Uses of Class javax.management.Notification

请注意：本 java api 1.7Beta 规范不是最终稳定版，未来随着版本的更迭，本规范可能有更新。
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.Notification

  • Packages that use Notification
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of Notification in javax.management

      Subclasses of Notification in javax.management
      修饰符与类型 类与描述
      class  AttributeChangeNotification
      Provides definitions of the attribute change notifications sent by MBeans.
      class  MBeanServerNotification
      Represents a notification emitted by the MBean Server through the MBeanServerDelegate MBean.
      Methods in javax.management with parameters of type Notification
      修饰符与类型 方法与描述
      protected void NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback)
      This method is called by sendNotification for each listener in order to send the notification to that listener.
      void NotificationListener.handleNotification(Notification notification, Object handback)
      Invoked when a JMX notification occurs.
      boolean AttributeChangeNotificationFilter.isNotificationEnabled(Notification notification)
      Invoked before sending the specified notification to the listener.
      boolean NotificationFilterSupport.isNotificationEnabled(Notification notification)
      Invoked before sending the specified notification to the listener.
      boolean NotificationFilter.isNotificationEnabled(Notification notification)
      Invoked before sending the specified notification to the listener.
      void StandardEmitterMBean.sendNotification(Notification n)
      Sends a notification.
      void MBeanServerDelegate.sendNotification(Notification notification)
      Enables the MBean server to send a notification.
      void NotificationBroadcasterSupport.sendNotification(Notification notification)
      Sends a notification.

    • Uses of Notification in javax.management.modelmbean

      Methods in javax.management.modelmbean with parameters of type Notification
      修饰符与类型 | 方法与描述
      void | RequiredModelMBean.sendNotification(Notification ntfyObj)
      void ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj)
      Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.

    • Uses of Notification in javax.management.monitor

      Subclasses of Notification in javax.management.monitor
      修饰符与类型 类与描述
      class  MonitorNotification
      Provides definitions of the notifications sent by monitor MBeans.

    • Uses of Notification in javax.management.relation

      Subclasses of Notification in javax.management.relation
      修饰符与类型 类与描述
      class  RelationNotification
      A notification of a change in the Relation Service.
      Methods in javax.management.relation with parameters of type Notification
      修饰符与类型 方法与描述
      void RelationService.handleNotification(Notification notif, Object handback)
      Invoked when a JMX notification occurs.
      boolean MBeanServerNotificationFilter.isNotificationEnabled(Notification notif)
      Invoked before sending the specified notification to the listener.

    • Uses of Notification in javax.management.remote

      Subclasses of Notification in javax.management.remote
      修饰符与类型 类与描述
      class  JMXConnectionNotification
      Notification emitted when a client connection is opened or closed or when notifications are lost.
      Methods in javax.management.remote that return Notification
      修饰符与类型 方法与描述
      Notification TargetedNotification.getNotification()
      The emitted notification.
      Constructors in javax.management.remote with parameters of type Notification
      构造方法与描述
      TargetedNotification(Notification notification, Integer listenerID)
      Constructs a TargetedNotification object.

    • Uses of Notification in javax.management.timer

      Subclasses of Notification in javax.management.timer
      修饰符与类型 类与描述
      class  TimerNotification
      This class provides definitions of the notifications sent by timer MBeans.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

encgp;d&>nnn<>cc/ etlgi[n//n


Uses of Class javax.management.NotificationBroadcasterSupport

  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.NotificationBroadcasterSupport

  • Packages that use NotificationBroadcasterSupport
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of NotificationBroadcasterSupport in javax.management.monitor

      Subclasses of NotificationBroadcasterSupport in javax.management.monitor
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  Monitor
      Defines the part common to all monitor MBeans.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.

    • Uses of NotificationBroadcasterSupport in javax.management.relation

      Subclasses of NotificationBroadcasterSupport in javax.management.relation
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

    • Uses of NotificationBroadcasterSupport in javax.management.remote

      Subclasses of NotificationBroadcasterSupport in javax.management.remote
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of NotificationBroadcasterSupport in javax.management.remote.rmi

      Subclasses of NotificationBroadcasterSupport in javax.management.remote.rmi
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.

    • Uses of NotificationBroadcasterSupport in javax.management.timer

      Subclasses of NotificationBroadcasterSupport in javax.management.timer
      修饰符与类型 类与描述
      class  Timer
      Provides the implementation of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fe= er


Uses of Class javax.management.NotificationFilterSupport

  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.NotificationFilterSupport

  • Packages that use NotificationFilterSupport
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of NotificationFilterSupport in javax.management.relation

      Subclasses of NotificationFilterSupport in javax.management.relation
      修饰符与类型 类与描述
      class  MBeanServerNotificationFilter
      Filter for MBeanServerNotification.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iaodt)"bOjjjn aarav.eot.ga


Uses of Class javax.management.ObjectInstance

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.ObjectInstance

  • Packages that use ObjectInstance
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of ObjectInstance in javax.management

      Methods in javax.management that return ObjectInstance
      修饰符与类型 | 方法与描述
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.getObjectInstance(ObjectName name)
      Gets the ObjectInstance for a given MBean registered with the MBean server.
      ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
      ObjectInstance MBeanServer.registerMBean(Object object, ObjectName name)
      Registers a pre-existing object as an MBean with the MBean server.
      Methods in javax.management that return types with arguments of type ObjectInstance
      修饰符与类型 方法与描述
      Set<ObjectInstance> MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.
      Set<ObjectInstance> MBeanServer.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.

    • Uses of ObjectInstance in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return ObjectInstance
      修饰符与类型 | 方法与描述
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      ObjectInstance | RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Methods in javax.management.remote.rmi that return types with arguments of type ObjectInstance
      修饰符与类型 | 方法与描述
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.ObjectName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.ObjectName

  • Packages that use ObjectName
    软件包 描述
    java.lang.management
    Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of ObjectName in java.lang.management

      Methods in java.lang.management that return ObjectName
      修饰符与类型 方法与描述
      ObjectName PlatformManagedObject.getObjectName()
      Returns an ObjectName instance representing the object name of this platform managed object.

    • Uses of ObjectName in javax.management

      Fields in javax.management declared as ObjectName
      修饰符与类型 字段与描述
      static ObjectName MBeanServerDelegate.DELEGATE_NAME
      Defines the default ObjectName of the MBeanServerDelegate.
      static ObjectName ObjectName.WILDCARD
      Defines the wildcard "*:*" ObjectName.
      Methods in javax.management that return ObjectName
      修饰符与类型 方法与描述
      static ObjectName ObjectName.getInstance(ObjectName name)
      Return an instance of ObjectName that can be used anywhere the given object can be used.
      static ObjectName ObjectName.getInstance(String name)
      Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used.
      static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
      Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used.
      static ObjectName ObjectName.getInstance(String domain, String key, String value)
      Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used.
      ObjectName MBeanServerNotification.getMBeanName()
      Returns the object name of the MBean that caused the notification.
      ObjectName MBeanServerInvocationHandler.getObjectName()
      The name of the MBean within the MBean server to which methods are forwarded.
      ObjectName ObjectInstance.getObjectName()
      Returns the object name part.
      ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.
      ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean Server.
      Methods in javax.management that return types with arguments of type ObjectName
      修饰符与类型 方法与描述
      Set<ObjectName> MBeanServerConnection.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
      Set<ObjectName> MBeanServer.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
      Methods in javax.management with parameters of type ObjectName
      修饰符与类型 | 方法与描述
      void MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      ValueExp StringValueExp.apply(ObjectName name)
      Applies the ValueExp on a MBean.
      ValueExp AttributeValueExp.apply(ObjectName name)
      Applies the AttributeValueExp on an MBean.
      ValueExp ValueExp.apply(ObjectName name)
      Applies the ValueExp on a MBean.
      boolean QueryExp.apply(ObjectName name)
      Applies the QueryExp on an MBean.
      boolean ObjectName.apply(ObjectName name)
      Test whether this ObjectName, which may be a pattern, matches another ObjectName.
      int ObjectName.compareTo(ObjectName name)
      Compares two ObjectName instances.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
      Deprecated.
      Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
      ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
      Deprecated.
      Use getClassLoader to obtain the class loader for deserialization.
      protected Object AttributeValueExp.getAttribute(ObjectName name)
      Return the value of the given attribute in the named MBean.
      Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
      Gets the value of a specific attribute of a named MBean.
      Object | MBeanServer.getAttribute(ObjectName name, String attribute)
      AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
      Retrieves the values of several attributes of a named MBean.
      AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
      ClassLoader MBeanServer.getClassLoader(ObjectName loaderName)
      Return the named ClassLoader.
      ClassLoader MBeanServer.getClassLoaderFor(ObjectName mbeanName)
      Return the ClassLoader that was used for loading the class of the named MBean.
      static ObjectName ObjectName.getInstance(ObjectName name)
      Return an instance of ObjectName that can be used anywhere the given object can be used.
      MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
      This method discovers the attributes and operations that an MBean exposes for management.
      MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
      ObjectInstance MBeanServerConnection.getObjectInstance(ObjectName name)
      Gets the ObjectInstance for a given MBean registered with the MBean server.
      ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
      Object MBeanServer.instantiate(String className, ObjectName loaderName)
      Instantiates an object using the class Loader specified by its ObjectName.
      Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates an object.
      Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
      Invokes an operation on an MBean.
      Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
      boolean MBeanServerConnection.isInstanceOf(ObjectName name, String className)
      Returns true if the MBean specified is an instance of the specified class, false otherwise.
      boolean | MBeanServer.isInstanceOf(ObjectName name, String className)
      boolean MBeanServerConnection.isRegistered(ObjectName name)
      Checks whether an MBean, identified by its object name, is already registered with the MBean server.
      boolean | MBeanServer.isRegistered(ObjectName name)
      static <T> T JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass)
      Make a proxy for a Standard MBean in a local or remote MBean Server.
      static <T> T JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationEmitter)
      Make a proxy for a Standard MBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
      static <T> T JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass)
      Make a proxy for an MXBean in a local or remote MBean Server.
      static <T> T JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationEmitter)
      Make a proxy for an MXBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
      static <T> T MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationBroadcaster)
      Return a proxy that implements the given interface by forwarding its methods through the given MBean server to the named MBean.
      ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.
      ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean Server.
      Set<ObjectInstance> MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.
      Set<ObjectInstance> MBeanServer.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.
      Set<ObjectName> MBeanServerConnection.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
      Set<ObjectName> MBeanServer.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
      ObjectInstance MBeanServer.registerMBean(Object object, ObjectName name)
      Registers a pre-existing object as an MBean with the MBean server.
      void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
      void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
      void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
      Sets the value of a specific attribute of a named MBean.
      void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
      AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
      Sets the values of several attributes of a named MBean.
      AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
      void MBeanServerConnection.unregisterMBean(ObjectName name)
      Unregisters an MBean from the MBean server.
      void MBeanServer.unregisterMBean(ObjectName name)
      Unregisters an MBean from the MBean server.
      Constructors in javax.management with parameters of type ObjectName
      构造方法与描述
      MBeanPermission(String className, String member, ObjectName objectName, String actions)
      Create a new MBeanPermission object with the specified target name (class name, member, object name) and actions.
      MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
      Invocation handler that forwards methods through an MBean server to a Standard MBean.
      MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
      Invocation handler that can forward methods through an MBean server to a Standard MBean or MXBean.
      MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
      Creates an MBeanServerNotification object specifying object names of the MBeans that caused the notification and the specified notification type.
      ObjectInstance(ObjectName objectName, String className)
      Allows an object instance to be created given an object name and the full class name, including the package name.

    • Uses of ObjectName in javax.management.loading

      Methods in javax.management.loading that return ObjectName
      修饰符与类型 方法与描述
      ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
      Allows the m-let to perform any operations it needs before being registered in the MBean server.
      Methods in javax.management.loading with parameters of type ObjectName
      修饰符与类型 方法与描述
      ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
      Allows the m-let to perform any operations it needs before being registered in the MBean server.

    • Uses of ObjectName in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ObjectName
      修饰符与类型 方法与描述
      ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.
      Methods in javax.management.modelmbean with parameters of type ObjectName
      修饰符与类型 方法与描述
      ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.

    • Uses of ObjectName in javax.management.monitor

      Methods in javax.management.monitor that return ObjectName
      修饰符与类型 方法与描述
      ObjectName MonitorMBean.getObservedObject()
      Deprecated.
      As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()
      ObjectName Monitor.getObservedObject()
      Deprecated.
      As of JMX 1.2, replaced by Monitor.getObservedObjects()
      ObjectName MonitorNotification.getObservedObject()
      Gets the observed object of this monitor notification.
      ObjectName[] MonitorMBean.getObservedObjects()
      Returns an array containing the objects being observed.
      ObjectName[] Monitor.getObservedObjects()
      Returns an array containing the objects being observed.
      ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
      Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.
      Methods in javax.management.monitor with parameters of type ObjectName
      修饰符与类型 方法与描述
      void MonitorMBean.addObservedObject(ObjectName object)
      Adds the specified object in the set of observed MBeans.
      void Monitor.addObservedObject(ObjectName object)
      Adds the specified object in the set of observed MBeans, if this object is not already present.
      boolean MonitorMBean.containsObservedObject(ObjectName object)
      Tests whether the specified object is in the set of observed MBeans.
      boolean Monitor.containsObservedObject(ObjectName object)
      Tests whether the specified object is in the set of observed MBeans.
      String StringMonitorMBean.getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      String StringMonitor.getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      Number GaugeMonitorMBean.getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      Number GaugeMonitor.getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      Number CounterMonitorMBean.getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      Number CounterMonitor.getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      long StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      long StringMonitor.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      long GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      long GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      long CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      long CounterMonitor.getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      Number CounterMonitorMBean.getThreshold(ObjectName object)
      Gets the threshold value for the specified MBean.
      Number CounterMonitor.getThreshold(ObjectName object)
      Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
      Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.
      void MonitorMBean.removeObservedObject(ObjectName object)
      Removes the specified object from the set of observed MBeans.
      void Monitor.removeObservedObject(ObjectName object)
      Removes the specified object from the set of observed MBeans.
      void MonitorMBean.setObservedObject(ObjectName object)
      Deprecated.
      As of JMX 1.2, replaced by MonitorMBean.addObservedObject(javax.management.ObjectName)
      void Monitor.setObservedObject(ObjectName object)
      Deprecated.
      As of JMX 1.2, replaced by Monitor.addObservedObject(javax.management.ObjectName)

    • Uses of ObjectName in javax.management.openmbean

      Fields in javax.management.openmbean with type parameters of type ObjectName
      修饰符与类型 字段与描述
      static SimpleType<ObjectName> SimpleType.OBJECTNAME
      The SimpleType instance describing values whose Java class name is javax.management.ObjectName.

    • Uses of ObjectName in javax.management.relation

      Methods in javax.management.relation that return ObjectName
      修饰符与类型 | 方法与描述
      ObjectName RelationNotification.getObjectName()
      Returns the ObjectName of the created/removed/updated relation.
      ObjectName RelationSupport.getRelationServiceName()
      Returns ObjectName of the Relation Service handling the relation.
      ObjectName Relation.getRelationServiceName()
      Returns ObjectName of the Relation Service handling the relation.
      ObjectName RelationServiceMBean.isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      ObjectName RelationService.isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)
      ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
      Methods in javax.management.relation that return types with arguments of type ObjectName
      修饰符与类型 方法与描述
      Map<ObjectName,List<String>> RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Map<ObjectName,List<String>> RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Vector<ObjectName> MBeanServerNotificationFilter.getDisabledObjectNames()
      Gets all the ObjectNames disabled.
      Vector<ObjectName> MBeanServerNotificationFilter.getEnabledObjectNames()
      Gets all the ObjectNames enabled.
      List<ObjectName> RelationNotification.getMBeansToUnregister()
      Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).
      List<ObjectName> RelationNotification.getNewRoleValue()
      Returns new value of updated role (only for role update).
      List<ObjectName> RelationNotification.getOldRoleValue()
      Returns old value of updated role (only for role update).
      Map<ObjectName,List<String>> RelationSupport.getReferencedMBeans()
      Retrieves MBeans referenced in the various roles of the relation.
      Map<ObjectName,List<String>> Relation.getReferencedMBeans()
      Retrieves MBeans referenced in the various roles of the relation.
      Map<ObjectName,List<String>> RelationServiceMBean.getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      Map<ObjectName,List<String>> RelationService.getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      List<ObjectName> RelationSupport.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> Relation.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> RelationServiceMBean.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      List<ObjectName> RelationService.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      List<ObjectName> RoleUnresolved.getRoleValue()
      Retrieves role value.
      List<ObjectName> Role.getRoleValue()
      Retrieves role value.
      Methods in javax.management.relation with parameters of type ObjectName
      修饰符与类型 | 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void MBeanServerNotificationFilter.disableObjectName(ObjectName objectName)
      Disables MBeanServerNotifications concerning given ObjectName.
      void MBeanServerNotificationFilter.enableObjectName(ObjectName objectName)
      Enables MBeanServerNotifications concerning given ObjectName.
      Map<ObjectName,List<String>> RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Map<ObjectName,List<String>> RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Map<String,List<String>> RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the relations where a given MBean is referenced.
      Map<String,List<String>> RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the relations where a given MBean is referenced.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      String RelationServiceMBean.isRelation(ObjectName objectName)
      Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
      String RelationService.isRelation(ObjectName objectName)
      Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
      ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)
      ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
      Method parameters in javax.management.relation with type arguments of type ObjectName
      修饰符与类型 方法与描述
      static String Role.roleValueToString(List<ObjectName> roleValue)
      Returns a string for the given role value.
      void RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RoleUnresolved.setRoleValue(List<ObjectName> value)
      Sets role value.
      void Role.setRoleValue(List<ObjectName> roleValue)
      Sets role value.
      void RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      void RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      Constructors in javax.management.relation with parameters of type ObjectName
      构造方法与描述
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
      Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      Creates a notification for a role update in a relation.
      RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      Constructor parameters in javax.management.relation with type arguments of type ObjectName
      构造方法与描述
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
      Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      Creates a notification for a role update in a relation.
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      Creates a notification for a role update in a relation.
      Role(String roleName, List<ObjectName> roleValue)
      Make a new Role object.
      RoleUnresolved(String name, List<ObjectName> value, int pbType)
      Constructor.

    • Uses of ObjectName in javax.management.remote

      Methods in javax.management.remote that return ObjectName
      修饰符与类型 方法与描述
      ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
      Called by an MBean server when this connector server is registered in that MBean server.
      Methods in javax.management.remote with parameters of type ObjectName
      修饰符与类型 方法与描述
      ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
      Called by an MBean server when this connector server is registered in that MBean server.

    • Uses of ObjectName in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return types with arguments of type ObjectName
      修饰符与类型 | 方法与描述
      Set<ObjectName> | RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      Methods in javax.management.remote.rmi with parameters of type ObjectName
      修饰符与类型 | 方法与描述
      void | RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      Integer[] | RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Integer[] | RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      Object | RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Object | RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList | RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      MBeanInfo | RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      MBeanInfo | RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
      MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      ObjectInstance | RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Object | RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Object | RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      boolean | RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      boolean | RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
      boolean | RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      boolean | RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
      boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.isRegistered(ObjectName).
      Set | RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
      Set | RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectName> | RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      void | RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      void | RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
      void | RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
      void | RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList | RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
      void | RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      void | RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
      void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.unregisterMBean(ObjectName).

    • Uses of ObjectName in javax.management.timer

      Methods in javax.management.timer that return ObjectName
      修饰符与类型 方法与描述
      ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
      Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
      Methods in javax.management.timer with parameters of type ObjectName
      修饰符与类型 方法与描述
      ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
      Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.OperationsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.OperationsException

  • Packages that use OperationsException
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of OperationsException in javax.management

      Subclasses of OperationsException in javax.management
      修饰符与类型 类与描述
      class  AttributeNotFoundException
      The specified attribute does not exist or cannot be retrieved.
      class  InstanceAlreadyExistsException
      The MBean is already registered in the repository.
      class  InstanceNotFoundException
      The specified MBean does not exist in the repository.
      class  IntrospectionException
      An exception occurred during the introspection of an MBean.
      class  InvalidAttributeValueException
      The value specified is not valid for the attribute.
      class  ListenerNotFoundException
      The specified MBean listener does not exist in the repository.
      class  MalformedObjectNameException
      The format of the string does not correspond to a valid ObjectName.
      class  NotCompliantMBeanException
      Exception which occurs when trying to register an object in the MBean server that is not a JMX compliant MBean.
      class  ServiceNotFoundException
      Represents exceptions raised when a requested service is not supported.
      Methods in javax.management that throw OperationsException
      修饰符与类型 方法与描述
      ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
      Deprecated.
      Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
      ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
      Deprecated.
      Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
      ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
      Deprecated.
      Use getClassLoader to obtain the class loader for deserialization.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>sa


Uses of Class javax.management.Query

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.Query

No usage of javax.management.Query
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x=/.f=" ahhhtiaanaxenm


Uses of Class javax.management.QueryEval

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.QueryEval

No usage of javax.management.QueryEval
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tl/0gat>txe;>exmvnN


Uses of Class javax.management.ReflectionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.ReflectionException

  • Packages that use ReflectionException
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of ReflectionException in javax.management

      Methods in javax.management that throw ReflectionException
      修饰符与类型 | 方法与描述
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates and registers an MBean in the MBean server.
      ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
      Deprecated.
      Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
      ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
      Deprecated.
      Use getClassLoader to obtain the class loader for deserialization.
      Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
      Gets the value of a specific attribute of a named MBean.
      Object | MBeanServer.getAttribute(ObjectName name, String attribute)
      Object DynamicMBean.getAttribute(String attribute)
      Obtain the value of a specific attribute of the Dynamic MBean.
      Object | StandardMBean.getAttribute(String attribute)
      AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
      Retrieves the values of several attributes of a named MBean.
      AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
      MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
      This method discovers the attributes and operations that an MBean exposes for management.
      MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
      Object MBeanServer.instantiate(String className)
      Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository.
      Object MBeanServer.instantiate(String className, Object[] params, String[] signature)
      Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository.
      Object MBeanServer.instantiate(String className, ObjectName loaderName)
      Instantiates an object using the class Loader specified by its ObjectName.
      Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
      Instantiates an object.
      Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
      Invokes an operation on an MBean.
      Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
      Object DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
      Allows an action to be invoked on the Dynamic MBean.
      Object | StandardMBean.invoke(String actionName, Object[] params, String[] signature)
      void DynamicMBean.setAttribute(Attribute attribute)
      Set the value of a specific attribute of the Dynamic MBean.
      void | StandardMBean.setAttribute(Attribute attribute)
      void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
      Sets the value of a specific attribute of a named MBean.
      void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
      AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
      Sets the values of several attributes of a named MBean.
      AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)

    • Uses of ReflectionException in javax.management.modelmbean

      Methods in javax.management.modelmbean that throw ReflectionException
      修饰符与类型 方法与描述
      Object RequiredModelMBean.getAttribute(String attrName)
      Returns the value of a specific attribute defined for this ModelMBean.
      Object RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
      Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
      void RequiredModelMBean.setAttribute(Attribute attribute)
      Sets the value of a specific attribute of a named ModelMBean.

    • Uses of ReflectionException in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that throw ReflectionException
      修饰符与类型 | 方法与描述
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      Object | RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Object | RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList | RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      MBeanInfo | RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      MBeanInfo | RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
      MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      Object | RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Object | RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      void | RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList | RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lNtj.uns


Uses of Class javax.management.RuntimeErrorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.RuntimeErrorException

No usage of javax.management.RuntimeErrorException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alvaml#no...cveeooeopM


Uses of Class javax.management.RuntimeMBeanException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.RuntimeMBeanException

No usage of javax.management.RuntimeMBeanException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c > oal#eve竐�


Uses of Class javax.management.RuntimeOperationsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.RuntimeOperationsException

  • Packages that use RuntimeOperationsException
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of RuntimeOperationsException in javax.management

      Methods in javax.management that throw RuntimeOperationsException
      修饰符与类型 方法与描述
      Object Descriptor.clone()
      Returns a descriptor which is equal to this descriptor.
      Object Descriptor.getFieldValue(String fieldName)
      Returns the value for a specific field name, or null if no value is present for that name.
      boolean Descriptor.isValid()
      Returns true if all of the fields have legal values given their names.
      void PersistentMBean.load()
      Instantiates thisMBean instance with the data found for the MBean in the persistent store.
      void Descriptor.setField(String fieldName, Object fieldValue)
      Sets the value for a specific field name.
      void ImmutableDescriptor.setField(String fieldName, Object fieldValue)
      This operation is unsupported since this class is immutable.
      void Descriptor.setFields(String[] fieldNames, Object[] fieldValues)
      Sets all fields in the field names array to the new value with the same index in the field values array.
      void ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues)
      This operation is unsupported since this class is immutable.
      void PersistentMBean.store()
      Captures the current state of this MBean instance and writes it out to the persistent store.

    • Uses of RuntimeOperationsException in javax.management.modelmbean

      Methods in javax.management.modelmbean that throw RuntimeOperationsException
      修饰符与类型 | 方法与描述
      void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
      void ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      Object DescriptorSupport.clone()
      Returns a new Descriptor which is a duplicate of the Descriptor.
      ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
      ModelMBeanAttributeInfo ModelMBeanInfo.getAttribute(String inName)
      Returns a ModelMBeanAttributeInfo requested by name.
      ModelMBeanConstructorInfo ModelMBeanInfoSupport.getConstructor(String inName)
      Returns the ModelMBeanConstructorInfo requested by name.
      Descriptor ModelMBeanInfoSupport.getDescriptor(String inDescriptorName)
      Returns a Descriptor requested by name.
      Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
      Descriptor ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType)
      Returns a Descriptor requested by name and descriptorType.
      Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
      Descriptor[] ModelMBeanInfo.getDescriptors(String inDescriptorType)
      Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
      Object | DescriptorSupport.getFieldValue(String fieldName)
      Descriptor ModelMBeanInfo.getMBeanDescriptor()
      Returns the ModelMBean's descriptor which contains MBean wide policies.
      ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
      ModelMBeanNotificationInfo ModelMBeanInfo.getNotification(String inName)
      Returns a ModelMBeanNotificationInfo requested by name.
      ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
      ModelMBeanOperationInfo ModelMBeanInfo.getOperation(String inName)
      Returns a ModelMBeanOperationInfo requested by name.
      boolean DescriptorSupport.isValid()
      Returns true if all of the fields have legal values given their names.
      void RequiredModelMBean.load()
      Instantiates this MBean instance with the data found for the MBean in the persistent store.
      void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
      void ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName)
      Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
      void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
      void ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue)
      Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.
      void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
      void ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification)
      Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
      void | RequiredModelMBean.sendNotification(Notification ntfyObj)
      void ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj)
      Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
      void | RequiredModelMBean.sendNotification(String ntfyText)
      void ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText)
      Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
      void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      void ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
      void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
      void ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors)
      Adds or replaces descriptors in the ModelMBeanInfo.
      void | DescriptorSupport.setField(String fieldName, Object fieldValue)
      void | DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)
      void RequiredModelMBean.setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
      void ModelMBean.setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
      void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
      void ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor)
      Sets the ModelMBean's descriptor.
      void RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.
      void ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.
      void RequiredModelMBean.store()
      Captures the current state of this MBean instance and writes it out to the persistent store.
      Constructors in javax.management.modelmbean that throw RuntimeOperationsException
      构造方法与描述
      DescriptorSupport(int initNumFields)
      Descriptor constructor.
      DescriptorSupport(String inStr)
      Descriptor constructor taking an XML String.
      DescriptorSupport(String[] fieldNames, Object[] fieldValues)
      Constructor taking field names and field values.
      RequiredModelMBean()
      Constructs an RequiredModelMBean with an empty ModelMBeanInfo.
      RequiredModelMBean(ModelMBeanInfo mbi)
      Constructs a RequiredModelMBean object using ModelMBeanInfo passed in.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n


Uses of Class javax.management.ServiceNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.ServiceNotFoundException

  • Packages that use ServiceNotFoundException
    软件包 描述
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.

    • Uses of ServiceNotFoundException in javax.management.loading

      Methods in javax.management.loading that throw ServiceNotFoundException
      修饰符与类型 方法与描述
      void MLetMBean.addURL(String url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      void MLet.addURL(String url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      Set<Object> MLetMBean.getMBeansFromURL(String url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      Set<Object> MLet.getMBeansFromURL(String url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      Set<Object> MLetMBean.getMBeansFromURL(URL url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      Set<Object> MLet.getMBeansFromURL(URL url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e na..//....=(//tel,ancbl/


Uses of Class javax.management.StandardEmitterMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.StandardEmitterMBean

No usage of javax.management.StandardEmitterMBean
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nog/./j./..."


Uses of Class javax.management.StandardMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.StandardMBean

  • Packages that use StandardMBean
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of StandardMBean in javax.management

      Subclasses of StandardMBean in javax.management
      修饰符与类型 类与描述
      class  StandardEmitterMBean
      An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lsia-rLuenaori)M/ r.dan>a


Uses of Class javax.management.StringValueExp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.StringValueExp

  • Packages that use StringValueExp
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of StringValueExp in javax.management

      Methods in javax.management that return StringValueExp
      修饰符与类型 方法与描述
      static StringValueExp Query.value(String val)
      Returns a new string expression.
      Methods in javax.management with parameters of type StringValueExp
      修饰符与类型 方法与描述
      static QueryExp Query.anySubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.finalSubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.initialSubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.isInstanceOf(StringValueExp classNameValue)
      Returns a query expression that represents an inheritance constraint on an MBean class.
      static QueryExp Query.match(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s. =l-eetamjEi� tnnSltl


Uses of Interface javax.management.Descriptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.Descriptor

  • Packages that use Descriptor
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of Descriptor in javax.management

      Classes in javax.management that implement Descriptor
      修饰符与类型 类与描述
      class  ImmutableDescriptor
      An immutable descriptor.
      Methods in javax.management that return Descriptor
      修饰符与类型 方法与描述
      Descriptor ImmutableDescriptor.clone()
      Returns a descriptor which is equal to this descriptor.
      Descriptor MBeanFeatureInfo.getDescriptor()
      Returns the descriptor for the feature.
      Descriptor DescriptorRead.getDescriptor()
      Returns a copy of Descriptor.
      Descriptor MBeanInfo.getDescriptor()
      Get the descriptor of this MBeanInfo.
      Methods in javax.management with parameters of type Descriptor
      修饰符与类型 方法与描述
      void DescriptorAccess.setDescriptor(Descriptor inDescriptor)
      Sets Descriptor (full replace).
      static ImmutableDescriptor ImmutableDescriptor.union(Descriptor... descriptors)
      Return an ImmutableDescriptor whose contents are the union of the given descriptors.
      Constructors in javax.management with parameters of type Descriptor
      构造方法与描述
      MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs an MBeanAttributeInfo object.
      MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs an MBeanConstructorInfo object.
      MBeanFeatureInfo(String name, String description, Descriptor descriptor)
      Constructs an MBeanFeatureInfo object.
      MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an MBeanInfo.
      MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
      Constructs an MBeanNotificationInfo object.
      MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
      Constructs an MBeanOperationInfo object.
      MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
      Constructs an MBeanParameterInfo object.

    • Uses of Descriptor in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement Descriptor
      修饰符与类型 类与描述
      class  DescriptorSupport
      This class represents the metadata set for a ModelMBean element.
      Methods in javax.management.modelmbean that return Descriptor
      修饰符与类型 | 方法与描述
      Descriptor | ModelMBeanInfoSupport.getDescriptor()
      Descriptor ModelMBeanConstructorInfo.getDescriptor()
      Returns a copy of the associated Descriptor.
      Descriptor ModelMBeanNotificationInfo.getDescriptor()
      Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.
      Descriptor ModelMBeanOperationInfo.getDescriptor()
      Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.
      Descriptor ModelMBeanAttributeInfo.getDescriptor()
      Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.
      Descriptor ModelMBeanInfoSupport.getDescriptor(String inDescriptorName)
      Returns a Descriptor requested by name.
      Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
      Descriptor ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType)
      Returns a Descriptor requested by name and descriptorType.
      Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
      Descriptor[] ModelMBeanInfo.getDescriptors(String inDescriptorType)
      Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
      Descriptor | ModelMBeanInfoSupport.getMBeanDescriptor()
      Descriptor ModelMBeanInfo.getMBeanDescriptor()
      Returns the ModelMBean's descriptor which contains MBean wide policies.
      Methods in javax.management.modelmbean with parameters of type Descriptor
      修饰符与类型 | 方法与描述
      void ModelMBeanConstructorInfo.setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo.
      void ModelMBeanNotificationInfo.setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
      void ModelMBeanOperationInfo.setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
      void ModelMBeanAttributeInfo.setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor.
      void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      void ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
      void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
      void ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors)
      Adds or replaces descriptors in the ModelMBeanInfo.
      void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
      void ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor)
      Sets the ModelMBean's descriptor.
      Constructors in javax.management.modelmbean with parameters of type Descriptor
      构造方法与描述
      ModelMBeanAttributeInfo(String name, String description, 方法 getter, 方法 setter, Descriptor descriptor)
      Constructs a ModelMBeanAttributeInfo object.
      ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs a ModelMBeanAttributeInfo object.
      ModelMBeanConstructorInfo(String description, Constructor<?> constructorMethod, Descriptor descriptor)
      Constructs a ModelMBeanConstructorInfo object.
      ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs a ModelMBeanConstructorInfo object.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
      ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
      Constructs a ModelMBeanNotificationInfo object.
      ModelMBeanOperationInfo(String description, 方法 operationMethod, Descriptor descriptor)
      Constructs a ModelMBeanOperationInfo object.
      ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
      Constructs a ModelMBeanOperationInfo object.

    • Uses of Descriptor in javax.management.openmbean

      Constructors in javax.management.openmbean with parameters of type Descriptor
      构造方法与描述
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, read/write access properties, and Descriptor.
      OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述, signature, and descriptor.
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType, impact, and descriptor.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, and descriptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.management.DescriptorAccess

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.DescriptorAccess

  • Packages that use DescriptorAccess
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of DescriptorAccess in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement DescriptorAccess
      修饰符与类型 类与描述
      class  ModelMBeanAttributeInfo
      The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
      class  ModelMBeanConstructorInfo
      The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
      class  ModelMBeanNotificationInfo
      The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
      class  ModelMBeanOperationInfo
      The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dae/gemm/aaav.</


Uses of Interface javax.management.DescriptorRead

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.DescriptorRead

  • Packages that use DescriptorRead
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of DescriptorRead in javax.management

      Subinterfaces of DescriptorRead in javax.management
      修饰符与类型 Interface and Description
      interface  DescriptorAccess
      This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e.
      Classes in javax.management that implement DescriptorRead
      修饰符与类型 类与描述
      class  MBeanAttributeInfo
      Describes an MBean attribute exposed for management.
      class  MBeanConstructorInfo
      Describes a constructor exposed by an MBean.
      class  MBeanFeatureInfo
      Provides general information for an MBean descriptor object.
      class  MBeanInfo
      Describes the management interface exposed by an MBean; that is, the set of attributes and operations which are available for management operations.
      class  MBeanNotificationInfo
      The MBeanNotificationInfo class is used to describe the characteristics of the different notification instances emitted by an MBean, for a given Java class of notification.
      class  MBeanOperationInfo
      Describes a management operation exposed by an MBean.
      class  MBeanParameterInfo
      Describes an argument of an operation exposed by an MBean.

    • Uses of DescriptorRead in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement DescriptorRead
      修饰符与类型 类与描述
      class  ModelMBeanAttributeInfo
      The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
      class  ModelMBeanConstructorInfo
      The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
      class  ModelMBeanInfoSupport
      This class represents the meta data for ModelMBeans.
      class  ModelMBeanNotificationInfo
      The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
      class  ModelMBeanOperationInfo
      The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.

    • Uses of DescriptorRead in javax.management.openmbean

      Classes in javax.management.openmbean that implement DescriptorRead
      修饰符与类型 类与描述
      class  OpenMBeanAttributeInfoSupport
      Describes an attribute of an open MBean.
      class  OpenMBeanConstructorInfoSupport
      Describes a constructor of an Open MBean.
      class  OpenMBeanInfoSupport
      The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface.
      class  OpenMBeanOperationInfoSupport
      Describes an operation of an Open MBean.
      class  OpenMBeanParameterInfoSupport
      Describes a parameter used in one or more operations or constructors of an open MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nh =Ettem jbS/tna/ca鑛_


Uses of Interface javax.management.DynamicMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.DynamicMBean

  • Packages that use DynamicMBean
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of DynamicMBean in javax.management

      Classes in javax.management that implement DynamicMBean
      修饰符与类型 类与描述
      class  StandardEmitterMBean
      An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.
      class  StandardMBean
      An MBean whose management interface is determined by reflection on a Java interface.

    • Uses of DynamicMBean in javax.management.modelmbean

      Subinterfaces of DynamicMBean in javax.management.modelmbean
      修饰符与类型 Interface and Description
      interface  ModelMBean
      This interface must be implemented by the ModelMBeans.
      Classes in javax.management.modelmbean that implement DynamicMBean
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otrnelM>"MMMe.xxeav/eoC/gl


Uses of Interface javax.management.MBeanRegistration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.MBeanRegistration

  • Packages that use MBeanRegistration
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of MBeanRegistration in javax.management

      Classes in javax.management that implement MBeanRegistration
      修饰符与类型 类与描述
      class  StandardEmitterMBean
      An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.
      class  StandardMBean
      An MBean whose management interface is determined by reflection on a Java interface.

    • Uses of MBeanRegistration in javax.management.loading

      Classes in javax.management.loading that implement MBeanRegistration
      修饰符与类型 类与描述
      class  MLet
      Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
      class  PrivateMLet
      An MLet that is not added to the ClassLoaderRepository.

    • Uses of MBeanRegistration in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement MBeanRegistration
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.

    • Uses of MBeanRegistration in javax.management.monitor

      Classes in javax.management.monitor that implement MBeanRegistration
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  Monitor
      Defines the part common to all monitor MBeans.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.

    • Uses of MBeanRegistration in javax.management.relation

      Classes in javax.management.relation that implement MBeanRegistration
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
      class  RelationSupport
      A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.

    • Uses of MBeanRegistration in javax.management.remote

      Classes in javax.management.remote that implement MBeanRegistration
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of MBeanRegistration in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement MBeanRegistration
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.

    • Uses of MBeanRegistration in javax.management.timer

      Classes in javax.management.timer that implement MBeanRegistration
      修饰符与类型 类与描述
      class  Timer
      Provides the implementation of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.management.MBeanServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.MBeanServer

  • Packages that use MBeanServer
    软件包 描述
    java.lang.management
    Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of MBeanServer in java.lang.management

      Methods in java.lang.management that return MBeanServer
      修饰符与类型 方法与描述
      static MBeanServer ManagementFactory.getPlatformMBeanServer()
      Returns the platform MBeanServer.

    • Uses of MBeanServer in javax.management

      Methods in javax.management that return MBeanServer
      修饰符与类型 方法与描述
      static MBeanServer MBeanServerFactory.createMBeanServer()
      Return a new object implementing the MBeanServer interface with a standard default domain name.
      static MBeanServer MBeanServerFactory.createMBeanServer(String domain)
      Return a new object implementing the MBeanServer interface with the specified default domain name.
      static MBeanServer QueryEval.getMBeanServer()
      Return the MBean server that was most recently given to the setMBeanServer method by this thread.
      static MBeanServer MBeanServerFactory.newMBeanServer()
      Return a new object implementing the MBeanServer interface with a standard default domain name, without keeping an internal reference to this new object.
      static MBeanServer MBeanServerFactory.newMBeanServer(String domain)
      Return a new object implementing the MBeanServer interface with the specified default domain name, without keeping an internal reference to this new object.
      MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
      This method creates a new MBeanServer implementation object.
      Methods in javax.management that return types with arguments of type MBeanServer
      修饰符与类型 方法与描述
      static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer(String agentId)
      Return a list of registered MBeanServer objects.
      Methods in javax.management with parameters of type MBeanServer
      修饰符与类型 | 方法与描述
      static ClassLoaderRepository MBeanServerFactory.getClassLoaderRepository(MBeanServer server)
      Return the ClassLoaderRepository used by the given MBeanServer.
      MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
      This method creates a new MBeanServer implementation object.
      ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.
      ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean Server.
      static void MBeanServerFactory.releaseMBeanServer(MBeanServer mbeanServer)
      Remove internal MBeanServerFactory references to a created MBeanServer.
      void StringValueExp.setMBeanServer(MBeanServer s)
      Deprecated.
      void AttributeValueExp.setMBeanServer(MBeanServer s)
      Deprecated.
      This method has no effect. The MBean Server used to obtain an attribute value is QueryEval.getMBeanServer().
      void QueryEval.setMBeanServer(MBeanServer s)
      Sets the MBean server on which the query is to be performed.
      void ValueExp.setMBeanServer(MBeanServer s)
      Deprecated.
      This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().
      void QueryExp.setMBeanServer(MBeanServer s)
      Sets the MBean server on which the query is to be performed.
      void | ObjectName.setMBeanServer(MBeanServer mbs)

    • Uses of MBeanServer in javax.management.loading

      Methods in javax.management.loading with parameters of type MBeanServer
      修饰符与类型 方法与描述
      ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
      Allows the m-let to perform any operations it needs before being registered in the MBean server.

    • Uses of MBeanServer in javax.management.modelmbean

      Methods in javax.management.modelmbean with parameters of type MBeanServer
      修饰符与类型 方法与描述
      ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.

    • Uses of MBeanServer in javax.management.monitor

      Fields in javax.management.monitor declared as MBeanServer
      修饰符与类型 字段与描述
      protected MBeanServer Monitor.server
      Reference to the MBean server.
      Methods in javax.management.monitor with parameters of type MBeanServer
      修饰符与类型 方法与描述
      ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
      Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.

    • Uses of MBeanServer in javax.management.relation

      Methods in javax.management.relation with parameters of type MBeanServer
      修饰符与类型 | 方法与描述
      ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)
      ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
      Constructors in javax.management.relation with parameters of type MBeanServer
      构造方法与描述
      RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      Creates a RelationSupport object.

    • Uses of MBeanServer in javax.management.remote

      Subinterfaces of MBeanServer in javax.management.remote
      修饰符与类型 Interface and Description
      interface  MBeanServerForwarder
      An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
      Methods in javax.management.remote that return MBeanServer
      修饰符与类型 方法与描述
      MBeanServer MBeanServerForwarder.getMBeanServer()
      Returns the MBeanServer object to which requests will be forwarded.
      MBeanServer JMXConnectorServer.getMBeanServer()
      Returns the MBean server that this connector server is attached to.
      Methods in javax.management.remote with parameters of type MBeanServer
      修饰符与类型 方法与描述
      JMXConnectorServer JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a new connector server at the given address.
      static JMXConnectorServer JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a connector server at the given address.
      ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
      Called by an MBean server when this connector server is registered in that MBean server.
      void MBeanServerForwarder.setMBeanServer(MBeanServer mbs)
      Sets the MBeanServer object to which requests will be forwarded after treatment by this object.
      Constructors in javax.management.remote with parameters of type MBeanServer
      构造方法与描述
      JMXConnectorServer(MBeanServer mbeanServer)
      Constructs a connector server that is attached to the given MBean server.

    • Uses of MBeanServer in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return MBeanServer
      修饰符与类型 方法与描述
      MBeanServer RMIServerImpl.getMBeanServer()
      The MBeanServer to which this connector server is attached.
      Methods in javax.management.remote.rmi with parameters of type MBeanServer
      修饰符与类型 方法与描述
      void RMIServerImpl.setMBeanServer(MBeanServer mbs)
      Sets the MBeanServer to which this connector server is attached.
      Constructors in javax.management.remote.rmi with parameters of type MBeanServer
      构造方法与描述
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.

    • Uses of MBeanServer in javax.management.timer

      Methods in javax.management.timer with parameters of type MBeanServer
      修饰符与类型 方法与描述
      ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
      Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.management.MBeanServerConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.MBeanServerConnection

  • Packages that use MBeanServerConnection
    软件包 描述
    java.lang.management
    Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of MBeanServerConnection in java.lang.management

      Methods in java.lang.management with parameters of type MBeanServerConnection
      修饰符与类型 方法与描述
      static <T extends PlatformManagedObject>
      T             		ManagementFactory.getPlatformMXBean(MBeanServerConnection connection, 类<T> mxbeanInterface)
      Returns the platform MXBean proxy for mxbeanInterface which is specified to have one single instance in a Java virtual machine and the proxy will forward the method calls through the given MBeanServerConnection.
      static <T extends PlatformManagedObject>
      List<T>             		ManagementFactory.getPlatformMXBeans(MBeanServerConnection connection, 类<T> mxbeanInterface)
      Returns the list of the platform MXBean proxies for forwarding the method calls of the mxbeanInterface through the given MBeanServerConnection.
      static <T> T ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, 类<T> mxbeanInterface)
      Returns a proxy for a platform MXBean interface of a given MXBean name that forwards its method calls through the given MBeanServerConnection.

    • Uses of MBeanServerConnection in javax.management

      Subinterfaces of MBeanServerConnection in javax.management
      修饰符与类型 Interface and Description
      interface  MBeanServer
      This is the interface for MBean manipulation on the agent side.
      Methods in javax.management that return MBeanServerConnection
      修饰符与类型 方法与描述
      MBeanServerConnection MBeanServerInvocationHandler.getMBeanServerConnection()
      The MBean server connection through which the methods of a proxy using this handler are forwarded.
      Methods in javax.management with parameters of type MBeanServerConnection
      修饰符与类型 方法与描述
      static <T> T JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass)
      Make a proxy for a Standard MBean in a local or remote MBean Server.
      static <T> T JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationEmitter)
      Make a proxy for a Standard MBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
      static <T> T JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass)
      Make a proxy for an MXBean in a local or remote MBean Server.
      static <T> T JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationEmitter)
      Make a proxy for an MXBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
      static <T> T MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, 类<T> interfaceClass, boolean notificationBroadcaster)
      Return a proxy that implements the given interface by forwarding its methods through the given MBean server to the named MBean.
      Constructors in javax.management with parameters of type MBeanServerConnection
      构造方法与描述
      MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
      Invocation handler that forwards methods through an MBean server to a Standard MBean.
      MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
      Invocation handler that can forward methods through an MBean server to a Standard MBean or MXBean.

    • Uses of MBeanServerConnection in javax.management.remote

      Subinterfaces of MBeanServerConnection in javax.management.remote
      修饰符与类型 Interface and Description
      interface  MBeanServerForwarder
      An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
      Methods in javax.management.remote that return MBeanServerConnection
      修饰符与类型 方法与描述
      MBeanServerConnection JMXConnector.getMBeanServerConnection()
      Returns an MBeanServerConnection object representing a remote MBean server.
      MBeanServerConnection JMXConnector.getMBeanServerConnection(Subject delegationSubject)
      Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.

    • Uses of MBeanServerConnection in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return MBeanServerConnection
      修饰符与类型 | 方法与描述
      MBeanServerConnection | RMIConnector.getMBeanServerConnection()
      MBeanServerConnection | RMIConnector.getMBeanServerConnection(Subject delegationSubject)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.teanarxx>remfoo


Uses of Interface javax.management.MBeanServerDelegateMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.MBeanServerDelegateMBean

  • Packages that use MBeanServerDelegateMBean
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of MBeanServerDelegateMBean in javax.management

      Classes in javax.management that implement MBeanServerDelegateMBean
      修饰符与类型 类与描述
      class  MBeanServerDelegate
      Represents the MBean server from the management point of view.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dl&t<>d>rSSSm;&&"dit


Uses of Interface javax.management.NotificationBroadcaster

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.NotificationBroadcaster

  • Packages that use NotificationBroadcaster
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of NotificationBroadcaster in javax.management

      Subinterfaces of NotificationBroadcaster in javax.management
      修饰符与类型 Interface and Description
      interface  NotificationEmitter
      Interface implemented by an MBean that emits Notifications.
      Classes in javax.management that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  MBeanServerDelegate
      Represents the MBean server from the management point of view.
      class  NotificationBroadcasterSupport
      Provides an implementation of NotificationEmitter interface.
      class  StandardEmitterMBean
      An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.

    • Uses of NotificationBroadcaster in javax.management.modelmbean

      Subinterfaces of NotificationBroadcaster in javax.management.modelmbean
      修饰符与类型 Interface and Description
      interface  ModelMBean
      This interface must be implemented by the ModelMBeans.
      interface  ModelMBeanNotificationBroadcaster
      This interface must be implemented by the ModelMBeans.
      Classes in javax.management.modelmbean that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.

    • Uses of NotificationBroadcaster in javax.management.monitor

      Classes in javax.management.monitor that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  Monitor
      Defines the part common to all monitor MBeans.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.

    • Uses of NotificationBroadcaster in javax.management.relation

      Classes in javax.management.relation that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

    • Uses of NotificationBroadcaster in javax.management.remote

      Classes in javax.management.remote that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of NotificationBroadcaster in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.

    • Uses of NotificationBroadcaster in javax.management.timer

      Classes in javax.management.timer that implement NotificationBroadcaster
      修饰符与类型 类与描述
      class  Timer
      Provides the implementation of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xt/.f=" ahhhgeoo "lo aj//o


Uses of Interface javax.management.NotificationEmitter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.NotificationEmitter

  • Packages that use NotificationEmitter
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.monitor
    Provides the definition of the monitor classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of NotificationEmitter in javax.management

      Classes in javax.management that implement NotificationEmitter
      修饰符与类型 类与描述
      class  MBeanServerDelegate
      Represents the MBean server from the management point of view.
      class  NotificationBroadcasterSupport
      Provides an implementation of NotificationEmitter interface.
      class  StandardEmitterMBean
      An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.
      Constructors in javax.management with parameters of type NotificationEmitter
      构造方法与描述
      StandardEmitterMBean(类<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
      Make an MBean whose management interface is specified by mbeanInterface, and where notifications are handled by the given NotificationEmitter.
      StandardEmitterMBean(类<?> mbeanInterface, NotificationEmitter emitter)
      Make an MBean whose management interface is specified by mbeanInterface, and where notifications are handled by the given NotificationEmitter.
      StandardEmitterMBean(T implementation, 类<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
      Make an MBean whose management interface is specified by mbeanInterface, with the given implementation and where notifications are handled by the given NotificationEmitter.
      StandardEmitterMBean(T implementation, 类<T> mbeanInterface, NotificationEmitter emitter)
      Make an MBean whose management interface is specified by mbeanInterface, with the given implementation and where notifications are handled by the given NotificationEmitter.

    • Uses of NotificationEmitter in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement NotificationEmitter
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.

    • Uses of NotificationEmitter in javax.management.monitor

      Classes in javax.management.monitor that implement NotificationEmitter
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  Monitor
      Defines the part common to all monitor MBeans.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.

    • Uses of NotificationEmitter in javax.management.relation

      Classes in javax.management.relation that implement NotificationEmitter
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

    • Uses of NotificationEmitter in javax.management.remote

      Classes in javax.management.remote that implement NotificationEmitter
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of NotificationEmitter in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement NotificationEmitter
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.

    • Uses of NotificationEmitter in javax.management.timer

      Classes in javax.management.timer that implement NotificationEmitter
      修饰符与类型 类与描述
      class  Timer
      Provides the implementation of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" c< titoooc/EEn.>/sacjp


Uses of Interface javax.management.NotificationFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.NotificationFilter

  • Packages that use NotificationFilter
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of NotificationFilter in javax.management

      Classes in javax.management that implement NotificationFilter
      修饰符与类型 类与描述
      class  AttributeChangeNotificationFilter
      This class implements of the NotificationFilter interface for the attribute change notification.
      class  NotificationFilterSupport
      Provides an implementation of the NotificationFilter interface.
      Methods in javax.management with parameters of type NotificationFilter
      修饰符与类型 | 方法与描述
      void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener.
      void NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to this MBean.
      void MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from this MBean.
      void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

    • Uses of NotificationFilter in javax.management.modelmbean

      Methods in javax.management.modelmbean with parameters of type NotificationFilter
      修饰符与类型 | 方法与描述
      void RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

    • Uses of NotificationFilter in javax.management.relation

      Classes in javax.management.relation that implement NotificationFilter
      修饰符与类型 类与描述
      class  MBeanServerNotificationFilter
      Filter for MBeanServerNotification.

    • Uses of NotificationFilter in javax.management.remote

      Methods in javax.management.remote with parameters of type NotificationFilter
      修饰符与类型 方法与描述
      void JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to be informed of changes in connection status.
      void JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback)
      Removes a listener from the list to be informed of changes in status.

    • Uses of NotificationFilter in javax.management.remote.rmi

      Methods in javax.management.remote.rmi with parameters of type NotificationFilter
      修饰符与类型 | 方法与描述
      void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.management.NotificationListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.NotificationListener

  • Packages that use NotificationListener
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
    javax.management.relation
    Provides the definition of the Relation Service.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of NotificationListener in javax.management

      Methods in javax.management with parameters of type NotificationListener
      修饰符与类型 | 方法与描述
      void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener.
      void NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to this MBean.
      void MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      void MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to a registered MBean.
      protected void NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback)
      This method is called by sendNotification for each listener in order to send the notification to that listener.
      void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener)
      void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener)
      void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener)
      void NotificationBroadcaster.removeNotificationListener(NotificationListener listener)
      Removes a listener from this MBean.
      void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from this MBean.
      void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
      void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from a registered MBean.
      void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

    • Uses of NotificationListener in javax.management.modelmbean

      Methods in javax.management.modelmbean with parameters of type NotificationListener
      修饰符与类型 | 方法与描述
      void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
      void ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      void RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
      void ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName)
      Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
      void RequiredModelMBean.removeNotificationListener(NotificationListener listener)
      Removes a listener for Notifications from the RequiredModelMBean.
      void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

    • Uses of NotificationListener in javax.management.relation

      Classes in javax.management.relation that implement NotificationListener
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

    • Uses of NotificationListener in javax.management.remote

      Methods in javax.management.remote with parameters of type NotificationListener
      修饰符与类型 方法与描述
      void JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to be informed of changes in connection status.
      void JMXConnector.removeConnectionNotificationListener(NotificationListener listener)
      Removes a listener from the list to be informed of changes in status.
      void JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback)
      Removes a listener from the list to be informed of changes in status.

    • Uses of NotificationListener in javax.management.remote.rmi

      Methods in javax.management.remote.rmi with parameters of type NotificationListener
      修饰符与类型 | 方法与描述
      void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener)
      void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!cma


Uses of Interface javax.management.PersistentMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.PersistentMBean

  • Packages that use PersistentMBean
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of PersistentMBean in javax.management.modelmbean

      Subinterfaces of PersistentMBean in javax.management.modelmbean
      修饰符与类型 Interface and Description
      interface  ModelMBean
      This interface must be implemented by the ModelMBeans.
      Classes in javax.management.modelmbean that implement PersistentMBean
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sc=>pe


Uses of Interface javax.management.QueryExp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.QueryExp

  • Packages that use QueryExp
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of QueryExp in javax.management

      Classes in javax.management that implement QueryExp
      修饰符与类型 类与描述
      class  ObjectName
      Represents the object name of an MBean, or a pattern that can match the names of several MBeans.
      Methods in javax.management that return QueryExp
      修饰符与类型 方法与描述
      static QueryExp Query.and(QueryExp q1, QueryExp q2)
      Returns a query expression that is the conjunction of two other query expressions.
      static QueryExp Query.anySubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.between(ValueExp v1, ValueExp v2, ValueExp v3)
      Returns a query expression that represents the constraint that one value is between two other values.
      static QueryExp Query.eq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents an equality constraint on two values.
      static QueryExp Query.finalSubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.geq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "greater than or equal to" constraint on two values.
      static QueryExp Query.gt(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "greater than" constraint on two values.
      static QueryExp Query.in(ValueExp val, ValueExp[] valueList)
      Returns an expression constraining a value to be one of an explicit list.
      static QueryExp Query.initialSubString(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.isInstanceOf(StringValueExp classNameValue)
      Returns a query expression that represents an inheritance constraint on an MBean class.
      static QueryExp Query.leq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "less than or equal to" constraint on two values.
      static QueryExp Query.lt(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "less than" constraint on two values.
      static QueryExp Query.match(AttributeValueExp a, StringValueExp s)
      Returns a query expression that represents a matching constraint on a string argument.
      static QueryExp Query.not(QueryExp queryExp)
      Returns a constraint that is the negation of its argument.
      static QueryExp Query.or(QueryExp q1, QueryExp q2)
      Returns a query expression that is the disjunction of two other query expressions.
      Methods in javax.management with parameters of type QueryExp
      修饰符与类型 方法与描述
      static QueryExp Query.and(QueryExp q1, QueryExp q2)
      Returns a query expression that is the conjunction of two other query expressions.
      static QueryExp Query.not(QueryExp queryExp)
      Returns a constraint that is the negation of its argument.
      static QueryExp Query.or(QueryExp q1, QueryExp q2)
      Returns a query expression that is the disjunction of two other query expressions.
      Set<ObjectInstance> MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.
      Set<ObjectInstance> MBeanServer.queryMBeans(ObjectName name, QueryExp query)
      Gets MBeans controlled by the MBean server.
      Set<ObjectName> MBeanServerConnection.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
      Set<ObjectName> MBeanServer.queryNames(ObjectName name, QueryExp query)
      Gets the names of MBeans controlled by the MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

O=


Uses of Interface javax.management.ValueExp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.ValueExp

  • Packages that use ValueExp
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.

    • Uses of ValueExp in javax.management

      Classes in javax.management that implement ValueExp
      修饰符与类型 类与描述
      class  AttributeValueExp
      Represents attributes used as arguments to relational constraints.
      class  StringValueExp
      Represents strings that are arguments to relational constraints.
      Methods in javax.management that return ValueExp
      修饰符与类型 方法与描述
      ValueExp StringValueExp.apply(ObjectName name)
      Applies the ValueExp on a MBean.
      ValueExp AttributeValueExp.apply(ObjectName name)
      Applies the AttributeValueExp on an MBean.
      ValueExp ValueExp.apply(ObjectName name)
      Applies the ValueExp on a MBean.
      static ValueExp Query.div(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the quotient of two numeric values.
      ValueExp BadBinaryOpValueExpException.getExp()
      Returns the ValueExp that originated the exception.
      static ValueExp Query.minus(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the difference between two numeric values.
      static ValueExp Query.plus(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the sum of two numeric values, or the concatenation of two string values.
      static ValueExp Query.times(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the product of two numeric values.
      static ValueExp Query.value(boolean val)
      Returns a boolean value expression that can be used in any Query call that expects a ValueExp.
      static ValueExp Query.value(double val)
      Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
      static ValueExp Query.value(float val)
      Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
      static ValueExp Query.value(int val)
      Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
      static ValueExp Query.value(long val)
      Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
      static ValueExp Query.value(Number val)
      Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
      Methods in javax.management with parameters of type ValueExp
      修饰符与类型 方法与描述
      static QueryExp Query.between(ValueExp v1, ValueExp v2, ValueExp v3)
      Returns a query expression that represents the constraint that one value is between two other values.
      static ValueExp Query.div(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the quotient of two numeric values.
      static QueryExp Query.eq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents an equality constraint on two values.
      static QueryExp Query.geq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "greater than or equal to" constraint on two values.
      static QueryExp Query.gt(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "greater than" constraint on two values.
      static QueryExp Query.in(ValueExp val, ValueExp[] valueList)
      Returns an expression constraining a value to be one of an explicit list.
      static QueryExp Query.in(ValueExp val, ValueExp[] valueList)
      Returns an expression constraining a value to be one of an explicit list.
      static QueryExp Query.leq(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "less than or equal to" constraint on two values.
      static QueryExp Query.lt(ValueExp v1, ValueExp v2)
      Returns a query expression that represents a "less than" constraint on two values.
      static ValueExp Query.minus(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the difference between two numeric values.
      static ValueExp Query.plus(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the sum of two numeric values, or the concatenation of two string values.
      static ValueExp Query.times(ValueExp value1, ValueExp value2)
      Returns a binary expression representing the product of two numeric values.
      Constructors in javax.management with parameters of type ValueExp
      构造方法与描述
      BadBinaryOpValueExpException(ValueExp exp)
      Constructs a BadBinaryOpValueExpException with the specified ValueExp.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gdhod>,8tMc stcs糽g/烈at


ClassLoaderRepository

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.loading

Interface ClassLoaderRepository

  • public interface ClassLoaderRepository

    Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server. They provide the necessary methods to load classes using the registered ClassLoaders.

    The first ClassLoader in a ClassLoaderRepository is always the MBean Server's own ClassLoader.

    When an MBean is registered in an MBean Server, if it is of a subclass of ClassLoader and if it does not implement the interface PrivateClassLoader, it is added to the end of the MBean Server's ClassLoaderRepository. If it is subsequently unregistered from the MBean Server, it is removed from the ClassLoaderRepository.

    The order of MBeans in the ClassLoaderRepository is significant. For any two MBeans X and Y in the ClassLoaderRepository, X must appear before Y if the registration of X was completed before the registration of Y started. If X and Y were registered concurrently, their order is indeterminate. The registration of an MBean corresponds to the call to MBeanServer.registerMBean(java.lang.Object, javax.management.ObjectName) or one of the MBeanServer .createMBean methods.

    从以下版本开始：
    1.5
    另请参见：
    MBeanServerFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<?> loadClass(String className)
      Load the given class name through the list of class loaders.
      类<?> loadClassBefore(ClassLoader stop, String className)
      Load the given class name through the list of class loaders, stopping at the given one.
      类<?> loadClassWithout(ClassLoader exclude, String className)
      Load the given class name through the list of class loaders, excluding the given one.

    • 方法详细信息

      • loadClass

        类<?> loadClass(String className)
                   throws ClassNotFoundException

        Load the given class name through the list of class loaders. Each ClassLoader in turn from the ClassLoaderRepository is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a 类 object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the end of the list is reached, a ClassNotFoundException is thrown.

        参数：
        className - The name of the class to be loaded.
        返回：
        the loaded class.
        抛出：
        ClassNotFoundException - The specified class could not be found.

      • loadClassWithout

        类<?> loadClassWithout(ClassLoader exclude,
                        String className)
                          throws ClassNotFoundException

        Load the given class name through the list of class loaders, excluding the given one. Each ClassLoader in turn from the ClassLoaderRepository, except exclude, is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a 类 object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the end of the list is reached, a ClassNotFoundException is thrown.

        Be aware that if a ClassLoader in the ClassLoaderRepository calls this method from its loadClass method, it exposes itself to a deadlock if another ClassLoader in the ClassLoaderRepository does the same thing at the same time. The loadClassBefore(java.lang.ClassLoader, java.lang.String) method is recommended to avoid the risk of deadlock.

        参数：
        className - The name of the class to be loaded.
        exclude - The class loader to be excluded. May be null, in which case this method is equivalent to loadClass(className).
        返回：
        the loaded class.
        抛出：
        ClassNotFoundException - The specified class could not be found.

      • loadClassBefore

        类<?> loadClassBefore(ClassLoader stop,
                       String className)
                         throws ClassNotFoundException

        Load the given class name through the list of class loaders, stopping at the given one. Each ClassLoader in turn from the ClassLoaderRepository is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a 类 object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the search reaches stop or the end of the list, a ClassNotFoundException is thrown.

        Typically this method is called from the loadClass method of stop, to consult loaders that appear before it in the ClassLoaderRepository. By stopping the search as soon as stop is reached, a potential deadlock with concurrent class loading is avoided.

        参数：
        className - The name of the class to be loaded.
        stop - The class loader at which to stop. May be null, in which case this method is equivalent to loadClass(className).
        返回：
        the loaded class.
        抛出：
        ClassNotFoundException - The specified class could not be found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..htn/st<)laaes/.>v /a.


DefaultLoaderRepository

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.loading

类 DefaultLoaderRepository

  • java.lang.Object
    • javax.management.loading.DefaultLoaderRepository
  • Deprecated.
    Use MBeanServer.getClassLoaderRepository()} instead.

    @Deprecated
public class DefaultLoaderRepository
extends Object

    Keeps the list of Class Loaders registered in the MBean Server. It provides the necessary methods to load classes using the registered Class Loaders.

    This deprecated class is maintained for compatibility. In previous versions of JMX, there was one DefaultLoaderRepository shared by all MBean servers. As of JMX 1.2, that functionality is approximated by using MBeanServerFactory.findMBeanServer(java.lang.String) to find all known MBean servers, and consulting the ClassLoaderRepository of each one. It is strongly recommended that code referencing DefaultLoaderRepository be rewritten.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultLoaderRepository()
      Deprecated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static 类<?> loadClass(String className)
      Deprecated.
      Go through the list of class loaders and try to load the requested class.
      static 类<?> loadClassWithout(ClassLoader loader, String className)
      Deprecated.
      Go through the list of class loaders but exclude the given class loader, then try to load the requested class.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultLoaderRepository

        public DefaultLoaderRepository()
        Deprecated.

    • 方法详细信息

      • loadClass

        public static 类<?> loadClass(String className)
                          throws ClassNotFoundException
        Deprecated.
        Go through the list of class loaders and try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.
        参数：
        className - The name of the class to be loaded.
        返回：
        the loaded class.
        抛出：
        ClassNotFoundException - The specified class could not be found.

      • loadClassWithout

        public static 类<?> loadClassWithout(ClassLoader loader,
                        String className)
                                 throws ClassNotFoundException
        Deprecated.
        Go through the list of class loaders but exclude the given class loader, then try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.
        参数：
        className - The name of the class to be loaded.
        loader - The class loader to be excluded.
        返回：
        the loaded class.
        抛出：
        ClassNotFoundException - The specified class could not be found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< /eudondoNtNsNNCaccd>ad<>oe<>n //><


javax.management.loading

Interfaces

  • ClassLoaderRepository
  • MLetMBean
  • PrivateClassLoader

Classes

  • DefaultLoaderRepository
  • MLet
  • MLetContent
  • PrivateMLet
N


javax.management.loading

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.loading

Provides the classes which implement advanced dynamic loading.

请参见： 描述

  • 接口摘要
    接口 描述
    ClassLoaderRepository
    Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
    MLetMBean
    Exposes the remote management interface of the MLet MBean.
    PrivateClassLoader
    Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository.
  • Class Summary
    类 描述
    DefaultLoaderRepository Deprecated
    Use MBeanServer.getClassLoaderRepository()} instead.
    MLet
    Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
    MLetContent
    This class represents the contents of the MLET tag.
    PrivateMLet
    An MLet that is not added to the ClassLoaderRepository.

软件包 javax.management.loading Description

Provides the classes which implement advanced dynamic loading. See the chapter Advanced Dynamic Loading in the JMX Specification.

An MBean that is of a subclass of ClassLoader can be used as a class loader to create other MBeans via the method MBeanServer.createMBean(String, ObjectName, ObjectName, Object[], String[]), and to instantiate arbitrary objects via the method MBeanServer.instantiate(String, ObjectName, Object[], String[]). The MLet class is an example of such an MBean. It is a URLClassLoader, so the list of URLs to load classes from can be configured.

Additionally, an MLet can read a configuration file that specifies a set of MBeans to be registered in the same MBean Server as the MLet.

Every MBean Server has a class loader repository containing all MBeans registered in that MBean Server that are of a subclass of ClassLoader. The class loader repository is used by the forms of the createMBean and instantiate methods in the MBeanServer interface that do not have an explicit loader parameter. It is also used by the MLet class when it does not find a class in its own set of URLs.

If an MBean implements the interface PrivateClassLoader, then it is not added to the class loader repository. The class PrivateMLet is a subclass of MLet that implements PrivateClassLoader.

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology, in particular the JMX Specification, version 1.4(pdf).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&a><&il"av.llaellp/.e> e


javax.management.loading Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.loading

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader (implements java.io.Closeable)
          • javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • javax.management.loading.DefaultLoaderRepository
    • javax.management.loading.MLetContent

Interface Hierarchy

  • javax.management.loading.ClassLoaderRepository
  • javax.management.loading.MLetMBean
  • javax.management.loading.PrivateClassLoader
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sss vheSrrrav e e vM


MLet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.loading

类 MLet

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
          • javax.management.loading.MLet
  • 所有已实现的接口：
    Closeable, Externalizable, Serializable, AutoCloseable, MLetMBean, MBeanRegistration
    直接已知子类：
    PrivateMLet

    public class MLet
extends URLClassLoader
implements MLetMBean, MBeanRegistration, Externalizable
    Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL. M-let is a shortcut for management applet. The m-let service does this by loading an m-let text file, which specifies information on the MBeans to be obtained. The information on each MBean is specified in a single instance of a tag, called the MLET tag. The location of the m-let text file is specified by a URL.

    The MLET tag has the following syntax:

    <MLET
    CODE = 类 | OBJECT = serfile
    ARCHIVE = "archiveList"
    [CODEBASE = codebaseURL]
    [NAME = mbeanname]
    [VERSION = version]
    >
    [arglist]
    </MLET>

    where:

    CODE = 类
    This attribute specifies the full Java class name, including package name, of the MBean to be obtained. The compiled .class file of the MBean must be contained in one of the .jar files specified by the ARCHIVE attribute. Either CODE or OBJECT must be present.
    OBJECT = serfile
    This attribute specifies the .ser file that contains a serialized representation of the MBean to be obtained. This file must be contained in one of the .jar files specified by the ARCHIVE attribute. If the .jar file contains a directory hierarchy, specify the path of the file within this hierarchy. Otherwise a match will not be found. Either CODE or OBJECT must be present.
    ARCHIVE = "archiveList"
    This mandatory attribute specifies one or more .jar files containing MBeans or other resources used by the MBean to be obtained. One of the .jar files must contain the file specified by the CODE or OBJECT attribute. If archivelist contains more than one file:
    • Each file must be separated from the one that follows it by a comma (,).
    • archivelist must be enclosed in double quote marks.
    All .jar files in archivelist must be stored in the directory specified by the code base URL.
    CODEBASE = codebaseURL
    This optional attribute specifies the code base URL of the MBean to be obtained. It identifies the directory that contains the .jar files specified by the ARCHIVE attribute. Specify this attribute only if the .jar files are not in the same directory as the m-let text file. If this attribute is not specified, the base URL of the m-let text file is used.
    NAME = mbeanname
    This optional attribute specifies the object name to be assigned to the MBean instance when the m-let service registers it. If mbeanname starts with the colon character (:), the domain part of the object name is the default domain of the MBean server, as returned by MBeanServer.getDefaultDomain().
    VERSION = version
    This optional attribute specifies the version number of the MBean and associated .jar files to be obtained. This version number can be used to specify that the .jar files are loaded from the server to update those stored locally in the cache the next time the m-let text file is loaded. version must be a series of non-negative decimal integers each separated by a period from the one that precedes it.
    arglist
    This optional attribute specifies a list of one or more parameters for the MBean to be instantiated. This list describes the parameters to be passed the MBean's constructor. Use the following syntax to specify each item in arglist:

    <ARG TYPE=argumentType VALUE=value>

    where:
    • argumentType is the type of the argument that will be passed as parameter to the MBean's constructor.

    The arguments' type in the argument list should be a Java primitive type or a Java basic type (java.lang.Boolean, java.lang.Byte, java.lang.Short, java.lang.Long, java.lang.Integer, java.lang.Float, java.lang.Double, java.lang.String).

    When an m-let text file is loaded, an instance of each MBean specified in the file is created and registered.

    The m-let service extends the java.net.URLClassLoader and can be used to load remote classes and jar files in the VM of the agent.

    Note - The MLet class loader uses the MBeanServerFactory.getClassLoaderRepository(javax.management.MBeanServer) to load classes that could not be found in the loaded jar files.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MLet()
      Constructs a new MLet using the default delegation parent ClassLoader.
      MLet(URL[] urls)
      Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
      MLet(URL[] urls, boolean delegateToCLR)
      Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
      MLet(URL[] urls, ClassLoader parent)
      Constructs a new MLet for the given URLs.
      MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      Constructs a new MLet for the given URLs.
      MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
      Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
      MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addURL(String url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      void addURL(URL url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      protected URL check(String version, URL codebase, String jarfile, MLetContent mlet)
      This method is to be overridden when extending this service to support caching and versioning.
      protected 类<?> findClass(String name)
      This is the main method for class loaders that is being redefined.
      protected String findLibrary(String libname)
      Returns the absolute path name of a native library.
      String getLibraryDirectory()
      Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
      Set<Object> getMBeansFromURL(String url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      Set<Object> getMBeansFromURL(URL url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      URL[] getURLs()
      Returns the search path of URLs for loading classes and resources.
      类<?> loadClass(String name, ClassLoaderRepository clr)
      Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs.
      void postDeregister()
      Allows the m-let to perform any operations needed after having been unregistered in the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the m-let to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the m-let to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the m-let to perform any operations it needs before being registered in the MBean server.
      void readExternal(ObjectInput in)
      Restore this MLet's contents from the given ObjectInput.
      void setLibraryDirectory(String libdir)
      Sets the directory used by the library loader for storing native libraries before they are loaded into memory.
      void writeExternal(ObjectOutput out)
      Save this MLet's contents to the given ObjectOutput.

      • 方法 - 继承于类 java.net.URLClassLoader

        close, definePackage, findResource, findResources, getPermissions, getResourceAsStream, newInstance, newInstance

      • 方法 - 继承于类 java.security.SecureClassLoader

        defineClass, defineClass

      • 方法 - 继承于类 java.lang.ClassLoader

        clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getClassLoadingLock, getPackage, getPackages, getParent, getResource, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, registerAsParallelCapable, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.loading.MLetMBean

        getResource, getResourceAsStream, getResources

    • 构造方法详细信息

      • MLet

        public MLet()
        Constructs a new MLet using the default delegation parent ClassLoader.

      • MLet

        public MLet(URL[] urls)
        Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.
        参数：
        urls - The URLs from which to load classes and resources.

      • MLet

        public MLet(URL[] urls,
    ClassLoader parent)
        Constructs a new MLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.

      • MLet

        public MLet(URL[] urls,
    ClassLoader parent,
    URLStreamHandlerFactory factory)
        Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.
        factory - The URLStreamHandlerFactory to use when creating URLs.

      • MLet

        public MLet(URL[] urls,
    boolean delegateToCLR)
        Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.
        参数：
        urls - The URLs from which to load classes and resources.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

      • MLet

        public MLet(URL[] urls,
    ClassLoader parent,
    boolean delegateToCLR)
        Constructs a new MLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

      • MLet

        public MLet(URL[] urls,
    ClassLoader parent,
    URLStreamHandlerFactory factory,
    boolean delegateToCLR)
        Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.
        factory - The URLStreamHandlerFactory to use when creating URLs.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

    • 方法详细信息

      • addURL

        public void addURL(URL url)
        Appends the specified URL to the list of URLs to search for classes and resources.
        指定者：
        addURL in interface MLetMBean
        重载：
        addURL in class URLClassLoader
        参数：
        url - the URL to be added to the search path of URLs

      • addURL

        public void addURL(String url)
            throws ServiceNotFoundException
        Appends the specified URL to the list of URLs to search for classes and resources.
        指定者：
        addURL in interface MLetMBean
        参数：
        url - the URL to add.
        抛出：
        ServiceNotFoundException - The specified URL is malformed.

      • getURLs

        public URL[] getURLs()
        Returns the search path of URLs for loading classes and resources. This includes the original list of URLs specified to the constructor, along with any URLs subsequently appended by the addURL() method.
        指定者：
        getURLs in interface MLetMBean
        重载：
        getURLs in class URLClassLoader
        返回：
        the search path of URLs for loading classes and resources.

      • getMBeansFromURL

        public Set<Object> getMBeansFromURL(URL url)
                             throws ServiceNotFoundException
        Loads a text file containing MLET tags that define the MBeans to be added to the MBean server. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered in the MBean server.
        指定者：
        getMBeansFromURL in interface MLetMBean
        参数：
        url - The URL of the text file to be loaded as URL object.
        返回：
        A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
        抛出：
        ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is null.
        IllegalStateException - MLet MBean is not registered with an MBeanServer.

      • getMBeansFromURL

        public Set<Object> getMBeansFromURL(String url)
                             throws ServiceNotFoundException
        Loads a text file containing MLET tags that define the MBeans to be added to the MBean server. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered in the MBean server.
        指定者：
        getMBeansFromURL in interface MLetMBean
        参数：
        url - The URL of the text file to be loaded as String object.
        返回：
        A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
        抛出：
        ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the url is malformed.
        IllegalStateException - MLet MBean is not registered with an MBeanServer.

      • getLibraryDirectory

        public String getLibraryDirectory()
        Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
        指定者：
        getLibraryDirectory in interface MLetMBean
        返回：
        The current directory used by the library loader.
        抛出：
        UnsupportedOperationException - if this implementation does not support storing native libraries in this way.
        另请参见：
        setLibraryDirectory(java.lang.String)

      • setLibraryDirectory

        public void setLibraryDirectory(String libdir)
        Sets the directory used by the library loader for storing native libraries before they are loaded into memory.
        指定者：
        setLibraryDirectory in interface MLetMBean
        参数：
        libdir - The directory used by the library loader.
        抛出：
        UnsupportedOperationException - if this implementation does not support storing native libraries in this way.
        另请参见：
        getLibraryDirectory()

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        Allows the m-let to perform any operations it needs before being registered in the MBean server. If the ObjectName is null, the m-let provides a default name for its registration <defaultDomain>:type=MLet
        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean server in which the m-let will be registered.
        name - The object name of the m-let.
        返回：
        The name of the m-let registered.
        抛出：
        Exception - This exception should be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postRegister

        public void postRegister(Boolean registrationDone)
        Allows the m-let to perform any operations needed after having been registered in the MBean server or after the registration has failed.
        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the m-let has been successfully registered in the MBean server. The value false means that either the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        Allows the m-let to perform any operations it needs before being unregistered by the MBean server.
        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        java.langException - This exception should be caught by the MBean server and re-thrown as an MBeanRegistrationException.
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postDeregister

        public void postDeregister()
        Allows the m-let to perform any operations needed after having been unregistered in the MBean server.
        指定者：
        postDeregister in interface MBeanRegistration

      • writeExternal

        public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

        Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

        The format of the written data is not specified, but if an implementation supports writeExternal(java.io.ObjectOutput) it must also support readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

        指定者：
        writeExternal in interface Externalizable
        参数：
        out - The object output stream to write to.
        抛出：
        IOException - If a problem occurred while writing.
        UnsupportedOperationException - If this implementation does not support this operation.

      • readExternal

        public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

        Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

        The format of the read data is not specified, but if an implementation supports readExternal(java.io.ObjectInput) it must also support writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

        指定者：
        readExternal in interface Externalizable
        参数：
        in - The object input stream to read from.
        抛出：
        IOException - if a problem occurred while reading.
        ClassNotFoundException - if the class for the object being restored cannot be found.
        UnsupportedOperationException - if this implementation does not support this operation.

      • loadClass

        public 类<?> loadClass(String name,
                 ClassLoaderRepository clr)
                   throws ClassNotFoundException

        Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs. The given ClassLoaderRepository can be null, in which case a ClassNotFoundException occurs immediately if the class is not found in this MLet's URLs.

        参数：
        name - The name of the class we want to load.
        clr - The ClassLoaderRepository that will be used to search for the given class, if it is not found in this ClassLoader. May be null.
        返回：
        The resulting Class object.
        抛出：
        ClassNotFoundException - The specified class could not be found in this ClassLoader nor in the given ClassLoaderRepository.

      • findClass

        protected 类<?> findClass(String name)
                      throws ClassNotFoundException
        This is the main method for class loaders that is being redefined.
        重载：
        findClass in class URLClassLoader
        参数：
        name - The name of the class.
        返回：
        The resulting Class object.
        抛出：
        ClassNotFoundException - The specified class could not be found.

      • findLibrary

        protected String findLibrary(String libname)
        Returns the absolute path name of a native library. The VM invokes this method to locate the native libraries that belong to classes loaded with this class loader. Libraries are searched in the JAR files using first just the native library name and if not found the native library name together with the architecture-specific path name (OSName/OSArch/OSVersion/lib/nativelibname), i.e.

        the library stat on Solaris SPARC 5.7 will be searched in the JAR file as:

        1. libstat.so
        2. SunOS/sparc/5.7/lib/libstat.so
        the library stat on Windows NT 4.0 will be searched in the JAR file as:
        1. stat.dll
        2. WindowsNT/x86/4.0/lib/stat.dll

        More specifically, let nativelibname be the result of System.mapLibraryName (libname). Then the following names are searched in the JAR files, in order:
        nativelibname
        <os.name>/<os.arch>/<os.version>/lib/nativelibname
        where <X> means System.getProperty(X) with any spaces in the result removed, and / stands for the file separator character (File.separator).

        If this method returns null, i.e. the libraries were not found in any of the JAR files loaded with this class loader, the VM searches the library along the path specified as the java.library.path property.

        重载：
        findLibrary in class ClassLoader
        参数：
        libname - The library name.
        返回：
        The absolute path of the native library.
        另请参见：
        System.loadLibrary(String), System.mapLibraryName(String)

      • check

        protected URL check(String version,
        URL codebase,
        String jarfile,
        MLetContent mlet)
             throws Exception

        This method is to be overridden when extending this service to support caching and versioning. It is called from getMBeansFromURL when the version, codebase, and jarfile have been extracted from the MLet file, and can be used to verify that it is all right to load the given MBean, or to replace the given URL with a different one.

        The default implementation of this method returns codebase unchanged.

        参数：
        version - The version number of the .jar file stored locally.
        codebase - The base URL of the remote .jar file.
        jarfile - The name of the .jar file to be loaded.
        mlet - The MLetContent instance that represents the MLET tag.
        返回：
        the codebase to use for the loaded MBean. The returned value should not be null.
        抛出：
        Exception - if the MBean is not to be loaded for some reason. The exception will be added to the set returned by getMBeansFromURL.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MLetContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.loading

类 MLetContent

  • java.lang.Object
    • javax.management.loading.MLetContent

  • public class MLetContent
extends Object
    This class represents the contents of the MLET tag. It can be consulted by a subclass of MLet that overrides the MLet.check method.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
      Creates an MLet instance initialized with attributes read from an MLET tag in an MLet text file.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Map<String,String> getAttributes()
      Gets the attributes of the MLET tag.
      String getCode()
      Gets the value of the CODE attribute of the MLET tag.
      URL getCodeBase()
      Gets the code base URL.
      URL getDocumentBase()
      Gets the MLet text file's base URL.
      String getJarFiles()
      Gets the list of .jar files specified by the ARCHIVE attribute of the MLET tag.
      String getName()
      Gets the value of the NAME attribute of the MLET tag.
      List<String> getParameterTypes()
      Gets the list of values of the TYPE attribute in each nested <PARAM> tag within the MLET tag.
      List<String> getParameterValues()
      Gets the list of values of the VALUE attribute in each nested <PARAM> tag within the MLET tag.
      String getSerializedObject()
      Gets the value of the OBJECT attribute of the MLET tag.
      String getVersion()
      Gets the value of the VERSION attribute of the MLET tag.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MLetContent

        public MLetContent(URL url,
           Map<String,String> attributes,
           List<String> types,
           List<String> values)
        Creates an MLet instance initialized with attributes read from an MLET tag in an MLet text file.
        参数：
        url - The URL of the MLet text file containing the MLET tag.
        attributes - A map of the attributes of the MLET tag. The keys in this map are the attribute names in lowercase, for example codebase. The values are the associated attribute values.
        types - A list of the TYPE attributes that appeared in nested <PARAM> tags.
        values - A list of the VALUE attributes that appeared in nested <PARAM> tags.

    • 方法详细信息

      • getAttributes

        public Map<String,String> getAttributes()
        Gets the attributes of the MLET tag. The keys in the returned map are the attribute names in lowercase, for example codebase. The values are the associated attribute values.
        返回：
        A map of the attributes of the MLET tag and their values.

      • getDocumentBase

        public URL getDocumentBase()
        Gets the MLet text file's base URL.
        返回：
        The MLet text file's base URL.

      • getCodeBase

        public URL getCodeBase()
        Gets the code base URL.
        返回：
        The code base URL.

      • getJarFiles

        public String getJarFiles()
        Gets the list of .jar files specified by the ARCHIVE attribute of the MLET tag.
        返回：
        A comma-separated list of .jar file names.

      • getCode

        public String getCode()
        Gets the value of the CODE attribute of the MLET tag.
        返回：
        The value of the CODE attribute of the MLET tag.

      • getSerializedObject

        public String getSerializedObject()
        Gets the value of the OBJECT attribute of the MLET tag.
        返回：
        The value of the OBJECT attribute of the MLET tag.

      • getName

        public String getName()
        Gets the value of the NAME attribute of the MLET tag.
        返回：
        The value of the NAME attribute of the MLET tag.

      • getVersion

        public String getVersion()
        Gets the value of the VERSION attribute of the MLET tag.
        返回：
        The value of the VERSION attribute of the MLET tag.

      • getParameterTypes

        public List<String> getParameterTypes()
        Gets the list of values of the TYPE attribute in each nested <PARAM> tag within the MLET tag.
        返回：
        the list of types.

      • getParameterValues

        public List<String> getParameterValues()
        Gets the list of values of the VALUE attribute in each nested <PARAM> tag within the MLET tag.
        返回：
        the list of values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cmoc><< << //< <.nnfeaeh r iMreeg eer


MLetMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.loading

Interface MLetMBean

  • All Known Implementing Classes:
    MLet, PrivateMLet

    public interface MLetMBean
    Exposes the remote management interface of the MLet MBean.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addURL(String url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      void addURL(URL url)
      Appends the specified URL to the list of URLs to search for classes and resources.
      String getLibraryDirectory()
      Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
      Set<Object> getMBeansFromURL(String url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      Set<Object> getMBeansFromURL(URL url)
      Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.
      URL getResource(String name)
      Finds the resource with the given name.
      InputStream getResourceAsStream(String name)
      Returns an input stream for reading the specified resource.
      Enumeration<URL> getResources(String name)
      Finds all the resources with the given name.
      URL[] getURLs()
      Returns the search path of URLs for loading classes and resources.
      void setLibraryDirectory(String libdir)
      Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

    • 方法详细信息

      • getMBeansFromURL

        Set<Object> getMBeansFromURL(String url)
                             throws ServiceNotFoundException
        Loads a text file containing MLET tags that define the MBeans to be added to the MBean server. The location of the text file is specified by a URL. The text file is read using the UTF-8 encoding. The MBeans specified in the MLET file will be instantiated and registered in the MBean server.
        参数：
        url - The URL of the text file to be loaded as String object.
        返回：
        A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
        抛出：
        ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is malformed.

      • getMBeansFromURL

        Set<Object> getMBeansFromURL(URL url)
                             throws ServiceNotFoundException
        Loads a text file containing MLET tags that define the MBeans to be added to the MBean server. The location of the text file is specified by a URL. The text file is read using the UTF-8 encoding. The MBeans specified in the MLET file will be instantiated and registered in the MBean server.
        参数：
        url - The URL of the text file to be loaded as URL object.
        返回：
        A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
        抛出：
        ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is null.

      • addURL

        void addURL(URL url)
        Appends the specified URL to the list of URLs to search for classes and resources.
        参数：
        url - the URL to add.

      • addURL

        void addURL(String url)
            throws ServiceNotFoundException
        Appends the specified URL to the list of URLs to search for classes and resources.
        参数：
        url - the URL to add.
        抛出：
        ServiceNotFoundException - The specified URL is malformed.

      • getURLs

        URL[] getURLs()
        Returns the search path of URLs for loading classes and resources. This includes the original list of URLs specified to the constructor, along with any URLs subsequently appended by the addURL() method.
        返回：
        the list of URLs.

      • getResource

        URL getResource(String name)
        Finds the resource with the given name. A resource is some data (images, audio, text, etc) that can be accessed by class code in a way that is independent of the location of the code. The name of a resource is a "/"-separated path name that identifies the resource.
        参数：
        name - The resource name
        返回：
        An URL for reading the resource, or null if the resource could not be found or the caller doesn't have adequate privileges to get the resource.

      • getResourceAsStream

        InputStream getResourceAsStream(String name)
        Returns an input stream for reading the specified resource. The search order is described in the documentation for getResource(String).
        参数：
        name - The resource name
        返回：
        An input stream for reading the resource, or null if the resource could not be found

      • getResources

        Enumeration<URL> getResources(String name)
                              throws IOException
        Finds all the resources with the given name. A resource is some data (images, audio, text, etc) that can be accessed by class code in a way that is independent of the location of the code. The name of a resource is a "/"-separated path name that identifies the resource.
        参数：
        name - The resource name.
        返回：
        An enumeration of URL to the resource. If no resources could be found, the enumeration will be empty. Resources that cannot be accessed will not be in the enumeration.
        抛出：
        IOException - if an I/O exception occurs when searching for resources.

      • getLibraryDirectory

        String getLibraryDirectory()
        Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
        返回：
        The current directory used by the library loader.
        抛出：
        UnsupportedOperationException - if this implementation does not support storing native libraries in this way.
        另请参见：
        setLibraryDirectory(java.lang.String)

      • setLibraryDirectory

        void setLibraryDirectory(String libdir)
        Sets the directory used by the library loader for storing native libraries before they are loaded into memory.
        参数：
        libdir - The directory used by the library loader.
        抛出：
        UnsupportedOperationException - if this implementation does not support storing native libraries in this way.
        另请参见：
        getLibraryDirectory()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l">>oeoeimnta/v.cov?<隺(a>〃dode


PrivateClassLoader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.management.loading

Interface PrivateClassLoader

  • All Known Implementing Classes:
    PrivateMLet

    public interface PrivateClassLoader
    Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository. When a ClassLoader is registered as an MBean in the MBean server, it is added to the MBean server's ClassLoaderRepository unless it implements this interface.
    从以下版本开始：
    1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sop"t"l"tlcacappa


PrivateMLet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.loading

类 PrivateMLet

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
          • javax.management.loading.MLet
            • javax.management.loading.PrivateMLet
  • 所有已实现的接口：
    Closeable, Externalizable, Serializable, AutoCloseable, MLetMBean, PrivateClassLoader, MBeanRegistration

    public class PrivateMLet
extends MLet
implements PrivateClassLoader
    An MLet that is not added to the ClassLoaderRepository. This class acts exactly like its parent class, MLet, with one exception. When a PrivateMLet is registered in an MBean server, it is not added to that MBean server's ClassLoaderRepository. This is true because this class implements the interface PrivateClassLoader.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrivateMLet(URL[] urls, boolean delegateToCLR)
      Constructs a new PrivateMLet for the specified URLs using the default delegation parent ClassLoader.
      PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
      Constructs a new PrivateMLet for the given URLs.
      PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
      Constructs a new PrivateMLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.

    • 方法摘要

      • 方法 - 继承于类 javax.management.loading.MLet

        addURL, addURL, check, findClass, findLibrary, getLibraryDirectory, getMBeansFromURL, getMBeansFromURL, getURLs, loadClass, postDeregister, postRegister, preDeregister, preRegister, readExternal, setLibraryDirectory, writeExternal

      • 方法 - 继承于类 java.net.URLClassLoader

        close, definePackage, findResource, findResources, getPermissions, getResourceAsStream, newInstance, newInstance

      • 方法 - 继承于类 java.security.SecureClassLoader

        defineClass, defineClass

      • 方法 - 继承于类 java.lang.ClassLoader

        clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getClassLoadingLock, getPackage, getPackages, getParent, getResource, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, registerAsParallelCapable, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.loading.MLetMBean

        getResource, getResourceAsStream, getResources

    • 构造方法详细信息

      • PrivateMLet

        public PrivateMLet(URL[] urls,
           boolean delegateToCLR)
        Constructs a new PrivateMLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.
        参数：
        urls - The URLs from which to load classes and resources.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

      • PrivateMLet

        public PrivateMLet(URL[] urls,
           ClassLoader parent,
           boolean delegateToCLR)
        Constructs a new PrivateMLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

      • PrivateMLet

        public PrivateMLet(URL[] urls,
           ClassLoader parent,
           URLStreamHandlerFactory factory,
           boolean delegateToCLR)
        Constructs a new PrivateMLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.
        参数：
        urls - The URLs from which to load classes and resources.
        parent - The parent class loader for delegation.
        factory - The URLStreamHandlerFactory to use when creating URLs.
        delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Fna&nmvmt?xx/ellc=� n /� nl/�"s1L


Uses of Package javax.management.loading

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.loading

  • Packages that use javax.management.loading
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
  • Classes in javax.management.loading used by javax.management
    类与描述
    ClassLoaderRepository
    Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
  • Classes in javax.management.loading used by javax.management.loading
    类与描述
    ClassLoaderRepository
    Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
    MLet
    Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
    MLetContent
    This class represents the contents of the MLET tag.
    MLetMBean
    Exposes the remote management interface of the MLet MBean.
    PrivateClassLoader
    Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository.
  • Classes in javax.management.loading used by javax.management.modelmbean
    类与描述
    ClassLoaderRepository
    Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/ nmti"n-vviiaa = paoL m


Uses of Class javax.management.loading.DefaultLoaderRepository

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.loading.DefaultLoaderRepository

No usage of javax.management.loading.DefaultLoaderRepository
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rrell#g.rhhhr/xxan>pen


Uses of Class javax.management.loading.MLet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.loading.MLet

  • Packages that use MLet
    软件包 描述
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.

    • Uses of MLet in javax.management.loading

      Subclasses of MLet in javax.management.loading
      修饰符与类型 类与描述
      class  PrivateMLet
      An MLet that is not added to the ClassLoaderRepository.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

va8lhl/brad/"dd/>>atss


Uses of Class javax.management.loading.MLetContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.loading.MLetContent

  • Packages that use MLetContent
    软件包 描述
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.

    • Uses of MLetContent in javax.management.loading

      Methods in javax.management.loading with parameters of type MLetContent
      修饰符与类型 方法与描述
      protected URL MLet.check(String version, URL codebase, String jarfile, MLetContent mlet)
      This method is to be overridden when extending this service to support caching and versioning.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

agt>head


Uses of Class javax.management.loading.PrivateMLet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.loading.PrivateMLet

No usage of javax.management.loading.PrivateMLet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otmaskife=== >""T v--


Uses of Interface javax.management.loading.ClassLoaderRepository

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.loading.ClassLoaderRepository

  • Packages that use ClassLoaderRepository
    软件包 描述
    javax.management
    Provides the core classes for the Java Management Extensions.
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ClassLoaderRepository in javax.management

      Methods in javax.management that return ClassLoaderRepository
      修饰符与类型 方法与描述
      ClassLoaderRepository MBeanServer.getClassLoaderRepository()
      Return the ClassLoaderRepository for this MBeanServer.
      static ClassLoaderRepository MBeanServerFactory.getClassLoaderRepository(MBeanServer server)
      Return the ClassLoaderRepository used by the given MBeanServer.

    • Uses of ClassLoaderRepository in javax.management.loading

      Methods in javax.management.loading with parameters of type ClassLoaderRepository
      修饰符与类型 方法与描述
      类<?> MLet.loadClass(String name, ClassLoaderRepository clr)
      Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs.

    • Uses of ClassLoaderRepository in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ClassLoaderRepository
      修饰符与类型 方法与描述
      protected ClassLoaderRepository RequiredModelMBean.getClassLoaderRepository()
      Return the Class Loader Repository used to perform class loading.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ ereeocetn


Uses of Interface javax.management.loading.MLetMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.loading.MLetMBean

  • Packages that use MLetMBean
    软件包 描述
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.

    • Uses of MLetMBean in javax.management.loading

      Classes in javax.management.loading that implement MLetMBean
      修饰符与类型 类与描述
      class  MLet
      Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
      class  PrivateMLet
      An MLet that is not added to the ClassLoaderRepository.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l玲了∷冕北栓�/薿ɡ/bfn


Uses of Interface javax.management.loading.PrivateClassLoader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.loading.PrivateClassLoader

  • Packages that use PrivateClassLoader
    软件包 描述
    javax.management.loading
    Provides the classes which implement advanced dynamic loading.

    • Uses of PrivateClassLoader in javax.management.loading

      Classes in javax.management.loading that implement PrivateClassLoader
      修饰符与类型 类与描述
      class  PrivateMLet
      An MLet that is not added to the ClassLoaderRepository.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d dau uod,nog 家迕闺ぜl


DescriptorSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 DescriptorSupport

  • java.lang.Object
    • javax.management.modelmbean.DescriptorSupport
  • 所有已实现的接口：
    Serializable, Cloneable, Descriptor

    public class DescriptorSupport
extends Object
implements Descriptor
    This class represents the metadata set for a ModelMBean element. A descriptor is part of the ModelMBeanInfo, ModelMBeanNotificationInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, and ModelMBeanParameterInfo.

    A descriptor consists of a collection of fields. Each field is in fieldname=fieldvalue format. Field names are not case sensitive, case will be preserved on field values.

    All field names and values are not predefined. New fields can be defined and added by any program. Some fields have been predefined for consistency of implementation and support by the ModelMBeanInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, ModelMBeanNotificationInfo, ModelMBeanOperationInfo and ModelMBean classes.

    The serialVersionUID of this class is -6292969195866300415L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DescriptorSupport()
      Descriptor default constructor.
      DescriptorSupport(DescriptorSupport inDescr)
      Descriptor constructor taking a Descriptor as parameter.
      DescriptorSupport(int initNumFields)
      Descriptor constructor.
      DescriptorSupport(String... fields)
      Constructor taking fields in the fieldName=fieldValue format.
      DescriptorSupport(String inStr)
      Descriptor constructor taking an XML String.
      DescriptorSupport(String[] fieldNames, Object[] fieldValues)
      Constructor taking field names and field values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Returns a new Descriptor which is a duplicate of the Descriptor.
      boolean equals(Object o)
      Compares this descriptor to the given object.
      String[] getFieldNames()
      Returns all the field names in the descriptor.
      String[] getFields()
      Returns all of the fields contained in this descriptor as a string array.
      Object getFieldValue(String fieldName)
      Returns the value for a specific field name, or null if no value is present for that name.
      Object[] getFieldValues(String... fieldNames)
      Returns all the field values in the descriptor as an array of Objects.
      int hashCode()
      Returns the hash code value for this descriptor.
      boolean isValid()
      Returns true if all of the fields have legal values given their names.
      void removeField(String fieldName)
      Removes a field from the descriptor.
      void setField(String fieldName, Object fieldValue)
      Sets the value for a specific field name.
      void setFields(String[] fieldNames, Object[] fieldValues)
      Sets all fields in the field names array to the new value with the same index in the field values array.
      String toString()
      Returns a human readable string representing the descriptor.
      String toXMLString()
      Returns an XML String representing the descriptor.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DescriptorSupport

        public DescriptorSupport()
        Descriptor default constructor. Default initial descriptor size is 20. It will grow as needed.
        Note that the created empty descriptor is not a valid descriptor (the method isValid returns false)

      • DescriptorSupport

        public DescriptorSupport(int initNumFields)
                  throws MBeanException,
                         RuntimeOperationsException
        Descriptor constructor. Takes as parameter the initial capacity of the Map that stores the descriptor fields. Capacity will grow as needed.
        Note that the created empty descriptor is not a valid descriptor (the method isValid returns false).
        参数：
        initNumFields - The initial capacity of the Map that stores the descriptor fields.
        抛出：
        RuntimeOperationsException - for illegal value for initNumFields (<= 0)
        MBeanException - Wraps a distributed communication Exception.

      • DescriptorSupport

        public DescriptorSupport(DescriptorSupport inDescr)
        Descriptor constructor taking a Descriptor as parameter. Creates a new descriptor initialized to the values of the descriptor passed in parameter.
        参数：
        inDescr - the descriptor to be used to initialize the constructed descriptor. If it is null or contains no descriptor fields, an empty Descriptor will be created.

      • DescriptorSupport

        public DescriptorSupport(String inStr)
                  throws MBeanException,
                         RuntimeOperationsException,
                         XMLParseException

        Descriptor constructor taking an XML String.

        The format of the XML string is not defined, but an implementation must ensure that the string returned by toXMLString() on an existing descriptor can be used to instantiate an equivalent descriptor using this constructor.

        In this implementation, all field values will be created as Strings. If the field values are not Strings, the programmer will have to reset or convert these fields correctly.

        参数：
        inStr - An XML-formatted string used to populate this Descriptor. The format is not defined, but any implementation must ensure that the string returned by method toXMLString on an existing descriptor can be used to instantiate an equivalent descriptor when instantiated using this constructor.
        抛出：
        RuntimeOperationsException - If the String inStr passed in parameter is null
        XMLParseException - XML parsing problem while parsing the input String
        MBeanException - Wraps a distributed communication Exception.

      • DescriptorSupport

        public DescriptorSupport(String[] fieldNames,
                 Object[] fieldValues)
                  throws RuntimeOperationsException
        Constructor taking field names and field values. Neither array can be null.
        参数：
        fieldNames - String array of field names. No elements of this array can be null.
        fieldValues - Object array of the corresponding field values. Elements of the array can be null. The fieldValue must be valid for the fieldName (as defined in method isValid)

        Note: array sizes of parameters should match. If both arrays are empty, then an empty descriptor is created.

        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. The array lengths must be equal. If the descriptor construction fails for any reason, this exception will be thrown.

      • DescriptorSupport

        public DescriptorSupport(String... fields)
        Constructor taking fields in the fieldName=fieldValue format.
        参数：
        fields - String array with each element containing a field name and value. If this array is null or empty, then the default constructor will be executed. Null strings or empty strings will be ignored.

        All field values should be Strings. If the field values are not Strings, the programmer will have to reset or convert these fields correctly.

        Note: Each string should be of the form fieldName=fieldValue. The field name ends at the first = character; for example if the String is a=b=c then the field name is a and its value is b=c.

        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. The field must contain an "=". "=fieldValue", "fieldName", and "fieldValue" are illegal. FieldName cannot be null. "fieldName=" will cause the value to be null. If the descriptor construction fails for any reason, this exception will be thrown.

    • 方法详细信息

      • getFieldValue

        public Object getFieldValue(String fieldName)
                     throws RuntimeOperationsException
        从接口复制的描述： Descriptor
        Returns the value for a specific field name, or null if no value is present for that name.
        指定者：
        getFieldValue in interface Descriptor
        参数：
        fieldName - the field name.
        返回：
        the corresponding value, or null if the field is not present.
        抛出：
        RuntimeOperationsException - if the field name is illegal.

      • setField

        public void setField(String fieldName,
            Object fieldValue)
              throws RuntimeOperationsException
        从接口复制的描述： Descriptor

        Sets the value for a specific field name. This will modify an existing field or add a new field.

        The field value will be validated before it is set. If it is not valid, then an exception will be thrown. The meaning of validity is dependent on the descriptor implementation.

        指定者：
        setField in interface Descriptor
        参数：
        fieldName - The field name to be set. Cannot be null or empty.
        fieldValue - The field value to be set for the field name. Can be null if that is a valid value for the field.
        抛出：
        RuntimeOperationsException - if the field name or field value is illegal (wrapped exception is IllegalArgumentException); or if the descriptor is immutable (wrapped exception is UnsupportedOperationException).

      • getFields

        public String[] getFields()
        从接口复制的描述： Descriptor
        Returns all of the fields contained in this descriptor as a string array.
        指定者：
        getFields in interface Descriptor
        返回：
        String array of fields in the format fieldName=fieldValue
        If the value of a field is not a String, then the toString() method will be called on it and the returned value, enclosed in parentheses, used as the value for the field in the returned array. If the value of a field is null, then the value of the field in the returned array will be empty. If the descriptor is empty, you will get an empty array.
        另请参见：
        Descriptor.setFields(java.lang.String[], java.lang.Object[])

      • getFieldNames

        public String[] getFieldNames()
        从接口复制的描述： Descriptor
        Returns all the field names in the descriptor.
        指定者：
        getFieldNames in interface Descriptor
        返回：
        String array of field names. If the descriptor is empty, you will get an empty array.

      • getFieldValues

        public Object[] getFieldValues(String... fieldNames)
        从接口复制的描述： Descriptor
        Returns all the field values in the descriptor as an array of Objects. The returned values are in the same order as the fieldNames String array parameter.
        指定者：
        getFieldValues in interface Descriptor
        参数：
        fieldNames - String array of the names of the fields that the values should be returned for. If the array is empty then an empty array will be returned. If the array is null then all values will be returned, as if the parameter were the array returned by Descriptor.getFieldNames(). If a field name in the array does not exist, including the case where it is null or the empty string, then null is returned for the matching array element being returned.
        返回：
        Object array of field values. If the list of fieldNames is empty, you will get an empty array.

      • setFields

        public void setFields(String[] fieldNames,
             Object[] fieldValues)
               throws RuntimeOperationsException
        从接口复制的描述： Descriptor

        Sets all fields in the field names array to the new value with the same index in the field values array. Array sizes must match.

        The field value will be validated before it is set. If it is not valid, then an exception will be thrown. If the arrays are empty, then no change will take effect.

        指定者：
        setFields in interface Descriptor
        参数：
        fieldNames - String array of field names. The array and array elements cannot be null.
        fieldValues - Object array of the corresponding field values. The array cannot be null. Elements of the array can be null.
        抛出：
        RuntimeOperationsException - if the change fails for any reason. Wrapped exception is IllegalArgumentException if fieldNames or fieldValues is null, or if the arrays are of different lengths, or if there is an illegal value in one of them. Wrapped exception is UnsupportedOperationException if the descriptor is immutable, and the call would change its contents.
        另请参见：
        Descriptor.getFields()

      • clone

        public Object clone()
             throws RuntimeOperationsException
        Returns a new Descriptor which is a duplicate of the Descriptor.
        指定者：
        clone in interface Descriptor
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor construction fails for any reason, this exception will be thrown.
        另请参见：
        Cloneable

      • removeField

        public void removeField(String fieldName)
        从接口复制的描述： Descriptor
        Removes a field from the descriptor.
        指定者：
        removeField in interface Descriptor
        参数：
        fieldName - String name of the field to be removed. If the field name is illegal or the field is not found, no exception is thrown.

      • equals

        public boolean equals(Object o)
        Compares this descriptor to the given object. The objects are equal if the given object is also a Descriptor, and if the two Descriptors have the same field names (possibly differing in case) and the same associated values. The respective values for a field in the two Descriptors are equal if the following conditions hold:

        • If one value is null then the other must be too.
        • If one value is a primitive array then the other must be a primitive array of the same type with the same elements.
        • If one value is an object array then the other must be too and Arrays.deepEquals must return true.
        • Otherwise Object.equals(Object) must return true.
        指定者：
        equals in interface Descriptor
        重载：
        equals in class Object
        参数：
        o - the object to compare with.
        返回：
        true if the objects are the same; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this descriptor. The hash code is computed as the sum of the hash codes for each field in the descriptor. The hash code of a field with name n and value v is n.toLowerCase().hashCode() ^ h. Here h is the hash code of v, computed as follows:

        • If v is null then h is 0.
        • If v is a primitive array then h is computed using the appropriate overloading of java.util.Arrays.hashCode.
        • If v is an object array then h is computed using Arrays.deepHashCode.
        • Otherwise h is v.hashCode().
        指定者：
        hashCode in interface Descriptor
        重载：
        hashCode in class Object
        返回：
        A hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • isValid

        public boolean isValid()
                throws RuntimeOperationsException
        Returns true if all of the fields have legal values given their names.

        This implementation does not support interoperating with a directory or lookup service. Thus, conforming to the specification, no checking is done on the "export" field.

        Otherwise this implementation returns false if:

        • name and descriptorType fieldNames are not defined, or null, or empty, or not String
        • class, role, getMethod, setMethod fieldNames, if defined, are null or not String
        • persistPeriod, currencyTimeLimit, lastUpdatedTimeStamp, lastReturnedTimeStamp if defined, are null, or not a Numeric String or not a Numeric Value >= -1
        • log fieldName, if defined, is null, or not a Boolean or not a String with value "t", "f", "true", "false". These String values must not be case sensitive.
        • visibility fieldName, if defined, is null, or not a Numeric String or a not Numeric Value >= 1 and <= 4
        • severity fieldName, if defined, is null, or not a Numeric String or not a Numeric Value >= 0 and <= 6
        • persistPolicy fieldName, if defined, is null, or not one of the following strings:
          "OnUpdate", "OnTimer", "NoMoreOftenThan", "OnUnregister", "Always", "Never". These String values must not be case sensitive.
        指定者：
        isValid in interface Descriptor
        返回：
        true if the values are legal.
        抛出：
        RuntimeOperationsException - If the validity checking fails for any reason, this exception will be thrown.

      • toXMLString

        public String toXMLString()

        Returns an XML String representing the descriptor.

        The format is not defined, but an implementation must ensure that the string returned by this method can be used to build an equivalent descriptor when instantiated using the constructor DescriptorSupport(String inStr).

        Fields which are not String objects will have toString() called on them to create the value. The value will be enclosed in parentheses. It is not guaranteed that you can reconstruct these objects unless they have been specifically set up to support toString() in a meaningful format and have a matching constructor that accepts a String in the same format.

        If the descriptor is empty the following String is returned: <Descriptor></Descriptor>

        返回：
        the XML string.
        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. If the XML formatted string construction fails for any reason, this exception will be thrown.

      • toString

        public String toString()
        Returns a human readable string representing the descriptor. The string will be in the format of "fieldName=fieldValue,fieldName2=fieldValue2,..."
        If there are no fields in the descriptor, then an empty String is returned.
        If a fieldValue is an object then the toString() method is called on it and its returned value is used as the value for the field enclosed in parenthesis.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor string fails for any reason, this exception will be thrown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidTargetObjectTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.modelmbean

类 InvalidTargetObjectTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.modelmbean.InvalidTargetObjectTypeException
  • 所有已实现的接口：
    Serializable

    public class InvalidTargetObjectTypeException
extends Exception
    Exception thrown when an invalid target object type is specified.

    The serialVersionUID of this class is 1190536278266811217L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidTargetObjectTypeException()
      Default constructor.
      InvalidTargetObjectTypeException(Exception e, String s)
      Constructor taking an exception and a string.
      InvalidTargetObjectTypeException(String s)
      Constructor from a string.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidTargetObjectTypeException

        public InvalidTargetObjectTypeException()
        Default constructor.

      • InvalidTargetObjectTypeException

        public InvalidTargetObjectTypeException(String s)
        Constructor from a string.
        参数：
        s - String value that will be incorporated in the message for this exception.

      • InvalidTargetObjectTypeException

        public InvalidTargetObjectTypeException(Exception e,
                                String s)
        Constructor taking an exception and a string.
        参数：
        e - Exception that we may have caught to reissue as an InvalidTargetObjectTypeException. The message will be used, and we may want to consider overriding the printStackTrace() methods to get data pointing back to original throw stack.
        s - String value that will be incorporated in message for this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ tv><<.<


javax.management.modelmbean

Interfaces

  • ModelMBean
  • ModelMBeanInfo
  • ModelMBeanNotificationBroadcaster

Classes

  • DescriptorSupport
  • ModelMBeanAttributeInfo
  • ModelMBeanConstructorInfo
  • ModelMBeanInfoSupport
  • ModelMBeanNotificationInfo
  • ModelMBeanOperationInfo
  • RequiredModelMBean

Exceptions

  • InvalidTargetObjectTypeException
  • XMLParseException
n


javax.management.modelmbean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.modelmbean

Provides the definition of the ModelMBean classes.

请参见： 描述

  • 接口摘要
    接口 描述
    ModelMBean
    This interface must be implemented by the ModelMBeans.
    ModelMBeanInfo
    This interface is implemented by the ModelMBeanInfo for every ModelMBean.
    ModelMBeanNotificationBroadcaster
    This interface must be implemented by the ModelMBeans.
  • Class Summary
    类 描述
    DescriptorSupport
    This class represents the metadata set for a ModelMBean element.
    ModelMBeanAttributeInfo
    The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
    ModelMBeanConstructorInfo
    The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
    ModelMBeanInfoSupport
    This class represents the meta data for ModelMBeans.
    ModelMBeanNotificationInfo
    The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
    ModelMBeanOperationInfo
    The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.
    RequiredModelMBean
    This class is the implementation of a ModelMBean.
  • Exception Summary
    Exception 描述
    InvalidTargetObjectTypeException
    Exception thrown when an invalid target object type is specified.
    XMLParseException
    This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects.

软件包 javax.management.modelmbean Description

Provides the definition of the ModelMBean classes. A Model MBean is an MBean that acts as a bridge between the management interface and the underlying managed resource. Both the management interface and the managed resource are specified as Java objects. The same Model MBean implementation can be reused many times with different management interfaces and managed resources, and it can provide common functionality such as persistence and caching.

A Model MBean implements the ModelMBean interface. It is a DynamicMBean whose getMBeanInfo method returns an object implementing ModelMBeanInfo.

Every MBean has an MBeanInfo with information about the MBean itself, and its attributes, operations, constructors, and notifications. A Model MBean augments this MBeanInfo with Descriptors that encode additional information in the form of (key,value) pairs. Usually, Descriptors are instances of DescriptorSupport.

The class RequiredModelMBean provides a standard Model MBean implementation.

The following example shows a Model MBean being used to make the get method of a HashMap available for management through an MBean server. No other methods are available through the MBean server. There is nothing special about HashMap here. Public methods from any public class can be exposed for management in the same way.

import java.lang.reflect.Method;
import java.util.HashMap;
import javax.management.*;
import javax.management.modelmbean.*;

// ...

MBeanServer mbs = MBeanServerFactory.createMBeanServer();
// The MBean Server

HashMap map = new HashMap();
// The resource that will be managed

// Construct the management interface for the Model MBean
Method getMethod = HashMap.class.getMethod("get", new Class[] {Object.class});
ModelMBeanOperationInfo getInfo =
    new ModelMBeanOperationInfo("Get value for key", getMethod);
ModelMBeanInfo mmbi =
    new ModelMBeanInfoSupport(HashMap.class.getName(),
                              "Map of keys and values",
                              null,  // no attributes
                              null,  // no constructors
                              new ModelMBeanOperationInfo[] {getInfo},
                              null); // no notifications

// Make the Model MBean and link it to the resource
ModelMBean mmb = new RequiredModelMBean(mmbi);
mmb.setManagedResource(map, "ObjectReference");

// Register the Model MBean in the MBean Server
ObjectName mapName = new ObjectName(":type=Map,name=whatever");
mbs.registerMBean(mmb, mapName);

// Resource can evolve independently of the MBean
map.put("key", "value");

// Can access the "get" method through the MBean Server
mbs.invoke(mapName, "get", new Object[] {"key"}, new String[] {Object.class.getName()});
// returns "value"

软件包 Specification

  • See the JMX 1.4 Specification PDF document available from the Java SE 6 Platform documentation on JMX
从以下版本开始：
1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aaave"osac"epbe>


javax.management.modelmbean Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.modelmbean

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanAttributeInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanConstructorInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanNotificationInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo)
    • javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.modelmbean.InvalidTargetObjectTypeException
        • javax.management.modelmbean.XMLParseException

Interface Hierarchy

  • javax.management.DynamicMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • javax.management.modelmbean.ModelMBeanInfo
  • javax.management.NotificationBroadcaster
    • javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.PersistentMBean)
  • javax.management.PersistentMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aiy.kiytedpei s ssmd


ModelMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.modelmbean

Interface ModelMBean

  • All Superinterfaces:
    DynamicMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, PersistentMBean
    All Known Implementing Classes:
    RequiredModelMBean

    public interface ModelMBean
extends DynamicMBean, PersistentMBean, ModelMBeanNotificationBroadcaster
    This interface must be implemented by the ModelMBeans. An implementation of this interface must be shipped with every JMX Agent.

    Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo (with Descriptors) for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the ModelMBeanInfo Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in an XML formatted file or dynamically and programmatically at runtime.

    Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid.

    MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrapping exceptions from distributed communications (RMI, EJB, etc.). These exceptions do not have to be thrown by the implementation except in the scenarios described in the specification and javadoc.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
      void setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.

      • 方法 - 继承于接口 javax.management.DynamicMBean

        getAttribute, getAttributes, getMBeanInfo, invoke, setAttribute, setAttributes

      • 方法 - 继承于接口 javax.management.PersistentMBean

        load, store

      • 方法 - 继承于接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster

        addAttributeChangeNotificationListener, removeAttributeChangeNotificationListener, sendAttributeChangeNotification, sendAttributeChangeNotification, sendNotification, sendNotification

      • 方法 - 继承于接口 javax.management.NotificationBroadcaster

        addNotificationListener, getNotificationInfo, removeNotificationListener

    • 方法详细信息

      • setModelMBeanInfo

        void setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
                       throws MBeanException,
                              RuntimeOperationsException
        Initializes a ModelMBean object using ModelMBeanInfo passed in. This method makes it possible to set a customized ModelMBeanInfo on the ModelMBean as long as it is not registered with the MBeanServer.
        Once the ModelMBean's ModelMBeanInfo (with Descriptors) are customized and set on the ModelMBean, the ModelMBean can be registered with the MBeanServer.

        If the ModelMBean is currently registered, this method throws a RuntimeOperationsException wrapping an IllegalStateException

        参数：
        inModelMBeanInfo - The ModelMBeanInfo object to be used by the ModelMBean.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException -
        • Wraps an IllegalArgumentException if the MBeanInfo passed in parameter is null.
        • Wraps an IllegalStateException if the ModelMBean is currently registered in the MBeanServer.

      • setManagedResource

        void setManagedResource(Object mr,
                      String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
        Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
        参数：
        mr - Object that is the managed resource
        mr_type - The type of reference for the managed resource. Can be: ObjectReference, Handle, IOR, EJBHandle, RMIReference. If the MBeanServer cannot process the mr_type passed in, an InvalidTargetTypeException will be thrown.
        抛出：
        MBeanException - The initializer of the object has thrown an exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The managed resource type passed in parameter is null.
        InstanceNotFoundException - The managed resource object could not be found
        InvalidTargetObjectTypeException - The managed resource type cannot be processed by the ModelMBean or JMX Agent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t觛bee葀nrlhn"l謈�<. 穌祎


ModelMBeanAttributeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 ModelMBeanAttributeInfo

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanAttributeInfo
        • javax.management.modelmbean.ModelMBeanAttributeInfo
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorAccess, DescriptorRead

    public class ModelMBeanAttributeInfo
extends MBeanAttributeInfo
implements DescriptorAccess

    The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean. It is a subclass of MBeanAttributeInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

    The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

    Name | Type | Meaning
    name | String | Attribute name.
    descriptorType | String | Must be "attribute".
    value | Object | Current (cached) value for attribute.
    default | Object | Default value for attribute.
    displayName | String | Name of attribute to be used in displays.
    getMethod | String | Name of operation descriptor for get method.
    setMethod | String | Name of operation descriptor for set method.
    protocolMap | Descriptor | See the section "Protocol Map Support" in the JMX specification document. Mappings must be appropriate for the attribute and entries can be updated or augmented at runtime.
    persistPolicy | String | One of: OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never. See the section "MBean Descriptor Fields" in the JMX specification document.
    persistPeriod | Number | Frequency of persist cycle in seconds. Used when persistPolicy is "OnTimer" or "NoMoreOftenThan".
    currencyTimeLimit | Number | How long value is valid: <0 never, =0 always, >0 seconds.
    lastUpdatedTimeStamp | Number | When value was set.
    visibility | Number | 1-4 where 1: always visible, 4: rarely visible.
    presentationString | String | XML formatted string to allow presentation of data.

    The default descriptor contains the name, descriptorType and displayName fields. The default value of the name and displayName fields is the name of the attribute.

    Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

    The serialVersionUID of this class is 6181543027787327345L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
      Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object.
      ModelMBeanAttributeInfo(String name, String description, 方法 getter, 方法 setter)
      Constructs a ModelMBeanAttributeInfo object with a default descriptor.
      ModelMBeanAttributeInfo(String name, String description, 方法 getter, 方法 setter, Descriptor descriptor)
      Constructs a ModelMBeanAttributeInfo object.
      ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
      Constructs a ModelMBeanAttributeInfo object with a default descriptor.
      ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs a ModelMBeanAttributeInfo object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
      Descriptor getDescriptor()
      Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.
      void setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor.
      String toString()
      Returns a human-readable version of the ModelMBeanAttributeInfo instance.

      • 方法 - 继承于类 javax.management.MBeanAttributeInfo

        equals, getType, hashCode, isIs, isReadable, isWritable

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ModelMBeanAttributeInfo

        public ModelMBeanAttributeInfo(String name,
                       String description,
                       方法 getter,
                       方法 setter)
                        throws IntrospectionException
        Constructs a ModelMBeanAttributeInfo object with a default descriptor. The Descriptor of the constructed object will include fields contributed by any annotations on the Method objects that contain the DescriptorKey meta-annotation.
        参数：
        name - The name of the attribute.
        描述 - A human readable description of the attribute. Optional.
        getter - The method used for reading the attribute value. May be null if the property is write-only.
        setter - The method used for writing the attribute value. May be null if the attribute is read-only.
        抛出：
        IntrospectionException - There is a consistency problem in the definition of this attribute.

      • ModelMBeanAttributeInfo

        public ModelMBeanAttributeInfo(String name,
                       String description,
                       方法 getter,
                       方法 setter,
                       Descriptor descriptor)
                        throws IntrospectionException
        Constructs a ModelMBeanAttributeInfo object. The Descriptor of the constructed object will include fields contributed by any annotations on the Method objects that contain the DescriptorKey meta-annotation.
        参数：
        name - The name of the attribute.
        描述 - A human readable description of the attribute. Optional.
        getter - The method used for reading the attribute value. May be null if the property is write-only.
        setter - The method used for writing the attribute value. May be null if the attribute is read-only.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the Attribute. If it is null, then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
        抛出：
        IntrospectionException - There is a consistency problem in the definition of this attribute.
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "descriptorType" is not equal to "attribute".

      • ModelMBeanAttributeInfo

        public ModelMBeanAttributeInfo(String name,
                       String type,
                       String description,
                       boolean isReadable,
                       boolean isWritable,
                       boolean isIs)
        Constructs a ModelMBeanAttributeInfo object with a default descriptor.
        参数：
        name - The name of the attribute
        type - The type or class name of the attribute
        描述 - A human readable description of the attribute.
        isReadable - True if the attribute has a getter method, false otherwise.
        isWritable - True if the attribute has a setter method, false otherwise.
        isIs - True if the attribute has an "is" getter, false otherwise.

      • ModelMBeanAttributeInfo

        public ModelMBeanAttributeInfo(String name,
                       String type,
                       String description,
                       boolean isReadable,
                       boolean isWritable,
                       boolean isIs,
                       Descriptor descriptor)
        Constructs a ModelMBeanAttributeInfo object.
        参数：
        name - The name of the attribute
        type - The type or class name of the attribute
        描述 - A human readable description of the attribute.
        isReadable - True if the attribute has a getter method, false otherwise.
        isWritable - True if the attribute has a setter method, false otherwise.
        isIs - True if the attribute has an "is" getter, false otherwise.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the Attribute. If it is null then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "descriptorType" is not equal to "attribute".

      • ModelMBeanAttributeInfo

        public ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
        Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object. A default descriptor will be created.
        参数：
        inInfo - the ModelMBeanAttributeInfo to be duplicated

    • 方法详细信息

      • getDescriptor

        public Descriptor getDescriptor()
        Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.
        指定者：
        getDescriptor in interface DescriptorRead
        重载：
        getDescriptor in class MBeanFeatureInfo
        返回：
        Descriptor associated with the ModelMBeanAttributeInfo object.
        另请参见：
        setDescriptor(javax.management.Descriptor)

      • setDescriptor

        public void setDescriptor(Descriptor inDescriptor)
        Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor. If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.
        指定者：
        setDescriptor in interface DescriptorAccess
        参数：
        inDescriptor - replaces the Descriptor associated with the ModelMBeanAttributeInfo
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for an invalid Descriptor
        另请参见：
        getDescriptor()

      • clone

        public Object clone()
        Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
        重载：
        clone in class MBeanAttributeInfo
        返回：
        a clone of this instance.
        抛出：
        RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor construction fails for any reason, this exception will be thrown.
        另请参见：
        Cloneable

      • toString

        public String toString()
        Returns a human-readable version of the ModelMBeanAttributeInfo instance.
        重载：
        toString in class MBeanAttributeInfo
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ModelMBeanConstructorInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 ModelMBeanConstructorInfo

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanConstructorInfo
        • javax.management.modelmbean.ModelMBeanConstructorInfo
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorAccess, DescriptorRead

    public class ModelMBeanConstructorInfo
extends MBeanConstructorInfo
implements DescriptorAccess

    The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean. It is a subclass of MBeanConstructorInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

    The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

    Name | Type | Meaning
    name | String | Constructor name.
    descriptorType | String | Must be "operation".
    role | String | Must be "constructor".
    displayName | String | Human readable name of constructor.
    visibility | Number | 1-4 where 1: always visible 4: rarely visible.
    presentationString | String | XML formatted string to describe how to present operation

    The persistPolicy and currencyTimeLimit fields are meaningless for constructors, but are not considered invalid.

    The default descriptor will have the name, descriptorType, displayName and role fields.

    The serialVersionUID of this class is 3862947819818064362L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModelMBeanConstructorInfo(String description, Constructor<?> constructorMethod)
      Constructs a ModelMBeanConstructorInfo object with a default descriptor.
      ModelMBeanConstructorInfo(String description, Constructor<?> constructorMethod, Descriptor descriptor)
      Constructs a ModelMBeanConstructorInfo object.
      ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
      Constructs a ModelMBeanConstructorInfo object with a default descriptor.
      ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs a ModelMBeanConstructorInfo object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
      Descriptor getDescriptor()
      Returns a copy of the associated Descriptor.
      void setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo.
      String toString()
      Returns a string containing the entire contents of the ModelMBeanConstructorInfo in human readable form.

      • 方法 - 继承于类 javax.management.MBeanConstructorInfo

        equals, getSignature, hashCode

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ModelMBeanConstructorInfo

        public ModelMBeanConstructorInfo(String description,
                         Constructor<?> constructorMethod)
        Constructs a ModelMBeanConstructorInfo object with a default descriptor. The Descriptor of the constructed object will include fields contributed by any annotations on the Constructor object that contain the DescriptorKey meta-annotation.
        参数：
        描述 - A human readable description of the constructor.
        constructorMethod - The java.lang.reflect.Constructor object describing the MBean constructor.

      • ModelMBeanConstructorInfo

        public ModelMBeanConstructorInfo(String description,
                         Constructor<?> constructorMethod,
                         Descriptor descriptor)
        Constructs a ModelMBeanConstructorInfo object. The Descriptor of the constructed object will include fields contributed by any annotations on the Constructor object that contain the DescriptorKey meta-annotation.
        参数：
        描述 - A human readable description of the constructor.
        constructorMethod - The java.lang.reflect.Constructor object describing the ModelMBean constructor.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the ModelMBeanConstructorInfo. If it is null, then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "descriptorType" is not equal to "operation" or descriptor field "role" is present but not equal to "constructor".

      • ModelMBeanConstructorInfo

        public ModelMBeanConstructorInfo(String name,
                         String description,
                         MBeanParameterInfo[] signature)
        Constructs a ModelMBeanConstructorInfo object with a default descriptor.
        参数：
        name - The name of the constructor.
        描述 - A human readable description of the constructor.
        signature - MBeanParameterInfo object array describing the parameters(arguments) of the constructor.

      • ModelMBeanConstructorInfo

        public ModelMBeanConstructorInfo(String name,
                         String description,
                         MBeanParameterInfo[] signature,
                         Descriptor descriptor)
        Constructs a ModelMBeanConstructorInfo object.
        参数：
        name - The name of the constructor.
        描述 - A human readable description of the constructor.
        signature - MBeanParameterInfo objects describing the parameters(arguments) of the constructor.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the MBeanConstructorInfo. If it is null then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "descriptorType" is not equal to "operation" or descriptor field "role" is present but not equal to "constructor".

    • 方法详细信息

      • clone

        public Object clone()
        Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
        重载：
        clone in class MBeanConstructorInfo
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • getDescriptor

        public Descriptor getDescriptor()
        Returns a copy of the associated Descriptor.
        指定者：
        getDescriptor in interface DescriptorRead
        重载：
        getDescriptor in class MBeanFeatureInfo
        返回：
        Descriptor associated with the ModelMBeanConstructorInfo object.
        另请参见：
        setDescriptor(javax.management.Descriptor)

      • setDescriptor

        public void setDescriptor(Descriptor inDescriptor)
        Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo. If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.
        指定者：
        setDescriptor in interface DescriptorAccess
        参数：
        inDescriptor - replaces the Descriptor associated with the ModelMBeanConstructor. If the descriptor does not contain all the following fields, the missing ones are added with their default values: displayName, name, role, descriptorType.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is present but not equal to name parameter, or descriptor field "descriptorType" is present but not equal to "operation" or descriptor field "role" is present but not equal to "constructor".
        另请参见：
        getDescriptor()

      • toString

        public String toString()
        Returns a string containing the entire contents of the ModelMBeanConstructorInfo in human readable form.
        重载：
        toString in class MBeanConstructorInfo
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g h -cdaoda/>>a//tonneemxpsEEooonttmlhhnslpl=>".r


ModelMBeanInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.modelmbean

Interface ModelMBeanInfo

  • All Known Implementing Classes:
    ModelMBeanInfoSupport

    public interface ModelMBeanInfo
    This interface is implemented by the ModelMBeanInfo for every ModelMBean. An implementation of this interface must be shipped with every JMX Agent.

    Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo and Descriptors for the ModelMBean instance. The attributes, operations, and notifications exposed via the ModelMBeanInfo for the ModelMBean comprise the management interface and are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in a file or dynamically and programmatically at runtime.

    Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes, operations, and notifications become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrapping exceptions from distributed communications (RMI, EJB, etc.)

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a copy of this object.
      ModelMBeanAttributeInfo getAttribute(String inName)
      Returns a ModelMBeanAttributeInfo requested by name.
      MBeanAttributeInfo[] getAttributes()
      Returns the list of attributes exposed for management.
      String getClassName()
      Returns the name of the Java class of the MBean described by this MBeanInfo.
      MBeanConstructorInfo[] getConstructors()
      Returns the list of the public constructors of the MBean.
      String getDescription()
      Returns a human readable description of the MBean.
      Descriptor getDescriptor(String inDescriptorName, String inDescriptorType)
      Returns a Descriptor requested by name and descriptorType.
      Descriptor[] getDescriptors(String inDescriptorType)
      Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
      Descriptor getMBeanDescriptor()
      Returns the ModelMBean's descriptor which contains MBean wide policies.
      ModelMBeanNotificationInfo getNotification(String inName)
      Returns a ModelMBeanNotificationInfo requested by name.
      MBeanNotificationInfo[] getNotifications()
      Returns the list of the notifications emitted by the MBean.
      ModelMBeanOperationInfo getOperation(String inName)
      Returns a ModelMBeanOperationInfo requested by name.
      MBeanOperationInfo[] getOperations()
      Returns the list of operations of the MBean.
      void setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
      void setDescriptors(Descriptor[] inDescriptors)
      Adds or replaces descriptors in the ModelMBeanInfo.
      void setMBeanDescriptor(Descriptor inDescriptor)
      Sets the ModelMBean's descriptor.

    • 方法详细信息

      • getDescriptors

        Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
        Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
        参数：
        inDescriptorType - value of descriptorType field that must be set for the descriptor to be returned. Must be "mbean", "attribute", "operation", "constructor" or "notification". If it is null or empty then all types will be returned.
        返回：
        Descriptor array containing all descriptors for the ModelMBean if type inDescriptorType.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException when the descriptorType in parameter is not one of: "mbean", "attribute", "operation", "constructor", "notification", empty or null.
        另请参见：
        setDescriptors(javax.management.Descriptor[])

      • setDescriptors

        void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
        Adds or replaces descriptors in the ModelMBeanInfo.
        参数：
        inDescriptors - The descriptors to be set in the ModelMBeanInfo. Null elements of the list will be ignored. All descriptors must have name and descriptorType fields.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null or invalid descriptor.
        MBeanException - Wraps a distributed communication Exception.
        另请参见：
        getDescriptors(java.lang.String)

      • getDescriptor

        Descriptor getDescriptor(String inDescriptorName,
                       String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
        Returns a Descriptor requested by name and descriptorType.
        参数：
        inDescriptorName - The name of the descriptor.
        inDescriptorType - The type of the descriptor being requested. If this is null or empty then all types are searched. Valid types are 'mbean', 'attribute', 'constructor' 'operation', and 'notification'. This value will be equal to the 'descriptorType' field in the descriptor that is returned.
        返回：
        Descriptor containing the descriptor for the ModelMBean with the same name and descriptorType. If no descriptor is found, null is returned.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null descriptor name or null or invalid type. The type must be "mbean","attribute", "constructor", "operation", or "notification".
        另请参见：
        setDescriptor(javax.management.Descriptor, java.lang.String)

      • setDescriptor

        void setDescriptor(Descriptor inDescriptor,
                 String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
        Sets descriptors in the info array of type inDescriptorType for the ModelMBean. The setDescriptor method of the corresponding ModelMBean*Info will be called to set the specified descriptor.
        参数：
        inDescriptor - The descriptor to be set in the ModelMBean. It must NOT be null. All descriptors must have name and descriptorType fields.
        inDescriptorType - The type of the descriptor being set. If this is null then the descriptorType field in the descriptor is used. If specified this value must be set in the descriptorType field in the descriptor. Must be "mbean","attribute", "constructor", "operation", or "notification".
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for illegal or null arguments or if the name field of the descriptor is not found in the corresponding MBeanAttributeInfo or MBeanConstructorInfo or MBeanNotificationInfo or MBeanOperationInfo.
        MBeanException - Wraps a distributed communication Exception.
        另请参见：
        getDescriptor(java.lang.String, java.lang.String)

      • getMBeanDescriptor

        Descriptor getMBeanDescriptor()
                              throws MBeanException,
                                     RuntimeOperationsException

        Returns the ModelMBean's descriptor which contains MBean wide policies. This descriptor contains metadata about the MBean and default policies for persistence and caching.

        The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

        Name | Type | Meaning
        name | String | MBean name.
        descriptorType | String | Must be "mbean".
        displayName | String | Name of MBean to be used in displays.
        persistPolicy | String | One of: OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never. See the section "MBean Descriptor Fields" in the JMX specification document.
        persistLocation | String | The fully qualified directory name where the MBean should be persisted (if appropriate).
        persistFile | String | File name into which the MBean should be persisted.
        persistPeriod | Number | Frequency of persist cycle in seconds, for OnTime and NoMoreOftenThan PersistPolicy
        currencyTimeLimit | Number | How long cached value is valid: <0 never, =0 always, >0 seconds.
        log | String | t: log all notifications, f: log no notifications.
        logfile | String | Fully qualified filename to log events to.
        visibility | Number | 1-4 where 1: always visible 4: rarely visible.
        export | String | Name to be used to export/expose this MBean so that it is findable by other JMX Agents.
        presentationString | String | XML formatted string to allow presentation of data to be associated with the MBean.

        The default descriptor is: name=className,descriptorType="mbean", displayName=className, persistPolicy="never",log="F",visibility="1" If the descriptor does not contain all these fields, they will be added with these default values.

        Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

        返回：
        the MBean descriptor.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - a RuntimeException occurred while getting the descriptor.
        另请参见：
        setMBeanDescriptor(javax.management.Descriptor)

      • setMBeanDescriptor

        void setMBeanDescriptor(Descriptor inDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
        Sets the ModelMBean's descriptor. This descriptor contains default, MBean wide metadata about the MBean and default policies for persistence and caching. This operation does a complete replacement of the descriptor, no merging is done. If the descriptor to set to is null then the default descriptor will be created. The default descriptor is: name=className,descriptorType="mbean", displayName=className, persistPolicy="never",log="F",visibility="1" If the descriptor does not contain all these fields, they will be added with these default values. See getMBeanDescriptor method javadoc for description of valid field names.
        参数：
        inDescriptor - the descriptor to set.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor.
        另请参见：
        getMBeanDescriptor()

      • getAttribute

        ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
        Returns a ModelMBeanAttributeInfo requested by name.
        参数：
        inName - The name of the ModelMBeanAttributeInfo to get. If no ModelMBeanAttributeInfo exists for this name null is returned.
        返回：
        the attribute info for the named attribute, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null attribute name.

      • getOperation

        ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
        Returns a ModelMBeanOperationInfo requested by name.
        参数：
        inName - The name of the ModelMBeanOperationInfo to get. If no ModelMBeanOperationInfo exists for this name null is returned.
        返回：
        the operation info for the named operation, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null operation name.

      • getNotification

        ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
        Returns a ModelMBeanNotificationInfo requested by name.
        参数：
        inName - The name of the ModelMBeanNotificationInfo to get. If no ModelMBeanNotificationInfo exists for this name null is returned.
        返回：
        the info for the named notification, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null notification name.

      • clone

        Object clone()
        Creates and returns a copy of this object.

      • getAttributes

        MBeanAttributeInfo[] getAttributes()
        Returns the list of attributes exposed for management. Each attribute is described by an MBeanAttributeInfo object.
        返回：
        An array of MBeanAttributeInfo objects.

      • getClassName

        String getClassName()
        Returns the name of the Java class of the MBean described by this MBeanInfo.
        返回：
        the Java class name.

      • getConstructors

        MBeanConstructorInfo[] getConstructors()
        Returns the list of the public constructors of the MBean. Each constructor is described by an MBeanConstructorInfo object.
        返回：
        An array of MBeanConstructorInfo objects.

      • getDescription

        String getDescription()
        Returns a human readable description of the MBean.
        返回：
        the description.

      • getNotifications

        MBeanNotificationInfo[] getNotifications()
        Returns the list of the notifications emitted by the MBean. Each notification is described by an MBeanNotificationInfo object.

        In addition to any notification specified by the application, a ModelMBean may always send also two additional notifications:

        • One with descriptor name "GENERIC" and displayName "jmx.modelmbean.generic"
        • Second is a standard attribute change notification with descriptor name "ATTRIBUTE_CHANGE" and displayName "jmx.attribute.change"
        Thus any implementation of ModelMBeanInfo should always add those two notifications in addition to those specified by the application.
        返回：
        An array of MBeanNotificationInfo objects.

      • getOperations

        MBeanOperationInfo[] getOperations()
        Returns the list of operations of the MBean. Each operation is described by an MBeanOperationInfo object.
        返回：
        An array of MBeanOperationInfo objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


ModelMBeanInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 ModelMBeanInfoSupport

  • java.lang.Object
    • javax.management.MBeanInfo
      • javax.management.modelmbean.ModelMBeanInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, ModelMBeanInfo

    public class ModelMBeanInfoSupport
extends MBeanInfo
implements ModelMBeanInfo
    This class represents the meta data for ModelMBeans. Descriptors have been added on the meta data objects.

    Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo and Descriptors for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in a file or dynamically and programmatically at runtime.

    Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrapping exceptions from distributed communications (RMI, EJB, etc.)

    The serialVersionUID of this class is -1935722590756516193L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModelMBeanInfoSupport(ModelMBeanInfo mbi)
      Constructs a ModelMBeanInfoSupport which is a duplicate of the given ModelMBeanInfo.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
      Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Returns a shallow clone of this instance.
      ModelMBeanAttributeInfo getAttribute(String inName)
      Returns a ModelMBeanAttributeInfo requested by name.
      ModelMBeanConstructorInfo getConstructor(String inName)
      Returns the ModelMBeanConstructorInfo requested by name.
      Descriptor getDescriptor()
      Get the descriptor of this MBeanInfo.
      Descriptor getDescriptor(String inDescriptorName)
      Returns a Descriptor requested by name.
      Descriptor getDescriptor(String inDescriptorName, String inDescriptorType)
      Returns a Descriptor requested by name and descriptorType.
      Descriptor[] getDescriptors(String inDescriptorType)
      Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
      Descriptor getMBeanDescriptor()
      Returns the ModelMBean's descriptor which contains MBean wide policies.
      ModelMBeanNotificationInfo getNotification(String inName)
      Returns a ModelMBeanNotificationInfo requested by name.
      ModelMBeanOperationInfo getOperation(String inName)
      Returns a ModelMBeanOperationInfo requested by name.
      void setDescriptor(Descriptor inDescriptor, String inDescriptorType)
      Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
      void setDescriptors(Descriptor[] inDescriptors)
      Adds or replaces descriptors in the ModelMBeanInfo.
      void setMBeanDescriptor(Descriptor inMBeanDescriptor)
      Sets the ModelMBean's descriptor.

      • 方法 - 继承于类 javax.management.MBeanInfo

        equals, getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.modelmbean.ModelMBeanInfo

        getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

    • 构造方法详细信息

      • ModelMBeanInfoSupport

        public ModelMBeanInfoSupport(ModelMBeanInfo mbi)
        Constructs a ModelMBeanInfoSupport which is a duplicate of the given ModelMBeanInfo. The returned object is a shallow copy of the given object. Neither the Descriptor nor the contained arrays (ModelMBeanAttributeInfo[] etc) are cloned. This method is chiefly of interest to modify the Descriptor of the returned instance via setDescriptor without affecting the Descriptor of the original object.
        参数：
        mbi - the ModelMBeanInfo instance from which the ModelMBeanInfo being created is initialized.

      • ModelMBeanInfoSupport

        public ModelMBeanInfoSupport(String className,
                     String description,
                     ModelMBeanAttributeInfo[] attributes,
                     ModelMBeanConstructorInfo[] constructors,
                     ModelMBeanOperationInfo[] operations,
                     ModelMBeanNotificationInfo[] notifications)
        Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default. The default descriptor is: name=className, descriptorType="mbean", displayName=className, persistPolicy="never", log="F", visibility="1"
        参数：
        className - classname of the MBean
        描述 - human readable description of the ModelMBean
        attributes - array of ModelMBeanAttributeInfo objects which have descriptors
        constructors - array of ModelMBeanConstructorInfo objects which have descriptors
        operations - array of ModelMBeanOperationInfo objects which have descriptors
        notifications - array of ModelMBeanNotificationInfo objects which have descriptors

      • ModelMBeanInfoSupport

        public ModelMBeanInfoSupport(String className,
                     String description,
                     ModelMBeanAttributeInfo[] attributes,
                     ModelMBeanConstructorInfo[] constructors,
                     ModelMBeanOperationInfo[] operations,
                     ModelMBeanNotificationInfo[] notifications,
                     Descriptor mbeandescriptor)
        Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
        参数：
        className - classname of the MBean
        描述 - human readable description of the ModelMBean
        attributes - array of ModelMBeanAttributeInfo objects which have descriptors
        constructors - array of ModelMBeanConstructorInfo objects which have descriptor
        operations - array of ModelMBeanOperationInfo objects which have descriptor
        notifications - array of ModelMBeanNotificationInfo objects which have descriptor
        mbeandescriptor - descriptor to be used as the MBeanDescriptor containing MBean wide policy. If the descriptor is null, a default descriptor will be constructed. The default descriptor is: name=className, descriptorType="mbean", displayName=className, persistPolicy="never", log="F", visibility="1". If the descriptor does not contain all of these fields, the missing ones are added with these default values.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor passed in parameter. (see getMBeanDescriptor for the definition of a valid MBean descriptor.)

    • 方法详细信息

      • clone

        public Object clone()
        Returns a shallow clone of this instance. Neither the Descriptor nor the contained arrays (ModelMBeanAttributeInfo[] etc) are cloned. This method is chiefly of interest to modify the Descriptor of the clone via setDescriptor without affecting the Descriptor of the original object.
        指定者：
        clone in interface ModelMBeanInfo
        重载：
        clone in class MBeanInfo
        返回：
        a shallow clone of this instance.
        另请参见：
        Cloneable

      • getDescriptors

        public Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
        指定者：
        getDescriptors in interface ModelMBeanInfo
        参数：
        inDescriptorType - value of descriptorType field that must be set for the descriptor to be returned. Must be "mbean", "attribute", "operation", "constructor" or "notification". If it is null or empty then all types will be returned.
        返回：
        Descriptor array containing all descriptors for the ModelMBean if type inDescriptorType.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException when the descriptorType in parameter is not one of: "mbean", "attribute", "operation", "constructor", "notification", empty or null.
        另请参见：
        ModelMBeanInfo.setDescriptors(javax.management.Descriptor[])

      • setDescriptors

        public void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Adds or replaces descriptors in the ModelMBeanInfo.
        指定者：
        setDescriptors in interface ModelMBeanInfo
        参数：
        inDescriptors - The descriptors to be set in the ModelMBeanInfo. Null elements of the list will be ignored. All descriptors must have name and descriptorType fields.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null or invalid descriptor.
        另请参见：
        ModelMBeanInfo.getDescriptors(java.lang.String)

      • getDescriptor

        public Descriptor getDescriptor(String inDescriptorName)
                         throws MBeanException,
                                RuntimeOperationsException
        Returns a Descriptor requested by name.
        参数：
        inDescriptorName - The name of the descriptor.
        返回：
        Descriptor containing a descriptor for the ModelMBean with the same name. If no descriptor is found, null is returned.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for null name.
        另请参见：
        setDescriptor(javax.management.Descriptor, java.lang.String)

      • getDescriptor

        public Descriptor getDescriptor(String inDescriptorName,
                       String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Returns a Descriptor requested by name and descriptorType.
        指定者：
        getDescriptor in interface ModelMBeanInfo
        参数：
        inDescriptorName - The name of the descriptor.
        inDescriptorType - The type of the descriptor being requested. If this is null or empty then all types are searched. Valid types are 'mbean', 'attribute', 'constructor' 'operation', and 'notification'. This value will be equal to the 'descriptorType' field in the descriptor that is returned.
        返回：
        Descriptor containing the descriptor for the ModelMBean with the same name and descriptorType. If no descriptor is found, null is returned.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null descriptor name or null or invalid type. The type must be "mbean","attribute", "constructor", "operation", or "notification".
        另请参见：
        ModelMBeanInfo.setDescriptor(javax.management.Descriptor, java.lang.String)

      • setDescriptor

        public void setDescriptor(Descriptor inDescriptor,
                 String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Sets descriptors in the info array of type inDescriptorType for the ModelMBean. The setDescriptor method of the corresponding ModelMBean*Info will be called to set the specified descriptor.
        指定者：
        setDescriptor in interface ModelMBeanInfo
        参数：
        inDescriptor - The descriptor to be set in the ModelMBean. It must NOT be null. All descriptors must have name and descriptorType fields.
        inDescriptorType - The type of the descriptor being set. If this is null then the descriptorType field in the descriptor is used. If specified this value must be set in the descriptorType field in the descriptor. Must be "mbean","attribute", "constructor", "operation", or "notification".
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for illegal or null arguments or if the name field of the descriptor is not found in the corresponding MBeanAttributeInfo or MBeanConstructorInfo or MBeanNotificationInfo or MBeanOperationInfo.
        另请参见：
        ModelMBeanInfo.getDescriptor(java.lang.String, java.lang.String)

      • getAttribute

        public ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Returns a ModelMBeanAttributeInfo requested by name.
        指定者：
        getAttribute in interface ModelMBeanInfo
        参数：
        inName - The name of the ModelMBeanAttributeInfo to get. If no ModelMBeanAttributeInfo exists for this name null is returned.
        返回：
        the attribute info for the named attribute, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null attribute name.

      • getOperation

        public ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Returns a ModelMBeanOperationInfo requested by name.
        指定者：
        getOperation in interface ModelMBeanInfo
        参数：
        inName - The name of the ModelMBeanOperationInfo to get. If no ModelMBeanOperationInfo exists for this name null is returned.
        返回：
        the operation info for the named operation, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null operation name.

      • getConstructor

        public ModelMBeanConstructorInfo getConstructor(String inName)
                                         throws MBeanException,
                                                RuntimeOperationsException
        Returns the ModelMBeanConstructorInfo requested by name. If no ModelMBeanConstructorInfo exists for this name null is returned.
        参数：
        inName - the name of the constructor.
        返回：
        the constructor info for the named constructor, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null constructor name.

      • getNotification

        public ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Returns a ModelMBeanNotificationInfo requested by name.
        指定者：
        getNotification in interface ModelMBeanInfo
        参数：
        inName - The name of the ModelMBeanNotificationInfo to get. If no ModelMBeanNotificationInfo exists for this name null is returned.
        返回：
        the info for the named notification, or null if there is none.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for a null notification name.

      • getDescriptor

        public Descriptor getDescriptor()
        Description copied from class: MBeanInfo
        Get the descriptor of this MBeanInfo. Changing the returned value will have no affect on the original descriptor.
        指定者：
        getDescriptor in interface DescriptorRead
        重载：
        getDescriptor in class MBeanInfo
        返回：
        a descriptor that is either immutable or a copy of the original.
        从以下版本开始：
        1.6

      • getMBeanDescriptor

        public Descriptor getMBeanDescriptor()
                              throws MBeanException
        从接口复制的描述： ModelMBeanInfo

        Returns the ModelMBean's descriptor which contains MBean wide policies. This descriptor contains metadata about the MBean and default policies for persistence and caching.

        The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

        Name | Type | Meaning
        name | String | MBean name.
        descriptorType | String | Must be "mbean".
        displayName | String | Name of MBean to be used in displays.
        persistPolicy | String | One of: OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never. See the section "MBean Descriptor Fields" in the JMX specification document.
        persistLocation | String | The fully qualified directory name where the MBean should be persisted (if appropriate).
        persistFile | String | File name into which the MBean should be persisted.
        persistPeriod | Number | Frequency of persist cycle in seconds, for OnTime and NoMoreOftenThan PersistPolicy
        currencyTimeLimit | Number | How long cached value is valid: <0 never, =0 always, >0 seconds.
        log | String | t: log all notifications, f: log no notifications.
        logfile | String | Fully qualified filename to log events to.
        visibility | Number | 1-4 where 1: always visible 4: rarely visible.
        export | String | Name to be used to export/expose this MBean so that it is findable by other JMX Agents.
        presentationString | String | XML formatted string to allow presentation of data to be associated with the MBean.

        The default descriptor is: name=className,descriptorType="mbean", displayName=className, persistPolicy="never",log="F",visibility="1" If the descriptor does not contain all these fields, they will be added with these default values.

        Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

        指定者：
        getMBeanDescriptor in interface ModelMBeanInfo
        返回：
        the MBean descriptor.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        另请参见：
        ModelMBeanInfo.setMBeanDescriptor(javax.management.Descriptor)

      • setMBeanDescriptor

        public void setMBeanDescriptor(Descriptor inMBeanDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
        从接口复制的描述： ModelMBeanInfo
        Sets the ModelMBean's descriptor. This descriptor contains default, MBean wide metadata about the MBean and default policies for persistence and caching. This operation does a complete replacement of the descriptor, no merging is done. If the descriptor to set to is null then the default descriptor will be created. The default descriptor is: name=className,descriptorType="mbean", displayName=className, persistPolicy="never",log="F",visibility="1" If the descriptor does not contain all these fields, they will be added with these default values. See getMBeanDescriptor method javadoc for description of valid field names.
        指定者：
        setMBeanDescriptor in interface ModelMBeanInfo
        参数：
        inMBeanDescriptor - the descriptor to set.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor.
        另请参见：
        ModelMBeanInfo.getMBeanDescriptor()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


ModelMBeanNotificationBroadcaster

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.modelmbean

Interface ModelMBeanNotificationBroadcaster

  • All Superinterfaces:
    NotificationBroadcaster
    All Known Subinterfaces:
    ModelMBean
    All Known Implementing Classes:
    RequiredModelMBean

    public interface ModelMBeanNotificationBroadcaster
extends NotificationBroadcaster
    This interface must be implemented by the ModelMBeans. An implementation of this interface must be shipped with every JMX Agent.

    Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo (with Descriptors) for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the ModelMBeanInfo Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in an XML formatted file or dynamically and programmatically at runtime.

    Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid.

    MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrapping exceptions from distributed communications (RMI, EJB, etc.). These exceptions do not have to be thrown by the implementation except in the scenarios described in the specification and javadoc.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      void removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName)
      Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
      void sendAttributeChangeNotification(Attribute oldValue, Attribute newValue)
      Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.
      void sendAttributeChangeNotification(AttributeChangeNotification notification)
      Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
      void sendNotification(Notification ntfyObj)
      Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
      void sendNotification(String ntfyText)
      Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.

      • 方法 - 继承于接口 javax.management.NotificationBroadcaster

        addNotificationListener, getNotificationInfo, removeNotificationListener

    • 方法详细信息

      • sendNotification

        void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
        Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
        参数：
        ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification object passed in parameter is null.

      • sendNotification

        void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
        Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
        参数：
        ntfyText - The text which is to be passed in the Notification to the 'handleNotification' method of the listener object. the constructed Notification will be: type "jmx.modelmbean.generic" source this ModelMBean instance sequence 1
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification text string passed in parameter is null.

      • sendAttributeChangeNotification

        void sendAttributeChangeNotification(AttributeChangeNotification notification)
                                     throws MBeanException,
                                            RuntimeOperationsException
        Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
        参数：
        notification - The notification which is to be passed to the 'handleNotification' method of the listener object.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The AttributeChangeNotification object passed in parameter is null.

      • sendAttributeChangeNotification

        void sendAttributeChangeNotification(Attribute oldValue,
                                   Attribute newValue)
                                     throws MBeanException,
                                            RuntimeOperationsException
        Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.

        参数：
        oldValue - The original value for the Attribute
        newValue - The current value for the Attribute

         The constructed attributeChangeNotification will be:
   type        "jmx.attribute.change"
   source      this ModelMBean instance
   sequence    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: An Attribute object passed in parameter is null or the names of the two Attribute objects in parameter are not the same.

      • addAttributeChangeNotificationListener

        void addAttributeChangeNotificationListener(NotificationListener listener,
                                          String attributeName,
                                          Object handback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
        Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any attributeChangeNotification is issued through or by the ModelMBean. This does not include other Notifications. They must be registered for independently. An AttributeChangeNotification will be generated for this attributeName.
        参数：
        listener - The listener object which will handles notifications emitted by the registered MBean.
        attributeName - The name of the ModelMBean attribute for which to receive change notifications. If null, then all attribute changes will cause an attributeChangeNotification to be issued.
        handback - The context to be sent to the listener with the notification when a notification is emitted.
        抛出：
        IllegalArgumentException - The listener cannot be null.
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException The attribute name passed in parameter does not exist.
        另请参见：
        removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

      • removeAttributeChangeNotificationListener

        void removeAttributeChangeNotificationListener(NotificationListener listener,
                                             String attributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
        Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
        参数：
        listener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
        attributeName - The attribute for which the listener no longer wants to receive attributeChangeNotifications. If null the listener will be removed for all attributeChangeNotifications.
        抛出：
        ListenerNotFoundException - The listener is not registered in the MBean or is null.
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException If the inAttributeName parameter does not correspond to an attribute name.
        另请参见：
        addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=a"s, N NsaaNss=p""cbp ls.t i=cdmae


ModelMBeanNotificationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 ModelMBeanNotificationInfo

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanNotificationInfo
        • javax.management.modelmbean.ModelMBeanNotificationInfo
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorAccess, DescriptorRead

    public class ModelMBeanNotificationInfo
extends MBeanNotificationInfo
implements DescriptorAccess

    The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean. It is a subclass of MBeanNotificationInfo with the addition of an associated Descriptor and an implementation of the Descriptor interface.

    The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

    Name | Type | Meaning
    name | String | Notification name.
    descriptorType | String | Must be "notification".
    severity | Number | 0-6 where 0: unknown; 1: non-recoverable; 2: critical, failure; 3: major, severe; 4: minor, marginal, error; 5: warning; 6: normal, cleared, informative
    messageID | String | Unique key for message text (to allow translation, analysis).
    messageText | String | Text of notification.
    log | String | T - log message, F - do not log message.
    logfile | String | fully qualified file name appropriate for operating system.
    visibility | Number | 1-4 where 1: always visible 4: rarely visible.
    presentationString | String | XML formatted string to allow presentation of data.

    The default descriptor contains the name, descriptorType, displayName and severity(=6) fields. The default value of the name and displayName fields is the name of the Notification class (as specified by the name parameter of the ModelMBeanNotificationInfo constructor).

    The serialVersionUID of this class is -7445681389570207141L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
      Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.
      ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
      Constructs a ModelMBeanNotificationInfo object with a default descriptor.
      ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
      Constructs a ModelMBeanNotificationInfo object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
      Descriptor getDescriptor()
      Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.
      void setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
      String toString()
      Returns a human readable string containing ModelMBeanNotificationInfo.

      • 方法 - 继承于类 javax.management.MBeanNotificationInfo

        equals, getNotifTypes, hashCode

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ModelMBeanNotificationInfo

        public ModelMBeanNotificationInfo(String[] notifTypes,
                          String name,
                          String description)
        Constructs a ModelMBeanNotificationInfo object with a default descriptor.
        参数：
        notifTypes - The array of strings (in dot notation) containing the notification types that may be emitted.
        name - The name of the Notification class.
        描述 - A human readable description of the Notification. Optional.

      • ModelMBeanNotificationInfo

        public ModelMBeanNotificationInfo(String[] notifTypes,
                          String name,
                          String description,
                          Descriptor descriptor)
        Constructs a ModelMBeanNotificationInfo object.
        参数：
        notifTypes - The array of strings (in dot notation) containing the notification types that may be emitted.
        name - The name of the Notification class.
        描述 - A human readable description of the Notification. Optional.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the MBeanNotificationInfo. If it is null a default descriptor will be created. If the descriptor does not contain the fields "displayName" or "severity", the missing ones are added with their default values.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to parameter name, or descriptor field "descriptorType" is not equal to "notification".

      • ModelMBeanNotificationInfo

        public ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
        Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.
        参数：
        inInfo - the ModelMBeanNotificationInfo to be duplicated

    • 方法详细信息

      • clone

        public Object clone()
        Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
        重载：
        clone in class MBeanNotificationInfo
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • getDescriptor

        public Descriptor getDescriptor()
        Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.
        指定者：
        getDescriptor in interface DescriptorRead
        重载：
        getDescriptor in class MBeanFeatureInfo
        返回：
        Descriptor associated with the ModelMBeanNotificationInfo object.
        另请参见：
        setDescriptor(javax.management.Descriptor)

      • setDescriptor

        public void setDescriptor(Descriptor inDescriptor)
        Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.
        指定者：
        setDescriptor in interface DescriptorAccess
        参数：
        inDescriptor - replaces the Descriptor associated with the ModelMBeanNotification interface
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for invalid Descriptor.
        另请参见：
        getDescriptor()

      • toString

        public String toString()
        Returns a human readable string containing ModelMBeanNotificationInfo.
        重载：
        toString in class MBeanNotificationInfo
        返回：
        a string describing this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

creal/l:lolna.orlovrr衦b 蠵睵 狱豆<鸼蝌蝏鈚醕.a


ModelMBeanOperationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 ModelMBeanOperationInfo

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanOperationInfo
        • javax.management.modelmbean.ModelMBeanOperationInfo
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorAccess, DescriptorRead

    public class ModelMBeanOperationInfo
extends MBeanOperationInfo
implements DescriptorAccess

    The ModelMBeanOperationInfo object describes a management operation of the ModelMBean. It is a subclass of MBeanOperationInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

    The fields in the descriptor are defined, but not limited to, the following. Note that when the Type in this table is Number, a String that is the decimal representation of a Long can also be used.

    Name | Type | Meaning
    name | String | Operation name.
    descriptorType | String | Must be "operation".
    类 | String | Class where method is defined (fully qualified).
    role | String | Must be "operation", "getter", or "setter".
    targetObject | Object | Object on which to execute this method.
    targetType | String | type of object reference for targetObject. Can be: ObjectReference | Handle | EJBHandle | IOR | RMIReference.
    value | Object | Cached value for operation.
    displayName | String | Human readable display name of the operation.
    currencyTimeLimit | Number | How long cached value is valid.
    lastUpdatedTimeStamp | Number | When cached value was set.
    visibility | Number | 1-4 where 1: always visible 4: rarely visible.
    presentationString | String | XML formatted string to describe how to present operation

    The default descriptor will have name, descriptorType, displayName and role fields set. The default value of the name and displayName fields is the operation name.

    Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

    The serialVersionUID of this class is 6532732096650090465L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanOperationInfo

        ACTION, ACTION_INFO, INFO, UNKNOWN

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
      Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.
      ModelMBeanOperationInfo(String description, 方法 operationMethod)
      Constructs a ModelMBeanOperationInfo object with a default descriptor.
      ModelMBeanOperationInfo(String description, 方法 operationMethod, Descriptor descriptor)
      Constructs a ModelMBeanOperationInfo object.
      ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
      Constructs a ModelMBeanOperationInfo object with a default descriptor.
      ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
      Constructs a ModelMBeanOperationInfo object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
      Descriptor getDescriptor()
      Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.
      void setDescriptor(Descriptor inDescriptor)
      Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
      String toString()
      Returns a string containing the entire contents of the ModelMBeanOperationInfo in human readable form.

      • 方法 - 继承于类 javax.management.MBeanOperationInfo

        equals, getImpact, getReturnType, getSignature, hashCode

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ModelMBeanOperationInfo

        public ModelMBeanOperationInfo(String description,
                       方法 operationMethod)
        Constructs a ModelMBeanOperationInfo object with a default descriptor. The Descriptor of the constructed object will include fields contributed by any annotations on the Method object that contain the DescriptorKey meta-annotation.
        参数：
        operationMethod - The java.lang.reflect.Method object describing the MBean operation.
        描述 - A human readable description of the operation.

      • ModelMBeanOperationInfo

        public ModelMBeanOperationInfo(String description,
                       方法 operationMethod,
                       Descriptor descriptor)
        Constructs a ModelMBeanOperationInfo object. The Descriptor of the constructed object will include fields contributed by any annotations on the Method object that contain the DescriptorKey meta-annotation.
        参数：
        operationMethod - The java.lang.reflect.Method object describing the MBean operation.
        描述 - A human readable description of the operation.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the ModelMBeanOperationInfo. If it is null a default descriptor will be created. If the descriptor does not contain the fields "displayName" or "role", the missing ones are added with their default values.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid; or descriptor field "name" is not equal to operation name; or descriptor field "DescriptorType" is not equal to "operation"; or descriptor optional field "role" is present but not equal to "operation", "getter", or "setter".

      • ModelMBeanOperationInfo

        public ModelMBeanOperationInfo(String name,
                       String description,
                       MBeanParameterInfo[] signature,
                       String type,
                       int impact)
        Constructs a ModelMBeanOperationInfo object with a default descriptor.
        参数：
        name - The name of the method.
        描述 - A human readable description of the operation.
        signature - MBeanParameterInfo objects describing the parameters(arguments) of the method.
        type - The type of the method's return value.
        impact - The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.

      • ModelMBeanOperationInfo

        public ModelMBeanOperationInfo(String name,
                       String description,
                       MBeanParameterInfo[] signature,
                       String type,
                       int impact,
                       Descriptor descriptor)
        Constructs a ModelMBeanOperationInfo object.
        参数：
        name - The name of the method.
        描述 - A human readable description of the operation.
        signature - MBeanParameterInfo objects describing the parameters(arguments) of the method.
        type - The type of the method's return value.
        impact - The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.
        descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the MBeanOperationInfo. If it is null then a default descriptor will be created. If the descriptor does not contain fields "displayName" or "role", the missing ones are added with their default values.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid; or descriptor field "name" is not equal to operation name; or descriptor field "DescriptorType" is not equal to "operation"; or descriptor optional field "role" is present but not equal to "operation", "getter", or "setter".

      • ModelMBeanOperationInfo

        public ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
        Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.
        参数：
        inInfo - the ModelMBeanOperationInfo to be duplicated

    • 方法详细信息

      • clone

        public Object clone()
        Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
        重载：
        clone in class MBeanOperationInfo
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • getDescriptor

        public Descriptor getDescriptor()
        Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.
        指定者：
        getDescriptor in interface DescriptorRead
        重载：
        getDescriptor in class MBeanFeatureInfo
        返回：
        Descriptor associated with the ModelMBeanOperationInfo object.
        另请参见：
        setDescriptor(javax.management.Descriptor)

      • setDescriptor

        public void setDescriptor(Descriptor inDescriptor)
        Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.
        指定者：
        setDescriptor in interface DescriptorAccess
        参数：
        inDescriptor - replaces the Descriptor associated with the ModelMBeanOperation.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException for invalid Descriptor.
        另请参见：
        getDescriptor()

      • toString

        public String toString()
        Returns a string containing the entire contents of the ModelMBeanOperationInfo in human readable form.
        重载：
        toString in class MBeanOperationInfo
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


RequiredModelMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.modelmbean

类 RequiredModelMBean

  • java.lang.Object
    • javax.management.modelmbean.RequiredModelMBean
  • 所有已实现的接口：
    DynamicMBean, MBeanRegistration, ModelMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, NotificationEmitter, PersistentMBean

    public class RequiredModelMBean
extends Object
implements ModelMBean, MBeanRegistration, NotificationEmitter
    This class is the implementation of a ModelMBean. An appropriate implementation of a ModelMBean must be shipped with every JMX Agent and the class must be named RequiredModelMBean.

    Java resources wishing to be manageable instantiate the RequiredModelMBean using the MBeanServer's createMBean method. The resource then sets the MBeanInfo and Descriptors for the RequiredModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined in an XML formatted file or dynamically and programmatically at runtime.

    Every RequiredModelMBean which is instantiated in the MBeanServer becomes manageable:
    its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer.

    A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a RequiredModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrapping exceptions from distributed communications (RMI, EJB, etc.)

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      RequiredModelMBean()
      Constructs an RequiredModelMBean with an empty ModelMBeanInfo.
      RequiredModelMBean(ModelMBeanInfo mbi)
      Constructs a RequiredModelMBean object using ModelMBeanInfo passed in.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
      Registers an object which implements the NotificationListener interface as a listener.
      void addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Registers an object which implements the NotificationListener interface as a listener.
      Object getAttribute(String attrName)
      Returns the value of a specific attribute defined for this ModelMBean.
      AttributeList getAttributes(String[] attrNames)
      Returns the values of several attributes in the ModelMBean.
      protected ClassLoaderRepository getClassLoaderRepository()
      Return the Class Loader Repository used to perform class loading.
      MBeanInfo getMBeanInfo()
      Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns the array of Notifications always generated by the RequiredModelMBean.
      Object invoke(String opName, Object[] opArgs, String[] sig)
      Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
      void load()
      Instantiates this MBean instance with the data found for the MBean in the persistent store.
      void postDeregister()
      Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean server.
      void removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
      Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
      void removeNotificationListener(NotificationListener listener)
      Removes a listener for Notifications from the RequiredModelMBean.
      void removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from this MBean.
      void sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
      Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.
      void sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
      Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
      void sendNotification(Notification ntfyObj)
      Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
      void sendNotification(String ntfyText)
      Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
      void setAttribute(Attribute attribute)
      Sets the value of a specific attribute of a named ModelMBean.
      AttributeList setAttributes(AttributeList attributes)
      Sets the values of an array of attributes of this ModelMBean.
      void setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
      void setModelMBeanInfo(ModelMBeanInfo mbi)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.
      void store()
      Captures the current state of this MBean instance and writes it out to the persistent store.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RequiredModelMBean

        public RequiredModelMBean()
                   throws MBeanException,
                          RuntimeOperationsException
        Constructs an RequiredModelMBean with an empty ModelMBeanInfo.

        The RequiredModelMBean's MBeanInfo and Descriptors can be customized using the setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) method. After the RequiredModelMBean's MBeanInfo and Descriptors are customized, the RequiredModelMBean can be registered with the MBeanServer.

        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps a RuntimeException during the construction of the object.

      • RequiredModelMBean

        public RequiredModelMBean(ModelMBeanInfo mbi)
                   throws MBeanException,
                          RuntimeOperationsException
        Constructs a RequiredModelMBean object using ModelMBeanInfo passed in. As long as the RequiredModelMBean is not registered with the MBeanServer yet, the RequiredModelMBean's MBeanInfo and Descriptors can be customized using the setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) method. After the RequiredModelMBean's MBeanInfo and Descriptors are customized, the RequiredModelMBean can be registered with the MBeanServer.
        参数：
        mbi - The ModelMBeanInfo object to be used by the RequiredModelMBean. The given ModelMBeanInfo is cloned and modified as specified by setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo)
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an {link java.lang.IllegalArgumentException}: The MBeanInfo passed in parameter is null.

    • 方法详细信息

      • setModelMBeanInfo

        public void setModelMBeanInfo(ModelMBeanInfo mbi)
                       throws MBeanException,
                              RuntimeOperationsException
        Initializes a ModelMBean object using ModelMBeanInfo passed in. This method makes it possible to set a customized ModelMBeanInfo on the ModelMBean as long as it is not registered with the MBeanServer.
        Once the ModelMBean's ModelMBeanInfo (with Descriptors) are customized and set on the ModelMBean, the ModelMBean be registered with the MBeanServer.

        If the ModelMBean is currently registered, this method throws a RuntimeOperationsException wrapping an IllegalStateException

        If the given inModelMBeanInfo does not contain any ModelMBeanNotificationInfo for the GENERIC or ATTRIBUTE_CHANGE notifications, then the RequiredModelMBean will supply its own default ModelMBeanNotificationInfos for those missing notifications.

        指定者：
        setModelMBeanInfo in interface ModelMBean
        参数：
        mbi - The ModelMBeanInfo object to be used by the ModelMBean.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException -
        • Wraps an IllegalArgumentException if the MBeanInfo passed in parameter is null.
        • Wraps an IllegalStateException if the ModelMBean is currently registered in the MBeanServer.

      • setManagedResource

        public void setManagedResource(Object mr,
                      String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
        Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
        指定者：
        setManagedResource in interface ModelMBean
        参数：
        mr - Object that is the managed resource
        mr_type - The type of reference for the managed resource.
        Can be: "ObjectReference", "Handle", "IOR", "EJBHandle", or "RMIReference".
        In this implementation only "ObjectReference" is supported.
        抛出：
        MBeanException - The initializer of the object has thrown an exception.
        InstanceNotFoundException - The managed resource object could not be found
        InvalidTargetObjectTypeException - The managed resource type should be "ObjectReference".
        RuntimeOperationsException - Wraps a RuntimeException when setting the resource.

      • load

        public void load()
          throws MBeanException,
                 RuntimeOperationsException,
                 InstanceNotFoundException

        Instantiates this MBean instance with the data found for the MBean in the persistent store. The data loaded could include attribute and operation values.

        This method should be called during construction or initialization of this instance, and before the MBean is registered with the MBeanServer.

        If the implementation of this class does not support persistence, an MBeanException wrapping a ServiceNotFoundException is thrown.

        指定者：
        load in interface PersistentMBean
        抛出：
        MBeanException - Wraps another exception, or persistence is not supported
        RuntimeOperationsException - Wraps exceptions from the persistence mechanism
        InstanceNotFoundException - Could not find or load this MBean from persistent storage

      • store

        public void store()
           throws MBeanException,
                  RuntimeOperationsException,
                  InstanceNotFoundException

        Captures the current state of this MBean instance and writes it out to the persistent store. The state stored could include attribute and operation values.

        If the implementation of this class does not support persistence, an MBeanException wrapping a ServiceNotFoundException is thrown.

        Persistence policy from the MBean and attribute descriptor is used to guide execution of this method. The MBean should be stored if 'persistPolicy' field is:

          != "never"
   = "always"
   = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
   = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
   = "onUnregister"

        Do not store the MBean if 'persistPolicy' field is:

            = "never"
    = "onUpdate"
    = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'
        指定者：
        store in interface PersistentMBean
        抛出：
        MBeanException - Wraps another exception, or persistence is not supported
        RuntimeOperationsException - Wraps exceptions from the persistence mechanism
        InstanceNotFoundException - Could not find/access the persistent store

      • getMBeanInfo

        public MBeanInfo getMBeanInfo()
        Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.
        指定者：
        getMBeanInfo in interface DynamicMBean
        返回：
        An instance of ModelMBeanInfo allowing retrieval all attributes, operations, and Notifications of this MBean.

      • invoke

        public Object invoke(String opName,
            Object[] opArgs,
            String[] sig)
              throws MBeanException,
                     ReflectionException
        Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.

        If the given method to be invoked, together with the provided signature, matches one of RequiredModelMbean accessible methods, this one will be call. Otherwise the call to the given method will be tried on the managed resource.

        The last value returned by an operation may be cached in the operation's descriptor which is in the ModelMBeanOperationInfo's descriptor. The valid value will be in the 'value' field if there is one. If the 'currencyTimeLimit' field in the descriptor is:

        • <0 Then the value is not cached and is never valid. The operation method is invoked. The 'value' and 'lastUpdatedTimeStamp' fields are cleared.
        • =0 Then the value is always cached and always valid. The 'value' field is returned. If there is no 'value' field then the operation method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are set to the operation's return value and the current time stamp.
        • >0 Represents the number of seconds that the 'value' field is valid. The 'value' field is no longer valid when 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now.
          • When 'value' is valid, 'value' is returned.
          • When 'value' is no longer valid then the operation method is invoked. The 'lastUpdatedTimeStamp' field and `value' fields are updated.

        Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

        指定者：
        invoke in interface DynamicMBean
        参数：
        opName - The name of the method to be invoked. The name can be the fully qualified method name including the classname, or just the method name if the classname is defined in the 'class' field of the operation descriptor.
        opArgs - An array containing the parameters to be set when the operation is invoked
        sig - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked.
        返回：
        The object returned by the method, which represents the result of invoking the method on the specified managed resource.
        抛出：
        MBeanException - Wraps one of the following Exceptions:
        • An Exception thrown by the managed object's invoked method.
        • ServiceNotFoundException: No ModelMBeanOperationInfo or no descriptor defined for the specified operation or the managed resource is null.
        • InvalidTargetObjectTypeException: The 'targetType' field value is not 'objectReference'.
        ReflectionException - Wraps an Exception thrown while trying to invoke the method.
        RuntimeOperationsException - Wraps an IllegalArgumentException Method name is null.

      • getAttribute

        public Object getAttribute(String attrName)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
        Returns the value of a specific attribute defined for this ModelMBean. The last value returned by an attribute may be cached in the attribute's descriptor. The valid value will be in the 'value' field if there is one. If the 'currencyTimeLimit' field in the descriptor is:
        • <0 Then the value is not cached and is never valid. The getter method is invoked for the attribute. The 'value' and 'lastUpdatedTimeStamp' fields are cleared.
        • =0 Then the value is always cached and always valid. The 'value' field is returned. If there is no'value' field then the getter method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are set to the attribute's value and the current time stamp.
        • >0 Represents the number of seconds that the 'value' field is valid. The 'value' field is no longer valid when 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now.
          • When 'value' is valid, 'value' is returned.
          • When 'value' is no longer valid then the getter method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are updated.

        Note: because of inconsistencies in previous versions of this specification, it is recommended not to use negative or zero values for currencyTimeLimit. To indicate that a cached value is never valid, omit the currencyTimeLimit field. To indicate that it is always valid, use a very large number for this field.

        If the 'getMethod' field contains the name of a valid operation descriptor, then the method described by the operation descriptor is executed. The response from the method is returned as the value of the attribute. If the operation fails or the returned value is not compatible with the declared type of the attribute, an exception will be thrown.

        If no 'getMethod' field is defined then the default value of the attribute is returned. If the returned value is not compatible with the declared type of the attribute, an exception will be thrown.

        The declared type of the attribute is the String returned by MBeanAttributeInfo.getType(). A value is compatible with this type if one of the following is true:

        • the value is null;
        • the declared name is a primitive type name (such as "int") and the value is an instance of the corresponding wrapper type (such as java.lang.Integer);
        • the name of the value's class is identical to the declared name;
        • the declared name can be loaded by the value's class loader and produces a class to which the value can be assigned.

        In this implementation, in every case where the getMethod needs to be called, because the method is invoked through the standard "invoke" method and thus needs operationInfo, an operation must be specified for that getMethod so that the invocation works correctly.

        指定者：
        getAttribute in interface DynamicMBean
        参数：
        attrName - A String specifying the name of the attribute to be retrieved. It must match the name of a ModelMBeanAttributeInfo.
        返回：
        The value of the retrieved attribute from the descriptor 'value' field or from the invocation of the operation in the 'getMethod' field of the descriptor.
        抛出：
        AttributeNotFoundException - The specified attribute is not accessible in the MBean. The following cases may result in an AttributeNotFoundException:
        • No ModelMBeanInfo was found for the Model MBean.
        • No ModelMBeanAttributeInfo was found for the specified attribute name.
        • The ModelMBeanAttributeInfo isReadable method returns 'false'.
        MBeanException - Wraps one of the following Exceptions:
        • InvalidAttributeValueException: A wrong value type was received from the attribute's getter method or no 'getMethod' field defined in the descriptor for the attribute and no default value exists.
        • ServiceNotFoundException: No ModelMBeanOperationInfo defined for the attribute's getter method or no descriptor associated with the ModelMBeanOperationInfo or the managed resource is null.
        • InvalidTargetObjectTypeException The 'targetType' field value is not 'objectReference'.
        • An Exception thrown by the managed object's getter.
        ReflectionException - Wraps an Exception thrown while trying to invoke the getter.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The attribute name in parameter is null.
        另请参见：
        setAttribute(javax.management.Attribute)

      • getAttributes

        public AttributeList getAttributes(String[] attrNames)
        Returns the values of several attributes in the ModelMBean. Executes a getAttribute for each attribute name in the attrNames array passed in.
        指定者：
        getAttributes in interface DynamicMBean
        参数：
        attrNames - A String array of names of the attributes to be retrieved.
        返回：
        The array of the retrieved attributes.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
        另请参见：
        setAttributes(javax.management.AttributeList)

      • setAttribute

        public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
        Sets the value of a specific attribute of a named ModelMBean. If the 'setMethod' field of the attribute's descriptor contains the name of a valid operation descriptor, then the method described by the operation descriptor is executed. In this implementation, the operation descriptor must be specified correctly and assigned to the modelMBeanInfo so that the 'setMethod' works correctly. The response from the method is set as the value of the attribute in the descriptor.

        If currencyTimeLimit is > 0, then the new value for the attribute is cached in the attribute descriptor's 'value' field and the 'lastUpdatedTimeStamp' field is set to the current time stamp.

        If the persist field of the attribute's descriptor is not null then Persistence policy from the attribute descriptor is used to guide storing the attribute in a persistent store.
        Store the MBean if 'persistPolicy' field is:

        • != "never"
        • = "always"
        • = "onUpdate"
        • = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
        • = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
        Do not store the MBean if 'persistPolicy' field is:
        • = "never"
        • = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'
        • = "onUnregister"
        • = "NoMoreOftenThan" and now < 'lastPersistTime' + 'persistPeriod'

        The ModelMBeanInfo of the Model MBean is stored in a file.

        指定者：
        setAttribute in interface DynamicMBean
        参数：
        attribute - The Attribute instance containing the name of the attribute to be set and the value it is to be set to.
        抛出：
        AttributeNotFoundException - The specified attribute is not accessible in the MBean.
        The following cases may result in an AttributeNotFoundException:
        • No ModelMBeanAttributeInfo is found for the specified attribute.
        • The ModelMBeanAttributeInfo's isWritable method returns 'false'.
        InvalidAttributeValueException - No descriptor is defined for the specified attribute.
        MBeanException - Wraps one of the following Exceptions:
        • An Exception thrown by the managed object's setter.
        • A ServiceNotFoundException if a setMethod field is defined in the descriptor for the attribute and the managed resource is null; or if no setMethod field is defined and caching is not enabled for the attribute. Note that if there is no getMethod field either, then caching is automatically enabled.
        • InvalidTargetObjectTypeException The 'targetType' field value is not 'objectReference'.
        • An Exception thrown by the managed object's getter.
        ReflectionException - Wraps an Exception thrown while trying to invoke the setter.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The attribute in parameter is null.
        另请参见：
        getAttribute(java.lang.String)

      • setAttributes

        public AttributeList setAttributes(AttributeList attributes)
        Sets the values of an array of attributes of this ModelMBean. Executes the setAttribute() method for each attribute in the list.
        指定者：
        setAttributes in interface DynamicMBean
        参数：
        attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
        返回：
        The array of attributes that were set, with their new values in Attribute instances.
        抛出：
        RuntimeOperationsException - Wraps an IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
        另请参见：
        getAttributes(java.lang.String[])

      • addNotificationListener

        public void addNotificationListener(NotificationListener listener,
                           NotificationFilter filter,
                           Object handback)
                             throws IllegalArgumentException
        Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any notification is issued through or by the ModelMBean. This does not include attributeChangeNotifications. They must be registered for independently.
        指定者：
        addNotificationListener in interface NotificationBroadcaster
        参数：
        listener - The listener object which will handles notifications emitted by the registered MBean.
        filter - The filter object. If null, no filtering will be performed before handling notifications.
        handback - The context to be sent to the listener with the notification when a notification is emitted.
        抛出：
        IllegalArgumentException - The listener cannot be null.
        另请参见：
        removeNotificationListener(javax.management.NotificationListener)

      • removeNotificationListener

        public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
        Removes a listener for Notifications from the RequiredModelMBean.
        指定者：
        removeNotificationListener in interface NotificationBroadcaster
        参数：
        listener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
        抛出：
        ListenerNotFoundException - The listener is not registered in the MBean or is null.
        另请参见：
        addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • removeNotificationListener

        public void removeNotificationListener(NotificationListener listener,
                              NotificationFilter filter,
                              Object handback)
                                throws ListenerNotFoundException
        从接口复制的描述： NotificationEmitter

        Removes a listener from this MBean. The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

        The filter and handback parameters may be null if and only if they are null in a listener to be removed.

        指定者：
        removeNotificationListener in interface NotificationEmitter
        参数：
        listener - A listener that was previously added to this MBean.
        filter - The filter that was specified when the listener was added.
        handback - The handback that was specified when the listener was added.
        抛出：
        ListenerNotFoundException - The listener is not registered with the MBean, or it is not registered with the given filter and handback.

      • sendNotification

        public void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
        指定者：
        sendNotification in interface ModelMBeanNotificationBroadcaster
        参数：
        ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification object passed in parameter is null.

      • sendNotification

        public void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
        指定者：
        sendNotification in interface ModelMBeanNotificationBroadcaster
        参数：
        ntfyText - The text which is to be passed in the Notification to the 'handleNotification' method of the listener object. the constructed Notification will be: type "jmx.modelmbean.generic" source this ModelMBean instance sequence 1
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification text string passed in parameter is null.

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        Returns the array of Notifications always generated by the RequiredModelMBean.

        RequiredModelMBean may always send also two additional notifications:

        • One with descriptor "name=GENERIC,descriptorType=notification,log=T,severity=6,displayName=jmx.modelmbean.generic"
        • Second is a standard attribute change notification with descriptor "name=ATTRIBUTE_CHANGE,descriptorType=notification,log=T,severity=6,displayName=jmx.attribute.change"
        Thus these two notifications are always added to those specified by the application.
        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        返回：
        MBeanNotificationInfo[]

      • addAttributeChangeNotificationListener

        public void addAttributeChangeNotificationListener(NotificationListener inlistener,
                                          String inAttributeName,
                                          Object inhandback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any attributeChangeNotification is issued through or by the ModelMBean. This does not include other Notifications. They must be registered for independently. An AttributeChangeNotification will be generated for this attributeName.
        指定者：
        addAttributeChangeNotificationListener in interface ModelMBeanNotificationBroadcaster
        参数：
        inlistener - The listener object which will handles notifications emitted by the registered MBean.
        inAttributeName - The name of the ModelMBean attribute for which to receive change notifications. If null, then all attribute changes will cause an attributeChangeNotification to be issued.
        inhandback - The context to be sent to the listener with the notification when a notification is emitted.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException The attribute name passed in parameter does not exist.
        IllegalArgumentException - The listener cannot be null.
        另请参见：
        ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

      • removeAttributeChangeNotificationListener

        public void removeAttributeChangeNotificationListener(NotificationListener inlistener,
                                             String inAttributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
        指定者：
        removeAttributeChangeNotificationListener in interface ModelMBeanNotificationBroadcaster
        参数：
        inlistener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
        inAttributeName - The attribute for which the listener no longer wants to receive attributeChangeNotifications. If null the listener will be removed for all attributeChangeNotifications.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException If the inAttributeName parameter does not correspond to an attribute name.
        ListenerNotFoundException - The listener is not registered in the MBean or is null.
        另请参见：
        ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)

      • sendAttributeChangeNotification

        public void sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
                                     throws MBeanException,
                                            RuntimeOperationsException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
        指定者：
        sendAttributeChangeNotification in interface ModelMBeanNotificationBroadcaster
        参数：
        ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: The AttributeChangeNotification object passed in parameter is null.

      • sendAttributeChangeNotification

        public void sendAttributeChangeNotification(Attribute inOldVal,
                                   Attribute inNewVal)
                                     throws MBeanException,
                                            RuntimeOperationsException
        从接口复制的描述： ModelMBeanNotificationBroadcaster
        Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.

        指定者：
        sendAttributeChangeNotification in interface ModelMBeanNotificationBroadcaster
        参数：
        inOldVal - The original value for the Attribute
        inNewVal - The current value for the Attribute

         The constructed attributeChangeNotification will be:
   type        "jmx.attribute.change"
   source      this ModelMBean instance
   sequence    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
        抛出：
        MBeanException - Wraps a distributed communication Exception.
        RuntimeOperationsException - Wraps an IllegalArgumentException: An Attribute object passed in parameter is null or the names of the two Attribute objects in parameter are not the same.

      • getClassLoaderRepository

        protected ClassLoaderRepository getClassLoaderRepository()
        Return the Class Loader Repository used to perform class loading. Subclasses may wish to redefine this method in order to return the appropriate ClassLoaderRepository that should be used in this object.
        返回：
        the Class Loader Repository.

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        Allows the MBean to perform any operations it needs before being registered in the MBean server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean server.

        In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.preRegister(server, name) in its own preRegister implementation.

        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean server in which the MBean will be registered.
        name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
        返回：
        The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
        抛出：
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postRegister

        public void postRegister(Boolean registrationDone)
        Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.postRegister(registrationDone) in its own postRegister implementation.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        Allows the MBean to perform any operations it needs before being unregistered by the MBean server.

        In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.preDeregister() in its own preDeregister implementation.

        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postDeregister

        public void postDeregister()
        Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

        In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.postDeregister() in its own postDeregister implementation.

        指定者：
        postDeregister in interface MBeanRegistration
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.management.modelmbean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.modelmbean

  • Packages that use javax.management.modelmbean
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.
  • Classes in javax.management.modelmbean used by javax.management.modelmbean
    类与描述
    DescriptorSupport
    This class represents the metadata set for a ModelMBean element.
    InvalidTargetObjectTypeException
    Exception thrown when an invalid target object type is specified.
    ModelMBean
    This interface must be implemented by the ModelMBeans.
    ModelMBeanAttributeInfo
    The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
    ModelMBeanConstructorInfo
    The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
    ModelMBeanInfo
    This interface is implemented by the ModelMBeanInfo for every ModelMBean.
    ModelMBeanNotificationBroadcaster
    This interface must be implemented by the ModelMBeans.
    ModelMBeanNotificationInfo
    The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
    ModelMBeanOperationInfo
    The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.
    XMLParseException
    This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>//t


XMLParseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.modelmbean

类 XMLParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.modelmbean.XMLParseException
  • 所有已实现的接口：
    Serializable

    public class XMLParseException
extends Exception
    This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects. It is also used to wrapper exceptions from XML parsers that may be used.

    The serialVersionUID of this class is 3176664577895105181L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLParseException()
      Default constructor .
      XMLParseException(Exception e, String s)
      Constructor taking a string and an exception.
      XMLParseException(String s)
      Constructor taking a string.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XMLParseException

        public XMLParseException()
        Default constructor .

      • XMLParseException

        public XMLParseException(String s)
        Constructor taking a string.
        参数：
        s - the detail message.

      • XMLParseException

        public XMLParseException(Exception e,
                 String s)
        Constructor taking a string and an exception.
        参数：
        e - the nested exception.
        s - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rot


Uses of Class javax.management.modelmbean.DescriptorSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.DescriptorSupport

  • Packages that use DescriptorSupport
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of DescriptorSupport in javax.management.modelmbean

      Constructors in javax.management.modelmbean with parameters of type DescriptorSupport
      构造方法与描述
      DescriptorSupport(DescriptorSupport inDescr)
      Descriptor constructor taking a Descriptor as parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-薬l "


Uses of Class javax.management.modelmbean.InvalidTargetObjectTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.InvalidTargetObjectTypeException

  • Packages that use InvalidTargetObjectTypeException
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of InvalidTargetObjectTypeException in javax.management.modelmbean

      Methods in javax.management.modelmbean that throw InvalidTargetObjectTypeException
      修饰符与类型 方法与描述
      void RequiredModelMBean.setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
      void ModelMBean.setManagedResource(Object mr, String mr_type)
      Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ndi>fsFfmah魏.gbooe


Uses of Class javax.management.modelmbean.ModelMBeanAttributeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.ModelMBeanAttributeInfo

  • Packages that use ModelMBeanAttributeInfo
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanAttributeInfo in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ModelMBeanAttributeInfo
      修饰符与类型 | 方法与描述
      ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
      ModelMBeanAttributeInfo ModelMBeanInfo.getAttribute(String inName)
      Returns a ModelMBeanAttributeInfo requested by name.
      Constructors in javax.management.modelmbean with parameters of type ModelMBeanAttributeInfo
      构造方法与描述
      ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
      Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
      Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

me=>ep<>r醞ecvtunsse=as


Uses of Class javax.management.modelmbean.ModelMBeanConstructorInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.ModelMBeanConstructorInfo

  • Packages that use ModelMBeanConstructorInfo
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanConstructorInfo in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ModelMBeanConstructorInfo
      修饰符与类型 方法与描述
      ModelMBeanConstructorInfo ModelMBeanInfoSupport.getConstructor(String inName)
      Returns the ModelMBeanConstructorInfo requested by name.
      Constructors in javax.management.modelmbean with parameters of type ModelMBeanConstructorInfo
      构造方法与描述
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
      Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.modelmbean.ModelMBeanInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.ModelMBeanInfoSupport

No usage of javax.management.modelmbean.ModelMBeanInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ahn&bEn=s"""l>ffhan a>


Uses of Class javax.management.modelmbean.ModelMBeanNotificationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.ModelMBeanNotificationInfo

  • Packages that use ModelMBeanNotificationInfo
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanNotificationInfo in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ModelMBeanNotificationInfo
      修饰符与类型 | 方法与描述
      ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
      ModelMBeanNotificationInfo ModelMBeanInfo.getNotification(String inName)
      Returns a ModelMBeanNotificationInfo requested by name.
      Constructors in javax.management.modelmbean with parameters of type ModelMBeanNotificationInfo
      构造方法与描述
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
      Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
      ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
      Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nos"o.im>sbs �.lMaoc


Uses of Class javax.management.modelmbean.ModelMBeanOperationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.ModelMBeanOperationInfo

  • Packages that use ModelMBeanOperationInfo
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanOperationInfo in javax.management.modelmbean

      Methods in javax.management.modelmbean that return ModelMBeanOperationInfo
      修饰符与类型 | 方法与描述
      ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
      ModelMBeanOperationInfo ModelMBeanInfo.getOperation(String inName)
      Returns a ModelMBeanOperationInfo requested by name.
      Constructors in javax.management.modelmbean with parameters of type ModelMBeanOperationInfo
      构造方法与描述
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
      Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
      ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
      Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
      ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
      Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a厮泵岜峄保劣o�<<溃寥<<�/


Uses of Class javax.management.modelmbean.RequiredModelMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.RequiredModelMBean

No usage of javax.management.modelmbean.RequiredModelMBean
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.Mms="cittttlIeea


Uses of Class javax.management.modelmbean.XMLParseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.modelmbean.XMLParseException

  • Packages that use XMLParseException
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of XMLParseException in javax.management.modelmbean

      Constructors in javax.management.modelmbean that throw XMLParseException
      构造方法与描述
      DescriptorSupport(String inStr)
      Descriptor constructor taking an XML String.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1/del=l e a"ir t"ah.=cM


Uses of Interface javax.management.modelmbean.ModelMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.modelmbean.ModelMBean

  • Packages that use ModelMBean
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBean in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement ModelMBean
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ih/..d.////.= ls=a"�>va<


Uses of Interface javax.management.modelmbean.ModelMBeanInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.modelmbean.ModelMBeanInfo

  • Packages that use ModelMBeanInfo
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanInfo in javax.management.modelmbean

      Classes in javax.management.modelmbean that implement ModelMBeanInfo
      修饰符与类型 类与描述
      class  ModelMBeanInfoSupport
      This class represents the meta data for ModelMBeans.
      Methods in javax.management.modelmbean with parameters of type ModelMBeanInfo
      修饰符与类型 方法与描述
      void RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.
      void ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
      Initializes a ModelMBean object using ModelMBeanInfo passed in.
      Constructors in javax.management.modelmbean with parameters of type ModelMBeanInfo
      构造方法与描述
      ModelMBeanInfoSupport(ModelMBeanInfo mbi)
      Constructs a ModelMBeanInfoSupport which is a duplicate of the given ModelMBeanInfo.
      RequiredModelMBean(ModelMBeanInfo mbi)
      Constructs a RequiredModelMBean object using ModelMBeanInfo passed in.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-tnl/lslllssl/eel<�


Uses of Interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.modelmbean.ModelMBeanNotificationBroadcaster

  • Packages that use ModelMBeanNotificationBroadcaster
    软件包 描述
    javax.management.modelmbean
    Provides the definition of the ModelMBean classes.

    • Uses of ModelMBeanNotificationBroadcaster in javax.management.modelmbean

      Subinterfaces of ModelMBeanNotificationBroadcaster in javax.management.modelmbean
      修饰符与类型 Interface and Description
      interface  ModelMBean
      This interface must be implemented by the ModelMBeans.
      Classes in javax.management.modelmbean that implement ModelMBeanNotificationBroadcaster
      修饰符与类型 类与描述
      class  RequiredModelMBean
      This class is the implementation of a ModelMBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eeartst"meo


CounterMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.monitor

类 CounterMonitor

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.monitor.Monitor
        • javax.management.monitor.CounterMonitor
  • 所有已实现的接口：
    MBeanRegistration, CounterMonitorMBean, MonitorMBean, NotificationBroadcaster, NotificationEmitter

    public class CounterMonitor
extends Monitor
implements CounterMonitorMBean
    Defines a monitor MBean designed to observe the values of a counter attribute.

    A counter monitor sends a threshold notification when the value of the counter reaches or exceeds a threshold known as the comparison level. The notify flag must be set to true.

    In addition, an offset mechanism enables particular counting intervals to be detected. If the offset value is not zero, whenever the threshold is triggered by the counter value reaching a comparison level, that comparison level is incremented by the offset value. This is regarded as taking place instantaneously, that is, before the count is incremented. Thus, for each level, the threshold triggers an event notification every time the count increases by an interval equal to the offset value.

    If the counter can wrap around its maximum value, the modulus needs to be specified. The modulus is the value at which the counter is reset to zero.

    If the counter difference mode is used, the value of the derived gauge is calculated as the difference between the observed counter values for two successive observations. If this difference is negative, the value of the derived gauge is incremented by the value of the modulus. The derived gauge value (V[t]) is calculated using the following method:

    • if (counter[t] - counter[t-GP]) is positive then V[t] = counter[t] - counter[t-GP]
    • if (counter[t] - counter[t-GP]) is negative then V[t] = counter[t] - counter[t-GP] + MODULUS
    This implementation of the counter monitor requires the observed attribute to be of the type integer (Byte, Integer, Short, Long).
    从以下版本开始：
    1.5

    • 字段摘要

      • Fields inherited from class javax.management.monitor.Monitor

        alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server

    • 构造方法摘要

      Constructors
      构造方法与描述
      CounterMonitor()
      Default constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Number getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      Number getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      boolean getDifferenceMode()
      Gets the difference mode flag value common to all observed MBeans.
      Number getInitThreshold()
      Gets the initial threshold value common to all observed objects.
      Number getModulus()
      Gets the modulus value common to all observed MBeans.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.
      boolean getNotify()
      Gets the notification's on/off switch value common to all observed MBeans.
      Number getOffset()
      Gets the offset value common to all observed MBeans.
      Number getThreshold()
      Deprecated.
      As of JMX 1.2, replaced by getThreshold(ObjectName)
      Number getThreshold(ObjectName object)
      Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      void setDifferenceMode(boolean value)
      Sets the difference mode flag value common to all observed MBeans.
      void setInitThreshold(Number value)
      Sets the initial threshold value common to all observed objects.
      void setModulus(Number value)
      Sets the modulus value common to all observed MBeans.
      void setNotify(boolean value)
      Sets the notification's on/off switch value common to all observed MBeans.
      void setOffset(Number value)
      Sets the offset value common to all observed MBeans.
      void setThreshold(Number value)
      Deprecated.
      As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)
      void start()
      Starts the counter monitor.
      void stop()
      Stops the counter monitor.

      • 方法 - 继承于类 javax.management.monitor.Monitor

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

    • 构造方法详细信息

      • CounterMonitor

        public CounterMonitor()
        Default constructor.

    • 方法详细信息

      • start

        public void start()
        Starts the counter monitor.
        指定者：
        start in interface MonitorMBean
        指定者：
        start in class Monitor

      • stop

        public void stop()
        Stops the counter monitor.
        指定者：
        stop in interface MonitorMBean
        指定者：
        stop in class Monitor

      • getDerivedGauge

        public Number getDerivedGauge(ObjectName object)
        Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
        指定者：
        getDerivedGauge in interface CounterMonitorMBean
        参数：
        object - the name of the object whose derived gauge is to be returned.
        返回：
        The derived gauge of the specified object.

      • getDerivedGaugeTimeStamp

        public long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
        指定者：
        getDerivedGaugeTimeStamp in interface CounterMonitorMBean
        参数：
        object - the name of the object whose derived gauge timestamp is to be returned.
        返回：
        The derived gauge timestamp of the specified object.

      • getThreshold

        public Number getThreshold(ObjectName object)
        Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
        指定者：
        getThreshold in interface CounterMonitorMBean
        参数：
        object - the name of the object whose threshold is to be returned.
        返回：
        The threshold value of the specified object.
        另请参见：
        CounterMonitorMBean.setThreshold(java.lang.Number)

      • getInitThreshold

        public Number getInitThreshold()
        Gets the initial threshold value common to all observed objects.
        指定者：
        getInitThreshold in interface CounterMonitorMBean
        返回：
        The initial threshold.
        另请参见：
        setInitThreshold(java.lang.Number)

      • setInitThreshold

        public void setInitThreshold(Number value)
                      throws IllegalArgumentException
        Sets the initial threshold value common to all observed objects.
        The current threshold of every object in the set of observed MBeans is updated consequently.
        指定者：
        setInitThreshold in interface CounterMonitorMBean
        参数：
        value - The initial threshold value.
        抛出：
        IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
        另请参见：
        getInitThreshold()

      • getDerivedGauge

        @Deprecated
public Number getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Returns the derived gauge of the first object in the set of observed MBeans.
        指定者：
        getDerivedGauge in interface CounterMonitorMBean
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
public long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp of the first object in the set of observed MBeans.
        指定者：
        getDerivedGaugeTimeStamp in interface CounterMonitorMBean
        返回：
        The derived gauge timestamp.

      • getThreshold

        @Deprecated
public Number getThreshold()
        Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)
        Gets the threshold value of the first object in the set of observed MBeans.
        指定者：
        getThreshold in interface CounterMonitorMBean
        返回：
        The threshold value.
        另请参见：
        setThreshold(java.lang.Number)

      • setThreshold

        @Deprecated
public void setThreshold(Number value)
                  throws IllegalArgumentException
        Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)
        Sets the initial threshold value.
        指定者：
        setThreshold in interface CounterMonitorMBean
        参数：
        value - The initial threshold value.
        抛出：
        IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
        另请参见：
        getThreshold()

      • getOffset

        public Number getOffset()
        Gets the offset value common to all observed MBeans.
        指定者：
        getOffset in interface CounterMonitorMBean
        返回：
        The offset value.
        另请参见：
        setOffset(java.lang.Number)

      • setOffset

        public void setOffset(Number value)
               throws IllegalArgumentException
        Sets the offset value common to all observed MBeans.
        指定者：
        setOffset in interface CounterMonitorMBean
        参数：
        value - The offset value.
        抛出：
        IllegalArgumentException - The specified offset is null or the offset value is less than zero.
        另请参见：
        getOffset()

      • getModulus

        public Number getModulus()
        Gets the modulus value common to all observed MBeans.
        指定者：
        getModulus in interface CounterMonitorMBean
        返回：
        The modulus value.
        另请参见：
        setModulus(java.lang.Number)

      • setModulus

        public void setModulus(Number value)
                throws IllegalArgumentException
        Sets the modulus value common to all observed MBeans.
        指定者：
        setModulus in interface CounterMonitorMBean
        参数：
        value - The modulus value.
        抛出：
        IllegalArgumentException - The specified modulus is null or the modulus value is less than zero.
        另请参见：
        getModulus()

      • getNotify

        public boolean getNotify()
        Gets the notification's on/off switch value common to all observed MBeans.
        指定者：
        getNotify in interface CounterMonitorMBean
        返回：
        true if the counter monitor notifies when exceeding the threshold, false otherwise.
        另请参见：
        setNotify(boolean)

      • setNotify

        public void setNotify(boolean value)
        Sets the notification's on/off switch value common to all observed MBeans.
        指定者：
        setNotify in interface CounterMonitorMBean
        参数：
        value - The notification's on/off switch value.
        另请参见：
        getNotify()

      • getDifferenceMode

        public boolean getDifferenceMode()
        Gets the difference mode flag value common to all observed MBeans.
        指定者：
        getDifferenceMode in interface CounterMonitorMBean
        返回：
        true if the difference mode is used, false otherwise.
        另请参见：
        setDifferenceMode(boolean)

      • setDifferenceMode

        public void setDifferenceMode(boolean value)
        Sets the difference mode flag value common to all observed MBeans.
        指定者：
        setDifferenceMode in interface CounterMonitorMBean
        参数：
        value - The difference mode flag value.
        另请参见：
        getDifferenceMode()

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.
        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CounterMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.monitor

Interface CounterMonitorMBean

  • All Superinterfaces:
    MonitorMBean
    All Known Implementing Classes:
    CounterMonitor

    public interface CounterMonitorMBean
extends MonitorMBean
    Exposes the remote management interface of the counter monitor MBean.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Number getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      Number getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      boolean getDifferenceMode()
      Gets the difference mode flag value.
      Number getInitThreshold()
      Gets the initial threshold value common to all observed objects.
      Number getModulus()
      Gets the modulus value.
      boolean getNotify()
      Gets the notification's on/off switch value.
      Number getOffset()
      Gets the offset value.
      Number getThreshold()
      Deprecated.
      As of JMX 1.2, replaced by getThreshold(ObjectName)
      Number getThreshold(ObjectName object)
      Gets the threshold value for the specified MBean.
      void setDifferenceMode(boolean value)
      Sets the difference mode flag value.
      void setInitThreshold(Number value)
      Sets the initial threshold value common to all observed MBeans.
      void setModulus(Number value)
      Sets the modulus value.
      void setNotify(boolean value)
      Sets the notification's on/off switch value.
      void setOffset(Number value)
      Sets the offset value.
      void setThreshold(Number value)
      Deprecated.
      As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

    • 方法详细信息

      • getDerivedGauge

        @Deprecated
Number getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Gets the derived gauge.
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp.
        返回：
        The derived gauge timestamp.

      • getThreshold

        @Deprecated
Number getThreshold()
        Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)
        Gets the threshold value.
        返回：
        The threshold value.
        另请参见：
        setThreshold(Number)

      • setThreshold

        @Deprecated
void setThreshold(Number value)
                  throws IllegalArgumentException
        Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)
        Sets the threshold value.
        参数：
        value - The threshold value.
        抛出：
        IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
        另请参见：
        getThreshold()

      • getDerivedGauge

        Number getDerivedGauge(ObjectName object)
        Gets the derived gauge for the specified MBean.
        参数：
        object - the MBean for which the derived gauge is to be returned
        返回：
        The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getDerivedGaugeTimeStamp

        long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp for the specified MBean.
        参数：
        object - the MBean for which the derived gauge timestamp is to be returned
        返回：
        The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getThreshold

        Number getThreshold(ObjectName object)
        Gets the threshold value for the specified MBean.
        参数：
        object - the MBean for which the threshold value is to be returned
        返回：
        The threshold value for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
        另请参见：
        setThreshold(java.lang.Number)

      • getInitThreshold

        Number getInitThreshold()
        Gets the initial threshold value common to all observed objects.
        返回：
        The initial threshold value.
        另请参见：
        setInitThreshold(java.lang.Number)

      • setInitThreshold

        void setInitThreshold(Number value)
                      throws IllegalArgumentException
        Sets the initial threshold value common to all observed MBeans.
        参数：
        value - The initial threshold value.
        抛出：
        IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
        另请参见：
        getInitThreshold()

      • getOffset

        Number getOffset()
        Gets the offset value.
        返回：
        The offset value.
        另请参见：
        setOffset(Number)

      • setOffset

        void setOffset(Number value)
               throws IllegalArgumentException
        Sets the offset value.
        参数：
        value - The offset value.
        抛出：
        IllegalArgumentException - The specified offset is null or the offset value is less than zero.
        另请参见：
        getOffset()

      • getModulus

        Number getModulus()
        Gets the modulus value.
        返回：
        The modulus value.
        另请参见：
        setModulus(java.lang.Number)

      • setModulus

        void setModulus(Number value)
                throws IllegalArgumentException
        Sets the modulus value.
        参数：
        value - The modulus value.
        抛出：
        IllegalArgumentException - The specified modulus is null or the modulus value is less than zero.
        另请参见：
        getModulus()

      • getNotify

        boolean getNotify()
        Gets the notification's on/off switch value.
        返回：
        true if the counter monitor notifies when exceeding the threshold, false otherwise.
        另请参见：
        setNotify(boolean)

      • setNotify

        void setNotify(boolean value)
        Sets the notification's on/off switch value.
        参数：
        value - The notification's on/off switch value.
        另请参见：
        getNotify()

      • getDifferenceMode

        boolean getDifferenceMode()
        Gets the difference mode flag value.
        返回：
        true if the difference mode is used, false otherwise.
        另请参见：
        setDifferenceMode(boolean)

      • setDifferenceMode

        void setDifferenceMode(boolean value)
        Sets the difference mode flag value.
        参数：
        value - The difference mode flag value.
        另请参见：
        getDifferenceMode()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

B ee>otCotioiniitaee/.>=f.tn aim/ua B


GaugeMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.monitor

类 GaugeMonitor

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.monitor.Monitor
        • javax.management.monitor.GaugeMonitor
  • 所有已实现的接口：
    MBeanRegistration, GaugeMonitorMBean, MonitorMBean, NotificationBroadcaster, NotificationEmitter

    public class GaugeMonitor
extends Monitor
implements GaugeMonitorMBean
    Defines a monitor MBean designed to observe the values of a gauge attribute.

    A gauge monitor observes an attribute that is continuously variable with time. A gauge monitor sends notifications as follows:

    • if the attribute value is increasing and becomes equal to or greater than the high threshold value, a threshold high notification is sent. The notify high flag must be set to true.
      Subsequent crossings of the high threshold value do not cause further notifications unless the attribute value becomes equal to or less than the low threshold value.
    • if the attribute value is decreasing and becomes equal to or less than the low threshold value, a threshold low notification is sent. The notify low flag must be set to true.
      Subsequent crossings of the low threshold value do not cause further notifications unless the attribute value becomes equal to or greater than the high threshold value.
    This provides a hysteresis mechanism to avoid repeated triggering of notifications when the attribute value makes small oscillations around the high or low threshold value.

    If the gauge difference mode is used, the value of the derived gauge is calculated as the difference between the observed gauge values for two successive observations.
    The derived gauge value (V[t]) is calculated using the following method:

    • V[t] = gauge[t] - gauge[t-GP]
    This implementation of the gauge monitor requires the observed attribute to be of the type integer or floating-point (Byte, Integer, Short, Long, Float, Double).
    从以下版本开始：
    1.5

    • 字段摘要

      • Fields inherited from class javax.management.monitor.Monitor

        alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server

    • 构造方法摘要

      Constructors
      构造方法与描述
      GaugeMonitor()
      Default constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Number getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      Number getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      boolean getDifferenceMode()
      Gets the difference mode flag value common to all observed MBeans.
      Number getHighThreshold()
      Gets the high threshold value common to all observed MBeans.
      Number getLowThreshold()
      Gets the low threshold value common to all observed MBeans.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.
      boolean getNotifyHigh()
      Gets the high notification's on/off switch value common to all observed MBeans.
      boolean getNotifyLow()
      Gets the low notification's on/off switch value common to all observed MBeans.
      void setDifferenceMode(boolean value)
      Sets the difference mode flag value common to all observed MBeans.
      void setNotifyHigh(boolean value)
      Sets the high notification's on/off switch value common to all observed MBeans.
      void setNotifyLow(boolean value)
      Sets the low notification's on/off switch value common to all observed MBeans.
      void setThresholds(Number highValue, Number lowValue)
      Sets the high and the low threshold values common to all observed MBeans.
      void start()
      Starts the gauge monitor.
      void stop()
      Stops the gauge monitor.

      • 方法 - 继承于类 javax.management.monitor.Monitor

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

    • 构造方法详细信息

      • GaugeMonitor

        public GaugeMonitor()
        Default constructor.

    • 方法详细信息

      • start

        public void start()
        Starts the gauge monitor.
        指定者：
        start in interface MonitorMBean
        指定者：
        start in class Monitor

      • stop

        public void stop()
        Stops the gauge monitor.
        指定者：
        stop in interface MonitorMBean
        指定者：
        stop in class Monitor

      • getDerivedGauge

        public Number getDerivedGauge(ObjectName object)
        Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
        指定者：
        getDerivedGauge in interface GaugeMonitorMBean
        参数：
        object - the name of the MBean.
        返回：
        The derived gauge of the specified object.

      • getDerivedGaugeTimeStamp

        public long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
        指定者：
        getDerivedGaugeTimeStamp in interface GaugeMonitorMBean
        参数：
        object - the name of the object whose derived gauge timestamp is to be returned.
        返回：
        The derived gauge timestamp of the specified object.

      • getDerivedGauge

        @Deprecated
public Number getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Returns the derived gauge of the first object in the set of observed MBeans.
        指定者：
        getDerivedGauge in interface GaugeMonitorMBean
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
public long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp of the first object in the set of observed MBeans.
        指定者：
        getDerivedGaugeTimeStamp in interface GaugeMonitorMBean
        返回：
        The derived gauge timestamp.

      • getHighThreshold

        public Number getHighThreshold()
        Gets the high threshold value common to all observed MBeans.
        指定者：
        getHighThreshold in interface GaugeMonitorMBean
        返回：
        The high threshold value.
        另请参见：
        setThresholds(java.lang.Number, java.lang.Number)

      • getLowThreshold

        public Number getLowThreshold()
        Gets the low threshold value common to all observed MBeans.
        指定者：
        getLowThreshold in interface GaugeMonitorMBean
        返回：
        The low threshold value.
        另请参见：
        setThresholds(java.lang.Number, java.lang.Number)

      • setThresholds

        public void setThresholds(Number highValue,
                 Number lowValue)
                   throws IllegalArgumentException
        Sets the high and the low threshold values common to all observed MBeans.
        指定者：
        setThresholds in interface GaugeMonitorMBean
        参数：
        highValue - The high threshold value.
        lowValue - The low threshold value.
        抛出：
        IllegalArgumentException - The specified high/low threshold is null or the low threshold is greater than the high threshold or the high threshold and the low threshold are not of the same type.
        另请参见：
        getHighThreshold(), getLowThreshold()

      • getNotifyHigh

        public boolean getNotifyHigh()
        Gets the high notification's on/off switch value common to all observed MBeans.
        指定者：
        getNotifyHigh in interface GaugeMonitorMBean
        返回：
        true if the gauge monitor notifies when exceeding the high threshold, false otherwise.
        另请参见：
        setNotifyHigh(boolean)

      • setNotifyHigh

        public void setNotifyHigh(boolean value)
        Sets the high notification's on/off switch value common to all observed MBeans.
        指定者：
        setNotifyHigh in interface GaugeMonitorMBean
        参数：
        value - The high notification's on/off switch value.
        另请参见：
        getNotifyHigh()

      • getNotifyLow

        public boolean getNotifyLow()
        Gets the low notification's on/off switch value common to all observed MBeans.
        指定者：
        getNotifyLow in interface GaugeMonitorMBean
        返回：
        true if the gauge monitor notifies when exceeding the low threshold, false otherwise.
        另请参见：
        setNotifyLow(boolean)

      • setNotifyLow

        public void setNotifyLow(boolean value)
        Sets the low notification's on/off switch value common to all observed MBeans.
        指定者：
        setNotifyLow in interface GaugeMonitorMBean
        参数：
        value - The low notification's on/off switch value.
        另请参见：
        getNotifyLow()

      • getDifferenceMode

        public boolean getDifferenceMode()
        Gets the difference mode flag value common to all observed MBeans.
        指定者：
        getDifferenceMode in interface GaugeMonitorMBean
        返回：
        true if the difference mode is used, false otherwise.
        另请参见：
        setDifferenceMode(boolean)

      • setDifferenceMode

        public void setDifferenceMode(boolean value)
        Sets the difference mode flag value common to all observed MBeans.
        指定者：
        setDifferenceMode in interface GaugeMonitorMBean
        参数：
        value - The difference mode flag value.
        另请参见：
        getDifferenceMode()

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.
        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GaugeMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.monitor

Interface GaugeMonitorMBean

  • All Superinterfaces:
    MonitorMBean
    All Known Implementing Classes:
    GaugeMonitor

    public interface GaugeMonitorMBean
extends MonitorMBean
    Exposes the remote management interface of the gauge monitor MBean.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Number getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      Number getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      boolean getDifferenceMode()
      Gets the difference mode flag value.
      Number getHighThreshold()
      Gets the high threshold value.
      Number getLowThreshold()
      Gets the low threshold value.
      boolean getNotifyHigh()
      Gets the high notification's on/off switch value.
      boolean getNotifyLow()
      Gets the low notification's on/off switch value.
      void setDifferenceMode(boolean value)
      Sets the difference mode flag value.
      void setNotifyHigh(boolean value)
      Sets the high notification's on/off switch value.
      void setNotifyLow(boolean value)
      Sets the low notification's on/off switch value.
      void setThresholds(Number highValue, Number lowValue)
      Sets the high and the low threshold values.

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

    • 方法详细信息

      • getDerivedGauge

        @Deprecated
Number getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Gets the derived gauge.
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp.
        返回：
        The derived gauge timestamp.

      • getDerivedGauge

        Number getDerivedGauge(ObjectName object)
        Gets the derived gauge for the specified MBean.
        参数：
        object - the MBean for which the derived gauge is to be returned
        返回：
        The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getDerivedGaugeTimeStamp

        long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp for the specified MBean.
        参数：
        object - the MBean for which the derived gauge timestamp is to be returned
        返回：
        The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getHighThreshold

        Number getHighThreshold()
        Gets the high threshold value.
        返回：
        The high threshold value.

      • getLowThreshold

        Number getLowThreshold()
        Gets the low threshold value.
        返回：
        The low threshold value.

      • setThresholds

        void setThresholds(Number highValue,
                 Number lowValue)
                   throws IllegalArgumentException
        Sets the high and the low threshold values.
        参数：
        highValue - The high threshold value.
        lowValue - The low threshold value.
        抛出：
        IllegalArgumentException - The specified high/low threshold is null or the low threshold is greater than the high threshold or the high threshold and the low threshold are not of the same type.

      • getNotifyHigh

        boolean getNotifyHigh()
        Gets the high notification's on/off switch value.
        返回：
        true if the gauge monitor notifies when exceeding the high threshold, false otherwise.
        另请参见：
        setNotifyHigh(boolean)

      • setNotifyHigh

        void setNotifyHigh(boolean value)
        Sets the high notification's on/off switch value.
        参数：
        value - The high notification's on/off switch value.
        另请参见：
        getNotifyHigh()

      • getNotifyLow

        boolean getNotifyLow()
        Gets the low notification's on/off switch value.
        返回：
        true if the gauge monitor notifies when exceeding the low threshold, false otherwise.
        另请参见：
        setNotifyLow(boolean)

      • setNotifyLow

        void setNotifyLow(boolean value)
        Sets the low notification's on/off switch value.
        参数：
        value - The low notification's on/off switch value.
        另请参见：
        getNotifyLow()

      • getDifferenceMode

        boolean getDifferenceMode()
        Gets the difference mode flag value.
        返回：
        true if the difference mode is used, false otherwise.
        另请参见：
        setDifferenceMode(boolean)

      • setDifferenceMode

        void setDifferenceMode(boolean value)
        Sets the difference mode flag value.
        参数：
        value - The difference mode flag value.
        另请参见：
        getDifferenceMode()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b=se4 r> ro<


javax.management.monitor

Interfaces

  • CounterMonitorMBean
  • GaugeMonitorMBean
  • MonitorMBean
  • StringMonitorMBean

Classes

  • CounterMonitor
  • GaugeMonitor
  • Monitor
  • MonitorNotification
  • StringMonitor

Exceptions

  • MonitorSettingException
.


javax.management.monitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.monitor

Provides the definition of the monitor classes.

请参见： 描述

  • 接口摘要
    接口 描述
    CounterMonitorMBean
    Exposes the remote management interface of the counter monitor MBean.
    GaugeMonitorMBean
    Exposes the remote management interface of the gauge monitor MBean.
    MonitorMBean
    Exposes the remote management interface of monitor MBeans.
    StringMonitorMBean
    Exposes the remote management interface of the string monitor MBean.
  • Class Summary
    类 描述
    CounterMonitor
    Defines a monitor MBean designed to observe the values of a counter attribute.
    GaugeMonitor
    Defines a monitor MBean designed to observe the values of a gauge attribute.
    Monitor
    Defines the part common to all monitor MBeans.
    MonitorNotification
    Provides definitions of the notifications sent by monitor MBeans.
    StringMonitor
    Defines a monitor MBean designed to observe the values of a string attribute.
  • Exception Summary
    Exception 描述
    MonitorSettingException
    Exception thrown by the monitor when a monitor setting becomes invalid while the monitor is running.

软件包 javax.management.monitor Description

Provides the definition of the monitor classes. A Monitor is an MBean that periodically observes the value of an attribute in one or more other MBeans. If the attribute meets a certain condition, the Monitor emits a MonitorNotification. When the monitor MBean periodically calls getAttribute to retrieve the value of the attribute being monitored it does so within the access control context of the Monitor.start() caller.

The value being monitored can be a simple value contained within a complex type. For example, the MemoryMXBean defined in java.lang.management has an attribute HeapMemoryUsage of type MemoryUsage. To monitor the amount of used memory, described by the used property of MemoryUsage, you could monitor "HeapMemoryUsage.used". That string would be the argument to setObservedAttribute.

The rules used to interpret an ObservedAttribute like "HeapMemoryUsage.used" are as follows. Suppose the string is A.e (so A would be "HeapMemoryUsage" and e would be "used" in the example).

First the value of the attribute A is obtained. Call it v. A value x is extracted from v as follows:

  • If v is a CompositeData and if v.get(e) returns a value then x is that value.
  • If v is an array and e is the string "length" then x is the length of the array.
  • If the above rules do not produce a value, and if Introspector.getBeanInfo for the class of v (v.getClass()) contains a PropertyDescriptor with the name e, then x is the result of calling the property's read method on v.

The third rule means for example that if the attribute HeapMemoryUsage is a MemoryUsage, monitoring "HeapMemoryUsage.used" will obtain the observed value by calling MemoryUsage.getUsed().

If the ObservedAttribute contains more than one period, for example "ConnectionPool.connectionStats.length", then the above rules are applied iteratively. Here, v would initially be the value of the attribute ConnectionPool, and x would be derived by applying the above rules with e equal to "connectionStats". Then v would be set to this x and a new x derived by applying the rules again with e equal to "length".

Although it is recommended that attribute names be valid Java identifiers, it is possible for an attribute to be called HeapMemoryUsage.used. This means that an ObservedAttribute that is HeapMemoryUsage.used could mean that the value to observe is either an attribute of that name, or the property used within an attribute called HeapMemoryUsage. So for compatibility reasons, when the ObservedAttribute contains a period (.), the monitor will check whether an attribute exists whose name is the full ObservedAttribute string (HeapMemoryUsage.used in the example). It does this by calling getMBeanInfo for the observed MBean and looking for a contained MBeanAttributeInfo with the given name. If one is found, then that is what is monitored. If more than one MBean is being observed, the behavior is unspecified if some of them have a HeapMemoryUsage.used attribute and others do not. An implementation may therefore call getMBeanInfo on just one of the MBeans in this case. The behavior is also unspecified if the result of the check changes while the monitor is active.

The exact behavior of monitors is detailed in the JMX Specification. What follows is a summary.

There are three kinds of Monitors:

  • A CounterMonitor observes attributes of integer type. The attributes are assumed to be non-negative, and monotonically increasing except for a possible roll-over at a specified modulus. Each observed attribute has an associated threshold value. A notification is sent when the attribute exceeds its threshold.

    An offset value can be specified. When an observed value exceeds its threshold, the threshold is incremented by the offset, or by a multiple of the offset sufficient to make the threshold greater than the new observed value.

    A CounterMonitor can operate in difference mode. In this mode, the value compared against the threshold is the difference between two successive observations of an attribute.

  • A GaugeMonitor observes attributes of numerical type. Each observed attribute has an associated high threshold and low threshold.

    When an observed attribute crosses the high threshold, if the notify high flag is true, then a notification is sent. Subsequent crossings of the high threshold value will not trigger further notifications until the gauge value becomes less than or equal to the low threshold.

    When an observed attribute crosses the low threshold, if the notify low flag is true, then a notification is sent. Subsequent crossings of the low threshold value will not trigger further notifications until the gauge value becomes greater than or equal to the high threshold.

    Typically, only one of the notify high and notify low flags is set. The other threshold is used to provide a hysteresis mechanism to avoid the repeated triggering of notifications when an attribute makes small oscillations around the threshold value.

    A GaugeMonitor can operate in difference mode. In this mode, the value compared against the high and low thresholds is the difference between two successive observations of an attribute.

  • A StringMonitor observes attributes of type String. A notification is sent when an observed attribute becomes equal and/or not equal to a given string.

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology, in particular the JMX Specification, version 1.4(pdf).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<..rhe(.>baadv/t


javax.management.monitor Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.monitor

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.monitor.MonitorNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException

Interface Hierarchy

  • javax.management.monitor.MonitorMBean
    • javax.management.monitor.CounterMonitorMBean
    • javax.management.monitor.GaugeMonitorMBean
    • javax.management.monitor.StringMonitorMBean
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n .ert hhh e>>>>> lt


Monitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.monitor

类 Monitor

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.monitor.Monitor
  • 所有已实现的接口：
    MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter
    直接已知子类：
    CounterMonitor, GaugeMonitor, StringMonitor

    public abstract class Monitor
extends NotificationBroadcasterSupport
implements MonitorMBean, MBeanRegistration
    Defines the part common to all monitor MBeans. A monitor MBean monitors values of an attribute common to a set of observed MBeans. The observed attribute is monitored at intervals specified by the granularity period. A gauge value (derived gauge) is derived from the values of the observed attribute.
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int alreadyNotified
      Deprecated.
      equivalent to alreadyNotifieds[0].
      protected int[] alreadyNotifieds
      Selected monitor errors that have already been notified.
      protected static int capacityIncrement
      The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
      protected String dbgTag
      Deprecated.
      No replacement.
      protected int elementCount
      The number of valid components in the vector of observed objects.
      protected static int OBSERVED_ATTRIBUTE_ERROR_NOTIFIED
      Flag denoting that a notification has occurred after changing the observed attribute.
      protected static int OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED
      Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
      protected static int OBSERVED_OBJECT_ERROR_NOTIFIED
      Flag denoting that a notification has occurred after changing the observed object.
      protected static int RESET_FLAGS_ALREADY_NOTIFIED
      This flag is used to reset the alreadyNotifieds monitor attribute.
      protected static int RUNTIME_ERROR_NOTIFIED
      Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
      protected MBeanServer server
      Reference to the MBean server.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Monitor()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addObservedObject(ObjectName object)
      Adds the specified object in the set of observed MBeans, if this object is not already present.
      boolean containsObservedObject(ObjectName object)
      Tests whether the specified object is in the set of observed MBeans.
      long getGranularityPeriod()
      Gets the granularity period (in milliseconds).
      String getObservedAttribute()
      Gets the attribute being observed.
      ObjectName getObservedObject()
      Deprecated.
      As of JMX 1.2, replaced by getObservedObjects()
      ObjectName[] getObservedObjects()
      Returns an array containing the objects being observed.
      boolean isActive()
      Tests whether the monitor MBean is active.
      void postDeregister()
      Allows the monitor MBean to perform any operations needed after having been unregistered by the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the monitor MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the monitor MBean to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.
      void removeObservedObject(ObjectName object)
      Removes the specified object from the set of observed MBeans.
      void setGranularityPeriod(long period)
      Sets the granularity period (in milliseconds).
      void setObservedAttribute(String attribute)
      Sets the attribute to observe.
      void setObservedObject(ObjectName object)
      Deprecated.
      As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
      abstract void start()
      Starts the monitor.
      abstract void stop()
      Stops the monitor.

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, getNotificationInfo, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • capacityIncrement

        protected static final int capacityIncrement
        The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
        另请参见：
        Constant Field Values

      • elementCount

        protected int elementCount
        The number of valid components in the vector of observed objects.

      • alreadyNotified

        @Deprecated
protected int alreadyNotified
        Deprecated. equivalent to alreadyNotifieds[0].
        Monitor errors that have already been notified.

      • alreadyNotifieds

        protected int[] alreadyNotifieds

        Selected monitor errors that have already been notified.

        Each element in this array corresponds to an observed object in the vector. It contains a bit mask of the flags OBSERVED_OBJECT_ERROR_NOTIFIED etc, indicating whether the corresponding notification has already been sent for the MBean being monitored.

      • server

        protected MBeanServer server
        Reference to the MBean server. This reference is null when the monitor MBean is not registered in an MBean server. This reference is initialized before the monitor MBean is registered in the MBean server.
        另请参见：
        preRegister(MBeanServer server, ObjectName name)

      • RESET_FLAGS_ALREADY_NOTIFIED

        protected static final int RESET_FLAGS_ALREADY_NOTIFIED
        This flag is used to reset the alreadyNotifieds monitor attribute.
        另请参见：
        Constant Field Values

      • OBSERVED_OBJECT_ERROR_NOTIFIED

        protected static final int OBSERVED_OBJECT_ERROR_NOTIFIED
        Flag denoting that a notification has occurred after changing the observed object. This flag is used to check that the new observed object is registered in the MBean server at the time of the first notification.
        另请参见：
        Constant Field Values

      • OBSERVED_ATTRIBUTE_ERROR_NOTIFIED

        protected static final int OBSERVED_ATTRIBUTE_ERROR_NOTIFIED
        Flag denoting that a notification has occurred after changing the observed attribute. This flag is used to check that the new observed attribute belongs to the observed object at the time of the first notification.
        另请参见：
        Constant Field Values

      • OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED

        protected static final int OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED
        Flag denoting that a notification has occurred after changing the observed object or the observed attribute. This flag is used to check that the observed attribute type is correct (depending on the monitor in use) at the time of the first notification.
        另请参见：
        Constant Field Values

      • RUNTIME_ERROR_NOTIFIED

        protected static final int RUNTIME_ERROR_NOTIFIED
        Flag denoting that a notification has occurred after changing the observed object or the observed attribute. This flag is used to notify any exception (except the cases described above) when trying to get the value of the observed attribute at the time of the first notification.
        另请参见：
        Constant Field Values

      • dbgTag

        @Deprecated
protected String dbgTag
        Deprecated. No replacement.
        This field is retained for compatibility but should not be referenced.

    • 构造方法详细信息

      • Monitor

        public Monitor()

    • 方法详细信息

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.

        Initializes the reference to the MBean server.

        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean server in which the monitor MBean will be registered.
        name - The object name of the monitor MBean.
        返回：
        The name of the monitor MBean registered.
        抛出：
        Exception

      • postRegister

        public void postRegister(Boolean registrationDone)
        Allows the monitor MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        Not used in this context.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        Allows the monitor MBean to perform any operations it needs before being unregistered by the MBean server.

        Stops the monitor.

        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        Exception

      • postDeregister

        public void postDeregister()
        Allows the monitor MBean to perform any operations needed after having been unregistered by the MBean server.

        Not used in this context.

        指定者：
        postDeregister in interface MBeanRegistration

      • start

        public abstract void start()
        Starts the monitor.
        指定者：
        start in interface MonitorMBean

      • stop

        public abstract void stop()
        Stops the monitor.
        指定者：
        stop in interface MonitorMBean

      • getObservedObject

        @Deprecated
public ObjectName getObservedObject()
        Deprecated. As of JMX 1.2, replaced by getObservedObjects()
        Returns the object name of the first object in the set of observed MBeans, or null if there is no such object.
        指定者：
        getObservedObject in interface MonitorMBean
        返回：
        The object being observed.
        另请参见：
        setObservedObject(ObjectName)

      • setObservedObject

        @Deprecated
public void setObservedObject(ObjectName object)
                       throws IllegalArgumentException
        Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
        Removes all objects from the set of observed objects, and then adds the specified object.
        指定者：
        setObservedObject in interface MonitorMBean
        参数：
        object - The object to observe.
        抛出：
        IllegalArgumentException - The specified object is null.
        另请参见：
        getObservedObject()

      • addObservedObject

        public void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
        Adds the specified object in the set of observed MBeans, if this object is not already present.
        指定者：
        addObservedObject in interface MonitorMBean
        参数：
        object - The object to observe.
        抛出：
        IllegalArgumentException - The specified object is null.

      • removeObservedObject

        public void removeObservedObject(ObjectName object)
        Removes the specified object from the set of observed MBeans.
        指定者：
        removeObservedObject in interface MonitorMBean
        参数：
        object - The object to remove.

      • containsObservedObject

        public boolean containsObservedObject(ObjectName object)
        Tests whether the specified object is in the set of observed MBeans.
        指定者：
        containsObservedObject in interface MonitorMBean
        参数：
        object - The object to check.
        返回：
        true if the specified object is present, false otherwise.

      • getObservedObjects

        public ObjectName[] getObservedObjects()
        Returns an array containing the objects being observed.
        指定者：
        getObservedObjects in interface MonitorMBean
        返回：
        The objects being observed.

      • getObservedAttribute

        public String getObservedAttribute()
        Gets the attribute being observed.
        The observed attribute is not initialized by default (set to null).
        指定者：
        getObservedAttribute in interface MonitorMBean
        返回：
        The attribute being observed.
        另请参见：
        setObservedAttribute(java.lang.String)

      • setObservedAttribute

        public void setObservedAttribute(String attribute)
                          throws IllegalArgumentException
        Sets the attribute to observe.
        The observed attribute is not initialized by default (set to null).
        指定者：
        setObservedAttribute in interface MonitorMBean
        参数：
        attribute - The attribute to observe.
        抛出：
        IllegalArgumentException - The specified attribute is null.
        另请参见：
        getObservedAttribute()

      • getGranularityPeriod

        public long getGranularityPeriod()
        Gets the granularity period (in milliseconds).
        The default value of the granularity period is 10 seconds.
        指定者：
        getGranularityPeriod in interface MonitorMBean
        返回：
        The granularity period value.
        另请参见：
        setGranularityPeriod(long)

      • setGranularityPeriod

        public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
        Sets the granularity period (in milliseconds).
        The default value of the granularity period is 10 seconds.
        指定者：
        setGranularityPeriod in interface MonitorMBean
        参数：
        period - The granularity period value.
        抛出：
        IllegalArgumentException - The granularity period is less than or equal to zero.
        另请参见：
        getGranularityPeriod()

      • isActive

        public boolean isActive()
        Tests whether the monitor MBean is active. A monitor MBean is marked active when the start method is called. It becomes inactive when the stop method is called.
        指定者：
        isActive in interface MonitorMBean
        返回：
        true if the monitor MBean is active, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�;


MonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.monitor

Interface MonitorMBean

  • All Known Subinterfaces:
    CounterMonitorMBean, GaugeMonitorMBean, StringMonitorMBean
    All Known Implementing Classes:
    CounterMonitor, GaugeMonitor, Monitor, StringMonitor

    public interface MonitorMBean
    Exposes the remote management interface of monitor MBeans.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addObservedObject(ObjectName object)
      Adds the specified object in the set of observed MBeans.
      boolean containsObservedObject(ObjectName object)
      Tests whether the specified object is in the set of observed MBeans.
      long getGranularityPeriod()
      Gets the granularity period (in milliseconds).
      String getObservedAttribute()
      Gets the attribute being observed.
      ObjectName getObservedObject()
      Deprecated.
      As of JMX 1.2, replaced by getObservedObjects()
      ObjectName[] getObservedObjects()
      Returns an array containing the objects being observed.
      boolean isActive()
      Tests if the monitor MBean is active.
      void removeObservedObject(ObjectName object)
      Removes the specified object from the set of observed MBeans.
      void setGranularityPeriod(long period)
      Sets the granularity period (in milliseconds).
      void setObservedAttribute(String attribute)
      Sets the attribute to observe.
      void setObservedObject(ObjectName object)
      Deprecated.
      As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
      void start()
      Starts the monitor.
      void stop()
      Stops the monitor.

    • 方法详细信息

      • start

        void start()
        Starts the monitor.

      • stop

        void stop()
        Stops the monitor.

      • addObservedObject

        void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
        Adds the specified object in the set of observed MBeans.
        参数：
        object - The object to observe.
        抛出：
        IllegalArgumentException - the specified object is null.

      • removeObservedObject

        void removeObservedObject(ObjectName object)
        Removes the specified object from the set of observed MBeans.
        参数：
        object - The object to remove.

      • containsObservedObject

        boolean containsObservedObject(ObjectName object)
        Tests whether the specified object is in the set of observed MBeans.
        参数：
        object - The object to check.
        返回：
        true if the specified object is in the set, false otherwise.

      • getObservedObjects

        ObjectName[] getObservedObjects()
        Returns an array containing the objects being observed.
        返回：
        The objects being observed.

      • getObservedObject

        @Deprecated
ObjectName getObservedObject()
        Deprecated. As of JMX 1.2, replaced by getObservedObjects()
        Gets the object name of the object being observed.
        返回：
        The object being observed.
        另请参见：
        setObservedObject(javax.management.ObjectName)

      • setObservedObject

        @Deprecated
void setObservedObject(ObjectName object)
        Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
        Sets the object to observe identified by its object name.
        参数：
        object - The object to observe.
        另请参见：
        getObservedObject()

      • getObservedAttribute

        String getObservedAttribute()
        Gets the attribute being observed.
        返回：
        The attribute being observed.
        另请参见：
        setObservedAttribute(java.lang.String)

      • setObservedAttribute

        void setObservedAttribute(String attribute)
        Sets the attribute to observe.
        参数：
        attribute - The attribute to observe.
        另请参见：
        getObservedAttribute()

      • getGranularityPeriod

        long getGranularityPeriod()
        Gets the granularity period (in milliseconds).
        返回：
        The granularity period.
        另请参见：
        setGranularityPeriod(long)

      • setGranularityPeriod

        void setGranularityPeriod(long period)
                          throws IllegalArgumentException
        Sets the granularity period (in milliseconds).
        参数：
        period - The granularity period.
        抛出：
        IllegalArgumentException - The granularity period is less than or equal to zero.
        另请参见：
        getGranularityPeriod()

      • isActive

        boolean isActive()
        Tests if the monitor MBean is active. A monitor MBean is marked active when the start method is called. It becomes inactive when the stop method is called.
        返回：
        true if the monitor MBean is active, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tloStlcmlcettceegjffaa.m .,,m./tc


MonitorNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.monitor

类 MonitorNotification

  • java.lang.Object
    • java.util.EventObject
      • javax.management.Notification
        • javax.management.monitor.MonitorNotification
  • 所有已实现的接口：
    Serializable

    public class MonitorNotification
extends Notification
    Provides definitions of the notifications sent by monitor MBeans.

    The notification source and a set of parameters concerning the monitor MBean's state need to be specified when creating a new object of this class. The list of notifications fired by the monitor MBeans is the following:

    • Common to all kind of monitors:
      • The observed object is not registered in the MBean server.
      • The observed attribute is not contained in the observed object.
      • The type of the observed attribute is not correct.
      • Any exception (except the cases described above) occurs when trying to get the value of the observed attribute.
    • Common to the counter and the gauge monitors:
      • The threshold high or threshold low are not of the same type as the gauge (gauge monitors).
      • The threshold or the offset or the modulus are not of the same type as the counter (counter monitors).
    • Counter monitors only:
      • The observed attribute has reached the threshold value.
    • Gauge monitors only:
      • The observed attribute has exceeded the threshold high value.
      • The observed attribute has exceeded the threshold low value.
    • String monitors only:
      • The observed attribute has matched the "string to compare" value.
      • The observed attribute has differed from the "string to compare" value.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OBSERVED_ATTRIBUTE_ERROR
      Notification type denoting that the observed attribute is not contained in the observed object.
      static String OBSERVED_ATTRIBUTE_TYPE_ERROR
      Notification type denoting that the type of the observed attribute is not correct.
      static String OBSERVED_OBJECT_ERROR
      Notification type denoting that the observed object is not registered in the MBean server.
      static String RUNTIME_ERROR
      Notification type denoting that a non-predefined error type has occurred when trying to get the value of the observed attribute.
      static String STRING_TO_COMPARE_VALUE_DIFFERED
      Notification type denoting that the observed attribute has differed from the "string to compare" value.
      static String STRING_TO_COMPARE_VALUE_MATCHED
      Notification type denoting that the observed attribute has matched the "string to compare" value.
      static String THRESHOLD_ERROR
      Notification type denoting that the type of the thresholds, offset or modulus is not correct.
      static String THRESHOLD_HIGH_VALUE_EXCEEDED
      Notification type denoting that the observed attribute has exceeded the threshold high value.
      static String THRESHOLD_LOW_VALUE_EXCEEDED
      Notification type denoting that the observed attribute has exceeded the threshold low value.
      static String THRESHOLD_VALUE_EXCEEDED
      Notification type denoting that the observed attribute has reached the threshold value.

      • Fields inherited from class javax.management.Notification

        source

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getDerivedGauge()
      Gets the derived gauge of this monitor notification.
      String getObservedAttribute()
      Gets the observed attribute of this monitor notification.
      ObjectName getObservedObject()
      Gets the observed object of this monitor notification.
      Object getTrigger()
      Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.

      • 方法 - 继承于类 javax.management.Notification

        getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OBSERVED_OBJECT_ERROR

        public static final String OBSERVED_OBJECT_ERROR
        Notification type denoting that the observed object is not registered in the MBean server. This notification is fired by all kinds of monitors.
        The value of this notification type is jmx.monitor.error.mbean.
        另请参见：
        Constant Field Values

      • OBSERVED_ATTRIBUTE_ERROR

        public static final String OBSERVED_ATTRIBUTE_ERROR
        Notification type denoting that the observed attribute is not contained in the observed object. This notification is fired by all kinds of monitors.
        The value of this notification type is jmx.monitor.error.attribute.
        另请参见：
        Constant Field Values

      • OBSERVED_ATTRIBUTE_TYPE_ERROR

        public static final String OBSERVED_ATTRIBUTE_TYPE_ERROR
        Notification type denoting that the type of the observed attribute is not correct. This notification is fired by all kinds of monitors.
        The value of this notification type is jmx.monitor.error.type.
        另请参见：
        Constant Field Values

      • THRESHOLD_ERROR

        public static final String THRESHOLD_ERROR
        Notification type denoting that the type of the thresholds, offset or modulus is not correct. This notification is fired by counter and gauge monitors.
        The value of this notification type is jmx.monitor.error.threshold.
        另请参见：
        Constant Field Values

      • RUNTIME_ERROR

        public static final String RUNTIME_ERROR
        Notification type denoting that a non-predefined error type has occurred when trying to get the value of the observed attribute. This notification is fired by all kinds of monitors.
        The value of this notification type is jmx.monitor.error.runtime.
        另请参见：
        Constant Field Values

      • THRESHOLD_VALUE_EXCEEDED

        public static final String THRESHOLD_VALUE_EXCEEDED
        Notification type denoting that the observed attribute has reached the threshold value. This notification is only fired by counter monitors.
        The value of this notification type is jmx.monitor.counter.threshold.
        另请参见：
        Constant Field Values

      • THRESHOLD_HIGH_VALUE_EXCEEDED

        public static final String THRESHOLD_HIGH_VALUE_EXCEEDED
        Notification type denoting that the observed attribute has exceeded the threshold high value. This notification is only fired by gauge monitors.
        The value of this notification type is jmx.monitor.gauge.high.
        另请参见：
        Constant Field Values

      • THRESHOLD_LOW_VALUE_EXCEEDED

        public static final String THRESHOLD_LOW_VALUE_EXCEEDED
        Notification type denoting that the observed attribute has exceeded the threshold low value. This notification is only fired by gauge monitors.
        The value of this notification type is jmx.monitor.gauge.low.
        另请参见：
        Constant Field Values

      • STRING_TO_COMPARE_VALUE_MATCHED

        public static final String STRING_TO_COMPARE_VALUE_MATCHED
        Notification type denoting that the observed attribute has matched the "string to compare" value. This notification is only fired by string monitors.
        The value of this notification type is jmx.monitor.string.matches.
        另请参见：
        Constant Field Values

      • STRING_TO_COMPARE_VALUE_DIFFERED

        public static final String STRING_TO_COMPARE_VALUE_DIFFERED
        Notification type denoting that the observed attribute has differed from the "string to compare" value. This notification is only fired by string monitors.
        The value of this notification type is jmx.monitor.string.differs.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getObservedObject

        public ObjectName getObservedObject()
        Gets the observed object of this monitor notification.
        返回：
        The observed object.

      • getObservedAttribute

        public String getObservedAttribute()
        Gets the observed attribute of this monitor notification.
        返回：
        The observed attribute.

      • getDerivedGauge

        public Object getDerivedGauge()
        Gets the derived gauge of this monitor notification.
        返回：
        The derived gauge.

      • getTrigger

        public Object getTrigger()
        Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.
        返回：
        The trigger.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f/< <鵳 enaoa瞡 o蛂ht


MonitorSettingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.monitor

类 MonitorSettingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException
  • 所有已实现的接口：
    Serializable

    public class MonitorSettingException
extends JMRuntimeException
    Exception thrown by the monitor when a monitor setting becomes invalid while the monitor is running.

    As the monitor attributes may change at runtime, a check is performed before each observation. If a monitor attribute has become invalid, a monitor setting exception is thrown.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MonitorSettingException()
      Default constructor.
      MonitorSettingException(String message)
      Constructor that allows an error message to be specified.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MonitorSettingException

        public MonitorSettingException()
        Default constructor.

      • MonitorSettingException

        public MonitorSettingException(String message)
        Constructor that allows an error message to be specified.
        参数：
        message - The specific error message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>///a.ja..//...=>cc"lsesssal>egcejO=<


StringMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.monitor

类 StringMonitor

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.monitor.Monitor
        • javax.management.monitor.StringMonitor
  • 所有已实现的接口：
    MBeanRegistration, MonitorMBean, StringMonitorMBean, NotificationBroadcaster, NotificationEmitter

    public class StringMonitor
extends Monitor
implements StringMonitorMBean
    Defines a monitor MBean designed to observe the values of a string attribute.

    A string monitor sends notifications as follows:

    • if the attribute value matches the string to compare value, a match notification is sent. The notify match flag must be set to true.
      Subsequent matchings of the string to compare values do not cause further notifications unless the attribute value differs from the string to compare value.
    • if the attribute value differs from the string to compare value, a differ notification is sent. The notify differ flag must be set to true.
      Subsequent differences from the string to compare value do not cause further notifications unless the attribute value matches the string to compare value.
    从以下版本开始：
    1.5

    • 字段摘要

      • Fields inherited from class javax.management.monitor.Monitor

        alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringMonitor()
      Default constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      String getDerivedGauge(ObjectName object)
      Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.
      boolean getNotifyDiffer()
      Gets the differing notification's on/off switch value common to all observed MBeans.
      boolean getNotifyMatch()
      Gets the matching notification's on/off switch value common to all observed MBeans.
      String getStringToCompare()
      Gets the string to compare with the observed attribute common to all observed MBeans.
      void setNotifyDiffer(boolean value)
      Sets the differing notification's on/off switch value common to all observed MBeans.
      void setNotifyMatch(boolean value)
      Sets the matching notification's on/off switch value common to all observed MBeans.
      void setStringToCompare(String value)
      Sets the string to compare with the observed attribute common to all observed MBeans.
      void start()
      Starts the string monitor.
      void stop()
      Stops the string monitor.

      • 方法 - 继承于类 javax.management.monitor.Monitor

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

    • 构造方法详细信息

      • StringMonitor

        public StringMonitor()
        Default constructor.

    • 方法详细信息

      • start

        public void start()
        Starts the string monitor.
        指定者：
        start in interface MonitorMBean
        指定者：
        start in class Monitor

      • stop

        public void stop()
        Stops the string monitor.
        指定者：
        stop in interface MonitorMBean
        指定者：
        stop in class Monitor

      • getDerivedGauge

        public String getDerivedGauge(ObjectName object)
        Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
        指定者：
        getDerivedGauge in interface StringMonitorMBean
        参数：
        object - the name of the MBean whose derived gauge is required.
        返回：
        The derived gauge of the specified object.

      • getDerivedGaugeTimeStamp

        public long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.
        指定者：
        getDerivedGaugeTimeStamp in interface StringMonitorMBean
        参数：
        object - the name of the object whose derived gauge timestamp is to be returned.
        返回：
        The derived gauge timestamp of the specified object.

      • getDerivedGauge

        @Deprecated
public String getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Returns the derived gauge of the first object in the set of observed MBeans.
        指定者：
        getDerivedGauge in interface StringMonitorMBean
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
public long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp of the first object in the set of observed MBeans.
        指定者：
        getDerivedGaugeTimeStamp in interface StringMonitorMBean
        返回：
        The derived gauge timestamp.

      • getStringToCompare

        public String getStringToCompare()
        Gets the string to compare with the observed attribute common to all observed MBeans.
        指定者：
        getStringToCompare in interface StringMonitorMBean
        返回：
        The string value.
        另请参见：
        setStringToCompare(java.lang.String)

      • setStringToCompare

        public void setStringToCompare(String value)
                        throws IllegalArgumentException
        Sets the string to compare with the observed attribute common to all observed MBeans.
        指定者：
        setStringToCompare in interface StringMonitorMBean
        参数：
        value - The string value.
        抛出：
        IllegalArgumentException - The specified string to compare is null.
        另请参见：
        getStringToCompare()

      • getNotifyMatch

        public boolean getNotifyMatch()
        Gets the matching notification's on/off switch value common to all observed MBeans.
        指定者：
        getNotifyMatch in interface StringMonitorMBean
        返回：
        true if the string monitor notifies when matching the string to compare, false otherwise.
        另请参见：
        setNotifyMatch(boolean)

      • setNotifyMatch

        public void setNotifyMatch(boolean value)
        Sets the matching notification's on/off switch value common to all observed MBeans.
        指定者：
        setNotifyMatch in interface StringMonitorMBean
        参数：
        value - The matching notification's on/off switch value.
        另请参见：
        getNotifyMatch()

      • getNotifyDiffer

        public boolean getNotifyDiffer()
        Gets the differing notification's on/off switch value common to all observed MBeans.
        指定者：
        getNotifyDiffer in interface StringMonitorMBean
        返回：
        true if the string monitor notifies when differing from the string to compare, false otherwise.
        另请参见：
        setNotifyDiffer(boolean)

      • setNotifyDiffer

        public void setNotifyDiffer(boolean value)
        Sets the differing notification's on/off switch value common to all observed MBeans.
        指定者：
        setNotifyDiffer in interface StringMonitorMBean
        参数：
        value - The differing notification's on/off switch value.
        另请参见：
        getNotifyDiffer()

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.
        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.monitor

Interface StringMonitorMBean

  • All Superinterfaces:
    MonitorMBean
    All Known Implementing Classes:
    StringMonitor

    public interface StringMonitorMBean
extends MonitorMBean
    Exposes the remote management interface of the string monitor MBean.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDerivedGauge()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
      String getDerivedGauge(ObjectName object)
      Gets the derived gauge for the specified MBean.
      long getDerivedGaugeTimeStamp()
      Deprecated.
      As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
      long getDerivedGaugeTimeStamp(ObjectName object)
      Gets the derived gauge timestamp for the specified MBean.
      boolean getNotifyDiffer()
      Gets the differing notification's on/off switch value.
      boolean getNotifyMatch()
      Gets the matching notification's on/off switch value.
      String getStringToCompare()
      Gets the string to compare with the observed attribute.
      void setNotifyDiffer(boolean value)
      Sets the differing notification's on/off switch value.
      void setNotifyMatch(boolean value)
      Sets the matching notification's on/off switch value.
      void setStringToCompare(String value)
      Sets the string to compare with the observed attribute.

      • 方法 - 继承于接口 javax.management.monitor.MonitorMBean

        addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

    • 方法详细信息

      • getDerivedGauge

        @Deprecated
String getDerivedGauge()
        Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
        Gets the derived gauge.
        返回：
        The derived gauge.

      • getDerivedGaugeTimeStamp

        @Deprecated
long getDerivedGaugeTimeStamp()
        Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
        Gets the derived gauge timestamp.
        返回：
        The derived gauge timestamp.

      • getDerivedGauge

        String getDerivedGauge(ObjectName object)
        Gets the derived gauge for the specified MBean.
        参数：
        object - the MBean for which the derived gauge is to be returned
        返回：
        The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getDerivedGaugeTimeStamp

        long getDerivedGaugeTimeStamp(ObjectName object)
        Gets the derived gauge timestamp for the specified MBean.
        参数：
        object - the MBean for which the derived gauge timestamp is to be returned
        返回：
        The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.

      • getStringToCompare

        String getStringToCompare()
        Gets the string to compare with the observed attribute.
        返回：
        The string value.
        另请参见：
        setStringToCompare(java.lang.String)

      • setStringToCompare

        void setStringToCompare(String value)
                        throws IllegalArgumentException
        Sets the string to compare with the observed attribute.
        参数：
        value - The string value.
        抛出：
        IllegalArgumentException - The specified string to compare is null.
        另请参见：
        getStringToCompare()

      • getNotifyMatch

        boolean getNotifyMatch()
        Gets the matching notification's on/off switch value.
        返回：
        true if the string monitor notifies when matching, false otherwise.
        另请参见：
        setNotifyMatch(boolean)

      • setNotifyMatch

        void setNotifyMatch(boolean value)
        Sets the matching notification's on/off switch value.
        参数：
        value - The matching notification's on/off switch value.
        另请参见：
        getNotifyMatch()

      • getNotifyDiffer

        boolean getNotifyDiffer()
        Gets the differing notification's on/off switch value.
        返回：
        true if the string monitor notifies when differing, false otherwise.
        另请参见：
        setNotifyDiffer(boolean)

      • setNotifyDiffer

        void setNotifyDiffer(boolean value)
        Sets the differing notification's on/off switch value.
        参数：
        value - The differing notification's on/off switch value.
        另请参见：
        getNotifyDiffer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ees>>oPttjOvev


Uses of Package javax.management.monitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.monitor

  • Packages that use javax.management.monitor
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.
  • Classes in javax.management.monitor used by javax.management.monitor
    类与描述
    CounterMonitorMBean
    Exposes the remote management interface of the counter monitor MBean.
    GaugeMonitorMBean
    Exposes the remote management interface of the gauge monitor MBean.
    Monitor
    Defines the part common to all monitor MBeans.
    MonitorMBean
    Exposes the remote management interface of monitor MBeans.
    StringMonitorMBean
    Exposes the remote management interface of the string monitor MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"=i/


Uses of Class javax.management.monitor.CounterMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.CounterMonitor

No usage of javax.management.monitor.CounterMonitor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.monitor.GaugeMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.GaugeMonitor

No usage of javax.management.monitor.GaugeMonitor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.monitor.Monitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.Monitor

  • Packages that use Monitor
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.

    • Uses of Monitor in javax.management.monitor

      Subclasses of Monitor in javax.management.monitor
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o./tB/tf>ids,hA/aa/b.


Uses of Class javax.management.monitor.MonitorNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.MonitorNotification

No usage of javax.management.monitor.MonitorNotification
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oadoassdt >oaa<


Uses of Class javax.management.monitor.MonitorSettingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.MonitorSettingException

No usage of javax.management.monitor.MonitorSettingException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.monitor.StringMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.monitor.StringMonitor

No usage of javax.management.monitor.StringMonitor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

at—间讳篇嗽冰籶Ｃ怂�


Uses of Interface javax.management.monitor.CounterMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.monitor.CounterMonitorMBean

  • Packages that use CounterMonitorMBean
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.

    • Uses of CounterMonitorMBean in javax.management.monitor

      Classes in javax.management.monitor that implement CounterMonitorMBean
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.e.hLsdre et/p o>


Uses of Interface javax.management.monitor.GaugeMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.monitor.GaugeMonitorMBean

  • Packages that use GaugeMonitorMBean
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.

    • Uses of GaugeMonitorMBean in javax.management.monitor

      Classes in javax.management.monitor that implement GaugeMonitorMBean
      修饰符与类型 类与描述
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ym>/;


Uses of Interface javax.management.monitor.MonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.monitor.MonitorMBean

  • Packages that use MonitorMBean
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.

    • Uses of MonitorMBean in javax.management.monitor

      Subinterfaces of MonitorMBean in javax.management.monitor
      修饰符与类型 Interface and Description
      interface  CounterMonitorMBean
      Exposes the remote management interface of the counter monitor MBean.
      interface  GaugeMonitorMBean
      Exposes the remote management interface of the gauge monitor MBean.
      interface  StringMonitorMBean
      Exposes the remote management interface of the string monitor MBean.
      Classes in javax.management.monitor that implement MonitorMBean
      修饰符与类型 类与描述
      class  CounterMonitor
      Defines a monitor MBean designed to observe the values of a counter attribute.
      class  GaugeMonitor
      Defines a monitor MBean designed to observe the values of a gauge attribute.
      class  Monitor
      Defines the part common to all monitor MBeans.
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/l/"l"mr�8tikn:s//>h>


Uses of Interface javax.management.monitor.StringMonitorMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.monitor.StringMonitorMBean

  • Packages that use StringMonitorMBean
    软件包 描述
    javax.management.monitor
    Provides the definition of the monitor classes.

    • Uses of StringMonitorMBean in javax.management.monitor

      Classes in javax.management.monitor that implement StringMonitorMBean
      修饰符与类型 类与描述
      class  StringMonitor
      Defines a monitor MBean designed to observe the values of a string attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.&mn;tijl萢.. lt/st">ndtt


ArrayType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 ArrayType<T>

  • java.lang.Object
    • javax.management.openmbean.OpenType<T>
      • javax.management.openmbean.ArrayType<T>
  • 所有已实现的接口：
    Serializable

    public class ArrayType<T>
extends OpenType<T>
    The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.

    Examples of valid ArrayType instances are:

     // 2-dimension array of java.lang.String
 ArrayType a1 = new ArrayType(2, SimpleType.STRING);

 // 1-dimension array of int
 ArrayType a2 = new ArrayType(SimpleType.INTEGER, true);

 // 1-dimension array of java.lang.Integer
 ArrayType a3 = new ArrayType(SimpleType.INTEGER, false);

 // 4-dimension array of int
 ArrayType a4 = new ArrayType(3, a2);

 // 4-dimension array of java.lang.Integer
 ArrayType a5 = new ArrayType(3, a3);

 // 1-dimension array of java.lang.String
 ArrayType a6 = new ArrayType(SimpleType.STRING, false);

 // 1-dimension array of long
 ArrayType a7 = new ArrayType(SimpleType.LONG, true);

 // 1-dimension array of java.lang.Integer
 ArrayType a8 = ArrayType.getArrayType(SimpleType.INTEGER);

 // 2-dimension array of java.lang.Integer
 ArrayType a9 = ArrayType.getArrayType(a8);

 // 2-dimension array of int
 ArrayType a10 = ArrayType.getPrimitiveArrayType(int[][].class);

 // 3-dimension array of int
 ArrayType a11 = ArrayType.getArrayType(a10);

 // 1-dimension array of float
 ArrayType a12 = ArrayType.getPrimitiveArrayType(float[].class);

 // 2-dimension array of float
 ArrayType a13 = ArrayType.getArrayType(a12);

 // 1-dimension array of javax.management.ObjectName
 ArrayType a14 = ArrayType.getArrayType(SimpleType.OBJECTNAME);

 // 2-dimension array of javax.management.ObjectName
 ArrayType a15 = ArrayType.getArrayType(a14);

 // 3-dimension array of java.lang.String
 ArrayType a16 = new ArrayType(3, SimpleType.STRING);

 // 1-dimension array of java.lang.String
 ArrayType a17 = new ArrayType(1, SimpleType.STRING);

 // 2-dimension array of java.lang.String
 ArrayType a18 = new ArrayType(1, a17);

 // 3-dimension array of java.lang.String
 ArrayType a19 = new ArrayType(1, a18);
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.openmbean.OpenType

        ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ArrayType(int dimension, OpenType<?> elementType)
      Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
      ArrayType(SimpleType<?> elementType, boolean primitiveArray)
      Constructs a unidimensional ArrayType instance for the supplied SimpleType.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this ArrayType instance for equality.
      static <E> ArrayType<E[]> getArrayType(OpenType<E> elementType)
      Create an ArrayType instance in a type-safe manner.
      int getDimension()
      Returns the dimension of arrays described by this ArrayType instance.
      OpenType<?> getElementOpenType()
      Returns the open type of element values contained in the arrays described by this ArrayType instance.
      static <T> ArrayType<T> getPrimitiveArrayType(类<T> arrayClass)
      Create an ArrayType instance in a type-safe manner.
      int hashCode()
      Returns the hash code value for this ArrayType instance.
      boolean isPrimitiveArray()
      Returns true if the open data values this open type describes are primitive arrays, false otherwise.
      boolean isValue(Object obj)
      Tests whether obj is a value for this ArrayType instance.
      String toString()
      Returns a string representation of this ArrayType instance.

      • 方法 - 继承于类 javax.management.openmbean.OpenType

        getClassName, getDescription, getTypeName, isArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ArrayType

        public ArrayType(int dimension,
         OpenType<?> elementType)
          throws OpenDataException
        Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.

        When invoked on an ArrayType instance, the getClassName method returns the class name of the array instances it describes (following the rules defined by the getName method of java.lang.Class), not the class name of the array elements (which is returned by a call to getElementOpenType().getClassName()).

        The internal field corresponding to the type name of this ArrayType instance is also set to the class name of the array instances it describes. In other words, the methods getClassName and getTypeName return the same string value. The internal field corresponding to the description of this ArrayType instance is set to a string value which follows the following template:

        • if non-primitive array: <dimension>-dimension array of <element_class_name>
        • if primitive array: <dimension>-dimension array of <primitive_type_of_the_element_class_name>

        As an example, the following piece of code:

         ArrayType t = new ArrayType(3, SimpleType.STRING);
 System.out.println("array class name       = " + t.getClassName());
 System.out.println("element class name     = " + t.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t.getTypeName());
 System.out.println("array type description = " + t.getDescription());
        would produce the following output:
         array class name       = [[[Ljava.lang.String;
 element class name     = java.lang.String
 array type name        = [[[Ljava.lang.String;
 array type description = 3-dimension array of java.lang.String
        And the following piece of code which is equivalent to the one listed above would also produce the same output:
         ArrayType t1 = new ArrayType(1, SimpleType.STRING);
 ArrayType t2 = new ArrayType(1, t1);
 ArrayType t3 = new ArrayType(1, t2);
 System.out.println("array class name       = " + t3.getClassName());
 System.out.println("element class name     = " + t3.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t3.getTypeName());
 System.out.println("array type description = " + t3.getDescription());
        参数：
        dimension - the dimension of arrays described by this ArrayType instance; must be greater than or equal to 1.
        elementType - the open type of element values contained in the arrays described by this ArrayType instance; must be an instance of either SimpleType, CompositeType, TabularType or another ArrayType with a SimpleType, CompositeType or TabularType as its elementType.
        抛出：
        IllegalArgumentException - if dimension is not a positive integer.
        OpenDataException - if elementType's className is not one of the allowed Java class names for open data.

      • ArrayType

        public ArrayType(SimpleType<?> elementType,
         boolean primitiveArray)
          throws OpenDataException
        Constructs a unidimensional ArrayType instance for the supplied SimpleType.

        This constructor supports the creation of arrays of primitive types when primitiveArray is true.

        For primitive arrays the getElementOpenType() method returns the SimpleType corresponding to the wrapper type of the primitive type of the array.

        When invoked on an ArrayType instance, the getClassName method returns the class name of the array instances it describes (following the rules defined by the getName method of java.lang.Class), not the class name of the array elements (which is returned by a call to getElementOpenType().getClassName()).

        The internal field corresponding to the type name of this ArrayType instance is also set to the class name of the array instances it describes. In other words, the methods getClassName and getTypeName return the same string value. The internal field corresponding to the description of this ArrayType instance is set to a string value which follows the following template:

        • if non-primitive array: 1-dimension array of <element_class_name>
        • if primitive array: 1-dimension array of <primitive_type_of_the_element_class_name>

        As an example, the following piece of code:

         ArrayType t = new ArrayType(SimpleType.INTEGER, true);
 System.out.println("array class name       = " + t.getClassName());
 System.out.println("element class name     = " + t.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t.getTypeName());
 System.out.println("array type description = " + t.getDescription());
        would produce the following output:
         array class name       = [I
 element class name     = java.lang.Integer
 array type name        = [I
 array type description = 1-dimension array of int
        参数：
        elementType - the SimpleType of the element values contained in the arrays described by this ArrayType instance.
        primitiveArray - true when this array describes primitive arrays.
        抛出：
        IllegalArgumentException - if dimension is not a positive integer.
        OpenDataException - if primitiveArray is true and elementType is not a valid SimpleType for a primitive type.
        从以下版本开始：
        1.6

    • 方法详细信息

      • getDimension

        public int getDimension()
        Returns the dimension of arrays described by this ArrayType instance.
        返回：
        the dimension.

      • getElementOpenType

        public OpenType<?> getElementOpenType()
        Returns the open type of element values contained in the arrays described by this ArrayType instance.
        返回：
        the element type.

      • isPrimitiveArray

        public boolean isPrimitiveArray()
        Returns true if the open data values this open type describes are primitive arrays, false otherwise.
        返回：
        true if this is a primitive array type.
        从以下版本开始：
        1.6

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a value for this ArrayType instance.

        This method returns true if and only if obj is not null, obj is an array and any one of the following is true:

        • if this ArrayType instance describes an array of SimpleType elements or their corresponding primitive types, obj's class name is the same as the className field defined for this ArrayType instance (i.e. the class name returned by the getClassName method, which includes the dimension information),
        • if this ArrayType instance describes an array of classes implementing the TabularData interface or the CompositeData interface, obj is assignable to such a declared array, and each element contained in obj is either null or a valid value for the element's open type specified by this ArrayType instance.
        指定者：
        isValue in class OpenType<T>
        参数：
        obj - the object to be tested.
        返回：
        true if obj is a value for this ArrayType instance.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this ArrayType instance for equality.

        Two ArrayType instances are equal if and only if they describe array instances which have the same dimension, elements' open type and primitive array flag.

        指定者：
        equals in class OpenType<T>
        参数：
        obj - the object to be compared for equality with this ArrayType instance; if obj is null or is not an instance of the class ArrayType this method returns false.
        返回：
        true if the specified object is equal to this ArrayType instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this ArrayType instance.

        The hash code of an ArrayType instance is the sum of the hash codes of all the elements of information used in equals comparisons (i.e. dimension, elements' open type and primitive array flag). The hashcode for a primitive value is the hashcode of the corresponding boxed object (e.g. the hashcode for true is Boolean.TRUE.hashCode()). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two ArrayType instances t1 and t2, as required by the general contract of the method Object.hashCode().

        As ArrayType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in class OpenType<T>
        返回：
        the hash code value for this ArrayType instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this ArrayType instance.

        The string representation consists of the name of this class (i.e. javax.management.openmbean.ArrayType), the type name, the dimension, the elements' open type and the primitive array flag defined for this instance.

        As ArrayType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in class OpenType<T>
        返回：
        a string representation of this ArrayType instance

      • getArrayType

        public static <E> ArrayType<E[]> getArrayType(OpenType<E> elementType)
                                   throws OpenDataException
        Create an ArrayType instance in a type-safe manner.

        Multidimensional arrays can be built up by calling this method as many times as necessary.

        Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

        As an example, the following piece of code:

         ArrayType t1 = ArrayType.getArrayType(SimpleType.STRING);
 ArrayType t2 = ArrayType.getArrayType(t1);
 ArrayType t3 = ArrayType.getArrayType(t2);
 System.out.println("array class name       = " + t3.getClassName());
 System.out.println("element class name     = " + t3.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t3.getTypeName());
 System.out.println("array type description = " + t3.getDescription());
        would produce the following output:
         array class name       = [[[Ljava.lang.String;
 element class name     = java.lang.String
 array type name        = [[[Ljava.lang.String;
 array type description = 3-dimension array of java.lang.String
        参数：
        elementType - the open type of element values contained in the arrays described by this ArrayType instance; must be an instance of either SimpleType, CompositeType, TabularType or another ArrayType with a SimpleType, CompositeType or TabularType as its elementType.
        抛出：
        OpenDataException - if elementType's className is not one of the allowed Java class names for open data.
        从以下版本开始：
        1.6

      • getPrimitiveArrayType

        public static <T> ArrayType<T> getPrimitiveArrayType(类<T> arrayClass)
        Create an ArrayType instance in a type-safe manner.

        Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

        As an example, the following piece of code:

         ArrayType t = ArrayType.getPrimitiveArrayType(int[][][].class);
 System.out.println("array class name       = " + t.getClassName());
 System.out.println("element class name     = " + t.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t.getTypeName());
 System.out.println("array type description = " + t.getDescription());
        would produce the following output:
         array class name       = [[[I
 element class name     = java.lang.Integer
 array type name        = [[[I
 array type description = 3-dimension array of int
        参数：
        arrayClass - a primitive array class such as int[].class, boolean[][].class, etc. The getElementOpenType() method of the returned ArrayType returns the SimpleType corresponding to the wrapper type of the primitive type of the array.
        抛出：
        IllegalArgumentException - if arrayClass is not a primitive array.
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompositeData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface CompositeData

  • All Known Implementing Classes:
    CompositeDataSupport

    public interface CompositeData
    The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containsKey(String key)
      Returns true if and only if this CompositeData instance contains an item whose name is key.
      boolean containsValue(Object value)
      Returns true if and only if this CompositeData instance contains an item whose value is value.
      boolean equals(Object obj)
      Compares the specified obj parameter with this CompositeData instance for equality.
      Object get(String key)
      Returns the value of the item whose name is key.
      Object[] getAll(String[] keys)
      Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
      CompositeType getCompositeType()
      Returns the composite type of this composite data instance.
      int hashCode()
      Returns the hash code value for this CompositeData instance.
      String toString()
      Returns a string representation of this CompositeData instance.
      Collection<?> values()
      Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.

    • 方法详细信息

      • getCompositeType

        CompositeType getCompositeType()
        Returns the composite type of this composite data instance.
        返回：
        the type of this CompositeData.

      • get

        Object get(String key)
        Returns the value of the item whose name is key.
        参数：
        key - the name of the item.
        返回：
        the value associated with this key.
        抛出：
        IllegalArgumentException - if key is a null or empty String.
        InvalidKeyException - if key is not an existing item name for this CompositeData instance.

      • getAll

        Object[] getAll(String[] keys)
        Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
        参数：
        keys - the names of the items.
        返回：
        the values corresponding to the keys.
        抛出：
        IllegalArgumentException - if an element in keys is a null or empty String.
        InvalidKeyException - if an element in keys is not an existing item name for this CompositeData instance.

      • containsKey

        boolean containsKey(String key)
        Returns true if and only if this CompositeData instance contains an item whose name is key. If key is a null or empty String, this method simply returns false.
        参数：
        key - the key to be tested.
        返回：
        true if this CompositeData contains the key.

      • containsValue

        boolean containsValue(Object value)
        Returns true if and only if this CompositeData instance contains an item whose value is value.
        参数：
        value - the value to be tested.
        返回：
        true if this CompositeData contains the value.

      • values

        Collection<?> values()
        Returns an unmodifiable Collection view of the item values contained in this CompositeData instance. The returned collection's iterator will return the values in the ascending lexicographic order of the corresponding item names.
        返回：
        the values.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this CompositeData instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the CompositeData interface,
        • their composite types are equal
        • their contents, i.e. (name, value) pairs are equal. If a value contained in the content is an array, the value comparison is done as if by calling the deepEquals method for arrays of object reference types or the appropriate overloading of Arrays.equals(e1,e2) for arrays of primitive types

        This ensures that this equals method works properly for obj parameters which are different implementations of the CompositeData interface, with the restrictions mentioned in the equals method of the java.util.Collection interface.

        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this CompositeData instance.
        返回：
        true if the specified object is equal to this CompositeData instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this CompositeData instance.

        The hash code of a CompositeData instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its composite type and all the item values).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeData instances t1 and t2, as required by the general contract of the method Object.hashCode().

        Each item value's hash code is added to the returned hash code. If an item value is an array, its hash code is obtained as if by calling the deepHashCode method for arrays of object reference types or the appropriate overloading of Arrays.hashCode(e) for arrays of primitive types.

        重载：
        hashCode in class Object
        返回：
        the hash code value for this CompositeData instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this CompositeData instance.

        The string representation consists of the name of the implementing class, the string representation of the composite type of this instance, and the string representation of the contents (ie list the itemName=itemValue mappings).

        重载：
        toString in class Object
        返回：
        a string representation of this CompositeData instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cdo>>ce


CompositeDataInvocationHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 CompositeDataInvocationHandler

  • java.lang.Object
    • javax.management.openmbean.CompositeDataInvocationHandler
  • 所有已实现的接口：
    InvocationHandler

    public class CompositeDataInvocationHandler
extends Object
implements InvocationHandler

    An InvocationHandler that forwards getter methods to a CompositeData. If you have an interface that contains only getter methods (such as String getName() or boolean isActive()) then you can use this class in conjunction with the Proxy class to produce an implementation of the interface where each getter returns the value of the corresponding item in a CompositeData.

    For example, suppose you have an interface like this:

       public interface NamedNumber {
       public int getNumber();
       public String getName();
   }
    and a CompositeData constructed like this:
       CompositeData cd =
       new CompositeDataSupport(
           someCompositeType,
           new String[] {"number", "name"},
           new Object[] {5, "five"}
       );
    then you can construct an object implementing NamedNumber and backed by the object cd like this:
       InvocationHandler handler =
       new CompositeDataInvocationHandler(cd);
   NamedNumber nn = (NamedNumber)
       Proxy.newProxyInstance(NamedNumber.class.getClassLoader(),
                              new Class[] {NamedNumber.class},
                              handler);
    A call to nn.getNumber() will then return 5.

    If the first letter of the property defined by a getter is a capital, then this handler will look first for an item in the CompositeData beginning with a capital, then, if that is not found, for an item beginning with the corresponding lowercase letter or code point. For a getter called getNumber(), the handler will first look for an item called Number, then for number. If the getter is called getnumber(), then the item must be called number.

    If the method given to invoke is the method boolean equals(Object) inherited from Object, then it will return true if and only if the argument is a Proxy whose InvocationHandler is also a CompositeDataInvocationHandler and whose backing CompositeData is equal (not necessarily identical) to this object's. If the method given to invoke is the method int hashCode() inherited from Object, then it will return a value that is consistent with this definition of equals: if two objects are equal according to equals, then they will have the same hashCode.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompositeDataInvocationHandler(CompositeData compositeData)
      Construct a handler backed by the given CompositeData.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CompositeData getCompositeData()
      Return the CompositeData that was supplied to the constructor.
      Object invoke(Object proxy, 方法 method, Object[] args)
      Processes a method invocation on a proxy instance and returns the result.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CompositeDataInvocationHandler

        public CompositeDataInvocationHandler(CompositeData compositeData)

        Construct a handler backed by the given CompositeData.

        参数：
        compositeData - the CompositeData that will supply information to getters.
        抛出：
        IllegalArgumentException - if compositeData is null.

    • 方法详细信息

      • getCompositeData

        public CompositeData getCompositeData()
        Return the CompositeData that was supplied to the constructor.
        返回：
        the CompositeData that this handler is backed by. This is never null.

      • invoke

        public Object invoke(Object proxy,
            方法 method,
            Object[] args)
              throws Throwable
        从接口复制的描述： InvocationHandler
        Processes a method invocation on a proxy instance and returns the result. This method will be invoked on an invocation handler when a method is invoked on a proxy instance that it is associated with.
        指定者：
        invoke in interface InvocationHandler
        参数：
        proxy - the proxy instance that the method was invoked on
        method - the Method instance corresponding to the interface method invoked on the proxy instance. The declaring class of the Method object will be the interface that the method was declared in, which may be a superinterface of the proxy interface that the proxy class inherits the method through.
        args - an array of objects containing the values of the arguments passed in the method invocation on the proxy instance, or null if interface method takes no arguments. Arguments of primitive types are wrapped in instances of the appropriate primitive wrapper class, such as java.lang.Integer or java.lang.Boolean.
        返回：
        the value to return from the method invocation on the proxy instance. If the declared return type of the interface method is a primitive type, then the value returned by this method must be an instance of the corresponding primitive wrapper class; otherwise, it must be a type assignable to the declared return type. If the value returned by this method is null and the interface method's return type is primitive, then a NullPointerException will be thrown by the method invocation on the proxy instance. If the value returned by this method is otherwise not compatible with the interface method's declared return type as described above, a ClassCastException will be thrown by the method invocation on the proxy instance.
        抛出：
        Throwable - the exception to throw from the method invocation on the proxy instance. The exception's type must be assignable either to any of the exception types declared in the throws clause of the interface method or to the unchecked exception types java.lang.RuntimeException or java.lang.Error. If a checked exception is thrown by this method that is not assignable to any of the exception types declared in the throws clause of the interface method, then an UndeclaredThrowableException containing the exception that was thrown by this method will be thrown by the method invocation on the proxy instance.
        另请参见：
        UndeclaredThrowableException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/pd - < >/> tt=rt hoe#>f <


CompositeDataSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 CompositeDataSupport

  • java.lang.Object
    • javax.management.openmbean.CompositeDataSupport
  • 所有已实现的接口：
    Serializable, CompositeData

    public class CompositeDataSupport
extends Object
implements CompositeData, Serializable
    The CompositeDataSupport class is the open data class which implements the CompositeData interface.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
      CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containsKey(String key)
      Returns true if and only if this CompositeData instance contains an item whose name is key.
      boolean containsValue(Object value)
      Returns true if and only if this CompositeData instance contains an item whose value is value.
      boolean equals(Object obj)
      Compares the specified obj parameter with this CompositeDataSupport instance for equality.
      Object get(String key)
      Returns the value of the item whose name is key.
      Object[] getAll(String[] keys)
      Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
      CompositeType getCompositeType()
      Returns the composite type of this composite data instance.
      int hashCode()
      Returns the hash code value for this CompositeDataSupport instance.
      String toString()
      Returns a string representation of this CompositeDataSupport instance.
      Collection<?> values()
      Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompositeDataSupport

        public CompositeDataSupport(CompositeType compositeType,
                    String[] itemNames,
                    Object[] itemValues)
                     throws OpenDataException

        Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[]. As a CompositeType does not specify any order on its items, the itemNames[] parameter is used to specify the order in which the values are given in itemValues[]. The items contained in this CompositeDataSupport instance are internally stored in a TreeMap, thus sorted in ascending lexicographic order of their names, for faster retrieval of individual item values.

        The constructor checks that all the constraints listed below for each parameter are satisfied, and throws the appropriate exception if they are not.

        参数：
        compositeType - the composite type of this composite data instance; must not be null.
        itemNames - itemNames must list, in any order, all the item names defined in compositeType; the order in which the names are listed, is used to match values in itemValues[]; must not be null or empty.
        itemValues - the values of the items, listed in the same order as their respective names in itemNames; each item value can be null, but if it is non-null it must be a valid value for the open type defined in compositeType for the corresponding item; must be of the same size as itemNames; must not be null or empty.
        抛出：
        IllegalArgumentException - compositeType is null, or itemNames[] or itemValues[] is null or empty, or one of the elements in itemNames[] is a null or empty string, or itemNames[] and itemValues[] are not of the same size.
        OpenDataException - itemNames[] or itemValues[]'s size differs from the number of items defined in compositeType, or one of the elements in itemNames[] does not exist as an item name defined in compositeType, or one of the elements in itemValues[] is not a valid value for the corresponding item as defined in compositeType.

      • CompositeDataSupport

        public CompositeDataSupport(CompositeType compositeType,
                    Map<String,?> items)
                     throws OpenDataException

        Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items. This constructor converts the keys to a string array and the values to an object array and calls CompositeDataSupport(javax.management.openmbean.CompositeType, java.lang.String[], java.lang.Object[]).

        参数：
        compositeType - the composite type of this composite data instance; must not be null.
        items - the mappings of all the item names to their values; items must contain all the item names defined in compositeType; must not be null or empty.
        抛出：
        IllegalArgumentException - compositeType is null, or items is null or empty, or one of the keys in items is a null or empty string.
        OpenDataException - items' size differs from the number of items defined in compositeType, or one of the keys in items does not exist as an item name defined in compositeType, or one of the values in items is not a valid value for the corresponding item as defined in compositeType.
        ArrayStoreException - one or more keys in items is not of the class java.lang.String.

    • 方法详细信息

      • getCompositeType

        public CompositeType getCompositeType()
        Returns the composite type of this composite data instance.
        指定者：
        getCompositeType in interface CompositeData
        返回：
        the type of this CompositeData.

      • get

        public Object get(String key)
        Returns the value of the item whose name is key.
        指定者：
        get in interface CompositeData
        参数：
        key - the name of the item.
        返回：
        the value associated with this key.
        抛出：
        IllegalArgumentException - if key is a null or empty String.
        InvalidKeyException - if key is not an existing item name for this CompositeData instance.

      • getAll

        public Object[] getAll(String[] keys)
        Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
        指定者：
        getAll in interface CompositeData
        参数：
        keys - the names of the items.
        返回：
        the values corresponding to the keys.
        抛出：
        IllegalArgumentException - if an element in keys is a null or empty String.
        InvalidKeyException - if an element in keys is not an existing item name for this CompositeData instance.

      • containsKey

        public boolean containsKey(String key)
        Returns true if and only if this CompositeData instance contains an item whose name is key. If key is a null or empty String, this method simply returns false.
        指定者：
        containsKey in interface CompositeData
        参数：
        key - the key to be tested.
        返回：
        true if this CompositeData contains the key.

      • containsValue

        public boolean containsValue(Object value)
        Returns true if and only if this CompositeData instance contains an item whose value is value.
        指定者：
        containsValue in interface CompositeData
        参数：
        value - the value to be tested.
        返回：
        true if this CompositeData contains the value.

      • values

        public Collection<?> values()
        Returns an unmodifiable Collection view of the item values contained in this CompositeData instance. The returned collection's iterator will return the values in the ascending lexicographic order of the corresponding item names.
        指定者：
        values in interface CompositeData
        返回：
        the values.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this CompositeDataSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the CompositeData interface,
        • their composite types are equal
        • their contents, i.e. (name, value) pairs are equal. If a value contained in the content is an array, the value comparison is done as if by calling the deepEquals method for arrays of object reference types or the appropriate overloading of Arrays.equals(e1,e2) for arrays of primitive types

        This ensures that this equals method works properly for obj parameters which are different implementations of the CompositeData interface, with the restrictions mentioned in the equals method of the java.util.Collection interface.

        指定者：
        equals in interface CompositeData
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this CompositeDataSupport instance.
        返回：
        true if the specified object is equal to this CompositeDataSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this CompositeDataSupport instance.

        The hash code of a CompositeDataSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its composite type and all the item values).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        Each item value's hash code is added to the returned hash code. If an item value is an array, its hash code is obtained as if by calling the deepHashCode method for arrays of object reference types or the appropriate overloading of Arrays.hashCode(e) for arrays of primitive types.

        指定者：
        hashCode in interface CompositeData
        重载：
        hashCode in class Object
        返回：
        the hash code value for this CompositeDataSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this CompositeDataSupport instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.CompositeDataSupport), the string representation of the composite type of this instance, and the string representation of the contents (ie list the itemName=itemValue mappings).

        指定者：
        toString in interface CompositeData
        重载：
        toString in class Object
        返回：
        a string representation of this CompositeDataSupport instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompositeDataView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface CompositeDataView

  • public interface CompositeDataView

    A Java class can implement this interface to indicate how it is to be converted into a CompositeData by the MXBean framework.

    A typical way to use this class is to add extra items to the CompositeData in addition to the ones that are declared in the CompositeType supplied by the MXBean framework. To do this, you must create another CompositeType that has all the same items, plus your extra items.

    For example, suppose you have a class Measure that consists of a String called units and a value that is either a long or a double. It might look like this:

     public class Measure implements CompositeDataView {
     private String units;
     private Number value; // a Long or a Double

     public Measure(String units, Number value) {
         this.units = units;
         this.value = value;
     }

     public static Measure from(CompositeData cd) {
         return new Measure((String) cd.get("units"),
                            (Number) cd.get("value"));
     }

     public String getUnits() {
         return units;
     }

     // Can't be called getValue(), because Number is not a valid type
     // in an MXBean, so the implied "value" property would be rejected.
     public Number _getValue() {
         return value;
     }

     public CompositeData toCompositeData(CompositeType ct) {
         try {
             List<String> itemNames = new ArrayList<String>(ct.keySet());
             List<String> itemDescriptions = new ArrayList<String>();
             List<OpenType<?>> itemTypes = new ArrayList<OpenType<?>>();
             for (String item : itemNames) {
                 itemDescriptions.add(ct.getDescription(item));
                 itemTypes.add(ct.getType(item));
             }
             itemNames.add("value");
             itemDescriptions.add("long or double value of the measure");
             itemTypes.add((value instanceof Long) ? SimpleType.LONG :
                           SimpleType.DOUBLE);
             CompositeType xct =
                 new CompositeType(ct.getTypeName(),
                                   ct.getDescription(),
                                   itemNames.toArray(new String[0]),
                                   itemDescriptions.toArray(new String[0]),
                                   itemTypes.toArray(new OpenType<?>[0]));
             CompositeData cd =
                 new CompositeDataSupport(xct,
                                          new String[] {"units", "value"},
                                          new Object[] {units, value});
             assert ct.isValue(cd);  // check we've done it right
             return cd;
         } catch (Exception e) {
             throw new RuntimeException(e);
         }
     }
 }

    The CompositeType that will appear in the openType field of the Descriptor for an attribute or operation of this type will show only the units item, but the actual CompositeData that is generated will have both units and value.

    从以下版本开始：
    1.6
    另请参见：
    MXBean

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CompositeData toCompositeData(CompositeType ct)
      Return a CompositeData corresponding to the values in this object.

    • 方法详细信息

      • toCompositeData

        CompositeData toCompositeData(CompositeType ct)

        Return a CompositeData corresponding to the values in this object. The returned value should usually be an instance of CompositeDataSupport, or a class that serializes as a CompositeDataSupport via a writeReplace method. Otherwise, a remote client that receives the object might not be able to reconstruct it.

        参数：
        ct - The expected CompositeType of the returned value. If the returned value is cd, then cd.getCompositeType().equals(ct) should be true. Typically this will be because cd is a CompositeDataSupport constructed with ct as its CompositeType.
        返回：
        the CompositeData.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xcL"lablalssall<-))axpavgoe.yyibn


CompositeType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 CompositeType

  • java.lang.Object
    • javax.management.openmbean.OpenType<CompositeData>
      • javax.management.openmbean.CompositeType
  • 所有已实现的接口：
    Serializable

    public class CompositeType
extends OpenType<CompositeData>
    The CompositeType class is the open type class whose instances describe the types of CompositeData values.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.openmbean.OpenType

        ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
      Constructs a CompositeType instance, checking for the validity of the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containsKey(String itemName)
      Returns true if this CompositeType instance defines an item whose name is itemName.
      boolean equals(Object obj)
      Compares the specified obj parameter with this CompositeType instance for equality.
      String getDescription(String itemName)
      Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
      OpenType<?> getType(String itemName)
      Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
      int hashCode()
      Returns the hash code value for this CompositeType instance.
      boolean isValue(Object obj)
      Tests whether obj is a value which could be described by this CompositeType instance.
      Set<String> keySet()
      Returns an unmodifiable Set view of all the item names defined by this CompositeType instance.
      String toString()
      Returns a string representation of this CompositeType instance.

      • 方法 - 继承于类 javax.management.openmbean.OpenType

        getClassName, getDescription, getTypeName, isArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompositeType

        public CompositeType(String typeName,
             String description,
             String[] itemNames,
             String[] itemDescriptions,
             OpenType<?>[] itemTypes)
              throws OpenDataException
        Constructs a CompositeType instance, checking for the validity of the given parameters. The validity constraints are described below for each parameter.

        Note that the contents of the three array parameters itemNames, itemDescriptions and itemTypes are internally copied so that any subsequent modification of these arrays by the caller of this constructor has no impact on the constructed CompositeType instance.

        The Java class name of composite data values this composite type represents (ie the class name returned by the getClassName method) is set to the string value returned by CompositeData.class.getName().

        参数：
        typeName - The name given to the composite type this instance represents; cannot be a null or empty string.
        描述 - The human readable description of the composite type this instance represents; cannot be a null or empty string.
        itemNames - The names of the items contained in the composite data values described by this CompositeType instance; cannot be null and should contain at least one element; no element can be a null or empty string. Note that the order in which the item names are given is not important to differentiate a CompositeType instance from another; the item names are internally stored sorted in ascending alphanumeric order.
        itemDescriptions - The descriptions, in the same order as itemNames, of the items contained in the composite data values described by this CompositeType instance; should be of the same size as itemNames; no element can be null or an empty string.
        itemTypes - The open type instances, in the same order as itemNames, describing the items contained in the composite data values described by this CompositeType instance; should be of the same size as itemNames; no element can be null.
        抛出：
        IllegalArgumentException - If typeName or 描述 is a null or empty string, or itemNames or itemDescriptions or itemTypes is null, or any element of itemNames or itemDescriptions is a null or empty string, or any element of itemTypes is null, or itemNames or itemDescriptions or itemTypes are not of the same size.
        OpenDataException - If itemNames contains duplicate item names (case sensitive, but leading and trailing whitespaces removed).

    • 方法详细信息

      • containsKey

        public boolean containsKey(String itemName)
        Returns true if this CompositeType instance defines an item whose name is itemName.
        参数：
        itemName - the name of the item.
        返回：
        true if an item of this name is present.

      • getDescription

        public String getDescription(String itemName)
        Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
        参数：
        itemName - the name of the item.
        返回：
        the description.

      • getType

        public OpenType<?> getType(String itemName)
        Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
        参数：
        itemName - the name of the time.
        返回：
        the type.

      • keySet

        public Set<String> keySet()
        Returns an unmodifiable Set view of all the item names defined by this CompositeType instance. The set's iterator will return the item names in ascending order.
        返回：
        a Set of String.

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a value which could be described by this CompositeType instance.

        If obj is null or is not an instance of javax.management.openmbean.CompositeData, isValue returns false.

        If obj is an instance of javax.management.openmbean.CompositeData, then let ct be its CompositeType as returned by CompositeData.getCompositeType(). The result is true if this is assignable from ct. This means that:

        • this.getTypeName() equals ct.getTypeName(), and
        • there are no item names present in this that are not also present in ct, and
        • for every item in this, its type is assignable from the type of the corresponding item in ct.

        A TabularType is assignable from another TabularType if they have the same typeName and index name list, and the row type of the first is assignable from the row type of the second.

        An ArrayType is assignable from another ArrayType if they have the same dimension; and both are primitive arrays or neither is; and the element type of the first is assignable from the element type of the second.

        In every other case, an OpenType is assignable from another OpenType only if they are equal.

        These rules mean that extra items can be added to a CompositeData without making it invalid for a CompositeType that does not have those items.

        指定者：
        isValue in class OpenType<CompositeData>
        参数：
        obj - the value whose open type is to be tested for compatibility with this CompositeType instance.
        返回：
        true if obj is a value for this composite type, false otherwise.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this CompositeType instance for equality.

        Two CompositeType instances are equal if and only if all of the following statements are true:

        • their type names are equal
        • their items' names and types are equal

        指定者：
        equals in class OpenType<CompositeData>
        参数：
        obj - the object to be compared for equality with this CompositeType instance; if obj is null, equals returns false.
        返回：
        true if the specified object is equal to this CompositeType instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this CompositeType instance.

        The hash code of a CompositeType instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: name, items names, items types). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeType instances t1 and t2, as required by the general contract of the method Object.hashCode().

        As CompositeType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in class OpenType<CompositeData>
        返回：
        the hash code value for this CompositeType instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this CompositeType instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.CompositeType), the type name for this instance, and the list of the items names and types string representation of this instance.

        As CompositeType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in class OpenType<CompositeData>
        返回：
        a string representation of this CompositeType instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hi/x/D


InvalidKeyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.openmbean

类 InvalidKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • javax.management.openmbean.InvalidKeyException
  • 所有已实现的接口：
    Serializable

    public class InvalidKeyException
extends IllegalArgumentException
    This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidKeyException()
      An InvalidKeyException with no detail message.
      InvalidKeyException(String msg)
      An InvalidKeyException with a detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidKeyException

        public InvalidKeyException()
        An InvalidKeyException with no detail message.

      • InvalidKeyException

        public InvalidKeyException(String msg)
        An InvalidKeyException with a detail message.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/the" =" ann aas">>natTlmmrhr>r<>(l"o


InvalidOpenTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.openmbean

类 InvalidOpenTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • javax.management.openmbean.InvalidOpenTypeException
  • 所有已实现的接口：
    Serializable

    public class InvalidOpenTypeException
extends IllegalArgumentException
    This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidOpenTypeException()
      An InvalidOpenTypeException with no detail message.
      InvalidOpenTypeException(String msg)
      An InvalidOpenTypeException with a detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidOpenTypeException

        public InvalidOpenTypeException()
        An InvalidOpenTypeException with no detail message.

      • InvalidOpenTypeException

        public InvalidOpenTypeException(String msg)
        An InvalidOpenTypeException with a detail message.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/ rt


javax.management.openmbean

Interfaces

  • CompositeData
  • CompositeDataView
  • OpenMBeanAttributeInfo
  • OpenMBeanConstructorInfo
  • OpenMBeanInfo
  • OpenMBeanOperationInfo
  • OpenMBeanParameterInfo
  • TabularData

Classes

  • ArrayType
  • CompositeDataInvocationHandler
  • CompositeDataSupport
  • CompositeType
  • OpenMBeanAttributeInfoSupport
  • OpenMBeanConstructorInfoSupport
  • OpenMBeanInfoSupport
  • OpenMBeanOperationInfoSupport
  • OpenMBeanParameterInfoSupport
  • OpenType
  • SimpleType
  • TabularDataSupport
  • TabularType

Exceptions

  • InvalidKeyException
  • InvalidOpenTypeException
  • KeyAlreadyExistsException
  • OpenDataException
l


javax.management.openmbean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.openmbean

Provides the open data types and Open MBean descriptor classes.

请参见： 描述

  • 接口摘要
    接口 描述
    CompositeData
    The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
    CompositeDataView
    A Java class can implement this interface to indicate how it is to be converted into a CompositeData by the MXBean framework.
    OpenMBeanAttributeInfo
    Describes an attribute of an open MBean.
    OpenMBeanConstructorInfo
    Describes a constructor of an Open MBean.
    OpenMBeanInfo
    Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.
    OpenMBeanOperationInfo
    Describes an operation of an Open MBean.
    OpenMBeanParameterInfo
    Describes a parameter used in one or more operations or constructors of an open MBean.
    TabularData
    The TabularData interface specifies the behavior of a specific type of complex open data objects which represent tabular data structures.
  • Class Summary
    类 描述
    ArrayType<T>
    The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
    CompositeDataInvocationHandler
    An InvocationHandler that forwards getter methods to a CompositeData.
    CompositeDataSupport
    The CompositeDataSupport class is the open data class which implements the CompositeData interface.
    CompositeType
    The CompositeType class is the open type class whose instances describe the types of CompositeData values.
    OpenMBeanAttributeInfoSupport
    Describes an attribute of an open MBean.
    OpenMBeanConstructorInfoSupport
    Describes a constructor of an Open MBean.
    OpenMBeanInfoSupport
    The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface.
    OpenMBeanOperationInfoSupport
    Describes an operation of an Open MBean.
    OpenMBeanParameterInfoSupport
    Describes a parameter used in one or more operations or constructors of an open MBean.
    OpenType<T>
    The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.
    SimpleType<T>
    The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values.
    TabularDataSupport
    The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.
    TabularType
    The TabularType class is the open type class whose instances describe the types of TabularData values.
  • Exception Summary
    Exception 描述
    InvalidKeyException
    This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
    InvalidOpenTypeException
    This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
    KeyAlreadyExistsException
    This runtime exception is thrown to indicate that the index of a row to be added to a tabular data instance is already used to refer to another row in this tabular data instance.
    OpenDataException
    This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.

软件包 javax.management.openmbean Description

Provides the open data types and Open MBean descriptor classes. An Open MBean is an MBean where the types of attributes and of operation parameters and return values are built using a small set of predefined Java classes. Open MBeans facilitate operation with remote management programs that do not necessarily have access to application-specific types, including non-Java programs.

Every MBean has an MBeanInfo with information about the MBean itself, and its attributes, operations, constructors, and notifications. In an Open MBean, this MBeanInfo implements the OpenMBeanInfo interface, usually by being an instance of OpenMBeanInfoSupport.

The attribute information returned by MBeanInfo.getAttributes for an Open MBean is an array of objects implementing OpenMBeanAttributeInfo, usually instances of OpenMBeanAttributeInfoSupport. In addition to the usual information about attributes, an OpenMBeanAttributeInfo specifies the OpenType of the attribute. The possible OpenType values are predefined, which is what ensures that remote managers will understand them.

Similar remarks apply to the parameter types of operations and constructors, and to the return types of operations.

There is a distinction between an attribute's Java language type, as returned by getType(), and its OpenType, as returned by getOpenType(). For example, if the Java language type is java.lang.String, the OpenType will be SimpleType.String. If the Java language type is CompositeData, the OpenType will be a CompositeType that describes the items in the CompositeData instances for the attribute.

Default values and constraints

In Open MBeans, attributes and parameters can have default values and/or constraints associated with them in the OpenMBeanAttributeInfo or OpenMBeanParameterInfo. There are two ways to specify these constraints. Either the values are directly specified as parameters to one of the constructors of OpenMBeanAttributeInfoSupport or OpenMBeanParameterInfoSupport, for example OpenMBeanParameterInfoSupport.OpenMBeanParameterInfoSupport( String, String, OpenType, Object, Object[]); or the values are specified in a Descriptor given as a parameter to one of the constructors.

When a Descriptor is used, the fields of interest are these:

  • defaultValue defines the value returned by getDefaultValue();
  • minValue defines the value returned by getMinValue();
  • maxValue defines the value returned by getMaxValue();
  • legalValues defines the values returned by getLegalValues().

For defaultValue, minValue, and maxValue, the associated value must either be of the Java type corresponding to openType, or be a string that can be converted into that type. The conversion uses the static method valueOf(String) if it finds one; otherwise a constructor with a single String parameter if it finds one; otherwise it fails.

For legalValues, the associated value must be either an array or a Set, and the elements of the array or set must be convertible as described for defaultValue etc.

The following conditions must be met for these fields:

  • the values must be of the appropriate type, or be strings that can be converted to the appropriate type as explained above;
  • if legalValues is present then neither minValue nor maxValue must be present;
  • if defaultValue is present then it must satisfy the constraints defined by legalValues, minValue, or maxValue when any of these is also present;
  • if minValue and maxValue are both present then minValue must not be greater than maxValue.
从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology, in particular the JMX Specification, version 1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oa o o fi ooooscrse


javax.management.openmbean Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.openmbean

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.management.openmbean.CompositeDataInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo)
    • javax.management.openmbean.OpenType<T> (implements java.io.Serializable)
      • javax.management.openmbean.ArrayType<T>
      • javax.management.openmbean.CompositeType
      • javax.management.openmbean.SimpleType<T>
      • javax.management.openmbean.TabularType
    • javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable, javax.management.openmbean.TabularData)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.openmbean.OpenDataException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • javax.management.openmbean.InvalidKeyException
            • javax.management.openmbean.InvalidOpenTypeException
            • javax.management.openmbean.KeyAlreadyExistsException

Interface Hierarchy

  • javax.management.openmbean.CompositeData
  • javax.management.openmbean.CompositeDataView
  • javax.management.openmbean.OpenMBeanConstructorInfo
  • javax.management.openmbean.OpenMBeanInfo
  • javax.management.openmbean.OpenMBeanOperationInfo
  • javax.management.openmbean.OpenMBeanParameterInfo
    • javax.management.openmbean.OpenMBeanAttributeInfo
  • javax.management.openmbean.TabularData
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t///.v/..... ss"m" c/


KeyAlreadyExistsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.openmbean

类 KeyAlreadyExistsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • javax.management.openmbean.KeyAlreadyExistsException
  • 所有已实现的接口：
    Serializable

    public class KeyAlreadyExistsException
extends IllegalArgumentException
    This runtime exception is thrown to indicate that the index of a row to be added to a tabular data instance is already used to refer to another row in this tabular data instance.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      KeyAlreadyExistsException()
      A KeyAlreadyExistsException with no detail message.
      KeyAlreadyExistsException(String msg)
      A KeyAlreadyExistsException with a detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeyAlreadyExistsException

        public KeyAlreadyExistsException()
        A KeyAlreadyExistsException with no detail message.

      • KeyAlreadyExistsException

        public KeyAlreadyExistsException(String msg)
        A KeyAlreadyExistsException with a detail message.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts/ny -裪b}bvbb xei>髅"絢醨.<


OpenDataException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.openmbean

类 OpenDataException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.openmbean.OpenDataException
  • 所有已实现的接口：
    Serializable

    public class OpenDataException
extends JMException
    This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenDataException()
      An OpenDataException with no detail message.
      OpenDataException(String msg)
      An OpenDataException with a detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OpenDataException

        public OpenDataException()
        An OpenDataException with no detail message.

      • OpenDataException

        public OpenDataException(String msg)
        An OpenDataException with a detail message.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsiuEu uaucetatn>a哪.:roclljaj7amv. /�


OpenMBeanAttributeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface OpenMBeanAttributeInfo

  • All Superinterfaces:
    OpenMBeanParameterInfo
    All Known Implementing Classes:
    OpenMBeanAttributeInfoSupport

    public interface OpenMBeanAttributeInfo
extends OpenMBeanParameterInfo

    Describes an attribute of an open MBean.

    This interface declares the same methods as the class MBeanAttributeInfo. A class implementing this interface (typically OpenMBeanAttributeInfoSupport) should extend MBeanAttributeInfo.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.
      int hashCode()
      Returns the hash code value for this OpenMBeanAttributeInfo instance.
      boolean isIs()
      Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
      boolean isReadable()
      Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
      boolean isWritable()
      Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
      String toString()
      Returns a string representation of this OpenMBeanAttributeInfo instance.

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanParameterInfo

        getDefaultValue, getDescription, getLegalValues, getMaxValue, getMinValue, getName, getOpenType, hasDefaultValue, hasLegalValues, hasMaxValue, hasMinValue, isValue

    • 方法详细信息

      • isReadable

        boolean isReadable()
        Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
        返回：
        true if the attribute is readable.

      • isWritable

        boolean isWritable()
        Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
        返回：
        true if the attribute is writable.

      • isIs

        boolean isIs()
        Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
        返回：
        true if the attribute is accessed through isXXX.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanAttributeInfo interface,
        • their names are equal
        • their open types are equal
        • their access properties (isReadable, isWritable and isIs) are equal
        • their default, min, max and legal values are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanAttributeInfo interface.
        指定者：
        equals in interface OpenMBeanParameterInfo
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this OpenMBeanAttributeInfo instance;
        返回：
        true if the specified object is equal to this OpenMBeanAttributeInfo instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this OpenMBeanAttributeInfo instance.

        The hash code of an OpenMBeanAttributeInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanAttributeInfo instances t1 and t2, as required by the general contract of the method Object.hashCode().

        指定者：
        hashCode in interface OpenMBeanParameterInfo
        重载：
        hashCode in class Object
        返回：
        the hash code value for this OpenMBeanAttributeInfo instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this OpenMBeanAttributeInfo instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanAttributeInfo), the string representation of the name and open type of the described attribute, and the string representation of its default, min, max and legal values.

        指定者：
        toString in interface OpenMBeanParameterInfo
        重载：
        toString in class Object
        返回：
        a string representation of this OpenMBeanAttributeInfo instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dLCsesw a>occ>Tio{


OpenMBeanAttributeInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenMBeanAttributeInfoSupport

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanAttributeInfo
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, OpenMBeanAttributeInfo, OpenMBeanParameterInfo

    public class OpenMBeanAttributeInfoSupport
extends MBeanAttributeInfo
implements OpenMBeanAttributeInfo
    Describes an attribute of an open MBean.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and 描述, and the specified read/write access properties.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, read/write access properties, and Descriptor.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述 and defaultValue, and the specified read/write access properties.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, defaultValue and legalValues, and the specified read/write access properties.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.
      Object getDefaultValue()
      Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
      Set<?> getLegalValues()
      Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
      Comparable<?> getMaxValue()
      Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
      Comparable<?> getMinValue()
      Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
      OpenType<?> getOpenType()
      Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.
      boolean hasDefaultValue()
      Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
      int hashCode()
      Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.
      boolean hasLegalValues()
      Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
      boolean hasMaxValue()
      Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
      boolean hasMinValue()
      Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
      boolean isValue(Object obj)
      Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
      String toString()
      Returns a string representation of this OpenMBeanAttributeInfoSupport instance.

      • 方法 - 继承于类 javax.management.MBeanAttributeInfo

        clone, getType, isIs, isReadable, isWritable

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getDescriptor, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanAttributeInfo

        isIs, isReadable, isWritable

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanParameterInfo

        getDescription, getName

    • 构造方法详细信息

      • OpenMBeanAttributeInfoSupport

        public OpenMBeanAttributeInfoSupport(String name,
                             String description,
                             OpenType<?> openType,
                             boolean isReadable,
                             boolean isWritable,
                             boolean isIs)
        Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and 描述, and the specified read/write access properties.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        isReadable - true if the attribute has a getter exposed for management.
        isWritable - true if the attribute has a setter exposed for management.
        isIs - true if the attribute's getter is of the form isXXX.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.

      • OpenMBeanAttributeInfoSupport

        public OpenMBeanAttributeInfoSupport(String name,
                             String description,
                             OpenType<?> openType,
                             boolean isReadable,
                             boolean isWritable,
                             boolean isIs,
                             Descriptor descriptor)

        Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, read/write access properties, and Descriptor.

        The descriptor can contain entries that will define the values returned by certain methods of this class, as explained in the package description.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        isReadable - true if the attribute has a getter exposed for management.
        isWritable - true if the attribute has a setter exposed for management.
        isIs - true if the attribute's getter is of the form isXXX.
        descriptor - The descriptor for the attribute. This may be null which is equivalent to an empty descriptor.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null, or the descriptor entries are invalid as described in the package description.
        从以下版本开始：
        1.6

      • OpenMBeanAttributeInfoSupport

        public OpenMBeanAttributeInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             boolean isReadable,
                             boolean isWritable,
                             boolean isIs,
                             T defaultValue)
                              throws OpenDataException
        Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述 and defaultValue, and the specified read/write access properties.
        类型参数：
        T - allows the compiler to check that the defaultValue, if non-null, has the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        isReadable - true if the attribute has a getter exposed for management.
        isWritable - true if the attribute has a setter exposed for management.
        isIs - true if the attribute's getter is of the form isXXX.
        defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType.

      • OpenMBeanAttributeInfoSupport

        public OpenMBeanAttributeInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             boolean isReadable,
                             boolean isWritable,
                             boolean isIs,
                             T defaultValue,
                             T[] legalValues)
                              throws OpenDataException

        Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, defaultValue and legalValues, and the specified read/write access properties.

        The contents of legalValues are copied, so subsequent modifications of the array referenced by legalValues have no impact on this OpenMBeanAttributeInfoSupport instance.

        类型参数：
        T - allows the compiler to check that the defaultValue and legalValues, if non-null, have the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        isReadable - true if the attribute has a getter exposed for management.
        isWritable - true if the attribute has a setter exposed for management.
        isIs - true if the attribute's getter is of the form isXXX.
        defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        legalValues - each contained value must be valid for the openType specified for this attribute; legal values not supported for ArrayType and TabularType; can be null or empty.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue is not a valid value for the specified openType, or one value in legalValues is not valid for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and defaultValue is not contained in legalValues.

      • OpenMBeanAttributeInfoSupport

        public OpenMBeanAttributeInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             boolean isReadable,
                             boolean isWritable,
                             boolean isIs,
                             T defaultValue,
                             Comparable<T> minValue,
                             Comparable<T> maxValue)
                              throws OpenDataException
        Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean, with the specified name, openType, 描述, defaultValue, minValue and maxValue. It is possible to specify minimal and maximal values only for an open type whose values are Comparable.
        类型参数：
        T - allows the compiler to check that the defaultValue, minValue, and maxValue, if non-null, have the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        isReadable - true if the attribute has a getter exposed for management.
        isWritable - true if the attribute has a setter exposed for management.
        isIs - true if the attribute's getter is of the form isXXX.
        defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        minValue - must be valid for the openType specified for this attribute; can be null, in which case it means that no minimal value is set.
        maxValue - must be valid for the openType specified for this attribute; can be null, in which case it means that no maximal value is set.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue, minValue or maxValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or both minValue and maxValue are non-null and minValue.compareTo(maxValue) > 0 is true, or both defaultValue and minValue are non-null and minValue.compareTo(defaultValue) > 0 is true, or both defaultValue and maxValue are non-null and defaultValue.compareTo(maxValue) > 0 is true.

    • 方法详细信息

      • getOpenType

        public OpenType<?> getOpenType()
        Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.
        指定者：
        getOpenType in interface OpenMBeanParameterInfo
        返回：
        the open type.

      • getDefaultValue

        public Object getDefaultValue()
        Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
        指定者：
        getDefaultValue in interface OpenMBeanParameterInfo
        返回：
        the default value.

      • getLegalValues

        public Set<?> getLegalValues()
        Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
        指定者：
        getLegalValues in interface OpenMBeanParameterInfo
        返回：
        the set of legal values.

      • getMinValue

        public Comparable<?> getMinValue()
        Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
        指定者：
        getMinValue in interface OpenMBeanParameterInfo
        返回：
        the minimum value.

      • getMaxValue

        public Comparable<?> getMaxValue()
        Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
        指定者：
        getMaxValue in interface OpenMBeanParameterInfo
        返回：
        the maximum value.

      • hasDefaultValue

        public boolean hasDefaultValue()
        Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
        指定者：
        hasDefaultValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a default value.

      • hasLegalValues

        public boolean hasLegalValues()
        Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
        指定者：
        hasLegalValues in interface OpenMBeanParameterInfo
        返回：
        true if there is a set of legal values.

      • hasMinValue

        public boolean hasMinValue()
        Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
        指定者：
        hasMinValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a minimum value.

      • hasMaxValue

        public boolean hasMaxValue()
        Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
        指定者：
        hasMaxValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a maximum value.

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
        指定者：
        isValue in interface OpenMBeanParameterInfo
        参数：
        obj - the object to be tested.
        返回：
        true if obj is a valid value for the parameter described by this OpenMBeanAttributeInfoSupport instance, false otherwise.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanAttributeInfo interface,
        • their names are equal
        • their open types are equal
        • their access properties (isReadable, isWritable and isIs) are equal
        • their default, min, max and legal values are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanAttributeInfo interface.

        If obj also implements DescriptorRead, then its getDescriptor() method must also return the same value as for this object.

        指定者：
        equals in interface OpenMBeanAttributeInfo
        指定者：
        equals in interface OpenMBeanParameterInfo
        重载：
        equals in class MBeanAttributeInfo
        参数：
        obj - the object to be compared for equality with this OpenMBeanAttributeInfoSupport instance.
        返回：
        true if the specified object is equal to this OpenMBeanAttributeInfoSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.

        The hash code of an OpenMBeanAttributeInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, its default, min, max and legal values, and its Descriptor).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanAttributeInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the OpenMBeanAttributeInfo interface may be equal to this OpenMBeanAttributeInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        As OpenMBeanAttributeInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in interface OpenMBeanAttributeInfo
        指定者：
        hashCode in interface OpenMBeanParameterInfo
        重载：
        hashCode in class MBeanAttributeInfo
        返回：
        the hash code value for this OpenMBeanAttributeInfoSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this OpenMBeanAttributeInfoSupport instance.

        The string representation consists of the name of this class (i.e. javax.management.openmbean.OpenMBeanAttributeInfoSupport), the string representation of the name and open type of the described parameter, the string representation of its default, min, max and legal values and the string representation of its descriptor.

        As OpenMBeanAttributeInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in interface OpenMBeanAttributeInfo
        指定者：
        toString in interface OpenMBeanParameterInfo
        重载：
        toString in class MBeanAttributeInfo
        返回：
        a string representation of this OpenMBeanAttributeInfoSupport instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OpenMBeanConstructorInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface OpenMBeanConstructorInfo

  • All Known Implementing Classes:
    OpenMBeanConstructorInfoSupport

    public interface OpenMBeanConstructorInfo

    Describes a constructor of an Open MBean.

    This interface declares the same methods as the class MBeanConstructorInfo. A class implementing this interface (typically OpenMBeanConstructorInfoSupport) should extend MBeanConstructorInfo.

    The getSignature() method should return at runtime an array of instances of a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.
      String getDescription()
      Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.
      String getName()
      Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.
      MBeanParameterInfo[] getSignature()
      Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.
      int hashCode()
      Returns the hash code value for this OpenMBeanConstructorInfo instance.
      String toString()
      Returns a string representation of this OpenMBeanConstructorInfo instance.

    • 方法详细信息

      • getDescription

        String getDescription()
        Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.
        返回：
        the description.

      • getName

        String getName()
        Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.
        返回：
        the name.

      • getSignature

        MBeanParameterInfo[] getSignature()
        Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.
        返回：
        the signature.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanConstructorInfo interface,
        • their names are equal
        • their signatures are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanConstructorInfo interface.
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this OpenMBeanConstructorInfo instance;
        返回：
        true if the specified object is equal to this OpenMBeanConstructorInfo instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this OpenMBeanConstructorInfo instance.

        The hash code of an OpenMBeanConstructorInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanConstructorInfo instances t1 and t2, as required by the general contract of the method Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        the hash code value for this OpenMBeanConstructorInfo instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this OpenMBeanConstructorInfo instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanConstructorInfo), and the name and signature of the described constructor.

        重载：
        toString in class Object
        返回：
        a string representation of this OpenMBeanConstructorInfo instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

soDroueSuetIIetttnppd/a>e


OpenMBeanConstructorInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenMBeanConstructorInfoSupport

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanConstructorInfo
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, OpenMBeanConstructorInfo

    public class OpenMBeanConstructorInfoSupport
extends MBeanConstructorInfo
implements OpenMBeanConstructorInfo
    Describes a constructor of an Open MBean.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
      Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述 and signature.
      OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述, signature, and descriptor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.
      int hashCode()
      Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.
      String toString()
      Returns a string representation of this OpenMBeanConstructorInfoSupport instance.

      • 方法 - 继承于类 javax.management.MBeanConstructorInfo

        clone, getSignature

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getDescriptor, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanConstructorInfo

        getDescription, getName, getSignature

    • 构造方法详细信息

      • OpenMBeanConstructorInfoSupport

        public OpenMBeanConstructorInfoSupport(String name,
                               String description,
                               OpenMBeanParameterInfo[] signature)

        Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述 and signature.

        The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        signature - can be null or empty if there are no parameters to describe.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string.
        ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.

      • OpenMBeanConstructorInfoSupport

        public OpenMBeanConstructorInfoSupport(String name,
                               String description,
                               OpenMBeanParameterInfo[] signature,
                               Descriptor descriptor)

        Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述, signature, and descriptor.

        The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        signature - can be null or empty if there are no parameters to describe.
        descriptor - The descriptor for the constructor. This may be null which is equivalent to an empty descriptor.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string.
        ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.
        从以下版本开始：
        1.6

    • 方法详细信息

      • equals

        public boolean equals(Object obj)

        Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanConstructorInfo interface,
        • their names are equal
        • their signatures are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanConstructorInfo interface.
        指定者：
        equals in interface OpenMBeanConstructorInfo
        重载：
        equals in class MBeanConstructorInfo
        参数：
        obj - the object to be compared for equality with this OpenMBeanConstructorInfoSupport instance;
        返回：
        true if the specified object is equal to this OpenMBeanConstructorInfoSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.

        The hash code of an OpenMBeanConstructorInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanConstructorInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the OpenMBeanConstructorInfo interface may be equal to this OpenMBeanConstructorInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        As OpenMBeanConstructorInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in interface OpenMBeanConstructorInfo
        重载：
        hashCode in class MBeanConstructorInfo
        返回：
        the hash code value for this OpenMBeanConstructorInfoSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()

        Returns a string representation of this OpenMBeanConstructorInfoSupport instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanConstructorInfoSupport), the name and signature of the described constructor and the string representation of its descriptor.

        As OpenMBeanConstructorInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in interface OpenMBeanConstructorInfo
        重载：
        toString in class MBeanConstructorInfo
        返回：
        a string representation of this OpenMBeanConstructorInfoSupport instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Iit/f


OpenMBeanInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface OpenMBeanInfo

  • All Known Implementing Classes:
    OpenMBeanInfoSupport

    public interface OpenMBeanInfo

    Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.

    This interface declares the same methods as the class MBeanInfo. A class implementing this interface (typically OpenMBeanInfoSupport) should extend MBeanInfo.

    The getAttributes(), getOperations() and getConstructors() methods of the implementing class should return at runtime an array of instances of a subclass of MBeanAttributeInfo, MBeanOperationInfo or MBeanConstructorInfo respectively which implement the OpenMBeanAttributeInfo, OpenMBeanOperationInfo or OpenMBeanConstructorInfo interface respectively.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanInfo instance for equality.
      MBeanAttributeInfo[] getAttributes()
      Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance.
      String getClassName()
      Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.
      MBeanConstructorInfo[] getConstructors()
      Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance.
      String getDescription()
      Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.
      MBeanNotificationInfo[] getNotifications()
      Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.
      MBeanOperationInfo[] getOperations()
      Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance.
      int hashCode()
      Returns the hash code value for this OpenMBeanInfo instance.
      String toString()
      Returns a string representation of this OpenMBeanInfo instance.

    • 方法详细信息

      • getClassName

        String getClassName()
        Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.
        返回：
        the class name.

      • getDescription

        String getDescription()
        Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.
        返回：
        the description.

      • getAttributes

        MBeanAttributeInfo[] getAttributes()
        Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanAttributeInfo which implements the OpenMBeanAttributeInfo interface (typically OpenMBeanAttributeInfoSupport).
        返回：
        the attribute array.

      • getOperations

        MBeanOperationInfo[] getOperations()
        Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanOperationInfo which implements the OpenMBeanOperationInfo interface (typically OpenMBeanOperationInfoSupport).
        返回：
        the operation array.

      • getConstructors

        MBeanConstructorInfo[] getConstructors()
        Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanConstructorInfo which implements the OpenMBeanConstructorInfo interface (typically OpenMBeanConstructorInfoSupport).
        返回：
        the constructor array.

      • getNotifications

        MBeanNotificationInfo[] getNotifications()
        Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.
        返回：
        the notification array.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanInfo instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanInfo interface,
        • their class names are equal
        • their infos on attributes, constructors, operations and notifications are equal
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanInfo interface.
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this OpenMBeanInfo instance;
        返回：
        true if the specified object is equal to this OpenMBeanInfo instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this OpenMBeanInfo instance.

        The hash code of an OpenMBeanInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its class name, and its infos on attributes, constructors, operations and notifications, where the hashCode of each of these arrays is calculated by a call to new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanInfo instances t1 and t2, as required by the general contract of the method Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        the hash code value for this OpenMBeanInfo instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this OpenMBeanInfo instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanInfo), the MBean class name, and the string representation of infos on attributes, constructors, operations and notifications of the described MBean.

        重载：
        toString in class Object
        返回：
        a string representation of this OpenMBeanInfo instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsag tnstnrssnrr>lddt//nartgnnnisg>>


OpenMBeanInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenMBeanInfoSupport

  • java.lang.Object
    • javax.management.MBeanInfo
      • javax.management.openmbean.OpenMBeanInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, OpenMBeanInfo

    public class OpenMBeanInfoSupport
extends MBeanInfo
implements OpenMBeanInfo
    The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface. Note that an open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations and notifications.
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.
      int hashCode()
      Returns the hash code value for this OpenMBeanInfoSupport instance.
      String toString()
      Returns a string representation of this OpenMBeanInfoSupport instance.

      • 方法 - 继承于类 javax.management.MBeanInfo

        clone, getAttributes, getClassName, getConstructors, getDescription, getDescriptor, getNotifications, getOperations

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanInfo

        getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

    • 构造方法详细信息

      • OpenMBeanInfoSupport

        public OpenMBeanInfoSupport(String className,
                    String description,
                    OpenMBeanAttributeInfo[] openAttributes,
                    OpenMBeanConstructorInfo[] openConstructors,
                    OpenMBeanOperationInfo[] openOperations,
                    MBeanNotificationInfo[] notifications)

        Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations and notifications.

        The openAttributes, openConstructors, openOperations and notifications array parameters are internally copied, so that subsequent changes to the arrays referenced by these parameters have no effect on this instance.

        参数：
        className - The fully qualified Java class name of the open MBean described by this OpenMBeanInfoSupport instance.
        描述 - A human readable description of the open MBean described by this OpenMBeanInfoSupport instance.
        openAttributes - The list of exposed attributes of the described open MBean; Must be an array of instances of a subclass of MBeanAttributeInfo, typically OpenMBeanAttributeInfoSupport.
        openConstructors - The list of exposed public constructors of the described open MBean; Must be an array of instances of a subclass of MBeanConstructorInfo, typically OpenMBeanConstructorInfoSupport.
        openOperations - The list of exposed operations of the described open MBean. Must be an array of instances of a subclass of MBeanOperationInfo, typically OpenMBeanOperationInfoSupport.
        notifications - The list of notifications emitted by the described open MBean.
        抛出：
        ArrayStoreException - If openAttributes, openConstructors or openOperations is not an array of instances of a subclass of MBeanAttributeInfo, MBeanConstructorInfo or MBeanOperationInfo respectively.

      • OpenMBeanInfoSupport

        public OpenMBeanInfoSupport(String className,
                    String description,
                    OpenMBeanAttributeInfo[] openAttributes,
                    OpenMBeanConstructorInfo[] openConstructors,
                    OpenMBeanOperationInfo[] openOperations,
                    MBeanNotificationInfo[] notifications,
                    Descriptor descriptor)

        Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.

        The openAttributes, openConstructors, openOperations and notifications array parameters are internally copied, so that subsequent changes to the arrays referenced by these parameters have no effect on this instance.

        参数：
        className - The fully qualified Java class name of the open MBean described by this OpenMBeanInfoSupport instance.
        描述 - A human readable description of the open MBean described by this OpenMBeanInfoSupport instance.
        openAttributes - The list of exposed attributes of the described open MBean; Must be an array of instances of a subclass of MBeanAttributeInfo, typically OpenMBeanAttributeInfoSupport.
        openConstructors - The list of exposed public constructors of the described open MBean; Must be an array of instances of a subclass of MBeanConstructorInfo, typically OpenMBeanConstructorInfoSupport.
        openOperations - The list of exposed operations of the described open MBean. Must be an array of instances of a subclass of MBeanOperationInfo, typically OpenMBeanOperationInfoSupport.
        notifications - The list of notifications emitted by the described open MBean.
        descriptor - The descriptor for the MBean. This may be null which is equivalent to an empty descriptor.
        抛出：
        ArrayStoreException - If openAttributes, openConstructors or openOperations is not an array of instances of a subclass of MBeanAttributeInfo, MBeanConstructorInfo or MBeanOperationInfo respectively.
        从以下版本开始：
        1.6

    • 方法详细信息

      • equals

        public boolean equals(Object obj)

        Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanInfo interface,
        • their class names are equal
        • their infos on attributes, constructors, operations and notifications are equal
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanInfo interface.
        指定者：
        equals in interface OpenMBeanInfo
        重载：
        equals in class MBeanInfo
        参数：
        obj - the object to be compared for equality with this OpenMBeanInfoSupport instance;
        返回：
        true if the specified object is equal to this OpenMBeanInfoSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this OpenMBeanInfoSupport instance.

        The hash code of an OpenMBeanInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its class name, and its infos on attributes, constructors, operations and notifications, where the hashCode of each of these arrays is calculated by a call to new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the OpenMBeanInfo interface may be equal to this OpenMBeanInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        As OpenMBeanInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in interface OpenMBeanInfo
        重载：
        hashCode in class MBeanInfo
        返回：
        the hash code value for this OpenMBeanInfoSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()

        Returns a string representation of this OpenMBeanInfoSupport instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanInfoSupport), the MBean class name, the string representation of infos on attributes, constructors, operations and notifications of the described MBean and the string representation of the descriptor.

        As OpenMBeanInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in interface OpenMBeanInfo
        重载：
        toString in class MBeanInfo
        返回：
        a string representation of this OpenMBeanInfoSupport instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aEmd


OpenMBeanOperationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface OpenMBeanOperationInfo

  • All Known Implementing Classes:
    OpenMBeanOperationInfoSupport

    public interface OpenMBeanOperationInfo

    Describes an operation of an Open MBean.

    This interface declares the same methods as the class MBeanOperationInfo. A class implementing this interface (typically OpenMBeanOperationInfoSupport) should extend MBeanOperationInfo.

    The getSignature() method should return at runtime an array of instances of a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.
      String getDescription()
      Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.
      int getImpact()
      Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance.
      String getName()
      Returns the name of the operation described by this OpenMBeanOperationInfo instance.
      OpenType<?> getReturnOpenType()
      Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
      String getReturnType()
      Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance.
      MBeanParameterInfo[] getSignature()
      Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance.
      int hashCode()
      Returns the hash code value for this OpenMBeanOperationInfo instance.
      String toString()
      Returns a string representation of this OpenMBeanOperationInfo instance.

    • 方法详细信息

      • getDescription

        String getDescription()
        Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.
        返回：
        the description.

      • getName

        String getName()
        Returns the name of the operation described by this OpenMBeanOperationInfo instance.
        返回：
        the name.

      • getSignature

        MBeanParameterInfo[] getSignature()
        Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance. Each instance in the returned array should actually be a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).
        返回：
        the signature.

      • getImpact

        int getImpact()
        Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance. The returned constant is one of MBeanOperationInfo.INFO, MBeanOperationInfo.ACTION, MBeanOperationInfo.ACTION_INFO, or MBeanOperationInfo.UNKNOWN.
        返回：
        the impact code.

      • getReturnType

        String getReturnType()
        Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance. This method should return the same value as a call to getReturnOpenType().getClassName().
        返回：
        the return type.

      • getReturnOpenType

        OpenType<?> getReturnOpenType()
        Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
        返回：
        the return type.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanOperationInfo interface,
        • their names are equal
        • their signatures are equal
        • their return open types are equal
        • their impacts are equal
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanOperationInfo interface.
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this OpenMBeanOperationInfo instance;
        返回：
        true if the specified object is equal to this OpenMBeanOperationInfo instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this OpenMBeanOperationInfo instance.

        The hash code of an OpenMBeanOperationInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, return open type, impact and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanOperationInfo instances t1 and t2, as required by the general contract of the method Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        the hash code value for this OpenMBeanOperationInfo instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this OpenMBeanOperationInfo instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanOperationInfo), and the name, signature, return open type and impact of the described operation.

        重载：
        toString in class Object
        返回：
        a string representation of this OpenMBeanOperationInfo instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

T>h= lscls


OpenMBeanOperationInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenMBeanOperationInfoSupport

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanOperationInfo
        • javax.management.openmbean.OpenMBeanOperationInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, OpenMBeanOperationInfo

    public class OpenMBeanOperationInfoSupport
extends MBeanOperationInfo
implements OpenMBeanOperationInfo
    Describes an operation of an Open MBean.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanOperationInfo

        ACTION, ACTION_INFO, INFO, UNKNOWN

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType and impact.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType, impact, and descriptor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.
      OpenType<?> getReturnOpenType()
      Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
      int hashCode()
      Returns the hash code value for this OpenMBeanOperationInfoSupport instance.
      String toString()
      Returns a string representation of this OpenMBeanOperationInfoSupport instance.

      • 方法 - 继承于类 javax.management.MBeanOperationInfo

        clone, getImpact, getReturnType, getSignature

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getDescriptor, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanOperationInfo

        getDescription, getImpact, getName, getReturnType, getSignature

    • 构造方法详细信息

      • OpenMBeanOperationInfoSupport

        public OpenMBeanOperationInfoSupport(String name,
                             String description,
                             OpenMBeanParameterInfo[] signature,
                             OpenType<?> returnOpenType,
                             int impact)

        Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType and impact.

        The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        signature - can be null or empty if there are no parameters to describe.
        returnOpenType - cannot be null: use SimpleType.VOID for operations that return nothing.
        impact - must be one of ACTION, ACTION_INFO, INFO, or UNKNOWN.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or returnOpenType is null, or impact is not one of ACTION, ACTION_INFO, INFO, or UNKNOWN.
        ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.

      • OpenMBeanOperationInfoSupport

        public OpenMBeanOperationInfoSupport(String name,
                             String description,
                             OpenMBeanParameterInfo[] signature,
                             OpenType<?> returnOpenType,
                             int impact,
                             Descriptor descriptor)

        Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType, impact, and descriptor.

        The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        signature - can be null or empty if there are no parameters to describe.
        returnOpenType - cannot be null: use SimpleType.VOID for operations that return nothing.
        impact - must be one of ACTION, ACTION_INFO, INFO, or UNKNOWN.
        descriptor - The descriptor for the operation. This may be null, which is equivalent to an empty descriptor.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or returnOpenType is null, or impact is not one of ACTION, ACTION_INFO, INFO, or UNKNOWN.
        ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.
        从以下版本开始：
        1.6

    • 方法详细信息

      • getReturnOpenType

        public OpenType<?> getReturnOpenType()
        Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
        指定者：
        getReturnOpenType in interface OpenMBeanOperationInfo
        返回：
        the return type.

      • equals

        public boolean equals(Object obj)

        Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanOperationInfo interface,
        • their names are equal
        • their signatures are equal
        • their return open types are equal
        • their impacts are equal
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanOperationInfo interface.
        指定者：
        equals in interface OpenMBeanOperationInfo
        重载：
        equals in class MBeanOperationInfo
        参数：
        obj - the object to be compared for equality with this OpenMBeanOperationInfoSupport instance;
        返回：
        true if the specified object is equal to this OpenMBeanOperationInfoSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this OpenMBeanOperationInfoSupport instance.

        The hash code of an OpenMBeanOperationInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, return open type, impact and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanOperationInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the OpenMBeanOperationInfo interface may be equal to this OpenMBeanOperationInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        As OpenMBeanOperationInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in interface OpenMBeanOperationInfo
        重载：
        hashCode in class MBeanOperationInfo
        返回：
        the hash code value for this OpenMBeanOperationInfoSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()

        Returns a string representation of this OpenMBeanOperationInfoSupport instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanOperationInfoSupport), and the name, signature, return open type and impact of the described operation and the string representation of its descriptor.

        As OpenMBeanOperationInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in interface OpenMBeanOperationInfo
        重载：
        toString in class MBeanOperationInfo
        返回：
        a string representation of this OpenMBeanOperationInfoSupport instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OpenMBeanParameterInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface OpenMBeanParameterInfo

  • All Known Subinterfaces:
    OpenMBeanAttributeInfo
    All Known Implementing Classes:
    OpenMBeanAttributeInfoSupport, OpenMBeanParameterInfoSupport

    public interface OpenMBeanParameterInfo

    Describes a parameter used in one or more operations or constructors of an open MBean.

    This interface declares the same methods as the class MBeanParameterInfo. A class implementing this interface (typically OpenMBeanParameterInfoSupport) should extend MBeanParameterInfo.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.
      Object getDefaultValue()
      Returns the default value for this parameter, if it has one, or null otherwise.
      String getDescription()
      Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.
      Set<?> getLegalValues()
      Returns the set of legal values for this parameter, if it has one, or null otherwise.
      Comparable<?> getMaxValue()
      Returns the maximal value for this parameter, if it has one, or null otherwise.
      Comparable<?> getMinValue()
      Returns the minimal value for this parameter, if it has one, or null otherwise.
      String getName()
      Returns the name of the parameter described by this OpenMBeanParameterInfo instance.
      OpenType<?> getOpenType()
      Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.
      boolean hasDefaultValue()
      Returns true if this parameter has a specified default value, or false otherwise.
      int hashCode()
      Returns the hash code value for this OpenMBeanParameterInfo instance.
      boolean hasLegalValues()
      Returns true if this parameter has a specified set of legal values, or false otherwise.
      boolean hasMaxValue()
      Returns true if this parameter has a specified maximal value, or false otherwise.
      boolean hasMinValue()
      Returns true if this parameter has a specified minimal value, or false otherwise.
      boolean isValue(Object obj)
      Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
      String toString()
      Returns a string representation of this OpenMBeanParameterInfo instance.

    • 方法详细信息

      • getDescription

        String getDescription()
        Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.
        返回：
        the description.

      • getName

        String getName()
        Returns the name of the parameter described by this OpenMBeanParameterInfo instance.
        返回：
        the name.

      • getOpenType

        OpenType<?> getOpenType()
        Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.
        返回：
        the open type.

      • getDefaultValue

        Object getDefaultValue()
        Returns the default value for this parameter, if it has one, or null otherwise.
        返回：
        the default value.

      • getLegalValues

        Set<?> getLegalValues()
        Returns the set of legal values for this parameter, if it has one, or null otherwise.
        返回：
        the set of legal values.

      • getMinValue

        Comparable<?> getMinValue()
        Returns the minimal value for this parameter, if it has one, or null otherwise.
        返回：
        the minimum value.

      • getMaxValue

        Comparable<?> getMaxValue()
        Returns the maximal value for this parameter, if it has one, or null otherwise.
        返回：
        the maximum value.

      • hasDefaultValue

        boolean hasDefaultValue()
        Returns true if this parameter has a specified default value, or false otherwise.
        返回：
        true if there is a default value.

      • hasLegalValues

        boolean hasLegalValues()
        Returns true if this parameter has a specified set of legal values, or false otherwise.
        返回：
        true if there is a set of legal values.

      • hasMinValue

        boolean hasMinValue()
        Returns true if this parameter has a specified minimal value, or false otherwise.
        返回：
        true if there is a minimum value.

      • hasMaxValue

        boolean hasMaxValue()
        Returns true if this parameter has a specified maximal value, or false otherwise.
        返回：
        true if there is a maximum value.

      • isValue

        boolean isValue(Object obj)
        Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
        参数：
        obj - the object to be tested.
        返回：
        true if obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance, false otherwise.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanParameterInfo interface,
        • their names are equal
        • their open types are equal
        • their default, min, max and legal values are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanParameterInfo interface.
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this OpenMBeanParameterInfo instance;
        返回：
        true if the specified object is equal to this OpenMBeanParameterInfo instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this OpenMBeanParameterInfo instance.

        The hash code of an OpenMBeanParameterInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanParameterInfo instances t1 and t2, as required by the general contract of the method Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        the hash code value for this OpenMBeanParameterInfo instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this OpenMBeanParameterInfo instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanParameterInfo), the string representation of the name and open type of the described parameter, and the string representation of its default, min, max and legal values.

        重载：
        toString in class Object
        返回：
        a string representation of this OpenMBeanParameterInfo instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fro)ho.Co.2hh.22(haac


OpenMBeanParameterInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenMBeanParameterInfoSupport

  • java.lang.Object
    • javax.management.MBeanFeatureInfo
      • javax.management.MBeanParameterInfo
        • javax.management.openmbean.OpenMBeanParameterInfoSupport
  • 所有已实现的接口：
    Serializable, Cloneable, DescriptorRead, OpenMBeanParameterInfo

    public class OpenMBeanParameterInfoSupport
extends MBeanParameterInfo
implements OpenMBeanParameterInfo
    Describes a parameter used in one or more operations or constructors of an open MBean.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.MBeanFeatureInfo

        描述, name

    • 构造方法摘要

      Constructors
      构造方法与描述
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and 描述.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, and descriptor.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述 and defaultValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue and legalValues.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.
      Object getDefaultValue()
      Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
      Set<?> getLegalValues()
      Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
      Comparable<?> getMaxValue()
      Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
      Comparable<?> getMinValue()
      Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
      OpenType<?> getOpenType()
      Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.
      boolean hasDefaultValue()
      Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
      int hashCode()
      Returns the hash code value for this OpenMBeanParameterInfoSupport instance.
      boolean hasLegalValues()
      Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
      boolean hasMaxValue()
      Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
      boolean hasMinValue()
      Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
      boolean isValue(Object obj)
      Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
      String toString()
      Returns a string representation of this OpenMBeanParameterInfoSupport instance.

      • 方法 - 继承于类 javax.management.MBeanParameterInfo

        clone, getType

      • 方法 - 继承于类 javax.management.MBeanFeatureInfo

        getDescription, getDescriptor, getName

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.management.openmbean.OpenMBeanParameterInfo

        getDescription, getName

    • 构造方法详细信息

      • OpenMBeanParameterInfoSupport

        public OpenMBeanParameterInfoSupport(String name,
                             String description,
                             OpenType<?> openType)
        Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and 描述.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.

      • OpenMBeanParameterInfoSupport

        public OpenMBeanParameterInfoSupport(String name,
                             String description,
                             OpenType<?> openType,
                             Descriptor descriptor)

        Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, and descriptor.

        The descriptor can contain entries that will define the values returned by certain methods of this class, as explained in the package description.

        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        descriptor - The descriptor for the parameter. This may be null which is equivalent to an empty descriptor.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null, or the descriptor entries are invalid as described in the package description.
        从以下版本开始：
        1.6

      • OpenMBeanParameterInfoSupport

        public OpenMBeanParameterInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             T defaultValue)
                              throws OpenDataException
        Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述 and defaultValue.
        类型参数：
        T - allows the compiler to check that the defaultValue, if non-null, has the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType.

      • OpenMBeanParameterInfoSupport

        public OpenMBeanParameterInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             T defaultValue,
                             T[] legalValues)
                              throws OpenDataException

        Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue and legalValues.

        The contents of legalValues are copied, so subsequent modifications of the array referenced by legalValues have no impact on this OpenMBeanParameterInfoSupport instance.

        类型参数：
        T - allows the compiler to check that the defaultValue and legalValues, if non-null, have the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        legalValues - each contained value must be valid for the openType specified for this parameter; legal values not supported for ArrayType and TabularType; can be null or empty.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue is not a valid value for the specified openType, or one value in legalValues is not valid for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and defaultValue is not contained in legalValues.

      • OpenMBeanParameterInfoSupport

        public OpenMBeanParameterInfoSupport(String name,
                             String description,
                             OpenType<T> openType,
                             T defaultValue,
                             Comparable<T> minValue,
                             Comparable<T> maxValue)
                              throws OpenDataException
        Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue, minValue and maxValue. It is possible to specify minimal and maximal values only for an open type whose values are Comparable.
        类型参数：
        T - allows the compiler to check that the defaultValue, minValue, and maxValue, if non-null, have the correct Java type for the given openType.
        参数：
        name - cannot be a null or empty string.
        描述 - cannot be a null or empty string.
        openType - cannot be null.
        defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
        minValue - must be valid for the openType specified for this parameter; can be null, in which case it means that no minimal value is set.
        maxValue - must be valid for the openType specified for this parameter; can be null, in which case it means that no maximal value is set.
        抛出：
        IllegalArgumentException - if name or 描述 are null or empty string, or openType is null.
        OpenDataException - if defaultValue, minValue or maxValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or both minValue and maxValue are non-null and minValue.compareTo(maxValue) > 0 is true, or both defaultValue and minValue are non-null and minValue.compareTo(defaultValue) > 0 is true, or both defaultValue and maxValue are non-null and defaultValue.compareTo(maxValue) > 0 is true.

    • 方法详细信息

      • getOpenType

        public OpenType<?> getOpenType()
        Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.
        指定者：
        getOpenType in interface OpenMBeanParameterInfo
        返回：
        the open type.

      • getDefaultValue

        public Object getDefaultValue()
        Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
        指定者：
        getDefaultValue in interface OpenMBeanParameterInfo
        返回：
        the default value.

      • getLegalValues

        public Set<?> getLegalValues()
        Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
        指定者：
        getLegalValues in interface OpenMBeanParameterInfo
        返回：
        the set of legal values.

      • getMinValue

        public Comparable<?> getMinValue()
        Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
        指定者：
        getMinValue in interface OpenMBeanParameterInfo
        返回：
        the minimum value.

      • getMaxValue

        public Comparable<?> getMaxValue()
        Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
        指定者：
        getMaxValue in interface OpenMBeanParameterInfo
        返回：
        the maximum value.

      • hasDefaultValue

        public boolean hasDefaultValue()
        Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
        指定者：
        hasDefaultValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a default value.

      • hasLegalValues

        public boolean hasLegalValues()
        Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
        指定者：
        hasLegalValues in interface OpenMBeanParameterInfo
        返回：
        true if there is a set of legal values.

      • hasMinValue

        public boolean hasMinValue()
        Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
        指定者：
        hasMinValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a minimum value.

      • hasMaxValue

        public boolean hasMaxValue()
        Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
        指定者：
        hasMaxValue in interface OpenMBeanParameterInfo
        返回：
        true if there is a maximum value.

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
        指定者：
        isValue in interface OpenMBeanParameterInfo
        参数：
        obj - the object to be tested.
        返回：
        true if obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance, false otherwise.

      • equals

        public boolean equals(Object obj)

        Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the OpenMBeanParameterInfo interface,
        • their names are equal
        • their open types are equal
        • their default, min, max and legal values are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanParameterInfo interface.

        If obj also implements DescriptorRead, then its getDescriptor() method must also return the same value as for this object.

        指定者：
        equals in interface OpenMBeanParameterInfo
        重载：
        equals in class MBeanParameterInfo
        参数：
        obj - the object to be compared for equality with this OpenMBeanParameterInfoSupport instance.
        返回：
        true if the specified object is equal to this OpenMBeanParameterInfoSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns the hash code value for this OpenMBeanParameterInfoSupport instance.

        The hash code of an OpenMBeanParameterInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, its default, min, max and legal values, and its Descriptor).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanParameterInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the OpenMBeanParameterInfo interface may be equal to this OpenMBeanParameterInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        As OpenMBeanParameterInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in interface OpenMBeanParameterInfo
        重载：
        hashCode in class MBeanParameterInfo
        返回：
        the hash code value for this OpenMBeanParameterInfoSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this OpenMBeanParameterInfoSupport instance.

        The string representation consists of the name of this class (i.e. javax.management.openmbean.OpenMBeanParameterInfoSupport), the string representation of the name and open type of the described parameter, the string representation of its default, min, max and legal values and the string representation of its descriptor.

        As OpenMBeanParameterInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in interface OpenMBeanParameterInfo
        重载：
        toString in class MBeanParameterInfo
        返回：
        a string representation of this OpenMBeanParameterInfoSupport instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OpenType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 OpenType<T>

  • java.lang.Object
    • javax.management.openmbean.OpenType<T>
  • 类型参数：
    T - the Java type that instances described by this type must have. For example, SimpleType.INTEGER is a SimpleType<Integer> which is a subclass of OpenType<Integer>, meaning that an attribute, parameter, or return value that is described as a SimpleType.INTEGER must have Java type Integer.
    所有已实现的接口：
    Serializable
    直接已知子类：
    ArrayType, CompositeType, SimpleType, TabularType

    public abstract class OpenType<T>
extends Object
implements Serializable
    The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.

    An open type is defined by:

    • the fully qualified Java class name of the open data values this type describes; note that only a limited set of Java classes is allowed for open data values (see ALLOWED_CLASSNAMES_LIST),
    • its name,
    • its description.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String[] ALLOWED_CLASSNAMES
      Deprecated.
      Use ALLOWED_CLASSNAMES_LIST instead.
      static List<String> ALLOWED_CLASSNAMES_LIST
      List of the fully qualified names of the Java classes allowed for open data values.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected OpenType(String className, String typeName, String description)
      Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean equals(Object obj)
      Compares the specified obj parameter with this open type instance for equality.
      String getClassName()
      Returns the fully qualified Java class name of the open data values this open type describes.
      String getDescription()
      Returns the text description of this OpenType instance.
      String getTypeName()
      Returns the name of this OpenType instance.
      abstract int hashCode()
      Returns a hash code value for the object.
      boolean isArray()
      Returns true if the open data values this open type describes are arrays, false otherwise.
      abstract boolean isValue(Object obj)
      Tests whether obj is a value for this open type.
      abstract String toString()
      Returns a string representation of this open type instance.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ALLOWED_CLASSNAMES_LIST

        public static final List<String> ALLOWED_CLASSNAMES_LIST
        List of the fully qualified names of the Java classes allowed for open data values. A multidimensional array of any one of these classes or their corresponding primitive types is also an allowed class for open data values.
        ALLOWED_CLASSNAMES_LIST = {
        "java.lang.Void",
        "java.lang.Boolean",
        "java.lang.Character",
        "java.lang.Byte",
        "java.lang.Short",
        "java.lang.Integer",
        "java.lang.Long",
        "java.lang.Float",
        "java.lang.Double",
        "java.lang.String",
        "java.math.BigDecimal",
        "java.math.BigInteger",
        "java.util.Date",
        "javax.management.ObjectName",
        CompositeData.class.getName(),
        TabularData.class.getName() } ;

      • ALLOWED_CLASSNAMES

        @Deprecated
public static final String[] ALLOWED_CLASSNAMES
        Deprecated. Use ALLOWED_CLASSNAMES_LIST instead.

    • 构造方法详细信息

      • OpenType

        protected OpenType(String className,
        String typeName,
        String description)
            throws OpenDataException
        Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters. The validity constraints are described below for each parameter.
        参数：
        className - The fully qualified Java class name of the open data values this open type describes. The valid Java class names allowed for open data values are listed in ALLOWED_CLASSNAMES_LIST. A multidimensional array of any one of these classes or their corresponding primitive types is also an allowed class, in which case the class name follows the rules defined by the method getName() of java.lang.Class. For example, a 3-dimensional array of Strings has for class name "[[[Ljava.lang.String;" (without the quotes).
        typeName - The name given to the open type this instance represents; cannot be a null or empty string.
        描述 - The human readable description of the open type this instance represents; cannot be a null or empty string.
        抛出：
        IllegalArgumentException - if className, typeName or 描述 is a null or empty string
        OpenDataException - if className is not one of the allowed Java class names for open data

    • 方法详细信息

      • getClassName

        public String getClassName()
        Returns the fully qualified Java class name of the open data values this open type describes. The only possible Java class names for open data values are listed in ALLOWED_CLASSNAMES_LIST. A multidimensional array of any one of these classes or their corresponding primitive types is also an allowed class, in which case the class name follows the rules defined by the method getName() of java.lang.Class. For example, a 3-dimensional array of Strings has for class name "[[[Ljava.lang.String;" (without the quotes), a 3-dimensional array of Integers has for class name "[[[Ljava.lang.Integer;" (without the quotes), and a 3-dimensional array of int has for class name "[[[I" (without the quotes)
        返回：
        the class name.

      • getTypeName

        public String getTypeName()
        Returns the name of this OpenType instance.
        返回：
        the type name.

      • getDescription

        public String getDescription()
        Returns the text description of this OpenType instance.
        返回：
        the description.

      • isArray

        public boolean isArray()
        Returns true if the open data values this open type describes are arrays, false otherwise.
        返回：
        true if this is an array type.

      • isValue

        public abstract boolean isValue(Object obj)
        Tests whether obj is a value for this open type.
        参数：
        obj - the object to be tested for validity.
        返回：
        true if obj is a value for this open type, false otherwise.

      • equals

        public abstract boolean equals(Object obj)
        Compares the specified obj parameter with this open type instance for equality.
        重载：
        equals in class Object
        参数：
        obj - the object to compare to.
        返回：
        true if this object and obj are equal.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public abstract int hashCode()
        Description copied from class: Object
        Returns a hash code value for the object. This method is supported for the benefit of hash tables such as those provided by HashMap.

        The general contract of hashCode is:

        • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
        • If two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result.
        • It is not required that if two objects are unequal according to the Object.equals(java.lang.Object) method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.

        As much as is reasonably practical, the hashCode method defined by class Object does return distinct integers for distinct objects. (This is typically implemented by converting the internal address of the object into an integer, but this implementation technique is not required by the JavaTM programming language.)

        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public abstract String toString()
        Returns a string representation of this open type instance.
        重载：
        toString in class Object
        返回：
        the string representation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p pyeepyyoteenpeanaaTeebenepmenegnev ..enytn


SimpleType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

类 SimpleType<T>

  • java.lang.Object
    • javax.management.openmbean.OpenType<T>
      • javax.management.openmbean.SimpleType<T>
  • 所有已实现的接口：
    Serializable

    public final class SimpleType<T>
extends OpenType<T>
    The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values. It predefines all its possible instances as static fields, and has no public constructor.

    Given a SimpleType instance describing values whose Java class name is className, the internal fields corresponding to the name and description of this SimpleType instance are also set to className. In other words, its methods getClassName, getTypeName and getDescription all return the same string value className.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static SimpleType<BigDecimal> BIGDECIMAL
      The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
      static SimpleType<BigInteger> BIGINTEGER
      The SimpleType instance describing values whose Java class name is java.math.BigInteger.
      static SimpleType<Boolean> BOOLEAN
      The SimpleType instance describing values whose Java class name is java.lang.Boolean.
      static SimpleType<Byte> BYTE
      The SimpleType instance describing values whose Java class name is java.lang.Byte.
      static SimpleType<Character> CHARACTER
      The SimpleType instance describing values whose Java class name is java.lang.Character.
      static SimpleType<Date> DATE
      The SimpleType instance describing values whose Java class name is java.util.Date.
      static SimpleType<Double> DOUBLE
      The SimpleType instance describing values whose Java class name is java.lang.Double.
      static SimpleType<Float> FLOAT
      The SimpleType instance describing values whose Java class name is java.lang.Float.
      static SimpleType<Integer> INTEGER
      The SimpleType instance describing values whose Java class name is java.lang.Integer.
      static SimpleType<Long> LONG
      The SimpleType instance describing values whose Java class name is java.lang.Long.
      static SimpleType<ObjectName> OBJECTNAME
      The SimpleType instance describing values whose Java class name is javax.management.ObjectName.
      static SimpleType<Short> SHORT
      The SimpleType instance describing values whose Java class name is java.lang.Short.
      static SimpleType<String> STRING
      The SimpleType instance describing values whose Java class name is java.lang.String.
      static SimpleType<Void> VOID
      The SimpleType instance describing values whose Java class name is java.lang.Void.

      • Fields inherited from class javax.management.openmbean.OpenType

        ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this SimpleType instance for equality.
      int hashCode()
      Returns the hash code value for this SimpleType instance.
      boolean isValue(Object obj)
      Tests whether obj is a value for this SimpleType instance.
      Object readResolve()
      Replace an object read from an ObjectInputStream with the unique instance for that value.
      String toString()
      Returns a string representation of this SimpleType instance.

      • 方法 - 继承于类 javax.management.openmbean.OpenType

        getClassName, getDescription, getTypeName, isArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • VOID

        public static final SimpleType<Void> VOID
        The SimpleType instance describing values whose Java class name is java.lang.Void.

      • BOOLEAN

        public static final SimpleType<Boolean> BOOLEAN
        The SimpleType instance describing values whose Java class name is java.lang.Boolean.

      • CHARACTER

        public static final SimpleType<Character> CHARACTER
        The SimpleType instance describing values whose Java class name is java.lang.Character.

      • BYTE

        public static final SimpleType<Byte> BYTE
        The SimpleType instance describing values whose Java class name is java.lang.Byte.

      • SHORT

        public static final SimpleType<Short> SHORT
        The SimpleType instance describing values whose Java class name is java.lang.Short.

      • INTEGER

        public static final SimpleType<Integer> INTEGER
        The SimpleType instance describing values whose Java class name is java.lang.Integer.

      • LONG

        public static final SimpleType<Long> LONG
        The SimpleType instance describing values whose Java class name is java.lang.Long.

      • FLOAT

        public static final SimpleType<Float> FLOAT
        The SimpleType instance describing values whose Java class name is java.lang.Float.

      • DOUBLE

        public static final SimpleType<Double> DOUBLE
        The SimpleType instance describing values whose Java class name is java.lang.Double.

      • STRING

        public static final SimpleType<String> STRING
        The SimpleType instance describing values whose Java class name is java.lang.String.

      • BIGDECIMAL

        public static final SimpleType<BigDecimal> BIGDECIMAL
        The SimpleType instance describing values whose Java class name is java.math.BigDecimal.

      • BIGINTEGER

        public static final SimpleType<BigInteger> BIGINTEGER
        The SimpleType instance describing values whose Java class name is java.math.BigInteger.

      • DATE

        public static final SimpleType<Date> DATE
        The SimpleType instance describing values whose Java class name is java.util.Date.

      • OBJECTNAME

        public static final SimpleType<ObjectName> OBJECTNAME
        The SimpleType instance describing values whose Java class name is javax.management.ObjectName.

    • 方法详细信息

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a value for this SimpleType instance.

        This method returns true if and only if obj is not null and obj's class name is the same as the className field defined for this SimpleType instance (ie the class name returned by the getClassName method).

        指定者：
        isValue in class OpenType<T>
        参数：
        obj - the object to be tested.
        返回：
        true if obj is a value for this SimpleType instance.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this SimpleType instance for equality.

        Two SimpleType instances are equal if and only if their getClassName methods return the same value.

        指定者：
        equals in class OpenType<T>
        参数：
        obj - the object to be compared for equality with this SimpleType instance; if obj is null or is not an instance of the class SimpleType, equals returns false.
        返回：
        true if the specified object is equal to this SimpleType instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this SimpleType instance. The hash code of a SimpleType instance is the the hash code of the string value returned by the getClassName method.

        As SimpleType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in class OpenType<T>
        返回：
        the hash code value for this SimpleType instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this SimpleType instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.SimpleType) and the type name for this instance (which is the java class name of the values this SimpleType instance represents).

        As SimpleType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in class OpenType<T>
        返回：
        a string representation of this SimpleType instance

      • readResolve

        public Object readResolve()
                   throws ObjectStreamException
        Replace an object read from an ObjectInputStream with the unique instance for that value.
        返回：
        the replacement object.
        抛出：
        ObjectStreamException - if the read object cannot be resolved.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


TabularData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.openmbean

Interface TabularData

  • All Known Implementing Classes:
    TabularDataSupport

    public interface TabularData
    The TabularData interface specifies the behavior of a specific type of complex open data objects which represent tabular data structures.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object[] calculateIndex(CompositeData value)
      Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
      void clear()
      Removes all CompositeData values (ie rows) from this TabularData instance.
      boolean containsKey(Object[] key)
      Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
      boolean containsValue(CompositeData value)
      Returns true if and only if this TabularData instance contains the specified CompositeData value.
      boolean equals(Object obj)
      Compares the specified obj parameter with this TabularData instance for equality.
      CompositeData get(Object[] key)
      Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
      TabularType getTabularType()
      Returns the tabular type describing this TabularData instance.
      int hashCode()
      Returns the hash code value for this TabularData instance.
      boolean isEmpty()
      Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
      Set<?> keySet()
      Returns a set view of the keys (ie the index values) of the CompositeData values (ie the rows) contained in this TabularData instance.
      void put(CompositeData value)
      Adds value to this TabularData instance.
      void putAll(CompositeData[] values)
      Add all the elements in values to this TabularData instance.
      CompositeData remove(Object[] key)
      Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
      int size()
      Returns the number of CompositeData values (ie the number of rows) contained in this TabularData instance.
      String toString()
      Returns a string representation of this TabularData instance.
      Collection<?> values()
      Returns a collection view of the CompositeData values (ie the rows) contained in this TabularData instance.

    • 方法详细信息

      • getTabularType

        TabularType getTabularType()
        Returns the tabular type describing this TabularData instance.
        返回：
        the tabular type.

      • calculateIndex

        Object[] calculateIndex(CompositeData value)
        Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance. This method checks for the type validity of the specified value, but does not check if the calculated index is already used to refer to a value in this TabularData instance.
        参数：
        value - the composite data value whose index in this TabularData instance is to be calculated; must be of the same composite type as this instance's row type; must not be null.
        返回：
        the index that the specified value would have in this TabularData instance.
        抛出：
        NullPointerException - if value is null
        InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.

      • size

        int size()
        Returns the number of CompositeData values (ie the number of rows) contained in this TabularData instance.
        返回：
        the number of values contained.

      • isEmpty

        boolean isEmpty()
        Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
        返回：
        true if this TabularData is empty.

      • containsKey

        boolean containsKey(Object[] key)
        Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key is null or does not conform to this TabularData instance's TabularType definition, this method simply returns false.
        参数：
        key - the index value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData indexes a row value with the specified key.

      • containsValue

        boolean containsValue(CompositeData value)
        Returns true if and only if this TabularData instance contains the specified CompositeData value. If value is null or does not conform to this TabularData instance's row type definition, this method simply returns false.
        参数：
        value - the row value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData instance contains the specified row value.

      • get

        CompositeData get(Object[] key)
        Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
        参数：
        key - the key of the row to return.
        返回：
        the value corresponding to key.
        抛出：
        NullPointerException - if the key is null
        InvalidKeyException - if the key does not conform to this TabularData instance's * TabularType definition

      • put

        void put(CompositeData value)
        Adds value to this TabularData instance. The composite type of value must be the same as this instance's row type (ie the composite type returned by this.getTabularType().getRowType()), and there must not already be an existing value in this TabularData instance whose index is the same as the one calculated for the value to be added. The index for value is calculated according to this TabularData instance's TabularType definition (see TabularType.getIndexNames()).
        参数：
        value - the composite data value to be added as a new row to this TabularData instance; must be of the same composite type as this instance's row type; must not be null.
        抛出：
        NullPointerException - if value is null
        InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.
        KeyAlreadyExistsException - if the index for value, calculated according to this TabularData instance's TabularType definition already maps to an existing value in the underlying HashMap.

      • remove

        CompositeData remove(Object[] key)
        Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
        参数：
        key - the index of the value to get in this TabularData instance; must be valid with this TabularData instance's row type definition; must not be null.
        返回：
        previous value associated with specified key, or null if there was no mapping for key.
        抛出：
        NullPointerException - if the key is null
        InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

      • putAll

        void putAll(CompositeData[] values)
        Add all the elements in values to this TabularData instance. If any element in values does not satisfy the constraints defined in put, or if any two elements in values have the same index calculated according to this TabularData instance's TabularType definition, then an exception describing the failure is thrown and no element of values is added, thus leaving this TabularData instance unchanged.
        参数：
        values - the array of composite data values to be added as new rows to this TabularData instance; if values is null or empty, this method returns without doing anything.
        抛出：
        NullPointerException - if an element of values is null
        InvalidOpenTypeException - if an element of values does not conform to this TabularData instance's row type definition
        KeyAlreadyExistsException - if the index for an element of values, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two elements of values have the same index.

      • clear

        void clear()
        Removes all CompositeData values (ie rows) from this TabularData instance.

      • keySet

        Set<?> keySet()
        Returns a set view of the keys (ie the index values) of the CompositeData values (ie the rows) contained in this TabularData instance. The returned Set is a Set<List<?>> but is declared as a Set<?> for compatibility reasons. The returned set can be used to iterate over the keys.
        返回：
        a set view (Set<List<?>>) of the index values used in this TabularData instance.

      • values

        Collection<?> values()
        Returns a collection view of the CompositeData values (ie the rows) contained in this TabularData instance. The returned Collection is a Collection<CompositeData> but is declared as a Collection<?> for compatibility reasons. The returned collection can be used to iterate over the values.
        返回：
        a collection view (Collection<CompositeData>) of the rows contained in this TabularData instance.

      • equals

        boolean equals(Object obj)
        Compares the specified obj parameter with this TabularData instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the TabularData interface,
        • their row types are equal
        • their contents (ie index to value mappings) are equal
        This ensures that this equals method works properly for obj parameters which are different implementations of the TabularData interface.
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this TabularData instance;
        返回：
        true if the specified object is equal to this TabularData instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this TabularData instance.

        The hash code of a TabularData instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its tabular type and its content, where the content is defined as all the index to value mappings).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        the hash code value for this TabularDataSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        String toString()
        Returns a string representation of this TabularData instance.

        The string representation consists of the name of the implementing class, and the tabular type of this instance.

        重载：
        toString in class Object
        返回：
        a string representation of this TabularData instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

envn"nsnrno""gnn"nnn/n./xgp "m"lx/mno


TabularDataSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 TabularDataSupport

  • java.lang.Object
    • javax.management.openmbean.TabularDataSupport
  • 所有已实现的接口：
    Serializable, Cloneable, Map<Object,Object>, TabularData

    public class TabularDataSupport
extends Object
implements TabularData, Map<Object,Object>, Cloneable, Serializable
    The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      Constructors
      构造方法与描述
      TabularDataSupport(TabularType tabularType)
      Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).
      TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
      Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object[] calculateIndex(CompositeData value)
      Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
      void clear()
      Removes all rows from this TabularDataSupport instance.
      Object clone()
      Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map.
      boolean containsKey(Object key)
      Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
      boolean containsKey(Object[] key)
      Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
      boolean containsValue(CompositeData value)
      Returns true if and only if this TabularData instance contains the specified CompositeData value.
      boolean containsValue(Object value)
      Returns true if and only if this TabularData instance contains the specified value.
      Set<Map.Entry<Object,Object>> entrySet()
      Returns a collection view of the index to row mappings contained in this TabularDataSupport instance.
      boolean equals(Object obj)
      Compares the specified obj parameter with this TabularDataSupport instance for equality.
      Object get(Object key)
      This method simply calls get((Object[]) key).
      CompositeData get(Object[] key)
      Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
      TabularType getTabularType()
      Returns the tabular type describing this TabularData instance.
      int hashCode()
      Returns the hash code value for this TabularDataSupport instance.
      boolean isEmpty()
      Returns true if this TabularDataSupport instance contains no rows.
      Set<Object> keySet()
      Returns a set view of the keys contained in the underlying map of this TabularDataSupport instance used to index the rows.
      void put(CompositeData value)
      Adds value to this TabularData instance.
      Object put(Object key, Object value)
      This method simply calls put((CompositeData) value) and therefore ignores its key parameter which can be null.
      void putAll(CompositeData[] values)
      Add all the elements in values to this TabularData instance.
      void putAll(Map<?,?> t)
      Add all the values contained in the specified map t to this TabularData instance.
      Object remove(Object key)
      This method simply calls remove((Object[]) key).
      CompositeData remove(Object[] key)
      Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
      int size()
      Returns the number of rows in this TabularDataSupport instance.
      String toString()
      Returns a string representation of this TabularDataSupport instance.
      Collection<Object> values()
      Returns a collection view of the rows contained in this TabularDataSupport instance.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TabularDataSupport

        public TabularDataSupport(TabularType tabularType)
        Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).

        This constructor simply calls this(tabularType, 101, 0.75f);

        参数：
        tabularType - the tabular type describing this TabularData instance; cannot be null.
        抛出：
        IllegalArgumentException - if the tabular type is null.

      • TabularDataSupport

        public TabularDataSupport(TabularType tabularType,
                  int initialCapacity,
                  float loadFactor)
        Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.
        参数：
        tabularType - the tabular type describing this TabularData instance; cannot be null.
        initialCapacity - the initial capacity of the HashMap.
        loadFactor - the load factor of the HashMap
        抛出：
        IllegalArgumentException - if the initial capacity is less than zero, or the load factor is nonpositive, or the tabular type is null.

    • 方法详细信息

      • getTabularType

        public TabularType getTabularType()
        Returns the tabular type describing this TabularData instance.
        指定者：
        getTabularType in interface TabularData
        返回：
        the tabular type.

      • calculateIndex

        public Object[] calculateIndex(CompositeData value)
        Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance. This method checks for the type validity of the specified value, but does not check if the calculated index is already used to refer to a value in this TabularData instance.
        指定者：
        calculateIndex in interface TabularData
        参数：
        value - the composite data value whose index in this TabularData instance is to be calculated; must be of the same composite type as this instance's row type; must not be null.
        返回：
        the index that the specified value would have in this TabularData instance.
        抛出：
        NullPointerException - if value is null.
        InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.

      • containsKey

        public boolean containsKey(Object key)
        Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key cannot be cast to a one dimension array of Object instances, this method simply returns false; otherwise it returns the the result of the call to this.containsKey((Object[]) key).
        指定者：
        containsKey in interface Map<Object,Object>
        参数：
        key - the index value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData indexes a row value with the specified key.

      • containsKey

        public boolean containsKey(Object[] key)
        Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key is null or does not conform to this TabularData instance's TabularType definition, this method simply returns false.
        指定者：
        containsKey in interface TabularData
        参数：
        key - the index value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData indexes a row value with the specified key.

      • containsValue

        public boolean containsValue(CompositeData value)
        Returns true if and only if this TabularData instance contains the specified CompositeData value. If value is null or does not conform to this TabularData instance's row type definition, this method simply returns false.
        指定者：
        containsValue in interface TabularData
        参数：
        value - the row value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData instance contains the specified row value.

      • containsValue

        public boolean containsValue(Object value)
        Returns true if and only if this TabularData instance contains the specified value.
        指定者：
        containsValue in interface Map<Object,Object>
        参数：
        value - the row value whose presence in this TabularData instance is to be tested.
        返回：
        true if this TabularData instance contains the specified row value.

      • get

        public Object get(Object key)
        This method simply calls get((Object[]) key).
        指定者：
        get in interface Map<Object,Object>
        参数：
        key - the key whose associated value is to be returned
        返回：
        the value to which the specified key is mapped, or null if this map contains no mapping for the key
        抛出：
        NullPointerException - if the key is null
        ClassCastException - if the key is not of the type Object[]
        InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

      • get

        public CompositeData get(Object[] key)
        Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
        指定者：
        get in interface TabularData
        参数：
        key - the index of the value to get in this TabularData instance; * must be valid with this TabularData instance's row type definition; * must not be null.
        返回：
        the value corresponding to key.
        抛出：
        NullPointerException - if the key is null
        InvalidKeyException - if the key does not conform to this TabularData instance's TabularType type definition.

      • put

        public Object put(Object key,
         Object value)
        This method simply calls put((CompositeData) value) and therefore ignores its key parameter which can be null.
        指定者：
        put in interface Map<Object,Object>
        参数：
        key - an ignored parameter.
        value - the CompositeData to put.
        返回：
        the value which is put
        抛出：
        NullPointerException - if the value is null
        ClassCastException - if the value is not of the type CompositeData
        InvalidOpenTypeException - if the value does not conform to this TabularData instance's TabularType definition
        KeyAlreadyExistsException - if the key for the value parameter, calculated according to this TabularData instance's TabularType definition already maps to an existing value

      • put

        public void put(CompositeData value)
        从接口复制的描述： TabularData
        Adds value to this TabularData instance. The composite type of value must be the same as this instance's row type (ie the composite type returned by this.getTabularType().getRowType()), and there must not already be an existing value in this TabularData instance whose index is the same as the one calculated for the value to be added. The index for value is calculated according to this TabularData instance's TabularType definition (see TabularType.getIndexNames()).
        指定者：
        put in interface TabularData
        参数：
        value - the composite data value to be added as a new row to this TabularData instance; must be of the same composite type as this instance's row type; must not be null.

      • remove

        public Object remove(Object key)
        This method simply calls remove((Object[]) key).
        指定者：
        remove in interface Map<Object,Object>
        参数：
        key - an Object[] representing the key to remove.
        返回：
        previous value associated with specified key, or null if there was no mapping for key.
        抛出：
        NullPointerException - if the key is null
        ClassCastException - if the key is not of the type Object[]
        InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

      • remove

        public CompositeData remove(Object[] key)
        Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
        指定者：
        remove in interface TabularData
        参数：
        key - the index of the value to get in this TabularData instance; must be valid with this TabularData instance's row type definition; must not be null.
        返回：
        previous value associated with specified key, or null if there was no mapping for key.
        抛出：
        NullPointerException - if the key is null
        InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

      • putAll

        public void putAll(Map<?,?> t)
        Add all the values contained in the specified map t to this TabularData instance. This method converts the collection of values contained in this map into an array of CompositeData values, if possible, and then call the method putAll(CompositeData[]). Note that the keys used in the specified map t are ignored. This method allows, for example to add the content of another TabularData instance with the same row type (but possibly different index names) into this instance.
        指定者：
        putAll in interface Map<Object,Object>
        参数：
        t - the map whose values are to be added as new rows to this TabularData instance; if t is null or empty, this method returns without doing anything.
        抛出：
        NullPointerException - if a value in t is null.
        ClassCastException - if a value in t is not an instance of CompositeData.
        InvalidOpenTypeException - if a value in t does not conform to this TabularData instance's row type definition.
        KeyAlreadyExistsException - if the index for a value in t, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two values in t have the same index.

      • putAll

        public void putAll(CompositeData[] values)
        Add all the elements in values to this TabularData instance. If any element in values does not satisfy the constraints defined in put, or if any two elements in values have the same index calculated according to this TabularData instance's TabularType definition, then an exception describing the failure is thrown and no element of values is added, thus leaving this TabularData instance unchanged.
        指定者：
        putAll in interface TabularData
        参数：
        values - the array of composite data values to be added as new rows to this TabularData instance; if values is null or empty, this method returns without doing anything.
        抛出：
        NullPointerException - if an element of values is null
        InvalidOpenTypeException - if an element of values does not conform to this TabularData instance's row type definition (ie its TabularType definition)
        KeyAlreadyExistsException - if the index for an element of values, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two elements of values have the same index

      • clear

        public void clear()
        Removes all rows from this TabularDataSupport instance.
        指定者：
        clear in interface Map<Object,Object>
        指定者：
        clear in interface TabularData

      • size

        public int size()
        Returns the number of rows in this TabularDataSupport instance.
        指定者：
        size in interface Map<Object,Object>
        指定者：
        size in interface TabularData
        返回：
        the number of rows in this TabularDataSupport instance.

      • isEmpty

        public boolean isEmpty()
        Returns true if this TabularDataSupport instance contains no rows.
        指定者：
        isEmpty in interface Map<Object,Object>
        指定者：
        isEmpty in interface TabularData
        返回：
        true if this TabularDataSupport instance contains no rows.

      • keySet

        public Set<Object> keySet()
        Returns a set view of the keys contained in the underlying map of this TabularDataSupport instance used to index the rows. Each key contained in this Set is an unmodifiable List<?> so the returned set view is a Set<List<?>> but is declared as a Set<Object> for compatibility reasons. The set is backed by the underlying map of this TabularDataSupport instance, so changes to the TabularDataSupport instance are reflected in the set, and vice-versa. The set supports element removal, which removes the corresponding row from this TabularDataSupport instance, via the Iterator.remove(), Set.remove(java.lang.Object), Set.removeAll(java.util.Collection), Set.retainAll(java.util.Collection), and Set.clear() operations. It does not support the Set.add(E) or Set.addAll(java.util.Collection) operations.
        指定者：
        keySet in interface Map<Object,Object>
        指定者：
        keySet in interface TabularData
        返回：
        a set view (Set<List<?>>) of the keys used to index the rows of this TabularDataSupport instance.

      • values

        public Collection<Object> values()
        Returns a collection view of the rows contained in this TabularDataSupport instance. The returned Collection is a Collection<CompositeData> but is declared as a Collection<Object> for compatibility reasons. The returned collection can be used to iterate over the values. The collection is backed by the underlying map, so changes to the TabularDataSupport instance are reflected in the collection, and vice-versa. The collection supports element removal, which removes the corresponding index to row mapping from this TabularDataSupport instance, via the Iterator.remove(), Collection.remove(java.lang.Object), Collection.removeAll(java.util.Collection), Collection.retainAll(java.util.Collection), and Collection.clear() operations. It does not support the Collection.add(E) or Collection.addAll(java.util.Collection) operations.
        指定者：
        values in interface Map<Object,Object>
        指定者：
        values in interface TabularData
        返回：
        a collection view (Collection<CompositeData>) of the values contained in this TabularDataSupport instance.

      • entrySet

        public Set<Map.Entry<Object,Object>> entrySet()
        Returns a collection view of the index to row mappings contained in this TabularDataSupport instance. Each element in the returned collection is a Map.Entry<List<?>,CompositeData> but is declared as a Map.Entry<Object,Object> for compatibility reasons. Each of the map entry keys is an unmodifiable List<?>. The collection is backed by the underlying map of this TabularDataSupport instance, so changes to the TabularDataSupport instance are reflected in the collection, and vice-versa. The collection supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove(), Collection.remove(java.lang.Object), Collection.removeAll(java.util.Collection), Collection.retainAll(java.util.Collection), and Collection.clear() operations. It does not support the Collection.add(E) or Collection.addAll(java.util.Collection) operations.

        IMPORTANT NOTICE: Do not use the setValue method of the Map.Entry elements contained in the returned collection view. Doing so would corrupt the index to row mappings contained in this TabularDataSupport instance.

        指定者：
        entrySet in interface Map<Object,Object>
        返回：
        a collection view (Set<Map.Entry<List<?>,CompositeData>>) of the mappings contained in this map.
        另请参见：
        Map.Entry

      • clone

        public Object clone()
        Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map. Only a shallow clone of the underlying map is made, i.e. no cloning of the indexes and row values is made as they are immutable.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this TabularDataSupport instance for equality.

        Returns true if and only if all of the following statements are true:

        • obj is non null,
        • obj also implements the TabularData interface,
        • their tabular types are equal
        • their contents (ie all CompositeData values) are equal.
        This ensures that this equals method works properly for obj parameters which are different implementations of the TabularData interface.
        指定者：
        equals in interface Map<Object,Object>
        指定者：
        equals in interface TabularData
        重载：
        equals in class Object
        参数：
        obj - the object to be compared for equality with this TabularDataSupport instance;
        返回：
        true if the specified object is equal to this TabularDataSupport instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this TabularDataSupport instance.

        The hash code of a TabularDataSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its tabular type and its content, where the content is defined as all the CompositeData values).

        This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode().

        However, note that another instance of a class implementing the TabularData interface may be equal to this TabularDataSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

        指定者：
        hashCode in interface Map<Object,Object>
        指定者：
        hashCode in interface TabularData
        重载：
        hashCode in class Object
        返回：
        the hash code value for this TabularDataSupport instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this TabularDataSupport instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.TabularDataSupport), the string representation of the tabular type of this instance, and the string representation of the contents (ie list the key=value mappings as returned by a call to dataMap. toString()).

        指定者：
        toString in interface TabularData
        重载：
        toString in class Object
        返回：
        a string representation of this TabularDataSupport instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TabularType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.openmbean

类 TabularType

  • java.lang.Object
    • javax.management.openmbean.OpenType<TabularData>
      • javax.management.openmbean.TabularType
  • 所有已实现的接口：
    Serializable

    public class TabularType
extends OpenType<TabularData>
    The TabularType class is the open type class whose instances describe the types of TabularData values.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.openmbean.OpenType

        ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST

    • 构造方法摘要

      Constructors
      构造方法与描述
      TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
      Constructs a TabularType instance, checking for the validity of the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares the specified obj parameter with this TabularType instance for equality.
      List<String> getIndexNames()
      Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.
      CompositeType getRowType()
      Returns the type of the row elements of tabular data values described by this TabularType instance.
      int hashCode()
      Returns the hash code value for this TabularType instance.
      boolean isValue(Object obj)
      Tests whether obj is a value which could be described by this TabularType instance.
      String toString()
      Returns a string representation of this TabularType instance.

      • 方法 - 继承于类 javax.management.openmbean.OpenType

        getClassName, getDescription, getTypeName, isArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TabularType

        public TabularType(String typeName,
           String description,
           CompositeType rowType,
           String[] indexNames)
            throws OpenDataException
        Constructs a TabularType instance, checking for the validity of the given parameters. The validity constraints are described below for each parameter.

        The Java class name of tabular data values this tabular type represents (ie the class name returned by the getClassName method) is set to the string value returned by TabularData.class.getName().

        参数：
        typeName - The name given to the tabular type this instance represents; cannot be a null or empty string.
        描述 - The human readable description of the tabular type this instance represents; cannot be a null or empty string.
        rowType - The type of the row elements of tabular data values described by this tabular type instance; cannot be null.
        indexNames - The names of the items the values of which are used to uniquely index each row element in the tabular data values described by this tabular type instance; cannot be null or empty. Each element should be an item name defined in rowType (no null or empty string allowed). It is important to note that the order of the item names in indexNames is used by the methods get and remove of class TabularData to match their array of values parameter to items.
        抛出：
        IllegalArgumentException - if rowType is null, or indexNames is a null or empty array, or an element in indexNames is a null or empty string, or typeName or 描述 is a null or empty string.
        OpenDataException - if an element's value of indexNames is not an item name defined in rowType.

    • 方法详细信息

      • getRowType

        public CompositeType getRowType()
        Returns the type of the row elements of tabular data values described by this TabularType instance.
        返回：
        the type of each row.

      • getIndexNames

        public List<String> getIndexNames()

        Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.

        返回：
        a List of String representing the names of the index items.

      • isValue

        public boolean isValue(Object obj)
        Tests whether obj is a value which could be described by this TabularType instance.

        If obj is null or is not an instance of javax.management.openmbean.TabularData, isValue returns false.

        If obj is an instance of javax.management.openmbean.TabularData, say td, the result is true if this TabularType is assignable from td.getTabularType(), as defined in CompositeType.isValue.

        指定者：
        isValue in class OpenType<TabularData>
        参数：
        obj - the value whose open type is to be tested for compatibility with this TabularType instance.
        返回：
        true if obj is a value for this tabular type, false otherwise.

      • equals

        public boolean equals(Object obj)
        Compares the specified obj parameter with this TabularType instance for equality.

        Two TabularType instances are equal if and only if all of the following statements are true:

        • their type names are equal
        • their row types are equal
        • they use the same index names, in the same order

        指定者：
        equals in class OpenType<TabularData>
        参数：
        obj - the object to be compared for equality with this TabularType instance; if obj is null, equals returns false.
        返回：
        true if the specified object is equal to this TabularType instance.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this TabularType instance.

        The hash code of a TabularType instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: name, row type, index names). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularType instances t1 and t2, as required by the general contract of the method Object.hashCode().

        As TabularType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

        指定者：
        hashCode in class OpenType<TabularData>
        返回：
        the hash code value for this TabularType instance
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string representation of this TabularType instance.

        The string representation consists of the name of this class (ie javax.management.openmbean.TabularType), the type name for this instance, the row type string representation of this instance, and the index names of this instance.

        As TabularType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

        指定者：
        toString in class OpenType<TabularData>
        返回：
        a string representation of this TabularType instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ann>>t


Uses of Package javax.management.openmbean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.openmbean

  • Packages that use javax.management.openmbean
    软件包 描述
    java.lang.management
    Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.
  • Classes in javax.management.openmbean used by java.lang.management
    类与描述
    CompositeData
    The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
  • Classes in javax.management.openmbean used by javax.management.openmbean
    类与描述
    ArrayType
    The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
    CompositeData
    The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
    CompositeType
    The CompositeType class is the open type class whose instances describe the types of CompositeData values.
    OpenDataException
    This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.
    OpenMBeanAttributeInfo
    Describes an attribute of an open MBean.
    OpenMBeanConstructorInfo
    Describes a constructor of an Open MBean.
    OpenMBeanInfo
    Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.
    OpenMBeanOperationInfo
    Describes an operation of an Open MBean.
    OpenMBeanParameterInfo
    Describes a parameter used in one or more operations or constructors of an open MBean.
    OpenType
    The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.
    SimpleType
    The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values.
    TabularData
    The TabularData interface specifies the behavior of a specific type of complex open data objects which represent tabular data structures.
    TabularType
    The TabularType class is the open type class whose instances describe the types of TabularData values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lmipnInurcccnn""rsuIIreet


Uses of Class javax.management.openmbean.ArrayType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.ArrayType

  • Packages that use ArrayType
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of ArrayType in javax.management.openmbean

      Methods in javax.management.openmbean that return ArrayType
      修饰符与类型 方法与描述
      static <E> ArrayType<E[]> ArrayType.getArrayType(OpenType<E> elementType)
      Create an ArrayType instance in a type-safe manner.
      static <T> ArrayType<T> ArrayType.getPrimitiveArrayType(类<T> arrayClass)
      Create an ArrayType instance in a type-safe manner.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"thtri


Uses of Class javax.management.openmbean.CompositeDataInvocationHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.CompositeDataInvocationHandler

No usage of javax.management.openmbean.CompositeDataInvocationHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pcr o


Uses of Class javax.management.openmbean.CompositeDataSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.CompositeDataSupport

No usage of javax.management.openmbean.CompositeDataSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ac—间讳篇嗽冰籶Ｃ怂�


Uses of Class javax.management.openmbean.CompositeType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.CompositeType

  • Packages that use CompositeType
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of CompositeType in javax.management.openmbean

      Methods in javax.management.openmbean that return CompositeType
      修饰符与类型 方法与描述
      CompositeType CompositeDataSupport.getCompositeType()
      Returns the composite type of this composite data instance.
      CompositeType CompositeData.getCompositeType()
      Returns the composite type of this composite data instance.
      CompositeType TabularType.getRowType()
      Returns the type of the row elements of tabular data values described by this TabularType instance.
      Methods in javax.management.openmbean with parameters of type CompositeType
      修饰符与类型 方法与描述
      CompositeData CompositeDataView.toCompositeData(CompositeType ct)
      Return a CompositeData corresponding to the values in this object.
      Constructors in javax.management.openmbean with parameters of type CompositeType
      构造方法与描述
      CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
      CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
      TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
      Constructs a TabularType instance, checking for the validity of the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gl L/hen.dbixaraa


Uses of Class javax.management.openmbean.InvalidKeyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.InvalidKeyException

No usage of javax.management.openmbean.InvalidKeyException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mcpeentanggg/.ffl


Uses of Class javax.management.openmbean.InvalidOpenTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.InvalidOpenTypeException

No usage of javax.management.openmbean.InvalidOpenTypeException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a" AR)o lhd>pa&T ..l


Uses of Class javax.management.openmbean.KeyAlreadyExistsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.KeyAlreadyExistsException

No usage of javax.management.openmbean.KeyAlreadyExistsException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C)in=t坙(er>-��!


Uses of Class javax.management.openmbean.OpenDataException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenDataException

  • Packages that use OpenDataException
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenDataException in javax.management.openmbean

      Methods in javax.management.openmbean that throw OpenDataException
      修饰符与类型 方法与描述
      static <E> ArrayType<E[]> ArrayType.getArrayType(OpenType<E> elementType)
      Create an ArrayType instance in a type-safe manner.
      Constructors in javax.management.openmbean that throw OpenDataException
      构造方法与描述
      ArrayType(int dimension, OpenType<?> elementType)
      Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
      ArrayType(SimpleType<?> elementType, boolean primitiveArray)
      Constructs a unidimensional ArrayType instance for the supplied SimpleType.
      CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
      CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
      Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
      CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
      Constructs a CompositeType instance, checking for the validity of the given parameters.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述 and defaultValue, and the specified read/write access properties.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, defaultValue and legalValues, and the specified read/write access properties.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述 and defaultValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue and legalValues.
      OpenType(String className, String typeName, String description)
      Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters.
      TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
      Constructs a TabularType instance, checking for the validity of the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

IdoeltaEtymlnndits-jvt js


Uses of Class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenMBeanAttributeInfoSupport

No usage of javax.management.openmbean.OpenMBeanAttributeInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fDotMBeO>pppa.xxematBa


Uses of Class javax.management.openmbean.OpenMBeanConstructorInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenMBeanConstructorInfoSupport

No usage of javax.management.openmbean.OpenMBeanConstructorInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cso>mbeo.pppe.aax.jeen


Uses of Class javax.management.openmbean.OpenMBeanInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenMBeanInfoSupport

No usage of javax.management.openmbean.OpenMBeanInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=S=M BOTR S=<


Uses of Class javax.management.openmbean.OpenMBeanOperationInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenMBeanOperationInfoSupport

No usage of javax.management.openmbean.OpenMBeanOperationInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fDopMBeO>pppa.xxemaeBa


Uses of Class javax.management.openmbean.OpenMBeanParameterInfoSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenMBeanParameterInfoSupport

No usage of javax.management.openmbean.OpenMBeanParameterInfoSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aosn>


Uses of Class javax.management.openmbean.OpenType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.OpenType

  • Packages that use OpenType
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenType in javax.management.openmbean

      Subclasses of OpenType in javax.management.openmbean
      修饰符与类型 类与描述
      class  ArrayType<T>
      The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
      class  CompositeType
      The CompositeType class is the open type class whose instances describe the types of CompositeData values.
      class  SimpleType<T>
      The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values.
      class  TabularType
      The TabularType class is the open type class whose instances describe the types of TabularData values.
      Methods in javax.management.openmbean that return OpenType
      修饰符与类型 方法与描述
      OpenType<?> ArrayType.getElementOpenType()
      Returns the open type of element values contained in the arrays described by this ArrayType instance.
      OpenType<?> OpenMBeanParameterInfoSupport.getOpenType()
      Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.
      OpenType<?> OpenMBeanAttributeInfoSupport.getOpenType()
      Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.
      OpenType<?> OpenMBeanParameterInfo.getOpenType()
      Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.
      OpenType<?> OpenMBeanOperationInfo.getReturnOpenType()
      Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
      OpenType<?> OpenMBeanOperationInfoSupport.getReturnOpenType()
      Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
      OpenType<?> CompositeType.getType(String itemName)
      Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
      Methods in javax.management.openmbean with parameters of type OpenType
      修饰符与类型 方法与描述
      static <E> ArrayType<E[]> ArrayType.getArrayType(OpenType<E> elementType)
      Create an ArrayType instance in a type-safe manner.
      Constructors in javax.management.openmbean with parameters of type OpenType
      构造方法与描述
      ArrayType(int dimension, OpenType<?> elementType)
      Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
      CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
      Constructs a CompositeType instance, checking for the validity of the given parameters.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and 描述, and the specified read/write access properties.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, read/write access properties, and Descriptor.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述 and defaultValue, and the specified read/write access properties.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, 描述, defaultValue and legalValues, and the specified read/write access properties.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType and impact.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType, impact, and descriptor.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and 描述.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, and descriptor.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述 and defaultValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue, minValue and maxValue.
      OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
      Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, 描述, defaultValue and legalValues.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.openmbean.SimpleType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.SimpleType

  • Packages that use SimpleType
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of SimpleType in javax.management.openmbean

      Fields in javax.management.openmbean declared as SimpleType
      修饰符与类型 字段与描述
      static SimpleType<BigDecimal> SimpleType.BIGDECIMAL
      The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
      static SimpleType<BigInteger> SimpleType.BIGINTEGER
      The SimpleType instance describing values whose Java class name is java.math.BigInteger.
      static SimpleType<Boolean> SimpleType.BOOLEAN
      The SimpleType instance describing values whose Java class name is java.lang.Boolean.
      static SimpleType<Byte> SimpleType.BYTE
      The SimpleType instance describing values whose Java class name is java.lang.Byte.
      static SimpleType<Character> SimpleType.CHARACTER
      The SimpleType instance describing values whose Java class name is java.lang.Character.
      static SimpleType<Date> SimpleType.DATE
      The SimpleType instance describing values whose Java class name is java.util.Date.
      static SimpleType<Double> SimpleType.DOUBLE
      The SimpleType instance describing values whose Java class name is java.lang.Double.
      static SimpleType<Float> SimpleType.FLOAT
      The SimpleType instance describing values whose Java class name is java.lang.Float.
      static SimpleType<Integer> SimpleType.INTEGER
      The SimpleType instance describing values whose Java class name is java.lang.Integer.
      static SimpleType<Long> SimpleType.LONG
      The SimpleType instance describing values whose Java class name is java.lang.Long.
      static SimpleType<ObjectName> SimpleType.OBJECTNAME
      The SimpleType instance describing values whose Java class name is javax.management.ObjectName.
      static SimpleType<Short> SimpleType.SHORT
      The SimpleType instance describing values whose Java class name is java.lang.Short.
      static SimpleType<String> SimpleType.STRING
      The SimpleType instance describing values whose Java class name is java.lang.String.
      static SimpleType<Void> SimpleType.VOID
      The SimpleType instance describing values whose Java class name is java.lang.Void.
      Constructors in javax.management.openmbean with parameters of type SimpleType
      构造方法与描述
      ArrayType(SimpleType<?> elementType, boolean primitiveArray)
      Constructs a unidimensional ArrayType instance for the supplied SimpleType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


Uses of Class javax.management.openmbean.TabularDataSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.TabularDataSupport

No usage of javax.management.openmbean.TabularDataSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.management.openmbean.TabularType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.openmbean.TabularType

  • Packages that use TabularType
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of TabularType in javax.management.openmbean

      Methods in javax.management.openmbean that return TabularType
      修饰符与类型 方法与描述
      TabularType TabularDataSupport.getTabularType()
      Returns the tabular type describing this TabularData instance.
      TabularType TabularData.getTabularType()
      Returns the tabular type describing this TabularData instance.
      Constructors in javax.management.openmbean with parameters of type TabularType
      构造方法与描述
      TabularDataSupport(TabularType tabularType)
      Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).
      TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
      Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v>a.tooci.tada..eec�


Uses of Interface javax.management.openmbean.CompositeData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.CompositeData

  • Packages that use CompositeData
    软件包 描述
    java.lang.management
    Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of CompositeData in java.lang.management

      Methods in java.lang.management with parameters of type CompositeData
      修饰符与类型 方法与描述
      static MemoryNotificationInfo MemoryNotificationInfo.from(CompositeData cd)
      Returns a MemoryNotificationInfo object represented by the given CompositeData.
      static MonitorInfo MonitorInfo.from(CompositeData cd)
      Returns a MonitorInfo object represented by the given CompositeData.
      static ThreadInfo ThreadInfo.from(CompositeData cd)
      Returns a ThreadInfo object represented by the given CompositeData.
      static MemoryUsage MemoryUsage.from(CompositeData cd)
      Returns a MemoryUsage object represented by the given CompositeData.

    • Uses of CompositeData in javax.management.openmbean

      Classes in javax.management.openmbean that implement CompositeData
      修饰符与类型 类与描述
      class  CompositeDataSupport
      The CompositeDataSupport class is the open data class which implements the CompositeData interface.
      Methods in javax.management.openmbean that return CompositeData
      修饰符与类型 方法与描述
      CompositeData TabularDataSupport.get(Object[] key)
      Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
      CompositeData TabularData.get(Object[] key)
      Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
      CompositeData CompositeDataInvocationHandler.getCompositeData()
      Return the CompositeData that was supplied to the constructor.
      CompositeData TabularDataSupport.remove(Object[] key)
      Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
      CompositeData TabularData.remove(Object[] key)
      Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
      CompositeData CompositeDataView.toCompositeData(CompositeType ct)
      Return a CompositeData corresponding to the values in this object.
      Methods in javax.management.openmbean with parameters of type CompositeData
      修饰符与类型 | 方法与描述
      Object[] TabularDataSupport.calculateIndex(CompositeData value)
      Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
      Object[] TabularData.calculateIndex(CompositeData value)
      Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
      boolean TabularDataSupport.containsValue(CompositeData value)
      Returns true if and only if this TabularData instance contains the specified CompositeData value.
      boolean TabularData.containsValue(CompositeData value)
      Returns true if and only if this TabularData instance contains the specified CompositeData value.
      void | TabularDataSupport.put(CompositeData value)
      void TabularData.put(CompositeData value)
      Adds value to this TabularData instance.
      void TabularDataSupport.putAll(CompositeData[] values)
      Add all the elements in values to this TabularData instance.
      void TabularData.putAll(CompositeData[] values)
      Add all the elements in values to this TabularData instance.
      Constructors in javax.management.openmbean with parameters of type CompositeData
      构造方法与描述
      CompositeDataInvocationHandler(CompositeData compositeData)
      Construct a handler backed by the given CompositeData.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aaalt"mleinbn;m I d/sy<


Uses of Interface javax.management.openmbean.CompositeDataView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.CompositeDataView

No usage of javax.management.openmbean.CompositeDataView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.management.openmbean.OpenMBeanAttributeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.OpenMBeanAttributeInfo

  • Packages that use OpenMBeanAttributeInfo
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenMBeanAttributeInfo in javax.management.openmbean

      Classes in javax.management.openmbean that implement OpenMBeanAttributeInfo
      修饰符与类型 类与描述
      class  OpenMBeanAttributeInfoSupport
      Describes an attribute of an open MBean.
      Constructors in javax.management.openmbean with parameters of type OpenMBeanAttributeInfo
      构造方法与描述
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations and notifications.
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bps TT=nasiaoie"e


Uses of Interface javax.management.openmbean.OpenMBeanConstructorInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.OpenMBeanConstructorInfo

  • Packages that use OpenMBeanConstructorInfo
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenMBeanConstructorInfo in javax.management.openmbean

      Classes in javax.management.openmbean that implement OpenMBeanConstructorInfo
      修饰符与类型 类与描述
      class  OpenMBeanConstructorInfoSupport
      Describes a constructor of an Open MBean.
      Constructors in javax.management.openmbean with parameters of type OpenMBeanConstructorInfo
      构造方法与描述
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations and notifications.
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

seaa /< o hdjoe>taeTnapo


Uses of Interface javax.management.openmbean.OpenMBeanInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.OpenMBeanInfo

  • Packages that use OpenMBeanInfo
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenMBeanInfo in javax.management.openmbean

      Classes in javax.management.openmbean that implement OpenMBeanInfo
      修饰符与类型 类与描述
      class  OpenMBeanInfoSupport
      The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x".EpfvlOyerd"n�,gam.e/ .


Uses of Interface javax.management.openmbean.OpenMBeanOperationInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.OpenMBeanOperationInfo

  • Packages that use OpenMBeanOperationInfo
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenMBeanOperationInfo in javax.management.openmbean

      Classes in javax.management.openmbean that implement OpenMBeanOperationInfo
      修饰符与类型 类与描述
      class  OpenMBeanOperationInfoSupport
      Describes an operation of an Open MBean.
      Constructors in javax.management.openmbean with parameters of type OpenMBeanOperationInfo
      构造方法与描述
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations and notifications.
      OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
      Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, 描述, openAttributes, openConstructors , openOperations, notifications, and descriptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3ecooassn m/y/paetl"b


Uses of Interface javax.management.openmbean.OpenMBeanParameterInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.OpenMBeanParameterInfo

  • Packages that use OpenMBeanParameterInfo
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of OpenMBeanParameterInfo in javax.management.openmbean

      Subinterfaces of OpenMBeanParameterInfo in javax.management.openmbean
      修饰符与类型 Interface and Description
      interface  OpenMBeanAttributeInfo
      Describes an attribute of an open MBean.
      Classes in javax.management.openmbean that implement OpenMBeanParameterInfo
      修饰符与类型 类与描述
      class  OpenMBeanAttributeInfoSupport
      Describes an attribute of an open MBean.
      class  OpenMBeanParameterInfoSupport
      Describes a parameter used in one or more operations or constructors of an open MBean.
      Constructors in javax.management.openmbean with parameters of type OpenMBeanParameterInfo
      构造方法与描述
      OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
      Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述 and signature.
      OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
      Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, 描述, signature, and descriptor.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType and impact.
      OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
      Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, 描述, signature, returnOpenType, impact, and descriptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oeempl.e"v籩ctA p&


Uses of Interface javax.management.openmbean.TabularData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.openmbean.TabularData

  • Packages that use TabularData
    软件包 描述
    javax.management.openmbean
    Provides the open data types and Open MBean descriptor classes.

    • Uses of TabularData in javax.management.openmbean

      Classes in javax.management.openmbean that implement TabularData
      修饰符与类型 类与描述
      class  TabularDataSupport
      The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

loases v aaai ddR


InvalidRelationIdException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 InvalidRelationIdException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
  • 所有已实现的接口：
    Serializable

    public class InvalidRelationIdException
extends RelationException
    This exception is raised when relation id provided for a relation is already used.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidRelationIdException()
      Default constructor, no message put in exception.
      InvalidRelationIdException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidRelationIdException

        public InvalidRelationIdException()
        Default constructor, no message put in exception.

      • InvalidRelationIdException

        public InvalidRelationIdException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atl>< . _f oj>e


InvalidRelationServiceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 InvalidRelationServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationServiceException
  • 所有已实现的接口：
    Serializable

    public class InvalidRelationServiceException
extends RelationException
    This exception is raised when an invalid Relation Service is provided.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidRelationServiceException()
      Default constructor, no message put in exception.
      InvalidRelationServiceException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidRelationServiceException

        public InvalidRelationServiceException()
        Default constructor, no message put in exception.

      • InvalidRelationServiceException

        public InvalidRelationServiceException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rbve"/aluC>ptn>>ln/


InvalidRelationTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 InvalidRelationTypeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationTypeException
  • 所有已实现的接口：
    Serializable

    public class InvalidRelationTypeException
extends RelationException
    Invalid relation type. This exception is raised when, in a relation type, there is already a relation type with that name, or the same name has been used for two different role infos, or no role info provided, or one null role info provided.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidRelationTypeException()
      Default constructor, no message put in exception.
      InvalidRelationTypeException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidRelationTypeException

        public InvalidRelationTypeException()
        Default constructor, no message put in exception.

      • InvalidRelationTypeException

        public InvalidRelationTypeException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r>tset a ra n( d alsip


InvalidRoleInfoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 InvalidRoleInfoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRoleInfoException
  • 所有已实现的接口：
    Serializable

    public class InvalidRoleInfoException
extends RelationException
    This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidRoleInfoException()
      Default constructor, no message put in exception.
      InvalidRoleInfoException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidRoleInfoException

        public InvalidRoleInfoException()
        Default constructor, no message put in exception.

      • InvalidRoleInfoException

        public InvalidRoleInfoException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t ennnfn no f tmwre/个试、⒁鲆缅丁庚�.


InvalidRoleValueException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 InvalidRoleValueException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRoleValueException
  • 所有已实现的接口：
    Serializable

    public class InvalidRoleValueException
extends RelationException
    Role value is invalid. This exception is raised when, in a role, the number of referenced MBeans in given value is less than expected minimum degree, or the number of referenced MBeans in provided value exceeds expected maximum degree, or one referenced MBean in the value is not an Object of the MBean class expected for that role, or an MBean provided for that role does not exist.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidRoleValueException()
      Default constructor, no message put in exception.
      InvalidRoleValueException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidRoleValueException

        public InvalidRoleValueException()
        Default constructor, no message put in exception.

      • InvalidRoleValueException

        public InvalidRoleValueException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stttteb>trtd"smo>;.s.t


javax.management.relation

Interfaces

  • Relation
  • RelationServiceMBean
  • RelationSupportMBean
  • RelationType

Classes

  • MBeanServerNotificationFilter
  • RelationNotification
  • RelationService
  • RelationSupport
  • RelationTypeSupport
  • Role
  • RoleInfo
  • RoleList
  • RoleResult
  • RoleStatus
  • RoleUnresolved
  • RoleUnresolvedList

Exceptions

  • InvalidRelationIdException
  • InvalidRelationServiceException
  • InvalidRelationTypeException
  • InvalidRoleInfoException
  • InvalidRoleValueException
  • RelationException
  • RelationNotFoundException
  • RelationServiceNotRegisteredException
  • RelationTypeNotFoundException
  • RoleInfoNotFoundException
  • RoleNotFoundException
n


javax.management.relation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.relation

Provides the definition of the Relation Service.

请参见： 描述

  • 接口摘要
    接口 描述
    Relation
    This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.
    RelationServiceMBean
    The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
    RelationSupportMBean
    A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
    RelationType
    The RelationType interface has to be implemented by any class expected to represent a relation type.
  • Class Summary
    类 描述
    MBeanServerNotificationFilter
    Filter for MBeanServerNotification.
    RelationNotification
    A notification of a change in the Relation Service.
    RelationService
    The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
    RelationSupport
    A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
    RelationTypeSupport
    A RelationTypeSupport object implements the RelationType interface.
    Role
    Represents a role: includes a role name and referenced MBeans (via their ObjectNames).
    RoleInfo
    A RoleInfo object summarises a role in a relation type.
    RoleList
    A RoleList represents a list of roles (Role objects).
    RoleResult
    Represents the result of a multiple access to several roles of a relation (either for reading or writing).
    RoleStatus
    This class describes the various problems which can be encountered when accessing a role.
    RoleUnresolved
    Represents an unresolved role: a role not retrieved from a relation due to a problem.
    RoleUnresolvedList
    A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write) the roles.
  • Exception Summary
    Exception 描述
    InvalidRelationIdException
    This exception is raised when relation id provided for a relation is already used.
    InvalidRelationServiceException
    This exception is raised when an invalid Relation Service is provided.
    InvalidRelationTypeException
    Invalid relation type.
    InvalidRoleInfoException
    This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
    InvalidRoleValueException
    Role value is invalid.
    RelationException
    This class is the superclass of any exception which can be raised during relation management.
    RelationNotFoundException
    This exception is raised when there is no relation for a given relation id in a Relation Service.
    RelationServiceNotRegisteredException
    This exception is raised when an access is done to the Relation Service and that one is not registered.
    RelationTypeNotFoundException
    This exception is raised when there is no relation type with given name in Relation Service.
    RoleInfoNotFoundException
    This exception is raised when there is no role info with given name in a given relation type.
    RoleNotFoundException
    This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.

软件包 javax.management.relation Description

Provides the definition of the Relation Service. The Relation Service is used to record relationships between MBeans in an MBean Server. The Relation Service is itself an MBean. More than one instance of a RelationService MBean can be registered in an MBean Server.

A relation type defines a relationship between MBeans. It contains roles that the MBeans play in the relationship. Usually there are at least two roles in a relation type.

A relation is a named instance of a relation type, where specific MBeans appear in the roles, represented by their ObjectNames.

For example, suppose there are Module MBeans, representing modules within an application. A DependsOn relation type could express the relationship that some modules depend on others, which could be used to determine the order in which the modules are started or stopped. The DependsOn relation type would have two roles, dependent and dependedOn.

Every role is typed, meaning that an MBean that appears in that role must be an instance of the role's type. In the DependsOn example, both roles would be of type Module.

Every role has a cardinality, which provides lower and upper bounds on the number of MBeans that can appear in that role in a given relation instance. Usually, the lower and upper bounds are both 1, with exactly one MBean appearing in the role. The cardinality only limits the number of MBeans in the role per relation instance. The same MBean can appear in the same role in any number of instances of a relation type. In the DependsOn example, a given module can depend on many other modules, and be depended on by many others, but any given relation instance links exactly one dependent module with exactly one dependedOn module.

A relation type can be created explicitly, as an object implementing the RelationType interface, typically a RelationTypeSupport. Alternatively, it can be created implicitly using the Relation Service's createRelationType method.

A relation instance can be created explicitly, as an object implementing the Relation interface, typically a RelationSupport. (A RelationSupport is itself a valid MBean, so it can be registered in the MBean Server, though this is not required.) Alternatively, a relation instance can be created implicitly using the Relation Service's createRelation method.

The DependsOn example might be coded as follows.

import java.util.*;
import javax.management.*;
import javax.management.relation.*;

// ...
MBeanServer mbs = ...;

// Create the Relation Service MBean
ObjectName relSvcName = new ObjectName(":type=RelationService");
RelationService relSvcObject = new RelationService(true);
mbs.registerMBean(relSvcObject, relSvcName);

// Create an MBean proxy for easier access to the Relation Service
RelationServiceMBean relSvc =
    MBeanServerInvocationHandler.newProxyInstance(mbs, relSvcName,
                                                  RelationServiceMBean.class,
                                                  false);

// Define the DependsOn relation type
RoleInfo[] dependsOnRoles = {
    new RoleInfo("dependent", Module.class.getName()),
    new RoleInfo("dependedOn", Module.class.getName())
};
relSvc.createRelationType("DependsOn", dependsOnRoles);

// Now define a relation instance "moduleA DependsOn moduleB"

ObjectName moduleA = new ObjectName(":type=Module,name=A");
ObjectName moduleB = new ObjectName(":type=Module,name=B");

Role dependent = new Role("dependent", Collections.singletonList(moduleA));
Role dependedOn = new Role("dependedOn", Collections.singletonList(moduleB));
Role[] roleArray = {dependent, dependedOn};
RoleList roles = new RoleList(Arrays.asList(roleArray));
relSvc.createRelation("A-DependsOn-B", "DependsOn", roles);

// Query the Relation Service to find what modules moduleA depends on
Map<ObjectName,List<String>> dependentAMap =
    relSvc.findAssociatedMBeans(moduleA, "DependsOn", "dependent");
Set<ObjectName> dependentASet = dependentAMap.keySet();
// Set of ObjectName containing moduleB
从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology, in particular the JMX Specification, version 1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

td.i>>toac


javax.management.relation Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.relation

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.relation.RoleList
          • javax.management.relation.RoleUnresolvedList
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.relation.RelationNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
      • javax.management.relation.MBeanServerNotificationFilter
    • javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • javax.management.relation.Role (implements java.io.Serializable)
    • javax.management.relation.RoleInfo (implements java.io.Serializable)
    • javax.management.relation.RoleResult (implements java.io.Serializable)
    • javax.management.relation.RoleStatus
    • javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
            • javax.management.relation.InvalidRelationServiceException
            • javax.management.relation.InvalidRelationTypeException
            • javax.management.relation.InvalidRoleInfoException
            • javax.management.relation.InvalidRoleValueException
            • javax.management.relation.RelationNotFoundException
            • javax.management.relation.RelationServiceNotRegisteredException
            • javax.management.relation.RelationTypeNotFoundException
            • javax.management.relation.RoleInfoNotFoundException
            • javax.management.relation.RoleNotFoundException

Interface Hierarchy

  • javax.management.relation.Relation
    • javax.management.relation.RelationSupportMBean
  • javax.management.relation.RelationServiceMBean
  • java.io.Serializable
    • javax.management.relation.RelationType
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ft nefmubbbyl i i..Bm


MBeanServerNotificationFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 MBeanServerNotificationFilter

  • java.lang.Object
    • javax.management.NotificationFilterSupport
      • javax.management.relation.MBeanServerNotificationFilter
  • 所有已实现的接口：
    Serializable, NotificationFilter

    public class MBeanServerNotificationFilter
extends NotificationFilterSupport
    Filter for MBeanServerNotification. This filter filters MBeanServerNotification notifications by selecting the ObjectNames of interest and the operations (registration, unregistration, both) of interest (corresponding to notification types).

    The serialVersionUID of this class is 2605900539589789736L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MBeanServerNotificationFilter()
      Creates a filter selecting all MBeanServerNotification notifications for all ObjectNames.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void disableAllObjectNames()
      Disables any MBeanServerNotification (all ObjectNames are deselected).
      void disableObjectName(ObjectName objectName)
      Disables MBeanServerNotifications concerning given ObjectName.
      void enableAllObjectNames()
      Enables all MBeanServerNotifications (all ObjectNames are selected).
      void enableObjectName(ObjectName objectName)
      Enables MBeanServerNotifications concerning given ObjectName.
      Vector<ObjectName> getDisabledObjectNames()
      Gets all the ObjectNames disabled.
      Vector<ObjectName> getEnabledObjectNames()
      Gets all the ObjectNames enabled.
      boolean isNotificationEnabled(Notification notif)
      Invoked before sending the specified notification to the listener.

      • 方法 - 继承于类 javax.management.NotificationFilterSupport

        disableAllTypes, disableType, enableType, getEnabledTypes

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MBeanServerNotificationFilter

        public MBeanServerNotificationFilter()
        Creates a filter selecting all MBeanServerNotification notifications for all ObjectNames.

    • 方法详细信息

      • disableAllObjectNames

        public void disableAllObjectNames()
        Disables any MBeanServerNotification (all ObjectNames are deselected).

      • disableObjectName

        public void disableObjectName(ObjectName objectName)
                       throws IllegalArgumentException
        Disables MBeanServerNotifications concerning given ObjectName.
        参数：
        objectName - ObjectName no longer of interest
        抛出：
        IllegalArgumentException - if the given ObjectName is null

      • enableAllObjectNames

        public void enableAllObjectNames()
        Enables all MBeanServerNotifications (all ObjectNames are selected).

      • enableObjectName

        public void enableObjectName(ObjectName objectName)
                      throws IllegalArgumentException
        Enables MBeanServerNotifications concerning given ObjectName.
        参数：
        objectName - ObjectName of interest
        抛出：
        IllegalArgumentException - if the given ObjectName is null

      • getEnabledObjectNames

        public Vector<ObjectName> getEnabledObjectNames()
        Gets all the ObjectNames enabled.
        返回：
        Vector of ObjectNames:

        - null means all ObjectNames are implicitly selected, except the ObjectNames explicitly deselected

        - empty means all ObjectNames are deselected, i.e. no ObjectName selected.

      • getDisabledObjectNames

        public Vector<ObjectName> getDisabledObjectNames()
        Gets all the ObjectNames disabled.
        返回：
        Vector of ObjectNames:

        - null means all ObjectNames are implicitly deselected, except the ObjectNames explicitly selected

        - empty means all ObjectNames are selected, i.e. no ObjectName deselected.

      • isNotificationEnabled

        public boolean isNotificationEnabled(Notification notif)
                              throws IllegalArgumentException
        Invoked before sending the specified notification to the listener.

        If:

        - the ObjectName of the concerned MBean is selected (explicitly OR (implicitly and not explicitly deselected))

        AND

        - the type of the operation (registration or unregistration) is selected

        then the notification is sent to the listener.

        指定者：
        isNotificationEnabled in interface NotificationFilter
        重载：
        isNotificationEnabled in class NotificationFilterSupport
        参数：
        notif - The notification to be sent.
        返回：
        true if the notification has to be sent to the listener, false otherwise.
        抛出：
        IllegalArgumentException - if null parameter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vre.e//f< eol cftir.n=edre1>di/eaa


Relation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.relation

Interface Relation

  • All Known Subinterfaces:
    RelationSupportMBean
    All Known Implementing Classes:
    RelationSupport

    public interface Relation
    This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.

    Simple relations, i.e. having only roles, no properties or methods, can be created directly by the Relation Service (represented as RelationSupport objects, internally handled by the Relation Service).

    If the user wants to represent more complex relations, involving properties and/or methods, he has to provide his own class implementing the Relation interface. This can be achieved either by inheriting from RelationSupport class, or by implementing the interface (fully or delegation to a RelationSupport object member).

    Specifying such user relation class is to introduce properties and/or methods. Those have to be exposed for remote management. So this means that any user relation class must be a MBean class.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      RoleResult getAllRoles()
      Returns all roles present in the relation.
      Map<ObjectName,List<String>> getReferencedMBeans()
      Retrieves MBeans referenced in the various roles of the relation.
      String getRelationId()
      Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
      ObjectName getRelationServiceName()
      Returns ObjectName of the Relation Service handling the relation.
      String getRelationTypeName()
      Returns name of associated relation type.
      List<ObjectName> getRole(String roleName)
      Retrieves role value for given role name.
      Integer getRoleCardinality(String roleName)
      Returns the number of MBeans currently referenced in the given role.
      RoleResult getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      void handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      RoleList retrieveAllRoles()
      Returns all roles in the relation without checking read mode.
      void setRole(Role role)
      Sets the given role.
      RoleResult setRoles(RoleList roleList)
      Sets the given roles.

    • 方法详细信息

      • getRole

        List<ObjectName> getRole(String roleName)
                         throws IllegalArgumentException,
                                RoleNotFoundException,
                                RelationServiceNotRegisteredException
        Retrieves role value for given role name.

        Checks if the role exists and is readable according to the relation type.

        参数：
        roleName - name of role
        返回：
        the ArrayList of ObjectName objects being the role value
        抛出：
        IllegalArgumentException - if null role name
        RoleNotFoundException - if:

        - there is no role with given name

        - the role is not readable.

        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        另请参见：
        setRole(javax.management.relation.Role)

      • getRoles

        RoleResult getRoles(String[] roleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
        Retrieves values of roles with given names.

        Checks for each role if it exists and is readable according to the relation type.

        参数：
        roleNameArray - array of names of roles to be retrieved
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
        抛出：
        IllegalArgumentException - if null role name
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        另请参见：
        setRoles(javax.management.relation.RoleList)

      • getRoleCardinality

        Integer getRoleCardinality(String roleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
        Returns the number of MBeans currently referenced in the given role.
        参数：
        roleName - name of role
        返回：
        the number of currently referenced MBeans in that role
        抛出：
        IllegalArgumentException - if null role name
        RoleNotFoundException - if there is no role with given name

      • getAllRoles

        RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
        Returns all roles present in the relation.
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not readable).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

      • retrieveAllRoles

        RoleList retrieveAllRoles()
        Returns all roles in the relation without checking read mode.
        返回：
        a RoleList.

      • setRole

        void setRole(Role role)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
        Sets the given role.

        Will check the role according to its corresponding role definition provided in relation's relation type

        Will send a notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not).

        参数：
        role - role to be set (name and new value)
        抛出：
        IllegalArgumentException - if null role
        RoleNotFoundException - if there is no role with the supplied role's name or if the role is not writable (no test on the write access mode performed when initializing the role)
        InvalidRoleValueException - if value provided for role is not valid, i.e.:

        - the number of referenced MBeans in given value is less than expected minimum degree

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - a MBean provided for that role does not exist.

        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
        RelationNotFoundException - if the relation has not been added in the Relation Service.
        另请参见：
        getRole(java.lang.String)

      • setRoles

        RoleResult setRoles(RoleList roleList)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
        Sets the given roles.

        Will check the role according to its corresponding role definition provided in relation's relation type

        Will send one notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not) per updated role.

        参数：
        roleList - list of roles to be set
        返回：
        a RoleResult object, including a RoleList (for roles successfully set) and a RoleUnresolvedList (for roles not set).
        抛出：
        IllegalArgumentException - if null role list
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
        RelationNotFoundException - if the relation MBean has not been added in the Relation Service.
        另请参见：
        getRoles(java.lang.String[])

      • handleMBeanUnregistration

        void handleMBeanUnregistration(ObjectName objectName,
                             String roleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
        Callback used by the Relation Service when a MBean referenced in a role is unregistered.

        The Relation Service will call this method to let the relation take action to reflect the impact of such unregistration.

        BEWARE. the user is not expected to call this method.

        Current implementation is to set the role with its current value (list of ObjectNames of referenced MBeans) without the unregistered one.

        参数：
        objectName - ObjectName of unregistered MBean
        roleName - name of role where the MBean is referenced
        抛出：
        IllegalArgumentException - if null parameter
        RoleNotFoundException - if role does not exist in the relation or is not writable
        InvalidRoleValueException - if role value does not conform to the associated role info (this will never happen when called from the Relation Service)
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
        RelationNotFoundException - if this method is called for a relation MBean not added in the Relation Service.

      • getReferencedMBeans

        Map<ObjectName,List<String>> getReferencedMBeans()
        Retrieves MBeans referenced in the various roles of the relation.
        返回：
        a HashMap mapping:

        ObjectName -> ArrayList of String (role names)

      • getRelationTypeName

        String getRelationTypeName()
        Returns name of associated relation type.
        返回：
        the name of the relation type.

      • getRelationServiceName

        ObjectName getRelationServiceName()
        Returns ObjectName of the Relation Service handling the relation.
        返回：
        the ObjectName of the Relation Service.

      • getRelationId

        String getRelationId()
        Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
        返回：
        the relation id.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


RelationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RelationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    InvalidRelationIdException, InvalidRelationServiceException, InvalidRelationTypeException, InvalidRoleInfoException, InvalidRoleValueException, RelationNotFoundException, RelationServiceNotRegisteredException, RelationTypeNotFoundException, RoleInfoNotFoundException, RoleNotFoundException

    public class RelationException
extends JMException
    This class is the superclass of any exception which can be raised during relation management.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationException()
      Default constructor, no message put in exception.
      RelationException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RelationException

        public RelationException()
        Default constructor, no message put in exception.

      • RelationException

        public RelationException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

reeaaalvaloeeloo#illsl>tee"nspl>lS�


RelationNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RelationNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.RelationNotFoundException
  • 所有已实现的接口：
    Serializable

    public class RelationNotFoundException
extends RelationException
    This exception is raised when there is no relation for a given relation id in a Relation Service.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationNotFoundException()
      Default constructor, no message put in exception.
      RelationNotFoundException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RelationNotFoundException

        public RelationNotFoundException()
        Default constructor, no message put in exception.

      • RelationNotFoundException

        public RelationNotFoundException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yt:S S"SrS>maryna


RelationNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RelationNotification

  • java.lang.Object
    • java.util.EventObject
      • javax.management.Notification
        • javax.management.relation.RelationNotification
  • 所有已实现的接口：
    Serializable

    public class RelationNotification
extends Notification
    A notification of a change in the Relation Service. A RelationNotification notification is sent when a relation is created via the Relation Service, or an MBean is added as a relation in the Relation Service, or a role is updated in a relation, or a relation is removed from the Relation Service.

    The serialVersionUID of this class is -6871117877523310399L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String RELATION_BASIC_CREATION
      Type for the creation of an internal relation.
      static String RELATION_BASIC_REMOVAL
      Type for the removal from the Relation Service of an internal relation.
      static String RELATION_BASIC_UPDATE
      Type for an update of an internal relation.
      static String RELATION_MBEAN_CREATION
      Type for the relation MBean added into the Relation Service.
      static String RELATION_MBEAN_REMOVAL
      Type for the removal from the Relation Service of a relation MBean.
      static String RELATION_MBEAN_UPDATE
      Type for the update of a relation MBean.

      • Fields inherited from class javax.management.Notification

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
      Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
      RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
      Creates a notification for a role update in a relation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List<ObjectName> getMBeansToUnregister()
      Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).
      List<ObjectName> getNewRoleValue()
      Returns new value of updated role (only for role update).
      ObjectName getObjectName()
      Returns the ObjectName of the created/removed/updated relation.
      List<ObjectName> getOldRoleValue()
      Returns old value of updated role (only for role update).
      String getRelationId()
      Returns the relation identifier of created/removed/updated relation.
      String getRelationTypeName()
      Returns the relation type name of created/removed/updated relation.
      String getRoleName()
      Returns name of updated role of updated relation (only for role update).

      • 方法 - 继承于类 javax.management.Notification

        getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • RELATION_BASIC_CREATION

        public static final String RELATION_BASIC_CREATION
        Type for the creation of an internal relation.
        另请参见：
        Constant Field Values

      • RELATION_MBEAN_CREATION

        public static final String RELATION_MBEAN_CREATION
        Type for the relation MBean added into the Relation Service.
        另请参见：
        Constant Field Values

      • RELATION_BASIC_UPDATE

        public static final String RELATION_BASIC_UPDATE
        Type for an update of an internal relation.
        另请参见：
        Constant Field Values

      • RELATION_MBEAN_UPDATE

        public static final String RELATION_MBEAN_UPDATE
        Type for the update of a relation MBean.
        另请参见：
        Constant Field Values

      • RELATION_BASIC_REMOVAL

        public static final String RELATION_BASIC_REMOVAL
        Type for the removal from the Relation Service of an internal relation.
        另请参见：
        Constant Field Values

      • RELATION_MBEAN_REMOVAL

        public static final String RELATION_MBEAN_REMOVAL
        Type for the removal from the Relation Service of a relation MBean.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • RelationNotification

        public RelationNotification(String notifType,
                    Object sourceObj,
                    long sequence,
                    long timeStamp,
                    String message,
                    String id,
                    String typeName,
                    ObjectName objectName,
                    List<ObjectName> unregMBeanList)
                     throws IllegalArgumentException
        Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
        参数：
        notifType - type of the notification; either:

        - RELATION_BASIC_CREATION

        - RELATION_MBEAN_CREATION

        - RELATION_BASIC_REMOVAL

        - RELATION_MBEAN_REMOVAL

        sourceObj - source object, sending the notification. This is either an ObjectName or a RelationService object. In the latter case it must be the MBean emitting the notification; the MBean Server will rewrite the source to be the ObjectName under which that MBean is registered.
        sequence - sequence number to identify the notification
        timeStamp - time stamp
        message - human-readable message describing the notification
        id - relation id identifying the relation in the Relation Service
        typeName - name of the relation type
        objectName - ObjectName of the relation object if it is an MBean (null for relations internally handled by the Relation Service)
        unregMBeanList - list of ObjectNames of referenced MBeans expected to be unregistered due to relation removal (only for removal, due to CIM qualifiers, can be null)
        抛出：
        IllegalArgumentException - if:

        - no value for the notification type

        - the notification type is not RELATION_BASIC_CREATION, RELATION_MBEAN_CREATION, RELATION_BASIC_REMOVAL or RELATION_MBEAN_REMOVAL

        - no source object

        - the source object is not a Relation Service

        - no relation id

        - no relation type name

      • RelationNotification

        public RelationNotification(String notifType,
                    Object sourceObj,
                    long sequence,
                    long timeStamp,
                    String message,
                    String id,
                    String typeName,
                    ObjectName objectName,
                    String name,
                    List<ObjectName> newValue,
                    List<ObjectName> oldValue)
                     throws IllegalArgumentException
        Creates a notification for a role update in a relation.
        参数：
        notifType - type of the notification; either:

        - RELATION_BASIC_UPDATE

        - RELATION_MBEAN_UPDATE

        sourceObj - source object, sending the notification. This is either an ObjectName or a RelationService object. In the latter case it must be the MBean emitting the notification; the MBean Server will rewrite the source to be the ObjectName under which that MBean is registered.
        sequence - sequence number to identify the notification
        timeStamp - time stamp
        message - human-readable message describing the notification
        id - relation id identifying the relation in the Relation Service
        typeName - name of the relation type
        objectName - ObjectName of the relation object if it is an MBean (null for relations internally handled by the Relation Service)
        name - name of the updated role
        newValue - new role value (List of ObjectName objects)
        oldValue - old role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter

    • 方法详细信息

      • getRelationId

        public String getRelationId()
        Returns the relation identifier of created/removed/updated relation.
        返回：
        the relation id.

      • getRelationTypeName

        public String getRelationTypeName()
        Returns the relation type name of created/removed/updated relation.
        返回：
        the relation type name.

      • getObjectName

        public ObjectName getObjectName()
        Returns the ObjectName of the created/removed/updated relation.
        返回：
        the ObjectName if the relation is an MBean, otherwise null.

      • getMBeansToUnregister

        public List<ObjectName> getMBeansToUnregister()
        Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).
        返回：
        a List of ObjectName.

      • getRoleName

        public String getRoleName()
        Returns name of updated role of updated relation (only for role update).
        返回：
        the name of the updated role.

      • getOldRoleValue

        public List<ObjectName> getOldRoleValue()
        Returns old value of updated role (only for role update).
        返回：
        the old value of the updated role.

      • getNewRoleValue

        public List<ObjectName> getNewRoleValue()
        Returns new value of updated role (only for role update).
        返回：
        the new value of the updated role.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fi


RelationService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RelationService

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.relation.RelationService
  • 所有已实现的接口：
    EventListener, MBeanRegistration, NotificationBroadcaster, NotificationEmitter, NotificationListener, RelationServiceMBean

    public class RelationService
extends NotificationBroadcasterSupport
implements RelationServiceMBean, MBeanRegistration, NotificationListener
    The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

    It implements the NotificationBroadcaster by extending NotificationBroadcasterSupport to send notifications when a relation is removed from it.

    It implements the NotificationListener interface to be able to receive notifications concerning unregistration of MBeans referenced in relation roles and of relation MBeans.

    It implements the MBeanRegistration interface to be able to retrieve its ObjectName and MBean Server.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationService(boolean immediatePurgeFlag)
      Constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
      Integer checkRoleReading(String roleName, String relationTypeName)
      Checks if given Role can be read in a relation of the given type.
      Integer checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      void createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Map<String,List<String>> findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the relations where a given MBean is referenced.
      List<String> findRelationsOfType(String relationTypeName)
      Returns the relation ids for relations of the given type.
      List<String> getAllRelationIds()
      Returns all the relation ids for all the relations handled by the Relation Service.
      List<String> getAllRelationTypeNames()
      Retrieves names of all known relation types.
      RoleResult getAllRoles(String relationId)
      Returns all roles present in the relation.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.
      boolean getPurgeFlag()
      Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.
      Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      String getRelationTypeName(String relationId)
      Returns name of associated relation type for given relation.
      List<ObjectName> getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      Integer getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      RoleInfo getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role name of a given relation type.
      List<RoleInfo> getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      RoleResult getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      void handleNotification(Notification notif, Object handback)
      Invoked when a JMX notification occurs.
      Boolean hasRelation(String relationId)
      Checks if there is a relation identified in Relation Service with given relation id.
      void isActive()
      Checks if the Relation Service is active.
      String isRelation(ObjectName objectName)
      Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
      ObjectName isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      void postDeregister()
      Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean Server.
      void purgeRelations()
      Purges the relations.
      void removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void sendRelationCreationNotification(String relationId)
      Sends a notification (RelationNotification) for a relation creation.
      void sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void setPurgeFlag(boolean purgeFlag)
      Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.
      void setRole(String relationId, Role role)
      Sets the given role in given relation.
      RoleResult setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      void updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
      Handles update of the Relation Service role map for the update of given role in given relation.

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RelationService

        public RelationService(boolean immediatePurgeFlag)
        Constructor.
        参数：
        immediatePurgeFlag - flag to indicate when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

        true is immediate purge.

    • 方法详细信息

      • isActive

        public void isActive()
              throws RelationServiceNotRegisteredException
        Checks if the Relation Service is active. Current condition is that the Relation Service must be registered in the MBean Server
        指定者：
        isActive in interface RelationServiceMBean
        抛出：
        RelationServiceNotRegisteredException - if it is not registered

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations it needs before being registered in the MBean Server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean Server.
        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean Server in which the MBean will be registered.
        name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
        返回：
        The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
        抛出：
        Exception - This exception will be caught by the MBean Server and re-thrown as an MBeanRegistrationException.

      • postRegister

        public void postRegister(Boolean registrationDone)
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postRegister will not change the state of the MBean: if the MBean was already registered (registrationDone is true), the MBean will remain registered.

        This might be confusing for the code calling createMBean() or registerMBean(), as such code might assume that MBean registration has failed when such an exception is raised. Therefore it is recommended that implementations of postRegister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postDeregister

        public void postDeregister()
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postDeregister will not change the state of the MBean: the MBean was already successfully deregistered and will remain so.

        This might be confusing for the code calling unregisterMBean(), as it might assume that MBean deregistration has failed. Therefore it is recommended that implementations of postDeregister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postDeregister in interface MBeanRegistration

      • getPurgeFlag

        public boolean getPurgeFlag()
        Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

        true is immediate purge.

        指定者：
        getPurgeFlag in interface RelationServiceMBean
        返回：
        true if purges are automatic.
        另请参见：
        setPurgeFlag(boolean)

      • setPurgeFlag

        public void setPurgeFlag(boolean purgeFlag)
        Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

        true is immediate purge.

        指定者：
        setPurgeFlag in interface RelationServiceMBean
        参数：
        purgeFlag - flag
        另请参见：
        getPurgeFlag()

      • createRelationType

        public void createRelationType(String relationTypeName,
                      RoleInfo[] roleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
        Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
        指定者：
        createRelationType in interface RelationServiceMBean
        参数：
        relationTypeName - name of the relation type
        roleInfoArray - array of role infos
        抛出：
        IllegalArgumentException - if null parameter
        InvalidRelationTypeException - If:

        - there is already a relation type with that name

        - the same name has been used for two different role infos

        - no role info provided

        - one null role info provided

      • addRelationType

        public void addRelationType(RelationType relationTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
        Adds given object as a relation type. The object is expected to implement the RelationType interface.
        指定者：
        addRelationType in interface RelationServiceMBean
        参数：
        relationTypeObj - relation type object (implementing the RelationType interface)
        抛出：
        IllegalArgumentException - if null parameter or if relationTypeObj.getRelationTypeName() returns null.
        InvalidRelationTypeException - if:

        - the same name has been used for two different roles

        - no role info provided

        - one null role info provided

        - there is already a relation type with that name

      • getAllRelationTypeNames

        public List<String> getAllRelationTypeNames()
        Retrieves names of all known relation types.
        指定者：
        getAllRelationTypeNames in interface RelationServiceMBean
        返回：
        ArrayList of relation type names (Strings)

      • getRoleInfos

        public List<RoleInfo> getRoleInfos(String relationTypeName)
                            throws IllegalArgumentException,
                                   RelationTypeNotFoundException
        Retrieves list of role infos (RoleInfo objects) of a given relation type.
        指定者：
        getRoleInfos in interface RelationServiceMBean
        参数：
        relationTypeName - name of relation type
        返回：
        ArrayList of RoleInfo.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if there is no relation type with that name.

      • getRoleInfo

        public RoleInfo getRoleInfo(String relationTypeName,
                   String roleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
        Retrieves role info for given role name of a given relation type.
        指定者：
        getRoleInfo in interface RelationServiceMBean
        参数：
        relationTypeName - name of relation type
        roleInfoName - name of role
        返回：
        RoleInfo object.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if the relation type is not known in the Relation Service
        RoleInfoNotFoundException - if the role is not part of the relation type.

      • removeRelationType

        public void removeRelationType(String relationTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
        Removes given relation type from Relation Service.

        The relation objects of that type will be removed from the Relation Service.

        指定者：
        removeRelationType in interface RelationServiceMBean
        参数：
        relationTypeName - name of the relation type to be removed
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - If there is no relation type with that name

      • createRelation

        public void createRelation(String relationId,
                  String relationTypeName,
                  RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
        Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.

        Roles are initialized according to the role list provided in parameter. The ones not initialized in this way are set to an empty ArrayList of ObjectNames.

        A RelationNotification, with type RELATION_BASIC_CREATION, is sent.

        指定者：
        createRelation in interface RelationServiceMBean
        参数：
        relationId - relation identifier, to identify uniquely the relation inside the Relation Service
        relationTypeName - name of the relation type (has to be created in the Relation Service)
        roleList - role list to initialize roles of the relation (can be null).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter, except the role list which can be null if no role initialization
        RoleNotFoundException - if a value is provided for a role that does not exist in the relation type
        InvalidRelationIdException - if relation id already used
        RelationTypeNotFoundException - if relation type not known in Relation Service
        InvalidRoleValueException - if:

        - the same role name is used for two different roles

        - the number of referenced MBeans in given value is less than expected minimum degree

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - an MBean provided for that role does not exist

      • addRelation

        public void addRelation(ObjectName relationObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
        Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.

        To be added as a relation, the MBean must conform to the following:

        - implement the Relation interface

        - have for RelationService ObjectName the ObjectName of current Relation Service

        - have a relation id unique and unused in current Relation Service

        - have for relation type a relation type created in the Relation Service

        - have roles conforming to the role info provided in the relation type.

        指定者：
        addRelation in interface RelationServiceMBean
        参数：
        relationObjectName - ObjectName of the relation MBean to be added.
        抛出：
        IllegalArgumentException - if null parameter
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        NoSuchMethodException - If the MBean does not implement the Relation interface
        InvalidRelationIdException - if:

        - no relation identifier in MBean

        - the relation identifier is already used in the Relation Service

        InstanceNotFoundException - if the MBean for given ObjectName has not been registered
        InvalidRelationServiceException - if:

        - no Relation Service name in MBean

        - the Relation Service name in the MBean is not the one of the current Relation Service

        RelationTypeNotFoundException - if:

        - no relation type name in MBean

        - the relation type name in MBean does not correspond to a relation type created in the Relation Service

        InvalidRoleValueException - if:

        - the number of referenced MBeans in a role is less than expected minimum degree

        - the number of referenced MBeans in a role exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - an MBean provided for a role does not exist

        RoleNotFoundException - if a value is provided for a role that does not exist in the relation type

      • isRelationMBean

        public ObjectName isRelationMBean(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
        If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
        指定者：
        isRelationMBean in interface RelationServiceMBean
        参数：
        relationId - relation id identifying the relation
        返回：
        ObjectName of the corresponding relation MBean, or null if the relation is not an MBean.
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - there is no relation associated to that id

      • isRelation

        public String isRelation(ObjectName objectName)
                  throws IllegalArgumentException
        Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
        指定者：
        isRelation in interface RelationServiceMBean
        参数：
        objectName - ObjectName of supposed relation
        返回：
        relation id (String) or null (if the ObjectName is not a relation handled by the Relation Service)
        抛出：
        IllegalArgumentException - if null parameter

      • hasRelation

        public Boolean hasRelation(String relationId)
                    throws IllegalArgumentException
        Checks if there is a relation identified in Relation Service with given relation id.
        指定者：
        hasRelation in interface RelationServiceMBean
        参数：
        relationId - relation id identifying the relation
        返回：
        boolean: true if there is a relation, false else
        抛出：
        IllegalArgumentException - if null parameter

      • getAllRelationIds

        public List<String> getAllRelationIds()
        Returns all the relation ids for all the relations handled by the Relation Service.
        指定者：
        getAllRelationIds in interface RelationServiceMBean
        返回：
        ArrayList of String

      • checkRoleReading

        public Integer checkRoleReading(String roleName,
                       String relationTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
        Checks if given Role can be read in a relation of the given type.
        指定者：
        checkRoleReading in interface RelationServiceMBean
        参数：
        roleName - name of role to be checked
        relationTypeName - name of the relation type
        返回：
        an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

        - 0 if role can be read

        - integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

        - integer corresponding to RoleStatus.ROLE_NOT_READABLE

        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if the relation type is not known in the Relation Service

      • checkRoleWriting

        public Integer checkRoleWriting(Role role,
                       String relationTypeName,
                       Boolean initFlag)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
        Checks if given Role can be set in a relation of given type.
        指定者：
        checkRoleWriting in interface RelationServiceMBean
        参数：
        role - role to be checked
        relationTypeName - name of relation type
        initFlag - flag to specify that the checking is done for the initialization of a role, write access shall not be verified.
        返回：
        an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

        - 0 if role can be set

        - integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

        - integer for RoleStatus.ROLE_NOT_WRITABLE

        - integer for RoleStatus.LESS_THAN_MIN_ROLE_DEGREE

        - integer for RoleStatus.MORE_THAN_MAX_ROLE_DEGREE

        - integer for RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS

        - integer for RoleStatus.REF_MBEAN_NOT_REGISTERED

        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if unknown relation type

      • sendRelationCreationNotification

        public void sendRelationCreationNotification(String relationId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
        Sends a notification (RelationNotification) for a relation creation. The notification type is:

        - RelationNotification.RELATION_BASIC_CREATION if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_CREATION if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in Relation Service createRelation() and addRelation() methods.

        指定者：
        sendRelationCreationNotification in interface RelationServiceMBean
        参数：
        relationId - relation identifier of the updated relation
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • sendRoleUpdateNotification

        public void sendRoleUpdateNotification(String relationId,
                              Role newRole,
                              List<ObjectName> oldValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
        Sends a notification (RelationNotification) for a role update in the given relation. The notification type is:

        - RelationNotification.RELATION_BASIC_UPDATE if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_UPDATE if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

        It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

        指定者：
        sendRoleUpdateNotification in interface RelationServiceMBean
        参数：
        relationId - relation identifier of the updated relation
        newRole - new role (name and new value)
        oldValue - old role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • sendRelationRemovalNotification

        public void sendRelationRemovalNotification(String relationId,
                                   List<ObjectName> unregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
        Sends a notification (RelationNotification) for a relation removal. The notification type is:

        - RelationNotification.RELATION_BASIC_REMOVAL if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_REMOVAL if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in Relation Service removeRelation() method.

        指定者：
        sendRelationRemovalNotification in interface RelationServiceMBean
        参数：
        relationId - relation identifier of the updated relation
        unregMBeanList - List of ObjectNames of MBeans expected to be unregistered due to relation removal (can be null)
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • updateRoleMap

        public void updateRoleMap(String relationId,
                 Role newRole,
                 List<ObjectName> oldValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
        Handles update of the Relation Service role map for the update of given role in given relation.

        It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

        It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

        To allow the Relation Service to maintain the consistency (in case of MBean unregistration) and to be able to perform queries, this method must be called when a role is updated.

        指定者：
        updateRoleMap in interface RelationServiceMBean
        参数：
        relationId - relation identifier of the updated relation
        newRole - new role (name and new value)
        oldValue - old role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationNotFoundException - if no relation for given id.

      • removeRelation

        public void removeRelation(String relationId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Removes given relation from the Relation Service.

        A RelationNotification notification is sent, its type being:

        - RelationNotification.RELATION_BASIC_REMOVAL if the relation was only internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_REMOVAL if the relation is registered as an MBean.

        For MBeans referenced in such relation, nothing will be done,

        指定者：
        removeRelation in interface RelationServiceMBean
        参数：
        relationId - relation id of the relation to be removed
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation corresponding to given relation id

      • purgeRelations

        public void purgeRelations()
                    throws RelationServiceNotRegisteredException
        Purges the relations.

        Depending on the purgeFlag value, this method is either called automatically when a notification is received for the unregistration of an MBean referenced in a relation (if the flag is set to true), or not (if the flag is set to false).

        In that case it is up to the user to call it to maintain the consistency of the relations. To be kept in mind that if an MBean is unregistered and the purge not done immediately, if the ObjectName is reused and assigned to another MBean referenced in a relation, calling manually this purgeRelations() method will cause trouble, as will consider the ObjectName as corresponding to the unregistered MBean, not seeing the new one.

        The behavior depends on the cardinality of the role where the unregistered MBean is referenced:

        - if removing one MBean reference in the role makes its number of references less than the minimum degree, the relation has to be removed.

        - if the remaining number of references after removing the MBean reference is still in the cardinality range, keep the relation and update it calling its handleMBeanUnregistration() callback.

        指定者：
        purgeRelations in interface RelationServiceMBean
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server.

      • findReferencingRelations

        public Map<String,List<String>> findReferencingRelations(ObjectName mbeanName,
                                                String relationTypeName,
                                                String roleName)
                                                  throws IllegalArgumentException
        Retrieves the relations where a given MBean is referenced.

        This corresponds to the CIM "References" and "ReferenceNames" operations.

        指定者：
        findReferencingRelations in interface RelationServiceMBean
        参数：
        mbeanName - ObjectName of MBean
        relationTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
        roleName - can be null; if specified, only the relations where the MBean is referenced in that role will be returned. Else all roles are considered.
        返回：
        an HashMap, where the keys are the relation ids of the relations where the MBean is referenced, and the value is, for each key, an ArrayList of role names (as an MBean can be referenced in several roles in the same relation).
        抛出：
        IllegalArgumentException - if null parameter

      • findAssociatedMBeans

        public Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName,
                                                String relationTypeName,
                                                String roleName)
                                                  throws IllegalArgumentException
        Retrieves the MBeans associated to given one in a relation.

        This corresponds to CIM Associators and AssociatorNames operations.

        指定者：
        findAssociatedMBeans in interface RelationServiceMBean
        参数：
        mbeanName - ObjectName of MBean
        relationTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
        roleName - can be null; if specified, only the relations where the MBean is referenced in that role will be considered. Else all roles are considered.
        返回：
        an HashMap, where the keys are the ObjectNames of the MBeans associated to given MBean, and the value is, for each key, an ArrayList of the relation ids of the relations where the key MBean is associated to given one (as they can be associated in several different relations).
        抛出：
        IllegalArgumentException - if null parameter

      • findRelationsOfType

        public List<String> findRelationsOfType(String relationTypeName)
                                 throws IllegalArgumentException,
                                        RelationTypeNotFoundException
        Returns the relation ids for relations of the given type.
        指定者：
        findRelationsOfType in interface RelationServiceMBean
        参数：
        relationTypeName - relation type name
        返回：
        an ArrayList of relation ids.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if there is no relation type with that name.

      • getRole

        public List<ObjectName> getRole(String relationId,
                       String roleName)
                         throws RelationServiceNotRegisteredException,
                                IllegalArgumentException,
                                RelationNotFoundException,
                                RoleNotFoundException
        Retrieves role value for given role name in given relation.
        指定者：
        getRole in interface RelationServiceMBean
        参数：
        relationId - relation id
        roleName - name of role
        返回：
        the ArrayList of ObjectName objects being the role value
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if:

        - there is no role with given name

        or

        - the role is not readable.

        另请参见：
        setRole(java.lang.String, javax.management.relation.Role)

      • getRoles

        public RoleResult getRoles(String relationId,
                  String[] roleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Retrieves values of roles with given names in given relation.
        指定者：
        getRoles in interface RelationServiceMBean
        参数：
        relationId - relation id
        roleNameArray - array of names of roles to be retrieved
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        另请参见：
        setRoles(java.lang.String, javax.management.relation.RoleList)

      • getAllRoles

        public RoleResult getAllRoles(String relationId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
        Returns all roles present in the relation.
        指定者：
        getAllRoles in interface RelationServiceMBean
        参数：
        relationId - relation id
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not readable).
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given id
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

      • getRoleCardinality

        public Integer getRoleCardinality(String relationId,
                         String roleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
        Retrieves the number of MBeans currently referenced in the given role.
        指定者：
        getRoleCardinality in interface RelationServiceMBean
        参数：
        relationId - relation id
        roleName - name of role
        返回：
        the number of currently referenced MBeans in that role
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if there is no role with given name

      • setRole

        public void setRole(String relationId,
           Role role)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException
        Sets the given role in given relation.

        Will check the role according to its corresponding role definition provided in relation's relation type

        The Relation Service will keep track of the change to keep the consistency of relations by handling referenced MBean unregistrations.

        指定者：
        setRole in interface RelationServiceMBean
        参数：
        relationId - relation id
        role - role to be set (name and new value)
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if the role does not exist or is not writable
        InvalidRoleValueException - if value provided for role is not valid:

        - the number of referenced MBeans in given value is less than expected minimum degree

        or

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        or

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        or

        - an MBean provided for that role does not exist

        另请参见：
        getRole(java.lang.String, java.lang.String)

      • setRoles

        public RoleResult setRoles(String relationId,
                  RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Sets the given roles in given relation.

        Will check the role according to its corresponding role definition provided in relation's relation type

        The Relation Service keeps track of the changes to keep the consistency of relations by handling referenced MBean unregistrations.

        指定者：
        setRoles in interface RelationServiceMBean
        参数：
        relationId - relation id
        roleList - list of roles to be set
        返回：
        a RoleResult object, including a RoleList (for roles successfully set) and a RoleUnresolvedList (for roles not set).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        另请参见：
        getRoles(java.lang.String, java.lang.String[])

      • getReferencedMBeans

        public Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
                                                 throws IllegalArgumentException,
                                                        RelationNotFoundException
        Retrieves MBeans referenced in the various roles of the relation.
        指定者：
        getReferencedMBeans in interface RelationServiceMBean
        参数：
        relationId - relation id
        返回：
        a HashMap mapping:

        ObjectName -> ArrayList of String (role names)

        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given relation id

      • getRelationTypeName

        public String getRelationTypeName(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
        Returns name of associated relation type for given relation.
        指定者：
        getRelationTypeName in interface RelationServiceMBean
        参数：
        relationId - relation id
        返回：
        the name of the associated relation type.
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given relation id

      • handleNotification

        public void handleNotification(Notification notif,
                      Object handback)
        Invoked when a JMX notification occurs. Currently handles notifications for unregistration of MBeans, either referenced in a relation role or being a relation itself.
        指定者：
        handleNotification in interface NotificationListener
        参数：
        notif - The notification.
        handback - An opaque object which helps the listener to associate information regarding the MBean emitter (can be null).

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.
        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RelationServiceMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.relation

Interface RelationServiceMBean

  • All Known Implementing Classes:
    RelationService

    public interface RelationServiceMBean
    The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
      Integer checkRoleReading(String roleName, String relationTypeName)
      Checks if given Role can be read in a relation of the given type.
      Integer checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      void createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the MBeans associated to given one in a relation.
      Map<String,List<String>> findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
      Retrieves the relations where a given MBean is referenced.
      List<String> findRelationsOfType(String relationTypeName)
      Returns the relation ids for relations of the given type.
      List<String> getAllRelationIds()
      Returns all the relation ids for all the relations handled by the Relation Service.
      List<String> getAllRelationTypeNames()
      Retrieves names of all known relation types.
      RoleResult getAllRoles(String relationId)
      Returns all roles present in the relation.
      boolean getPurgeFlag()
      Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.
      Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      String getRelationTypeName(String relationId)
      Returns name of associated relation type for given relation.
      List<ObjectName> getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      Integer getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      RoleInfo getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role of a given relation type.
      List<RoleInfo> getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      RoleResult getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      Boolean hasRelation(String relationId)
      Checks if there is a relation identified in Relation Service with given relation id.
      void isActive()
      Checks if the Relation Service is active.
      String isRelation(ObjectName objectName)
      Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
      ObjectName isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      void purgeRelations()
      Purges the relations.
      void removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void sendRelationCreationNotification(String relationId)
      Sends a notification (RelationNotification) for a relation creation.
      void sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void setPurgeFlag(boolean purgeFlag)
      Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.
      void setRole(String relationId, Role role)
      Sets the given role in given relation.
      RoleResult setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      void updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Handles update of the Relation Service role map for the update of given role in given relation.

    • 方法详细信息

      • isActive

        void isActive()
              throws RelationServiceNotRegisteredException
        Checks if the Relation Service is active. Current condition is that the Relation Service must be registered in the MBean Server
        抛出：
        RelationServiceNotRegisteredException - if it is not registered

      • getPurgeFlag

        boolean getPurgeFlag()
        Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

        true is immediate purge.

        返回：
        true if purges are immediate.
        另请参见：
        setPurgeFlag(boolean)

      • setPurgeFlag

        void setPurgeFlag(boolean purgeFlag)
        Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

        true is immediate purge.

        参数：
        purgeFlag - flag
        另请参见：
        getPurgeFlag()

      • createRelationType

        void createRelationType(String relationTypeName,
                      RoleInfo[] roleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
        Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
        参数：
        relationTypeName - name of the relation type
        roleInfoArray - array of role infos
        抛出：
        IllegalArgumentException - if null parameter
        InvalidRelationTypeException - If:

        - there is already a relation type with that name

        - the same name has been used for two different role infos

        - no role info provided

        - one null role info provided

      • addRelationType

        void addRelationType(RelationType relationTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
        Adds given object as a relation type. The object is expected to implement the RelationType interface.
        参数：
        relationTypeObj - relation type object (implementing the RelationType interface)
        抛出：
        IllegalArgumentException - if null parameter or if relationTypeObj.getRelationTypeName() returns null.
        InvalidRelationTypeException - if there is already a relation type with that name

      • getAllRelationTypeNames

        List<String> getAllRelationTypeNames()
        Retrieves names of all known relation types.
        返回：
        ArrayList of relation type names (Strings)

      • getRoleInfos

        List<RoleInfo> getRoleInfos(String relationTypeName)
                            throws IllegalArgumentException,
                                   RelationTypeNotFoundException
        Retrieves list of role infos (RoleInfo objects) of a given relation type.
        参数：
        relationTypeName - name of relation type
        返回：
        ArrayList of RoleInfo.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if there is no relation type with that name.

      • getRoleInfo

        RoleInfo getRoleInfo(String relationTypeName,
                   String roleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
        Retrieves role info for given role of a given relation type.
        参数：
        relationTypeName - name of relation type
        roleInfoName - name of role
        返回：
        RoleInfo object.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if the relation type is not known in the Relation Service
        RoleInfoNotFoundException - if the role is not part of the relation type.

      • removeRelationType

        void removeRelationType(String relationTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
        Removes given relation type from Relation Service.

        The relation objects of that type will be removed from the Relation Service.

        参数：
        relationTypeName - name of the relation type to be removed
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - If there is no relation type with that name

      • createRelation

        void createRelation(String relationId,
                  String relationTypeName,
                  RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
        Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.

        Roles are initialized according to the role list provided in parameter. The ones not initialized in this way are set to an empty ArrayList of ObjectNames.

        A RelationNotification, with type RELATION_BASIC_CREATION, is sent.

        参数：
        relationId - relation identifier, to identify uniquely the relation inside the Relation Service
        relationTypeName - name of the relation type (has to be created in the Relation Service)
        roleList - role list to initialize roles of the relation (can be null).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RoleNotFoundException - if a value is provided for a role that does not exist in the relation type
        InvalidRelationIdException - if relation id already used
        RelationTypeNotFoundException - if relation type not known in Relation Service
        InvalidRoleValueException - if:

        - the same role name is used for two different roles

        - the number of referenced MBeans in given value is less than expected minimum degree

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - an MBean provided for that role does not exist

      • addRelation

        void addRelation(ObjectName relationObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
        Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.

        To be added as a relation, the MBean must conform to the following:

        - implement the Relation interface

        - have for RelationService ObjectName the ObjectName of current Relation Service

        - have a relation id that is unique and unused in current Relation Service

        - have for relation type a relation type created in the Relation Service

        - have roles conforming to the role info provided in the relation type.

        参数：
        relationObjectName - ObjectName of the relation MBean to be added.
        抛出：
        IllegalArgumentException - if null parameter
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        NoSuchMethodException - If the MBean does not implement the Relation interface
        InvalidRelationIdException - if:

        - no relation identifier in MBean

        - the relation identifier is already used in the Relation Service

        InstanceNotFoundException - if the MBean for given ObjectName has not been registered
        InvalidRelationServiceException - if:

        - no Relation Service name in MBean

        - the Relation Service name in the MBean is not the one of the current Relation Service

        RelationTypeNotFoundException - if:

        - no relation type name in MBean

        - the relation type name in MBean does not correspond to a relation type created in the Relation Service

        InvalidRoleValueException - if:

        - the number of referenced MBeans in a role is less than expected minimum degree

        - the number of referenced MBeans in a role exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - an MBean provided for a role does not exist

        RoleNotFoundException - if a value is provided for a role that does not exist in the relation type

      • isRelationMBean

        ObjectName isRelationMBean(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
        If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
        参数：
        relationId - relation id identifying the relation
        返回：
        ObjectName of the corresponding relation MBean, or null if the relation is not an MBean.
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - there is no relation associated to that id

      • isRelation

        String isRelation(ObjectName objectName)
                  throws IllegalArgumentException
        Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
        参数：
        objectName - ObjectName of supposed relation
        返回：
        relation id (String) or null (if the ObjectName is not a relation handled by the Relation Service)
        抛出：
        IllegalArgumentException - if null parameter

      • hasRelation

        Boolean hasRelation(String relationId)
                    throws IllegalArgumentException
        Checks if there is a relation identified in Relation Service with given relation id.
        参数：
        relationId - relation id identifying the relation
        返回：
        boolean: true if there is a relation, false else
        抛出：
        IllegalArgumentException - if null parameter

      • getAllRelationIds

        List<String> getAllRelationIds()
        Returns all the relation ids for all the relations handled by the Relation Service.
        返回：
        ArrayList of String

      • checkRoleReading

        Integer checkRoleReading(String roleName,
                       String relationTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
        Checks if given Role can be read in a relation of the given type.
        参数：
        roleName - name of role to be checked
        relationTypeName - name of the relation type
        返回：
        an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

        - 0 if role can be read

        - integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

        - integer corresponding to RoleStatus.ROLE_NOT_READABLE

        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if the relation type is not known in the Relation Service

      • checkRoleWriting

        Integer checkRoleWriting(Role role,
                       String relationTypeName,
                       Boolean initFlag)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
        Checks if given Role can be set in a relation of given type.
        参数：
        role - role to be checked
        relationTypeName - name of relation type
        initFlag - flag to specify that the checking is done for the initialization of a role, write access shall not be verified.
        返回：
        an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

        - 0 if role can be set

        - integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

        - integer for RoleStatus.ROLE_NOT_WRITABLE

        - integer for RoleStatus.LESS_THAN_MIN_ROLE_DEGREE

        - integer for RoleStatus.MORE_THAN_MAX_ROLE_DEGREE

        - integer for RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS

        - integer for RoleStatus.REF_MBEAN_NOT_REGISTERED

        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if unknown relation type

      • sendRelationCreationNotification

        void sendRelationCreationNotification(String relationId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
        Sends a notification (RelationNotification) for a relation creation. The notification type is:

        - RelationNotification.RELATION_BASIC_CREATION if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_CREATION if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in Relation Service createRelation() and addRelation() methods.

        参数：
        relationId - relation identifier of the updated relation
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • sendRoleUpdateNotification

        void sendRoleUpdateNotification(String relationId,
                              Role newRole,
                              List<ObjectName> oldRoleValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
        Sends a notification (RelationNotification) for a role update in the given relation. The notification type is:

        - RelationNotification.RELATION_BASIC_UPDATE if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_UPDATE if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

        It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

        参数：
        relationId - relation identifier of the updated relation
        newRole - new role (name and new value)
        oldRoleValue - old role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • sendRelationRemovalNotification

        void sendRelationRemovalNotification(String relationId,
                                   List<ObjectName> unregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
        Sends a notification (RelationNotification) for a relation removal. The notification type is:

        - RelationNotification.RELATION_BASIC_REMOVAL if the relation is an object internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_REMOVAL if the relation is a MBean added as a relation.

        The source object is the Relation Service itself.

        It is called in Relation Service removeRelation() method.

        参数：
        relationId - relation identifier of the updated relation
        unregMBeanList - List of ObjectNames of MBeans expected to be unregistered due to relation removal (can be null)
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if there is no relation for given relation id

      • updateRoleMap

        void updateRoleMap(String relationId,
                 Role newRole,
                 List<ObjectName> oldRoleValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
        Handles update of the Relation Service role map for the update of given role in given relation.

        It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

        It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

        To allow the Relation Service to maintain the consistency (in case of MBean unregistration) and to be able to perform queries, this method must be called when a role is updated.

        参数：
        relationId - relation identifier of the updated relation
        newRole - new role (name and new value)
        oldRoleValue - old role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationNotFoundException - if no relation for given id.

      • removeRelation

        void removeRelation(String relationId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Removes given relation from the Relation Service.

        A RelationNotification notification is sent, its type being:

        - RelationNotification.RELATION_BASIC_REMOVAL if the relation was only internal to the Relation Service

        - RelationNotification.RELATION_MBEAN_REMOVAL if the relation is registered as an MBean.

        For MBeans referenced in such relation, nothing will be done,

        参数：
        relationId - relation id of the relation to be removed
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation corresponding to given relation id

      • purgeRelations

        void purgeRelations()
                    throws RelationServiceNotRegisteredException
        Purges the relations.

        Depending on the purgeFlag value, this method is either called automatically when a notification is received for the unregistration of an MBean referenced in a relation (if the flag is set to true), or not (if the flag is set to false).

        In that case it is up to the user to call it to maintain the consistency of the relations. To be kept in mind that if an MBean is unregistered and the purge not done immediately, if the ObjectName is reused and assigned to another MBean referenced in a relation, calling manually this purgeRelations() method will cause trouble, as will consider the ObjectName as corresponding to the unregistered MBean, not seeing the new one.

        The behavior depends on the cardinality of the role where the unregistered MBean is referenced:

        - if removing one MBean reference in the role makes its number of references less than the minimum degree, the relation has to be removed.

        - if the remaining number of references after removing the MBean reference is still in the cardinality range, keep the relation and update it calling its handleMBeanUnregistration() callback.

        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server.

      • findReferencingRelations

        Map<String,List<String>> findReferencingRelations(ObjectName mbeanName,
                                                String relationTypeName,
                                                String roleName)
                                                  throws IllegalArgumentException
        Retrieves the relations where a given MBean is referenced.

        This corresponds to the CIM "References" and "ReferenceNames" operations.

        参数：
        mbeanName - ObjectName of MBean
        relationTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
        roleName - can be null; if specified, only the relations where the MBean is referenced in that role will be returned. Else all roles are considered.
        返回：
        an HashMap, where the keys are the relation ids of the relations where the MBean is referenced, and the value is, for each key, an ArrayList of role names (as an MBean can be referenced in several roles in the same relation).
        抛出：
        IllegalArgumentException - if null parameter

      • findAssociatedMBeans

        Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName,
                                                String relationTypeName,
                                                String roleName)
                                                  throws IllegalArgumentException
        Retrieves the MBeans associated to given one in a relation.

        This corresponds to CIM Associators and AssociatorNames operations.

        参数：
        mbeanName - ObjectName of MBean
        relationTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
        roleName - can be null; if specified, only the relations where the MBean is referenced in that role will be considered. Else all roles are considered.
        返回：
        an HashMap, where the keys are the ObjectNames of the MBeans associated to given MBean, and the value is, for each key, an ArrayList of the relation ids of the relations where the key MBean is associated to given one (as they can be associated in several different relations).
        抛出：
        IllegalArgumentException - if null parameter

      • findRelationsOfType

        List<String> findRelationsOfType(String relationTypeName)
                                 throws IllegalArgumentException,
                                        RelationTypeNotFoundException
        Returns the relation ids for relations of the given type.
        参数：
        relationTypeName - relation type name
        返回：
        an ArrayList of relation ids.
        抛出：
        IllegalArgumentException - if null parameter
        RelationTypeNotFoundException - if there is no relation type with that name.

      • getRole

        List<ObjectName> getRole(String relationId,
                       String roleName)
                         throws RelationServiceNotRegisteredException,
                                IllegalArgumentException,
                                RelationNotFoundException,
                                RoleNotFoundException
        Retrieves role value for given role name in given relation.
        参数：
        relationId - relation id
        roleName - name of role
        返回：
        the ArrayList of ObjectName objects being the role value
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if:

        - there is no role with given name

        or

        - the role is not readable.

        另请参见：
        setRole(java.lang.String, javax.management.relation.Role)

      • getRoles

        RoleResult getRoles(String relationId,
                  String[] roleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Retrieves values of roles with given names in given relation.
        参数：
        relationId - relation id
        roleNameArray - array of names of roles to be retrieved
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        另请参见：
        setRoles(java.lang.String, javax.management.relation.RoleList)

      • getAllRoles

        RoleResult getAllRoles(String relationId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
        Returns all roles present in the relation.
        参数：
        relationId - relation id
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not readable).
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given id
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

      • getRoleCardinality

        Integer getRoleCardinality(String relationId,
                         String roleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
        Retrieves the number of MBeans currently referenced in the given role.
        参数：
        relationId - relation id
        roleName - name of role
        返回：
        the number of currently referenced MBeans in that role
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if there is no role with given name

      • setRole

        void setRole(String relationId,
           Role role)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException,
                    RelationTypeNotFoundException
        Sets the given role in given relation.

        Will check the role according to its corresponding role definition provided in relation's relation type

        The Relation Service will keep track of the change to keep the consistency of relations by handling referenced MBean unregistrations.

        参数：
        relationId - relation id
        role - role to be set (name and new value)
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        RoleNotFoundException - if:

        - internal relation

        and

        - the role does not exist or is not writable

        InvalidRoleValueException - if internal relation and value provided for role is not valid:

        - the number of referenced MBeans in given value is less than expected minimum degree

        or

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        or

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        or

        - an MBean provided for that role does not exist

        RelationTypeNotFoundException - if unknown relation type
        另请参见：
        getRole(java.lang.String, java.lang.String)

      • setRoles

        RoleResult setRoles(String relationId,
                  RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
        Sets the given roles in given relation.

        Will check the role according to its corresponding role definition provided in relation's relation type

        The Relation Service keeps track of the changes to keep the consistency of relations by handling referenced MBean unregistrations.

        参数：
        relationId - relation id
        roleList - list of roles to be set
        返回：
        a RoleResult object, including a RoleList (for roles successfully set) and a RoleUnresolvedList (for roles not set).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation with given id
        另请参见：
        getRoles(java.lang.String, java.lang.String[])

      • getReferencedMBeans

        Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
                                                 throws IllegalArgumentException,
                                                        RelationNotFoundException
        Retrieves MBeans referenced in the various roles of the relation.
        参数：
        relationId - relation id
        返回：
        a HashMap mapping:

        ObjectName -> ArrayList of String (role names)

        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given relation id

      • getRelationTypeName

        String getRelationTypeName(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
        Returns name of associated relation type for given relation.
        参数：
        relationId - relation id
        返回：
        the name of the associated relation type.
        抛出：
        IllegalArgumentException - if null parameter
        RelationNotFoundException - if no relation for given relation id
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

leas=ci"citttitttell wroE<"mms


RelationServiceNotRegisteredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RelationServiceNotRegisteredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.RelationServiceNotRegisteredException
  • 所有已实现的接口：
    Serializable

    public class RelationServiceNotRegisteredException
extends RelationException
    This exception is raised when an access is done to the Relation Service and that one is not registered.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationServiceNotRegisteredException()
      Default constructor, no message put in exception.
      RelationServiceNotRegisteredException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RelationServiceNotRegisteredException

        public RelationServiceNotRegisteredException()
        Default constructor, no message put in exception.

      • RelationServiceNotRegisteredException

        public RelationServiceNotRegisteredException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olni/emremeeemeem.rrajrngnt>v"ai.a=jht


RelationSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RelationSupport

  • java.lang.Object
    • javax.management.relation.RelationSupport
  • 所有已实现的接口：
    MBeanRegistration, Relation, RelationSupportMBean

    public class RelationSupport
extends Object
implements RelationSupportMBean, MBeanRegistration
    A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type. As internal representation, it is not exposed to the user.

    RelationSupport class conforms to the design patterns of standard MBean. So the user can decide to instantiate a RelationSupport object himself as a MBean (as it follows the MBean design patterns), to register it in the MBean Server, and then to add it in the Relation Service.

    The user can also, when creating his own MBean relation class, have it extending RelationSupport, to retrieve the implementations of required interfaces (see below).

    It is also possible to have in a user relation MBean class a member being a RelationSupport object, and to implement the required interfaces by delegating all to this member.

    RelationSupport implements the Relation interface (to be handled by the Relation Service).

    It implements also the MBeanRegistration interface to be able to retrieve the MBean Server where it is registered (if registered as a MBean) to access to its Relation Service.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
      Creates a RelationSupport object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      RoleResult getAllRoles()
      Returns all roles present in the relation.
      Map<ObjectName,List<String>> getReferencedMBeans()
      Retrieves MBeans referenced in the various roles of the relation.
      String getRelationId()
      Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
      ObjectName getRelationServiceName()
      Returns ObjectName of the Relation Service handling the relation.
      String getRelationTypeName()
      Returns name of associated relation type.
      List<ObjectName> getRole(String roleName)
      Retrieves role value for given role name.
      Integer getRoleCardinality(String roleName)
      Returns the number of MBeans currently referenced in the given role.
      RoleResult getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      void handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      Boolean isInRelationService()
      Returns an internal flag specifying if the object is still handled by the Relation Service.
      void postDeregister()
      Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the MBean to perform any operations it needs before being registered in the MBean Server.
      RoleList retrieveAllRoles()
      Returns all roles in the relation without checking read mode.
      void setRelationServiceManagementFlag(Boolean flag)
      Specifies whether this relation is handled by the Relation Service.
      void setRole(Role role)
      Sets the given role.
      RoleResult setRoles(RoleList list)
      Sets the given roles.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RelationSupport

        public RelationSupport(String relationId,
               ObjectName relationServiceName,
               String relationTypeName,
               RoleList list)
                throws InvalidRoleValueException,
                       IllegalArgumentException
        Creates a RelationSupport object.

        This constructor has to be used when the RelationSupport object will be registered as a MBean by the user, or when creating a user relation MBean whose class extends RelationSupport.

        Nothing is done at the Relation Service level, i.e. the RelationSupport object is not added to the RelationService and no checks are performed to see if the provided values are correct. The object is always created, EXCEPT if:

        - any of the required parameters is null.

        - the same name is used for two roles.

        To be handled as a relation, the RelationSupport object has to be added to the Relation Service using the Relation Service method addRelation().

        参数：
        relationId - relation identifier, to identify the relation in the Relation Service.

        Expected to be unique in the given Relation Service.

        relationServiceName - ObjectName of the Relation Service where the relation will be registered.

        This parameter is required as it is the Relation Service that is aware of the definition of the relation type of the given relation, so that will be able to check update operations (set).

        relationTypeName - Name of relation type.

        Expected to have been created in the given Relation Service.

        list - list of roles (Role objects) to initialize the relation. Can be null.

        Expected to conform to relation info in associated relation type.

        抛出：
        InvalidRoleValueException - if the same name is used for two roles.
        IllegalArgumentException - if any of the required parameters (relation id, relation service ObjectName, or relation type name) is null.

      • RelationSupport

        public RelationSupport(String relationId,
               ObjectName relationServiceName,
               MBeanServer relationServiceMBeanServer,
               String relationTypeName,
               RoleList list)
                throws InvalidRoleValueException,
                       IllegalArgumentException
        Creates a RelationSupport object.

        This constructor has to be used when the user relation MBean implements the interfaces expected to be supported by a relation by delegating to a RelationSupport object.

        This object needs to know the Relation Service expected to handle the relation. So it has to know the MBean Server where the Relation Service is registered.

        According to a limitation, a relation MBean must be registered in the same MBean Server as the Relation Service expected to handle it. So the user relation MBean has to be created and registered, and then the wrapped RelationSupport object can be created within the identified MBean Server.

        Nothing is done at the Relation Service level, i.e. the RelationSupport object is not added to the RelationService and no checks are performed to see if the provided values are correct. The object is always created, EXCEPT if:

        - any of the required parameters is null.

        - the same name is used for two roles.

        To be handled as a relation, the RelationSupport object has to be added to the Relation Service using the Relation Service method addRelation().

        参数：
        relationId - relation identifier, to identify the relation in the Relation Service.

        Expected to be unique in the given Relation Service.

        relationServiceName - ObjectName of the Relation Service where the relation will be registered.

        This parameter is required as it is the Relation Service that is aware of the definition of the relation type of the given relation, so that will be able to check update operations (set).

        relationServiceMBeanServer - MBean Server where the wrapping MBean is or will be registered.

        Expected to be the MBean Server where the Relation Service is or will be registered.

        relationTypeName - Name of relation type.

        Expected to have been created in the given Relation Service.

        list - list of roles (Role objects) to initialize the relation. Can be null.

        Expected to conform to relation info in associated relation type.

        抛出：
        InvalidRoleValueException - if the same name is used for two roles.
        IllegalArgumentException - if any of the required parameters (relation id, relation service ObjectName, relation service MBeanServer, or relation type name) is null.

    • 方法详细信息

      • getRole

        public List<ObjectName> getRole(String roleName)
                         throws IllegalArgumentException,
                                RoleNotFoundException,
                                RelationServiceNotRegisteredException
        Retrieves role value for given role name.

        Checks if the role exists and is readable according to the relation type.

        指定者：
        getRole in interface Relation
        参数：
        roleName - name of role
        返回：
        the ArrayList of ObjectName objects being the role value
        抛出：
        IllegalArgumentException - if null role name
        RoleNotFoundException - if:

        - there is no role with given name

        - the role is not readable.

        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        另请参见：
        setRole(javax.management.relation.Role)

      • getRoles

        public RoleResult getRoles(String[] roleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
        Retrieves values of roles with given names.

        Checks for each role if it exists and is readable according to the relation type.

        指定者：
        getRoles in interface Relation
        参数：
        roleNameArray - array of names of roles to be retrieved
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
        抛出：
        IllegalArgumentException - if null role name
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        另请参见：
        setRoles(javax.management.relation.RoleList)

      • getAllRoles

        public RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
        Returns all roles present in the relation.
        指定者：
        getAllRoles in interface Relation
        返回：
        a RoleResult object, including a RoleList (for roles successfully retrieved) and a RoleUnresolvedList (for roles not readable).
        抛出：
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

      • retrieveAllRoles

        public RoleList retrieveAllRoles()
        Returns all roles in the relation without checking read mode.
        指定者：
        retrieveAllRoles in interface Relation
        返回：
        a RoleList

      • getRoleCardinality

        public Integer getRoleCardinality(String roleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
        Returns the number of MBeans currently referenced in the given role.
        指定者：
        getRoleCardinality in interface Relation
        参数：
        roleName - name of role
        返回：
        the number of currently referenced MBeans in that role
        抛出：
        IllegalArgumentException - if null role name
        RoleNotFoundException - if there is no role with given name

      • setRole

        public void setRole(Role role)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
        Sets the given role.

        Will check the role according to its corresponding role definition provided in relation's relation type

        Will send a notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not).

        指定者：
        setRole in interface Relation
        参数：
        role - role to be set (name and new value)
        抛出：
        IllegalArgumentException - if null role
        RoleNotFoundException - if there is no role with the supplied role's name or if the role is not writable (no test on the write access mode performed when initializing the role)
        InvalidRoleValueException - if value provided for role is not valid, i.e.:

        - the number of referenced MBeans in given value is less than expected minimum degree

        - the number of referenced MBeans in provided value exceeds expected maximum degree

        - one referenced MBean in the value is not an Object of the MBean class expected for that role

        - a MBean provided for that role does not exist

        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service
        RelationNotFoundException - if the relation has not been added in the Relation Service.
        另请参见：
        getRole(java.lang.String)

      • setRoles

        public RoleResult setRoles(RoleList list)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
        Sets the given roles.

        Will check the role according to its corresponding role definition provided in relation's relation type

        Will send one notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not) per updated role.

        指定者：
        setRoles in interface Relation
        参数：
        list - list of roles to be set
        返回：
        a RoleResult object, including a RoleList (for roles successfully set) and a RoleUnresolvedList (for roles not set).
        抛出：
        IllegalArgumentException - if null role list
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
        RelationNotFoundException - if the relation MBean has not been added in the Relation Service.
        另请参见：
        getRoles(java.lang.String[])

      • handleMBeanUnregistration

        public void handleMBeanUnregistration(ObjectName objectName,
                             String roleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
        Callback used by the Relation Service when a MBean referenced in a role is unregistered.

        The Relation Service will call this method to let the relation take action to reflect the impact of such unregistration.

        BEWARE. the user is not expected to call this method.

        Current implementation is to set the role with its current value (list of ObjectNames of referenced MBeans) without the unregistered one.

        指定者：
        handleMBeanUnregistration in interface Relation
        参数：
        objectName - ObjectName of unregistered MBean
        roleName - name of role where the MBean is referenced
        抛出：
        IllegalArgumentException - if null parameter
        RoleNotFoundException - if role does not exist in the relation or is not writable
        InvalidRoleValueException - if role value does not conform to the associated role info (this will never happen when called from the Relation Service)
        RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
        RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
        RelationNotFoundException - if this method is called for a relation MBean not added in the Relation Service.

      • getReferencedMBeans

        public Map<ObjectName,List<String>> getReferencedMBeans()
        Retrieves MBeans referenced in the various roles of the relation.
        指定者：
        getReferencedMBeans in interface Relation
        返回：
        a HashMap mapping:

        ObjectName -> ArrayList of String (role names)

      • getRelationTypeName

        public String getRelationTypeName()
        Returns name of associated relation type.
        指定者：
        getRelationTypeName in interface Relation
        返回：
        the name of the relation type.

      • getRelationServiceName

        public ObjectName getRelationServiceName()
        Returns ObjectName of the Relation Service handling the relation.
        指定者：
        getRelationServiceName in interface Relation
        返回：
        the ObjectName of the Relation Service.

      • getRelationId

        public String getRelationId()
        Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
        指定者：
        getRelationId in interface Relation
        返回：
        the relation id.

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations it needs before being registered in the MBean Server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean Server.
        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean Server in which the MBean will be registered.
        name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
        返回：
        The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
        抛出：
        Exception - This exception will be caught by the MBean Server and re-thrown as an MBeanRegistrationException.

      • postRegister

        public void postRegister(Boolean registrationDone)
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postRegister will not change the state of the MBean: if the MBean was already registered (registrationDone is true), the MBean will remain registered.

        This might be confusing for the code calling createMBean() or registerMBean(), as such code might assume that MBean registration has failed when such an exception is raised. Therefore it is recommended that implementations of postRegister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postDeregister

        public void postDeregister()
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postDeregister will not change the state of the MBean: the MBean was already successfully deregistered and will remain so.

        This might be confusing for the code calling unregisterMBean(), as it might assume that MBean deregistration has failed. Therefore it is recommended that implementations of postDeregister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postDeregister in interface MBeanRegistration

      • isInRelationService

        public Boolean isInRelationService()
        Returns an internal flag specifying if the object is still handled by the Relation Service.
        指定者：
        isInRelationService in interface RelationSupportMBean
        返回：
        a Boolean equal to Boolean.TRUE if the object is still handled by the Relation Service and Boolean.FALSE otherwise.

      • setRelationServiceManagementFlag

        public void setRelationServiceManagementFlag(Boolean flag)
                                      throws IllegalArgumentException
        从接口复制的描述： RelationSupportMBean

        Specifies whether this relation is handled by the Relation Service.

        BEWARE, this method has to be exposed as the Relation Service will access the relation through its management interface. It is RECOMMENDED NOT to use this method. Using it does not affect the registration of the relation object in the Relation Service, but will provide wrong information about it!

        指定者：
        setRelationServiceManagementFlag in interface RelationSupportMBean
        参数：
        flag - whether the relation is handled by the Relation Service.
        抛出：
        IllegalArgumentException - if null parameter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cr /v


RelationSupportMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.relation

Interface RelationSupportMBean

  • All Superinterfaces:
    Relation
    All Known Implementing Classes:
    RelationSupport

    public interface RelationSupportMBean
extends Relation
    A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type. As internal representation, it is not exposed to the user.

    RelationSupport class conforms to the design patterns of standard MBean. So the user can decide to instantiate a RelationSupport object himself as a MBean (as it follows the MBean design patterns), to register it in the MBean Server, and then to add it in the Relation Service.

    The user can also, when creating his own MBean relation class, have it extending RelationSupport, to retrieve the implementations of required interfaces (see below).

    It is also possible to have in a user relation MBean class a member being a RelationSupport object, and to implement the required interfaces by delegating all to this member.

    RelationSupport implements the Relation interface (to be handled by the Relation Service).

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Boolean isInRelationService()
      Returns an internal flag specifying if the object is still handled by the Relation Service.
      void setRelationServiceManagementFlag(Boolean flag)
      Specifies whether this relation is handled by the Relation Service.

      • 方法 - 继承于接口 javax.management.relation.Relation

        getAllRoles, getReferencedMBeans, getRelationId, getRelationServiceName, getRelationTypeName, getRole, getRoleCardinality, getRoles, handleMBeanUnregistration, retrieveAllRoles, setRole, setRoles

    • 方法详细信息

      • isInRelationService

        Boolean isInRelationService()
        Returns an internal flag specifying if the object is still handled by the Relation Service.
        返回：
        a Boolean equal to Boolean.TRUE if the object is still handled by the Relation Service and Boolean.FALSE otherwise.

      • setRelationServiceManagementFlag

        void setRelationServiceManagementFlag(Boolean flag)
                                      throws IllegalArgumentException

        Specifies whether this relation is handled by the Relation Service.

        BEWARE, this method has to be exposed as the Relation Service will access the relation through its management interface. It is RECOMMENDED NOT to use this method. Using it does not affect the registration of the relation object in the Relation Service, but will provide wrong information about it!

        参数：
        flag - whether the relation is handled by the Relation Service.
        抛出：
        IllegalArgumentException - if null parameter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v" /raaraaNmmaNN;>ggs>ea/alraa.r..rl


RelationType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.relation

Interface RelationType

  • All Superinterfaces:
    Serializable
    All Known Implementing Classes:
    RelationTypeSupport

    public interface RelationType
extends Serializable
    The RelationType interface has to be implemented by any class expected to represent a relation type.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getRelationTypeName()
      Returns the relation type name.
      RoleInfo getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      List<RoleInfo> getRoleInfos()
      Returns the list of role definitions (ArrayList of RoleInfo objects).

    • 方法详细信息

      • getRelationTypeName

        String getRelationTypeName()
        Returns the relation type name.
        返回：
        the relation type name.

      • getRoleInfos

        List<RoleInfo> getRoleInfos()
        Returns the list of role definitions (ArrayList of RoleInfo objects).
        返回：
        an ArrayList of RoleInfo.

      • getRoleInfo

        RoleInfo getRoleInfo(String roleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
        Returns the role info (RoleInfo object) for the given role info name (null if not found).
        参数：
        roleInfoName - role info name
        返回：
        RoleInfo object providing role definition does not exist
        抛出：
        IllegalArgumentException - if null parameter
        RoleInfoNotFoundException - if no role info with that name in relation type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

loa./...c..alclsl.<<架t简�/>�>/=�


RelationTypeNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RelationTypeNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.RelationTypeNotFoundException
  • 所有已实现的接口：
    Serializable

    public class RelationTypeNotFoundException
extends RelationException
    This exception is raised when there is no relation type with given name in Relation Service.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RelationTypeNotFoundException()
      Default constructor, no message put in exception.
      RelationTypeNotFoundException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RelationTypeNotFoundException

        public RelationTypeNotFoundException()
        Default constructor, no message put in exception.

      • RelationTypeNotFoundException

        public RelationTypeNotFoundException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iaeleleae=blkaflla�/tw/:epfu=pp"e


RelationTypeSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RelationTypeSupport

  • java.lang.Object
    • javax.management.relation.RelationTypeSupport
  • 所有已实现的接口：
    Serializable, RelationType

    public class RelationTypeSupport
extends Object
implements RelationType
    A RelationTypeSupport object implements the RelationType interface.

    It represents a relation type, providing role information for each role expected to be supported in every relation of that type.

    A relation type includes a relation type name and a list of role infos (represented by RoleInfo objects).

    A relation type has to be declared in the Relation Service:

    - either using the createRelationType() method, where a RelationTypeSupport object will be created and kept in the Relation Service

    - either using the addRelationType() method where the user has to create an object implementing the RelationType interface, and this object will be used as representing a relation type in the Relation Service.

    The serialVersionUID of this class is 4611072955724144607L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected RelationTypeSupport(String relationTypeName)
      Constructor to be used for subclasses.
        RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
      Constructor where all role definitions are dynamically created and passed as parameter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addRoleInfo(RoleInfo roleInfo)
      Add a role info.
      String getRelationTypeName()
      Returns the relation type name.
      RoleInfo getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      List<RoleInfo> getRoleInfos()
      Returns the list of role definitions (ArrayList of RoleInfo objects).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RelationTypeSupport

        public RelationTypeSupport(String relationTypeName,
                   RoleInfo[] roleInfoArray)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
        Constructor where all role definitions are dynamically created and passed as parameter.
        参数：
        relationTypeName - Name of relation type
        roleInfoArray - List of role definitions (RoleInfo objects)
        抛出：
        IllegalArgumentException - if null parameter
        InvalidRelationTypeException - if:

        - the same name has been used for two different roles

        - no role info provided

        - one null role info provided

      • RelationTypeSupport

        protected RelationTypeSupport(String relationTypeName)
        Constructor to be used for subclasses.
        参数：
        relationTypeName - Name of relation type.
        抛出：
        IllegalArgumentException - if null parameter.

    • 方法详细信息

      • getRelationTypeName

        public String getRelationTypeName()
        Returns the relation type name.
        指定者：
        getRelationTypeName in interface RelationType
        返回：
        the relation type name.

      • getRoleInfos

        public List<RoleInfo> getRoleInfos()
        Returns the list of role definitions (ArrayList of RoleInfo objects).
        指定者：
        getRoleInfos in interface RelationType
        返回：
        an ArrayList of RoleInfo.

      • getRoleInfo

        public RoleInfo getRoleInfo(String roleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
        Returns the role info (RoleInfo object) for the given role info name (null if not found).
        指定者：
        getRoleInfo in interface RelationType
        参数：
        roleInfoName - role info name
        返回：
        RoleInfo object providing role definition does not exist
        抛出：
        IllegalArgumentException - if null parameter
        RoleInfoNotFoundException - if no role info with that name in relation type.

      • addRoleInfo

        protected void addRoleInfo(RoleInfo roleInfo)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
        Add a role info. This method of course should not be used after the creation of the relation type, because updating it would invalidate that the relations created associated to that type still conform to it. Can throw a RuntimeException if trying to update a relation type declared in the Relation Service.
        参数：
        roleInfo - role info to be added.
        抛出：
        IllegalArgumentException - if null parameter.
        InvalidRelationTypeException - if there is already a role info in current relation type with the same name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e/csern.r鯽e


Role

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 Role

  • java.lang.Object
    • javax.management.relation.Role
  • 所有已实现的接口：
    Serializable

    public class Role
extends Object
implements Serializable
    Represents a role: includes a role name and referenced MBeans (via their ObjectNames). The role value is always represented as an ArrayList collection (of ObjectNames) to homogenize the access.

    The serialVersionUID of this class is -279985518429862552L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Role(String roleName, List<ObjectName> roleValue)
      Make a new Role object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Clone the role object.
      String getRoleName()
      Retrieves role name.
      List<ObjectName> getRoleValue()
      Retrieves role value.
      static String roleValueToString(List<ObjectName> roleValue)
      Returns a string for the given role value.
      void setRoleName(String roleName)
      Sets role name.
      void setRoleValue(List<ObjectName> roleValue)
      Sets role value.
      String toString()
      Returns a string describing the role.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Role

        public Role(String roleName,
    List<ObjectName> roleValue)
     throws IllegalArgumentException

        Make a new Role object. No check is made that the ObjectNames in the role value exist in an MBean server. That check will be made when the role is set in a relation.

        参数：
        roleName - role name
        roleValue - role value (List of ObjectName objects)
        抛出：
        IllegalArgumentException - if null parameter

    • 方法详细信息

      • getRoleName

        public String getRoleName()
        Retrieves role name.
        返回：
        the role name.
        另请参见：
        setRoleName(java.lang.String)

      • getRoleValue

        public List<ObjectName> getRoleValue()
        Retrieves role value.
        返回：
        ArrayList of ObjectName objects for referenced MBeans.
        另请参见：
        setRoleValue(java.util.List)

      • setRoleName

        public void setRoleName(String roleName)
                 throws IllegalArgumentException
        Sets role name.
        参数：
        roleName - role name
        抛出：
        IllegalArgumentException - if null parameter
        另请参见：
        getRoleName()

      • setRoleValue

        public void setRoleValue(List<ObjectName> roleValue)
                  throws IllegalArgumentException
        Sets role value.
        参数：
        roleValue - List of ObjectName objects for referenced MBeans.
        抛出：
        IllegalArgumentException - if null parameter
        另请参见：
        getRoleValue()

      • toString

        public String toString()
        Returns a string describing the role.
        重载：
        toString in class Object
        返回：
        the description of the role.

      • clone

        public Object clone()
        Clone the role object.
        重载：
        clone in class Object
        返回：
        a Role that is an independent copy of the current Role object.
        另请参见：
        Cloneable

      • roleValueToString

        public static String roleValueToString(List<ObjectName> roleValue)
                                throws IllegalArgumentException
        Returns a string for the given role value.
        参数：
        roleValue - List of ObjectName objects
        返回：
        A String consisting of the ObjectNames separated by newlines (\n).
        抛出：
        IllegalArgumentException - if null parameter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

|a&&e&>&;&dbp;|bps<< "> ---c/p <<>>ls/


RoleInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleInfo

  • java.lang.Object
    • javax.management.relation.RoleInfo
  • 所有已实现的接口：
    Serializable

    public class RoleInfo
extends Object
implements Serializable
    A RoleInfo object summarises a role in a relation type.

    The serialVersionUID of this class is 2504952983494636987L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ROLE_CARDINALITY_INFINITY
      To specify an unlimited cardinality.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleInfo(RoleInfo roleInfo)
      Copy constructor.
      RoleInfo(String roleName, String mbeanClassName)
      Constructor.
      RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
      Constructor.
      RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
      Constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean checkMaxDegree(int value)
      Returns true if the value parameter is lower than or equal to the expected maximum degree, false otherwise.
      boolean checkMinDegree(int value)
      Returns true if the value parameter is greater than or equal to the expected minimum degree, false otherwise.
      String getDescription()
      Returns description text for the role.
      int getMaxDegree()
      Returns maximum degree for corresponding role reference.
      int getMinDegree()
      Returns minimum degree for corresponding role reference.
      String getName()
      Returns the name of the role.
      String getRefMBeanClassName()
      Returns name of type of MBean expected to be referenced in corresponding role.
      boolean isReadable()
      Returns read access mode for the role (true if it is readable).
      boolean isWritable()
      Returns write access mode for the role (true if it is writable).
      String toString()
      Returns a string describing the role info.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ROLE_CARDINALITY_INFINITY

        public static final int ROLE_CARDINALITY_INFINITY
        To specify an unlimited cardinality.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • RoleInfo

        public RoleInfo(String roleName,
        String mbeanClassName,
        boolean read,
        boolean write,
        int min,
        int max,
        String descr)
         throws IllegalArgumentException,
                InvalidRoleInfoException,
                ClassNotFoundException,
                NotCompliantMBeanException
        Constructor.
        参数：
        roleName - name of the role.
        mbeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, mbeanClassName).
        read - flag to indicate if the corresponding role can be read
        write - flag to indicate if the corresponding role can be set
        min - minimum degree for role, i.e. minimum number of MBeans to provide in corresponding role Must be less than or equal to max. (ROLE_CARDINALITY_INFINITY for unlimited)
        max - maximum degree for role, i.e. maximum number of MBeans to provide in corresponding role Must be greater than or equal to min (ROLE_CARDINALITY_INFINITY for unlimited)
        descr - description of the role (can be null)
        抛出：
        IllegalArgumentException - if null parameter
        InvalidRoleInfoException - if the minimum degree is greater than the maximum degree.
        ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
        NotCompliantMBeanException - if the class mbeanClassName is not a MBean class.

      • RoleInfo

        public RoleInfo(String roleName,
        String mbeanClassName,
        boolean read,
        boolean write)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
        Constructor.
        参数：
        roleName - name of the role
        mbeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, mbeanClassName).
        read - flag to indicate if the corresponding role can be read
        write - flag to indicate if the corresponding role can be set

        Minimum and maximum degrees defaulted to 1.

        Description of role defaulted to null.

        抛出：
        IllegalArgumentException - if null parameter
        ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
        NotCompliantMBeanException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.

      • RoleInfo

        public RoleInfo(String roleName,
        String mbeanClassName)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
        Constructor.
        参数：
        roleName - name of the role
        mbeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, mbeanClassName).

        IsReadable and IsWritable defaulted to true.

        Minimum and maximum degrees defaulted to 1.

        Description of role defaulted to null.

        抛出：
        IllegalArgumentException - if null parameter
        ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
        NotCompliantMBeanException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.

      • RoleInfo

        public RoleInfo(RoleInfo roleInfo)
         throws IllegalArgumentException
        Copy constructor.
        参数：
        roleInfo - the RoleInfo instance to be copied.
        抛出：
        IllegalArgumentException - if null parameter

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of the role.
        返回：
        the name of the role.

      • isReadable

        public boolean isReadable()
        Returns read access mode for the role (true if it is readable).
        返回：
        true if the role is readable.

      • isWritable

        public boolean isWritable()
        Returns write access mode for the role (true if it is writable).
        返回：
        true if the role is writable.

      • getDescription

        public String getDescription()
        Returns description text for the role.
        返回：
        the description of the role.

      • getMinDegree

        public int getMinDegree()
        Returns minimum degree for corresponding role reference.
        返回：
        the minimum degree.

      • getMaxDegree

        public int getMaxDegree()
        Returns maximum degree for corresponding role reference.
        返回：
        the maximum degree.

      • getRefMBeanClassName

        public String getRefMBeanClassName()

        Returns name of type of MBean expected to be referenced in corresponding role.

        返回：
        the name of the referenced type.

      • checkMinDegree

        public boolean checkMinDegree(int value)
        Returns true if the value parameter is greater than or equal to the expected minimum degree, false otherwise.
        参数：
        value - the value to be checked
        返回：
        true if greater than or equal to minimum degree, false otherwise.

      • checkMaxDegree

        public boolean checkMaxDegree(int value)
        Returns true if the value parameter is lower than or equal to the expected maximum degree, false otherwise.
        参数：
        value - the value to be checked
        返回：
        true if lower than or equal to maximum degree, false otherwise.

      • toString

        public String toString()
        Returns a string describing the role info.
        重载：
        toString in class Object
        返回：
        a description of the role info.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

te9衝籵eanim觬=宦ng�.宥b>eorsl


RoleInfoNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RoleInfoNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.RoleInfoNotFoundException
  • 所有已实现的接口：
    Serializable

    public class RoleInfoNotFoundException
extends RelationException
    This exception is raised when there is no role info with given name in a given relation type.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleInfoNotFoundException()
      Default constructor, no message put in exception.
      RoleInfoNotFoundException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RoleInfoNotFoundException

        public RoleInfoNotFoundException()
        Default constructor, no message put in exception.

      • RoleInfoNotFoundException

        public RoleInfoNotFoundException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. .e a/


RoleList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleList

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.ArrayList<Object>
          • javax.management.relation.RoleList
  • 所有已实现的接口：
    Serializable, Cloneable, Iterable<Object>, Collection<Object>, List<Object>, RandomAccess

    public class RoleList
extends ArrayList<Object>
    A RoleList represents a list of roles (Role objects). It is used as parameter when creating a relation, and when trying to set several roles in a relation (via 'setRoles()' method). It is returned as part of a RoleResult, to provide roles successfully retrieved.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleList()
      Constructs an empty RoleList.
      RoleList(int initialCapacity)
      Constructs an empty RoleList with the initial capacity specified.
      RoleList(List<Role> list)
      Constructs a RoleList containing the elements of the List specified, in the order in which they are returned by the List's iterator.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int index, Object element)
      Inserts the specified element at the specified position in this list.
      void add(int index, Role role)
      Inserts the role specified as an element at the position specified.
      boolean add(Object o)
      Appends the specified element to the end of this list.
      void add(Role role)
      Adds the Role specified as the last element of the list.
      boolean addAll(Collection<?> c)
      Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
      boolean addAll(int index, Collection<?> c)
      Inserts all of the elements in the specified collection into this list, starting at the specified position.
      boolean addAll(int index, RoleList roleList)
      Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
      boolean addAll(RoleList roleList)
      Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
      List<Role> asList()
      Return a view of this list as a List<Role>.
      Object set(int index, Object element)
      Replaces the element at the specified position in this list with the specified element.
      void set(int index, Role role)
      Sets the element at the position specified to be the role specified.

      • 方法 - 继承于类 java.util.ArrayList

        clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, removeRange, retainAll, size, subList, toArray, toArray, trimToSize

      • 方法 - 继承于类 java.util.AbstractList

        equals, hashCode

      • 方法 - 继承于类 java.util.AbstractCollection

        containsAll, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.util.List

        containsAll, equals, hashCode

    • 构造方法详细信息

      • RoleList

        public RoleList()
        Constructs an empty RoleList.

      • RoleList

        public RoleList(int initialCapacity)
        Constructs an empty RoleList with the initial capacity specified.
        参数：
        initialCapacity - initial capacity

      • RoleList

        public RoleList(List<Role> list)
         throws IllegalArgumentException
        Constructs a RoleList containing the elements of the List specified, in the order in which they are returned by the List's iterator. The RoleList instance has an initial capacity of 110% of the size of the List specified.
        参数：
        list - the List that defines the initial contents of the new RoleList.
        抛出：
        IllegalArgumentException - if the list parameter is null or if the list parameter contains any non-Role objects.
        另请参见：
        ArrayList.ArrayList(java.util.Collection)

    • 方法详细信息

      • asList

        public List<Role> asList()
        Return a view of this list as a List<Role>. Changes to the returned value are reflected by changes to the original RoleList and vice versa.
        返回：
        a List<Role> whose contents reflect the contents of this RoleList.

        If this method has ever been called on a given RoleList instance, a subsequent attempt to add an object to that instance which is not a Role will fail with an IllegalArgumentException. For compatibility reasons, a RoleList on which this method has never been called does allow objects other than Roles to be added.

        抛出：
        IllegalArgumentException - if this RoleList contains an element that is not a Role.
        从以下版本开始：
        1.6

      • add

        public void add(Role role)
         throws IllegalArgumentException
        Adds the Role specified as the last element of the list.
        参数：
        role - the role to be added.
        抛出：
        IllegalArgumentException - if the role is null.

      • add

        public void add(int index,
       Role role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
        Inserts the role specified as an element at the position specified. Elements with an index greater than or equal to the current position are shifted up.
        参数：
        index - The position in the list where the new Role object is to be inserted.
        role - The Role object to be inserted.
        抛出：
        IllegalArgumentException - if the role is null.
        IndexOutOfBoundsException - if accessing with an index outside of the list.

      • set

        public void set(int index,
       Role role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
        Sets the element at the position specified to be the role specified. The previous element at that position is discarded.
        参数：
        index - The position specified.
        role - The value to which the role element should be set.
        抛出：
        IllegalArgumentException - if the role is null.
        IndexOutOfBoundsException - if accessing with an index outside of the list.

      • addAll

        public boolean addAll(RoleList roleList)
               throws IndexOutOfBoundsException
        Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
        参数：
        roleList - Elements to be inserted into the list (can be null)
        返回：
        true if this list changed as a result of the call.
        抛出：
        IndexOutOfBoundsException - if accessing with an index outside of the list.
        另请参见：
        ArrayList.addAll(Collection)

      • addAll

        public boolean addAll(int index,
             RoleList roleList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
        Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
        参数：
        index - Position at which to insert the first element from the RoleList specified.
        roleList - Elements to be inserted into the list.
        返回：
        true if this list changed as a result of the call.
        抛出：
        IllegalArgumentException - if the role is null.
        IndexOutOfBoundsException - if accessing with an index outside of the list.
        另请参见：
        ArrayList.addAll(int, Collection)

      • add

        public boolean add(Object o)
        Description copied from class: ArrayList
        Appends the specified element to the end of this list.
        指定者：
        add in interface Collection<Object>
        指定者：
        add in interface List<Object>
        重载：
        add in class ArrayList<Object>
        参数：
        o - element to be appended to this list
        返回：
        true (as specified by Collection.add(E))

      • add

        public void add(int index,
       Object element)
        Description copied from class: ArrayList
        Inserts the specified element at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
        指定者：
        add in interface List<Object>
        重载：
        add in class ArrayList<Object>
        参数：
        index - index at which the specified element is to be inserted
        element - element to be inserted

      • addAll

        public boolean addAll(Collection<?> c)
        Description copied from class: ArrayList
        Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (This implies that the behavior of this call is undefined if the specified collection is this list, and this list is nonempty.)
        指定者：
        addAll in interface Collection<Object>
        指定者：
        addAll in interface List<Object>
        重载：
        addAll in class ArrayList<Object>
        参数：
        c - collection containing elements to be added to this list
        返回：
        true if this list changed as a result of the call
        另请参见：
        AbstractCollection.add(Object)

      • addAll

        public boolean addAll(int index,
             Collection<?> c)
        Description copied from class: ArrayList
        Inserts all of the elements in the specified collection into this list, starting at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in the list in the order that they are returned by the specified collection's iterator.
        指定者：
        addAll in interface List<Object>
        重载：
        addAll in class ArrayList<Object>
        参数：
        index - index at which to insert the first element from the specified collection
        c - collection containing elements to be added to this list
        返回：
        true if this list changed as a result of the call

      • set

        public Object set(int index,
         Object element)
        Description copied from class: ArrayList
        Replaces the element at the specified position in this list with the specified element.
        指定者：
        set in interface List<Object>
        重载：
        set in class ArrayList<Object>
        参数：
        index - index of the element to replace
        element - element to be stored at the specified position
        返回：
        the element previously at the specified position
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RoleNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.relation

类 RoleNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.RoleNotFoundException
  • 所有已实现的接口：
    Serializable

    public class RoleNotFoundException
extends RelationException
    This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleNotFoundException()
      Default constructor, no message put in exception.
      RoleNotFoundException(String message)
      Constructor with given message put in exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RoleNotFoundException

        public RoleNotFoundException()
        Default constructor, no message put in exception.

      • RoleNotFoundException

        public RoleNotFoundException(String message)
        Constructor with given message put in exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.Rhneanlanettneenjffle>aoRR>"e >< tt>>


RoleResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleResult

  • java.lang.Object
    • javax.management.relation.RoleResult
  • 所有已实现的接口：
    Serializable

    public class RoleResult
extends Object
implements Serializable
    Represents the result of a multiple access to several roles of a relation (either for reading or writing).

    The serialVersionUID of this class is -6304063118040985512L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
      Constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      RoleList getRoles()
      Retrieves list of roles successfully accessed.
      RoleUnresolvedList getRolesUnresolved()
      Retrieves list of roles unsuccessfully accessed.
      void setRoles(RoleList list)
      Sets list of roles successfully accessed.
      void setRolesUnresolved(RoleUnresolvedList unresolvedList)
      Sets list of roles unsuccessfully accessed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RoleResult

        public RoleResult(RoleList list,
          RoleUnresolvedList unresolvedList)
        Constructor.
        参数：
        list - list of roles successfully accessed.
        unresolvedList - list of roles not accessed (with problem descriptions).

    • 方法详细信息

      • getRoles

        public RoleList getRoles()
        Retrieves list of roles successfully accessed.
        返回：
        a RoleList
        另请参见：
        setRoles(javax.management.relation.RoleList)

      • getRolesUnresolved

        public RoleUnresolvedList getRolesUnresolved()
        Retrieves list of roles unsuccessfully accessed.
        返回：
        a RoleUnresolvedList.
        另请参见：
        setRolesUnresolved(javax.management.relation.RoleUnresolvedList)

      • setRoles

        public void setRoles(RoleList list)
        Sets list of roles successfully accessed.
        参数：
        list - list of roles successfully accessed
        另请参见：
        getRoles()

      • setRolesUnresolved

        public void setRolesUnresolved(RoleUnresolvedList unresolvedList)
        Sets list of roles unsuccessfully accessed.
        参数：
        unresolvedList - list of roles unsuccessfully accessed
        另请参见：
        getRolesUnresolved()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lr"i=,rM-pi/


RoleStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleStatus

  • java.lang.Object
    • javax.management.relation.RoleStatus

  • public class RoleStatus
extends Object
    This class describes the various problems which can be encountered when accessing a role.
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int LESS_THAN_MIN_ROLE_DEGREE
      Problem type when trying to set a role value with less ObjectNames than the minimum expected cardinality.
      static int MORE_THAN_MAX_ROLE_DEGREE
      Problem type when trying to set a role value with more ObjectNames than the maximum expected cardinality.
      static int NO_ROLE_WITH_NAME
      Problem type when trying to access an unknown role.
      static int REF_MBEAN_NOT_REGISTERED
      Problem type when trying to set a role value including the ObjectName of a MBean not registered in the MBean Server.
      static int REF_MBEAN_OF_INCORRECT_CLASS
      Problem type when trying to set a role value including the ObjectName of a MBean not of the class expected for that role.
      static int ROLE_NOT_READABLE
      Problem type when trying to read a non-readable attribute.
      static int ROLE_NOT_WRITABLE
      Problem type when trying to update a non-writable attribute.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleStatus()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static boolean isRoleStatus(int status)
      Returns true if given value corresponds to a known role status, false otherwise.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NO_ROLE_WITH_NAME

        public static final int NO_ROLE_WITH_NAME
        Problem type when trying to access an unknown role.
        另请参见：
        Constant Field Values

      • ROLE_NOT_READABLE

        public static final int ROLE_NOT_READABLE
        Problem type when trying to read a non-readable attribute.
        另请参见：
        Constant Field Values

      • ROLE_NOT_WRITABLE

        public static final int ROLE_NOT_WRITABLE
        Problem type when trying to update a non-writable attribute.
        另请参见：
        Constant Field Values

      • LESS_THAN_MIN_ROLE_DEGREE

        public static final int LESS_THAN_MIN_ROLE_DEGREE
        Problem type when trying to set a role value with less ObjectNames than the minimum expected cardinality.
        另请参见：
        Constant Field Values

      • MORE_THAN_MAX_ROLE_DEGREE

        public static final int MORE_THAN_MAX_ROLE_DEGREE
        Problem type when trying to set a role value with more ObjectNames than the maximum expected cardinality.
        另请参见：
        Constant Field Values

      • REF_MBEAN_OF_INCORRECT_CLASS

        public static final int REF_MBEAN_OF_INCORRECT_CLASS
        Problem type when trying to set a role value including the ObjectName of a MBean not of the class expected for that role.
        另请参见：
        Constant Field Values

      • REF_MBEAN_NOT_REGISTERED

        public static final int REF_MBEAN_NOT_REGISTERED
        Problem type when trying to set a role value including the ObjectName of a MBean not registered in the MBean Server.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • RoleStatus

        public RoleStatus()

    • 方法详细信息

      • isRoleStatus

        public static boolean isRoleStatus(int status)
        Returns true if given value corresponds to a known role status, false otherwise.
        参数：
        status - a status code.
        返回：
        true if this value is a known role status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c aAlelman""aktvo"" nt vt/j.N /an/t


RoleUnresolved

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleUnresolved

  • java.lang.Object
    • javax.management.relation.RoleUnresolved
  • 所有已实现的接口：
    Serializable

    public class RoleUnresolved
extends Object
implements Serializable
    Represents an unresolved role: a role not retrieved from a relation due to a problem. It provides the role name, value (if problem when trying to set the role) and an integer defining the problem (constants defined in RoleStatus).

    The serialVersionUID of this class is -48350262537070138L.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleUnresolved(String name, List<ObjectName> value, int pbType)
      Constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Clone this object.
      int getProblemType()
      Retrieves problem type.
      String getRoleName()
      Retrieves role name.
      List<ObjectName> getRoleValue()
      Retrieves role value.
      void setProblemType(int pbType)
      Sets problem type.
      void setRoleName(String name)
      Sets role name.
      void setRoleValue(List<ObjectName> value)
      Sets role value.
      String toString()
      Return a string describing this object.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RoleUnresolved

        public RoleUnresolved(String name,
              List<ObjectName> value,
              int pbType)
               throws IllegalArgumentException
        Constructor.
        参数：
        name - name of the role
        value - value of the role (if problem when setting the role)
        pbType - type of problem (according to known problem types, listed as static final members).
        抛出：
        IllegalArgumentException - if null parameter or incorrect problem type

    • 方法详细信息

      • getRoleName

        public String getRoleName()
        Retrieves role name.
        返回：
        the role name.
        另请参见：
        setRoleName(java.lang.String)

      • getRoleValue

        public List<ObjectName> getRoleValue()
        Retrieves role value.
        返回：
        an ArrayList of ObjectName objects, the one provided to be set in given role. Null if the unresolved role is returned for a read access.
        另请参见：
        setRoleValue(java.util.List)

      • getProblemType

        public int getProblemType()
        Retrieves problem type.
        返回：
        an integer corresponding to a problem, those being described as static final members of current class.
        另请参见：
        setProblemType(int)

      • setRoleName

        public void setRoleName(String name)
                 throws IllegalArgumentException
        Sets role name.
        参数：
        name - the new role name.
        抛出：
        IllegalArgumentException - if null parameter
        另请参见：
        getRoleName()

      • setRoleValue

        public void setRoleValue(List<ObjectName> value)
        Sets role value.
        参数：
        value - List of ObjectName objects for referenced MBeans not set in role.
        另请参见：
        getRoleValue()

      • setProblemType

        public void setProblemType(int pbType)
                    throws IllegalArgumentException
        Sets problem type.
        参数：
        pbType - integer corresponding to a problem. Must be one of those described as static final members of current class.
        抛出：
        IllegalArgumentException - if incorrect problem type
        另请参见：
        getProblemType()

      • clone

        public Object clone()
        Clone this object.
        重载：
        clone in class Object
        返回：
        an independent clone.
        另请参见：
        Cloneable

      • toString

        public String toString()
        Return a string describing this object.
        重载：
        toString in class Object
        返回：
        a description of this RoleUnresolved object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.=l/Nma/nCaa/bhmeoorlo,=h.suk.NOlaae>o F


RoleUnresolvedList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.relation

类 RoleUnresolvedList

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractList<E>
        • java.util.ArrayList<Object>
          • javax.management.relation.RoleUnresolvedList
  • 所有已实现的接口：
    Serializable, Cloneable, Iterable<Object>, Collection<Object>, List<Object>, RandomAccess

    public class RoleUnresolvedList
extends ArrayList<Object>
    A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write) the roles.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.AbstractList

        modCount

    • 构造方法摘要

      Constructors
      构造方法与描述
      RoleUnresolvedList()
      Constructs an empty RoleUnresolvedList.
      RoleUnresolvedList(int initialCapacity)
      Constructs an empty RoleUnresolvedList with the initial capacity specified.
      RoleUnresolvedList(List<RoleUnresolved> list)
      Constructs a RoleUnresolvedList containing the elements of the List specified, in the order in which they are returned by the List's iterator.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int index, Object element)
      Inserts the specified element at the specified position in this list.
      void add(int index, RoleUnresolved role)
      Inserts the unresolved role specified as an element at the position specified.
      boolean add(Object o)
      Appends the specified element to the end of this list.
      void add(RoleUnresolved role)
      Adds the RoleUnresolved specified as the last element of the list.
      boolean addAll(Collection<?> c)
      Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
      boolean addAll(int index, Collection<?> c)
      Inserts all of the elements in the specified collection into this list, starting at the specified position.
      boolean addAll(int index, RoleUnresolvedList roleList)
      Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
      boolean addAll(RoleUnresolvedList roleList)
      Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
      List<RoleUnresolved> asList()
      Return a view of this list as a List<RoleUnresolved>.
      Object set(int index, Object element)
      Replaces the element at the specified position in this list with the specified element.
      void set(int index, RoleUnresolved role)
      Sets the element at the position specified to be the unresolved role specified.

      • 方法 - 继承于类 java.util.ArrayList

        clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, removeRange, retainAll, size, subList, toArray, toArray, trimToSize

      • 方法 - 继承于类 java.util.AbstractList

        equals, hashCode

      • 方法 - 继承于类 java.util.AbstractCollection

        containsAll, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.util.List

        containsAll, equals, hashCode

    • 构造方法详细信息

      • RoleUnresolvedList

        public RoleUnresolvedList()
        Constructs an empty RoleUnresolvedList.

      • RoleUnresolvedList

        public RoleUnresolvedList(int initialCapacity)
        Constructs an empty RoleUnresolvedList with the initial capacity specified.
        参数：
        initialCapacity - initial capacity

      • RoleUnresolvedList

        public RoleUnresolvedList(List<RoleUnresolved> list)
                   throws IllegalArgumentException
        Constructs a RoleUnresolvedList containing the elements of the List specified, in the order in which they are returned by the List's iterator. The RoleUnresolvedList instance has an initial capacity of 110% of the size of the List specified.
        参数：
        list - the List that defines the initial contents of the new RoleUnresolvedList.
        抛出：
        IllegalArgumentException - if the list parameter is null or if the list parameter contains any non-RoleUnresolved objects.
        另请参见：
        ArrayList.ArrayList(java.util.Collection)

    • 方法详细信息

      • asList

        public List<RoleUnresolved> asList()
        Return a view of this list as a List<RoleUnresolved>. Changes to the returned value are reflected by changes to the original RoleUnresolvedList and vice versa.
        返回：
        a List<RoleUnresolved> whose contents reflect the contents of this RoleUnresolvedList.

        If this method has ever been called on a given RoleUnresolvedList instance, a subsequent attempt to add an object to that instance which is not a RoleUnresolved will fail with an IllegalArgumentException. For compatibility reasons, a RoleUnresolvedList on which this method has never been called does allow objects other than RoleUnresolveds to be added.

        抛出：
        IllegalArgumentException - if this RoleUnresolvedList contains an element that is not a RoleUnresolved.
        从以下版本开始：
        1.6

      • add

        public void add(RoleUnresolved role)
         throws IllegalArgumentException
        Adds the RoleUnresolved specified as the last element of the list.
        参数：
        role - - the unresolved role to be added.
        抛出：
        IllegalArgumentException - if the unresolved role is null.

      • add

        public void add(int index,
       RoleUnresolved role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
        Inserts the unresolved role specified as an element at the position specified. Elements with an index greater than or equal to the current position are shifted up.
        参数：
        index - - The position in the list where the new RoleUnresolved object is to be inserted.
        role - - The RoleUnresolved object to be inserted.
        抛出：
        IllegalArgumentException - if the unresolved role is null.
        IndexOutOfBoundsException - if index is out of range (index < 0 || index > size()).

      • set

        public void set(int index,
       RoleUnresolved role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
        Sets the element at the position specified to be the unresolved role specified. The previous element at that position is discarded.
        参数：
        index - - The position specified.
        role - - The value to which the unresolved role element should be set.
        抛出：
        IllegalArgumentException - if the unresolved role is null.
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= size()).

      • addAll

        public boolean addAll(RoleUnresolvedList roleList)
               throws IndexOutOfBoundsException
        Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
        参数：
        roleList - - Elements to be inserted into the list (can be null).
        返回：
        true if this list changed as a result of the call.
        抛出：
        IndexOutOfBoundsException - if accessing with an index outside of the list.

      • addAll

        public boolean addAll(int index,
             RoleUnresolvedList roleList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
        Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
        参数：
        index - - Position at which to insert the first element from the RoleUnresolvedList specified.
        roleList - - Elements to be inserted into the list.
        返回：
        true if this list changed as a result of the call.
        抛出：
        IllegalArgumentException - if the role is null.
        IndexOutOfBoundsException - if index is out of range (index < 0 || index > size()).

      • add

        public boolean add(Object o)
        Description copied from class: ArrayList
        Appends the specified element to the end of this list.
        指定者：
        add in interface Collection<Object>
        指定者：
        add in interface List<Object>
        重载：
        add in class ArrayList<Object>
        参数：
        o - element to be appended to this list
        返回：
        true (as specified by Collection.add(E))

      • add

        public void add(int index,
       Object element)
        Description copied from class: ArrayList
        Inserts the specified element at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
        指定者：
        add in interface List<Object>
        重载：
        add in class ArrayList<Object>
        参数：
        index - index at which the specified element is to be inserted
        element - element to be inserted

      • addAll

        public boolean addAll(Collection<?> c)
        Description copied from class: ArrayList
        Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (This implies that the behavior of this call is undefined if the specified collection is this list, and this list is nonempty.)
        指定者：
        addAll in interface Collection<Object>
        指定者：
        addAll in interface List<Object>
        重载：
        addAll in class ArrayList<Object>
        参数：
        c - collection containing elements to be added to this list
        返回：
        true if this list changed as a result of the call
        另请参见：
        AbstractCollection.add(Object)

      • addAll

        public boolean addAll(int index,
             Collection<?> c)
        Description copied from class: ArrayList
        Inserts all of the elements in the specified collection into this list, starting at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in the list in the order that they are returned by the specified collection's iterator.
        指定者：
        addAll in interface List<Object>
        重载：
        addAll in class ArrayList<Object>
        参数：
        index - index at which to insert the first element from the specified collection
        c - collection containing elements to be added to this list
        返回：
        true if this list changed as a result of the call

      • set

        public Object set(int index,
         Object element)
        Description copied from class: ArrayList
        Replaces the element at the specified position in this list with the specified element.
        指定者：
        set in interface List<Object>
        重载：
        set in class ArrayList<Object>
        参数：
        index - index of the element to replace
        element - element to be stored at the specified position
        返回：
        the element previously at the specified position
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


Uses of Package javax.management.relation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.relation

  • Packages that use javax.management.relation
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.
  • Classes in javax.management.relation used by javax.management.relation
    类与描述
    InvalidRelationIdException
    This exception is raised when relation id provided for a relation is already used.
    InvalidRelationServiceException
    This exception is raised when an invalid Relation Service is provided.
    InvalidRelationTypeException
    Invalid relation type.
    InvalidRoleInfoException
    This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
    InvalidRoleValueException
    Role value is invalid.
    Relation
    This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.
    RelationException
    This class is the superclass of any exception which can be raised during relation management.
    RelationNotFoundException
    This exception is raised when there is no relation for a given relation id in a Relation Service.
    RelationServiceMBean
    The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
    RelationServiceNotRegisteredException
    This exception is raised when an access is done to the Relation Service and that one is not registered.
    RelationSupportMBean
    A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
    RelationType
    The RelationType interface has to be implemented by any class expected to represent a relation type.
    RelationTypeNotFoundException
    This exception is raised when there is no relation type with given name in Relation Service.
    Role
    Represents a role: includes a role name and referenced MBeans (via their ObjectNames).
    RoleInfo
    A RoleInfo object summarises a role in a relation type.
    RoleInfoNotFoundException
    This exception is raised when there is no role info with given name in a given relation type.
    RoleList
    A RoleList represents a list of roles (Role objects).
    RoleNotFoundException
    This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.
    RoleResult
    Represents the result of a multiple access to several roles of a relation (either for reading or writing).
    RoleUnresolved
    Represents an unresolved role: a role not retrieved from a relation due to a problem.
    RoleUnresolvedList
    A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write) the roles.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

efnai irefffi lljilaact>"


Uses of Class javax.management.relation.InvalidRelationIdException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.InvalidRelationIdException

  • Packages that use InvalidRelationIdException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of InvalidRelationIdException in javax.management.relation

      Methods in javax.management.relation that throw InvalidRelationIdException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ihmh


Uses of Class javax.management.relation.InvalidRelationServiceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.InvalidRelationServiceException

  • Packages that use InvalidRelationServiceException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of InvalidRelationServiceException in javax.management.relation

      Methods in javax.management.relation that throw InvalidRelationServiceException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/n./f./."...el襛�.m�>>筪


Uses of Class javax.management.relation.InvalidRelationTypeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.InvalidRelationTypeException

  • Packages that use InvalidRelationTypeException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of InvalidRelationTypeException in javax.management.relation

      Methods in javax.management.relation that throw InvalidRelationTypeException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
      void RelationService.addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
      protected void RelationTypeSupport.addRoleInfo(RoleInfo roleInfo)
      Add a role info.
      void RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      void RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      Constructors in javax.management.relation that throw InvalidRelationTypeException
      构造方法与描述
      RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
      Constructor where all role definitions are dynamically created and passed as parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pdtflIee p"飈ala


Uses of Class javax.management.relation.InvalidRoleInfoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.InvalidRoleInfoException

  • Packages that use InvalidRoleInfoException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of InvalidRoleInfoException in javax.management.relation

      Constructors in javax.management.relation that throw InvalidRoleInfoException
      构造方法与描述
      RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
      Constructor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c"tehe b yyydsnnlksb>sake


Uses of Class javax.management.relation.InvalidRoleValueException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.InvalidRoleValueException

  • Packages that use InvalidRoleValueException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of InvalidRoleValueException in javax.management.relation

      Methods in javax.management.relation that throw InvalidRoleValueException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationService.setRole(String relationId, Role role)
      Sets the given role in given relation.
      Constructors in javax.management.relation that throw InvalidRoleValueException
      构造方法与描述
      RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bole鵷o/r>a>


Uses of Class javax.management.relation.MBeanServerNotificationFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.MBeanServerNotificationFilter

No usage of javax.management.relation.MBeanServerNotificationFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esmatioRdeee#iRR<>orgt


Uses of Class javax.management.relation.RelationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationException

  • Packages that use RelationException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationException in javax.management.relation

      Subclasses of RelationException in javax.management.relation
      修饰符与类型 类与描述
      class  InvalidRelationIdException
      This exception is raised when relation id provided for a relation is already used.
      class  InvalidRelationServiceException
      This exception is raised when an invalid Relation Service is provided.
      class  InvalidRelationTypeException
      Invalid relation type.
      class  InvalidRoleInfoException
      This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
      class  InvalidRoleValueException
      Role value is invalid.
      class  RelationNotFoundException
      This exception is raised when there is no relation for a given relation id in a Relation Service.
      class  RelationServiceNotRegisteredException
      This exception is raised when an access is done to the Relation Service and that one is not registered.
      class  RelationTypeNotFoundException
      This exception is raised when there is no relation type with given name in Relation Service.
      class  RoleInfoNotFoundException
      This exception is raised when there is no role info with given name in a given relation type.
      class  RoleNotFoundException
      This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.


Uses of Class javax.management.relation.RelationNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationNotFoundException

  • Packages that use RelationNotFoundException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationNotFoundException in javax.management.relation

      Methods in javax.management.relation that throw RelationNotFoundException
      修饰符与类型 方法与描述
      RoleResult RelationServiceMBean.getAllRoles(String relationId)
      Returns all roles present in the relation.
      RoleResult RelationService.getAllRoles(String relationId)
      Returns all roles present in the relation.
      Map<ObjectName,List<String>> RelationServiceMBean.getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      Map<ObjectName,List<String>> RelationService.getReferencedMBeans(String relationId)
      Retrieves MBeans referenced in the various roles of the relation.
      String RelationServiceMBean.getRelationTypeName(String relationId)
      Returns name of associated relation type for given relation.
      String RelationService.getRelationTypeName(String relationId)
      Returns name of associated relation type for given relation.
      List<ObjectName> RelationServiceMBean.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      List<ObjectName> RelationService.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      Integer RelationServiceMBean.getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      Integer RelationService.getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      RoleResult RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      RoleResult RelationService.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      ObjectName RelationServiceMBean.isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      ObjectName RelationService.isRelationMBean(String relationId)
      If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
      void RelationServiceMBean.removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void RelationService.removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void RelationServiceMBean.sendRelationCreationNotification(String relationId)
      Sends a notification (RelationNotification) for a relation creation.
      void RelationService.sendRelationCreationNotification(String relationId)
      Sends a notification (RelationNotification) for a relation creation.
      void RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
      Sends a notification (RelationNotification) for a relation removal.
      void RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationService.setRole(String relationId, Role role)
      Sets the given role in given relation.
      RoleResult RelationSupport.setRoles(RoleList list)
      Sets the given roles.
      RoleResult Relation.setRoles(RoleList roleList)
      Sets the given roles.
      RoleResult RelationServiceMBean.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      RoleResult RelationService.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      void RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      void RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctctcodlⅹ>�


Uses of Class javax.management.relation.RelationNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationNotification

No usage of javax.management.relation.RelationNotification
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mna "cltilll"uttFs">>/


Uses of Class javax.management.relation.RelationService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationService

No usage of javax.management.relation.RelationService
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/ab;1;p-1/F


Uses of Class javax.management.relation.RelationServiceNotRegisteredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationServiceNotRegisteredException

  • Packages that use RelationServiceNotRegisteredException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationServiceNotRegisteredException in javax.management.relation

      Methods in javax.management.relation that throw RelationServiceNotRegisteredException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      RoleResult RelationSupport.getAllRoles()
      Returns all roles present in the relation.
      RoleResult Relation.getAllRoles()
      Returns all roles present in the relation.
      RoleResult RelationServiceMBean.getAllRoles(String relationId)
      Returns all roles present in the relation.
      RoleResult RelationService.getAllRoles(String relationId)
      Returns all roles present in the relation.
      List<ObjectName> RelationSupport.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> Relation.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> RelationServiceMBean.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      List<ObjectName> RelationService.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      RoleResult RelationSupport.getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      RoleResult Relation.getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      RoleResult RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      RoleResult RelationService.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void RelationServiceMBean.isActive()
      Checks if the Relation Service is active.
      void RelationService.isActive()
      Checks if the Relation Service is active.
      void RelationServiceMBean.purgeRelations()
      Purges the relations.
      void RelationService.purgeRelations()
      Purges the relations.
      void RelationServiceMBean.removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void RelationService.removeRelation(String relationId)
      Removes given relation from the Relation Service.
      void RelationServiceMBean.removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void RelationService.removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationService.setRole(String relationId, Role role)
      Sets the given role in given relation.
      RoleResult RelationSupport.setRoles(RoleList list)
      Sets the given roles.
      RoleResult Relation.setRoles(RoleList roleList)
      Sets the given roles.
      RoleResult RelationServiceMBean.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      RoleResult RelationService.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      void RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      void RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bsRo>Tmg瞨瞨>ssa>


Uses of Class javax.management.relation.RelationSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationSupport

No usage of javax.management.relation.RelationSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hleyeregeiiiduaaOet/N


Uses of Class javax.management.relation.RelationTypeNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationTypeNotFoundException

  • Packages that use RelationTypeNotFoundException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationTypeNotFoundException in javax.management.relation

      Methods in javax.management.relation that throw RelationTypeNotFoundException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      Integer RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName)
      Checks if given Role can be read in a relation of the given type.
      Integer RelationService.checkRoleReading(String roleName, String relationTypeName)
      Checks if given Role can be read in a relation of the given type.
      Integer RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      Integer RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      List<String> RelationServiceMBean.findRelationsOfType(String relationTypeName)
      Returns the relation ids for relations of the given type.
      List<String> RelationService.findRelationsOfType(String relationTypeName)
      Returns the relation ids for relations of the given type.
      RoleInfo RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role of a given relation type.
      RoleInfo RelationService.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role name of a given relation type.
      List<RoleInfo> RelationServiceMBean.getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      List<RoleInfo> RelationService.getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void RelationServiceMBean.removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void RelationService.removeRelationType(String relationTypeName)
      Removes given relation type from Relation Service.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      RoleResult RelationSupport.setRoles(RoleList list)
      Sets the given roles.
      RoleResult Relation.setRoles(RoleList roleList)
      Sets the given roles.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rh vvmno


Uses of Class javax.management.relation.RelationTypeSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RelationTypeSupport

No usage of javax.management.relation.RelationTypeSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sesdde>.c


Uses of Class javax.management.relation.Role

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.Role

  • Packages that use Role
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of Role in javax.management.relation

      Methods in javax.management.relation that return types with arguments of type Role
      修饰符与类型 方法与描述
      List<Role> RoleList.asList()
      Return a view of this list as a List<Role>.
      Methods in javax.management.relation with parameters of type Role
      修饰符与类型 方法与描述
      void RoleList.add(int index, Role role)
      Inserts the role specified as an element at the position specified.
      void RoleList.add(Role role)
      Adds the Role specified as the last element of the list.
      Integer RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      Integer RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
      Checks if given Role can be set in a relation of given type.
      void RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
      Sends a notification (RelationNotification) for a role update in the given relation.
      void RoleList.set(int index, Role role)
      Sets the element at the position specified to be the role specified.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationService.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      void RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
      Handles update of the Relation Service role map for the update of given role in given relation.
      Constructor parameters in javax.management.relation with type arguments of type Role
      构造方法与描述
      RoleList(List<Role> list)
      Constructs a RoleList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

steen eg" cvlhhnearve


Uses of Class javax.management.relation.RoleInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleInfo

  • Packages that use RoleInfo
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleInfo in javax.management.relation

      Methods in javax.management.relation that return RoleInfo
      修饰符与类型 方法与描述
      RoleInfo RelationTypeSupport.getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      RoleInfo RelationType.getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      RoleInfo RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role of a given relation type.
      RoleInfo RelationService.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role name of a given relation type.
      Methods in javax.management.relation that return types with arguments of type RoleInfo
      修饰符与类型 方法与描述
      List<RoleInfo> RelationTypeSupport.getRoleInfos()
      Returns the list of role definitions (ArrayList of RoleInfo objects).
      List<RoleInfo> RelationType.getRoleInfos()
      Returns the list of role definitions (ArrayList of RoleInfo objects).
      List<RoleInfo> RelationServiceMBean.getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      List<RoleInfo> RelationService.getRoleInfos(String relationTypeName)
      Retrieves list of role infos (RoleInfo objects) of a given relation type.
      Methods in javax.management.relation with parameters of type RoleInfo
      修饰符与类型 方法与描述
      protected void RelationTypeSupport.addRoleInfo(RoleInfo roleInfo)
      Add a role info.
      void RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      void RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
      Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
      Constructors in javax.management.relation with parameters of type RoleInfo
      构造方法与描述
      RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
      Constructor where all role definitions are dynamically created and passed as parameter.
      RoleInfo(RoleInfo roleInfo)
      Copy constructor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raei">ss d


Uses of Class javax.management.relation.RoleInfoNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleInfoNotFoundException

  • Packages that use RoleInfoNotFoundException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleInfoNotFoundException in javax.management.relation

      Methods in javax.management.relation that throw RoleInfoNotFoundException
      修饰符与类型 方法与描述
      RoleInfo RelationTypeSupport.getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      RoleInfo RelationType.getRoleInfo(String roleInfoName)
      Returns the role info (RoleInfo object) for the given role info name (null if not found).
      RoleInfo RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role of a given relation type.
      RoleInfo RelationService.getRoleInfo(String relationTypeName, String roleInfoName)
      Retrieves role info for given role name of a given relation type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.a>ati.trrrmxllex/.../v/l


Uses of Class javax.management.relation.RoleList

��ע�⣺�� java api 1.7Beta �淶���������ȶ��棬δ�����Ű汾�ĸ��������淶�����и��¡�
  • ����
  • ������
  • ��
  • ʹ��
  • ��
  • �ѹ�ʱ
  • ����
  • ����
Java™ Platform
Standard Ed. 7
�ݰ� ea-b138
  • ��һ��
  • ��һ��
  • ���
  • �޿��
  • ���е���

Uses of Class
javax.management.relation.RoleList

  • Packages that use RoleList
    ������ ����
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleList in javax.management.relation

      Methods in javax.management.relation that return RoleList
      ���η������� ����������
      RoleList RoleResult.getRoles()
      Retrieves list of roles successfully accessed.
      RoleList RelationSupport.retrieveAllRoles()
      Returns all roles in the relation without checking read mode.
      RoleList Relation.retrieveAllRoles()
      Returns all roles in the relation without checking read mode.
      Methods in javax.management.relation with parameters of type RoleList
      ���η������� ����������
      boolean RoleList.addAll(int index, RoleList roleList)
      Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
      boolean RoleList.addAll(RoleList roleList)
      Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      RoleResult RelationSupport.setRoles(RoleList list)
      Sets the given roles.
      void RoleResult.setRoles(RoleList list)
      Sets list of roles successfully accessed.
      RoleResult Relation.setRoles(RoleList roleList)
      Sets the given roles.
      RoleResult RelationServiceMBean.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      RoleResult RelationService.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      Constructors in javax.management.relation with parameters of type RoleList
      ���췽��������
      RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
      Creates a RelationSupport object.
      RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
      Constructor.
  • ����
  • ������
  • ��
  • ʹ��
  • ��
  • �ѹ�ʱ
  • ����
  • ����
Java™ Platform
Standard Ed. 7
�ݰ� ea-b138
  • ��һ��
  • ��һ��
  • ���
  • �޿��
  • ���е���

�ύ��������
�йظ���� API �ο����ϺͿ�����Ա�ĵ�������� Java SE ������Ա�ĵ�. ���ĵ���������ϸ�ġ����򿪷���Ա���������Լ�������������ﶨ�塢ʹ�ü��ɺ͹�������ʾ����
��Ȩ���� © 1993, 2011, Oracle �������˻�Ա����������Ȩ����
�ݰ� ea-b138

mRlpg//lprt �. �<;�>c�<


Uses of Class javax.management.relation.RoleNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleNotFoundException

  • Packages that use RoleNotFoundException
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleNotFoundException in javax.management.relation

      Methods in javax.management.relation that throw RoleNotFoundException
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationService.addRelation(ObjectName relationObjectName)
      Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
      void RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      void RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
      Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
      List<ObjectName> RelationSupport.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> Relation.getRole(String roleName)
      Retrieves role value for given role name.
      List<ObjectName> RelationServiceMBean.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      List<ObjectName> RelationService.getRole(String relationId, String roleName)
      Retrieves role value for given role name in given relation.
      Integer RelationSupport.getRoleCardinality(String roleName)
      Returns the number of MBeans currently referenced in the given role.
      Integer Relation.getRoleCardinality(String roleName)
      Returns the number of MBeans currently referenced in the given role.
      Integer RelationServiceMBean.getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      Integer RelationService.getRoleCardinality(String relationId, String roleName)
      Retrieves the number of MBeans currently referenced in the given role.
      void RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
      Callback used by the Relation Service when a MBean referenced in a role is unregistered.
      void RelationSupport.setRole(Role role)
      Sets the given role.
      void Relation.setRole(Role role)
      Sets the given role.
      void RelationServiceMBean.setRole(String relationId, Role role)
      Sets the given role in given relation.
      void RelationService.setRole(String relationId, Role role)
      Sets the given role in given relation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t


Uses of Class javax.management.relation.RoleResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleResult

  • Packages that use RoleResult
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleResult in javax.management.relation

      Methods in javax.management.relation that return RoleResult
      修饰符与类型 方法与描述
      RoleResult RelationSupport.getAllRoles()
      Returns all roles present in the relation.
      RoleResult Relation.getAllRoles()
      Returns all roles present in the relation.
      RoleResult RelationServiceMBean.getAllRoles(String relationId)
      Returns all roles present in the relation.
      RoleResult RelationService.getAllRoles(String relationId)
      Returns all roles present in the relation.
      RoleResult RelationSupport.getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      RoleResult Relation.getRoles(String[] roleNameArray)
      Retrieves values of roles with given names.
      RoleResult RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      RoleResult RelationService.getRoles(String relationId, String[] roleNameArray)
      Retrieves values of roles with given names in given relation.
      RoleResult RelationSupport.setRoles(RoleList list)
      Sets the given roles.
      RoleResult Relation.setRoles(RoleList roleList)
      Sets the given roles.
      RoleResult RelationServiceMBean.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
      RoleResult RelationService.setRoles(String relationId, RoleList roleList)
      Sets the given roles in given relation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dMin Salttt dCCaaat=sv ai


Uses of Class javax.management.relation.RoleStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleStatus

No usage of javax.management.relation.RoleStatus
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/sat()"oRlllAhoodp>are


Uses of Class javax.management.relation.RoleUnresolved

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleUnresolved

  • Packages that use RoleUnresolved
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleUnresolved in javax.management.relation

      Methods in javax.management.relation that return types with arguments of type RoleUnresolved
      修饰符与类型 方法与描述
      List<RoleUnresolved> RoleUnresolvedList.asList()
      Return a view of this list as a List<RoleUnresolved>.
      Methods in javax.management.relation with parameters of type RoleUnresolved
      修饰符与类型 方法与描述
      void RoleUnresolvedList.add(int index, RoleUnresolved role)
      Inserts the unresolved role specified as an element at the position specified.
      void RoleUnresolvedList.add(RoleUnresolved role)
      Adds the RoleUnresolved specified as the last element of the list.
      void RoleUnresolvedList.set(int index, RoleUnresolved role)
      Sets the element at the position specified to be the unresolved role specified.
      Constructor parameters in javax.management.relation with type arguments of type RoleUnresolved
      构造方法与描述
      RoleUnresolvedList(List<RoleUnresolved> list)
      Constructs a RoleUnresolvedList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>ptdeoo"kpad<


Uses of Class javax.management.relation.RoleUnresolvedList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.relation.RoleUnresolvedList

  • Packages that use RoleUnresolvedList
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RoleUnresolvedList in javax.management.relation

      Methods in javax.management.relation that return RoleUnresolvedList
      修饰符与类型 方法与描述
      RoleUnresolvedList RoleResult.getRolesUnresolved()
      Retrieves list of roles unsuccessfully accessed.
      Methods in javax.management.relation with parameters of type RoleUnresolvedList
      修饰符与类型 方法与描述
      boolean RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList)
      Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
      boolean RoleUnresolvedList.addAll(RoleUnresolvedList roleList)
      Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
      void RoleResult.setRolesUnresolved(RoleUnresolvedList unresolvedList)
      Sets list of roles unsuccessfully accessed.
      Constructors in javax.management.relation with parameters of type RoleUnresolvedList
      构造方法与描述
      RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
      Constructor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>>/triae<>f g


Uses of Interface javax.management.relation.Relation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.relation.Relation

  • Packages that use Relation
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of Relation in javax.management.relation

      Subinterfaces of Relation in javax.management.relation
      修饰符与类型 Interface and Description
      interface  RelationSupportMBean
      A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
      Classes in javax.management.relation that implement Relation
      修饰符与类型 类与描述
      class  RelationSupport
      A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>oaMle"ldtt>�"nn.>.


Uses of Interface javax.management.relation.RelationServiceMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.relation.RelationServiceMBean

  • Packages that use RelationServiceMBean
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationServiceMBean in javax.management.relation

      Classes in javax.management.relation that implement RelationServiceMBean
      修饰符与类型 类与描述
      class  RelationService
      The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u>ud oscJ<


Uses of Interface javax.management.relation.RelationSupportMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.relation.RelationSupportMBean

  • Packages that use RelationSupportMBean
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationSupportMBean in javax.management.relation

      Classes in javax.management.relation that implement RelationSupportMBean
      修饰符与类型 类与描述
      class  RelationSupport
      A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.s.S/"aac"/)e=觱aab


Uses of Interface javax.management.relation.RelationType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.relation.RelationType

  • Packages that use RelationType
    软件包 描述
    javax.management.relation
    Provides the definition of the Relation Service.

    • Uses of RelationType in javax.management.relation

      Classes in javax.management.relation that implement RelationType
      修饰符与类型 类与描述
      class  RelationTypeSupport
      A RelationTypeSupport object implements the RelationType interface.
      Methods in javax.management.relation with parameters of type RelationType
      修饰符与类型 方法与描述
      void RelationServiceMBean.addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
      void RelationService.addRelationType(RelationType relationTypeObj)
      Adds given object as a relation type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Fe"t ss>>ilur=/<>"v>fei


javax.management.remote

Interfaces

  • JMXAddressable
  • JMXAuthenticator
  • JMXConnector
  • JMXConnectorProvider
  • JMXConnectorServerMBean
  • JMXConnectorServerProvider
  • MBeanServerForwarder

Classes

  • JMXConnectionNotification
  • JMXConnectorFactory
  • JMXConnectorServer
  • JMXConnectorServerFactory
  • JMXPrincipal
  • JMXServiceURL
  • NotificationResult
  • SubjectDelegationPermission
  • TargetedNotification

Exceptions

  • JMXProviderException
  • JMXServerErrorException
"


javax.management.remote

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.remote

Interfaces for remote access to JMX MBean servers.

请参见： 描述

  • 接口摘要
    接口 描述
    JMXAddressable
    Implemented by objects that can have a JMXServiceURL address.
    JMXAuthenticator
    Interface to define how remote credentials are converted into a JAAS Subject.
    JMXConnector
    The client end of a JMX API connector.
    JMXConnectorProvider
    A provider for creating JMX API connector clients using a given protocol.
    JMXConnectorServerMBean
    MBean interface for connector servers.
    JMXConnectorServerProvider
    A provider for creating JMX API connector servers using a given protocol.
    MBeanServerForwarder
    An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
  • Class Summary
    类 描述
    JMXConnectionNotification
    Notification emitted when a client connection is opened or closed or when notifications are lost.
    JMXConnectorFactory
    Factory to create JMX API connector clients.
    JMXConnectorServer
    Superclass of every connector server.
    JMXConnectorServerFactory
    Factory to create JMX API connector servers.
    JMXPrincipal
    The identity of a remote client of the JMX Remote API.
    JMXServiceURL
    The address of a JMX API connector server.
    NotificationResult
    Result of a query for buffered notifications.
    SubjectDelegationPermission
    Permission required by an authentication identity to perform operations on behalf of an authorization identity.
    TargetedNotification
    A (Notification, Listener ID) pair.
  • Exception Summary
    Exception 描述
    JMXProviderException
    Exception thrown by JMXConnectorFactory and JMXConnectorServerFactory when a provider exists for the required protocol but cannot be used for some reason.
    JMXServerErrorException
    Exception thrown as the result of a remote MBeanServer method invocation when an Error is thrown while processing the invocation in the remote MBean server.

软件包 javax.management.remote Description

Interfaces for remote access to JMX MBean servers. This package defines the essential interfaces for making a JMX MBean server manageable remotely. The specification of this functionality is completed by Part III of the JMX Specification, version 1.4 PDF document.

The JMX specification defines the notion of connectors. A connector is attached to a JMX API MBean server and makes it accessible to remote Java clients. The client end of a connector exports essentially the same interface as the MBean server, specifically the MBeanServerConnection interface.

A connector makes an MBean server remotely accessible through a given protocol. The JMX Remote API allows the use of different type of connectors:

  • The JMX Remote API defines a standard connector, the RMI Connector, which provides remote access to an MBeanServer through RMI.
  • The JMX Remote API also defines an optional connector called JMXMP Connector implementing the JMX Message Protocol (JMXMP). As it is optional, it is not part of this bundle (see note below).
  • User-defined connector protocols are also possible using the JMXConnectorFactory and, optionally, the Generic Connector (not part of this bundle, see note below).

Note: the optional packages implementing the optional part of the JMX Remote API are not included in the Java SE Platform but are available from the JMX Remote API Reference Implementation.

Connector addresses

Typically, a connector server has an address, represented by the class JMXServiceURL. An address for the RMI Connector can look like this:

      service:jmx:rmi:///jndi/rmi://myhost:1099/myname

In this JMXServiceURL, the first rmi: specifies the RMI connector, while the second rmi: specifies the RMI registry into which the RMI connector server has stored its stub.

The example above shows only one form of address. An address for the RMI Connector can take several forms, as detailed in the documentation for the package javax.management.remote.rmi.

Creating a connector server

A connector server is created by constructing an instance of a subclass of JMXConnectorServer. Usually, this instance is created using the method JMXConnectorServerFactory.newJMXConnectorServer.

Typically, a connector server is associated with an MBean server either by registering it in that MBean server, or by supplying the MBean server as a parameter when creating the connector server.

Creating a connector client

A connector client is usually created by supplying the JMXServiceURL of the connector server to connect to to the JMXConnectorFactory.connect method.

For more specialized uses, a connector client can be created by directly instantiating a class that implements the JMXConnector interface, for example the class RMIConnector.

Additional client or server parameters

When creating a connector client or server, it is possible to supply an object of type Map that defines additional parameters. Each entry in this Map has a key that is a string and an associated value whose type is appropriate for that key. The standard keys defined by the JMX Remote API all begin with the string "jmx.remote.". The document JMX Remote API lists these standard keys.

Connection identifiers

Every connection opened by a connector server has a string identifier, called its connection id. This identifier appears in the JMXConnectionNotification events emitted by the connector server, in the list returned by getConnectionIds(), and in the value returned by the client's getConnectionId() method.

As an example, a connection ID can look something like this:

rmi://192.18.1.9 username 1

The formal grammar for connection ids that follow this convention is as follows (using the grammar notation from The Java Language Specification, Second Edition):

ConnectionId:
    Protocol : ClientAddressopt Space ClientIdopt Space ArbitraryText

ClientAddress:
    // HostAddress ClientPortopt

ClientPort
    : HostPort

The Protocol is a protocol that would be recognized by JMXConnectorFactory.

The ClientAddress is the address and port of the connecting client, if these can be determined, otherwise nothing. The HostAddress is the Internet address of the host that the client is connecting from, in numeric or DNS form. Numeric IPv6 addresses are enclosed in square brackets []. The HostPort is the decimal port number that the client is connecting from.

The ClientId is the identity of the client entity, typically a string returned by JMXPrincipal.getName(). This string must not contain spaces.

The ArbitraryText is any additional text that the connector server adds when creating the client id. At a minimum, it must be enough to distinguish this connection ID from the ID of any other connection currently opened by this connector server.

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology, in particular the JMX Specification, version 1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ybty lreavl;rainnnM stru l


javax.management.remote Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.remote

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.remote.JMXConnectionNotification
    • javax.management.remote.JMXConnectorFactory
    • javax.management.remote.JMXConnectorServerFactory
    • javax.management.remote.JMXPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.management.remote.JMXServiceURL (implements java.io.Serializable)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
    • javax.management.remote.NotificationResult (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.management.remote.SubjectDelegationPermission
    • javax.management.remote.TargetedNotification (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.management.remote.JMXProviderException
          • javax.management.remote.JMXServerErrorException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.management.remote.JMXConnector
  • javax.management.remote.JMXAddressable
  • javax.management.remote.JMXAuthenticator
  • javax.management.remote.JMXConnectorProvider
  • javax.management.remote.JMXConnectorServerMBean
  • javax.management.remote.JMXConnectorServerProvider
  • javax.management.MBeanServerConnection
    • javax.management.MBeanServer
      • javax.management.remote.MBeanServerForwarder
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x eicr>mmmoe /e/eeer


JMXAddressable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXAddressable

  • All Known Implementing Classes:
    JMXConnectorServer, RMIConnector, RMIConnectorServer

    public interface JMXAddressable

    Implemented by objects that can have a JMXServiceURL address. All JMXConnectorServer objects implement this interface. Depending on the connector implementation, a JMXConnector object may implement this interface too. JMXConnector objects for the RMI Connector are instances of RMIConnector which implements this interface.

    An object implementing this interface might not have an address at a given moment. This is indicated by a null return value from getAddress().

    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMXServiceURL getAddress()
      The address of this object.

    • 方法详细信息

      • getAddress

        JMXServiceURL getAddress()

        The address of this object.

        返回：
        the address of this object, or null if it does not have one.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eas


JMXAuthenticator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXAuthenticator

  • public interface JMXAuthenticator

    Interface to define how remote credentials are converted into a JAAS Subject. This interface is used by the RMI Connector Server, and can be used by other connector servers.

    The user-defined authenticator instance is passed to the connector server in the environment map as the value of the attribute JMXConnectorServer.AUTHENTICATOR. For connector servers that use only this authentication system, if this attribute is not present or its value is null then no user authentication will be performed and full access to the methods exported by the MBeanServerConnection object will be allowed.

    If authentication is successful then an authenticated subject filled in with its associated principals is returned. Authorization checks will be then performed based on the given set of principals.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Subject authenticate(Object credentials)
      Authenticates the MBeanServerConnection client with the given client credentials.

    • 方法详细信息

      • authenticate

        Subject authenticate(Object credentials)

        Authenticates the MBeanServerConnection client with the given client credentials.

        参数：
        credentials - the user-defined credentials to be passed into the server in order to authenticate the user before creating the MBeanServerConnection. The actual type of this parameter, and whether it can be null, depends on the connector.
        返回：
        the authenticated subject containing its associated principals.
        抛出：
        SecurityException - if the server cannot authenticate the user with the provided credentials.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llzgscso t C" OialrSns輑


JMXConnectionNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXConnectionNotification

  • java.lang.Object
    • java.util.EventObject
      • javax.management.Notification
        • javax.management.remote.JMXConnectionNotification
  • 所有已实现的接口：
    Serializable

    public class JMXConnectionNotification
extends Notification

    Notification emitted when a client connection is opened or closed or when notifications are lost. These notifications are sent by connector servers (instances of JMXConnectorServer) and by connector clients (instances of JMXConnector). For certain connectors, a session can consist of a sequence of connections. Connection-opened and connection-closed notifications will be sent for each one.

    The notification type is one of the following:

    Type | Meaning
    jmx.remote.connection.opened | A new client connection has been opened.
    jmx.remote.connection.closed | A client connection has been closed.
    jmx.remote.connection.failed | A client connection has failed unexpectedly.
    jmx.remote.connection.notifs.lost | A client connection has potentially lost notifications. This notification only appears on the client side.

    The timeStamp of the notification is a time value (consistent with System.currentTimeMillis()) indicating when the notification was constructed.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CLOSED
      Notification type string for a connection-closed notification.
      static String FAILED
      Notification type string for a connection-failed notification.
      static String NOTIFS_LOST
      Notification type string for a connection that has possibly lost notifications.
      static String OPENED
      Notification type string for a connection-opened notification.

      • Fields inherited from class javax.management.Notification

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
      Constructs a new connection notification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getConnectionId()
      The connection ID to which this notification pertains.

      • 方法 - 继承于类 javax.management.Notification

        getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OPENED

        public static final String OPENED

        Notification type string for a connection-opened notification.

        另请参见：
        Constant Field Values

      • CLOSED

        public static final String CLOSED

        Notification type string for a connection-closed notification.

        另请参见：
        Constant Field Values

      • FAILED

        public static final String FAILED

        Notification type string for a connection-failed notification.

        另请参见：
        Constant Field Values

      • NOTIFS_LOST

        public static final String NOTIFS_LOST

        Notification type string for a connection that has possibly lost notifications.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JMXConnectionNotification

        public JMXConnectionNotification(String type,
                         Object source,
                         String connectionId,
                         long sequenceNumber,
                         String message,
                         Object userData)
        Constructs a new connection notification. The source of the notification depends on whether it is being sent by a connector server or a connector client:
        • For a connector server, if it is registered in an MBean server, the source is the ObjectName under which it is registered. Otherwise, it is a reference to the connector server object itself, an instance of a subclass of JMXConnectorServer.
        • For a connector client, the source is a reference to the connector client object, an instance of a class implementing JMXConnector.
        参数：
        type - the type of the notification. This is usually one of the constants OPENED, CLOSED, FAILED, NOTIFS_LOST. It is not an error for it to be a different string.
        source - the connector server or client emitting the notification.
        connectionId - the ID of the connection within its connector server.
        sequenceNumber - a non-negative integer. It is expected but not required that this number will be greater than any previous sequenceNumber in a notification from this source.
        message - an unspecified text message, typically containing a human-readable description of the event. Can be null.
        userData - an object whose type and meaning is defined by the connector server. Can be null.
        抛出：
        NullPointerException - if type, source, or connectionId is null.
        IllegalArgumentException - if sequenceNumber is negative.

    • 方法详细信息

      • getConnectionId

        public String getConnectionId()

        The connection ID to which this notification pertains.

        返回：
        the connection ID.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ce nSlSeln>gy nl=eis"e=[eoeancae


JMXConnector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXConnector

  • All Superinterfaces:
    AutoCloseable, Closeable
    All Known Implementing Classes:
    RMIConnector

    public interface JMXConnector
extends Closeable

    The client end of a JMX API connector. An object of this type can be used to establish a connection to a connector server.

    A newly-created object of this type is unconnected. Its connect method must be called before it can be used. However, objects created by JMXConnectorFactory.connect are already connected.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CREDENTIALS
      Name of the attribute that specifies the credentials to send to the connector server during connection.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to be informed of changes in connection status.
      void close()
      Closes the client connection to its server.
      void connect()
      Establishes the connection to the connector server.
      void connect(Map<String,?> env)
      Establishes the connection to the connector server.
      String getConnectionId()
      Gets this connection's ID from the connector server.
      MBeanServerConnection getMBeanServerConnection()
      Returns an MBeanServerConnection object representing a remote MBean server.
      MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
      Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.
      void removeConnectionNotificationListener(NotificationListener listener)
      Removes a listener from the list to be informed of changes in status.
      void removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback)
      Removes a listener from the list to be informed of changes in status.

    • 字段详细信息

      • CREDENTIALS

        static final String CREDENTIALS

        Name of the attribute that specifies the credentials to send to the connector server during connection. The value associated with this attribute, if any, is a serializable object of an appropriate type for the server's JMXAuthenticator.

        另请参见：
        Constant Field Values

    • 方法详细信息

      • connect

        void connect()
             throws IOException

        Establishes the connection to the connector server. This method is equivalent to connect(null).

        抛出：
        IOException - if the connection could not be made because of a communication problem.
        SecurityException - if the connection could not be made for security reasons.

      • connect

        void connect(Map<String,?> env)
             throws IOException

        Establishes the connection to the connector server.

        If connect has already been called successfully on this object, calling it again has no effect. If, however, close() was called after connect, the new connect will throw an IOException.

        Otherwise, either connect has never been called on this object, or it has been called but produced an exception. Then calling connect will attempt to establish a connection to the connector server.

        参数：
        env - the properties of the connection. Properties in this map override properties in the map specified when the JMXConnector was created, if any. This parameter can be null, which is equivalent to an empty map.
        抛出：
        IOException - if the connection could not be made because of a communication problem.
        SecurityException - if the connection could not be made for security reasons.

      • getMBeanServerConnection

        MBeanServerConnection getMBeanServerConnection()
                                               throws IOException

        Returns an MBeanServerConnection object representing a remote MBean server. For a given JMXConnector, two successful calls to this method will usually return the same MBeanServerConnection object, though this is not required.

        For each method in the returned MBeanServerConnection, calling the method causes the corresponding method to be called in the remote MBean server. The value returned by the MBean server method is the value returned to the client. If the MBean server method produces an Exception, the same Exception is seen by the client. If the MBean server method, or the attempt to call it, produces an Error, the Error is wrapped in a JMXServerErrorException, which is seen by the client.

        Calling this method is equivalent to calling getMBeanServerConnection(null) meaning that no delegation subject is specified and that all the operations called on the MBeanServerConnection must use the authenticated subject, if any.

        返回：
        an object that implements the MBeanServerConnection interface by forwarding its methods to the remote MBean server.
        抛出：
        IOException - if a valid MBeanServerConnection cannot be created, for instance because the connection to the remote MBean server has not yet been established (with the connect method), or it has been closed, or it has broken.

      • getMBeanServerConnection

        MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
                                               throws IOException

        Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject. For a given JMXConnector and Subject, two successful calls to this method will usually return the same MBeanServerConnection object, though this is not required.

        For each method in the returned MBeanServerConnection, calling the method causes the corresponding method to be called in the remote MBean server on behalf of the given delegation subject instead of the authenticated subject. The value returned by the MBean server method is the value returned to the client. If the MBean server method produces an Exception, the same Exception is seen by the client. If the MBean server method, or the attempt to call it, produces an Error, the Error is wrapped in a JMXServerErrorException, which is seen by the client.

        参数：
        delegationSubject - the Subject on behalf of which requests will be performed. Can be null, in which case requests will be performed on behalf of the authenticated Subject, if any.
        返回：
        an object that implements the MBeanServerConnection interface by forwarding its methods to the remote MBean server on behalf of a given delegation subject.
        抛出：
        IOException - if a valid MBeanServerConnection cannot be created, for instance because the connection to the remote MBean server has not yet been established (with the connect method), or it has been closed, or it has broken.

      • close

        void close()
           throws IOException

        Closes the client connection to its server. Any ongoing or new request using the MBeanServerConnection returned by getMBeanServerConnection() will get an IOException.

        If close has already been called successfully on this object, calling it again has no effect. If close has never been called, or if it was called but produced an exception, an attempt will be made to close the connection. This attempt can succeed, in which case close will return normally, or it can generate an exception.

        Closing a connection is a potentially slow operation. For example, if the server has crashed, the close operation might have to wait for a network protocol timeout. Callers that do not want to block in a close operation should do it in a separate thread.

        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface Closeable
        抛出：
        IOException - if the connection cannot be closed cleanly. If this exception is thrown, it is not known whether the server end of the connection has been cleanly closed.

      • addConnectionNotificationListener

        void addConnectionNotificationListener(NotificationListener listener,
                                     NotificationFilter filter,
                                     Object handback)

        Adds a listener to be informed of changes in connection status. The listener will receive notifications of type JMXConnectionNotification. An implementation can send other types of notifications too.

        Any number of listeners can be added with this method. The same listener can be added more than once with the same or different values for the filter and handback. There is no special treatment of a duplicate entry. For example, if a listener is registered twice with no filter, then its handleNotification method will be called twice for each notification.

        参数：
        listener - a listener to receive connection status notifications.
        filter - a filter to select which notifications are to be delivered to the listener, or null if all notifications are to be delivered.
        handback - an object to be given to the listener along with each notification. Can be null.
        抛出：
        NullPointerException - if listener is null.
        另请参见：
        removeConnectionNotificationListener(javax.management.NotificationListener), NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • removeConnectionNotificationListener

        void removeConnectionNotificationListener(NotificationListener listener)
                                          throws ListenerNotFoundException

        Removes a listener from the list to be informed of changes in status. The listener must previously have been added. If there is more than one matching listener, all are removed.

        参数：
        listener - a listener to receive connection status notifications.
        抛出：
        NullPointerException - if listener is null.
        ListenerNotFoundException - if the listener is not registered with this JMXConnector.
        另请参见：
        removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object), addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • removeConnectionNotificationListener

        void removeConnectionNotificationListener(NotificationListener l,
                                        NotificationFilter f,
                                        Object handback)
                                          throws ListenerNotFoundException

        Removes a listener from the list to be informed of changes in status. The listener must previously have been added with the same three parameters. If there is more than one matching listener, only one is removed.

        参数：
        l - a listener to receive connection status notifications.
        f - a filter to select which notifications are to be delivered to the listener. Can be null.
        handback - an object to be given to the listener along with each notification. Can be null.
        抛出：
        ListenerNotFoundException - if the listener is not registered with this JMXConnector, or is not registered with the given filter and handback.
        另请参见：
        removeConnectionNotificationListener(NotificationListener), addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • getConnectionId

        String getConnectionId()
                       throws IOException

        Gets this connection's ID from the connector server. For a given connector server, every connection will have a unique id which does not change during the lifetime of the connection.

        返回：
        the unique ID of this connection. This is the same as the ID that the connector server includes in its JMXConnectionNotifications. The package description describes the conventions for connection IDs.
        抛出：
        IOException - if the connection ID cannot be obtained, for instance because the connection is closed or broken.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


JMXConnectorFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

类 JMXConnectorFactory

  • java.lang.Object
    • javax.management.remote.JMXConnectorFactory

  • public class JMXConnectorFactory
extends Object

    Factory to create JMX API connector clients. There are no instances of this class.

    Connections are usually made using the connect method of this class. More advanced applications can separate the creation of the connector client, using newJMXConnector and the establishment of the connection itself, using JMXConnector.connect(Map).

    Each client is created by an instance of JMXConnectorProvider. This instance is found as follows. Suppose the given JMXServiceURL looks like "service:jmx:protocol:remainder". Then the factory will attempt to find the appropriate JMXConnectorProvider for protocol. Each occurrence of the character + or - in protocol is replaced by . or _, respectively.

    A provider package list is searched for as follows:

    1. If the environment parameter to newJMXConnector contains the key jmx.remote.protocol.provider.pkgs then the associated value is the provider package list.
    2. Otherwise, if the system property jmx.remote.protocol.provider.pkgs exists, then its value is the provider package list.
    3. Otherwise, there is no provider package list.

    The provider package list is a string that is interpreted as a list of non-empty Java package names separated by vertical bars (|). If the string is empty, then so is the provider package list. If the provider package list is not a String, or if it contains an element that is an empty string, a JMXProviderException is thrown.

    If the provider package list exists and is not empty, then for each element pkg of the list, the factory will attempt to load the class

    pkg.protocol.ClientProvider

    If the environment parameter to newJMXConnector contains the key jmx.remote.protocol.provider.class.loader then the associated value is the class loader to use to load the provider. If the associated value is not an instance of ClassLoader, an IllegalArgumentException is thrown.

    If the jmx.remote.protocol.provider.class.loader key is not present in the environment parameter, the calling thread's context class loader is used.

    If the attempt to load this class produces a ClassNotFoundException, the search for a handler continues with the next element of the list.

    Otherwise, a problem with the provider found is signalled by a JMXProviderException whose cause indicates the underlying exception, as follows:

    • if the attempt to load the class produces an exception other than ClassNotFoundException, that is the cause;
    • if Class.newInstance() for the class produces an exception, that is the cause.

    If no provider is found by the above steps, including the default case where there is no provider package list, then the implementation will use its own provider for protocol, or it will throw a MalformedURLException if there is none. An implementation may choose to find providers by other means. For example, it may support the JAR conventions for service providers, where the service interface is JMXConnectorProvider.

    Every implementation must support the RMI connector protocols, specified with the string rmi or iiop.

    Once a provider is found, the result of the newJMXConnector method is the result of calling newJMXConnector on the provider.

    The Map parameter passed to the JMXConnectorProvider is a new read-only Map that contains all the entries that were in the environment parameter to JMXConnectorFactory.newJMXConnector, if there was one. Additionally, if the jmx.remote.protocol.provider.class.loader key is not present in the environment parameter, it is added to the new read-only Map. The associated value is the calling thread's context class loader.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_CLASS_LOADER
      Name of the attribute that specifies the default class loader.
      static String PROTOCOL_PROVIDER_CLASS_LOADER
      Name of the attribute that specifies the class loader for loading protocol providers.
      static String PROTOCOL_PROVIDER_PACKAGES
      Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static JMXConnector connect(JMXServiceURL serviceURL)
      Creates a connection to the connector server at the given address.
      static JMXConnector connect(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connection to the connector server at the given address.
      static JMXConnector newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connector client for the connector server at the given address.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CLASS_LOADER

        public static final String DEFAULT_CLASS_LOADER

        Name of the attribute that specifies the default class loader. This class loader is used to deserialize return values and exceptions from remote MBeanServerConnection calls. The value associated with this attribute is an instance of ClassLoader.

        另请参见：
        Constant Field Values

      • PROTOCOL_PROVIDER_PACKAGES

        public static final String PROTOCOL_PROVIDER_PACKAGES

        Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol. The value associated with this attribute is a string with package names separated by vertical bars (|).

        另请参见：
        Constant Field Values

      • PROTOCOL_PROVIDER_CLASS_LOADER

        public static final String PROTOCOL_PROVIDER_CLASS_LOADER

        Name of the attribute that specifies the class loader for loading protocol providers. The value associated with this attribute is an instance of ClassLoader.

        另请参见：
        Constant Field Values

    • 方法详细信息

      • connect

        public static JMXConnector connect(JMXServiceURL serviceURL)
                            throws IOException

        Creates a connection to the connector server at the given address.

        This method is equivalent to connect(serviceURL, null).

        参数：
        serviceURL - the address of the connector server to connect to.
        返回：
        a JMXConnector whose connect method has been called.
        抛出：
        NullPointerException - if serviceURL is null.
        IOException - if the connector client or the connection cannot be made because of a communication problem.
        SecurityException - if the connection cannot be made for security reasons.

      • connect

        public static JMXConnector connect(JMXServiceURL serviceURL,
                   Map<String,?> environment)
                            throws IOException

        Creates a connection to the connector server at the given address.

        This method is equivalent to:

         JMXConnector conn = JMXConnectorFactory.newJMXConnector(serviceURL,
                                                         environment);
 conn.connect(environment);
        参数：
        serviceURL - the address of the connector server to connect to.
        environment - a set of attributes to determine how the connection is made. This parameter can be null. Keys in this map must be Strings. The appropriate type of each associated value depends on the attribute. The contents of environment are not changed by this call.
        返回：
        a JMXConnector representing the newly-made connection. Each successful call to this method produces a different object.
        抛出：
        NullPointerException - if serviceURL is null.
        IOException - if the connector client or the connection cannot be made because of a communication problem.
        SecurityException - if the connection cannot be made for security reasons.

      • newJMXConnector

        public static JMXConnector newJMXConnector(JMXServiceURL serviceURL,
                           Map<String,?> environment)
                                    throws IOException

        Creates a connector client for the connector server at the given address. The resultant client is not connected until its connect method is called.

        参数：
        serviceURL - the address of the connector server to connect to.
        environment - a set of attributes to determine how the connection is made. This parameter can be null. Keys in this map must be Strings. The appropriate type of each associated value depends on the attribute. The contents of environment are not changed by this call.
        返回：
        a JMXConnector representing the new connector client. Each successful call to this method produces a different object.
        抛出：
        NullPointerException - if serviceURL is null.
        IOException - if the connector client cannot be made because of a communication problem.
        MalformedURLException - if there is no provider for the protocol in serviceURL.
        JMXProviderException - if there is a provider for the protocol in serviceURL but it cannot be used for some reason.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>glsadpad


JMXConnectorProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXConnectorProvider

  • public interface JMXConnectorProvider

    A provider for creating JMX API connector clients using a given protocol. Instances of this interface are created by JMXConnectorFactory as part of its newJMXConnector method.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMXConnector newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a new connector client that is ready to connect to the connector server at the given address.

    • 方法详细信息

      • newJMXConnector

        JMXConnector newJMXConnector(JMXServiceURL serviceURL,
                           Map<String,?> environment)
                             throws IOException

        Creates a new connector client that is ready to connect to the connector server at the given address. Each successful call to this method produces a different JMXConnector object.

        参数：
        serviceURL - the address of the connector server to connect to.
        environment - a read-only Map containing named attributes to determine how the connection is made. Keys in this map must be Strings. The appropriate type of each associated value depends on the attribute.

        返回：
        a JMXConnector representing the new connector client. Each successful call to this method produces a different object.
        抛出：
        NullPointerException - if serviceURL or environment is null.
        IOException - It is recommended for a provider implementation to throw MalformedURLException if the protocol in the serviceURL is not recognized by this provider, JMXProviderException if this is a provider for the protocol in serviceURL but it cannot be used for some reason or any other IOException if the connection cannot be made because of a communication problem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>vFcatcstc"ooc""lh d&=dnndtppnFnst


JMXConnectorServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXConnectorServer

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.remote.JMXConnectorServer
  • 所有已实现的接口：
    MBeanRegistration, NotificationBroadcaster, NotificationEmitter, JMXAddressable, JMXConnectorServerMBean
    直接已知子类：
    RMIConnectorServer

    public abstract class JMXConnectorServer
extends NotificationBroadcasterSupport
implements JMXConnectorServerMBean, MBeanRegistration, JMXAddressable

    Superclass of every connector server. A connector server is attached to an MBean server. It listens for client connection requests and creates a connection for each one.

    A connector server is associated with an MBean server either by registering it in that MBean server, or by passing the MBean server to its constructor.

    A connector server is inactive when created. It only starts listening for client connections when the start method is called. A connector server stops listening for client connections when the stop method is called or when the connector server is unregistered from its MBean server.

    Stopping a connector server does not unregister it from its MBean server. A connector server once stopped cannot be restarted.

    Each time a client connection is made or broken, a notification of class JMXConnectionNotification is emitted.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String AUTHENTICATOR
      Name of the attribute that specifies the authenticator for a connector server.

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXConnectorServer()
      Constructs a connector server that will be registered as an MBean in the MBean server it is attached to.
      JMXConnectorServer(MBeanServer mbeanServer)
      Constructs a connector server that is attached to the given MBean server.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void connectionClosed(String connectionId, String message, Object userData)
      Called by a subclass when a client connection is closed normally.
      protected void connectionFailed(String connectionId, String message, Object userData)
      Called by a subclass when a client connection fails.
      protected void connectionOpened(String connectionId, String message, Object userData)
      Called by a subclass when a new client connection is opened.
      String[] getConnectionIds()
      The list of IDs for currently-open connections to this connector server.
      MBeanServer getMBeanServer()
      Returns the MBean server that this connector server is attached to.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns an array indicating the notifications that this MBean sends.
      void postDeregister()
      Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Called by an MBean server when this connector server is unregistered from that MBean server.
      ObjectName preRegister(MBeanServer mbs, ObjectName name)
      Called by an MBean server when this connector server is registered in that MBean server.
      void setMBeanServerForwarder(MBeanServerForwarder mbsf)
      Inserts an object that intercepts requests for the MBean server that arrive through this connector server.
      JMXConnector toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.management.remote.JMXConnectorServerMBean

        getAddress, getAttributes, isActive, start, stop

      • 方法 - 继承于接口 javax.management.remote.JMXAddressable

        getAddress

    • 字段详细信息

      • AUTHENTICATOR

        public static final String AUTHENTICATOR

        Name of the attribute that specifies the authenticator for a connector server. The value associated with this attribute, if any, must be an object that implements the interface JMXAuthenticator.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JMXConnectorServer

        public JMXConnectorServer()

        Constructs a connector server that will be registered as an MBean in the MBean server it is attached to. This constructor is typically called by one of the createMBean methods when creating, within an MBean server, a connector server that makes it available remotely.

      • JMXConnectorServer

        public JMXConnectorServer(MBeanServer mbeanServer)

        Constructs a connector server that is attached to the given MBean server. A connector server that is created in this way can be registered in a different MBean server, or not registered in any MBean server.

        参数：
        mbeanServer - the MBean server that this connector server is attached to. Null if this connector server will be attached to an MBean server by being registered in it.

    • 方法详细信息

      • getMBeanServer

        public MBeanServer getMBeanServer()

        Returns the MBean server that this connector server is attached to.

        返回：
        the MBean server that this connector server is attached to, or null if it is not yet attached to an MBean server.

      • setMBeanServerForwarder

        public void setMBeanServerForwarder(MBeanServerForwarder mbsf)
        从接口复制的描述： JMXConnectorServerMBean

        Inserts an object that intercepts requests for the MBean server that arrive through this connector server. This object will be supplied as the MBeanServer for any new connection created by this connector server. Existing connections are unaffected.

        This method can be called more than once with different MBeanServerForwarder objects. The result is a chain of forwarders. The last forwarder added is the first in the chain. In more detail:

        • If this connector server is already associated with an MBeanServer object, then that object is given to mbsf.setMBeanServer. If doing so produces an exception, this method throws the same exception without any other effect.

        • If this connector is not already associated with an MBeanServer object, or if the mbsf.setMBeanServer call just mentioned succeeds, then mbsf becomes this connector server's MBeanServer.

        指定者：
        setMBeanServerForwarder in interface JMXConnectorServerMBean
        参数：
        mbsf - the new MBeanServerForwarder.

      • getConnectionIds

        public String[] getConnectionIds()
        从接口复制的描述： JMXConnectorServerMBean

        The list of IDs for currently-open connections to this connector server.

        指定者：
        getConnectionIds in interface JMXConnectorServerMBean
        返回：
        a new string array containing the list of IDs. If there are no currently-open connections, this array will be empty.

      • toJMXConnector

        public JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

        Returns a client stub for this connector server. A client stub is a serializable object whose connect method can be used to make one new connection to this connector server.

        A given connector need not support the generation of client stubs. However, the connectors specified by the JMX Remote API do (JMXMP Connector and RMI Connector).

        The default implementation of this method uses JMXConnectorServerMBean.getAddress() and JMXConnectorFactory to generate the stub, with code equivalent to the following:

         JMXServiceURL addr = getAddress();
 return JMXConnectorFactory.newJMXConnector(addr, env);

        A connector server for which this is inappropriate must override this method so that it either implements the appropriate logic or throws UnsupportedOperationException.

        指定者：
        toJMXConnector in interface JMXConnectorServerMBean
        参数：
        env - client connection parameters of the same sort that could be provided to JMXConnector.connect(Map). Can be null, which is equivalent to an empty map.
        返回：
        a client stub that can be used to make a new connection to this connector server.
        抛出：
        UnsupportedOperationException - if this connector server does not support the generation of client stubs.
        IllegalStateException - if the JMXConnectorServer is not started (see JMXConnectorServerMBean.isActive()).
        IOException - if a communications problem means that a stub cannot be created.

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()

        Returns an array indicating the notifications that this MBean sends. The implementation in JMXConnectorServer returns an array with one element, indicating that it can emit notifications of class JMXConnectionNotification with the types defined in that class. A subclass that can emit other notifications should return an array that contains this element plus descriptions of the other notifications.

        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.

      • connectionOpened

        protected void connectionOpened(String connectionId,
                    String message,
                    Object userData)

        Called by a subclass when a new client connection is opened. Adds connectionId to the list returned by getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.OPENED.

        参数：
        connectionId - the ID of the new connection. This must be different from the ID of any connection previously opened by this connector server.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().
        抛出：
        NullPointerException - if connectionId is null.

      • connectionClosed

        protected void connectionClosed(String connectionId,
                    String message,
                    Object userData)

        Called by a subclass when a client connection is closed normally. Removes connectionId from the list returned by getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.CLOSED.

        参数：
        connectionId - the ID of the closed connection.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().
        抛出：
        NullPointerException - if connectionId is null.

      • connectionFailed

        protected void connectionFailed(String connectionId,
                    String message,
                    Object userData)

        Called by a subclass when a client connection fails. Removes connectionId from the list returned by getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.FAILED.

        参数：
        connectionId - the ID of the failed connection.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().
        抛出：
        NullPointerException - if connectionId is null.

      • preRegister

        public ObjectName preRegister(MBeanServer mbs,
                     ObjectName name)

        Called by an MBean server when this connector server is registered in that MBean server. This connector server becomes attached to the MBean server and its getMBeanServer() method will return mbs.

        If this connector server is already attached to an MBean server, this method has no effect. The MBean server it is attached to is not necessarily the one it is being registered in.

        指定者：
        preRegister in interface MBeanRegistration
        参数：
        mbs - the MBean server in which this connection server is being registered.
        name - The object name of the MBean.
        返回：
        The name under which the MBean is to be registered.
        抛出：
        NullPointerException - if mbs or name is null.

      • postRegister

        public void postRegister(Boolean registrationDone)
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postRegister will not change the state of the MBean: if the MBean was already registered (registrationDone is true), the MBean will remain registered.

        This might be confusing for the code calling createMBean() or registerMBean(), as such code might assume that MBean registration has failed when such an exception is raised. Therefore it is recommended that implementations of postRegister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception

        Called by an MBean server when this connector server is unregistered from that MBean server. If this connector server was attached to that MBean server by being registered in it, and if the connector server is still active, then unregistering it will call the stop method. If the stop method throws an exception, the unregistration attempt will fail. It is recommended to call the stop method explicitly before unregistering the MBean.

        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        IOException - if thrown by the stop method.
        Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException.

      • postDeregister

        public void postDeregister()
        从接口复制的描述： MBeanRegistration
        Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

        If the implementation of this method throws a RuntimeException or an Error, the MBean Server will rethrow those inside a RuntimeMBeanException or RuntimeErrorException, respectively. However, throwing an exception in postDeregister will not change the state of the MBean: the MBean was already successfully deregistered and will remain so.

        This might be confusing for the code calling unregisterMBean(), as it might assume that MBean deregistration has failed. Therefore it is recommended that implementations of postDeregister do not throw Runtime Exceptions or Errors if it can be avoided.

        指定者：
        postDeregister in interface MBeanRegistration
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JMXConnectorServerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

类 JMXConnectorServerFactory

  • java.lang.Object
    • javax.management.remote.JMXConnectorServerFactory

  • public class JMXConnectorServerFactory
extends Object

    Factory to create JMX API connector servers. There are no instances of this class.

    Each connector server is created by an instance of JMXConnectorServerProvider. This instance is found as follows. Suppose the given JMXServiceURL looks like "service:jmx:protocol:remainder". Then the factory will attempt to find the appropriate JMXConnectorServerProvider for protocol. Each occurrence of the character + or - in protocol is replaced by . or _, respectively.

    A provider package list is searched for as follows:

    1. If the environment parameter to newJMXConnectorServer contains the key jmx.remote.protocol.provider.pkgs then the associated value is the provider package list.
    2. Otherwise, if the system property jmx.remote.protocol.provider.pkgs exists, then its value is the provider package list.
    3. Otherwise, there is no provider package list.

    The provider package list is a string that is interpreted as a list of non-empty Java package names separated by vertical bars (|). If the string is empty, then so is the provider package list. If the provider package list is not a String, or if it contains an element that is an empty string, a JMXProviderException is thrown.

    If the provider package list exists and is not empty, then for each element pkg of the list, the factory will attempt to load the class

    pkg.protocol.ServerProvider

    If the environment parameter to newJMXConnectorServer contains the key jmx.remote.protocol.provider.class.loader then the associated value is the class loader to use to load the provider. If the associated value is not an instance of ClassLoader, an IllegalArgumentException is thrown.

    If the jmx.remote.protocol.provider.class.loader key is not present in the environment parameter, the calling thread's context class loader is used.

    If the attempt to load this class produces a ClassNotFoundException, the search for a handler continues with the next element of the list.

    Otherwise, a problem with the provider found is signalled by a JMXProviderException whose cause indicates the underlying exception, as follows:

    • if the attempt to load the class produces an exception other than ClassNotFoundException, that is the cause;
    • if Class.newInstance() for the class produces an exception, that is the cause.

    If no provider is found by the above steps, including the default case where there is no provider package list, then the implementation will use its own provider for protocol, or it will throw a MalformedURLException if there is none. An implementation may choose to find providers by other means. For example, it may support the JAR conventions for service providers, where the service interface is JMXConnectorServerProvider.

    Every implementation must support the RMI connector protocols, specified with the string rmi or iiop.

    Once a provider is found, the result of the newJMXConnectorServer method is the result of calling newJMXConnectorServer on the provider.

    The Map parameter passed to the JMXConnectorServerProvider is a new read-only Map that contains all the entries that were in the environment parameter to JMXConnectorServerFactory.newJMXConnectorServer, if there was one. Additionally, if the jmx.remote.protocol.provider.class.loader key is not present in the environment parameter, it is added to the new read-only Map. The associated value is the calling thread's context class loader.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_CLASS_LOADER
      Name of the attribute that specifies the default class loader.
      static String DEFAULT_CLASS_LOADER_NAME
      Name of the attribute that specifies the default class loader MBean name.
      static String PROTOCOL_PROVIDER_CLASS_LOADER
      Name of the attribute that specifies the class loader for loading protocol providers.
      static String PROTOCOL_PROVIDER_PACKAGES
      Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a connector server at the given address.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CLASS_LOADER

        public static final String DEFAULT_CLASS_LOADER

        Name of the attribute that specifies the default class loader. This class loader is used to deserialize objects in requests received from the client, possibly after consulting an MBean-specific class loader. The value associated with this attribute is an instance of ClassLoader.

        另请参见：
        Constant Field Values

      • DEFAULT_CLASS_LOADER_NAME

        public static final String DEFAULT_CLASS_LOADER_NAME

        Name of the attribute that specifies the default class loader MBean name. This class loader is used to deserialize objects in requests received from the client, possibly after consulting an MBean-specific class loader. The value associated with this attribute is an instance of ObjectName.

        另请参见：
        Constant Field Values

      • PROTOCOL_PROVIDER_PACKAGES

        public static final String PROTOCOL_PROVIDER_PACKAGES

        Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol. The value associated with this attribute is a string with package names separated by vertical bars (|).

        另请参见：
        Constant Field Values

      • PROTOCOL_PROVIDER_CLASS_LOADER

        public static final String PROTOCOL_PROVIDER_CLASS_LOADER

        Name of the attribute that specifies the class loader for loading protocol providers. The value associated with this attribute is an instance of ClassLoader.

        另请参见：
        Constant Field Values

    • 方法详细信息

      • newJMXConnectorServer

        public static JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL,
                                       Map<String,?> environment,
                                       MBeanServer mbeanServer)
                                                throws IOException

        Creates a connector server at the given address. The resultant server is not started until its start method is called.

        参数：
        serviceURL - the address of the new connector server. The actual address of the new connector server, as returned by its getAddress method, will not necessarily be exactly the same. For example, it might include a port number if the original address did not.
        environment - a set of attributes to control the new connector server's behavior. This parameter can be null. Keys in this map must be Strings. The appropriate type of each associated value depends on the attribute. The contents of environment are not changed by this call.
        mbeanServer - the MBean server that this connector server is attached to. Null if this connector server will be attached to an MBean server by being registered in it.
        返回：
        a JMXConnectorServer representing the new connector server. Each successful call to this method produces a different object.
        抛出：
        NullPointerException - if serviceURL is null.
        IOException - if the connector server cannot be made because of a communication problem.
        MalformedURLException - if there is no provider for the protocol in serviceURL.
        JMXProviderException - if there is a provider for the protocol in serviceURL but it cannot be used for some reason.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st,eetsntsuttsuua/MMics aaaMevtfbt oeoBli


JMXConnectorServerMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXConnectorServerMBean

  • All Known Implementing Classes:
    JMXConnectorServer, RMIConnectorServer

    public interface JMXConnectorServerMBean

    MBean interface for connector servers. A JMX API connector server is attached to an MBean server, and establishes connections to that MBean server for remote clients.

    A newly-created connector server is inactive, and does not yet listen for connections. Only when its start method has been called does it start listening for connections.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMXServiceURL getAddress()
      The address of this connector server.
      Map<String,?> getAttributes()
      The attributes for this connector server.
      String[] getConnectionIds()
      The list of IDs for currently-open connections to this connector server.
      boolean isActive()
      Determines whether the connector server is active.
      void setMBeanServerForwarder(MBeanServerForwarder mbsf)
      Inserts an object that intercepts requests for the MBean server that arrive through this connector server.
      void start()
      Activates the connector server, that is, starts listening for client connections.
      void stop()
      Deactivates the connector server, that is, stops listening for client connections.
      JMXConnector toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.

    • 方法详细信息

      • start

        void start()
           throws IOException

        Activates the connector server, that is, starts listening for client connections. Calling this method when the connector server is already active has no effect. Calling this method when the connector server has been stopped will generate an IOException.

        抛出：
        IOException - if it is not possible to start listening or if the connector server has been stopped.
        IllegalStateException - if the connector server has not been attached to an MBean server.

      • stop

        void stop()
          throws IOException

        Deactivates the connector server, that is, stops listening for client connections. Calling this method will also close all client connections that were made by this server. After this method returns, whether normally or with an exception, the connector server will not create any new client connections.

        Once a connector server has been stopped, it cannot be started again.

        Calling this method when the connector server has already been stopped has no effect. Calling this method when the connector server has not yet been started will disable the connector server object permanently.

        If closing a client connection produces an exception, that exception is not thrown from this method. A JMXConnectionNotification with type JMXConnectionNotification.FAILED is emitted from this MBean with the connection ID of the connection that could not be closed.

        Closing a connector server is a potentially slow operation. For example, if a client machine with an open connection has crashed, the close operation might have to wait for a network protocol timeout. Callers that do not want to block in a close operation should do it in a separate thread.

        抛出：
        IOException - if the server cannot be closed cleanly. When this exception is thrown, the server has already attempted to close all client connections. All client connections are closed except possibly those that generated exceptions when the server attempted to close them.

      • isActive

        boolean isActive()

        Determines whether the connector server is active. A connector server starts being active when its start method returns successfully and remains active until either its stop method is called or the connector server fails.

        返回：
        true if the connector server is active.

      • setMBeanServerForwarder

        void setMBeanServerForwarder(MBeanServerForwarder mbsf)

        Inserts an object that intercepts requests for the MBean server that arrive through this connector server. This object will be supplied as the MBeanServer for any new connection created by this connector server. Existing connections are unaffected.

        This method can be called more than once with different MBeanServerForwarder objects. The result is a chain of forwarders. The last forwarder added is the first in the chain. In more detail:

        • If this connector server is already associated with an MBeanServer object, then that object is given to mbsf.setMBeanServer. If doing so produces an exception, this method throws the same exception without any other effect.

        • If this connector is not already associated with an MBeanServer object, or if the mbsf.setMBeanServer call just mentioned succeeds, then mbsf becomes this connector server's MBeanServer.

        参数：
        mbsf - the new MBeanServerForwarder.
        抛出：
        IllegalArgumentException - if the call to mbsf.setMBeanServer fails with IllegalArgumentException. This includes the case where mbsf is null.

      • getConnectionIds

        String[] getConnectionIds()

        The list of IDs for currently-open connections to this connector server.

        返回：
        a new string array containing the list of IDs. If there are no currently-open connections, this array will be empty.

      • getAddress

        JMXServiceURL getAddress()

        The address of this connector server.

        The address returned may not be the exact original JMXServiceURL that was supplied when creating the connector server, since the original address may not always be complete. For example the port number may be dynamically allocated when starting the connector server. Instead the address returned is the actual JMXServiceURL of the JMXConnectorServer. This is the address that clients supply to JMXConnectorFactory.connect(JMXServiceURL).

        Note that the address returned may be null if the JMXConnectorServer is not yet active.

        返回：
        the address of this connector server, or null if it does not have one.

      • getAttributes

        Map<String,?> getAttributes()

        The attributes for this connector server.

        返回：
        a read-only map containing the attributes for this connector server. Attributes whose values are not serializable are omitted from this map. If there are no serializable attributes, the returned map is empty.

      • toJMXConnector

        JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

        Returns a client stub for this connector server. A client stub is a serializable object whose connect method can be used to make one new connection to this connector server.

        A given connector need not support the generation of client stubs. However, the connectors specified by the JMX Remote API do (JMXMP Connector and RMI Connector).

        参数：
        env - client connection parameters of the same sort that can be provided to JMXConnector.connect(Map). Can be null, which is equivalent to an empty map.
        返回：
        a client stub that can be used to make a new connection to this connector server.
        抛出：
        UnsupportedOperationException - if this connector server does not support the generation of client stubs.
        IllegalStateException - if the JMXConnectorServer is not started (see isActive()).
        IOException - if a communications problem means that a stub cannot be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/o."h"a"."=...""h ss�&t莶agc


JMXConnectorServerProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface JMXConnectorServerProvider

  • public interface JMXConnectorServerProvider

    A provider for creating JMX API connector servers using a given protocol. Instances of this interface are created by JMXConnectorServerFactory as part of its newJMXConnectorServer method.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a new connector server at the given address.

    • 方法详细信息

      • newJMXConnectorServer

        JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL,
                                       Map<String,?> environment,
                                       MBeanServer mbeanServer)
                                         throws IOException

        Creates a new connector server at the given address. Each successful call to this method produces a different JMXConnectorServer object.

        参数：
        serviceURL - the address of the new connector server. The actual address of the new connector server, as returned by its getAddress method, will not necessarily be exactly the same. For example, it might include a port number if the original address did not.
        environment - a read-only Map containing named attributes to control the new connector server's behavior. Keys in this map must be Strings. The appropriate type of each associated value depends on the attribute.
        mbeanServer - the MBean server that this connector server is attached to. Null if this connector server will be attached to an MBean server by being registered in it.
        返回：
        a JMXConnectorServer representing the new connector server. Each successful call to this method produces a different object.
        抛出：
        NullPointerException - if serviceURL or environment is null.
        IOException - It is recommended for a provider implementation to throw MalformedURLException if the protocol in the serviceURL is not recognized by this provider, JMXProviderException if this is a provider for the protocol in serviceURL but it cannot be used for some reason or any other IOException if the connector server cannot be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-gtsb ib tpp tte ee hh rhsd roehn


JMXPrincipal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXPrincipal

  • java.lang.Object
    • javax.management.remote.JMXPrincipal
  • 所有已实现的接口：
    Serializable, Principal

    public class JMXPrincipal
extends Object
implements Principal, Serializable

    The identity of a remote client of the JMX Remote API.

    Principals such as this JMXPrincipal may be associated with a particular Subject to augment that Subject with an additional identity. Refer to the Subject class for more information on how to achieve this. Authorization decisions can then be based upon the Principals associated with a Subject.

    从以下版本开始：
    1.5
    另请参见：
    Principal, Subject, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXPrincipal(String name)
      Creates a JMXPrincipal for a given identity.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object o)
      Compares the specified Object with this JMXPrincipal for equality.
      String getName()
      Returns the name of this principal.
      int hashCode()
      Returns a hash code for this JMXPrincipal.
      String toString()
      Returns a string representation of this JMXPrincipal.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMXPrincipal

        public JMXPrincipal(String name)

        Creates a JMXPrincipal for a given identity.

        参数：
        name - the JMX Remote API name for this identity.
        抛出：
        NullPointerException - if the name is null.

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of this principal.

        指定者：
        getName in interface Principal
        返回：
        the name of this JMXPrincipal.

      • toString

        public String toString()
        Returns a string representation of this JMXPrincipal.

        指定者：
        toString in interface Principal
        重载：
        toString in class Object
        返回：
        a string representation of this JMXPrincipal.

      • equals

        public boolean equals(Object o)
        Compares the specified Object with this JMXPrincipal for equality. Returns true if the given object is also a JMXPrincipal and the two JMXPrincipals have the same name.

        指定者：
        equals in interface Principal
        重载：
        equals in class Object
        参数：
        o - Object to be compared for equality with this JMXPrincipal.
        返回：
        true if the specified Object is equal to this JMXPrincipal.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code for this JMXPrincipal.

        指定者：
        hashCode in interface Principal
        重载：
        hashCode in class Object
        返回：
        a hash code for this JMXPrincipal.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a;v==i "iitt>ittei..lt< ti=ssl>> "sea


JMXProviderException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXProviderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.management.remote.JMXProviderException
  • 所有已实现的接口：
    Serializable

    public class JMXProviderException
extends IOException

    Exception thrown by JMXConnectorFactory and JMXConnectorServerFactory when a provider exists for the required protocol but cannot be used for some reason.

    从以下版本开始：
    1.5
    另请参见：
    JMXConnectorFactory.newJMXConnector(javax.management.remote.JMXServiceURL, java.util.Map), JMXConnectorServerFactory.newJMXConnectorServer(javax.management.remote.JMXServiceURL, java.util.Map, javax.management.MBeanServer), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXProviderException()
      Constructs a JMXProviderException with no specified detail message.
      JMXProviderException(String message)
      Constructs a JMXProviderException with the specified detail message.
      JMXProviderException(String message, Throwable cause)
      Constructs a JMXProviderException with the specified detail message and nested exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMXProviderException

        public JMXProviderException()

        Constructs a JMXProviderException with no specified detail message.

      • JMXProviderException

        public JMXProviderException(String message)

        Constructs a JMXProviderException with the specified detail message.

        参数：
        message - the detail message

      • JMXProviderException

        public JMXProviderException(String message,
                    Throwable cause)

        Constructs a JMXProviderException with the specified detail message and nested exception.

        参数：
        message - the detail message
        cause - the nested exception

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Description copied from class: Throwable
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

        This implementation returns the cause that was supplied via one of the constructors requiring a Throwable, or that was set after creation with the Throwable.initCause(Throwable) method. While it is typically unnecessary to override this method, a subclass can override it to return a cause set by some other means. This is appropriate for a "legacy chained throwable" that predates the addition of chained exceptions to Throwable. Note that it is not necessary to override any of the PrintStackTrace methods, all of which invoke the getCause method to determine the cause of a throwable.

        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

no S"t th.t>h.. a...lctap j o .teh


JMXServerErrorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXServerErrorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.management.remote.JMXServerErrorException
  • 所有已实现的接口：
    Serializable

    public class JMXServerErrorException
extends IOException
    Exception thrown as the result of a remote MBeanServer method invocation when an Error is thrown while processing the invocation in the remote MBean server. A JMXServerErrorException instance contains the original Error that occurred as its cause.
    从以下版本开始：
    1.5
    另请参见：
    ServerError, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXServerErrorException(String s, Error err)
      Constructs a JMXServerErrorException with the specified detail message and nested error.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMXServerErrorException

        public JMXServerErrorException(String s,
                       Error err)
        Constructs a JMXServerErrorException with the specified detail message and nested error.
        参数：
        s - the detail message.
        err - the nested error. An instance of this class can be constructed where this parameter is null, but the standard connectors will never do so.

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Description copied from class: Throwable
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

        This implementation returns the cause that was supplied via one of the constructors requiring a Throwable, or that was set after creation with the Throwable.initCause(Throwable) method. While it is typically unnecessary to override this method, a subclass can override it to return a cause set by some other means. This is appropriate for a "legacy chained throwable" that predates the addition of chained exceptions to Throwable. Note that it is not necessary to override any of the PrintStackTrace methods, all of which invoke the getCause method to determine the cause of a throwable.

        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t>cJhP.ll pltcil acmse o


JMXServiceURL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 JMXServiceURL

  • java.lang.Object
    • javax.management.remote.JMXServiceURL
  • 所有已实现的接口：
    Serializable

    public class JMXServiceURL
extends Object
implements Serializable

    The address of a JMX API connector server. Instances of this class are immutable.

    The address is an Abstract Service URL for SLP, as defined in RFC 2609 and amended by RFC 3111. It must look like this:

    service:jmx:protocol:sap

    Here, protocol is the transport protocol to be used to connect to the connector server. It is a string of one or more ASCII characters, each of which is a letter, a digit, or one of the characters + or -. The first character must be a letter. Uppercase letters are converted into lowercase ones.

    sap is the address at which the connector server is found. This address uses a subset of the syntax defined by RFC 2609 for IP-based protocols. It is a subset because the user@host syntax is not supported.

    The other syntaxes defined by RFC 2609 are not currently supported by this class.

    The supported syntax is:

    //[host[:port]][url-path]

    Square brackets [] indicate optional parts of the address. Not all protocols will recognize all optional parts.

    The host is a host name, an IPv4 numeric host address, or an IPv6 numeric address enclosed in square brackets.

    The port is a decimal port number. 0 means a default or anonymous port, depending on the protocol.

    The host and port can be omitted. The port cannot be supplied without a host.

    The url-path, if any, begins with a slash (/) or a semicolon (;) and continues to the end of the address. It can contain attributes using the semicolon syntax specified in RFC 2609. Those attributes are not parsed by this class and incorrect attribute syntax is not detected.

    Although it is legal according to RFC 2609 to have a url-path that begins with a semicolon, not all implementations of SLP allow it, so it is recommended to avoid that syntax.

    Case is not significant in the initial service:jmx:protocol string or in the host part of the address. Depending on the protocol, case can be significant in the url-path.

    从以下版本开始：
    1.5
    另请参见：
    RFC 2609, "Service Templates and Service: Schemes", RFC 3111, "Service Location Protocol Modifications for IPv6", Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMXServiceURL(String serviceURL)
      Constructs a JMXServiceURL by parsing a Service URL string.
      JMXServiceURL(String protocol, String host, int port)
      Constructs a JMXServiceURL with the given protocol, host, and port.
      JMXServiceURL(String protocol, String host, int port, String urlPath)
      Constructs a JMXServiceURL with the given parts.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Indicates whether some other object is equal to this one.
      String getHost()
      The host part of the Service URL.
      int getPort()
      The port of the Service URL.
      String getProtocol()
      The protocol part of the Service URL.
      String getURLPath()
      The URL Path part of the Service URL.
      int hashCode()
      Returns a hash code value for the object.
      String toString()
      The string representation of this Service URL.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMXServiceURL

        public JMXServiceURL(String serviceURL)
              throws MalformedURLException

        Constructs a JMXServiceURL by parsing a Service URL string.

        参数：
        serviceURL - the URL string to be parsed.
        抛出：
        NullPointerException - if serviceURL is null.
        MalformedURLException - if serviceURL does not conform to the syntax for an Abstract Service URL or if it is not a valid name for a JMX Remote API service. A JMXServiceURL must begin with the string "service:jmx:" (case-insensitive). It must not contain any characters that are not printable ASCII characters.

      • JMXServiceURL

        public JMXServiceURL(String protocol,
             String host,
             int port)
              throws MalformedURLException

        Constructs a JMXServiceURL with the given protocol, host, and port. This constructor is equivalent to JMXServiceURL(protocol, host, port, null).

        参数：
        protocol - the protocol part of the URL. If null, defaults to jmxmp.
        host - the host part of the URL. If null, defaults to the local host name, as determined by InetAddress.getLocalHost().getHostName(). If it is a numeric IPv6 address, it can optionally be enclosed in square brackets [].
        port - the port part of the URL.
        抛出：
        MalformedURLException - if one of the parts is syntactically incorrect, or if host is null and it is not possible to find the local host name, or if port is negative.

      • JMXServiceURL

        public JMXServiceURL(String protocol,
             String host,
             int port,
             String urlPath)
              throws MalformedURLException

        Constructs a JMXServiceURL with the given parts.

        参数：
        protocol - the protocol part of the URL. If null, defaults to jmxmp.
        host - the host part of the URL. If null, defaults to the local host name, as determined by InetAddress.getLocalHost().getHostName(). If it is a numeric IPv6 address, it can optionally be enclosed in square brackets [].
        port - the port part of the URL.
        urlPath - the URL path part of the URL. If null, defaults to the empty string.
        抛出：
        MalformedURLException - if one of the parts is syntactically incorrect, or if host is null and it is not possible to find the local host name, or if port is negative.

    • 方法详细信息

      • getProtocol

        public String getProtocol()

        The protocol part of the Service URL.

        返回：
        the protocol part of the Service URL. This is never null.

      • getHost

        public String getHost()

        The host part of the Service URL. If the Service URL was constructed with the constructor that takes a URL string parameter, the result is the substring specifying the host in that URL. If the Service URL was constructed with a constructor that takes a separate host parameter, the result is the string that was specified. If that string was null, the result is InetAddress.getLocalHost().getHostName().

        In either case, if the host was specified using the [...] syntax for numeric IPv6 addresses, the square brackets are not included in the return value here.

        返回：
        the host part of the Service URL. This is never null.

      • getPort

        public int getPort()

        The port of the Service URL. If no port was specified, the returned value is 0.

        返回：
        the port of the Service URL, or 0 if none.

      • getURLPath

        public String getURLPath()

        The URL Path part of the Service URL. This is an empty string, or a string beginning with a slash (/), or a string beginning with a semicolon (;).

        返回：
        the URL Path part of the Service URL. This is never null.

      • toString

        public String toString()

        The string representation of this Service URL. If the value returned by this method is supplied to the JMXServiceURL constructor, the resultant object is equal to this one.

        The host part of the returned string is the value returned by getHost(). If that value specifies a numeric IPv6 address, it is surrounded by square brackets [].

        The port part of the returned string is the value returned by getPort() in its shortest decimal form. If the value is zero, it is omitted.

        重载：
        toString in class Object
        返回：
        the string representation of this Service URL.

      • equals

        public boolean equals(Object obj)

        Indicates whether some other object is equal to this one. This method returns true if and only if obj is an instance of JMXServiceURL whose getProtocol(), getHost(), getPort(), and getURLPath() methods return the same values as for this object. The values for getProtocol() and getHost() can differ in case without affecting equality.

        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Description copied from class: Object
        Returns a hash code value for the object. This method is supported for the benefit of hash tables such as those provided by HashMap.

        The general contract of hashCode is:

        • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
        • If two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result.
        • It is not required that if two objects are unequal according to the Object.equals(java.lang.Object) method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.

        As much as is reasonably practical, the hashCode method defined by class Object does return distinct integers for distinct objects. (This is typically implemented by converting the internal address of the object into an integer, but this implementation technique is not required by the JavaTM programming language.)

        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t >oien..o/n<.t档


MBeanServerForwarder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote

Interface MBeanServerForwarder

  • All Superinterfaces:
    MBeanServer, MBeanServerConnection

    public interface MBeanServerForwarder
extends MBeanServer

    An object of this class implements the MBeanServer interface and wraps another object that also implements that interface. Typically, an implementation of this interface performs some action in some or all methods of the MBeanServer interface before and/or after forwarding the method to the wrapped object. Examples include security checking and logging.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MBeanServer getMBeanServer()
      Returns the MBeanServer object to which requests will be forwarded.
      void setMBeanServer(MBeanServer mbs)
      Sets the MBeanServer object to which requests will be forwarded after treatment by this object.

      • 方法 - 继承于接口 javax.management.MBeanServer

        addNotificationListener, addNotificationListener, createMBean, createMBean, createMBean, createMBean, deserialize, deserialize, deserialize, getAttribute, getAttributes, getClassLoader, getClassLoaderFor, getClassLoaderRepository, getDefaultDomain, getDomains, getMBeanCount, getMBeanInfo, getObjectInstance, instantiate, instantiate, instantiate, instantiate, invoke, isInstanceOf, isRegistered, queryMBeans, queryNames, registerMBean, removeNotificationListener, removeNotificationListener, removeNotificationListener, removeNotificationListener, setAttribute, setAttributes, unregisterMBean

    • 方法详细信息

      • getMBeanServer

        MBeanServer getMBeanServer()
        Returns the MBeanServer object to which requests will be forwarded.
        返回：
        the MBeanServer object to which requests will be forwarded, or null if there is none.
        另请参见：
        setMBeanServer(javax.management.MBeanServer)

      • setMBeanServer

        void setMBeanServer(MBeanServer mbs)
        Sets the MBeanServer object to which requests will be forwarded after treatment by this object.
        参数：
        mbs - the MBeanServer object to which requests will be forwarded.
        抛出：
        IllegalArgumentException - if this object is already forwarding to an MBeanServer object or if mbs is null or if mbs is identical to this object.
        另请参见：
        getMBeanServer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/inaagvagn,,gnn.aSS maan dtdgd.i/idv


NotificationResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 NotificationResult

  • java.lang.Object
    • javax.management.remote.NotificationResult
  • 所有已实现的接口：
    Serializable

    public class NotificationResult
extends Object
implements Serializable

    Result of a query for buffered notifications. Notifications in a notification buffer have positive, monotonically increasing sequence numbers. The result of a notification query contains the following elements:

    • The sequence number of the earliest notification still in the buffer.
    • The sequence number of the next notification available for querying. This will be the starting sequence number for the next notification query.
    • An array of (Notification,listenerID) pairs corresponding to the returned notifications and the listeners they correspond to.

    It is possible for the nextSequenceNumber to be less than the earliestSequenceNumber. This signifies that notifications between the two might have been lost.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotificationResult(long earliestSequenceNumber, long nextSequenceNumber, TargetedNotification[] targetedNotifications)
      Constructs a notification query result.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      long getEarliestSequenceNumber()
      Returns the sequence number of the earliest notification still in the buffer.
      long getNextSequenceNumber()
      Returns the sequence number of the next notification available for querying.
      TargetedNotification[] getTargetedNotifications()
      Returns the notifications resulting from the query, and the listeners they correspond to.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NotificationResult

        public NotificationResult(long earliestSequenceNumber,
                  long nextSequenceNumber,
                  TargetedNotification[] targetedNotifications)

        Constructs a notification query result.

        参数：
        earliestSequenceNumber - the sequence number of the earliest notification still in the buffer.
        nextSequenceNumber - the sequence number of the next notification available for querying.
        targetedNotifications - the notifications resulting from the query, and the listeners they correspond to. This array can be empty.
        抛出：
        IllegalArgumentException - if targetedNotifications is null or if earliestSequenceNumber or nextSequenceNumber is negative.

    • 方法详细信息

      • getEarliestSequenceNumber

        public long getEarliestSequenceNumber()
        Returns the sequence number of the earliest notification still in the buffer.
        返回：
        the sequence number of the earliest notification still in the buffer.

      • getNextSequenceNumber

        public long getNextSequenceNumber()
        Returns the sequence number of the next notification available for querying.
        返回：
        the sequence number of the next notification available for querying.

      • getTargetedNotifications

        public TargetedNotification[] getTargetedNotifications()
        Returns the notifications resulting from the query, and the listeners they correspond to.
        返回：
        the notifications resulting from the query, and the listeners they correspond to. This array can be empty.

      • toString

        public String toString()
        Returns a string representation of the object. The result should be a concise but informative representation that is easy for a person to read.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bol4ULiRdvrii&nrJtsstiavaaga.)S"g<"i.. St


SubjectDelegationPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.management.remote

类 SubjectDelegationPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.management.remote.SubjectDelegationPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class SubjectDelegationPermission
extends BasicPermission

    Permission required by an authentication identity to perform operations on behalf of an authorization identity.

    A SubjectDelegationPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of the authorization principal classname followed by a period and the authorization principal name, that is "PrincipalClassName.PrincipalName".

    An asterisk may appear by itself, or if immediately preceded by a "." may appear at the end of the target name, to signify a wildcard match.

    For example, "*", "javax.management.remote.JMXPrincipal.*" and "javax.management.remote.JMXPrincipal.delegate" are valid target names. The first one denotes any principal name from any principal class, the second one denotes any principal name of the concrete principal class javax.management.remote.JMXPrincipal and the third one denotes a concrete principal name delegate of the concrete principal class javax.management.remote.JMXPrincipal.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SubjectDelegationPermission(String name)
      Creates a new SubjectDelegationPermission with the specified name.
      SubjectDelegationPermission(String name, String actions)
      Creates a new SubjectDelegationPermission object with the specified name.

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SubjectDelegationPermission

        public SubjectDelegationPermission(String name)
        Creates a new SubjectDelegationPermission with the specified name. The name is the symbolic name of the SubjectDelegationPermission.
        参数：
        name - the name of the SubjectDelegationPermission
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • SubjectDelegationPermission

        public SubjectDelegationPermission(String name,
                           String actions)
        Creates a new SubjectDelegationPermission object with the specified name. The name is the symbolic name of the SubjectDelegationPermission, and the actions String is currently unused and must be null.
        参数：
        name - the name of the SubjectDelegationPermission
        actions - must be null.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty or actions is not null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdfe f rswwt stiyah.lti itct


TargetedNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote

类 TargetedNotification

  • java.lang.Object
    • javax.management.remote.TargetedNotification
  • 所有已实现的接口：
    Serializable

    public class TargetedNotification
extends Object
implements Serializable

    A (Notification, Listener ID) pair.

    This class is used to associate an emitted notification with the listener ID to which it is targeted.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TargetedNotification(Notification notification, Integer listenerID)
      Constructs a TargetedNotification object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Integer getListenerID()
      The ID of the listener to which the notification is targeted.
      Notification getNotification()
      The emitted notification.
      String toString()
      Returns a textual representation of this Targeted Notification.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TargetedNotification

        public TargetedNotification(Notification notification,
                    Integer listenerID)

        Constructs a TargetedNotification object. The object contains a pair (Notification, Listener ID). The Listener ID identifies the client listener to which that notification is targeted. The client listener ID is one previously returned by the connector server in response to an addNotificationListener request.

        参数：
        notification - Notification emitted from the MBean server.
        listenerID - The ID of the listener to which this notification is targeted.
        抛出：
        IllegalArgumentException - if the listenerID or notification is null.

    • 方法详细信息

      • getNotification

        public Notification getNotification()

        The emitted notification.

        返回：
        The notification.

      • getListenerID

        public Integer getListenerID()

        The ID of the listener to which the notification is targeted.

        返回：
        The listener ID.

      • toString

        public String toString()
        Returns a textual representation of this Targeted Notification.
        重载：
        toString in class Object
        返回：
        a String representation of this Targeted Notification.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:t&D D"DlD>til:bi


Uses of Package javax.management.remote

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.remote

  • Packages that use javax.management.remote
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
  • Classes in javax.management.remote used by javax.management.remote
    类与描述
    JMXAddressable
    Implemented by objects that can have a JMXServiceURL address.
    JMXConnector
    The client end of a JMX API connector.
    JMXConnectorServer
    Superclass of every connector server.
    JMXConnectorServerMBean
    MBean interface for connector servers.
    JMXServiceURL
    The address of a JMX API connector server.
    MBeanServerForwarder
    An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
    TargetedNotification
    A (Notification, Listener ID) pair.
  • Classes in javax.management.remote used by javax.management.remote.rmi
    类与描述
    JMXAddressable
    Implemented by objects that can have a JMXServiceURL address.
    JMXConnector
    The client end of a JMX API connector.
    JMXConnectorServer
    Superclass of every connector server.
    JMXConnectorServerMBean
    MBean interface for connector servers.
    JMXServiceURL
    The address of a JMX API connector server.
    MBeanServerForwarder
    An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
    NotificationResult
    Result of a query for buffered notifications.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/idFrFSneeeBr//>p> nrsl


Uses of Class javax.management.remote.JMXConnectionNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXConnectionNotification

No usage of javax.management.remote.JMXConnectionNotification
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tl e>lA/dagr. ._er


Uses of Class javax.management.remote.JMXConnectorFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXConnectorFactory

No usage of javax.management.remote.JMXConnectorFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pi;RrviMJXXXenvvajamem


Uses of Class javax.management.remote.JMXConnectorServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXConnectorServer

  • Packages that use JMXConnectorServer
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of JMXConnectorServer in javax.management.remote

      Methods in javax.management.remote that return JMXConnectorServer
      修饰符与类型 方法与描述
      JMXConnectorServer JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a new connector server at the given address.
      static JMXConnectorServer JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a connector server at the given address.

    • Uses of JMXConnectorServer in javax.management.remote.rmi

      Subclasses of JMXConnectorServer in javax.management.remote.rmi
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o- y> t.


Uses of Class javax.management.remote.JMXConnectorServerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXConnectorServerFactory

No usage of javax.management.remote.JMXConnectorServerFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h=tee/Jermmmnm..eeSoe.


Uses of Class javax.management.remote.JMXPrincipal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXPrincipal

No usage of javax.management.remote.JMXPrincipal
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ebg.//./...llr.�//.yec


Uses of Class javax.management.remote.JMXProviderException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXProviderException

No usage of javax.management.remote.JMXProviderException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xh>鹴a 萺�/t <.d


Uses of Class javax.management.remote.JMXServerErrorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXServerErrorException

No usage of javax.management.remote.JMXServerErrorException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dae; skibr3swrntcss>i


Uses of Class javax.management.remote.JMXServiceURL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.JMXServiceURL

  • Packages that use JMXServiceURL
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of JMXServiceURL in javax.management.remote

      Methods in javax.management.remote that return JMXServiceURL
      修饰符与类型 方法与描述
      JMXServiceURL JMXAddressable.getAddress()
      The address of this object.
      JMXServiceURL JMXConnectorServerMBean.getAddress()
      The address of this connector server.
      Methods in javax.management.remote with parameters of type JMXServiceURL
      修饰符与类型 方法与描述
      static JMXConnector JMXConnectorFactory.connect(JMXServiceURL serviceURL)
      Creates a connection to the connector server at the given address.
      static JMXConnector JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connection to the connector server at the given address.
      JMXConnector JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a new connector client that is ready to connect to the connector server at the given address.
      static JMXConnector JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connector client for the connector server at the given address.
      JMXConnectorServer JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a new connector server at the given address.
      static JMXConnectorServer JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
      Creates a connector server at the given address.

    • Uses of JMXServiceURL in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return JMXServiceURL
      修饰符与类型 | 方法与描述
      JMXServiceURL RMIConnector.getAddress()
      The address of this connector.
      JMXServiceURL | RMIConnectorServer.getAddress()
      Constructors in javax.management.remote.rmi with parameters of type JMXServiceURL
      构造方法与描述
      RMIConnector(JMXServiceURL url, Map<String,?> environment)
      Constructs an RMIConnector that will connect the RMI connector server with the given address.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
      Makes an RMIConnectorServer.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpeecrvactn.o s>crloetp


Uses of Class javax.management.remote.NotificationResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.NotificationResult

  • Packages that use NotificationResult
    软件包 描述
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of NotificationResult in javax.management.remote.rmi

      Methods in javax.management.remote.rmi that return NotificationResult
      修饰符与类型 | 方法与描述
      NotificationResult | RMIConnectionImpl_Stub.fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)
      NotificationResult | RMIConnectionImpl.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
      NotificationResult RMIConnection.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
      Retrieves notifications from the connector server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iA>/asl/>aael�"_�>>�


Uses of Class javax.management.remote.SubjectDelegationPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.SubjectDelegationPermission

No usage of javax.management.remote.SubjectDelegationPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gt"apan"t>>>La<< lse.>


Uses of Class javax.management.remote.TargetedNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.TargetedNotification

  • Packages that use TargetedNotification
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.

    • Uses of TargetedNotification in javax.management.remote

      Methods in javax.management.remote that return TargetedNotification
      修饰符与类型 方法与描述
      TargetedNotification[] NotificationResult.getTargetedNotifications()
      Returns the notifications resulting from the query, and the listeners they correspond to.
      Constructors in javax.management.remote with parameters of type TargetedNotification
      构造方法与描述
      NotificationResult(long earliestSequenceNumber, long nextSequenceNumber, TargetedNotification[] targetedNotifications)
      Constructs a notification query result.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d<被ai�> to鵳�"※e�<


Uses of Interface javax.management.remote.JMXAddressable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXAddressable

  • Packages that use JMXAddressable
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of JMXAddressable in javax.management.remote

      Classes in javax.management.remote that implement JMXAddressable
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of JMXAddressable in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement JMXAddressable
      修饰符与类型 类与描述
      class  RMIConnector
      A connection to a remote RMI connector.
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/ >


Uses of Interface javax.management.remote.JMXAuthenticator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXAuthenticator

No usage of javax.management.remote.JMXAuthenticator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h/td/JMmeooota..aja-ij


Uses of Interface javax.management.remote.JMXConnector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXConnector

  • Packages that use JMXConnector
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of JMXConnector in javax.management.remote

      Methods in javax.management.remote that return JMXConnector
      修饰符与类型 方法与描述
      static JMXConnector JMXConnectorFactory.connect(JMXServiceURL serviceURL)
      Creates a connection to the connector server at the given address.
      static JMXConnector JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connection to the connector server at the given address.
      JMXConnector JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a new connector client that is ready to connect to the connector server at the given address.
      static JMXConnector JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
      Creates a connector client for the connector server at the given address.
      JMXConnector JMXConnectorServerMBean.toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.
      JMXConnector JMXConnectorServer.toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.

    • Uses of JMXConnector in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement JMXConnector
      修饰符与类型 类与描述
      class  RMIConnector
      A connection to a remote RMI connector.
      Methods in javax.management.remote.rmi that return JMXConnector
      修饰符与类型 方法与描述
      JMXConnector RMIConnectorServer.toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/S uF;mup�


Uses of Interface javax.management.remote.JMXConnectorProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXConnectorProvider

No usage of javax.management.remote.JMXConnectorProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p">> nct dsneL".s<>


Uses of Interface javax.management.remote.JMXConnectorServerMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXConnectorServerMBean

  • Packages that use JMXConnectorServerMBean
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of JMXConnectorServerMBean in javax.management.remote

      Classes in javax.management.remote that implement JMXConnectorServerMBean
      修饰符与类型 类与描述
      class  JMXConnectorServer
      Superclass of every connector server.

    • Uses of JMXConnectorServerMBean in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement JMXConnectorServerMBean
      修饰符与类型 类与描述
      class  RMIConnectorServer
      A JMX API connector server that creates RMI-based connections from remote clients.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f<>far h ";>a.be>鱨>mik


Uses of Interface javax.management.remote.JMXConnectorServerProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.JMXConnectorServerProvider

No usage of javax.management.remote.JMXConnectorServerProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.te/remeeeenj..j mmm/


Uses of Interface javax.management.remote.MBeanServerForwarder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.MBeanServerForwarder

  • Packages that use MBeanServerForwarder
    软件包 描述
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of MBeanServerForwarder in javax.management.remote

      Methods in javax.management.remote with parameters of type MBeanServerForwarder
      修饰符与类型 | 方法与描述
      void JMXConnectorServerMBean.setMBeanServerForwarder(MBeanServerForwarder mbsf)
      Inserts an object that intercepts requests for the MBean server that arrive through this connector server.
      void | JMXConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)

    • Uses of MBeanServerForwarder in javax.management.remote.rmi

      Methods in javax.management.remote.rmi with parameters of type MBeanServerForwarder
      修饰符与类型 | 方法与描述
      void | RMIConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

muev/....///.addlastc"tLso


javax.management.remote.rmi

Interfaces

  • RMIConnection
  • RMIServer

Classes

  • RMIConnectionImpl
  • RMIConnectionImpl_Stub
  • RMIConnector
  • RMIConnectorServer
  • RMIIIOPServerImpl
  • RMIJRMPServerImpl
  • RMIServerImpl
  • RMIServerImpl_Stub
b


javax.management.remote.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.remote.rmi

The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

请参见： 描述

  • 接口摘要
    接口 描述
    RMIConnection
    RMI object used to forward an MBeanServer request from a client to its MBeanServer implementation on the server side.
    RMIServer
    RMI object used to establish connections to an RMI connector.
  • Class Summary
    类 描述
    RMIConnectionImpl
    Implementation of the RMIConnection interface.
    RMIConnectionImpl_Stub
    RMIConnector
    A connection to a remote RMI connector.
    RMIConnectorServer
    A JMX API connector server that creates RMI-based connections from remote clients.
    RMIIIOPServerImpl
    An RMIServerImpl that is exported through IIOP and that creates client connections as RMI objects exported through IIOP.
    RMIJRMPServerImpl
    An RMIServer object that is exported through JRMP and that creates client connections as RMI objects exported through JRMP.
    RMIServerImpl
    An RMI object representing a connector server.
    RMIServerImpl_Stub

软件包 javax.management.remote.rmi Description

The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server. This package defines the classes that the user of an RMI connector needs to reference directly, for both the client and server sides. It also defines certain classes that the user will not usually reference directly, but that must be defined so that different implementations of the RMI connector can interoperate.

The RMI connector supports both the JRMP and the IIOP transports for RMI.

Like most connectors in the JMX Remote API, an RMI connector usually has an address, which is a JMXServiceURL. The protocol part of this address is rmi for a connector that uses the default RMI transport (JRMP), or iiop for a connector that uses RMI/IIOP.

There are two forms for RMI connector addresses:

  • In the JNDI form, the URL indicates where to find an RMI stub for the connector. This RMI stub is a Java object of type RMIServer that gives remote access to the connector server. With this address form, the RMI stub is obtained from an external directory entry included in the URL. An external directory is any directory recognized by JNDI, typically the RMI registry, LDAP, or COS Naming.
  • In the encoded form, the URL directly includes the information needed to connect to the connector server. When using RMI/JRMP, the encoded form is the serialized RMI stub for the server object, encoded using BASE64 without embedded newlines. When using RMI/IIOP, the encoded form is the CORBA IOR for the server object.

Addresses are covered in more detail below.

Creating an RMI connector server

The usual way to create an RMI connector server is to supply an RMI connector address to the method JMXConnectorServerFactory.newJMXConnectorServer. The MBean server to which the connector server is attached can be specified as a parameter to that method. Alternatively, the connector server can be registered as an MBean in that MBean server.

An RMI connector server can also be created by constructing an instance of RMIConnectorServer, explicitly or through the MBean server's createMBean method.

Choosing the RMI transport

You can choose the RMI transport (JRMP or IIOP) by specifying rmi or iiop in the protocol part of the serviceURL when creating the connector server. You can also create specialised connector servers by instantiating an appropriate subclass of RMIServerImpl and supplying it to the RMIConnectorServer constructor.

Connector addresses generated by the server

If the serviceURL you specify has an empty URL path (after the optional host and port), or if you do not specify a serviceURL, then the connector server will fabricate a new JMXServiceURL that clients can use to connect:

  • If the serviceURL looks like:

            service:jmx:rmi://host:port

    then the connector server will generate an RMIJRMPServerImpl and the returned JMXServiceURL looks like:

            service:jmx:rmi://host:port/stub/XXXX

    where XXXX is the serialized form of the stub for the generated object, encoded in BASE64 without newlines.

  • If the serviceURL looks like:

            service:jmx:iiop://host:port

    then the connector server will generate an RMIIIOPServerImpl and the returned JMXServiceURL looks like:

            service:jmx:iiop://host:port/ior/IOR:XXXX

    where IOR:XXXX is the standard CORBA encoding of the Interoperable Object Reference for the generated object.

  • If there is no serviceURL, there must be a user-provided RMIServerImpl. If the toStub method on this object returns an instance of Stub, then the connector server will generate a JMXServiceURL using the iiop form above. Otherwise, it will generate a JMXServiceURL using the rmi form.

The host in a user-provided serviceURL is optional. If present, it is copied into the generated JMXServiceURL but otherwise ignored. If absent, the generated JXMServiceURL will have the local host name.

The port in a user-provided serviceURL is also optional. If present, it is also copied into the generated JMXServiceURL; otherwise, the generated JMXServiceURL has no port. For an serviceURL using the rmi protocol, the port, if present, indicates what port the generated remote object should be exported on. It has no other effect.

If the user provides an RMIServerImpl rather than a JMXServiceURL, then the generated JMXServiceURL will have the local host name in its host part and no port.

Connector addresses based on directory entries

As an alternative to the generated addresses just described, the serviceURL address supplied when creating a connector server can specify a directory address in which to store the provided or generated RMIServer stub. This directory address is then used by both client and server.

In this case, the serviceURL has one of these two forms:

    service:jmx:rmi://host:port/jndi/jndi-name
    service:jmx:iiop://host:port/jndi/jndi-name

Here, jndi-name is a string that can be supplied to javax.naming.InitialContext.bind.

As usual, the host and :port can be omitted.

The connector server will generate an RMIServerImpl based on the protocol (rmi or iiop) and, for rmi, the port if any. When the connector server is started, it will derive a stub from this object using its toStub method and store the object using the given jndi-name. The properties defined by the JNDI API are consulted as usual.

For example, if the JMXServiceURL is:

      service:jmx:rmi://ignoredhost/jndi/rmi://myhost/myname
then the connector server will generate an RMIJRMPServerImpl and store its stub using the JNDI name
      rmi://myhost/myname
which means entry myname in the RMI registry running on the default port of host myhost. Note that the RMI registry only allows registration from the local host. So, in this case, myhost must be the name (or a name) of the host that the connector server is running on.

In this JMXServiceURL, the first rmi: specifies the RMI connector, while the second rmi: specifies the RMI registry.

As another example, if the JMXServiceURL is:

      service:jmx:iiop://ignoredhost/jndi/ldap://dirhost:9999/cn=this,ou=that
then the connector server will generate an RMIIIOPServerImpl and store its stub using the JNDI name
      ldap://dirhost:9999/cn=this,ou=that
which means entry cn=this,ou=that in the LDAP directory running on port 9999 of host dirhost.

If the JMXServiceURL is:

      service:jmx:iiop://ignoredhost/jndi/cn=this,ou=that
then the connector server will generate an RMIIIOPServerImpl and store its stub using the JNDI name
      cn=this,ou=that
For this case to work, the JNDI API must have been configured appropriately to supply the information about what directory to use.

In these examples, the host name ignoredhost is not used by the connector server or its clients. It can be omitted, for example:

      service:jmx:iiop:///jndi/cn=this,ou=that

However, it is good practice to use the name of the host where the connector server is running. This is often different from the name of the directory host.

Connector server attributes

When using the default JRMP transport, RMI socket factories can be specified using the attributes jmx.remote.rmi.client.socket.factory and jmx.remote.rmi.server.socket.factory in the environment given to the RMIConnectorServer constructor. The values of these attributes must be of type RMIClientSocketFactory and RMIServerSocketFactory, respectively. These factories are used when creating the RMI objects associated with the connector.

Creating an RMI connector client

An RMI connector client is usually constructed using JMXConnectorFactory, with a JMXServiceURL that has rmi or iiop as its protocol.

If the JMXServiceURL was generated by the server, as described above under "connector addresses generated by the server", then the client will need to obtain it directly or indirectly from the server. Typically, the server makes the JMXServiceURL available by storing it in a file or a lookup service.

If the JMXServiceURL uses the directory syntax, as described above under "connector addresses based on directory entries", then the client may obtain it as just explained, or client and server may both know the appropriate directory entry to use. For example, if the connector server for the Whatsit agent uses the entry whatsit-agent-connector in the RMI registry on host myhost, then client and server can both know that the appropriate JMXServiceURL is:

    service:jmx:rmi:///jndi/rmi://myhost/whatsit-agent-connector

If you have an RMI stub of type RMIServer, you can construct an RMI connection directly by using the appropriate constructor of RMIConnector.

Specifying an ORB for the RMI/IIOP connector

When using the IIOP transport, the client and server can specify what ORB to use with the attribute java.naming.corba.orb. Connection to the ORB happens at start time for the connector server, and at connect time for the connector client. If the java.naming.corba.orb attribute is contained in the environment Map, then its value (an ORB), is used to connect the IIOP Stubs. Otherwise, a new org.omg.CORBA.ORB is created by calling org.omg.CORBA.ORB.init((String[])null,(Properties)null). A later RMI connector client or server in the same JVM can reuse this ORB, or it can create another one in the same way.

If the java.naming.corba.orb attribute is specified and does not point to an ORB, then an IllegalArgumentException will be thrown.

The mechanism described here does not apply when the IIOP Remote objects (Stubs or Servers) are created and connected to an ORB manually before being passed to the RMIConnector and RMIConnectorServer.

Dynamic code downloading

If an RMI connector client or server receives from its peer an instance of a class that it does not know, and if dynamic code downloading is active for the RMI connection, then the class can be downloaded from a codebase specified by the peer. The article Dynamic code downloading using Java RMI explains this in more detail.

从以下版本开始：
1.5
另请参见：
JavaTM Remote Method Invocation (RMI), Java Naming and Directory InterfaceTM (JNDI), RFC 2045, section 6.8, "Base64 Content-Transfer-Encoding"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oon#arsaslsh ta穋


javax.management.remote.rmi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.remote.rmi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
        • javax.management.remote.rmi.RMIConnectorServer
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteStub
        • javax.management.remote.rmi.RMIConnectionImpl_Stub (implements javax.management.remote.rmi.RMIConnection)
        • javax.management.remote.rmi.RMIServerImpl_Stub (implements javax.management.remote.rmi.RMIServer)
    • javax.management.remote.rmi.RMIConnectionImpl (implements javax.management.remote.rmi.RMIConnection, java.rmi.server.Unreferenced)
    • javax.management.remote.rmi.RMIConnector (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnector, java.io.Serializable)
    • javax.management.remote.rmi.RMIServerImpl (implements java.io.Closeable, javax.management.remote.rmi.RMIServer)
      • javax.management.remote.rmi.RMIIIOPServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.management.remote.rmi.RMIConnection (also extends java.rmi.Remote)
  • java.rmi.Remote
    • javax.management.remote.rmi.RMIConnection (also extends java.io.Closeable)
    • javax.management.remote.rmi.RMIServer
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ad f l ro non yr


RMIConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote.rmi

Interface RMIConnection

  • All Superinterfaces:
    AutoCloseable, Closeable, Remote
    All Known Implementing Classes:
    RMIConnectionImpl, RMIConnectionImpl_Stub

    public interface RMIConnection
extends Closeable, Remote

    RMI object used to forward an MBeanServer request from a client to its MBeanServer implementation on the server side. There is one Remote object implementing this interface for each remote client connected to an RMI connector.

    User code does not usually refer to this interface. It is specified as part of the public API so that different implementations of that API will interoperate.

    To ensure that client parameters will be deserialized at the server side with the correct classloader, client parameters such as parameters used to invoke a method are wrapped in a MarshalledObject. An implementation of this interface must first get the appropriate class loader for the operation and its target, then deserialize the marshalled parameters with this classloader. Except as noted, a parameter that is a MarshalledObject or MarshalledObject[] must not be null; the behavior is unspecified if it is.

    Class loading aspects are detailed in the JMX Specification, version 1.4 PDF document.

    Most methods in this interface parallel methods in the MBeanServerConnection interface. Where an aspect of the behavior of a method is not specified here, it is the same as in the corresponding MBeanServerConnection method.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      Integer[] addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
      void close()
      Closes this connection.
      ObjectInstance createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      NotificationResult fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
      Retrieves notifications from the connector server.
      Object getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      String getConnectionId()
      Returns the connection ID.
      String getDefaultDomain(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDefaultDomain().
      String[] getDomains(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDomains().
      Integer getMBeanCount(Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanCount().
      MBeanInfo getMBeanInfo(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      ObjectInstance getObjectInstance(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Object invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      boolean isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
      boolean isRegistered(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.isRegistered(ObjectName).
      Set<ObjectInstance> queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
      Set<ObjectName> queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      void removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      void removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
      void removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
      void setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
      void unregisterMBean(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.unregisterMBean(ObjectName).

    • 方法详细信息

      • getConnectionId

        String getConnectionId()
                       throws IOException

        Returns the connection ID. This string is different for every open connection to a given RMI connector server.

        返回：
        the connection ID
        抛出：
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnector.connect

      • close

        void close()
           throws IOException

        Closes this connection. On return from this method, the RMI object implementing this interface is unexported, so further remote calls to it will fail.

        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface Closeable
        抛出：
        IOException - if the connection could not be closed, or the Remote object could not be unexported, or there was a communication failure when transmitting the remote close request.

      • createMBean

        ObjectInstance createMBean(String className,
                         ObjectName name,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
        Handles the method MBeanServerConnection.createMBean(String, ObjectName).
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • createMBean

        ObjectInstance createMBean(String className,
                         ObjectName name,
                         ObjectName loaderName,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        loaderName - The object name of the class loader to be used.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • createMBean

        ObjectInstance createMBean(String className,
                         ObjectName name,
                         MarshalledObject params,
                         String[] signature,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        params - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern, or no ObjectName is specified for the MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • createMBean

        ObjectInstance createMBean(String className,
                         ObjectName name,
                         ObjectName loaderName,
                         MarshalledObject params,
                         String[] signature,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        loaderName - The object name of the class loader to be used.
        params - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern, or no ObjectName is specified for the MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • unregisterMBean

        void unregisterMBean(ObjectName name,
                   Subject delegationSubject)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
        Handles the method MBeanServerConnection.unregisterMBean(ObjectName).
        参数：
        name - The object name of the MBean to be unregistered.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanRegistrationException - The preDeregister ((MBeanRegistration interface) method of the MBean has thrown an exception.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the MBean you are when trying to unregister is the MBeanServerDelegate MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • getObjectInstance

        ObjectInstance getObjectInstance(ObjectName name,
                               Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        IOException
        Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
        参数：
        name - The object name of the MBean.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The ObjectInstance associated with the MBean specified by name. The contained ObjectName is name and the contained class name is getMBeanInfo(name).getClassName().
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • queryMBeans

        Set<ObjectInstance> queryMBeans(ObjectName name,
                              MarshalledObject query,
                              Subject delegationSubject)
                                throws IOException
        Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        参数：
        name - The object name pattern identifying the MBeans to be retrieved. If null or no domain and key properties are specified, all the MBeans registered will be retrieved.
        query - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectInstance objects for the selected MBeans. If no MBean satisfies the query an empty list is returned.
        抛出：
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • queryNames

        Set<ObjectName> queryNames(ObjectName name,
                         MarshalledObject query,
                         Subject delegationSubject)
                           throws IOException
        Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        参数：
        name - The object name pattern identifying the MBean names to be retrieved. If null or no domain and key properties are specified, the name of all registered MBeans will be retrieved.
        query - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectNames for the MBeans selected. If no MBean satisfies the query, an empty list is returned.
        抛出：
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • isRegistered

        boolean isRegistered(ObjectName name,
                   Subject delegationSubject)
                     throws IOException
        Handles the method MBeanServerConnection.isRegistered(ObjectName).
        参数：
        name - The object name of the MBean to be checked.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        True if the MBean is already registered in the MBean server, false otherwise.
        抛出：
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • getMBeanCount

        Integer getMBeanCount(Subject delegationSubject)
                      throws IOException
        Handles the method MBeanServerConnection.getMBeanCount().
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the number of MBeans registered.
        抛出：
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • getAttribute

        Object getAttribute(ObjectName name,
                  String attribute,
                  Subject delegationSubject)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
        Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
        参数：
        name - The object name of the MBean from which the attribute is to be retrieved.
        attribute - A String specifying the name of the attribute to be retrieved.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The value of the retrieved attribute.
        抛出：
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        MBeanException - Wraps an exception thrown by the MBean's getter.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the getter.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
        RuntimeMBeanException - Wraps a runtime exception thrown by the MBean's getter.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        另请参见：
        setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • getAttributes

        AttributeList getAttributes(ObjectName name,
                          String[] attributes,
                          Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
        Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
        参数：
        name - The object name of the MBean from which the attributes are retrieved.
        attributes - A list of the attributes to be retrieved.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of the retrieved attributes.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        RuntimeOperationsException - Wrap a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        另请参见：
        setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • setAttribute

        void setAttribute(ObjectName name,
                MarshalledObject attribute,
                Subject delegationSubject)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
        Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute). The Attribute parameter is wrapped in a MarshalledObject.
        参数：
        name - The name of the MBean within which the attribute is to be set.
        attribute - The identification of the attribute to be set and the value it is to be set to, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        InvalidAttributeValueException - The value specified for the attribute is not valid.
        MBeanException - Wraps an exception thrown by the MBean's setter.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        另请参见：
        getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

      • setAttributes

        AttributeList setAttributes(ObjectName name,
                          MarshalledObject attributes,
                          Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
        Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList). The AttributeList parameter is wrapped in a MarshalledObject.
        参数：
        name - The object name of the MBean within which the attributes are to be set.
        attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of attributes that were set, with their new values.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        另请参见：
        getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

      • invoke

        Object invoke(ObjectName name,
            String operationName,
            MarshalledObject params,
            String[] signature,
            Subject delegationSubject)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
        Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        参数：
        name - The object name of the MBean on which the method is to be invoked.
        operationName - The name of the operation to be invoked.
        params - An array containing the parameters to be set when the operation is invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The object returned by the operation, which represents the result of invoking the operation on the MBean specified.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanException - Wraps an exception thrown by the MBean's invoked method.
        ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        RuntimeOperationsException - Wraps an IllegalArgumentException when name or operationName is null.

      • getDefaultDomain

        String getDefaultDomain(Subject delegationSubject)
                        throws IOException
        Handles the method MBeanServerConnection.getDefaultDomain().
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the default domain.
        抛出：
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • getDomains

        String[] getDomains(Subject delegationSubject)
                    throws IOException
        Handles the method MBeanServerConnection.getDomains().
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the list of domains.
        抛出：
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.

      • getMBeanInfo

        MBeanInfo getMBeanInfo(ObjectName name,
                     Subject delegationSubject)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
        Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
        参数：
        name - The name of the MBean to analyze
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An instance of MBeanInfo allowing the retrieval of all attributes and operations of this MBean.
        抛出：
        IntrospectionException - An exception occurred during introspection.
        InstanceNotFoundException - The MBean specified was not found.
        ReflectionException - An exception occurred when trying to invoke the getMBeanInfo of a Dynamic MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.

      • isInstanceOf

        boolean isInstanceOf(ObjectName name,
                   String className,
                   Subject delegationSubject)
                     throws InstanceNotFoundException,
                            IOException
        Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
        参数：
        name - The ObjectName of the MBean.
        className - The name of the class.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        true if the MBean specified is an instance of the specified class according to the rules above, false otherwise.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.

      • addNotificationListener

        void addNotificationListener(ObjectName name,
                           ObjectName listener,
                           MarshalledObject filter,
                           MarshalledObject handback,
                           Subject delegationSubject)
                             throws InstanceNotFoundException,
                                    IOException
        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object (handback) parameter is also wrapped in a MarshalledObject.
        参数：
        name - The name of the MBean on which the listener should be added.
        listener - The object name of the listener which will handle the notifications emitted by the registered MBean.
        filter - The filter object, encapsulated into a MarshalledObject. If filter encapsulated in the MarshalledObject has a null value, no filtering will be performed before handling notifications.
        handback - The context to be sent to the listener when a notification is emitted, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name of the notification listener or of the notification broadcaster does not match any of the registered MBeans.
        RuntimeOperationsException - Wraps an IllegalArgumentException. The MBean named by listener exists but does not implement the NotificationListener interface, or name or listener is null.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        另请参见：
        removeNotificationListener(ObjectName, ObjectName, Subject), removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

      • removeNotificationListener

        void removeNotificationListener(ObjectName name,
                              ObjectName listener,
                              Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
        参数：
        name - The name of the MBean on which the listener should be removed.
        listener - The object name of the listener to be removed.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        RuntimeOperationsException - Wraps an IllegalArgumentException when name or listener is null.
        另请参见：
        addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • removeNotificationListener

        void removeNotificationListener(ObjectName name,
                              ObjectName listener,
                              MarshalledObject filter,
                              MarshalledObject handback,
                              Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object parameter is also wrapped in a MarshalledObject.
        参数：
        name - The name of the MBean on which the listener should be removed.
        listener - A listener that was previously added to this MBean.
        filter - The filter that was specified when the listener was added, encapsulated into a MarshalledObject.
        handback - The handback that was specified when the listener was added, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to perform this operation.
        IOException - if a general communication exception occurred.
        RuntimeOperationsException - Wraps an IllegalArgumentException when name or listener is null.
        另请参见：
        addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • addNotificationListeners

        Integer[] addNotificationListeners(ObjectName[] names,
                                 MarshalledObject[] filters,
                                 Subject[] delegationSubjects)
                                   throws InstanceNotFoundException,
                                          IOException

        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).

        Register for notifications from the given MBeans that match the given filters. The remote client can subsequently retrieve the notifications using the fetchNotifications method.

        For each listener, the original NotificationListener and handback are kept on the client side; in order for the client to be able to identify them, the server generates and returns a unique listenerID. This listenerID is forwarded with the Notifications to the remote client.

        If any one of the given (name, filter) pairs cannot be registered, then the operation fails with an exception, and no names or filters are registered.

        参数：
        names - the ObjectNames identifying the MBeans emitting the Notifications.
        filters - an array of marshalled representations of the NotificationFilters. Elements of this array can be null.
        delegationSubjects - the Subjects on behalf of which the listeners are being added. Elements of this array can be null. Also, the delegationSubjects parameter itself can be null, which is equivalent to an array of null values with the same size as the names and filters arrays.
        返回：
        an array of listenerIDs identifying the local listeners. This array has the same number of elements as the parameters.
        抛出：
        IllegalArgumentException - if names or filters is null, or if names contains a null element, or if the three arrays do not all have the same size.
        ClassCastException - if one of the elements of filters unmarshalls as a non-null object that is not a NotificationFilter.
        InstanceNotFoundException - if one of the names does not correspond to any registered MBean.
        SecurityException - if, for one of the MBeans, the client, or the delegated Subject if any, does not have permission to add a listener.
        IOException - if a general communication exception occurred.

      • removeNotificationListeners

        void removeNotificationListeners(ObjectName name,
                               Integer[] listenerIDs,
                               Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        ListenerNotFoundException,
                                        IOException

        Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.

        This method removes one or more NotificationListeners from a given MBean in the MBean server.

        The NotificationListeners are identified by the IDs which were returned by the addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) method.

        参数：
        name - the ObjectName identifying the MBean emitting the Notifications.
        listenerIDs - the list of the IDs corresponding to the listeners to remove.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - if the given name does not correspond to any registered MBean.
        ListenerNotFoundException - if one of the listeners was not found on the server side. This exception can happen if the MBean discarded a listener for some reason other than a call to MBeanServer.removeNotificationListener.
        SecurityException - if the client, or the delegated Subject if any, does not have permission to remove the listeners.
        IOException - if a general communication exception occurred.
        IllegalArgumentException - if ObjectName or listenerIds is null or if listenerIds contains a null element.

      • fetchNotifications

        NotificationResult fetchNotifications(long clientSequenceNumber,
                                    int maxNotifications,
                                    long timeout)
                                      throws IOException

        Retrieves notifications from the connector server. This method can block until there is at least one notification or until the specified timeout is reached. The method can also return at any time with zero notifications.

        A notification can be included in the result if its sequence number is no less than clientSequenceNumber and this client has registered at least one listener for the MBean generating the notification, with a filter that accepts the notification. Each listener that is interested in the notification is identified by an Integer ID that was returned by addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]).

        参数：
        clientSequenceNumber - the first sequence number that the client is interested in. If negative, it is interpreted as meaning the sequence number that the next notification will have.
        maxNotifications - the maximum number of different notifications to return. The TargetedNotification array in the returned NotificationResult can have more elements than this if the same notification appears more than once. The behavior is unspecified if this parameter is negative.
        timeout - the maximum time in milliseconds to wait for a notification to arrive. This can be 0 to indicate that the method should not wait if there are no notifications, but should return at once. It can be Long.MAX_VALUE to indicate that there is no timeout. The behavior is unspecified if this parameter is negative.
        返回：
        A NotificationResult.
        抛出：
        IOException - if a general communication exception occurred.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


RMIConnectionImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIConnectionImpl

  • java.lang.Object
    • javax.management.remote.rmi.RMIConnectionImpl
  • 所有已实现的接口：
    Closeable, AutoCloseable, Remote, Unreferenced, RMIConnection

    public class RMIConnectionImpl
extends Object
implements RMIConnection, Unreferenced

    Implementation of the RMIConnection interface. User code will not usually reference this class.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
      Constructs a new RMIConnection.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      Integer[] addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
      void close()
      Closes this connection.
      ObjectInstance createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      NotificationResult fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
      Retrieves notifications from the connector server.
      Object getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      String getConnectionId()
      Returns the connection ID.
      String getDefaultDomain(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDefaultDomain().
      String[] getDomains(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDomains().
      Integer getMBeanCount(Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanCount().
      MBeanInfo getMBeanInfo(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      ObjectInstance getObjectInstance(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Object invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      boolean isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
      boolean isRegistered(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.isRegistered(ObjectName).
      Set<ObjectInstance> queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
      Set<ObjectName> queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      void removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      void removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
      void removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
      void setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
      String toString()
      Returns a string representation of this object.
      void unreferenced()
      Called by the RMI runtime sometime after the runtime determines that the reference list, the list of clients referencing the remote object, becomes empty.
      void unregisterMBean(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.unregisterMBean(ObjectName).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RMIConnectionImpl

        public RMIConnectionImpl(RMIServerImpl rmiServer,
                 String connectionId,
                 ClassLoader defaultClassLoader,
                 Subject subject,
                 Map<String,?> env)
        Constructs a new RMIConnection. This connection can be used with either the JRMP or IIOP transport. This object does not export itself: it is the responsibility of the caller to export it appropriately (see RMIJRMPServerImpl.makeClient(String,Subject) and RMIIIOPServerImpl.makeClient(String,Subject).
        参数：
        rmiServer - The RMIServerImpl object for which this connection is created. The behavior is unspecified if this parameter is null.
        connectionId - The ID for this connection. The behavior is unspecified if this parameter is null.
        defaultClassLoader - The default ClassLoader to be used when deserializing marshalled objects. Can be null, to signify the bootstrap class loader.
        subject - the authenticated subject to be used for authorization. Can be null, to signify that no subject has been authenticated.
        env - the environment containing attributes for the new RMIServerImpl. Can be null, equivalent to an empty map.

    • 方法详细信息

      • getConnectionId

        public String getConnectionId()
                       throws IOException
        从接口复制的描述： RMIConnection

        Returns the connection ID. This string is different for every open connection to a given RMI connector server.

        指定者：
        getConnectionId in interface RMIConnection
        返回：
        the connection ID
        抛出：
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnector.connect

      • close

        public void close()
           throws IOException
        从接口复制的描述： RMIConnection

        Closes this connection. On return from this method, the RMI object implementing this interface is unexported, so further remote calls to it will fail.

        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface RMIConnection
        抛出：
        IOException - if the connection could not be closed, or the Remote object could not be unexported, or there was a communication failure when transmitting the remote close request.

      • unreferenced

        public void unreferenced()
        从接口复制的描述： Unreferenced
        Called by the RMI runtime sometime after the runtime determines that the reference list, the list of clients referencing the remote object, becomes empty.
        指定者：
        unreferenced in interface Unreferenced

      • createMBean

        public ObjectInstance createMBean(String className,
                         ObjectName name,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName).
        指定者：
        createMBean in interface RMIConnection
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        IOException - if a general communication exception occurred.

      • createMBean

        public ObjectInstance createMBean(String className,
                         ObjectName name,
                         ObjectName loaderName,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
        指定者：
        createMBean in interface RMIConnection
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        loaderName - The object name of the class loader to be used.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        IOException - if a general communication exception occurred.

      • createMBean

        public ObjectInstance createMBean(String className,
                         ObjectName name,
                         MarshalledObject params,
                         String[] signature,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        createMBean in interface RMIConnection
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        params - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        IOException - if a general communication exception occurred.

      • createMBean

        public ObjectInstance createMBean(String className,
                         ObjectName name,
                         ObjectName loaderName,
                         MarshalledObject params,
                         String[] signature,
                         Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        createMBean in interface RMIConnection
        参数：
        className - The class name of the MBean to be instantiated.
        name - The object name of the MBean. May be null.
        loaderName - The object name of the class loader to be used.
        params - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        IOException - if a general communication exception occurred.

      • unregisterMBean

        public void unregisterMBean(ObjectName name,
                   Subject delegationSubject)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.unregisterMBean(ObjectName).
        指定者：
        unregisterMBean in interface RMIConnection
        参数：
        name - The object name of the MBean to be unregistered.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanRegistrationException - The preDeregister ((MBeanRegistration interface) method of the MBean has thrown an exception.
        IOException - if a general communication exception occurred.

      • getObjectInstance

        public ObjectInstance getObjectInstance(ObjectName name,
                               Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
        指定者：
        getObjectInstance in interface RMIConnection
        参数：
        name - The object name of the MBean.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The ObjectInstance associated with the MBean specified by name. The contained ObjectName is name and the contained class name is getMBeanInfo(name).getClassName().
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        IOException - if a general communication exception occurred.

      • queryMBeans

        public Set<ObjectInstance> queryMBeans(ObjectName name,
                              MarshalledObject query,
                              Subject delegationSubject)
                                throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        指定者：
        queryMBeans in interface RMIConnection
        参数：
        name - The object name pattern identifying the MBeans to be retrieved. If null or no domain and key properties are specified, all the MBeans registered will be retrieved.
        query - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectInstance objects for the selected MBeans. If no MBean satisfies the query an empty list is returned.
        抛出：
        IOException - if a general communication exception occurred.

      • queryNames

        public Set<ObjectName> queryNames(ObjectName name,
                         MarshalledObject query,
                         Subject delegationSubject)
                           throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        指定者：
        queryNames in interface RMIConnection
        参数：
        name - The object name pattern identifying the MBean names to be retrieved. If null or no domain and key properties are specified, the name of all registered MBeans will be retrieved.
        query - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectNames for the MBeans selected. If no MBean satisfies the query, an empty list is returned.
        抛出：
        IOException - if a general communication exception occurred.

      • isRegistered

        public boolean isRegistered(ObjectName name,
                   Subject delegationSubject)
                     throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.isRegistered(ObjectName).
        指定者：
        isRegistered in interface RMIConnection
        参数：
        name - The object name of the MBean to be checked.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        True if the MBean is already registered in the MBean server, false otherwise.
        抛出：
        IOException - if a general communication exception occurred.

      • getMBeanCount

        public Integer getMBeanCount(Subject delegationSubject)
                      throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getMBeanCount().
        指定者：
        getMBeanCount in interface RMIConnection
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the number of MBeans registered.
        抛出：
        IOException - if a general communication exception occurred.

      • getAttribute

        public Object getAttribute(ObjectName name,
                  String attribute,
                  Subject delegationSubject)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
        指定者：
        getAttribute in interface RMIConnection
        参数：
        name - The object name of the MBean from which the attribute is to be retrieved.
        attribute - A String specifying the name of the attribute to be retrieved.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The value of the retrieved attribute.
        抛出：
        MBeanException - Wraps an exception thrown by the MBean's getter.
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the getter.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • getAttributes

        public AttributeList getAttributes(ObjectName name,
                          String[] attributes,
                          Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
        指定者：
        getAttributes in interface RMIConnection
        参数：
        name - The object name of the MBean from which the attributes are retrieved.
        attributes - A list of the attributes to be retrieved.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of the retrieved attributes.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • setAttribute

        public void setAttribute(ObjectName name,
                MarshalledObject attribute,
                Subject delegationSubject)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute). The Attribute parameter is wrapped in a MarshalledObject.
        指定者：
        setAttribute in interface RMIConnection
        参数：
        name - The name of the MBean within which the attribute is to be set.
        attribute - The identification of the attribute to be set and the value it is to be set to, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        InvalidAttributeValueException - The value specified for the attribute is not valid.
        MBeanException - Wraps an exception thrown by the MBean's setter.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

      • setAttributes

        public AttributeList setAttributes(ObjectName name,
                          MarshalledObject attributes,
                          Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList). The AttributeList parameter is wrapped in a MarshalledObject.
        指定者：
        setAttributes in interface RMIConnection
        参数：
        name - The object name of the MBean within which the attributes are to be set.
        attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of attributes that were set, with their new values.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

      • invoke

        public Object invoke(ObjectName name,
            String operationName,
            MarshalledObject params,
            String[] signature,
            Subject delegationSubject)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        invoke in interface RMIConnection
        参数：
        name - The object name of the MBean on which the method is to be invoked.
        operationName - The name of the operation to be invoked.
        params - An array containing the parameters to be set when the operation is invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked. Can be null, equivalent to an empty array.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The object returned by the operation, which represents the result of invoking the operation on the MBean specified.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanException - Wraps an exception thrown by the MBean's invoked method.
        ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
        IOException - if a general communication exception occurred.

      • getDefaultDomain

        public String getDefaultDomain(Subject delegationSubject)
                        throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getDefaultDomain().
        指定者：
        getDefaultDomain in interface RMIConnection
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the default domain.
        抛出：
        IOException - if a general communication exception occurred.

      • getDomains

        public String[] getDomains(Subject delegationSubject)
                    throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getDomains().
        指定者：
        getDomains in interface RMIConnection
        参数：
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the list of domains.
        抛出：
        IOException - if a general communication exception occurred.

      • getMBeanInfo

        public MBeanInfo getMBeanInfo(ObjectName name,
                     Subject delegationSubject)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
        指定者：
        getMBeanInfo in interface RMIConnection
        参数：
        name - The name of the MBean to analyze
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An instance of MBeanInfo allowing the retrieval of all attributes and operations of this MBean.
        抛出：
        InstanceNotFoundException - The MBean specified was not found.
        IntrospectionException - An exception occurred during introspection.
        ReflectionException - An exception occurred when trying to invoke the getMBeanInfo of a Dynamic MBean.
        IOException - if a general communication exception occurred.

      • isInstanceOf

        public boolean isInstanceOf(ObjectName name,
                   String className,
                   Subject delegationSubject)
                     throws InstanceNotFoundException,
                            IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
        指定者：
        isInstanceOf in interface RMIConnection
        参数：
        name - The ObjectName of the MBean.
        className - The name of the class.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        true if the MBean specified is an instance of the specified class according to the rules above, false otherwise.
        抛出：
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        IOException - if a general communication exception occurred.

      • addNotificationListeners

        public Integer[] addNotificationListeners(ObjectName[] names,
                                 MarshalledObject[] filters,
                                 Subject[] delegationSubjects)
                                   throws InstanceNotFoundException,
                                          IOException
        从接口复制的描述： RMIConnection

        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).

        Register for notifications from the given MBeans that match the given filters. The remote client can subsequently retrieve the notifications using the fetchNotifications method.

        For each listener, the original NotificationListener and handback are kept on the client side; in order for the client to be able to identify them, the server generates and returns a unique listenerID. This listenerID is forwarded with the Notifications to the remote client.

        If any one of the given (name, filter) pairs cannot be registered, then the operation fails with an exception, and no names or filters are registered.

        指定者：
        addNotificationListeners in interface RMIConnection
        参数：
        names - the ObjectNames identifying the MBeans emitting the Notifications.
        filters - an array of marshalled representations of the NotificationFilters. Elements of this array can be null.
        delegationSubjects - the Subjects on behalf of which the listeners are being added. Elements of this array can be null. Also, the delegationSubjects parameter itself can be null, which is equivalent to an array of null values with the same size as the names and filters arrays.
        返回：
        an array of listenerIDs identifying the local listeners. This array has the same number of elements as the parameters.
        抛出：
        InstanceNotFoundException - if one of the names does not correspond to any registered MBean.
        IOException - if a general communication exception occurred.

      • addNotificationListener

        public void addNotificationListener(ObjectName name,
                           ObjectName listener,
                           MarshalledObject filter,
                           MarshalledObject handback,
                           Subject delegationSubject)
                             throws InstanceNotFoundException,
                                    IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object (handback) parameter is also wrapped in a MarshalledObject.
        指定者：
        addNotificationListener in interface RMIConnection
        参数：
        name - The name of the MBean on which the listener should be added.
        listener - The object name of the listener which will handle the notifications emitted by the registered MBean.
        filter - The filter object, encapsulated into a MarshalledObject. If filter encapsulated in the MarshalledObject has a null value, no filtering will be performed before handling notifications.
        handback - The context to be sent to the listener when a notification is emitted, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name of the notification listener or of the notification broadcaster does not match any of the registered MBeans.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.removeNotificationListener(ObjectName, ObjectName, Subject), RMIConnection.removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

      • removeNotificationListeners

        public void removeNotificationListeners(ObjectName name,
                               Integer[] listenerIDs,
                               Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        ListenerNotFoundException,
                                        IOException
        从接口复制的描述： RMIConnection

        Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.

        This method removes one or more NotificationListeners from a given MBean in the MBean server.

        The NotificationListeners are identified by the IDs which were returned by the RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) method.

        指定者：
        removeNotificationListeners in interface RMIConnection
        参数：
        name - the ObjectName identifying the MBean emitting the Notifications.
        listenerIDs - the list of the IDs corresponding to the listeners to remove.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - if the given name does not correspond to any registered MBean.
        ListenerNotFoundException - if one of the listeners was not found on the server side. This exception can happen if the MBean discarded a listener for some reason other than a call to MBeanServer.removeNotificationListener.
        IOException - if a general communication exception occurred.

      • removeNotificationListener

        public void removeNotificationListener(ObjectName name,
                              ObjectName listener,
                              Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
        指定者：
        removeNotificationListener in interface RMIConnection
        参数：
        name - The name of the MBean on which the listener should be removed.
        listener - The object name of the listener to be removed.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • removeNotificationListener

        public void removeNotificationListener(ObjectName name,
                              ObjectName listener,
                              MarshalledObject filter,
                              MarshalledObject handback,
                              Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object parameter is also wrapped in a MarshalledObject.
        指定者：
        removeNotificationListener in interface RMIConnection
        参数：
        name - The name of the MBean on which the listener should be removed.
        listener - A listener that was previously added to this MBean.
        filter - The filter that was specified when the listener was added, encapsulated into a MarshalledObject.
        handback - The handback that was specified when the listener was added, encapsulated into a MarshalledObject.
        delegationSubject - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • fetchNotifications

        public NotificationResult fetchNotifications(long clientSequenceNumber,
                                    int maxNotifications,
                                    long timeout)
                                      throws IOException
        从接口复制的描述： RMIConnection

        Retrieves notifications from the connector server. This method can block until there is at least one notification or until the specified timeout is reached. The method can also return at any time with zero notifications.

        A notification can be included in the result if its sequence number is no less than clientSequenceNumber and this client has registered at least one listener for the MBean generating the notification, with a filter that accepts the notification. Each listener that is interested in the notification is identified by an Integer ID that was returned by RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]).

        指定者：
        fetchNotifications in interface RMIConnection
        参数：
        clientSequenceNumber - the first sequence number that the client is interested in. If negative, it is interpreted as meaning the sequence number that the next notification will have.
        maxNotifications - the maximum number of different notifications to return. The TargetedNotification array in the returned NotificationResult can have more elements than this if the same notification appears more than once. The behavior is unspecified if this parameter is negative.
        timeout - the maximum time in milliseconds to wait for a notification to arrive. This can be 0 to indicate that the method should not wait if there are no notifications, but should return at once. It can be Long.MAX_VALUE to indicate that there is no timeout. The behavior is unspecified if this parameter is negative.
        返回：
        A NotificationResult.
        抛出：
        IOException - if a general communication exception occurred.

      • toString

        public String toString()

        Returns a string representation of this object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read.

        重载：
        toString in class Object
        返回：
        a String representation of this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIConnectionImpl_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIConnectionImpl_Stub

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteStub
        • javax.management.remote.rmi.RMIConnectionImpl_Stub
  • 所有已实现的接口：
    Closeable, Serializable, AutoCloseable, Remote, RMIConnection

    public final class RMIConnectionImpl_Stub
extends RemoteStub
implements RMIConnection
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIConnectionImpl_Stub(RemoteRef ref)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      Integer[] addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
      void close()
      Closes this connection.
      ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      NotificationResult fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)
      Retrieves notifications from the connector server.
      Object getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      String getConnectionId()
      Returns the connection ID.
      String getDefaultDomain(Subject $param_Subject_1)
      Handles the method MBeanServerConnection.getDefaultDomain().
      String[] getDomains(Subject $param_Subject_1)
      Handles the method MBeanServerConnection.getDomains().
      Integer getMBeanCount(Subject $param_Subject_1)
      Handles the method MBeanServerConnection.getMBeanCount().
      MBeanInfo getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      ObjectInstance getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Object invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      boolean isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
      boolean isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      Handles the method MBeanServerConnection.isRegistered(ObjectName).
      Set queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
      Set queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      void removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      void removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
      void removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
      Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
      void setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
      void unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      Handles the method MBeanServerConnection.unregisterMBean(ObjectName).

      • 方法 - 继承于类 java.rmi.server.RemoteStub

        setRef

      • 方法 - 继承于类 java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RMIConnectionImpl_Stub

        public RMIConnectionImpl_Stub(RemoteRef ref)

    • 方法详细信息

      • addNotificationListener

        public void addNotificationListener(ObjectName $param_ObjectName_1,
                           ObjectName $param_ObjectName_2,
                           MarshalledObject $param_MarshalledObject_3,
                           MarshalledObject $param_MarshalledObject_4,
                           Subject $param_Subject_5)
                             throws IOException,
                                    InstanceNotFoundException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object (handback) parameter is also wrapped in a MarshalledObject.
        指定者：
        addNotificationListener in interface RMIConnection
        参数：
        $param_ObjectName_1 - The name of the MBean on which the listener should be added.
        $param_ObjectName_2 - The object name of the listener which will handle the notifications emitted by the registered MBean.
        $param_MarshalledObject_3 - The filter object, encapsulated into a MarshalledObject. If filter encapsulated in the MarshalledObject has a null value, no filtering will be performed before handling notifications.
        $param_MarshalledObject_4 - The context to be sent to the listener when a notification is emitted, encapsulated into a MarshalledObject.
        $param_Subject_5 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean name of the notification listener or of the notification broadcaster does not match any of the registered MBeans.
        另请参见：
        RMIConnection.removeNotificationListener(ObjectName, ObjectName, Subject), RMIConnection.removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

      • addNotificationListeners

        public Integer[] addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1,
                                 MarshalledObject[] $param_arrayOf_MarshalledObject_2,
                                 Subject[] $param_arrayOf_Subject_3)
                                   throws IOException,
                                          InstanceNotFoundException
        从接口复制的描述： RMIConnection

        Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).

        Register for notifications from the given MBeans that match the given filters. The remote client can subsequently retrieve the notifications using the fetchNotifications method.

        For each listener, the original NotificationListener and handback are kept on the client side; in order for the client to be able to identify them, the server generates and returns a unique listenerID. This listenerID is forwarded with the Notifications to the remote client.

        If any one of the given (name, filter) pairs cannot be registered, then the operation fails with an exception, and no names or filters are registered.

        指定者：
        addNotificationListeners in interface RMIConnection
        参数：
        $param_arrayOf_ObjectName_1 - the ObjectNames identifying the MBeans emitting the Notifications.
        $param_arrayOf_MarshalledObject_2 - an array of marshalled representations of the NotificationFilters. Elements of this array can be null.
        $param_arrayOf_Subject_3 - the Subjects on behalf of which the listeners are being added. Elements of this array can be null. Also, the delegationSubjects parameter itself can be null, which is equivalent to an array of null values with the same size as the names and filters arrays.
        返回：
        an array of listenerIDs identifying the local listeners. This array has the same number of elements as the parameters.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - if one of the names does not correspond to any registered MBean.

      • close

        public void close()
           throws IOException
        从接口复制的描述： RMIConnection

        Closes this connection. On return from this method, the RMI object implementing this interface is unexported, so further remote calls to it will fail.

        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface RMIConnection
        抛出：
        IOException - if the connection could not be closed, or the Remote object could not be unexported, or there was a communication failure when transmitting the remote close request.

      • createMBean

        public ObjectInstance createMBean(String $param_String_1,
                         ObjectName $param_ObjectName_2,
                         MarshalledObject $param_MarshalledObject_3,
                         String[] $param_arrayOf_String_4,
                         Subject $param_Subject_5)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        createMBean in interface RMIConnection
        参数：
        $param_String_1 - The class name of the MBean to be instantiated.
        $param_ObjectName_2 - The object name of the MBean. May be null.
        $param_MarshalledObject_3 - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        $param_arrayOf_String_4 - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        $param_Subject_5 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        IOException - if a general communication exception occurred.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.

      • createMBean

        public ObjectInstance createMBean(String $param_String_1,
                         ObjectName $param_ObjectName_2,
                         ObjectName $param_ObjectName_3,
                         MarshalledObject $param_MarshalledObject_4,
                         String[] $param_arrayOf_String_5,
                         Subject $param_Subject_6)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  InstanceNotFoundException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        createMBean in interface RMIConnection
        参数：
        $param_String_1 - The class name of the MBean to be instantiated.
        $param_ObjectName_2 - The object name of the MBean. May be null.
        $param_ObjectName_3 - The object name of the class loader to be used.
        $param_MarshalledObject_4 - An array containing the parameters of the constructor to be invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        $param_arrayOf_String_5 - An array containing the signature of the constructor to be invoked. Can be null, equivalent to an empty array.
        $param_Subject_6 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        IOException - if a general communication exception occurred.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.

      • createMBean

        public ObjectInstance createMBean(String $param_String_1,
                         ObjectName $param_ObjectName_2,
                         ObjectName $param_ObjectName_3,
                         Subject $param_Subject_4)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  InstanceNotFoundException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
        指定者：
        createMBean in interface RMIConnection
        参数：
        $param_String_1 - The class name of the MBean to be instantiated.
        $param_ObjectName_2 - The object name of the MBean. May be null.
        $param_ObjectName_3 - The object name of the class loader to be used.
        $param_Subject_4 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        IOException - if a general communication exception occurred.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        InstanceNotFoundException - The specified class loader is not registered in the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.

      • createMBean

        public ObjectInstance createMBean(String $param_String_1,
                         ObjectName $param_ObjectName_2,
                         Subject $param_Subject_3)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.createMBean(String, ObjectName).
        指定者：
        createMBean in interface RMIConnection
        参数：
        $param_String_1 - The class name of the MBean to be instantiated.
        $param_ObjectName_2 - The object name of the MBean. May be null.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
        抛出：
        IOException - if a general communication exception occurred.
        InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
        MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
        MBeanException - The constructor of the MBean has thrown an exception.
        NotCompliantMBeanException - This class is not a JMX compliant MBean.
        ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.

      • fetchNotifications

        public NotificationResult fetchNotifications(long $param_long_1,
                                    int $param_int_2,
                                    long $param_long_3)
                                      throws IOException
        从接口复制的描述： RMIConnection

        Retrieves notifications from the connector server. This method can block until there is at least one notification or until the specified timeout is reached. The method can also return at any time with zero notifications.

        A notification can be included in the result if its sequence number is no less than clientSequenceNumber and this client has registered at least one listener for the MBean generating the notification, with a filter that accepts the notification. Each listener that is interested in the notification is identified by an Integer ID that was returned by RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]).

        指定者：
        fetchNotifications in interface RMIConnection
        参数：
        $param_long_1 - the first sequence number that the client is interested in. If negative, it is interpreted as meaning the sequence number that the next notification will have.
        $param_int_2 - the maximum number of different notifications to return. The TargetedNotification array in the returned NotificationResult can have more elements than this if the same notification appears more than once. The behavior is unspecified if this parameter is negative.
        $param_long_3 - the maximum time in milliseconds to wait for a notification to arrive. This can be 0 to indicate that the method should not wait if there are no notifications, but should return at once. It can be Long.MAX_VALUE to indicate that there is no timeout. The behavior is unspecified if this parameter is negative.
        返回：
        A NotificationResult.
        抛出：
        IOException - if a general communication exception occurred.

      • getAttribute

        public Object getAttribute(ObjectName $param_ObjectName_1,
                  String $param_String_2,
                  Subject $param_Subject_3)
                    throws IOException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           MBeanException,
                           ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
        指定者：
        getAttribute in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean from which the attribute is to be retrieved.
        $param_String_2 - A String specifying the name of the attribute to be retrieved.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The value of the retrieved attribute.
        抛出：
        IOException - if a general communication exception occurred.
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanException - Wraps an exception thrown by the MBean's getter.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the getter.
        另请参见：
        RMIConnection.setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • getAttributes

        public AttributeList getAttributes(ObjectName $param_ObjectName_1,
                          String[] $param_arrayOf_String_2,
                          Subject $param_Subject_3)
                            throws IOException,
                                   InstanceNotFoundException,
                                   ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
        指定者：
        getAttributes in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean from which the attributes are retrieved.
        $param_arrayOf_String_2 - A list of the attributes to be retrieved.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of the retrieved attributes.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        另请参见：
        RMIConnection.setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • getConnectionId

        public String getConnectionId()
                       throws IOException
        从接口复制的描述： RMIConnection

        Returns the connection ID. This string is different for every open connection to a given RMI connector server.

        指定者：
        getConnectionId in interface RMIConnection
        返回：
        the connection ID
        抛出：
        IOException - if a general communication exception occurred.
        另请参见：
        RMIConnector.connect

      • getDefaultDomain

        public String getDefaultDomain(Subject $param_Subject_1)
                        throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getDefaultDomain().
        指定者：
        getDefaultDomain in interface RMIConnection
        参数：
        $param_Subject_1 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the default domain.
        抛出：
        IOException - if a general communication exception occurred.

      • getDomains

        public String[] getDomains(Subject $param_Subject_1)
                    throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getDomains().
        指定者：
        getDomains in interface RMIConnection
        参数：
        $param_Subject_1 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the list of domains.
        抛出：
        IOException - if a general communication exception occurred.

      • getMBeanCount

        public Integer getMBeanCount(Subject $param_Subject_1)
                      throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getMBeanCount().
        指定者：
        getMBeanCount in interface RMIConnection
        参数：
        $param_Subject_1 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        the number of MBeans registered.
        抛出：
        IOException - if a general communication exception occurred.

      • getMBeanInfo

        public MBeanInfo getMBeanInfo(ObjectName $param_ObjectName_1,
                     Subject $param_Subject_2)
                       throws IOException,
                              InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
        指定者：
        getMBeanInfo in interface RMIConnection
        参数：
        $param_ObjectName_1 - The name of the MBean to analyze
        $param_Subject_2 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        An instance of MBeanInfo allowing the retrieval of all attributes and operations of this MBean.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified was not found.
        IntrospectionException - An exception occurred during introspection.
        ReflectionException - An exception occurred when trying to invoke the getMBeanInfo of a Dynamic MBean.

      • getObjectInstance

        public ObjectInstance getObjectInstance(ObjectName $param_ObjectName_1,
                               Subject $param_Subject_2)
                                 throws IOException,
                                        InstanceNotFoundException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
        指定者：
        getObjectInstance in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean.
        $param_Subject_2 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The ObjectInstance associated with the MBean specified by name. The contained ObjectName is name and the contained class name is getMBeanInfo(name).getClassName().
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.

      • invoke

        public Object invoke(ObjectName $param_ObjectName_1,
            String $param_String_2,
            MarshalledObject $param_MarshalledObject_3,
            String[] $param_arrayOf_String_4,
            Subject $param_Subject_5)
              throws IOException,
                     InstanceNotFoundException,
                     MBeanException,
                     ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]). The Object[] parameter is wrapped in a MarshalledObject.
        指定者：
        invoke in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean on which the method is to be invoked.
        $param_String_2 - The name of the operation to be invoked.
        $param_MarshalledObject_3 - An array containing the parameters to be set when the operation is invoked, encapsulated into a MarshalledObject. The encapsulated array can be null, equivalent to an empty array.
        $param_arrayOf_String_4 - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked. Can be null, equivalent to an empty array.
        $param_Subject_5 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The object returned by the operation, which represents the result of invoking the operation on the MBean specified.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanException - Wraps an exception thrown by the MBean's invoked method.
        ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.

      • isInstanceOf

        public boolean isInstanceOf(ObjectName $param_ObjectName_1,
                   String $param_String_2,
                   Subject $param_Subject_3)
                     throws IOException,
                            InstanceNotFoundException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
        指定者：
        isInstanceOf in interface RMIConnection
        参数：
        $param_ObjectName_1 - The ObjectName of the MBean.
        $param_String_2 - The name of the class.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        true if the MBean specified is an instance of the specified class according to the rules above, false otherwise.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.

      • isRegistered

        public boolean isRegistered(ObjectName $param_ObjectName_1,
                   Subject $param_Subject_2)
                     throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.isRegistered(ObjectName).
        指定者：
        isRegistered in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean to be checked.
        $param_Subject_2 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        True if the MBean is already registered in the MBean server, false otherwise.
        抛出：
        IOException - if a general communication exception occurred.

      • queryMBeans

        public Set queryMBeans(ObjectName $param_ObjectName_1,
              MarshalledObject $param_MarshalledObject_2,
              Subject $param_Subject_3)
                throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        指定者：
        queryMBeans in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name pattern identifying the MBeans to be retrieved. If null or no domain and key properties are specified, all the MBeans registered will be retrieved.
        $param_MarshalledObject_2 - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectInstance objects for the selected MBeans. If no MBean satisfies the query an empty list is returned.
        抛出：
        IOException - if a general communication exception occurred.

      • queryNames

        public Set queryNames(ObjectName $param_ObjectName_1,
             MarshalledObject $param_MarshalledObject_2,
             Subject $param_Subject_3)
               throws IOException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp). The QueryExp is wrapped in a MarshalledObject.
        指定者：
        queryNames in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name pattern identifying the MBean names to be retrieved. If null or no domain and key properties are specified, the name of all registered MBeans will be retrieved.
        $param_MarshalledObject_2 - The query expression to be applied for selecting MBeans, encapsulated into a MarshalledObject. If the MarshalledObject encapsulates a null value no query expression will be applied for selecting MBeans.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        A set containing the ObjectNames for the MBeans selected. If no MBean satisfies the query, an empty list is returned.
        抛出：
        IOException - if a general communication exception occurred.

      • removeNotificationListener

        public void removeNotificationListener(ObjectName $param_ObjectName_1,
                              ObjectName $param_ObjectName_2,
                              MarshalledObject $param_MarshalledObject_3,
                              MarshalledObject $param_MarshalledObject_4,
                              Subject $param_Subject_5)
                                throws IOException,
                                       InstanceNotFoundException,
                                       ListenerNotFoundException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). The NotificationFilter parameter is wrapped in a MarshalledObject. The Object parameter is also wrapped in a MarshalledObject.
        指定者：
        removeNotificationListener in interface RMIConnection
        参数：
        $param_ObjectName_1 - The name of the MBean on which the listener should be removed.
        $param_ObjectName_2 - A listener that was previously added to this MBean.
        $param_MarshalledObject_3 - The filter that was specified when the listener was added, encapsulated into a MarshalledObject.
        $param_MarshalledObject_4 - The handback that was specified when the listener was added, encapsulated into a MarshalledObject.
        $param_Subject_5 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
        另请参见：
        RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • removeNotificationListener

        public void removeNotificationListener(ObjectName $param_ObjectName_1,
                              ObjectName $param_ObjectName_2,
                              Subject $param_Subject_3)
                                throws IOException,
                                       InstanceNotFoundException,
                                       ListenerNotFoundException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
        指定者：
        removeNotificationListener in interface RMIConnection
        参数：
        $param_ObjectName_1 - The name of the MBean on which the listener should be removed.
        $param_ObjectName_2 - The object name of the listener to be removed.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
        ListenerNotFoundException - The listener is not registered in the MBean.
        另请参见：
        RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

      • removeNotificationListeners

        public void removeNotificationListeners(ObjectName $param_ObjectName_1,
                               Integer[] $param_arrayOf_Integer_2,
                               Subject $param_Subject_3)
                                 throws IOException,
                                        InstanceNotFoundException,
                                        ListenerNotFoundException
        从接口复制的描述： RMIConnection

        Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.

        This method removes one or more NotificationListeners from a given MBean in the MBean server.

        The NotificationListeners are identified by the IDs which were returned by the RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) method.

        指定者：
        removeNotificationListeners in interface RMIConnection
        参数：
        $param_ObjectName_1 - the ObjectName identifying the MBean emitting the Notifications.
        $param_arrayOf_Integer_2 - the list of the IDs corresponding to the listeners to remove.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - if the given name does not correspond to any registered MBean.
        ListenerNotFoundException - if one of the listeners was not found on the server side. This exception can happen if the MBean discarded a listener for some reason other than a call to MBeanServer.removeNotificationListener.

      • setAttribute

        public void setAttribute(ObjectName $param_ObjectName_1,
                MarshalledObject $param_MarshalledObject_2,
                Subject $param_Subject_3)
                  throws IOException,
                         AttributeNotFoundException,
                         InstanceNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute). The Attribute parameter is wrapped in a MarshalledObject.
        指定者：
        setAttribute in interface RMIConnection
        参数：
        $param_ObjectName_1 - The name of the MBean within which the attribute is to be set.
        $param_MarshalledObject_2 - The identification of the attribute to be set and the value it is to be set to, encapsulated into a MarshalledObject.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        AttributeNotFoundException - The attribute specified is not accessible in the MBean.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        InvalidAttributeValueException - The value specified for the attribute is not valid.
        MBeanException - Wraps an exception thrown by the MBean's setter.
        ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
        另请参见：
        RMIConnection.getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

      • setAttributes

        public AttributeList setAttributes(ObjectName $param_ObjectName_1,
                          MarshalledObject $param_MarshalledObject_2,
                          Subject $param_Subject_3)
                            throws IOException,
                                   InstanceNotFoundException,
                                   ReflectionException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList). The AttributeList parameter is wrapped in a MarshalledObject.
        指定者：
        setAttributes in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean within which the attributes are to be set.
        $param_MarshalledObject_2 - A list of attributes: The identification of the attributes to be set and the values they are to be set to, encapsulated into a MarshalledObject.
        $param_Subject_3 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        返回：
        The list of attributes that were set, with their new values.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
        另请参见：
        RMIConnection.getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

      • unregisterMBean

        public void unregisterMBean(ObjectName $param_ObjectName_1,
                   Subject $param_Subject_2)
                     throws IOException,
                            InstanceNotFoundException,
                            MBeanRegistrationException
        从接口复制的描述： RMIConnection
        Handles the method MBeanServerConnection.unregisterMBean(ObjectName).
        指定者：
        unregisterMBean in interface RMIConnection
        参数：
        $param_ObjectName_1 - The object name of the MBean to be unregistered.
        $param_Subject_2 - The Subject containing the delegation principals or null if the authentication principal is used instead.
        抛出：
        IOException - if a general communication exception occurred.
        InstanceNotFoundException - The MBean specified is not registered in the MBean server.
        MBeanRegistrationException - The preDeregister ((MBeanRegistration interface) method of the MBean has thrown an exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;nEdadSdpdr&&drrto;;m.p飋帮�


RMIConnector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIConnector

  • java.lang.Object
    • javax.management.remote.rmi.RMIConnector
  • 所有已实现的接口：
    Closeable, Serializable, AutoCloseable, JMXAddressable, JMXConnector

    public class RMIConnector
extends Object
implements JMXConnector, Serializable, JMXAddressable

    A connection to a remote RMI connector. Usually, such connections are made using JMXConnectorFactory. However, specialized applications can use this class directly, for example with an RMIServer stub obtained without going through JNDI.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • 字段 - 继承于接口 javax.management.remote.JMXConnector

        CREDENTIALS

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIConnector(JMXServiceURL url, Map<String,?> environment)
      Constructs an RMIConnector that will connect the RMI connector server with the given address.
      RMIConnector(RMIServer rmiServer, Map<String,?> environment)
      Constructs an RMIConnector using the given RMI stub.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Adds a listener to be informed of changes in connection status.
      void close()
      Closes the client connection to its server.
      void connect()
      Establishes the connection to the connector server.
      void connect(Map<String,?> environment)
      Establishes the connection to the connector server.
      JMXServiceURL getAddress()
      The address of this connector.
      String getConnectionId()
      Gets this connection's ID from the connector server.
      MBeanServerConnection getMBeanServerConnection()
      Returns an MBeanServerConnection object representing a remote MBean server.
      MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
      Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.
      void removeConnectionNotificationListener(NotificationListener listener)
      Removes a listener from the list to be informed of changes in status.
      void removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
      Removes a listener from the list to be informed of changes in status.
      String toString()
      Returns a string representation of this object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RMIConnector

        public RMIConnector(JMXServiceURL url,
            Map<String,?> environment)

        Constructs an RMIConnector that will connect the RMI connector server with the given address.

        The address can refer directly to the connector server, using one of the following syntaxes:

         service:jmx:rmi://[host[:port]]/stub/encoded-stub
 service:jmx:iiop://[host[:port]]/ior/encoded-IOR

        (Here, the square brackets [] are not part of the address but indicate that the host and port are optional.)

        The address can instead indicate where to find an RMI stub through JNDI, using one of the following syntaxes:

         service:jmx:rmi://[host[:port]]/jndi/jndi-name
 service:jmx:iiop://[host[:port]]/jndi/jndi-name

        An implementation may also recognize additional address syntaxes, for example:

         service:jmx:iiop://[host[:port]]/stub/encoded-stub
        参数：
        url - the address of the RMI connector server.
        environment - additional attributes specifying how to make the connection. For JNDI-based addresses, these attributes can usefully include JNDI attributes recognized by InitialContext. This parameter can be null, which is equivalent to an empty Map.
        抛出：
        IllegalArgumentException - if url is null.

      • RMIConnector

        public RMIConnector(RMIServer rmiServer,
            Map<String,?> environment)

        Constructs an RMIConnector using the given RMI stub.

        参数：
        rmiServer - an RMI stub representing the RMI connector server.
        environment - additional attributes specifying how to make the connection. This parameter can be null, which is equivalent to an empty Map.
        抛出：
        IllegalArgumentException - if rmiServer is null.

    • 方法详细信息

      • toString

        public String toString()

        Returns a string representation of this object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read.

        重载：
        toString in class Object
        返回：
        a String representation of this object.

      • getAddress

        public JMXServiceURL getAddress()

        The address of this connector.

        指定者：
        getAddress in interface JMXAddressable
        返回：
        the address of this connector, or null if it does not have one.
        从以下版本开始：
        1.6

      • connect

        public void connect()
             throws IOException
        从接口复制的描述： JMXConnector

        Establishes the connection to the connector server. This method is equivalent to connect(null).

        指定者：
        connect in interface JMXConnector
        抛出：
        IOException - if the connection could not be made because of a communication problem.

      • connect

        public void connect(Map<String,?> environment)
             throws IOException
        从接口复制的描述： JMXConnector

        Establishes the connection to the connector server.

        If connect has already been called successfully on this object, calling it again has no effect. If, however, JMXConnector.close() was called after connect, the new connect will throw an IOException.

        Otherwise, either connect has never been called on this object, or it has been called but produced an exception. Then calling connect will attempt to establish a connection to the connector server.

        指定者：
        connect in interface JMXConnector
        参数：
        environment - the properties of the connection. Properties in this map override properties in the map specified when the JMXConnector was created, if any. This parameter can be null, which is equivalent to an empty map.
        抛出：
        IOException - if the connection could not be made because of a communication problem.

      • getConnectionId

        public String getConnectionId()
                       throws IOException
        从接口复制的描述： JMXConnector

        Gets this connection's ID from the connector server. For a given connector server, every connection will have a unique id which does not change during the lifetime of the connection.

        指定者：
        getConnectionId in interface JMXConnector
        返回：
        the unique ID of this connection. This is the same as the ID that the connector server includes in its JMXConnectionNotifications. The package description describes the conventions for connection IDs.
        抛出：
        IOException - if the connection ID cannot be obtained, for instance because the connection is closed or broken.

      • getMBeanServerConnection

        public MBeanServerConnection getMBeanServerConnection()
                                               throws IOException
        从接口复制的描述： JMXConnector

        Returns an MBeanServerConnection object representing a remote MBean server. For a given JMXConnector, two successful calls to this method will usually return the same MBeanServerConnection object, though this is not required.

        For each method in the returned MBeanServerConnection, calling the method causes the corresponding method to be called in the remote MBean server. The value returned by the MBean server method is the value returned to the client. If the MBean server method produces an Exception, the same Exception is seen by the client. If the MBean server method, or the attempt to call it, produces an Error, the Error is wrapped in a JMXServerErrorException, which is seen by the client.

        Calling this method is equivalent to calling getMBeanServerConnection(null) meaning that no delegation subject is specified and that all the operations called on the MBeanServerConnection must use the authenticated subject, if any.

        指定者：
        getMBeanServerConnection in interface JMXConnector
        返回：
        an object that implements the MBeanServerConnection interface by forwarding its methods to the remote MBean server.
        抛出：
        IOException - if a valid MBeanServerConnection cannot be created, for instance because the connection to the remote MBean server has not yet been established (with the connect method), or it has been closed, or it has broken.

      • getMBeanServerConnection

        public MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
                                               throws IOException
        从接口复制的描述： JMXConnector

        Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject. For a given JMXConnector and Subject, two successful calls to this method will usually return the same MBeanServerConnection object, though this is not required.

        For each method in the returned MBeanServerConnection, calling the method causes the corresponding method to be called in the remote MBean server on behalf of the given delegation subject instead of the authenticated subject. The value returned by the MBean server method is the value returned to the client. If the MBean server method produces an Exception, the same Exception is seen by the client. If the MBean server method, or the attempt to call it, produces an Error, the Error is wrapped in a JMXServerErrorException, which is seen by the client.

        指定者：
        getMBeanServerConnection in interface JMXConnector
        参数：
        delegationSubject - the Subject on behalf of which requests will be performed. Can be null, in which case requests will be performed on behalf of the authenticated Subject, if any.
        返回：
        an object that implements the MBeanServerConnection interface by forwarding its methods to the remote MBean server on behalf of a given delegation subject.
        抛出：
        IOException - if a valid MBeanServerConnection cannot be created, for instance because the connection to the remote MBean server has not yet been established (with the connect method), or it has been closed, or it has broken.

      • addConnectionNotificationListener

        public void addConnectionNotificationListener(NotificationListener listener,
                                     NotificationFilter filter,
                                     Object handback)
        从接口复制的描述： JMXConnector

        Adds a listener to be informed of changes in connection status. The listener will receive notifications of type JMXConnectionNotification. An implementation can send other types of notifications too.

        Any number of listeners can be added with this method. The same listener can be added more than once with the same or different values for the filter and handback. There is no special treatment of a duplicate entry. For example, if a listener is registered twice with no filter, then its handleNotification method will be called twice for each notification.

        指定者：
        addConnectionNotificationListener in interface JMXConnector
        参数：
        listener - a listener to receive connection status notifications.
        filter - a filter to select which notifications are to be delivered to the listener, or null if all notifications are to be delivered.
        handback - an object to be given to the listener along with each notification. Can be null.
        另请参见：
        JMXConnector.removeConnectionNotificationListener(javax.management.NotificationListener), NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • removeConnectionNotificationListener

        public void removeConnectionNotificationListener(NotificationListener listener)
                                          throws ListenerNotFoundException
        从接口复制的描述： JMXConnector

        Removes a listener from the list to be informed of changes in status. The listener must previously have been added. If there is more than one matching listener, all are removed.

        指定者：
        removeConnectionNotificationListener in interface JMXConnector
        参数：
        listener - a listener to receive connection status notifications.
        抛出：
        ListenerNotFoundException - if the listener is not registered with this JMXConnector.
        另请参见：
        JMXConnector.removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object), JMXConnector.addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • removeConnectionNotificationListener

        public void removeConnectionNotificationListener(NotificationListener listener,
                                        NotificationFilter filter,
                                        Object handback)
                                          throws ListenerNotFoundException
        从接口复制的描述： JMXConnector

        Removes a listener from the list to be informed of changes in status. The listener must previously have been added with the same three parameters. If there is more than one matching listener, only one is removed.

        指定者：
        removeConnectionNotificationListener in interface JMXConnector
        参数：
        listener - a listener to receive connection status notifications.
        filter - a filter to select which notifications are to be delivered to the listener. Can be null.
        handback - an object to be given to the listener along with each notification. Can be null.
        抛出：
        ListenerNotFoundException - if the listener is not registered with this JMXConnector, or is not registered with the given filter and handback.
        另请参见：
        JMXConnector.removeConnectionNotificationListener(NotificationListener),
JMXConnector.addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object),
NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

      • close

        public void close()
           throws IOException
        从接口复制的描述： JMXConnector

        Closes the client connection to its server. Any ongoing or new request using the MBeanServerConnection returned by JMXConnector.getMBeanServerConnection() will get an IOException.

        If close has already been called successfully on this object, calling it again has no effect. If close has never been called, or if it was called but produced an exception, an attempt will be made to close the connection. This attempt can succeed, in which case close will return normally, or it can generate an exception.

        Closing a connection is a potentially slow operation. For example, if the server has crashed, the close operation might have to wait for a network protocol timeout. Callers that do not want to block in a close operation should do it in a separate thread.

        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface JMXConnector
        抛出：
        IOException - if the connection cannot be closed cleanly. If this exception is thrown, it is not known whether the server end of the connection has been cleanly closed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"eimbeoleolssollAv//eocalmme.e(lhots..ea>篸>a.>g


RMIConnectorServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIConnectorServer

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.remote.JMXConnectorServer
        • javax.management.remote.rmi.RMIConnectorServer
  • 所有已实现的接口：
    MBeanRegistration, NotificationBroadcaster, NotificationEmitter, JMXAddressable, JMXConnectorServerMBean

    public class RMIConnectorServer
extends JMXConnectorServer

    A JMX API connector server that creates RMI-based connections from remote clients. Usually, such connector servers are made using JMXConnectorServerFactory. However, specialized applications can use this class directly, for example with an RMIServerImpl object.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String JNDI_REBIND_ATTRIBUTE
      Name of the attribute that specifies whether the RMIServer stub that represents an RMI connector server should override an existing stub at the same address.
      static String RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE
      Name of the attribute that specifies the RMIClientSocketFactory for the RMI objects created in conjunction with this connector.
      static String RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE
      Name of the attribute that specifies the RMIServerSocketFactory for the RMI objects created in conjunction with this connector.

      • Fields inherited from class javax.management.remote.JMXConnectorServer

        AUTHENTICATOR

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
      Makes an RMIConnectorServer.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void connectionClosed(String connectionId, String message, Object userData)
      Called by a subclass when a client connection is closed normally.
      protected void connectionFailed(String connectionId, String message, Object userData)
      Called by a subclass when a client connection fails.
      protected void connectionOpened(String connectionId, String message, Object userData)
      Called by a subclass when a new client connection is opened.
      JMXServiceURL getAddress()
      The address of this connector server.
      Map<String,?> getAttributes()
      The attributes for this connector server.
      boolean isActive()
      Determines whether the connector server is active.
      void setMBeanServerForwarder(MBeanServerForwarder mbsf)
      Inserts an object that intercepts requests for the MBean server that arrive through this connector server.
      void start()
      Activates the connector server, that is starts listening for client connections.
      void stop()
      Deactivates the connector server, that is, stops listening for client connections.
      JMXConnector toJMXConnector(Map<String,?> env)
      Returns a client stub for this connector server.

      • 方法 - 继承于类 javax.management.remote.JMXConnectorServer

        getConnectionIds, getMBeanServer, getNotificationInfo, postDeregister, postRegister, preDeregister, preRegister

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JNDI_REBIND_ATTRIBUTE

        public static final String JNDI_REBIND_ATTRIBUTE

        Name of the attribute that specifies whether the RMIServer stub that represents an RMI connector server should override an existing stub at the same address. The value associated with this attribute, if any, should be a string that is equal, ignoring case, to "true" or "false". The default value is false.

        另请参见：
        Constant Field Values

      • RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE

        public static final String RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE

        Name of the attribute that specifies the RMIClientSocketFactory for the RMI objects created in conjunction with this connector. The value associated with this attribute must be of type RMIClientSocketFactory and can only be specified in the Map argument supplied when creating a connector server.

        另请参见：
        Constant Field Values

      • RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE

        public static final String RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE

        Name of the attribute that specifies the RMIServerSocketFactory for the RMI objects created in conjunction with this connector. The value associated with this attribute must be of type RMIServerSocketFactory and can only be specified in the Map argument supplied when creating a connector server.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • RMIConnectorServer

        public RMIConnectorServer(JMXServiceURL url,
                  Map<String,?> environment)
                   throws IOException

        Makes an RMIConnectorServer. This is equivalent to calling RMIConnectorServer(directoryURL,environment,null,null)

        参数：
        url - the URL defining how to create the connector server. Cannot be null.
        environment - attributes governing the creation and storing of the RMI object. Can be null, which is equivalent to an empty Map.
        抛出：
        IllegalArgumentException - if url is null.
        MalformedURLException - if url does not conform to the syntax for an RMI connector, or if its protocol is not recognized by this implementation. Only "rmi" and "iiop" are valid when this constructor is used.
        IOException - if the connector server cannot be created for some reason or if it is inevitable that its start method will fail.

      • RMIConnectorServer

        public RMIConnectorServer(JMXServiceURL url,
                  Map<String,?> environment,
                  MBeanServer mbeanServer)
                   throws IOException

        Makes an RMIConnectorServer for the given MBean server. This is equivalent to calling RMIConnectorServer(directoryURL,environment,null,mbeanServer)

        参数：
        url - the URL defining how to create the connector server. Cannot be null.
        environment - attributes governing the creation and storing of the RMI object. Can be null, which is equivalent to an empty Map.
        mbeanServer - the MBean server to which the new connector server is attached, or null if it will be attached by being registered as an MBean in the MBean server.
        抛出：
        IllegalArgumentException - if url is null.
        MalformedURLException - if url does not conform to the syntax for an RMI connector, or if its protocol is not recognized by this implementation. Only "rmi" and "iiop" are valid when this constructor is used.
        IOException - if the connector server cannot be created for some reason or if it is inevitable that its start method will fail.

      • RMIConnectorServer

        public RMIConnectorServer(JMXServiceURL url,
                  Map<String,?> environment,
                  RMIServerImpl rmiServerImpl,
                  MBeanServer mbeanServer)
                   throws IOException

        Makes an RMIConnectorServer for the given MBean server.

        参数：
        url - the URL defining how to create the connector server. Cannot be null.
        environment - attributes governing the creation and storing of the RMI object. Can be null, which is equivalent to an empty Map.
        rmiServerImpl - An implementation of the RMIServer interface, consistent with the protocol type specified in url. If this parameter is non null, the protocol type specified by url is not constrained, and is assumed to be valid. Otherwise, only "rmi" and "iiop" will be recognized.
        mbeanServer - the MBean server to which the new connector server is attached, or null if it will be attached by being registered as an MBean in the MBean server.
        抛出：
        IllegalArgumentException - if url is null.
        MalformedURLException - if url does not conform to the syntax for an RMI connector, or if its protocol is not recognized by this implementation. Only "rmi" and "iiop" are recognized when rmiServerImpl is null.
        IOException - if the connector server cannot be created for some reason or if it is inevitable that its start method will fail.
        另请参见：
        start()

    • 方法详细信息

      • toJMXConnector

        public JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

        Returns a client stub for this connector server. A client stub is a serializable object whose connect method can be used to make one new connection to this connector server.

        指定者：
        toJMXConnector in interface JMXConnectorServerMBean
        重载：
        toJMXConnector in class JMXConnectorServer
        参数：
        env - client connection parameters of the same sort that could be provided to JMXConnector.connect(Map). Can be null, which is equivalent to an empty map.
        返回：
        a client stub that can be used to make a new connection to this connector server.
        抛出：
        UnsupportedOperationException - if this connector server does not support the generation of client stubs.
        IllegalStateException - if the JMXConnectorServer is not started (see isActive()).
        IOException - if a communications problem means that a stub cannot be created.

      • start

        public void start()
           throws IOException

        Activates the connector server, that is starts listening for client connections. Calling this method when the connector server is already active has no effect. Calling this method when the connector server has been stopped will generate an IOException.

        The behavior of this method when called for the first time depends on the parameters that were supplied at construction, as described below.

        First, an object of a subclass of RMIServerImpl is required, to export the connector server through RMI:

        • If an RMIServerImpl was supplied to the constructor, it is used.
        • Otherwise, if the protocol part of the JMXServiceURL supplied to the constructor was iiop, an object of type RMIIIOPServerImpl is created.
        • Otherwise, if the JMXServiceURL was null, or its protocol part was rmi, an object of type RMIJRMPServerImpl is created.
        • Otherwise, the implementation can create an implementation-specific RMIServerImpl or it can throw MalformedURLException.

        If the given address includes a JNDI directory URL as specified in the package documentation for javax.management.remote.rmi, then this RMIConnectorServer will bootstrap by binding the RMIServerImpl to the given address.

        If the URL path part of the JMXServiceURL was empty or a single slash (/), then the RMI object will not be bound to a directory. Instead, a reference to it will be encoded in the URL path of the RMIConnectorServer address (returned by getAddress()). The encodings for rmi and iiop are described in the package documentation for javax.management.remote.rmi.

        The behavior when the URL path is neither empty nor a JNDI directory URL, or when the protocol is neither rmi nor iiop, is implementation defined, and may include throwing MalformedURLException when the connector server is created or when it is started.

        抛出：
        IllegalStateException - if the connector server has not been attached to an MBean server.
        IOException - if the connector server cannot be started.

      • stop

        public void stop()
          throws IOException

        Deactivates the connector server, that is, stops listening for client connections. Calling this method will also close all client connections that were made by this server. After this method returns, whether normally or with an exception, the connector server will not create any new client connections.

        Once a connector server has been stopped, it cannot be started again.

        Calling this method when the connector server has already been stopped has no effect. Calling this method when the connector server has not yet been started will disable the connector server object permanently.

        If closing a client connection produces an exception, that exception is not thrown from this method. A JMXConnectionNotification is emitted from this MBean with the connection ID of the connection that could not be closed.

        Closing a connector server is a potentially slow operation. For example, if a client machine with an open connection has crashed, the close operation might have to wait for a network protocol timeout. Callers that do not want to block in a close operation should do it in a separate thread.

        This method calls the method close on the connector server's RMIServerImpl object.

        If the RMIServerImpl was bound to a JNDI directory by the start method, it is unbound from the directory by this method.

        抛出：
        IOException - if the server cannot be closed cleanly, or if the RMIServerImpl cannot be unbound from the directory. When this exception is thrown, the server has already attempted to close all client connections, if appropriate; to call RMIServerImpl.close(); and to unbind the RMIServerImpl from its directory, if appropriate. All client connections are closed except possibly those that generated exceptions when the server attempted to close them.

      • isActive

        public boolean isActive()
        从接口复制的描述： JMXConnectorServerMBean

        Determines whether the connector server is active. A connector server starts being active when its start method returns successfully and remains active until either its stop method is called or the connector server fails.

        返回：
        true if the connector server is active.

      • getAddress

        public JMXServiceURL getAddress()
        从接口复制的描述： JMXConnectorServerMBean

        The address of this connector server.

        The address returned may not be the exact original JMXServiceURL that was supplied when creating the connector server, since the original address may not always be complete. For example the port number may be dynamically allocated when starting the connector server. Instead the address returned is the actual JMXServiceURL of the JMXConnectorServer. This is the address that clients supply to JMXConnectorFactory.connect(JMXServiceURL).

        Note that the address returned may be null if the JMXConnectorServer is not yet active.

        返回：
        the address of this connector server, or null if it does not have one.

      • getAttributes

        public Map<String,?> getAttributes()
        从接口复制的描述： JMXConnectorServerMBean

        The attributes for this connector server.

        返回：
        a read-only map containing the attributes for this connector server. Attributes whose values are not serializable are omitted from this map. If there are no serializable attributes, the returned map is empty.

      • setMBeanServerForwarder

        public void setMBeanServerForwarder(MBeanServerForwarder mbsf)
        从接口复制的描述： JMXConnectorServerMBean

        Inserts an object that intercepts requests for the MBean server that arrive through this connector server. This object will be supplied as the MBeanServer for any new connection created by this connector server. Existing connections are unaffected.

        This method can be called more than once with different MBeanServerForwarder objects. The result is a chain of forwarders. The last forwarder added is the first in the chain. In more detail:

        • If this connector server is already associated with an MBeanServer object, then that object is given to mbsf.setMBeanServer. If doing so produces an exception, this method throws the same exception without any other effect.

        • If this connector is not already associated with an MBeanServer object, or if the mbsf.setMBeanServer call just mentioned succeeds, then mbsf becomes this connector server's MBeanServer.

        指定者：
        setMBeanServerForwarder in interface JMXConnectorServerMBean
        重载：
        setMBeanServerForwarder in class JMXConnectorServer
        参数：
        mbsf - the new MBeanServerForwarder.

      • connectionOpened

        protected void connectionOpened(String connectionId,
                    String message,
                    Object userData)
        Description copied from class: JMXConnectorServer

        Called by a subclass when a new client connection is opened. Adds connectionId to the list returned by JMXConnectorServer.getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.OPENED.

        重载：
        connectionOpened in class JMXConnectorServer
        参数：
        connectionId - the ID of the new connection. This must be different from the ID of any connection previously opened by this connector server.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().

      • connectionClosed

        protected void connectionClosed(String connectionId,
                    String message,
                    Object userData)
        Description copied from class: JMXConnectorServer

        Called by a subclass when a client connection is closed normally. Removes connectionId from the list returned by JMXConnectorServer.getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.CLOSED.

        重载：
        connectionClosed in class JMXConnectorServer
        参数：
        connectionId - the ID of the closed connection.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().

      • connectionFailed

        protected void connectionFailed(String connectionId,
                    String message,
                    Object userData)
        Description copied from class: JMXConnectorServer

        Called by a subclass when a client connection fails. Removes connectionId from the list returned by JMXConnectorServer.getConnectionIds(), then emits a JMXConnectionNotification with type JMXConnectionNotification.FAILED.

        重载：
        connectionFailed in class JMXConnectorServer
        参数：
        connectionId - the ID of the failed connection.
        message - the message for the emitted JMXConnectionNotification. Can be null. See Notification.getMessage().
        userData - the userData for the emitted JMXConnectionNotification. Can be null. See Notification.getUserData().
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RMIIIOPServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIIIOPServerImpl

  • java.lang.Object
    • javax.management.remote.rmi.RMIServerImpl
      • javax.management.remote.rmi.RMIIIOPServerImpl
  • 所有已实现的接口：
    Closeable, AutoCloseable, Remote, RMIServer

    public class RMIIIOPServerImpl
extends RMIServerImpl

    An RMIServerImpl that is exported through IIOP and that creates client connections as RMI objects exported through IIOP. User code does not usually reference this class directly.

    从以下版本开始：
    1.5
    另请参见：
    RMIServerImpl

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIIIOPServerImpl(Map<String,?> env)
      Creates a new RMIServerImpl.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void closeClient(RMIConnection client)
      Closes a client connection made by makeClient.
      protected void closeServer()
      Called by RMIServerImpl.close() to close the connector server by unexporting this object.
      protected void export()
      Exports this RMI object.
      protected String getProtocol()
      Returns the protocol string for this object.
      protected RMIConnection makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through IIOP.
      Remote toStub()
      Returns an IIOP stub.

      • 方法 - 继承于类 javax.management.remote.rmi.RMIServerImpl

        clientClosed, close, getDefaultClassLoader, getMBeanServer, getVersion, newClient, setDefaultClassLoader, setMBeanServer

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RMIIIOPServerImpl

        public RMIIIOPServerImpl(Map<String,?> env)
                  throws IOException

        Creates a new RMIServerImpl.

        参数：
        env - the environment containing attributes for the new RMIServerImpl. Can be null, which is equivalent to an empty Map.
        抛出：
        IOException - if the RMI object cannot be created.

    • 方法详细信息

      • export

        protected void export()
               throws IOException
        Description copied from class: RMIServerImpl

        Exports this RMI object.

        指定者：
        export in class RMIServerImpl
        抛出：
        IOException - if this RMI object cannot be exported.

      • getProtocol

        protected String getProtocol()
        Description copied from class: RMIServerImpl

        Returns the protocol string for this object. The string is rmi for RMI/JRMP and iiop for RMI/IIOP.

        指定者：
        getProtocol in class RMIServerImpl
        返回：
        the protocol string for this object.

      • toStub

        public Remote toStub()
              throws IOException

        Returns an IIOP stub.

        The stub might not yet be connected to the ORB. The stub will be serializable only if it is connected to the ORB.
        指定者：
        toStub in class RMIServerImpl
        返回：
        an IIOP stub.
        抛出：
        IOException - if the stub cannot be created - e.g the RMIIIOPServerImpl has not been exported yet.

      • makeClient

        protected RMIConnection makeClient(String connectionId,
                       Subject subject)
                            throws IOException

        Creates a new client connection as an RMI object exported through IIOP.

        指定者：
        makeClient in class RMIServerImpl
        参数：
        connectionId - the ID of the new connection. Every connection opened by this connector server will have a different ID. The behavior is unspecified if this parameter is null.
        subject - the authenticated subject. Can be null.
        返回：
        the newly-created RMIConnection.
        抛出：
        IOException - if the new client object cannot be created or exported.

      • closeClient

        protected void closeClient(RMIConnection client)
                    throws IOException
        Description copied from class: RMIServerImpl

        Closes a client connection made by makeClient.

        指定者：
        closeClient in class RMIServerImpl
        参数：
        client - a connection previously returned by makeClient on which the closeClient method has not previously been called. The behavior is unspecified if these conditions are violated, including the case where client is null.
        抛出：
        IOException - if the client connection cannot be closed.

      • closeServer

        protected void closeServer()
                    throws IOException

        Called by RMIServerImpl.close() to close the connector server by unexporting this object. After returning from this method, the connector server must not accept any new connections.

        指定者：
        closeServer in class RMIServerImpl
        抛出：
        IOException - if the attempt to close the connector server failed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C K_e.Sr.SreeSrrninn: sd�/


RMIJRMPServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIJRMPServerImpl

  • java.lang.Object
    • javax.management.remote.rmi.RMIServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl
  • 所有已实现的接口：
    Closeable, AutoCloseable, Remote, RMIServer

    public class RMIJRMPServerImpl
extends RMIServerImpl

    An RMIServer object that is exported through JRMP and that creates client connections as RMI objects exported through JRMP. User code does not usually reference this class directly.

    从以下版本开始：
    1.5
    另请参见：
    RMIServerImpl

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
      Creates a new RMIServer object that will be exported on the given port using the given socket factories.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void closeClient(RMIConnection client)
      Closes a client connection made by makeClient.
      protected void closeServer()
      Called by RMIServerImpl.close() to close the connector server by unexporting this object.
      protected void export()
      Exports this RMI object.
      protected String getProtocol()
      Returns the protocol string for this object.
      protected RMIConnection makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through JRMP.
      Remote toStub()
      Returns a serializable stub for this RMIServer object.

      • 方法 - 继承于类 javax.management.remote.rmi.RMIServerImpl

        clientClosed, close, getDefaultClassLoader, getMBeanServer, getVersion, newClient, setDefaultClassLoader, setMBeanServer

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RMIJRMPServerImpl

        public RMIJRMPServerImpl(int port,
                 RMIClientSocketFactory csf,
                 RMIServerSocketFactory ssf,
                 Map<String,?> env)
                  throws IOException

        Creates a new RMIServer object that will be exported on the given port using the given socket factories.

        参数：
        port - the port on which this object and the RMIConnectionImpl objects it creates will be exported. Can be zero, to indicate any available port.
        csf - the client socket factory for the created RMI objects. Can be null.
        ssf - the server socket factory for the created RMI objects. Can be null.
        env - the environment map. Can be null.
        抛出：
        IOException - if the RMIServer object cannot be created.
        IllegalArgumentException - if port is negative.

    • 方法详细信息

      • export

        protected void export()
               throws IOException
        Description copied from class: RMIServerImpl

        Exports this RMI object.

        指定者：
        export in class RMIServerImpl
        抛出：
        IOException - if this RMI object cannot be exported.

      • getProtocol

        protected String getProtocol()
        Description copied from class: RMIServerImpl

        Returns the protocol string for this object. The string is rmi for RMI/JRMP and iiop for RMI/IIOP.

        指定者：
        getProtocol in class RMIServerImpl
        返回：
        the protocol string for this object.

      • toStub

        public Remote toStub()
              throws IOException

        Returns a serializable stub for this RMIServer object.

        指定者：
        toStub in class RMIServerImpl
        返回：
        a serializable stub.
        抛出：
        IOException - if the stub cannot be obtained - e.g the RMIJRMPServerImpl has not been exported yet.

      • makeClient

        protected RMIConnection makeClient(String connectionId,
                       Subject subject)
                            throws IOException

        Creates a new client connection as an RMI object exported through JRMP. The port and socket factories for the new RMIConnection object are the ones supplied to the RMIJRMPServerImpl constructor.

        指定者：
        makeClient in class RMIServerImpl
        参数：
        connectionId - the ID of the new connection. Every connection opened by this connector server will have a different id. The behavior is unspecified if this parameter is null.
        subject - the authenticated subject. Can be null.
        返回：
        the newly-created RMIConnection.
        抛出：
        IOException - if the new RMIConnection object cannot be created or exported.

      • closeClient

        protected void closeClient(RMIConnection client)
                    throws IOException
        Description copied from class: RMIServerImpl

        Closes a client connection made by makeClient.

        指定者：
        closeClient in class RMIServerImpl
        参数：
        client - a connection previously returned by makeClient on which the closeClient method has not previously been called. The behavior is unspecified if these conditions are violated, including the case where client is null.
        抛出：
        IOException - if the client connection cannot be closed.

      • closeServer

        protected void closeServer()
                    throws IOException

        Called by RMIServerImpl.close() to close the connector server by unexporting this object. After returning from this method, the connector server must not accept any new connections.

        指定者：
        closeServer in class RMIServerImpl
        抛出：
        IOException - if the attempt to close the connector server failed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oke-ttl薘.c>avtlRtsn胹d<=pty膖aa湘v/c"B.b


RMIServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.remote.rmi

Interface RMIServer

  • All Superinterfaces:
    Remote
    All Known Implementing Classes:
    RMIIIOPServerImpl, RMIJRMPServerImpl, RMIServerImpl, RMIServerImpl_Stub

    public interface RMIServer
extends Remote

    RMI object used to establish connections to an RMI connector. There is one Remote object implementing this interface for each RMI connector.

    User code does not usually refer to this interface. It is specified as part of the public API so that different implementations of that API will interoperate.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getVersion()
      The version of the RMI Connector Protocol understood by this connector server.
      RMIConnection newClient(Object credentials)
      Makes a new connection through this RMI connector.

    • 方法详细信息

      • getVersion

        String getVersion()
                  throws RemoteException

        The version of the RMI Connector Protocol understood by this connector server. This is a string with the following format:

         protocol-version implementation-name

        The protocol-version is a series of two or more non-negative integers separated by periods (.). An implementation of the version described by this documentation must use the string 1.0 here.

        After the protocol version there must be a space, followed by the implementation name. The format of the implementation name is unspecified. It is recommended that it include an implementation version number. An implementation can use an empty string as its implementation name, for example for security reasons.

        返回：
        a string with the format described here.
        抛出：
        RemoteException - if there is a communication exception during the remote method call.

      • newClient

        RMIConnection newClient(Object credentials)
                        throws IOException

        Makes a new connection through this RMI connector. Each remote client calls this method to obtain a new RMI object representing its connection.

        参数：
        credentials - this object specifies the user-defined credentials to be passed in to the server in order to authenticate the user before creating the RMIConnection. Can be null.
        返回：
        the newly-created connection object.
        抛出：
        IOException - if the new client object cannot be created or exported, or if there is a communication exception during the remote method call.
        SecurityException - if the given credentials do not allow the server to authenticate the caller successfully.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.t/f< aa a/>>a//tfccOn.altd ss"m(.t


RMIServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIServerImpl

  • java.lang.Object
    • javax.management.remote.rmi.RMIServerImpl
  • 所有已实现的接口：
    Closeable, AutoCloseable, Remote, RMIServer
    直接已知子类：
    RMIIIOPServerImpl, RMIJRMPServerImpl

    public abstract class RMIServerImpl
extends Object
implements Closeable, RMIServer

    An RMI object representing a connector server. Remote clients can make connections using the newClient(Object) method. This method returns an RMI object representing the connection.

    User code does not usually reference this class directly. RMI connection servers are usually created with the class RMIConnectorServer. Remote clients usually create connections either with JMXConnectorFactory or by instantiating RMIConnector.

    This is an abstract class. Concrete subclasses define the details of the client connection objects, such as whether they use JRMP or IIOP.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIServerImpl(Map<String,?> env)
      Constructs a new RMIServerImpl.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void clientClosed(RMIConnection client)
      Method called when a client connection created by makeClient is closed.
      void close()
      Closes this connection server.
      protected abstract void closeClient(RMIConnection client)
      Closes a client connection made by makeClient.
      protected abstract void closeServer()
      Called by close() to close the connector server.
      protected abstract void export()
      Exports this RMI object.
      ClassLoader getDefaultClassLoader()
      Gets the default ClassLoader used by this connector server.
      MBeanServer getMBeanServer()
      The MBeanServer to which this connector server is attached.
      protected abstract String getProtocol()
      Returns the protocol string for this object.
      String getVersion()
      The version of the RMI Connector Protocol understood by this connector server.
      protected abstract RMIConnection makeClient(String connectionId, Subject subject)
      Creates a new client connection.
      RMIConnection newClient(Object credentials)
      Creates a new client connection.
      void setDefaultClassLoader(ClassLoader cl)
      Sets the default ClassLoader for this connector server.
      void setMBeanServer(MBeanServer mbs)
      Sets the MBeanServer to which this connector server is attached.
      abstract Remote toStub()
      Returns a remotable stub for this server object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RMIServerImpl

        public RMIServerImpl(Map<String,?> env)

        Constructs a new RMIServerImpl.

        参数：
        env - the environment containing attributes for the new RMIServerImpl. Can be null, which is equivalent to an empty Map.

    • 方法详细信息

      • export

        protected abstract void export()
                        throws IOException

        Exports this RMI object.

        抛出：
        IOException - if this RMI object cannot be exported.

      • toStub

        public abstract Remote toStub()
                       throws IOException
        Returns a remotable stub for this server object.
        返回：
        a remotable stub.
        抛出：
        IOException - if the stub cannot be obtained - e.g the RMIServerImpl has not been exported yet.

      • setDefaultClassLoader

        public void setDefaultClassLoader(ClassLoader cl)

        Sets the default ClassLoader for this connector server. New client connections will use this classloader. Existing client connections are unaffected.

        参数：
        cl - the new ClassLoader to be used by this connector server.
        另请参见：
        getDefaultClassLoader()

      • getDefaultClassLoader

        public ClassLoader getDefaultClassLoader()

        Gets the default ClassLoader used by this connector server.

        返回：
        the default ClassLoader used by this connector server.

        另请参见：
        setDefaultClassLoader(java.lang.ClassLoader)

      • setMBeanServer

        public void setMBeanServer(MBeanServer mbs)

        Sets the MBeanServer to which this connector server is attached. New client connections will interact with this MBeanServer. Existing client connections are unaffected.

        参数：
        mbs - the new MBeanServer. Can be null, but new client connections will be refused as long as it is.
        另请参见：
        getMBeanServer()

      • getMBeanServer

        public MBeanServer getMBeanServer()

        The MBeanServer to which this connector server is attached. This is the last value passed to setMBeanServer(javax.management.MBeanServer) on this object, or null if that method has never been called.

        返回：
        the MBeanServer to which this connector is attached.
        另请参见：
        setMBeanServer(javax.management.MBeanServer)

      • getVersion

        public String getVersion()
        从接口复制的描述： RMIServer

        The version of the RMI Connector Protocol understood by this connector server. This is a string with the following format:

         protocol-version implementation-name

        The protocol-version is a series of two or more non-negative integers separated by periods (.). An implementation of the version described by this documentation must use the string 1.0 here.

        After the protocol version there must be a space, followed by the implementation name. The format of the implementation name is unspecified. It is recommended that it include an implementation version number. An implementation can use an empty string as its implementation name, for example for security reasons.

        指定者：
        getVersion in interface RMIServer
        返回：
        a string with the format described here.

      • newClient

        public RMIConnection newClient(Object credentials)
                        throws IOException

        Creates a new client connection. This method calls makeClient and adds the returned client connection object to an internal list. When this RMIServerImpl is shut down via its close() method, the close() method of each object remaining in the list is called.

        The fact that a client connection object is in this internal list does not prevent it from being garbage collected.

        指定者：
        newClient in interface RMIServer
        参数：
        credentials - this object specifies the user-defined credentials to be passed in to the server in order to authenticate the caller before creating the RMIConnection. Can be null.
        返回：
        the newly-created RMIConnection. This is usually the object created by makeClient, though an implementation may choose to wrap that object in another object implementing RMIConnection.
        抛出：
        IOException - if the new client object cannot be created or exported.
        SecurityException - if the given credentials do not allow the server to authenticate the user successfully.
        IllegalStateException - if getMBeanServer() is null.

      • makeClient

        protected abstract RMIConnection makeClient(String connectionId,
                       Subject subject)
                                     throws IOException

        Creates a new client connection. This method is called by the public method newClient(Object).

        参数：
        connectionId - the ID of the new connection. Every connection opened by this connector server will have a different ID. The behavior is unspecified if this parameter is null.
        subject - the authenticated subject. Can be null.
        返回：
        the newly-created RMIConnection.
        抛出：
        IOException - if the new client object cannot be created or exported.

      • closeClient

        protected abstract void closeClient(RMIConnection client)
                             throws IOException

        Closes a client connection made by makeClient.

        参数：
        client - a connection previously returned by makeClient on which the closeClient method has not previously been called. The behavior is unspecified if these conditions are violated, including the case where client is null.
        抛出：
        IOException - if the client connection cannot be closed.

      • getProtocol

        protected abstract String getProtocol()

        Returns the protocol string for this object. The string is rmi for RMI/JRMP and iiop for RMI/IIOP.

        返回：
        the protocol string for this object.

      • clientClosed

        protected void clientClosed(RMIConnection client)
                     throws IOException

        Method called when a client connection created by makeClient is closed. A subclass that defines makeClient must arrange for this method to be called when the resultant object's close method is called. This enables it to be removed from the RMIServerImpl's list of connections. It is not an error for client not to be in that list.

        After removing client from the list of connections, this method calls closeClient(client).

        参数：
        client - the client connection that has been closed.
        抛出：
        IOException - if closeClient(javax.management.remote.rmi.RMIConnection) throws this exception.
        NullPointerException - if client is null.

      • close

        public void close()
           throws IOException

        Closes this connection server. This method first calls the closeServer() method so that no new client connections will be accepted. Then, for each remaining RMIConnection object returned by makeClient, its close method is called.

        The behavior when this method is called more than once is unspecified.

        If closeServer() throws an IOException, the individual connections are nevertheless closed, and then the IOException is thrown from this method.

        If closeServer() returns normally but one or more of the individual connections throws an IOException, then, after closing all the connections, one of those IOExceptions is thrown from this method. If more than one connection throws an IOException, it is unspecified which one is thrown from this method.

        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        抛出：
        IOException - if closeServer() or one of the RMIConnection.close() calls threw IOException.

      • closeServer

        protected abstract void closeServer()
                             throws IOException

        Called by close() to close the connector server. After returning from this method, the connector server must not accept any new connections.

        抛出：
        IOException - if the attempt to close the connector server failed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r


RMIServerImpl_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.remote.rmi

类 RMIServerImpl_Stub

  • java.lang.Object
    • java.rmi.server.RemoteObject
      • java.rmi.server.RemoteStub
        • javax.management.remote.rmi.RMIServerImpl_Stub
  • 所有已实现的接口：
    Serializable, Remote, RMIServer

    public final class RMIServerImpl_Stub
extends RemoteStub
implements RMIServer
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.rmi.server.RemoteObject

        ref

    • 构造方法摘要

      Constructors
      构造方法与描述
      RMIServerImpl_Stub(RemoteRef ref)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getVersion()
      The version of the RMI Connector Protocol understood by this connector server.
      RMIConnection newClient(Object $param_Object_1)
      Makes a new connection through this RMI connector.

      • 方法 - 继承于类 java.rmi.server.RemoteStub

        setRef

      • 方法 - 继承于类 java.rmi.server.RemoteObject

        equals, getRef, hashCode, toString, toStub

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RMIServerImpl_Stub

        public RMIServerImpl_Stub(RemoteRef ref)

    • 方法详细信息

      • getVersion

        public String getVersion()
                  throws RemoteException
        从接口复制的描述： RMIServer

        The version of the RMI Connector Protocol understood by this connector server. This is a string with the following format:

         protocol-version implementation-name

        The protocol-version is a series of two or more non-negative integers separated by periods (.). An implementation of the version described by this documentation must use the string 1.0 here.

        After the protocol version there must be a space, followed by the implementation name. The format of the implementation name is unspecified. It is recommended that it include an implementation version number. An implementation can use an empty string as its implementation name, for example for security reasons.

        指定者：
        getVersion in interface RMIServer
        返回：
        a string with the format described here.
        抛出：
        RemoteException - if there is a communication exception during the remote method call.

      • newClient

        public RMIConnection newClient(Object $param_Object_1)
                        throws IOException
        从接口复制的描述： RMIServer

        Makes a new connection through this RMI connector. Each remote client calls this method to obtain a new RMI object representing its connection.

        指定者：
        newClient in interface RMIServer
        参数：
        $param_Object_1 - this object specifies the user-defined credentials to be passed in to the server in order to authenticate the user before creating the RMIConnection. Can be null.
        返回：
        the newly-created connection object.
        抛出：
        IOException - if the new client object cannot be created or exported, or if there is a communication exception during the remote method call.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//R..../.."...""hnii>< >l "lcksit ii s=a=om


Uses of Package javax.management.remote.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.remote.rmi

  • Packages that use javax.management.remote.rmi
    软件包 描述
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
  • Classes in javax.management.remote.rmi used by javax.management.remote.rmi
    类与描述
    RMIConnection
    RMI object used to forward an MBeanServer request from a client to its MBeanServer implementation on the server side.
    RMIServer
    RMI object used to establish connections to an RMI connector.
    RMIServerImpl
    An RMI object representing a connector server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/=.roioj aaan(<


Uses of Class javax.management.remote.rmi.RMIConnectionImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIConnectionImpl

No usage of javax.management.remote.rmi.RMIConnectionImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ed.mmanvaaaan"hh"araa


Uses of Class javax.management.remote.rmi.RMIConnectionImpl_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIConnectionImpl_Stub

No usage of javax.management.remote.rmi.RMIConnectionImpl_Stub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e u,dcP/flttoQ>


Uses of Class javax.management.remote.rmi.RMIConnector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIConnector

No usage of javax.management.remote.rmi.RMIConnector
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ae—间讳篇嗽冰籶Ｃ怂�


Uses of Class javax.management.remote.rmi.RMIConnectorServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIConnectorServer

No usage of javax.management.remote.rmi.RMIConnectorServer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--meclbo<=gcFm�


Uses of Class javax.management.remote.rmi.RMIIIOPServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIIIOPServerImpl

No usage of javax.management.remote.rmi.RMIIIOPServerImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>-t>e>l-e4><


Uses of Class javax.management.remote.rmi.RMIJRMPServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIJRMPServerImpl

No usage of javax.management.remote.rmi.RMIJRMPServerImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>D\9>lahU趑<;<鈋.


Uses of Class javax.management.remote.rmi.RMIServerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIServerImpl

  • Packages that use RMIServerImpl
    软件包 描述
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of RMIServerImpl in javax.management.remote.rmi

      Subclasses of RMIServerImpl in javax.management.remote.rmi
      修饰符与类型 类与描述
      class  RMIIIOPServerImpl
      An RMIServerImpl that is exported through IIOP and that creates client connections as RMI objects exported through IIOP.
      class  RMIJRMPServerImpl
      An RMIServer object that is exported through JRMP and that creates client connections as RMI objects exported through JRMP.
      Constructors in javax.management.remote.rmi with parameters of type RMIServerImpl
      构造方法与描述
      RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
      Constructs a new RMIConnection.
      RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
      Makes an RMIConnectorServer for the given MBean server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.Ca"n tno/lx>r..=< m/.w p


Uses of Class javax.management.remote.rmi.RMIServerImpl_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.remote.rmi.RMIServerImpl_Stub

No usage of javax.management.remote.rmi.RMIServerImpl_Stub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.vms="cittttlIMM


Uses of Interface javax.management.remote.rmi.RMIConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.rmi.RMIConnection

  • Packages that use RMIConnection
    软件包 描述
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of RMIConnection in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement RMIConnection
      修饰符与类型 | 类与描述
      class  RMIConnectionImpl
      Implementation of the RMIConnection interface.
      class  | RMIConnectionImpl_Stub
      Methods in javax.management.remote.rmi that return RMIConnection
      修饰符与类型 | 方法与描述
      protected RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through IIOP.
      protected RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through JRMP.
      protected abstract RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection.
      RMIConnection | RMIServerImpl_Stub.newClient(Object $param_Object_1)
      RMIConnection RMIServer.newClient(Object credentials)
      Makes a new connection through this RMI connector.
      RMIConnection RMIServerImpl.newClient(Object credentials)
      Creates a new client connection.
      Methods in javax.management.remote.rmi with parameters of type RMIConnection
      修饰符与类型 | 方法与描述
      protected void RMIServerImpl.clientClosed(RMIConnection client)
      Method called when a client connection created by makeClient is closed.
      protected void | RMIIIOPServerImpl.closeClient(RMIConnection client)
      protected void | RMIJRMPServerImpl.closeClient(RMIConnection client)
      protected abstract void RMIServerImpl.closeClient(RMIConnection client)
      Closes a client connection made by makeClient.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pll/aca


Uses of Interface javax.management.remote.rmi.RMIServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.remote.rmi.RMIServer

  • Packages that use RMIServer
    软件包 描述
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.

    • Uses of RMIServer in javax.management.remote.rmi

      Classes in javax.management.remote.rmi that implement RMIServer
      修饰符与类型 | 类与描述
      class  RMIIIOPServerImpl
      An RMIServerImpl that is exported through IIOP and that creates client connections as RMI objects exported through IIOP.
      class  RMIJRMPServerImpl
      An RMIServer object that is exported through JRMP and that creates client connections as RMI objects exported through JRMP.
      class  RMIServerImpl
      An RMI object representing a connector server.
      class  | RMIServerImpl_Stub
      Constructors in javax.management.remote.rmi with parameters of type RMIServer
      构造方法与描述
      RMIConnector(RMIServer rmiServer, Map<String,?> environment)
      Constructs an RMIConnector using the given RMI stub.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" lra lv/t-/jca./=


javax.management.timer

Interfaces

  • TimerMBean

Classes

  • Timer
  • TimerNotification


javax.management.timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.management.timer

Provides the definition of the Timer MBean.

请参见： 描述

  • 接口摘要
    接口 描述
    TimerMBean
    Exposes the management interface of the timer MBean.
  • Class Summary
    类 描述
    Timer
    Provides the implementation of the timer MBean.
    TimerNotification
    This class provides definitions of the notifications sent by timer MBeans.

软件包 javax.management.timer Description

Provides the definition of the Timer MBean. A Timer MBean maintains a list of scheduled notifications and, because it is a NotificationBroadcaster, a list of listeners for those notifications. Whenever the time for one of the scheduled notifications is reached, each listener receives the notification. Notifications can be repeated at a fixed interval, and the number of repetitions can be bounded.

A listener for a Timer MBean can itself be an MBean, using the method MBeanServer.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object). In this way, a management application can create an MBean representing a task, then schedule that task using a Timer MBean.

从以下版本开始：
1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.//e;ow "�=vb/iu


javax.management.timer Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.management.timer

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.timer.TimerNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)

Interface Hierarchy

  • javax.management.timer.TimerMBean
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

glela h.m"".-rr?.?eele


Timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.timer

类 Timer

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport
      • javax.management.timer.Timer
  • 所有已实现的接口：
    MBeanRegistration, NotificationBroadcaster, NotificationEmitter, TimerMBean

    public class Timer
extends NotificationBroadcasterSupport
implements TimerMBean, MBeanRegistration
    Provides the implementation of the timer MBean. The timer MBean sends out an alarm at a specified time that wakes up all the listeners registered to receive timer notifications.

    This class manages a list of dated timer notifications. A method allows users to add/remove as many notifications as required. When a timer notification is emitted by the timer and becomes obsolete, it is automatically removed from the list of timer notifications.
    Additional timer notifications can be added into regularly repeating notifications.

    Note:

    1. When sending timer notifications, the timer updates the notification sequence number irrespective of the notification type.
    2. The timer service relies on the system date of the host where the Timer class is loaded. Listeners may receive untimely notifications if their host has a different system date. To avoid such problems, synchronize the system date of all host machines where timing is needed.
    3. The default behavior for periodic notifications is fixed-delay execution, as specified in Timer. In order to use fixed-rate execution, use the overloaded addNotification(String, String, Object, Date, long, long, boolean) method.
    4. Notification listeners are potentially all executed in the same thread. Therefore, they should execute rapidly to avoid holding up other listeners or perturbing the regularity of fixed-delay executions. See NotificationBroadcasterSupport.
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static long ONE_DAY
      Number of milliseconds in one day.
      static long ONE_HOUR
      Number of milliseconds in one hour.
      static long ONE_MINUTE
      Number of milliseconds in one minute.
      static long ONE_SECOND
      Number of milliseconds in one second.
      static long ONE_WEEK
      Number of milliseconds in one week.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Timer()
      Default constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Integer addNotification(String type, String message, Object userData, Date date)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
      Vector<Integer> getAllNotificationIDs()
      Gets all timer notification identifiers registered into the list of notifications.
      Date getDate(Integer id)
      Gets a copy of the date associated to a timer notification.
      Boolean getFixedRate(Integer id)
      Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.
      int getNbNotifications()
      Gets the number of timer notifications registered into the list of notifications.
      Long getNbOccurences(Integer id)
      Gets a copy of the remaining number of occurrences associated to a timer notification.
      Vector<Integer> getNotificationIDs(String type)
      Gets all the identifiers of timer notifications corresponding to the specified type.
      MBeanNotificationInfo[] getNotificationInfo()
      Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.
      String getNotificationMessage(Integer id)
      Gets the timer notification detailed message corresponding to the specified identifier.
      String getNotificationType(Integer id)
      Gets the timer notification type corresponding to the specified identifier.
      Object getNotificationUserData(Integer id)
      Gets the timer notification user data object corresponding to the specified identifier.
      Long getPeriod(Integer id)
      Gets a copy of the period (in milliseconds) associated to a timer notification.
      boolean getSendPastNotifications()
      Gets the flag indicating whether or not the timer sends past notifications.
      boolean isActive()
      Tests whether the timer MBean is active.
      boolean isEmpty()
      Tests whether the list of timer notifications is empty.
      void postDeregister()
      Allows the timer MBean to perform any operations needed after having been unregistered by the MBean server.
      void postRegister(Boolean registrationDone)
      Allows the timer MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
      void preDeregister()
      Allows the timer MBean to perform any operations it needs before being unregistered by the MBean server.
      ObjectName preRegister(MBeanServer server, ObjectName name)
      Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
      void removeAllNotifications()
      Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
      void removeNotification(Integer id)
      Removes the timer notification corresponding to the specified identifier from the list of notifications.
      void removeNotifications(String type)
      Removes all the timer notifications corresponding to the specified type from the list of notifications.
      void setSendPastNotifications(boolean value)
      Sets the flag indicating whether the timer sends past notifications or not.
      void start()
      Starts the timer.
      void stop()
      Stops the timer.

      • 方法 - 继承于类 javax.management.NotificationBroadcasterSupport

        addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ONE_SECOND

        public static final long ONE_SECOND
        Number of milliseconds in one second. Useful constant for the addNotification method.
        另请参见：
        Constant Field Values

      • ONE_MINUTE

        public static final long ONE_MINUTE
        Number of milliseconds in one minute. Useful constant for the addNotification method.
        另请参见：
        Constant Field Values

      • ONE_HOUR

        public static final long ONE_HOUR
        Number of milliseconds in one hour. Useful constant for the addNotification method.
        另请参见：
        Constant Field Values

      • ONE_DAY

        public static final long ONE_DAY
        Number of milliseconds in one day. Useful constant for the addNotification method.
        另请参见：
        Constant Field Values

      • ONE_WEEK

        public static final long ONE_WEEK
        Number of milliseconds in one week. Useful constant for the addNotification method.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Timer

        public Timer()
        Default constructor.

    • 方法详细信息

      • preRegister

        public ObjectName preRegister(MBeanServer server,
                     ObjectName name)
                       throws Exception
        Allows the timer MBean to perform any operations it needs before being registered in the MBean server.

        Not used in this context.

        指定者：
        preRegister in interface MBeanRegistration
        参数：
        server - The MBean server in which the timer MBean will be registered.
        name - The object name of the timer MBean.
        返回：
        The name of the timer MBean registered.
        抛出：
        Exception

      • postRegister

        public void postRegister(Boolean registrationDone)
        Allows the timer MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

        Not used in this context.

        指定者：
        postRegister in interface MBeanRegistration
        参数：
        registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

      • preDeregister

        public void preDeregister()
                   throws Exception
        Allows the timer MBean to perform any operations it needs before being unregistered by the MBean server.

        Stops the timer.

        指定者：
        preDeregister in interface MBeanRegistration
        抛出：
        Exception

      • postDeregister

        public void postDeregister()
        Allows the timer MBean to perform any operations needed after having been unregistered by the MBean server.

        Not used in this context.

        指定者：
        postDeregister in interface MBeanRegistration

      • getNotificationInfo

        public MBeanNotificationInfo[] getNotificationInfo()
        从接口复制的描述： NotificationBroadcaster

        Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

        It is not illegal for the MBean to send notifications not described in this array. However, some clients of the MBean server may depend on the array being complete for their correct functioning.

        指定者：
        getNotificationInfo in interface NotificationBroadcaster
        重载：
        getNotificationInfo in class NotificationBroadcasterSupport
        返回：
        the array of possible notifications.

      • start

        public void start()
        Starts the timer.

        If there is one or more timer notifications before the time in the list of notifications, the notification is sent according to the sendPastNotifications flag and then, updated according to its period and remaining number of occurrences. If the timer notification date remains earlier than the current date, this notification is just removed from the list of notifications.

        指定者：
        start in interface TimerMBean

      • stop

        public void stop()
        Stops the timer.
        指定者：
        stop in interface TimerMBean

      • addNotification

        public Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period,
                      long nbOccurences,
                      boolean fixedRate)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
        For once-off notifications, the notification is delivered immediately.
        For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurrences cannot be updated.

        In the case of a periodic notification, the value of parameter fixedRate is used to specify the execution scheme, as specified in Timer.

        指定者：
        addNotification in interface TimerMBean
        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        nbOccurences - The total number the timer notification will be emitted.
        fixedRate - If true and if the notification is periodic, the notification is scheduled with a fixed-rate execution scheme. If false and if the notification is periodic, the notification is scheduled with a fixed-delay execution scheme. Ignored if the notification is not periodic.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period or the number of occurrences is negative.
        另请参见：
        addNotification(String, String, Object, Date, long, long)

      • addNotification

        public Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period,
                      long nbOccurences)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
        For once-off notifications, the notification is delivered immediately.
        For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurrences cannot be updated.

        In the case of a periodic notification, uses a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

        指定者：
        addNotification in interface TimerMBean
        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        nbOccurences - The total number the timer notification will be emitted.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period or the number of occurrences is negative.
        另请参见：
        addNotification(String, String, Object, Date, long, long, boolean)

      • addNotification

        public Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.

        The timer notification will repeat continuously using the timer period using a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date. The first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        指定者：
        addNotification in interface TimerMBean
        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period is negative.

      • addNotification

        public Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.

        The timer notification will be handled once at the specified date.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date and the notification is delivered immediately.

        指定者：
        addNotification in interface TimerMBean
        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null.

      • removeNotification

        public void removeNotification(Integer id)
                        throws InstanceNotFoundException
        Removes the timer notification corresponding to the specified identifier from the list of notifications.
        指定者：
        removeNotification in interface TimerMBean
        参数：
        id - The timer notification identifier.
        抛出：
        InstanceNotFoundException - The specified identifier does not correspond to any timer notification in the list of notifications of this timer MBean.

      • removeNotifications

        public void removeNotifications(String type)
                         throws InstanceNotFoundException
        Removes all the timer notifications corresponding to the specified type from the list of notifications.
        指定者：
        removeNotifications in interface TimerMBean
        参数：
        type - The timer notification type.
        抛出：
        InstanceNotFoundException - The specified type does not correspond to any timer notification in the list of notifications of this timer MBean.

      • removeAllNotifications

        public void removeAllNotifications()
        Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
        指定者：
        removeAllNotifications in interface TimerMBean

      • getNbNotifications

        public int getNbNotifications()
        Gets the number of timer notifications registered into the list of notifications.
        指定者：
        getNbNotifications in interface TimerMBean
        返回：
        The number of timer notifications.

      • getAllNotificationIDs

        public Vector<Integer> getAllNotificationIDs()
        Gets all timer notification identifiers registered into the list of notifications.
        指定者：
        getAllNotificationIDs in interface TimerMBean
        返回：
        A vector of Integer objects containing all the timer notification identifiers.
        The vector is empty if there is no timer notification registered for this timer MBean.

      • getNotificationIDs

        public Vector<Integer> getNotificationIDs(String type)
        Gets all the identifiers of timer notifications corresponding to the specified type.
        指定者：
        getNotificationIDs in interface TimerMBean
        参数：
        type - The timer notification type.
        返回：
        A vector of Integer objects containing all the identifiers of timer notifications with the specified type.
        The vector is empty if there is no timer notifications registered for this timer MBean with the specified type.

      • getNotificationType

        public String getNotificationType(Integer id)
        Gets the timer notification type corresponding to the specified identifier.
        指定者：
        getNotificationType in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification type or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNotificationMessage

        public String getNotificationMessage(Integer id)
        Gets the timer notification detailed message corresponding to the specified identifier.
        指定者：
        getNotificationMessage in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification detailed message or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNotificationUserData

        public Object getNotificationUserData(Integer id)
        Gets the timer notification user data object corresponding to the specified identifier.
        指定者：
        getNotificationUserData in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification user data object or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getDate

        public Date getDate(Integer id)
        Gets a copy of the date associated to a timer notification.
        指定者：
        getDate in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the date or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getPeriod

        public Long getPeriod(Integer id)
        Gets a copy of the period (in milliseconds) associated to a timer notification.
        指定者：
        getPeriod in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the period or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNbOccurences

        public Long getNbOccurences(Integer id)
        Gets a copy of the remaining number of occurrences associated to a timer notification.
        指定者：
        getNbOccurences in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the remaining number of occurrences or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getFixedRate

        public Boolean getFixedRate(Integer id)
        Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.
        指定者：
        getFixedRate in interface TimerMBean
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

      • getSendPastNotifications

        public boolean getSendPastNotifications()
        Gets the flag indicating whether or not the timer sends past notifications.
        The default value of the past notifications sending on/off flag is false.
        指定者：
        getSendPastNotifications in interface TimerMBean
        返回：
        The past notifications sending on/off flag value.
        另请参见：
        setSendPastNotifications(boolean)

      • setSendPastNotifications

        public void setSendPastNotifications(boolean value)
        Sets the flag indicating whether the timer sends past notifications or not.
        The default value of the past notifications sending on/off flag is false.
        指定者：
        setSendPastNotifications in interface TimerMBean
        参数：
        value - The past notifications sending on/off flag value.
        另请参见：
        getSendPastNotifications()

      • isActive

        public boolean isActive()
        Tests whether the timer MBean is active. A timer MBean is marked active when the start method is called. It becomes inactive when the stop method is called.
        The default value of the active on/off flag is false.
        指定者：
        isActive in interface TimerMBean
        返回：
        true if the timer MBean is active, false otherwise.

      • isEmpty

        public boolean isEmpty()
        Tests whether the list of timer notifications is empty.
        指定者：
        isEmpty in interface TimerMBean
        返回：
        true if the list of timer notifications is empty, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TimerMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.management.timer

Interface TimerMBean

  • All Known Implementing Classes:
    Timer

    public interface TimerMBean
    Exposes the management interface of the timer MBean.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Integer addNotification(String type, String message, Object userData, Date date)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
      Integer addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
      Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
      Vector<Integer> getAllNotificationIDs()
      Gets all timer notification identifiers registered into the list of notifications.
      Date getDate(Integer id)
      Gets a copy of the date associated to a timer notification.
      Boolean getFixedRate(Integer id)
      Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.
      int getNbNotifications()
      Gets the number of timer notifications registered into the list of notifications.
      Long getNbOccurences(Integer id)
      Gets a copy of the remaining number of occurrences associated to a timer notification.
      Vector<Integer> getNotificationIDs(String type)
      Gets all the identifiers of timer notifications corresponding to the specified type.
      String getNotificationMessage(Integer id)
      Gets the timer notification detailed message corresponding to the specified identifier.
      String getNotificationType(Integer id)
      Gets the timer notification type corresponding to the specified identifier.
      Object getNotificationUserData(Integer id)
      Gets the timer notification user data object corresponding to the specified identifier.
      Long getPeriod(Integer id)
      Gets a copy of the period (in milliseconds) associated to a timer notification.
      boolean getSendPastNotifications()
      Gets the flag indicating whether or not the timer sends past notifications.
      boolean isActive()
      Tests whether the timer MBean is active.
      boolean isEmpty()
      Tests whether the list of timer notifications is empty.
      void removeAllNotifications()
      Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
      void removeNotification(Integer id)
      Removes the timer notification corresponding to the specified identifier from the list of notifications.
      void removeNotifications(String type)
      Removes all the timer notifications corresponding to the specified type from the list of notifications.
      void setSendPastNotifications(boolean value)
      Sets the flag indicating whether the timer sends past notifications or not.
      void start()
      Starts the timer.
      void stop()
      Stops the timer.

    • 方法详细信息

      • start

        void start()
        Starts the timer.

        If there is one or more timer notifications before the time in the list of notifications, the notification is sent according to the sendPastNotifications flag and then, updated according to its period and remaining number of occurrences. If the timer notification date remains earlier than the current date, this notification is just removed from the list of notifications.

      • stop

        void stop()
        Stops the timer.

      • addNotification

        Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period,
                      long nbOccurences,
                      boolean fixedRate)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
        For once-off notifications, the notification is delivered immediately.
        For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurrences cannot be updated.

        In the case of a periodic notification, the value of parameter fixedRate is used to specify the execution scheme, as specified in Timer.

        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        nbOccurences - The total number the timer notification will be emitted.
        fixedRate - If true and if the notification is periodic, the notification is scheduled with a fixed-rate execution scheme. If false and if the notification is periodic, the notification is scheduled with a fixed-delay execution scheme. Ignored if the notification is not periodic.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period or the number of occurrences is negative.
        另请参见：
        addNotification(String, String, Object, Date, long, long)

      • addNotification

        Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period,
                      long nbOccurences)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
        For once-off notifications, the notification is delivered immediately.
        For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurrences cannot be updated.

        In the case of a periodic notification, uses a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        nbOccurences - The total number the timer notification will be emitted.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period or the number of occurrences is negative.
        另请参见：
        addNotification(String, String, Object, Date, long, long, boolean)

      • addNotification

        Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date,
                      long period)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.

        The timer notification will repeat continuously using the timer period using a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date. The first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        period - The period of the timer notification (in milliseconds).
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null or the period is negative.

      • addNotification

        Integer addNotification(String type,
                      String message,
                      Object userData,
                      Date date)
                        throws IllegalArgumentException
        Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.

        The timer notification will be handled once at the specified date.

        If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date and the notification is delivered immediately.

        参数：
        type - The timer notification type.
        message - The timer notification detailed message.
        userData - The timer notification user data object.
        date - The date when the notification occurs.
        返回：
        The identifier of the new created timer notification.
        抛出：
        IllegalArgumentException - The date is null.

      • removeNotification

        void removeNotification(Integer id)
                        throws InstanceNotFoundException
        Removes the timer notification corresponding to the specified identifier from the list of notifications.
        参数：
        id - The timer notification identifier.
        抛出：
        InstanceNotFoundException - The specified identifier does not correspond to any timer notification in the list of notifications of this timer MBean.

      • removeNotifications

        void removeNotifications(String type)
                         throws InstanceNotFoundException
        Removes all the timer notifications corresponding to the specified type from the list of notifications.
        参数：
        type - The timer notification type.
        抛出：
        InstanceNotFoundException - The specified type does not correspond to any timer notification in the list of notifications of this timer MBean.

      • removeAllNotifications

        void removeAllNotifications()
        Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.

      • getNbNotifications

        int getNbNotifications()
        Gets the number of timer notifications registered into the list of notifications.
        返回：
        The number of timer notifications.

      • getAllNotificationIDs

        Vector<Integer> getAllNotificationIDs()
        Gets all timer notification identifiers registered into the list of notifications.
        返回：
        A vector of Integer objects containing all the timer notification identifiers.
        The vector is empty if there is no timer notification registered for this timer MBean.

      • getNotificationIDs

        Vector<Integer> getNotificationIDs(String type)
        Gets all the identifiers of timer notifications corresponding to the specified type.
        参数：
        type - The timer notification type.
        返回：
        A vector of Integer objects containing all the identifiers of timer notifications with the specified type.
        The vector is empty if there is no timer notifications registered for this timer MBean with the specified type.

      • getNotificationType

        String getNotificationType(Integer id)
        Gets the timer notification type corresponding to the specified identifier.
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification type or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNotificationMessage

        String getNotificationMessage(Integer id)
        Gets the timer notification detailed message corresponding to the specified identifier.
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification detailed message or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNotificationUserData

        Object getNotificationUserData(Integer id)
        Gets the timer notification user data object corresponding to the specified identifier.
        参数：
        id - The timer notification identifier.
        返回：
        The timer notification user data object or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getDate

        Date getDate(Integer id)
        Gets a copy of the date associated to a timer notification.
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the date or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getPeriod

        Long getPeriod(Integer id)
        Gets a copy of the period (in milliseconds) associated to a timer notification.
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the period or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getNbOccurences

        Long getNbOccurences(Integer id)
        Gets a copy of the remaining number of occurrences associated to a timer notification.
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the remaining number of occurrences or null if the identifier is not mapped to any timer notification registered for this timer MBean.

      • getFixedRate

        Boolean getFixedRate(Integer id)
        Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.
        参数：
        id - The timer notification identifier.
        返回：
        A copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

      • getSendPastNotifications

        boolean getSendPastNotifications()
        Gets the flag indicating whether or not the timer sends past notifications.
        返回：
        The past notifications sending on/off flag value.
        另请参见：
        setSendPastNotifications(boolean)

      • setSendPastNotifications

        void setSendPastNotifications(boolean value)
        Sets the flag indicating whether the timer sends past notifications or not.
        参数：
        value - The past notifications sending on/off flag value.
        另请参见：
        getSendPastNotifications()

      • isActive

        boolean isActive()
        Tests whether the timer MBean is active. A timer MBean is marked active when the start method is called. It becomes inactive when the stop method is called.
        返回：
        true if the timer MBean is active, false otherwise.

      • isEmpty

        boolean isEmpty()
        Tests whether the list of timer notifications is empty.
        返回：
        true if the list of timer notifications is empty, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b-aem<>m<>c>d>>dtooc psnae>pr> "es


TimerNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.management.timer

类 TimerNotification

  • java.lang.Object
    • java.util.EventObject
      • javax.management.Notification
        • javax.management.timer.TimerNotification
  • 所有已实现的接口：
    Serializable

    public class TimerNotification
extends Notification
    This class provides definitions of the notifications sent by timer MBeans.
    It defines a timer notification identifier which allows to retrieve a timer notification from the list of notifications of a timer MBean.

    The timer notifications are created and handled by the timer MBean.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.management.Notification

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
      Creates a timer notification object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Integer getNotificationID()
      Gets the identifier of this timer notification.

      • 方法 - 继承于类 javax.management.Notification

        getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TimerNotification

        public TimerNotification(String type,
                 Object source,
                 long sequenceNumber,
                 long timeStamp,
                 String msg,
                 Integer id)
        Creates a timer notification object.
        参数：
        type - The notification type.
        source - The notification producer.
        sequenceNumber - The notification sequence number within the source object.
        timeStamp - The notification emission date.
        msg - The notification message.
        id - The notification identifier.

    • 方法详细信息

      • getNotificationID

        public Integer getNotificationID()
        Gets the identifier of this timer notification.
        返回：
        The identifier.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aac i ti rtt rrh>lltmeinTirmeengx././/=o=a/


Uses of Package javax.management.timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.management.timer

  • Packages that use javax.management.timer
    软件包 描述
    javax.management.timer
    Provides the definition of the Timer MBean.
  • Classes in javax.management.timer used by javax.management.timer
    类与描述
    TimerMBean
    Exposes the management interface of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oTnyidad.sl ssCCpin==i ts


Uses of Class javax.management.timer.Timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.timer.Timer

No usage of javax.management.timer.Timer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/tnna


Uses of Class javax.management.timer.TimerNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.management.timer.TimerNotification

No usage of javax.management.timer.TimerNotification
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rcia>taa/..rtn


Uses of Interface javax.management.timer.TimerMBean

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.management.timer.TimerMBean

  • Packages that use TimerMBean
    软件包 描述
    javax.management.timer
    Provides the definition of the Timer MBean.

    • Uses of TimerMBean in javax.management.timer

      Classes in javax.management.timer that implement TimerMBean
      修饰符与类型 类与描述
      class  Timer
      Provides the implementation of the timer MBean.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ieb�<>c/.o苧 a.hls.m縟rt


AuthenticationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 AuthenticationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
  • 所有已实现的接口：
    Serializable

    public class AuthenticationException
extends NamingSecurityException
    This exception is thrown when an authentication error occurs while accessing the naming or directory service. An authentication error can happen, for example, when the credentials supplied by the user program is invalid or otherwise fails to authenticate the user to the naming/directory service.

    If the program wants to handle this exception in particular, it should catch AuthenticationException explicitly before attempting to catch NamingException. After catching AuthenticationException, the program could reattempt the authentication by updating the resolved context's environment properties with the appropriate appropriate credentials.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      AuthenticationException()
      Constructs a new instance of AuthenticationException.
      AuthenticationException(String explanation)
      Constructs a new instance of AuthenticationException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AuthenticationException

        public AuthenticationException(String explanation)
        Constructs a new instance of AuthenticationException using the explanation supplied. All other fields default to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • AuthenticationException

        public AuthenticationException()
        Constructs a new instance of AuthenticationException. All fields are set to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sabtb"


AuthenticationNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 AuthenticationNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationNotSupportedException
  • 所有已实现的接口：
    Serializable

    public class AuthenticationNotSupportedException
extends NamingSecurityException
    This exception is thrown when the particular flavor of authentication requested is not supported. For example, if the program is attempting to use strong authentication but the directory/naming supports only simple authentication, this exception would be thrown. Identification of a particular flavor of authentication is provider- and server-specific. It may be specified using specific authentication schemes such those identified using SASL, or a generic authentication specifier (such as "simple" and "strong").

    If the program wants to handle this exception in particular, it should catch AuthenticationNotSupportedException explicitly before attempting to catch NamingException. After catching AuthenticationNotSupportedException, the program could reattempt the authentication using a different authentication flavor by updating the resolved context's environment properties accordingly.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      AuthenticationNotSupportedException()
      Constructs a new instance of AuthenticationNotSupportedException all name resolution fields and explanation initialized to null.
      AuthenticationNotSupportedException(String explanation)
      Constructs a new instance of AuthenticationNotSupportedException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AuthenticationNotSupportedException

        public AuthenticationNotSupportedException(String explanation)
        Constructs a new instance of AuthenticationNotSupportedException using an explanation. All other fields default to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • AuthenticationNotSupportedException

        public AuthenticationNotSupportedException()
        Constructs a new instance of AuthenticationNotSupportedException all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vn ji"je>.sonr /x 縨油s穕椎裕


BinaryRefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 BinaryRefAddr

  • java.lang.Object
    • javax.naming.RefAddr
      • javax.naming.BinaryRefAddr
  • 所有已实现的接口：
    Serializable

    public class BinaryRefAddr
extends RefAddr
    This class represents the binary form of the address of a communications end-point.

    A BinaryRefAddr consists of a type that describes the communication mechanism and an opaque buffer containing the address description specific to that communication mechanism. The format and interpretation of the address type and the contents of the opaque buffer are based on the agreement of three parties: the client that uses the address, the object/server that can be reached using the address, and the administrator or program that creates the address.

    An example of a binary reference address is an BER X.500 presentation address. Another example of a binary reference address is a serialized form of a service's object handle.

    A binary reference address is immutable in the sense that its fields once created, cannot be replaced. However, it is possible to access the byte array used to hold the opaque buffer. Programs are strongly recommended against changing this byte array. Changes to this byte array need to be explicitly synchronized.

    从以下版本开始：
    1.3
    另请参见：
    RefAddr, StringRefAddr, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.RefAddr

        addrType

    • 构造方法摘要

      Constructors
      构造方法与描述
      BinaryRefAddr(String addrType, byte[] src)
      Constructs a new instance of BinaryRefAddr using its address type and a byte array for contents.
      BinaryRefAddr(String addrType, byte[] src, int offset, int count)
      Constructs a new instance of BinaryRefAddr using its address type and a region of a byte array for contents.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Determines whether obj is equal to this address.
      Object getContent()
      Retrieves the contents of this address as an Object.
      int hashCode()
      Computes the hash code of this address using its address type and contents.
      String toString()
      Generates the string representation of this address.

      • 方法 - 继承于类 javax.naming.RefAddr

        getType

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BinaryRefAddr

        public BinaryRefAddr(String addrType,
             byte[] src)
        Constructs a new instance of BinaryRefAddr using its address type and a byte array for contents.
        参数：
        addrType - A non-null string describing the type of the address.
        src - The non-null contents of the address as a byte array. The contents of src is copied into the new BinaryRefAddr.

      • BinaryRefAddr

        public BinaryRefAddr(String addrType,
             byte[] src,
             int offset,
             int count)
        Constructs a new instance of BinaryRefAddr using its address type and a region of a byte array for contents.
        参数：
        addrType - A non-null string describing the type of the address.
        src - The non-null contents of the address as a byte array. The contents of src is copied into the new BinaryRefAddr.
        offset - The starting index in src to get the bytes. 0 <= offset <= src.length.
        count - The number of bytes to extract from src. 0 <= count <= src.length-offset.

    • 方法详细信息

      • getContent

        public Object getContent()
        Retrieves the contents of this address as an Object. The result is a byte array. Changes to this array will affect this BinaryRefAddr's contents. Programs are recommended against changing this array's contents and to lock the buffer if they need to change it.
        指定者：
        getContent in class RefAddr
        返回：
        The non-null buffer containing this address's contents.

      • equals

        public boolean equals(Object obj)
        Determines whether obj is equal to this address. It is equal if it contains the same address type and their contents are byte-wise equivalent.
        重载：
        equals in class RefAddr
        参数：
        obj - The possibly null object to check.
        返回：
        true if the object is equal; false otherwise.
        另请参见：
        RefAddr.getContent(), RefAddr.getType()

      • hashCode

        public int hashCode()
        Computes the hash code of this address using its address type and contents. Two BinaryRefAddrs have the same hash code if they have the same address type and the same contents. It is also possible for different BinaryRefAddrs to have the same hash code.
        重载：
        hashCode in class RefAddr
        返回：
        The hash code of this address as an int.
        另请参见：
        Object.hashCode()

      • toString

        public String toString()
        Generates the string representation of this address. The string consists of the address's type and contents with labels. The first 32 bytes of contents are displayed (in hexadecimal). If there are more than 32 bytes, "..." is used to indicate more. This string is meant to used for debugging purposes and not meant to be interpreted programmatically.
        重载：
        toString in class RefAddr
        返回：
        The non-null string representation of this address.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ab.es.<羖tp/>p/a.nbnel<>t1f;ess


Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 Binding

  • java.lang.Object
    • javax.naming.NameClassPair
      • javax.naming.Binding
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    SearchResult

    public class Binding
extends NameClassPair
    This class represents a name-to-object binding found in a context.

    A context consists of name-to-object bindings. The Binding class represents such a binding. It consists of a name and an object. The Context.listBindings() method returns an enumeration of Binding.

    Use subclassing for naming systems that generate contents of a binding dynamically.

    A Binding instance is not synchronized against concurrent access by multiple threads. Threads that need to access a Binding concurrently should synchronize amongst themselves and provide the necessary locking.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Binding(String name, Object obj)
      Constructs an instance of a Binding given its name and object.
      Binding(String name, Object obj, boolean isRelative)
      Constructs an instance of a Binding given its name, object, and whether the name is relative.
      Binding(String name, String className, Object obj)
      Constructs an instance of a Binding given its name, class name, and object.
      Binding(String name, String className, Object obj, boolean isRelative)
      Constructs an instance of a Binding given its name, class name, object, and whether the name is relative.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getClassName()
      Retrieves the class name of the object bound to the name of this binding.
      Object getObject()
      Retrieves the object bound to the name of this binding.
      void setObject(Object obj)
      Sets the object associated with this binding.
      String toString()
      Generates the string representation of this binding.

      • 方法 - 继承于类 javax.naming.NameClassPair

        getName, getNameInNamespace, isRelative, setClassName, setName, setNameInNamespace, setRelative

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Binding

        public Binding(String name,
       Object obj)
        Constructs an instance of a Binding given its name and object.

        getClassName() will return the class name of obj (or null if obj is null) unless the class name has been explicitly set using setClassName()

        参数：
        name - The non-null name of the object. It is relative to the target context (which is named by the first parameter of the listBindings() method)
        obj - The possibly null object bound to name.
        另请参见：
        NameClassPair.setClassName(java.lang.String)

      • Binding

        public Binding(String name,
       Object obj,
       boolean isRelative)
        Constructs an instance of a Binding given its name, object, and whether the name is relative.

        getClassName() will return the class name of obj (or null if obj is null) unless the class name has been explicitly set using setClassName()

        参数：
        name - The non-null string name of the object.
        obj - The possibly null object bound to name.
        isRelative - true if name is a name relative to the target context (which is named by the first parameter of the listBindings() method); false if name is a URL string.
        另请参见：
        NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.setClassName(java.lang.String)

      • Binding

        public Binding(String name,
       String className,
       Object obj)
        Constructs an instance of a Binding given its name, class name, and object.
        参数：
        name - The non-null name of the object. It is relative to the target context (which is named by the first parameter of the listBindings() method)
        className - The possibly null class name of the object bound to name. If null, the class name of obj is returned by getClassName(). If obj is also null, getClassName() will return null.
        obj - The possibly null object bound to name.
        另请参见：
        NameClassPair.setClassName(java.lang.String)

      • Binding

        public Binding(String name,
       String className,
       Object obj,
       boolean isRelative)
        Constructs an instance of a Binding given its name, class name, object, and whether the name is relative.
        参数：
        name - The non-null string name of the object.
        className - The possibly null class name of the object bound to name. If null, the class name of obj is returned by getClassName(). If obj is also null, getClassName() will return null.
        obj - The possibly null object bound to name.
        isRelative - true if name is a name relative to the target context (which is named by the first parameter of the listBindings() method); false if name is a URL string.
        另请参见：
        NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.setClassName(java.lang.String)

    • 方法详细信息

      • getClassName

        public String getClassName()
        Retrieves the class name of the object bound to the name of this binding. If the class name has been set explicitly, return it. Otherwise, if this binding contains a non-null object, that object's class name is used. Otherwise, null is returned.
        重载：
        getClassName in class NameClassPair
        返回：
        A possibly null string containing class name of object bound.
        另请参见：
        getObject(),
getClassName(),
NameClassPair.setClassName(java.lang.String)

      • getObject

        public Object getObject()
        Retrieves the object bound to the name of this binding.
        返回：
        The object bound; null if this binding does not contain an object.
        另请参见：
        setObject(java.lang.Object)

      • setObject

        public void setObject(Object obj)
        Sets the object associated with this binding.
        参数：
        obj - The possibly null object to use.
        另请参见：
        getObject()

      • toString

        public String toString()
        Generates the string representation of this binding. The string representation consists of the string representation of the name/class pair and the string representation of this binding's object, separated by ':'. The contents of this string is useful for debugging and is not meant to be interpreted programmatically.
        重载：
        toString in class NameClassPair
        返回：
        The non-null string representation of this binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dM m b>cba.e n c


CannotProceedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 CannotProceedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.CannotProceedException
  • 所有已实现的接口：
    Serializable

    public class CannotProceedException
extends NamingException
    This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further. When performing an operation on a composite name, a naming service provider may reach a part of the name that does not belong to its namespace. At that point, it can construct a CannotProceedException and then invoke methods provided by javax.naming.spi.NamingManager (such as getContinuationContext()) to locate another provider to continue the operation. If this is not possible, this exception is raised to the caller of the context operation.

    If the program wants to handle this exception in particular, it should catch CannotProceedException explicitly before attempting to catch NamingException.

    A CannotProceedException instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify CannotProceedException should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Name altName
      Contains the name of the resolved object, relative to the context altNameCtx.
      protected Context altNameCtx
      Contains the context relative to which altName is specified.
      protected Hashtable<?,?> environment
      Contains the environment relevant for the Context or DirContext method that cannot proceed.
      protected Name remainingNewName
      Contains the remaining unresolved part of the second "name" argument to Context.rename().

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotProceedException()
      Constructs a new instance of CannotProceedException.
      CannotProceedException(String explanation)
      Constructs a new instance of CannotProceedException using an explanation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name getAltName()
      Retrieves the altName field of this exception.
      Context getAltNameCtx()
      Retrieves the altNameCtx field of this exception.
      Hashtable<?,?> getEnvironment()
      Retrieves the environment that was in effect when this exception was created.
      Name getRemainingNewName()
      Retrieves the "remaining new name" field of this exception, which is used when this exception is thrown during a rename() operation.
      void setAltName(Name altName)
      Sets the altName field of this exception.
      void setAltNameCtx(Context altNameCtx)
      Sets the altNameCtx field of this exception.
      void setEnvironment(Hashtable<?,?> environment)
      Sets the environment that will be returned when getEnvironment() is called.
      void setRemainingNewName(Name newName)
      Sets the "remaining new name" field of this exception.

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • remainingNewName

        protected Name remainingNewName
        Contains the remaining unresolved part of the second "name" argument to Context.rename(). This information necessary for continuing the Context.rename() operation.

        This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getRemainingName() and setRemainingName().

        另请参见：
        getRemainingNewName(), setRemainingNewName(javax.naming.Name)

      • environment

        protected Hashtable<?,?> environment
        Contains the environment relevant for the Context or DirContext method that cannot proceed.

        This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getEnvironment() and setEnvironment().

        另请参见：
        getEnvironment(), setEnvironment(java.util.Hashtable)

      • altName

        protected Name altName
        Contains the name of the resolved object, relative to the context altNameCtx. It is a composite name. If null, then no name is specified. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

        This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltName() and setAltName().

        另请参见：
        getAltName(), setAltName(javax.naming.Name), altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • altNameCtx

        protected Context altNameCtx
        Contains the context relative to which altName is specified. If null, then the default initial context is implied. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

        This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltNameCtx() and setAltNameCtx().

        另请参见：
        getAltNameCtx(), setAltNameCtx(javax.naming.Context), altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

    • 构造方法详细信息

      • CannotProceedException

        public CannotProceedException(String explanation)
        Constructs a new instance of CannotProceedException using an explanation. All unspecified fields default to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception. If null, this exception has no detail message.
        另请参见：
        Throwable.getMessage()

      • CannotProceedException

        public CannotProceedException()
        Constructs a new instance of CannotProceedException. All fields default to null.

    • 方法详细信息

      • getEnvironment

        public Hashtable<?,?> getEnvironment()
        Retrieves the environment that was in effect when this exception was created.
        返回：
        Possibly null environment property set. null means no environment was recorded for this exception.
        另请参见：
        setEnvironment(java.util.Hashtable)

      • setEnvironment

        public void setEnvironment(Hashtable<?,?> environment)
        Sets the environment that will be returned when getEnvironment() is called.
        参数：
        environment - A possibly null environment property set. null means no environment is being recorded for this exception.
        另请参见：
        getEnvironment()

      • getRemainingNewName

        public Name getRemainingNewName()
        Retrieves the "remaining new name" field of this exception, which is used when this exception is thrown during a rename() operation.
        返回：
        The possibly null part of the new name that has not been resolved. It is a composite name. It can be null, which means the remaining new name field has not been set.
        另请参见：
        setRemainingNewName(javax.naming.Name)

      • setRemainingNewName

        public void setRemainingNewName(Name newName)
        Sets the "remaining new name" field of this exception. This is the value returned by getRemainingNewName().

        newName is a composite name. If the intent is to set this field using a compound name or string, you must "stringify" the compound name, and create a composite name with a single component using the string. You can then invoke this method using the resulting composite name.

        A copy of newName is made and stored. Subsequent changes to name does not affect the copy in this NamingException and vice versa.

        参数：
        newName - The possibly null name to set the "remaining new name" to. If null, it sets the remaining name field to null.
        另请参见：
        getRemainingNewName()

      • getAltName

        public Name getAltName()
        Retrieves the altName field of this exception. This is the name of the resolved object, relative to the context altNameCtx. It will be used during a subsequent call to the javax.naming.spi.ObjectFactory.getObjectInstance method.
        返回：
        The name of the resolved object, relative to altNameCtx. It is a composite name. If null, then no name is specified.
        另请参见：
        setAltName(javax.naming.Name),
getAltNameCtx(),
ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • setAltName

        public void setAltName(Name altName)
        Sets the altName field of this exception.
        参数：
        altName - The name of the resolved object, relative to altNameCtx. It is a composite name. If null, then no name is specified.
        另请参见：
        getAltName(), setAltNameCtx(javax.naming.Context)

      • getAltNameCtx

        public Context getAltNameCtx()
        Retrieves the altNameCtx field of this exception. This is the context relative to which altName is named. It will be used during a subsequent call to the javax.naming.spi.ObjectFactory.getObjectInstance method.
        返回：
        The context relative to which altName is named. If null, then the default initial context is implied.
        另请参见：
        setAltNameCtx(javax.naming.Context),
getAltName(),
ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • setAltNameCtx

        public void setAltNameCtx(Context altNameCtx)
        Sets the altNameCtx field of this exception.
        参数：
        altNameCtx - The context relative to which altName is named. If null, then the default initial context is implied.
        另请参见：
        getAltNameCtx(), setAltName(javax.naming.Name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R


CommunicationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 CommunicationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.CommunicationException
  • 所有已实现的接口：
    Serializable

    public class CommunicationException
extends NamingException
    This exception is thrown when the client is unable to communicate with the directory or naming service. The inability to communicate with the service might be a result of many factors, such as network partitioning, hardware or interface problems, failures on either the client or server side. This exception is meant to be used to capture such communication problems.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      CommunicationException()
      Constructs a new instance of CommunicationException.
      CommunicationException(String explanation)
      Constructs a new instance of CommunicationException using the arguments supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CommunicationException

        public CommunicationException(String explanation)
        Constructs a new instance of CommunicationException using the arguments supplied.
        参数：
        explanation - Additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • CommunicationException

        public CommunicationException()
        Constructs a new instance of CommunicationException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.x. a,m>,maeemaal>aa ,ef<=""jf/pttmtio/j


CompositeName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 CompositeName

  • java.lang.Object
    • javax.naming.CompositeName
  • 所有已实现的接口：
    Serializable, Cloneable, Comparable<Object>, Name

    public class CompositeName
extends Object
implements Name
    This class represents a composite name -- a sequence of component names spanning multiple namespaces. Each component is a string name from the namespace of a naming system. If the component comes from a hierarchical namespace, that component can be further parsed into its atomic parts by using the CompoundName class.

    The components of a composite name are numbered. The indexes of a composite name with N components range from 0 up to, but not including, N. This range may be written as [0,N). The most significant component is at index 0. An empty composite name has no components.

    JNDI Composite Name Syntax

    JNDI defines a standard string representation for composite names. This representation is the concatenation of the components of a composite name from left to right using the component separator (a forward slash character (/)) to separate each component. The JNDI syntax defines the following meta characters:
    • escape (backward slash \),
    • quote characters (single (') and double quotes (")), and
    • component separator (forward slash character (/)).
    Any occurrence of a leading quote, an escape preceding any meta character, an escape at the end of a component, or a component separator character in an unquoted component must be preceded by an escape character when that component is being composed into a composite name string. Alternatively, to avoid adding escape characters as described, the entire component can be quoted using matching single quotes or matching double quotes. A single quote occurring within a double-quoted component is not considered a meta character (and need not be escaped), and vice versa.

    When two composite names are compared, the case of the characters is significant.

    A leading component separator (the composite name string begins with a separator) denotes a leading empty component (a component consisting of an empty string). A trailing component separator (the composite name string ends with a separator) denotes a trailing empty component. Adjacent component separators denote an empty component.

    Composite Name Examples

    This table shows examples of some composite names. Each row shows the string form of a composite name and its corresponding structural form (CompositeName).

    String Name | CompositeName
    "" {} (the empty name == new CompositeName("") == new CompositeName())
    "x" | {"x"}
    "x/y" | {"x", "y"}
    "x/" | {"x", ""}
    "/x" | {"", "x"}
    "/" {""}
    "//" {"", ""}
    "/x/" | {"", "x", ""}
    "x//y" | {"x", "", "y"}

    Composition Examples

    Here are some composition examples. The right column shows composing string composite names while the left column shows composing the corresponding CompositeNames. Notice that composing the string forms of two composite names simply involves concatenating their string forms together.

    String Names | CompositeNames
    "x/y" + "/" = x/y/ | {"x", "y"} + {""} = {"x", "y", ""}
    "" + "x" = "x" | {} + {"x"} = {"x"}
    "/" + "x" = "/x" | {""} + {"x"} = {"", "x"}
    "x" + "" + "" = "x" | {"x"} + {} + {} = {"x"}

    Multithreaded Access

    A CompositeName instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a CompositeName should lock the object.
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        CompositeName()
      Constructs a new empty composite name.
      protected CompositeName(Enumeration<String> comps)
      Constructs a new composite name instance using the components specified by 'comps'.
        CompositeName(String n)
      Constructs a new composite name instance by parsing the string n using the composite name syntax (left-to-right, slash separated).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name add(int posn, String comp)
      Adds a single component at a specified position within this composite name.
      Name add(String comp)
      Adds a single component to the end of this composite name.
      Name addAll(int posn, Name n)
      Adds the components of a composite name -- in order -- at a specified position within this composite name.
      Name addAll(Name suffix)
      Adds the components of a composite name -- in order -- to the end of this composite name.
      Object clone()
      Generates a copy of this composite name.
      int compareTo(Object obj)
      Compares this CompositeName with the specified Object for order.
      boolean endsWith(Name n)
      Determines whether a composite name is a suffix of this composite name.
      boolean equals(Object obj)
      Determines whether two composite names are equal.
      String get(int posn)
      Retrieves a component of this composite name.
      Enumeration<String> getAll()
      Retrieves the components of this composite name as an enumeration of strings.
      Name getPrefix(int posn)
      Creates a composite name whose components consist of a prefix of the components in this composite name.
      Name getSuffix(int posn)
      Creates a composite name whose components consist of a suffix of the components in this composite name.
      int hashCode()
      Computes the hash code of this composite name.
      boolean isEmpty()
      Determines whether this composite name is empty.
      Object remove(int posn)
      Deletes a component from this composite name.
      int size()
      Retrieves the number of components in this composite name.
      boolean startsWith(Name n)
      Determines whether a composite name is a prefix of this composite name.
      String toString()
      Generates the string representation of this composite name.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompositeName

        protected CompositeName(Enumeration<String> comps)
        Constructs a new composite name instance using the components specified by 'comps'. This protected method is intended to be to be used by subclasses of CompositeName when they override methods such as clone(), getPrefix(), getSuffix().
        参数：
        comps - A non-null enumeration containing the components for the new composite name. Each element is of class String. The enumeration will be consumed to extract its elements.

      • CompositeName

        public CompositeName(String n)
              throws InvalidNameException
        Constructs a new composite name instance by parsing the string n using the composite name syntax (left-to-right, slash separated). The composite name syntax is described in detail in the class description.
        参数：
        n - The non-null string to parse.
        抛出：
        InvalidNameException - If n has invalid composite name syntax.

      • CompositeName

        public CompositeName()
        Constructs a new empty composite name. Such a name returns true when isEmpty() is invoked on it.

    • 方法详细信息

      • toString

        public String toString()
        Generates the string representation of this composite name. The string representation consists of enumerating in order each component of the composite name and separating each component by a forward slash character. Quoting and escape characters are applied where necessary according to the JNDI syntax, which is described in the class description. An empty component is represented by an empty string. The string representation thus generated can be passed to the CompositeName constructor to create a new equivalent composite name.
        重载：
        toString in class Object
        返回：
        A non-null string representation of this composite name.

      • equals

        public boolean equals(Object obj)
        Determines whether two composite names are equal. If obj is null or not a composite name, false is returned. Two composite names are equal if each component in one is equal to the corresponding component in the other. This implies both have the same number of components, and each component's equals() test against the corresponding component in the other name returns true.
        重载：
        equals in class Object
        参数：
        obj - The possibly null object to compare against.
        返回：
        true if obj is equal to this composite name, false otherwise.
        另请参见：
        hashCode()

      • hashCode

        public int hashCode()
        Computes the hash code of this composite name. The hash code is the sum of the hash codes of individual components of this composite name.
        重载：
        hashCode in class Object
        返回：
        An int representing the hash code of this name.
        另请参见：
        equals(java.lang.Object)

      • compareTo

        public int compareTo(Object obj)
        Compares this CompositeName with the specified Object for order. Returns a negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given Object.

        If obj is null or not an instance of CompositeName, ClassCastException is thrown.

        See equals() for what it means for two composite names to be equal. If two composite names are equal, 0 is returned.

        Ordering of composite names follows the lexicographical rules for string comparison, with the extension that this applies to all the components in the composite name. The effect is as if all the components were lined up in their specified ordered and the lexicographical rules applied over the two line-ups. If this composite name is "lexicographically" lesser than obj, a negative number is returned. If this composite name is "lexicographically" greater than obj, a positive number is returned.

        指定者：
        compareTo in interface Comparable<Object>
        指定者：
        compareTo in interface Name
        参数：
        obj - The non-null object to compare against.
        返回：
        a negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given Object.
        抛出：
        ClassCastException - if obj is not a CompositeName.
        另请参见：
        Comparable.compareTo(Object)

      • clone

        public Object clone()
        Generates a copy of this composite name. Changes to the components of this composite name won't affect the new copy and vice versa.
        指定者：
        clone in interface Name
        重载：
        clone in class Object
        返回：
        A non-null copy of this composite name.
        另请参见：
        Cloneable

      • size

        public int size()
        Retrieves the number of components in this composite name.
        指定者：
        size in interface Name
        返回：
        The nonnegative number of components in this composite name.

      • isEmpty

        public boolean isEmpty()
        Determines whether this composite name is empty. A composite name is empty if it has zero components.
        指定者：
        isEmpty in interface Name
        返回：
        true if this composite name is empty, false otherwise.

      • getAll

        public Enumeration<String> getAll()
        Retrieves the components of this composite name as an enumeration of strings. The effects of updates to this composite name on this enumeration is undefined.
        指定者：
        getAll in interface Name
        返回：
        A non-null enumeration of the components of this composite name. Each element of the enumeration is of class String.

      • get

        public String get(int posn)
        Retrieves a component of this composite name.
        指定者：
        get in interface Name
        参数：
        posn - The 0-based index of the component to retrieve. Must be in the range [0,size()).
        返回：
        The non-null component at index posn.
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range.

      • getPrefix

        public Name getPrefix(int posn)
        Creates a composite name whose components consist of a prefix of the components in this composite name. Subsequent changes to this composite name does not affect the name that is returned.
        指定者：
        getPrefix in interface Name
        参数：
        posn - The 0-based index of the component at which to stop. Must be in the range [0,size()].
        返回：
        A composite name consisting of the components at indexes in the range [0,posn).
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.

      • getSuffix

        public Name getSuffix(int posn)
        Creates a composite name whose components consist of a suffix of the components in this composite name. Subsequent changes to this composite name does not affect the name that is returned.
        指定者：
        getSuffix in interface Name
        参数：
        posn - The 0-based index of the component at which to start. Must be in the range [0,size()].
        返回：
        A composite name consisting of the components at indexes in the range [posn,size()). If posn is equal to size(), an empty composite name is returned.
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.

      • startsWith

        public boolean startsWith(Name n)
        Determines whether a composite name is a prefix of this composite name. A composite name 'n' is a prefix if it is equal to getPrefix(n.size())--in other words, this composite name starts with 'n'. If 'n' is null or not a composite name, false is returned.
        指定者：
        startsWith in interface Name
        参数：
        n - The possibly null name to check.
        返回：
        true if n is a CompositeName and is a prefix of this composite name, false otherwise.

      • endsWith

        public boolean endsWith(Name n)
        Determines whether a composite name is a suffix of this composite name. A composite name 'n' is a suffix if it it is equal to getSuffix(size()-n.size())--in other words, this composite name ends with 'n'. If n is null or not a composite name, false is returned.
        指定者：
        endsWith in interface Name
        参数：
        n - The possibly null name to check.
        返回：
        true if n is a CompositeName and is a suffix of this composite name, false otherwise.

      • addAll

        public Name addAll(Name suffix)
            throws InvalidNameException
        Adds the components of a composite name -- in order -- to the end of this composite name.
        指定者：
        addAll in interface Name
        参数：
        suffix - The non-null components to add.
        返回：
        The updated CompositeName, not a new one. Cannot be null.
        抛出：
        InvalidNameException - If suffix is not a composite name.

      • addAll

        public Name addAll(int posn,
          Name n)
            throws InvalidNameException
        Adds the components of a composite name -- in order -- at a specified position within this composite name. Components of this composite name at or after the index of the first new component are shifted up (away from index 0) to accommodate the new components.
        指定者：
        addAll in interface Name
        参数：
        n - The non-null components to add.
        posn - The index in this name at which to add the new components. Must be in the range [0,size()].
        返回：
        The updated CompositeName, not a new one. Cannot be null.
        抛出：
        InvalidNameException - If n is not a composite name.
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.

      • add

        public Name add(String comp)
         throws InvalidNameException
        Adds a single component to the end of this composite name.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        返回：
        The updated CompositeName, not a new one. Cannot be null.
        抛出：
        InvalidNameException - If adding comp at end of the name would violate the name's syntax.

      • add

        public Name add(int posn,
       String comp)
         throws InvalidNameException
        Adds a single component at a specified position within this composite name. Components of this composite name at or after the index of the new component are shifted up by one (away from index 0) to accommodate the new component.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        posn - The index at which to add the new component. Must be in the range [0,size()].
        返回：
        The updated CompositeName, not a new one. Cannot be null.
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.
        InvalidNameException - If adding comp at the specified position would violate the name's syntax.

      • remove

        public Object remove(int posn)
              throws InvalidNameException
        Deletes a component from this composite name. The component of this composite name at position 'posn' is removed, and components at indices greater than 'posn' are shifted down (towards index 0) by one.
        指定者：
        remove in interface Name
        参数：
        posn - The index of the component to delete. Must be in the range [0,size()).
        返回：
        The component removed (a String).
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range (includes case where composite name is empty).
        InvalidNameException - If deleting the component would violate the name's syntax.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompoundName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 CompoundName

  • java.lang.Object
    • javax.naming.CompoundName
  • 所有已实现的接口：
    Serializable, Cloneable, Comparable<Object>, Name

    public class CompoundName
extends Object
implements Name
    This class represents a compound name -- a name from a hierarchical name space. Each component in a compound name is an atomic name.

    The components of a compound name are numbered. The indexes of a compound name with N components range from 0 up to, but not including, N. This range may be written as [0,N). The most significant component is at index 0. An empty compound name has no components.

    Compound Name Syntax

    The syntax of a compound name is specified using a set of properties:
    jndi.syntax.direction
    Direction for parsing ("right_to_left", "left_to_right", "flat"). If unspecified, defaults to "flat", which means the namespace is flat with no hierarchical structure.
    jndi.syntax.separator
    Separator between atomic name components. Required unless direction is "flat".
    jndi.syntax.ignorecase
    If present, "true" means ignore the case when comparing name components. If its value is not "true", or if the property is not present, case is considered when comparing name components.
    jndi.syntax.escape
    If present, specifies the escape string for overriding separator, escapes and quotes.
    jndi.syntax.beginquote
    If present, specifies the string delimiting start of a quoted string.
    jndi.syntax.endquote
    String delimiting end of quoted string. If present, specifies the string delimiting the end of a quoted string. If not present, use syntax.beginquote as end quote.
    jndi.syntax.beginquote2
    Alternative set of begin/end quotes.
    jndi.syntax.endquote2
    Alternative set of begin/end quotes.
    jndi.syntax.trimblanks
    If present, "true" means trim any leading and trailing whitespaces in a name component for comparison purposes. If its value is not "true", or if the property is not present, blanks are significant.
    jndi.syntax.separator.ava
    If present, specifies the string that separates attribute-value-assertions when specifying multiple attribute/value pairs. (e.g. "," in age=65,gender=male).
    jndi.syntax.separator.typeval
    If present, specifies the string that separators attribute from value (e.g. "=" in "age=65")
    These properties are interpreted according to the following rules:
    1. In a string without quotes or escapes, any instance of the separator delimits two atomic names. Each atomic name is referred to as a component.
    2. A separator, quote or escape is escaped if preceded immediately (on the left) by the escape.
    3. If there are two sets of quotes, a specific begin-quote must be matched by its corresponding end-quote.
    4. A non-escaped begin-quote which precedes a component must be matched by a non-escaped end-quote at the end of the component. A component thus quoted is referred to as a quoted component. It is parsed by removing the being- and end- quotes, and by treating the intervening characters as ordinary characters unless one of the rules involving quoted components listed below applies.
    5. Quotes embedded in non-quoted components are treated as ordinary strings and need not be matched.
    6. A separator that is escaped or appears between non-escaped quotes is treated as an ordinary string and not a separator.
    7. An escape string within a quoted component acts as an escape only when followed by the corresponding end-quote string. This can be used to embed an escaped quote within a quoted component.
    8. An escaped escape string is not treated as an escape string.
    9. An escape string that does not precede a meta string (quotes or separator) and is not at the end of a component is treated as an ordinary string.
    10. A leading separator (the compound name string begins with a separator) denotes a leading empty atomic component (consisting of an empty string). A trailing separator (the compound name string ends with a separator) denotes a trailing empty atomic component. Adjacent separators denote an empty atomic component.

    The string form of the compound name follows the syntax described above. When the components of the compound name are turned into their string representation, the reserved syntax rules described above are applied (e.g. embedded separators are escaped or quoted) so that when the same string is parsed, it will yield the same components of the original compound name.

    Multithreaded Access

    A CompoundName instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a CompoundName should lock the object.
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected javax.naming.NameImpl impl
      Implementation of this compound name.
      protected Properties mySyntax
      Syntax properties for this compound name.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected CompoundName(Enumeration<String> comps, Properties syntax)
      Constructs a new compound name instance using the components specified in comps and syntax.
        CompoundName(String n, Properties syntax)
      Constructs a new compound name instance by parsing the string n using the syntax specified by the syntax properties supplied.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name add(int posn, String comp)
      Adds a single component at a specified position within this compound name.
      Name add(String comp)
      Adds a single component to the end of this compound name.
      Name addAll(int posn, Name n)
      Adds the components of a compound name -- in order -- at a specified position within this compound name.
      Name addAll(Name suffix)
      Adds the components of a compound name -- in order -- to the end of this compound name.
      Object clone()
      Creates a copy of this compound name.
      int compareTo(Object obj)
      Compares this CompoundName with the specified Object for order.
      boolean endsWith(Name n)
      Determines whether a compound name is a suffix of this compound name.
      boolean equals(Object obj)
      Determines whether obj is syntactically equal to this compound name.
      String get(int posn)
      Retrieves a component of this compound name.
      Enumeration<String> getAll()
      Retrieves the components of this compound name as an enumeration of strings.
      Name getPrefix(int posn)
      Creates a compound name whose components consist of a prefix of the components in this compound name.
      Name getSuffix(int posn)
      Creates a compound name whose components consist of a suffix of the components in this compound name.
      int hashCode()
      Computes the hash code of this compound name.
      boolean isEmpty()
      Determines whether this compound name is empty.
      Object remove(int posn)
      Deletes a component from this compound name.
      int size()
      Retrieves the number of components in this compound name.
      boolean startsWith(Name n)
      Determines whether a compound name is a prefix of this compound name.
      String toString()
      Generates the string representation of this compound name, using the syntax rules of the compound name.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • impl

        protected transient javax.naming.NameImpl impl
        Implementation of this compound name. This field is initialized by the constructors and cannot be null. It should be treated as a read-only variable by subclasses.

      • mySyntax

        protected transient Properties mySyntax
        Syntax properties for this compound name. This field is initialized by the constructors and cannot be null. It should be treated as a read-only variable by subclasses. Any necessary changes to mySyntax should be made within constructors and not after the compound name has been instantiated.

    • 构造方法详细信息

      • CompoundName

        protected CompoundName(Enumeration<String> comps,
            Properties syntax)
        Constructs a new compound name instance using the components specified in comps and syntax. This protected method is intended to be to be used by subclasses of CompoundName when they override methods such as clone(), getPrefix(), getSuffix().
        参数：
        comps - A non-null enumeration of the components to add. Each element of the enumeration is of class String. The enumeration will be consumed to extract its elements.
        syntax - A non-null properties that specify the syntax of this compound name. See class description for contents of properties.

      • CompoundName

        public CompoundName(String n,
            Properties syntax)
             throws InvalidNameException
        Constructs a new compound name instance by parsing the string n using the syntax specified by the syntax properties supplied.
        参数：
        n - The non-null string to parse.
        syntax - A non-null list of properties that specify the syntax of this compound name. See class description for contents of properties.
        抛出：
        InvalidNameException - If 'n' violates the syntax specified by syntax.

    • 方法详细信息

      • toString

        public String toString()
        Generates the string representation of this compound name, using the syntax rules of the compound name. The syntax rules are described in the class description. An empty component is represented by an empty string. The string representation thus generated can be passed to the CompoundName constructor with the same syntax properties to create a new equivalent compound name.
        重载：
        toString in class Object
        返回：
        A non-null string representation of this compound name.

      • equals

        public boolean equals(Object obj)
        Determines whether obj is syntactically equal to this compound name. If obj is null or not a CompoundName, false is returned. Two compound names are equal if each component in one is "equal" to the corresponding component in the other.

        Equality is also defined in terms of the syntax of this compound name. The default implementation of CompoundName uses the syntax properties jndi.syntax.ignorecase and jndi.syntax.trimblanks when comparing two components for equality. If case is ignored, two strings with the same sequence of characters but with different cases are considered equal. If blanks are being trimmed, leading and trailing blanks are ignored for the purpose of the comparison.

        Both compound names must have the same number of components.

        Implementation note: Currently the syntax properties of the two compound names are not compared for equality. They might be in the future.

        重载：
        equals in class Object
        参数：
        obj - The possibly null object to compare against.
        返回：
        true if obj is equal to this compound name, false otherwise.
        另请参见：
        compareTo(java.lang.Object obj)

      • hashCode

        public int hashCode()
        Computes the hash code of this compound name. The hash code is the sum of the hash codes of the "canonicalized" forms of individual components of this compound name. Each component is "canonicalized" according to the compound name's syntax before its hash code is computed. For a case-insensitive name, for example, the uppercased form of a name has the same hash code as its lowercased equivalent.
        重载：
        hashCode in class Object
        返回：
        An int representing the hash code of this name.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • clone

        public Object clone()
        Creates a copy of this compound name. Changes to the components of this compound name won't affect the new copy and vice versa. The clone and this compound name share the same syntax.
        指定者：
        clone in interface Name
        重载：
        clone in class Object
        返回：
        A non-null copy of this compound name.
        另请参见：
        Cloneable

      • compareTo

        public int compareTo(Object obj)
        Compares this CompoundName with the specified Object for order. Returns a negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given Object.

        If obj is null or not an instance of CompoundName, ClassCastException is thrown.

        See equals() for what it means for two compound names to be equal. If two compound names are equal, 0 is returned.

        Ordering of compound names depend on the syntax of the compound name. By default, they follow lexicographical rules for string comparison with the extension that this applies to all the components in the compound name and that comparison of individual components is affected by the jndi.syntax.ignorecase and jndi.syntax.trimblanks properties, identical to how they affect equals(). If this compound name is "lexicographically" lesser than obj, a negative number is returned. If this compound name is "lexicographically" greater than obj, a positive number is returned.

        Implementation note: Currently the syntax properties of the two compound names are not compared when checking order. They might be in the future.

        指定者：
        compareTo in interface Comparable<Object>
        指定者：
        compareTo in interface Name
        参数：
        obj - The non-null object to compare against.
        返回：
        a negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given Object.
        抛出：
        ClassCastException - if obj is not a CompoundName.
        另请参见：
        equals(java.lang.Object)

      • size

        public int size()
        Retrieves the number of components in this compound name.
        指定者：
        size in interface Name
        返回：
        The nonnegative number of components in this compound name.

      • isEmpty

        public boolean isEmpty()
        Determines whether this compound name is empty. A compound name is empty if it has zero components.
        指定者：
        isEmpty in interface Name
        返回：
        true if this compound name is empty, false otherwise.

      • getAll

        public Enumeration<String> getAll()
        Retrieves the components of this compound name as an enumeration of strings. The effects of updates to this compound name on this enumeration is undefined.
        指定者：
        getAll in interface Name
        返回：
        A non-null enumeration of the components of this compound name. Each element of the enumeration is of class String.

      • get

        public String get(int posn)
        Retrieves a component of this compound name.
        指定者：
        get in interface Name
        参数：
        posn - The 0-based index of the component to retrieve. Must be in the range [0,size()).
        返回：
        The component at index posn.
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range.

      • getPrefix

        public Name getPrefix(int posn)
        Creates a compound name whose components consist of a prefix of the components in this compound name. The result and this compound name share the same syntax. Subsequent changes to this compound name does not affect the name that is returned and vice versa.
        指定者：
        getPrefix in interface Name
        参数：
        posn - The 0-based index of the component at which to stop. Must be in the range [0,size()].
        返回：
        A compound name consisting of the components at indexes in the range [0,posn).
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.

      • getSuffix

        public Name getSuffix(int posn)
        Creates a compound name whose components consist of a suffix of the components in this compound name. The result and this compound name share the same syntax. Subsequent changes to this compound name does not affect the name that is returned.
        指定者：
        getSuffix in interface Name
        参数：
        posn - The 0-based index of the component at which to start. Must be in the range [0,size()].
        返回：
        A compound name consisting of the components at indexes in the range [posn,size()). If posn is equal to size(), an empty compound name is returned.
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.

      • startsWith

        public boolean startsWith(Name n)
        Determines whether a compound name is a prefix of this compound name. A compound name 'n' is a prefix if it is equal to getPrefix(n.size())--in other words, this compound name starts with 'n'. If n is null or not a compound name, false is returned.

        Implementation note: Currently the syntax properties of n are not used when doing the comparison. They might be in the future.

        指定者：
        startsWith in interface Name
        参数：
        n - The possibly null compound name to check.
        返回：
        true if n is a CompoundName and is a prefix of this compound name, false otherwise.

      • endsWith

        public boolean endsWith(Name n)
        Determines whether a compound name is a suffix of this compound name. A compound name 'n' is a suffix if it it is equal to getSuffix(size()-n.size())--in other words, this compound name ends with 'n'. If n is null or not a compound name, false is returned.

        Implementation note: Currently the syntax properties of n are not used when doing the comparison. They might be in the future.

        指定者：
        endsWith in interface Name
        参数：
        n - The possibly null compound name to check.
        返回：
        true if n is a CompoundName and is a suffix of this compound name, false otherwise.

      • addAll

        public Name addAll(Name suffix)
            throws InvalidNameException
        Adds the components of a compound name -- in order -- to the end of this compound name.

        Implementation note: Currently the syntax properties of suffix is not used or checked. They might be in the future.

        指定者：
        addAll in interface Name
        参数：
        suffix - The non-null components to add.
        返回：
        The updated CompoundName, not a new one. Cannot be null.
        抛出：
        InvalidNameException - If suffix is not a compound name, or if the addition of the components violates the syntax of this compound name (e.g. exceeding number of components).

      • addAll

        public Name addAll(int posn,
          Name n)
            throws InvalidNameException
        Adds the components of a compound name -- in order -- at a specified position within this compound name. Components of this compound name at or after the index of the first new component are shifted up (away from index 0) to accommodate the new components.

        Implementation note: Currently the syntax properties of suffix is not used or checked. They might be in the future.

        指定者：
        addAll in interface Name
        参数：
        n - The non-null components to add.
        posn - The index in this name at which to add the new components. Must be in the range [0,size()].
        返回：
        The updated CompoundName, not a new one. Cannot be null.
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.
        InvalidNameException - If n is not a compound name, or if the addition of the components violates the syntax of this compound name (e.g. exceeding number of components).

      • add

        public Name add(String comp)
         throws InvalidNameException
        Adds a single component to the end of this compound name.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        返回：
        The updated CompoundName, not a new one. Cannot be null.
        抛出：
        InvalidNameException - If adding comp at end of the name would violate the compound name's syntax.

      • add

        public Name add(int posn,
       String comp)
         throws InvalidNameException
        Adds a single component at a specified position within this compound name. Components of this compound name at or after the index of the new component are shifted up by one (away from index 0) to accommodate the new component.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        posn - The index at which to add the new component. Must be in the range [0,size()].
        返回：
        The updated CompoundName, not a new one. Cannot be null.
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range.
        InvalidNameException - If adding comp at the specified position would violate the compound name's syntax.

      • remove

        public Object remove(int posn)
              throws InvalidNameException
        Deletes a component from this compound name. The component of this compound name at position 'posn' is removed, and components at indices greater than 'posn' are shifted down (towards index 0) by one.
        指定者：
        remove in interface Name
        参数：
        posn - The index of the component to delete. Must be in the range [0,size()).
        返回：
        The component removed (a String).
        抛出：
        ArrayIndexOutOfBoundsException - If posn is outside the specified range (includes case where compound name is empty).
        InvalidNameException - If deleting the component would violate the compound name's syntax.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 ConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ConfigurationException
  • 所有已实现的接口：
    Serializable

    public class ConfigurationException
extends NamingException
    This exception is thrown when there is a configuration problem. This can arise when installation of a provider was not done correctly, or if there are configuration problems with the server, or if configuration information required to access the provider or service is malformed or missing. For example, a request to use SSL as the security protocol when the service provider software was not configured with the SSL component would cause such an exception. Another example is if the provider requires that a URL be specified as one of the environment properties but the client failed to provide it.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      ConfigurationException()
      Constructs a new instance of ConfigurationException with all name resolution fields and explanation initialized to null.
      ConfigurationException(String explanation)
      Constructs a new instance of ConfigurationException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ConfigurationException

        public ConfigurationException(String explanation)
        Constructs a new instance of ConfigurationException using an explanation. All other fields default to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • ConfigurationException

        public ConfigurationException()
        Constructs a new instance of ConfigurationException with all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c(oclstast


Context

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming

Interface Context

  • All Known Subinterfaces:
    DirContext, EventContext, EventDirContext, LdapContext
    All Known Implementing Classes:
    InitialContext, InitialDirContext, InitialLdapContext

    public interface Context
    This interface represents a naming context, which consists of a set of name-to-object bindings. It contains methods for examining and updating these bindings.

    Names

    Each name passed as an argument to a Context method is relative to that context. The empty name is used to name the context itself. A name parameter may never be null.

    Most of the methods have overloaded versions with one taking a Name parameter and one taking a String. These overloaded versions are equivalent in that if the Name and String parameters are just different representations of the same name, then the overloaded versions of the same methods behave the same. In the method descriptions below, only one version is fully documented. The second version instead has a link to the first: the same documentation applies to both.

    For systems that support federation, String name arguments to Context methods are composite names. Name arguments that are instances of CompositeName are treated as composite names, while Name arguments that are not instances of CompositeName are treated as compound names (which might be instances of CompoundName or other implementations of compound names). This allows the results of NameParser.parse() to be used as arguments to the Context methods. Prior to JNDI 1.2, all name arguments were treated as composite names.

    Furthermore, for systems that support federation, all names returned in a NamingEnumeration from list() and listBindings() are composite names represented as strings. See CompositeName for the string syntax of names.

    For systems that do not support federation, the name arguments (in either Name or String forms) and the names returned in NamingEnumeration may be names in their own namespace rather than names in a composite namespace, at the discretion of the service provider.

    Exceptions

    All the methods in this interface can throw a NamingException or any of its subclasses. See NamingException and their subclasses for details on each exception.

    Concurrent Access

    A Context instance is not guaranteed to be synchronized against concurrent access by multiple threads. Threads that need to access a single Context instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different Context instance need not synchronize. Note that the lookup method, when passed an empty name, will return a new Context instance representing the same naming context.

    For purposes of concurrency control, a Context operation that returns a NamingEnumeration is not considered to have completed while the enumeration is still in use, or while any referrals generated by that operation are still being followed.

    Parameters

    A Name parameter passed to any method of the Context interface or one of its subinterfaces will not be modified by the service provider. The service provider may keep a reference to it for the duration of the operation, including any enumeration of the method's results and the processing of any referrals generated. The caller should not modify the object during this time. A Name returned by any such method is owned by the caller. The caller may subsequently modify it; the service provider may not.

    Environment Properties

    JNDI applications need a way to communicate various preferences and properties that define the environment in which naming and directory services are accessed. For example, a context might require specification of security credentials in order to access the service. Another context might require that server configuration information be supplied. These are referred to as the environment of a context. The Context interface provides methods for retrieving and updating this environment.

    The environment is inherited from the parent context as context methods proceed from one context to the next. Changes to the environment of one context do not directly affect those of other contexts.

    It is implementation-dependent when environment properties are used and/or verified for validity. For example, some of the security-related properties are used by service providers to "log in" to the directory. This login process might occur at the time the context is created, or the first time a method is invoked on the context. When, and whether this occurs at all, is implementation-dependent. When environment properties are added or removed from the context, verifying the validity of the changes is again implementation-dependent. For example, verification of some properties might occur at the time the change is made, or at the time the next operation is performed on the context, or not at all.

    Any object with a reference to a context may examine that context's environment. Sensitive information such as clear-text passwords should not be stored there unless the implementation is known to protect it.

    Resource Files

    To simplify the task of setting up the environment required by a JNDI application, application components and service providers may be distributed along with resource files. A JNDI resource file is a file in the properties file format (see java.util.Properties), containing a list of key/value pairs. The key is the name of the property (e.g. "java.naming.factory.object") and the value is a string in the format defined for that property. Here is an example of a JNDI resource file:

     java.naming.factory.object=com.sun.jndi.ldap.AttrsToCorba:com.wiz.from.Person
 java.naming.factory.state=com.sun.jndi.ldap.CorbaToAttrs:com.wiz.from.Person
 java.naming.factory.control=com.sun.jndi.ldap.ResponseControlFactory
    The JNDI class library reads the resource files and makes the property values freely available. Thus JNDI resource files should be considered to be "world readable", and sensitive information such as clear-text passwords should not be stored there.

    There are two kinds of JNDI resource files: provider and application.

    Provider Resource Files
    Each service provider has an optional resource that lists properties specific to that provider. The name of this resource is:
    [prefix/]jndiprovider.properties
    where prefix is the package name of the provider's context implementation(s), with each period (".") converted to a slash ("/"). For example, suppose a service provider defines a context implementation with class name com.sun.jndi.ldap.LdapCtx. The provider resource for this provider is named com/sun/jndi/ldap/jndiprovider.properties. If the class is not in a package, the resource's name is simply jndiprovider.properties.

    Certain methods in the JNDI class library make use of the standard JNDI properties that specify lists of JNDI factories:

    • java.naming.factory.object
    • java.naming.factory.state
    • java.naming.factory.control
    • java.naming.factory.url.pkgs
    The JNDI library will consult the provider resource file when determining the values of these properties. Properties other than these may be set in the provider resource file at the discretion of the service provider. The service provider's documentation should clearly state which properties are allowed; other properties in the file will be ignored.
    Application Resource Files
    When an application is deployed, it will generally have several codebase directories and JARs in its classpath. Similarly, when an applet is deployed, it will have a codebase and archives specifying where to find the applet's classes. JNDI locates (using ClassLoader.getResources()) all application resource files named jndi.properties in the classpath. In addition, if the file java.home/lib/jndi.properties exists and is readable, JNDI treats it as an additional application resource file. (java.home indicates the directory named by the java.home system property.) All of the properties contained in these files are placed into the environment of the initial context. This environment is then inherited by other contexts.

    For each property found in more than one application resource file, JNDI uses the first value found or, in a few cases where it makes sense to do so, it concatenates all of the values (details are given below). For example, if the "java.naming.factory.object" property is found in three jndi.properties resource files, the list of object factories is a concatenation of the property values from all three files. Using this scheme, each deployable component is responsible for listing the factories that it exports. JNDI automatically collects and uses all of these export lists when searching for factory classes.

    Search Algorithm for Properties
    When JNDI constructs an initial context, the context's environment is initialized with properties defined in the environment parameter passed to the constructor, the system properties, the applet parameters, and the application resource files. See InitialContext for details. This initial environment is then inherited by other context instances.

    When the JNDI class library needs to determine the value of a property, it does so by merging the values from the following two sources, in order:

    1. The environment of the context being operated on.
    2. The provider resource file (jndiprovider.properties) for the context being operated on.
    For each property found in both of these two sources, JNDI determines the property's value as follows. If the property is one of the standard JNDI properties that specify a list of JNDI factories (listed above), the values are concatenated into a single colon-separated list. For other properties, only the first value found is used.

    When a service provider needs to determine the value of a property, it will generally take that value directly from the environment. A service provider may define provider-specific properties to be placed in its own provider resource file. In that case it should merge values as described in the previous paragraph.

    In this way, each service provider developer can specify a list of factories to use with that service provider. These can be modified by the application resources specified by the deployer of the application or applet, which in turn can be modified by the user.

    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String APPLET
      Constant that holds the name of the environment property for specifying an applet for the initial context constructor to use when searching for other properties.
      static String AUTHORITATIVE
      Constant that holds the name of the environment property for specifying the authoritativeness of the service requested.
      static String BATCHSIZE
      Constant that holds the name of the environment property for specifying the batch size to use when returning data via the service's protocol.
      static String DNS_URL
      Constant that holds the name of the environment property for specifying the DNS host and domain names to use for the JNDI URL context (for example, "dns://somehost/wiz.com").
      static String INITIAL_CONTEXT_FACTORY
      Constant that holds the name of the environment property for specifying the initial context factory to use.
      static String LANGUAGE
      Constant that holds the name of the environment property for specifying the preferred language to use with the service.
      static String OBJECT_FACTORIES
      Constant that holds the name of the environment property for specifying the list of object factories to use.
      static String PROVIDER_URL
      Constant that holds the name of the environment property for specifying configuration information for the service provider to use.
      static String REFERRAL
      Constant that holds the name of the environment property for specifying how referrals encountered by the service provider are to be processed.
      static String SECURITY_AUTHENTICATION
      Constant that holds the name of the environment property for specifying the security level to use.
      static String SECURITY_CREDENTIALS
      Constant that holds the name of the environment property for specifying the credentials of the principal for authenticating the caller to the service.
      static String SECURITY_PRINCIPAL
      Constant that holds the name of the environment property for specifying the identity of the principal for authenticating the caller to the service.
      static String SECURITY_PROTOCOL
      Constant that holds the name of the environment property for specifying the security protocol to use.
      static String STATE_FACTORIES
      Constant that holds the name of the environment property for specifying the list of state factories to use.
      static String URL_PKG_PREFIXES
      Constant that holds the name of the environment property for specifying the list of package prefixes to use when loading in URL context factories.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object addToEnvironment(String propName, Object propVal)
      Adds a new environment property to the environment of this context.
      void bind(Name name, Object obj)
      Binds a name to an object.
      void bind(String name, Object obj)
      Binds a name to an object.
      void close()
      Closes this context.
      Name composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      String composeName(String name, String prefix)
      Composes the name of this context with a name relative to this context.
      Context createSubcontext(Name name)
      Creates and binds a new context.
      Context createSubcontext(String name)
      Creates and binds a new context.
      void destroySubcontext(Name name)
      Destroys the named context and removes it from the namespace.
      void destroySubcontext(String name)
      Destroys the named context and removes it from the namespace.
      Hashtable<?,?> getEnvironment()
      Retrieves the environment in effect for this context.
      String getNameInNamespace()
      Retrieves the full name of this context within its own namespace.
      NameParser getNameParser(Name name)
      Retrieves the parser associated with the named context.
      NameParser getNameParser(String name)
      Retrieves the parser associated with the named context.
      NamingEnumeration<NameClassPair> list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> list(String name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<Binding> listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> listBindings(String name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      Object lookup(Name name)
      Retrieves the named object.
      Object lookup(String name)
      Retrieves the named object.
      Object lookupLink(Name name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      Object lookupLink(String name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      void rebind(Name name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      void rebind(String name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      Object removeFromEnvironment(String propName)
      Removes an environment property from the environment of this context.
      void rename(Name oldName, Name newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void rename(String oldName, String newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void unbind(Name name)
      Unbinds the named object.
      void unbind(String name)
      Unbinds the named object.

    • 字段详细信息

      • INITIAL_CONTEXT_FACTORY

        static final String INITIAL_CONTEXT_FACTORY
        Constant that holds the name of the environment property for specifying the initial context factory to use. The value of the property should be the fully qualified class name of the factory class that will create an initial context. This property may be specified in the environment parameter passed to the initial context constructor, an applet parameter, a system property, or an application resource file. If it is not specified in any of these sources, NoInitialContextException is thrown when an initial context is required to complete an operation.

        The value of this constant is "java.naming.factory.initial".

        另请参见：
        InitialContext, InitialDirContext, NamingManager.getInitialContext(java.util.Hashtable), InitialContextFactory, NoInitialContextException, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, Constant Field Values

      • OBJECT_FACTORIES

        static final String OBJECT_FACTORIES
        Constant that holds the name of the environment property for specifying the list of object factories to use. The value of the property should be a colon-separated list of the fully qualified class names of factory classes that will create an object given information about the object. This property may be specified in the environment, an applet parameter, a system property, or one or more resource files.

        The value of this constant is "java.naming.factory.object".

        另请参见：
        NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, Constant Field Values

      • STATE_FACTORIES

        static final String STATE_FACTORIES
        Constant that holds the name of the environment property for specifying the list of state factories to use. The value of the property should be a colon-separated list of the fully qualified class names of state factory classes that will be used to get an object's state given the object itself. This property may be specified in the environment, an applet parameter, a system property, or one or more resource files.

        The value of this constant is "java.naming.factory.state".

        从以下版本开始：
        1.3
        另请参见：
        NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), StateFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, Constant Field Values

      • URL_PKG_PREFIXES

        static final String URL_PKG_PREFIXES
        Constant that holds the name of the environment property for specifying the list of package prefixes to use when loading in URL context factories. The value of the property should be a colon-separated list of package prefixes for the class name of the factory class that will create a URL context factory. This property may be specified in the environment, an applet parameter, a system property, or one or more resource files. The prefix com.sun.jndi.url is always appended to the possibly empty list of package prefixes.

        The value of this constant is "java.naming.factory.url.pkgs".

        另请参见：
        NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable), ObjectFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, Constant Field Values

      • PROVIDER_URL

        static final String PROVIDER_URL
        Constant that holds the name of the environment property for specifying configuration information for the service provider to use. The value of the property should contain a URL string (e.g. "ldap://somehost:389"). This property may be specified in the environment, an applet parameter, a system property, or a resource file. If it is not specified in any of these sources, the default configuration is determined by the service provider.

        The value of this constant is "java.naming.provider.url".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, Constant Field Values

      • DNS_URL

        static final String DNS_URL
        Constant that holds the name of the environment property for specifying the DNS host and domain names to use for the JNDI URL context (for example, "dns://somehost/wiz.com"). This property may be specified in the environment, an applet parameter, a system property, or a resource file. If it is not specified in any of these sources and the program attempts to use a JNDI URL containing a DNS name, a ConfigurationException will be thrown.

        The value of this constant is "java.naming.dns.url".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • AUTHORITATIVE

        static final String AUTHORITATIVE
        Constant that holds the name of the environment property for specifying the authoritativeness of the service requested. If the value of the property is the string "true", it means that the access is to the most authoritative source (i.e. bypass any cache or replicas). If the value is anything else, the source need not be (but may be) authoritative. If unspecified, the value defaults to "false".

        The value of this constant is "java.naming.authoritative".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • BATCHSIZE

        static final String BATCHSIZE
        Constant that holds the name of the environment property for specifying the batch size to use when returning data via the service's protocol. This is a hint to the provider to return the results of operations in batches of the specified size, so the provider can optimize its performance and usage of resources. The value of the property is the string representation of an integer. If unspecified, the batch size is determined by the service provider.

        The value of this constant is "java.naming.batchsize".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • REFERRAL

        static final String REFERRAL
        Constant that holds the name of the environment property for specifying how referrals encountered by the service provider are to be processed. The value of the property is one of the following strings:
        "follow"
        follow referrals automatically
        "ignore"
        ignore referrals
        "throw"
        throw ReferralException when a referral is encountered.
        If this property is not specified, the default is determined by the provider.

        The value of this constant is "java.naming.referral".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • SECURITY_PROTOCOL

        static final String SECURITY_PROTOCOL
        Constant that holds the name of the environment property for specifying the security protocol to use. Its value is a string determined by the service provider (e.g. "ssl"). If this property is unspecified, the behaviour is determined by the service provider.

        The value of this constant is "java.naming.security.protocol".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • SECURITY_AUTHENTICATION

        static final String SECURITY_AUTHENTICATION
        Constant that holds the name of the environment property for specifying the security level to use. Its value is one of the following strings: "none", "simple", "strong". If this property is unspecified, the behaviour is determined by the service provider.

        The value of this constant is "java.naming.security.authentication".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • SECURITY_PRINCIPAL

        static final String SECURITY_PRINCIPAL
        Constant that holds the name of the environment property for specifying the identity of the principal for authenticating the caller to the service. The format of the principal depends on the authentication scheme. If this property is unspecified, the behaviour is determined by the service provider.

        The value of this constant is "java.naming.security.principal".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • SECURITY_CREDENTIALS

        static final String SECURITY_CREDENTIALS
        Constant that holds the name of the environment property for specifying the credentials of the principal for authenticating the caller to the service. The value of the property depends on the authentication scheme. For example, it could be a hashed password, clear-text password, key, certificate, and so on. If this property is unspecified, the behaviour is determined by the service provider.

        The value of this constant is "java.naming.security.credentials".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • LANGUAGE

        static final String LANGUAGE
        Constant that holds the name of the environment property for specifying the preferred language to use with the service. The value of the property is a colon-separated list of language tags as defined in RFC 1766. If this property is unspecified, the language preference is determined by the service provider.

        The value of this constant is "java.naming.language".

        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), Constant Field Values

      • APPLET

        static final String APPLET
        Constant that holds the name of the environment property for specifying an applet for the initial context constructor to use when searching for other properties. The value of this property is the java.applet.Applet instance that is being executed. This property may be specified in the environment parameter passed to the initial context constructor. When this property is set, each property that the initial context constructor looks for in the system properties is first looked for in the applet's parameter list. If this property is unspecified, the initial context constructor will search for properties only in the environment parameter passed to it, the system properties, and application resource files.

        The value of this constant is "java.naming.applet".

        从以下版本开始：
        1.3
        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String), InitialContext, Constant Field Values

    • 方法详细信息

      • lookup

        Object lookup(Name name)
              throws NamingException
        Retrieves the named object. If name is empty, returns a new instance of this context (which represents the same naming context as this context, but its environment may be modified independently and it may be accessed concurrently).
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        lookup(String), lookupLink(Name)

      • lookup

        Object lookup(String name)
              throws NamingException
        Retrieves the named object. See lookup(Name) for details.
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered

      • bind

        void bind(Name name,
        Object obj)
          throws NamingException
        Binds a name to an object. All intermediate contexts and the target context (that named by all but terminal atomic component of the name) must already exist.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        bind(String, Object), rebind(Name, Object), DirContext.bind(Name, Object, javax.naming.directory.Attributes)

      • bind

        void bind(String name,
        Object obj)
          throws NamingException
        Binds a name to an object. See bind(Name, Object) for details.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered

      • rebind

        void rebind(Name name,
          Object obj)
            throws NamingException
        Binds a name to an object, overwriting any existing binding. All intermediate contexts and the target context (that named by all but terminal atomic component of the name) must already exist.

        If the object is a DirContext, any existing attributes associated with the name are replaced with those of the object. Otherwise, any existing attributes associated with the name remain unchanged.

        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        rebind(String, Object), bind(Name, Object), DirContext.rebind(Name, Object, javax.naming.directory.Attributes), DirContext

      • rebind

        void rebind(String name,
          Object obj)
            throws NamingException
        Binds a name to an object, overwriting any existing binding. See rebind(Name, Object) for details.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered

      • unbind

        void unbind(Name name)
            throws NamingException
        Unbinds the named object. Removes the terminal atomic name in name from the target context--that named by all but the terminal atomic part of name.

        This method is idempotent. It succeeds even if the terminal atomic name is not bound in the target context, but throws NameNotFoundException if any of the intermediate contexts do not exist.

        Any attributes associated with the name are removed. Intermediate contexts are not changed.

        参数：
        name - the name to unbind; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NamingException - if a naming exception is encountered
        另请参见：
        unbind(String)

      • unbind

        void unbind(String name)
            throws NamingException
        Unbinds the named object. See unbind(Name) for details.
        参数：
        name - the name to unbind; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NamingException - if a naming exception is encountered

      • rename

        void rename(Name oldName,
          Name newName)
            throws NamingException
        Binds a new name to the object bound to an old name, and unbinds the old name. Both names are relative to this context. Any attributes associated with the old name become associated with the new name. Intermediate contexts of the old name are not changed.
        参数：
        oldName - the name of the existing binding; may not be empty
        newName - the name of the new binding; may not be empty
        抛出：
        NameAlreadyBoundException - if newName is already bound
        NamingException - if a naming exception is encountered
        另请参见：
        rename(String, String),
bind(Name, Object),
rebind(Name, Object)

      • rename

        void rename(String oldName,
          String newName)
            throws NamingException
        Binds a new name to the object bound to an old name, and unbinds the old name. See rename(Name, Name) for details.
        参数：
        oldName - the name of the existing binding; may not be empty
        newName - the name of the new binding; may not be empty
        抛出：
        NameAlreadyBoundException - if newName is already bound
        NamingException - if a naming exception is encountered

      • list

        NamingEnumeration<NameClassPair> list(Name name)
                                      throws NamingException
        Enumerates the names bound in the named context, along with the class names of objects bound to them. The contents of any subcontexts are not included.

        If a binding is added to or removed from this context, its effect on an enumeration previously returned is undefined.

        参数：
        name - the name of the context to list
        返回：
        an enumeration of the names and class names of the bindings in this context. Each element of the enumeration is of type NameClassPair.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        list(String), listBindings(Name), NameClassPair

      • list

        NamingEnumeration<NameClassPair> list(String name)
                                      throws NamingException
        Enumerates the names bound in the named context, along with the class names of objects bound to them. See list(Name) for details.
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the names and class names of the bindings in this context. Each element of the enumeration is of type NameClassPair.
        抛出：
        NamingException - if a naming exception is encountered

      • listBindings

        NamingEnumeration<Binding> listBindings(Name name)
                                        throws NamingException
        Enumerates the names bound in the named context, along with the objects bound to them. The contents of any subcontexts are not included.

        If a binding is added to or removed from this context, its effect on an enumeration previously returned is undefined.

        参数：
        name - the name of the context to list
        返回：
        an enumeration of the bindings in this context. Each element of the enumeration is of type Binding.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        listBindings(String), list(Name), Binding

      • listBindings

        NamingEnumeration<Binding> listBindings(String name)
                                        throws NamingException
        Enumerates the names bound in the named context, along with the objects bound to them. See listBindings(Name) for details.
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the bindings in this context. Each element of the enumeration is of type Binding.
        抛出：
        NamingException - if a naming exception is encountered

      • destroySubcontext

        void destroySubcontext(Name name)
                       throws NamingException
        Destroys the named context and removes it from the namespace. Any attributes associated with the name are also removed. Intermediate contexts are not destroyed.

        This method is idempotent. It succeeds even if the terminal atomic name is not bound in the target context, but throws NameNotFoundException if any of the intermediate contexts do not exist.

        In a federated naming system, a context from one naming system may be bound to a name in another. One can subsequently look up and perform operations on the foreign context using a composite name. However, an attempt destroy the context using this composite name will fail with NotContextException, because the foreign context is not a "subcontext" of the context in which it is bound. Instead, use unbind() to remove the binding of the foreign context. Destroying the foreign context requires that the destroySubcontext() be performed on a context from the foreign context's "native" naming system.

        参数：
        name - the name of the context to be destroyed; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NotContextException - if the name is bound but does not name a context, or does not name a context of the appropriate type
        ContextNotEmptyException - if the named context is not empty
        NamingException - if a naming exception is encountered
        另请参见：
        destroySubcontext(String)

      • destroySubcontext

        void destroySubcontext(String name)
                       throws NamingException
        Destroys the named context and removes it from the namespace. See destroySubcontext(Name) for details.
        参数：
        name - the name of the context to be destroyed; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NotContextException - if the name is bound but does not name a context, or does not name a context of the appropriate type
        ContextNotEmptyException - if the named context is not empty
        NamingException - if a naming exception is encountered

      • createSubcontext

        Context createSubcontext(Name name)
                         throws NamingException
        Creates and binds a new context. Creates a new context with the given name and binds it in the target context (that named by all but terminal atomic component of the name). All intermediate contexts and the target context must already exist.
        参数：
        name - the name of the context to create; may not be empty
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if creation of the subcontext requires specification of mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        createSubcontext(String), DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes)

      • createSubcontext

        Context createSubcontext(String name)
                         throws NamingException
        Creates and binds a new context. See createSubcontext(Name) for details.
        参数：
        name - the name of the context to create; may not be empty
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if creation of the subcontext requires specification of mandatory attributes
        NamingException - if a naming exception is encountered

      • lookupLink

        Object lookupLink(Name name)
                  throws NamingException
        Retrieves the named object, following links except for the terminal atomic component of the name. If the object bound to name is not a link, returns the object itself.
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name, not following the terminal link (if any).
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        lookupLink(String)

      • lookupLink

        Object lookupLink(String name)
                  throws NamingException
        Retrieves the named object, following links except for the terminal atomic component of the name. See lookupLink(Name) for details.
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name, not following the terminal link (if any)
        抛出：
        NamingException - if a naming exception is encountered

      • getNameParser

        NameParser getNameParser(Name name)
                         throws NamingException
        Retrieves the parser associated with the named context. In a federation of namespaces, different naming systems will parse names differently. This method allows an application to get a parser for parsing names into their atomic components using the naming convention of a particular naming system. Within any single naming system, NameParser objects returned by this method must be equal (using the equals() test).
        参数：
        name - the name of the context from which to get the parser
        返回：
        a name parser that can parse compound names into their atomic components
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        getNameParser(String), CompoundName

      • getNameParser

        NameParser getNameParser(String name)
                         throws NamingException
        Retrieves the parser associated with the named context. See getNameParser(Name) for details.
        参数：
        name - the name of the context from which to get the parser
        返回：
        a name parser that can parse compound names into their atomic components
        抛出：
        NamingException - if a naming exception is encountered

      • composeName

        Name composeName(Name name,
               Name prefix)
                 throws NamingException
        Composes the name of this context with a name relative to this context. Given a name (name) relative to this context, and the name (prefix) of this context relative to one of its ancestors, this method returns the composition of the two names using the syntax appropriate for the naming system(s) involved. That is, if name names an object relative to this context, the result is the name of the same object, but relative to the ancestor context. None of the names may be null.

        For example, if this context is named "wiz.com" relative to the initial context, then

          composeName("east", "wiz.com")
        might return "east.wiz.com". If instead this context is named "org/research", then
          composeName("user/jane", "org/research")
        might return "org/research/user/jane" while
          composeName("user/jane", "research")
        returns "research/user/jane".
        参数：
        name - a name relative to this context
        prefix - the name of this context relative to one of its ancestors
        返回：
        the composition of prefix and name
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        composeName(String, String)

      • composeName

        String composeName(String name,
                 String prefix)
                   throws NamingException
        Composes the name of this context with a name relative to this context. See composeName(Name, Name) for details.
        参数：
        name - a name relative to this context
        prefix - the name of this context relative to one of its ancestors
        返回：
        the composition of prefix and name
        抛出：
        NamingException - if a naming exception is encountered

      • addToEnvironment

        Object addToEnvironment(String propName,
                      Object propVal)
                        throws NamingException
        Adds a new environment property to the environment of this context. If the property already exists, its value is overwritten. See class description for more details on environment properties.
        参数：
        propName - the name of the environment property to add; may not be null
        propVal - the value of the property to add; may not be null
        返回：
        the previous value of the property, or null if the property was not in the environment before
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        getEnvironment(), removeFromEnvironment(String)

      • removeFromEnvironment

        Object removeFromEnvironment(String propName)
                             throws NamingException
        Removes an environment property from the environment of this context. See class description for more details on environment properties.
        参数：
        propName - the name of the environment property to remove; may not be null
        返回：
        the previous value of the property, or null if the property was not in the environment
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        getEnvironment(), addToEnvironment(String, Object)

      • getEnvironment

        Hashtable<?,?> getEnvironment()
                              throws NamingException
        Retrieves the environment in effect for this context. See class description for more details on environment properties.

        The caller should not make any changes to the object returned: their effect on the context is undefined. The environment of this context may be changed using addToEnvironment() and removeFromEnvironment().

        返回：
        the environment of this context; never null
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        addToEnvironment(String, Object), removeFromEnvironment(String)

      • close

        void close()
           throws NamingException
        Closes this context. This method releases this context's resources immediately, instead of waiting for them to be released automatically by the garbage collector.

        This method is idempotent: invoking it on a context that has already been closed has no effect. Invoking any other method on a closed context is not allowed, and results in undefined behaviour.

        抛出：
        NamingException - if a naming exception is encountered

      • getNameInNamespace

        String getNameInNamespace()
                          throws NamingException
        Retrieves the full name of this context within its own namespace.

        Many naming services have a notion of a "full name" for objects in their respective namespaces. For example, an LDAP entry has a distinguished name, and a DNS record has a fully qualified name. This method allows the client application to retrieve this name. The string returned by this method is not a JNDI composite name and should not be passed directly to context methods. In naming systems for which the notion of full name does not make sense, OperationNotSupportedException is thrown.

        返回：
        this context's name in its own namespace; never null
        抛出：
        OperationNotSupportedException - if the naming system does not have the notion of a full name
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


ContextNotEmptyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 ContextNotEmptyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ContextNotEmptyException
  • 所有已实现的接口：
    Serializable

    public class ContextNotEmptyException
extends NamingException
    This exception is thrown when attempting to destroy a context that is not empty.

    If the program wants to handle this exception in particular, it should catch ContextNotEmptyException explicitly before attempting to catch NamingException. For example, after catching ContextNotEmptyException, the program might try to remove the contents of the context before reattempting the destroy.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context.destroySubcontext(javax.naming.Name), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      ContextNotEmptyException()
      Constructs a new instance of ContextNotEmptyException with all name resolution fields and explanation initialized to null.
      ContextNotEmptyException(String explanation)
      Constructs a new instance of ContextNotEmptyException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ContextNotEmptyException

        public ContextNotEmptyException(String explanation)
        Constructs a new instance of ContextNotEmptyException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • ContextNotEmptyException

        public ContextNotEmptyException()
        Constructs a new instance of ContextNotEmptyException with all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdoaslc lc llc Wccate inshastftoCt


InitialContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 InitialContext

  • java.lang.Object
    • javax.naming.InitialContext
  • 所有已实现的接口：
    Context
    直接已知子类：
    InitialDirContext

    public class InitialContext
extends Object
implements Context
    This class is the starting context for performing naming operations.

    All naming operations are relative to a context. The initial context implements the Context interface and provides the starting point for resolution of names.

    When the initial context is constructed, its environment is initialized with properties defined in the environment parameter passed to the constructor, and in any application resource files. In addition, a small number of standard JNDI properties may be specified as system properties or as applet parameters (through the use of Context.APPLET). These special properties are listed in the field detail sections of the Context and LdapContext interface documentation.

    JNDI determines each property's value by merging the values from the following two sources, in order:

    1. The first occurrence of the property from the constructor's environment parameter and (for appropriate properties) the applet parameters and system properties.
    2. The application resource files (jndi.properties).
    For each property found in both of these two sources, or in more than one application resource file, the property's value is determined as follows. If the property is one of the standard JNDI properties that specify a list of JNDI factories (see Context), all of the values are concatenated into a single colon-separated list. For other properties, only the first value found is used.

    The initial context implementation is determined at runtime. The default policy uses the environment property "java.naming.factory.initial", which contains the class name of the initial context factory. An exception to this policy is made when resolving URL strings, as described below.

    When a URL string (a String of the form scheme_id:rest_of_name) is passed as a name parameter to any method, a URL context factory for handling that scheme is located and used to resolve the URL. If no such factory is found, the initial context specified by "java.naming.factory.initial" is used. Similarly, when a CompositeName object whose first component is a URL string is passed as a name parameter to any method, a URL context factory is located and used to resolve the first name component. See NamingManager.getURLContext() for a description of how URL context factories are located.

    This default policy of locating the initial context and URL context factories may be overridden by calling NamingManager.setInitialContextFactoryBuilder().

    NoInitialContextException is thrown when an initial context cannot be instantiated. This exception can be thrown during any interaction with the InitialContext, not only when the InitialContext is constructed. For example, the implementation of the initial context might lazily retrieve the context only when actual methods are invoked on it. The application should not have any dependency on when the existence of an initial context is determined.

    When the environment property "java.naming.factory.initial" is non-null, the InitialContext constructor will attempt to create the initial context specified therein. At that time, the initial context factory involved might throw an exception if a problem is encountered. However, it is provider implementation-dependent when it verifies and indicates to the users of the initial context any environment property- or connection- related problems. It can do so lazily--delaying until an operation is performed on the context, or eagerly, at the time the context is constructed.

    An InitialContext instance is not synchronized against concurrent access by multiple threads. Multiple threads each manipulating a different InitialContext instance need not synchronize. Threads that need to access a single InitialContext instance concurrently should synchronize amongst themselves and provide the necessary locking.

    从以下版本开始：
    JNDI 1.1 / Java 2 Platform, Standard Edition, v 1.3
    另请参见：
    Context, NamingManager.setInitialContextFactoryBuilder

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Context defaultInitCtx
      Field holding the result of calling NamingManager.getInitialContext().
      protected boolean gotDefault
      Field indicating whether the initial context has been obtained by calling NamingManager.getInitialContext().
      protected Hashtable<Object,Object> myProps
      The environment associated with this InitialContext.

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        InitialContext()
      Constructs an initial context.
      protected InitialContext(boolean lazy)
      Constructs an initial context with the option of not initializing it.
        InitialContext(Hashtable<?,?> environment)
      Constructs an initial context using the supplied environment.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object addToEnvironment(String propName, Object propVal)
      Adds a new environment property to the environment of this context.
      void bind(Name name, Object obj)
      Binds a name to an object.
      void bind(String name, Object obj)
      Binds a name to an object.
      void close()
      Closes this context.
      Name composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      String composeName(String name, String prefix)
      Composes the name of this context with a name relative to this context.
      Context createSubcontext(Name name)
      Creates and binds a new context.
      Context createSubcontext(String name)
      Creates and binds a new context.
      void destroySubcontext(Name name)
      Destroys the named context and removes it from the namespace.
      void destroySubcontext(String name)
      Destroys the named context and removes it from the namespace.
      static <T> T doLookup(Name name)
      A static method to retrieve the named object.
      static <T> T doLookup(String name)
      A static method to retrieve the named object.
      protected Context getDefaultInitCtx()
      Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx.
      Hashtable<?,?> getEnvironment()
      Retrieves the environment in effect for this context.
      String getNameInNamespace()
      Retrieves the full name of this context within its own namespace.
      NameParser getNameParser(Name name)
      Retrieves the parser associated with the named context.
      NameParser getNameParser(String name)
      Retrieves the parser associated with the named context.
      protected Context getURLOrDefaultInitCtx(Name name)
      Retrieves a context for resolving name.
      protected Context getURLOrDefaultInitCtx(String name)
      Retrieves a context for resolving the string name name.
      protected void init(Hashtable<?,?> environment)
      Initializes the initial context using the supplied environment.
      NamingEnumeration<NameClassPair> list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> list(String name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<Binding> listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> listBindings(String name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      Object lookup(Name name)
      Retrieves the named object.
      Object lookup(String name)
      Retrieves the named object.
      Object lookupLink(Name name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      Object lookupLink(String name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      void rebind(Name name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      void rebind(String name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      Object removeFromEnvironment(String propName)
      Removes an environment property from the environment of this context.
      void rename(Name oldName, Name newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void rename(String oldName, String newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void unbind(Name name)
      Unbinds the named object.
      void unbind(String name)
      Unbinds the named object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • myProps

        protected Hashtable<Object,Object> myProps
        The environment associated with this InitialContext. It is initialized to null and is updated by the constructor that accepts an environment or by the init() method.
        另请参见：
        addToEnvironment(java.lang.String, java.lang.Object),
removeFromEnvironment(java.lang.String),
getEnvironment()

      • defaultInitCtx

        protected Context defaultInitCtx
        Field holding the result of calling NamingManager.getInitialContext(). It is set by getDefaultInitCtx() the first time getDefaultInitCtx() is called. Subsequent invocations of getDefaultInitCtx() return the value of defaultInitCtx.
        另请参见：
        getDefaultInitCtx()

      • gotDefault

        protected boolean gotDefault
        Field indicating whether the initial context has been obtained by calling NamingManager.getInitialContext(). If true, its result is in defaultInitCtx.

    • 构造方法详细信息

      • InitialContext

        protected InitialContext(boolean lazy)
                  throws NamingException
        Constructs an initial context with the option of not initializing it. This may be used by a constructor in a subclass when the value of the environment parameter is not yet known at the time the InitialContext constructor is called. The subclass's constructor will call this constructor, compute the value of the environment, and then call init() before returning.
        参数：
        lazy - true means do not initialize the initial context; false is equivalent to calling new InitialContext()
        抛出：
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.3
        另请参见：
        init(Hashtable)

      • InitialContext

        public InitialContext()
               throws NamingException
        Constructs an initial context. No environment properties are supplied. Equivalent to new InitialContext(null).
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        InitialContext(Hashtable)

      • InitialContext

        public InitialContext(Hashtable<?,?> environment)
               throws NamingException
        Constructs an initial context using the supplied environment. Environment properties are discussed in the class description.

        This constructor will not modify environment or save a reference to it, but may save a clone. Caller should not modify mutable keys and values in environment after it has been passed to the constructor.

        参数：
        environment - environment used to create the initial context. Null indicates an empty environment.
        抛出：
        NamingException - if a naming exception is encountered

    • 方法详细信息

      • init

        protected void init(Hashtable<?,?> environment)
             throws NamingException
        Initializes the initial context using the supplied environment. Environment properties are discussed in the class description.

        This method will modify environment and save a reference to it. The caller may no longer modify it.

        参数：
        environment - environment used to create the initial context. Null indicates an empty environment.
        抛出：
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.3
        另请参见：
        InitialContext(boolean)

      • doLookup

        public static <T> T doLookup(Name name)
                  throws NamingException
        A static method to retrieve the named object. This is a shortcut method equivalent to invoking:

        InitialContext ic = new InitialContext(); Object obj = ic.lookup();

        If name is empty, returns a new instance of this context (which represents the same naming context as this context, but its environment may be modified independently and it may be accessed concurrently).

        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.6
        另请参见：
        doLookup(String), lookup(Name)

      • doLookup

        public static <T> T doLookup(String name)
                  throws NamingException
        A static method to retrieve the named object. See doLookup(Name) for details.
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.6

      • getDefaultInitCtx

        protected Context getDefaultInitCtx()
                             throws NamingException
        Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx. Set gotDefault so that we know we've tried this before.
        返回：
        The non-null cached initial context.
        抛出：
        NoInitialContextException - If cannot find an initial context.
        NamingException - If a naming exception was encountered.

      • getURLOrDefaultInitCtx

        protected Context getURLOrDefaultInitCtx(String name)
                                  throws NamingException
        Retrieves a context for resolving the string name name. If name name is a URL string, then attempt to find a URL context for it. If none is found, or if name is not a URL string, then return getDefaultInitCtx().

        See getURLOrDefaultInitCtx(Name) for description of how a subclass should use this method.

        参数：
        name - The non-null name for which to get the context.
        返回：
        A URL context for name or the cached initial context. The result cannot be null.
        抛出：
        NoInitialContextException - If cannot find an initial context.
        NamingException - In a naming exception is encountered.
        另请参见：
        NamingManager.getURLContext(java.lang.String, java.util.Hashtable)

      • getURLOrDefaultInitCtx

        protected Context getURLOrDefaultInitCtx(Name name)
                                  throws NamingException
        Retrieves a context for resolving name. If the first component of name name is a URL string, then attempt to find a URL context for it. If none is found, or if the first component of name is not a URL string, then return getDefaultInitCtx().

        When creating a subclass of InitialContext, use this method as follows. Define a new method that uses this method to get an initial context of the desired subclass.

         protected XXXContext getURLOrDefaultInitXXXCtx(Name name)
 throws NamingException {
  Context answer = getURLOrDefaultInitCtx(name);
  if (!(answer instanceof XXXContext)) {
    if (answer == null) {
      throw new NoInitialContextException();
    } else {
      throw new NotContextException("Not an XXXContext");
    }
  }
  return (XXXContext)answer;
 }
        When providing implementations for the new methods in the subclass, use this newly defined method to get the initial context.

         public Object XXXMethod1(Name name, ...) {
  throws NamingException {
    return getURLOrDefaultInitXXXCtx(name).XXXMethod1(name, ...);
 }
        参数：
        name - The non-null name for which to get the context.
        返回：
        A URL context for name or the cached initial context. The result cannot be null.
        抛出：
        NoInitialContextException - If cannot find an initial context.
        NamingException - In a naming exception is encountered.
        另请参见：
        NamingManager.getURLContext(java.lang.String, java.util.Hashtable)

      • lookup

        public Object lookup(String name)
              throws NamingException
        从接口复制的描述： Context
        Retrieves the named object. See Context.lookup(Name) for details.
        指定者：
        lookup in interface Context
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered

      • lookup

        public Object lookup(Name name)
              throws NamingException
        从接口复制的描述： Context
        Retrieves the named object. If name is empty, returns a new instance of this context (which represents the same naming context as this context, but its environment may be modified independently and it may be accessed concurrently).
        指定者：
        lookup in interface Context
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.lookup(String), Context.lookupLink(Name)

      • bind

        public void bind(String name,
        Object obj)
          throws NamingException
        从接口复制的描述： Context
        Binds a name to an object. See Context.bind(Name, Object) for details.
        指定者：
        bind in interface Context
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered

      • bind

        public void bind(Name name,
        Object obj)
          throws NamingException
        从接口复制的描述： Context
        Binds a name to an object. All intermediate contexts and the target context (that named by all but terminal atomic component of the name) must already exist.
        指定者：
        bind in interface Context
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        Context.bind(String, Object), Context.rebind(Name, Object), DirContext.bind(Name, Object, javax.naming.directory.Attributes)

      • rebind

        public void rebind(String name,
          Object obj)
            throws NamingException
        从接口复制的描述： Context
        Binds a name to an object, overwriting any existing binding. See Context.rebind(Name, Object) for details.
        指定者：
        rebind in interface Context
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered

      • rebind

        public void rebind(Name name,
          Object obj)
            throws NamingException
        从接口复制的描述： Context
        Binds a name to an object, overwriting any existing binding. All intermediate contexts and the target context (that named by all but terminal atomic component of the name) must already exist.

        If the object is a DirContext, any existing attributes associated with the name are replaced with those of the object. Otherwise, any existing attributes associated with the name remain unchanged.

        指定者：
        rebind in interface Context
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        抛出：
        InvalidAttributesException - if object did not supply all mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        Context.rebind(String, Object), Context.bind(Name, Object), DirContext.rebind(Name, Object, javax.naming.directory.Attributes), DirContext

      • unbind

        public void unbind(String name)
            throws NamingException
        从接口复制的描述： Context
        Unbinds the named object. See Context.unbind(Name) for details.
        指定者：
        unbind in interface Context
        参数：
        name - the name to unbind; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NamingException - if a naming exception is encountered

      • unbind

        public void unbind(Name name)
            throws NamingException
        从接口复制的描述： Context
        Unbinds the named object. Removes the terminal atomic name in name from the target context--that named by all but the terminal atomic part of name.

        This method is idempotent. It succeeds even if the terminal atomic name is not bound in the target context, but throws NameNotFoundException if any of the intermediate contexts do not exist.

        Any attributes associated with the name are removed. Intermediate contexts are not changed.

        指定者：
        unbind in interface Context
        参数：
        name - the name to unbind; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NamingException - if a naming exception is encountered
        另请参见：
        Context.unbind(String)

      • rename

        public void rename(String oldName,
          String newName)
            throws NamingException
        从接口复制的描述： Context
        Binds a new name to the object bound to an old name, and unbinds the old name. See Context.rename(Name, Name) for details.
        指定者：
        rename in interface Context
        参数：
        oldName - the name of the existing binding; may not be empty
        newName - the name of the new binding; may not be empty
        抛出：
        NameAlreadyBoundException - if newName is already bound
        NamingException - if a naming exception is encountered

      • rename

        public void rename(Name oldName,
          Name newName)
            throws NamingException
        从接口复制的描述： Context
        Binds a new name to the object bound to an old name, and unbinds the old name. Both names are relative to this context. Any attributes associated with the old name become associated with the new name. Intermediate contexts of the old name are not changed.
        指定者：
        rename in interface Context
        参数：
        oldName - the name of the existing binding; may not be empty
        newName - the name of the new binding; may not be empty
        抛出：
        NameAlreadyBoundException - if newName is already bound
        NamingException - if a naming exception is encountered
        另请参见：
        Context.rename(String, String),
Context.bind(Name, Object),
Context.rebind(Name, Object)

      • list

        public NamingEnumeration<NameClassPair> list(String name)
                                      throws NamingException
        从接口复制的描述： Context
        Enumerates the names bound in the named context, along with the class names of objects bound to them. See Context.list(Name) for details.
        指定者：
        list in interface Context
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the names and class names of the bindings in this context. Each element of the enumeration is of type NameClassPair.
        抛出：
        NamingException - if a naming exception is encountered

      • list

        public NamingEnumeration<NameClassPair> list(Name name)
                                      throws NamingException
        从接口复制的描述： Context
        Enumerates the names bound in the named context, along with the class names of objects bound to them. The contents of any subcontexts are not included.

        If a binding is added to or removed from this context, its effect on an enumeration previously returned is undefined.

        指定者：
        list in interface Context
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the names and class names of the bindings in this context. Each element of the enumeration is of type NameClassPair.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.list(String), Context.listBindings(Name), NameClassPair

      • listBindings

        public NamingEnumeration<Binding> listBindings(String name)
                                        throws NamingException
        从接口复制的描述： Context
        Enumerates the names bound in the named context, along with the objects bound to them. See Context.listBindings(Name) for details.
        指定者：
        listBindings in interface Context
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the bindings in this context. Each element of the enumeration is of type Binding.
        抛出：
        NamingException - if a naming exception is encountered

      • listBindings

        public NamingEnumeration<Binding> listBindings(Name name)
                                        throws NamingException
        从接口复制的描述： Context
        Enumerates the names bound in the named context, along with the objects bound to them. The contents of any subcontexts are not included.

        If a binding is added to or removed from this context, its effect on an enumeration previously returned is undefined.

        指定者：
        listBindings in interface Context
        参数：
        name - the name of the context to list
        返回：
        an enumeration of the bindings in this context. Each element of the enumeration is of type Binding.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.listBindings(String), Context.list(Name), Binding

      • destroySubcontext

        public void destroySubcontext(String name)
                       throws NamingException
        从接口复制的描述： Context
        Destroys the named context and removes it from the namespace. See Context.destroySubcontext(Name) for details.
        指定者：
        destroySubcontext in interface Context
        参数：
        name - the name of the context to be destroyed; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NotContextException - if the name is bound but does not name a context, or does not name a context of the appropriate type
        ContextNotEmptyException - if the named context is not empty
        NamingException - if a naming exception is encountered

      • destroySubcontext

        public void destroySubcontext(Name name)
                       throws NamingException
        从接口复制的描述： Context
        Destroys the named context and removes it from the namespace. Any attributes associated with the name are also removed. Intermediate contexts are not destroyed.

        This method is idempotent. It succeeds even if the terminal atomic name is not bound in the target context, but throws NameNotFoundException if any of the intermediate contexts do not exist.

        In a federated naming system, a context from one naming system may be bound to a name in another. One can subsequently look up and perform operations on the foreign context using a composite name. However, an attempt destroy the context using this composite name will fail with NotContextException, because the foreign context is not a "subcontext" of the context in which it is bound. Instead, use unbind() to remove the binding of the foreign context. Destroying the foreign context requires that the destroySubcontext() be performed on a context from the foreign context's "native" naming system.

        指定者：
        destroySubcontext in interface Context
        参数：
        name - the name of the context to be destroyed; may not be empty
        抛出：
        NameNotFoundException - if an intermediate context does not exist
        NotContextException - if the name is bound but does not name a context, or does not name a context of the appropriate type
        ContextNotEmptyException - if the named context is not empty
        NamingException - if a naming exception is encountered
        另请参见：
        Context.destroySubcontext(String)

      • createSubcontext

        public Context createSubcontext(String name)
                         throws NamingException
        从接口复制的描述： Context
        Creates and binds a new context. See Context.createSubcontext(Name) for details.
        指定者：
        createSubcontext in interface Context
        参数：
        name - the name of the context to create; may not be empty
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if creation of the subcontext requires specification of mandatory attributes
        NamingException - if a naming exception is encountered

      • createSubcontext

        public Context createSubcontext(Name name)
                         throws NamingException
        从接口复制的描述： Context
        Creates and binds a new context. Creates a new context with the given name and binds it in the target context (that named by all but terminal atomic component of the name). All intermediate contexts and the target context must already exist.
        指定者：
        createSubcontext in interface Context
        参数：
        name - the name of the context to create; may not be empty
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if creation of the subcontext requires specification of mandatory attributes
        NamingException - if a naming exception is encountered
        另请参见：
        Context.createSubcontext(String), DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes)

      • lookupLink

        public Object lookupLink(String name)
                  throws NamingException
        从接口复制的描述： Context
        Retrieves the named object, following links except for the terminal atomic component of the name. See Context.lookupLink(Name) for details.
        指定者：
        lookupLink in interface Context
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name, not following the terminal link (if any)
        抛出：
        NamingException - if a naming exception is encountered

      • lookupLink

        public Object lookupLink(Name name)
                  throws NamingException
        从接口复制的描述： Context
        Retrieves the named object, following links except for the terminal atomic component of the name. If the object bound to name is not a link, returns the object itself.
        指定者：
        lookupLink in interface Context
        参数：
        name - the name of the object to look up
        返回：
        the object bound to name, not following the terminal link (if any).
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.lookupLink(String)

      • getNameParser

        public NameParser getNameParser(String name)
                         throws NamingException
        从接口复制的描述： Context
        Retrieves the parser associated with the named context. See Context.getNameParser(Name) for details.
        指定者：
        getNameParser in interface Context
        参数：
        name - the name of the context from which to get the parser
        返回：
        a name parser that can parse compound names into their atomic components
        抛出：
        NamingException - if a naming exception is encountered

      • getNameParser

        public NameParser getNameParser(Name name)
                         throws NamingException
        从接口复制的描述： Context
        Retrieves the parser associated with the named context. In a federation of namespaces, different naming systems will parse names differently. This method allows an application to get a parser for parsing names into their atomic components using the naming convention of a particular naming system. Within any single naming system, NameParser objects returned by this method must be equal (using the equals() test).
        指定者：
        getNameParser in interface Context
        参数：
        name - the name of the context from which to get the parser
        返回：
        a name parser that can parse compound names into their atomic components
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.getNameParser(String), CompoundName

      • composeName

        public String composeName(String name,
                 String prefix)
                   throws NamingException
        Composes the name of this context with a name relative to this context. Since an initial context may never be named relative to any context other than itself, the value of the prefix parameter must be an empty name ("").
        指定者：
        composeName in interface Context
        参数：
        name - a name relative to this context
        prefix - the name of this context relative to one of its ancestors
        返回：
        the composition of prefix and name
        抛出：
        NamingException - if a naming exception is encountered

      • composeName

        public Name composeName(Name name,
               Name prefix)
                 throws NamingException
        Composes the name of this context with a name relative to this context. Since an initial context may never be named relative to any context other than itself, the value of the prefix parameter must be an empty name.
        指定者：
        composeName in interface Context
        参数：
        name - a name relative to this context
        prefix - the name of this context relative to one of its ancestors
        返回：
        the composition of prefix and name
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.composeName(String, String)

      • addToEnvironment

        public Object addToEnvironment(String propName,
                      Object propVal)
                        throws NamingException
        从接口复制的描述： Context
        Adds a new environment property to the environment of this context. If the property already exists, its value is overwritten. See class description for more details on environment properties.
        指定者：
        addToEnvironment in interface Context
        参数：
        propName - the name of the environment property to add; may not be null
        propVal - the value of the property to add; may not be null
        返回：
        the previous value of the property, or null if the property was not in the environment before
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.getEnvironment(), Context.removeFromEnvironment(String)

      • removeFromEnvironment

        public Object removeFromEnvironment(String propName)
                             throws NamingException
        从接口复制的描述： Context
        Removes an environment property from the environment of this context. See class description for more details on environment properties.
        指定者：
        removeFromEnvironment in interface Context
        参数：
        propName - the name of the environment property to remove; may not be null
        返回：
        the previous value of the property, or null if the property was not in the environment
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.getEnvironment(), Context.addToEnvironment(String, Object)

      • getEnvironment

        public Hashtable<?,?> getEnvironment()
                              throws NamingException
        从接口复制的描述： Context
        Retrieves the environment in effect for this context. See class description for more details on environment properties.

        The caller should not make any changes to the object returned: their effect on the context is undefined. The environment of this context may be changed using addToEnvironment() and removeFromEnvironment().

        指定者：
        getEnvironment in interface Context
        返回：
        the environment of this context; never null
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        Context.addToEnvironment(String, Object), Context.removeFromEnvironment(String)

      • close

        public void close()
           throws NamingException
        从接口复制的描述： Context
        Closes this context. This method releases this context's resources immediately, instead of waiting for them to be released automatically by the garbage collector.

        This method is idempotent: invoking it on a context that has already been closed has no effect. Invoking any other method on a closed context is not allowed, and results in undefined behaviour.

        指定者：
        close in interface Context
        抛出：
        NamingException - if a naming exception is encountered

      • getNameInNamespace

        public String getNameInNamespace()
                          throws NamingException
        从接口复制的描述： Context
        Retrieves the full name of this context within its own namespace.

        Many naming services have a notion of a "full name" for objects in their respective namespaces. For example, an LDAP entry has a distinguished name, and a DNS record has a fully qualified name. This method allows the client application to retrieve this name. The string returned by this method is not a JNDI composite name and should not be passed directly to context methods. In naming systems for which the notion of full name does not make sense, OperationNotSupportedException is thrown.

        指定者：
        getNameInNamespace in interface Context
        返回：
        this context's name in its own namespace; never null
        抛出：
        OperationNotSupportedException - if the naming system does not have the notion of a full name
        NamingException - if a naming exception is encountered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InsufficientResourcesException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 InsufficientResourcesException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.InsufficientResourcesException
  • 所有已实现的接口：
    Serializable

    public class InsufficientResourcesException
extends NamingException
    This exception is thrown when resources are not available to complete the requested operation. This might due to a lack of resources on the server or on the client. There are no restrictions to resource types, as different services might make use of different resources. Such restrictions might be due to physical limits and/or adminstrative quotas. Examples of limited resources are internal buffers, memory, network bandwidth.

    InsufficientResourcesException is different from LimitExceededException in that the latter is due to user/system specified limits. See LimitExceededException for details.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InsufficientResourcesException()
      Constructs a new instance of InsufficientResourcesException with all name resolution fields and explanation initialized to null.
      InsufficientResourcesException(String explanation)
      Constructs a new instance of InsufficientResourcesException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InsufficientResourcesException

        public InsufficientResourcesException(String explanation)
        Constructs a new instance of InsufficientResourcesException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • InsufficientResourcesException

        public InsufficientResourcesException()
        Constructs a new instance of InsufficientResourcesException with all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bisjn"ag"av..avvi=..S>l/ta>>pr aence/O


InterruptedNamingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 InterruptedNamingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.InterruptedNamingException
  • 所有已实现的接口：
    Serializable

    public class InterruptedNamingException
extends NamingException
    This exception is thrown when the naming operation being invoked has been interrupted. For example, an application might interrupt a thread that is performing a search. If the search supports being interrupted, it will throw InterruptedNamingException. Whether an operation is interruptible and when depends on its implementation (as provided by the service providers). Different implementations have different ways of protecting their resources and objects from being damaged due to unexpected interrupts.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context, DirContext, Thread.interrupt(), InterruptedException, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InterruptedNamingException()
      Constructs an instance of InterruptedNamingException with all name resolution fields and explanation initialized to null.
      InterruptedNamingException(String explanation)
      Constructs an instance of InterruptedNamingException using an explanation of the problem.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InterruptedNamingException

        public InterruptedNamingException(String explanation)
        Constructs an instance of InterruptedNamingException using an explanation of the problem. All name resolution-related fields are initialized to null.
        参数：
        explanation - A possibly null message explaining the problem.
        另请参见：
        Throwable.getMessage()

      • InterruptedNamingException

        public InterruptedNamingException()
        Constructs an instance of InterruptedNamingException with all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= "tjcacg://gnama hgliS(hhi sas./>af


InvalidNameException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 InvalidNameException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.InvalidNameException
  • 所有已实现的接口：
    Serializable

    public class InvalidNameException
extends NamingException
    This exception indicates that the name being specified does not conform to the naming syntax of a naming system. This exception is thrown by any of the methods that does name parsing (such as those in Context, DirContext, CompositeName and CompoundName).

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context, DirContext, CompositeName, CompoundName, NameParser, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidNameException()
      Constructs an instance of InvalidNameException with all fields set to null.
      InvalidNameException(String explanation)
      Constructs an instance of InvalidNameException using an explanation of the problem.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidNameException

        public InvalidNameException(String explanation)
        Constructs an instance of InvalidNameException using an explanation of the problem. All other fields are initialized to null.
        参数：
        explanation - A possibly null message explaining the problem.
        另请参见：
        Throwable.getMessage()

      • InvalidNameException

        public InvalidNameException()
        Constructs an instance of InvalidNameException with all fields set to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xe.s7sesescidext exx娶妆罕档伪朐r牟 �/hs


javax.naming

Interfaces

  • Context
  • Name
  • NameParser
  • NamingEnumeration
  • Referenceable

Classes

  • BinaryRefAddr
  • Binding
  • CompositeName
  • CompoundName
  • InitialContext
  • LinkRef
  • NameClassPair
  • RefAddr
  • Reference
  • StringRefAddr

Exceptions

  • AuthenticationException
  • AuthenticationNotSupportedException
  • CannotProceedException
  • CommunicationException
  • ConfigurationException
  • ContextNotEmptyException
  • InsufficientResourcesException
  • InterruptedNamingException
  • InvalidNameException
  • LimitExceededException
  • LinkException
  • LinkLoopException
  • MalformedLinkException
  • NameAlreadyBoundException
  • NameNotFoundException
  • NamingException
  • NamingSecurityException
  • NoInitialContextException
  • NoPermissionException
  • NotContextException
  • OperationNotSupportedException
  • PartialResultException
  • ReferralException
  • ServiceUnavailableException
  • SizeLimitExceededException
  • TimeLimitExceededException
L


javax.naming

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.naming

Provides the classes and interfaces for accessing naming services.

请参见： 描述

  • 接口摘要
    接口 描述
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NameParser
    This interface is used for parsing names from a hierarchical namespace.
    NamingEnumeration<T>
    This interface is for enumerating lists returned by methods in the javax.naming and javax.naming.directory packages.
    Referenceable
    This interface is implemented by an object that can provide a Reference to itself.
  • Class Summary
    类 描述
    BinaryRefAddr
    This class represents the binary form of the address of a communications end-point.
    Binding
    This class represents a name-to-object binding found in a context.
    CompositeName
    This class represents a composite name -- a sequence of component names spanning multiple namespaces.
    CompoundName
    This class represents a compound name -- a name from a hierarchical name space.
    InitialContext
    This class is the starting context for performing naming operations.
    LinkRef
    This class represents a Reference whose contents is a name, called the link name, that is bound to an atomic name in a context.
    NameClassPair
    This class represents the object name and class name pair of a binding found in a context.
    RefAddr
    This class represents the address of a communications end-point.
    Reference
    This class represents a reference to an object that is found outside of the naming/directory system.
    StringRefAddr
    This class represents the string form of the address of a communications end-point.
  • Exception Summary
    Exception 描述
    AuthenticationException
    This exception is thrown when an authentication error occurs while accessing the naming or directory service.
    AuthenticationNotSupportedException
    This exception is thrown when the particular flavor of authentication requested is not supported.
    CannotProceedException
    This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further.
    CommunicationException
    This exception is thrown when the client is unable to communicate with the directory or naming service.
    ConfigurationException
    This exception is thrown when there is a configuration problem.
    ContextNotEmptyException
    This exception is thrown when attempting to destroy a context that is not empty.
    InsufficientResourcesException
    This exception is thrown when resources are not available to complete the requested operation.
    InterruptedNamingException
    This exception is thrown when the naming operation being invoked has been interrupted.
    InvalidNameException
    This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
    LimitExceededException
    This exception is thrown when a method terminates abnormally due to a user or system specified limit.
    LinkException
    This exception is used to describe problems encounter while resolving links.
    LinkLoopException
    This exception is thrown when a loop was detected will attempting to resolve a link, or an implementation specific limit on link counts has been reached.
    MalformedLinkException
    This exception is thrown when a malformed link was encountered while resolving or constructing a link.
    NameAlreadyBoundException
    This exception is thrown by methods to indicate that a binding cannot be added because the name is already bound to another object.
    NameNotFoundException
    This exception is thrown when a component of the name cannot be resolved because it is not bound.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
    NamingSecurityException
    This is the superclass of security-related exceptions thrown by operations in the Context and DirContext interfaces.
    NoInitialContextException
    This exception is thrown when no initial context implementation can be created.
    NoPermissionException
    This exception is thrown when attempting to perform an operation for which the client has no permission.
    NotContextException
    This exception is thrown when a naming operation proceeds to a point where a context is required to continue the operation, but the resolved object is not a context.
    OperationNotSupportedException
    This exception is thrown when a context implementation does not support the operation being invoked.
    PartialResultException
    This exception is thrown to indicate that the result being returned or returned so far is partial, and that the operation cannot be completed.
    ReferralException
    This abstract class is used to represent a referral exception, which is generated in response to a referral such as that returned by LDAP v3 servers.
    ServiceUnavailableException
    This exception is thrown when attempting to communicate with a directory or naming service and that service is not available.
    SizeLimitExceededException
    This exception is thrown when a method produces a result that exceeds a size-related limit.
    TimeLimitExceededException
    This exception is thrown when a method does not terminate within the specified time limit.

软件包 javax.naming Description

Provides the classes and interfaces for accessing naming services.

This package defines the naming operations of the Java Naming and Directory InterfaceTM (JNDI). JNDI provides naming and directory functionality to applications written in the Java programming language. It is designed to be independent of any specific naming or directory service implementation. Thus a variety of services--new, emerging, and already deployed ones--can be accessed in a common way.

Context

This package defines the notion of a context, represented by the Context interface. A context consists of a set of name-to-object bindings. Context is the core interface for looking up, binding, unbinding, and renaming objects, and for creating and destroying subcontexts.

lookup() is the most commonly used operation. You supply lookup() the name of the object you want to look up, and it returns the object bound to that name. For example, the following code fragment looks up a printer and sends a document to the printer object to be printed:

Printer printer = (Printer)ctx.lookup("treekiller");
printer.print(report);

Names

Every naming method in the Context interface has two overloads: one that accepts a Name argument and one that accepts a string name. Name is an interface that represents a generic name--an ordered sequence of zero of more components. For these methods, Name can be used to represent a composite name (CompositeName) so that you can name an object using a name which spans multiple namespaces.

The overloads that accept Name are useful for applications that need to manipulate names: composing them, comparing components, and so on. The overloads that accept string names are likely to be more useful for simple applications, such as those that simply read in a name and look up the corresponding object.

Bindings

The Binding class represents a name-to-object binding. It is a tuple containing the name of the bound object, the name of the object's class, and the object itself.

The Binding class is actually a subclass of NameClassPair, which consists simply of the object's name and the object's class name. The NameClassPair is useful when you only want information about the object's class and do not want to pay the extra cost of getting the object.

References

Objects are stored in naming and directory services in different ways. If an object store supports storing Java objects, it might support storing an object in its serialized form. However, some naming and directory services do not support the storing of Java objects. Furthermore, for some objects in the directory, Java programs are but one group of applications that access them. In this case, a serialized Java object might not be the most appropriate representation. JNDI defines a reference, represented by the Reference class, which contains information on how to construct a copy of the object. JNDI will attempt to turn references looked up from the directory into the Java objects they represent, so that JNDI clients have the illusion that what is stored in the directory are Java objects.

The Initial Context

In JNDI, all naming and directory operations are performed relative to a context. There are no absolute roots. Therefore JNDI defines an initial context, InitialContext, which provides a starting point for naming and directory operations. Once you have an initial context, you can use it to look up other contexts and objects.

Exceptions

JNDI defines a class hierarchy for exceptions that can be thrown in the course of performing naming and directory operations. The root of this class hierarchy is NamingException. Programs interested in dealing with a particular exception can catch the corresponding subclass of the exception. Otherwise, programs should catch NamingException.

Package Specification

The JNDI API Specification and related documents can be found in the JNDI documentation.
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tgmg=nO/al////>>/c蘣t


javax.naming Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.naming

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.naming.CompositeName (implements javax.naming.Name)
    • javax.naming.CompoundName (implements javax.naming.Name)
    • javax.naming.InitialContext (implements javax.naming.Context)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
    • javax.naming.RefAddr (implements java.io.Serializable)
      • javax.naming.BinaryRefAddr
      • javax.naming.StringRefAddr
    • javax.naming.Reference (implements java.lang.Cloneable, java.io.Serializable)
      • javax.naming.LinkRef
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.CannotProceedException
          • javax.naming.CommunicationException
          • javax.naming.ConfigurationException
          • javax.naming.ContextNotEmptyException
          • javax.naming.InsufficientResourcesException
          • javax.naming.InterruptedNamingException
          • javax.naming.InvalidNameException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
            • javax.naming.TimeLimitExceededException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
            • javax.naming.MalformedLinkException
          • javax.naming.NameAlreadyBoundException
          • javax.naming.NameNotFoundException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
            • javax.naming.AuthenticationNotSupportedException
            • javax.naming.NoPermissionException
          • javax.naming.NoInitialContextException
          • javax.naming.NotContextException
          • javax.naming.OperationNotSupportedException
          • javax.naming.PartialResultException
          • javax.naming.ReferralException
          • javax.naming.ServiceUnavailableException

Interface Hierarchy

  • java.lang.Cloneable
    • javax.naming.Name (also extends java.lang.Comparable<T>, java.io.Serializable)
  • java.lang.Comparable<T>
    • javax.naming.Name (also extends java.lang.Cloneable, java.io.Serializable)
  • javax.naming.Context
  • java.util.Enumeration<E>
    • javax.naming.NamingEnumeration<T>
  • javax.naming.NameParser
  • javax.naming.Referenceable
  • java.io.Serializable
    • javax.naming.Name (also extends java.lang.Cloneable, java.lang.Comparable<T>)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t. omalpeee hhixi "p


LimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 LimitExceededException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LimitExceededException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    SizeLimitExceededException, TimeLimitExceededException

    public class LimitExceededException
extends NamingException
    This exception is thrown when a method terminates abnormally due to a user or system specified limit. This is different from a InsufficientResourceException in that LimitExceededException is due to a user/system specified limit. For example, running out of memory to complete the request would be an insufficient resource. The client asking for 10 answers and getting back 11 is a size limit exception.

    Examples of these limits include client and server configuration limits such as size, time, number of hops, etc.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      LimitExceededException()
      Constructs a new instance of LimitExceededException with all name resolution fields and explanation initialized to null.
      LimitExceededException(String explanation)
      Constructs a new instance of LimitExceededException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LimitExceededException

        public LimitExceededException()
        Constructs a new instance of LimitExceededException with all name resolution fields and explanation initialized to null.

      • LimitExceededException

        public LimitExceededException(String explanation)
        Constructs a new instance of LimitExceededException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null detail about this exception.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tkaoimoeomedetl la�/=llkk nbnakl"nv�


LinkException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 LinkException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LinkException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    LinkLoopException, MalformedLinkException

    public class LinkException
extends NamingException
    This exception is used to describe problems encounter while resolving links. Addition information is added to the base NamingException for pinpointing the problem with the link.

    Analogous to how NamingException captures name resolution information, LinkException captures "link"-name resolution information pinpointing the problem encountered while resolving a link. All these fields may be null.

    • Link Resolved Name. Portion of link name that has been resolved.
    • Link Resolved Object. Object to which resolution of link name proceeded.
    • Link Remaining Name. Portion of link name that has not been resolved.
    • Link Explanation. Detail explaining why link resolution failed.

    A LinkException instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single LinkException instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Context.lookupLink(javax.naming.Name), LinkRef, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected String linkExplanation
      Contains the exception of why resolution of the link failed.
      protected Name linkRemainingName
      Contains the remaining link name that has not been resolved yet.
      protected Name linkResolvedName
      Contains the part of the link that has been successfully resolved.
      protected Object linkResolvedObj
      Contains the object to which resolution of the part of the link was successful.

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      LinkException()
      Constructs a new instance of LinkException.
      LinkException(String explanation)
      Constructs a new instance of LinkException with an explanation All the other fields are initialized to null.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getLinkExplanation()
      Retrieves the explanation associated with the problem encounter when resolving a link.
      Name getLinkRemainingName()
      Retrieves the remaining unresolved portion of the link name.
      Name getLinkResolvedName()
      Retrieves the leading portion of the link name that was resolved successfully.
      Object getLinkResolvedObj()
      Retrieves the object to which resolution was successful.
      void setLinkExplanation(String msg)
      Sets the explanation associated with the problem encounter when resolving a link.
      void setLinkRemainingName(Name name)
      Sets the remaining link name field of this exception.
      void setLinkResolvedName(Name name)
      Sets the resolved link name field of this exception.
      void setLinkResolvedObj(Object obj)
      Sets the link resolved object field of this exception.
      String toString()
      Generates the string representation of this exception.
      String toString(boolean detail)
      Generates the string representation of this exception.

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • linkResolvedName

        protected Name linkResolvedName
        Contains the part of the link that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getLinkResolvedName(), setLinkResolvedName(javax.naming.Name)

      • linkResolvedObj

        protected Object linkResolvedObj
        Contains the object to which resolution of the part of the link was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getLinkResolvedObj(), setLinkResolvedObj(java.lang.Object)

      • linkRemainingName

        protected Name linkRemainingName
        Contains the remaining link name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getLinkRemainingName(), setLinkRemainingName(javax.naming.Name)

      • linkExplanation

        protected String linkExplanation
        Contains the exception of why resolution of the link failed. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getLinkExplanation(), setLinkExplanation(java.lang.String)

    • 构造方法详细信息

      • LinkException

        public LinkException(String explanation)
        Constructs a new instance of LinkException with an explanation All the other fields are initialized to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • LinkException

        public LinkException()
        Constructs a new instance of LinkException. All the non-link-related and link-related fields are initialized to null.

    • 方法详细信息

      • getLinkResolvedName

        public Name getLinkResolvedName()
        Retrieves the leading portion of the link name that was resolved successfully.
        返回：
        The part of the link name that was resolved successfully. It is a composite name. It can be null, which means the link resolved name field has not been set.
        另请参见：
        getLinkResolvedObj(), setLinkResolvedName(javax.naming.Name)

      • getLinkRemainingName

        public Name getLinkRemainingName()
        Retrieves the remaining unresolved portion of the link name.
        返回：
        The part of the link name that has not been resolved. It is a composite name. It can be null, which means the link remaining name field has not been set.
        另请参见：
        setLinkRemainingName(javax.naming.Name)

      • getLinkResolvedObj

        public Object getLinkResolvedObj()
        Retrieves the object to which resolution was successful. This is the object to which the resolved link name is bound.
        返回：
        The possibly null object that was resolved so far. If null, it means the link resolved object field has not been set.
        另请参见：
        getLinkResolvedName(), setLinkResolvedObj(java.lang.Object)

      • getLinkExplanation

        public String getLinkExplanation()
        Retrieves the explanation associated with the problem encounter when resolving a link.
        返回：
        The possibly null detail string explaining more about the problem with resolving a link. If null, it means there is no link detail message for this exception.
        另请参见：
        setLinkExplanation(java.lang.String)

      • setLinkExplanation

        public void setLinkExplanation(String msg)
        Sets the explanation associated with the problem encounter when resolving a link.
        参数：
        msg - The possibly null detail string explaining more about the problem with resolving a link. If null, it means no detail will be recorded.
        另请参见：
        getLinkExplanation()

      • setLinkResolvedName

        public void setLinkResolvedName(Name name)
        Sets the resolved link name field of this exception.

        name is a composite name. If the intent is to set this field using a compound name or string, you must "stringify" the compound name, and create a composite name with a single component using the string. You can then invoke this method using the resulting composite name.

        A copy of name is made and stored. Subsequent changes to name does not affect the copy in this NamingException and vice versa.

        参数：
        name - The name to set resolved link name to. This can be null. If null, it sets the link resolved name field to null.
        另请参见：
        getLinkResolvedName()

      • setLinkRemainingName

        public void setLinkRemainingName(Name name)
        Sets the remaining link name field of this exception.

        name is a composite name. If the intent is to set this field using a compound name or string, you must "stringify" the compound name, and create a composite name with a single component using the string. You can then invoke this method using the resulting composite name.

        A copy of name is made and stored. Subsequent changes to name does not affect the copy in this NamingException and vice versa.

        参数：
        name - The name to set remaining link name to. This can be null. If null, it sets the remaining name field to null.
        另请参见：
        getLinkRemainingName()

      • setLinkResolvedObj

        public void setLinkResolvedObj(Object obj)
        Sets the link resolved object field of this exception. This indicates the last successfully resolved object of link name.
        参数：
        obj - The object to set link resolved object to. This can be null. If null, the link resolved object field is set to null.
        另请参见：
        getLinkResolvedObj()

      • toString

        public String toString()
        Generates the string representation of this exception. This string consists of the NamingException information plus the link's remaining name. This string is used for debugging and not meant to be interpreted programmatically.
        重载：
        toString in class NamingException
        返回：
        The non-null string representation of this link exception.

      • toString

        public String toString(boolean detail)
        Generates the string representation of this exception. This string consists of the NamingException information plus the additional information of resolving the link. If 'detail' is true, the string also contains information on the link resolved object. If false, this method is the same as the form of toString() that accepts no parameters. This string is used for debugging and not meant to be interpreted programmatically.
        重载：
        toString in class NamingException
        参数：
        detail - If true, add information about the link resolved object.
        返回：
        The non-null string representation of this link exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LinkLoopException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 LinkLoopException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
  • 所有已实现的接口：
    Serializable

    public class LinkLoopException
extends LinkException
    This exception is thrown when a loop was detected will attempting to resolve a link, or an implementation specific limit on link counts has been reached.

    Synchronization and serialization issues that apply to LinkException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    LinkRef, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.LinkException

        linkExplanation, linkRemainingName, linkResolvedName, linkResolvedObj

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      LinkLoopException()
      Constructs a new instance of LinkLoopException.
      LinkLoopException(String explanation)
      Constructs a new instance of LinkLoopException with an explanation All the other fields are initialized to null.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.LinkException

        getLinkExplanation, getLinkRemainingName, getLinkResolvedName, getLinkResolvedObj, setLinkExplanation, setLinkRemainingName, setLinkResolvedName, setLinkResolvedObj, toString, toString

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinkLoopException

        public LinkLoopException(String explanation)
        Constructs a new instance of LinkLoopException with an explanation All the other fields are initialized to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • LinkLoopException

        public LinkLoopException()
        Constructs a new instance of LinkLoopException. All the non-link-related and link-related fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/wat"gc>gcaeecaaamTTnaawgabbl#aa" ."o


LinkRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 LinkRef

  • java.lang.Object
    • javax.naming.Reference
      • javax.naming.LinkRef
  • 所有已实现的接口：
    Serializable, Cloneable

    public class LinkRef
extends Reference
    This class represents a Reference whose contents is a name, called the link name, that is bound to an atomic name in a context.

    The name is a URL, or a name to be resolved relative to the initial context, or if the first character of the name is ".", the name is relative to the context in which the link is bound.

    Normal resolution of names in context operations always follow links. Resolution of the link name itself may cause resolution to pass through other links. This gives rise to the possibility of a cycle of links whose resolution could not terminate normally. As a simple means to avoid such non-terminating resolutions, service providers may define limits on the number of links that may be involved in any single operation invoked by the caller.

    A LinkRef contains a single StringRefAddr, whose type is "LinkAddress", and whose contents is the link name. The class name field of the Reference is that of this (LinkRef) class.

    LinkRef is bound to a name using the normal Context.bind()/rebind(), and DirContext.bind()/rebind(). Context.lookupLink() is used to retrieve the link itself if the terminal atomic name is bound to a link.

    Many naming systems support a native notion of link that may be used within the naming system itself. JNDI does not specify whether there is any relationship between such native links and JNDI links.

    A LinkRef instance is not synchronized against concurrent access by multiple threads. Threads that need to access a LinkRef instance concurrently should synchronize amongst themselves and provide the necessary locking.

    从以下版本开始：
    1.3
    另请参见：
    LinkException, LinkLoopException, MalformedLinkException, Context.lookupLink(javax.naming.Name), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.Reference

        addrs, classFactory, classFactoryLocation, className

    • 构造方法摘要

      Constructors
      构造方法与描述
      LinkRef(Name linkName)
      Constructs a LinkRef for a name.
      LinkRef(String linkName)
      Constructs a LinkRef for a string name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getLinkName()
      Retrieves the name of this link.

      • 方法 - 继承于类 javax.naming.Reference

        add, add, clear, clone, equals, get, get, getAll, getClassName, getFactoryClassLocation, getFactoryClassName, hashCode, remove, size, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LinkRef

        public LinkRef(Name linkName)
        Constructs a LinkRef for a name.
        参数：
        linkName - The non-null name for which to create this link.

      • LinkRef

        public LinkRef(String linkName)
        Constructs a LinkRef for a string name.
        参数：
        linkName - The non-null name for which to create this link.

    • 方法详细信息

      • getLinkName

        public String getLinkName()
                   throws NamingException
        Retrieves the name of this link.
        返回：
        The non-null name of this link.
        抛出：
        MalformedLinkException - If a link name could not be extracted
        NamingException - If a naming exception was encountered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

VbBTFT TATTMNAVRN ==u/o o/>>>/d>/adles-


MalformedLinkException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 MalformedLinkException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LinkException
            • javax.naming.MalformedLinkException
  • 所有已实现的接口：
    Serializable

    public class MalformedLinkException
extends LinkException
    This exception is thrown when a malformed link was encountered while resolving or constructing a link.

    Synchronization and serialization issues that apply to LinkException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    LinkRef.getLinkName(), LinkRef, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.LinkException

        linkExplanation, linkRemainingName, linkResolvedName, linkResolvedObj

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      MalformedLinkException()
      Constructs a new instance of Malformed LinkException.
      MalformedLinkException(String explanation)
      Constructs a new instance of MalformedLinkException with an explanation All the other fields are initialized to null.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.LinkException

        getLinkExplanation, getLinkRemainingName, getLinkResolvedName, getLinkResolvedObj, setLinkExplanation, setLinkRemainingName, setLinkResolvedName, setLinkResolvedObj, toString, toString

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MalformedLinkException

        public MalformedLinkException(String explanation)
        Constructs a new instance of MalformedLinkException with an explanation All the other fields are initialized to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.

      • MalformedLinkException

        public MalformedLinkException()
        Constructs a new instance of Malformed LinkException. All fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/█` \� @mta� 塼h繟�/T�<�


Name

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming

Interface Name

  • All Superinterfaces:
    Cloneable, Comparable<Object>, Serializable
    All Known Implementing Classes:
    CompositeName, CompoundName, LdapName

    public interface Name
extends Cloneable, Serializable, Comparable<Object>
    The Name interface represents a generic name -- an ordered sequence of components. It can be a composite name (names that span multiple namespaces), or a compound name (names that are used within individual hierarchical naming systems).

    There can be different implementations of Name; for example, composite names, URLs, or namespace-specific compound names.

    The components of a name are numbered. The indexes of a name with N components range from 0 up to, but not including, N. This range may be written as [0,N). The most significant component is at index 0. An empty name has no components.

    None of the methods in this interface accept null as a valid value for a parameter that is a name or a name component. Likewise, methods that return a name or name component never return null.

    An instance of a Name may not be synchronized against concurrent multithreaded access if that access is not read-only.

    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static long serialVersionUID
      The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name add(int posn, String comp)
      Adds a single component at a specified position within this name.
      Name add(String comp)
      Adds a single component to the end of this name.
      Name addAll(int posn, Name n)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Object clone()
      Generates a new copy of this name.
      int compareTo(Object obj)
      Compares this name with another name for order.
      boolean endsWith(Name n)
      Determines whether this name ends with a specified suffix.
      String get(int posn)
      Retrieves a component of this name.
      Enumeration<String> getAll()
      Retrieves the components of this name as an enumeration of strings.
      Name getPrefix(int posn)
      Creates a name whose components consist of a prefix of the components of this name.
      Name getSuffix(int posn)
      Creates a name whose components consist of a suffix of the components in this name.
      boolean isEmpty()
      Determines whether this name is empty.
      Object remove(int posn)
      Removes a component from this name.
      int size()
      Returns the number of components in this name.
      boolean startsWith(Name n)
      Determines whether this name starts with a specified prefix.

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • clone

        Object clone()
        Generates a new copy of this name. Subsequent changes to the components of this name will not affect the new copy, and vice versa.
        返回：
        a copy of this name
        另请参见：
        Object.clone()

      • compareTo

        int compareTo(Object obj)
        Compares this name with another name for order. Returns a negative integer, zero, or a positive integer as this name is less than, equal to, or greater than the given name.

        As with Object.equals(), the notion of ordering for names depends on the class that implements this interface. For example, the ordering may be based on lexicographical ordering of the name components. Specific attributes of the name, such as how it treats case, may affect the ordering. In general, two names of different classes may not be compared.

        指定者：
        compareTo in interface Comparable<Object>
        参数：
        obj - the non-null object to compare against.
        返回：
        a negative integer, zero, or a positive integer as this name is less than, equal to, or greater than the given name
        抛出：
        ClassCastException - if obj is not a Name of a type that may be compared with this name
        另请参见：
        Comparable.compareTo(Object)

      • size

        int size()
        Returns the number of components in this name.
        返回：
        the number of components in this name

      • isEmpty

        boolean isEmpty()
        Determines whether this name is empty. An empty name is one with zero components.
        返回：
        true if this name is empty, false otherwise

      • getAll

        Enumeration<String> getAll()
        Retrieves the components of this name as an enumeration of strings. The effect on the enumeration of updates to this name is undefined. If the name has zero components, an empty (non-null) enumeration is returned.
        返回：
        an enumeration of the components of this name, each a string

      • get

        String get(int posn)
        Retrieves a component of this name.
        参数：
        posn - the 0-based index of the component to retrieve. Must be in the range [0,size()).
        返回：
        the component at index posn
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range

      • getPrefix

        Name getPrefix(int posn)
        Creates a name whose components consist of a prefix of the components of this name. Subsequent changes to this name will not affect the name that is returned and vice versa.
        参数：
        posn - the 0-based index of the component at which to stop. Must be in the range [0,size()].
        返回：
        a name consisting of the components at indexes in the range [0,posn).
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range

      • getSuffix

        Name getSuffix(int posn)
        Creates a name whose components consist of a suffix of the components in this name. Subsequent changes to this name do not affect the name that is returned and vice versa.
        参数：
        posn - the 0-based index of the component at which to start. Must be in the range [0,size()].
        返回：
        a name consisting of the components at indexes in the range [posn,size()). If posn is equal to size(), an empty name is returned.
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range

      • startsWith

        boolean startsWith(Name n)
        Determines whether this name starts with a specified prefix. A name n is a prefix if it is equal to getPrefix(n.size()).
        参数：
        n - the name to check
        返回：
        true if n is a prefix of this name, false otherwise

      • endsWith

        boolean endsWith(Name n)
        Determines whether this name ends with a specified suffix. A name n is a suffix if it is equal to getSuffix(size()-n.size()).
        参数：
        n - the name to check
        返回：
        true if n is a suffix of this name, false otherwise

      • addAll

        Name addAll(Name suffix)
            throws InvalidNameException
        Adds the components of a name -- in order -- to the end of this name.
        参数：
        suffix - the components to add
        返回：
        the updated name (not a new one)
        抛出：
        InvalidNameException - if suffix is not a valid name, or if the addition of the components would violate the syntax rules of this name

      • addAll

        Name addAll(int posn,
          Name n)
            throws InvalidNameException
        Adds the components of a name -- in order -- at a specified position within this name. Components of this name at or after the index of the first new component are shifted up (away from 0) to accommodate the new components.
        参数：
        n - the components to add
        posn - the index in this name at which to add the new components. Must be in the range [0,size()].
        返回：
        the updated name (not a new one)
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range
        InvalidNameException - if n is not a valid name, or if the addition of the components would violate the syntax rules of this name

      • add

        Name add(String comp)
         throws InvalidNameException
        Adds a single component to the end of this name.
        参数：
        comp - the component to add
        返回：
        the updated name (not a new one)
        抛出：
        InvalidNameException - if adding comp would violate the syntax rules of this name

      • add

        Name add(int posn,
       String comp)
         throws InvalidNameException
        Adds a single component at a specified position within this name. Components of this name at or after the index of the new component are shifted up by one (away from index 0) to accommodate the new component.
        参数：
        comp - the component to add
        posn - the index at which to add the new component. Must be in the range [0,size()].
        返回：
        the updated name (not a new one)
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range
        InvalidNameException - if adding comp would violate the syntax rules of this name

      • remove

        Object remove(int posn)
              throws InvalidNameException
        Removes a component from this name. The component of this name at the specified position is removed. Components with indexes greater than this position are shifted down (toward index 0) by one.
        参数：
        posn - the index of the component to remove. Must be in the range [0,size()).
        返回：
        the component removed (a String)
        抛出：
        ArrayIndexOutOfBoundsException - if posn is outside the specified range
        InvalidNameException - if deleting the component would violate the syntax rules of the name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>t lm瞨裕安lebd > m"a


NameAlreadyBoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NameAlreadyBoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NameAlreadyBoundException
  • 所有已实现的接口：
    Serializable

    public class NameAlreadyBoundException
extends NamingException
    This exception is thrown by methods to indicate that a binding cannot be added because the name is already bound to another object.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context.bind(javax.naming.Name, java.lang.Object),
Context.rebind(javax.naming.Name, java.lang.Object),
Context.createSubcontext(javax.naming.Name),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameAlreadyBoundException()
      Constructs a new instance of NameAlreadyBoundException.
      NameAlreadyBoundException(String explanation)
      Constructs a new instance of NameAlreadyBoundException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NameAlreadyBoundException

        public NameAlreadyBoundException(String explanation)
        Constructs a new instance of NameAlreadyBoundException using the explanation supplied. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • NameAlreadyBoundException

        public NameAlreadyBoundException()
        Constructs a new instance of NameAlreadyBoundException. All fields are set to null;
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a< t a t atc


NameClassPair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 NameClassPair

  • java.lang.Object
    • javax.naming.NameClassPair
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    Binding

    public class NameClassPair
extends Object
implements Serializable
    This class represents the object name and class name pair of a binding found in a context.

    A context consists of name-to-object bindings. The NameClassPair class represents the name and the class of the bound object. It consists of a name and a string representing the package-qualified class name.

    Use subclassing for naming systems that generate contents of a name/class pair dynamically.

    A NameClassPair instance is not synchronized against concurrent access by multiple threads. Threads that need to access a NameClassPair concurrently should synchronize amongst themselves and provide the necessary locking.

    从以下版本开始：
    1.3
    另请参见：
    Context.list(javax.naming.Name), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameClassPair(String name, String className)
      Constructs an instance of a NameClassPair given its name and class name.
      NameClassPair(String name, String className, boolean isRelative)
      Constructs an instance of a NameClassPair given its name, class name, and whether it is relative to the listing context.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getClassName()
      Retrieves the class name of the object bound to the name of this binding.
      String getName()
      Retrieves the name of this binding.
      String getNameInNamespace()
      Retrieves the full name of this binding.
      boolean isRelative()
      Determines whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
      void setClassName(String name)
      Sets the class name of this binding.
      void setName(String name)
      Sets the name of this binding.
      void setNameInNamespace(String fullName)
      Sets the full name of this binding.
      void setRelative(boolean r)
      Sets whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
      String toString()
      Generates the string representation of this name/class pair.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NameClassPair

        public NameClassPair(String name,
             String className)
        Constructs an instance of a NameClassPair given its name and class name.
        参数：
        name - The non-null name of the object. It is relative to the target context (which is named by the first parameter of the list() method)
        className - The possibly null class name of the object bound to name. It is null if the object bound is null.
        另请参见：
        getClassName(),
setClassName(java.lang.String),
getName(),
setName(java.lang.String)

      • NameClassPair

        public NameClassPair(String name,
             String className,
             boolean isRelative)
        Constructs an instance of a NameClassPair given its name, class name, and whether it is relative to the listing context.
        参数：
        name - The non-null name of the object.
        className - The possibly null class name of the object bound to name. It is null if the object bound is null.
        isRelative - true if name is a name relative to the target context (which is named by the first parameter of the list() method); false if name is a URL string.
        另请参见：
        getClassName(),
setClassName(java.lang.String),
getName(),
setName(java.lang.String),
isRelative(),
setRelative(boolean)

    • 方法详细信息

      • getClassName

        public String getClassName()
        Retrieves the class name of the object bound to the name of this binding. If a reference or some other indirect information is bound, retrieves the class name of the eventual object that will be returned by Binding.getObject().
        返回：
        The possibly null class name of object bound. It is null if the object bound is null.
        另请参见：
        Binding.getObject(),
Binding.getClassName(),
setClassName(java.lang.String)

      • getName

        public String getName()
        Retrieves the name of this binding. If isRelative() is true, this name is relative to the target context (which is named by the first parameter of the list()). If isRelative() is false, this name is a URL string.
        返回：
        The non-null name of this binding.
        另请参见：
        isRelative(), setName(java.lang.String)

      • setName

        public void setName(String name)
        Sets the name of this binding.
        参数：
        name - the non-null string to use as the name.
        另请参见：
        getName(), setRelative(boolean)

      • setClassName

        public void setClassName(String name)
        Sets the class name of this binding.
        参数：
        name - the possibly null string to use as the class name. If null, Binding.getClassName() will return the actual class name of the object in the binding. The class name will be null if the object bound is null.
        另请参见：
        getClassName(), Binding.getClassName()

      • isRelative

        public boolean isRelative()
        Determines whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
        返回：
        true if the name of this binding is relative to the target context; false if the name of this binding is a URL string.
        另请参见：
        setRelative(boolean), getName()

      • setRelative

        public void setRelative(boolean r)
        Sets whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
        参数：
        r - If true, the name of binding is relative to the target context; if false, the name of binding is a URL string.
        另请参见：
        isRelative(), setName(java.lang.String)

      • getNameInNamespace

        public String getNameInNamespace()
        Retrieves the full name of this binding. The full name is the absolute name of this binding within its own namespace. See Context.getNameInNamespace().

        In naming systems for which the notion of full name does not apply to this binding an UnsupportedOperationException is thrown. This exception is also thrown when a service provider written before the introduction of the method is in use.

        The string returned by this method is not a JNDI composite name and should not be passed directly to context methods.

        返回：
        The full name of this binding.
        抛出：
        UnsupportedOperationException - if the notion of full name does not apply to this binding in the naming system.
        从以下版本开始：
        1.5
        另请参见：
        setNameInNamespace(java.lang.String), getName()

      • setNameInNamespace

        public void setNameInNamespace(String fullName)
        Sets the full name of this binding. This method must be called to set the full name whenever a NameClassPair is created and a full name is applicable to this binding.

        Setting the full name to null, or not setting it at all, will cause getNameInNamespace() to throw an exception.

        参数：
        fullName - The full name to use.
        从以下版本开始：
        1.5
        另请参见：
        getNameInNamespace(), setName(java.lang.String)

      • toString

        public String toString()
        Generates the string representation of this name/class pair. The string representation consists of the name and class name separated by a colon (':'). The contents of this string is useful for debugging and is not meant to be interpreted programmatically.
        重载：
        toString in class Object
        返回：
        The string representation of this name/class pair.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.-atdn tnti pohie/tmn/iv.g.a=a"lgiaaP.EEai<


NameNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NameNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NameNotFoundException
  • 所有已实现的接口：
    Serializable

    public class NameNotFoundException
extends NamingException
    This exception is thrown when a component of the name cannot be resolved because it is not bound.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameNotFoundException()
      Constructs a new instance of NameNotFoundException.
      NameNotFoundException(String explanation)
      Constructs a new instance of NameNotFoundException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NameNotFoundException

        public NameNotFoundException(String explanation)
        Constructs a new instance of NameNotFoundException using the explanation supplied. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • NameNotFoundException

        public NameNotFoundException()
        Constructs a new instance of NameNotFoundException. all name resolution fields and explanation initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=D= MT=ET========<<toia>b


NameParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming

Interface NameParser

  • public interface NameParser
    This interface is used for parsing names from a hierarchical namespace. The NameParser contains knowledge of the syntactic information (like left-to-right orientation, name separator, etc.) needed to parse names. The equals() method, when used to compare two NameParsers, returns true if and only if they serve the same namespace.
    从以下版本开始：
    1.3
    另请参见：
    CompoundName, Name

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name parse(String name)
      Parses a name into its components.

    • 方法详细信息

      • parse

        Name parse(String name)
           throws NamingException
        Parses a name into its components.
        参数：
        name - The non-null string name to parse.
        返回：
        A non-null parsed form of the name using the naming convention of this parser.
        抛出：
        InvalidNameException - If name does not conform to syntax defined for the namespace.
        NamingException - If a naming exception was encountered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>ttllmllbeelbbhaffav=j/nwdahhblb)v


NamingEnumeration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming

Interface NamingEnumeration<T>

  • All Superinterfaces:
    Enumeration<T>

    public interface NamingEnumeration<T>
extends Enumeration<T>
    This interface is for enumerating lists returned by methods in the javax.naming and javax.naming.directory packages. It extends Enumeration to allow as exceptions to be thrown during the enumeration.

    When a method such as list(), listBindings(), or search() returns a NamingEnumeration, any exceptions encountered are reserved until all results have been returned. At the end of the enumeration, the exception is thrown (by hasMore());

    For example, if the list() is returning only a partial answer, the corresponding exception would be PartialResultException. list() would first return a NamingEnumeration. When the last of the results has been returned by the NamingEnumeration's next(), invoking hasMore() would result in PartialResultException being thrown.

    In another example, if a search() method was invoked with a specified size limit of 'n'. If the answer consists of more than 'n' results, search() would first return a NamingEnumeration. When the n'th result has been returned by invoking next() on the NamingEnumeration, a SizeLimitExceedException would then thrown when hasMore() is invoked.

    Note that if the program uses hasMoreElements() and nextElement() instead to iterate through the NamingEnumeration, because these methods cannot throw exceptions, no exception will be thrown. Instead, in the previous example, after the n'th result has been returned by nextElement(), invoking hasMoreElements() would return false.

    Note also that NoSuchElementException is thrown if the program invokes next() or nextElement() when there are no elements left in the enumeration. The program can always avoid this exception by using hasMore() and hasMoreElements() to check whether the end of the enumeration has been reached.

    If an exception is thrown during an enumeration, the enumeration becomes invalid. Subsequent invocation of any method on that enumeration will yield undefined results.

    从以下版本开始：
    1.3
    另请参见：
    Context.list(javax.naming.Name),
Context.listBindings(javax.naming.Name),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
Attributes.getAll(),
Attributes.getIDs(),
Attribute.getAll()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Closes this enumeration.
      boolean hasMore()
      Determines whether there are any more elements in the enumeration.
      T 下一个()
      Retrieves the next element in the enumeration.

      • 方法 - 继承于接口 java.util.Enumeration

        hasMoreElements, nextElement

    • 方法详细信息

      • 下一个

        T next()
       throws NamingException
        Retrieves the next element in the enumeration. This method allows naming exceptions encountered while retrieving the next element to be caught and handled by the application.

        Note that next() can also throw the runtime exception NoSuchElementException to indicate that the caller is attempting to enumerate beyond the end of the enumeration. This is different from a NamingException, which indicates that there was a problem in obtaining the next element, for example, due to a referral or server unavailability, etc.

        返回：
        The possibly null element in the enumeration. null is only valid for enumerations that can return null (e.g. Attribute.getAll() returns an enumeration of attribute values, and an attribute value can be null).
        抛出：
        NamingException - If a naming exception is encountered while attempting to retrieve the next element. See NamingException and its subclasses for the possible naming exceptions.
        NoSuchElementException - If attempting to get the next element when none is available.
        另请参见：
        Enumeration.nextElement()

      • hasMore

        boolean hasMore()
                throws NamingException
        Determines whether there are any more elements in the enumeration. This method allows naming exceptions encountered while determining whether there are more elements to be caught and handled by the application.
        返回：
        true if there is more in the enumeration ; false otherwise.
        抛出：
        NamingException - If a naming exception is encountered while attempting to determine whether there is another element in the enumeration. See NamingException and its subclasses for the possible naming exceptions.
        另请参见：
        Enumeration.hasMoreElements()

      • close

        void close()
           throws NamingException
        Closes this enumeration. After this method has been invoked on this enumeration, the enumeration becomes invalid and subsequent invocation of any of its methods will yield undefined results. This method is intended for aborting an enumeration to free up resources. If an enumeration proceeds to the end--that is, until hasMoreElements() or hasMore() returns false-- resources will be freed up automatically and there is no need to explicitly call close().

        This method indicates to the service provider that it is free to release resources associated with the enumeration, and can notify servers to cancel any outstanding requests. The close() method is a hint to implementations for managing their resources. Implementations are encouraged to use appropriate algorithms to manage their resources when client omits the close() calls.

        抛出：
        NamingException - If a naming exception is encountered while closing the enumeration.
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oldtnmanajvajjNsssc <>ah. / /lar


NamingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 NamingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    AttributeInUseException, AttributeModificationException, CannotProceedException, CommunicationException, ConfigurationException, ContextNotEmptyException, InsufficientResourcesException, InterruptedNamingException, InvalidAttributeIdentifierException, InvalidAttributesException, InvalidAttributeValueException, InvalidNameException, InvalidSearchControlsException, InvalidSearchFilterException, LimitExceededException, LinkException, NameAlreadyBoundException, NameNotFoundException, NamingSecurityException, NoInitialContextException, NoSuchAttributeException, NotContextException, OperationNotSupportedException, PartialResultException, ReferralException, SchemaViolationException, ServiceUnavailableException

    public class NamingException
extends Exception
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces. The nature of the failure is described by the name of the subclass. This exception captures the information pinpointing where the operation failed, such as where resolution last proceeded to.
    • Resolved Name. Portion of name that has been resolved.
    • Resolved Object. Object to which resolution of name proceeded.
    • Remaining Name. Portion of name that has not been resolved.
    • Explanation. Detail explaining why name resolution failed.
    • Root Exception. The exception that caused this naming exception to be thrown.
    null is an acceptable value for any of these fields. When null, it means that no such information has been recorded for that field.

    A NamingException instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single NamingException instance should lock the object.

    This exception has been retrofitted to conform to the general purpose exception-chaining mechanism. The root exception (or root cause) is the same object as the cause returned by the Throwable.getCause() method.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Name remainingName
      Contains the remaining name that has not been resolved yet.
      protected Name resolvedName
      Contains the part of the name that has been successfully resolved.
      protected Object resolvedObj
      Contains the object to which resolution of the part of the name was successful.
      protected Throwable rootException
      Contains the original exception that caused this NamingException to be thrown.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingException()
      Constructs a new NamingException.
      NamingException(String explanation)
      Constructs a new NamingException with an explanation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void appendRemainingComponent(String name)
      Add name as the last component in remaining name.
      void appendRemainingName(Name name)
      Add components from 'name' as the last components in remaining name.
      Throwable getCause()
      Returns the cause of this exception.
      String getExplanation()
      Retrieves the explanation associated with this exception.
      Name getRemainingName()
      Retrieves the remaining unresolved portion of the name.
      Name getResolvedName()
      Retrieves the leading portion of the name that was resolved successfully.
      Object getResolvedObj()
      Retrieves the object to which resolution was successful.
      Throwable getRootCause()
      Retrieves the root cause of this NamingException, if any.
      Throwable initCause(Throwable cause)
      Initializes the cause of this exception to the specified value.
      void setRemainingName(Name name)
      Sets the remaining name field of this exception.
      void setResolvedName(Name name)
      Sets the resolved name field of this exception.
      void setResolvedObj(Object obj)
      Sets the resolved object field of this exception.
      void setRootCause(Throwable e)
      Records the root cause of this NamingException.
      String toString()
      Generates the string representation of this exception.
      String toString(boolean detail)
      Generates the string representation in more detail.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • resolvedName

        protected Name resolvedName
        Contains the part of the name that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getResolvedName(), setResolvedName(javax.naming.Name)

      • resolvedObj

        protected Object resolvedObj
        Contains the object to which resolution of the part of the name was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
        另请参见：
        getResolvedObj(), setResolvedObj(java.lang.Object)

      • remainingName

        protected Name remainingName
        Contains the remaining name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get, set, "append" methods.
        另请参见：
        getRemainingName(),
setRemainingName(javax.naming.Name),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

      • rootException

        protected Throwable rootException
        Contains the original exception that caused this NamingException to be thrown. This field is set if there is additional information that could be obtained from the original exception, or if the original exception could not be mapped to a subclass of NamingException. Can be null.

        This field predates the general-purpose exception chaining facility. The initCause(Throwable) and getCause() methods are now the preferred means of accessing this information.

        另请参见：
        getRootCause(), setRootCause(Throwable), initCause(Throwable), getCause()

    • 构造方法详细信息

      • NamingException

        public NamingException(String explanation)
        Constructs a new NamingException with an explanation. All unspecified fields are set to null.
        参数：
        explanation - A possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • NamingException

        public NamingException()
        Constructs a new NamingException. All fields are set to null.

    • 方法详细信息

      • getResolvedName

        public Name getResolvedName()
        Retrieves the leading portion of the name that was resolved successfully.
        返回：
        The part of the name that was resolved successfully. It is a composite name. It can be null, which means the resolved name field has not been set.
        另请参见：
        getResolvedObj(), setResolvedName(javax.naming.Name)

      • getRemainingName

        public Name getRemainingName()
        Retrieves the remaining unresolved portion of the name.
        返回：
        The part of the name that has not been resolved. It is a composite name. It can be null, which means the remaining name field has not been set.
        另请参见：
        setRemainingName(javax.naming.Name),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

      • getResolvedObj

        public Object getResolvedObj()
        Retrieves the object to which resolution was successful. This is the object to which the resolved name is bound.
        返回：
        The possibly null object that was resolved so far. null means that the resolved object field has not been set.
        另请参见：
        getResolvedName(), setResolvedObj(java.lang.Object)

      • getExplanation

        public String getExplanation()
        Retrieves the explanation associated with this exception.
        返回：
        The possibly null detail string explaining more about this exception. If null, it means there is no detail message for this exception.
        另请参见：
        Throwable.getMessage()

      • setResolvedName

        public void setResolvedName(Name name)
        Sets the resolved name field of this exception.

        name is a composite name. If the intent is to set this field using a compound name or string, you must "stringify" the compound name, and create a composite name with a single component using the string. You can then invoke this method using the resulting composite name.

        A copy of name is made and stored. Subsequent changes to name does not affect the copy in this NamingException and vice versa.

        参数：
        name - The possibly null name to set resolved name to. If null, it sets the resolved name field to null.
        另请参见：
        getResolvedName()

      • setRemainingName

        public void setRemainingName(Name name)
        Sets the remaining name field of this exception.

        name is a composite name. If the intent is to set this field using a compound name or string, you must "stringify" the compound name, and create a composite name with a single component using the string. You can then invoke this method using the resulting composite name.

        A copy of name is made and stored. Subsequent changes to name does not affect the copy in this NamingException and vice versa.

        参数：
        name - The possibly null name to set remaining name to. If null, it sets the remaining name field to null.
        另请参见：
        getRemainingName(),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

      • setResolvedObj

        public void setResolvedObj(Object obj)
        Sets the resolved object field of this exception.
        参数：
        obj - The possibly null object to set resolved object to. If null, the resolved object field is set to null.
        另请参见：
        getResolvedObj()

      • appendRemainingComponent

        public void appendRemainingComponent(String name)
        Add name as the last component in remaining name.
        参数：
        name - The component to add. If name is null, this method does not do anything.
        另请参见：
        setRemainingName(javax.naming.Name),
getRemainingName(),
appendRemainingName(javax.naming.Name)

      • appendRemainingName

        public void appendRemainingName(Name name)
        Add components from 'name' as the last components in remaining name.

        name is a composite name. If the intent is to append a compound name, you should "stringify" the compound name then invoke the overloaded form that accepts a String parameter.

        Subsequent changes to name does not affect the remaining name field in this NamingException and vice versa.

        参数：
        name - The possibly null name containing ordered components to add. If name is null, this method does not do anything.
        另请参见：
        setRemainingName(javax.naming.Name),
getRemainingName(),
appendRemainingComponent(java.lang.String)

      • getRootCause

        public Throwable getRootCause()
        Retrieves the root cause of this NamingException, if any. The root cause of a naming exception is used when the service provider wants to indicate to the caller a non-naming related exception but at the same time wants to use the NamingException structure to indicate how far the naming operation proceeded.

        This method predates the general-purpose exception chaining facility. The getCause() method is now the preferred means of obtaining this information.

        返回：
        The possibly null exception that caused this naming exception. If null, it means no root cause has been set for this naming exception.
        另请参见：
        setRootCause(java.lang.Throwable), rootException, getCause()

      • setRootCause

        public void setRootCause(Throwable e)
        Records the root cause of this NamingException. If e is this, this method does not do anything.

        This method predates the general-purpose exception chaining facility. The initCause(Throwable) method is now the preferred means of recording this information.

        参数：
        e - The possibly null exception that caused the naming operation to fail. If null, it means this naming exception has no root cause.
        另请参见：
        getRootCause(), rootException, initCause(java.lang.Throwable)

      • getCause

        public Throwable getCause()
        Returns the cause of this exception. The cause is the throwable that caused this naming exception to be thrown. Returns null if the cause is nonexistent or unknown.
        重载：
        getCause in class Throwable
        返回：
        the cause of this exception, or null if the cause is nonexistent or unknown.
        从以下版本开始：
        1.4
        另请参见：
        initCause(Throwable)

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause of this exception to the specified value. The cause is the throwable that caused this naming exception to be thrown.

        This method may be called at most once.

        重载：
        initCause in class Throwable
        参数：
        cause - the cause, which is saved for later retrieval by the getCause() method. A null value indicates that the cause is nonexistent or unknown.
        返回：
        a reference to this NamingException instance.
        抛出：
        IllegalArgumentException - if cause is this exception. (A throwable cannot be its own cause.)
        IllegalStateException - if this method has already been called on this exception.
        从以下版本开始：
        1.4
        另请参见：
        getCause()

      • toString

        public String toString()
        Generates the string representation of this exception. The string representation consists of this exception's class name, its detailed message, and if it has a root cause, the string representation of the root cause exception, followed by the remaining name (if it is not null). This string is used for debugging and not meant to be interpreted programmatically.
        重载：
        toString in class Throwable
        返回：
        The non-null string containing the string representation of this exception.

      • toString

        public String toString(boolean detail)
        Generates the string representation in more detail. This string representation consists of the information returned by the toString() that takes no parameters, plus the string representation of the resolved object (if it is not null). This string is used for debugging and not meant to be interpreted programmatically.
        参数：
        detail - If true, include details about the resolved object in addition to the other information.
        返回：
        The non-null string containing the string representation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NamingSecurityException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NamingSecurityException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NamingSecurityException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    AuthenticationException, AuthenticationNotSupportedException, NoPermissionException

    public abstract class NamingSecurityException
extends NamingException
    This is the superclass of security-related exceptions thrown by operations in the Context and DirContext interfaces. The nature of the failure is described by the name of the subclass.

    If the program wants to handle this exception in particular, it should catch NamingSecurityException explicitly before attempting to catch NamingException. A program might want to do this, for example, if it wants to treat security-related exceptions specially from other sorts of naming exception.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingSecurityException()
      Constructs a new instance of NamingSecurityException.
      NamingSecurityException(String explanation)
      Constructs a new instance of NamingSecurityException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NamingSecurityException

        public NamingSecurityException(String explanation)
        Constructs a new instance of NamingSecurityException using the explanation supplied. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • NamingSecurityException

        public NamingSecurityException()
        Constructs a new instance of NamingSecurityException. All fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lba//dvtdvi>>viiycee>e


NoInitialContextException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NoInitialContextException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NoInitialContextException
  • 所有已实现的接口：
    Serializable

    public class NoInitialContextException
extends NamingException
    This exception is thrown when no initial context implementation can be created. The policy of how an initial context implementation is selected is described in the documentation of the InitialContext class.

    This exception can be thrown during any interaction with the InitialContext, not only when the InitialContext is constructed. For example, the implementation of the initial context might lazily retrieve the context only when actual methods are invoked on it. The application should not have any dependency on when the existence of an initial context is determined.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    InitialContext, InitialDirContext, NamingManager.getInitialContext(java.util.Hashtable), NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoInitialContextException()
      Constructs an instance of NoInitialContextException.
      NoInitialContextException(String explanation)
      Constructs an instance of NoInitialContextException with an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoInitialContextException

        public NoInitialContextException()
        Constructs an instance of NoInitialContextException. All fields are initialized to null.

      • NoInitialContextException

        public NoInitialContextException(String explanation)
        Constructs an instance of NoInitialContextException with an explanation. All other fields are initialized to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cElibolorasssaau>""esa.llrid


NoPermissionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NoPermissionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NamingSecurityException
            • javax.naming.NoPermissionException
  • 所有已实现的接口：
    Serializable

    public class NoPermissionException
extends NamingSecurityException
    This exception is thrown when attempting to perform an operation for which the client has no permission. The access control/permission model is dictated by the directory/naming server.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoPermissionException()
      Constructs a new instance of NoPermissionException.
      NoPermissionException(String explanation)
      Constructs a new instance of NoPermissionException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoPermissionException

        public NoPermissionException(String explanation)
        Constructs a new instance of NoPermissionException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.

      • NoPermissionException

        public NoPermissionException()
        Constructs a new instance of NoPermissionException. All fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iinasaaamav.ami.a_dd邯is�;<l&i >n"譺


NotContextException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 NotContextException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.NotContextException
  • 所有已实现的接口：
    Serializable

    public class NotContextException
extends NamingException
    This exception is thrown when a naming operation proceeds to a point where a context is required to continue the operation, but the resolved object is not a context. For example, Context.destroy() requires that the named object be a context. If it is not, NotContextException is thrown. Another example is a non-context being encountered during the resolution phase of the Context methods.

    It is also thrown when a particular subtype of context is required, such as a DirContext, and the resolved object is a context but not of the required subtype.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context.destroySubcontext(javax.naming.Name), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotContextException()
      Constructs a new instance of NotContextException.
      NotContextException(String explanation)
      Constructs a new instance of NotContextException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NotContextException

        public NotContextException(String explanation)
        Constructs a new instance of NotContextException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • NotContextException

        public NotContextException()
        Constructs a new instance of NotContextException. All fields default to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i< p >o- -> a-


OperationNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 OperationNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.OperationNotSupportedException
  • 所有已实现的接口：
    Serializable

    public class OperationNotSupportedException
extends NamingException
    This exception is thrown when a context implementation does not support the operation being invoked. For example, if a server does not support the Context.bind() method it would throw OperationNotSupportedException when the bind() method is invoked on it.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      OperationNotSupportedException()
      Constructs a new instance of OperationNotSupportedException.
      OperationNotSupportedException(String explanation)
      Constructs a new instance of OperationNotSupportedException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OperationNotSupportedException

        public OperationNotSupportedException()
        Constructs a new instance of OperationNotSupportedException. All fields default to null.

      • OperationNotSupportedException

        public OperationNotSupportedException(String explanation)
        Constructs a new instance of OperationNotSupportedException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,a ;x;&;3;9193,0 l 1,11r,rll羠篇∶渌Or眕


PartialResultException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 PartialResultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.PartialResultException
  • 所有已实现的接口：
    Serializable

    public class PartialResultException
extends NamingException
    This exception is thrown to indicate that the result being returned or returned so far is partial, and that the operation cannot be completed. For example, when listing a context, this exception indicates that returned results only represents some of the bindings in the context.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      PartialResultException()
      Constructs a new instance of PartialResultException.
      PartialResultException(String explanation)
      Constructs a new instance of the exception using the explanation message specified.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PartialResultException

        public PartialResultException(String explanation)
        Constructs a new instance of the exception using the explanation message specified. All other fields default to null.
        参数：
        explanation - Possibly null detail explaining the exception.

      • PartialResultException

        public PartialResultException()
        Constructs a new instance of PartialResultException. All fields default to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eod<>g.ita tame>


RefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 RefAddr

  • java.lang.Object
    • javax.naming.RefAddr
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    BinaryRefAddr, StringRefAddr

    public abstract class RefAddr
extends Object
implements Serializable
    This class represents the address of a communications end-point. It consists of a type that describes the communication mechanism and an address contents determined by an RefAddr subclass.

    For example, an address type could be "BSD Printer Address", which specifies that it is an address to be used with the BSD printing protocol. Its contents could be the machine name identifying the location of the printer server that understands this protocol.

    A RefAddr is contained within a Reference.

    RefAddr is an abstract class. Concrete implementations of it determine its synchronization properties.

    从以下版本开始：
    1.3
    另请参见：
    Reference, LinkRef, StringRefAddr, BinaryRefAddr, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected String addrType
      Contains the type of this address.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected RefAddr(String addrType)
      Constructs a new instance of RefAddr using its address type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Determines whether obj is equal to this RefAddr.
      abstract Object getContent()
      Retrieves the contents of this address.
      String getType()
      Retrieves the address type of this address.
      int hashCode()
      Computes the hash code of this address using its address type and contents.
      String toString()
      Generates the string representation of this address.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • addrType

        protected String addrType
        Contains the type of this address.

    • 构造方法详细信息

      • RefAddr

        protected RefAddr(String addrType)
        Constructs a new instance of RefAddr using its address type.
        参数：
        addrType - A non-null string describing the type of the address.

    • 方法详细信息

      • getType

        public String getType()
        Retrieves the address type of this address.
        返回：
        The non-null address type of this address.

      • getContent

        public abstract Object getContent()
        Retrieves the contents of this address.
        返回：
        The possibly null address contents.

      • equals

        public boolean equals(Object obj)
        Determines whether obj is equal to this RefAddr.

        obj is equal to this RefAddr all of these conditions are true

          non-null
        • instance of RefAddr
        • obj has the same address type as this RefAddr (using String.compareTo())
        • both obj and this RefAddr's contents are null or they are equal (using the equals() test).
        重载：
        equals in class Object
        参数：
        obj - possibly null obj to check.
        返回：
        true if obj is equal to this refaddr; false otherwise.
        另请参见：
        getContent(), getType()

      • hashCode

        public int hashCode()
        Computes the hash code of this address using its address type and contents. The hash code is the sum of the hash code of the address type and the hash code of the address contents.
        重载：
        hashCode in class Object
        返回：
        The hash code of this address as an int.
        另请参见：
        Object.hashCode()

      • toString

        public String toString()
        Generates the string representation of this address. The string consists of the address's type and contents with labels. This representation is intended for display only and not to be parsed.
        重载：
        toString in class Object
        返回：
        The non-null string representation of this address.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l嚵崃鋏霜其迷Ａl话�)鋋 1 a<萷g....< 来9>


Reference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 Reference

  • java.lang.Object
    • javax.naming.Reference
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    LinkRef

    public class Reference
extends Object
implements Cloneable, Serializable
    This class represents a reference to an object that is found outside of the naming/directory system.

    Reference provides a way of recording address information about objects which themselves are not directly bound to the naming/directory system.

    A Reference consists of an ordered list of addresses and class information about the object being referenced. Each address in the list identifies a communications endpoint for the same conceptual object. The "communications endpoint" is information that indicates how to contact the object. It could be, for example, a network address, a location in memory on the local machine, another process on the same machine, etc. The order of the addresses in the list may be of significance to object factories that interpret the reference.

    Multiple addresses may arise for various reasons, such as replication or the object offering interfaces over more than one communication mechanism. The addresses are indexed starting with zero.

    A Reference also contains information to assist in creating an instance of the object to which this Reference refers. It contains the class name of that object, and the class name and location of the factory to be used to create the object. The class factory location is a space-separated list of URLs representing the class path used to load the factory. When the factory class (or any class or resource upon which it depends) needs to be loaded, each URL is used (in order) to attempt to load the class.

    A Reference instance is not synchronized against concurrent access by multiple threads. Threads that need to access a single Reference concurrently should synchronize amongst themselves and provide the necessary locking.

    从以下版本开始：
    1.3
    另请参见：
    RefAddr, StringRefAddr, BinaryRefAddr, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector<RefAddr> addrs
      Contains the addresses contained in this Reference.
      protected String classFactory
      Contains the name of the factory class for creating an instance of the object to which this Reference refers.
      protected String classFactoryLocation
      Contains the location of the factory class.
      protected String className
      Contains the fully-qualified name of the class of the object to which this Reference refers.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Reference(String className)
      Constructs a new reference for an object with class name 'className'.
      Reference(String className, RefAddr addr)
      Constructs a new reference for an object with class name 'className' and an address.
      Reference(String className, RefAddr addr, String factory, String factoryLocation)
      Constructs a new reference for an object with class name 'className', the class name and location of the object's factory, and the address for the object.
      Reference(String className, String factory, String factoryLocation)
      Constructs a new reference for an object with class name 'className', and the class name and location of the object's factory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int posn, RefAddr addr)
      Adds an address to the list of addresses at index posn.
      void add(RefAddr addr)
      Adds an address to the end of the list of addresses.
      void clear()
      Deletes all addresses from this reference.
      Object clone()
      Makes a copy of this reference using its class name list of addresses, class factory name and class factory location.
      boolean equals(Object obj)
      Determines whether obj is a reference with the same addresses (in same order) as this reference.
      RefAddr get(int posn)
      Retrieves the address at index posn.
      RefAddr get(String addrType)
      Retrieves the first address that has the address type 'addrType'.
      Enumeration<RefAddr> getAll()
      Retrieves an enumeration of the addresses in this reference.
      String getClassName()
      Retrieves the class name of the object to which this reference refers.
      String getFactoryClassLocation()
      Retrieves the location of the factory of the object to which this reference refers.
      String getFactoryClassName()
      Retrieves the class name of the factory of the object to which this reference refers.
      int hashCode()
      Computes the hash code of this reference.
      Object remove(int posn)
      Deletes the address at index posn from the list of addresses.
      int size()
      Retrieves the number of addresses in this reference.
      String toString()
      Generates the string representation of this reference.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • className

        protected String className
        Contains the fully-qualified name of the class of the object to which this Reference refers.
        另请参见：
        Class.getName()

      • addrs

        protected Vector<RefAddr> addrs
        Contains the addresses contained in this Reference. Initialized by constructor.

      • classFactory

        protected String classFactory
        Contains the name of the factory class for creating an instance of the object to which this Reference refers. Initialized to null.

      • classFactoryLocation

        protected String classFactoryLocation
        Contains the location of the factory class. Initialized to null.

    • 构造方法详细信息

      • Reference

        public Reference(String className)
        Constructs a new reference for an object with class name 'className'. Class factory and class factory location are set to null. The newly created reference contains zero addresses.
        参数：
        className - The non-null class name of the object to which this reference refers.

      • Reference

        public Reference(String className,
         RefAddr addr)
        Constructs a new reference for an object with class name 'className' and an address. Class factory and class factory location are set to null.
        参数：
        className - The non-null class name of the object to which this reference refers.
        addr - The non-null address of the object.

      • Reference

        public Reference(String className,
         String factory,
         String factoryLocation)
        Constructs a new reference for an object with class name 'className', and the class name and location of the object's factory.
        参数：
        className - The non-null class name of the object to which this reference refers.
        factory - The possibly null class name of the object's factory.
        factoryLocation - The possibly null location from which to load the factory (e.g. URL)
        另请参见：
        ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • Reference

        public Reference(String className,
         RefAddr addr,
         String factory,
         String factoryLocation)
        Constructs a new reference for an object with class name 'className', the class name and location of the object's factory, and the address for the object.
        参数：
        className - The non-null class name of the object to which this reference refers.
        factory - The possibly null class name of the object's factory.
        factoryLocation - The possibly null location from which to load the factory (e.g. URL)
        addr - The non-null address of the object.
        另请参见：
        ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

    • 方法详细信息

      • getClassName

        public String getClassName()
        Retrieves the class name of the object to which this reference refers.
        返回：
        The non-null fully-qualified class name of the object. (e.g. "java.lang.String")

      • getFactoryClassName

        public String getFactoryClassName()
        Retrieves the class name of the factory of the object to which this reference refers.
        返回：
        The possibly null fully-qualified class name of the factory. (e.g. "java.lang.String")

      • getFactoryClassLocation

        public String getFactoryClassLocation()
        Retrieves the location of the factory of the object to which this reference refers. If it is a codebase, then it is an ordered list of URLs, separated by spaces, listing locations from where the factory class definition should be loaded.
        返回：
        The possibly null string containing the location for loading in the factory's class.

      • get

        public RefAddr get(String addrType)
        Retrieves the first address that has the address type 'addrType'. String.compareTo() is used to test the equality of the address types.
        参数：
        addrType - The non-null address type for which to find the address.
        返回：
        The address in this reference with address type 'addrType; null if no such address exist.

      • get

        public RefAddr get(int posn)
        Retrieves the address at index posn.
        参数：
        posn - The index of the address to retrieve.
        返回：
        The address at the 0-based index posn. It must be in the range [0,getAddressCount()).
        抛出：
        ArrayIndexOutOfBoundsException - If posn not in the specified range.

      • getAll

        public Enumeration<RefAddr> getAll()
        Retrieves an enumeration of the addresses in this reference. When addresses are added, changed or removed from this reference, its effects on this enumeration are undefined.
        返回：
        An non-null enumeration of the addresses (RefAddr) in this reference. If this reference has zero addresses, an enumeration with zero elements is returned.

      • size

        public int size()
        Retrieves the number of addresses in this reference.
        返回：
        The nonnegative number of addresses in this reference.

      • add

        public void add(RefAddr addr)
        Adds an address to the end of the list of addresses.
        参数：
        addr - The non-null address to add.

      • add

        public void add(int posn,
       RefAddr addr)
        Adds an address to the list of addresses at index posn. All addresses at index posn or greater are shifted up the list by one (away from index 0).
        参数：
        posn - The 0-based index of the list to insert addr.
        addr - The non-null address to add.
        抛出：
        ArrayIndexOutOfBoundsException - If posn not in the specified range.

      • remove

        public Object remove(int posn)
        Deletes the address at index posn from the list of addresses. All addresses at index greater than posn are shifted down the list by one (towards index 0).
        参数：
        posn - The 0-based index of in address to delete.
        返回：
        The address removed.
        抛出：
        ArrayIndexOutOfBoundsException - If posn not in the specified range.

      • clear

        public void clear()
        Deletes all addresses from this reference.

      • equals

        public boolean equals(Object obj)
        Determines whether obj is a reference with the same addresses (in same order) as this reference. The addresses are checked using RefAddr.equals(). In addition to having the same addresses, the Reference also needs to have the same class name as this reference. The class factory and class factory location are not checked. If obj is null or not an instance of Reference, null is returned.
        重载：
        equals in class Object
        参数：
        obj - The possibly null object to check.
        返回：
        true if obj is equal to this reference; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Computes the hash code of this reference. The hash code is the sum of the hash code of its addresses.
        重载：
        hashCode in class Object
        返回：
        A hash code of this reference as an int.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Generates the string representation of this reference. The string consists of the class name to which this reference refers, and the string representation of each of its addresses. This representation is intended for display only and not to be parsed.
        重载：
        toString in class Object
        返回：
        The non-null string representation of this reference.

      • clone

        public Object clone()
        Makes a copy of this reference using its class name list of addresses, class factory name and class factory location. Changes to the newly created copy does not affect this Reference and vice versa.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u


Referenceable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming

Interface Referenceable

  • public interface Referenceable
    This interface is implemented by an object that can provide a Reference to itself.

    A Reference represents a way of recording address information about objects which themselves are not directly bound to the naming system. Such objects can implement the Referenceable interface as a way for programs that use that object to determine what its Reference is. For example, when binding a object, if an object implements the Referenceable interface, getReference() can be invoked on the object to get its Reference to use for binding.

    从以下版本开始：
    1.3
    另请参见：
    Context.bind(javax.naming.Name, java.lang.Object), NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), Reference

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Reference getReference()
      Retrieves the Reference of this object.

    • 方法详细信息

      • getReference

        Reference getReference()
                       throws NamingException
        Retrieves the Reference of this object.
        返回：
        The non-null Reference of this object.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=m=ul>>i>>e >ee/ <


ReferralException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 ReferralException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ReferralException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    LdapReferralException

    public abstract class ReferralException
extends NamingException
    This abstract class is used to represent a referral exception, which is generated in response to a referral such as that returned by LDAP v3 servers.

    A service provider provides a subclass of ReferralException by providing implementations for getReferralInfo() and getReferralContext() (and appropriate constructors and/or corresponding "set" methods).

    The following code sample shows how ReferralException can be used.

          while (true) {
          try {
              bindings = ctx.listBindings(name);
              while (bindings.hasMore()) {
                  b = bindings.next();
                  ...
              }
              break;
          } catch (ReferralException e) {
              ctx = e.getReferralContext();
          }
      }

    ReferralException is an abstract class. Concrete implementations determine its synchronization and serialization properties.

    An environment parameter passed to the getReferralContext() method is owned by the caller. The service provider will not modify the object or keep a reference to it, but may keep a reference to a clone of it.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ReferralException()
      Constructs a new instance of ReferralException.
      protected ReferralException(String explanation)
      Constructs a new instance of ReferralException using the explanation supplied.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Context getReferralContext()
      Retrieves the context at which to continue the method.
      abstract Context getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties.
      abstract Object getReferralInfo()
      Retrieves information (such as URLs) related to this referral.
      abstract void retryReferral()
      Retries the referral currently being processed.
      abstract boolean skipReferral()
      Discards the referral about to be processed.

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ReferralException

        protected ReferralException(String explanation)
        Constructs a new instance of ReferralException using the explanation supplied. All other fields are set to null.
        参数：
        explanation - Additional detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()

      • ReferralException

        protected ReferralException()
        Constructs a new instance of ReferralException. All fields are set to null.

    • 方法详细信息

      • getReferralInfo

        public abstract Object getReferralInfo()
        Retrieves information (such as URLs) related to this referral. The program may examine or display this information to the user to determine whether to continue with the referral, or to determine additional information needs to be supplied in order to continue with the referral.
        返回：
        Non-null referral information related to this referral.

      • getReferralContext

        public abstract Context getReferralContext()
                                    throws NamingException
        Retrieves the context at which to continue the method. Regardless of whether a referral is encountered directly during a context operation, or indirectly, for example, during a search enumeration, the referral exception should provide a context at which to continue the operation. The referral context is created using the environment properties of the context that threw the ReferralException.

        To continue the operation, the client program should re-invoke the method using the same arguments as the original invocation.

        返回：
        The non-null context at which to continue the method.
        抛出：
        NamingException - If a naming exception was encountered. Call either retryReferral() or skipReferral() to continue processing referrals.

      • getReferralContext

        public abstract Context getReferralContext(Hashtable<?,?> env)
                                    throws NamingException
        Retrieves the context at which to continue the method using environment properties. Regardless of whether a referral is encountered directly during a context operation, or indirectly, for example, during a search enumeration, the referral exception should provide a context at which to continue the operation.

        The referral context is created using env as its environment properties. This method should be used instead of the no-arg overloaded form when the caller needs to use different environment properties for the referral context. It might need to do this, for example, when it needs to supply different authentication information to the referred server in order to create the referral context.

        To continue the operation, the client program should re-invoke the method using the same arguments as the original invocation.

        参数：
        env - The possibly null environment to use when retrieving the referral context. If null, no environment properties will be used.
        返回：
        The non-null context at which to continue the method.
        抛出：
        NamingException - If a naming exception was encountered. Call either retryReferral() or skipReferral() to continue processing referrals.

      • skipReferral

        public abstract boolean skipReferral()
        Discards the referral about to be processed. A call to this method should be followed by a call to getReferralContext to allow the processing of other referrals to continue. The following code fragment shows a typical usage pattern.

          } catch (ReferralException e) {
      if (!shallIFollow(e.getReferralInfo())) {
          if (!e.skipReferral()) {
              return;
          }
      }
      ctx = e.getReferralContext();
  }
        返回：
        true If more referral processing is pending; false otherwise.

      • retryReferral

        public abstract void retryReferral()
        Retries the referral currently being processed. A call to this method should be followed by a call to getReferralContext to allow the current referral to be retried. The following code fragment shows a typical usage pattern.

          } catch (ReferralException e) {
      while (true) {
          try {
              ctx = e.getReferralContext(env);
              break;
          } catch (NamingException ne) {
              if (! shallIRetry()) {
                  return;
              }
              // modify environment properties (env), if necessary
              e.retryReferral();
          }
      }
  }
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vc vtVini > m


ServiceUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 ServiceUnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ServiceUnavailableException
  • 所有已实现的接口：
    Serializable

    public class ServiceUnavailableException
extends NamingException
    This exception is thrown when attempting to communicate with a directory or naming service and that service is not available. It might be unavailable for different reasons. For example, the server might be too busy to service the request, or the server might not be registered to service any requests, etc.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceUnavailableException()
      Constructs a new instance of ServiceUnavailableException.
      ServiceUnavailableException(String explanation)
      Constructs a new instance of ServiceUnavailableException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ServiceUnavailableException

        public ServiceUnavailableException(String explanation)
        Constructs a new instance of ServiceUnavailableException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • ServiceUnavailableException

        public ServiceUnavailableException()
        Constructs a new instance of ServiceUnavailableException. All fields default to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a o(en(ecppeccre<>h.sge/.nca


SizeLimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 SizeLimitExceededException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
  • 所有已实现的接口：
    Serializable

    public class SizeLimitExceededException
extends LimitExceededException
    This exception is thrown when a method produces a result that exceeds a size-related limit. This can happen, for example, if the result contains more objects than the user requested, or when the size of the result exceeds some implementation-specific limit.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      SizeLimitExceededException()
      Constructs a new instance of SizeLimitExceededException.
      SizeLimitExceededException(String explanation)
      Constructs a new instance of SizeLimitExceededException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SizeLimitExceededException

        public SizeLimitExceededException()
        Constructs a new instance of SizeLimitExceededException. All fields default to null.

      • SizeLimitExceededException

        public SizeLimitExceededException(String explanation)
        Constructs a new instance of SizeLimitExceededException using an explanation. All other fields default to null.
        参数：
        explanation - Possibly null detail about this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&&r1;1s1s1boo/<>/a>/


StringRefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming

类 StringRefAddr

  • java.lang.Object
    • javax.naming.RefAddr
      • javax.naming.StringRefAddr
  • 所有已实现的接口：
    Serializable

    public class StringRefAddr
extends RefAddr
    This class represents the string form of the address of a communications end-point. It consists of a type that describes the communication mechanism and a string contents specific to that communication mechanism. The format and interpretation of the address type and the contents of the address are based on the agreement of three parties: the client that uses the address, the object/server that can be reached using the address, and the administrator or program that creates the address.

    An example of a string reference address is a host name. Another example of a string reference address is a URL.

    A string reference address is immutable: once created, it cannot be changed. Multithreaded access to a single StringRefAddr need not be synchronized.

    从以下版本开始：
    1.3
    另请参见：
    RefAddr, BinaryRefAddr, Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.RefAddr

        addrType

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringRefAddr(String addrType, String addr)
      Constructs a new instance of StringRefAddr using its address type and contents.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getContent()
      Retrieves the contents of this address.

      • 方法 - 继承于类 javax.naming.RefAddr

        equals, getType, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StringRefAddr

        public StringRefAddr(String addrType,
             String addr)
        Constructs a new instance of StringRefAddr using its address type and contents.
        参数：
        addrType - A non-null string describing the type of the address.
        addr - The possibly null contents of the address in the form of a string.

    • 方法详细信息

      • getContent

        public Object getContent()
        Retrieves the contents of this address. The result is a string.
        指定者：
        getContent in class RefAddr
        返回：
        The possibly null address contents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=sa ataaa"llasslissLzft=miidietcxei=fz=hltc>


TimeLimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming

类 TimeLimitExceededException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.LimitExceededException
            • javax.naming.TimeLimitExceededException
  • 所有已实现的接口：
    Serializable

    public class TimeLimitExceededException
extends LimitExceededException
    This exception is thrown when a method does not terminate within the specified time limit. This can happen, for example, if the user specifies that the method should take no longer than 10 seconds, and the method fails to complete with 10 seconds.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      TimeLimitExceededException()
      Constructs a new instance of TimeLimitExceededException.
      TimeLimitExceededException(String explanation)
      Constructs a new instance of TimeLimitExceededException using the argument supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TimeLimitExceededException

        public TimeLimitExceededException()
        Constructs a new instance of TimeLimitExceededException. All fields default to null.

      • TimeLimitExceededException

        public TimeLimitExceededException(String explanation)
        Constructs a new instance of TimeLimitExceededException using the argument supplied.
        参数：
        explanation - possibly null detail about this exception.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,p , ,t,1,3211,re� tlc2糰间湓鲠※Ｔ卑诵


Uses of Package javax.naming

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.naming

  • Packages that use javax.naming
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
  • Classes in javax.naming used by javax.naming
    类与描述
    Binding
    This class represents a name-to-object binding found in a context.
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    InvalidNameException
    This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
    LimitExceededException
    This exception is thrown when a method terminates abnormally due to a user or system specified limit.
    LinkException
    This exception is used to describe problems encounter while resolving links.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NameClassPair
    This class represents the object name and class name pair of a binding found in a context.
    NameParser
    This interface is used for parsing names from a hierarchical namespace.
    NamingEnumeration
    This interface is for enumerating lists returned by methods in the javax.naming and javax.naming.directory packages.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
    NamingSecurityException
    This is the superclass of security-related exceptions thrown by operations in the Context and DirContext interfaces.
    RefAddr
    This class represents the address of a communications end-point.
    Reference
    This class represents a reference to an object that is found outside of the naming/directory system.
  • Classes in javax.naming used by javax.naming.directory
    类与描述
    Binding
    This class represents a name-to-object binding found in a context.
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    InitialContext
    This class is the starting context for performing naming operations.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NameClassPair
    This class represents the object name and class name pair of a binding found in a context.
    NamingEnumeration
    This interface is for enumerating lists returned by methods in the javax.naming and javax.naming.directory packages.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
  • Classes in javax.naming used by javax.naming.event
    类与描述
    Binding
    This class represents a name-to-object binding found in a context.
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
  • Classes in javax.naming used by javax.naming.ldap
    类与描述
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    InitialContext
    This class is the starting context for performing naming operations.
    InvalidNameException
    This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
    ReferralException
    This abstract class is used to represent a referral exception, which is generated in response to a referral such as that returned by LDAP v3 servers.
  • Classes in javax.naming used by javax.naming.spi
    类与描述
    CannotProceedException
    This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further.
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
    Name
    The Name interface represents a generic name -- an ordered sequence of components.
    NamingException
    This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
  • Classes in javax.naming used by javax.sql.rowset.spi
    类与描述
    Context
    This interface represents a naming context, which consists of a set of name-to-object bindings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i,Ce


Uses of Class javax.naming.AuthenticationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.AuthenticationException

No usage of javax.naming.AuthenticationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

avdr=


Uses of Class javax.naming.AuthenticationNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.AuthenticationNotSupportedException

No usage of javax.naming.AuthenticationNotSupportedException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a4 pl�.�.yt"!n&sks�


Uses of Class javax.naming.BinaryRefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.BinaryRefAddr

No usage of javax.naming.BinaryRefAddr
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r1kmfe etm,ors .跆宥�/


Uses of Class javax.naming.Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.Binding

  • Packages that use Binding
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.

    • Uses of Binding in javax.naming

      Methods in javax.naming that return types with arguments of type Binding
      修饰符与类型 | 方法与描述
      NamingEnumeration<Binding> Context.listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
      NamingEnumeration<Binding> Context.listBindings(String name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(String name)

    • Uses of Binding in javax.naming.directory

      Subclasses of Binding in javax.naming.directory
      修饰符与类型 类与描述
      class  SearchResult
      This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.

    • Uses of Binding in javax.naming.event

      Fields in javax.naming.event declared as Binding
      修饰符与类型 字段与描述
      protected Binding NamingEvent.newBinding
      Contains information about the object after the change.
      protected Binding NamingEvent.oldBinding
      Contains information about the object before the change.
      Methods in javax.naming.event that return Binding
      修饰符与类型 方法与描述
      Binding NamingEvent.getNewBinding()
      Retrieves the binding of the object after the change.
      Binding NamingEvent.getOldBinding()
      Retrieves the binding of the object before the change.
      Constructors in javax.naming.event with parameters of type Binding
      构造方法与描述
      NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
      Constructs an instance of NamingEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fta c/rf;ti雘b>c owj輆


Uses of Class javax.naming.CannotProceedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.CannotProceedException

  • Packages that use CannotProceedException
    软件包 描述
    javax.naming.spi

    • Uses of CannotProceedException in javax.naming.spi

      Methods in javax.naming.spi with parameters of type CannotProceedException
      修饰符与类型 方法与描述
      static Context NamingManager.getContinuationContext(CannotProceedException cpe)
      Creates a context in which to continue a context operation.
      static DirContext DirectoryManager.getContinuationDirContext(CannotProceedException cpe)
      Creates a context in which to continue a DirContext operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sr=>Col"=aaaa><<


Uses of Class javax.naming.CommunicationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.CommunicationException

No usage of javax.naming.CommunicationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ptix./j./..."


Uses of Class javax.naming.CompositeName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.CompositeName

No usage of javax.naming.CompositeName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆�<�/


Uses of Class javax.naming.CompoundName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.CompoundName

No usage of javax.naming.CompoundName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>> t>�>l六吮x楔六眅


Uses of Class javax.naming.ConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ConfigurationException

No usage of javax.naming.ConfigurationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. tl耯revIJ.c >a薶L"


Uses of Class javax.naming.ContextNotEmptyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ContextNotEmptyException

No usage of javax.naming.ContextNotEmptyException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c ooassht >i//n ets


Uses of Class javax.naming.InitialContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.InitialContext

  • Packages that use InitialContext
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of InitialContext in javax.naming.directory

      Subclasses of InitialContext in javax.naming.directory
      修饰符与类型 类与描述
      class  InitialDirContext
      This class is the starting context for performing directory operations.

    • Uses of InitialContext in javax.naming.ldap

      Subclasses of InitialContext in javax.naming.ldap
      修饰符与类型 类与描述
      class  InitialLdapContext
      This class is the starting context for performing LDAPv3-style extended operations and controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xdpsxepnaojht<


Uses of Class javax.naming.InsufficientResourcesException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.InsufficientResourcesException

No usage of javax.naming.InsufficientResourcesException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=, istel,,,trnnam>a=


Uses of Class javax.naming.InterruptedNamingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.InterruptedNamingException

No usage of javax.naming.InterruptedNamingException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-motsn>sl>g/s


Uses of Class javax.naming.InvalidNameException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.InvalidNameException

  • Packages that use InvalidNameException
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of InvalidNameException in javax.naming

      Methods in javax.naming that throw InvalidNameException
      修饰符与类型 方法与描述
      Name CompoundName.add(int posn, String comp)
      Adds a single component at a specified position within this compound name.
      Name CompositeName.add(int posn, String comp)
      Adds a single component at a specified position within this composite name.
      Name Name.add(int posn, String comp)
      Adds a single component at a specified position within this name.
      Name CompoundName.add(String comp)
      Adds a single component to the end of this compound name.
      Name CompositeName.add(String comp)
      Adds a single component to the end of this composite name.
      Name Name.add(String comp)
      Adds a single component to the end of this name.
      Name CompoundName.addAll(int posn, Name n)
      Adds the components of a compound name -- in order -- at a specified position within this compound name.
      Name CompositeName.addAll(int posn, Name n)
      Adds the components of a composite name -- in order -- at a specified position within this composite name.
      Name Name.addAll(int posn, Name n)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name CompoundName.addAll(Name suffix)
      Adds the components of a compound name -- in order -- to the end of this compound name.
      Name CompositeName.addAll(Name suffix)
      Adds the components of a composite name -- in order -- to the end of this composite name.
      Name Name.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Object CompoundName.remove(int posn)
      Deletes a component from this compound name.
      Object CompositeName.remove(int posn)
      Deletes a component from this composite name.
      Object Name.remove(int posn)
      Removes a component from this name.
      Constructors in javax.naming that throw InvalidNameException
      构造方法与描述
      CompositeName(String n)
      Constructs a new composite name instance by parsing the string n using the composite name syntax (left-to-right, slash separated).
      CompoundName(String n, Properties syntax)
      Constructs a new compound name instance by parsing the string n using the syntax specified by the syntax properties supplied.

    • Uses of InvalidNameException in javax.naming.ldap

      Methods in javax.naming.ldap that throw InvalidNameException
      修饰符与类型 方法与描述
      Name LdapName.add(int posn, String comp)
      Adds a single component at a specified position within this LDAP name.
      Name LdapName.add(String comp)
      Adds a single component to the end of this LDAP name.
      Name LdapName.addAll(int posn, Name suffix)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name LdapName.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Object LdapName.remove(int posn)
      Removes a component from this LDAP name.
      Constructors in javax.naming.ldap that throw InvalidNameException
      构造方法与描述
      LdapName(String name)
      Constructs an LDAP name from the given distinguished name.
      Rdn(Attributes attrSet)
      Constructs an Rdn from the given attribute set.
      Rdn(String rdnString)
      Constructs an Rdn from the given string.
      Rdn(String type, Object value)
      Constructs an Rdn from the given attribute type and value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eie>rkodopnnovg e


Uses of Class javax.naming.LimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.LimitExceededException

  • Packages that use LimitExceededException
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of LimitExceededException in javax.naming

      Subclasses of LimitExceededException in javax.naming
      修饰符与类型 类与描述
      class  SizeLimitExceededException
      This exception is thrown when a method produces a result that exceeds a size-related limit.
      class  TimeLimitExceededException
      This exception is thrown when a method does not terminate within the specified time limit.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dj= tithmmmna../eim#eaa/


Uses of Class javax.naming.LinkException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.LinkException

  • Packages that use LinkException
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of LinkException in javax.naming

      Subclasses of LinkException in javax.naming
      修饰符与类型 类与描述
      class  LinkLoopException
      This exception is thrown when a loop was detected will attempting to resolve a link, or an implementation specific limit on link counts has been reached.
      class  MalformedLinkException
      This exception is thrown when a malformed link was encountered while resolving or constructing a link.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laＳＫㄋ粲塞t<<<


Uses of Class javax.naming.LinkLoopException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.LinkLoopException

No usage of javax.naming.LinkLoopException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n_a>omNb"ooos< /li=


Uses of Class javax.naming.LinkRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.LinkRef

No usage of javax.naming.LinkRef
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a_—间讳篇嗽冰籶Ｃ粼3


Uses of Class javax.naming.MalformedLinkException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.MalformedLinkException

No usage of javax.naming.MalformedLinkException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa >"rr鵏=oeS o>bm>=/


Uses of Class javax.naming.NameAlreadyBoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NameAlreadyBoundException

No usage of javax.naming.NameAlreadyBoundException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=.">>teCC/=s/m


Uses of Class javax.naming.NameClassPair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NameClassPair

  • Packages that use NameClassPair
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.

    • Uses of NameClassPair in javax.naming

      Subclasses of NameClassPair in javax.naming
      修饰符与类型 类与描述
      class  Binding
      This class represents a name-to-object binding found in a context.
      Methods in javax.naming that return types with arguments of type NameClassPair
      修饰符与类型 | 方法与描述
      NamingEnumeration<NameClassPair> Context.list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
      NamingEnumeration<NameClassPair> Context.list(String name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(String name)

    • Uses of NameClassPair in javax.naming.directory

      Subclasses of NameClassPair in javax.naming.directory
      修饰符与类型 类与描述
      class  SearchResult
      This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a,"l""sso.t/d/>ar


Uses of Class javax.naming.NameNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NameNotFoundException

No usage of javax.naming.NameNotFoundException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;"


Uses of Class javax.naming.NamingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NamingException

  • Packages that use NamingException
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi

    • Uses of NamingException in javax.naming

      Subclasses of NamingException in javax.naming
      修饰符与类型 类与描述
      class  AuthenticationException
      This exception is thrown when an authentication error occurs while accessing the naming or directory service.
      class  AuthenticationNotSupportedException
      This exception is thrown when the particular flavor of authentication requested is not supported.
      class  CannotProceedException
      This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further.
      class  CommunicationException
      This exception is thrown when the client is unable to communicate with the directory or naming service.
      class  ConfigurationException
      This exception is thrown when there is a configuration problem.
      class  ContextNotEmptyException
      This exception is thrown when attempting to destroy a context that is not empty.
      class  InsufficientResourcesException
      This exception is thrown when resources are not available to complete the requested operation.
      class  InterruptedNamingException
      This exception is thrown when the naming operation being invoked has been interrupted.
      class  InvalidNameException
      This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
      class  LimitExceededException
      This exception is thrown when a method terminates abnormally due to a user or system specified limit.
      class  LinkException
      This exception is used to describe problems encounter while resolving links.
      class  LinkLoopException
      This exception is thrown when a loop was detected will attempting to resolve a link, or an implementation specific limit on link counts has been reached.
      class  MalformedLinkException
      This exception is thrown when a malformed link was encountered while resolving or constructing a link.
      class  NameAlreadyBoundException
      This exception is thrown by methods to indicate that a binding cannot be added because the name is already bound to another object.
      class  NameNotFoundException
      This exception is thrown when a component of the name cannot be resolved because it is not bound.
      class  NamingSecurityException
      This is the superclass of security-related exceptions thrown by operations in the Context and DirContext interfaces.
      class  NoInitialContextException
      This exception is thrown when no initial context implementation can be created.
      class  NoPermissionException
      This exception is thrown when attempting to perform an operation for which the client has no permission.
      class  NotContextException
      This exception is thrown when a naming operation proceeds to a point where a context is required to continue the operation, but the resolved object is not a context.
      class  OperationNotSupportedException
      This exception is thrown when a context implementation does not support the operation being invoked.
      class  PartialResultException
      This exception is thrown to indicate that the result being returned or returned so far is partial, and that the operation cannot be completed.
      class  ReferralException
      This abstract class is used to represent a referral exception, which is generated in response to a referral such as that returned by LDAP v3 servers.
      class  ServiceUnavailableException
      This exception is thrown when attempting to communicate with a directory or naming service and that service is not available.
      class  SizeLimitExceededException
      This exception is thrown when a method produces a result that exceeds a size-related limit.
      class  TimeLimitExceededException
      This exception is thrown when a method does not terminate within the specified time limit.
      Methods in javax.naming that throw NamingException
      修饰符与类型 | 方法与描述
      Object Context.addToEnvironment(String propName, Object propVal)
      Adds a new environment property to the environment of this context.
      Object | InitialContext.addToEnvironment(String propName, Object propVal)
      void Context.bind(Name name, Object obj)
      Binds a name to an object.
      void | InitialContext.bind(Name name, Object obj)
      void Context.bind(String name, Object obj)
      Binds a name to an object.
      void | InitialContext.bind(String name, Object obj)
      void NamingEnumeration.close()
      Closes this enumeration.
      void Context.close()
      Closes this context.
      void | InitialContext.close()
      Name Context.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      Name InitialContext.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      String Context.composeName(String name, String prefix)
      Composes the name of this context with a name relative to this context.
      String InitialContext.composeName(String name, String prefix)
      Composes the name of this context with a name relative to this context.
      Context Context.createSubcontext(Name name)
      Creates and binds a new context.
      Context | InitialContext.createSubcontext(Name name)
      Context Context.createSubcontext(String name)
      Creates and binds a new context.
      Context | InitialContext.createSubcontext(String name)
      void Context.destroySubcontext(Name name)
      Destroys the named context and removes it from the namespace.
      void | InitialContext.destroySubcontext(Name name)
      void Context.destroySubcontext(String name)
      Destroys the named context and removes it from the namespace.
      void | InitialContext.destroySubcontext(String name)
      static <T> T InitialContext.doLookup(Name name)
      A static method to retrieve the named object.
      static <T> T InitialContext.doLookup(String name)
      A static method to retrieve the named object.
      protected Context InitialContext.getDefaultInitCtx()
      Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx.
      Hashtable<?,?> Context.getEnvironment()
      Retrieves the environment in effect for this context.
      Hashtable<?,?> | InitialContext.getEnvironment()
      String LinkRef.getLinkName()
      Retrieves the name of this link.
      String Context.getNameInNamespace()
      Retrieves the full name of this context within its own namespace.
      String | InitialContext.getNameInNamespace()
      NameParser Context.getNameParser(Name name)
      Retrieves the parser associated with the named context.
      NameParser | InitialContext.getNameParser(Name name)
      NameParser Context.getNameParser(String name)
      Retrieves the parser associated with the named context.
      NameParser | InitialContext.getNameParser(String name)
      Reference Referenceable.getReference()
      Retrieves the Reference of this object.
      abstract Context ReferralException.getReferralContext()
      Retrieves the context at which to continue the method.
      abstract Context ReferralException.getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties.
      protected Context InitialContext.getURLOrDefaultInitCtx(Name name)
      Retrieves a context for resolving name.
      protected Context InitialContext.getURLOrDefaultInitCtx(String name)
      Retrieves a context for resolving the string name name.
      boolean NamingEnumeration.hasMore()
      Determines whether there are any more elements in the enumeration.
      protected void InitialContext.init(Hashtable<?,?> environment)
      Initializes the initial context using the supplied environment.
      NamingEnumeration<NameClassPair> Context.list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
      NamingEnumeration<NameClassPair> Context.list(String name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(String name)
      NamingEnumeration<Binding> Context.listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
      NamingEnumeration<Binding> Context.listBindings(String name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(String name)
      Object Context.lookup(Name name)
      Retrieves the named object.
      Object | InitialContext.lookup(Name name)
      Object Context.lookup(String name)
      Retrieves the named object.
      Object | InitialContext.lookup(String name)
      Object Context.lookupLink(Name name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      Object | InitialContext.lookupLink(Name name)
      Object Context.lookupLink(String name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      Object | InitialContext.lookupLink(String name)
      T NamingEnumeration.下一个()
      Retrieves the next element in the enumeration.
      Name NameParser.parse(String name)
      Parses a name into its components.
      void Context.rebind(Name name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      void | InitialContext.rebind(Name name, Object obj)
      void Context.rebind(String name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      void | InitialContext.rebind(String name, Object obj)
      Object Context.removeFromEnvironment(String propName)
      Removes an environment property from the environment of this context.
      Object | InitialContext.removeFromEnvironment(String propName)
      void Context.rename(Name oldName, Name newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void | InitialContext.rename(Name oldName, Name newName)
      void Context.rename(String oldName, String newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void | InitialContext.rename(String oldName, String newName)
      void Context.unbind(Name name)
      Unbinds the named object.
      void | InitialContext.unbind(Name name)
      void Context.unbind(String name)
      Unbinds the named object.
      void | InitialContext.unbind(String name)
      Constructors in javax.naming that throw NamingException
      构造方法与描述
      InitialContext()
      Constructs an initial context.
      InitialContext(boolean lazy)
      Constructs an initial context with the option of not initializing it.
      InitialContext(Hashtable<?,?> environment)
      Constructs an initial context using the supplied environment.

    • Uses of NamingException in javax.naming.directory

      Subclasses of NamingException in javax.naming.directory
      修饰符与类型 类与描述
      class  AttributeInUseException
      This exception is thrown when an operation attempts to add an attribute that already exists.
      class  AttributeModificationException
      This exception is thrown when an attempt is made to add, or remove, or modify an attribute, its identifier, or its values that conflicts with the attribute's (schema) definition or the attribute's state.
      class  InvalidAttributeIdentifierException
      This exception is thrown when an attempt is made to add to create an attribute with an invalid attribute identifier.
      class  InvalidAttributesException
      This exception is thrown when an attempt is made to add or modify an attribute set that has been specified incompletely or incorrectly.
      class  InvalidAttributeValueException
      This class is thrown when an attempt is made to add to an attribute a value that conflicts with the attribute's schema definition.
      class  InvalidSearchControlsException
      This exception is thrown when the specification of the SearchControls for a search operation is invalid.
      class  InvalidSearchFilterException
      This exception is thrown when the specification of a search filter is invalid.
      class  NoSuchAttributeException
      This exception is thrown when attempting to access an attribute that does not exist.
      class  SchemaViolationException
      This exception is thrown when a method in some ways violates the schema.
      Methods in javax.naming.directory that throw NamingException
      修饰符与类型 | 方法与描述
      void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
      void DirContext.bind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
      void DirContext.bind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
      DirContext DirContext.createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
      DirContext DirContext.createSubcontext(String name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      Object BasicAttribute.get()
      Retrieves one of this attribute's values.
      Object Attribute.get()
      Retrieves one of this attribute's values.
      Object | BasicAttribute.get(int ix)
      Object Attribute.get(int ix)
      Retrieves the attribute value from the ordered list of attribute values.
      NamingEnumeration<?> BasicAttribute.getAll()
      Retrieves an enumeration of this attribute's values.
      NamingEnumeration<?> Attribute.getAll()
      Retrieves an enumeration of the attribute's values.
      DirContext BasicAttribute.getAttributeDefinition()
      Retrieves this attribute's schema definition.
      DirContext Attribute.getAttributeDefinition()
      Retrieves the attribute's schema definition.
      Attributes | InitialDirContext.getAttributes(Name name)
      Attributes DirContext.getAttributes(Name name)
      Retrieves all of the attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
      Attributes DirContext.getAttributes(Name name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(String name)
      Attributes DirContext.getAttributes(String name)
      Retrieves all of the attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)
      Attributes DirContext.getAttributes(String name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      DirContext BasicAttribute.getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with this attribute.
      DirContext Attribute.getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with the attribute.
      DirContext | InitialDirContext.getSchema(Name name)
      DirContext DirContext.getSchema(Name name)
      Retrieves the schema associated with the named object.
      DirContext | InitialDirContext.getSchema(String name)
      DirContext DirContext.getSchema(String name)
      Retrieves the schema associated with the named object.
      DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
      DirContext DirContext.getSchemaClassDefinition(Name name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      DirContext | InitialDirContext.getSchemaClassDefinition(String name)
      DirContext DirContext.getSchemaClassDefinition(String name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      void DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
      void DirContext.modifyAttributes(Name name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
      void DirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
      void DirContext.modifyAttributes(String name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
      void DirContext.rebind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
      void DirContext.rebind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      Constructors in javax.naming.directory that throw NamingException
      构造方法与描述
      InitialDirContext()
      Constructs an initial DirContext.
      InitialDirContext(boolean lazy)
      Constructs an initial DirContext with the option of not initializing it.
      InitialDirContext(Hashtable<?,?> environment)
      Constructs an initial DirContext using the supplied environment.

    • Uses of NamingException in javax.naming.event

      Methods in javax.naming.event that return NamingException
      修饰符与类型 方法与描述
      NamingException NamingExceptionEvent.getException()
      Retrieves the exception that was thrown.
      Methods in javax.naming.event that throw NamingException
      修饰符与类型 方法与描述
      void EventContext.addNamingListener(Name target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
      void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
      void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
      void EventContext.addNamingListener(String target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object named by the string target name and scope changes.
      void EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
      void EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.
      void EventContext.removeNamingListener(NamingListener l)
      Removes a listener from receiving naming events fired by this EventContext.
      boolean EventContext.targetMustExist()
      Determines whether a listener can register interest in a target that does not exist.
      Constructors in javax.naming.event with parameters of type NamingException
      构造方法与描述
      NamingExceptionEvent(EventContext source, NamingException exc)
      Constructs an instance of NamingExceptionEvent using the context in which the NamingException was thrown and the exception that was thrown.

    • Uses of NamingException in javax.naming.ldap

      Subclasses of NamingException in javax.naming.ldap
      修饰符与类型 类与描述
      class  LdapReferralException
      This abstract class is used to represent an LDAP referral exception.
      Methods in javax.naming.ldap that return NamingException
      修饰符与类型 方法与描述
      NamingException UnsolicitedNotification.getException()
      Retrieves the exception as constructed using information sent by the server.
      NamingException SortResponseControl.getException()
      Retrieves the NamingException appropriate for the result code.
      Methods in javax.naming.ldap that throw NamingException
      修饰符与类型 | 方法与描述
      ExtendedResponse StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates an extended response object that corresponds to the LDAP StartTLS extended request.
      ExtendedResponse ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates the response object that corresponds to this request.
      ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
      ExtendedResponse LdapContext.extendedOperation(ExtendedRequest request)
      Performs an extended operation.
      Control[] | InitialLdapContext.getConnectControls()
      Control[] LdapContext.getConnectControls()
      Retrieves the connection request controls in effect for this context.
      abstract Control ControlFactory.getControlInstance(Control ctl)
      Creates a control using this control factory.
      static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
      Creates a control using known control factories.
      Control[] HasControls.getControls()
      Retrieves an array of Controls from the object that implements this interface.
      abstract Context LdapReferralException.getReferralContext()
      Retrieves the context at which to continue the method using the context's environment and no controls.
      abstract Context LdapReferralException.getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties and no controls.
      abstract Context LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls)
      Retrieves the context at which to continue the method using request controls and environment properties.
      Control[] | InitialLdapContext.getRequestControls()
      Control[] LdapContext.getRequestControls()
      Retrieves the request controls in effect for this context.
      Control[] | InitialLdapContext.getResponseControls()
      Control[] LdapContext.getResponseControls()
      Retrieves the response controls produced as a result of the last method invoked on this context.
      LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
      LdapContext LdapContext.newInstance(Control[] requestControls)
      Creates a new instance of this context initialized using request controls.
      void | InitialLdapContext.reconnect(Control[] connCtls)
      void LdapContext.reconnect(Control[] connCtls)
      Reconnects to the LDAP server using the supplied controls and this context's environment.
      void | InitialLdapContext.setRequestControls(Control[] requestControls)
      void LdapContext.setRequestControls(Control[] requestControls)
      Sets the request controls for methods subsequently invoked on this context.
      Constructors in javax.naming.ldap that throw NamingException
      构造方法与描述
      InitialLdapContext()
      Constructs an initial context using no environment properties or connection request controls.
      InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
      Constructs an initial context using environment properties and connection request controls.

    • Uses of NamingException in javax.naming.spi

      Methods in javax.naming.spi that throw NamingException
      修饰符与类型 方法与描述
      InitialContextFactory InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment)
      Creates an initial context factory using the specified environment.
      ObjectFactory ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
      Creates a new object factory using the environment supplied.
      static Context NamingManager.getContinuationContext(CannotProceedException cpe)
      Creates a context in which to continue a context operation.
      static DirContext DirectoryManager.getContinuationDirContext(CannotProceedException cpe)
      Creates a context in which to continue a DirContext operation.
      Context InitialContextFactory.getInitialContext(Hashtable<?,?> environment)
      Creates an Initial Context for beginning name resolution.
      static Context NamingManager.getInitialContext(Hashtable<?,?> env)
      Creates an initial context using the specified environment properties.
      Object StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static Object NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static DirStateFactory.Result DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.
      DirStateFactory.Result DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.
      static Context NamingManager.getURLContext(String scheme, Hashtable<?,?> environment)
      Creates a context for the given URL scheme id.
      ResolveResult Resolver.resolveToClass(Name name, 类<? extends Context> contextType)
      Partially resolves a name.
      ResolveResult Resolver.resolveToClass(String name, 类<? extends Context> contextType)
      Partially resolves a name.
      static void NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
      Sets the InitialContextFactory builder to be builder.
      static void NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder)
      The ObjectFactoryBuilder determines the policy used when trying to load object factories.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.naming.NamingSecurityException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NamingSecurityException

  • Packages that use NamingSecurityException
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of NamingSecurityException in javax.naming

      Subclasses of NamingSecurityException in javax.naming
      修饰符与类型 类与描述
      class  AuthenticationException
      This exception is thrown when an authentication error occurs while accessing the naming or directory service.
      class  AuthenticationNotSupportedException
      This exception is thrown when the particular flavor of authentication requested is not supported.
      class  NoPermissionException
      This exception is thrown when attempting to perform an operation for which the client has no permission.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tie//ja..///.addc rd=rst


Uses of Class javax.naming.NoInitialContextException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NoInitialContextException

No usage of javax.naming.NoInitialContextException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>E&& .= b


Uses of Class javax.naming.NoPermissionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NoPermissionException

No usage of javax.naming.NoPermissionException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-imotsn>sl>g/sf


Uses of Class javax.naming.NotContextException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.NotContextException

No usage of javax.naming.NotContextException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.naming.OperationNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.OperationNotSupportedException

No usage of javax.naming.OperationNotSupportedException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

exa /nomaii"c Tn dpa


Uses of Class javax.naming.PartialResultException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.PartialResultException

No usage of javax.naming.PartialResultException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/tＨ�/�o>


Uses of Class javax.naming.RefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.RefAddr

  • Packages that use RefAddr
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of RefAddr in javax.naming

      Subclasses of RefAddr in javax.naming
      修饰符与类型 类与描述
      class  BinaryRefAddr
      This class represents the binary form of the address of a communications end-point.
      class  StringRefAddr
      This class represents the string form of the address of a communications end-point.
      Fields in javax.naming with type parameters of type RefAddr
      修饰符与类型 字段与描述
      protected Vector<RefAddr> Reference.addrs
      Contains the addresses contained in this Reference.
      Methods in javax.naming that return RefAddr
      修饰符与类型 方法与描述
      RefAddr Reference.get(int posn)
      Retrieves the address at index posn.
      RefAddr Reference.get(String addrType)
      Retrieves the first address that has the address type 'addrType'.
      Methods in javax.naming that return types with arguments of type RefAddr
      修饰符与类型 方法与描述
      Enumeration<RefAddr> Reference.getAll()
      Retrieves an enumeration of the addresses in this reference.
      Methods in javax.naming with parameters of type RefAddr
      修饰符与类型 方法与描述
      void Reference.add(int posn, RefAddr addr)
      Adds an address to the list of addresses at index posn.
      void Reference.add(RefAddr addr)
      Adds an address to the end of the list of addresses.
      Constructors in javax.naming with parameters of type RefAddr
      构造方法与描述
      Reference(String className, RefAddr addr)
      Constructs a new reference for an object with class name 'className' and an address.
      Reference(String className, RefAddr addr, String factory, String factoryLocation)
      Constructs a new reference for an object with class name 'className', the class name and location of the object's factory, and the address for the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eelolnaclhgd"rot <


Uses of Class javax.naming.Reference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.Reference

  • Packages that use Reference
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of Reference in javax.naming

      Subclasses of Reference in javax.naming
      修饰符与类型 类与描述
      class  LinkRef
      This class represents a Reference whose contents is a name, called the link name, that is bound to an atomic name in a context.
      Methods in javax.naming that return Reference
      修饰符与类型 方法与描述
      Reference Referenceable.getReference()
      Retrieves the Reference of this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.naming.ReferralException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ReferralException

  • Packages that use ReferralException
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of ReferralException in javax.naming.ldap

      Subclasses of ReferralException in javax.naming.ldap
      修饰符与类型 类与描述
      class  LdapReferralException
      This abstract class is used to represent an LDAP referral exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ijd""t.


Uses of Class javax.naming.ServiceUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ServiceUnavailableException

No usage of javax.naming.ServiceUnavailableException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Tsrhtreakgggprllsl


Uses of Class javax.naming.SizeLimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.SizeLimitExceededException

No usage of javax.naming.SizeLimitExceededException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sTt>h>lshegsttgrreg


Uses of Class javax.naming.StringRefAddr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.StringRefAddr

No usage of javax.naming.StringRefAddr
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Class javax.naming.TimeLimitExceededException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.TimeLimitExceededException

No usage of javax.naming.TimeLimitExceededException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.naming.Context

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.Context

  • Packages that use Context
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of Context in javax.naming

      Classes in javax.naming that implement Context
      修饰符与类型 类与描述
      class  InitialContext
      This class is the starting context for performing naming operations.
      Fields in javax.naming declared as Context
      修饰符与类型 字段与描述
      protected Context CannotProceedException.altNameCtx
      Contains the context relative to which altName is specified.
      protected Context InitialContext.defaultInitCtx
      Field holding the result of calling NamingManager.getInitialContext().
      Methods in javax.naming that return Context
      修饰符与类型 | 方法与描述
      Context Context.createSubcontext(Name name)
      Creates and binds a new context.
      Context | InitialContext.createSubcontext(Name name)
      Context Context.createSubcontext(String name)
      Creates and binds a new context.
      Context | InitialContext.createSubcontext(String name)
      Context CannotProceedException.getAltNameCtx()
      Retrieves the altNameCtx field of this exception.
      protected Context InitialContext.getDefaultInitCtx()
      Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx.
      abstract Context ReferralException.getReferralContext()
      Retrieves the context at which to continue the method.
      abstract Context ReferralException.getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties.
      protected Context InitialContext.getURLOrDefaultInitCtx(Name name)
      Retrieves a context for resolving name.
      protected Context InitialContext.getURLOrDefaultInitCtx(String name)
      Retrieves a context for resolving the string name name.
      Methods in javax.naming with parameters of type Context
      修饰符与类型 方法与描述
      void CannotProceedException.setAltNameCtx(Context altNameCtx)
      Sets the altNameCtx field of this exception.

    • Uses of Context in javax.naming.directory

      Subinterfaces of Context in javax.naming.directory
      修饰符与类型 Interface and Description
      interface  DirContext
      The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
      Classes in javax.naming.directory that implement Context
      修饰符与类型 类与描述
      class  InitialDirContext
      This class is the starting context for performing directory operations.

    • Uses of Context in javax.naming.event

      Subinterfaces of Context in javax.naming.event
      修饰符与类型 Interface and Description
      interface  EventContext
      Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.
      interface  EventDirContext
      Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.

    • Uses of Context in javax.naming.ldap

      Subinterfaces of Context in javax.naming.ldap
      修饰符与类型 Interface and Description
      interface  LdapContext
      This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations.
      Classes in javax.naming.ldap that implement Context
      修饰符与类型 类与描述
      class  InitialLdapContext
      This class is the starting context for performing LDAPv3-style extended operations and controls.
      Methods in javax.naming.ldap that return Context
      修饰符与类型 方法与描述
      abstract Context LdapReferralException.getReferralContext()
      Retrieves the context at which to continue the method using the context's environment and no controls.
      abstract Context LdapReferralException.getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties and no controls.
      abstract Context LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls)
      Retrieves the context at which to continue the method using request controls and environment properties.
      Methods in javax.naming.ldap with parameters of type Context
      修饰符与类型 方法与描述
      static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
      Creates a control using known control factories.

    • Uses of Context in javax.naming.spi

      Methods in javax.naming.spi that return Context
      修饰符与类型 方法与描述
      static Context NamingManager.getContinuationContext(CannotProceedException cpe)
      Creates a context in which to continue a context operation.
      Context InitialContextFactory.getInitialContext(Hashtable<?,?> environment)
      Creates an Initial Context for beginning name resolution.
      static Context NamingManager.getInitialContext(Hashtable<?,?> env)
      Creates an initial context using the specified environment properties.
      static Context NamingManager.getURLContext(String scheme, Hashtable<?,?> environment)
      Creates a context for the given URL scheme id.
      Methods in javax.naming.spi with parameters of type Context
      修饰符与类型 方法与描述
      Object ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an object using the location or reference information specified.
      static Object NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an instance of an object for the specified object and environment.
      static Object DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an instance of an object for the specified object, attributes, and environment.
      Object DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an object using the location or reference information, and attributes specified.
      Object StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static Object NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static DirStateFactory.Result DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.
      DirStateFactory.Result DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.
      Method parameters in javax.naming.spi with type arguments of type Context
      修饰符与类型 方法与描述
      ResolveResult Resolver.resolveToClass(Name name, 类<? extends Context> contextType)
      Partially resolves a name.
      ResolveResult Resolver.resolveToClass(String name, 类<? extends Context> contextType)
      Partially resolves a name.

    • Uses of Context in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type Context
      修饰符与类型 方法与描述
      static void SyncFactory.setJNDIContext(Context ctx)
      Sets the initial JNDI context from which SyncProvider implementations can be retrieved from a JNDI namespace
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.naming.Name

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.Name

  • Packages that use Name
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi

    • Uses of Name in javax.naming

      Classes in javax.naming that implement Name
      修饰符与类型 类与描述
      class  CompositeName
      This class represents a composite name -- a sequence of component names spanning multiple namespaces.
      class  CompoundName
      This class represents a compound name -- a name from a hierarchical name space.
      Fields in javax.naming declared as Name
      修饰符与类型 字段与描述
      protected Name CannotProceedException.altName
      Contains the name of the resolved object, relative to the context altNameCtx.
      protected Name LinkException.linkRemainingName
      Contains the remaining link name that has not been resolved yet.
      protected Name LinkException.linkResolvedName
      Contains the part of the link that has been successfully resolved.
      protected Name NamingException.remainingName
      Contains the remaining name that has not been resolved yet.
      protected Name CannotProceedException.remainingNewName
      Contains the remaining unresolved part of the second "name" argument to Context.rename().
      protected Name NamingException.resolvedName
      Contains the part of the name that has been successfully resolved.
      Methods in javax.naming that return Name
      修饰符与类型 方法与描述
      Name CompoundName.add(int posn, String comp)
      Adds a single component at a specified position within this compound name.
      Name CompositeName.add(int posn, String comp)
      Adds a single component at a specified position within this composite name.
      Name Name.add(int posn, String comp)
      Adds a single component at a specified position within this name.
      Name CompoundName.add(String comp)
      Adds a single component to the end of this compound name.
      Name CompositeName.add(String comp)
      Adds a single component to the end of this composite name.
      Name Name.add(String comp)
      Adds a single component to the end of this name.
      Name CompoundName.addAll(int posn, Name n)
      Adds the components of a compound name -- in order -- at a specified position within this compound name.
      Name CompositeName.addAll(int posn, Name n)
      Adds the components of a composite name -- in order -- at a specified position within this composite name.
      Name Name.addAll(int posn, Name n)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name CompoundName.addAll(Name suffix)
      Adds the components of a compound name -- in order -- to the end of this compound name.
      Name CompositeName.addAll(Name suffix)
      Adds the components of a composite name -- in order -- to the end of this composite name.
      Name Name.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Name Context.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      Name InitialContext.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      Name CannotProceedException.getAltName()
      Retrieves the altName field of this exception.
      Name LinkException.getLinkRemainingName()
      Retrieves the remaining unresolved portion of the link name.
      Name LinkException.getLinkResolvedName()
      Retrieves the leading portion of the link name that was resolved successfully.
      Name CompoundName.getPrefix(int posn)
      Creates a compound name whose components consist of a prefix of the components in this compound name.
      Name CompositeName.getPrefix(int posn)
      Creates a composite name whose components consist of a prefix of the components in this composite name.
      Name Name.getPrefix(int posn)
      Creates a name whose components consist of a prefix of the components of this name.
      Name NamingException.getRemainingName()
      Retrieves the remaining unresolved portion of the name.
      Name CannotProceedException.getRemainingNewName()
      Retrieves the "remaining new name" field of this exception, which is used when this exception is thrown during a rename() operation.
      Name NamingException.getResolvedName()
      Retrieves the leading portion of the name that was resolved successfully.
      Name CompoundName.getSuffix(int posn)
      Creates a compound name whose components consist of a suffix of the components in this compound name.
      Name CompositeName.getSuffix(int posn)
      Creates a composite name whose components consist of a suffix of the components in this composite name.
      Name Name.getSuffix(int posn)
      Creates a name whose components consist of a suffix of the components in this name.
      Name NameParser.parse(String name)
      Parses a name into its components.
      Methods in javax.naming with parameters of type Name
      修饰符与类型 | 方法与描述
      Name CompoundName.addAll(int posn, Name n)
      Adds the components of a compound name -- in order -- at a specified position within this compound name.
      Name CompositeName.addAll(int posn, Name n)
      Adds the components of a composite name -- in order -- at a specified position within this composite name.
      Name Name.addAll(int posn, Name n)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name CompoundName.addAll(Name suffix)
      Adds the components of a compound name -- in order -- to the end of this compound name.
      Name CompositeName.addAll(Name suffix)
      Adds the components of a composite name -- in order -- to the end of this composite name.
      Name Name.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      void NamingException.appendRemainingName(Name name)
      Add components from 'name' as the last components in remaining name.
      void Context.bind(Name name, Object obj)
      Binds a name to an object.
      void | InitialContext.bind(Name name, Object obj)
      Name Context.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      Name InitialContext.composeName(Name name, Name prefix)
      Composes the name of this context with a name relative to this context.
      Context Context.createSubcontext(Name name)
      Creates and binds a new context.
      Context | InitialContext.createSubcontext(Name name)
      void Context.destroySubcontext(Name name)
      Destroys the named context and removes it from the namespace.
      void | InitialContext.destroySubcontext(Name name)
      static <T> T InitialContext.doLookup(Name name)
      A static method to retrieve the named object.
      boolean CompoundName.endsWith(Name n)
      Determines whether a compound name is a suffix of this compound name.
      boolean CompositeName.endsWith(Name n)
      Determines whether a composite name is a suffix of this composite name.
      boolean Name.endsWith(Name n)
      Determines whether this name ends with a specified suffix.
      NameParser Context.getNameParser(Name name)
      Retrieves the parser associated with the named context.
      NameParser | InitialContext.getNameParser(Name name)
      protected Context InitialContext.getURLOrDefaultInitCtx(Name name)
      Retrieves a context for resolving name.
      NamingEnumeration<NameClassPair> Context.list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
      NamingEnumeration<Binding> Context.listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
      Object Context.lookup(Name name)
      Retrieves the named object.
      Object | InitialContext.lookup(Name name)
      Object Context.lookupLink(Name name)
      Retrieves the named object, following links except for the terminal atomic component of the name.
      Object | InitialContext.lookupLink(Name name)
      void Context.rebind(Name name, Object obj)
      Binds a name to an object, overwriting any existing binding.
      void | InitialContext.rebind(Name name, Object obj)
      void Context.rename(Name oldName, Name newName)
      Binds a new name to the object bound to an old name, and unbinds the old name.
      void | InitialContext.rename(Name oldName, Name newName)
      void CannotProceedException.setAltName(Name altName)
      Sets the altName field of this exception.
      void LinkException.setLinkRemainingName(Name name)
      Sets the remaining link name field of this exception.
      void LinkException.setLinkResolvedName(Name name)
      Sets the resolved link name field of this exception.
      void NamingException.setRemainingName(Name name)
      Sets the remaining name field of this exception.
      void CannotProceedException.setRemainingNewName(Name newName)
      Sets the "remaining new name" field of this exception.
      void NamingException.setResolvedName(Name name)
      Sets the resolved name field of this exception.
      boolean CompoundName.startsWith(Name n)
      Determines whether a compound name is a prefix of this compound name.
      boolean CompositeName.startsWith(Name n)
      Determines whether a composite name is a prefix of this composite name.
      boolean Name.startsWith(Name n)
      Determines whether this name starts with a specified prefix.
      void Context.unbind(Name name)
      Unbinds the named object.
      void | InitialContext.unbind(Name name)
      Constructors in javax.naming with parameters of type Name
      构造方法与描述
      LinkRef(Name linkName)
      Constructs a LinkRef for a name.

    • Uses of Name in javax.naming.directory

      Methods in javax.naming.directory with parameters of type Name
      修饰符与类型 | 方法与描述
      void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
      void DirContext.bind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
      DirContext DirContext.createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      Attributes | InitialDirContext.getAttributes(Name name)
      Attributes DirContext.getAttributes(Name name)
      Retrieves all of the attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
      Attributes DirContext.getAttributes(Name name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      DirContext | InitialDirContext.getSchema(Name name)
      DirContext DirContext.getSchema(Name name)
      Retrieves the schema associated with the named object.
      DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
      DirContext DirContext.getSchemaClassDefinition(Name name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      void DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
      void DirContext.modifyAttributes(Name name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
      void DirContext.rebind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.

    • Uses of Name in javax.naming.event

      Methods in javax.naming.event with parameters of type Name
      修饰符与类型 方法与描述
      void EventContext.addNamingListener(Name target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
      void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
      void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.

    • Uses of Name in javax.naming.ldap

      Classes in javax.naming.ldap that implement Name
      修饰符与类型 类与描述
      class  LdapName
      This class represents a distinguished name as specified by RFC 2253.
      Methods in javax.naming.ldap that return Name
      修饰符与类型 方法与描述
      Name LdapName.add(int posn, Rdn comp)
      Adds a single RDN at a specified position within this LDAP name.
      Name LdapName.add(int posn, String comp)
      Adds a single component at a specified position within this LDAP name.
      Name LdapName.add(Rdn comp)
      Adds a single RDN to the end of this LDAP name.
      Name LdapName.add(String comp)
      Adds a single component to the end of this LDAP name.
      Name LdapName.addAll(int posn, List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- at a specified position within this name.
      Name LdapName.addAll(int posn, Name suffix)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name LdapName.addAll(List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- to the end of this name.
      Name LdapName.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Name LdapName.getPrefix(int posn)
      Creates a name whose components consist of a prefix of the components of this LDAP name.
      Name LdapName.getSuffix(int posn)
      Creates a name whose components consist of a suffix of the components in this LDAP name.
      Methods in javax.naming.ldap with parameters of type Name
      修饰符与类型 方法与描述
      Name LdapName.addAll(int posn, Name suffix)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name LdapName.addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      boolean LdapName.endsWith(Name n)
      Determines whether this LDAP name ends with a specified LDAP name suffix.
      boolean LdapName.startsWith(Name n)
      Determines whether this LDAP name starts with a specified LDAP name prefix.

    • Uses of Name in javax.naming.spi

      Fields in javax.naming.spi declared as Name
      修饰符与类型 字段与描述
      protected Name ResolveResult.remainingName
      Field containing the remaining name yet to be resolved.
      Methods in javax.naming.spi that return Name
      修饰符与类型 方法与描述
      Name ResolveResult.getRemainingName()
      Retrieves the remaining unresolved portion of the name.
      Methods in javax.naming.spi with parameters of type Name
      修饰符与类型 方法与描述
      void ResolveResult.appendRemainingName(Name name)
      Adds components to the end of remaining name.
      Object ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an object using the location or reference information specified.
      static Object NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an instance of an object for the specified object and environment.
      static Object DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an instance of an object for the specified object, attributes, and environment.
      Object DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an object using the location or reference information, and attributes specified.
      Object StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static Object NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static DirStateFactory.Result DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.
      DirStateFactory.Result DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.
      ResolveResult Resolver.resolveToClass(Name name, 类<? extends Context> contextType)
      Partially resolves a name.
      void ResolveResult.setRemainingName(Name name)
      Sets the remaining name field of this result to name.
      Constructors in javax.naming.spi with parameters of type Name
      构造方法与描述
      ResolveResult(Object robj, Name rname)
      Constructs a new instance of ResolveResult consisting of the resolved Object and the remaining name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.naming.NameParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.NameParser

  • Packages that use NameParser
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.

    • Uses of NameParser in javax.naming

      Methods in javax.naming that return NameParser
      修饰符与类型 | 方法与描述
      NameParser Context.getNameParser(Name name)
      Retrieves the parser associated with the named context.
      NameParser | InitialContext.getNameParser(Name name)
      NameParser Context.getNameParser(String name)
      Retrieves the parser associated with the named context.
      NameParser | InitialContext.getNameParser(String name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drlfco/moeei>


Uses of Interface javax.naming.NamingEnumeration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.NamingEnumeration

  • Packages that use NamingEnumeration
    软件包 描述
    javax.naming
    Provides the classes and interfaces for accessing naming services.
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.

    • Uses of NamingEnumeration in javax.naming

      Methods in javax.naming that return NamingEnumeration
      修饰符与类型 | 方法与描述
      NamingEnumeration<NameClassPair> Context.list(Name name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
      NamingEnumeration<NameClassPair> Context.list(String name)
      Enumerates the names bound in the named context, along with the class names of objects bound to them.
      NamingEnumeration<NameClassPair> | InitialContext.list(String name)
      NamingEnumeration<Binding> Context.listBindings(Name name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
      NamingEnumeration<Binding> Context.listBindings(String name)
      Enumerates the names bound in the named context, along with the objects bound to them.
      NamingEnumeration<Binding> | InitialContext.listBindings(String name)

    • Uses of NamingEnumeration in javax.naming.directory

      Methods in javax.naming.directory that return NamingEnumeration
      修饰符与类型 | 方法与描述
      NamingEnumeration<Attribute> | BasicAttributes.getAll()
      NamingEnumeration<?> BasicAttribute.getAll()
      Retrieves an enumeration of this attribute's values.
      NamingEnumeration<?> Attribute.getAll()
      Retrieves an enumeration of the attribute's values.
      NamingEnumeration<? extends Attribute> Attributes.getAll()
      Retrieves an enumeration of the attributes in the attribute set.
      NamingEnumeration<String> | BasicAttributes.getIDs()
      NamingEnumeration<String> Attributes.getIDs()
      Retrieves an enumeration of the ids of the attributes in the attribute set.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.guo<蟦�


Uses of Interface javax.naming.Referenceable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.Referenceable

No usage of javax.naming.Referenceable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nrgj../"=...rocch胠 h


Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.directory

Interface Attribute

  • All Superinterfaces:
    Cloneable, Serializable
    All Known Implementing Classes:
    BasicAttribute

    public interface Attribute
extends Cloneable, Serializable
    This interface represents an attribute associated with a named object.

    In a directory, named objects can have associated with them attributes. The Attribute interface represents an attribute associated with a named object. An attribute contains 0 or more, possibly null, values. The attribute values can be ordered or unordered (see isOrdered()). If the values are unordered, no duplicates are allowed. If the values are ordered, duplicates are allowed.

    The content and representation of an attribute and its values is defined by the attribute's schema. The schema contains information about the attribute's syntax and other properties about the attribute. See getAttributeDefinition() and getAttributeSyntaxDefinition() for details regarding how to get schema information about an attribute if the underlying directory service supports schemas.

    Equality of two attributes is determined by the implementation class. A simple implementation can use Object.equals() to determine equality of attribute values, while a more sophisticated implementation might make use of schema information to determine equality. Similarly, one implementation might provide a static storage structure which simply returns the values passed to its constructor, while another implementation might define get() and getAll(). to get the values dynamically from the directory.

    Note that updates to Attribute (such as adding or removing a value) do not affect the corresponding representation of the attribute in the directory. Updates to the directory can only be effected using operations in the DirContext interface.

    从以下版本开始：
    1.3
    另请参见：
    BasicAttribute

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static long serialVersionUID
      Use serialVersionUID from JNDI 1.1.1 for interoperability.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int ix, Object attrVal)
      Adds an attribute value to the ordered list of attribute values.
      boolean add(Object attrVal)
      Adds a new value to the attribute.
      void clear()
      Removes all values from this attribute.
      Object clone()
      Makes a copy of the attribute.
      boolean contains(Object attrVal)
      Determines whether a value is in the attribute.
      Object get()
      Retrieves one of this attribute's values.
      Object get(int ix)
      Retrieves the attribute value from the ordered list of attribute values.
      NamingEnumeration<?> getAll()
      Retrieves an enumeration of the attribute's values.
      DirContext getAttributeDefinition()
      Retrieves the attribute's schema definition.
      DirContext getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with the attribute.
      String getID()
      Retrieves the id of this attribute.
      boolean isOrdered()
      Determines whether this attribute's values are ordered.
      Object remove(int ix)
      Removes an attribute value from the ordered list of attribute values.
      boolean remove(Object attrval)
      Removes a specified value from the attribute.
      Object set(int ix, Object attrVal)
      Sets an attribute value in the ordered list of attribute values.
      int size()
      Retrieves the number of values in this attribute.

    • 字段详细信息

      • serialVersionUID

        static final long serialVersionUID
        Use serialVersionUID from JNDI 1.1.1 for interoperability.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getAll

        NamingEnumeration<?> getAll()
                            throws NamingException
        Retrieves an enumeration of the attribute's values. The behaviour of this enumeration is unspecified if the attribute's values are added, changed, or removed while the enumeration is in progress. If the attribute values are ordered, the enumeration's items will be ordered.
        返回：
        A non-null enumeration of the attribute's values. Each element of the enumeration is a possibly null Object. The object's class is the class of the attribute value. The element is null if the attribute's value is null. If the attribute has zero values, an empty enumeration is returned.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the values.
        另请参见：
        isOrdered()

      • get

        Object get()
           throws NamingException
        Retrieves one of this attribute's values. If the attribute has more than one value and is unordered, any one of the values is returned. If the attribute has more than one value and is ordered, the first value is returned.
        返回：
        A possibly null object representing one of the attribute's value. It is null if the attribute's value is null.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the value.
        NoSuchElementException - If this attribute has no values.

      • size

        int size()
        Retrieves the number of values in this attribute.
        返回：
        The nonnegative number of values in this attribute.

      • getID

        String getID()
        Retrieves the id of this attribute.
        返回：
        The id of this attribute. It cannot be null.

      • contains

        boolean contains(Object attrVal)
        Determines whether a value is in the attribute. Equality is determined by the implementation, which may use Object.equals() or schema information to determine equality.
        参数：
        attrVal - The possibly null value to check. If null, check whether the attribute has an attribute value whose value is null.
        返回：
        true if attrVal is one of this attribute's values; false otherwise.
        另请参见：
        Object.equals(java.lang.Object), BasicAttribute.equals(java.lang.Object)

      • add

        boolean add(Object attrVal)
        Adds a new value to the attribute. If the attribute values are unordered and attrVal is already in the attribute, this method does nothing. If the attribute values are ordered, attrVal is added to the end of the list of attribute values.

        Equality is determined by the implementation, which may use Object.equals() or schema information to determine equality.

        参数：
        attrVal - The new possibly null value to add. If null, null is added as an attribute value.
        返回：
        true if a value was added; false otherwise.

      • remove

        boolean remove(Object attrval)
        Removes a specified value from the attribute. If attrval is not in the attribute, this method does nothing. If the attribute values are ordered, the first occurrence of attrVal is removed and attribute values at indices greater than the removed value are shifted up towards the head of the list (and their indices decremented by one).

        Equality is determined by the implementation, which may use Object.equals() or schema information to determine equality.

        参数：
        attrval - The possibly null value to remove from this attribute. If null, remove the attribute value that is null.
        返回：
        true if the value was removed; false otherwise.

      • clear

        void clear()
        Removes all values from this attribute.

      • getAttributeSyntaxDefinition

        DirContext getAttributeSyntaxDefinition()
                                        throws NamingException
        Retrieves the syntax definition associated with the attribute. An attribute's syntax definition specifies the format of the attribute's value(s). Note that this is different from the attribute value's representation as a Java object. Syntax definition refers to the directory's notion of syntax.

        For example, even though a value might be a Java String object, its directory syntax might be "Printable String" or "Telephone Number". Or a value might be a byte array, and its directory syntax is "JPEG" or "Certificate". For example, if this attribute's syntax is "JPEG", this method would return the syntax definition for "JPEG".

        The information that you can retrieve from a syntax definition is directory-dependent.

        If an implementation does not support schemas, it should throw OperationNotSupportedException. If an implementation does support schemas, it should define this method to return the appropriate information.

        返回：
        The attribute's syntax definition. Null if the implementation supports schemas but this particular attribute does not have any schema information.
        抛出：
        OperationNotSupportedException - If getting the schema is not supported.
        NamingException - If a naming exception occurs while getting the schema.

      • getAttributeDefinition

        DirContext getAttributeDefinition()
                                  throws NamingException
        Retrieves the attribute's schema definition. An attribute's schema definition contains information such as whether the attribute is multivalued or single-valued, the matching rules to use when comparing the attribute's values. The information that you can retrieve from an attribute definition is directory-dependent.

        If an implementation does not support schemas, it should throw OperationNotSupportedException. If an implementation does support schemas, it should define this method to return the appropriate information.

        返回：
        This attribute's schema definition. Null if the implementation supports schemas but this particular attribute does not have any schema information.
        抛出：
        OperationNotSupportedException - If getting the schema is not supported.
        NamingException - If a naming exception occurs while getting the schema.

      • clone

        Object clone()
        Makes a copy of the attribute. The copy contains the same attribute values as the original attribute: the attribute values are not themselves cloned. Changes to the copy will not affect the original and vice versa.
        返回：
        A non-null copy of the attribute.

      • isOrdered

        boolean isOrdered()
        Determines whether this attribute's values are ordered. If an attribute's values are ordered, duplicate values are allowed. If an attribute's values are unordered, they are presented in any order and there are no duplicate values.
        返回：
        true if this attribute's values are ordered; false otherwise.
        另请参见：
        get(int), remove(int), add(int, java.lang.Object), set(int, java.lang.Object)

      • get

        Object get(int ix)
           throws NamingException
        Retrieves the attribute value from the ordered list of attribute values. This method returns the value at the ix index of the list of attribute values. If the attribute values are unordered, this method returns the value that happens to be at that index.
        参数：
        ix - The index of the value in the ordered list of attribute values. 0 <= ix < size().
        返回：
        The possibly null attribute value at index ix; null if the attribute value is null.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the value.
        IndexOutOfBoundsException - If ix is outside the specified range.

      • remove

        Object remove(int ix)
        Removes an attribute value from the ordered list of attribute values. This method removes the value at the ix index of the list of attribute values. If the attribute values are unordered, this method removes the value that happens to be at that index. Values located at indices greater than ix are shifted up towards the front of the list (and their indices decremented by one).
        参数：
        ix - The index of the value to remove. 0 <= ix < size().
        返回：
        The possibly null attribute value at index ix that was removed; null if the attribute value is null.
        抛出：
        IndexOutOfBoundsException - If ix is outside the specified range.

      • add

        void add(int ix,
       Object attrVal)
        Adds an attribute value to the ordered list of attribute values. This method adds attrVal to the list of attribute values at index ix. Values located at indices at or greater than ix are shifted down towards the end of the list (and their indices incremented by one). If the attribute values are unordered and already have attrVal, IllegalStateException is thrown.
        参数：
        ix - The index in the ordered list of attribute values to add the new value. 0 <= ix <= size().
        attrVal - The possibly null attribute value to add; if null, null is the value added.
        抛出：
        IndexOutOfBoundsException - If ix is outside the specified range.
        IllegalStateException - If the attribute values are unordered and attrVal is one of those values.

      • set

        Object set(int ix,
         Object attrVal)
        Sets an attribute value in the ordered list of attribute values. This method sets the value at the ix index of the list of attribute values to be attrVal. The old value is removed. If the attribute values are unordered, this method sets the value that happens to be at that index to attrVal, unless attrVal is already one of the values. In that case, IllegalStateException is thrown.
        参数：
        ix - The index of the value in the ordered list of attribute values. 0 <= ix < size().
        attrVal - The possibly null attribute value to use. If null, 'null' replaces the old value.
        返回：
        The possibly null attribute value at index ix that was replaced. Null if the attribute value was null.
        抛出：
        IndexOutOfBoundsException - If ix is outside the specified range.
        IllegalStateException - If attrVal already exists and the attribute values are unordered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


AttributeInUseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 AttributeInUseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
  • 所有已实现的接口：
    Serializable

    public class AttributeInUseException
extends NamingException
    This exception is thrown when an operation attempts to add an attribute that already exists.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttributeInUseException()
      Constructs a new instance of AttributeInUseException.
      AttributeInUseException(String explanation)
      Constructs a new instance of AttributeInUseException with an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AttributeInUseException

        public AttributeInUseException(String explanation)
        Constructs a new instance of AttributeInUseException with an explanation. All other fields are set to null.
        参数：
        explanation - Possibly null additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • AttributeInUseException

        public AttributeInUseException()
        Constructs a new instance of AttributeInUseException. All fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mrlcmngingn/ninn/.hhr sdnd>/.sentd>>etya


AttributeModificationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 AttributeModificationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.AttributeModificationException
  • 所有已实现的接口：
    Serializable

    public class AttributeModificationException
extends NamingException
    This exception is thrown when an attempt is made to add, or remove, or modify an attribute, its identifier, or its values that conflicts with the attribute's (schema) definition or the attribute's state. It is thrown in response to DirContext.modifyAttributes(). It contains a list of modifications that have not been performed, in the order that they were supplied to modifyAttributes(). If the list is null, none of the modifications were performed successfully.

    An AttributeModificationException instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single AttributeModification instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttributeModificationException()
      Constructs a new instance of AttributeModificationException.
      AttributeModificationException(String explanation)
      Constructs a new instance of AttributeModificationException using an explanation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ModificationItem[] getUnexecutedModifications()
      Retrieves the unexecuted modification list.
      void setUnexecutedModifications(ModificationItem[] e)
      Sets the unexecuted modification list to be e.
      String toString()
      The string representation of this exception consists of information about where the error occurred, and the first unexecuted modification.

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AttributeModificationException

        public AttributeModificationException(String explanation)
        Constructs a new instance of AttributeModificationException using an explanation. All other fields are set to null.
        参数：
        explanation - Possibly null additional detail about this exception. If null, this exception has no detail message.
        另请参见：
        Throwable.getMessage()

      • AttributeModificationException

        public AttributeModificationException()
        Constructs a new instance of AttributeModificationException. All fields are set to null.

    • 方法详细信息

      • setUnexecutedModifications

        public void setUnexecutedModifications(ModificationItem[] e)
        Sets the unexecuted modification list to be e. Items in the list must appear in the same order in which they were originally supplied in DirContext.modifyAttributes(). The first item in the list is the first one that was not executed. If this list is null, none of the operations originally submitted to modifyAttributes() were executed.
        参数：
        e - The possibly null list of unexecuted modifications.
        另请参见：
        getUnexecutedModifications()

      • getUnexecutedModifications

        public ModificationItem[] getUnexecutedModifications()
        Retrieves the unexecuted modification list. Items in the list appear in the same order in which they were originally supplied in DirContext.modifyAttributes(). The first item in the list is the first one that was not executed. If this list is null, none of the operations originally submitted to modifyAttributes() were executed.
        返回：
        The possibly null unexecuted modification list.
        另请参见：
        setUnexecutedModifications(javax.naming.directory.ModificationItem[])

      • toString

        public String toString()
        The string representation of this exception consists of information about where the error occurred, and the first unexecuted modification. This string is meant for debugging and not mean to be interpreted programmatically.
        重载：
        toString in class NamingException
        返回：
        The non-null string representation of this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u>tgsvcni/>jea>am;lponro衋觟emhaicSnnst"


Attributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.directory

Interface Attributes

  • All Superinterfaces:
    Cloneable, Serializable
    All Known Implementing Classes:
    BasicAttributes

    public interface Attributes
extends Cloneable, Serializable
    This interface represents a collection of attributes.

    In a directory, named objects can have associated with them attributes. The Attributes interface represents a collection of attributes. For example, you can request from the directory the attributes associated with an object. Those attributes are returned in an object that implements the Attributes interface.

    Attributes in an object that implements the Attributes interface are unordered. The object can have zero or more attributes. Attributes is either case-sensitive or case-insensitive (case-ignore). This property is determined at the time the Attributes object is created. (see BasicAttributes constructor for example). In a case-insensitive Attributes, the case of its attribute identifiers is ignored when searching for an attribute, or adding attributes. In a case-sensitive Attributes, the case is significant.

    Note that updates to Attributes (such as adding or removing an attribute) do not affect the corresponding representation in the directory. Updates to the directory can only be effected using operations in the DirContext interface.

    从以下版本开始：
    1.3
    另请参见：
    DirContext.getAttributes(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
BasicAttributes

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Makes a copy of the attribute set.
      Attribute get(String attrID)
      Retrieves the attribute with the given attribute id from the attribute set.
      NamingEnumeration<? extends Attribute> getAll()
      Retrieves an enumeration of the attributes in the attribute set.
      NamingEnumeration<String> getIDs()
      Retrieves an enumeration of the ids of the attributes in the attribute set.
      boolean isCaseIgnored()
      Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
      Attribute put(Attribute attr)
      Adds a new attribute to the attribute set.
      Attribute put(String attrID, Object val)
      Adds a new attribute to the attribute set.
      Attribute remove(String attrID)
      Removes the attribute with the attribute id 'attrID' from the attribute set.
      int size()
      Retrieves the number of attributes in the attribute set.

    • 方法详细信息

      • isCaseIgnored

        boolean isCaseIgnored()
        Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
        返回：
        true if case is ignored; false otherwise.

      • size

        int size()
        Retrieves the number of attributes in the attribute set.
        返回：
        The nonnegative number of attributes in this attribute set.

      • get

        Attribute get(String attrID)
        Retrieves the attribute with the given attribute id from the attribute set.
        参数：
        attrID - The non-null id of the attribute to retrieve. If this attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        返回：
        The attribute identified by attrID; null if not found.
        另请参见：
        put(java.lang.String, java.lang.Object), remove(java.lang.String)

      • getAll

        NamingEnumeration<? extends Attribute> getAll()
        Retrieves an enumeration of the attributes in the attribute set. The effects of updates to this attribute set on this enumeration are undefined.
        返回：
        A non-null enumeration of the attributes in this attribute set. Each element of the enumeration is of class Attribute. If attribute set has zero attributes, an empty enumeration is returned.

      • getIDs

        NamingEnumeration<String> getIDs()
        Retrieves an enumeration of the ids of the attributes in the attribute set. The effects of updates to this attribute set on this enumeration are undefined.
        返回：
        A non-null enumeration of the attributes' ids in this attribute set. Each element of the enumeration is of class String. If attribute set has zero attributes, an empty enumeration is returned.

      • put

        Attribute put(String attrID,
            Object val)
        Adds a new attribute to the attribute set.
        参数：
        attrID - non-null The id of the attribute to add. If the attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        val - The possibly null value of the attribute to add. If null, the attribute does not have any values.
        返回：
        The Attribute with attrID that was previous in this attribute set; null if no such attribute existed.
        另请参见：
        remove(java.lang.String)

      • put

        Attribute put(Attribute attr)
        Adds a new attribute to the attribute set.
        参数：
        attr - The non-null attribute to add. If the attribute set ignores the character case of its attribute ids, the case of attr's identifier is ignored.
        返回：
        The Attribute with the same ID as attr that was previous in this attribute set; null if no such attribute existed.
        另请参见：
        remove(java.lang.String)

      • remove

        Attribute remove(String attrID)
        Removes the attribute with the attribute id 'attrID' from the attribute set. If the attribute does not exist, ignore.
        参数：
        attrID - The non-null id of the attribute to remove. If the attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        返回：
        The Attribute with the same ID as attrID that was previous in the attribute set; null if no such attribute existed.

      • clone

        Object clone()
        Makes a copy of the attribute set. The new set contains the same attributes as the original set: the attributes are not themselves cloned. Changes to the copy will not affect the original and vice versa.
        返回：
        A non-null copy of this attribute set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"mi/el.nogCt/=t.lcm>= /r.vs>


BasicAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 BasicAttribute

  • java.lang.Object
    • javax.naming.directory.BasicAttribute
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public class BasicAttribute
extends Object
implements Attribute
    This class provides a basic implementation of the Attribute interface.

    This implementation does not support the schema methods getAttributeDefinition() and getAttributeSyntaxDefinition(). They simply throw OperationNotSupportedException. Subclasses of BasicAttribute should override these methods if they support them.

    The BasicAttribute class by default uses Object.equals() to determine equality of attribute values when testing for equality or when searching for values, except when the value is an array. For an array, each element of the array is checked using Object.equals(). Subclasses of BasicAttribute can make use of schema information when doing similar equality checks by overriding methods in which such use of schema is meaningful. Similarly, the BasicAttribute class by default returns the values passed to its constructor and/or manipulated using the add/remove methods. Subclasses of BasicAttribute can override get() and getAll() to get the values dynamically from the directory (or implement the Attribute interface directly instead of subclassing BasicAttribute).

    Note that updates to BasicAttribute (such as adding or removing a value) does not affect the corresponding representation of the attribute in the directory. Updates to the directory can only be effected using operations in the DirContext interface.

    A BasicAttribute instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a BasicAttribute should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected String attrID
      Holds the attribute's id.
      protected boolean ordered
      A flag for recording whether this attribute's values are ordered.
      protected Vector<Object> values
      Holds the attribute's values.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicAttribute(String id)
      Constructs a new instance of an unordered attribute with no value.
      BasicAttribute(String id, boolean ordered)
      Constructs a new instance of a possibly ordered attribute with no value.
      BasicAttribute(String id, Object value)
      Constructs a new instance of an unordered attribute with a single value.
      BasicAttribute(String id, Object value, boolean ordered)
      Constructs a new instance of a possibly ordered attribute with a single value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int ix, Object attrVal)
      Adds an attribute value to the ordered list of attribute values.
      boolean add(Object attrVal)
      Adds a new value to this attribute.
      void clear()
      Removes all values from this attribute.
      Object clone()
      Creates and returns a copy of this object.
      boolean contains(Object attrVal)
      Determines whether a value is in this attribute.
      boolean equals(Object obj)
      Determines whether obj is equal to this attribute.
      Object get()
      Retrieves one of this attribute's values.
      Object get(int ix)
      Retrieves the attribute value from the ordered list of attribute values.
      NamingEnumeration<?> getAll()
      Retrieves an enumeration of this attribute's values.
      DirContext getAttributeDefinition()
      Retrieves this attribute's schema definition.
      DirContext getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with this attribute.
      String getID()
      Retrieves the id of this attribute.
      int hashCode()
      Calculates the hash code of this attribute.
      boolean isOrdered()
      Determines whether this attribute's values are ordered.
      Object remove(int ix)
      Removes an attribute value from the ordered list of attribute values.
      boolean remove(Object attrval)
      Removes a specified value from this attribute.
      Object set(int ix, Object attrVal)
      Sets an attribute value in the ordered list of attribute values.
      int size()
      Retrieves the number of values in this attribute.
      String toString()
      Generates the string representation of this attribute.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • attrID

        protected String attrID
        Holds the attribute's id. It is initialized by the public constructor and cannot be null unless methods in BasicAttribute that use attrID have been overridden.

      • values

        protected transient Vector<Object> values
        Holds the attribute's values. Initialized by public constructors. Cannot be null unless methods in BasicAttribute that use values have been overridden.

      • ordered

        protected boolean ordered
        A flag for recording whether this attribute's values are ordered.

    • 构造方法详细信息

      • BasicAttribute

        public BasicAttribute(String id)
        Constructs a new instance of an unordered attribute with no value.
        参数：
        id - The attribute's id. It cannot be null.

      • BasicAttribute

        public BasicAttribute(String id,
              Object value)
        Constructs a new instance of an unordered attribute with a single value.
        参数：
        id - The attribute's id. It cannot be null.
        value - The attribute's value. If null, a null value is added to the attribute.

      • BasicAttribute

        public BasicAttribute(String id,
              boolean ordered)
        Constructs a new instance of a possibly ordered attribute with no value.
        参数：
        id - The attribute's id. It cannot be null.
        ordered - true means the attribute's values will be ordered; false otherwise.

      • BasicAttribute

        public BasicAttribute(String id,
              Object value,
              boolean ordered)
        Constructs a new instance of a possibly ordered attribute with a single value.
        参数：
        id - The attribute's id. It cannot be null.
        value - The attribute's value. If null, a null value is added to the attribute.
        ordered - true means the attribute's values will be ordered; false otherwise.

    • 方法详细信息

      • clone

        public Object clone()
        Description copied from class: Object
        Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
         x.clone() != x
        will be true, and that the expression:
         x.clone().getClass() == x.getClass()
        will be true, but these are not absolute requirements. While it is typically the case that:
         x.clone().equals(x)
        will be true, this is not an absolute requirement.

        By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

        By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

        The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable and that the return type of the clone method of an array type T[] is T[] where T is any reference or primitive type. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

        The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

        指定者：
        clone in interface Attribute
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • equals

        public boolean equals(Object obj)
        Determines whether obj is equal to this attribute. Two attributes are equal if their attribute-ids, syntaxes and values are equal. If the attribute values are unordered, the order that the values were added are irrelevant. If the attribute values are ordered, then the order the values must match. If obj is null or not an Attribute, false is returned.

        By default Object.equals() is used when comparing the attribute id and its values except when a value is an array. For an array, each element of the array is checked using Object.equals(). A subclass may override this to make use of schema syntax information and matching rules, which define what it means for two attributes to be equal. How and whether a subclass makes use of the schema information is determined by the subclass. If a subclass overrides equals(), it should also override hashCode() such that two attributes that are equal have the same hash code.

        重载：
        equals in class Object
        参数：
        obj - The possibly null object to check.
        返回：
        true if obj is equal to this attribute; false otherwise.
        另请参见：
        hashCode(), contains(java.lang.Object)

      • hashCode

        public int hashCode()
        Calculates the hash code of this attribute.

        The hash code is computed by adding the hash code of the attribute's id and that of all of its values except for values that are arrays. For an array, the hash code of each element of the array is summed. If a subclass overrides hashCode(), it should override equals() as well so that two attributes that are equal have the same hash code.

        重载：
        hashCode in class Object
        返回：
        an int representing the hash code of this attribute.
        另请参见：
        equals(java.lang.Object)

      • toString

        public String toString()
        Generates the string representation of this attribute. The string consists of the attribute's id and its values. This string is meant for debugging and not meant to be interpreted programmatically.
        重载：
        toString in class Object
        返回：
        The non-null string representation of this attribute.

      • getAll

        public NamingEnumeration<?> getAll()
                            throws NamingException
        Retrieves an enumeration of this attribute's values.

        By default, the values returned are those passed to the constructor and/or manipulated using the add/replace/remove methods. A subclass may override this to retrieve the values dynamically from the directory.

        指定者：
        getAll in interface Attribute
        返回：
        A non-null enumeration of the attribute's values. Each element of the enumeration is a possibly null Object. The object's class is the class of the attribute value. The element is null if the attribute's value is null. If the attribute has zero values, an empty enumeration is returned.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the values.
        另请参见：
        Attribute.isOrdered()

      • get

        public Object get()
           throws NamingException
        Retrieves one of this attribute's values.

        By default, the value returned is one of those passed to the constructor and/or manipulated using the add/replace/remove methods. A subclass may override this to retrieve the value dynamically from the directory.

        指定者：
        get in interface Attribute
        返回：
        A possibly null object representing one of the attribute's value. It is null if the attribute's value is null.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the value.

      • size

        public int size()
        从接口复制的描述： Attribute
        Retrieves the number of values in this attribute.
        指定者：
        size in interface Attribute
        返回：
        The nonnegative number of values in this attribute.

      • getID

        public String getID()
        从接口复制的描述： Attribute
        Retrieves the id of this attribute.
        指定者：
        getID in interface Attribute
        返回：
        The id of this attribute. It cannot be null.

      • contains

        public boolean contains(Object attrVal)
        Determines whether a value is in this attribute.

        By default, Object.equals() is used when comparing attrVal with this attribute's values except when attrVal is an array. For an array, each element of the array is checked using Object.equals(). A subclass may use schema information to determine equality.

        指定者：
        contains in interface Attribute
        参数：
        attrVal - The possibly null value to check. If null, check whether the attribute has an attribute value whose value is null.
        返回：
        true if attrVal is one of this attribute's values; false otherwise.
        另请参见：
        Object.equals(java.lang.Object), equals(java.lang.Object)

      • add

        public boolean add(Object attrVal)
        Adds a new value to this attribute.

        By default, Object.equals() is used when comparing attrVal with this attribute's values except when attrVal is an array. For an array, each element of the array is checked using Object.equals(). A subclass may use schema information to determine equality.

        指定者：
        add in interface Attribute
        参数：
        attrVal - The new possibly null value to add. If null, null is added as an attribute value.
        返回：
        true if a value was added; false otherwise.

      • remove

        public boolean remove(Object attrval)
        Removes a specified value from this attribute.

        By default, Object.equals() is used when comparing attrVal with this attribute's values except when attrVal is an array. For an array, each element of the array is checked using Object.equals(). A subclass may use schema information to determine equality.

        指定者：
        remove in interface Attribute
        参数：
        attrval - The possibly null value to remove from this attribute. If null, remove the attribute value that is null.
        返回：
        true if the value was removed; false otherwise.

      • clear

        public void clear()
        从接口复制的描述： Attribute
        Removes all values from this attribute.
        指定者：
        clear in interface Attribute

      • isOrdered

        public boolean isOrdered()
        从接口复制的描述： Attribute
        Determines whether this attribute's values are ordered. If an attribute's values are ordered, duplicate values are allowed. If an attribute's values are unordered, they are presented in any order and there are no duplicate values.
        指定者：
        isOrdered in interface Attribute
        返回：
        true if this attribute's values are ordered; false otherwise.
        另请参见：
        Attribute.get(int),
Attribute.remove(int),
Attribute.add(int, java.lang.Object),
Attribute.set(int, java.lang.Object)

      • get

        public Object get(int ix)
           throws NamingException
        从接口复制的描述： Attribute
        Retrieves the attribute value from the ordered list of attribute values. This method returns the value at the ix index of the list of attribute values. If the attribute values are unordered, this method returns the value that happens to be at that index.
        指定者：
        get in interface Attribute
        参数：
        ix - The index of the value in the ordered list of attribute values. 0 <= ix < size().
        返回：
        The possibly null attribute value at index ix; null if the attribute value is null.
        抛出：
        NamingException - If a naming exception was encountered while retrieving the value.

      • remove

        public Object remove(int ix)
        从接口复制的描述： Attribute
        Removes an attribute value from the ordered list of attribute values. This method removes the value at the ix index of the list of attribute values. If the attribute values are unordered, this method removes the value that happens to be at that index. Values located at indices greater than ix are shifted up towards the front of the list (and their indices decremented by one).
        指定者：
        remove in interface Attribute
        参数：
        ix - The index of the value to remove. 0 <= ix < size().
        返回：
        The possibly null attribute value at index ix that was removed; null if the attribute value is null.

      • add

        public void add(int ix,
       Object attrVal)
        从接口复制的描述： Attribute
        Adds an attribute value to the ordered list of attribute values. This method adds attrVal to the list of attribute values at index ix. Values located at indices at or greater than ix are shifted down towards the end of the list (and their indices incremented by one). If the attribute values are unordered and already have attrVal, IllegalStateException is thrown.
        指定者：
        add in interface Attribute
        参数：
        ix - The index in the ordered list of attribute values to add the new value. 0 <= ix <= size().
        attrVal - The possibly null attribute value to add; if null, null is the value added.

      • set

        public Object set(int ix,
         Object attrVal)
        从接口复制的描述： Attribute
        Sets an attribute value in the ordered list of attribute values. This method sets the value at the ix index of the list of attribute values to be attrVal. The old value is removed. If the attribute values are unordered, this method sets the value that happens to be at that index to attrVal, unless attrVal is already one of the values. In that case, IllegalStateException is thrown.
        指定者：
        set in interface Attribute
        参数：
        ix - The index of the value in the ordered list of attribute values. 0 <= ix < size().
        attrVal - The possibly null attribute value to use. If null, 'null' replaces the old value.
        返回：
        The possibly null attribute value at index ix that was replaced. Null if the attribute value was null.

      • getAttributeSyntaxDefinition

        public DirContext getAttributeSyntaxDefinition()
                                        throws NamingException
        Retrieves the syntax definition associated with this attribute.

        This method by default throws OperationNotSupportedException. A subclass should override this method if it supports schema.

        指定者：
        getAttributeSyntaxDefinition in interface Attribute
        返回：
        The attribute's syntax definition. Null if the implementation supports schemas but this particular attribute does not have any schema information.
        抛出：
        OperationNotSupportedException - If getting the schema is not supported.
        NamingException - If a naming exception occurs while getting the schema.

      • getAttributeDefinition

        public DirContext getAttributeDefinition()
                                  throws NamingException
        Retrieves this attribute's schema definition.

        This method by default throws OperationNotSupportedException. A subclass should override this method if it supports schema.

        指定者：
        getAttributeDefinition in interface Attribute
        返回：
        This attribute's schema definition. Null if the implementation supports schemas but this particular attribute does not have any schema information.
        抛出：
        OperationNotSupportedException - If getting the schema is not supported.
        NamingException - If a naming exception occurs while getting the schema.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicAttributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 BasicAttributes

  • java.lang.Object
    • javax.naming.directory.BasicAttributes
  • 所有已实现的接口：
    Serializable, Cloneable, Attributes

    public class BasicAttributes
extends Object
implements Attributes
    This class provides a basic implementation of the Attributes interface.

    BasicAttributes is either case-sensitive or case-insensitive (case-ignore). This property is determined at the time the BasicAttributes constructor is called. In a case-insensitive BasicAttributes, the case of its attribute identifiers is ignored when searching for an attribute, or adding attributes. In a case-sensitive BasicAttributes, the case is significant.

    When the BasicAttributes class needs to create an Attribute, it uses BasicAttribute. There is no other dependency on BasicAttribute.

    Note that updates to BasicAttributes (such as adding or removing an attribute) does not affect the corresponding representation in the directory. Updates to the directory can only be effected using operations in the DirContext interface.

    A BasicAttributes instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single BasicAttributes instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    DirContext.getAttributes(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicAttributes()
      Constructs a new instance of Attributes.
      BasicAttributes(boolean ignoreCase)
      Constructs a new instance of Attributes.
      BasicAttributes(String attrID, Object val)
      Constructs a new instance of Attributes with one attribute.
      BasicAttributes(String attrID, Object val, boolean ignoreCase)
      Constructs a new instance of Attributes with one attribute.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates and returns a copy of this object.
      boolean equals(Object obj)
      Determines whether this BasicAttributes is equal to another Attributes Two Attributes are equal if they are both instances of Attributes, treat the case of attribute IDs the same way, and contain the same attributes.
      Attribute get(String attrID)
      Retrieves the attribute with the given attribute id from the attribute set.
      NamingEnumeration<Attribute> getAll()
      Retrieves an enumeration of the attributes in the attribute set.
      NamingEnumeration<String> getIDs()
      Retrieves an enumeration of the ids of the attributes in the attribute set.
      int hashCode()
      Calculates the hash code of this BasicAttributes.
      boolean isCaseIgnored()
      Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
      Attribute put(Attribute attr)
      Adds a new attribute to the attribute set.
      Attribute put(String attrID, Object val)
      Adds a new attribute to the attribute set.
      Attribute remove(String attrID)
      Removes the attribute with the attribute id 'attrID' from the attribute set.
      int size()
      Retrieves the number of attributes in the attribute set.
      String toString()
      Generates the string representation of this attribute set.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BasicAttributes

        public BasicAttributes()
        Constructs a new instance of Attributes. The character case of attribute identifiers is significant when subsequently retrieving or adding attributes.

      • BasicAttributes

        public BasicAttributes(boolean ignoreCase)
        Constructs a new instance of Attributes. If ignoreCase is true, the character case of attribute identifiers is ignored; otherwise the case is significant.
        参数：
        ignoreCase - true means this attribute set will ignore the case of its attribute identifiers when retrieving or adding attributes; false means case is respected.

      • BasicAttributes

        public BasicAttributes(String attrID,
               Object val)
        Constructs a new instance of Attributes with one attribute. The attribute specified by attrID and val are added to the newly created attribute. The character case of attribute identifiers is significant when subsequently retrieving or adding attributes.
        参数：
        attrID - non-null The id of the attribute to add.
        val - The value of the attribute to add. If null, a null value is added to the attribute.

      • BasicAttributes

        public BasicAttributes(String attrID,
               Object val,
               boolean ignoreCase)
        Constructs a new instance of Attributes with one attribute. The attribute specified by attrID and val are added to the newly created attribute. If ignoreCase is true, the character case of attribute identifiers is ignored; otherwise the case is significant.
        参数：
        attrID - non-null The id of the attribute to add. If this attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        val - The value of the attribute to add. If null, a null value is added to the attribute.
        ignoreCase - true means this attribute set will ignore the case of its attribute identifiers when retrieving or adding attributes; false means case is respected.

    • 方法详细信息

      • clone

        public Object clone()
        Description copied from class: Object
        Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
         x.clone() != x
        will be true, and that the expression:
         x.clone().getClass() == x.getClass()
        will be true, but these are not absolute requirements. While it is typically the case that:
         x.clone().equals(x)
        will be true, this is not an absolute requirement.

        By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

        By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

        The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable and that the return type of the clone method of an array type T[] is T[] where T is any reference or primitive type. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

        The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

        指定者：
        clone in interface Attributes
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • isCaseIgnored

        public boolean isCaseIgnored()
        从接口复制的描述： Attributes
        Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
        指定者：
        isCaseIgnored in interface Attributes
        返回：
        true if case is ignored; false otherwise.

      • size

        public int size()
        从接口复制的描述： Attributes
        Retrieves the number of attributes in the attribute set.
        指定者：
        size in interface Attributes
        返回：
        The nonnegative number of attributes in this attribute set.

      • get

        public Attribute get(String attrID)
        从接口复制的描述： Attributes
        Retrieves the attribute with the given attribute id from the attribute set.
        指定者：
        get in interface Attributes
        参数：
        attrID - The non-null id of the attribute to retrieve. If this attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        返回：
        The attribute identified by attrID; null if not found.
        另请参见：
        Attributes.put(java.lang.String, java.lang.Object), Attributes.remove(java.lang.String)

      • getAll

        public NamingEnumeration<Attribute> getAll()
        从接口复制的描述： Attributes
        Retrieves an enumeration of the attributes in the attribute set. The effects of updates to this attribute set on this enumeration are undefined.
        指定者：
        getAll in interface Attributes
        返回：
        A non-null enumeration of the attributes in this attribute set. Each element of the enumeration is of class Attribute. If attribute set has zero attributes, an empty enumeration is returned.

      • getIDs

        public NamingEnumeration<String> getIDs()
        从接口复制的描述： Attributes
        Retrieves an enumeration of the ids of the attributes in the attribute set. The effects of updates to this attribute set on this enumeration are undefined.
        指定者：
        getIDs in interface Attributes
        返回：
        A non-null enumeration of the attributes' ids in this attribute set. Each element of the enumeration is of class String. If attribute set has zero attributes, an empty enumeration is returned.

      • put

        public Attribute put(String attrID,
            Object val)
        从接口复制的描述： Attributes
        Adds a new attribute to the attribute set.
        指定者：
        put in interface Attributes
        参数：
        attrID - non-null The id of the attribute to add. If the attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        val - The possibly null value of the attribute to add. If null, the attribute does not have any values.
        返回：
        The Attribute with attrID that was previous in this attribute set; null if no such attribute existed.
        另请参见：
        Attributes.remove(java.lang.String)

      • put

        public Attribute put(Attribute attr)
        从接口复制的描述： Attributes
        Adds a new attribute to the attribute set.
        指定者：
        put in interface Attributes
        参数：
        attr - The non-null attribute to add. If the attribute set ignores the character case of its attribute ids, the case of attr's identifier is ignored.
        返回：
        The Attribute with the same ID as attr that was previous in this attribute set; null if no such attribute existed.
        另请参见：
        Attributes.remove(java.lang.String)

      • remove

        public Attribute remove(String attrID)
        从接口复制的描述： Attributes
        Removes the attribute with the attribute id 'attrID' from the attribute set. If the attribute does not exist, ignore.
        指定者：
        remove in interface Attributes
        参数：
        attrID - The non-null id of the attribute to remove. If the attribute set ignores the character case of its attribute ids, the case of attrID is ignored.
        返回：
        The Attribute with the same ID as attrID that was previous in the attribute set; null if no such attribute existed.

      • toString

        public String toString()
        Generates the string representation of this attribute set. The string consists of each attribute identifier and the contents of each attribute. The contents of this string is useful for debugging and is not meant to be interpreted programmatically.
        重载：
        toString in class Object
        返回：
        A non-null string listing the contents of this attribute set.

      • equals

        public boolean equals(Object obj)
        Determines whether this BasicAttributes is equal to another Attributes Two Attributes are equal if they are both instances of Attributes, treat the case of attribute IDs the same way, and contain the same attributes. Each Attribute in this BasicAttributes is checked for equality using Object.equals(), which may have be overridden by implementations of Attribute). If a subclass overrides equals(), it should override hashCode() as well so that two Attributes instances that are equal have the same hash code.
        重载：
        equals in class Object
        参数：
        obj - the possibly null object to compare against.
        返回：
        true If obj is equal to this BasicAttributes.
        另请参见：
        hashCode()

      • hashCode

        public int hashCode()
        Calculates the hash code of this BasicAttributes.

        The hash code is computed by adding the hash code of the attributes of this object. If this BasicAttributes ignores case of its attribute IDs, one is added to the hash code. If a subclass overrides hashCode(), it should override equals() as well so that two Attributes instances that are equal have the same hash code.

        重载：
        hashCode in class Object
        返回：
        an int representing the hash code of this BasicAttributes instance.
        另请参见：
        equals(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A trm#el#et..etttc//o>rteDDtseascpff/g=rhaph�


DirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.directory

Interface DirContext

  • All Superinterfaces:
    Context
    All Known Subinterfaces:
    EventDirContext, LdapContext
    All Known Implementing Classes:
    InitialDirContext, InitialLdapContext

    public interface DirContext
extends Context
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.

    Names

    Each name passed as an argument to a DirContext method is relative to that context. The empty name is used to name the context itself. The name parameter may never be null.

    Most of the methods have overloaded versions with one taking a Name parameter and one taking a String. These overloaded versions are equivalent in that if the Name and String parameters are just different representations of the same name, then the overloaded versions of the same methods behave the same. In the method descriptions below, only one version is documented. The second version instead has a link to the first: the same documentation applies to both.

    See Context for a discussion on the interpretation of the name argument to the Context methods. These same rules apply to the name argument to the DirContext methods.

    Attribute Models

    There are two basic models of what attributes should be associated with. First, attributes may be directly associated with a DirContext object. In this model, an attribute operation on the named object is roughly equivalent to a lookup on the name (which returns the DirContext object), followed by the attribute operation invoked on the DirContext object in which the caller supplies an empty name. The attributes can be viewed as being stored along with the object (note that this does not imply that the implementation must do so).

    The second model is that attributes are associated with a name (typically an atomic name) in a DirContext. In this model, an attribute operation on the named object is roughly equivalent to a lookup on the name of the parent DirContext of the named object, followed by the attribute operation invoked on the parent in which the caller supplies the terminal atomic name. The attributes can be viewed as being stored in the parent DirContext (again, this does not imply that the implementation must do so). Objects that are not DirContexts can have attributes, as long as their parents are DirContexts.

    JNDI support both of these models. It is up to the individual service providers to decide where to "store" attributes. JNDI clients are safest when they do not make assumptions about whether an object's attributes are stored as part of the object, or stored within the parent object and associated with the object's name.

    Attribute Type Names

    In the getAttributes() and search() methods, you can supply the attributes to return by supplying a list of attribute names (strings). The attributes that you get back might not have the same names as the attribute names you have specified. This is because some directories support features that cause them to return other attributes. Such features include attribute subclassing, attribute name synonyms, and attribute language codes.

    In attribute subclassing, attributes are defined in a class hierarchy. In some directories, for example, the "name" attribute might be the superclass of all name-related attributes, including "commonName" and "surName". Asking for the "name" attribute might return both the "commonName" and "surName" attributes.

    With attribute type synonyms, a directory can assign multiple names to the same attribute. For example, "cn" and "commonName" might both refer to the same attribute. Asking for "cn" might return the "commonName" attribute.

    Some directories support the language codes for attributes. Asking such a directory for the "description" attribute, for example, might return all of the following attributes:

    • description
    • description;lang-en
    • description;lang-de
    • description;lang-fr

    Operational Attributes

    Some directories have the notion of "operational attributes" which are attributes associated with a directory object for administrative purposes. An example of operational attributes is the access control list for an object.

    In the getAttributes() and search() methods, you can specify that all attributes associated with the requested objects be returned by supply null as the list of attributes to return. The attributes returned do not include operational attributes. In order to retrieve operational attributes, you must name them explicitly.

    Named Context

    There are certain methods in which the name must resolve to a context (for example, when searching a single level context). The documentation of such methods use the term named context to describe their name parameter. For these methods, if the named object is not a DirContext, NotContextException is thrown. Aside from these methods, there is no requirement that the named object be a DirContext.

    Parameters

    An Attributes, SearchControls, or array object passed as a parameter to any method will not be modified by the service provider. The service provider may keep a reference to it for the duration of the operation, including any enumeration of the method's results and the processing of any referrals generated. The caller should not modify the object during this time. An Attributes object returned by any method is owned by the caller. The caller may subsequently modify it; the service provider will not.

    Exceptions

    All the methods in this interface can throw a NamingException or any of its subclasses. See NamingException and their subclasses for details on each exception.

    从以下版本开始：
    1.3
    另请参见：
    Context

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ADD_ATTRIBUTE
      This constant specifies to add an attribute with the specified values.
      static int REMOVE_ATTRIBUTE
      This constant specifies to delete the specified attribute values from the attribute.
      static int REPLACE_ATTRIBUTE
      This constant specifies to replace an attribute with specified values.

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void bind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      void bind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      DirContext createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext createSubcontext(String name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      Attributes getAttributes(Name name)
      Retrieves all of the attributes associated with a named object.
      Attributes getAttributes(Name name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      Attributes getAttributes(String name)
      Retrieves all of the attributes associated with a named object.
      Attributes getAttributes(String name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      DirContext getSchema(Name name)
      Retrieves the schema associated with the named object.
      DirContext getSchema(String name)
      Retrieves the schema associated with the named object.
      DirContext getSchemaClassDefinition(Name name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      DirContext getSchemaClassDefinition(String name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      void modifyAttributes(Name name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void modifyAttributes(Name name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void modifyAttributes(String name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void modifyAttributes(String name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void rebind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      void rebind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      NamingEnumeration<SearchResult> search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 字段详细信息

      • ADD_ATTRIBUTE

        static final int ADD_ATTRIBUTE
        This constant specifies to add an attribute with the specified values.

        If attribute does not exist, create the attribute. The resulting attribute has a union of the specified value set and the prior value set. Adding an attribute with no value will throw InvalidAttributeValueException if the attribute must have at least one value. For a single-valued attribute where that attribute already exists, throws AttributeInUseException. If attempting to add more than one value to a single-valued attribute, throws InvalidAttributeValueException.

        The value of this constant is 1.

        另请参见：
        ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), Constant Field Values

      • REPLACE_ATTRIBUTE

        static final int REPLACE_ATTRIBUTE
        This constant specifies to replace an attribute with specified values.

        If attribute already exists, replaces all existing values with new specified values. If the attribute does not exist, creates it. If no value is specified, deletes all the values of the attribute. Removal of the last value will remove the attribute if the attribute is required to have at least one value. If attempting to add more than one value to a single-valued attribute, throws InvalidAttributeValueException.

        The value of this constant is 2.

        另请参见：
        ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), Constant Field Values

      • REMOVE_ATTRIBUTE

        static final int REMOVE_ATTRIBUTE
        This constant specifies to delete the specified attribute values from the attribute.

        The resulting attribute has the set difference of its prior value set and the specified value set. If no values are specified, deletes the entire attribute. If the attribute does not exist, or if some or all members of the specified value set do not exist, this absence may be ignored and the operation succeeds, or a NamingException may be thrown to indicate the absence. Removal of the last value will remove the attribute if the attribute is required to have at least one value.

        The value of this constant is 3.

        另请参见：
        ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), Constant Field Values

    • 方法详细信息

      • getAttributes

        Attributes getAttributes(Name name)
                         throws NamingException
        Retrieves all of the attributes associated with a named object. See the class description regarding attribute models, attribute type names, and operational attributes.
        参数：
        name - the name of the object from which to retrieve attributes
        返回：
        the set of attributes associated with name. Returns an empty attribute set if name has no attributes; never null.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        getAttributes(String), getAttributes(Name, String[])

      • getAttributes

        Attributes getAttributes(String name)
                         throws NamingException
        Retrieves all of the attributes associated with a named object. See getAttributes(Name) for details.
        参数：
        name - the name of the object from which to retrieve attributes
        返回：
        the set of attributes associated with name
        抛出：
        NamingException - if a naming exception is encountered

      • getAttributes

        Attributes getAttributes(Name name,
                       String[] attrIds)
                         throws NamingException
        Retrieves selected attributes associated with a named object. See the class description regarding attribute models, attribute type names, and operational attributes.

        If the object does not have an attribute specified, the directory will ignore the nonexistent attribute and return those requested attributes that the object does have.

        A directory might return more attributes than was requested (see Attribute Type Names in the class description), but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        参数：
        name - the name of the object from which to retrieve attributes
        attrIds - the identifiers of the attributes to retrieve. null indicates that all attributes should be retrieved; an empty array indicates that none should be retrieved.
        返回：
        the requested attributes; never null
        抛出：
        NamingException - if a naming exception is encountered

      • getAttributes

        Attributes getAttributes(String name,
                       String[] attrIds)
                         throws NamingException
        Retrieves selected attributes associated with a named object. See getAttributes(Name, String[]) for details.
        参数：
        name - The name of the object from which to retrieve attributes
        attrIds - the identifiers of the attributes to retrieve. null indicates that all attributes should be retrieved; an empty array indicates that none should be retrieved.
        返回：
        the requested attributes; never null
        抛出：
        NamingException - if a naming exception is encountered

      • modifyAttributes

        void modifyAttributes(Name name,
                    int mod_op,
                    Attributes attrs)
                      throws NamingException
        Modifies the attributes associated with a named object. The order of the modifications is not specified. Where possible, the modifications are performed atomically.
        参数：
        name - the name of the object whose attributes will be updated
        mod_op - the modification operation, one of: ADD_ATTRIBUTE, REPLACE_ATTRIBUTE, REMOVE_ATTRIBUTE.
        attrs - the attributes to be used for the modification; may not be null
        抛出：
        AttributeModificationException - if the modification cannot be completed successfully
        NamingException - if a naming exception is encountered
        另请参见：
        modifyAttributes(Name, ModificationItem[])

      • modifyAttributes

        void modifyAttributes(String name,
                    int mod_op,
                    Attributes attrs)
                      throws NamingException
        Modifies the attributes associated with a named object. See modifyAttributes(Name, int, Attributes) for details.
        参数：
        name - the name of the object whose attributes will be updated
        mod_op - the modification operation, one of: ADD_ATTRIBUTE, REPLACE_ATTRIBUTE, REMOVE_ATTRIBUTE.
        attrs - the attributes to be used for the modification; may not be null
        抛出：
        AttributeModificationException - if the modification cannot be completed successfully
        NamingException - if a naming exception is encountered

      • modifyAttributes

        void modifyAttributes(Name name,
                    ModificationItem[] mods)
                      throws NamingException
        Modifies the attributes associated with a named object using an ordered list of modifications. The modifications are performed in the order specified. Each modification specifies a modification operation code and an attribute on which to operate. Where possible, the modifications are performed atomically.
        参数：
        name - the name of the object whose attributes will be updated
        mods - an ordered sequence of modifications to be performed; may not be null
        抛出：
        AttributeModificationException - if the modifications cannot be completed successfully
        NamingException - if a naming exception is encountered
        另请参见：
        modifyAttributes(Name, int, Attributes), ModificationItem

      • modifyAttributes

        void modifyAttributes(String name,
                    ModificationItem[] mods)
                      throws NamingException
        Modifies the attributes associated with a named object using an ordered list of modifications. See modifyAttributes(Name, ModificationItem[]) for details.
        参数：
        name - the name of the object whose attributes will be updated
        mods - an ordered sequence of modifications to be performed; may not be null
        抛出：
        AttributeModificationException - if the modifications cannot be completed successfully
        NamingException - if a naming exception is encountered

      • bind

        void bind(Name name,
        Object obj,
        Attributes attrs)
          throws NamingException
        Binds a name to an object, along with associated attributes. If attrs is null, the resulting binding will have the attributes associated with obj if obj is a DirContext, and no attributes otherwise. If attrs is non-null, the resulting binding will have attrs as its attributes; any attributes associated with obj are ignored.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered
        另请参见：
        Context.bind(Name, Object), rebind(Name, Object, Attributes)

      • bind

        void bind(String name,
        Object obj,
        Attributes attrs)
          throws NamingException
        Binds a name to an object, along with associated attributes. See bind(Name, Object, Attributes) for details.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered

      • rebind

        void rebind(Name name,
          Object obj,
          Attributes attrs)
            throws NamingException
        Binds a name to an object, along with associated attributes, overwriting any existing binding. If attrs is null and obj is a DirContext, the attributes from obj are used. If attrs is null and obj is not a DirContext, any existing attributes associated with the object already bound in the directory remain unchanged. If attrs is non-null, any existing attributes associated with the object already bound in the directory are removed and attrs is associated with the named object. If obj is a DirContext and attrs is non-null, the attributes of obj are ignored.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered
        另请参见：
        Context.bind(Name, Object), bind(Name, Object, Attributes)

      • rebind

        void rebind(String name,
          Object obj,
          Attributes attrs)
            throws NamingException
        Binds a name to an object, along with associated attributes, overwriting any existing binding. See rebind(Name, Object, Attributes) for details.
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered

      • createSubcontext

        DirContext createSubcontext(Name name,
                          Attributes attrs)
                            throws NamingException
        Creates and binds a new context, along with associated attributes. This method creates a new subcontext with the given name, binds it in the target context (that named by all but terminal atomic component of the name), and associates the supplied attributes with the newly created object. All intermediate and target contexts must already exist. If attrs is null, this method is equivalent to Context.createSubcontext().
        参数：
        name - the name of the context to create; may not be empty
        attrs - the attributes to associate with the newly created context
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if the name is already bound
        InvalidAttributesException - if attrs does not contain all the mandatory attributes required for creation
        NamingException - if a naming exception is encountered
        另请参见：
        Context.createSubcontext(Name)

      • createSubcontext

        DirContext createSubcontext(String name,
                          Attributes attrs)
                            throws NamingException
        Creates and binds a new context, along with associated attributes. See createSubcontext(Name, Attributes) for details.
        参数：
        name - the name of the context to create; may not be empty
        attrs - the attributes to associate with the newly created context
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if the name is already bound
        InvalidAttributesException - if attrs does not contain all the mandatory attributes required for creation
        NamingException - if a naming exception is encountered

      • getSchema

        DirContext getSchema(Name name)
                     throws NamingException
        Retrieves the schema associated with the named object. The schema describes rules regarding the structure of the namespace and the attributes stored within it. The schema specifies what types of objects can be added to the directory and where they can be added; what mandatory and optional attributes an object can have. The range of support for schemas is directory-specific.

        This method returns the root of the schema information tree that is applicable to the named object. Several named objects (or even an entire directory) might share the same schema.

        Issues such as structure and contents of the schema tree, permission to modify to the contents of the schema tree, and the effect of such modifications on the directory are dependent on the underlying directory.

        参数：
        name - the name of the object whose schema is to be retrieved
        返回：
        the schema associated with the context; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchema

        DirContext getSchema(String name)
                     throws NamingException
        Retrieves the schema associated with the named object. See getSchema(Name) for details.
        参数：
        name - the name of the object whose schema is to be retrieved
        返回：
        the schema associated with the context; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchemaClassDefinition

        DirContext getSchemaClassDefinition(Name name)
                                    throws NamingException
        Retrieves a context containing the schema objects of the named object's class definitions.

        One category of information found in directory schemas is class definitions. An "object class" definition specifies the object's type and what attributes (mandatory and optional) the object must/can have. Note that the term "object class" being referred to here is in the directory sense rather than in the Java sense. For example, if the named object is a directory object of "Person" class, getSchemaClassDefinition() would return a DirContext representing the (directory's) object class definition of "Person".

        The information that can be retrieved from an object class definition is directory-dependent.

        Prior to JNDI 1.2, this method returned a single schema object representing the class definition of the named object. Since JNDI 1.2, this method returns a DirContext containing all of the named object's class definitions.

        参数：
        name - the name of the object whose object class definition is to be retrieved
        返回：
        the DirContext containing the named object's class definitions; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchemaClassDefinition

        DirContext getSchemaClassDefinition(String name)
                                    throws NamingException
        Retrieves a context containing the schema objects of the named object's class definitions. See getSchemaClassDefinition(Name) for details.
        参数：
        name - the name of the object whose object class definition is to be retrieved
        返回：
        the DirContext containing the named object's class definitions; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • search

        NamingEnumeration<SearchResult> search(Name name,
                                     Attributes matchingAttributes,
                                     String[] attributesToReturn)
                                       throws NamingException
        Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes. The search is performed using the default SearchControls settings.

        For an object to be selected, each attribute in matchingAttributes must match some attribute of the object. If matchingAttributes is empty or null, all objects in the target context are returned.

        An attribute A1 in matchingAttributes is considered to match an attribute A2 of an object if A1 and A2 have the same identifier, and each value of A1 is equal to some value of A2. This implies that the order of values is not significant, and that A2 may contain "extra" values not found in A1 without affecting the comparison. It also implies that if A1 has no values, then testing for a match is equivalent to testing for the presence of an attribute A2 with the same identifier.

        The precise definition of "equality" used in comparing attribute values is defined by the underlying directory service. It might use the Object.equals method, for example, or might use a schema to specify a different equality operation. For matching based on operations other than equality (such as substring comparison) use the version of the search method that takes a filter argument.

        When changes are made to this DirContext, the effect on enumerations returned by prior calls to this method is undefined.

        If the object does not have the attribute specified, the directory will ignore the nonexistent attribute and return the requested attributes that the object does have.

        A directory might return more attributes than was requested (see Attribute Type Names in the class description), but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for. If empty or null, all objects in the target context are returned.
        attributesToReturn - the attributes to return. null indicates that all attributes are to be returned; an empty array indicates that none are to be returned.
        返回：
        a non-null enumeration of SearchResult objects. Each SearchResult contains the attributes identified by attributesToReturn and the name of the corresponding object, named relative to the context named by name.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        SearchControls, SearchResult, search(Name, String, Object[], SearchControls)

      • search

        NamingEnumeration<SearchResult> search(String name,
                                     Attributes matchingAttributes,
                                     String[] attributesToReturn)
                                       throws NamingException
        Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes. See search(Name, Attributes, String[]) for details.
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        attributesToReturn - the attributes to return
        返回：
        a non-null enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered

      • search

        NamingEnumeration<SearchResult> search(Name name,
                                     Attributes matchingAttributes)
                                       throws NamingException
        Searches in a single context for objects that contain a specified set of attributes. This method returns all the attributes of such objects. It is equivalent to supplying null as the atributesToReturn parameter to the method search(Name, Attributes, String[]).
        See search(Name, Attributes, String[]) for a full description.
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        返回：
        an enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        search(Name, Attributes, String[])

      • search

        NamingEnumeration<SearchResult> search(String name,
                                     Attributes matchingAttributes)
                                       throws NamingException
        Searches in a single context for objects that contain a specified set of attributes. See search(Name, Attributes) for details.
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        返回：
        an enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered

      • search

        NamingEnumeration<SearchResult> search(Name name,
                                     String filter,
                                     SearchControls cons)
                                       throws NamingException
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls.

        The format and interpretation of filter follows RFC 2254 with the following interpretations for attr and value mentioned in the RFC.

        attr is the attribute's identifier.

        value is the string representation the attribute's value. The translation of this string representation into the attribute's value is directory-specific.

        For the assertion "someCount=127", for example, attr is "someCount" and value is "127". The provider determines, based on the attribute ID ("someCount") (and possibly its schema), that the attribute's value is an integer. It then parses the string "127" appropriately.

        Any non-ASCII characters in the filter string should be represented by the appropriate Java (Unicode) characters, and not encoded as UTF-8 octets. Alternately, the "backslash-hexcode" notation described in RFC 2254 may be used.

        If the directory does not support a string representation of some or all of its attributes, the form of search that accepts filter arguments in the form of Objects can be used instead. The service provider for such a directory would then translate the filter arguments to its service-specific representation for filter evaluation. See search(Name, String, Object[], SearchControls).

        RFC 2254 defines certain operators for the filter, including substring matches, equality, approximate match, greater than, less than. These operators are mapped to operators with corresponding semantics in the underlying directory. For example, for the equals operator, suppose the directory has a matching rule defining "equality" of the attributes in the filter. This rule would be used for checking equality of the attributes specified in the filter with the attributes of objects in the directory. Similarly, if the directory has a matching rule for ordering, this rule would be used for making "greater than" and "less than" comparisons.

        Not all of the operators defined in RFC 2254 are applicable to all attributes. When an operator is not applicable, the exception InvalidSearchFilterException is thrown.

        The result is returned in an enumeration of SearchResults. Each SearchResult contains the name of the object and other information about the object (see SearchResult). The name is either relative to the target context of the search (which is named by the name parameter), or it is a URL string. If the target context is included in the enumeration (as is possible when cons specifies a search scope of SearchControls.OBJECT_SCOPE or SearchControls.SUBSTREE_SCOPE), its name is the empty string. The SearchResult may also contain attributes of the matching object if the cons argument specified that attributes be returned.

        If the object does not have a requested attribute, that nonexistent attribute will be ignored. Those requested attributes that the object does have will be returned.

        A directory might return more attributes than were requested (see Attribute Type Names in the class description) but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        参数：
        name - the name of the context or object to search
        filter - the filter expression to use for the search; may not be null
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        InvalidSearchFilterException - if the search filter specified is not supported or understood by the underlying directory
        InvalidSearchControlsException - if the search controls contain invalid settings
        NamingException - if a naming exception is encountered
        另请参见：
        search(Name, String, Object[], SearchControls), SearchControls, SearchResult

      • search

        NamingEnumeration<SearchResult> search(String name,
                                     String filter,
                                     SearchControls cons)
                                       throws NamingException
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls. See search(Name, String, SearchControls) for details.
        参数：
        name - the name of the context or object to search
        filter - the filter expression to use for the search; may not be null
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults for the objects that satisfy the filter.
        抛出：
        InvalidSearchFilterException - if the search filter specified is not supported or understood by the underlying directory
        InvalidSearchControlsException - if the search controls contain invalid settings
        NamingException - if a naming exception is encountered

      • search

        NamingEnumeration<SearchResult> search(Name name,
                                     String filterExpr,
                                     Object[] filterArgs,
                                     SearchControls cons)
                                       throws NamingException
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls.

        The interpretation of filterExpr is based on RFC 2254. It may additionally contain variables of the form {i} -- where i is an integer -- that refer to objects in the filterArgs array. The interpretation of filterExpr is otherwise identical to that of the filter parameter of the method search(Name, String, SearchControls).

        When a variable {i} appears in a search filter, it indicates that the filter argument filterArgs[i] is to be used in that place. Such variables may be used wherever an attr, value, or matchingrule production appears in the filter grammar of RFC 2254, section 4. When a string-valued filter argument is substituted for a variable, the filter is interpreted as if the string were given in place of the variable, with any characters having special significance within filters (such as '*') having been escaped according to the rules of RFC 2254.

        For directories that do not use a string representation for some or all of their attributes, the filter argument corresponding to an attribute value may be of a type other than String. Directories that support unstructured binary-valued attributes, for example, should accept byte arrays as filter arguments. The interpretation (if any) of filter arguments of any other type is determined by the service provider for that directory, which maps the filter operations onto operations with corresponding semantics in the underlying directory.

        This method returns an enumeration of the results. Each element in the enumeration contains the name of the object and other information about the object (see SearchResult). The name is either relative to the target context of the search (which is named by the name parameter), or it is a URL string. If the target context is included in the enumeration (as is possible when cons specifies a search scope of SearchControls.OBJECT_SCOPE or SearchControls.SUBSTREE_SCOPE), its name is the empty string.

        The SearchResult may also contain attributes of the matching object if the cons argument specifies that attributes be returned.

        If the object does not have a requested attribute, that nonexistent attribute will be ignored. Those requested attributes that the object does have will be returned.

        A directory might return more attributes than were requested (see Attribute Type Names in the class description) but is not allowed to return arbitrary, unrelated attributes.

        If a search filter with invalid variable substitutions is provided to this method, the result is undefined. When changes are made to this DirContext, the effect on enumerations returned by prior calls to this method is undefined.

        See also Operational Attributes in the class description.

        参数：
        name - the name of the context or object to search
        filterExpr - the filter expression to use for the search. The expression may contain variables of the form "{i}" where i is a nonnegative integer. May not be null.
        filterArgs - the array of arguments to substitute for the variables in filterExpr. The value of filterArgs[i] will replace each occurrence of "{i}". If null, equivalent to an empty array.
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        ArrayIndexOutOfBoundsException - if filterExpr contains {i} expressions where i is outside the bounds of the array filterArgs
        InvalidSearchControlsException - if cons contains invalid settings
        InvalidSearchFilterException - if filterExpr with filterArgs represents an invalid search filter
        NamingException - if a naming exception is encountered
        另请参见：
        search(Name, Attributes, String[]), MessageFormat

      • search

        NamingEnumeration<SearchResult> search(String name,
                                     String filterExpr,
                                     Object[] filterArgs,
                                     SearchControls cons)
                                       throws NamingException
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls. See search(Name, String, Object[], SearchControls) for details.
        参数：
        name - the name of the context or object to search
        filterExpr - the filter expression to use for the search. The expression may contain variables of the form "{i}" where i is a nonnegative integer. May not be null.
        filterArgs - the array of arguments to substitute for the variables in filterExpr. The value of filterArgs[i] will replace each occurrence of "{i}". If null, equivalent to an empty array.
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        ArrayIndexOutOfBoundsException - if filterExpr contains {i} expressions where i is outside the bounds of the array filterArgs
        InvalidSearchControlsException - if cons contains invalid settings
        InvalidSearchFilterException - if filterExpr with filterArgs represents an invalid search filter
        NamingException - if a naming exception is encountered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


InitialDirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 InitialDirContext

  • java.lang.Object
    • javax.naming.InitialContext
      • javax.naming.directory.InitialDirContext
  • 所有已实现的接口：
    Context, DirContext
    直接已知子类：
    InitialLdapContext

    public class InitialDirContext
extends InitialContext
implements DirContext
    This class is the starting context for performing directory operations. The documentation in the class description of InitialContext (including those for synchronization) apply here.
    从以下版本开始：
    1.3
    另请参见：
    InitialContext

    • 字段摘要

      • Fields inherited from class javax.naming.InitialContext

        defaultInitCtx, gotDefault, myProps

      • 字段 - 继承于接口 javax.naming.directory.DirContext

        ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        InitialDirContext()
      Constructs an initial DirContext.
      protected InitialDirContext(boolean lazy)
      Constructs an initial DirContext with the option of not initializing it.
        InitialDirContext(Hashtable<?,?> environment)
      Constructs an initial DirContext using the supplied environment.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void bind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      void bind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      DirContext createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext createSubcontext(String name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      Attributes getAttributes(Name name)
      Retrieves all of the attributes associated with a named object.
      Attributes getAttributes(Name name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      Attributes getAttributes(String name)
      Retrieves all of the attributes associated with a named object.
      Attributes getAttributes(String name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      DirContext getSchema(Name name)
      Retrieves the schema associated with the named object.
      DirContext getSchema(String name)
      Retrieves the schema associated with the named object.
      DirContext getSchemaClassDefinition(Name name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      DirContext getSchemaClassDefinition(String name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      void modifyAttributes(Name name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void modifyAttributes(Name name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void modifyAttributes(String name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void modifyAttributes(String name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void rebind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      void rebind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      NamingEnumeration<SearchResult> search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.

      • 方法 - 继承于类 javax.naming.InitialContext

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, doLookup, doLookup, getDefaultInitCtx, getEnvironment, getNameInNamespace, getNameParser, getNameParser, getURLOrDefaultInitCtx, getURLOrDefaultInitCtx, init, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 构造方法详细信息

      • InitialDirContext

        protected InitialDirContext(boolean lazy)
                     throws NamingException
        Constructs an initial DirContext with the option of not initializing it. This may be used by a constructor in a subclass when the value of the environment parameter is not yet known at the time the InitialDirContext constructor is called. The subclass's constructor will call this constructor, compute the value of the environment, and then call init() before returning.
        参数：
        lazy - true means do not initialize the initial DirContext; false is equivalent to calling new InitialDirContext()
        抛出：
        NamingException - if a naming exception is encountered
        从以下版本开始：
        1.3
        另请参见：
        InitialContext.init(Hashtable)

      • InitialDirContext

        public InitialDirContext()
                  throws NamingException
        Constructs an initial DirContext. No environment properties are supplied. Equivalent to new InitialDirContext(null).
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        InitialDirContext(Hashtable)

      • InitialDirContext

        public InitialDirContext(Hashtable<?,?> environment)
                  throws NamingException
        Constructs an initial DirContext using the supplied environment. Environment properties are discussed in the javax.naming.InitialContext class description.

        This constructor will not modify environment or save a reference to it, but may save a clone. Caller should not modify mutable keys and values in environment after it has been passed to the constructor.

        参数：
        environment - environment used to create the initial DirContext. Null indicates an empty environment.
        抛出：
        NamingException - if a naming exception is encountered

    • 方法详细信息

      • getAttributes

        public Attributes getAttributes(String name)
                         throws NamingException
        从接口复制的描述： DirContext
        Retrieves all of the attributes associated with a named object. See DirContext.getAttributes(Name) for details.
        指定者：
        getAttributes in interface DirContext
        参数：
        name - the name of the object from which to retrieve attributes
        返回：
        the set of attributes associated with name
        抛出：
        NamingException - if a naming exception is encountered

      • getAttributes

        public Attributes getAttributes(String name,
                       String[] attrIds)
                         throws NamingException
        从接口复制的描述： DirContext
        Retrieves selected attributes associated with a named object. See DirContext.getAttributes(Name, String[]) for details.
        指定者：
        getAttributes in interface DirContext
        参数：
        name - The name of the object from which to retrieve attributes
        attrIds - the identifiers of the attributes to retrieve. null indicates that all attributes should be retrieved; an empty array indicates that none should be retrieved.
        返回：
        the requested attributes; never null
        抛出：
        NamingException - if a naming exception is encountered

      • getAttributes

        public Attributes getAttributes(Name name)
                         throws NamingException
        从接口复制的描述： DirContext
        Retrieves all of the attributes associated with a named object. See the class description regarding attribute models, attribute type names, and operational attributes.
        指定者：
        getAttributes in interface DirContext
        参数：
        name - the name of the object from which to retrieve attributes
        返回：
        the set of attributes associated with name. Returns an empty attribute set if name has no attributes; never null.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.getAttributes(String), DirContext.getAttributes(Name, String[])

      • getAttributes

        public Attributes getAttributes(Name name,
                       String[] attrIds)
                         throws NamingException
        从接口复制的描述： DirContext
        Retrieves selected attributes associated with a named object. See the class description regarding attribute models, attribute type names, and operational attributes.

        If the object does not have an attribute specified, the directory will ignore the nonexistent attribute and return those requested attributes that the object does have.

        A directory might return more attributes than was requested (see Attribute Type Names in the class description), but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        指定者：
        getAttributes in interface DirContext
        参数：
        name - the name of the object from which to retrieve attributes
        attrIds - the identifiers of the attributes to retrieve. null indicates that all attributes should be retrieved; an empty array indicates that none should be retrieved.
        返回：
        the requested attributes; never null
        抛出：
        NamingException - if a naming exception is encountered

      • modifyAttributes

        public void modifyAttributes(String name,
                    int mod_op,
                    Attributes attrs)
                      throws NamingException
        从接口复制的描述： DirContext
        Modifies the attributes associated with a named object. See DirContext.modifyAttributes(Name, int, Attributes) for details.
        指定者：
        modifyAttributes in interface DirContext
        参数：
        name - the name of the object whose attributes will be updated
        mod_op - the modification operation, one of: ADD_ATTRIBUTE, REPLACE_ATTRIBUTE, REMOVE_ATTRIBUTE.
        attrs - the attributes to be used for the modification; may not be null
        抛出：
        AttributeModificationException - if the modification cannot be completed successfully
        NamingException - if a naming exception is encountered

      • modifyAttributes

        public void modifyAttributes(Name name,
                    int mod_op,
                    Attributes attrs)
                      throws NamingException
        从接口复制的描述： DirContext
        Modifies the attributes associated with a named object. The order of the modifications is not specified. Where possible, the modifications are performed atomically.
        指定者：
        modifyAttributes in interface DirContext
        参数：
        name - the name of the object whose attributes will be updated
        mod_op - the modification operation, one of: ADD_ATTRIBUTE, REPLACE_ATTRIBUTE, REMOVE_ATTRIBUTE.
        attrs - the attributes to be used for the modification; may not be null
        抛出：
        AttributeModificationException - if the modification cannot be completed successfully
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.modifyAttributes(Name, ModificationItem[])

      • modifyAttributes

        public void modifyAttributes(String name,
                    ModificationItem[] mods)
                      throws NamingException
        从接口复制的描述： DirContext
        Modifies the attributes associated with a named object using an ordered list of modifications. See DirContext.modifyAttributes(Name, ModificationItem[]) for details.
        指定者：
        modifyAttributes in interface DirContext
        参数：
        name - the name of the object whose attributes will be updated
        mods - an ordered sequence of modifications to be performed; may not be null
        抛出：
        AttributeModificationException - if the modifications cannot be completed successfully
        NamingException - if a naming exception is encountered

      • modifyAttributes

        public void modifyAttributes(Name name,
                    ModificationItem[] mods)
                      throws NamingException
        从接口复制的描述： DirContext
        Modifies the attributes associated with a named object using an ordered list of modifications. The modifications are performed in the order specified. Each modification specifies a modification operation code and an attribute on which to operate. Where possible, the modifications are performed atomically.
        指定者：
        modifyAttributes in interface DirContext
        参数：
        name - the name of the object whose attributes will be updated
        mods - an ordered sequence of modifications to be performed; may not be null
        抛出：
        AttributeModificationException - if the modifications cannot be completed successfully
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.modifyAttributes(Name, int, Attributes), ModificationItem

      • bind

        public void bind(String name,
        Object obj,
        Attributes attrs)
          throws NamingException
        从接口复制的描述： DirContext
        Binds a name to an object, along with associated attributes. See DirContext.bind(Name, Object, Attributes) for details.
        指定者：
        bind in interface DirContext
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered

      • bind

        public void bind(Name name,
        Object obj,
        Attributes attrs)
          throws NamingException
        从接口复制的描述： DirContext
        Binds a name to an object, along with associated attributes. If attrs is null, the resulting binding will have the attributes associated with obj if obj is a DirContext, and no attributes otherwise. If attrs is non-null, the resulting binding will have attrs as its attributes; any attributes associated with obj are ignored.
        指定者：
        bind in interface DirContext
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        NameAlreadyBoundException - if name is already bound
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered
        另请参见：
        Context.bind(Name, Object), DirContext.rebind(Name, Object, Attributes)

      • rebind

        public void rebind(String name,
          Object obj,
          Attributes attrs)
            throws NamingException
        从接口复制的描述： DirContext
        Binds a name to an object, along with associated attributes, overwriting any existing binding. See DirContext.rebind(Name, Object, Attributes) for details.
        指定者：
        rebind in interface DirContext
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered

      • rebind

        public void rebind(Name name,
          Object obj,
          Attributes attrs)
            throws NamingException
        从接口复制的描述： DirContext
        Binds a name to an object, along with associated attributes, overwriting any existing binding. If attrs is null and obj is a DirContext, the attributes from obj are used. If attrs is null and obj is not a DirContext, any existing attributes associated with the object already bound in the directory remain unchanged. If attrs is non-null, any existing attributes associated with the object already bound in the directory are removed and attrs is associated with the named object. If obj is a DirContext and attrs is non-null, the attributes of obj are ignored.
        指定者：
        rebind in interface DirContext
        参数：
        name - the name to bind; may not be empty
        obj - the object to bind; possibly null
        attrs - the attributes to associate with the binding
        抛出：
        InvalidAttributesException - if some "mandatory" attributes of the binding are not supplied
        NamingException - if a naming exception is encountered
        另请参见：
        Context.bind(Name, Object), DirContext.bind(Name, Object, Attributes)

      • createSubcontext

        public DirContext createSubcontext(String name,
                          Attributes attrs)
                            throws NamingException
        从接口复制的描述： DirContext
        Creates and binds a new context, along with associated attributes. See DirContext.createSubcontext(Name, Attributes) for details.
        指定者：
        createSubcontext in interface DirContext
        参数：
        name - the name of the context to create; may not be empty
        attrs - the attributes to associate with the newly created context
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if the name is already bound
        InvalidAttributesException - if attrs does not contain all the mandatory attributes required for creation
        NamingException - if a naming exception is encountered

      • createSubcontext

        public DirContext createSubcontext(Name name,
                          Attributes attrs)
                            throws NamingException
        从接口复制的描述： DirContext
        Creates and binds a new context, along with associated attributes. This method creates a new subcontext with the given name, binds it in the target context (that named by all but terminal atomic component of the name), and associates the supplied attributes with the newly created object. All intermediate and target contexts must already exist. If attrs is null, this method is equivalent to Context.createSubcontext().
        指定者：
        createSubcontext in interface DirContext
        参数：
        name - the name of the context to create; may not be empty
        attrs - the attributes to associate with the newly created context
        返回：
        the newly created context
        抛出：
        NameAlreadyBoundException - if the name is already bound
        InvalidAttributesException - if attrs does not contain all the mandatory attributes required for creation
        NamingException - if a naming exception is encountered
        另请参见：
        Context.createSubcontext(Name)

      • getSchema

        public DirContext getSchema(String name)
                     throws NamingException
        从接口复制的描述： DirContext
        Retrieves the schema associated with the named object. See DirContext.getSchema(Name) for details.
        指定者：
        getSchema in interface DirContext
        参数：
        name - the name of the object whose schema is to be retrieved
        返回：
        the schema associated with the context; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchema

        public DirContext getSchema(Name name)
                     throws NamingException
        从接口复制的描述： DirContext
        Retrieves the schema associated with the named object. The schema describes rules regarding the structure of the namespace and the attributes stored within it. The schema specifies what types of objects can be added to the directory and where they can be added; what mandatory and optional attributes an object can have. The range of support for schemas is directory-specific.

        This method returns the root of the schema information tree that is applicable to the named object. Several named objects (or even an entire directory) might share the same schema.

        Issues such as structure and contents of the schema tree, permission to modify to the contents of the schema tree, and the effect of such modifications on the directory are dependent on the underlying directory.

        指定者：
        getSchema in interface DirContext
        参数：
        name - the name of the object whose schema is to be retrieved
        返回：
        the schema associated with the context; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchemaClassDefinition

        public DirContext getSchemaClassDefinition(String name)
                                    throws NamingException
        从接口复制的描述： DirContext
        Retrieves a context containing the schema objects of the named object's class definitions. See DirContext.getSchemaClassDefinition(Name) for details.
        指定者：
        getSchemaClassDefinition in interface DirContext
        参数：
        name - the name of the object whose object class definition is to be retrieved
        返回：
        the DirContext containing the named object's class definitions; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • getSchemaClassDefinition

        public DirContext getSchemaClassDefinition(Name name)
                                    throws NamingException
        从接口复制的描述： DirContext
        Retrieves a context containing the schema objects of the named object's class definitions.

        One category of information found in directory schemas is class definitions. An "object class" definition specifies the object's type and what attributes (mandatory and optional) the object must/can have. Note that the term "object class" being referred to here is in the directory sense rather than in the Java sense. For example, if the named object is a directory object of "Person" class, getSchemaClassDefinition() would return a DirContext representing the (directory's) object class definition of "Person".

        The information that can be retrieved from an object class definition is directory-dependent.

        Prior to JNDI 1.2, this method returned a single schema object representing the class definition of the named object. Since JNDI 1.2, this method returns a DirContext containing all of the named object's class definitions.

        指定者：
        getSchemaClassDefinition in interface DirContext
        参数：
        name - the name of the object whose object class definition is to be retrieved
        返回：
        the DirContext containing the named object's class definitions; never null
        抛出：
        OperationNotSupportedException - if schema not supported
        NamingException - if a naming exception is encountered

      • search

        public NamingEnumeration<SearchResult> search(String name,
                                     Attributes matchingAttributes)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in a single context for objects that contain a specified set of attributes. See DirContext.search(Name, Attributes) for details.
        指定者：
        search in interface DirContext
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        返回：
        an enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered

      • search

        public NamingEnumeration<SearchResult> search(Name name,
                                     Attributes matchingAttributes)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in a single context for objects that contain a specified set of attributes. This method returns all the attributes of such objects. It is equivalent to supplying null as the atributesToReturn parameter to the method search(Name, Attributes, String[]).
        See DirContext.search(Name, Attributes, String[]) for a full description.
        指定者：
        search in interface DirContext
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        返回：
        an enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.search(Name, Attributes, String[])

      • search

        public NamingEnumeration<SearchResult> search(String name,
                                     Attributes matchingAttributes,
                                     String[] attributesToReturn)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes. See DirContext.search(Name, Attributes, String[]) for details.
        指定者：
        search in interface DirContext
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for
        attributesToReturn - the attributes to return
        返回：
        a non-null enumeration of SearchResult objects
        抛出：
        NamingException - if a naming exception is encountered

      • search

        public NamingEnumeration<SearchResult> search(Name name,
                                     Attributes matchingAttributes,
                                     String[] attributesToReturn)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes. The search is performed using the default SearchControls settings.

        For an object to be selected, each attribute in matchingAttributes must match some attribute of the object. If matchingAttributes is empty or null, all objects in the target context are returned.

        An attribute A1 in matchingAttributes is considered to match an attribute A2 of an object if A1 and A2 have the same identifier, and each value of A1 is equal to some value of A2. This implies that the order of values is not significant, and that A2 may contain "extra" values not found in A1 without affecting the comparison. It also implies that if A1 has no values, then testing for a match is equivalent to testing for the presence of an attribute A2 with the same identifier.

        The precise definition of "equality" used in comparing attribute values is defined by the underlying directory service. It might use the Object.equals method, for example, or might use a schema to specify a different equality operation. For matching based on operations other than equality (such as substring comparison) use the version of the search method that takes a filter argument.

        When changes are made to this DirContext, the effect on enumerations returned by prior calls to this method is undefined.

        If the object does not have the attribute specified, the directory will ignore the nonexistent attribute and return the requested attributes that the object does have.

        A directory might return more attributes than was requested (see Attribute Type Names in the class description), but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        指定者：
        search in interface DirContext
        参数：
        name - the name of the context to search
        matchingAttributes - the attributes to search for. If empty or null, all objects in the target context are returned.
        attributesToReturn - the attributes to return. null indicates that all attributes are to be returned; an empty array indicates that none are to be returned.
        返回：
        a non-null enumeration of SearchResult objects. Each SearchResult contains the attributes identified by attributesToReturn and the name of the corresponding object, named relative to the context named by name.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        SearchControls, SearchResult, DirContext.search(Name, String, Object[], SearchControls)

      • search

        public NamingEnumeration<SearchResult> search(String name,
                                     String filter,
                                     SearchControls cons)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls. See DirContext.search(Name, String, SearchControls) for details.
        指定者：
        search in interface DirContext
        参数：
        name - the name of the context or object to search
        filter - the filter expression to use for the search; may not be null
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults for the objects that satisfy the filter.
        抛出：
        InvalidSearchFilterException - if the search filter specified is not supported or understood by the underlying directory
        InvalidSearchControlsException - if the search controls contain invalid settings
        NamingException - if a naming exception is encountered

      • search

        public NamingEnumeration<SearchResult> search(Name name,
                                     String filter,
                                     SearchControls cons)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls.

        The format and interpretation of filter follows RFC 2254 with the following interpretations for attr and value mentioned in the RFC.

        attr is the attribute's identifier.

        value is the string representation the attribute's value. The translation of this string representation into the attribute's value is directory-specific.

        For the assertion "someCount=127", for example, attr is "someCount" and value is "127". The provider determines, based on the attribute ID ("someCount") (and possibly its schema), that the attribute's value is an integer. It then parses the string "127" appropriately.

        Any non-ASCII characters in the filter string should be represented by the appropriate Java (Unicode) characters, and not encoded as UTF-8 octets. Alternately, the "backslash-hexcode" notation described in RFC 2254 may be used.

        If the directory does not support a string representation of some or all of its attributes, the form of search that accepts filter arguments in the form of Objects can be used instead. The service provider for such a directory would then translate the filter arguments to its service-specific representation for filter evaluation. See search(Name, String, Object[], SearchControls).

        RFC 2254 defines certain operators for the filter, including substring matches, equality, approximate match, greater than, less than. These operators are mapped to operators with corresponding semantics in the underlying directory. For example, for the equals operator, suppose the directory has a matching rule defining "equality" of the attributes in the filter. This rule would be used for checking equality of the attributes specified in the filter with the attributes of objects in the directory. Similarly, if the directory has a matching rule for ordering, this rule would be used for making "greater than" and "less than" comparisons.

        Not all of the operators defined in RFC 2254 are applicable to all attributes. When an operator is not applicable, the exception InvalidSearchFilterException is thrown.

        The result is returned in an enumeration of SearchResults. Each SearchResult contains the name of the object and other information about the object (see SearchResult). The name is either relative to the target context of the search (which is named by the name parameter), or it is a URL string. If the target context is included in the enumeration (as is possible when cons specifies a search scope of SearchControls.OBJECT_SCOPE or SearchControls.SUBSTREE_SCOPE), its name is the empty string. The SearchResult may also contain attributes of the matching object if the cons argument specified that attributes be returned.

        If the object does not have a requested attribute, that nonexistent attribute will be ignored. Those requested attributes that the object does have will be returned.

        A directory might return more attributes than were requested (see Attribute Type Names in the class description) but is not allowed to return arbitrary, unrelated attributes.

        See also Operational Attributes in the class description.

        指定者：
        search in interface DirContext
        参数：
        name - the name of the context or object to search
        filter - the filter expression to use for the search; may not be null
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        InvalidSearchFilterException - if the search filter specified is not supported or understood by the underlying directory
        InvalidSearchControlsException - if the search controls contain invalid settings
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.search(Name, String, Object[], SearchControls), SearchControls, SearchResult

      • search

        public NamingEnumeration<SearchResult> search(String name,
                                     String filterExpr,
                                     Object[] filterArgs,
                                     SearchControls cons)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls. See DirContext.search(Name, String, Object[], SearchControls) for details.
        指定者：
        search in interface DirContext
        参数：
        name - the name of the context or object to search
        filterExpr - the filter expression to use for the search. The expression may contain variables of the form "{i}" where i is a nonnegative integer. May not be null.
        filterArgs - the array of arguments to substitute for the variables in filterExpr. The value of filterArgs[i] will replace each occurrence of "{i}". If null, equivalent to an empty array.
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        InvalidSearchControlsException - if cons contains invalid settings
        InvalidSearchFilterException - if filterExpr with filterArgs represents an invalid search filter
        NamingException - if a naming exception is encountered

      • search

        public NamingEnumeration<SearchResult> search(Name name,
                                     String filterExpr,
                                     Object[] filterArgs,
                                     SearchControls cons)
                                       throws NamingException
        从接口复制的描述： DirContext
        Searches in the named context or object for entries that satisfy the given search filter. Performs the search as specified by the search controls.

        The interpretation of filterExpr is based on RFC 2254. It may additionally contain variables of the form {i} -- where i is an integer -- that refer to objects in the filterArgs array. The interpretation of filterExpr is otherwise identical to that of the filter parameter of the method search(Name, String, SearchControls).

        When a variable {i} appears in a search filter, it indicates that the filter argument filterArgs[i] is to be used in that place. Such variables may be used wherever an attr, value, or matchingrule production appears in the filter grammar of RFC 2254, section 4. When a string-valued filter argument is substituted for a variable, the filter is interpreted as if the string were given in place of the variable, with any characters having special significance within filters (such as '*') having been escaped according to the rules of RFC 2254.

        For directories that do not use a string representation for some or all of their attributes, the filter argument corresponding to an attribute value may be of a type other than String. Directories that support unstructured binary-valued attributes, for example, should accept byte arrays as filter arguments. The interpretation (if any) of filter arguments of any other type is determined by the service provider for that directory, which maps the filter operations onto operations with corresponding semantics in the underlying directory.

        This method returns an enumeration of the results. Each element in the enumeration contains the name of the object and other information about the object (see SearchResult). The name is either relative to the target context of the search (which is named by the name parameter), or it is a URL string. If the target context is included in the enumeration (as is possible when cons specifies a search scope of SearchControls.OBJECT_SCOPE or SearchControls.SUBSTREE_SCOPE), its name is the empty string.

        The SearchResult may also contain attributes of the matching object if the cons argument specifies that attributes be returned.

        If the object does not have a requested attribute, that nonexistent attribute will be ignored. Those requested attributes that the object does have will be returned.

        A directory might return more attributes than were requested (see Attribute Type Names in the class description) but is not allowed to return arbitrary, unrelated attributes.

        If a search filter with invalid variable substitutions is provided to this method, the result is undefined. When changes are made to this DirContext, the effect on enumerations returned by prior calls to this method is undefined.

        See also Operational Attributes in the class description.

        指定者：
        search in interface DirContext
        参数：
        name - the name of the context or object to search
        filterExpr - the filter expression to use for the search. The expression may contain variables of the form "{i}" where i is a nonnegative integer. May not be null.
        filterArgs - the array of arguments to substitute for the variables in filterExpr. The value of filterArgs[i] will replace each occurrence of "{i}". If null, equivalent to an empty array.
        cons - the search controls that control the search. If null, the default search controls are used (equivalent to (new SearchControls())).
        返回：
        an enumeration of SearchResults of the objects that satisfy the filter; never null
        抛出：
        InvalidSearchControlsException - if cons contains invalid settings
        InvalidSearchFilterException - if filterExpr with filterArgs represents an invalid search filter
        NamingException - if a naming exception is encountered
        另请参见：
        DirContext.search(Name, Attributes, String[]), MessageFormat
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvalidAttributeIdentifierException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 InvalidAttributeIdentifierException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.InvalidAttributeIdentifierException
  • 所有已实现的接口：
    Serializable

    public class InvalidAttributeIdentifierException
extends NamingException
    This exception is thrown when an attempt is made to add to create an attribute with an invalid attribute identifier. The validity of an attribute identifier is directory-specific.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAttributeIdentifierException()
      Constructs a new instance of InvalidAttributeIdentifierException.
      InvalidAttributeIdentifierException(String explanation)
      Constructs a new instance of InvalidAttributeIdentifierException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidAttributeIdentifierException

        public InvalidAttributeIdentifierException(String explanation)
        Constructs a new instance of InvalidAttributeIdentifierException using the explanation supplied. All other fields set to null.
        参数：
        explanation - Possibly null string containing additional detail about this exception.
        另请参见：
        Throwable.getMessage()

      • InvalidAttributeIdentifierException

        public InvalidAttributeIdentifierException()
        Constructs a new instance of InvalidAttributeIdentifierException. All fields are set to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ioniilltllm""lmmma..ter#tett(jma" ."reN/


InvalidAttributesException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 InvalidAttributesException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.InvalidAttributesException
  • 所有已实现的接口：
    Serializable

    public class InvalidAttributesException
extends NamingException
    This exception is thrown when an attempt is made to add or modify an attribute set that has been specified incompletely or incorrectly. This could happen, for example, when attempting to add or modify a binding, or to create a new subcontext without specifying all the mandatory attributes required for creation of the object. Another situation in which this exception is thrown is by specification of incompatible attributes within the same attribute set, or attributes in conflict with that specified by the object's schema.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAttributesException()
      Constructs a new instance of InvalidAttributesException.
      InvalidAttributesException(String explanation)
      Constructs a new instance of InvalidAttributesException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidAttributesException

        public InvalidAttributesException(String explanation)
        Constructs a new instance of InvalidAttributesException using an explanation. All other fields are set to null.
        参数：
        explanation - Additional detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()

      • InvalidAttributesException

        public InvalidAttributesException()
        Constructs a new instance of InvalidAttributesException. All fields are set to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rc>= i iv"ia


InvalidAttributeValueException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 InvalidAttributeValueException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.InvalidAttributeValueException
  • 所有已实现的接口：
    Serializable

    public class InvalidAttributeValueException
extends NamingException
    This class is thrown when an attempt is made to add to an attribute a value that conflicts with the attribute's schema definition. This could happen, for example, if attempting to add an attribute with no value when the attribute is required to have at least one value, or if attempting to add more than one value to a single valued-attribute, or if attempting to add a value that conflicts with the syntax of the attribute.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAttributeValueException()
      Constructs a new instance of InvalidAttributeValueException.
      InvalidAttributeValueException(String explanation)
      Constructs a new instance of InvalidAttributeValueException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidAttributeValueException

        public InvalidAttributeValueException(String explanation)
        Constructs a new instance of InvalidAttributeValueException using an explanation. All other fields are set to null.
        参数：
        explanation - Additional detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()

      • InvalidAttributeValueException

        public InvalidAttributeValueException()
        Constructs a new instance of InvalidAttributeValueException. All fields are set to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n �=pc�< 魹剅ffbi/ema塵0d4ai琣ve"


InvalidSearchControlsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 InvalidSearchControlsException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.InvalidSearchControlsException
  • 所有已实现的接口：
    Serializable

    public class InvalidSearchControlsException
extends NamingException
    This exception is thrown when the specification of the SearchControls for a search operation is invalid. For example, if the scope is set to a value other than OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE, this exception is thrown.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidSearchControlsException()
      Constructs a new instance of InvalidSearchControlsException.
      InvalidSearchControlsException(String msg)
      Constructs a new instance of InvalidSearchControlsException with an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidSearchControlsException

        public InvalidSearchControlsException()
        Constructs a new instance of InvalidSearchControlsException. All fields are set to null.

      • InvalidSearchControlsException

        public InvalidSearchControlsException(String msg)
        Constructs a new instance of InvalidSearchControlsException with an explanation. All other fields set to null.
        参数：
        msg - Detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dcsk,kmknkrrund is耸⑹枚们趋盲待掠g�"


InvalidSearchFilterException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 InvalidSearchFilterException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.InvalidSearchFilterException
  • 所有已实现的接口：
    Serializable

    public class InvalidSearchFilterException
extends NamingException
    This exception is thrown when the specification of a search filter is invalid. The expression of the filter may be invalid, or there may be a problem with one of the parameters passed to the filter.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidSearchFilterException()
      Constructs a new instance of InvalidSearchFilterException.
      InvalidSearchFilterException(String msg)
      Constructs a new instance of InvalidSearchFilterException with an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidSearchFilterException

        public InvalidSearchFilterException()
        Constructs a new instance of InvalidSearchFilterException. All fields are set to null.

      • InvalidSearchFilterException

        public InvalidSearchFilterException(String msg)
        Constructs a new instance of InvalidSearchFilterException with an explanation. All other fields are set to null.
        参数：
        msg - Detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d绷 羖玲龄没嵩ｔ缺<粒鸣赠热</bf o藅<>


javax.naming.directory

Interfaces

  • Attribute
  • Attributes
  • DirContext

Classes

  • BasicAttribute
  • BasicAttributes
  • InitialDirContext
  • ModificationItem
  • SearchControls
  • SearchResult

Exceptions

  • AttributeInUseException
  • AttributeModificationException
  • InvalidAttributeIdentifierException
  • InvalidAttributesException
  • InvalidAttributeValueException
  • InvalidSearchControlsException
  • InvalidSearchFilterException
  • NoSuchAttributeException
  • SchemaViolationException
�


javax.naming.directory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.naming.directory

Extends the javax.naming package to provide functionality for accessing directory services.

请参见： 描述

  • 接口摘要
    接口 描述
    Attribute
    This interface represents an attribute associated with a named object.
    Attributes
    This interface represents a collection of attributes.
    DirContext
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
  • Class Summary
    类 描述
    BasicAttribute
    This class provides a basic implementation of the Attribute interface.
    BasicAttributes
    This class provides a basic implementation of the Attributes interface.
    InitialDirContext
    This class is the starting context for performing directory operations.
    ModificationItem
    This class represents a modification item.
    SearchControls
    This class encapsulates factors that determine scope of search and what gets returned as a result of the search.
    SearchResult
    This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.
  • Exception Summary
    Exception 描述
    AttributeInUseException
    This exception is thrown when an operation attempts to add an attribute that already exists.
    AttributeModificationException
    This exception is thrown when an attempt is made to add, or remove, or modify an attribute, its identifier, or its values that conflicts with the attribute's (schema) definition or the attribute's state.
    InvalidAttributeIdentifierException
    This exception is thrown when an attempt is made to add to create an attribute with an invalid attribute identifier.
    InvalidAttributesException
    This exception is thrown when an attempt is made to add or modify an attribute set that has been specified incompletely or incorrectly.
    InvalidAttributeValueException
    This class is thrown when an attempt is made to add to an attribute a value that conflicts with the attribute's schema definition.
    InvalidSearchControlsException
    This exception is thrown when the specification of the SearchControls for a search operation is invalid.
    InvalidSearchFilterException
    This exception is thrown when the specification of a search filter is invalid.
    NoSuchAttributeException
    This exception is thrown when attempting to access an attribute that does not exist.
    SchemaViolationException
    This exception is thrown when a method in some ways violates the schema.

软件包 javax.naming.directory Description

Extends the javax.naming package to provide functionality for accessing directory services.

This package defines the directory operations of the Java Naming and Directory InterfaceTM (JNDI). JNDI provides naming and directory functionality to applications written in the Java programming language. It is designed to be independent of any specific naming or directory service implementation. Thus a variety of services--new, emerging, and already deployed ones--can be accessed in a common way.

This package allows applications to retrieve and update attributes associated with objects stored in a directory, and to search for objects using specified attributes.

The Directory Context

The DirContext interface represents a directory context. It defines methods for examining and updating attributes associated with a directory object, or directory entry as it is sometimes called.

You use getAttributes() to retrieve the attributes associated with a directory object (for which you supply the name). Attributes are modified using modifyAttributes(). You can add, replace, or remove attributes and/or attribute values using this operation.

DirContext also behaves as a naming context by extending the Context interface in the javax.naming package. This means that any directory object can also provide a naming context. For example, the directory object for a person might contain the attributes of that person, and at the same time provide a context for naming objects relative to that person such as his printers and home directory.

Searches

DirContext contains methods for performing content-based searching of the directory. In the simplest and most common form of usage, the application specifies a set of attributes--possibly with specific values--to match, and submits this attribute set, to the search() method. There are other overloaded forms of search() that support more sophisticated search filters.

Package Specification

The JNDI API Specification and related documents can be found in the JNDI documentation.
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lAl"ylola>e-i>CC znel


javax.naming.directory Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.naming.directory

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.naming.directory.BasicAttribute (implements javax.naming.directory.Attribute)
    • javax.naming.directory.BasicAttributes (implements javax.naming.directory.Attributes)
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
    • javax.naming.directory.ModificationItem (implements java.io.Serializable)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
    • javax.naming.directory.SearchControls (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
          • javax.naming.directory.AttributeModificationException
          • javax.naming.directory.InvalidAttributeIdentifierException
          • javax.naming.directory.InvalidAttributesException
          • javax.naming.directory.InvalidAttributeValueException
          • javax.naming.directory.InvalidSearchControlsException
          • javax.naming.directory.InvalidSearchFilterException
          • javax.naming.directory.NoSuchAttributeException
          • javax.naming.directory.SchemaViolationException

Interface Hierarchy

  • java.lang.Cloneable
    • javax.naming.directory.Attribute (also extends java.io.Serializable)
    • javax.naming.directory.Attributes (also extends java.io.Serializable)
  • javax.naming.Context
    • javax.naming.directory.DirContext
  • java.io.Serializable
    • javax.naming.directory.Attribute (also extends java.lang.Cloneable)
    • javax.naming.directory.Attributes (also extends java.lang.Cloneable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mhslevtohhhr // ittba


ModificationItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 ModificationItem

  • java.lang.Object
    • javax.naming.directory.ModificationItem
  • 所有已实现的接口：
    Serializable

    public class ModificationItem
extends Object
implements Serializable
    This class represents a modification item. It consists of a modification code and an attribute on which to operate.

    A ModificationItem instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single ModificationItem instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ModificationItem(int mod_op, Attribute attr)
      Creates a new instance of ModificationItem.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Attribute getAttribute()
      Retrieves the attribute associated with this modification item.
      int getModificationOp()
      Retrieves the modification code of this modification item.
      String toString()
      Generates the string representation of this modification item, which consists of the modification operation and its related attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ModificationItem

        public ModificationItem(int mod_op,
                Attribute attr)
        Creates a new instance of ModificationItem.
        参数：
        mod_op - Modification to apply. It must be one of: DirContext.ADD_ATTRIBUTE DirContext.REPLACE_ATTRIBUTE DirContext.REMOVE_ATTRIBUTE
        attr - The non-null attribute to use for modification.
        抛出：
        IllegalArgumentException - If attr is null, or if mod_op is not one of the ones specified above.

    • 方法详细信息

      • getModificationOp

        public int getModificationOp()
        Retrieves the modification code of this modification item.
        返回：
        The modification code. It is one of: DirContext.ADD_ATTRIBUTE DirContext.REPLACE_ATTRIBUTE DirContext.REMOVE_ATTRIBUTE

      • getAttribute

        public Attribute getAttribute()
        Retrieves the attribute associated with this modification item.
        返回：
        The non-null attribute to use for the modification.

      • toString

        public String toString()
        Generates the string representation of this modification item, which consists of the modification operation and its related attribute. The string representation is meant for debugging and not to be interpreted programmatically.
        重载：
        toString in class Object
        返回：
        The non-null string representation of this modification item.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

efpigiiicimgxceix.jj<iin 蘮nb秎/ppl/s


NoSuchAttributeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 NoSuchAttributeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.NoSuchAttributeException
  • 所有已实现的接口：
    Serializable

    public class NoSuchAttributeException
extends NamingException
    This exception is thrown when attempting to access an attribute that does not exist.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoSuchAttributeException()
      Constructs a new instance of NoSuchAttributeException.
      NoSuchAttributeException(String explanation)
      Constructs a new instance of NoSuchAttributeException using an explanation.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoSuchAttributeException

        public NoSuchAttributeException(String explanation)
        Constructs a new instance of NoSuchAttributeException using an explanation. All other fields are set to null.
        参数：
        explanation - Additional detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()

      • NoSuchAttributeException

        public NoSuchAttributeException()
        Constructs a new instance of NoSuchAttributeException. All fields are initialized to null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

brrpmp.pa".>..g//.0e0


SchemaViolationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.directory

类 SchemaViolationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.SchemaViolationException
  • 所有已实现的接口：
    Serializable

    public class SchemaViolationException
extends NamingException
    This exception is thrown when a method in some ways violates the schema. An example of schema violation is modifying attributes of an object that violates the object's schema definition. Another example is renaming or moving an object to a part of the namespace that violates the namespace's schema definition.

    Synchronization and serialization issues that apply to NamingException apply directly here.

    从以下版本开始：
    1.3
    另请参见：
    Context.bind(javax.naming.Name, java.lang.Object),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
Context.rebind(javax.naming.Name, java.lang.Object),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
Context.createSubcontext(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      构造方法与描述
      SchemaViolationException()
      Constructs a new instance of SchemaViolationException.
      SchemaViolationException(String explanation)
      Constructs a new instance of SchemaViolationException using the explanation supplied.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SchemaViolationException

        public SchemaViolationException()
        Constructs a new instance of SchemaViolationException. All fields are set to null.

      • SchemaViolationException

        public SchemaViolationException(String explanation)
        Constructs a new instance of SchemaViolationException using the explanation supplied. All other fields are set to null.
        参数：
        explanation - Detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mle. acjaec ectibbrcb


SearchControls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 SearchControls

  • java.lang.Object
    • javax.naming.directory.SearchControls
  • 所有已实现的接口：
    Serializable

    public class SearchControls
extends Object
implements Serializable
    This class encapsulates factors that determine scope of search and what gets returned as a result of the search.

    A SearchControls instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single SearchControls instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int OBJECT_SCOPE
      Search the named object.
      static int ONELEVEL_SCOPE
      Search one level of the named context.
      static int SUBTREE_SCOPE
      Search the entire subtree rooted at the named object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SearchControls()
      Constructs a search constraints using defaults.
      SearchControls(int scope, long countlim, int timelim, String[] attrs, boolean retobj, boolean deref)
      Constructs a search constraints using arguments.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      long getCountLimit()
      Retrieves the maximum number of entries that will be returned as a result of the search.
      boolean getDerefLinkFlag()
      Determines whether links will be dereferenced during the search.
      String[] getReturningAttributes()
      Retrieves the attributes that will be returned as part of the search.
      boolean getReturningObjFlag()
      Determines whether objects will be returned as part of the result.
      int getSearchScope()
      Retrieves the search scope of these SearchControls.
      int getTimeLimit()
      Retrieves the time limit of these SearchControls in milliseconds.
      void setCountLimit(long limit)
      Sets the maximum number of entries to be returned as a result of the search.
      void setDerefLinkFlag(boolean on)
      Enables/disables link dereferencing during the search.
      void setReturningAttributes(String[] attrs)
      Specifies the attributes that will be returned as part of the search.
      void setReturningObjFlag(boolean on)
      Enables/disables returning objects returned as part of the result.
      void setSearchScope(int scope)
      Sets the search scope to one of: OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE.
      void setTimeLimit(int ms)
      Sets the time limit of these SearchControls in milliseconds.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OBJECT_SCOPE

        public static final int OBJECT_SCOPE
        Search the named object.

        The NamingEnumeration that results from search() using OBJECT_SCOPE will contain one or zero element. The enumeration contains one element if the named object satisfies the search filter specified in search(). The element will have as its name the empty string because the names of elements in the NamingEnumeration are relative to the target context--in this case, the target context is the named object. It contains zero element if the named object does not satisfy the search filter specified in search().

        The value of this constant is 0.

        另请参见：
        Constant Field Values

      • ONELEVEL_SCOPE

        public static final int ONELEVEL_SCOPE
        Search one level of the named context.

        The NamingEnumeration that results from search() using ONELEVEL_SCOPE contains elements with objects in the named context that satisfy the search filter specified in search(). The names of elements in the NamingEnumeration are atomic names relative to the named context.

        The value of this constant is 1.

        另请参见：
        Constant Field Values

      • SUBTREE_SCOPE

        public static final int SUBTREE_SCOPE
        Search the entire subtree rooted at the named object.

        If the named object is not a DirContext, search only the object. If the named object is a DirContext, search the subtree rooted at the named object, including the named object itself.

        The search will not cross naming system boundaries.

        The NamingEnumeration that results from search() using SUBTREE_SCOPE contains elements of objects from the subtree (including the named context) that satisfy the search filter specified in search(). The names of elements in the NamingEnumeration are either relative to the named context or is a URL string. If the named context satisfies the search filter, it is included in the enumeration with the empty string as its name.

        The value of this constant is 2.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SearchControls

        public SearchControls()
        Constructs a search constraints using defaults.

        The defaults are:

        • search one level
        • no maximum return limit for search results
        • no time limit for search
        • return all attributes associated with objects that satisfy the search filter.
        • do not return named object (return only name and class)
        • do not dereference links during search

      • SearchControls

        public SearchControls(int scope,
              long countlim,
              int timelim,
              String[] attrs,
              boolean retobj,
              boolean deref)
        Constructs a search constraints using arguments.
        参数：
        scope - The search scope. One of: OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE.
        timelim - The number of milliseconds to wait before returning. If 0, wait indefinitely.
        deref - If true, dereference links during search.
        countlim - The maximum number of entries to return. If 0, return all entries that satisfy filter.
        retobj - If true, return the object bound to the name of the entry; if false, do not return object.
        attrs - The identifiers of the attributes to return along with the entry. If null, return all attributes. If empty return no attributes.

    • 方法详细信息

      • getSearchScope

        public int getSearchScope()
        Retrieves the search scope of these SearchControls.

        One of OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE.

        返回：
        The search scope of this SearchControls.
        另请参见：
        setSearchScope(int)

      • getTimeLimit

        public int getTimeLimit()
        Retrieves the time limit of these SearchControls in milliseconds.

        If the value is 0, this means to wait indefinitely.

        返回：
        The time limit of these SearchControls in milliseconds.
        另请参见：
        setTimeLimit(int)

      • getDerefLinkFlag

        public boolean getDerefLinkFlag()
        Determines whether links will be dereferenced during the search.
        返回：
        true if links will be dereferenced; false otherwise.
        另请参见：
        setDerefLinkFlag(boolean)

      • getReturningObjFlag

        public boolean getReturningObjFlag()
        Determines whether objects will be returned as part of the result.
        返回：
        true if objects will be returned; false otherwise.
        另请参见：
        setReturningObjFlag(boolean)

      • getCountLimit

        public long getCountLimit()
        Retrieves the maximum number of entries that will be returned as a result of the search.

        0 indicates that all entries will be returned.

        返回：
        The maximum number of entries that will be returned.
        另请参见：
        setCountLimit(long)

      • getReturningAttributes

        public String[] getReturningAttributes()
        Retrieves the attributes that will be returned as part of the search.

        A value of null indicates that all attributes will be returned. An empty array indicates that no attributes are to be returned.

        返回：
        An array of attribute ids identifying the attributes that will be returned. Can be null.
        另请参见：
        setReturningAttributes(java.lang.String[])

      • setSearchScope

        public void setSearchScope(int scope)
        Sets the search scope to one of: OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE.
        参数：
        scope - The search scope of this SearchControls.
        另请参见：
        getSearchScope()

      • setTimeLimit

        public void setTimeLimit(int ms)
        Sets the time limit of these SearchControls in milliseconds.

        If the value is 0, this means to wait indefinitely.

        参数：
        ms - The time limit of these SearchControls in milliseconds.
        另请参见：
        getTimeLimit()

      • setDerefLinkFlag

        public void setDerefLinkFlag(boolean on)
        Enables/disables link dereferencing during the search.
        参数：
        on - if true links will be dereferenced; if false, not followed.
        另请参见：
        getDerefLinkFlag()

      • setReturningObjFlag

        public void setReturningObjFlag(boolean on)
        Enables/disables returning objects returned as part of the result.

        If disabled, only the name and class of the object is returned. If enabled, the object will be returned.

        参数：
        on - if true, objects will be returned; if false, objects will not be returned.
        另请参见：
        getReturningObjFlag()

      • setCountLimit

        public void setCountLimit(long limit)
        Sets the maximum number of entries to be returned as a result of the search.

        0 indicates no limit: all entries will be returned.

        参数：
        limit - The maximum number of entries that will be returned.
        另请参见：
        getCountLimit()

      • setReturningAttributes

        public void setReturningAttributes(String[] attrs)
        Specifies the attributes that will be returned as part of the search.

        null indicates that all attributes will be returned. An empty array indicates no attributes are returned.

        参数：
        attrs - An array of attribute ids identifying the attributes that will be returned. Can be null.
        另请参见：
        getReturningAttributes()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oe/m1bDur癱鋖=其vnop笔dtao b秂=


SearchResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.directory

类 SearchResult

  • java.lang.Object
    • javax.naming.NameClassPair
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
  • 所有已实现的接口：
    Serializable

    public class SearchResult
extends Binding
    This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.

    A SearchResult instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single SearchResult instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SearchResult(String name, Object obj, Attributes attrs)
      Constructs a search result using the result's name, its bound object, and its attributes.
      SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
      Constructs a search result using the result's name, its bound object, and its attributes, and whether the name is relative.
      SearchResult(String name, String className, Object obj, Attributes attrs)
      Constructs a search result using the result's name, its class name, its bound object, and its attributes.
      SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
      Constructs a search result using the result's name, its class name, its bound object, its attributes, and whether the name is relative.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Attributes getAttributes()
      Retrieves the attributes in this search result.
      void setAttributes(Attributes attrs)
      Sets the attributes of this search result to attrs.
      String toString()
      Generates the string representation of this SearchResult.

      • 方法 - 继承于类 javax.naming.Binding

        getClassName, getObject, setObject

      • 方法 - 继承于类 javax.naming.NameClassPair

        getName, getNameInNamespace, isRelative, setClassName, setName, setNameInNamespace, setRelative

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SearchResult

        public SearchResult(String name,
            Object obj,
            Attributes attrs)
        Constructs a search result using the result's name, its bound object, and its attributes.

        getClassName() will return the class name of obj (or null if obj is null) unless the class name has been explicitly set using setClassName().

        参数：
        name - The non-null name of the search item. It is relative to the target context of the search (which is named by the first parameter of the search() method)
        obj - The object bound to name. Can be null.
        attrs - The attributes that were requested to be returned with this search item. Cannot be null.
        另请参见：
        NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

      • SearchResult

        public SearchResult(String name,
            Object obj,
            Attributes attrs,
            boolean isRelative)
        Constructs a search result using the result's name, its bound object, and its attributes, and whether the name is relative.

        getClassName() will return the class name of obj (or null if obj is null) unless the class name has been explicitly set using setClassName()

        参数：
        name - The non-null name of the search item.
        obj - The object bound to name. Can be null.
        attrs - The attributes that were requested to be returned with this search item. Cannot be null.
        isRelative - true if name is relative to the target context of the search (which is named by the first parameter of the search() method); false if name is a URL string.
        另请参见：
        NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

      • SearchResult

        public SearchResult(String name,
            String className,
            Object obj,
            Attributes attrs)
        Constructs a search result using the result's name, its class name, its bound object, and its attributes.
        参数：
        name - The non-null name of the search item. It is relative to the target context of the search (which is named by the first parameter of the search() method)
        className - The possibly null class name of the object bound to name. If null, the class name of obj is returned by getClassName(). If obj is also null, getClassName() will return null.
        obj - The object bound to name. Can be null.
        attrs - The attributes that were requested to be returned with this search item. Cannot be null.
        另请参见：
        NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

      • SearchResult

        public SearchResult(String name,
            String className,
            Object obj,
            Attributes attrs,
            boolean isRelative)
        Constructs a search result using the result's name, its class name, its bound object, its attributes, and whether the name is relative.
        参数：
        name - The non-null name of the search item.
        className - The possibly null class name of the object bound to name. If null, the class name of obj is returned by getClassName(). If obj is also null, getClassName() will return null.
        obj - The object bound to name. Can be null.
        attrs - The attributes that were requested to be returned with this search item. Cannot be null.
        isRelative - true if name is relative to the target context of the search (which is named by the first parameter of the search() method); false if name is a URL string.
        另请参见：
        NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

    • 方法详细信息

      • getAttributes

        public Attributes getAttributes()
        Retrieves the attributes in this search result.
        返回：
        The non-null attributes in this search result. Can be empty.
        另请参见：
        setAttributes(javax.naming.directory.Attributes)

      • setAttributes

        public void setAttributes(Attributes attrs)
        Sets the attributes of this search result to attrs.
        参数：
        attrs - The non-null attributes to use. Can be empty.
        另请参见：
        getAttributes()

      • toString

        public String toString()
        Generates the string representation of this SearchResult. The string representation consists of the string representation of the binding and the string representation of this search result's attributes, separated by ':'. The contents of this string is useful for debugging and is not meant to be interpreted programmatically.
        重载：
        toString in class Binding
        返回：
        The string representation of this SearchResult. Cannot be null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


Uses of Package javax.naming.directory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.naming.directory

  • Packages that use javax.naming.directory
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi
  • Classes in javax.naming.directory used by javax.naming.directory
    类与描述
    Attribute
    This interface represents an attribute associated with a named object.
    Attributes
    This interface represents a collection of attributes.
    DirContext
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
    ModificationItem
    This class represents a modification item.
    SearchControls
    This class encapsulates factors that determine scope of search and what gets returned as a result of the search.
    SearchResult
    This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.
  • Classes in javax.naming.directory used by javax.naming.event
    类与描述
    DirContext
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
    SearchControls
    This class encapsulates factors that determine scope of search and what gets returned as a result of the search.
  • Classes in javax.naming.directory used by javax.naming.ldap
    类与描述
    Attributes
    This interface represents a collection of attributes.
    DirContext
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
    InitialDirContext
    This class is the starting context for performing directory operations.
  • Classes in javax.naming.directory used by javax.naming.spi
    类与描述
    Attributes
    This interface represents a collection of attributes.
    DirContext
    The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnaopodole cn猻uoobo"g


Uses of Class javax.naming.directory.AttributeInUseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.AttributeInUseException

No usage of javax.naming.directory.AttributeInUseException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c/ro">M"=cccoLhho


Uses of Class javax.naming.directory.AttributeModificationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.AttributeModificationException

No usage of javax.naming.directory.AttributeModificationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.naming.directory.BasicAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.BasicAttribute

No usage of javax.naming.directory.BasicAttribute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

airgspac eee"pddtfdar


Uses of Class javax.naming.directory.BasicAttributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.BasicAttributes

No usage of javax.naming.directory.BasicAttributes
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c>trsi"�r ajo.


Uses of Class javax.naming.directory.InitialDirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InitialDirContext

  • Packages that use InitialDirContext
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of InitialDirContext in javax.naming.ldap

      Subclasses of InitialDirContext in javax.naming.ldap
      修饰符与类型 类与描述
      class  InitialLdapContext
      This class is the starting context for performing LDAPv3-style extended operations and controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tktiminxa///j.aa"ie anae


Uses of Class javax.naming.directory.InvalidAttributeIdentifierException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InvalidAttributeIdentifierException

No usage of javax.naming.directory.InvalidAttributeIdentifierException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e"a<><>i <"gg<"a=r


Uses of Class javax.naming.directory.InvalidAttributesException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InvalidAttributesException

No usage of javax.naming.directory.InvalidAttributesException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

亘帘冰保了宣/�<◆ �<


Uses of Class javax.naming.directory.InvalidAttributeValueException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InvalidAttributeValueException

No usage of javax.naming.directory.InvalidAttributeValueException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cA/l.a1;be


Uses of Class javax.naming.directory.InvalidSearchControlsException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InvalidSearchControlsException

No usage of javax.naming.directory.InvalidSearchControlsException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A8�;b=LL發<1c<


Uses of Class javax.naming.directory.InvalidSearchFilterException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.InvalidSearchFilterException

No usage of javax.naming.directory.InvalidSearchFilterException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>my


Uses of Class javax.naming.directory.ModificationItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.ModificationItem

  • Packages that use ModificationItem
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.

    • Uses of ModificationItem in javax.naming.directory

      Methods in javax.naming.directory that return ModificationItem
      修饰符与类型 方法与描述
      ModificationItem[] AttributeModificationException.getUnexecutedModifications()
      Retrieves the unexecuted modification list.
      Methods in javax.naming.directory with parameters of type ModificationItem
      修饰符与类型 | 方法与描述
      void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
      void DirContext.modifyAttributes(Name name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
      void DirContext.modifyAttributes(String name, ModificationItem[] mods)
      Modifies the attributes associated with a named object using an ordered list of modifications.
      void AttributeModificationException.setUnexecutedModifications(ModificationItem[] e)
      Sets the unexecuted modification list to be e.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ga)> s.=a( t> l>o/r


Uses of Class javax.naming.directory.NoSuchAttributeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.NoSuchAttributeException

No usage of javax.naming.directory.NoSuchAttributeException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


Uses of Class javax.naming.directory.SchemaViolationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.SchemaViolationException

No usage of javax.naming.directory.SchemaViolationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rt�e勦 $N /a


Uses of Class javax.naming.directory.SearchControls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.SearchControls

  • Packages that use SearchControls
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.

    • Uses of SearchControls in javax.naming.directory

      Methods in javax.naming.directory with parameters of type SearchControls
      修饰符与类型 | 方法与描述
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.

    • Uses of SearchControls in javax.naming.event

      Methods in javax.naming.event with parameters of type SearchControls
      修饰符与类型 方法与描述
      void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
      void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
      void EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
      void EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p


Uses of Class javax.naming.directory.SearchResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.directory.SearchResult

  • Packages that use SearchResult
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.

    • Uses of SearchResult in javax.naming.directory

      Methods in javax.naming.directory that return types with arguments of type SearchResult
      修饰符与类型 | 方法与描述
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(Name name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)
      NamingEnumeration<SearchResult> DirContext.search(String name, String filter, SearchControls cons)
      Searches in the named context or object for entries that satisfy the given search filter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e<== lellpsr a/.鎚r.皌ef


Uses of Interface javax.naming.directory.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.directory.Attribute

  • Packages that use Attribute
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.

    • Uses of Attribute in javax.naming.directory

      Classes in javax.naming.directory that implement Attribute
      修饰符与类型 类与描述
      class  BasicAttribute
      This class provides a basic implementation of the Attribute interface.
      Methods in javax.naming.directory that return Attribute
      修饰符与类型 | 方法与描述
      Attribute | BasicAttributes.get(String attrID)
      Attribute Attributes.get(String attrID)
      Retrieves the attribute with the given attribute id from the attribute set.
      Attribute ModificationItem.getAttribute()
      Retrieves the attribute associated with this modification item.
      Attribute | BasicAttributes.put(Attribute attr)
      Attribute Attributes.put(Attribute attr)
      Adds a new attribute to the attribute set.
      Attribute | BasicAttributes.put(String attrID, Object val)
      Attribute Attributes.put(String attrID, Object val)
      Adds a new attribute to the attribute set.
      Attribute | BasicAttributes.remove(String attrID)
      Attribute Attributes.remove(String attrID)
      Removes the attribute with the attribute id 'attrID' from the attribute set.
      Methods in javax.naming.directory that return types with arguments of type Attribute
      修饰符与类型 | 方法与描述
      NamingEnumeration<Attribute> | BasicAttributes.getAll()
      NamingEnumeration<? extends Attribute> Attributes.getAll()
      Retrieves an enumeration of the attributes in the attribute set.
      Methods in javax.naming.directory with parameters of type Attribute
      修饰符与类型 | 方法与描述
      Attribute | BasicAttributes.put(Attribute attr)
      Attribute Attributes.put(Attribute attr)
      Adds a new attribute to the attribute set.
      Constructors in javax.naming.directory with parameters of type Attribute
      构造方法与描述
      ModificationItem(int mod_op, Attribute attr)
      Creates a new instance of ModificationItem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=aP aaaaadrn


Uses of Interface javax.naming.directory.Attributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.directory.Attributes

  • Packages that use Attributes
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi

    • Uses of Attributes in javax.naming.directory

      Classes in javax.naming.directory that implement Attributes
      修饰符与类型 类与描述
      class  BasicAttributes
      This class provides a basic implementation of the Attributes interface.
      Methods in javax.naming.directory that return Attributes
      修饰符与类型 | 方法与描述
      Attributes SearchResult.getAttributes()
      Retrieves the attributes in this search result.
      Attributes | InitialDirContext.getAttributes(Name name)
      Attributes DirContext.getAttributes(Name name)
      Retrieves all of the attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
      Attributes DirContext.getAttributes(Name name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(String name)
      Attributes DirContext.getAttributes(String name)
      Retrieves all of the attributes associated with a named object.
      Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)
      Attributes DirContext.getAttributes(String name, String[] attrIds)
      Retrieves selected attributes associated with a named object.
      Methods in javax.naming.directory with parameters of type Attributes
      修饰符与类型 | 方法与描述
      void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
      void DirContext.bind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
      void DirContext.bind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
      DirContext DirContext.createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
      DirContext DirContext.createSubcontext(String name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      void DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
      void DirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
      Modifies the attributes associated with a named object.
      void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
      void DirContext.rebind(Name name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
      void DirContext.rebind(String name, Object obj, Attributes attrs)
      Binds a name to an object, along with associated attributes, overwriting any existing binding.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes)
      Searches in a single context for objects that contain a specified set of attributes.
      NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      NamingEnumeration<SearchResult> DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
      Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.
      void SearchResult.setAttributes(Attributes attrs)
      Sets the attributes of this search result to attrs.
      Constructors in javax.naming.directory with parameters of type Attributes
      构造方法与描述
      SearchResult(String name, Object obj, Attributes attrs)
      Constructs a search result using the result's name, its bound object, and its attributes.
      SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
      Constructs a search result using the result's name, its bound object, and its attributes, and whether the name is relative.
      SearchResult(String name, String className, Object obj, Attributes attrs)
      Constructs a search result using the result's name, its class name, its bound object, and its attributes.
      SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
      Constructs a search result using the result's name, its class name, its bound object, its attributes, and whether the name is relative.

    • Uses of Attributes in javax.naming.ldap

      Methods in javax.naming.ldap that return Attributes
      修饰符与类型 方法与描述
      Attributes Rdn.toAttributes()
      Retrieves the Attributes view of the type/value mappings contained in this Rdn.
      Constructors in javax.naming.ldap with parameters of type Attributes
      构造方法与描述
      Rdn(Attributes attrSet)
      Constructs an Rdn from the given attribute set.

    • Uses of Attributes in javax.naming.spi

      Methods in javax.naming.spi that return Attributes
      修饰符与类型 方法与描述
      Attributes DirStateFactory.Result.getAttributes()
      Retrieves the attributes to be bound.
      Methods in javax.naming.spi with parameters of type Attributes
      修饰符与类型 方法与描述
      static Object DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an instance of an object for the specified object, attributes, and environment.
      Object DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an object using the location or reference information, and attributes specified.
      static DirStateFactory.Result DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.
      DirStateFactory.Result DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.
      Constructors in javax.naming.spi with parameters of type Attributes
      构造方法与描述
      DirStateFactory.Result(Object obj, Attributes outAttrs)
      Constructs an instance of Result.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.naming.directory.DirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.directory.DirContext

  • Packages that use DirContext
    软件包 描述
    javax.naming.directory
    Extends the javax.naming package to provide functionality for accessing directory services.
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.naming.spi

    • Uses of DirContext in javax.naming.directory

      Classes in javax.naming.directory that implement DirContext
      修饰符与类型 类与描述
      class  InitialDirContext
      This class is the starting context for performing directory operations.
      Methods in javax.naming.directory that return DirContext
      修饰符与类型 | 方法与描述
      DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
      DirContext DirContext.createSubcontext(Name name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
      DirContext DirContext.createSubcontext(String name, Attributes attrs)
      Creates and binds a new context, along with associated attributes.
      DirContext BasicAttribute.getAttributeDefinition()
      Retrieves this attribute's schema definition.
      DirContext Attribute.getAttributeDefinition()
      Retrieves the attribute's schema definition.
      DirContext BasicAttribute.getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with this attribute.
      DirContext Attribute.getAttributeSyntaxDefinition()
      Retrieves the syntax definition associated with the attribute.
      DirContext | InitialDirContext.getSchema(Name name)
      DirContext DirContext.getSchema(Name name)
      Retrieves the schema associated with the named object.
      DirContext | InitialDirContext.getSchema(String name)
      DirContext DirContext.getSchema(String name)
      Retrieves the schema associated with the named object.
      DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
      DirContext DirContext.getSchemaClassDefinition(Name name)
      Retrieves a context containing the schema objects of the named object's class definitions.
      DirContext | InitialDirContext.getSchemaClassDefinition(String name)
      DirContext DirContext.getSchemaClassDefinition(String name)
      Retrieves a context containing the schema objects of the named object's class definitions.

    • Uses of DirContext in javax.naming.event

      Subinterfaces of DirContext in javax.naming.event
      修饰符与类型 Interface and Description
      interface  EventDirContext
      Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.

    • Uses of DirContext in javax.naming.ldap

      Subinterfaces of DirContext in javax.naming.ldap
      修饰符与类型 Interface and Description
      interface  LdapContext
      This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations.
      Classes in javax.naming.ldap that implement DirContext
      修饰符与类型 类与描述
      class  InitialLdapContext
      This class is the starting context for performing LDAPv3-style extended operations and controls.

    • Uses of DirContext in javax.naming.spi

      Methods in javax.naming.spi that return DirContext
      修饰符与类型 方法与描述
      static DirContext DirectoryManager.getContinuationDirContext(CannotProceedException cpe)
      Creates a context in which to continue a DirContext operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otdas/v v.<詄m>


EventContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.event

Interface EventContext

  • All Superinterfaces:
    Context
    All Known Subinterfaces:
    EventDirContext

    public interface EventContext
extends Context
    Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.

    Target

    The name parameter in the addNamingListener() methods is referred to as the target. The target, along with the scope, identify the object(s) that the listener is interested in. It is possible to register interest in a target that does not exist, but there might be limitations in the extent to which this can be supported by the service provider and underlying protocol/service.

    If a service only supports registration for existing targets, an attempt to register for a nonexistent target results in a NameNotFoundException being thrown as early as possible, preferably at the time addNamingListener() is called, or if that is not possible, the listener will receive the exception through the NamingExceptionEvent.

    Also, for service providers that only support registration for existing targets, when the target that a listener has registered for is subsequently removed from the namespace, the listener is notified via a NamingExceptionEvent (containing a NameNotFoundException).

    An application can use the method targetMustExist() to check whether a EventContext supports registration of nonexistent targets.

    Event Source

    The EventContext instance on which you invoke the registration methods is the event source of the events that are (potentially) generated. The source is not necessarily the object named by the target. Only when the target is the empty name is the object named by the target the source. In other words, the target, along with the scope parameter, are used to identify the object(s) that the listener is interested in, but the event source is the EventContext instance with which the listener has registered.

    For example, suppose a listener makes the following registration:

          NamespaceChangeListener listener = ...;
      src.addNamingListener("x", SUBTREE_SCOPE, listener);
    When an object named "x/y" is subsequently deleted, the corresponding NamingEvent (evt) must contain:
          evt.getEventContext() == src
      evt.getOldBinding().getName().equals("x/y")

    Furthermore, listener registration/deregistration is with the EventContext instance, and not with the corresponding object in the namespace. If the program intends at some point to remove a listener, then it needs to keep a reference to the EventContext instance on which it invoked addNamingListener() (just as it needs to keep a reference to the listener in order to remove it later). It cannot expect to do a lookup() and get another instance of a EventContext on which to perform the deregistration.

    Lifetime of Registration

    A registered listener becomes deregistered when:
    • It is removed using removeNamingListener().
    • An exception is thrown while collecting information about the events. That is, when the listener receives a NamingExceptionEvent.
    • Context.close() is invoked on the EventContext instance with which it has registered.
    Until that point, a EventContext instance that has outstanding listeners will continue to exist and be maintained by the service provider.

    Listener Implementations

    The registration/deregistration methods accept an instance of NamingListener. There are subinterfaces of NamingListener for different of event types of NamingEvent. For example, the ObjectChangeListener interface is for the NamingEvent.OBJECT_CHANGED event type. To register interest in multiple event types, the listener implementation should implement multiple NamingListener subinterfaces and use a single invocation of addNamingListener(). In addition to reducing the number of method calls and possibly the code size of the listeners, this allows some service providers to optimize the registration.

    Threading Issues

    Like Context instances in general, instances of EventContext are not guaranteed to be thread-safe. Care must be taken when multiple threads are accessing the same EventContext concurrently. See the package description for more information on threading issues.
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int OBJECT_SCOPE
      Constant for expressing interest in events concerning the object named by the target.
      static int ONELEVEL_SCOPE
      Constant for expressing interest in events concerning objects in the context named by the target, excluding the context named by the target.
      static int SUBTREE_SCOPE
      Constant for expressing interest in events concerning objects in the subtree of the object named by the target, including the object named by the target.

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addNamingListener(Name target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
      void addNamingListener(String target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object named by the string target name and scope changes.
      void removeNamingListener(NamingListener l)
      Removes a listener from receiving naming events fired by this EventContext.
      boolean targetMustExist()
      Determines whether a listener can register interest in a target that does not exist.

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 字段详细信息

      • OBJECT_SCOPE

        static final int OBJECT_SCOPE
        Constant for expressing interest in events concerning the object named by the target.

        The value of this constant is 0.

        另请参见：
        Constant Field Values

      • ONELEVEL_SCOPE

        static final int ONELEVEL_SCOPE
        Constant for expressing interest in events concerning objects in the context named by the target, excluding the context named by the target.

        The value of this constant is 1.

        另请参见：
        Constant Field Values

      • SUBTREE_SCOPE

        static final int SUBTREE_SCOPE
        Constant for expressing interest in events concerning objects in the subtree of the object named by the target, including the object named by the target.

        The value of this constant is 2.

        另请参见：
        Constant Field Values

    • 方法详细信息

      • addNamingListener

        void addNamingListener(Name target,
                     int scope,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes. The event source of those events is this context. See the class description for a discussion on event source and target. See the descriptions of the constants OBJECT_SCOPE, ONELEVEL_SCOPE, and SUBTREE_SCOPE to see how scope affects the registration.

        target needs to name a context only when scope is ONELEVEL_SCOPE. target may name a non-context if scope is either OBJECT_SCOPE or SUBTREE_SCOPE. Using SUBTREE_SCOPE for a non-context might be useful, for example, if the caller does not know in advance whether target is a context and just wants to register interest in the (possibly degenerate subtree) rooted at target.

        When the listener is notified of an event, the listener may in invoked in a thread other than the one in which addNamingListener() is executed. Care must be taken when multiple threads are accessing the same EventContext concurrently. See the package description for more information on threading issues.

        参数：
        target - A nonnull name to be resolved relative to this context.
        scope - One of OBJECT_SCOPE, ONELEVEL_SCOPE, or SUBTREE_SCOPE.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        removeNamingListener(javax.naming.event.NamingListener)

      • addNamingListener

        void addNamingListener(String target,
                     int scope,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when the object named by the string target name and scope changes. See the overload that accepts a Name for details.
        参数：
        target - The nonnull string name of the object resolved relative to this context.
        scope - One of OBJECT_SCOPE, ONELEVEL_SCOPE, or SUBTREE_SCOPE.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        removeNamingListener(javax.naming.event.NamingListener)

      • removeNamingListener

        void removeNamingListener(NamingListener l)
                          throws NamingException
        Removes a listener from receiving naming events fired by this EventContext. The listener may have registered more than once with this EventContext, perhaps with different target/scope arguments. After this method is invoked, the listener will no longer receive events with this EventContext instance as the event source (except for those events already in the process of being dispatched). If the listener was not, or is no longer, registered with this EventContext instance, this method does not do anything.
        参数：
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while removing the listener.
        另请参见：
        addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener)

      • targetMustExist

        boolean targetMustExist()
                        throws NamingException
        Determines whether a listener can register interest in a target that does not exist.
        返回：
        true if the target must exist; false if the target need not exist.
        抛出：
        NamingException - If the context's behavior in this regard cannot be determined.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x<


EventDirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.event

Interface EventDirContext

  • All Superinterfaces:
    Context, DirContext, EventContext

    public interface EventDirContext
extends EventContext, DirContext
    Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.

    The methods in this interface support identification of objects by RFC 2254 search filters.

    Using the search filter, it is possible to register interest in objects that do not exist at the time of registration but later come into existence and satisfy the filter. However, there might be limitations in the extent to which this can be supported by the service provider and underlying protocol/service. If the caller submits a filter that cannot be supported in this way, addNamingListener() throws an InvalidSearchFilterException.

    See EventContext for a description of event source and target, and information about listener registration/deregistration that are also applicable to methods in this interface. See the package description for information on threading issues.

    A SearchControls or array object passed as a parameter to any method is owned by the caller. The service provider will not modify the object or keep a reference to it.

    从以下版本开始：
    1.3

    • 字段摘要

      • 字段 - 继承于接口 javax.naming.event.EventContext

        OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE

      • 字段 - 继承于接口 javax.naming.directory.DirContext

        ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
      void addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
      void addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
      void addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.

      • 方法 - 继承于接口 javax.naming.event.EventContext

        addNamingListener, addNamingListener, removeNamingListener, targetMustExist

      • 方法 - 继承于接口 javax.naming.directory.DirContext

        bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 方法详细信息

      • addNamingListener

        void addNamingListener(Name target,
                     String filter,
                     SearchControls ctls,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.

        The scope, returningObj flag, and returningAttributes flag from the search controls ctls are used to control the selection of objects that the listener is interested in, and determines what information is returned in the eventual NamingEvent object. Note that the requested information to be returned might not be present in the NamingEvent object if they are unavailable or could not be obtained by the service provider or service.

        参数：
        target - The nonnull name of the object resolved relative to this context.
        filter - The nonnull string filter (see RFC2254).
        ctls - The possibly null search controls. If null, the default search controls are used.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls)

      • addNamingListener

        void addNamingListener(String target,
                     String filter,
                     SearchControls ctls,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified. See the overload that accepts a Name for details of how this method behaves.
        参数：
        target - The nonnull string name of the object resolved relative to this context.
        filter - The nonnull string filter (see RFC2254).
        ctls - The possibly null search controls. If null, the default search controls is used.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(java.lang.String, java.lang.String, javax.naming.directory.SearchControls)

      • addNamingListener

        void addNamingListener(Name target,
                     String filter,
                     Object[] filterArgs,
                     SearchControls ctls,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified. The scope, returningObj flag, and returningAttributes flag from the search controls ctls are used to control the selection of objects that the listener is interested in, and determines what information is returned in the eventual NamingEvent object. Note that the requested information to be returned might not be present in the NamingEvent object if they are unavailable or could not be obtained by the service provider or service.
        参数：
        target - The nonnull name of the object resolved relative to this context.
        filter - The nonnull string filter (see RFC2254).
        filterArgs - The possibly null array of arguments for the filter.
        ctls - The possibly null search controls. If null, the default search controls are used.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(javax.naming.Name, java.lang.String, java.lang.Object[], javax.naming.directory.SearchControls)

      • addNamingListener

        void addNamingListener(String target,
                     String filter,
                     Object[] filterArgs,
                     SearchControls ctls,
                     NamingListener l)
                       throws NamingException
        Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified. See the overload that accepts a Name for details of how this method behaves.
        参数：
        target - The nonnull string name of the object resolved relative to this context.
        filter - The nonnull string filter (see RFC2254).
        filterArgs - The possibly null array of arguments for the filter.
        ctls - The possibly null search controls. If null, the default search controls is used.
        l - The nonnull listener.
        抛出：
        NamingException - If a problem was encountered while adding the listener.
        另请参见：
        EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(java.lang.String, java.lang.String, java.lang.Object[], javax.naming.directory.SearchControls)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


javax.naming.event

Interfaces

  • EventContext
  • EventDirContext
  • NamespaceChangeListener
  • NamingListener
  • ObjectChangeListener

Classes

  • NamingEvent
  • NamingExceptionEvent
�


javax.naming.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.naming.event

Provides support for event notification when accessing naming and directory services.

请参见： 描述

  • 接口摘要
    接口 描述
    EventContext
    Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.
    EventDirContext
    Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.
    NamespaceChangeListener
    Specifies the methods that a listener interested in namespace changes must implement.
    NamingListener
    This interface is the root of listener interfaces that handle NamingEvents.
    ObjectChangeListener
    Specifies the method that a listener of a NamingEvent with event type of OBJECT_CHANGED must implement.
  • Class Summary
    类 描述
    NamingEvent
    This class represents an event fired by a naming/directory service.
    NamingExceptionEvent
    This class represents an event fired when the procedures/processes used to collect information for notifying listeners of NamingEvents threw a NamingException.

软件包 javax.naming.event Description

Provides support for event notification when accessing naming and directory services.

This package defines the event notification operations of the Java Naming and Directory InterfaceTM (JNDI). JNDI provides naming and directory functionality to applications written in the Java programming language. It is designed to be independent of any specific naming or directory service implementation. Thus a variety of services--new, emerging, and already deployed ones--can be accessed in a common way.

Naming Events

This package defines a NamingEvent class to represent an event that is generated by a naming/directory service. It also defines subinterfaces of Context and DirContext, called EventContext and EventDirContext, through which applications can register their interest in events fired by the context.

NamingEvent represents an event that occurs in a naming or directory service. There are two categories of naming events:

  • Those that affect the namespace (add/remove/rename an object)
  • Those that affect the objects' contents.
Each category of events is handled by a corresponding listener: NamespaceChangeListener, ObjectChangeListener.

An application, for example, can register its interest in changes to objects in a context as follows:

EventContext src =
    (EventContext)(new InitialContext()).lookup("o=wiz,c=us");
src.addNamingListener("ou=users", EventContext.ONELEVEL_SCOPE,
    new ChangeHandler());
...
class ChangeHandler implements ObjectChangeListener {
    public void objectChanged(NamingEvent evt) {
        System.out.println(evt.getNewBinding());
    }
    public void namingExceptionThrown(NamingExceptionEvent evt) {
        System.out.println(evt.getException());
    }
}

Threading Issues

When an event is dispatched to a listener, the listener method (such as objectChanged()) may be executed in a thread other than the one in which the call to addNamingListener() was executed. The choice of which thread to use is made by the service provider. When an event is dispatched to multiple listeners, the service provider may choose (and is generally encouraged) to execute the listener methods concurrently in separate threads.

When a listener instance invokes NamingEvent.getEventContext(), it must take into account the possibility that other threads will be working with that context concurrently. Likewise, when a listener is registered via addNamingListener(), the registering thread must take into account the likely possibility that the service provider will later invoke the listeners in newly-created threads. As Context instances are not guaranteed to be thread-safe in general, all context operations must be synchronized as needed.

Exception Handling

When a listener registers for events with a context, the context might need to do some internal processing in order to collect information required to generate the events. The context, for example, might need to make a request to the server to register interest in changes on the server that will eventually be translated into events. If an exception occurs that prevents information about the events from being collected, the listener will never be notified of the events. When such an exception occurs, a NamingExceptionEvent is fired to notify the listener. The listener's namingExceptionThrown() method is invoked, as shown in the sample code above, and the listener is automatically deregistered.

Package Specification

The JNDI API Specification and related documents can be found in the JNDI documentation.
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vnerred>a eet/


javax.naming.event Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.naming.event

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.naming.event.NamingEvent
      • javax.naming.event.NamingExceptionEvent

Interface Hierarchy

  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.event.EventDirContext (also extends javax.naming.event.EventContext)
    • javax.naming.event.EventContext
      • javax.naming.event.EventDirContext (also extends javax.naming.directory.DirContext)
  • java.util.EventListener
    • javax.naming.event.NamingListener
      • javax.naming.event.NamespaceChangeListener
      • javax.naming.event.ObjectChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/d )Bnn hhEB


NamespaceChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.event

Interface NamespaceChangeListener

  • All Superinterfaces:
    EventListener, NamingListener

    public interface NamespaceChangeListener
extends NamingListener
    Specifies the methods that a listener interested in namespace changes must implement. Specifically, the listener is interested in NamingEvents with event types of OBJECT_ADDED, OBJECT_RENAMED, or OBJECT_REMOVED.

    Such a listener must:

    1. Implement this interface and its methods.
    2. Implement NamingListener.namingExceptionThrown() so that it will be notified of exceptions thrown while attempting to collect information about the events.
    3. Register with the source using the source's addNamingListener() method.
    A listener that wants to be notified of OBJECT_CHANGED event types should also implement the ObjectChangeListener interface.
    从以下版本开始：
    1.3
    另请参见：
    NamingEvent, ObjectChangeListener, EventContext, EventDirContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void objectAdded(NamingEvent evt)
      Called when an object has been added.
      void objectRemoved(NamingEvent evt)
      Called when an object has been removed.
      void objectRenamed(NamingEvent evt)
      Called when an object has been renamed.

      • 方法 - 继承于接口 javax.naming.event.NamingListener

        namingExceptionThrown

    • 方法详细信息

      • objectAdded

        void objectAdded(NamingEvent evt)
        Called when an object has been added.

        The binding of the newly added object can be obtained using evt.getNewBinding().

        参数：
        evt - The nonnull event.
        另请参见：
        NamingEvent.OBJECT_ADDED

      • objectRemoved

        void objectRemoved(NamingEvent evt)
        Called when an object has been removed.

        The binding of the newly removed object can be obtained using evt.getOldBinding().

        参数：
        evt - The nonnull event.
        另请参见：
        NamingEvent.OBJECT_REMOVED

      • objectRenamed

        void objectRenamed(NamingEvent evt)
        Called when an object has been renamed.

        The binding of the renamed object can be obtained using evt.getNewBinding(). Its old binding (before the rename) can be obtained using evt.getOldBinding(). One of these may be null if the old/new binding was outside the scope in which the listener has registered interest.

        参数：
        evt - The nonnull event.
        另请参见：
        NamingEvent.OBJECT_RENAMED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e. etgntgn..gnn.siix.lxajedree"-";


NamingEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.event

类 NamingEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.naming.event.NamingEvent
  • 所有已实现的接口：
    Serializable

    public class NamingEvent
extends EventObject
    This class represents an event fired by a naming/directory service.

    The NamingEvent's state consists of

    • The event source: the EventContext which fired this event.
    • The event type.
    • The new binding: information about the object after the change.
    • The old binding: information about the object before the change.
    • Change information: information about the change that triggered this event; usually service provider-specific or server-specific information.

    Note that the event source is always the same EventContext instance that the listener has registered with. Furthermore, the names of the bindings in the NamingEvent are always relative to that instance. For example, suppose a listener makes the following registration:

         NamespaceChangeListener listener = ...;
     src.addNamingListener("x", SUBTREE_SCOPE, listener);
    When an object named "x/y" is subsequently deleted, the corresponding NamingEvent (evt) must contain:
         evt.getEventContext() == src
     evt.getOldBinding().getName().equals("x/y")
    Care must be taken when multiple threads are accessing the same EventContext concurrently. See the package description for more information on threading issues.
    从以下版本开始：
    1.3
    另请参见：
    NamingListener, EventContext, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Object changeInfo
      Contains information about the change that generated this event.
      protected Binding newBinding
      Contains information about the object after the change.
      static int OBJECT_ADDED
      Naming event type for indicating that a new object has been added.
      static int OBJECT_CHANGED
      Naming event type for indicating that an object has been changed.
      static int OBJECT_REMOVED
      Naming event type for indicating that an object has been removed.
      static int OBJECT_RENAMED
      Naming event type for indicating that an object has been renamed.
      protected Binding oldBinding
      Contains information about the object before the change.
      protected int type
      Contains the type of this event.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
      Constructs an instance of NamingEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispatch(NamingListener listener)
      Invokes the appropriate listener method on this event.
      Object getChangeInfo()
      Retrieves the change information for this event.
      EventContext getEventContext()
      Retrieves the event source that fired this event.
      Binding getNewBinding()
      Retrieves the binding of the object after the change.
      Binding getOldBinding()
      Retrieves the binding of the object before the change.
      int getType()
      Returns the type of this event.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OBJECT_ADDED

        public static final int OBJECT_ADDED
        Naming event type for indicating that a new object has been added. The value of this constant is 0.
        另请参见：
        Constant Field Values

      • OBJECT_REMOVED

        public static final int OBJECT_REMOVED
        Naming event type for indicating that an object has been removed. The value of this constant is 1.
        另请参见：
        Constant Field Values

      • OBJECT_RENAMED

        public static final int OBJECT_RENAMED
        Naming event type for indicating that an object has been renamed. Note that some services might fire multiple events for a single logical rename operation. For example, the rename operation might be implemented by adding a binding with the new name and removing the old binding.

        The old/new binding in NamingEvent may be null if the old name or new name is outside of the scope for which the listener has registered.

        When an interior node in the namespace tree has been renamed, the topmost node which is part of the listener's scope should used to generate a rename event. The extent to which this can be supported is provider-specific. For example, a service might generate rename notifications for all descendants of the changed interior node and the corresponding provider might not be able to prevent those notifications from being propagated to the listeners.

        The value of this constant is 2.

        另请参见：
        Constant Field Values

      • OBJECT_CHANGED

        public static final int OBJECT_CHANGED
        Naming event type for indicating that an object has been changed. The changes might include the object's attributes, or the object itself. Note that some services might fire multiple events for a single modification. For example, the modification might be implemented by first removing the old binding and adding a new binding containing the same name but a different object.

        The value of this constant is 3.

        另请参见：
        Constant Field Values

      • changeInfo

        protected Object changeInfo
        Contains information about the change that generated this event.

      • type

        protected int type
        Contains the type of this event.
        另请参见：
        OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED

      • oldBinding

        protected Binding oldBinding
        Contains information about the object before the change.

      • newBinding

        protected Binding newBinding
        Contains information about the object after the change.

    • 构造方法详细信息

      • NamingEvent

        public NamingEvent(EventContext source,
           int type,
           Binding newBd,
           Binding oldBd,
           Object changeInfo)
        Constructs an instance of NamingEvent.

        The names in newBd and oldBd are to be resolved relative to the event source source. For an OBJECT_ADDED event type, newBd must not be null. For an OBJECT_REMOVED event type, oldBd must not be null. For an OBJECT_CHANGED event type, newBd and oldBd must not be null. For an OBJECT_RENAMED event type, one of newBd or oldBd may be null if the new or old binding is outside of the scope for which the listener has registered.

        参数：
        source - The non-null context that fired this event.
        type - The type of the event.
        newBd - A possibly null binding before the change. See method description.
        oldBd - A possibly null binding after the change. See method description.
        changeInfo - A possibly null object containing information about the change.
        另请参见：
        OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED

    • 方法详细信息

      • getType

        public int getType()
        Returns the type of this event.
        返回：
        The type of this event.
        另请参见：
        OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED

      • getEventContext

        public EventContext getEventContext()
        Retrieves the event source that fired this event. This returns the same object as EventObject.getSource().

        If the result of this method is used to access the event source, for example, to look up the object or get its attributes, then it needs to be locked because implementations of Context are not guaranteed to be thread-safe (and EventContext is a subinterface of Context). See the package description for more information on threading issues.

        返回：
        The non-null context that fired this event.

      • getOldBinding

        public Binding getOldBinding()
        Retrieves the binding of the object before the change.

        The binding must be nonnull if the object existed before the change relative to the source context (getEventContext()). That is, it must be nonnull for OBJECT_REMOVED and OBJECT_CHANGED. For OBJECT_RENAMED, it is null if the object before the rename is outside of the scope for which the listener has registered interest; it is nonnull if the object is inside the scope before the rename.

        The name in the binding is to be resolved relative to the event source getEventContext(). The object returned by Binding.getObject() may be null if such information is unavailable.

        返回：
        The possibly null binding of the object before the change.

      • getNewBinding

        public Binding getNewBinding()
        Retrieves the binding of the object after the change.

        The binding must be nonnull if the object existed after the change relative to the source context (getEventContext()). That is, it must be nonnull for OBJECT_ADDED and OBJECT_CHANGED. For OBJECT_RENAMED, it is null if the object after the rename is outside the scope for which the listener registered interest; it is nonnull if the object is inside the scope after the rename.

        The name in the binding is to be resolved relative to the event source getEventContext(). The object returned by Binding.getObject() may be null if such information is unavailable.

        返回：
        The possibly null binding of the object after the change.

      • getChangeInfo

        public Object getChangeInfo()
        Retrieves the change information for this event. The value of the change information is service-specific. For example, it could be an ID that identifies the change in a change log on the server.
        返回：
        The possibly null change information of this event.

      • dispatch

        public void dispatch(NamingListener listener)
        Invokes the appropriate listener method on this event. The default implementation of this method handles the following event types: OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED.

        The listener method is executed in the same thread as this method. See the package description for more information on threading issues.

        参数：
        listener - The nonnull listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nbenrneC


NamingExceptionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.event

类 NamingExceptionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.naming.event.NamingExceptionEvent
  • 所有已实现的接口：
    Serializable

    public class NamingExceptionEvent
extends EventObject
    This class represents an event fired when the procedures/processes used to collect information for notifying listeners of NamingEvents threw a NamingException. This can happen, for example, if the server which the listener is using aborts subsequent to the addNamingListener() call.
    从以下版本开始：
    1.3
    另请参见：
    NamingListener.namingExceptionThrown(javax.naming.event.NamingExceptionEvent), EventContext, Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingExceptionEvent(EventContext source, NamingException exc)
      Constructs an instance of NamingExceptionEvent using the context in which the NamingException was thrown and the exception that was thrown.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispatch(NamingListener listener)
      Invokes the namingExceptionThrown() method on a listener using this event.
      EventContext getEventContext()
      Retrieves the EventContext that fired this event.
      NamingException getException()
      Retrieves the exception that was thrown.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NamingExceptionEvent

        public NamingExceptionEvent(EventContext source,
                    NamingException exc)
        Constructs an instance of NamingExceptionEvent using the context in which the NamingException was thrown and the exception that was thrown.
        参数：
        source - The non-null context in which the exception was thrown.
        exc - The non-null NamingException that was thrown.

    • 方法详细信息

      • getException

        public NamingException getException()
        Retrieves the exception that was thrown.
        返回：
        The exception that was thrown.

      • getEventContext

        public EventContext getEventContext()
        Retrieves the EventContext that fired this event. This returns the same object as EventObject.getSource().
        返回：
        The non-null EventContext that fired this event.

      • dispatch

        public void dispatch(NamingListener listener)
        Invokes the namingExceptionThrown() method on a listener using this event.
        参数：
        listener - The non-null naming listener on which to invoke the method.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vv>< tt


NamingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.event

Interface NamingListener

  • All Superinterfaces:
    EventListener
    All Known Subinterfaces:
    NamespaceChangeListener, ObjectChangeListener, UnsolicitedNotificationListener

    public interface NamingListener
extends EventListener
    This interface is the root of listener interfaces that handle NamingEvents. It does not make sense for a listener to implement just this interface. A listener typically implements a subinterface of NamingListener, such as ObjectChangeListener or NamespaceChangeListener.

    This interface contains a single method, namingExceptionThrown(), that must be implemented so that the listener can be notified of exceptions that are thrown (by the service provider) while gathering information about the events that they're interested in. When this method is invoked, the listener has been automatically deregistered from the EventContext with which it has registered.

    For example, suppose a listener implements ObjectChangeListener and registers with a EventContext. Then, if the connection to the server is subsequently broken, the listener will receive a NamingExceptionEvent and may take some corrective action, such as notifying the user of the application.

    从以下版本开始：
    1.3
    另请参见：
    NamingEvent, NamingExceptionEvent, EventContext, EventDirContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void namingExceptionThrown(NamingExceptionEvent evt)
      Called when a naming exception is thrown while attempting to fire a NamingEvent.

    • 方法详细信息

      • namingExceptionThrown

        void namingExceptionThrown(NamingExceptionEvent evt)
        Called when a naming exception is thrown while attempting to fire a NamingEvent.
        参数：
        evt - The nonnull event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/on.=.h".h rrh eehtvetltg"iie>.


ObjectChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.event

Interface ObjectChangeListener

  • All Superinterfaces:
    EventListener, NamingListener

    public interface ObjectChangeListener
extends NamingListener
    Specifies the method that a listener of a NamingEvent with event type of OBJECT_CHANGED must implement.

    An OBJECT_CHANGED event type is fired when (the contents of) an object has changed. This might mean that its attributes have been modified, added, or removed, and/or that the object itself has been replaced. How the object has changed can be determined by examining the NamingEvent's old and new bindings.

    A listener interested in OBJECT_CHANGED event types must:

    1. Implement this interface and its method (objectChanged())
    2. Implement NamingListener.namingExceptionThrown() so that it will be notified of exceptions thrown while attempting to collect information about the events.
    3. Register with the source using the source's addNamingListener() method.
    A listener that wants to be notified of namespace change events should also implement the NamespaceChangeListener interface.
    从以下版本开始：
    1.3
    另请参见：
    NamingEvent, NamespaceChangeListener, EventContext, EventDirContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void objectChanged(NamingEvent evt)
      Called when an object has been changed.

      • 方法 - 继承于接口 javax.naming.event.NamingListener

        namingExceptionThrown

    • 方法详细信息

      • objectChanged

        void objectChanged(NamingEvent evt)
        Called when an object has been changed.

        The binding of the changed object can be obtained using evt.getNewBinding(). Its old binding (before the change) can be obtained using evt.getOldBinding().

        参数：
        evt - The nonnull naming event.
        另请参见：
        NamingEvent.OBJECT_CHANGED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnNaaiimaavsi",Rauo e///Emv


Uses of Package javax.naming.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.naming.event

  • Packages that use javax.naming.event
    软件包 描述
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
  • Classes in javax.naming.event used by javax.naming.event
    类与描述
    EventContext
    Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.
    NamingEvent
    This class represents an event fired by a naming/directory service.
    NamingExceptionEvent
    This class represents an event fired when the procedures/processes used to collect information for notifying listeners of NamingEvents threw a NamingException.
    NamingListener
    This interface is the root of listener interfaces that handle NamingEvents.
  • Classes in javax.naming.event used by javax.naming.ldap
    类与描述
    NamingListener
    This interface is the root of listener interfaces that handle NamingEvents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

siteiis tiiivhss)v;e}x1i


Uses of Class javax.naming.event.NamingEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.event.NamingEvent

  • Packages that use NamingEvent
    软件包 描述
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.

    • Uses of NamingEvent in javax.naming.event

      Methods in javax.naming.event with parameters of type NamingEvent
      修饰符与类型 方法与描述
      void NamespaceChangeListener.objectAdded(NamingEvent evt)
      Called when an object has been added.
      void ObjectChangeListener.objectChanged(NamingEvent evt)
      Called when an object has been changed.
      void NamespaceChangeListener.objectRemoved(NamingEvent evt)
      Called when an object has been removed.
      void NamespaceChangeListener.objectRenamed(NamingEvent evt)
      Called when an object has been renamed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l m=daasrt>a鍁nt磘


Uses of Class javax.naming.event.NamingExceptionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.event.NamingExceptionEvent

  • Packages that use NamingExceptionEvent
    软件包 描述
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.

    • Uses of NamingExceptionEvent in javax.naming.event

      Methods in javax.naming.event with parameters of type NamingExceptionEvent
      修饰符与类型 方法与描述
      void NamingListener.namingExceptionThrown(NamingExceptionEvent evt)
      Called when a naming exception is thrown while attempting to fire a NamingEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


Uses of Interface javax.naming.event.EventContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.event.EventContext

  • Packages that use EventContext
    软件包 描述
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.

    • Uses of EventContext in javax.naming.event

      Subinterfaces of EventContext in javax.naming.event
      修饰符与类型 Interface and Description
      interface  EventDirContext
      Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.
      Methods in javax.naming.event that return EventContext
      修饰符与类型 方法与描述
      EventContext NamingEvent.getEventContext()
      Retrieves the event source that fired this event.
      EventContext NamingExceptionEvent.getEventContext()
      Retrieves the EventContext that fired this event.
      Constructors in javax.naming.event with parameters of type EventContext
      构造方法与描述
      NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
      Constructs an instance of NamingEvent.
      NamingExceptionEvent(EventContext source, NamingException exc)
      Constructs an instance of NamingExceptionEvent using the context in which the NamingException was thrown and the exception that was thrown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

OFuc 2Rswax"c


Uses of Interface javax.naming.event.EventDirContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.event.EventDirContext

No usage of javax.naming.event.EventDirContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st=>n> pattt<;aael aa


Uses of Interface javax.naming.event.NamespaceChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.event.NamespaceChangeListener

No usage of javax.naming.event.NamespaceChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.naming.event.NamingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.event.NamingListener

  • Packages that use NamingListener
    软件包 描述
    javax.naming.event
    Provides support for event notification when accessing naming and directory services.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of NamingListener in javax.naming.event

      Subinterfaces of NamingListener in javax.naming.event
      修饰符与类型 Interface and Description
      interface  NamespaceChangeListener
      Specifies the methods that a listener interested in namespace changes must implement.
      interface  ObjectChangeListener
      Specifies the method that a listener of a NamingEvent with event type of OBJECT_CHANGED must implement.
      Methods in javax.naming.event with parameters of type NamingListener
      修饰符与类型 方法与描述
      void EventContext.addNamingListener(Name target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
      void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
      void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
      void EventContext.addNamingListener(String target, int scope, NamingListener l)
      Adds a listener for receiving naming events fired when the object named by the string target name and scope changes.
      void EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
      void EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
      Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.
      void NamingEvent.dispatch(NamingListener listener)
      Invokes the appropriate listener method on this event.
      void NamingExceptionEvent.dispatch(NamingListener listener)
      Invokes the namingExceptionThrown() method on a listener using this event.
      void EventContext.removeNamingListener(NamingListener l)
      Removes a listener from receiving naming events fired by this EventContext.

    • Uses of NamingListener in javax.naming.ldap

      Subinterfaces of NamingListener in javax.naming.ldap
      修饰符与类型 Interface and Description
      interface  UnsolicitedNotificationListener
      This interface is for handling UnsolicitedNotificationEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<. aciali=atb/to槐


Uses of Interface javax.naming.event.ObjectChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.event.ObjectChangeListener

No usage of javax.naming.event.ObjectChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vC /ron<>///


BasicControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 BasicControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
  • 所有已实现的接口：
    Serializable, Control
    直接已知子类：
    ManageReferralControl, PagedResultsControl, PagedResultsResponseControl, SortControl, SortResponseControl

    public class BasicControl
extends Object
implements Control
    This class provides a basic implementation of the Control interface. It represents an LDAPv3 Control as defined in RFC 2251.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean criticality
      The control's criticality.
      protected String id
      The control's object identifier string.
      protected byte[] value
      The control's ASN.1 BER encoded value.

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicControl(String id)
      Constructs a non-critical control.
      BasicControl(String id, boolean criticality, byte[] value)
      Constructs a control using the supplied arguments.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getEncodedValue()
      Retrieves the control's ASN.1 BER encoded value.
      String getID()
      Retrieves the control's object identifier string.
      boolean isCritical()
      Determines the control's criticality.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • id

        protected String id
        The control's object identifier string.

      • criticality

        protected boolean criticality
        The control's criticality.

      • value

        protected byte[] value
        The control's ASN.1 BER encoded value.

    • 构造方法详细信息

      • BasicControl

        public BasicControl(String id)
        Constructs a non-critical control.
        参数：
        id - The control's object identifier string.

      • BasicControl

        public BasicControl(String id,
            boolean criticality,
            byte[] value)
        Constructs a control using the supplied arguments.
        参数：
        id - The control's object identifier string.
        criticality - The control's criticality.
        value - The control's ASN.1 BER encoded value. It is not cloned - any changes to value will affect the contents of the control. It may be null.

    • 方法详细信息

      • getID

        public String getID()
        Retrieves the control's object identifier string.
        指定者：
        getID in interface Control
        返回：
        The non-null object identifier string.

      • isCritical

        public boolean isCritical()
        Determines the control's criticality.
        指定者：
        isCritical in interface Control
        返回：
        true if the control is critical; false otherwise.

      • getEncodedValue

        public byte[] getEncodedValue()
        Retrieves the control's ASN.1 BER encoded value. The result includes the BER tag and length for the control's value but does not include the control's object identifier and criticality setting.
        指定者：
        getEncodedValue in interface Control
        返回：
        A possibly null byte array representing the control's ASN.1 BER encoded value. It is not cloned - any changes to the returned value will affect the contents of the control.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ti i=e=ecnao"e .ngms耯l .c"


Control

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface Control

  • All Superinterfaces:
    Serializable
    All Known Implementing Classes:
    BasicControl, ManageReferralControl, PagedResultsControl, PagedResultsResponseControl, SortControl, SortResponseControl

    public interface Control
extends Serializable
    This interface represents an LDAPv3 control as defined in RFC 2251.

    The LDAPv3 protocol uses controls to send and receive additional data to affect the behavior of predefined operations. Controls can be sent along with any LDAP operation to the server. These are referred to as request controls. For example, a "sort" control can be sent with an LDAP search operation to request that the results be returned in a particular order. Solicited and unsolicited controls can also be returned with responses from the server. Such controls are referred to as response controls. For example, an LDAP server might define a special control to return change notifications.

    This interface is used to represent both request and response controls.

    从以下版本开始：
    1.3
    另请参见：
    ControlFactory

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static boolean CRITICAL
      Indicates a critical control.
      static boolean NONCRITICAL
      Indicates a non-critical control.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getEncodedValue()
      Retrieves the ASN.1 BER encoded value of the LDAP control.
      String getID()
      Retrieves the object identifier assigned for the LDAP control.
      boolean isCritical()
      Determines the criticality of the LDAP control.

    • 字段详细信息

      • CRITICAL

        static final boolean CRITICAL
        Indicates a critical control. The value of this constant is true.
        另请参见：
        Constant Field Values

      • NONCRITICAL

        static final boolean NONCRITICAL
        Indicates a non-critical control. The value of this constant is false.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getID

        String getID()
        Retrieves the object identifier assigned for the LDAP control.
        返回：
        The non-null object identifier string.

      • isCritical

        boolean isCritical()
        Determines the criticality of the LDAP control. A critical control must not be ignored by the server. In other words, if the server receives a critical control that it does not support, regardless of whether the control makes sense for the operation, the operation will not be performed and an OperationNotSupportedException will be thrown.
        返回：
        true if this control is critical; false otherwise.

      • getEncodedValue

        byte[] getEncodedValue()
        Retrieves the ASN.1 BER encoded value of the LDAP control. The result is the raw BER bytes including the tag and length of the control's value. It does not include the controls OID or criticality. Null is returned if the value is absent.
        返回：
        A possibly null byte array representing the ASN.1 BER encoded value of the LDAP control.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>d tfiifi d t bnttl.i m


ControlFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 ControlFactory

  • java.lang.Object
    • javax.naming.ldap.ControlFactory

  • public abstract class ControlFactory
extends Object
    This abstract class represents a factory for creating LDAPv3 controls. LDAPv3 controls are defined in RFC 2251.

    When a service provider receives a response control, it uses control factories to return the specific/appropriate control class implementation.

    从以下版本开始：
    1.3
    另请参见：
    Control

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ControlFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Control getControlInstance(Control ctl)
      Creates a control using this control factory.
      static Control getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
      Creates a control using known control factories.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ControlFactory

        protected ControlFactory()

    • 方法详细信息

      • getControlInstance

        public abstract Control getControlInstance(Control ctl)
                                    throws NamingException
        Creates a control using this control factory.

        The factory is used by the service provider to return controls that it reads from the LDAP protocol as specialized control classes. Without this mechanism, the provider would be returning controls that only contained data in BER encoded format.

        Typically, ctl is a "basic" control containing BER encoded data. The factory is used to create a specialized control implementation, usually by decoding the BER encoded data, that provides methods to access that data in a type-safe and friendly manner.

        For example, a factory might use the BER encoded data in basic control and return an instance of a VirtualListReplyControl.

        If this factory cannot create a control using the argument supplied, it should return null. A factory should only throw an exception if it is sure that it is the only intended factory and that no other control factories should be tried. This might happen, for example, if the BER data in the control does not match what is expected of a control with the given OID. Since this method throws NamingException, any other internally generated exception that should be propagated must be wrapped inside a NamingException.

        参数：
        ctl - A non-null control.
        返回：
        A possibly null Control.
        抛出：
        NamingException - If ctl contains invalid data that prevents it from being used to create a control. A factory should only throw an exception if it knows how to produce the control (identified by the OID) but is unable to because of, for example invalid BER data.

      • getControlInstance

        public static Control getControlInstance(Control ctl,
                         Context ctx,
                         Hashtable<?,?> env)
                                  throws NamingException
        Creates a control using known control factories.

        The following rule is used to create the control:

        • Use the control factories specified in the LdapContext.CONTROL_FACTORIES property of the environment, and of the provider resource file associated with ctx, in that order. The value of this property is a colon-separated list of factory class names that are tried in order, and the first one that succeeds in creating the control is the one used. If none of the factories can be loaded, return ctl. If an exception is encountered while creating the control, the exception is passed up to the caller.

        Note that a control factory must be public and must have a public constructor that accepts no arguments.

        参数：
        ctl - The non-null control object containing the OID and BER data.
        ctx - The possibly null context in which the control is being created. If null, no such information is available.
        env - The possibly null environment of the context. This is used to find the value of the LdapContext.CONTROL_FACTORIES property.
        返回：
        A control object created using ctl; or ctl if a control object cannot be created using the algorithm described above.
        抛出：
        NamingException - if a naming exception was encountered while attempting to create the control object. If one of the factories accessed throws an exception, it is propagated up to the caller. If an error was encountered while loading and instantiating the factory and object classes, the exception is wrapped inside a NamingException and then rethrown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lri/mglettt茯 <>r


ExtendedRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface ExtendedRequest

  • All Superinterfaces:
    Serializable
    All Known Implementing Classes:
    StartTlsRequest

    public interface ExtendedRequest
extends Serializable
    This interface represents an LDAPv3 extended operation request as defined in RFC 2251.
         ExtendedRequest ::= [APPLICATION 23] SEQUENCE {
              requestName      [0] LDAPOID,
              requestValue     [1] OCTET STRING OPTIONAL }
    It comprises an object identifier string and an optional ASN.1 BER encoded value.

    The methods in this class are used by the service provider to construct the bits to send to the LDAP server. Applications typically only deal with the classes that implement this interface, supplying them with any information required for a particular extended operation request. It would then pass such a class as an argument to the LdapContext.extendedOperation() method for performing the LDAPv3 extended operation.

    For example, suppose the LDAP server supported a 'get time' extended operation. It would supply GetTimeRequest and GetTimeResponse classes:

     public class GetTimeRequest implements ExtendedRequest {
     public GetTimeRequest() {... };
     public ExtendedResponse createExtendedResponse(String id,
         byte[] berValue, int offset, int length)
         throws NamingException {
         return new GetTimeResponse(id, berValue, offset, length);
     }
     ...
 }
 public class GetTimeResponse implements ExtendedResponse {
     long time;
     public GetTimeResponse(String id, byte[] berValue, int offset,
         int length) throws NamingException {
         time =      ... // decode berValue to get time
     }
     public java.util.Date getDate() { return new java.util.Date(time) };
     public long getTime() { return time };
     ...
 }
    A program would use then these classes as follows:
     GetTimeResponse resp =
     (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
 long time = resp.getTime();
    从以下版本开始：
    1.3
    另请参见：
    ExtendedResponse, LdapContext.extendedOperation(javax.naming.ldap.ExtendedRequest)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ExtendedResponse createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates the response object that corresponds to this request.
      byte[] getEncodedValue()
      Retrieves the ASN.1 BER encoded value of the LDAP extended operation request.
      String getID()
      Retrieves the object identifier of the request.

    • 方法详细信息

      • getID

        String getID()
        Retrieves the object identifier of the request.
        返回：
        The non-null object identifier string representing the LDAP ExtendedRequest.requestName component.

      • getEncodedValue

        byte[] getEncodedValue()
        Retrieves the ASN.1 BER encoded value of the LDAP extended operation request. Null is returned if the value is absent. The result is the raw BER bytes including the tag and length of the request value. It does not include the request OID. This method is called by the service provider to get the bits to put into the extended operation to be sent to the LDAP server.
        返回：
        A possibly null byte array representing the ASN.1 BER encoded contents of the LDAP ExtendedRequest.requestValue component.
        抛出：
        IllegalStateException - If the encoded value cannot be retrieved because the request contains insufficient or invalid data/state.

      • createExtendedResponse

        ExtendedResponse createExtendedResponse(String id,
                                      byte[] berValue,
                                      int offset,
                                      int length)
                                        throws NamingException
        Creates the response object that corresponds to this request.

        After the service provider has sent the extended operation request to the LDAP server, it will receive a response from the server. If the operation failed, the provider will throw a NamingException. If the operation succeeded, the provider will invoke this method using the data that it got back in the response. It is the job of this method to return a class that implements the ExtendedResponse interface that is appropriate for the extended operation request.

        For example, a Start TLS extended request class would need to know how to process a Start TLS extended response. It does this by creating a class that implements ExtendedResponse.

        参数：
        id - The possibly null object identifier of the response control.
        berValue - The possibly null ASN.1 BER encoded value of the response control. This is the raw BER bytes including the tag and length of the response value. It does not include the response OID.
        offset - The starting position in berValue of the bytes to use.
        length - The number of bytes in berValue to use.
        返回：
        A non-null object.
        抛出：
        NamingException - if cannot create extended response due to an error.
        另请参见：
        ExtendedResponse
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.s/= =<=.=f./.../hoot=mtegplcuaaic /


ExtendedResponse

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface ExtendedResponse

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    UnsolicitedNotification
    All Known Implementing Classes:
    StartTlsResponse

    public interface ExtendedResponse
extends Serializable
    This interface represents an LDAP extended operation response as defined in RFC 2251.
         ExtendedResponse ::= [APPLICATION 24] SEQUENCE {
          COMPONENTS OF LDAPResult,
          responseName     [10] LDAPOID OPTIONAL,
          response         [11] OCTET STRING OPTIONAL }
    It comprises an optional object identifier and an optional ASN.1 BER encoded value.

    The methods in this class can be used by the application to get low level information about the extended operation response. However, typically, the application will be using methods specific to the class that implements this interface. Such a class should have decoded the BER buffer in the response and should provide methods that allow the user to access that data in the response in a type-safe and friendly manner.

    For example, suppose the LDAP server supported a 'get time' extended operation. It would supply GetTimeRequest and GetTimeResponse classes. The GetTimeResponse class might look like:

     public class GetTimeResponse implements ExtendedResponse {
     public java.util.Date getDate() {...};
     public long getTime() {...};
     ....
 }
    A program would use then these classes as follows:
     GetTimeResponse resp =
     (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
 java.util.Date now = resp.getDate();
    从以下版本开始：
    1.3
    另请参见：
    ExtendedRequest

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getEncodedValue()
      Retrieves the ASN.1 BER encoded value of the LDAP extended operation response.
      String getID()
      Retrieves the object identifier of the response.

    • 方法详细信息

      • getID

        String getID()
        Retrieves the object identifier of the response. The LDAP protocol specifies that the response object identifier is optional. If the server does not send it, the response will contain no ID (i.e. null).
        返回：
        A possibly null object identifier string representing the LDAP ExtendedResponse.responseName component.

      • getEncodedValue

        byte[] getEncodedValue()
        Retrieves the ASN.1 BER encoded value of the LDAP extended operation response. Null is returned if the value is absent from the response sent by the LDAP server. The result is the raw BER bytes including the tag and length of the response value. It does not include the response OID.
        返回：
        A possibly null byte array representing the ASN.1 BER encoded contents of the LDAP ExtendedResponse.response component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bSjb o po -TT --od<


HasControls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface HasControls

  • All Known Subinterfaces:
    UnsolicitedNotification

    public interface HasControls
    This interface is for returning controls with objects returned in NamingEnumerations. For example, suppose a server sends back controls with the results of a search operation, the service provider would return a NamingEnumeration of objects that are both SearchResult and implement HasControls.
       NamingEnumeration elts = ectx.search((Name)name, filter, sctls);
   while (elts.hasMore()) {
     Object entry = elts.next();

     // Get search result
     SearchResult res = (SearchResult)entry;
     // do something with it

     // Get entry controls
     if (entry instanceof HasControls) {
         Control[] entryCtls = ((HasControls)entry).getControls();
         // do something with controls
     }
   }
    从以下版本开始：
    1.3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Control[] getControls()
      Retrieves an array of Controls from the object that implements this interface.

    • 方法详细信息

      • getControls

        Control[] getControls()
                      throws NamingException
        Retrieves an array of Controls from the object that implements this interface. It is null if there are no controls.
        返回：
        A possibly null array of Control objects.
        抛出：
        NamingException - If cannot return controls due to an error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a r>r>f>d>rSS>rrosvvp-.plpdllo.ohn


InitialLdapContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 InitialLdapContext

  • java.lang.Object
    • javax.naming.InitialContext
      • javax.naming.directory.InitialDirContext
        • javax.naming.ldap.InitialLdapContext
  • 所有已实现的接口：
    Context, DirContext, LdapContext

    public class InitialLdapContext
extends InitialDirContext
implements LdapContext
    This class is the starting context for performing LDAPv3-style extended operations and controls.

    See javax.naming.InitialContext and javax.naming.InitialDirContext for details on synchronization, and the policy for how an initial context is created.

    Request Controls

    When you create an initial context (InitialLdapContext), you can specify a list of request controls. These controls will be used as the request controls for any implicit LDAP "bind" operation performed by the context or contexts derived from the context. These are called connection request controls. Use getConnectControls() to get a context's connection request controls.

    The request controls supplied to the initial context constructor are not used as the context request controls for subsequent context operations such as searches and lookups. Context request controls are set and updated by using setRequestControls().

    As shown, there can be two different sets of request controls associated with a context: connection request controls and context request controls. This is required for those applications needing to send critical controls that might not be applicable to both the context operation and any implicit LDAP "bind" operation. A typical user program would do the following:

     InitialLdapContext lctx = new InitialLdapContext(env, critConnCtls);
 lctx.setRequestControls(critModCtls);
 lctx.modifyAttributes(name, mods);
 Controls[] respCtls =  lctx.getResponseControls();
    It specifies first the critical controls for creating the initial context (critConnCtls), and then sets the context's request controls (critModCtls) for the context operation. If for some reason lctx needs to reconnect to the server, it will use critConnCtls. See the LdapContext interface for more discussion about request controls.

    Service provider implementors should read the "Service Provider" section in the LdapContext class description for implementation details.

    从以下版本开始：
    1.3
    另请参见：
    LdapContext, InitialContext, InitialDirContext, NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder)

    • 字段摘要

      • Fields inherited from class javax.naming.InitialContext

        defaultInitCtx, gotDefault, myProps

      • 字段 - 继承于接口 javax.naming.ldap.LdapContext

        CONTROL_FACTORIES

      • 字段 - 继承于接口 javax.naming.directory.DirContext

        ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 构造方法摘要

      Constructors
      构造方法与描述
      InitialLdapContext()
      Constructs an initial context using no environment properties or connection request controls.
      InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
      Constructs an initial context using environment properties and connection request controls.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ExtendedResponse extendedOperation(ExtendedRequest request)
      Performs an extended operation.
      Control[] getConnectControls()
      Retrieves the connection request controls in effect for this context.
      Control[] getRequestControls()
      Retrieves the request controls in effect for this context.
      Control[] getResponseControls()
      Retrieves the response controls produced as a result of the last method invoked on this context.
      LdapContext newInstance(Control[] reqCtls)
      Creates a new instance of this context initialized using request controls.
      void reconnect(Control[] connCtls)
      Reconnects to the LDAP server using the supplied controls and this context's environment.
      void setRequestControls(Control[] requestControls)
      Sets the request controls for methods subsequently invoked on this context.

      • 方法 - 继承于类 javax.naming.directory.InitialDirContext

        bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search

      • 方法 - 继承于类 javax.naming.InitialContext

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, doLookup, doLookup, getDefaultInitCtx, getEnvironment, getNameInNamespace, getNameParser, getNameParser, getURLOrDefaultInitCtx, getURLOrDefaultInitCtx, init, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.naming.directory.DirContext

        bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 构造方法详细信息

      • InitialLdapContext

        public InitialLdapContext()
                   throws NamingException
        Constructs an initial context using no environment properties or connection request controls. Equivalent to new InitialLdapContext(null, null).
        抛出：
        NamingException - if a naming exception is encountered

      • InitialLdapContext

        public InitialLdapContext(Hashtable<?,?> environment,
                  Control[] connCtls)
                   throws NamingException
        Constructs an initial context using environment properties and connection request controls. See javax.naming.InitialContext for a discussion of environment properties.

        This constructor will not modify its parameters or save references to them, but may save a clone or copy. Caller should not modify mutable keys and values in environment after it has been passed to the constructor.

        connCtls is used as the underlying context instance's connection request controls. See the class description for details.

        参数：
        environment - environment used to create the initial DirContext. Null indicates an empty environment.
        connCtls - connection request controls for the initial context. If null, no connection request controls are used.
        抛出：
        NamingException - if a naming exception is encountered
        另请参见：
        reconnect(javax.naming.ldap.Control[]), LdapContext.reconnect(javax.naming.ldap.Control[])

    • 方法详细信息

      • extendedOperation

        public ExtendedResponse extendedOperation(ExtendedRequest request)
                                   throws NamingException
        从接口复制的描述： LdapContext
        Performs an extended operation. This method is used to support LDAPv3 extended operations.
        指定者：
        extendedOperation in interface LdapContext
        参数：
        request - The non-null request to be performed.
        返回：
        The possibly null response of the operation. null means the operation did not generate any response.
        抛出：
        NamingException - If an error occurred while performing the extended operation.

      • newInstance

        public LdapContext newInstance(Control[] reqCtls)
                        throws NamingException
        从接口复制的描述： LdapContext
        Creates a new instance of this context initialized using request controls. This method is a convenience method for creating a new instance of this context for the purposes of multithreaded access. For example, if multiple threads want to use different context request controls, each thread may use this method to get its own copy of this context and set/get context request controls without having to synchronize with other threads.

        The new context has the same environment properties and connection request controls as this context. See the class description for details. Implementations might also allow this context and the new context to share the same network connection or other resources if doing so does not impede the independence of either context.

        指定者：
        newInstance in interface LdapContext
        参数：
        reqCtls - The possibly null request controls to use for the new context. If null, the context is initialized with no request controls.
        返回：
        A non-null LdapContext instance.
        抛出：
        NamingException - If an error occurred while creating the new instance.
        另请参见：
        InitialLdapContext

      • reconnect

        public void reconnect(Control[] connCtls)
               throws NamingException
        从接口复制的描述： LdapContext
        Reconnects to the LDAP server using the supplied controls and this context's environment.

        This method is a way to explicitly initiate an LDAP "bind" operation. For example, you can use this method to set request controls for the LDAP "bind" operation, or to explicitly connect to the server to get response controls returned by the LDAP "bind" operation.

        This method sets this context's connCtls to be its new connection request controls. This context's context request controls are not affected. After this method has been invoked, any subsequent implicit reconnections will be done using connCtls. connCtls are also used as connection request controls for new context instances derived from this context. These connection request controls are not affected by setRequestControls().

        Service provider implementors should read the "Service Provider" section in the class description for implementation details.

        指定者：
        reconnect in interface LdapContext
        参数：
        connCtls - The possibly null controls to use. If null, no controls are used.
        抛出：
        NamingException - If an error occurred while reconnecting.
        另请参见：
        LdapContext.getConnectControls(), LdapContext.newInstance(javax.naming.ldap.Control[])

      • getConnectControls

        public Control[] getConnectControls()
                             throws NamingException
        从接口复制的描述： LdapContext
        Retrieves the connection request controls in effect for this context. The controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.
        指定者：
        getConnectControls in interface LdapContext
        返回：
        A possibly-null array of controls. null means no connect controls have been set for this context.
        抛出：
        NamingException - If an error occurred while getting the request controls.

      • setRequestControls

        public void setRequestControls(Control[] requestControls)
                        throws NamingException
        从接口复制的描述： LdapContext
        Sets the request controls for methods subsequently invoked on this context. The request controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.

        This removes any previous request controls and adds requestControls for use by subsequent methods invoked on this context. This method does not affect this context's connection request controls.

        Note that requestControls will be in effect until the next invocation of setRequestControls(). You need to explicitly invoke setRequestControls() with null or an empty array to clear the controls if you don't want them to affect the context methods any more. To check what request controls are in effect for this context, use getRequestControls().

        指定者：
        setRequestControls in interface LdapContext
        参数：
        requestControls - The possibly null controls to use. If null, no controls are used.
        抛出：
        NamingException - If an error occurred while setting the request controls.
        另请参见：
        LdapContext.getRequestControls()

      • getRequestControls

        public Control[] getRequestControls()
                             throws NamingException
        从接口复制的描述： LdapContext
        Retrieves the request controls in effect for this context. The request controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.
        指定者：
        getRequestControls in interface LdapContext
        返回：
        A possibly-null array of controls. null means no request controls have been set for this context.
        抛出：
        NamingException - If an error occurred while getting the request controls.
        另请参见：
        LdapContext.setRequestControls(javax.naming.ldap.Control[])

      • getResponseControls

        public Control[] getResponseControls()
                              throws NamingException
        从接口复制的描述： LdapContext
        Retrieves the response controls produced as a result of the last method invoked on this context. The response controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.

        These response controls might have been generated by a successful or failed operation.

        When a context method that may return response controls is invoked, response controls from the previous method invocation are cleared. getResponseControls() returns all of the response controls generated by LDAP operations used by the context method in the order received from the LDAP server. Invoking getResponseControls() does not clear the response controls. You can call it many times (and get back the same controls) until the next context method that may return controls is invoked.

        指定者：
        getResponseControls in interface LdapContext
        返回：
        A possibly null array of controls. If null, the previous method invoked on this context did not produce any controls.
        抛出：
        NamingException - If an error occurred while getting the response controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.naming.ldap

Interfaces

  • Control
  • ExtendedRequest
  • ExtendedResponse
  • HasControls
  • LdapContext
  • UnsolicitedNotification
  • UnsolicitedNotificationListener

Classes

  • BasicControl
  • ControlFactory
  • InitialLdapContext
  • LdapName
  • ManageReferralControl
  • PagedResultsControl
  • PagedResultsResponseControl
  • Rdn
  • SortControl
  • SortKey
  • SortResponseControl
  • StartTlsRequest
  • StartTlsResponse
  • UnsolicitedNotificationEvent

Exceptions

  • LdapReferralException
=


javax.naming.ldap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.naming.ldap

Provides support for LDAPv3 extended operations and controls.

请参见： 描述

  • 接口摘要
    接口 描述
    Control
    This interface represents an LDAPv3 control as defined in RFC 2251.
    ExtendedRequest
    This interface represents an LDAPv3 extended operation request as defined in RFC 2251.
    ExtendedResponse
    This interface represents an LDAP extended operation response as defined in RFC 2251.
    HasControls
    This interface is for returning controls with objects returned in NamingEnumerations.
    LdapContext
    This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations.
    UnsolicitedNotification
    This interface represents an unsolicited notification as defined in RFC 2251.
    UnsolicitedNotificationListener
    This interface is for handling UnsolicitedNotificationEvent.
  • Class Summary
    类 描述
    BasicControl
    This class provides a basic implementation of the Control interface.
    ControlFactory
    This abstract class represents a factory for creating LDAPv3 controls.
    InitialLdapContext
    This class is the starting context for performing LDAPv3-style extended operations and controls.
    LdapName
    This class represents a distinguished name as specified by RFC 2253.
    ManageReferralControl
    Requests that referral and other special LDAP objects be manipulated as normal LDAP objects.
    PagedResultsControl
    Requests that the results of a search operation be returned by the LDAP server in batches of a specified size.
    PagedResultsResponseControl
    Indicates the end of a batch of search results.
    Rdn
    This class represents a relative distinguished name, or RDN, which is a component of a distinguished name as specified by RFC 2253.
    SortControl
    Requests that the results of a search operation be sorted by the LDAP server before being returned.
    SortKey
    A sort key and its associated sort parameters.
    SortResponseControl
    Indicates whether the requested sort of search results was successful or not.
    StartTlsRequest
    This class implements the LDAPv3 Extended Request for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended request value is defined.
    StartTlsResponse
    This class implements the LDAPv3 Extended Response for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended response value is defined.
    UnsolicitedNotificationEvent
    This class represents an event fired in response to an unsolicited notification sent by the LDAP server.
  • Exception Summary
    Exception 描述
    LdapReferralException
    This abstract class is used to represent an LDAP referral exception.

软件包 javax.naming.ldap Description

Provides support for LDAPv3 extended operations and controls.

This package extends the directory operations of the Java Naming and Directory InterfaceTM (JNDI). JNDI provides naming and directory functionality to applications written in the Java programming language. It is designed to be independent of any specific naming or directory service implementation. Thus a variety of services--new, emerging, and already deployed ones--can be accessed in a common way.

This package is for applications and service providers that deal with LDAPv3 extended operations and controls, as defined by RFC 2251. The core interface in this package is LdapContext, which defines methods on a context for performing extended operations and handling controls.

Extended Operations

This package defines the interface ExtendedRequest to represent the argument to an extended operation, and the interface ExtendedResponse to represent the result of the extended operation. An extended response is always paired with an extended request but not necessarily vice versa. That is, you can have an extended request that has no corresponding extended response.

An application typically does not deal directly with these interfaces. Instead, it deals with classes that implement these interfaces. The application gets these classes either as part of a repertoire of extended operations standardized through the IETF, or from directory vendors for vendor-specific extended operations. The request classes should have constructors that accept arguments in a type-safe and user-friendly manner, while the response classes should have access methods for getting the data of the response in a type-safe and user-friendly manner. Internally, the request/response classes deal with encoding and decoding BER values.

For example, suppose an LDAP server supports a "get time" extended operation. It would supply classes such as GetTimeRequest and GetTimeResponse, so that applications can use this feature. An application would use these classes as follows:

GetTimeResponse resp =
    (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
long time = resp.getTime();

The GetTimeRequest and GetTimeResponse classes might be defined as follows:

public class GetTimeRequest implements ExtendedRequest {
    // User-friendly constructor
    public GetTimeRequest() {
    };

    // Methods used by service providers
    public String getID() {
        return GETTIME_REQ_OID;
    }
    public byte[] getEncodedValue() {
        return null;  // no value needed for get time request
    }
    public ExtendedResponse createExtendedResponse(
        String id, byte[] berValue, int offset, int length) throws NamingException {
        return new GetTimeResponse(id, berValue, offset, length);
    }
}
public class GetTimeResponse() implements ExtendedResponse {
    long time;
    // called by GetTimeRequest.createExtendedResponse()
    public GetTimeResponse(String id, byte[] berValue, int offset, int length)
        throws NamingException {
        // check validity of id
        long time =  ... // decode berValue to get time
    }

    // Type-safe and User-friendly methods
    public java.util.Date getDate() { return new java.util.Date(time); }
    public long getTime() { return time; }

    // Low level methods
    public byte[] getEncodedValue() {
        return // berValue saved;
    }
    public String getID() {
        return GETTIME_RESP_OID;
    }
}

Controls

This package defines the interface Control to represent an LDAPv3 control. It can be a control that is sent to an LDAP server (request control) or a control returned by an LDAP server (response control). Unlike extended requests and responses, there is not necessarily any pairing between request controls and response controls. You can send request controls and expect no response controls back, or receive response controls without sending any request controls.

An application typically does not deal directly with this interface. Instead, it deals with classes that implement this interface. The application gets control classes either as part of a repertoire of controls standardized through the IETF, or from directory vendors for vendor-specific controls. The request control classes should have constructors that accept arguments in a type-safe and user-friendly manner, while the response control classes should have access methods for getting the data of the response in a type-safe and user-friendly manner. Internally, the request/response control classes deal with encoding and decoding BER values.

For example, suppose an LDAP server supports a "signed results" request control, which when sent with a request, asks the server to digitally sign the results of an operation. It would supply a class SignedResultsControl so that applications can use this feature. An application would use this class as follows:

Control[] reqCtls = new Control[] {new SignedResultsControl(Control.CRITICAL)};
ectx.setRequestControls(reqCtls);
NamingEnumeration enum = ectx.search(...);
The SignedResultsControl class might be defined as follows:
public class SignedResultsControl implements Control {
    // User-friendly constructor
    public SignedResultsControl(boolean criticality) {
        // assemble the components of the request control
    };

    // Methods used by service providers
    public String getID() {
        return // control's object identifier
    }
    public byte[] getEncodedValue() {
        return // ASN.1 BER encoded control value
    }
    ...
}

When a service provider receives response controls, it uses the ControlFactory class to produce specific classes that implement the Control interface.

An LDAP server can send back response controls with an LDAP operation and also with enumeration results, such as those returned by a list or search operation. The LdapContext provides a method (getResponseControls()) for getting the response controls sent with an LDAP operation, while the HasControls interface is used to retrieve response controls associated with enumeration results.

For example, suppose an LDAP server sends back a "change ID" control in response to a successful modification. It would supply a class ChangeIDControl so that the application can use this feature. An application would perform an update, and then try to get the change ID.

// Perform update
Context ctx = ectx.createSubsubcontext("cn=newobj");

// Get response controls
Control[] respCtls = ectx.getResponseControls();
if (respCtls != null) {
    // Find the one we want
    for (int i = 0; i < respCtls; i++) {
        if(respCtls[i] instanceof ChangeIDControl) {
            ChangeIDControl cctl = (ChangeIDControl)respCtls[i];
            System.out.println(cctl.getChangeID());
        }
    }
}
The vendor might supply the following ChangeIDControl and VendorXControlFactory classes. The VendorXControlFactory will be used by the service provider when the provider receives response controls from the LDAP server.
public class ChangeIDControl implements Control {
    long id;

    // Constructor used by ControlFactory
    public ChangeIDControl(String OID, byte[] berVal) throws NamingException {
        // check validity of OID
        id = // extract change ID from berVal
    };

    // Type-safe and User-friendly method
    public long getChangeID() {
        return id;
    }

    // Low-level methods
    public String getID() {
        return CHANGEID_OID;
    }
    public byte[] getEncodedValue() {
        return // original berVal
    }
    ...
}
public class VendorXControlFactory extends ControlFactory {
    public VendorXControlFactory () {
    }

    public Control getControlInstance(Control orig) throws NamingException {
        if (isOneOfMyControls(orig.getID())) {
            ...

            // determine which of ours it is and call its constructor
            return (new ChangeIDControl(orig.getID(), orig.getEncodedValue()));
        }
        return null;  // not one of ours
    }
}

Package Specification

The JNDI API Specification and related documents can be found in the JNDI documentation.
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"enao><"s>>>"okk n


javax.naming.ldap Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.naming.ldap

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.naming.ldap.BasicControl (implements javax.naming.ldap.Control)
      • javax.naming.ldap.ManageReferralControl
      • javax.naming.ldap.PagedResultsControl
      • javax.naming.ldap.PagedResultsResponseControl
      • javax.naming.ldap.SortControl
      • javax.naming.ldap.SortResponseControl
    • javax.naming.ldap.ControlFactory
    • java.util.EventObject (implements java.io.Serializable)
      • javax.naming.ldap.UnsolicitedNotificationEvent
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
        • javax.naming.ldap.InitialLdapContext (implements javax.naming.ldap.LdapContext)
    • javax.naming.ldap.LdapName (implements javax.naming.Name)
    • javax.naming.ldap.Rdn (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.naming.ldap.SortKey
    • javax.naming.ldap.StartTlsRequest (implements javax.naming.ldap.ExtendedRequest)
    • javax.naming.ldap.StartTlsResponse (implements javax.naming.ldap.ExtendedResponse)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException

Interface Hierarchy

  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.ldap.LdapContext
  • java.util.EventListener
    • javax.naming.event.NamingListener
      • javax.naming.ldap.UnsolicitedNotificationListener
  • javax.naming.ldap.HasControls
    • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.ExtendedResponse)
  • java.io.Serializable
    • javax.naming.ldap.Control
    • javax.naming.ldap.ExtendedRequest
    • javax.naming.ldap.ExtendedResponse
      • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.HasControls)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

asnts netttgccco ooer


LdapContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface LdapContext

  • All Superinterfaces:
    Context, DirContext
    All Known Implementing Classes:
    InitialLdapContext

    public interface LdapContext
extends DirContext
    This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations. For applications that do not require such controls or extended operations, the more generic javax.naming.directory.DirContext should be used instead.

    Usage Details About Controls

    This interface provides support for LDAP v3 controls. At a high level, this support allows a user program to set request controls for LDAP operations that are executed in the course of the user program's invocation of Context/DirContext methods, and read response controls resulting from LDAP operations. At the implementation level, there are some details that developers of both the user program and service providers need to understand in order to correctly use request and response controls.

    Request Controls

    There are two types of request controls:

    • Request controls that affect how a connection is created
    • Request controls that affect context methods
    The former is used whenever a connection needs to be established or re-established with an LDAP server. The latter is used when all other LDAP operations are sent to the LDAP server. The reason why a distinction between these two types of request controls is necessary is because JNDI is a high-level API that does not deal directly with connections. It is the job of service providers to do any necessary connection management. Consequently, a single connection may be shared by multiple context instances, and a service provider is free to use its own algorithms to conserve connection and network usage. Thus, when a method is invoked on the context instance, the service provider might need to do some connection management in addition to performing the corresponding LDAP operations. For connection management, it uses the connection request controls, while for the normal LDAP operations, it uses the context request controls.

    Unless explicitly qualified, the term "request controls" refers to context request controls.

    Context Request Controls

    There are two ways in which a context instance gets its request controls:
    1. ldapContext.newInstance(reqCtls)
    2. ldapContext.setRequestControls(reqCtls)
    where ldapContext is an instance of LdapContext. Specifying null or an empty array for reqCtls means no request controls. newInstance() creates a new instance of a context using reqCtls, while setRequestControls() updates an existing context instance's request controls to reqCtls.

    Unlike environment properties, request controls of a context instance are not inherited by context instances that are derived from it. Derived context instances have null as their context request controls. You must set the request controls of a derived context instance explicitly using setRequestControls().

    A context instance's request controls are retrieved using the method getRequestControls().

    Connection Request Controls

    There are three ways in which connection request controls are set:
    1. new InitialLdapContext(env, connCtls)
    2. refException.getReferralContext(env, connCtls)
    3. ldapContext.reconnect(connCtls);
    where refException is an instance of LdapReferralException, and ldapContext is an instance of LdapContext. Specifying null or an empty array for connCtls means no connection request controls.

    Like environment properties, connection request controls of a context are inherited by contexts that are derived from it. Typically, you initialize the connection request controls using the InitialLdapContext constructor or LdapReferralContext.getReferralContext(). These connection request controls are inherited by contexts that share the same connection--that is, contexts derived from the initial or referral contexts.

    Use reconnect() to change the connection request controls of a context. Invoking ldapContext.reconnect() affects only the connection used by ldapContext and any new contexts instances that are derived form ldapContext. Contexts that previously shared the connection with ldapContext remain unchanged. That is, a context's connection request controls must be explicitly changed and is not affected by changes to another context's connection request controls.

    A context instance's connection request controls are retrieved using the method getConnectControls().

    Service Provider Requirements

    A service provider supports connection and context request controls in the following ways. Context request controls must be associated on a per context instance basis while connection request controls must be associated on a per connection instance basis. The service provider must look for the connection request controls in the environment property "java.naming.ldap.control.connect" and pass this environment property on to context instances that it creates.

    Response Controls

    The method LdapContext.getResponseControls() is used to retrieve the response controls generated by LDAP operations executed as the result of invoking a Context/DirContext operation. The result is all of the responses controls generated by the underlying LDAP operations, including any implicit reconnection. To get only the reconnection response controls, use reconnect() followed by getResponseControls().

    Parameters

    A Control[] array passed as a parameter to any method is owned by the caller. The service provider will not modify the array or keep a reference to it, although it may keep references to the individual Control objects in the array. A Control[] array returned by any method is immutable, and may not subsequently be modified by either the caller or the service provider.
    从以下版本开始：
    1.3
    另请参见：
    InitialLdapContext, LdapReferralException.getReferralContext(java.util.Hashtable,javax.naming.ldap.Control[])

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CONTROL_FACTORIES
      Constant that holds the name of the environment property for specifying the list of control factories to use.

      • 字段 - 继承于接口 javax.naming.directory.DirContext

        ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE

      • 字段 - 继承于接口 javax.naming.Context

        APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ExtendedResponse extendedOperation(ExtendedRequest request)
      Performs an extended operation.
      Control[] getConnectControls()
      Retrieves the connection request controls in effect for this context.
      Control[] getRequestControls()
      Retrieves the request controls in effect for this context.
      Control[] getResponseControls()
      Retrieves the response controls produced as a result of the last method invoked on this context.
      LdapContext newInstance(Control[] requestControls)
      Creates a new instance of this context initialized using request controls.
      void reconnect(Control[] connCtls)
      Reconnects to the LDAP server using the supplied controls and this context's environment.
      void setRequestControls(Control[] requestControls)
      Sets the request controls for methods subsequently invoked on this context.

      • 方法 - 继承于接口 javax.naming.directory.DirContext

        bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search

      • 方法 - 继承于接口 javax.naming.Context

        addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

    • 字段详细信息

      • CONTROL_FACTORIES

        static final String CONTROL_FACTORIES
        Constant that holds the name of the environment property for specifying the list of control factories to use. The value of the property should be a colon-separated list of the fully qualified class names of factory classes that will create a control given another control. See ControlFactory.getControlInstance() for details. This property may be specified in the environment, an applet parameter, a system property, or one or more resource files.

        The value of this constant is "java.naming.factory.control".

        另请参见：
        ControlFactory, Context.addToEnvironment(java.lang.String, java.lang.Object), Context.removeFromEnvironment(java.lang.String), Constant Field Values

    • 方法详细信息

      • extendedOperation

        ExtendedResponse extendedOperation(ExtendedRequest request)
                                   throws NamingException
        Performs an extended operation. This method is used to support LDAPv3 extended operations.
        参数：
        request - The non-null request to be performed.
        返回：
        The possibly null response of the operation. null means the operation did not generate any response.
        抛出：
        NamingException - If an error occurred while performing the extended operation.

      • newInstance

        LdapContext newInstance(Control[] requestControls)
                        throws NamingException
        Creates a new instance of this context initialized using request controls. This method is a convenience method for creating a new instance of this context for the purposes of multithreaded access. For example, if multiple threads want to use different context request controls, each thread may use this method to get its own copy of this context and set/get context request controls without having to synchronize with other threads.

        The new context has the same environment properties and connection request controls as this context. See the class description for details. Implementations might also allow this context and the new context to share the same network connection or other resources if doing so does not impede the independence of either context.

        参数：
        requestControls - The possibly null request controls to use for the new context. If null, the context is initialized with no request controls.
        返回：
        A non-null LdapContext instance.
        抛出：
        NamingException - If an error occurred while creating the new instance.
        另请参见：
        InitialLdapContext

      • reconnect

        void reconnect(Control[] connCtls)
               throws NamingException
        Reconnects to the LDAP server using the supplied controls and this context's environment.

        This method is a way to explicitly initiate an LDAP "bind" operation. For example, you can use this method to set request controls for the LDAP "bind" operation, or to explicitly connect to the server to get response controls returned by the LDAP "bind" operation.

        This method sets this context's connCtls to be its new connection request controls. This context's context request controls are not affected. After this method has been invoked, any subsequent implicit reconnections will be done using connCtls. connCtls are also used as connection request controls for new context instances derived from this context. These connection request controls are not affected by setRequestControls().

        Service provider implementors should read the "Service Provider" section in the class description for implementation details.

        参数：
        connCtls - The possibly null controls to use. If null, no controls are used.
        抛出：
        NamingException - If an error occurred while reconnecting.
        另请参见：
        getConnectControls(), newInstance(javax.naming.ldap.Control[])

      • getConnectControls

        Control[] getConnectControls()
                             throws NamingException
        Retrieves the connection request controls in effect for this context. The controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.
        返回：
        A possibly-null array of controls. null means no connect controls have been set for this context.
        抛出：
        NamingException - If an error occurred while getting the request controls.

      • setRequestControls

        void setRequestControls(Control[] requestControls)
                        throws NamingException
        Sets the request controls for methods subsequently invoked on this context. The request controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.

        This removes any previous request controls and adds requestControls for use by subsequent methods invoked on this context. This method does not affect this context's connection request controls.

        Note that requestControls will be in effect until the next invocation of setRequestControls(). You need to explicitly invoke setRequestControls() with null or an empty array to clear the controls if you don't want them to affect the context methods any more. To check what request controls are in effect for this context, use getRequestControls().

        参数：
        requestControls - The possibly null controls to use. If null, no controls are used.
        抛出：
        NamingException - If an error occurred while setting the request controls.
        另请参见：
        getRequestControls()

      • getRequestControls

        Control[] getRequestControls()
                             throws NamingException
        Retrieves the request controls in effect for this context. The request controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.
        返回：
        A possibly-null array of controls. null means no request controls have been set for this context.
        抛出：
        NamingException - If an error occurred while getting the request controls.
        另请参见：
        setRequestControls(javax.naming.ldap.Control[])

      • getResponseControls

        Control[] getResponseControls()
                              throws NamingException
        Retrieves the response controls produced as a result of the last method invoked on this context. The response controls are owned by the JNDI implementation and are immutable. Neither the array nor the controls may be modified by the caller.

        These response controls might have been generated by a successful or failed operation.

        When a context method that may return response controls is invoked, response controls from the previous method invocation are cleared. getResponseControls() returns all of the response controls generated by LDAP operations used by the context method in the order received from the LDAP server. Invoking getResponseControls() does not clear the response controls. You can call it many times (and get back the same controls) until the next context method that may return controls is invoked.

        返回：
        A possibly null array of controls. If null, the previous method invoked on this context did not produce any controls.
        抛出：
        NamingException - If an error occurred while getting the response controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l s


LdapName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 LdapName

  • java.lang.Object
    • javax.naming.ldap.LdapName
  • 所有已实现的接口：
    Serializable, Cloneable, Comparable<Object>, Name

    public class LdapName
extends Object
implements Name
    This class represents a distinguished name as specified by RFC 2253. A distinguished name, or DN, is composed of an ordered list of components called relative distinguished names, or RDNs. Details of a DN's syntax are described in RFC 2253.

    This class resolves a few ambiguities found in RFC 2253 as follows:

    • RFC 2253 leaves the term "whitespace" undefined. The ASCII space character 0x20 (" ") is used in its place.
    • Whitespace is allowed on either side of ',', ';', '=', and '+'. Such whitespace is accepted but not generated by this code, and is ignored when comparing names.
    • AttributeValue strings containing '=' or non-leading '#' characters (unescaped) are accepted.

    String names passed to LdapName or returned by it use the full Unicode character set. They may also contain characters encoded into UTF-8 with each octet represented by a three-character substring such as "\\B4". They may not, however, contain characters encoded into UTF-8 with each octet represented by a single character in the string: the meaning would be ambiguous.

    LdapName will properly parse all valid names, but does not attempt to detect all possible violations when parsing invalid names. It is "generous" in accepting invalid names. The "validity" of a name is determined ultimately when it is supplied to an LDAP server, which may accept or reject the name based on factors such as its schema information and interoperability considerations.

    When names are tested for equality, attribute types, both binary and string values, are case-insensitive. String values with different but equivalent usage of quoting, escaping, or UTF8-hex-encoding are considered equal. The order of components in multi-valued RDNs (such as "ou=Sales+cn=Bob") is not significant.

    The components of a LDAP name, that is, RDNs, are numbered. The indexes of a LDAP name with n RDNs range from 0 to n-1. This range may be written as [0,n). The right most RDN is at index 0, and the left most RDN is at index n-1. For example, the distinguished name: "CN=Steve Kille, O=Isode Limited, C=GB" is numbered in the following sequence ranging from 0 to 2: {C=GB, O=Isode Limited, CN=Steve Kille}. An empty LDAP name is represented by an empty RDN list.

    Concurrent multithreaded read-only access of an instance of LdapName need not be synchronized.

    Unless otherwise noted, the behavior of passing a null argument to a constructor or method in this class will cause a NullPointerException to be thrown.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      LdapName(List<Rdn> rdns)
      Constructs an LDAP name given its parsed RDN components.
      LdapName(String name)
      Constructs an LDAP name from the given distinguished name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Name add(int posn, Rdn comp)
      Adds a single RDN at a specified position within this LDAP name.
      Name add(int posn, String comp)
      Adds a single component at a specified position within this LDAP name.
      Name add(Rdn comp)
      Adds a single RDN to the end of this LDAP name.
      Name add(String comp)
      Adds a single component to the end of this LDAP name.
      Name addAll(int posn, List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- at a specified position within this name.
      Name addAll(int posn, Name suffix)
      Adds the components of a name -- in order -- at a specified position within this name.
      Name addAll(List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- to the end of this name.
      Name addAll(Name suffix)
      Adds the components of a name -- in order -- to the end of this name.
      Object clone()
      Generates a new copy of this name.
      int compareTo(Object obj)
      Compares this LdapName with the specified Object for order.
      boolean endsWith(List<Rdn> rdns)
      Determines whether the specified RDN sequence forms a suffix of this LDAP name.
      boolean endsWith(Name n)
      Determines whether this LDAP name ends with a specified LDAP name suffix.
      boolean equals(Object obj)
      Determines whether two LDAP names are equal.
      String get(int posn)
      Retrieves a component of this LDAP name as a string.
      Enumeration<String> getAll()
      Retrieves the components of this name as an enumeration of strings.
      Name getPrefix(int posn)
      Creates a name whose components consist of a prefix of the components of this LDAP name.
      Rdn getRdn(int posn)
      Retrieves an RDN of this LDAP name as an Rdn.
      List<Rdn> getRdns()
      Retrieves the list of relative distinguished names.
      Name getSuffix(int posn)
      Creates a name whose components consist of a suffix of the components in this LDAP name.
      int hashCode()
      Computes the hash code of this LDAP name.
      boolean isEmpty()
      Determines whether this LDAP name is empty.
      Object remove(int posn)
      Removes a component from this LDAP name.
      int size()
      Retrieves the number of components in this LDAP name.
      boolean startsWith(List<Rdn> rdns)
      Determines whether the specified RDN sequence forms a prefix of this LDAP name.
      boolean startsWith(Name n)
      Determines whether this LDAP name starts with a specified LDAP name prefix.
      String toString()
      Returns a string representation of this LDAP name in a format defined by RFC 2253 and described in the class description.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LdapName

        public LdapName(String name)
         throws InvalidNameException
        Constructs an LDAP name from the given distinguished name.
        参数：
        name - This is a non-null distinguished name formatted according to the rules defined in RFC 2253.
        抛出：
        InvalidNameException - if a syntax violation is detected.
        另请参见：
        Rdn.escapeValue(Object value)

      • LdapName

        public LdapName(List<Rdn> rdns)
        Constructs an LDAP name given its parsed RDN components.

        The indexing of RDNs in the list follows the numbering of RDNs described in the class description.

        参数：
        rdns - The non-null list of Rdns forming this LDAP name.

    • 方法详细信息

      • size

        public int size()
        Retrieves the number of components in this LDAP name.
        指定者：
        size in interface Name
        返回：
        The non-negative number of components in this LDAP name.

      • isEmpty

        public boolean isEmpty()
        Determines whether this LDAP name is empty. An empty name is one with zero components.
        指定者：
        isEmpty in interface Name
        返回：
        true if this LDAP name is empty, false otherwise.

      • getAll

        public Enumeration<String> getAll()
        Retrieves the components of this name as an enumeration of strings. The effect of updates to this name on this enumeration is undefined. If the name has zero components, an empty (non-null) enumeration is returned. The order of the components returned by the enumeration is same as the order in which the components are numbered as described in the class description.
        指定者：
        getAll in interface Name
        返回：
        A non-null enumeration of the components of this LDAP name. Each element of the enumeration is of class String.

      • get

        public String get(int posn)
        Retrieves a component of this LDAP name as a string.
        指定者：
        get in interface Name
        参数：
        posn - The 0-based index of the component to retrieve. Must be in the range [0,size()).
        返回：
        The non-null component at index posn.
        抛出：
        IndexOutOfBoundsException - if posn is outside the specified range.

      • getRdn

        public Rdn getRdn(int posn)
        Retrieves an RDN of this LDAP name as an Rdn.
        参数：
        posn - The 0-based index of the RDN to retrieve. Must be in the range [0,size()).
        返回：
        The non-null RDN at index posn.
        抛出：
        IndexOutOfBoundsException - if posn is outside the specified range.

      • getPrefix

        public Name getPrefix(int posn)
        Creates a name whose components consist of a prefix of the components of this LDAP name. Subsequent changes to this name will not affect the name that is returned and vice versa.
        指定者：
        getPrefix in interface Name
        参数：
        posn - The 0-based index of the component at which to stop. Must be in the range [0,size()].
        返回：
        An instance of LdapName consisting of the components at indexes in the range [0,posn). If posn is zero, an empty LDAP name is returned.
        抛出：
        IndexOutOfBoundsException - If posn is outside the specified range.

      • getSuffix

        public Name getSuffix(int posn)
        Creates a name whose components consist of a suffix of the components in this LDAP name. Subsequent changes to this name do not affect the name that is returned and vice versa.
        指定者：
        getSuffix in interface Name
        参数：
        posn - The 0-based index of the component at which to start. Must be in the range [0,size()].
        返回：
        An instance of LdapName consisting of the components at indexes in the range [posn,size()). If posn is equal to size(), an empty LDAP name is returned.
        抛出：
        IndexOutOfBoundsException - If posn is outside the specified range.

      • startsWith

        public boolean startsWith(Name n)
        Determines whether this LDAP name starts with a specified LDAP name prefix. A name 上一个 is a prefix if it is equal to getPrefix(n.size())--in other words this LDAP name starts with 'n'. If n is null or not a RFC2253 formatted name as described in the class description, false is returned.
        指定者：
        startsWith in interface Name
        参数：
        上一个 - The LDAP name to check.
        返回：
        true if 上一个 is a prefix of this LDAP name, false otherwise.
        另请参见：
        getPrefix(int posn)

      • startsWith

        public boolean startsWith(List<Rdn> rdns)
        Determines whether the specified RDN sequence forms a prefix of this LDAP name. Returns true if this LdapName is at least as long as rdns, and for every position p in the range [0, rdns.size()) the component getRdn(p) matches rdns.get(p). Returns false otherwise. If rdns is null, false is returned.
        参数：
        rdns - The sequence of Rdns to check.
        返回：
        true if rdns form a prefix of this LDAP name, false otherwise.

      • endsWith

        public boolean endsWith(Name n)
        Determines whether this LDAP name ends with a specified LDAP name suffix. A name 上一个 is a suffix if it is equal to getSuffix(size()-n.size())--in other words this LDAP name ends with 'n'. If n is null or not a RFC2253 formatted name as described in the class description, false is returned.
        指定者：
        endsWith in interface Name
        参数：
        上一个 - The LDAP name to check.
        返回：
        true if 上一个 is a suffix of this name, false otherwise.
        另请参见：
        getSuffix(int posn)

      • endsWith

        public boolean endsWith(List<Rdn> rdns)
        Determines whether the specified RDN sequence forms a suffix of this LDAP name. Returns true if this LdapName is at least as long as rdns, and for every position p in the range [size() - rdns.size(), size()) the component getRdn(p) matches rdns.get(p). Returns false otherwise. If rdns is null, false is returned.
        参数：
        rdns - The sequence of Rdns to check.
        返回：
        true if rdns form a suffix of this LDAP name, false otherwise.

      • addAll

        public Name addAll(Name suffix)
            throws InvalidNameException
        Adds the components of a name -- in order -- to the end of this name.
        指定者：
        addAll in interface Name
        参数：
        suffix - The non-null components to add.
        返回：
        The updated name (not a new instance).
        抛出：
        InvalidNameException - if suffix is not a valid LDAP name, or if the addition of the components would violate the syntax rules of this LDAP name.

      • addAll

        public Name addAll(List<Rdn> suffixRdns)
        Adds the RDNs of a name -- in order -- to the end of this name.
        参数：
        suffixRdns - The non-null suffix Rdns to add.
        返回：
        The updated name (not a new instance).

      • addAll

        public Name addAll(int posn,
          Name suffix)
            throws InvalidNameException
        Adds the components of a name -- in order -- at a specified position within this name. Components of this LDAP name at or after the index (if any) of the first new component are shifted up (away from index 0) to accomodate the new components.
        指定者：
        addAll in interface Name
        参数：
        suffix - The non-null components to add.
        posn - The index at which to add the new component. Must be in the range [0,size()].
        返回：
        The updated name (not a new instance).
        抛出：
        InvalidNameException - if suffix is not a valid LDAP name, or if the addition of the components would violate the syntax rules of this LDAP name.
        IndexOutOfBoundsException. - If posn is outside the specified range.

      • addAll

        public Name addAll(int posn,
          List<Rdn> suffixRdns)
        Adds the RDNs of a name -- in order -- at a specified position within this name. RDNs of this LDAP name at or after the index (if any) of the first new RDN are shifted up (away from index 0) to accomodate the new RDNs.
        参数：
        suffixRdns - The non-null suffix Rdns to add.
        posn - The index at which to add the suffix RDNs. Must be in the range [0,size()].
        返回：
        The updated name (not a new instance).
        抛出：
        IndexOutOfBoundsException. - If posn is outside the specified range.

      • add

        public Name add(String comp)
         throws InvalidNameException
        Adds a single component to the end of this LDAP name.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        返回：
        The updated LdapName, not a new instance. Cannot be null.
        抛出：
        InvalidNameException - If adding comp at end of the name would violate the name's syntax.

      • add

        public Name add(Rdn comp)
        Adds a single RDN to the end of this LDAP name.
        参数：
        comp - The non-null RDN to add.
        返回：
        The updated LdapName, not a new instance. Cannot be null.

      • add

        public Name add(int posn,
       String comp)
         throws InvalidNameException
        Adds a single component at a specified position within this LDAP name. Components of this LDAP name at or after the index (if any) of the new component are shifted up by one (away from index 0) to accommodate the new component.
        指定者：
        add in interface Name
        参数：
        comp - The non-null component to add.
        posn - The index at which to add the new component. Must be in the range [0,size()].
        返回：
        The updated LdapName, not a new instance. Cannot be null.
        抛出：
        IndexOutOfBoundsException. - If posn is outside the specified range.
        InvalidNameException - If adding comp at the specified position would violate the name's syntax.

      • add

        public Name add(int posn,
       Rdn comp)
        Adds a single RDN at a specified position within this LDAP name. RDNs of this LDAP name at or after the index (if any) of the new RDN are shifted up by one (away from index 0) to accommodate the new RDN.
        参数：
        comp - The non-null RDN to add.
        posn - The index at which to add the new RDN. Must be in the range [0,size()].
        返回：
        The updated LdapName, not a new instance. Cannot be null.
        抛出：
        IndexOutOfBoundsException - If posn is outside the specified range.

      • remove

        public Object remove(int posn)
              throws InvalidNameException
        Removes a component from this LDAP name. The component of this name at the specified position is removed. Components with indexes greater than this position (if any) are shifted down (toward index 0) by one.
        指定者：
        remove in interface Name
        参数：
        posn - The index of the component to remove. Must be in the range [0,size()).
        返回：
        The component removed (a String).
        抛出：
        IndexOutOfBoundsException - if posn is outside the specified range.
        InvalidNameException - if deleting the component would violate the syntax rules of the name.

      • getRdns

        public List<Rdn> getRdns()
        Retrieves the list of relative distinguished names. The contents of the list are unmodifiable. The indexing of RDNs in the returned list follows the numbering of RDNs as described in the class description. If the name has zero components, an empty list is returned.
        返回：
        The name as a list of RDNs which are instances of the class Rdn.

      • clone

        public Object clone()
        Generates a new copy of this name. Subsequent changes to the components of this name will not affect the new copy, and vice versa.
        指定者：
        clone in interface Name
        重载：
        clone in class Object
        返回：
        A copy of the this LDAP name.
        另请参见：
        Cloneable

      • toString

        public String toString()
        Returns a string representation of this LDAP name in a format defined by RFC 2253 and described in the class description. If the name has zero components an empty string is returned.
        重载：
        toString in class Object
        返回：
        The string representation of the LdapName.

      • equals

        public boolean equals(Object obj)
        Determines whether two LDAP names are equal. If obj is null or not an LDAP name, false is returned.

        Two LDAP names are equal if each RDN in one is equal to the corresponding RDN in the other. This implies both have the same number of RDNs, and each RDN's equals() test against the corresponding RDN in the other name returns true. See Rdn.equals(Object obj) for a definition of RDN equality.

        重载：
        equals in class Object
        参数：
        obj - The possibly null object to compare against.
        返回：
        true if obj is equal to this LDAP name, false otherwise.
        另请参见：
        hashCode()

      • compareTo

        public int compareTo(Object obj)
        Compares this LdapName with the specified Object for order. Returns a negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given Object.

        If obj is null or not an instance of LdapName, ClassCastException is thrown.

        Ordering of LDAP names follows the lexicographical rules for string comparison, with the extension that this applies to all the RDNs in the LDAP name. All the RDNs are lined up in their specified order and compared lexicographically. See Rdn.compareTo(Object obj) for RDN comparison rules.

        If this LDAP name is lexicographically lesser than obj, a negative number is returned. If this LDAP name is lexicographically greater than obj, a positive number is returned.

        指定者：
        compareTo in interface Comparable<Object>
        指定者：
        compareTo in interface Name
        参数：
        obj - The non-null LdapName instance to compare against.
        返回：
        A negative integer, zero, or a positive integer as this Name is less than, equal to, or greater than the given obj.
        抛出：
        ClassCastException - if obj is null or not a LdapName.
        另请参见：
        Comparable.compareTo(Object)

      • hashCode

        public int hashCode()
        Computes the hash code of this LDAP name. The hash code is the sum of the hash codes of individual RDNs of this name.
        重载：
        hashCode in class Object
        返回：
        An int representing the hash code of this name.
        另请参见：
        equals(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oc"n


LdapReferralException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 LdapReferralException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException
  • 所有已实现的接口：
    Serializable

    public abstract class LdapReferralException
extends ReferralException
    This abstract class is used to represent an LDAP referral exception. It extends the base ReferralException by providing a getReferralContext() method that accepts request controls. LdapReferralException is an abstract class. Concrete implementations of it determine its synchronization and serialization properties.

    A Control[] array passed as a parameter to the getReferralContext() method is owned by the caller. The service provider will not modify the array or keep a reference to it, although it may keep references to the individual Control objects in the array.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.naming.NamingException

        remainingName, resolvedName, resolvedObj, rootException

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected LdapReferralException()
      Constructs a new instance of LdapReferralException.
      protected LdapReferralException(String explanation)
      Constructs a new instance of LdapReferralException using the explanation supplied.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Context getReferralContext()
      Retrieves the context at which to continue the method using the context's environment and no controls.
      abstract Context getReferralContext(Hashtable<?,?> env)
      Retrieves the context at which to continue the method using environment properties and no controls.
      abstract Context getReferralContext(Hashtable<?,?> env, Control[] reqCtls)
      Retrieves the context at which to continue the method using request controls and environment properties.

      • 方法 - 继承于类 javax.naming.ReferralException

        getReferralInfo, retryReferral, skipReferral

      • 方法 - 继承于类 javax.naming.NamingException

        appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LdapReferralException

        protected LdapReferralException(String explanation)
        Constructs a new instance of LdapReferralException using the explanation supplied. All other fields are set to null.
        参数：
        explanation - Additional detail about this exception. Can be null.
        另请参见：
        Throwable.getMessage()

      • LdapReferralException

        protected LdapReferralException()
        Constructs a new instance of LdapReferralException. All fields are set to null.

    • 方法详细信息

      • getReferralContext

        public abstract Context getReferralContext()
                                    throws NamingException
        Retrieves the context at which to continue the method using the context's environment and no controls. The referral context is created using the environment properties of the context that threw the ReferralException and no controls.

        This method is equivalent to

         getReferralContext(ctx.getEnvironment(), null);
        where ctx is the context that threw the ReferralException.

        It is overridden in this class for documentation purposes only. See ReferralException for how to use this method.

        指定者：
        getReferralContext in class ReferralException
        返回：
        The non-null context at which to continue the method.
        抛出：
        NamingException - If a naming exception was encountered. Call either retryReferral() or skipReferral() to continue processing referrals.

      • getReferralContext

        public abstract Context getReferralContext(Hashtable<?,?> env)
                                    throws NamingException
        Retrieves the context at which to continue the method using environment properties and no controls. The referral context is created using env as its environment properties and no controls.

        This method is equivalent to

         getReferralContext(env, null);

        It is overridden in this class for documentation purposes only. See ReferralException for how to use this method.

        指定者：
        getReferralContext in class ReferralException
        参数：
        env - The possibly null environment to use when retrieving the referral context. If null, no environment properties will be used.
        返回：
        The non-null context at which to continue the method.
        抛出：
        NamingException - If a naming exception was encountered. Call either retryReferral() or skipReferral() to continue processing referrals.

      • getReferralContext

        public abstract Context getReferralContext(Hashtable<?,?> env,
                         Control[] reqCtls)
                                    throws NamingException
        Retrieves the context at which to continue the method using request controls and environment properties. Regardless of whether a referral is encountered directly during a context operation, or indirectly, for example, during a search enumeration, the referral exception should provide a context at which to continue the operation. To continue the operation, the client program should re-invoke the method using the same arguments as the original invocation.

        reqCtls is used when creating the connection to the referred server. These controls will be used as the connection request controls for the context and context instances derived from the context. reqCtls will also be the context's request controls for subsequent context operations. See the LdapContext class description for details.

        This method should be used instead of the other two overloaded forms when the caller needs to supply request controls for creating the referral context. It might need to do this, for example, when it needs to supply special controls relating to authentication.

        Service provider implementors should read the "Service Provider" section in the LdapContext class description for implementation details.

        参数：
        reqCtls - The possibly null request controls to use for the new context. If null or the empty array means use no request controls.
        env - The possibly null environment properties to use when for the new context. If null, the context is initialized with no environment properties.
        返回：
        The non-null context at which to continue the method.
        抛出：
        NamingException - If a naming exception was encountered. Call either retryReferral() or skipReferral() to continue processing referrals.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dorsro roinnoiimlmm ahh thhmnhietni oresii .e


ManageReferralControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.ldap

类 ManageReferralControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
      • javax.naming.ldap.ManageReferralControl
  • 所有已实现的接口：
    Serializable, Control

    public final class ManageReferralControl
extends BasicControl
    Requests that referral and other special LDAP objects be manipulated as normal LDAP objects. It enables the requestor to interrogate or update such objects.

    This class implements the LDAPv3 Request Control for ManageDsaIT as defined in RFC 3296. The control has no control value.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The ManageReferral control's assigned object identifier is 2.16.840.1.113730.3.4.2.

      • Fields inherited from class javax.naming.ldap.BasicControl

        criticality, id, value

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      ManageReferralControl()
      Constructs a critical ManageReferral control.
      ManageReferralControl(boolean criticality)
      Constructs a ManageReferral control.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.ldap.BasicControl

        getEncodedValue, getID, isCritical

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The ManageReferral control's assigned object identifier is 2.16.840.1.113730.3.4.2.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ManageReferralControl

        public ManageReferralControl()
        Constructs a critical ManageReferral control.

      • ManageReferralControl

        public ManageReferralControl(boolean criticality)
        Constructs a ManageReferral control.
        参数：
        criticality - The control's criticality setting.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/iO//.=..=f""=ffat##.cnlctt(nl(yhbtjmlmljat


PagedResultsControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.ldap

类 PagedResultsControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
      • javax.naming.ldap.PagedResultsControl
  • 所有已实现的接口：
    Serializable, Control

    public final class PagedResultsControl
extends BasicControl
    Requests that the results of a search operation be returned by the LDAP server in batches of a specified size. The requestor controls the rate at which batches are returned by the rate at which it invokes search operations.

    The following code sample shows how the class may be used:

     // Open an LDAP association
     LdapContext ctx = new InitialLdapContext();

     // Activate paged results
     int pageSize = 20; // 20 entries per page
     byte[] cookie = null;
     int total;
     ctx.setRequestControls(new Control[]{
         new PagedResultsControl(pageSize, Control.CRITICAL) });

     do {
         // Perform the search
         NamingEnumeration results =
             ctx.search("", "(objectclass=*)", new SearchControls());

         // Iterate over a batch of search results
         while (results != null && results.hasMore()) {
             // Display an entry
             SearchResult entry = (SearchResult)results.next();
             System.out.println(entry.getName());
             System.out.println(entry.getAttributes());

             // Handle the entry's response controls (if any)
             if (entry instanceof HasControls) {
                 // ((HasControls)entry).getControls();
             }
         }
         // Examine the paged results control response
         Control[] controls = ctx.getResponseControls();
         if (controls != null) {
             for (int i = 0; i < controls.length; i++) {
                 if (controls[i] instanceof PagedResultsResponseControl) {
                     PagedResultsResponseControl prrc =
                         (PagedResultsResponseControl)controls[i];
                     total = prrc.getResultSize();
                     cookie = prrc.getCookie();
                 } else {
                     // Handle other response controls (if any)
                 }
             }
         }

         // Re-activate paged results
         ctx.setRequestControls(new Control[]{
             new PagedResultsControl(pageSize, cookie, Control.CRITICAL) });
     } while (cookie != null);

     // Close the LDAP association
     ctx.close();
     ...

    This class implements the LDAPv3 Control for paged-results as defined in RFC 2696. The control's value has the following ASN.1 definition:

     realSearchControlValue ::= SEQUENCE {
         size      INTEGER (0..maxInt),
                           -- requested page size from client
                           -- result set size estimate from server
         cookie    OCTET STRING
     }
    从以下版本开始：
    1.5
    另请参见：
    PagedResultsResponseControl, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The paged-results control's assigned object identifier is 1.2.840.113556.1.4.319.

      • Fields inherited from class javax.naming.ldap.BasicControl

        criticality, id, value

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      PagedResultsControl(int pageSize, boolean criticality)
      Constructs a control to set the number of entries to be returned per page of results.
      PagedResultsControl(int pageSize, byte[] cookie, boolean criticality)
      Constructs a control to set the number of entries to be returned per page of results.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.ldap.BasicControl

        getEncodedValue, getID, isCritical

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The paged-results control's assigned object identifier is 1.2.840.113556.1.4.319.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PagedResultsControl

        public PagedResultsControl(int pageSize,
                   boolean criticality)
                    throws IOException
        Constructs a control to set the number of entries to be returned per page of results.
        参数：
        pageSize - The number of entries to return in a page.
        criticality - If true then the server must honor the control and return search results as indicated by pageSize or refuse to perform the search. If false, then the server need not honor the control.
        抛出：
        IOException - If an error was encountered while encoding the supplied arguments into a control.

      • PagedResultsControl

        public PagedResultsControl(int pageSize,
                   byte[] cookie,
                   boolean criticality)
                    throws IOException
        Constructs a control to set the number of entries to be returned per page of results. The cookie is provided by the server and may be obtained from the paged-results response control.

        A sequence of paged-results can be abandoned by setting the pageSize to zero and setting the cookie to the last cookie received from the server.

        参数：
        pageSize - The number of entries to return in a page.
        cookie - A possibly null server-generated cookie.
        criticality - If true then the server must honor the control and return search results as indicated by pageSize or refuse to perform the search. If false, then the server need not honor the control.
        抛出：
        IOException - If an error was encountered while encoding the supplied arguments into a control.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m tgnsansasa ccpe<. ieo evreisteyFnttte>tyw


PagedResultsResponseControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 PagedResultsResponseControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
      • javax.naming.ldap.PagedResultsResponseControl
  • 所有已实现的接口：
    Serializable, Control

    public final class PagedResultsResponseControl
extends BasicControl
    Indicates the end of a batch of search results. Contains an estimate of the total number of entries in the result set and an opaque cookie. The cookie must be supplied to the next search operation in order to get the next batch of results.

    The code sample in PagedResultsControl shows how this class may be used.

    This class implements the LDAPv3 Response Control for paged-results as defined in RFC 2696. The control's value has the following ASN.1 definition:

     realSearchControlValue ::= SEQUENCE {
         size      INTEGER (0..maxInt),
                           -- requested page size from client
                           -- result set size estimate from server
         cookie    OCTET STRING
     }
    从以下版本开始：
    1.5
    另请参见：
    PagedResultsControl, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The paged-results response control's assigned object identifier is 1.2.840.113556.1.4.319.

      • Fields inherited from class javax.naming.ldap.BasicControl

        criticality, id, value

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      PagedResultsResponseControl(String id, boolean criticality, byte[] value)
      Constructs a paged-results response control.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getCookie()
      Retrieves the server-generated cookie.
      int getResultSize()
      Retrieves (an estimate of) the number of entries in the search result.

      • 方法 - 继承于类 javax.naming.ldap.BasicControl

        getEncodedValue, getID, isCritical

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The paged-results response control's assigned object identifier is 1.2.840.113556.1.4.319.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PagedResultsResponseControl

        public PagedResultsResponseControl(String id,
                           boolean criticality,
                           byte[] value)
                            throws IOException
        Constructs a paged-results response control.
        参数：
        id - The control's object identifier string.
        criticality - The control's criticality.
        value - The control's ASN.1 BER encoded value. It is not cloned - any changes to value will affect the contents of the control.
        抛出：
        IOException - If an error was encountered while decoding the control's value.

    • 方法详细信息

      • getResultSize

        public int getResultSize()
        Retrieves (an estimate of) the number of entries in the search result.
        返回：
        The number of entries in the search result, or zero if unknown.

      • getCookie

        public byte[] getCookie()
        Retrieves the server-generated cookie. Null is returned when there are no more entries for the server to return.
        返回：
        A possibly null server-generated cookie. It is not cloned - any changes to the cookie will update the control's state and thus are not recommended.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> "b" "}"k } e ldda"nctlls"se_beasltIyalll el


Rdn

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 Rdn

  • java.lang.Object
    • javax.naming.ldap.Rdn
  • 所有已实现的接口：
    Serializable, Comparable<Object>

    public class Rdn
extends Object
implements Serializable, Comparable<Object>
    This class represents a relative distinguished name, or RDN, which is a component of a distinguished name as specified by RFC 2253. An example of an RDN is "OU=Sales+CN=J.Smith". In this example, the RDN consist of multiple attribute type/value pairs. The RDN is parsed as described in the class description for LdapName.

    The Rdn class represents an RDN as attribute type/value mappings, which can be viewed using Attributes. In addition, it contains convenience methods that allow easy retrieval of type and value when the Rdn consist of a single type/value pair, which is how it appears in a typical usage. It also contains helper methods that allow escaping of the unformatted attribute value and unescaping of the value formatted according to the escaping syntax defined in RFC2253. For methods that take or return attribute value as an Object, the value is either a String (in unescaped form) or a byte array.

    Rdn will properly parse all valid RDNs, but does not attempt to detect all possible violations when parsing invalid RDNs. It is "generous" in accepting invalid RDNs. The "validity" of a name is determined ultimately when it is supplied to an LDAP server, which may accept or reject the name based on factors such as its schema information and interoperability considerations.

    The following code example shows how to construct an Rdn using the constructor that takes type and value as arguments:

          Rdn rdn = new Rdn("cn", "Juicy, Fruit");
      System.out.println(rdn.toString());
    The last line will print cn=Juicy\, Fruit. The unescapeValue() method can be used to unescape the escaped comma resulting in the original value "Juicy, Fruit". The escapeValue() method adds the escape back preceding the comma.

    This class can be instantiated by a string representation of the RDN defined in RFC 2253 as shown in the following code example:

          Rdn rdn = new Rdn("cn=Juicy\\, Fruit");
      System.out.println(rdn.toString());
    The last line will print cn=Juicy\, Fruit.

    Concurrent multithreaded read-only access of an instance of Rdn need not be synchronized.

    Unless otherwise noted, the behavior of passing a null argument to a constructor or method in this class will cause NullPointerException to be thrown.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Rdn(Attributes attrSet)
      Constructs an Rdn from the given attribute set.
      Rdn(Rdn rdn)
      Constructs an Rdn from the given rdn.
      Rdn(String rdnString)
      Constructs an Rdn from the given string.
      Rdn(String type, Object value)
      Constructs an Rdn from the given attribute type and value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int compareTo(Object obj)
      Compares this Rdn with the specified Object for order.
      boolean equals(Object obj)
      Compares the specified Object with this Rdn for equality.
      static String escapeValue(Object val)
      Given the value of an attribute, returns a string escaped according to the rules specified in RFC 2253.
      String getType()
      Retrieves one of this Rdn's type.
      Object getValue()
      Retrieves one of this Rdn's value.
      int hashCode()
      Returns the hash code of this RDN.
      int size()
      Retrieves the number of attribute type/value pairs in this Rdn.
      Attributes toAttributes()
      Retrieves the Attributes view of the type/value mappings contained in this Rdn.
      String toString()
      Returns this Rdn as a string represented in a format defined by RFC 2253 and described in the class description for LdapName.
      static Object unescapeValue(String val)
      Given an attribute value string formated according to the rules specified in RFC 2253, returns the unformated value.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Rdn

        public Rdn(Attributes attrSet)
    throws InvalidNameException
        Constructs an Rdn from the given attribute set. See Attributes.

        The string attribute values are not interpretted as RFC 2253 formatted RDN strings. That is, the values are used literally (not parsed) and assumed to be unescaped.

        参数：
        attrSet - The non-null and non-empty attributes containing type/value mappings.
        抛出：
        InvalidNameException - If contents of attrSet cannot be used to construct a valid RDN.

      • Rdn

        public Rdn(String rdnString)
    throws InvalidNameException
        Constructs an Rdn from the given string. This constructor takes a string formatted according to the rules defined in RFC 2253 and described in the class description for LdapName.
        参数：
        rdnString - The non-null and non-empty RFC2253 formatted string.
        抛出：
        InvalidNameException - If a syntax error occurs during parsing of the rdnString.

      • Rdn

        public Rdn(Rdn rdn)
        Constructs an Rdn from the given rdn. The contents of the rdn are simply copied into the newly created Rdn.
        参数：
        rdn - The non-null Rdn to be copied.

      • Rdn

        public Rdn(String type,
   Object value)
    throws InvalidNameException
        Constructs an Rdn from the given attribute type and value. The string attribute values are not interpretted as RFC 2253 formatted RDN strings. That is, the values are used literally (not parsed) and assumed to be unescaped.
        参数：
        type - The non-null and non-empty string attribute type.
        value - The non-null and non-empty attribute value.
        抛出：
        InvalidNameException - If type/value cannot be used to construct a valid RDN.
        另请参见：
        toString()

    • 方法详细信息

      • getValue

        public Object getValue()
        Retrieves one of this Rdn's value. This is a convenience method for obtaining the value, when the RDN contains a single type and value mapping, which is the common RDN usage.

        For a multi-valued RDN, this method returns value corresponding to the type returned by getType() method.

        返回：
        The non-null attribute value.

      • getType

        public String getType()
        Retrieves one of this Rdn's type. This is a convenience method for obtaining the type, when the RDN contains a single type and value mapping, which is the common RDN usage.

        For a multi-valued RDN, the type/value pairs have no specific order defined on them. In that case, this method returns type of one of the type/value pairs. The getValue() method returns the value corresponding to the type returned by this method.

        返回：
        The non-null attribute type.

      • toString

        public String toString()
        Returns this Rdn as a string represented in a format defined by RFC 2253 and described in the class description for LdapName.
        重载：
        toString in class Object
        返回：
        The string representation of the Rdn.

      • compareTo

        public int compareTo(Object obj)
        Compares this Rdn with the specified Object for order. Returns a negative integer, zero, or a positive integer as this Rdn is less than, equal to, or greater than the given Object.

        If obj is null or not an instance of Rdn, ClassCastException is thrown.

        The attribute type and value pairs of the RDNs are lined up against each other and compared lexicographically. The order of components in multi-valued Rdns (such as "ou=Sales+cn=Bob") is not significant.

        指定者：
        compareTo in interface Comparable<Object>
        参数：
        obj - The non-null object to compare against.
        返回：
        A negative integer, zero, or a positive integer as this Rdn is less than, equal to, or greater than the given Object.
        抛出：
        ClassCastException - if obj is null or not a Rdn.

      • equals

        public boolean equals(Object obj)
        Compares the specified Object with this Rdn for equality. Returns true if the given object is also a Rdn and the two Rdns represent the same attribute type and value mappings. The order of components in multi-valued Rdns (such as "ou=Sales+cn=Bob") is not significant.

        Type and value equalilty matching is done as below:

        • The types are compared for equality with their case ignored.
        • String values with different but equivalent usage of quoting, escaping, or UTF8-hex-encoding are considered equal. The case of the values is ignored during the comparison.

        If obj is null or not an instance of Rdn, false is returned.

        重载：
        equals in class Object
        参数：
        obj - object to be compared for equality with this Rdn.
        返回：
        true if the specified object is equal to this Rdn.
        另请参见：
        hashCode()

      • hashCode

        public int hashCode()
        Returns the hash code of this RDN. Two RDNs that are equal (according to the equals method) will have the same hash code.
        重载：
        hashCode in class Object
        返回：
        An int representing the hash code of this Rdn.
        另请参见：
        equals(java.lang.Object)

      • toAttributes

        public Attributes toAttributes()
        Retrieves the Attributes view of the type/value mappings contained in this Rdn.
        返回：
        The non-null attributes containing the type/value mappings of this Rdn.

      • size

        public int size()
        Retrieves the number of attribute type/value pairs in this Rdn.
        返回：
        The non-negative number of type/value pairs in this Rdn.

      • escapeValue

        public static String escapeValue(Object val)
        Given the value of an attribute, returns a string escaped according to the rules specified in RFC 2253.

        For example, if the val is "Sue, Grabbit and Runn", the escaped value returned by this method is "Sue\, Grabbit and Runn".

        A string value is represented as a String and binary value as a byte array.

        参数：
        val - The non-null object to be escaped.
        返回：
        Escaped string value.
        抛出：
        ClassCastException - if val is is not a String or byte array.

      • unescapeValue

        public static Object unescapeValue(String val)
        Given an attribute value string formated according to the rules specified in RFC 2253, returns the unformated value. Escapes and quotes are stripped away, and hex-encoded UTF-8 is converted to equivalent UTF-16 characters. Returns a string value as a String, and a binary value as a byte array.

        Legal and illegal values are defined in RFC 2253. This method is generous in accepting the values and does not catch all illegal values. Therefore, passing in an illegal value might not necessarily trigger an IllegalArgumentException.

        参数：
        val - The non-null string to be unescaped.
        返回：
        Unescaped value.
        抛出：
        IllegalArgumentException - When an Illegal value is provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


SortControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.naming.ldap

类 SortControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
      • javax.naming.ldap.SortControl
  • 所有已实现的接口：
    Serializable, Control

    public final class SortControl
extends BasicControl
    Requests that the results of a search operation be sorted by the LDAP server before being returned. The sort criteria are specified using an ordered list of one or more sort keys, with associated sort parameters. Search results are sorted at the LDAP server according to the parameters supplied in the sort control and then returned to the requestor. If sorting is not supported at the server (and the sort control is marked as critical) then the search operation is not performed and an error is returned.

    The following code sample shows how the class may be used:

     // Open an LDAP association
     LdapContext ctx = new InitialLdapContext();

     // Activate sorting
     String sortKey = "cn";
     ctx.setRequestControls(new Control[]{
         new SortControl(sortKey, Control.CRITICAL) });

     // Perform a search
     NamingEnumeration results =
         ctx.search("", "(objectclass=*)", new SearchControls());

     // Iterate over search results
     while (results != null && results.hasMore()) {
         // Display an entry
         SearchResult entry = (SearchResult)results.next();
         System.out.println(entry.getName());
         System.out.println(entry.getAttributes());

         // Handle the entry's response controls (if any)
         if (entry instanceof HasControls) {
             // ((HasControls)entry).getControls();
         }
     }
     // Examine the sort control response
     Control[] controls = ctx.getResponseControls();
     if (controls != null) {
         for (int i = 0; i < controls.length; i++) {
             if (controls[i] instanceof SortResponseControl) {
                 SortResponseControl src = (SortResponseControl)controls[i];
                 if (! src.isSorted()) {
                     throw src.getException();
                 }
             } else {
                 // Handle other response controls (if any)
             }
         }
     }

     // Close the LDAP association
     ctx.close();
     ...

    This class implements the LDAPv3 Request Control for server-side sorting as defined in RFC 2891. The control's value has the following ASN.1 definition:

     SortKeyList ::= SEQUENCE OF SEQUENCE {
         attributeType     AttributeDescription,
         orderingRule  [0] MatchingRuleId OPTIONAL,
         reverseOrder  [1] BOOLEAN DEFAULT FALSE }
    从以下版本开始：
    1.5
    另请参见：
    SortKey, SortResponseControl, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The server-side sort control's assigned object identifier is 1.2.840.113556.1.4.473.

      • Fields inherited from class javax.naming.ldap.BasicControl

        criticality, id, value

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      SortControl(SortKey[] sortBy, boolean criticality)
      Constructs a control to sort on a list of sort keys.
      SortControl(String[] sortBy, boolean criticality)
      Constructs a control to sort on a list of attributes in ascending order.
      SortControl(String sortBy, boolean criticality)
      Constructs a control to sort on a single attribute in ascending order.

    • 方法摘要

      • 方法 - 继承于类 javax.naming.ldap.BasicControl

        getEncodedValue, getID, isCritical

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The server-side sort control's assigned object identifier is 1.2.840.113556.1.4.473.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SortControl

        public SortControl(String sortBy,
           boolean criticality)
            throws IOException
        Constructs a control to sort on a single attribute in ascending order. Sorting will be performed using the ordering matching rule defined for use with the specified attribute.
        参数：
        sortBy - An attribute ID to sort by.
        criticality - If true then the server must honor the control and return the search results sorted as requested or refuse to perform the search. If false, then the server need not honor the control.
        抛出：
        IOException - If an error was encountered while encoding the supplied arguments into a control.

      • SortControl

        public SortControl(String[] sortBy,
           boolean criticality)
            throws IOException
        Constructs a control to sort on a list of attributes in ascending order. Sorting will be performed using the ordering matching rule defined for use with each of the specified attributes.
        参数：
        sortBy - A non-null list of attribute IDs to sort by. The list is in order of highest to lowest sort key precedence.
        criticality - If true then the server must honor the control and return the search results sorted as requested or refuse to perform the search. If false, then the server need not honor the control.
        抛出：
        IOException - If an error was encountered while encoding the supplied arguments into a control.

      • SortControl

        public SortControl(SortKey[] sortBy,
           boolean criticality)
            throws IOException
        Constructs a control to sort on a list of sort keys. Each sort key specifies the sort order and ordering matching rule to use.
        参数：
        sortBy - A non-null list of keys to sort by. The list is in order of highest to lowest sort key precedence.
        criticality - If true then the server must honor the control and return the search results sorted as requested or refuse to perform the search. If false, then the server need not honor the control.
        抛出：
        IOException - If an error was encountered while encoding the supplied arguments into a control.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"(m a/eed>d<>ssatsptiovd>dsvat


SortKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 SortKey

  • java.lang.Object
    • javax.naming.ldap.SortKey

  • public class SortKey
extends Object
    A sort key and its associated sort parameters. This class implements a sort key which is used by the LDAPv3 Control for server-side sorting of search results as defined in RFC 2891.
    从以下版本开始：
    1.5
    另请参见：
    SortControl

    • 构造方法摘要

      Constructors
      构造方法与描述
      SortKey(String attrID)
      Creates the default sort key for an attribute.
      SortKey(String attrID, boolean ascendingOrder, String matchingRuleID)
      Creates a sort key for an attribute.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAttributeID()
      Retrieves the attribute ID of the sort key.
      String getMatchingRuleID()
      Retrieves the matching rule ID used to order the attribute values.
      boolean isAscending()
      Determines the sort order.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SortKey

        public SortKey(String attrID)
        Creates the default sort key for an attribute. Entries will be sorted according to the specified attribute in ascending order using the ordering matching rule defined for use with that attribute.
        参数：
        attrID - The non-null ID of the attribute to be used as a sort key.

      • SortKey

        public SortKey(String attrID,
       boolean ascendingOrder,
       String matchingRuleID)
        Creates a sort key for an attribute. Entries will be sorted according to the specified attribute in the specified sort order and using the specified matching rule, if supplied.
        参数：
        attrID - The non-null ID of the attribute to be used as a sort key.
        ascendingOrder - If true then entries are arranged in ascending order. Otherwise there are arranged in descending order.
        matchingRuleID - The possibly null ID of the matching rule to use to order the attribute values. If not specified then the ordering matching rule defined for the sort key attribute is used.

    • 方法详细信息

      • getAttributeID

        public String getAttributeID()
        Retrieves the attribute ID of the sort key.
        返回：
        The non-null Attribute ID of the sort key.

      • isAscending

        public boolean isAscending()
        Determines the sort order.
        返回：
        true if the sort order is ascending, false if descending.

      • getMatchingRuleID

        public String getMatchingRuleID()
        Retrieves the matching rule ID used to order the attribute values.
        返回：
        The possibly null matching rule ID. If null then the ordering matching rule defined for the sort key attribute is used.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,s gv.la.lo((looCm t h ao ngrne tn"


SortResponseControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 SortResponseControl

  • java.lang.Object
    • javax.naming.ldap.BasicControl
      • javax.naming.ldap.SortResponseControl
  • 所有已实现的接口：
    Serializable, Control

    public final class SortResponseControl
extends BasicControl
    Indicates whether the requested sort of search results was successful or not. When the result code indicates success then the results have been sorted as requested. Otherwise the sort was unsuccessful and additional details regarding the cause of the error may have been provided by the server.

    The code sample in SortControl shows how this class may be used.

    This class implements the LDAPv3 Response Control for server-side sorting as defined in RFC 2891. The control's value has the following ASN.1 definition:

     SortResult ::= SEQUENCE {
        sortResult  ENUMERATED {
            success                   (0), -- results are sorted
            operationsError           (1), -- server internal failure
            timeLimitExceeded         (3), -- timelimit reached before
                                           -- sorting was completed
            strongAuthRequired        (8), -- refused to return sorted
                                           -- results via insecure
                                           -- protocol
            adminLimitExceeded       (11), -- too many matching entries
                                           -- for the server to sort
            noSuchAttribute          (16), -- unrecognized attribute
                                           -- type in sort key
            inappropriateMatching    (18), -- unrecognized or inappro-
                                           -- priate matching rule in
                                           -- sort key
            insufficientAccessRights (50), -- refused to return sorted
                                           -- results to this client
            busy                     (51), -- too busy to process
            unwillingToPerform       (53), -- unable to sort
            other                    (80)
            },
      attributeType [0] AttributeType OPTIONAL }
    从以下版本开始：
    1.5
    另请参见：
    SortControl, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The server-side sort response control's assigned object identifier is 1.2.840.113556.1.4.474.

      • Fields inherited from class javax.naming.ldap.BasicControl

        criticality, id, value

      • 字段 - 继承于接口 javax.naming.ldap.Control

        CRITICAL, NONCRITICAL

    • 构造方法摘要

      Constructors
      构造方法与描述
      SortResponseControl(String id, boolean criticality, byte[] value)
      Constructs a control to indicate the outcome of a sort request.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAttributeID()
      Retrieves the ID of the attribute that caused the sort to fail.
      NamingException getException()
      Retrieves the NamingException appropriate for the result code.
      int getResultCode()
      Retrieves the LDAP result code of the sort operation.
      boolean isSorted()
      Determines if the search results have been successfully sorted.

      • 方法 - 继承于类 javax.naming.ldap.BasicControl

        getEncodedValue, getID, isCritical

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The server-side sort response control's assigned object identifier is 1.2.840.113556.1.4.474.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SortResponseControl

        public SortResponseControl(String id,
                   boolean criticality,
                   byte[] value)
                    throws IOException
        Constructs a control to indicate the outcome of a sort request.
        参数：
        id - The control's object identifier string.
        criticality - The control's criticality.
        value - The control's ASN.1 BER encoded value. It is not cloned - any changes to value will affect the contents of the control.
        抛出：
        IOException - if an error is encountered while decoding the control's value.

    • 方法详细信息

      • isSorted

        public boolean isSorted()
        Determines if the search results have been successfully sorted. If an error occurred during sorting a NamingException is thrown.
        返回：
        true if the search results have been sorted.

      • getResultCode

        public int getResultCode()
        Retrieves the LDAP result code of the sort operation.
        返回：
        The result code. A zero value indicates success.

      • getAttributeID

        public String getAttributeID()
        Retrieves the ID of the attribute that caused the sort to fail. Returns null if no ID was returned by the server.
        返回：
        The possibly null ID of the bad attribute.

      • getException

        public NamingException getException()
        Retrieves the NamingException appropriate for the result code.
        返回：
        A NamingException or null if the result code indicates success.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./..r.a./."/./..ec.eaeyrcprmply/..Crcagmrc


StartTlsRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 StartTlsRequest

  • java.lang.Object
    • javax.naming.ldap.StartTlsRequest
  • 所有已实现的接口：
    Serializable, ExtendedRequest

    public class StartTlsRequest
extends Object
implements ExtendedRequest
    This class implements the LDAPv3 Extended Request for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended request value is defined.

    StartTlsRequest/StartTlsResponse are used to establish a TLS connection over the existing LDAP connection associated with the JNDI context on which extendedOperation() is invoked. Typically, a JNDI program uses these classes as follows.

     import javax.naming.ldap.*;

 // Open an LDAP association
 LdapContext ctx = new InitialLdapContext();

 // Perform a StartTLS extended operation
 StartTlsResponse tls =
     (StartTlsResponse) ctx.extendedOperation(new StartTlsRequest());

 // Open a TLS connection (over the existing LDAP association) and get details
 // of the negotiated TLS session: cipher suite, peer certificate, etc.
 SSLSession session = tls.negotiate();

 // ... use ctx to perform protected LDAP operations

 // Close the TLS connection (revert back to the underlying LDAP association)
 tls.close();

 // ... use ctx to perform unprotected LDAP operations

 // Close the LDAP association
 ctx.close;
    从以下版本开始：
    1.4
    另请参见：
    StartTlsResponse, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The StartTLS extended request's assigned object identifier is 1.3.6.1.4.1.1466.20037.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StartTlsRequest()
      Constructs a StartTLS extended request.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ExtendedResponse createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates an extended response object that corresponds to the LDAP StartTLS extended request.
      byte[] getEncodedValue()
      Retrieves the StartTLS request's ASN.1 BER encoded value.
      String getID()
      Retrieves the StartTLS request's object identifier string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The StartTLS extended request's assigned object identifier is 1.3.6.1.4.1.1466.20037.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StartTlsRequest

        public StartTlsRequest()
        Constructs a StartTLS extended request.

    • 方法详细信息

      • getID

        public String getID()
        Retrieves the StartTLS request's object identifier string.
        指定者：
        getID in interface ExtendedRequest
        返回：
        The object identifier string, "1.3.6.1.4.1.1466.20037".

      • getEncodedValue

        public byte[] getEncodedValue()
        Retrieves the StartTLS request's ASN.1 BER encoded value. Since the request has no defined value, null is always returned.
        指定者：
        getEncodedValue in interface ExtendedRequest
        返回：
        The null value.

      • createExtendedResponse

        public ExtendedResponse createExtendedResponse(String id,
                                      byte[] berValue,
                                      int offset,
                                      int length)
                                        throws NamingException
        Creates an extended response object that corresponds to the LDAP StartTLS extended request.

        The result must be a concrete subclass of StartTlsResponse and must have a public zero-argument constructor.

        This method locates the implementation class by locating configuration files that have the name:

        META-INF/services/javax.naming.ldap.StartTlsResponse
        The configuration files and their corresponding implementation classes must be accessible to the calling thread's context class loader.

        Each configuration file should contain a list of fully-qualified class names, one per line. Space and tab characters surrounding each name, as well as blank lines, are ignored. The comment character is '#' (0x23); on each line all characters following the first comment character are ignored. The file must be encoded in UTF-8.

        This method will return an instance of the first implementation class that it is able to load and instantiate successfully from the list of class names collected from the configuration files. This method uses the calling thread's context classloader to find the configuration files and to load the implementation class.

        If no class can be found in this way, this method will use an implementation-specific way to locate an implementation. If none is found, a NamingException is thrown.

        指定者：
        createExtendedResponse in interface ExtendedRequest
        参数：
        id - The object identifier of the extended response. Its value must be "1.3.6.1.4.1.1466.20037" or null. Both values are equivalent.
        berValue - The possibly null ASN.1 BER encoded value of the extended response. This is the raw BER bytes including the tag and length of the response value. It does not include the response OID. Its value is ignored because a Start TLS response is not expected to contain any response value.
        offset - The starting position in berValue of the bytes to use. Its value is ignored because a Start TLS response is not expected to contain any response value.
        length - The number of bytes in berValue to use. Its value is ignored because a Start TLS response is not expected to contain any response value.
        返回：
        The StartTLS extended response object.
        抛出：
        NamingException - If a naming exception was encountered while creating the StartTLS extended response object.
        另请参见：
        ExtendedResponse
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n"Arrr rDrtn>草&pb�sp;ep 3<13


StartTlsResponse

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 StartTlsResponse

  • java.lang.Object
    • javax.naming.ldap.StartTlsResponse
  • 所有已实现的接口：
    Serializable, ExtendedResponse

    public abstract class StartTlsResponse
extends Object
implements ExtendedResponse
    This class implements the LDAPv3 Extended Response for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended response value is defined.

    The Start TLS extended request and response are used to establish a TLS connection over the existing LDAP connection associated with the JNDI context on which extendedOperation() is invoked. Typically, a JNDI program uses the StartTLS extended request and response classes as follows.

     import javax.naming.ldap.*;

 // Open an LDAP association
 LdapContext ctx = new InitialLdapContext();

 // Perform a StartTLS extended operation
 StartTlsResponse tls =
     (StartTlsResponse) ctx.extendedOperation(new StartTlsRequest());

 // Open a TLS connection (over the existing LDAP association) and get details
 // of the negotiated TLS session: cipher suite, peer certificate, ...
 SSLSession session = tls.negotiate();

 // ... use ctx to perform protected LDAP operations

 // Close the TLS connection (revert back to the underlying LDAP association)
 tls.close();

 // ... use ctx to perform unprotected LDAP operations

 // Close the LDAP association
 ctx.close;
    从以下版本开始：
    1.4
    另请参见：
    StartTlsRequest, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String OID
      The StartTLS extended response's assigned object identifier is 1.3.6.1.4.1.1466.20037.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected StartTlsResponse()
      Constructs a StartTLS extended response.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void close()
      Closes the TLS connection gracefully and reverts back to the underlying connection.
      byte[] getEncodedValue()
      Retrieves the StartTLS response's ASN.1 BER encoded value.
      String getID()
      Retrieves the StartTLS response's object identifier string.
      abstract SSLSession negotiate()
      Negotiates a TLS session using the default SSL socket factory.
      abstract SSLSession negotiate(SSLSocketFactory factory)
      Negotiates a TLS session using an SSL socket factory.
      abstract void setEnabledCipherSuites(String[] suites)
      Overrides the default list of cipher suites enabled for use on the TLS connection.
      abstract void setHostnameVerifier(HostnameVerifier verifier)
      Sets the hostname verifier used by negotiate() after the TLS handshake has completed and the default hostname verification has failed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • OID

        public static final String OID
        The StartTLS extended response's assigned object identifier is 1.3.6.1.4.1.1466.20037.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StartTlsResponse

        protected StartTlsResponse()
        Constructs a StartTLS extended response. A concrete subclass must have a public no-arg constructor.

    • 方法详细信息

      • getID

        public String getID()
        Retrieves the StartTLS response's object identifier string.
        指定者：
        getID in interface ExtendedResponse
        返回：
        The object identifier string, "1.3.6.1.4.1.1466.20037".

      • getEncodedValue

        public byte[] getEncodedValue()
        Retrieves the StartTLS response's ASN.1 BER encoded value. Since the response has no defined value, null is always returned.
        指定者：
        getEncodedValue in interface ExtendedResponse
        返回：
        The null value.

      • setEnabledCipherSuites

        public abstract void setEnabledCipherSuites(String[] suites)
        Overrides the default list of cipher suites enabled for use on the TLS connection. The cipher suites must have already been listed by SSLSocketFactory.getSupportedCipherSuites() as being supported. Even if a suite has been enabled, it still might not be used because the peer does not support it, or because the requisite certificates (and private keys) are not available.
        参数：
        suites - The non-null list of names of all the cipher suites to enable.
        另请参见：
        negotiate()

      • setHostnameVerifier

        public abstract void setHostnameVerifier(HostnameVerifier verifier)
        Sets the hostname verifier used by negotiate() after the TLS handshake has completed and the default hostname verification has failed. setHostnameVerifier() must be called before negotiate() is invoked for it to have effect. If called after negotiate(), this method does not do anything.
        参数：
        verifier - The non-null hostname verifier callback.
        另请参见：
        negotiate()

      • negotiate

        public abstract SSLSession negotiate()
                              throws IOException
        Negotiates a TLS session using the default SSL socket factory.

        This method is equivalent to negotiate(null).

        返回：
        The negotiated SSL session
        抛出：
        IOException - If an IO error was encountered while establishing the TLS session.
        另请参见：
        setEnabledCipherSuites(java.lang.String[]), setHostnameVerifier(javax.net.ssl.HostnameVerifier)

      • negotiate

        public abstract SSLSession negotiate(SSLSocketFactory factory)
                              throws IOException
        Negotiates a TLS session using an SSL socket factory.

        Creates an SSL socket using the supplied SSL socket factory and attaches it to the existing connection. Performs the TLS handshake and returns the negotiated session information.

        If cipher suites have been set via setEnabledCipherSuites then they are enabled before the TLS handshake begins.

        Hostname verification is performed after the TLS handshake completes. The default hostname verification performs a match of the server's hostname against the hostname information found in the server's certificate. If this verification fails and no callback has been set via setHostnameVerifier then the negotiation fails. If this verification fails and a callback has been set via setHostnameVerifier, then the callback is used to determine whether the negotiation succeeds.

        If an error occurs then the SSL socket is closed and an IOException is thrown. The underlying connection remains intact.

        参数：
        factory - The possibly null SSL socket factory to use. If null, the default SSL socket factory is used.
        返回：
        The negotiated SSL session
        抛出：
        IOException - If an IO error was encountered while establishing the TLS session.
        另请参见：
        setEnabledCipherSuites(java.lang.String[]), setHostnameVerifier(javax.net.ssl.HostnameVerifier)

      • close

        public abstract void close()
                    throws IOException
        Closes the TLS connection gracefully and reverts back to the underlying connection.
        抛出：
        IOException - If an IO error was encountered while closing the TLS connection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a# i = a1REtofilb< f


UnsolicitedNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface UnsolicitedNotification

  • All Superinterfaces:
    ExtendedResponse, HasControls, Serializable

    public interface UnsolicitedNotification
extends ExtendedResponse, HasControls
    This interface represents an unsolicited notification as defined in RFC 2251. An unsolicited notification is sent by the LDAP server to the LDAP client without any provocation from the client. Its format is that of an extended response (ExtendedResponse).
    从以下版本开始：
    1.3
    另请参见：
    ExtendedResponse, UnsolicitedNotificationEvent, UnsolicitedNotificationListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      NamingException getException()
      Retrieves the exception as constructed using information sent by the server.
      String[] getReferrals()
      Retrieves the referral(s) sent by the server.

      • 方法 - 继承于接口 javax.naming.ldap.ExtendedResponse

        getEncodedValue, getID

      • 方法 - 继承于接口 javax.naming.ldap.HasControls

        getControls

    • 方法详细信息

      • getReferrals

        String[] getReferrals()
        Retrieves the referral(s) sent by the server.
        返回：
        A possibly null array of referrals, each of which is represented by a URL string. If null, no referral was sent by the server.

      • getException

        NamingException getException()
        Retrieves the exception as constructed using information sent by the server.
        返回：
        A possibly null exception as constructed using information sent by the server. If null, a "success" status was indicated by the server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>c L< s s.__nonj


UnsolicitedNotificationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.ldap

类 UnsolicitedNotificationEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.naming.ldap.UnsolicitedNotificationEvent
  • 所有已实现的接口：
    Serializable

    public class UnsolicitedNotificationEvent
extends EventObject
    This class represents an event fired in response to an unsolicited notification sent by the LDAP server.
    从以下版本开始：
    1.3
    另请参见：
    UnsolicitedNotification, UnsolicitedNotificationListener, EventContext.addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener), EventDirContext.addNamingListener(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls, javax.naming.event.NamingListener), EventContext.removeNamingListener(javax.naming.event.NamingListener), Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
      Constructs a new instance of UnsolicitedNotificationEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispatch(UnsolicitedNotificationListener listener)
      Invokes the notificationReceived() method on a listener using this event.
      UnsolicitedNotification getNotification()
      Returns the unsolicited notification.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnsolicitedNotificationEvent

        public UnsolicitedNotificationEvent(Object src,
                            UnsolicitedNotification notice)
        Constructs a new instance of UnsolicitedNotificationEvent.
        参数：
        src - The non-null source that fired the event.
        notice - The non-null unsolicited notification.

    • 方法详细信息

      • getNotification

        public UnsolicitedNotification getNotification()
        Returns the unsolicited notification.
        返回：
        The non-null unsolicited notification that caused this event to be fired.

      • dispatch

        public void dispatch(UnsolicitedNotificationListener listener)
        Invokes the notificationReceived() method on a listener using this event.
        参数：
        listener - The non-null listener on which to invoke notificationReceived.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fe dpo>pogn gnns)iiiuhs=ommv" aiy lllnSe


UnsolicitedNotificationListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.ldap

Interface UnsolicitedNotificationListener

  • All Superinterfaces:
    EventListener, NamingListener

    public interface UnsolicitedNotificationListener
extends NamingListener
    This interface is for handling UnsolicitedNotificationEvent. "Unsolicited notification" is defined in RFC 2251. It allows the server to send unsolicited notifications to the client. A UnsolicitedNotificationListener must:
    1. Implement this interface and its method
    2. Implement NamingListener.namingExceptionThrown() so that it will be notified of exceptions thrown while attempting to collect unsolicited notification events.
    3. Register with the context using one of the addNamingListener() methods from EventContext or EventDirContext. Only the NamingListener argument of these methods are applicable; the rest are ignored for a UnsolicitedNotificationListener. (These arguments might be applicable to the listener if it implements other listener interfaces).
    从以下版本开始：
    1.3
    另请参见：
    UnsolicitedNotificationEvent,
UnsolicitedNotification,
EventContext.addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener),
EventDirContext.addNamingListener(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls, javax.naming.event.NamingListener),
EventContext.removeNamingListener(javax.naming.event.NamingListener)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void notificationReceived(UnsolicitedNotificationEvent evt)
      Called when an unsolicited notification has been received.

      • 方法 - 继承于接口 javax.naming.event.NamingListener

        namingExceptionThrown

    • 方法详细信息

      • notificationReceived

        void notificationReceived(UnsolicitedNotificationEvent evt)
        Called when an unsolicited notification has been received.
        参数：
        evt - The non-null UnsolicitedNotificationEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d< suuouunllunn eoonvino/


Uses of Package javax.naming.ldap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.naming.ldap

  • Packages that use javax.naming.ldap
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
  • Classes in javax.naming.ldap used by javax.naming.ldap
    类与描述
    BasicControl
    This class provides a basic implementation of the Control interface.
    Control
    This interface represents an LDAPv3 control as defined in RFC 2251.
    ExtendedRequest
    This interface represents an LDAPv3 extended operation request as defined in RFC 2251.
    ExtendedResponse
    This interface represents an LDAP extended operation response as defined in RFC 2251.
    HasControls
    This interface is for returning controls with objects returned in NamingEnumerations.
    LdapContext
    This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations.
    Rdn
    This class represents a relative distinguished name, or RDN, which is a component of a distinguished name as specified by RFC 2253.
    SortKey
    A sort key and its associated sort parameters.
    UnsolicitedNotification
    This interface represents an unsolicited notification as defined in RFC 2251.
    UnsolicitedNotificationEvent
    This class represents an event fired in response to an unsolicited notification sent by the LDAP server.
    UnsolicitedNotificationListener
    This interface is for handling UnsolicitedNotificationEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"v>mvav eiiiferre=cce>a.


Uses of Class javax.naming.ldap.BasicControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.BasicControl

  • Packages that use BasicControl
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of BasicControl in javax.naming.ldap

      Subclasses of BasicControl in javax.naming.ldap
      修饰符与类型 类与描述
      class  ManageReferralControl
      Requests that referral and other special LDAP objects be manipulated as normal LDAP objects.
      class  PagedResultsControl
      Requests that the results of a search operation be returned by the LDAP server in batches of a specified size.
      class  PagedResultsResponseControl
      Indicates the end of a batch of search results.
      class  SortControl
      Requests that the results of a search operation be sorted by the LDAP server before being returned.
      class  SortResponseControl
      Indicates whether the requested sort of search results was successful or not.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tEhi a< g


Uses of Class javax.naming.ldap.ControlFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.ControlFactory

No usage of javax.naming.ldap.ControlFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=u"ttrostCCCs///>;a=a


Uses of Class javax.naming.ldap.InitialLdapContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.InitialLdapContext

No usage of javax.naming.ldap.InitialLdapContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

msiv..//..... <


Uses of Class javax.naming.ldap.LdapName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.LdapName

No usage of javax.naming.ldap.LdapName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.naming.ldap.LdapReferralException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.LdapReferralException

No usage of javax.naming.ldap.LdapReferralException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ef=>xbigm�>t/ ao衋


Uses of Class javax.naming.ldap.ManageReferralControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.ManageReferralControl

No usage of javax.naming.ldap.ManageReferralControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f=�$詆辱� t<


Uses of Class javax.naming.ldap.PagedResultsControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.PagedResultsControl

No usage of javax.naming.ldap.PagedResultsControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.naming.ldap.PagedResultsResponseControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.PagedResultsResponseControl

No usage of javax.naming.ldap.PagedResultsResponseControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Vc/../ttirta>rs;te)


Uses of Class javax.naming.ldap.Rdn

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.Rdn

  • Packages that use Rdn
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of Rdn in javax.naming.ldap

      Methods in javax.naming.ldap that return Rdn
      修饰符与类型 方法与描述
      Rdn LdapName.getRdn(int posn)
      Retrieves an RDN of this LDAP name as an Rdn.
      Methods in javax.naming.ldap that return types with arguments of type Rdn
      修饰符与类型 方法与描述
      List<Rdn> LdapName.getRdns()
      Retrieves the list of relative distinguished names.
      Methods in javax.naming.ldap with parameters of type Rdn
      修饰符与类型 方法与描述
      Name LdapName.add(int posn, Rdn comp)
      Adds a single RDN at a specified position within this LDAP name.
      Name LdapName.add(Rdn comp)
      Adds a single RDN to the end of this LDAP name.
      Method parameters in javax.naming.ldap with type arguments of type Rdn
      修饰符与类型 方法与描述
      Name LdapName.addAll(int posn, List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- at a specified position within this name.
      Name LdapName.addAll(List<Rdn> suffixRdns)
      Adds the RDNs of a name -- in order -- to the end of this name.
      boolean LdapName.endsWith(List<Rdn> rdns)
      Determines whether the specified RDN sequence forms a suffix of this LDAP name.
      boolean LdapName.startsWith(List<Rdn> rdns)
      Determines whether the specified RDN sequence forms a prefix of this LDAP name.
      Constructors in javax.naming.ldap with parameters of type Rdn
      构造方法与描述
      Rdn(Rdn rdn)
      Constructs an Rdn from the given rdn.
      Constructor parameters in javax.naming.ldap with type arguments of type Rdn
      构造方法与描述
      LdapName(List<Rdn> rdns)
      Constructs an LDAP name given its parsed RDN components.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tmmce/x>csfsnkc h."e


Uses of Class javax.naming.ldap.SortControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.SortControl

No usage of javax.naming.ldap.SortControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=o


Uses of Class javax.naming.ldap.SortKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.SortKey

  • Packages that use SortKey
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of SortKey in javax.naming.ldap

      Constructors in javax.naming.ldap with parameters of type SortKey
      构造方法与描述
      SortControl(SortKey[] sortBy, boolean criticality)
      Constructs a control to sort on a list of sort keys.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ebddmnn


Uses of Class javax.naming.ldap.SortResponseControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.SortResponseControl

No usage of javax.naming.ldap.SortResponseControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.h.hi><>i


Uses of Class javax.naming.ldap.StartTlsRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.StartTlsRequest

No usage of javax.naming.ldap.StartTlsRequest
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s


Uses of Class javax.naming.ldap.StartTlsResponse

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.StartTlsResponse

No usage of javax.naming.ldap.StartTlsResponse
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l黀@snj | (O


Uses of Class javax.naming.ldap.UnsolicitedNotificationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.ldap.UnsolicitedNotificationEvent

  • Packages that use UnsolicitedNotificationEvent
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of UnsolicitedNotificationEvent in javax.naming.ldap

      Methods in javax.naming.ldap with parameters of type UnsolicitedNotificationEvent
      修饰符与类型 方法与描述
      void UnsolicitedNotificationListener.notificationReceived(UnsolicitedNotificationEvent evt)
      Called when an unsolicited notification has been received.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt>ia/


Uses of Interface javax.naming.ldap.Control

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.Control

  • Packages that use Control
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of Control in javax.naming.ldap

      Classes in javax.naming.ldap that implement Control
      修饰符与类型 类与描述
      class  BasicControl
      This class provides a basic implementation of the Control interface.
      class  ManageReferralControl
      Requests that referral and other special LDAP objects be manipulated as normal LDAP objects.
      class  PagedResultsControl
      Requests that the results of a search operation be returned by the LDAP server in batches of a specified size.
      class  PagedResultsResponseControl
      Indicates the end of a batch of search results.
      class  SortControl
      Requests that the results of a search operation be sorted by the LDAP server before being returned.
      class  SortResponseControl
      Indicates whether the requested sort of search results was successful or not.
      Methods in javax.naming.ldap that return Control
      修饰符与类型 | 方法与描述
      Control[] | InitialLdapContext.getConnectControls()
      Control[] LdapContext.getConnectControls()
      Retrieves the connection request controls in effect for this context.
      abstract Control ControlFactory.getControlInstance(Control ctl)
      Creates a control using this control factory.
      static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
      Creates a control using known control factories.
      Control[] HasControls.getControls()
      Retrieves an array of Controls from the object that implements this interface.
      Control[] | InitialLdapContext.getRequestControls()
      Control[] LdapContext.getRequestControls()
      Retrieves the request controls in effect for this context.
      Control[] | InitialLdapContext.getResponseControls()
      Control[] LdapContext.getResponseControls()
      Retrieves the response controls produced as a result of the last method invoked on this context.
      Methods in javax.naming.ldap with parameters of type Control
      修饰符与类型 | 方法与描述
      abstract Control ControlFactory.getControlInstance(Control ctl)
      Creates a control using this control factory.
      static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
      Creates a control using known control factories.
      abstract Context LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls)
      Retrieves the context at which to continue the method using request controls and environment properties.
      LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
      LdapContext LdapContext.newInstance(Control[] requestControls)
      Creates a new instance of this context initialized using request controls.
      void | InitialLdapContext.reconnect(Control[] connCtls)
      void LdapContext.reconnect(Control[] connCtls)
      Reconnects to the LDAP server using the supplied controls and this context's environment.
      void | InitialLdapContext.setRequestControls(Control[] requestControls)
      void LdapContext.setRequestControls(Control[] requestControls)
      Sets the request controls for methods subsequently invoked on this context.
      Constructors in javax.naming.ldap with parameters of type Control
      构造方法与描述
      InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
      Constructs an initial context using environment properties and connection request controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r&.tt/rrrsit>穉.


Uses of Interface javax.naming.ldap.ExtendedRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.ExtendedRequest

  • Packages that use ExtendedRequest
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of ExtendedRequest in javax.naming.ldap

      Classes in javax.naming.ldap that implement ExtendedRequest
      修饰符与类型 类与描述
      class  StartTlsRequest
      This class implements the LDAPv3 Extended Request for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended request value is defined.
      Methods in javax.naming.ldap with parameters of type ExtendedRequest
      修饰符与类型 | 方法与描述
      ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
      ExtendedResponse LdapContext.extendedOperation(ExtendedRequest request)
      Performs an extended operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. phaR#>ujhf/ r/ "i


Uses of Interface javax.naming.ldap.ExtendedResponse

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.ExtendedResponse

  • Packages that use ExtendedResponse
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of ExtendedResponse in javax.naming.ldap

      Subinterfaces of ExtendedResponse in javax.naming.ldap
      修饰符与类型 Interface and Description
      interface  UnsolicitedNotification
      This interface represents an unsolicited notification as defined in RFC 2251.
      Classes in javax.naming.ldap that implement ExtendedResponse
      修饰符与类型 类与描述
      class  StartTlsResponse
      This class implements the LDAPv3 Extended Response for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended response value is defined.
      Methods in javax.naming.ldap that return ExtendedResponse
      修饰符与类型 | 方法与描述
      ExtendedResponse StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates an extended response object that corresponds to the LDAP StartTLS extended request.
      ExtendedResponse ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
      Creates the response object that corresponds to this request.
      ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
      ExtendedResponse LdapContext.extendedOperation(ExtendedRequest request)
      Performs an extended operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p/ i vthte/lcs/ehtl


Uses of Interface javax.naming.ldap.HasControls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.HasControls

  • Packages that use HasControls
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of HasControls in javax.naming.ldap

      Subinterfaces of HasControls in javax.naming.ldap
      修饰符与类型 Interface and Description
      interface  UnsolicitedNotification
      This interface represents an unsolicited notification as defined in RFC 2251.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


Uses of Interface javax.naming.ldap.LdapContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.LdapContext

  • Packages that use LdapContext
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of LdapContext in javax.naming.ldap

      Classes in javax.naming.ldap that implement LdapContext
      修饰符与类型 类与描述
      class  InitialLdapContext
      This class is the starting context for performing LDAPv3-style extended operations and controls.
      Methods in javax.naming.ldap that return LdapContext
      修饰符与类型 | 方法与描述
      LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
      LdapContext LdapContext.newInstance(Control[] requestControls)
      Creates a new instance of this context initialized using request controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. =i-<<;/r萊snoh蕋ae


Uses of Interface javax.naming.ldap.UnsolicitedNotification

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.UnsolicitedNotification

  • Packages that use UnsolicitedNotification
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of UnsolicitedNotification in javax.naming.ldap

      Methods in javax.naming.ldap that return UnsolicitedNotification
      修饰符与类型 方法与描述
      UnsolicitedNotification UnsolicitedNotificationEvent.getNotification()
      Returns the unsolicited notification.
      Constructors in javax.naming.ldap with parameters of type UnsolicitedNotification
      构造方法与描述
      UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
      Constructs a new instance of UnsolicitedNotificationEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/ nj=vypwhc"e=j/f 萺aa


Uses of Interface javax.naming.ldap.UnsolicitedNotificationListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.ldap.UnsolicitedNotificationListener

  • Packages that use UnsolicitedNotificationListener
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.

    • Uses of UnsolicitedNotificationListener in javax.naming.ldap

      Methods in javax.naming.ldap with parameters of type UnsolicitedNotificationListener
      修饰符与类型 方法与描述
      void UnsolicitedNotificationEvent.dispatch(UnsolicitedNotificationListener listener)
      Invokes the notificationReceived() method on a listener using this event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esdld"aanl at p=>lt


DirectoryManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

类 DirectoryManager

  • java.lang.Object
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager

  • public class DirectoryManager
extends NamingManager
    This class contains methods for supporting DirContext implementations.

    This class is an extension of NamingManager. It contains methods for use by service providers for accessing object factories and state factories, and for getting continuation contexts for supporting federation.

    DirectoryManager is safe for concurrent access by multiple threads.

    Except as otherwise noted, a Name, Attributes, or environment parameter passed to any method is owned by the caller. The implementation will not modify the object or keep a reference to it, although it may keep a reference to a clone or copy.

    从以下版本开始：
    1.3
    另请参见：
    DirObjectFactory, DirStateFactory

    • 字段摘要

      • Fields inherited from class javax.naming.spi.NamingManager

        CPE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static DirContext getContinuationDirContext(CannotProceedException cpe)
      Creates a context in which to continue a DirContext operation.
      static Object getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an instance of an object for the specified object, attributes, and environment.
      static DirStateFactory.Result getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.

      • 方法 - 继承于类 javax.naming.spi.NamingManager

        getContinuationContext, getInitialContext, getObjectInstance, getStateToBind, getURLContext, hasInitialContextFactoryBuilder, setInitialContextFactoryBuilder, setObjectFactoryBuilder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getContinuationDirContext

        public static DirContext getContinuationDirContext(CannotProceedException cpe)
                                            throws NamingException
        Creates a context in which to continue a DirContext operation. Operates just like NamingManager.getContinuationContext(), only the continuation context returned is a DirContext.
        参数：
        cpe - The non-null exception that triggered this continuation.
        返回：
        A non-null DirContext object for continuing the operation.
        抛出：
        NamingException - If a naming exception occurred.
        另请参见：
        NamingManager.getContinuationContext(CannotProceedException)

      • getObjectInstance

        public static Object getObjectInstance(Object refInfo,
                       Name name,
                       Context nameCtx,
                       Hashtable<?,?> environment,
                       Attributes attrs)
                                throws Exception
        Creates an instance of an object for the specified object, attributes, and environment.

        This method is the same as NamingManager.getObjectInstance except for the following differences:

        • It accepts an Attributes parameter that contains attributes associated with the object. The DirObjectFactory might use these attributes to save having to look them up from the directory.
        • The object factories tried must implement either ObjectFactory or DirObjectFactory. If it implements DirObjectFactory, DirObjectFactory.getObjectInstance() is used, otherwise, ObjectFactory.getObjectInstance() is used.
        Service providers that implement the DirContext interface should use this method, not NamingManager.getObjectInstance().

        参数：
        refInfo - The possibly null object for which to create an object.
        name - The name of this object relative to nameCtx. Specifying a name is optional; if it is omitted, name should be null.
        nameCtx - The context relative to which the name parameter is specified. If null, name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the object factory and the object.
        attrs - The possibly null attributes associated with refInfo. This might not be the complete set of attributes for refInfo; you might be able to read more attributes from the directory.
        返回：
        An object created using refInfo and attrs; or refInfo if an object cannot be created by a factory.
        抛出：
        NamingException - If a naming exception was encountered while attempting to get a URL context, or if one of the factories accessed throws a NamingException.
        Exception - If one of the factories accessed throws an exception, or if an error was encountered while loading and instantiating the factory and object classes. A factory should only throw an exception if it does not want other factories to be used in an attempt to create an object. See DirObjectFactory.getObjectInstance().
        从以下版本开始：
        1.3
        另请参见：
        NamingManager.getURLContext(java.lang.String, java.util.Hashtable), DirObjectFactory, DirObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)

      • getStateToBind

        public static DirStateFactory.Result getStateToBind(Object obj,
                                    Name name,
                                    Context nameCtx,
                                    Hashtable<?,?> environment,
                                    Attributes attrs)
                                             throws NamingException
        Retrieves the state of an object for binding when given the original object and its attributes.

        This method is like NamingManager.getStateToBind except for the following differences:

        • It accepts an Attributes parameter containing attributes that were passed to the DirContext.bind() method.
        • It returns a non-null DirStateFactory.Result instance containing the object to be bound, and the attributes to accompany the binding. Either the object or the attributes may be null.
        • The state factories tried must each implement either StateFactory or DirStateFactory. If it implements DirStateFactory, then DirStateFactory.getStateToBind() is called; otherwise, StateFactory.getStateToBind() is called.
        Service providers that implement the DirContext interface should use this method, not NamingManager.getStateToBind().

        See NamingManager.getStateToBind() for a description of how the list of state factories to be tried is determined.

        The object returned by this method is owned by the caller. The implementation will not subsequently modify it. It will contain either a new Attributes object that is likewise owned by the caller, or a reference to the original attrs parameter.

        参数：
        obj - The non-null object for which to get state to bind.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the state factory and the object's state.
        attrs - The possibly null Attributes that is to be bound with the object.
        返回：
        A non-null DirStateFactory.Result containing the object and attributes to be bound. If no state factory returns a non-null answer, the result will contain the object (obj) itself with the original attributes.
        抛出：
        NamingException - If a naming exception was encountered while using the factories. A factory should only throw an exception if it does not want other factories to be used in an attempt to create an object. See DirStateFactory.getStateToBind().
        从以下版本开始：
        1.3
        另请参见：
        DirStateFactory, DirStateFactory.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Trut /ia-i/b nheinv/m g


DirObjectFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface DirObjectFactory

  • All Superinterfaces:
    ObjectFactory

    public interface DirObjectFactory
extends ObjectFactory
    This interface represents a factory for creating an object given an object and attributes about the object.

    The JNDI framework allows for object implementations to be loaded in dynamically via object factories. See ObjectFactory for details.

    A DirObjectFactory extends ObjectFactory by allowing an Attributes instance to be supplied to the getObjectInstance() method. DirObjectFactory implementations are intended to be used by DirContext service providers. The service provider, in addition reading an object from the directory, might already have attributes that are useful for the object factory to check to see whether the factory is supposed to process the object. For instance, an LDAP-style service provider might have read the "objectclass" of the object. A CORBA object factory might be interested only in LDAP entries with "objectclass=corbaObject". By using the attributes supplied by the LDAP service provider, the CORBA object factory can quickly eliminate objects that it need not worry about, and non-CORBA object factories can quickly eliminate CORBA-related LDAP entries.

    从以下版本开始：
    1.3
    另请参见：
    NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), ObjectFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Creates an object using the location or reference information, and attributes specified.

      • 方法 - 继承于接口 javax.naming.spi.ObjectFactory

        getObjectInstance

    • 方法详细信息

      • getObjectInstance

        Object getObjectInstance(Object obj,
                       Name name,
                       Context nameCtx,
                       Hashtable<?,?> environment,
                       Attributes attrs)
                         throws Exception
        Creates an object using the location or reference information, and attributes specified.

        Special requirements of this object are supplied using environment. An example of such an environment property is user identity information.

        DirectoryManager.getObjectInstance() successively loads in object factories. If it encounters a DirObjectFactory, it will invoke DirObjectFactory.getObjectInstance(); otherwise, it invokes ObjectFactory.getObjectInstance(). It does this until a factory produces a non-null answer.

        When an exception is thrown by an object factory, the exception is passed on to the caller of DirectoryManager.getObjectInstance(). The search for other factories that may produce a non-null answer is halted. An object factory should only throw an exception if it is sure that it is the only intended factory and that no other object factories should be tried. If this factory cannot create an object using the arguments supplied, it should return null.

        Since DirObjectFactory extends ObjectFactory, it effectively has two getObjectInstance() methods, where one differs from the other by the attributes argument. Given a factory that implements DirObjectFactory, DirectoryManager.getObjectInstance() will only use the method that accepts the attributes argument, while NamingManager.getObjectInstance() will only use the one that does not accept the attributes argument.

        See ObjectFactory for a description URL context factories and other properties of object factories that apply equally to DirObjectFactory.

        The name, attrs, and environment parameters are owned by the caller. The implementation will not modify these objects or keep references to them, although it may keep references to clones or copies.

        参数：
        obj - The possibly null object containing location or reference information that can be used in creating an object.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment that is used in creating the object.
        attrs - The possibly null attributes containing some of obj's attributes. attrs might not necessarily have all of obj's attributes. If the object factory requires more attributes, it needs to get it, either using obj, or name and nameCtx. The factory must not modify attrs.
        返回：
        The object created; null if an object cannot be created.
        抛出：
        Exception - If this object factory encountered an exception while attempting to create an object, and no other object factories are to be tried.
        另请参见：
        DirectoryManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), NamingManager.getURLContext(java.lang.String, java.util.Hashtable)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etc<>/s


DirStateFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface DirStateFactory

  • All Superinterfaces:
    StateFactory

    public interface DirStateFactory
extends StateFactory
    This interface represents a factory for obtaining the state of an object and corresponding attributes for binding.

    The JNDI framework allows for object implementations to be loaded in dynamically via object factories.

    A DirStateFactory extends StateFactory by allowing an Attributes instance to be supplied to and be returned by the getStateToBind() method. DirStateFactory implementations are intended to be used by DirContext service providers. When a caller binds an object using DirContext.bind(), he might also specify a set of attributes to be bound with the object. The object and attributes to be bound are passed to the getStateToBind() method of a factory. If the factory processes the object and attributes, it returns a corresponding pair of object and attributes to be bound. If the factory does not process the object, it must return null.

    For example, a caller might bind a printer object with some printer-related attributes.

     ctx.rebind("inky", printer, printerAttrs);
    An LDAP service provider for ctx uses a DirStateFactory (indirectly via DirectoryManager.getStateToBind()) and gives it printer and printerAttrs. A factory for an LDAP directory might turn printer into a set of attributes and merge that with printerAttrs. The service provider then uses the resulting attributes to create an LDAP entry and updates the directory.

    Since DirStateFactory extends StateFactory, it has two getStateToBind() methods, where one differs from the other by the attributes argument. DirectoryManager.getStateToBind() will only use the form that accepts the attributes argument, while NamingManager.getStateToBind() will only use the form that does not accept the attributes argument.

    Either form of the getStateToBind() method of a DirStateFactory may be invoked multiple times, possibly using different parameters. The implementation is thread-safe.

    从以下版本开始：
    1.3
    另请参见：
    DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), DirObjectFactory

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  DirStateFactory.Result
      An object/attributes pair for returning the result of DirStateFactory.getStateToBind().

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DirStateFactory.Result getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.

      • 方法 - 继承于接口 javax.naming.spi.StateFactory

        getStateToBind

    • 方法详细信息

      • getStateToBind

        DirStateFactory.Result getStateToBind(Object obj,
                                    Name name,
                                    Context nameCtx,
                                    Hashtable<?,?> environment,
                                    Attributes inAttrs)
                                      throws NamingException
        Retrieves the state of an object for binding given the object and attributes to be transformed.

        DirectoryManager.getStateToBind() successively loads in state factories. If a factory implements DirStateFactory, DirectoryManager invokes this method; otherwise, it invokes StateFactory.getStateToBind(). It does this until a factory produces a non-null answer.

        When an exception is thrown by a factory, the exception is passed on to the caller of DirectoryManager.getStateToBind(). The search for other factories that may produce a non-null answer is halted. A factory should only throw an exception if it is sure that it is the only intended factory and that no other factories should be tried. If this factory cannot create an object using the arguments supplied, it should return null.

        The name and nameCtx parameters may optionally be used to specify the name of the object being created. See the description of "Name and Context Parameters" in ObjectFactory.getObjectInstance() for details. If a factory uses nameCtx it should synchronize its use against concurrent access, since context implementations are not guaranteed to be thread-safe.

        The name, inAttrs, and environment parameters are owned by the caller. The implementation will not modify these objects or keep references to them, although it may keep references to clones or copies. The object returned by this method is owned by the caller. The implementation will not subsequently modify it. It will contain either a new Attributes object that is likewise owned by the caller, or a reference to the original inAttrs parameter.

        参数：
        obj - A possibly null object whose state is to be retrieved.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the object's state.
        inAttrs - The possibly null attributes to be bound with the object. The factory must not modify inAttrs.
        返回：
        A Result containing the object's state for binding and the corresponding attributes to be bound; null if the object don't use this factory.
        抛出：
        NamingException - If this factory encountered an exception while attempting to get the object's state, and no other factories are to be tried.
        另请参见：
        DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etcttrFortcFceccrg /neiReaxgaggaj


DirStateFactory.Result

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.spi

类 DirStateFactory.Result

  • java.lang.Object
    • javax.naming.spi.DirStateFactory.Result
  • Enclosing interface:
    DirStateFactory

    public static class DirStateFactory.Result
extends Object
    An object/attributes pair for returning the result of DirStateFactory.getStateToBind().

    • 构造方法摘要

      Constructors
      构造方法与描述
      DirStateFactory.Result(Object obj, Attributes outAttrs)
      Constructs an instance of Result.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Attributes getAttributes()
      Retrieves the attributes to be bound.
      Object getObject()
      Retrieves the object to be bound.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DirStateFactory.Result

        public DirStateFactory.Result(Object obj,
                      Attributes outAttrs)
        Constructs an instance of Result.
        参数：
        obj - The possibly null object to be bound.
        outAttrs - The possibly null attributes to be bound.

    • 方法详细信息

      • getObject

        public Object getObject()
        Retrieves the object to be bound.
        返回：
        The possibly null object to be bound.

      • getAttributes

        public Attributes getAttributes()
        Retrieves the attributes to be bound.
        返回：
        The possibly null attributes to be bound.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tht>m>tttTeeec cnanrcnnncaaashel


InitialContextFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface InitialContextFactory

  • public interface InitialContextFactory
    This interface represents a factory that creates an initial context.

    The JNDI framework allows for different initial context implementations to be specified at runtime. The initial context is created using an initial context factory. An initial context factory must implement the InitialContextFactory interface, which provides a method for creating instances of initial context that implement the Context interface. In addition, the factory class must be public and must have a public constructor that accepts no arguments.

    从以下版本开始：
    1.3
    另请参见：
    InitialContextFactoryBuilder, NamingManager.getInitialContext(java.util.Hashtable), InitialContext, InitialDirContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Context getInitialContext(Hashtable<?,?> environment)
      Creates an Initial Context for beginning name resolution.

    • 方法详细信息

      • getInitialContext

        Context getInitialContext(Hashtable<?,?> environment)
                          throws NamingException
        Creates an Initial Context for beginning name resolution. Special requirements of this context are supplied using environment.

        The environment parameter is owned by the caller. The implementation will not modify the object or keep a reference to it, although it may keep a reference to a clone or copy.

        参数：
        environment - The possibly null environment specifying information to be used in the creation of the initial context.
        返回：
        A non-null initial context object that implements the Context interface.
        抛出：
        NamingException - If cannot create an initial context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gl//j/./n/xaan//j.ii8b�-aa/di/ >scn


InitialContextFactoryBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface InitialContextFactoryBuilder

  • public interface InitialContextFactoryBuilder
    This interface represents a builder that creates initial context factories.

    The JNDI framework allows for different initial context implementations to be specified at runtime. An initial context is created using an initial context factory. A program can install its own builder that creates initial context factories, thereby overriding the default policies used by the framework, by calling NamingManager.setInitialContextFactoryBuilder(). The InitialContextFactoryBuilder interface must be implemented by such a builder.

    从以下版本开始：
    1.3
    另请参见：
    InitialContextFactory, NamingManager.getInitialContext(java.util.Hashtable), NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder), NamingManager.hasInitialContextFactoryBuilder(), InitialContext, InitialDirContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InitialContextFactory createInitialContextFactory(Hashtable<?,?> environment)
      Creates an initial context factory using the specified environment.

    • 方法详细信息

      • createInitialContextFactory

        InitialContextFactory createInitialContextFactory(Hashtable<?,?> environment)
                                                  throws NamingException
        Creates an initial context factory using the specified environment.

        The environment parameter is owned by the caller. The implementation will not modify the object or keep a reference to it, although it may keep a reference to a clone or copy.

        参数：
        environment - Environment used in creating an initial context implementation. Can be null.
        返回：
        A non-null initial context factory.
        抛出：
        NamingException - If an initial context factory could not be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Noo_g_ab/_"n">N渭ass.o.tc eo躷靠a"�


javax.naming.spi

Interfaces

  • DirObjectFactory
  • DirStateFactory
  • InitialContextFactory
  • InitialContextFactoryBuilder
  • ObjectFactory
  • ObjectFactoryBuilder
  • Resolver
  • StateFactory

Classes

  • DirectoryManager
  • DirStateFactory.Result
  • NamingManager
  • ResolveResult
�


javax.naming.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.naming.spi

  • 接口摘要
    接口 描述
    DirObjectFactory
    This interface represents a factory for creating an object given an object and attributes about the object.
    DirStateFactory
    This interface represents a factory for obtaining the state of an object and corresponding attributes for binding.
    InitialContextFactory
    This interface represents a factory that creates an initial context.
    InitialContextFactoryBuilder
    This interface represents a builder that creates initial context factories.
    ObjectFactory
    This interface represents a factory for creating an object.
    ObjectFactoryBuilder
    This interface represents a builder that creates object factories.
    Resolver
    This interface represents an "intermediate context" for name resolution.
    StateFactory
    This interface represents a factory for obtaining the state of an object for binding.
  • Class Summary
    类 描述
    DirectoryManager
    This class contains methods for supporting DirContext implementations.
    DirStateFactory.Result
    An object/attributes pair for returning the result of DirStateFactory.getStateToBind().
    NamingManager
    This class contains methods for creating context objects and objects referred to by location information in the naming or directory service.
    ResolveResult
    This class represents the result of resolution of a name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lsviplhloellr/xx嘁s>


javax.naming.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.naming.spi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.naming.spi.DirStateFactory.Result
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager
    • javax.naming.spi.ResolveResult (implements java.io.Serializable)

Interface Hierarchy

  • javax.naming.spi.InitialContextFactory
  • javax.naming.spi.InitialContextFactoryBuilder
  • javax.naming.spi.ObjectFactory
    • javax.naming.spi.DirObjectFactory
  • javax.naming.spi.ObjectFactoryBuilder
  • javax.naming.spi.Resolver
  • javax.naming.spi.StateFactory
    • javax.naming.spi.DirStateFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"ee.//....=>//r>佑<


NamingManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

类 NamingManager

  • java.lang.Object
    • javax.naming.spi.NamingManager
  • 直接已知子类：
    DirectoryManager

    public class NamingManager
extends Object
    This class contains methods for creating context objects and objects referred to by location information in the naming or directory service.

    This class cannot be instantiated. It has only static methods.

    The mention of URL in the documentation for this class refers to a URL string as defined by RFC 1738 and its related RFCs. It is any string that conforms to the syntax described therein, and may not always have corresponding support in the java.net.URL class or Web browsers.

    NamingManager is safe for concurrent access by multiple threads.

    Except as otherwise noted, a Name or environment parameter passed to any method is owned by the caller. The implementation will not modify the object or keep a reference to it, although it may keep a reference to a clone or copy.

    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CPE
      Constant that holds the name of the environment property into which getContinuationContext() stores the value of its CannotProceedException parameter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Context getContinuationContext(CannotProceedException cpe)
      Creates a context in which to continue a context operation.
      static Context getInitialContext(Hashtable<?,?> env)
      Creates an initial context using the specified environment properties.
      static Object getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an instance of an object for the specified object and environment.
      static Object getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.
      static Context getURLContext(String scheme, Hashtable<?,?> environment)
      Creates a context for the given URL scheme id.
      static boolean hasInitialContextFactoryBuilder()
      Determines whether an initial context factory builder has been set.
      static void setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
      Sets the InitialContextFactory builder to be builder.
      static void setObjectFactoryBuilder(ObjectFactoryBuilder builder)
      The ObjectFactoryBuilder determines the policy used when trying to load object factories.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CPE

        public static final String CPE
        Constant that holds the name of the environment property into which getContinuationContext() stores the value of its CannotProceedException parameter. This property is inherited by the continuation context, and may be used by that context's service provider to inspect the fields of the exception.

        The value of this constant is "java.naming.spi.CannotProceedException".

        从以下版本开始：
        1.3
        另请参见：
        getContinuationContext(javax.naming.CannotProceedException), Constant Field Values

    • 方法详细信息

      • setObjectFactoryBuilder

        public static void setObjectFactoryBuilder(ObjectFactoryBuilder builder)
                                    throws NamingException
        The ObjectFactoryBuilder determines the policy used when trying to load object factories. See getObjectInstance() and class ObjectFactory for a description of the default policy. setObjectFactoryBuilder() overrides this default policy by installing an ObjectFactoryBuilder. Subsequent object factories will be loaded and created using the installed builder.

        The builder can only be installed if the executing thread is allowed (by the security manager's checkSetFactory() method) to do so. Once installed, the builder cannot be replaced.

        参数：
        builder - The factory builder to install. If null, no builder is installed.
        抛出：
        SecurityException - builder cannot be installed for security reasons.
        NamingException - builder cannot be installed for a non-security-related reason.
        IllegalStateException - If a factory has already been installed.
        另请参见：
        getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory, ObjectFactoryBuilder, SecurityManager.checkSetFactory()

      • getObjectInstance

        public static Object getObjectInstance(Object refInfo,
                       Name name,
                       Context nameCtx,
                       Hashtable<?,?> environment)
                                throws Exception
        Creates an instance of an object for the specified object and environment.

        If an object factory builder has been installed, it is used to create a factory for creating the object. Otherwise, the following rules are used to create the object:

        1. If refInfo is a Reference or Referenceable containing a factory class name, use the named factory to create the object. Return refInfo if the factory cannot be created. Under JDK 1.1, if the factory class must be loaded from a location specified in the reference, a SecurityManager must have been installed or the factory creation will fail. If an exception is encountered while creating the factory, it is passed up to the caller.
        2. If refInfo is a Reference or Referenceable with no factory class name, and the address or addresses are StringRefAddrs with address type "URL", try the URL context factory corresponding to each URL's scheme id to create the object (see getURLContext()). If that fails, continue to the next step.
        3. Use the object factories specified in the Context.OBJECT_FACTORIES property of the environment, and of the provider resource file associated with nameCtx, in that order. The value of this property is a colon-separated list of factory class names that are tried in order, and the first one that succeeds in creating an object is the one used. If none of the factories can be loaded, return refInfo. If an exception is encountered while creating the object, the exception is passed up to the caller.

        Service providers that implement the DirContext interface should use DirectoryManager.getObjectInstance(), not this method. Service providers that implement only the Context interface should use this method.

        Note that an object factory (an object that implements the ObjectFactory interface) must be public and must have a public constructor that accepts no arguments.

        The name and nameCtx parameters may optionally be used to specify the name of the object being created. name is the name of the object, relative to context nameCtx. This information could be useful to the object factory or to the object implementation. If there are several possible contexts from which the object could be named -- as will often be the case -- it is up to the caller to select one. A good rule of thumb is to select the "deepest" context available. If nameCtx is null, name is relative to the default initial context. If no name is being specified, the name parameter should be null.

        参数：
        refInfo - The possibly null object for which to create an object.
        name - The name of this object relative to nameCtx. Specifying a name is optional; if it is omitted, name should be null.
        nameCtx - The context relative to which the name parameter is specified. If null, name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the object factory and the object.
        返回：
        An object created using refInfo; or refInfo if an object cannot be created using the algorithm described above.
        抛出：
        NamingException - if a naming exception was encountered while attempting to get a URL context, or if one of the factories accessed throws a NamingException.
        Exception - if one of the factories accessed throws an exception, or if an error was encountered while loading and instantiating the factory and object classes. A factory should only throw an exception if it does not want other factories to be used in an attempt to create an object. See ObjectFactory.getObjectInstance().
        另请参见：
        getURLContext(java.lang.String, java.util.Hashtable), ObjectFactory, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • getURLContext

        public static Context getURLContext(String scheme,
                    Hashtable<?,?> environment)
                             throws NamingException
        Creates a context for the given URL scheme id.

        The resulting context is for resolving URLs of the scheme scheme. The resulting context is not tied to a specific URL. It is able to handle arbitrary URLs with the specified scheme.

        The class name of the factory that creates the resulting context has the naming convention scheme-idURLContextFactory (e.g. "ftpURLContextFactory" for the "ftp" scheme-id), in the package specified as follows. The Context.URL_PKG_PREFIXES environment property (which may contain values taken from applet parameters, system properties, or application resource files) contains a colon-separated list of package prefixes. Each package prefix in the property is tried in the order specified to load the factory class. The default package prefix is "com.sun.jndi.url" (if none of the specified packages work, this default is tried). The complete package name is constructed using the package prefix, concatenated with the scheme id.

        For example, if the scheme id is "ldap", and the Context.URL_PKG_PREFIXES property contains "com.widget:com.wiz.jndi", the naming manager would attempt to load the following classes until one is successfully instantiated:

        • com.widget.ldap.ldapURLContextFactory
        • com.wiz.jndi.ldap.ldapURLContextFactory
        • com.sun.jndi.url.ldap.ldapURLContextFactory
        If none of the package prefixes work, null is returned.

        If a factory is instantiated, it is invoked with the following parameters to produce the resulting context.

        factory.getObjectInstance(null, environment);

        For example, invoking getObjectInstance() as shown above on a LDAP URL context factory would return a context that can resolve LDAP urls (e.g. "ldap://ldap.wiz.com/o=wiz,c=us", "ldap://ldap.umich.edu/o=umich,c=us", ...).

        Note that an object factory (an object that implements the ObjectFactory interface) must be public and must have a public constructor that accepts no arguments.

        参数：
        scheme - The non-null scheme-id of the URLs supported by the context.
        environment - The possibly null environment properties to be used in the creation of the object factory and the context.
        返回：
        A context for resolving URLs with the scheme id scheme; null if the factory for creating the context is not found.
        抛出：
        NamingException - If a naming exception occurs while creating the context.
        另请参见：
        getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

      • getInitialContext

        public static Context getInitialContext(Hashtable<?,?> env)
                                 throws NamingException
        Creates an initial context using the specified environment properties.

        If an InitialContextFactoryBuilder has been installed, it is used to create the factory for creating the initial context. Otherwise, the class specified in the Context.INITIAL_CONTEXT_FACTORY environment property is used. Note that an initial context factory (an object that implements the InitialContextFactory interface) must be public and must have a public constructor that accepts no arguments.

        参数：
        env - The possibly null environment properties used when creating the context.
        返回：
        A non-null initial context.
        抛出：
        NoInitialContextException - If the Context.INITIAL_CONTEXT_FACTORY property is not found or names a nonexistent class or a class that cannot be instantiated, or if the initial context could not be created for some other reason.
        NamingException - If some other naming exception was encountered.
        另请参见：
        InitialContext, InitialDirContext

      • setInitialContextFactoryBuilder

        public static void setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
                                            throws NamingException
        Sets the InitialContextFactory builder to be builder.

        The builder can only be installed if the executing thread is allowed by the security manager to do so. Once installed, the builder cannot be replaced.

        参数：
        builder - The initial context factory builder to install. If null, no builder is set.
        抛出：
        SecurityException - builder cannot be installed for security reasons.
        NamingException - builder cannot be installed for a non-security-related reason.
        IllegalStateException - If a builder was previous installed.
        另请参见：
        hasInitialContextFactoryBuilder(), SecurityManager.checkSetFactory()

      • hasInitialContextFactoryBuilder

        public static boolean hasInitialContextFactoryBuilder()
        Determines whether an initial context factory builder has been set.
        返回：
        true if an initial context factory builder has been set; false otherwise.
        另请参见：
        setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder)

      • getContinuationContext

        public static Context getContinuationContext(CannotProceedException cpe)
                                      throws NamingException
        Creates a context in which to continue a context operation.

        In performing an operation on a name that spans multiple namespaces, a context from one naming system may need to pass the operation on to the next naming system. The context implementation does this by first constructing a CannotProceedException containing information pinpointing how far it has proceeded. It then obtains a continuation context from JNDI by calling getContinuationContext. The context implementation should then resume the context operation by invoking the same operation on the continuation context, using the remainder of the name that has not yet been resolved.

        Before making use of the cpe parameter, this method updates the environment associated with that object by setting the value of the property CPE to cpe. This property will be inherited by the continuation context, and may be used by that context's service provider to inspect the fields of this exception.

        参数：
        cpe - The non-null exception that triggered this continuation.
        返回：
        A non-null Context object for continuing the operation.
        抛出：
        NamingException - If a naming exception occurred.

      • getStateToBind

        public static Object getStateToBind(Object obj,
                    Name name,
                    Context nameCtx,
                    Hashtable<?,?> environment)
                             throws NamingException
        Retrieves the state of an object for binding.

        Service providers that implement the DirContext interface should use DirectoryManager.getStateToBind(), not this method. Service providers that implement only the Context interface should use this method.

        This method uses the specified state factories in the Context.STATE_FACTORIES property from the environment properties, and from the provider resource file associated with nameCtx, in that order. The value of this property is a colon-separated list of factory class names that are tried in order, and the first one that succeeds in returning the object's state is the one used. If no object's state can be retrieved in this way, return the object itself. If an exception is encountered while retrieving the state, the exception is passed up to the caller.

        Note that a state factory (an object that implements the StateFactory interface) must be public and must have a public constructor that accepts no arguments.

        The name and nameCtx parameters may optionally be used to specify the name of the object being created. See the description of "Name and Context Parameters" in ObjectFactory.getObjectInstance() for details.

        This method may return a Referenceable object. The service provider obtaining this object may choose to store it directly, or to extract its reference (using Referenceable.getReference()) and store that instead.

        参数：
        obj - The non-null object for which to get state to bind.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the state factory and the object's state.
        返回：
        The non-null object representing obj's state for binding. It could be the object (obj) itself.
        抛出：
        NamingException - If one of the factories accessed throws an exception, or if an error was encountered while loading and instantiating the factory and object classes. A factory should only throw an exception if it does not want other factories to be used in an attempt to create an object. See StateFactory.getStateToBind().
        从以下版本开始：
        1.3
        另请参见：
        StateFactory, StateFactory.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


ObjectFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface ObjectFactory

  • All Known Subinterfaces:
    DirObjectFactory

    public interface ObjectFactory
    This interface represents a factory for creating an object.

    The JNDI framework allows for object implementations to be loaded in dynamically via object factories. For example, when looking up a printer bound in the name space, if the print service binds printer names to References, the printer Reference could be used to create a printer object, so that the caller of lookup can directly operate on the printer object after the lookup.

    An ObjectFactory is responsible for creating objects of a specific type. In the above example, you may have a PrinterObjectFactory for creating Printer objects.

    An object factory must implement the ObjectFactory interface. In addition, the factory class must be public and must have a public constructor that accepts no parameters.

    The getObjectInstance() method of an object factory may be invoked multiple times, possibly using different parameters. The implementation is thread-safe.

    The mention of URL in the documentation for this class refers to a URL string as defined by RFC 1738 and its related RFCs. It is any string that conforms to the syntax described therein, and may not always have corresponding support in the java.net.URL class or Web browsers.

    从以下版本开始：
    1.3
    另请参见：
    NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable), ObjectFactoryBuilder, StateFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Creates an object using the location or reference information specified.

    • 方法详细信息

      • getObjectInstance

        Object getObjectInstance(Object obj,
                       Name name,
                       Context nameCtx,
                       Hashtable<?,?> environment)
                         throws Exception
        Creates an object using the location or reference information specified.

        Special requirements of this object are supplied using environment. An example of such an environment property is user identity information.

        NamingManager.getObjectInstance() successively loads in object factories and invokes this method on them until one produces a non-null answer. When an exception is thrown by an object factory, the exception is passed on to the caller of NamingManager.getObjectInstance() (and no search is made for other factories that may produce a non-null answer). An object factory should only throw an exception if it is sure that it is the only intended factory and that no other object factories should be tried. If this factory cannot create an object using the arguments supplied, it should return null.

        A URL context factory is a special ObjectFactory that creates contexts for resolving URLs or objects whose locations are specified by URLs. The getObjectInstance() method of a URL context factory will obey the following rules.

        1. If obj is null, create a context for resolving URLs of the scheme associated with this factory. The resulting context is not tied to a specific URL: it is able to handle arbitrary URLs with this factory's scheme id. For example, invoking getObjectInstance() with obj set to null on an LDAP URL context factory would return a context that can resolve LDAP URLs such as "ldap://ldap.wiz.com/o=wiz,c=us" and "ldap://ldap.umich.edu/o=umich,c=us".
        2. If obj is a URL string, create an object (typically a context) identified by the URL. For example, suppose this is an LDAP URL context factory. If obj is "ldap://ldap.wiz.com/o=wiz,c=us", getObjectInstance() would return the context named by the distinguished name "o=wiz, c=us" at the LDAP server ldap.wiz.com. This context can then be used to resolve LDAP names (such as "cn=George") relative to that context.
        3. If obj is an array of URL strings, the assumption is that the URLs are equivalent in terms of the context to which they refer. Verification of whether the URLs are, or need to be, equivalent is up to the context factory. The order of the URLs in the array is not significant. The object returned by getObjectInstance() is like that of the single URL case. It is the object named by the URLs.
        4. If obj is of any other type, the behavior of getObjectInstance() is determined by the context factory implementation.

        The name and environment parameters are owned by the caller. The implementation will not modify these objects or keep references to them, although it may keep references to clones or copies.

        Name and Context Parameters. The name and nameCtx parameters may optionally be used to specify the name of the object being created. name is the name of the object, relative to context nameCtx. If there are several possible contexts from which the object could be named -- as will often be the case -- it is up to the caller to select one. A good rule of thumb is to select the "deepest" context available. If nameCtx is null, name is relative to the default initial context. If no name is being specified, the name parameter should be null. If a factory uses nameCtx it should synchronize its use against concurrent access, since context implementations are not guaranteed to be thread-safe.

        参数：
        obj - The possibly null object containing location or reference information that can be used in creating an object.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment that is used in creating the object.
        返回：
        The object created; null if an object cannot be created.
        抛出：
        Exception - if this object factory encountered an exception while attempting to create an object, and no other object factories are to be tried.
        另请参见：
        NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ekrcjceeced>>edd"m e" er./citoFvpBg


ObjectFactoryBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface ObjectFactoryBuilder

  • public interface ObjectFactoryBuilder
    This interface represents a builder that creates object factories.

    The JNDI framework allows for object implementations to be loaded in dynamically via object factories. For example, when looking up a printer bound in the name space, if the print service binds printer names to References, the printer Reference could be used to create a printer object, so that the caller of lookup can directly operate on the printer object after the lookup. An ObjectFactory is responsible for creating objects of a specific type. JNDI uses a default policy for using and loading object factories. You can override this default policy by calling NamingManager.setObjectFactoryBuilder() with an ObjectFactoryBuilder, which contains the program-defined way of creating/loading object factories. Any ObjectFactoryBuilder implementation must implement this interface that for creating object factories.

    从以下版本开始：
    1.3
    另请参见：
    ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.setObjectFactoryBuilder(javax.naming.spi.ObjectFactoryBuilder)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ObjectFactory createObjectFactory(Object obj, Hashtable<?,?> environment)
      Creates a new object factory using the environment supplied.

    • 方法详细信息

      • createObjectFactory

        ObjectFactory createObjectFactory(Object obj,
                                Hashtable<?,?> environment)
                                  throws NamingException
        Creates a new object factory using the environment supplied.

        The environment parameter is owned by the caller. The implementation will not modify the object or keep a reference to it, although it may keep a reference to a clone or copy.

        参数：
        obj - The possibly null object for which to create a factory.
        environment - Environment to use when creating the factory. Can be null.
        返回：
        A non-null new instance of an ObjectFactory.
        抛出：
        NamingException - If an object factory cannot be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e o ownow iiw amllhe hTp t


Resolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface Resolver

  • public interface Resolver
    This interface represents an "intermediate context" for name resolution.

    The Resolver interface contains methods that are implemented by contexts that do not support subtypes of Context, but which can act as intermediate contexts for resolution purposes.

    A Name parameter passed to any method is owned by the caller. The service provider will not modify the object or keep a reference to it. A ResolveResult object returned by any method is owned by the caller. The caller may subsequently modify it; the service provider may not.

    从以下版本开始：
    1.3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ResolveResult resolveToClass(Name name, 类<? extends Context> contextType)
      Partially resolves a name.
      ResolveResult resolveToClass(String name, 类<? extends Context> contextType)
      Partially resolves a name.

    • 方法详细信息

      • resolveToClass

        ResolveResult resolveToClass(Name name,
                           类<? extends Context> contextType)
                             throws NamingException
        Partially resolves a name. Stops at the first context that is an instance of a given subtype of Context.
        参数：
        name - the name to resolve
        contextType - the type of object to resolve. This should be a subtype of Context.
        返回：
        the object that was found, along with the unresolved suffix of name. Cannot be null.
        抛出：
        NotContextException - if no context of the appropriate type is found
        NamingException - if a naming exception was encountered
        另请参见：
        resolveToClass(String, Class)

      • resolveToClass

        ResolveResult resolveToClass(String name,
                           类<? extends Context> contextType)
                             throws NamingException
        Partially resolves a name. See resolveToClass(Name, Class) for details.
        参数：
        name - the name to resolve
        contextType - the type of object to resolve. This should be a subtype of Context.
        返回：
        the object that was found, along with the unresolved suffix of name. Cannot be null.
        抛出：
        NotContextException - if no context of the appropriate type is found
        NamingException - if a naming exception was encountered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ttn>isa/=runruu"A>>l lyevn rnyt


ResolveResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.naming.spi

类 ResolveResult

  • java.lang.Object
    • javax.naming.spi.ResolveResult
  • 所有已实现的接口：
    Serializable

    public class ResolveResult
extends Object
implements Serializable
    This class represents the result of resolution of a name. It contains the object to which name was resolved, and the portion of the name that has not been resolved.

    A ResolveResult instance is not synchronized against concurrent multithreaded access. Multiple threads trying to access and modify a single ResolveResult instance should lock the object.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Name remainingName
      Field containing the remaining name yet to be resolved.
      protected Object resolvedObj
      Field containing the Object that was resolved to successfully.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ResolveResult()
      Constructs an instance of ResolveResult with the resolved object and remaining name both initialized to null.
        ResolveResult(Object robj, Name rname)
      Constructs a new instance of ResolveResult consisting of the resolved Object and the remaining name.
        ResolveResult(Object robj, String rcomp)
      Constructs a new instance of ResolveResult consisting of the resolved object and the remaining unresolved component.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void appendRemainingComponent(String name)
      Adds a single component to the end of remaining name.
      void appendRemainingName(Name name)
      Adds components to the end of remaining name.
      Name getRemainingName()
      Retrieves the remaining unresolved portion of the name.
      Object getResolvedObj()
      Retrieves the Object to which resolution was successful.
      void setRemainingName(Name name)
      Sets the remaining name field of this result to name.
      void setResolvedObj(Object obj)
      Sets the resolved Object field of this result to obj.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • resolvedObj

        protected Object resolvedObj
        Field containing the Object that was resolved to successfully. It can be null only when constructed using a subclass. Constructors should always initialize this.

      • remainingName

        protected Name remainingName
        Field containing the remaining name yet to be resolved. It can be null only when constructed using a subclass. Constructors should always initialize this.

    • 构造方法详细信息

      • ResolveResult

        protected ResolveResult()
        Constructs an instance of ResolveResult with the resolved object and remaining name both initialized to null.

      • ResolveResult

        public ResolveResult(Object robj,
             String rcomp)
        Constructs a new instance of ResolveResult consisting of the resolved object and the remaining unresolved component.
        参数：
        robj - The non-null object resolved to.
        rcomp - The single remaining name component that has yet to be resolved. Cannot be null (but can be empty).

      • ResolveResult

        public ResolveResult(Object robj,
             Name rname)
        Constructs a new instance of ResolveResult consisting of the resolved Object and the remaining name.
        参数：
        robj - The non-null Object resolved to.
        rname - The non-null remaining name that has yet to be resolved.

    • 方法详细信息

      • getRemainingName

        public Name getRemainingName()
        Retrieves the remaining unresolved portion of the name.
        返回：
        The remaining unresolved portion of the name. Cannot be null but empty OK.
        另请参见：
        appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String),
setRemainingName(javax.naming.Name)

      • getResolvedObj

        public Object getResolvedObj()
        Retrieves the Object to which resolution was successful.
        返回：
        The Object to which resolution was successful. Cannot be null.
        另请参见：
        setResolvedObj(java.lang.Object)

      • setRemainingName

        public void setRemainingName(Name name)
        Sets the remaining name field of this result to name. A copy of name is made so that modifying the copy within this ResolveResult does not affect name and vice versa.
        参数：
        name - The name to set remaining name to. Cannot be null.
        另请参见：
        getRemainingName(),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

      • appendRemainingName

        public void appendRemainingName(Name name)
        Adds components to the end of remaining name.
        参数：
        name - The components to add. Can be null.
        另请参见：
        getRemainingName(),
setRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

      • appendRemainingComponent

        public void appendRemainingComponent(String name)
        Adds a single component to the end of remaining name.
        参数：
        name - The component to add. Can be null.
        另请参见：
        getRemainingName(), appendRemainingName(javax.naming.Name)

      • setResolvedObj

        public void setResolvedObj(Object obj)
        Sets the resolved Object field of this result to obj.
        参数：
        obj - The object to use for setting the resolved obj field. Cannot be null.
        另请参见：
        getResolvedObj()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a r>r>/>d>rS>btrosvvommlmerie ./<"m


StateFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.naming.spi

Interface StateFactory

  • All Known Subinterfaces:
    DirStateFactory

    public interface StateFactory
    This interface represents a factory for obtaining the state of an object for binding.

    The JNDI framework allows for object implementations to be loaded in dynamically via object factories. For example, when looking up a printer bound in the name space, if the print service binds printer names to References, the printer Reference could be used to create a printer object, so that the caller of lookup can directly operate on the printer object after the lookup.

    An ObjectFactory is responsible for creating objects of a specific type. In the above example, you may have a PrinterObjectFactory for creating Printer objects.

    For the reverse process, when an object is bound into the namespace, JNDI provides state factories. Continuing with the printer example, suppose the printer object is updated and rebound:

     ctx.rebind("inky", printer);
    The service provider for ctx uses a state factory to obtain the state of printer for binding into its namespace. A state factory for the Printer type object might return a more compact object for storage in the naming system.

    A state factory must implement the StateFactory interface. In addition, the factory class must be public and must have a public constructor that accepts no parameters.

    The getStateToBind() method of a state factory may be invoked multiple times, possibly using different parameters. The implementation is thread-safe.

    StateFactory is intended for use with service providers that implement only the Context interface. DirStateFactory is intended for use with service providers that implement the DirContext interface.

    从以下版本开始：
    1.3
    另请参见：
    NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), ObjectFactory, DirStateFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
      Retrieves the state of an object for binding.

    • 方法详细信息

      • getStateToBind

        Object getStateToBind(Object obj,
                    Name name,
                    Context nameCtx,
                    Hashtable<?,?> environment)
                      throws NamingException
        Retrieves the state of an object for binding.

        NamingManager.getStateToBind() successively loads in state factories and invokes this method on them until one produces a non-null answer. DirectoryManager.getStateToBind() successively loads in state factories. If a factory implements DirStateFactory, then DirectoryManager invokes DirStateFactory.getStateToBind(); otherwise it invokes StateFactory.getStateToBind().

        When an exception is thrown by a factory, the exception is passed on to the caller of NamingManager.getStateToBind() and DirectoryManager.getStateToBind(). The search for other factories that may produce a non-null answer is halted. A factory should only throw an exception if it is sure that it is the only intended factory and that no other factories should be tried. If this factory cannot create an object using the arguments supplied, it should return null.

        The name and nameCtx parameters may optionally be used to specify the name of the object being created. See the description of "Name and Context Parameters" in ObjectFactory.getObjectInstance() for details. If a factory uses nameCtx it should synchronize its use against concurrent access, since context implementations are not guaranteed to be thread-safe.

        The name and environment parameters are owned by the caller. The implementation will not modify these objects or keep references to them, although it may keep references to clones or copies.

        参数：
        obj - A non-null object whose state is to be retrieved.
        name - The name of this object relative to nameCtx, or null if no name is specified.
        nameCtx - The context relative to which the name parameter is specified, or null if name is relative to the default initial context.
        environment - The possibly null environment to be used in the creation of the object's state.
        返回：
        The object's state for binding; null if the factory is not returning any changes.
        抛出：
        NamingException - if this factory encountered an exception while attempting to get the object's state, and no other factories are to be tried.
        另请参见：
        NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osbddidvgv j


Uses of Package javax.naming.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.naming.spi

  • Packages that use javax.naming.spi
    软件包 描述
    javax.naming.spi
  • Classes in javax.naming.spi used by javax.naming.spi
    类与描述
    DirStateFactory.Result
    An object/attributes pair for returning the result of DirStateFactory.getStateToBind().
    InitialContextFactory
    This interface represents a factory that creates an initial context.
    InitialContextFactoryBuilder
    This interface represents a builder that creates initial context factories.
    NamingManager
    This class contains methods for creating context objects and objects referred to by location information in the naming or directory service.
    ObjectFactory
    This interface represents a factory for creating an object.
    ObjectFactoryBuilder
    This interface represents a builder that creates object factories.
    ResolveResult
    This class represents the result of resolution of a name.
    StateFactory
    This interface represents a factory for obtaining the state of an object for binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>vnvvstsa===cvccan/t


Uses of Class javax.naming.spi.DirectoryManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.spi.DirectoryManager

No usage of javax.naming.spi.DirectoryManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>- /


Uses of Class javax.naming.spi.DirStateFactory.Result

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.spi.DirStateFactory.Result

  • Packages that use DirStateFactory.Result
    软件包 描述
    javax.naming.spi

    • Uses of DirStateFactory.Result in javax.naming.spi

      Methods in javax.naming.spi that return DirStateFactory.Result
      修饰符与类型 方法与描述
      static DirStateFactory.Result DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
      Retrieves the state of an object for binding when given the original object and its attributes.
      DirStateFactory.Result DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
      Retrieves the state of an object for binding given the object and attributes to be transformed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>t. ll&o.


Uses of Class javax.naming.spi.NamingManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.spi.NamingManager

  • Packages that use NamingManager
    软件包 描述
    javax.naming.spi

    • Uses of NamingManager in javax.naming.spi

      Subclasses of NamingManager in javax.naming.spi
      修饰符与类型 类与描述
      class  DirectoryManager
      This class contains methods for supporting DirContext implementations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ig h r ruhrPe腷b1ta=/" -�


Uses of Class javax.naming.spi.ResolveResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.naming.spi.ResolveResult

  • Packages that use ResolveResult
    软件包 描述
    javax.naming.spi

    • Uses of ResolveResult in javax.naming.spi

      Methods in javax.naming.spi that return ResolveResult
      修饰符与类型 方法与描述
      ResolveResult Resolver.resolveToClass(Name name, 类<? extends Context> contextType)
      Partially resolves a name.
      ResolveResult Resolver.resolveToClass(String name, 类<? extends Context> contextType)
      Partially resolves a name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>sp.ihenacdan u.==a./>


Uses of Interface javax.naming.spi.DirObjectFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.DirObjectFactory

No usage of javax.naming.spi.DirObjectFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lb<<纒tlton


Uses of Interface javax.naming.spi.DirStateFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.DirStateFactory

No usage of javax.naming.spi.DirStateFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>t><>ll


Uses of Interface javax.naming.spi.InitialContextFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.InitialContextFactory

  • Packages that use InitialContextFactory
    软件包 描述
    javax.naming.spi

    • Uses of InitialContextFactory in javax.naming.spi

      Methods in javax.naming.spi that return InitialContextFactory
      修饰符与类型 方法与描述
      InitialContextFactory InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment)
      Creates an initial context factory using the specified environment.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

die.../"=...r<适l=l<


Uses of Interface javax.naming.spi.InitialContextFactoryBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.InitialContextFactoryBuilder

  • Packages that use InitialContextFactoryBuilder
    软件包 描述
    javax.naming.spi

    • Uses of InitialContextFactoryBuilder in javax.naming.spi

      Methods in javax.naming.spi with parameters of type InitialContextFactoryBuilder
      修饰符与类型 方法与描述
      static void NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
      Sets the InitialContextFactory builder to be builder.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e" Tra&羒箃>/lma<


Uses of Interface javax.naming.spi.ObjectFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.ObjectFactory

  • Packages that use ObjectFactory
    软件包 描述
    javax.naming.spi

    • Uses of ObjectFactory in javax.naming.spi

      Subinterfaces of ObjectFactory in javax.naming.spi
      修饰符与类型 Interface and Description
      interface  DirObjectFactory
      This interface represents a factory for creating an object given an object and attributes about the object.
      Methods in javax.naming.spi that return ObjectFactory
      修饰符与类型 方法与描述
      ObjectFactory ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
      Creates a new object factory using the environment supplied.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o> oho ma smoo> Op-pU


Uses of Interface javax.naming.spi.ObjectFactoryBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.ObjectFactoryBuilder

  • Packages that use ObjectFactoryBuilder
    软件包 描述
    javax.naming.spi

    • Uses of ObjectFactoryBuilder in javax.naming.spi

      Methods in javax.naming.spi with parameters of type ObjectFactoryBuilder
      修饰符与类型 方法与描述
      static void NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder)
      The ObjectFactoryBuilder determines the policy used when trying to load object factories.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtpp.s...ll.


Uses of Interface javax.naming.spi.Resolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.Resolver

No usage of javax.naming.spi.Resolver
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=g"tar_n-aaakh =si-


Uses of Interface javax.naming.spi.StateFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.naming.spi.StateFactory

  • Packages that use StateFactory
    软件包 描述
    javax.naming.spi

    • Uses of StateFactory in javax.naming.spi

      Subinterfaces of StateFactory in javax.naming.spi
      修饰符与类型 Interface and Description
      interface  DirStateFactory
      This interface represents a factory for obtaining the state of an object and corresponding attributes for binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oamrnbobvrbtreiieleha"tt


javax.net

Classes

  • ServerSocketFactory
  • SocketFactory


javax.net

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.net

Provides classes for networking applications.

请参见： 描述

  • Class Summary
    类 描述
    ServerSocketFactory
    This class creates server sockets.
    SocketFactory
    This class creates sockets.

软件包 javax.net Description

Provides classes for networking applications. These classes include factories for creating sockets. Using socket factories you can encapsulate socket creation and configuration behavior.
从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcafiicsld騈e�=>}


javax.net Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.net

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.net.ServerSocketFactory
    • javax.net.SocketFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h�


ServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net

类 ServerSocketFactory

  • java.lang.Object
    • javax.net.ServerSocketFactory
  • 直接已知子类：
    SSLServerSocketFactory

    public abstract class ServerSocketFactory
extends Object
    This class creates server sockets. It may be subclassed by other factories, which create particular types of server sockets. This provides a general framework for the addition of public socket-level functionality. It is the server side analogue of a socket factory, and similarly provides a way to capture a variety of policies related to the sockets being constructed.

    Like socket factories, server Socket factory instances have methods used to create sockets. There is also an environment specific default server socket factory; frameworks will often use their own customized factory.

    从以下版本开始：
    1.4
    另请参见：
    SocketFactory

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ServerSocketFactory()
      Creates a server socket factory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ServerSocket createServerSocket()
      Returns an unbound server socket.
      abstract ServerSocket createServerSocket(int port)
      Returns a server socket bound to the specified port.
      abstract ServerSocket createServerSocket(int port, int backlog)
      Returns a server socket bound to the specified port, and uses the specified connection backlog.
      abstract ServerSocket createServerSocket(int port, int backlog, InetAddress ifAddress)
      Returns a server socket bound to the specified port, with a specified listen backlog and local IP.
      static ServerSocketFactory getDefault()
      Returns a copy of the environment's default socket factory.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServerSocketFactory

        protected ServerSocketFactory()
        Creates a server socket factory.

    • 方法详细信息

      • getDefault

        public static ServerSocketFactory getDefault()
        Returns a copy of the environment's default socket factory.
        返回：
        the ServerSocketFactory

      • createServerSocket

        public ServerSocket createServerSocket()
                                throws IOException
        Returns an unbound server socket. The socket is configured with the socket options (such as accept timeout) given to this factory.
        返回：
        the unbound socket
        抛出：
        IOException - if the socket cannot be created
        另请参见：
        ServerSocket.bind(java.net.SocketAddress),
ServerSocket.bind(java.net.SocketAddress, int),
ServerSocket.ServerSocket()

      • createServerSocket

        public abstract ServerSocket createServerSocket(int port)
                                         throws IOException
        Returns a server socket bound to the specified port. The socket is configured with the socket options (such as accept timeout) given to this factory.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        参数：
        port - the port to listen to
        返回：
        the ServerSocket
        抛出：
        IOException - for networking errors
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int), ServerSocket.ServerSocket(int)

      • createServerSocket

        public abstract ServerSocket createServerSocket(int port,
                              int backlog)
                                         throws IOException
        Returns a server socket bound to the specified port, and uses the specified connection backlog. The socket is configured with the socket options (such as accept timeout) given to this factory.

        The backlog argument must be a positive value greater than 0. If the value passed if equal or less than 0, then the default value will be assumed.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        参数：
        port - the port to listen to
        backlog - how many connections are queued
        返回：
        the ServerSocket
        抛出：
        IOException - for networking errors
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int), ServerSocket.ServerSocket(int, int)

      • createServerSocket

        public abstract ServerSocket createServerSocket(int port,
                              int backlog,
                              InetAddress ifAddress)
                                         throws IOException
        Returns a server socket bound to the specified port, with a specified listen backlog and local IP.

        The ifAddress argument can be used on a multi-homed host for a ServerSocket that will only accept connect requests to one of its addresses. If ifAddress is null, it will accept connections on all local addresses. The socket is configured with the socket options (such as accept timeout) given to this factory.

        The backlog argument must be a positive value greater than 0. If the value passed if equal or less than 0, then the default value will be assumed.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        参数：
        port - the port to listen to
        backlog - how many connections are queued
        ifAddress - the network interface address to use
        返回：
        the ServerSocket
        抛出：
        IOException - for networking errors
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int), ServerSocket.ServerSocket(int, int, java.net.InetAddress)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a jsion


SocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net

类 SocketFactory

  • java.lang.Object
    • javax.net.SocketFactory
  • 直接已知子类：
    SSLSocketFactory

    public abstract class SocketFactory
extends Object
    This class creates sockets. It may be subclassed by other factories, which create particular subclasses of sockets and thus provide a general framework for the addition of public socket-level functionality.

    Socket factories are a simple way to capture a variety of policies related to the sockets being constructed, producing such sockets in a way which does not require special configuration of the code which asks for the sockets:

    • Due to polymorphism of both factories and sockets, different kinds of sockets can be used by the same application code just by passing it different kinds of factories.
    • Factories can themselves be customized with parameters used in socket construction. So for example, factories could be customized to return sockets with different networking timeouts or security parameters already configured.
    • The sockets returned to the application can be subclasses of java.net.Socket, so that they can directly expose new APIs for features such as compression, security, record marking, statistics collection, or firewall tunneling.

    Factory classes are specified by environment-specific configuration mechanisms. For example, the getDefault method could return a factory that was appropriate for a particular user or applet, and a framework could use a factory customized to its own purposes.

    从以下版本开始：
    1.4
    另请参见：
    ServerSocketFactory

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SocketFactory()
      Creates a SocketFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Socket createSocket()
      Creates an unconnected socket.
      abstract Socket createSocket(InetAddress host, int port)
      Creates a socket and connects it to the specified port number at the specified address.
      abstract Socket createSocket(InetAddress address, int port, InetAddress localAddress, int localPort)
      Creates a socket and connect it to the specified remote address on the specified remote port.
      abstract Socket createSocket(String host, int port)
      Creates a socket and connects it to the specified remote host at the specified remote port.
      abstract Socket createSocket(String host, int port, InetAddress localHost, int localPort)
      Creates a socket and connects it to the specified remote host on the specified remote port.
      static SocketFactory getDefault()
      Returns a copy of the environment's default socket factory.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SocketFactory

        protected SocketFactory()
        Creates a SocketFactory.

    • 方法详细信息

      • getDefault

        public static SocketFactory getDefault()
        Returns a copy of the environment's default socket factory.
        返回：
        the default SocketFactory

      • createSocket

        public Socket createSocket()
                    throws IOException
        Creates an unconnected socket.
        返回：
        the unconnected socket
        抛出：
        IOException - if the socket cannot be created
        另请参见：
        Socket.connect(java.net.SocketAddress),
Socket.connect(java.net.SocketAddress, int),
Socket.Socket()

      • createSocket

        public abstract Socket createSocket(String host,
                  int port)
                             throws IOException,
                                    UnknownHostException
        Creates a socket and connects it to the specified remote host at the specified remote port. This socket is configured using the socket options established for this factory.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        host - the server host name with which to connect, or null for the loopback address.
        port - the server port
        返回：
        the Socket
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        UnknownHostException - if the host is not known
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int), Socket.Socket(String, int)

      • createSocket

        public abstract Socket createSocket(String host,
                  int port,
                  InetAddress localHost,
                  int localPort)
                             throws IOException,
                                    UnknownHostException
        Creates a socket and connects it to the specified remote host on the specified remote port. The socket will also be bound to the local address and port supplied. This socket is configured using the socket options established for this factory.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        host - the server host name with which to connect, or null for the loopback address.
        port - the server port
        localHost - the local address the socket is bound to
        localPort - the local port the socket is bound to
        返回：
        the Socket
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        UnknownHostException - if the host is not known
        IllegalArgumentException - if the port parameter or localPort parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int), Socket.Socket(String, int, java.net.InetAddress, int)

      • createSocket

        public abstract Socket createSocket(InetAddress host,
                  int port)
                             throws IOException
        Creates a socket and connects it to the specified port number at the specified address. This socket is configured using the socket options established for this factory.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        host - the server host
        port - the server port
        返回：
        the Socket
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        NullPointerException - if host is null.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int), Socket.Socket(java.net.InetAddress, int)

      • createSocket

        public abstract Socket createSocket(InetAddress address,
                  int port,
                  InetAddress localAddress,
                  int localPort)
                             throws IOException
        Creates a socket and connect it to the specified remote address on the specified remote port. The socket will also be bound to the local address and port suplied. The socket is configured using the socket options established for this factory.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        address - the server network address
        port - the server port
        localAddress - the client network address
        localPort - the client port
        返回：
        the Socket
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        IllegalArgumentException - if the port parameter or localPort parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        NullPointerException - if address is null.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int), Socket.Socket(java.net.InetAddress, int, java.net.InetAddress, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<)rg"olmt


Uses of Package javax.net

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.net

  • Packages that use javax.net
    软件包 描述
    javax.net
    Provides classes for networking applications.
    javax.net.ssl
    Provides classes for the secure socket package.
  • Classes in javax.net used by javax.net
    类与描述
    ServerSocketFactory
    This class creates server sockets.
    SocketFactory
    This class creates sockets.
  • Classes in javax.net used by javax.net.ssl
    类与描述
    ServerSocketFactory
    This class creates server sockets.
    SocketFactory
    This class creates sockets.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

if.nlnyfaisu"="llde


Uses of Class javax.net.ServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ServerSocketFactory

  • Packages that use ServerSocketFactory
    软件包 描述
    javax.net
    Provides classes for networking applications.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of ServerSocketFactory in javax.net

      Methods in javax.net that return ServerSocketFactory
      修饰符与类型 方法与描述
      static ServerSocketFactory ServerSocketFactory.getDefault()
      Returns a copy of the environment's default socket factory.

    • Uses of ServerSocketFactory in javax.net.ssl

      Subclasses of ServerSocketFactory in javax.net.ssl
      修饰符与类型 类与描述
      class  SSLServerSocketFactory
      SSLServerSocketFactorys create SSLServerSockets.
      Methods in javax.net.ssl that return ServerSocketFactory
      修饰符与类型 方法与描述
      static ServerSocketFactory SSLServerSocketFactory.getDefault()
      Returns the default SSL server socket factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/aengalLi=


Uses of Class javax.net.SocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.SocketFactory

  • Packages that use SocketFactory
    软件包 描述
    javax.net
    Provides classes for networking applications.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SocketFactory in javax.net

      Methods in javax.net that return SocketFactory
      修饰符与类型 方法与描述
      static SocketFactory SocketFactory.getDefault()
      Returns a copy of the environment's default socket factory.

    • Uses of SocketFactory in javax.net.ssl

      Subclasses of SocketFactory in javax.net.ssl
      修饰符与类型 类与描述
      class  SSLSocketFactory
      SSLSocketFactorys create SSLSockets.
      Methods in javax.net.ssl that return SocketFactory
      修饰符与类型 方法与描述
      static SocketFactory SSLSocketFactory.getDefault()
      Returns the default SSL socket factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aemoi goexlb 9a/４�>e 


CertPathTrustManagerParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 CertPathTrustManagerParameters

  • java.lang.Object
    • javax.net.ssl.CertPathTrustManagerParameters
  • 所有已实现的接口：
    ManagerFactoryParameters

    public class CertPathTrustManagerParameters
extends Object
implements ManagerFactoryParameters
    A wrapper for CertPathParameters. This class is used to pass validation settings to CertPath based TrustManagers using the TrustManagerFactory.init() method.

    Instances of this class are immutable.

    从以下版本开始：
    1.5
    另请参见：
    X509TrustManager, TrustManagerFactory, CertPathParameters

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertPathTrustManagerParameters(CertPathParameters parameters)
      Construct new CertPathTrustManagerParameters from the specified parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CertPathParameters getParameters()
      Return a clone of the CertPathParameters encapsulated by this class.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CertPathTrustManagerParameters

        public CertPathTrustManagerParameters(CertPathParameters parameters)
        Construct new CertPathTrustManagerParameters from the specified parameters. The parameters are cloned to protect against subsequent modification.
        参数：
        parameters - the CertPathParameters to be used
        抛出：
        NullPointerException - if parameters is null

    • 方法详细信息

      • getParameters

        public CertPathParameters getParameters()
        Return a clone of the CertPathParameters encapsulated by this class.
        返回：
        a clone of the CertPathParameters encapsulated by this class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h stliatt�">lc m/a/


ExtendedSSLSession

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 ExtendedSSLSession

  • java.lang.Object
    • javax.net.ssl.ExtendedSSLSession
  • 所有已实现的接口：
    SSLSession

    public abstract class ExtendedSSLSession
extends Object
implements SSLSession
    Extends the SSLSession interface to support additional session attributes.
    从以下版本开始：
    1.7

    • 构造方法摘要

      Constructors
      构造方法与描述
      ExtendedSSLSession()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String[] getLocalSupportedSignatureAlgorithms()
      Obtains an array of supported signature algorithms that the local side is willing to use.
      abstract String[] getPeerSupportedSignatureAlgorithms()
      Obtains an array of supported signature algorithms that the peer is able to use.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.net.ssl.SSLSession

        getApplicationBufferSize, getCipherSuite, getCreationTime, getId, getLastAccessedTime, getLocalCertificates, getLocalPrincipal, getPacketBufferSize, getPeerCertificateChain, getPeerCertificates, getPeerHost, getPeerPort, getPeerPrincipal, getProtocol, getSessionContext, getValue, getValueNames, invalidate, isValid, putValue, removeValue

    • 构造方法详细信息

      • ExtendedSSLSession

        public ExtendedSSLSession()

    • 方法详细信息

      • getLocalSupportedSignatureAlgorithms

        public abstract String[] getLocalSupportedSignatureAlgorithms()
        Obtains an array of supported signature algorithms that the local side is willing to use.

        Note: this method is used to indicate to the peer which signature algorithms may be used for digital signatures in TLS 1.2. It is not meaningful for TLS versions prior to 1.2.

        The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See Appendix A in the Java Cryptography Architecture API Specification & Reference for information about standard algorithm names.

        Note: the local supported signature algorithms should conform to the algorithm constraints specified by getAlgorithmConstraints() method in SSLParameters.

        返回：
        An array of supported signature algorithms, in descending order of preference. The return value is an empty array if no signature algorithm is supported.
        另请参见：
        SSLParameters.getAlgorithmConstraints()

      • getPeerSupportedSignatureAlgorithms

        public abstract String[] getPeerSupportedSignatureAlgorithms()
        Obtains an array of supported signature algorithms that the peer is able to use.

        Note: this method is used to indicate to the local side which signature algorithms may be used for digital signatures in TLS 1.2. It is not meaningful for TLS versions prior to 1.2.

        The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See Appendix A in the Java Cryptography Architecture API Specification & Reference for information about standard algorithm names.

        返回：
        An array of supported signature algorithms, in descending order of preference. The return value is an empty array if the peer has not sent the supported signature algorithms.
        另请参见：
        X509KeyManager, X509ExtendedKeyManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&medfacd"i>es. amoe.le&eaai/a rm


HandshakeCompletedEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 HandshakeCompletedEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.net.ssl.HandshakeCompletedEvent
  • 所有已实现的接口：
    Serializable

    public class HandshakeCompletedEvent
extends EventObject
    This event indicates that an SSL handshake completed on a given SSL connection. All of the core information about that handshake's result is captured through an "SSLSession" object. As a convenience, this event class provides direct access to some important session attributes.

    The source of this event is the SSLSocket on which handshaking just completed.

    从以下版本开始：
    1.4
    另请参见：
    SSLSocket, HandshakeCompletedListener, SSLSession, Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
      Constructs a new HandshakeCompletedEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getCipherSuite()
      Returns the cipher suite in use by the session which was produced by the handshake.
      Certificate[] getLocalCertificates()
      Returns the certificate(s) that were sent to the peer during handshaking.
      Principal getLocalPrincipal()
      Returns the principal that was sent to the peer during handshaking.
      X509Certificate[] getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.
      Certificate[] getPeerCertificates()
      Returns the identity of the peer which was established as part of defining the session.
      Principal getPeerPrincipal()
      Returns the identity of the peer which was established as part of defining the session.
      SSLSession getSession()
      Returns the session that triggered this event.
      SSLSocket getSocket()
      Returns the socket which is the source of this event.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HandshakeCompletedEvent

        public HandshakeCompletedEvent(SSLSocket sock,
                       SSLSession s)
        Constructs a new HandshakeCompletedEvent.
        参数：
        sock - the SSLSocket acting as the source of the event
        s - the SSLSession this event is associated with

    • 方法详细信息

      • getSession

        public SSLSession getSession()
        Returns the session that triggered this event.
        返回：
        the SSLSession for this handshake

      • getCipherSuite

        public String getCipherSuite()
        Returns the cipher suite in use by the session which was produced by the handshake. (This is a convenience method for getting the ciphersuite from the SSLsession.)
        返回：
        the name of the cipher suite negotiated during this session.

      • getLocalCertificates

        public Certificate[] getLocalCertificates()
        Returns the certificate(s) that were sent to the peer during handshaking. Note: This method is useful only when using certificate-based cipher suites. When multiple certificates are available for use in a handshake, the implementation chooses what it considers the "best" certificate chain available, and transmits that to the other side. This method allows the caller to know which certificate chain was actually used.
        返回：
        an ordered array of certificates, with the local certificate first followed by any certificate authorities. If no certificates were sent, then null is returned.
        另请参见：
        getLocalPrincipal()

      • getPeerCertificates

        public Certificate[] getPeerCertificates()
                                  throws SSLPeerUnverifiedException
        Returns the identity of the peer which was established as part of defining the session. Note: This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.
        返回：
        an ordered array of the peer certificates, with the peer's own certificate first followed by any certificate authorities.
        抛出：
        SSLPeerUnverifiedException - if the peer is not verified.
        另请参见：
        getPeerPrincipal()

      • getPeerCertificateChain

        public X509Certificate[] getPeerCertificateChain()
                                          throws SSLPeerUnverifiedException
        Returns the identity of the peer which was identified as part of defining the session. Note: This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.

        Note: this method exists for compatibility with previous releases. New applications should use getPeerCertificates() instead.

        返回：
        an ordered array of peer X.509 certificates, with the peer's own certificate first followed by any certificate authorities. (The certificates are in the original JSSE X509Certificate format).
        抛出：
        SSLPeerUnverifiedException - if the peer is not verified.
        另请参见：
        getPeerPrincipal()

      • getPeerPrincipal

        public Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
        Returns the identity of the peer which was established as part of defining the session.
        返回：
        the peer's principal. Returns an X500Principal of the end-entity certiticate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites.
        抛出：
        SSLPeerUnverifiedException - if the peer's identity has not been verified
        从以下版本开始：
        1.5
        另请参见：
        getPeerCertificates(), getLocalPrincipal()

      • getLocalPrincipal

        public Principal getLocalPrincipal()
        Returns the principal that was sent to the peer during handshaking.
        返回：
        the principal sent to the peer. Returns an X500Principal of the end-entity certificate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites. If no principal was sent, then null is returned.
        从以下版本开始：
        1.5
        另请参见：
        getLocalCertificates(), getPeerPrincipal()

      • getSocket

        public SSLSocket getSocket()
        Returns the socket which is the source of this event. (This is a convenience function, to let applications write code without type casts.)
        返回：
        the socket on which the connection was made.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olM omn=" oesmdhyfo"oM=tl�<<禷蝨nm>=l 筺 ab


HandshakeCompletedListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface HandshakeCompletedListener

  • All Superinterfaces:
    EventListener

    public interface HandshakeCompletedListener
extends EventListener
    This interface is implemented by any class which wants to receive notifications about the completion of an SSL protocol handshake on a given SSL connection.

    When an SSL handshake completes, new security parameters will have been established. Those parameters always include the security keys used to protect messages. They may also include parameters associated with a new session such as authenticated peer identity and a new SSL cipher suite.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void handshakeCompleted(HandshakeCompletedEvent event)
      This method is invoked on registered objects when a SSL handshake is completed.

    • 方法详细信息

      • handshakeCompleted

        void handshakeCompleted(HandshakeCompletedEvent event)
        This method is invoked on registered objects when a SSL handshake is completed.
        参数：
        event - the event identifying when the SSL Handshake completed on a given SSL connection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gs>/Cachaciaaciiegaaha>>g.alnnvnC


HostnameVerifier

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface HostnameVerifier

  • public interface HostnameVerifier
    This class is the base interface for hostname verification.

    During handshaking, if the URL's hostname and the server's identification hostname mismatch, the verification mechanism can call back to implementers of this interface to determine if this connection should be allowed.

    The policies can be certificate-based or may depend on other authentication schemes.

    These callbacks are used when the default rules for URL hostname verification fail.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean verify(String hostname, SSLSession session)
      Verify that the host name is an acceptable match with the server's authentication scheme.

    • 方法详细信息

      • verify

        boolean verify(String hostname,
             SSLSession session)
        Verify that the host name is an acceptable match with the server's authentication scheme.
        参数：
        hostname - the host name
        session - SSLSession used on the connection to host
        返回：
        true if the host name is acceptable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&<#腥邪� 杏/> &0;3#�99>193 O903#1>


HttpsURLConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 HttpsURLConnection

  • java.lang.Object
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection

  • public abstract class HttpsURLConnection
extends HttpURLConnection
    HttpsURLConnection extends HttpURLConnection with support for https-specific features.

    See http://www.w3.org/pub/WWW/Protocols/ and RFC 2818 for more details on the https specification.

    This class uses HostnameVerifier and SSLSocketFactory. There are default implementations defined for both classes. However, the implementations can be replaced on a per-class (static) or per-instance basis. All new HttpsURLConnections instances will be assigned the "default" static values at instance creation, but they can be overriden by calling the appropriate per-instance set method(s) before connecting.

    从以下版本开始：
    1.4

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected HostnameVerifier hostnameVerifier
      The hostnameVerifier for this object.

      • Fields inherited from class java.net.HttpURLConnection

        chunkLength, fixedContentLength, fixedContentLengthLong, HTTP_ACCEPTED, HTTP_BAD_GATEWAY, HTTP_BAD_METHOD, HTTP_BAD_REQUEST, HTTP_CLIENT_TIMEOUT, HTTP_CONFLICT, HTTP_CREATED, HTTP_ENTITY_TOO_LARGE, HTTP_FORBIDDEN, HTTP_GATEWAY_TIMEOUT, HTTP_GONE, HTTP_INTERNAL_ERROR, HTTP_LENGTH_REQUIRED, HTTP_MOVED_PERM, HTTP_MOVED_TEMP, HTTP_MULT_CHOICE, HTTP_NO_CONTENT, HTTP_NOT_ACCEPTABLE, HTTP_NOT_AUTHORITATIVE, HTTP_NOT_FOUND, HTTP_NOT_IMPLEMENTED, HTTP_NOT_MODIFIED, HTTP_OK, HTTP_PARTIAL, HTTP_PAYMENT_REQUIRED, HTTP_PRECON_FAILED, HTTP_PROXY_AUTH, HTTP_REQ_TOO_LONG, HTTP_RESET, HTTP_SEE_OTHER, HTTP_SERVER_ERROR, HTTP_UNAUTHORIZED, HTTP_UNAVAILABLE, HTTP_UNSUPPORTED_TYPE, HTTP_USE_PROXY, HTTP_VERSION, instanceFollowRedirects, 方法, responseCode, responseMessage

      • Fields inherited from class java.net.URLConnection

        allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected HttpsURLConnection(URL url)
      Creates an HttpsURLConnection using the URL specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String getCipherSuite()
      Returns the cipher suite in use on this connection.
      static HostnameVerifier getDefaultHostnameVerifier()
      Gets the default HostnameVerifier that is inherited by new instances of this class.
      static SSLSocketFactory getDefaultSSLSocketFactory()
      Gets the default static SSLSocketFactory that is inherited by new instances of this class.
      HostnameVerifier getHostnameVerifier()
      Gets the HostnameVerifier in place on this instance.
      abstract Certificate[] getLocalCertificates()
      Returns the certificate(s) that were sent to the server during handshaking.
      Principal getLocalPrincipal()
      Returns the principal that was sent to the server during handshaking.
      Principal getPeerPrincipal()
      Returns the server's principal which was established as part of defining the session.
      abstract Certificate[] getServerCertificates()
      Returns the server's certificate chain which was established as part of defining the session.
      SSLSocketFactory getSSLSocketFactory()
      Gets the SSL socket factory to be used when creating sockets for secure https URL connections.
      static void setDefaultHostnameVerifier(HostnameVerifier v)
      Sets the default HostnameVerifier inherited by a new instance of this class.
      static void setDefaultSSLSocketFactory(SSLSocketFactory sf)
      Sets the default SSLSocketFactory inherited by new instances of this class.
      void setHostnameVerifier(HostnameVerifier v)
      Sets the HostnameVerifier for this instance.
      void setSSLSocketFactory(SSLSocketFactory sf)
      Sets the SSLSocketFactory to be used when this instance creates sockets for secure https URL connections.

      • 方法 - 继承于类 java.net.HttpURLConnection

        disconnect, getErrorStream, getFollowRedirects, getHeaderField, getHeaderFieldDate, getHeaderFieldKey, getInstanceFollowRedirects, getPermission, getRequestMethod, getResponseCode, getResponseMessage, setChunkedStreamingMode, setFixedLengthStreamingMode, setFixedLengthStreamingMode, setFollowRedirects, setInstanceFollowRedirects, setRequestMethod, usingProxy

      • 方法 - 继承于类 java.net.URLConnection

        addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentLengthLong, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderFieldInt, getHeaderFieldLong, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • hostnameVerifier

        protected HostnameVerifier hostnameVerifier
        The hostnameVerifier for this object.

    • 构造方法详细信息

      • HttpsURLConnection

        protected HttpsURLConnection(URL url)
        Creates an HttpsURLConnection using the URL specified.
        参数：
        url - the URL

    • 方法详细信息

      • getCipherSuite

        public abstract String getCipherSuite()
        Returns the cipher suite in use on this connection.
        返回：
        the cipher suite
        抛出：
        IllegalStateException - if this method is called before the connection has been established.

      • getLocalCertificates

        public abstract Certificate[] getLocalCertificates()
        Returns the certificate(s) that were sent to the server during handshaking.

        Note: This method is useful only when using certificate-based cipher suites.

        When multiple certificates are available for use in a handshake, the implementation chooses what it considers the "best" certificate chain available, and transmits that to the other side. This method allows the caller to know which certificate chain was actually sent.

        返回：
        an ordered array of certificates, with the client's own certificate first followed by any certificate authorities. If no certificates were sent, then null is returned.
        抛出：
        IllegalStateException - if this method is called before the connection has been established.
        另请参见：
        getLocalPrincipal()

      • getServerCertificates

        public abstract Certificate[] getServerCertificates()
                                             throws SSLPeerUnverifiedException
        Returns the server's certificate chain which was established as part of defining the session.

        Note: This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.

        返回：
        an ordered array of server certificates, with the peer's own certificate first followed by any certificate authorities.
        抛出：
        SSLPeerUnverifiedException - if the peer is not verified.
        IllegalStateException - if this method is called before the connection has been established.
        另请参见：
        getPeerPrincipal()

      • getPeerPrincipal

        public Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
        Returns the server's principal which was established as part of defining the session.

        Note: Subclasses should override this method. If not overridden, it will default to returning the X500Principal of the server's end-entity certificate for certificate-based ciphersuites, or throw an SSLPeerUnverifiedException for non-certificate based ciphersuites, such as Kerberos.

        返回：
        the server's principal. Returns an X500Principal of the end-entity certiticate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites.
        抛出：
        SSLPeerUnverifiedException - if the peer was not verified
        IllegalStateException - if this method is called before the connection has been established.
        从以下版本开始：
        1.5
        另请参见：
        getServerCertificates(), getLocalPrincipal()

      • getLocalPrincipal

        public Principal getLocalPrincipal()
        Returns the principal that was sent to the server during handshaking.

        Note: Subclasses should override this method. If not overridden, it will default to returning the X500Principal of the end-entity certificate that was sent to the server for certificate-based ciphersuites or, return null for non-certificate based ciphersuites, such as Kerberos.

        返回：
        the principal sent to the server. Returns an X500Principal of the end-entity certificate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites. If no principal was sent, then null is returned.
        抛出：
        IllegalStateException - if this method is called before the connection has been established.
        从以下版本开始：
        1.5
        另请参见：
        getLocalCertificates(), getPeerPrincipal()

      • setDefaultHostnameVerifier

        public static void setDefaultHostnameVerifier(HostnameVerifier v)
        Sets the default HostnameVerifier inherited by a new instance of this class.

        If this method is not called, the default HostnameVerifier assumes the connection should not be permitted.

        参数：
        v - the default host name verifier
        抛出：
        IllegalArgumentException - if the HostnameVerifier parameter is null.
        SecurityException - if a security manager exists and its checkPermission method does not allow SSLPermission("setHostnameVerifier")
        另请参见：
        getDefaultHostnameVerifier()

      • getDefaultHostnameVerifier

        public static HostnameVerifier getDefaultHostnameVerifier()
        Gets the default HostnameVerifier that is inherited by new instances of this class.
        返回：
        the default host name verifier
        另请参见：
        setDefaultHostnameVerifier(HostnameVerifier)

      • setHostnameVerifier

        public void setHostnameVerifier(HostnameVerifier v)
        Sets the HostnameVerifier for this instance.

        New instances of this class inherit the default static hostname verifier set by setDefaultHostnameVerifier. Calls to this method replace this object's HostnameVerifier.

        参数：
        v - the host name verifier
        抛出：
        IllegalArgumentException - if the HostnameVerifier parameter is null.
        另请参见：
        getHostnameVerifier(), setDefaultHostnameVerifier(HostnameVerifier)

      • getHostnameVerifier

        public HostnameVerifier getHostnameVerifier()
        Gets the HostnameVerifier in place on this instance.
        返回：
        the host name verifier
        另请参见：
        setHostnameVerifier(HostnameVerifier), setDefaultHostnameVerifier(HostnameVerifier)

      • setDefaultSSLSocketFactory

        public static void setDefaultSSLSocketFactory(SSLSocketFactory sf)
        Sets the default SSLSocketFactory inherited by new instances of this class.

        The socket factories are used when creating sockets for secure https URL connections.

        参数：
        sf - the default SSL socket factory
        抛出：
        IllegalArgumentException - if the SSLSocketFactory parameter is null.
        SecurityException - if a security manager exists and its checkSetFactory method does not allow a socket factory to be specified.
        另请参见：
        getDefaultSSLSocketFactory()

      • getDefaultSSLSocketFactory

        public static SSLSocketFactory getDefaultSSLSocketFactory()
        Gets the default static SSLSocketFactory that is inherited by new instances of this class.

        The socket factories are used when creating sockets for secure https URL connections.

        返回：
        the default SSLSocketFactory
        另请参见：
        setDefaultSSLSocketFactory(SSLSocketFactory)

      • setSSLSocketFactory

        public void setSSLSocketFactory(SSLSocketFactory sf)
        Sets the SSLSocketFactory to be used when this instance creates sockets for secure https URL connections.

        New instances of this class inherit the default static SSLSocketFactory set by setDefaultSSLSocketFactory. Calls to this method replace this object's SSLSocketFactory.

        参数：
        sf - the SSL socket factory
        抛出：
        IllegalArgumentException - if the SSLSocketFactory parameter is null.
        另请参见：
        getSSLSocketFactory()

      • getSSLSocketFactory

        public SSLSocketFactory getSSLSocketFactory()
        Gets the SSL socket factory to be used when creating sockets for secure https URL connections.
        返回：
        the SSLSocketFactory
        另请参见：
        setSSLSocketFactory(SSLSocketFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.net.ssl

Interfaces

  • HandshakeCompletedListener
  • HostnameVerifier
  • KeyManager
  • ManagerFactoryParameters
  • SSLSession
  • SSLSessionBindingListener
  • SSLSessionContext
  • TrustManager
  • X509KeyManager
  • X509TrustManager

Classes

  • CertPathTrustManagerParameters
  • ExtendedSSLSession
  • HandshakeCompletedEvent
  • HttpsURLConnection
  • KeyManagerFactory
  • KeyManagerFactorySpi
  • KeyStoreBuilderParameters
  • SSLContext
  • SSLContextSpi
  • SSLEngine
  • SSLEngineResult
  • SSLParameters
  • SSLPermission
  • SSLServerSocket
  • SSLServerSocketFactory
  • SSLSessionBindingEvent
  • SSLSocket
  • SSLSocketFactory
  • TrustManagerFactory
  • TrustManagerFactorySpi
  • X509ExtendedKeyManager
  • X509ExtendedTrustManager

Enums

  • SSLEngineResult.HandshakeStatus
  • SSLEngineResult.Status

Exceptions

  • SSLException
  • SSLHandshakeException
  • SSLKeyException
  • SSLPeerUnverifiedException
  • SSLProtocolException
a


javax.net.ssl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.net.ssl

Provides classes for the secure socket package.

请参见： 描述

  • 接口摘要
    接口 描述
    HandshakeCompletedListener
    This interface is implemented by any class which wants to receive notifications about the completion of an SSL protocol handshake on a given SSL connection.
    HostnameVerifier
    This class is the base interface for hostname verification.
    KeyManager
    This is the base interface for JSSE key managers.
    ManagerFactoryParameters
    This class is the base interface for providing algorithm-specific information to a KeyManagerFactory or TrustManagerFactory.
    SSLSession
    In SSL, sessions are used to describe an ongoing relationship between two entities.
    SSLSessionBindingListener
    This interface is implemented by objects which want to know when they are being bound or unbound from a SSLSession.
    SSLSessionContext
    A SSLSessionContext represents a set of SSLSessions associated with a single entity.
    TrustManager
    This is the base interface for JSSE trust managers.
    X509KeyManager
    Instances of this interface manage which X509 certificate-based key pairs are used to authenticate the local side of a secure socket.
    X509TrustManager
    Instance of this interface manage which X509 certificates may be used to authenticate the remote side of a secure socket.
  • Class Summary
    类 描述
    CertPathTrustManagerParameters
    A wrapper for CertPathParameters.
    ExtendedSSLSession
    Extends the SSLSession interface to support additional session attributes.
    HandshakeCompletedEvent
    This event indicates that an SSL handshake completed on a given SSL connection.
    HttpsURLConnection
    HttpsURLConnection extends HttpURLConnection with support for https-specific features.
    KeyManagerFactory
    This class acts as a factory for key managers based on a source of key material.
    KeyManagerFactorySpi
    This class defines the Service Provider Interface (SPI) for the KeyManagerFactory class.
    KeyStoreBuilderParameters
    A parameters object for X509KeyManagers that encapsulates a List of KeyStore.Builders.
    SSLContext
    Instances of this class represent a secure socket protocol implementation which acts as a factory for secure socket factories or SSLEngines.
    SSLContextSpi
    This class defines the Service Provider Interface (SPI) for the SSLContext class.
    SSLEngine
    A class which enables secure communications using protocols such as the Secure Sockets Layer (SSL) or IETF RFC 2246 "Transport Layer Security" (TLS) protocols, but is transport independent.
    SSLEngineResult
    An encapsulation of the result state produced by SSLEngine I/O calls.
    SSLParameters
    Encapsulates parameters for an SSL/TLS connection.
    SSLPermission
    This class is for various network permissions.
    SSLServerSocket
    This class extends ServerSockets and provides secure server sockets using protocols such as the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.
    SSLServerSocketFactory
    SSLServerSocketFactorys create SSLServerSockets.
    SSLSessionBindingEvent
    This event is propagated to a SSLSessionBindingListener.
    SSLSocket
    This class extends Sockets and provides secure socket using protocols such as the "Secure Sockets Layer" (SSL) or IETF "Transport Layer Security" (TLS) protocols.
    SSLSocketFactory
    SSLSocketFactorys create SSLSockets.
    TrustManagerFactory
    This class acts as a factory for trust managers based on a source of trust material.
    TrustManagerFactorySpi
    This class defines the Service Provider Interface (SPI) for the TrustManagerFactory class.
    X509ExtendedKeyManager
    Abstract class that provides for extension of the X509KeyManager interface.
    X509ExtendedTrustManager
    Extensions to the X509TrustManager interface to support SSL/TLS connection sensitive trust management.
  • Enum Summary
    Enum 描述
    SSLEngineResult.HandshakeStatus
    An SSLEngineResult enum describing the current handshaking state of this SSLEngine.
    SSLEngineResult.Status
    An SSLEngineResult enum describing the overall result of the SSLEngine operation.
  • Exception Summary
    Exception 描述
    SSLException
    Indicates some kind of error detected by an SSL subsystem.
    SSLHandshakeException
    Indicates that the client and server could not negotiate the desired level of security.
    SSLKeyException
    Reports a bad SSL key.
    SSLPeerUnverifiedException
    Indicates that the peer's identity has not been verified.
    SSLProtocolException
    Reports an error in the operation of the SSL protocol.

软件包 javax.net.ssl Description

Provides classes for the secure socket package. Using the secure socket classes, you can communicate using SSL or a related security protocol to reliably detect any errors introduced into the network byte stream and to optionally encrypt the data and/or authenticate the communicating peers.

Package Specification

  • JavaTM Cryptography Architecture Standard Algorithm Name Documentation
从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c .


javax.net.ssl Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.net.ssl

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.net.ssl.CertPathTrustManagerParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.net.ssl.HandshakeCompletedEvent
      • javax.net.ssl.SSLSessionBindingEvent
    • javax.net.ssl.ExtendedSSLSession (implements javax.net.ssl.SSLSession)
    • javax.net.ssl.KeyManagerFactory
    • javax.net.ssl.KeyManagerFactorySpi
    • javax.net.ssl.KeyStoreBuilderParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.net.ssl.SSLPermission
    • java.net.ServerSocket (implements java.io.Closeable)
      • javax.net.ssl.SSLServerSocket
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory
    • java.net.Socket (implements java.io.Closeable)
      • javax.net.ssl.SSLSocket
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory
    • javax.net.ssl.SSLContext
    • javax.net.ssl.SSLContextSpi
    • javax.net.ssl.SSLEngine
    • javax.net.ssl.SSLEngineResult
    • javax.net.ssl.SSLParameters
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
            • javax.net.ssl.SSLKeyException
            • javax.net.ssl.SSLPeerUnverifiedException
            • javax.net.ssl.SSLProtocolException
    • javax.net.ssl.TrustManagerFactory
    • javax.net.ssl.TrustManagerFactorySpi
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection
    • javax.net.ssl.X509ExtendedKeyManager (implements javax.net.ssl.X509KeyManager)
    • javax.net.ssl.X509ExtendedTrustManager (implements javax.net.ssl.X509TrustManager)

Interface Hierarchy

  • java.util.EventListener
    • javax.net.ssl.HandshakeCompletedListener
    • javax.net.ssl.SSLSessionBindingListener
  • javax.net.ssl.HostnameVerifier
  • javax.net.ssl.KeyManager
    • javax.net.ssl.X509KeyManager
  • javax.net.ssl.ManagerFactoryParameters
  • javax.net.ssl.SSLSession
  • javax.net.ssl.SSLSessionContext
  • javax.net.ssl.TrustManager
    • javax.net.ssl.X509TrustManager

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.net.ssl.SSLEngineResult.Status
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l /v.//....=>ss n l.


KeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.net.ssl

Interface KeyManager

  • All Known Subinterfaces:
    X509KeyManager
    All Known Implementing Classes:
    X509ExtendedKeyManager

    public interface KeyManager
    This is the base interface for JSSE key managers.

    KeyManagers are responsible for managing the key material which is used to authenticate the local SSLSocket to its peer. If no key material is available, the socket will be unable to present authentication credentials.

    KeyManagers are created by either using a KeyManagerFactory, or by implementing one of the KeyManager subclasses.

    从以下版本开始：
    1.4
    另请参见：
    KeyManagerFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Hnt//.=..=f""=ffah""<<3hhh/>


KeyManagerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 KeyManagerFactory

  • java.lang.Object
    • javax.net.ssl.KeyManagerFactory

  • public class KeyManagerFactory
extends Object
    This class acts as a factory for key managers based on a source of key material. Each key manager manages a specific type of key material for use by secure sockets. The key material is based on a KeyStore and/or provider specific sources.
    从以下版本开始：
    1.4
    另请参见：
    KeyManager

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
      Creates a KeyManagerFactory object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAlgorithm()
      Returns the algorithm name of this KeyManagerFactory object.
      static String getDefaultAlgorithm()
      Obtains the default KeyManagerFactory algorithm name.
      static KeyManagerFactory getInstance(String algorithm)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
      static KeyManagerFactory getInstance(String algorithm, Provider provider)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
      static KeyManagerFactory getInstance(String algorithm, String provider)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
      KeyManager[] getKeyManagers()
      Returns one key manager for each type of key material.
      Provider getProvider()
      Returns the provider of this KeyManagerFactory object.
      void init(KeyStore ks, char[] password)
      Initializes this factory with a source of key material.
      void init(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific key material.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyManagerFactory

        protected KeyManagerFactory(KeyManagerFactorySpi factorySpi,
                 Provider provider,
                 String algorithm)
        Creates a KeyManagerFactory object.
        参数：
        factorySpi - the delegate
        provider - the provider
        algorithm - the algorithm

    • 方法详细信息

      • getDefaultAlgorithm

        public static final String getDefaultAlgorithm()
        Obtains the default KeyManagerFactory algorithm name.

        The default algorithm can be changed at runtime by setting the value of the "ssl.KeyManagerFactory.algorithm" security property (set in the Java security properties file or by calling Security.setProperty(java.lang.String, java.lang.String)) to the desired algorithm name.

        返回：
        the default algorithm name as specified in the Java security properties, or an implementation-specific default if no such property exists.
        另请参见：
        Security.setProperty(java.lang.String, java.lang.String)

      • getAlgorithm

        public final String getAlgorithm()
        Returns the algorithm name of this KeyManagerFactory object.

        This is the same name that was specified in one of the getInstance calls that created this KeyManagerFactory object.

        返回：
        the algorithm name of this KeyManagerFactory object.

      • getInstance

        public static final KeyManagerFactory getInstance(String algorithm)
                                           throws NoSuchAlgorithmException
        Returns a KeyManagerFactory object that acts as a factory for key managers.

        This method traverses the list of registered security Providers, starting with the most preferred Provider. A new KeyManagerFactory object encapsulating the KeyManagerFactorySpi implementation from the first Provider that supports the specified algorithm is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the standard name of the requested algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        返回：
        the new KeyManagerFactory object.
        抛出：
        NoSuchAlgorithmException - if no Provider supports a KeyManagerFactorySpi implementation for the specified algorithm.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getInstance

        public static final KeyManagerFactory getInstance(String algorithm,
                            String provider)
                                           throws NoSuchAlgorithmException,
                                                  NoSuchProviderException
        Returns a KeyManagerFactory object that acts as a factory for key managers.

        A new KeyManagerFactory object encapsulating the KeyManagerFactorySpi implementation from the specified provider is returned. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the standard name of the requested algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        provider - the name of the provider.
        返回：
        the new KeyManagerFactory object.
        抛出：
        NoSuchAlgorithmException - if a KeyManagerFactorySpi implementation for the specified algorithm is not available from the specified provider.
        NoSuchProviderException - if the specified provider is not registered in the security provider list.
        IllegalArgumentException - if the provider name is null or empty.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getInstance

        public static final KeyManagerFactory getInstance(String algorithm,
                            Provider provider)
                                           throws NoSuchAlgorithmException
        Returns a KeyManagerFactory object that acts as a factory for key managers.

        A new KeyManagerFactory object encapsulating the KeyManagerFactorySpi implementation from the specified Provider object is returned. Note that the specified Provider object does not have to be registered in the provider list.

        参数：
        algorithm - the standard name of the requested algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        provider - an instance of the provider.
        返回：
        the new KeyManagerFactory object.
        抛出：
        NoSuchAlgorithmException - if a KeyManagerFactorySpi implementation for the specified algorithm is not available from the specified Provider object.
        IllegalArgumentException - if provider is null.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider()
        Returns the provider of this KeyManagerFactory object.
        返回：
        the provider of this KeyManagerFactory object

      • init

        public final void init(KeyStore ks,
        char[] password)
                throws KeyStoreException,
                       NoSuchAlgorithmException,
                       UnrecoverableKeyException
        Initializes this factory with a source of key material.

        The provider typically uses a KeyStore for obtaining key material for use during secure socket negotiations. The KeyStore is generally password-protected.

        For more flexible initialization, please see init(ManagerFactoryParameters).

        参数：
        ks - the key store or null
        password - the password for recovering keys in the KeyStore
        抛出：
        KeyStoreException - if this operation fails
        NoSuchAlgorithmException - if the specified algorithm is not available from the specified provider.
        UnrecoverableKeyException - if the key cannot be recovered (e.g. the given password is wrong).

      • init

        public final void init(ManagerFactoryParameters spec)
                throws InvalidAlgorithmParameterException
        Initializes this factory with a source of provider-specific key material.

        In some cases, initialization parameters other than a keystore and password may be needed by a provider. Users of that particular provider are expected to pass an implementation of the appropriate ManagerFactoryParameters as defined by the provider. The provider can then call the specified methods in the ManagerFactoryParameters implementation to obtain the needed information.

        参数：
        spec - an implementation of a provider-specific parameter specification
        抛出：
        InvalidAlgorithmParameterException - if an error is encountered

      • getKeyManagers

        public final KeyManager[] getKeyManagers()
        Returns one key manager for each type of key material.
        返回：
        the key managers
        抛出：
        IllegalStateException - if the KeyManagerFactory is not initialized
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

to1eta>ast i�


KeyManagerFactorySpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 KeyManagerFactorySpi

  • java.lang.Object
    • javax.net.ssl.KeyManagerFactorySpi

  • public abstract class KeyManagerFactorySpi
extends Object
    This class defines the Service Provider Interface (SPI) for the KeyManagerFactory class.

    All the abstract methods in this class must be implemented by each cryptographic service provider who wishes to supply the implementation of a particular key manager factory.

    从以下版本开始：
    1.4
    另请参见：
    KeyManagerFactory, KeyManager

    • 构造方法摘要

      Constructors
      构造方法与描述
      KeyManagerFactorySpi()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract KeyManager[] engineGetKeyManagers()
      Returns one key manager for each type of key material.
      protected abstract void engineInit(KeyStore ks, char[] password)
      Initializes this factory with a source of key material.
      protected abstract void engineInit(ManagerFactoryParameters spec)
      Initializes this factory with a source of key material.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyManagerFactorySpi

        public KeyManagerFactorySpi()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit(KeyStore ks,
              char[] password)
                            throws KeyStoreException,
                                   NoSuchAlgorithmException,
                                   UnrecoverableKeyException
        Initializes this factory with a source of key material.
        参数：
        ks - the key store or null
        password - the password for recovering keys
        抛出：
        KeyStoreException - if this operation fails
        NoSuchAlgorithmException - if the specified algorithm is not available from the specified provider.
        UnrecoverableKeyException - if the key cannot be recovered
        另请参见：
        KeyManagerFactory.init(KeyStore, char[])

      • engineInit

        protected abstract void engineInit(ManagerFactoryParameters spec)
                            throws InvalidAlgorithmParameterException
        Initializes this factory with a source of key material.

        In some cases, initialization parameters other than a keystore and password may be needed by a provider. Users of that particular provider are expected to pass an implementation of the appropriate ManagerFactoryParameters as defined by the provider. The provider can then call the specified methods in the ManagerFactoryParameters implementation to obtain the needed information.

        参数：
        spec - an implementation of a provider-specific parameter specification
        抛出：
        InvalidAlgorithmParameterException - if there is problem with the parameters
        另请参见：
        KeyManagerFactory.init(ManagerFactoryParameters spec)

      • engineGetKeyManagers

        protected abstract KeyManager[] engineGetKeyManagers()
        Returns one key manager for each type of key material.
        返回：
        the key managers
        抛出：
        IllegalStateException - if the KeyManagerFactorySpi is not initialized
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e i>lcalcprrySruPttyirosdeess


KeyStoreBuilderParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 KeyStoreBuilderParameters

  • java.lang.Object
    • javax.net.ssl.KeyStoreBuilderParameters
  • 所有已实现的接口：
    ManagerFactoryParameters

    public class KeyStoreBuilderParameters
extends Object
implements ManagerFactoryParameters
    A parameters object for X509KeyManagers that encapsulates a List of KeyStore.Builders.
    从以下版本开始：
    1.5
    另请参见：
    KeyStore.Builder, X509KeyManager

    • 构造方法摘要

      Constructors
      构造方法与描述
      KeyStoreBuilderParameters(KeyStore.Builder builder)
      Construct new KeyStoreBuilderParameters from the specified KeyStore.Builder.
      KeyStoreBuilderParameters(List<KeyStore.Builder> parameters)
      Construct new KeyStoreBuilderParameters from a List of KeyStore.Builders.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List<KeyStore.Builder> getParameters()
      Return the unmodifiable List of the KeyStore.Builders encapsulated by this object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyStoreBuilderParameters

        public KeyStoreBuilderParameters(KeyStore.Builder builder)
        Construct new KeyStoreBuilderParameters from the specified KeyStore.Builder.
        参数：
        builder - the Builder object
        抛出：
        NullPointerException - if builder is null

      • KeyStoreBuilderParameters

        public KeyStoreBuilderParameters(List<KeyStore.Builder> parameters)
        Construct new KeyStoreBuilderParameters from a List of KeyStore.Builders. Note that the list is cloned to protect against subsequent modification.
        参数：
        parameters - the List of Builder objects
        抛出：
        NullPointerException - if parameters is null
        IllegalArgumentException - if parameters is an empty list

    • 方法详细信息

      • getParameters

        public List<KeyStore.Builder> getParameters()
        Return the unmodifiable List of the KeyStore.Builders encapsulated by this object.
        返回：
        the unmodifiable List of the KeyStore.Builders encapsulated by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


ManagerFactoryParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.net.ssl

Interface ManagerFactoryParameters

  • All Known Implementing Classes:
    CertPathTrustManagerParameters, KeyStoreBuilderParameters

    public interface ManagerFactoryParameters
    This class is the base interface for providing algorithm-specific information to a KeyManagerFactory or TrustManagerFactory.

    In some cases, initialization parameters other than keystores may be needed by a provider. Users of that particular provider are expected to pass an implementation of the appropriate sub-interface of this class as defined by the provider. The provider can then call the specified methods in the ManagerFactoryParameters implementation to obtain the needed information.

    从以下版本开始：
    1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ln/v/......//...ro""icj /d.


SSLContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLContext

  • java.lang.Object
    • javax.net.ssl.SSLContext

  • public class SSLContext
extends Object
    Instances of this class represent a secure socket protocol implementation which acts as a factory for secure socket factories or SSLEngines. This class is initialized with an optional set of key and trust managers and source of secure random bytes.

    Every implementation of the Java platform is required to support the following standard SSLContext protocol:

    • TLSv1
    This protocol is described in the SSLContext section of the Java Cryptography Architecture Standard Algorithm Name Documentation. Consult the release documentation for your implementation to see if any other algorithms are supported.
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
      Creates an SSLContext object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SSLEngine createSSLEngine()
      Creates a new SSLEngine using this context.
      SSLEngine createSSLEngine(String peerHost, int peerPort)
      Creates a new SSLEngine using this context using advisory peer information.
      SSLSessionContext getClientSessionContext()
      Returns the client session context, which represents the set of SSL sessions available for use during the handshake phase of client-side SSL sockets.
      static SSLContext getDefault()
      Returns the default SSL context.
      SSLParameters getDefaultSSLParameters()
      Returns a copy of the SSLParameters indicating the default settings for this SSL context.
      static SSLContext getInstance(String protocol)
      Returns a SSLContext object that implements the specified secure socket protocol.
      static SSLContext getInstance(String protocol, Provider provider)
      Returns a SSLContext object that implements the specified secure socket protocol.
      static SSLContext getInstance(String protocol, String provider)
      Returns a SSLContext object that implements the specified secure socket protocol.
      String getProtocol()
      Returns the protocol name of this SSLContext object.
      Provider getProvider()
      Returns the provider of this SSLContext object.
      SSLSessionContext getServerSessionContext()
      Returns the server session context, which represents the set of SSL sessions available for use during the handshake phase of server-side SSL sockets.
      SSLServerSocketFactory getServerSocketFactory()
      Returns a ServerSocketFactory object for this context.
      SSLSocketFactory getSocketFactory()
      Returns a SocketFactory object for this context.
      SSLParameters getSupportedSSLParameters()
      Returns a copy of the SSLParameters indicating the supported settings for this SSL context.
      void init(KeyManager[] km, TrustManager[] tm, SecureRandom random)
      Initializes this context.
      static void setDefault(SSLContext context)
      Sets the default SSL context.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLContext

        protected SSLContext(SSLContextSpi contextSpi,
          Provider provider,
          String protocol)
        Creates an SSLContext object.
        参数：
        contextSpi - the delegate
        provider - the provider
        protocol - the protocol

    • 方法详细信息

      • getDefault

        public static SSLContext getDefault()
                             throws NoSuchAlgorithmException
        Returns the default SSL context.

        If a default context was set using the SSLContext.setDefault() method, it is returned. Otherwise, the first call of this method triggers the call SSLContext.getInstance("Default"). If successful, that object is made the default SSL context and returned.

        The default context is immediately usable and does not require initialization.

        返回：
        the default SSL context
        抛出：
        NoSuchAlgorithmException - if the SSLContext.getInstance() call fails
        从以下版本开始：
        1.6

      • setDefault

        public static void setDefault(SSLContext context)
        Sets the default SSL context. It will be returned by subsequent calls to getDefault(). The default context must be immediately usable and not require initialization.
        参数：
        context - the SSLContext
        抛出：
        NullPointerException - if context is null
        SecurityException - if a security manager exists and its checkPermission method does not allow SSLPermission("setDefaultSSLContext")
        从以下版本开始：
        1.6

      • getInstance

        public static SSLContext getInstance(String protocol)
                              throws NoSuchAlgorithmException
        Returns a SSLContext object that implements the specified secure socket protocol.

        This method traverses the list of registered security Providers, starting with the most preferred Provider. A new SSLContext object encapsulating the SSLContextSpi implementation from the first Provider that supports the specified protocol is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        protocol - the standard name of the requested protocol. See the SSLContext section in the Java Cryptography Architecture Standard Algorithm Name Documentation for information about standard protocol names.
        返回：
        the new SSLContext object.
        抛出：
        NoSuchAlgorithmException - if no Provider supports a TrustManagerFactorySpi implementation for the specified protocol.
        NullPointerException - if protocol is null.
        另请参见：
        Provider

      • getInstance

        public static SSLContext getInstance(String protocol,
                     String provider)
                              throws NoSuchAlgorithmException,
                                     NoSuchProviderException
        Returns a SSLContext object that implements the specified secure socket protocol.

        A new SSLContext object encapsulating the SSLContextSpi implementation from the specified provider is returned. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        protocol - the standard name of the requested protocol. See the SSLContext section in the Java Cryptography Architecture Standard Algorithm Name Documentation for information about standard protocol names.
        provider - the name of the provider.
        返回：
        the new SSLContext object.
        抛出：
        NoSuchAlgorithmException - if a SSLContextSpi implementation for the specified protocol is not available from the specified provider.
        NoSuchProviderException - if the specified provider is not registered in the security provider list.
        IllegalArgumentException - if the provider name is null or empty.
        NullPointerException - if protocol is null.
        另请参见：
        Provider

      • getInstance

        public static SSLContext getInstance(String protocol,
                     Provider provider)
                              throws NoSuchAlgorithmException
        Returns a SSLContext object that implements the specified secure socket protocol.

        A new SSLContext object encapsulating the SSLContextSpi implementation from the specified Provider object is returned. Note that the specified Provider object does not have to be registered in the provider list.

        参数：
        protocol - the standard name of the requested protocol. See the SSLContext section in the Java Cryptography Architecture Standard Algorithm Name Documentation for information about standard protocol names.
        provider - an instance of the provider.
        返回：
        the new SSLContext object.
        抛出：
        NoSuchAlgorithmException - if a KeyManagerFactorySpi implementation for the specified protocol is not available from the specified Provider object.
        IllegalArgumentException - if the provider name is null.
        NullPointerException - if protocol is null.
        另请参见：
        Provider

      • getProtocol

        public final String getProtocol()
        Returns the protocol name of this SSLContext object.

        This is the same name that was specified in one of the getInstance calls that created this SSLContext object.

        返回：
        the protocol name of this SSLContext object.

      • getProvider

        public final Provider getProvider()
        Returns the provider of this SSLContext object.
        返回：
        the provider of this SSLContext object

      • init

        public final void init(KeyManager[] km,
        TrustManager[] tm,
        SecureRandom random)
                throws KeyManagementException
        Initializes this context. Either of the first two parameters may be null in which case the installed security providers will be searched for the highest priority implementation of the appropriate factory. Likewise, the secure random parameter may be null in which case the default implementation will be used.

        Only the first instance of a particular key and/or trust manager implementation type in the array is used. (For example, only the first javax.net.ssl.X509KeyManager in the array will be used.)

        参数：
        km - the sources of authentication keys or null
        tm - the sources of peer authentication trust decisions or null
        random - the source of randomness for this generator or null
        抛出：
        KeyManagementException - if this operation fails

      • getSocketFactory

        public final SSLSocketFactory getSocketFactory()
        Returns a SocketFactory object for this context.
        返回：
        the SocketFactory object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the init() has not been called

      • getServerSocketFactory

        public final SSLServerSocketFactory getServerSocketFactory()
        Returns a ServerSocketFactory object for this context.
        返回：
        the ServerSocketFactory object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the init() has not been called

      • createSSLEngine

        public final SSLEngine createSSLEngine()
        Creates a new SSLEngine using this context.

        Applications using this factory method are providing no hints for an internal session reuse strategy. If hints are desired, createSSLEngine(String, int) should be used instead.

        Some cipher suites (such as Kerberos) require remote hostname information, in which case this factory method should not be used.

        返回：
        the SSLEngine object
        抛出：
        UnsupportedOperationException - if the underlying provider does not implement the operation.
        IllegalStateException - if the SSLContextImpl requires initialization and the init() has not been called
        从以下版本开始：
        1.5

      • createSSLEngine

        public final SSLEngine createSSLEngine(String peerHost,
                        int peerPort)
        Creates a new SSLEngine using this context using advisory peer information.

        Applications using this factory method are providing hints for an internal session reuse strategy.

        Some cipher suites (such as Kerberos) require remote hostname information, in which case peerHost needs to be specified.

        参数：
        peerHost - the non-authoritative name of the host
        peerPort - the non-authoritative port
        返回：
        the new SSLEngine object
        抛出：
        UnsupportedOperationException - if the underlying provider does not implement the operation.
        IllegalStateException - if the SSLContextImpl requires initialization and the init() has not been called
        从以下版本开始：
        1.5

      • getServerSessionContext

        public final SSLSessionContext getServerSessionContext()
        Returns the server session context, which represents the set of SSL sessions available for use during the handshake phase of server-side SSL sockets.

        This context may be unavailable in some environments, in which case this method returns null. For example, when the underlying SSL provider does not provide an implementation of SSLSessionContext interface, this method returns null. A non-null session context is returned otherwise.

        返回：
        server session context bound to this SSL context

      • getClientSessionContext

        public final SSLSessionContext getClientSessionContext()
        Returns the client session context, which represents the set of SSL sessions available for use during the handshake phase of client-side SSL sockets.

        This context may be unavailable in some environments, in which case this method returns null. For example, when the underlying SSL provider does not provide an implementation of SSLSessionContext interface, this method returns null. A non-null session context is returned otherwise.

        返回：
        client session context bound to this SSL context

      • getDefaultSSLParameters

        public final SSLParameters getDefaultSSLParameters()
        Returns a copy of the SSLParameters indicating the default settings for this SSL context.

        The parameters will always have the ciphersuites and protocols arrays set to non-null values.

        返回：
        a copy of the SSLParameters object with the default settings
        抛出：
        UnsupportedOperationException - if the default SSL parameters could not be obtained.
        从以下版本开始：
        1.6

      • getSupportedSSLParameters

        public final SSLParameters getSupportedSSLParameters()
        Returns a copy of the SSLParameters indicating the supported settings for this SSL context.

        The parameters will always have the ciphersuites and protocols arrays set to non-null values.

        返回：
        a copy of the SSLParameters object with the supported settings
        抛出：
        UnsupportedOperationException - if the supported SSL parameters could not be obtained.
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SSLContextSpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLContextSpi

  • java.lang.Object
    • javax.net.ssl.SSLContextSpi

  • public abstract class SSLContextSpi
extends Object
    This class defines the Service Provider Interface (SPI) for the SSLContext class.

    All the abstract methods in this class must be implemented by each cryptographic service provider who wishes to supply the implementation of a particular SSL context.

    从以下版本开始：
    1.4
    另请参见：
    SSLContext

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLContextSpi()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract SSLEngine engineCreateSSLEngine()
      Creates a new SSLEngine using this context.
      protected abstract SSLEngine engineCreateSSLEngine(String host, int port)
      Creates a SSLEngine using this context.
      protected abstract SSLSessionContext engineGetClientSessionContext()
      Returns a client SSLSessionContext object for this context.
      protected SSLParameters engineGetDefaultSSLParameters()
      Returns a copy of the SSLParameters indicating the default settings for this SSL context.
      protected abstract SSLSessionContext engineGetServerSessionContext()
      Returns a server SSLSessionContext object for this context.
      protected abstract SSLServerSocketFactory engineGetServerSocketFactory()
      Returns a ServerSocketFactory object for this context.
      protected abstract SSLSocketFactory engineGetSocketFactory()
      Returns a SocketFactory object for this context.
      protected SSLParameters engineGetSupportedSSLParameters()
      Returns a copy of the SSLParameters indicating the maximum supported settings for this SSL context.
      protected abstract void engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr)
      Initializes this context.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLContextSpi

        public SSLContextSpi()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit(KeyManager[] km,
              TrustManager[] tm,
              SecureRandom sr)
                            throws KeyManagementException
        Initializes this context.
        参数：
        km - the sources of authentication keys
        tm - the sources of peer authentication trust decisions
        sr - the source of randomness
        抛出：
        KeyManagementException - if this operation fails
        另请参见：
        SSLContext.init(KeyManager [], TrustManager [], SecureRandom)

      • engineGetSocketFactory

        protected abstract SSLSocketFactory engineGetSocketFactory()
        Returns a SocketFactory object for this context.
        返回：
        the SocketFactory object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the engineInit() has not been called
        另请参见：
        SSLContext.getSocketFactory()

      • engineGetServerSocketFactory

        protected abstract SSLServerSocketFactory engineGetServerSocketFactory()
        Returns a ServerSocketFactory object for this context.
        返回：
        the ServerSocketFactory object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the engineInit() has not been called
        另请参见：
        SSLContext.getServerSocketFactory()

      • engineCreateSSLEngine

        protected abstract SSLEngine engineCreateSSLEngine()
        Creates a new SSLEngine using this context.

        Applications using this factory method are providing no hints for an internal session reuse strategy. If hints are desired, engineCreateSSLEngine(String, int) should be used instead.

        Some cipher suites (such as Kerberos) require remote hostname information, in which case this factory method should not be used.

        返回：
        the SSLEngine Object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the engineInit() has not been called
        从以下版本开始：
        1.5
        另请参见：
        SSLContext.createSSLEngine()

      • engineCreateSSLEngine

        protected abstract SSLEngine engineCreateSSLEngine(String host,
                              int port)
        Creates a SSLEngine using this context.

        Applications using this factory method are providing hints for an internal session reuse strategy.

        Some cipher suites (such as Kerberos) require remote hostname information, in which case peerHost needs to be specified.

        参数：
        host - the non-authoritative name of the host
        port - the non-authoritative port
        返回：
        the SSLEngine Object
        抛出：
        IllegalStateException - if the SSLContextImpl requires initialization and the engineInit() has not been called
        从以下版本开始：
        1.5
        另请参见：
        SSLContext.createSSLEngine(String, int)

      • engineGetServerSessionContext

        protected abstract SSLSessionContext engineGetServerSessionContext()
        Returns a server SSLSessionContext object for this context.
        返回：
        the SSLSessionContext object
        另请参见：
        SSLContext.getServerSessionContext()

      • engineGetClientSessionContext

        protected abstract SSLSessionContext engineGetClientSessionContext()
        Returns a client SSLSessionContext object for this context.
        返回：
        the SSLSessionContext object
        另请参见：
        SSLContext.getClientSessionContext()

      • engineGetDefaultSSLParameters

        protected SSLParameters engineGetDefaultSSLParameters()
        Returns a copy of the SSLParameters indicating the default settings for this SSL context.

        The parameters will always have the ciphersuite and protocols arrays set to non-null values.

        The default implementation obtains the parameters from an SSLSocket created by calling the SocketFactory.createSocket() method of this context's SocketFactory.

        返回：
        a copy of the SSLParameters object with the default settings
        抛出：
        UnsupportedOperationException - if the default SSL parameters could not be obtained.
        从以下版本开始：
        1.6

      • engineGetSupportedSSLParameters

        protected SSLParameters engineGetSupportedSSLParameters()
        Returns a copy of the SSLParameters indicating the maximum supported settings for this SSL context.

        The parameters will always have the ciphersuite and protocols arrays set to non-null values.

        The default implementation obtains the parameters from an SSLSocket created by calling the SocketFactory.createSocket() method of this context's SocketFactory.

        返回：
        a copy of the SSLParameters object with the maximum supported settings
        抛出：
        UnsupportedOperationException - if the supported SSL parameters could not be obtained.
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tj= ittithmmthhii..asniallan/pa;<< l= /


SSLEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLEngine

  • java.lang.Object
    • javax.net.ssl.SSLEngine

  • public abstract class SSLEngine
extends Object
    A class which enables secure communications using protocols such as the Secure Sockets Layer (SSL) or IETF RFC 2246 "Transport Layer Security" (TLS) protocols, but is transport independent.

    The secure communications modes include:

    • Integrity Protection. SSL/TLS protects against modification of messages by an active wiretapper.
    • Authentication. In most modes, SSL/TLS provides peer authentication. Servers are usually authenticated, and clients may be authenticated as requested by servers.
    • Confidentiality (Privacy Protection). In most modes, SSL/TLS encrypts data being sent between client and server. This protects the confidentiality of data, so that passive wiretappers won't see sensitive data such as financial information or personal information of many kinds.
    These kinds of protection are specified by a "cipher suite", which is a combination of cryptographic algorithms used by a given SSL connection. During the negotiation process, the two endpoints must agree on a cipher suite that is available in both environments. If there is no such suite in common, no SSL connection can be established, and no data can be exchanged.

    The cipher suite used is established by a negotiation process called "handshaking". The goal of this process is to create or rejoin a "session", which may protect many connections over time. After handshaking has completed, you can access session attributes by using the getSession() method.

    The SSLSocket class provides much of the same security functionality, but all of the inbound and outbound data is automatically transported using the underlying Socket, which by design uses a blocking model. While this is appropriate for many applications, this model does not provide the scalability required by large servers.

    The primary distinction of an SSLEngine is that it operates on inbound and outbound byte streams, independent of the transport mechanism. It is the responsibility of the SSLEngine user to arrange for reliable I/O transport to the peer. By separating the SSL/TLS abstraction from the I/O transport mechanism, the SSLEngine can be used for a wide variety of I/O types, such as non-blocking I/O (polling), selectable non-blocking I/O, Socket and the traditional Input/OutputStreams, local ByteBuffers or byte arrays, future asynchronous I/O models , and so on.

    At a high level, the SSLEngine appears thus:

                       app data

                |           ^
                |     |     |
                v     |     |
           +----+-----|-----+----+
           |          |          |
           |       SSL|Engine    |
   wrap()  |          |          |  unwrap()
           | OUTBOUND | INBOUND  |
           |          |          |
           +----+-----|-----+----+
                |     |     ^
                |     |     |
                v           |

                   net data
    Application data (also known as plaintext or cleartext) is data which is produced or consumed by an application. Its counterpart is network data, which consists of either handshaking and/or ciphertext (encrypted) data, and destined to be transported via an I/O mechanism. Inbound data is data which has been received from the peer, and outbound data is destined for the peer.

    (In the context of an SSLEngine, the term "handshake data" is taken to mean any data exchanged to establish and control a secure connection. Handshake data includes the SSL/TLS messages "alert", "change_cipher_spec," and "handshake.")

    There are five distinct phases to an SSLEngine.

    1. Creation - The SSLEngine has been created and initialized, but has not yet been used. During this phase, an application may set any SSLEngine-specific settings (enabled cipher suites, whether the SSLEngine should handshake in client or server mode, and so on). Once handshaking has begun, though, any new settings (except client/server mode, see below) will be used for the next handshake.
    2. Initial Handshake - The initial handshake is a procedure by which the two peers exchange communication parameters until an SSLSession is established. Application data can not be sent during this phase.
    3. Application Data - Once the communication parameters have been established and the handshake is complete, application data may flow through the SSLEngine. Outbound application messages are encrypted and integrity protected, and inbound messages reverse the process.
    4. Rehandshaking - Either side may request a renegotiation of the session at any time during the Application Data phase. New handshaking data can be intermixed among the application data. Before starting the rehandshake phase, the application may reset the SSL/TLS communication parameters such as the list of enabled ciphersuites and whether to use client authentication, but can not change between client/server modes. As before, once handshaking has begun, any new SSLEngine configuration settings will not be used until the next handshake.
    5. Closure - When the connection is no longer needed, the application should close the SSLEngine and should send/receive any remaining messages to the peer before closing the underlying transport mechanism. Once an engine is closed, it is not reusable: a new SSLEngine must be created.
    An SSLEngine is created by calling SSLContext.createSSLEngine() from an initialized SSLContext. Any configuration parameters should be set before making the first call to wrap(), unwrap(), or beginHandshake(). These methods all trigger the initial handshake.

    Data moves through the engine by calling wrap() or unwrap() on outbound or inbound data, respectively. Depending on the state of the SSLEngine, a wrap() call may consume application data from the source buffer and may produce network data in the destination buffer. The outbound data may contain application and/or handshake data. A call to unwrap() will examine the source buffer and may advance the handshake if the data is handshaking information, or may place application data in the destination buffer if the data is application. The state of the underlying SSL/TLS algorithm will determine when data is consumed and produced.

    Calls to wrap() and unwrap() return an SSLEngineResult which indicates the status of the operation, and (optionally) how to interact with the engine to make progress.

    The SSLEngine produces/consumes complete SSL/TLS packets only, and does not store application data internally between calls to wrap()/unwrap(). Thus input and output ByteBuffers must be sized appropriately to hold the maximum record that can be produced. Calls to SSLSession.getPacketBufferSize() and SSLSession.getApplicationBufferSize() should be used to determine the appropriate buffer sizes. The size of the outbound application data buffer generally does not matter. If buffer conditions do not allow for the proper consumption/production of data, the application must determine (via SSLEngineResult) and correct the problem, and then try the call again.

    For example, unwrap() will return a SSLEngineResult.Status.BUFFER_OVERFLOW result if the engine determines that there is not enough destination buffer space available. Applications should call SSLSession.getApplicationBufferSize() and compare that value with the space available in the destination buffer, enlarging the buffer if necessary. Similarly, if unwrap() were to return a SSLEngineResult.Status.BUFFER_UNDERFLOW, the application should call SSLSession.getPacketBufferSize() to ensure that the source buffer has enough room to hold a record (enlarging if necessary), and then obtain more inbound data.

       SSLEngineResult r = engine.unwrap(src, dst);
   switch (r.getStatus()) {
   BUFFER_OVERFLOW:
       // Could attempt to drain the dst buffer of any already obtained
       // data, but we'll just increase it to the size needed.
       int appSize = engine.getSession().getApplicationBufferSize();
       ByteBuffer b = ByteBuffer.allocate(appSize + dst.position());
       dst.flip();
       b.put(dst);
       dst = b;
       // retry the operation.
       break;
   BUFFER_UNDERFLOW:
       int netSize = engine.getSession().getPacketBufferSize();
       // Resize buffer if needed.
       if (netSize > dst.capacity()) {
           ByteBuffer b = ByteBuffer.allocate(netSize);
           src.flip();
           b.put(src);
           src = b;
       }
       // Obtain more inbound network data for src,
       // then retry the operation.
       break;
   // other cases: CLOSED, OK.
   }

    Unlike SSLSocket, all methods of SSLEngine are non-blocking. SSLEngine implementations may require the results of tasks that may take an extended period of time to complete, or may even block. For example, a TrustManager may need to connect to a remote certificate validation service, or a KeyManager might need to prompt a user to determine which certificate to use as part of client authentication. Additionally, creating cryptographic signatures and verifying them can be slow, seemingly blocking.

    For any operation which may potentially block, the SSLEngine will create a Runnable delegated task. When SSLEngineResult indicates that a delegated task result is needed, the application must call getDelegatedTask() to obtain an outstanding delegated task and call its run() method (possibly using a different thread depending on the compute strategy). The application should continue obtaining delegated tasks until no more exist, and try the original operation again.

    At the end of a communication session, applications should properly close the SSL/TLS link. The SSL/TLS protocols have closure handshake messages, and these messages should be communicated to the peer before releasing the SSLEngine and closing the underlying transport mechanism. A close can be initiated by one of: an SSLException, an inbound closure handshake message, or one of the close methods. In all cases, closure handshake messages are generated by the engine, and wrap() should be repeatedly called until the resulting SSLEngineResult's status returns "CLOSED", or isOutboundDone() returns true. All data obtained from the wrap() method should be sent to the peer.

    closeOutbound() is used to signal the engine that the application will not be sending any more data.

    A peer will signal its intent to close by sending its own closure handshake message. After this message has been received and processed by the local SSLEngine's unwrap() call, the application can detect the close by calling unwrap() and looking for a SSLEngineResult with status "CLOSED", or if isInboundDone() returns true. If for some reason the peer closes the communication link without sending the proper SSL/TLS closure message, the application can detect the end-of-stream and can signal the engine via closeInbound() that there will no more inbound messages to process. Some applications might choose to require orderly shutdown messages from a peer, in which case they can check that the closure was generated by a handshake message and not by an end-of-stream condition.

    There are two groups of cipher suites which you will need to know about when managing cipher suites:

    • Supported cipher suites: all the suites which are supported by the SSL implementation. This list is reported using getSupportedCipherSuites().
    • Enabled cipher suites, which may be fewer than the full set of supported suites. This group is set using the setEnabledCipherSuites(String []) method, and queried using the getEnabledCipherSuites() method. Initially, a default set of cipher suites will be enabled on a new engine that represents the minimum suggested configuration.
    Implementation defaults require that only cipher suites which authenticate servers and provide confidentiality be enabled by default. Only if both sides explicitly agree to unauthenticated and/or non-private (unencrypted) communications will such a cipher suite be selected.

    Each SSL/TLS connection must have one client and one server, thus each endpoint must decide which role to assume. This choice determines who begins the handshaking process as well as which type of messages should be sent by each party. The method setUseClientMode(boolean) configures the mode. Once the initial handshaking has started, an SSLEngine can not switch between client and server modes, even when performing renegotiations.

    Applications might choose to process delegated tasks in different threads. When an SSLEngine is created, the current AccessControlContext is saved. All future delegated tasks will be processed using this context: that is, all access control decisions will be made using the context captured at engine creation.

    Concurrency Notes: There are two concurrency issues to be aware of:
    1. The wrap() and unwrap() methods may execute concurrently of each other.
    2. The SSL/TLS protocols employ ordered packets. Applications must take care to ensure that generated packets are delivered in sequence. If packets arrive out-of-order, unexpected or fatal results may occur.

      For example:

                    synchronized (outboundLock) {
                  sslEngine.wrap(src, dst);
                  outboundQueue.put(dst);
              }
      As a corollary, two threads must not attempt to call the same method (either wrap() or unwrap()) concurrently, because there is no way to guarantee the eventual packet ordering.
    从以下版本开始：
    1.5
    另请参见：
    SSLContext, SSLSocket, SSLServerSocket, SSLSession, Socket

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SSLEngine()
      Constructor for an SSLEngine providing no hints for an internal session reuse strategy.
      protected SSLEngine(String peerHost, int peerPort)
      Constructor for an SSLEngine.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void beginHandshake()
      Initiates handshaking (initial or renegotiation) on this SSLEngine.
      abstract void closeInbound()
      Signals that no more inbound network data will be sent to this SSLEngine.
      abstract void closeOutbound()
      Signals that no more outbound application data will be sent on this SSLEngine.
      abstract Runnable getDelegatedTask()
      Returns a delegated Runnable task for this SSLEngine.
      abstract String[] getEnabledCipherSuites()
      Returns the names of the SSL cipher suites which are currently enabled for use on this engine.
      abstract String[] getEnabledProtocols()
      Returns the names of the protocol versions which are currently enabled for use with this SSLEngine.
      abstract boolean getEnableSessionCreation()
      Returns true if new SSL sessions may be established by this engine.
      SSLSession getHandshakeSession()
      Returns the SSLSession being constructed during a SSL/TLS handshake.
      abstract SSLEngineResult.HandshakeStatus getHandshakeStatus()
      Returns the current handshake status for this SSLEngine.
      abstract boolean getNeedClientAuth()
      Returns true if the engine will require client authentication.
      String getPeerHost()
      Returns the host name of the peer.
      int getPeerPort()
      Returns the port number of the peer.
      abstract SSLSession getSession()
      Returns the SSLSession in use in this SSLEngine.
      SSLParameters getSSLParameters()
      Returns the SSLParameters in effect for this SSLEngine.
      abstract String[] getSupportedCipherSuites()
      Returns the names of the cipher suites which could be enabled for use on this engine.
      abstract String[] getSupportedProtocols()
      Returns the names of the protocols which could be enabled for use with this SSLEngine.
      abstract boolean getUseClientMode()
      Returns true if the engine is set to use client mode when handshaking.
      abstract boolean getWantClientAuth()
      Returns true if the engine will request client authentication.
      abstract boolean isInboundDone()
      Returns whether unwrap(ByteBuffer, ByteBuffer) will accept any more inbound data messages.
      abstract boolean isOutboundDone()
      Returns whether wrap(ByteBuffer, ByteBuffer) will produce any more outbound data messages.
      abstract void setEnabledCipherSuites(String[] suites)
      Sets the cipher suites enabled for use on this engine.
      abstract void setEnabledProtocols(String[] protocols)
      Set the protocol versions enabled for use on this engine.
      abstract void setEnableSessionCreation(boolean flag)
      Controls whether new SSL sessions may be established by this engine.
      abstract void setNeedClientAuth(boolean need)
      Configures the engine to require client authentication.
      void setSSLParameters(SSLParameters params)
      Applies SSLParameters to this engine.
      abstract void setUseClientMode(boolean mode)
      Configures the engine to use client (or server) mode when handshaking.
      abstract void setWantClientAuth(boolean want)
      Configures the engine to request client authentication.
      SSLEngineResult unwrap(ByteBuffer src, ByteBuffer dst)
      Attempts to decode SSL/TLS network data into a plaintext application data buffer.
      SSLEngineResult unwrap(ByteBuffer src, ByteBuffer[] dsts)
      Attempts to decode SSL/TLS network data into a sequence of plaintext application data buffers.
      abstract SSLEngineResult unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length)
      Attempts to decode SSL/TLS network data into a subsequence of plaintext application data buffers.
      SSLEngineResult wrap(ByteBuffer[] srcs, ByteBuffer dst)
      Attempts to encode plaintext bytes from a sequence of data buffers into SSL/TLS network data.
      abstract SSLEngineResult wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst)
      Attempts to encode plaintext bytes from a subsequence of data buffers into SSL/TLS network data.
      SSLEngineResult wrap(ByteBuffer src, ByteBuffer dst)
      Attempts to encode a buffer of plaintext application data into SSL/TLS network data.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLEngine

        protected SSLEngine()
        Constructor for an SSLEngine providing no hints for an internal session reuse strategy.
        另请参见：
        SSLContext.createSSLEngine(), SSLSessionContext

      • SSLEngine

        protected SSLEngine(String peerHost,
         int peerPort)
        Constructor for an SSLEngine.

        SSLEngine implementations may use the peerHost and peerPort parameters as hints for their internal session reuse strategy.

        Some cipher suites (such as Kerberos) require remote hostname information. Implementations of this class should use this constructor to use Kerberos.

        The parameters are not authenticated by the SSLEngine.

        参数：
        peerHost - the name of the peer host
        peerPort - the port number of the peer
        另请参见：
        SSLContext.createSSLEngine(String, int), SSLSessionContext

    • 方法详细信息

      • getPeerHost

        public String getPeerHost()
        Returns the host name of the peer.

        Note that the value is not authenticated, and should not be relied upon.

        返回：
        the host name of the peer, or null if nothing is available.

      • getPeerPort

        public int getPeerPort()
        Returns the port number of the peer.

        Note that the value is not authenticated, and should not be relied upon.

        返回：
        the port number of the peer, or -1 if nothing is available.

      • wrap

        public SSLEngineResult wrap(ByteBuffer src,
                   ByteBuffer dst)
                     throws SSLException
        Attempts to encode a buffer of plaintext application data into SSL/TLS network data.

        An invocation of this method behaves in exactly the same manner as the invocation:

         engine.wrap(new ByteBuffer [] { src }, 0, 1, dst);
        参数：
        src - a ByteBuffer containing outbound application data
        dst - a ByteBuffer to hold outbound network data
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        ReadOnlyBufferException - if the dst buffer is read-only.
        IllegalArgumentException - if either src or dst is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        wrap(ByteBuffer [], int, int, ByteBuffer)

      • wrap

        public SSLEngineResult wrap(ByteBuffer[] srcs,
                   ByteBuffer dst)
                     throws SSLException
        Attempts to encode plaintext bytes from a sequence of data buffers into SSL/TLS network data.

        An invocation of this method behaves in exactly the same manner as the invocation:

         engine.wrap(srcs, 0, srcs.length, dst);
        参数：
        srcs - an array of ByteBuffers containing the outbound application data
        dst - a ByteBuffer to hold outbound network data
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        ReadOnlyBufferException - if the dst buffer is read-only.
        IllegalArgumentException - if either srcs or dst is null, or if any element in srcs is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        wrap(ByteBuffer [], int, int, ByteBuffer)

      • wrap

        public abstract SSLEngineResult wrap(ByteBuffer[] srcs,
                   int offset,
                   int length,
                   ByteBuffer dst)
                              throws SSLException
        Attempts to encode plaintext bytes from a subsequence of data buffers into SSL/TLS network data. This "gathering" operation encodes, in a single invocation, a sequence of bytes from one or more of a given sequence of buffers. Gathering wraps are often useful when implementing network protocols or file formats that, for example, group data into segments consisting of one or more fixed-length headers followed by a variable-length body. See GatheringByteChannel for more information on gathering, and GatheringByteChannel.write(ByteBuffer[], int, int) for more information on the subsequence behavior.

        Depending on the state of the SSLEngine, this method may produce network data without consuming any application data (for example, it may generate handshake data.)

        The application is responsible for reliably transporting the network data to the peer, and for ensuring that data created by multiple calls to wrap() is transported in the same order in which it was generated. The application must properly synchronize multiple calls to this method.

        If this SSLEngine has not yet started its initial handshake, this method will automatically start the handshake.

        This method will attempt to produce one SSL/TLS packet, and will consume as much source data as possible, but will never consume more than the sum of the bytes remaining in each buffer. Each ByteBuffer's position is updated to reflect the amount of data consumed or produced. The limits remain the same.

        The underlying memory used by the srcs and dst ByteBuffers must not be the same.

        See the class description for more information on engine closure.

        参数：
        srcs - an array of ByteBuffers containing the outbound application data
        offset - The offset within the buffer array of the first buffer from which bytes are to be retrieved; it must be non-negative and no larger than srcs.length
        length - The maximum number of buffers to be accessed; it must be non-negative and no larger than srcs.length - offset
        dst - a ByteBuffer to hold outbound network data
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        IndexOutOfBoundsException - if the preconditions on the offset and length parameters do not hold.
        ReadOnlyBufferException - if the dst buffer is read-only.
        IllegalArgumentException - if either srcs or dst is null, or if any element in the srcs subsequence specified is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        GatheringByteChannel, GatheringByteChannel.write( ByteBuffer[], int, int)

      • unwrap

        public SSLEngineResult unwrap(ByteBuffer src,
                     ByteBuffer dst)
                       throws SSLException
        Attempts to decode SSL/TLS network data into a plaintext application data buffer.

        An invocation of this method behaves in exactly the same manner as the invocation:

         engine.unwrap(src, new ByteBuffer [] { dst }, 0, 1);
        参数：
        src - a ByteBuffer containing inbound network data.
        dst - a ByteBuffer to hold inbound application data.
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        ReadOnlyBufferException - if the dst buffer is read-only.
        IllegalArgumentException - if either src or dst is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        unwrap(ByteBuffer, ByteBuffer [], int, int)

      • unwrap

        public SSLEngineResult unwrap(ByteBuffer src,
                     ByteBuffer[] dsts)
                       throws SSLException
        Attempts to decode SSL/TLS network data into a sequence of plaintext application data buffers.

        An invocation of this method behaves in exactly the same manner as the invocation:

         engine.unwrap(src, dsts, 0, dsts.length);
        参数：
        src - a ByteBuffer containing inbound network data.
        dsts - an array of ByteBuffers to hold inbound application data.
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        ReadOnlyBufferException - if any of the dst buffers are read-only.
        IllegalArgumentException - if either src or dsts is null, or if any element in dsts is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        unwrap(ByteBuffer, ByteBuffer [], int, int)

      • unwrap

        public abstract SSLEngineResult unwrap(ByteBuffer src,
                     ByteBuffer[] dsts,
                     int offset,
                     int length)
                                throws SSLException
        Attempts to decode SSL/TLS network data into a subsequence of plaintext application data buffers. This "scattering" operation decodes, in a single invocation, a sequence of bytes into one or more of a given sequence of buffers. Scattering unwraps are often useful when implementing network protocols or file formats that, for example, group data into segments consisting of one or more fixed-length headers followed by a variable-length body. See ScatteringByteChannel for more information on scattering, and ScatteringByteChannel.read(ByteBuffer[], int, int) for more information on the subsequence behavior.

        Depending on the state of the SSLEngine, this method may consume network data without producing any application data (for example, it may consume handshake data.)

        The application is responsible for reliably obtaining the network data from the peer, and for invoking unwrap() on the data in the order it was received. The application must properly synchronize multiple calls to this method.

        If this SSLEngine has not yet started its initial handshake, this method will automatically start the handshake.

        This method will attempt to consume one complete SSL/TLS network packet, but will never consume more than the sum of the bytes remaining in the buffers. Each ByteBuffer's position is updated to reflect the amount of data consumed or produced. The limits remain the same.

        The underlying memory used by the src and dsts ByteBuffers must not be the same.

        The inbound network buffer may be modified as a result of this call: therefore if the network data packet is required for some secondary purpose, the data should be duplicated before calling this method. Note: the network data will not be useful to a second SSLEngine, as each SSLEngine contains unique random state which influences the SSL/TLS messages.

        See the class description for more information on engine closure.

        参数：
        src - a ByteBuffer containing inbound network data.
        dsts - an array of ByteBuffers to hold inbound application data.
        offset - The offset within the buffer array of the first buffer from which bytes are to be transferred; it must be non-negative and no larger than dsts.length.
        length - The maximum number of buffers to be accessed; it must be non-negative and no larger than dsts.length - offset.
        返回：
        an SSLEngineResult describing the result of this operation.
        抛出：
        SSLException - A problem was encountered while processing the data that caused the SSLEngine to abort. See the class description for more information on engine closure.
        IndexOutOfBoundsException - If the preconditions on the offset and length parameters do not hold.
        ReadOnlyBufferException - if any of the dst buffers are read-only.
        IllegalArgumentException - if either src or dsts is null, or if any element in the dsts subsequence specified is null.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        ScatteringByteChannel, ScatteringByteChannel.read( ByteBuffer[], int, int)

      • getDelegatedTask

        public abstract Runnable getDelegatedTask()
        Returns a delegated Runnable task for this SSLEngine.

        SSLEngine operations may require the results of operations that block, or may take an extended period of time to complete. This method is used to obtain an outstanding Runnable operation (task). Each task must be assigned a thread (possibly the current) to perform the run operation. Once the run method returns, the Runnable object is no longer needed and may be discarded.

        Delegated tasks run in the AccessControlContext in place when this object was created.

        A call to this method will return each outstanding task exactly once.

        Multiple delegated tasks can be run in parallel.

        返回：
        a delegated Runnable task, or null if none are available.

      • closeInbound

        public abstract void closeInbound()
                           throws SSLException
        Signals that no more inbound network data will be sent to this SSLEngine.

        If the application initiated the closing process by calling closeOutbound(), under some circumstances it is not required that the initiator wait for the peer's corresponding close message. (See section 7.2.1 of the TLS specification (RFC 2246) for more information on waiting for closure alerts.) In such cases, this method need not be called.

        But if the application did not initiate the closure process, or if the circumstances above do not apply, this method should be called whenever the end of the SSL/TLS data stream is reached. This ensures closure of the inbound side, and checks that the peer followed the SSL/TLS close procedure properly, thus detecting possible truncation attacks.

        This method is idempotent: if the inbound side has already been closed, this method does not do anything.

        wrap() should be called to flush any remaining handshake data.

        抛出：
        SSLException - if this engine has not received the proper SSL/TLS close notification message from the peer.
        另请参见：
        isInboundDone(), isOutboundDone()

      • isInboundDone

        public abstract boolean isInboundDone()
        Returns whether unwrap(ByteBuffer, ByteBuffer) will accept any more inbound data messages.
        返回：
        true if the SSLEngine will not consume anymore network data (and by implication, will not produce any more application data.)
        另请参见：
        closeInbound()

      • closeOutbound

        public abstract void closeOutbound()
        Signals that no more outbound application data will be sent on this SSLEngine.

        This method is idempotent: if the outbound side has already been closed, this method does not do anything.

        wrap(ByteBuffer, ByteBuffer) should be called to flush any remaining handshake data.

        另请参见：
        isOutboundDone()

      • isOutboundDone

        public abstract boolean isOutboundDone()
        Returns whether wrap(ByteBuffer, ByteBuffer) will produce any more outbound data messages.

        Note that during the closure phase, a SSLEngine may generate handshake closure data that must be sent to the peer. wrap() must be called to generate this data. When this method returns true, no more outbound data will be created.

        返回：
        true if the SSLEngine will not produce any more network data
        另请参见：
        closeOutbound(), closeInbound()

      • getSupportedCipherSuites

        public abstract String[] getSupportedCipherSuites()
        Returns the names of the cipher suites which could be enabled for use on this engine. Normally, only a subset of these will actually be enabled by default, since this list may include cipher suites which do not meet quality of service requirements for those defaults. Such cipher suites might be useful in specialized applications.
        返回：
        an array of cipher suite names
        另请参见：
        getEnabledCipherSuites(), setEnabledCipherSuites(String [])

      • getEnabledCipherSuites

        public abstract String[] getEnabledCipherSuites()
        Returns the names of the SSL cipher suites which are currently enabled for use on this engine. When an SSLEngine is first created, all enabled cipher suites support a minimum quality of service. Thus, in some environments this value might be empty.

        Even if a suite has been enabled, it might never be used. (For example, the peer does not support it, the requisite certificates/private keys for the suite are not available, or an anonymous suite is enabled but authentication is required.)

        返回：
        an array of cipher suite names
        另请参见：
        getSupportedCipherSuites(), setEnabledCipherSuites(String [])

      • setEnabledCipherSuites

        public abstract void setEnabledCipherSuites(String[] suites)
        Sets the cipher suites enabled for use on this engine.

        Each cipher suite in the suites parameter must have been listed by getSupportedCipherSuites(), or the method will fail. Following a successful call to this method, only suites listed in the suites parameter are enabled for use.

        See getEnabledCipherSuites() for more information on why a specific cipher suite may never be used on a engine.

        参数：
        suites - Names of all the cipher suites to enable
        抛出：
        IllegalArgumentException - when one or more of the ciphers named by the parameter is not supported, or when the parameter is null.
        另请参见：
        getSupportedCipherSuites(), getEnabledCipherSuites()

      • getSupportedProtocols

        public abstract String[] getSupportedProtocols()
        Returns the names of the protocols which could be enabled for use with this SSLEngine.
        返回：
        an array of protocols supported

      • getEnabledProtocols

        public abstract String[] getEnabledProtocols()
        Returns the names of the protocol versions which are currently enabled for use with this SSLEngine.
        返回：
        an array of protocols
        另请参见：
        setEnabledProtocols(String [])

      • setEnabledProtocols

        public abstract void setEnabledProtocols(String[] protocols)
        Set the protocol versions enabled for use on this engine.

        The protocols must have been listed by getSupportedProtocols() as being supported. Following a successful call to this method, only protocols listed in the protocols parameter are enabled for use.

        参数：
        protocols - Names of all the protocols to enable.
        抛出：
        IllegalArgumentException - when one or more of the protocols named by the parameter is not supported or when the protocols parameter is null.
        另请参见：
        getEnabledProtocols()

      • getSession

        public abstract SSLSession getSession()
        Returns the SSLSession in use in this SSLEngine.

        These can be long lived, and frequently correspond to an entire login session for some user. The session specifies a particular cipher suite which is being actively used by all connections in that session, as well as the identities of the session's client and server.

        Unlike SSLSocket.getSession() this method does not block until handshaking is complete.

        Until the initial handshake has completed, this method returns a session object which reports an invalid cipher suite of "SSL_NULL_WITH_NULL_NULL".

        返回：
        the SSLSession for this SSLEngine
        另请参见：
        SSLSession

      • getHandshakeSession

        public SSLSession getHandshakeSession()
        Returns the SSLSession being constructed during a SSL/TLS handshake.

        TLS protocols may negotiate parameters that are needed when using an instance of this class, but before the SSLSession has been completely initialized and made available via getSession. For example, the list of valid signature algorithms may restrict the type of certificates that can used during TrustManager decisions, or the maximum TLS fragment packet sizes can be resized to better support the network environment.

        This method provides early access to the SSLSession being constructed. Depending on how far the handshake has progressed, some data may not yet be available for use. For example, if a remote server will be sending a Certificate chain, but that chain has yet not been processed, the getPeerCertificates method of SSLSession will throw a SSLPeerUnverifiedException. Once that chain has been processed, getPeerCertificates will return the proper value.

        返回：
        null if this instance is not currently handshaking, or if the current handshake has not progressed far enough to create a basic SSLSession. Otherwise, this method returns the SSLSession currently being negotiated.
        抛出：
        UnsupportedOperationException - if the underlying provider does not implement the operation.
        从以下版本开始：
        1.7
        另请参见：
        SSLSocket, SSLSession, ExtendedSSLSession, X509ExtendedKeyManager, X509ExtendedTrustManager

      • beginHandshake

        public abstract void beginHandshake()
                             throws SSLException
        Initiates handshaking (initial or renegotiation) on this SSLEngine.

        This method is not needed for the initial handshake, as the wrap() and unwrap() methods will implicitly call this method if handshaking has not already begun.

        Note that the peer may also request a session renegotiation with this SSLEngine by sending the appropriate session renegotiate handshake message.

        Unlike the SSLSocket#startHandshake() method, this method does not block until handshaking is completed.

        To force a complete SSL/TLS session renegotiation, the current session should be invalidated prior to calling this method.

        Some protocols may not support multiple handshakes on an existing engine and may throw an SSLException.

        抛出：
        SSLException - if a problem was encountered while signaling the SSLEngine to begin a new handshake. See the class description for more information on engine closure.
        IllegalStateException - if the client/server mode has not yet been set.
        另请参见：
        SSLSession.invalidate()

      • getHandshakeStatus

        public abstract SSLEngineResult.HandshakeStatus getHandshakeStatus()
        Returns the current handshake status for this SSLEngine.
        返回：
        the current SSLEngineResult.HandshakeStatus.

      • setUseClientMode

        public abstract void setUseClientMode(boolean mode)
        Configures the engine to use client (or server) mode when handshaking.

        This method must be called before any handshaking occurs. Once handshaking has begun, the mode can not be reset for the life of this engine.

        Servers normally authenticate themselves, and clients are not required to do so.

        参数：
        mode - true if the engine should start its handshaking in "client" mode
        抛出：
        IllegalArgumentException - if a mode change is attempted after the initial handshake has begun.
        另请参见：
        getUseClientMode()

      • getUseClientMode

        public abstract boolean getUseClientMode()
        Returns true if the engine is set to use client mode when handshaking.
        返回：
        true if the engine should do handshaking in "client" mode
        另请参见：
        setUseClientMode(boolean)

      • setNeedClientAuth

        public abstract void setNeedClientAuth(boolean need)
        Configures the engine to require client authentication. This option is only useful for engines in the server mode.

        An engine's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setWantClientAuth(boolean), if this option is set and the client chooses not to provide authentication information about itself, the negotiations will stop and the engine will begin its closure procedure.

        Calling this method overrides any previous setting made by this method or setWantClientAuth(boolean).

        参数：
        need - set to true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • getNeedClientAuth

        public abstract boolean getNeedClientAuth()
        Returns true if the engine will require client authentication. This option is only useful to engines in the server mode.
        返回：
        true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • setWantClientAuth

        public abstract void setWantClientAuth(boolean want)
        Configures the engine to request client authentication. This option is only useful for engines in the server mode.

        An engine's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setNeedClientAuth(boolean), if this option is set and the client chooses not to provide authentication information about itself, the negotiations will continue.

        Calling this method overrides any previous setting made by this method or setNeedClientAuth(boolean).

        参数：
        want - set to true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

      • getWantClientAuth

        public abstract boolean getWantClientAuth()
        Returns true if the engine will request client authentication. This option is only useful for engines in the server mode.
        返回：
        true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        setNeedClientAuth(boolean), getNeedClientAuth(), setWantClientAuth(boolean), setUseClientMode(boolean)

      • setEnableSessionCreation

        public abstract void setEnableSessionCreation(boolean flag)
        Controls whether new SSL sessions may be established by this engine. If session creations are not allowed, and there are no existing sessions to resume, there will be no successful handshaking.
        参数：
        flag - true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed
        另请参见：
        getEnableSessionCreation()

      • getEnableSessionCreation

        public abstract boolean getEnableSessionCreation()
        Returns true if new SSL sessions may be established by this engine.
        返回：
        true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed
        另请参见：
        setEnableSessionCreation(boolean)

      • getSSLParameters

        public SSLParameters getSSLParameters()
        Returns the SSLParameters in effect for this SSLEngine. The ciphersuites and protocols of the returned SSLParameters are always non-null.
        返回：
        the SSLParameters in effect for this SSLEngine.
        从以下版本开始：
        1.6

      • setSSLParameters

        public void setSSLParameters(SSLParameters params)
        Applies SSLParameters to this engine.

        This means:

        • if params.getCipherSuites() is non-null, setEnabledCipherSuites() is called with that value
        • if params.getProtocols() is non-null, setEnabledProtocols() is called with that value
        • if params.getNeedClientAuth() or params.getWantClientAuth() return true, setNeedClientAuth(true) and setWantClientAuth(true) are called, respectively; otherwise setWantClientAuth(false) is called.
        参数：
        params - the parameters
        抛出：
        IllegalArgumentException - if the setEnabledCipherSuites() or the setEnabledProtocols() call fails
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SSLEngineResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLEngineResult

  • java.lang.Object
    • javax.net.ssl.SSLEngineResult

  • public class SSLEngineResult
extends Object
    An encapsulation of the result state produced by SSLEngine I/O calls.

    A SSLEngine provides a means for establishing secure communication sessions between two peers. SSLEngine operations typically consume bytes from an input buffer and produce bytes in an output buffer. This class provides operational result values describing the state of the SSLEngine, including indications of what operations are needed to finish an ongoing handshake. Lastly, it reports the number of bytes consumed and produced as a result of this operation.

    从以下版本开始：
    1.5
    另请参见：
    SSLEngine, SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  SSLEngineResult.HandshakeStatus
      An SSLEngineResult enum describing the current handshaking state of this SSLEngine.
      static class  SSLEngineResult.Status
      An SSLEngineResult enum describing the overall result of the SSLEngine operation.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
      Initializes a new instance of this class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int bytesConsumed()
      Returns the number of bytes consumed from the input buffer.
      int bytesProduced()
      Returns the number of bytes written to the output buffer.
      SSLEngineResult.HandshakeStatus getHandshakeStatus()
      Gets the handshake status of this SSLEngine operation.
      SSLEngineResult.Status getStatus()
      Gets the return value of this SSLEngine operation.
      String toString()
      Returns a String representation of this object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLEngineResult

        public SSLEngineResult(SSLEngineResult.Status status,
               SSLEngineResult.HandshakeStatus handshakeStatus,
               int bytesConsumed,
               int bytesProduced)
        Initializes a new instance of this class.
        参数：
        status - the return value of the operation.
        handshakeStatus - the current handshaking status.
        bytesConsumed - the number of bytes consumed from the source ByteBuffer
        bytesProduced - the number of bytes placed into the destination ByteBuffer
        抛出：
        IllegalArgumentException - if the status or handshakeStatus arguments are null, or if <bytesConsumed or bytesProduced is negative.

    • 方法详细信息

      • getStatus

        public final SSLEngineResult.Status getStatus()
        Gets the return value of this SSLEngine operation.
        返回：
        the return value

      • getHandshakeStatus

        public final SSLEngineResult.HandshakeStatus getHandshakeStatus()
        Gets the handshake status of this SSLEngine operation.
        返回：
        the handshake status

      • bytesConsumed

        public final int bytesConsumed()
        Returns the number of bytes consumed from the input buffer.
        返回：
        the number of bytes consumed.

      • bytesProduced

        public final int bytesProduced()
        Returns the number of bytes written to the output buffer.
        返回：
        the number of bytes produced

      • toString

        public String toString()
        Returns a String representation of this object.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=f>>>l>r>iahre"h ||me=t#tad>toenffnnlrrano=s


SSLEngineResult.HandshakeStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.net.ssl

Enum SSLEngineResult.HandshakeStatus

  • java.lang.Object
    • java.lang.Enum<SSLEngineResult.HandshakeStatus>
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
  • 所有已实现的接口：
    Serializable, Comparable<SSLEngineResult.HandshakeStatus>
    封闭类：
    SSLEngineResult

    public static enum SSLEngineResult.HandshakeStatus
extends Enum<SSLEngineResult.HandshakeStatus>
    An SSLEngineResult enum describing the current handshaking state of this SSLEngine.
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FINISHED
      The SSLEngine has just finished handshaking.
      NEED_TASK
      The SSLEngine needs the results of one (or more) delegated tasks before handshaking can continue.
      NEED_UNWRAP
      The SSLEngine needs to receive data from the remote side before handshaking can continue.
      NEED_WRAP
      The SSLEngine must send data to the remote side before handshaking can continue, so SSLEngine.wrap() should be called.
      NOT_HANDSHAKING
      The SSLEngine is not currently handshaking.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SSLEngineResult.HandshakeStatus valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SSLEngineResult.HandshakeStatus[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NOT_HANDSHAKING

        public static final SSLEngineResult.HandshakeStatus NOT_HANDSHAKING
        The SSLEngine is not currently handshaking.

      • FINISHED

        public static final SSLEngineResult.HandshakeStatus FINISHED
        The SSLEngine has just finished handshaking.

        This value is only generated by a call to SSLEngine.wrap()/unwrap() when that call finishes a handshake. It is never generated by SSLEngine.getHandshakeStatus().

        另请参见：
        SSLEngine.wrap(ByteBuffer, ByteBuffer),
SSLEngine.unwrap(ByteBuffer, ByteBuffer),
SSLEngine.getHandshakeStatus()

      • NEED_TASK

        public static final SSLEngineResult.HandshakeStatus NEED_TASK
        The SSLEngine needs the results of one (or more) delegated tasks before handshaking can continue.
        另请参见：
        SSLEngine.getDelegatedTask()

      • NEED_WRAP

        public static final SSLEngineResult.HandshakeStatus NEED_WRAP
        The SSLEngine must send data to the remote side before handshaking can continue, so SSLEngine.wrap() should be called.
        另请参见：
        SSLEngine.wrap(ByteBuffer, ByteBuffer)

      • NEED_UNWRAP

        public static final SSLEngineResult.HandshakeStatus NEED_UNWRAP
        The SSLEngine needs to receive data from the remote side before handshaking can continue.

    • 方法详细信息

      • values

        public static SSLEngineResult.HandshakeStatus[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SSLEngineResult.HandshakeStatus c : SSLEngineResult.HandshakeStatus.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SSLEngineResult.HandshakeStatus valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

LeEnjv/av/.../.."< mr/uss/ /rggn eeno


SSLEngineResult.Status

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.net.ssl

Enum SSLEngineResult.Status

  • java.lang.Object
    • java.lang.Enum<SSLEngineResult.Status>
      • javax.net.ssl.SSLEngineResult.Status
  • 所有已实现的接口：
    Serializable, Comparable<SSLEngineResult.Status>
    封闭类：
    SSLEngineResult

    public static enum SSLEngineResult.Status
extends Enum<SSLEngineResult.Status>
    An SSLEngineResult enum describing the overall result of the SSLEngine operation. The Status value does not reflect the state of a SSLEngine handshake currently in progress. The SSLEngineResult's HandshakeStatus should be consulted for that information.
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BUFFER_OVERFLOW
      The SSLEngine was not able to process the operation because there are not enough bytes available in the destination buffer to hold the result.
      BUFFER_UNDERFLOW
      The SSLEngine was not able to unwrap the incoming data because there were not enough source bytes available to make a complete packet.
      CLOSED
      The operation just closed this side of the SSLEngine, or the operation could not be completed because it was already closed.
      OK
      The SSLEngine completed the operation, and is available to process similar calls.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SSLEngineResult.Status valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SSLEngineResult.Status[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BUFFER_UNDERFLOW

        public static final SSLEngineResult.Status BUFFER_UNDERFLOW
        The SSLEngine was not able to unwrap the incoming data because there were not enough source bytes available to make a complete packet.

        Repeat the call once more bytes are available.

      • BUFFER_OVERFLOW

        public static final SSLEngineResult.Status BUFFER_OVERFLOW
        The SSLEngine was not able to process the operation because there are not enough bytes available in the destination buffer to hold the result.

        Repeat the call once more bytes are available.

        另请参见：
        SSLSession.getPacketBufferSize(), SSLSession.getApplicationBufferSize()

      • OK

        public static final SSLEngineResult.Status OK
        The SSLEngine completed the operation, and is available to process similar calls.

      • CLOSED

        public static final SSLEngineResult.Status CLOSED
        The operation just closed this side of the SSLEngine, or the operation could not be completed because it was already closed.

    • 方法详细信息

      • values

        public static SSLEngineResult.Status[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SSLEngineResult.Status c : SSLEngineResult.Status.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SSLEngineResult.Status valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ngddsdvdid/c/inxmann 肯螴縜"


SSLException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    SSLHandshakeException, SSLKeyException, SSLPeerUnverifiedException, SSLProtocolException

    public class SSLException
extends IOException
    Indicates some kind of error detected by an SSL subsystem. This class is the general class of exceptions produced by failed SSL-related operations.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLException(String reason)
      Constructs an exception reporting an error found by an SSL subsystem.
      SSLException(String message, Throwable cause)
      Creates a SSLException with the specified detail message and cause.
      SSLException(Throwable cause)
      Creates a SSLException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLException

        public SSLException(String reason)
        Constructs an exception reporting an error found by an SSL subsystem.
        参数：
        reason - describes the problem.

      • SSLException

        public SSLException(String message,
            Throwable cause)
        Creates a SSLException with the specified detail message and cause.
        参数：
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        从以下版本开始：
        1.5

      • SSLException

        public SSLException(Throwable cause)
        Creates a SSLException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lii///<>>蕀aa le>"=rchi<>a <">-t


SSLHandshakeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLHandshakeException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
  • 所有已实现的接口：
    Serializable

    public class SSLHandshakeException
extends SSLException
    Indicates that the client and server could not negotiate the desired level of security. The connection is no longer usable.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLHandshakeException(String reason)
      Constructs an exception reporting an error found by an SSL subsystem during handshaking.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLHandshakeException

        public SSLHandshakeException(String reason)
        Constructs an exception reporting an error found by an SSL subsystem during handshaking.
        参数：
        reason - describes the problem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)s"#ehw.hwoaawoogjff>etd ee ( fsiaslvr


SSLKeyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLKeyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLKeyException
  • 所有已实现的接口：
    Serializable

    public class SSLKeyException
extends SSLException
    Reports a bad SSL key. Normally, this indicates misconfiguration of the server or client SSL certificate and private key.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLKeyException(String reason)
      Constructs an exception reporting a key management error found by an SSL subsystem.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLKeyException

        public SSLKeyException(String reason)
        Constructs an exception reporting a key management error found by an SSL subsystem.
        参数：
        reason - describes the problem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//羖 l1l苐c 捌涿裕羖醗逼１毙⌒ 腮ㄡg


SSLParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLParameters

  • java.lang.Object
    • javax.net.ssl.SSLParameters

  • public class SSLParameters
extends Object
    Encapsulates parameters for an SSL/TLS connection. The parameters are the list of ciphersuites to be accepted in an SSL/TLS handshake, the list of protocols to be allowed, the endpoint identification algorithm during SSL/TLS handshaking, the algorithm constraints and whether SSL/TLS servers should request or require client authentication.

    SSLParameters can be created via the constructors in this class. Objects can also be obtained using the getSSLParameters() methods in SSLSocket and SSLServerSocket and SSLEngine or the getDefaultSSLParameters() and getSupportedSSLParameters() methods in SSLContext.

    SSLParameters can be applied to a connection via the methods
SSLSocket.setSSLParameters() and
SSLServerSocket.setSSLParameters()
and SSLEngine.getSSLParameters().

    从以下版本开始：
    1.6
    另请参见：
    SSLSocket, SSLEngine, SSLContext

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLParameters()
      Constructs SSLParameters.
      SSLParameters(String[] cipherSuites)
      Constructs SSLParameters from the specified array of ciphersuites.
      SSLParameters(String[] cipherSuites, String[] protocols)
      Constructs SSLParameters from the specified array of ciphersuites and protocols.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AlgorithmConstraints getAlgorithmConstraints()
      Returns the cryptographic algorithm constraints.
      String[] getCipherSuites()
      Returns a copy of the array of ciphersuites or null if none have been set.
      String getEndpointIdentificationAlgorithm()
      Gets the endpoint identification algorithm.
      boolean getNeedClientAuth()
      Returns whether client authentication should be required.
      String[] getProtocols()
      Returns a copy of the array of protocols or null if none have been set.
      boolean getWantClientAuth()
      Returns whether client authentication should be requested.
      void setAlgorithmConstraints(AlgorithmConstraints constraints)
      Sets the cryptographic algorithm constraints, which will be used in addition to any configured by the runtime environment.
      void setCipherSuites(String[] cipherSuites)
      Sets the array of ciphersuites.
      void setEndpointIdentificationAlgorithm(String algorithm)
      Sets the endpoint identification algorithm.
      void setNeedClientAuth(boolean needClientAuth)
      Sets whether client authentication should be required.
      void setProtocols(String[] protocols)
      Sets the array of protocols.
      void setWantClientAuth(boolean wantClientAuth)
      Sets whether client authentication should be requested.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLParameters

        public SSLParameters()
        Constructs SSLParameters.

        The cipherSuites and protocols values are set to null, wantClientAuth and needClientAuth are set to false.

      • SSLParameters

        public SSLParameters(String[] cipherSuites)
        Constructs SSLParameters from the specified array of ciphersuites.

        Calling this constructor is equivalent to calling the no-args constructor followed by setCipherSuites(cipherSuites);.

        参数：
        cipherSuites - the array of ciphersuites (or null)

      • SSLParameters

        public SSLParameters(String[] cipherSuites,
             String[] protocols)
        Constructs SSLParameters from the specified array of ciphersuites and protocols.

        Calling this constructor is equivalent to calling the no-args constructor followed by setCipherSuites(cipherSuites); setProtocols(protocols);.

        参数：
        cipherSuites - the array of ciphersuites (or null)
        protocols - the array of protocols (or null)

    • 方法详细信息

      • getCipherSuites

        public String[] getCipherSuites()
        Returns a copy of the array of ciphersuites or null if none have been set.
        返回：
        a copy of the array of ciphersuites or null if none have been set.

      • setCipherSuites

        public void setCipherSuites(String[] cipherSuites)
        Sets the array of ciphersuites.
        参数：
        cipherSuites - the array of ciphersuites (or null)

      • getProtocols

        public String[] getProtocols()
        Returns a copy of the array of protocols or null if none have been set.
        返回：
        a copy of the array of protocols or null if none have been set.

      • setProtocols

        public void setProtocols(String[] protocols)
        Sets the array of protocols.
        参数：
        protocols - the array of protocols (or null)

      • getWantClientAuth

        public boolean getWantClientAuth()
        Returns whether client authentication should be requested.
        返回：
        whether client authentication should be requested.

      • setWantClientAuth

        public void setWantClientAuth(boolean wantClientAuth)
        Sets whether client authentication should be requested. Calling this method clears the needClientAuth flag.
        参数：
        wantClientAuth - whether client authentication should be requested

      • getNeedClientAuth

        public boolean getNeedClientAuth()
        Returns whether client authentication should be required.
        返回：
        whether client authentication should be required.

      • setNeedClientAuth

        public void setNeedClientAuth(boolean needClientAuth)
        Sets whether client authentication should be required. Calling this method clears the wantClientAuth flag.
        参数：
        needClientAuth - whether client authentication should be required

      • getAlgorithmConstraints

        public AlgorithmConstraints getAlgorithmConstraints()
        Returns the cryptographic algorithm constraints.
        返回：
        the cryptographic algorithm constraints, or null if the constraints have not been set
        从以下版本开始：
        1.7
        另请参见：
        setAlgorithmConstraints(AlgorithmConstraints)

      • setAlgorithmConstraints

        public void setAlgorithmConstraints(AlgorithmConstraints constraints)
        Sets the cryptographic algorithm constraints, which will be used in addition to any configured by the runtime environment.

        If the constraints parameter is non-null, every cryptographic algorithm, key and algorithm parameters used in the SSL/TLS handshake must be permitted by the constraints.

        参数：
        constraints - the algorithm constraints (or null)
        从以下版本开始：
        1.7

      • getEndpointIdentificationAlgorithm

        public String getEndpointIdentificationAlgorithm()
        Gets the endpoint identification algorithm.
        返回：
        the endpoint identification algorithm, or null if none has been set.
        从以下版本开始：
        1.7
        另请参见：
        X509ExtendedTrustManager, setEndpointIdentificationAlgorithm(String)

      • setEndpointIdentificationAlgorithm

        public void setEndpointIdentificationAlgorithm(String algorithm)
        Sets the endpoint identification algorithm.

        If the algorithm parameter is non-null or non-empty, the endpoint identification/verification procedures must be handled during SSL/TLS handshaking. This is to prevent man-in-the-middle attacks.

        参数：
        algorithm - The standard string name of the endpoint identification algorithm (or null). See Appendix A in the Java Cryptography Architecture API Specification & Reference for information about standard algorithm names.
        从以下版本开始：
        1.7
        另请参见：
        X509ExtendedTrustManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fr<>l/ -g ro sea!caems-


SSLPeerUnverifiedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLPeerUnverifiedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLPeerUnverifiedException
  • 所有已实现的接口：
    Serializable

    public class SSLPeerUnverifiedException
extends SSLException
    Indicates that the peer's identity has not been verified.

    When the peer was not able to identify itself (for example; no certificate, the particular cipher suite being used does not support authentication, or no peer authentication was established during SSL handshaking) this exception is thrown.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLPeerUnverifiedException(String reason)
      Constructs an exception reporting that the SSL peer's identity has not been verifiied.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLPeerUnverifiedException

        public SSLPeerUnverifiedException(String reason)
        Constructs an exception reporting that the SSL peer's identity has not been verifiied.
        参数：
        reason - describes the problem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d"i)nACtACdllCddpl//saLsraaLemhethSrat


SSLPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.net.ssl.SSLPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class SSLPermission
extends BasicPermission
    This class is for various network permissions. An SSLPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of the network permission (see below). The naming convention follows the hierarchical property naming convention. Also, an asterisk may appear at the end of the name, following a ".", or by itself, to signify a wildcard match. For example: "foo.*" or "*" is valid, "*foo" or "a*b" is not valid.

    The following table lists all the possible SSLPermission target names, and for each provides a description of what the permission allows and a discussion of the risks of granting code the permission.

    Permission Target Name | What the Permission Allows | Risks of Allowing this Permission
    setHostnameVerifier | The ability to set a callback which can decide whether to allow a mismatch between the host being connected to by an HttpsURLConnection and the common name field in server certificate. | Malicious code can set a verifier that monitors host names visited by HttpsURLConnection requests or that allows server certificates with invalid common names.
    getSSLSessionContext | The ability to get the SSLSessionContext of an SSLSession. | Malicious code may monitor sessions which have been established with SSL peers or might invalidate sessions to slow down performance.
    setDefaultSSLContext | The ability to set the default SSL context | Malicious code can set a context that monitors the opening of connections or the plaintext data that is transmitted.
    从以下版本开始：
    1.4
    另请参见：
    BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLPermission(String name)
      Creates a new SSLPermission with the specified name.
      SSLPermission(String name, String actions)
      Creates a new SSLPermission object with the specified name.

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLPermission

        public SSLPermission(String name)
        Creates a new SSLPermission with the specified name. The name is the symbolic name of the SSLPermission, such as "setDefaultAuthenticator", etc. An asterisk may appear at the end of the name, following a ".", or by itself, to signify a wildcard match.
        参数：
        name - the name of the SSLPermission.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • SSLPermission

        public SSLPermission(String name,
             String actions)
        Creates a new SSLPermission object with the specified name. The name is the symbolic name of the SSLPermission, and the actions String is currently unused and should be null.
        参数：
        name - the name of the SSLPermission.
        actions - ignored.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ster(i>ciiuttiuupdoog "noo t r ireCl


SSLProtocolException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.net.ssl

类 SSLProtocolException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLProtocolException
  • 所有已实现的接口：
    Serializable

    public class SSLProtocolException
extends SSLException
    Reports an error in the operation of the SSL protocol. Normally this indicates a flaw in one of the protocol implementations.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLProtocolException(String reason)
      Constructs an exception reporting an SSL protocol error detected by an SSL subsystem.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLProtocolException

        public SSLProtocolException(String reason)
        Constructs an exception reporting an SSL protocol error detected by an SSL subsystem.
        参数：
        reason - describes the problem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h.riSPsLPsbppsbbl


SSLServerSocket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLServerSocket

  • java.lang.Object
    • java.net.ServerSocket
      • javax.net.ssl.SSLServerSocket
  • 所有已实现的接口：
    Closeable, AutoCloseable

    public abstract class SSLServerSocket
extends ServerSocket
    This class extends ServerSockets and provides secure server sockets using protocols such as the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

    Instances of this class are generally created using a SSLServerSocketFactory. The primary function of SSLServerSockets is to create SSLSockets by accepting connections.

    SSLServerSockets contain several pieces of state data which are inherited by the SSLSocket at socket creation. These include the enabled cipher suites and protocols, whether client authentication is necessary, and whether created sockets should begin handshaking in client or server mode. The state inherited by the created SSLSocket can be overriden by calling the appropriate methods.

    从以下版本开始：
    1.4
    另请参见：
    ServerSocket, SSLSocket

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SSLServerSocket()
      Used only by subclasses.
      protected SSLServerSocket(int port)
      Used only by subclasses.
      protected SSLServerSocket(int port, int backlog)
      Used only by subclasses.
      protected SSLServerSocket(int port, int backlog, InetAddress address)
      Used only by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String[] getEnabledCipherSuites()
      Returns the list of cipher suites which are currently enabled for use by newly accepted connections.
      abstract String[] getEnabledProtocols()
      Returns the names of the protocols which are currently enabled for use by the newly accepted connections.
      abstract boolean getEnableSessionCreation()
      Returns true if new SSL sessions may be established by the sockets which are created from this server socket.
      abstract boolean getNeedClientAuth()
      Returns true if client authentication will be required on newly accepted server-mode SSLSockets.
      SSLParameters getSSLParameters()
      Returns the SSLParameters in effect for newly accepted connections.
      abstract String[] getSupportedCipherSuites()
      Returns the names of the cipher suites which could be enabled for use on an SSL connection.
      abstract String[] getSupportedProtocols()
      Returns the names of the protocols which could be enabled for use.
      abstract boolean getUseClientMode()
      Returns true if accepted connections will be in SSL client mode.
      abstract boolean getWantClientAuth()
      Returns true if client authentication will be requested on newly accepted server-mode connections.
      abstract void setEnabledCipherSuites(String[] suites)
      Sets the cipher suites enabled for use by accepted connections.
      abstract void setEnabledProtocols(String[] protocols)
      Controls which particular protocols are enabled for use by accepted connections.
      abstract void setEnableSessionCreation(boolean flag)
      Controls whether new SSL sessions may be established by the sockets which are created from this server socket.
      abstract void setNeedClientAuth(boolean need)
      Controls whether accepted server-mode SSLSockets will be initially configured to require client authentication.
      void setSSLParameters(SSLParameters params)
      Applies SSLParameters to newly accepted connections.
      abstract void setUseClientMode(boolean mode)
      Controls whether accepted connections are in the (default) SSL server mode, or the SSL client mode.
      abstract void setWantClientAuth(boolean want)
      Controls whether accepted server-mode SSLSockets will be initially configured to request client authentication.

      • 方法 - 继承于类 java.net.ServerSocket

        accept, bind, bind, close, getChannel, getInetAddress, getLocalPort, getLocalSocketAddress, getReceiveBufferSize, getReuseAddress, getSoTimeout, implAccept, isBound, isClosed, setPerformancePreferences, setReceiveBufferSize, setReuseAddress, setSocketFactory, setSoTimeout, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLServerSocket

        protected SSLServerSocket()
                   throws IOException
        Used only by subclasses.

        Create an unbound TCP server socket using the default authentication context.

        抛出：
        IOException - if an I/O error occurs when creating the socket

      • SSLServerSocket

        protected SSLServerSocket(int port)
                   throws IOException
        Used only by subclasses.

        Create a TCP server socket on a port, using the default authentication context. The connection backlog defaults to fifty connections queued up before the system starts to reject new connection requests.

        A port number of 0 creates a socket on any free port.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        参数：
        port - the port on which to listen
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int)

      • SSLServerSocket

        protected SSLServerSocket(int port,
               int backlog)
                   throws IOException
        Used only by subclasses.

        Create a TCP server socket on a port, using the default authentication context and a specified backlog of connections.

        A port number of 0 creates a socket on any free port.

        The backlog argument is the requested maximum number of pending connections on the socket. Its exact semantics are implementation specific. In particular, an implementation may impose a maximum length or may choose to ignore the parameter altogther. The value provided should be greater than 0. If it is less than or equal to 0, then an implementation specific default will be used.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        参数：
        port - the port on which to listen
        backlog - requested maximum length of the queue of incoming connections.
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int)

      • SSLServerSocket

        protected SSLServerSocket(int port,
               int backlog,
               InetAddress address)
                   throws IOException
        Used only by subclasses.

        Create a TCP server socket on a port, using the default authentication context and a specified backlog of connections as well as a particular specified network interface. This constructor is used on multihomed hosts, such as those used for firewalls or as routers, to control through which interface a network service is provided.

        If there is a security manager, its checkListen method is called with the port argument as its argument to ensure the operation is allowed. This could result in a SecurityException.

        A port number of 0 creates a socket on any free port.

        The backlog argument is the requested maximum number of pending connections on the socket. Its exact semantics are implementation specific. In particular, an implementation may impose a maximum length or may choose to ignore the parameter altogther. The value provided should be greater than 0. If it is less than or equal to 0, then an implementation specific default will be used.

        If address is null, it will default accepting connections on any/all local addresses.

        参数：
        port - the port on which to listen
        backlog - requested maximum length of the queue of incoming connections.
        address - the address of the network interface through which connections will be accepted
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkListen method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkListen(int)

    • 方法详细信息

      • getEnabledCipherSuites

        public abstract String[] getEnabledCipherSuites()
        Returns the list of cipher suites which are currently enabled for use by newly accepted connections.

        If this list has not been explicitly modified, a system-provided default guarantees a minimum quality of service in all enabled cipher suites.

        There are several reasons why an enabled cipher suite might not actually be used. For example: the server socket might not have appropriate private keys available to it or the cipher suite might be anonymous, precluding the use of client authentication, while the server socket has been told to require that sort of authentication.

        返回：
        an array of cipher suites enabled
        另请参见：
        getSupportedCipherSuites(), setEnabledCipherSuites(String [])

      • setEnabledCipherSuites

        public abstract void setEnabledCipherSuites(String[] suites)
        Sets the cipher suites enabled for use by accepted connections.

        The cipher suites must have been listed by getSupportedCipherSuites() as being supported. Following a successful call to this method, only suites listed in the suites parameter are enabled for use.

        Suites that require authentication information which is not available in this ServerSocket's authentication context will not be used in any case, even if they are enabled.

        SSLSockets returned from accept() inherit this setting.

        参数：
        suites - Names of all the cipher suites to enable
        抛出：
        IllegalArgumentException - when one or more of ciphers named by the parameter is not supported, or when the parameter is null.
        另请参见：
        getSupportedCipherSuites(), getEnabledCipherSuites()

      • getSupportedCipherSuites

        public abstract String[] getSupportedCipherSuites()
        Returns the names of the cipher suites which could be enabled for use on an SSL connection.

        Normally, only a subset of these will actually be enabled by default, since this list may include cipher suites which do not meet quality of service requirements for those defaults. Such cipher suites are useful in specialized applications.

        返回：
        an array of cipher suite names
        另请参见：
        getEnabledCipherSuites(), setEnabledCipherSuites(String [])

      • getSupportedProtocols

        public abstract String[] getSupportedProtocols()
        Returns the names of the protocols which could be enabled for use.
        返回：
        an array of protocol names supported
        另请参见：
        getEnabledProtocols(), setEnabledProtocols(String [])

      • getEnabledProtocols

        public abstract String[] getEnabledProtocols()
        Returns the names of the protocols which are currently enabled for use by the newly accepted connections.
        返回：
        an array of protocol names
        另请参见：
        getSupportedProtocols(), setEnabledProtocols(String [])

      • setEnabledProtocols

        public abstract void setEnabledProtocols(String[] protocols)
        Controls which particular protocols are enabled for use by accepted connections.

        The protocols must have been listed by getSupportedProtocols() as being supported. Following a successful call to this method, only protocols listed in the protocols parameter are enabled for use.

        SSLSockets returned from accept() inherit this setting.

        参数：
        protocols - Names of all the protocols to enable.
        抛出：
        IllegalArgumentException - when one or more of the protocols named by the parameter is not supported or when the protocols parameter is null.
        另请参见：
        getEnabledProtocols(), getSupportedProtocols()

      • setNeedClientAuth

        public abstract void setNeedClientAuth(boolean need)
        Controls whether accepted server-mode SSLSockets will be initially configured to require client authentication.

        A socket's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setWantClientAuth(boolean), if the accepted socket's option is set and the client chooses not to provide authentication information about itself, the negotiations will stop and the connection will be dropped.

        Calling this method overrides any previous setting made by this method or setWantClientAuth(boolean).

        The initial inherited setting may be overridden by calling SSLSocket.setNeedClientAuth(boolean) or SSLSocket.setWantClientAuth(boolean).

        参数：
        need - set to true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • getNeedClientAuth

        public abstract boolean getNeedClientAuth()
        Returns true if client authentication will be required on newly accepted server-mode SSLSockets.

        The initial inherited setting may be overridden by calling SSLSocket.setNeedClientAuth(boolean) or SSLSocket.setWantClientAuth(boolean).

        返回：
        true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • setWantClientAuth

        public abstract void setWantClientAuth(boolean want)
        Controls whether accepted server-mode SSLSockets will be initially configured to request client authentication.

        A socket's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setNeedClientAuth(boolean), if the accepted socket's option is set and the client chooses not to provide authentication information about itself, the negotiations will continue.

        Calling this method overrides any previous setting made by this method or setNeedClientAuth(boolean).

        The initial inherited setting may be overridden by calling SSLSocket.setNeedClientAuth(boolean) or SSLSocket.setWantClientAuth(boolean).

        参数：
        want - set to true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

      • getWantClientAuth

        public abstract boolean getWantClientAuth()
        Returns true if client authentication will be requested on newly accepted server-mode connections.

        The initial inherited setting may be overridden by calling SSLSocket.setNeedClientAuth(boolean) or SSLSocket.setWantClientAuth(boolean).

        返回：
        true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        setWantClientAuth(boolean), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

      • setUseClientMode

        public abstract void setUseClientMode(boolean mode)
        Controls whether accepted connections are in the (default) SSL server mode, or the SSL client mode.

        Servers normally authenticate themselves, and clients are not required to do so.

        In rare cases, TCP servers need to act in the SSL client mode on newly accepted connections. For example, FTP clients acquire server sockets and listen there for reverse connections from the server. An FTP client would use an SSLServerSocket in "client" mode to accept the reverse connection while the FTP server uses an SSLSocket with "client" mode disabled to initiate the connection. During the resulting handshake, existing SSL sessions may be reused.

        SSLSockets returned from accept() inherit this setting.

        参数：
        mode - true if newly accepted connections should use SSL client mode.
        另请参见：
        getUseClientMode()

      • getUseClientMode

        public abstract boolean getUseClientMode()
        Returns true if accepted connections will be in SSL client mode.
        返回：
        true if the connection should use SSL client mode.
        另请参见：
        setUseClientMode(boolean)

      • setEnableSessionCreation

        public abstract void setEnableSessionCreation(boolean flag)
        Controls whether new SSL sessions may be established by the sockets which are created from this server socket.

        SSLSockets returned from accept() inherit this setting.

        参数：
        flag - true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed.
        另请参见：
        getEnableSessionCreation()

      • getEnableSessionCreation

        public abstract boolean getEnableSessionCreation()
        Returns true if new SSL sessions may be established by the sockets which are created from this server socket.
        返回：
        true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed
        另请参见：
        setEnableSessionCreation(boolean)

      • getSSLParameters

        public SSLParameters getSSLParameters()
        Returns the SSLParameters in effect for newly accepted connections. The ciphersuites and protocols of the returned SSLParameters are always non-null.
        返回：
        the SSLParameters in effect for newly accepted connections
        从以下版本开始：
        1.7
        另请参见：
        setSSLParameters(SSLParameters)

      • setSSLParameters

        public void setSSLParameters(SSLParameters params)
        Applies SSLParameters to newly accepted connections.

        This means:

        • if params.getCipherSuites() is non-null, setEnabledCipherSuites() is called with that value
        • if params.getProtocols() is non-null, setEnabledProtocols() is called with that value
        • if params.getNeedClientAuth() or params.getWantClientAuth() return true, setNeedClientAuth(true) and setWantClientAuth(true) are called, respectively; otherwise setWantClientAuth(false) is called.
        参数：
        params - the parameters
        抛出：
        IllegalArgumentException - if the setEnabledCipherSuites() or the setEnabledProtocols() call fails
        从以下版本开始：
        1.7
        另请参见：
        getSSLParameters()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SSLServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLServerSocketFactory

  • java.lang.Object
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory

  • public abstract class SSLServerSocketFactory
extends ServerSocketFactory
    SSLServerSocketFactorys create SSLServerSockets.
    从以下版本开始：
    1.4
    另请参见：
    SSLSocket, SSLServerSocket

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SSLServerSocketFactory()
      Constructor is used only by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ServerSocketFactory getDefault()
      Returns the default SSL server socket factory.
      abstract String[] getDefaultCipherSuites()
      Returns the list of cipher suites which are enabled by default.
      abstract String[] getSupportedCipherSuites()
      Returns the names of the cipher suites which could be enabled for use on an SSL connection created by this factory.

      • 方法 - 继承于类 javax.net.ServerSocketFactory

        createServerSocket, createServerSocket, createServerSocket, createServerSocket

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLServerSocketFactory

        protected SSLServerSocketFactory()
        Constructor is used only by subclasses.

    • 方法详细信息

      • getDefault

        public static ServerSocketFactory getDefault()
        Returns the default SSL server socket factory.

        The first time this method is called, the security property "ssl.ServerSocketFactory.provider" is examined. If it is non-null, a class by that name is loaded and instantiated. If that is successful and the object is an instance of SSLServerSocketFactory, it is made the default SSL server socket factory.

        Otherwise, this method returns SSLContext.getDefault().getServerSocketFactory(). If that call fails, an inoperative factory is returned.

        返回：
        the default ServerSocketFactory
        另请参见：
        SSLContext.getDefault()

      • getDefaultCipherSuites

        public abstract String[] getDefaultCipherSuites()
        Returns the list of cipher suites which are enabled by default. Unless a different list is enabled, handshaking on an SSL connection will use one of these cipher suites. The minimum quality of service for these defaults requires confidentiality protection and server authentication (that is, no anonymous cipher suites).
        返回：
        array of the cipher suites enabled by default
        另请参见：
        getSupportedCipherSuites()

      • getSupportedCipherSuites

        public abstract String[] getSupportedCipherSuites()
        Returns the names of the cipher suites which could be enabled for use on an SSL connection created by this factory. Normally, only a subset of these will actually be enabled by default, since this list may include cipher suites which do not meet quality of service requirements for those defaults. Such cipher suites are useful in specialized applications.
        返回：
        an array of cipher suite names
        另请参见：
        getDefaultCipherSuites()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/ndokeckenttennjmvve/vvreeo#c>ea#lle)vS.


SSLSession

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface SSLSession

  • All Known Implementing Classes:
    ExtendedSSLSession

    public interface SSLSession
    In SSL, sessions are used to describe an ongoing relationship between two entities. Each SSL connection involves one session at a time, but that session may be used on many connections between those entities, simultaneously or sequentially. The session used on a connection may also be replaced by a different session. Sessions are created, or rejoined, as part of the SSL handshaking protocol. Sessions may be invalidated due to policies affecting security or resource usage, or by an application explicitly calling invalidate. Session management policies are typically used to tune performance.

    In addition to the standard session attributes, SSL sessions expose these read-only attributes:

    • Peer Identity. Sessions are between a particular client and a particular server. The identity of the peer may have been established as part of session setup. Peers are generally identified by X.509 certificate chains.
    • Cipher Suite Name. Cipher suites describe the kind of cryptographic protection that's used by connections in a particular session.
    • Peer Host. All connections in a session are between the same two hosts. The address of the host on the other side of the connection is available.

    Sessions may be explicitly invalidated. Invalidation may also be done implicitly, when faced with certain kinds of errors.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getApplicationBufferSize()
      Gets the current size of the largest application data that is expected when using this session.
      String getCipherSuite()
      Returns the name of the SSL cipher suite which is used for all connections in the session.
      long getCreationTime()
      Returns the time at which this Session representation was created, in milliseconds since midnight, January 1, 1970 UTC.
      byte[] getId()
      Returns the identifier assigned to this Session.
      long getLastAccessedTime()
      Returns the last time this Session representation was accessed by the session level infrastructure, in milliseconds since midnight, January 1, 1970 UTC.
      Certificate[] getLocalCertificates()
      Returns the certificate(s) that were sent to the peer during handshaking.
      Principal getLocalPrincipal()
      Returns the principal that was sent to the peer during handshaking.
      int getPacketBufferSize()
      Gets the current size of the largest SSL/TLS packet that is expected when using this session.
      X509Certificate[] getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.
      Certificate[] getPeerCertificates()
      Returns the identity of the peer which was established as part of defining the session.
      String getPeerHost()
      Returns the host name of the peer in this session.
      int getPeerPort()
      Returns the port number of the peer in this session.
      Principal getPeerPrincipal()
      Returns the identity of the peer which was established as part of defining the session.
      String getProtocol()
      Returns the standard name of the protocol used for all connections in the session.
      SSLSessionContext getSessionContext()
      Returns the context in which this session is bound.
      Object getValue(String name)
      Returns the object bound to the given name in the session's application layer data.
      String[] getValueNames()
      Returns an array of the names of all the application layer data objects bound into the Session.
      void invalidate()
      Invalidates the session.
      boolean isValid()
      Returns whether this session is valid and available for resuming or joining.
      void putValue(String name, Object value)
      Binds the specified value object into the session's application layer data with the given name.
      void removeValue(String name)
      Removes the object bound to the given name in the session's application layer data.

    • 方法详细信息

      • getId

        byte[] getId()
        Returns the identifier assigned to this Session.
        返回：
        the Session identifier

      • getSessionContext

        SSLSessionContext getSessionContext()
        Returns the context in which this session is bound.

        This context may be unavailable in some environments, in which case this method returns null.

        If the context is available and there is a security manager installed, the caller may require permission to access it or a security exception may be thrown. In a Java environment, the security manager's checkPermission method is called with a SSLPermission("getSSLSessionContext") permission.

        返回：
        the session context used for this session, or null if the context is unavailable.
        抛出：
        SecurityException - if the calling thread does not have permission to get SSL session context.

      • getCreationTime

        long getCreationTime()
        Returns the time at which this Session representation was created, in milliseconds since midnight, January 1, 1970 UTC.
        返回：
        the time this Session was created

      • getLastAccessedTime

        long getLastAccessedTime()
        Returns the last time this Session representation was accessed by the session level infrastructure, in milliseconds since midnight, January 1, 1970 UTC.

        Access indicates a new connection being established using session data. Application level operations, such as getting or setting a value associated with the session, are not reflected in this access time.

        This information is particularly useful in session management policies. For example, a session manager thread could leave all sessions in a given context which haven't been used in a long time; or, the sessions might be sorted according to age to optimize some task.

        返回：
        the last time this Session was accessed

      • invalidate

        void invalidate()
        Invalidates the session.

        Future connections will not be able to resume or join this session. However, any existing connection using this session can continue to use the session until the connection is closed.

        另请参见：
        isValid()

      • isValid

        boolean isValid()
        Returns whether this session is valid and available for resuming or joining.
        返回：
        true if this session may be rejoined.
        从以下版本开始：
        1.5
        另请参见：
        invalidate()

      • putValue

        void putValue(String name,
            Object value)
        Binds the specified value object into the session's application layer data with the given name.

        Any existing binding using the same name is replaced. If the new (or existing) value implements the SSLSessionBindingListener interface, the object represented by value is notified appropriately.

        For security reasons, the same named values may not be visible across different access control contexts.

        参数：
        name - the name to which the data object will be bound. This may not be null.
        value - the data object to be bound. This may not be null.
        抛出：
        IllegalArgumentException - if either argument is null.

      • getValue

        Object getValue(String name)
        Returns the object bound to the given name in the session's application layer data. Returns null if there is no such binding.

        For security reasons, the same named values may not be visible across different access control contexts.

        参数：
        name - the name of the binding to find.
        返回：
        the value bound to that name, or null if the binding does not exist.
        抛出：
        IllegalArgumentException - if the argument is null.

      • removeValue

        void removeValue(String name)
        Removes the object bound to the given name in the session's application layer data. Does nothing if there is no object bound to the given name. If the bound existing object implements the SessionBindingListener interface, it is notified appropriately.

        For security reasons, the same named values may not be visible across different access control contexts.

        参数：
        name - the name of the object to remove visible across different access control contexts
        抛出：
        IllegalArgumentException - if the argument is null.

      • getValueNames

        String[] getValueNames()
        Returns an array of the names of all the application layer data objects bound into the Session.

        For security reasons, the same named values may not be visible across different access control contexts.

        返回：
        a non-null (possibly empty) array of names of the objects bound to this Session.

      • getPeerCertificates

        Certificate[] getPeerCertificates()
                                  throws SSLPeerUnverifiedException
        Returns the identity of the peer which was established as part of defining the session.

        Note: This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.

        返回：
        an ordered array of peer certificates, with the peer's own certificate first followed by any certificate authorities.
        抛出：
        SSLPeerUnverifiedException - if the peer's identity has not been verified
        另请参见：
        getPeerPrincipal()

      • getLocalCertificates

        Certificate[] getLocalCertificates()
        Returns the certificate(s) that were sent to the peer during handshaking.

        Note: This method is useful only when using certificate-based cipher suites.

        When multiple certificates are available for use in a handshake, the implementation chooses what it considers the "best" certificate chain available, and transmits that to the other side. This method allows the caller to know which certificate chain was actually used.

        返回：
        an ordered array of certificates, with the local certificate first followed by any certificate authorities. If no certificates were sent, then null is returned.
        另请参见：
        getLocalPrincipal()

      • getPeerCertificateChain

        X509Certificate[] getPeerCertificateChain()
                                          throws SSLPeerUnverifiedException
        Returns the identity of the peer which was identified as part of defining the session.

        Note: This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.

        Note: this method exists for compatibility with previous releases. New applications should use getPeerCertificates() instead.

        返回：
        an ordered array of peer X.509 certificates, with the peer's own certificate first followed by any certificate authorities. (The certificates are in the original JSSE certificate X509Certificate format.)
        抛出：
        SSLPeerUnverifiedException - if the peer's identity has not been verified
        另请参见：
        getPeerPrincipal()

      • getPeerPrincipal

        Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
        Returns the identity of the peer which was established as part of defining the session.
        返回：
        the peer's principal. Returns an X500Principal of the end-entity certiticate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites.
        抛出：
        SSLPeerUnverifiedException - if the peer's identity has not been verified
        从以下版本开始：
        1.5
        另请参见：
        getPeerCertificates(), getLocalPrincipal()

      • getLocalPrincipal

        Principal getLocalPrincipal()
        Returns the principal that was sent to the peer during handshaking.
        返回：
        the principal sent to the peer. Returns an X500Principal of the end-entity certificate for X509-based cipher suites, and KerberosPrincipal for Kerberos cipher suites. If no principal was sent, then null is returned.
        从以下版本开始：
        1.5
        另请参见：
        getLocalCertificates(), getPeerPrincipal()

      • getCipherSuite

        String getCipherSuite()
        Returns the name of the SSL cipher suite which is used for all connections in the session.

        This defines the level of protection provided to the data sent on the connection, including the kind of encryption used and most aspects of how authentication is done.

        返回：
        the name of the session's cipher suite

      • getProtocol

        String getProtocol()
        Returns the standard name of the protocol used for all connections in the session.

        This defines the protocol used in the connection.

        返回：
        the standard name of the protocol used for all connections in the session.

      • getPeerHost

        String getPeerHost()
        Returns the host name of the peer in this session.

        For the server, this is the client's host; and for the client, it is the server's host. The name may not be a fully qualified host name or even a host name at all as it may represent a string encoding of the peer's network address. If such a name is desired, it might be resolved through a name service based on the value returned by this method.

        This value is not authenticated and should not be relied upon. It is mainly used as a hint for SSLSession caching strategies.

        返回：
        the host name of the peer host, or null if no information is available.

      • getPeerPort

        int getPeerPort()
        Returns the port number of the peer in this session.

        For the server, this is the client's port number; and for the client, it is the server's port number.

        This value is not authenticated and should not be relied upon. It is mainly used as a hint for SSLSession caching strategies.

        返回：
        the port number of the peer host, or -1 if no information is available.
        从以下版本开始：
        1.5

      • getPacketBufferSize

        int getPacketBufferSize()
        Gets the current size of the largest SSL/TLS packet that is expected when using this session.

        A SSLEngine using this session may generate SSL/TLS packets of any size up to and including the value returned by this method. All SSLEngine network buffers should be sized at least this large to avoid insufficient space problems when performing wrap and unwrap calls.

        返回：
        the current maximum expected network packet size
        从以下版本开始：
        1.5
        另请参见：
        SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)

      • getApplicationBufferSize

        int getApplicationBufferSize()
        Gets the current size of the largest application data that is expected when using this session.

        SSLEngine application data buffers must be large enough to hold the application data from any inbound network application data packet received. Typically, outbound application data buffers can be of any size.

        返回：
        the current maximum expected application packet size
        从以下版本开始：
        1.5
        另请参见：
        SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=


SSLSessionBindingEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLSessionBindingEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.net.ssl.SSLSessionBindingEvent
  • 所有已实现的接口：
    Serializable

    public class SSLSessionBindingEvent
extends EventObject
    This event is propagated to a SSLSessionBindingListener. When a listener object is bound or unbound to an SSLSession by SSLSession.putValue(String, Object) or SSLSession.removeValue(String), objects which implement the SSLSessionBindingListener will be receive an event of this type. The event's name field is the key in which the listener is being bound or unbound.
    从以下版本开始：
    1.4
    另请参见：
    SSLSession, SSLSessionBindingListener, Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLSessionBindingEvent(SSLSession session, String name)
      Constructs a new SSLSessionBindingEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Returns the name to which the object is being bound, or the name from which the object is being unbound.
      SSLSession getSession()
      Returns the SSLSession into which the listener is being bound or from which the listener is being unbound.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLSessionBindingEvent

        public SSLSessionBindingEvent(SSLSession session,
                      String name)
        Constructs a new SSLSessionBindingEvent.
        参数：
        session - the SSLSession acting as the source of the event
        name - the name to which the object is being bound or unbound
        抛出：
        IllegalArgumentException - if session is null.

    • 方法详细信息

      • getName

        public String getName()
        Returns the name to which the object is being bound, or the name from which the object is being unbound.
        返回：
        the name to which the object is being bound or unbound

      • getSession

        public SSLSession getSession()
        Returns the SSLSession into which the listener is being bound or from which the listener is being unbound.
        返回：
        the SSLSession
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"(g>i =s-ascl=--==A= DDE= s=


SSLSessionBindingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface SSLSessionBindingListener

  • All Superinterfaces:
    EventListener

    public interface SSLSessionBindingListener
extends EventListener
    This interface is implemented by objects which want to know when they are being bound or unbound from a SSLSession. When either event occurs via SSLSession.putValue(String, Object) or SSLSession.removeValue(String), the event is communicated through a SSLSessionBindingEvent identifying the session.
    从以下版本开始：
    1.4
    另请参见：
    SSLSession, SSLSessionBindingEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueBound(SSLSessionBindingEvent event)
      This is called to notify the listener that it is being bound into an SSLSession.
      void valueUnbound(SSLSessionBindingEvent event)
      This is called to notify the listener that it is being unbound from a SSLSession.

    • 方法详细信息

      • valueBound

        void valueBound(SSLSessionBindingEvent event)
        This is called to notify the listener that it is being bound into an SSLSession.
        参数：
        event - the event identifying the SSLSession into which the listener is being bound.

      • valueUnbound

        void valueUnbound(SSLSessionBindingEvent event)
        This is called to notify the listener that it is being unbound from a SSLSession.
        参数：
        event - the event identifying the SSLSession from which the listener is being unbound.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>/<


SSLSessionContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface SSLSessionContext

  • public interface SSLSessionContext
    A SSLSessionContext represents a set of SSLSessions associated with a single entity. For example, it could be associated with a server or client who participates in many sessions concurrently.

    Not all environments will contain session contexts.

    There are SSLSessionContext parameters that affect how sessions are stored:

    • Sessions can be set to expire after a specified time limit.
    • The number of sessions that can be stored in context can be limited.
    A session can be retrieved based on its session id, and all session id's in a SSLSessionContext can be listed.
    从以下版本开始：
    1.4
    另请参见：
    SSLSession

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Enumeration<byte[]> getIds()
      Returns an Enumeration of all session id's grouped under this SSLSessionContext.
      SSLSession getSession(byte[] sessionId)
      Returns the SSLSession bound to the specified session id.
      int getSessionCacheSize()
      Returns the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.
      int getSessionTimeout()
      Returns the timeout limit of SSLSession objects grouped under this SSLSessionContext.
      void setSessionCacheSize(int size)
      Sets the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.
      void setSessionTimeout(int seconds)
      Sets the timeout limit for SSLSession objects grouped under this SSLSessionContext.

    • 方法详细信息

      • getSession

        SSLSession getSession(byte[] sessionId)
        Returns the SSLSession bound to the specified session id.
        参数：
        sessionId - the Session identifier
        返回：
        the SSLSession or null if the specified session id does not refer to a valid SSLSession.
        抛出：
        NullPointerException - if sessionId is null.

      • getIds

        Enumeration<byte[]> getIds()
        Returns an Enumeration of all session id's grouped under this SSLSessionContext.
        返回：
        an enumeration of all the Session id's

      • setSessionTimeout

        void setSessionTimeout(int seconds)
                       throws IllegalArgumentException
        Sets the timeout limit for SSLSession objects grouped under this SSLSessionContext.

        If the timeout limit is set to 't' seconds, a session exceeds the timeout limit 't' seconds after its creation time. When the timeout limit is exceeded for a session, the SSLSession object is invalidated and future connections cannot resume or rejoin the session. A check for sessions exceeding the timeout is made immediately whenever the timeout limit is changed for this SSLSessionContext.

        参数：
        seconds - the new session timeout limit in seconds; zero means there is no limit.
        抛出：
        IllegalArgumentException - if the timeout specified is < 0.
        另请参见：
        getSessionTimeout()

      • getSessionTimeout

        int getSessionTimeout()
        Returns the timeout limit of SSLSession objects grouped under this SSLSessionContext.

        If the timeout limit is set to 't' seconds, a session exceeds the timeout limit 't' seconds after its creation time. When the timeout limit is exceeded for a session, the SSLSession object is invalidated and future connections cannot resume or rejoin the session. A check for sessions exceeding the timeout limit is made immediately whenever the timeout limit is changed for this SSLSessionContext.

        返回：
        the session timeout limit in seconds; zero means there is no limit.
        另请参见：
        setSessionTimeout(int)

      • setSessionCacheSize

        void setSessionCacheSize(int size)
                         throws IllegalArgumentException
        Sets the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.
        参数：
        size - the new session cache size limit; zero means there is no limit.
        抛出：
        IllegalArgumentException - if the specified size is < 0.
        另请参见：
        getSessionCacheSize()

      • getSessionCacheSize

        int getSessionCacheSize()
        Returns the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.
        返回：
        size of the session cache; zero means there is no size limit.
        另请参见：
        setSessionCacheSize(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sgarocoileteihc(竤 Aist vso>i>


SSLSocket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLSocket

  • java.lang.Object
    • java.net.Socket
      • javax.net.ssl.SSLSocket
  • 所有已实现的接口：
    Closeable, AutoCloseable

    public abstract class SSLSocket
extends Socket
    This class extends Sockets and provides secure socket using protocols such as the "Secure Sockets Layer" (SSL) or IETF "Transport Layer Security" (TLS) protocols.

    Such sockets are normal stream sockets, but they add a layer of security protections over the underlying network transport protocol, such as TCP. Those protections include:

    • Integrity Protection. SSL protects against modification of messages by an active wiretapper.
    • Authentication. In most modes, SSL provides peer authentication. Servers are usually authenticated, and clients may be authenticated as requested by servers.
    • Confidentiality (Privacy Protection). In most modes, SSL encrypts data being sent between client and server. This protects the confidentiality of data, so that passive wiretappers won't see sensitive data such as financial information or personal information of many kinds.

    These kinds of protection are specified by a "cipher suite", which is a combination of cryptographic algorithms used by a given SSL connection. During the negotiation process, the two endpoints must agree on a ciphersuite that is available in both environments. If there is no such suite in common, no SSL connection can be established, and no data can be exchanged.

    The cipher suite used is established by a negotiation process called "handshaking". The goal of this process is to create or rejoin a "session", which may protect many connections over time. After handshaking has completed, you can access session attributes by using the getSession method. The initial handshake on this connection can be initiated in one of three ways:

    • calling startHandshake which explicitly begins handshakes, or
    • any attempt to read or write application data on this socket causes an implicit handshake, or
    • a call to getSession tries to set up a session if there is no currently valid session, and an implicit handshake is done.

    If handshaking fails for any reason, the SSLSocket is closed, and no futher communications can be done.

    There are two groups of cipher suites which you will need to know about when managing cipher suites:

    • Supported cipher suites: all the suites which are supported by the SSL implementation. This list is reported using getSupportedCipherSuites.
    • Enabled cipher suites, which may be fewer than the full set of supported suites. This group is set using the setEnabledCipherSuites method, and queried using the getEnabledCipherSuites method. Initially, a default set of cipher suites will be enabled on a new socket that represents the minimum suggested configuration.

    Implementation defaults require that only cipher suites which authenticate servers and provide confidentiality be enabled by default. Only if both sides explicitly agree to unauthenticated and/or non-private (unencrypted) communications will such a ciphersuite be selected.

    When SSLSockets are first created, no handshaking is done so that applications may first set their communication preferences: what cipher suites to use, whether the socket should be in client or server mode, etc. However, security is always provided by the time that application data is sent over the connection.

    You may register to receive event notification of handshake completion. This involves the use of two additional classes. HandshakeCompletedEvent objects are passed to HandshakeCompletedListener instances, which are registered by users of this API. SSLSockets are created by SSLSocketFactorys, or by accepting a connection from a SSLServerSocket.

    A SSL socket must choose to operate in the client or server mode. This will determine who begins the handshaking process, as well as which messages should be sent by each party. Each connection must have one client and one server, or handshaking will not progress properly. Once the initial handshaking has started, a socket can not switch between client and server modes, even when performing renegotiations.

    从以下版本开始：
    1.4
    另请参见：
    Socket, SSLServerSocket, SSLSocketFactory

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SSLSocket()
      Used only by subclasses.
      protected SSLSocket(InetAddress address, int port)
      Used only by subclasses.
      protected SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort)
      Used only by subclasses.
      protected SSLSocket(String host, int port)
      Used only by subclasses.
      protected SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
      Used only by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addHandshakeCompletedListener(HandshakeCompletedListener listener)
      Registers an event listener to receive notifications that an SSL handshake has completed on this connection.
      abstract String[] getEnabledCipherSuites()
      Returns the names of the SSL cipher suites which are currently enabled for use on this connection.
      abstract String[] getEnabledProtocols()
      Returns the names of the protocol versions which are currently enabled for use on this connection.
      abstract boolean getEnableSessionCreation()
      Returns true if new SSL sessions may be established by this socket.
      SSLSession getHandshakeSession()
      Returns the SSLSession being constructed during a SSL/TLS handshake.
      abstract boolean getNeedClientAuth()
      Returns true if the socket will require client authentication.
      abstract SSLSession getSession()
      Returns the SSL Session in use by this connection.
      SSLParameters getSSLParameters()
      Returns the SSLParameters in effect for this SSLSocket.
      abstract String[] getSupportedCipherSuites()
      Returns the names of the cipher suites which could be enabled for use on this connection.
      abstract String[] getSupportedProtocols()
      Returns the names of the protocols which could be enabled for use on an SSL connection.
      abstract boolean getUseClientMode()
      Returns true if the socket is set to use client mode when handshaking.
      abstract boolean getWantClientAuth()
      Returns true if the socket will request client authentication.
      abstract void removeHandshakeCompletedListener(HandshakeCompletedListener listener)
      Removes a previously registered handshake completion listener.
      abstract void setEnabledCipherSuites(String[] suites)
      Sets the cipher suites enabled for use on this connection.
      abstract void setEnabledProtocols(String[] protocols)
      Sets the protocol versions enabled for use on this connection.
      abstract void setEnableSessionCreation(boolean flag)
      Controls whether new SSL sessions may be established by this socket.
      abstract void setNeedClientAuth(boolean need)
      Configures the socket to require client authentication.
      void setSSLParameters(SSLParameters params)
      Applies SSLParameters to this socket.
      abstract void setUseClientMode(boolean mode)
      Configures the socket to use client (or server) mode when handshaking.
      abstract void setWantClientAuth(boolean want)
      Configures the socket to request client authentication.
      abstract void startHandshake()
      Starts an SSL handshake on this connection.

      • 方法 - 继承于类 java.net.Socket

        bind, close, connect, connect, getChannel, getInetAddress, getInputStream, getKeepAlive, getLocalAddress, getLocalPort, getLocalSocketAddress, getOOBInline, getOutputStream, getPort, getReceiveBufferSize, getRemoteSocketAddress, getReuseAddress, getSendBufferSize, getSoLinger, getSoTimeout, getTcpNoDelay, getTrafficClass, isBound, isClosed, isConnected, isInputShutdown, isOutputShutdown, sendUrgentData, setKeepAlive, setOOBInline, setPerformancePreferences, setReceiveBufferSize, setReuseAddress, setSendBufferSize, setSocketImplFactory, setSoLinger, setSoTimeout, setTcpNoDelay, setTrafficClass, shutdownInput, shutdownOutput, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SSLSocket

        protected SSLSocket()
        Used only by subclasses. Constructs an uninitialized, unconnected TCP socket.

      • SSLSocket

        protected SSLSocket(String host,
         int port)
             throws IOException,
                    UnknownHostException
        Used only by subclasses. Constructs a TCP connection to a named host at a specified port. This acts as the SSL client.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        host - name of the host with which to connect, or null for the loopback address.
        port - number of the server's port
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        UnknownHostException - if the host is not known
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • SSLSocket

        protected SSLSocket(InetAddress address,
         int port)
             throws IOException
        Used only by subclasses. Constructs a TCP connection to a server at a specified address and port. This acts as the SSL client.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        address - the server's host
        port - its port
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        IllegalArgumentException - if the port parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        NullPointerException - if address is null.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • SSLSocket

        protected SSLSocket(String host,
         int port,
         InetAddress clientAddress,
         int clientPort)
             throws IOException,
                    UnknownHostException
        Used only by subclasses. Constructs an SSL connection to a named host at a specified port, binding the client side of the connection a given address and port. This acts as the SSL client.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        host - name of the host with which to connect, or null for the loopback address.
        port - number of the server's port
        clientAddress - the client's address the socket is bound to, or null for the anyLocal address.
        clientPort - the client's port the socket is bound to, or zero for a system selected free port.
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        UnknownHostException - if the host is not known
        IllegalArgumentException - if the port parameter or clientPort parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

      • SSLSocket

        protected SSLSocket(InetAddress address,
         int port,
         InetAddress clientAddress,
         int clientPort)
             throws IOException
        Used only by subclasses. Constructs an SSL connection to a server at a specified address and TCP port, binding the client side of the connection a given address and port. This acts as the SSL client.

        If there is a security manager, its checkConnect method is called with the host address and port as its arguments. This could result in a SecurityException.

        参数：
        address - the server's host
        port - its port
        clientAddress - the client's address the socket is bound to, or null for the anyLocal address.
        clientPort - the client's port the socket is bound to, or zero for a system selected free port.
        抛出：
        IOException - if an I/O error occurs when creating the socket
        SecurityException - if a security manager exists and its checkConnect method doesn't allow the operation.
        IllegalArgumentException - if the port parameter or clientPort parameter is outside the specified range of valid port values, which is between 0 and 65535, inclusive.
        NullPointerException - if address is null.
        另请参见：
        SecurityManager.checkConnect(java.lang.String, int)

    • 方法详细信息

      • getSupportedCipherSuites

        public abstract String[] getSupportedCipherSuites()
        Returns the names of the cipher suites which could be enabled for use on this connection. Normally, only a subset of these will actually be enabled by default, since this list may include cipher suites which do not meet quality of service requirements for those defaults. Such cipher suites might be useful in specialized applications.
        返回：
        an array of cipher suite names
        另请参见：
        getEnabledCipherSuites(), setEnabledCipherSuites(String [])

      • getEnabledCipherSuites

        public abstract String[] getEnabledCipherSuites()
        Returns the names of the SSL cipher suites which are currently enabled for use on this connection. When an SSLSocket is first created, all enabled cipher suites support a minimum quality of service. Thus, in some environments this value might be empty.

        Even if a suite has been enabled, it might never be used. (For example, the peer does not support it, the requisite certificates (and private keys) for the suite are not available, or an anonymous suite is enabled but authentication is required.

        返回：
        an array of cipher suite names
        另请参见：
        getSupportedCipherSuites(), setEnabledCipherSuites(String [])

      • setEnabledCipherSuites

        public abstract void setEnabledCipherSuites(String[] suites)
        Sets the cipher suites enabled for use on this connection.

        Each cipher suite in the suites parameter must have been listed by getSupportedCipherSuites(), or the method will fail. Following a successful call to this method, only suites listed in the suites parameter are enabled for use.

        See getEnabledCipherSuites() for more information on why a specific ciphersuite may never be used on a connection.

        参数：
        suites - Names of all the cipher suites to enable
        抛出：
        IllegalArgumentException - when one or more of the ciphers named by the parameter is not supported, or when the parameter is null.
        另请参见：
        getSupportedCipherSuites(), getEnabledCipherSuites()

      • getSupportedProtocols

        public abstract String[] getSupportedProtocols()
        Returns the names of the protocols which could be enabled for use on an SSL connection.
        返回：
        an array of protocols supported

      • getEnabledProtocols

        public abstract String[] getEnabledProtocols()
        Returns the names of the protocol versions which are currently enabled for use on this connection.
        返回：
        an array of protocols
        另请参见：
        setEnabledProtocols(String [])

      • setEnabledProtocols

        public abstract void setEnabledProtocols(String[] protocols)
        Sets the protocol versions enabled for use on this connection.

        The protocols must have been listed by getSupportedProtocols() as being supported. Following a successful call to this method, only protocols listed in the protocols parameter are enabled for use.

        参数：
        protocols - Names of all the protocols to enable.
        抛出：
        IllegalArgumentException - when one or more of the protocols named by the parameter is not supported or when the protocols parameter is null.
        另请参见：
        getEnabledProtocols()

      • getSession

        public abstract SSLSession getSession()
        Returns the SSL Session in use by this connection. These can be long lived, and frequently correspond to an entire login session for some user. The session specifies a particular cipher suite which is being actively used by all connections in that session, as well as the identities of the session's client and server.

        This method will initiate the initial handshake if necessary and then block until the handshake has been established.

        If an error occurs during the initial handshake, this method returns an invalid session object which reports an invalid cipher suite of "SSL_NULL_WITH_NULL_NULL".

        返回：
        the SSLSession

      • getHandshakeSession

        public SSLSession getHandshakeSession()
        Returns the SSLSession being constructed during a SSL/TLS handshake.

        TLS protocols may negotiate parameters that are needed when using an instance of this class, but before the SSLSession has been completely initialized and made available via getSession. For example, the list of valid signature algorithms may restrict the type of certificates that can used during TrustManager decisions, or the maximum TLS fragment packet sizes can be resized to better support the network environment.

        This method provides early access to the SSLSession being constructed. Depending on how far the handshake has progressed, some data may not yet be available for use. For example, if a remote server will be sending a Certificate chain, but that chain has yet not been processed, the getPeerCertificates method of SSLSession will throw a SSLPeerUnverifiedException. Once that chain has been processed, getPeerCertificates will return the proper value.

        Unlike getSession(), this method does not initiate the initial handshake and does not block until handshaking is complete.

        返回：
        null if this instance is not currently handshaking, or if the current handshake has not progressed far enough to create a basic SSLSession. Otherwise, this method returns the SSLSession currently being negotiated.
        抛出：
        UnsupportedOperationException - if the underlying provider does not implement the operation.
        从以下版本开始：
        1.7
        另请参见：
        SSLEngine, SSLSession, ExtendedSSLSession, X509ExtendedKeyManager, X509ExtendedTrustManager

      • addHandshakeCompletedListener

        public abstract void addHandshakeCompletedListener(HandshakeCompletedListener listener)
        Registers an event listener to receive notifications that an SSL handshake has completed on this connection.
        参数：
        listener - the HandShake Completed event listener
        抛出：
        IllegalArgumentException - if the argument is null.
        另请参见：
        startHandshake(), removeHandshakeCompletedListener(HandshakeCompletedListener)

      • removeHandshakeCompletedListener

        public abstract void removeHandshakeCompletedListener(HandshakeCompletedListener listener)
        Removes a previously registered handshake completion listener.
        参数：
        listener - the HandShake Completed event listener
        抛出：
        IllegalArgumentException - if the listener is not registered, or the argument is null.
        另请参见：
        addHandshakeCompletedListener(HandshakeCompletedListener)

      • startHandshake

        public abstract void startHandshake()
                             throws IOException
        Starts an SSL handshake on this connection. Common reasons include a need to use new encryption keys, to change cipher suites, or to initiate a new session. To force complete reauthentication, the current session could be invalidated before starting this handshake.

        If data has already been sent on the connection, it continues to flow during this handshake. When the handshake completes, this will be signaled with an event. This method is synchronous for the initial handshake on a connection and returns when the negotiated handshake is complete. Some protocols may not support multiple handshakes on an existing socket and may throw an IOException.

        抛出：
        IOException - on a network level error
        另请参见：
        addHandshakeCompletedListener(HandshakeCompletedListener)

      • setUseClientMode

        public abstract void setUseClientMode(boolean mode)
        Configures the socket to use client (or server) mode when handshaking.

        This method must be called before any handshaking occurs. Once handshaking has begun, the mode can not be reset for the life of this socket.

        Servers normally authenticate themselves, and clients are not required to do so.

        参数：
        mode - true if the socket should start its handshaking in "client" mode
        抛出：
        IllegalArgumentException - if a mode change is attempted after the initial handshake has begun.
        另请参见：
        getUseClientMode()

      • getUseClientMode

        public abstract boolean getUseClientMode()
        Returns true if the socket is set to use client mode when handshaking.
        返回：
        true if the socket should do handshaking in "client" mode
        另请参见：
        setUseClientMode(boolean)

      • setNeedClientAuth

        public abstract void setNeedClientAuth(boolean need)
        Configures the socket to require client authentication. This option is only useful for sockets in the server mode.

        A socket's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setWantClientAuth(boolean), if this option is set and the client chooses not to provide authentication information about itself, the negotiations will stop and the connection will be dropped.

        Calling this method overrides any previous setting made by this method or setWantClientAuth(boolean).

        参数：
        need - set to true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • getNeedClientAuth

        public abstract boolean getNeedClientAuth()
        Returns true if the socket will require client authentication. This option is only useful to sockets in the server mode.
        返回：
        true if client authentication is required, or false if no client authentication is desired.
        另请参见：
        setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

      • setWantClientAuth

        public abstract void setWantClientAuth(boolean want)
        Configures the socket to request client authentication. This option is only useful for sockets in the server mode.

        A socket's client authentication setting is one of the following:

        • client authentication required
        • client authentication requested
        • no client authentication desired

        Unlike setNeedClientAuth(boolean), if this option is set and the client chooses not to provide authentication information about itself, the negotiations will continue.

        Calling this method overrides any previous setting made by this method or setNeedClientAuth(boolean).

        参数：
        want - set to true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

      • getWantClientAuth

        public abstract boolean getWantClientAuth()
        Returns true if the socket will request client authentication. This option is only useful for sockets in the server mode.
        返回：
        true if client authentication is requested, or false if no client authentication is desired.
        另请参见：
        setNeedClientAuth(boolean), getNeedClientAuth(), setWantClientAuth(boolean), setUseClientMode(boolean)

      • setEnableSessionCreation

        public abstract void setEnableSessionCreation(boolean flag)
        Controls whether new SSL sessions may be established by this socket. If session creations are not allowed, and there are no existing sessions to resume, there will be no successful handshaking.
        参数：
        flag - true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed
        另请参见：
        getEnableSessionCreation()

      • getEnableSessionCreation

        public abstract boolean getEnableSessionCreation()
        Returns true if new SSL sessions may be established by this socket.
        返回：
        true indicates that sessions may be created; this is the default. false indicates that an existing session must be resumed
        另请参见：
        setEnableSessionCreation(boolean)

      • getSSLParameters

        public SSLParameters getSSLParameters()
        Returns the SSLParameters in effect for this SSLSocket. The ciphersuites and protocols of the returned SSLParameters are always non-null.
        返回：
        the SSLParameters in effect for this SSLSocket.
        从以下版本开始：
        1.6

      • setSSLParameters

        public void setSSLParameters(SSLParameters params)
        Applies SSLParameters to this socket.

        This means:

        • if params.getCipherSuites() is non-null, setEnabledCipherSuites() is called with that value
        • if params.getProtocols() is non-null, setEnabledProtocols() is called with that value
        • if params.getNeedClientAuth() or params.getWantClientAuth() return true, setNeedClientAuth(true) and setWantClientAuth(true) are called, respectively; otherwise setWantClientAuth(false) is called.
        参数：
        params - the parameters
        抛出：
        IllegalArgumentException - if the setEnabledCipherSuites() or the setEnabledProtocols() call fails
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SSLSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 SSLSocketFactory

  • java.lang.Object
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory

  • public abstract class SSLSocketFactory
extends SocketFactory
    SSLSocketFactorys create SSLSockets.
    从以下版本开始：
    1.4
    另请参见：
    SSLSocket

    • 构造方法摘要

      Constructors
      构造方法与描述
      SSLSocketFactory()
      Constructor is used only by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Socket createSocket(Socket s, String host, int port, boolean autoClose)
      Returns a socket layered over an existing socket connected to the named host, at the given port.
      static SocketFactory getDefault()
      Returns the default SSL socket factory.
      abstract String[] getDefaultCipherSuites()
      Returns the list of cipher suites which are enabled by default.
      abstract String[] getSupportedCipherSuites()
      Returns the names of the cipher suites which could be enabled for use on an SSL connection.

      • 方法 - 继承于类 javax.net.SocketFactory

        createSocket, createSocket, createSocket, createSocket, createSocket

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SSLSocketFactory

        public SSLSocketFactory()
        Constructor is used only by subclasses.

    • 方法详细信息

      • getDefault

        public static SocketFactory getDefault()
        Returns the default SSL socket factory.

        The first time this method is called, the security property "ssl.SocketFactory.provider" is examined. If it is non-null, a class by that name is loaded and instantiated. If that is successful and the object is an instance of SSLSocketFactory, it is made the default SSL socket factory.

        Otherwise, this method returns SSLContext.getDefault().getSocketFactory(). If that call fails, an inoperative factory is returned.

        返回：
        the default SocketFactory
        另请参见：
        SSLContext.getDefault()

      • getDefaultCipherSuites

        public abstract String[] getDefaultCipherSuites()
        Returns the list of cipher suites which are enabled by default. Unless a different list is enabled, handshaking on an SSL connection will use one of these cipher suites. The minimum quality of service for these defaults requires confidentiality protection and server authentication (that is, no anonymous cipher suites).
        返回：
        array of the cipher suites enabled by default
        另请参见：
        getSupportedCipherSuites()

      • getSupportedCipherSuites

        public abstract String[] getSupportedCipherSuites()
        Returns the names of the cipher suites which could be enabled for use on an SSL connection. Normally, only a subset of these will actually be enabled by default, since this list may include cipher suites which do not meet quality of service requirements for those defaults. Such cipher suites are useful in specialized applications.
        返回：
        an array of cipher suite names
        另请参见：
        getDefaultCipherSuites()

      • createSocket

        public abstract Socket createSocket(Socket s,
                  String host,
                  int port,
                  boolean autoClose)
                             throws IOException
        Returns a socket layered over an existing socket connected to the named host, at the given port. This constructor can be used when tunneling SSL through a proxy or when negotiating the use of SSL over an existing socket. The host and port refer to the logical peer destination. This socket is configured using the socket options established for this factory.
        参数：
        s - the existing socket
        host - the server host
        port - the server port
        autoClose - close the underlying socket when this socket is closed
        返回：
        a socket connected to the specified host and port
        抛出：
        IOException - if an I/O error occurs when creating the socket
        NullPointerException - if the parameter s is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e= eok=ck=s""=ss dtt/./.xaa/ctg.ecooS.ttrs


TrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.net.ssl

Interface TrustManager

  • All Known Subinterfaces:
    X509TrustManager
    All Known Implementing Classes:
    X509ExtendedTrustManager

    public interface TrustManager
    This is the base interface for JSSE trust managers.

    TrustManagers are responsible for managing the trust material that is used when making trust decisions, and for deciding whether credentials presented by a peer should be accepted.

    TrustManagers are created by either using a TrustManagerFactory, or by implementing one of the TrustManager subclasses.

    从以下版本开始：
    1.4
    另请参见：
    TrustManagerFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/eersi sicppicct oopareh<)o


TrustManagerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 TrustManagerFactory

  • java.lang.Object
    • javax.net.ssl.TrustManagerFactory

  • public class TrustManagerFactory
extends Object
    This class acts as a factory for trust managers based on a source of trust material. Each trust manager manages a specific type of trust material for use by secure sockets. The trust material is based on a KeyStore and/or provider specific sources.
    从以下版本开始：
    1.4
    另请参见：
    TrustManager

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
      Creates a TrustManagerFactory object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAlgorithm()
      Returns the algorithm name of this TrustManagerFactory object.
      static String getDefaultAlgorithm()
      Obtains the default TrustManagerFactory algorithm name.
      static TrustManagerFactory getInstance(String algorithm)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
      static TrustManagerFactory getInstance(String algorithm, Provider provider)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
      static TrustManagerFactory getInstance(String algorithm, String provider)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
      Provider getProvider()
      Returns the provider of this TrustManagerFactory object.
      TrustManager[] getTrustManagers()
      Returns one trust manager for each type of trust material.
      void init(KeyStore ks)
      Initializes this factory with a source of certificate authorities and related trust material.
      void init(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific trust material.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TrustManagerFactory

        protected TrustManagerFactory(TrustManagerFactorySpi factorySpi,
                   Provider provider,
                   String algorithm)
        Creates a TrustManagerFactory object.
        参数：
        factorySpi - the delegate
        provider - the provider
        algorithm - the algorithm

    • 方法详细信息

      • getDefaultAlgorithm

        public static final String getDefaultAlgorithm()
        Obtains the default TrustManagerFactory algorithm name.

        The default TrustManager can be changed at runtime by setting the value of the "ssl.TrustManagerFactory.algorithm" security property (set in the Java security properties file or by calling Security.setProperty(String, String)) to the desired algorithm name.

        返回：
        the default algorithm name as specified in the Java security properties, or an implementation-specific default if no such property exists.

      • getAlgorithm

        public final String getAlgorithm()
        Returns the algorithm name of this TrustManagerFactory object.

        This is the same name that was specified in one of the getInstance calls that created this TrustManagerFactory object.

        返回：
        the algorithm name of this TrustManagerFactory object

      • getInstance

        public static final TrustManagerFactory getInstance(String algorithm)
                                             throws NoSuchAlgorithmException
        Returns a TrustManagerFactory object that acts as a factory for trust managers.

        This method traverses the list of registered security Providers, starting with the most preferred Provider. A new TrustManagerFactory object encapsulating the TrustManagerFactorySpi implementation from the first Provider that supports the specified algorithm is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the standard name of the requested trust management algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        返回：
        the new TrustManagerFactory object.
        抛出：
        NoSuchAlgorithmException - if no Provider supports a TrustManagerFactorySpi implementation for the specified algorithm.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getInstance

        public static final TrustManagerFactory getInstance(String algorithm,
                              String provider)
                                             throws NoSuchAlgorithmException,
                                                    NoSuchProviderException
        Returns a TrustManagerFactory object that acts as a factory for trust managers.

        A new KeyManagerFactory object encapsulating the KeyManagerFactorySpi implementation from the specified provider is returned. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the standard name of the requested trust management algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        provider - the name of the provider.
        返回：
        the new TrustManagerFactory object
        抛出：
        NoSuchAlgorithmException - if a TrustManagerFactorySpi implementation for the specified algorithm is not available from the specified provider.
        NoSuchProviderException - if the specified provider is not registered in the security provider list.
        IllegalArgumentException - if the provider name is null or empty.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getInstance

        public static final TrustManagerFactory getInstance(String algorithm,
                              Provider provider)
                                             throws NoSuchAlgorithmException
        Returns a TrustManagerFactory object that acts as a factory for trust managers.

        A new TrustManagerFactory object encapsulating the TrustManagerFactorySpi implementation from the specified Provider object is returned. Note that the specified Provider object does not have to be registered in the provider list.

        参数：
        algorithm - the standard name of the requested trust management algorithm. See the Java Secure Socket Extension Reference Guide for information about standard algorithm names.
        provider - an instance of the provider.
        返回：
        the new TrustManagerFactory object.
        抛出：
        NoSuchAlgorithmException - if a TrustManagerFactorySpi implementation for the specified algorithm is not available from the specified Provider object.
        IllegalArgumentException - if the provider is null.
        NullPointerException - if algorithm is null.
        另请参见：
        Provider

      • getProvider

        public final Provider getProvider()
        Returns the provider of this TrustManagerFactory object.
        返回：
        the provider of this TrustManagerFactory object

      • init

        public final void init(KeyStore ks)
                throws KeyStoreException
        Initializes this factory with a source of certificate authorities and related trust material.

        The provider typically uses a KeyStore as a basis for making trust decisions.

        For more flexible initialization, please see init(ManagerFactoryParameters).

        参数：
        ks - the key store, or null
        抛出：
        KeyStoreException - if this operation fails

      • init

        public final void init(ManagerFactoryParameters spec)
                throws InvalidAlgorithmParameterException
        Initializes this factory with a source of provider-specific trust material.

        In some cases, initialization parameters other than a keystore may be needed by a provider. Users of that particular provider are expected to pass an implementation of the appropriate ManagerFactoryParameters as defined by the provider. The provider can then call the specified methods in the ManagerFactoryParameters implementation to obtain the needed information.

        参数：
        spec - an implementation of a provider-specific parameter specification
        抛出：
        InvalidAlgorithmParameterException - if an error is encountered

      • getTrustManagers

        public final TrustManager[] getTrustManagers()
        Returns one trust manager for each type of trust material.
        返回：
        the trust managers
        抛出：
        IllegalStateException - if the factory is not initialized.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ai>c,i>i,m<>aiwia./s>舙f/>� yrmrc


TrustManagerFactorySpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 TrustManagerFactorySpi

  • java.lang.Object
    • javax.net.ssl.TrustManagerFactorySpi

  • public abstract class TrustManagerFactorySpi
extends Object
    This class defines the Service Provider Interface (SPI) for the TrustManagerFactory class.

    All the abstract methods in this class must be implemented by each cryptographic service provider who wishes to supply the implementation of a particular trust manager factory.

    从以下版本开始：
    1.4
    另请参见：
    TrustManagerFactory, TrustManager

    • 构造方法摘要

      Constructors
      构造方法与描述
      TrustManagerFactorySpi()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract TrustManager[] engineGetTrustManagers()
      Returns one trust manager for each type of trust material.
      protected abstract void engineInit(KeyStore ks)
      Initializes this factory with a source of certificate authorities and related trust material.
      protected abstract void engineInit(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific key material.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TrustManagerFactorySpi

        public TrustManagerFactorySpi()

    • 方法详细信息

      • engineInit

        protected abstract void engineInit(KeyStore ks)
                            throws KeyStoreException
        Initializes this factory with a source of certificate authorities and related trust material.
        参数：
        ks - the key store or null
        抛出：
        KeyStoreException - if this operation fails
        另请参见：
        TrustManagerFactory.init(KeyStore)

      • engineInit

        protected abstract void engineInit(ManagerFactoryParameters spec)
                            throws InvalidAlgorithmParameterException
        Initializes this factory with a source of provider-specific key material.

        In some cases, initialization parameters other than a keystore may be needed by a provider. Users of that particular provider are expected to pass an implementation of the appropriate ManagerFactoryParameters as defined by the provider. The provider can then call the specified methods in the ManagerFactoryParameters implementation to obtain the needed information.

        参数：
        spec - an implementation of a provider-specific parameter specification
        抛出：
        InvalidAlgorithmParameterException - if there is problem with the parameters
        另请参见：
        TrustManagerFactory.init(ManagerFactoryParameters spec)

      • engineGetTrustManagers

        protected abstract TrustManager[] engineGetTrustManagers()
        Returns one trust manager for each type of trust material.
        返回：
        the trust managers
        抛出：
        IllegalStateException - if the factory is not initialized.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ccorMnranrTuurTTcu==lma lcceijcau . e ia>


Uses of Package javax.net.ssl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.net.ssl

  • Packages that use javax.net.ssl
    软件包 描述
    java.net
    Provides the classes for implementing networking applications.
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.net.ssl
    Provides classes for the secure socket package.
    javax.rmi.ssl
    Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.
  • Classes in javax.net.ssl used by java.net
    类与描述
    SSLPeerUnverifiedException
    Indicates that the peer's identity has not been verified.
  • Classes in javax.net.ssl used by javax.naming.ldap
    类与描述
    HostnameVerifier
    This class is the base interface for hostname verification.
    SSLSession
    In SSL, sessions are used to describe an ongoing relationship between two entities.
    SSLSocketFactory
    SSLSocketFactorys create SSLSockets.
  • Classes in javax.net.ssl used by javax.net.ssl
    类与描述
    HandshakeCompletedEvent
    This event indicates that an SSL handshake completed on a given SSL connection.
    HandshakeCompletedListener
    This interface is implemented by any class which wants to receive notifications about the completion of an SSL protocol handshake on a given SSL connection.
    HostnameVerifier
    This class is the base interface for hostname verification.
    KeyManager
    This is the base interface for JSSE key managers.
    KeyManagerFactory
    This class acts as a factory for key managers based on a source of key material.
    KeyManagerFactorySpi
    This class defines the Service Provider Interface (SPI) for the KeyManagerFactory class.
    ManagerFactoryParameters
    This class is the base interface for providing algorithm-specific information to a KeyManagerFactory or TrustManagerFactory.
    SSLContext
    Instances of this class represent a secure socket protocol implementation which acts as a factory for secure socket factories or SSLEngines.
    SSLContextSpi
    This class defines the Service Provider Interface (SPI) for the SSLContext class.
    SSLEngine
    A class which enables secure communications using protocols such as the Secure Sockets Layer (SSL) or IETF RFC 2246 "Transport Layer Security" (TLS) protocols, but is transport independent.
    SSLEngineResult
    An encapsulation of the result state produced by SSLEngine I/O calls.
    SSLEngineResult.HandshakeStatus
    An SSLEngineResult enum describing the current handshaking state of this SSLEngine.
    SSLEngineResult.Status
    An SSLEngineResult enum describing the overall result of the SSLEngine operation.
    SSLException
    Indicates some kind of error detected by an SSL subsystem.
    SSLParameters
    Encapsulates parameters for an SSL/TLS connection.
    SSLPeerUnverifiedException
    Indicates that the peer's identity has not been verified.
    SSLServerSocketFactory
    SSLServerSocketFactorys create SSLServerSockets.
    SSLSession
    In SSL, sessions are used to describe an ongoing relationship between two entities.
    SSLSessionBindingEvent
    This event is propagated to a SSLSessionBindingListener.
    SSLSessionContext
    A SSLSessionContext represents a set of SSLSessions associated with a single entity.
    SSLSocket
    This class extends Sockets and provides secure socket using protocols such as the "Secure Sockets Layer" (SSL) or IETF "Transport Layer Security" (TLS) protocols.
    SSLSocketFactory
    SSLSocketFactorys create SSLSockets.
    TrustManager
    This is the base interface for JSSE trust managers.
    TrustManagerFactory
    This class acts as a factory for trust managers based on a source of trust material.
    TrustManagerFactorySpi
    This class defines the Service Provider Interface (SPI) for the TrustManagerFactory class.
    X509KeyManager
    Instances of this interface manage which X509 certificate-based key pairs are used to authenticate the local side of a secure socket.
    X509TrustManager
    Instance of this interface manage which X509 certificates may be used to authenticate the remote side of a secure socket.
  • Classes in javax.net.ssl used by javax.rmi.ssl
    类与描述
    SSLContext
    Instances of this class represent a secure socket protocol implementation which acts as a factory for secure socket factories or SSLEngines.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hoig C>T F


X509ExtendedKeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 X509ExtendedKeyManager

  • java.lang.Object
    • javax.net.ssl.X509ExtendedKeyManager
  • 所有已实现的接口：
    KeyManager, X509KeyManager

    public abstract class X509ExtendedKeyManager
extends Object
implements X509KeyManager
    Abstract class that provides for extension of the X509KeyManager interface.

    Methods in this class should be overriden to provide actual implementations.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected X509ExtendedKeyManager()
      Constructor used by subclasses only.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
      Choose an alias to authenticate the client side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
      String chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
      Choose an alias to authenticate the server side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.net.ssl.X509KeyManager

        chooseClientAlias, chooseServerAlias, getCertificateChain, getClientAliases, getPrivateKey, getServerAliases

    • 构造方法详细信息

      • X509ExtendedKeyManager

        protected X509ExtendedKeyManager()
        Constructor used by subclasses only.

    • 方法详细信息

      • chooseEngineClientAlias

        public String chooseEngineClientAlias(String[] keyType,
                             Principal[] issuers,
                             SSLEngine engine)
        Choose an alias to authenticate the client side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

        The default implementation returns null.

        参数：
        keyType - the key algorithm type name(s), ordered with the most-preferred key type first.
        issuers - the list of acceptable CA issuer subject names or null if it does not matter which issuers are used.
        engine - the SSLEngine to be used for this connection. This parameter can be null, which indicates that implementations of this interface are free to select an alias applicable to any engine.
        返回：
        the alias name for the desired key, or null if there are no matches.

      • chooseEngineServerAlias

        public String chooseEngineServerAlias(String keyType,
                             Principal[] issuers,
                             SSLEngine engine)
        Choose an alias to authenticate the server side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

        The default implementation returns null.

        参数：
        keyType - the key algorithm type name.
        issuers - the list of acceptable CA issuer subject names or null if it does not matter which issuers are used.
        engine - the SSLEngine to be used for this connection. This parameter can be null, which indicates that implementations of this interface are free to select an alias applicable to any engine.
        返回：
        the alias name for the desired key, or null if there are no matches.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ >ovdacldo>oyr/


X509ExtendedTrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.net.ssl

类 X509ExtendedTrustManager

  • java.lang.Object
    • javax.net.ssl.X509ExtendedTrustManager
  • 所有已实现的接口：
    TrustManager, X509TrustManager

    public abstract class X509ExtendedTrustManager
extends Object
implements X509TrustManager
    Extensions to the X509TrustManager interface to support SSL/TLS connection sensitive trust management.

    To prevent man-in-the-middle attacks, hostname checks can be done to verify that the hostname in an end-entity certificate matches the targeted hostname. TLS does not require such checks, but some protocols over TLS (such as HTTPS) do. In earlier versions of the JDK, the certificate chain checks were done at the SSL/TLS layer, and the hostname verification checks were done at the layer over TLS. This class allows for the checking to be done during a single call to this class.

    RFC 2830 defines the server identification specification for the "LDAPS" algorithm. RFC 2818 defines both the server identification and the client identification specification for the "HTTPS" algorithm.

    从以下版本开始：
    1.7
    另请参见：
    X509TrustManager, HostnameVerifier

    • 构造方法摘要

      Constructors
      构造方法与描述
      X509ExtendedTrustManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void checkClientTrusted(X509Certificate[] chain, String authType, Socket socket)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
      abstract void checkClientTrusted(X509Certificate[] chain, String authType, SSLEngine engine)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
      abstract void checkServerTrusted(X509Certificate[] chain, String authType, Socket socket)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
      abstract void checkServerTrusted(X509Certificate[] chain, String authType, SSLEngine engine)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.net.ssl.X509TrustManager

        checkClientTrusted, checkServerTrusted, getAcceptedIssuers

    • 构造方法详细信息

      • X509ExtendedTrustManager

        public X509ExtendedTrustManager()

    • 方法详细信息

      • checkClientTrusted

        public abstract void checkClientTrusted(X509Certificate[] chain,
                      String authType,
                      Socket socket)
                                 throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.

        The authentication type is determined by the actual certificate used. For instance, if RSAPublicKey is used, the authType should be "RSA". Checking is case-sensitive.

        If the socket parameter is an instance of SSLSocket, and the endpoint identification algorithm of the SSLParameters is non-empty, to prevent man-in-the-middle attacks, the address that the socket connected to should be checked against the peer's identity presented in the end-entity X509 certificate, as specified in the endpoint identification algorithm.

        If the socket parameter is an instance of SSLSocket, and the algorithm constraints of the SSLParameters is non-null, for every certificate in the certification path, fields such as subject public key, the signature algorithm, key usage, extended key usage, etc. need to conform to the algorithm constraints in place on this socket.

        参数：
        chain - the peer certificate chain
        authType - the key exchange algorithm used
        socket - the socket used for this connection. This parameter can be null, which indicates that implementations need not check the ssl parameters
        抛出：
        IllegalArgumentException - if null or zero-length array is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager
        另请参见：
        SSLParameters.getEndpointIdentificationAlgorithm(),
SSLParameters.setEndpointIdentificationAlgorithm(String),
SSLParameters.getAlgorithmConstraints(),
SSLParameters.setAlgorithmConstraints(AlgorithmConstraints)

      • checkServerTrusted

        public abstract void checkServerTrusted(X509Certificate[] chain,
                      String authType,
                      Socket socket)
                                 throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.

        The authentication type is the key exchange algorithm portion of the cipher suites represented as a String, such as "RSA", "DHE_DSS". Note: for some exportable cipher suites, the key exchange algorithm is determined at run time during the handshake. For instance, for TLS_RSA_EXPORT_WITH_RC4_40_MD5, the authType should be RSA_EXPORT when an ephemeral RSA key is used for the key exchange, and RSA when the key from the server certificate is used. Checking is case-sensitive.

        If the socket parameter is an instance of SSLSocket, and the endpoint identification algorithm of the SSLParameters is non-empty, to prevent man-in-the-middle attacks, the address that the socket connected to should be checked against the peer's identity presented in the end-entity X509 certificate, as specified in the endpoint identification algorithm.

        If the socket parameter is an instance of SSLSocket, and the algorithm constraints of the SSLParameters is non-null, for every certificate in the certification path, fields such as subject public key, the signature algorithm, key usage, extended key usage, etc. need to conform to the algorithm constraints in place on this socket.

        参数：
        chain - the peer certificate chain
        authType - the key exchange algorithm used
        socket - the socket used for this connection. This parameter can be null, which indicates that implementations need not check the ssl parameters
        抛出：
        IllegalArgumentException - if null or zero-length array is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager
        另请参见：
        SSLParameters.getEndpointIdentificationAlgorithm(),
SSLParameters.setEndpointIdentificationAlgorithm(String),
SSLParameters.getAlgorithmConstraints(),
SSLParameters.setAlgorithmConstraints(AlgorithmConstraints)

      • checkClientTrusted

        public abstract void checkClientTrusted(X509Certificate[] chain,
                      String authType,
                      SSLEngine engine)
                                 throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.

        The authentication type is determined by the actual certificate used. For instance, if RSAPublicKey is used, the authType should be "RSA". Checking is case-sensitive.

        If the engine parameter is available, and the endpoint identification algorithm of the SSLParameters is non-empty, to prevent man-in-the-middle attacks, the address that the engine connected to should be checked against the peer's identity presented in the end-entity X509 certificate, as specified in the endpoint identification algorithm.

        If the engine parameter is available, and the algorithm constraints of the SSLParameters is non-null, for every certificate in the certification path, fields such as subject public key, the signature algorithm, key usage, extended key usage, etc. need to conform to the algorithm constraints in place on this engine.

        参数：
        chain - the peer certificate chain
        authType - the key exchange algorithm used
        engine - the engine used for this connection. This parameter can be null, which indicates that implementations need not check the ssl parameters
        抛出：
        IllegalArgumentException - if null or zero-length array is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager
        另请参见：
        SSLParameters.getEndpointIdentificationAlgorithm(),
SSLParameters.setEndpointIdentificationAlgorithm(String),
SSLParameters.getAlgorithmConstraints(),
SSLParameters.setAlgorithmConstraints(AlgorithmConstraints)

      • checkServerTrusted

        public abstract void checkServerTrusted(X509Certificate[] chain,
                      String authType,
                      SSLEngine engine)
                                 throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.

        The authentication type is the key exchange algorithm portion of the cipher suites represented as a String, such as "RSA", "DHE_DSS". Note: for some exportable cipher suites, the key exchange algorithm is determined at run time during the handshake. For instance, for TLS_RSA_EXPORT_WITH_RC4_40_MD5, the authType should be RSA_EXPORT when an ephemeral RSA key is used for the key exchange, and RSA when the key from the server certificate is used. Checking is case-sensitive.

        If the engine parameter is available, and the endpoint identification algorithm of the SSLParameters is non-empty, to prevent man-in-the-middle attacks, the address that the engine connected to should be checked against the peer's identity presented in the end-entity X509 certificate, as specified in the endpoint identification algorithm.

        If the engine parameter is available, and the algorithm constraints of the SSLParameters is non-null, for every certificate in the certification path, fields such as subject public key, the signature algorithm, key usage, extended key usage, etc. need to conform to the algorithm constraints in place on this engine.

        参数：
        chain - the peer certificate chain
        authType - the key exchange algorithm used
        engine - the engine used for this connection. This parameter can be null, which indicates that implementations need not check the ssl parameters
        抛出：
        IllegalArgumentException - if null or zero-length array is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager
        另请参见：
        SSLParameters.getEndpointIdentificationAlgorithm(),
SSLParameters.setEndpointIdentificationAlgorithm(String),
SSLParameters.getAlgorithmConstraints(),
SSLParameters.setAlgorithmConstraints(AlgorithmConstraints)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Aeeit� ;a�&s/e


X509KeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface X509KeyManager

  • All Superinterfaces:
    KeyManager
    All Known Implementing Classes:
    X509ExtendedKeyManager

    public interface X509KeyManager
extends KeyManager
    Instances of this interface manage which X509 certificate-based key pairs are used to authenticate the local side of a secure socket.

    During secure socket negotiations, implentations call methods in this interface to:

    • determine the set of aliases that are available for negotiations based on the criteria presented,
    • select the best alias based on the criteria presented, and
    • obtain the corresponding key material for given aliases.

    Note: the X509ExtendedKeyManager should be used in favor of this class.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket)
      Choose an alias to authenticate the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
      String chooseServerAlias(String keyType, Principal[] issuers, Socket socket)
      Choose an alias to authenticate the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
      X509Certificate[] getCertificateChain(String alias)
      Returns the certificate chain associated with the given alias.
      String[] getClientAliases(String keyType, Principal[] issuers)
      Get the matching aliases for authenticating the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
      PrivateKey getPrivateKey(String alias)
      Returns the key associated with the given alias.
      String[] getServerAliases(String keyType, Principal[] issuers)
      Get the matching aliases for authenticating the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

    • 方法详细信息

      • getClientAliases

        String[] getClientAliases(String keyType,
                        Principal[] issuers)
        Get the matching aliases for authenticating the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
        参数：
        keyType - the key algorithm type name
        issuers - the list of acceptable CA issuer subject names, or null if it does not matter which issuers are used.
        返回：
        an array of the matching alias names, or null if there were no matches.

      • chooseClientAlias

        String chooseClientAlias(String[] keyType,
                       Principal[] issuers,
                       Socket socket)
        Choose an alias to authenticate the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
        参数：
        keyType - the key algorithm type name(s), ordered with the most-preferred key type first.
        issuers - the list of acceptable CA issuer subject names or null if it does not matter which issuers are used.
        socket - the socket to be used for this connection. This parameter can be null, which indicates that implementations are free to select an alias applicable to any socket.
        返回：
        the alias name for the desired key, or null if there are no matches.

      • getServerAliases

        String[] getServerAliases(String keyType,
                        Principal[] issuers)
        Get the matching aliases for authenticating the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
        参数：
        keyType - the key algorithm type name
        issuers - the list of acceptable CA issuer subject names or null if it does not matter which issuers are used.
        返回：
        an array of the matching alias names, or null if there were no matches.

      • chooseServerAlias

        String chooseServerAlias(String keyType,
                       Principal[] issuers,
                       Socket socket)
        Choose an alias to authenticate the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
        参数：
        keyType - the key algorithm type name.
        issuers - the list of acceptable CA issuer subject names or null if it does not matter which issuers are used.
        socket - the socket to be used for this connection. This parameter can be null, which indicates that implementations are free to select an alias applicable to any socket.
        返回：
        the alias name for the desired key, or null if there are no matches.

      • getCertificateChain

        X509Certificate[] getCertificateChain(String alias)
        Returns the certificate chain associated with the given alias.
        参数：
        alias - the alias name
        返回：
        the certificate chain (ordered with the user's certificate first and the root certificate authority last), or null if the alias can't be found.

      • getPrivateKey

        PrivateKey getPrivateKey(String alias)
        Returns the key associated with the given alias.
        参数：
        alias - the alias name
        返回：
        the requested key, or null if the alias can't be found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toiiCreerecrreccra== gn Tohen e/


X509TrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.net.ssl

Interface X509TrustManager

  • All Superinterfaces:
    TrustManager
    All Known Implementing Classes:
    X509ExtendedTrustManager

    public interface X509TrustManager
extends TrustManager
    Instance of this interface manage which X509 certificates may be used to authenticate the remote side of a secure socket. Decisions may be based on trusted certificate authorities, certificate revocation lists, online status checking or other means.
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void checkClientTrusted(X509Certificate[] chain, String authType)
      Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for client SSL authentication based on the authentication type.
      void checkServerTrusted(X509Certificate[] chain, String authType)
      Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for server SSL authentication based on the authentication type.
      X509Certificate[] getAcceptedIssuers()
      Return an array of certificate authority certificates which are trusted for authenticating peers.

    • 方法详细信息

      • checkClientTrusted

        void checkClientTrusted(X509Certificate[] chain,
                      String authType)
                        throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for client SSL authentication based on the authentication type.

        The authentication type is determined by the actual certificate used. For instance, if RSAPublicKey is used, the authType should be "RSA". Checking is case-sensitive.

        参数：
        chain - the peer certificate chain
        authType - the authentication type based on the client certificate
        抛出：
        IllegalArgumentException - if null or zero-length chain is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager.

      • checkServerTrusted

        void checkServerTrusted(X509Certificate[] chain,
                      String authType)
                        throws CertificateException
        Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for server SSL authentication based on the authentication type.

        The authentication type is the key exchange algorithm portion of the cipher suites represented as a String, such as "RSA", "DHE_DSS". Note: for some exportable cipher suites, the key exchange algorithm is determined at run time during the handshake. For instance, for TLS_RSA_EXPORT_WITH_RC4_40_MD5, the authType should be RSA_EXPORT when an ephemeral RSA key is used for the key exchange, and RSA when the key from the server certificate is used. Checking is case-sensitive.

        参数：
        chain - the peer certificate chain
        authType - the key exchange algorithm used
        抛出：
        IllegalArgumentException - if null or zero-length chain is passed in for the chain parameter or if null or zero-length string is passed in for the authType parameter
        CertificateException - if the certificate chain is not trusted by this TrustManager.

      • getAcceptedIssuers

        X509Certificate[] getAcceptedIssuers()
        Return an array of certificate authority certificates which are trusted for authenticating peers.
        返回：
        a non-null (possibly empty) array of acceptable CA issuer certificates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orsblsiasidvviddrc<< < < . //


Uses of Class javax.net.ssl.CertPathTrustManagerParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.CertPathTrustManagerParameters

No usage of javax.net.ssl.CertPathTrustManagerParameters
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.aeyspee st


Uses of Class javax.net.ssl.ExtendedSSLSession

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.ExtendedSSLSession

No usage of javax.net.ssl.ExtendedSSLSession
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.net.ssl.HandshakeCompletedEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.HandshakeCompletedEvent

  • Packages that use HandshakeCompletedEvent
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of HandshakeCompletedEvent in javax.net.ssl

      Methods in javax.net.ssl with parameters of type HandshakeCompletedEvent
      修饰符与类型 方法与描述
      void HandshakeCompletedListener.handshakeCompleted(HandshakeCompletedEvent event)
      This method is invoked on registered objects when a SSL handshake is completed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e眡>xsa/tj


Uses of Class javax.net.ssl.HttpsURLConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.HttpsURLConnection

No usage of javax.net.ssl.HttpsURLConnection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>n yisshde


Uses of Class javax.net.ssl.KeyManagerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.KeyManagerFactory

  • Packages that use KeyManagerFactory
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of KeyManagerFactory in javax.net.ssl

      Methods in javax.net.ssl that return KeyManagerFactory
      修饰符与类型 方法与描述
      static KeyManagerFactory KeyManagerFactory.getInstance(String algorithm)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
      static KeyManagerFactory KeyManagerFactory.getInstance(String algorithm, Provider provider)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
      static KeyManagerFactory KeyManagerFactory.getInstance(String algorithm, String provider)
      Returns a KeyManagerFactory object that acts as a factory for key managers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i"niitllm""".tnnyk[g>p<,.


Uses of Class javax.net.ssl.KeyManagerFactorySpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.KeyManagerFactorySpi

  • Packages that use KeyManagerFactorySpi
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of KeyManagerFactorySpi in javax.net.ssl

      Constructors in javax.net.ssl with parameters of type KeyManagerFactorySpi
      构造方法与描述
      KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
      Creates a KeyManagerFactory object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<./iiaapa&e<


Uses of Class javax.net.ssl.KeyStoreBuilderParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.KeyStoreBuilderParameters

No usage of javax.net.ssl.KeyStoreBuilderParameters
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hc>- ><<


Uses of Class javax.net.ssl.SSLContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLContext

  • Packages that use SSLContext
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.
    javax.rmi.ssl
    Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

    • Uses of SSLContext in javax.net.ssl

      Methods in javax.net.ssl that return SSLContext
      修饰符与类型 方法与描述
      static SSLContext SSLContext.getDefault()
      Returns the default SSL context.
      static SSLContext SSLContext.getInstance(String protocol)
      Returns a SSLContext object that implements the specified secure socket protocol.
      static SSLContext SSLContext.getInstance(String protocol, Provider provider)
      Returns a SSLContext object that implements the specified secure socket protocol.
      static SSLContext SSLContext.getInstance(String protocol, String provider)
      Returns a SSLContext object that implements the specified secure socket protocol.
      Methods in javax.net.ssl with parameters of type SSLContext
      修饰符与类型 方法与描述
      static void SSLContext.setDefault(SSLContext context)
      Sets the default SSL context.

    • Uses of SSLContext in javax.rmi.ssl

      Constructors in javax.rmi.ssl with parameters of type SSLContext
      构造方法与描述
      SslRMIServerSocketFactory(SSLContext context, String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
      Creates a new SslRMIServerSocketFactory with the specified SSLContext and SSL socket configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

egoe//>rng>mtld


Uses of Class javax.net.ssl.SSLContextSpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLContextSpi

  • Packages that use SSLContextSpi
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLContextSpi in javax.net.ssl

      Constructors in javax.net.ssl with parameters of type SSLContextSpi
      构造方法与描述
      SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
      Creates an SSLContext object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/rgspac eee"pddsuicc st


Uses of Class javax.net.ssl.SSLEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLEngine

  • Packages that use SSLEngine
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLEngine in javax.net.ssl

      Methods in javax.net.ssl that return SSLEngine
      修饰符与类型 方法与描述
      SSLEngine SSLContext.createSSLEngine()
      Creates a new SSLEngine using this context.
      SSLEngine SSLContext.createSSLEngine(String peerHost, int peerPort)
      Creates a new SSLEngine using this context using advisory peer information.
      protected abstract SSLEngine SSLContextSpi.engineCreateSSLEngine()
      Creates a new SSLEngine using this context.
      protected abstract SSLEngine SSLContextSpi.engineCreateSSLEngine(String host, int port)
      Creates a SSLEngine using this context.
      Methods in javax.net.ssl with parameters of type SSLEngine
      修饰符与类型 方法与描述
      abstract void X509ExtendedTrustManager.checkClientTrusted(X509Certificate[] chain, String authType, SSLEngine engine)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
      abstract void X509ExtendedTrustManager.checkServerTrusted(X509Certificate[] chain, String authType, SSLEngine engine)
      Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
      String X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
      Choose an alias to authenticate the client side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
      String X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
      Choose an alias to authenticate the server side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aeegayrsui<"cait


Uses of Class javax.net.ssl.SSLEngineResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLEngineResult

  • Packages that use SSLEngineResult
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLEngineResult in javax.net.ssl

      Methods in javax.net.ssl that return SSLEngineResult
      修饰符与类型 方法与描述
      SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst)
      Attempts to decode SSL/TLS network data into a plaintext application data buffer.
      SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts)
      Attempts to decode SSL/TLS network data into a sequence of plaintext application data buffers.
      abstract SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length)
      Attempts to decode SSL/TLS network data into a subsequence of plaintext application data buffers.
      SSLEngineResult SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst)
      Attempts to encode plaintext bytes from a sequence of data buffers into SSL/TLS network data.
      abstract SSLEngineResult SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst)
      Attempts to encode plaintext bytes from a subsequence of data buffers into SSL/TLS network data.
      SSLEngineResult SSLEngine.wrap(ByteBuffer src, ByteBuffer dst)
      Attempts to encode a buffer of plaintext application data into SSL/TLS network data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nbat<-"b_wtt s.a-os觓tas


Uses of Class javax.net.ssl.SSLEngineResult.HandshakeStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLEngineResult.HandshakeStatus

  • Packages that use SSLEngineResult.HandshakeStatus
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLEngineResult.HandshakeStatus in javax.net.ssl

      Methods in javax.net.ssl that return SSLEngineResult.HandshakeStatus
      修饰符与类型 方法与描述
      SSLEngineResult.HandshakeStatus SSLEngineResult.getHandshakeStatus()
      Gets the handshake status of this SSLEngine operation.
      abstract SSLEngineResult.HandshakeStatus SSLEngine.getHandshakeStatus()
      Returns the current handshake status for this SSLEngine.
      static SSLEngineResult.HandshakeStatus SSLEngineResult.HandshakeStatus.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SSLEngineResult.HandshakeStatus[] SSLEngineResult.HandshakeStatus.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.net.ssl with parameters of type SSLEngineResult.HandshakeStatus
      构造方法与描述
      SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
      Initializes a new instance of this class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h.tPuri/asssj.aascasesanl


Uses of Class javax.net.ssl.SSLEngineResult.Status

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLEngineResult.Status

  • Packages that use SSLEngineResult.Status
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLEngineResult.Status in javax.net.ssl

      Methods in javax.net.ssl that return SSLEngineResult.Status
      修饰符与类型 方法与描述
      SSLEngineResult.Status SSLEngineResult.getStatus()
      Gets the return value of this SSLEngine operation.
      static SSLEngineResult.Status SSLEngineResult.Status.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SSLEngineResult.Status[] SSLEngineResult.Status.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.net.ssl with parameters of type SSLEngineResult.Status
      构造方法与描述
      SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
      Initializes a new instance of this class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/sc>S<


Uses of Class javax.net.ssl.SSLException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLException

  • Packages that use SSLException
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLException in javax.net.ssl

      Subclasses of SSLException in javax.net.ssl
      修饰符与类型 类与描述
      class  SSLHandshakeException
      Indicates that the client and server could not negotiate the desired level of security.
      class  SSLKeyException
      Reports a bad SSL key.
      class  SSLPeerUnverifiedException
      Indicates that the peer's identity has not been verified.
      class  SSLProtocolException
      Reports an error in the operation of the SSL protocol.
      Methods in javax.net.ssl that throw SSLException
      修饰符与类型 方法与描述
      abstract void SSLEngine.beginHandshake()
      Initiates handshaking (initial or renegotiation) on this SSLEngine.
      abstract void SSLEngine.closeInbound()
      Signals that no more inbound network data will be sent to this SSLEngine.
      SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst)
      Attempts to decode SSL/TLS network data into a plaintext application data buffer.
      SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts)
      Attempts to decode SSL/TLS network data into a sequence of plaintext application data buffers.
      abstract SSLEngineResult SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length)
      Attempts to decode SSL/TLS network data into a subsequence of plaintext application data buffers.
      SSLEngineResult SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst)
      Attempts to encode plaintext bytes from a sequence of data buffers into SSL/TLS network data.
      abstract SSLEngineResult SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst)
      Attempts to encode plaintext bytes from a subsequence of data buffers into SSL/TLS network data.
      SSLEngineResult SSLEngine.wrap(ByteBuffer src, ByteBuffer dst)
      Attempts to encode a buffer of plaintext application data into SSL/TLS network data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttyo/slajeba/o鈙wo/


Uses of Class javax.net.ssl.SSLHandshakeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLHandshakeException

No usage of javax.net.ssl.SSLHandshakeException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.d<<


Uses of Class javax.net.ssl.SSLKeyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLKeyException

No usage of javax.net.ssl.SSLKeyException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"sRo>T>g莞be3&pa癰bi


Uses of Class javax.net.ssl.SSLParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLParameters

  • Packages that use SSLParameters
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLParameters in javax.net.ssl

      Methods in javax.net.ssl that return SSLParameters
      修饰符与类型 方法与描述
      protected SSLParameters SSLContextSpi.engineGetDefaultSSLParameters()
      Returns a copy of the SSLParameters indicating the default settings for this SSL context.
      protected SSLParameters SSLContextSpi.engineGetSupportedSSLParameters()
      Returns a copy of the SSLParameters indicating the maximum supported settings for this SSL context.
      SSLParameters SSLContext.getDefaultSSLParameters()
      Returns a copy of the SSLParameters indicating the default settings for this SSL context.
      SSLParameters SSLServerSocket.getSSLParameters()
      Returns the SSLParameters in effect for newly accepted connections.
      SSLParameters SSLSocket.getSSLParameters()
      Returns the SSLParameters in effect for this SSLSocket.
      SSLParameters SSLEngine.getSSLParameters()
      Returns the SSLParameters in effect for this SSLEngine.
      SSLParameters SSLContext.getSupportedSSLParameters()
      Returns a copy of the SSLParameters indicating the supported settings for this SSL context.
      Methods in javax.net.ssl with parameters of type SSLParameters
      修饰符与类型 方法与描述
      void SSLServerSocket.setSSLParameters(SSLParameters params)
      Applies SSLParameters to newly accepted connections.
      void SSLSocket.setSSLParameters(SSLParameters params)
      Applies SSLParameters to this socket.
      void SSLEngine.setSSLParameters(SSLParameters params)
      Applies SSLParameters to this engine.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.a=esb"lap.t"es-


Uses of Class javax.net.ssl.SSLPeerUnverifiedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLPeerUnverifiedException

  • Packages that use SSLPeerUnverifiedException
    软件包 描述
    java.net
    Provides the classes for implementing networking applications.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLPeerUnverifiedException in java.net

      Methods in java.net that throw SSLPeerUnverifiedException
      修饰符与类型 方法与描述
      abstract Principal SecureCacheResponse.getPeerPrincipal()
      Returns the server's principal which was established as part of defining the session during the original connection that retrieved the network resource.
      abstract List<Certificate> SecureCacheResponse.getServerCertificateChain()
      Returns the server's certificate chain, which was established as part of defining the session in the original connection that retrieved the network resource, from cache.

    • Uses of SSLPeerUnverifiedException in javax.net.ssl

      Methods in javax.net.ssl that throw SSLPeerUnverifiedException
      修饰符与类型 方法与描述
      X509Certificate[] HandshakeCompletedEvent.getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.
      X509Certificate[] SSLSession.getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.
      Certificate[] HandshakeCompletedEvent.getPeerCertificates()
      Returns the identity of the peer which was established as part of defining the session.
      Certificate[] SSLSession.getPeerCertificates()
      Returns the identity of the peer which was established as part of defining the session.
      Principal HttpsURLConnection.getPeerPrincipal()
      Returns the server's principal which was established as part of defining the session.
      Principal HandshakeCompletedEvent.getPeerPrincipal()
      Returns the identity of the peer which was established as part of defining the session.
      Principal SSLSession.getPeerPrincipal()
      Returns the identity of the peer which was established as part of defining the session.
      abstract Certificate[] HttpsURLConnection.getServerCertificates()
      Returns the server's certificate chain which was established as part of defining the session.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>cut.ma(t.t s/a瞔<.e"r" o


Uses of Class javax.net.ssl.SSLPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLPermission

No usage of javax.net.ssl.SSLPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e<<


Uses of Class javax.net.ssl.SSLProtocolException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLProtocolException

No usage of javax.net.ssl.SSLProtocolException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cothr>drs hiaec�


Uses of Class javax.net.ssl.SSLServerSocket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLServerSocket

No usage of javax.net.ssl.SSLServerSocket
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/ab;1;p-1


Uses of Class javax.net.ssl.SSLServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLServerSocketFactory

  • Packages that use SSLServerSocketFactory
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLServerSocketFactory in javax.net.ssl

      Methods in javax.net.ssl that return SSLServerSocketFactory
      修饰符与类型 方法与描述
      protected abstract SSLServerSocketFactory SSLContextSpi.engineGetServerSocketFactory()
      Returns a ServerSocketFactory object for this context.
      SSLServerSocketFactory SSLContext.getServerSocketFactory()
      Returns a ServerSocketFactory object for this context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>..lra�/ -t"ivi sd .l


Uses of Class javax.net.ssl.SSLSessionBindingEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLSessionBindingEvent

  • Packages that use SSLSessionBindingEvent
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLSessionBindingEvent in javax.net.ssl

      Methods in javax.net.ssl with parameters of type SSLSessionBindingEvent
      修饰符与类型 方法与描述
      void SSLSessionBindingListener.valueBound(SSLSessionBindingEvent event)
      This is called to notify the listener that it is being bound into an SSLSession.
      void SSLSessionBindingListener.valueUnbound(SSLSessionBindingEvent event)
      This is called to notify the listener that it is being unbound from a SSLSession.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>rn.


Uses of Class javax.net.ssl.SSLSocket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLSocket

  • Packages that use SSLSocket
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLSocket in javax.net.ssl

      Methods in javax.net.ssl that return SSLSocket
      修饰符与类型 方法与描述
      SSLSocket HandshakeCompletedEvent.getSocket()
      Returns the socket which is the source of this event.
      Constructors in javax.net.ssl with parameters of type SSLSocket
      构造方法与描述
      HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
      Constructs a new HandshakeCompletedEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=l/jatav///je..l""" =ss=l


Uses of Class javax.net.ssl.SSLSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.SSLSocketFactory

  • Packages that use SSLSocketFactory
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLSocketFactory in javax.naming.ldap

      Methods in javax.naming.ldap with parameters of type SSLSocketFactory
      修饰符与类型 方法与描述
      abstract SSLSession StartTlsResponse.negotiate(SSLSocketFactory factory)
      Negotiates a TLS session using an SSL socket factory.

    • Uses of SSLSocketFactory in javax.net.ssl

      Methods in javax.net.ssl that return SSLSocketFactory
      修饰符与类型 方法与描述
      protected abstract SSLSocketFactory SSLContextSpi.engineGetSocketFactory()
      Returns a SocketFactory object for this context.
      static SSLSocketFactory HttpsURLConnection.getDefaultSSLSocketFactory()
      Gets the default static SSLSocketFactory that is inherited by new instances of this class.
      SSLSocketFactory SSLContext.getSocketFactory()
      Returns a SocketFactory object for this context.
      SSLSocketFactory HttpsURLConnection.getSSLSocketFactory()
      Gets the SSL socket factory to be used when creating sockets for secure https URL connections.
      Methods in javax.net.ssl with parameters of type SSLSocketFactory
      修饰符与类型 方法与描述
      static void HttpsURLConnection.setDefaultSSLSocketFactory(SSLSocketFactory sf)
      Sets the default SSLSocketFactory inherited by new instances of this class.
      void HttpsURLConnection.setSSLSocketFactory(SSLSocketFactory sf)
      Sets the SSLSocketFactory to be used when this instance creates sockets for secure https URL connections.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1lci


Uses of Class javax.net.ssl.TrustManagerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.TrustManagerFactory

  • Packages that use TrustManagerFactory
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of TrustManagerFactory in javax.net.ssl

      Methods in javax.net.ssl that return TrustManagerFactory
      修饰符与类型 方法与描述
      static TrustManagerFactory TrustManagerFactory.getInstance(String algorithm)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
      static TrustManagerFactory TrustManagerFactory.getInstance(String algorithm, Provider provider)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
      static TrustManagerFactory TrustManagerFactory.getInstance(String algorithm, String provider)
      Returns a TrustManagerFactory object that acts as a factory for trust managers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la/v/....///.ass reeiea.


Uses of Class javax.net.ssl.TrustManagerFactorySpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.TrustManagerFactorySpi

  • Packages that use TrustManagerFactorySpi
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of TrustManagerFactorySpi in javax.net.ssl

      Constructors in javax.net.ssl with parameters of type TrustManagerFactorySpi
      构造方法与描述
      TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
      Creates a TrustManagerFactory object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tnro父o


Uses of Class javax.net.ssl.X509ExtendedKeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.X509ExtendedKeyManager

No usage of javax.net.ssl.X509ExtendedKeyManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pn tttora___a"<<<=sv-


Uses of Class javax.net.ssl.X509ExtendedTrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.net.ssl.X509ExtendedTrustManager

No usage of javax.net.ssl.X509ExtendedTrustManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9rp sa鬿 llCk.nm�"is


Uses of Interface javax.net.ssl.HandshakeCompletedListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.HandshakeCompletedListener

  • Packages that use HandshakeCompletedListener
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of HandshakeCompletedListener in javax.net.ssl

      Methods in javax.net.ssl with parameters of type HandshakeCompletedListener
      修饰符与类型 方法与描述
      abstract void SSLSocket.addHandshakeCompletedListener(HandshakeCompletedListener listener)
      Registers an event listener to receive notifications that an SSL handshake has completed on this connection.
      abstract void SSLSocket.removeHandshakeCompletedListener(HandshakeCompletedListener listener)
      Removes a previously registered handshake completion listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n e


Uses of Interface javax.net.ssl.HostnameVerifier

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.HostnameVerifier

  • Packages that use HostnameVerifier
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of HostnameVerifier in javax.naming.ldap

      Methods in javax.naming.ldap with parameters of type HostnameVerifier
      修饰符与类型 方法与描述
      abstract void StartTlsResponse.setHostnameVerifier(HostnameVerifier verifier)
      Sets the hostname verifier used by negotiate() after the TLS handshake has completed and the default hostname verification has failed.

    • Uses of HostnameVerifier in javax.net.ssl

      Fields in javax.net.ssl declared as HostnameVerifier
      修饰符与类型 字段与描述
      protected HostnameVerifier HttpsURLConnection.hostnameVerifier
      The hostnameVerifier for this object.
      Methods in javax.net.ssl that return HostnameVerifier
      修饰符与类型 方法与描述
      static HostnameVerifier HttpsURLConnection.getDefaultHostnameVerifier()
      Gets the default HostnameVerifier that is inherited by new instances of this class.
      HostnameVerifier HttpsURLConnection.getHostnameVerifier()
      Gets the HostnameVerifier in place on this instance.
      Methods in javax.net.ssl with parameters of type HostnameVerifier
      修饰符与类型 方法与描述
      static void HttpsURLConnection.setDefaultHostnameVerifier(HostnameVerifier v)
      Sets the default HostnameVerifier inherited by a new instance of this class.
      void HttpsURLConnection.setHostnameVerifier(HostnameVerifier v)
      Sets the HostnameVerifier for this instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ftu <"f=Mut}芿rnpx_


Uses of Interface javax.net.ssl.KeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.KeyManager

  • Packages that use KeyManager
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of KeyManager in javax.net.ssl

      Subinterfaces of KeyManager in javax.net.ssl
      修饰符与类型 Interface and Description
      interface  X509KeyManager
      Instances of this interface manage which X509 certificate-based key pairs are used to authenticate the local side of a secure socket.
      Classes in javax.net.ssl that implement KeyManager
      修饰符与类型 类与描述
      class  X509ExtendedKeyManager
      Abstract class that provides for extension of the X509KeyManager interface.
      Methods in javax.net.ssl that return KeyManager
      修饰符与类型 方法与描述
      protected abstract KeyManager[] KeyManagerFactorySpi.engineGetKeyManagers()
      Returns one key manager for each type of key material.
      KeyManager[] KeyManagerFactory.getKeyManagers()
      Returns one key manager for each type of key material.
      Methods in javax.net.ssl with parameters of type KeyManager
      修饰符与类型 方法与描述
      protected abstract void SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr)
      Initializes this context.
      void SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random)
      Initializes this context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aFbs lel"Ssl> !=r->/ -N


Uses of Interface javax.net.ssl.ManagerFactoryParameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.ManagerFactoryParameters

  • Packages that use ManagerFactoryParameters
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of ManagerFactoryParameters in javax.net.ssl

      Classes in javax.net.ssl that implement ManagerFactoryParameters
      修饰符与类型 类与描述
      class  CertPathTrustManagerParameters
      A wrapper for CertPathParameters.
      class  KeyStoreBuilderParameters
      A parameters object for X509KeyManagers that encapsulates a List of KeyStore.Builders.
      Methods in javax.net.ssl with parameters of type ManagerFactoryParameters
      修饰符与类型 方法与描述
      protected abstract void TrustManagerFactorySpi.engineInit(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific key material.
      protected abstract void KeyManagerFactorySpi.engineInit(ManagerFactoryParameters spec)
      Initializes this factory with a source of key material.
      void TrustManagerFactory.init(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific trust material.
      void KeyManagerFactory.init(ManagerFactoryParameters spec)
      Initializes this factory with a source of provider-specific key material.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

axh""ldil""ce entr.�


Uses of Interface javax.net.ssl.SSLSession

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.SSLSession

  • Packages that use SSLSession
    软件包 描述
    javax.naming.ldap
    Provides support for LDAPv3 extended operations and controls.
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLSession in javax.naming.ldap

      Methods in javax.naming.ldap that return SSLSession
      修饰符与类型 方法与描述
      abstract SSLSession StartTlsResponse.negotiate()
      Negotiates a TLS session using the default SSL socket factory.
      abstract SSLSession StartTlsResponse.negotiate(SSLSocketFactory factory)
      Negotiates a TLS session using an SSL socket factory.

    • Uses of SSLSession in javax.net.ssl

      Classes in javax.net.ssl that implement SSLSession
      修饰符与类型 类与描述
      class  ExtendedSSLSession
      Extends the SSLSession interface to support additional session attributes.
      Methods in javax.net.ssl that return SSLSession
      修饰符与类型 方法与描述
      SSLSession SSLSocket.getHandshakeSession()
      Returns the SSLSession being constructed during a SSL/TLS handshake.
      SSLSession SSLEngine.getHandshakeSession()
      Returns the SSLSession being constructed during a SSL/TLS handshake.
      SSLSession SSLSessionBindingEvent.getSession()
      Returns the SSLSession into which the listener is being bound or from which the listener is being unbound.
      SSLSession HandshakeCompletedEvent.getSession()
      Returns the session that triggered this event.
      abstract SSLSession SSLSocket.getSession()
      Returns the SSL Session in use by this connection.
      abstract SSLSession SSLEngine.getSession()
      Returns the SSLSession in use in this SSLEngine.
      SSLSession SSLSessionContext.getSession(byte[] sessionId)
      Returns the SSLSession bound to the specified session id.
      Methods in javax.net.ssl with parameters of type SSLSession
      修饰符与类型 方法与描述
      boolean HostnameVerifier.verify(String hostname, SSLSession session)
      Verify that the host name is an acceptable match with the server's authentication scheme.
      Constructors in javax.net.ssl with parameters of type SSLSession
      构造方法与描述
      HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
      Constructs a new HandshakeCompletedEvent.
      SSLSessionBindingEvent(SSLSession session, String name)
      Constructs a new SSLSessionBindingEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsS 3ln alr>oeho<


Uses of Interface javax.net.ssl.SSLSessionBindingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.SSLSessionBindingListener

No usage of javax.net.ssl.SSLSessionBindingListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n e" th.tttei//U"aoS


Uses of Interface javax.net.ssl.SSLSessionContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.SSLSessionContext

  • Packages that use SSLSessionContext
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of SSLSessionContext in javax.net.ssl

      Methods in javax.net.ssl that return SSLSessionContext
      修饰符与类型 方法与描述
      protected abstract SSLSessionContext SSLContextSpi.engineGetClientSessionContext()
      Returns a client SSLSessionContext object for this context.
      protected abstract SSLSessionContext SSLContextSpi.engineGetServerSessionContext()
      Returns a server SSLSessionContext object for this context.
      SSLSessionContext SSLContext.getClientSessionContext()
      Returns the client session context, which represents the set of SSL sessions available for use during the handshake phase of client-side SSL sockets.
      SSLSessionContext SSLContext.getServerSessionContext()
      Returns the server session context, which represents the set of SSL sessions available for use during the handshake phase of server-side SSL sockets.
      SSLSessionContext SSLSession.getSessionContext()
      Returns the context in which this session is bound.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/enref<>s.r/t=roiasar


Uses of Interface javax.net.ssl.TrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.TrustManager

  • Packages that use TrustManager
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of TrustManager in javax.net.ssl

      Subinterfaces of TrustManager in javax.net.ssl
      修饰符与类型 Interface and Description
      interface  X509TrustManager
      Instance of this interface manage which X509 certificates may be used to authenticate the remote side of a secure socket.
      Classes in javax.net.ssl that implement TrustManager
      修饰符与类型 类与描述
      class  X509ExtendedTrustManager
      Extensions to the X509TrustManager interface to support SSL/TLS connection sensitive trust management.
      Methods in javax.net.ssl that return TrustManager
      修饰符与类型 方法与描述
      protected abstract TrustManager[] TrustManagerFactorySpi.engineGetTrustManagers()
      Returns one trust manager for each type of trust material.
      TrustManager[] TrustManagerFactory.getTrustManagers()
      Returns one trust manager for each type of trust material.
      Methods in javax.net.ssl with parameters of type TrustManager
      修饰符与类型 方法与描述
      protected abstract void SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr)
      Initializes this context.
      void SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random)
      Initializes this context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ein lecep oma擘籸nbru.o�


Uses of Interface javax.net.ssl.X509KeyManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.X509KeyManager

  • Packages that use X509KeyManager
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of X509KeyManager in javax.net.ssl

      Classes in javax.net.ssl that implement X509KeyManager
      修饰符与类型 类与描述
      class  X509ExtendedKeyManager
      Abstract class that provides for extension of the X509KeyManager interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.xatdn/_sasme罚�<肽gc


Uses of Interface javax.net.ssl.X509TrustManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.net.ssl.X509TrustManager

  • Packages that use X509TrustManager
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.

    • Uses of X509TrustManager in javax.net.ssl

      Classes in javax.net.ssl that implement X509TrustManager
      修饰符与类型 类与描述
      class  X509ExtendedTrustManager
      Extensions to the X509TrustManager interface to support SSL/TLS connection sensitive trust management.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

amls�&tiliefNn./""trp&


AttributeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface AttributeException

  • public interface AttributeException
    Interface AttributeException is a mixin interface which a subclass of PrintException can implement to report an error condition involving one or more printing attributes that a particular Print Service instance does not support. Either the attribute is not supported at all, or the attribute is supported but the particular specified value is not supported. The Print Service API does not define any print exception classes that implement interface AttributeException, that being left to the Print Service implementor's discretion.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类[] getUnsupportedAttributes()
      Returns the array of printing attribute classes for which the Print Service instance does not support the attribute at all, or null if there are no such attributes.
      Attribute[] getUnsupportedValues()
      Returns the array of printing attributes for which the Print Service instance supports the attribute but does not support that particular value of the attribute, or null if there are no such attribute values.

    • 方法详细信息

      • getUnsupportedAttributes

        类[] getUnsupportedAttributes()
        Returns the array of printing attribute classes for which the Print Service instance does not support the attribute at all, or null if there are no such attributes. The objects in the returned array are classes that extend the base interface Attribute.
        返回：
        unsupported attribute classes

      • getUnsupportedValues

        Attribute[] getUnsupportedValues()
        Returns the array of printing attributes for which the Print Service instance supports the attribute but does not support that particular value of the attribute, or null if there are no such attribute values.
        返回：
        unsupported attribute values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ss.tn/yddf醰a"us


CancelablePrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface CancelablePrintJob

  • All Superinterfaces:
    DocPrintJob

    public interface CancelablePrintJob
extends DocPrintJob
    This interface is used by a printing application to cancel a print job. This interface extends DocPrintJob. A DocPrintJob implementation returned from a print service implements this interface if the print job can be cancelled. Before trying to cancel a print job, the client needs to test if the DocPrintJob object returned from the print service actually implements this interface. Clients should never assume that a DocPrintJob implements this interface. A print service might support cancellation only for certain types of print data and representation class names. This means that only some of the DocPrintJob objects returned from a service will implement this interface.

    Service implementors are encouraged to implement this optional interface and to deliver a javax.print.event.PrintJobEvent.JOB_CANCELLED event to any listeners if a job is successfully cancelled with an implementation of this interface. Services should also note that an implementation of this method may be made from a separate client thread than that which made the print request. Thus the implementation of this interface must be made thread safe.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void cancel()
      Stops further processing of a print job.

      • 方法 - 继承于接口 javax.print.DocPrintJob

        addPrintJobAttributeListener, addPrintJobListener, getAttributes, getPrintService, print, removePrintJobAttributeListener, removePrintJobListener

    • 方法详细信息

      • cancel

        void cancel()
            throws PrintException
        Stops further processing of a print job.

        If a service supports this method it cannot be concluded that job cancellation will always suceeed. A job may not be able to be cancelled once it has reached and passed some point in its processing. A successful cancellation means only that the entire job was not printed, some portion may already have printed when cancel returns.

        The service will throw a PrintException if the cancellation did not succeed. A job which has not yet been submitted for printing should throw this exception. Cancelling an already successfully cancelled Print Job is not considered an error and will always succeed.

        Cancellation in some services may be a lengthy process, involving requests to a server and processing of its print queue. Clients may wish to execute cancel in a thread which does not affect application execution.

        抛出：
        PrintException - if the job could not be successfully cancelled.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.taxv/l o&tie ed蚻


Doc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface Doc

  • All Known Implementing Classes:
    SimpleDoc

    public interface Doc
    Interface Doc specifies the interface for an object that supplies one piece of print data for a Print Job. "Doc" is a short, easy-to-pronounce term that means "a piece of print data." The client passes to the Print Job an object that implements interface Doc, and the Print Job calls methods on that object to obtain the print data. The Doc interface lets a Print Job:
    • Determine the format, or "doc flavor" (class DocFlavor), in which the print data is available. A doc flavor designates the print data format (a MIME type) and the representation class of the object from which the print data comes.

    • Obtain the print data representation object, which is an instance of the doc flavor's representation class. The Print Job can then obtain the actual print data from the representation object.

    • Obtain the printing attributes that specify additional characteristics of the doc or that specify processing instructions to be applied to the doc. Printing attributes are defined in package javax.print.attribute. The doc returns its printing attributes stored in an javax.print.attribute.DocAttributeSet.

    Each method in an implementation of interface Doc is permitted always to return the same object each time the method is called. This has implications for a Print Job or other caller of a doc object whose print data representation object "consumes" the print data as the caller obtains the print data, such as a print data representation object which is a stream. Once the Print Job has called getPrintData() and obtained the stream, any further calls to getPrintData() will return the same stream object upon which reading may already be in progress, not a new stream object that will re-read the print data from the beginning. Specifying a doc object to behave this way simplifies the implementation of doc objects, and is justified on the grounds that a particular doc is intended to convey print data only to one Print Job, not to several different Print Jobs. (To convey the same print data to several different Print Jobs, you have to create several different doc objects on top of the same print data source.)

    Interface Doc affords considerable implementation flexibility. The print data might already be in existence when the doc object is constructed. In this case the objects returned by the doc's methods can be supplied to the doc's constructor, be stored in the doc ahead of time, and simply be returned when called for. Alternatively, the print data might not exist yet when the doc object is constructed. In this case the doc object might provide a "lazy" implementation that generates the print data representation object (and/or the print data) only when the Print Job calls for it (when the Print Job calls the getPrintData() method).

    There is no restriction on the number of client threads that may be simultaneously accessing the same doc. Therefore, all implementations of interface Doc must be designed to be multiple thread safe.

    However there can only be one consumer of the print data obtained from a Doc.

    If print data is obtained from the client as a stream, by calling Doc's getReaderForText() or getStreamForBytes() methods, or because the print data source is already an InputStream or Reader, then the print service should always close these streams for the client on all job completion conditions. With the following caveat. If the print data is itself a stream, the service will always close it. If the print data is otherwise something that can be requested as a stream, the service will only close the stream if it has obtained the stream before terminating. That is, just because a print service might request data as a stream does not mean that it will, with the implications that Doc implementors which rely on the service to close them should create such streams only in response to a request from the service.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DocAttributeSet getAttributes()
      Obtains the set of printing attributes for this doc object.
      DocFlavor getDocFlavor()
      Determines the doc flavor in which this doc object will supply its piece of print data.
      Object getPrintData()
      Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor.
      Reader getReaderForText()
      Obtains a reader for extracting character print data from this doc.
      InputStream getStreamForBytes()
      Obtains an input stream for extracting byte print data from this doc.

    • 方法详细信息

      • getDocFlavor

        DocFlavor getDocFlavor()
        Determines the doc flavor in which this doc object will supply its piece of print data.
        返回：
        Doc flavor.

      • getPrintData

        Object getPrintData()
                    throws IOException
        Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor. The getPrintData() method returns an instance of the representation class whose name is given by getDocFlavor().getRepresentationClassName(), and the return value can be cast from class Object to that representation class.
        返回：
        Print data representation object.
        抛出：
        IOException - Thrown if the representation class is a stream and there was an I/O error while constructing the stream.

      • getAttributes

        DocAttributeSet getAttributes()
        Obtains the set of printing attributes for this doc object. If the returned attribute set includes an instance of a particular attribute X, the printer must use that attribute value for this doc, overriding any value of attribute X in the job's attribute set. If the returned attribute set does not include an instance of a particular attribute X or if null is returned, the printer must consult the job's attribute set to obtain the value for attribute X, and if not found there, the printer must use an implementation-dependent default value. The returned attribute set is unmodifiable.
        返回：
        Unmodifiable set of printing attributes for this doc, or null to obtain all attribute values from the job's attribute set.

      • getReaderForText

        Reader getReaderForText()
                        throws IOException
        Obtains a reader for extracting character print data from this doc. The Doc implementation is required to support this method if the DocFlavor has one of the following print data representation classes, and return null otherwise:
        • char[]
        • java.lang.String
        • java.io.Reader
        The doc's print data representation object is used to construct and return a Reader for reading the print data as a stream of characters from the print data representation object. However, if the print data representation object is itself a Reader, then the print data representation object is simply returned.

        返回：
        Reader for reading the print data characters from this doc. If a reader cannot be provided because this doc does not meet the criteria stated above, null is returned.
        抛出：
        IOException - Thrown if there was an I/O error while creating the reader.

      • getStreamForBytes

        InputStream getStreamForBytes()
                              throws IOException
        Obtains an input stream for extracting byte print data from this doc. The Doc implementation is required to support this method if the DocFlavor has one of the following print data representation classes, and return null otherwise:
        • byte[]
        • java.io.InputStream
        This doc's print data representation object is obtained, then an input stream for reading the print data from the print data representation object as a stream of bytes is created and returned. However, if the print data representation object is itself an input stream, then the print data representation object is simply returned.

        返回：
        Input stream for reading the print data bytes from this doc. If an input stream cannot be provided because this doc does not meet the criteria stated above, null is returned.
        抛出：
        IOException - Thrown if there was an I/O error while creating the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

er 鎙>>m:-/s:egccal� eteai


DocFlavor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 DocFlavor

  • java.lang.Object
    • javax.print.DocFlavor
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    public class DocFlavor
extends Object
implements Serializable, Cloneable
    Class DocFlavor encapsulates an object that specifies the format in which print data is supplied to a DocPrintJob. "Doc" is a short, easy-to-pronounce term that means "a piece of print data." The print data format, or "doc flavor", consists of two things:
    • MIME type. This is a Multipurpose Internet Mail Extensions (MIME) media type (as defined in RFC 2045 and RFC 2046) that specifies how the print data is to be interpreted. The charset of text data should be the IANA MIME-preferred name, or its canonical name if no preferred name is specified. Additionally a few historical names supported by earlier versions of the Java platform may be recognized. See character encodings for more information on the character encodings supported on the Java platform.

    • Representation class name. This specifies the fully-qualified name of the class of the object from which the actual print data comes, as returned by the Class.getName() method. (Thus the class name for byte[] is "[B", for char[] it is "[C".)

    A DocPrintJob obtains its print data by means of interface Doc. A Doc object lets the DocPrintJob determine the doc flavor the client can supply. A Doc object also lets the DocPrintJob obtain an instance of the doc flavor's representation class, from which the DocPrintJob then obtains the actual print data.

    Client Formatted Print Data

    There are two broad categories of print data, client formatted print data and service formatted print data.

    For client formatted print data, the client determines or knows the print data format. For example the client may have a JPEG encoded image, a URL for HTML code, or a disk file containing plain text in some encoding, possibly obtained from an external source, and requires a way to describe the data format to the print service.

    The doc flavor's representation class is a conduit for the JPS DocPrintJob to obtain a sequence of characters or bytes from the client. The doc flavor's MIME type is one of the standard media types telling how to interpret the sequence of characters or bytes. For a list of standard media types, see the Internet Assigned Numbers Authority's (IANA's) Media Types Directory. Interface Doc provides two utility operations, getReaderForText and getStreamForBytes(), to help a Doc object's client extract client formatted print data.

    For client formatted print data, the print data representation class is typically one of the following (although other representation classes are permitted):

    • Character array (char[]) -- The print data consists of the Unicde characters in the array.

    • String -- The print data consists of the Unicode characters in the string.

    • Character stream (java.io.Reader) -- The print data consists of the Unicode characters read from the stream up to the end-of-stream.

    • Byte array (byte[]) -- The print data consists of the bytes in the array. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII.

    • Byte stream (java.io.InputStream) -- The print data consists of the bytes read from the stream up to the end-of-stream. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII.
    • Uniform Resource Locator (URL) -- The print data consists of the bytes read from the URL location. The bytes are encoded in the character set specified by the doc flavor's MIME type. If the MIME type does not specify a character set, the default character set is US-ASCII.

      When the representation class is a URL, the print service itself accesses and downloads the document directly from its URL address, without involving the client. The service may be some form of network print service which is executing in a different environment. This means you should not use a URL print data flavor to print a document at a restricted URL that the client can see but the printer cannot see. This also means you should not use a URL print data flavor to print a document stored in a local file that is not available at a URL accessible independently of the client. For example, a file that is not served up by an HTTP server or FTP server. To print such documents, let the client open an input stream on the URL or file and use an input stream data flavor.

    Default and Platform Encodings

    For byte print data where the doc flavor's MIME type does not include a charset parameter, the Java Print Service instance assumes the US-ASCII character set by default. This is in accordance with RFC 2046, which says the default character set is US-ASCII. Note that US-ASCII is a subset of UTF-8, so in the future this may be widened if a future RFC endorses UTF-8 as the default in a compatible manner.

    Also note that this is different than the behaviour of the Java runtime when interpreting a stream of bytes as text data. That assumes the default encoding for the user's locale. Thus, when spooling a file in local encoding to a Java Print Service it is important to correctly specify the encoding. Developers working in the English locales should be particularly conscious of this, as their platform encoding corresponds to the default mime charset. By this coincidence that particular case may work without specifying the encoding of platform data.

    Every instance of the Java virtual machine has a default character encoding determined during virtual-machine startup and typically depends upon the locale and charset being used by the underlying operating system. In a distributed environment there is no gurantee that two VM's share the same default encoding. Thus clients which want to stream platform encoded text data from the host platform to a Java Print Service instance must explicitly declare the charset and not rely on defaults.

    The preferred form is the official IANA primary name for an encoding. Applications which stream text data should always specify the charset in the mime type, which necessitates obtaining the encoding of the host platform for data (eg files) stored in that platform's encoding. A CharSet which corresponds to this and is suitable for use in a mime-type for a DocFlavor can be obtained from DocFlavor.hostEncoding This may not always be the primary IANA name but is guaranteed to be understood by this VM. For common flavors, the pre-defined *HOST DocFlavors may be used.

    See character encodings for more information on the character encodings supported on the Java platform.

    Recommended DocFlavors

    The Java Print Service API does not define any mandatorily supported DocFlavors. However, here are some examples of MIME types that a Java Print Service instance might support for client formatted print data. Nested classes inside class DocFlavor declare predefined static constant DocFlavor objects for these example doc flavors; class DocFlavor's constructor can be used to create an arbitrary doc flavor.

    • Preformatted text

      MIME-Type | 描述
      "text/plain" | Plain text in the default character set (US-ASCII)
      "text/plain; charset=xxx" | Plain text in character set xxx
      "text/html" | HyperText Markup Language in the default character set (US-ASCII)
      "text/html; charset=xxx" | HyperText Markup Language in character set xxx

      In general, preformatted text print data is provided either in a character oriented representation class (character array, String, Reader) or in a byte oriented representation class (byte array, InputStream, URL).

    • Preformatted page description language (PDL) documents

      MIME-Type | 描述
      "application/pdf" | Portable Document Format document
      "application/postscript" | PostScript document
      "application/vnd.hp-PCL" | Printer Control Language document

      In general, preformatted PDL print data is provided in a byte oriented representation class (byte array, InputStream, URL).

    • Preformatted images

      MIME-Type | 描述
      "image/gif" | Graphics Interchange Format image
      "image/jpeg" | Joint Photographic Experts Group image
      "image/png" | Portable Network Graphics image

      In general, preformatted image print data is provided in a byte oriented representation class (byte array, InputStream, URL).

    • Preformatted autosense print data

      MIME-Type | 描述
      "application/octet-stream" | The print data format is unspecified (just an octet stream)

      The printer decides how to interpret the print data; the way this "autosensing" works is implementation dependent. In general, preformatted autosense print data is provided in a byte oriented representation class (byte array, InputStream, URL).

      Service Formatted Print Data

      For service formatted print data, the Java Print Service instance determines the print data format. The doc flavor's representation class denotes an interface whose methods the DocPrintJob invokes to determine the content to be printed -- such as a renderable image interface or a Java printable interface. The doc flavor's MIME type is the special value "application/x-java-jvm-local-objectref" indicating the client will supply a reference to a Java object that implements the interface named as the representation class. This MIME type is just a placeholder; what's important is the print data representation class.

      For service formatted print data, the print data representation class is typically one of the following (although other representation classes are permitted). Nested classes inside class DocFlavor declare predefined static constant DocFlavor objects for these example doc flavors; class DocFlavor's constructor can be used to create an arbitrary doc flavor.

      • Renderable image object -- The client supplies an object that implements interface RenderableImage. The printer calls methods in that interface to obtain the image to be printed.

      • Printable object -- The client supplies an object that implements interface Printable. The printer calls methods in that interface to obtain the pages to be printed, one by one. For each page, the printer supplies a graphics context, and whatever the client draws in that graphics context gets printed.

      • Pageable object -- The client supplies an object that implements interface Pageable. The printer calls methods in that interface to obtain the pages to be printed, one by one. For each page, the printer supplies a graphics context, and whatever the client draws in that graphics context gets printed.

      Pre-defined Doc Flavors

      A Java Print Service instance is not required to support the following print data formats and print data representation classes. In fact, a developer using this class should never assume that a particular print service supports the document types corresponding to these pre-defined doc flavors. Always query the print service to determine what doc flavors it supports. However, developers who have print services that support these doc flavors are encouraged to refer to the predefined singleton instances created here.
      • Plain text print data provided through a byte stream. Specifically, the following doc flavors are recommended to be supported:
        · ("text/plain", "java.io.InputStream")
        · ("text/plain; charset=us-ascii", "java.io.InputStream")
        · ("text/plain; charset=utf-8", "java.io.InputStream")

      • Renderable image objects. Specifically, the following doc flavor is recommended to be supported:
        · ("application/x-java-jvm-local-objectref", "java.awt.image.renderable.RenderableImage")

      A Java Print Service instance is allowed to support any other doc flavors (or none) in addition to the above mandatory ones, at the implementation's choice.

      Support for the above doc flavors is desirable so a printing client can rely on being able to print on any JPS printer, regardless of which doc flavors the printer supports. If the printer doesn't support the client's preferred doc flavor, the client can at least print plain text, or the client can convert its data to a renderable image and print the image.

      Furthermore, every Java Print Service instance must fulfill these requirements for processing plain text print data:

      • The character pair carriage return-line feed (CR-LF) means "go to column 1 of the next line."
      • A carriage return (CR) character standing by itself means "go to column 1 of the next line."
      • A line feed (LF) character standing by itself means "go to column 1 of the next line."

      The client must itself perform all plain text print data formatting not addressed by the above requirements.

      Design Rationale

      Class DocFlavor in package javax.print.data is similar to class DataFlavor. Class DataFlavor is not used in the Java Print Service (JPS) API for three reasons which are all rooted in allowing the JPS API to be shared by other print services APIs which may need to run on Java profiles which do not include all of the Java Platform, Standard Edition.

      1. The JPS API is designed to be used in Java profiles which do not support AWT.

      2. The implementation of class java.awt.datatransfer.DataFlavor does not guarantee that equivalent data flavors will have the same serialized representation. DocFlavor does, and can be used in services which need this.

      3. The implementation of class java.awt.datatransfer.DataFlavor includes a human presentable name as part of the serialized representation. This is not appropriate as part of a service matching constraint.

      Class DocFlavor's serialized representation uses the following canonical form of a MIME type string. Thus, two doc flavors with MIME types that are not identical but that are equivalent (that have the same canonical form) may be considered equal.

      • The media type, media subtype, and parameters are retained, but all comments and whitespace characters are discarded.
      • The media type, media subtype, and parameter names are converted to lowercase.
      • The parameter values retain their original case, except a charset parameter value for a text media type is converted to lowercase.
      • Quote characters surrounding parameter values are removed.
      • Quoting backslash characters inside parameter values are removed.
      • The parameters are arranged in ascending order of parameter name.

      Class DocFlavor's serialized representation also contains the fully-qualified class name of the representation class (a String object), rather than the representation class itself (a Class object). This allows a client to examine the doc flavors a Java Print Service instance supports without having to load the representation classes, which may be problematic for limited-resource clients.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DocFlavor.BYTE_ARRAY
      Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
      static class  DocFlavor.CHAR_ARRAY
      Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
      static class  DocFlavor.INPUT_STREAM
      Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
      static class  DocFlavor.READER
      Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
      static class  DocFlavor.SERVICE_FORMATTED
      Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
      static class  DocFlavor.STRING
      Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
      static class  DocFlavor.URL
      Class DocFlavor.URL provides predefined static constant DocFlavor objects.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String hostEncoding
      A String representing the host operating system encoding.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor(String mimeType, String className)
      Constructs a new doc flavor object from the given MIME type and representation class name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Determines if this doc flavor object is equal to the given object.
      String getMediaSubtype()
      Returns this doc flavor object's media subtype (from the MIME type).
      String getMediaType()
      Returns this doc flavor object's media type (from the MIME type).
      String getMimeType()
      Returns this doc flavor object's MIME type string based on the canonical form.
      String getParameter(String paramName)
      Returns a String representing a MIME parameter.
      String getRepresentationClassName()
      Returns the name of this doc flavor object's representation class.
      int hashCode()
      Returns a hash code for this doc flavor object.
      String toString()
      Converts this DocFlavor to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • hostEncoding

        public static final String hostEncoding
        A String representing the host operating system encoding. This will follow the conventions documented in RFC 2278: IANA Charset Registration Procedures except where historical names are returned for compatibility with previous versions of the Java platform. The value returned from method is valid only for the VM which returns it, for use in a DocFlavor. This is the charset for all the "HOST" pre-defined DocFlavors in the executing VM.

    • 构造方法详细信息

      • DocFlavor

        public DocFlavor(String mimeType,
         String className)
        Constructs a new doc flavor object from the given MIME type and representation class name. The given MIME type is converted into canonical form and stored internally.
        参数：
        mimeType - MIME media type string.
        className - Fully-qualified representation class name.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null or className is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.

    • 方法详细信息

      • getMimeType

        public String getMimeType()
        Returns this doc flavor object's MIME type string based on the canonical form. Each parameter value is enclosed in quotes.
        返回：
        the mime type

      • getMediaType

        public String getMediaType()
        Returns this doc flavor object's media type (from the MIME type).
        返回：
        the media type

      • getMediaSubtype

        public String getMediaSubtype()
        Returns this doc flavor object's media subtype (from the MIME type).
        返回：
        the media sub-type

      • getParameter

        public String getParameter(String paramName)
        Returns a String representing a MIME parameter. Mime types may include parameters which are usually optional. The charset for text types is a commonly useful example. This convenience method will return the value of the specified parameter if one was specified in the mime type for this flavor.

        参数：
        paramName - the name of the paramater. This name is internally converted to the canonical lower case format before performing the match.
        返回：
        String representing a mime parameter, or null if that parameter is not in the mime type string.
        抛出：
        throws - NullPointerException if paramName is null.

      • getRepresentationClassName

        public String getRepresentationClassName()
        Returns the name of this doc flavor object's representation class.
        返回：
        the name of the representation class.

      • toString

        public String toString()
        Converts this DocFlavor to a string.
        重载：
        toString in class Object
        返回：
        MIME type string based on the canonical form. Each parameter value is enclosed in quotes. A "class=" parameter is appended to the MIME type string to indicate the representation class name.

      • hashCode

        public int hashCode()
        Returns a hash code for this doc flavor object.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Determines if this doc flavor object is equal to the given object. The two are equal if the given object is not null, is an instance of DocFlavor, has a MIME type equivalent to this doc flavor object's MIME type (that is, the MIME types have the same media type, media subtype, and parameters), and has the same representation class name as this doc flavor object. Thus, if two doc flavor objects' MIME types are the same except for comments, they are considered equal. However, two doc flavor objects with MIME types of "text/plain" and "text/plain; charset=US-ASCII" are not considered equal, even though they represent the same media type (because the default character set for plain text is US-ASCII).
        重载：
        equals in class Object
        参数：
        obj - Object to test.
        返回：
        True if this doc flavor object equals obj, false otherwise.
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DocFlavor.BYTE_ARRAY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.BYTE_ARRAY

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.BYTE_ARRAY
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.BYTE_ARRAY
extends DocFlavor
    Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.BYTE_ARRAY AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.BYTE_ARRAY TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "[B" (byte array).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.BYTE_ARRAY(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of "[B" (byte array).

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN_HOST

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_HOST
        Doc flavor with MIME type = "text/plain", encoded in the host platform encoding. See hostEncoding Print data representation class name = "[B" (byte array).

      • TEXT_PLAIN_UTF_8

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_8
        Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "[B" (byte array).

      • TEXT_PLAIN_UTF_16

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[B" (byte array).

      • TEXT_PLAIN_UTF_16BE

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16BE
        Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).

      • TEXT_PLAIN_UTF_16LE

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16LE
        Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).

      • TEXT_PLAIN_US_ASCII

        public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_US_ASCII
        Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "[B" (byte array).

      • TEXT_HTML_HOST

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_HOST
        Doc flavor with MIME type = "text/html", encoded in the host platform encoding. See hostEncoding Print data representation class name = "[B" (byte array).

      • TEXT_HTML_UTF_8

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_8
        Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "[B" (byte array).

      • TEXT_HTML_UTF_16

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[B" (byte array).

      • TEXT_HTML_UTF_16BE

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16BE
        Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).

      • TEXT_HTML_UTF_16LE

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16LE
        Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).

      • TEXT_HTML_US_ASCII

        public static final DocFlavor.BYTE_ARRAY TEXT_HTML_US_ASCII
        Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "[B" (byte array).

      • PDF

        public static final DocFlavor.BYTE_ARRAY PDF
        Doc flavor with MIME type = "application/pdf", print data representation class name = "[B" (byte array).

      • POSTSCRIPT

        public static final DocFlavor.BYTE_ARRAY POSTSCRIPT
        Doc flavor with MIME type = "application/postscript", print data representation class name = "[B" (byte array).

      • PCL

        public static final DocFlavor.BYTE_ARRAY PCL
        Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "[B" (byte array).

      • GIF

        public static final DocFlavor.BYTE_ARRAY GIF
        Doc flavor with MIME type = "image/gif", print data representation class name = "[B" (byte array).

      • JPEG

        public static final DocFlavor.BYTE_ARRAY JPEG
        Doc flavor with MIME type = "image/jpeg", print data representation class name = "[B" (byte array).

      • PNG

        public static final DocFlavor.BYTE_ARRAY PNG
        Doc flavor with MIME type = "image/png", print data representation class name = "[B" (byte array).

      • AUTOSENSE

        public static final DocFlavor.BYTE_ARRAY AUTOSENSE
        Doc flavor with MIME type = "application/octet-stream", print data representation class name = "[B" (byte array). The client must determine that data described using this DocFlavor is valid for the printer.

    • 构造方法详细信息

      • DocFlavor.BYTE_ARRAY

        public DocFlavor.BYTE_ARRAY(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of "[B" (byte array).
        参数：
        mimeType - MIME media type string.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


DocFlavor.CHAR_ARRAY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.CHAR_ARRAY

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.CHAR_ARRAY
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.CHAR_ARRAY
extends DocFlavor
    Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class. As such, the character set is Unicode.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.CHAR_ARRAY TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[C" (character array).
      static DocFlavor.CHAR_ARRAY TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[C" (character array).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.CHAR_ARRAY(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of "[C" (character array).

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN

        public static final DocFlavor.CHAR_ARRAY TEXT_PLAIN
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[C" (character array).

      • TEXT_HTML

        public static final DocFlavor.CHAR_ARRAY TEXT_HTML
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[C" (character array).

    • 构造方法详细信息

      • DocFlavor.CHAR_ARRAY

        public DocFlavor.CHAR_ARRAY(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of "[C" (character array).
        参数：
        mimeType - MIME media type string. If it is a text media type, it is assumed to contain a "charset=utf-16" parameter.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s>LTXtEXthmmthhRrii/Rod//t >


DocFlavor.INPUT_STREAM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.INPUT_STREAM

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.INPUT_STREAM
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.INPUT_STREAM
extends DocFlavor
    Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.INPUT_STREAM AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.INPUT_STREAM TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.INPUT_STREAM(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.io.InputStream" (byte stream).

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN_HOST

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_HOST
        Doc flavor with MIME type = "text/plain", encoded in the host platform encoding. See hostEncoding Print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_PLAIN_UTF_8

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_8
        Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_PLAIN_UTF_16

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_PLAIN_UTF_16BE

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16BE
        Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_PLAIN_UTF_16LE

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16LE
        Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_PLAIN_US_ASCII

        public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_US_ASCII
        Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_HOST

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_HOST
        Doc flavor with MIME type = "text/html", encoded in the host platform encoding. See hostEncoding Print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_UTF_8

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_8
        Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_UTF_16

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_UTF_16BE

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16BE
        Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_UTF_16LE

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16LE
        Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).

      • TEXT_HTML_US_ASCII

        public static final DocFlavor.INPUT_STREAM TEXT_HTML_US_ASCII
        Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).

      • PDF

        public static final DocFlavor.INPUT_STREAM PDF
        Doc flavor with MIME type = "application/pdf", print data representation class name = "java.io.InputStream" (byte stream).

      • POSTSCRIPT

        public static final DocFlavor.INPUT_STREAM POSTSCRIPT
        Doc flavor with MIME type = "application/postscript", print data representation class name = "java.io.InputStream" (byte stream).

      • PCL

        public static final DocFlavor.INPUT_STREAM PCL
        Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.io.InputStream" (byte stream).

      • GIF

        public static final DocFlavor.INPUT_STREAM GIF
        Doc flavor with MIME type = "image/gif", print data representation class name = "java.io.InputStream" (byte stream).

      • JPEG

        public static final DocFlavor.INPUT_STREAM JPEG
        Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.io.InputStream" (byte stream).

      • PNG

        public static final DocFlavor.INPUT_STREAM PNG
        Doc flavor with MIME type = "image/png", print data representation class name = "java.io.InputStream" (byte stream).

      • AUTOSENSE

        public static final DocFlavor.INPUT_STREAM AUTOSENSE
        Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.io.InputStream" (byte stream). The client must determine that data described using this DocFlavor is valid for the printer.

    • 构造方法详细信息

      • DocFlavor.INPUT_STREAM

        public DocFlavor.INPUT_STREAM(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.io.InputStream" (byte stream).
        参数：
        mimeType - MIME media type string.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t8ihgtn tnettneeeSss.gnnlnilajS/nhgosoan>il


DocFlavor.READER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.READER

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.READER
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.READER
extends DocFlavor
    Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class. As such, the character set is Unicode.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.READER TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).
      static DocFlavor.READER TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.READER(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of\ "java.io.Reader" (character stream).

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN

        public static final DocFlavor.READER TEXT_PLAIN
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).

      • TEXT_HTML

        public static final DocFlavor.READER TEXT_HTML
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).

    • 构造方法详细信息

      • DocFlavor.READER

        public DocFlavor.READER(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of\ "java.io.Reader" (character stream).
        参数：
        mimeType - MIME media type string. If it is a text media type, it is assumed to contain a "charset=utf-16" parameter.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t ywlvoavoDccoDDolccI.roPvShTM.EEUoinixxn aT


DocFlavor.SERVICE_FORMATTED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.SERVICE_FORMATTED

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.SERVICE_FORMATTED
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.SERVICE_FORMATTED
extends DocFlavor
    Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.SERVICE_FORMATTED PAGEABLE
      Service formatted print data doc flavor with print data representation class name = "java.awt.print.Pageable" (pageable object).
      static DocFlavor.SERVICE_FORMATTED PRINTABLE
      Service formatted print data doc flavor with print data representation class name = "java.awt.print.Printable" (printable object).
      static DocFlavor.SERVICE_FORMATTED RENDERABLE_IMAGE
      Service formatted print data doc flavor with print data representation class name = "java.awt.image.renderable.RenderableImage" (renderable image object).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.SERVICE_FORMATTED(String className)
      Constructs a new doc flavor with a MIME type of "application/x-java-jvm-local-objectref" indicating service formatted print data and the given print data representation class name.

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • RENDERABLE_IMAGE

        public static final DocFlavor.SERVICE_FORMATTED RENDERABLE_IMAGE
        Service formatted print data doc flavor with print data representation class name = "java.awt.image.renderable.RenderableImage" (renderable image object).

      • PRINTABLE

        public static final DocFlavor.SERVICE_FORMATTED PRINTABLE
        Service formatted print data doc flavor with print data representation class name = "java.awt.print.Printable" (printable object).

      • PAGEABLE

        public static final DocFlavor.SERVICE_FORMATTED PAGEABLE
        Service formatted print data doc flavor with print data representation class name = "java.awt.print.Pageable" (pageable object).

    • 构造方法详细信息

      • DocFlavor.SERVICE_FORMATTED

        public DocFlavor.SERVICE_FORMATTED(String className)
        Constructs a new doc flavor with a MIME type of "application/x-java-jvm-local-objectref" indicating service formatted print data and the given print data representation class name.
        参数：
        className - Fully-qualified representation class name.
        抛出：
        NullPointerException - (unchecked exception) Thrown if className is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l/tre"uaixh i<�


DocFlavor.STRING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.STRING

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.STRING
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.STRING
extends DocFlavor
    Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class. As such, the character set is Unicode.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.STRING TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.lang.String".
      static DocFlavor.STRING TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.lang.String".

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.STRING(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.lang.String".

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN

        public static final DocFlavor.STRING TEXT_PLAIN
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.lang.String".

      • TEXT_HTML

        public static final DocFlavor.STRING TEXT_HTML
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.lang.String".

    • 构造方法详细信息

      • DocFlavor.STRING

        public DocFlavor.STRING(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.lang.String".
        参数：
        mimeType - MIME media type string. If it is a text media type, it is assumed to contain a "charset=utf-16" parameter.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fhrr_rdr_retd_fmdiff><"f


DocFlavor.URL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 DocFlavor.URL

  • java.lang.Object
    • javax.print.DocFlavor
      • javax.print.DocFlavor.URL
  • 所有已实现的接口：
    Serializable, Cloneable
    封闭类：
    DocFlavor

    public static class DocFlavor.URL
extends DocFlavor
    Class DocFlavor.URL provides predefined static constant DocFlavor objects. For example doc flavors using a Uniform Resource Locator (java.net.URL) as the print data representation class.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.print.DocFlavor

        DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocFlavor.URL AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.net.URL".
      static DocFlavor.URL GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "java.net.URL".
      static DocFlavor.URL JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.net.URL".
      static DocFlavor.URL PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.net.URL".
      static DocFlavor.URL PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "java.net.URL".
      static DocFlavor.URL PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "java.net.URL".
      static DocFlavor.URL POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "java.net.URL".
      static DocFlavor.URL TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.URL TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.URL TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = java.net.URL"" (byte stream).
      static DocFlavor.URL TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).

      • Fields inherited from class javax.print.DocFlavor

        hostEncoding

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocFlavor.URL(String mimeType)
      Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.net.URL".

    • 方法摘要

      • 方法 - 继承于类 javax.print.DocFlavor

        equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TEXT_PLAIN_HOST

        public static final DocFlavor.URL TEXT_PLAIN_HOST
        Doc flavor with MIME type = "text/plain", encoded in the host platform encoding. See hostEncoding Print data representation class name = "java.net.URL" (byte stream).

      • TEXT_PLAIN_UTF_8

        public static final DocFlavor.URL TEXT_PLAIN_UTF_8
        Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).

      • TEXT_PLAIN_UTF_16

        public static final DocFlavor.URL TEXT_PLAIN_UTF_16
        Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = java.net.URL"" (byte stream).

      • TEXT_PLAIN_UTF_16BE

        public static final DocFlavor.URL TEXT_PLAIN_UTF_16BE
        Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).

      • TEXT_PLAIN_UTF_16LE

        public static final DocFlavor.URL TEXT_PLAIN_UTF_16LE
        Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).

      • TEXT_PLAIN_US_ASCII

        public static final DocFlavor.URL TEXT_PLAIN_US_ASCII
        Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_HOST

        public static final DocFlavor.URL TEXT_HTML_HOST
        Doc flavor with MIME type = "text/html", encoded in the host platform encoding. See hostEncoding Print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_UTF_8

        public static final DocFlavor.URL TEXT_HTML_UTF_8
        Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_UTF_16

        public static final DocFlavor.URL TEXT_HTML_UTF_16
        Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_UTF_16BE

        public static final DocFlavor.URL TEXT_HTML_UTF_16BE
        Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_UTF_16LE

        public static final DocFlavor.URL TEXT_HTML_UTF_16LE
        Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).

      • TEXT_HTML_US_ASCII

        public static final DocFlavor.URL TEXT_HTML_US_ASCII
        Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).

      • PDF

        public static final DocFlavor.URL PDF
        Doc flavor with MIME type = "application/pdf", print data representation class name = "java.net.URL".

      • POSTSCRIPT

        public static final DocFlavor.URL POSTSCRIPT
        Doc flavor with MIME type = "application/postscript", print data representation class name = "java.net.URL".

      • PCL

        public static final DocFlavor.URL PCL
        Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.net.URL".

      • GIF

        public static final DocFlavor.URL GIF
        Doc flavor with MIME type = "image/gif", print data representation class name = "java.net.URL".

      • JPEG

        public static final DocFlavor.URL JPEG
        Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.net.URL".

      • PNG

        public static final DocFlavor.URL PNG
        Doc flavor with MIME type = "image/png", print data representation class name = "java.net.URL".

      • AUTOSENSE

        public static final DocFlavor.URL AUTOSENSE
        Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.net.URL". The client must determine that data described using this DocFlavor is valid for the printer.

    • 构造方法详细信息

      • DocFlavor.URL

        public DocFlavor.URL(String mimeType)
        Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.net.URL".
        参数：
        mimeType - MIME media type string.
        抛出：
        NullPointerException - (unchecked exception) Thrown if mimeType is null.
        IllegalArgumentException - (unchecked exception) Thrown if mimeType does not obey the syntax for a MIME media type string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


DocPrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface DocPrintJob

  • All Known Subinterfaces:
    CancelablePrintJob, MultiDocPrintJob

    public interface DocPrintJob
    This interface represents a print job that can print a specified document with a set of job attributes. An object implementing this interface is obtained from a print service.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes)
      Registers a listener for changes in the specified attributes.
      void addPrintJobListener(PrintJobListener listener)
      Registers a listener for event occurring during this print job.
      PrintJobAttributeSet getAttributes()
      Obtains this Print Job's set of printing attributes.
      PrintService getPrintService()
      Determines the PrintService object to which this print job object is bound.
      void print(Doc doc, PrintRequestAttributeSet attributes)
      Prints a document with the specified job attributes.
      void removePrintJobAttributeListener(PrintJobAttributeListener listener)
      Removes an attribute listener from this print job.
      void removePrintJobListener(PrintJobListener listener)
      Removes a listener from this print job.

    • 方法详细信息

      • getPrintService

        PrintService getPrintService()
        Determines the PrintService object to which this print job object is bound.
        返回：
        PrintService object.

      • getAttributes

        PrintJobAttributeSet getAttributes()
        Obtains this Print Job's set of printing attributes. The returned attribute set object is unmodifiable. The returned attribute set object is a "snapshot" of this Print Job's attribute set at the time of the getAttributes() method call; that is, the returned attribute set's object's contents will not be updated if this Print Job's attribute set's contents change in the future. To detect changes in attribute values, call getAttributes() again and compare the new attribute set to the previous attribute set; alternatively, register a listener for print job events. The returned value may be an empty set but should not be null.
        返回：
        the print job attributes

      • addPrintJobListener

        void addPrintJobListener(PrintJobListener listener)
        Registers a listener for event occurring during this print job. If listener is null, no exception is thrown and no action is performed. If listener is already registered, it will be registered again.
        参数：
        listener - The object implementing the listener interface
        另请参见：
        removePrintJobListener(javax.print.event.PrintJobListener)

      • removePrintJobListener

        void removePrintJobListener(PrintJobListener listener)
        Removes a listener from this print job. This method performs no function, nor does it throw an exception, if the listener specified by the argument was not previously added to this component. If listener is null, no exception is thrown and no action is performed. If a listener was registered more than once only one of the registrations will be removed.
        参数：
        listener - The object implementing the listener interface
        另请参见：
        addPrintJobListener(javax.print.event.PrintJobListener)

      • addPrintJobAttributeListener

        void addPrintJobAttributeListener(PrintJobAttributeListener listener,
                                PrintJobAttributeSet attributes)
        Registers a listener for changes in the specified attributes. If listener is null, no exception is thrown and no action is performed. To determine the attribute updates that may be reported by this job, a client can call getAttributes() and identify the subset that are interesting and likely to be reported to the listener. Clients expecting to be updated about changes in a specific job attribute should verify it is in that set, but updates about an attribute will be made only if it changes and this is detected by the job. Also updates may be subject to batching by the job. To minimise overhead in print job processing it is recommended to listen on only that subset of attributes which are likely to change. If the specified set is empty no attribute updates will be reported to the listener. If the attribute set is null, then this means to listen on all dynamic attributes that the job supports. This may result in no update notifications if a job can not report any attribute updates. If listener is already registered, it will be registered again.
        参数：
        listener - The object implementing the listener interface
        attributes - The attributes to listen on, or null to mean all attributes that can change, as determined by the job.
        另请参见：
        removePrintJobAttributeListener(javax.print.event.PrintJobAttributeListener)

      • removePrintJobAttributeListener

        void removePrintJobAttributeListener(PrintJobAttributeListener listener)
        Removes an attribute listener from this print job. This method performs no function, nor does it throw an exception, if the listener specified by the argument was not previously added to this component. If the listener is null, no exception is thrown and no action is performed. If a listener is registered more than once, even for a different set of attributes, no guarantee is made which listener is removed.
        参数：
        listener - The object implementing the listener interface
        另请参见：
        addPrintJobAttributeListener(javax.print.event.PrintJobAttributeListener, javax.print.attribute.PrintJobAttributeSet)

      • print

        void print(Doc doc,
         PrintRequestAttributeSet attributes)
           throws PrintException
        Prints a document with the specified job attributes. This method should only be called once for a given print job. Calling it again will not result in a new job being spooled to the printer. The service implementation will define policy for service interruption and recovery. When the print method returns, printing may not yet have completed as printing may happen asynchronously, perhaps in a different thread. Application clients which want to monitor the success or failure should register a PrintJobListener.

        Print service implementors should close any print data streams (ie Reader or InputStream implementations) that they obtain from the client doc. Robust clients may still wish to verify this. An exception is always generated if a DocFlavor cannot be printed.

        参数：
        doc - The document to be printed. If must be a flavor supported by this PrintJob.
        attributes - The job attributes to be applied to this print job. If this parameter is null then the default attributes are used.
        抛出：
        PrintException - The exception additionally may implement an interface that more precisely describes the cause of the exception
        • FlavorException. If the document has a flavor not supported by this print job.
        • AttributeException. If one or more of the attributes are not valid for this print job.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/Drpiirppaallp


FlavorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface FlavorException

  • public interface FlavorException
    Interface FlavorException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a doc flavor or flavors (class DocFlavor). The Print Service API does not define any print exception classes that implement interface FlavorException, that being left to the Print Service implementor's discretion.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DocFlavor[] getUnsupportedFlavors()
      Returns the unsupported flavors.

    • 方法详细信息

      • getUnsupportedFlavors

        DocFlavor[] getUnsupportedFlavors()
        Returns the unsupported flavors.
        返回：
        the unsupported doc flavors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bells"ct"cokkcoos<==joij o. ol


javax.print

Interfaces

  • AttributeException
  • CancelablePrintJob
  • Doc
  • DocPrintJob
  • FlavorException
  • MultiDoc
  • MultiDocPrintJob
  • MultiDocPrintService
  • PrintService
  • URIException

Classes

  • DocFlavor
  • DocFlavor.BYTE_ARRAY
  • DocFlavor.CHAR_ARRAY
  • DocFlavor.INPUT_STREAM
  • DocFlavor.READER
  • DocFlavor.SERVICE_FORMATTED
  • DocFlavor.STRING
  • DocFlavor.URL
  • PrintServiceLookup
  • ServiceUI
  • ServiceUIFactory
  • SimpleDoc
  • StreamPrintService
  • StreamPrintServiceFactory

Exceptions

  • PrintException
t


javax.print

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.print

Provides the principal classes and interfaces for the JavaTM Print Service API.

请参见： 描述

  • 接口摘要
    接口 描述
    AttributeException
    Interface AttributeException is a mixin interface which a subclass of PrintException can implement to report an error condition involving one or more printing attributes that a particular Print Service instance does not support.
    CancelablePrintJob
    This interface is used by a printing application to cancel a print job.
    Doc
    Interface Doc specifies the interface for an object that supplies one piece of print data for a Print Job.
    DocPrintJob
    This interface represents a print job that can print a specified document with a set of job attributes.
    FlavorException
    Interface FlavorException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a doc flavor or flavors (class DocFlavor).
    MultiDoc
    Interface MultiDoc specifies the interface for an object that supplies more than one piece of print data for a Print Job.
    MultiDocPrintJob
    Obtained from a MultiDocPrintService, a MultiDocPrintJob can print a specified collection of documents as a single print job with a set of job attributes.
    MultiDocPrintService
    Interface MultiPrintService is the factory for a MultiDocPrintJob.
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
    URIException
    Interface URIException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a URI address.
  • Class Summary
    类 描述
    DocFlavor
    Class DocFlavor encapsulates an object that specifies the format in which print data is supplied to a DocPrintJob.
    DocFlavor.BYTE_ARRAY
    Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
    DocFlavor.CHAR_ARRAY
    Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
    DocFlavor.INPUT_STREAM
    Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
    DocFlavor.READER
    Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
    DocFlavor.SERVICE_FORMATTED
    Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
    DocFlavor.STRING
    Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
    DocFlavor.URL
    Class DocFlavor.URL provides predefined static constant DocFlavor objects.
    PrintServiceLookup
    Implementations of this class provide lookup services for print services (typically equivalent to printers) of a particular type.
    ServiceUI
    This class is a collection of UI convenience methods which provide a graphical user dialog for browsing print services looked up through the Java Print Service API.
    ServiceUIFactory
    Services may optionally provide UIs which allow different styles of interaction in different roles.
    SimpleDoc
    This class is an implementation of interface Doc that can be used in many common printing requests.
    StreamPrintService
    This class extends PrintService and represents a print service that prints data in different formats to a client-provided output stream.
    StreamPrintServiceFactory
    A StreamPrintServiceFactory is the factory for StreamPrintService instances, which can print to an output stream in a particular document format described as a mime type.
  • Exception Summary
    Exception 描述
    PrintException
    Class PrintException encapsulates a printing-related error condition that occurred while using a Print Service instance.

软件包 javax.print Description

Provides the principal classes and interfaces for the JavaTM Print Service API. The Java Print Service API enables client and server applications to:
  • Discover and select print services based on their capabilities
  • Specify the format of print data
  • Submit print jobs to services that support the document type to be printed.

Print Service Discovery

An application invokes the static methods of the abstract class PrintServiceLookup to locate print services that have the capabilities to satisfy the application's print request. For example, to print a double-sided document, the application first needs to find printers that have the double-sided printing capability.

The JDK includes PrintServiceLookup implementations that can locate the standard platform printers. To locate other types of printers, such as IPP printers or JINI printers, a print-service provider can write implementations of PrintServiceLookup. The print-service provider can dynamically install these PrintServiceLookup implementations using the SPI JAR file specification.

Attribute Definitions

The javax.print.attribute and javax.print.attribute.standard packages define print attributes, which describe the capabilities of a print service, specify the requirements of a print job, and track the progress of a print job.

The javax.print.attribute package describes the types of attributes and how they can be collected into sets. The javax.print.attribute.standard package enumerates all of the standard attributes supported by the API, most of which are implementations of attributes specified in the IETF Specification, RFC 2911 Internet Printing Protocol, 1.1: Model and Semantics, dated September 2000. The attributes specified in javax.print.attribute.standard include common capabilites, such as: resolution, copies, media sizes, job priority, and page ranges.

Document Type Specification

The DocFlavor class represents the print data format, such as JPEG or PostScript. A DocFlavor object consists of a MIME type, which describes the format, and a document representation class name that indicates how the document is delivered to the printer or output stream. An application uses the DocFlavor and an attribute set to find printers that can print the document type specified by the DocFlavor and have the capabilities specified by the attribute set.

Using the API

A typical application using the Java Print Service API performs these steps to process a print request:
  1. Chooses a DocFlavor.
  2. Creates a set of attributes.
  3. Locates a print service that can handle the print request as specified by the DocFlavor and the attribute set.
  4. Creates a Doc object encapsulating the DocFlavor and the actual print data, which can take many forms including: a Postscript file, a JPEG image, a URL, or plain text.
  5. Gets a print job, represented by DocPrintJob, from the print service.
  6. Calls the print method of the print job.
The following code sample demonstrates a typical use of the Java Print Service API: locating printers that can print five double-sided copies of a Postscript document on size A4 paper, creating a print job from one of the returned print services, and calling print.

FileInputStream psStream;
try {
   psStream = new FileInputStream("file.ps");
} catch (FileNotFoundException ffne) {
}
if (psStream == null) {
    return;
}

DocFlavor psInFormat = DocFlavor.INPUT_STREAM.POSTSCRIPT;
Doc myDoc = new SimpleDoc(psStream, psInFormat, null);
PrintRequestAttributeSet aset =
        new HashPrintRequestAttributeSet();
aset.add(new Copies(5));
aset.add(MediaSize.A4);
aset.add(Sides.DUPLEX);
PrintService[] services =
  PrintServiceLookup.lookupPrintServices(psInFormat, aset);
if (services.length > 0) {
   DocPrintJob job = services[0].createPrintJob();
   try {
        job.print(myDoc, aset);
   } catch (PrintException pe) {}
}

Please note: In the javax.print APIs, a null reference parameter to methods is incorrect unless explicitly documented on the method as having a meaningful interpretation. Usage to the contrary is incorrect coding and may result in a run time exception either immediately or at some later time. IllegalArgumentException and NullPointerException are examples of typical and acceptable run time exceptions for such cases.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=t.cFes.eSsl"lte=n


javax.print Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.print

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.print.DocFlavor (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.DocFlavor.BYTE_ARRAY
      • javax.print.DocFlavor.CHAR_ARRAY
      • javax.print.DocFlavor.INPUT_STREAM
      • javax.print.DocFlavor.READER
      • javax.print.DocFlavor.SERVICE_FORMATTED
      • javax.print.DocFlavor.STRING
      • javax.print.DocFlavor.URL
    • javax.print.PrintServiceLookup
    • javax.print.ServiceUI
    • javax.print.ServiceUIFactory
    • javax.print.SimpleDoc (implements javax.print.Doc)
    • javax.print.StreamPrintService (implements javax.print.PrintService)
    • javax.print.StreamPrintServiceFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.print.PrintException

Interface Hierarchy

  • javax.print.AttributeException
  • javax.print.Doc
  • javax.print.DocPrintJob
    • javax.print.CancelablePrintJob
    • javax.print.MultiDocPrintJob
  • javax.print.FlavorException
  • javax.print.MultiDoc
  • javax.print.PrintService
    • javax.print.MultiDocPrintService
  • javax.print.URIException
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

inna/j."...egss vnnan


MultiDoc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface MultiDoc

  • public interface MultiDoc
    Interface MultiDoc specifies the interface for an object that supplies more than one piece of print data for a Print Job. "Doc" is a short, easy-to-pronounce term that means "a piece of print data," and a "multidoc" is a group of several docs. The client passes to the Print Job an object that implements interface MultiDoc, and the Print Job calls methods on that object to obtain the print data.

    Interface MultiDoc provides an abstraction similar to a "linked list" of docs. A multidoc object is like a node in the linked list, containing the current doc in the list and a pointer to the next node (multidoc) in the list. The Print Job can call the multidoc's getDoc() method to get the current doc. When it's ready to go on to the next doc, the Print Job can call the multidoc's next() method to get the next multidoc, which contains the next doc. So Print Job code for accessing a multidoc might look like this:

          void processMultiDoc(MultiDoc theMultiDoc) {

          MultiDoc current = theMultiDoc;

          while (current != null) {
              processDoc (current.getDoc());
              current = current.next();
          }
      }

    Of course, interface MultiDoc can be implemented in any way that fulfills the contract; it doesn't have to use a linked list in the implementation.

    To get all the print data for a multidoc print job, a Print Service proxy could use either of two patterns:

    1. The interleaved pattern: Get the doc from the current multidoc. Get the print data representation object from the current doc. Get all the print data from the print data representation object. Get the next multidoc from the current multidoc, and repeat until there are no more. (The code example above uses the interleaved pattern.)

    2. The all-at-once pattern: Get the doc from the current multidoc, and save the doc in a list. Get the next multidoc from the current multidoc, and repeat until there are no more. Then iterate over the list of saved docs. Get the print data representation object from the current doc. Get all the print data from the print data representation object. Go to the next doc in the list, and repeat until there are no more.
    Now, consider a printing client that is generating print data on the fly and does not have the resources to store more than one piece of print data at a time. If the print service proxy used the all-at-once pattern to get the print data, it would pose a problem for such a client; the client would have to keep all the docs' print data around until the print service proxy comes back and asks for them, which the client is not able to do. To work with such a client, the print service proxy must use the interleaved pattern.

    To address this problem, and to simplify the design of clients providing multiple docs to a Print Job, every Print Service proxy that supports multidoc print jobs is required to access a MultiDoc object using the interleaved pattern. That is, given a MultiDoc object, the print service proxy will call getDoc() one or more times until it successfully obtains the current Doc object. The print service proxy will then obtain the current doc's print data, not proceeding until all the print data is obtained or an unrecoverable error occurs. If it is able to continue, the print service proxy will then call next() one or more times until it successfully obtains either the next MultiDoc object or an indication that there are no more. An implementation of interface MultiDoc can assume the print service proxy will follow this interleaved pattern; for any other pattern of usage, the MultiDoc implementation's behavior is unspecified.

    There is no restriction on the number of client threads that may be simultaneously accessing the same multidoc. Therefore, all implementations of interface MultiDoc must be designed to be multiple thread safe. In fact, a client thread could be adding docs to the end of the (conceptual) list while a Print Job thread is simultaneously obtaining docs from the beginning of the list; provided the multidoc object synchronizes the threads properly, the two threads will not interfere with each other

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Doc getDoc()
      Obtain the current doc object.
      MultiDoc 下一个()
      Go to the multidoc object that contains the next doc object in the sequence of doc objects.

    • 方法详细信息

      • getDoc

        Doc getDoc()
           throws IOException
        Obtain the current doc object.
        返回：
        Current doc object.
        抛出：
        IOException - Thrown if a error ocurred reading the document.

      • 下一个

        MultiDoc next()
              throws IOException
        Go to the multidoc object that contains the next doc object in the sequence of doc objects.
        返回：
        Multidoc object containing the next doc object, or null if there are no further doc objects.
        抛出：
        IOException - Thrown if an error occurred locating the next document
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dieies sirnbirr .tte �.ipcee


MultiDocPrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface MultiDocPrintJob

  • All Superinterfaces:
    DocPrintJob

    public interface MultiDocPrintJob
extends DocPrintJob
    Obtained from a MultiDocPrintService, a MultiDocPrintJob can print a specified collection of documents as a single print job with a set of job attributes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
      Print a MultiDoc with the specified job attributes.

      • 方法 - 继承于接口 javax.print.DocPrintJob

        addPrintJobAttributeListener, addPrintJobListener, getAttributes, getPrintService, print, removePrintJobAttributeListener, removePrintJobListener

    • 方法详细信息

      • print

        void print(MultiDoc multiDoc,
         PrintRequestAttributeSet attributes)
           throws PrintException
        Print a MultiDoc with the specified job attributes. This method should only be called once for a given print job. Calling it again will not result in a new job being spooled to the printer. The service implementation will define policy for service interruption and recovery. Application clients which want to monitor the success or failure should register a PrintJobListener.
        参数：
        multiDoc - The documents to be printed. ALL must be a flavor supported by the PrintJob & PrintService.
        attributes - The job attributes to be applied to this print job. If this parameter is null then the default attributes are used.
        抛出：
        PrintException - The exception additionally may implement an interfaces which more precisely describes the cause of the exception
        • FlavorException. If the document has a flavor not supported by this print job.
        • AttributeException. If one or more of the attributes are not valid for this print job.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ry_aa<"><"s>>"ss vtt>"< n>>aao


MultiDocPrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface MultiDocPrintService

  • All Superinterfaces:
    PrintService

    public interface MultiDocPrintService
extends PrintService
    Interface MultiPrintService is the factory for a MultiDocPrintJob. A MultiPrintService describes the capabilities of a Printer and can be queried regarding a printer's supported attributes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MultiDocPrintJob createMultiDocPrintJob()
      Create a job which can print a multiDoc.

      • 方法 - 继承于接口 javax.print.PrintService

        addPrintServiceAttributeListener, createPrintJob, equals, getAttribute, getAttributes, getDefaultAttributeValue, getName, getServiceUIFactory, getSupportedAttributeCategories, getSupportedAttributeValues, getSupportedDocFlavors, getUnsupportedAttributes, hashCode, isAttributeCategorySupported, isAttributeValueSupported, isDocFlavorSupported, removePrintServiceAttributeListener

    • 方法详细信息

      • createMultiDocPrintJob

        MultiDocPrintJob createMultiDocPrintJob()
        Create a job which can print a multiDoc.
        返回：
        a MultiDocPrintJob
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mreEaE>EuESDcumto>热n.tadoam.l/ja


PrintException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print

类 PrintException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.print.PrintException
  • 所有已实现的接口：
    Serializable

    public class PrintException
extends Exception
    Class PrintException encapsulates a printing-related error condition that occurred while using a Print Service instance. This base class furnishes only a string description of the error. Subclasses furnish more detailed information if applicable.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintException()
      Construct a print exception with no detail message.
      PrintException(Exception e)
      Construct a print exception chaining the supplied exception.
      PrintException(String s)
      Construct a print exception with the given detail message.
      PrintException(String s, Exception e)
      Construct a print exception with the given detail message and chained exception.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrintException

        public PrintException()
        Construct a print exception with no detail message.

      • PrintException

        public PrintException(String s)
        Construct a print exception with the given detail message.
        参数：
        s - Detail message, or null if no detail message.

      • PrintException

        public PrintException(Exception e)
        Construct a print exception chaining the supplied exception.
        参数：
        e - Chained exception.

      • PrintException

        public PrintException(String s,
              Exception e)
        Construct a print exception with the given detail message and chained exception.
        参数：
        s - Detail message, or null if no detail message.
        e - Chained exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>maktkatn/np//j=ssaus=ae"y"sg"nir p


PrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface PrintService

  • All Known Subinterfaces:
    MultiDocPrintService
    All Known Implementing Classes:
    StreamPrintService

    public interface PrintService
    Interface PrintService is the factory for a DocPrintJob. A PrintService describes the capabilities of a Printer and can be queried regarding a printer's supported attributes.

    Example:

       DocFlavor flavor = DocFlavor.INPUT_STREAM.POSTSCRIPT;
   PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
   aset.add(MediaSizeName.ISO_A4);
   PrintService[] pservices =
                 PrintServiceLookup.lookupPrintServices(flavor, aset);
   if (pservices.length > 0) {
       DocPrintJob pj = pservices[0].createPrintJob();
       try {
           FileInputStream fis = new FileInputStream("test.ps");
           Doc doc = new SimpleDoc(fis, flavor, null);
           pj.print(doc, aset);
        } catch (FileNotFoundException fe) {
        } catch (PrintException e) {
        }
   }

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPrintServiceAttributeListener(PrintServiceAttributeListener listener)
      Registers a listener for events on this PrintService.
      DocPrintJob createPrintJob()
      Creates and returns a PrintJob capable of handling data from any of the supported document flavors.
      boolean equals(Object obj)
      Determines if two services are referring to the same underlying service.
      <T extends PrintServiceAttribute>
      T             		getAttribute(类<T> category)
      Gets the value of the single specified service attribute.
      PrintServiceAttributeSet getAttributes()
      Obtains this print service's set of printer description attributes giving this Print Service's status.
      Object getDefaultAttributeValue(类<? extends Attribute> category)
      Determines this print service's default printing attribute value in the given category.
      String getName()
      Returns a String name for this print service which may be used by applications to request a particular print service.
      ServiceUIFactory getServiceUIFactory()
      Returns a factory for UI components which allow users to interact with the service in various roles.
      类<?>[] getSupportedAttributeCategories()
      Determines the printing attribute categories a client can specify when setting up a job for this print service.
      Object getSupportedAttributeValues(类<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
      Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.
      DocFlavor[] getSupportedDocFlavors()
      Determines the print data formats a client can specify when setting up a job for this PrintService.
      AttributeSet getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
      Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.
      int hashCode()
      This method should be implemented consistently with equals(Object).
      boolean isAttributeCategorySupported(类<? extends Attribute> category)
      Determines whether a client can specify the given printing attribute category when setting up a job for this print service.
      boolean isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
      Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
      boolean isDocFlavorSupported(DocFlavor flavor)
      Determines if this print service supports a specific DocFlavor.
      void removePrintServiceAttributeListener(PrintServiceAttributeListener listener)
      Removes the print-service listener from this print service.

    • 方法详细信息

      • getName

        String getName()
        Returns a String name for this print service which may be used by applications to request a particular print service. In a suitable context, such as a name service, this name must be unique. In some environments this unique name may be the same as the user friendly printer name defined as the PrinterName attribute.
        返回：
        name of the service.

      • createPrintJob

        DocPrintJob createPrintJob()
        Creates and returns a PrintJob capable of handling data from any of the supported document flavors.
        返回：
        a DocPrintJob object

      • addPrintServiceAttributeListener

        void addPrintServiceAttributeListener(PrintServiceAttributeListener listener)
        Registers a listener for events on this PrintService.
        参数：
        listener - a PrintServiceAttributeListener, which monitors the status of a print service
        另请参见：
        removePrintServiceAttributeListener(javax.print.event.PrintServiceAttributeListener)

      • removePrintServiceAttributeListener

        void removePrintServiceAttributeListener(PrintServiceAttributeListener listener)
        Removes the print-service listener from this print service. This means the listener is no longer interested in PrintService events.
        参数：
        listener - a PrintServiceAttributeListener object
        另请参见：
        addPrintServiceAttributeListener(javax.print.event.PrintServiceAttributeListener)

      • getAttributes

        PrintServiceAttributeSet getAttributes()
        Obtains this print service's set of printer description attributes giving this Print Service's status. The returned attribute set object is unmodifiable. The returned attribute set object is a "snapshot" of this Print Service's attribute set at the time of the getAttributes() method call: that is, the returned attribute set's contents will not be updated if this print service's attribute set's contents change in the future. To detect changes in attribute values, call getAttributes() again and compare the new attribute set to the previous attribute set; alternatively, register a listener for print service events.
        返回：
        Unmodifiable snapshot of this Print Service's attribute set. May be empty, but not null.

      • getAttribute

        <T extends PrintServiceAttribute> T getAttribute(类<T> category)
        Gets the value of the single specified service attribute. This may be useful to clients which only need the value of one attribute and want to minimise overhead.
        参数：
        category - the category of a PrintServiceAttribute supported by this service - may not be null.
        返回：
        the value of the supported attribute or null if the attribute is not supported by this service.
        抛出：
        NullPointerException - if the category is null.
        IllegalArgumentException - (unchecked exception) if category is not a 类 that implements interface PrintServiceAttribute.

      • getSupportedDocFlavors

        DocFlavor[] getSupportedDocFlavors()
        Determines the print data formats a client can specify when setting up a job for this PrintService. A print data format is designated by a "doc flavor" (class DocFlavor) consisting of a MIME type plus a print data representation class.

        Note that some doc flavors may not be supported in combination with all attributes. Use getUnsupportedAttributes(..) to validate specific combinations.

        返回：
        Array of supported doc flavors, should have at least one element.

      • isDocFlavorSupported

        boolean isDocFlavorSupported(DocFlavor flavor)
        Determines if this print service supports a specific DocFlavor. This is a convenience method to determine if the DocFlavor would be a member of the result of getSupportedDocFlavors().

        Note that some doc flavors may not be supported in combination with all attributes. Use getUnsupportedAttributes(..) to validate specific combinations.

        参数：
        flavor - the DocFlavorto query for support.
        返回：
        true if this print service supports the specified DocFlavor; false otherwise.
        抛出：
        NullPointerException - (unchecked exception) Thrown if flavor is null.

      • getSupportedAttributeCategories

        类<?>[] getSupportedAttributeCategories()
        Determines the printing attribute categories a client can specify when setting up a job for this print service. A printing attribute category is designated by a 类 that implements interface Attribute. This method returns just the attribute categories that are supported; it does not return the particular attribute values that are supported.

        This method returns all the printing attribute categories this print service supports for any possible job. Some categories may not be supported in a particular context (ie for a particular DocFlavor). Use one of the methods that include a DocFlavor to validate the request before submitting it, such as getSupportedAttributeValues(..).

        返回：
        Array of printing attribute categories that the client can specify as a doc-level or job-level attribute in a Print Request. Each element in the array is a 类 that implements interface Attribute. The array is empty if no categories are supported.

      • isAttributeCategorySupported

        boolean isAttributeCategorySupported(类<? extends Attribute> category)
        Determines whether a client can specify the given printing attribute category when setting up a job for this print service. A printing attribute category is designated by a 类 that implements interface Attribute. This method tells whether the attribute category is supported; it does not tell whether a particular attribute value is supported.

        Some categories may not be supported in a particular context (ie for a particular DocFlavor). Use one of the methods which include a DocFlavor to validate the request before submitting it, such as getSupportedAttributeValues(..).

        This is a convenience method to determine if the category would be a member of the result of getSupportedAttributeCategories().

        参数：
        category - Printing attribute category to test. It must be a 类 that implements interface Attribute.
        返回：
        true if this print service supports specifying a doc-level or job-level attribute in category in a Print Request; false if it doesn't.
        抛出：
        NullPointerException - (unchecked exception) Thrown if category is null.
        IllegalArgumentException - (unchecked exception) Thrown if category is not a 类 that implements interface Attribute.

      • getDefaultAttributeValue

        Object getDefaultAttributeValue(类<? extends Attribute> category)
        Determines this print service's default printing attribute value in the given category. A printing attribute value is an instance of a class that implements interface Attribute. If a client sets up a print job and does not specify any attribute value in the given category, this Print Service will use the default attribute value instead.

        Some attributes may not be supported in a particular context (ie for a particular DocFlavor). Use one of the methods that include a DocFlavor to validate the request before submitting it, such as getSupportedAttributeValues(..).

        Not all attributes have a default value. For example the service will not have a defaultvalue for RequestingUser i.e. a null return for a supported category means there is no service default value for that category. Use the isAttributeCategorySupported(Class) method to distinguish these cases.

        参数：
        category - Printing attribute category for which the default attribute value is requested. It must be a 类 that implements interface Attribute.
        返回：
        Default attribute value for category, or null if this Print Service does not support specifying a doc-level or job-level attribute in category in a Print Request, or the service does not have a default value for this attribute.
        抛出：
        NullPointerException - (unchecked exception) Thrown if category is null.
        IllegalArgumentException - (unchecked exception) Thrown if category is not a 类 that implements interface Attribute.

      • getSupportedAttributeValues

        Object getSupportedAttributeValues(类<? extends Attribute> category,
                                 DocFlavor flavor,
                                 AttributeSet attributes)
        Determines the printing attribute values a client can specify in the given category when setting up a job for this print service. A printing attribute value is an instance of a class that implements interface Attribute.

        If flavor is null and attributes is null or is an empty set, this method returns all the printing attribute values this Print Service supports for any possible job. If flavor is not null or attributes is not an empty set, this method returns just the printing attribute values that are compatible with the given doc flavor and/or set of attributes. That is, a null return value may indicate that specifying this attribute is incompatible with the specified DocFlavor. Also if DocFlavor is not null it must be a flavor supported by this PrintService, else IllegalArgumentException will be thrown.

        If the attributes parameter contains an Attribute whose category is the same as the category parameter, the service must ignore this attribute in the AttributeSet.

        DocAttributes which are to be specified on the Doc must be included in this set to accurately represent the context.

        This method returns an Object because different printing attribute categories indicate the supported attribute values in different ways. The documentation for each printing attribute in package javax.print.attribute.standard describes how each attribute indicates its supported values. Possible ways of indicating support include:

        • Return a single instance of the attribute category to indicate that any value is legal -- used, for example, by an attribute whose value is an arbitrary text string. (The value of the returned attribute object is irrelevant.)
        • Return an array of one or more instances of the attribute category, containing the legal values -- used, for example, by an attribute with a list of enumerated values. The type of the array is an array of the specified attribute category type as returned by its getCategory(Class).
        • Return a single object (of some class other than the attribute category) that indicates bounds on the legal values -- used, for example, by an integer-valued attribute that must lie within a certain range.

        参数：
        category - Printing attribute category to test. It must be a 类 that implements interface Attribute.
        flavor - Doc flavor for a supposed job, or null.
        attributes - Set of printing attributes for a supposed job (both job-level attributes and document-level attributes), or null.
        返回：
        Object indicating supported values for category, or null if this Print Service does not support specifying a doc-level or job-level attribute in category in a Print Request.
        抛出：
        NullPointerException - (unchecked exception) Thrown if category is null.
        IllegalArgumentException - (unchecked exception) Thrown if category is not a 类 that implements interface Attribute, or DocFlavor is not supported by this service.

      • isAttributeValueSupported

        boolean isAttributeValueSupported(Attribute attrval,
                                DocFlavor flavor,
                                AttributeSet attributes)
        Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service. A printing attribute value is an instance of a class that implements interface Attribute.

        If flavor is null and attributes is null or is an empty set, this method tells whether this Print Service supports the given printing attribute value for some possible combination of doc flavor and set of attributes. If flavor is not null or attributes is not an empty set, this method tells whether this Print Service supports the given printing attribute value in combination with the given doc flavor and/or set of attributes.

        Also if DocFlavor is not null it must be a flavor supported by this PrintService, else IllegalArgumentException will be thrown.

        DocAttributes which are to be specified on the Doc must be included in this set to accurately represent the context.

        This is a convenience method to determine if the value would be a member of the result of getSupportedAttributeValues(...).

        参数：
        attrval - Printing attribute value to test.
        flavor - Doc flavor for a supposed job, or null.
        attributes - Set of printing attributes for a supposed job (both job-level attributes and document-level attributes), or null.
        返回：
        True if this Print Service supports specifying attrval as a doc-level or job-level attribute in a Print Request, false if it doesn't.
        抛出：
        NullPointerException - (unchecked exception) if attrval is null.
        IllegalArgumentException - if flavor is not supported by this PrintService.

      • getUnsupportedAttributes

        AttributeSet getUnsupportedAttributes(DocFlavor flavor,
                                    AttributeSet attributes)
        Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor. This method is useful for validating a potential print job and identifying the specific attributes which cannot be supported. It is important to supply only a supported DocFlavor or an IllegalArgumentException will be thrown. If the return value from this method is null, all attributes are supported.

        DocAttributes which are to be specified on the Doc must be included in this set to accurately represent the context.

        If the return value is non-null, all attributes in the returned set are unsupported with this DocFlavor. The returned set does not distinguish attribute categories that are unsupported from unsupported attribute values.

        A supported print request can then be created by removing all unsupported attributes from the original attribute set, except in the case that the DocFlavor is unsupported.

        If any attributes are unsupported only because they are in conflict with other attributes then it is at the discretion of the service to select the attribute(s) to be identified as the cause of the conflict.

        Use isDocFlavorSupported() to verify that a DocFlavor is supported before calling this method.

        参数：
        flavor - Doc flavor to test, or null
        attributes - Set of printing attributes for a supposed job (both job-level attributes and document-level attributes), or null.
        返回：
        null if this Print Service supports the print request specification, else the unsupported attributes.
        抛出：
        IllegalArgumentException - ifflavor is not supported by this PrintService.

      • getServiceUIFactory

        ServiceUIFactory getServiceUIFactory()
        Returns a factory for UI components which allow users to interact with the service in various roles. Services which do not provide any UI should return null. Print Services which do provide UI but want to be supported in an environment with no UI support should ensure that the factory is not initialised unless the application calls this method to obtain the factory. See ServiceUIFactory for more information.
        返回：
        null or a factory for UI components.

      • equals

        boolean equals(Object obj)
        Determines if two services are referring to the same underlying service. Objects encapsulating a print service may not exhibit equality of reference even though they refer to the same underlying service.

        Clients should call this method to determine if two services are referring to the same underlying service.

        Services must implement this method and return true only if the service objects being compared may be used interchangeably by the client. Services are free to return the same object reference to an underlying service if that, but clients must not depend on equality of reference.

        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this service is the same as the obj argument, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        This method should be implemented consistently with equals(Object).
        重载：
        hashCode in class Object
        返回：
        hash code of this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


PrintServiceLookup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 PrintServiceLookup

  • java.lang.Object
    • javax.print.PrintServiceLookup

  • public abstract class PrintServiceLookup
extends Object
    Implementations of this class provide lookup services for print services (typically equivalent to printers) of a particular type.

    Multiple implementations may be installed concurrently. All implementations must be able to describe the located printers as instances of a PrintService. Typically implementations of this service class are located automatically in JAR files (see the SPI JAR file specification). These classes must be instantiable using a default constructor. Alternatively applications may explicitly register instances at runtime.

    Applications use only the static methods of this abstract class. The instance methods are implemented by a service provider in a subclass and the unification of the results from all installed lookup classes are reported by the static methods of this class when called by the application.

    A PrintServiceLookup implementor is recommended to check for the SecurityManager.checkPrintJobAccess() to deny access to untrusted code. Following this recommended policy means that untrusted code may not be able to locate any print services. Downloaded applets are the most common example of untrusted code.

    This check is made on a per lookup service basis to allow flexibility in the policy to reflect the needs of different lookup services.

    Services which are registered by registerService(PrintService) will not be included in lookup results if a security manager is installed and its checkPrintJobAccess() method denies access.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintServiceLookup()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract PrintService getDefaultPrintService()
      Not called directly by applications.
      abstract MultiDocPrintService[] getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Not called directly by applications.
      abstract PrintService[] getPrintServices()
      Not called directly by applications.
      abstract PrintService[] getPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.
      static PrintService lookupDefaultPrintService()
      Locates the default print service for this environment.
      static MultiDocPrintService[] lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.
      static PrintService[] lookupPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates print services capable of printing the specified DocFlavor.
      static boolean registerService(PrintService service)
      Allows an application to directly register an instance of a class which implements a print service.
      static boolean registerServiceProvider(PrintServiceLookup sp)
      Allows an application to explicitly register a class that implements lookup services.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PrintServiceLookup

        public PrintServiceLookup()

    • 方法详细信息

      • lookupPrintServices

        public static final PrintService[] lookupPrintServices(DocFlavor flavor,
                                 AttributeSet attributes)
        Locates print services capable of printing the specified DocFlavor.
        参数：
        flavor - the flavor to print. If null, this constraint is not used.
        attributes - attributes that the print service must support. If null this constraint is not used.
        返回：
        array of matching PrintService objects representing print services that support the specified flavor attributes. If no services match, the array is zero-length.

      • lookupMultiDocPrintServices

        public static final MultiDocPrintService[] lookupMultiDocPrintServices(DocFlavor[] flavors,
                                                 AttributeSet attributes)
        Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.

        This method is useful to help locate a service that can print a MultiDoc in which the elements may be different flavors. An application could perform this itself by multiple lookups on each DocFlavor in turn and collating the results, but the lookup service may be able to do this more efficiently.

        参数：
        flavors - the flavors to print. If null or empty this constraint is not used. Otherwise return only multidoc print services that can print all specified doc flavors.
        attributes - attributes that the print service must support. If null this constraint is not used.
        返回：
        array of matching MultiDocPrintService objects. If no services match, the array is zero-length.

      • lookupDefaultPrintService

        public static final PrintService lookupDefaultPrintService()
        Locates the default print service for this environment. This may return null. If multiple lookup services each specify a default, the chosen service is not precisely defined, but a platform native service, rather than an installed service, is usually returned as the default. If there is no clearly identifiable platform native default print service, the default is the first to be located in an implementation-dependent manner.

        This may include making use of any preferences API that is available as part of the Java or native platform. This algorithm may be overridden by a user setting the property javax.print.defaultPrinter. A service specified must be discovered to be valid and currently available to be returned as the default.

        返回：
        the default PrintService.

      • registerServiceProvider

        public static boolean registerServiceProvider(PrintServiceLookup sp)
        Allows an application to explicitly register a class that implements lookup services. The registration will not persist across VM invocations. This is useful if an application needs to make a new service available that is not part of the installation. If the lookup service is already registered, or cannot be registered, the method returns false.

        参数：
        sp - an implementation of a lookup service.
        返回：
        true if the new lookup service is newly registered; false otherwise.

      • registerService

        public static boolean registerService(PrintService service)
        Allows an application to directly register an instance of a class which implements a print service. The lookup operations for this service will be performed by the PrintServiceLookup class using the attribute values and classes reported by the service. This may be less efficient than a lookup service tuned for that service. Therefore registering a PrintServiceLookup instance instead is recommended. The method returns true if this service is not previously registered and is now successfully registered. This method should not be called with StreamPrintService instances. They will always fail to register and the method will return false.
        参数：
        service - an implementation of a print service.
        返回：
        true if the service is newly registered; false otherwise.

      • getPrintServices

        public abstract PrintService[] getPrintServices(DocFlavor flavor,
                              AttributeSet attributes)
        Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified. This method is not called directly by applications.

        Implemented by a service provider, used by the static methods of this class.

        The results should be the same as obtaining all the PrintServices and querying each one individually on its support for the specified attributes and flavors, but the process can be more efficient by taking advantage of the capabilities of lookup services for the print services.

        参数：
        flavor - of document required. If null it is ignored.
        attributes - required to be supported. If null this constraint is not used.
        返回：
        array of matching PrintServices. If no services match, the array is zero-length.

      • getPrintServices

        public abstract PrintService[] getPrintServices()
        Not called directly by applications. Implemented by a service provider, used by the static methods of this class.
        返回：
        array of all PrintServices known to this lookup service class. If none are found, the array is zero-length.

      • getMultiDocPrintServices

        public abstract MultiDocPrintService[] getMultiDocPrintServices(DocFlavor[] flavors,
                                              AttributeSet attributes)
        Not called directly by applications.

        Implemented by a service provider, used by the static methods of this class.

        Locates MultiDoc print services which can be positively confirmed to support the combination of attributes and DocFlavors specified.

        参数：
        flavors - of documents required. If null or empty it is ignored.
        attributes - required to be supported. If null this constraint is not used.
        返回：
        array of matching PrintServices. If no services match, the array is zero-length.

      • getDefaultPrintService

        public abstract PrintService getDefaultPrintService()
        Not called directly by applications. Implemented by a service provider, and called by the print lookup service
        返回：
        the default PrintService for this lookup service. If there is no default, returns null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tc /OoCOogrrogg>illtrst evisp r>>uioe


ServiceUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 ServiceUI

  • java.lang.Object
    • javax.print.ServiceUI

  • public class ServiceUI
extends Object
    This class is a collection of UI convenience methods which provide a graphical user dialog for browsing print services looked up through the Java Print Service API.

    The dialogs follow a standard pattern of acting as a continue/cancel option for a user as well as allowing the user to select the print service to use and specify choices such as paper size and number of copies.

    The dialogs are designed to work with pluggable print services though the public APIs of those print services.

    If a print service provides any vendor extensions these may be made accessible to the user through a vendor supplied tab panel Component. Such a vendor extension is encouraged to use Swing! and to support its accessibility APIs. The vendor extensions should return the settings as part of the AttributeSet. Applications which want to preserve the user settings should use those settings to specify the print job. Note that this class is not referenced by any other part of the Java Print Service and may not be included in profiles which cannot depend on the presence of the AWT packages.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static PrintService printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceUI

        public ServiceUI()

    • 方法详细信息

      • printDialog

        public static PrintService printDialog(GraphicsConfiguration gc,
                       int x,
                       int y,
                       PrintService[] services,
                       PrintService defaultService,
                       DocFlavor flavor,
                       PrintRequestAttributeSet attributes)
                                throws HeadlessException
        Presents a dialog to the user for selecting a print service (printer). It is displayed at the location specified by the application and is modal. If the specification is invalid or would make the dialog not visible it will be displayed at a location determined by the implementation. The dialog blocks its calling thread and is application modal.

        The dialog may include a tab panel with custom UI lazily obtained from the PrintService's ServiceUIFactory when the PrintService is browsed. The dialog will attempt to locate a MAIN_UIROLE first as a JComponent, then as a Panel. If there is no ServiceUIFactory or no matching role the custom tab will be empty or not visible.

        The dialog returns the print service selected by the user if the user OK's the dialog and null if the user cancels the dialog.

        An application must pass in an array of print services to browse. The array must be non-null and non-empty. Typically an application will pass in only PrintServices capable of printing a particular document flavor.

        An application may pass in a PrintService to be initially displayed. A non-null parameter must be included in the array of browsable services. If this parameter is null a service is chosen by the implementation.

        An application may optionally pass in the flavor to be printed. If this is non-null choices presented to the user can be better validated against those supported by the services. An application must pass in a PrintRequestAttributeSet for returning user choices. On calling the PrintRequestAttributeSet may be empty, or may contain application-specified values.

        These are used to set the initial settings for the initially displayed print service. Values which are not supported by the print service are ignored. As the user browses print services, attributes and values are copied to the new display. If a user browses a print service which does not support a particular attribute-value, the default for that service is used as the new value to be copied.

        If the user cancels the dialog, the returned attributes will not reflect any changes made by the user. A typical basic usage of this method may be :

         PrintService[] services = PrintServiceLookup.lookupPrintServices(
                            DocFlavor.INPUT_STREAM.JPEG, null);
 PrintRequestAttributeSet attributes = new HashPrintRequestAttributeSet();
 if (services.length > 0) {
    PrintService service =  ServiceUI.printDialog(null, 50, 50,
                                               services, services[0],
                                               null,
                                               attributes);
    if (service != null) {
     ... print ...
    }
 }

        参数：
        gc - used to select screen. null means primary or default screen.
        x - location of dialog including border in screen coordinates
        y - location of dialog including border in screen coordinates
        services - to be browsable, must be non-null.
        defaultService - - initial PrintService to display.
        flavor - - the flavor to be printed, or null.
        attributes - on input is the initial application supplied preferences. This cannot be null but may be empty. On output the attributes reflect changes made by the user.
        返回：
        print service selected by the user, or null if the user cancelled the dialog.
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        IllegalArgumentException - if services is null or empty, or attributes is null, or the initial PrintService is not in the list of browsable services.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kc/ieSceSteeStttuaa/./atnnPncteii..e=mv


ServiceUIFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 ServiceUIFactory

  • java.lang.Object
    • javax.print.ServiceUIFactory

  • public abstract class ServiceUIFactory
extends Object
    Services may optionally provide UIs which allow different styles of interaction in different roles. One role may be end-user browsing and setting of print options. Another role may be administering the print service.

    Although the Print Service API does not presently provide standardised support for administering a print service, monitoring of the print service is possible and a UI may provide for private update mechanisms.

    The basic design intent is to allow applications to lazily locate and initialize services only when needed without any API dependencies except in an environment in which they are used.

    Swing UIs are preferred as they provide a more consistent L&F and can support accessibility APIs.

    Example usage:

      ServiceUIFactory factory = printService.getServiceUIFactory();
  if (factory != null) {
      JComponent swingui = (JComponent)factory.getUI(
                                         ServiceUIFactory.MAIN_UIROLE,
                                         ServiceUIFactory.JCOMPONENT_UI);
      if (swingui != null) {
          tabbedpane.add("Custom UI", swingui);
      }
  }

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ABOUT_UIROLE
      Denotes a UI which performs an informative "About" role.
      static int ADMIN_UIROLE
      Denotes a UI which performs an administrative role.
      static String DIALOG_UI
      Denotes a UI implemented as an AWT dialog.
      static String JCOMPONENT_UI
      Denotes a UI implemented as a Swing component.
      static String JDIALOG_UI
      Denotes a UI implemented as a Swing dialog.
      static int MAIN_UIROLE
      Denotes a UI which performs the normal end user role.
      static String PANEL_UI
      Denotes a UI implemented as an AWT panel.
      static int RESERVED_UIROLE
      Not a valid role but role id's greater than this may be used for private roles supported by a service.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceUIFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Object getUI(int role, String ui)
      Get a UI object which may be cast to the requested UI type by the application and used in its user interface.
      abstract String[] getUIClassNamesForRole(int role)
      Given a UI role obtained from this factory obtain the UI types available from this factory which implement this role.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JCOMPONENT_UI

        public static final String JCOMPONENT_UI
        Denotes a UI implemented as a Swing component. The value of the String is the fully qualified classname : "javax.swing.JComponent".
        另请参见：
        Constant Field Values

      • PANEL_UI

        public static final String PANEL_UI
        Denotes a UI implemented as an AWT panel. The value of the String is the fully qualified classname : "java.awt.Panel"
        另请参见：
        Constant Field Values

      • DIALOG_UI

        public static final String DIALOG_UI
        Denotes a UI implemented as an AWT dialog. The value of the String is the fully qualified classname : "java.awt.Dialog"
        另请参见：
        Constant Field Values

      • JDIALOG_UI

        public static final String JDIALOG_UI
        Denotes a UI implemented as a Swing dialog. The value of the String is the fully qualified classname : "javax.swing.JDialog"
        另请参见：
        Constant Field Values

      • ABOUT_UIROLE

        public static final int ABOUT_UIROLE
        Denotes a UI which performs an informative "About" role.
        另请参见：
        Constant Field Values

      • ADMIN_UIROLE

        public static final int ADMIN_UIROLE
        Denotes a UI which performs an administrative role.
        另请参见：
        Constant Field Values

      • MAIN_UIROLE

        public static final int MAIN_UIROLE
        Denotes a UI which performs the normal end user role.
        另请参见：
        Constant Field Values

      • RESERVED_UIROLE

        public static final int RESERVED_UIROLE
        Not a valid role but role id's greater than this may be used for private roles supported by a service. Knowledge of the function performed by this role is required to make proper use of it.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ServiceUIFactory

        public ServiceUIFactory()

    • 方法详细信息

      • getUI

        public abstract Object getUI(int role,
           String ui)
        Get a UI object which may be cast to the requested UI type by the application and used in its user interface.

        参数：
        role - requested. Must be one of the standard roles or a private role supported by this factory.
        ui - type in which the role is requested.
        返回：
        the UI role or null if the requested UI role is not available from this factory
        抛出：
        IllegalArgumentException - if the role or ui is neither one of the standard ones, nor a private one supported by the factory.

      • getUIClassNamesForRole

        public abstract String[] getUIClassNamesForRole(int role)
        Given a UI role obtained from this factory obtain the UI types available from this factory which implement this role. The returned Strings should refer to the static variables defined in this class so that applications can use equality of reference ("==").
        参数：
        role - to be looked up.
        返回：
        the UI types supported by this class for the specified role, null if no UIs are available for the role.
        抛出：
        IllegalArgumentException - is the role is a non-standard role not supported by this factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r(ima y >daa>ddd/ggpstdeernutp oIsppst. to


SimpleDoc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 SimpleDoc

  • java.lang.Object
    • javax.print.SimpleDoc
  • 所有已实现的接口：
    Doc

    public final class SimpleDoc
extends Object
implements Doc
    This class is an implementation of interface Doc that can be used in many common printing requests. It can handle all of the presently defined "pre-defined" doc flavors defined as static variables in the DocFlavor class.

    In particular this class implements certain required semantics of the Doc specification as follows:

    • constructs a stream for the service if requested and appropriate.
    • ensures the same object is returned for each call on a method.
    • ensures multiple threads can access the Doc
    • performs some validation of that the data matches the doc flavor.
    Clients who want to re-use the doc object in other jobs, or need a MultiDoc will not want to use this class.

    If the print data is a stream, or a print job requests data as a stream, then SimpleDoc does not monitor if the service properly closes the stream after data transfer completion or job termination. Clients may prefer to use provide their own implementation of doc that adds a listener to monitor job completion and to validate that resources such as streams are freed (ie closed).

    • 构造方法摘要

      Constructors
      构造方法与描述
      SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
      Constructs a SimpleDoc with the specified print data, doc flavor and doc attribute set.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DocAttributeSet getAttributes()
      Obtains the set of printing attributes for this doc object.
      DocFlavor getDocFlavor()
      Determines the doc flavor in which this doc object will supply its piece of print data.
      Object getPrintData()
      Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor.
      Reader getReaderForText()
      Obtains a reader for extracting character print data from this doc.
      InputStream getStreamForBytes()
      Obtains an input stream for extracting byte print data from this doc.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SimpleDoc

        public SimpleDoc(Object printData,
         DocFlavor flavor,
         DocAttributeSet attributes)
        Constructs a SimpleDoc with the specified print data, doc flavor and doc attribute set.
        参数：
        printData - the print data object
        flavor - the DocFlavor object
        attributes - a DocAttributeSet, which can be null
        抛出：
        IllegalArgumentException - if flavor or printData is null, or the printData does not correspond to the specified doc flavor--for example, the data is not of the type specified as the representation in the DocFlavor.

    • 方法详细信息

      • getDocFlavor

        public DocFlavor getDocFlavor()
        Determines the doc flavor in which this doc object will supply its piece of print data.
        指定者：
        getDocFlavor in interface Doc
        返回：
        Doc flavor.

      • getAttributes

        public DocAttributeSet getAttributes()
        Obtains the set of printing attributes for this doc object. If the returned attribute set includes an instance of a particular attribute X, the printer must use that attribute value for this doc, overriding any value of attribute X in the job's attribute set. If the returned attribute set does not include an instance of a particular attribute X or if null is returned, the printer must consult the job's attribute set to obtain the value for attribute X, and if not found there, the printer must use an implementation-dependent default value. The returned attribute set is unmodifiable.
        指定者：
        getAttributes in interface Doc
        返回：
        Unmodifiable set of printing attributes for this doc, or null to obtain all attribute values from the job's attribute set.

      • getPrintData

        public Object getPrintData()
                    throws IOException
        从接口复制的描述： Doc
        Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor. The getPrintData() method returns an instance of the representation class whose name is given by getDocFlavor().getRepresentationClassName(), and the return value can be cast from class Object to that representation class.
        指定者：
        getPrintData in interface Doc
        返回：
        Print data representation object.
        抛出：
        IOException - Thrown if the representation class is a stream and there was an I/O error while constructing the stream.

      • getReaderForText

        public Reader getReaderForText()
                        throws IOException
        Obtains a reader for extracting character print data from this doc. The Doc implementation is required to support this method if the DocFlavor has one of the following print data representation classes, and return null otherwise:
        • char[]
        • java.lang.String
        • java.io.Reader
        The doc's print data representation object is used to construct and return a Reader for reading the print data as a stream of characters from the print data representation object. However, if the print data representation object is itself a Reader then the print data representation object is simply returned.

        指定者：
        getReaderForText in interface Doc
        返回：
        a Reader for reading the print data characters from this doc. If a reader cannot be provided because this doc does not meet the criteria stated above, null is returned.
        抛出：
        IOException - if there was an I/O error while creating the reader.

      • getStreamForBytes

        public InputStream getStreamForBytes()
                              throws IOException
        Obtains an input stream for extracting byte print data from this doc. The Doc implementation is required to support this method if the DocFlavor has one of the following print data representation classes; otherwise this method returns null:
        • byte[]
        • java.io.InputStream
        The doc's print data representation object is obtained. Then, an input stream for reading the print data from the print data representation object as a stream of bytes is created and returned. However, if the print data representation object is itself an input stream then the print data representation object is simply returned.

        指定者：
        getStreamForBytes in interface Doc
        返回：
        an InputStream for reading the print data bytes from this doc. If an input stream cannot be provided because this doc does not meet the criteria stated above, null is returned.
        抛出：
        IOException - if there was an I/O error while creating the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irtar>t<<>ttnntt,r rdeeuru st d>t>hud


StreamPrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 StreamPrintService

  • java.lang.Object
    • javax.print.StreamPrintService
  • 所有已实现的接口：
    PrintService

    public abstract class StreamPrintService
extends Object
implements PrintService
    This class extends PrintService and represents a print service that prints data in different formats to a client-provided output stream. This is principally intended for services where the output format is a document type suitable for viewing or archiving. The output format must be declared as a mime type. This is equivalent to an output document flavor where the representation class is always "java.io.OutputStream" An instance of the StreamPrintService class is obtained from a StreamPrintServiceFactory instance.

    Note that a StreamPrintService is different from a PrintService, which supports a Destination attribute. A StreamPrintService always requires an output stream, whereas a PrintService optionally accepts a Destination. A StreamPrintService has no default destination for its formatted output. Additionally a StreamPrintService is expected to generate output in a format useful in other contexts. StreamPrintService's are not expected to support the Destination attribute.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected StreamPrintService(OutputStream out)
      Constructs a StreamPrintService object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispose()
      Disposes this StreamPrintService.
      abstract String getOutputFormat()
      Returns the document format emitted by this print service.
      OutputStream getOutputStream()
      Gets the output stream.
      boolean isDisposed()
      Returns a boolean indicating whether or not this StreamPrintService has been disposed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.print.PrintService

        addPrintServiceAttributeListener, createPrintJob, equals, getAttribute, getAttributes, getDefaultAttributeValue, getName, getServiceUIFactory, getSupportedAttributeCategories, getSupportedAttributeValues, getSupportedDocFlavors, getUnsupportedAttributes, hashCode, isAttributeCategorySupported, isAttributeValueSupported, isDocFlavorSupported, removePrintServiceAttributeListener

    • 构造方法详细信息

      • StreamPrintService

        protected StreamPrintService(OutputStream out)
        Constructs a StreamPrintService object.
        参数：
        out - stream to which to send formatted print data.

    • 方法详细信息

      • getOutputStream

        public OutputStream getOutputStream()
        Gets the output stream.
        返回：
        the stream to which this service will send formatted print data.

      • getOutputFormat

        public abstract String getOutputFormat()
        Returns the document format emitted by this print service. Must be in mimetype format, compatible with the mime type components of DocFlavors @see DocFlavor.
        返回：
        mime type identifying the output format.

      • dispose

        public void dispose()
        Disposes this StreamPrintService. If a stream service cannot be re-used, it must be disposed to indicate this. Typically the client will call this method. Services which write data which cannot meaningfully be appended to may also dispose the stream. This does not close the stream. It just marks it as not for further use by this service.

      • isDisposed

        public boolean isDisposed()
        Returns a boolean indicating whether or not this StreamPrintService has been disposed. If this object has been disposed, will return true. Used by services and client applications to recognize streams to which no further data should be written.
        返回：
        if this StreamPrintService has been disposed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hkr (rr/.pjnIIrtrmeltt.auj=t


StreamPrintServiceFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print

类 StreamPrintServiceFactory

  • java.lang.Object
    • javax.print.StreamPrintServiceFactory

  • public abstract class StreamPrintServiceFactory
extends Object
    A StreamPrintServiceFactory is the factory for StreamPrintService instances, which can print to an output stream in a particular document format described as a mime type. A typical output document format may be Postscript(TM).

    This class is implemented by a service and located by the implementation using the SPI JAR File specification.

    Applications locate instances of this class by calling the lookupStreamPrintServiceFactories(DocFlavor, String) method.

    Applications can use a StreamPrintService obtained from a factory in place of a PrintService which represents a physical printer device.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StreamPrintServiceFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String getOutputFormat()
      Queries the factory for the document format that is emitted by printers obtained from this factory.
      abstract StreamPrintService getPrintService(OutputStream out)
      Returns a StreamPrintService that can print to the specified output stream.
      abstract DocFlavor[] getSupportedDocFlavors()
      Queries the factory for the document flavors that can be accepted by printers obtained from this factory.
      static StreamPrintServiceFactory[] lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
      Locates factories for print services that can be used with a print job to output a stream of data in the format specified by outputMimeType.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StreamPrintServiceFactory

        public StreamPrintServiceFactory()

    • 方法详细信息

      • lookupStreamPrintServiceFactories

        public static StreamPrintServiceFactory[] lookupStreamPrintServiceFactories(DocFlavor flavor,
                                                            String outputMimeType)
        Locates factories for print services that can be used with a print job to output a stream of data in the format specified by outputMimeType.

        The outputMimeType parameter describes the document type that you want to create, whereas the flavor parameter describes the format in which the input data will be provided by the application to the StreamPrintService.

        Although null is an acceptable value to use in the lookup of stream printing services, it's typical to search for a particular desired format, such as Postscript(TM).

        参数：
        flavor - of the input document type - null means match all types.
        outputMimeType - representing the required output format, used to identify suitable stream printer factories. A value of null means match all formats.
        返回：
        - matching factories for stream print service instance, empty if no suitable factories could be located.

      • getOutputFormat

        public abstract String getOutputFormat()
        Queries the factory for the document format that is emitted by printers obtained from this factory.
        返回：
        the output format described as a mime type.

      • getSupportedDocFlavors

        public abstract DocFlavor[] getSupportedDocFlavors()
        Queries the factory for the document flavors that can be accepted by printers obtained from this factory.
        返回：
        array of supported doc flavors.

      • getPrintService

        public abstract StreamPrintService getPrintService(OutputStream out)
        Returns a StreamPrintService that can print to the specified output stream. The output stream is created and managed by the application. It is the application's responsibility to close the stream and to ensure that this Printer is not reused. The application should not close this stream until any print job created from the printer is complete. Doing so earlier may generate a PrinterException and an event indicating that the job failed.

        Whereas a PrintService connected to a physical printer can be reused, a StreamPrintService connected to a stream cannot. The underlying StreamPrintService may be disposed by the print system with the dispose method before returning from the print method of DocPrintJob so that the print system knows this printer is no longer usable. This is equivalent to a physical printer going offline - permanently. Applications may supply a null print stream to create a queryable service. It is not valid to create a PrintJob for such a stream. Implementations which allocate resources on construction should examine the stream and may wish to only allocate resources if the stream is non-null.

        参数：
        out - destination stream for generated output.
        返回：
        a PrintService which will generate the format specified by the DocFlavor supported by this Factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:hvDcococddoccttoo a mm hee>TTclolD


URIException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print

Interface URIException

  • public interface URIException
    Interface URIException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a URI address. The Print Service API does not define any print exception classes that implement interface URIException, that being left to the Print Service implementor's discretion.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int URIInaccessible
      Indicates that the printer cannot access the URI address.
      static int URIOtherProblem
      Indicates any kind of problem not specifically identified by the other reasons.
      static int URISchemeNotSupported
      Indicates that the printer does not support the URI scheme ("http", "ftp", etc.) in the URI address.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getReason()
      Return the reason for the event.
      URI getUnsupportedURI()
      Return the URI.

    • 字段详细信息

      • URIInaccessible

        static final int URIInaccessible
        Indicates that the printer cannot access the URI address. For example, the printer might report this error if it goes to get the print data and cannot even establish a connection to the URI address.
        另请参见：
        Constant Field Values

      • URISchemeNotSupported

        static final int URISchemeNotSupported
        Indicates that the printer does not support the URI scheme ("http", "ftp", etc.) in the URI address.
        另请参见：
        Constant Field Values

      • URIOtherProblem

        static final int URIOtherProblem
        Indicates any kind of problem not specifically identified by the other reasons.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getUnsupportedURI

        URI getUnsupportedURI()
        Return the URI.
        返回：
        the URI that is the cause of this exception.

      • getReason

        int getReason()
        Return the reason for the event.
        返回：
        one of the predefined reasons enumerated in this interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lo"S/ajlaj/aaj//.atto"sassloc"cL"cis


Uses of Package javax.print

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.print

  • Packages that use javax.print
    软件包 描述
    java.awt.print
    Provides classes and interfaces for a general printing API.
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
  • Classes in javax.print used by java.awt.print
    类与描述
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
    StreamPrintServiceFactory
    A StreamPrintServiceFactory is the factory for StreamPrintService instances, which can print to an output stream in a particular document format described as a mime type.
  • Classes in javax.print used by javax.print
    类与描述
    Doc
    Interface Doc specifies the interface for an object that supplies one piece of print data for a Print Job.
    DocFlavor
    Class DocFlavor encapsulates an object that specifies the format in which print data is supplied to a DocPrintJob.
    DocFlavor.BYTE_ARRAY
    Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
    DocFlavor.CHAR_ARRAY
    Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
    DocFlavor.INPUT_STREAM
    Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
    DocFlavor.READER
    Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
    DocFlavor.SERVICE_FORMATTED
    Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
    DocFlavor.STRING
    Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
    DocFlavor.URL
    Class DocFlavor.URL provides predefined static constant DocFlavor objects.
    DocPrintJob
    This interface represents a print job that can print a specified document with a set of job attributes.
    MultiDoc
    Interface MultiDoc specifies the interface for an object that supplies more than one piece of print data for a Print Job.
    MultiDocPrintJob
    Obtained from a MultiDocPrintService, a MultiDocPrintJob can print a specified collection of documents as a single print job with a set of job attributes.
    MultiDocPrintService
    Interface MultiPrintService is the factory for a MultiDocPrintJob.
    PrintException
    Class PrintException encapsulates a printing-related error condition that occurred while using a Print Service instance.
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
    PrintServiceLookup
    Implementations of this class provide lookup services for print services (typically equivalent to printers) of a particular type.
    ServiceUIFactory
    Services may optionally provide UIs which allow different styles of interaction in different roles.
    StreamPrintService
    This class extends PrintService and represents a print service that prints data in different formats to a client-provided output stream.
    StreamPrintServiceFactory
    A StreamPrintServiceFactory is the factory for StreamPrintService instances, which can print to an output stream in a particular document format described as a mime type.
  • Classes in javax.print used by javax.print.event
    类与描述
    DocPrintJob
    This interface represents a print job that can print a specified document with a set of job attributes.
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
  • Classes in javax.print used by javax.swing
    类与描述
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
  • Classes in javax.print used by javax.swing.text
    类与描述
    PrintService
    Interface PrintService is the factory for a DocPrintJob.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

no ayyp > /t aDvthdd


Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface Attribute

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    DocAttribute, PrintJobAttribute, PrintRequestAttribute, PrintServiceAttribute, SupportedValuesAttribute
    All Known Implementing Classes:
    Chromaticity, ColorSupported, Compression, Copies, CopiesSupported, DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, Destination, DialogTypeSelection, DocumentName, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobImpressionsCompleted, JobImpressionsSupported, JobKOctets, JobKOctetsProcessed, JobKOctetsSupported, JobMediaSheets, JobMediaSheetsCompleted, JobMediaSheetsSupported, JobMessageFromOperator, JobName, JobOriginatingUserName, JobPriority, JobPrioritySupported, JobSheets, JobState, JobStateReason, JobStateReasons, Media, MediaName, MediaPrintableArea, MediaSize, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, NumberUpSupported, OrientationRequested, OutputDeviceAssigned, PageRanges, PagesPerMinute, PagesPerMinuteColor, PDLOverrideSupported, PresentationDirection, PrinterInfo, PrinterIsAcceptingJobs, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterName, PrinterResolution, PrinterState, PrinterStateReason, PrinterStateReasons, PrinterURI, PrintQuality, QueuedJobCount, ReferenceUriSchemesSupported, RequestingUserName, Severity, SheetCollate, Sides

    public interface Attribute
extends Serializable
    Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute. All printing attributes are serializable.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value when it is added to an attribute set.
      String getName()
      Get the name of the category of which this attribute value is an instance.

    • 方法详细信息

      • getCategory

        类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value when it is added to an attribute set.
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        String getName()
        Get the name of the category of which this attribute value is an instance.

        Note: This method is intended to provide a default, nonlocalized string for the attribute's category. If two attribute objects return the same category from the getCategory() method, they should return the same name from the getName() method.

        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

srnn/ l hap".�.! f c


AttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface AttributeSet

  • All Known Subinterfaces:
    DocAttributeSet, PrintJobAttributeSet, PrintRequestAttributeSet, PrintServiceAttributeSet
    All Known Implementing Classes:
    HashAttributeSet, HashDocAttributeSet, HashPrintJobAttributeSet, HashPrintRequestAttributeSet, HashPrintServiceAttributeSet

    public interface AttributeSet
    Interface AttributeSet specifies the interface for a set of printing attributes. A printing attribute is an object whose class implements interface Attribute.

    An attribute set contains a group of attribute values, where duplicate values are not allowed in the set. Furthermore, each value in an attribute set is a member of some category, and at most one value in any particular category is allowed in the set. For an attribute set, the values are Attribute objects, and the categories are 类 objects. An attribute's category is the class (or interface) at the root of the class hierarchy for that kind of attribute. Note that an attribute object's category may be a superclass of the attribute object's class rather than the attribute object's class itself. An attribute object's category is determined by calling the getCategory() method defined in interface Attribute.

    The interfaces of an AttributeSet resemble those of the Java Collections API's java.util.Map interface, but is more restrictive in the types it will accept, and combines keys and values into an Attribute.

    Attribute sets are used in several places in the Print Service API. In each context, only certain kinds of attributes are allowed to appear in the attribute set, as determined by the tagging interfaces which the attribute class implements -- DocAttribute, PrintRequestAttribute, PrintJobAttribute, and PrintServiceAttribute. There are four specializations of an attribute set that are restricted to contain just one of the four kinds of attribute -- DocAttributeSet, PrintRequestAttributeSet, PrintJobAttributeSet, and PrintServiceAttributeSet, respectively. Note that many attribute classes implement more than one tagging interface and so may appear in more than one context.

    • A DocAttributeSet, containing DocAttributes, specifies the characteristics of an individual doc and the print job settings to be applied to an individual doc.

    • A PrintRequestAttributeSet, containing PrintRequestAttributes, specifies the settings to be applied to a whole print job and to all the docs in the print job.

    • A PrintJobAttributeSet, containing PrintJobAttributes, reports the status of a print job.

    • A PrintServiceAttributeSet, containing PrintServiceAttributes, reports the status of a Print Service instance.

    In some contexts, the client is only allowed to examine an attribute set's contents but not change them (the set is read-only). In other places, the client is allowed both to examine and to change an attribute set's contents (the set is read-write). For a read-only attribute set, calling a mutating operation throws an UnmodifiableSetException.

    The Print Service API provides one implementation of interface AttributeSet, class HashAttributeSet. A client can use class HashAttributeSet or provide its own implementation of interface AttributeSet. The Print Service API also provides implementations of interface AttributeSet's subinterfaces -- classes HashDocAttributeSet, HashPrintRequestAttributeSet, HashPrintJobAttributeSet, and HashPrintServiceAttributeSet.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value.
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      void clear()
      Removes all attributes from this attribute set.
      boolean containsKey(类<?> category)
      Returns true if this attribute set contains an attribute for the specified category.
      boolean containsValue(Attribute attribute)
      Returns true if this attribute set contains the given attribute value.
      boolean equals(Object object)
      Compares the specified object with this attribute set for equality.
      Attribute get(类<?> category)
      Returns the attribute value which this attribute set contains in the given attribute category.
      int hashCode()
      Returns the hash code value for this attribute set.
      boolean isEmpty()
      Returns true if this attribute set contains no attributes.
      boolean remove(Attribute attribute)
      Removes the specified attribute from this attribute set if present.
      boolean remove(类<?> category)
      Removes any attribute for this category from this attribute set if present.
      int size()
      Returns the number of attributes in this attribute set.
      Attribute[] toArray()
      Returns an array of the attributes contained in this set.

    • 方法详细信息

      • get

        Attribute get(类<?> category)
        Returns the attribute value which this attribute set contains in the given attribute category. Returns null if this attribute set does not contain any attribute value in the given attribute category.
        参数：
        category - Attribute category whose associated attribute value is to be returned. It must be a 类 that implements interface Attribute.
        返回：
        The attribute value in the given attribute category contained in this attribute set, or null if this attribute set does not contain any attribute value in the given attribute category.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the category is null.
        ClassCastException - (unchecked exception) Thrown if the category is not a 类 that implements interface Attribute.

      • add

        boolean add(Attribute attribute)
        Adds the specified attribute to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value.
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the attribute is null.
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.

      • remove

        boolean remove(类<?> category)
        Removes any attribute for this category from this attribute set if present. If category is null, then remove() does nothing and returns false.
        参数：
        category - Attribute category to be removed from this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value had been a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the remove() operation.

      • remove

        boolean remove(Attribute attribute)
        Removes the specified attribute from this attribute set if present. If attribute is null, then remove() does nothing and returns false.
        参数：
        attribute - Attribute value to be removed from this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value had been a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the remove() operation.

      • containsKey

        boolean containsKey(类<?> category)
        Returns true if this attribute set contains an attribute for the specified category.
        参数：
        category - whose presence in this attribute set is to be tested.
        返回：
        true if this attribute set contains an attribute value for the specified category.

      • containsValue

        boolean containsValue(Attribute attribute)
        Returns true if this attribute set contains the given attribute value.
        参数：
        attribute - Attribute value whose presence in this attribute set is to be tested.
        返回：
        true if this attribute set contains the given attribute value.

      • addAll

        boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the = add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. The behavior of the addAll(AttributeSet) operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll(AttributeSet) operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll(AttributeSet) method.
        NullPointerException - (Unchecked exception) Thrown if some element in the specified set is null.
        另请参见：
        add(Attribute)

      • size

        int size()
        Returns the number of attributes in this attribute set. If this attribute set contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
        返回：
        The number of attributes in this attribute set.

      • toArray

        Attribute[] toArray()
        Returns an array of the attributes contained in this set.
        返回：
        the Attributes contained in this set as an array, zero length if the AttributeSet is empty.

      • clear

        void clear()
        Removes all attributes from this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the clear() operation.

      • isEmpty

        boolean isEmpty()
        Returns true if this attribute set contains no attributes.
        返回：
        true if this attribute set contains no attributes.

      • equals

        boolean equals(Object object)
        Compares the specified object with this attribute set for equality. Returns true if the given object is also an attribute set and the two attribute sets contain the same attribute category-attribute value mappings. This ensures that the equals() method works properly across different implementations of the AttributeSet interface.
        重载：
        equals in class Object
        参数：
        object - to be compared for equality with this attribute set.
        返回：
        true if the specified object is equal to this attribute set.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns the hash code value for this attribute set. The hash code of an attribute set is defined to be the sum of the hash codes of each entry in the AttributeSet. This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two attribute sets t1 and t2, as required by the general contract of Object.hashCode().
        重载：
        hashCode in class Object
        返回：
        The hash code value for this attribute set.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


AttributeSetUtilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

类 AttributeSetUtilities

  • java.lang.Object
    • javax.print.attribute.AttributeSetUtilities

  • public final class AttributeSetUtilities
extends Object
    Class AttributeSetUtilities provides static methods for manipulating AttributeSets.
    • Methods for creating unmodifiable and synchronized views of attribute sets.
    • operations useful for building implementations of interface AttributeSet

    An unmodifiable view U of an AttributeSet S provides a client with "read-only" access to S. Query operations on U "read through" to S; thus, changes in S are reflected in U. However, any attempt to modify U, results in an UnmodifiableSetException. The unmodifiable view object U will be serializable if the attribute set object S is serializable.

    A synchronized view V of an attribute set S provides a client with synchronized (multiple thread safe) access to S. Each operation of V is synchronized using V itself as the lock object and then merely invokes the corresponding operation of S. In order to guarantee mutually exclusive access, it is critical that all access to S is accomplished through V. The synchronized view object V will be serializable if the attribute set object S is serializable.

    As mentioned in the package description of javax.print, a null reference parameter to methods is incorrect unless explicitly documented on the method as having a meaningful interpretation. Usage to the contrary is incorrect coding and may result in a run time exception either immediately or at some later time. IllegalArgumentException and NullPointerException are examples of typical and acceptable run time exceptions for such cases.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static AttributeSet synchronizedView(AttributeSet attributeSet)
      Creates a synchronized view of the given attribute set.
      static DocAttributeSet synchronizedView(DocAttributeSet attributeSet)
      Creates a synchronized view of the given doc attribute set.
      static PrintJobAttributeSet synchronizedView(PrintJobAttributeSet attributeSet)
      Creates a synchronized view of the given print job attribute set.
      static PrintRequestAttributeSet synchronizedView(PrintRequestAttributeSet attributeSet)
      Creates a synchronized view of the given print request attribute set.
      static PrintServiceAttributeSet synchronizedView(PrintServiceAttributeSet attributeSet)
      Creates a synchronized view of the given print service attribute set.
      static AttributeSet unmodifiableView(AttributeSet attributeSet)
      Creates an unmodifiable view of the given attribute set.
      static DocAttributeSet unmodifiableView(DocAttributeSet attributeSet)
      Creates an unmodifiable view of the given doc attribute set.
      static PrintJobAttributeSet unmodifiableView(PrintJobAttributeSet attributeSet)
      Creates an unmodifiable view of the given print job attribute set.
      static PrintRequestAttributeSet unmodifiableView(PrintRequestAttributeSet attributeSet)
      Creates an unmodifiable view of the given print request attribute set.
      static PrintServiceAttributeSet unmodifiableView(PrintServiceAttributeSet attributeSet)
      Creates an unmodifiable view of the given print service attribute set.
      static 类<?> verifyAttributeCategory(Object object, 类<?> interfaceName)
      Verify that the given object is a 类 that implements the given interface, which is assumed to be interface Attribute or a subinterface thereof.
      static Attribute verifyAttributeValue(Object object, 类<?> interfaceName)
      Verify that the given object is an instance of the given interface, which is assumed to be interface Attribute or a subinterface thereof.
      static void verifyCategoryForValue(类<?> category, Attribute attribute)
      Verify that the given attribute category object is equal to the category of the given attribute value object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • unmodifiableView

        public static AttributeSet unmodifiableView(AttributeSet attributeSet)
        Creates an unmodifiable view of the given attribute set.
        参数：
        attributeSet - Underlying attribute set.
        返回：
        Unmodifiable view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null. Null is never a

      • unmodifiableView

        public static DocAttributeSet unmodifiableView(DocAttributeSet attributeSet)
        Creates an unmodifiable view of the given doc attribute set.
        参数：
        attributeSet - Underlying doc attribute set.
        返回：
        Unmodifiable view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • unmodifiableView

        public static PrintRequestAttributeSet unmodifiableView(PrintRequestAttributeSet attributeSet)
        Creates an unmodifiable view of the given print request attribute set.
        参数：
        attributeSet - Underlying print request attribute set.
        返回：
        Unmodifiable view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • unmodifiableView

        public static PrintJobAttributeSet unmodifiableView(PrintJobAttributeSet attributeSet)
        Creates an unmodifiable view of the given print job attribute set.
        参数：
        attributeSet - Underlying print job attribute set.
        返回：
        Unmodifiable view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • unmodifiableView

        public static PrintServiceAttributeSet unmodifiableView(PrintServiceAttributeSet attributeSet)
        Creates an unmodifiable view of the given print service attribute set.
        参数：
        attributeSet - Underlying print service attribute set.
        返回：
        Unmodifiable view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • synchronizedView

        public static AttributeSet synchronizedView(AttributeSet attributeSet)
        Creates a synchronized view of the given attribute set.
        参数：
        attributeSet - Underlying attribute set.
        返回：
        Synchronized view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • synchronizedView

        public static DocAttributeSet synchronizedView(DocAttributeSet attributeSet)
        Creates a synchronized view of the given doc attribute set.
        参数：
        attributeSet - Underlying doc attribute set.
        返回：
        Synchronized view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • synchronizedView

        public static PrintRequestAttributeSet synchronizedView(PrintRequestAttributeSet attributeSet)
        Creates a synchronized view of the given print request attribute set.
        参数：
        attributeSet - Underlying print request attribute set.
        返回：
        Synchronized view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • synchronizedView

        public static PrintJobAttributeSet synchronizedView(PrintJobAttributeSet attributeSet)
        Creates a synchronized view of the given print job attribute set.
        参数：
        attributeSet - Underlying print job attribute set.
        返回：
        Synchronized view of attributeSet.
        抛出：
        NullPointerException - Thrown if attributeSet is null.

      • synchronizedView

        public static PrintServiceAttributeSet synchronizedView(PrintServiceAttributeSet attributeSet)
        Creates a synchronized view of the given print service attribute set.
        参数：
        attributeSet - Underlying print service attribute set.
        返回：
        Synchronized view of attributeSet.

      • verifyAttributeCategory

        public static 类<?> verifyAttributeCategory(Object object,
                               类<?> interfaceName)
        Verify that the given object is a 类 that implements the given interface, which is assumed to be interface Attribute or a subinterface thereof.
        参数：
        object - Object to test.
        interfaceName - Interface the object must implement.
        返回：
        If object is a 类 that implements interfaceName, object is returned downcast to type 类; otherwise an exception is thrown.
        抛出：
        NullPointerException - (unchecked exception) Thrown if object is null.
        ClassCastException - (unchecked exception) Thrown if object is not a 类 that implements interfaceName.

      • verifyAttributeValue

        public static Attribute verifyAttributeValue(Object object,
                             类<?> interfaceName)
        Verify that the given object is an instance of the given interface, which is assumed to be interface Attribute or a subinterface thereof.
        参数：
        object - Object to test.
        interfaceName - Interface of which the object must be an instance.
        返回：
        If object is an instance of interfaceName, object is returned downcast to type Attribute; otherwise an exception is thrown.
        抛出：
        NullPointerException - (unchecked exception) Thrown if object is null.
        ClassCastException - (unchecked exception) Thrown if object is not an instance of interfaceName.

      • verifyCategoryForValue

        public static void verifyCategoryForValue(类<?> category,
                          Attribute attribute)
        Verify that the given attribute category object is equal to the category of the given attribute value object. If so, this method returns doing nothing. If not, this method throws an exception.
        参数：
        category - Attribute category to test.
        attribute - Attribute value to test.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the category is null or if the attribute is null.
        IllegalArgumentException - (unchecked exception) Thrown if the category is not equal to the category of the attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sd


DateTimeSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 DateTimeSyntax

  • java.lang.Object
    • javax.print.attribute.DateTimeSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, JobHoldUntil

    public abstract class DateTimeSyntax
extends Object
implements Serializable, Cloneable
    Class DateTimeSyntax is an abstract base class providing the common implementation of all attributes whose value is a date and time.

    Under the hood, a date-time attribute is stored as a value of class java.util.Date. You can get a date-time attribute's Date value by calling getValue(). A date-time attribute's Date value is established when it is constructed (see DateTimeSyntax(Date)). Once constructed, a date-time attribute's value is immutable.

    To construct a date-time attribute from separate values of the year, month, day, hour, minute, and so on, use a java.util.Calendar object to construct a java.util.Date object, then use the java.util.Date object to construct the date-time attribute. To convert a date-time attribute to separate values of the year, month, day, hour, minute, and so on, create a java.util.Calendar object and set it to the java.util.Date from the date-time attribute. Class DateTimeSyntax stores its value in the form of a java.util.Date rather than a java.util.Calendar because it typically takes less memory to store and less time to compare a java.util.Date than a java.util.Calendar.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DateTimeSyntax(Date value)
      Construct a new date-time attribute with the given java.util.Date value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this date-time attribute is equivalent to the passed in object.
      Date getValue()
      Returns this date-time attribute's java.util.Date value.
      int hashCode()
      Returns a hash code value for this date-time attribute.
      String toString()
      Returns a string value corresponding to this date-time attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DateTimeSyntax

        protected DateTimeSyntax(Date value)
        Construct a new date-time attribute with the given java.util.Date value.
        参数：
        value - java.util.Date value.
        抛出：
        NullPointerException - (unchecked exception) Thrown if theValue is null.

    • 方法详细信息

      • getValue

        public Date getValue()
        Returns this date-time attribute's java.util.Date value.
        返回：
        the Date.

      • equals

        public boolean equals(Object object)
        Returns whether this date-time attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class DateTimeSyntax.
        3. This date-time attribute's java.util.Date value and object's java.util.Date value are equal.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this date-time attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code value for this date-time attribute. The hashcode is that of this attribute's java.util.Date value.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string value corresponding to this date-time attribute. The string value is just this attribute's java.util.Date value converted to a string.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ettt oidoigvvigg uuc>ScettbDtDttrtaaiaeeinl;


DocAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute

Interface DocAttribute

  • All Superinterfaces:
    Attribute, Serializable
    All Known Implementing Classes:
    Chromaticity, Compression, DocumentName, Finishings, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, NumberUp, OrientationRequested, PageRanges, PrinterResolution, PrintQuality, SheetCollate, Sides

    public interface DocAttribute
extends Attribute
    Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc. ("Doc" is a short, easy-to-pronounce term that means "a piece of print data.") The client may include a DocAttribute in a Doc's attribute set to specify a characteristic of that doc. If an attribute implements PrintRequestAttribute as well as DocAttribute, the client may include the attribute in a attribute set which specifies a print job to specify a characteristic for all the docs in that job.

    另请参见：
    DocAttributeSet, PrintRequestAttributeSet

    • 方法摘要

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-d L"lablalssall


DocAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface DocAttributeSet

  • All Superinterfaces:
    AttributeSet
    All Known Implementing Classes:
    HashDocAttributeSet

    public interface DocAttributeSet
extends AttributeSet
    Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e. printing attributes that implement interface DocAttribute. In the Print Service API, the client uses a DocAttributeSet to specify the characteristics of an individual doc and the print job settings to be applied to an individual doc.

    A DocAttributeSet is just an AttributeSet whose constructors and mutating operations guarantee an additional invariant, namely that all attribute values in the DocAttributeSet must be instances of interface DocAttribute. The add(Attribute), and addAll(AttributeSet) operations are respecified below to guarantee this additional invariant.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 方法详细信息

      • add

        boolean add(Attribute attribute)
        Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
        指定者：
        add in interface AttributeSet
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.
        ClassCastException - (unchecked exception) Thrown if the attribute is not an instance of interface DocAttribute.
        NullPointerException - (unchecked exception) Thrown if the attribute is null.

      • addAll

        boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. If none of the categories in the specified set are the same as any categories in this attribute set, the addAll() operation effectively modifies this attribute set so that its value is the union of the two sets.

        The behavior of the addAll() operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll() operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        指定者：
        addAll in interface AttributeSet
        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll() method.
        ClassCastException - (Unchecked exception) Thrown if some element in the specified set is not an instance of interface DocAttribute.
        NullPointerException - (Unchecked exception) Thrown if the specified set is null.
        另请参见：
        add(Attribute)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bmu/p/e/i/ttrrrtvnn�>u"gh/n"" n"sr


EnumSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 EnumSyntax

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    Chromaticity, ColorSupported, Compression, DialogTypeSelection, Fidelity, Finishings, JobSheets, JobState, JobStateReason, Media, MultipleDocumentHandling, OrientationRequested, PDLOverrideSupported, PresentationDirection, PrinterIsAcceptingJobs, PrinterState, PrinterStateReason, PrintQuality, ReferenceUriSchemesSupported, Severity, SheetCollate, Sides

    public abstract class EnumSyntax
extends Object
implements Serializable, Cloneable
    Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects. An enumeration class (which extends class EnumSyntax) provides a group of enumeration values (objects) that are singleton instances of the enumeration class; for example:
         public class Bach extends EnumSyntax {
         public static final Bach JOHANN_SEBASTIAN     = new Bach(0);
         public static final Bach WILHELM_FRIEDEMANN   = new Bach(1);
         public static final Bach CARL_PHILIP_EMMANUEL = new Bach(2);
         public static final Bach JOHANN_CHRISTIAN     = new Bach(3);
         public static final Bach P_D_Q                = new Bach(4);

         private static final String[] stringTable = {
             "Johann Sebastian Bach",
              "Wilhelm Friedemann Bach",
              "Carl Philip Emmanuel Bach",
              "Johann Christian Bach",
              "P.D.Q. Bach"
         };

         protected String[] getStringTable() {
             return stringTable;
         }

         private static final Bach[] enumValueTable = {
             JOHANN_SEBASTIAN,
              WILHELM_FRIEDEMANN,
              CARL_PHILIP_EMMANUEL,
              JOHANN_CHRISTIAN,
              P_D_Q
         };

         protected EnumSyntax[] getEnumValueTable() {
             return enumValueTable;
         }
     }
    You can then write code that uses the == and != operators to test enumeration values; for example:
         Bach theComposer;
     . . .
     if (theComposer == Bach.JOHANN_SEBASTIAN) {
         System.out.println ("The greatest composer of all time!");
     }
    The equals() method for an enumeration class just does a test for identical objects (==).

    You can convert an enumeration value to a string by calling toString(). The string is obtained from a table supplied by the enumeration class.

    Under the hood, an enumeration value is just an integer, a different integer for each enumeration value within an enumeration class. You can get an enumeration value's integer value by calling getValue(). An enumeration value's integer value is established when it is constructed (see EnumSyntax(int)). Since the constructor is protected, the only possible enumeration values are the singleton objects declared in the enumeration class; additional enumeration values cannot be created at run time.

    You can define a subclass of an enumeration class that extends it with additional enumeration values. The subclass's enumeration values' integer values need not be distinct from the superclass's enumeration values' integer values; the ==, !=, equals(), and toString() methods will still work properly even if the subclass uses some of the same integer values as the superclass. However, the application in which the enumeration class and subclass are used may need to have distinct integer values in the superclass and subclass.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected EnumSyntax(int value)
      Construct a new enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Returns a clone of this enumeration value, which to preserve the semantics of enumeration values is the same object as this enumeration value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for this enumeration value's enumeration class.
      protected int getOffset()
      Returns the lowest integer value used by this enumeration value's enumeration class.
      protected String[] getStringTable()
      Returns the string table for this enumeration value's enumeration class.
      int getValue()
      Returns this enumeration value's integer value.
      int hashCode()
      Returns a hash code value for this enumeration value.
      protected Object readResolve()
      During object input, convert this deserialized enumeration instance to the proper enumeration value defined in the enumeration attribute class.
      String toString()
      Returns a string value corresponding to this enumeration value.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • EnumSyntax

        protected EnumSyntax(int value)
        Construct a new enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getValue

        public int getValue()
        Returns this enumeration value's integer value.
        返回：
        the value

      • clone

        public Object clone()
        Returns a clone of this enumeration value, which to preserve the semantics of enumeration values is the same object as this enumeration value.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • hashCode

        public int hashCode()
        Returns a hash code value for this enumeration value. The hash code is just this enumeration value's integer value.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string value corresponding to this enumeration value.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • readResolve

        protected Object readResolve()
                      throws ObjectStreamException
        During object input, convert this deserialized enumeration instance to the proper enumeration value defined in the enumeration attribute class.
        返回：
        The enumeration singleton value stored at index i-L in the enumeration value table returned by getEnumValueTable(), where i is this enumeration value's integer value and L is the value returned by getOffset().
        抛出：
        ObjectStreamException - if the stream can't be deserialised
        InvalidObjectException - Thrown if the enumeration value table is null, this enumeration value's integer value does not correspond to an element in the enumeration value table, or the corresponding element in the enumeration value table is null. (Note: InvalidObjectException is a subclass of ObjectStreamException, which readResolve() is declared to throw.)

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for this enumeration value's enumeration class. The enumeration class's integer values are assumed to lie in the range L..L+上一个-1, where L is the value returned by getOffset() and 上一个 is the length of the string table. The element in the string table at index i-L is the value returned by toString() for the enumeration value whose integer value is i. If an integer within the above range is not used by any enumeration value, leave the corresponding table element null.

        The default implementation returns null. If the enumeration class (a subclass of class EnumSyntax) does not override this method to return a non-null string table, and the subclass does not override the toString() method, the base class toString() method will return just a string representation of this enumeration value's integer value.

        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for this enumeration value's enumeration class. The enumeration class's integer values are assumed to lie in the range L..L+上一个-1, where L is the value returned by getOffset() and 上一个 is the length of the enumeration value table. The element in the enumeration value table at index i-L is the enumeration value object whose integer value is i; the readResolve() method needs this to preserve singleton semantics during deserialization of an enumeration instance. If an integer within the above range is not used by any enumeration value, leave the corresponding table element null.

        The default implementation returns null. If the enumeration class (a subclass of class EnumSyntax) does not override this method to return a non-null enumeration value table, and the subclass does not override the readResolve() method, the base class readResolve() method will throw an exception whenever an enumeration instance is deserialized from an object input stream.

        返回：
        the value table

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by this enumeration value's enumeration class.

        The default implementation returns 0. If the enumeration class (a subclass of class EnumSyntax) uses integer values starting at other than 0, override this method in the subclass.

        返回：
        the offset of the lowest enumeration value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

踢n 皀=igTa�"Ve!6a鰋xlu>n>eavr�


HashAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 HashAttributeSet

  • java.lang.Object
    • javax.print.attribute.HashAttributeSet
  • 所有已实现的接口：
    Serializable, AttributeSet
    直接已知子类：
    HashDocAttributeSet, HashPrintJobAttributeSet, HashPrintRequestAttributeSet, HashPrintServiceAttributeSet

    public class HashAttributeSet
extends Object
implements AttributeSet, Serializable
    Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        HashAttributeSet()
      Construct a new, empty attribute set.
        HashAttributeSet(Attribute attribute)
      Construct a new attribute set, initially populated with the given attribute.
        HashAttributeSet(Attribute[] attributes)
      Construct a new attribute set, initially populated with the values from the given array.
      protected HashAttributeSet(Attribute[] attributes, 类<?> interfaceName)
      Construct a new attribute set, where the members of the attribute set are restricted to the given interface.
      protected HashAttributeSet(Attribute attribute, 类<?> interfaceName)
      Construct a new attribute set, initially populated with the given attribute, where the members of the attribute set are restricted to the given interface.
        HashAttributeSet(AttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set.
      protected HashAttributeSet(AttributeSet attributes, 类<?> interfaceName)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the given interface.
      protected HashAttributeSet(类<?> interfaceName)
      Construct a new, empty attribute set, where the members of the attribute set are restricted to the given interface.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute to this attribute set if it is not already present, first removing any existing in the same attribute category as the specified attribute value.
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      void clear()
      Removes all attributes from this attribute set.
      boolean containsKey(类<?> category)
      Returns true if this attribute set contains an attribute for the specified category.
      boolean containsValue(Attribute attribute)
      Returns true if this attribute set contains the given attribute.
      boolean equals(Object object)
      Compares the specified object with this attribute set for equality.
      Attribute get(类<?> category)
      Returns the attribute value which this attribute set contains in the given attribute category.
      int hashCode()
      Returns the hash code value for this attribute set.
      boolean isEmpty()
      Returns true if this attribute set contains no attributes.
      boolean remove(Attribute attribute)
      Removes the specified attribute from this attribute set if present.
      boolean remove(类<?> category)
      Removes any attribute for this category from this attribute set if present.
      int size()
      Returns the number of attributes in this attribute set.
      Attribute[] toArray()
      Returns an array of the attributes contained in this set.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HashAttributeSet

        public HashAttributeSet()
        Construct a new, empty attribute set.

      • HashAttributeSet

        public HashAttributeSet(Attribute attribute)
        Construct a new attribute set, initially populated with the given attribute.
        参数：
        attribute - Attribute value to add to the set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.

      • HashAttributeSet

        public HashAttributeSet(Attribute[] attributes)
        Construct a new attribute set, initially populated with the values from the given array. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.

      • HashAttributeSet

        public HashAttributeSet(AttributeSet attributes)
        Construct a new attribute set, initially populated with the values from the given set.
        参数：
        attributes - Set of attributes from which to initialise this set. If null, an empty attribute set is constructed.

      • HashAttributeSet

        protected HashAttributeSet(类<?> interfaceName)
        Construct a new, empty attribute set, where the members of the attribute set are restricted to the given interface.
        参数：
        interfaceName - The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.
        抛出：
        NullPointerException - if interfaceName is null.

      • HashAttributeSet

        protected HashAttributeSet(Attribute attribute,
                类<?> interfaceName)
        Construct a new attribute set, initially populated with the given attribute, where the members of the attribute set are restricted to the given interface.
        参数：
        attribute - Attribute value to add to the set.
        interfaceName - The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.
        NullPointerException - if interfaceName is null.
        ClassCastException - (unchecked exception) Thrown if attribute is not an instance of interfaceName.

      • HashAttributeSet

        protected HashAttributeSet(Attribute[] attributes,
                类<?> interfaceName)
        Construct a new attribute set, where the members of the attribute set are restricted to the given interface. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        interfaceName - The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.
        NullPointerException - if interfaceName is null.
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of interfaceName.

      • HashAttributeSet

        protected HashAttributeSet(AttributeSet attributes,
                类<?> interfaceName)
        Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the given interface.
        参数：
        attributes - set of attribute values to initialise the set. If null, an empty attribute set is constructed.
        interfaceName - The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.
        抛出：
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of interfaceName.

    • 方法详细信息

      • get

        public Attribute get(类<?> category)
        Returns the attribute value which this attribute set contains in the given attribute category. Returns null if this attribute set does not contain any attribute value in the given attribute category.
        指定者：
        get in interface AttributeSet
        参数：
        category - Attribute category whose associated attribute value is to be returned. It must be a 类 that implements interface Attribute.
        返回：
        The attribute value in the given attribute category contained in this attribute set, or null if this attribute set does not contain any attribute value in the given attribute category.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the category is null.
        ClassCastException - (unchecked exception) Thrown if the category is not a 类 that implements interface Attribute.

      • add

        public boolean add(Attribute attribute)
        Adds the specified attribute to this attribute set if it is not already present, first removing any existing in the same attribute category as the specified attribute value.
        指定者：
        add in interface AttributeSet
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the attribute is null.
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.

      • remove

        public boolean remove(类<?> category)
        Removes any attribute for this category from this attribute set if present. If category is null, then remove() does nothing and returns false.
        指定者：
        remove in interface AttributeSet
        参数：
        category - Attribute category to be removed from this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute category had been a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the remove() operation.

      • remove

        public boolean remove(Attribute attribute)
        Removes the specified attribute from this attribute set if present. If attribute is null, then remove() does nothing and returns false.
        指定者：
        remove in interface AttributeSet
        参数：
        attribute - Attribute value to be removed from this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value had been a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the remove() operation.

      • containsKey

        public boolean containsKey(类<?> category)
        Returns true if this attribute set contains an attribute for the specified category.
        指定者：
        containsKey in interface AttributeSet
        参数：
        category - whose presence in this attribute set is to be tested.
        返回：
        true if this attribute set contains an attribute value for the specified category.

      • containsValue

        public boolean containsValue(Attribute attribute)
        Returns true if this attribute set contains the given attribute.
        指定者：
        containsValue in interface AttributeSet
        参数：
        attribute - value whose presence in this attribute set is to be tested.
        返回：
        true if this attribute set contains the given attribute value.

      • addAll

        public boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. The behavior of the addAll(AttributeSet) operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll(AttributeSet) operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        指定者：
        addAll in interface AttributeSet
        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll(AttributeSet) method.
        NullPointerException - (Unchecked exception) Thrown if some element in the specified set is null, or the set is null.
        另请参见：
        add(Attribute)

      • size

        public int size()
        Returns the number of attributes in this attribute set. If this attribute set contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
        指定者：
        size in interface AttributeSet
        返回：
        The number of attributes in this attribute set.

      • toArray

        public Attribute[] toArray()
        从接口复制的描述： AttributeSet
        Returns an array of the attributes contained in this set.
        指定者：
        toArray in interface AttributeSet
        返回：
        the Attributes contained in this set as an array, zero length if the AttributeSet is empty.

      • clear

        public void clear()
        Removes all attributes from this attribute set.
        指定者：
        clear in interface AttributeSet
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the clear() operation.

      • isEmpty

        public boolean isEmpty()
        Returns true if this attribute set contains no attributes.
        指定者：
        isEmpty in interface AttributeSet
        返回：
        true if this attribute set contains no attributes.

      • equals

        public boolean equals(Object object)
        Compares the specified object with this attribute set for equality. Returns true if the given object is also an attribute set and the two attribute sets contain the same attribute category-attribute value mappings. This ensures that the equals() method works properly across different implementations of the AttributeSet interface.
        指定者：
        equals in interface AttributeSet
        重载：
        equals in class Object
        参数：
        object - to be compared for equality with this attribute set.
        返回：
        true if the specified object is equal to this attribute set.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this attribute set. The hash code of an attribute set is defined to be the sum of the hash codes of each entry in the AttributeSet. This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two attribute sets t1 and t2, as required by the general contract of Object.hashCode().
        指定者：
        hashCode in interface AttributeSet
        重载：
        hashCode in class Object
        返回：
        The hash code value for this attribute set.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HashDocAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print.attribute

类 HashDocAttributeSet

  • java.lang.Object
    • javax.print.attribute.HashAttributeSet
      • javax.print.attribute.HashDocAttributeSet
  • 所有已实现的接口：
    Serializable, AttributeSet, DocAttributeSet

    public class HashDocAttributeSet
extends HashAttributeSet
implements DocAttributeSet, Serializable
    Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      HashDocAttributeSet()
      Construct a new, empty hash doc attribute set.
      HashDocAttributeSet(DocAttribute attribute)
      Construct a new hash doc attribute set, initially populated with the given value.
      HashDocAttributeSet(DocAttribute[] attributes)
      Construct a new hash doc attribute set, initially populated with the values from the given array.
      HashDocAttributeSet(DocAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the DocAttribute interface.

    • 方法摘要

      • 方法 - 继承于类 javax.print.attribute.HashAttributeSet

        add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.DocAttributeSet

        add, addAll

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 构造方法详细信息

      • HashDocAttributeSet

        public HashDocAttributeSet()
        Construct a new, empty hash doc attribute set.

      • HashDocAttributeSet

        public HashDocAttributeSet(DocAttribute attribute)
        Construct a new hash doc attribute set, initially populated with the given value.
        参数：
        attribute - Attribute value to add to the set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.

      • HashDocAttributeSet

        public HashDocAttributeSet(DocAttribute[] attributes)
        Construct a new hash doc attribute set, initially populated with the values from the given array. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.

      • HashDocAttributeSet

        public HashDocAttributeSet(DocAttributeSet attributes)
        Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the DocAttribute interface.
        参数：
        attributes - set of attribute values to initialise the set. If null, an empty attribute set is constructed.
        抛出：
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of DocAttribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r/he(ut(ubttubbAbpp<>a<=sskLscsi>sti-b


HashPrintJobAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print.attribute

类 HashPrintJobAttributeSet

  • java.lang.Object
    • javax.print.attribute.HashAttributeSet
      • javax.print.attribute.HashPrintJobAttributeSet
  • 所有已实现的接口：
    Serializable, AttributeSet, PrintJobAttributeSet

    public class HashPrintJobAttributeSet
extends HashAttributeSet
implements PrintJobAttributeSet, Serializable
    Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      HashPrintJobAttributeSet()
      Construct a new, empty hash print job attribute set.
      HashPrintJobAttributeSet(PrintJobAttribute attribute)
      Construct a new hash print job attribute set, initially populated with the given value.
      HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
      Construct a new hash print job attribute set, initially populated with the values from the given array.
      HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintJobAttribute interface.

    • 方法摘要

      • 方法 - 继承于类 javax.print.attribute.HashAttributeSet

        add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.PrintJobAttributeSet

        add, addAll

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 构造方法详细信息

      • HashPrintJobAttributeSet

        public HashPrintJobAttributeSet()
        Construct a new, empty hash print job attribute set.

      • HashPrintJobAttributeSet

        public HashPrintJobAttributeSet(PrintJobAttribute attribute)
        Construct a new hash print job attribute set, initially populated with the given value.
        参数：
        attribute - Attribute value to add to the set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.

      • HashPrintJobAttributeSet

        public HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
        Construct a new hash print job attribute set, initially populated with the values from the given array. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.

      • HashPrintJobAttributeSet

        public HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
        Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintJobAttribute interface.
        参数：
        attributes - set of attribute values to initialise the set. If null, an empty attribute set is constructed.
        抛出：
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of PrintJobAttribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ngb" i> Lkiiakk"l eanftccd>/ld >led.m


HashPrintRequestAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print.attribute

类 HashPrintRequestAttributeSet

  • java.lang.Object
    • javax.print.attribute.HashAttributeSet
      • javax.print.attribute.HashPrintRequestAttributeSet
  • 所有已实现的接口：
    Serializable, AttributeSet, PrintRequestAttributeSet

    public class HashPrintRequestAttributeSet
extends HashAttributeSet
implements PrintRequestAttributeSet, Serializable
    Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      HashPrintRequestAttributeSet()
      Construct a new, empty print request attribute set.
      HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
      Construct a new print request attribute set, initially populated with the given value.
      HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
      Construct a new print request attribute set, initially populated with the values from the given array.
      HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the (PrintRequestAttributeSe interface.

    • 方法摘要

      • 方法 - 继承于类 javax.print.attribute.HashAttributeSet

        add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.PrintRequestAttributeSet

        add, addAll

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 构造方法详细信息

      • HashPrintRequestAttributeSet

        public HashPrintRequestAttributeSet()
        Construct a new, empty print request attribute set.

      • HashPrintRequestAttributeSet

        public HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
        Construct a new print request attribute set, initially populated with the given value.
        参数：
        attribute - Attribute value to add to the set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.

      • HashPrintRequestAttributeSet

        public HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
        Construct a new print request attribute set, initially populated with the values from the given array. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.

      • HashPrintRequestAttributeSet

        public HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
        Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the (PrintRequestAttributeSe interface.
        参数：
        attributes - set of attribute values to initialise the set. If null, an empty attribute set is constructed.
        抛出：
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of (PrintRequestAttributeSe.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s#rn>tg>ssvn


HashPrintServiceAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print.attribute

类 HashPrintServiceAttributeSet

  • java.lang.Object
    • javax.print.attribute.HashAttributeSet
      • javax.print.attribute.HashPrintServiceAttributeSet
  • 所有已实现的接口：
    Serializable, AttributeSet, PrintServiceAttributeSet

    public class HashPrintServiceAttributeSet
extends HashAttributeSet
implements PrintServiceAttributeSet, Serializable
    Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      HashPrintServiceAttributeSet()
      Construct a new, empty hash print service attribute set.
      HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
      Construct a new hash print service attribute set, initially populated with the given value.
      HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
      Construct a new print service attribute set, initially populated with the values from the given array.
      HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintServiceAttribute interface.

    • 方法摘要

      • 方法 - 继承于类 javax.print.attribute.HashAttributeSet

        add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.PrintServiceAttributeSet

        add, addAll

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 构造方法详细信息

      • HashPrintServiceAttributeSet

        public HashPrintServiceAttributeSet()
        Construct a new, empty hash print service attribute set.

      • HashPrintServiceAttributeSet

        public HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
        Construct a new hash print service attribute set, initially populated with the given value.
        参数：
        attribute - Attribute value to add to the set.
        抛出：
        NullPointerException - (unchecked exception) Thrown if attribute is null.

      • HashPrintServiceAttributeSet

        public HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
        Construct a new print service attribute set, initially populated with the values from the given array. The new attribute set is populated by adding the elements of attributes array to the set in sequence, starting at index 0. Thus, later array elements may replace earlier array elements if the array contains duplicate attribute values or attribute categories.
        参数：
        attributes - Array of attribute values to add to the set. If null, an empty attribute set is constructed.
        抛出：
        NullPointerException - (unchecked exception) Thrown if any element of attributes is null.

      • HashPrintServiceAttributeSet

        public HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
        Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintServiceAttribute interface.
        参数：
        attributes - set of attribute values to initialise the set. If null, an empty attribute set is constructed.
        抛出：
        ClassCastException - (unchecked exception) Thrown if any element of attributes is not an instance of PrintServiceAttribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/<<>//o>>tis> rtD gg og� eria sv


IntegerSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 IntegerSyntax

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    Copies, JobImpressions, JobImpressionsCompleted, JobKOctets, JobKOctetsProcessed, JobMediaSheets, JobMediaSheetsCompleted, JobPriority, JobPrioritySupported, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, PagesPerMinute, PagesPerMinuteColor, QueuedJobCount

    public abstract class IntegerSyntax
extends Object
implements Serializable, Cloneable
    Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.

    Under the hood, an integer attribute is just an integer. You can get an integer attribute's integer value by calling getValue(). An integer attribute's integer value is established when it is constructed (see IntegerSyntax(int)). Once constructed, an integer attribute's value is immutable.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected IntegerSyntax(int value)
      Construct a new integer attribute with the given integer value.
      protected IntegerSyntax(int value, int lowerBound, int upperBound)
      Construct a new integer attribute with the given integer value, which must lie within the given range.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this integer attribute is equivalent to the passed in object.
      int getValue()
      Returns this integer attribute's integer value.
      int hashCode()
      Returns a hash code value for this integer attribute.
      String toString()
      Returns a string value corresponding to this integer attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • IntegerSyntax

        protected IntegerSyntax(int value)
        Construct a new integer attribute with the given integer value.
        参数：
        value - Integer value.

      • IntegerSyntax

        protected IntegerSyntax(int value,
             int lowerBound,
             int upperBound)
        Construct a new integer attribute with the given integer value, which must lie within the given range.
        参数：
        value - Integer value.
        lowerBound - Lower bound.
        upperBound - Upper bound.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than lowerBound or greater than upperBound.

    • 方法详细信息

      • getValue

        public int getValue()
        Returns this integer attribute's integer value.
        返回：
        the integer value

      • equals

        public boolean equals(Object object)
        Returns whether this integer attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class IntegerSyntax.
        3. This integer attribute's value and object's value are equal.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this integer attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code value for this integer attribute. The hash code is just this integer attribute's integer value.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string value corresponding to this integer attribute. The string value is just this integer attribute's integer value converted to a string.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1r2r rOce 间恕癿胊籥盟吮胏间粤 11�1 胞觬


javax.print.attribute

Interfaces

  • Attribute
  • AttributeSet
  • DocAttribute
  • DocAttributeSet
  • PrintJobAttribute
  • PrintJobAttributeSet
  • PrintRequestAttribute
  • PrintRequestAttributeSet
  • PrintServiceAttribute
  • PrintServiceAttributeSet
  • SupportedValuesAttribute

Classes

  • AttributeSetUtilities
  • DateTimeSyntax
  • EnumSyntax
  • HashAttributeSet
  • HashDocAttributeSet
  • HashPrintJobAttributeSet
  • HashPrintRequestAttributeSet
  • HashPrintServiceAttributeSet
  • IntegerSyntax
  • ResolutionSyntax
  • SetOfIntegerSyntax
  • Size2DSyntax
  • TextSyntax
  • URISyntax

Exceptions

  • UnmodifiableSetException
a


javax.print.attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.print.attribute

Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.

请参见： 描述

  • 接口摘要
    接口 描述
    Attribute
    Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
    AttributeSet
    Interface AttributeSet specifies the interface for a set of printing attributes.
    DocAttribute
    Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
    DocAttributeSet
    Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
    PrintJobAttribute
    PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job.
    PrintJobAttributeSet
    Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
    PrintRequestAttribute
    Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
    PrintServiceAttribute
    Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
    PrintServiceAttributeSet
    Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
    SupportedValuesAttribute
    Interface SupportedValuesAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the supported values for another attribute.
  • Class Summary
    类 描述
    AttributeSetUtilities
    Class AttributeSetUtilities provides static methods for manipulating AttributeSets.
    DateTimeSyntax
    Class DateTimeSyntax is an abstract base class providing the common implementation of all attributes whose value is a date and time.
    EnumSyntax
    Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects.
    HashAttributeSet
    Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.
    HashDocAttributeSet
    Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
    HashPrintJobAttributeSet
    Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
    HashPrintRequestAttributeSet
    Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
    HashPrintServiceAttributeSet
    Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
    IntegerSyntax
    Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.
    ResolutionSyntax
    Class ResolutionSyntax is an abstract base class providing the common implementation of all attributes denoting a printer resolution.
    SetOfIntegerSyntax
    Class SetOfIntegerSyntax is an abstract base class providing the common implementation of all attributes whose value is a set of nonnegative integers.
    Size2DSyntax
    Class Size2DSyntax is an abstract base class providing the common implementation of all attributes denoting a size in two dimensions.
    TextSyntax
    Class TextSyntax is an abstract base class providing the common implementation of all attributes whose value is a string.
    URISyntax
    Class URISyntax is an abstract base class providing the common implementation of all attributes whose value is a Uniform Resource Identifier (URI).
  • Exception Summary
    Exception 描述
    UnmodifiableSetException
    Thrown to indicate that the requested operation cannot be performed because the set is unmodifiable.

软件包 javax.print.attribute Description

Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.

What is an Attribute?

When setting up a print job, a client specifies two things: print data and processing instructions. The print data is the actual content to be printed. The processing instructions tell the printer how to print the print data, such as: what media to use, how many copies to print, and whether to print on one or both sides of a sheet. The client specifies these processing instructions with the attribute definitions of the Java Print Service API.

The print data and the processing instructions are separate entities. This means that:

  • You can print the same print data at different times using different processing instructions.
    For example, you can print a slide presentation on US letter-sized white paper, double-sided, stapled, 20 copies to make handouts for a talk; and you could print the same slide presentation on US letter-sized transparencies, single-sided, one copy to make the actual slides for the talk.
  • You can use the same processing instructions at different times to print different data. For example, you could set your default processing instructions to: US letter-sized paper, double sided, stapled. Whenever you print a job, it prints with these settings, unless you explicitly override them.

The processing instruction does not specify how the print job processes the request; each processing instruction is only a description of the results of a print job. The print job determines the manner in which it achieves the results specified by the processing instructions. Representing processing instructions as descriptive items provides more flexibility for implementing print jobs.

Attribute Categories and Values

Each printer has a set of capabilities, such as the ability to print on different paper sizes or the ability to print more than one copy. Each of the capabilities has a range of values. For example, a printer's orientation capability might have this range of values: [landscape, portrait]. For each print request, the capability is set to one of these values. The Java Print Service API uses the term attribute category to refer to a printer capability and the term attribute value to refer to the value of the capability.

In the Java Print Service API, an attribute category is represented by a Java class implementing the Attribute interface. Attribute values are instances of such a class or one of its subclasses. For example, to specify the number of copies, an application constructs an instance of the Copies class with the number of desired copies and uses the Copies instance as part of the print request. In this case, the Copies class represents the attribute category, and the Copies instance represents the attribute value.

Attribute Roles

When submitting a print job to a printer, the client provides the attributes describing the characteristics of the print data, such as the document name, and how the print data should be printed, such as double-sided, five copies. If a print job consists of multiple pieces of print data, different pieces might have different processing instructions, such as 8 x 11 inch media for the first document, and 11 x 17 inch media for another document.

Once the printer starts processing the print job, additional information about the job becomes available, which might include: the job state (such as completed or queued) and the number of pages printed so far. These pieces of information are also attributes. Attributes can also describe the printer itself, such as: the printer name, the printer location, and the number of jobs queued.

The Java Print Service API defines these different kinds of attributes with five subinterfaces of Attribute:

  • DocAttribute specifies a characteristic of an individual document and the print job settings to be applied to an individual document.
  • PrintRequestAttribute specifies a setting applied to a whole print job and to all the documents in the print job.
  • PrintJobAttribute reports the status of a print job.
  • PrintServiceAttribute reports the status of a print service.
  • SupportedValuesAttribute gives the supported values for another attribute.
Each attribute class implements one or more of these tagging subinterfaces to indicate where the attribute can be used in the API. If an attribute class implements multiple tagging subinterfaces, the attribute can be used in multiple contexts. For example, the media attribute can apply to one document in a print job as a DocAttribute or to an entire print job as a PrintRequestAttribute. Certain low-level attributes are never used on their own but are always aggregated into higher-level attributes. These low-level attribute classes only implement interface Attribute, not any of the tagging subinterfaces.

The Java Print Service API defines a group of standard attribute classes modeled upon the attributes in the Internet Printing Protocol (IPP) version 1.1. The standard attribute classes are in the subpackage javax.print.attribute.standard to keep the actual attribute classes conceptually separate from the generic apparatus defined in package javax.print.attribute.

Attribute Sets

A client usually needs to provide more than one processing instruction when submitting a print job. For example, the client might need to specify a media size of A4 and a landscape orientation. To send more than one processing instruction, the client collects the attributes into an attribute set, which the Java Print Service API represents with the AttributeSet interface.

The AttributeSet interface is similar to the Map interface: it provides a map of key to values, in which each key is unique and can contain no more than one value. However, the AttributeSet interface is designed to specifically support the needs of the Java Print Service API. An AttributeSet requires that:

  1. Each key in an AttributeSet corresponds to a category, and the value of the key can only be one of the attribute values that belong to the category represented by the key. Thus, unlike a Map, an AttributeSet restricts the possible values of a key: an attribute category cannot be set to an attribute value that does not belong to that category.
  2. No two attributes from the same category can exist in the same set. For example, an attribute collection must not contain both a "one-sided" attribute and a "two-sided" attribute because these two attributes give the printer conflicting instructions.
  3. Only attributes implementing the Attribute interface can be added to the set.

The javax.print.attribute package includes HashAttributeSet as a concrete implementation of the attribute set interface. HashAttributeSet provides an attribute set based on a hash map. You can use this implementation or provide your own implementation of interface AttributeSet.

The Java Print Service API provides four specializations of an attribute set that are restricted to contain just one of the four kinds of attributes, as discussed in the Attribute Roles section:

  • DocAttributeSet
  • PrintRequestAttributeSet
  • PrintJobAttributeSet
  • PrintServiceAttributeSet
Notice that only four kinds of attribute sets are listed here, but there are five kinds of attributes. Interface SupportedValuesAttribute denotes an attribute that gives the supported values for another attribute. Supported-values attributes are never aggregated into attribute sets, so there is no attribute set subinterface defined for them.

In some contexts, an attribute set is read-only, which means that the client is only allowed to examine an attribute set's contents but not change them. In other contexts, the attribute set is read-write, which means that the client is allowed both to examine and to change an attribute set's contents. For a read-only attribute set, calling a mutating operation throws an UnmodifiableSetException.

Package javax.print.attribute includes one concrete implementation of each of the attribute set subinterfaces:

  • HashDocAttributeSet
  • HashPrintRequestAttributeSet,
  • HashPrintJobAttributeSet,
  • HashPrintServiceAttributeSet.
All of these classes extend HashAttributeSet and enforce the restriction that the attribute set is only allowed to contain the corresponding kind of attribute.

Attribute Class Design

An attribute value is a small, atomic data item, such as an integer or an enumerated value. The Java Print Service API does not use primitive data types, such as int, to represent attribute values for these reasons:
  • Primitive data types are not type-safe. For example, a compiler should not allow a "copies" attribute value to be used for a "sides" attribute.
  • Some attributes must be represented as a record of several values. One example is printer resolution, which requires two numbers, such as 600 and 300 representing 600 x 300 dpi.
For type-safety and to represent all attributes uniformly, the Java Print Service API defines each attribute category as a class, such as class Copies, class Sides, and class PrinterResolution. Each attribute class wraps one or more primitive data items containing the attribute's value. Attribute set operations perform frequent comparisons between attribute category objects when adding attributes, finding existing attributes in the same category, and looking up an attribute given its category. Because an attribute category is represented by a class, fast attribute-value comparisons can be performed with the Class.equals method.

Even though the Java Print Service API includes a large number of different attribute categories, there are only a few different types of attribute values. Most attributes can be represented by a small number of data types, such as: integer values, integer ranges, text, or an enumeration of integer values. The type of the attribute value that a category accepts is called the attribute's abstract syntax. To provide consistency and reduce code duplication, the Java Print Service API defines abstract syntax classes to represent each abstract syntax, and these classes are used as the parent of standard attributes whenever possible. The abstract syntax classes are:

  • EnumSyntax provides a type-safe enumeration in which enumerated values are represented as singleton objects. Each enumeration singleton is an instance of the enumeration class that wraps a hidden int value.
  • IntegerSyntax is the abstract syntax for integer-valued attributes.
  • TextSyntax is the abstract syntax for text-valued attributes, and includes a locale giving the text string's natural language.
  • SetOfIntegerSyntax is the abstract syntax for attributes representing a range or set of integers
  • ResolutionSyntax is the abstract syntax for attributes representing resolution values, such as 600x300 dpi.
  • Size2DSyntax is the abstract syntax for attributes representing a two-dimensional size, such as a paper size of 8.5 x 11 inches.
  • DateTimeSyntax is the abstract syntax for attributes whose value is a date and time.
  • URISyntax is the abstract syntax for attributes whose value is a Uniform Resource Indicator.
The abstract syntax classes are independent of the attributes that use them. In fact, applications that have nothing to do with printing can use the abstract syntax classes. Although most of the standard attribute classes extend one of the abstract syntax classes, no attribute class is required to extend one of these classes. The abstract syntax classes merely provide a convenient implementation that can be shared by many attribute classes.

Each attribute class implements the Attribute interface, either directly or indirectly, to mark it as a printing attribute. An attribute class that can appear in restricted attribute sets in certain contexts also implements one or more subinterfaces of Attribute. Most attribute classes also extend the appropriate abstract syntax class to get the implementation. Consider the Sides attribute class:

public class Sides
  extends EnumSyntax
  implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
  {
  public final Object getCategory()
    {
    return Sides.class;
    }
  ...
  }

Since every attribute class implements Attribute, every attribute class must provide an implementation for the getCategory method, which returns the attribute category. In the case of Sides, the getCategory method returns Sides.class. The getCategory method is final to ensure that any vendor-defined subclasses of a standard attribute class appear in the same category. Every attribute object is immutable once constructed so that attribute object references can be passed around freely. To get a different attribute value, construct a different attribute object.

Attribute Vendors

The Java Print Service API is designed so that vendors can:
  • define new vendor-specific values for any standard attribute defined in javax.print.attribute.standard.
  • define new attribute categories representing the vendor printer's proprietary capabilities not already supported by the standard attributes.
To define a new value for an attribute, a client can construct instances of such attributes with arbitrary values at runtime. However, an enumerated attribute using an abstract syntax class of EnumSyntax specifies all the possible attribute values at compile time as singleton instances of the attribute class. This means that new enumerated values cannot be constructed at run time. To define new vendor-specific values for a standard enumerated attribute, the vendor must define a new attribute class specifying the new singleton instances. To ensure that the new attribute values fall in the same category as the standard attribute values, the new attribute class must be a subclass of the standard attribute class.

To define a new attribute category, a vendor defines a new attribute class. This attribute class, like the standard attribute classes, implements Attribute or one of its subinterfaces and extends an abstract syntax class. The vendor can either use an existing abstract syntax class or define a new one. The new vendor-defined attribute can be used wherever an Attribute is used, such as in an AttributeSet.

Using Attributes

A typical printing application uses the PrintRequestAttributeSet because print-request attributes are the types of attributes that client usually specifies. This example demonstrates creating an attribute set of print-request attributes and locating a printer that can print the document according to the specified attributes:

FileInputStream psStream;
try {
   psstream = new FileInputStream("file.ps");
} catch (FileNotFoundException ffne) {
}
if (psstream == null) {
    return;
}
//Set the document type.  See the DocFlavor documentation for
//more information.
DocFlavor psInFormat = DocFlavor.INPUT_STREAM.POSTSCRIPT;
Doc myDoc = new SimpleDoc(pstream, psInFormat, null);
PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
aset.add(new Copies(5));
aset.add(MediaSize.A4);
aset.add(Sides.DUPLEX);

PrintService[] services =
                PrintServiceLookup.lookupPrintServices(psInFormat, aset);
if (services.length > 0) {
   DocPrintJob job = services[0].createPrintJob();
   try {
        job.print(myDoc, aset);
   } catch (PrintException pe) {}
}

Please note: In the javax.print APIs, a null reference parameter to methods is incorrect unless explicitly documented on the method as having a meaningful interpretation. Usage to the contrary is incorrect coding and may result in a run time exception either immediately or at some later time. IllegalArgumentException and NullPointerException are examples of typical and acceptable run time exceptions for such cases.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


javax.print.attribute Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.print.attribute

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.print.attribute.AttributeSetUtilities
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.HashAttributeSet (implements javax.print.attribute.AttributeSet, java.io.Serializable)
      • javax.print.attribute.HashDocAttributeSet (implements javax.print.attribute.DocAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintJobAttributeSet (implements javax.print.attribute.PrintJobAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintRequestAttributeSet (implements javax.print.attribute.PrintRequestAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintServiceAttributeSet (implements javax.print.attribute.PrintServiceAttributeSet, java.io.Serializable)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.print.attribute.UnmodifiableSetException
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)

Interface Hierarchy

  • javax.print.attribute.AttributeSet
    • javax.print.attribute.DocAttributeSet
    • javax.print.attribute.PrintJobAttributeSet
    • javax.print.attribute.PrintRequestAttributeSet
    • javax.print.attribute.PrintServiceAttributeSet
  • java.io.Serializable
    • javax.print.attribute.Attribute
      • javax.print.attribute.DocAttribute
      • javax.print.attribute.PrintJobAttribute
      • javax.print.attribute.PrintRequestAttribute
      • javax.print.attribute.PrintServiceAttribute
      • javax.print.attribute.SupportedValuesAttribute
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c a;"bnEdddt <


PrintJobAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute

Interface PrintJobAttribute

  • All Superinterfaces:
    Attribute, Serializable
    All Known Implementing Classes:
    Chromaticity, Copies, DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, Destination, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobImpressionsCompleted, JobKOctets, JobKOctetsProcessed, JobMediaSheets, JobMediaSheetsCompleted, JobMessageFromOperator, JobName, JobOriginatingUserName, JobPriority, JobSheets, JobState, JobStateReasons, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, OrientationRequested, OutputDeviceAssigned, PageRanges, PresentationDirection, PrinterResolution, PrintQuality, SheetCollate, Sides

    public interface PrintJobAttribute
extends Attribute
    PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job. A Print Service instance adds a number of PrintJobAttributes to a Print Job's attribute set to report the Print Job's status. If an attribute implements PrintRequestAttribute as well as PrintJobAttribute, the client may include the attribute in a attribute set to specify the attribute's value for the Print Job.

    另请参见：
    PrintRequestAttributeSet, PrintJobAttributeSet

    • 方法摘要

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=r" oC=Co=s"slcc nn;bp


PrintJobAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface PrintJobAttributeSet

  • All Superinterfaces:
    AttributeSet
    All Known Implementing Classes:
    HashPrintJobAttributeSet

    public interface PrintJobAttributeSet
extends AttributeSet
    Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e. printing attributes that implement interface PrintJobAttribute. In the Print Service API, a service uses a PrintJobAttributeSet to report the status of a print job.

    A PrintJobAttributeSet is just an AttributeSet whose constructors and mutating operations guarantee an additional invariant, namely that all attribute values in the PrintJobAttributeSet must be instances of interface PrintJobAttribute. The add(Attribute), and addAll(AttributeSet) operations are respecified below to guarantee this additional invariant.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 方法详细信息

      • add

        boolean add(Attribute attribute)
        Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
        指定者：
        add in interface AttributeSet
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.
        ClassCastException - (unchecked exception) Thrown if the attribute is not an instance of interface PrintJobAttribute.
        NullPointerException - (unchecked exception) Thrown if the attribute is null.

      • addAll

        boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. If none of the categories in the specified set are the same as any categories in this attribute set, the addAll() operation effectively modifies this attribute set so that its value is the union of the two sets.

        The behavior of the addAll() operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll() operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        指定者：
        addAll in interface AttributeSet
        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll() method.
        ClassCastException - (Unchecked exception) Thrown if some element in the specified set is not an instance of interface PrintJobAttribute.
        NullPointerException - (Unchecked exception) Thrown if the specified set is null.
        另请参见：
        add(Attribute)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d.oc>rgr>>d oa neoobtoOa糴


PrintRequestAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute

Interface PrintRequestAttribute

  • All Superinterfaces:
    Attribute, Serializable
    All Known Implementing Classes:
    Chromaticity, Copies, Destination, DialogTypeSelection, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobKOctets, JobMediaSheets, JobName, JobPriority, JobSheets, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberUp, OrientationRequested, PageRanges, PresentationDirection, PrinterResolution, PrintQuality, RequestingUserName, SheetCollate, Sides

    public interface PrintRequestAttribute
extends Attribute
    Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.

    Attributes which are tagged with PrintRequestAttribute and are also tagged as PrintJobAttribute, represent the subset of job attributes which can be part of the specification of a job request.

    If an attribute implements DocAttribute as well as PrintRequestAttribute, the client may include the attribute in a Doc}'s attribute set to specify a job setting which pertains just to that doc.

    另请参见：
    DocAttributeSet, PrintRequestAttributeSet

    • 方法摘要

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o=d/saspasr::srraonni=caeaee�


PrintRequestAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface PrintRequestAttributeSet

  • All Superinterfaces:
    AttributeSet
    All Known Implementing Classes:
    HashPrintRequestAttributeSet

    public interface PrintRequestAttributeSet
extends AttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e. printing attributes that implement interface PrintRequestAttribute. The client uses a PrintRequestAttributeSet to specify the settings to be applied to a whole print job and to all the docs in the print job.

    PrintRequestAttributeSet is just an AttributeSet whose constructors and mutating operations guarantee an additional invariant, namely that all attribute values in the PrintRequestAttributeSet must be instances of interface PrintRequestAttribute. The add(Attribute), and addAll(AttributeSet) operations are respecified below to guarantee this additional invariant.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 方法详细信息

      • add

        boolean add(Attribute attribute)
        Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
        指定者：
        add in interface AttributeSet
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.
        ClassCastException - (unchecked exception) Thrown if the attribute is not an instance of interface PrintRequestAttribute.
        NullPointerException - (unchecked exception) Thrown if the attribute is null.

      • addAll

        boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. If none of the categories in the specified set are the same as any categories in this attribute set, the addAll() operation effectively modifies this attribute set so that its value is the union of the two sets.

        The behavior of the addAll() operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll() operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        指定者：
        addAll in interface AttributeSet
        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll() method.
        ClassCastException - (Unchecked exception) Thrown if some element in the specified set is not an instance of interface PrintRequestAttribute.
        NullPointerException - (Unchecked exception) Thrown if the specified set is null.
        另请参见：
        add(Attribute)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b lalla>i"t>n=l


PrintServiceAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute

Interface PrintServiceAttribute

  • All Superinterfaces:
    Attribute, Serializable
    All Known Implementing Classes:
    ColorSupported, PagesPerMinute, PagesPerMinuteColor, PDLOverrideSupported, PrinterInfo, PrinterIsAcceptingJobs, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterName, PrinterState, PrinterStateReasons, PrinterURI, QueuedJobCount

    public interface PrintServiceAttribute
extends Attribute
    Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service. A Print Service instance adds a number of PrintServiceAttributes to a Print service's attribute set to report the Print Service's status.

    另请参见：
    PrintServiceAttributeSet

    • 方法摘要

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ev a n n s ssDb lalCgxecu


PrintServiceAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute

Interface PrintServiceAttributeSet

  • All Superinterfaces:
    AttributeSet
    All Known Implementing Classes:
    HashPrintServiceAttributeSet

    public interface PrintServiceAttributeSet
extends AttributeSet
    Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e. printing attributes that implement interface PrintServiceAttribute. In the Print Service API, the Print Service instance uses a PrintServiceAttributeSet to report the status of the print service.

    A PrintServiceAttributeSet is just an AttributeSet whose constructors and mutating operations guarantee an additional invariant, namely that all attribute values in the PrintServiceAttributeSet must be instances of interface PrintServiceAttribute. The add(Attribute), and addAll(AttributeSet) operations are respecified below to guarantee this additional invariant.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.

      • 方法 - 继承于接口 javax.print.attribute.AttributeSet

        clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

    • 方法详细信息

      • add

        boolean add(Attribute attribute)
        Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
        指定者：
        add in interface AttributeSet
        参数：
        attribute - Attribute value to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call, i.e., the given attribute value was not already a member of this attribute set.
        抛出：
        UnmodifiableSetException - (unchecked exception) Thrown if this attribute set does not support the add() operation.
        ClassCastException - (unchecked exception) Thrown if the attribute is not an instance of interface PrintServiceAttribute.
        NullPointerException - (unchecked exception) Thrown if the attribute is null.

      • addAll

        boolean addAll(AttributeSet attributes)
        Adds all of the elements in the specified set to this attribute. The outcome is the same as if the add(Attribute) operation had been applied to this attribute set successively with each element from the specified set. If none of the categories in the specified set are the same as any categories in this attribute set, the addAll() operation effectively modifies this attribute set so that its value is the union of the two sets.

        The behavior of the addAll() operation is unspecified if the specified set is modified while the operation is in progress.

        If the addAll() operation throws an exception, the effect on this attribute set's state is implementation dependent; elements from the specified set before the point of the exception may or may not have been added to this attribute set.

        指定者：
        addAll in interface AttributeSet
        参数：
        attributes - whose elements are to be added to this attribute set.
        返回：
        true if this attribute set changed as a result of the call.
        抛出：
        UnmodifiableSetException - (Unchecked exception) Thrown if this attribute set does not support the addAll() method.
        ClassCastException - (Unchecked exception) Thrown if some element in the specified set is not an instance of interface PrintServiceAttribute.
        NullPointerException - (Unchecked exception) Thrown if the specified set is null.
        另请参见：
        add(Attribute)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>o/a/>///< /bo>h dd/>/mlsb > >


ResolutionSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 ResolutionSyntax

  • java.lang.Object
    • javax.print.attribute.ResolutionSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    PrinterResolution

    public abstract class ResolutionSyntax
extends Object
implements Serializable, Cloneable
    Class ResolutionSyntax is an abstract base class providing the common implementation of all attributes denoting a printer resolution.

    A resolution attribute's value consists of two items, the cross feed direction resolution and the feed direction resolution. A resolution attribute may be constructed by supplying the two values and indicating the units in which the values are measured. Methods are provided to return a resolution attribute's values, indicating the units in which the values are to be returned. The two most common resolution units are dots per inch (dpi) and dots per centimeter (dpcm), and exported constants DPI and DPCM are provided for indicating those units.

    Once constructed, a resolution attribute's value is immutable.

    Design

    A resolution attribute's cross feed direction resolution and feed direction resolution values are stored internally using units of dots per 100 inches (dphi). Storing the values in dphi rather than, say, metric units allows precise integer arithmetic conversions between dpi and dphi and between dpcm and dphi: 1 dpi = 100 dphi, 1 dpcm = 254 dphi. Thus, the values can be stored into and retrieved back from a resolution attribute in either units with no loss of precision. This would not be guaranteed if a floating point representation were used. However, roundoff error will in general occur if a resolution attribute's values are created in one units and retrieved in different units; for example, 600 dpi will be rounded to 236 dpcm, whereas the true value (to five figures) is 236.22 dpcm.

    Storing the values internally in common units of dphi lets two resolution attributes be compared without regard to the units in which they were created; for example, 300 dpcm will compare equal to 762 dpi, as they both are stored as 76200 dphi. In particular, a lookup service can match resolution attributes based on equality of their serialized representations regardless of the units in which they were created. Again, using integers for internal storage allows precise equality comparisons to be done, which would not be guaranteed if a floating point representation were used.

    The exported constant DPI is actually the conversion factor by which to multiply a value in dpi to get the value in dphi. Likewise, the exported constant DPCM is the conversion factor by which to multiply a value in dpcm to get the value in dphi. A client can specify a resolution value in units other than dpi or dpcm by supplying its own conversion factor. However, since the internal units of dphi was chosen with supporting only the external units of dpi and dpcm in mind, there is no guarantee that the conversion factor for the client's units will be an exact integer. If the conversion factor isn't an exact integer, resolution values in the client's units won't be stored precisely.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DPCM
      Value to indicate units of dots per centimeter (dpcm).
      static int DPI
      Value to indicate units of dots per inch (dpi).

    • 构造方法摘要

      Constructors
      构造方法与描述
      ResolutionSyntax(int crossFeedResolution, int feedResolution, int units)
      Construct a new resolution attribute from the given items.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this resolution attribute is equivalent to the passed in object.
      int getCrossFeedResolution(int units)
      Returns this resolution attribute's cross feed direction resolution in the given units.
      protected int getCrossFeedResolutionDphi()
      Returns this resolution attribute's cross feed direction resolution in units of dphi.
      int getFeedResolution(int units)
      Returns this resolution attribute's feed direction resolution in the given units.
      protected int getFeedResolutionDphi()
      Returns this resolution attribute's feed direction resolution in units of dphi.
      int[] getResolution(int units)
      Get this resolution attribute's resolution values in the given units.
      int hashCode()
      Returns a hash code value for this resolution attribute.
      boolean lessThanOrEquals(ResolutionSyntax other)
      Determine whether this resolution attribute's value is less than or equal to the given resolution attribute's value.
      String toString()
      Returns a string version of this resolution attribute.
      String toString(int units, String unitsName)
      Returns a string version of this resolution attribute in the given units.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DPI

        public static final int DPI
        Value to indicate units of dots per inch (dpi). It is actually the conversion factor by which to multiply dpi to yield dphi (100).
        另请参见：
        Constant Field Values

      • DPCM

        public static final int DPCM
        Value to indicate units of dots per centimeter (dpcm). It is actually the conversion factor by which to multiply dpcm to yield dphi (254).
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ResolutionSyntax

        public ResolutionSyntax(int crossFeedResolution,
                int feedResolution,
                int units)
        Construct a new resolution attribute from the given items.
        参数：
        crossFeedResolution - Cross feed direction resolution.
        feedResolution - Feed direction resolution.
        units - Unit conversion factor, e.g. DPI or DPCM.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if crossFeedResolution < 1 or feedResolution < 1 or units < 1.

    • 方法详细信息

      • getResolution

        public int[] getResolution(int units)
        Get this resolution attribute's resolution values in the given units. The values are rounded to the nearest integer.
        参数：
        units - Unit conversion factor, e.g. DPI or DPCM.
        返回：
        A two-element array with the cross feed direction resolution at index 0 and the feed direction resolution at index 1.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getCrossFeedResolution

        public int getCrossFeedResolution(int units)
        Returns this resolution attribute's cross feed direction resolution in the given units. The value is rounded to the nearest integer.
        参数：
        units - Unit conversion factor, e.g. DPI or DPCM.
        返回：
        Cross feed direction resolution.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getFeedResolution

        public int getFeedResolution(int units)
        Returns this resolution attribute's feed direction resolution in the given units. The value is rounded to the nearest integer.
        参数：
        units - Unit conversion factor, e.g. DPI or DPCM.
        返回：
        Feed direction resolution.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • toString

        public String toString(int units,
              String unitsName)
        Returns a string version of this resolution attribute in the given units. The string takes the form "CxF U", where C is the cross feed direction resolution, F is the feed direction resolution, and U is the units name. The values are rounded to the nearest integer.
        参数：
        units - Unit conversion factor, e.g. DPI or DPCM.
        unitsName - Units name string, e.g. "dpi" or "dpcm". If null, no units name is appended to the result.
        返回：
        String version of this resolution attribute.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • lessThanOrEquals

        public boolean lessThanOrEquals(ResolutionSyntax other)
        Determine whether this resolution attribute's value is less than or equal to the given resolution attribute's value. This is true if all of the following conditions are true:
        • This attribute's cross feed direction resolution is less than or equal to the other attribute's cross feed direction resolution.
        • This attribute's feed direction resolution is less than or equal to the other attribute's feed direction resolution.
        参数：
        other - Resolution attribute to compare with.
        返回：
        True if this resolution attribute is less than or equal to the other resolution attribute, false otherwise.
        抛出：
        NullPointerException - (unchecked exception) Thrown if other is null.

      • equals

        public boolean equals(Object object)
        Returns whether this resolution attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class ResolutionSyntax.
        3. This attribute's cross feed direction resolution is equal to object's cross feed direction resolution.
        4. This attribute's feed direction resolution is equal to object's feed direction resolution.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this resolution attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code value for this resolution attribute.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string version of this resolution attribute. The string takes the form "CxF dphi", where C is the cross feed direction resolution and F is the feed direction resolution. The values are reported in the internal units of dphi.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • getCrossFeedResolutionDphi

        protected int getCrossFeedResolutionDphi()
        Returns this resolution attribute's cross feed direction resolution in units of dphi. (For use in a subclass.)
        返回：
        Cross feed direction resolution.

      • getFeedResolutionDphi

        protected int getFeedResolutionDphi()
        Returns this resolution attribute's feed direction resolution in units of dphi. (For use in a subclass.)
        返回：
        Feed direction resolution.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

琾 aa�


SetOfIntegerSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 SetOfIntegerSyntax

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    CopiesSupported, JobImpressionsSupported, JobKOctetsSupported, JobMediaSheetsSupported, NumberUpSupported, PageRanges

    public abstract class SetOfIntegerSyntax
extends Object
implements Serializable, Cloneable
    Class SetOfIntegerSyntax is an abstract base class providing the common implementation of all attributes whose value is a set of nonnegative integers. This includes attributes whose value is a single range of integers and attributes whose value is a set of ranges of integers.

    You can construct an instance of SetOfIntegerSyntax by giving it in "string form." The string consists of zero or more comma-separated integer groups. Each integer group consists of either one integer, two integers separated by a hyphen (-), or two integers separated by a colon (:). Each integer consists of one or more decimal digits (0 through 9). Whitespace characters cannot appear within an integer but are otherwise ignored. For example: "", "1", "5-10", "1:2, 4".

    You can also construct an instance of SetOfIntegerSyntax by giving it in "array form." Array form consists of an array of zero or more integer groups where each integer group is a length-1 or length-2 array of ints; for example, int[0][], int[][]{{1}}, int[][]{{5,10}}, int[][]{{1,2},{4}}.

    In both string form and array form, each successive integer group gives a range of integers to be included in the set. The first integer in each group gives the lower bound of the range; the second integer in each group gives the upper bound of the range; if there is only one integer in the group, the upper bound is the same as the lower bound. If the upper bound is less than the lower bound, it denotes a null range (no values). If the upper bound is equal to the lower bound, it denotes a range consisting of a single value. If the upper bound is greater than the lower bound, it denotes a range consisting of more than one value. The ranges may appear in any order and are allowed to overlap. The union of all the ranges gives the set's contents. Once a SetOfIntegerSyntax instance is constructed, its value is immutable.

    The SetOfIntegerSyntax object's value is actually stored in "canonical array form." This is the same as array form, except there are no null ranges; the members of the set are represented in as few ranges as possible (i.e., overlapping ranges are coalesced); the ranges appear in ascending order; and each range is always represented as a length-two array of ints in the form {lower bound, upper bound}. An empty set is represented as a zero-length array.

    Class SetOfIntegerSyntax has operations to return the set's members in canonical array form, to test whether a given integer is a member of the set, and to iterate through the members of the set.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SetOfIntegerSyntax(int member)
      Construct a new set-of-integer attribute containing a single integer.
      protected SetOfIntegerSyntax(int[][] members)
      Construct a new set-of-integer attribute with the given members in array form.
      protected SetOfIntegerSyntax(int lowerBound, int upperBound)
      Construct a new set-of-integer attribute containing a single range of integers.
      protected SetOfIntegerSyntax(String members)
      Construct a new set-of-integer attribute with the given members in string form.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(int x)
      Determine if this set-of-integer attribute contains the given value.
      boolean contains(IntegerSyntax attribute)
      Determine if this set-of-integer attribute contains the given integer attribute's value.
      boolean equals(Object object)
      Returns whether this set-of-integer attribute is equivalent to the passed in object.
      int[][] getMembers()
      Obtain this set-of-integer attribute's members in canonical array form.
      int hashCode()
      Returns a hash code value for this set-of-integer attribute.
      int 下一个(int x)
      Determine the smallest integer in this set-of-integer attribute that is greater than the given value.
      String toString()
      Returns a string value corresponding to this set-of-integer attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SetOfIntegerSyntax

        protected SetOfIntegerSyntax(String members)
        Construct a new set-of-integer attribute with the given members in string form.
        参数：
        members - Set members in string form. If null, an empty set is constructed.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if members does not obey the proper syntax.

      • SetOfIntegerSyntax

        protected SetOfIntegerSyntax(int[][] members)
        Construct a new set-of-integer attribute with the given members in array form.
        参数：
        members - Set members in array form. If null, an empty set is constructed.
        抛出：
        NullPointerException - (Unchecked exception) Thrown if any element of members is null.
        IllegalArgumentException - (Unchecked exception) Thrown if any element of members is not a length-one or length-two array or if any non-null range in members has a lower bound less than zero.

      • SetOfIntegerSyntax

        protected SetOfIntegerSyntax(int member)
        Construct a new set-of-integer attribute containing a single integer.
        参数：
        member - Set member.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if member is less than zero.

      • SetOfIntegerSyntax

        protected SetOfIntegerSyntax(int lowerBound,
                  int upperBound)
        Construct a new set-of-integer attribute containing a single range of integers. If the lower bound is greater than the upper bound (a null range), an empty set is constructed.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if the range is non-null and lowerBound is less than zero.

    • 方法详细信息

      • getMembers

        public int[][] getMembers()
        Obtain this set-of-integer attribute's members in canonical array form. The returned array is "safe;" the client may alter it without affecting this set-of-integer attribute.
        返回：
        This set-of-integer attribute's members in canonical array form.

      • contains

        public boolean contains(int x)
        Determine if this set-of-integer attribute contains the given value.
        参数：
        x - Integer value.
        返回：
        True if this set-of-integer attribute contains the value x, false otherwise.

      • contains

        public boolean contains(IntegerSyntax attribute)
        Determine if this set-of-integer attribute contains the given integer attribute's value.
        参数：
        attribute - Integer attribute.
        返回：
        True if this set-of-integer attribute contains theAttribute's value, false otherwise.

      • 下一个

        public int next(int x)
        Determine the smallest integer in this set-of-integer attribute that is greater than the given value. If there are no integers in this set-of-integer attribute greater than the given value, -1 is returned. (Since a set-of-integer attribute can only contain nonnegative values, -1 will never appear in the set.) You can use the next() method to iterate through the integer values in a set-of-integer attribute in ascending order, like this:
             SetOfIntegerSyntax attribute = . . .;
     int i = -1;
     while ((i = attribute.next (i)) != -1)
         {
         foo (i);
         }
        参数：
        x - Integer value.
        返回：
        The smallest integer in this set-of-integer attribute that is greater than x, or -1 if no integer in this set-of-integer attribute is greater than x.

      • equals

        public boolean equals(Object object)
        Returns whether this set-of-integer attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class SetOfIntegerSyntax.
        3. This set-of-integer attribute's members and object's members are the same.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this set-of-integer attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code value for this set-of-integer attribute. The hash code is the sum of the lower and upper bounds of the ranges in the canonical array form, or 0 for an empty set.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string value corresponding to this set-of-integer attribute. The string value is a zero-length string if this set is empty. Otherwise, the string value is a comma-separated list of the ranges in the canonical array form, where each range is represented as "i" if the lower bound equals the upper bound or "i-j" otherwise.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lL>t b ob ftt ffiraa>l/gcee


Size2DSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 Size2DSyntax

  • java.lang.Object
    • javax.print.attribute.Size2DSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    MediaSize

    public abstract class Size2DSyntax
extends Object
implements Serializable, Cloneable
    Class Size2DSyntax is an abstract base class providing the common implementation of all attributes denoting a size in two dimensions.

    A two-dimensional size attribute's value consists of two items, the X dimension and the Y dimension. A two-dimensional size attribute may be constructed by supplying the two values and indicating the units in which the values are measured. Methods are provided to return a two-dimensional size attribute's values, indicating the units in which the values are to be returned. The two most common size units are inches (in) and millimeters (mm), and exported constants INCH and MM are provided for indicating those units.

    Once constructed, a two-dimensional size attribute's value is immutable.

    Design

    A two-dimensional size attribute's X and Y dimension values are stored internally as integers in units of micrometers (µm), where 1 micrometer = 10-6 meter = 1/1000 millimeter = 1/25400 inch. This permits dimensions to be represented exactly to a precision of 1/1000 mm (= 1 µm) or 1/100 inch (= 254 µm). If fractional inches are expressed in negative powers of two, this permits dimensions to be represented exactly to a precision of 1/8 inch (= 3175 µm) but not 1/16 inch (because 1/16 inch does not equal an integral number of µm).

    Storing the dimensions internally in common units of µm lets two size attributes be compared without regard to the units in which they were created; for example, 8.5 in will compare equal to 215.9 mm, as they both are stored as 215900 µm. For example, a lookup service can match resolution attributes based on equality of their serialized representations regardless of the units in which they were created. Using integers for internal storage allows precise equality comparisons to be done, which would not be guaranteed if an internal floating point representation were used. Note that if you're looking for U.S. letter sized media in metric units, you have to search for a media size of 215.9 x 279.4 mm; rounding off to an integral 216 x 279 mm will not match.

    The exported constant INCH is actually the conversion factor by which to multiply a value in inches to get the value in µm. Likewise, the exported constant MM is the conversion factor by which to multiply a value in mm to get the value in µm. A client can specify a resolution value in units other than inches or mm by supplying its own conversion factor. However, since the internal units of µm was chosen with supporting only the external units of inch and mm in mind, there is no guarantee that the conversion factor for the client's units will be an exact integer. If the conversion factor isn't an exact integer, resolution values in the client's units won't be stored precisely.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int INCH
      Value to indicate units of inches (in).
      static int MM
      Value to indicate units of millimeters (mm).

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Size2DSyntax(float x, float y, int units)
      Construct a new two-dimensional size attribute from the given floating-point values.
      protected Size2DSyntax(int x, int y, int units)
      Construct a new two-dimensional size attribute from the given integer values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this two-dimensional size attribute is equivalent to the passed in object.
      float[] getSize(int units)
      Get this two-dimensional size attribute's dimensions in the given units as floating-point values.
      float getX(int units)
      Returns this two-dimensional size attribute's X dimension in the given units as a floating-point value.
      protected int getXMicrometers()
      Returns this two-dimensional size attribute's X dimension in units of micrometers (µm).
      float getY(int units)
      Returns this two-dimensional size attribute's Y dimension in the given units as a floating-point value.
      protected int getYMicrometers()
      Returns this two-dimensional size attribute's Y dimension in units of micrometers (µm).
      int hashCode()
      Returns a hash code value for this two-dimensional size attribute.
      String toString()
      Returns a string version of this two-dimensional size attribute.
      String toString(int units, String unitsName)
      Returns a string version of this two-dimensional size attribute in the given units.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INCH

        public static final int INCH
        Value to indicate units of inches (in). It is actually the conversion factor by which to multiply inches to yield µm (25400).
        另请参见：
        Constant Field Values

      • MM

        public static final int MM
        Value to indicate units of millimeters (mm). It is actually the conversion factor by which to multiply mm to yield µm (1000).
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Size2DSyntax

        protected Size2DSyntax(float x,
            float y,
            int units)
        Construct a new two-dimensional size attribute from the given floating-point values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. INCH or MM.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1.

      • Size2DSyntax

        protected Size2DSyntax(int x,
            int y,
            int units)
        Construct a new two-dimensional size attribute from the given integer values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. INCH or MM.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1.

    • 方法详细信息

      • getSize

        public float[] getSize(int units)
        Get this two-dimensional size attribute's dimensions in the given units as floating-point values.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        A two-element array with the X dimension at index 0 and the Y dimension at index 1.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getX

        public float getX(int units)
        Returns this two-dimensional size attribute's X dimension in the given units as a floating-point value.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        X dimension.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getY

        public float getY(int units)
        Returns this two-dimensional size attribute's Y dimension in the given units as a floating-point value.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        Y dimension.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • toString

        public String toString(int units,
              String unitsName)
        Returns a string version of this two-dimensional size attribute in the given units. The string takes the form "XxY U", where X is the X dimension, Y is the Y dimension, and U is the units name. The values are displayed in floating point.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        unitsName - Units name string, e.g. "in" or "mm". If null, no units name is appended to the result.
        返回：
        String version of this two-dimensional size attribute.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • equals

        public boolean equals(Object object)
        Returns whether this two-dimensional size attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class Size2DSyntax.
        3. This attribute's X dimension is equal to object's X dimension.
        4. This attribute's Y dimension is equal to object's Y dimension.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this two-dimensional size attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hash code value for this two-dimensional size attribute.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns a string version of this two-dimensional size attribute. The string takes the form "XxY um", where X is the X dimension and Y is the Y dimension. The values are reported in the internal units of micrometers.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • getXMicrometers

        protected int getXMicrometers()
        Returns this two-dimensional size attribute's X dimension in units of micrometers (µm). (For use in a subclass.)
        返回：
        X dimension (µm).

      • getYMicrometers

        protected int getYMicrometers()
        Returns this two-dimensional size attribute's Y dimension in units of micrometers (µm). (For use in a subclass.)
        返回：
        Y dimension (µm).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l bprr a=/雔s詓 s=�"c�"nf�


SupportedValuesAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute

Interface SupportedValuesAttribute

  • All Superinterfaces:
    Attribute, Serializable
    All Known Implementing Classes:
    CopiesSupported, JobImpressionsSupported, JobKOctetsSupported, JobMediaSheetsSupported, JobPrioritySupported, NumberUpSupported

    public interface SupportedValuesAttribute
extends Attribute
    Interface SupportedValuesAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the supported values for another attribute. For example, if a Print Service instance supports the Copies attribute, the Print Service instance will have a CopiesSupported attribute, which is a SupportedValuesAttribute giving the legal values a client may specify for the Copies attribute.

    • 方法摘要

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d-et/>>a>>"MM>""mybbte >hgct


TextSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 TextSyntax

  • java.lang.Object
    • javax.print.attribute.TextSyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    DocumentName, JobMessageFromOperator, JobName, JobOriginatingUserName, OutputDeviceAssigned, PrinterInfo, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterName, RequestingUserName

    public abstract class TextSyntax
extends Object
implements Serializable, Cloneable
    Class TextSyntax is an abstract base class providing the common implementation of all attributes whose value is a string. The text attribute includes a locale to indicate the natural language. Thus, a text attribute always represents a localized string. Once constructed, a text attribute's value is immutable.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TextSyntax(String value, Locale locale)
      Constructs a TextAttribute with the specified string and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this text attribute is equivalent to the passed in object.
      Locale getLocale()
      Returns this text attribute's text string's natural language (locale).
      String getValue()
      Returns this text attribute's text string.
      int hashCode()
      Returns a hashcode for this text attribute.
      String toString()
      Returns a String identifying this text attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TextSyntax

        protected TextSyntax(String value,
          Locale locale)
        Constructs a TextAttribute with the specified string and locale.
        参数：
        value - Text string.
        locale - Natural language of the text string. null is interpreted to mean the default locale for as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if value is null.

    • 方法详细信息

      • getValue

        public String getValue()
        Returns this text attribute's text string.
        返回：
        the text string.

      • getLocale

        public Locale getLocale()
        Returns this text attribute's text string's natural language (locale).
        返回：
        the locale

      • hashCode

        public int hashCode()
        Returns a hashcode for this text attribute.
        重载：
        hashCode in class Object
        返回：
        A hashcode value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object object)
        Returns whether this text attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class TextSyntax.
        3. This text attribute's underlying string and object's underlying string are equal.
        4. This text attribute's locale and object's locale are equal.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this text attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Returns a String identifying this text attribute. The String is the attribute's underlying text string.
        重载：
        toString in class Object
        返回：
        A String identifying this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csl_eprt


UnmodifiableSetException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.print.attribute

类 UnmodifiableSetException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.print.attribute.UnmodifiableSetException
  • 所有已实现的接口：
    Serializable

    public class UnmodifiableSetException
extends RuntimeException
    Thrown to indicate that the requested operation cannot be performed because the set is unmodifiable.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnmodifiableSetException()
      Constructs an UnsupportedOperationException with no detail message.
      UnmodifiableSetException(String message)
      Constructs an UnmodifiableSetException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnmodifiableSetException

        public UnmodifiableSetException()
        Constructs an UnsupportedOperationException with no detail message.

      • UnmodifiableSetException

        public UnmodifiableSetException(String message)
        Constructs an UnmodifiableSetException with the specified detail message.
        参数：
        message - the detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>a//cuaa


URISyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute

类 URISyntax

  • java.lang.Object
    • javax.print.attribute.URISyntax
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    Destination, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterURI

    public abstract class URISyntax
extends Object
implements Serializable, Cloneable
    Class URISyntax is an abstract base class providing the common implementation of all attributes whose value is a Uniform Resource Identifier (URI). Once constructed, a URI attribute's value is immutable.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected URISyntax(URI uri)
      Constructs a URI attribute with the specified URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this URI attribute is equivalent to the passed in object.
      URI getURI()
      Returns this URI attribute's URI value.
      int hashCode()
      Returns a hashcode for this URI attribute.
      String toString()
      Returns a String identifying this URI attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • URISyntax

        protected URISyntax(URI uri)
        Constructs a URI attribute with the specified URI.
        参数：
        uri - URI.
        抛出：
        NullPointerException - (unchecked exception) Thrown if uri is null.

    • 方法详细信息

      • getURI

        public URI getURI()
        Returns this URI attribute's URI value.
        返回：
        the URI.

      • hashCode

        public int hashCode()
        Returns a hashcode for this URI attribute.
        重载：
        hashCode in class Object
        返回：
        A hashcode value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object object)
        Returns whether this URI attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class URISyntax.
        3. This URI attribute's underlying URI and object's underlying URI are equal.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this URI attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Returns a String identifying this URI attribute. The String is the string representation of the attribute's underlying URI.
        重载：
        toString in class Object
        返回：
        A String identifying this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o tp=#"#h rrh / ooTFOl TM.TM OO==V->eAb


Uses of Package javax.print.attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.print.attribute

  • Packages that use javax.print.attribute
    软件包 描述
    java.awt.print
    Provides classes and interfaces for a general printing API.
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
  • Classes in javax.print.attribute used by java.awt.print
    类与描述
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
  • Classes in javax.print.attribute used by javax.print
    类与描述
    Attribute
    Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
    AttributeSet
    Interface AttributeSet specifies the interface for a set of printing attributes.
    DocAttributeSet
    Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
    PrintJobAttributeSet
    Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
    PrintServiceAttribute
    Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
    PrintServiceAttributeSet
    Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
  • Classes in javax.print.attribute used by javax.print.attribute
    类与描述
    Attribute
    Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
    AttributeSet
    Interface AttributeSet specifies the interface for a set of printing attributes.
    DocAttribute
    Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
    DocAttributeSet
    Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
    EnumSyntax
    Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects.
    HashAttributeSet
    Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.
    IntegerSyntax
    Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.
    PrintJobAttribute
    PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job.
    PrintJobAttributeSet
    Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
    PrintRequestAttribute
    Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
    PrintServiceAttribute
    Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
    PrintServiceAttributeSet
    Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
    ResolutionSyntax
    Class ResolutionSyntax is an abstract base class providing the common implementation of all attributes denoting a printer resolution.
  • Classes in javax.print.attribute used by javax.print.attribute.standard
    类与描述
    Attribute
    Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
    DateTimeSyntax
    Class DateTimeSyntax is an abstract base class providing the common implementation of all attributes whose value is a date and time.
    DocAttribute
    Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
    EnumSyntax
    Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects.
    IntegerSyntax
    Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.
    PrintJobAttribute
    PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job.
    PrintRequestAttribute
    Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.
    PrintServiceAttribute
    Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
    ResolutionSyntax
    Class ResolutionSyntax is an abstract base class providing the common implementation of all attributes denoting a printer resolution.
    SetOfIntegerSyntax
    Class SetOfIntegerSyntax is an abstract base class providing the common implementation of all attributes whose value is a set of nonnegative integers.
    Size2DSyntax
    Class Size2DSyntax is an abstract base class providing the common implementation of all attributes denoting a size in two dimensions.
    SupportedValuesAttribute
    Interface SupportedValuesAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the supported values for another attribute.
    TextSyntax
    Class TextSyntax is an abstract base class providing the common implementation of all attributes whose value is a string.
    URISyntax
    Class URISyntax is an abstract base class providing the common implementation of all attributes whose value is a Uniform Resource Identifier (URI).
  • Classes in javax.print.attribute used by javax.print.event
    类与描述
    PrintJobAttributeSet
    Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
    PrintServiceAttributeSet
    Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
  • Classes in javax.print.attribute used by javax.swing
    类与描述
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
  • Classes in javax.print.attribute used by javax.swing.text
    类与描述
    PrintRequestAttributeSet
    Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

utSea/meajjtunh


Uses of Class javax.print.attribute.AttributeSetUtilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.AttributeSetUtilities

No usage of javax.print.attribute.AttributeSetUtilities
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

au lrrtaoo<


Uses of Class javax.print.attribute.DateTimeSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.DateTimeSyntax

  • Packages that use DateTimeSyntax
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of DateTimeSyntax in javax.print.attribute.standard

      Subclasses of DateTimeSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  DateTimeAtCompleted
      Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).
      class  DateTimeAtCreation
      Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.
      class  DateTimeAtProcessing
      Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.
      class  JobHoldUntil
      Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


Uses of Class javax.print.attribute.EnumSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.EnumSyntax

  • Packages that use EnumSyntax
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of EnumSyntax in javax.print.attribute

      Methods in javax.print.attribute that return EnumSyntax
      修饰符与类型 方法与描述
      protected EnumSyntax[] EnumSyntax.getEnumValueTable()
      Returns the enumeration value table for this enumeration value's enumeration class.

    • Uses of EnumSyntax in javax.print.attribute.standard

      Subclasses of EnumSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  Chromaticity
      Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
      class  ColorSupported
      Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
      class  Compression
      Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
      class  DialogTypeSelection
      Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
      class  Fidelity
      Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
      class  Finishings
      Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
      class  JobSheets
      Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
      class  JobState
      JobState is a printing attribute class, an enumeration, that identifies the current state of a print job.
      class  JobStateReason
      Class JobStateReason is a printing attribute class, an enumeration, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
      class  Media
      Class Media is a printing attribute class that specifies the medium on which to print.
      class  MediaName
      Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
      class  MediaSizeName
      Class MediaSizeName is a subclass of Media.
      class  MediaTray
      Class MediaTray is a subclass of Media.
      class  MultipleDocumentHandling
      Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
      class  OrientationRequested
      Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
      class  PDLOverrideSupported
      Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.
      class  PresentationDirection
      Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
      class  PrinterIsAcceptingJobs
      Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs.
      class  PrinterState
      Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer.
      class  PrinterStateReason
      Class PrinterStateReason is a printing attribute class, an enumeration, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
      class  PrintQuality
      Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
      class  ReferenceUriSchemesSupported
      Class ReferenceUriSchemesSupported is a printing attribute class an enumeration, that indicates a "URI scheme," such as "http:" or "ftp:", that a printer can use to retrieve print data stored at a URI location.
      class  Severity
      Class Severity is a printing attribute class, an enumeration, that denotes the severity of a PrinterStateReason attribute.
      class  SheetCollate
      Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
      class  Sides
      Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.
      Methods in javax.print.attribute.standard that return EnumSyntax
      修饰符与类型 方法与描述
      protected EnumSyntax[] SheetCollate.getEnumValueTable()
      Returns the enumeration value table for class SheetCollate.
      protected EnumSyntax[] Sides.getEnumValueTable()
      Returns the enumeration value table for class Sides.
      protected EnumSyntax[] ReferenceUriSchemesSupported.getEnumValueTable()
      Returns the enumeration value table for class ReferenceUriSchemesSupported.
      protected EnumSyntax[] Severity.getEnumValueTable()
      Returns the enumeration value table for class Severity.
      protected EnumSyntax[] PrinterStateReason.getEnumValueTable()
      Returns the enumeration value table for class PrinterStateReason.
      protected EnumSyntax[] PrinterState.getEnumValueTable()
      Returns the enumeration value table for class PrinterState.
      protected EnumSyntax[] PrinterIsAcceptingJobs.getEnumValueTable()
      Returns the enumeration value table for class PrinterIsAcceptingJobs.
      protected EnumSyntax[] PrintQuality.getEnumValueTable()
      Returns the enumeration value table for class PrintQuality.
      protected EnumSyntax[] PresentationDirection.getEnumValueTable()
      Returns the enumeration value table for class PresentationDirection.
      protected EnumSyntax[] PDLOverrideSupported.getEnumValueTable()
      Returns the enumeration value table for class PDLOverrideSupported.
      protected EnumSyntax[] MultipleDocumentHandling.getEnumValueTable()
      Returns the enumeration value table for class MultipleDocumentHandling.
      protected EnumSyntax[] MediaTray.getEnumValueTable()
      Returns the enumeration value table for class MediaTray.
      protected EnumSyntax[] MediaName.getEnumValueTable()
      Returns the enumeration value table for class MediaTray.
      protected EnumSyntax[] JobStateReason.getEnumValueTable()
      Returns the enumeration value table for class JobStateReason.
      protected EnumSyntax[] JobState.getEnumValueTable()
      Returns the enumeration value table for class JobState.
      protected EnumSyntax[] JobSheets.getEnumValueTable()
      Returns the enumeration value table for class JobSheets.
      protected EnumSyntax[] Finishings.getEnumValueTable()
      Returns the enumeration value table for class Finishings.
      protected EnumSyntax[] Fidelity.getEnumValueTable()
      Returns the enumeration value table for class Fidelity.
      protected EnumSyntax[] DialogTypeSelection.getEnumValueTable()
      Returns the enumeration value table for class DialogTypeSelection.
      protected EnumSyntax[] Compression.getEnumValueTable()
      Returns the enumeration value table for class Compression.
      protected EnumSyntax[] ColorSupported.getEnumValueTable()
      Returns the enumeration value table for class ColorSupported.
      protected EnumSyntax[] Chromaticity.getEnumValueTable()
      Returns the enumeration value table for class Chromaticity.
      protected EnumSyntax[] OrientationRequested.getEnumValueTable()
      Returns the enumeration value table for class OrientationRequested.
      protected EnumSyntax[] MediaSizeName.getEnumValueTable()
      Returns the enumeration value table for class MediaSizeName.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r


Uses of Class javax.print.attribute.HashAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.HashAttributeSet

  • Packages that use HashAttributeSet
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.

    • Uses of HashAttributeSet in javax.print.attribute

      Subclasses of HashAttributeSet in javax.print.attribute
      修饰符与类型 类与描述
      class  HashDocAttributeSet
      Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
      class  HashPrintJobAttributeSet
      Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
      class  HashPrintRequestAttributeSet
      Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
      class  HashPrintServiceAttributeSet
      Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tvrsateoJbbbd.nnatisdaa/r


Uses of Class javax.print.attribute.HashDocAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.HashDocAttributeSet

No usage of javax.print.attribute.HashDocAttributeSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/ot/trdt>>> >eettir<


Uses of Class javax.print.attribute.HashPrintJobAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.HashPrintJobAttributeSet

No usage of javax.print.attribute.HashPrintJobAttributeSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d lea>oee")tra/t


Uses of Class javax.print.attribute.HashPrintRequestAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.HashPrintRequestAttributeSet

No usage of javax.print.attribute.HashPrintRequestAttributeSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>//nFcsx"c/.el.>s


Uses of Class javax.print.attribute.HashPrintServiceAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.HashPrintServiceAttributeSet

No usage of javax.print.attribute.HashPrintServiceAttributeSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rg瑃攕T"`ex/$.&


Uses of Class javax.print.attribute.IntegerSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.IntegerSyntax

  • Packages that use IntegerSyntax
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of IntegerSyntax in javax.print.attribute

      Methods in javax.print.attribute with parameters of type IntegerSyntax
      修饰符与类型 方法与描述
      boolean SetOfIntegerSyntax.contains(IntegerSyntax attribute)
      Determine if this set-of-integer attribute contains the given integer attribute's value.

    • Uses of IntegerSyntax in javax.print.attribute.standard

      Subclasses of IntegerSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  Copies
      Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
      class  JobImpressions
      Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted.
      class  JobImpressionsCompleted
      Class JobImpressionsCompleted is an integer valued printing attribute class that specifies the number of impressions completed for the job so far.
      class  JobKOctets
      Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job.
      class  JobKOctetsProcessed
      Class JobKOctetsProcessed is an integer valued printing attribute class that specifies the total number of print data octets processed so far in K octets, i.e., in units of 1024 octets.
      class  JobMediaSheets
      Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.
      class  JobMediaSheetsCompleted
      Class JobMediaSheetsCompleted is an integer valued printing attribute class that specifies the number of media sheets which have completed marking and stacking for the entire job so far, whether those sheets have been processed on one side or on both.
      class  JobPriority
      Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.
      class  JobPrioritySupported
      Class JobPrioritySupported is an integer valued printing attribute class that specifies whether a Print Service instance supports the JobPriority attribute and the number of different job priority levels supported.
      class  NumberOfDocuments
      Class NumberOfDocuments is an integer valued printing attribute that indicates the number of individual docs the printer has accepted for this job, regardless of whether the docs' print data has reached the printer or not.
      class  NumberOfInterveningJobs
      Class NumberOfInterveningJobs is an integer valued printing attribute that indicates the number of jobs that are ahead of this job in the relative chronological order of expected time to complete (i.e., the current scheduled order).
      class  NumberUp
      Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
      class  PagesPerMinute
      Class PagesPerMinute is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer (e.g., simplex, black-and-white).
      class  PagesPerMinuteColor
      Class PagesPerMinuteColor is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer when printing color (e.g., simplex, color).
      class  QueuedJobCount
      Class QueuedJobCount is an integer valued printing attribute that indicates the number of jobs in the printer whose JobState is either PENDING, PENDING_HELD, PROCESSING, or PROCESSING_STOPPED.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lr/aandydt9era<�.oavb


Uses of Class javax.print.attribute.ResolutionSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.ResolutionSyntax

  • Packages that use ResolutionSyntax
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of ResolutionSyntax in javax.print.attribute

      Methods in javax.print.attribute with parameters of type ResolutionSyntax
      修饰符与类型 方法与描述
      boolean ResolutionSyntax.lessThanOrEquals(ResolutionSyntax other)
      Determine whether this resolution attribute's value is less than or equal to the given resolution attribute's value.

    • Uses of ResolutionSyntax in javax.print.attribute.standard

      Subclasses of ResolutionSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  PrinterResolution
      Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t .jce etrrr""bb<.=


Uses of Class javax.print.attribute.SetOfIntegerSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.SetOfIntegerSyntax

  • Packages that use SetOfIntegerSyntax
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of SetOfIntegerSyntax in javax.print.attribute.standard

      Subclasses of SetOfIntegerSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  CopiesSupported
      Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute.
      class  JobImpressionsSupported
      Class JobImpressionsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobImpressions attribute.
      class  JobKOctetsSupported
      Class JobKOctetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobKOctets attribute.
      class  JobMediaSheetsSupported
      Class JobMediaSheetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobMediaSheets attribute.
      class  NumberUpSupported
      Class NumberUpSupported is a printing attribute class, a set of integers, that gives the supported values for a NumberUp attribute.
      class  PageRanges
      Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttgryncmhlelsUApo.air>t>s


Uses of Class javax.print.attribute.Size2DSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.Size2DSyntax

  • Packages that use Size2DSyntax
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Size2DSyntax in javax.print.attribute.standard

      Subclasses of Size2DSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  MediaSize
      Class MediaSize is a two-dimensional size valued printing attribute class that indicates the dimensions of the medium in a portrait orientation, with the X dimension running along the bottom edge and the Y dimension running along the left edge.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a >>


Uses of Class javax.print.attribute.TextSyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.TextSyntax

  • Packages that use TextSyntax
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of TextSyntax in javax.print.attribute.standard

      Subclasses of TextSyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  DocumentName
      Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document.
      class  JobMessageFromOperator
      Class JobMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user the reasons for modification or other management action taken on a job.
      class  JobName
      Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job.
      class  JobOriginatingUserName
      Class JobOriginatingUserName is a printing attribute class, a text attribute, that contains the name of the end user that submitted the print job.
      class  OutputDeviceAssigned
      Class OutputDeviceAssigned is a printing attribute class, a text attribute, that identifies the output device to which the service has assigned this job.
      class  PrinterInfo
      Class PrinterInfo is a printing attribute class, a text attribute, that provides descriptive information about a printer.
      class  PrinterLocation
      Class PrinterLocation is a printing attribute class, a text attribute, that identifies the location of the device.
      class  PrinterMakeAndModel
      Class PrinterMakeAndModel is a printing attribute class, a text attribute, that the make and model of the printer.
      class  PrinterMessageFromOperator
      Class PrinterMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user information about or status of the printer, such as why it is unavailable or when it is expected to be available.
      class  PrinterName
      Class PrinterName is a printing attribute class, a text attribute, that specifies the name of a printer.
      class  RequestingUserName
      Class RequestingUserName is a printing attribute class, a text attribute, that specifies the name of the end user that submitted the print job.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&.t>e.=tIo=.lm


Uses of Class javax.print.attribute.UnmodifiableSetException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.UnmodifiableSetException

No usage of javax.print.attribute.UnmodifiableSetException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"ntind stttcerr raa"


Uses of Class javax.print.attribute.URISyntax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.URISyntax

  • Packages that use URISyntax
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of URISyntax in javax.print.attribute.standard

      Subclasses of URISyntax in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  Destination
      Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
      class  PrinterMoreInfo
      Class PrinterMoreInfo is a printing attribute class, a URI, that is used to obtain more information about this specific printer.
      class  PrinterMoreInfoManufacturer
      Class PrinterMoreInfoManufacturer is a printing attribute class, a URI, that is used to obtain more information about this type of device.
      class  PrinterURI
      Class PrinterURI is a printing attribute class, a URI, that specifies the globally unique name of a printer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dcteh s dl/er= ""rl" ti�


Uses of Interface javax.print.attribute.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.Attribute

  • Packages that use Attribute
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Attribute in javax.print

      Methods in javax.print that return Attribute
      修饰符与类型 方法与描述
      Attribute[] AttributeException.getUnsupportedValues()
      Returns the array of printing attributes for which the Print Service instance supports the attribute but does not support that particular value of the attribute, or null if there are no such attribute values.
      Methods in javax.print with parameters of type Attribute
      修饰符与类型 方法与描述
      boolean PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
      Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
      Method parameters in javax.print with type arguments of type Attribute
      修饰符与类型 方法与描述
      Object PrintService.getDefaultAttributeValue(类<? extends Attribute> category)
      Determines this print service's default printing attribute value in the given category.
      Object PrintService.getSupportedAttributeValues(类<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
      Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.
      boolean PrintService.isAttributeCategorySupported(类<? extends Attribute> category)
      Determines whether a client can specify the given printing attribute category when setting up a job for this print service.

    • Uses of Attribute in javax.print.attribute

      Subinterfaces of Attribute in javax.print.attribute
      修饰符与类型 Interface and Description
      interface  DocAttribute
      Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
      interface  PrintJobAttribute
      PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job.
      interface  PrintRequestAttribute
      Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.
      interface  PrintServiceAttribute
      Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
      interface  SupportedValuesAttribute
      Interface SupportedValuesAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the supported values for another attribute.
      Methods in javax.print.attribute that return Attribute
      修饰符与类型 | 方法与描述
      Attribute HashAttributeSet.get(类<?> category)
      Returns the attribute value which this attribute set contains in the given attribute category.
      Attribute AttributeSet.get(类<?> category)
      Returns the attribute value which this attribute set contains in the given attribute category.
      Attribute[] | HashAttributeSet.toArray()
      Attribute[] AttributeSet.toArray()
      Returns an array of the attributes contained in this set.
      static Attribute AttributeSetUtilities.verifyAttributeValue(Object object, 类<?> interfaceName)
      Verify that the given object is an instance of the given interface, which is assumed to be interface Attribute or a subinterface thereof.
      Methods in javax.print.attribute that return types with arguments of type Attribute
      修饰符与类型 方法与描述
      类<? extends Attribute> Attribute.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value when it is added to an attribute set.
      Methods in javax.print.attribute with parameters of type Attribute
      修饰符与类型 方法与描述
      boolean HashAttributeSet.add(Attribute attribute)
      Adds the specified attribute to this attribute set if it is not already present, first removing any existing in the same attribute category as the specified attribute value.
      boolean DocAttributeSet.add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean PrintJobAttributeSet.add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean PrintServiceAttributeSet.add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean AttributeSet.add(Attribute attribute)
      Adds the specified attribute to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value.
      boolean PrintRequestAttributeSet.add(Attribute attribute)
      Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
      boolean HashAttributeSet.containsValue(Attribute attribute)
      Returns true if this attribute set contains the given attribute.
      boolean AttributeSet.containsValue(Attribute attribute)
      Returns true if this attribute set contains the given attribute value.
      boolean HashAttributeSet.remove(Attribute attribute)
      Removes the specified attribute from this attribute set if present.
      boolean AttributeSet.remove(Attribute attribute)
      Removes the specified attribute from this attribute set if present.
      static void AttributeSetUtilities.verifyCategoryForValue(类<?> category, Attribute attribute)
      Verify that the given attribute category object is equal to the category of the given attribute value object.
      Constructors in javax.print.attribute with parameters of type Attribute
      构造方法与描述
      HashAttributeSet(Attribute attribute)
      Construct a new attribute set, initially populated with the given attribute.
      HashAttributeSet(Attribute[] attributes)
      Construct a new attribute set, initially populated with the values from the given array.
      HashAttributeSet(Attribute[] attributes, 类<?> interfaceName)
      Construct a new attribute set, where the members of the attribute set are restricted to the given interface.
      HashAttributeSet(Attribute attribute, 类<?> interfaceName)
      Construct a new attribute set, initially populated with the given attribute, where the members of the attribute set are restricted to the given interface.

    • Uses of Attribute in javax.print.attribute.standard

      Methods in javax.print.attribute.standard that return types with arguments of type Attribute
      修饰符与类型 方法与描述
      类<? extends Attribute> SheetCollate.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Sides.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> RequestingUserName.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> ReferenceUriSchemesSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> QueuedJobCount.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterURI.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Severity.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterStateReasons.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterStateReason.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterState.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterResolution.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterName.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterMoreInfoManufacturer.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterMoreInfo.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterMessageFromOperator.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterMakeAndModel.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterLocation.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterIsAcceptingJobs.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrinterInfo.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PrintQuality.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PresentationDirection.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PagesPerMinuteColor.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PagesPerMinute.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PageRanges.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> PDLOverrideSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> OutputDeviceAssigned.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> NumberUpSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> NumberUp.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> NumberOfInterveningJobs.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> NumberOfDocuments.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> MultipleDocumentHandling.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobStateReasons.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobStateReason.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobState.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobSheets.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobPrioritySupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobPriority.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobOriginatingUserName.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobMessageFromOperator.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobMediaSheetsSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobMediaSheetsCompleted.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobName.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobMediaSheets.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobKOctetsSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobKOctetsProcessed.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobKOctets.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobImpressionsSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobImpressionsCompleted.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobImpressions.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> JobHoldUntil.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Finishings.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Fidelity.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> DocumentName.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Destination.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> DateTimeAtProcessing.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> DateTimeAtCreation.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> DateTimeAtCompleted.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> CopiesSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Copies.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Compression.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> ColorSupported.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Chromaticity.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> OrientationRequested.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> MediaSize.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> MediaPrintableArea.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      类<? extends Attribute> Media.getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.print.attribute.AttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.AttributeSet

  • Packages that use AttributeSet
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.

    • Uses of AttributeSet in javax.print

      Methods in javax.print that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
      Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.
      Methods in javax.print with parameters of type AttributeSet
      修饰符与类型 方法与描述
      abstract MultiDocPrintService[] PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Not called directly by applications.
      abstract PrintService[] PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.
      Object PrintService.getSupportedAttributeValues(类<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
      Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.
      AttributeSet PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
      Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.
      boolean PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
      Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
      static MultiDocPrintService[] PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.
      static PrintService[] PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates print services capable of printing the specified DocFlavor.

    • Uses of AttributeSet in javax.print.attribute

      Subinterfaces of AttributeSet in javax.print.attribute
      修饰符与类型 Interface and Description
      interface  DocAttributeSet
      Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
      interface  PrintJobAttributeSet
      Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
      interface  PrintRequestAttributeSet
      Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
      interface  PrintServiceAttributeSet
      Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
      Classes in javax.print.attribute that implement AttributeSet
      修饰符与类型 类与描述
      class  HashAttributeSet
      Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.
      class  HashDocAttributeSet
      Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
      class  HashPrintJobAttributeSet
      Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
      class  HashPrintRequestAttributeSet
      Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
      class  HashPrintServiceAttributeSet
      Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
      Methods in javax.print.attribute that return AttributeSet
      修饰符与类型 方法与描述
      static AttributeSet AttributeSetUtilities.synchronizedView(AttributeSet attributeSet)
      Creates a synchronized view of the given attribute set.
      static AttributeSet AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet)
      Creates an unmodifiable view of the given attribute set.
      Methods in javax.print.attribute with parameters of type AttributeSet
      修饰符与类型 方法与描述
      boolean HashAttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      boolean DocAttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      boolean PrintJobAttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      boolean PrintServiceAttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      boolean AttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      boolean PrintRequestAttributeSet.addAll(AttributeSet attributes)
      Adds all of the elements in the specified set to this attribute.
      static AttributeSet AttributeSetUtilities.synchronizedView(AttributeSet attributeSet)
      Creates a synchronized view of the given attribute set.
      static AttributeSet AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet)
      Creates an unmodifiable view of the given attribute set.
      Constructors in javax.print.attribute with parameters of type AttributeSet
      构造方法与描述
      HashAttributeSet(AttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set.
      HashAttributeSet(AttributeSet attributes, 类<?> interfaceName)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the given interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i bit/ap/rrrv.hhvtasna&s=eu


Uses of Interface javax.print.attribute.DocAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.DocAttribute

  • Packages that use DocAttribute
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of DocAttribute in javax.print.attribute

      Constructors in javax.print.attribute with parameters of type DocAttribute
      构造方法与描述
      HashDocAttributeSet(DocAttribute attribute)
      Construct a new hash doc attribute set, initially populated with the given value.
      HashDocAttributeSet(DocAttribute[] attributes)
      Construct a new hash doc attribute set, initially populated with the values from the given array.

    • Uses of DocAttribute in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement DocAttribute
      修饰符与类型 类与描述
      class  Chromaticity
      Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
      class  Compression
      Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
      class  DocumentName
      Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document.
      class  Finishings
      Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
      class  Media
      Class Media is a printing attribute class that specifies the medium on which to print.
      class  MediaName
      Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
      class  MediaPrintableArea
      Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.
      class  MediaSizeName
      Class MediaSizeName is a subclass of Media.
      class  MediaTray
      Class MediaTray is a subclass of Media.
      class  NumberUp
      Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
      class  OrientationRequested
      Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
      class  PageRanges
      Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
      class  PrinterResolution
      Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
      class  PrintQuality
      Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
      class  SheetCollate
      Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
      class  Sides
      Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ihttt n< <=teia sh


Uses of Interface javax.print.attribute.DocAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.DocAttributeSet

  • Packages that use DocAttributeSet
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.

    • Uses of DocAttributeSet in javax.print

      Methods in javax.print that return DocAttributeSet
      修饰符与类型 方法与描述
      DocAttributeSet SimpleDoc.getAttributes()
      Obtains the set of printing attributes for this doc object.
      DocAttributeSet Doc.getAttributes()
      Obtains the set of printing attributes for this doc object.
      Constructors in javax.print with parameters of type DocAttributeSet
      构造方法与描述
      SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
      Constructs a SimpleDoc with the specified print data, doc flavor and doc attribute set.

    • Uses of DocAttributeSet in javax.print.attribute

      Classes in javax.print.attribute that implement DocAttributeSet
      修饰符与类型 类与描述
      class  HashDocAttributeSet
      Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
      Methods in javax.print.attribute that return DocAttributeSet
      修饰符与类型 方法与描述
      static DocAttributeSet AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet)
      Creates a synchronized view of the given doc attribute set.
      static DocAttributeSet AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet)
      Creates an unmodifiable view of the given doc attribute set.
      Methods in javax.print.attribute with parameters of type DocAttributeSet
      修饰符与类型 方法与描述
      static DocAttributeSet AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet)
      Creates a synchronized view of the given doc attribute set.
      static DocAttributeSet AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet)
      Creates an unmodifiable view of the given doc attribute set.
      Constructors in javax.print.attribute with parameters of type DocAttributeSet
      构造方法与描述
      HashDocAttributeSet(DocAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the DocAttribute interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,a rwknkrrusnrn>的<更虾悯


Uses of Interface javax.print.attribute.PrintJobAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintJobAttribute

  • Packages that use PrintJobAttribute
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrintJobAttribute in javax.print.attribute

      Constructors in javax.print.attribute with parameters of type PrintJobAttribute
      构造方法与描述
      HashPrintJobAttributeSet(PrintJobAttribute attribute)
      Construct a new hash print job attribute set, initially populated with the given value.
      HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
      Construct a new hash print job attribute set, initially populated with the values from the given array.

    • Uses of PrintJobAttribute in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement PrintJobAttribute
      修饰符与类型 类与描述
      class  Chromaticity
      Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
      class  Copies
      Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
      class  DateTimeAtCompleted
      Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).
      class  DateTimeAtCreation
      Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.
      class  DateTimeAtProcessing
      Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.
      class  Destination
      Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
      class  Fidelity
      Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
      class  Finishings
      Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
      class  JobHoldUntil
      Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.
      class  JobImpressions
      Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted.
      class  JobImpressionsCompleted
      Class JobImpressionsCompleted is an integer valued printing attribute class that specifies the number of impressions completed for the job so far.
      class  JobKOctets
      Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job.
      class  JobKOctetsProcessed
      Class JobKOctetsProcessed is an integer valued printing attribute class that specifies the total number of print data octets processed so far in K octets, i.e., in units of 1024 octets.
      class  JobMediaSheets
      Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.
      class  JobMediaSheetsCompleted
      Class JobMediaSheetsCompleted is an integer valued printing attribute class that specifies the number of media sheets which have completed marking and stacking for the entire job so far, whether those sheets have been processed on one side or on both.
      class  JobMessageFromOperator
      Class JobMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user the reasons for modification or other management action taken on a job.
      class  JobName
      Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job.
      class  JobOriginatingUserName
      Class JobOriginatingUserName is a printing attribute class, a text attribute, that contains the name of the end user that submitted the print job.
      class  JobPriority
      Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.
      class  JobSheets
      Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
      class  JobState
      JobState is a printing attribute class, an enumeration, that identifies the current state of a print job.
      class  JobStateReasons
      Class JobStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
      class  Media
      Class Media is a printing attribute class that specifies the medium on which to print.
      class  MediaName
      Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
      class  MediaPrintableArea
      Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.
      class  MediaSizeName
      Class MediaSizeName is a subclass of Media.
      class  MediaTray
      Class MediaTray is a subclass of Media.
      class  MultipleDocumentHandling
      Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
      class  NumberOfDocuments
      Class NumberOfDocuments is an integer valued printing attribute that indicates the number of individual docs the printer has accepted for this job, regardless of whether the docs' print data has reached the printer or not.
      class  NumberOfInterveningJobs
      Class NumberOfInterveningJobs is an integer valued printing attribute that indicates the number of jobs that are ahead of this job in the relative chronological order of expected time to complete (i.e., the current scheduled order).
      class  NumberUp
      Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
      class  OrientationRequested
      Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
      class  OutputDeviceAssigned
      Class OutputDeviceAssigned is a printing attribute class, a text attribute, that identifies the output device to which the service has assigned this job.
      class  PageRanges
      Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
      class  PresentationDirection
      Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
      class  PrinterResolution
      Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
      class  PrintQuality
      Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
      class  SheetCollate
      Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
      class  Sides
      Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rn nioaivg


Uses of Interface javax.print.attribute.PrintJobAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintJobAttributeSet

  • Packages that use PrintJobAttributeSet
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintJobAttributeSet in javax.print

      Methods in javax.print that return PrintJobAttributeSet
      修饰符与类型 方法与描述
      PrintJobAttributeSet DocPrintJob.getAttributes()
      Obtains this Print Job's set of printing attributes.
      Methods in javax.print with parameters of type PrintJobAttributeSet
      修饰符与类型 方法与描述
      void DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes)
      Registers a listener for changes in the specified attributes.

    • Uses of PrintJobAttributeSet in javax.print.attribute

      Classes in javax.print.attribute that implement PrintJobAttributeSet
      修饰符与类型 类与描述
      class  HashPrintJobAttributeSet
      Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
      Methods in javax.print.attribute that return PrintJobAttributeSet
      修饰符与类型 方法与描述
      static PrintJobAttributeSet AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet)
      Creates a synchronized view of the given print job attribute set.
      static PrintJobAttributeSet AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet)
      Creates an unmodifiable view of the given print job attribute set.
      Methods in javax.print.attribute with parameters of type PrintJobAttributeSet
      修饰符与类型 方法与描述
      static PrintJobAttributeSet AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet)
      Creates a synchronized view of the given print job attribute set.
      static PrintJobAttributeSet AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet)
      Creates an unmodifiable view of the given print job attribute set.
      Constructors in javax.print.attribute with parameters of type PrintJobAttributeSet
      构造方法与描述
      HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintJobAttribute interface.

    • Uses of PrintJobAttributeSet in javax.print.event

      Methods in javax.print.event that return PrintJobAttributeSet
      修饰符与类型 方法与描述
      PrintJobAttributeSet PrintJobAttributeEvent.getAttributes()
      Determine the printing attributes that changed and their new values.
      Constructors in javax.print.event with parameters of type PrintJobAttributeSet
      构造方法与描述
      PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
      Constructs a PrintJobAttributeEvent object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ds e;


Uses of Interface javax.print.attribute.PrintRequestAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintRequestAttribute

  • Packages that use PrintRequestAttribute
    软件包 描述
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrintRequestAttribute in javax.print.attribute

      Constructors in javax.print.attribute with parameters of type PrintRequestAttribute
      构造方法与描述
      HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
      Construct a new print request attribute set, initially populated with the given value.
      HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
      Construct a new print request attribute set, initially populated with the values from the given array.

    • Uses of PrintRequestAttribute in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement PrintRequestAttribute
      修饰符与类型 类与描述
      class  Chromaticity
      Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
      class  Copies
      Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
      class  Destination
      Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
      class  DialogTypeSelection
      Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
      class  Fidelity
      Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
      class  Finishings
      Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
      class  JobHoldUntil
      Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.
      class  JobImpressions
      Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted.
      class  JobKOctets
      Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job.
      class  JobMediaSheets
      Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.
      class  JobName
      Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job.
      class  JobPriority
      Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.
      class  JobSheets
      Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
      class  Media
      Class Media is a printing attribute class that specifies the medium on which to print.
      class  MediaName
      Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
      class  MediaPrintableArea
      Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.
      class  MediaSizeName
      Class MediaSizeName is a subclass of Media.
      class  MediaTray
      Class MediaTray is a subclass of Media.
      class  MultipleDocumentHandling
      Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
      class  NumberUp
      Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
      class  OrientationRequested
      Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
      class  PageRanges
      Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
      class  PresentationDirection
      Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
      class  PrinterResolution
      Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
      class  PrintQuality
      Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
      class  RequestingUserName
      Class RequestingUserName is a printing attribute class, a text attribute, that specifies the name of the end user that submitted the print job.
      class  SheetCollate
      Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
      class  Sides
      Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

enae">> art/o


Uses of Interface javax.print.attribute.PrintRequestAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintRequestAttributeSet

  • Packages that use PrintRequestAttributeSet
    软件包 描述
    java.awt.print
    Provides classes and interfaces for a general printing API.
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of PrintRequestAttributeSet in java.awt.print

      Methods in java.awt.print with parameters of type PrintRequestAttributeSet
      修饰符与类型 方法与描述
      PageFormat PrinterJob.getPageFormat(PrintRequestAttributeSet attributes)
      Calculates a PageFormat with values consistent with those supported by the current PrintService for this job (ie the value returned by getPrintService()) and media, printable area and orientation contained in attributes.
      PageFormat PrinterJob.pageDialog(PrintRequestAttributeSet attributes)
      A convenience method which displays a cross-platform page setup dialog.
      void PrinterJob.print(PrintRequestAttributeSet attributes)
      Prints a set of pages using the settings in the attribute set.
      boolean PrinterJob.printDialog(PrintRequestAttributeSet attributes)
      A convenience method which displays a cross-platform print dialog for all services which are capable of printing 2D graphics using the Pageable interface.

    • Uses of PrintRequestAttributeSet in javax.print

      Methods in javax.print with parameters of type PrintRequestAttributeSet
      修饰符与类型 方法与描述
      void DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes)
      Prints a document with the specified job attributes.
      void MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
      Print a MultiDoc with the specified job attributes.
      static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).

    • Uses of PrintRequestAttributeSet in javax.print.attribute

      Classes in javax.print.attribute that implement PrintRequestAttributeSet
      修饰符与类型 类与描述
      class  HashPrintRequestAttributeSet
      Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
      Methods in javax.print.attribute that return PrintRequestAttributeSet
      修饰符与类型 方法与描述
      static PrintRequestAttributeSet AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet)
      Creates a synchronized view of the given print request attribute set.
      static PrintRequestAttributeSet AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet)
      Creates an unmodifiable view of the given print request attribute set.
      Methods in javax.print.attribute with parameters of type PrintRequestAttributeSet
      修饰符与类型 方法与描述
      static PrintRequestAttributeSet AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet)
      Creates a synchronized view of the given print request attribute set.
      static PrintRequestAttributeSet AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet)
      Creates an unmodifiable view of the given print request attribute set.
      Constructors in javax.print.attribute with parameters of type PrintRequestAttributeSet
      构造方法与描述
      HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the (PrintRequestAttributeSe interface.

    • Uses of PrintRequestAttributeSet in javax.swing

      Methods in javax.swing with parameters of type PrintRequestAttributeSet
      修饰符与类型 方法与描述
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      Prints this table, as specified by the fully featured print method, with the default printer specified as the print service.
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      Prints this JTable.

    • Uses of PrintRequestAttributeSet in javax.swing.text

      Methods in javax.swing.text with parameters of type PrintRequestAttributeSet
      修饰符与类型 方法与描述
      boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
      Prints the content of this JTextComponent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sn-c.lslacaec.rr/eebht.thCP


Uses of Interface javax.print.attribute.PrintServiceAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintServiceAttribute

  • Packages that use PrintServiceAttribute
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrintServiceAttribute in javax.print

      Methods in javax.print with type parameters of type PrintServiceAttribute
      修饰符与类型 方法与描述
      <T extends PrintServiceAttribute>
      T             		PrintService.getAttribute(类<T> category)
      Gets the value of the single specified service attribute.

    • Uses of PrintServiceAttribute in javax.print.attribute

      Constructors in javax.print.attribute with parameters of type PrintServiceAttribute
      构造方法与描述
      HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
      Construct a new hash print service attribute set, initially populated with the given value.
      HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
      Construct a new print service attribute set, initially populated with the values from the given array.

    • Uses of PrintServiceAttribute in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement PrintServiceAttribute
      修饰符与类型 类与描述
      class  ColorSupported
      Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
      class  PagesPerMinute
      Class PagesPerMinute is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer (e.g., simplex, black-and-white).
      class  PagesPerMinuteColor
      Class PagesPerMinuteColor is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer when printing color (e.g., simplex, color).
      class  PDLOverrideSupported
      Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.
      class  PrinterInfo
      Class PrinterInfo is a printing attribute class, a text attribute, that provides descriptive information about a printer.
      class  PrinterIsAcceptingJobs
      Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs.
      class  PrinterLocation
      Class PrinterLocation is a printing attribute class, a text attribute, that identifies the location of the device.
      class  PrinterMakeAndModel
      Class PrinterMakeAndModel is a printing attribute class, a text attribute, that the make and model of the printer.
      class  PrinterMessageFromOperator
      Class PrinterMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user information about or status of the printer, such as why it is unavailable or when it is expected to be available.
      class  PrinterMoreInfo
      Class PrinterMoreInfo is a printing attribute class, a URI, that is used to obtain more information about this specific printer.
      class  PrinterMoreInfoManufacturer
      Class PrinterMoreInfoManufacturer is a printing attribute class, a URI, that is used to obtain more information about this type of device.
      class  PrinterName
      Class PrinterName is a printing attribute class, a text attribute, that specifies the name of a printer.
      class  PrinterState
      Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer.
      class  PrinterStateReasons
      Class PrinterStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
      class  PrinterURI
      Class PrinterURI is a printing attribute class, a URI, that specifies the globally unique name of a printer.
      class  QueuedJobCount
      Class QueuedJobCount is an integer valued printing attribute that indicates the number of jobs in the printer whose JobState is either PENDING, PENDING_HELD, PROCESSING, or PROCESSING_STOPPED.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.cll" .thhheAPPsoax.atbi/v


Uses of Interface javax.print.attribute.PrintServiceAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.PrintServiceAttributeSet

  • Packages that use PrintServiceAttributeSet
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.attribute
    Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintServiceAttributeSet in javax.print

      Methods in javax.print that return PrintServiceAttributeSet
      修饰符与类型 方法与描述
      PrintServiceAttributeSet PrintService.getAttributes()
      Obtains this print service's set of printer description attributes giving this Print Service's status.

    • Uses of PrintServiceAttributeSet in javax.print.attribute

      Classes in javax.print.attribute that implement PrintServiceAttributeSet
      修饰符与类型 类与描述
      class  HashPrintServiceAttributeSet
      Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
      Methods in javax.print.attribute that return PrintServiceAttributeSet
      修饰符与类型 方法与描述
      static PrintServiceAttributeSet AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet)
      Creates a synchronized view of the given print service attribute set.
      static PrintServiceAttributeSet AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet)
      Creates an unmodifiable view of the given print service attribute set.
      Methods in javax.print.attribute with parameters of type PrintServiceAttributeSet
      修饰符与类型 方法与描述
      static PrintServiceAttributeSet AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet)
      Creates a synchronized view of the given print service attribute set.
      static PrintServiceAttributeSet AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet)
      Creates an unmodifiable view of the given print service attribute set.
      Constructors in javax.print.attribute with parameters of type PrintServiceAttributeSet
      构造方法与描述
      HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
      Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintServiceAttribute interface.

    • Uses of PrintServiceAttributeSet in javax.print.event

      Methods in javax.print.event that return PrintServiceAttributeSet
      修饰符与类型 方法与描述
      PrintServiceAttributeSet PrintServiceAttributeEvent.getAttributes()
      Determine the printing service attributes that changed and their new values.
      Constructors in javax.print.event with parameters of type PrintServiceAttributeSet
      构造方法与描述
      PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
      Constructs a PrintServiceAttributeEvent object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/triScStrrristta/ibau a v<


Uses of Interface javax.print.attribute.SupportedValuesAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.attribute.SupportedValuesAttribute

  • Packages that use SupportedValuesAttribute
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of SupportedValuesAttribute in javax.print.attribute.standard

      Classes in javax.print.attribute.standard that implement SupportedValuesAttribute
      修饰符与类型 类与描述
      class  CopiesSupported
      Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute.
      class  JobImpressionsSupported
      Class JobImpressionsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobImpressions attribute.
      class  JobKOctetsSupported
      Class JobKOctetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobKOctets attribute.
      class  JobMediaSheetsSupported
      Class JobMediaSheetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobMediaSheets attribute.
      class  JobPrioritySupported
      Class JobPrioritySupported is an integer valued printing attribute class that specifies whether a Print Service instance supports the JobPriority attribute and the number of different job priority levels supported.
      class  NumberUpSupported
      Class NumberUpSupported is a printing attribute class, a set of integers, that gives the supported values for a NumberUp attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n azedrrlc/ya=uc eadO#bj


Chromaticity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Chromaticity

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Chromaticity
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class Chromaticity
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing. This is used by a print client to specify how the print data should be generated or processed. It is not descriptive of the color capabilities of the device. Query the service's ColorSupported attribute to determine if the device can be verified to support color printing.

    The table below shows the effects of specifying a Chromaticity attribute of MONOCHROME or COLOR for a monochrome or color document.

    Chromaticity
    Attribute     		Effect on
    Monochrome Document     		Effect on
    Color Document
    MONOCHROME | Printed as is, in monochrome | Printed in monochrome, with colors converted to shades of gray
    COLOR | Printed as is, in monochrome | Printed as is, in color

    IPP Compatibility: Chromaticity is not an IPP attribute at present.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Chromaticity COLOR
      Color printing.
      static Chromaticity MONOCHROME
      Monochrome printing.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Chromaticity(int value)
      Construct a new chromaticity enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Chromaticity.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class Chromaticity.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MONOCHROME

        public static final Chromaticity MONOCHROME
        Monochrome printing.

      • COLOR

        public static final Chromaticity COLOR
        Color printing.

    • 构造方法详细信息

      • Chromaticity

        protected Chromaticity(int value)
        Construct a new chromaticity enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Chromaticity.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Chromaticity.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Chromaticity, the category is the class Chromaticity itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Chromaticity, the category name is "chromaticity".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aee&&ono 1


ColorSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 ColorSupported

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.ColorSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class ColorSupported
extends EnumSyntax
implements PrintServiceAttribute
    Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color. All document instructions having to do with color are embedded within the print data (none are attributes attached to the job outside the print data).

    Note: End users are able to determine the nature and details of the color support by querying the PrinterMoreInfoManufacturer attribute.

    Don't confuse the ColorSupported attribute with the Chromaticity attribute. Chromaticity is an attribute the client can specify for a job to tell the printer whether to print a document in monochrome or color, possibly causing the printer to print a color document in monochrome. ColorSupported is a printer description attribute that tells whether the printer can print in color regardless of how the client specifies to print any particular document.

    IPP Compatibility: The IPP boolean value is "true" for SUPPORTED and "false" for NOT_SUPPORTED. The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static ColorSupported NOT_SUPPORTED
      The printer is not capable of any type of color printing.
      static ColorSupported SUPPORTED
      The printer is capable of some type of color printing, such as highlight color or full process color.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ColorSupported(int value)
      Construct a new color supported enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class ColorSupported.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class ColorSupported.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NOT_SUPPORTED

        public static final ColorSupported NOT_SUPPORTED
        The printer is not capable of any type of color printing.

      • SUPPORTED

        public static final ColorSupported SUPPORTED
        The printer is capable of some type of color printing, such as highlight color or full process color.

    • 构造方法详细信息

      • ColorSupported

        protected ColorSupported(int value)
        Construct a new color supported enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class ColorSupported.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class ColorSupported.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class ColorSupported, the category is class ColorSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class ColorSupported, the category name is "color-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sc� bi iE.t=hx襤ah<.t.. f 蝏衟b糽v/ hvi


Compression

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Compression

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Compression
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute

    public class Compression
extends EnumSyntax
implements DocAttribute
    Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed. Compression is an attribute of the print data (the doc), not of the Print Job. If a Compression attribute is not specified for a doc, the printer assumes the doc's print data is uncompressed (i.e., the default Compression value is always NONE).

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Compression COMPRESS
      UNIX compression technology.
      static Compression DEFLATE
      ZIP public domain inflate/deflate compression technology.
      static Compression GZIP
      GNU zip compression technology described in RFC 1952.
      static Compression NONE
      No compression is used.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Compression(int value)
      Construct a new compression enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Compression.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class Compression.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final Compression NONE
        No compression is used.

      • DEFLATE

        public static final Compression DEFLATE
        ZIP public domain inflate/deflate compression technology.

      • GZIP

        public static final Compression GZIP
        GNU zip compression technology described in RFC 1952.

      • COMPRESS

        public static final Compression COMPRESS
        UNIX compression technology.

    • 构造方法详细信息

      • Compression

        protected Compression(int value)
        Construct a new compression enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Compression.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Compression.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Compression and any vendor-defined subclasses, the category is class Compression itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Compression and any vendor-defined subclasses, the category name is "compression".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.B�> f/fsga =


Copies

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Copies

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.Copies
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class Copies
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.

    On many devices the supported number of collated copies will be limited by the number of physical output bins on the device, and may be different from the number of uncollated copies which can be supported.

    The effect of a Copies attribute with a value of 上一个 on a multidoc print job (a job with multiple documents) depends on the (perhaps defaulted) value of the MultipleDocumentHandling attribute:

    • SINGLE_DOCUMENT -- The result will be 上一个 copies of a single output document comprising all the input docs.

    • SINGLE_DOCUMENT_NEW_SHEET -- The result will be 上一个 copies of a single output document comprising all the input docs, and the first impression of each input doc will always start on a new media sheet.

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- The result will be 上一个 copies of the first input document, followed by 上一个 copies of the second input document, . . . followed by 上一个 copies of the last input document.

    • SEPARATE_DOCUMENTS_COLLATED_COPIES -- The result will be the first input document, the second input document, . . . the last input document, the group of documents being repeated 上一个 times.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Copies(int value)
      Construct a new copies attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this copies attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Copies

        public Copies(int value)
        Construct a new copies attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this copies attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class Copies.
        3. This copies attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this copies attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Copies, the category is class Copies itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Copies, the category name is "copies".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fh cftm tmaeemaatcvvrnlSh..tnanignaaSn. nNga f


CopiesSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 CopiesSupported

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.CopiesSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class CopiesSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute
    Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute. It is restricted to a single contiguous range of integers; multiple non-overlapping ranges are not allowed.

    IPP Compatibility: The CopiesSupported attribute's canonical array form gives the lower and upper bound for the range of copies to be included in an IPP "copies-supported" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CopiesSupported(int member)
      Construct a new copies supported attribute containing a single integer.
      CopiesSupported(int lowerBound, int upperBound)
      Construct a new copies supported attribute containing a single range of integers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this copies supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CopiesSupported

        public CopiesSupported(int member)
        Construct a new copies supported attribute containing a single integer. That is, only the one value of Copies is supported.
        参数：
        member - Set member.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if member is less than 1.

      • CopiesSupported

        public CopiesSupported(int lowerBound,
               int upperBound)
        Construct a new copies supported attribute containing a single range of integers. That is, only those values of Copies in the one range are supported.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this copies supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class CopiesSupported.
        3. This copies supported attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this copies supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class CopiesSupported, the category is class CopiesSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class CopiesSupported, the category name is "copies-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

amg=ah hla ""i>"a .


DateTimeAtCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 DateTimeAtCompleted

  • java.lang.Object
    • javax.print.attribute.DateTimeSyntax
      • javax.print.attribute.standard.DateTimeAtCompleted
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class DateTimeAtCompleted
extends DateTimeSyntax
implements PrintJobAttribute
    Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).

    To construct a DateTimeAtCompleted attribute from separate values of the year, month, day, hour, minute, and so on, use a Calendar object to construct a Date object, then use the Date object to construct the DateTimeAtCompleted attribute. To convert a DateTimeAtCompleted attribute to separate values of the year, month, day, hour, minute, and so on, create a Calendar object and set it to the Date from the DateTimeAtCompleted attribute.

    IPP Compatibility: The information needed to construct an IPP "date-time-at-completed" attribute can be obtained as described above. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DateTimeAtCompleted(Date dateTime)
      Construct a new date-time at completed attribute with the given Date value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this date-time at completed attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.DateTimeSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DateTimeAtCompleted

        public DateTimeAtCompleted(Date dateTime)
        Construct a new date-time at completed attribute with the given Date value.
        参数：
        dateTime - Date value.
        抛出：
        NullPointerException - (unchecked exception) Thrown if dateTime is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this date-time at completed attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class DateTimeAtCompleted.
        3. This date-time at completed attribute's Date value and object's Date value are equal.
        重载：
        equals in class DateTimeSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this date-time at completed attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class DateTimeAtCompleted, the category is class DateTimeAtCompleted itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class DateTimeAtCompleted, the category name is "date-time-at-completed".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f.urar=""az hhtaabu/t/erg>


DateTimeAtCreation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 DateTimeAtCreation

  • java.lang.Object
    • javax.print.attribute.DateTimeSyntax
      • javax.print.attribute.standard.DateTimeAtCreation
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class DateTimeAtCreation
extends DateTimeSyntax
implements PrintJobAttribute
    Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.

    To construct a DateTimeAtCreation attribute from separate values of the year, month, day, hour, minute, and so on, use a Calendar object to construct a Date object, then use the Date object to construct the DateTimeAtCreation attribute. To convert a DateTimeAtCreation attribute to separate values of the year, month, day, hour, minute, and so on, create a Calendar object and set it to the Date from the DateTimeAtCreation attribute.

    IPP Compatibility: The information needed to construct an IPP "date-time-at-creation" attribute can be obtained as described above. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DateTimeAtCreation(Date dateTime)
      Construct a new date-time at creation attribute with the given Date value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this date-time at creation attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.DateTimeSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DateTimeAtCreation

        public DateTimeAtCreation(Date dateTime)
        Construct a new date-time at creation attribute with the given Date value.
        参数：
        dateTime - Date value.
        抛出：
        NullPointerException - (unchecked exception) Thrown if dateTime is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this date-time at creation attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class DateTimeAtCreation.
        3. This date-time at creation attribute's Date value and object's Date value are equal.
        重载：
        equals in class DateTimeSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this date-time at creation attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class DateTimeAtCreation, the category is class DateTimeAtCreation itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class DateTimeAtCreation, the category name is "date-time-at-creation".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/aba&a8ae18assgbay >pp


DateTimeAtProcessing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 DateTimeAtProcessing

  • java.lang.Object
    • javax.print.attribute.DateTimeSyntax
      • javax.print.attribute.standard.DateTimeAtProcessing
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class DateTimeAtProcessing
extends DateTimeSyntax
implements PrintJobAttribute
    Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.

    To construct a DateTimeAtProcessing attribute from separate values of the year, month, day, hour, minute, and so on, use a Calendar object to construct a Date object, then use the Date object to construct the DateTimeAtProcessing attribute. To convert a DateTimeAtProcessing attribute to separate values of the year, month, day, hour, minute, and so on, create a Calendar object and set it to the Date from the DateTimeAtProcessing attribute.

    IPP Compatibility: The information needed to construct an IPP "date-time-at-processing" attribute can be obtained as described above. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DateTimeAtProcessing(Date dateTime)
      Construct a new date-time at processing attribute with the given Date value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this date-time at processing attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.DateTimeSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DateTimeAtProcessing

        public DateTimeAtProcessing(Date dateTime)
        Construct a new date-time at processing attribute with the given Date value.
        参数：
        dateTime - Date value.
        抛出：
        NullPointerException - (unchecked exception) Thrown if dateTime is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this date-time at processing attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class DateTimeAtProcessing.
        3. This date-time at processing attribute's Date value and object's Date value are equal.
        重载：
        equals in class DateTimeSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this date-time at processing attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class DateTimeAtProcessing, the category is class DateTimeAtProcessing itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class DateTimeAtProcessing, the category name is "date-time-at-processing".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elr r r r Ieere d实礷potttrzbrseugg/bonm騡uA


Destination

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Destination

  • java.lang.Object
    • javax.print.attribute.URISyntax
      • javax.print.attribute.standard.Destination
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class Destination
extends URISyntax
implements PrintJobAttribute, PrintRequestAttribute
    Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data. Many PrintServices will not support the notion of a destination other than the printer device, and so will not support this attribute.

    A common use for this attribute will be applications which want to redirect output to a local disk file : eg."file:out.prn". Note that proper construction of "file:" scheme URI instances should be performed using the toURI() method of class File. See the documentation on that class for more information.

    If a destination URI is specified in a PrintRequest and it is not accessible for output by the PrintService, a PrintException will be thrown. The PrintException may implement URIException to provide a more specific cause.

    IPP Compatibility: Destination is not an IPP attribute.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Destination(URI uri)
      Constructs a new destination attribute with the specified URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this destination attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.URISyntax

        getURI, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Destination

        public Destination(URI uri)
        Constructs a new destination attribute with the specified URI.
        参数：
        uri - URI.
        抛出：
        NullPointerException - (unchecked exception) Thrown if uri is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this destination attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class Destination.
        3. This destination attribute's URI and object's URI are equal.
        重载：
        equals in class URISyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this destination attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Destination, the category is class Destination itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Destination, the category name is "spool-data-destination".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

# chihb


DialogTypeSelection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 DialogTypeSelection

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.DialogTypeSelection
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintRequestAttribute

    public final class DialogTypeSelection
extends EnumSyntax
implements PrintRequestAttribute
    Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options. If NATIVE is specified, then where available, a native platform dialog is displayed. If COMMON is specified, a cross-platform print dialog is displayed. This option to specify a native dialog for use with an IPP attribute set provides a standard way to reflect back of the setting and option changes made by a user to the calling application, and integrates the native dialog into the Java printing APIs. But note that some options and settings in a native dialog may not necessarily map to IPP attributes as they may be non-standard platform, or even printer specific options.

    IPP Compatibility: This is not an IPP attribute.

    从以下版本开始：
    1.7
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static DialogTypeSelection | COMMON
      static DialogTypeSelection | NATIVE

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DialogTypeSelection(int value)
      Construct a new dialog type selection enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类 getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class DialogTypeSelection.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class DialogTypeSelection.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NATIVE

        public static final DialogTypeSelection NATIVE

      • COMMON

        public static final DialogTypeSelection COMMON

    • 构造方法详细信息

      • DialogTypeSelection

        protected DialogTypeSelection(int value)
        Construct a new dialog type selection enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class DialogTypeSelection.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class DialogTypeSelection.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类 getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class DialogTypeSelection the category is class DialogTypeSelection itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class DialogTypeSelection the category name is "dialog-type-selection".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

el /n/n/r/doVrpnd/nn >i>ell=ls"/Lsicssa"t"rnaihi


DocumentName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 DocumentName

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.DocumentName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute

    public final class DocumentName
extends TextSyntax
implements DocAttribute
    Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document. DocumentName is an attribute of the print data (the doc), not of the Print Job. A document's name is an arbitrary string defined by the client. However if a JobName is not specified, the DocumentName should be used instead, which implies that supporting specification of DocumentName requires reporting of JobName and vice versa. See JobName for more information.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocumentName(String documentName, Locale locale)
      Constructs a new document name attribute with the given document name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this document name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DocumentName

        public DocumentName(String documentName,
            Locale locale)
        Constructs a new document name attribute with the given document name and locale.
        参数：
        documentName - Document name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if documentName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this document name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class DocumentName.
        3. This document name attribute's underlying string and object's underlying string are equal.
        4. This document name attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this document name attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class DocumentName, the category is class DocumentName itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class DocumentName, the category name is "document-name".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.elnliltlm "llns//N=lu >>lvLh.r/ ="=t


Fidelity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Fidelity

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Fidelity
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class Fidelity
extends EnumSyntax
implements PrintJobAttribute, PrintRequestAttribute
    Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required. If FIDELITY_TRUE is specified and a service cannot print the job exactly as specified it must reject the job. If FIDELITY_FALSE is specified a reasonable attempt to print the job is acceptable. If not supplied the default is FIDELITY_FALSE.

    IPP Compatibility: The IPP boolean value is "true" for FIDELITY_TRUE and "false" for FIDELITY_FALSE. The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value. See RFC 2911 Section 15.1 for a fuller description of the IPP fidelity attribute.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Fidelity FIDELITY_FALSE
      The printer should make reasonable attempts to print the job, even if it cannot print it exactly as specified.
      static Fidelity FIDELITY_TRUE
      The job must be printed exactly as specified.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Fidelity(int value)
      Construct a new fidelity enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Fidelity.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class Fidelity.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FIDELITY_TRUE

        public static final Fidelity FIDELITY_TRUE
        The job must be printed exactly as specified. or else rejected.

      • FIDELITY_FALSE

        public static final Fidelity FIDELITY_FALSE
        The printer should make reasonable attempts to print the job, even if it cannot print it exactly as specified.

    • 构造方法详细信息

      • Fidelity

        protected Fidelity(int value)
        Construct a new fidelity enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Fidelity.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Fidelity.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Fidelity the category is class Fidelity itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Fidelity the category name is "ipp-attribute-fidelity".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d"e>>>s>emied"t#::"en}nu o/-< r< <.


Finishings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Finishings

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Finishings
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public class Finishings
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job. For multidoc print jobs (jobs with multiple documents), the MultipleDocumentHandling attribute determines what constitutes a "copy" for purposes of finishing.

    Standard Finishings values are:

    NONE STAPLE EDGE_STITCH
    BIND SADDLE_STITCH COVER

    The following Finishings values are more specific; they indicate a corner or an edge as if the document were a portrait document:

    STAPLE_TOP_LEFT EDGE_STITCH_LEFT STAPLE_DUAL_LEFT
    STAPLE_BOTTOM_LEFT EDGE_STITCH_TOP STAPLE_DUAL_TOP
    STAPLE_TOP_RIGHT EDGE_STITCH_RIGHT STAPLE_DUAL_RIGHT
    STAPLE_BOTTOM_RIGHT EDGE_STITCH_BOTTOM STAPLE_DUAL_BOTTOM

    The STAPLE_XXX values are specified with respect to the document as if the document were a portrait document. If the document is actually a landscape or a reverse-landscape document, the client supplies the appropriate transformed value. For example, to position a staple in the upper left hand corner of a landscape document when held for reading, the client supplies the STAPLE_BOTTOM_LEFT value (since landscape is defined as a +90 degree rotation from portrait, i.e., anti-clockwise). On the other hand, to position a staple in the upper left hand corner of a reverse-landscape document when held for reading, the client supplies the STAPLE_TOP_RIGHT value (since reverse-landscape is defined as a -90 degree rotation from portrait, i.e., clockwise).

    The angle (vertical, horizontal, angled) of each staple with respect to the document depends on the implementation which may in turn depend on the value of the attribute.

    The effect of a Finishings attribute on a multidoc print job (a job with multiple documents) depends on whether all the docs have the same binding specified or whether different docs have different bindings specified, and on the (perhaps defaulted) value of the MultipleDocumentHandling attribute.

    • If all the docs have the same binding specified, then any value of MultipleDocumentHandling makes sense, and the printer's processing depends on the MultipleDocumentHandling value:
      • SINGLE_DOCUMENT -- All the input docs will be bound together as one output document with the specified binding.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be bound together as one output document with the specified binding, and the first impression of each input doc will always start on a new media sheet.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- Each input doc will be bound separately with the specified binding.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- Each input doc will be bound separately with the specified binding.

    • If different docs have different bindings specified, then only two values of MultipleDocumentHandling make sense, and the printer reports an error when the job is submitted if any other value is specified:
      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- Each input doc will be bound separately with its own specified binding.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- Each input doc will be bound separately with its own specified binding.

    IPP Compatibility: Class Finishings encapsulates some of the IPP enum values that can be included in an IPP "finishings" attribute, which is a set of enums. The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value. In IPP Finishings is a multi-value attribute, this API currently allows only one binding to be specified.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Finishings BIND
      This value indicates that a binding is to be applied to the document; the type and placement of the binding is site-defined.
      static Finishings COVER
      This value is specified when it is desired to select a non-printed (or pre-printed) cover for the document.
      static Finishings EDGE_STITCH
      Bind the document(s) with one or more staples (wire stitches) along one edge.
      static Finishings EDGE_STITCH_BOTTOM
      Bind the document(s) with one or more staples (wire stitches) along the bottom edge.
      static Finishings EDGE_STITCH_LEFT
      Bind the document(s) with one or more staples (wire stitches) along the left edge.
      static Finishings EDGE_STITCH_RIGHT
      Bind the document(s) with one or more staples (wire stitches) along the right edge.
      static Finishings EDGE_STITCH_TOP
      Bind the document(s) with one or more staples (wire stitches) along the top edge.
      static Finishings NONE
      Perform no binding.
      static Finishings SADDLE_STITCH
      Bind the document(s) with one or more staples (wire stitches) along the middle fold.
      static Finishings STAPLE
      Bind the document(s) with one or more staples.
      static Finishings STAPLE_BOTTOM_LEFT
      Bind the document(s) with one or more staples in the bottom left corner.
      static Finishings STAPLE_BOTTOM_RIGHT
      Bind the document(s) with one or more staples in the bottom right corner.
      static Finishings STAPLE_DUAL_BOTTOM
      Bind the document(s) with two staples (wire stitches) along the bottom edge assuming a portrait document (see above).
      static Finishings STAPLE_DUAL_LEFT
      Bind the document(s) with two staples (wire stitches) along the left edge assuming a portrait document (see above).
      static Finishings STAPLE_DUAL_RIGHT
      Bind the document(s) with two staples (wire stitches) along the right edge assuming a portrait document (see above).
      static Finishings STAPLE_DUAL_TOP
      Bind the document(s) with two staples (wire stitches) along the top edge assuming a portrait document (see above).
      static Finishings STAPLE_TOP_LEFT
      Bind the document(s) with one or more staples in the top left corner.
      static Finishings STAPLE_TOP_RIGHT
      Bind the document(s) with one or more staples in the top right corner.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Finishings(int value)
      Construct a new finishings binding enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Finishings.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected int getOffset()
      Returns the lowest integer value used by class Finishings.
      protected String[] getStringTable()
      Returns the string table for class Finishings.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final Finishings NONE
        Perform no binding.

      • STAPLE

        public static final Finishings STAPLE
        Bind the document(s) with one or more staples. The exact number and placement of the staples is site-defined.

      • COVER

        public static final Finishings COVER
        This value is specified when it is desired to select a non-printed (or pre-printed) cover for the document. This does not supplant the specification of a printed cover (on cover stock medium) by the document itself.

      • BIND

        public static final Finishings BIND
        This value indicates that a binding is to be applied to the document; the type and placement of the binding is site-defined.

      • SADDLE_STITCH

        public static final Finishings SADDLE_STITCH
        Bind the document(s) with one or more staples (wire stitches) along the middle fold. The exact number and placement of the staples and the middle fold is implementation- and/or site-defined.

      • EDGE_STITCH

        public static final Finishings EDGE_STITCH
        Bind the document(s) with one or more staples (wire stitches) along one edge. The exact number and placement of the staples is implementation- and/or site- defined.

      • STAPLE_TOP_LEFT

        public static final Finishings STAPLE_TOP_LEFT
        Bind the document(s) with one or more staples in the top left corner.

      • STAPLE_BOTTOM_LEFT

        public static final Finishings STAPLE_BOTTOM_LEFT
        Bind the document(s) with one or more staples in the bottom left corner.

      • STAPLE_TOP_RIGHT

        public static final Finishings STAPLE_TOP_RIGHT
        Bind the document(s) with one or more staples in the top right corner.

      • STAPLE_BOTTOM_RIGHT

        public static final Finishings STAPLE_BOTTOM_RIGHT
        Bind the document(s) with one or more staples in the bottom right corner.

      • EDGE_STITCH_LEFT

        public static final Finishings EDGE_STITCH_LEFT
        Bind the document(s) with one or more staples (wire stitches) along the left edge. The exact number and placement of the staples is implementation- and/or site-defined.

      • EDGE_STITCH_TOP

        public static final Finishings EDGE_STITCH_TOP
        Bind the document(s) with one or more staples (wire stitches) along the top edge. The exact number and placement of the staples is implementation- and/or site-defined.

      • EDGE_STITCH_RIGHT

        public static final Finishings EDGE_STITCH_RIGHT
        Bind the document(s) with one or more staples (wire stitches) along the right edge. The exact number and placement of the staples is implementation- and/or site-defined.

      • EDGE_STITCH_BOTTOM

        public static final Finishings EDGE_STITCH_BOTTOM
        Bind the document(s) with one or more staples (wire stitches) along the bottom edge. The exact number and placement of the staples is implementation- and/or site-defined.

      • STAPLE_DUAL_LEFT

        public static final Finishings STAPLE_DUAL_LEFT
        Bind the document(s) with two staples (wire stitches) along the left edge assuming a portrait document (see above).

      • STAPLE_DUAL_TOP

        public static final Finishings STAPLE_DUAL_TOP
        Bind the document(s) with two staples (wire stitches) along the top edge assuming a portrait document (see above).

      • STAPLE_DUAL_RIGHT

        public static final Finishings STAPLE_DUAL_RIGHT
        Bind the document(s) with two staples (wire stitches) along the right edge assuming a portrait document (see above).

      • STAPLE_DUAL_BOTTOM

        public static final Finishings STAPLE_DUAL_BOTTOM
        Bind the document(s) with two staples (wire stitches) along the bottom edge assuming a portrait document (see above).

    • 构造方法详细信息

      • Finishings

        protected Finishings(int value)
        Construct a new finishings binding enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Finishings.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Finishings.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by class Finishings.
        重载：
        getOffset in class EnumSyntax
        返回：
        the offset of the lowest enumeration value.

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Finishings and any vendor-defined subclasses, the category is class Finishings itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Finishings and any vendor-defined subclasses, the category name is "finishings".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.print.attribute.standard

Classes

  • Chromaticity
  • ColorSupported
  • Compression
  • Copies
  • CopiesSupported
  • DateTimeAtCompleted
  • DateTimeAtCreation
  • DateTimeAtProcessing
  • Destination
  • DialogTypeSelection
  • DocumentName
  • Fidelity
  • Finishings
  • JobHoldUntil
  • JobImpressions
  • JobImpressionsCompleted
  • JobImpressionsSupported
  • JobKOctets
  • JobKOctetsProcessed
  • JobKOctetsSupported
  • JobMediaSheets
  • JobMediaSheetsCompleted
  • JobMediaSheetsSupported
  • JobMessageFromOperator
  • JobName
  • JobOriginatingUserName
  • JobPriority
  • JobPrioritySupported
  • JobSheets
  • JobState
  • JobStateReason
  • JobStateReasons
  • Media
  • MediaName
  • MediaPrintableArea
  • MediaSize
  • MediaSize.Engineering
  • MediaSize.ISO
  • MediaSize.JIS
  • MediaSize.NA
  • MediaSize.Other
  • MediaSizeName
  • MediaTray
  • MultipleDocumentHandling
  • NumberOfDocuments
  • NumberOfInterveningJobs
  • NumberUp
  • NumberUpSupported
  • OrientationRequested
  • OutputDeviceAssigned
  • PageRanges
  • PagesPerMinute
  • PagesPerMinuteColor
  • PDLOverrideSupported
  • PresentationDirection
  • PrinterInfo
  • PrinterIsAcceptingJobs
  • PrinterLocation
  • PrinterMakeAndModel
  • PrinterMessageFromOperator
  • PrinterMoreInfo
  • PrinterMoreInfoManufacturer
  • PrinterName
  • PrinterResolution
  • PrinterState
  • PrinterStateReason
  • PrinterStateReasons
  • PrinterURI
  • PrintQuality
  • QueuedJobCount
  • ReferenceUriSchemesSupported
  • RequestingUserName
  • Severity
  • SheetCollate
  • Sides
i


javax.print.attribute.standard

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.print.attribute.standard

软件包 javax.print.attribute.standard contains classes for specific printing attributes.

请参见： 描述

  • Class Summary
    类 描述
    Chromaticity
    Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
    ColorSupported
    Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
    Compression
    Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
    Copies
    Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
    CopiesSupported
    Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute.
    DateTimeAtCompleted
    Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).
    DateTimeAtCreation
    Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.
    DateTimeAtProcessing
    Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.
    Destination
    Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
    DialogTypeSelection
    Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
    DocumentName
    Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document.
    Fidelity
    Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
    Finishings
    Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
    JobHoldUntil
    Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.
    JobImpressions
    Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted.
    JobImpressionsCompleted
    Class JobImpressionsCompleted is an integer valued printing attribute class that specifies the number of impressions completed for the job so far.
    JobImpressionsSupported
    Class JobImpressionsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobImpressions attribute.
    JobKOctets
    Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job.
    JobKOctetsProcessed
    Class JobKOctetsProcessed is an integer valued printing attribute class that specifies the total number of print data octets processed so far in K octets, i.e., in units of 1024 octets.
    JobKOctetsSupported
    Class JobKOctetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobKOctets attribute.
    JobMediaSheets
    Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.
    JobMediaSheetsCompleted
    Class JobMediaSheetsCompleted is an integer valued printing attribute class that specifies the number of media sheets which have completed marking and stacking for the entire job so far, whether those sheets have been processed on one side or on both.
    JobMediaSheetsSupported
    Class JobMediaSheetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobMediaSheets attribute.
    JobMessageFromOperator
    Class JobMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user the reasons for modification or other management action taken on a job.
    JobName
    Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job.
    JobOriginatingUserName
    Class JobOriginatingUserName is a printing attribute class, a text attribute, that contains the name of the end user that submitted the print job.
    JobPriority
    Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.
    JobPrioritySupported
    Class JobPrioritySupported is an integer valued printing attribute class that specifies whether a Print Service instance supports the JobPriority attribute and the number of different job priority levels supported.
    JobSheets
    Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
    JobState
    JobState is a printing attribute class, an enumeration, that identifies the current state of a print job.
    JobStateReason
    Class JobStateReason is a printing attribute class, an enumeration, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
    JobStateReasons
    Class JobStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
    Media
    Class Media is a printing attribute class that specifies the medium on which to print.
    MediaName
    Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
    MediaPrintableArea
    Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.
    MediaSize
    Class MediaSize is a two-dimensional size valued printing attribute class that indicates the dimensions of the medium in a portrait orientation, with the X dimension running along the bottom edge and the Y dimension running along the left edge.
    MediaSize.Engineering
    Class MediaSize.Engineering includes MediaSize values for engineering media.
    MediaSize.ISO
    Class MediaSize.ISO includes MediaSize values for ISO media.
    MediaSize.JIS
    Class MediaSize.JIS includes MediaSize values for JIS (Japanese) media.
    MediaSize.NA
    Class MediaSize.NA includes MediaSize values for North American media.
    MediaSize.Other
    Class MediaSize.Other includes MediaSize values for miscellaneous media.
    MediaSizeName
    Class MediaSizeName is a subclass of Media.
    MediaTray
    Class MediaTray is a subclass of Media.
    MultipleDocumentHandling
    Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
    NumberOfDocuments
    Class NumberOfDocuments is an integer valued printing attribute that indicates the number of individual docs the printer has accepted for this job, regardless of whether the docs' print data has reached the printer or not.
    NumberOfInterveningJobs
    Class NumberOfInterveningJobs is an integer valued printing attribute that indicates the number of jobs that are ahead of this job in the relative chronological order of expected time to complete (i.e., the current scheduled order).
    NumberUp
    Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
    NumberUpSupported
    Class NumberUpSupported is a printing attribute class, a set of integers, that gives the supported values for a NumberUp attribute.
    OrientationRequested
    Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
    OutputDeviceAssigned
    Class OutputDeviceAssigned is a printing attribute class, a text attribute, that identifies the output device to which the service has assigned this job.
    PageRanges
    Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
    PagesPerMinute
    Class PagesPerMinute is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer (e.g., simplex, black-and-white).
    PagesPerMinuteColor
    Class PagesPerMinuteColor is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer when printing color (e.g., simplex, color).
    PDLOverrideSupported
    Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.
    PresentationDirection
    Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
    PrinterInfo
    Class PrinterInfo is a printing attribute class, a text attribute, that provides descriptive information about a printer.
    PrinterIsAcceptingJobs
    Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs.
    PrinterLocation
    Class PrinterLocation is a printing attribute class, a text attribute, that identifies the location of the device.
    PrinterMakeAndModel
    Class PrinterMakeAndModel is a printing attribute class, a text attribute, that the make and model of the printer.
    PrinterMessageFromOperator
    Class PrinterMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user information about or status of the printer, such as why it is unavailable or when it is expected to be available.
    PrinterMoreInfo
    Class PrinterMoreInfo is a printing attribute class, a URI, that is used to obtain more information about this specific printer.
    PrinterMoreInfoManufacturer
    Class PrinterMoreInfoManufacturer is a printing attribute class, a URI, that is used to obtain more information about this type of device.
    PrinterName
    Class PrinterName is a printing attribute class, a text attribute, that specifies the name of a printer.
    PrinterResolution
    Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
    PrinterState
    Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer.
    PrinterStateReason
    Class PrinterStateReason is a printing attribute class, an enumeration, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
    PrinterStateReasons
    Class PrinterStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
    PrinterURI
    Class PrinterURI is a printing attribute class, a URI, that specifies the globally unique name of a printer.
    PrintQuality
    Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
    QueuedJobCount
    Class QueuedJobCount is an integer valued printing attribute that indicates the number of jobs in the printer whose JobState is either PENDING, PENDING_HELD, PROCESSING, or PROCESSING_STOPPED.
    ReferenceUriSchemesSupported
    Class ReferenceUriSchemesSupported is a printing attribute class an enumeration, that indicates a "URI scheme," such as "http:" or "ftp:", that a printer can use to retrieve print data stored at a URI location.
    RequestingUserName
    Class RequestingUserName is a printing attribute class, a text attribute, that specifies the name of the end user that submitted the print job.
    Severity
    Class Severity is a printing attribute class, an enumeration, that denotes the severity of a PrinterStateReason attribute.
    SheetCollate
    Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
    Sides
    Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.

软件包 javax.print.attribute.standard Description

软件包 javax.print.attribute.standard contains classes for specific printing attributes. The parent package, javax.print.attribute, provides classes and interfaces that describe the types of Java Print Service attributes and how they can be collected into attribute sets.

An attribute represents a printing feature that a print service can provide. For each attribute, a print service either does or does not support the attribute. For each possible value of a supported attribute, a print service either does or does not support the value.

The API requires every print service to support certain attributes; other attributes are optional and the service can choose whether or not to support them. Each attribute has a set of values that it accepts. The API requires every print service to support certain values for certain attributes; other attribute values are optional and the service can choose whether or not to support them. These support requirements are recorded in the documentation for each attribute class.

Package javax.print.attribute.standard contains standard printing attributes and standard printing attribute values that are widely used in the printing domain. A print service vendor can provide new vendor-specific printing attributes in addition to the standard ones. A vendor can also provide vendor-specific extensions (subclasses) of the standard printing attributes -- for example, to provide additional vendor-specific values for an existing standard attribute. Of course, if a vendor wants clients to be able to use any added or extended attributes, the vendor must publish the new attribute classes.

Many of the standard attribute classes extend one of the abstract syntax classes of the javax.print.attribute package. These abstract syntax classes each represent a different type. The EnumSyntax class, for example, represents a type-safe enumeration. The abstract syntax class provides a wrapper for the attribute value.

If an attribute class extends EnumSyntax, and the value of the attribute is an IPP-compatible value, the attribute's toString method returns the IPP string representation of the attribute value, such as "processing-stopped" for the JobState attribute. However, because the EnumSyntax class is extensible, vendors can define their own attribute values. If an attribute uses the EnumSyntax class and is set to one of these vendor-defined values then the toString method will not return the IPP string representation of the value.

A printing client application will typically not need to use all the printing attribute classes in package javax.print.attribute.standard, just the ones that pertain to the application.

The attribute classes in package javax.print.attribute.standard are based on the Internet Printing Protocol (IPP) attributes as defined in the Internet RFC document, RFC 2911 Internet Printing Protocol/1.1: Model and Semantics dated September 2000. See RFC 2911 for more information. The descriptive text for each attribute class was taken largely from the above documents. The above authors' contribution to the API is gratefully acknowledged.

Attribute Organization

There are five kinds of printing attributes: doc attributes, print request attributes, print job attributes, print service attributes, and supported-values attributes.

Doc Attributes

Doc attributes specify the characteristics of an individual doc and the print job settings to be applied to an individual doc. A doc attribute class implements interface DocAttribute. A doc attribute can appear in a DocAttributeSet.

Print Request Attributes

Print request attributes specify the settings to be applied to a whole print job and to all the docs in the print job. A print request attribute class implements interface PrintRequestAttribute. A print request attribute can appear in a PrintRequestAttributeSet.

Some attributes are doc attributes but not print request attributes and may only be specified at the doc level. Some attributes are print request attributes but not doc attributes and may only be specified at the Print Request level. Some attributes are both doc attributes and print request attributes and may be specified either at the doc level or at the Print Request level.

When specified at the doc level, an attribute applies just to that one doc. When specified at the Print Request level, an attribute applies to the whole job, including all the docs in the job. However, an attribute specified at the doc level overrides an attribute in the same category specified at the Print Request level.

Print Job Attributes

Print job attributes report the status of a Print Job. A print job attribute class implements interface PrintJobAttribute. A print job attribute can appear in a PrintJobAttributeSet.

Some attributes are both print request attributes and print job attributes; a client may include such attributes in a Print Request to specify characteristics for the ensuing Print Job, and those attributes then also appear in the Print Job's attribute set. Some attributes are print job attributes but not print request attributes; the print service itself adds these attributes to the Print Job's attribute set.

Print Service Attributes

Print service attributes report the status of a print service. A print service attribute class implements interface PrintServiceAttribute. A print service attribute can appear in a PrintServiceAttributeSet.

Supported-Values Attributes

A supported-value attribute indicates the legal values for another attribute that a print service supports. A supported-values attribute class implements interface SupportedValuesAttribute. However, supported-values attributes never appear in attribute sets, so there is no restricted AttributeSet subinterface for them.

Attribute Table

The table below lists all the printing attributes. The table shows the tagging interfaces each attribute class implements in addition to interface Attribute, thus indicating how each attribute is used in the API. For each doc attribute and print request attribute, the column marked "SupportedValuesAttribute" lists the supported-values attribute class, if any, with which a print service indicates the supported values for that attribute category.

Attribute Class | Doc Attribute | Print Request Attribute | Print Job Attribute | Print Service Attribute | SupportedValuesAttribute
Compression | X |  |  |  |
DocumentName | X |  |  |  |
Chromaticity | X | X | X |  |
Copies |  | X | X |  | CopiesSupported
Finishings | X | X | X |  |
JobHoldUntil |  | X | X |  |
JobImpressions |  | X | X |  | JobImpressionsSupported
JobKOctets |  | X | X |  | JobKOctetsSupported
JobMediaSheets |  | X | X |  | JobMediaSheetsSupported
JobName |  | X | X |  |
JobPriority |  | X | X |  | JobPrioritySupported
JobSheets |  | X | X |  |
Media | X | X | X |  |
MediaSize |  |  |  |  |
MultipleDocumentHandling |  | X | X |  |
NumberUp | X | X | X |  | NumberUpSupported
OrientationRequested | X | X | X |  |
PageRanges | X | X | X |  |
PresentationDirection | X | X | X |  |
PrinterResolution | X | X | X |  |
PrintQuality | X | X | X |  |
RequestingUserName |  | X | X |  |
SheetCollate | X | X | X |  |
Sides | X | X | X |  |
DateTimeAtCompleted |  |  | X |  |
DateTimeAtCreation |  |  | X |  |
DateTimeAtProcessing |  |  | X |  |
JobImpressionsCompleted |  |  | X |  |
JobKOctetsProcessed |  |  | X |  |
JobMediaSheetsCompleted |  |  | X |  |
JobMessageFromOperator |  |  | X |  |
JobOriginatingUserName |  |  | X |  |
JobState |  |  | X |  |
JobStateReasons Contains zero or more -- |  |  | X |  |
-- JobStateReason |  |  |  |  |
NumberOfDocuments |  |  | X |  |
NumberOfInterveningJobs |  |  | X |  |
OutputDeviceAssigned |  |  | X |  |
ColorSupported |  |  |  | X |
PagesPerMinute |  |  |  | X |
PagesPerMinuteColor |  |  |  | X |
PDLOverrideSupported |  |  |  | X |
PrinterIsAcceptingJobs |  |  |  | X |
PrinterInfo |  |  |  | X |
PrinterLocation |  |  |  | X |
PrinterMessageFromOperator |  |  |  | X |
PrinterMakeAndModel |  |  |  | X |
PrinterMoreInfo |  |  |  | X |
PrinterMoreInfoManufacturer |  |  |  | X |
PrinterName |  |  |  | X |
PrinterState |  |  |  | X |
PrinterStateReasons Contains zero or more -- |  |  |  | X |
-- PrinterStateReason |  |  |  |  |
-- Severity |  |  |  |  |
QueuedJobCount |  |  |  | X |
ReferenceUriSchemesSupported |  |  |  |  |

Please note: In the javax.print APIs, a null reference parameter to methods is incorrect unless explicitly documented on the method as having a meaningful interpretation. Usage to the contrary is incorrect coding and may result in a run time exception either immediately or at some later time. IllegalArgumentException and NullPointerException are examples of typical and acceptable run time exceptions for such cases.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.print.attribute.standard Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.print.attribute.standard

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • javax.print.attribute.standard.JobStateReasons (implements javax.print.attribute.PrintJobAttribute)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • javax.print.attribute.standard.PrinterStateReasons (implements javax.print.attribute.PrintServiceAttribute)
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DateTimeAtCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtCreation (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtProcessing (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobHoldUntil (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Chromaticity (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ColorSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.Compression (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.DialogTypeSelection (implements javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Fidelity (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Finishings (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobState (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Media (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
        • javax.print.attribute.standard.MediaName (implements javax.print.attribute.Attribute)
        • javax.print.attribute.standard.MediaSizeName
        • javax.print.attribute.standard.MediaTray (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.MultipleDocumentHandling (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.OrientationRequested (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PDLOverrideSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PresentationDirection (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterIsAcceptingJobs (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterState (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.PrintQuality (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ReferenceUriSchemesSupported (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Severity (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.SheetCollate (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Sides (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Copies (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressions (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressionsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobKOctets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobKOctetsProcessed (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobMediaSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobMediaSheetsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobPriority (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobPrioritySupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberOfDocuments (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberOfInterveningJobs (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberUp (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PagesPerMinute (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PagesPerMinuteColor (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.QueuedJobCount (implements javax.print.attribute.PrintServiceAttribute)
    • javax.print.attribute.standard.MediaPrintableArea (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.standard.MediaSize.Engineering
    • javax.print.attribute.standard.MediaSize.ISO
    • javax.print.attribute.standard.MediaSize.JIS
    • javax.print.attribute.standard.MediaSize.NA
    • javax.print.attribute.standard.MediaSize.Other
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.PrinterResolution (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.CopiesSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobImpressionsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobKOctetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobMediaSheetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberUpSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.PageRanges (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.MediaSize (implements javax.print.attribute.Attribute)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DocumentName (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.JobMessageFromOperator (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobName (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobOriginatingUserName (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.OutputDeviceAssigned (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.PrinterInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterLocation (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMakeAndModel (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMessageFromOperator (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterName (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.RequestingUserName (implements javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Destination (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterMoreInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterURI (implements javax.print.attribute.PrintServiceAttribute)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"T>tDm=F"""H>TT"L>X


JobHoldUntil

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobHoldUntil

  • java.lang.Object
    • javax.print.attribute.DateTimeSyntax
      • javax.print.attribute.standard.JobHoldUntil
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class JobHoldUntil
extends DateTimeSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.

    If the value of this attribute specifies a date-time that is in the future, the printer should add the JobStateReason value of JOB_HOLD_UNTIL_SPECIFIED to the job's JobStateReasons attribute, must move the job to the PENDING_HELD state, and must not schedule the job for printing until the specified date-time arrives.

    When the specified date-time arrives, the printer must remove the JobStateReason value of JOB_HOLD_UNTIL_SPECIFIED from the job's JobStateReasons attribute, if present. If there are no other job state reasons that keep the job in the PENDING_HELD state, the printer must consider the job as a candidate for processing by moving the job to the PENDING state.

    If the specified date-time has already passed, the job must be a candidate for processing immediately. Thus, one way to make the job immediately become a candidate for processing is to specify a JobHoldUntil attribute constructed like this (denoting a date-time of January 1, 1970, 00:00:00 GMT):

         JobHoldUntil immediately = new JobHoldUntil (new Date (0L));

    If the client does not supply this attribute in a Print Request and the printer supports this attribute, the printer must use its (implementation-dependent) default JobHoldUntil value at job submission time (unlike most job template attributes that are used if necessary at job processing time).

    To construct a JobHoldUntil attribute from separate values of the year, month, day, hour, minute, and so on, use a Calendar object to construct a Date object, then use the Date object to construct the JobHoldUntil attribute. To convert a JobHoldUntil attribute to separate values of the year, month, day, hour, minute, and so on, create a Calendar object and set it to the Date from the JobHoldUntil attribute.

    IPP Compatibility: Although IPP supports a "job-hold-until" attribute specified as a keyword, IPP does not at this time support a "job-hold-until" attribute specified as a date and time. However, the date and time can be converted to one of the standard IPP keywords with some loss of precision; for example, a JobHoldUntil value with today's date and 9:00pm local time might be converted to the standard IPP keyword "night". The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobHoldUntil(Date dateTime)
      Construct a new job hold until date-time attribute with the given Date value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job hold until attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.DateTimeSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobHoldUntil

        public JobHoldUntil(Date dateTime)
        Construct a new job hold until date-time attribute with the given Date value.
        参数：
        dateTime - Date value.
        抛出：
        NullPointerException - (unchecked exception) Thrown if dateTime is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job hold until attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobHoldUntil.
        3. This job hold until attribute's Date value and object's Date value are equal.
        重载：
        equals in class DateTimeSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job hold until attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobHoldUntil, the category is class JobHoldUntil itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobHoldUntil, the category name is "job-hold-until".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eo atoiwoiwttiwwt ccmgEhATTU#LTETtiFFstii/r>t


JobImpressions

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobImpressions

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobImpressions
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class JobImpressions
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted. An "impression" is the image (possibly many print-stream pages in different configurations) imposed onto a single media page.

    The JobImpressions attribute describes the size of the job. This attribute is not intended to be a counter; it is intended to be useful routing and scheduling information if known. The printer may try to compute the JobImpressions attribute's value if it is not supplied in the Print Request. Even if the client does supply a value for the JobImpressions attribute in the Print Request, the printer may choose to change the value if the printer is able to compute a value which is more accurate than the client supplied value. The printer may be able to determine the correct value for the JobImpressions attribute either right at job submission time or at any later point in time.

    As with JobKOctets, the JobImpressions value must not include the multiplicative factors contributed by the number of copies specified by the Copies attribute, independent of whether the device can process multiple copies without making multiple passes over the job or document data and independent of whether the output is collated or not. Thus the value is independent of the implementation and reflects the size of the document(s) measured in impressions independent of the number of copies.

    As with JobKOctets, the JobImpressions value must also not include the multiplicative factor due to a copies instruction embedded in the document data. If the document data actually includes replications of the document data, this value will include such replication. In other words, this value is always the number of impressions in the source document data, rather than a measure of the number of impressions to be produced by the job.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobImpressionsSupported, JobImpressionsCompleted, JobKOctets, JobMediaSheets, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobImpressions(int value)
      Construct a new job impressions attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job impressions attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobImpressions

        public JobImpressions(int value)
        Construct a new job impressions attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job impressions attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobImpressions.
        3. This job impressions attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job impressions attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobImpressions, the category is class JobImpressions itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobImpressions, the category name is "job-impressions".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d"&iii/ililFeldbe>llmaoroddrtmy<"/rra><�


JobImpressionsCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobImpressionsCompleted

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobImpressionsCompleted
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class JobImpressionsCompleted
extends IntegerSyntax
implements PrintJobAttribute
    Class JobImpressionsCompleted is an integer valued printing attribute class that specifies the number of impressions completed for the job so far. For printing devices, the impressions completed includes interpreting, marking, and stacking the output.

    The JobImpressionsCompleted attribute describes the progress of the job. This attribute is intended to be a counter. That is, the JobImpressionsCompleted value for a job that has not started processing must be 0. When the job's JobState is PROCESSING or PROCESSING_STOPPED, the JobImpressionsCompleted value is intended to increase as the job is processed; it indicates the amount of the job that has been processed at the time the Print Job's attribute set is queried or at the time a print job event is reported. When the job enters the COMPLETED, CANCELED, or ABORTED states, the JobImpressionsCompleted value is the final value for the job.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobImpressions, JobImpressionsSupported, JobKOctetsProcessed, JobMediaSheetsCompleted, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobImpressionsCompleted(int value)
      Construct a new job impressions completed attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job impressions completed attribute is equivalent tp the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobImpressionsCompleted

        public JobImpressionsCompleted(int value)
        Construct a new job impressions completed attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job impressions completed attribute is equivalent tp the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobImpressionsCompleted.
        3. This job impressions completed attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job impressions completed attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobImpressionsCompleted, the category is class JobImpressionsCompleted itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobImpressionsCompleted, the category name is "job-impressions-completed".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n


JobImpressionsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobImpressionsSupported

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.JobImpressionsSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class JobImpressionsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute
    Class JobImpressionsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobImpressions attribute. It is restricted to a single contiguous range of integers; multiple non-overlapping ranges are not allowed. This gives the lower and upper bounds of the total sizes of print jobs in number of impressions that the printer will accept.

    IPP Compatibility: The JobImpressionsSupported attribute's canonical array form gives the lower and upper bound for the range of values to be included in an IPP "job-impressions-supported" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobImpressionsSupported(int lowerBound, int upperBound)
      Construct a new job impressions supported attribute containing a single range of integers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job impressions supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobImpressionsSupported

        public JobImpressionsSupported(int lowerBound,
                       int upperBound)
        Construct a new job impressions supported attribute containing a single range of integers. That is, only those values of JobImpressions in the one range are supported.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job impressions supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobImpressionsSupported.
        3. This job impressions supported attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job impressions supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobImpressionsSupported, the category is class JobImpressionsSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobImpressionsSupported, the category name is "job-impressions-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ii/ㄋ� ㄈ 纒 ><<>bn瞫輕>>;es竤aab3s


JobKOctets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobKOctets

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobKOctets
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class JobKOctets
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job. The value must be rounded up, so that a job between 1 and 1024 octets must be indicated as being 1K octets, 1025 to 2048 must be 2K octets, etc. For a multidoc print job (a job with multiple documents), the JobKOctets value is computed by adding up the individual documents' sizes in octets, then rounding up to the next K octets value.

    The JobKOctets attribute describes the size of the job. This attribute is not intended to be a counter; it is intended to be useful routing and scheduling information if known. The printer may try to compute the JobKOctets attribute's value if it is not supplied in the Print Request. Even if the client does supply a value for the JobKOctets attribute in the Print Request, the printer may choose to change the value if the printer is able to compute a value which is more accurate than the client supplied value. The printer may be able to determine the correct value for the JobKOctets attribute either right at job submission time or at any later point in time.

    The JobKOctets value must not include the multiplicative factors contributed by the number of copies specified by the Copies attribute, independent of whether the device can process multiple copies without making multiple passes over the job or document data and independent of whether the output is collated or not. Thus the value is independent of the implementation and indicates the size of the document(s) measured in K octets independent of the number of copies.

    The JobKOctets value must also not include the multiplicative factor due to a copies instruction embedded in the document data. If the document data actually includes replications of the document data, this value will include such replication. In other words, this value is always the size of the source document data, rather than a measure of the hardcopy output to be produced.

    The size of a doc is computed based on the print data representation class as specified by the doc's DocFlavor, as shown in the table below.

    Representation Class | Document Size
    byte[] | Length of the byte array
    java.io.InputStream | Number of bytes read from the stream
    char[] | Length of the character array x 2
    java.lang.String | Length of the string x 2
    java.io.Reader | Number of characters read from the stream x 2
    java.net.URL | Number of bytes read from the file at the given URL address
    java.awt.image.renderable.RenderableImage | Implementation dependent*
    java.awt.print.Printable | Implementation dependent*
    java.awt.print.Pageable | Implementation dependent*

    * In these cases the Print Service itself generates the print data sent to the printer. If the Print Service supports the JobKOctets attribute, for these cases the Print Service itself must calculate the size of the print data, replacing any JobKOctets value the client specified.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobKOctetsSupported, JobKOctetsProcessed, JobImpressions, JobMediaSheets, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobKOctets(int value)
      Construct a new job K octets attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job K octets attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobKOctets

        public JobKOctets(int value)
        Construct a new job K octets attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job K octets attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobKOctets.
        3. This job K octets attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job K octets attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobKOctets, the category is class JobKOctets itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobKOctets, the category name is "job-k-octets".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.fo Ret=-= =S-- aOdnpe=ival3/8�--�>/-


JobKOctetsProcessed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobKOctetsProcessed

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobKOctetsProcessed
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class JobKOctetsProcessed
extends IntegerSyntax
implements PrintJobAttribute
    Class JobKOctetsProcessed is an integer valued printing attribute class that specifies the total number of print data octets processed so far in K octets, i.e., in units of 1024 octets. The value must be rounded up, so that a job between 1 and 1024 octets inclusive must be indicated as being 1K octets, 1025 to 2048 inclusive must be 2K, etc. For a multidoc print job (a job with multiple documents), the JobKOctetsProcessed value is computed by adding up the individual documents' number of octets processed so far, then rounding up to the next K octets value.

    The JobKOctetsProcessed attribute describes the progress of the job. This attribute is intended to be a counter. That is, the JobKOctetsProcessed value for a job that has not started processing must be 0. When the job's JobState is PROCESSING or PROCESSING_STOPPED, the JobKOctetsProcessed value is intended to increase as the job is processed; it indicates the amount of the job that has been processed at the time the Print Job's attribute set is queried or at the time a print job event is reported. When the job enters the COMPLETED, CANCELED, or ABORTED states, the JobKOctetsProcessed value is the final value for the job.

    For implementations where multiple copies are produced by the interpreter with only a single pass over the data, the final value of the JobKOctetsProcessed attribute must be equal to the value of the JobKOctets attribute. For implementations where multiple copies are produced by the interpreter by processing the data for each copy, the final value must be a multiple of the value of the JobKOctets attribute.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobKOctets, JobKOctetsSupported, JobImpressionsCompleted, JobMediaSheetsCompleted, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobKOctetsProcessed(int value)
      Construct a new job K octets processed attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job K octets processed attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobKOctetsProcessed

        public JobKOctetsProcessed(int value)
        Construct a new job K octets processed attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job K octets processed attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobKOctetsProcessed.
        3. This job K octets processed attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job K octets processed attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobKOctetsProcessed, the category is class JobKOctetsProcessed itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobKOctetsProcessed, the category name is "job-k-octets-processed".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mslebeJetetshthhtdbbu


JobKOctetsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobKOctetsSupported

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.JobKOctetsSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class JobKOctetsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute
    Class JobKOctetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobKOctets attribute. It is restricted to a single contiguous range of integers; multiple non-overlapping ranges are not allowed. This gives the lower and upper bounds of the total sizes of print jobs in units of K octets (1024 octets) that the printer will accept.

    IPP Compatibility: The JobKOctetsSupported attribute's canonical array form gives the lower and upper bound for the range of values to be included in an IPP "job-k-octets-supported" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobKOctetsSupported(int lowerBound, int upperBound)
      Construct a new job K octets supported attribute containing a single range of integers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job K octets supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobKOctetsSupported

        public JobKOctetsSupported(int lowerBound,
                   int upperBound)
        Construct a new job K octets supported attribute containing a single range of integers. That is, only those values of JobKOctets in the one range are supported.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job K octets supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobKOctetsSupported.
        3. This job K octets supported attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job K octets supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobKOctetsSupported, the category is class JobKOctetsSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobKOctetsSupported, the category name is "job-k-octets-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bsasl i>


JobMediaSheets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobMediaSheets

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobMediaSheets
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public class JobMediaSheets
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.

    The JobMediaSheets attribute describes the size of the job. This attribute is not intended to be a counter; it is intended to be useful routing and scheduling information if known. The printer may try to compute the JobMediaSheets attribute's value if it is not supplied in the Print Request. Even if the client does supply a value for the JobMediaSheets attribute in the Print Request, the printer may choose to change the value if the printer is able to compute a value which is more accurate than the client supplied value. The printer may be able to determine the correct value for the JobMediaSheets attribute either right at job submission time or at any later point in time.

    Unlike the JobKOctets and JobImpressions attributes, the JobMediaSheets value must include the multiplicative factors contributed by the number of copies specified by the Copies attribute and a "number of copies" instruction embedded in the document data, if any. This difference allows the system administrator to control the lower and upper bounds of both (1) the size of the document(s) with JobKOctetsSupported and JobImpressionsSupported and (2) the size of the job with JobMediaSheetsSupported.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobMediaSheetsSupported, JobMediaSheetsCompleted, JobKOctets, JobImpressions, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobMediaSheets(int value)
      Construct a new job media sheets attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job media sheets attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobMediaSheets

        public JobMediaSheets(int value)
        Construct a new job media sheets attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job media sheets attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobMediaSheets.
        3. This job media sheets attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job media sheets attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobMediaSheets and any vendor-defined subclasses, the category is class JobMediaSheets itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobMediaSheets and any vendor-defined subclasses, the category name is "job-media-sheets".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

trtrt;ttm); i)_aa=/etxxs.vc


JobMediaSheetsCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobMediaSheetsCompleted

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobMediaSheetsCompleted
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class JobMediaSheetsCompleted
extends IntegerSyntax
implements PrintJobAttribute
    Class JobMediaSheetsCompleted is an integer valued printing attribute class that specifies the number of media sheets which have completed marking and stacking for the entire job so far, whether those sheets have been processed on one side or on both.

    The JobMediaSheetsCompleted attribute describes the progress of the job. This attribute is intended to be a counter. That is, the JobMediaSheetsCompleted value for a job that has not started processing must be 0. When the job's JobState is PROCESSING or PROCESSING_STOPPED, the JobMediaSheetsCompleted value is intended to increase as the job is processed; it indicates the amount of the job that has been processed at the time the Print Job's attribute set is queried or at the time a print job event is reported. When the job enters the COMPLETED, CANCELED, or ABORTED states, the JobMediaSheetsCompleted value is the final value for the job.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    JobMediaSheets, JobMediaSheetsSupported, JobKOctetsProcessed, JobImpressionsCompleted, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobMediaSheetsCompleted(int value)
      Construct a new job media sheets completed attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job media sheets completed attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobMediaSheetsCompleted

        public JobMediaSheetsCompleted(int value)
        Construct a new job media sheets completed attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job media sheets completed attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobMediaSheetsCompleted.
        3. This job media sheets completed attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job media sheets completed attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobMediaSheetsCompleted, the category is class JobMediaSheetsCompleted itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobMediaSheetsCompleted, the category name is "job-media-sheets-completed".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cel> >v> >v


JobMediaSheetsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobMediaSheetsSupported

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.JobMediaSheetsSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class JobMediaSheetsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute
    Class JobMediaSheetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobMediaSheets attribute. It is restricted to a single contiguous range of integers; multiple non-overlapping ranges are not allowed. This gives the lower and upper bounds of the total sizes of print jobs in number of media sheets that the printer will accept.

    IPP Compatibility: The JobMediaSheetsSupported attribute's canonical array form gives the lower and upper bound for the range of values to be included in an IPP "job-media-sheets-supported" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobMediaSheetsSupported(int lowerBound, int upperBound)
      Construct a new job media sheets supported attribute containing a single range of integers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job media sheets supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobMediaSheetsSupported

        public JobMediaSheetsSupported(int lowerBound,
                       int upperBound)
        Construct a new job media sheets supported attribute containing a single range of integers. That is, only those values of JobMediaSheets in the one range are supported.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job media sheets supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobMediaSheetsSupported.
        3. This job media sheets supported attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job media sheets supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobMediaSheetsSupported, the category is class JobMediaSheetsSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobMediaSheetsSupported, the category name is "job-media-sheets-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<<&gsg>gFgn舶�&sa8nle>8�133o-tnaglool>a


JobMessageFromOperator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobMessageFromOperator

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.JobMessageFromOperator
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class JobMessageFromOperator
extends TextSyntax
implements PrintJobAttribute
    Class JobMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user the reasons for modification or other management action taken on a job.

    A Print Job's attribute set includes zero instances or one instance of a JobMessageFromOperator attribute, not more than one instance. A new JobMessageFromOperator attribute replaces an existing JobMessageFromOperator attribute, if any. In other words, JobMessageFromOperator is not intended to be a history log. If it wishes, the client can detect changes to a Print Job's JobMessageFromOperator attribute and maintain the client's own history log of the JobMessageFromOperator attribute values.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobMessageFromOperator(String message, Locale locale)
      Constructs a new job message from operator attribute with the given message and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job message from operator attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobMessageFromOperator

        public JobMessageFromOperator(String message,
                      Locale locale)
        Constructs a new job message from operator attribute with the given message and locale.
        参数：
        message - Message.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if message is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job message from operator attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobMessageFromOperator.
        3. This job message from operator attribute's underlying string and object's underlying string are equal.
        4. This job message from operator attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job message from operator attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobMessageFromOperator, the category is class JobMessageFromOperator itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobMessageFromOperator, the category name is "job-message-from-operator".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssrf纅膊snnp3;8ss


JobName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobName

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.JobName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class JobName
extends TextSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job. A job's name is an arbitrary string defined by the client. It does not need to be unique between different jobs. A Print Job's JobName attribute is set to the value supplied by the client in the Print Request's attribute set. If, however, the client does not supply a JobName attribute in the Print Request, the printer, when it creates the Print Job, must generate a JobName. The printer should generate the value of the Print Job's JobName attribute from the first of the following sources that produces a value: (1) the DocumentName attribute of the first (or only) doc in the job, (2) the URL of the first (or only) doc in the job, if the doc's print data representation object is a URL, or (3) any other piece of Print Job specific and/or document content information.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobName(String jobName, Locale locale)
      Constructs a new job name attribute with the given job name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobName

        public JobName(String jobName,
       Locale locale)
        Constructs a new job name attribute with the given job name and locale.
        参数：
        jobName - Job name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if jobName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobName.
        3. This job name attribute's underlying string and object's underlying string are equal.
        4. This job name attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job name attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobName, the category is class JobName itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobName, the category name is "job-name".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/d/b/>/ sff>ss纓> /nnr


JobOriginatingUserName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobOriginatingUserName

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.JobOriginatingUserName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class JobOriginatingUserName
extends TextSyntax
implements PrintJobAttribute
    Class JobOriginatingUserName is a printing attribute class, a text attribute, that contains the name of the end user that submitted the print job. If possible, the printer sets this attribute to the most authenticated printable user name that it can obtain from the authentication service that authenticated the submitted Print Request. If such is not available, the printer uses the value of the RequestingUserName attribute supplied by the client in the Print Request's attribute set. If no authentication service is available, and the client did not supply a RequestingUserName attribute, the printer sets the JobOriginatingUserName attribute to an empty (zero-length) string.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobOriginatingUserName(String userName, Locale locale)
      Constructs a new job originating user name attribute with the given user name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job originating user name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobOriginatingUserName

        public JobOriginatingUserName(String userName,
                      Locale locale)
        Constructs a new job originating user name attribute with the given user name and locale.
        参数：
        userName - User name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if userName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job originating user name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobOriginatingUserName.
        3. This job originating user name attribute's underlying string and object's underlying string are equal.
        4. This job originating user name attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job originating user name attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobOriginatingUserName, the category is class JobOriginatingUserName itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobOriginatingUserName, the category name is "job-originating-user-name".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsy>>>a>a>iumar&m ssn lsytts=dp"lndsw"y"ce"s


JobPriority

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobPriority

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobPriority
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class JobPriority
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.

    If a JobPriority attribute is specified for a Print Job, it specifies a priority for scheduling the job. A higher value specifies a higher priority. The value 1 indicates the lowest possible priority. The value 100 indicates the highest possible priority. Among those jobs that are ready to print, a printer must print all jobs with a priority value of 上一个 before printing those with a priority value of 上一个-1 for all n.

    If the client does not specify a JobPriority attribute for a Print Job and the printer does support the JobPriority attribute, the printer must use an implementation-defined default JobPriority value.

    The client can always specify any job priority value from 1 to 100 for a job. However, a Print Service instance may support fewer than 100 different job priority levels. If this is the case, the Print Service instance automatically maps the client-specified job priority value to one of the supported job priority levels, dividing the 100 job priority values equally among the available job priority levels.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobPriority(int value)
      Construct a new job priority attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job priority attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobPriority

        public JobPriority(int value)
        Construct a new job priority attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 1 or greater than 100.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job priority attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobPriority.
        3. This job priority attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job priority attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobPriority, the category is class JobPriority itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobPriority, the category name is "job-priority".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=b=BMBTB=BVR===== NNi> uesvkb""arvpv>_a-O


JobPrioritySupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobPrioritySupported

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.JobPrioritySupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class JobPrioritySupported
extends IntegerSyntax
implements SupportedValuesAttribute
    Class JobPrioritySupported is an integer valued printing attribute class that specifies whether a Print Service instance supports the JobPriority attribute and the number of different job priority levels supported.

    The client can always specify any JobPriority value from 1 to 100 for a job. However, the Print Service instance may support fewer than 100 different job priority levels. If this is the case, the Print Service instance automatically maps the client-specified job priority value to one of the supported job priority levels, dividing the 100 job priority values equally among the available job priority levels.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobPrioritySupported(int value)
      Construct a new job priority supported attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this job priority supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JobPrioritySupported

        public JobPrioritySupported(int value)
        Construct a new job priority supported attribute with the given integer value.
        参数：
        value - Number of different job priority levels supported.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 1 or greater than 100.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this job priority supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class JobPrioritySupported.
        3. This job priority supported attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this job priority supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobPrioritySupported, the category is class JobPrioritySupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobPrioritySupported, the category name is "job-priority-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ef nwndndni odexlb ;竞b祝<< �


JobSheets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobSheets

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.JobSheets
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public class JobSheets
extends EnumSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job. Class JobSheets declares keywords for standard job sheets values. Implementation- or site-defined names for a job sheets attribute may also be created by defining a subclass of class JobSheets.

    The effect of a JobSheets attribute on multidoc print jobs (jobs with multiple documents) may be affected by the MultipleDocumentHandling job attribute, depending on the meaning of the particular JobSheets value.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value. For a subclass, the attribute value must be localized to give the IPP name and natural language values.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static JobSheets NONE
      No job sheets are printed.
      static JobSheets STANDARD
      One or more site specific standard job sheets are printed.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JobSheets(int value)
      Construct a new job sheets enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class JobSheets.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class JobSheets.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final JobSheets NONE
        No job sheets are printed.

      • STANDARD

        public static final JobSheets STANDARD
        One or more site specific standard job sheets are printed. e.g. a single start sheet is printed, or both start and end sheets are printed.

    • 构造方法详细信息

      • JobSheets

        protected JobSheets(int value)
        Construct a new job sheets enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class JobSheets.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class JobSheets.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobSheets and any vendor-defined subclasses, the category is class JobSheets itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobSheets and any vendor-defined subclasses, the category name is "job-sheets".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.v=onoo>oi.hddn cl)/a�/xjacocroatoc!vjgj.ja


JobState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobState

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.JobState
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public class JobState
extends EnumSyntax
implements PrintJobAttribute
    JobState is a printing attribute class, an enumeration, that identifies the current state of a print job. Class JobState defines standard job state values. A Print Service implementation only needs to report those job states which are appropriate for the particular implementation; it does not have to report every defined job state. The JobStateReasons attribute augments the JobState attribute to give more detailed information about the job in the given job state.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static JobState ABORTED
      The job has been aborted by the system (usually while the job was in the PROCESSING or PROCESSING_STOPPED state), the printer has completed aborting the job, and all job status attributes have reached their final values for the job.
      static JobState CANCELED
      The job has been canceled by some human agency, the printer has completed canceling the job, and all job status attributes have reached their final values for the job.
      static JobState COMPLETED
      The job has completed successfully or with warnings or errors after processing, all of the job media sheets have been successfully stacked in the appropriate output bin(s), and all job status attributes have reached their final values for the job.
      static JobState PENDING
      The job is a candidate to start processing, but is not yet processing.
      static JobState PENDING_HELD
      The job is not a candidate for processing for any number of reasons but will return to the PENDING state as soon as the reasons are no longer present.
      static JobState PROCESSING
      The job is processing.
      static JobState PROCESSING_STOPPED
      The job has stopped while processing for any number of reasons and will return to the PROCESSING state as soon as the reasons are no longer present.
      static JobState UNKNOWN
      The job state is unknown.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JobState(int value)
      Construct a new job state enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class JobState.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class JobState.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNKNOWN

        public static final JobState UNKNOWN
        The job state is unknown.

      • PENDING

        public static final JobState PENDING
        The job is a candidate to start processing, but is not yet processing.

      • PENDING_HELD

        public static final JobState PENDING_HELD
        The job is not a candidate for processing for any number of reasons but will return to the PENDING state as soon as the reasons are no longer present. The job's JobStateReasons attribute must indicate why the job is no longer a candidate for processing.

      • PROCESSING

        public static final JobState PROCESSING
        The job is processing. One or more of the following activities is occurring:
        1. The job is using, or is attempting to use, one or more purely software processes that are analyzing, creating, or interpreting a PDL, etc.

        2. The job is using, or is attempting to use, one or more hardware devices that are interpreting a PDL, making marks on a medium, and/or performing finishing, such as stapling, etc.

        3. The printer has made the job ready for printing, but the output device is not yet printing it, either because the job hasn't reached the output device or because the job is queued in the output device or some other spooler, awaiting the output device to print it.

        When the job is in the PROCESSING state, the entire job state includes the detailed status represented in the printer's PrinterState and PrinterStateReasons attributes.

        Implementations may, though they need not, include additional values in the job's JobStateReasons attribute to indicate the progress of the job, such as adding the JOB_PRINTING value to indicate when the output device is actually making marks on paper and/or the PROCESSING_TO_STOP_POINT value to indicate that the printer is in the process of canceling or aborting the job.

      • PROCESSING_STOPPED

        public static final JobState PROCESSING_STOPPED
        The job has stopped while processing for any number of reasons and will return to the PROCESSING state as soon as the reasons are no longer present.

        The job's JobStateReasons attribute may indicate why the job has stopped processing. For example, if the output device is stopped, the PRINTER_STOPPED value may be included in the job's JobStateReasons attribute.

        Note: When an output device is stopped, the device usually indicates its condition in human readable form locally at the device. A client can obtain more complete device status remotely by querying the printer's PrinterState and PrinterStateReasons attributes.

      • CANCELED

        public static final JobState CANCELED
        The job has been canceled by some human agency, the printer has completed canceling the job, and all job status attributes have reached their final values for the job. While the printer is canceling the job, the job remains in its current state, but the job's JobStateReasons attribute should contain the PROCESSING_TO_STOP_POINT value and one of the CANCELED_BY_USER, CANCELED_BY_OPERATOR, or CANCELED_AT_DEVICE values. When the job moves to the CANCELED state, the PROCESSING_TO_STOP_POINT value, if present, must be removed, but the CANCELED_BY_xxx value, if present, must remain.

      • ABORTED

        public static final JobState ABORTED
        The job has been aborted by the system (usually while the job was in the PROCESSING or PROCESSING_STOPPED state), the printer has completed aborting the job, and all job status attributes have reached their final values for the job. While the printer is aborting the job, the job remains in its current state, but the job's JobStateReasons attribute should contain the PROCESSING_TO_STOP_POINT and ABORTED_BY_SYSTEM values. When the job moves to the ABORTED state, the PROCESSING_TO_STOP_POINT value, if present, must be removed, but the ABORTED_BY_SYSTEM value, if present, must remain.

      • COMPLETED

        public static final JobState COMPLETED
        The job has completed successfully or with warnings or errors after processing, all of the job media sheets have been successfully stacked in the appropriate output bin(s), and all job status attributes have reached their final values for the job. The job's JobStateReasons attribute should contain one of these values: COMPLETED_SUCCESSFULLY, COMPLETED_WITH_WARNINGS, or COMPLETED_WITH_ERRORS.

    • 构造方法详细信息

      • JobState

        protected JobState(int value)
        Construct a new job state enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class JobState.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class JobState.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobState and any vendor-defined subclasses, the category is class JobState itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobState and any vendor-defined subclasses, the category name is "job-state".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o9hb.<


JobStateReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobStateReason

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.JobStateReason
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public class JobStateReason
extends EnumSyntax
implements Attribute
    Class JobStateReason is a printing attribute class, an enumeration, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute. Class JobStateReason defines standard job state reason values. A Print Service implementation only needs to report those job state reasons which are appropriate for the particular implementation; it does not have to report every defined job state reason.

    Instances of JobStateReason do not appear in a Print Job's attribute set directly. Rather, a JobStateReasons attribute appears in the Print Job's attribute set. The JobStateReasons attribute contains zero, one, or more than one JobStateReason objects which pertain to the Print Job's status. The printer adds a JobStateReason object to the Print Job's JobStateReasons attribute when the corresponding condition becomes true of the Print Job, and the printer removes the JobStateReason object again when the corresponding condition becomes false, regardless of whether the Print Job's overall JobState also changed.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static JobStateReason ABORTED_BY_SYSTEM
      The job was aborted by the system.
      static JobStateReason COMPRESSION_ERROR
      The job was aborted by the system because the printer encountered an error in the document data while decompressing it.
      static JobStateReason DOCUMENT_ACCESS_ERROR
      The Printer could not access one or more documents passed by reference (i.e., the print data representation object is a URL).
      static JobStateReason DOCUMENT_FORMAT_ERROR
      The job was aborted by the system because the printer encountered an error in the document data while processing it.
      static JobStateReason JOB_CANCELED_AT_DEVICE
      The job was canceled by an unidentified local user, i.e., a user at a console at the device.
      static JobStateReason JOB_CANCELED_BY_OPERATOR
      The job was canceled by the operator, i.e., by a user who has been authenticated as having operator privileges (whether local or remote).
      static JobStateReason JOB_CANCELED_BY_USER
      The job was canceled by the owner of the job, i.e., by a user whose authenticated identity is the same as the value of the originating user that created the Print Job, or by some other authorized end-user, such as a member of the job owner's security group.
      static JobStateReason JOB_COMPLETED_SUCCESSFULLY
      The job completed successfully.
      static JobStateReason JOB_COMPLETED_WITH_ERRORS
      The job completed with errors (and possibly warnings too).
      static JobStateReason JOB_COMPLETED_WITH_WARNINGS
      The job completed with warnings.
      static JobStateReason JOB_DATA_INSUFFICIENT
      The printer has created the Print Job, but the printer is expecting additional print data before it can move the job into the PROCESSING state.
      static JobStateReason JOB_HOLD_UNTIL_SPECIFIED
      The value of the job's JobHoldUntil attribute was specified with a date-time that is still in the future.
      static JobStateReason JOB_INCOMING
      The printer has created the Print Job, but the printer has not finished accessing or accepting all the print data yet.
      static JobStateReason JOB_INTERPRETING
      The job is in the PROCESSING state, but more specifically, the printer ia interpreting the document data.
      static JobStateReason JOB_OUTGOING
      The printer is transmitting the job to the output device.
      static JobStateReason JOB_PRINTING
      The output device is marking media.
      static JobStateReason JOB_QUEUED
      The job is in the PROCESSING state, but more specifically, the printer has queued the document data.
      static JobStateReason JOB_QUEUED_FOR_MARKER
      The job is in the PENDING_HELD, PENDING, or PROCESSING state, but more specifically, the printer has completed enough processing of the document to be able to start marking and the job is waiting for the marker.
      static JobStateReason JOB_RESTARTABLE
      This job is retained and is currently able to be restarted.
      static JobStateReason JOB_TRANSFORMING
      The job is in the PROCESSING state, but more specifically, the printer is interpreting document data and producing another electronic representation.
      static JobStateReason PRINTER_STOPPED
      The value of the printer's PrinterState attribute ia STOPPED.
      static JobStateReason PRINTER_STOPPED_PARTLY
      The value of the printer's PrinterStateReasons attribute contains a PrinterStateReason value of STOPPED_PARTLY.
      static JobStateReason PROCESSING_TO_STOP_POINT
      The requester has canceled the job or the printer has aborted the job, but the printer is still performing some actions on the job until a specified stop point occurs or job termination/cleanup is completed.
      static JobStateReason QUEUED_IN_DEVICE
      The job has been forwarded to a device or print system that is unable to send back status.
      static JobStateReason RESOURCES_ARE_NOT_READY
      At least one of the resources needed by the job, such as media, fonts, resource objects, etc., is not ready on any of the physical printers for which the job is a candidate.
      static JobStateReason SERVICE_OFF_LINE
      The printer is off-line and accepting no jobs.
      static JobStateReason SUBMISSION_INTERRUPTED
      The job was not completely submitted for some unforeseen reason.
      static JobStateReason UNSUPPORTED_COMPRESSION
      The job was aborted by the system because the printer determined while attempting to decompress the document's data that the compression is actually not among those supported by the printer.
      static JobStateReason UNSUPPORTED_DOCUMENT_FORMAT
      The job was aborted by the system because the document data's document format (doc flavor) is not among those supported by the printer.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JobStateReason(int value)
      Construct a new job state reason enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class JobStateReason.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class JobStateReason.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • JOB_INCOMING

        public static final JobStateReason JOB_INCOMING
        The printer has created the Print Job, but the printer has not finished accessing or accepting all the print data yet.

      • JOB_DATA_INSUFFICIENT

        public static final JobStateReason JOB_DATA_INSUFFICIENT
        The printer has created the Print Job, but the printer is expecting additional print data before it can move the job into the PROCESSING state. If a printer starts processing before it has received all data, the printer removes the JOB_DATA_INSUFFICIENT reason, but the JOB_INCOMING reason remains. If a printer starts processing after it has received all data, the printer removes the JOB_DATA_INSUFFICIENT and JOB_INCOMING reasons at the same time.

      • DOCUMENT_ACCESS_ERROR

        public static final JobStateReason DOCUMENT_ACCESS_ERROR
        The Printer could not access one or more documents passed by reference (i.e., the print data representation object is a URL). This reason is intended to cover any file access problem,including file does not exist and access denied because of an access control problem. Whether the printer aborts the job and moves the job to the ABORTED job state or prints all documents that are accessible and moves the job to the COMPLETED job state and adds the COMPLETED_WITH_ERRORS reason to the job's JobStateReasons attribute depends on implementation and/or site policy. This value should be supported if the printer supports doc flavors with URL print data representation objects.

      • SUBMISSION_INTERRUPTED

        public static final JobStateReason SUBMISSION_INTERRUPTED
        The job was not completely submitted for some unforeseen reason. Possibilities include (1) the printer has crashed before the job was fully submitted by the client, (2) the printer or the document transfer method has crashed in some non-recoverable way before the document data was entirely transferred to the printer, (3) the client crashed before the job was fully submitted.

      • JOB_OUTGOING

        public static final JobStateReason JOB_OUTGOING
        The printer is transmitting the job to the output device.

      • JOB_HOLD_UNTIL_SPECIFIED

        public static final JobStateReason JOB_HOLD_UNTIL_SPECIFIED
        The value of the job's JobHoldUntil attribute was specified with a date-time that is still in the future. The job must not be a candidate for processing until this reason is removed and there are no other reasons to hold the job. This value should be supported if the JobHoldUntil job template attribute is supported.

      • RESOURCES_ARE_NOT_READY

        public static final JobStateReason RESOURCES_ARE_NOT_READY
        At least one of the resources needed by the job, such as media, fonts, resource objects, etc., is not ready on any of the physical printers for which the job is a candidate. This condition may be detected when the job is accepted, or subsequently while the job is pending or processing, depending on implementation. The job may remain in its current state or be moved to the PENDING_HELD state, depending on implementation and/or job scheduling policy.

      • PRINTER_STOPPED_PARTLY

        public static final JobStateReason PRINTER_STOPPED_PARTLY
        The value of the printer's PrinterStateReasons attribute contains a PrinterStateReason value of STOPPED_PARTLY.

      • PRINTER_STOPPED

        public static final JobStateReason PRINTER_STOPPED
        The value of the printer's PrinterState attribute ia STOPPED.

      • JOB_INTERPRETING

        public static final JobStateReason JOB_INTERPRETING
        The job is in the PROCESSING state, but more specifically, the printer ia interpreting the document data.

      • JOB_QUEUED

        public static final JobStateReason JOB_QUEUED
        The job is in the PROCESSING state, but more specifically, the printer has queued the document data.

      • JOB_TRANSFORMING

        public static final JobStateReason JOB_TRANSFORMING
        The job is in the PROCESSING state, but more specifically, the printer is interpreting document data and producing another electronic representation.

      • JOB_QUEUED_FOR_MARKER

        public static final JobStateReason JOB_QUEUED_FOR_MARKER
        The job is in the PENDING_HELD, PENDING, or PROCESSING state, but more specifically, the printer has completed enough processing of the document to be able to start marking and the job is waiting for the marker. Systems that require human intervention to release jobs put the job into the PENDING_HELD job state. Systems that automatically select a job to use the marker put the job into the PENDING job state or keep the job in the PROCESSING job state while waiting for the marker, depending on implementation. All implementations put the job into (or back into) the PROCESSING state when marking does begin.

      • JOB_PRINTING

        public static final JobStateReason JOB_PRINTING
        The output device is marking media. This value is useful for printers which spend a great deal of time processing (1) when no marking is happening and then want to show that marking is now happening or (2) when the job is in the process of being canceled or aborted while the job remains in the PROCESSING state, but the marking has not yet stopped so that impression or sheet counts are still increasing for the job.

      • JOB_CANCELED_BY_USER

        public static final JobStateReason JOB_CANCELED_BY_USER
        The job was canceled by the owner of the job, i.e., by a user whose authenticated identity is the same as the value of the originating user that created the Print Job, or by some other authorized end-user, such as a member of the job owner's security group. This value should be supported.

      • JOB_CANCELED_BY_OPERATOR

        public static final JobStateReason JOB_CANCELED_BY_OPERATOR
        The job was canceled by the operator, i.e., by a user who has been authenticated as having operator privileges (whether local or remote). If the security policy is to allow anyone to cancel anyone's job, then this value may be used when the job is canceled by someone other than the owner of the job. For such a security policy, in effect, everyone is an operator as far as canceling jobs is concerned. This value should be supported if the implementation permits canceling by someone other than the owner of the job.

      • JOB_CANCELED_AT_DEVICE

        public static final JobStateReason JOB_CANCELED_AT_DEVICE
        The job was canceled by an unidentified local user, i.e., a user at a console at the device. This value should be supported if the implementation supports canceling jobs at the console.

      • ABORTED_BY_SYSTEM

        public static final JobStateReason ABORTED_BY_SYSTEM
        The job was aborted by the system. Either the job (1) is in the process of being aborted, (2) has been aborted by the system and placed in the ABORTED state, or (3) has been aborted by the system and placed in the PENDING_HELD state, so that a user or operator can manually try the job again. This value should be supported.

      • UNSUPPORTED_COMPRESSION

        public static final JobStateReason UNSUPPORTED_COMPRESSION
        The job was aborted by the system because the printer determined while attempting to decompress the document's data that the compression is actually not among those supported by the printer. This value must be supported, since Compression is a required doc description attribute.

      • COMPRESSION_ERROR

        public static final JobStateReason COMPRESSION_ERROR
        The job was aborted by the system because the printer encountered an error in the document data while decompressing it. If the printer posts this reason, the document data has already passed any tests that would have led to the UNSUPPORTED_COMPRESSION job state reason.

      • UNSUPPORTED_DOCUMENT_FORMAT

        public static final JobStateReason UNSUPPORTED_DOCUMENT_FORMAT
        The job was aborted by the system because the document data's document format (doc flavor) is not among those supported by the printer. If the client specifies a doc flavor with a MIME type of "application/octet-stream", the printer may abort the job if the printer cannot determine the document data's actual format through auto-sensing (even if the printer supports the document format if specified explicitly). This value must be supported, since a doc flavor is required to be specified for each doc.

      • DOCUMENT_FORMAT_ERROR

        public static final JobStateReason DOCUMENT_FORMAT_ERROR
        The job was aborted by the system because the printer encountered an error in the document data while processing it. If the printer posts this reason, the document data has already passed any tests that would have led to the UNSUPPORTED_DOCUMENT_FORMAT job state reason.

      • PROCESSING_TO_STOP_POINT

        public static final JobStateReason PROCESSING_TO_STOP_POINT
        The requester has canceled the job or the printer has aborted the job, but the printer is still performing some actions on the job until a specified stop point occurs or job termination/cleanup is completed.

        If the implementation requires some measurable time to cancel the job in the PROCESSING or PROCESSING_STOPPED job states, the printer must use this reason to indicate that the printer is still performing some actions on the job while the job remains in the PROCESSING or PROCESSING_STOPPED state. After all the job's job description attributes have stopped incrementing, the printer moves the job from the PROCESSING state to the CANCELED or ABORTED job states.

      • SERVICE_OFF_LINE

        public static final JobStateReason SERVICE_OFF_LINE
        The printer is off-line and accepting no jobs. All PENDING jobs are put into the PENDING_HELD state. This situation could be true if the service's or document transform's input is impaired or broken.

      • JOB_COMPLETED_SUCCESSFULLY

        public static final JobStateReason JOB_COMPLETED_SUCCESSFULLY
        The job completed successfully. This value should be supported.

      • JOB_COMPLETED_WITH_WARNINGS

        public static final JobStateReason JOB_COMPLETED_WITH_WARNINGS
        The job completed with warnings. This value should be supported if the implementation detects warnings.

      • JOB_COMPLETED_WITH_ERRORS

        public static final JobStateReason JOB_COMPLETED_WITH_ERRORS
        The job completed with errors (and possibly warnings too). This value should be supported if the implementation detects errors.

      • JOB_RESTARTABLE

        public static final JobStateReason JOB_RESTARTABLE
        This job is retained and is currently able to be restarted. If JOB_RESTARTABLE is contained in the job's JobStateReasons attribute, then the printer must accept a request to restart that job. This value should be supported if restarting jobs is supported. [The capability for restarting jobs is not in the Java Print Service API at present.]

      • QUEUED_IN_DEVICE

        public static final JobStateReason QUEUED_IN_DEVICE
        The job has been forwarded to a device or print system that is unable to send back status. The printer sets the job's JobState attribute to COMPLETED and adds the QUEUED_IN_DEVICE reason to the job's JobStateReasons attribute to indicate that the printer has no additional information about the job and never will have any better information.

    • 构造方法详细信息

      • JobStateReason

        protected JobStateReason(int value)
        Construct a new job state reason enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class JobStateReason.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class JobStateReason.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobStateReason and any vendor-defined subclasses, the category is class JobStateReason itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobStateReason and any vendor-defined subclasses, the category name is "job-state-reason".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JobStateReasons

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 JobStateReasons

  • java.lang.Object
    • java.util.AbstractCollection<E>
      • java.util.AbstractSet<E>
        • java.util.HashSet<JobStateReason>
          • javax.print.attribute.standard.JobStateReasons
  • 所有已实现的接口：
    Serializable, Cloneable, Iterable<JobStateReason>, Collection<JobStateReason>, Set<JobStateReason>, Attribute, PrintJobAttribute

    public final class JobStateReasons
extends HashSet<JobStateReason>
implements PrintJobAttribute
    Class JobStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.

    Instances of JobStateReason do not appear in a Print Job's attribute set directly. Rather, a JobStateReasons attribute appears in the Print Job's attribute set. The JobStateReasons attribute contains zero, one, or more than one JobStateReason objects which pertain to the Print Job's status. The printer adds a JobStateReason object to the Print Job's JobStateReasons attribute when the corresponding condition becomes true of the Print Job, and the printer removes the JobStateReason object again when the corresponding condition becomes false, regardless of whether the Print Job's overall JobState also changed.

    Class JobStateReasons inherits its implementation from class java.util.HashSet. Unlike most printing attributes which are immutable once constructed, class JobStateReasons is designed to be mutable; you can add JobStateReason objects to an existing JobStateReasons object and remove them again. However, like class java.util.HashSet, class JobStateReasons is not multiple thread safe. If a JobStateReasons object will be used by multiple threads, be sure to synchronize its operations (e.g., using a synchronized set view obtained from class java.util.Collections).

    IPP Compatibility: The string value returned by each individual JobStateReason object's toString() method gives the IPP keyword value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JobStateReasons()
      Construct a new, empty job state reasons attribute; the underlying hash set has the default initial capacity and load factor.
      JobStateReasons(Collection<JobStateReason> collection)
      Construct a new job state reasons attribute that contains the same JobStateReason objects as the given collection.
      JobStateReasons(int initialCapacity)
      Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and the default load factor.
      JobStateReasons(int initialCapacity, float loadFactor)
      Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and load factor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(JobStateReason o)
      Adds the specified element to this job state reasons attribute if it is not already present.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 java.util.HashSet

        clear, clone, contains, isEmpty, iterator, remove, size

      • 方法 - 继承于类 java.util.AbstractSet

        equals, hashCode, removeAll

      • 方法 - 继承于类 java.util.AbstractCollection

        addAll, containsAll, retainAll, toArray, toArray, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.util.Set

        addAll, containsAll, equals, hashCode, removeAll, retainAll, toArray, toArray

    • 构造方法详细信息

      • JobStateReasons

        public JobStateReasons()
        Construct a new, empty job state reasons attribute; the underlying hash set has the default initial capacity and load factor.

      • JobStateReasons

        public JobStateReasons(int initialCapacity)
        Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and the default load factor.
        参数：
        initialCapacity - Initial capacity.
        抛出：
        IllegalArgumentException - if the initial capacity is less than zero.

      • JobStateReasons

        public JobStateReasons(int initialCapacity,
               float loadFactor)
        Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and load factor.
        参数：
        initialCapacity - Initial capacity.
        loadFactor - Load factor.
        抛出：
        IllegalArgumentException - if the initial capacity is less than zero.

      • JobStateReasons

        public JobStateReasons(Collection<JobStateReason> collection)
        Construct a new job state reasons attribute that contains the same JobStateReason objects as the given collection. The underlying hash set's initial capacity and load factor are as specified in the superclass constructor HashSet(Collection).
        参数：
        collection - Collection to copy.
        抛出：
        NullPointerException - (unchecked exception) Thrown if collection is null or if any element in collection is null.
        ClassCastException - (unchecked exception) Thrown if any element in collection is not an instance of class JobStateReason.

    • 方法详细信息

      • add

        public boolean add(JobStateReason o)
        Adds the specified element to this job state reasons attribute if it is not already present. The element to be added must be an instance of class JobStateReason. If this job state reasons attribute already contains the specified element, the call leaves this job state reasons attribute unchanged and returns false.
        指定者：
        add in interface Collection<JobStateReason>
        指定者：
        add in interface Set<JobStateReason>
        重载：
        add in class HashSet<JobStateReason>
        参数：
        o - Element to be added to this job state reasons attribute.
        返回：
        true if this job state reasons attribute did not already contain the specified element.
        抛出：
        NullPointerException - (unchecked exception) Thrown if the specified element is null.
        ClassCastException - (unchecked exception) Thrown if the specified element is not an instance of class JobStateReason.
        从以下版本开始：
        1.5

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class JobStateReasons, the category is class JobStateReasons itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class JobStateReasons, the category name is "job-state-reasons".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.i. t/>"ww>""ataaa///alljal>Anl(llb."..tn##a


Media

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Media

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Media
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
    直接已知子类：
    MediaName, MediaSizeName, MediaTray

    public abstract class Media
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class Media is a printing attribute class that specifies the medium on which to print.

    Media may be specified in different ways.

    • it may be specified by paper source - eg paper tray
    • it may be specified by a standard size - eg "A4"
    • it may be specified by a name - eg "letterhead"
    Each of these corresponds to the IPP "media" attribute. The current API does not support describing media by characteristics (eg colour, opacity). This may be supported in a later revision of the specification.

    A Media object is constructed with a value which represents one of the ways in which the Media attribute can be specified.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Media(int value)
      Constructs a new media attribute specified by name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this media attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getEnumValueTable, getOffset, getStringTable, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Media

        protected Media(int value)
        Constructs a new media attribute specified by name.
        参数：
        value - a value

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this media attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is of the same subclass of Media as this object.
        3. The values are equal.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this media attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Media and any vendor-defined subclasses, the category is class Media itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Media and any vendor-defined subclasses, the category name is "media".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.i>d>nt>na>>naa:r==nhigtiianh iatpniihsaedt s


MediaName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MediaName

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Media
        • javax.print.attribute.standard.MediaName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public class MediaName
extends Media
implements Attribute
    Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.

    This attribute can be used instead of specifying MediaSize or MediaTray.

    Class MediaName currently declares a few standard media names. Implementation- or site-defined names for a media name attribute may also be created by defining a subclass of class MediaName.

    IPP Compatibility: MediaName is a representation class for values of the IPP "media" attribute which names media.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaName ISO_A4_TRANSPARENT
      A4 transparency.
      static MediaName ISO_A4_WHITE
      white A4 paper.
      static MediaName NA_LETTER_TRANSPARENT
      letter transparency.
      static MediaName NA_LETTER_WHITE
      white letter paper.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MediaName(int value)
      Constructs a new media name enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class MediaTray.
      protected String[] getStringTable()
      Returns the string table for class MediaTray.

      • 方法 - 继承于类 javax.print.attribute.standard.Media

        equals, getCategory, getName

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName

    • 字段详细信息

      • NA_LETTER_WHITE

        public static final MediaName NA_LETTER_WHITE
        white letter paper.

      • NA_LETTER_TRANSPARENT

        public static final MediaName NA_LETTER_TRANSPARENT
        letter transparency.

      • ISO_A4_WHITE

        public static final MediaName ISO_A4_WHITE
        white A4 paper.

      • ISO_A4_TRANSPARENT

        public static final MediaName ISO_A4_TRANSPARENT
        A4 transparency.

    • 构造方法详细信息

      • MediaName

        protected MediaName(int value)
        Constructs a new media name enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class MediaTray.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the String table.

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class MediaTray.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the enumeration value table.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atvne'etnsah >aai/e/itati靍ae.a=itbni|t idas


MediaPrintableArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MediaPrintableArea

  • java.lang.Object
    • javax.print.attribute.standard.MediaPrintableArea
  • 所有已实现的接口：
    Serializable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class MediaPrintableArea
extends Object
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.

    The printable area is specified to be a rectangle, within the overall dimensions of a media.

    Most printers cannot print on the entire surface of the media, due to printer hardware limitations. This class can be used to query the acceptable values for a supposed print job, and to request an area within the constraints of the printable area to be used in a print job.

    To query for the printable area, a client must supply a suitable context. Without specifying at the very least the size of the media being used no meaningful value for printable area can be obtained.

    The attribute is not described in terms of the distance from the edge of the paper, in part to emphasise that this attribute is not independent of a particular media, but must be described within the context of a choice of other attributes. Additionally it is usually more convenient for a client to use the printable area.

    The hardware's minimum margins is not just a property of the printer, but may be a function of the media size, orientation, media type, and any specified finishings. PrintService provides the method to query the supported values of an attribute in a suitable context : See PrintService.getSupportedAttributeValues()

    The rectangular printable area is defined thus: The (x,y) origin is positioned at the top-left of the paper in portrait mode regardless of the orientation specified in the requesting context. For example a printable area for A4 paper in portrait or landscape orientation will have height > width.

    A printable area attribute's values are stored internally as integers in units of micrometers (µm), where 1 micrometer = 10-6 meter = 1/1000 millimeter = 1/25400 inch. This permits dimensions to be represented exactly to a precision of 1/1000 mm (= 1 µm) or 1/100 inch (= 254 µm). If fractional inches are expressed in negative powers of two, this permits dimensions to be represented exactly to a precision of 1/8 inch (= 3175 µm) but not 1/16 inch (because 1/16 inch does not equal an integral number of µm).

    IPP Compatibility: MediaPrintableArea is not an IPP attribute.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int INCH
      Value to indicate units of inches (in).
      static int MM
      Value to indicate units of millimeters (mm).

    • 构造方法摘要

      Constructors
      构造方法与描述
      MediaPrintableArea(float x, float y, float w, float h, int units)
      Constructs a MediaPrintableArea object from floating point values.
      MediaPrintableArea(int x, int y, int w, int h, int units)
      Constructs a MediaPrintableArea object from integer values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this media margins attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      float getHeight(int units)
      Get the height of the printable area in the specified units.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      float[] getPrintableArea(int units)
      Get the printable area as an array of 4 values in the order x, y, w, h.
      float getWidth(int units)
      Get the width of the printable area in the specified units.
      float getX(int units)
      Get the x location of the origin of the printable area in the specified units.
      float getY(int units)
      Get the y location of the origin of the printable area in the specified units.
      int hashCode()
      Returns a hash code value for this attribute.
      String toString()
      Returns a string version of this rectangular size attribute in mm.
      String toString(int units, String unitsName)
      Returns a string version of this rectangular size attribute in the given units.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INCH

        public static final int INCH
        Value to indicate units of inches (in). It is actually the conversion factor by which to multiply inches to yield µm (25400).
        另请参见：
        Constant Field Values

      • MM

        public static final int MM
        Value to indicate units of millimeters (mm). It is actually the conversion factor by which to multiply mm to yield µm (1000).
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MediaPrintableArea

        public MediaPrintableArea(float x,
                  float y,
                  float w,
                  float h,
                  int units)
        Constructs a MediaPrintableArea object from floating point values.
        参数：
        x - printable x
        y - printable y
        w - printable width
        h - printable height
        units - in which the values are expressed.
        抛出：
        IllegalArgumentException - Thrown if x < 0 or y < 0 or w <= 0 or h <= 0 or units < 1.

      • MediaPrintableArea

        public MediaPrintableArea(int x,
                  int y,
                  int w,
                  int h,
                  int units)
        Constructs a MediaPrintableArea object from integer values.
        参数：
        x - printable x
        y - printable y
        w - printable width
        h - printable height
        units - in which the values are expressed.
        抛出：
        IllegalArgumentException - Thrown if x < 0 or y < 0 or w <= 0 or h <= 0 or units < 1.

    • 方法详细信息

      • getPrintableArea

        public float[] getPrintableArea(int units)
        Get the printable area as an array of 4 values in the order x, y, w, h. The values returned are in the given units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        printable area as array of x, y, w, h in the specified units.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getX

        public float getX(int units)
        Get the x location of the origin of the printable area in the specified units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        x location of the origin of the printable area in the specified units.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getY

        public float getY(int units)
        Get the y location of the origin of the printable area in the specified units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        y location of the origin of the printable area in the specified units.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getWidth

        public float getWidth(int units)
        Get the width of the printable area in the specified units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        width of the printable area in the specified units.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • getHeight

        public float getHeight(int units)
        Get the height of the printable area in the specified units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        返回：
        height of the printable area in the specified units.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • equals

        public boolean equals(Object object)
        Returns whether this media margins attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class MediaPrintableArea.
        3. The origin and dimensions are the same.
        重载：
        equals in class Object
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this media margins attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class MediaPrintableArea, the category is class MediaPrintableArea itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class MediaPrintableArea, the category name is "media-printable-area".

        This is not an IPP V1.1 attribute.

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.

      • toString

        public String toString(int units,
              String unitsName)
        Returns a string version of this rectangular size attribute in the given units.
        参数：
        units - Unit conversion factor, e.g. INCH or MM.
        unitsName - Units name string, e.g. "in" or "mm". If null, no units name is appended to the result.
        返回：
        String version of this two-dimensional size attribute.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if units < 1.

      • toString

        public String toString()
        Returns a string version of this rectangular size attribute in mm.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • hashCode

        public int hashCode()
        Returns a hash code value for this attribute.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MediaSize

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MediaSize

  • java.lang.Object
    • javax.print.attribute.Size2DSyntax
      • javax.print.attribute.standard.MediaSize
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public class MediaSize
extends Size2DSyntax
implements Attribute
    Class MediaSize is a two-dimensional size valued printing attribute class that indicates the dimensions of the medium in a portrait orientation, with the X dimension running along the bottom edge and the Y dimension running along the left edge. Thus, the Y dimension must be greater than or equal to the X dimension. Class MediaSize declares many standard media size values, organized into nested classes for ISO, JIS, North American, engineering, and other media.

    MediaSize is not yet used to specify media. Its current role is as a mapping for named media (see MediaSizeName). Clients can use the mapping method MediaSize.getMediaSizeForName(MediaSizeName) to find the physical dimensions of the MediaSizeName instances enumerated in this API. This is useful for clients which need this information to format & paginate printing.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  MediaSize.Engineering
      Class MediaSize.Engineering includes MediaSize values for engineering media.
      static class  MediaSize.ISO
      Class MediaSize.ISO includes MediaSize values for ISO media.
      static class  MediaSize.JIS
      Class MediaSize.JIS includes MediaSize values for JIS (Japanese) media.
      static class  MediaSize.NA
      Class MediaSize.NA includes MediaSize values for North American media.
      static class  MediaSize.Other
      Class MediaSize.Other includes MediaSize values for miscellaneous media.

    • 字段摘要

      • Fields inherited from class javax.print.attribute.Size2DSyntax

        INCH, MM

    • 构造方法摘要

      Constructors
      构造方法与描述
      MediaSize(float x, float y, int units)
      Construct a new media size attribute from the given floating-point values.
      MediaSize(float x, float y, int units, MediaSizeName media)
      Construct a new media size attribute from the given floating-point values.
      MediaSize(int x, int y, int units)
      Construct a new media size attribute from the given integer values.
      MediaSize(int x, int y, int units, MediaSizeName media)
      Construct a new media size attribute from the given integer values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this media size attribute is equivalent to the passed in object.
      static MediaSizeName findMedia(float x, float y, int units)
      The specified dimensions are used to locate a matching MediaSize instance from amongst all the standard MediaSize instances.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      static MediaSize getMediaSizeForName(MediaSizeName media)
      Get the MediaSize for the specified named media.
      MediaSizeName getMediaSizeName()
      Get the media name, if any, for this size.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.Size2DSyntax

        getSize, getX, getXMicrometers, getY, getYMicrometers, hashCode, toString, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MediaSize

        public MediaSize(float x,
         float y,
         int units)
        Construct a new media size attribute from the given floating-point values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. Size2DSyntax.INCH or Size2DSyntax.MM.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1 or x > y.

      • MediaSize

        public MediaSize(int x,
         int y,
         int units)
        Construct a new media size attribute from the given integer values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. Size2DSyntax.INCH or Size2DSyntax.MM.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1 or x > y.

      • MediaSize

        public MediaSize(float x,
         float y,
         int units,
         MediaSizeName media)
        Construct a new media size attribute from the given floating-point values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. Size2DSyntax.INCH or Size2DSyntax.MM.
        media - a media name to associate with this MediaSize
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1 or x > y.

      • MediaSize

        public MediaSize(int x,
         int y,
         int units,
         MediaSizeName media)
        Construct a new media size attribute from the given integer values.
        参数：
        x - X dimension.
        y - Y dimension.
        units - Unit conversion factor, e.g. Size2DSyntax.INCH or Size2DSyntax.MM.
        media - a media name to associate with this MediaSize
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if x < 0 or y < 0 or units < 1 or x > y.

    • 方法详细信息

      • getMediaSizeName

        public MediaSizeName getMediaSizeName()
        Get the media name, if any, for this size.
        返回：
        the name for this media size, or null if no name was associated with this size (an anonymous size).

      • getMediaSizeForName

        public static MediaSize getMediaSizeForName(MediaSizeName media)
        Get the MediaSize for the specified named media.
        参数：
        media - - the name of the media for which the size is sought
        返回：
        size of the media, or null if this media is not associated with any size.

      • findMedia

        public static MediaSizeName findMedia(float x,
                      float y,
                      int units)
        The specified dimensions are used to locate a matching MediaSize instance from amongst all the standard MediaSize instances. If there is no exact match, the closest match is used.

        The MediaSize is in turn used to locate the MediaSizeName object. This method may return null if the closest matching MediaSize has no corresponding Media instance.

        This method is useful for clients which have only dimensions and want to find a Media which corresponds to the dimensions.

        参数：
        x - - X dimension
        y - - Y dimension.
        units - Unit conversion factor, e.g. Size2DSyntax.INCH or Size2DSyntax.MM
        返回：
        MediaSizeName matching these dimensions, or null.
        抛出：
        IllegalArgumentException - if x <= 0, y <= 0, or units < 1

      • equals

        public boolean equals(Object object)
        Returns whether this media size attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class MediaSize.
        3. This media size attribute's X dimension is equal to object's X dimension.
        4. This media size attribute's Y dimension is equal to object's Y dimension.
        重载：
        equals in class Size2DSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this media size attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class MediaSize and any vendor-defined subclasses, the category is class MediaSize itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class MediaSize and any vendor-defined subclasses, the category name is "media-size".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<�>ule/nd


MediaSize.Engineering

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute.standard

类 MediaSize.Engineering

  • java.lang.Object
    • javax.print.attribute.standard.MediaSize.Engineering
  • 封闭类：
    MediaSize

    public static final class MediaSize.Engineering
extends Object
    Class MediaSize.Engineering includes MediaSize values for engineering media.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSize A
      Specifies the engineering A size, 8.5 inch by 11 inch.
      static MediaSize B
      Specifies the engineering B size, 11 inch by 17 inch.
      static MediaSize C
      Specifies the engineering C size, 17 inch by 22 inch.
      static MediaSize D
      Specifies the engineering D size, 22 inch by 34 inch.
      static MediaSize E
      Specifies the engineering E size, 34 inch by 44 inch.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • A

        public static final MediaSize A
        Specifies the engineering A size, 8.5 inch by 11 inch.

      • B

        public static final MediaSize B
        Specifies the engineering B size, 11 inch by 17 inch.

      • C

        public static final MediaSize C
        Specifies the engineering C size, 17 inch by 22 inch.

      • D

        public static final MediaSize D
        Specifies the engineering D size, 22 inch by 34 inch.

      • E

        public static final MediaSize E
        Specifies the engineering E size, 34 inch by 44 inch.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cil tv=


MediaSize.ISO

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute.standard

类 MediaSize.ISO

  • java.lang.Object
    • javax.print.attribute.standard.MediaSize.ISO
  • 封闭类：
    MediaSize

    public static final class MediaSize.ISO
extends Object
    Class MediaSize.ISO includes MediaSize values for ISO media.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSize A0
      Specifies the ISO A0 size, 841 mm by 1189 mm.
      static MediaSize A1
      Specifies the ISO A1 size, 594 mm by 841 mm.
      static MediaSize A10
      Specifies the ISO A10 size, 26 mm by 37 mm.
      static MediaSize A2
      Specifies the ISO A2 size, 420 mm by 594 mm.
      static MediaSize A3
      Specifies the ISO A3 size, 297 mm by 420 mm.
      static MediaSize A4
      Specifies the ISO A4 size, 210 mm by 297 mm.
      static MediaSize A5
      Specifies the ISO A5 size, 148 mm by 210 mm.
      static MediaSize A6
      Specifies the ISO A6 size, 105 mm by 148 mm.
      static MediaSize A7
      Specifies the ISO A7 size, 74 mm by 105 mm.
      static MediaSize A8
      Specifies the ISO A8 size, 52 mm by 74 mm.
      static MediaSize A9
      Specifies the ISO A9 size, 37 mm by 52 mm.
      static MediaSize B0
      Specifies the ISO B0 size, 1000 mm by 1414 mm.
      static MediaSize B1
      Specifies the ISO B1 size, 707 mm by 1000 mm.
      static MediaSize B10
      Specifies the ISO B10 size, 31 mm by 44 mm.
      static MediaSize B2
      Specifies the ISO B2 size, 500 mm by 707 mm.
      static MediaSize B3
      Specifies the ISO B3 size, 353 mm by 500 mm.
      static MediaSize B4
      Specifies the ISO B4 size, 250 mm by 353 mm.
      static MediaSize B5
      Specifies the ISO B5 size, 176 mm by 250 mm.
      static MediaSize B6
      Specifies the ISO B6 size, 125 mm by 176 mm.
      static MediaSize B7
      Specifies the ISO B7 size, 88 mm by 125 mm.
      static MediaSize B8
      Specifies the ISO B8 size, 62 mm by 88 mm.
      static MediaSize B9
      Specifies the ISO B9 size, 44 mm by 62 mm.
      static MediaSize C3
      Specifies the ISO C3 size, 324 mm by 458 mm.
      static MediaSize C4
      Specifies the ISO C4 size, 229 mm by 324 mm.
      static MediaSize C5
      Specifies the ISO C5 size, 162 mm by 229 mm.
      static MediaSize C6
      Specifies the ISO C6 size, 114 mm by 162 mm.
      static MediaSize DESIGNATED_LONG
      Specifies the ISO Designated Long size, 110 mm by 220 mm.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • A0

        public static final MediaSize A0
        Specifies the ISO A0 size, 841 mm by 1189 mm.

      • A1

        public static final MediaSize A1
        Specifies the ISO A1 size, 594 mm by 841 mm.

      • A2

        public static final MediaSize A2
        Specifies the ISO A2 size, 420 mm by 594 mm.

      • A3

        public static final MediaSize A3
        Specifies the ISO A3 size, 297 mm by 420 mm.

      • A4

        public static final MediaSize A4
        Specifies the ISO A4 size, 210 mm by 297 mm.

      • A5

        public static final MediaSize A5
        Specifies the ISO A5 size, 148 mm by 210 mm.

      • A6

        public static final MediaSize A6
        Specifies the ISO A6 size, 105 mm by 148 mm.

      • A7

        public static final MediaSize A7
        Specifies the ISO A7 size, 74 mm by 105 mm.

      • A8

        public static final MediaSize A8
        Specifies the ISO A8 size, 52 mm by 74 mm.

      • A9

        public static final MediaSize A9
        Specifies the ISO A9 size, 37 mm by 52 mm.

      • A10

        public static final MediaSize A10
        Specifies the ISO A10 size, 26 mm by 37 mm.

      • B0

        public static final MediaSize B0
        Specifies the ISO B0 size, 1000 mm by 1414 mm.

      • B1

        public static final MediaSize B1
        Specifies the ISO B1 size, 707 mm by 1000 mm.

      • B2

        public static final MediaSize B2
        Specifies the ISO B2 size, 500 mm by 707 mm.

      • B3

        public static final MediaSize B3
        Specifies the ISO B3 size, 353 mm by 500 mm.

      • B4

        public static final MediaSize B4
        Specifies the ISO B4 size, 250 mm by 353 mm.

      • B5

        public static final MediaSize B5
        Specifies the ISO B5 size, 176 mm by 250 mm.

      • B6

        public static final MediaSize B6
        Specifies the ISO B6 size, 125 mm by 176 mm.

      • B7

        public static final MediaSize B7
        Specifies the ISO B7 size, 88 mm by 125 mm.

      • B8

        public static final MediaSize B8
        Specifies the ISO B8 size, 62 mm by 88 mm.

      • B9

        public static final MediaSize B9
        Specifies the ISO B9 size, 44 mm by 62 mm.

      • B10

        public static final MediaSize B10
        Specifies the ISO B10 size, 31 mm by 44 mm.

      • C3

        public static final MediaSize C3
        Specifies the ISO C3 size, 324 mm by 458 mm.

      • C4

        public static final MediaSize C4
        Specifies the ISO C4 size, 229 mm by 324 mm.

      • C5

        public static final MediaSize C5
        Specifies the ISO C5 size, 162 mm by 229 mm.

      • C6

        public static final MediaSize C6
        Specifies the ISO C6 size, 114 mm by 162 mm.

      • DESIGNATED_LONG

        public static final MediaSize DESIGNATED_LONG
        Specifies the ISO Designated Long size, 110 mm by 220 mm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s; l s e =nne" na.. t skslbvv="


MediaSize.JIS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute.standard

类 MediaSize.JIS

  • java.lang.Object
    • javax.print.attribute.standard.MediaSize.JIS
  • 封闭类：
    MediaSize

    public static final class MediaSize.JIS
extends Object
    Class MediaSize.JIS includes MediaSize values for JIS (Japanese) media. *

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSize B0
      Specifies the JIS B0 size, 1030 mm by 1456 mm.
      static MediaSize B1
      Specifies the JIS B1 size, 728 mm by 1030 mm.
      static MediaSize B10
      Specifies the JIS B10 size, 32 mm by 45 mm.
      static MediaSize B2
      Specifies the JIS B2 size, 515 mm by 728 mm.
      static MediaSize B3
      Specifies the JIS B3 size, 364 mm by 515 mm.
      static MediaSize B4
      Specifies the JIS B4 size, 257 mm by 364 mm.
      static MediaSize B5
      Specifies the JIS B5 size, 182 mm by 257 mm.
      static MediaSize B6
      Specifies the JIS B6 size, 128 mm by 182 mm.
      static MediaSize B7
      Specifies the JIS B7 size, 91 mm by 128 mm.
      static MediaSize B8
      Specifies the JIS B8 size, 64 mm by 91 mm.
      static MediaSize B9
      Specifies the JIS B9 size, 45 mm by 64 mm.
      static MediaSize CHOU_1
      Specifies the JIS Chou ("long") #1 envelope size, 142 mm by 332 mm.
      static MediaSize CHOU_2
      Specifies the JIS Chou ("long") #2 envelope size, 119 mm by 277 mm.
      static MediaSize CHOU_3
      Specifies the JIS Chou ("long") #3 envelope size, 120 mm by 235 mm.
      static MediaSize CHOU_30
      Specifies the JIS Chou ("long") #30 envelope size, 92 mm by 235 mm.
      static MediaSize CHOU_4
      Specifies the JIS Chou ("long") #4 envelope size, 90 mm by 205 mm.
      static MediaSize CHOU_40
      Specifies the JIS Chou ("long") #40 envelope size, 90 mm by 225 mm.
      static MediaSize KAKU_0
      Specifies the JIS Kaku ("square") #0 envelope size, 287 mm by 382 mm.
      static MediaSize KAKU_1
      Specifies the JIS Kaku ("square") #1 envelope size, 270 mm by 382 mm.
      static MediaSize KAKU_2
      Specifies the JIS Kaku ("square") #2 envelope size, 240 mm by 332 mm.
      static MediaSize KAKU_20
      Specifies the JIS Kaku ("square") #20 envelope size, 229 mm by 324 mm.
      static MediaSize KAKU_3
      Specifies the JIS Kaku ("square") #3 envelope size, 216 mm by 277 mm.
      static MediaSize KAKU_4
      Specifies the JIS Kaku ("square") #4 envelope size, 197 mm by 267 mm.
      static MediaSize KAKU_5
      Specifies the JIS Kaku ("square") #5 envelope size, 190 mm by 240 mm.
      static MediaSize KAKU_6
      Specifies the JIS Kaku ("square") #6 envelope size, 162 mm by 229 mm.
      static MediaSize KAKU_7
      Specifies the JIS Kaku ("square") #7 envelope size, 142 mm by 205 mm.
      static MediaSize KAKU_8
      Specifies the JIS Kaku ("square") #8 envelope size, 119 mm by 197 mm.
      static MediaSize KAKU_A4
      Specifies the JIS Kaku ("square") A4 envelope size, 228 mm by 312 mm.
      static MediaSize YOU_1
      Specifies the JIS You ("Western") #1 envelope size, 120 mm by 176 mm.
      static MediaSize YOU_2
      Specifies the JIS You ("Western") #2 envelope size, 114 mm by 162 mm.
      static MediaSize YOU_3
      Specifies the JIS You ("Western") #3 envelope size, 98 mm by 148 mm.
      static MediaSize YOU_4
      Specifies the JIS You ("Western") #4 envelope size, 105 mm by 235 mm.
      static MediaSize YOU_5
      Specifies the JIS You ("Western") #5 envelope size, 95 mm by 217 mm.
      static MediaSize YOU_6
      Specifies the JIS You ("Western") #6 envelope size, 98 mm by 190 mm.
      static MediaSize YOU_7
      Specifies the JIS You ("Western") #7 envelope size, 92 mm by 165 mm.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • B0

        public static final MediaSize B0
        Specifies the JIS B0 size, 1030 mm by 1456 mm.

      • B1

        public static final MediaSize B1
        Specifies the JIS B1 size, 728 mm by 1030 mm.

      • B2

        public static final MediaSize B2
        Specifies the JIS B2 size, 515 mm by 728 mm.

      • B3

        public static final MediaSize B3
        Specifies the JIS B3 size, 364 mm by 515 mm.

      • B4

        public static final MediaSize B4
        Specifies the JIS B4 size, 257 mm by 364 mm.

      • B5

        public static final MediaSize B5
        Specifies the JIS B5 size, 182 mm by 257 mm.

      • B6

        public static final MediaSize B6
        Specifies the JIS B6 size, 128 mm by 182 mm.

      • B7

        public static final MediaSize B7
        Specifies the JIS B7 size, 91 mm by 128 mm.

      • B8

        public static final MediaSize B8
        Specifies the JIS B8 size, 64 mm by 91 mm.

      • B9

        public static final MediaSize B9
        Specifies the JIS B9 size, 45 mm by 64 mm.

      • B10

        public static final MediaSize B10
        Specifies the JIS B10 size, 32 mm by 45 mm.

      • CHOU_1

        public static final MediaSize CHOU_1
        Specifies the JIS Chou ("long") #1 envelope size, 142 mm by 332 mm.

      • CHOU_2

        public static final MediaSize CHOU_2
        Specifies the JIS Chou ("long") #2 envelope size, 119 mm by 277 mm.

      • CHOU_3

        public static final MediaSize CHOU_3
        Specifies the JIS Chou ("long") #3 envelope size, 120 mm by 235 mm.

      • CHOU_4

        public static final MediaSize CHOU_4
        Specifies the JIS Chou ("long") #4 envelope size, 90 mm by 205 mm.

      • CHOU_30

        public static final MediaSize CHOU_30
        Specifies the JIS Chou ("long") #30 envelope size, 92 mm by 235 mm.

      • CHOU_40

        public static final MediaSize CHOU_40
        Specifies the JIS Chou ("long") #40 envelope size, 90 mm by 225 mm.

      • KAKU_0

        public static final MediaSize KAKU_0
        Specifies the JIS Kaku ("square") #0 envelope size, 287 mm by 382 mm.

      • KAKU_1

        public static final MediaSize KAKU_1
        Specifies the JIS Kaku ("square") #1 envelope size, 270 mm by 382 mm.

      • KAKU_2

        public static final MediaSize KAKU_2
        Specifies the JIS Kaku ("square") #2 envelope size, 240 mm by 332 mm.

      • KAKU_3

        public static final MediaSize KAKU_3
        Specifies the JIS Kaku ("square") #3 envelope size, 216 mm by 277 mm.

      • KAKU_4

        public static final MediaSize KAKU_4
        Specifies the JIS Kaku ("square") #4 envelope size, 197 mm by 267 mm.

      • KAKU_5

        public static final MediaSize KAKU_5
        Specifies the JIS Kaku ("square") #5 envelope size, 190 mm by 240 mm.

      • KAKU_6

        public static final MediaSize KAKU_6
        Specifies the JIS Kaku ("square") #6 envelope size, 162 mm by 229 mm.

      • KAKU_7

        public static final MediaSize KAKU_7
        Specifies the JIS Kaku ("square") #7 envelope size, 142 mm by 205 mm.

      • KAKU_8

        public static final MediaSize KAKU_8
        Specifies the JIS Kaku ("square") #8 envelope size, 119 mm by 197 mm.

      • KAKU_20

        public static final MediaSize KAKU_20
        Specifies the JIS Kaku ("square") #20 envelope size, 229 mm by 324 mm.

      • KAKU_A4

        public static final MediaSize KAKU_A4
        Specifies the JIS Kaku ("square") A4 envelope size, 228 mm by 312 mm.

      • YOU_1

        public static final MediaSize YOU_1
        Specifies the JIS You ("Western") #1 envelope size, 120 mm by 176 mm.

      • YOU_2

        public static final MediaSize YOU_2
        Specifies the JIS You ("Western") #2 envelope size, 114 mm by 162 mm.

      • YOU_3

        public static final MediaSize YOU_3
        Specifies the JIS You ("Western") #3 envelope size, 98 mm by 148 mm.

      • YOU_4

        public static final MediaSize YOU_4
        Specifies the JIS You ("Western") #4 envelope size, 105 mm by 235 mm.

      • YOU_5

        public static final MediaSize YOU_5
        Specifies the JIS You ("Western") #5 envelope size, 95 mm by 217 mm.

      • YOU_6

        public static final MediaSize YOU_6
        Specifies the JIS You ("Western") #6 envelope size, 98 mm by 190 mm.

      • YOU_7

        public static final MediaSize YOU_7
        Specifies the JIS You ("Western") #7 envelope size, 92 mm by 165 mm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method


MediaSize.NA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute.standard

类 MediaSize.NA

  • java.lang.Object
    • javax.print.attribute.standard.MediaSize.NA
  • 封闭类：
    MediaSize

    public static final class MediaSize.NA
extends Object
    Class MediaSize.NA includes MediaSize values for North American media.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSize LEGAL
      Specifies the North American legal size, 8.5 inches by 14 inches.
      static MediaSize LETTER
      Specifies the North American letter size, 8.5 inches by 11 inches.
      static MediaSize NA_10x13_ENVELOPE
      Specifies the North American 10 inch by 13 inch envelope size.
      static MediaSize NA_10x14_ENVELOPE
      Specifies the North American 10 inch by 14 inch envelope size.
      static MediaSize NA_10X15_ENVELOPE
      Specifies the North American 10 inch by 15 inch envelope size.
      static MediaSize NA_5X7
      Specifies the North American 5 inch by 7 inch paper.
      static MediaSize NA_6X9_ENVELOPE
      Specifies the North American 6 inch by 9 inch envelope size.
      static MediaSize NA_7X9_ENVELOPE
      Specifies the North American 7 inch by 9 inch envelope size.
      static MediaSize NA_8X10
      Specifies the North American 8 inch by 10 inch paper.
      static MediaSize NA_9x11_ENVELOPE
      Specifies the North American 9 inch by 11 inch envelope size.
      static MediaSize NA_9x12_ENVELOPE
      Specifies the North American 9 inch by 12 inch envelope size.
      static MediaSize NA_NUMBER_10_ENVELOPE
      Specifies the North American Number 10 business envelope size, 4.125 inches by 9.5 inches.
      static MediaSize NA_NUMBER_11_ENVELOPE
      Specifies the North American Number 11 business envelope size, 4.5 inches by 10.375 inches.
      static MediaSize NA_NUMBER_12_ENVELOPE
      Specifies the North American Number 12 business envelope size, 4.75 inches by 11 inches.
      static MediaSize NA_NUMBER_14_ENVELOPE
      Specifies the North American Number 14 business envelope size, 5 inches by 11.5 inches.
      static MediaSize NA_NUMBER_9_ENVELOPE
      Specifies the North American Number 9 business envelope size, 3.875 inches by 8.875 inches.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LETTER

        public static final MediaSize LETTER
        Specifies the North American letter size, 8.5 inches by 11 inches.

      • LEGAL

        public static final MediaSize LEGAL
        Specifies the North American legal size, 8.5 inches by 14 inches.

      • NA_5X7

        public static final MediaSize NA_5X7
        Specifies the North American 5 inch by 7 inch paper.

      • NA_8X10

        public static final MediaSize NA_8X10
        Specifies the North American 8 inch by 10 inch paper.

      • NA_NUMBER_9_ENVELOPE

        public static final MediaSize NA_NUMBER_9_ENVELOPE
        Specifies the North American Number 9 business envelope size, 3.875 inches by 8.875 inches.

      • NA_NUMBER_10_ENVELOPE

        public static final MediaSize NA_NUMBER_10_ENVELOPE
        Specifies the North American Number 10 business envelope size, 4.125 inches by 9.5 inches.

      • NA_NUMBER_11_ENVELOPE

        public static final MediaSize NA_NUMBER_11_ENVELOPE
        Specifies the North American Number 11 business envelope size, 4.5 inches by 10.375 inches.

      • NA_NUMBER_12_ENVELOPE

        public static final MediaSize NA_NUMBER_12_ENVELOPE
        Specifies the North American Number 12 business envelope size, 4.75 inches by 11 inches.

      • NA_NUMBER_14_ENVELOPE

        public static final MediaSize NA_NUMBER_14_ENVELOPE
        Specifies the North American Number 14 business envelope size, 5 inches by 11.5 inches.

      • NA_6X9_ENVELOPE

        public static final MediaSize NA_6X9_ENVELOPE
        Specifies the North American 6 inch by 9 inch envelope size.

      • NA_7X9_ENVELOPE

        public static final MediaSize NA_7X9_ENVELOPE
        Specifies the North American 7 inch by 9 inch envelope size.

      • NA_9x11_ENVELOPE

        public static final MediaSize NA_9x11_ENVELOPE
        Specifies the North American 9 inch by 11 inch envelope size.

      • NA_9x12_ENVELOPE

        public static final MediaSize NA_9x12_ENVELOPE
        Specifies the North American 9 inch by 12 inch envelope size.

      • NA_10x13_ENVELOPE

        public static final MediaSize NA_10x13_ENVELOPE
        Specifies the North American 10 inch by 13 inch envelope size.

      • NA_10x14_ENVELOPE

        public static final MediaSize NA_10x14_ENVELOPE
        Specifies the North American 10 inch by 14 inch envelope size.

      • NA_10X15_ENVELOPE

        public static final MediaSize NA_10X15_ENVELOPE
        Specifies the North American 10 inch by 15 inch envelope size.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j a"ttmitmtllmttidbb/<3 hh seu.


MediaSize.Other

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.print.attribute.standard

类 MediaSize.Other

  • java.lang.Object
    • javax.print.attribute.standard.MediaSize.Other
  • 封闭类：
    MediaSize

    public static final class MediaSize.Other
extends Object
    Class MediaSize.Other includes MediaSize values for miscellaneous media.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSize EXECUTIVE
      Specifies the executive size, 7.25 inches by 10.5 inches.
      static MediaSize FOLIO
      Specifies the folio size, 8.5 inches by 13 inches.
      static MediaSize INVOICE
      Specifies the invoice size, 5.5 inches by 8.5 inches.
      static MediaSize ITALY_ENVELOPE
      Specifies the Italy envelope size, 110 mm by 230 mm.
      static MediaSize JAPANESE_DOUBLE_POSTCARD
      Specifies the Japanese Double postcard size, 148 mm by 200 mm.
      static MediaSize JAPANESE_POSTCARD
      Specifies the Japanese postcard size, 100 mm by 148 mm.
      static MediaSize LEDGER
      Specifies the ledger size, 11 inches by 17 inches.
      static MediaSize MONARCH_ENVELOPE
      Specifies the Monarch envelope size, 3.87 inch by 7.5 inch.
      static MediaSize PERSONAL_ENVELOPE
      Specifies the Personal envelope size, 3.625 inch by 6.5 inch.
      static MediaSize QUARTO
      Specifies the quarto size, 8.5 inches by 10.83 inches.
      static MediaSize TABLOID
      Specifies the tabloid size, 11 inches by 17 inches.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EXECUTIVE

        public static final MediaSize EXECUTIVE
        Specifies the executive size, 7.25 inches by 10.5 inches.

      • LEDGER

        public static final MediaSize LEDGER
        Specifies the ledger size, 11 inches by 17 inches.

      • TABLOID

        public static final MediaSize TABLOID
        Specifies the tabloid size, 11 inches by 17 inches.
        从以下版本开始：
        1.5

      • INVOICE

        public static final MediaSize INVOICE
        Specifies the invoice size, 5.5 inches by 8.5 inches.

      • FOLIO

        public static final MediaSize FOLIO
        Specifies the folio size, 8.5 inches by 13 inches.

      • QUARTO

        public static final MediaSize QUARTO
        Specifies the quarto size, 8.5 inches by 10.83 inches.

      • ITALY_ENVELOPE

        public static final MediaSize ITALY_ENVELOPE
        Specifies the Italy envelope size, 110 mm by 230 mm.

      • MONARCH_ENVELOPE

        public static final MediaSize MONARCH_ENVELOPE
        Specifies the Monarch envelope size, 3.87 inch by 7.5 inch.

      • PERSONAL_ENVELOPE

        public static final MediaSize PERSONAL_ENVELOPE
        Specifies the Personal envelope size, 3.625 inch by 6.5 inch.

      • JAPANESE_POSTCARD

        public static final MediaSize JAPANESE_POSTCARD
        Specifies the Japanese postcard size, 100 mm by 148 mm.

      • JAPANESE_DOUBLE_POSTCARD

        public static final MediaSize JAPANESE_DOUBLE_POSTCARD
        Specifies the Japanese Double postcard size, 148 mm by 200 mm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iacu


MediaSizeName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MediaSizeName

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Media
        • javax.print.attribute.standard.MediaSizeName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public class MediaSizeName
extends Media
    Class MediaSizeName is a subclass of Media.

    This attribute can be used instead of specifying MediaName or MediaTray.

    Class MediaSizeName currently declares a few standard media name values.

    IPP Compatibility: MediaSizeName is a representation class for values of the IPP "media" attribute which names media sizes. The names of the media sizes correspond to those in the IPP 1.1 RFC RFC 2911

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaSizeName A
      A size .
      static MediaSizeName B
      B size .
      static MediaSizeName C
      C size .
      static MediaSizeName D
      D size .
      static MediaSizeName E
      E size .
      static MediaSizeName EXECUTIVE
      executive size .
      static MediaSizeName FOLIO
      folio size .
      static MediaSizeName INVOICE
      invoice size .
      static MediaSizeName ISO_A0
      A0 size.
      static MediaSizeName ISO_A1
      A1 size.
      static MediaSizeName ISO_A10
      A10 size.
      static MediaSizeName ISO_A2
      A2 size.
      static MediaSizeName ISO_A3
      A3 size.
      static MediaSizeName ISO_A4
      A4 size.
      static MediaSizeName ISO_A5
      A5 size.
      static MediaSizeName ISO_A6
      A6 size.
      static MediaSizeName ISO_A7
      A7 size.
      static MediaSizeName ISO_A8
      A8 size.
      static MediaSizeName ISO_A9
      A9 size.
      static MediaSizeName ISO_B0
      ISO B0 size.
      static MediaSizeName ISO_B1
      ISO B1 size.
      static MediaSizeName ISO_B10
      ISO B10 size.
      static MediaSizeName ISO_B2
      ISO B2 size.
      static MediaSizeName ISO_B3
      ISO B3 size.
      static MediaSizeName ISO_B4
      ISO B4 size.
      static MediaSizeName ISO_B5
      ISO B5 size.
      static MediaSizeName ISO_B6
      ISO B6 size.
      static MediaSizeName ISO_B7
      ISO B7 size.
      static MediaSizeName ISO_B8
      ISO B8 size.
      static MediaSizeName ISO_B9
      ISO B9 size.
      static MediaSizeName ISO_C0
      ISO C0 size.
      static MediaSizeName ISO_C1
      ISO C1 size.
      static MediaSizeName ISO_C2
      ISO C2 size.
      static MediaSizeName ISO_C3
      ISO C3 size.
      static MediaSizeName ISO_C4
      ISO C4 size.
      static MediaSizeName ISO_C5
      ISO C5 size.
      static MediaSizeName ISO_C6
      letter size.
      static MediaSizeName ISO_DESIGNATED_LONG
      ISO designated long size .
      static MediaSizeName ITALY_ENVELOPE
      Italy envelope size .
      static MediaSizeName JAPANESE_DOUBLE_POSTCARD
      Japanese Double Postcard size.
      static MediaSizeName JAPANESE_POSTCARD
      Japanese Postcard size.
      static MediaSizeName JIS_B0
      JIS B0 size.
      static MediaSizeName JIS_B1
      JIS B1 size.
      static MediaSizeName JIS_B10
      JIS B10 size.
      static MediaSizeName JIS_B2
      JIS B2 size.
      static MediaSizeName JIS_B3
      JIS B3 size.
      static MediaSizeName JIS_B4
      JIS B4 size.
      static MediaSizeName JIS_B5
      JIS B5 size.
      static MediaSizeName JIS_B6
      JIS B6 size.
      static MediaSizeName JIS_B7
      JIS B7 size.
      static MediaSizeName JIS_B8
      JIS B8 size.
      static MediaSizeName JIS_B9
      JIS B9 size.
      static MediaSizeName LEDGER
      ledger size .
      static MediaSizeName MONARCH_ENVELOPE
      monarch envelope size .
      static MediaSizeName NA_10X13_ENVELOPE
      10x13 North American envelope size .
      static MediaSizeName NA_10X14_ENVELOPE
      10x14North American envelope size .
      static MediaSizeName NA_10X15_ENVELOPE
      10x15 North American envelope size.
      static MediaSizeName NA_5X7
      5x7 North American paper.
      static MediaSizeName NA_6X9_ENVELOPE
      6x9 North American envelope size.
      static MediaSizeName NA_7X9_ENVELOPE
      7x9 North American envelope size.
      static MediaSizeName NA_8X10
      8x10 North American paper.
      static MediaSizeName NA_9X11_ENVELOPE
      9x11 North American envelope size.
      static MediaSizeName NA_9X12_ENVELOPE
      9x12 North American envelope size.
      static MediaSizeName NA_LEGAL
      legal size .
      static MediaSizeName NA_LETTER
      letter size.
      static MediaSizeName NA_NUMBER_10_ENVELOPE
      number 10 envelope size .
      static MediaSizeName NA_NUMBER_11_ENVELOPE
      number 11 envelope size .
      static MediaSizeName NA_NUMBER_12_ENVELOPE
      number 12 envelope size .
      static MediaSizeName NA_NUMBER_14_ENVELOPE
      number 14 envelope size .
      static MediaSizeName NA_NUMBER_9_ENVELOPE
      number 9 envelope size .
      static MediaSizeName PERSONAL_ENVELOPE
      personal envelope size .
      static MediaSizeName QUARTO
      quarto size .
      static MediaSizeName TABLOID
      tabloid size .

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MediaSizeName(int value)
      Construct a new media size enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class MediaSizeName.
      protected String[] getStringTable()
      Returns the string table for class MediaSizeName.

      • 方法 - 继承于类 javax.print.attribute.standard.Media

        equals, getCategory, getName

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ISO_A0

        public static final MediaSizeName ISO_A0
        A0 size.

      • ISO_A1

        public static final MediaSizeName ISO_A1
        A1 size.

      • ISO_A2

        public static final MediaSizeName ISO_A2
        A2 size.

      • ISO_A3

        public static final MediaSizeName ISO_A3
        A3 size.

      • ISO_A4

        public static final MediaSizeName ISO_A4
        A4 size.

      • ISO_A5

        public static final MediaSizeName ISO_A5
        A5 size.

      • ISO_A6

        public static final MediaSizeName ISO_A6
        A6 size.

      • ISO_A7

        public static final MediaSizeName ISO_A7
        A7 size.

      • ISO_A8

        public static final MediaSizeName ISO_A8
        A8 size.

      • ISO_A9

        public static final MediaSizeName ISO_A9
        A9 size.

      • ISO_A10

        public static final MediaSizeName ISO_A10
        A10 size.

      • ISO_B0

        public static final MediaSizeName ISO_B0
        ISO B0 size.

      • ISO_B1

        public static final MediaSizeName ISO_B1
        ISO B1 size.

      • ISO_B2

        public static final MediaSizeName ISO_B2
        ISO B2 size.

      • ISO_B3

        public static final MediaSizeName ISO_B3
        ISO B3 size.

      • ISO_B4

        public static final MediaSizeName ISO_B4
        ISO B4 size.

      • ISO_B5

        public static final MediaSizeName ISO_B5
        ISO B5 size.

      • ISO_B6

        public static final MediaSizeName ISO_B6
        ISO B6 size.

      • ISO_B7

        public static final MediaSizeName ISO_B7
        ISO B7 size.

      • ISO_B8

        public static final MediaSizeName ISO_B8
        ISO B8 size.

      • ISO_B9

        public static final MediaSizeName ISO_B9
        ISO B9 size.

      • ISO_B10

        public static final MediaSizeName ISO_B10
        ISO B10 size.

      • JIS_B0

        public static final MediaSizeName JIS_B0
        JIS B0 size.

      • JIS_B1

        public static final MediaSizeName JIS_B1
        JIS B1 size.

      • JIS_B2

        public static final MediaSizeName JIS_B2
        JIS B2 size.

      • JIS_B3

        public static final MediaSizeName JIS_B3
        JIS B3 size.

      • JIS_B4

        public static final MediaSizeName JIS_B4
        JIS B4 size.

      • JIS_B5

        public static final MediaSizeName JIS_B5
        JIS B5 size.

      • JIS_B6

        public static final MediaSizeName JIS_B6
        JIS B6 size.

      • JIS_B7

        public static final MediaSizeName JIS_B7
        JIS B7 size.

      • JIS_B8

        public static final MediaSizeName JIS_B8
        JIS B8 size.

      • JIS_B9

        public static final MediaSizeName JIS_B9
        JIS B9 size.

      • JIS_B10

        public static final MediaSizeName JIS_B10
        JIS B10 size.

      • ISO_C0

        public static final MediaSizeName ISO_C0
        ISO C0 size.

      • ISO_C1

        public static final MediaSizeName ISO_C1
        ISO C1 size.

      • ISO_C2

        public static final MediaSizeName ISO_C2
        ISO C2 size.

      • ISO_C3

        public static final MediaSizeName ISO_C3
        ISO C3 size.

      • ISO_C4

        public static final MediaSizeName ISO_C4
        ISO C4 size.

      • ISO_C5

        public static final MediaSizeName ISO_C5
        ISO C5 size.

      • ISO_C6

        public static final MediaSizeName ISO_C6
        letter size.

      • NA_LETTER

        public static final MediaSizeName NA_LETTER
        letter size.

      • NA_LEGAL

        public static final MediaSizeName NA_LEGAL
        legal size .

      • EXECUTIVE

        public static final MediaSizeName EXECUTIVE
        executive size .

      • LEDGER

        public static final MediaSizeName LEDGER
        ledger size .

      • TABLOID

        public static final MediaSizeName TABLOID
        tabloid size .

      • INVOICE

        public static final MediaSizeName INVOICE
        invoice size .

      • FOLIO

        public static final MediaSizeName FOLIO
        folio size .

      • QUARTO

        public static final MediaSizeName QUARTO
        quarto size .

      • JAPANESE_POSTCARD

        public static final MediaSizeName JAPANESE_POSTCARD
        Japanese Postcard size.

      • JAPANESE_DOUBLE_POSTCARD

        public static final MediaSizeName JAPANESE_DOUBLE_POSTCARD
        Japanese Double Postcard size.

      • A

        public static final MediaSizeName A
        A size .

      • B

        public static final MediaSizeName B
        B size .

      • C

        public static final MediaSizeName C
        C size .

      • D

        public static final MediaSizeName D
        D size .

      • E

        public static final MediaSizeName E
        E size .

      • ISO_DESIGNATED_LONG

        public static final MediaSizeName ISO_DESIGNATED_LONG
        ISO designated long size .

      • ITALY_ENVELOPE

        public static final MediaSizeName ITALY_ENVELOPE
        Italy envelope size .

      • MONARCH_ENVELOPE

        public static final MediaSizeName MONARCH_ENVELOPE
        monarch envelope size .

      • PERSONAL_ENVELOPE

        public static final MediaSizeName PERSONAL_ENVELOPE
        personal envelope size .

      • NA_NUMBER_9_ENVELOPE

        public static final MediaSizeName NA_NUMBER_9_ENVELOPE
        number 9 envelope size .

      • NA_NUMBER_10_ENVELOPE

        public static final MediaSizeName NA_NUMBER_10_ENVELOPE
        number 10 envelope size .

      • NA_NUMBER_11_ENVELOPE

        public static final MediaSizeName NA_NUMBER_11_ENVELOPE
        number 11 envelope size .

      • NA_NUMBER_12_ENVELOPE

        public static final MediaSizeName NA_NUMBER_12_ENVELOPE
        number 12 envelope size .

      • NA_NUMBER_14_ENVELOPE

        public static final MediaSizeName NA_NUMBER_14_ENVELOPE
        number 14 envelope size .

      • NA_6X9_ENVELOPE

        public static final MediaSizeName NA_6X9_ENVELOPE
        6x9 North American envelope size.

      • NA_7X9_ENVELOPE

        public static final MediaSizeName NA_7X9_ENVELOPE
        7x9 North American envelope size.

      • NA_9X11_ENVELOPE

        public static final MediaSizeName NA_9X11_ENVELOPE
        9x11 North American envelope size.

      • NA_9X12_ENVELOPE

        public static final MediaSizeName NA_9X12_ENVELOPE
        9x12 North American envelope size.

      • NA_10X13_ENVELOPE

        public static final MediaSizeName NA_10X13_ENVELOPE
        10x13 North American envelope size .

      • NA_10X14_ENVELOPE

        public static final MediaSizeName NA_10X14_ENVELOPE
        10x14North American envelope size .

      • NA_10X15_ENVELOPE

        public static final MediaSizeName NA_10X15_ENVELOPE
        10x15 North American envelope size.

      • NA_5X7

        public static final MediaSizeName NA_5X7
        5x7 North American paper.

      • NA_8X10

        public static final MediaSizeName NA_8X10
        8x10 North American paper.

    • 构造方法详细信息

      • MediaSizeName

        protected MediaSizeName(int value)
        Construct a new media size enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class MediaSizeName.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class MediaSizeName.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MediaTray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MediaTray

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Media
        • javax.print.attribute.standard.MediaTray
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public class MediaTray
extends Media
implements Attribute
    Class MediaTray is a subclass of Media. Class MediaTray is a printing attribute class, an enumeration, that specifies the media tray or bin for the job. This attribute can be used instead of specifying MediaSize or MediaName.

    Class MediaTray declares keywords for standard media kind values. Implementation- or site-defined names for a media kind attribute may also be created by defining a subclass of class MediaTray.

    IPP Compatibility: MediaTray is a representation class for values of the IPP "media" attribute which name paper trays.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MediaTray BOTTOM
      The bottom input tray in the printer.
      static MediaTray ENVELOPE
      The envelope input tray in the printer.
      static MediaTray LARGE_CAPACITY
      The large capacity input tray in the printer.
      static MediaTray MAIN
      The main input tray in the printer.
      static MediaTray MANUAL
      The manual feed input tray in the printer.
      static MediaTray MIDDLE
      The middle input tray in the printe.
      static MediaTray SIDE
      The side input tray.
      static MediaTray TOP
      The top input tray in the printer.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MediaTray(int value)
      Construct a new media tray enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class MediaTray.
      protected String[] getStringTable()
      Returns the string table for class MediaTray.

      • 方法 - 继承于类 javax.print.attribute.standard.Media

        equals, getCategory, getName

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.print.attribute.Attribute

        getCategory, getName

    • 字段详细信息

      • TOP

        public static final MediaTray TOP
        The top input tray in the printer.

      • MIDDLE

        public static final MediaTray MIDDLE
        The middle input tray in the printe.

      • BOTTOM

        public static final MediaTray BOTTOM
        The bottom input tray in the printer.

      • ENVELOPE

        public static final MediaTray ENVELOPE
        The envelope input tray in the printer.

      • MANUAL

        public static final MediaTray MANUAL
        The manual feed input tray in the printer.

      • LARGE_CAPACITY

        public static final MediaTray LARGE_CAPACITY
        The large capacity input tray in the printer.

      • MAIN

        public static final MediaTray MAIN
        The main input tray in the printer.

      • SIDE

        public static final MediaTray SIDE
        The side input tray.

    • 构造方法详细信息

      • MediaTray

        protected MediaTray(int value)
        Construct a new media tray enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class MediaTray.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class MediaTray.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt#zeirdiraddraastvv/>a"ntrtttrjduts


MultipleDocumentHandling

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 MultipleDocumentHandling

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.MultipleDocumentHandling
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public class MultipleDocumentHandling
extends EnumSyntax
implements PrintRequestAttribute, PrintJobAttribute
    Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets. When the value of the Copies attribute exceeds 1, MultipleDocumentHandling also controls the order in which the copies that result from processing the documents are produced. This attribute is relevant only for a multidoc print job consisting of two or more individual docs.

    Briefly, MultipleDocumentHandling determines the relationship between the multiple input (electronic) documents fed into a multidoc print job and the output (physical) document or documents produced by the multidoc print job. There are two possibilities:

    • The multiple input documents are combined into a single output document. Finishing operations (Finishings), are performed on this single output document. The Copies attribute tells how many copies of this single output document to produce. The MultipleDocumentHandling values SINGLE_DOCUMENT and SINGLE_DOCUMENT_NEW_SHEET specify two variations of this possibility.

    • The multiple input documents remain separate output documents. Finishing operations (Finishings), are performed on each output document separately. The Copies attribute tells how many copies of each separate output document to produce. The MultipleDocumentHandling values SEPARATE_DOCUMENTS_UNCOLLATED_COPIES and SEPARATE_DOCUMENTS_COLLATED_COPIES specify two variations of this possibility.

    In the detailed explanations below, if "a" represents an instance of document data, then the result of processing the data in document "a" is a sequence of media sheets represented by "a(*)".

    The standard MultipleDocumentHandling values are:

    • SINGLE_DOCUMENT. If a print job has multiple documents -- say, the document data is called a and b -- then the result of processing all the document data (a and then b) must be treated as a single sequence of media sheets for finishing operations; that is, finishing would be performed on the concatenation of the sequences a(*),b(*). The printer must not force the data in each document instance to be formatted onto a new print-stream page, nor to start a new impression on a new media sheet. If more than one copy is made, the ordering of the sets of media sheets resulting from processing the document data must be a(*),b(*),a(*),b(*),..., and the printer object must force each copy (a(*),b(*)) to start on a new media sheet.

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES. If a print job has multiple documents -- say, the document data is called a and b -- then the result of processing the data in each document instance must be treated as a single sequence of media sheets for finishing operations; that is, the sets a(*) and b(*) would each be finished separately. The printer must force each copy of the result of processing the data in a single document to start on a new media sheet. If more than one copy is made, the ordering of the sets of media sheets resulting from processing the document data must be a(*),a(*),...,b(*),b(*)....

    • SEPARATE_DOCUMENTS_COLLATED_COPIES. If a print job has multiple documents -- say, the document data is called a and b -- then the result of processing the data in each document instance must be treated as a single sequence of media sheets for finishing operations; that is, the sets a(*) and b(*) would each be finished separately. The printer must force each copy of the result of processing the data in a single document to start on a new media sheet. If more than one copy is made, the ordering of the sets of media sheets resulting from processing the document data must be a(*),b(*),a(*),b(*),....

    • SINGLE_DOCUMENT_NEW_SHEET. Same as SINGLE_DOCUMENT, except that the printer must ensure that the first impression of each document instance in the job is placed on a new media sheet. This value allows multiple documents to be stapled together with a single staple where each document starts on a new sheet.

    SINGLE_DOCUMENT is the same as SEPARATE_DOCUMENTS_COLLATED_COPIES with respect to ordering of print-stream pages, but not media sheet generation, since SINGLE_DOCUMENT will put the first page of the next document on the back side of a sheet if an odd number of pages have been produced so far for the job, while SEPARATE_DOCUMENTS_COLLATED_COPIES always forces the next document or document copy on to a new sheet.

    In addition, if a Finishings attribute of STAPLE is specified, then:

    • With SINGLE_DOCUMENT, documents a and b are stapled together as a single document with no regard to new sheets.

    • With SINGLE_DOCUMENT_NEW_SHEET, documents a and b are stapled together as a single document, but document b starts on a new sheet.

    • With SEPARATE_DOCUMENTS_UNCOLLATED_COPIES and SEPARATE_DOCUMENTS_COLLATED_COPIES, documents a and b are stapled separately.

    Note: None of these values provide means to produce uncollated sheets within a document, i.e., where multiple copies of sheet 上一个 are produced before sheet 上一个+1 of the same document. To specify that, see the SheetCollate attribute.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Copies, Finishings, NumberUp, PageRanges, SheetCollate, Sides, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static MultipleDocumentHandling SEPARATE_DOCUMENTS_COLLATED_COPIES
      Separate documents collated copies -- see above for further information.
      static MultipleDocumentHandling SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
      Separate documents uncollated copies -- see above for further information.
      static MultipleDocumentHandling SINGLE_DOCUMENT
      Single document -- see above for further information.
      static MultipleDocumentHandling SINGLE_DOCUMENT_NEW_SHEET
      Single document new sheet -- see above for further information.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MultipleDocumentHandling(int value)
      Construct a new multiple document handling enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class MultipleDocumentHandling.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class MultipleDocumentHandling.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SINGLE_DOCUMENT

        public static final MultipleDocumentHandling SINGLE_DOCUMENT
        Single document -- see above for further information.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES

        public static final MultipleDocumentHandling SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
        Separate documents uncollated copies -- see above for further information.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES

        public static final MultipleDocumentHandling SEPARATE_DOCUMENTS_COLLATED_COPIES
        Separate documents collated copies -- see above for further information.

      • SINGLE_DOCUMENT_NEW_SHEET

        public static final MultipleDocumentHandling SINGLE_DOCUMENT_NEW_SHEET
        Single document new sheet -- see above for further information.

    • 构造方法详细信息

      • MultipleDocumentHandling

        protected MultipleDocumentHandling(int value)
        Construct a new multiple document handling enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class MultipleDocumentHandling.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class MultipleDocumentHandling.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class MultipleDocumentHandling and any vendor-defined subclasses, the category is class MultipleDocumentHandling itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class MultipleDocumentHandling and any vendor-defined subclasses, the category name is "multiple-document-handling".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lp|d


NumberOfDocuments

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 NumberOfDocuments

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.NumberOfDocuments
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class NumberOfDocuments
extends IntegerSyntax
implements PrintJobAttribute
    Class NumberOfDocuments is an integer valued printing attribute that indicates the number of individual docs the printer has accepted for this job, regardless of whether the docs' print data has reached the printer or not.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NumberOfDocuments(int value)
      Construct a new number of documents attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this number of documents attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NumberOfDocuments

        public NumberOfDocuments(int value)
        Construct a new number of documents attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this number of documents attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class NumberOfDocuments.
        3. This number of documents attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this number of documents attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class NumberOfDocuments, the category is class NumberOfDocuments itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class NumberOfDocuments, the category name is "number-of-documents".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sp=>a smC""uyreyuo ""p"ddpma"


NumberOfInterveningJobs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 NumberOfInterveningJobs

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.NumberOfInterveningJobs
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class NumberOfInterveningJobs
extends IntegerSyntax
implements PrintJobAttribute
    Class NumberOfInterveningJobs is an integer valued printing attribute that indicates the number of jobs that are ahead of this job in the relative chronological order of expected time to complete (i.e., the current scheduled order).

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NumberOfInterveningJobs(int value)
      Construct a new number of intervening jobs attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this number of intervening jobs attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NumberOfInterveningJobs

        public NumberOfInterveningJobs(int value)
        Construct a new number of intervening jobs attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this number of intervening jobs attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class NumberOfInterveningJobs.
        3. This number of intervening jobs attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this number of intervening jobs attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class NumberOfInterveningJobs, the category is class NumberOfInterveningJobs itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class NumberOfInterveningJobs, the category name is "number-of-intervening-jobs".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i)s=l tl"t>>"ttci aystc-rcap_<


NumberUp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 NumberUp

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.NumberUp
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class NumberUp
extends IntegerSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium. That is, if the NumberUp value is n, the printer must place 上一个 print-stream pages on a single side of an instance of the selected medium. To accomplish this, the printer may add some sort of translation, scaling, or rotation. This attribute primarily controls the translation, scaling and rotation of print-stream pages.

    The effect of a NumberUp attribute on a multidoc print job (a job with multiple documents) depends on whether all the docs have the same number up values specified or whether different docs have different number up values specified, and on the (perhaps defaulted) value of the MultipleDocumentHandling attribute.

    • If all the docs have the same number up value 上一个 specified, then any value of MultipleDocumentHandling makes sense, and the printer's processing depends on the MultipleDocumentHandling value:
      • SINGLE_DOCUMENT -- All the input docs will be combined together into one output document. Each media impression will consist of 上一个m print-stream pages from the output document.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined together into one output document. Each media impression will consist of 上一个 print-stream pages from the output document. However, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than 上一个 print-stream pages on it.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- The input docs will remain separate. Each media impression will consist of 上一个 print-stream pages from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than 上一个 print-stream pages on it.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- The input docs will remain separate. Each media impression will consist of 上一个 print-stream pages from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than 上一个 print-stream pages on it.
      • SINGLE_DOCUMENT -- All the input docs will be combined together into one output document. Each media impression will consist of ni print-stream pages from the output document, where i is the number of the input doc corresponding to that point in the output document. When the next input doc has a different number up value from the previous input doc, the first print-stream page of the next input doc goes at the start of the next media impression, possibly leaving fewer than the full number of print-stream pages on the previous media impression.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined together into one output document. Each media impression will consist of 上一个 print-stream pages from the output document. However, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than 上一个 print-stream pages on it.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- The input docs will remain separate. For input doc i, each media impression will consist of ni print-stream pages from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than ni print-stream pages on it.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- The input docs will remain separate. For input doc i, each media impression will consist of ni print-stream pages from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have fewer than ni print-stream pages on it.
    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NumberUp(int value)
      Construct a new number up attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this number up attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NumberUp

        public NumberUp(int value)
        Construct a new number up attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this number up attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class NumberUp.
        3. This number up attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this number up attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class NumberUp, the category is class NumberUp itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class NumberUp, the category name is "number-up".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.l"ndtLdI"llcslvnl/v�>=veksaIk


NumberUpSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 NumberUpSupported

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.NumberUpSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, SupportedValuesAttribute

    public final class NumberUpSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute
    Class NumberUpSupported is a printing attribute class, a set of integers, that gives the supported values for a NumberUp attribute.

    IPP Compatibility: The NumberUpSupported attribute's canonical array form gives the lower and upper bound for each range of number-up to be included in an IPP "number-up-supported" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NumberUpSupported(int member)
      Construct a new number up supported attribute containing a single integer.
      NumberUpSupported(int[][] members)
      Construct a new number up supported attribute with the given members.
      NumberUpSupported(int lowerBound, int upperBound)
      Construct a new number up supported attribute containing a single range of integers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this number up supported attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NumberUpSupported

        public NumberUpSupported(int[][] members)
        Construct a new number up supported attribute with the given members. The supported values for NumberUp are specified in "array form;" see class SetOfIntegerSyntax for an explanation of array form.
        参数：
        members - Set members in array form.
        抛出：
        NullPointerException - (unchecked exception) Thrown if members is null or any element of members is null.
        IllegalArgumentException - (unchecked exception) Thrown if any element of members is not a length-one or length-two array. Also thrown if members is a zero-length array or if any member of the set is less than 1.

      • NumberUpSupported

        public NumberUpSupported(int member)
        Construct a new number up supported attribute containing a single integer. That is, only the one value of NumberUp is supported.
        参数：
        member - Set member.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if member is less than 1.

      • NumberUpSupported

        public NumberUpSupported(int lowerBound,
                 int upperBound)
        Construct a new number up supported attribute containing a single range of integers. That is, only those values of NumberUp in the one range are supported.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this number up supported attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class NumberUpSupported.
        3. This number up supported attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this number up supported attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class NumberUpSupported, the category is class NumberUpSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class NumberUpSupported, the category name is "number-up-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s&> l


OrientationRequested

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 OrientationRequested

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.OrientationRequested
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class OrientationRequested
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.

    For some document formats (such as "application/postscript"), the desired orientation of the print-stream pages is specified within the document data. This information is generated by a device driver prior to the submission of the print job. Other document formats (such as "text/plain") do not include the notion of desired orientation within the document data. In the latter case it is possible for the printer to bind the desired orientation to the document data after it has been submitted. It is expected that a printer would only support the OrientationRequested attribute for some document formats (e.g., "text/plain" or "text/html") but not others (e.g. "application/postscript"). This is no different from any other job template attribute, since a print job can always impose constraints among the values of different job template attributes. However, a special mention is made here since it is very likely that a printer will support the OrientationRequested attribute for only a subset of the supported document formats.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static OrientationRequested LANDSCAPE
      The content will be imaged across the long edge of the medium.
      static OrientationRequested PORTRAIT
      The content will be imaged across the short edge of the medium.
      static OrientationRequested REVERSE_LANDSCAPE
      The content will be imaged across the long edge of the medium, but in the opposite manner from landscape.
      static OrientationRequested REVERSE_PORTRAIT
      The content will be imaged across the short edge of the medium, but in the opposite manner from portrait.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected OrientationRequested(int value)
      Construct a new orientation requested enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class OrientationRequested.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected int getOffset()
      Returns the lowest integer value used by class OrientationRequested.
      protected String[] getStringTable()
      Returns the string table for class OrientationRequested.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PORTRAIT

        public static final OrientationRequested PORTRAIT
        The content will be imaged across the short edge of the medium.

      • LANDSCAPE

        public static final OrientationRequested LANDSCAPE
        The content will be imaged across the long edge of the medium. Landscape is defined to be a rotation of the print-stream page to be imaged by +90 degrees with respect to the medium (i.e. anti-clockwise) from the portrait orientation. Note: The +90 direction was chosen because simple finishing on the long edge is the same edge whether portrait or landscape.

      • REVERSE_LANDSCAPE

        public static final OrientationRequested REVERSE_LANDSCAPE
        The content will be imaged across the long edge of the medium, but in the opposite manner from landscape. Reverse-landscape is defined to be a rotation of the print-stream page to be imaged by -90 degrees with respect to the medium (i.e. clockwise) from the portrait orientation. Note: The REVERSE_LANDSCAPE value was added because some applications rotate landscape -90 degrees from portrait, rather than +90 degrees.

      • REVERSE_PORTRAIT

        public static final OrientationRequested REVERSE_PORTRAIT
        The content will be imaged across the short edge of the medium, but in the opposite manner from portrait. Reverse-portrait is defined to be a rotation of the print-stream page to be imaged by 180 degrees with respect to the medium from the portrait orientation. Note: The REVERSE_PORTRAIT value was added for use with the Finishings attribute in cases where the opposite edge is desired for finishing a portrait document on simple finishing devices that have only one finishing position. Thus a "text/plain" portrait document can be stapled "on the right" by a simple finishing device as is common use with some Middle Eastern languages such as Hebrew.

    • 构造方法详细信息

      • OrientationRequested

        protected OrientationRequested(int value)
        Construct a new orientation requested enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class OrientationRequested.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class OrientationRequested.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by class OrientationRequested.
        重载：
        getOffset in class EnumSyntax
        返回：
        the offset of the lowest enumeration value.

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class OrientationRequested, the category is class OrientationRequested itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class OrientationRequested, the category name is "orientation-requested".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


OutputDeviceAssigned

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 OutputDeviceAssigned

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.OutputDeviceAssigned
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute

    public final class OutputDeviceAssigned
extends TextSyntax
implements PrintJobAttribute
    Class OutputDeviceAssigned is a printing attribute class, a text attribute, that identifies the output device to which the service has assigned this job. If an output device implements an embedded Print Service instance, the printer need not set this attribute. If a print server implements a Print Service instance, the value may be empty (zero- length string) or not returned until the service assigns an output device to the job. This attribute is particularly useful when a single service supports multiple devices (so called "fan-out").

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      OutputDeviceAssigned(String deviceName, Locale locale)
      Constructs a new output device assigned attribute with the given device name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this output device assigned attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OutputDeviceAssigned

        public OutputDeviceAssigned(String deviceName,
                    Locale locale)
        Constructs a new output device assigned attribute with the given device name and locale.
        参数：
        deviceName - Device name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if deviceName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this output device assigned attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class OutputDeviceAssigned.
        3. This output device assigned attribute's underlying string and object's underlying string are equal.
        4. This output device assigned attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this output device assigned attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class OutputDeviceAssigned, the category is class OutputDeviceAssigned itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class OutputDeviceAssigned, the category name is "output-device-assigned".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i=cil se s iis pp snntiiToCiDnEp//Ohoo/nn


PageRanges

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PageRanges

  • java.lang.Object
    • javax.print.attribute.SetOfIntegerSyntax
      • javax.print.attribute.standard.PageRanges
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class PageRanges
extends SetOfIntegerSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed. Nothing is printed for any pages identified that do not exist in the document(s). The attribute is associated with print-stream pages, not application-numbered pages (for example, the page numbers found in the headers and or footers for certain word processing applications).

    In most cases, the exact pages to be printed will be generated by a device driver and this attribute would not be required. However, when printing an archived document which has already been formatted, the end user may elect to print just a subset of the pages contained in the document. In this case, if a page range of "上一个-m" is specified, the first page to be printed will be page n. All subsequent pages of the document will be printed through and including page m.

    If a PageRanges attribute is not specified for a print job, all pages of the document will be printed. In other words, the default value for the PageRanges attribute is always {{1, Integer.MAX_VALUE}}.

    The effect of a PageRanges attribute on a multidoc print job (a job with multiple documents) depends on whether all the docs have the same page ranges specified or whether different docs have different page ranges specified, and on the (perhaps defaulted) value of the MultipleDocumentHandling attribute.

    • If all the docs have the same page ranges specified, then any value of MultipleDocumentHandling makes sense, and the printer's processing depends on the MultipleDocumentHandling value:
      • SINGLE_DOCUMENT -- All the input docs will be combined together into one output document. The specified page ranges of that output document will be printed.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined together into one output document, and the first impression of each input doc will always start on a new media sheet. The specified page ranges of that output document will be printed.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- For each separate input doc, the specified page ranges will be printed.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- For each separate input doc, the specified page ranges will be printed.
      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- For each separate input doc, its own specified page ranges will be printed..

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- For each separate input doc, its own specified page ranges will be printed..

    IPP Compatibility: The PageRanges attribute's canonical array form gives the lower and upper bound for each range of pages to be included in and IPP "page-ranges" attribute. See class SetOfIntegerSyntax for an explanation of canonical array form. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PageRanges(int member)
      Construct a new page ranges attribute containing a single integer.
      PageRanges(int[][] members)
      Construct a new page ranges attribute with the given members.
      PageRanges(int lowerBound, int upperBound)
      Construct a new page ranges attribute containing a single range of integers.
      PageRanges(String members)
      Construct a new page ranges attribute with the given members in string form.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this page ranges attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.SetOfIntegerSyntax

        contains, contains, getMembers, hashCode, 下一个, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PageRanges

        public PageRanges(int[][] members)
        Construct a new page ranges attribute with the given members. The members are specified in "array form;" see class SetOfIntegerSyntax for an explanation of array form.
        参数：
        members - Set members in array form.
        抛出：
        NullPointerException - (unchecked exception) Thrown if members is null or any element of members is null.
        IllegalArgumentException - (unchecked exception) Thrown if any element of members is not a length-one or length-two array. Also thrown if members is a zero-length array or if any member of the set is less than 1.

      • PageRanges

        public PageRanges(String members)
        Construct a new page ranges attribute with the given members in string form. See class SetOfIntegerSyntax for explanation of the syntax.
        参数：
        members - Set members in string form.
        抛出：
        NullPointerException - (unchecked exception) Thrown if members is null or any element of members is null.
        IllegalArgumentException - (Unchecked exception) Thrown if members does not obey the proper syntax. Also thrown if the constructed set-of-integer is a zero-length array or if any member of the set is less than 1.

      • PageRanges

        public PageRanges(int member)
        Construct a new page ranges attribute containing a single integer. That is, only the one page is to be printed.
        参数：
        member - Set member.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if member is less than 1.

      • PageRanges

        public PageRanges(int lowerBound,
          int upperBound)
        Construct a new page ranges attribute containing a single range of integers. That is, only those pages in the one range are to be printed.
        参数：
        lowerBound - Lower bound of the range.
        upperBound - Upper bound of the range.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if a null range is specified or if a non-null range is specified with lowerBound less than 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this page ranges attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PageRanges.
        3. This page ranges attribute's members and object's members are the same.
        重载：
        equals in class SetOfIntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this page ranges attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PageRanges, the category is class PageRanges itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PageRanges, the category name is "page-ranges".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l<>iaiuil lyy cnr.rb.sil


PagesPerMinute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PagesPerMinute

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.PagesPerMinute
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PagesPerMinute
extends IntegerSyntax
implements PrintServiceAttribute
    Class PagesPerMinute is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer (e.g., simplex, black-and-white). This attribute is informative, not a service guarantee. Generally, it is the value used in the marketing literature to describe the device. A value of 0 indicates a device that takes more than two minutes to process a page.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PagesPerMinute(int value)
      Construct a new pages per minute attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this pages per minute attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PagesPerMinute

        public PagesPerMinute(int value)
        Construct a new pages per minute attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this pages per minute attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PagesPerMinute.
        3. This pages per minute attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this pages per minute attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PagesPerMinute, the category is class PagesPerMinute itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PagesPerMinute, the category name is "pages-per-minute".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r)o grieri-nni--eriiEie h


PagesPerMinuteColor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PagesPerMinuteColor

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.PagesPerMinuteColor
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PagesPerMinuteColor
extends IntegerSyntax
implements PrintServiceAttribute
    Class PagesPerMinuteColor is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer when printing color (e.g., simplex, color). For purposes of this attribute, "color" means the same as for the ColorSupported attribute, namely, the device is capable of any type of color printing at all, including highlight color as well as full process color. This attribute is informative, not a service guarantee. Generally, it is the value used in the marketing literature to describe the color capabilities of this device. A value of 0 indicates a device that takes more than two minutes to process a page. If a color device has several color modes, it may use the pages-per- minute value for this attribute that corresponds to the mode that produces the highest number.

    A black and white only printer must not include the PagesPerMinuteColor attribute in its attribute set or service registration. If this attribute is present, then the ColorSupported printer description attribute must also be present and have a value of SUPPORTED.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PagesPerMinuteColor(int value)
      Construct a new pages per minute color attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this pages per minute color attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PagesPerMinuteColor

        public PagesPerMinuteColor(int value)
        Construct a new pages per minute color attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this pages per minute color attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PagesPerMinuteColor.
        3. This pages per minute attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this pages per minute color attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PagesPerMinuteColor, the category is class PagesPerMinuteColor itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PagesPerMinuteColor, the category name is "pages-per-minute-color".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eptos"g="c llc <


PDLOverrideSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PDLOverrideSupported

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PDLOverrideSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public class PDLOverrideSupported
extends EnumSyntax
implements PrintServiceAttribute
    Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PDLOverrideSupported ATTEMPTED
      The printer attempts to make the external job attribute values take precedence over embedded instructions in the documents' print data, however there is no guarantee.
      static PDLOverrideSupported NOT_ATTEMPTED
      The printer makes no attempt to make the external job attribute values take precedence over embedded instructions in the documents' print data.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PDLOverrideSupported(int value)
      Construct a new PDL override supported enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PDLOverrideSupported.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class PDLOverrideSupported.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NOT_ATTEMPTED

        public static final PDLOverrideSupported NOT_ATTEMPTED
        The printer makes no attempt to make the external job attribute values take precedence over embedded instructions in the documents' print data.

      • ATTEMPTED

        public static final PDLOverrideSupported ATTEMPTED
        The printer attempts to make the external job attribute values take precedence over embedded instructions in the documents' print data, however there is no guarantee.

    • 构造方法详细信息

      • PDLOverrideSupported

        protected PDLOverrideSupported(int value)
        Construct a new PDL override supported enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PDLOverrideSupported.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PDLOverrideSupported.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PDLOverrideSupported and any vendor-defined subclasses, the category is class PDLOverrideSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PDLOverrideSupported and any vendor-defined subclasses, the category name is "pdl-override-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vca h


PresentationDirection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.attribute.standard

类 PresentationDirection

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PresentationDirection
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute

    public final class PresentationDirection
extends EnumSyntax
implements PrintJobAttribute, PrintRequestAttribute
    Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium. This is useful to mirror the text layout conventions of different scripts. For example, English is "toright-tobottom", Hebrew is "toleft-tobottom" and Japanese is usually "tobottom-toleft".

    IPP Compatibility: This attribute is not an IPP 1.1 attribute; it is an attribute in the Production Printing Extension (PDF) of IPP 1.1. The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PresentationDirection TOBOTTOM_TOLEFT
      Pages are laid out in columns starting at the top right, proceeeding towards the bottom & left.
      static PresentationDirection TOBOTTOM_TORIGHT
      Pages are laid out in columns starting at the top left, proceeeding towards the bottom & right.
      static PresentationDirection TOLEFT_TOBOTTOM
      Pages are laid out in rows starting at the top right, proceeeding towards the left & bottom.
      static PresentationDirection TOLEFT_TOTOP
      Pages are laid out in rows starting at the bottom right, proceeeding towards the left & top.
      static PresentationDirection TORIGHT_TOBOTTOM
      Pages are laid out in rows starting at the top left, proceeeding towards the right & bottom.
      static PresentationDirection TORIGHT_TOTOP
      Pages are laid out in rows starting at the bottom left, proceeeding towards the right & top.
      static PresentationDirection TOTOP_TOLEFT
      Pages are laid out in columns starting at the bottom right, proceeeding towards the top & left.
      static PresentationDirection TOTOP_TORIGHT
      Pages are laid out in columns starting at the bottom left, proceeeding towards the top & right.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PresentationDirection.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class PresentationDirection.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • TOBOTTOM_TORIGHT

        public static final PresentationDirection TOBOTTOM_TORIGHT
        Pages are laid out in columns starting at the top left, proceeeding towards the bottom & right.

      • TOBOTTOM_TOLEFT

        public static final PresentationDirection TOBOTTOM_TOLEFT
        Pages are laid out in columns starting at the top right, proceeeding towards the bottom & left.

      • TOTOP_TORIGHT

        public static final PresentationDirection TOTOP_TORIGHT
        Pages are laid out in columns starting at the bottom left, proceeeding towards the top & right.

      • TOTOP_TOLEFT

        public static final PresentationDirection TOTOP_TOLEFT
        Pages are laid out in columns starting at the bottom right, proceeeding towards the top & left.

      • TORIGHT_TOBOTTOM

        public static final PresentationDirection TORIGHT_TOBOTTOM
        Pages are laid out in rows starting at the top left, proceeeding towards the right & bottom.

      • TORIGHT_TOTOP

        public static final PresentationDirection TORIGHT_TOTOP
        Pages are laid out in rows starting at the bottom left, proceeeding towards the right & top.

      • TOLEFT_TOBOTTOM

        public static final PresentationDirection TOLEFT_TOBOTTOM
        Pages are laid out in rows starting at the top right, proceeeding towards the left & bottom.

      • TOLEFT_TOTOP

        public static final PresentationDirection TOLEFT_TOTOP
        Pages are laid out in rows starting at the bottom right, proceeeding towards the left & top.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PresentationDirection.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PresentationDirection.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PresentationDirection the category is class PresentationDirection itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PresentationDirection the category name is "presentation-direction".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

me/spszsos.ncomucottBAAO sA=="oa"aloro /


PrinterInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterInfo

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.PrinterInfo
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterInfo
extends TextSyntax
implements PrintServiceAttribute
    Class PrinterInfo is a printing attribute class, a text attribute, that provides descriptive information about a printer. This could include things like: "This printer can be used for printing color transparencies for HR presentations", or "Out of courtesy for others, please print only small (1-5 page) jobs at this printer", or even \ "This printer is going away on July 1, 1997, please find a new printer".

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterInfo(String info, Locale locale)
      Constructs a new printer info attribute with the given information string and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer info attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterInfo

        public PrinterInfo(String info,
           Locale locale)
        Constructs a new printer info attribute with the given information string and locale.
        参数：
        info - Printer information string.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if info is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer info attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterInfo.
        3. This printer info attribute's underlying string and object's underlying string are equal.
        4. This printer info attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer info attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterInfo, the category is class PrinterInfo itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterInfo, the category name is "printer-info".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iac P/T==< I T""Te l


PrinterIsAcceptingJobs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterIsAcceptingJobs

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PrinterIsAcceptingJobs
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterIsAcceptingJobs
extends EnumSyntax
implements PrintServiceAttribute
    Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs. This value is independent of the PrinterState and PrinterStateReasons attributes because its value does not affect the current job; rather it affects future jobs. If the value is NOT_ACCEPTING_JOBS, the printer will reject jobs even when the PrinterState is IDLE. If value is ACCEPTING_JOBS, the Printer will accept jobs even when the PrinterState is STOPPED.

    IPP Compatibility: The IPP boolean value is "true" for ACCEPTING_JOBS and "false" for NOT_ACCEPTING_JOBS. TThe category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PrinterIsAcceptingJobs ACCEPTING_JOBS
      The printer is currently acccepting jobs.
      static PrinterIsAcceptingJobs NOT_ACCEPTING_JOBS
      The printer is currently rejecting any jobs sent to it.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PrinterIsAcceptingJobs(int value)
      Construct a new printer is accepting jobs enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PrinterIsAcceptingJobs.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class PrinterIsAcceptingJobs.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NOT_ACCEPTING_JOBS

        public static final PrinterIsAcceptingJobs NOT_ACCEPTING_JOBS
        The printer is currently rejecting any jobs sent to it.

      • ACCEPTING_JOBS

        public static final PrinterIsAcceptingJobs ACCEPTING_JOBS
        The printer is currently acccepting jobs.

    • 构造方法详细信息

      • PrinterIsAcceptingJobs

        protected PrinterIsAcceptingJobs(int value)
        Construct a new printer is accepting jobs enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PrinterIsAcceptingJobs.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PrinterIsAcceptingJobs.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterIsAcceptingJobs, the category is class PrinterIsAcceptingJobs itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterIsAcceptingJobs, the category name is "printer-is-accepting-jobs".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtltuetettrrtttij..fl�<< d/ srlilvitttore>DaD�


PrinterLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterLocation

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.PrinterLocation
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterLocation
extends TextSyntax
implements PrintServiceAttribute
    Class PrinterLocation is a printing attribute class, a text attribute, that identifies the location of the device. This could include things like: "in Room 123A, second floor of building XYZ".

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterLocation(String location, Locale locale)
      Constructs a new printer location attribute with the given location and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer location attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterLocation

        public PrinterLocation(String location,
               Locale locale)
        Constructs a new printer location attribute with the given location and locale.
        参数：
        location - Printer location.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if location is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer location attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterLocation.
        3. This printer location attribute's underlying string and object's underlying string are equal.
        4. This printer location attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer location attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterLocation, the category is class PrinterLocation itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterLocation, the category name is "printer-location".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

arsPc.se.snttsnnaa a;rt<)) es mtett Go rt


PrinterMakeAndModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterMakeAndModel

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.PrinterMakeAndModel
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterMakeAndModel
extends TextSyntax
implements PrintServiceAttribute
    Class PrinterMakeAndModel is a printing attribute class, a text attribute, that the make and model of the printer.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterMakeAndModel(String makeAndModel, Locale locale)
      Constructs a new printer make and model attribute with the given make and model string and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer make and model attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterMakeAndModel

        public PrinterMakeAndModel(String makeAndModel,
                   Locale locale)
        Constructs a new printer make and model attribute with the given make and model string and locale.
        参数：
        makeAndModel - Printer make and model string.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if makeAndModel is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer make and model attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterMakeAndModel.
        3. This printer make and model attribute's underlying string and object's underlying string are equal.
        4. This printer make and model attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer make and model attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterMakeAndModel, the category is class PrinterMakeAndModel itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterMakeAndModel, the category name is "printer-make-and-model".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:dss<>>>dsstleeAssiftn a< nrania <


PrinterMessageFromOperator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterMessageFromOperator

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.PrinterMessageFromOperator
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterMessageFromOperator
extends TextSyntax
implements PrintServiceAttribute
    Class PrinterMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user information about or status of the printer, such as why it is unavailable or when it is expected to be available.

    A Print Service's attribute set includes zero instances or one instance of a PrinterMessageFromOperator attribute, not more than one instance. A new PrinterMessageFromOperator attribute replaces an existing PrinterMessageFromOperator attribute, if any. In other words, PrinterMessageFromOperator is not intended to be a history log. If it wishes, the client can detect changes to a Print Service's PrinterMessageFromOperator attribute and maintain the client's own history log of the PrinterMessageFromOperator attribute values.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterMessageFromOperator(String message, Locale locale)
      Constructs a new printer message from operator attribute with the given message and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer message from operator attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterMessageFromOperator

        public PrinterMessageFromOperator(String message,
                          Locale locale)
        Constructs a new printer message from operator attribute with the given message and locale.
        参数：
        message - Message.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if message is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer message from operator attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterMessageFromOperator.
        3. This printer message from operator attribute's underlying string and object's underlying string are equal.
        4. This printer message from operator attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer message from operator attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterMessageFromOperator, the category is class PrinterMessageFromOperator itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterMessageFromOperator, the category name is "printer-message-from-operator".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

le"bibobtpiitppsP==mmlh..� >sBsaaananaBiaee


PrinterMoreInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterMoreInfo

  • java.lang.Object
    • javax.print.attribute.URISyntax
      • javax.print.attribute.standard.PrinterMoreInfo
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterMoreInfo
extends URISyntax
implements PrintServiceAttribute
    Class PrinterMoreInfo is a printing attribute class, a URI, that is used to obtain more information about this specific printer. For example, this could be an HTTP type URI referencing an HTML page accessible to a web browser. The information obtained from this URI is intended for end user consumption. Features outside the scope of the Print Service API can be accessed from this URI. The information is intended to be specific to this printer instance and site specific services (e.g. job pricing, services offered, end user assistance).

    In contrast, the PrinterMoreInfoManufacturer attribute is used to find out more information about this general kind of printer rather than this specific printer.

    IPP Compatibility: The string form returned by toString() gives the IPP uri value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterMoreInfo(URI uri)
      Constructs a new printer more info attribute with the specified URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer more info attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.URISyntax

        getURI, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterMoreInfo

        public PrinterMoreInfo(URI uri)
        Constructs a new printer more info attribute with the specified URI.
        参数：
        uri - URI.
        抛出：
        NullPointerException - (unchecked exception) Thrown if uri is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer more info attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterMoreInfo.
        3. This printer more info attribute's URI and object's URI are equal.
        重载：
        equals in class URISyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer more info attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterMoreInfo, the category is class PrinterMoreInfo itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterMoreInfo, the category name is "printer-more-info".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eml> dv


PrinterMoreInfoManufacturer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterMoreInfoManufacturer

  • java.lang.Object
    • javax.print.attribute.URISyntax
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterMoreInfoManufacturer
extends URISyntax
implements PrintServiceAttribute
    Class PrinterMoreInfoManufacturer is a printing attribute class, a URI, that is used to obtain more information about this type of device. The information obtained from this URI is intended for end user consumption. Features outside the scope of the Print Service API can be accessed from this URI (e.g., latest firmware, upgrades, service proxies, optional features available, details on color support). The information is intended to be germane to this kind of printer without regard to site specific modifications or services.

    PrinterMoreInfo attribute is used to find out more information about this specific printer rather than this general kind of printer.

    IPP Compatibility: The string form returned by toString() gives the IPP uri value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterMoreInfoManufacturer(URI uri)
      Constructs a new printer more info manufacturer attribute with the specified URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer more info manufacturer attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.URISyntax

        getURI, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterMoreInfoManufacturer

        public PrinterMoreInfoManufacturer(URI uri)
        Constructs a new printer more info manufacturer attribute with the specified URI.
        参数：
        uri - URI.
        抛出：
        NullPointerException - (unchecked exception) Thrown if uri is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer more info manufacturer attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterMoreInfoManufacturer.
        3. This printer more info manufacturer attribute's URI and object's URI are equal.
        重载：
        equals in class URISyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer more info manufacturer attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterMoreInfoManufacturer, the category is class PrinterMoreInfoManufacturer itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterMoreInfoManufacturer, the category name is "printer-more-info-manufacturer".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l//ts筩">r�>法b


PrinterName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterName

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.PrinterName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterName
extends TextSyntax
implements PrintServiceAttribute
    Class PrinterName is a printing attribute class, a text attribute, that specifies the name of a printer. It is a name that is more end-user friendly than a URI. An administrator determines a printer's name and sets this attribute to that name. This name may be the last part of the printer's URI or it may be unrelated. In non-US-English locales, a name may contain characters that are not allowed in a URI.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterName(String printerName, Locale locale)
      Constructs a new printer name attribute with the given name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterName

        public PrinterName(String printerName,
           Locale locale)
        Constructs a new printer name attribute with the given name and locale.
        参数：
        printerName - Printer name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if printerName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterName.
        3. This printer name attribute's underlying string and object's underlying string are equal.
        4. This printer name attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer name attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterName, the category is class PrinterName itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterName, the category name is "printer-name".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

odr u r w ,n woicera汀鞔待ぞ�< h


PrinterResolution

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterResolution

  • java.lang.Object
    • javax.print.attribute.ResolutionSyntax
      • javax.print.attribute.standard.PrinterResolution
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class PrinterResolution
extends ResolutionSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job. This attribute assumes that printers have a small set of device resolutions at which they can operate rather than a continuum.

    PrinterResolution is used in multiple ways:

    1. When a client searches looking for a printer that supports the client's desired resolution exactly (no more, no less), the client specifies an instance of class PrinterResolution indicating the exact resolution the client wants. Only printers supporting that exact resolution will match the search.

    2. When a client needs to print a job using the client's desired resolution exactly (no more, no less), the client specifies an instance of class PrinterResolution as an attribute of the Print Job. This will fail if the Print Job doesn't support that exact resolution, and Fidelity is set to true.
    If a client wants to locate a printer supporting a resolution greater than some required minimum, then it may be necessary to exclude this attribute from a lookup request and to directly query the set of supported resolutions, and specify the one that most closely meets the client's requirements. In some cases this may be more simply achieved by specifying a PrintQuality attribute which often controls resolution.

    IPP Compatibility: The information needed to construct an IPP "printer-resolution" attribute can be obtained by calling methods on the PrinterResolution object. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class javax.print.attribute.ResolutionSyntax

        DPCM, DPI

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterResolution(int crossFeedResolution, int feedResolution, int units)
      Construct a new printer resolution attribute from the given items.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer resolution attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.ResolutionSyntax

        getCrossFeedResolution, getCrossFeedResolutionDphi, getFeedResolution, getFeedResolutionDphi, getResolution, hashCode, lessThanOrEquals, toString, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterResolution

        public PrinterResolution(int crossFeedResolution,
                 int feedResolution,
                 int units)
        Construct a new printer resolution attribute from the given items.
        参数：
        crossFeedResolution - Cross feed direction resolution.
        feedResolution - Feed direction resolution.
        units - Unit conversion factor, e.g. ResolutionSyntax.DPI or ResolutionSyntax.>DPCM.
        抛出：
        IllegalArgumentException - (unchecked exception) Thrown if crossFeedResolution < 1 or feedResolution < 1 or units < 1.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer resolution attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterResolution.
        3. This attribute's cross feed direction resolution is equal to object's cross feed direction resolution.
        4. This attribute's feed direction resolution is equal to object's feed direction resolution.
        重载：
        equals in class ResolutionSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this printer resolution attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterResolution, the category is class PrinterResolution itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterResolution, the category name is "printer-resolution".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j,beoe.e/elcm/ja7sjjAP.蔍 靠�.喝詒膃挝a a蝦a"th


PrinterState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterState

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PrinterState
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterState
extends EnumSyntax
implements PrintServiceAttribute
    Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer. Class PrinterState defines standard printer state values. A Print Service implementation only needs to report those printer states which are appropriate for the particular implementation; it does not have to report every defined printer state. The PrinterStateReasons attribute augments the PrinterState attribute to give more detailed information about the printer in given printer state.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PrinterState IDLE
      Indicates that new jobs can start processing without waiting.
      static PrinterState PROCESSING
      Indicates that jobs are processing; new jobs will wait before processing.
      static PrinterState STOPPED
      Indicates that no jobs can be processed and intervention is required.
      static PrinterState UNKNOWN
      The printer state is unknown.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PrinterState(int value)
      Construct a new printer state enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PrinterState.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class PrinterState.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNKNOWN

        public static final PrinterState UNKNOWN
        The printer state is unknown.

      • IDLE

        public static final PrinterState IDLE
        Indicates that new jobs can start processing without waiting.

      • PROCESSING

        public static final PrinterState PROCESSING
        Indicates that jobs are processing; new jobs will wait before processing.

      • STOPPED

        public static final PrinterState STOPPED
        Indicates that no jobs can be processed and intervention is required.

    • 构造方法详细信息

      • PrinterState

        protected PrinterState(int value)
        Construct a new printer state enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PrinterState.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PrinterState.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterState, the category is class PrinterState itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterState, the category name is "printer-state".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.a h them emmhk ir/ g""=xlasitrmg///SngeljlS


PrinterStateReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterStateReason

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PrinterStateReason
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public class PrinterStateReason
extends EnumSyntax
implements Attribute
    Class PrinterStateReason is a printing attribute class, an enumeration, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute. Class PrinterStateReason defines standard printer state reason values. A Print Service implementation only needs to report those printer state reasons which are appropriate for the particular implementation; it does not have to report every defined printer state reason.

    Instances of PrinterStateReason do not appear in a Print Service's attribute set directly. Rather, a PrinterStateReasons attribute appears in the Print Service's attribute set. The PrinterStateReasons attribute contains zero, one, or more than one PrinterStateReason objects which pertain to the Print Service's status, and each PrinterStateReason object is associated with a Severity level of REPORT (least severe), WARNING, or ERROR (most severe). The printer adds a PrinterStateReason object to the Print Service's PrinterStateReasons attribute when the corresponding condition becomes true of the printer, and the printer removesthe PrinterStateReason object again when the corresponding condition becomes false, regardless of whether the Print Service's overall PrinterState also changed.

    IPP Compatibility: The string values returned by each individual PrinterStateReason and associated Severity object's toString() methods, concatenated together with a hyphen ("-") in between, gives the IPP keyword value for a PrinterStateReasons. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PrinterStateReason CONNECTING_TO_DEVICE
      The printer has scheduled a job on the output device and is in the process of connecting to a shared network output device (and might not be able to actually start printing the job for an arbitrarily long time depending on the usage of the output device by other servers on the network).
      static PrinterStateReason COVER_OPEN
      One or more covers on the device are open.
      static PrinterStateReason DEVELOPER_EMPTY
      The device is out of developer.
      static PrinterStateReason DEVELOPER_LOW
      The device is low on developer.
      static PrinterStateReason DOOR_OPEN
      One or more doors on the device are open.
      static PrinterStateReason FUSER_OVER_TEMP
      The fuser temperature is above normal.
      static PrinterStateReason FUSER_UNDER_TEMP
      The fuser temperature is below normal.
      static PrinterStateReason INPUT_TRAY_MISSING
      One or more input trays are not in the device.
      static PrinterStateReason INTERLOCK_OPEN
      One or more interlock devices on the printer are unlocked.
      static PrinterStateReason INTERPRETER_RESOURCE_UNAVAILABLE
      An interpreter resource is unavailable (e.g., font, form).
      static PrinterStateReason MARKER_SUPPLY_EMPTY
      The device is out of at least one marker supply (e.g.
      static PrinterStateReason MARKER_SUPPLY_LOW
      The device is low on at least one marker supply (e.g.
      static PrinterStateReason MARKER_WASTE_ALMOST_FULL
      The device marker supply waste receptacle is almost full.
      static PrinterStateReason MARKER_WASTE_FULL
      The device marker supply waste receptacle is full.
      static PrinterStateReason MEDIA_EMPTY
      At least one input tray is empty.
      static PrinterStateReason MEDIA_JAM
      The device has a media jam.
      static PrinterStateReason MEDIA_LOW
      At least one input tray is low on media.
      static PrinterStateReason MEDIA_NEEDED
      A tray has run out of media.
      static PrinterStateReason MOVING_TO_PAUSED
      Someone has paused the printer, but the device(s) are taking an appreciable time to stop.
      static PrinterStateReason OPC_LIFE_OVER
      The optical photo conductor is no longer functioning.
      static PrinterStateReason OPC_NEAR_EOL
      The optical photo conductor is near end of life.
      static PrinterStateReason OTHER
      The printer has detected an error other than ones listed below.
      static PrinterStateReason OUTPUT_AREA_ALMOST_FULL
      One or more output areas are almost full (e.g.
      static PrinterStateReason OUTPUT_AREA_FULL
      One or more output areas are full (e.g.
      static PrinterStateReason OUTPUT_TRAY_MISSING
      One or more output trays are not in the device.
      static PrinterStateReason PAUSED
      Someone has paused the printer and the printer's PrinterState is STOPPED.
      static PrinterStateReason SHUTDOWN
      Someone has removed a printer from service, and the device may be powered down or physically removed.
      static PrinterStateReason SPOOL_AREA_FULL
      The limit of persistent storage allocated for spooling has been reached.
      static PrinterStateReason STOPPED_PARTLY
      When a printer controls more than one output device, this reason indicates that one or more output devices are stopped.
      static PrinterStateReason STOPPING
      The printer is in the process of stopping the device and will be stopped in a while.
      static PrinterStateReason TIMED_OUT
      The server was able to connect to the output device (or is always connected), but was unable to get a response from the output device.
      static PrinterStateReason TONER_EMPTY
      The device is out of toner.
      static PrinterStateReason TONER_LOW
      The device is low on toner.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PrinterStateReason(int value)
      Construct a new printer state reason enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PrinterStateReason.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class PrinterStateReason.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OTHER

        public static final PrinterStateReason OTHER
        The printer has detected an error other than ones listed below.

      • MEDIA_NEEDED

        public static final PrinterStateReason MEDIA_NEEDED
        A tray has run out of media.

      • MEDIA_JAM

        public static final PrinterStateReason MEDIA_JAM
        The device has a media jam.

      • MOVING_TO_PAUSED

        public static final PrinterStateReason MOVING_TO_PAUSED
        Someone has paused the printer, but the device(s) are taking an appreciable time to stop. Later, when all output has stopped, the PrinterState becomes STOPPED, and the PAUSED value replaces the MOVING_TO_PAUSED value in the PrinterStateReasons attribute. This value must be supported if the printer can be paused and the implementation takes significant time to pause a device in certain circumstances.

      • PAUSED

        public static final PrinterStateReason PAUSED
        Someone has paused the printer and the printer's PrinterState is STOPPED. In this state, a printer must not produce printed output, but it must perform other operations requested by a client. If a printer had been printing a job when the printer was paused, the Printer must resume printing that job when the printer is no longer paused and leave no evidence in the printed output of such a pause. This value must be supported if the printer can be paused.

      • SHUTDOWN

        public static final PrinterStateReason SHUTDOWN
        Someone has removed a printer from service, and the device may be powered down or physically removed. In this state, a printer must not produce printed output, and unless the printer is realized by a print server that is still active, the printer must perform no other operations requested by a client. If a printer had been printing a job when it was shut down, the printer need not resume printing that job when the printer is no longer shut down. If the printer resumes printing such a job, it may leave evidence in the printed output of such a shutdown, e.g. the part printed before the shutdown may be printed a second time after the shutdown.

      • CONNECTING_TO_DEVICE

        public static final PrinterStateReason CONNECTING_TO_DEVICE
        The printer has scheduled a job on the output device and is in the process of connecting to a shared network output device (and might not be able to actually start printing the job for an arbitrarily long time depending on the usage of the output device by other servers on the network).

      • TIMED_OUT

        public static final PrinterStateReason TIMED_OUT
        The server was able to connect to the output device (or is always connected), but was unable to get a response from the output device.

      • STOPPING

        public static final PrinterStateReason STOPPING
        The printer is in the process of stopping the device and will be stopped in a while. When the device is stopped, the printer will change the PrinterState to STOPPED. The STOPPING reason is never an error, even for a printer with a single output device. When an output device ceases accepting jobs, the printer's PrinterStateReasons will have this reason while the output device completes printing.

      • STOPPED_PARTLY

        public static final PrinterStateReason STOPPED_PARTLY
        When a printer controls more than one output device, this reason indicates that one or more output devices are stopped. If the reason's severity is a report, fewer than half of the output devices are stopped. If the reason's severity is a warning, half or more but fewer than all of the output devices are stopped.

      • TONER_LOW

        public static final PrinterStateReason TONER_LOW
        The device is low on toner.

      • TONER_EMPTY

        public static final PrinterStateReason TONER_EMPTY
        The device is out of toner.

      • SPOOL_AREA_FULL

        public static final PrinterStateReason SPOOL_AREA_FULL
        The limit of persistent storage allocated for spooling has been reached. The printer is temporarily unable to accept more jobs. The printer will remove this reason when it is able to accept more jobs. This value should be used by a non-spooling printer that only accepts one or a small number jobs at a time or a spooling printer that has filled the spool space.

      • COVER_OPEN

        public static final PrinterStateReason COVER_OPEN
        One or more covers on the device are open.

      • INTERLOCK_OPEN

        public static final PrinterStateReason INTERLOCK_OPEN
        One or more interlock devices on the printer are unlocked.

      • DOOR_OPEN

        public static final PrinterStateReason DOOR_OPEN
        One or more doors on the device are open.

      • INPUT_TRAY_MISSING

        public static final PrinterStateReason INPUT_TRAY_MISSING
        One or more input trays are not in the device.

      • MEDIA_LOW

        public static final PrinterStateReason MEDIA_LOW
        At least one input tray is low on media.

      • MEDIA_EMPTY

        public static final PrinterStateReason MEDIA_EMPTY
        At least one input tray is empty.

      • OUTPUT_TRAY_MISSING

        public static final PrinterStateReason OUTPUT_TRAY_MISSING
        One or more output trays are not in the device.

      • OUTPUT_AREA_ALMOST_FULL

        public static final PrinterStateReason OUTPUT_AREA_ALMOST_FULL
        One or more output areas are almost full (e.g. tray, stacker, collator).

      • OUTPUT_AREA_FULL

        public static final PrinterStateReason OUTPUT_AREA_FULL
        One or more output areas are full (e.g. tray, stacker, collator).

      • MARKER_SUPPLY_LOW

        public static final PrinterStateReason MARKER_SUPPLY_LOW
        The device is low on at least one marker supply (e.g. toner, ink, ribbon).

      • MARKER_SUPPLY_EMPTY

        public static final PrinterStateReason MARKER_SUPPLY_EMPTY
        The device is out of at least one marker supply (e.g. toner, ink, ribbon).

      • MARKER_WASTE_ALMOST_FULL

        public static final PrinterStateReason MARKER_WASTE_ALMOST_FULL
        The device marker supply waste receptacle is almost full.

      • MARKER_WASTE_FULL

        public static final PrinterStateReason MARKER_WASTE_FULL
        The device marker supply waste receptacle is full.

      • FUSER_OVER_TEMP

        public static final PrinterStateReason FUSER_OVER_TEMP
        The fuser temperature is above normal.

      • FUSER_UNDER_TEMP

        public static final PrinterStateReason FUSER_UNDER_TEMP
        The fuser temperature is below normal.

      • OPC_NEAR_EOL

        public static final PrinterStateReason OPC_NEAR_EOL
        The optical photo conductor is near end of life.

      • OPC_LIFE_OVER

        public static final PrinterStateReason OPC_LIFE_OVER
        The optical photo conductor is no longer functioning.

      • DEVELOPER_LOW

        public static final PrinterStateReason DEVELOPER_LOW
        The device is low on developer.

      • DEVELOPER_EMPTY

        public static final PrinterStateReason DEVELOPER_EMPTY
        The device is out of developer.

      • INTERPRETER_RESOURCE_UNAVAILABLE

        public static final PrinterStateReason INTERPRETER_RESOURCE_UNAVAILABLE
        An interpreter resource is unavailable (e.g., font, form).

    • 构造方法详细信息

      • PrinterStateReason

        protected PrinterStateReason(int value)
        Construct a new printer state reason enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PrinterStateReason.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PrinterStateReason.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterStateReason and any vendor-defined subclasses, the category is class PrinterStateReason itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterStateReason and any vendor-defined subclasses, the category name is "printer-state-reason".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PrinterStateReasons

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterStateReasons

  • java.lang.Object
    • java.util.AbstractMap<K,V>
      • java.util.HashMap<PrinterStateReason,Severity>
        • javax.print.attribute.standard.PrinterStateReasons
  • 所有已实现的接口：
    Serializable, Cloneable, Map<PrinterStateReason,Severity>, Attribute, PrintServiceAttribute

    public final class PrinterStateReasons
extends HashMap<PrinterStateReason,Severity>
implements PrintServiceAttribute
    Class PrinterStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.

    Instances of PrinterStateReason do not appear in a Print Service's attribute set directly. Rather, a PrinterStateReasons attribute appears in the Print Service's attribute set. The PrinterStateReasons attribute contains zero, one, or more than one PrinterStateReason objects which pertain to the Print Service's status, and each PrinterStateReason object is associated with a Severity level of REPORT (least severe), WARNING, or ERROR (most severe). The printer adds a PrinterStateReason object to the Print Service's PrinterStateReasons attribute when the corresponding condition becomes true of the printer, and the printer removes the PrinterStateReason object again when the corresponding condition becomes false, regardless of whether the Print Service's overall PrinterState also changed.

    Class PrinterStateReasons inherits its implementation from class java.util.HashMap. Each entry in the map consists of a PrinterStateReason object (key) mapping to a Severity object (value):

    Unlike most printing attributes which are immutable once constructed, class PrinterStateReasons is designed to be mutable; you can add PrinterStateReason objects to an existing PrinterStateReasons object and remove them again. However, like class java.util.HashMap, class PrinterStateReasons is not multiple thread safe. If a PrinterStateReasons object will be used by multiple threads, be sure to synchronize its operations (e.g., using a synchronized map view obtained from class java.util.Collections).

    IPP Compatibility: The string values returned by each individual PrinterStateReason object's and the associated Severity object's toString() methods, concatenated together with a hyphen ("-") in between, gives the IPP keyword value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.util.AbstractMap

        AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterStateReasons()
      Construct a new, empty printer state reasons attribute; the underlying hash map has the default initial capacity and load factor.
      PrinterStateReasons(int initialCapacity)
      super a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and the default load factor.
      PrinterStateReasons(int initialCapacity, float loadFactor)
      Construct a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and load factor.
      PrinterStateReasons(Map<PrinterStateReason,Severity> map)
      Construct a new printer state reasons attribute that contains the same PrinterStateReason-to-Severity mappings as the given map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      Set<PrinterStateReason> printerStateReasonSet(Severity severity)
      Obtain an unmodifiable set view of the individual printer state reason attributes at the given severity level in this PrinterStateReasons attribute.
      Severity put(PrinterStateReason reason, Severity severity)
      Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level.

      • 方法 - 继承于类 java.util.HashMap

        clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, putAll, remove, size, values

      • 方法 - 继承于类 java.util.AbstractMap

        equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.util.Map

        equals, hashCode

    • 构造方法详细信息

      • PrinterStateReasons

        public PrinterStateReasons()
        Construct a new, empty printer state reasons attribute; the underlying hash map has the default initial capacity and load factor.

      • PrinterStateReasons

        public PrinterStateReasons(int initialCapacity)
        super a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and the default load factor.
        参数：
        initialCapacity - Initial capacity.
        抛出：
        IllegalArgumentException - if the initial capacity is less than zero.

      • PrinterStateReasons

        public PrinterStateReasons(int initialCapacity,
                   float loadFactor)
        Construct a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and load factor.
        参数：
        initialCapacity - Initial capacity.
        loadFactor - Load factor.
        抛出：
        IllegalArgumentException - if the initial capacity is less than zero.

      • PrinterStateReasons

        public PrinterStateReasons(Map<PrinterStateReason,Severity> map)
        Construct a new printer state reasons attribute that contains the same PrinterStateReason-to-Severity mappings as the given map. The underlying hash map's initial capacity and load factor are as specified in the superclass constructor HashMap(Map).
        参数：
        map - Map to copy.
        抛出：
        NullPointerException - (unchecked exception) Thrown if map is null or if any key or value in map is null.
        ClassCastException - (unchecked exception) Thrown if any key in map is not an instance of class PrinterStateReason or if any value in map is not an instance of class Severity.

    • 方法详细信息

      • put

        public Severity put(PrinterStateReason reason,
           Severity severity)
        Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level. If this printer state reasons attribute previously contained a mapping for the given printer state reason, the old value is replaced.
        指定者：
        put in interface Map<PrinterStateReason,Severity>
        重载：
        put in class HashMap<PrinterStateReason,Severity>
        参数：
        reason - Printer state reason. This must be an instance of class PrinterStateReason.
        severity - Severity of the printer state reason. This must be an instance of class Severity.
        返回：
        Previous severity associated with the given printer state reason, or null if the given printer state reason was not present.
        抛出：
        NullPointerException - (unchecked exception) Thrown if reason is null or severity is null.
        ClassCastException - (unchecked exception) Thrown if reason is not an instance of class PrinterStateReason or if severity is not an instance of class Severity.
        从以下版本开始：
        1.5

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterStateReasons, the category is class PrinterStateReasons itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterStateReasons, the category name is "printer-state-reasons".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.

      • printerStateReasonSet

        public Set<PrinterStateReason> printerStateReasonSet(Severity severity)
        Obtain an unmodifiable set view of the individual printer state reason attributes at the given severity level in this PrinterStateReasons attribute. Each element in the set view is a PrinterStateReason object. The only elements in the set view are the PrinterStateReason objects that map to the given severity value. The set view is backed by this PrinterStateReasons attribute, so changes to this PrinterStateReasons attribute are reflected in the set view. The set view does not support element insertion or removal. The set view's iterator does not support element removal.
        参数：
        severity - Severity level.
        返回：
        Set view of the individual PrinterStateReason attributes at the given Severity level.
        抛出：
        NullPointerException - (unchecked exception) Thrown if severity is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

E DotRreRreSSreePaaa/iaiptrst/etamtaaiv.pvn"sa a


PrinterURI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrinterURI

  • java.lang.Object
    • javax.print.attribute.URISyntax
      • javax.print.attribute.standard.PrinterURI
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class PrinterURI
extends URISyntax
implements PrintServiceAttribute
    Class PrinterURI is a printing attribute class, a URI, that specifies the globally unique name of a printer. If it has such a name, an administrator determines a printer's URI and sets this attribute to that name.

    IPP Compatibility: This implements the IPP printer-uri attribute. The string form returned by toString() gives the IPP printer-uri value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrinterURI(URI uri)
      Constructs a new PrinterURI attribute with the specified URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this printer name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.URISyntax

        getURI, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrinterURI

        public PrinterURI(URI uri)
        Constructs a new PrinterURI attribute with the specified URI.
        参数：
        uri - URI of the printer
        抛出：
        NullPointerException - (unchecked exception) Thrown if uri is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this printer name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class PrinterURI.
        3. This PrinterURI attribute's underlying URI and object's underlying URI are equal.
        重载：
        equals in class URISyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this PrinterURI attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrinterURI and any vendor-defined subclasses, the category is class PrinterURI itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrinterURI and any vendor-defined subclasses, the category name is "printer-uri".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stpsaeeteetrrett>t..t/uibtt/aet/aPettta///s


PrintQuality

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 PrintQuality

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.PrintQuality
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public class PrintQuality
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static PrintQuality DRAFT
      Lowest quality available on the printer.
      static PrintQuality HIGH
      Highest quality available on the printer.
      static PrintQuality NORMAL
      Normal or intermediate quality on the printer.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PrintQuality(int value)
      Construct a new print quality enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class PrintQuality.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected int getOffset()
      Returns the lowest integer value used by class PrintQuality.
      protected String[] getStringTable()
      Returns the string table for class PrintQuality.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DRAFT

        public static final PrintQuality DRAFT
        Lowest quality available on the printer.

      • NORMAL

        public static final PrintQuality NORMAL
        Normal or intermediate quality on the printer.

      • HIGH

        public static final PrintQuality HIGH
        Highest quality available on the printer.

    • 构造方法详细信息

      • PrintQuality

        protected PrintQuality(int value)
        Construct a new print quality enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class PrintQuality.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class PrintQuality.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getOffset

        protected int getOffset()
        Returns the lowest integer value used by class PrintQuality.
        重载：
        getOffset in class EnumSyntax
        返回：
        the offset of the lowest enumeration value.

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class PrintQuality and any vendor-defined subclasses, the category is class PrintQuality itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class PrintQuality and any vendor-defined subclasses, the category name is "print-quality".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

at/d ehaamLmeim>cep h // dit


QueuedJobCount

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 QueuedJobCount

  • java.lang.Object
    • javax.print.attribute.IntegerSyntax
      • javax.print.attribute.standard.QueuedJobCount
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintServiceAttribute

    public final class QueuedJobCount
extends IntegerSyntax
implements PrintServiceAttribute
    Class QueuedJobCount is an integer valued printing attribute that indicates the number of jobs in the printer whose JobState is either PENDING, PENDING_HELD, PROCESSING, or PROCESSING_STOPPED.

    IPP Compatibility: The integer value gives the IPP integer value. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      QueuedJobCount(int value)
      Construct a new queued job count attribute with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this queued job count attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.IntegerSyntax

        getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • QueuedJobCount

        public QueuedJobCount(int value)
        Construct a new queued job count attribute with the given integer value.
        参数：
        value - Integer value.
        抛出：
        IllegalArgumentException - (Unchecked exception) Thrown if value is less than 0.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this queued job count attribute is equivalent to the passed in object. To be equivalent, all of the following conditions mus be true:
        1. object is not null.
        2. object is an instance of class QueuedJobCount.
        3. This queued job count attribute's value and object's value are equal.
        重载：
        equals in class IntegerSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this queued job count attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class QueuedJobCount, the category is class QueuedJobCount itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class QueuedJobCount, the category name is "queued-job-count".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/b< /


ReferenceUriSchemesSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 ReferenceUriSchemesSupported

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.ReferenceUriSchemesSupported
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public class ReferenceUriSchemesSupported
extends EnumSyntax
implements Attribute
    Class ReferenceUriSchemesSupported is a printing attribute class an enumeration, that indicates a "URI scheme," such as "http:" or "ftp:", that a printer can use to retrieve print data stored at a URI location. If a printer supports doc flavors with a print data representation class of "java.net.URL", the printer uses instances of class ReferenceUriSchemesSupported to advertise the URI schemes it can accept. The acceptable URI schemes are included as service attributes in the lookup service; this lets clients search the for printers that can get print data using a certain URI scheme. The acceptable URI schemes can also be queried using the capability methods in interface PrintService. However, ReferenceUriSchemesSupported attributes are used solely for determining acceptable URI schemes, they are never included in a doc's, print request's, print job's, or print service's attribute set.

    The Internet Assigned Numbers Authority maintains the official list of URI schemes.

    Class ReferenceUriSchemesSupported defines enumeration values for widely used URI schemes. A printer that supports additional URI schemes can define them in a subclass of class ReferenceUriSchemesSupported.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static ReferenceUriSchemesSupported FILE
      Host-specific file names.
      static ReferenceUriSchemesSupported FTP
      File Transfer Protocol (FTP).
      static ReferenceUriSchemesSupported GOPHER
      Gopher Protocol.
      static ReferenceUriSchemesSupported HTTP
      HyperText Transfer Protocol (HTTP).
      static ReferenceUriSchemesSupported HTTPS
      Secure HyperText Transfer Protocol (HTTPS).
      static ReferenceUriSchemesSupported NEWS
      USENET news.
      static ReferenceUriSchemesSupported NNTP
      USENET news using Network News Transfer Protocol (NNTP).
      static ReferenceUriSchemesSupported WAIS
      Wide Area Information Server (WAIS) protocol.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ReferenceUriSchemesSupported(int value)
      Construct a new reference URI scheme enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class ReferenceUriSchemesSupported.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class ReferenceUriSchemesSupported.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FTP

        public static final ReferenceUriSchemesSupported FTP
        File Transfer Protocol (FTP).

      • HTTP

        public static final ReferenceUriSchemesSupported HTTP
        HyperText Transfer Protocol (HTTP).

      • HTTPS

        public static final ReferenceUriSchemesSupported HTTPS
        Secure HyperText Transfer Protocol (HTTPS).

      • GOPHER

        public static final ReferenceUriSchemesSupported GOPHER
        Gopher Protocol.

      • NEWS

        public static final ReferenceUriSchemesSupported NEWS
        USENET news.

      • NNTP

        public static final ReferenceUriSchemesSupported NNTP
        USENET news using Network News Transfer Protocol (NNTP).

      • WAIS

        public static final ReferenceUriSchemesSupported WAIS
        Wide Area Information Server (WAIS) protocol.

      • FILE

        public static final ReferenceUriSchemesSupported FILE
        Host-specific file names.

    • 构造方法详细信息

      • ReferenceUriSchemesSupported

        protected ReferenceUriSchemesSupported(int value)
        Construct a new reference URI scheme enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class ReferenceUriSchemesSupported.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class ReferenceUriSchemesSupported.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class ReferenceUriSchemesSupported and any vendor-defined subclasses, the category is class ReferenceUriSchemesSupported itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class ReferenceUriSchemesSupported and any vendor-defined subclasses, the category name is "reference-uri-schemes-supported".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>rmllalbm/iFl=/gni=ania mt=a . �


RequestingUserName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 RequestingUserName

  • java.lang.Object
    • javax.print.attribute.TextSyntax
      • javax.print.attribute.standard.RequestingUserName
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, PrintRequestAttribute

    public final class RequestingUserName
extends TextSyntax
implements PrintRequestAttribute
    Class RequestingUserName is a printing attribute class, a text attribute, that specifies the name of the end user that submitted the print job. A requesting user name is an arbitrary string defined by the client. The printer does not put the client-specified RequestingUserName attribute into the Print Job's attribute set; rather, the printer puts in a JobOriginatingUserName attribute. This means that services which support specifying a username with this attribute should also report a JobOriginatingUserName in the job's attribute set. Note that many print services may have a way to independently authenticate the user name, and so may state support for a requesting user name, but in practice will then report the user name authenticated by the service rather than that specified via this attribute.

    IPP Compatibility: The string value gives the IPP name value. The locale gives the IPP natural language. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RequestingUserName(String userName, Locale locale)
      Constructs a new requesting user name attribute with the given user name and locale.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object object)
      Returns whether this requesting user name attribute is equivalent to the passed in object.
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      String getName()
      Get the name of the category of which this attribute value is an instance.

      • 方法 - 继承于类 javax.print.attribute.TextSyntax

        getLocale, getValue, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RequestingUserName

        public RequestingUserName(String userName,
                  Locale locale)
        Constructs a new requesting user name attribute with the given user name and locale.
        参数：
        userName - User name.
        locale - Natural language of the text string. null is interpreted to mean the default locale as returned by Locale.getDefault()
        抛出：
        NullPointerException - (unchecked exception) Thrown if userName is null.

    • 方法详细信息

      • equals

        public boolean equals(Object object)
        Returns whether this requesting user name attribute is equivalent to the passed in object. To be equivalent, all of the following conditions must be true:
        1. object is not null.
        2. object is an instance of class RequestingUserName.
        3. This requesting user name attribute's underlying string and object's underlying string are equal.
        4. This requesting user name attribute's locale and object's locale are equal.
        重载：
        equals in class TextSyntax
        参数：
        object - Object to compare to.
        返回：
        True if object is equivalent to this requesting user name attribute, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class RequestingUserName, the category is class RequestingUserName itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class RequestingUserName, the category name is "requesting-user-name".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ratherrUrreeereed/nnht/ IAA>>bnpa; ccl <


Severity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Severity

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Severity
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute

    public final class Severity
extends EnumSyntax
implements Attribute
    Class Severity is a printing attribute class, an enumeration, that denotes the severity of a PrinterStateReason attribute.

    Instances of Severity do not appear in a Print Service's attribute set directly. Rather, a PrinterStateReasons attribute appears in the Print Service's attribute set. The PrinterStateReasons attribute contains zero, one, or more than one PrinterStateReason objects which pertain to the Print Service's status, and each PrinterStateReason object is associated with a Severity level of REPORT (least severe), WARNING, or ERROR (most severe). The printer adds a PrinterStateReason object to the Print Service's PrinterStateReasons attribute when the corresponding condition becomes true of the printer, and the printer removes the PrinterStateReason object again when the corresponding condition becomes false, regardless of whether the Print Service's overall PrinterState also changed.

    IPP Compatibility: Severity.toString() returns either "error", "warning", or "report". The string values returned by each individual PrinterStateReason and associated Severity object's toString() methods, concatenated together with a hyphen ("-") in between, gives the IPP keyword value for a PrinterStateReasons. The category name returned by getName() gives the IPP attribute name.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Severity ERROR
      Indicates that the PrinterStateReason is an "error" (most severe).
      static Severity REPORT
      Indicates that the PrinterStateReason is a "report" (least severe).
      static Severity WARNING
      Indicates that the PrinterStateReason is a "warning." An implementation may choose to omit some or all warnings.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Severity(int value)
      Construct a new severity enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Severity.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class Severity.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • REPORT

        public static final Severity REPORT
        Indicates that the PrinterStateReason is a "report" (least severe). An implementation may choose to omit some or all reports. Some reports specify finer granularity about the printer state; others serve as a precursor to a warning. A report must contain nothing that could affect the printed output.

      • WARNING

        public static final Severity WARNING
        Indicates that the PrinterStateReason is a "warning." An implementation may choose to omit some or all warnings. Warnings serve as a precursor to an error. A warning must contain nothing that prevents a job from completing, though in some cases the output may be of lower quality.

      • ERROR

        public static final Severity ERROR
        Indicates that the PrinterStateReason is an "error" (most severe). An implementation must include all errors. If this attribute contains one or more errors, the printer's PrinterState must be STOPPED.

    • 构造方法详细信息

      • Severity

        protected Severity(int value)
        Construct a new severity enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Severity.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Severity.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Severity, the category is class Severity itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Severit, the category name is "severity".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itnv.vAvrvaxp/xx/.<ettrpsp�>rs<


SheetCollate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 SheetCollate

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.SheetCollate
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class SheetCollate
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute. When SheetCollate is COLLATED, each copy of each document is printed with the print-stream sheets in sequence. When SheetCollate is UNCOLLATED, each print-stream sheet is printed a number of times equal to the value of the Copies attribute in succession. For example, suppose a document produces two media sheets as output, Copies is 6, and SheetCollate is UNCOLLATED; in this case six copies of the first media sheet are printed followed by six copies of the second media sheet.

    Whether the effect of sheet collation is achieved by placing copies of a document in multiple output bins or in the same output bin with implementation defined document separation is implementation dependent. Also whether it is achieved by making multiple passes over the job or by using an output sorter is implementation dependent.

    If a printer does not support the SheetCollate attribute (meaning the client cannot specify any particular sheet collation), the printer must behave as though SheetCollate were always set to COLLATED.

    The SheetCollate attribute interacts with the MultipleDocumentHandling attribute. The MultipleDocumentHandling attribute describes the collation of entire documents, and the SheetCollate attribute describes the semantics of collating individual pages within a document.

    The effect of a SheetCollate attribute on a multidoc print job (a job with multiple documents) depends on whether all the docs have the same sheet collation specified or whether different docs have different sheet collations specified, and on the (perhaps defaulted) value of the MultipleDocumentHandling attribute.

    • If all the docs have the same sheet collation specified, then the following combinations of SheetCollate and MultipleDocumentHandling are permitted, and the printer reports an error when the job is submitted if any other combination is specified:
      • SheetCollate = COLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT -- All the input docs will be combined into one output document. Multiple copies of the output document will be produced with pages in collated order, i.e. pages 1, 2, 3, . . ., 1, 2, 3, . . .

      • SheetCollate = COLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined into one output document, and the first impression of each input doc will always start on a new media sheet. Multiple copies of the output document will be produced with pages in collated order, i.e. pages 1, 2, 3, . . ., 1, 2, 3, . . .

      • SheetCollate = COLLATED, MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- Each input doc will remain a separate output document. Multiple copies of each output document (call them A, B, . . .) will be produced with each document's pages in collated order, but the documents themselves in uncollated order, i.e. pages A1, A2, A3, . . ., A1, A2, A3, . . ., B1, B2, B3, . . ., B1, B2, B3, . . .

      • SheetCollate = COLLATED, MultipleDocumentHandling = SEPARATE_DOCUMENTS_COLLATED_COPIES -- Each input doc will remain a separate output document. Multiple copies of each output document (call them A, B, . . .) will be produced with each document's pages in collated order, with the documents themselves also in collated order, i.e. pages A1, A2, A3, . . ., B1, B2, B3, . . ., A1, A2, A3, . . ., B1, B2, B3, . . .

      • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT -- All the input docs will be combined into one output document. Multiple copies of the output document will be produced with pages in uncollated order, i.e. pages 1, 1, . . ., 2, 2, . . ., 3, 3, . . .

      • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined into one output document, and the first impression of each input doc will always start on a new media sheet. Multiple copies of the output document will be produced with pages in uncollated order, i.e. pages 1, 1, . . ., 2, 2, . . ., 3, 3, . . .

      • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- Each input doc will remain a separate output document. Multiple copies of each output document (call them A, B, . . .) will be produced with each document's pages in uncollated order, with the documents themselves also in uncollated order, i.e. pages A1, A1, . . ., A2, A2, . . ., A3, A3, . . ., B1, B1, . . ., B2, B2, . . ., B3, B3, . . .

    • If different docs have different sheet collations specified, then only one value of MultipleDocumentHandling is permitted, and the printer reports an error when the job is submitted if any other value is specified:
      • MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- Each input doc will remain a separate output document. Multiple copies of each output document (call them A, B, . . .) will be produced with each document's pages in collated or uncollated order as the corresponding input doc's SheetCollate attribute specifies, and with the documents themselves in uncollated order. If document A had SheetCollate = UNCOLLATED and document B had SheetCollate = COLLATED, the following pages would be produced: A1, A1, . . ., A2, A2, . . ., A3, A3, . . ., B1, B2, B3, . . ., B1, B2, B3, . . .

    IPP Compatibility: SheetCollate is not an IPP attribute at present.

    另请参见：
    MultipleDocumentHandling, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static SheetCollate COLLATED
      Sheets within a document appear in collated order when multiple copies are printed.
      static SheetCollate UNCOLLATED
      Sheets within a document appear in uncollated order when multiple copies are printed.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SheetCollate(int value)
      Construct a new sheet collate enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class SheetCollate.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class SheetCollate.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNCOLLATED

        public static final SheetCollate UNCOLLATED
        Sheets within a document appear in uncollated order when multiple copies are printed.

      • COLLATED

        public static final SheetCollate COLLATED
        Sheets within a document appear in collated order when multiple copies are printed.

    • 构造方法详细信息

      • SheetCollate

        protected SheetCollate(int value)
        Construct a new sheet collate enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class SheetCollate.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class SheetCollate.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class SheetCollate, the category is class SheetCollate itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class SheetCollate, the category name is "sheet-collate".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< /sv/v#/ai "altlt舖8�=t;sn.⒎nee>xb 詌a


Sides

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.attribute.standard

类 Sides

  • java.lang.Object
    • javax.print.attribute.EnumSyntax
      • javax.print.attribute.standard.Sides
  • 所有已实现的接口：
    Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute

    public final class Sides
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
    Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.

    The effect of a Sides attribute on a multidoc print job (a job with multiple documents) depends on whether all the docs have the same sides values specified or whether different docs have different sides values specified, and on the (perhaps defaulted) value of the MultipleDocumentHandling attribute.

    • If all the docs have the same sides value 上一个 specified, then any value of MultipleDocumentHandling makes sense, and the printer's processing depends on the MultipleDocumentHandling value:
      • SINGLE_DOCUMENT -- All the input docs will be combined together into one output document. Each media sheet will consist of 上一个 impressions from the output document.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined together into one output document. Each media sheet will consist of 上一个 impressions from the output document. However, the first impression of each input doc will always start on a new media sheet; this means the last media sheet of an input doc may have only one impression on it.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- The input docs will remain separate. Each media sheet will consist of 上一个 impressions from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last media sheet of an input doc may have only one impression on it.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- The input docs will remain separate. Each media sheet will consist of 上一个 impressions from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last media sheet of an input doc may have only one impression on it.

      • SINGLE_DOCUMENT -- All the input docs will be combined together into one output document. Each media sheet will consist of ni impressions from the output document, where i is the number of the input doc corresponding to that point in the output document. When the next input doc has a different sides value from the previous input doc, the first print-stream page of the next input doc goes at the start of the next media sheet, possibly leaving only one impression on the previous media sheet.

      • SINGLE_DOCUMENT_NEW_SHEET -- All the input docs will be combined together into one output document. Each media sheet will consist of 上一个 impressions from the output document. However, the first impression of each input doc will always start on a new media sheet; this means the last impression of an input doc may have only one impression on it.

      • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- The input docs will remain separate. For input doc i, each media sheet will consist of ni impressions from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last media sheet of an input doc may have only one impression on it.

      • SEPARATE_DOCUMENTS_COLLATED_COPIES -- The input docs will remain separate. For input doc i, each media sheet will consist of ni impressions from the input doc. Since the input docs are separate, the first impression of each input doc will always start on a new media sheet; this means the last media sheet of an input doc may have only one impression on it.

    IPP Compatibility: The category name returned by getName() is the IPP attribute name. The enumeration's integer value is the IPP enum value. The toString() method returns the IPP string representation of the attribute value.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Sides DUPLEX
      An alias for "two sided long edge" (see TWO_SIDED_LONG_EDGE).
      static Sides ONE_SIDED
      Imposes each consecutive print-stream page upon the same side of consecutive media sheets.
      static Sides TUMBLE
      An alias for "two sided short edge" (see TWO_SIDED_SHORT_EDGE).
      static Sides TWO_SIDED_LONG_EDGE
      Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the long edge.
      static Sides TWO_SIDED_SHORT_EDGE
      Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the short edge.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Sides(int value)
      Construct a new sides enumeration value with the given integer value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<? extends Attribute> getCategory()
      Get the printing attribute class which is to be used as the "category" for this printing attribute value.
      protected EnumSyntax[] getEnumValueTable()
      Returns the enumeration value table for class Sides.
      String getName()
      Get the name of the category of which this attribute value is an instance.
      protected String[] getStringTable()
      Returns the string table for class Sides.

      • 方法 - 继承于类 javax.print.attribute.EnumSyntax

        clone, getOffset, getValue, hashCode, readResolve, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ONE_SIDED

        public static final Sides ONE_SIDED
        Imposes each consecutive print-stream page upon the same side of consecutive media sheets.

      • TWO_SIDED_LONG_EDGE

        public static final Sides TWO_SIDED_LONG_EDGE
        Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the long edge. This imposition is also known as "duplex" (see DUPLEX).

      • TWO_SIDED_SHORT_EDGE

        public static final Sides TWO_SIDED_SHORT_EDGE
        Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the short edge. This imposition is also known as "tumble" (see TUMBLE).

      • DUPLEX

        public static final Sides DUPLEX
        An alias for "two sided long edge" (see TWO_SIDED_LONG_EDGE).

      • TUMBLE

        public static final Sides TUMBLE
        An alias for "two sided short edge" (see TWO_SIDED_SHORT_EDGE).

    • 构造方法详细信息

      • Sides

        protected Sides(int value)
        Construct a new sides enumeration value with the given integer value.
        参数：
        value - Integer value.

    • 方法详细信息

      • getStringTable

        protected String[] getStringTable()
        Returns the string table for class Sides.
        重载：
        getStringTable in class EnumSyntax
        返回：
        the string table

      • getEnumValueTable

        protected EnumSyntax[] getEnumValueTable()
        Returns the enumeration value table for class Sides.
        重载：
        getEnumValueTable in class EnumSyntax
        返回：
        the value table

      • getCategory

        public final 类<? extends Attribute> getCategory()
        Get the printing attribute class which is to be used as the "category" for this printing attribute value.

        For class Sides, the category is class Sides itself.

        指定者：
        getCategory in interface Attribute
        返回：
        Printing attribute class (category), an instance of class java.lang.Class.

      • getName

        public final String getName()
        Get the name of the category of which this attribute value is an instance.

        For class Sides, the category name is "sides".

        指定者：
        getName in interface Attribute
        返回：
        Attribute category name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


Uses of Package javax.print.attribute.standard

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.print.attribute.standard

  • Packages that use javax.print.attribute.standard
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.
  • Classes in javax.print.attribute.standard used by javax.print.attribute.standard
    类与描述
    Chromaticity
    Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
    ColorSupported
    Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
    Compression
    Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
    DialogTypeSelection
    Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
    Fidelity
    Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
    Finishings
    Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
    JobSheets
    Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
    JobState
    JobState is a printing attribute class, an enumeration, that identifies the current state of a print job.
    JobStateReason
    Class JobStateReason is a printing attribute class, an enumeration, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
    Media
    Class Media is a printing attribute class that specifies the medium on which to print.
    MediaName
    Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
    MediaSize
    Class MediaSize is a two-dimensional size valued printing attribute class that indicates the dimensions of the medium in a portrait orientation, with the X dimension running along the bottom edge and the Y dimension running along the left edge.
    MediaSizeName
    Class MediaSizeName is a subclass of Media.
    MediaTray
    Class MediaTray is a subclass of Media.
    MultipleDocumentHandling
    Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
    OrientationRequested
    Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
    PDLOverrideSupported
    Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.
    PresentationDirection
    Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
    PrinterIsAcceptingJobs
    Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs.
    PrinterState
    Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer.
    PrinterStateReason
    Class PrinterStateReason is a printing attribute class, an enumeration, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
    PrintQuality
    Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
    ReferenceUriSchemesSupported
    Class ReferenceUriSchemesSupported is a printing attribute class an enumeration, that indicates a "URI scheme," such as "http:" or "ftp:", that a printer can use to retrieve print data stored at a URI location.
    Severity
    Class Severity is a printing attribute class, an enumeration, that denotes the severity of a PrinterStateReason attribute.
    SheetCollate
    Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.
    Sides
    Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cicPrtrsasss dbb/ttttx.vs


Uses of Class javax.print.attribute.standard.Chromaticity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Chromaticity

  • Packages that use Chromaticity
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Chromaticity in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Chromaticity
      修饰符与类型 字段与描述
      static Chromaticity Chromaticity.COLOR
      Color printing.
      static Chromaticity Chromaticity.MONOCHROME
      Monochrome printing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iocp pt


Uses of Class javax.print.attribute.standard.ColorSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.ColorSupported

  • Packages that use ColorSupported
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of ColorSupported in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as ColorSupported
      修饰符与类型 字段与描述
      static ColorSupported ColorSupported.NOT_SUPPORTED
      The printer is not capable of any type of color printing.
      static ColorSupported ColorSupported.SUPPORTED
      The printer is capable of some type of color printing, such as highlight color or full process color.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtp s==" >l o-pphRi"rt


Uses of Class javax.print.attribute.standard.Compression

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Compression

  • Packages that use Compression
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Compression in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Compression
      修饰符与类型 字段与描述
      static Compression Compression.COMPRESS
      UNIX compression technology.
      static Compression Compression.DEFLATE
      ZIP public domain inflate/deflate compression technology.
      static Compression Compression.GZIP
      GNU zip compression technology described in RFC 1952.
      static Compression Compression.NONE
      No compression is used.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

so scKu /ise莌 nls.dis


Uses of Class javax.print.attribute.standard.Copies

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Copies

No usage of javax.print.attribute.standard.Copies
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se=>e>


Uses of Class javax.print.attribute.standard.CopiesSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.CopiesSupported

No usage of javax.print.attribute.standard.CopiesSupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/"t"=v<"


Uses of Class javax.print.attribute.standard.DateTimeAtCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.DateTimeAtCompleted

No usage of javax.print.attribute.standard.DateTimeAtCompleted
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o<"vsie


Uses of Class javax.print.attribute.standard.DateTimeAtCreation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.DateTimeAtCreation

No usage of javax.print.attribute.standard.DateTimeAtCreation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>aot>>l


Uses of Class javax.print.attribute.standard.DateTimeAtProcessing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.DateTimeAtProcessing

No usage of javax.print.attribute.standard.DateTimeAtProcessing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e馻ilmsrF


Uses of Class javax.print.attribute.standard.Destination

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Destination

No usage of javax.print.attribute.standard.Destination
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆ �<


Uses of Class javax.print.attribute.standard.DialogTypeSelection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.DialogTypeSelection

  • Packages that use DialogTypeSelection
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of DialogTypeSelection in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as DialogTypeSelection
      修饰符与类型 | 字段与描述
      static DialogTypeSelection | DialogTypeSelection.COMMON
      static DialogTypeSelection | DialogTypeSelection.NATIVE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orceo d薬�


Uses of Class javax.print.attribute.standard.DocumentName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.DocumentName

No usage of javax.print.attribute.standard.DocumentName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ehliardtsaaat. inntj


Uses of Class javax.print.attribute.standard.Fidelity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Fidelity

  • Packages that use Fidelity
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Fidelity in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Fidelity
      修饰符与类型 字段与描述
      static Fidelity Fidelity.FIDELITY_FALSE
      The printer should make reasonable attempts to print the job, even if it cannot print it exactly as specified.
      static Fidelity Fidelity.FIDELITY_TRUE
      The job must be printed exactly as specified.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.o>>ba/ltssl<=/


Uses of Class javax.print.attribute.standard.Finishings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Finishings

  • Packages that use Finishings
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Finishings in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Finishings
      修饰符与类型 字段与描述
      static Finishings Finishings.BIND
      This value indicates that a binding is to be applied to the document; the type and placement of the binding is site-defined.
      static Finishings Finishings.COVER
      This value is specified when it is desired to select a non-printed (or pre-printed) cover for the document.
      static Finishings Finishings.EDGE_STITCH
      Bind the document(s) with one or more staples (wire stitches) along one edge.
      static Finishings Finishings.EDGE_STITCH_BOTTOM
      Bind the document(s) with one or more staples (wire stitches) along the bottom edge.
      static Finishings Finishings.EDGE_STITCH_LEFT
      Bind the document(s) with one or more staples (wire stitches) along the left edge.
      static Finishings Finishings.EDGE_STITCH_RIGHT
      Bind the document(s) with one or more staples (wire stitches) along the right edge.
      static Finishings Finishings.EDGE_STITCH_TOP
      Bind the document(s) with one or more staples (wire stitches) along the top edge.
      static Finishings Finishings.NONE
      Perform no binding.
      static Finishings Finishings.SADDLE_STITCH
      Bind the document(s) with one or more staples (wire stitches) along the middle fold.
      static Finishings Finishings.STAPLE
      Bind the document(s) with one or more staples.
      static Finishings Finishings.STAPLE_BOTTOM_LEFT
      Bind the document(s) with one or more staples in the bottom left corner.
      static Finishings Finishings.STAPLE_BOTTOM_RIGHT
      Bind the document(s) with one or more staples in the bottom right corner.
      static Finishings Finishings.STAPLE_DUAL_BOTTOM
      Bind the document(s) with two staples (wire stitches) along the bottom edge assuming a portrait document (see above).
      static Finishings Finishings.STAPLE_DUAL_LEFT
      Bind the document(s) with two staples (wire stitches) along the left edge assuming a portrait document (see above).
      static Finishings Finishings.STAPLE_DUAL_RIGHT
      Bind the document(s) with two staples (wire stitches) along the right edge assuming a portrait document (see above).
      static Finishings Finishings.STAPLE_DUAL_TOP
      Bind the document(s) with two staples (wire stitches) along the top edge assuming a portrait document (see above).
      static Finishings Finishings.STAPLE_TOP_LEFT
      Bind the document(s) with one or more staples in the top left corner.
      static Finishings Finishings.STAPLE_TOP_RIGHT
      Bind the document(s) with one or more staples in the top right corner.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.sarmP>aecaeuuvae/nt<


Uses of Class javax.print.attribute.standard.JobHoldUntil

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobHoldUntil

No usage of javax.print.attribute.standard.JobHoldUntil
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cblttaeh/e


Uses of Class javax.print.attribute.standard.JobImpressions

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobImpressions

No usage of javax.print.attribute.standard.JobImpressions
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>>� eilmolse=itI


Uses of Class javax.print.attribute.standard.JobImpressionsCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobImpressionsCompleted

No usage of javax.print.attribute.standard.JobImpressionsCompleted
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p"Oxtr<


Uses of Class javax.print.attribute.standard.JobImpressionsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobImpressionsSupported

No usage of javax.print.attribute.standard.JobImpressionsSupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"hr>o� �>


Uses of Class javax.print.attribute.standard.JobKOctets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobKOctets

No usage of javax.print.attribute.standard.JobKOctets
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Class javax.print.attribute.standard.JobKOctetsProcessed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobKOctetsProcessed

No usage of javax.print.attribute.standard.JobKOctetsProcessed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i>sor>s>gsK


Uses of Class javax.print.attribute.standard.JobKOctetsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobKOctetsSupported

No usage of javax.print.attribute.standard.JobKOctetsSupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rre躶羘 <0 豨a


Uses of Class javax.print.attribute.standard.JobMediaSheets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobMediaSheets

No usage of javax.print.attribute.standard.JobMediaSheets
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ar/ab;1;p-1


Uses of Class javax.print.attribute.standard.JobMediaSheetsCompleted

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobMediaSheetsCompleted

No usage of javax.print.attribute.standard.JobMediaSheetsCompleted
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

't"=ir8=/,oop -


Uses of Class javax.print.attribute.standard.JobMediaSheetsSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobMediaSheetsSupported

No usage of javax.print.attribute.standard.JobMediaSheetsSupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mt/r@b\e�,|


Uses of Class javax.print.attribute.standard.JobMessageFromOperator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobMessageFromOperator

No usage of javax.print.attribute.standard.JobMessageFromOperator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>et>>lmb &\t>


Uses of Class javax.print.attribute.standard.JobName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobName

No usage of javax.print.attribute.standard.JobName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA"yachc/y.m谤h<鎟╩�


Uses of Class javax.print.attribute.standard.JobOriginatingUserName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobOriginatingUserName

No usage of javax.print.attribute.standard.JobOriginatingUserName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

in//ikC"dp_ an sun


Uses of Class javax.print.attribute.standard.JobPriority

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobPriority

No usage of javax.print.attribute.standard.JobPriority
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


Uses of Class javax.print.attribute.standard.JobPrioritySupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobPrioritySupported

No usage of javax.print.attribute.standard.JobPrioritySupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.P j/<./oo


Uses of Class javax.print.attribute.standard.JobSheets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobSheets

  • Packages that use JobSheets
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of JobSheets in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as JobSheets
      修饰符与类型 字段与描述
      static JobSheets JobSheets.NONE
      No job sheets are printed.
      static JobSheets JobSheets.STANDARD
      One or more site specific standard job sheets are printed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rbaecsc>n,-etort/>sd醓


Uses of Class javax.print.attribute.standard.JobState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobState

  • Packages that use JobState
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of JobState in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as JobState
      修饰符与类型 字段与描述
      static JobState JobState.ABORTED
      The job has been aborted by the system (usually while the job was in the PROCESSING or PROCESSING_STOPPED state), the printer has completed aborting the job, and all job status attributes have reached their final values for the job.
      static JobState JobState.CANCELED
      The job has been canceled by some human agency, the printer has completed canceling the job, and all job status attributes have reached their final values for the job.
      static JobState JobState.COMPLETED
      The job has completed successfully or with warnings or errors after processing, all of the job media sheets have been successfully stacked in the appropriate output bin(s), and all job status attributes have reached their final values for the job.
      static JobState JobState.PENDING
      The job is a candidate to start processing, but is not yet processing.
      static JobState JobState.PENDING_HELD
      The job is not a candidate for processing for any number of reasons but will return to the PENDING state as soon as the reasons are no longer present.
      static JobState JobState.PROCESSING
      The job is processing.
      static JobState JobState.PROCESSING_STOPPED
      The job has stopped while processing for any number of reasons and will return to the PROCESSING state as soon as the reasons are no longer present.
      static JobState JobState.UNKNOWN
      The job state is unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a..Pv�3


Uses of Class javax.print.attribute.standard.JobStateReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobStateReason

  • Packages that use JobStateReason
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of JobStateReason in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as JobStateReason
      修饰符与类型 字段与描述
      static JobStateReason JobStateReason.ABORTED_BY_SYSTEM
      The job was aborted by the system.
      static JobStateReason JobStateReason.COMPRESSION_ERROR
      The job was aborted by the system because the printer encountered an error in the document data while decompressing it.
      static JobStateReason JobStateReason.DOCUMENT_ACCESS_ERROR
      The Printer could not access one or more documents passed by reference (i.e., the print data representation object is a URL).
      static JobStateReason JobStateReason.DOCUMENT_FORMAT_ERROR
      The job was aborted by the system because the printer encountered an error in the document data while processing it.
      static JobStateReason JobStateReason.JOB_CANCELED_AT_DEVICE
      The job was canceled by an unidentified local user, i.e., a user at a console at the device.
      static JobStateReason JobStateReason.JOB_CANCELED_BY_OPERATOR
      The job was canceled by the operator, i.e., by a user who has been authenticated as having operator privileges (whether local or remote).
      static JobStateReason JobStateReason.JOB_CANCELED_BY_USER
      The job was canceled by the owner of the job, i.e., by a user whose authenticated identity is the same as the value of the originating user that created the Print Job, or by some other authorized end-user, such as a member of the job owner's security group.
      static JobStateReason JobStateReason.JOB_COMPLETED_SUCCESSFULLY
      The job completed successfully.
      static JobStateReason JobStateReason.JOB_COMPLETED_WITH_ERRORS
      The job completed with errors (and possibly warnings too).
      static JobStateReason JobStateReason.JOB_COMPLETED_WITH_WARNINGS
      The job completed with warnings.
      static JobStateReason JobStateReason.JOB_DATA_INSUFFICIENT
      The printer has created the Print Job, but the printer is expecting additional print data before it can move the job into the PROCESSING state.
      static JobStateReason JobStateReason.JOB_HOLD_UNTIL_SPECIFIED
      The value of the job's JobHoldUntil attribute was specified with a date-time that is still in the future.
      static JobStateReason JobStateReason.JOB_INCOMING
      The printer has created the Print Job, but the printer has not finished accessing or accepting all the print data yet.
      static JobStateReason JobStateReason.JOB_INTERPRETING
      The job is in the PROCESSING state, but more specifically, the printer ia interpreting the document data.
      static JobStateReason JobStateReason.JOB_OUTGOING
      The printer is transmitting the job to the output device.
      static JobStateReason JobStateReason.JOB_PRINTING
      The output device is marking media.
      static JobStateReason JobStateReason.JOB_QUEUED
      The job is in the PROCESSING state, but more specifically, the printer has queued the document data.
      static JobStateReason JobStateReason.JOB_QUEUED_FOR_MARKER
      The job is in the PENDING_HELD, PENDING, or PROCESSING state, but more specifically, the printer has completed enough processing of the document to be able to start marking and the job is waiting for the marker.
      static JobStateReason JobStateReason.JOB_RESTARTABLE
      This job is retained and is currently able to be restarted.
      static JobStateReason JobStateReason.JOB_TRANSFORMING
      The job is in the PROCESSING state, but more specifically, the printer is interpreting document data and producing another electronic representation.
      static JobStateReason JobStateReason.PRINTER_STOPPED
      The value of the printer's PrinterState attribute ia STOPPED.
      static JobStateReason JobStateReason.PRINTER_STOPPED_PARTLY
      The value of the printer's PrinterStateReasons attribute contains a PrinterStateReason value of STOPPED_PARTLY.
      static JobStateReason JobStateReason.PROCESSING_TO_STOP_POINT
      The requester has canceled the job or the printer has aborted the job, but the printer is still performing some actions on the job until a specified stop point occurs or job termination/cleanup is completed.
      static JobStateReason JobStateReason.QUEUED_IN_DEVICE
      The job has been forwarded to a device or print system that is unable to send back status.
      static JobStateReason JobStateReason.RESOURCES_ARE_NOT_READY
      At least one of the resources needed by the job, such as media, fonts, resource objects, etc., is not ready on any of the physical printers for which the job is a candidate.
      static JobStateReason JobStateReason.SERVICE_OFF_LINE
      The printer is off-line and accepting no jobs.
      static JobStateReason JobStateReason.SUBMISSION_INTERRUPTED
      The job was not completely submitted for some unforeseen reason.
      static JobStateReason JobStateReason.UNSUPPORTED_COMPRESSION
      The job was aborted by the system because the printer determined while attempting to decompress the document's data that the compression is actually not among those supported by the printer.
      static JobStateReason JobStateReason.UNSUPPORTED_DOCUMENT_FORMAT
      The job was aborted by the system because the document data's document format (doc flavor) is not among those supported by the printer.
      Methods in javax.print.attribute.standard with parameters of type JobStateReason
      修饰符与类型 方法与描述
      boolean JobStateReasons.add(JobStateReason o)
      Adds the specified element to this job state reasons attribute if it is not already present.
      Constructor parameters in javax.print.attribute.standard with type arguments of type JobStateReason
      构造方法与描述
      JobStateReasons(Collection<JobStateReason> collection)
      Construct a new job state reasons attribute that contains the same JobStateReason objects as the given collection.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rB> ngfp>膐s/�<鄀<./琫


Uses of Class javax.print.attribute.standard.JobStateReasons

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.JobStateReasons

No usage of javax.print.attribute.standard.JobStateReasons
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctls"coalsssd


Uses of Class javax.print.attribute.standard.Media

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Media

  • Packages that use Media
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Media in javax.print.attribute.standard

      Subclasses of Media in javax.print.attribute.standard
      修饰符与类型 类与描述
      class  MediaName
      Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
      class  MediaSizeName
      Class MediaSizeName is a subclass of Media.
      class  MediaTray
      Class MediaTray is a subclass of Media.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ca /slsphf.jv/ea iavht


Uses of Class javax.print.attribute.standard.MediaName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaName

  • Packages that use MediaName
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of MediaName in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as MediaName
      修饰符与类型 字段与描述
      static MediaName MediaName.ISO_A4_TRANSPARENT
      A4 transparency.
      static MediaName MediaName.ISO_A4_WHITE
      white A4 paper.
      static MediaName MediaName.NA_LETTER_TRANSPARENT
      letter transparency.
      static MediaName MediaName.NA_LETTER_WHITE
      white letter paper.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/pltvoh <>Ftiysi t;te>


Uses of Class javax.print.attribute.standard.MediaPrintableArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaPrintableArea

No usage of javax.print.attribute.standard.MediaPrintableArea
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ar>A">IHWIIIAt//g>=aM


Uses of Class javax.print.attribute.standard.MediaSize

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize

  • Packages that use MediaSize
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of MediaSize in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as MediaSize
      修饰符与类型 字段与描述
      static MediaSize MediaSize.Engineering.A
      Specifies the engineering A size, 8.5 inch by 11 inch.
      static MediaSize MediaSize.ISO.A0
      Specifies the ISO A0 size, 841 mm by 1189 mm.
      static MediaSize MediaSize.ISO.A1
      Specifies the ISO A1 size, 594 mm by 841 mm.
      static MediaSize MediaSize.ISO.A10
      Specifies the ISO A10 size, 26 mm by 37 mm.
      static MediaSize MediaSize.ISO.A2
      Specifies the ISO A2 size, 420 mm by 594 mm.
      static MediaSize MediaSize.ISO.A3
      Specifies the ISO A3 size, 297 mm by 420 mm.
      static MediaSize MediaSize.ISO.A4
      Specifies the ISO A4 size, 210 mm by 297 mm.
      static MediaSize MediaSize.ISO.A5
      Specifies the ISO A5 size, 148 mm by 210 mm.
      static MediaSize MediaSize.ISO.A6
      Specifies the ISO A6 size, 105 mm by 148 mm.
      static MediaSize MediaSize.ISO.A7
      Specifies the ISO A7 size, 74 mm by 105 mm.
      static MediaSize MediaSize.ISO.A8
      Specifies the ISO A8 size, 52 mm by 74 mm.
      static MediaSize MediaSize.ISO.A9
      Specifies the ISO A9 size, 37 mm by 52 mm.
      static MediaSize MediaSize.Engineering.B
      Specifies the engineering B size, 11 inch by 17 inch.
      static MediaSize MediaSize.ISO.B0
      Specifies the ISO B0 size, 1000 mm by 1414 mm.
      static MediaSize MediaSize.JIS.B0
      Specifies the JIS B0 size, 1030 mm by 1456 mm.
      static MediaSize MediaSize.ISO.B1
      Specifies the ISO B1 size, 707 mm by 1000 mm.
      static MediaSize MediaSize.JIS.B1
      Specifies the JIS B1 size, 728 mm by 1030 mm.
      static MediaSize MediaSize.ISO.B10
      Specifies the ISO B10 size, 31 mm by 44 mm.
      static MediaSize MediaSize.JIS.B10
      Specifies the JIS B10 size, 32 mm by 45 mm.
      static MediaSize MediaSize.ISO.B2
      Specifies the ISO B2 size, 500 mm by 707 mm.
      static MediaSize MediaSize.JIS.B2
      Specifies the JIS B2 size, 515 mm by 728 mm.
      static MediaSize MediaSize.ISO.B3
      Specifies the ISO B3 size, 353 mm by 500 mm.
      static MediaSize MediaSize.JIS.B3
      Specifies the JIS B3 size, 364 mm by 515 mm.
      static MediaSize MediaSize.ISO.B4
      Specifies the ISO B4 size, 250 mm by 353 mm.
      static MediaSize MediaSize.JIS.B4
      Specifies the JIS B4 size, 257 mm by 364 mm.
      static MediaSize MediaSize.ISO.B5
      Specifies the ISO B5 size, 176 mm by 250 mm.
      static MediaSize MediaSize.JIS.B5
      Specifies the JIS B5 size, 182 mm by 257 mm.
      static MediaSize MediaSize.ISO.B6
      Specifies the ISO B6 size, 125 mm by 176 mm.
      static MediaSize MediaSize.JIS.B6
      Specifies the JIS B6 size, 128 mm by 182 mm.
      static MediaSize MediaSize.ISO.B7
      Specifies the ISO B7 size, 88 mm by 125 mm.
      static MediaSize MediaSize.JIS.B7
      Specifies the JIS B7 size, 91 mm by 128 mm.
      static MediaSize MediaSize.ISO.B8
      Specifies the ISO B8 size, 62 mm by 88 mm.
      static MediaSize MediaSize.JIS.B8
      Specifies the JIS B8 size, 64 mm by 91 mm.
      static MediaSize MediaSize.ISO.B9
      Specifies the ISO B9 size, 44 mm by 62 mm.
      static MediaSize MediaSize.JIS.B9
      Specifies the JIS B9 size, 45 mm by 64 mm.
      static MediaSize MediaSize.Engineering.C
      Specifies the engineering C size, 17 inch by 22 inch.
      static MediaSize MediaSize.ISO.C3
      Specifies the ISO C3 size, 324 mm by 458 mm.
      static MediaSize MediaSize.ISO.C4
      Specifies the ISO C4 size, 229 mm by 324 mm.
      static MediaSize MediaSize.ISO.C5
      Specifies the ISO C5 size, 162 mm by 229 mm.
      static MediaSize MediaSize.ISO.C6
      Specifies the ISO C6 size, 114 mm by 162 mm.
      static MediaSize MediaSize.JIS.CHOU_1
      Specifies the JIS Chou ("long") #1 envelope size, 142 mm by 332 mm.
      static MediaSize MediaSize.JIS.CHOU_2
      Specifies the JIS Chou ("long") #2 envelope size, 119 mm by 277 mm.
      static MediaSize MediaSize.JIS.CHOU_3
      Specifies the JIS Chou ("long") #3 envelope size, 120 mm by 235 mm.
      static MediaSize MediaSize.JIS.CHOU_30
      Specifies the JIS Chou ("long") #30 envelope size, 92 mm by 235 mm.
      static MediaSize MediaSize.JIS.CHOU_4
      Specifies the JIS Chou ("long") #4 envelope size, 90 mm by 205 mm.
      static MediaSize MediaSize.JIS.CHOU_40
      Specifies the JIS Chou ("long") #40 envelope size, 90 mm by 225 mm.
      static MediaSize MediaSize.Engineering.D
      Specifies the engineering D size, 22 inch by 34 inch.
      static MediaSize MediaSize.ISO.DESIGNATED_LONG
      Specifies the ISO Designated Long size, 110 mm by 220 mm.
      static MediaSize MediaSize.Engineering.E
      Specifies the engineering E size, 34 inch by 44 inch.
      static MediaSize MediaSize.Other.EXECUTIVE
      Specifies the executive size, 7.25 inches by 10.5 inches.
      static MediaSize MediaSize.Other.FOLIO
      Specifies the folio size, 8.5 inches by 13 inches.
      static MediaSize MediaSize.Other.INVOICE
      Specifies the invoice size, 5.5 inches by 8.5 inches.
      static MediaSize MediaSize.Other.ITALY_ENVELOPE
      Specifies the Italy envelope size, 110 mm by 230 mm.
      static MediaSize MediaSize.Other.JAPANESE_DOUBLE_POSTCARD
      Specifies the Japanese Double postcard size, 148 mm by 200 mm.
      static MediaSize MediaSize.Other.JAPANESE_POSTCARD
      Specifies the Japanese postcard size, 100 mm by 148 mm.
      static MediaSize MediaSize.JIS.KAKU_0
      Specifies the JIS Kaku ("square") #0 envelope size, 287 mm by 382 mm.
      static MediaSize MediaSize.JIS.KAKU_1
      Specifies the JIS Kaku ("square") #1 envelope size, 270 mm by 382 mm.
      static MediaSize MediaSize.JIS.KAKU_2
      Specifies the JIS Kaku ("square") #2 envelope size, 240 mm by 332 mm.
      static MediaSize MediaSize.JIS.KAKU_20
      Specifies the JIS Kaku ("square") #20 envelope size, 229 mm by 324 mm.
      static MediaSize MediaSize.JIS.KAKU_3
      Specifies the JIS Kaku ("square") #3 envelope size, 216 mm by 277 mm.
      static MediaSize MediaSize.JIS.KAKU_4
      Specifies the JIS Kaku ("square") #4 envelope size, 197 mm by 267 mm.
      static MediaSize MediaSize.JIS.KAKU_5
      Specifies the JIS Kaku ("square") #5 envelope size, 190 mm by 240 mm.
      static MediaSize MediaSize.JIS.KAKU_6
      Specifies the JIS Kaku ("square") #6 envelope size, 162 mm by 229 mm.
      static MediaSize MediaSize.JIS.KAKU_7
      Specifies the JIS Kaku ("square") #7 envelope size, 142 mm by 205 mm.
      static MediaSize MediaSize.JIS.KAKU_8
      Specifies the JIS Kaku ("square") #8 envelope size, 119 mm by 197 mm.
      static MediaSize MediaSize.JIS.KAKU_A4
      Specifies the JIS Kaku ("square") A4 envelope size, 228 mm by 312 mm.
      static MediaSize MediaSize.Other.LEDGER
      Specifies the ledger size, 11 inches by 17 inches.
      static MediaSize MediaSize.NA.LEGAL
      Specifies the North American legal size, 8.5 inches by 14 inches.
      static MediaSize MediaSize.NA.LETTER
      Specifies the North American letter size, 8.5 inches by 11 inches.
      static MediaSize MediaSize.Other.MONARCH_ENVELOPE
      Specifies the Monarch envelope size, 3.87 inch by 7.5 inch.
      static MediaSize MediaSize.NA.NA_10x13_ENVELOPE
      Specifies the North American 10 inch by 13 inch envelope size.
      static MediaSize MediaSize.NA.NA_10x14_ENVELOPE
      Specifies the North American 10 inch by 14 inch envelope size.
      static MediaSize MediaSize.NA.NA_10X15_ENVELOPE
      Specifies the North American 10 inch by 15 inch envelope size.
      static MediaSize MediaSize.NA.NA_5X7
      Specifies the North American 5 inch by 7 inch paper.
      static MediaSize MediaSize.NA.NA_6X9_ENVELOPE
      Specifies the North American 6 inch by 9 inch envelope size.
      static MediaSize MediaSize.NA.NA_7X9_ENVELOPE
      Specifies the North American 7 inch by 9 inch envelope size.
      static MediaSize MediaSize.NA.NA_8X10
      Specifies the North American 8 inch by 10 inch paper.
      static MediaSize MediaSize.NA.NA_9x11_ENVELOPE
      Specifies the North American 9 inch by 11 inch envelope size.
      static MediaSize MediaSize.NA.NA_9x12_ENVELOPE
      Specifies the North American 9 inch by 12 inch envelope size.
      static MediaSize MediaSize.NA.NA_NUMBER_10_ENVELOPE
      Specifies the North American Number 10 business envelope size, 4.125 inches by 9.5 inches.
      static MediaSize MediaSize.NA.NA_NUMBER_11_ENVELOPE
      Specifies the North American Number 11 business envelope size, 4.5 inches by 10.375 inches.
      static MediaSize MediaSize.NA.NA_NUMBER_12_ENVELOPE
      Specifies the North American Number 12 business envelope size, 4.75 inches by 11 inches.
      static MediaSize MediaSize.NA.NA_NUMBER_14_ENVELOPE
      Specifies the North American Number 14 business envelope size, 5 inches by 11.5 inches.
      static MediaSize MediaSize.NA.NA_NUMBER_9_ENVELOPE
      Specifies the North American Number 9 business envelope size, 3.875 inches by 8.875 inches.
      static MediaSize MediaSize.Other.PERSONAL_ENVELOPE
      Specifies the Personal envelope size, 3.625 inch by 6.5 inch.
      static MediaSize MediaSize.Other.QUARTO
      Specifies the quarto size, 8.5 inches by 10.83 inches.
      static MediaSize MediaSize.Other.TABLOID
      Specifies the tabloid size, 11 inches by 17 inches.
      static MediaSize MediaSize.JIS.YOU_1
      Specifies the JIS You ("Western") #1 envelope size, 120 mm by 176 mm.
      static MediaSize MediaSize.JIS.YOU_2
      Specifies the JIS You ("Western") #2 envelope size, 114 mm by 162 mm.
      static MediaSize MediaSize.JIS.YOU_3
      Specifies the JIS You ("Western") #3 envelope size, 98 mm by 148 mm.
      static MediaSize MediaSize.JIS.YOU_4
      Specifies the JIS You ("Western") #4 envelope size, 105 mm by 235 mm.
      static MediaSize MediaSize.JIS.YOU_5
      Specifies the JIS You ("Western") #5 envelope size, 95 mm by 217 mm.
      static MediaSize MediaSize.JIS.YOU_6
      Specifies the JIS You ("Western") #6 envelope size, 98 mm by 190 mm.
      static MediaSize MediaSize.JIS.YOU_7
      Specifies the JIS You ("Western") #7 envelope size, 92 mm by 165 mm.
      Methods in javax.print.attribute.standard that return MediaSize
      修饰符与类型 方法与描述
      static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
      Get the MediaSize for the specified named media.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.print.attribute.standard.MediaSize.Engineering

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize.Engineering

No usage of javax.print.attribute.standard.MediaSize.Engineering
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.u/lr�./ .o&>_


Uses of Class javax.print.attribute.standard.MediaSize.ISO

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize.ISO

No usage of javax.print.attribute.standard.MediaSize.ISO
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/p.aron>e<<


Uses of Class javax.print.attribute.standard.MediaSize.JIS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize.JIS

No usage of javax.print.attribute.standard.MediaSize.JIS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c"eAtv


Uses of Class javax.print.attribute.standard.MediaSize.NA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize.NA

No usage of javax.print.attribute.standard.MediaSize.NA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>�t>>ltcA


Uses of Class javax.print.attribute.standard.MediaSize.Other

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSize.Other

No usage of javax.print.attribute.standard.MediaSize.Other
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>gaf>S<=>i


Uses of Class javax.print.attribute.standard.MediaSizeName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaSizeName

  • Packages that use MediaSizeName
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of MediaSizeName in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as MediaSizeName
      修饰符与类型 字段与描述
      static MediaSizeName MediaSizeName.A
      A size .
      static MediaSizeName MediaSizeName.B
      B size .
      static MediaSizeName MediaSizeName.C
      C size .
      static MediaSizeName MediaSizeName.D
      D size .
      static MediaSizeName MediaSizeName.E
      E size .
      static MediaSizeName MediaSizeName.EXECUTIVE
      executive size .
      static MediaSizeName MediaSizeName.FOLIO
      folio size .
      static MediaSizeName MediaSizeName.INVOICE
      invoice size .
      static MediaSizeName MediaSizeName.ISO_A0
      A0 size.
      static MediaSizeName MediaSizeName.ISO_A1
      A1 size.
      static MediaSizeName MediaSizeName.ISO_A10
      A10 size.
      static MediaSizeName MediaSizeName.ISO_A2
      A2 size.
      static MediaSizeName MediaSizeName.ISO_A3
      A3 size.
      static MediaSizeName MediaSizeName.ISO_A4
      A4 size.
      static MediaSizeName MediaSizeName.ISO_A5
      A5 size.
      static MediaSizeName MediaSizeName.ISO_A6
      A6 size.
      static MediaSizeName MediaSizeName.ISO_A7
      A7 size.
      static MediaSizeName MediaSizeName.ISO_A8
      A8 size.
      static MediaSizeName MediaSizeName.ISO_A9
      A9 size.
      static MediaSizeName MediaSizeName.ISO_B0
      ISO B0 size.
      static MediaSizeName MediaSizeName.ISO_B1
      ISO B1 size.
      static MediaSizeName MediaSizeName.ISO_B10
      ISO B10 size.
      static MediaSizeName MediaSizeName.ISO_B2
      ISO B2 size.
      static MediaSizeName MediaSizeName.ISO_B3
      ISO B3 size.
      static MediaSizeName MediaSizeName.ISO_B4
      ISO B4 size.
      static MediaSizeName MediaSizeName.ISO_B5
      ISO B5 size.
      static MediaSizeName MediaSizeName.ISO_B6
      ISO B6 size.
      static MediaSizeName MediaSizeName.ISO_B7
      ISO B7 size.
      static MediaSizeName MediaSizeName.ISO_B8
      ISO B8 size.
      static MediaSizeName MediaSizeName.ISO_B9
      ISO B9 size.
      static MediaSizeName MediaSizeName.ISO_C0
      ISO C0 size.
      static MediaSizeName MediaSizeName.ISO_C1
      ISO C1 size.
      static MediaSizeName MediaSizeName.ISO_C2
      ISO C2 size.
      static MediaSizeName MediaSizeName.ISO_C3
      ISO C3 size.
      static MediaSizeName MediaSizeName.ISO_C4
      ISO C4 size.
      static MediaSizeName MediaSizeName.ISO_C5
      ISO C5 size.
      static MediaSizeName MediaSizeName.ISO_C6
      letter size.
      static MediaSizeName MediaSizeName.ISO_DESIGNATED_LONG
      ISO designated long size .
      static MediaSizeName MediaSizeName.ITALY_ENVELOPE
      Italy envelope size .
      static MediaSizeName MediaSizeName.JAPANESE_DOUBLE_POSTCARD
      Japanese Double Postcard size.
      static MediaSizeName MediaSizeName.JAPANESE_POSTCARD
      Japanese Postcard size.
      static MediaSizeName MediaSizeName.JIS_B0
      JIS B0 size.
      static MediaSizeName MediaSizeName.JIS_B1
      JIS B1 size.
      static MediaSizeName MediaSizeName.JIS_B10
      JIS B10 size.
      static MediaSizeName MediaSizeName.JIS_B2
      JIS B2 size.
      static MediaSizeName MediaSizeName.JIS_B3
      JIS B3 size.
      static MediaSizeName MediaSizeName.JIS_B4
      JIS B4 size.
      static MediaSizeName MediaSizeName.JIS_B5
      JIS B5 size.
      static MediaSizeName MediaSizeName.JIS_B6
      JIS B6 size.
      static MediaSizeName MediaSizeName.JIS_B7
      JIS B7 size.
      static MediaSizeName MediaSizeName.JIS_B8
      JIS B8 size.
      static MediaSizeName MediaSizeName.JIS_B9
      JIS B9 size.
      static MediaSizeName MediaSizeName.LEDGER
      ledger size .
      static MediaSizeName MediaSizeName.MONARCH_ENVELOPE
      monarch envelope size .
      static MediaSizeName MediaSizeName.NA_10X13_ENVELOPE
      10x13 North American envelope size .
      static MediaSizeName MediaSizeName.NA_10X14_ENVELOPE
      10x14North American envelope size .
      static MediaSizeName MediaSizeName.NA_10X15_ENVELOPE
      10x15 North American envelope size.
      static MediaSizeName MediaSizeName.NA_5X7
      5x7 North American paper.
      static MediaSizeName MediaSizeName.NA_6X9_ENVELOPE
      6x9 North American envelope size.
      static MediaSizeName MediaSizeName.NA_7X9_ENVELOPE
      7x9 North American envelope size.
      static MediaSizeName MediaSizeName.NA_8X10
      8x10 North American paper.
      static MediaSizeName MediaSizeName.NA_9X11_ENVELOPE
      9x11 North American envelope size.
      static MediaSizeName MediaSizeName.NA_9X12_ENVELOPE
      9x12 North American envelope size.
      static MediaSizeName MediaSizeName.NA_LEGAL
      legal size .
      static MediaSizeName MediaSizeName.NA_LETTER
      letter size.
      static MediaSizeName MediaSizeName.NA_NUMBER_10_ENVELOPE
      number 10 envelope size .
      static MediaSizeName MediaSizeName.NA_NUMBER_11_ENVELOPE
      number 11 envelope size .
      static MediaSizeName MediaSizeName.NA_NUMBER_12_ENVELOPE
      number 12 envelope size .
      static MediaSizeName MediaSizeName.NA_NUMBER_14_ENVELOPE
      number 14 envelope size .
      static MediaSizeName MediaSizeName.NA_NUMBER_9_ENVELOPE
      number 9 envelope size .
      static MediaSizeName MediaSizeName.PERSONAL_ENVELOPE
      personal envelope size .
      static MediaSizeName MediaSizeName.QUARTO
      quarto size .
      static MediaSizeName MediaSizeName.TABLOID
      tabloid size .
      Methods in javax.print.attribute.standard that return MediaSizeName
      修饰符与类型 方法与描述
      static MediaSizeName MediaSize.findMedia(float x, float y, int units)
      The specified dimensions are used to locate a matching MediaSize instance from amongst all the standard MediaSize instances.
      MediaSizeName MediaSize.getMediaSizeName()
      Get the media name, if any, for this size.
      Methods in javax.print.attribute.standard with parameters of type MediaSizeName
      修饰符与类型 方法与描述
      static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
      Get the MediaSize for the specified named media.
      Constructors in javax.print.attribute.standard with parameters of type MediaSizeName
      构造方法与描述
      MediaSize(float x, float y, int units, MediaSizeName media)
      Construct a new media size attribute from the given floating-point values.
      MediaSize(int x, int y, int units, MediaSizeName media)
      Construct a new media size attribute from the given integer values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s


Uses of Class javax.print.attribute.standard.MediaTray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MediaTray

  • Packages that use MediaTray
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of MediaTray in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as MediaTray
      修饰符与类型 字段与描述
      static MediaTray MediaTray.BOTTOM
      The bottom input tray in the printer.
      static MediaTray MediaTray.ENVELOPE
      The envelope input tray in the printer.
      static MediaTray MediaTray.LARGE_CAPACITY
      The large capacity input tray in the printer.
      static MediaTray MediaTray.MAIN
      The main input tray in the printer.
      static MediaTray MediaTray.MANUAL
      The manual feed input tray in the printer.
      static MediaTray MediaTray.MIDDLE
      The middle input tray in the printe.
      static MediaTray MediaTray.SIDE
      The side input tray.
      static MediaTray MediaTray.TOP
      The top input tray in the printer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

M"e/rib/taaar///tnt"sa


Uses of Class javax.print.attribute.standard.MultipleDocumentHandling

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.MultipleDocumentHandling

  • Packages that use MultipleDocumentHandling
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of MultipleDocumentHandling in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as MultipleDocumentHandling
      修饰符与类型 字段与描述
      static MultipleDocumentHandling MultipleDocumentHandling.SEPARATE_DOCUMENTS_COLLATED_COPIES
      Separate documents collated copies -- see above for further information.
      static MultipleDocumentHandling MultipleDocumentHandling.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
      Separate documents uncollated copies -- see above for further information.
      static MultipleDocumentHandling MultipleDocumentHandling.SINGLE_DOCUMENT
      Single document -- see above for further information.
      static MultipleDocumentHandling MultipleDocumentHandling.SINGLE_DOCUMENT_NEW_SHEET
      Single document new sheet -- see above for further information.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> s-


Uses of Class javax.print.attribute.standard.NumberOfDocuments

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.NumberOfDocuments

No usage of javax.print.attribute.standard.NumberOfDocuments
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

# s/rib/taaar/// esc.


Uses of Class javax.print.attribute.standard.NumberOfInterveningJobs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.NumberOfInterveningJobs

No usage of javax.print.attribute.standard.NumberOfInterveningJobs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rl/i> " //s//m.hc/a


Uses of Class javax.print.attribute.standard.NumberUp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.NumberUp

No usage of javax.print.attribute.standard.NumberUp
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA"yachc/y.m谤h<鎟╩�


Uses of Class javax.print.attribute.standard.NumberUpSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.NumberUpSupported

No usage of javax.print.attribute.standard.NumberUpSupported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-scRo/r竍d3lvh.ea.


Uses of Class javax.print.attribute.standard.OrientationRequested

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.OrientationRequested

  • Packages that use OrientationRequested
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of OrientationRequested in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as OrientationRequested
      修饰符与类型 字段与描述
      static OrientationRequested OrientationRequested.LANDSCAPE
      The content will be imaged across the long edge of the medium.
      static OrientationRequested OrientationRequested.PORTRAIT
      The content will be imaged across the short edge of the medium.
      static OrientationRequested OrientationRequested.REVERSE_LANDSCAPE
      The content will be imaged across the long edge of the medium, but in the opposite manner from landscape.
      static OrientationRequested OrientationRequested.REVERSE_PORTRAIT
      The content will be imaged across the short edge of the medium, but in the opposite manner from portrait.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

leloaFed.vlce/r黀礶黀bc�:


Uses of Class javax.print.attribute.standard.OutputDeviceAssigned

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.OutputDeviceAssigned

No usage of javax.print.attribute.standard.OutputDeviceAssigned
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

apntintxa...jlmm..ral


Uses of Class javax.print.attribute.standard.PageRanges

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PageRanges

No usage of javax.print.attribute.standard.PageRanges
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ap—间讳篇嗽冰籶Ｃ粼3


Uses of Class javax.print.attribute.standard.PagesPerMinute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PagesPerMinute

No usage of javax.print.attribute.standard.PagesPerMinute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>tlont>g莞be3&ral>bi


Uses of Class javax.print.attribute.standard.PagesPerMinuteColor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PagesPerMinuteColor

No usage of javax.print.attribute.standard.PagesPerMinuteColor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

meltrC>lptt.i�.<"t.


Uses of Class javax.print.attribute.standard.PDLOverrideSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PDLOverrideSupported

  • Packages that use PDLOverrideSupported
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PDLOverrideSupported in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PDLOverrideSupported
      修饰符与类型 字段与描述
      static PDLOverrideSupported PDLOverrideSupported.ATTEMPTED
      The printer attempts to make the external job attribute values take precedence over embedded instructions in the documents' print data, however there is no guarantee.
      static PDLOverrideSupported PDLOverrideSupported.NOT_ATTEMPTED
      The printer makes no attempt to make the external job attribute values take precedence over embedded instructions in the documents' print data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>e <"m- aC txtlnlslek>a<


Uses of Class javax.print.attribute.standard.PresentationDirection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PresentationDirection

  • Packages that use PresentationDirection
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PresentationDirection in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PresentationDirection
      修饰符与类型 字段与描述
      static PresentationDirection PresentationDirection.TOBOTTOM_TOLEFT
      Pages are laid out in columns starting at the top right, proceeeding towards the bottom & left.
      static PresentationDirection PresentationDirection.TOBOTTOM_TORIGHT
      Pages are laid out in columns starting at the top left, proceeeding towards the bottom & right.
      static PresentationDirection PresentationDirection.TOLEFT_TOBOTTOM
      Pages are laid out in rows starting at the top right, proceeeding towards the left & bottom.
      static PresentationDirection PresentationDirection.TOLEFT_TOTOP
      Pages are laid out in rows starting at the bottom right, proceeeding towards the left & top.
      static PresentationDirection PresentationDirection.TORIGHT_TOBOTTOM
      Pages are laid out in rows starting at the top left, proceeeding towards the right & bottom.
      static PresentationDirection PresentationDirection.TORIGHT_TOTOP
      Pages are laid out in rows starting at the bottom left, proceeeding towards the right & top.
      static PresentationDirection PresentationDirection.TOTOP_TOLEFT
      Pages are laid out in columns starting at the bottom right, proceeeding towards the top & left.
      static PresentationDirection PresentationDirection.TOTOP_TORIGHT
      Pages are laid out in columns starting at the bottom left, proceeeding towards the top & right.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/s=nA>u >rpeOya�=鸥


Uses of Class javax.print.attribute.standard.PrinterInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterInfo

No usage of javax.print.attribute.standard.PrinterInfo
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

leoaimmtltt


Uses of Class javax.print.attribute.standard.PrinterIsAcceptingJobs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterIsAcceptingJobs

  • Packages that use PrinterIsAcceptingJobs
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrinterIsAcceptingJobs in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PrinterIsAcceptingJobs
      修饰符与类型 字段与描述
      static PrinterIsAcceptingJobs PrinterIsAcceptingJobs.ACCEPTING_JOBS
      The printer is currently acccepting jobs.
      static PrinterIsAcceptingJobs PrinterIsAcceptingJobs.NOT_ACCEPTING_JOBS
      The printer is currently rejecting any jobs sent to it.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rccreoitnntdbtlopcci a.


Uses of Class javax.print.attribute.standard.PrinterLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterLocation

No usage of javax.print.attribute.standard.PrinterLocation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


Uses of Class javax.print.attribute.standard.PrinterMakeAndModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterMakeAndModel

No usage of javax.print.attribute.standard.PrinterMakeAndModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c/ioJcpe-t"Areavaoa<


Uses of Class javax.print.attribute.standard.PrinterMessageFromOperator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterMessageFromOperator

No usage of javax.print.attribute.standard.PrinterMessageFromOperator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pls"JipeycaAr."stls


Uses of Class javax.print.attribute.standard.PrinterMoreInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterMoreInfo

No usage of javax.print.attribute.standard.PrinterMoreInfo
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


Uses of Class javax.print.attribute.standard.PrinterMoreInfoManufacturer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterMoreInfoManufacturer

No usage of javax.print.attribute.standard.PrinterMoreInfoManufacturer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnnl8CAeaDi


Uses of Class javax.print.attribute.standard.PrinterName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterName

No usage of javax.print.attribute.standard.PrinterName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>l...l.../gchl藀.rgl


Uses of Class javax.print.attribute.standard.PrinterResolution

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterResolution

No usage of javax.print.attribute.standard.PrinterResolution
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

V.ar间籸_sa""t� a


Uses of Class javax.print.attribute.standard.PrinterState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterState

  • Packages that use PrinterState
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrinterState in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PrinterState
      修饰符与类型 字段与描述
      static PrinterState PrinterState.IDLE
      Indicates that new jobs can start processing without waiting.
      static PrinterState PrinterState.PROCESSING
      Indicates that jobs are processing; new jobs will wait before processing.
      static PrinterState PrinterState.STOPPED
      Indicates that no jobs can be processed and intervention is required.
      static PrinterState PrinterState.UNKNOWN
      The printer state is unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e馿i=al.hfsl.roeaogs>


Uses of Class javax.print.attribute.standard.PrinterStateReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterStateReason

  • Packages that use PrinterStateReason
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrinterStateReason in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PrinterStateReason
      修饰符与类型 字段与描述
      static PrinterStateReason PrinterStateReason.CONNECTING_TO_DEVICE
      The printer has scheduled a job on the output device and is in the process of connecting to a shared network output device (and might not be able to actually start printing the job for an arbitrarily long time depending on the usage of the output device by other servers on the network).
      static PrinterStateReason PrinterStateReason.COVER_OPEN
      One or more covers on the device are open.
      static PrinterStateReason PrinterStateReason.DEVELOPER_EMPTY
      The device is out of developer.
      static PrinterStateReason PrinterStateReason.DEVELOPER_LOW
      The device is low on developer.
      static PrinterStateReason PrinterStateReason.DOOR_OPEN
      One or more doors on the device are open.
      static PrinterStateReason PrinterStateReason.FUSER_OVER_TEMP
      The fuser temperature is above normal.
      static PrinterStateReason PrinterStateReason.FUSER_UNDER_TEMP
      The fuser temperature is below normal.
      static PrinterStateReason PrinterStateReason.INPUT_TRAY_MISSING
      One or more input trays are not in the device.
      static PrinterStateReason PrinterStateReason.INTERLOCK_OPEN
      One or more interlock devices on the printer are unlocked.
      static PrinterStateReason PrinterStateReason.INTERPRETER_RESOURCE_UNAVAILABLE
      An interpreter resource is unavailable (e.g., font, form).
      static PrinterStateReason PrinterStateReason.MARKER_SUPPLY_EMPTY
      The device is out of at least one marker supply (e.g.
      static PrinterStateReason PrinterStateReason.MARKER_SUPPLY_LOW
      The device is low on at least one marker supply (e.g.
      static PrinterStateReason PrinterStateReason.MARKER_WASTE_ALMOST_FULL
      The device marker supply waste receptacle is almost full.
      static PrinterStateReason PrinterStateReason.MARKER_WASTE_FULL
      The device marker supply waste receptacle is full.
      static PrinterStateReason PrinterStateReason.MEDIA_EMPTY
      At least one input tray is empty.
      static PrinterStateReason PrinterStateReason.MEDIA_JAM
      The device has a media jam.
      static PrinterStateReason PrinterStateReason.MEDIA_LOW
      At least one input tray is low on media.
      static PrinterStateReason PrinterStateReason.MEDIA_NEEDED
      A tray has run out of media.
      static PrinterStateReason PrinterStateReason.MOVING_TO_PAUSED
      Someone has paused the printer, but the device(s) are taking an appreciable time to stop.
      static PrinterStateReason PrinterStateReason.OPC_LIFE_OVER
      The optical photo conductor is no longer functioning.
      static PrinterStateReason PrinterStateReason.OPC_NEAR_EOL
      The optical photo conductor is near end of life.
      static PrinterStateReason PrinterStateReason.OTHER
      The printer has detected an error other than ones listed below.
      static PrinterStateReason PrinterStateReason.OUTPUT_AREA_ALMOST_FULL
      One or more output areas are almost full (e.g.
      static PrinterStateReason PrinterStateReason.OUTPUT_AREA_FULL
      One or more output areas are full (e.g.
      static PrinterStateReason PrinterStateReason.OUTPUT_TRAY_MISSING
      One or more output trays are not in the device.
      static PrinterStateReason PrinterStateReason.PAUSED
      Someone has paused the printer and the printer's PrinterState is STOPPED.
      static PrinterStateReason PrinterStateReason.SHUTDOWN
      Someone has removed a printer from service, and the device may be powered down or physically removed.
      static PrinterStateReason PrinterStateReason.SPOOL_AREA_FULL
      The limit of persistent storage allocated for spooling has been reached.
      static PrinterStateReason PrinterStateReason.STOPPED_PARTLY
      When a printer controls more than one output device, this reason indicates that one or more output devices are stopped.
      static PrinterStateReason PrinterStateReason.STOPPING
      The printer is in the process of stopping the device and will be stopped in a while.
      static PrinterStateReason PrinterStateReason.TIMED_OUT
      The server was able to connect to the output device (or is always connected), but was unable to get a response from the output device.
      static PrinterStateReason PrinterStateReason.TONER_EMPTY
      The device is out of toner.
      static PrinterStateReason PrinterStateReason.TONER_LOW
      The device is low on toner.
      Methods in javax.print.attribute.standard that return types with arguments of type PrinterStateReason
      修饰符与类型 方法与描述
      Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
      Obtain an unmodifiable set view of the individual printer state reason attributes at the given severity level in this PrinterStateReasons attribute.
      Methods in javax.print.attribute.standard with parameters of type PrinterStateReason
      修饰符与类型 方法与描述
      Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
      Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level.
      Constructor parameters in javax.print.attribute.standard with type arguments of type PrinterStateReason
      构造方法与描述
      PrinterStateReasons(Map<PrinterStateReason,Severity> map)
      Construct a new printer state reasons attribute that contains the same PrinterStateReason-to-Severity mappings as the given map.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

er ov眑>


Uses of Class javax.print.attribute.standard.PrinterStateReasons

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterStateReasons

No usage of javax.print.attribute.standard.PrinterStateReasons
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ortdutphteeeoeeestnrn


Uses of Class javax.print.attribute.standard.PrinterURI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrinterURI

No usage of javax.print.attribute.standard.PrinterURI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

啜帘冰保了宣/�<◆ �<


Uses of Class javax.print.attribute.standard.PrintQuality

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.PrintQuality

  • Packages that use PrintQuality
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of PrintQuality in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as PrintQuality
      修饰符与类型 字段与描述
      static PrintQuality PrintQuality.DRAFT
      Lowest quality available on the printer.
      static PrintQuality PrintQuality.HIGH
      Highest quality available on the printer.
      static PrintQuality PrintQuality.NORMAL
      Normal or intermediate quality on the printer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>fcav


Uses of Class javax.print.attribute.standard.QueuedJobCount

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.QueuedJobCount

No usage of javax.print.attribute.standard.QueuedJobCount
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oin


Uses of Class javax.print.attribute.standard.ReferenceUriSchemesSupported

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.ReferenceUriSchemesSupported

  • Packages that use ReferenceUriSchemesSupported
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of ReferenceUriSchemesSupported in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as ReferenceUriSchemesSupported
      修饰符与类型 字段与描述
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.FILE
      Host-specific file names.
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.FTP
      File Transfer Protocol (FTP).
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.GOPHER
      Gopher Protocol.
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.HTTP
      HyperText Transfer Protocol (HTTP).
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.HTTPS
      Secure HyperText Transfer Protocol (HTTPS).
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.NEWS
      USENET news.
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.NNTP
      USENET news using Network News Transfer Protocol (NNTP).
      static ReferenceUriSchemesSupported ReferenceUriSchemesSupported.WAIS
      Wide Area Information Server (WAIS) protocol.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pierRrsotd&bet 衋satyut


Uses of Class javax.print.attribute.standard.RequestingUserName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.RequestingUserName

No usage of javax.print.attribute.standard.RequestingUserName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/r.aatied>>>


Uses of Class javax.print.attribute.standard.Severity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Severity

  • Packages that use Severity
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Severity in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Severity
      修饰符与类型 字段与描述
      static Severity Severity.ERROR
      Indicates that the PrinterStateReason is an "error" (most severe).
      static Severity Severity.REPORT
      Indicates that the PrinterStateReason is a "report" (least severe).
      static Severity Severity.WARNING
      Indicates that the PrinterStateReason is a "warning." An implementation may choose to omit some or all warnings.
      Methods in javax.print.attribute.standard that return Severity
      修饰符与类型 方法与描述
      Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
      Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level.
      Methods in javax.print.attribute.standard with parameters of type Severity
      修饰符与类型 方法与描述
      Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
      Obtain an unmodifiable set view of the individual printer state reason attributes at the given severity level in this PrinterStateReasons attribute.
      Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
      Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level.
      Constructor parameters in javax.print.attribute.standard with type arguments of type Severity
      构造方法与描述
      PrinterStateReasons(Map<PrinterStateReason,Severity> map)
      Construct a new printer state reasons attribute that contains the same PrinterStateReason-to-Severity mappings as the given map.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


Uses of Class javax.print.attribute.standard.SheetCollate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.SheetCollate

  • Packages that use SheetCollate
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of SheetCollate in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as SheetCollate
      修饰符与类型 字段与描述
      static SheetCollate SheetCollate.COLLATED
      Sheets within a document appear in collated order when multiple copies are printed.
      static SheetCollate SheetCollate.UNCOLLATED
      Sheets within a document appear in uncollated order when multiple copies are printed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

asn istel,,,trnntb />ltd


Uses of Class javax.print.attribute.standard.Sides

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.attribute.standard.Sides

  • Packages that use Sides
    软件包 描述
    javax.print.attribute.standard
    软件包 javax.print.attribute.standard contains classes for specific printing attributes.

    • Uses of Sides in javax.print.attribute.standard

      Fields in javax.print.attribute.standard declared as Sides
      修饰符与类型 字段与描述
      static Sides Sides.DUPLEX
      An alias for "two sided long edge" (see TWO_SIDED_LONG_EDGE).
      static Sides Sides.ONE_SIDED
      Imposes each consecutive print-stream page upon the same side of consecutive media sheets.
      static Sides Sides.TUMBLE
      An alias for "two sided short edge" (see TWO_SIDED_SHORT_EDGE).
      static Sides Sides.TWO_SIDED_LONG_EDGE
      Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the long edge.
      static Sides Sides.TWO_SIDED_SHORT_EDGE
      Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the short edge.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

trepityoSvvvc;ii(-rsddaa<


Uses of Class javax.print.DocFlavor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor

  • Packages that use DocFlavor
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor in javax.print

      Subclasses of DocFlavor in javax.print
      修饰符与类型 类与描述
      static class  DocFlavor.BYTE_ARRAY
      Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
      static class  DocFlavor.CHAR_ARRAY
      Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
      static class  DocFlavor.INPUT_STREAM
      Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
      static class  DocFlavor.READER
      Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
      static class  DocFlavor.SERVICE_FORMATTED
      Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
      static class  DocFlavor.STRING
      Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
      static class  DocFlavor.URL
      Class DocFlavor.URL provides predefined static constant DocFlavor objects.
      Methods in javax.print that return DocFlavor
      修饰符与类型 方法与描述
      DocFlavor SimpleDoc.getDocFlavor()
      Determines the doc flavor in which this doc object will supply its piece of print data.
      DocFlavor Doc.getDocFlavor()
      Determines the doc flavor in which this doc object will supply its piece of print data.
      abstract DocFlavor[] StreamPrintServiceFactory.getSupportedDocFlavors()
      Queries the factory for the document flavors that can be accepted by printers obtained from this factory.
      DocFlavor[] PrintService.getSupportedDocFlavors()
      Determines the print data formats a client can specify when setting up a job for this PrintService.
      DocFlavor[] FlavorException.getUnsupportedFlavors()
      Returns the unsupported flavors.
      Methods in javax.print with parameters of type DocFlavor
      修饰符与类型 方法与描述
      abstract MultiDocPrintService[] PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Not called directly by applications.
      abstract PrintService[] PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.
      Object PrintService.getSupportedAttributeValues(类<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
      Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.
      AttributeSet PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
      Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.
      boolean PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
      Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
      boolean PrintService.isDocFlavorSupported(DocFlavor flavor)
      Determines if this print service supports a specific DocFlavor.
      static MultiDocPrintService[] PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.
      static PrintService[] PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates print services capable of printing the specified DocFlavor.
      static StreamPrintServiceFactory[] StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
      Locates factories for print services that can be used with a print job to output a stream of data in the format specified by outputMimeType.
      static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).
      Constructors in javax.print with parameters of type DocFlavor
      构造方法与描述
      SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
      Constructs a SimpleDoc with the specified print data, doc flavor and doc attribute set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nv"


Uses of Class javax.print.DocFlavor.BYTE_ARRAY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.BYTE_ARRAY

  • Packages that use DocFlavor.BYTE_ARRAY
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.BYTE_ARRAY in javax.print

      Fields in javax.print declared as DocFlavor.BYTE_ARRAY
      修饰符与类型 字段与描述
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
      static DocFlavor.BYTE_ARRAY DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "[B" (byte array).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aMxiR D/jyblaapll�


Uses of Class javax.print.DocFlavor.CHAR_ARRAY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.CHAR_ARRAY

  • Packages that use DocFlavor.CHAR_ARRAY
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.CHAR_ARRAY in javax.print

      Fields in javax.print declared as DocFlavor.CHAR_ARRAY
      修饰符与类型 字段与描述
      static DocFlavor.CHAR_ARRAY DocFlavor.CHAR_ARRAY.TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[C" (character array).
      static DocFlavor.CHAR_ARRAY DocFlavor.CHAR_ARRAY.TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[C" (character array).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l ove> /nrarA


Uses of Class javax.print.DocFlavor.INPUT_STREAM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.INPUT_STREAM

  • Packages that use DocFlavor.INPUT_STREAM
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.INPUT_STREAM in javax.print

      Fields in javax.print declared as DocFlavor.INPUT_STREAM
      修饰符与类型 字段与描述
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
      static DocFlavor.INPUT_STREAM DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tilrcFltn///p.rrc"epsspl/


Uses of Class javax.print.DocFlavor.READER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.READER

  • Packages that use DocFlavor.READER
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.READER in javax.print

      Fields in javax.print declared as DocFlavor.READER
      修饰符与类型 字段与描述
      static DocFlavor.READER DocFlavor.READER.TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).
      static DocFlavor.READER DocFlavor.READER.TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lle.STRPNUUUrDjjcacr "stc


Uses of Class javax.print.DocFlavor.SERVICE_FORMATTED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.SERVICE_FORMATTED

  • Packages that use DocFlavor.SERVICE_FORMATTED
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.SERVICE_FORMATTED in javax.print

      Fields in javax.print declared as DocFlavor.SERVICE_FORMATTED
      修饰符与类型 字段与描述
      static DocFlavor.SERVICE_FORMATTED DocFlavor.SERVICE_FORMATTED.PAGEABLE
      Service formatted print data doc flavor with print data representation class name = "java.awt.print.Pageable" (pageable object).
      static DocFlavor.SERVICE_FORMATTED DocFlavor.SERVICE_FORMATTED.PRINTABLE
      Service formatted print data doc flavor with print data representation class name = "java.awt.print.Printable" (printable object).
      static DocFlavor.SERVICE_FORMATTED DocFlavor.SERVICE_FORMATTED.RENDERABLE_IMAGE
      Service formatted print data doc flavor with print data representation class name = "java.awt.image.renderable.RenderableImage" (renderable image object).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taves /


Uses of Class javax.print.DocFlavor.STRING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.STRING

  • Packages that use DocFlavor.STRING
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.STRING in javax.print

      Fields in javax.print declared as DocFlavor.STRING
      修饰符与类型 字段与描述
      static DocFlavor.STRING DocFlavor.STRING.TEXT_HTML
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.lang.String".
      static DocFlavor.STRING DocFlavor.STRING.TEXT_PLAIN
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.lang.String".
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ldil lslllssl dde=ile==eo


Uses of Class javax.print.DocFlavor.URL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.DocFlavor.URL

  • Packages that use DocFlavor.URL
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of DocFlavor.URL in javax.print

      Fields in javax.print declared as DocFlavor.URL
      修饰符与类型 字段与描述
      static DocFlavor.URL DocFlavor.URL.AUTOSENSE
      Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.GIF
      Doc flavor with MIME type = "image/gif", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.JPEG
      Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.PCL
      Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.PDF
      Doc flavor with MIME type = "application/pdf", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.PNG
      Doc flavor with MIME type = "image/png", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.POSTSCRIPT
      Doc flavor with MIME type = "application/postscript", print data representation class name = "java.net.URL".
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_HOST
      Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_US_ASCII
      Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_UTF_16
      Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_UTF_16BE
      Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_UTF_16LE
      Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_HTML_UTF_8
      Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_HOST
      Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_US_ASCII
      Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_UTF_16
      Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = java.net.URL"" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_UTF_16BE
      Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_UTF_16LE
      Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
      static DocFlavor.URL DocFlavor.URL.TEXT_PLAIN_UTF_8
      Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. osa-soieol.�//D> trt


Uses of Class javax.print.PrintException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.PrintException

  • Packages that use PrintException
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of PrintException in javax.print

      Methods in javax.print that throw PrintException
      修饰符与类型 方法与描述
      void CancelablePrintJob.cancel()
      Stops further processing of a print job.
      void DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes)
      Prints a document with the specified job attributes.
      void MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
      Print a MultiDoc with the specified job attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./..r=.=f.//.g.�./l..ll.


Uses of Class javax.print.PrintServiceLookup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.PrintServiceLookup

  • Packages that use PrintServiceLookup
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of PrintServiceLookup in javax.print

      Methods in javax.print with parameters of type PrintServiceLookup
      修饰符与类型 方法与描述
      static boolean PrintServiceLookup.registerServiceProvider(PrintServiceLookup sp)
      Allows an application to explicitly register a class that implements lookup services.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nmt//ja..///.ahhii=iskla


Uses of Class javax.print.ServiceUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.ServiceUI

No usage of javax.print.ServiceUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p=-h/a>-->>> mnnTTAMa


Uses of Class javax.print.ServiceUIFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.ServiceUIFactory

  • Packages that use ServiceUIFactory
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of ServiceUIFactory in javax.print

      Methods in javax.print that return ServiceUIFactory
      修饰符与类型 方法与描述
      ServiceUIFactory PrintService.getServiceUIFactory()
      Returns a factory for UI components which allow users to interact with the service in various roles.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l旚�-od =.os�/C>�


Uses of Class javax.print.SimpleDoc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.SimpleDoc

No usage of javax.print.SimpleDoc
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a >


Uses of Class javax.print.StreamPrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.StreamPrintService

  • Packages that use StreamPrintService
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of StreamPrintService in javax.print

      Methods in javax.print that return StreamPrintService
      修饰符与类型 方法与描述
      abstract StreamPrintService StreamPrintServiceFactory.getPrintService(OutputStream out)
      Returns a StreamPrintService that can print to the specified output stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tr/r i"s ann feoo ei萯


Uses of Class javax.print.StreamPrintServiceFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.StreamPrintServiceFactory

  • Packages that use StreamPrintServiceFactory
    软件包 描述
    java.awt.print
    Provides classes and interfaces for a general printing API.
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of StreamPrintServiceFactory in java.awt.print

      Methods in java.awt.print that return StreamPrintServiceFactory
      修饰符与类型 方法与描述
      static StreamPrintServiceFactory[] PrinterJob.lookupStreamPrintServices(String mimeType)
      A convenience method which locates factories for stream print services which can image 2D graphics.

    • Uses of StreamPrintServiceFactory in javax.print

      Methods in javax.print that return StreamPrintServiceFactory
      修饰符与类型 方法与描述
      static StreamPrintServiceFactory[] StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
      Locates factories for print services that can be used with a print job to output a stream of data in the format specified by outputMimeType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>


Uses of Interface javax.print.AttributeException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.AttributeException

No usage of javax.print.AttributeException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fte t avi


Uses of Interface javax.print.CancelablePrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.CancelablePrintJob

No usage of javax.print.CancelablePrintJob
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>$佬hav


Uses of Interface javax.print.Doc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.Doc

  • Packages that use Doc
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of Doc in javax.print

      Classes in javax.print that implement Doc
      修饰符与类型 类与描述
      class  SimpleDoc
      This class is an implementation of interface Doc that can be used in many common printing requests.
      Methods in javax.print that return Doc
      修饰符与类型 方法与描述
      Doc MultiDoc.getDoc()
      Obtain the current doc object.
      Methods in javax.print with parameters of type Doc
      修饰符与类型 方法与描述
      void DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes)
      Prints a document with the specified job attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h>n.o


Uses of Interface javax.print.DocPrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.DocPrintJob

  • Packages that use DocPrintJob
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of DocPrintJob in javax.print

      Subinterfaces of DocPrintJob in javax.print
      修饰符与类型 Interface and Description
      interface  CancelablePrintJob
      This interface is used by a printing application to cancel a print job.
      interface  MultiDocPrintJob
      Obtained from a MultiDocPrintService, a MultiDocPrintJob can print a specified collection of documents as a single print job with a set of job attributes.
      Methods in javax.print that return DocPrintJob
      修饰符与类型 方法与描述
      DocPrintJob PrintService.createPrintJob()
      Creates and returns a PrintJob capable of handling data from any of the supported document flavors.

    • Uses of DocPrintJob in javax.print.event

      Methods in javax.print.event that return DocPrintJob
      修饰符与类型 方法与描述
      DocPrintJob PrintJobAttributeEvent.getPrintJob()
      Determine the Print Job to which this print job event pertains.
      DocPrintJob PrintJobEvent.getPrintJob()
      Determines the DocPrintJob to which this print job event pertains.
      Constructors in javax.print.event with parameters of type DocPrintJob
      构造方法与描述
      PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
      Constructs a PrintJobAttributeEvent object.
      PrintJobEvent(DocPrintJob source, int reason)
      Constructs a PrintJobEvent object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" j s nc llliriivf">/geco>y


Uses of Interface javax.print.FlavorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.FlavorException

No usage of javax.print.FlavorException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


Uses of Interface javax.print.MultiDoc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.MultiDoc

  • Packages that use MultiDoc
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of MultiDoc in javax.print

      Methods in javax.print that return MultiDoc
      修饰符与类型 方法与描述
      MultiDoc MultiDoc.下一个()
      Go to the multidoc object that contains the next doc object in the sequence of doc objects.
      Methods in javax.print with parameters of type MultiDoc
      修饰符与类型 方法与描述
      void MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
      Print a MultiDoc with the specified job attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ni/mnaer Sajdltnr atr


Uses of Interface javax.print.MultiDocPrintJob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.MultiDocPrintJob

  • Packages that use MultiDocPrintJob
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of MultiDocPrintJob in javax.print

      Methods in javax.print that return MultiDocPrintJob
      修饰符与类型 方法与描述
      MultiDocPrintJob MultiDocPrintService.createMultiDocPrintJob()
      Create a job which can print a multiDoc.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/vlslsasss/


Uses of Interface javax.print.MultiDocPrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.MultiDocPrintService

  • Packages that use MultiDocPrintService
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of MultiDocPrintService in javax.print

      Methods in javax.print that return MultiDocPrintService
      修饰符与类型 方法与描述
      abstract MultiDocPrintService[] PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Not called directly by applications.
      static MultiDocPrintService[] PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes)
      Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A n."tCO.� camta"=anpo{


Uses of Interface javax.print.PrintService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.PrintService

  • Packages that use PrintService
    软件包 描述
    java.awt.print
    Provides classes and interfaces for a general printing API.
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of PrintService in java.awt.print

      Methods in java.awt.print that return PrintService
      修饰符与类型 方法与描述
      PrintService PrinterJob.getPrintService()
      Returns the service (printer) for this printer job.
      static PrintService[] PrinterJob.lookupPrintServices()
      A convenience method which looks up 2D print services.
      Methods in java.awt.print with parameters of type PrintService
      修饰符与类型 方法与描述
      void PrinterJob.setPrintService(PrintService service)
      Associate this PrinterJob with a new PrintService.

    • Uses of PrintService in javax.print

      Subinterfaces of PrintService in javax.print
      修饰符与类型 Interface and Description
      interface  MultiDocPrintService
      Interface MultiPrintService is the factory for a MultiDocPrintJob.
      Classes in javax.print that implement PrintService
      修饰符与类型 类与描述
      class  StreamPrintService
      This class extends PrintService and represents a print service that prints data in different formats to a client-provided output stream.
      Methods in javax.print that return PrintService
      修饰符与类型 方法与描述
      abstract PrintService PrintServiceLookup.getDefaultPrintService()
      Not called directly by applications.
      PrintService DocPrintJob.getPrintService()
      Determines the PrintService object to which this print job object is bound.
      abstract PrintService[] PrintServiceLookup.getPrintServices()
      Not called directly by applications.
      abstract PrintService[] PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.
      static PrintService PrintServiceLookup.lookupDefaultPrintService()
      Locates the default print service for this environment.
      static PrintService[] PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes)
      Locates print services capable of printing the specified DocFlavor.
      static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).
      Methods in javax.print with parameters of type PrintService
      修饰符与类型 方法与描述
      static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).
      static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
      Presents a dialog to the user for selecting a print service (printer).
      static boolean PrintServiceLookup.registerService(PrintService service)
      Allows an application to directly register an instance of a class which implements a print service.

    • Uses of PrintService in javax.print.event

      Methods in javax.print.event that return PrintService
      修饰符与类型 方法与描述
      PrintService PrintServiceAttributeEvent.getPrintService()
      Returns the print service.
      Constructors in javax.print.event with parameters of type PrintService
      构造方法与描述
      PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
      Constructs a PrintServiceAttributeEvent object.

    • Uses of PrintService in javax.swing

      Methods in javax.swing with parameters of type PrintService
      修饰符与类型 方法与描述
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      Prints this JTable.

    • Uses of PrintService in javax.swing.text

      Methods in javax.swing.text with parameters of type PrintService
      修饰符与类型 方法与描述
      boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
      Prints the content of this JTextComponent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tjtiaxr � .l �//e=n s


Uses of Interface javax.print.URIException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.URIException

No usage of javax.print.URIException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nebtangvaaaan"hhrP>ct


javax.print.event

Interfaces

  • PrintJobAttributeListener
  • PrintJobListener
  • PrintServiceAttributeListener

Classes

  • PrintEvent
  • PrintJobAdapter
  • PrintJobAttributeEvent
  • PrintJobEvent
  • PrintServiceAttributeEvent


javax.print.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.print.event

软件包 javax.print.event contains event classes and listener interfaces.

请参见： 描述

  • 接口摘要
    接口 描述
    PrintJobAttributeListener
    Implementations of this interface are attached to a DocPrintJob to monitor the status of attribute changes associated with the print job.
    PrintJobListener
    Implementations of this listener interface should be attached to a DocPrintJob to monitor the status of the printer job.
    PrintServiceAttributeListener
    Implementations of this listener interface are attached to a PrintService to monitor the status of the print service.
  • Class Summary
    类 描述
    PrintEvent
    Class PrintEvent is the super class of all Print Service API events.
    PrintJobAdapter
    An abstract adapter class for receiving print job events.
    PrintJobAttributeEvent
    Class PrintJobAttributeEvent encapsulates an event a PrintService reports to let the client know that one or more printing attributes for a PrintJob have changed.
    PrintJobEvent
    Class PrintJobEvent encapsulates common events a print job reports to let a listener know of progress in the processing of the DocPrintJob.
    PrintServiceAttributeEvent
    Class PrintServiceAttributeEvent encapsulates an event a Print Service instance reports to let the client know of changes in the print service state.

软件包 javax.print.event Description

软件包 javax.print.event contains event classes and listener interfaces.

They may be used to monitor both print services (such as printers going on-line & off-line), and the progress of a specific print job.

Please note: In the javax.print APIs, a null reference parameter to methods is incorrect unless explicitly documented on the method as having a meaningful interpretation. Usage to the contrary is incorrect coding and may result in a run time exception either immediately or at some later time. IllegalArgumentException and NullPointerException are examples of typical and acceptable run time exceptions for such cases.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oyi-omn -/ao ctteJe


javax.print.event Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.print.event

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
        • javax.print.event.PrintJobEvent
        • javax.print.event.PrintServiceAttributeEvent
    • javax.print.event.PrintJobAdapter (implements javax.print.event.PrintJobListener)

Interface Hierarchy

  • javax.print.event.PrintJobAttributeListener
  • javax.print.event.PrintJobListener
  • javax.print.event.PrintServiceAttributeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tp usI,,, a::enee .


PrintEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.event

类 PrintEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.print.event.PrintEvent
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    PrintJobAttributeEvent, PrintJobEvent, PrintServiceAttributeEvent

    public class PrintEvent
extends EventObject
    Class PrintEvent is the super class of all Print Service API events.
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintEvent(Object source)
      Constructs a PrintEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Returns a String representation of this EventObject.

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrintEvent

        public PrintEvent(Object source)
        Constructs a PrintEvent object.
        参数：
        source - is the source of the event
        抛出：
        IllegalArgumentException - if source is null.

    • 方法详细信息

      • toString

        public String toString()
        Description copied from class: EventObject
        Returns a String representation of this EventObject.
        重载：
        toString in class EventObject
        返回：
        a message describing the event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

."sx"ts >"nco&>rtatiaap te.i


PrintJobAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.event

类 PrintJobAdapter

  • java.lang.Object
    • javax.print.event.PrintJobAdapter
  • 所有已实现的接口：
    PrintJobListener

    public abstract class PrintJobAdapter
extends Object
implements PrintJobListener
    An abstract adapter class for receiving print job events. The methods in this class are empty. This class exists as a convenience for creating listener objects. Extend this class to create a PrintJobEvent listener and override the methods for the events of interest. Unlike the ComponentListener interface, this abstract interface provides null methods so that you only need to define the methods you need, rather than all of the methods.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintJobAdapter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void printDataTransferCompleted(PrintJobEvent pje)
      Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
      void printJobCanceled(PrintJobEvent pje)
      Called to notify the client that the job was canceled by user or program.
      void printJobCompleted(PrintJobEvent pje)
      Called to notify the client that the job completed successfully.
      void printJobFailed(PrintJobEvent pje)
      Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
      void printJobNoMoreEvents(PrintJobEvent pje)
      Called to notify the client that no more events will be delivered.
      void printJobRequiresAttention(PrintJobEvent pje)
      Called to notify the client that some possibly user rectifiable problem occurs (eg printer out of paper).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PrintJobAdapter

        public PrintJobAdapter()

    • 方法详细信息

      • printDataTransferCompleted

        public void printDataTransferCompleted(PrintJobEvent pje)
        Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data. The client should not assume that the data has been completely printed after receiving this event.
        指定者：
        printDataTransferCompleted in interface PrintJobListener
        参数：
        pje - the event being notified

      • printJobCompleted

        public void printJobCompleted(PrintJobEvent pje)
        Called to notify the client that the job completed successfully.
        指定者：
        printJobCompleted in interface PrintJobListener
        参数：
        pje - the event being notified

      • printJobFailed

        public void printJobFailed(PrintJobEvent pje)
        Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
        指定者：
        printJobFailed in interface PrintJobListener
        参数：
        pje - the event being notified

      • printJobCanceled

        public void printJobCanceled(PrintJobEvent pje)
        Called to notify the client that the job was canceled by user or program.
        指定者：
        printJobCanceled in interface PrintJobListener
        参数：
        pje - the event being notified

      • printJobNoMoreEvents

        public void printJobNoMoreEvents(PrintJobEvent pje)
        Called to notify the client that no more events will be delivered. One cause of this event being generated is if the job has successfully completed, but the printing system is limited in capability and cannot verify this. This event is required to be delivered if none of the other terminal events (completed/failed/canceled) are delivered.
        指定者：
        printJobNoMoreEvents in interface PrintJobListener
        参数：
        pje - the event being notified

      • printJobRequiresAttention

        public void printJobRequiresAttention(PrintJobEvent pje)
        Called to notify the client that some possibly user rectifiable problem occurs (eg printer out of paper).
        指定者：
        printJobRequiresAttention in interface PrintJobListener
        参数：
        pje - the event being notified
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tncsJ/m/<&ur"� hlen"loh


PrintJobAttributeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.event

类 PrintJobAttributeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
  • 所有已实现的接口：
    Serializable

    public class PrintJobAttributeEvent
extends PrintEvent
    Class PrintJobAttributeEvent encapsulates an event a PrintService reports to let the client know that one or more printing attributes for a PrintJob have changed.
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
      Constructs a PrintJobAttributeEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      PrintJobAttributeSet getAttributes()
      Determine the printing attributes that changed and their new values.
      DocPrintJob getPrintJob()
      Determine the Print Job to which this print job event pertains.

      • 方法 - 继承于类 javax.print.event.PrintEvent

        toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrintJobAttributeEvent

        public PrintJobAttributeEvent(DocPrintJob source,
                      PrintJobAttributeSet attributes)
        Constructs a PrintJobAttributeEvent object.
        参数：
        source - the print job generating this event
        attributes - the attribute changes being reported
        抛出：
        IllegalArgumentException - if source is null.

    • 方法详细信息

      • getPrintJob

        public DocPrintJob getPrintJob()
        Determine the Print Job to which this print job event pertains.
        返回：
        Print Job object.

      • getAttributes

        public PrintJobAttributeSet getAttributes()
        Determine the printing attributes that changed and their new values.
        返回：
        Attributes containing the new values for the print job attributes that changed. The returned set may not be modifiable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eidnn t see ssf iicie=


PrintJobAttributeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.event

Interface PrintJobAttributeListener

  • public interface PrintJobAttributeListener
    Implementations of this interface are attached to a DocPrintJob to monitor the status of attribute changes associated with the print job.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void attributeUpdate(PrintJobAttributeEvent pjae)
      Notifies the listener of a change in some print job attributes.

    • 方法详细信息

      • attributeUpdate

        void attributeUpdate(PrintJobAttributeEvent pjae)
        Notifies the listener of a change in some print job attributes. One example of an occurrence triggering this event is if the JobState attribute changed from PROCESSING to PROCESSING_STOPPED.
        参数：
        pjae - the event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>met/ct/gOO/gga.aaj.f/.e alldo


PrintJobEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.event

类 PrintJobEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobEvent
  • 所有已实现的接口：
    Serializable

    public class PrintJobEvent
extends PrintEvent
    Class PrintJobEvent encapsulates common events a print job reports to let a listener know of progress in the processing of the DocPrintJob.
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DATA_TRANSFER_COMPLETE
      The job is not necessarily printed yet, but the data has been transferred successfully from the client to the print service.
      static int JOB_CANCELED
      The job was canceled by the PrintService.
      static int JOB_COMPLETE
      The document cis completely printed.
      static int JOB_FAILED
      The print service reports that the job cannot be completed.
      static int NO_MORE_EVENTS
      Not all print services may be capable of delivering interesting events, or even telling when a job is complete.
      static int REQUIRES_ATTENTION
      The print service indicates that a - possibly transient - problem may require external intervention before the print service can continue.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintJobEvent(DocPrintJob source, int reason)
      Constructs a PrintJobEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getPrintEventType()
      Gets the reason for this event.
      DocPrintJob getPrintJob()
      Determines the DocPrintJob to which this print job event pertains.

      • 方法 - 继承于类 javax.print.event.PrintEvent

        toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • JOB_CANCELED

        public static final int JOB_CANCELED
        The job was canceled by the PrintService.
        另请参见：
        Constant Field Values

      • JOB_COMPLETE

        public static final int JOB_COMPLETE
        The document cis completely printed.
        另请参见：
        Constant Field Values

      • JOB_FAILED

        public static final int JOB_FAILED
        The print service reports that the job cannot be completed. The application must resubmit the job.
        另请参见：
        Constant Field Values

      • REQUIRES_ATTENTION

        public static final int REQUIRES_ATTENTION
        The print service indicates that a - possibly transient - problem may require external intervention before the print service can continue. One example of an event that can generate this message is when the printer runs out of paper.
        另请参见：
        Constant Field Values

      • NO_MORE_EVENTS

        public static final int NO_MORE_EVENTS
        Not all print services may be capable of delivering interesting events, or even telling when a job is complete. This message indicates the print job has no further information or communication with the print service. This message should always be delivered if a terminal event (completed/failed/canceled) is not delivered. For example, if messages such as JOB_COMPLETE have NOT been received before receiving this message, the only inference that should be drawn is that the print service does not support delivering such an event.
        另请参见：
        Constant Field Values

      • DATA_TRANSFER_COMPLETE

        public static final int DATA_TRANSFER_COMPLETE
        The job is not necessarily printed yet, but the data has been transferred successfully from the client to the print service. The client may free data resources.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PrintJobEvent

        public PrintJobEvent(DocPrintJob source,
             int reason)
        Constructs a PrintJobEvent object.
        参数：
        source - a DocPrintJob object
        reason - an int specifying the reason.
        抛出：
        IllegalArgumentException - if source is null.

    • 方法详细信息

      • getPrintEventType

        public int getPrintEventType()
        Gets the reason for this event.
        返回：
        reason int.

      • getPrintJob

        public DocPrintJob getPrintJob()
        Determines the DocPrintJob to which this print job event pertains.
        返回：
        the DocPrintJob object that represents the print job that reports the events encapsulated by this PrintJobEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jl=rnngall/�=la.�-iye vPve.v=>"u�


PrintJobListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.event

Interface PrintJobListener

  • All Known Implementing Classes:
    PrintJobAdapter

    public interface PrintJobListener
    Implementations of this listener interface should be attached to a DocPrintJob to monitor the status of the printer job. These callback methods may be invoked on the thread processing the print job, or a service created notification thread. In either case the client should not perform lengthy processing in these callbacks.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void printDataTransferCompleted(PrintJobEvent pje)
      Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
      void printJobCanceled(PrintJobEvent pje)
      Called to notify the client that the job was canceled by a user or a program.
      void printJobCompleted(PrintJobEvent pje)
      Called to notify the client that the job completed successfully.
      void printJobFailed(PrintJobEvent pje)
      Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
      void printJobNoMoreEvents(PrintJobEvent pje)
      Called to notify the client that no more events will be delivered.
      void printJobRequiresAttention(PrintJobEvent pje)
      Called to notify the client that an error has occurred that the user might be able to fix.

    • 方法详细信息

      • printDataTransferCompleted

        void printDataTransferCompleted(PrintJobEvent pje)
        Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data. The client should not assume that the data has been completely printed after receiving this event. If this event is not received the client should wait for a terminal event (completed/canceled/failed) before freeing the resources.
        参数：
        pje - the job generating this event

      • printJobCompleted

        void printJobCompleted(PrintJobEvent pje)
        Called to notify the client that the job completed successfully.
        参数：
        pje - the job generating this event

      • printJobFailed

        void printJobFailed(PrintJobEvent pje)
        Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
        参数：
        pje - the job generating this event

      • printJobCanceled

        void printJobCanceled(PrintJobEvent pje)
        Called to notify the client that the job was canceled by a user or a program.
        参数：
        pje - the job generating this event

      • printJobNoMoreEvents

        void printJobNoMoreEvents(PrintJobEvent pje)
        Called to notify the client that no more events will be delivered. One cause of this event being generated is if the job has successfully completed, but the printing system is limited in capability and cannot verify this. This event is required to be delivered if none of the other terminal events (completed/failed/canceled) are delivered.
        参数：
        pje - the job generating this event

      • printJobRequiresAttention

        void printJobRequiresAttention(PrintJobEvent pje)
        Called to notify the client that an error has occurred that the user might be able to fix. One example of an error that can generate this event is when the printer runs out of paper.
        参数：
        pje - the job generating this event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s< !T/sslE


PrintServiceAttributeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.print.event

类 PrintServiceAttributeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.print.event.PrintEvent
        • javax.print.event.PrintServiceAttributeEvent
  • 所有已实现的接口：
    Serializable

    public class PrintServiceAttributeEvent
extends PrintEvent
    Class PrintServiceAttributeEvent encapsulates an event a Print Service instance reports to let the client know of changes in the print service state.
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
      Constructs a PrintServiceAttributeEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      PrintServiceAttributeSet getAttributes()
      Determine the printing service attributes that changed and their new values.
      PrintService getPrintService()
      Returns the print service.

      • 方法 - 继承于类 javax.print.event.PrintEvent

        toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrintServiceAttributeEvent

        public PrintServiceAttributeEvent(PrintService source,
                          PrintServiceAttributeSet attributes)
        Constructs a PrintServiceAttributeEvent object.
        参数：
        source - the print job generating this event
        attributes - the attribute changes being reported
        抛出：
        IllegalArgumentException - if source is null.

    • 方法详细信息

      • getPrintService

        public PrintService getPrintService()
        Returns the print service.
        返回：
        Print Service object.

      • getAttributes

        public PrintServiceAttributeSet getAttributes()
        Determine the printing service attributes that changed and their new values.
        返回：
        Attributes containing the new values for the service attributes that changed. The returned set may be unmodifiable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r eOSETFET_RRT__ nttsaLi <AiLLl=moe


PrintServiceAttributeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.print.event

Interface PrintServiceAttributeListener

  • public interface PrintServiceAttributeListener
    Implementations of this listener interface are attached to a PrintService to monitor the status of the print service.

    To monitor a particular job see PrintJobListener and PrintJobAttributeListener.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void attributeUpdate(PrintServiceAttributeEvent psae)
      Called to notify a listener of an event in the print service.

    • 方法详细信息

      • attributeUpdate

        void attributeUpdate(PrintServiceAttributeEvent psae)
        Called to notify a listener of an event in the print service. The service will call this method on an event notification thread. The client should not perform lengthy processing in this callback or subsequent event notifications may be blocked.
        参数：
        psae - the event being notified
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>g../e./erfferr>3bba.&va.el//gv


Uses of Package javax.print.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.print.event

  • Packages that use javax.print.event
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.
  • Classes in javax.print.event used by javax.print
    类与描述
    PrintJobAttributeListener
    Implementations of this interface are attached to a DocPrintJob to monitor the status of attribute changes associated with the print job.
    PrintJobListener
    Implementations of this listener interface should be attached to a DocPrintJob to monitor the status of the printer job.
    PrintServiceAttributeListener
    Implementations of this listener interface are attached to a PrintService to monitor the status of the print service.
  • Classes in javax.print.event used by javax.print.event
    类与描述
    PrintEvent
    Class PrintEvent is the super class of all Print Service API events.
    PrintJobAttributeEvent
    Class PrintJobAttributeEvent encapsulates an event a PrintService reports to let the client know that one or more printing attributes for a PrintJob have changed.
    PrintJobEvent
    Class PrintJobEvent encapsulates common events a print job reports to let a listener know of progress in the processing of the DocPrintJob.
    PrintJobListener
    Implementations of this listener interface should be attached to a DocPrintJob to monitor the status of the printer job.
    PrintServiceAttributeEvent
    Class PrintServiceAttributeEvent encapsulates an event a Print Service instance reports to let the client know of changes in the print service state.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>,e md �


Uses of Class javax.print.event.PrintEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.event.PrintEvent

  • Packages that use PrintEvent
    软件包 描述
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintEvent in javax.print.event

      Subclasses of PrintEvent in javax.print.event
      修饰符与类型 类与描述
      class  PrintJobAttributeEvent
      Class PrintJobAttributeEvent encapsulates an event a PrintService reports to let the client know that one or more printing attributes for a PrintJob have changed.
      class  PrintJobEvent
      Class PrintJobEvent encapsulates common events a print job reports to let a listener know of progress in the processing of the DocPrintJob.
      class  PrintServiceAttributeEvent
      Class PrintServiceAttributeEvent encapsulates an event a Print Service instance reports to let the client know of changes in the print service state.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

><


Uses of Class javax.print.event.PrintJobAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.event.PrintJobAdapter

No usage of javax.print.event.PrintJobAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l"e.intoDcccna..etpo.


Uses of Class javax.print.event.PrintJobAttributeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.event.PrintJobAttributeEvent

  • Packages that use PrintJobAttributeEvent
    软件包 描述
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintJobAttributeEvent in javax.print.event

      Methods in javax.print.event with parameters of type PrintJobAttributeEvent
      修饰符与类型 方法与描述
      void PrintJobAttributeListener.attributeUpdate(PrintJobAttributeEvent pjae)
      Notifies the listener of a change in some print job attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l" l siRi. C虳(>/T-c


Uses of Class javax.print.event.PrintJobEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.event.PrintJobEvent

  • Packages that use PrintJobEvent
    软件包 描述
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintJobEvent in javax.print.event

      Methods in javax.print.event with parameters of type PrintJobEvent
      修饰符与类型 方法与描述
      void PrintJobAdapter.printDataTransferCompleted(PrintJobEvent pje)
      Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
      void PrintJobListener.printDataTransferCompleted(PrintJobEvent pje)
      Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
      void PrintJobAdapter.printJobCanceled(PrintJobEvent pje)
      Called to notify the client that the job was canceled by user or program.
      void PrintJobListener.printJobCanceled(PrintJobEvent pje)
      Called to notify the client that the job was canceled by a user or a program.
      void PrintJobAdapter.printJobCompleted(PrintJobEvent pje)
      Called to notify the client that the job completed successfully.
      void PrintJobListener.printJobCompleted(PrintJobEvent pje)
      Called to notify the client that the job completed successfully.
      void PrintJobAdapter.printJobFailed(PrintJobEvent pje)
      Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
      void PrintJobListener.printJobFailed(PrintJobEvent pje)
      Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
      void PrintJobAdapter.printJobNoMoreEvents(PrintJobEvent pje)
      Called to notify the client that no more events will be delivered.
      void PrintJobListener.printJobNoMoreEvents(PrintJobEvent pje)
      Called to notify the client that no more events will be delivered.
      void PrintJobAdapter.printJobRequiresAttention(PrintJobEvent pje)
      Called to notify the client that some possibly user rectifiable problem occurs (eg printer out of paper).
      void PrintJobListener.printJobRequiresAttention(PrintJobEvent pje)
      Called to notify the client that an error has occurred that the user might be able to fix.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.D>lesfe =ycLra "蝜iii


Uses of Class javax.print.event.PrintServiceAttributeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.print.event.PrintServiceAttributeEvent

  • Packages that use PrintServiceAttributeEvent
    软件包 描述
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintServiceAttributeEvent in javax.print.event

      Methods in javax.print.event with parameters of type PrintServiceAttributeEvent
      修饰符与类型 方法与描述
      void PrintServiceAttributeListener.attributeUpdate(PrintServiceAttributeEvent psae)
      Called to notify a listener of an event in the print service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.mlad-ercccd.aae/erRe >


Uses of Interface javax.print.event.PrintJobAttributeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.event.PrintJobAttributeListener

  • Packages that use PrintJobAttributeListener
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of PrintJobAttributeListener in javax.print

      Methods in javax.print with parameters of type PrintJobAttributeListener
      修饰符与类型 方法与描述
      void DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes)
      Registers a listener for changes in the specified attributes.
      void DocPrintJob.removePrintJobAttributeListener(PrintJobAttributeListener listener)
      Removes an attribute listener from this print job.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eepcitObwh mfsbbhir


Uses of Interface javax.print.event.PrintJobListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.event.PrintJobListener

  • Packages that use PrintJobListener
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.
    javax.print.event
    软件包 javax.print.event contains event classes and listener interfaces.

    • Uses of PrintJobListener in javax.print

      Methods in javax.print with parameters of type PrintJobListener
      修饰符与类型 方法与描述
      void DocPrintJob.addPrintJobListener(PrintJobListener listener)
      Registers a listener for event occurring during this print job.
      void DocPrintJob.removePrintJobListener(PrintJobListener listener)
      Removes a listener from this print job.

    • Uses of PrintJobListener in javax.print.event

      Classes in javax.print.event that implement PrintJobListener
      修饰符与类型 类与描述
      class  PrintJobAdapter
      An abstract adapter class for receiving print job events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rdetliehteeef llijlicnl .lt


Uses of Interface javax.print.event.PrintServiceAttributeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.print.event.PrintServiceAttributeListener

  • Packages that use PrintServiceAttributeListener
    软件包 描述
    javax.print
    Provides the principal classes and interfaces for the JavaTM Print Service API.

    • Uses of PrintServiceAttributeListener in javax.print

      Methods in javax.print with parameters of type PrintServiceAttributeListener
      修饰符与类型 方法与描述
      void PrintService.addPrintServiceAttributeListener(PrintServiceAttributeListener listener)
      Registers a listener for events on this PrintService.
      void PrintService.removePrintServiceAttributeListener(PrintServiceAttributeListener listener)
      Removes the print-service listener from this print service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lia/tl/../crn>l


javax.rmi

Classes

  • PortableRemoteObject
l


javax.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.rmi

Contains user APIs for RMI-IIOP.

请参见： 描述

  • Class Summary
    类 描述
    PortableRemoteObject
    Server implementation objects may either inherit from javax.rmi.PortableRemoteObject or they may implement a remote interface and then use the exportObject method to register themselves as a server object.

软件包 javax.rmi Description

Contains user APIs for RMI-IIOP. These APIs are provided for use by RMI-IIOP applications, and provide equivalent semantics when running over either IIOP or JRMP. See also the javax.rmi.CORBA package.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n&/isrmt"e y/n>�


javax.rmi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.rmi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.rmi.PortableRemoteObject
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_<>s/


PortableRemoteObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.rmi

类 PortableRemoteObject

  • java.lang.Object
    • javax.rmi.PortableRemoteObject

  • public class PortableRemoteObject
extends Object
    Server implementation objects may either inherit from javax.rmi.PortableRemoteObject or they may implement a remote interface and then use the exportObject method to register themselves as a server object. The toStub method takes a server implementation and returns a stub that can be used to access that server object. The connect method makes a Remote object ready for remote communication. The unexportObject method is used to deregister a server object, allowing it to become available for garbage collection. The narrow method takes an object reference or abstract interface type and attempts to narrow it to conform to the given interface. If the operation is successful the result will be an object of the specified type, otherwise an exception will be thrown.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected PortableRemoteObject()
      Initializes the object by calling exportObject(this).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static void connect(Remote target, Remote source)
      Makes a Remote object ready for remote communication.
      static void exportObject(Remote obj)
      Makes a server object ready to receive remote calls.
      static Object narrow(Object narrowFrom, 类 narrowTo)
      Checks to ensure that an object of a remote or abstract interface type can be cast to a desired type.
      static Remote toStub(Remote obj)
      Returns a stub for the given server object.
      static void unexportObject(Remote obj)
      Deregisters a server object from the runtime, allowing the object to become available for garbage collection.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PortableRemoteObject

        protected PortableRemoteObject()
                        throws RemoteException
        Initializes the object by calling exportObject(this).
        抛出：
        RemoteException - if export fails.

    • 方法详细信息

      • exportObject

        public static void exportObject(Remote obj)
                         throws RemoteException
        Makes a server object ready to receive remote calls. Note that subclasses of PortableRemoteObject do not need to call this method, as it is called by the constructor.
        参数：
        obj - the server object to export.
        抛出：
        RemoteException - if export fails.

      • toStub

        public static Remote toStub(Remote obj)
                     throws NoSuchObjectException
        Returns a stub for the given server object.
        参数：
        obj - the server object for which a stub is required. Must either be a subclass of PortableRemoteObject or have been previously the target of a call to exportObject(java.rmi.Remote).
        返回：
        the most derived stub for the object.
        抛出：
        NoSuchObjectException - if a stub cannot be located for the given server object.

      • unexportObject

        public static void unexportObject(Remote obj)
                           throws NoSuchObjectException
        Deregisters a server object from the runtime, allowing the object to become available for garbage collection.
        参数：
        obj - the object to unexport.
        抛出：
        NoSuchObjectException - if the remote object is not currently exported.

      • narrow

        public static Object narrow(Object narrowFrom,
            类 narrowTo)
                     throws ClassCastException
        Checks to ensure that an object of a remote or abstract interface type can be cast to a desired type.
        参数：
        narrowFrom - the object to check.
        narrowTo - the desired type.
        返回：
        an object which can be cast to the desired type.
        抛出：
        ClassCastException - if narrowFrom cannot be cast to narrowTo.

      • connect

        public static void connect(Remote target,
           Remote source)
                    throws RemoteException
        Makes a Remote object ready for remote communication. This normally happens implicitly when the object is sent or received as an argument on a remote method call, but in some circumstances it is useful to perform this action by making an explicit call. See the Stub.connect(org.omg.CORBA.ORB) method for more information.
        参数：
        target - the object to connect.
        source - a previously connected object.
        抛出：
        RemoteException - if source is not connected or if target is already connected to a different ORB than source.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C{io=JtDn/si8l/>o胐dtluae


Uses of Package javax.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.rmi

No usage of javax.rmi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oena"ymyp>sl>g<<


Uses of Class javax.rmi.PortableRemoteObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.PortableRemoteObject

No usage of javax.rmi.PortableRemoteObject
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t�/>lis/


ClassDesc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.rmi.CORBA

类 ClassDesc

  • java.lang.Object
    • javax.rmi.CORBA.ClassDesc
  • 所有已实现的接口：
    Serializable

    public class ClassDesc
extends Object
implements Serializable
    This class is used to marshal java.lang.Class objects over IIOP.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ClassDesc()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ClassDesc

        public ClassDesc()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>rsscya


javax.rmi.CORBA

Interfaces

  • PortableRemoteObjectDelegate
  • StubDelegate
  • Tie
  • UtilDelegate
  • ValueHandler
  • ValueHandlerMultiFormat

Classes

  • ClassDesc
  • Stub
  • Util
r


javax.rmi.CORBA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.rmi.CORBA

Contains portability APIs for RMI-IIOP.

请参见： 描述

  • 接口摘要
    接口 描述
    PortableRemoteObjectDelegate
    Supports delegation for method implementations in PortableRemoteObject.
    StubDelegate
    Supports delegation for method implementations in Stub.
    Tie
    Defines methods which all RMI-IIOP server side ties must implement.
    UtilDelegate
    Supports delegation for method implementations in Util.
    ValueHandler
    Defines methods which allow serialization of Java objects to and from GIOP streams.
    ValueHandlerMultiFormat
    Java to IDL ptc 02-01-12 1.5.1.5
  • Class Summary
    类 描述
    ClassDesc
    This class is used to marshal java.lang.Class objects over IIOP.
    Stub
    Base class from which all RMI-IIOP stubs must inherit.
    Util
    Provides utility methods that can be used by stubs and ties to perform common operations.

软件包 javax.rmi.CORBA Description

Contains portability APIs for RMI-IIOP. These APIs provide a standard interface between the generated stubs and ties and the RMI-IIOP runtime. They also allow third party ORBs to be used for RMI over IIOP as an alternative to the ORB supplied by Sun. They are not intended to be called directly from RMI-IIOP applications. See also the javax.rmi package.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/n///s/<<<>>//s>y


javax.rmi.CORBA Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.rmi.CORBA

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.rmi.CORBA.ClassDesc (implements java.io.Serializable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
    • javax.rmi.CORBA.Util

Interface Hierarchy

  • org.omg.CORBA.portable.InvokeHandler
    • javax.rmi.CORBA.Tie
  • javax.rmi.CORBA.PortableRemoteObjectDelegate
  • javax.rmi.CORBA.StubDelegate
  • javax.rmi.CORBA.UtilDelegate
  • javax.rmi.CORBA.ValueHandler
    • javax.rmi.CORBA.ValueHandlerMultiFormat
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.l>s>&s


PortableRemoteObjectDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface PortableRemoteObjectDelegate

  • public interface PortableRemoteObjectDelegate
    Supports delegation for method implementations in PortableRemoteObject. The delegate is a singleton instance of a class that implements this interface and provides a replacement implementation for all the methods of javax.rmi.PortableRemoteObject. Delegates are enabled by providing the delegate's class name as the value of the javax.rmi.CORBA.PortableRemoteObjectClass system property.
    另请参见：
    PortableRemoteObject

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void connect(Remote target, Remote source)
      Delegation call for PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote).
      void exportObject(Remote obj)
      Delegation call for PortableRemoteObject.exportObject(java.rmi.Remote).
      Object narrow(Object narrowFrom, 类 narrowTo)
      Delegation call for PortableRemoteObject.narrow(java.lang.Object, java.lang.Class).
      Remote toStub(Remote obj)
      Delegation call for PortableRemoteObject.toStub(java.rmi.Remote).
      void unexportObject(Remote obj)
      Delegation call for PortableRemoteObject.unexportObject(java.rmi.Remote).

    • 方法详细信息

      • exportObject

        void exportObject(Remote obj)
                  throws RemoteException
        Delegation call for PortableRemoteObject.exportObject(java.rmi.Remote).
        抛出：
        RemoteException

      • toStub

        Remote toStub(Remote obj)
              throws NoSuchObjectException
        Delegation call for PortableRemoteObject.toStub(java.rmi.Remote).
        抛出：
        NoSuchObjectException

      • unexportObject

        void unexportObject(Remote obj)
                    throws NoSuchObjectException
        Delegation call for PortableRemoteObject.unexportObject(java.rmi.Remote).
        抛出：
        NoSuchObjectException

      • narrow

        Object narrow(Object narrowFrom,
            类 narrowTo)
              throws ClassCastException
        Delegation call for PortableRemoteObject.narrow(java.lang.Object, java.lang.Class).
        抛出：
        ClassCastException

      • connect

        void connect(Remote target,
           Remote source)
             throws RemoteException
        Delegation call for PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote).
        抛出：
        RemoteException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ncP/tea"aConl"el>ag


Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.rmi.CORBA

类 Stub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub
  • 所有已实现的接口：
    Serializable, Object
    直接已知子类：
    _Remote_Stub

    public abstract class Stub
extends ObjectImpl
implements Serializable
    Base class from which all RMI-IIOP stubs must inherit.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Stub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void connect(ORB orb)
      Connects this stub to an ORB.
      boolean equals(Object obj)
      Compares two stubs for equality.
      int hashCode()
      Returns a hash code value for the object which is the same for all stubs that represent the same remote object.
      String toString()
      Returns a string representation of this stub.

      • 方法 - 继承于类 org.omg.CORBA_2_3.portable.ObjectImpl

        _get_codebase

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Stub

        public Stub()

    • 方法详细信息

      • hashCode

        public int hashCode()
        Returns a hash code value for the object which is the same for all stubs that represent the same remote object.
        重载：
        hashCode in class ObjectImpl
        返回：
        the hash code value.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares two stubs for equality. Returns true when used to compare stubs that represent the same remote object, and false otherwise.
        重载：
        equals in class ObjectImpl
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Returns a string representation of this stub. Returns the same string for all stubs that represent the same remote object.
        重载：
        toString in class ObjectImpl
        返回：
        a string representation of this stub.

      • connect

        public void connect(ORB orb)
             throws RemoteException
        Connects this stub to an ORB. Required after the stub is deserialized but not after it is demarshalled by an ORB stream. If an unconnected stub is passed to an ORB stream for marshalling, it is implicitly connected to that ORB. Application code should not call this method directly, but should call the portable wrapper method PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote).
        参数：
        orb - the ORB to connect to.
        抛出：
        RemoteException - if the stub is already connected to a different ORB, or if the stub does not represent an exported remote or local object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsn>o\as>Flducdecva筶 e""s",e.h


StubDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface StubDelegate

  • public interface StubDelegate
    Supports delegation for method implementations in Stub. A delegate is an instance of a class that implements this interface and provides a replacement implementation for all the methods of javax.rmi.CORBA.Stub. If delegation is enabled, each stub has an associated delegate. Delegates are enabled by providing the delegate's class name as the value of the javax.rmi.CORBA.StubClass system property.
    另请参见：
    Stub

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void connect(Stub self, ORB orb)
      Delegation call for Stub.connect(org.omg.CORBA.ORB).
      boolean equals(Stub self, Object obj)
      Delegation call for Stub.equals(java.lang.Object).
      int hashCode(Stub self)
      Delegation call for Stub.hashCode().
      void readObject(Stub self, ObjectInputStream s)
      Delegation call for Stub.readObject(java.io.ObjectInputStream).
      String toString(Stub self)
      Delegation call for Stub.toString().
      void writeObject(Stub self, ObjectOutputStream s)
      Delegation call for Stub.writeObject(java.io.ObjectOutputStream).

    • 方法详细信息

      • hashCode

        int hashCode(Stub self)
        Delegation call for Stub.hashCode().

      • equals

        boolean equals(Stub self,
             Object obj)
        Delegation call for Stub.equals(java.lang.Object).

      • toString

        String toString(Stub self)
        Delegation call for Stub.toString().

      • connect

        void connect(Stub self,
           ORB orb)
             throws RemoteException
        Delegation call for Stub.connect(org.omg.CORBA.ORB).
        抛出：
        RemoteException

      • readObject

        void readObject(Stub self,
              ObjectInputStream s)
                throws IOException,
                       ClassNotFoundException
        Delegation call for Stub.readObject(java.io.ObjectInputStream).
        抛出：
        IOException
        ClassNotFoundException

      • writeObject

        void writeObject(Stub self,
               ObjectOutputStream s)
                 throws IOException
        Delegation call for Stub.writeObject(java.io.ObjectOutputStream).
        抛出：
        IOException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oaicsotsoCnnoCCol///a.j/Eoi. ies


Tie

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface Tie

  • All Superinterfaces:
    InvokeHandler

    public interface Tie
extends InvokeHandler
    Defines methods which all RMI-IIOP server side ties must implement.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void deactivate()
      Deactivates the target object represented by this tie.
      Remote getTarget()
      Returns the target for this tie.
      ORB orb()
      Returns the ORB for this tie.
      void orb(ORB orb)
      Sets the ORB for this tie.
      void setTarget(Remote target)
      Called by Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) to set the target for this tie.
      Object thisObject()
      Returns an object reference for the target object represented by this tie.

      • 方法 - 继承于接口 org.omg.CORBA.portable.InvokeHandler

        _invoke

    • 方法详细信息

      • thisObject

        Object thisObject()
        Returns an object reference for the target object represented by this tie.
        返回：
        an object reference for the target object.

      • deactivate

        void deactivate()
                throws NoSuchObjectException
        Deactivates the target object represented by this tie.
        抛出：
        NoSuchObjectException

      • orb

        ORB orb()
        Returns the ORB for this tie.
        返回：
        the ORB.

      • orb

        void orb(ORB orb)
        Sets the ORB for this tie.
        参数：
        orb - the ORB.

      • setTarget

        void setTarget(Remote target)
        Called by Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) to set the target for this tie.
        参数：
        target - the object to use as the target for this tie.

      • getTarget

        Remote getTarget()
        Returns the target for this tie.
        返回：
        the target.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pn ttortora__raa-f>>VBBVAVA=AA OO=l


Uses of Package javax.rmi.CORBA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.rmi.CORBA

  • Packages that use javax.rmi.CORBA
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in javax.rmi.CORBA used by javax.rmi.CORBA
    类与描述
    Stub
    Base class from which all RMI-IIOP stubs must inherit.
    Tie
    Defines methods which all RMI-IIOP server side ties must implement.
    ValueHandler
    Defines methods which allow serialization of Java objects to and from GIOP streams.
  • Classes in javax.rmi.CORBA used by org.omg.stub.java.rmi
    类与描述
    Stub
    Base class from which all RMI-IIOP stubs must inherit.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shblp>�/


Util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

类 Util

  • java.lang.Object
    • javax.rmi.CORBA.Util

  • public class Util
extends Object
    Provides utility methods that can be used by stubs and ties to perform common operations.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Object copyObject(Object obj, ORB orb)
      Copies or connects an object.
      static Object[] copyObjects(Object[] obj, ORB orb)
      Copies or connects an array of objects.
      static ValueHandler createValueHandler()
      Returns a singleton instance of a class that implements the ValueHandler interface.
      static String getCodebase(类 clz)
      Returns the codebase, if any, for the given class.
      static Tie getTie(Remote target)
      Returns the tie (if any) for a given target object.
      static boolean isLocal(Stub stub)
      The isLocal method has the same semantics as the ObjectImpl._is_local method, except that it can throw a RemoteException.
      static 类 loadClass(String className, String remoteCodebase, ClassLoader loader)
      Returns a class instance for the specified class.
      static RemoteException mapSystemException(SystemException ex)
      Maps a SystemException to a RemoteException.
      static Object readAny(InputStream in)
      Reads a java.lang.Object as a CORBA any.
      static void registerTarget(Tie tie, Remote target)
      Registers a target for a tie.
      static void unexportObject(Remote target)
      Removes the associated tie from an internal table and calls Tie.deactivate() to deactivate the object.
      static RemoteException wrapException(Throwable orig)
      Wraps an exception thrown by an implementation method.
      static void writeAbstractObject(OutputStream out, Object obj)
      Writes a java.lang.Object as either a value or a CORBA Object.
      static void writeAny(OutputStream out, Object obj)
      Writes any java.lang.Object as a CORBA any.
      static void writeRemoteObject(OutputStream out, Object obj)
      Writes a java.lang.Object as a CORBA Object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • mapSystemException

        public static RemoteException mapSystemException(SystemException ex)
        Maps a SystemException to a RemoteException.
        参数：
        ex - the SystemException to map.
        返回：
        the mapped exception.

      • writeAny

        public static void writeAny(OutputStream out,
            Object obj)
        Writes any java.lang.Object as a CORBA any.
        参数：
        out - the stream in which to write the any.
        obj - the object to write as an any.

      • readAny

        public static Object readAny(InputStream in)
        Reads a java.lang.Object as a CORBA any.
        参数：
        in - the stream from which to read the any.
        返回：
        the object read from the stream.

      • writeRemoteObject

        public static void writeRemoteObject(OutputStream out,
                     Object obj)
        Writes a java.lang.Object as a CORBA Object. If obj is an exported RMI-IIOP server object, the tie is found and wired to obj, then written to out.write_Object(org.omg.CORBA.Object). If obj is a CORBA Object, it is written to out.write_Object(org.omg.CORBA.Object).
        参数：
        out - the stream in which to write the object.
        obj - the object to write.

      • writeAbstractObject

        public static void writeAbstractObject(OutputStream out,
                       Object obj)
        Writes a java.lang.Object as either a value or a CORBA Object. If obj is a value object or a stub object, it is written to out.write_abstract_interface(java.lang.Object). If obj is an exported RMI-IIOP server object, the tie is found and wired to obj, then written to out.write_abstract_interface(java.lang.Object).
        参数：
        out - the stream in which to write the object.
        obj - the object to write.

      • registerTarget

        public static void registerTarget(Tie tie,
                  Remote target)
        Registers a target for a tie. Adds the tie to an internal table and calls Tie.setTarget(java.rmi.Remote) on the tie object.
        参数：
        tie - the tie to register.
        target - the target for the tie.

      • unexportObject

        public static void unexportObject(Remote target)
                           throws NoSuchObjectException
        Removes the associated tie from an internal table and calls Tie.deactivate() to deactivate the object.
        参数：
        target - the object to unexport.
        抛出：
        NoSuchObjectException

      • getTie

        public static Tie getTie(Remote target)
        Returns the tie (if any) for a given target object.
        返回：
        the tie or null if no tie is registered for the given target.

      • createValueHandler

        public static ValueHandler createValueHandler()
        Returns a singleton instance of a class that implements the ValueHandler interface.
        返回：
        a class which implements the ValueHandler interface.

      • getCodebase

        public static String getCodebase(类 clz)
        Returns the codebase, if any, for the given class.
        参数：
        clz - the class to get a codebase for.
        返回：
        a space-separated list of URLs, or null.

      • loadClass

        public static 类 loadClass(String className,
              String remoteCodebase,
              ClassLoader loader)
                       throws ClassNotFoundException
        Returns a class instance for the specified class.

        The spec for this method is the "Java to IDL language mapping", ptc/00-01-06.

        In Java SE Platform, this method works as follows:

        • Find the first non-null ClassLoader on the call stack and attempt to load the class using this ClassLoader.
        • If the first step fails, and if remoteCodebase is non-null and useCodebaseOnly is false, then call java.rmi.server.RMIClassLoader.loadClass(remoteCodebase, className).
        • If remoteCodebase is null or useCodebaseOnly is true, then call java.rmi.server.RMIClassLoader.loadClass(className).
        • If a class was not successfully loaded by step 1, 2, or 3, and loader is non-null, then call loader.loadClass(className).
        • If a class was successfully loaded by step 1, 2, 3, or 4, then return the loaded class, else throw ClassNotFoundException.
        参数：
        className - the name of the class.
        remoteCodebase - a space-separated list of URLs at which the class might be found. May be null.
        loader - a ClassLoader that may be used to load the class if all other methods fail.
        返回：
        the 类 object representing the loaded class.
        抛出：
        ClassNotFoundException - if class cannot be loaded.

      • isLocal

        public static boolean isLocal(Stub stub)
                       throws RemoteException
        The isLocal method has the same semantics as the ObjectImpl._is_local method, except that it can throw a RemoteException. The _is_local() method is provided so that stubs may determine if a particular object is implemented by a local servant and hence local invocation APIs may be used.
        参数：
        stub - the stub to test.
        返回：
        The _is_local() method returns true if the servant incarnating the object is located in the same process as the stub and they both share the same ORB instance. The _is_local() method returns false otherwise. The default behavior of _is_local() is to return false.
        抛出：
        RemoteException - The Java to IDL specification does not specify the conditions that cause a RemoteException to be thrown.

      • wrapException

        public static RemoteException wrapException(Throwable orig)
        Wraps an exception thrown by an implementation method. It returns the corresponding client-side exception.
        参数：
        orig - the exception to wrap.
        返回：
        the wrapped exception.

      • copyObjects

        public static Object[] copyObjects(Object[] obj,
                   ORB orb)
                            throws RemoteException
        Copies or connects an array of objects. Used by local stubs to copy any number of actual parameters, preserving sharing across parameters as necessary to support RMI semantics.
        参数：
        obj - the objects to copy or connect.
        orb - the ORB.
        返回：
        the copied or connected objects.
        抛出：
        RemoteException - if any object could not be copied or connected.

      • copyObject

        public static Object copyObject(Object obj,
                ORB orb)
                         throws RemoteException
        Copies or connects an object. Used by local stubs to copy an actual parameter, result object, or exception.
        参数：
        obj - the object to copy.
        orb - the ORB.
        返回：
        the copy or connected object.
        抛出：
        RemoteException - if the object could not be copied or connected.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s�


UtilDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface UtilDelegate

  • public interface UtilDelegate
    Supports delegation for method implementations in Util. The delegate is a singleton instance of a class that implements this interface and provides a replacement implementation for all the methods of javax.rmi.CORBA.Util. Delegation is enabled by providing the delegate's class name as the value of the javax.rmi.CORBA.UtilClass system property.
    另请参见：
    Util

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object copyObject(Object obj, ORB orb)
      Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
      Object[] copyObjects(Object[] obj, ORB orb)
      Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
      ValueHandler createValueHandler()
      Delegation call for Util.createValueHandler().
      String getCodebase(类 clz)
      Delegation call for Util.getCodebase(java.lang.Class).
      Tie getTie(Remote target)
      Delegation call for Util.getTie(java.rmi.Remote).
      boolean isLocal(Stub stub)
      Delegation call for Util.isLocal(javax.rmi.CORBA.Stub).
      类 loadClass(String className, String remoteCodebase, ClassLoader loader)
      Delegation call for Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader).
      RemoteException mapSystemException(SystemException ex)
      Delegation call for Util.mapSystemException(org.omg.CORBA.SystemException).
      Object readAny(InputStream in)
      Delegation call for Util.readAny(org.omg.CORBA.portable.InputStream).
      void registerTarget(Tie tie, Remote target)
      Delegation call for Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote).
      void unexportObject(Remote target)
      Delegation call for Util.unexportObject(java.rmi.Remote).
      RemoteException wrapException(Throwable obj)
      Delegation call for Util.wrapException(java.lang.Throwable).
      void writeAbstractObject(OutputStream out, Object obj)
      Delegation call for Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      void writeAny(OutputStream out, Object obj)
      Delegation call for Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      void writeRemoteObject(OutputStream out, Object obj)
      Delegation call for Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).

    • 方法详细信息

      • mapSystemException

        RemoteException mapSystemException(SystemException ex)
        Delegation call for Util.mapSystemException(org.omg.CORBA.SystemException).

      • writeAny

        void writeAny(OutputStream out,
            Object obj)
        Delegation call for Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object).

      • readAny

        Object readAny(InputStream in)
        Delegation call for Util.readAny(org.omg.CORBA.portable.InputStream).

      • writeRemoteObject

        void writeRemoteObject(OutputStream out,
                     Object obj)
        Delegation call for Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).

      • writeAbstractObject

        void writeAbstractObject(OutputStream out,
                       Object obj)
        Delegation call for Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).

      • registerTarget

        void registerTarget(Tie tie,
                  Remote target)
        Delegation call for Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote).

      • unexportObject

        void unexportObject(Remote target)
                    throws NoSuchObjectException
        Delegation call for Util.unexportObject(java.rmi.Remote).
        抛出：
        NoSuchObjectException

      • getTie

        Tie getTie(Remote target)
        Delegation call for Util.getTie(java.rmi.Remote).

      • createValueHandler

        ValueHandler createValueHandler()
        Delegation call for Util.createValueHandler().

      • getCodebase

        String getCodebase(类 clz)
        Delegation call for Util.getCodebase(java.lang.Class).

      • loadClass

        类 loadClass(String className,
              String remoteCodebase,
              ClassLoader loader)
                throws ClassNotFoundException
        Delegation call for Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader).
        抛出：
        ClassNotFoundException

      • isLocal

        boolean isLocal(Stub stub)
                throws RemoteException
        Delegation call for Util.isLocal(javax.rmi.CORBA.Stub).
        抛出：
        RemoteException

      • wrapException

        RemoteException wrapException(Throwable obj)
        Delegation call for Util.wrapException(java.lang.Throwable).

      • copyObject

        Object copyObject(Object obj,
                ORB orb)
                  throws RemoteException
        Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
        抛出：
        RemoteException

      • copyObjects

        Object[] copyObjects(Object[] obj,
                   ORB orb)
                     throws RemoteException
        Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
        抛出：
        RemoteException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s :n=sl"slcaalccsd /d:/<


ValueHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface ValueHandler

  • All Known Subinterfaces:
    ValueHandlerMultiFormat

    public interface ValueHandler
    Defines methods which allow serialization of Java objects to and from GIOP streams.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getRMIRepositoryID(类 clz)
      Returns the CORBA RepositoryId for the given Java class.
      RunTime getRunTimeCodeBase()
      Returns the CodeBase for this ValueHandler.
      boolean isCustomMarshaled(类 clz)
      Indicates whether the given class performs custom or default marshaling.
      Serializable readValue(InputStream in, int offset, 类 clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.
      Serializable writeReplace(Serializable value)
      If the value contains a writeReplace method then the result is returned.
      void writeValue(OutputStream out, Serializable value)
      Writes a value to the stream using Java semantics.

    • 方法详细信息

      • writeValue

        void writeValue(OutputStream out,
              Serializable value)
        Writes a value to the stream using Java semantics.
        参数：
        out - the stream to write the value to.
        value - the value to be written to the stream.

      • readValue

        Serializable readValue(InputStream in,
                     int offset,
                     类 clz,
                     String repositoryID,
                     RunTime sender)
        Reads a value from the stream using Java semantics.
        参数：
        in - the stream to read the value from.
        offset - the current position in the input stream.
        clz - the type of the value to be read in.
        repositoryID - the RepositoryId of the value to be read in.
        sender - the sending context runtime codebase.
        返回：
        the value read from the stream.

      • getRMIRepositoryID

        String getRMIRepositoryID(类 clz)
        Returns the CORBA RepositoryId for the given Java class.
        参数：
        clz - a Java class.
        返回：
        the CORBA RepositoryId for the class.

      • isCustomMarshaled

        boolean isCustomMarshaled(类 clz)
        Indicates whether the given class performs custom or default marshaling.
        参数：
        clz - the class to test for custom marshaling.
        返回：
        true if the class performs custom marshaling, false if it does not.

      • getRunTimeCodeBase

        RunTime getRunTimeCodeBase()
        Returns the CodeBase for this ValueHandler. This is used by the ORB runtime. The server sends the service context containing the IOR for this CodeBase on the first GIOP reply. The client does the same on the first GIOP request.
        返回：
        the SendingContext.CodeBase of this ValueHandler.

      • writeReplace

        Serializable writeReplace(Serializable value)
        If the value contains a writeReplace method then the result is returned. Otherwise, the value itself is returned.
        参数：
        value - the value to be marshaled.
        返回：
        the true value to marshal on the wire.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


ValueHandlerMultiFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.rmi.CORBA

Interface ValueHandlerMultiFormat

  • All Superinterfaces:
    ValueHandler

    public interface ValueHandlerMultiFormat
extends ValueHandler
    Java to IDL ptc 02-01-12 1.5.1.5
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte getMaximumStreamFormatVersion()
      Returns the maximum stream format version for RMI/IDL custom value types that is supported by this ValueHandler object.
      void writeValue(OutputStream out, Serializable value, byte streamFormatVersion)
      Allows the ORB to pass the stream format version for RMI/IDL custom value types.

      • 方法 - 继承于接口 javax.rmi.CORBA.ValueHandler

        getRMIRepositoryID, getRunTimeCodeBase, isCustomMarshaled, readValue, writeReplace, writeValue

    • 方法详细信息

      • getMaximumStreamFormatVersion

        byte getMaximumStreamFormatVersion()
        Returns the maximum stream format version for RMI/IDL custom value types that is supported by this ValueHandler object. The ValueHandler object must support the returned stream format version and all lower versions. An ORB may use this value to include in a standard IOR tagged component or service context to indicate to other ORBs the maximum RMI-IIOP stream format that it supports. If not included, the default for GIOP 1.2 is stream format version 1, and stream format version 2 for GIOP 1.3 and higher.

      • writeValue

        void writeValue(OutputStream out,
              Serializable value,
              byte streamFormatVersion)
        Allows the ORB to pass the stream format version for RMI/IDL custom value types. If the ORB calls this method, it must pass a stream format version between 1 and the value returned by the getMaximumStreamFormatVersion method inclusive, or else a BAD_PARAM exception with standard minor code will be thrown. If the ORB calls the older ValueHandler.writeValue(OutputStream, Serializable) method, stream format version 1 is implied. The ORB output stream passed to the ValueHandlerMultiFormat.writeValue method must implement the ValueOutputStream interface, and the ORB input stream passed to the ValueHandler.readValue method must implement the ValueInputStream interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt"= l cl ><< >>>!ddfagf>asefolo


Uses of Class javax.rmi.CORBA.ClassDesc

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.CORBA.ClassDesc

No usage of javax.rmi.CORBA.ClassDesc
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d1.t=�


Uses of Class javax.rmi.CORBA.Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.CORBA.Stub

  • Packages that use Stub
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of Stub in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type Stub
      修饰符与类型 方法与描述
      void StubDelegate.connect(Stub self, ORB orb)
      Delegation call for connect(org.omg.CORBA.ORB).
      boolean StubDelegate.equals(Stub self, Object obj)
      Delegation call for equals(java.lang.Object).
      int StubDelegate.hashCode(Stub self)
      Delegation call for hashCode().
      boolean UtilDelegate.isLocal(Stub stub)
      Delegation call for Util.isLocal(javax.rmi.CORBA.Stub).
      static boolean Util.isLocal(Stub stub)
      The isLocal method has the same semantics as the ObjectImpl._is_local method, except that it can throw a RemoteException.
      void StubDelegate.readObject(Stub self, ObjectInputStream s)
      Delegation call for Stub.readObject(java.io.ObjectInputStream).
      String StubDelegate.toString(Stub self)
      Delegation call for toString().
      void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
      Delegation call for Stub.writeObject(java.io.ObjectOutputStream).

    • Uses of Stub in org.omg.stub.java.rmi

      Subclasses of Stub in org.omg.stub.java.rmi
      修饰符与类型 类与描述
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/�/l d as ca.


Uses of Class javax.rmi.CORBA.Util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.CORBA.Util

No usage of javax.rmi.CORBA.Util
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

am.g.htU/tttRx.. "ta/


Uses of Interface javax.rmi.CORBA.PortableRemoteObjectDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.PortableRemoteObjectDelegate

No usage of javax.rmi.CORBA.PortableRemoteObjectDelegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"in/beulic


Uses of Interface javax.rmi.CORBA.StubDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.StubDelegate

No usage of javax.rmi.CORBA.StubDelegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=x"sastc"ooos <


Uses of Interface javax.rmi.CORBA.Tie

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.Tie

  • Packages that use Tie
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.

    • Uses of Tie in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return Tie
      修饰符与类型 方法与描述
      Tie UtilDelegate.getTie(Remote target)
      Delegation call for Util.getTie(java.rmi.Remote).
      static Tie Util.getTie(Remote target)
      Returns the tie (if any) for a given target object.
      Methods in javax.rmi.CORBA with parameters of type Tie
      修饰符与类型 方法与描述
      void UtilDelegate.registerTarget(Tie tie, Remote target)
      Delegation call for Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote).
      static void Util.registerTarget(Tie tie, Remote target)
      Registers a target for a tie.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n=e A"e=a=0 .>


Uses of Interface javax.rmi.CORBA.UtilDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.UtilDelegate

No usage of javax.rmi.CORBA.UtilDelegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sa>}s


Uses of Interface javax.rmi.CORBA.ValueHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.ValueHandler

  • Packages that use ValueHandler
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.

    • Uses of ValueHandler in javax.rmi.CORBA

      Subinterfaces of ValueHandler in javax.rmi.CORBA
      修饰符与类型 Interface and Description
      interface  ValueHandlerMultiFormat
      Java to IDL ptc 02-01-12 1.5.1.5
      Methods in javax.rmi.CORBA that return ValueHandler
      修饰符与类型 方法与描述
      ValueHandler UtilDelegate.createValueHandler()
      Delegation call for Util.createValueHandler().
      static ValueHandler Util.createValueHandler()
      Returns a singleton instance of a class that implements the ValueHandler interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oda o


Uses of Interface javax.rmi.CORBA.ValueHandlerMultiFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.rmi.CORBA.ValueHandlerMultiFormat

No usage of javax.rmi.CORBA.ValueHandlerMultiFormat
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.gC acetneee=leetc<


javax.rmi.ssl

Classes

  • SslRMIClientSocketFactory
  • SslRMIServerSocketFactory


javax.rmi.ssl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.rmi.ssl

Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

请参见： 描述

  • Class Summary
    类 描述
    SslRMIClientSocketFactory
    An SslRMIClientSocketFactory instance is used by the RMI runtime in order to obtain client sockets for RMI calls via SSL.
    SslRMIServerSocketFactory
    An SslRMIServerSocketFactory instance is used by the RMI runtime in order to obtain server sockets for RMI calls via SSL.

软件包 javax.rmi.ssl Description

Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.
从以下版本开始：
1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3;HletnlTagVt/�


javax.rmi.ssl Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.rmi.ssl

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.rmi.ssl.SslRMIClientSocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.io.Serializable)
    • javax.rmi.ssl.SslRMIServerSocketFactory (implements java.rmi.server.RMIServerSocketFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p<


SslRMIClientSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.rmi.ssl

类 SslRMIClientSocketFactory

  • java.lang.Object
    • javax.rmi.ssl.SslRMIClientSocketFactory
  • 所有已实现的接口：
    Serializable, RMIClientSocketFactory

    public class SslRMIClientSocketFactory
extends Object
implements RMIClientSocketFactory, Serializable

    An SslRMIClientSocketFactory instance is used by the RMI runtime in order to obtain client sockets for RMI calls via SSL.

    This class implements RMIClientSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

    This class creates SSL sockets using the default SSLSocketFactory (see SSLSocketFactory.getDefault()). All instances of this class are functionally equivalent. In particular, they all share the same truststore, and the same keystore when client authentication is required by the server. This behavior can be modified in subclasses by overriding the createSocket(String,int) method; in that case, equals and hashCode may also need to be overridden.

    If the system property javax.rmi.ssl.client.enabledCipherSuites is specified, the createSocket(String,int) method will call SSLSocket.setEnabledCipherSuites(String[]) before returning the socket. The value of this system property is a string that is a comma-separated list of SSL/TLS cipher suites to enable.

    If the system property javax.rmi.ssl.client.enabledProtocols is specified, the createSocket(String,int) method will call SSLSocket.setEnabledProtocols(String[]) before returning the socket. The value of this system property is a string that is a comma-separated list of SSL/TLS protocol versions to enable.

    从以下版本开始：
    1.5
    另请参见：
    SSLSocketFactory, SslRMIServerSocketFactory, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SslRMIClientSocketFactory()
      Creates a new SslRMIClientSocketFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Socket createSocket(String host, int port)
      Creates an SSL socket.
      boolean equals(Object obj)
      Indicates whether some other object is "equal to" this one.
      int hashCode()
      Returns a hash code value for this SslRMIClientSocketFactory.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SslRMIClientSocketFactory

        public SslRMIClientSocketFactory()

        Creates a new SslRMIClientSocketFactory.

    • 方法详细信息

      • createSocket

        public Socket createSocket(String host,
                  int port)
                    throws IOException

        Creates an SSL socket.

        If the system property javax.rmi.ssl.client.enabledCipherSuites is specified, this method will call SSLSocket.setEnabledCipherSuites(String[]) before returning the socket. The value of this system property is a string that is a comma-separated list of SSL/TLS cipher suites to enable.

        If the system property javax.rmi.ssl.client.enabledProtocols is specified, this method will call SSLSocket.setEnabledProtocols(String[]) before returning the socket. The value of this system property is a string that is a comma-separated list of SSL/TLS protocol versions to enable.

        指定者：
        createSocket in interface RMIClientSocketFactory
        参数：
        host - the host name
        port - the port number
        返回：
        a socket connected to the specified host and port.
        抛出：
        IOException - if an I/O error occurs during socket creation

      • equals

        public boolean equals(Object obj)

        Indicates whether some other object is "equal to" this one.

        Because all instances of this class are functionally equivalent (they all use the default SSLSocketFactory), this method simply returns this.getClass().equals(obj.getClass()).

        A subclass should override this method (as well as hashCode()) if its instances are not all functionally equivalent.

        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns a hash code value for this SslRMIClientSocketFactory.

        重载：
        hashCode in class Object
        返回：
        a hash code value for this SslRMIClientSocketFactory.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tb nmpsc/?a/dC奔


SslRMIServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.rmi.ssl

类 SslRMIServerSocketFactory

  • java.lang.Object
    • javax.rmi.ssl.SslRMIServerSocketFactory
  • 所有已实现的接口：
    RMIServerSocketFactory

    public class SslRMIServerSocketFactory
extends Object
implements RMIServerSocketFactory

    An SslRMIServerSocketFactory instance is used by the RMI runtime in order to obtain server sockets for RMI calls via SSL.

    This class implements RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

    This class creates SSL sockets using the default SSLSocketFactory (see SSLSocketFactory.getDefault()) or the default SSLServerSocketFactory (see SSLServerSocketFactory.getDefault()) unless the constructor taking an SSLContext is used in which case the SSL sockets are created using the SSLSocketFactory returned by SSLContext.getSocketFactory() or the SSLServerSocketFactory returned by SSLContext.getServerSocketFactory(). When an SSLContext is not supplied all the instances of this class share the same keystore, and the same truststore (when client authentication is required by the server). This behavior can be modified by supplying an already initialized SSLContext instance.

    从以下版本开始：
    1.5
    另请参见：
    SSLSocketFactory, SSLServerSocketFactory, SslRMIClientSocketFactory

    • 构造方法摘要

      Constructors
      构造方法与描述
      SslRMIServerSocketFactory()
      Creates a new SslRMIServerSocketFactory with the default SSL socket configuration.
      SslRMIServerSocketFactory(SSLContext context, String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
      Creates a new SslRMIServerSocketFactory with the specified SSLContext and SSL socket configuration.
      SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
      Creates a new SslRMIServerSocketFactory with the specified SSL socket configuration.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ServerSocket createServerSocket(int port)
      Creates a server socket that accepts SSL connections configured according to this factory's SSL socket configuration parameters.
      boolean equals(Object obj)
      Indicates whether some other object is "equal to" this one.
      String[] getEnabledCipherSuites()
      Returns the names of the cipher suites enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the cipher suites that are enabled by default.
      String[] getEnabledProtocols()
      Returns the names of the protocol versions enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the protocol versions that are enabled by default.
      boolean getNeedClientAuth()
      Returns true if client authentication is required on SSL connections accepted by server sockets created by this factory.
      int hashCode()
      Returns a hash code value for this SslRMIServerSocketFactory.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SslRMIServerSocketFactory

        public SslRMIServerSocketFactory()

        Creates a new SslRMIServerSocketFactory with the default SSL socket configuration.

        SSL connections accepted by server sockets created by this factory have the default cipher suites and protocol versions enabled and do not require client authentication.

      • SslRMIServerSocketFactory

        public SslRMIServerSocketFactory(String[] enabledCipherSuites,
                         String[] enabledProtocols,
                         boolean needClientAuth)
                          throws IllegalArgumentException

        Creates a new SslRMIServerSocketFactory with the specified SSL socket configuration.

        参数：
        enabledCipherSuites - names of all the cipher suites to enable on SSL connections accepted by server sockets created by this factory, or null to use the cipher suites that are enabled by default
        enabledProtocols - names of all the protocol versions to enable on SSL connections accepted by server sockets created by this factory, or null to use the protocol versions that are enabled by default
        needClientAuth - true to require client authentication on SSL connections accepted by server sockets created by this factory; false to not require client authentication
        抛出：
        IllegalArgumentException - when one or more of the cipher suites named by the enabledCipherSuites parameter is not supported, when one or more of the protocols named by the enabledProtocols parameter is not supported or when a problem is encountered while trying to check if the supplied cipher suites and protocols to be enabled are supported.
        另请参见：
        SSLSocket.setEnabledCipherSuites(java.lang.String[]),
SSLSocket.setEnabledProtocols(java.lang.String[]),
SSLSocket.setNeedClientAuth(boolean)

      • SslRMIServerSocketFactory

        public SslRMIServerSocketFactory(SSLContext context,
                         String[] enabledCipherSuites,
                         String[] enabledProtocols,
                         boolean needClientAuth)
                          throws IllegalArgumentException

        Creates a new SslRMIServerSocketFactory with the specified SSLContext and SSL socket configuration.

        参数：
        context - the SSL context to be used for creating SSL sockets. If context is null the default SSLSocketFactory or the default SSLServerSocketFactory will be used to create SSL sockets. Otherwise, the socket factory returned by SSLContext.getSocketFactory() or SSLContext.getServerSocketFactory() will be used instead.
        enabledCipherSuites - names of all the cipher suites to enable on SSL connections accepted by server sockets created by this factory, or null to use the cipher suites that are enabled by default
        enabledProtocols - names of all the protocol versions to enable on SSL connections accepted by server sockets created by this factory, or null to use the protocol versions that are enabled by default
        needClientAuth - true to require client authentication on SSL connections accepted by server sockets created by this factory; false to not require client authentication
        抛出：
        IllegalArgumentException - when one or more of the cipher suites named by the enabledCipherSuites parameter is not supported, when one or more of the protocols named by the enabledProtocols parameter is not supported or when a problem is encountered while trying to check if the supplied cipher suites and protocols to be enabled are supported.
        从以下版本开始：
        1.7
        另请参见：
        SSLSocket.setEnabledCipherSuites(java.lang.String[]),
SSLSocket.setEnabledProtocols(java.lang.String[]),
SSLSocket.setNeedClientAuth(boolean)

    • 方法详细信息

      • getEnabledCipherSuites

        public final String[] getEnabledCipherSuites()

        Returns the names of the cipher suites enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the cipher suites that are enabled by default.

        返回：
        an array of cipher suites enabled, or null
        另请参见：
        SSLSocket.setEnabledCipherSuites(java.lang.String[])

      • getEnabledProtocols

        public final String[] getEnabledProtocols()

        Returns the names of the protocol versions enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the protocol versions that are enabled by default.

        返回：
        an array of protocol versions enabled, or null
        另请参见：
        SSLSocket.setEnabledProtocols(java.lang.String[])

      • getNeedClientAuth

        public final boolean getNeedClientAuth()

        Returns true if client authentication is required on SSL connections accepted by server sockets created by this factory.

        返回：
        true if client authentication is required
        另请参见：
        SSLSocket.setNeedClientAuth(boolean)

      • createServerSocket

        public ServerSocket createServerSocket(int port)
                                throws IOException

        Creates a server socket that accepts SSL connections configured according to this factory's SSL socket configuration parameters.

        指定者：
        createServerSocket in interface RMIServerSocketFactory
        参数：
        port - the port number
        返回：
        the server socket on the specified port
        抛出：
        IOException - if an I/O error occurs during server socket creation

      • equals

        public boolean equals(Object obj)

        Indicates whether some other object is "equal to" this one.

        Two SslRMIServerSocketFactory objects are equal if they have been constructed with the same SSL context and SSL socket configuration parameters.

        A subclass should override this method (as well as hashCode()) if it adds instance state that affects equality.

        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns a hash code value for this SslRMIServerSocketFactory.

        重载：
        hashCode in class Object
        返回：
        a hash code value for this SslRMIServerSocketFactory.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1rsr oOee间恕癿胐�.所t/鸣 湓� ol,.�


Uses of Package javax.rmi.ssl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.rmi.ssl

No usage of javax.rmi.ssl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h t-caeapkkklxeehe"ei


Uses of Class javax.rmi.ssl.SslRMIClientSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.ssl.SslRMIClientSocketFactory

No usage of javax.rmi.ssl.SslRMIClientSocketFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

soe


Uses of Class javax.rmi.ssl.SslRMIServerSocketFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.rmi.ssl.SslRMIServerSocketFactory

No usage of javax.rmi.ssl.SslRMIServerSocketFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u�0 d<�).


AbstractScriptEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 AbstractScriptEngine

  • java.lang.Object
    • javax.script.AbstractScriptEngine
  • 所有已实现的接口：
    ScriptEngine

    public abstract class AbstractScriptEngine
extends Object
implements ScriptEngine
    Provides a standard implementation for several of the variants of the eval method.

    eval(Reader)

    eval(String)

    eval(String, Bindings)

    eval(Reader, Bindings)

    are implemented using the abstract methods

    eval(Reader,ScriptContext) or eval(String, ScriptContext)

    with a SimpleScriptContext.

    A SimpleScriptContext is used as the default ScriptContext of the AbstractScriptEngine..

    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ScriptContext context
      The default ScriptContext of this AbstractScriptEngine.

      • 字段 - 继承于接口 javax.script.ScriptEngine

        ARGV, ENGINE, ENGINE_VERSION, FILENAME, LANGUAGE, LANGUAGE_VERSION, NAME

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractScriptEngine()
      Creates a new instance of AbstractScriptEngine using a SimpleScriptContext as its default ScriptContext.
      AbstractScriptEngine(Bindings n)
      Creates a new instance using the specified Bindings as the ENGINE_SCOPE Bindings in the protected context field.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object eval(Reader reader)
      eval(Reader) calls the abstract eval(Reader, ScriptContext) passing the value of the context field.
      Object eval(Reader reader, Bindings bindings)
      eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field.
      Object eval(String script)
      Same as eval(Reader) except that the abstract eval(String, ScriptContext) is used.
      Object eval(String script, Bindings bindings)
      Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
      Object get(String key)
      Gets the value for the specified key in the ENGINE_SCOPE of the protected context field.
      Bindings getBindings(int scope)
      Returns the Bindings with the specified scope value in the protected context field.
      ScriptContext getContext()
      Returns the value of the protected context field.
      protected ScriptContext getScriptContext(Bindings nn)
      Returns a SimpleScriptContext.
      void put(String key, Object value)
      Sets the specified value with the specified key in the ENGINE_SCOPE Bindings of the protected context field.
      void setBindings(Bindings bindings, int scope)
      Sets the Bindings with the corresponding scope value in the context field.
      void setContext(ScriptContext ctxt)
      Sets the value of the protected context field to the specified ScriptContext.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.script.ScriptEngine

        createBindings, eval, eval, getFactory

    • 字段详细信息

      • context

        protected ScriptContext context
        The default ScriptContext of this AbstractScriptEngine.

    • 构造方法详细信息

      • AbstractScriptEngine

        public AbstractScriptEngine()
        Creates a new instance of AbstractScriptEngine using a SimpleScriptContext as its default ScriptContext.

      • AbstractScriptEngine

        public AbstractScriptEngine(Bindings n)
        Creates a new instance using the specified Bindings as the ENGINE_SCOPE Bindings in the protected context field.
        参数：
        上一个 - The specified Bindings.
        抛出：
        NullPointerException - if n is null.

    • 方法详细信息

      • setContext

        public void setContext(ScriptContext ctxt)
        Sets the value of the protected context field to the specified ScriptContext.
        指定者：
        setContext in interface ScriptEngine
        参数：
        ctxt - The specified ScriptContext.
        抛出：
        NullPointerException - if ctxt is null.

      • getContext

        public ScriptContext getContext()
        Returns the value of the protected context field.
        指定者：
        getContext in interface ScriptEngine
        返回：
        The value of the protected context field.

      • getBindings

        public Bindings getBindings(int scope)
        Returns the Bindings with the specified scope value in the protected context field.
        指定者：
        getBindings in interface ScriptEngine
        参数：
        scope - The specified scope
        返回：
        The corresponding Bindings.
        抛出：
        IllegalArgumentException - if the value of scope is invalid for the type the protected context field.

      • setBindings

        public void setBindings(Bindings bindings,
               int scope)
        Sets the Bindings with the corresponding scope value in the context field.
        指定者：
        setBindings in interface ScriptEngine
        参数：
        bindings - The specified Bindings.
        scope - The specified scope.
        抛出：
        IllegalArgumentException - if the value of scope is invalid for the type the context field.
        NullPointerException - if the bindings is null and the scope is ScriptContext.ENGINE_SCOPE

      • put

        public void put(String key,
       Object value)
        Sets the specified value with the specified key in the ENGINE_SCOPE Bindings of the protected context field.
        指定者：
        put in interface ScriptEngine
        参数：
        key - The specified key.
        value - The specified value.
        抛出：
        NullPointerException - if key is null.
        IllegalArgumentException - if key is empty.

      • get

        public Object get(String key)
        Gets the value for the specified key in the ENGINE_SCOPE of the protected context field.
        指定者：
        get in interface ScriptEngine
        参数：
        key - The key whose value is to be returned
        返回：
        The value for the specified key.
        抛出：
        NullPointerException - if key is null.
        IllegalArgumentException - if key is empty.

      • eval

        public Object eval(Reader reader,
          Bindings bindings)
            throws ScriptException
        eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field. The specified Bindings is used instead of the ENGINE_SCOPE Bindings of the context field.
        指定者：
        eval in interface ScriptEngine
        参数：
        reader - A Reader containing the source of the script.
        bindings - A Bindings to use for the ENGINE_SCOPE while the script executes.
        返回：
        The return value from eval(Reader, ScriptContext)
        抛出：
        ScriptException - if an error occurs in script.
        NullPointerException - if any of the parameters is null.

      • eval

        public Object eval(String script,
          Bindings bindings)
            throws ScriptException
        Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
        指定者：
        eval in interface ScriptEngine
        参数：
        script - A String containing the source of the script.
        bindings - A Bindings to use as the ENGINE_SCOPE while the script executes.
        返回：
        The return value from eval(String, ScriptContext)
        抛出：
        ScriptException - if an error occurs in script.
        NullPointerException - if any of the parameters is null.

      • eval

        public Object eval(Reader reader)
            throws ScriptException
        eval(Reader) calls the abstract eval(Reader, ScriptContext) passing the value of the context field.
        指定者：
        eval in interface ScriptEngine
        参数：
        reader - A Reader containing the source of the script.
        返回：
        The return value from eval(Reader, ScriptContext)
        抛出：
        ScriptException - if an error occurs in script.
        NullPointerException - if any of the parameters is null.

      • eval

        public Object eval(String script)
            throws ScriptException
        Same as eval(Reader) except that the abstract eval(String, ScriptContext) is used.
        指定者：
        eval in interface ScriptEngine
        参数：
        script - A String containing the source of the script.
        返回：
        The return value from eval(String, ScriptContext)
        抛出：
        ScriptException - if an error occurrs in script.
        NullPointerException - if any of the parameters is null.

      • getScriptContext

        protected ScriptContext getScriptContext(Bindings nn)
        Returns a SimpleScriptContext. The SimpleScriptContext:

        • Uses the specified Bindings for its ENGINE_SCOPE
        • Uses the Bindings returned by the abstract getGlobalScope method as its GLOBAL_SCOPE
        • Uses the Reader and Writer in the default ScriptContext of this ScriptEngine

        A SimpleScriptContext returned by this method is used to implement eval methods using the abstract eval(Reader,Bindings) and eval(String,Bindings) versions.
        参数：
        nn - Bindings to use for the ENGINE_SCOPE
        返回：
        The SimpleScriptContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Bindings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface Bindings

  • All Superinterfaces:
    Map<String,Object>
    All Known Implementing Classes:
    SimpleBindings

    public interface Bindings
extends Map<String,Object>
    A mapping of key/value pairs, all of whose keys are Strings.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containsKey(Object key)
      Returns true if this map contains a mapping for the specified key.
      Object get(Object key)
      Returns the value to which this map maps the specified key.
      Object put(String name, Object value)
      Set a named value.
      void putAll(Map<? extends String,? extends Object> toMerge)
      Adds all the mappings in a given Map to this Bindings.
      Object remove(Object key)
      Removes the mapping for this key from this map if it is present (optional operation).

      • 方法 - 继承于接口 java.util.Map

        clear, containsValue, entrySet, equals, hashCode, isEmpty, keySet, size, values

    • 方法详细信息

      • put

        Object put(String name,
         Object value)
        Set a named value.
        指定者：
        put in interface Map<String,Object>
        参数：
        name - The name associated with the value.
        value - The value associated with the name.
        返回：
        The value previously associated with the given name. Returns null if no value was previously associated with the name.
        抛出：
        NullPointerException - if the name is null.
        IllegalArgumentException - if the name is empty String.

      • putAll

        void putAll(Map<? extends String,? extends Object> toMerge)
        Adds all the mappings in a given Map to this Bindings.
        指定者：
        putAll in interface Map<String,Object>
        参数：
        toMerge - The Map to merge with this one.
        抛出：
        NullPointerException - if toMerge map is null or if some key in the map is null.
        IllegalArgumentException - if some key in the map is an empty String.

      • containsKey

        boolean containsKey(Object key)
        Returns true if this map contains a mapping for the specified key. More formally, returns true if and only if this map contains a mapping for a key k such that (key==null ? k==null : key.equals(k)). (There can be at most one such mapping.)
        指定者：
        containsKey in interface Map<String,Object>
        参数：
        key - key whose presence in this map is to be tested.
        返回：
        true if this map contains a mapping for the specified key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String

      • get

        Object get(Object key)
        Returns the value to which this map maps the specified key. Returns null if the map contains no mapping for this key. A return value of null does not necessarily indicate that the map contains no mapping for the key; it's also possible that the map explicitly maps the key to null. The containsKey operation may be used to distinguish these two cases.

        More formally, if this map contains a mapping from a key k to a value v such that (key==null ? k==null : key.equals(k)), then this method returns v; otherwise it returns null. (There can be at most one such mapping.)

        指定者：
        get in interface Map<String,Object>
        参数：
        key - key whose associated value is to be returned.
        返回：
        the value to which this map maps the specified key, or null if the map contains no mapping for this key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String

      • remove

        Object remove(Object key)
        Removes the mapping for this key from this map if it is present (optional operation). More formally, if this map contains a mapping from key k to value v such that (key==null ? k==null : key.equals(k)), that mapping is removed. (The map can contain at most one such mapping.)

        Returns the value to which the map previously associated the key, or null if the map contained no mapping for this key. (A null return can also indicate that the map previously associated null with the specified key if the implementation supports null values.) The map will not contain a mapping for the specified key once the call returns.

        指定者：
        remove in interface Map<String,Object>
        参数：
        key - key whose mapping is to be removed from the map.
        返回：
        previous value associated with specified key, or null if there was no mapping for key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ixnsu e eveheeiceeelv/gomeu/xn".cln


Compilable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface Compilable

  • public interface Compilable
    The optional interface implemented by ScriptEngines whose methods compile scripts to a form that can be executed repeatedly without recompilation.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CompiledScript compile(Reader script)
      Compiles the script (source read from Reader) for later execution.
      CompiledScript compile(String script)
      Compiles the script (source represented as a String) for later execution.

    • 方法详细信息

      • compile

        CompiledScript compile(String script)
                       throws ScriptException
        Compiles the script (source represented as a String) for later execution.
        参数：
        script - The source of the script, represented as a String.
        返回：
        An subclass of CompiledScript to be executed later using one of the eval methods of CompiledScript.
        抛出：
        ScriptException - if compilation fails.
        NullPointerException - if the argument is null.

      • compile

        CompiledScript compile(Reader script)
                       throws ScriptException
        Compiles the script (source read from Reader) for later execution. Functionality is identical to compile(String) other than the way in which the source is passed.
        参数：
        script - The reader from which the script source is obtained.
        返回：
        An implementation of CompiledScript to be executed later using one of its eval methods of CompiledScript.
        抛出：
        ScriptException - if compilation fails.
        NullPointerException - if argument is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/=l.he re s<< ssx>uu&n<&dnsl&;s bft


CompiledScript

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 CompiledScript

  • java.lang.Object
    • javax.script.CompiledScript

  • public abstract class CompiledScript
extends Object
    Extended by classes that store results of compilations. State might be stored in the form of Java classes, Java class files or scripting language opcodes. The script may be executed repeatedly without reparsing.

    Each CompiledScript is associated with a ScriptEngine -- A call to an eval method of the CompiledScript causes the execution of the script by the ScriptEngine. Changes in the state of the ScriptEngine caused by execution of tne CompiledScript may visible during subsequent executions of scripts by the engine.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompiledScript()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object eval()
      Executes the program stored in the CompiledScript object.
      Object eval(Bindings bindings)
      Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution.
      abstract Object eval(ScriptContext context)
      Executes the program stored in this CompiledScript object.
      abstract ScriptEngine getEngine()
      Returns the ScriptEngine whose compile method created this CompiledScript.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CompiledScript

        public CompiledScript()

    • 方法详细信息

      • eval

        public abstract Object eval(ScriptContext context)
                     throws ScriptException
        Executes the program stored in this CompiledScript object.
        参数：
        context - A ScriptContext that is used in the same way as the ScriptContext passed to the eval methods of ScriptEngine.
        返回：
        The value returned by the script execution, if any. Should return null if no value is returned by the script execution.
        抛出：
        ScriptException - if an error occurs.
        NullPointerException - if context is null.

      • eval

        public Object eval(Bindings bindings)
            throws ScriptException
        Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution. If bindings is null, then the effect of calling this method is same as that of eval(getEngine().getContext()).

        . The GLOBAL_SCOPE Bindings, Reader and Writer associated with the default ScriptContext of the associated ScriptEngine are used.

        参数：
        bindings - The bindings of attributes used for the ENGINE_SCOPE.
        返回：
        The return value from the script execution
        抛出：
        ScriptException - if an error occurs.

      • eval

        public Object eval()
            throws ScriptException
        Executes the program stored in the CompiledScript object. The default ScriptContext of the associated ScriptEngine is used. The effect of calling this method is same as that of eval(getEngine().getContext()).
        返回：
        The return value from the script execution
        抛出：
        ScriptException - if an error occurs.

      • getEngine

        public abstract ScriptEngine getEngine()
        Returns the ScriptEngine whose compile method created this CompiledScript. The CompiledScript will execute in this engine.
        返回：
        The ScriptEngine that created this CompiledScript
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hattstleeallt>n lcantnn t


Invocable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface Invocable

  • public interface Invocable
    The optional interface implemented by ScriptEngines whose methods allow the invocation of procedures in scripts that have previously been executed.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <T> T getInterface(类<T> clasz)
      Returns an implementation of an interface using functions compiled in the interpreter.
      <T> T getInterface(Object thiz, 类<T> clasz)
      Returns an implementation of an interface using member functions of a scripting object compiled in the interpreter.
      Object invokeFunction(String name, Object... args)
      Used to call top-level procedures and functions defined in scripts.
      Object invokeMethod(Object thiz, String name, Object... args)
      Calls a method on a script object compiled during a previous script execution, which is retained in the state of the ScriptEngine.

    • 方法详细信息

      • invokeMethod

        Object invokeMethod(Object thiz,
                  String name,
                  Object... args)
                    throws ScriptException,
                           NoSuchMethodException
        Calls a method on a script object compiled during a previous script execution, which is retained in the state of the ScriptEngine.
        参数：
        name - The name of the procedure to be called.
        thiz - If the procedure is a member of a class defined in the script and thiz is an instance of that class returned by a previous execution or invocation, the named method is called through that instance.
        args - Arguments to pass to the procedure. The rules for converting the arguments to scripting variables are implementation-specific.
        返回：
        The value returned by the procedure. The rules for converting the scripting variable returned by the script method to a Java Object are implementation-specific.
        抛出：
        ScriptException - if an error occurrs during invocation of the method.
        NoSuchMethodException - if method with given name or matching argument types cannot be found.
        NullPointerException - if the method name is null.
        IllegalArgumentException - if the specified thiz is null or the specified Object is does not represent a scripting object.

      • invokeFunction

        Object invokeFunction(String name,
                    Object... args)
                      throws ScriptException,
                             NoSuchMethodException
        Used to call top-level procedures and functions defined in scripts.
        参数：
        args - Arguments to pass to the procedure or function
        返回：
        The value returned by the procedure or function
        抛出：
        ScriptException - if an error occurrs during invocation of the method.
        NoSuchMethodException - if method with given name or matching argument types cannot be found.
        NullPointerException - if method name is null.

      • getInterface

        <T> T getInterface(类<T> clasz)
        Returns an implementation of an interface using functions compiled in the interpreter. The methods of the interface may be implemented using the invokeFunction method.
        参数：
        clasz - The 类 object of the interface to return.
        返回：
        An instance of requested interface - null if the requested interface is unavailable, i. e. if compiled functions in the ScriptEngine cannot be found matching the ones in the requested interface.
        抛出：
        IllegalArgumentException - if the specified 类 object is null or is not an interface.

      • getInterface

        <T> T getInterface(Object thiz,
                 类<T> clasz)
        Returns an implementation of an interface using member functions of a scripting object compiled in the interpreter. The methods of the interface may be implemented using the invokeMethod method.
        参数：
        thiz - The scripting object whose member functions are used to implement the methods of the interface.
        clasz - The 类 object of the interface to return.
        返回：
        An instance of requested interface - null if the requested interface is unavailable, i. e. if compiled methods in the ScriptEngine cannot be found matching the ones in the requested interface.
        抛出：
        IllegalArgumentException - if the specified 类 object is null or is not an interface, or if the specified Object is null or does not represent a scripting object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et)ulalye..keel 3(aiatispt tka<>


javax.script

Interfaces

  • Bindings
  • Compilable
  • Invocable
  • ScriptContext
  • ScriptEngine
  • ScriptEngineFactory

Classes

  • AbstractScriptEngine
  • CompiledScript
  • ScriptEngineManager
  • SimpleBindings
  • SimpleScriptContext

Exceptions

  • ScriptException
p


javax.script

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.script

The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

请参见： 描述

  • 接口摘要
    接口 描述
    Bindings
    A mapping of key/value pairs, all of whose keys are Strings.
    Compilable
    The optional interface implemented by ScriptEngines whose methods compile scripts to a form that can be executed repeatedly without recompilation.
    Invocable
    The optional interface implemented by ScriptEngines whose methods allow the invocation of procedures in scripts that have previously been executed.
    ScriptContext
    The interface whose implementing classes are used to connect Script Engines with objects, such as scoped Bindings, in hosting applications.
    ScriptEngine
    ScriptEngine is the fundamental interface whose methods must be fully functional in every implementation of this specification.
    ScriptEngineFactory
    ScriptEngineFactory is used to describe and instantiate ScriptEngines.
  • Class Summary
    类 描述
    AbstractScriptEngine
    Provides a standard implementation for several of the variants of the eval method.
    CompiledScript
    Extended by classes that store results of compilations.
    ScriptEngineManager
    The ScriptEngineManager implements a discovery and instantiation mechanism for ScriptEngine classes and also maintains a collection of key/value pairs storing state shared by all engines created by the Manager.
    SimpleBindings
    A simple implementation of Bindings backed by a HashMap or some other specified Map.
    SimpleScriptContext
    Simple implementation of ScriptContext.
  • Exception Summary
    Exception 描述
    ScriptException
    The generic Exception class for the Scripting APIs.

软件包 javax.script Description

The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications. This API is intended for use by application programmers who wish to execute programs written in scripting languages in their Java applications. The scripting language programs are usually provided by the end-users of the applications.

The main areas of functionality of javax.script package include

  1. Script execution: Scripts are streams of characters used as sources for programs executed by script engines. Script execution uses eval methods of ScriptEngine and methods of the Invocable interface.

  2. Binding: This facility allows Java objects to be exposed to script programs as named variables. Bindings and ScriptContext classes are used for this purpose.

  3. Compilation: This functionality allows the intermediate code generated by the front-end of a script engine to be stored and executed repeatedly. This benefits applications that execute the same script multiple times. These applications can gain efficiency since the engines' front-ends only need to execute once per script rather than once per script execution. Note that this functionality is optional and script engines may choose not to implement it. Callers need to check for availability of the Compilable interface using an instanceof check.

  4. Invocation: This functionality allows the reuse of intermediate code generated by a script engine's front-end. Whereas Compilation allows entire scripts represented by intermediate code to be re-executed, Invocation functionality allows individual procedures/methods in the scripts to be re-executed. As in the case with compilation, not all script engines are required to provide this facility. Caller has to check for Invocable availability.

  5. Script engine discovery and Metadata: Applications written to the Scripting API might have specific requirements on script engines. Some may require a specific scripting language and/or version while others may require a specific implementation engine and/or version. Script engines are packaged in a specified way so that engines can be discovered at runtime and queried for attributes. The Engine discovery mechanism is based on the Service discovery mechanism described in the Jar File Specification. Script engine implementing classes are packaged in jar files that include a text resource named META-INF/services/javax.script.ScriptEngineFactory. This resource must include a line for each ScriptEngineFactory that is packaged in the jar file. ScriptEngineManager includes getEngineFactories method to get all ScriptEngineFactory instances discovered using this mechanism. ScriptEngineFactory has methods to query attributes about script engine.

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ejc/enic ca vvitllxtpi/tu


javax.script Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.script

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.script.AbstractScriptEngine (implements javax.script.ScriptEngine)
    • javax.script.CompiledScript
    • javax.script.ScriptEngineManager
    • javax.script.SimpleBindings (implements javax.script.Bindings)
    • javax.script.SimpleScriptContext (implements javax.script.ScriptContext)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.script.ScriptException

Interface Hierarchy

  • javax.script.Compilable
  • javax.script.Invocable
  • java.util.Map<K,V>
    • javax.script.Bindings
  • javax.script.ScriptContext
  • javax.script.ScriptEngine
  • javax.script.ScriptEngineFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

auscirfo tIssiD /s


ScriptContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface ScriptContext

  • All Known Implementing Classes:
    SimpleScriptContext

    public interface ScriptContext
    The interface whose implementing classes are used to connect Script Engines with objects, such as scoped Bindings, in hosting applications. Each scope is a set of named attributes whose values can be set and retrieved using the ScriptContext methods. ScriptContexts also expose Readers and Writers that can be used by the ScriptEngines for input and output.
    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ENGINE_SCOPE
      EngineScope attributes are visible during the lifetime of a single ScriptEngine and a set of attributes is maintained for each engine.
      static int GLOBAL_SCOPE
      GlobalScope attributes are visible to all engines created by same ScriptEngineFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getAttribute(String name)
      Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.
      Object getAttribute(String name, int scope)
      Gets the value of an attribute in a given scope.
      int getAttributesScope(String name)
      Get the lowest scope in which an attribute is defined.
      Bindings getBindings(int scope)
      Gets the Bindings associated with the given scope in this ScriptContext.
      Writer getErrorWriter()
      Returns the Writer used to display error output.
      Reader getReader()
      Returns a Reader to be used by the script to read input.
      List<Integer> getScopes()
      Returns immutable List of all the valid values for scope in the ScriptContext.
      Writer getWriter()
      Returns the Writer for scripts to use when displaying output.
      Object removeAttribute(String name, int scope)
      Remove an attribute in a given scope.
      void setAttribute(String name, Object value, int scope)
      Sets the value of an attribute in a given scope.
      void setBindings(Bindings bindings, int scope)
      Associates a Bindings instance with a particular scope in this ScriptContext.
      void setErrorWriter(Writer writer)
      Sets the Writer used to display error output.
      void setReader(Reader reader)
      Sets the Reader for scripts to read input .
      void setWriter(Writer writer)
      Sets the Writer for scripts to use when displaying output.

    • 字段详细信息

      • ENGINE_SCOPE

        static final int ENGINE_SCOPE
        EngineScope attributes are visible during the lifetime of a single ScriptEngine and a set of attributes is maintained for each engine.
        另请参见：
        Constant Field Values

      • GLOBAL_SCOPE

        static final int GLOBAL_SCOPE
        GlobalScope attributes are visible to all engines created by same ScriptEngineFactory.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • setBindings

        void setBindings(Bindings bindings,
               int scope)
        Associates a Bindings instance with a particular scope in this ScriptContext. Calls to the getAttribute and setAttribute methods must map to the get and put methods of the Bindings for the specified scope.
        参数：
        bindings - The Bindings to associate with the given scope
        scope - The scope
        抛出：
        IllegalArgumentException - If no Bindings is defined for the specified scope value in ScriptContexts of this type.
        NullPointerException - if value of scope is ENGINE_SCOPE and the specified Bindings is null.

      • getBindings

        Bindings getBindings(int scope)
        Gets the Bindings associated with the given scope in this ScriptContext.
        返回：
        The associated Bindings. Returns null if it has not been set.
        抛出：
        IllegalArgumentException - If no Bindings is defined for the specified scope value in ScriptContext of this type.

      • setAttribute

        void setAttribute(String name,
                Object value,
                int scope)
        Sets the value of an attribute in a given scope.
        参数：
        name - The name of the attribute to set
        value - The value of the attribute
        scope - The scope in which to set the attribute
        抛出：
        IllegalArgumentException - if the name is empty or if the scope is invalid.
        NullPointerException - if the name is null.

      • getAttribute

        Object getAttribute(String name,
                  int scope)
        Gets the value of an attribute in a given scope.
        参数：
        name - The name of the attribute to retrieve.
        scope - The scope in which to retrieve the attribute.
        返回：
        The value of the attribute. Returns null is the name does not exist in the given scope.
        抛出：
        IllegalArgumentException - if the name is empty or if the value of scope is invalid.
        NullPointerException - if the name is null.

      • removeAttribute

        Object removeAttribute(String name,
                     int scope)
        Remove an attribute in a given scope.
        参数：
        name - The name of the attribute to remove
        scope - The scope in which to remove the attribute
        返回：
        The removed value.
        抛出：
        IllegalArgumentException - if the name is empty or if the scope is invalid.
        NullPointerException - if the name is null.

      • getAttribute

        Object getAttribute(String name)
        Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order. The order is determined by the numeric value of the scope parameter (lowest scope values first.)
        参数：
        name - The name of the the attribute to retrieve.
        返回：
        The value of the attribute in the lowest scope for which an attribute with the given name is defined. Returns null if no attribute with the name exists in any scope.
        抛出：
        NullPointerException - if the name is null.
        IllegalArgumentException - if the name is empty.

      • getAttributesScope

        int getAttributesScope(String name)
        Get the lowest scope in which an attribute is defined.
        参数：
        name - Name of the attribute .
        返回：
        The lowest scope. Returns -1 if no attribute with the given name is defined in any scope.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • getWriter

        Writer getWriter()
        Returns the Writer for scripts to use when displaying output.
        返回：
        The Writer.

      • getErrorWriter

        Writer getErrorWriter()
        Returns the Writer used to display error output.
        返回：
        The Writer

      • setWriter

        void setWriter(Writer writer)
        Sets the Writer for scripts to use when displaying output.
        参数：
        writer - The new Writer.

      • setErrorWriter

        void setErrorWriter(Writer writer)
        Sets the Writer used to display error output.
        参数：
        writer - The Writer.

      • getReader

        Reader getReader()
        Returns a Reader to be used by the script to read input.
        返回：
        The Reader.

      • setReader

        void setReader(Reader reader)
        Sets the Reader for scripts to read input .
        参数：
        reader - The new Reader.

      • getScopes

        List<Integer> getScopes()
        Returns immutable List of all the valid values for scope in the ScriptContext.
        返回：
        list of scope values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s p/n/"/


ScriptEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface ScriptEngine

  • All Known Implementing Classes:
    AbstractScriptEngine

    public interface ScriptEngine
    ScriptEngine is the fundamental interface whose methods must be fully functional in every implementation of this specification.

    These methods provide basic scripting functionality. Applications written to this simple interface are expected to work with minimal modifications in every implementation. It includes methods that execute scripts, and ones that set and get values.

    The values are key/value pairs of two types. The first type of pairs consists of those whose keys are reserved and defined in this specification or by individual implementations. The values in the pairs with reserved keys have specified meanings.

    The other type of pairs consists of those that create Java language Bindings, the values are usually represented in scripts by the corresponding keys or by decorated forms of them.
    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ARGV
      Reserved key for a named value that passes an array of positional arguments to a script.
      static String ENGINE
      Reserved key for a named value that is the name of the ScriptEngine implementation.
      static String ENGINE_VERSION
      Reserved key for a named value that identifies the version of the ScriptEngine implementation.
      static String FILENAME
      Reserved key for a named value that is the name of the file being executed.
      static String LANGUAGE
      Reserved key for a named value that is the full name of Scripting Language supported by the implementation.
      static String LANGUAGE_VERSION
      Reserved key for the named value that identifies the version of the scripting language supported by the implementation.
      static String NAME
      Reserved key for a named value that identifies the short name of the scripting language.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Bindings createBindings()
      Returns an uninitialized Bindings.
      Object eval(Reader reader)
      Same as eval(String) except that the source of the script is provided as a Reader
      Object eval(Reader reader, Bindings n)
      Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
      Object eval(Reader reader, ScriptContext context)
      Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
      Object eval(String script)
      Executes the specified script.
      Object eval(String script, Bindings n)
      Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution.
      Object eval(String script, ScriptContext context)
      Causes the immediate execution of the script whose source is the String passed as the first argument.
      Object get(String key)
      Retrieves a value set in the state of this engine.
      Bindings getBindings(int scope)
      Returns a scope of named values.
      ScriptContext getContext()
      Returns the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.
      ScriptEngineFactory getFactory()
      Returns a ScriptEngineFactory for the class to which this ScriptEngine belongs.
      void put(String key, Object value)
      Sets a key/value pair in the state of the ScriptEngine that may either create a Java Language Binding to be used in the execution of scripts or be used in some other way, depending on whether the key is reserved.
      void setBindings(Bindings bindings, int scope)
      Sets a scope of named values to be used by scripts.
      void setContext(ScriptContext context)
      Sets the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.

    • 字段详细信息

      • ARGV

        static final String ARGV
        Reserved key for a named value that passes an array of positional arguments to a script.
        另请参见：
        Constant Field Values

      • FILENAME

        static final String FILENAME
        Reserved key for a named value that is the name of the file being executed.
        另请参见：
        Constant Field Values

      • ENGINE

        static final String ENGINE
        Reserved key for a named value that is the name of the ScriptEngine implementation.
        另请参见：
        Constant Field Values

      • ENGINE_VERSION

        static final String ENGINE_VERSION
        Reserved key for a named value that identifies the version of the ScriptEngine implementation.
        另请参见：
        Constant Field Values

      • NAME

        static final String NAME
        Reserved key for a named value that identifies the short name of the scripting language. The name is used by the ScriptEngineManager to locate a ScriptEngine with a given name in the getEngineByName method.
        另请参见：
        Constant Field Values

      • LANGUAGE

        static final String LANGUAGE
        Reserved key for a named value that is the full name of Scripting Language supported by the implementation.
        另请参见：
        Constant Field Values

      • LANGUAGE_VERSION

        static final String LANGUAGE_VERSION
        Reserved key for the named value that identifies the version of the scripting language supported by the implementation.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • eval

        Object eval(String script,
          ScriptContext context)
            throws ScriptException
        Causes the immediate execution of the script whose source is the String passed as the first argument. The script may be reparsed or recompiled before execution. State left in the engine from previous executions, including variable values and compiled procedures may be visible during this execution.
        参数：
        script - The script to be executed by the script engine.
        context - A ScriptContext exposing sets of attributes in different scopes. The meanings of the scopes ScriptContext.GLOBAL_SCOPE, and ScriptContext.ENGINE_SCOPE are defined in the specification.

        The ENGINE_SCOPE Bindings of the ScriptContext contains the bindings of scripting variables to application objects to be used during this script execution.
        返回：
        The value returned from the execution of the script.
        抛出：
        ScriptException - if an error occurrs in script. ScriptEngines should create and throw ScriptException wrappers for checked Exceptions thrown by underlying scripting implementations.
        NullPointerException - if either argument is null.

      • eval

        Object eval(Reader reader,
          ScriptContext context)
            throws ScriptException
        Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
        参数：
        reader - The source of the script to be executed by the script engine.
        context - The ScriptContext passed to the script engine.
        返回：
        The value returned from the execution of the script.
        抛出：
        ScriptException - if an error occurrs in script.
        NullPointerException - if either argument is null.

      • eval

        Object eval(String script)
            throws ScriptException
        Executes the specified script. The default ScriptContext for the ScriptEngine is used.
        参数：
        script - The script language source to be executed.
        返回：
        The value returned from the execution of the script.
        抛出：
        ScriptException - if error occurrs in script.
        NullPointerException - if the argument is null.

      • eval

        Object eval(Reader reader)
            throws ScriptException
        Same as eval(String) except that the source of the script is provided as a Reader
        参数：
        reader - The source of the script.
        返回：
        The value returned by the script.
        抛出：
        ScriptException - if an error occurrs in script.
        NullPointerException - if the argument is null.

      • eval

        Object eval(String script,
          Bindings n)
            throws ScriptException
        Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution. The Reader, Writer and non-ENGINE_SCOPE Bindings of the default ScriptContext are used. The ENGINE_SCOPE Bindings of the ScriptEngine is not changed, and its mappings are unaltered by the script execution.
        参数：
        script - The source for the script.
        上一个 - The Bindings of attributes to be used for script execution.
        返回：
        The value returned by the script.
        抛出：
        ScriptException - if an error occurrs in script.
        NullPointerException - if either argument is null.

      • eval

        Object eval(Reader reader,
          Bindings n)
            throws ScriptException
        Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
        参数：
        reader - The source of the script.
        上一个 - The Bindings of attributes.
        返回：
        The value returned by the script.
        抛出：
        ScriptException - if an error occurrs.
        NullPointerException - if either argument is null.

      • put

        void put(String key,
       Object value)
        Sets a key/value pair in the state of the ScriptEngine that may either create a Java Language Binding to be used in the execution of scripts or be used in some other way, depending on whether the key is reserved. Must have the same effect as getBindings(ScriptContext.ENGINE_SCOPE).put.
        参数：
        key - The name of named value to add
        value - The value of named value to add.
        抛出：
        NullPointerException - if key is null.
        IllegalArgumentException - if key is empty.

      • get

        Object get(String key)
        Retrieves a value set in the state of this engine. The value might be one which was set using setValue or some other value in the state of the ScriptEngine, depending on the implementation. Must have the same effect as getBindings(ScriptContext.ENGINE_SCOPE).get
        参数：
        key - The key whose value is to be returned
        返回：
        the value for the given key
        抛出：
        NullPointerException - if key is null.
        IllegalArgumentException - if key is empty.

      • getBindings

        Bindings getBindings(int scope)
        Returns a scope of named values. The possible scopes are:

        • ScriptContext.GLOBAL_SCOPE - The set of named values representing global scope. If this ScriptEngine is created by a ScriptEngineManager, then the manager sets global scope bindings. This may be null if no global scope is associated with this ScriptEngine
        • ScriptContext.ENGINE_SCOPE - The set of named values representing the state of this ScriptEngine. The values are generally visible in scripts using the associated keys as variable names.
        • Any other value of scope defined in the default ScriptContext of the ScriptEngine.

        The Bindings instances that are returned must be identical to those returned by the getBindings method of ScriptContext called with corresponding arguments on the default ScriptContext of the ScriptEngine.
        参数：
        scope - Either ScriptContext.ENGINE_SCOPE or ScriptContext.GLOBAL_SCOPE which specifies the Bindings to return. Implementations of ScriptContext may define additional scopes. If the default ScriptContext of the ScriptEngine defines additional scopes, any of them can be passed to get the corresponding Bindings.
        返回：
        The Bindings with the specified scope.
        抛出：
        IllegalArgumentException - if specified scope is invalid

      • setBindings

        void setBindings(Bindings bindings,
               int scope)
        Sets a scope of named values to be used by scripts. The possible scopes are:

        • ScriptContext.ENGINE_SCOPE - The specified Bindings replaces the engine scope of the ScriptEngine.
        • ScriptContext.GLOBAL_SCOPE - The specified Bindings must be visible as the GLOBAL_SCOPE.
        • Any other value of scope defined in the default ScriptContext of the ScriptEngine.

        The method must have the same effect as calling the setBindings method of ScriptContext with the corresponding value of scope on the default ScriptContext of the ScriptEngine.
        参数：
        bindings - The Bindings for the specified scope.
        scope - The specified scope. Either ScriptContext.ENGINE_SCOPE, ScriptContext.GLOBAL_SCOPE, or any other valid value of scope.
        抛出：
        IllegalArgumentException - if the scope is invalid
        NullPointerException - if the bindings is null and the scope is ScriptContext.ENGINE_SCOPE

      • createBindings

        Bindings createBindings()
        Returns an uninitialized Bindings.
        返回：
        A Bindings that can be used to replace the state of this ScriptEngine.

      • getContext

        ScriptContext getContext()
        Returns the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.
        返回：
        The default ScriptContext of the ScriptEngine.

      • setContext

        void setContext(ScriptContext context)
        Sets the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.
        参数：
        context - A ScriptContext that will replace the default ScriptContext in the ScriptEngine.
        抛出：
        NullPointerException - if context is null.

      • getFactory

        ScriptEngineFactory getFactory()
        Returns a ScriptEngineFactory for the class to which this ScriptEngine belongs.
        返回：
        The ScriptEngineFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


ScriptEngineFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.script

Interface ScriptEngineFactory

  • public interface ScriptEngineFactory
    ScriptEngineFactory is used to describe and instantiate ScriptEngines.

    Each class implementing ScriptEngine has a corresponding factory that exposes metadata describing the engine class.

    The ScriptEngineManager uses the service provider mechanism described in the Jar File Specification to obtain instances of all ScriptEngineFactories available in the current ClassLoader.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getEngineName()
      Returns the full name of the ScriptEngine.
      String getEngineVersion()
      Returns the version of the ScriptEngine.
      List<String> getExtensions()
      Returns an immutable list of filename extensions, which generally identify scripts written in the language supported by this ScriptEngine.
      String getLanguageName()
      Returns the name of the scripting langauge supported by this ScriptEngine.
      String getLanguageVersion()
      Returns the version of the scripting language supported by this ScriptEngine.
      String getMethodCallSyntax(String obj, String m, String... args)
      Returns a String which can be used to invoke a method of a Java object using the syntax of the supported scripting language.
      List<String> getMimeTypes()
      Returns an immutable list of mimetypes, associated with scripts that can be executed by the engine.
      List<String> getNames()
      Returns an immutable list of short names for the ScriptEngine, which may be used to identify the ScriptEngine by the ScriptEngineManager.
      String getOutputStatement(String toDisplay)
      Returns a String that can be used as a statement to display the specified String using the syntax of the supported scripting language.
      Object getParameter(String key)
      Returns the value of an attribute whose meaning may be implementation-specific.
      String getProgram(String... statements)
      Returns A valid scripting language executable progam with given statements.
      ScriptEngine getScriptEngine()
      Returns an instance of the ScriptEngine associated with this ScriptEngineFactory.

    • 方法详细信息

      • getEngineName

        String getEngineName()
        Returns the full name of the ScriptEngine. For instance an implementation based on the Mozilla Rhino Javascript engine might return Rhino Mozilla Javascript Engine.
        返回：
        The name of the engine implementation.

      • getEngineVersion

        String getEngineVersion()
        Returns the version of the ScriptEngine.
        返回：
        The ScriptEngine implementation version.

      • getExtensions

        List<String> getExtensions()
        Returns an immutable list of filename extensions, which generally identify scripts written in the language supported by this ScriptEngine. The array is used by the ScriptEngineManager to implement its getEngineByExtension method.
        返回：
        The list of extensions.

      • getMimeTypes

        List<String> getMimeTypes()
        Returns an immutable list of mimetypes, associated with scripts that can be executed by the engine. The list is used by the ScriptEngineManager class to implement its getEngineByMimetype method.
        返回：
        The list of mime types.

      • getNames

        List<String> getNames()
        Returns an immutable list of short names for the ScriptEngine, which may be used to identify the ScriptEngine by the ScriptEngineManager. For instance, an implementation based on the Mozilla Rhino Javascript engine might return list containing {"javascript", "rhino"}.

      • getLanguageName

        String getLanguageName()
        Returns the name of the scripting langauge supported by this ScriptEngine.
        返回：
        The name of the supported language.

      • getLanguageVersion

        String getLanguageVersion()
        Returns the version of the scripting language supported by this ScriptEngine.
        返回：
        The version of the supported language.

      • getParameter

        Object getParameter(String key)
        Returns the value of an attribute whose meaning may be implementation-specific. Keys for which the value is defined in all implementations are:
        • ScriptEngine.ENGINE
        • ScriptEngine.ENGINE_VERSION
        • ScriptEngine.NAME
        • ScriptEngine.LANGUAGE
        • ScriptEngine.LANGUAGE_VERSION

        The values for these keys are the Strings returned by getEngineName, getEngineVersion, getName, getLanguageName and getLanguageVersion respectively.

        A reserved key, THREADING, whose value describes the behavior of the engine with respect to concurrent execution of scripts and maintenance of state is also defined. These values for the THREADING key are:

        • null - The engine implementation is not thread safe, and cannot be used to execute scripts concurrently on multiple threads.
        • "MULTITHREADED" - The engine implementation is internally thread-safe and scripts may execute concurrently although effects of script execution on one thread may be visible to scripts on other threads.
        • "THREAD-ISOLATED" - The implementation satisfies the requirements of "MULTITHREADED", and also, the engine maintains independent values for symbols in scripts executing on different threads.
        • "STATELESS" - The implementation satisfies the requirements of
        • "THREAD-ISOLATED". In addition, script executions do not alter the mappings in the Bindings which is the engine scope of the ScriptEngine. In particular, the keys in the Bindings and their associated values are the same before and after the execution of the script.

        Implementations may define implementation-specific keys.
        参数：
        key - The name of the parameter
        返回：
        The value for the given parameter. Returns null if no value is assigned to the key.

      • getMethodCallSyntax

        String getMethodCallSyntax(String obj,
                         String m,
                         String... args)
        Returns a String which can be used to invoke a method of a Java object using the syntax of the supported scripting language. For instance, an implementaton for a Javascript engine might be;

 public String getMethodCallSyntax(String obj,
                                   String m, String... args) {
      String ret = obj;
      ret += "." + m + "(";
      for (int i = 0; i < args.length; i++) {
          ret += args[i];
          if (i < args.length - 1) {
              ret += ",";
          }
      }
      ret += ")";
      return ret;
 }

        参数：
        obj - The name representing the object whose method is to be invoked. The name is the one used to create bindings using the put method of ScriptEngine, the put method of an ENGINE_SCOPE Bindings,or the setAttribute method of ScriptContext. The identifier used in scripts may be a decorated form of the specified one.
        m - The name of the method to invoke.
        args - names of the arguments in the method call.
        返回：
        The String used to invoke the method in the syntax of the scripting language.

      • getOutputStatement

        String getOutputStatement(String toDisplay)
        Returns a String that can be used as a statement to display the specified String using the syntax of the supported scripting language. For instance, the implementaton for a Perl engine might be;

 public String getOutputStatement(String toDisplay) {
      return "print(" + toDisplay + ")";
 }
        参数：
        toDisplay - The String to be displayed by the returned statement.
        返回：
        The string used to display the String in the syntax of the scripting language.

      • getProgram

        String getProgram(String... statements)
        Returns A valid scripting language executable progam with given statements. For instance an implementation for a PHP engine might be:

 public String getProgram(String... statements) {
      $retval = "<?\n";
      int len = statements.length;
      for (int i = 0; i < len; i++) {
          $retval += statements[i] + ";\n";
      }
      $retval += "?>";

 }
        参数：
        statements - The statements to be executed. May be return values of calls to the getMethodCallSyntax and getOutputStatement methods.
        返回：
        The Program

      • getScriptEngine

        ScriptEngine getScriptEngine()
        Returns an instance of the ScriptEngine associated with this ScriptEngineFactory. A new ScriptEngine is generally returned, but implementations may pool, share or reuse engines.
        返回：
        A new ScriptEngine instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


ScriptEngineManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 ScriptEngineManager

  • java.lang.Object
    • javax.script.ScriptEngineManager

  • public class ScriptEngineManager
extends Object
    The ScriptEngineManager implements a discovery and instantiation mechanism for ScriptEngine classes and also maintains a collection of key/value pairs storing state shared by all engines created by the Manager. This class uses the service provider mechanism to enumerate all the implementations of ScriptEngineFactory.

    The ScriptEngineManager provides a method to return an array of all these factories as well as utility methods which look up factories on the basis of language name, file extension and mime type.

    The Bindings of key/value pairs, referred to as the "Global Scope" maintained by the manager is available to all instances of ScriptEngine created by the ScriptEngineManager. The values in the Bindings are generally exposed in all scripts.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScriptEngineManager()
      If the thread context ClassLoader can be accessed by the caller, then the effect of calling this constructor is the same as calling ScriptEngineManager(Thread.currentThread().getContextClassLoader()).
      ScriptEngineManager(ClassLoader loader)
      This constructor loads the implementations of ScriptEngineFactory visible to the given ClassLoader using the service provider mechanism.

      If loader is null, the script engine factories that are bundled with the platform and that are in the usual extension directories (installed extensions) are loaded.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object get(String key)
      Gets the value for the specified key in the Global Scope
      Bindings getBindings()
      getBindings returns the value of the globalScope field.
      ScriptEngine getEngineByExtension(String extension)
      Look up and create a ScriptEngine for a given extension.
      ScriptEngine getEngineByMimeType(String mimeType)
      Look up and create a ScriptEngine for a given mime type.
      ScriptEngine getEngineByName(String shortName)
      Looks up and creates a ScriptEngine for a given name.
      List<ScriptEngineFactory> getEngineFactories()
      Returns an array whose elements are instances of all the ScriptEngineFactory classes found by the discovery mechanism.
      void put(String key, Object value)
      Sets the specified key/value pair in the Global Scope.
      void registerEngineExtension(String extension, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle an extension.
      void registerEngineMimeType(String type, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle a mime type.
      void registerEngineName(String name, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle a language name.
      void setBindings(Bindings bindings)
      setBindings stores the specified Bindings in the globalScope field.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ScriptEngineManager

        public ScriptEngineManager()
        If the thread context ClassLoader can be accessed by the caller, then the effect of calling this constructor is the same as calling ScriptEngineManager(Thread.currentThread().getContextClassLoader()). Otherwise, the effect is the same as calling ScriptEngineManager(null).
        另请参见：
        Thread.getContextClassLoader()

      • ScriptEngineManager

        public ScriptEngineManager(ClassLoader loader)
        This constructor loads the implementations of ScriptEngineFactory visible to the given ClassLoader using the service provider mechanism.

        If loader is null, the script engine factories that are bundled with the platform and that are in the usual extension directories (installed extensions) are loaded.

        参数：
        loader - ClassLoader used to discover script engine factories.

    • 方法详细信息

      • setBindings

        public void setBindings(Bindings bindings)
        setBindings stores the specified Bindings in the globalScope field. ScriptEngineManager sets this Bindings as global bindings for ScriptEngine objects created by it.
        参数：
        bindings - The specified Bindings
        抛出：
        IllegalArgumentException - if bindings is null.

      • getBindings

        public Bindings getBindings()
        getBindings returns the value of the globalScope field. ScriptEngineManager sets this Bindings as global bindings for ScriptEngine objects created by it.
        返回：
        The globalScope field.

      • put

        public void put(String key,
       Object value)
        Sets the specified key/value pair in the Global Scope.
        参数：
        key - Key to set
        value - Value to set.
        抛出：
        NullPointerException - if key is null.
        IllegalArgumentException - if key is empty string.

      • get

        public Object get(String key)
        Gets the value for the specified key in the Global Scope
        参数：
        key - The key whose value is to be returned.
        返回：
        The value for the specified key.

      • getEngineByName

        public ScriptEngine getEngineByName(String shortName)
        Looks up and creates a ScriptEngine for a given name. The algorithm first searches for a ScriptEngineFactory that has been registered as a handler for the specified name using the registerEngineName method.

        If one is not found, it searches the array of ScriptEngineFactory instances stored by the constructor for one with the specified name. If a ScriptEngineFactory is found by either method, it is used to create instance of ScriptEngine.
        参数：
        shortName - The short name of the ScriptEngine implementation. returned by the getNames method of its ScriptEngineFactory.
        返回：
        A ScriptEngine created by the factory located in the search. Returns null if no such factory was found. The ScriptEngineManager sets its own globalScope Bindings as the GLOBAL_SCOPE Bindings of the newly created ScriptEngine.
        抛出：
        NullPointerException - if shortName is null.

      • getEngineByExtension

        public ScriptEngine getEngineByExtension(String extension)
        Look up and create a ScriptEngine for a given extension. The algorithm used by getEngineByName is used except that the search starts by looking for a ScriptEngineFactory registered to handle the given extension using registerEngineExtension.
        参数：
        extension - The given extension
        返回：
        The engine to handle scripts with this extension. Returns null if not found.
        抛出：
        NullPointerException - if extension is null.

      • getEngineByMimeType

        public ScriptEngine getEngineByMimeType(String mimeType)
        Look up and create a ScriptEngine for a given mime type. The algorithm used by getEngineByName is used except that the search starts by looking for a ScriptEngineFactory registered to handle the given mime type using registerEngineMimeType.
        参数：
        mimeType - The given mime type
        返回：
        The engine to handle scripts with this mime type. Returns null if not found.
        抛出：
        NullPointerException - if mimeType is null.

      • getEngineFactories

        public List<ScriptEngineFactory> getEngineFactories()
        Returns an array whose elements are instances of all the ScriptEngineFactory classes found by the discovery mechanism.
        返回：
        List of all discovered ScriptEngineFactorys.

      • registerEngineName

        public void registerEngineName(String name,
                      ScriptEngineFactory factory)
        Registers a ScriptEngineFactory to handle a language name. Overrides any such association found using the Discovery mechanism.
        参数：
        name - The name to be associated with the ScriptEngineFactory.
        factory - The class to associate with the given name.
        抛出：
        NullPointerException - if any of the parameters is null.

      • registerEngineMimeType

        public void registerEngineMimeType(String type,
                          ScriptEngineFactory factory)
        Registers a ScriptEngineFactory to handle a mime type. Overrides any such association found using the Discovery mechanism.
        参数：
        type - The mime type to be associated with the ScriptEngineFactory.
        factory - The class to associate with the given mime type.
        抛出：
        NullPointerException - if any of the parameters is null.

      • registerEngineExtension

        public void registerEngineExtension(String extension,
                           ScriptEngineFactory factory)
        Registers a ScriptEngineFactory to handle an extension. Overrides any such association found using the Discovery mechanism.
        参数：
        extension - The extension type to be associated with the ScriptEngineFactory.
        factory - The class to associate with the given extension.
        抛出：
        NullPointerException - if any of the parameters is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

E0abJ|訪J&io hE.:odi�<� >岸.纍 >v


ScriptException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 ScriptException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.script.ScriptException
  • 所有已实现的接口：
    Serializable

    public class ScriptException
extends Exception
    The generic Exception class for the Scripting APIs. Checked exception types thrown by underlying scripting implementations must be wrapped in instances of ScriptException. The class has members to store line and column numbers and filenames if this information is available.
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScriptException(Exception e)
      Creates a ScriptException wrapping an Exception thrown by an underlying interpreter.
      ScriptException(String s)
      Creates a ScriptException with a String to be used in its message.
      ScriptException(String message, String fileName, int lineNumber)
      Creates a ScriptException with message, filename and linenumber to be used in error messages.
      ScriptException(String message, String fileName, int lineNumber, int columnNumber)
      ScriptException constructor specifying message, filename, line number and column number.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Get the column number on which an error occurred.
      String getFileName()
      Get the source of the script causing the error.
      int getLineNumber()
      Get the line number on which an error occurred.
      String getMessage()
      Returns a message containing the String passed to a constructor as well as line and column numbers and filename if any of these are known.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ScriptException

        public ScriptException(String s)
        Creates a ScriptException with a String to be used in its message. Filename, and line and column numbers are unspecified.
        参数：
        s - The String to use in the message.

      • ScriptException

        public ScriptException(Exception e)
        Creates a ScriptException wrapping an Exception thrown by an underlying interpreter. Line and column numbers and filename are unspecified.
        参数：
        e - The wrapped Exception.

      • ScriptException

        public ScriptException(String message,
               String fileName,
               int lineNumber)
        Creates a ScriptException with message, filename and linenumber to be used in error messages.
        参数：
        message - The string to use in the message
        fileName - The file or resource name describing the location of a script error causing the ScriptException to be thrown.
        lineNumber - A line number describing the location of a script error causing the ScriptException to be thrown.

      • ScriptException

        public ScriptException(String message,
               String fileName,
               int lineNumber,
               int columnNumber)
        ScriptException constructor specifying message, filename, line number and column number.
        参数：
        message - The message.
        fileName - The filename
        lineNumber - the line number.
        columnNumber - the column number.

    • 方法详细信息

      • getMessage

        public String getMessage()
        Returns a message containing the String passed to a constructor as well as line and column numbers and filename if any of these are known.
        重载：
        getMessage in class Throwable
        返回：
        The error message.

      • getLineNumber

        public int getLineNumber()
        Get the line number on which an error occurred.
        返回：
        The line number. Returns -1 if a line number is unavailable.

      • getColumnNumber

        public int getColumnNumber()
        Get the column number on which an error occurred.
        返回：
        The column number. Returns -1 if a column number is unavailable.

      • getFileName

        public String getFileName()
        Get the source of the script causing the error.
        返回：
        The file name of the script or some other string describing the script source. May return some implementation-defined string such as <unknown> if a description of the source is unavailable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> NEgsngsittsiiet nioEtccFina/ccFFhrSadcs


SimpleBindings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 SimpleBindings

  • java.lang.Object
    • javax.script.SimpleBindings
  • 所有已实现的接口：
    Map<String,Object>, Bindings

    public class SimpleBindings
extends Object
implements Bindings
    A simple implementation of Bindings backed by a HashMap or some other specified Map.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 构造方法摘要

      Constructors
      构造方法与描述
      SimpleBindings()
      Default constructor uses a HashMap.
      SimpleBindings(Map<String,Object> m)
      Constructor uses an existing Map to store the values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void clear()
      Removes all of the mappings from this map (optional operation).
      boolean containsKey(Object key)
      Returns true if this map contains a mapping for the specified key.
      boolean containsValue(Object value)
      Returns true if this map maps one or more keys to the specified value.
      Set<Map.Entry<String,Object>> entrySet()
      Returns a Set view of the mappings contained in this map.
      Object get(Object key)
      Returns the value to which this map maps the specified key.
      boolean isEmpty()
      Returns true if this map contains no key-value mappings.
      Set<String> keySet()
      Returns a Set view of the keys contained in this map.
      Object put(String name, Object value)
      Sets the specified key/value in the underlying map field.
      void putAll(Map<? extends String,? extends Object> toMerge)
      putAll is implemented using Map.putAll.
      Object remove(Object key)
      Removes the mapping for this key from this map if it is present (optional operation).
      int size()
      Returns the number of key-value mappings in this map.
      Collection<Object> values()
      Returns a Collection view of the values contained in this map.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.util.Map

        equals, hashCode

    • 构造方法详细信息

      • SimpleBindings

        public SimpleBindings(Map<String,Object> m)
        Constructor uses an existing Map to store the values.
        参数：
        m - The Map backing this SimpleBindings.
        抛出：
        NullPointerException - if m is null

      • SimpleBindings

        public SimpleBindings()
        Default constructor uses a HashMap.

    • 方法详细信息

      • put

        public Object put(String name,
         Object value)
        Sets the specified key/value in the underlying map field.
        指定者：
        put in interface Map<String,Object>
        指定者：
        put in interface Bindings
        参数：
        name - Name of value
        value - Value to set.
        返回：
        Previous value for the specified key. Returns null if key was previously unset.
        抛出：
        NullPointerException - if the name is null.
        IllegalArgumentException - if the name is empty.

      • putAll

        public void putAll(Map<? extends String,? extends Object> toMerge)
        putAll is implemented using Map.putAll.
        指定者：
        putAll in interface Map<String,Object>
        指定者：
        putAll in interface Bindings
        参数：
        toMerge - The Map of values to add.
        抛出：
        NullPointerException - if toMerge map is null or if some key in the map is null.
        IllegalArgumentException - if some key in the map is an empty String.

      • clear

        public void clear()
        Removes all of the mappings from this map (optional operation). The map will be empty after this call returns.
        指定者：
        clear in interface Map<String,Object>

      • containsKey

        public boolean containsKey(Object key)
        Returns true if this map contains a mapping for the specified key. More formally, returns true if and only if this map contains a mapping for a key k such that (key==null ? k==null : key.equals(k)). (There can be at most one such mapping.)
        指定者：
        containsKey in interface Map<String,Object>
        指定者：
        containsKey in interface Bindings
        参数：
        key - key whose presence in this map is to be tested.
        返回：
        true if this map contains a mapping for the specified key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String

      • containsValue

        public boolean containsValue(Object value)
        Returns true if this map maps one or more keys to the specified value. More formally, returns true if and only if this map contains at least one mapping to a value v such that (value==null ? v==null : value.equals(v)). This operation will probably require time linear in the map size for most implementations of the Map interface.
        指定者：
        containsValue in interface Map<String,Object>
        参数：
        value - value whose presence in this map is to be tested
        返回：
        true if this map maps one or more keys to the specified value

      • entrySet

        public Set<Map.Entry<String,Object>> entrySet()
        Returns a Set view of the mappings contained in this map. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress (except through the iterator's own remove operation, or through the setValue operation on a map entry returned by the iterator) the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.
        指定者：
        entrySet in interface Map<String,Object>
        返回：
        a set view of the mappings contained in this map

      • get

        public Object get(Object key)
        Returns the value to which this map maps the specified key. Returns null if the map contains no mapping for this key. A return value of null does not necessarily indicate that the map contains no mapping for the key; it's also possible that the map explicitly maps the key to null. The containsKey operation may be used to distinguish these two cases.

        More formally, if this map contains a mapping from a key k to a value v such that (key==null ? k==null : key.equals(k)), then this method returns v; otherwise it returns null. (There can be at most one such mapping.)

        指定者：
        get in interface Map<String,Object>
        指定者：
        get in interface Bindings
        参数：
        key - key whose associated value is to be returned.
        返回：
        the value to which this map maps the specified key, or null if the map contains no mapping for this key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String

      • isEmpty

        public boolean isEmpty()
        Returns true if this map contains no key-value mappings.
        指定者：
        isEmpty in interface Map<String,Object>
        返回：
        true if this map contains no key-value mappings

      • keySet

        public Set<String> keySet()
        Returns a Set view of the keys contained in this map. The set is backed by the map, so changes to the map are reflected in the set, and vice-versa. If the map is modified while an iteration over the set is in progress (except through the iterator's own remove operation), the results of the iteration are undefined. The set supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Set.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations.
        指定者：
        keySet in interface Map<String,Object>
        返回：
        a set view of the keys contained in this map

      • remove

        public Object remove(Object key)
        Removes the mapping for this key from this map if it is present (optional operation). More formally, if this map contains a mapping from key k to value v such that (key==null ? k==null : key.equals(k)), that mapping is removed. (The map can contain at most one such mapping.)

        Returns the value to which the map previously associated the key, or null if the map contained no mapping for this key. (A null return can also indicate that the map previously associated null with the specified key if the implementation supports null values.) The map will not contain a mapping for the specified key once the call returns.

        指定者：
        remove in interface Map<String,Object>
        指定者：
        remove in interface Bindings
        参数：
        key - key whose mapping is to be removed from the map.
        返回：
        previous value associated with specified key, or null if there was no mapping for key.
        抛出：
        NullPointerException - if key is null
        ClassCastException - if key is not String
        IllegalArgumentException - if key is empty String

      • size

        public int size()
        Returns the number of key-value mappings in this map. If the map contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
        指定者：
        size in interface Map<String,Object>
        返回：
        the number of key-value mappings in this map

      • values

        public Collection<Object> values()
        Returns a Collection view of the values contained in this map. The collection is backed by the map, so changes to the map are reflected in the collection, and vice-versa. If the map is modified while an iteration over the collection is in progress (except through the iterator's own remove operation), the results of the iteration are undefined. The collection supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Collection.remove, removeAll, retainAll and clear operations. It does not support the add or addAll operations.
        指定者：
        values in interface Map<String,Object>
        返回：
        a collection view of the values contained in this map
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n


SimpleScriptContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.script

类 SimpleScriptContext

  • java.lang.Object
    • javax.script.SimpleScriptContext
  • 所有已实现的接口：
    ScriptContext

    public class SimpleScriptContext
extends Object
implements ScriptContext
    Simple implementation of ScriptContext.
    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Bindings engineScope
      This is the engine scope bindings.
      protected Writer errorWriter
      This is the writer to be used to output errors from scripts.
      protected Bindings globalScope
      This is the global scope bindings.
      protected Reader reader
      This is the reader to be used for input from scripts.
      protected Writer writer
      This is the writer to be used to output from scripts.

      • 字段 - 继承于接口 javax.script.ScriptContext

        ENGINE_SCOPE, GLOBAL_SCOPE

    • 构造方法摘要

      Constructors
      构造方法与描述
      SimpleScriptContext()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getAttribute(String name)
      Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.
      Object getAttribute(String name, int scope)
      Gets the value of an attribute in a given scope.
      int getAttributesScope(String name)
      Get the lowest scope in which an attribute is defined.
      Bindings getBindings(int scope)
      Returns the value of the engineScope field if specified scope is ENGINE_SCOPE.
      Writer getErrorWriter()
      Returns the Writer used to display error output.
      Reader getReader()
      Returns a Reader to be used by the script to read input.
      List<Integer> getScopes()
      Returns immutable List of all the valid values for scope in the ScriptContext.
      Writer getWriter()
      Returns the Writer for scripts to use when displaying output.
      Object removeAttribute(String name, int scope)
      Remove an attribute in a given scope.
      void setAttribute(String name, Object value, int scope)
      Sets the value of an attribute in a given scope.
      void setBindings(Bindings bindings, int scope)
      Sets a Bindings of attributes for the given scope.
      void setErrorWriter(Writer writer)
      Sets the Writer used to display error output.
      void setReader(Reader reader)
      Sets the Reader for scripts to read input .
      void setWriter(Writer writer)
      Sets the Writer for scripts to use when displaying output.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • writer

        protected Writer writer
        This is the writer to be used to output from scripts. By default, a PrintWriter based on System.out is used. Accessor methods getWriter, setWriter are used to manage this field.
        另请参见：
        System.out, PrintWriter

      • errorWriter

        protected Writer errorWriter
        This is the writer to be used to output errors from scripts. By default, a PrintWriter based on System.err is used. Accessor methods getErrorWriter, setErrorWriter are used to manage this field.
        另请参见：
        System.err, PrintWriter

      • reader

        protected Reader reader
        This is the reader to be used for input from scripts. By default, a InputStreamReader based on System.in is used and default charset is used by this reader. Accessor methods getReader, setReader are used to manage this field.
        另请参见：
        System.in, InputStreamReader

      • engineScope

        protected Bindings engineScope
        This is the engine scope bindings. By default, a SimpleBindings is used. Accessor methods setBindings, getBindings are used to manage this field.
        另请参见：
        SimpleBindings

      • globalScope

        protected Bindings globalScope
        This is the global scope bindings. By default, a null value (which means no global scope) is used. Accessor methods setBindings, getBindings are used to manage this field.

    • 构造方法详细信息

      • SimpleScriptContext

        public SimpleScriptContext()

    • 方法详细信息

      • setBindings

        public void setBindings(Bindings bindings,
               int scope)
        Sets a Bindings of attributes for the given scope. If the value of scope is ENGINE_SCOPE the given Bindings replaces the engineScope field. If the value of scope is GLOBAL_SCOPE the given Bindings replaces the globalScope field.
        指定者：
        setBindings in interface ScriptContext
        参数：
        bindings - The Bindings of attributes to set.
        scope - The value of the scope in which the attributes are set.
        抛出：
        IllegalArgumentException - if scope is invalid.
        NullPointerException - if the value of scope is ENGINE_SCOPE and the specified Bindings is null.

      • getAttribute

        public Object getAttribute(String name)
        Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order. The order is determined by the numeric value of the scope parameter (lowest scope values first.)
        指定者：
        getAttribute in interface ScriptContext
        参数：
        name - The name of the the attribute to retrieve.
        返回：
        The value of the attribute in the lowest scope for which an attribute with the given name is defined. Returns null if no attribute with the name exists in any scope.
        抛出：
        NullPointerException - if the name is null.
        IllegalArgumentException - if the name is empty.

      • getAttribute

        public Object getAttribute(String name,
                  int scope)
        Gets the value of an attribute in a given scope.
        指定者：
        getAttribute in interface ScriptContext
        参数：
        name - The name of the attribute to retrieve.
        scope - The scope in which to retrieve the attribute.
        返回：
        The value of the attribute. Returns null is the name does not exist in the given scope.
        抛出：
        IllegalArgumentException - if the name is empty or if the value of scope is invalid.
        NullPointerException - if the name is null.

      • removeAttribute

        public Object removeAttribute(String name,
                     int scope)
        Remove an attribute in a given scope.
        指定者：
        removeAttribute in interface ScriptContext
        参数：
        name - The name of the attribute to remove
        scope - The scope in which to remove the attribute
        返回：
        The removed value.
        抛出：
        IllegalArgumentException - if the name is empty or if the scope is invalid.
        NullPointerException - if the name is null.

      • setAttribute

        public void setAttribute(String name,
                Object value,
                int scope)
        Sets the value of an attribute in a given scope.
        指定者：
        setAttribute in interface ScriptContext
        参数：
        name - The name of the attribute to set
        value - The value of the attribute
        scope - The scope in which to set the attribute
        抛出：
        IllegalArgumentException - if the name is empty or if the scope is invalid.
        NullPointerException - if the name is null.

      • getWriter

        public Writer getWriter()
        Returns the Writer for scripts to use when displaying output.
        指定者：
        getWriter in interface ScriptContext
        返回：
        The Writer.

      • getReader

        public Reader getReader()
        Returns a Reader to be used by the script to read input.
        指定者：
        getReader in interface ScriptContext
        返回：
        The Reader.

      • setReader

        public void setReader(Reader reader)
        Sets the Reader for scripts to read input .
        指定者：
        setReader in interface ScriptContext
        参数：
        reader - The new Reader.

      • setWriter

        public void setWriter(Writer writer)
        Sets the Writer for scripts to use when displaying output.
        指定者：
        setWriter in interface ScriptContext
        参数：
        writer - The new Writer.

      • getErrorWriter

        public Writer getErrorWriter()
        Returns the Writer used to display error output.
        指定者：
        getErrorWriter in interface ScriptContext
        返回：
        The Writer

      • setErrorWriter

        public void setErrorWriter(Writer writer)
        Sets the Writer used to display error output.
        指定者：
        setErrorWriter in interface ScriptContext
        参数：
        writer - The Writer.

      • getAttributesScope

        public int getAttributesScope(String name)
        Get the lowest scope in which an attribute is defined.
        指定者：
        getAttributesScope in interface ScriptContext
        参数：
        name - Name of the attribute .
        返回：
        The lowest scope. Returns -1 if no attribute with the given name is defined in any scope.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • getBindings

        public Bindings getBindings(int scope)
        Returns the value of the engineScope field if specified scope is ENGINE_SCOPE. Returns the value of the globalScope field if the specified scope is GLOBAL_SCOPE.
        指定者：
        getBindings in interface ScriptContext
        参数：
        scope - The specified scope
        返回：
        The value of either the engineScope or globalScope field.
        抛出：
        IllegalArgumentException - if the value of scope is invalid.

      • getScopes

        public List<Integer> getScopes()
        Returns immutable List of all the valid values for scope in the ScriptContext.
        指定者：
        getScopes in interface ScriptContext
        返回：
        list of scope values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sahcE


Uses of Package javax.script

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.script

  • Packages that use javax.script
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.
  • Classes in javax.script used by javax.script
    类与描述
    Bindings
    A mapping of key/value pairs, all of whose keys are Strings.
    CompiledScript
    Extended by classes that store results of compilations.
    ScriptContext
    The interface whose implementing classes are used to connect Script Engines with objects, such as scoped Bindings, in hosting applications.
    ScriptEngine
    ScriptEngine is the fundamental interface whose methods must be fully functional in every implementation of this specification.
    ScriptEngineFactory
    ScriptEngineFactory is used to describe and instantiate ScriptEngines.
    ScriptException
    The generic Exception class for the Scripting APIs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ae -is"s z=1z


Uses of Class javax.script.AbstractScriptEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.AbstractScriptEngine

No usage of javax.script.AbstractScriptEngine
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i U


Uses of Class javax.script.CompiledScript

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.CompiledScript

  • Packages that use CompiledScript
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of CompiledScript in javax.script

      Methods in javax.script that return CompiledScript
      修饰符与类型 方法与描述
      CompiledScript Compilable.compile(Reader script)
      Compiles the script (source read from Reader) for later execution.
      CompiledScript Compilable.compile(String script)
      Compiles the script (source represented as a String) for later execution.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hdaatkg&tep"cm(/nBsohc


Uses of Class javax.script.ScriptEngineManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.ScriptEngineManager

No usage of javax.script.ScriptEngineManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

txya/a>irppp.l--


Uses of Class javax.script.ScriptException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.ScriptException

  • Packages that use ScriptException
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of ScriptException in javax.script

      Methods in javax.script that throw ScriptException
      修饰符与类型 方法与描述
      CompiledScript Compilable.compile(Reader script)
      Compiles the script (source read from Reader) for later execution.
      CompiledScript Compilable.compile(String script)
      Compiles the script (source represented as a String) for later execution.
      Object CompiledScript.eval()
      Executes the program stored in the CompiledScript object.
      Object CompiledScript.eval(Bindings bindings)
      Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution.
      Object ScriptEngine.eval(Reader reader)
      Same as eval(String) except that the source of the script is provided as a Reader
      Object AbstractScriptEngine.eval(Reader reader)
      eval(Reader) calls the abstract eval(Reader, ScriptContext) passing the value of the context field.
      Object ScriptEngine.eval(Reader reader, Bindings n)
      Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
      Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
      eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field.
      Object ScriptEngine.eval(Reader reader, ScriptContext context)
      Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
      abstract Object CompiledScript.eval(ScriptContext context)
      Executes the program stored in this CompiledScript object.
      Object ScriptEngine.eval(String script)
      Executes the specified script.
      Object AbstractScriptEngine.eval(String script)
      Same as eval(Reader) except that the abstract eval(String, ScriptContext) is used.
      Object ScriptEngine.eval(String script, Bindings n)
      Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution.
      Object AbstractScriptEngine.eval(String script, Bindings bindings)
      Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
      Object ScriptEngine.eval(String script, ScriptContext context)
      Causes the immediate execution of the script whose source is the String passed as the first argument.
      Object Invocable.invokeFunction(String name, Object... args)
      Used to call top-level procedures and functions defined in scripts.
      Object Invocable.invokeMethod(Object thiz, String name, Object... args)
      Calls a method on a script object compiled during a previous script execution, which is retained in the state of the ScriptEngine.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Jnca/wei


Uses of Class javax.script.SimpleBindings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.SimpleBindings

No usage of javax.script.SimpleBindings
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.tssi"sjs


Uses of Class javax.script.SimpleScriptContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.script.SimpleScriptContext

No usage of javax.script.SimpleScriptContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c�//>nH.


Uses of Interface javax.script.Bindings

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.Bindings

  • Packages that use Bindings
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of Bindings in javax.script

      Classes in javax.script that implement Bindings
      修饰符与类型 类与描述
      class  SimpleBindings
      A simple implementation of Bindings backed by a HashMap or some other specified Map.
      Fields in javax.script declared as Bindings
      修饰符与类型 字段与描述
      protected Bindings SimpleScriptContext.engineScope
      This is the engine scope bindings.
      protected Bindings SimpleScriptContext.globalScope
      This is the global scope bindings.
      Methods in javax.script that return Bindings
      修饰符与类型 方法与描述
      Bindings ScriptEngine.createBindings()
      Returns an uninitialized Bindings.
      Bindings ScriptEngineManager.getBindings()
      getBindings returns the value of the globalScope field.
      Bindings SimpleScriptContext.getBindings(int scope)
      Returns the value of the engineScope field if specified scope is ENGINE_SCOPE.
      Bindings ScriptContext.getBindings(int scope)
      Gets the Bindings associated with the given scope in this ScriptContext.
      Bindings ScriptEngine.getBindings(int scope)
      Returns a scope of named values.
      Bindings AbstractScriptEngine.getBindings(int scope)
      Returns the Bindings with the specified scope value in the protected context field.
      Methods in javax.script with parameters of type Bindings
      修饰符与类型 方法与描述
      Object CompiledScript.eval(Bindings bindings)
      Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution.
      Object ScriptEngine.eval(Reader reader, Bindings n)
      Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
      Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
      eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field.
      Object ScriptEngine.eval(String script, Bindings n)
      Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution.
      Object AbstractScriptEngine.eval(String script, Bindings bindings)
      Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
      protected ScriptContext AbstractScriptEngine.getScriptContext(Bindings nn)
      Returns a SimpleScriptContext.
      void ScriptEngineManager.setBindings(Bindings bindings)
      setBindings stores the specified Bindings in the globalScope field.
      void SimpleScriptContext.setBindings(Bindings bindings, int scope)
      Sets a Bindings of attributes for the given scope.
      void ScriptContext.setBindings(Bindings bindings, int scope)
      Associates a Bindings instance with a particular scope in this ScriptContext.
      void ScriptEngine.setBindings(Bindings bindings, int scope)
      Sets a scope of named values to be used by scripts.
      void AbstractScriptEngine.setBindings(Bindings bindings, int scope)
      Sets the Bindings with the corresponding scope value in the context field.
      Constructors in javax.script with parameters of type Bindings
      构造方法与描述
      AbstractScriptEngine(Bindings n)
      Creates a new instance using the specified Bindings as the ENGINE_SCOPE Bindings in the protected context field.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R.t�vo et= Ssrg/


Uses of Interface javax.script.Compilable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.Compilable

No usage of javax.script.Compilable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iof= scrisssocnnraaa


Uses of Interface javax.script.Invocable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.Invocable

No usage of javax.script.Invocable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"nspst"ocllls


Uses of Interface javax.script.ScriptContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.ScriptContext

  • Packages that use ScriptContext
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of ScriptContext in javax.script

      Classes in javax.script that implement ScriptContext
      修饰符与类型 类与描述
      class  SimpleScriptContext
      Simple implementation of ScriptContext.
      Fields in javax.script declared as ScriptContext
      修饰符与类型 字段与描述
      protected ScriptContext AbstractScriptEngine.context
      The default ScriptContext of this AbstractScriptEngine.
      Methods in javax.script that return ScriptContext
      修饰符与类型 方法与描述
      ScriptContext ScriptEngine.getContext()
      Returns the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.
      ScriptContext AbstractScriptEngine.getContext()
      Returns the value of the protected context field.
      protected ScriptContext AbstractScriptEngine.getScriptContext(Bindings nn)
      Returns a SimpleScriptContext.
      Methods in javax.script with parameters of type ScriptContext
      修饰符与类型 方法与描述
      Object ScriptEngine.eval(Reader reader, ScriptContext context)
      Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
      abstract Object CompiledScript.eval(ScriptContext context)
      Executes the program stored in this CompiledScript object.
      Object ScriptEngine.eval(String script, ScriptContext context)
      Causes the immediate execution of the script whose source is the String passed as the first argument.
      void ScriptEngine.setContext(ScriptContext context)
      Sets the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.
      void AbstractScriptEngine.setContext(ScriptContext ctxt)
      Sets the value of the protected context field to the specified ScriptContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l okse>t./ltaetpt纓"o


Uses of Interface javax.script.ScriptEngine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.ScriptEngine

  • Packages that use ScriptEngine
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of ScriptEngine in javax.script

      Classes in javax.script that implement ScriptEngine
      修饰符与类型 类与描述
      class  AbstractScriptEngine
      Provides a standard implementation for several of the variants of the eval method.
      Methods in javax.script that return ScriptEngine
      修饰符与类型 方法与描述
      abstract ScriptEngine CompiledScript.getEngine()
      Returns the ScriptEngine whose compile method created this CompiledScript.
      ScriptEngine ScriptEngineManager.getEngineByExtension(String extension)
      Look up and create a ScriptEngine for a given extension.
      ScriptEngine ScriptEngineManager.getEngineByMimeType(String mimeType)
      Look up and create a ScriptEngine for a given mime type.
      ScriptEngine ScriptEngineManager.getEngineByName(String shortName)
      Looks up and creates a ScriptEngine for a given name.
      ScriptEngine ScriptEngineFactory.getScriptEngine()
      Returns an instance of the ScriptEngine associated with this ScriptEngineFactory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cmot/tddoeee


Uses of Interface javax.script.ScriptEngineFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.script.ScriptEngineFactory

  • Packages that use ScriptEngineFactory
    软件包 描述
    javax.script
    The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.

    • Uses of ScriptEngineFactory in javax.script

      Methods in javax.script that return ScriptEngineFactory
      修饰符与类型 方法与描述
      ScriptEngineFactory ScriptEngine.getFactory()
      Returns a ScriptEngineFactory for the class to which this ScriptEngine belongs.
      Methods in javax.script that return types with arguments of type ScriptEngineFactory
      修饰符与类型 方法与描述
      List<ScriptEngineFactory> ScriptEngineManager.getEngineFactories()
      Returns an array whose elements are instances of all the ScriptEngineFactory classes found by the discovery mechanism.
      Methods in javax.script with parameters of type ScriptEngineFactory
      修饰符与类型 方法与描述
      void ScriptEngineManager.registerEngineExtension(String extension, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle an extension.
      void ScriptEngineManager.registerEngineMimeType(String type, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle a mime type.
      void ScriptEngineManager.registerEngineName(String name, ScriptEngineFactory factory)
      Registers a ScriptEngineFactory to handle a language name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

en.t盿/tuAAr&edtE<>ps"st


AuthPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth

类 AuthPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.security.auth.AuthPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class AuthPermission
extends BasicPermission
    This class is for authentication permissions. An AuthPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of a security configuration parameter (see below). Currently the AuthPermission object is used to guard access to the Policy, Subject, LoginContext, and Configuration objects.

    The possible target names for an Authentication Permission are:

          doAs -                  allow the caller to invoke the
                              Subject.doAs methods.

      doAsPrivileged -        allow the caller to invoke the
                              Subject.doAsPrivileged methods.

      getSubject -            allow for the retrieval of the
                              Subject(s) associated with the
                              current Thread.

      getSubjectFromDomainCombiner -  allow for the retrieval of the
                              Subject associated with the
                              a SubjectDomainCombiner.

      setReadOnly -           allow the caller to set a Subject
                              to be read-only.

      modifyPrincipals -      allow the caller to modify the Set
                              of Principals associated with a
                              Subject

      modifyPublicCredentials - allow the caller to modify the
                              Set of public credentials
                              associated with a Subject

      modifyPrivateCredentials - allow the caller to modify the
                              Set of private credentials
                              associated with a Subject

      refreshCredential -     allow code to invoke the refresh
                              method on a credential which implements
                              the Refreshable interface.

      destroyCredential -     allow code to invoke the destroy
                              method on a credential object
                              which implements the Destroyable
                              interface.

      createLoginContext.{name} -  allow code to instantiate a
                              LoginContext with the
                              specified name.  name
                              is used as the index into the installed login
                              Configuration
                              (that returned by
                              Configuration.getConfiguration()).
                              name can be wildcarded (set to '*')
                              to allow for any name.

      getLoginConfiguration - allow for the retrieval of the system-wide
                              login Configuration.

      createLoginConfiguration.{type} - allow code to obtain a Configuration
                              object via
                              Configuration.getInstance.

      setLoginConfiguration - allow for the setting of the system-wide
                              login Configuration.

      refreshLoginConfiguration - allow for the refreshing of the system-wide
                              login Configuration.

    The following target name has been deprecated in favor of createLoginContext.{name}.

          createLoginContext -    allow code to instantiate a
                              LoginContext.

    javax.security.auth.Policy has been deprecated in favor of java.security.Policy. Therefore, the following target names have also been deprecated:

          getPolicy -             allow the caller to retrieve the system-wide
                              Subject-based access control policy.

      setPolicy -             allow the caller to set the system-wide
                              Subject-based access control policy.

      refreshPolicy -         allow the caller to refresh the system-wide
                              Subject-based access control policy.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AuthPermission(String name)
      Creates a new AuthPermission with the specified name.
      AuthPermission(String name, String actions)
      Creates a new AuthPermission object with the specified name.

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AuthPermission

        public AuthPermission(String name)
        Creates a new AuthPermission with the specified name. The name is the symbolic name of the AuthPermission.

        参数：
        name - the name of the AuthPermission
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • AuthPermission

        public AuthPermission(String name,
              String actions)
        Creates a new AuthPermission object with the specified name. The name is the symbolic name of the AuthPermission, and the actions String is currently unused and should be null.

        参数：
        name - the name of the AuthPermission

        actions - should be null.
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtgt = eps=ile


Destroyable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.auth

Interface Destroyable

  • All Known Implementing Classes:
    KerberosKey, KerberosTicket, KeyStore.PasswordProtection, X500PrivateCredential

    public interface Destroyable
    Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
    另请参见：
    Subject

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      Destroy this Object.
      boolean isDestroyed()
      Determine if this Object has been destroyed.

    • 方法详细信息

      • destroy

        void destroy()
             throws DestroyFailedException
        Destroy this Object.

        Sensitive information associated with this Object is destroyed or cleared. Subsequent calls to certain methods on this Object will result in an IllegalStateException being thrown.

        抛出：
        DestroyFailedException - if the destroy operation fails.

        SecurityException - if the caller does not have permission to destroy this Object.

      • isDestroyed

        boolean isDestroyed()
        Determine if this Object has been destroyed.

        返回：
        true if this Object has been destroyed, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< u===A==AMRMMMMD=!! s imojehjjbc


DestroyFailedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth

类 DestroyFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.auth.DestroyFailedException
  • 所有已实现的接口：
    Serializable

    public class DestroyFailedException
extends Exception
    Signals that a destroy operation failed.

    This exception is thrown by credentials implementing the Destroyable interface when the destroy method fails.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DestroyFailedException()
      Constructs a DestroyFailedException with no detail message.
      DestroyFailedException(String msg)
      Constructs a DestroyFailedException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DestroyFailedException

        public DestroyFailedException()
        Constructs a DestroyFailedException with no detail message. A detail message is a String that describes this particular exception.

      • DestroyFailedException

        public DestroyFailedException(String msg)
        Constructs a DestroyFailedException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3h rcnucoCnC>CC -i"-=unc "�"i alifo


javax.security.auth

Interfaces

  • Destroyable
  • Refreshable

Classes

  • AuthPermission
  • Policy
  • PrivateCredentialPermission
  • Subject
  • SubjectDomainCombiner

Exceptions

  • DestroyFailedException
  • RefreshFailedException
a


javax.security.auth

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth

This package provides a framework for authentication and authorization.

请参见： 描述

  • 接口摘要
    接口 描述
    Destroyable
    Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
    Refreshable
    Objects such as credentials may optionally implement this interface to provide the capability to refresh itself.
  • Class Summary
    类 描述
    AuthPermission
    This class is for authentication permissions.
    Policy Deprecated
    as of JDK version 1.4 -- Replaced by java.security.Policy.
    PrivateCredentialPermission
    This class is used to protect access to private Credentials belonging to a particular Subject.
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
    SubjectDomainCombiner
    A SubjectDomainCombiner updates ProtectionDomains with Principals from the Subject associated with this SubjectDomainCombiner.
  • Exception Summary
    Exception 描述
    DestroyFailedException
    Signals that a destroy operation failed.
    RefreshFailedException
    Signals that a refresh operation failed.

软件包 javax.security.auth Description

This package provides a framework for authentication and authorization. The framework allows authentication to be performed in pluggable fashion. Different authentication modules can be plugged under an application without requiring modifications to the application itself. The authorization component allows specification of access controls based on code location, code signers and code executors (Subjects).
从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

seeusededliennliffm./.<觢蕋


javax.security.auth Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.security.auth.AuthPermission
      • javax.security.auth.PrivateCredentialPermission
    • javax.security.auth.Policy
    • javax.security.auth.Subject (implements java.io.Serializable)
    • javax.security.auth.SubjectDomainCombiner (implements java.security.DomainCombiner)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.auth.DestroyFailedException
        • javax.security.auth.RefreshFailedException

Interface Hierarchy

  • javax.security.auth.Destroyable
  • javax.security.auth.Refreshable
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hcrl<>sasss>/ee


Policy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth

类 Policy

  • java.lang.Object
    • javax.security.auth.Policy
  • Deprecated.
    as of JDK version 1.4 -- Replaced by java.security.Policy. java.security.Policy has a method:
          public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
    and ProtectionDomain has a constructor:
          public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
    These two APIs provide callers the means to query the Policy for Principal-based Permission entries.

    @Deprecated
public abstract class Policy
extends Object

    This is an abstract class for representing the system policy for Subject-based authorization. A subclass implementation of this class provides a means to specify a Subject-based access control Policy.

    A Policy object can be queried for the set of Permissions granted to code running as a Principal in the following manner:

          policy = Policy.getPolicy();
      PermissionCollection perms = policy.getPermissions(subject,
                                                      codeSource);
    The Policy object consults the local policy and returns and appropriate Permissions object with the Permissions granted to the Principals associated with the provided subject, and granted to the code specified by the provided codeSource.

    A Policy contains the following information. Note that this example only represents the syntax for the default Policy implementation. Subclass implementations of this class may implement alternative syntaxes and may retrieve the Policy from any source such as files, databases, or servers.

    Each entry in the Policy is represented as a grant entry. Each grant entry specifies a codebase, code signers, and Principals triplet, as well as the Permissions granted to that triplet.

          grant CodeBase ["URL"], Signedby ["signers"],
            Principal [Principal_Class] "Principal_Name" {
          Permission Permission_Class ["Target_Name"]
                                      [, "Permission_Actions"]
                                      [, signedBy "SignerName"];
      };
    The CodeBase and Signedby components of the triplet name/value pairs are optional. If they are not present, then any any codebase will match, and any signer (including unsigned code) will match. For Example,
          grant CodeBase "foo.com", Signedby "foo",
            Principal com.sun.security.auth.SolarisPrincipal "duke" {
          permission java.io.FilePermission "/home/duke", "read, write";
      };
    This grant entry specifies that code from "foo.com", signed by "foo', and running as a SolarisPrincipal with the name, duke, has one Permission. This Permission permits the executing code to read and write files in the directory, "/home/duke".

    To "run" as a particular Principal, code invokes the Subject.doAs(subject, ...) method. After invoking that method, the code runs as all the Principals associated with the specified Subject. Note that this Policy (and the Permissions granted in this Policy) only become effective after the call to Subject.doAs has occurred.

    Multiple Principals may be listed within one grant entry. All the Principals in the grant entry must be associated with the Subject provided to Subject.doAs for that Subject to be granted the specified Permissions.

          grant Principal com.sun.security.auth.SolarisPrincipal "duke",
            Principal com.sun.security.auth.SolarisNumericUserPrincipal "0" {
          permission java.io.FilePermission "/home/duke", "read, write";
          permission java.net.SocketPermission "duke.com", "connect";
      };
    This entry grants any code running as both "duke" and "0" permission to read and write files in duke's home directory, as well as permission to make socket connections to "duke.com".

    Note that non Principal-based grant entries are not permitted in this Policy. Therefore, grant entries such as:

          grant CodeBase "foo.com", Signedby "foo" {
          permission java.io.FilePermission "/tmp/scratch", "read, write";
      };
    are rejected. Such permission must be listed in the java.security.Policy.

    The default Policy implementation can be changed by setting the value of the "auth.policy.provider" security property (in the Java security properties file) to the fully qualified name of the desired Policy implementation class. The Java security properties file is located in the file named <JAVA_HOME>/lib/security/java.security. <JAVA_HOME> refers to the value of the java.home system property, and specifies the directory where the JRE is installed.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Policy()
      Deprecated.
      Sole constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract PermissionCollection getPermissions(Subject subject, CodeSource cs)
      Deprecated.
      Retrieve the Permissions granted to the Principals associated with the specified CodeSource.
      static Policy getPolicy()
      Deprecated.
      Returns the installed Policy object.
      abstract void refresh()
      Deprecated.
      Refresh and reload the Policy.
      static void setPolicy(Policy policy)
      Deprecated.
      Sets the system-wide Policy object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Policy

        protected Policy()
        Deprecated.
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • 方法详细信息

      • getPolicy

        public static Policy getPolicy()
        Deprecated.
        Returns the installed Policy object. This method first calls SecurityManager.checkPermission with the AuthPermission("getPolicy") permission to ensure the caller has permission to get the Policy object.

        返回：
        the installed Policy. The return value cannot be null.
        抛出：
        SecurityException - if the current thread does not have permission to get the Policy object.
        另请参见：
        setPolicy(javax.security.auth.Policy)

      • setPolicy

        public static void setPolicy(Policy policy)
        Deprecated.
        Sets the system-wide Policy object. This method first calls SecurityManager.checkPermission with the AuthPermission("setPolicy") permission to ensure the caller has permission to set the Policy.

        参数：
        policy - the new system Policy object.
        抛出：
        SecurityException - if the current thread does not have permission to set the Policy.
        另请参见：
        getPolicy()

      • getPermissions

        public abstract PermissionCollection getPermissions(Subject subject,
                                  CodeSource cs)
        Deprecated.
        Retrieve the Permissions granted to the Principals associated with the specified CodeSource.

        参数：
        subject - the Subject whose associated Principals, in conjunction with the provided CodeSource, determines the Permissions returned by this method. This parameter may be null.

        cs - the code specified by its CodeSource that determines, in conjunction with the provided Subject, the Permissions returned by this method. This parameter may be null.
        返回：
        the Collection of Permissions granted to all the Subject and code specified in the provided subject and cs parameters.

      • refresh

        public abstract void refresh()
        Deprecated.
        Refresh and reload the Policy.

        This method causes this object to refresh/reload its current Policy. This is implementation-dependent. For example, if the Policy object is stored in a file, calling refresh will cause the file to be re-read.

        抛出：
        SecurityException - if the caller does not have permission to refresh the Policy.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csa d;taos rp>dgn<-e籵


PrivateCredentialPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth

类 PrivateCredentialPermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.auth.PrivateCredentialPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class PrivateCredentialPermission
extends Permission
    This class is used to protect access to private Credentials belonging to a particular Subject. The Subject is represented by a Set of Principals.

    The target name of this Permission specifies a Credential class name, and a Set of Principals. The only valid value for this Permission's actions is, "read". The target name must abide by the following syntax:

          CredentialClass {PrincipalClass "PrincipalName"}*
    For example, the following permission grants access to the com.sun.PrivateCredential owned by Subjects which have a com.sun.Principal with the name, "duke". Note that although this example, as well as all the examples below, do not contain Codebase, SignedBy, or Principal information in the grant statement (for simplicity reasons), actual policy configurations should specify that information when appropriate.

    grant {
      permission javax.security.auth.PrivateCredentialPermission
              "com.sun.PrivateCredential com.sun.Principal \"duke\"",
              "read";
    };
    If CredentialClass is "*", then access is granted to all private Credentials belonging to the specified Subject. If "PrincipalName" is "*", then access is granted to the specified Credential owned by any Subject that has the specified Principal (the actual PrincipalName doesn't matter). For example, the following grants access to the a.b.Credential owned by any Subject that has an a.b.Principal.
        grant {
      permission javax.security.auth.PrivateCredentialPermission
              "a.b.Credential a.b.Principal "*"",
              "read";
    };
    If both the PrincipalClass and "PrincipalName" are "*", then access is granted to the specified Credential owned by any Subject.

    In addition, the PrincipalClass/PrincipalName pairing may be repeated:

        grant {
      permission javax.security.auth.PrivateCredentialPermission
              "a.b.Credential a.b.Principal "duke" c.d.Principal "dukette"",
              "read";
    };
    The above grants access to the private Credential, "a.b.Credential", belonging to a Subject with at least two associated Principals: "a.b.Principal" with the name, "duke", and "c.d.Principal", with the name, "dukette".
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrivateCredentialPermission(String name, String actions)
      Creates a new PrivateCredentialPermission with the specified name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Checks two PrivateCredentialPermission objects for equality.
      String getActions()
      Returns the "canonical string representation" of the actions.
      String getCredentialClass()
      Returns the Class name of the Credential associated with this PrivateCredentialPermission.
      String[][] getPrincipals()
      Returns the Principal classes and names associated with this PrivateCredentialPermission.
      int hashCode()
      Returns the hash code value for this object.
      boolean implies(Permission p)
      Checks if this PrivateCredentialPermission implies the specified Permission.
      PermissionCollection newPermissionCollection()
      Return a homogeneous collection of PrivateCredentialPermissions in a PermissionCollection.

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PrivateCredentialPermission

        public PrivateCredentialPermission(String name,
                           String actions)
        Creates a new PrivateCredentialPermission with the specified name. The name specifies both a Credential class and a Principal Set.

        参数：
        name - the name specifying the Credential class and Principal Set.

        actions - the actions specifying that the Credential can be read.
        抛出：
        IllegalArgumentException - if name does not conform to the correct syntax or if actions is not "read".

    • 方法详细信息

      • getCredentialClass

        public String getCredentialClass()
        Returns the Class name of the Credential associated with this PrivateCredentialPermission.

        返回：
        the Class name of the Credential associated with this PrivateCredentialPermission.

      • getPrincipals

        public String[][] getPrincipals()
        Returns the Principal classes and names associated with this PrivateCredentialPermission. The information is returned as a two-dimensional array (array[x][y]). The 'x' value corresponds to the number of Principal class and name pairs. When (y==0), it corresponds to the Principal class value, and when (y==1), it corresponds to the Principal name value. For example, array[0][0] corresponds to the class name of the first Principal in the array. array[0][1] corresponds to the Principal name of the first Principal in the array.

        返回：
        the Principal class and names associated with this PrivateCredentialPermission.

      • implies

        public boolean implies(Permission p)
        Checks if this PrivateCredentialPermission implies the specified Permission.

        This method returns true if:

        • p is an instanceof PrivateCredentialPermission and

        • the target name for p is implied by this object's target name. For example:
            [* P1 "duke"] implies [a.b.Credential P1 "duke"].
  [C1 P1 "duke"] implies [C1 P1 "duke" P2 "dukette"].
  [C1 P2 "dukette"] implies [C1 P1 "duke" P2 "dukette"].

        指定者：
        implies in class Permission
        参数：
        p - the Permission to check against.
        返回：
        true if this PrivateCredentialPermission implies the specified Permission, false if not.

      • equals

        public boolean equals(Object obj)
        Checks two PrivateCredentialPermission objects for equality. Checks that obj is a PrivateCredentialPermission, and has the same credential class as this object, as well as the same Principals as this object. The order of the Principals in the respective Permission's target names is not relevant.

        指定者：
        equals in class Permission
        参数：
        obj - the object we are testing for equality with this object.
        返回：
        true if obj is a PrivateCredentialPermission, has the same credential class as this object, and has the same Principals as this object.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this object.
        指定者：
        hashCode in class Permission
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions()
        Returns the "canonical string representation" of the actions. This method always returns the String, "read".

        指定者：
        getActions in class Permission
        返回：
        the actions (always returns "read").

      • newPermissionCollection

        public PermissionCollection newPermissionCollection()
        Return a homogeneous collection of PrivateCredentialPermissions in a PermissionCollection. No such PermissionCollection is defined, so this method always returns null.

        重载：
        newPermissionCollection in class Permission
        返回：
        null in all cases.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ae=aoPoel >Psplgoe�>At/>thDFe>cdot_l f /hi


Refreshable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.auth

Interface Refreshable

  • All Known Implementing Classes:
    KerberosTicket

    public interface Refreshable
    Objects such as credentials may optionally implement this interface to provide the capability to refresh itself. For example, a credential with a particular time-restricted lifespan may implement this interface to allow callers to refresh the time period for which it is valid.
    另请参见：
    Subject

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isCurrent()
      Determine if this Object is current.
      void refresh()
      Update or extend the validity period for this Object.

    • 方法详细信息

      • isCurrent

        boolean isCurrent()
        Determine if this Object is current.

        返回：
        true if this Object is currently current, false otherwise.

      • refresh

        void refresh()
             throws RefreshFailedException
        Update or extend the validity period for this Object.

        抛出：
        SecurityException - if the caller does not have permission to update or extend the validity period for this Object.

        RefreshFailedException - if the refresh attempt failed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a< >>ca


RefreshFailedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth

类 RefreshFailedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.auth.RefreshFailedException
  • 所有已实现的接口：
    Serializable

    public class RefreshFailedException
extends Exception
    Signals that a refresh operation failed.

    This exception is thrown by credentials implementing the Refreshable interface when the refresh method fails.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RefreshFailedException()
      Constructs a RefreshFailedException with no detail message.
      RefreshFailedException(String msg)
      Constructs a RefreshFailedException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RefreshFailedException

        public RefreshFailedException()
        Constructs a RefreshFailedException with no detail message. A detail message is a String that describes this particular exception.

      • RefreshFailedException

        public RefreshFailedException(String msg)
        Constructs a RefreshFailedException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lTa.=r".haratrn/>>.s<>d .a/a./a c"


Subject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth

类 Subject

  • java.lang.Object
    • javax.security.auth.Subject
  • 所有已实现的接口：
    Serializable

    public final class Subject
extends Object
implements Serializable

    A Subject represents a grouping of related information for a single entity, such as a person. Such information includes the Subject's identities as well as its security-related attributes (passwords and cryptographic keys, for example).

    Subjects may potentially have multiple identities. Each identity is represented as a Principal within the Subject. Principals simply bind names to a Subject. For example, a Subject that happens to be a person, Alice, might have two Principals: one which binds "Alice Bar", the name on her driver license, to the Subject, and another which binds, "999-99-9999", the number on her student identification card, to the Subject. Both Principals refer to the same Subject even though each has a different name.

    A Subject may also own security-related attributes, which are referred to as credentials. Sensitive credentials that require special protection, such as private cryptographic keys, are stored within a private credential Set. Credentials intended to be shared, such as public key certificates or Kerberos server tickets are stored within a public credential Set. Different permissions are required to access and modify the different credential Sets.

    To retrieve all the Principals associated with a Subject, invoke the getPrincipals method. To retrieve all the public or private credentials belonging to a Subject, invoke the getPublicCredentials method or getPrivateCredentials method, respectively. To modify the returned Set of Principals and credentials, use the methods defined in the Set class. For example:

          Subject subject;
      Principal principal;
      Object credential;

      // add a Principal and credential to the Subject
      subject.getPrincipals().add(principal);
      subject.getPublicCredentials().add(credential);

    This Subject class implements Serializable. While the Principals associated with the Subject are serialized, the credentials associated with the Subject are not. Note that the java.security.Principal class does not implement Serializable. Therefore all concrete Principal implementations associated with Subjects must implement Serializable.

    另请参见：
    Principal, DomainCombiner, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      Subject()
      Create an instance of a Subject with an empty Set of Principals and empty Sets of public and private credentials.
      Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
      Create an instance of a Subject with Principals and credentials.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static <T> T doAs(Subject subject, PrivilegedAction<T> action)
      Perform work as a particular Subject.
      static <T> T doAs(Subject subject, PrivilegedExceptionAction<T> action)
      Perform work as a particular Subject.
      static <T> T doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
      Perform privileged work as a particular Subject.
      static <T> T doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
      Perform privileged work as a particular Subject.
      boolean equals(Object o)
      Compares the specified Object with this Subject for equality.
      Set<Principal> getPrincipals()
      Return the Set of Principals associated with this Subject.
      <T extends Principal>
      Set<T>             		getPrincipals(类<T> c)
      Return a Set of Principals associated with this Subject that are instances or subclasses of the specified 类.
      Set<Object> getPrivateCredentials()
      Return the Set of private credentials held by this Subject.
      <T> Set<T> getPrivateCredentials(类<T> c)
      Return a Set of private credentials associated with this Subject that are instances or subclasses of the specified 类.
      Set<Object> getPublicCredentials()
      Return the Set of public credentials held by this Subject.
      <T> Set<T> getPublicCredentials(类<T> c)
      Return a Set of public credentials associated with this Subject that are instances or subclasses of the specified 类.
      static Subject getSubject(AccessControlContext acc)
      Get the Subject associated with the provided AccessControlContext.
      int hashCode()
      Returns a hashcode for this Subject.
      boolean isReadOnly()
      Query whether this Subject is read-only.
      void setReadOnly()
      Set this Subject to be read-only.
      String toString()
      Return the String representation of this Subject.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Subject

        public Subject()
        Create an instance of a Subject with an empty Set of Principals and empty Sets of public and private credentials.

        The newly constructed Sets check whether this Subject has been set read-only before permitting subsequent modifications. The newly created Sets also prevent illegal modifications by ensuring that callers have sufficient permissions.

        To modify the Principals Set, the caller must have AuthPermission("modifyPrincipals"). To modify the public credential Set, the caller must have AuthPermission("modifyPublicCredentials"). To modify the private credential Set, the caller must have AuthPermission("modifyPrivateCredentials").

      • Subject

        public Subject(boolean readOnly,
       Set<? extends Principal> principals,
       Set<?> pubCredentials,
       Set<?> privCredentials)
        Create an instance of a Subject with Principals and credentials.

        The Principals and credentials from the specified Sets are copied into newly constructed Sets. These newly created Sets check whether this Subject has been set read-only before permitting subsequent modifications. The newly created Sets also prevent illegal modifications by ensuring that callers have sufficient permissions.

        To modify the Principals Set, the caller must have AuthPermission("modifyPrincipals"). To modify the public credential Set, the caller must have AuthPermission("modifyPublicCredentials"). To modify the private credential Set, the caller must have AuthPermission("modifyPrivateCredentials").

        参数：
        readOnly - true if the Subject is to be read-only, and false otherwise.

        principals - the Set of Principals to be associated with this Subject.

        pubCredentials - the Set of public credentials to be associated with this Subject.

        privCredentials - the Set of private credentials to be associated with this Subject.
        抛出：
        NullPointerException - if the specified principals, pubCredentials, or privCredentials are null.

    • 方法详细信息

      • setReadOnly

        public void setReadOnly()
        Set this Subject to be read-only.

        Modifications (additions and removals) to this Subject's Principal Set and credential Sets will be disallowed. The destroy operation on this Subject's credentials will still be permitted.

        Subsequent attempts to modify the Subject's Principal and credential Sets will result in an IllegalStateException being thrown. Also, once a Subject is read-only, it can not be reset to being writable again.

        抛出：
        SecurityException - if the caller does not have permission to set this Subject to be read-only.

      • isReadOnly

        public boolean isReadOnly()
        Query whether this Subject is read-only.

        返回：
        true if this Subject is read-only, false otherwise.

      • getSubject

        public static Subject getSubject(AccessControlContext acc)
        Get the Subject associated with the provided AccessControlContext.

        The AccessControlContext may contain many Subjects (from nested doAs calls). In this situation, the most recent Subject associated with the AccessControlContext is returned.

        参数：
        acc - the AccessControlContext from which to retrieve the Subject.
        返回：
        the Subject associated with the provided AccessControlContext, or null if no Subject is associated with the provided AccessControlContext.
        抛出：
        SecurityException - if the caller does not have permission to get the Subject.

        NullPointerException - if the provided AccessControlContext is null.

      • doAs

        public static <T> T doAs(Subject subject,
         PrivilegedAction<T> action)
        Perform work as a particular Subject.

        This method first retrieves the current Thread's AccessControlContext via AccessController.getContext, and then instantiates a new AccessControlContext using the retrieved context along with a new SubjectDomainCombiner (constructed using the provided Subject). Finally, this method invokes AccessController.doPrivileged, passing it the provided PrivilegedAction, as well as the newly constructed AccessControlContext.

        参数：
        subject - the Subject that the specified action will run as. This parameter may be null.

        action - the code to be run as the specified Subject.

        返回：
        the value returned by the PrivilegedAction's run method.
        抛出：
        NullPointerException - if the PrivilegedAction is null.

        SecurityException - if the caller does not have permission to invoke this method.

      • doAs

        public static <T> T doAs(Subject subject,
         PrivilegedExceptionAction<T> action)
              throws PrivilegedActionException
        Perform work as a particular Subject.

        This method first retrieves the current Thread's AccessControlContext via AccessController.getContext, and then instantiates a new AccessControlContext using the retrieved context along with a new SubjectDomainCombiner (constructed using the provided Subject). Finally, this method invokes AccessController.doPrivileged, passing it the provided PrivilegedExceptionAction, as well as the newly constructed AccessControlContext.

        参数：
        subject - the Subject that the specified action will run as. This parameter may be null.

        action - the code to be run as the specified Subject.

        返回：
        the value returned by the PrivilegedExceptionAction's run method.
        抛出：
        PrivilegedActionException - if the PrivilegedExceptionAction.run method throws a checked exception.

        NullPointerException - if the specified PrivilegedExceptionAction is null.

        SecurityException - if the caller does not have permission to invoke this method.

      • doAsPrivileged

        public static <T> T doAsPrivileged(Subject subject,
                   PrivilegedAction<T> action,
                   AccessControlContext acc)
        Perform privileged work as a particular Subject.

        This method behaves exactly as Subject.doAs, except that instead of retrieving the current Thread's AccessControlContext, it uses the provided AccessControlContext. If the provided AccessControlContext is null, this method instantiates a new AccessControlContext with an empty collection of ProtectionDomains.

        参数：
        subject - the Subject that the specified action will run as. This parameter may be null.

        action - the code to be run as the specified Subject.

        acc - the AccessControlContext to be tied to the specified subject and action.

        返回：
        the value returned by the PrivilegedAction's run method.
        抛出：
        NullPointerException - if the PrivilegedAction is null.

        SecurityException - if the caller does not have permission to invoke this method.

      • doAsPrivileged

        public static <T> T doAsPrivileged(Subject subject,
                   PrivilegedExceptionAction<T> action,
                   AccessControlContext acc)
                        throws PrivilegedActionException
        Perform privileged work as a particular Subject.

        This method behaves exactly as Subject.doAs, except that instead of retrieving the current Thread's AccessControlContext, it uses the provided AccessControlContext. If the provided AccessControlContext is null, this method instantiates a new AccessControlContext with an empty collection of ProtectionDomains.

        参数：
        subject - the Subject that the specified action will run as. This parameter may be null.

        action - the code to be run as the specified Subject.

        acc - the AccessControlContext to be tied to the specified subject and action.

        返回：
        the value returned by the PrivilegedExceptionAction's run method.
        抛出：
        PrivilegedActionException - if the PrivilegedExceptionAction.run method throws a checked exception.

        NullPointerException - if the specified PrivilegedExceptionAction is null.

        SecurityException - if the caller does not have permission to invoke this method.

      • getPrincipals

        public Set<Principal> getPrincipals()
        Return the Set of Principals associated with this Subject. Each Principal represents an identity for this Subject.

        The returned Set is backed by this Subject's internal Principal Set. Any modification to the returned Set affects the internal Principal Set as well.

        返回：
        The Set of Principals associated with this Subject.

      • getPrincipals

        public <T extends Principal> Set<T> getPrincipals(类<T> c)
        Return a Set of Principals associated with this Subject that are instances or subclasses of the specified 类.

        The returned Set is not backed by this Subject's internal Principal Set. A new Set is created and returned for each method invocation. Modifications to the returned Set will not affect the internal Principal Set.

        参数：
        c - the returned Set of Principals will all be instances of this class.
        返回：
        a Set of Principals that are instances of the specified 类.
        抛出：
        NullPointerException - if the specified 类 is null.

      • getPublicCredentials

        public Set<Object> getPublicCredentials()
        Return the Set of public credentials held by this Subject.

        The returned Set is backed by this Subject's internal public Credential Set. Any modification to the returned Set affects the internal public Credential Set as well.

        返回：
        A Set of public credentials held by this Subject.

      • getPrivateCredentials

        public Set<Object> getPrivateCredentials()
        Return the Set of private credentials held by this Subject.

        The returned Set is backed by this Subject's internal private Credential Set. Any modification to the returned Set affects the internal private Credential Set as well.

        A caller requires permissions to access the Credentials in the returned Set, or to modify the Set itself. A SecurityException is thrown if the caller does not have the proper permissions.

        While iterating through the Set, a SecurityException is thrown if the caller does not have permission to access a particular Credential. The Iterator is nevertheless advanced to next element in the Set.

        返回：
        A Set of private credentials held by this Subject.

      • getPublicCredentials

        public <T> Set<T> getPublicCredentials(类<T> c)
        Return a Set of public credentials associated with this Subject that are instances or subclasses of the specified 类.

        The returned Set is not backed by this Subject's internal public Credential Set. A new Set is created and returned for each method invocation. Modifications to the returned Set will not affect the internal public Credential Set.

        参数：
        c - the returned Set of public credentials will all be instances of this class.
        返回：
        a Set of public credentials that are instances of the specified 类.
        抛出：
        NullPointerException - if the specified 类 is null.

      • getPrivateCredentials

        public <T> Set<T> getPrivateCredentials(类<T> c)
        Return a Set of private credentials associated with this Subject that are instances or subclasses of the specified 类.

        The caller must have permission to access all of the requested Credentials, or a SecurityException will be thrown.

        The returned Set is not backed by this Subject's internal private Credential Set. A new Set is created and returned for each method invocation. Modifications to the returned Set will not affect the internal private Credential Set.

        参数：
        c - the returned Set of private credentials will all be instances of this class.
        返回：
        a Set of private credentials that are instances of the specified 类.
        抛出：
        NullPointerException - if the specified 类 is null.

      • equals

        public boolean equals(Object o)
        Compares the specified Object with this Subject for equality. Returns true if the given object is also a Subject and the two Subject instances are equivalent. More formally, two Subject instances are equal if their Principal and Credential Sets are equal.

        重载：
        equals in class Object
        参数：
        o - Object to be compared for equality with this Subject.
        返回：
        true if the specified Object is equal to this Subject.
        抛出：
        SecurityException - if the caller does not have permission to access the private credentials for this Subject, or if the caller does not have permission to access the private credentials for the provided Subject.
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Return the String representation of this Subject.

        重载：
        toString in class Object
        返回：
        the String representation of this Subject.

      • hashCode

        public int hashCode()
        Returns a hashcode for this Subject.

        重载：
        hashCode in class Object
        返回：
        a hashcode for this Subject.
        抛出：
        SecurityException - if the caller does not have permission to access this Subject's private credentials.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SubjectDomainCombiner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth

类 SubjectDomainCombiner

  • java.lang.Object
    • javax.security.auth.SubjectDomainCombiner
  • 所有已实现的接口：
    DomainCombiner

    public class SubjectDomainCombiner
extends Object
implements DomainCombiner
    A SubjectDomainCombiner updates ProtectionDomains with Principals from the Subject associated with this SubjectDomainCombiner.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SubjectDomainCombiner(Subject subject)
      Associate the provided Subject with this SubjectDomainCombiner.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ProtectionDomain[] combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
      Update the relevant ProtectionDomains with the Principals from the Subject associated with this SubjectDomainCombiner.
      Subject getSubject()
      Get the Subject associated with this SubjectDomainCombiner.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SubjectDomainCombiner

        public SubjectDomainCombiner(Subject subject)
        Associate the provided Subject with this SubjectDomainCombiner.

        参数：
        subject - the Subject to be associated with with this SubjectDomainCombiner.

    • 方法详细信息

      • getSubject

        public Subject getSubject()
        Get the Subject associated with this SubjectDomainCombiner.

        返回：
        the Subject associated with this SubjectDomainCombiner, or null if no Subject is associated with this SubjectDomainCombiner.
        抛出：
        SecurityException - if the caller does not have permission to get the Subject associated with this SubjectDomainCombiner.

      • combine

        public ProtectionDomain[] combine(ProtectionDomain[] currentDomains,
                         ProtectionDomain[] assignedDomains)
        Update the relevant ProtectionDomains with the Principals from the Subject associated with this SubjectDomainCombiner.

        A new ProtectionDomain instance is created for each ProtectionDomain in the currentDomains array. Each new ProtectionDomain instance is created using the CodeSource, Permissions and ClassLoader from the corresponding ProtectionDomain in currentDomains, as well as with the Principals from the Subject associated with this SubjectDomainCombiner.

        All of the newly instantiated ProtectionDomains are combined into a new array. The ProtectionDomains from the assignedDomains array are appended to this new array, and the result is returned.

        Note that optimizations such as the removal of duplicate ProtectionDomains may have occurred. In addition, caching of ProtectionDomains may be permitted.

        指定者：
        combine in interface DomainCombiner
        参数：
        currentDomains - the ProtectionDomains associated with the current execution Thread, up to the most recent privileged ProtectionDomain. The ProtectionDomains are are listed in order of execution, with the most recently executing ProtectionDomain residing at the beginning of the array. This parameter may be null if the current execution Thread has no associated ProtectionDomains.

        assignedDomains - the ProtectionDomains inherited from the parent Thread, or the ProtectionDomains from the privileged context, if a call to AccessController.doPrivileged(..., context) had occurred This parameter may be null if there were no ProtectionDomains inherited from the parent Thread, or from the privileged context.
        返回：
        a new array consisting of the updated ProtectionDomains, or null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

boslosasssaaictt.h.f.//a/v/aC/..=h<


Uses of Package javax.security.auth

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth

  • Packages that use javax.security.auth
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.security.auth
    This package provides a framework for authentication and authorization.
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.
    javax.security.auth.x500
    This package contains the classes that should be used to store X500 Principal and X500 Private Crendentials in a Subject.
  • Classes in javax.security.auth used by java.security
    类与描述
    Destroyable
    Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
    DestroyFailedException
    Signals that a destroy operation failed.
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.management.remote
    类与描述
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.management.remote.rmi
    类与描述
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.security.auth
    类与描述
    DestroyFailedException
    Signals that a destroy operation failed.
    Policy
    Deprecated.
    as of JDK version 1.4 -- Replaced by java.security.Policy. java.security.Policy has a method:
          public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
    and ProtectionDomain has a constructor:
          public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
    These two APIs provide callers the means to query the Policy for Principal-based Permission entries.
    RefreshFailedException
    Signals that a refresh operation failed.
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.security.auth.kerberos
    类与描述
    Destroyable
    Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
    DestroyFailedException
    Signals that a destroy operation failed.
    Refreshable
    Objects such as credentials may optionally implement this interface to provide the capability to refresh itself.
    RefreshFailedException
    Signals that a refresh operation failed.
  • Classes in javax.security.auth used by javax.security.auth.login
    类与描述
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.security.auth.spi
    类与描述
    Subject
    A Subject represents a grouping of related information for a single entity, such as a person.
  • Classes in javax.security.auth used by javax.security.auth.x500
    类与描述
    Destroyable
    Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aO."=S>mp"bml/onl<&aas


Callback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.security.auth.callback

Interface Callback

  • All Known Implementing Classes:
    AuthorizeCallback, ChoiceCallback, ConfirmationCallback, LanguageCallback, NameCallback, PasswordCallback, RealmCallback, RealmChoiceCallback, TextInputCallback, TextOutputCallback

    public interface Callback

    Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.

    Callback implementations do not retrieve or display the information requested by underlying security services. Callback implementations simply provide the means to pass such requests to applications, and for applications, if appropriate, to return requested information back to the underlying security services.

    另请参见：
    CallbackHandler, ChoiceCallback, ConfirmationCallback, LanguageCallback, NameCallback, PasswordCallback, TextInputCallback, TextOutputCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snecs"


CallbackHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.auth.callback

Interface CallbackHandler

  • public interface CallbackHandler

    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.

    CallbackHandlers are implemented in an application-dependent fashion. For example, implementations for an application with a graphical user interface (GUI) may pop up windows to prompt for requested information or to display error messages. An implementation may also choose to obtain requested information from an alternate source without asking the end user.

    Underlying security services make requests for different types of information by passing individual Callbacks to the CallbackHandler. The CallbackHandler implementation decides how to retrieve and display information depending on the Callbacks passed to it. For example, if the underlying service needs a username and password to authenticate a user, it uses a NameCallback and PasswordCallback. The CallbackHandler can then choose to prompt for a username and password serially, or to prompt for both in a single window.

    A default CallbackHandler class implementation may be specified in the auth.login.defaultCallbackHandler security property. The security property can be set in the Java security properties file located in the file named <JAVA_HOME>/lib/security/java.security. <JAVA_HOME> refers to the value of the java.home system property, and specifies the directory where the JRE is installed.

    If the security property is set to the fully qualified name of a CallbackHandler implementation class, then a LoginContext will load the specified CallbackHandler and pass it to the underlying LoginModules. The LoginContext only loads the default handler if it was not provided one.

    All default handler implementations must provide a public zero-argument constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void handle(Callback[] callbacks)
      Retrieve or display the information requested in the provided Callbacks.

    • 方法详细信息

      • handle

        void handle(Callback[] callbacks)
            throws IOException,
                   UnsupportedCallbackException

        Retrieve or display the information requested in the provided Callbacks.

        The handle method implementation checks the instance(s) of the Callback object(s) passed in to retrieve or display the requested information. The following example is provided to help demonstrate what an handle method implementation might look like. This example code is for guidance only. Many details, including proper error handling, are left out for simplicity.

         public void handle(Callback[] callbacks)
 throws IOException, UnsupportedCallbackException {

   for (int i = 0; i < callbacks.length; i++) {
      if (callbacks[i] instanceof TextOutputCallback) {

          // display the message according to the specified type
          TextOutputCallback toc = (TextOutputCallback)callbacks[i];
          switch (toc.getMessageType()) {
          case TextOutputCallback.INFORMATION:
              System.out.println(toc.getMessage());
              break;
          case TextOutputCallback.ERROR:
              System.out.println("ERROR: " + toc.getMessage());
              break;
          case TextOutputCallback.WARNING:
              System.out.println("WARNING: " + toc.getMessage());
              break;
          default:
              throw new IOException("Unsupported message type: " +
                                  toc.getMessageType());
          }

      } else if (callbacks[i] instanceof NameCallback) {

          // prompt the user for a username
          NameCallback nc = (NameCallback)callbacks[i];

          // ignore the provided defaultName
          System.err.print(nc.getPrompt());
          System.err.flush();
          nc.setName((new BufferedReader
                  (new InputStreamReader(System.in))).readLine());

      } else if (callbacks[i] instanceof PasswordCallback) {

          // prompt the user for sensitive information
          PasswordCallback pc = (PasswordCallback)callbacks[i];
          System.err.print(pc.getPrompt());
          System.err.flush();
          pc.setPassword(readPassword(System.in));

      } else {
          throw new UnsupportedCallbackException
                  (callbacks[i], "Unrecognized Callback");
      }
   }
 }

 // Reads user password from given input stream.
 private char[] readPassword(InputStream in) throws IOException {
    // insert code to read a user password from the input stream
 }
        参数：
        callbacks - an array of Callback objects provided by an underlying security service which contains the information requested to be retrieved or displayed.
        抛出：
        IOException - if an input or output error occurs.

        UnsupportedCallbackException - if the implementation of this method does not support one or more of the Callbacks specified in the callbacks parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atleerIsic.u/><>>./aih齣m >


ChoiceCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 ChoiceCallback

  • java.lang.Object
    • javax.security.auth.callback.ChoiceCallback
  • 所有已实现的接口：
    Serializable, Callback
    直接已知子类：
    RealmChoiceCallback

    public class ChoiceCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).

    另请参见：
    CallbackHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
      Construct a ChoiceCallback with a prompt, a list of choices, a default choice, and a boolean specifying whether or not multiple selections from the list of choices are allowed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean allowMultipleSelections()
      Get the boolean determining whether multiple selections from the choices list are allowed.
      String[] getChoices()
      Get the list of choices.
      int getDefaultChoice()
      Get the defaultChoice.
      String getPrompt()
      Get the prompt.
      int[] getSelectedIndexes()
      Get the selected choices.
      void setSelectedIndex(int selection)
      Set the selected choice.
      void setSelectedIndexes(int[] selections)
      Set the selected choices.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ChoiceCallback

        public ChoiceCallback(String prompt,
              String[] choices,
              int defaultChoice,
              boolean multipleSelectionsAllowed)
        Construct a ChoiceCallback with a prompt, a list of choices, a default choice, and a boolean specifying whether or not multiple selections from the list of choices are allowed.

        参数：
        prompt - the prompt used to describe the list of choices.

        choices - the list of choices.

        defaultChoice - the choice to be used as the default choice when the list of choices are displayed. This value is represented as an index into the choices array.

        multipleSelectionsAllowed - boolean specifying whether or not multiple selections can be made from the list of choices.
        抛出：
        IllegalArgumentException - if prompt is null, if prompt has a length of 0, if choices is null, if choices has a length of 0, if any element from choices is null, if any element from choices has a length of 0 or if defaultChoice does not fall within the array boundaries of choices.

    • 方法详细信息

      • getPrompt

        public String getPrompt()
        Get the prompt.

        返回：
        the prompt.

      • getChoices

        public String[] getChoices()
        Get the list of choices.

        返回：
        the list of choices.

      • getDefaultChoice

        public int getDefaultChoice()
        Get the defaultChoice.

        返回：
        the defaultChoice, represented as an index into the choices list.

      • allowMultipleSelections

        public boolean allowMultipleSelections()
        Get the boolean determining whether multiple selections from the choices list are allowed.

        返回：
        whether multiple selections are allowed.

      • setSelectedIndex

        public void setSelectedIndex(int selection)
        Set the selected choice.

        参数：
        selection - the selection represented as an index into the choices list.
        另请参见：
        getSelectedIndexes()

      • setSelectedIndexes

        public void setSelectedIndexes(int[] selections)
        Set the selected choices.

        参数：
        selections - the selections represented as indexes into the choices list.
        抛出：
        UnsupportedOperationException - if multiple selections are not allowed, as determined by allowMultipleSelections.
        另请参见：
        getSelectedIndexes()

      • getSelectedIndexes

        public int[] getSelectedIndexes()
        Get the selected choices.

        返回：
        the selected choices, represented as indexes into the choices list.
        另请参见：
        setSelectedIndexes(int[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t鱏Sf"cddmcs浜os>"tRess s hn


ConfirmationCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 ConfirmationCallback

  • java.lang.Object
    • javax.security.auth.callback.ConfirmationCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class ConfirmationCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a ConfirmationCallback to the handle method of a CallbackHandler to ask for YES/NO, OK/CANCEL, YES/NO/CANCEL or other similar confirmations.

    另请参见：
    CallbackHandler, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int CANCEL
      CANCEL option.
      static int ERROR
      ERROR message type.
      static int INFORMATION
      INFORMATION message type.
      static int NO
      NO option.
      static int OK
      OK option.
      static int OK_CANCEL_OPTION
      OK/CANCEL confirmation confirmation option.
      static int UNSPECIFIED_OPTION
      Unspecified option type.
      static int WARNING
      WARNING message type.
      static int YES
      YES option.
      static int YES_NO_CANCEL_OPTION
      YES/NO/CANCEL confirmation confirmation option.
      static int YES_NO_OPTION
      YES/NO confirmation option.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ConfirmationCallback(int messageType, int optionType, int defaultOption)
      Construct a ConfirmationCallback with a message type, an option type and a default option.
      ConfirmationCallback(int messageType, String[] options, int defaultOption)
      Construct a ConfirmationCallback with a message type, a list of options and a default option.
      ConfirmationCallback(String prompt, int messageType, int optionType, int defaultOption)
      Construct a ConfirmationCallback with a prompt, message type, an option type and a default option.
      ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
      Construct a ConfirmationCallback with a prompt, message type, a list of options and a default option.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getDefaultOption()
      Get the default option.
      int getMessageType()
      Get the message type.
      String[] getOptions()
      Get the confirmation options.
      int getOptionType()
      Get the option type.
      String getPrompt()
      Get the prompt.
      int getSelectedIndex()
      Get the selected confirmation option.
      void setSelectedIndex(int selection)
      Set the selected confirmation option.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • UNSPECIFIED_OPTION

        public static final int UNSPECIFIED_OPTION
        Unspecified option type.

        The getOptionType method returns this value if this ConfirmationCallback was instantiated with options instead of an optionType.

        另请参见：
        Constant Field Values

      • YES_NO_OPTION

        public static final int YES_NO_OPTION
        YES/NO confirmation option.

        An underlying security service specifies this as the optionType to a ConfirmationCallback constructor if it requires a confirmation which can be answered with either YES or NO.

        另请参见：
        Constant Field Values

      • YES_NO_CANCEL_OPTION

        public static final int YES_NO_CANCEL_OPTION
        YES/NO/CANCEL confirmation confirmation option.

        An underlying security service specifies this as the optionType to a ConfirmationCallback constructor if it requires a confirmation which can be answered with either YES, NO or CANCEL.

        另请参见：
        Constant Field Values

      • OK_CANCEL_OPTION

        public static final int OK_CANCEL_OPTION
        OK/CANCEL confirmation confirmation option.

        An underlying security service specifies this as the optionType to a ConfirmationCallback constructor if it requires a confirmation which can be answered with either OK or CANCEL.

        另请参见：
        Constant Field Values

      • YES

        public static final int YES
        YES option.

        If an optionType was specified to this ConfirmationCallback, this option may be specified as a defaultOption or returned as the selected index.

        另请参见：
        Constant Field Values

      • NO

        public static final int NO
        NO option.

        If an optionType was specified to this ConfirmationCallback, this option may be specified as a defaultOption or returned as the selected index.

        另请参见：
        Constant Field Values

      • CANCEL

        public static final int CANCEL
        CANCEL option.

        If an optionType was specified to this ConfirmationCallback, this option may be specified as a defaultOption or returned as the selected index.

        另请参见：
        Constant Field Values

      • OK

        public static final int OK
        OK option.

        If an optionType was specified to this ConfirmationCallback, this option may be specified as a defaultOption or returned as the selected index.

        另请参见：
        Constant Field Values

      • INFORMATION

        public static final int INFORMATION
        INFORMATION message type.
        另请参见：
        Constant Field Values

      • WARNING

        public static final int WARNING
        WARNING message type.
        另请参见：
        Constant Field Values

      • ERROR

        public static final int ERROR
        ERROR message type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ConfirmationCallback

        public ConfirmationCallback(int messageType,
                    int optionType,
                    int defaultOption)
        Construct a ConfirmationCallback with a message type, an option type and a default option.

        Underlying security services use this constructor if they require either a YES/NO, YES/NO/CANCEL or OK/CANCEL confirmation.

        参数：
        messageType - the message type (INFORMATION, WARNING or ERROR).

        optionType - the option type (YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION).

        defaultOption - the default option from the provided optionType (YES, NO, CANCEL or OK).
        抛出：
        IllegalArgumentException - if messageType is not either INFORMATION, WARNING, or ERROR, if optionType is not either YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION, or if defaultOption does not correspond to one of the options in optionType.

      • ConfirmationCallback

        public ConfirmationCallback(int messageType,
                    String[] options,
                    int defaultOption)
        Construct a ConfirmationCallback with a message type, a list of options and a default option.

        Underlying security services use this constructor if they require a confirmation different from the available preset confirmations provided (for example, CONTINUE/ABORT or STOP/GO). The confirmation options are listed in the options array, and are displayed by the CallbackHandler implementation in a manner consistent with the way preset options are displayed.

        参数：
        messageType - the message type (INFORMATION, WARNING or ERROR).

        options - the list of confirmation options.

        defaultOption - the default option, represented as an index into the options array.
        抛出：
        IllegalArgumentException - if messageType is not either INFORMATION, WARNING, or ERROR, if options is null, if options has a length of 0, if any element from options is null, if any element from options has a length of 0, or if defaultOption does not lie within the array boundaries of options.

      • ConfirmationCallback

        public ConfirmationCallback(String prompt,
                    int messageType,
                    int optionType,
                    int defaultOption)
        Construct a ConfirmationCallback with a prompt, message type, an option type and a default option.

        Underlying security services use this constructor if they require either a YES/NO, YES/NO/CANCEL or OK/CANCEL confirmation.

        参数：
        prompt - the prompt used to describe the list of options.

        messageType - the message type (INFORMATION, WARNING or ERROR).

        optionType - the option type (YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION).

        defaultOption - the default option from the provided optionType (YES, NO, CANCEL or OK).
        抛出：
        IllegalArgumentException - if prompt is null, if prompt has a length of 0, if messageType is not either INFORMATION, WARNING, or ERROR, if optionType is not either YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION, or if defaultOption does not correspond to one of the options in optionType.

      • ConfirmationCallback

        public ConfirmationCallback(String prompt,
                    int messageType,
                    String[] options,
                    int defaultOption)
        Construct a ConfirmationCallback with a prompt, message type, a list of options and a default option.

        Underlying security services use this constructor if they require a confirmation different from the available preset confirmations provided (for example, CONTINUE/ABORT or STOP/GO). The confirmation options are listed in the options array, and are displayed by the CallbackHandler implementation in a manner consistent with the way preset options are displayed.

        参数：
        prompt - the prompt used to describe the list of options.

        messageType - the message type (INFORMATION, WARNING or ERROR).

        options - the list of confirmation options.

        defaultOption - the default option, represented as an index into the options array.
        抛出：
        IllegalArgumentException - if prompt is null, if prompt has a length of 0, if messageType is not either INFORMATION, WARNING, or ERROR, if options is null, if options has a length of 0, if any element from options is null, if any element from options has a length of 0, or if defaultOption does not lie within the array boundaries of options.

    • 方法详细信息

      • getPrompt

        public String getPrompt()
        Get the prompt.

        返回：
        the prompt, or null if this ConfirmationCallback was instantiated without a prompt.

      • getMessageType

        public int getMessageType()
        Get the message type.

        返回：
        the message type (INFORMATION, WARNING or ERROR).

      • getOptionType

        public int getOptionType()
        Get the option type.

        If this method returns UNSPECIFIED_OPTION, then this ConfirmationCallback was instantiated with options instead of an optionType. In this case, invoke the getOptions method to determine which confirmation options to display.

        返回：
        the option type (YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION), or UNSPECIFIED_OPTION if this ConfirmationCallback was instantiated with options instead of an optionType.

      • getOptions

        public String[] getOptions()
        Get the confirmation options.

        返回：
        the list of confirmation options, or null if this ConfirmationCallback was instantiated with an optionType instead of options.

      • getDefaultOption

        public int getDefaultOption()
        Get the default option.

        返回：
        the default option, represented as YES, NO, OK or CANCEL if an optionType was specified to the constructor of this ConfirmationCallback. Otherwise, this method returns the default option as an index into the options array specified to the constructor of this ConfirmationCallback.

      • setSelectedIndex

        public void setSelectedIndex(int selection)
        Set the selected confirmation option.

        参数：
        selection - the selection represented as YES, NO, OK or CANCEL if an optionType was specified to the constructor of this ConfirmationCallback. Otherwise, the selection represents the index into the options array specified to the constructor of this ConfirmationCallback.
        另请参见：
        getSelectedIndex()

      • getSelectedIndex

        public int getSelectedIndex()
        Get the selected confirmation option.

        返回：
        the selected confirmation option represented as YES, NO, OK or CANCEL if an optionType was specified to the constructor of this ConfirmationCallback. Otherwise, this method returns the selected confirmation option as an index into the options array specified to the constructor of this ConfirmationCallback.
        另请参见：
        setSelectedIndex(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.security.auth.callback

Interfaces

  • Callback
  • CallbackHandler

Classes

  • ChoiceCallback
  • ConfirmationCallback
  • LanguageCallback
  • NameCallback
  • PasswordCallback
  • TextInputCallback
  • TextOutputCallback

Exceptions

  • UnsupportedCallbackException
l


javax.security.auth.callback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth.callback

This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).

请参见： 描述

  • 接口摘要
    接口 描述
    Callback
    Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.
    CallbackHandler
    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
  • Class Summary
    类 描述
    ChoiceCallback
    Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).
    ConfirmationCallback
    Underlying security services instantiate and pass a ConfirmationCallback to the handle method of a CallbackHandler to ask for YES/NO, OK/CANCEL, YES/NO/CANCEL or other similar confirmations.
    LanguageCallback
    Underlying security services instantiate and pass a LanguageCallback to the handle method of a CallbackHandler to retrieve the Locale used for localizing text.
    NameCallback
    Underlying security services instantiate and pass a NameCallback to the handle method of a CallbackHandler to retrieve name information.
    PasswordCallback
    Underlying security services instantiate and pass a PasswordCallback to the handle method of a CallbackHandler to retrieve password information.
    TextInputCallback
    Underlying security services instantiate and pass a TextInputCallback to the handle method of a CallbackHandler to retrieve generic text information.
    TextOutputCallback
    Underlying security services instantiate and pass a TextOutputCallback to the handle method of a CallbackHandler to display information messages, warning messages and error messages.
  • Exception Summary
    Exception 描述
    UnsupportedCallbackException
    Signals that a CallbackHandler does not recognize a particular Callback.

软件包 javax.security.auth.callback Description

This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).
从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g>n bslosaslls ""ossblm


javax.security.auth.callback Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth.callback

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.ConfirmationCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.LanguageCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.NameCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.PasswordCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.TextOutputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.auth.callback.UnsupportedCallbackException

Interface Hierarchy

  • javax.security.auth.callback.Callback
  • javax.security.auth.callback.CallbackHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vn"=vad


LanguageCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 LanguageCallback

  • java.lang.Object
    • javax.security.auth.callback.LanguageCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class LanguageCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a LanguageCallback to the handle method of a CallbackHandler to retrieve the Locale used for localizing text.

    另请参见：
    CallbackHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      LanguageCallback()
      Construct a LanguageCallback.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Locale getLocale()
      Get the retrieved Locale.
      void setLocale(Locale locale)
      Set the retrieved Locale.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LanguageCallback

        public LanguageCallback()
        Construct a LanguageCallback.

    • 方法详细信息

      • setLocale

        public void setLocale(Locale locale)
        Set the retrieved Locale.

        参数：
        locale - the retrieved Locale.
        另请参见：
        getLocale()

      • getLocale

        public Locale getLocale()
        Get the retrieved Locale.

        返回：
        the retrieved Locale, or null if no Locale could be retrieved.
        另请参见：
        setLocale(java.util.Locale)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NameCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 NameCallback

  • java.lang.Object
    • javax.security.auth.callback.NameCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class NameCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a NameCallback to the handle method of a CallbackHandler to retrieve name information.

    另请参见：
    CallbackHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameCallback(String prompt)
      Construct a NameCallback with a prompt.
      NameCallback(String prompt, String defaultName)
      Construct a NameCallback with a prompt and default name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDefaultName()
      Get the default name.
      String getName()
      Get the retrieved name.
      String getPrompt()
      Get the prompt.
      void setName(String name)
      Set the retrieved name.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameCallback

        public NameCallback(String prompt)
        Construct a NameCallback with a prompt.

        参数：
        prompt - the prompt used to request the name.
        抛出：
        IllegalArgumentException - if prompt is null or if prompt has a length of 0.

      • NameCallback

        public NameCallback(String prompt,
            String defaultName)
        Construct a NameCallback with a prompt and default name.

        参数：
        prompt - the prompt used to request the information.

        defaultName - the name to be used as the default name displayed with the prompt.
        抛出：
        IllegalArgumentException - if prompt is null, if prompt has a length of 0, if defaultName is null, or if defaultName has a length of 0.

    • 方法详细信息

      • getPrompt

        public String getPrompt()
        Get the prompt.

        返回：
        the prompt.

      • getDefaultName

        public String getDefaultName()
        Get the default name.

        返回：
        the default name, or null if this NameCallback was not instantiated with a defaultName.

      • setName

        public void setName(String name)
        Set the retrieved name.

        参数：
        name - the retrieved name (which may be null).
        另请参见：
        getName()

      • getName

        public String getName()
        Get the retrieved name.

        返回：
        the retrieved name (which may be null)
        另请参见：
        setName(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iV TRv=====> AAu lg/<i.


PasswordCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 PasswordCallback

  • java.lang.Object
    • javax.security.auth.callback.PasswordCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class PasswordCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a PasswordCallback to the handle method of a CallbackHandler to retrieve password information.

    另请参见：
    CallbackHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PasswordCallback(String prompt, boolean echoOn)
      Construct a PasswordCallback with a prompt and a boolean specifying whether the password should be displayed as it is being typed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void clearPassword()
      Clear the retrieved password.
      char[] getPassword()
      Get the retrieved password.
      String getPrompt()
      Get the prompt.
      boolean isEchoOn()
      Return whether the password should be displayed as it is being typed.
      void setPassword(char[] password)
      Set the retrieved password.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PasswordCallback

        public PasswordCallback(String prompt,
                boolean echoOn)
        Construct a PasswordCallback with a prompt and a boolean specifying whether the password should be displayed as it is being typed.

        参数：
        prompt - the prompt used to request the password.

        echoOn - true if the password should be displayed as it is being typed.
        抛出：
        IllegalArgumentException - if prompt is null or if prompt has a length of 0.

    • 方法详细信息

      • getPrompt

        public String getPrompt()
        Get the prompt.

        返回：
        the prompt.

      • isEchoOn

        public boolean isEchoOn()
        Return whether the password should be displayed as it is being typed.

        返回：
        the whether the password should be displayed as it is being typed.

      • setPassword

        public void setPassword(char[] password)
        Set the retrieved password.

        This method makes a copy of the input password before storing it.

        参数：
        password - the retrieved password, which may be null.
        另请参见：
        getPassword()

      • getPassword

        public char[] getPassword()
        Get the retrieved password.

        This method returns a copy of the retrieved password.

        返回：
        the retrieved password, which may be null.
        另请参见：
        setPassword(char[])

      • clearPassword

        public void clearPassword()
        Clear the retrieved password.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

smt/dl_lnli>ons赶s排>/p� s


TextInputCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 TextInputCallback

  • java.lang.Object
    • javax.security.auth.callback.TextInputCallback
  • 所有已实现的接口：
    Serializable, Callback
    直接已知子类：
    RealmCallback

    public class TextInputCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a TextInputCallback to the handle method of a CallbackHandler to retrieve generic text information.

    另请参见：
    CallbackHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TextInputCallback(String prompt)
      Construct a TextInputCallback with a prompt.
      TextInputCallback(String prompt, String defaultText)
      Construct a TextInputCallback with a prompt and default input value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDefaultText()
      Get the default text.
      String getPrompt()
      Get the prompt.
      String getText()
      Get the retrieved text.
      void setText(String text)
      Set the retrieved text.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TextInputCallback

        public TextInputCallback(String prompt)
        Construct a TextInputCallback with a prompt.

        参数：
        prompt - the prompt used to request the information.
        抛出：
        IllegalArgumentException - if prompt is null or if prompt has a length of 0.

      • TextInputCallback

        public TextInputCallback(String prompt,
                 String defaultText)
        Construct a TextInputCallback with a prompt and default input value.

        参数：
        prompt - the prompt used to request the information.

        defaultText - the text to be used as the default text displayed with the prompt.
        抛出：
        IllegalArgumentException - if prompt is null, if prompt has a length of 0, if defaultText is null or if defaultText has a length of 0.

    • 方法详细信息

      • getPrompt

        public String getPrompt()
        Get the prompt.

        返回：
        the prompt.

      • getDefaultText

        public String getDefaultText()
        Get the default text.

        返回：
        the default text, or null if this TextInputCallback was not instantiated with defaultText.

      • setText

        public void setText(String text)
        Set the retrieved text.

        参数：
        text - the retrieved text, which may be null.
        另请参见：
        getText()

      • getText

        public String getText()
        Get the retrieved text.

        返回：
        the retrieved text, which may be null.
        另请参见：
        setText(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.=< <><>il >iu纎Ts>//<<鲻l>dall=;


TextOutputCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 TextOutputCallback

  • java.lang.Object
    • javax.security.auth.callback.TextOutputCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class TextOutputCallback
extends Object
implements Callback, Serializable

    Underlying security services instantiate and pass a TextOutputCallback to the handle method of a CallbackHandler to display information messages, warning messages and error messages.

    另请参见：
    CallbackHandler, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ERROR
      Error message.
      static int INFORMATION
      Information message.
      static int WARNING
      Warning message.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TextOutputCallback(int messageType, String message)
      Construct a TextOutputCallback with a message type and message to be displayed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getMessage()
      Get the message to be displayed.
      int getMessageType()
      Get the message type.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • INFORMATION

        public static final int INFORMATION
        Information message.
        另请参见：
        Constant Field Values

      • WARNING

        public static final int WARNING
        Warning message.
        另请参见：
        Constant Field Values

      • ERROR

        public static final int ERROR
        Error message.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TextOutputCallback

        public TextOutputCallback(int messageType,
                  String message)
        Construct a TextOutputCallback with a message type and message to be displayed.

        参数：
        messageType - the message type (INFORMATION, WARNING or ERROR).

        message - the message to be displayed.

        抛出：
        IllegalArgumentException - if messageType is not either INFORMATION, WARNING or ERROR, if message is null, or if message has a length of 0.

    • 方法详细信息

      • getMessageType

        public int getMessageType()
        Get the message type.

        返回：
        the message type (INFORMATION, WARNING or ERROR).

      • getMessage

        public String getMessage()
        Get the message to be displayed.

        返回：
        the message to be displayed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tupeeter=htt/hass==i


UnsupportedCallbackException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.callback

类 UnsupportedCallbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.auth.callback.UnsupportedCallbackException
  • 所有已实现的接口：
    Serializable

    public class UnsupportedCallbackException
extends Exception
    Signals that a CallbackHandler does not recognize a particular Callback.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnsupportedCallbackException(Callback callback)
      Constructs a UnsupportedCallbackException with no detail message.
      UnsupportedCallbackException(Callback callback, String msg)
      Constructs a UnsupportedCallbackException with the specified detail message.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Callback getCallback()
      Get the unrecognized Callback.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnsupportedCallbackException

        public UnsupportedCallbackException(Callback callback)
        Constructs a UnsupportedCallbackException with no detail message.

        参数：
        callback - the unrecognized Callback.

      • UnsupportedCallbackException

        public UnsupportedCallbackException(Callback callback,
                            String msg)
        Constructs a UnsupportedCallbackException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        callback - the unrecognized Callback.

        msg - the detail message.

    • 方法详细信息

      • getCallback

        public Callback getCallback()
        Get the unrecognized Callback.

        返回：
        the unrecognized Callback.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" atat"t=ts d="ldvuuiif


Uses of Package javax.security.auth.callback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth.callback

  • Packages that use javax.security.auth.callback
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.callback
    This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.
    javax.security.sasl
    Contains class and interfaces for supporting SASL.
  • Classes in javax.security.auth.callback used by java.security
    类与描述
    CallbackHandler
    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
  • Classes in javax.security.auth.callback used by javax.security.auth.callback
    类与描述
    Callback
    Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.
    UnsupportedCallbackException
    Signals that a CallbackHandler does not recognize a particular Callback.
  • Classes in javax.security.auth.callback used by javax.security.auth.login
    类与描述
    CallbackHandler
    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
  • Classes in javax.security.auth.callback used by javax.security.auth.spi
    类与描述
    CallbackHandler
    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
  • Classes in javax.security.auth.callback used by javax.security.sasl
    类与描述
    Callback
    Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.
    CallbackHandler
    An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
    ChoiceCallback
    Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).
    TextInputCallback
    Underlying security services instantiate and pass a TextInputCallback to the handle method of a CallbackHandler to retrieve generic text information.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.yaenaeivnnehand">t=ca


Uses of Class javax.security.auth.callback.ChoiceCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.ChoiceCallback

  • Packages that use ChoiceCallback
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of ChoiceCallback in javax.security.sasl

      Subclasses of ChoiceCallback in javax.security.sasl
      修饰符与类型 类与描述
      class  RealmChoiceCallback
      This callback is used by SaslClient and SaslServer to obtain a realm given a list of realm choices.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>fitmlelrrraahhc


Uses of Class javax.security.auth.callback.ConfirmationCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.ConfirmationCallback

No usage of javax.security.auth.callback.ConfirmationCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

heob/caa/uuuia.. ae/


Uses of Class javax.security.auth.callback.LanguageCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.LanguageCallback

No usage of javax.security.auth.callback.LanguageCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-emotsn>sl>g/s


Uses of Class javax.security.auth.callback.NameCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.NameCallback

No usage of javax.security.auth.callback.NameCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-gmotsn>sl>g/s


Uses of Class javax.security.auth.callback.PasswordCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.PasswordCallback

No usage of javax.security.auth.callback.PasswordCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nrba溫tsit.豯.i乨g


Uses of Class javax.security.auth.callback.TextInputCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.TextInputCallback

  • Packages that use TextInputCallback
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of TextInputCallback in javax.security.sasl

      Subclasses of TextInputCallback in javax.security.sasl
      修饰符与类型 类与描述
      class  RealmCallback
      This callback is used by SaslClient and SaslServer to retrieve realm information.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r t9bcey>rJ=arsond/j.i�


Uses of Class javax.security.auth.callback.TextOutputCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.TextOutputCallback

No usage of javax.security.auth.callback.TextOutputCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//j/../"=...r<鞍mii/<


Uses of Class javax.security.auth.callback.UnsupportedCallbackException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.callback.UnsupportedCallbackException

  • Packages that use UnsupportedCallbackException
    软件包 描述
    javax.security.auth.callback
    This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).

    • Uses of UnsupportedCallbackException in javax.security.auth.callback

      Methods in javax.security.auth.callback that throw UnsupportedCallbackException
      修饰符与类型 方法与描述
      void CallbackHandler.handle(Callback[] callbacks)
      Retrieve or display the information requested in the provided Callbacks.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ei a


Uses of Interface javax.security.auth.callback.Callback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.callback.Callback

  • Packages that use Callback
    软件包 描述
    javax.security.auth.callback
    This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of Callback in javax.security.auth.callback

      Classes in javax.security.auth.callback that implement Callback
      修饰符与类型 类与描述
      class  ChoiceCallback
      Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).
      class  ConfirmationCallback
      Underlying security services instantiate and pass a ConfirmationCallback to the handle method of a CallbackHandler to ask for YES/NO, OK/CANCEL, YES/NO/CANCEL or other similar confirmations.
      class  LanguageCallback
      Underlying security services instantiate and pass a LanguageCallback to the handle method of a CallbackHandler to retrieve the Locale used for localizing text.
      class  NameCallback
      Underlying security services instantiate and pass a NameCallback to the handle method of a CallbackHandler to retrieve name information.
      class  PasswordCallback
      Underlying security services instantiate and pass a PasswordCallback to the handle method of a CallbackHandler to retrieve password information.
      class  TextInputCallback
      Underlying security services instantiate and pass a TextInputCallback to the handle method of a CallbackHandler to retrieve generic text information.
      class  TextOutputCallback
      Underlying security services instantiate and pass a TextOutputCallback to the handle method of a CallbackHandler to display information messages, warning messages and error messages.
      Methods in javax.security.auth.callback that return Callback
      修饰符与类型 方法与描述
      Callback UnsupportedCallbackException.getCallback()
      Get the unrecognized Callback.
      Methods in javax.security.auth.callback with parameters of type Callback
      修饰符与类型 方法与描述
      void CallbackHandler.handle(Callback[] callbacks)
      Retrieve or display the information requested in the provided Callbacks.
      Constructors in javax.security.auth.callback with parameters of type Callback
      构造方法与描述
      UnsupportedCallbackException(Callback callback)
      Constructs a UnsupportedCallbackException with no detail message.
      UnsupportedCallbackException(Callback callback, String msg)
      Constructs a UnsupportedCallbackException with the specified detail message.

    • Uses of Callback in javax.security.sasl

      Classes in javax.security.sasl that implement Callback
      修饰符与类型 类与描述
      class  AuthorizeCallback
      This callback is used by SaslServer to determine whether one entity (identified by an authenticated authentication id) can act on behalf of another entity (identified by an authorization id).
      class  RealmCallback
      This callback is used by SaslClient and SaslServer to retrieve realm information.
      class  RealmChoiceCallback
      This callback is used by SaslClient and SaslServer to obtain a realm given a list of realm choices.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aamno=crd>a �< a


Uses of Interface javax.security.auth.callback.CallbackHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.callback.CallbackHandler

  • Packages that use CallbackHandler
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of CallbackHandler in java.security

      Methods in java.security that return CallbackHandler
      修饰符与类型 方法与描述
      CallbackHandler KeyStore.CallbackHandlerProtection.getCallbackHandler()
      Returns the CallbackHandler.
      Methods in java.security with parameters of type CallbackHandler
      修饰符与类型 方法与描述
      abstract void AuthProvider.login(Subject subject, CallbackHandler handler)
      Log in to this provider.
      abstract void AuthProvider.setCallbackHandler(CallbackHandler handler)
      Set a CallbackHandler.
      Constructors in java.security with parameters of type CallbackHandler
      构造方法与描述
      KeyStore.CallbackHandlerProtection(CallbackHandler handler)
      Constructs a new CallbackHandlerProtection from a CallbackHandler.

    • Uses of CallbackHandler in javax.security.auth.login

      Constructors in javax.security.auth.login with parameters of type CallbackHandler
      构造方法与描述
      LoginContext(String name, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name and a CallbackHandler object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.

    • Uses of CallbackHandler in javax.security.auth.spi

      Methods in javax.security.auth.spi with parameters of type CallbackHandler
      修饰符与类型 方法与描述
      void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      Initialize this LoginModule.

    • Uses of CallbackHandler in javax.security.sasl

      Methods in javax.security.sasl with parameters of type CallbackHandler
      修饰符与类型 方法与描述
      SaslClient SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      static SaslClient Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      SaslServer SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer using the parameters supplied.
      static SaslServer Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer for the specified mechanism.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=do=hlascsasa l/ke"s.�"


Uses of Class javax.security.auth.AuthPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.AuthPermission

No usage of javax.security.auth.AuthPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iOo armps=e.


Uses of Class javax.security.auth.DestroyFailedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.DestroyFailedException

  • Packages that use DestroyFailedException
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth
    This package provides a framework for authentication and authorization.
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.

    • Uses of DestroyFailedException in java.security

      Methods in java.security that throw DestroyFailedException
      修饰符与类型 方法与描述
      void KeyStore.PasswordProtection.destroy()
      Clears the password.

    • Uses of DestroyFailedException in javax.security.auth

      Methods in javax.security.auth that throw DestroyFailedException
      修饰符与类型 方法与描述
      void Destroyable.destroy()
      Destroy this Object.

    • Uses of DestroyFailedException in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that throw DestroyFailedException
      修饰符与类型 方法与描述
      void KerberosTicket.destroy()
      Destroys the ticket and destroys any sensitive information stored in it.
      void KerberosKey.destroy()
      Destroys this key.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A茺耍列粒擞ǎo衕b╮,,eb//


Uses of Class javax.security.auth.Policy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.Policy

  • Packages that use Policy
    软件包 描述
    javax.security.auth
    This package provides a framework for authentication and authorization.

    • Uses of Policy in javax.security.auth

      Methods in javax.security.auth that return Policy
      修饰符与类型 方法与描述
      static Policy Policy.getPolicy()
      Deprecated.
      Returns the installed Policy object.
      Methods in javax.security.auth with parameters of type Policy
      修饰符与类型 方法与描述
      static void Policy.setPolicy(Policy policy)
      Deprecated.
      Sets the system-wide Policy object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

! tar_n"aaamvssdB-d!== c


Uses of Class javax.security.auth.PrivateCredentialPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.PrivateCredentialPermission

No usage of javax.security.auth.PrivateCredentialPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.ooassdt >l<


Uses of Class javax.security.auth.RefreshFailedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.RefreshFailedException

  • Packages that use RefreshFailedException
    软件包 描述
    javax.security.auth
    This package provides a framework for authentication and authorization.
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.

    • Uses of RefreshFailedException in javax.security.auth

      Methods in javax.security.auth that throw RefreshFailedException
      修饰符与类型 方法与描述
      void Refreshable.refresh()
      Update or extend the validity period for this Object.

    • Uses of RefreshFailedException in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that throw RefreshFailedException
      修饰符与类型 方法与描述
      void KerberosTicket.refresh()
      Extends the validity period of this ticket.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ha.te/psel�//l"o sxrl/


Uses of Class javax.security.auth.Subject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.Subject

  • Packages that use Subject
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.management.remote
    Interfaces for remote access to JMX MBean servers.
    javax.management.remote.rmi
    The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
    javax.security.auth
    This package provides a framework for authentication and authorization.
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.

    • Uses of Subject in java.security

      Methods in java.security with parameters of type Subject
      修饰符与类型 方法与描述
      abstract void AuthProvider.login(Subject subject, CallbackHandler handler)
      Log in to this provider.

    • Uses of Subject in javax.management.remote

      Methods in javax.management.remote that return Subject
      修饰符与类型 方法与描述
      Subject JMXAuthenticator.authenticate(Object credentials)
      Authenticates the MBeanServerConnection client with the given client credentials.
      Methods in javax.management.remote with parameters of type Subject
      修饰符与类型 方法与描述
      MBeanServerConnection JMXConnector.getMBeanServerConnection(Subject delegationSubject)
      Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.

    • Uses of Subject in javax.management.remote.rmi

      Methods in javax.management.remote.rmi with parameters of type Subject
      修饰符与类型 | 方法与描述
      void | RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      Integer[] | RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
      Integer[] | RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
      Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
      ObjectInstance | RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      ObjectInstance | RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.createMBean(String, ObjectName).
      Object | RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      Object | RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttribute(ObjectName, String).
      AttributeList | RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).
      String | RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)
      String | RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)
      String RMIConnection.getDefaultDomain(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDefaultDomain().
      String[] | RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)
      String[] | RMIConnectionImpl.getDomains(Subject delegationSubject)
      String[] RMIConnection.getDomains(Subject delegationSubject)
      Handles the method MBeanServerConnection.getDomains().
      Integer | RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)
      Integer | RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
      Integer RMIConnection.getMBeanCount(Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanCount().
      MBeanInfo | RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      MBeanInfo | RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
      MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).
      MBeanServerConnection | RMIConnector.getMBeanServerConnection(Subject delegationSubject)
      ObjectInstance | RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      ObjectInstance | RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
      ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.getObjectInstance(ObjectName).
      Object | RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
      Object | RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
      Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
      boolean | RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
      boolean | RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
      Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
      boolean | RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      boolean | RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
      boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.isRegistered(ObjectName).
      protected RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through IIOP.
      protected RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection as an RMI object exported through JRMP.
      protected abstract RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
      Creates a new client connection.
      Set | RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectInstance> | RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
      Set | RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      Set<ObjectName> | RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
      Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
      void | RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
      void | RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
      void | RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
      Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
      void | RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
      Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
      void | RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      void | RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).
      AttributeList | RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
      AttributeList | RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
      Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).
      void | RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
      void | RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
      void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
      Handles the method MBeanServerConnection.unregisterMBean(ObjectName).
      Constructors in javax.management.remote.rmi with parameters of type Subject
      构造方法与描述
      RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
      Constructs a new RMIConnection.

    • Uses of Subject in javax.security.auth

      Methods in javax.security.auth that return Subject
      修饰符与类型 方法与描述
      Subject SubjectDomainCombiner.getSubject()
      Get the Subject associated with this SubjectDomainCombiner.
      static Subject Subject.getSubject(AccessControlContext acc)
      Get the Subject associated with the provided AccessControlContext.
      Methods in javax.security.auth with parameters of type Subject
      修饰符与类型 方法与描述
      static <T> T Subject.doAs(Subject subject, PrivilegedAction<T> action)
      Perform work as a particular Subject.
      static <T> T Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
      Perform work as a particular Subject.
      static <T> T Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
      Perform privileged work as a particular Subject.
      static <T> T Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
      Perform privileged work as a particular Subject.
      abstract PermissionCollection Policy.getPermissions(Subject subject, CodeSource cs)
      Deprecated.
      Retrieve the Permissions granted to the Principals associated with the specified CodeSource.
      Constructors in javax.security.auth with parameters of type Subject
      构造方法与描述
      SubjectDomainCombiner(Subject subject)
      Associate the provided Subject with this SubjectDomainCombiner.

    • Uses of Subject in javax.security.auth.login

      Methods in javax.security.auth.login that return Subject
      修饰符与类型 方法与描述
      Subject LoginContext.getSubject()
      Return the authenticated Subject.
      Constructors in javax.security.auth.login with parameters of type Subject
      构造方法与描述
      LoginContext(String name, Subject subject)
      Instantiate a new LoginContext object with a name and a Subject object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.

    • Uses of Subject in javax.security.auth.spi

      Methods in javax.security.auth.spi with parameters of type Subject
      修饰符与类型 方法与描述
      void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      Initialize this LoginModule.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.security.auth.SubjectDomainCombiner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.SubjectDomainCombiner

No usage of javax.security.auth.SubjectDomainCombiner
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ht/cvax..///.=tta.i/h


Uses of Interface javax.security.auth.Destroyable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.Destroyable

  • Packages that use Destroyable
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.
    javax.security.auth.x500
    This package contains the classes that should be used to store X500 Principal and X500 Private Crendentials in a Subject.

    • Uses of Destroyable in java.security

      Classes in java.security that implement Destroyable
      修饰符与类型 类与描述
      static class  KeyStore.PasswordProtection
      A password-based implementation of ProtectionParameter.

    • Uses of Destroyable in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Destroyable
      修饰符与类型 类与描述
      class  KerberosKey
      This class encapsulates a long term secret key for a Kerberos principal.
      class  KerberosTicket
      This class encapsulates a Kerberos ticket and associated information as viewed from the client's point of view.

    • Uses of Destroyable in javax.security.auth.x500

      Classes in javax.security.auth.x500 that implement Destroyable
      修饰符与类型 类与描述
      class  X500PrivateCredential
      This class represents an X500PrivateCredential.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>a">"eN>sn�


Uses of Interface javax.security.auth.Refreshable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.Refreshable

  • Packages that use Refreshable
    软件包 描述
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.

    • Uses of Refreshable in javax.security.auth.kerberos

      Classes in javax.security.auth.kerberos that implement Refreshable
      修饰符与类型 类与描述
      class  KerberosTicket
      This class encapsulates a Kerberos ticket and associated information as viewed from the client's point of view.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b"l


DelegationPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.kerberos

类 DelegationPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.security.auth.kerberos.DelegationPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class DelegationPermission
extends BasicPermission
implements Serializable
    This class is used to restrict the usage of the Kerberos delegation model, ie: forwardable and proxiable tickets.

    The target name of this Permission specifies a pair of kerberos service principals. The first is the subordinate service principal being entrusted to use the TGT. The second service principal designates the target service the subordinate service principal is to interact with on behalf of the initiating KerberosPrincipal. This latter service principal is specified to restrict the use of a proxiable ticket.

    For example, to specify the "host" service use of a forwardable TGT the target permission is specified as follows:

      DelegationPermission("\"host/foo.example.com@EXAMPLE.COM\" \"krbtgt/EXAMPLE.COM@EXAMPLE.COM\"");

    To give the "backup" service a proxiable nfs service ticket the target permission might be specified:

      DelegationPermission("\"backup/bar.example.com@EXAMPLE.COM\" \"nfs/home.EXAMPLE.COM@EXAMPLE.COM\"");
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DelegationPermission(String principals)
      Create a new DelegationPermission with the specified subordinate and target principals.
      DelegationPermission(String principals, String actions)
      Create a new DelegationPermission with the specified subordinate and target principals.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Checks two DelegationPermission objects for equality.
      int hashCode()
      Returns the hash code value for this object.
      boolean implies(Permission p)
      Checks if this Kerberos delegation permission object "implies" the specified permission.
      PermissionCollection newPermissionCollection()
      Returns a PermissionCollection object for storing DelegationPermission objects.

      • 方法 - 继承于类 java.security.BasicPermission

        getActions

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DelegationPermission

        public DelegationPermission(String principals)
        Create a new DelegationPermission with the specified subordinate and target principals.

        参数：
        principals - the name of the subordinate and target principals
        抛出：
        NullPointerException - if principals is null.
        IllegalArgumentException - if principals is empty.

      • DelegationPermission

        public DelegationPermission(String principals,
                    String actions)
        Create a new DelegationPermission with the specified subordinate and target principals.

        参数：
        principals - the name of the subordinate and target principals

        actions - should be null.
        抛出：
        NullPointerException - if principals is null.
        IllegalArgumentException - if principals is empty.

    • 方法详细信息

      • implies

        public boolean implies(Permission p)
        Checks if this Kerberos delegation permission object "implies" the specified permission.

        If none of the above are true, implies returns false.

        重载：
        implies in class BasicPermission
        参数：
        p - the permission to check against.
        返回：
        true if the specified permission is implied by this object, false if not.

      • equals

        public boolean equals(Object obj)
        Checks two DelegationPermission objects for equality.

        重载：
        equals in class BasicPermission
        参数：
        obj - the object to test for equality with this object.
        返回：
        true if obj is a DelegationPermission, and has the same subordinate and service principal as this. DelegationPermission object.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this object.
        重载：
        hashCode in class BasicPermission
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • newPermissionCollection

        public PermissionCollection newPermissionCollection()
        Returns a PermissionCollection object for storing DelegationPermission objects.
        DelegationPermission objects must be stored in a manner that allows them to be inserted into the collection in any order, but that also enables the PermissionCollection implies method to be implemented in an efficient (and consistent) manner.
        重载：
        newPermissionCollection in class BasicPermission
        返回：
        a new PermissionCollection object suitable for storing DelegationPermissions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u� P s.sMold..rO/tletc


javax.security.auth.kerberos

Classes

  • DelegationPermission
  • KerberosKey
  • KerberosPrincipal
  • KerberosTicket
  • ServicePermission
"


javax.security.auth.kerberos

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth.kerberos

This package contains utility classes related to the Kerberos network authentication protocol.

请参见： 描述

  • Class Summary
    类 描述
    DelegationPermission
    This class is used to restrict the usage of the Kerberos delegation model, ie: forwardable and proxiable tickets.
    KerberosKey
    This class encapsulates a long term secret key for a Kerberos principal.
    KerberosPrincipal
    This class encapsulates a Kerberos principal.
    KerberosTicket
    This class encapsulates a Kerberos ticket and associated information as viewed from the client's point of view.
    ServicePermission
    This class is used to protect Kerberos services and the credentials necessary to access those services.

软件包 javax.security.auth.kerberos Description

This package contains utility classes related to the Kerberos network authentication protocol. They do not provide much Kerberos support themselves.

The Kerberos network authentication protocol is defined in RFC 4120. The Java platform contains support for the client side of Kerberos via the org.ietf.jgss package. There might also be a login module that implements LoginModule to authenticate Kerberos principals.

You can provide the name of your default realm and Key Distribution Center (KDC) host for that realm using the system properties java.security.krb5.realm and java.security.krb5.kdc. Alternatively, you can provide an MIT style configuration file called krb5.conf in <java-home>/lib/security. If you place this file elsewhere, you can indicate that location via the system property java.security.krb5.conf.

从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

adteva0t,ue..th


javax.security.auth.kerberos Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth.kerberos

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.kerberos.KerberosKey (implements javax.security.auth.Destroyable, javax.crypto.SecretKey)
    • javax.security.auth.kerberos.KerberosPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.kerberos.KerberosTicket (implements javax.security.auth.Destroyable, javax.security.auth.Refreshable, java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.security.auth.kerberos.DelegationPermission (implements java.io.Serializable)
      • javax.security.auth.kerberos.ServicePermission (implements java.io.Serializable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rCij=vxe/as/p>> t.".>


KerberosKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.kerberos

类 KerberosKey

  • java.lang.Object
    • javax.security.auth.kerberos.KerberosKey
  • 所有已实现的接口：
    Serializable, Key, SecretKey, Destroyable

    public class KerberosKey
extends Object
implements SecretKey, Destroyable
    This class encapsulates a long term secret key for a Kerberos principal.

    All Kerberos JAAS login modules that obtain a principal's password and generate the secret key from it should use this class. Where available, the login module might even read this secret key directly from a Kerberos "keytab". Sometimes, such as when authenticating a server in the absence of user-to-user authentication, the login module will store an instance of this class in the private credential set of a Subject during the commit phase of the authentication process.

    It might be necessary for the application to be granted a PrivateCredentialPermission if it needs to access the KerberosKey instance from a Subject. This permission is not needed when the application depends on the default JGSS Kerberos mechanism to access the KerberosKey. In that case, however, the application will need an appropriate ServicePermission.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      KerberosKey(KerberosPrincipal principal, byte[] keyBytes, int keyType, int versionNum)
      Constructs a KerberosKey from the given bytes when the key type and key version number are known.
      KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
      Constructs a KerberosKey from a principal's password.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      Destroys this key.
      boolean equals(Object other)
      Compares the specified Object with this KerberosKey for equality.
      String getAlgorithm()
      Returns the standard algorithm name for this key.
      byte[] getEncoded()
      Returns the key material of this secret key.
      String getFormat()
      Returns the name of the encoding format for this secret key.
      int getKeyType()
      Returns the key type for this long-term key.
      KerberosPrincipal getPrincipal()
      Returns the principal that this key belongs to.
      int getVersionNumber()
      Returns the key version number.
      int hashCode()
      Returns a hashcode for this KerberosKey.
      boolean isDestroyed()
      Determines if this key has been destroyed.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KerberosKey

        public KerberosKey(KerberosPrincipal principal,
           byte[] keyBytes,
           int keyType,
           int versionNum)
        Constructs a KerberosKey from the given bytes when the key type and key version number are known. This can be used when reading the secret key information from a Kerberos "keytab".
        参数：
        principal - the principal that this secret key belongs to
        keyBytes - the raw bytes for the secret key
        keyType - the key type for the secret key as defined by the Kerberos protocol specification.
        versionNum - the version number of this secret key

      • KerberosKey

        public KerberosKey(KerberosPrincipal principal,
           char[] password,
           String algorithm)
        Constructs a KerberosKey from a principal's password.
        参数：
        principal - the principal that this password belongs to
        password - the password that should be used to compute the key
        algorithm - the name for the algorithm that this key will be used for. This parameter may be null in which case the default algorithm "DES" will be assumed.
        抛出：
        IllegalArgumentException - if the name of the algorithm passed is unsupported.

    • 方法详细信息

      • getPrincipal

        public final KerberosPrincipal getPrincipal()
        Returns the principal that this key belongs to.
        返回：
        the principal this key belongs to.

      • getVersionNumber

        public final int getVersionNumber()
        Returns the key version number.
        返回：
        the key version number.

      • getKeyType

        public final int getKeyType()
        Returns the key type for this long-term key.
        返回：
        the key type.

      • getAlgorithm

        public final String getAlgorithm()
        Returns the standard algorithm name for this key. For example, "DES" would indicate that this key is a DES key. See Appendix A in the Java Cryptography Architecture API Specification & Reference for information about standard algorithm names.
        指定者：
        getAlgorithm in interface Key
        返回：
        the name of the algorithm associated with this key.

      • getFormat

        public final String getFormat()
        Returns the name of the encoding format for this secret key.
        指定者：
        getFormat in interface Key
        返回：
        the String "RAW"

      • getEncoded

        public final byte[] getEncoded()
        Returns the key material of this secret key.
        指定者：
        getEncoded in interface Key
        返回：
        the key material

      • destroy

        public void destroy()
             throws DestroyFailedException
        Destroys this key. A call to any of its other methods after this will cause an IllegalStateException to be thrown.
        指定者：
        destroy in interface Destroyable
        抛出：
        DestroyFailedException - if some error occurs while destorying this key.

      • isDestroyed

        public boolean isDestroyed()
        Determines if this key has been destroyed.
        指定者：
        isDestroyed in interface Destroyable
        返回：
        true if this Object has been destroyed, false otherwise.

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • hashCode

        public int hashCode()
        Returns a hashcode for this KerberosKey.
        重载：
        hashCode in class Object
        返回：
        a hashCode() for the KerberosKey
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object other)
        Compares the specified Object with this KerberosKey for equality. Returns true if the given object is also a KerberosKey and the two KerberosKey instances are equivalent.
        重载：
        equals in class Object
        参数：
        other - the Object to compare to
        返回：
        true if the specified object is equal to this KerberosKey, false otherwise. NOTE: Returns false if either of the KerberosKey objects has been destroyed.
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

birs&;/i ;p E;hnd}dh謘<->aaOp<>a籲<=g�/h


KerberosPrincipal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.kerberos

类 KerberosPrincipal

  • java.lang.Object
    • javax.security.auth.kerberos.KerberosPrincipal
  • 所有已实现的接口：
    Serializable, Principal

    public final class KerberosPrincipal
extends Object
implements Principal, Serializable
    This class encapsulates a Kerberos principal.
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int KRB_NT_PRINCIPAL
      user principal name type.
      static int KRB_NT_SRV_HST
      service with host name as instance (telnet, rcommands) name type.
      static int KRB_NT_SRV_INST
      service and other unique instance (krbtgt) name type.
      static int KRB_NT_SRV_XHST
      service with host as remaining components name type.
      static int KRB_NT_UID
      unique ID name type.
      static int KRB_NT_UNKNOWN
      unknown name type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      KerberosPrincipal(String name)
      Constructs a KerberosPrincipal from the provided string input.
      KerberosPrincipal(String name, int nameType)
      Constructs a KerberosPrincipal from the provided string and name type input.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object other)
      Compares the specified Object with this Principal for equality.
      String getName()
      The returned string corresponds to the single-string representation of a Kerberos Principal name as specified in Section 2.1 of RFC 1964.
      int getNameType()
      Returns the name type of the KerberosPrincipal.
      String getRealm()
      Returns the realm component of this Kerberos principal.
      int hashCode()
      Returns a hashcode for this principal.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • KRB_NT_UNKNOWN

        public static final int KRB_NT_UNKNOWN
        unknown name type.
        另请参见：
        Constant Field Values

      • KRB_NT_PRINCIPAL

        public static final int KRB_NT_PRINCIPAL
        user principal name type.
        另请参见：
        Constant Field Values

      • KRB_NT_SRV_INST

        public static final int KRB_NT_SRV_INST
        service and other unique instance (krbtgt) name type.
        另请参见：
        Constant Field Values

      • KRB_NT_SRV_HST

        public static final int KRB_NT_SRV_HST
        service with host name as instance (telnet, rcommands) name type.
        另请参见：
        Constant Field Values

      • KRB_NT_SRV_XHST

        public static final int KRB_NT_SRV_XHST
        service with host as remaining components name type.
        另请参见：
        Constant Field Values

      • KRB_NT_UID

        public static final int KRB_NT_UID
        unique ID name type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • KerberosPrincipal

        public KerberosPrincipal(String name)
        Constructs a KerberosPrincipal from the provided string input. The name type for this principal defaults to KRB_NT_PRINCIPAL This string is assumed to contain a name in the format that is specified in Section 2.1.1. (Kerberos Principal Name Form) of RFC 1964 (for example, duke@FOO.COM, where duke represents a principal, and FOO.COM represents a realm).

        If the input name does not contain a realm, the default realm is used. The default realm can be specified either in a Kerberos configuration file or via the java.security.krb5.realm system property. For more information, Kerberos Requirements

        参数：
        name - the principal name
        抛出：
        IllegalArgumentException - if name is improperly formatted, if name is null, or if name does not contain the realm to use and the default realm is not specified in either a Kerberos configuration file or via the java.security.krb5.realm system property.

      • KerberosPrincipal

        public KerberosPrincipal(String name,
                 int nameType)
        Constructs a KerberosPrincipal from the provided string and name type input. The string is assumed to contain a name in the format that is specified in Section 2.1 (Mandatory Name Forms) of RFC 1964. Valid name types are specified in Section 6.2 (Principal Names) of RFC 4120. The input name must be consistent with the provided name type. (for example, duke@FOO.COM, is a valid input string for the name type, KRB_NT_PRINCIPAL where duke represents a principal, and FOO.COM represents a realm).

        If the input name does not contain a realm, the default realm is used. The default realm can be specified either in a Kerberos configuration file or via the java.security.krb5.realm system property. For more information, see Kerberos Requirements.

        参数：
        name - the principal name
        nameType - the name type of the principal
        抛出：
        IllegalArgumentException - if name is improperly formatted, if name is null, if the nameType is not supported, or if name does not contain the realm to use and the default realm is not specified in either a Kerberos configuration file or via the java.security.krb5.realm system property.

    • 方法详细信息

      • getRealm

        public String getRealm()
        Returns the realm component of this Kerberos principal.
        返回：
        the realm component of this Kerberos principal.

      • hashCode

        public int hashCode()
        Returns a hashcode for this principal. The hash code is defined to be the result of the following calculation:

  hashCode = getName().hashCode();
        指定者：
        hashCode in interface Principal
        重载：
        hashCode in class Object
        返回：
        a hashCode() for the KerberosPrincipal
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object other)
        Compares the specified Object with this Principal for equality. Returns true if the given object is also a KerberosPrincipal and the two KerberosPrincipal instances are equivalent. More formally two KerberosPrincipal instances are equal if the values returned by getName() are equal and the values returned by getNameType() are equal.
        指定者：
        equals in interface Principal
        重载：
        equals in class Object
        参数：
        other - the Object to compare to
        返回：
        true if the Object passed in represents the same principal as this one, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getName

        public String getName()
        The returned string corresponds to the single-string representation of a Kerberos Principal name as specified in Section 2.1 of RFC 1964.
        指定者：
        getName in interface Principal
        返回：
        the principal name.

      • getNameType

        public int getNameType()
        Returns the name type of the KerberosPrincipal. Valid name types are specified in Section 6.2 of RFC4120.
        返回：
        the name type.

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        指定者：
        toString in interface Principal
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


KerberosTicket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.kerberos

类 KerberosTicket

  • java.lang.Object
    • javax.security.auth.kerberos.KerberosTicket
  • 所有已实现的接口：
    Serializable, Destroyable, Refreshable

    public class KerberosTicket
extends Object
implements Destroyable, Refreshable, Serializable
    This class encapsulates a Kerberos ticket and associated information as viewed from the client's point of view. It captures all information that the Key Distribution Center (KDC) sends to the client in the reply message KDC-REP defined in the Kerberos Protocol Specification (RFC 4120).

    All Kerberos JAAS login modules that authenticate a user to a KDC should use this class. Where available, the login module might even read this information from a ticket cache in the operating system instead of directly communicating with the KDC. During the commit phase of the JAAS authentication process, the JAAS login module should instantiate this class and store the instance in the private credential set of a Subject.

    It might be necessary for the application to be granted a PrivateCredentialPermission if it needs to access a KerberosTicket instance from a Subject. This permission is not needed when the application depends on the default JGSS Kerberos mechanism to access the KerberosTicket. In that case, however, the application will need an appropriate ServicePermission.

    Note that this class is applicable to both ticket granting tickets and other regular service tickets. A ticket granting ticket is just a special case of a more generalized service ticket.

    从以下版本开始：
    1.4
    另请参见：
    Subject, PrivateCredentialPermission, LoginContext, GSSCredential, GSSManager, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
      Constructs a KerberosTicket using credentials information that a client either receives from a KDC or reads from a cache.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      Destroys the ticket and destroys any sensitive information stored in it.
      boolean equals(Object other)
      Compares the specified Object with this KerberosTicket for equality.
      Date getAuthTime()
      Returns the time that the client was authenticated.
      KerberosPrincipal getClient()
      Returns the client principal associated with this ticket.
      InetAddress[] getClientAddresses()
      Returns a list of addresses from where the ticket can be used.
      byte[] getEncoded()
      Returns an ASN.1 encoding of the entire ticket.
      Date getEndTime()
      Returns the expiration time for this ticket's validity period.
      boolean[] getFlags()
      Returns the flags associated with this ticket.
      Date getRenewTill()
      Returns the latest expiration time for this ticket, including all renewals.
      KerberosPrincipal getServer()
      Returns the service principal associated with this ticket.
      SecretKey getSessionKey()
      Returns the session key associated with this ticket.
      int getSessionKeyType()
      Returns the key type of the session key associated with this ticket as defined by the Kerberos Protocol Specification.
      Date getStartTime()
      Returns the start time for this ticket's validity period.
      int hashCode()
      Returns a hashcode for this KerberosTicket.
      boolean isCurrent()
      Determines if this ticket is still current.
      boolean isDestroyed()
      Determines if this ticket has been destroyed.
      boolean isForwardable()
      Determines if this ticket is forwardable.
      boolean isForwarded()
      Determines if this ticket had been forwarded or was issued based on authentication involving a forwarded ticket-granting ticket.
      boolean isInitial()
      Determines if this ticket was issued using the Kerberos AS-Exchange protocol, and not issued based on some ticket-granting ticket.
      boolean isPostdated()
      Determines is this ticket is post-dated.
      boolean isProxiable()
      Determines if this ticket is proxiable.
      boolean isProxy()
      Determines is this ticket is a proxy-ticket.
      boolean isRenewable()
      Determines is this ticket is renewable.
      void refresh()
      Extends the validity period of this ticket.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KerberosTicket

        public KerberosTicket(byte[] asn1Encoding,
              KerberosPrincipal client,
              KerberosPrincipal server,
              byte[] sessionKey,
              int keyType,
              boolean[] flags,
              Date authTime,
              Date startTime,
              Date endTime,
              Date renewTill,
              InetAddress[] clientAddresses)
        Constructs a KerberosTicket using credentials information that a client either receives from a KDC or reads from a cache.
        参数：
        asn1Encoding - the ASN.1 encoding of the ticket as defined by the Kerberos protocol specification.
        client - the client that owns this service ticket
        server - the service that this ticket is for
        sessionKey - the raw bytes for the session key that must be used to encrypt the authenticator that will be sent to the server
        keyType - the key type for the session key as defined by the Kerberos protocol specification.
        flags - the ticket flags. Each element in this array indicates the value for the corresponding bit in the ASN.1 BitString that represents the ticket flags. If the number of elements in this array is less than the number of flags used by the Kerberos protocol, then the missing flags will be filled in with false.
        authTime - the time of initial authentication for the client
        startTime - the time after which the ticket will be valid. This may be null in which case the value of authTime is treated as the startTime.
        endTime - the time after which the ticket will no longer be valid
        renewTill - an absolute expiration time for the ticket, including all renewal that might be possible. This field may be null for tickets that are not renewable.
        clientAddresses - the addresses from where the ticket may be used by the client. This field may be null when the ticket is usable from any address.

    • 方法详细信息

      • getClient

        public final KerberosPrincipal getClient()
        Returns the client principal associated with this ticket.
        返回：
        the client principal.

      • getServer

        public final KerberosPrincipal getServer()
        Returns the service principal associated with this ticket.
        返回：
        the service principal.

      • getSessionKey

        public final SecretKey getSessionKey()
        Returns the session key associated with this ticket.
        返回：
        the session key.

      • getSessionKeyType

        public final int getSessionKeyType()
        Returns the key type of the session key associated with this ticket as defined by the Kerberos Protocol Specification.
        返回：
        the key type of the session key associated with this ticket.
        另请参见：
        getSessionKey()

      • isForwardable

        public final boolean isForwardable()
        Determines if this ticket is forwardable.
        返回：
        true if this ticket is forwardable, false if not.

      • isForwarded

        public final boolean isForwarded()
        Determines if this ticket had been forwarded or was issued based on authentication involving a forwarded ticket-granting ticket.
        返回：
        true if this ticket had been forwarded or was issued based on authentication involving a forwarded ticket-granting ticket, false otherwise.

      • isProxiable

        public final boolean isProxiable()
        Determines if this ticket is proxiable.
        返回：
        true if this ticket is proxiable, false if not.

      • isProxy

        public final boolean isProxy()
        Determines is this ticket is a proxy-ticket.
        返回：
        true if this ticket is a proxy-ticket, false if not.

      • isPostdated

        public final boolean isPostdated()
        Determines is this ticket is post-dated.
        返回：
        true if this ticket is post-dated, false if not.

      • isRenewable

        public final boolean isRenewable()
        Determines is this ticket is renewable. If so, the refresh method can be called, assuming the validity period for renewing is not already over.
        返回：
        true if this ticket is renewable, false if not.

      • isInitial

        public final boolean isInitial()
        Determines if this ticket was issued using the Kerberos AS-Exchange protocol, and not issued based on some ticket-granting ticket.
        返回：
        true if this ticket was issued using the Kerberos AS-Exchange protocol, false if not.

      • getFlags

        public final boolean[] getFlags()
        Returns the flags associated with this ticket. Each element in the returned array indicates the value for the corresponding bit in the ASN.1 BitString that represents the ticket flags.
        返回：
        the flags associated with this ticket.

      • getAuthTime

        public final Date getAuthTime()
        Returns the time that the client was authenticated.
        返回：
        the time that the client was authenticated or null if not set.

      • getStartTime

        public final Date getStartTime()
        Returns the start time for this ticket's validity period.
        返回：
        the start time for this ticket's validity period or null if not set.

      • getEndTime

        public final Date getEndTime()
        Returns the expiration time for this ticket's validity period.
        返回：
        the expiration time for this ticket's validity period.

      • getRenewTill

        public final Date getRenewTill()
        Returns the latest expiration time for this ticket, including all renewals. This will return a null value for non-renewable tickets.
        返回：
        the latest expiration time for this ticket.

      • getClientAddresses

        public final InetAddress[] getClientAddresses()
        Returns a list of addresses from where the ticket can be used.
        返回：
        ths list of addresses or null, if the field was not provided.

      • getEncoded

        public final byte[] getEncoded()
        Returns an ASN.1 encoding of the entire ticket.
        返回：
        an ASN.1 encoding of the entire ticket.

      • isCurrent

        public boolean isCurrent()
        Determines if this ticket is still current.
        指定者：
        isCurrent in interface Refreshable
        返回：
        true if this Object is currently current, false otherwise.

      • refresh

        public void refresh()
             throws RefreshFailedException
        Extends the validity period of this ticket. The ticket will contain a new session key if the refresh operation succeeds. The refresh operation will fail if the ticket is not renewable or the latest allowable renew time has passed. Any other error returned by the KDC will also cause this method to fail. Note: This method is not synchronized with the the accessor methods of this object. Hence callers need to be aware of multiple threads that might access this and try to renew it at the same time.
        指定者：
        refresh in interface Refreshable
        抛出：
        RefreshFailedException - if the ticket is not renewable, or the latest allowable renew time has passed, or the KDC returns some error.
        另请参见：
        isRenewable(), getRenewTill()

      • destroy

        public void destroy()
             throws DestroyFailedException
        Destroys the ticket and destroys any sensitive information stored in it.
        指定者：
        destroy in interface Destroyable
        抛出：
        DestroyFailedException - if the destroy operation fails.

      • isDestroyed

        public boolean isDestroyed()
        Determines if this ticket has been destroyed.
        指定者：
        isDestroyed in interface Destroyable
        返回：
        true if this Object has been destroyed, false otherwise.

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • hashCode

        public int hashCode()
        Returns a hashcode for this KerberosTicket.
        重载：
        hashCode in class Object
        返回：
        a hashCode() for the KerberosTicket
        从以下版本开始：
        1.6
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object other)
        Compares the specified Object with this KerberosTicket for equality. Returns true if the given object is also a KerberosTicket and the two KerberosTicket instances are equivalent.
        重载：
        equals in class Object
        参数：
        other - the Object to compare to
        返回：
        true if the specified object is equal to this KerberosTicket, false otherwise. NOTE: Returns false if either of the KerberosTicket objects has been destroyed.
        从以下版本开始：
        1.6
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServicePermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.kerberos

类 ServicePermission

  • java.lang.Object
    • java.security.Permission
      • javax.security.auth.kerberos.ServicePermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class ServicePermission
extends Permission
implements Serializable
    This class is used to protect Kerberos services and the credentials necessary to access those services. There is a one to one mapping of a service principal and the credentials necessary to access the service. Therefore granting access to a service principal implicitly grants access to the credential necessary to establish a security context with the service principal. This applies regardless of whether the credentials are in a cache or acquired via an exchange with the KDC. The credential can be either a ticket granting ticket, a service ticket or a secret key from a key table.

    A ServicePermission contains a service principal name and a list of actions which specify the context the credential can be used within.

    The service principal name is the canonical name of the KereberosPrincipal supplying the service, that is the KerberosPrincipal represents a Kerberos service principal. This name is treated in a case sensitive manner. An asterisk may appear by itself, to signify any service principal.

    Granting this permission implies that the caller can use a cached credential (TGT, service ticket or secret key) within the context designated by the action. In the case of the TGT, granting this permission also implies that the TGT can be obtained by an Authentication Service exchange.

    The possible actions are:

        initiate -              allow the caller to use the credential to
                            initiate a security context with a service
                            principal.

    accept -                allow the caller to use the credential to
                            accept security context as a particular
                            principal.
    For example, to specify the permission to access to the TGT to initiate a security context the permission is constructed as follows:

         ServicePermission("krbtgt/EXAMPLE.COM@EXAMPLE.COM", "initiate");

    To obtain a service ticket to initiate a context with the "host" service the permission is constructed as follows:

         ServicePermission("host/foo.example.com@EXAMPLE.COM", "initiate");

    For a Kerberized server the action is "accept". For example, the permission necessary to access and use the secret key of the Kerberized "host" service (telnet and the likes) would be constructed as follows:

         ServicePermission("host/foo.example.com@EXAMPLE.COM", "accept");
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServicePermission(String servicePrincipal, String action)
      Create a new ServicePermission with the specified servicePrincipal and action.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Checks two ServicePermission objects for equality.
      String getActions()
      Returns the canonical string representation of the actions.
      int hashCode()
      Returns the hash code value for this object.
      boolean implies(Permission p)
      Checks if this Kerberos service permission object "implies" the specified permission.
      PermissionCollection newPermissionCollection()
      Returns a PermissionCollection object for storing ServicePermission objects.

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ServicePermission

        public ServicePermission(String servicePrincipal,
                 String action)
        Create a new ServicePermission with the specified servicePrincipal and action.
        参数：
        servicePrincipal - the name of the service principal. An asterisk may appear by itself, to signify any service principal.

        action - the action string

    • 方法详细信息

      • implies

        public boolean implies(Permission p)
        Checks if this Kerberos service permission object "implies" the specified permission.

        If none of the above are true, implies returns false.

        指定者：
        implies in class Permission
        参数：
        p - the permission to check against.
        返回：
        true if the specified permission is implied by this object, false if not.

      • equals

        public boolean equals(Object obj)
        Checks two ServicePermission objects for equality.

        指定者：
        equals in class Permission
        参数：
        obj - the object to test for equality with this object.
        返回：
        true if obj is a ServicePermission, and has the same service principal, and actions as this ServicePermission object.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code value for this object.
        指定者：
        hashCode in class Permission
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • getActions

        public String getActions()
        Returns the canonical string representation of the actions. Always returns present actions in the following order: initiate, accept.
        指定者：
        getActions in class Permission
        返回：
        the actions of this Permission.

      • newPermissionCollection

        public PermissionCollection newPermissionCollection()
        Returns a PermissionCollection object for storing ServicePermission objects.
        ServicePermission objects must be stored in a manner that allows them to be inserted into the collection in any order, but that also enables the PermissionCollection implies method to be implemented in an efficient (and consistent) manner.
        重载：
        newPermissionCollection in class Permission
        返回：
        a new PermissionCollection object suitable for storing ServicePermissions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h Omfspi s>lljbletgv=ttsb<


Uses of Package javax.security.auth.kerberos

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth.kerberos

  • Packages that use javax.security.auth.kerberos
    软件包 描述
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.
  • Classes in javax.security.auth.kerberos used by javax.security.auth.kerberos
    类与描述
    KerberosPrincipal
    This class encapsulates a Kerberos principal.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/si/.".=f"""h asvvsl<=


Uses of Class javax.security.auth.kerberos.DelegationPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.kerberos.DelegationPermission

No usage of javax.security.auth.kerberos.DelegationPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

no/


Uses of Class javax.security.auth.kerberos.KerberosKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.kerberos.KerberosKey

No usage of javax.security.auth.kerberos.KerberosKey
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆ �<


Uses of Class javax.security.auth.kerberos.KerberosPrincipal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.kerberos.KerberosPrincipal

  • Packages that use KerberosPrincipal
    软件包 描述
    javax.security.auth.kerberos
    This package contains utility classes related to the Kerberos network authentication protocol.

    • Uses of KerberosPrincipal in javax.security.auth.kerberos

      Methods in javax.security.auth.kerberos that return KerberosPrincipal
      修饰符与类型 方法与描述
      KerberosPrincipal KerberosTicket.getClient()
      Returns the client principal associated with this ticket.
      KerberosPrincipal KerberosKey.getPrincipal()
      Returns the principal that this key belongs to.
      KerberosPrincipal KerberosTicket.getServer()
      Returns the service principal associated with this ticket.
      Constructors in javax.security.auth.kerberos with parameters of type KerberosPrincipal
      构造方法与描述
      KerberosKey(KerberosPrincipal principal, byte[] keyBytes, int keyType, int versionNum)
      Constructs a KerberosKey from the given bytes when the key type and key version number are known.
      KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
      Constructs a KerberosKey from a principal's password.
      KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
      Constructs a KerberosTicket using credentials information that a client either receives from a KDC or reads from a cache.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eotcda>dahaoe> ) i(


Uses of Class javax.security.auth.kerberos.KerberosTicket

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.kerberos.KerberosTicket

No usage of javax.security.auth.kerberos.KerberosTicket
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<./serbso"""baaatrokx


Uses of Class javax.security.auth.kerberos.ServicePermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.kerberos.ServicePermission

No usage of javax.security.auth.kerberos.ServicePermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./ta/oK>"is


AccountException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 AccountException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    AccountExpiredException, AccountLockedException, AccountNotFoundException

    public class AccountException
extends LoginException
    A generic account exception.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AccountException()
      Constructs a AccountException with no detail message.
      AccountException(String msg)
      Constructs a AccountException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AccountException

        public AccountException()
        Constructs a AccountException with no detail message. A detail message is a String that describes this particular exception.

      • AccountException

        public AccountException(String msg)
        Constructs a AccountException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aespia


AccountExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 AccountExpiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
  • 所有已实现的接口：
    Serializable

    public class AccountExpiredException
extends AccountException
    Signals that a user account has expired.

    This exception is thrown by LoginModules when they determine that an account has expired. For example, a LoginModule, after successfully authenticating a user, may determine that the user's account has expired. In this case the LoginModule throws this exception to notify the application. The application can then take the appropriate steps to notify the user.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AccountExpiredException()
      Constructs a AccountExpiredException with no detail message.
      AccountExpiredException(String msg)
      Constructs a AccountExpiredException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AccountExpiredException

        public AccountExpiredException()
        Constructs a AccountExpiredException with no detail message. A detail message is a String that describes this particular exception.

      • AccountExpiredException

        public AccountExpiredException(String msg)
        Constructs a AccountExpiredException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tutol./o ss==ls&vpaaac"lrrrs"lo"=a


AccountLockedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 AccountLockedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountLockedException
  • 所有已实现的接口：
    Serializable

    public class AccountLockedException
extends AccountException
    Signals that an account was locked.

    This exception may be thrown by a LoginModule if it determines that authentication is being attempted on a locked account.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AccountLockedException()
      Constructs a AccountLockedException with no detail message.
      AccountLockedException(String msg)
      Constructs a AccountLockedException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AccountLockedException

        public AccountLockedException()
        Constructs a AccountLockedException with no detail message. A detail message is a String that describes this particular exception.

      • AccountLockedException

        public AccountLockedException(String msg)
        Constructs a AccountLockedException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

odr u r w ,n woicera汀び鞔待 【＞a"


AccountNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 AccountNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountNotFoundException
  • 所有已实现的接口：
    Serializable

    public class AccountNotFoundException
extends AccountException
    Signals that an account was not found.

    This exception may be thrown by a LoginModule if it is unable to locate an account necessary to perform authentication.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AccountNotFoundException()
      Constructs a AccountNotFoundException with no detail message.
      AccountNotFoundException(String msg)
      Constructs a AccountNotFoundException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AccountNotFoundException

        public AccountNotFoundException()
        Constructs a AccountNotFoundException with no detail message. A detail message is a String that describes this particular exception.

      • AccountNotFoundException

        public AccountNotFoundException(String msg)
        Constructs a AccountNotFoundException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ebg./}..l... lenymg觩/rlhtt�.p/薱�


AppConfigurationEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.login

类 AppConfigurationEntry

  • java.lang.Object
    • javax.security.auth.login.AppConfigurationEntry

  • public class AppConfigurationEntry
extends Object
    This class represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method in the Configuration class. Each respective AppConfigurationEntry contains a LoginModule name, a control flag (specifying whether this LoginModule is REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL), and LoginModule-specific options. Please refer to the Configuration class for more information on the different control flags and their semantics.
    另请参见：
    Configuration

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  AppConfigurationEntry.LoginModuleControlFlag
      This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
      Default constructor for this class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AppConfigurationEntry.LoginModuleControlFlag getControlFlag()
      Return the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.
      String getLoginModuleName()
      Get the class name of the configured LoginModule.
      Map<String,?> getOptions()
      Get the options configured for this LoginModule.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AppConfigurationEntry

        public AppConfigurationEntry(String loginModuleName,
                     AppConfigurationEntry.LoginModuleControlFlag controlFlag,
                     Map<String,?> options)
        Default constructor for this class.

        This entry represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method from the Configuration class.

        参数：
        loginModuleName - String representing the class name of the LoginModule configured for the specified application.

        controlFlag - either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL.

        options - the options configured for this LoginModule.
        抛出：
        IllegalArgumentException - if loginModuleName is null, if LoginModuleName has a length of 0, if controlFlag is not either REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL, or if options is null.

    • 方法详细信息

      • getLoginModuleName

        public String getLoginModuleName()
        Get the class name of the configured LoginModule.
        返回：
        the class name of the configured LoginModule as a String.

      • getControlFlag

        public AppConfigurationEntry.LoginModuleControlFlag getControlFlag()
        Return the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.
        返回：
        the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.

      • getOptions

        public Map<String,?> getOptions()
        Get the options configured for this LoginModule.
        返回：
        the options configured for this LoginModule as an unmodifiable Map.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mnemasisecPPtc>S ii"so/"cf Trs)胷ntovroo


AppConfigurationEntry.LoginModuleControlFlag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.auth.login

类 AppConfigurationEntry.LoginModuleControlFlag

  • java.lang.Object
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
  • 封闭类：
    AppConfigurationEntry

    public static class AppConfigurationEntry.LoginModuleControlFlag
extends Object
    This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static AppConfigurationEntry.LoginModuleControlFlag OPTIONAL
      Optional LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag REQUIRED
      Required LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag REQUISITE
      Requisite LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag SUFFICIENT
      Sufficient LoginModule.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Return a String representation of this controlFlag.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • REQUIRED

        public static final AppConfigurationEntry.LoginModuleControlFlag REQUIRED
        Required LoginModule.

      • REQUISITE

        public static final AppConfigurationEntry.LoginModuleControlFlag REQUISITE
        Requisite LoginModule.

      • SUFFICIENT

        public static final AppConfigurationEntry.LoginModuleControlFlag SUFFICIENT
        Sufficient LoginModule.

      • OPTIONAL

        public static final AppConfigurationEntry.LoginModuleControlFlag OPTIONAL
        Optional LoginModule.

    • 方法详细信息

      • toString

        public String toString()
        Return a String representation of this controlFlag.

        The String has the format, "LoginModuleControlFlag: flag", where flag is either required, requisite, sufficient, or optional.

        重载：
        toString in class Object
        返回：
        a String representation of this controlFlag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea>


Configuration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.login

类 Configuration

  • java.lang.Object
    • javax.security.auth.login.Configuration

  • public abstract class Configuration
extends Object
    A Configuration object is responsible for specifying which LoginModules should be used for a particular application, and in what order the LoginModules should be invoked.

    A login configuration contains the following information. Note that this example only represents the default syntax for the Configuration. Subclass implementations of this class may implement alternative syntaxes and may retrieve the Configuration from any source such as files, databases, or servers.

          Name {
            ModuleClass  Flag    ModuleOptions;
            ModuleClass  Flag    ModuleOptions;
            ModuleClass  Flag    ModuleOptions;
      };
      Name {
            ModuleClass  Flag    ModuleOptions;
            ModuleClass  Flag    ModuleOptions;
      };
      other {
            ModuleClass  Flag    ModuleOptions;
            ModuleClass  Flag    ModuleOptions;
      };

    Each entry in the Configuration is indexed via an application name, Name, and contains a list of LoginModules configured for that application. Each LoginModule is specified via its fully qualified class name. Authentication proceeds down the module list in the exact order specified. If an application does not have specific entry, it defaults to the specific entry for "other".

    The Flag value controls the overall behavior as authentication proceeds down the stack. The following represents a description of the valid values for Flag and their respective semantics:

          1) Required     - The LoginModule is required to succeed.
                      If it succeeds or fails, authentication still continues
                      to proceed down the LoginModule list.

      2) Requisite    - The LoginModule is required to succeed.
                      If it succeeds, authentication continues down the
                      LoginModule list.  If it fails,
                      control immediately returns to the application
                      (authentication does not proceed down the
                      LoginModule list).

      3) Sufficient   - The LoginModule is not required to
                      succeed.  If it does succeed, control immediately
                      returns to the application (authentication does not
                      proceed down the LoginModule list).
                      If it fails, authentication continues down the
                      LoginModule list.

      4) Optional     - The LoginModule is not required to
                      succeed.  If it succeeds or fails,
                      authentication still continues to proceed down the
                      LoginModule list.

    The overall authentication succeeds only if all Required and Requisite LoginModules succeed. If a Sufficient LoginModule is configured and succeeds, then only the Required and Requisite LoginModules prior to that Sufficient LoginModule need to have succeeded for the overall authentication to succeed. If no Required or Requisite LoginModules are configured for an application, then at least one Sufficient or Optional LoginModule must succeed.

    ModuleOptions is a space separated list of LoginModule-specific values which are passed directly to the underlying LoginModules. Options are defined by the LoginModule itself, and control the behavior within it. For example, a LoginModule may define options to support debugging/testing capabilities. The correct way to specify options in the Configuration is by using the following key-value pairing: debug="true". The key and value should be separated by an 'equals' symbol, and the value should be surrounded by double quotes. If a String in the form, ${system.property}, occurs in the value, it will be expanded to the value of the system property. Note that there is no limit to the number of options a LoginModule may define.

    The following represents an example Configuration entry based on the syntax above:

     Login {
   com.sun.security.auth.module.UnixLoginModule required;
   com.sun.security.auth.module.Krb5LoginModule optional
                   useTicketCache="true"
                   ticketCache="${user.home}${/}tickets";
 };

    This Configuration specifies that an application named, "Login", requires users to first authenticate to the com.sun.security.auth.module.UnixLoginModule, which is required to succeed. Even if the UnixLoginModule authentication fails, the com.sun.security.auth.module.Krb5LoginModule still gets invoked. This helps hide the source of failure. Since the Krb5LoginModule is Optional, the overall authentication succeeds only if the UnixLoginModule (Required) succeeds.

    Also note that the LoginModule-specific options, useTicketCache="true" and ticketCache=${user.home}${/}tickets", are passed to the Krb5LoginModule. These options instruct the Krb5LoginModule to use the ticket cache at the specified location. The system properties, user.home and / (file.separator), are expanded to their respective values.

    There is only one Configuration object installed in the runtime at any given time. A Configuration object can be installed by calling the setConfiguration method. The installed Configuration object can be obtained by calling the getConfiguration method.

    If no Configuration object has been installed in the runtime, a call to getConfiguration installs an instance of the default Configuration implementation (a default subclass implementation of this abstract class). The default Configuration implementation can be changed by setting the value of the "login.configuration.provider" security property (in the Java security properties file) to the fully qualified name of the desired Configuration subclass implementation. The Java security properties file is located in the file named <JAVA_HOME>/lib/security/java.security. <JAVA_HOME> refers to the value of the java.home system property, and specifies the directory where the JRE is installed.

    Application code can directly subclass Configuration to provide a custom implementation. In addition, an instance of a Configuration object can be constructed by invoking one of the getInstance factory methods with a standard type. The default policy type is "JavaLoginConfig". See the Configuration section in the Java Cryptography Architecture Standard Algorithm Name Documentation for a list of standard Configuration types.

    另请参见：
    LoginContext

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static interface  Configuration.Parameters
      This represents a marker interface for Configuration parameters.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Configuration()
      Sole constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract AppConfigurationEntry[] getAppConfigurationEntry(String name)
      Retrieve the AppConfigurationEntries for the specified name from this Configuration.
      static Configuration getConfiguration()
      Get the installed login Configuration.
      static Configuration getInstance(String type, Configuration.Parameters params)
      Returns a Configuration object of the specified type.
      static Configuration getInstance(String type, Configuration.Parameters params, Provider provider)
      Returns a Configuration object of the specified type.
      static Configuration getInstance(String type, Configuration.Parameters params, String provider)
      Returns a Configuration object of the specified type.
      Configuration.Parameters getParameters()
      Return Configuration parameters.
      Provider getProvider()
      Return the Provider of this Configuration.
      String getType()
      Return the type of this Configuration.
      void refresh()
      Refresh and reload the Configuration.
      static void setConfiguration(Configuration configuration)
      Set the login Configuration.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Configuration

        protected Configuration()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • 方法详细信息

      • getConfiguration

        public static Configuration getConfiguration()
        Get the installed login Configuration.

        返回：
        the login Configuration. If a Configuration object was set via the Configuration.setConfiguration method, then that object is returned. Otherwise, a default Configuration object is returned.
        抛出：
        SecurityException - if the caller does not have permission to retrieve the Configuration.
        另请参见：
        setConfiguration(javax.security.auth.login.Configuration)

      • setConfiguration

        public static void setConfiguration(Configuration configuration)
        Set the login Configuration.

        参数：
        configuration - the new Configuration
        抛出：
        SecurityException - if the current thread does not have Permission to set the Configuration.
        另请参见：
        getConfiguration()

      • getInstance

        public static Configuration getInstance(String type,
                        Configuration.Parameters params)
                                 throws NoSuchAlgorithmException
        Returns a Configuration object of the specified type.

        This method traverses the list of registered security providers, starting with the most preferred Provider. A new Configuration object encapsulating the ConfigurationSpi implementation from the first Provider that supports the specified type is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        type - the specified Configuration type. See the Configuration section in the Java Cryptography Architecture Standard Algorithm Name Documentation for a list of standard Configuration types.
        params - parameters for the Configuration, which may be null.
        返回：
        the new Configuration object.
        抛出：
        SecurityException - if the caller does not have permission to get a Configuration instance for the specified type.
        NullPointerException - if the specified type is null.
        IllegalArgumentException - if the specified parameters are not understood by the ConfigurationSpi implementation from the selected Provider.
        NoSuchAlgorithmException - if no Provider supports a ConfigurationSpi implementation for the specified type.
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getInstance

        public static Configuration getInstance(String type,
                        Configuration.Parameters params,
                        String provider)
                                 throws NoSuchProviderException,
                                        NoSuchAlgorithmException
        Returns a Configuration object of the specified type.

        A new Configuration object encapsulating the ConfigurationSpi implementation from the specified provider is returned. The specified provider must be registered in the provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        type - the specified Configuration type. See the Configuration section in the Java Cryptography Architecture Standard Algorithm Name Documentation for a list of standard Configuration types.
        params - parameters for the Configuration, which may be null.
        provider - the provider.
        返回：
        the new Configuration object.
        抛出：
        SecurityException - if the caller does not have permission to get a Configuration instance for the specified type.
        NullPointerException - if the specified type is null.
        IllegalArgumentException - if the specified provider is null or empty, or if the specified parameters are not understood by the ConfigurationSpi implementation from the specified provider.
        NoSuchProviderException - if the specified provider is not registered in the security provider list.
        NoSuchAlgorithmException - if the specified provider does not support a ConfigurationSpi implementation for the specified type.
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getInstance

        public static Configuration getInstance(String type,
                        Configuration.Parameters params,
                        Provider provider)
                                 throws NoSuchAlgorithmException
        Returns a Configuration object of the specified type.

        A new Configuration object encapsulating the ConfigurationSpi implementation from the specified Provider object is returned. Note that the specified Provider object does not have to be registered in the provider list.

        参数：
        type - the specified Configuration type. See the Configuration section in the Java Cryptography Architecture Standard Algorithm Name Documentation for a list of standard Configuration types.
        params - parameters for the Configuration, which may be null.
        provider - the Provider.
        返回：
        the new Configuration object.
        抛出：
        SecurityException - if the caller does not have permission to get a Configuration instance for the specified type.
        NullPointerException - if the specified type is null.
        IllegalArgumentException - if the specified Provider is null, or if the specified parameters are not understood by the ConfigurationSpi implementation from the specified Provider.
        NoSuchAlgorithmException - if the specified Provider does not support a ConfigurationSpi implementation for the specified type.
        从以下版本开始：
        1.6
        另请参见：
        Provider

      • getProvider

        public Provider getProvider()
        Return the Provider of this Configuration.

        This Configuration instance will only have a Provider if it was obtained via a call to Configuration.getInstance. Otherwise this method returns null.

        返回：
        the Provider of this Configuration, or null.
        从以下版本开始：
        1.6

      • getType

        public String getType()
        Return the type of this Configuration.

        This Configuration instance will only have a type if it was obtained via a call to Configuration.getInstance. Otherwise this method returns null.

        返回：
        the type of this Configuration, or null.
        从以下版本开始：
        1.6

      • getParameters

        public Configuration.Parameters getParameters()
        Return Configuration parameters.

        This Configuration instance will only have parameters if it was obtained via a call to Configuration.getInstance. Otherwise this method returns null.

        返回：
        Configuration parameters, or null.
        从以下版本开始：
        1.6

      • getAppConfigurationEntry

        public abstract AppConfigurationEntry[] getAppConfigurationEntry(String name)
        Retrieve the AppConfigurationEntries for the specified name from this Configuration.

        参数：
        name - the name used to index the Configuration.
        返回：
        an array of AppConfigurationEntries for the specified name from this Configuration, or null if there are no entries for the specified name

      • refresh

        public void refresh()
        Refresh and reload the Configuration.

        This method causes this Configuration object to refresh/reload its contents in an implementation-dependent manner. For example, if this Configuration object stores its entries in a file, calling refresh may cause the file to be re-read.

        The default implementation of this method does nothing. This method should be overridden if a refresh operation is supported by the implementation.

        抛出：
        SecurityException - if the caller does not have permission to refresh its Configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Configuration.Parameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.security.auth.login

Interface Configuration.Parameters

  • All Known Implementing Classes:
    URIParameter
    封闭类：
    Configuration

    public static interface Configuration.Parameters
    This represents a marker interface for Configuration parameters.
    从以下版本开始：
    1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iiugneined>>edde 44unoss ec


ConfigurationSpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.login

类 ConfigurationSpi

  • java.lang.Object
    • javax.security.auth.login.ConfigurationSpi

  • public abstract class ConfigurationSpi
extends Object
    This class defines the Service Provider Interface (SPI) for the Configuration class. All the abstract methods in this class must be implemented by each service provider who wishes to supply a Configuration implementation.

    Subclass implementations of this abstract class must provide a public constructor that takes a Configuration.Parameters object as an input parameter. This constructor also must throw an IllegalArgumentException if it does not understand the Configuration.Parameters input.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      ConfigurationSpi()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract AppConfigurationEntry[] engineGetAppConfigurationEntry(String name)
      Retrieve the AppConfigurationEntries for the specified name.
      protected void engineRefresh()
      Refresh and reload the Configuration.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ConfigurationSpi

        public ConfigurationSpi()

    • 方法详细信息

      • engineGetAppConfigurationEntry

        protected abstract AppConfigurationEntry[] engineGetAppConfigurationEntry(String name)
        Retrieve the AppConfigurationEntries for the specified name.

        参数：
        name - the name used to index the Configuration.
        返回：
        an array of AppConfigurationEntries for the specified name, or null if there are no entries.

      • engineRefresh

        protected void engineRefresh()
        Refresh and reload the Configuration.

        This method causes this Configuration object to refresh/reload its contents in an implementation-dependent manner. For example, if this Configuration object stores its entries in a file, calling refresh may cause the file to be re-read.

        The default implementation of this method does nothing. This method should be overridden if a refresh operation is supported by the implementation.

        抛出：
        SecurityException - if the caller does not have permission to refresh its Configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sdsaaju


CredentialException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 CredentialException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.CredentialException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    CredentialExpiredException, CredentialNotFoundException

    public class CredentialException
extends LoginException
    A generic credential exception.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CredentialException()
      Constructs a CredentialException with no detail message.
      CredentialException(String msg)
      Constructs a CredentialException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CredentialException

        public CredentialException()
        Constructs a CredentialException with no detail message. A detail message is a String that describes this particular exception.

      • CredentialException

        public CredentialException(String msg)
        Constructs a CredentialException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


CredentialExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 CredentialExpiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
  • 所有已实现的接口：
    Serializable

    public class CredentialExpiredException
extends CredentialException
    Signals that a Credential has expired.

    This exception is thrown by LoginModules when they determine that a Credential has expired. For example, a LoginModule authenticating a user in its login method may determine that the user's password, although entered correctly, has expired. In this case the LoginModule throws this exception to notify the application. The application can then take the appropriate steps to assist the user in updating the password.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CredentialExpiredException()
      Constructs a CredentialExpiredException with no detail message.
      CredentialExpiredException(String msg)
      Constructs a CredentialExpiredException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CredentialExpiredException

        public CredentialExpiredException()
        Constructs a CredentialExpiredException with no detail message. A detail message is a String that describes this particular exception.

      • CredentialExpiredException

        public CredentialExpiredException(String msg)
        Constructs a CredentialExpiredException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>gS"v".D.at<..>"LabsaDutsllQ黨 i"/s


CredentialNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 CredentialNotFoundException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialNotFoundException
  • 所有已实现的接口：
    Serializable

    public class CredentialNotFoundException
extends CredentialException
    Signals that a credential was not found.

    This exception may be thrown by a LoginModule if it is unable to locate a credential necessary to perform authentication.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CredentialNotFoundException()
      Constructs a CredentialNotFoundException with no detail message.
      CredentialNotFoundException(String msg)
      Constructs a CredentialNotFoundException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CredentialNotFoundException

        public CredentialNotFoundException()
        Constructs a CredentialNotFoundException with no detail message. A detail message is a String that describes this particular exception.

      • CredentialNotFoundException

        public CredentialNotFoundException(String msg)
        Constructs a CredentialNotFoundException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ehrunucuvutlovei,ir 筷纺人耸⑹蚌茫蒙


FailedLoginException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 FailedLoginException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.FailedLoginException
  • 所有已实现的接口：
    Serializable

    public class FailedLoginException
extends LoginException
    Signals that user authentication failed.

    This exception is thrown by LoginModules if authentication failed. For example, a LoginModule throws this exception if the user entered an incorrect password.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      FailedLoginException()
      Constructs a FailedLoginException with no detail message.
      FailedLoginException(String msg)
      Constructs a FailedLoginException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FailedLoginException

        public FailedLoginException()
        Constructs a FailedLoginException with no detail message. A detail message is a String that describes this particular exception.

      • FailedLoginException

        public FailedLoginException(String msg)
        Constructs a FailedLoginException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nil:":f:w:p/ownar.nn>�<襯>>禸禝喔凳�<


javax.security.auth.login

Interfaces

  • Configuration.Parameters

Classes

  • AppConfigurationEntry
  • AppConfigurationEntry.LoginModuleControlFlag
  • Configuration
  • ConfigurationSpi
  • LoginContext

Exceptions

  • AccountException
  • AccountExpiredException
  • AccountLockedException
  • AccountNotFoundException
  • CredentialException
  • CredentialExpiredException
  • CredentialNotFoundException
  • FailedLoginException
  • LoginException
l


javax.security.auth.login

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth.login

This package provides a pluggable authentication framework.

请参见： 描述

  • 接口摘要
    接口 描述
    Configuration.Parameters
    This represents a marker interface for Configuration parameters.
  • Class Summary
    类 描述
    AppConfigurationEntry
    This class represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method in the Configuration class.
    AppConfigurationEntry.LoginModuleControlFlag
    This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.
    Configuration
    A Configuration object is responsible for specifying which LoginModules should be used for a particular application, and in what order the LoginModules should be invoked.
    ConfigurationSpi
    This class defines the Service Provider Interface (SPI) for the Configuration class.
    LoginContext
    The LoginContext class describes the basic methods used to authenticate Subjects and provides a way to develop an application independent of the underlying authentication technology.
  • Exception Summary
    Exception 描述
    AccountException
    A generic account exception.
    AccountExpiredException
    Signals that a user account has expired.
    AccountLockedException
    Signals that an account was locked.
    AccountNotFoundException
    Signals that an account was not found.
    CredentialException
    A generic credential exception.
    CredentialExpiredException
    Signals that a Credential has expired.
    CredentialNotFoundException
    Signals that a credential was not found.
    FailedLoginException
    Signals that user authentication failed.
    LoginException
    This is the basic login exception.

软件包 javax.security.auth.login Description

This package provides a pluggable authentication framework.

Package Specification

  • JavaTM Cryptography Architecture Standard Algorithm Name Documentation
从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lb;&lnn|n蟭;


javax.security.auth.login Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth.login

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.login.AppConfigurationEntry
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
    • javax.security.auth.login.Configuration
    • javax.security.auth.login.ConfigurationSpi
    • javax.security.auth.login.LoginContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
              • javax.security.auth.login.AccountLockedException
              • javax.security.auth.login.AccountNotFoundException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
              • javax.security.auth.login.CredentialNotFoundException
            • javax.security.auth.login.FailedLoginException

Interface Hierarchy

  • javax.security.auth.login.Configuration.Parameters
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e mndtSaaatshh.e//


LoginContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.login

类 LoginContext

  • java.lang.Object
    • javax.security.auth.login.LoginContext

  • public class LoginContext
extends Object

    The LoginContext class describes the basic methods used to authenticate Subjects and provides a way to develop an application independent of the underlying authentication technology. A Configuration specifies the authentication technology, or LoginModule, to be used with a particular application. Different LoginModules can be plugged in under an application without requiring any modifications to the application itself.

    In addition to supporting pluggable authentication, this class also supports the notion of stacked authentication. Applications may be configured to use more than one LoginModule. For example, one could configure both a Kerberos LoginModule and a smart card LoginModule under an application.

    A typical caller instantiates a LoginContext with a name and a CallbackHandler. LoginContext uses the name as the index into a Configuration to determine which LoginModules should be used, and which ones must succeed in order for the overall authentication to succeed. The CallbackHandler is passed to the underlying LoginModules so they may communicate and interact with users (prompting for a username and password via a graphical user interface, for example).

    Once the caller has instantiated a LoginContext, it invokes the login method to authenticate a Subject. The login method invokes the configured modules to perform their respective types of authentication (username/password, smart card pin verification, etc.). Note that the LoginModules will not attempt authentication retries nor introduce delays if the authentication fails. Such tasks belong to the LoginContext caller.

    If the login method returns without throwing an exception, then the overall authentication succeeded. The caller can then retrieve the newly authenticated Subject by invoking the getSubject method. Principals and Credentials associated with the Subject may be retrieved by invoking the Subject's respective getPrincipals, getPublicCredentials, and getPrivateCredentials methods.

    To logout the Subject, the caller calls the logout method. As with the login method, this logout method invokes the logout method for the configured modules.

    A LoginContext should not be used to authenticate more than one Subject. A separate LoginContext should be used to authenticate each different Subject.

    The following documentation applies to all LoginContext constructors:

    1. Subject
      • If the constructor has a Subject input parameter, the LoginContext uses the caller-specified Subject object.

      • If the caller specifies a null Subject and a null value is permitted, the LoginContext instantiates a new Subject.

      • If the constructor does not have a Subject input parameter, the LoginContext instantiates a new Subject.

    2. Configuration
      • If the constructor has a Configuration input parameter and the caller specifies a non-null Configuration, the LoginContext uses the caller-specified Configuration.

        If the constructor does not have a Configuration input parameter, or if the caller specifies a null Configuration object, the constructor uses the following call to get the installed Configuration:

              config = Configuration.getConfiguration();
        For both cases, the name argument given to the constructor is passed to the Configuration.getAppConfigurationEntry method. If the Configuration has no entries for the specified name, then the LoginContext calls getAppConfigurationEntry with the name, "other" (the default entry name). If there is no entry for "other", then a LoginException is thrown.

      • When LoginContext uses the installed Configuration, the caller requires the createLoginContext.name and possibly createLoginContext.other AuthPermissions. Furthermore, the LoginContext will invoke configured modules from within an AccessController.doPrivileged call so that modules that perform security-sensitive tasks (such as connecting to remote hosts, and updating the Subject) will require the respective permissions, but the callers of the LoginContext will not require those permissions.

      • When LoginContext uses a caller-specified Configuration, the caller does not require any createLoginContext AuthPermission. The LoginContext saves the AccessControlContext for the caller, and invokes the configured modules from within an AccessController.doPrivileged call constrained by that context. This means the caller context (stored when the LoginContext was created) must have sufficient permissions to perform any security-sensitive tasks that the modules may perform.

    3. CallbackHandler
      • If the constructor has a CallbackHandler input parameter, the LoginContext uses the caller-specified CallbackHandler object.

      • If the constructor does not have a CallbackHandler input parameter, or if the caller specifies a null CallbackHandler object (and a null value is permitted), the LoginContext queries the auth.login.defaultCallbackHandler security property for the fully qualified class name of a default handler implementation. If the security property is not set, then the underlying modules will not have a CallbackHandler for use in communicating with users. The caller thus assumes that the configured modules have alternative means for authenticating the user.

      • When the LoginContext uses the installed Configuration (instead of a caller-specified Configuration, see above), then this LoginContext must wrap any caller-specified or default CallbackHandler implementation in a new CallbackHandler implementation whose handle method implementation invokes the specified CallbackHandler's handle method in a java.security.AccessController.doPrivileged call constrained by the caller's current AccessControlContext.

    Note that Security Properties (such as auth.login.defaultCallbackHandler) can be set programmatically via the java.security.Security class, or statically in the Java security properties file located in the file named <JAVA_HOME>/lib/security/java.security. <JAVA_HOME> refers to the value of the java.home system property, and specifies the directory where the JRE is installed.

    另请参见：
    Security, AuthPermission, Subject, CallbackHandler, Configuration, LoginModule

    • 构造方法摘要

      Constructors
      构造方法与描述
      LoginContext(String name)
      Instantiate a new LoginContext object with a name.
      LoginContext(String name, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name and a CallbackHandler object.
      LoginContext(String name, Subject subject)
      Instantiate a new LoginContext object with a name and a Subject object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Subject getSubject()
      Return the authenticated Subject.
      void login()
      Perform the authentication.
      void logout()
      Logout the Subject.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LoginContext

        public LoginContext(String name)
             throws LoginException
        Instantiate a new LoginContext object with a name.
        参数：
        name - the name used as the index into the Configuration.
        抛出：
        LoginException - if the caller-specified name does not appear in the Configuration and there is no Configuration entry for "other", or if the auth.login.defaultCallbackHandler security property was set, but the implementation class could not be loaded.

        SecurityException - if a SecurityManager is set and the caller does not have AuthPermission("createLoginContext.name"), or if a configuration entry for name does not exist and the caller does not additionally have AuthPermission("createLoginContext.other")

      • LoginContext

        public LoginContext(String name,
            Subject subject)
             throws LoginException
        Instantiate a new LoginContext object with a name and a Subject object.

        参数：
        name - the name used as the index into the Configuration.

        subject - the Subject to authenticate.
        抛出：
        LoginException - if the caller-specified name does not appear in the Configuration and there is no Configuration entry for "other", if the caller-specified subject is null, or if the auth.login.defaultCallbackHandler security property was set, but the implementation class could not be loaded.

        SecurityException - if a SecurityManager is set and the caller does not have AuthPermission("createLoginContext.name"), or if a configuration entry for name does not exist and the caller does not additionally have AuthPermission("createLoginContext.other")

      • LoginContext

        public LoginContext(String name,
            CallbackHandler callbackHandler)
             throws LoginException
        Instantiate a new LoginContext object with a name and a CallbackHandler object.

        参数：
        name - the name used as the index into the Configuration.

        callbackHandler - the CallbackHandler object used by LoginModules to communicate with the user.
        抛出：
        LoginException - if the caller-specified name does not appear in the Configuration and there is no Configuration entry for "other", or if the caller-specified callbackHandler is null.

        SecurityException - if a SecurityManager is set and the caller does not have AuthPermission("createLoginContext.name"), or if a configuration entry for name does not exist and the caller does not additionally have AuthPermission("createLoginContext.other")

      • LoginContext

        public LoginContext(String name,
            Subject subject,
            CallbackHandler callbackHandler)
             throws LoginException
        Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.

        参数：
        name - the name used as the index into the Configuration.

        subject - the Subject to authenticate.

        callbackHandler - the CallbackHandler object used by LoginModules to communicate with the user.
        抛出：
        LoginException - if the caller-specified name does not appear in the Configuration and there is no Configuration entry for "other", or if the caller-specified subject is null, or if the caller-specified callbackHandler is null.

        SecurityException - if a SecurityManager is set and the caller does not have AuthPermission("createLoginContext.name"), or if a configuration entry for name does not exist and the caller does not additionally have AuthPermission("createLoginContext.other")

      • LoginContext

        public LoginContext(String name,
            Subject subject,
            CallbackHandler callbackHandler,
            Configuration config)
             throws LoginException
        Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.

        参数：
        name - the name used as the index into the caller-specified Configuration.

        subject - the Subject to authenticate, or null.

        callbackHandler - the CallbackHandler object used by LoginModules to communicate with the user, or null.

        config - the Configuration that lists the login modules to be called to perform the authentication, or null.
        抛出：
        LoginException - if the caller-specified name does not appear in the Configuration and there is no Configuration entry for "other".

        SecurityException - if a SecurityManager is set, config is null, and either the caller does not have AuthPermission("createLoginContext.name"), or if a configuration entry for name does not exist and the caller does not additionally have AuthPermission("createLoginContext.other")
        从以下版本开始：
        1.5

    • 方法详细信息

      • login

        public void login()
           throws LoginException
        Perform the authentication.

        This method invokes the login method for each LoginModule configured for the name specified to the LoginContext constructor, as determined by the login Configuration. Each LoginModule then performs its respective type of authentication (username/password, smart card pin verification, etc.).

        This method completes a 2-phase authentication process by calling each configured LoginModule's commit method if the overall authentication succeeded (the relevant REQUIRED, REQUISITE, SUFFICIENT, and OPTIONAL LoginModules succeeded), or by calling each configured LoginModule's abort method if the overall authentication failed. If authentication succeeded, each successful LoginModule's commit method associates the relevant Principals and Credentials with the Subject. If authentication failed, each LoginModule's abort method removes/destroys any previously stored state.

        If the commit phase of the authentication process fails, then the overall authentication fails and this method invokes the abort method for each configured LoginModule.

        If the abort phase fails for any reason, then this method propagates the original exception thrown either during the login phase or the commit phase. In either case, the overall authentication fails.

        In the case where multiple LoginModules fail, this method propagates the exception raised by the first LoginModule which failed.

        Note that if this method enters the abort phase (either the login or commit phase failed), this method invokes all LoginModules configured for the application regardless of their respective Configuration flag parameters. Essentially this means that Requisite and Sufficient semantics are ignored during the abort phase. This guarantees that proper cleanup and state restoration can take place.

        抛出：
        LoginException - if the authentication fails.

      • logout

        public void logout()
            throws LoginException
        Logout the Subject.

        This method invokes the logout method for each LoginModule configured for this LoginContext. Each LoginModule performs its respective logout procedure which may include removing/destroying Principal and Credential information from the Subject and state cleanup.

        Note that this method invokes all LoginModules configured for the application regardless of their respective Configuration flag parameters. Essentially this means that Requisite and Sufficient semantics are ignored for this method. This guarantees that proper cleanup and state restoration can take place.

        抛出：
        LoginException - if the logout fails.

      • getSubject

        public Subject getSubject()
        Return the authenticated Subject.

        返回：
        the authenticated Subject. If the caller specified a Subject to this LoginContext's constructor, this method returns the caller-specified Subject. If a Subject was not specified and authentication succeeds, this method returns the Subject instantiated and used for authentication by this LoginContext. If a Subject was not specified, and authentication fails or has not been attempted, this method returns null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LoginException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.auth.login

类 LoginException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    AccountException, CredentialException, FailedLoginException

    public class LoginException
extends GeneralSecurityException
    This is the basic login exception.
    另请参见：
    LoginContext, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      LoginException()
      Constructs a LoginException with no detail message.
      LoginException(String msg)
      Constructs a LoginException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LoginException

        public LoginException()
        Constructs a LoginException with no detail message. A detail message is a String that describes this particular exception.

      • LoginException

        public LoginException(String msg)
        Constructs a LoginException with the specified detail message. A detail message is a String that describes this particular exception.

        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.gaxnjc jcaeecaantnn p e>m sa/il


Uses of Package javax.security.auth.login

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth.login

  • Packages that use javax.security.auth.login
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.
  • Classes in javax.security.auth.login used by java.security
    类与描述
    Configuration.Parameters
    This represents a marker interface for Configuration parameters.
    LoginException
    This is the basic login exception.
  • Classes in javax.security.auth.login used by javax.security.auth.login
    类与描述
    AccountException
    A generic account exception.
    AppConfigurationEntry
    This class represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method in the Configuration class.
    AppConfigurationEntry.LoginModuleControlFlag
    This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.
    Configuration
    A Configuration object is responsible for specifying which LoginModules should be used for a particular application, and in what order the LoginModules should be invoked.
    Configuration.Parameters
    This represents a marker interface for Configuration parameters.
    CredentialException
    A generic credential exception.
    LoginException
    This is the basic login exception.
  • Classes in javax.security.auth.login used by javax.security.auth.spi
    类与描述
    LoginException
    This is the basic login exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"onp;f;pPPPn&


Uses of Class javax.security.auth.login.AccountException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AccountException

  • Packages that use AccountException
    软件包 描述
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of AccountException in javax.security.auth.login

      Subclasses of AccountException in javax.security.auth.login
      修饰符与类型 类与描述
      class  AccountExpiredException
      Signals that a user account has expired.
      class  AccountLockedException
      Signals that an account was locked.
      class  AccountNotFoundException
      Signals that an account was not found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s#.agr鹴p l


Uses of Class javax.security.auth.login.AccountExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AccountExpiredException

No usage of javax.security.auth.login.AccountExpiredException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n doin//hlllae..;ssd.


Uses of Class javax.security.auth.login.AccountLockedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AccountLockedException

No usage of javax.security.auth.login.AccountLockedException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>鬾t>o>l o/liilde/l


Uses of Class javax.security.auth.login.AccountNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AccountNotFoundException

No usage of javax.security.auth.login.AccountNotFoundException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nm./$//r.


Uses of Class javax.security.auth.login.AppConfigurationEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AppConfigurationEntry

  • Packages that use AppConfigurationEntry
    软件包 描述
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of AppConfigurationEntry in javax.security.auth.login

      Methods in javax.security.auth.login that return AppConfigurationEntry
      修饰符与类型 方法与描述
      protected abstract AppConfigurationEntry[] ConfigurationSpi.engineGetAppConfigurationEntry(String name)
      Retrieve the AppConfigurationEntries for the specified name.
      abstract AppConfigurationEntry[] Configuration.getAppConfigurationEntry(String name)
      Retrieve the AppConfigurationEntries for the specified name from this Configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gr/c/o lp;ibSxhcxnir襰


Uses of Class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag

  • Packages that use AppConfigurationEntry.LoginModuleControlFlag
    软件包 描述
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of AppConfigurationEntry.LoginModuleControlFlag in javax.security.auth.login

      Fields in javax.security.auth.login declared as AppConfigurationEntry.LoginModuleControlFlag
      修饰符与类型 字段与描述
      static AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.LoginModuleControlFlag.OPTIONAL
      Optional LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.LoginModuleControlFlag.REQUIRED
      Required LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.LoginModuleControlFlag.REQUISITE
      Requisite LoginModule.
      static AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.LoginModuleControlFlag.SUFFICIENT
      Sufficient LoginModule.
      Methods in javax.security.auth.login that return AppConfigurationEntry.LoginModuleControlFlag
      修饰符与类型 方法与描述
      AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.getControlFlag()
      Return the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.
      Constructors in javax.security.auth.login with parameters of type AppConfigurationEntry.LoginModuleControlFlag
      构造方法与描述
      AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
      Default constructor for this class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1


Uses of Class javax.security.auth.login.Configuration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.Configuration

  • Packages that use Configuration
    软件包 描述
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of Configuration in javax.security.auth.login

      Methods in javax.security.auth.login that return Configuration
      修饰符与类型 方法与描述
      static Configuration Configuration.getConfiguration()
      Get the installed login Configuration.
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params)
      Returns a Configuration object of the specified type.
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
      Returns a Configuration object of the specified type.
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params, String provider)
      Returns a Configuration object of the specified type.
      Methods in javax.security.auth.login with parameters of type Configuration
      修饰符与类型 方法与描述
      static void Configuration.setConfiguration(Configuration configuration)
      Set the login Configuration.
      Constructors in javax.security.auth.login with parameters of type Configuration
      构造方法与描述
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a_dslth< b.l"g/r/ah>o""


Uses of Class javax.security.auth.login.ConfigurationSpi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.ConfigurationSpi

No usage of javax.security.auth.login.ConfigurationSpi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t.fUse< hhh/ ll /a


Uses of Class javax.security.auth.login.CredentialException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.CredentialException

  • Packages that use CredentialException
    软件包 描述
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of CredentialException in javax.security.auth.login

      Subclasses of CredentialException in javax.security.auth.login
      修饰符与类型 类与描述
      class  CredentialExpiredException
      Signals that a Credential has expired.
      class  CredentialNotFoundException
      Signals that a credential was not found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i-ttR iagaslt.raeen萾>


Uses of Class javax.security.auth.login.CredentialExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.CredentialExpiredException

No usage of javax.security.auth.login.CredentialExpiredException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atrnv">otmmmb ==il//=


Uses of Class javax.security.auth.login.CredentialNotFoundException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.CredentialNotFoundException

No usage of javax.security.auth.login.CredentialNotFoundException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

刬>�/r+黳1 琩t$s黰


Uses of Class javax.security.auth.login.FailedLoginException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.FailedLoginException

No usage of javax.security.auth.login.FailedLoginException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nrnr&s>皉/


Uses of Class javax.security.auth.login.LoginContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.LoginContext

No usage of javax.security.auth.login.LoginContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sgtＨ�/�o>


Uses of Class javax.security.auth.login.LoginException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.login.LoginException

  • Packages that use LoginException
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.login
    This package provides a pluggable authentication framework.
    javax.security.auth.spi
    This package provides the interface to be used for implementing pluggable authentication modules.

    • Uses of LoginException in java.security

      Methods in java.security that throw LoginException
      修饰符与类型 方法与描述
      abstract void AuthProvider.login(Subject subject, CallbackHandler handler)
      Log in to this provider.
      abstract void AuthProvider.logout()
      Log out from this provider.

    • Uses of LoginException in javax.security.auth.login

      Subclasses of LoginException in javax.security.auth.login
      修饰符与类型 类与描述
      class  AccountException
      A generic account exception.
      class  AccountExpiredException
      Signals that a user account has expired.
      class  AccountLockedException
      Signals that an account was locked.
      class  AccountNotFoundException
      Signals that an account was not found.
      class  CredentialException
      A generic credential exception.
      class  CredentialExpiredException
      Signals that a Credential has expired.
      class  CredentialNotFoundException
      Signals that a credential was not found.
      class  FailedLoginException
      Signals that user authentication failed.
      Methods in javax.security.auth.login that throw LoginException
      修饰符与类型 方法与描述
      void LoginContext.login()
      Perform the authentication.
      void LoginContext.logout()
      Logout the Subject.
      Constructors in javax.security.auth.login that throw LoginException
      构造方法与描述
      LoginContext(String name)
      Instantiate a new LoginContext object with a name.
      LoginContext(String name, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name and a CallbackHandler object.
      LoginContext(String name, Subject subject)
      Instantiate a new LoginContext object with a name and a Subject object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.
      LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
      Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.

    • Uses of LoginException in javax.security.auth.spi

      Methods in javax.security.auth.spi that throw LoginException
      修饰符与类型 方法与描述
      boolean LoginModule.abort()
      Method to abort the authentication process (phase 2).
      boolean LoginModule.commit()
      Method to commit the authentication process (phase 2).
      boolean LoginModule.login()
      Method to authenticate a Subject (phase 1).
      boolean LoginModule.logout()
      Method which logs out a Subject.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ree>spmvt ot s


Uses of Interface javax.security.auth.login.Configuration.Parameters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.login.Configuration.Parameters

  • Packages that use Configuration.Parameters
    软件包 描述
    java.security
    Provides the classes and interfaces for the security framework.
    javax.security.auth.login
    This package provides a pluggable authentication framework.

    • Uses of Configuration.Parameters in java.security

      Classes in java.security that implement Configuration.Parameters
      修饰符与类型 类与描述
      class  URIParameter
      A parameter that contains a URI pointing to data intended for a PolicySpi or ConfigurationSpi implementation.

    • Uses of Configuration.Parameters in javax.security.auth.login

      Methods in javax.security.auth.login that return Configuration.Parameters
      修饰符与类型 方法与描述
      Configuration.Parameters Configuration.getParameters()
      Return Configuration parameters.
      Methods in javax.security.auth.login with parameters of type Configuration.Parameters
      修饰符与类型 方法与描述
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params)
      Returns a Configuration object of the specified type.
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
      Returns a Configuration object of the specified type.
      static Configuration Configuration.getInstance(String type, Configuration.Parameters params, String provider)
      Returns a Configuration object of the specified type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cioro.l.drc./scc谋捕P譏嘤=


javax.security.auth.spi

Interfaces

  • LoginModule


javax.security.auth.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth.spi

This package provides the interface to be used for implementing pluggable authentication modules.

请参见： 描述

  • 接口摘要
    接口 描述
    LoginModule
    LoginModule describes the interface implemented by authentication technology providers.

软件包 javax.security.auth.spi Description

This package provides the interface to be used for implementing pluggable authentication modules.
从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

UEQLUQtUItn UUt ccnhocthei


javax.security.auth.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth.spi

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.security.auth.spi.LoginModule
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>s ac


LoginModule

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.auth.spi

Interface LoginModule

  • public interface LoginModule

    LoginModule describes the interface implemented by authentication technology providers. LoginModules are plugged in under applications to provide a particular type of authentication.

    While applications write to the LoginContext API, authentication technology providers implement the LoginModule interface. A Configuration specifies the LoginModule(s) to be used with a particular login application. Therefore different LoginModules can be plugged in under the application without requiring any modifications to the application itself.

    The LoginContext is responsible for reading the Configuration and instantiating the appropriate LoginModules. Each LoginModule is initialized with a Subject, a CallbackHandler, shared LoginModule state, and LoginModule-specific options. The Subject represents the Subject currently being authenticated and is updated with relevant Credentials if authentication succeeds. LoginModules use the CallbackHandler to communicate with users. The CallbackHandler may be used to prompt for usernames and passwords, for example. Note that the CallbackHandler may be null. LoginModules which absolutely require a CallbackHandler to authenticate the Subject may throw a LoginException. LoginModules optionally use the shared state to share information or data among themselves.

    The LoginModule-specific options represent the options configured for this LoginModule by an administrator or user in the login Configuration. The options are defined by the LoginModule itself and control the behavior within it. For example, a LoginModule may define options to support debugging/testing capabilities. Options are defined using a key-value syntax, such as debug=true. The LoginModule stores the options as a Map so that the values may be retrieved using the key. Note that there is no limit to the number of options a LoginModule chooses to define.

    The calling application sees the authentication process as a single operation. However, the authentication process within the LoginModule proceeds in two distinct phases. In the first phase, the LoginModule's login method gets invoked by the LoginContext's login method. The login method for the LoginModule then performs the actual authentication (prompt for and verify a password for example) and saves its authentication status as private state information. Once finished, the LoginModule's login method either returns true (if it succeeded) or false (if it should be ignored), or throws a LoginException to specify a failure. In the failure case, the LoginModule must not retry the authentication or introduce delays. The responsibility of such tasks belongs to the application. If the application attempts to retry the authentication, the LoginModule's login method will be called again.

    In the second phase, if the LoginContext's overall authentication succeeded (the relevant REQUIRED, REQUISITE, SUFFICIENT and OPTIONAL LoginModules succeeded), then the commit method for the LoginModule gets invoked. The commit method for a LoginModule checks its privately saved state to see if its own authentication succeeded. If the overall LoginContext authentication succeeded and the LoginModule's own authentication succeeded, then the commit method associates the relevant Principals (authenticated identities) and Credentials (authentication data such as cryptographic keys) with the Subject located within the LoginModule.

    If the LoginContext's overall authentication failed (the relevant REQUIRED, REQUISITE, SUFFICIENT and OPTIONAL LoginModules did not succeed), then the abort method for each LoginModule gets invoked. In this case, the LoginModule removes/destroys any authentication state originally saved.

    Logging out a Subject involves only one phase. The LoginContext invokes the LoginModule's logout method. The logout method for the LoginModule then performs the logout procedures, such as removing Principals or Credentials from the Subject or logging session information.

    A LoginModule implementation must have a constructor with no arguments. This allows classes which load the LoginModule to instantiate it.

    另请参见：
    LoginContext, Configuration

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean abort()
      Method to abort the authentication process (phase 2).
      boolean commit()
      Method to commit the authentication process (phase 2).
      void initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
      Initialize this LoginModule.
      boolean login()
      Method to authenticate a Subject (phase 1).
      boolean logout()
      Method which logs out a Subject.

    • 方法详细信息

      • initialize

        void initialize(Subject subject,
              CallbackHandler callbackHandler,
              Map<String,?> sharedState,
              Map<String,?> options)
        Initialize this LoginModule.

        This method is called by the LoginContext after this LoginModule has been instantiated. The purpose of this method is to initialize this LoginModule with the relevant information. If this LoginModule does not understand any of the data stored in sharedState or options parameters, they can be ignored.

        参数：
        subject - the Subject to be authenticated.

        callbackHandler - a CallbackHandler for communicating with the end user (prompting for usernames and passwords, for example).

        sharedState - state shared with other configured LoginModules.

        options - options specified in the login Configuration for this particular LoginModule.

      • login

        boolean login()
              throws LoginException
        Method to authenticate a Subject (phase 1).

        The implementation of this method authenticates a Subject. For example, it may prompt for Subject information such as a username and password and then attempt to verify the password. This method saves the result of the authentication attempt as private state within the LoginModule.

        返回：
        true if the authentication succeeded, or false if this LoginModule should be ignored.
        抛出：
        LoginException - if the authentication fails

      • commit

        boolean commit()
               throws LoginException
        Method to commit the authentication process (phase 2).

        This method is called if the LoginContext's overall authentication succeeded (the relevant REQUIRED, REQUISITE, SUFFICIENT and OPTIONAL LoginModules succeeded).

        If this LoginModule's own authentication attempt succeeded (checked by retrieving the private state saved by the login method), then this method associates relevant Principals and Credentials with the Subject located in the LoginModule. If this LoginModule's own authentication attempted failed, then this method removes/destroys any state that was originally saved.

        返回：
        true if this method succeeded, or false if this LoginModule should be ignored.
        抛出：
        LoginException - if the commit fails

      • abort

        boolean abort()
              throws LoginException
        Method to abort the authentication process (phase 2).

        This method is called if the LoginContext's overall authentication failed. (the relevant REQUIRED, REQUISITE, SUFFICIENT and OPTIONAL LoginModules did not succeed).

        If this LoginModule's own authentication attempt succeeded (checked by retrieving the private state saved by the login method), then this method cleans up any state that was originally saved.

        返回：
        true if this method succeeded, or false if this LoginModule should be ignored.
        抛出：
        LoginException - if the abort fails

      • logout

        boolean logout()
               throws LoginException
        Method which logs out a Subject.

        An implementation of this method might remove/destroy a Subject's Principals and Credentials.

        返回：
        true if this method succeeded, or false if this LoginModule should be ignored.
        抛出：
        LoginException - if the logout fails
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t.r-rn>. la <糴im &d


Uses of Package javax.security.auth.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth.spi

No usage of javax.security.auth.spi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f/eutibim g�"mm= lcp


Uses of Interface javax.security.auth.spi.LoginModule

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.auth.spi.LoginModule

No usage of javax.security.auth.spi.LoginModule
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yxms=c/a


javax.security.auth.x500

Classes

  • X500Principal
  • X500PrivateCredential


javax.security.auth.x500

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.auth.x500

This package contains the classes that should be used to store X500 Principal and X500 Private Crendentials in a Subject.

请参见： 描述

  • Class Summary
    类 描述
    X500Principal
    This class represents an X.500 Principal.
    X500PrivateCredential
    This class represents an X500PrivateCredential.

软件包 javax.security.auth.x500 Description

This package contains the classes that should be used to store X500 Principal and X500 Private Crendentials in a Subject.
从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.#mo.< NNna hcra=


javax.security.auth.x500 Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.auth.x500

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.auth.x500.X500Principal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.x500.X500PrivateCredential (implements javax.security.auth.Destroyable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r aal/Ceenaaall


Uses of Package javax.security.auth.x500

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.auth.x500

  • Packages that use javax.security.auth.x500
    软件包 描述
    java.security.cert
    Provides classes and interfaces for parsing and managing certificates, certificate revocation lists (CRLs), and certification paths.
  • Classes in javax.security.auth.x500 used by java.security.cert
    类与描述
    X500Principal
    This class represents an X.500 Principal.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

si;i""n h" iak=pp a{-k


X500Principal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.x500

类 X500Principal

  • java.lang.Object
    • javax.security.auth.x500.X500Principal
  • 所有已实现的接口：
    Serializable, Principal

    public final class X500Principal
extends Object
implements Principal, Serializable

    This class represents an X.500 Principal. X500Principals are represented by distinguished names such as "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US".

    This class can be instantiated by using a string representation of the distinguished name, or by using the ASN.1 DER encoded byte representation of the distinguished name. The current specification for the string representation of a distinguished name is defined in RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names. This class, however, accepts string formats from both RFC 2253 and RFC 1779: A String Representation of Distinguished Names, and also recognizes attribute type keywords whose OIDs (Object Identifiers) are defined in RFC 3280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile.

    The string representation for this X500Principal can be obtained by calling the getName methods.

    Note that the getSubjectX500Principal and getIssuerX500Principal methods of X509Certificate return X500Principals representing the issuer and subject fields of the certificate.

    从以下版本开始：
    1.4
    另请参见：
    X509Certificate, Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CANONICAL
      Canonical String format of Distinguished Names.
      static String RFC1779
      RFC 1779 String format of Distinguished Names.
      static String RFC2253
      RFC 2253 String format of Distinguished Names.

    • 构造方法摘要

      Constructors
      构造方法与描述
      X500Principal(byte[] name)
      Creates an X500Principal from a distinguished name in ASN.1 DER encoded form.
      X500Principal(InputStream is)
      Creates an X500Principal from an InputStream containing the distinguished name in ASN.1 DER encoded form.
      X500Principal(String name)
      Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US").
      X500Principal(String name, Map<String,String> keywordMap)
      Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US").

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object o)
      Compares the specified Object with this X500Principal for equality.
      byte[] getEncoded()
      Returns the distinguished name in ASN.1 DER encoded form.
      String getName()
      Returns a string representation of the X.500 distinguished name using the format defined in RFC 2253.
      String getName(String format)
      Returns a string representation of the X.500 distinguished name using the specified format.
      String getName(String format, Map<String,String> oidMap)
      Returns a string representation of the X.500 distinguished name using the specified format.
      int hashCode()
      Return a hash code for this X500Principal.
      String toString()
      Return a user-friendly string representation of this X500Principal.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • RFC1779

        public static final String RFC1779
        RFC 1779 String format of Distinguished Names.
        另请参见：
        Constant Field Values

      • RFC2253

        public static final String RFC2253
        RFC 2253 String format of Distinguished Names.
        另请参见：
        Constant Field Values

      • CANONICAL

        public static final String CANONICAL
        Canonical String format of Distinguished Names.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • X500Principal

        public X500Principal(String name)
        Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US"). The distinguished name must be specified using the grammar defined in RFC 1779 or RFC 2253 (either format is acceptable).

        This constructor recognizes the attribute type keywords defined in RFC 1779 and RFC 2253 (and listed in getName(String format)), as well as the T, DNQ or DNQUALIFIER, SURNAME, GIVENNAME, INITIALS, GENERATION, EMAILADDRESS, and SERIALNUMBER keywords whose OIDs are defined in RFC 3280 and its successor. Any other attribute type must be specified as an OID.

        参数：
        name - an X.500 distinguished name in RFC 1779 or RFC 2253 format
        抛出：
        NullPointerException - if the name is null
        IllegalArgumentException - if the name is improperly specified

      • X500Principal

        public X500Principal(String name,
             Map<String,String> keywordMap)
        Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US"). The distinguished name must be specified using the grammar defined in RFC 1779 or RFC 2253 (either format is acceptable).

        This constructor recognizes the attribute type keywords specified in X500Principal(String) and also recognizes additional keywords that have entries in the keywordMap parameter. Keyword entries in the keywordMap take precedence over the default keywords recognized by X500Principal(String). Keywords MUST be specified in all upper-case, otherwise they will be ignored. Improperly specified keywords are ignored; however if a keyword in the name maps to an improperly specified OID, an IllegalArgumentException is thrown. It is permissible to have 2 different keywords that map to the same OID.

        参数：
        name - an X.500 distinguished name in RFC 1779 or RFC 2253 format
        keywordMap - an attribute type keyword map, where each key is a keyword String that maps to a corresponding object identifier in String form (a sequence of nonnegative integers separated by periods). The map may be empty but never null.
        抛出：
        NullPointerException - if name or keywordMap is null
        IllegalArgumentException - if the name is improperly specified or a keyword in the name maps to an OID that is not in the correct form
        从以下版本开始：
        1.6

      • X500Principal

        public X500Principal(byte[] name)
        Creates an X500Principal from a distinguished name in ASN.1 DER encoded form. The ASN.1 notation for this structure is as follows.

 Name ::= CHOICE {
   RDNSequence }

 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName

 RelativeDistinguishedName ::=
   SET SIZE (1 .. MAX) OF AttributeTypeAndValue

 AttributeTypeAndValue ::= SEQUENCE {
   type     AttributeType,
   value    AttributeValue }

 AttributeType ::= OBJECT IDENTIFIER

 AttributeValue ::= ANY DEFINED BY AttributeType
 ....
 DirectoryString ::= CHOICE {
       teletexString           TeletexString (SIZE (1..MAX)),
       printableString         PrintableString (SIZE (1..MAX)),
       universalString         UniversalString (SIZE (1..MAX)),
       utf8String              UTF8String (SIZE (1.. MAX)),
       bmpString               BMPString (SIZE (1..MAX)) }
        参数：
        name - a byte array containing the distinguished name in ASN.1 DER encoded form
        抛出：
        IllegalArgumentException - if an encoding error occurs (incorrect form for DN)

      • X500Principal

        public X500Principal(InputStream is)
        Creates an X500Principal from an InputStream containing the distinguished name in ASN.1 DER encoded form. The ASN.1 notation for this structure is supplied in the documentation for X500Principal(byte[] name).

        The read position of the input stream is positioned to the next available byte after the encoded distinguished name.

        参数：
        is - an InputStream containing the distinguished name in ASN.1 DER encoded form
        抛出：
        NullPointerException - if the InputStream is null
        IllegalArgumentException - if an encoding error occurs (incorrect form for DN)

    • 方法详细信息

      • getName

        public String getName()
        Returns a string representation of the X.500 distinguished name using the format defined in RFC 2253.

        This method is equivalent to calling getName(X500Principal.RFC2253).

        指定者：
        getName in interface Principal
        返回：
        the distinguished name of this X500Principal

      • getName

        public String getName(String format)
        Returns a string representation of the X.500 distinguished name using the specified format. Valid values for the format are "RFC1779", "RFC2253", and "CANONICAL" (case insensitive).

        If "RFC1779" is specified as the format, this method emits the attribute type keywords defined in RFC 1779 (CN, L, ST, O, OU, C, STREET). Any other attribute type is emitted as an OID.

        If "RFC2253" is specified as the format, this method emits the attribute type keywords defined in RFC 2253 (CN, L, ST, O, OU, C, STREET, DC, UID). Any other attribute type is emitted as an OID. Under a strict reading, RFC 2253 only specifies a UTF-8 string representation. The String returned by this method is the Unicode string achieved by decoding this UTF-8 representation.

        If "CANONICAL" is specified as the format, this method returns an RFC 2253 conformant string representation with the following additional canonicalizations:

        1. Leading zeros are removed from attribute types that are encoded as dotted decimal OIDs
        2. DirectoryString attribute values of type PrintableString and UTF8String are not output in hexadecimal format
        3. DirectoryString attribute values of types other than PrintableString and UTF8String are output in hexadecimal format
        4. Leading and trailing white space characters are removed from non-hexadecimal attribute values (unless the value consists entirely of white space characters)
        5. Internal substrings of one or more white space characters are converted to a single space in non-hexadecimal attribute values
        6. Relative Distinguished Names containing more than one Attribute Value Assertion (AVA) are output in the following order: an alphabetical ordering of AVAs containing standard keywords, followed by a numeric ordering of AVAs containing OID keywords.
        7. The only characters in attribute values that are escaped are those which section 2.4 of RFC 2253 states must be escaped (they are escaped using a preceding backslash character)
        8. The entire name is converted to upper case using String.toUpperCase(Locale.US)
        9. The entire name is converted to lower case using String.toLowerCase(Locale.US)
        10. The name is finally normalized using normalization form KD, as described in the Unicode Standard and UAX #15

        Additional standard formats may be introduced in the future.

        参数：
        format - the format to use
        返回：
        a string representation of this X500Principal using the specified format
        抛出：
        IllegalArgumentException - if the specified format is invalid or null

      • getName

        public String getName(String format,
             Map<String,String> oidMap)
        Returns a string representation of the X.500 distinguished name using the specified format. Valid values for the format are "RFC1779" and "RFC2253" (case insensitive). "CANONICAL" is not permitted and an IllegalArgumentException will be thrown.

        This method returns Strings in the format as specified in getName(String) and also emits additional attribute type keywords for OIDs that have entries in the oidMap parameter. OID entries in the oidMap take precedence over the default OIDs recognized by getName(String). Improperly specified OIDs are ignored; however if an OID in the name maps to an improperly specified keyword, an IllegalArgumentException is thrown.

        Additional standard formats may be introduced in the future.

        Warning: additional attribute type keywords may not be recognized by other implementations; therefore do not use this method if you are unsure if these keywords will be recognized by other implementations.

        参数：
        format - the format to use
        oidMap - an OID map, where each key is an object identifier in String form (a sequence of nonnegative integers separated by periods) that maps to a corresponding attribute type keyword String. The map may be empty but never null.
        返回：
        a string representation of this X500Principal using the specified format
        抛出：
        IllegalArgumentException - if the specified format is invalid, null, or an OID in the name maps to an improperly specified keyword
        NullPointerException - if oidMap is null
        从以下版本开始：
        1.6

      • getEncoded

        public byte[] getEncoded()
        Returns the distinguished name in ASN.1 DER encoded form. The ASN.1 notation for this structure is supplied in the documentation for X500Principal(byte[] name).

        Note that the byte array returned is cloned to protect against subsequent modifications.

        返回：
        a byte array containing the distinguished name in ASN.1 DER encoded form

      • toString

        public String toString()
        Return a user-friendly string representation of this X500Principal.
        指定者：
        toString in interface Principal
        重载：
        toString in class Object
        返回：
        a string representation of this X500Principal

      • equals

        public boolean equals(Object o)
        Compares the specified Object with this X500Principal for equality.

        Specifically, this method returns true if the Object o is an X500Principal and if the respective canonical string representations (obtained via the getName(X500Principal.CANONICAL) method) of this object and o are equal.

        This implementation is compliant with the requirements of RFC 3280.

        指定者：
        equals in interface Principal
        重载：
        equals in class Object
        参数：
        o - Object to be compared for equality with this X500Principal
        返回：
        true if the specified Object is equal to this X500Principal, false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Return a hash code for this X500Principal.

        The hash code is calculated via: getName(X500Principal.CANONICAL).hashCode()

        指定者：
        hashCode in interface Principal
        重载：
        hashCode in class Object
        返回：
        a hash code for this X500Principal
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


X500PrivateCredential

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.auth.x500

类 X500PrivateCredential

  • java.lang.Object
    • javax.security.auth.x500.X500PrivateCredential
  • 所有已实现的接口：
    Destroyable

    public final class X500PrivateCredential
extends Object
implements Destroyable

    This class represents an X500PrivateCredential. It associates an X.509 certificate, corresponding private key and the KeyStore alias used to reference that exact key pair in the KeyStore. This enables looking up the private credentials for an X.500 principal in a subject.

    • 构造方法摘要

      Constructors
      构造方法与描述
      X500PrivateCredential(X509Certificate cert, PrivateKey key)
      Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.
      X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
      Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      Clears the references to the X.509 certificate, private key and the KeyStore alias in this object.
      String getAlias()
      Returns the KeyStore alias.
      X509Certificate getCertificate()
      Returns the X.509 certificate.
      PrivateKey getPrivateKey()
      Returns the PrivateKey.
      boolean isDestroyed()
      Determines if the references to the X.509 certificate and private key in this object have been cleared.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • X500PrivateCredential

        public X500PrivateCredential(X509Certificate cert,
                     PrivateKey key)
        Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.

        参数：
        cert - X509Certificate
        key - PrivateKey for the certificate
        抛出：
        IllegalArgumentException - if either cert or key is null

      • X500PrivateCredential

        public X500PrivateCredential(X509Certificate cert,
                     PrivateKey key,
                     String alias)
        Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.

        参数：
        cert - X509Certificate
        key - PrivateKey for the certificate
        alias - KeyStore alias
        抛出：
        IllegalArgumentException - if either cert, key or alias is null

    • 方法详细信息

      • getCertificate

        public X509Certificate getCertificate()
        Returns the X.509 certificate.

        返回：
        the X509Certificate

      • getPrivateKey

        public PrivateKey getPrivateKey()
        Returns the PrivateKey.

        返回：
        the PrivateKey

      • getAlias

        public String getAlias()
        Returns the KeyStore alias.

        返回：
        the KeyStore alias

      • destroy

        public void destroy()
        Clears the references to the X.509 certificate, private key and the KeyStore alias in this object.
        指定者：
        destroy in interface Destroyable

      • isDestroyed

        public boolean isDestroyed()
        Determines if the references to the X.509 certificate and private key in this object have been cleared.

        指定者：
        isDestroyed in interface Destroyable
        返回：
        true if X509Certificate and the PrivateKey are null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

efr>.ajlaj a j stiisT>opssd h.r/ afd>�<�/


Uses of Class javax.security.auth.x500.X500Principal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.x500.X500Principal

  • Packages that use X500Principal
    软件包 描述
    java.security.cert
    Provides classes and interfaces for parsing and managing certificates, certificate revocation lists (CRLs), and certification paths.

    • Uses of X500Principal in java.security.cert

      Methods in java.security.cert that return X500Principal
      修饰符与类型 方法与描述
      X500Principal CertificateRevokedException.getAuthorityName()
      Returns the name of the authority that signed the certificate's revocation status information.
      X500Principal TrustAnchor.getCA()
      Returns the name of the most-trusted CA as an X500Principal.
      X500Principal X509CRLEntry.getCertificateIssuer()
      Get the issuer of the X509Certificate described by this entry.
      X500Principal X509CertSelector.getIssuer()
      Returns the issuer criterion as an X500Principal.
      X500Principal X509CRL.getIssuerX500Principal()
      Returns the issuer (issuer distinguished name) value from the CRL as an X500Principal.
      X500Principal X509Certificate.getIssuerX500Principal()
      Returns the issuer (issuer distinguished name) value from the certificate as an X500Principal.
      X500Principal X509CertSelector.getSubject()
      Returns the subject criterion as an X500Principal.
      X500Principal X509Certificate.getSubjectX500Principal()
      Returns the subject (subject distinguished name) value from the certificate as an X500Principal.
      Methods in java.security.cert that return types with arguments of type X500Principal
      修饰符与类型 方法与描述
      Collection<X500Principal> X509CRLSelector.getIssuers()
      Returns the issuerNames criterion.
      Methods in java.security.cert with parameters of type X500Principal
      修饰符与类型 方法与描述
      void X509CRLSelector.addIssuer(X500Principal issuer)
      Adds a name to the issuerNames criterion.
      void X509CertSelector.setIssuer(X500Principal issuer)
      Sets the issuer criterion.
      void X509CertSelector.setSubject(X500Principal subject)
      Sets the subject criterion.
      Method parameters in java.security.cert with type arguments of type X500Principal
      修饰符与类型 方法与描述
      void X509CRLSelector.setIssuers(Collection<X500Principal> issuers)
      Sets the issuerNames criterion.
      Constructors in java.security.cert with parameters of type X500Principal
      构造方法与描述
      CertificateRevokedException(Date revocationDate, CRLReason reason, X500Principal authority, Map<String,Extension> extensions)
      Constructs a CertificateRevokedException with the specified revocation date, reason code, authority name, and map of extensions.
      TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
      Creates an instance of TrustAnchor where the most-trusted CA is specified as an X500Principal and public key.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsgvs�> naf


Uses of Class javax.security.auth.x500.X500PrivateCredential

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.auth.x500.X500PrivateCredential

No usage of javax.security.auth.x500.X500PrivateCredential
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u stsecajvvv..aa


Certificate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.cert

类 Certificate

  • java.lang.Object
    • javax.security.cert.Certificate
  • 直接已知子类：
    X509Certificate

    public abstract class Certificate
extends Object

    Abstract class for managing a variety of identity certificates. An identity certificate is a guarantee by a principal that a public key is that of another principal. (A principal represents an entity such as an individual user, a group, or a corporation.)

    This class is an abstraction for certificates that have different formats but important common uses. For example, different types of certificates, such as X.509 and PGP, share general certificate functionality (like encoding and verifying) and some types of information (like a public key).

    X.509, PGP, and SDSI certificates can all be implemented by subclassing the Certificate class, even though they contain different sets of information, and they store and retrieve the information in different ways.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    X509Certificate

    • 构造方法摘要

      Constructors
      构造方法与描述
      Certificate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object other)
      Compares this certificate for equality with the specified object.
      abstract byte[] getEncoded()
      Returns the encoded form of this certificate.
      abstract PublicKey getPublicKey()
      Gets the public key from this certificate.
      int hashCode()
      Returns a hashcode value for this certificate from its encoded form.
      abstract String toString()
      Returns a string representation of this certificate.
      abstract void verify(PublicKey key)
      Verifies that this certificate was signed using the private key that corresponds to the specified public key.
      abstract void verify(PublicKey key, String sigProvider)
      Verifies that this certificate was signed using the private key that corresponds to the specified public key.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Certificate

        public Certificate()

    • 方法详细信息

      • equals

        public boolean equals(Object other)
        Compares this certificate for equality with the specified object. If the other object is an instanceof Certificate, then its encoded form is retrieved and compared with the encoded form of this certificate.
        重载：
        equals in class Object
        参数：
        other - the object to test for equality with this certificate.
        返回：
        true if the encoded forms of the two certificates match, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hashcode value for this certificate from its encoded form.
        重载：
        hashCode in class Object
        返回：
        the hashcode value.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • getEncoded

        public abstract byte[] getEncoded()
                           throws CertificateEncodingException
        Returns the encoded form of this certificate. It is assumed that each certificate type would have only a single form of encoding; for example, X.509 certificates would be encoded as ASN.1 DER.
        返回：
        encoded form of this certificate
        抛出：
        CertificateEncodingException - on internal certificate encoding failure

      • verify

        public abstract void verify(PublicKey key)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        Verifies that this certificate was signed using the private key that corresponds to the specified public key.
        参数：
        key - the PublicKey used to carry out the verification.
        抛出：
        NoSuchAlgorithmException - on unsupported signature algorithms.
        InvalidKeyException - on incorrect key.
        NoSuchProviderException - if there's no default provider.
        SignatureException - on signature errors.
        CertificateException - on encoding errors.

      • verify

        public abstract void verify(PublicKey key,
          String sigProvider)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
        Verifies that this certificate was signed using the private key that corresponds to the specified public key. This method uses the signature verification engine supplied by the specified provider.
        参数：
        key - the PublicKey used to carry out the verification.
        sigProvider - the name of the signature provider.
        抛出：
        NoSuchAlgorithmException - on unsupported signature algorithms.
        InvalidKeyException - on incorrect key.
        NoSuchProviderException - on incorrect provider.
        SignatureException - on signature errors.
        CertificateException - on encoding errors.

      • toString

        public abstract String toString()
        Returns a string representation of this certificate.
        重载：
        toString in class Object
        返回：
        a string representation of this certificate.

      • getPublicKey

        public abstract PublicKey getPublicKey()
        Gets the public key from this certificate.
        返回：
        the public key.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.oZ>s>snh.>ithe/cerm<�(e


CertificateEncodingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.cert

类 CertificateEncodingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
  • 所有已实现的接口：
    Serializable

    public class CertificateEncodingException
extends CertificateException
    Certificate Encoding Exception. This is thrown whenever an error occurs whilst attempting to encode a certificate.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertificateEncodingException()
      Constructs a CertificateEncodingException with no detail message.
      CertificateEncodingException(String message)
      Constructs a CertificateEncodingException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertificateEncodingException

        public CertificateEncodingException()
        Constructs a CertificateEncodingException with no detail message. A detail message is a String that describes this particular exception.

      • CertificateEncodingException

        public CertificateEncodingException(String message)
        Constructs a CertificateEncodingException with the specified detail message. A detail message is a String that describes this particular exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vh


CertificateException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.cert

类 CertificateException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.cert.CertificateException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    CertificateEncodingException, CertificateExpiredException, CertificateNotYetValidException, CertificateParsingException

    public class CertificateException
extends Exception
    This exception indicates one of a variety of certificate problems.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Certificate, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertificateException()
      Constructs a certificate exception with no detail message.
      CertificateException(String msg)
      Constructs a certificate exception with the given detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertificateException

        public CertificateException()
        Constructs a certificate exception with no detail message. A detail message is a String that describes this particular exception.

      • CertificateException

        public CertificateException(String msg)
        Constructs a certificate exception with the given detail message. A detail message is a String that describes this particular exception.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shpRrn>on=s"/ ss d<


CertificateExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.cert

类 CertificateExpiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateExpiredException
  • 所有已实现的接口：
    Serializable

    public class CertificateExpiredException
extends CertificateException
    Certificate Expired Exception. This is thrown whenever the current Date or the specified Date is after the notAfter date/time specified in the validity period of the certificate.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertificateExpiredException()
      Constructs a CertificateExpiredException with no detail message.
      CertificateExpiredException(String message)
      Constructs a CertificateExpiredException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertificateExpiredException

        public CertificateExpiredException()
        Constructs a CertificateExpiredException with no detail message. A detail message is a String that describes this particular exception.

      • CertificateExpiredException

        public CertificateExpiredException(String message)
        Constructs a CertificateExpiredException with the specified detail message. A detail message is a String that describes this particular exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;g #/#�#9#&0a9;9 , p,x29111le吮华醓o


CertificateNotYetValidException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.cert

类 CertificateNotYetValidException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateNotYetValidException
  • 所有已实现的接口：
    Serializable

    public class CertificateNotYetValidException
extends CertificateException
    Certificate is not yet valid exception. This is thrown whenever the current Date or the specified Date is before the notBefore date/time in the Certificate validity period.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertificateNotYetValidException()
      Constructs a CertificateNotYetValidException with no detail message.
      CertificateNotYetValidException(String message)
      Constructs a CertificateNotYetValidException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertificateNotYetValidException

        public CertificateNotYetValidException()
        Constructs a CertificateNotYetValidException with no detail message. A detail message is a String that describes this particular exception.

      • CertificateNotYetValidException

        public CertificateNotYetValidException(String message)
        Constructs a CertificateNotYetValidException with the specified detail message. A detail message is a String that describes this particular exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<oo>s .;;鴉;


CertificateParsingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.cert

类 CertificateParsingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateParsingException
  • 所有已实现的接口：
    Serializable

    public class CertificateParsingException
extends CertificateException
    Certificate Parsing Exception. This is thrown whenever invalid DER encoded certificate is parsed or unsupported DER features are found in the Certificate.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      CertificateParsingException()
      Constructs a CertificateParsingException with no detail message.
      CertificateParsingException(String message)
      Constructs a CertificateParsingException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CertificateParsingException

        public CertificateParsingException()
        Constructs a CertificateParsingException with no detail message. A detail message is a String that describes this particular exception.

      • CertificateParsingException

        public CertificateParsingException(String message)
        Constructs a CertificateParsingException with the specified detail message. A detail message is a String that describes this particular exception.
        参数：
        message - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fs=<<rc


javax.security.cert

Classes

  • Certificate
  • X509Certificate

Exceptions

  • CertificateEncodingException
  • CertificateException
  • CertificateExpiredException
  • CertificateNotYetValidException
  • CertificateParsingException
>


javax.security.cert

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.cert

Provides classes for public key certificates.

请参见： 描述

  • Class Summary
    类 描述
    Certificate
    Abstract class for managing a variety of identity certificates.
    X509Certificate
    Abstract class for X.509 v1 certificates.
  • Exception Summary
    Exception 描述
    CertificateEncodingException
    Certificate Encoding Exception.
    CertificateException
    This exception indicates one of a variety of certificate problems.
    CertificateExpiredException
    Certificate Expired Exception.
    CertificateNotYetValidException
    Certificate is not yet valid exception.
    CertificateParsingException
    Certificate Parsing Exception.

软件包 javax.security.cert Description

Provides classes for public key certificates.

These classes include a simplified version of the java.security.cert package. These classes were developed as part of the Java Secure Socket Extension (JSSE). When JSSE was added to the J2SE version 1.4, this package was added for backward-compatibility reasons only.

New applications should not use this package, but rather java.security.cert.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.rnea//wwOO(a.. hra


javax.security.cert Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.cert

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
          • javax.security.cert.CertificateExpiredException
          • javax.security.cert.CertificateNotYetValidException
          • javax.security.cert.CertificateParsingException
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

phr/=.fe=== >""s>gpar


Uses of Package javax.security.cert

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.cert

  • Packages that use javax.security.cert
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.
    javax.security.cert
    Provides classes for public key certificates.
  • Classes in javax.security.cert used by javax.net.ssl
    类与描述
    X509Certificate
    Abstract class for X.509 v1 certificates.
  • Classes in javax.security.cert used by javax.security.cert
    类与描述
    Certificate
    Abstract class for managing a variety of identity certificates.
    CertificateEncodingException
    Certificate Encoding Exception.
    CertificateException
    This exception indicates one of a variety of certificate problems.
    CertificateExpiredException
    Certificate Expired Exception.
    CertificateNotYetValidException
    Certificate is not yet valid exception.
    X509Certificate
    Abstract class for X.509 v1 certificates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bnas <<< as 0A= 錫ap/>t


X509Certificate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.cert

类 X509Certificate

  • java.lang.Object
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate

  • public abstract class X509Certificate
extends Certificate
    Abstract class for X.509 v1 certificates. This provides a standard way to access all the version 1 attributes of an X.509 certificate. Attributes that are specific to X.509 v2 or v3 are not available through this interface. Future API evolution will provide full access to complete X.509 v3 attributes.

    The basic X.509 format was defined by ISO/IEC and ANSI X9 and is described below in ASN.1:

     Certificate  ::=  SEQUENCE  {
     tbsCertificate       TBSCertificate,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

    These certificates are widely used to support authentication and other functionality in Internet security systems. Common applications include Privacy Enhanced Mail (PEM), Transport Layer Security (SSL), code signing for trusted software distribution, and Secure Electronic Transactions (SET).

    These certificates are managed and vouched for by Certificate Authorities (CAs). CAs are services which create certificates by placing data in the X.509 standard format and then digitally signing that data. CAs act as trusted third parties, making introductions between principals who have no direct knowledge of each other. CA certificates are either signed by themselves, or by some other CA such as a "root" CA.

    The ASN.1 definition of tbsCertificate is:

     TBSCertificate  ::=  SEQUENCE  {
     version         [0]  EXPLICIT Version DEFAULT v1,
     serialNumber         CertificateSerialNumber,
     signature            AlgorithmIdentifier,
     issuer               Name,
     validity             Validity,
     subject              Name,
     subjectPublicKeyInfo SubjectPublicKeyInfo,
     }

    Here is sample code to instantiate an X.509 certificate:

     InputStream inStream = new FileInputStream("fileName-of-cert");
 X509Certificate cert = X509Certificate.getInstance(inStream);
 inStream.close();
    OR
     byte[] certData = <certificate read from a file, say>
 X509Certificate cert = X509Certificate.getInstance(certData);

    In either case, the code that instantiates an X.509 certificate consults the Java security properties file to locate the actual implementation or instantiates a default implementation.

    The Java security properties file is located in the file named <JAVA_HOME>/lib/security/java.security. <JAVA_HOME> refers to the value of the java.home system property, and specifies the directory where the JRE is installed. In the Security properties file, a default implementation for X.509 v1 may be given such as:

     cert.provider.x509v1=com.sun.security.cert.internal.x509.X509V1CertImpl

    The value of this cert.provider.x509v1 property has to be changed to instatiate another implementation. If this security property is not set, a default implementation will be used. Currently, due to possible security restrictions on access to Security properties, this value is looked up and cached at class initialization time and will fallback on a default implementation if the Security property is not accessible.

    Note: The classes in the package javax.security.cert exist for compatibility with earlier versions of the Java Secure Sockets Extension (JSSE). New applications should instead use the standard Java SE certificate classes located in java.security.cert.

    从以下版本开始：
    1.4
    另请参见：
    Certificate, X509Extension

    • 构造方法摘要

      Constructors
      构造方法与描述
      X509Certificate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void checkValidity()
      Checks that the certificate is currently valid.
      abstract void checkValidity(Date date)
      Checks that the specified date is within the certificate's validity period.
      static X509Certificate getInstance(byte[] certData)
      Instantiates an X509Certificate object, and initializes it with the specified byte array.
      static X509Certificate getInstance(InputStream inStream)
      Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream.
      abstract Principal getIssuerDN()
      Gets the issuer (issuer distinguished name) value from the certificate.
      abstract Date getNotAfter()
      Gets the notAfter date from the validity period of the certificate.
      abstract Date getNotBefore()
      Gets the notBefore date from the validity period of the certificate.
      abstract BigInteger getSerialNumber()
      Gets the serialNumber value from the certificate.
      abstract String getSigAlgName()
      Gets the signature algorithm name for the certificate signature algorithm.
      abstract String getSigAlgOID()
      Gets the signature algorithm OID string from the certificate.
      abstract byte[] getSigAlgParams()
      Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm.
      abstract Principal getSubjectDN()
      Gets the subject (subject distinguished name) value from the certificate.
      abstract int getVersion()
      Gets the version (version number) value from the certificate.

      • 方法 - 继承于类 javax.security.cert.Certificate

        equals, getEncoded, getPublicKey, hashCode, toString, verify, verify

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • X509Certificate

        public X509Certificate()

    • 方法详细信息

      • getInstance

        public static final X509Certificate getInstance(InputStream inStream)
                                         throws CertificateException
        Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream. The implementation (X509Certificate is an abstract class) is provided by the class specified as the value of the cert.provider.x509v1 property in the security properties file.

        Note: Only one DER-encoded certificate is expected to be in the input stream. Also, all X509Certificate subclasses must provide a constructor of the form:

         public <subClass>(InputStream inStream) ...
        参数：
        inStream - an input stream with the data to be read to initialize the certificate.
        返回：
        an X509Certificate object initialized with the data from the input stream.
        抛出：
        CertificateException - if a class initialization or certificate parsing error occurs.

      • getInstance

        public static final X509Certificate getInstance(byte[] certData)
                                         throws CertificateException
        Instantiates an X509Certificate object, and initializes it with the specified byte array. The implementation (X509Certificate is an abstract class) is provided by the class specified as the value of the cert.provider.x509v1 property in the security properties file.

        Note: All X509Certificate subclasses must provide a constructor of the form:

         public <subClass>(InputStream inStream) ...
        参数：
        certData - a byte array containing the DER-encoded certificate.
        返回：
        an X509Certificate object initialized with the data from certData.
        抛出：
        CertificateException - if a class initialization or certificate parsing error occurs.

      • checkValidity

        public abstract void checkValidity()
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
        Checks that the certificate is currently valid. It is if the current date and time are within the validity period given in the certificate.

        The validity period consists of two date/time values: the first and last dates (and times) on which the certificate is valid. It is defined in ASN.1 as:

         validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }
        抛出：
        CertificateExpiredException - if the certificate has expired.
        CertificateNotYetValidException - if the certificate is not yet valid.

      • checkValidity

        public abstract void checkValidity(Date date)
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
        Checks that the specified date is within the certificate's validity period. In other words, this determines whether the certificate would be valid at the specified date/time.
        参数：
        date - the Date to check against to see if this certificate is valid at that date/time.
        抛出：
        CertificateExpiredException - if the certificate has expired with respect to the date supplied.
        CertificateNotYetValidException - if the certificate is not yet valid with respect to the date supplied.
        另请参见：
        checkValidity()

      • getVersion

        public abstract int getVersion()
        Gets the version (version number) value from the certificate. The ASN.1 definition for this is:
         version         [0]  EXPLICIT Version DEFAULT v1

 Version  ::=  INTEGER  {  v1(0), v2(1), v3(2)  }
        返回：
        the version number from the ASN.1 encoding, i.e. 0, 1 or 2.

      • getSerialNumber

        public abstract BigInteger getSerialNumber()
        Gets the serialNumber value from the certificate. The serial number is an integer assigned by the certification authority to each certificate. It must be unique for each certificate issued by a given CA (i.e., the issuer name and serial number identify a unique certificate). The ASN.1 definition for this is:
         serialNumber     CertificateSerialNumber

 CertificateSerialNumber  ::=  INTEGER
        返回：
        the serial number.

      • getIssuerDN

        public abstract Principal getIssuerDN()
        Gets the issuer (issuer distinguished name) value from the certificate. The issuer name identifies the entity that signed (and issued) the certificate.

        The issuer name field contains an X.500 distinguished name (DN). The ASN.1 definition for this is:

         issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
        The Name describes a hierarchical name composed of attributes, such as country name, and corresponding values, such as US. The type of the AttributeValue component is determined by the AttributeType; in general it will be a directoryString. A directoryString is usually one of PrintableString, TeletexString or UniversalString.
        返回：
        a Principal whose name is the issuer distinguished name.

      • getSubjectDN

        public abstract Principal getSubjectDN()
        Gets the subject (subject distinguished name) value from the certificate. The ASN.1 definition for this is:
         subject    Name

        See getIssuerDN for Name and other relevant definitions.

        返回：
        a Principal whose name is the subject name.
        另请参见：
        getIssuerDN()

      • getNotBefore

        public abstract Date getNotBefore()
        Gets the notBefore date from the validity period of the certificate. The relevant ASN.1 definitions are:
         validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }
        返回：
        the start date of the validity period.
        另请参见：
        checkValidity()

      • getNotAfter

        public abstract Date getNotAfter()
        Gets the notAfter date from the validity period of the certificate. See getNotBefore for relevant ASN.1 definitions.
        返回：
        the end date of the validity period.
        另请参见：
        checkValidity()

      • getSigAlgName

        public abstract String getSigAlgName()
        Gets the signature algorithm name for the certificate signature algorithm. An example is the string "SHA-1/DSA". The ASN.1 definition for this is:
         signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

        The algorithm name is determined from the algorithm OID string.

        返回：
        the signature algorithm name.

      • getSigAlgOID

        public abstract String getSigAlgOID()
        Gets the signature algorithm OID string from the certificate. An OID is represented by a set of positive whole numbers separated by periods. For example, the string "1.2.840.10040.4.3" identifies the SHA-1 with DSA signature algorithm, as per the PKIX part I.

        See getSigAlgName for relevant ASN.1 definitions.

        返回：
        the signature algorithm OID string.

      • getSigAlgParams

        public abstract byte[] getSigAlgParams()
        Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm. In most cases, the signature algorithm parameters are null; the parameters are usually supplied with the certificate's public key.

        See getSigAlgName for relevant ASN.1 definitions.

        返回：
        the DER-encoded signature algorithm parameters, or null if no parameters are present.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.security.cert.Certificate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.Certificate

  • Packages that use Certificate
    软件包 描述
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of Certificate in javax.security.cert

      Subclasses of Certificate in javax.security.cert
      修饰符与类型 类与描述
      class  X509Certificate
      Abstract class for X.509 v1 certificates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n v>m.o


Uses of Class javax.security.cert.CertificateEncodingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.CertificateEncodingException

  • Packages that use CertificateEncodingException
    软件包 描述
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of CertificateEncodingException in javax.security.cert

      Methods in javax.security.cert that throw CertificateEncodingException
      修饰符与类型 方法与描述
      abstract byte[] Certificate.getEncoded()
      Returns the encoded form of this certificate.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r< >hOsPaopO"/tbf.篹e


Uses of Class javax.security.cert.CertificateException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.CertificateException

  • Packages that use CertificateException
    软件包 描述
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of CertificateException in javax.security.cert

      Subclasses of CertificateException in javax.security.cert
      修饰符与类型 类与描述
      class  CertificateEncodingException
      Certificate Encoding Exception.
      class  CertificateExpiredException
      Certificate Expired Exception.
      class  CertificateNotYetValidException
      Certificate is not yet valid exception.
      class  CertificateParsingException
      Certificate Parsing Exception.
      Methods in javax.security.cert that throw CertificateException
      修饰符与类型 方法与描述
      static X509Certificate X509Certificate.getInstance(byte[] certData)
      Instantiates an X509Certificate object, and initializes it with the specified byte array.
      static X509Certificate X509Certificate.getInstance(InputStream inStream)
      Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream.
      abstract void Certificate.verify(PublicKey key)
      Verifies that this certificate was signed using the private key that corresponds to the specified public key.
      abstract void Certificate.verify(PublicKey key, String sigProvider)
      Verifies that this certificate was signed using the private key that corresponds to the specified public key.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cpnNlme/rsAt=a


Uses of Class javax.security.cert.CertificateExpiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.CertificateExpiredException

  • Packages that use CertificateExpiredException
    软件包 描述
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of CertificateExpiredException in javax.security.cert

      Methods in javax.security.cert that throw CertificateExpiredException
      修饰符与类型 方法与描述
      abstract void X509Certificate.checkValidity()
      Checks that the certificate is currently valid.
      abstract void X509Certificate.checkValidity(Date date)
      Checks that the specified date is within the certificate's validity period.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.b/.hre(><<


Uses of Class javax.security.cert.CertificateNotYetValidException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.CertificateNotYetValidException

  • Packages that use CertificateNotYetValidException
    软件包 描述
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of CertificateNotYetValidException in javax.security.cert

      Methods in javax.security.cert that throw CertificateNotYetValidException
      修饰符与类型 方法与描述
      abstract void X509Certificate.checkValidity()
      Checks that the certificate is currently valid.
      abstract void X509Certificate.checkValidity(Date date)
      Checks that the specified date is within the certificate's validity period.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ys"/Anf"i/antisrr/.cs< r


Uses of Class javax.security.cert.CertificateParsingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.CertificateParsingException

No usage of javax.security.cert.CertificateParsingException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ivsf sp ttttt>ll="nla


Uses of Class javax.security.cert.X509Certificate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.cert.X509Certificate

  • Packages that use X509Certificate
    软件包 描述
    javax.net.ssl
    Provides classes for the secure socket package.
    javax.security.cert
    Provides classes for public key certificates.

    • Uses of X509Certificate in javax.net.ssl

      Methods in javax.net.ssl that return X509Certificate
      修饰符与类型 方法与描述
      X509Certificate[] HandshakeCompletedEvent.getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.
      X509Certificate[] SSLSession.getPeerCertificateChain()
      Returns the identity of the peer which was identified as part of defining the session.

    • Uses of X509Certificate in javax.security.cert

      Methods in javax.security.cert that return X509Certificate
      修饰符与类型 方法与描述
      static X509Certificate X509Certificate.getInstance(byte[] certData)
      Instantiates an X509Certificate object, and initializes it with the specified byte array.
      static X509Certificate X509Certificate.getInstance(InputStream inStream)
      Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rmg te


AuthenticationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.sasl

类 AuthenticationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException
  • 所有已实现的接口：
    Serializable

    public class AuthenticationException
extends SaslException
    This exception is thrown by a SASL mechanism implementation to indicate that the SASL exchange has failed due to reasons related to authentication, such as an invalid identity, passphrase, or key.

    Note that the lack of an AuthenticationException does not mean that the failure was not due to an authentication error. A SASL mechanism implementation might throw the more general SaslException instead of AuthenticationException if it is unable to determine the nature of the failure, or if does not want to disclose the nature of the failure, for example, due to security reasons.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AuthenticationException()
      Constructs a new instance of AuthenticationException.
      AuthenticationException(String detail)
      Constructs a new instance of AuthenticationException with a detailed message.
      AuthenticationException(String detail, Throwable ex)
      Constructs a new instance of AuthenticationException with a detailed message and a root exception.

    • 方法摘要

      • 方法 - 继承于类 javax.security.sasl.SaslException

        getCause, initCause, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AuthenticationException

        public AuthenticationException()
        Constructs a new instance of AuthenticationException. The root exception and the detailed message are null.

      • AuthenticationException

        public AuthenticationException(String detail)
        Constructs a new instance of AuthenticationException with a detailed message. The root exception is null.
        参数：
        detail - A possibly null string containing details of the exception.
        另请参见：
        Throwable.getMessage()

      • AuthenticationException

        public AuthenticationException(String detail,
                       Throwable ex)
        Constructs a new instance of AuthenticationException with a detailed message and a root exception.
        参数：
        detail - A possibly null string containing details of the exception.
        ex - A possibly null root exception that caused this exception.
        另请参见：
        Throwable.getMessage(), SaslException.getCause()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oh la囊RAa>= a


AuthorizeCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.sasl

类 AuthorizeCallback

  • java.lang.Object
    • javax.security.sasl.AuthorizeCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class AuthorizeCallback
extends Object
implements Callback, Serializable
    This callback is used by SaslServer to determine whether one entity (identified by an authenticated authentication id) can act on behalf of another entity (identified by an authorization id).
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AuthorizeCallback(String authnID, String authzID)
      Constructs an instance of AuthorizeCallback.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAuthenticationID()
      Returns the authentication id to check.
      String getAuthorizationID()
      Returns the authorization id to check.
      String getAuthorizedID()
      Returns the id of the authorized user.
      boolean isAuthorized()
      Determines whether the authentication id is allowed to act on behalf of the authorization id.
      void setAuthorized(boolean ok)
      Sets whether the authorization is allowed.
      void setAuthorizedID(String id)
      Sets the id of the authorized entity.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AuthorizeCallback

        public AuthorizeCallback(String authnID,
                 String authzID)
        Constructs an instance of AuthorizeCallback.
        参数：
        authnID - The (authenticated) authentication id.
        authzID - The authorization id.

    • 方法详细信息

      • getAuthenticationID

        public String getAuthenticationID()
        Returns the authentication id to check.
        返回：
        The authentication id to check.

      • getAuthorizationID

        public String getAuthorizationID()
        Returns the authorization id to check.
        返回：
        The authentication id to check.

      • isAuthorized

        public boolean isAuthorized()
        Determines whether the authentication id is allowed to act on behalf of the authorization id.
        返回：
        true if authorization is allowed; false otherwise
        另请参见：
        setAuthorized(boolean), getAuthorizedID()

      • setAuthorized

        public void setAuthorized(boolean ok)
        Sets whether the authorization is allowed.
        参数：
        ok - true if authorization is allowed; false otherwise
        另请参见：
        isAuthorized(), setAuthorizedID(java.lang.String)

      • getAuthorizedID

        public String getAuthorizedID()
        Returns the id of the authorized user.
        返回：
        The id of the authorized user. null means the authorization failed.
        另请参见：
        setAuthorized(boolean), setAuthorizedID(java.lang.String)

      • setAuthorizedID

        public void setAuthorizedID(String id)
        Sets the id of the authorized entity. Called by handler only when the id is different from getAuthorizationID(). For example, the id might need to be canonicalized for the environment in which it will be used.
        参数：
        id - The id of the authorized user.
        另请参见：
        setAuthorized(boolean), getAuthorizedID()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nm_iu.nlttntoelul" �<皒-"猣詄縤y�


javax.security.sasl

Interfaces

  • SaslClient
  • SaslClientFactory
  • SaslServer
  • SaslServerFactory

Classes

  • AuthorizeCallback
  • RealmCallback
  • RealmChoiceCallback
  • Sasl

Exceptions

  • AuthenticationException
  • SaslException
=


javax.security.sasl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.security.sasl

Contains class and interfaces for supporting SASL.

请参见： 描述

  • 接口摘要
    接口 描述
    SaslClient
    Performs SASL authentication as a client.
    SaslClientFactory
    An interface for creating instances of SaslClient.
    SaslServer
    Performs SASL authentication as a server.
    SaslServerFactory
    An interface for creating instances of SaslServer.
  • Class Summary
    类 描述
    AuthorizeCallback
    This callback is used by SaslServer to determine whether one entity (identified by an authenticated authentication id) can act on behalf of another entity (identified by an authorization id).
    RealmCallback
    This callback is used by SaslClient and SaslServer to retrieve realm information.
    RealmChoiceCallback
    This callback is used by SaslClient and SaslServer to obtain a realm given a list of realm choices.
    Sasl
    A static class for creating SASL clients and servers.
  • Exception Summary
    Exception 描述
    AuthenticationException
    This exception is thrown by a SASL mechanism implementation to indicate that the SASL exchange has failed due to reasons related to authentication, such as an invalid identity, passphrase, or key.
    SaslException
    This class represents an error that has occurred when using SASL.

软件包 javax.security.sasl Description

Contains class and interfaces for supporting SASL. This package defines classes and interfaces for SASL mechanisms. It is used by developers to add authentication support for connection-based protocols that use SASL.

SASL Overview

Simple Authentication and Security Layer (SASL) specifies a challenge-response protocol in which data is exchanged between the client and the server for the purposes of authentication and (optional) establishment of a security layer on which to carry on subsequent communications. It is used with connection-based protocols such as LDAPv3 or IMAPv4. SASL is described in RFC 2222.

There are various mechanisms defined for SASL. Each mechanism defines the data that must be exchanged between the client and server in order for the authentication to succeed. This data exchange required for a particular mechanism is referred to to as its protocol profile. The following are some examples of mechanims that have been defined by the Internet standards community.

  • DIGEST-MD5 (RFC 2831). This mechanism defines how HTTP Digest Authentication can be used as a SASL mechanism.
  • Anonymous (RFC 2245). This mechamism is anonymous authentication in which no credentials are necessary.
  • External (RFC 2222). This mechanism obtains authentication information from an external source (such as TLS or IPsec).
  • S/Key (RFC 2222). This mechanism uses the MD4 digest algorithm to exchange data based on a shared secret.
  • GSSAPI (RFC 2222). This mechanism uses the GSSAPI for obtaining authentication information.

Some of these mechanisms provide both authentication and establishment of a security layer, others only authentication. Anonymous and S/Key do not provide for any security layers. GSSAPI and DIGEST-MD5 allow negotiation of the security layer. For External, the security layer is determined by the external protocol.

Usage

Users of this API are typically developers who produce client library implementations for connection-based protocols, such as LDAPv3 and IMAPv4, and developers who write servers (such as LDAP servers and IMAP servers). Developers who write client libraries use the SaslClient and SaslClientFactory interfaces. Developers who write servers use the SaslServer and SaslServerFactory interfaces.

Among these two groups of users, each can be further divided into two groups: those who produce the SASL mechanisms and those who 使用 the SASL mechanisms. The producers of SASL mechanisms need to provide implementations for these interfaces, while users of the SASL mechanisms use the APIs in this package to access those implementations.

Related Documentation

Please refer to the Java SASL Programming Guide for information on how to use this API.
从以下版本开始：
1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/..v/<>a >a,aa>ctt>>/<


javax.security.sasl Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.security.sasl

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.security.sasl.AuthorizeCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmChoiceCallback
    • javax.security.sasl.Sasl
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmCallback
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException

Interface Hierarchy

  • javax.security.sasl.SaslClient
  • javax.security.sasl.SaslClientFactory
  • javax.security.sasl.SaslServer
  • javax.security.sasl.SaslServerFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dc4uhsemccci/ttas((ph


RealmCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.sasl

类 RealmCallback

  • java.lang.Object
    • javax.security.auth.callback.TextInputCallback
      • javax.security.sasl.RealmCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class RealmCallback
extends TextInputCallback
    This callback is used by SaslClient and SaslServer to retrieve realm information.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RealmCallback(String prompt)
      Constructs a RealmCallback with a prompt.
      RealmCallback(String prompt, String defaultRealmInfo)
      Constructs a RealmCallback with a prompt and default realm information.

    • 方法摘要

      • 方法 - 继承于类 javax.security.auth.callback.TextInputCallback

        getDefaultText, getPrompt, getText, setText

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RealmCallback

        public RealmCallback(String prompt)
        Constructs a RealmCallback with a prompt.
        参数：
        prompt - The non-null prompt to use to request the realm information.
        抛出：
        IllegalArgumentException - If prompt is null or the empty string.

      • RealmCallback

        public RealmCallback(String prompt,
             String defaultRealmInfo)
        Constructs a RealmCallback with a prompt and default realm information.
        参数：
        prompt - The non-null prompt to use to request the realm information.
        defaultRealmInfo - The non-null default realm information to use.
        抛出：
        IllegalArgumentException - If prompt is null or the empty string, or if defaultRealm is empty or null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/4d


RealmChoiceCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.security.sasl

类 RealmChoiceCallback

  • java.lang.Object
    • javax.security.auth.callback.ChoiceCallback
      • javax.security.sasl.RealmChoiceCallback
  • 所有已实现的接口：
    Serializable, Callback

    public class RealmChoiceCallback
extends ChoiceCallback
    This callback is used by SaslClient and SaslServer to obtain a realm given a list of realm choices.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
      Constructs a RealmChoiceCallback with a prompt, a list of choices and a default choice.

    • 方法摘要

      • 方法 - 继承于类 javax.security.auth.callback.ChoiceCallback

        allowMultipleSelections, getChoices, getDefaultChoice, getPrompt, getSelectedIndexes, setSelectedIndex, setSelectedIndexes

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RealmChoiceCallback

        public RealmChoiceCallback(String prompt,
                   String[] choices,
                   int defaultChoice,
                   boolean multiple)
        Constructs a RealmChoiceCallback with a prompt, a list of choices and a default choice.
        参数：
        prompt - the non-null prompt to use to request the realm.
        choices - the non-null list of realms to choose from.
        defaultChoice - the choice to be used as the default choice when the list of choices is displayed. It is an index into the choices arary.
        multiple - true if multiple choices allowed; false otherwise
        抛出：
        IllegalArgumentException - If prompt is null or the empty string, if choices has a length of 0, if any element from choices is null or empty, or if defaultChoice does not fall within the array boundary of choices
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>3pTpApbpsab13/o/88ren1><<>g>/


Sasl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.sasl

类 Sasl

  • java.lang.Object
    • javax.security.sasl.Sasl

  • public class Sasl
extends Object
    A static class for creating SASL clients and servers.

    This class defines the policy of how to locate, load, and instantiate SASL clients and servers.

    For example, an application or library gets a SASL client by doing something like:

     SaslClient sc = Sasl.createSaslClient(mechanisms,
     authorizationId, protocol, serverName, props, callbackHandler);
    It can then proceed to use the instance to create an authentication connection.

    Similarly, a server gets a SASL server by using code that looks as follows:

     SaslServer ss = Sasl.createSaslServer(mechanism,
     protocol, serverName, props, callbackHandler);
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CREDENTIALS
      The name of a property that specifies the credentials to use.
      static String MAX_BUFFER
      The name of a property that specifies the maximum size of the receive buffer in bytes of SaslClient/SaslServer.
      static String POLICY_FORWARD_SECRECY
      The name of a property that specifies whether mechanisms that implement forward secrecy between sessions are required.
      static String POLICY_NOACTIVE
      The name of a property that specifies whether mechanisms susceptible to active (non-dictionary) attacks are not permitted.
      static String POLICY_NOANONYMOUS
      The name of a property that specifies whether mechanisms that accept anonymous login are not permitted.
      static String POLICY_NODICTIONARY
      The name of a property that specifies whether mechanisms susceptible to passive dictionary attacks are not permitted.
      static String POLICY_NOPLAINTEXT
      The name of a property that specifies whether mechanisms susceptible to simple plain passive attacks (e.g., "PLAIN") are not permitted.
      static String POLICY_PASS_CREDENTIALS
      The name of a property that specifies whether mechanisms that pass client credentials are required.
      static String QOP
      The name of a property that specifies the quality-of-protection to use.
      static String RAW_SEND_SIZE
      The name of a property that specifies the maximum size of the raw send buffer in bytes of SaslClient/SaslServer.
      static String REUSE
      The name of a property that specifies whether to reuse previously authenticated session information.
      static String SERVER_AUTH
      The name of a property that specifies whether the server must authenticate to the client.
      static String STRENGTH
      The name of a property that specifies the cipher strength to use.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SaslClient createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      static SaslServer createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer for the specified mechanism.
      static Enumeration<SaslClientFactory> getSaslClientFactories()
      Gets an enumeration of known factories for producing SaslClient.
      static Enumeration<SaslServerFactory> getSaslServerFactories()
      Gets an enumeration of known factories for producing SaslServer.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • QOP

        public static final String QOP
        The name of a property that specifies the quality-of-protection to use. The property contains a comma-separated, ordered list of quality-of-protection values that the client or server is willing to support. A qop value is one of
        • "auth" - authentication only
        • "auth-int" - authentication plus integrity protection
        • "auth-conf" - authentication plus integrity and confidentiality protection
        The order of the list specifies the preference order of the client or server. If this property is absent, the default qop is "auth". The value of this constant is "javax.security.sasl.qop".
        另请参见：
        Constant Field Values

      • STRENGTH

        public static final String STRENGTH
        The name of a property that specifies the cipher strength to use. The property contains a comma-separated, ordered list of cipher strength values that the client or server is willing to support. A strength value is one of
        • "low"
        • "medium"
        • "high"
        The order of the list specifies the preference order of the client or server. An implementation should allow configuration of the meaning of these values. An application may use the Java Cryptography Extension (JCE) with JCE-aware mechanisms to control the selection of cipher suites that match the strength values.
        If this property is absent, the default strength is "high,medium,low". The value of this constant is "javax.security.sasl.strength".
        另请参见：
        Constant Field Values

      • SERVER_AUTH

        public static final String SERVER_AUTH
        The name of a property that specifies whether the server must authenticate to the client. The property contains "true" if the server must authenticate the to client; "false" otherwise. The default is "false".
        The value of this constant is "javax.security.sasl.server.authentication".
        另请参见：
        Constant Field Values

      • MAX_BUFFER

        public static final String MAX_BUFFER
        The name of a property that specifies the maximum size of the receive buffer in bytes of SaslClient/SaslServer. The property contains the string representation of an integer.
        If this property is absent, the default size is defined by the mechanism.
        The value of this constant is "javax.security.sasl.maxbuffer".
        另请参见：
        Constant Field Values

      • RAW_SEND_SIZE

        public static final String RAW_SEND_SIZE
        The name of a property that specifies the maximum size of the raw send buffer in bytes of SaslClient/SaslServer. The property contains the string representation of an integer. The value of this property is negotiated between the client and server during the authentication exchange.
        The value of this constant is "javax.security.sasl.rawsendsize".
        另请参见：
        Constant Field Values

      • REUSE

        public static final String REUSE
        The name of a property that specifies whether to reuse previously authenticated session information. The property contains "true" if the mechanism implementation may attempt to reuse previously authenticated session information; it contains "false" if the implementation must not reuse previously authenticated session information. A setting of "true" serves only as a hint: it does not necessarily entail actual reuse because reuse might not be possible due to a number of reasons, including, but not limited to, lack of mechanism support for reuse, expiration of reusable information, and the peer's refusal to support reuse. The property's default value is "false". The value of this constant is "javax.security.sasl.reuse". Note that all other parameters and properties required to create a SASL client/server instance must be provided regardless of whether this property has been supplied. That is, you cannot supply any less information in anticipation of reuse. Mechanism implementations that support reuse might allow customization of its implementation, for factors such as cache size, timeouts, and criteria for reuseability. Such customizations are implementation-dependent.
        另请参见：
        Constant Field Values

      • POLICY_NOPLAINTEXT

        public static final String POLICY_NOPLAINTEXT
        The name of a property that specifies whether mechanisms susceptible to simple plain passive attacks (e.g., "PLAIN") are not permitted. The property contains "true" if such mechanisms are not permitted; "false" if such mechanisms are permitted. The default is "false".
        The value of this constant is "javax.security.sasl.policy.noplaintext".
        另请参见：
        Constant Field Values

      • POLICY_NOACTIVE

        public static final String POLICY_NOACTIVE
        The name of a property that specifies whether mechanisms susceptible to active (non-dictionary) attacks are not permitted. The property contains "true" if mechanisms susceptible to active attacks are not permitted; "false" if such mechanisms are permitted. The default is "false".
        The value of this constant is "javax.security.sasl.policy.noactive".
        另请参见：
        Constant Field Values

      • POLICY_NODICTIONARY

        public static final String POLICY_NODICTIONARY
        The name of a property that specifies whether mechanisms susceptible to passive dictionary attacks are not permitted. The property contains "true" if mechanisms susceptible to dictionary attacks are not permitted; "false" if such mechanisms are permitted. The default is "false".
        The value of this constant is "javax.security.sasl.policy.nodictionary".
        另请参见：
        Constant Field Values

      • POLICY_NOANONYMOUS

        public static final String POLICY_NOANONYMOUS
        The name of a property that specifies whether mechanisms that accept anonymous login are not permitted. The property contains "true" if mechanisms that accept anonymous login are not permitted; "false" if such mechanisms are permitted. The default is "false".
        The value of this constant is "javax.security.sasl.policy.noanonymous".
        另请参见：
        Constant Field Values

      • POLICY_FORWARD_SECRECY

        public static final String POLICY_FORWARD_SECRECY
        The name of a property that specifies whether mechanisms that implement forward secrecy between sessions are required. Forward secrecy means that breaking into one session will not automatically provide information for breaking into future sessions. The property contains "true" if mechanisms that implement forward secrecy between sessions are required; "false" if such mechanisms are not required. The default is "false".
        The value of this constant is "javax.security.sasl.policy.forward".
        另请参见：
        Constant Field Values

      • POLICY_PASS_CREDENTIALS

        public static final String POLICY_PASS_CREDENTIALS
        The name of a property that specifies whether mechanisms that pass client credentials are required. The property contains "true" if mechanisms that pass client credentials are required; "false" if such mechanisms are not required. The default is "false".
        The value of this constant is "javax.security.sasl.policy.credentials".
        另请参见：
        Constant Field Values

      • CREDENTIALS

        public static final String CREDENTIALS
        The name of a property that specifies the credentials to use. The property contains a mechanism-specific Java credential object. Mechanism implementations may examine the value of this property to determine whether it is a class that they support. The property may be used to supply credentials to a mechanism that supports delegated authentication.
        The value of this constant is "javax.security.sasl.credentials".
        另请参见：
        Constant Field Values

    • 方法详细信息

      • createSaslClient

        public static SaslClient createSaslClient(String[] mechanisms,
                          String authorizationId,
                          String protocol,
                          String serverName,
                          Map<String,?> props,
                          CallbackHandler cbh)
                                   throws SaslException
        Creates a SaslClient using the parameters supplied. This method uses the JCA Security Provider Framework, described in the "Java Cryptography Architecture API Specification & Reference", for locating and selecting a SaslClient implementation. First, it obtains an ordered list of SaslClientFactory instances from the registered security providers for the "SaslClientFactory" service and the specified SASL mechanism(s). It then invokes createSaslClient() on each factory instance on the list until one produces a non-null SaslClient instance. It returns the non-null SaslClient instance, or null if the search fails to produce a non-null SaslClient instance.

        A security provider for SaslClientFactory registers with the JCA Security Provider Framework keys of the form
        SaslClientFactory.mechanism_name
        and values that are class names of implementations of javax.security.sasl.SaslClientFactory. For example, a provider that contains a factory class, com.wiz.sasl.digest.ClientFactory, that supports the "DIGEST-MD5" mechanism would register the following entry with the JCA: SaslClientFactory.DIGEST-MD5 com.wiz.sasl.digest.ClientFactory

        See the "Java Cryptography Architecture API Specification & Reference" for information about how to install and configure security service providers.

        参数：
        mechanisms - The non-null list of mechanism names to try. Each is the IANA-registered name of a SASL mechanism. (e.g. "GSSAPI", "CRAM-MD5").
        authorizationId - The possibly null protocol-dependent identification to be used for authorization. If null or empty, the server derives an authorization ID from the client's authentication credentials. When the SASL authentication completes successfully, the specified entity is granted access.
        protocol - The non-null string name of the protocol for which the authentication is being performed (e.g., "ldap").
        serverName - The non-null fully-qualified host name of the server to authenticate to.
        props - The possibly null set of properties used to select the SASL mechanism and to configure the authentication exchange of the selected mechanism. For example, if props contains the Sasl.POLICY_NOPLAINTEXT property with the value "true", then the selected SASL mechanism must not be susceptible to simple plain passive attacks. In addition to the standard properties declared in this class, other, possibly mechanism-specific, properties can be included. Properties not relevant to the selected mechanism are ignored, including any map entries with non-String keys.
        cbh - The possibly null callback handler to used by the SASL mechanisms to get further information from the application/library to complete the authentication. For example, a SASL mechanism might require the authentication ID, password and realm from the caller. The authentication ID is requested by using a NameCallback. The password is requested by using a PasswordCallback. The realm is requested by using a RealmChoiceCallback if there is a list of realms to choose from, and by using a RealmCallback if the realm must be entered.
        返回：
        A possibly null SaslClient created using the parameters supplied. If null, cannot find a SaslClientFactory that will produce one.
        抛出：
        SaslException - If cannot create a SaslClient because of an error.

      • createSaslServer

        public static SaslServer createSaslServer(String mechanism,
                          String protocol,
                          String serverName,
                          Map<String,?> props,
                          CallbackHandler cbh)
                                   throws SaslException
        Creates a SaslServer for the specified mechanism. This method uses the JCA Security Provider Framework, described in the "Java Cryptography Architecture API Specification & Reference", for locating and selecting a SaslServer implementation. First, it obtains an ordered list of SaslServerFactory instances from the registered security providers for the "SaslServerFactory" service and the specified mechanism. It then invokes createSaslServer() on each factory instance on the list until one produces a non-null SaslServer instance. It returns the non-null SaslServer instance, or null if the search fails to produce a non-null SaslServer instance.

        A security provider for SaslServerFactory registers with the JCA Security Provider Framework keys of the form
        SaslServerFactory.mechanism_name
        and values that are class names of implementations of javax.security.sasl.SaslServerFactory. For example, a provider that contains a factory class, com.wiz.sasl.digest.ServerFactory, that supports the "DIGEST-MD5" mechanism would register the following entry with the JCA: SaslServerFactory.DIGEST-MD5 com.wiz.sasl.digest.ServerFactory

        See the "Java Cryptography Architecture API Specification & Reference" for information about how to install and configure security service providers.

        参数：
        mechanism - The non-null mechanism name. It must be an IANA-registered name of a SASL mechanism. (e.g. "GSSAPI", "CRAM-MD5").
        protocol - The non-null string name of the protocol for which the authentication is being performed (e.g., "ldap").
        serverName - The non-null fully qualified host name of the server.
        props - The possibly null set of properties used to select the SASL mechanism and to configure the authentication exchange of the selected mechanism. For example, if props contains the Sasl.POLICY_NOPLAINTEXT property with the value "true", then the selected SASL mechanism must not be susceptible to simple plain passive attacks. In addition to the standard properties declared in this class, other, possibly mechanism-specific, properties can be included. Properties not relevant to the selected mechanism are ignored, including any map entries with non-String keys.
        cbh - The possibly null callback handler to used by the SASL mechanisms to get further information from the application/library to complete the authentication. For example, a SASL mechanism might require the authentication ID, password and realm from the caller. The authentication ID is requested by using a NameCallback. The password is requested by using a PasswordCallback. The realm is requested by using a RealmChoiceCallback if there is a list of realms to choose from, and by using a RealmCallback if the realm must be entered.
        返回：
        A possibly null SaslServer created using the parameters supplied. If null, cannot find a SaslServerFactory that will produce one.
        抛出：
        SaslException - If cannot create a SaslServer because of an error.

      • getSaslClientFactories

        public static Enumeration<SaslClientFactory> getSaslClientFactories()
        Gets an enumeration of known factories for producing SaslClient. This method uses the same algorithm for locating factories as createSaslClient().
        返回：
        A non-null enumeration of known factories for producing SaslClient.
        另请参见：
        createSaslClient(java.lang.String[], java.lang.String, java.lang.String, java.lang.String, java.util.Map, javax.security.auth.callback.CallbackHandler)

      • getSaslServerFactories

        public static Enumeration<SaslServerFactory> getSaslServerFactories()
        Gets an enumeration of known factories for producing SaslServer. This method uses the same algorithm for locating factories as createSaslServer().
        返回：
        A non-null enumeration of known factories for producing SaslServer.
        另请参见：
        createSaslServer(java.lang.String, java.lang.String, java.lang.String, java.util.Map, javax.security.auth.callback.CallbackHandler)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SaslClient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.sasl

Interface SaslClient

  • public interface SaslClient
    Performs SASL authentication as a client.

    A protocol library such as one for LDAP gets an instance of this class in order to perform authentication defined by a specific SASL mechanism. Invoking methods on the SaslClient instance process challenges and create responses according to the SASL mechanism implemented by the SaslClient. As the authentication proceeds, the instance encapsulates the state of a SASL client's authentication exchange.

    Here's an example of how an LDAP library might use a SaslClient. It first gets an instance of a SaslClient:

     SaslClient sc = Sasl.createSaslClient(mechanisms,
     authorizationId, protocol, serverName, props, callbackHandler);
    It can then proceed to use the client for authentication. For example, an LDAP library might use the client as follows:
     // Get initial response and send to server
 byte[] response = (sc.hasInitialResponse() ? sc.evaluateChallenge(new byte[0]) :
     null);
 LdapResult res = ldap.sendBindRequest(dn, sc.getName(), response);
 while (!sc.isComplete() &&
     (res.status == SASL_BIND_IN_PROGRESS || res.status == SUCCESS)) {
     response = sc.evaluateChallenge(res.getBytes());
     if (res.status == SUCCESS) {
         // we're done; don't expect to send another BIND
         if (response != null) {
             throw new SaslException(
                 "Protocol error: attempting to send response after completion");
         }
         break;
     }
     res = ldap.sendBindRequest(dn, sc.getName(), response);
 }
 if (sc.isComplete() && res.status == SUCCESS) {
    String qop = (String) sc.getNegotiatedProperty(Sasl.QOP);
    if (qop != null
        && (qop.equalsIgnoreCase("auth-int")
            || qop.equalsIgnoreCase("auth-conf"))) {

      // Use SaslClient.wrap() and SaslClient.unwrap() for future
      // communication with server
      ldap.in = new SecureInputStream(sc, ldap.in);
      ldap.out = new SecureOutputStream(sc, ldap.out);
    }
 }
    If the mechanism has an initial response, the library invokes evaluateChallenge() with an empty challenge and to get initial response. Protocols such as IMAP4, which do not include an initial response with their first authentication command to the server, initiates the authentication without first calling hasInitialResponse() or evaluateChallenge(). When the server responds to the command, it sends an initial challenge. For a SASL mechanism in which the client sends data first, the server should have issued a challenge with no data. This will then result in a call (on the client) to evaluateChallenge() with an empty challenge.
    从以下版本开始：
    1.5
    另请参见：
    Sasl, SaslClientFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispose()
      Disposes of any system resources or security-sensitive information the SaslClient might be using.
      byte[] evaluateChallenge(byte[] challenge)
      Evaluates the challenge data and generates a response.
      String getMechanismName()
      Returns the IANA-registered mechanism name of this SASL client.
      Object getNegotiatedProperty(String propName)
      Retrieves the negotiated property.
      boolean hasInitialResponse()
      Determines whether this mechanism has an optional initial response.
      boolean isComplete()
      Determines whether the authentication exchange has completed.
      byte[] unwrap(byte[] incoming, int offset, int len)
      Unwraps a byte array received from the server.
      byte[] wrap(byte[] outgoing, int offset, int len)
      Wraps a byte array to be sent to the server.

    • 方法详细信息

      • getMechanismName

        String getMechanismName()
        Returns the IANA-registered mechanism name of this SASL client. (e.g. "CRAM-MD5", "GSSAPI").
        返回：
        A non-null string representing the IANA-registered mechanism name.

      • hasInitialResponse

        boolean hasInitialResponse()
        Determines whether this mechanism has an optional initial response. If true, caller should call evaluateChallenge() with an empty array to get the initial response.
        返回：
        true if this mechanism has an initial response.

      • evaluateChallenge

        byte[] evaluateChallenge(byte[] challenge)
                         throws SaslException
        Evaluates the challenge data and generates a response. If a challenge is received from the server during the authentication process, this method is called to prepare an appropriate next response to submit to the server.
        参数：
        challenge - The non-null challenge sent from the server. The challenge array may have zero length.
        返回：
        The possibly null reponse to send to the server. It is null if the challenge accompanied a "SUCCESS" status and the challenge only contains data for the client to update its state and no response needs to be sent to the server. The response is a zero-length byte array if the client is to send a response with no data.
        抛出：
        SaslException - If an error occurred while processing the challenge or generating a response.

      • isComplete

        boolean isComplete()
        Determines whether the authentication exchange has completed. This method may be called at any time, but typically, it will not be called until the caller has received indication from the server (in a protocol-specific manner) that the exchange has completed.
        返回：
        true if the authentication exchange has completed; false otherwise.

      • unwrap

        byte[] unwrap(byte[] incoming,
            int offset,
            int len)
              throws SaslException
        Unwraps a byte array received from the server. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true) and only if the authentication exchange has negotiated integrity and/or privacy as the quality of protection; otherwise, an IllegalStateException is thrown.

        incoming is the contents of the SASL buffer as defined in RFC 2222 without the leading four octet field that represents the length. offset and len specify the portion of incoming to use.

        参数：
        incoming - A non-null byte array containing the encoded bytes from the server.
        offset - The starting position at incoming of the bytes to use.
        len - The number of bytes from incoming to use.
        返回：
        A non-null byte array containing the decoded bytes.
        抛出：
        SaslException - if incoming cannot be successfully unwrapped.
        IllegalStateException - if the authentication exchange has not completed, or if the negotiated quality of protection has neither integrity nor privacy.

      • wrap

        byte[] wrap(byte[] outgoing,
          int offset,
          int len)
            throws SaslException
        Wraps a byte array to be sent to the server. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true) and only if the authentication exchange has negotiated integrity and/or privacy as the quality of protection; otherwise, an IllegalStateException is thrown.

        The result of this method will make up the contents of the SASL buffer as defined in RFC 2222 without the leading four octet field that represents the length. offset and len specify the portion of outgoing to use.

        参数：
        outgoing - A non-null byte array containing the bytes to encode.
        offset - The starting position at outgoing of the bytes to use.
        len - The number of bytes from outgoing to use.
        返回：
        A non-null byte array containing the encoded bytes.
        抛出：
        SaslException - if outgoing cannot be successfully wrapped.
        IllegalStateException - if the authentication exchange has not completed, or if the negotiated quality of protection has neither integrity nor privacy.

      • getNegotiatedProperty

        Object getNegotiatedProperty(String propName)
        Retrieves the negotiated property. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true); otherwise, an IllegalStateException is thrown.
        参数：
        propName - The non-null property name.
        返回：
        The value of the negotiated property. If null, the property was not negotiated or is not applicable to this mechanism.
        抛出：
        IllegalStateException - if this authentication exchange has not completed

      • dispose

        void dispose()
             throws SaslException
        Disposes of any system resources or security-sensitive information the SaslClient might be using. Invoking this method invalidates the SaslClient instance. This method is idempotent.
        抛出：
        SaslException - If a problem was encountered while disposing the resources.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ieopr or mss mmhkiimh m reeneei ain


SaslClientFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.sasl

Interface SaslClientFactory

  • public interface SaslClientFactory
    An interface for creating instances of SaslClient. A class that implements this interface must be thread-safe and handle multiple simultaneous requests. It must also have a public constructor that accepts no argument.

    This interface is not normally accessed directly by a client, which will use the Sasl static methods instead. However, a particular environment may provide and install a new or different SaslClientFactory.

    从以下版本开始：
    1.5
    另请参见：
    SaslClient, Sasl

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SaslClient createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      String[] getMechanismNames(Map<String,?> props)
      Returns an array of names of mechanisms that match the specified mechanism selection policies.

    • 方法详细信息

      • createSaslClient

        SaslClient createSaslClient(String[] mechanisms,
                          String authorizationId,
                          String protocol,
                          String serverName,
                          Map<String,?> props,
                          CallbackHandler cbh)
                            throws SaslException
        Creates a SaslClient using the parameters supplied.
        参数：
        mechanisms - The non-null list of mechanism names to try. Each is the IANA-registered name of a SASL mechanism. (e.g. "GSSAPI", "CRAM-MD5").
        authorizationId - The possibly null protocol-dependent identification to be used for authorization. If null or empty, the server derives an authorization ID from the client's authentication credentials. When the SASL authentication completes successfully, the specified entity is granted access.
        protocol - The non-null string name of the protocol for which the authentication is being performed (e.g., "ldap").
        serverName - The non-null fully qualified host name of the server to authenticate to.
        props - The possibly null set of properties used to select the SASL mechanism and to configure the authentication exchange of the selected mechanism. See the Sasl class for a list of standard properties. Other, possibly mechanism-specific, properties can be included. Properties not relevant to the selected mechanism are ignored, including any map entries with non-String keys.
        cbh - The possibly null callback handler to used by the SASL mechanisms to get further information from the application/library to complete the authentication. For example, a SASL mechanism might require the authentication ID, password and realm from the caller. The authentication ID is requested by using a NameCallback. The password is requested by using a PasswordCallback. The realm is requested by using a RealmChoiceCallback if there is a list of realms to choose from, and by using a RealmCallback if the realm must be entered.
        返回：
        A possibly null SaslClient created using the parameters supplied. If null, this factory cannot produce a SaslClient using the parameters supplied.
        抛出：
        SaslException - If cannot create a SaslClient because of an error.

      • getMechanismNames

        String[] getMechanismNames(Map<String,?> props)
        Returns an array of names of mechanisms that match the specified mechanism selection policies.
        参数：
        props - The possibly null set of properties used to specify the security policy of the SASL mechanisms. For example, if props contains the Sasl.POLICY_NOPLAINTEXT property with the value "true", then the factory must not return any SASL mechanisms that are susceptible to simple plain passive attacks. See the Sasl class for a complete list of policy properties. Non-policy related properties, if present in props, are ignored, including any map entries with non-String keys.
        返回：
        A non-null array containing a IANA-registered SASL mechanism names.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

plplcs es ess een/tttmcthil "m"chcs/


SaslException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.security.sasl

类 SaslException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.security.sasl.SaslException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    AuthenticationException

    public class SaslException
extends IOException
    This class represents an error that has occurred when using SASL.
    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SaslException()
      Constructs a new instance of SaslException.
      SaslException(String detail)
      Constructs a new instance of SaslException with a detailed message.
      SaslException(String detail, Throwable ex)
      Constructs a new instance of SaslException with a detailed message and a root exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.
      Throwable initCause(Throwable cause)
      Initializes the cause of this throwable to the specified value.
      String toString()
      Returns the string representation of this exception.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SaslException

        public SaslException()
        Constructs a new instance of SaslException. The root exception and the detailed message are null.

      • SaslException

        public SaslException(String detail)
        Constructs a new instance of SaslException with a detailed message. The root exception is null.
        参数：
        detail - A possibly null string containing details of the exception.
        另请参见：
        Throwable.getMessage()

      • SaslException

        public SaslException(String detail,
             Throwable ex)
        Constructs a new instance of SaslException with a detailed message and a root exception. For example, a SaslException might result from a problem with the callback handler, which might throw a NoSuchCallbackException if it does not support the requested callback, or throw an IOException if it had problems obtaining data for the callback. The SaslException's root exception would be then be the exception thrown by the callback handler.
        参数：
        detail - A possibly null string containing details of the exception.
        ex - A possibly null root exception that caused this exception.
        另请参见：
        Throwable.getMessage(), getCause()

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Description copied from class: Throwable
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

        This implementation returns the cause that was supplied via one of the constructors requiring a Throwable, or that was set after creation with the Throwable.initCause(Throwable) method. While it is typically unnecessary to override this method, a subclass can override it to return a cause set by some other means. This is appropriate for a "legacy chained throwable" that predates the addition of chained exceptions to Throwable. Note that it is not necessary to override any of the PrintStackTrace methods, all of which invoke the getCause method to determine the cause of a throwable.

        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.

      • initCause

        public Throwable initCause(Throwable cause)
        Description copied from class: Throwable
        Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

        This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with Throwable.Throwable(Throwable) or Throwable.Throwable(String,Throwable), this method cannot be called even once.

        重载：
        initCause in class Throwable
        参数：
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        返回：
        a reference to this Throwable instance.

      • toString

        public String toString()
        Returns the string representation of this exception. The string representation contains this exception's class name, its detailed messsage, and if it has a root exception, the string representation of the root exception. This string representation is meant for debugging and not meant to be interpreted programmatically.
        重载：
        toString in class Throwable
        返回：
        The non-null string representation of this exception.
        另请参见：
        Throwable.getMessage()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llibpbxbi&nc>n a>i�"襱N"""乙a猼u<


SaslServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.sasl

Interface SaslServer

  • public interface SaslServer
    Performs SASL authentication as a server.

    A server such an LDAP server gets an instance of this class in order to perform authentication defined by a specific SASL mechanism. Invoking methods on the SaslServer instance generates challenges according to the SASL mechanism implemented by the SaslServer. As the authentication proceeds, the instance encapsulates the state of a SASL server's authentication exchange.

    Here's an example of how an LDAP server might use a SaslServer. It first gets an instance of a SaslServer for the SASL mechanism requested by the client:

     SaslServer ss = Sasl.createSaslServer(mechanism,
     "ldap", myFQDN, props, callbackHandler);
    It can then proceed to use the server for authentication. For example, suppose the LDAP server received an LDAP BIND request containing the name of the SASL mechanism and an (optional) initial response. It then might use the server as follows:
     while (!ss.isComplete()) {
     try {
         byte[] challenge = ss.evaluateResponse(response);
         if (ss.isComplete()) {
             status = ldap.sendBindResponse(mechanism, challenge, SUCCESS);
         } else {
             status = ldap.sendBindResponse(mechanism, challenge,
                   SASL_BIND_IN_PROGRESS);
             response = ldap.readBindRequest();
         }
     } catch (SaslException e) {
          status = ldap.sendErrorResponse(e);
          break;
     }
 }
 if (ss.isComplete() && status == SUCCESS) {
    String qop = (String) sc.getNegotiatedProperty(Sasl.QOP);
    if (qop != null
        && (qop.equalsIgnoreCase("auth-int")
            || qop.equalsIgnoreCase("auth-conf"))) {

      // Use SaslServer.wrap() and SaslServer.unwrap() for future
      // communication with client
      ldap.in = new SecureInputStream(ss, ldap.in);
      ldap.out = new SecureOutputStream(ss, ldap.out);
    }
 }
    从以下版本开始：
    1.5
    另请参见：
    Sasl, SaslServerFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void dispose()
      Disposes of any system resources or security-sensitive information the SaslServer might be using.
      byte[] evaluateResponse(byte[] response)
      Evaluates the response data and generates a challenge.
      String getAuthorizationID()
      Reports the authorization ID in effect for the client of this session.
      String getMechanismName()
      Returns the IANA-registered mechanism name of this SASL server.
      Object getNegotiatedProperty(String propName)
      Retrieves the negotiated property.
      boolean isComplete()
      Determines whether the authentication exchange has completed.
      byte[] unwrap(byte[] incoming, int offset, int len)
      Unwraps a byte array received from the client.
      byte[] wrap(byte[] outgoing, int offset, int len)
      Wraps a byte array to be sent to the client.

    • 方法详细信息

      • getMechanismName

        String getMechanismName()
        Returns the IANA-registered mechanism name of this SASL server. (e.g. "CRAM-MD5", "GSSAPI").
        返回：
        A non-null string representing the IANA-registered mechanism name.

      • evaluateResponse

        byte[] evaluateResponse(byte[] response)
                        throws SaslException
        Evaluates the response data and generates a challenge. If a response is received from the client during the authentication process, this method is called to prepare an appropriate next challenge to submit to the client. The challenge is null if the authentication has succeeded and no more challenge data is to be sent to the client. It is non-null if the authentication must be continued by sending a challenge to the client, or if the authentication has succeeded but challenge data needs to be processed by the client. isComplete() should be called after each call to evaluateResponse(),to determine if any further response is needed from the client.
        参数：
        response - The non-null (but possibly empty) response sent by the client.
        返回：
        The possibly null challenge to send to the client. It is null if the authentication has succeeded and there is no more challenge data to be sent to the client.
        抛出：
        SaslException - If an error occurred while processing the response or generating a challenge.

      • isComplete

        boolean isComplete()
        Determines whether the authentication exchange has completed. This method is typically called after each invocation of evaluateResponse() to determine whether the authentication has completed successfully or should be continued.
        返回：
        true if the authentication exchange has completed; false otherwise.

      • getAuthorizationID

        String getAuthorizationID()
        Reports the authorization ID in effect for the client of this session. This method can only be called if isComplete() returns true.
        返回：
        The authorization ID of the client.
        抛出：
        IllegalStateException - if this authentication session has not completed

      • unwrap

        byte[] unwrap(byte[] incoming,
            int offset,
            int len)
              throws SaslException
        Unwraps a byte array received from the client. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true) and only if the authentication exchange has negotiated integrity and/or privacy as the quality of protection; otherwise, an IllegalStateException is thrown.

        incoming is the contents of the SASL buffer as defined in RFC 2222 without the leading four octet field that represents the length. offset and len specify the portion of incoming to use.

        参数：
        incoming - A non-null byte array containing the encoded bytes from the client.
        offset - The starting position at incoming of the bytes to use.
        len - The number of bytes from incoming to use.
        返回：
        A non-null byte array containing the decoded bytes.
        抛出：
        SaslException - if incoming cannot be successfully unwrapped.
        IllegalStateException - if the authentication exchange has not completed, or if the negotiated quality of protection has neither integrity nor privacy

      • wrap

        byte[] wrap(byte[] outgoing,
          int offset,
          int len)
            throws SaslException
        Wraps a byte array to be sent to the client. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true) and only if the authentication exchange has negotiated integrity and/or privacy as the quality of protection; otherwise, a SaslException is thrown.

        The result of this method will make up the contents of the SASL buffer as defined in RFC 2222 without the leading four octet field that represents the length. offset and len specify the portion of outgoing to use.

        参数：
        outgoing - A non-null byte array containing the bytes to encode.
        offset - The starting position at outgoing of the bytes to use.
        len - The number of bytes from outgoing to use.
        返回：
        A non-null byte array containing the encoded bytes.
        抛出：
        SaslException - if outgoing cannot be successfully wrapped.
        IllegalStateException - if the authentication exchange has not completed, or if the negotiated quality of protection has neither integrity nor privacy.

      • getNegotiatedProperty

        Object getNegotiatedProperty(String propName)
        Retrieves the negotiated property. This method can be called only after the authentication exchange has completed (i.e., when isComplete() returns true); otherwise, an IllegalStateException is thrown.
        参数：
        propName - the property
        返回：
        The value of the negotiated property. If null, the property was not negotiated or is not applicable to this mechanism.
        抛出：
        IllegalStateException - if this authentication exchange has not completed

      • dispose

        void dispose()
             throws SaslException
        Disposes of any system resources or security-sensitive information the SaslServer might be using. Invoking this method invalidates the SaslServer instance. This method is idempotent.
        抛出：
        SaslException - If a problem was encountered while disposing the resources.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g w w=w d iogoel a淳i胧ra�/f <�


SaslServerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.security.sasl

Interface SaslServerFactory

  • public interface SaslServerFactory
    An interface for creating instances of SaslServer. A class that implements this interface must be thread-safe and handle multiple simultaneous requests. It must also have a public constructor that accepts no argument.

    This interface is not normally accessed directly by a server, which will use the Sasl static methods instead. However, a particular environment may provide and install a new or different SaslServerFactory.

    从以下版本开始：
    1.5
    另请参见：
    SaslServer, Sasl

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SaslServer createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer using the parameters supplied.
      String[] getMechanismNames(Map<String,?> props)
      Returns an array of names of mechanisms that match the specified mechanism selection policies.

    • 方法详细信息

      • createSaslServer

        SaslServer createSaslServer(String mechanism,
                          String protocol,
                          String serverName,
                          Map<String,?> props,
                          CallbackHandler cbh)
                            throws SaslException
        Creates a SaslServer using the parameters supplied. It returns null if no SaslServer can be created using the parameters supplied. Throws SaslException if it cannot create a SaslServer because of an error.
        参数：
        mechanism - The non-null IANA-registered name of a SASL mechanism. (e.g. "GSSAPI", "CRAM-MD5").
        protocol - The non-null string name of the protocol for which the authentication is being performed (e.g., "ldap").
        serverName - The non-null fully qualified host name of the server to authenticate to.
        props - The possibly null set of properties used to select the SASL mechanism and to configure the authentication exchange of the selected mechanism. See the Sasl class for a list of standard properties. Other, possibly mechanism-specific, properties can be included. Properties not relevant to the selected mechanism are ignored, including any map entries with non-String keys.
        cbh - The possibly null callback handler to used by the SASL mechanisms to get further information from the application/library to complete the authentication. For example, a SASL mechanism might require the authentication ID, password and realm from the caller. The authentication ID is requested by using a NameCallback. The password is requested by using a PasswordCallback. The realm is requested by using a RealmChoiceCallback if there is a list of realms to choose from, and by using a RealmCallback if the realm must be entered.
        返回：
        A possibly null SaslServer created using the parameters supplied. If null, this factory cannot produce a SaslServer using the parameters supplied.
        抛出：
        SaslException - If cannot create a SaslServer because of an error.

      • getMechanismNames

        String[] getMechanismNames(Map<String,?> props)
        Returns an array of names of mechanisms that match the specified mechanism selection policies.
        参数：
        props - The possibly null set of properties used to specify the security policy of the SASL mechanisms. For example, if props contains the Sasl.POLICY_NOPLAINTEXT property with the value "true", then the factory must not return any SASL mechanisms that are susceptible to simple plain passive attacks. See the Sasl class for a complete list of policy properties. Non-policy related properties, if present in props, are ignored, including any map entries with non-String keys.
        返回：
        A non-null array containing a IANA-registered SASL mechanism names.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

deted>dii


Uses of Package javax.security.sasl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.security.sasl

  • Packages that use javax.security.sasl
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.
  • Classes in javax.security.sasl used by javax.security.sasl
    类与描述
    SaslClient
    Performs SASL authentication as a client.
    SaslClientFactory
    An interface for creating instances of SaslClient.
    SaslException
    This class represents an error that has occurred when using SASL.
    SaslServer
    Performs SASL authentication as a server.
    SaslServerFactory
    An interface for creating instances of SaslServer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1lRa"="c lll>.wvg


Uses of Class javax.security.sasl.AuthenticationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.AuthenticationException

No usage of javax.security.sasl.AuthenticationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" n


Uses of Class javax.security.sasl.AuthorizeCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.AuthorizeCallback

No usage of javax.security.sasl.AuthorizeCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/sRo>T>g莞be3&攁癰b


Uses of Class javax.security.sasl.RealmCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.RealmCallback

No usage of javax.security.sasl.RealmCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-amotsn>sl>g/s


Uses of Class javax.security.sasl.RealmChoiceCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.RealmChoiceCallback

No usage of javax.security.sasl.RealmChoiceCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-ja>tttso>sl><�>gnht


Uses of Class javax.security.sasl.Sasl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.Sasl

No usage of javax.security.sasl.Sasl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA"yachc/y.m谤h<鎟╩�


Uses of Class javax.security.sasl.SaslException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.security.sasl.SaslException

  • Packages that use SaslException
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of SaslException in javax.security.sasl

      Subclasses of SaslException in javax.security.sasl
      修饰符与类型 类与描述
      class  AuthenticationException
      This exception is thrown by a SASL mechanism implementation to indicate that the SASL exchange has failed due to reasons related to authentication, such as an invalid identity, passphrase, or key.
      Methods in javax.security.sasl that throw SaslException
      修饰符与类型 方法与描述
      SaslClient SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      static SaslClient Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      SaslServer SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer using the parameters supplied.
      static SaslServer Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer for the specified mechanism.
      void SaslServer.dispose()
      Disposes of any system resources or security-sensitive information the SaslServer might be using.
      void SaslClient.dispose()
      Disposes of any system resources or security-sensitive information the SaslClient might be using.
      byte[] SaslClient.evaluateChallenge(byte[] challenge)
      Evaluates the challenge data and generates a response.
      byte[] SaslServer.evaluateResponse(byte[] response)
      Evaluates the response data and generates a challenge.
      byte[] SaslServer.unwrap(byte[] incoming, int offset, int len)
      Unwraps a byte array received from the client.
      byte[] SaslClient.unwrap(byte[] incoming, int offset, int len)
      Unwraps a byte array received from the server.
      byte[] SaslServer.wrap(byte[] outgoing, int offset, int len)
      Wraps a byte array to be sent to the client.
      byte[] SaslClient.wrap(byte[] outgoing, int offset, int len)
      Wraps a byte array to be sent to the server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Clbracl>. r>u詁r


Uses of Interface javax.security.sasl.SaslClient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.sasl.SaslClient

  • Packages that use SaslClient
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of SaslClient in javax.security.sasl

      Methods in javax.security.sasl that return SaslClient
      修饰符与类型 方法与描述
      SaslClient SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
      static SaslClient Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslClient using the parameters supplied.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtvm/N, > _r soaObc"


Uses of Interface javax.security.sasl.SaslClientFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.sasl.SaslClientFactory

  • Packages that use SaslClientFactory
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of SaslClientFactory in javax.security.sasl

      Methods in javax.security.sasl that return types with arguments of type SaslClientFactory
      修饰符与类型 方法与描述
      static Enumeration<SaslClientFactory> Sasl.getSaslClientFactories()
      Gets an enumeration of known factories for producing SaslClient.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v/e.f=" ahhhiitt a >a"m>l


Uses of Interface javax.security.sasl.SaslServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.sasl.SaslServer

  • Packages that use SaslServer
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of SaslServer in javax.security.sasl

      Methods in javax.security.sasl that return SaslServer
      修饰符与类型 方法与描述
      SaslServer SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer using the parameters supplied.
      static SaslServer Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
      Creates a SaslServer for the specified mechanism.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rc.bk/Cllbbb/i//SaS.><&,.


Uses of Interface javax.security.sasl.SaslServerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.security.sasl.SaslServerFactory

  • Packages that use SaslServerFactory
    软件包 描述
    javax.security.sasl
    Contains class and interfaces for supporting SASL.

    • Uses of SaslServerFactory in javax.security.sasl

      Methods in javax.security.sasl that return types with arguments of type SaslServerFactory
      修饰符与类型 方法与描述
      static Enumeration<SaslServerFactory> Sasl.getSaslServerFactories()
      Gets an enumeration of known factories for producing SaslServer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/mtkag/.ppp=>UUaaa"f e"


ControllerEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface ControllerEventListener

  • All Superinterfaces:
    EventListener

    public interface ControllerEventListener
extends EventListener
    The ControllerEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a requested type of MIDI control-change event. To register a ControllerEventListener object to receive such notifications, invoke the addControllerEventListener method of Sequencer, specifying the types of MIDI controllers about which you are interested in getting control-change notifications.
    另请参见：
    MidiChannel.controlChange(int, int)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void controlChange(ShortMessage event)
      Invoked when a Sequencer has encountered and processed a control-change event of interest to this listener.

    • 方法详细信息

      • controlChange

        void controlChange(ShortMessage event)
        Invoked when a Sequencer has encountered and processed a control-change event of interest to this listener. The event passed in is a ShortMessage whose first data byte indicates the controller number and whose second data byte is the value to which the controller was set.
        参数：
        event - the control-change event that the sequencer encountered in the sequence it is processing
        另请参见：
        Sequencer.addControllerEventListener(ControllerEventListener, int[]),
MidiChannel.controlChange(int, int),
ShortMessage.getData1(),
ShortMessage.getData2()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnv� >


Instrument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 Instrument

  • java.lang.Object
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument

  • public abstract class Instrument
extends SoundbankResource
    An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect. Instruments are typically stored in collections called soundbanks. Before the instrument can be used to play notes, it must first be loaded onto a synthesizer, and then it must be selected for use on one or more channels, via a program-change command. MIDI notes that are subsequently received on those channels will be played using the sound of the selected instrument.
    另请参见：
    Soundbank, Soundbank.getInstruments(), Patch, Synthesizer.loadInstrument(Instrument), MidiChannel.programChange(int, int)

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Instrument(Soundbank soundbank, Patch patch, String name, 类<?> dataClass)
      Constructs a new MIDI instrument from the specified Patch.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Patch getPatch()
      Obtains the Patch object that indicates the bank and program numbers where this instrument is to be stored in the synthesizer.

      • 方法 - 继承于类 javax.sound.midi.SoundbankResource

        getData, getDataClass, getName, getSoundbank

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Instrument

        protected Instrument(Soundbank soundbank,
          Patch patch,
          String name,
          类<?> dataClass)
        Constructs a new MIDI instrument from the specified Patch. When a subsequent request is made to load the instrument, the sound bank will search its contents for this instrument's Patch, and the instrument will be loaded into the synthesizer at the bank and program location indicated by the Patch object.
        参数：
        soundbank - sound bank containing the instrument
        patch - the patch of this instrument
        name - the name of this instrument
        dataClass - the class used to represent the sample's data.
        另请参见：
        Synthesizer.loadInstrument(Instrument)

    • 方法详细信息

      • getPatch

        public Patch getPatch()
        Obtains the Patch object that indicates the bank and program numbers where this instrument is to be stored in the synthesizer.
        返回：
        this instrument's patch
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a->ct#.sit


InvalidMidiDataException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.midi

类 InvalidMidiDataException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.sound.midi.InvalidMidiDataException
  • 所有已实现的接口：
    Serializable

    public class InvalidMidiDataException
extends Exception
    An InvalidMidiDataException indicates that inappropriate MIDI data was encountered. This often means that the data is invalid in and of itself, from the perspective of the MIDI specification. An example would be an undefined status byte. However, the exception might simply mean that the data was invalid in the context it was used, or that the object to which the data was given was unable to parse or use it. For example, a file reader might not be able to parse a Type 2 MIDI file, even though that format is defined in the MIDI specification.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidMidiDataException()
      Constructs an InvalidMidiDataException with null for its error detail message.
      InvalidMidiDataException(String message)
      Constructs an InvalidMidiDataException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidMidiDataException

        public InvalidMidiDataException()
        Constructs an InvalidMidiDataException with null for its error detail message.

      • InvalidMidiDataException

        public InvalidMidiDataException(String message)
        Constructs an InvalidMidiDataException with the specified detail message.
        参数：
        message - the string to display as an error detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttmtEttthtpo.noocdddsprsgnnr "�>


javax.sound.midi

Interfaces

  • ControllerEventListener
  • MetaEventListener
  • MidiChannel
  • MidiDevice
  • MidiDeviceReceiver
  • MidiDeviceTransmitter
  • Receiver
  • Sequencer
  • Soundbank
  • Synthesizer
  • Transmitter

Classes

  • Instrument
  • MetaMessage
  • MidiDevice.Info
  • MidiEvent
  • MidiFileFormat
  • MidiMessage
  • MidiSystem
  • Patch
  • Sequence
  • Sequencer.SyncMode
  • ShortMessage
  • SoundbankResource
  • SysexMessage
  • Track
  • VoiceStatus

Exceptions

  • InvalidMidiDataException
  • MidiUnavailableException
e


javax.sound.midi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sound.midi

Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

请参见： 描述

  • 接口摘要
    接口 描述
    ControllerEventListener
    The ControllerEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a requested type of MIDI control-change event.
    MetaEventListener
    The MetaEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a MetaMessage.
    MidiChannel
    A MidiChannel object represents a single MIDI channel.
    MidiDevice
    MidiDevice is the base interface for all MIDI devices.
    MidiDeviceReceiver
    MidiDeviceReceiver is a Receiver which represents a MIDI input connector of a MidiDevice (see MidiDevice.getReceiver()).
    MidiDeviceTransmitter
    MidiDeviceTransmitter is a Transmitter which represents a MIDI input connector of a MidiDevice (see MidiDevice.getTransmitter()).
    Receiver
    A Receiver receives MidiEvent objects and typically does something useful in response, such as interpreting them to generate sound or raw MIDI output.
    Sequencer
    A hardware or software device that plays back a MIDI sequence is known as a sequencer.
    Soundbank
    A Soundbank contains a set of Instruments that can be loaded into a Synthesizer.
    Synthesizer
    A Synthesizer generates sound.
    Transmitter
    A Transmitter sends MidiEvent objects to one or more Receivers.
  • Class Summary
    类 描述
    Instrument
    An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect.
    MetaMessage
    A MetaMessage is a MidiMessage that is not meaningful to synthesizers, but that can be stored in a MIDI file and interpreted by a sequencer program.
    MidiDevice.Info
    A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.
    MidiEvent
    MIDI events contain a MIDI message and a corresponding time-stamp expressed in ticks, and can represent the MIDI event information stored in a MIDI file or a Sequence object.
    MidiFileFormat
    A MidiFileFormat object encapsulates a MIDI file's type, as well as its length and timing information.
    MidiMessage
    MidiMessage is the base class for MIDI messages.
    MidiSystem
    The MidiSystem class provides access to the installed MIDI system resources, including devices such as synthesizers, sequencers, and MIDI input and output ports.
    Patch
    A Patch object represents a location, on a MIDI synthesizer, into which a single instrument is stored (loaded).
    Sequence
    A Sequence is a data structure containing musical information (often an entire song or composition) that can be played back by a Sequencer object.
    Sequencer.SyncMode
    A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device.
    ShortMessage
    A ShortMessage contains a MIDI message that has at most two data bytes following its status byte.
    SoundbankResource
    A SoundbankResource represents any audio resource stored in a Soundbank.
    SysexMessage
    A SysexMessage object represents a MIDI system exclusive message.
    Track
    A MIDI track is an independent stream of MIDI events (time-stamped MIDI data) that can be stored along with other tracks in a standard MIDI file.
    VoiceStatus
    A VoiceStatus object contains information about the current status of one of the voices produced by a Synthesizer.
  • Exception Summary
    Exception 描述
    InvalidMidiDataException
    An InvalidMidiDataException indicates that inappropriate MIDI data was encountered.
    MidiUnavailableException
    A MidiUnavailableException is thrown when a requested MIDI component cannot be opened or created because it is unavailable.

软件包 javax.sound.midi Description

Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

Related Documentation

For overviews, tutorials, examples, and guides, please see:
  • Sound
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tttaea< ac r>eciidtl


javax.sound.midi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sound.midi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sound.midi.MidiDevice.Info
    • javax.sound.midi.MidiEvent
    • javax.sound.midi.MidiFileFormat
    • javax.sound.midi.MidiMessage (implements java.lang.Cloneable)
      • javax.sound.midi.MetaMessage
      • javax.sound.midi.ShortMessage
      • javax.sound.midi.SysexMessage
    • javax.sound.midi.MidiSystem
    • javax.sound.midi.Patch
    • javax.sound.midi.Sequence
    • javax.sound.midi.Sequencer.SyncMode
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.sound.midi.InvalidMidiDataException
        • javax.sound.midi.MidiUnavailableException
    • javax.sound.midi.Track
    • javax.sound.midi.VoiceStatus

Interface Hierarchy

  • java.lang.AutoCloseable
    • javax.sound.midi.MidiDevice
      • javax.sound.midi.Sequencer
      • javax.sound.midi.Synthesizer
    • javax.sound.midi.Receiver
      • javax.sound.midi.MidiDeviceReceiver
    • javax.sound.midi.Transmitter
      • javax.sound.midi.MidiDeviceTransmitter
  • java.util.EventListener
    • javax.sound.midi.ControllerEventListener
    • javax.sound.midi.MetaEventListener
  • javax.sound.midi.MidiChannel
  • javax.sound.midi.Soundbank
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.c. r>Fliii"dooe uutt


MetaEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface MetaEventListener

  • All Superinterfaces:
    EventListener

    public interface MetaEventListener
extends EventListener
    The MetaEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a MetaMessage. To register a MetaEventListener object to receive such notifications, pass it as the argument to the addMetaEventListener method of Sequencer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void meta(MetaMessage meta)
      Invoked when a Sequencer has encountered and processed a MetaMessage in the Sequence it is processing.

    • 方法详细信息

      • meta

        void meta(MetaMessage meta)
        Invoked when a Sequencer has encountered and processed a MetaMessage in the Sequence it is processing.
        参数：
        meta - the meta-message that the sequencer encountered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpove <> <)//<))s&""etaaDp./ /n


MetaMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 MetaMessage

  • java.lang.Object
    • javax.sound.midi.MidiMessage
      • javax.sound.midi.MetaMessage
  • 所有已实现的接口：
    Cloneable

    public class MetaMessage
extends MidiMessage
    A MetaMessage is a MidiMessage that is not meaningful to synthesizers, but that can be stored in a MIDI file and interpreted by a sequencer program. (See the discussion in the MidiMessage class description.) The Standard MIDI Files specification defines various types of meta-events, such as sequence number, lyric, cue point, and set tempo. There are also meta-events for such information as lyrics, copyrights, tempo indications, time and key signatures, markers, etc. For more information, see the Standard MIDI Files 1.0 specification, which is part of the Complete MIDI 1.0 Detailed Specification published by the MIDI Manufacturer's Association (http://www.midi.org).

    When data is being transported using MIDI wire protocol, a ShortMessage with the status value 0xFF represents a system reset message. In MIDI files, this same status value denotes a MetaMessage. The types of meta-message are distinguished from each other by the first byte that follows the status byte 0xFF. The subsequent bytes are data bytes. As with system exclusive messages, there are an arbitrary number of data bytes, depending on the type of MetaMessage.

    另请参见：
    MetaEventListener

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int META
      Status byte for MetaMessage (0xFF, or 255), which is used in MIDI files.

      • Fields inherited from class javax.sound.midi.MidiMessage

        data, length

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        MetaMessage()
      Constructs a new MetaMessage.
      protected MetaMessage(byte[] data)
      Constructs a new MetaMessage.
        MetaMessage(int type, byte[] data, int length)
      Constructs a new MetaMessage and sets the message parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a new object of the same class and with the same contents as this object.
      byte[] getData()
      Obtains a copy of the data for the meta message.
      int getType()
      Obtains the type of the MetaMessage.
      void setMessage(int type, byte[] data, int length)
      Sets the message parameters for a MetaMessage.

      • 方法 - 继承于类 javax.sound.midi.MidiMessage

        getLength, getMessage, getStatus, setMessage

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • META

        public static final int META
        Status byte for MetaMessage (0xFF, or 255), which is used in MIDI files. It has the same value as SYSTEM_RESET, which is used in the real-time "MIDI wire" protocol.
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

    • 构造方法详细信息

      • MetaMessage

        public MetaMessage()
        Constructs a new MetaMessage. The contents of the message are not set here; use setMessage to set them subsequently.

      • MetaMessage

        public MetaMessage(int type,
           byte[] data,
           int length)
            throws InvalidMidiDataException
        Constructs a new MetaMessage and sets the message parameters. The contents of the message can be changed by using the setMessage method.
        参数：
        type - meta-message type (must be less than 128)
        data - the data bytes in the MIDI message
        length - an amount of bytes in the data byte array; it should be non-negative and less than or equal to data.length
        抛出：
        InvalidMidiDataException - if the parameter values do not specify a valid MIDI meta message
        从以下版本开始：
        1.7
        另请参见：
        setMessage(int, byte[], int),
getType(),
getData()

      • MetaMessage

        protected MetaMessage(byte[] data)
        Constructs a new MetaMessage.
        参数：
        data - an array of bytes containing the complete message. The message data may be changed using the setMessage method.
        另请参见：
        setMessage(int, byte[], int)

    • 方法详细信息

      • setMessage

        public void setMessage(int type,
              byte[] data,
              int length)
                throws InvalidMidiDataException
        Sets the message parameters for a MetaMessage. Since only one status byte value, 0xFF, is allowed for meta-messages, it does not need to be specified here. Calls to getStatus return 0xFF for all meta-messages.

        The type argument should be a valid value for the byte that follows the status byte in the MetaMessage. The data argument should contain all the subsequent bytes of the MetaMessage. In other words, the byte that specifies the type of MetaMessage is not considered a data byte.

        参数：
        type - meta-message type (must be less than 128)
        data - the data bytes in the MIDI message
        length - the number of bytes in the data byte array
        抛出：
        InvalidMidiDataException - if the parameter values do not specify a valid MIDI meta message
        InvalidMidiDataException

      • getType

        public int getType()
        Obtains the type of the MetaMessage.
        返回：
        an integer representing the MetaMessage type

      • getData

        public byte[] getData()
        Obtains a copy of the data for the meta message. The returned array of bytes does not include the status byte or the message length data. The length of the data for the meta message is the length of the array. Note that the length of the entire message includes the status byte and the meta message type byte, and therefore may be longer than the returned array.
        返回：
        array containing the meta message data.
        另请参见：
        MidiMessage.getLength()

      • clone

        public Object clone()
        Creates a new object of the same class and with the same contents as this object.
        指定者：
        clone in class MidiMessage
        返回：
        a clone of this instance
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o t>il�


MidiChannel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface MidiChannel

  • public interface MidiChannel
    A MidiChannel object represents a single MIDI channel. Generally, each MidiChannel method processes a like-named MIDI "channel voice" or "channel mode" message as defined by the MIDI specification. However, MidiChannel adds some "get" methods that retrieve the value most recently set by one of the standard MIDI channel messages. Similarly, methods for per-channel solo and mute have been added.

    A Synthesizer object has a collection of MidiChannels, usually one for each of the 16 channels prescribed by the MIDI 1.0 specification. The Synthesizer generates sound when its MidiChannels receive noteOn messages.

    See the MIDI 1.0 Specification for more information about the prescribed behavior of the MIDI channel messages, which are not exhaustively documented here. The specification is titled MIDI Reference: The Complete MIDI 1.0 Detailed Specification, and is published by the MIDI Manufacturer's Association ( http://www.midi.org).

    MIDI was originally a protocol for reporting the gestures of a keyboard musician. This genesis is visible in the MidiChannel API, which preserves such MIDI concepts as key number, key velocity, and key pressure. It should be understood that the MIDI data does not necessarily originate with a keyboard player (the source could be a different kind of musician, or software). Some devices might generate constant values for velocity and pressure, regardless of how the note was performed. Also, the MIDI specification often leaves it up to the synthesizer to use the data in the way the implementor sees fit. For example, velocity data need not always be mapped to volume and/or brightness.

    另请参见：
    Synthesizer.getChannels()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void allNotesOff()
      Turns off all notes that are currently sounding on this channel.
      void allSoundOff()
      Immediately turns off all sounding notes on this channel, ignoring the state of the Hold Pedal and the internal decay rate of the current Instrument.
      void controlChange(int controller, int value)
      Reacts to a change in the specified controller's value.
      int getChannelPressure()
      Obtains the channel's keyboard pressure.
      int getController(int controller)
      Obtains the current value of the specified controller.
      boolean getMono()
      Obtains the current mono/poly mode.
      boolean getMute()
      Obtains the current mute state for this channel.
      boolean getOmni()
      Obtains the current omni mode.
      int getPitchBend()
      Obtains the upward or downward pitch offset for this channel.
      int getPolyPressure(int noteNumber)
      Obtains the pressure with which the specified key is being depressed.
      int getProgram()
      Obtains the current program number for this channel.
      boolean getSolo()
      Obtains the current solo state for this channel.
      boolean localControl(boolean on)
      Turns local control on or off.
      void noteOff(int noteNumber)
      Turns the specified note off.
      void noteOff(int noteNumber, int velocity)
      Turns the specified note off.
      void noteOn(int noteNumber, int velocity)
      Starts the specified note sounding.
      void programChange(int program)
      Changes a program (patch).
      void programChange(int bank, int program)
      Changes the program using bank and program (patch) numbers.
      void resetAllControllers()
      Resets all the implemented controllers to their default values.
      void setChannelPressure(int pressure)
      Reacts to a change in the keyboard pressure.
      void setMono(boolean on)
      Turns mono mode on or off.
      void setMute(boolean mute)
      Sets the mute state for this channel.
      void setOmni(boolean on)
      Turns omni mode on or off.
      void setPitchBend(int bend)
      Changes the pitch offset for all notes on this channel.
      void setPolyPressure(int noteNumber, int pressure)
      Reacts to a change in the specified note's key pressure.
      void setSolo(boolean soloState)
      Sets the solo state for this channel.

    • 方法详细信息

      • noteOn

        void noteOn(int noteNumber,
          int velocity)
        Starts the specified note sounding. The key-down velocity usually controls the note's volume and/or brightness. If velocity is zero, this method instead acts like noteOff(int), terminating the note.
        参数：
        noteNumber - the MIDI note number, from 0 to 127 (60 = Middle C)
        velocity - the speed with which the key was depressed
        另请参见：
        noteOff(int, int)

      • noteOff

        void noteOff(int noteNumber,
           int velocity)
        Turns the specified note off. The key-up velocity, if not ignored, can be used to affect how quickly the note decays. In any case, the note might not die away instantaneously; its decay rate is determined by the internals of the Instrument. If the Hold Pedal (a controller; see controlChange) is down, the effect of this method is deferred until the pedal is released.
        参数：
        noteNumber - the MIDI note number, from 0 to 127 (60 = Middle C)
        velocity - the speed with which the key was released
        另请参见：
        noteOff(int),
noteOn(int, int),
allNotesOff(),
allSoundOff()

      • noteOff

        void noteOff(int noteNumber)
        Turns the specified note off.
        参数：
        noteNumber - the MIDI note number, from 0 to 127 (60 = Middle C)
        另请参见：
        noteOff(int, int)

      • setPolyPressure

        void setPolyPressure(int noteNumber,
                   int pressure)
        Reacts to a change in the specified note's key pressure. Polyphonic key pressure allows a keyboard player to press multiple keys simultaneously, each with a different amount of pressure. The pressure, if not ignored, is typically used to vary such features as the volume, brightness, or vibrato of the note. It is possible that the underlying synthesizer does not support this MIDI message. In order to verify that setPolyPressure was successful, use getPolyPressure.
        参数：
        noteNumber - the MIDI note number, from 0 to 127 (60 = Middle C)
        pressure - value for the specified key, from 0 to 127 (127 = maximum pressure)
        另请参见：
        getPolyPressure(int)

      • getPolyPressure

        int getPolyPressure(int noteNumber)
        Obtains the pressure with which the specified key is being depressed.
        参数：
        noteNumber - the MIDI note number, from 0 to 127 (60 = Middle C) If the device does not support setting poly pressure, this method always returns 0. Calling setPolyPressure will have no effect then.
        返回：
        the amount of pressure for that note, from 0 to 127 (127 = maximum pressure)
        另请参见：
        setPolyPressure(int, int)

      • setChannelPressure

        void setChannelPressure(int pressure)
        Reacts to a change in the keyboard pressure. Channel pressure indicates how hard the keyboard player is depressing the entire keyboard. This can be the maximum or average of the per-key pressure-sensor values, as set by setPolyPressure. More commonly, it is a measurement of a single sensor on a device that doesn't implement polyphonic key pressure. Pressure can be used to control various aspects of the sound, as described under setPolyPressure. It is possible that the underlying synthesizer does not support this MIDI message. In order to verify that setChannelPressure was successful, use getChannelPressure.
        参数：
        pressure - the pressure with which the keyboard is being depressed, from 0 to 127 (127 = maximum pressure)
        另请参见：
        setPolyPressure(int, int), getChannelPressure()

      • getChannelPressure

        int getChannelPressure()
        Obtains the channel's keyboard pressure. If the device does not support setting channel pressure, this method always returns 0. Calling setChannelPressure will have no effect then.
        返回：
        the amount of pressure for that note, from 0 to 127 (127 = maximum pressure)
        另请参见：
        setChannelPressure(int)

      • controlChange

        void controlChange(int controller,
                 int value)
        Reacts to a change in the specified controller's value. A controller is some control other than a keyboard key, such as a switch, slider, pedal, wheel, or breath-pressure sensor. The MIDI 1.0 Specification provides standard numbers for typical controllers on MIDI devices, and describes the intended effect for some of the controllers. The way in which an Instrument reacts to a controller change may be specific to the Instrument.

        The MIDI 1.0 Specification defines both 7-bit controllers and 14-bit controllers. Continuous controllers, such as wheels and sliders, typically have 14 bits (two MIDI bytes), while discrete controllers, such as switches, typically have 7 bits (one MIDI byte). Refer to the specification to see the expected resolution for each type of control.

        Controllers 64 through 95 (0x40 - 0x5F) allow 7-bit precision. The value of a 7-bit controller is set completely by the value argument. An additional set of controllers provide 14-bit precision by using two controller numbers, one for the most significant 7 bits and another for the least significant 7 bits. Controller numbers 0 through 31 (0x00 - 0x1F) control the most significant 7 bits of 14-bit controllers; controller numbers 32 through 63 (0x20 - 0x3F) control the least significant 7 bits of these controllers. For example, controller number 7 (0x07) controls the upper 7 bits of the channel volume controller, and controller number 39 (0x27) controls the lower 7 bits. The value of a 14-bit controller is determined by the interaction of the two halves. When the most significant 7 bits of a controller are set (using controller numbers 0 through 31), the lower 7 bits are automatically set to 0. The corresponding controller number for the lower 7 bits may then be used to further modulate the controller value. It is possible that the underlying synthesizer does not support a specific controller message. In order to verify that a call to controlChange was successful, use getController.

        参数：
        controller - the controller number (0 to 127; see the MIDI 1.0 Specification for the interpretation)
        value - the value to which the specified controller is changed (0 to 127)
        另请参见：
        getController(int)

      • getController

        int getController(int controller)
        Obtains the current value of the specified controller. The return value is represented with 7 bits. For 14-bit controllers, the MSB and LSB controller value needs to be obtained separately. For example, the 14-bit value of the volume controller can be calculated by multiplying the value of controller 7 (0x07, channel volume MSB) with 128 and adding the value of controller 39 (0x27, channel volume LSB). If the device does not support setting a specific controller, this method returns 0 for that controller. Calling controlChange will have no effect then.
        参数：
        controller - the number of the controller whose value is desired. The allowed range is 0-127; see the MIDI 1.0 Specification for the interpretation.
        返回：
        the current value of the specified controller (0 to 127)
        另请参见：
        controlChange(int, int)

      • programChange

        void programChange(int program)
        Changes a program (patch). This selects a specific instrument from the currently selected bank of instruments.

        The MIDI specification does not dictate whether notes that are already sounding should switch to the new instrument (timbre) or continue with their original timbre until terminated by a note-off.

        The program number is zero-based (expressed from 0 to 127). Note that MIDI hardware displays and literature about MIDI typically use the range 1 to 128 instead. It is possible that the underlying synthesizer does not support a specific program. In order to verify that a call to programChange was successful, use getProgram.

        参数：
        program - the program number to switch to (0 to 127)
        另请参见：
        programChange(int, int), getProgram()

      • programChange

        void programChange(int bank,
                 int program)
        Changes the program using bank and program (patch) numbers. It is possible that the underlying synthesizer does not support a specific bank, or program. In order to verify that a call to programChange was successful, use getProgram and getController. Since banks are changed by way of control changes, you can verify the current bank with the following statement:
           int bank = (getController(0) * 128)
              + getController(32);
        参数：
        bank - the bank number to switch to (0 to 16383)
        program - the program (patch) to use in the specified bank (0 to 127)
        另请参见：
        programChange(int), getProgram()

      • getProgram

        int getProgram()
        Obtains the current program number for this channel.
        返回：
        the program number of the currently selected patch
        另请参见：
        Patch.getProgram(),
Synthesizer.loadInstrument(javax.sound.midi.Instrument),
programChange(int)

      • setPitchBend

        void setPitchBend(int bend)
        Changes the pitch offset for all notes on this channel. This affects all currently sounding notes as well as subsequent ones. (For pitch bend to cease, the value needs to be reset to the center position.)

        The MIDI specification stipulates that pitch bend be a 14-bit value, where zero is maximum downward bend, 16383 is maximum upward bend, and 8192 is the center (no pitch bend). The actual amount of pitch change is not specified; it can be changed by a pitch-bend sensitivity setting. However, the General MIDI specification says that the default range should be two semitones up and down from center. It is possible that the underlying synthesizer does not support this MIDI message. In order to verify that setPitchBend was successful, use getPitchBend.

        参数：
        bend - the amount of pitch change, as a nonnegative 14-bit value (8192 = no bend)
        另请参见：
        getPitchBend()

      • getPitchBend

        int getPitchBend()
        Obtains the upward or downward pitch offset for this channel. If the device does not support setting pitch bend, this method always returns 8192. Calling setPitchBend will have no effect then.
        返回：
        bend amount, as a nonnegative 14-bit value (8192 = no bend)
        另请参见：
        setPitchBend(int)

      • resetAllControllers

        void resetAllControllers()
        Resets all the implemented controllers to their default values.
        另请参见：
        controlChange(int, int)

      • allNotesOff

        void allNotesOff()
        Turns off all notes that are currently sounding on this channel. The notes might not die away instantaneously; their decay rate is determined by the internals of the Instrument. If the Hold Pedal controller (see controlChange) is down, the effect of this method is deferred until the pedal is released.
        另请参见：
        allSoundOff(), noteOff(int)

      • allSoundOff

        void allSoundOff()
        Immediately turns off all sounding notes on this channel, ignoring the state of the Hold Pedal and the internal decay rate of the current Instrument.
        另请参见：
        allNotesOff()

      • localControl

        boolean localControl(boolean on)
        Turns local control on or off. The default is for local control to be on. The "on" setting means that if a device is capable of both synthesizing sound and transmitting MIDI messages, it will synthesize sound in response to the note-on and note-off messages that it itself transmits. It will also respond to messages received from other transmitting devices. The "off" setting means that the synthesizer will ignore its own transmitted MIDI messages, but not those received from other devices. It is possible that the underlying synthesizer does not support local control. In order to verify that a call to localControl was successful, check the return value.
        参数：
        on - true to turn local control on, false to turn local control off
        返回：
        the new local-control value, or false if local control is not supported

      • setMono

        void setMono(boolean on)
        Turns mono mode on or off. In mono mode, the channel synthesizes only one note at a time. In poly mode (identical to mono mode off), the channel can synthesize multiple notes simultaneously. The default is mono off (poly mode on).

        "Mono" is short for the word "monophonic," which in this context is opposed to the word "polyphonic" and refers to a single synthesizer voice per MIDI channel. It has nothing to do with how many audio channels there might be (as in "monophonic" versus "stereophonic" recordings). It is possible that the underlying synthesizer does not support mono mode. In order to verify that a call to setMono was successful, use getMono.

        参数：
        on - true to turn mono mode on, false to turn it off (which means turning poly mode on).
        另请参见：
        getMono(), VoiceStatus

      • getMono

        boolean getMono()
        Obtains the current mono/poly mode. Synthesizers that do not allow changing mono/poly mode will always return the same value, regardless of calls to setMono.
        返回：
        true if mono mode is on, otherwise false (meaning poly mode is on).
        另请参见：
        setMono(boolean)

      • setOmni

        void setOmni(boolean on)
        Turns omni mode on or off. In omni mode, the channel responds to messages sent on all channels. When omni is off, the channel responds only to messages sent on its channel number. The default is omni off. It is possible that the underlying synthesizer does not support omni mode. In order to verify that setOmni was successful, use getOmni.
        参数：
        on - true to turn omni mode on, false to turn it off.
        另请参见：
        getOmni(), VoiceStatus

      • getOmni

        boolean getOmni()
        Obtains the current omni mode. Synthesizers that do not allow changing the omni mode will always return the same value, regardless of calls to setOmni.
        返回：
        true if omni mode is on, otherwise false (meaning omni mode is off).
        另请参见：
        setOmni(boolean)

      • setMute

        void setMute(boolean mute)
        Sets the mute state for this channel. A value of true means the channel is to be muted, false means the channel can sound (if other channels are not soloed).

        Unlike allSoundOff(), this method applies to only a specific channel, not to all channels. Further, it silences not only currently sounding notes, but also subsequently received notes. It is possible that the underlying synthesizer does not support muting channels. In order to verify that a call to setMute was successful, use getMute.

        参数：
        mute - the new mute state
        另请参见：
        getMute(), setSolo(boolean)

      • getMute

        boolean getMute()
        Obtains the current mute state for this channel. If the underlying synthesizer does not support muting this channel, this method always returns false.
        返回：
        true the channel is muted, or false if not
        另请参见：
        setMute(boolean)

      • setSolo

        void setSolo(boolean soloState)
        Sets the solo state for this channel. If solo is true only this channel and other soloed channels will sound. If solo is false then only other soloed channels will sound, unless no channels are soloed, in which case all unmuted channels will sound. It is possible that the underlying synthesizer does not support solo channels. In order to verify that a call to setSolo was successful, use getSolo.
        参数：
        soloState - new solo state for the channel
        另请参见：
        getSolo()

      • getSolo

        boolean getSolo()
        Obtains the current solo state for this channel. If the underlying synthesizer does not support solo on this channel, this method always returns false.
        返回：
        true the channel is solo, or false if not
        另请参见：
        setSolo(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


MidiDevice

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface MidiDevice

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    Sequencer, Synthesizer

    public interface MidiDevice
extends AutoCloseable
    MidiDevice is the base interface for all MIDI devices. Common devices include synthesizers, sequencers, MIDI input ports, and MIDI output ports.

    A MidiDevice can be a transmitter or a receiver of MIDI events, or both. Therefore, it can provide Transmitter or Receiver instances (or both). Typically, MIDI IN ports provide transmitters, MIDI OUT ports and synthesizers provide receivers. A Sequencer typically provides transmitters for playback and receivers for recording.

    A MidiDevice can be opened and closed explicitly as well as implicitly. Explicit opening is accomplished by calling open(), explicit closing is done by calling close() on the MidiDevice instance. If an application opens a MidiDevice explicitly, it has to close it explicitly to free system resources and enable the application to exit cleanly. Implicit opening is done by calling MidiSystem.getReceiver and MidiSystem.getTransmitter. The MidiDevice used by MidiSystem.getReceiver and MidiSystem.getTransmitter is implementation-dependant unless the properties javax.sound.midi.Receiver and javax.sound.midi.Transmitter are used (see the description of properties to select default providers in MidiSystem). A MidiDevice that was opened implicitly, is closed implicitly by closing the Receiver or Transmitter that resulted in opening it. If more than one implicitly opening Receiver or Transmitter were obtained by the application, the decive is closed after the last Receiver or Transmitter has been closed. On the other hand, calling getReceiver or getTransmitter on the device instance directly does not open the device implicitly. Closing these Transmitters and Receivers does not close the device implicitly. To use a device with Receivers or Transmitters obtained this way, the device has to be opened and closed explicitly.

    If implicit and explicit opening and closing are mixed on the same MidiDevice instance, the following rules apply:

    • After an explicit open (either before or after implicit opens), the device will not be closed by implicit closing. The only way to close an explicitly opened device is an explicit close.
    • An explicit close always closes the device, even if it also has been opened implicitly. A subsequent implicit close has no further effect.
    To detect if a MidiDevice represents a hardware MIDI port, the following programming technique can be used:
     MidiDevice device = ...;
 if ( ! (device instanceof Sequencer) && ! (device instanceof Synthesizer)) {
   // we're now sure that device represents a MIDI port
   // ...
 }

    A MidiDevice includes a MidiDevice.Info object to provide manufacturer information and so on.

    另请参见：
    Synthesizer, Sequencer, Receiver, Transmitter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  MidiDevice.Info
      A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Closes the device, indicating that the device should now release any system resources it is using.
      MidiDevice.Info getDeviceInfo()
      Obtains information about the device, including its Java class and Strings containing its name, vendor, and description.
      int getMaxReceivers()
      Obtains the maximum number of MIDI IN connections available on this MIDI device for receiving MIDI data.
      int getMaxTransmitters()
      Obtains the maximum number of MIDI OUT connections available on this MIDI device for transmitting MIDI data.
      long getMicrosecondPosition()
      Obtains the current time-stamp of the device, in microseconds.
      Receiver getReceiver()
      Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data.
      List<Receiver> getReceivers()
      Returns all currently active, non-closed receivers connected with this MidiDevice.
      Transmitter getTransmitter()
      Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.
      List<Transmitter> getTransmitters()
      Returns all currently active, non-closed transmitters connected with this MidiDevice.
      boolean isOpen()
      Reports whether the device is open.
      void open()
      Opens the device, indicating that it should now acquire any system resources it requires and become operational.

    • 方法详细信息

      • getDeviceInfo

        MidiDevice.Info getDeviceInfo()
        Obtains information about the device, including its Java class and Strings containing its name, vendor, and description.
        返回：
        device info

      • open

        void open()
          throws MidiUnavailableException
        Opens the device, indicating that it should now acquire any system resources it requires and become operational.

        An application opening a device explicitly with this call has to close the device by calling close(). This is necessary to release system resources and allow applications to exit cleanly.

        Note that some devices, once closed, cannot be reopened. Attempts to reopen such a device will always result in a MidiUnavailableException.

        抛出：
        MidiUnavailableException - thrown if the device cannot be opened due to resource restrictions.
        SecurityException - thrown if the device cannot be opened due to security restrictions.
        另请参见：
        close(), isOpen()

      • close

        void close()
        Closes the device, indicating that the device should now release any system resources it is using.

        All Receiver and Transmitter instances open from this device are closed. This includes instances retrieved via MidiSystem.

        指定者：
        close in interface AutoCloseable
        另请参见：
        open(), isOpen()

      • isOpen

        boolean isOpen()
        Reports whether the device is open.
        返回：
        true if the device is open, otherwise false
        另请参见：
        open(), close()

      • getMicrosecondPosition

        long getMicrosecondPosition()
        Obtains the current time-stamp of the device, in microseconds. If a device supports time-stamps, it should start counting at 0 when the device is opened and continue incrementing its time-stamp in microseconds until the device is closed. If it does not support time-stamps, it should always return -1.
        返回：
        the current time-stamp of the device in microseconds, or -1 if time-stamping is not supported by the device.

      • getMaxReceivers

        int getMaxReceivers()
        Obtains the maximum number of MIDI IN connections available on this MIDI device for receiving MIDI data.
        返回：
        maximum number of MIDI IN connections, or -1 if an unlimited number of connections is available.

      • getMaxTransmitters

        int getMaxTransmitters()
        Obtains the maximum number of MIDI OUT connections available on this MIDI device for transmitting MIDI data.
        返回：
        maximum number of MIDI OUT connections, or -1 if an unlimited number of connections is available.

      • getReceiver

        Receiver getReceiver()
                     throws MidiUnavailableException
        Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data. The returned receiver must be closed when the application has finished using it.

        Usually the returned receiver implements the MidiDeviceReceiver interface.

        Obtaining a Receiver with this method does not open the device. To be able to use the device, it has to be opened explicitly by calling open(). Also, closing the Receiver does not close the device. It has to be closed explicitly by calling close().

        返回：
        a receiver for the device.
        抛出：
        MidiUnavailableException - thrown if a receiver is not available due to resource restrictions
        另请参见：
        Receiver.close()

      • getReceivers

        List<Receiver> getReceivers()
        Returns all currently active, non-closed receivers connected with this MidiDevice. A receiver can be removed from the device by closing it.

        Usually the returned receivers implement the MidiDeviceReceiver interface.

        返回：
        an unmodifiable list of the open receivers
        从以下版本开始：
        1.5

      • getTransmitter

        Transmitter getTransmitter()
                           throws MidiUnavailableException
        Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.

        Usually the returned transmitter implements the MidiDeviceTransmitter interface.

        Obtaining a Transmitter with this method does not open the device. To be able to use the device, it has to be opened explicitly by calling open(). Also, closing the Transmitter does not close the device. It has to be closed explicitly by calling close().

        返回：
        a MIDI OUT transmitter for the device.
        抛出：
        MidiUnavailableException - thrown if a transmitter is not available due to resource restrictions
        另请参见：
        Transmitter.close()

      • getTransmitters

        List<Transmitter> getTransmitters()
        Returns all currently active, non-closed transmitters connected with this MidiDevice. A transmitter can be removed from the device by closing it.

        Usually the returned transmitters implement the MidiDeviceTransmitter interface.

        返回：
        an unmodifiable list of the open transmitters
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drehilpblp oop Ib gprip psr&e s p h


MidiDevice.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 MidiDevice.Info

  • java.lang.Object
    • javax.sound.midi.MidiDevice.Info
  • Enclosing interface:
    MidiDevice

    public static class MidiDevice.Info
extends Object
    A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.
    另请参见：
    MidiDevice.getDeviceInfo()

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MidiDevice.Info(String name, String vendor, String description, String version)
      Constructs a device info object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Reports whether two objects are equal.
      String getDescription()
      Obtains the description of the device.
      String getName()
      Obtains the name of the device.
      String getVendor()
      Obtains the name of the company who supplies the device.
      String getVersion()
      Obtains the version of the device.
      int hashCode()
      Finalizes the hashcode method.
      String toString()
      Provides a string representation of the device information.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MidiDevice.Info

        protected MidiDevice.Info(String name,
               String vendor,
               String description,
               String version)
        Constructs a device info object.
        参数：
        name - the name of the device
        vendor - the name of the company who provides the device
        描述 - a description of the device
        version - version information for the device

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Reports whether two objects are equal. Returns true if the objects are identical.
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare this object
        返回：
        true if this object is the same as the obj argument; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashcode method.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • getName

        public final String getName()
        Obtains the name of the device.
        返回：
        a string containing the device's name

      • getVendor

        public final String getVendor()
        Obtains the name of the company who supplies the device.
        返回：
        device the vendor's name

      • getDescription

        public final String getDescription()
        Obtains the description of the device.
        返回：
        a description of the device

      • getVersion

        public final String getVersion()
        Obtains the version of the device.
        返回：
        textual version information for the device.

      • toString

        public final String toString()
        Provides a string representation of the device information.
        重载：
        toString in class Object
        返回：
        a description of the info object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ice"


MidiDeviceReceiver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface MidiDeviceReceiver

  • All Superinterfaces:
    AutoCloseable, Receiver

    public interface MidiDeviceReceiver
extends Receiver

    MidiDeviceReceiver is a Receiver which represents a MIDI input connector of a MidiDevice (see MidiDevice.getReceiver()).

    从以下版本开始：
    1.7

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MidiDevice getMidiDevice()
      Obtains a MidiDevice object which is an owner of this Receiver.

      • 方法 - 继承于接口 javax.sound.midi.Receiver

        close, send

    • 方法详细信息

      • getMidiDevice

        MidiDevice getMidiDevice()
        Obtains a MidiDevice object which is an owner of this Receiver.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aln "ltcltilltiimb//- c --ndddn-a


MidiDeviceTransmitter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface MidiDeviceTransmitter

  • All Superinterfaces:
    AutoCloseable, Transmitter

    public interface MidiDeviceTransmitter
extends Transmitter

    MidiDeviceTransmitter is a Transmitter which represents a MIDI input connector of a MidiDevice (see MidiDevice.getTransmitter()).

    从以下版本开始：
    1.7

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MidiDevice getMidiDevice()
      Obtains a MidiDevice object which is an owner of this Transmitter.

      • 方法 - 继承于接口 javax.sound.midi.Transmitter

        close, getReceiver, setReceiver

    • 方法详细信息

      • getMidiDevice

        MidiDevice getMidiDevice()
        Obtains a MidiDevice object which is an owner of this Transmitter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(hzfn iniegl(ebn.//.fae"jf#g


MidiEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 MidiEvent

  • java.lang.Object
    • javax.sound.midi.MidiEvent

  • public class MidiEvent
extends Object
    MIDI events contain a MIDI message and a corresponding time-stamp expressed in ticks, and can represent the MIDI event information stored in a MIDI file or a Sequence object. The duration of a tick is specified by the timing information contained in the MIDI file or Sequence object.

    In Java Sound, MidiEvent objects are typically contained in a Track, and Tracks are likewise contained in a Sequence.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiEvent(MidiMessage message, long tick)
      Constructs a new MidiEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MidiMessage getMessage()
      Obtains the MIDI message contained in the event.
      long getTick()
      Obtains the time-stamp for the event, in MIDI ticks
      void setTick(long tick)
      Sets the time-stamp for the event, in MIDI ticks

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MidiEvent

        public MidiEvent(MidiMessage message,
         long tick)
        Constructs a new MidiEvent.
        参数：
        message - the MIDI message contained in the event
        tick - the time-stamp for the event, in MIDI ticks

    • 方法详细信息

      • getMessage

        public MidiMessage getMessage()
        Obtains the MIDI message contained in the event.
        返回：
        the MIDI message

      • setTick

        public void setTick(long tick)
        Sets the time-stamp for the event, in MIDI ticks
        参数：
        tick - the new time-stamp, in MIDI ticks

      • getTick

        public long getTick()
        Obtains the time-stamp for the event, in MIDI ticks
        返回：
        the time-stamp for the event, in MIDI ticks
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rge/cdeodd ttc/.aee >"鋖sff...O"j.e薱


MidiFileFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 MidiFileFormat

  • java.lang.Object
    • javax.sound.midi.MidiFileFormat

  • public class MidiFileFormat
extends Object
    A MidiFileFormat object encapsulates a MIDI file's type, as well as its length and timing information.

    A MidiFileFormat object can include a set of properties. A property is a pair of key and value: the key is of type String, the associated property value is an arbitrary object. Properties specify additional informational meta data (like a author, or copyright). Properties are optional information, and file reader and file writer implementations are not required to provide or recognize properties.

    The following table lists some common properties that should be used in implementations:

    Property key | Value type | 描述
    "author" | String | name of the author of this file
    "title" | String | title of this file
    "copyright" | String | copyright message
    "date" | Date | date of the recording or release
    "comment" | String | an arbitrary text
    另请参见：
    MidiSystem.getMidiFileFormat(java.io.File), Sequencer.setSequence(java.io.InputStream stream)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int byteLength
      The length of the MIDI file in bytes.
      protected float divisionType
      The division type of the MIDI file.
      protected long microsecondLength
      The duration of the MIDI file in microseconds.
      protected int resolution
      The timing resolution of the MIDI file.
      protected int type
      The type of MIDI file.
      static int UNKNOWN_LENGTH
      Represents unknown length.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds)
      Constructs a MidiFileFormat.
      MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
      Construct a MidiFileFormat with a set of properties.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getByteLength()
      Obtains the length of the MIDI file, expressed in 8-bit bytes.
      float getDivisionType()
      Obtains the timing division type for the MIDI file.
      long getMicrosecondLength()
      Obtains the length of the MIDI file, expressed in microseconds.
      Object getProperty(String key)
      Obtain the property value specified by the key.
      int getResolution()
      Obtains the timing resolution for the MIDI file.
      int getType()
      Obtains the MIDI file type.
      Map<String,Object> properties()
      Obtain an unmodifiable map of properties.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • UNKNOWN_LENGTH

        public static final int UNKNOWN_LENGTH
        Represents unknown length.
        另请参见：
        getByteLength(), getMicrosecondLength(), Constant Field Values

      • type

        protected int type
        The type of MIDI file.

      • divisionType

        protected float divisionType
        The division type of the MIDI file.
        另请参见：
        Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30

      • resolution

        protected int resolution
        The timing resolution of the MIDI file.

      • byteLength

        protected int byteLength
        The length of the MIDI file in bytes.

      • microsecondLength

        protected long microsecondLength
        The duration of the MIDI file in microseconds.

    • 构造方法详细信息

      • MidiFileFormat

        public MidiFileFormat(int type,
              float divisionType,
              int resolution,
              int bytes,
              long microseconds)
        Constructs a MidiFileFormat.
        参数：
        type - the MIDI file type (0, 1, or 2)
        divisionType - the timing division type (PPQ or one of the SMPTE types)
        resolution - the timing resolution
        bytes - the length of the MIDI file in bytes, or UNKNOWN_LENGTH if not known
        microseconds - the duration of the file in microseconds, or UNKNOWN_LENGTH if not known
        另请参见：
        UNKNOWN_LENGTH, Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30

      • MidiFileFormat

        public MidiFileFormat(int type,
              float divisionType,
              int resolution,
              int bytes,
              long microseconds,
              Map<String,Object> properties)
        Construct a MidiFileFormat with a set of properties.
        参数：
        type - the MIDI file type (0, 1, or 2)
        divisionType - the timing division type (PPQ or one of the SMPTE types)
        resolution - the timing resolution
        bytes - the length of the MIDI file in bytes, or UNKNOWN_LENGTH if not known
        microseconds - the duration of the file in microseconds, or UNKNOWN_LENGTH if not known
        properties - a Map<String,Object> object with properties
        从以下版本开始：
        1.5
        另请参见：
        UNKNOWN_LENGTH, Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30

    • 方法详细信息

      • getType

        public int getType()
        Obtains the MIDI file type.
        返回：
        the file's type (0, 1, or 2)

      • getDivisionType

        public float getDivisionType()
        Obtains the timing division type for the MIDI file.
        返回：
        the division type (PPQ or one of the SMPTE types)
        另请参见：
        Sequence.Sequence(float, int), Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30, Sequence.getDivisionType()

      • getResolution

        public int getResolution()
        Obtains the timing resolution for the MIDI file. If the division type is PPQ, the resolution is specified in ticks per beat. For SMTPE timing, the resolution is specified in ticks per frame.
        返回：
        the number of ticks per beat (PPQ) or per frame (SMPTE)
        另请参见：
        getDivisionType(), Sequence.getResolution()

      • getByteLength

        public int getByteLength()
        Obtains the length of the MIDI file, expressed in 8-bit bytes.
        返回：
        the number of bytes in the file, or UNKNOWN_LENGTH if not known
        另请参见：
        UNKNOWN_LENGTH

      • getMicrosecondLength

        public long getMicrosecondLength()
        Obtains the length of the MIDI file, expressed in microseconds.
        返回：
        the file's duration in microseconds, or UNKNOWN_LENGTH if not known
        另请参见：
        Sequence.getMicrosecondLength(), getByteLength(), UNKNOWN_LENGTH

      • properties

        public Map<String,Object> properties()
        Obtain an unmodifiable map of properties. The concept of properties is further explained in the class description.
        返回：
        a Map<String,Object> object containing all properties. If no properties are recognized, an empty map is returned.
        从以下版本开始：
        1.5
        另请参见：
        getProperty(String)

      • getProperty

        public Object getProperty(String key)
        Obtain the property value specified by the key. The concept of properties is further explained in the class description.

        If the specified property is not defined for a particular file format, this method returns null.

        参数：
        key - the key of the desired property
        返回：
        the value of the property with the specified key, or null if the property does not exist.
        从以下版本开始：
        1.5
        另请参见：
        properties()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r�>/>j>f>lrtt衖nt�>./p>鵯v/va>/==b>l"


MidiMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 MidiMessage

  • java.lang.Object
    • javax.sound.midi.MidiMessage
  • 所有已实现的接口：
    Cloneable
    直接已知子类：
    MetaMessage, ShortMessage, SysexMessage

    public abstract class MidiMessage
extends Object
implements Cloneable
    MidiMessage is the base class for MIDI messages. They include not only the standard MIDI messages that a synthesizer can respond to, but also "meta-events" that can be used by sequencer programs. There are meta-events for such information as lyrics, copyrights, tempo indications, time and key signatures, markers, etc. For more information, see the Standard MIDI Files 1.0 specification, which is part of the Complete MIDI 1.0 Detailed Specification published by the MIDI Manufacturer's Association (http://www.midi.org).

    The base MidiMessage class provides access to three types of information about a MIDI message:

    • The messages's status byte
    • The total length of the message in bytes (the status byte plus any data bytes)
    • A byte array containing the complete message
    MidiMessage includes methods to get, but not set, these values. Setting them is a subclass responsibility.

    The MIDI standard expresses MIDI data in bytes. However, because JavaTM uses signed bytes, the Java Sound API uses integers instead of bytes when expressing MIDI data. For example, the getStatus() method of MidiMessage returns MIDI status bytes as integers. If you are processing MIDI data that originated outside Java Sound and now is encoded as signed bytes, the bytes can can be converted to integers using this conversion:

    int i = (int)(byte & 0xFF)

    If you simply need to pass a known MIDI byte value as a method parameter, it can be expressed directly as an integer, using (for example) decimal or hexidecimal notation. For instance, to pass the "active sensing" status byte as the first argument to ShortMessage's setMessage(int) method, you can express it as 254 or 0xFE.

    另请参见：
    Track, Sequence, Receiver

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected byte[] data
      The MIDI message data.
      protected int length
      The number of bytes in the MIDI message, including the status byte and any data bytes.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected MidiMessage(byte[] data)
      Constructs a new MidiMessage.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Object clone()
      Creates a new object of the same class and with the same contents as this object.
      int getLength()
      Obtains the total length of the MIDI message in bytes.
      byte[] getMessage()
      Obtains the MIDI message data.
      int getStatus()
      Obtains the status byte for the MIDI message.
      protected void setMessage(byte[] data, int length)
      Sets the data for the MIDI message.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • data

        protected byte[] data
        The MIDI message data. The first byte is the status byte for the message; subsequent bytes up to the length of the message are data bytes for this message.
        另请参见：
        getLength()

      • length

        protected int length
        The number of bytes in the MIDI message, including the status byte and any data bytes.
        另请参见：
        getLength()

    • 构造方法详细信息

      • MidiMessage

        protected MidiMessage(byte[] data)
        Constructs a new MidiMessage. This protected constructor is called by concrete subclasses, which should ensure that the data array specifies a complete, valid MIDI message.
        参数：
        data - an array of bytes containing the complete message. The message data may be changed using the setMessage method.
        另请参见：
        setMessage(byte[], int)

    • 方法详细信息

      • setMessage

        protected void setMessage(byte[] data,
              int length)
                   throws InvalidMidiDataException
        Sets the data for the MIDI message. This protected method is called by concrete subclasses, which should ensure that the data array specifies a complete, valid MIDI message.
        抛出：
        InvalidMidiDataException

      • getMessage

        public byte[] getMessage()
        Obtains the MIDI message data. The first byte of the returned byte array is the status byte of the message. Any subsequent bytes up to the length of the message are data bytes. The byte array may have a length which is greater than that of the actual message; the total length of the message in bytes is reported by the getLength() method.
        返回：
        the byte array containing the complete MidiMessage data

      • getStatus

        public int getStatus()
        Obtains the status byte for the MIDI message. The status "byte" is represented as an integer; see the discussion in the MidiMessage class description.
        返回：
        the integer representation of this event's status byte

      • getLength

        public int getLength()
        Obtains the total length of the MIDI message in bytes. A MIDI message consists of one status byte and zero or more data bytes. The return value ranges from 1 for system real-time messages, to 2 or 3 for channel messages, to any value for meta and system exclusive messages.
        返回：
        the length of the message in bytes

      • clone

        public abstract Object clone()
        Creates a new object of the same class and with the same contents as this object.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sip e ts>>yg"""bob


MidiSystem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

类 MidiSystem

  • java.lang.Object
    • javax.sound.midi.MidiSystem

  • public class MidiSystem
extends Object
    The MidiSystem class provides access to the installed MIDI system resources, including devices such as synthesizers, sequencers, and MIDI input and output ports. A typical simple MIDI application might begin by invoking one or more MidiSystem methods to learn what devices are installed and to obtain the ones needed in that application.

    The class also has methods for reading files, streams, and URLs that contain standard MIDI file data or soundbanks. You can query the MidiSystem for the format of a specified MIDI file.

    You cannot instantiate a MidiSystem; all the methods are static.

    Properties can be used to specify default MIDI devices. Both system properties and a properties file are considered. The properties file is "lib/sound.properties" in the JRE directory. If a property exists both as a system property and in the properties file, the system property takes precedence. If none is specified, a suitable default is chosen among the available devices. The syntax of the properties file is specified in Properties.load. The following table lists the available property keys and which methods consider them:

    Property Key | 接口 | Affected Method
    javax.sound.midi.Receiver | Receiver | getReceiver()
    javax.sound.midi.Sequencer | Sequencer | getSequencer()
    javax.sound.midi.Synthesizer | Synthesizer | getSynthesizer()
    javax.sound.midi.Transmitter | Transmitter | getTransmitter()
    The property value consists of the provider class name and the device name, separated by the hash mark ("#"). The provider class name is the fully-qualified name of a concrete MIDI device provider class. The device name is matched against the String returned by the getName method of MidiDevice.Info. Either the class name, or the device name may be omitted. If only the class name is specified, the trailing hash mark is optional.

    If the provider class is specified, and it can be successully retrieved from the installed providers, the list of MidiDevice.Info objects is retrieved from the provider. Otherwise, or when these devices do not provide a subsequent match, the list is retrieved from getMidiDeviceInfo() to contain all available MidiDevice.Info objects.

    If a device name is specified, the resulting list of MidiDevice.Info objects is searched: the first one with a matching name, and whose MidiDevice implements the respective interface, will be returned. If no matching MidiDevice.Info object is found, or the device name is not specified, the first suitable device from the resulting list will be returned. For Sequencer and Synthesizer, a device is suitable if it implements the respective interface; whereas for Receiver and Transmitter, a device is suitable if it implements neither Sequencer nor Synthesizer and provides at least one Receiver or Transmitter, respectively. For example, the property javax.sound.midi.Receiver with a value "com.sun.media.sound.MidiProvider#SunMIDI1" will have the following consequences when getReceiver is called: if the class com.sun.media.sound.MidiProvider exists in the list of installed MIDI device providers, the first Receiver device with name "SunMIDI1" will be returned. If it cannot be found, the first Receiver from that provider will be returned, regardless of name. If there is none, the first Receiver with name "SunMIDI1" in the list of all devices (as returned by getMidiDeviceInfo) will be returned, or, if not found, the first Receiver that can be found in the list of all devices is returned. If that fails, too, a MidiUnavailableException is thrown.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static MidiDevice getMidiDevice(MidiDevice.Info info)
      Obtains the requested MIDI device.
      static MidiDevice.Info[] getMidiDeviceInfo()
      Obtains an array of information objects representing the set of all MIDI devices available on the system.
      static MidiFileFormat getMidiFileFormat(File file)
      Obtains the MIDI file format of the specified File.
      static MidiFileFormat getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the data in the specified input stream.
      static MidiFileFormat getMidiFileFormat(URL url)
      Obtains the MIDI file format of the data in the specified URL.
      static int[] getMidiFileTypes()
      Obtains the set of MIDI file types for which file writing support is provided by the system.
      static int[] getMidiFileTypes(Sequence sequence)
      Obtains the set of MIDI file types that the system can write from the sequence specified.
      static Receiver getReceiver()
      Obtains a MIDI receiver from an external MIDI port or other default device.
      static Sequence getSequence(File file)
      Obtains a MIDI sequence from the specified File.
      static Sequence getSequence(InputStream stream)
      Obtains a MIDI sequence from the specified input stream.
      static Sequence getSequence(URL url)
      Obtains a MIDI sequence from the specified URL.
      static Sequencer getSequencer()
      Obtains the default Sequencer, connected to a default device.
      static Sequencer getSequencer(boolean connected)
      Obtains the default Sequencer, optionally connected to a default device.
      static Soundbank getSoundbank(File file)
      Constructs a Soundbank by reading it from the specified File.
      static Soundbank getSoundbank(InputStream stream)
      Constructs a MIDI sound bank by reading it from the specified stream.
      static Soundbank getSoundbank(URL url)
      Constructs a Soundbank by reading it from the specified URL.
      static Synthesizer getSynthesizer()
      Obtains the default synthesizer.
      static Transmitter getTransmitter()
      Obtains a MIDI transmitter from an external MIDI port or other default source.
      static boolean isFileTypeSupported(int fileType)
      Indicates whether file writing support for the specified MIDI file type is provided by the system.
      static boolean isFileTypeSupported(int fileType, Sequence sequence)
      Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
      static int write(Sequence in, int type, File out)
      Writes a stream of bytes representing a file of the MIDI file type indicated to the external file provided.
      static int write(Sequence in, int fileType, OutputStream out)
      Writes a stream of bytes representing a file of the MIDI file type indicated to the output stream provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getMidiDeviceInfo

        public static MidiDevice.Info[] getMidiDeviceInfo()
        Obtains an array of information objects representing the set of all MIDI devices available on the system. A returned information object can then be used to obtain the corresponding device object, by invoking getMidiDevice.
        返回：
        an array of MidiDevice.Info objects, one for each installed MIDI device. If no such devices are installed, an array of length 0 is returned.

      • getMidiDevice

        public static MidiDevice getMidiDevice(MidiDevice.Info info)
                                throws MidiUnavailableException
        Obtains the requested MIDI device.
        参数：
        info - a device information object representing the desired device.
        返回：
        the requested device
        抛出：
        MidiUnavailableException - if the requested device is not available due to resource restrictions
        IllegalArgumentException - if the info object does not represent a MIDI device installed on the system
        另请参见：
        getMidiDeviceInfo()

      • getReceiver

        public static Receiver getReceiver()
                            throws MidiUnavailableException
        Obtains a MIDI receiver from an external MIDI port or other default device. The returned receiver always implements the MidiDeviceReceiver interface.

        If the system property javax.sound.midi.Receiver is defined or it is defined in the file "sound.properties", it is used to identify the device that provides the default receiver. For details, refer to the class description. If a suitable MIDI port is not available, the Receiver is retrieved from an installed synthesizer.

        If this method returns successfully, the MidiDevice the Receiver belongs to is opened implicitly, if it is not already open. It is possible to close an implicitly opened device by calling close on the returned Receiver. All open Receiver instances have to be closed in order to release system resources hold by the MidiDevice. For a detailed description of open/close behaviour see the class description of MidiDevice.

        返回：
        the default MIDI receiver
        抛出：
        MidiUnavailableException - if the default receiver is not available due to resource restrictions, or no device providing receivers is installed in the system

      • getTransmitter

        public static Transmitter getTransmitter()
                                  throws MidiUnavailableException
        Obtains a MIDI transmitter from an external MIDI port or other default source. The returned transmitter always implements the MidiDeviceTransmitter interface.

        If the system property javax.sound.midi.Transmitter is defined or it is defined in the file "sound.properties", it is used to identify the device that provides the default transmitter. For details, refer to the class description. If this method returns successfully, the MidiDevice the Transmitter belongs to is opened implicitly, if it is not already open. It is possible to close an implicitly opened device by calling close on the returned Transmitter. All open Transmitter instances have to be closed in order to release system resources hold by the MidiDevice. For a detailed description of open/close behaviour see the class description of MidiDevice.

        返回：
        the default MIDI transmitter
        抛出：
        MidiUnavailableException - if the default transmitter is not available due to resource restrictions, or no device providing transmitters is installed in the system

      • getSynthesizer

        public static Synthesizer getSynthesizer()
                                  throws MidiUnavailableException
        Obtains the default synthesizer.

        If the system property javax.sound.midi.Synthesizer is defined or it is defined in the file "sound.properties", it is used to identify the default synthesizer. For details, refer to the class description.

        返回：
        the default synthesizer
        抛出：
        MidiUnavailableException - if the synthesizer is not available due to resource restrictions, or no synthesizer is installed in the system

      • getSequencer

        public static Sequencer getSequencer()
                              throws MidiUnavailableException
        Obtains the default Sequencer, connected to a default device. The returned Sequencer instance is connected to the default Synthesizer, as returned by getSynthesizer(). If there is no Synthesizer available, or the default Synthesizer cannot be opened, the sequencer is connected to the default Receiver, as returned by getReceiver(). The connection is made by retrieving a Transmitter instance from the Sequencer and setting its Receiver. Closing and re-opening the sequencer will restore the connection to the default device.

        This method is equivalent to calling getSequencer(true).

        If the system property javax.sound.midi.Sequencer is defined or it is defined in the file "sound.properties", it is used to identify the default sequencer. For details, refer to the class description.

        返回：
        the default sequencer, connected to a default Receiver
        抛出：
        MidiUnavailableException - if the sequencer is not available due to resource restrictions, or there is no Receiver available by any installed MidiDevice, or no sequencer is installed in the system.
        另请参见：
        getSequencer(boolean), getSynthesizer(), getReceiver()

      • getSequencer

        public static Sequencer getSequencer(boolean connected)
                              throws MidiUnavailableException
        Obtains the default Sequencer, optionally connected to a default device.

        If connected is true, the returned Sequencer instance is connected to the default Synthesizer, as returned by getSynthesizer(). If there is no Synthesizer available, or the default Synthesizer cannot be opened, the sequencer is connected to the default Receiver, as returned by getReceiver(). The connection is made by retrieving a Transmitter instance from the Sequencer and setting its Receiver. Closing and re-opening the sequencer will restore the connection to the default device.

        If connected is false, the returned Sequencer instance is not connected, it has no open Transmitters. In order to play the sequencer on a MIDI device, or a Synthesizer, it is necessary to get a Transmitter and set its Receiver.

        If the system property javax.sound.midi.Sequencer is defined or it is defined in the file "sound.properties", it is used to identify the default sequencer. For details, refer to the class description.

        返回：
        the default sequencer
        抛出：
        MidiUnavailableException - if the sequencer is not available due to resource restrictions, or no sequencer is installed in the system, or if connected is true, and there is no Receiver available by any installed MidiDevice
        从以下版本开始：
        1.5
        另请参见：
        getSynthesizer(), getReceiver()

      • getSoundbank

        public static Soundbank getSoundbank(InputStream stream)
                              throws InvalidMidiDataException,
                                     IOException
        Constructs a MIDI sound bank by reading it from the specified stream. The stream must point to a valid MIDI soundbank file. In general, MIDI soundbank providers may need to read some data from the stream before determining whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support this, this method may fail with an IOException.
        参数：
        stream - the source of the sound bank data.
        返回：
        the sound bank
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI soundbank data recognized by the system
        IOException - if an I/O error occurred when loading the soundbank
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getSoundbank

        public static Soundbank getSoundbank(URL url)
                              throws InvalidMidiDataException,
                                     IOException
        Constructs a Soundbank by reading it from the specified URL. The URL must point to a valid MIDI soundbank file.
        参数：
        url - the source of the sound bank data
        返回：
        the sound bank
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI soundbank data recognized by the system
        IOException - if an I/O error occurred when loading the soundbank

      • getSoundbank

        public static Soundbank getSoundbank(File file)
                              throws InvalidMidiDataException,
                                     IOException
        Constructs a Soundbank by reading it from the specified File. The File must point to a valid MIDI soundbank file.
        参数：
        file - the source of the sound bank data
        返回：
        the sound bank
        抛出：
        InvalidMidiDataException - if the File does not point to valid MIDI soundbank data recognized by the system
        IOException - if an I/O error occurred when loading the soundbank

      • getMidiFileFormat

        public static MidiFileFormat getMidiFileFormat(InputStream stream)
                                        throws InvalidMidiDataException,
                                               IOException
        Obtains the MIDI file format of the data in the specified input stream. The stream must point to valid MIDI file data for a file type recognized by the system.

        This method and/or the code it invokes may need to read some data from the stream to determine whether its data format is supported. The implementation may therefore need to mark the stream, read enough data to determine whether it is in a supported format, and reset the stream's read pointer to its original position. If the input stream does not permit this set of operations, this method may fail with an IOException.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while determining the file format.

        参数：
        stream - the input stream from which file format information should be extracted
        返回：
        an MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs while accessing the stream
        另请参见：
        getMidiFileFormat(URL), getMidiFileFormat(File), InputStream.markSupported(), InputStream.mark(int)

      • getMidiFileFormat

        public static MidiFileFormat getMidiFileFormat(URL url)
                                        throws InvalidMidiDataException,
                                               IOException
        Obtains the MIDI file format of the data in the specified URL. The URL must point to valid MIDI file data for a file type recognized by the system.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while determining the file format.

        参数：
        url - the URL from which file format information should be extracted
        返回：
        a MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs while accessing the URL
        另请参见：
        getMidiFileFormat(InputStream), getMidiFileFormat(File)

      • getMidiFileFormat

        public static MidiFileFormat getMidiFileFormat(File file)
                                        throws InvalidMidiDataException,
                                               IOException
        Obtains the MIDI file format of the specified File. The File must point to valid MIDI file data for a file type recognized by the system.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while determining the file format.

        参数：
        file - the File from which file format information should be extracted
        返回：
        a MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the File does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs while accessing the file
        另请参见：
        getMidiFileFormat(InputStream), getMidiFileFormat(URL)

      • getSequence

        public static Sequence getSequence(InputStream stream)
                            throws InvalidMidiDataException,
                                   IOException
        Obtains a MIDI sequence from the specified input stream. The stream must point to valid MIDI file data for a file type recognized by the system.

        This method and/or the code it invokes may need to read some data from the stream to determine whether its data format is supported. The implementation may therefore need to mark the stream, read enough data to determine whether it is in a supported format, and reset the stream's read pointer to its original position. If the input stream does not permit this set of operations, this method may fail with an IOException.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while constructing the Sequence object from the file data.

        参数：
        stream - the input stream from which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data contained in the input stream
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs while accessing the stream
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getSequence

        public static Sequence getSequence(URL url)
                            throws InvalidMidiDataException,
                                   IOException
        Obtains a MIDI sequence from the specified URL. The URL must point to valid MIDI file data for a file type recognized by the system.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while constructing the Sequence object from the file data.

        参数：
        url - the URL from which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data pointed to by the URL
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs while accessing the URL

      • getSequence

        public static Sequence getSequence(File file)
                            throws InvalidMidiDataException,
                                   IOException
        Obtains a MIDI sequence from the specified File. The File must point to valid MIDI file data for a file type recognized by the system.

        This operation can only succeed for files of a type which can be parsed by an installed file reader. It may fail with an InvalidMidiDataException even for valid files if no compatible file reader is installed. It will also fail with an InvalidMidiDataException if a compatible file reader is installed, but encounters errors while constructing the Sequence object from the file data.

        参数：
        file - the File from which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data pointed to by the File
        抛出：
        InvalidMidiDataException - if the File does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs

      • getMidiFileTypes

        public static int[] getMidiFileTypes()
        Obtains the set of MIDI file types for which file writing support is provided by the system.
        返回：
        array of unique file types. If no file types are supported, an array of length 0 is returned.

      • isFileTypeSupported

        public static boolean isFileTypeSupported(int fileType)
        Indicates whether file writing support for the specified MIDI file type is provided by the system.
        参数：
        fileType - the file type for which write capabilities are queried
        返回：
        true if the file type is supported, otherwise false

      • getMidiFileTypes

        public static int[] getMidiFileTypes(Sequence sequence)
        Obtains the set of MIDI file types that the system can write from the sequence specified.
        参数：
        sequence - the sequence for which MIDI file type support is queried
        返回：
        the set of unique supported file types. If no file types are supported, returns an array of length 0.

      • isFileTypeSupported

        public static boolean isFileTypeSupported(int fileType,
                          Sequence sequence)
        Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
        参数：
        fileType - the file type for which write capabilities are queried
        sequence - the sequence for which file writing support is queried
        返回：
        true if the file type is supported for this sequence, otherwise false

      • write

        public static int write(Sequence in,
        int fileType,
        OutputStream out)
                 throws IOException
        Writes a stream of bytes representing a file of the MIDI file type indicated to the output stream provided.
        参数：
        in - sequence containing MIDI data to be written to the file
        fileType - the file type of the file to be written to the output stream
        out - stream to which the file data should be written
        返回：
        the number of bytes written to the output stream
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file format is not supported by the system
        另请参见：
        isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)

      • write

        public static int write(Sequence in,
        int type,
        File out)
                 throws IOException
        Writes a stream of bytes representing a file of the MIDI file type indicated to the external file provided.
        参数：
        in - sequence containing MIDI data to be written to the file
        type - the file type of the file to be written to the output stream
        out - external file to which the file data should be written
        返回：
        the number of bytes written to the file
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file type is not supported by the system
        另请参见：
        isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


MidiUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.midi

类 MidiUnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.sound.midi.MidiUnavailableException
  • 所有已实现的接口：
    Serializable

    public class MidiUnavailableException
extends Exception
    A MidiUnavailableException is thrown when a requested MIDI component cannot be opened or created because it is unavailable. This often occurs when a device is in use by another application. More generally, it can occur when there is a finite number of a certain kind of resource that can be used for some purpose, and all of them are already in use (perhaps all by this application). For an example of the latter case, see the setReceiver method of Transmitter.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiUnavailableException()
      Constructs a MidiUnavailableException that has null as its error detail message.
      MidiUnavailableException(String message)
      Constructs a MidiUnavailableException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MidiUnavailableException

        public MidiUnavailableException()
        Constructs a MidiUnavailableException that has null as its error detail message.

      • MidiUnavailableException

        public MidiUnavailableException(String message)
        Constructs a MidiUnavailableException with the specified detail message.
        参数：
        message - the string to display as an error detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< tti>.v>.m<<.mms iibsaksnnaotcskc">I


Patch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 Patch

  • java.lang.Object
    • javax.sound.midi.Patch

  • public class Patch
extends Object
    A Patch object represents a location, on a MIDI synthesizer, into which a single instrument is stored (loaded). Every Instrument object has its own Patch object that specifies the memory location into which that instrument should be loaded. The location is specified abstractly by a bank index and a program number (not by any scheme that directly refers to a specific address or offset in RAM). This is a hierarchical indexing scheme: MIDI provides for up to 16384 banks, each of which contains up to 128 program locations. For example, a minimal sort of synthesizer might have only one bank of instruments, and only 32 instruments (programs) in that bank.

    To select what instrument should play the notes on a particular MIDI channel, two kinds of MIDI message are used that specify a patch location: a bank-select command, and a program-change channel command. The Java Sound equivalent is the programChange(int, int) method of MidiChannel.

    另请参见：
    Instrument,
Instrument.getPatch(),
MidiChannel.programChange(int, int),
Synthesizer.loadInstruments(Soundbank, Patch[]),
Soundbank,
Sequence.getPatchList()

    • 构造方法摘要

      Constructors
      构造方法与描述
      Patch(int bank, int program)
      Constructs a new patch object from the specified bank and program numbers.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getBank()
      Returns the number of the bank that contains the instrument whose location this Patch specifies.
      int getProgram()
      Returns the index, within a bank, of the instrument whose location this Patch specifies.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Patch

        public Patch(int bank,
     int program)
        Constructs a new patch object from the specified bank and program numbers.
        参数：
        bank - the bank index (in the range from 0 to 16383)
        program - the program index (in the range from 0 to 127)

    • 方法详细信息

      • getBank

        public int getBank()
        Returns the number of the bank that contains the instrument whose location this Patch specifies.
        返回：
        the bank number, whose range is from 0 to 16383
        另请参见：
        MidiChannel.programChange(int, int)

      • getProgram

        public int getProgram()
        Returns the index, within a bank, of the instrument whose location this Patch specifies.
        返回：
        the instrument's program number, whose range is from 0 to 127
        另请参见：
        MidiChannel.getProgram(),
MidiChannel.programChange(int),
MidiChannel.programChange(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lnu,>/>,/


Receiver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface Receiver

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    MidiDeviceReceiver

    public interface Receiver
extends AutoCloseable
    A Receiver receives MidiEvent objects and typically does something useful in response, such as interpreting them to generate sound or raw MIDI output. Common MIDI receivers include synthesizers and MIDI Out ports.
    另请参见：
    MidiDevice, Synthesizer, Transmitter

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Indicates that the application has finished using the receiver, and that limited resources it requires may be released or made available.
      void send(MidiMessage message, long timeStamp)
      Sends a MIDI message and time-stamp to this receiver.

    • 方法详细信息

      • send

        void send(MidiMessage message,
        long timeStamp)
        Sends a MIDI message and time-stamp to this receiver. If time-stamping is not supported by this receiver, the time-stamp value should be -1.
        参数：
        message - the MIDI message to send
        timeStamp - the time-stamp for the message, in microseconds.
        抛出：
        IllegalStateException - if the receiver is closed

      • close

        void close()
        Indicates that the application has finished using the receiver, and that limited resources it requires may be released or made available.

        If the creation of this Receiver resulted in implicitly opening the underlying device, the device is implicitly closed by this method. This is true unless the device is kept open by other Receiver or Transmitter instances that opened the device implicitly, and unless the device has been opened explicitly. If the device this Receiver is retrieved from is closed explicitly by calling MidiDevice.close, the Receiver is closed, too. For a detailed description of open/close behaviour see the class description of MidiDevice.

        指定者：
        close in interface AutoCloseable
        另请参见：
        MidiSystem.getReceiver()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stelelrclrheerhhi


Sequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 Sequence

  • java.lang.Object
    • javax.sound.midi.Sequence

  • public class Sequence
extends Object
    A Sequence is a data structure containing musical information (often an entire song or composition) that can be played back by a Sequencer object. Specifically, the Sequence contains timing information and one or more tracks. Each track consists of a series of MIDI events (such as note-ons, note-offs, program changes, and meta-events). The sequence's timing information specifies the type of unit that is used to time-stamp the events in the sequence.

    A Sequence can be created from a MIDI file by reading the file into an input stream and invoking one of the getSequence methods of MidiSystem. A sequence can also be built from scratch by adding new Tracks to an empty Sequence, and adding MidiEvent objects to these Tracks.

    另请参见：
    Sequencer.setSequence(java.io.InputStream stream),
Sequencer.setSequence(Sequence sequence),
Track.add(MidiEvent),
MidiFileFormat

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected float divisionType
      The timing division type of the sequence.
      static float PPQ
      The tempo-based timing type, for which the resolution is expressed in pulses (ticks) per quarter note.
      protected int resolution
      The timing resolution of the sequence.
      static float SMPTE_24
      The SMPTE-based timing type with 24 frames per second (resolution is expressed in ticks per frame).
      static float SMPTE_25
      The SMPTE-based timing type with 25 frames per second (resolution is expressed in ticks per frame).
      static float SMPTE_30
      The SMPTE-based timing type with 30 frames per second (resolution is expressed in ticks per frame).
      static float SMPTE_30DROP
      The SMPTE-based timing type with 29.97 frames per second (resolution is expressed in ticks per frame).
      protected Vector<Track> tracks
      The MIDI tracks in this sequence.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Sequence(float divisionType, int resolution)
      Constructs a new MIDI sequence with the specified timing division type and timing resolution.
      Sequence(float divisionType, int resolution, int numTracks)
      Constructs a new MIDI sequence with the specified timing division type, timing resolution, and number of tracks.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Track createTrack()
      Creates a new, initially empty track as part of this sequence.
      boolean deleteTrack(Track track)
      Removes the specified track from the sequence.
      float getDivisionType()
      Obtains the timing division type for this sequence.
      long getMicrosecondLength()
      Obtains the duration of this sequence, expressed in microseconds.
      Patch[] getPatchList()
      Obtains a list of patches referenced in this sequence.
      int getResolution()
      Obtains the timing resolution for this sequence.
      long getTickLength()
      Obtains the duration of this sequence, expressed in MIDI ticks.
      Track[] getTracks()
      Obtains an array containing all the tracks in this sequence.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PPQ

        public static final float PPQ
        The tempo-based timing type, for which the resolution is expressed in pulses (ticks) per quarter note.
        另请参见：
        Sequence(float, int), Constant Field Values

      • SMPTE_24

        public static final float SMPTE_24
        The SMPTE-based timing type with 24 frames per second (resolution is expressed in ticks per frame).
        另请参见：
        Sequence(float, int), Constant Field Values

      • SMPTE_25

        public static final float SMPTE_25
        The SMPTE-based timing type with 25 frames per second (resolution is expressed in ticks per frame).
        另请参见：
        Sequence(float, int), Constant Field Values

      • SMPTE_30DROP

        public static final float SMPTE_30DROP
        The SMPTE-based timing type with 29.97 frames per second (resolution is expressed in ticks per frame).
        另请参见：
        Sequence(float, int), Constant Field Values

      • SMPTE_30

        public static final float SMPTE_30
        The SMPTE-based timing type with 30 frames per second (resolution is expressed in ticks per frame).
        另请参见：
        Sequence(float, int), Constant Field Values

      • divisionType

        protected float divisionType
        The timing division type of the sequence.
        另请参见：
        PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType()

      • resolution

        protected int resolution
        The timing resolution of the sequence.
        另请参见：
        getResolution()

      • tracks

        protected Vector<Track> tracks
        The MIDI tracks in this sequence.
        另请参见：
        getTracks()

    • 构造方法详细信息

      • Sequence

        public Sequence(float divisionType,
        int resolution)
         throws InvalidMidiDataException
        Constructs a new MIDI sequence with the specified timing division type and timing resolution. The division type must be one of the recognized MIDI timing types. For tempo-based timing, divisionType is PPQ (pulses per quarter note) and the resolution is specified in ticks per beat. For SMTPE timing, divisionType specifies the number of frames per second and the resolution is specified in ticks per frame. The sequence will contain no initial tracks. Tracks may be added to or removed from the sequence using createTrack() and deleteTrack(javax.sound.midi.Track).
        参数：
        divisionType - the timing division type (PPQ or one of the SMPTE types)
        resolution - the timing resolution
        抛出：
        InvalidMidiDataException - if divisionType is not valid
        另请参见：
        PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType(), getResolution(), getTracks()

      • Sequence

        public Sequence(float divisionType,
        int resolution,
        int numTracks)
         throws InvalidMidiDataException
        Constructs a new MIDI sequence with the specified timing division type, timing resolution, and number of tracks. The division type must be one of the recognized MIDI timing types. For tempo-based timing, divisionType is PPQ (pulses per quarter note) and the resolution is specified in ticks per beat. For SMTPE timing, divisionType specifies the number of frames per second and the resolution is specified in ticks per frame. The sequence will be initialized with the number of tracks specified by numTracks. These tracks are initially empty (i.e. they contain only the meta-event End of Track). The tracks may be retrieved for editing using the getTracks() method. Additional tracks may be added, or existing tracks removed, using createTrack() and deleteTrack(javax.sound.midi.Track).
        参数：
        divisionType - the timing division type (PPQ or one of the SMPTE types)
        resolution - the timing resolution
        numTracks - the initial number of tracks in the sequence.
        抛出：
        InvalidMidiDataException - if divisionType is not valid
        另请参见：
        PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType(), getResolution()

    • 方法详细信息

      • getDivisionType

        public float getDivisionType()
        Obtains the timing division type for this sequence.
        返回：
        the division type (PPQ or one of the SMPTE types)
        另请参见：
        PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, Sequence(float, int), MidiFileFormat.getDivisionType()

      • getResolution

        public int getResolution()
        Obtains the timing resolution for this sequence. If the sequence's division type is PPQ, the resolution is specified in ticks per beat. For SMTPE timing, the resolution is specified in ticks per frame.
        返回：
        the number of ticks per beat (PPQ) or per frame (SMPTE)
        另请参见：
        getDivisionType(),
Sequence(float, int),
MidiFileFormat.getResolution()

      • createTrack

        public Track createTrack()
        Creates a new, initially empty track as part of this sequence. The track initially contains the meta-event End of Track. The newly created track is returned. All tracks in the sequence may be retrieved using getTracks(). Tracks may be removed from the sequence using deleteTrack(javax.sound.midi.Track).
        返回：
        the newly created track

      • deleteTrack

        public boolean deleteTrack(Track track)
        Removes the specified track from the sequence.
        参数：
        track - the track to remove
        返回：
        true if the track existed in the track and was removed, otherwise false.
        另请参见：
        createTrack(), getTracks()

      • getTracks

        public Track[] getTracks()
        Obtains an array containing all the tracks in this sequence. If the sequence contains no tracks, an array of length 0 is returned.
        返回：
        the array of tracks
        另请参见：
        createTrack(), deleteTrack(javax.sound.midi.Track)

      • getMicrosecondLength

        public long getMicrosecondLength()
        Obtains the duration of this sequence, expressed in microseconds.
        返回：
        this sequence's duration in microseconds.

      • getTickLength

        public long getTickLength()
        Obtains the duration of this sequence, expressed in MIDI ticks.
        返回：
        this sequence's length in ticks
        另请参见：
        getMicrosecondLength()

      • getPatchList

        public Patch[] getPatchList()
        Obtains a list of patches referenced in this sequence. This patch list may be used to load the required Instrument objects into a Synthesizer.
        返回：
        an array of Patch objects used in this sequence
        另请参见：
        Synthesizer.loadInstruments(Soundbank, Patch[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Sequencer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface Sequencer

  • All Superinterfaces:
    AutoCloseable, MidiDevice

    public interface Sequencer
extends MidiDevice
    A hardware or software device that plays back a MIDI sequence is known as a sequencer. A MIDI sequence contains lists of time-stamped MIDI data, such as might be read from a standard MIDI file. Most sequencers also provide functions for creating and editing sequences.

    The Sequencer interface includes methods for the following basic MIDI sequencer operations:

    • obtaining a sequence from MIDI file data
    • starting and stopping playback
    • moving to an arbitrary position in the sequence
    • changing the tempo (speed) of playback
    • synchronizing playback to an internal clock or to received MIDI messages
    • controlling the timing of another device
    In addition, the following operations are supported, either directly, or indirectly through objects that the Sequencer has access to:
    • editing the data by adding or deleting individual MIDI events or entire tracks
    • muting or soloing individual tracks in the sequence
    • notifying listener objects about any meta-events or control-change events encountered while playing back the sequence.
    另请参见：
    Sequencer.SyncMode, addMetaEventListener(javax.sound.midi.MetaEventListener), ControllerEventListener, Receiver, Transmitter, MidiDevice

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Sequencer.SyncMode
      A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device.

      • Nested classes/interfaces inherited from interface javax.sound.midi.MidiDevice

        MidiDevice.Info

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int LOOP_CONTINUOUSLY
      A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int[] addControllerEventListener(ControllerEventListener listener, int[] controllers)
      Registers a controller event listener to receive notification whenever the sequencer processes a control-change event of the requested type or types.
      boolean addMetaEventListener(MetaEventListener listener)
      Registers a meta-event listener to receive notification whenever a meta-event is encountered in the sequence and processed by the sequencer.
      int getLoopCount()
      Obtains the number of repetitions for playback.
      long getLoopEndPoint()
      Obtains the end position of the loop, in MIDI ticks.
      long getLoopStartPoint()
      Obtains the start position of the loop, in MIDI ticks.
      Sequencer.SyncMode getMasterSyncMode()
      Obtains the current master synchronization mode for this sequencer.
      Sequencer.SyncMode[] getMasterSyncModes()
      Obtains the set of master synchronization modes supported by this sequencer.
      long getMicrosecondLength()
      Obtains the length of the current sequence, expressed in microseconds, or 0 if no sequence is set.
      long getMicrosecondPosition()
      Obtains the current position in the sequence, expressed in microseconds.
      Sequence getSequence()
      Obtains the sequence on which the Sequencer is currently operating.
      Sequencer.SyncMode getSlaveSyncMode()
      Obtains the current slave synchronization mode for this sequencer.
      Sequencer.SyncMode[] getSlaveSyncModes()
      Obtains the set of slave synchronization modes supported by the sequencer.
      float getTempoFactor()
      Returns the current tempo factor for the sequencer.
      float getTempoInBPM()
      Obtains the current tempo, expressed in beats per minute.
      float getTempoInMPQ()
      Obtains the current tempo, expressed in microseconds per quarter note.
      long getTickLength()
      Obtains the length of the current sequence, expressed in MIDI ticks, or 0 if no sequence is set.
      long getTickPosition()
      Obtains the current position in the sequence, expressed in MIDI ticks.
      boolean getTrackMute(int track)
      Obtains the current mute state for a track.
      boolean getTrackSolo(int track)
      Obtains the current solo state for a track.
      boolean isRecording()
      Indicates whether the Sequencer is currently recording.
      boolean isRunning()
      Indicates whether the Sequencer is currently running.
      void recordDisable(Track track)
      Disables recording to the specified track.
      void recordEnable(Track track, int channel)
      Prepares the specified track for recording events received on a particular channel.
      int[] removeControllerEventListener(ControllerEventListener listener, int[] controllers)
      Removes a controller event listener's interest in one or more types of controller event.
      void removeMetaEventListener(MetaEventListener listener)
      Removes the specified meta-event listener from this sequencer's list of registered listeners, if in fact the listener is registered.
      void setLoopCount(int count)
      Sets the number of repetitions of the loop for playback.
      void setLoopEndPoint(long tick)
      Sets the last MIDI tick that will be played in the loop.
      void setLoopStartPoint(long tick)
      Sets the first MIDI tick that will be played in the loop.
      void setMasterSyncMode(Sequencer.SyncMode sync)
      Sets the source of timing information used by this sequencer.
      void setMicrosecondPosition(long microseconds)
      Sets the current position in the sequence, expressed in microseconds
      void setSequence(InputStream stream)
      Sets the current sequence on which the sequencer operates.
      void setSequence(Sequence sequence)
      Sets the current sequence on which the sequencer operates.
      void setSlaveSyncMode(Sequencer.SyncMode sync)
      Sets the slave synchronization mode for the sequencer.
      void setTempoFactor(float factor)
      Scales the sequencer's actual playback tempo by the factor provided.
      void setTempoInBPM(float bpm)
      Sets the tempo in beats per minute.
      void setTempoInMPQ(float mpq)
      Sets the tempo in microseconds per quarter note.
      void setTickPosition(long tick)
      Sets the current sequencer position in MIDI ticks
      void setTrackMute(int track, boolean mute)
      Sets the mute state for a track.
      void setTrackSolo(int track, boolean solo)
      Sets the solo state for a track.
      void start()
      Starts playback of the MIDI data in the currently loaded sequence.
      void startRecording()
      Starts recording and playback of MIDI data.
      void stop()
      Stops recording, if active, and playback of the currently loaded sequence, if any.
      void stopRecording()
      Stops recording, if active.

      • 方法 - 继承于接口 javax.sound.midi.MidiDevice

        close, getDeviceInfo, getMaxReceivers, getMaxTransmitters, getReceiver, getReceivers, getTransmitter, getTransmitters, isOpen, open

    • 字段详细信息

      • LOOP_CONTINUOUSLY

        static final int LOOP_CONTINUOUSLY
        A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.
        从以下版本开始：
        1.5
        另请参见：
        setLoopCount(int), Constant Field Values

    • 方法详细信息

      • setSequence

        void setSequence(Sequence sequence)
                 throws InvalidMidiDataException
        Sets the current sequence on which the sequencer operates.

        This method can be called even if the Sequencer is closed.

        参数：
        sequence - the sequence to be loaded.
        抛出：
        InvalidMidiDataException - if the sequence contains invalid MIDI data, or is not supported.

      • setSequence

        void setSequence(InputStream stream)
                 throws IOException,
                        InvalidMidiDataException
        Sets the current sequence on which the sequencer operates. The stream must point to MIDI file data.

        This method can be called even if the Sequencer is closed.

        参数：
        stream - stream containing MIDI file data.
        抛出：
        IOException - if an I/O exception occurs during reading of the stream.
        InvalidMidiDataException - if invalid data is encountered in the stream, or the stream is not supported.

      • getSequence

        Sequence getSequence()
        Obtains the sequence on which the Sequencer is currently operating.

        This method can be called even if the Sequencer is closed.

        返回：
        the current sequence, or null if no sequence is currently set.

      • start

        void start()
        Starts playback of the MIDI data in the currently loaded sequence. Playback will begin from the current position. If the playback position reaches the loop end point, and the loop count is greater than 0, playback will resume at the loop start point for the number of repetitions set with setLoopCount. After that, or if the loop count is 0, playback will continue to play to the end of the sequence.

        The implementation ensures that the synthesizer is brought to a consistent state when jumping to the loop start point by sending appropriate controllers, pitch bend, and program change events.

        抛出：
        IllegalStateException - if the Sequencer is closed.
        另请参见：
        setLoopStartPoint(long), setLoopEndPoint(long), setLoopCount(int), stop()

      • stop

        void stop()
        Stops recording, if active, and playback of the currently loaded sequence, if any.
        抛出：
        IllegalStateException - if the Sequencer is closed.
        另请参见：
        start(), isRunning()

      • isRunning

        boolean isRunning()
        Indicates whether the Sequencer is currently running. The default is false. The Sequencer starts running when either start() or startRecording() is called. isRunning then returns true until playback of the sequence completes or stop() is called.
        返回：
        true if the Sequencer is running, otherwise false

      • startRecording

        void startRecording()
        Starts recording and playback of MIDI data. Data is recorded to all enabled tracks, on the channel(s) for which they were enabled. Recording begins at the current position of the sequencer. Any events already in the track are overwritten for the duration of the recording session. Events from the currently loaded sequence, if any, are delivered to the sequencer's transmitter(s) along with messages received during recording.

        Note that tracks are not by default enabled for recording. In order to record MIDI data, at least one track must be specifically enabled for recording.

        抛出：
        IllegalStateException - if the Sequencer is closed.
        另请参见：
        startRecording(),
recordEnable(javax.sound.midi.Track, int),
recordDisable(javax.sound.midi.Track)

      • stopRecording

        void stopRecording()
        Stops recording, if active. Playback of the current sequence continues.
        抛出：
        IllegalStateException - if the Sequencer is closed.
        另请参见：
        startRecording(), isRecording()

      • isRecording

        boolean isRecording()
        Indicates whether the Sequencer is currently recording. The default is false. The Sequencer begins recording when startRecording() is called, and then returns true until stop() or stopRecording() is called.
        返回：
        true if the Sequencer is recording, otherwise false

      • recordEnable

        void recordEnable(Track track,
                int channel)
        Prepares the specified track for recording events received on a particular channel. Once enabled, a track will receive events when recording is active.
        参数：
        track - the track to which events will be recorded
        channel - the channel on which events will be received. If -1 is specified for the channel value, the track will receive data from all channels.
        抛出：
        IllegalArgumentException - thrown if the track is not part of the current sequence.

      • recordDisable

        void recordDisable(Track track)
        Disables recording to the specified track. Events will no longer be recorded into this track.
        参数：
        track - the track to disable for recording, or null to disable recording for all tracks.

      • getTempoInBPM

        float getTempoInBPM()
        Obtains the current tempo, expressed in beats per minute. The actual tempo of playback is the product of the returned value and the tempo factor.
        返回：
        the current tempo in beats per minute
        另请参见：
        getTempoFactor(), setTempoInBPM(float), getTempoInMPQ()

      • setTempoInBPM

        void setTempoInBPM(float bpm)
        Sets the tempo in beats per minute. The actual tempo of playback is the product of the specified value and the tempo factor.
        参数：
        bpm - desired new tempo in beats per minute
        另请参见：
        getTempoFactor(), setTempoInMPQ(float), getTempoInBPM()

      • getTempoInMPQ

        float getTempoInMPQ()
        Obtains the current tempo, expressed in microseconds per quarter note. The actual tempo of playback is the product of the returned value and the tempo factor.
        返回：
        the current tempo in microseconds per quarter note
        另请参见：
        getTempoFactor(), setTempoInMPQ(float), getTempoInBPM()

      • setTempoInMPQ

        void setTempoInMPQ(float mpq)
        Sets the tempo in microseconds per quarter note. The actual tempo of playback is the product of the specified value and the tempo factor.
        参数：
        mpq - desired new tempo in microseconds per quarter note.
        另请参见：
        getTempoFactor(), setTempoInBPM(float), getTempoInMPQ()

      • setTempoFactor

        void setTempoFactor(float factor)
        Scales the sequencer's actual playback tempo by the factor provided. The default is 1.0. A value of 1.0 represents the natural rate (the tempo specified in the sequence), 2.0 means twice as fast, etc. The tempo factor does not affect the values returned by getTempoInMPQ() and getTempoInBPM(). Those values indicate the tempo prior to scaling.

        Note that the tempo factor cannot be adjusted when external synchronization is used. In that situation, setTempoFactor always sets the tempo factor to 1.0.

        参数：
        factor - the requested tempo scalar
        另请参见：
        getTempoFactor()

      • getTempoFactor

        float getTempoFactor()
        Returns the current tempo factor for the sequencer. The default is 1.0.
        返回：
        tempo factor.
        另请参见：
        setTempoFactor(float)

      • getTickLength

        long getTickLength()
        Obtains the length of the current sequence, expressed in MIDI ticks, or 0 if no sequence is set.
        返回：
        length of the sequence in ticks

      • getTickPosition

        long getTickPosition()
        Obtains the current position in the sequence, expressed in MIDI ticks. (The duration of a tick in seconds is determined both by the tempo and by the timing resolution stored in the Sequence.)
        返回：
        current tick
        另请参见：
        setTickPosition(long)

      • setTickPosition

        void setTickPosition(long tick)
        Sets the current sequencer position in MIDI ticks
        参数：
        tick - the desired tick position
        另请参见：
        getTickPosition()

      • getMicrosecondLength

        long getMicrosecondLength()
        Obtains the length of the current sequence, expressed in microseconds, or 0 if no sequence is set.
        返回：
        length of the sequence in microseconds.

      • getMicrosecondPosition

        long getMicrosecondPosition()
        Obtains the current position in the sequence, expressed in microseconds.
        指定者：
        getMicrosecondPosition in interface MidiDevice
        返回：
        the current position in microseconds
        另请参见：
        setMicrosecondPosition(long)

      • setMicrosecondPosition

        void setMicrosecondPosition(long microseconds)
        Sets the current position in the sequence, expressed in microseconds
        参数：
        microseconds - desired position in microseconds
        另请参见：
        getMicrosecondPosition()

      • setMasterSyncMode

        void setMasterSyncMode(Sequencer.SyncMode sync)
        Sets the source of timing information used by this sequencer. The sequencer synchronizes to the master, which is the internal clock, MIDI clock, or MIDI time code, depending on the value of sync. The sync argument must be one of the supported modes, as returned by getMasterSyncModes().
        参数：
        sync - the desired master synchronization mode
        另请参见：
        Sequencer.SyncMode.INTERNAL_CLOCK, Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, getMasterSyncMode()

      • getMasterSyncMode

        Sequencer.SyncMode getMasterSyncMode()
        Obtains the current master synchronization mode for this sequencer.
        返回：
        the current master synchronization mode
        另请参见：
        setMasterSyncMode(Sequencer.SyncMode), getMasterSyncModes()

      • getMasterSyncModes

        Sequencer.SyncMode[] getMasterSyncModes()
        Obtains the set of master synchronization modes supported by this sequencer.
        返回：
        the available master synchronization modes
        另请参见：
        Sequencer.SyncMode.INTERNAL_CLOCK, Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, getMasterSyncMode(), setMasterSyncMode(Sequencer.SyncMode)

      • setSlaveSyncMode

        void setSlaveSyncMode(Sequencer.SyncMode sync)
        Sets the slave synchronization mode for the sequencer. This indicates the type of timing information sent by the sequencer to its receiver. The sync argument must be one of the supported modes, as returned by getSlaveSyncModes().
        参数：
        sync - the desired slave synchronization mode
        另请参见：
        Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, Sequencer.SyncMode.NO_SYNC, getSlaveSyncModes()

      • getSlaveSyncMode

        Sequencer.SyncMode getSlaveSyncMode()
        Obtains the current slave synchronization mode for this sequencer.
        返回：
        the current slave synchronization mode
        另请参见：
        setSlaveSyncMode(Sequencer.SyncMode), getSlaveSyncModes()

      • getSlaveSyncModes

        Sequencer.SyncMode[] getSlaveSyncModes()
        Obtains the set of slave synchronization modes supported by the sequencer.
        返回：
        the available slave synchronization modes
        另请参见：
        Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, Sequencer.SyncMode.NO_SYNC

      • setTrackMute

        void setTrackMute(int track,
                boolean mute)
        Sets the mute state for a track. This method may fail for a number of reasons. For example, the track number specified may not be valid for the current sequence, or the sequencer may not support this functionality. An application which needs to verify whether this operation succeeded should follow this call with a call to getTrackMute(int).
        参数：
        track - the track number. Tracks in the current sequence are numbered from 0 to the number of tracks in the sequence minus 1.
        mute - the new mute state for the track. true implies the track should be muted, false implies the track should be unmuted.
        另请参见：
        getSequence()

      • getTrackMute

        boolean getTrackMute(int track)
        Obtains the current mute state for a track. The default mute state for all tracks which have not been muted is false. In any case where the specified track has not been muted, this method should return false. This applies if the sequencer does not support muting of tracks, and if the specified track index is not valid.
        参数：
        track - the track number. Tracks in the current sequence are numbered from 0 to the number of tracks in the sequence minus 1.
        返回：
        true if muted, false if not.

      • setTrackSolo

        void setTrackSolo(int track,
                boolean solo)
        Sets the solo state for a track. If solo is true only this track and other solo'd tracks will sound. If solo is false then only other solo'd tracks will sound, unless no tracks are solo'd in which case all un-muted tracks will sound.

        This method may fail for a number of reasons. For example, the track number specified may not be valid for the current sequence, or the sequencer may not support this functionality. An application which needs to verify whether this operation succeeded should follow this call with a call to getTrackSolo(int).

        参数：
        track - the track number. Tracks in the current sequence are numbered from 0 to the number of tracks in the sequence minus 1.
        solo - the new solo state for the track. true implies the track should be solo'd, false implies the track should not be solo'd.
        另请参见：
        getSequence()

      • getTrackSolo

        boolean getTrackSolo(int track)
        Obtains the current solo state for a track. The default mute state for all tracks which have not been solo'd is false. In any case where the specified track has not been solo'd, this method should return false. This applies if the sequencer does not support soloing of tracks, and if the specified track index is not valid.
        参数：
        track - the track number. Tracks in the current sequence are numbered from 0 to the number of tracks in the sequence minus 1.
        返回：
        true if solo'd, false if not.

      • addMetaEventListener

        boolean addMetaEventListener(MetaEventListener listener)
        Registers a meta-event listener to receive notification whenever a meta-event is encountered in the sequence and processed by the sequencer. This method can fail if, for instance,this class of sequencer does not support meta-event notification.
        参数：
        listener - listener to add
        返回：
        true if the listener was successfully added, otherwise false
        另请参见：
        removeMetaEventListener(javax.sound.midi.MetaEventListener), MetaEventListener, MetaMessage

      • removeMetaEventListener

        void removeMetaEventListener(MetaEventListener listener)
        Removes the specified meta-event listener from this sequencer's list of registered listeners, if in fact the listener is registered.
        参数：
        listener - the meta-event listener to remove
        另请参见：
        addMetaEventListener(javax.sound.midi.MetaEventListener)

      • addControllerEventListener

        int[] addControllerEventListener(ControllerEventListener listener,
                               int[] controllers)
        Registers a controller event listener to receive notification whenever the sequencer processes a control-change event of the requested type or types. The types are specified by the controllers argument, which should contain an array of MIDI controller numbers. (Each number should be between 0 and 127, inclusive. See the MIDI 1.0 Specification for the numbers that correspond to various types of controllers.)

        The returned array contains the MIDI controller numbers for which the listener will now receive events. Some sequencers might not support controller event notification, in which case the array has a length of 0. Other sequencers might support notification for some controllers but not all. This method may be invoked repeatedly. Each time, the returned array indicates all the controllers that the listener will be notified about, not only the controllers requested in that particular invocation.

        参数：
        listener - the controller event listener to add to the list of registered listeners
        controllers - the MIDI controller numbers for which change notification is requested
        返回：
        the numbers of all the MIDI controllers whose changes will now be reported to the specified listener
        另请参见：
        removeControllerEventListener(javax.sound.midi.ControllerEventListener, int[]), ControllerEventListener

      • removeControllerEventListener

        int[] removeControllerEventListener(ControllerEventListener listener,
                                  int[] controllers)
        Removes a controller event listener's interest in one or more types of controller event. The controllers argument is an array of MIDI numbers corresponding to the controllers for which the listener should no longer receive change notifications. To completely remove this listener from the list of registered listeners, pass in null for controllers. The returned array contains the MIDI controller numbers for which the listener will now receive events. The array has a length of 0 if the listener will not receive change notifications for any controllers.
        参数：
        listener - old listener
        controllers - the MIDI controller numbers for which change notification should be cancelled, or null to cancel for all controllers
        返回：
        the numbers of all the MIDI controllers whose changes will now be reported to the specified listener
        另请参见：
        addControllerEventListener(javax.sound.midi.ControllerEventListener, int[])

      • setLoopStartPoint

        void setLoopStartPoint(long tick)
        Sets the first MIDI tick that will be played in the loop. If the loop count is greater than 0, playback will jump to this point when reaching the loop end point.

        A value of 0 for the starting point means the beginning of the loaded sequence. The starting point must be lower than or equal to the ending point, and it must fall within the size of the loaded sequence.

        A sequencer's loop start point defaults to start of the sequence.

        参数：
        tick - the loop's starting position, in MIDI ticks (zero-based)
        抛出：
        IllegalArgumentException - if the requested loop start point cannot be set, usually because it falls outside the sequence's duration or because the start point is after the end point
        从以下版本开始：
        1.5
        另请参见：
        setLoopEndPoint(long), setLoopCount(int), getLoopStartPoint(), start()

      • getLoopStartPoint

        long getLoopStartPoint()
        Obtains the start position of the loop, in MIDI ticks.
        返回：
        the start position of the loop, in MIDI ticks (zero-based)
        从以下版本开始：
        1.5
        另请参见：
        setLoopStartPoint(long)

      • setLoopEndPoint

        void setLoopEndPoint(long tick)
        Sets the last MIDI tick that will be played in the loop. If the loop count is 0, the loop end point has no effect and playback continues to play when reaching the loop end point.

        A value of -1 for the ending point indicates the last tick of the sequence. Otherwise, the ending point must be greater than or equal to the starting point, and it must fall within the size of the loaded sequence.

        A sequencer's loop end point defaults to -1, meaning the end of the sequence.

        参数：
        tick - the loop's ending position, in MIDI ticks (zero-based), or -1 to indicate the final tick
        抛出：
        IllegalArgumentException - if the requested loop point cannot be set, usually because it falls outside the sequence's duration or because the ending point is before the starting point
        从以下版本开始：
        1.5
        另请参见：
        setLoopStartPoint(long), setLoopCount(int), getLoopEndPoint(), start()

      • getLoopEndPoint

        long getLoopEndPoint()
        Obtains the end position of the loop, in MIDI ticks.
        返回：
        the end position of the loop, in MIDI ticks (zero-based), or -1 to indicate the end of the sequence
        从以下版本开始：
        1.5
        另请参见：
        setLoopEndPoint(long)

      • setLoopCount

        void setLoopCount(int count)
        Sets the number of repetitions of the loop for playback. When the playback position reaches the loop end point, it will loop back to the loop start point count times, after which playback will continue to play to the end of the sequence.

        If the current position when this method is invoked is greater than the loop end point, playback continues to the end of the sequence without looping, unless the loop end point is changed subsequently.

        A count value of 0 disables looping: playback will continue at the loop end point, and it will not loop back to the loop start point. This is a sequencer's default.

        If playback is stopped during looping, the current loop status is cleared; subsequent start requests are not affected by an interrupted loop operation.

        参数：
        count - the number of times playback should loop back from the loop's end position to the loop's start position, or LOOP_CONTINUOUSLY to indicate that looping should continue until interrupted
        抛出：
        IllegalArgumentException - if count is negative and not equal to LOOP_CONTINUOUSLY
        从以下版本开始：
        1.5
        另请参见：
        setLoopStartPoint(long), setLoopEndPoint(long), getLoopCount(), start()

      • getLoopCount

        int getLoopCount()
        Obtains the number of repetitions for playback.
        返回：
        the number of loops after which playback plays to the end of the sequence
        从以下版本开始：
        1.5
        另请参见：
        setLoopCount(int), start()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Sequencer.SyncMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 Sequencer.SyncMode

  • java.lang.Object
    • javax.sound.midi.Sequencer.SyncMode
  • Enclosing interface:
    Sequencer

    public static class Sequencer.SyncMode
extends Object
    A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device. If the sequencer is being synchronized to a master, the sequencer revises its current time in response to messages from the master. If the sequencer has a slave, the sequencer similarly sends messages to control the slave's timing.

    There are three predefined modes that specify possible masters for a sequencer: INTERNAL_CLOCK, MIDI_SYNC, and MIDI_TIME_CODE. The latter two work if the sequencer receives MIDI messages from another device. In these two modes, the sequencer's time gets reset based on system real-time timing clock messages or MIDI time code (MTC) messages, respectively. These two modes can also be used as slave modes, in which case the sequencer sends the corresponding types of MIDI messages to its receiver (whether or not the sequencer is also receiving them from a master). A fourth mode, NO_SYNC, is used to indicate that the sequencer should not control its receiver's timing.

    另请参见：
    Sequencer.setMasterSyncMode(Sequencer.SyncMode), Sequencer.setSlaveSyncMode(Sequencer.SyncMode)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Sequencer.SyncMode INTERNAL_CLOCK
      A master synchronization mode that makes the sequencer get its timing information from its internal clock.
      static Sequencer.SyncMode MIDI_SYNC
      A master or slave synchronization mode that specifies the use of MIDI clock messages.
      static Sequencer.SyncMode MIDI_TIME_CODE
      A master or slave synchronization mode that specifies the use of MIDI Time Code.
      static Sequencer.SyncMode NO_SYNC
      A slave synchronization mode indicating that no timing information should be sent to the receiver.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Sequencer.SyncMode(String name)
      Constructs a synchronization mode.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Determines whether two objects are equal.
      int hashCode()
      Finalizes the hashcode method.
      String toString()
      Provides this synchronization mode's name as the string representation of the mode.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INTERNAL_CLOCK

        public static final Sequencer.SyncMode INTERNAL_CLOCK
        A master synchronization mode that makes the sequencer get its timing information from its internal clock. This is not a legal slave sync mode.

      • MIDI_SYNC

        public static final Sequencer.SyncMode MIDI_SYNC
        A master or slave synchronization mode that specifies the use of MIDI clock messages. If this mode is used as the master sync mode, the sequencer gets its timing information from system real-time MIDI clock messages. This mode only applies as the master sync mode for sequencers that are also MIDI receivers. If this is the slave sync mode, the sequencer sends system real-time MIDI clock messages to its receiver. MIDI clock messages are sent at a rate of 24 per quarter note.

      • MIDI_TIME_CODE

        public static final Sequencer.SyncMode MIDI_TIME_CODE
        A master or slave synchronization mode that specifies the use of MIDI Time Code. If this mode is used as the master sync mode, the sequencer gets its timing information from MIDI Time Code messages. This mode only applies as the master sync mode to sequencers that are also MIDI receivers. If this mode is used as the slave sync mode, the sequencer sends MIDI Time Code messages to its receiver. (See the MIDI 1.0 Detailed Specification for a description of MIDI Time Code.)

      • NO_SYNC

        public static final Sequencer.SyncMode NO_SYNC
        A slave synchronization mode indicating that no timing information should be sent to the receiver. This is not a legal master sync mode.

    • 构造方法详细信息

      • Sequencer.SyncMode

        protected Sequencer.SyncMode(String name)
        Constructs a synchronization mode.
        参数：
        name - name of the synchronization mode

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Determines whether two objects are equal. Returns true if the objects are identical
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare
        返回：
        true if this object is the same as the obj argument, false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashcode method.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides this synchronization mode's name as the string representation of the mode.
        重载：
        toString in class Object
        返回：
        the name of this synchronization mode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.c/hn>sg>sl/r tllrsrt > >>deilno


ShortMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 ShortMessage

  • java.lang.Object
    • javax.sound.midi.MidiMessage
      • javax.sound.midi.ShortMessage
  • 所有已实现的接口：
    Cloneable

    public class ShortMessage
extends MidiMessage
    A ShortMessage contains a MIDI message that has at most two data bytes following its status byte. The types of MIDI message that satisfy this criterion are channel voice, channel mode, system common, and system real-time--in other words, everything except system exclusive and meta-events. The ShortMessage class provides methods for getting and setting the contents of the MIDI message.

    A number of ShortMessage methods have integer parameters by which you specify a MIDI status or data byte. If you know the numeric value, you can express it directly. For system common and system real-time messages, you can often use the corresponding fields of ShortMessage, such as SYSTEM_RESET. For channel messages, the upper four bits of the status byte are specified by a command value and the lower four bits are specified by a MIDI channel number. To convert incoming MIDI data bytes that are in the form of Java's signed bytes, you can use the conversion code given in the MidiMessage class description.

    另请参见：
    SysexMessage, MetaMessage

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ACTIVE_SENSING
      Status byte for Active Sensing message (0xFE, or 254).
      static int CHANNEL_PRESSURE
      Command value for Channel Pressure (Aftertouch) message (0xD0, or 208)
      static int CONTINUE
      Status byte for Continue message (0xFB, or 251).
      static int CONTROL_CHANGE
      Command value for Control Change message (0xB0, or 176)
      static int END_OF_EXCLUSIVE
      Status byte for End of System Exclusive message (0xF7, or 247).
      static int MIDI_TIME_CODE
      Status byte for MIDI Time Code Quarter Frame message (0xF1, or 241).
      static int NOTE_OFF
      Command value for Note Off message (0x80, or 128)
      static int NOTE_ON
      Command value for Note On message (0x90, or 144)
      static int PITCH_BEND
      Command value for Pitch Bend message (0xE0, or 224)
      static int POLY_PRESSURE
      Command value for Polyphonic Key Pressure (Aftertouch) message (0xA0, or 160)
      static int PROGRAM_CHANGE
      Command value for Program Change message (0xC0, or 192)
      static int SONG_POSITION_POINTER
      Status byte for Song Position Pointer message (0xF2, or 242).
      static int SONG_SELECT
      Status byte for MIDI Song Select message (0xF3, or 243).
      static int START
      Status byte for Start message (0xFA, or 250).
      static int STOP
      Status byte for Stop message (0xFC, or 252).
      static int SYSTEM_RESET
      Status byte for System Reset message (0xFF, or 255).
      static int TIMING_CLOCK
      Status byte for Timing Clock messagem (0xF8, or 248).
      static int TUNE_REQUEST
      Status byte for Tune Request message (0xF6, or 246).

      • Fields inherited from class javax.sound.midi.MidiMessage

        data, length

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        ShortMessage()
      Constructs a new ShortMessage.
      protected ShortMessage(byte[] data)
      Constructs a new ShortMessage.
        ShortMessage(int status)
      Constructs a new ShortMessage which represents a MIDI message that takes no data bytes.
        ShortMessage(int status, int data1, int data2)
      Constructs a new ShortMessage which represents a MIDI message that takes up to two data bytes.
        ShortMessage(int command, int channel, int data1, int data2)
      Constructs a new ShortMessage which represents a channel MIDI message that takes up to two data bytes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a new object of the same class and with the same contents as this object.
      int getChannel()
      Obtains the MIDI channel associated with this event.
      int getCommand()
      Obtains the MIDI command associated with this event.
      int getData1()
      Obtains the first data byte in the message.
      int getData2()
      Obtains the second data byte in the message.
      protected int getDataLength(int status)
      Retrieves the number of data bytes associated with a particular status byte value.
      void setMessage(int status)
      Sets the parameters for a MIDI message that takes no data bytes.
      void setMessage(int status, int data1, int data2)
      Sets the parameters for a MIDI message that takes one or two data bytes.
      void setMessage(int command, int channel, int data1, int data2)
      Sets the short message parameters for a channel message which takes up to two data bytes.

      • 方法 - 继承于类 javax.sound.midi.MidiMessage

        getLength, getMessage, getStatus, setMessage

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • MIDI_TIME_CODE

        public static final int MIDI_TIME_CODE
        Status byte for MIDI Time Code Quarter Frame message (0xF1, or 241).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • SONG_POSITION_POINTER

        public static final int SONG_POSITION_POINTER
        Status byte for Song Position Pointer message (0xF2, or 242).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • SONG_SELECT

        public static final int SONG_SELECT
        Status byte for MIDI Song Select message (0xF3, or 243).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • TUNE_REQUEST

        public static final int TUNE_REQUEST
        Status byte for Tune Request message (0xF6, or 246).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • END_OF_EXCLUSIVE

        public static final int END_OF_EXCLUSIVE
        Status byte for End of System Exclusive message (0xF7, or 247).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • TIMING_CLOCK

        public static final int TIMING_CLOCK
        Status byte for Timing Clock messagem (0xF8, or 248).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • START

        public static final int START
        Status byte for Start message (0xFA, or 250).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • CONTINUE

        public static final int CONTINUE
        Status byte for Continue message (0xFB, or 251).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • STOP

        public static final int STOP
        Status byte for Stop message (0xFC, or 252).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • ACTIVE_SENSING

        public static final int ACTIVE_SENSING
        Status byte for Active Sensing message (0xFE, or 254).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • SYSTEM_RESET

        public static final int SYSTEM_RESET
        Status byte for System Reset message (0xFF, or 255).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • NOTE_OFF

        public static final int NOTE_OFF
        Command value for Note Off message (0x80, or 128)
        另请参见：
        Constant Field Values

      • NOTE_ON

        public static final int NOTE_ON
        Command value for Note On message (0x90, or 144)
        另请参见：
        Constant Field Values

      • POLY_PRESSURE

        public static final int POLY_PRESSURE
        Command value for Polyphonic Key Pressure (Aftertouch) message (0xA0, or 160)
        另请参见：
        Constant Field Values

      • CONTROL_CHANGE

        public static final int CONTROL_CHANGE
        Command value for Control Change message (0xB0, or 176)
        另请参见：
        Constant Field Values

      • PROGRAM_CHANGE

        public static final int PROGRAM_CHANGE
        Command value for Program Change message (0xC0, or 192)
        另请参见：
        Constant Field Values

      • CHANNEL_PRESSURE

        public static final int CHANNEL_PRESSURE
        Command value for Channel Pressure (Aftertouch) message (0xD0, or 208)
        另请参见：
        Constant Field Values

      • PITCH_BEND

        public static final int PITCH_BEND
        Command value for Pitch Bend message (0xE0, or 224)
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ShortMessage

        public ShortMessage()
        Constructs a new ShortMessage. The contents of the new message are guaranteed to specify a valid MIDI message. Subsequently, you may set the contents of the message using one of the setMessage methods.
        另请参见：
        setMessage(int)

      • ShortMessage

        public ShortMessage(int status)
             throws InvalidMidiDataException
        Constructs a new ShortMessage which represents a MIDI message that takes no data bytes. The contents of the message can be changed by using one of the setMessage methods.
        参数：
        status - the MIDI status byte
        抛出：
        InvalidMidiDataException - if status does not specify a valid MIDI status byte for a message that requires no data bytes
        从以下版本开始：
        1.7
        另请参见：
        setMessage(int),
setMessage(int, int, int),
setMessage(int, int, int, int),
MidiMessage.getStatus()

      • ShortMessage

        public ShortMessage(int status,
            int data1,
            int data2)
             throws InvalidMidiDataException
        Constructs a new ShortMessage which represents a MIDI message that takes up to two data bytes. If the message only takes one data byte, the second data byte is ignored. If the message does not take any data bytes, both data bytes are ignored. The contents of the message can be changed by using one of the setMessage methods.
        参数：
        status - the MIDI status byte
        data1 - the first data byte
        data2 - the second data byte
        抛出：
        InvalidMidiDataException - if the status byte or all data bytes belonging to the message do not specify a valid MIDI message
        从以下版本开始：
        1.7
        另请参见：
        setMessage(int),
setMessage(int, int, int),
setMessage(int, int, int, int),
MidiMessage.getStatus(),
getData1(),
getData2()

      • ShortMessage

        public ShortMessage(int command,
            int channel,
            int data1,
            int data2)
             throws InvalidMidiDataException
        Constructs a new ShortMessage which represents a channel MIDI message that takes up to two data bytes. If the message only takes one data byte, the second data byte is ignored. If the message does not take any data bytes, both data bytes are ignored. The contents of the message can be changed by using one of the setMessage methods.
        参数：
        command - the MIDI command represented by this message
        channel - the channel associated with the message
        data1 - the first data byte
        data2 - the second data byte
        抛出：
        InvalidMidiDataException - if the command value, channel value or all data bytes belonging to the message do not specify a valid MIDI message
        从以下版本开始：
        1.7
        另请参见：
        setMessage(int),
setMessage(int, int, int),
setMessage(int, int, int, int),
getCommand(),
getChannel(),
getData1(),
getData2()

      • ShortMessage

        protected ShortMessage(byte[] data)
        Constructs a new ShortMessage.
        参数：
        data - an array of bytes containing the complete message. The message data may be changed using the setMessage method.
        另请参见：
        setMessage(int)

    • 方法详细信息

      • setMessage

        public void setMessage(int status)
                throws InvalidMidiDataException
        Sets the parameters for a MIDI message that takes no data bytes.
        参数：
        status - the MIDI status byte
        抛出：
        InvalidMidiDataException - if status does not specify a valid MIDI status byte for a message that requires no data bytes.
        InvalidMidiDataException
        另请参见：
        setMessage(int, int, int), setMessage(int, int, int, int)

      • setMessage

        public void setMessage(int status,
              int data1,
              int data2)
                throws InvalidMidiDataException
        Sets the parameters for a MIDI message that takes one or two data bytes. If the message takes only one data byte, the second data byte is ignored; if the message does not take any data bytes, both data bytes are ignored.
        参数：
        status - the MIDI status byte
        data1 - the first data byte
        data2 - the second data byte
        抛出：
        InvalidMidiDataException - if the the status byte, or all data bytes belonging to the message, do not specify a valid MIDI message.
        InvalidMidiDataException
        另请参见：
        setMessage(int, int, int, int), setMessage(int)

      • setMessage

        public void setMessage(int command,
              int channel,
              int data1,
              int data2)
                throws InvalidMidiDataException
        Sets the short message parameters for a channel message which takes up to two data bytes. If the message only takes one data byte, the second data byte is ignored; if the message does not take any data bytes, both data bytes are ignored.
        参数：
        command - the MIDI command represented by this message
        channel - the channel associated with the message
        data1 - the first data byte
        data2 - the second data byte
        抛出：
        InvalidMidiDataException - if the status byte or all data bytes belonging to the message, do not specify a valid MIDI message
        InvalidMidiDataException
        另请参见：
        setMessage(int, int, int),
setMessage(int),
getCommand(),
getChannel(),
getData1(),
getData2()

      • getChannel

        public int getChannel()
        Obtains the MIDI channel associated with this event. This method assumes that the event is a MIDI channel message; if not, the return value will not be meaningful.
        返回：
        MIDI channel associated with the message.
        另请参见：
        setMessage(int, int, int, int)

      • getCommand

        public int getCommand()
        Obtains the MIDI command associated with this event. This method assumes that the event is a MIDI channel message; if not, the return value will not be meaningful.
        另请参见：
        setMessage(int, int, int, int)

      • getData1

        public int getData1()
        Obtains the first data byte in the message.
        返回：
        the value of the data1 field
        另请参见：
        setMessage(int, int, int)

      • getData2

        public int getData2()
        Obtains the second data byte in the message.
        返回：
        the value of the data2 field
        另请参见：
        setMessage(int, int, int)

      • clone

        public Object clone()
        Creates a new object of the same class and with the same contents as this object.
        指定者：
        clone in class MidiMessage
        返回：
        a clone of this instance.
        另请参见：
        Cloneable

      • getDataLength

        protected final int getDataLength(int status)
                           throws InvalidMidiDataException
        Retrieves the number of data bytes associated with a particular status byte value.
        参数：
        status - status byte value, which must represent a short MIDI message
        返回：
        data length in bytes (0, 1, or 2)
        抛出：
        InvalidMidiDataException - if the status argument does not represent the status byte for any short message
        InvalidMidiDataException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Soundbank

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface Soundbank

  • public interface Soundbank
    A Soundbank contains a set of Instruments that can be loaded into a Synthesizer. Note that a Java Sound Soundbank is different from a MIDI bank. MIDI permits up to 16383 banks, each containing up to 128 instruments (also sometimes called programs, patches, or timbres). However, a Soundbank can contain 16383 times 128 instruments, because the instruments within a Soundbank are indexed by both a MIDI program number and a MIDI bank number (via a Patch object). Thus, a Soundbank can be thought of as a collection of MIDI banks.

    Soundbank includes methods that return String objects containing the sound bank's name, manufacturer, version number, and description. The precise content and format of these strings is left to the implementor.

    Different synthesizers use a variety of synthesis techniques. A common one is wavetable synthesis, in which a segment of recorded sound is played back, often with looping and pitch change. The Downloadable Sound (DLS) format uses segments of recorded sound, as does the Headspace Engine. Soundbanks and Instruments that are based on wavetable synthesis (or other uses of stored sound recordings) should typically implement the getResources() method to provide access to these recorded segments. This is optional, however; the method can return an zero-length array if the synthesis technique doesn't use sampled sound (FM synthesis and physical modeling are examples of such techniques), or if it does but the implementor chooses not to make the samples accessible.

    另请参见：
    Synthesizer.getDefaultSoundbank(), Synthesizer.isSoundbankSupported(javax.sound.midi.Soundbank), Synthesizer.loadInstruments(Soundbank, Patch[]), Patch, Instrument, SoundbankResource

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDescription()
      Obtains a textual description of the sound bank, suitable for display.
      Instrument getInstrument(Patch patch)
      Obtains an Instrument from the given Patch.
      Instrument[] getInstruments()
      Obtains a list of instruments contained in this sound bank.
      String getName()
      Obtains the name of the sound bank.
      SoundbankResource[] getResources()
      Extracts a list of non-Instrument resources contained in the sound bank.
      String getVendor()
      Obtains a string naming the company that provides the sound bank
      String getVersion()
      Obtains the version string for the sound bank.

    • 方法详细信息

      • getName

        String getName()
        Obtains the name of the sound bank.
        返回：
        a String naming the sound bank

      • getVersion

        String getVersion()
        Obtains the version string for the sound bank.
        返回：
        a String that indicates the sound bank's version

      • getVendor

        String getVendor()
        Obtains a string naming the company that provides the sound bank
        返回：
        the vendor string

      • getDescription

        String getDescription()
        Obtains a textual description of the sound bank, suitable for display.
        返回：
        a String that describes the sound bank

      • getResources

        SoundbankResource[] getResources()
        Extracts a list of non-Instrument resources contained in the sound bank.
        返回：
        an array of resources, exclusing instruments. If the sound bank contains no resources (other than instruments), returns an array of length 0.

      • getInstruments

        Instrument[] getInstruments()
        Obtains a list of instruments contained in this sound bank.
        返回：
        an array of the Instruments in this SoundBank If the sound bank contains no instruments, returns an array of length 0.
        另请参见：
        Synthesizer.getLoadedInstruments(), getInstrument(Patch)

      • getInstrument

        Instrument getInstrument(Patch patch)
        Obtains an Instrument from the given Patch.
        参数：
        patch - a Patch object specifying the bank index and program change number
        返回：
        the requested instrument, or null if the sound bank doesn't contain that instrument
        另请参见：
        getInstruments(), Synthesizer.loadInstruments(Soundbank, Patch[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hsitsonsonaddnaa tccseirog)e //>a


SoundbankResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 SoundbankResource

  • java.lang.Object
    • javax.sound.midi.SoundbankResource
  • 直接已知子类：
    Instrument

    public abstract class SoundbankResource
extends Object
    A SoundbankResource represents any audio resource stored in a Soundbank. Common soundbank resources include:
    • Instruments. An instrument may be specified in a variety of ways. However, all soundbanks have some mechanism for defining instruments. In doing so, they may reference other resources stored in the soundbank. Each instrument has a Patch which specifies the MIDI program and bank by which it may be referenced in MIDI messages. Instrument information may be stored in Instrument objects.
    • Audio samples. A sample typically is a sampled audio waveform which contains a short sound recording whose duration is a fraction of a second, or at most a few seconds. These audio samples may be used by a Synthesizer to synthesize sound in response to MIDI commands, or extracted for use by an application. (The terminology reflects musicians' use of the word "sample" to refer collectively to a series of contiguous audio samples or frames, rather than to a single, instantaneous sample.) The data class for an audio sample will be an object that encapsulates the audio sample data itself and information about how to interpret it (the format of the audio data), such as an AudioInputStream.
    • Embedded sequences. A sound bank may contain built-in song data stored in a data object such as a Sequence.

    Synthesizers that use wavetable synthesis or related techniques play back the audio in a sample when synthesizing notes, often when emulating the real-world instrument that was originally recorded. However, there is not necessarily a one-to-one correspondence between the Instruments and samples in a Soundbank. A single Instrument can use multiple SoundbankResources (typically for notes of dissimilar pitch or brightness). Also, more than one Instrument can use the same sample.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SoundbankResource(Soundbank soundBank, String name, 类<?> dataClass)
      Constructs a new SoundbankResource from the given sound bank and wavetable index.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Object getData()
      Obtains the sampled audio that is stored in this SoundbankResource.
      类<?> getDataClass()
      Obtains the class used by this sample to represent its data.
      String getName()
      Obtains the name of the resource.
      Soundbank getSoundbank()
      Obtains the sound bank that contains this SoundbankResource.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SoundbankResource

        protected SoundbankResource(Soundbank soundBank,
                 String name,
                 类<?> dataClass)
        Constructs a new SoundbankResource from the given sound bank and wavetable index. (Setting the SoundbankResource's name, sampled audio data, and instruments is a subclass responsibility.)
        参数：
        soundBank - the sound bank containing this SoundbankResource
        name - the name of the sample
        dataClass - the class used to represent the sample's data
        另请参见：
        getSoundbank(),
getName(),
getDataClass(),
getData()

    • 方法详细信息

      • getSoundbank

        public Soundbank getSoundbank()
        Obtains the sound bank that contains this SoundbankResource.
        返回：
        the sound bank in which this SoundbankResource is stored

      • getName

        public String getName()
        Obtains the name of the resource. This should generally be a string descriptive of the resource.
        返回：
        the instrument's name

      • getDataClass

        public 类<?> getDataClass()
        Obtains the class used by this sample to represent its data. The object returned by getData will be of this class. If this SoundbankResource object does not support direct access to its data, returns null.
        返回：
        the class used to represent the sample's data, or null if the data is not accessible

      • getData

        public abstract Object getData()
        Obtains the sampled audio that is stored in this SoundbankResource. The type of object returned depends on the implementation of the concrete class, and may be queried using getDataClass.
        返回：
        an object containing the sampled audio data
        另请参见：
        getDataClass()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"i.le =as si srn >


Synthesizer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface Synthesizer

  • All Superinterfaces:
    AutoCloseable, MidiDevice

    public interface Synthesizer
extends MidiDevice
    A Synthesizer generates sound. This usually happens when one of the Synthesizer's MidiChannel objects receives a noteOn message, either directly or via the Synthesizer object. Many Synthesizers support Receivers, through which MIDI events can be delivered to the Synthesizer. In such cases, the Synthesizer typically responds by sending a corresponding message to the appropriate MidiChannel, or by processing the event itself if the event isn't one of the MIDI channel messages.

    The Synthesizer interface includes methods for loading and unloading instruments from soundbanks. An instrument is a specification for synthesizing a certain type of sound, whether that sound emulates a traditional instrument or is some kind of sound effect or other imaginary sound. A soundbank is a collection of instruments, organized by bank and program number (via the instrument's Patch object). Different Synthesizer classes might implement different sound-synthesis techniques, meaning that some instruments and not others might be compatible with a given synthesizer. Also, synthesizers may have a limited amount of memory for instruments, meaning that not every soundbank and instrument can be used by every synthesizer, even if the synthesis technique is compatible. To see whether the instruments from a certain soundbank can be played by a given synthesizer, invoke the isSoundbankSupported method of Synthesizer.

    "Loading" an instrument means that that instrument becomes available for synthesizing notes. The instrument is loaded into the bank and program location specified by its Patch object. Loading does not necessarily mean that subsequently played notes will immediately have the sound of this newly loaded instrument. For the instrument to play notes, one of the synthesizer's MidiChannel objects must receive (or have received) a program-change message that causes that particular instrument's bank and program number to be selected.

    另请参见：
    MidiSystem.getSynthesizer(), Soundbank, Instrument, MidiChannel.programChange(int, int), Receiver, Transmitter, MidiDevice

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.sound.midi.MidiDevice

        MidiDevice.Info

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Instrument[] getAvailableInstruments()
      Obtains a list of instruments that come with the synthesizer.
      MidiChannel[] getChannels()
      Obtains the set of MIDI channels controlled by this synthesizer.
      Soundbank getDefaultSoundbank()
      Obtains the default soundbank for the synthesizer, if one exists.
      long getLatency()
      Obtains the processing latency incurred by this synthesizer, expressed in microseconds.
      Instrument[] getLoadedInstruments()
      Obtains a list of the instruments that are currently loaded onto this Synthesizer.
      int getMaxPolyphony()
      Obtains the maximum number of notes that this synthesizer can sound simultaneously.
      VoiceStatus[] getVoiceStatus()
      Obtains the current status of the voices produced by this synthesizer.
      boolean isSoundbankSupported(Soundbank soundbank)
      Informs the caller whether this synthesizer is capable of loading instruments from the specified soundbank.
      boolean loadAllInstruments(Soundbank soundbank)
      Loads onto the Synthesizer all instruments contained in the specified Soundbank.
      boolean loadInstrument(Instrument instrument)
      Makes a particular instrument available for synthesis.
      boolean loadInstruments(Soundbank soundbank, Patch[] patchList)
      Loads the instruments referenced by the specified patches, from the specified Soundbank.
      boolean remapInstrument(Instrument from, Instrument to)
      Remaps an instrument.
      void unloadAllInstruments(Soundbank soundbank)
      Unloads all instruments contained in the specified Soundbank.
      void unloadInstrument(Instrument instrument)
      Unloads a particular instrument.
      void unloadInstruments(Soundbank soundbank, Patch[] patchList)
      Unloads the instruments referenced by the specified patches, from the MIDI sound bank specified.

      • 方法 - 继承于接口 javax.sound.midi.MidiDevice

        close, getDeviceInfo, getMaxReceivers, getMaxTransmitters, getMicrosecondPosition, getReceiver, getReceivers, getTransmitter, getTransmitters, isOpen, open

    • 方法详细信息

      • getMaxPolyphony

        int getMaxPolyphony()
        Obtains the maximum number of notes that this synthesizer can sound simultaneously.
        返回：
        the maximum number of simultaneous notes
        另请参见：
        getVoiceStatus()

      • getLatency

        long getLatency()
        Obtains the processing latency incurred by this synthesizer, expressed in microseconds. This latency measures the worst-case delay between the time a MIDI message is delivered to the synthesizer and the time that the synthesizer actually produces the corresponding result.

        Although the latency is expressed in microseconds, a synthesizer's actual measured delay may vary over a wider range than this resolution suggests. For example, a synthesizer might have a worst-case delay of a few milliseconds or more.

        返回：
        the worst-case delay, in microseconds

      • getChannels

        MidiChannel[] getChannels()
        Obtains the set of MIDI channels controlled by this synthesizer. Each non-null element in the returned array is a MidiChannel that receives the MIDI messages sent on that channel number.

        The MIDI 1.0 specification provides for 16 channels, so this method returns an array of at least 16 elements. However, if this synthesizer doesn't make use of all 16 channels, some of the elements of the array might be null, so you should check each element before using it.

        返回：
        an array of the MidiChannel objects managed by this Synthesizer. Some of the array elements may be null.

      • getVoiceStatus

        VoiceStatus[] getVoiceStatus()
        Obtains the current status of the voices produced by this synthesizer. If this class of Synthesizer does not provide voice information, the returned array will always be of length 0. Otherwise, its length is always equal to the total number of voices, as returned by getMaxPolyphony(). (See the VoiceStatus class description for an explanation of synthesizer voices.)
        返回：
        an array of VoiceStatus objects that supply information about the corresponding synthesizer voices
        另请参见：
        getMaxPolyphony(), VoiceStatus

      • isSoundbankSupported

        boolean isSoundbankSupported(Soundbank soundbank)
        Informs the caller whether this synthesizer is capable of loading instruments from the specified soundbank. If the soundbank is unsupported, any attempts to load instruments from it will result in an IllegalArgumentException.
        参数：
        soundbank - soundbank for which support is queried
        返回：
        true if the soundbank is supported, otherwise false
        另请参见：
        loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
unloadAllInstruments(javax.sound.midi.Soundbank),
getDefaultSoundbank()

      • loadInstrument

        boolean loadInstrument(Instrument instrument)
        Makes a particular instrument available for synthesis. This instrument is loaded into the patch location specified by its Patch object, so that if a program-change message is received (or has been received) that causes that patch to be selected, subsequent notes will be played using the sound of instrument. If the specified instrument is already loaded, this method does nothing and returns true.

        The instrument must be part of a soundbank that this Synthesizer supports. (To make sure, you can use the getSoundbank method of Instrument and the isSoundbankSupported method of Synthesizer.)

        参数：
        instrument - instrument to load
        返回：
        true if the instrument is successfully loaded (or already had been), false if the instrument could not be loaded (for example, if the synthesizer has insufficient memory to load it)
        抛出：
        IllegalArgumentException - if this Synthesizer doesn't support the specified instrument's soundbank
        另请参见：
        unloadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank),
remapInstrument(javax.sound.midi.Instrument, javax.sound.midi.Instrument),
SoundbankResource.getSoundbank(),
MidiChannel.programChange(int, int)

      • unloadInstrument

        void unloadInstrument(Instrument instrument)
        Unloads a particular instrument.
        参数：
        instrument - instrument to unload
        抛出：
        IllegalArgumentException - if this Synthesizer doesn't support the specified instrument's soundbank
        另请参见：
        loadInstrument(javax.sound.midi.Instrument),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
unloadAllInstruments(javax.sound.midi.Soundbank),
getLoadedInstruments(),
remapInstrument(javax.sound.midi.Instrument, javax.sound.midi.Instrument)

      • remapInstrument

        boolean remapInstrument(Instrument from,
                      Instrument to)
        Remaps an instrument. Instrument to takes the place of instrument from.
        For example, if from was located at bank number 2, program number 11, remapping causes that bank and program location to be occupied instead by to.
        If the function succeeds, instrument from is unloaded.

        To cancel the remapping reload instrument from by invoking one of loadInstrument(javax.sound.midi.Instrument), loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]) or loadAllInstruments(javax.sound.midi.Soundbank).

        参数：
        from - the Instrument object to be replaced
        to - the Instrument object to be used in place of the old instrument, it should be loaded into the synthesizer
        返回：
        true if the instrument succeessfully remapped, false if feature is not implemented by synthesizer
        抛出：
        IllegalArgumentException - if instrument from or instrument to aren't supported by synthesizer or if instrument to is not loaded
        NullPointerException - if from or to parameters have null value
        另请参见：
        loadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank)

      • getDefaultSoundbank

        Soundbank getDefaultSoundbank()
        Obtains the default soundbank for the synthesizer, if one exists. (Some synthesizers provide a default or built-in soundbank.) If a synthesizer doesn't have a default soundbank, instruments must be loaded explicitly from an external soundbank.
        返回：
        default soundbank, or null if one does not exist.
        另请参见：
        isSoundbankSupported(javax.sound.midi.Soundbank)

      • getAvailableInstruments

        Instrument[] getAvailableInstruments()
        Obtains a list of instruments that come with the synthesizer. These instruments might be built into the synthesizer, or they might be part of a default soundbank provided with the synthesizer, etc.

        Note that you don't use this method to find out which instruments are currently loaded onto the synthesizer; for that purpose, you use getLoadedInstruments(). Nor does the method indicate all the instruments that can be loaded onto the synthesizer; it only indicates the subset that come with the synthesizer. To learn whether another instrument can be loaded, you can invoke isSoundbankSupported(), and if the instrument's Soundbank is supported, you can try loading the instrument.

        返回：
        list of available instruments. If the synthesizer has no instruments coming with it, an array of length 0 is returned.
        另请参见：
        getLoadedInstruments(), isSoundbankSupported(Soundbank), loadInstrument(javax.sound.midi.Instrument)

      • getLoadedInstruments

        Instrument[] getLoadedInstruments()
        Obtains a list of the instruments that are currently loaded onto this Synthesizer.
        返回：
        a list of currently loaded instruments
        另请参见：
        loadInstrument(javax.sound.midi.Instrument),
getAvailableInstruments(),
Soundbank.getInstruments()

      • loadAllInstruments

        boolean loadAllInstruments(Soundbank soundbank)
        Loads onto the Synthesizer all instruments contained in the specified Soundbank.
        参数：
        soundbank - the Soundbank whose are instruments are to be loaded
        返回：
        true if the instruments are all successfully loaded (or already had been), false if any instrument could not be loaded (for example, if the Synthesizer had insufficient memory)
        抛出：
        IllegalArgumentException - if the requested soundbank is incompatible with this synthesizer.
        另请参见：
        isSoundbankSupported(javax.sound.midi.Soundbank),
loadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])

      • unloadAllInstruments

        void unloadAllInstruments(Soundbank soundbank)
        Unloads all instruments contained in the specified Soundbank.
        参数：
        soundbank - soundbank containing instruments to unload
        抛出：
        IllegalArgumentException - thrown if the soundbank is not supported.
        另请参见：
        isSoundbankSupported(javax.sound.midi.Soundbank),
unloadInstrument(javax.sound.midi.Instrument),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])

      • loadInstruments

        boolean loadInstruments(Soundbank soundbank,
                      Patch[] patchList)
        Loads the instruments referenced by the specified patches, from the specified Soundbank. Each of the Patch objects indicates a bank and program number; the Instrument that has the matching Patch is loaded into that bank and program location.
        参数：
        soundbank - the Soundbank containing the instruments to load
        patchList - list of patches for which instruments should be loaded
        返回：
        true if the instruments are all successfully loaded (or already had been), false if any instrument could not be loaded (for example, if the Synthesizer had insufficient memory)
        抛出：
        IllegalArgumentException - thrown if the soundbank is not supported.
        另请参见：
        isSoundbankSupported(javax.sound.midi.Soundbank),
Instrument.getPatch(),
loadAllInstruments(javax.sound.midi.Soundbank),
loadInstrument(javax.sound.midi.Instrument),
Soundbank.getInstrument(Patch),
Sequence.getPatchList()

      • unloadInstruments

        void unloadInstruments(Soundbank soundbank,
                     Patch[] patchList)
        Unloads the instruments referenced by the specified patches, from the MIDI sound bank specified.
        参数：
        soundbank - soundbank containing instruments to unload
        patchList - list of patches for which instruments should be unloaded
        抛出：
        IllegalArgumentException - thrown if the soundbank is not supported.
        另请参见：
        unloadInstrument(javax.sound.midi.Instrument),
unloadAllInstruments(javax.sound.midi.Soundbank),
isSoundbankSupported(javax.sound.midi.Soundbank),
Instrument.getPatch(),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SysexMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi

类 SysexMessage

  • java.lang.Object
    • javax.sound.midi.MidiMessage
      • javax.sound.midi.SysexMessage
  • 所有已实现的接口：
    Cloneable

    public class SysexMessage
extends MidiMessage
    A SysexMessage object represents a MIDI system exclusive message.

    When a system exclusive message is read from a MIDI file, it always has a defined length. Data from a system exclusive message from a MIDI file should be stored in the data array of a SysexMessage as follows: the system exclusive message status byte (0xF0 or 0xF7), all message data bytes, and finally the end-of-exclusive flag (0xF7). The length reported by the SysexMessage object is therefore the length of the system exclusive data plus two: one byte for the status byte and one for the end-of-exclusive flag.

    As dictated by the Standard MIDI Files specification, two status byte values are legal for a SysexMessage read from a MIDI file:

    • 0xF0: System Exclusive message (same as in MIDI wire protocol)
    • 0xF7: Special System Exclusive message

    When Java Sound is used to handle system exclusive data that is being received using MIDI wire protocol, it should place the data in one or more SysexMessages. In this case, the length of the system exclusive data is not known in advance; the end of the system exclusive data is marked by an end-of-exclusive flag (0xF7) in the MIDI wire byte stream.

    • 0xF0: System Exclusive message (same as in MIDI wire protocol)
    • 0xF7: End of Exclusive (EOX)
    The first SysexMessage object containing data for a particular system exclusive message should have the status value 0xF0. If this message contains all the system exclusive data for the message, it should end with the status byte 0xF7 (EOX). Otherwise, additional system exclusive data should be sent in one or more SysexMessages with a status value of 0xF7. The SysexMessage containing the last of the data for the system exclusive message should end with the value 0xF7 (EOX) to mark the end of the system exclusive message.

    If system exclusive data from SysexMessages objects is being transmitted using MIDI wire protocol, only the initial 0xF0 status byte, the system exclusive data itself, and the final 0xF7 (EOX) byte should be propagated; any 0xF7 status bytes used to indicate that a SysexMessage contains continuing system exclusive data should not be propagated via MIDI wire protocol.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int SPECIAL_SYSTEM_EXCLUSIVE
      Status byte for Special System Exclusive message (0xF7, or 247), which is used in MIDI files.
      static int SYSTEM_EXCLUSIVE
      Status byte for System Exclusive message (0xF0, or 240).

      • Fields inherited from class javax.sound.midi.MidiMessage

        data, length

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        SysexMessage()
      Constructs a new SysexMessage.
      protected SysexMessage(byte[] data)
      Constructs a new SysexMessage.
        SysexMessage(byte[] data, int length)
      Constructs a new SysexMessage and sets the data for the message.
        SysexMessage(int status, byte[] data, int length)
      Constructs a new SysexMessage and sets the data for the message.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a new object of the same class and with the same contents as this object.
      byte[] getData()
      Obtains a copy of the data for the system exclusive message.
      void setMessage(byte[] data, int length)
      Sets the data for the system exclusive message.
      void setMessage(int status, byte[] data, int length)
      Sets the data for the system exclusive message.

      • 方法 - 继承于类 javax.sound.midi.MidiMessage

        getLength, getMessage, getStatus

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SYSTEM_EXCLUSIVE

        public static final int SYSTEM_EXCLUSIVE
        Status byte for System Exclusive message (0xF0, or 240).
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

      • SPECIAL_SYSTEM_EXCLUSIVE

        public static final int SPECIAL_SYSTEM_EXCLUSIVE
        Status byte for Special System Exclusive message (0xF7, or 247), which is used in MIDI files. It has the same value as END_OF_EXCLUSIVE, which is used in the real-time "MIDI wire" protocol.
        另请参见：
        MidiMessage.getStatus(), Constant Field Values

    • 构造方法详细信息

      • SysexMessage

        public SysexMessage()
        Constructs a new SysexMessage. The contents of the new message are guaranteed to specify a valid MIDI message. Subsequently, you may set the contents of the message using one of the setMessage methods.
        另请参见：
        setMessage(byte[], int)

      • SysexMessage

        public SysexMessage(byte[] data,
            int length)
             throws InvalidMidiDataException
        Constructs a new SysexMessage and sets the data for the message. The first byte of the data array must be a valid system exclusive status byte (0xF0 or 0xF7). The contents of the message can be changed by using one of the setMessage methods.
        参数：
        data - the system exclusive message data including the status byte
        length - the length of the valid message data in the array, including the status byte; it should be non-negative and less than or equal to data.length
        抛出：
        InvalidMidiDataException - if the parameter values do not specify a valid MIDI meta message.
        从以下版本开始：
        1.7
        另请参见：
        setMessage(byte[], int),
setMessage(int, byte[], int),
getData()

      • SysexMessage

        public SysexMessage(int status,
            byte[] data,
            int length)
             throws InvalidMidiDataException
        Constructs a new SysexMessage and sets the data for the message. The contents of the message can be changed by using one of the setMessage methods.
        参数：
        status - the status byte for the message; it must be a valid system exclusive status byte (0xF0 or 0xF7)
        data - the system exclusive message data (without the status byte)
        length - the length of the valid message data in the array; it should be non-negative and less than or equal to data.length
        抛出：
        InvalidMidiDataException - if the parameter values do not specify a valid MIDI meta message.
        从以下版本开始：
        1.7
        另请参见：
        setMessage(byte[], int),
setMessage(int, byte[], int),
getData()

      • SysexMessage

        protected SysexMessage(byte[] data)
        Constructs a new SysexMessage.
        参数：
        data - an array of bytes containing the complete message. The message data may be changed using the setMessage method.
        另请参见：
        setMessage(byte[], int)

    • 方法详细信息

      • setMessage

        public void setMessage(byte[] data,
              int length)
                throws InvalidMidiDataException
        Sets the data for the system exclusive message. The first byte of the data array must be a valid system exclusive status byte (0xF0 or 0xF7).
        重载：
        setMessage in class MidiMessage
        参数：
        data - the system exclusive message data
        length - the length of the valid message data in the array, including the status byte.
        抛出：
        InvalidMidiDataException

      • setMessage

        public void setMessage(int status,
              byte[] data,
              int length)
                throws InvalidMidiDataException
        Sets the data for the system exclusive message.
        参数：
        status - the status byte for the message (0xF0 or 0xF7)
        data - the system exclusive message data
        length - the length of the valid message data in the array
        抛出：
        InvalidMidiDataException

      • getData

        public byte[] getData()
        Obtains a copy of the data for the system exclusive message. The returned array of bytes does not include the status byte.
        返回：
        array containing the system exclusive message data.

      • clone

        public Object clone()
        Creates a new object of the same class and with the same contents as this object.
        指定者：
        clone in class MidiMessage
        返回：
        a clone of this instance
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=t",e


Track

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

类 Track

  • java.lang.Object
    • javax.sound.midi.Track

  • public class Track
extends Object
    A MIDI track is an independent stream of MIDI events (time-stamped MIDI data) that can be stored along with other tracks in a standard MIDI file. The MIDI specification allows only 16 channels of MIDI data, but tracks are a way to get around this limitation. A MIDI file can contain any number of tracks, each containing its own stream of up to 16 channels of MIDI data.

    A Track occupies a middle level in the hierarchy of data played by a Sequencer: sequencers play sequences, which contain tracks, which contain MIDI events. A sequencer may provide controls that mute or solo individual tracks.

    The timing information and resolution for a track is controlled by and stored in the sequence containing the track. A given Track is considered to belong to the particular Sequence that maintains its timing. For this reason, a new (empty) track is created by calling the Sequence.createTrack() method, rather than by directly invoking a Track constructor.

    The Track class provides methods to edit the track by adding or removing MidiEvent objects from it. These operations keep the event list in the correct time order. Methods are also included to obtain the track's size, in terms of either the number of events it contains or its duration in ticks.

    另请参见：
    Sequencer.setTrackMute(int, boolean), Sequencer.setTrackSolo(int, boolean)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean add(MidiEvent event)
      Adds a new event to the track.
      MidiEvent get(int index)
      Obtains the event at the specified index.
      boolean remove(MidiEvent event)
      Removes the specified event from the track.
      int size()
      Obtains the number of events in this track.
      long ticks()
      Obtains the length of the track, expressed in MIDI ticks.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • add

        public boolean add(MidiEvent event)
        Adds a new event to the track. However, if the event is already contained in the track, it is not added again. The list of events is kept in time order, meaning that this event inserted at the appropriate place in the list, not necessarily at the end.
        参数：
        event - the event to add
        返回：
        true if the event did not already exist in the track and was added, otherwise false

      • remove

        public boolean remove(MidiEvent event)
        Removes the specified event from the track.
        参数：
        event - the event to remove
        返回：
        true if the event existed in the track and was removed, otherwise false

      • get

        public MidiEvent get(int index)
              throws ArrayIndexOutOfBoundsException
        Obtains the event at the specified index.
        参数：
        index - the location of the desired event in the event vector
        抛出：
        ArrayIndexOutOfBoundsException - if the specified index is negative or not less than the current size of this track.
        ArrayIndexOutOfBoundsException
        另请参见：
        size()

      • size

        public int size()
        Obtains the number of events in this track.
        返回：
        the size of the track's event vector

      • ticks

        public long ticks()
        Obtains the length of the track, expressed in MIDI ticks. (The duration of a tick in seconds is determined by the timing resolution of the Sequence containing this track, and also by the tempo of the music as set by the sequencer.)
        返回：
        the duration, in ticks
        另请参见：
        Sequence.Sequence(float, int),
Sequencer.setTempoInBPM(float),
Sequencer.getTickPosition()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

saaot",)",] ,]]bMaanocs""nnx/vvf>o.(


Transmitter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.midi

Interface Transmitter

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    MidiDeviceTransmitter

    public interface Transmitter
extends AutoCloseable
    A Transmitter sends MidiEvent objects to one or more Receivers. Common MIDI transmitters include sequencers and MIDI input ports.
    另请参见：
    Receiver

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Indicates that the application has finished using the transmitter, and that limited resources it requires may be released or made available.
      Receiver getReceiver()
      Obtains the current receiver to which this transmitter will deliver MIDI messages.
      void setReceiver(Receiver receiver)
      Sets the receiver to which this transmitter will deliver MIDI messages.

    • 方法详细信息

      • setReceiver

        void setReceiver(Receiver receiver)
        Sets the receiver to which this transmitter will deliver MIDI messages. If a receiver is currently set, it is replaced with this one.
        参数：
        receiver - the desired receiver.

      • getReceiver

        Receiver getReceiver()
        Obtains the current receiver to which this transmitter will deliver MIDI messages.
        返回：
        the current receiver. If no receiver is currently set, returns null

      • close

        void close()
        Indicates that the application has finished using the transmitter, and that limited resources it requires may be released or made available.

        If the creation of this Transmitter resulted in implicitly opening the underlying device, the device is implicitly closed by this method. This is true unless the device is kept open by other Receiver or Transmitter instances that opened the device implicitly, and unless the device has been opened explicitly. If the device this Transmitter is retrieved from is closed explicitly by calling MidiDevice.close, the Transmitter is closed, too. For a detailed description of open/close behaviour see the class description of MidiDevice.

        指定者：
        close in interface AutoCloseable
        另请参见：
        MidiSystem.getTransmitter()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tLh>>v /vi>bp


Uses of Package javax.sound.midi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sound.midi

  • Packages that use javax.sound.midi
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.
  • Classes in javax.sound.midi used by javax.sound.midi
    类与描述
    ControllerEventListener
    The ControllerEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a requested type of MIDI control-change event.
    Instrument
    An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect.
    InvalidMidiDataException
    An InvalidMidiDataException indicates that inappropriate MIDI data was encountered.
    MetaEventListener
    The MetaEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a MetaMessage.
    MetaMessage
    A MetaMessage is a MidiMessage that is not meaningful to synthesizers, but that can be stored in a MIDI file and interpreted by a sequencer program.
    MidiChannel
    A MidiChannel object represents a single MIDI channel.
    MidiDevice
    MidiDevice is the base interface for all MIDI devices.
    MidiDevice.Info
    A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.
    MidiEvent
    MIDI events contain a MIDI message and a corresponding time-stamp expressed in ticks, and can represent the MIDI event information stored in a MIDI file or a Sequence object.
    MidiFileFormat
    A MidiFileFormat object encapsulates a MIDI file's type, as well as its length and timing information.
    MidiMessage
    MidiMessage is the base class for MIDI messages.
    MidiUnavailableException
    A MidiUnavailableException is thrown when a requested MIDI component cannot be opened or created because it is unavailable.
    Patch
    A Patch object represents a location, on a MIDI synthesizer, into which a single instrument is stored (loaded).
    Receiver
    A Receiver receives MidiEvent objects and typically does something useful in response, such as interpreting them to generate sound or raw MIDI output.
    Sequence
    A Sequence is a data structure containing musical information (often an entire song or composition) that can be played back by a Sequencer object.
    Sequencer
    A hardware or software device that plays back a MIDI sequence is known as a sequencer.
    Sequencer.SyncMode
    A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device.
    ShortMessage
    A ShortMessage contains a MIDI message that has at most two data bytes following its status byte.
    Soundbank
    A Soundbank contains a set of Instruments that can be loaded into a Synthesizer.
    SoundbankResource
    A SoundbankResource represents any audio resource stored in a Soundbank.
    Synthesizer
    A Synthesizer generates sound.
    Track
    A MIDI track is an independent stream of MIDI events (time-stamped MIDI data) that can be stored along with other tracks in a standard MIDI file.
    Transmitter
    A Transmitter sends MidiEvent objects to one or more Receivers.
    VoiceStatus
    A VoiceStatus object contains information about the current status of one of the voices produced by a Synthesizer.
  • Classes in javax.sound.midi used by javax.sound.midi.spi
    类与描述
    InvalidMidiDataException
    An InvalidMidiDataException indicates that inappropriate MIDI data was encountered.
    MidiDevice
    MidiDevice is the base interface for all MIDI devices.
    MidiDevice.Info
    A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.
    MidiFileFormat
    A MidiFileFormat object encapsulates a MIDI file's type, as well as its length and timing information.
    Sequence
    A Sequence is a data structure containing musical information (often an entire song or composition) that can be played back by a Sequencer object.
    Soundbank
    A Soundbank contains a set of Instruments that can be loaded into a Synthesizer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fn=olo >>>t>or�"o >>>r=


VoiceStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.midi

类 VoiceStatus

  • java.lang.Object
    • javax.sound.midi.VoiceStatus

  • public class VoiceStatus
extends Object
    A VoiceStatus object contains information about the current status of one of the voices produced by a Synthesizer.

    MIDI synthesizers are generally capable of producing some maximum number of simultaneous notes, also referred to as voices. A voice is a stream of successive single notes, and the process of assigning incoming MIDI notes to specific voices is known as voice allocation. However, the voice-allocation algorithm and the contents of each voice are normally internal to a MIDI synthesizer and hidden from outside view. One can, of course, learn from MIDI messages which notes the synthesizer is playing, and one might be able deduce something about the assignment of notes to voices. But MIDI itself does not provide a means to report which notes a synthesizer has assigned to which voice, nor even to report how many voices the synthesizer is capable of synthesizing.

    In Java Sound, however, a Synthesizer class can expose the contents of its voices through its getVoiceStatus() method. This behavior is recommended but optional; synthesizers that don't expose their voice allocation simply return a zero-length array. A Synthesizer that does report its voice status should maintain this information at all times for all of its voices, whether they are currently sounding or not. In other words, a given type of Synthesizer always has a fixed number of voices, equal to the maximum number of simultaneous notes it is capable of sounding.

    If the voice is not currently processing a MIDI note, it is considered inactive. A voice is inactive when it has been given no note-on commands, or when every note-on command received has been terminated by a corresponding note-off (or by an "all notes off" message). For example, this happens when a synthesizer capable of playing 16 simultaneous notes is told to play a four-note chord; only four voices are active in this case (assuming no earlier notes are still playing). Usually, a voice whose status is reported as active is producing audible sound, but this is not always true; it depends on the details of the instrument (that is, the synthesis algorithm) and how long the note has been going on. For example, a voice may be synthesizing the sound of a single hand-clap. Because this sound dies away so quickly, it may become inaudible before a note-off message is received. In such a situation, the voice is still considered active even though no sound is currently being produced.

    Besides its active or inactive status, the VoiceStatus class provides fields that reveal the voice's current MIDI channel, bank and program number, MIDI note number, and MIDI volume. All of these can change during the course of a voice. While the voice is inactive, each of these fields has an unspecified value, so you should check the active field first.

    另请参见：
    Synthesizer.getMaxPolyphony(), Synthesizer.getVoiceStatus()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      boolean active
      Indicates whether the voice is currently processing a MIDI note.
      int bank
      The bank number of the instrument that this voice is currently using.
      int channel
      The MIDI channel on which this voice is playing.
      int note
      The MIDI note that this voice is playing.
      int program
      The program number of the instrument that this voice is currently using.
      int volume
      The current MIDI volume level for the voice.

    • 构造方法摘要

      Constructors
      构造方法与描述
      VoiceStatus()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • active

        public boolean active
        Indicates whether the voice is currently processing a MIDI note. See the explanation of active and inactive voices.

      • channel

        public int channel
        The MIDI channel on which this voice is playing. The value is a zero-based channel number if the voice is active, or unspecified if the voice is inactive.
        另请参见：
        MidiChannel, active

      • bank

        public int bank
        The bank number of the instrument that this voice is currently using. This is a number dictated by the MIDI bank-select message; it does not refer to a SoundBank object. The value ranges from 0 to 16383 if the voice is active, and is unspecified if the voice is inactive.
        另请参见：
        Patch, Soundbank, active, MidiChannel.programChange(int, int)

      • program

        public int program
        The program number of the instrument that this voice is currently using. The value ranges from 0 to 127 if the voice is active, and is unspecified if the voice is inactive.
        另请参见：
        MidiChannel.getProgram(), Patch, active

      • note

        public int note
        The MIDI note that this voice is playing. The range for an active voice is from 0 to 127 in semitones, with 60 referring to Middle C. The value is unspecified if the voice is inactive.
        另请参见：
        MidiChannel.noteOn(int, int), active

      • volume

        public int volume
        The current MIDI volume level for the voice. The value ranges from 0 to 127 if the voice is active, and is unspecified if the voice is inactive.

        Note that this value does not necessarily reflect the instantaneous level of the sound produced by this voice; that level is the result of many contributing factors, including the current instrument and the shape of the amplitude envelope it produces.

        另请参见：
        active

    • 构造方法详细信息

      • VoiceStatus

        public VoiceStatus()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vrana/ax//.jj../hddot llvdt psass pn


Uses of Class javax.sound.midi.Instrument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.Instrument

  • Packages that use Instrument
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Instrument in javax.sound.midi

      Methods in javax.sound.midi that return Instrument
      修饰符与类型 方法与描述
      Instrument[] Synthesizer.getAvailableInstruments()
      Obtains a list of instruments that come with the synthesizer.
      Instrument Soundbank.getInstrument(Patch patch)
      Obtains an Instrument from the given Patch.
      Instrument[] Soundbank.getInstruments()
      Obtains a list of instruments contained in this sound bank.
      Instrument[] Synthesizer.getLoadedInstruments()
      Obtains a list of the instruments that are currently loaded onto this Synthesizer.
      Methods in javax.sound.midi with parameters of type Instrument
      修饰符与类型 方法与描述
      boolean Synthesizer.loadInstrument(Instrument instrument)
      Makes a particular instrument available for synthesis.
      boolean Synthesizer.remapInstrument(Instrument from, Instrument to)
      Remaps an instrument.
      void Synthesizer.unloadInstrument(Instrument instrument)
      Unloads a particular instrument.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ust bneta/


Uses of Class javax.sound.midi.InvalidMidiDataException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.InvalidMidiDataException

  • Packages that use InvalidMidiDataException
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of InvalidMidiDataException in javax.sound.midi

      Methods in javax.sound.midi that throw InvalidMidiDataException
      修饰符与类型 方法与描述
      protected int ShortMessage.getDataLength(int status)
      Retrieves the number of data bytes associated with a particular status byte value.
      static MidiFileFormat MidiSystem.getMidiFileFormat(File file)
      Obtains the MIDI file format of the specified File.
      static MidiFileFormat MidiSystem.getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the data in the specified input stream.
      static MidiFileFormat MidiSystem.getMidiFileFormat(URL url)
      Obtains the MIDI file format of the data in the specified URL.
      static Sequence MidiSystem.getSequence(File file)
      Obtains a MIDI sequence from the specified File.
      static Sequence MidiSystem.getSequence(InputStream stream)
      Obtains a MIDI sequence from the specified input stream.
      static Sequence MidiSystem.getSequence(URL url)
      Obtains a MIDI sequence from the specified URL.
      static Soundbank MidiSystem.getSoundbank(File file)
      Constructs a Soundbank by reading it from the specified File.
      static Soundbank MidiSystem.getSoundbank(InputStream stream)
      Constructs a MIDI sound bank by reading it from the specified stream.
      static Soundbank MidiSystem.getSoundbank(URL url)
      Constructs a Soundbank by reading it from the specified URL.
      void SysexMessage.setMessage(byte[] data, int length)
      Sets the data for the system exclusive message.
      protected void MidiMessage.setMessage(byte[] data, int length)
      Sets the data for the MIDI message.
      void ShortMessage.setMessage(int status)
      Sets the parameters for a MIDI message that takes no data bytes.
      void SysexMessage.setMessage(int status, byte[] data, int length)
      Sets the data for the system exclusive message.
      void MetaMessage.setMessage(int type, byte[] data, int length)
      Sets the message parameters for a MetaMessage.
      void ShortMessage.setMessage(int status, int data1, int data2)
      Sets the parameters for a MIDI message that takes one or two data bytes.
      void ShortMessage.setMessage(int command, int channel, int data1, int data2)
      Sets the short message parameters for a channel message which takes up to two data bytes.
      void Sequencer.setSequence(InputStream stream)
      Sets the current sequence on which the sequencer operates.
      void Sequencer.setSequence(Sequence sequence)
      Sets the current sequence on which the sequencer operates.
      Constructors in javax.sound.midi that throw InvalidMidiDataException
      构造方法与描述
      MetaMessage(int type, byte[] data, int length)
      Constructs a new MetaMessage and sets the message parameters.
      Sequence(float divisionType, int resolution)
      Constructs a new MIDI sequence with the specified timing division type and timing resolution.
      Sequence(float divisionType, int resolution, int numTracks)
      Constructs a new MIDI sequence with the specified timing division type, timing resolution, and number of tracks.
      ShortMessage(int status)
      Constructs a new ShortMessage which represents a MIDI message that takes no data bytes.
      ShortMessage(int status, int data1, int data2)
      Constructs a new ShortMessage which represents a MIDI message that takes up to two data bytes.
      ShortMessage(int command, int channel, int data1, int data2)
      Constructs a new ShortMessage which represents a channel MIDI message that takes up to two data bytes.
      SysexMessage(byte[] data, int length)
      Constructs a new SysexMessage and sets the data for the message.
      SysexMessage(int status, byte[] data, int length)
      Constructs a new SysexMessage and sets the data for the message.

    • Uses of InvalidMidiDataException in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that throw InvalidMidiDataException
      修饰符与类型 方法与描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(File file)
      Obtains the MIDI file format of the File provided.
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the input stream provided.
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(URL url)
      Obtains the MIDI file format of the URL provided.
      abstract Sequence MidiFileReader.getSequence(File file)
      Obtains a MIDI sequence from the File provided.
      abstract Sequence MidiFileReader.getSequence(InputStream stream)
      Obtains a MIDI sequence from the input stream provided.
      abstract Sequence MidiFileReader.getSequence(URL url)
      Obtains a MIDI sequence from the URL provided.
      abstract Soundbank SoundbankReader.getSoundbank(File file)
      Obtains a soundbank object from the File provided.
      abstract Soundbank SoundbankReader.getSoundbank(InputStream stream)
      Obtains a soundbank object from the InputStream provided.
      abstract Soundbank SoundbankReader.getSoundbank(URL url)
      Obtains a soundbank object from the URL provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eaiuif.tseO >n


Uses of Class javax.sound.midi.MetaMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MetaMessage

  • Packages that use MetaMessage
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MetaMessage in javax.sound.midi

      Methods in javax.sound.midi with parameters of type MetaMessage
      修饰符与类型 方法与描述
      void MetaEventListener.meta(MetaMessage meta)
      Invoked when a Sequencer has encountered and processed a MetaMessage in the Sequence it is processing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Snuoue/erot>omee c>= h


Uses of Class javax.sound.midi.MidiDevice.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiDevice.Info

  • Packages that use MidiDevice.Info
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of MidiDevice.Info in javax.sound.midi

      Methods in javax.sound.midi that return MidiDevice.Info
      修饰符与类型 方法与描述
      MidiDevice.Info MidiDevice.getDeviceInfo()
      Obtains information about the device, including its Java class and Strings containing its name, vendor, and description.
      static MidiDevice.Info[] MidiSystem.getMidiDeviceInfo()
      Obtains an array of information objects representing the set of all MIDI devices available on the system.
      Methods in javax.sound.midi with parameters of type MidiDevice.Info
      修饰符与类型 方法与描述
      static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
      Obtains the requested MIDI device.

    • Uses of MidiDevice.Info in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that return MidiDevice.Info
      修饰符与类型 方法与描述
      abstract MidiDevice.Info[] MidiDeviceProvider.getDeviceInfo()
      Obtains the set of info objects representing the device or devices provided by this MidiDeviceProvider.
      Methods in javax.sound.midi.spi with parameters of type MidiDevice.Info
      修饰符与类型 方法与描述
      abstract MidiDevice MidiDeviceProvider.getDevice(MidiDevice.Info info)
      Obtains an instance of the device represented by the info object.
      boolean MidiDeviceProvider.isDeviceSupported(MidiDevice.Info info)
      Indicates whether the device provider supports the device represented by the specified device info object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

islaetset "=c sa


Uses of Class javax.sound.midi.MidiEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiEvent

  • Packages that use MidiEvent
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MidiEvent in javax.sound.midi

      Methods in javax.sound.midi that return MidiEvent
      修饰符与类型 方法与描述
      MidiEvent Track.get(int index)
      Obtains the event at the specified index.
      Methods in javax.sound.midi with parameters of type MidiEvent
      修饰符与类型 方法与描述
      boolean Track.add(MidiEvent event)
      Adds a new event to the track.
      boolean Track.remove(MidiEvent event)
      Removes the specified event from the track.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.sound.midi.MidiFileFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiFileFormat

  • Packages that use MidiFileFormat
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of MidiFileFormat in javax.sound.midi

      Methods in javax.sound.midi that return MidiFileFormat
      修饰符与类型 方法与描述
      static MidiFileFormat MidiSystem.getMidiFileFormat(File file)
      Obtains the MIDI file format of the specified File.
      static MidiFileFormat MidiSystem.getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the data in the specified input stream.
      static MidiFileFormat MidiSystem.getMidiFileFormat(URL url)
      Obtains the MIDI file format of the data in the specified URL.

    • Uses of MidiFileFormat in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that return MidiFileFormat
      修饰符与类型 方法与描述
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(File file)
      Obtains the MIDI file format of the File provided.
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the input stream provided.
      abstract MidiFileFormat MidiFileReader.getMidiFileFormat(URL url)
      Obtains the MIDI file format of the URL provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ana-a>h rlo<.=ltaaa


Uses of Class javax.sound.midi.MidiMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiMessage

  • Packages that use MidiMessage
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MidiMessage in javax.sound.midi

      Subclasses of MidiMessage in javax.sound.midi
      修饰符与类型 类与描述
      class  MetaMessage
      A MetaMessage is a MidiMessage that is not meaningful to synthesizers, but that can be stored in a MIDI file and interpreted by a sequencer program.
      class  ShortMessage
      A ShortMessage contains a MIDI message that has at most two data bytes following its status byte.
      class  SysexMessage
      A SysexMessage object represents a MIDI system exclusive message.
      Methods in javax.sound.midi that return MidiMessage
      修饰符与类型 方法与描述
      MidiMessage MidiEvent.getMessage()
      Obtains the MIDI message contained in the event.
      Methods in javax.sound.midi with parameters of type MidiMessage
      修饰符与类型 方法与描述
      void Receiver.send(MidiMessage message, long timeStamp)
      Sends a MIDI message and time-stamp to this receiver.
      Constructors in javax.sound.midi with parameters of type MidiMessage
      构造方法与描述
      MidiEvent(MidiMessage message, long tick)
      Constructs a new MidiEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

httheafa


Uses of Class javax.sound.midi.MidiSystem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiSystem

No usage of javax.sound.midi.MidiSystem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<<= cl< ddddoaam/"ee


Uses of Class javax.sound.midi.MidiUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.MidiUnavailableException

  • Packages that use MidiUnavailableException
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MidiUnavailableException in javax.sound.midi

      Methods in javax.sound.midi that throw MidiUnavailableException
      修饰符与类型 方法与描述
      static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
      Obtains the requested MIDI device.
      static Receiver MidiSystem.getReceiver()
      Obtains a MIDI receiver from an external MIDI port or other default device.
      Receiver MidiDevice.getReceiver()
      Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data.
      static Sequencer MidiSystem.getSequencer()
      Obtains the default Sequencer, connected to a default device.
      static Sequencer MidiSystem.getSequencer(boolean connected)
      Obtains the default Sequencer, optionally connected to a default device.
      static Synthesizer MidiSystem.getSynthesizer()
      Obtains the default synthesizer.
      static Transmitter MidiSystem.getTransmitter()
      Obtains a MIDI transmitter from an external MIDI port or other default source.
      Transmitter MidiDevice.getTransmitter()
      Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.
      void MidiDevice.open()
      Opens the device, indicating that it should now acquire any system resources it requires and become operational.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=">0;>>>9z.d3ka＃八北藄


Uses of Class javax.sound.midi.Patch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.Patch

  • Packages that use Patch
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Patch in javax.sound.midi

      Methods in javax.sound.midi that return Patch
      修饰符与类型 方法与描述
      Patch Instrument.getPatch()
      Obtains the Patch object that indicates the bank and program numbers where this instrument is to be stored in the synthesizer.
      Patch[] Sequence.getPatchList()
      Obtains a list of patches referenced in this sequence.
      Methods in javax.sound.midi with parameters of type Patch
      修饰符与类型 方法与描述
      Instrument Soundbank.getInstrument(Patch patch)
      Obtains an Instrument from the given Patch.
      boolean Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList)
      Loads the instruments referenced by the specified patches, from the specified Soundbank.
      void Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList)
      Unloads the instruments referenced by the specified patches, from the MIDI sound bank specified.
      Constructors in javax.sound.midi with parameters of type Patch
      构造方法与描述
      Instrument(Soundbank soundbank, Patch patch, String name, 类<?> dataClass)
      Constructs a new MIDI instrument from the specified Patch.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hssm>.uel r< ptb>m/>///i


Uses of Class javax.sound.midi.Sequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.Sequence

  • Packages that use Sequence
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of Sequence in javax.sound.midi

      Methods in javax.sound.midi that return Sequence
      修饰符与类型 方法与描述
      Sequence Sequencer.getSequence()
      Obtains the sequence on which the Sequencer is currently operating.
      static Sequence MidiSystem.getSequence(File file)
      Obtains a MIDI sequence from the specified File.
      static Sequence MidiSystem.getSequence(InputStream stream)
      Obtains a MIDI sequence from the specified input stream.
      static Sequence MidiSystem.getSequence(URL url)
      Obtains a MIDI sequence from the specified URL.
      Methods in javax.sound.midi with parameters of type Sequence
      修饰符与类型 方法与描述
      static int[] MidiSystem.getMidiFileTypes(Sequence sequence)
      Obtains the set of MIDI file types that the system can write from the sequence specified.
      static boolean MidiSystem.isFileTypeSupported(int fileType, Sequence sequence)
      Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
      void Sequencer.setSequence(Sequence sequence)
      Sets the current sequence on which the sequencer operates.
      static int MidiSystem.write(Sequence in, int type, File out)
      Writes a stream of bytes representing a file of the MIDI file type indicated to the external file provided.
      static int MidiSystem.write(Sequence in, int fileType, OutputStream out)
      Writes a stream of bytes representing a file of the MIDI file type indicated to the output stream provided.

    • Uses of Sequence in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that return Sequence
      修饰符与类型 方法与描述
      abstract Sequence MidiFileReader.getSequence(File file)
      Obtains a MIDI sequence from the File provided.
      abstract Sequence MidiFileReader.getSequence(InputStream stream)
      Obtains a MIDI sequence from the input stream provided.
      abstract Sequence MidiFileReader.getSequence(URL url)
      Obtains a MIDI sequence from the URL provided.
      Methods in javax.sound.midi.spi with parameters of type Sequence
      修饰符与类型 方法与描述
      abstract int[] MidiFileWriter.getMidiFileTypes(Sequence sequence)
      Obtains the file types that this file writer can write from the sequence specified.
      boolean MidiFileWriter.isFileTypeSupported(int fileType, Sequence sequence)
      Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
      abstract int MidiFileWriter.write(Sequence in, int fileType, File out)
      Writes a stream of bytes representing a MIDI file of the file type indicated to the external file provided.
      abstract int MidiFileWriter.write(Sequence in, int fileType, OutputStream out)
      Writes a stream of bytes representing a MIDI file of the file type indicated to the output stream provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

reedpm"i dslsl-cnuad>-t


Uses of Class javax.sound.midi.Sequencer.SyncMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.Sequencer.SyncMode

  • Packages that use Sequencer.SyncMode
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Sequencer.SyncMode in javax.sound.midi

      Fields in javax.sound.midi declared as Sequencer.SyncMode
      修饰符与类型 字段与描述
      static Sequencer.SyncMode Sequencer.SyncMode.INTERNAL_CLOCK
      A master synchronization mode that makes the sequencer get its timing information from its internal clock.
      static Sequencer.SyncMode Sequencer.SyncMode.MIDI_SYNC
      A master or slave synchronization mode that specifies the use of MIDI clock messages.
      static Sequencer.SyncMode Sequencer.SyncMode.MIDI_TIME_CODE
      A master or slave synchronization mode that specifies the use of MIDI Time Code.
      static Sequencer.SyncMode Sequencer.SyncMode.NO_SYNC
      A slave synchronization mode indicating that no timing information should be sent to the receiver.
      Methods in javax.sound.midi that return Sequencer.SyncMode
      修饰符与类型 方法与描述
      Sequencer.SyncMode Sequencer.getMasterSyncMode()
      Obtains the current master synchronization mode for this sequencer.
      Sequencer.SyncMode[] Sequencer.getMasterSyncModes()
      Obtains the set of master synchronization modes supported by this sequencer.
      Sequencer.SyncMode Sequencer.getSlaveSyncMode()
      Obtains the current slave synchronization mode for this sequencer.
      Sequencer.SyncMode[] Sequencer.getSlaveSyncModes()
      Obtains the set of slave synchronization modes supported by the sequencer.
      Methods in javax.sound.midi with parameters of type Sequencer.SyncMode
      修饰符与类型 方法与描述
      void Sequencer.setMasterSyncMode(Sequencer.SyncMode sync)
      Sets the source of timing information used by this sequencer.
      void Sequencer.setSlaveSyncMode(Sequencer.SyncMode sync)
      Sets the slave synchronization mode for the sequencer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dMsj蠦"


Uses of Class javax.sound.midi.ShortMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.ShortMessage

  • Packages that use ShortMessage
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of ShortMessage in javax.sound.midi

      Methods in javax.sound.midi with parameters of type ShortMessage
      修饰符与类型 方法与描述
      void ControllerEventListener.controlChange(ShortMessage event)
      Invoked when a Sequencer has encountered and processed a control-change event of interest to this listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oen


Uses of Class javax.sound.midi.SoundbankResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.SoundbankResource

  • Packages that use SoundbankResource
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of SoundbankResource in javax.sound.midi

      Subclasses of SoundbankResource in javax.sound.midi
      修饰符与类型 类与描述
      class  Instrument
      An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect.
      Methods in javax.sound.midi that return SoundbankResource
      修饰符与类型 方法与描述
      SoundbankResource[] Soundbank.getResources()
      Extracts a list of non-Instrument resources contained in the sound bank.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sa tis re eanndn>d"b>uv<


Uses of Class javax.sound.midi.SysexMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.SysexMessage

No usage of javax.sound.midi.SysexMessage
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tom-erv..///.= -<


Uses of Class javax.sound.midi.Track

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.Track

  • Packages that use Track
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Track in javax.sound.midi

      Fields in javax.sound.midi with type parameters of type Track
      修饰符与类型 字段与描述
      protected Vector<Track> Sequence.tracks
      The MIDI tracks in this sequence.
      Methods in javax.sound.midi that return Track
      修饰符与类型 方法与描述
      Track Sequence.createTrack()
      Creates a new, initially empty track as part of this sequence.
      Track[] Sequence.getTracks()
      Obtains an array containing all the tracks in this sequence.
      Methods in javax.sound.midi with parameters of type Track
      修饰符与类型 方法与描述
      boolean Sequence.deleteTrack(Track track)
      Removes the specified track from the sequence.
      void Sequencer.recordDisable(Track track)
      Disables recording to the specified track.
      void Sequencer.recordEnable(Track track, int channel)
      Prepares the specified track for recording events received on a particular channel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0nfv"er


Uses of Class javax.sound.midi.VoiceStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.VoiceStatus

  • Packages that use VoiceStatus
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of VoiceStatus in javax.sound.midi

      Methods in javax.sound.midi that return VoiceStatus
      修饰符与类型 方法与描述
      VoiceStatus[] Synthesizer.getVoiceStatus()
      Obtains the current status of the voices produced by this synthesizer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&/l"a.u njjjeittcdr=ic"ll


Uses of Interface javax.sound.midi.ControllerEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.ControllerEventListener

  • Packages that use ControllerEventListener
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of ControllerEventListener in javax.sound.midi

      Methods in javax.sound.midi with parameters of type ControllerEventListener
      修饰符与类型 方法与描述
      int[] Sequencer.addControllerEventListener(ControllerEventListener listener, int[] controllers)
      Registers a controller event listener to receive notification whenever the sequencer processes a control-change event of the requested type or types.
      int[] Sequencer.removeControllerEventListener(ControllerEventListener listener, int[] controllers)
      Removes a controller event listener's interest in one or more types of controller event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsanp


Uses of Interface javax.sound.midi.MetaEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.MetaEventListener

  • Packages that use MetaEventListener
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MetaEventListener in javax.sound.midi

      Methods in javax.sound.midi with parameters of type MetaEventListener
      修饰符与类型 方法与描述
      boolean Sequencer.addMetaEventListener(MetaEventListener listener)
      Registers a meta-event listener to receive notification whenever a meta-event is encountered in the sequence and processed by the sequencer.
      void Sequencer.removeMetaEventListener(MetaEventListener listener)
      Removes the specified meta-event listener from this sequencer's list of registered listeners, if in fact the listener is registered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vsa.=".h rrr elle esiuiio


Uses of Interface javax.sound.midi.MidiChannel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.MidiChannel

  • Packages that use MidiChannel
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of MidiChannel in javax.sound.midi

      Methods in javax.sound.midi that return MidiChannel
      修饰符与类型 方法与描述
      MidiChannel[] Synthesizer.getChannels()
      Obtains the set of MIDI channels controlled by this synthesizer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o.ncdepedcii,hp�.懊�.档.�


Uses of Interface javax.sound.midi.MidiDevice

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.MidiDevice

  • Packages that use MidiDevice
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of MidiDevice in javax.sound.midi

      Subinterfaces of MidiDevice in javax.sound.midi
      修饰符与类型 Interface and Description
      interface  Sequencer
      A hardware or software device that plays back a MIDI sequence is known as a sequencer.
      interface  Synthesizer
      A Synthesizer generates sound.
      Methods in javax.sound.midi that return MidiDevice
      修饰符与类型 方法与描述
      MidiDevice MidiDeviceTransmitter.getMidiDevice()
      Obtains a MidiDevice object which is an owner of this Transmitter.
      MidiDevice MidiDeviceReceiver.getMidiDevice()
      Obtains a MidiDevice object which is an owner of this Receiver.
      static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
      Obtains the requested MIDI device.

    • Uses of MidiDevice in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that return MidiDevice
      修饰符与类型 方法与描述
      abstract MidiDevice MidiDeviceProvider.getDevice(MidiDevice.Info info)
      Obtains an instance of the device represented by the info object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y lrowtSs.=t/iedo.i/tei


Uses of Interface javax.sound.midi.MidiDeviceReceiver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.MidiDeviceReceiver

No usage of javax.sound.midi.MidiDeviceReceiver
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aco="rlcaaat <


Uses of Interface javax.sound.midi.MidiDeviceTransmitter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.MidiDeviceTransmitter

No usage of javax.sound.midi.MidiDeviceTransmitter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/�>


Uses of Interface javax.sound.midi.Receiver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.Receiver

  • Packages that use Receiver
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Receiver in javax.sound.midi

      Subinterfaces of Receiver in javax.sound.midi
      修饰符与类型 Interface and Description
      interface  MidiDeviceReceiver
      MidiDeviceReceiver is a Receiver which represents a MIDI input connector of a MidiDevice (see MidiDevice.getReceiver()).
      Methods in javax.sound.midi that return Receiver
      修饰符与类型 方法与描述
      static Receiver MidiSystem.getReceiver()
      Obtains a MIDI receiver from an external MIDI port or other default device.
      Receiver Transmitter.getReceiver()
      Obtains the current receiver to which this transmitter will deliver MIDI messages.
      Receiver MidiDevice.getReceiver()
      Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data.
      Methods in javax.sound.midi that return types with arguments of type Receiver
      修饰符与类型 方法与描述
      List<Receiver> MidiDevice.getReceivers()
      Returns all currently active, non-closed receivers connected with this MidiDevice.
      Methods in javax.sound.midi with parameters of type Receiver
      修饰符与类型 方法与描述
      void Transmitter.setReceiver(Receiver receiver)
      Sets the receiver to which this transmitter will deliver MIDI messages.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pp> byhyd


Uses of Interface javax.sound.midi.Sequencer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.Sequencer

  • Packages that use Sequencer
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Sequencer in javax.sound.midi

      Methods in javax.sound.midi that return Sequencer
      修饰符与类型 方法与描述
      static Sequencer MidiSystem.getSequencer()
      Obtains the default Sequencer, connected to a default device.
      static Sequencer MidiSystem.getSequencer(boolean connected)
      Obtains the default Sequencer, optionally connected to a default device.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnd.cif esssehwwsetobtn>a


Uses of Interface javax.sound.midi.Soundbank

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.Soundbank

  • Packages that use Soundbank
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
    javax.sound.midi.spi
    Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

    • Uses of Soundbank in javax.sound.midi

      Methods in javax.sound.midi that return Soundbank
      修饰符与类型 方法与描述
      Soundbank Synthesizer.getDefaultSoundbank()
      Obtains the default soundbank for the synthesizer, if one exists.
      Soundbank SoundbankResource.getSoundbank()
      Obtains the sound bank that contains this SoundbankResource.
      static Soundbank MidiSystem.getSoundbank(File file)
      Constructs a Soundbank by reading it from the specified File.
      static Soundbank MidiSystem.getSoundbank(InputStream stream)
      Constructs a MIDI sound bank by reading it from the specified stream.
      static Soundbank MidiSystem.getSoundbank(URL url)
      Constructs a Soundbank by reading it from the specified URL.
      Methods in javax.sound.midi with parameters of type Soundbank
      修饰符与类型 方法与描述
      boolean Synthesizer.isSoundbankSupported(Soundbank soundbank)
      Informs the caller whether this synthesizer is capable of loading instruments from the specified soundbank.
      boolean Synthesizer.loadAllInstruments(Soundbank soundbank)
      Loads onto the Synthesizer all instruments contained in the specified Soundbank.
      boolean Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList)
      Loads the instruments referenced by the specified patches, from the specified Soundbank.
      void Synthesizer.unloadAllInstruments(Soundbank soundbank)
      Unloads all instruments contained in the specified Soundbank.
      void Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList)
      Unloads the instruments referenced by the specified patches, from the MIDI sound bank specified.
      Constructors in javax.sound.midi with parameters of type Soundbank
      构造方法与描述
      Instrument(Soundbank soundbank, Patch patch, String name, 类<?> dataClass)
      Constructs a new MIDI instrument from the specified Patch.
      SoundbankResource(Soundbank soundBank, String name, 类<?> dataClass)
      Constructs a new SoundbankResource from the given sound bank and wavetable index.

    • Uses of Soundbank in javax.sound.midi.spi

      Methods in javax.sound.midi.spi that return Soundbank
      修饰符与类型 方法与描述
      abstract Soundbank SoundbankReader.getSoundbank(File file)
      Obtains a soundbank object from the File provided.
      abstract Soundbank SoundbankReader.getSoundbank(InputStream stream)
      Obtains a soundbank object from the InputStream provided.
      abstract Soundbank SoundbankReader.getSoundbank(URL url)
      Obtains a soundbank object from the URL provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tD c lcyhtr�>r�.╝n>


Uses of Interface javax.sound.midi.Synthesizer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.Synthesizer

  • Packages that use Synthesizer
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Synthesizer in javax.sound.midi

      Methods in javax.sound.midi that return Synthesizer
      修饰符与类型 方法与描述
      static Synthesizer MidiSystem.getSynthesizer()
      Obtains the default synthesizer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ms"_aatab_oo_sddetenumtr


Uses of Interface javax.sound.midi.Transmitter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.midi.Transmitter

  • Packages that use Transmitter
    软件包 描述
    javax.sound.midi
    Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.

    • Uses of Transmitter in javax.sound.midi

      Subinterfaces of Transmitter in javax.sound.midi
      修饰符与类型 Interface and Description
      interface  MidiDeviceTransmitter
      MidiDeviceTransmitter is a Transmitter which represents a MIDI input connector of a MidiDevice (see MidiDevice.getTransmitter()).
      Methods in javax.sound.midi that return Transmitter
      修饰符与类型 方法与描述
      static Transmitter MidiSystem.getTransmitter()
      Obtains a MIDI transmitter from an external MIDI port or other default source.
      Transmitter MidiDevice.getTransmitter()
      Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.
      Methods in javax.sound.midi that return types with arguments of type Transmitter
      修饰符与类型 方法与描述
      List<Transmitter> MidiDevice.getTransmitters()
      Returns all currently active, non-closed transmitters connected with this MidiDevice.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ai7veoes7dsdtdd詅氮鼻潜a


javax.sound.midi.spi

Classes

  • MidiDeviceProvider
  • MidiFileReader
  • MidiFileWriter
  • SoundbankReader
-


javax.sound.midi.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sound.midi.spi

Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

请参见： 描述

  • Class Summary
    类 描述
    MidiDeviceProvider
    A MidiDeviceProvider is a factory or provider for a particular type of MIDI device.
    MidiFileReader
    A MidiFileReader supplies MIDI file-reading services.
    MidiFileWriter
    A MidiFileWriter supplies MIDI file-writing services.
    SoundbankReader
    A SoundbankReader supplies soundbank file-reading services.

软件包 javax.sound.midi.spi Description

Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.

Related Documentation

For overviews, tutorials, examples, and guides, please see:
  • Sound
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ta


javax.sound.midi.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sound.midi.spi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sound.midi.spi.MidiDeviceProvider
    • javax.sound.midi.spi.MidiFileReader
    • javax.sound.midi.spi.MidiFileWriter
    • javax.sound.midi.spi.SoundbankReader
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>a>/


MidiDeviceProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi.spi

类 MidiDeviceProvider

  • java.lang.Object
    • javax.sound.midi.spi.MidiDeviceProvider

  • public abstract class MidiDeviceProvider
extends Object
    A MidiDeviceProvider is a factory or provider for a particular type of MIDI device. This mechanism allows the implementation to determine how resources are managed in the creation and management of a device.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiDeviceProvider()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract MidiDevice getDevice(MidiDevice.Info info)
      Obtains an instance of the device represented by the info object.
      abstract MidiDevice.Info[] getDeviceInfo()
      Obtains the set of info objects representing the device or devices provided by this MidiDeviceProvider.
      boolean isDeviceSupported(MidiDevice.Info info)
      Indicates whether the device provider supports the device represented by the specified device info object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MidiDeviceProvider

        public MidiDeviceProvider()

    • 方法详细信息

      • isDeviceSupported

        public boolean isDeviceSupported(MidiDevice.Info info)
        Indicates whether the device provider supports the device represented by the specified device info object.
        参数：
        info - an info object that describes the device for which support is queried
        返回：
        true if the specified device is supported, otherwise false

      • getDeviceInfo

        public abstract MidiDevice.Info[] getDeviceInfo()
        Obtains the set of info objects representing the device or devices provided by this MidiDeviceProvider.
        返回：
        set of device info objects

      • getDevice

        public abstract MidiDevice getDevice(MidiDevice.Info info)
        Obtains an instance of the device represented by the info object.
        参数：
        info - an info object that describes the desired device
        返回：
        device instance
        抛出：
        IllegalArgumentException - if the info object specified does not match the info object for a device supported by this MidiDeviceProvider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aeaebuhd/edb#anas/


MidiFileReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi.spi

类 MidiFileReader

  • java.lang.Object
    • javax.sound.midi.spi.MidiFileReader

  • public abstract class MidiFileReader
extends Object
    A MidiFileReader supplies MIDI file-reading services. Classes implementing this interface can parse the format information from one or more types of MIDI file, and can produce a Sequence object from files of these types.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiFileReader()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract MidiFileFormat getMidiFileFormat(File file)
      Obtains the MIDI file format of the File provided.
      abstract MidiFileFormat getMidiFileFormat(InputStream stream)
      Obtains the MIDI file format of the input stream provided.
      abstract MidiFileFormat getMidiFileFormat(URL url)
      Obtains the MIDI file format of the URL provided.
      abstract Sequence getSequence(File file)
      Obtains a MIDI sequence from the File provided.
      abstract Sequence getSequence(InputStream stream)
      Obtains a MIDI sequence from the input stream provided.
      abstract Sequence getSequence(URL url)
      Obtains a MIDI sequence from the URL provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MidiFileReader

        public MidiFileReader()

    • 方法详细信息

      • getMidiFileFormat

        public abstract MidiFileFormat getMidiFileFormat(InputStream stream)
                                          throws InvalidMidiDataException,
                                                 IOException
        Obtains the MIDI file format of the input stream provided. The stream must point to valid MIDI file data. In general, MIDI file readers may need to read some data from the stream before determining whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support this, this method may fail with an IOException.
        参数：
        stream - the input stream from which file format information should be extracted
        返回：
        a MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getMidiFileFormat

        public abstract MidiFileFormat getMidiFileFormat(URL url)
                                          throws InvalidMidiDataException,
                                                 IOException
        Obtains the MIDI file format of the URL provided. The URL must point to valid MIDI file data.
        参数：
        url - the URL from which file format information should be extracted
        返回：
        a MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs

      • getMidiFileFormat

        public abstract MidiFileFormat getMidiFileFormat(File file)
                                          throws InvalidMidiDataException,
                                                 IOException
        Obtains the MIDI file format of the File provided. The File must point to valid MIDI file data.
        参数：
        file - the File from which file format information should be extracted
        返回：
        a MidiFileFormat object describing the MIDI file format
        抛出：
        InvalidMidiDataException - if the File does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs

      • getSequence

        public abstract Sequence getSequence(InputStream stream)
                              throws InvalidMidiDataException,
                                     IOException
        Obtains a MIDI sequence from the input stream provided. The stream must point to valid MIDI file data. In general, MIDI file readers may need to read some data from the stream before determining whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support this, this method may fail with an IOException.
        参数：
        stream - the input stream from which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data contained in the input stream.
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getSequence

        public abstract Sequence getSequence(URL url)
                              throws InvalidMidiDataException,
                                     IOException
        Obtains a MIDI sequence from the URL provided. The URL must point to valid MIDI file data.
        参数：
        url - the URL for which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data pointed to by the URL
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs

      • getSequence

        public abstract Sequence getSequence(File file)
                              throws InvalidMidiDataException,
                                     IOException
        Obtains a MIDI sequence from the File provided. The File must point to valid MIDI file data.
        参数：
        file - the File from which the Sequence should be constructed
        返回：
        a Sequence object based on the MIDI file data pointed to by the File
        抛出：
        InvalidMidiDataException - if the File does not point to valid MIDI file data recognized by the system
        IOException - if an I/O exception occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>./sd>N<"im <萣et�"e


MidiFileWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi.spi

类 MidiFileWriter

  • java.lang.Object
    • javax.sound.midi.spi.MidiFileWriter

  • public abstract class MidiFileWriter
extends Object
    A MidiFileWriter supplies MIDI file-writing services. Classes that implement this interface can write one or more types of MIDI file from a Sequence object.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      MidiFileWriter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int[] getMidiFileTypes()
      Obtains the set of MIDI file types for which file writing support is provided by this file writer.
      abstract int[] getMidiFileTypes(Sequence sequence)
      Obtains the file types that this file writer can write from the sequence specified.
      boolean isFileTypeSupported(int fileType)
      Indicates whether file writing support for the specified MIDI file type is provided by this file writer.
      boolean isFileTypeSupported(int fileType, Sequence sequence)
      Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
      abstract int write(Sequence in, int fileType, File out)
      Writes a stream of bytes representing a MIDI file of the file type indicated to the external file provided.
      abstract int write(Sequence in, int fileType, OutputStream out)
      Writes a stream of bytes representing a MIDI file of the file type indicated to the output stream provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MidiFileWriter

        public MidiFileWriter()

    • 方法详细信息

      • getMidiFileTypes

        public abstract int[] getMidiFileTypes()
        Obtains the set of MIDI file types for which file writing support is provided by this file writer.
        返回：
        array of file types. If no file types are supported, an array of length 0 is returned.

      • getMidiFileTypes

        public abstract int[] getMidiFileTypes(Sequence sequence)
        Obtains the file types that this file writer can write from the sequence specified.
        参数：
        sequence - the sequence for which MIDI file type support is queried
        返回：
        array of file types. If no file types are supported, returns an array of length 0.

      • isFileTypeSupported

        public boolean isFileTypeSupported(int fileType)
        Indicates whether file writing support for the specified MIDI file type is provided by this file writer.
        参数：
        fileType - the file type for which write capabilities are queried
        返回：
        true if the file type is supported, otherwise false

      • isFileTypeSupported

        public boolean isFileTypeSupported(int fileType,
                          Sequence sequence)
        Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
        参数：
        fileType - the file type for which write capabilities are queried
        sequence - the sequence for which file writing support is queried
        返回：
        true if the file type is supported for this sequence, otherwise false

      • write

        public abstract int write(Sequence in,
        int fileType,
        OutputStream out)
                   throws IOException
        Writes a stream of bytes representing a MIDI file of the file type indicated to the output stream provided.
        参数：
        in - sequence containing MIDI data to be written to the file
        fileType - type of the file to be written to the output stream
        out - stream to which the file data should be written
        返回：
        the number of bytes written to the output stream
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file type is not supported by this file writer
        另请参见：
        isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)

      • write

        public abstract int write(Sequence in,
        int fileType,
        File out)
                   throws IOException
        Writes a stream of bytes representing a MIDI file of the file type indicated to the external file provided.
        参数：
        in - sequence containing MIDI data to be written to the external file
        fileType - type of the file to be written to the external file
        out - external file to which the file data should be written
        返回：
        the number of bytes written to the file
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file type is not supported by this file writer
        另请参见：
        isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"h>sjv av sii ss""cc t


SoundbankReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.midi.spi

类 SoundbankReader

  • java.lang.Object
    • javax.sound.midi.spi.SoundbankReader

  • public abstract class SoundbankReader
extends Object
    A SoundbankReader supplies soundbank file-reading services. Concrete subclasses of SoundbankReader parse a given soundbank file, producing a Soundbank object that can be loaded into a Synthesizer.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      SoundbankReader()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Soundbank getSoundbank(File file)
      Obtains a soundbank object from the File provided.
      abstract Soundbank getSoundbank(InputStream stream)
      Obtains a soundbank object from the InputStream provided.
      abstract Soundbank getSoundbank(URL url)
      Obtains a soundbank object from the URL provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SoundbankReader

        public SoundbankReader()

    • 方法详细信息

      • getSoundbank

        public abstract Soundbank getSoundbank(URL url)
                                throws InvalidMidiDataException,
                                       IOException
        Obtains a soundbank object from the URL provided.
        参数：
        url - URL representing the soundbank.
        返回：
        soundbank object
        抛出：
        InvalidMidiDataException - if the URL does not point to valid MIDI soundbank data recognized by this soundbank reader
        IOException - if an I/O error occurs

      • getSoundbank

        public abstract Soundbank getSoundbank(InputStream stream)
                                throws InvalidMidiDataException,
                                       IOException
        Obtains a soundbank object from the InputStream provided.
        参数：
        stream - InputStream representing the soundbank
        返回：
        soundbank object
        抛出：
        InvalidMidiDataException - if the stream does not point to valid MIDI soundbank data recognized by this soundbank reader
        IOException - if an I/O error occurs

      • getSoundbank

        public abstract Soundbank getSoundbank(File file)
                                throws InvalidMidiDataException,
                                       IOException
        Obtains a soundbank object from the File provided.
        参数：
        file - the File representing the soundbank
        返回：
        soundbank object
        抛出：
        InvalidMidiDataException - if the file does not point to valid MIDI soundbank data recognized by this soundbank reader
        IOException - if an I/O error occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c r u n/>d/t>idl#fto t ohei wwdh.a r


Uses of Package javax.sound.midi.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sound.midi.spi

No usage of javax.sound.midi.spi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h t-caeapkkki/??


Uses of Class javax.sound.midi.spi.MidiDeviceProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.spi.MidiDeviceProvider

No usage of javax.sound.midi.spi.MidiDeviceProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fmIe-l


Uses of Class javax.sound.midi.spi.MidiFileReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.spi.MidiFileReader

No usage of javax.sound.midi.spi.MidiFileReader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>g/s


Uses of Class javax.sound.midi.spi.MidiFileWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.spi.MidiFileWriter

No usage of javax.sound.midi.spi.MidiFileWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p"�s莫 � >g


Uses of Class javax.sound.midi.spi.SoundbankReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.midi.spi.SoundbankReader

No usage of javax.sound.midi.spi.SoundbankReader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

M< er s渆"3cn8$e


AudioFileFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 AudioFileFormat

  • java.lang.Object
    • javax.sound.sampled.AudioFileFormat

  • public class AudioFileFormat
extends Object
    An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.

    The AudioSystem class includes methods for determining the format of an audio file, obtaining an audio input stream from an audio file, and writing an audio file from an audio input stream.

    An AudioFileFormat object can include a set of properties. A property is a pair of key and value: the key is of type String, the associated property value is an arbitrary object. Properties specify additional informational meta data (like a author, copyright, or file duration). Properties are optional information, and file reader and file writer implementations are not required to provide or recognize properties.

    The following table lists some common properties that should be used in implementations:

    Property key | Value type | 描述
    "duration" | Long | playback duration of the file in microseconds
    "author" | String | name of the author of this file
    "title" | String | title of this file
    "copyright" | String | copyright message
    "date" | Date | date of the recording or release
    "comment" | String | an arbitrary text
    从以下版本开始：
    1.3
    另请参见：
    AudioInputStream

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  AudioFileFormat.Type
      An instance of the Type class represents one of the standard types of audio file.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
      Constructs an audio file format object.
        AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
      Construct an audio file format object with a set of defined properties.
      protected AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
      Constructs an audio file format object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getByteLength()
      Obtains the size in bytes of the entire audio file (not just its audio data).
      AudioFormat getFormat()
      Obtains the format of the audio data contained in the audio file.
      int getFrameLength()
      Obtains the length of the audio data contained in the file, expressed in sample frames.
      Object getProperty(String key)
      Obtain the property value specified by the key.
      AudioFileFormat.Type getType()
      Obtains the audio file type, such as WAVE or AU.
      Map<String,Object> properties()
      Obtain an unmodifiable map of properties.
      String toString()
      Provides a string representation of the file format.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AudioFileFormat

        protected AudioFileFormat(AudioFileFormat.Type type,
               int byteLength,
               AudioFormat format,
               int frameLength)
        Constructs an audio file format object. This protected constructor is intended for use by providers of file-reading services when returning information about an audio file or about supported audio file formats.
        参数：
        type - the type of the audio file
        byteLength - the length of the file in bytes, or AudioSystem.NOT_SPECIFIED
        format - the format of the audio data contained in the file
        frameLength - the audio data length in sample frames, or AudioSystem.NOT_SPECIFIED
        另请参见：
        getType()

      • AudioFileFormat

        public AudioFileFormat(AudioFileFormat.Type type,
               AudioFormat format,
               int frameLength)
        Constructs an audio file format object. This public constructor may be used by applications to describe the properties of a requested audio file.
        参数：
        type - the type of the audio file
        format - the format of the audio data contained in the file
        frameLength - the audio data length in sample frames, or AudioSystem.NOT_SPECIFIED

      • AudioFileFormat

        public AudioFileFormat(AudioFileFormat.Type type,
               AudioFormat format,
               int frameLength,
               Map<String,Object> properties)
        Construct an audio file format object with a set of defined properties. This public constructor may be used by applications to describe the properties of a requested audio file. The properties map will be copied to prevent any changes to it.
        参数：
        type - the type of the audio file
        format - the format of the audio data contained in the file
        frameLength - the audio data length in sample frames, or AudioSystem.NOT_SPECIFIED
        properties - a Map<String,Object> object with properties
        从以下版本开始：
        1.5

    • 方法详细信息

      • getType

        public AudioFileFormat.Type getType()
        Obtains the audio file type, such as WAVE or AU.
        返回：
        the audio file type
        另请参见：
        AudioFileFormat.Type.WAVE, AudioFileFormat.Type.AU, AudioFileFormat.Type.AIFF, AudioFileFormat.Type.AIFC, AudioFileFormat.Type.SND

      • getByteLength

        public int getByteLength()
        Obtains the size in bytes of the entire audio file (not just its audio data).
        返回：
        the audio file length in bytes
        另请参见：
        AudioSystem.NOT_SPECIFIED

      • getFormat

        public AudioFormat getFormat()
        Obtains the format of the audio data contained in the audio file.
        返回：
        the audio data format

      • getFrameLength

        public int getFrameLength()
        Obtains the length of the audio data contained in the file, expressed in sample frames.
        返回：
        the number of sample frames of audio data in the file
        另请参见：
        AudioSystem.NOT_SPECIFIED

      • properties

        public Map<String,Object> properties()
        Obtain an unmodifiable map of properties. The concept of properties is further explained in the class description.
        返回：
        a Map<String,Object> object containing all properties. If no properties are recognized, an empty map is returned.
        从以下版本开始：
        1.5
        另请参见：
        getProperty(String)

      • getProperty

        public Object getProperty(String key)
        Obtain the property value specified by the key. The concept of properties is further explained in the class description.

        If the specified property is not defined for a particular file format, this method returns null.

        参数：
        key - the key of the desired property
        返回：
        the value of the property with the specified key, or null if the property does not exist.
        从以下版本开始：
        1.5
        另请参见：
        properties()

      • toString

        public String toString()
        Provides a string representation of the file format.
        重载：
        toString in class Object
        返回：
        the file format as a string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n=e/ otin.>isj/.ts鰏f


AudioFileFormat.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 AudioFileFormat.Type

  • java.lang.Object
    • javax.sound.sampled.AudioFileFormat.Type
  • 封闭类：
    AudioFileFormat

    public static class AudioFileFormat.Type
extends Object
    An instance of the Type class represents one of the standard types of audio file. Static instances are provided for the common types.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static AudioFileFormat.Type AIFC
      Specifies an AIFF-C file.
      static AudioFileFormat.Type AIFF
      Specifies an AIFF file.
      static AudioFileFormat.Type AU
      Specifies an AU file.
      static AudioFileFormat.Type SND
      Specifies a SND file.
      static AudioFileFormat.Type WAVE
      Specifies a WAVE file.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioFileFormat.Type(String name, String extension)
      Constructs a file type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Finalizes the equals method
      String getExtension()
      Obtains the common file name extension for this file type.
      int hashCode()
      Finalizes the hashCode method
      String toString()
      Provides the file type's name as the String representation of the file type.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • WAVE

        public static final AudioFileFormat.Type WAVE
        Specifies a WAVE file.

      • AU

        public static final AudioFileFormat.Type AU
        Specifies an AU file.

      • AIFF

        public static final AudioFileFormat.Type AIFF
        Specifies an AIFF file.

      • AIFC

        public static final AudioFileFormat.Type AIFC
        Specifies an AIFF-C file.

      • SND

        public static final AudioFileFormat.Type SND
        Specifies a SND file.

    • 构造方法详细信息

      • AudioFileFormat.Type

        public AudioFileFormat.Type(String name,
                    String extension)
        Constructs a file type.
        参数：
        name - the string that names the file type
        extension - the string that commonly marks the file type without leading dot.

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Finalizes the equals method
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashCode method
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides the file type's name as the String representation of the file type.
        重载：
        toString in class Object
        返回：
        the file type's name

      • getExtension

        public String getExtension()
        Obtains the common file name extension for this file type.
        返回：
        file type extension
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p.eih de d<<<:oohcy<, hsehs u


AudioFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 AudioFormat

  • java.lang.Object
    • javax.sound.sampled.AudioFormat

  • public class AudioFormat
extends Object
    AudioFormat is the class that specifies a particular arrangement of data in a sound stream. By examing the information stored in the audio format, you can discover how to interpret the bits in the binary sound data.

    Every data line has an audio format associated with its data stream. The audio format of a source (playback) data line indicates what kind of data the data line expects to receive for output. For a target (capture) data line, the audio format specifies the kind of the data that can be read from the line. Sound files also have audio formats, of course. The AudioFileFormat class encapsulates an AudioFormat in addition to other, file-specific information. Similarly, an AudioInputStream has an AudioFormat.

    The AudioFormat class accommodates a number of common sound-file encoding techniques, including pulse-code modulation (PCM), mu-law encoding, and a-law encoding. These encoding techniques are predefined, but service providers can create new encoding types. The encoding that a specific format uses is named by its encoding field.

    In addition to the encoding, the audio format includes other properties that further specify the exact arrangement of the data. These include the number of channels, sample rate, sample size, byte order, frame rate, and frame size. Sounds may have different numbers of audio channels: one for mono, two for stereo. The sample rate measures how many "snapshots" (samples) of the sound pressure are taken per second, per channel. (If the sound is stereo rather than mono, two samples are actually measured at each instant of time: one for the left channel, and another for the right channel; however, the sample rate still measures the number per channel, so the rate is the same regardless of the number of channels. This is the standard use of the term.) The sample size indicates how many bits are used to store each snapshot; 8 and 16 are typical values. For 16-bit samples (or any other sample size larger than a byte), byte order is important; the bytes in each sample are arranged in either the "little-endian" or "big-endian" style. For encodings like PCM, a frame consists of the set of samples for all channels at a given point in time, and so the size of a frame (in bytes) is always equal to the size of a sample (in bytes) times the number of channels. However, with some other sorts of encodings a frame can contain a bundle of compressed data for a whole series of samples, as well as additional, non-sample data. For such encodings, the sample rate and sample size refer to the data after it is decoded into PCM, and so they are completely different from the frame rate and frame size.

    An AudioFormat object can include a set of properties. A property is a pair of key and value: the key is of type String, the associated property value is an arbitrary object. Properties specify additional format specifications, like the bit rate for compressed formats. Properties are mainly used as a means to transport additional information of the audio format to and from the service providers. Therefore, properties are ignored in the matches(AudioFormat) method. However, methods which rely on the installed service providers, like (AudioFormat, AudioFormat) isConversionSupported may consider properties, depending on the respective service provider implementation.

    The following table lists some common properties which service providers should use, if applicable:

    Property key | Value type | 描述
    "bitrate" | Integer | average bit rate in bits per second
    "vbr" | Boolean | true, if the file is encoded in variable bit rate (VBR)
    "quality" | Integer | encoding/conversion quality, 1..100

    Vendors of service providers (plugins) are encouraged to seek information about other already established properties in third party plugins, and follow the same conventions.

    从以下版本开始：
    1.3
    另请参见：
    DataLine.getFormat(), AudioInputStream.getFormat(), AudioFileFormat, FormatConversionProvider

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  AudioFormat.Encoding
      The Encoding class names the specific type of data representation used for an audio stream.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean bigEndian
      Indicates whether the audio data is stored in big-endian or little-endian order.
      protected int channels
      The number of audio channels in this format (1 for mono, 2 for stereo).
      protected AudioFormat.Encoding encoding
      The audio encoding technique used by this format.
      protected float frameRate
      The number of frames played or recorded per second, for sounds that have this format.
      protected int frameSize
      The number of bytes in each frame of a sound that has this format.
      protected float sampleRate
      The number of samples played or recorded per second, for sounds that have this format.
      protected int sampleSizeInBits
      The number of bits in each sample of a sound that has this format.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian)
      Constructs an AudioFormat with the given parameters.
      AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
      Constructs an AudioFormat with the given parameters.
      AudioFormat(float sampleRate, int sampleSizeInBits, int channels, boolean signed, boolean bigEndian)
      Constructs an AudioFormat with a linear PCM encoding and the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getChannels()
      Obtains the number of channels.
      AudioFormat.Encoding getEncoding()
      Obtains the type of encoding for sounds in this format.
      float getFrameRate()
      Obtains the frame rate in frames per second.
      int getFrameSize()
      Obtains the frame size in bytes.
      Object getProperty(String key)
      Obtain the property value specified by the key.
      float getSampleRate()
      Obtains the sample rate.
      int getSampleSizeInBits()
      Obtains the size of a sample.
      boolean isBigEndian()
      Indicates whether the audio data is stored in big-endian or little-endian byte order.
      boolean matches(AudioFormat format)
      Indicates whether this format matches the one specified.
      Map<String,Object> properties()
      Obtain an unmodifiable map of properties.
      String toString()
      Returns a string that describes the format, such as: "PCM SIGNED 22050 Hz 16 bit mono big-endian".

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • encoding

        protected AudioFormat.Encoding encoding
        The audio encoding technique used by this format.

      • sampleRate

        protected float sampleRate
        The number of samples played or recorded per second, for sounds that have this format.

      • sampleSizeInBits

        protected int sampleSizeInBits
        The number of bits in each sample of a sound that has this format.

      • channels

        protected int channels
        The number of audio channels in this format (1 for mono, 2 for stereo).

      • frameSize

        protected int frameSize
        The number of bytes in each frame of a sound that has this format.

      • frameRate

        protected float frameRate
        The number of frames played or recorded per second, for sounds that have this format.

      • bigEndian

        protected boolean bigEndian
        Indicates whether the audio data is stored in big-endian or little-endian order.

    • 构造方法详细信息

      • AudioFormat

        public AudioFormat(AudioFormat.Encoding encoding,
           float sampleRate,
           int sampleSizeInBits,
           int channels,
           int frameSize,
           float frameRate,
           boolean bigEndian)
        Constructs an AudioFormat with the given parameters. The encoding specifies the convention used to represent the data. The other parameters are further explained in the class description.
        参数：
        encoding - the audio encoding technique
        sampleRate - the number of samples per second
        sampleSizeInBits - the number of bits in each sample
        channels - the number of channels (1 for mono, 2 for stereo, and so on)
        frameSize - the number of bytes in each frame
        frameRate - the number of frames per second
        bigEndian - indicates whether the data for a single sample is stored in big-endian byte order (false means little-endian)

      • AudioFormat

        public AudioFormat(AudioFormat.Encoding encoding,
           float sampleRate,
           int sampleSizeInBits,
           int channels,
           int frameSize,
           float frameRate,
           boolean bigEndian,
           Map<String,Object> properties)
        Constructs an AudioFormat with the given parameters. The encoding specifies the convention used to represent the data. The other parameters are further explained in the class description.
        参数：
        encoding - the audio encoding technique
        sampleRate - the number of samples per second
        sampleSizeInBits - the number of bits in each sample
        channels - the number of channels (1 for mono, 2 for stereo, and so on)
        frameSize - the number of bytes in each frame
        frameRate - the number of frames per second
        bigEndian - indicates whether the data for a single sample is stored in big-endian byte order (false means little-endian)
        properties - a Map<String,Object> object containing format properties
        从以下版本开始：
        1.5

      • AudioFormat

        public AudioFormat(float sampleRate,
           int sampleSizeInBits,
           int channels,
           boolean signed,
           boolean bigEndian)
        Constructs an AudioFormat with a linear PCM encoding and the given parameters. The frame size is set to the number of bytes required to contain one sample from each channel, and the frame rate is set to the sample rate.
        参数：
        sampleRate - the number of samples per second
        sampleSizeInBits - the number of bits in each sample
        channels - the number of channels (1 for mono, 2 for stereo, and so on)
        signed - indicates whether the data is signed or unsigned
        bigEndian - indicates whether the data for a single sample is stored in big-endian byte order (false means little-endian)

    • 方法详细信息

      • getEncoding

        public AudioFormat.Encoding getEncoding()
        Obtains the type of encoding for sounds in this format.
        返回：
        the encoding type
        另请参见：
        AudioFormat.Encoding.PCM_SIGNED, AudioFormat.Encoding.PCM_UNSIGNED, AudioFormat.Encoding.ULAW, AudioFormat.Encoding.ALAW

      • getSampleRate

        public float getSampleRate()
        Obtains the sample rate. For compressed formats, the return value is the sample rate of the uncompressed audio data. When this AudioFormat is used for queries (e.g. AudioSystem.isConversionSupported) or capabilities (e.g. DataLine.Info.getFormats), a sample rate of AudioSystem.NOT_SPECIFIED means that any sample rate is acceptable. AudioSystem.NOT_SPECIFIED is also returned when the sample rate is not defined for this audio format.
        返回：
        the number of samples per second, or AudioSystem.NOT_SPECIFIED
        另请参见：
        getFrameRate(), AudioSystem.NOT_SPECIFIED

      • getSampleSizeInBits

        public int getSampleSizeInBits()
        Obtains the size of a sample. For compressed formats, the return value is the sample size of the uncompressed audio data. When this AudioFormat is used for queries (e.g. AudioSystem.isConversionSupported) or capabilities (e.g. DataLine.Info.getFormats), a sample size of AudioSystem.NOT_SPECIFIED means that any sample size is acceptable. AudioSystem.NOT_SPECIFIED is also returned when the sample size is not defined for this audio format.
        返回：
        the number of bits in each sample, or AudioSystem.NOT_SPECIFIED
        另请参见：
        getFrameSize(), AudioSystem.NOT_SPECIFIED

      • getChannels

        public int getChannels()
        Obtains the number of channels. When this AudioFormat is used for queries (e.g. AudioSystem.isConversionSupported) or capabilities (e.g. DataLine.Info.getFormats), a return value of AudioSystem.NOT_SPECIFIED means that any (positive) number of channels is acceptable.
        返回：
        The number of channels (1 for mono, 2 for stereo, etc.), or AudioSystem.NOT_SPECIFIED
        另请参见：
        AudioSystem.NOT_SPECIFIED

      • getFrameSize

        public int getFrameSize()
        Obtains the frame size in bytes. When this AudioFormat is used for queries (e.g. AudioSystem.isConversionSupported) or capabilities (e.g. DataLine.Info.getFormats), a frame size of AudioSystem.NOT_SPECIFIED means that any frame size is acceptable. AudioSystem.NOT_SPECIFIED is also returned when the frame size is not defined for this audio format.
        返回：
        the number of bytes per frame, or AudioSystem.NOT_SPECIFIED
        另请参见：
        getSampleSizeInBits(), AudioSystem.NOT_SPECIFIED

      • getFrameRate

        public float getFrameRate()
        Obtains the frame rate in frames per second. When this AudioFormat is used for queries (e.g. AudioSystem.isConversionSupported) or capabilities (e.g. DataLine.Info.getFormats), a frame rate of AudioSystem.NOT_SPECIFIED means that any frame rate is acceptable. AudioSystem.NOT_SPECIFIED is also returned when the frame rate is not defined for this audio format.
        返回：
        the number of frames per second, or AudioSystem.NOT_SPECIFIED
        另请参见：
        getSampleRate(), AudioSystem.NOT_SPECIFIED

      • isBigEndian

        public boolean isBigEndian()
        Indicates whether the audio data is stored in big-endian or little-endian byte order. If the sample size is not more than one byte, the return value is irrelevant.
        返回：
        true if the data is stored in big-endian byte order, false if little-endian

      • properties

        public Map<String,Object> properties()
        Obtain an unmodifiable map of properties. The concept of properties is further explained in the class description.
        返回：
        a Map<String,Object> object containing all properties. If no properties are recognized, an empty map is returned.
        从以下版本开始：
        1.5
        另请参见：
        getProperty(String)

      • getProperty

        public Object getProperty(String key)
        Obtain the property value specified by the key. The concept of properties is further explained in the class description.

        If the specified property is not defined for a particular file format, this method returns null.

        参数：
        key - the key of the desired property
        返回：
        the value of the property with the specified key, or null if the property does not exist.
        从以下版本开始：
        1.5
        另请参见：
        properties()

      • matches

        public boolean matches(AudioFormat format)
        Indicates whether this format matches the one specified. To match, two formats must have the same encoding, and consistent values of the number of channels, sample rate, sample size, frame rate, and frame size. The values of the property are consistent if they are equal or the specified format has the property value AudioSystem.NOT_SPECIFIED. The byte order (big-endian or little-endian) must be the same if the sample size is greater than one byte.
        参数：
        format - format to test for match
        返回：
        true if this format matches the one specified, false otherwise.

      • toString

        public String toString()
        Returns a string that describes the format, such as: "PCM SIGNED 22050 Hz 16 bit mono big-endian". The contents of the string may vary between implementations of Java Sound.
        重载：
        toString in class Object
        返回：
        a string that describes the format parameters
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AudioFormat.Encoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 AudioFormat.Encoding

  • java.lang.Object
    • javax.sound.sampled.AudioFormat.Encoding
  • 封闭类：
    AudioFormat

    public static class AudioFormat.Encoding
extends Object
    The Encoding class names the specific type of data representation used for an audio stream. The encoding includes aspects of the sound format other than the number of channels, sample rate, sample size, frame rate, frame size, and byte order.

    One ubiquitous type of audio encoding is pulse-code modulation (PCM), which is simply a linear (proportional) representation of the sound waveform. With PCM, the number stored in each sample is proportional to the instantaneous amplitude of the sound pressure at that point in time. The numbers may be signed or unsigned integers or floats. Besides PCM, other encodings include mu-law and a-law, which are nonlinear mappings of the sound amplitude that are often used for recording speech.

    You can use a predefined encoding by referring to one of the static objects created by this class, such as PCM_SIGNED or PCM_UNSIGNED. Service providers can create new encodings, such as compressed audio formats, and make these available through the AudioSystem class.

    The Encoding class is static, so that all AudioFormat objects that have the same encoding will refer to the same object (rather than different instances of the same class). This allows matches to be made by checking that two format's encodings are equal.

    从以下版本开始：
    1.3
    另请参见：
    AudioFormat, FormatConversionProvider

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static AudioFormat.Encoding ALAW
      Specifies a-law encoded data.
      static AudioFormat.Encoding PCM_FLOAT
      Specifies floating-point PCM data.
      static AudioFormat.Encoding PCM_SIGNED
      Specifies signed, linear PCM data.
      static AudioFormat.Encoding PCM_UNSIGNED
      Specifies unsigned, linear PCM data.
      static AudioFormat.Encoding ULAW
      Specifies u-law encoded data.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioFormat.Encoding(String name)
      Constructs a new encoding.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Finalizes the equals method
      int hashCode()
      Finalizes the hashCode method
      String toString()
      Provides the String representation of the encoding.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • PCM_SIGNED

        public static final AudioFormat.Encoding PCM_SIGNED
        Specifies signed, linear PCM data.

      • PCM_UNSIGNED

        public static final AudioFormat.Encoding PCM_UNSIGNED
        Specifies unsigned, linear PCM data.

      • PCM_FLOAT

        public static final AudioFormat.Encoding PCM_FLOAT
        Specifies floating-point PCM data.
        从以下版本开始：
        1.7

      • ULAW

        public static final AudioFormat.Encoding ULAW
        Specifies u-law encoded data.

      • ALAW

        public static final AudioFormat.Encoding ALAW
        Specifies a-law encoded data.

    • 构造方法详细信息

      • AudioFormat.Encoding

        public AudioFormat.Encoding(String name)
        Constructs a new encoding.
        参数：
        name - the name of the new type of encoding

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Finalizes the equals method
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashCode method
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides the String representation of the encoding. This String is the same name that was passed to the constructor. For the predefined encodings, the name is similar to the encoding's variable (field) name. For example, PCM_SIGNED.toString() returns the name "pcm_signed".
        重载：
        toString in class Object
        返回：
        the encoding name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aDndye


AudioInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 AudioInputStream

  • java.lang.Object
    • java.io.InputStream
      • javax.sound.sampled.AudioInputStream
  • 所有已实现的接口：
    Closeable, AutoCloseable

    public class AudioInputStream
extends InputStream
    An audio input stream is an input stream with a specified audio format and length. The length is expressed in sample frames, not bytes. Several methods are provided for reading a certain number of bytes from the stream, or an unspecified number of bytes. The audio input stream keeps track of the last byte that was read. You can skip over an arbitrary number of bytes to get to a later position for reading. An audio input stream may support marks. When you set a mark, the current position is remembered so that you can return to it later.

    The AudioSystem class includes many methods that manipulate AudioInputStream objects. For example, the methods let you:

    • obtain an audio input stream from an external audio file, stream, or URL
    • write an external file from an audio input stream
    • convert an audio input stream to a different audio format
    从以下版本开始：
    1.3
    另请参见：
    AudioSystem, Clip.open(AudioInputStream)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AudioFormat format
      The format of the audio data contained in the stream.
      protected long frameLength
      This stream's length, in sample frames.
      protected long framePos
      The current position in this stream, in sample frames (zero-based).
      protected int frameSize
      The size of each frame, in bytes.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioInputStream(InputStream stream, AudioFormat format, long length)
      Constructs an audio input stream that has the requested format and length in sample frames, using audio data from the specified input stream.
      AudioInputStream(TargetDataLine line)
      Constructs an audio input stream that reads its data from the target data line indicated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int available()
      Returns the maximum number of bytes that can be read (or skipped over) from this audio input stream without blocking.
      void close()
      Closes this audio input stream and releases any system resources associated with the stream.
      AudioFormat getFormat()
      Obtains the audio format of the sound data in this audio input stream.
      long getFrameLength()
      Obtains the length of the stream, expressed in sample frames rather than bytes.
      void mark(int readlimit)
      Marks the current position in this audio input stream.
      boolean markSupported()
      Tests whether this audio input stream supports the mark and reset methods.
      int read()
      Reads the next byte of data from the audio input stream.
      int read(byte[] b)
      Reads some number of bytes from the audio input stream and stores them into the buffer array b.
      int read(byte[] b, int off, int len)
      Reads up to a specified maximum number of bytes of data from the audio stream, putting them into the given byte array.
      void reset()
      Repositions this audio input stream to the position it had at the time its mark method was last invoked.
      long skip(long n)
      Skips over and discards a specified number of bytes from this audio input stream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • format

        protected AudioFormat format
        The format of the audio data contained in the stream.

      • frameLength

        protected long frameLength
        This stream's length, in sample frames.

      • frameSize

        protected int frameSize
        The size of each frame, in bytes.

      • framePos

        protected long framePos
        The current position in this stream, in sample frames (zero-based).

    • 构造方法详细信息

      • AudioInputStream

        public AudioInputStream(InputStream stream,
                AudioFormat format,
                long length)
        Constructs an audio input stream that has the requested format and length in sample frames, using audio data from the specified input stream.
        参数：
        stream - the stream on which this AudioInputStream object is based
        format - the format of this stream's audio data
        length - the length in sample frames of the data in this stream

      • AudioInputStream

        public AudioInputStream(TargetDataLine line)
        Constructs an audio input stream that reads its data from the target data line indicated. The format of the stream is the same as that of the target data line, and the length is AudioSystem#NOT_SPECIFIED.
        参数：
        line - the target data line from which this stream obtains its data.
        另请参见：
        AudioSystem.NOT_SPECIFIED

    • 方法详细信息

      • getFormat

        public AudioFormat getFormat()
        Obtains the audio format of the sound data in this audio input stream.
        返回：
        an audio format object describing this stream's format

      • getFrameLength

        public long getFrameLength()
        Obtains the length of the stream, expressed in sample frames rather than bytes.
        返回：
        the length in sample frames

      • read

        public int read()
         throws IOException
        Reads the next byte of data from the audio input stream. The audio input stream's frame size must be one byte, or an IOException will be thrown.
        指定者：
        read in class InputStream
        返回：
        the next byte of data, or -1 if the end of the stream is reached
        抛出：
        IOException - if an input or output error occurs
        另请参见：
        read(byte[], int, int), read(byte[]),

      • read

        public int read(byte[] b)
         throws IOException
        Reads some number of bytes from the audio input stream and stores them into the buffer array b. The number of bytes actually read is returned as an integer. This method blocks until input data is available, the end of the stream is detected, or an exception is thrown.

        This method will always read an integral number of frames. If the length of the array is not an integral number of frames, a maximum of b.length - (b.length % frameSize) bytes will be read.

        重载：
        read in class InputStream
        参数：
        b - the buffer into which the data is read
        返回：
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
        抛出：
        IOException - if an input or output error occurs
        另请参见：
        read(byte[], int, int),
read(),
available()

      • read

        public int read(byte[] b,
       int off,
       int len)
         throws IOException
        Reads up to a specified maximum number of bytes of data from the audio stream, putting them into the given byte array.

        This method will always read an integral number of frames. If len does not specify an integral number of frames, a maximum of len - (len % frameSize) bytes will be read.

        重载：
        read in class InputStream
        参数：
        b - the buffer into which the data is read
        off - the offset, from the beginning of array b, at which the data will be written
        len - the maximum number of bytes to read
        返回：
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
        抛出：
        IOException - if an input or output error occurs
        另请参见：
        read(byte[]), read(), skip(long), available()

      • skip

        public long skip(long n)
          throws IOException
        Skips over and discards a specified number of bytes from this audio input stream.
        重载：
        skip in class InputStream
        参数：
        上一个 - the requested number of bytes to be skipped
        返回：
        the actual number of bytes skipped
        抛出：
        IOException - if an input or output error occurs
        另请参见：
        read(), available()

      • available

        public int available()
              throws IOException
        Returns the maximum number of bytes that can be read (or skipped over) from this audio input stream without blocking. This limit applies only to the next invocation of a read or skip method for this audio input stream; the limit can vary each time these methods are invoked. Depending on the underlying stream,an IOException may be thrown if this stream is closed.
        重载：
        available in class InputStream
        返回：
        the number of bytes that can be read from this audio input stream without blocking
        抛出：
        IOException - if an input or output error occurs
        另请参见：
        read(byte[], int, int), read(byte[]), read(), skip(long)

      • close

        public void close()
           throws IOException
        Closes this audio input stream and releases any system resources associated with the stream.
        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        重载：
        close in class InputStream
        抛出：
        IOException - if an input or output error occurs

      • mark

        public void mark(int readlimit)
        Marks the current position in this audio input stream.
        重载：
        mark in class InputStream
        参数：
        readlimit - the maximum number of bytes that can be read before the mark position becomes invalid.
        另请参见：
        reset(), markSupported()

      • reset

        public void reset()
           throws IOException
        Repositions this audio input stream to the position it had at the time its mark method was last invoked.
        重载：
        reset in class InputStream
        抛出：
        IOException - if an input or output error occurs.
        另请参见：
        mark(int), markSupported()

      • markSupported

        public boolean markSupported()
        Tests whether this audio input stream supports the mark and reset methods.
        重载：
        markSupported in class InputStream
        返回：
        true if this stream supports the mark and reset methods; false otherwise
        另请参见：
        mark(int), reset()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dyeaeFmtFmtllmttntddnSvtsppuio>/e >oceebSei


AudioPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 AudioPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.sound.sampled.AudioPermission
  • 所有已实现的接口：
    Serializable, Guard

    public class AudioPermission
extends BasicPermission
    The AudioPermission class represents access rights to the audio system resources. An AudioPermission contains a target name but no actions list; you either have the named permission or you don't.

    The target name is the name of the audio permission (see the table below). The names follow the hierarchical property-naming convention. Also, an asterisk can be used to represent all the audio permissions.

    The following table lists the possible AudioPermission target names. For each name, the table provides a description of exactly what that permission allows, as well as a discussion of the risks of granting code the permission.

    Permission Target Name | What the Permission Allows | Risks of Allowing this Permission
    play | Audio playback through the audio device or devices on the system. Allows the application to obtain and manipulate lines and mixers for audio playback (rendering). | In some cases use of this permission may affect other applications because the audio from one line may be mixed with other audio being played on the system, or because manipulation of a mixer affects the audio for all lines using that mixer.
    record | Audio recording through the audio device or devices on the system. Allows the application to obtain and manipulate lines and mixers for audio recording (capture). | In some cases use of this permission may affect other applications because manipulation of a mixer affects the audio for all lines using that mixer. This permission can enable an applet or application to eavesdrop on a user.

    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioPermission(String name)
      Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".
      AudioPermission(String name, String actions)
      Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AudioPermission

        public AudioPermission(String name)
        Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record". An asterisk can be used to indicate all audio permissions.
        参数：
        name - the name of the new AudioPermission
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.

      • AudioPermission

        public AudioPermission(String name,
               String actions)
        Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record". The actions parameter is currently unused and should be null.
        参数：
        name - the name of the new AudioPermission
        actions - (unused; should be null)
        抛出：
        NullPointerException - if name is null.
        IllegalArgumentException - if name is empty.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

khLl u<bT>>tkf


AudioSystem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

类 AudioSystem

  • java.lang.Object
    • javax.sound.sampled.AudioSystem

  • public class AudioSystem
extends Object
    The AudioSystem class acts as the entry point to the sampled-audio system resources. This class lets you query and access the mixers that are installed on the system. AudioSystem includes a number of methods for converting audio data between different formats, and for translating between audio files and streams. It also provides a method for obtaining a Line directly from the AudioSystem without dealing explicitly with mixers.

    Properties can be used to specify the default mixer for specific line types. Both system properties and a properties file are considered. In the Oracle reference implementation, the properties file is "lib/sound.properties" in the JRE directory. If a property exists both as a system property and in the properties file, the system property takes precedence. If none is specified, a suitable default is chosen among the available devices. The syntax of the properties file is specified in Properties.load. The following table lists the available property keys and which methods consider them:

    Property Key | 接口 | Affected Method(s)
    javax.sound.sampled.Clip | Clip | getLine(javax.sound.sampled.Line.Info), getClip()
    javax.sound.sampled.Port | Port | getLine(javax.sound.sampled.Line.Info)
    javax.sound.sampled.SourceDataLine | SourceDataLine | getLine(javax.sound.sampled.Line.Info), getSourceDataLine(javax.sound.sampled.AudioFormat)
    javax.sound.sampled.TargetDataLine | TargetDataLine | getLine(javax.sound.sampled.Line.Info), getTargetDataLine(javax.sound.sampled.AudioFormat)
    The property value consists of the provider class name and the mixer name, separated by the hash mark ("#"). The provider class name is the fully-qualified name of a concrete mixer provider class. The mixer name is matched against the String returned by the getName method of Mixer.Info. Either the class name, or the mixer name may be omitted. If only the class name is specified, the trailing hash mark is optional.

    If the provider class is specified, and it can be successully retrieved from the installed providers, the list of Mixer.Info objects is retrieved from the provider. Otherwise, or when these mixers do not provide a subsequent match, the list is retrieved from getMixerInfo() to contain all available Mixer.Info objects.

    If a mixer name is specified, the resulting list of Mixer.Info objects is searched: the first one with a matching name, and whose Mixer provides the respective line interface, will be returned. If no matching Mixer.Info object is found, or the mixer name is not specified, the first mixer from the resulting list, which provides the respective line interface, will be returned. For example, the property javax.sound.sampled.Clip with a value "com.sun.media.sound.MixerProvider#SunClip" will have the following consequences when getLine is called requesting a Clip instance: if the class com.sun.media.sound.MixerProvider exists in the list of installed mixer providers, the first Clip from the first mixer with name "SunClip" will be returned. If it cannot be found, the first Clip from the first mixer of the specified provider will be returned, regardless of name. If there is none, the first Clip from the first Mixer with name "SunClip" in the list of all mixers (as returned by getMixerInfo) will be returned, or, if not found, the first Clip of the first Mixerthat can be found in the list of all mixers is returned. If that fails, too, an IllegalArgumentException is thrown.

    从以下版本开始：
    1.3
    另请参见：
    AudioFormat, AudioInputStream, Mixer, Line, Line.Info

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int NOT_SPECIFIED
      An integer that stands for an unknown numeric value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static AudioFileFormat getAudioFileFormat(File file)
      Obtains the audio file format of the specified File.
      static AudioFileFormat getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the provided input stream.
      static AudioFileFormat getAudioFileFormat(URL url)
      Obtains the audio file format of the specified URL.
      static AudioFileFormat.Type[] getAudioFileTypes()
      Obtains the file types for which file writing support is provided by the system.
      static AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that the system can write from the audio input stream specified.
      static AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.
      static AudioInputStream getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated format, by converting the provided audio input stream.
      static AudioInputStream getAudioInputStream(File file)
      Obtains an audio input stream from the provided File.
      static AudioInputStream getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the provided input stream.
      static AudioInputStream getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.
      static Clip getClip()
      Obtains a clip that can be used for playing back an audio file or an audio stream.
      static Clip getClip(Mixer.Info mixerInfo)
      Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.
      static Line getLine(Line.Info info)
      Obtains a line that matches the description in the specified Line.Info object.
      static Mixer getMixer(Mixer.Info info)
      Obtains the requested audio mixer.
      static Mixer.Info[] getMixerInfo()
      Obtains an array of mixer info objects that represents the set of audio mixers that are currently installed on the system.
      static SourceDataLine getSourceDataLine(AudioFormat format)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.
      static SourceDataLine getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static Line.Info[] getSourceLineInfo(Line.Info info)
      Obtains information about all source lines of a particular type that are supported by the installed mixers.
      static TargetDataLine getTargetDataLine(AudioFormat format)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.
      static TargetDataLine getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static AudioFormat.Encoding[] getTargetEncodings(AudioFormat.Encoding sourceEncoding)
      Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.
      static AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
      Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.
      static AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.
      static Line.Info[] getTargetLineInfo(Line.Info info)
      Obtains information about all target lines of a particular type that are supported by the installed mixers.
      static boolean isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
      static boolean isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat)
      Indicates whether an audio input stream of a specified format can be obtained from an audio input stream of another specified format.
      static boolean isFileTypeSupported(AudioFileFormat.Type fileType)
      Indicates whether file writing support for the specified file type is provided by the system.
      static boolean isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
      static boolean isLineSupported(Line.Info info)
      Indicates whether the system supports any lines that match the specified Line.Info object.
      static int write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the specified file type to the external file provided.
      static int write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the specified file type to the output stream provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NOT_SPECIFIED

        public static final int NOT_SPECIFIED
        An integer that stands for an unknown numeric value. This value is appropriate only for signed quantities that do not normally take negative values. Examples include file sizes, frame sizes, buffer sizes, and sample rates. A number of Java Sound constructors accept a value of NOT_SPECIFIED for such parameters. Other methods may also accept or return this value, as documented.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getMixerInfo

        public static Mixer.Info[] getMixerInfo()
        Obtains an array of mixer info objects that represents the set of audio mixers that are currently installed on the system.
        返回：
        an array of info objects for the currently installed mixers. If no mixers are available on the system, an array of length 0 is returned.
        另请参见：
        getMixer(javax.sound.sampled.Mixer.Info)

      • getMixer

        public static Mixer getMixer(Mixer.Info info)
        Obtains the requested audio mixer.
        参数：
        info - a Mixer.Info object representing the desired mixer, or null for the system default mixer
        返回：
        the requested mixer
        抛出：
        SecurityException - if the requested mixer is unavailable because of security restrictions
        IllegalArgumentException - if the info object does not represent a mixer installed on the system
        另请参见：
        getMixerInfo()

      • getSourceLineInfo

        public static Line.Info[] getSourceLineInfo(Line.Info info)
        Obtains information about all source lines of a particular type that are supported by the installed mixers.
        参数：
        info - a Line.Info object that specifies the kind of lines about which information is requested
        返回：
        an array of Line.Info objects describing source lines matching the type requested. If no matching source lines are supported, an array of length 0 is returned.
        另请参见：
        Mixer.getSourceLineInfo(Line.Info)

      • getTargetLineInfo

        public static Line.Info[] getTargetLineInfo(Line.Info info)
        Obtains information about all target lines of a particular type that are supported by the installed mixers.
        参数：
        info - a Line.Info object that specifies the kind of lines about which information is requested
        返回：
        an array of Line.Info objects describing target lines matching the type requested. If no matching target lines are supported, an array of length 0 is returned.
        另请参见：
        Mixer.getTargetLineInfo(Line.Info)

      • isLineSupported

        public static boolean isLineSupported(Line.Info info)
        Indicates whether the system supports any lines that match the specified Line.Info object. A line is supported if any installed mixer supports it.
        参数：
        info - a Line.Info object describing the line for which support is queried
        返回：
        true if at least one matching line is supported, otherwise false
        另请参见：
        Mixer.isLineSupported(Line.Info)

      • getLine

        public static Line getLine(Line.Info info)
                    throws LineUnavailableException
        Obtains a line that matches the description in the specified Line.Info object.

        If a DataLine is requested, and info is an instance of DataLine.Info specifying at least one fully qualified audio format, the last one will be used as the default format of the returned DataLine.

        If system properties javax.sound.sampled.Clip, javax.sound.sampled.Port, javax.sound.sampled.SourceDataLine and javax.sound.sampled.TargetDataLine are defined or they are defined in the file "sound.properties", they are used to retrieve default lines. For details, refer to the class description. If the respective property is not set, or the mixer requested in the property is not installed or does not provide the requested line, all installed mixers are queried for the requested line type. A Line will be returned from the first mixer providing the requested line type.

        参数：
        info - a Line.Info object describing the desired kind of line
        返回：
        a line of the requested kind
        抛出：
        LineUnavailableException - if a matching line is not available due to resource restrictions
        SecurityException - if a matching line is not available due to security restrictions
        IllegalArgumentException - if the system does not support at least one line matching the specified Line.Info object through any installed mixer

      • getClip

        public static Clip getClip()
                    throws LineUnavailableException
        Obtains a clip that can be used for playing back an audio file or an audio stream. The returned clip will be provided by the default system mixer, or, if not possible, by any other mixer installed in the system that supports a Clip object.

        The returned clip must be opened with the open(AudioFormat) or open(AudioInputStream) method.

        This is a high-level method that uses getMixer and getLine internally.

        If the system property javax.sound.sampled.Clip is defined or it is defined in the file "sound.properties", it is used to retrieve the default clip. For details, refer to the class description.

        返回：
        the desired clip object
        抛出：
        LineUnavailableException - if a clip object is not available due to resource restrictions
        SecurityException - if a clip object is not available due to security restrictions
        IllegalArgumentException - if the system does not support at least one clip instance through any installed mixer
        从以下版本开始：
        1.5
        另请参见：
        getClip(Mixer.Info)

      • getClip

        public static Clip getClip(Mixer.Info mixerInfo)
                    throws LineUnavailableException
        Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.

        The returned clip must be opened with the open(AudioFormat) or open(AudioInputStream) method.

        This is a high-level method that uses getMixer and getLine internally.

        参数：
        mixerInfo - a Mixer.Info object representing the desired mixer, or null for the system default mixer
        返回：
        a clip object from the specified mixer
        抛出：
        LineUnavailableException - if a clip is not available from this mixer due to resource restrictions
        SecurityException - if a clip is not available from this mixer due to security restrictions
        IllegalArgumentException - if the system does not support at least one clip through the specified mixer
        从以下版本开始：
        1.5
        另请参见：
        getClip()

      • getSourceDataLine

        public static SourceDataLine getSourceDataLine(AudioFormat format)
                                        throws LineUnavailableException
        Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object. The returned line will be provided by the default system mixer, or, if not possible, by any other mixer installed in the system that supports a matching SourceDataLine object.

        The returned line should be opened with the open(AudioFormat) or open(AudioFormat, int) method.

        This is a high-level method that uses getMixer and getLine internally.

        The returned SourceDataLine's default audio format will be initialized with format.

        If the system property javax.sound.sampled.SourceDataLine is defined or it is defined in the file "sound.properties", it is used to retrieve the default source data line. For details, refer to the class description.

        参数：
        format - an AudioFormat object specifying the supported audio format of the returned line, or null for any audio format
        返回：
        the desired SourceDataLine object
        抛出：
        LineUnavailableException - if a matching source data line is not available due to resource restrictions
        SecurityException - if a matching source data line is not available due to security restrictions
        IllegalArgumentException - if the system does not support at least one source data line supporting the specified audio format through any installed mixer
        从以下版本开始：
        1.5
        另请参见：
        getSourceDataLine(AudioFormat, Mixer.Info)

      • getSourceDataLine

        public static SourceDataLine getSourceDataLine(AudioFormat format,
                               Mixer.Info mixerinfo)
                                        throws LineUnavailableException
        Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

        The returned line should be opened with the open(AudioFormat) or open(AudioFormat, int) method.

        This is a high-level method that uses getMixer and getLine internally.

        The returned SourceDataLine's default audio format will be initialized with format.

        参数：
        format - an AudioFormat object specifying the supported audio format of the returned line, or null for any audio format
        mixerinfo - a Mixer.Info object representing the desired mixer, or null for the system default mixer
        返回：
        the desired SourceDataLine object
        抛出：
        LineUnavailableException - if a matching source data line is not available from the specified mixer due to resource restrictions
        SecurityException - if a matching source data line is not available from the specified mixer due to security restrictions
        IllegalArgumentException - if the specified mixer does not support at least one source data line supporting the specified audio format
        从以下版本开始：
        1.5
        另请参见：
        getSourceDataLine(AudioFormat)

      • getTargetDataLine

        public static TargetDataLine getTargetDataLine(AudioFormat format)
                                        throws LineUnavailableException
        Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object. The returned line will be provided by the default system mixer, or, if not possible, by any other mixer installed in the system that supports a matching TargetDataLine object.

        The returned line should be opened with the open(AudioFormat) or open(AudioFormat, int) method.

        This is a high-level method that uses getMixer and getLine internally.

        The returned TargetDataLine's default audio format will be initialized with format.

        If the system property javax.sound.sampled.TargetDataLine is defined or it is defined in the file "sound.properties", it is used to retrieve the default target data line. For details, refer to the class description.

        参数：
        format - an AudioFormat object specifying the supported audio format of the returned line, or null for any audio format
        返回：
        the desired TargetDataLine object
        抛出：
        LineUnavailableException - if a matching target data line is not available due to resource restrictions
        SecurityException - if a matching target data line is not available due to security restrictions
        IllegalArgumentException - if the system does not support at least one target data line supporting the specified audio format through any installed mixer
        从以下版本开始：
        1.5
        另请参见：
        getTargetDataLine(AudioFormat, Mixer.Info), AudioPermission

      • getTargetDataLine

        public static TargetDataLine getTargetDataLine(AudioFormat format,
                               Mixer.Info mixerinfo)
                                        throws LineUnavailableException
        Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

        The returned line should be opened with the open(AudioFormat) or open(AudioFormat, int) method.

        This is a high-level method that uses getMixer and getLine internally.

        The returned TargetDataLine's default audio format will be initialized with format.

        参数：
        format - an AudioFormat object specifying the supported audio format of the returned line, or null for any audio format
        mixerinfo - a Mixer.Info object representing the desired mixer, or null for the system default mixer
        返回：
        the desired TargetDataLine object
        抛出：
        LineUnavailableException - if a matching target data line is not available from the specified mixer due to resource restrictions
        SecurityException - if a matching target data line is not available from the specified mixer due to security restrictions
        IllegalArgumentException - if the specified mixer does not support at least one target data line supporting the specified audio format
        从以下版本开始：
        1.5
        另请参见：
        getTargetDataLine(AudioFormat), AudioPermission

      • getTargetEncodings

        public static AudioFormat.Encoding[] getTargetEncodings(AudioFormat.Encoding sourceEncoding)
        Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.
        参数：
        sourceEncoding - the encoding for which conversion support is queried
        返回：
        array of encodings. If sourceEncodingis not supported, an array of length 0 is returned. Otherwise, the array will have a length of at least 1, representing sourceEncoding (no conversion).

      • getTargetEncodings

        public static AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
        Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.
        参数：
        sourceFormat - the audio format for which conversion is queried
        返回：
        array of encodings. If sourceFormatis not supported, an array of length 0 is returned. Otherwise, the array will have a length of at least 1, representing the encoding of sourceFormat (no conversion).

      • isConversionSupported

        public static boolean isConversionSupported(AudioFormat.Encoding targetEncoding,
                            AudioFormat sourceFormat)
        Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
        参数：
        targetEncoding - the desired encoding after conversion
        sourceFormat - the audio format before conversion
        返回：
        true if the conversion is supported, otherwise false

      • getAudioInputStream

        public static AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding,
                                   AudioInputStream sourceStream)
        Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.
        参数：
        targetEncoding - the desired encoding after conversion
        sourceStream - the stream to be converted
        返回：
        an audio input stream of the indicated encoding
        抛出：
        IllegalArgumentException - if the conversion is not supported
        另请参见：
        getTargetEncodings(AudioFormat.Encoding), getTargetEncodings(AudioFormat), isConversionSupported(AudioFormat.Encoding, AudioFormat), getAudioInputStream(AudioFormat, AudioInputStream)

      • getTargetFormats

        public static AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding,
                             AudioFormat sourceFormat)
        Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.
        参数：
        targetEncoding - the desired encoding after conversion
        sourceFormat - the audio format before conversion
        返回：
        array of formats. If no formats of the specified encoding are supported, an array of length 0 is returned.

      • isConversionSupported

        public static boolean isConversionSupported(AudioFormat targetFormat,
                            AudioFormat sourceFormat)
        Indicates whether an audio input stream of a specified format can be obtained from an audio input stream of another specified format.
        参数：
        targetFormat - the desired audio format after conversion
        sourceFormat - the audio format before conversion
        返回：
        true if the conversion is supported, otherwise false

      • getAudioInputStream

        public static AudioInputStream getAudioInputStream(AudioFormat targetFormat,
                                   AudioInputStream sourceStream)
        Obtains an audio input stream of the indicated format, by converting the provided audio input stream.
        参数：
        targetFormat - the desired audio format after conversion
        sourceStream - the stream to be converted
        返回：
        an audio input stream of the indicated format
        抛出：
        IllegalArgumentException - if the conversion is not supported #see #getTargetEncodings(AudioFormat)
        另请参见：
        getTargetFormats(AudioFormat.Encoding, AudioFormat),
isConversionSupported(AudioFormat, AudioFormat),
getAudioInputStream(AudioFormat.Encoding, AudioInputStream)

      • getAudioFileFormat

        public static AudioFileFormat getAudioFileFormat(InputStream stream)
                                          throws UnsupportedAudioFileException,
                                                 IOException
        Obtains the audio file format of the provided input stream. The stream must point to valid audio file data. The implementation of this method may require multiple parsers to examine the stream to determine whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support these operations, this method may fail with an IOException.
        参数：
        stream - the input stream from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the stream's audio file format
        抛出：
        UnsupportedAudioFileException - if the stream does not point to valid audio file data recognized by the system
        IOException - if an input/output exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getAudioFileFormat

        public static AudioFileFormat getAudioFileFormat(URL url)
                                          throws UnsupportedAudioFileException,
                                                 IOException
        Obtains the audio file format of the specified URL. The URL must point to valid audio file data.
        参数：
        url - the URL from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the audio file format
        抛出：
        UnsupportedAudioFileException - if the URL does not point to valid audio file data recognized by the system
        IOException - if an input/output exception occurs

      • getAudioFileFormat

        public static AudioFileFormat getAudioFileFormat(File file)
                                          throws UnsupportedAudioFileException,
                                                 IOException
        Obtains the audio file format of the specified File. The File must point to valid audio file data.
        参数：
        file - the File from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the audio file format
        抛出：
        UnsupportedAudioFileException - if the File does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioInputStream

        public static AudioInputStream getAudioInputStream(InputStream stream)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains an audio input stream from the provided input stream. The stream must point to valid audio file data. The implementation of this method may require multiple parsers to examine the stream to determine whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support these operation, this method may fail with an IOException.
        参数：
        stream - the input stream from which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data contained in the input stream.
        抛出：
        UnsupportedAudioFileException - if the stream does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getAudioInputStream

        public static AudioInputStream getAudioInputStream(URL url)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains an audio input stream from the URL provided. The URL must point to valid audio file data.
        参数：
        url - the URL for which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data pointed to by the URL
        抛出：
        UnsupportedAudioFileException - if the URL does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioInputStream

        public static AudioInputStream getAudioInputStream(File file)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains an audio input stream from the provided File. The File must point to valid audio file data.
        参数：
        file - the File for which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data pointed to by the File
        抛出：
        UnsupportedAudioFileException - if the File does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioFileTypes

        public static AudioFileFormat.Type[] getAudioFileTypes()
        Obtains the file types for which file writing support is provided by the system.
        返回：
        array of unique file types. If no file types are supported, an array of length 0 is returned.

      • isFileTypeSupported

        public static boolean isFileTypeSupported(AudioFileFormat.Type fileType)
        Indicates whether file writing support for the specified file type is provided by the system.
        参数：
        fileType - the file type for which write capabilities are queried
        返回：
        true if the file type is supported, otherwise false

      • getAudioFileTypes

        public static AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
        Obtains the file types that the system can write from the audio input stream specified.
        参数：
        stream - the audio input stream for which audio file type support is queried
        返回：
        array of file types. If no file types are supported, an array of length 0 is returned.

      • isFileTypeSupported

        public static boolean isFileTypeSupported(AudioFileFormat.Type fileType,
                          AudioInputStream stream)
        Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
        参数：
        fileType - the file type for which write capabilities are queried
        stream - the stream for which file-writing support is queried
        返回：
        true if the file type is supported for this audio input stream, otherwise false

      • write

        public static int write(AudioInputStream stream,
        AudioFileFormat.Type fileType,
        OutputStream out)
                 throws IOException
        Writes a stream of bytes representing an audio file of the specified file type to the output stream provided. Some file types require that the length be written into the file header; such files cannot be written from start to finish unless the length is known in advance. An attempt to write a file of such a type will fail with an IOException if the length in the audio file type is AudioSystem.NOT_SPECIFIED.
        参数：
        stream - the audio input stream containing audio data to be written to the file
        fileType - the kind of audio file to write
        out - the stream to which the file data should be written
        返回：
        the number of bytes written to the output stream
        抛出：
        IOException - if an input/output exception occurs
        IllegalArgumentException - if the file type is not supported by the system
        另请参见：
        isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()

      • write

        public static int write(AudioInputStream stream,
        AudioFileFormat.Type fileType,
        File out)
                 throws IOException
        Writes a stream of bytes representing an audio file of the specified file type to the external file provided.
        参数：
        stream - the audio input stream containing audio data to be written to the file
        fileType - the kind of audio file to write
        out - the external file to which the file data should be written
        返回：
        the number of bytes written to the file
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file type is not supported by the system
        另请参见：
        isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


BooleanControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 BooleanControl

  • java.lang.Object
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl

  • public abstract class BooleanControl
extends Control
    A BooleanControl provides the ability to switch between two possible settings that affect a line's audio. The settings are boolean values (true and false). A graphical user interface might represent the control by a two-state button, an on/off switch, two mutually exclusive buttons, or a checkbox (among other possibilities). For example, depressing a button might activate a MUTE control to silence the line's audio.

    As with other Control subclasses, a method is provided that returns string labels for the values, suitable for display in the user interface.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  BooleanControl.Type
      An instance of the BooleanControl.Type class identifies one kind of boolean control.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected BooleanControl(BooleanControl.Type type, boolean initialValue)
      Constructs a new boolean control object with the given parameters.
      protected BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
      Constructs a new boolean control object with the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getStateLabel(boolean state)
      Obtains the label for the specified state.
      boolean getValue()
      Obtains this control's current value.
      void setValue(boolean value)
      Sets the current value for the control.
      String toString()
      Provides a string representation of the control

      • 方法 - 继承于类 javax.sound.sampled.Control

        getType

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BooleanControl

        protected BooleanControl(BooleanControl.Type type,
              boolean initialValue,
              String trueStateLabel,
              String falseStateLabel)
        Constructs a new boolean control object with the given parameters.
        参数：
        type - the type of control represented this float control object
        initialValue - the initial control value
        trueStateLabel - the label for the state represented by true, such as "true" or "on."
        falseStateLabel - the label for the state represented by false, such as "false" or "off."

      • BooleanControl

        protected BooleanControl(BooleanControl.Type type,
              boolean initialValue)
        Constructs a new boolean control object with the given parameters. The labels for the true and false states default to "true" and "false."
        参数：
        type - the type of control represented by this float control object
        initialValue - the initial control value

    • 方法详细信息

      • setValue

        public void setValue(boolean value)
        Sets the current value for the control. The default implementation simply sets the value as indicated. Some controls require that their line be open before they can be affected by setting a value.
        参数：
        value - desired new value.

      • getValue

        public boolean getValue()
        Obtains this control's current value.
        返回：
        current value.

      • getStateLabel

        public String getStateLabel(boolean state)
        Obtains the label for the specified state.
        返回：
        the label for the specified state, such as "true" or "on" for true, or "false" or "off" for false.

      • toString

        public String toString()
        Provides a string representation of the control
        重载：
        toString in class Control
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a/f< ta taiitaadrccttumsforvR Lf oOaac<)/i


BooleanControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 BooleanControl.Type

  • java.lang.Object
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
  • 封闭类：
    BooleanControl

    public static class BooleanControl.Type
extends Control.Type
    An instance of the BooleanControl.Type class identifies one kind of boolean control. Static instances are provided for the common types.
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static BooleanControl.Type APPLY_REVERB
      Represents a control for whether reverberation is applied to a line.
      static BooleanControl.Type MUTE
      Represents a control for the mute status of a line.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected BooleanControl.Type(String name)
      Constructs a new boolean control type.

    • 方法摘要

      • 方法 - 继承于类 javax.sound.sampled.Control.Type

        equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MUTE

        public static final BooleanControl.Type MUTE
        Represents a control for the mute status of a line. Note that mute status does not affect gain.

      • APPLY_REVERB

        public static final BooleanControl.Type APPLY_REVERB
        Represents a control for whether reverberation is applied to a line. Note that the status of this control not affect the reverberation settings for a line, but does affect whether these settings are used.

    • 构造方法详细信息

      • BooleanControl.Type

        protected BooleanControl.Type(String name)
        Constructs a new boolean control type.
        参数：
        name - the name of the new boolean control type
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e=DEH=TH========!//ed


Clip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface Clip

  • All Superinterfaces:
    AutoCloseable, DataLine, Line

    public interface Clip
extends DataLine
    The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.

    Because the data is pre-loaded and has a known length, you can set a clip to start playing at any position in its audio data. You can also create a loop, so that when the clip is played it will cycle repeatedly. Loops are specified with a starting and ending sample frame, along with the number of times that the loop should be played.

    Clips may be obtained from a Mixer that supports lines of this type. Data is loaded into a clip when it is opened.

    Playback of an audio clip may be started and stopped using the start and stop methods. These methods do not reset the media position; start causes playback to continue from the position where playback was last stopped. To restart playback from the beginning of the clip's audio data, simply follow the invocation of stop with setFramePosition(0), which rewinds the media to the beginning of the clip.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.sound.sampled.DataLine

        DataLine.Info

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int LOOP_CONTINUOUSLY
      A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getFrameLength()
      Obtains the media length in sample frames.
      long getMicrosecondLength()
      Obtains the media duration in microseconds
      void loop(int count)
      Starts looping playback from the current position.
      void open(AudioFormat format, byte[] data, int offset, int bufferSize)
      Opens the clip, meaning that it should acquire any required system resources and become operational.
      void open(AudioInputStream stream)
      Opens the clip with the format and audio data present in the provided audio input stream.
      void setFramePosition(int frames)
      Sets the media position in sample frames.
      void setLoopPoints(int start, int end)
      Sets the first and last sample frames that will be played in the loop.
      void setMicrosecondPosition(long microseconds)
      Sets the media position in microseconds.

      • 方法 - 继承于接口 javax.sound.sampled.DataLine

        available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

    • 字段详细信息

      • LOOP_CONTINUOUSLY

        static final int LOOP_CONTINUOUSLY
        A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.
        另请参见：
        loop(int), Constant Field Values

    • 方法详细信息

      • open

        void open(AudioFormat format,
        byte[] data,
        int offset,
        int bufferSize)
          throws LineUnavailableException
        Opens the clip, meaning that it should acquire any required system resources and become operational. The clip is opened with the format and audio data indicated. If this operation succeeds, the line is marked as open and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line which is already open is illegal and may result in an IllegalStateException.

        Note that some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        format - the format of the supplied audio data
        data - a byte array containing audio data to load into the clip
        offset - the point at which to start copying, expressed in bytes from the beginning of the array
        bufferSize - the number of bytes of data to load into the clip from the array.
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IllegalArgumentException - if the buffer size does not represent an integral number of sample frames, or if format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        Line.close(), Line.isOpen(), LineListener

      • open

        void open(AudioInputStream stream)
          throws LineUnavailableException,
                 IOException
        Opens the clip with the format and audio data present in the provided audio input stream. Opening a clip means that it should acquire any required system resources and become operational. If this operation input stream. If this operation succeeds, the line is marked open and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line which is already open is illegal and may result in an IllegalStateException.

        Note that some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        stream - an audio input stream from which audio data will be read into the clip
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IOException - if an I/O exception occurs during reading of the stream
        IllegalArgumentException - if the stream's audio format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        Line.close(), Line.isOpen(), LineListener

      • getFrameLength

        int getFrameLength()
        Obtains the media length in sample frames.
        返回：
        the media length, expressed in sample frames, or AudioSystem.NOT_SPECIFIED if the line is not open.
        另请参见：
        AudioSystem.NOT_SPECIFIED

      • getMicrosecondLength

        long getMicrosecondLength()
        Obtains the media duration in microseconds
        返回：
        the media duration, expressed in microseconds, or AudioSystem.NOT_SPECIFIED if the line is not open.
        另请参见：
        AudioSystem.NOT_SPECIFIED

      • setFramePosition

        void setFramePosition(int frames)
        Sets the media position in sample frames. The position is zero-based; the first frame is frame number zero. When the clip begins playing the next time, it will start by playing the frame at this position.

        To obtain the current position in sample frames, use the getFramePosition method of DataLine.

        参数：
        frames - the desired new media position, expressed in sample frames

      • setMicrosecondPosition

        void setMicrosecondPosition(long microseconds)
        Sets the media position in microseconds. When the clip begins playing the next time, it will start at this position. The level of precision is not guaranteed. For example, an implementation might calculate the microsecond position from the current frame position and the audio sample frame rate. The precision in microseconds would then be limited to the number of microseconds per sample frame.

        To obtain the current position in microseconds, use the getMicrosecondPosition method of DataLine.

        参数：
        microseconds - the desired new media position, expressed in microseconds

      • setLoopPoints

        void setLoopPoints(int start,
                 int end)
        Sets the first and last sample frames that will be played in the loop. The ending point must be greater than or equal to the starting point, and both must fall within the the size of the loaded media. A value of 0 for the starting point means the beginning of the loaded media. Similarly, a value of -1 for the ending point indicates the last frame of the media.
        参数：
        start - the loop's starting position, in sample frames (zero-based)
        end - the loop's ending position, in sample frames (zero-based), or -1 to indicate the final frame
        抛出：
        IllegalArgumentException - if the requested loop points cannot be set, usually because one or both falls outside the media's duration or because the ending point is before the starting point

      • loop

        void loop(int count)
        Starts looping playback from the current position. Playback will continue to the loop's end point, then loop back to the loop start point count times, and finally continue playback to the end of the clip.

        If the current position when this method is invoked is greater than the loop end point, playback simply continues to the end of the clip without looping.

        A count value of 0 indicates that any current looping should cease and playback should continue to the end of the clip. The behavior is undefined when this method is invoked with any other value during a loop operation.

        If playback is stopped during looping, the current loop status is cleared; the behavior of subsequent loop and start requests is not affected by an interrupted loop operation.

        参数：
        count - the number of times playback should loop back from the loop's end position to the loop's start position, or LOOP_CONTINUOUSLY to indicate that looping should continue until interrupted
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nFarr& />&p>_m蝔e nrha n eb秈鄆


CompoundControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 CompoundControl

  • java.lang.Object
    • javax.sound.sampled.Control
      • javax.sound.sampled.CompoundControl

  • public abstract class CompoundControl
extends Control
    A CompoundControl, such as a graphic equalizer, provides control over two or more related properties, each of which is itself represented as a Control.
    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  CompoundControl.Type
      An instance of the CompoundControl.Type inner class identifies one kind of compound control.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected CompoundControl(CompoundControl.Type type, Control[] memberControls)
      Constructs a new compound control object with the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Control[] getMemberControls()
      Returns the set of member controls that comprise the compound control.
      String toString()
      Provides a string representation of the control

      • 方法 - 继承于类 javax.sound.sampled.Control

        getType

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompoundControl

        protected CompoundControl(CompoundControl.Type type,
               Control[] memberControls)
        Constructs a new compound control object with the given parameters.
        参数：
        type - the type of control represented this compound control object
        memberControls - the set of member controls

    • 方法详细信息

      • getMemberControls

        public Control[] getMemberControls()
        Returns the set of member controls that comprise the compound control.
        返回：
        the set of member controls.

      • toString

        public String toString()
        Provides a string representation of the control
        重载：
        toString in class Control
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e >oxebceballbaaa"ooa..djosdLmupxxxje..au/ex


CompoundControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 CompoundControl.Type

  • java.lang.Object
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.CompoundControl.Type
  • 封闭类：
    CompoundControl

    public static class CompoundControl.Type
extends Control.Type
    An instance of the CompoundControl.Type inner class identifies one kind of compound control. Static instances are provided for the common types.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected CompoundControl.Type(String name)
      Constructs a new compound control type.

    • 方法摘要

      • 方法 - 继承于类 javax.sound.sampled.Control.Type

        equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CompoundControl.Type

        protected CompoundControl.Type(String name)
        Constructs a new compound control type.
        参数：
        name - the name of the new compound control type
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tr>io.ol.ocnnoccotaaCe(n/((llakta umot


Control

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 Control

  • java.lang.Object
    • javax.sound.sampled.Control
  • 直接已知子类：
    BooleanControl, CompoundControl, EnumControl, FloatControl

    public abstract class Control
extends Object
    Lines often have a set of controls, such as gain and pan, that affect the audio signal passing through the line. Java Sound's Line objects let you obtain a particular control object by passing its class as the argument to a getControl method.

    Because the various types of controls have different purposes and features, all of their functionality is accessed from the subclasses that define each kind of control.

    从以下版本开始：
    1.3
    另请参见：
    Line.getControls(), Line.isControlSupported(javax.sound.sampled.Control.Type)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  Control.Type
      An instance of the Type class represents the type of the control.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Control(Control.Type type)
      Constructs a Control with the specified type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Control.Type getType()
      Obtains the control's type.
      String toString()
      Obtains a String describing the control type and its current state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Control

        protected Control(Control.Type type)
        Constructs a Control with the specified type.
        参数：
        type - the kind of control desired

    • 方法详细信息

      • getType

        public Control.Type getType()
        Obtains the control's type.
        返回：
        the control's type.

      • toString

        public String toString()
        Obtains a String describing the control type and its current state.
        重载：
        toString in class Object
        返回：
        a String representation of the Control.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>崞l�>扑瓢F盟槐Ｓ�>保轩艋铀◆羧壤>sg�


Control.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 Control.Type

  • java.lang.Object
    • javax.sound.sampled.Control.Type
  • 直接已知子类：
    BooleanControl.Type, CompoundControl.Type, EnumControl.Type, FloatControl.Type
    封闭类：
    Control

    public static class Control.Type
extends Object
    An instance of the Type class represents the type of the control. Static instances are provided for the common types.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Control.Type(String name)
      Constructs a new control type with the name specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Finalizes the equals method
      int hashCode()
      Finalizes the hashCode method
      String toString()
      Provides the String representation of the control type.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Control.Type

        protected Control.Type(String name)
        Constructs a new control type with the name specified. The name should be a descriptive string appropriate for labelling the control in an application, such as "Gain" or "Balance."
        参数：
        name - the name of the new control type.

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Finalizes the equals method
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashCode method
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides the String representation of the control type. This String is the same name that was passed to the constructor.
        重载：
        toString in class Object
        返回：
        the control type name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ysse n/aauq iuqql mm ci#nd6avtel>>>. il.xe


DataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface DataLine

  • All Superinterfaces:
    AutoCloseable, Line
    All Known Subinterfaces:
    Clip, SourceDataLine, TargetDataLine

    public interface DataLine
extends Line
    DataLine adds media-related functionality to its superinterface, Line. This functionality includes transport-control methods that start, stop, drain, and flush the audio data that passes through the line. A data line can also report the current position, volume, and audio format of the media. Data lines are used for output of audio by means of the subinterfaces SourceDataLine or Clip, which allow an application program to write data. Similarly, audio input is handled by the subinterface TargetDataLine, which allows data to be read.

    A data line has an internal buffer in which the incoming or outgoing audio data is queued. The drain() method blocks until this internal buffer becomes empty, usually because all queued data has been processed. The flush() method discards any available queued data from the internal buffer.

    A data line produces START and STOP events whenever it begins or ceases active presentation or capture of data. These events can be generated in response to specific requests, or as a result of less direct state changes. For example, if start() is called on an inactive data line, and data is available for capture or playback, a START event will be generated shortly, when data playback or capture actually begins. Or, if the flow of data to an active data line is constricted so that a gap occurs in the presentation of data, a STOP event is generated.

    Mixers often support synchronized control of multiple data lines. Synchronization can be established through the Mixer interface's synchronize method. See the description of the Mixer interface for a more complete description.

    从以下版本开始：
    1.3
    另请参见：
    LineEvent

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  DataLine.Info
      Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int available()
      Obtains the number of bytes of data currently available to the application for processing in the data line's internal buffer.
      void drain()
      Drains queued data from the line by continuing data I/O until the data line's internal buffer has been emptied.
      void flush()
      Flushes queued data from the line.
      int getBufferSize()
      Obtains the maximum number of bytes of data that will fit in the data line's internal buffer.
      AudioFormat getFormat()
      Obtains the current format (encoding, sample rate, number of channels, etc.) of the data line's audio data.
      int getFramePosition()
      Obtains the current position in the audio data, in sample frames.
      float getLevel()
      Obtains the current volume level for the line.
      long getLongFramePosition()
      Obtains the current position in the audio data, in sample frames.
      long getMicrosecondPosition()
      Obtains the current position in the audio data, in microseconds.
      boolean isActive()
      Indicates whether the line is engaging in active I/O (such as playback or capture).
      boolean isRunning()
      Indicates whether the line is running.
      void start()
      Allows a line to engage in data I/O.
      void stop()
      Stops the line.

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

    • 方法详细信息

      • drain

        void drain()
        Drains queued data from the line by continuing data I/O until the data line's internal buffer has been emptied. This method blocks until the draining is complete. Because this is a blocking method, it should be used with care. If drain() is invoked on a stopped line that has data in its queue, the method will block until the line is running and the data queue becomes empty. If drain() is invoked by one thread, and another continues to fill the data queue, the operation will not complete. This method always returns when the data line is closed.
        另请参见：
        flush()

      • flush

        void flush()
        Flushes queued data from the line. The flushed data is discarded. In some cases, not all queued data can be discarded. For example, a mixer can flush data from the buffer for a specific input line, but any unplayed data already in the output buffer (the result of the mix) will still be played. You can invoke this method after pausing a line (the normal case) if you want to skip the "stale" data when you restart playback or capture. (It is legal to flush a line that is not stopped, but doing so on an active line is likely to cause a discontinuity in the data, resulting in a perceptible click.)
        另请参见：
        stop(), drain()

      • start

        void start()
        Allows a line to engage in data I/O. If invoked on a line that is already running, this method does nothing. Unless the data in the buffer has been flushed, the line resumes I/O starting with the first frame that was unprocessed at the time the line was stopped. When audio capture or playback starts, a START event is generated.
        另请参见：
        stop(), isRunning(), LineEvent

      • stop

        void stop()
        Stops the line. A stopped line should cease I/O activity. If the line is open and running, however, it should retain the resources required to resume activity. A stopped line should retain any audio data in its buffer instead of discarding it, so that upon resumption the I/O can continue where it left off, if possible. (This doesn't guarantee that there will never be discontinuities beyond the current buffer, of course; if the stopped condition continues for too long, input or output samples might be dropped.) If desired, the retained data can be discarded by invoking the flush method. When audio capture or playback stops, a STOP event is generated.
        另请参见：
        start(),
isRunning(),
flush(),
LineEvent

      • isRunning

        boolean isRunning()
        Indicates whether the line is running. The default is false. An open line begins running when the first data is presented in response to an invocation of the start method, and continues until presentation ceases in response to a call to stop or because playback completes.
        返回：
        true if the line is running, otherwise false
        另请参见：
        start(), stop()

      • isActive

        boolean isActive()
        Indicates whether the line is engaging in active I/O (such as playback or capture). When an inactive line becomes active, it sends a START event to its listeners. Similarly, when an active line becomes inactive, it sends a STOP event.
        返回：
        true if the line is actively capturing or rendering sound, otherwise false
        另请参见：
        Line.isOpen(),
Line.addLineListener(javax.sound.sampled.LineListener),
Line.removeLineListener(javax.sound.sampled.LineListener),
LineEvent,
LineListener

      • getFormat

        AudioFormat getFormat()
        Obtains the current format (encoding, sample rate, number of channels, etc.) of the data line's audio data.

        If the line is not open and has never been opened, it returns the default format. The default format is an implementation specific audio format, or, if the DataLine.Info object, which was used to retrieve this DataLine, specifies at least one fully qualified audio format, the last one will be used as the default format. Opening the line with a specific audio format (e.g. SourceDataLine.open(AudioFormat)) will override the default format.

        返回：
        current audio data format
        另请参见：
        AudioFormat

      • getBufferSize

        int getBufferSize()
        Obtains the maximum number of bytes of data that will fit in the data line's internal buffer. For a source data line, this is the size of the buffer to which data can be written. For a target data line, it is the size of the buffer from which data can be read. Note that the units used are bytes, but will always correspond to an integral number of sample frames of audio data.
        返回：
        the size of the buffer in bytes

      • available

        int available()
        Obtains the number of bytes of data currently available to the application for processing in the data line's internal buffer. For a source data line, this is the amount of data that can be written to the buffer without blocking. For a target data line, this is the amount of data available to be read by the application. For a clip, this value is always 0 because the audio data is loaded into the buffer when the clip is opened, and persists without modification until the clip is closed.

        Note that the units used are bytes, but will always correspond to an integral number of sample frames of audio data.

        An application is guaranteed that a read or write operation of up to the number of bytes returned from available() will not block; however, there is no guarantee that attempts to read or write more data will block.

        返回：
        the amount of data available, in bytes

      • getFramePosition

        int getFramePosition()
        Obtains the current position in the audio data, in sample frames. The frame position measures the number of sample frames captured by, or rendered from, the line since it was opened. This return value will wrap around after 2^31 frames. It is recommended to use getLongFramePosition instead.
        返回：
        the number of frames already processed since the line was opened
        另请参见：
        getLongFramePosition()

      • getLongFramePosition

        long getLongFramePosition()
        Obtains the current position in the audio data, in sample frames. The frame position measures the number of sample frames captured by, or rendered from, the line since it was opened.
        返回：
        the number of frames already processed since the line was opened
        从以下版本开始：
        1.5

      • getMicrosecondPosition

        long getMicrosecondPosition()
        Obtains the current position in the audio data, in microseconds. The microsecond position measures the time corresponding to the number of sample frames captured by, or rendered from, the line since it was opened. The level of precision is not guaranteed. For example, an implementation might calculate the microsecond position from the current frame position and the audio sample frame rate. The precision in microseconds would then be limited to the number of microseconds per sample frame.
        返回：
        the number of microseconds of data processed since the line was opened

      • getLevel

        float getLevel()
        Obtains the current volume level for the line. This level is a measure of the signal's current amplitude, and should not be confused with the current setting of a gain control. The range is from 0.0 (silence) to 1.0 (maximum possible amplitude for the sound waveform). The units measure linear amplitude, not decibels.
        返回：
        the current amplitude of the signal in this line, or AudioSystem.NOT_SPECIFIED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rf;


DataLine.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 DataLine.Info

  • java.lang.Object
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
  • Enclosing interface:
    DataLine

    public static class DataLine.Info
extends Line.Info
    Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines. This information includes:
    • the audio formats supported by the data line
    • the minimum and maximum sizes of its internal buffer
    Because a Line.Info knows the class of the line its describes, a DataLine.Info object can describe DataLine subinterfaces such as SourceDataLine, TargetDataLine, and Clip. You can query a mixer for lines of any of these types, passing an appropriate instance of DataLine.Info as the argument to a method such as Mixer.getLine(Line.Info).
    从以下版本开始：
    1.3
    另请参见：
    Line.Info

    • 构造方法摘要

      Constructors
      构造方法与描述
      DataLine.Info(类<?> lineClass, AudioFormat format)
      Constructs a data line's info object from the specified information, which includes a single audio format.
      DataLine.Info(类<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
      Constructs a data line's info object from the specified information, which includes a set of supported audio formats and a range for the buffer size.
      DataLine.Info(类<?> lineClass, AudioFormat format, int bufferSize)
      Constructs a data line's info object from the specified information, which includes a single audio format and a desired buffer size.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AudioFormat[] getFormats()
      Obtains a set of audio formats supported by the data line.
      int getMaxBufferSize()
      Obtains the maximum buffer size supported by the data line.
      int getMinBufferSize()
      Obtains the minimum buffer size supported by the data line.
      boolean isFormatSupported(AudioFormat format)
      Indicates whether this data line supports a particular audio format.
      boolean matches(Line.Info info)
      Determines whether the specified info object matches this one.
      String toString()
      Obtains a textual description of the data line info.

      • 方法 - 继承于类 javax.sound.sampled.Line.Info

        getLineClass

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DataLine.Info

        public DataLine.Info(类<?> lineClass,
             AudioFormat[] formats,
             int minBufferSize,
             int maxBufferSize)
        Constructs a data line's info object from the specified information, which includes a set of supported audio formats and a range for the buffer size. This constructor is typically used by mixer implementations when returning information about a supported line.
        参数：
        lineClass - the class of the data line described by the info object
        formats - set of formats supported
        minBufferSize - minimum buffer size supported by the data line, in bytes
        maxBufferSize - maximum buffer size supported by the data line, in bytes

      • DataLine.Info

        public DataLine.Info(类<?> lineClass,
             AudioFormat format,
             int bufferSize)
        Constructs a data line's info object from the specified information, which includes a single audio format and a desired buffer size. This constructor is typically used by an application to describe a desired line.
        参数：
        lineClass - the class of the data line described by the info object
        format - desired format
        bufferSize - desired buffer size in bytes

      • DataLine.Info

        public DataLine.Info(类<?> lineClass,
             AudioFormat format)
        Constructs a data line's info object from the specified information, which includes a single audio format. This constructor is typically used by an application to describe a desired line.
        参数：
        lineClass - the class of the data line described by the info object
        format - desired format

    • 方法详细信息

      • getFormats

        public AudioFormat[] getFormats()
        Obtains a set of audio formats supported by the data line. Note that isFormatSupported(AudioFormat) might return true for certain additional formats that are missing from the set returned by getFormats(). The reverse is not the case: isFormatSupported(AudioFormat) is guaranteed to return true for all formats returned by getFormats(). Some fields in the AudioFormat instances can be set to NOT_SPECIFIED if that field does not apply to the format, or if the format supports a wide range of values for that field. For example, a multi-channel device supporting up to 64 channels, could set the channel field in the AudioFormat instances returned by this method to NOT_SPECIFIED.
        返回：
        a set of supported audio formats.
        另请参见：
        isFormatSupported(AudioFormat)

      • isFormatSupported

        public boolean isFormatSupported(AudioFormat format)
        Indicates whether this data line supports a particular audio format. The default implementation of this method simply returns true if the specified format matches any of the supported formats.
        参数：
        format - the audio format for which support is queried.
        返回：
        true if the format is supported, otherwise false
        另请参见：
        getFormats(), AudioFormat.matches(javax.sound.sampled.AudioFormat)

      • getMinBufferSize

        public int getMinBufferSize()
        Obtains the minimum buffer size supported by the data line.
        返回：
        minimum buffer size in bytes, or AudioSystem.NOT_SPECIFIED

      • getMaxBufferSize

        public int getMaxBufferSize()
        Obtains the maximum buffer size supported by the data line.
        返回：
        maximum buffer size in bytes, or AudioSystem.NOT_SPECIFIED

      • matches

        public boolean matches(Line.Info info)
        Determines whether the specified info object matches this one. To match, the superclass match requirements must be met. In addition, this object's minimum buffer size must be at least as large as that of the object specified, its maximum buffer size must be at most as large as that of the object specified, and all of its formats must match formats supported by the object specified.
        重载：
        matches in class Line.Info
        参数：
        info - the info object which is being compared to this one
        返回：
        true if this object matches the one specified, otherwise false.

      • toString

        public String toString()
        Obtains a textual description of the data line info.
        重载：
        toString in class Line.Info
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c>kar ee et ettrottdo(>eaa baooddddo huifn


EnumControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 EnumControl

  • java.lang.Object
    • javax.sound.sampled.Control
      • javax.sound.sampled.EnumControl

  • public abstract class EnumControl
extends Control
    A EnumControl provides control over a set of discrete possible values, each represented by an object. In a graphical user interface, such a control might be represented by a set of buttons, each of which chooses one value or setting. For example, a reverb control might provide several preset reverberation settings, instead of providing continuously adjustable parameters of the sort that would be represented by FloatControl objects.

    Controls that provide a choice between only two settings can often be implemented instead as a BooleanControl, and controls that provide a set of values along some quantifiable dimension might be implemented instead as a FloatControl with a coarse resolution. However, a key feature of EnumControl is that the returned values are arbitrary objects, rather than numerical or boolean values. This means that each returned object can provide further information. As an example, the settings of a REVERB control are instances of ReverbType that can be queried for the parameter values used for each setting.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  EnumControl.Type
      An instance of the EnumControl.Type inner class identifies one kind of enumerated control.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected EnumControl(EnumControl.Type type, Object[] values, Object value)
      Constructs a new enumerated control object with the given parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getValue()
      Obtains this control's current value.
      Object[] getValues()
      Returns the set of possible values for this control.
      void setValue(Object value)
      Sets the current value for the control.
      String toString()
      Provides a string representation of the control.

      • 方法 - 继承于类 javax.sound.sampled.Control

        getType

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • EnumControl

        protected EnumControl(EnumControl.Type type,
           Object[] values,
           Object value)
        Constructs a new enumerated control object with the given parameters.
        参数：
        type - the type of control represented this enumerated control object
        values - the set of possible values for the control
        value - the initial control value

    • 方法详细信息

      • setValue

        public void setValue(Object value)
        Sets the current value for the control. The default implementation simply sets the value as indicated. If the value indicated is not supported, an IllegalArgumentException is thrown. Some controls require that their line be open before they can be affected by setting a value.
        参数：
        value - the desired new value
        抛出：
        IllegalArgumentException - if the value indicated does not fall within the allowable range

      • getValue

        public Object getValue()
        Obtains this control's current value.
        返回：
        the current value

      • getValues

        public Object[] getValues()
        Returns the set of possible values for this control.
        返回：
        the set of possible values

      • toString

        public String toString()
        Provides a string representation of the control.
        重载：
        toString in class Control
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

qtuuhcoicofrroffraccv/rd< c>.>>g< tpt


EnumControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 EnumControl.Type

  • java.lang.Object
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.EnumControl.Type
  • 封闭类：
    EnumControl

    public static class EnumControl.Type
extends Control.Type
    An instance of the EnumControl.Type inner class identifies one kind of enumerated control. Static instances are provided for the common types.
    从以下版本开始：
    1.3
    另请参见：
    EnumControl

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static EnumControl.Type REVERB
      Represents a control over a set of possible reverberation settings.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected EnumControl.Type(String name)
      Constructs a new enumerated control type.

    • 方法摘要

      • 方法 - 继承于类 javax.sound.sampled.Control.Type

        equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • REVERB

        public static final EnumControl.Type REVERB
        Represents a control over a set of possible reverberation settings. Each reverberation setting is described by an instance of the ReverbType class. (To access these settings, invoke EnumControl.getValues() on an enumerated control of type REVERB.)

    • 构造方法详细信息

      • EnumControl.Type

        protected EnumControl.Type(String name)
        Constructs a new enumerated control type.
        参数：
        name - the name of the new enumerated control type
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ute>et>ct>"OO>"". tt>ehienncnos&oninsb/e.ei


FloatControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 FloatControl

  • java.lang.Object
    • javax.sound.sampled.Control
      • javax.sound.sampled.FloatControl

  • public abstract class FloatControl
extends Control
    A FloatControl object provides control over a range of floating-point values. Float controls are often represented in graphical user interfaces by continuously adjustable objects such as sliders or rotary knobs. Concrete subclasses of FloatControl implement controls, such as gain and pan, that affect a line's audio signal in some way that an application can manipulate. The FloatControl.Type inner class provides static instances of types that are used to identify some common kinds of float control.

    The FloatControl abstract class provides methods to set and get the control's current floating-point value. Other methods obtain the possible range of values and the control's resolution (the smallest increment between returned values). Some float controls allow ramping to a new value over a specified period of time. FloatControl also includes methods that return string labels for the minimum, maximum, and midpoint positions of the control.

    从以下版本开始：
    1.3
    另请参见：
    Line.getControls(), Line.isControlSupported(javax.sound.sampled.Control.Type)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  FloatControl.Type
      An instance of the FloatControl.Type inner class identifies one kind of float control.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
      Constructs a new float control object with the given parameters.
      protected FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
      Constructs a new float control object with the given parameters

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float getMaximum()
      Obtains the maximum value permitted.
      String getMaxLabel()
      Obtains the label for the maximum value, such as "Right" or "Full."
      String getMidLabel()
      Obtains the label for the mid-point value, such as "Center" or "Default."
      float getMinimum()
      Obtains the minimum value permitted.
      String getMinLabel()
      Obtains the label for the minimum value, such as "Left" or "Off."
      float getPrecision()
      Obtains the resolution or granularity of the control, in the units that the control measures.
      String getUnits()
      Obtains the label for the units in which the control's values are expressed, such as "dB" or "frames per second."
      int getUpdatePeriod()
      Obtains the smallest time interval, in microseconds, over which the control's value can change during a shift.
      float getValue()
      Obtains this control's current value.
      void setValue(float newValue)
      Sets the current value for the control.
      void shift(float from, float to, int microseconds)
      Changes the control value from the initial value to the final value linearly over the specified time period, specified in microseconds.
      String toString()
      Provides a string representation of the control

      • 方法 - 继承于类 javax.sound.sampled.Control

        getType

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FloatControl

        protected FloatControl(FloatControl.Type type,
            float minimum,
            float maximum,
            float precision,
            int updatePeriod,
            float initialValue,
            String units,
            String minLabel,
            String midLabel,
            String maxLabel)
        Constructs a new float control object with the given parameters
        参数：
        type - the kind of control represented by this float control object
        minimum - the smallest value permitted for the control
        maximum - the largest value permitted for the control
        precision - the resolution or granularity of the control. This is the size of the increment between discrete valid values.
        updatePeriod - the smallest time interval, in microseconds, over which the control can change from one discrete value to the next during a shift
        initialValue - the value that the control starts with when constructed
        units - the label for the units in which the control's values are expressed, such as "dB" or "frames per second"
        minLabel - the label for the minimum value, such as "Left" or "Off"
        midLabel - the label for the midpoint value, such as "Center" or "Default"
        maxLabel - the label for the maximum value, such as "Right" or "Full"
        抛出：
        IllegalArgumentException - if minimum is greater than maximum or initialValue does not fall within the allowable range

      • FloatControl

        protected FloatControl(FloatControl.Type type,
            float minimum,
            float maximum,
            float precision,
            int updatePeriod,
            float initialValue,
            String units)
        Constructs a new float control object with the given parameters. The labels for the minimum, maximum, and mid-point values are set to zero-length strings.
        参数：
        type - the kind of control represented by this float control object
        minimum - the smallest value permitted for the control
        maximum - the largest value permitted for the control
        precision - the resolution or granularity of the control. This is the size of the increment between discrete valid values.
        updatePeriod - the smallest time interval, in microseconds, over which the control can change from one discrete value to the next during a shift
        initialValue - the value that the control starts with when constructed
        units - the label for the units in which the control's values are expressed, such as "dB" or "frames per second"
        抛出：
        IllegalArgumentException - if minimum is greater than maximum or initialValue does not fall within the allowable range

    • 方法详细信息

      • setValue

        public void setValue(float newValue)
        Sets the current value for the control. The default implementation simply sets the value as indicated. If the value indicated is greater than the maximum value, or smaller than the minimum value, an IllegalArgumentException is thrown. Some controls require that their line be open before they can be affected by setting a value.
        参数：
        newValue - desired new value
        抛出：
        IllegalArgumentException - if the value indicated does not fall within the allowable range

      • getValue

        public float getValue()
        Obtains this control's current value.
        返回：
        the current value

      • getMaximum

        public float getMaximum()
        Obtains the maximum value permitted.
        返回：
        the maximum allowable value

      • getMinimum

        public float getMinimum()
        Obtains the minimum value permitted.
        返回：
        the minimum allowable value

      • getUnits

        public String getUnits()
        Obtains the label for the units in which the control's values are expressed, such as "dB" or "frames per second."
        返回：
        the units label, or a zero-length string if no label

      • getMinLabel

        public String getMinLabel()
        Obtains the label for the minimum value, such as "Left" or "Off."
        返回：
        the minimum value label, or a zero-length string if no label * has been set

      • getMidLabel

        public String getMidLabel()
        Obtains the label for the mid-point value, such as "Center" or "Default."
        返回：
        the mid-point value label, or a zero-length string if no label * has been set

      • getMaxLabel

        public String getMaxLabel()
        Obtains the label for the maximum value, such as "Right" or "Full."
        返回：
        the maximum value label, or a zero-length string if no label * has been set

      • getPrecision

        public float getPrecision()
        Obtains the resolution or granularity of the control, in the units that the control measures. The precision is the size of the increment between discrete valid values for this control, over the set of supported floating-point values.
        返回：
        the control's precision

      • getUpdatePeriod

        public int getUpdatePeriod()
        Obtains the smallest time interval, in microseconds, over which the control's value can change during a shift. The update period is the inverse of the frequency with which the control updates its value during a shift. If the implementation does not support value shifting over time, it should set the control's value to the final value immediately and return -1 from this method.
        返回：
        update period in microseconds, or -1 if shifting over time is unsupported
        另请参见：
        shift(float, float, int)

      • shift

        public void shift(float from,
         float to,
         int microseconds)
        Changes the control value from the initial value to the final value linearly over the specified time period, specified in microseconds. This method returns without blocking; it does not wait for the shift to complete. An implementation should complete the operation within the time specified. The default implementation simply changes the value to the final value immediately.
        参数：
        from - initial value at the beginning of the shift
        to - final value after the shift
        microseconds - maximum duration of the shift in microseconds
        抛出：
        IllegalArgumentException - if either from or to value does not fall within the allowable range
        另请参见：
        getUpdatePeriod()

      • toString

        public String toString()
        Provides a string representation of the control
        重载：
        toString in class Control
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w sr ieoedl跫和奔"m魇 Lo衪�.


FloatControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 FloatControl.Type

  • java.lang.Object
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.FloatControl.Type
  • 封闭类：
    FloatControl

    public static class FloatControl.Type
extends Control.Type
    An instance of the FloatControl.Type inner class identifies one kind of float control. Static instances are provided for the common types.
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static FloatControl.Type AUX_RETURN
      Represents a control for the auxiliary return gain on a line.
      static FloatControl.Type AUX_SEND
      Represents a control for the auxiliary send gain on a line.
      static FloatControl.Type BALANCE
      Represents a control for the relative balance of a stereo signal between two stereo speakers.
      static FloatControl.Type MASTER_GAIN
      Represents a control for the overall gain on a line.
      static FloatControl.Type PAN
      Represents a control for the relative pan (left-right positioning) of the signal.
      static FloatControl.Type REVERB_RETURN
      Represents a control for the post-reverb gain on a line.
      static FloatControl.Type REVERB_SEND
      Represents a control for the pre-reverb gain on a line.
      static FloatControl.Type SAMPLE_RATE
      Represents a control that changes the sample rate of audio playback.
      static FloatControl.Type VOLUME
      Represents a control for the volume on a line.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected FloatControl.Type(String name)
      Constructs a new float control type.

    • 方法摘要

      • 方法 - 继承于类 javax.sound.sampled.Control.Type

        equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MASTER_GAIN

        public static final FloatControl.Type MASTER_GAIN
        Represents a control for the overall gain on a line.

        Gain is a quantity in decibels (dB) that is added to the intrinsic decibel level of the audio signal--that is, the level of the signal before it is altered by the gain control. A positive gain amplifies (boosts) the signal's volume, and a negative gain attenuates (cuts) it. The gain setting defaults to a value of 0.0 dB, meaning the signal's loudness is unaffected. Note that gain measures dB, not amplitude. The relationship between a gain in decibels and the corresponding linear amplitude multiplier is:

        linearScalar = pow(10.0, gainDB/20.0)

        The FloatControl class has methods to impose a maximum and minimum allowable value for gain. However, because an audio signal might already be at a high amplitude, the maximum setting does not guarantee that the signal will be undistorted when the gain is applied to it (unless the maximum is zero or negative). To avoid numeric overflow from excessively large gain settings, a gain control can implement clipping, meaning that the signal's amplitude will be limited to the maximum value representable by its audio format, instead of wrapping around.

        These comments apply to gain controls in general, not just master gain controls. A line can have more than one gain control. For example, a mixer (which is itself a line) might have a master gain control, an auxiliary return control, a reverb return control, and, on each of its source lines, an individual aux send and reverb send.

        另请参见：
        AUX_SEND, AUX_RETURN, REVERB_SEND, REVERB_RETURN, VOLUME

      • AUX_SEND

        public static final FloatControl.Type AUX_SEND
        Represents a control for the auxiliary send gain on a line.
        另请参见：
        MASTER_GAIN, AUX_RETURN

      • AUX_RETURN

        public static final FloatControl.Type AUX_RETURN
        Represents a control for the auxiliary return gain on a line.
        另请参见：
        MASTER_GAIN, AUX_SEND

      • REVERB_SEND

        public static final FloatControl.Type REVERB_SEND
        Represents a control for the pre-reverb gain on a line. This control may be used to affect how much of a line's signal is directed to a mixer's internal reverberation unit.
        另请参见：
        MASTER_GAIN, REVERB_RETURN, EnumControl.Type.REVERB

      • REVERB_RETURN

        public static final FloatControl.Type REVERB_RETURN
        Represents a control for the post-reverb gain on a line. This control may be used to control the relative amplitude of the signal returned from an internal reverberation unit.
        另请参见：
        MASTER_GAIN, REVERB_SEND

      • VOLUME

        public static final FloatControl.Type VOLUME
        Represents a control for the volume on a line.

      • PAN

        public static final FloatControl.Type PAN
        Represents a control for the relative pan (left-right positioning) of the signal. The signal may be mono; the pan setting affects how it is distributed by the mixer in a stereo mix. The valid range of values is -1.0 (left channel only) to 1.0 (right channel only). The default is 0.0 (centered).
        另请参见：
        BALANCE

      • BALANCE

        public static final FloatControl.Type BALANCE
        Represents a control for the relative balance of a stereo signal between two stereo speakers. The valid range of values is -1.0 (left channel only) to 1.0 (right channel only). The default is 0.0 (centered).
        另请参见：
        PAN

      • SAMPLE_RATE

        public static final FloatControl.Type SAMPLE_RATE
        Represents a control that changes the sample rate of audio playback. The net effect of changing the sample rate depends on the relationship between the media's natural rate and the rate that is set via this control. The natural rate is the sample rate that is specified in the data line's AudioFormat object. For example, if the natural rate of the media is 11025 samples per second and the sample rate is set to 22050 samples per second, the media will play back at twice the normal speed.

        Changing the sample rate with this control does not affect the data line's audio format. Also note that whenever you change a sound's sample rate, a change in the sound's pitch results. For example, doubling the sample rate has the effect of doubling the frequencies in the sound's spectrum, which raises the pitch by an octave.

    • 构造方法详细信息

      • FloatControl.Type

        protected FloatControl.Type(String name)
        Constructs a new float control type.
        参数：
        name - the name of the new float control type
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ou-, aalaavllavvohnnsa,narrn uDru l">>/sa簔


javax.sound.sampled

Interfaces

  • Clip
  • DataLine
  • Line
  • LineListener
  • Mixer
  • Port
  • SourceDataLine
  • TargetDataLine

Classes

  • AudioFileFormat
  • AudioFileFormat.Type
  • AudioFormat
  • AudioFormat.Encoding
  • AudioInputStream
  • AudioPermission
  • AudioSystem
  • BooleanControl
  • BooleanControl.Type
  • CompoundControl
  • CompoundControl.Type
  • Control
  • Control.Type
  • DataLine.Info
  • EnumControl
  • EnumControl.Type
  • FloatControl
  • FloatControl.Type
  • Line.Info
  • LineEvent
  • LineEvent.Type
  • Mixer.Info
  • Port.Info
  • ReverbType

Exceptions

  • LineUnavailableException
  • UnsupportedAudioFileException
d


javax.sound.sampled

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sound.sampled

Provides interfaces and classes for capture, processing, and playback of sampled audio data.

请参见： 描述

  • 接口摘要
    接口 描述
    Clip
    The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
    DataLine
    DataLine adds media-related functionality to its superinterface, Line.
    Line
    The Line interface represents a mono or multi-channel audio feed.
    LineListener
    Instances of classes that implement the LineListener interface can register to receive events when a line's status changes.
    Mixer
    A mixer is an audio device with one or more lines.
    Port
    Ports are simple lines for input or output of audio to or from audio devices.
    SourceDataLine
    A source data line is a data line to which data may be written.
    TargetDataLine
    A target data line is a type of DataLine from which audio data can be read.
  • Class Summary
    类 描述
    AudioFileFormat
    An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.
    AudioFileFormat.Type
    An instance of the Type class represents one of the standard types of audio file.
    AudioFormat
    AudioFormat is the class that specifies a particular arrangement of data in a sound stream.
    AudioFormat.Encoding
    The Encoding class names the specific type of data representation used for an audio stream.
    AudioInputStream
    An audio input stream is an input stream with a specified audio format and length.
    AudioPermission
    The AudioPermission class represents access rights to the audio system resources.
    AudioSystem
    The AudioSystem class acts as the entry point to the sampled-audio system resources.
    BooleanControl
    A BooleanControl provides the ability to switch between two possible settings that affect a line's audio.
    BooleanControl.Type
    An instance of the BooleanControl.Type class identifies one kind of boolean control.
    CompoundControl
    A CompoundControl, such as a graphic equalizer, provides control over two or more related properties, each of which is itself represented as a Control.
    CompoundControl.Type
    An instance of the CompoundControl.Type inner class identifies one kind of compound control.
    Control
    Lines often have a set of controls, such as gain and pan, that affect the audio signal passing through the line.
    Control.Type
    An instance of the Type class represents the type of the control.
    DataLine.Info
    Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines.
    EnumControl
    A EnumControl provides control over a set of discrete possible values, each represented by an object.
    EnumControl.Type
    An instance of the EnumControl.Type inner class identifies one kind of enumerated control.
    FloatControl
    A FloatControl object provides control over a range of floating-point values.
    FloatControl.Type
    An instance of the FloatControl.Type inner class identifies one kind of float control.
    Line.Info
    A Line.Info object contains information about a line.
    LineEvent
    The LineEvent class encapsulates information that a line sends its listeners whenever the line opens, closes, starts, or stops.
    LineEvent.Type
    The LineEvent.Type inner class identifies what kind of event occurred on a line.
    Mixer.Info
    The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description.
    Port.Info
    The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer.
    ReverbType
    The ReverbType class provides methods for accessing various reverberation settings to be applied to an audio signal.
  • Exception Summary
    Exception 描述
    LineUnavailableException
    A LineUnavailableException is an exception indicating that a line cannot be opened because it is unavailable.
    UnsupportedAudioFileException
    An UnsupportedAudioFileException is an exception indicating that an operation failed because a file did not contain valid data of a recognized file type and format.

软件包 javax.sound.sampled Description

Provides interfaces and classes for capture, processing, and playback of sampled audio data.

Related Documentation

For overviews, tutorials, examples, and guides, please see:
  • Sound
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dBtyfeo)ntIsol


javax.sound.sampled Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sound.sampled

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sound.sampled.AudioFileFormat
    • javax.sound.sampled.AudioFileFormat.Type
    • javax.sound.sampled.AudioFormat
    • javax.sound.sampled.AudioFormat.Encoding
    • javax.sound.sampled.AudioSystem
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl
      • javax.sound.sampled.CompoundControl
      • javax.sound.sampled.EnumControl
      • javax.sound.sampled.FloatControl
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
      • javax.sound.sampled.CompoundControl.Type
      • javax.sound.sampled.EnumControl.Type
      • javax.sound.sampled.FloatControl.Type
    • java.util.EventObject (implements java.io.Serializable)
      • javax.sound.sampled.LineEvent
    • java.io.InputStream (implements java.io.Closeable)
      • javax.sound.sampled.AudioInputStream
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
      • javax.sound.sampled.Port.Info
    • javax.sound.sampled.LineEvent.Type
    • javax.sound.sampled.Mixer.Info
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.sound.sampled.AudioPermission
    • javax.sound.sampled.ReverbType
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.sound.sampled.LineUnavailableException
        • javax.sound.sampled.UnsupportedAudioFileException

Interface Hierarchy

  • java.lang.AutoCloseable
    • javax.sound.sampled.Line
      • javax.sound.sampled.DataLine
        • javax.sound.sampled.Clip
        • javax.sound.sampled.SourceDataLine
        • javax.sound.sampled.TargetDataLine
      • javax.sound.sampled.Mixer
      • javax.sound.sampled.Port
  • java.util.EventListener
    • javax.sound.sampled.LineListener
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

MniTbk=s"""l>ssoriin"


Line

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface Line

  • All Superinterfaces:
    AutoCloseable
    All Known Subinterfaces:
    Clip, DataLine, Mixer, Port, SourceDataLine, TargetDataLine

    public interface Line
extends AutoCloseable
    The Line interface represents a mono or multi-channel audio feed. A line is an element of the digital audio "pipeline," such as a mixer, an input or output port, or a data path into or out of a mixer.

    A line can have controls, such as gain, pan, and reverb. The controls themselves are instances of classes that extend the base Control class. The Line interface provides two accessor methods for obtaining the line's controls: getControls returns the entire set, and getControl returns a single control of specified type.

    Lines exist in various states at different times. When a line opens, it reserves system resources for itself, and when it closes, these resources are freed for other objects or applications. The isOpen() method lets you discover whether a line is open or closed. An open line need not be processing data, however. Such processing is typically initiated by subinterface methods such as SourceDataLine.write and TargetDataLine.read.

    You can register an object to receive notifications whenever the line's state changes. The object must implement the LineListener interface, which consists of the single method update. This method will be invoked when a line opens and closes (and, if it's a DataLine, when it starts and stops).

    An object can be registered to listen to multiple lines. The event it receives in its update method will specify which line created the event, what type of event it was (OPEN, CLOSE, START, or STOP), and how many sample frames the line had processed at the time the event occurred.

    Certain line operations, such as open and close, can generate security exceptions if invoked by unprivileged code when the line is a shared audio resource.

    从以下版本开始：
    1.3
    另请参见：
    LineEvent

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Line.Info
      A Line.Info object contains information about a line.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLineListener(LineListener listener)
      Adds a listener to this line.
      void close()
      Closes the line, indicating that any system resources in use by the line can be released.
      Control getControl(Control.Type control)
      Obtains a control of the specified type, if there is any.
      Control[] getControls()
      Obtains the set of controls associated with this line.
      Line.Info getLineInfo()
      Obtains the Line.Info object describing this line.
      boolean isControlSupported(Control.Type control)
      Indicates whether the line supports a control of the specified type.
      boolean isOpen()
      Indicates whether the line is open, meaning that it has reserved system resources and is operational, although it might not currently be playing or capturing sound.
      void open()
      Opens the line, indicating that it should acquire any required system resources and become operational.
      void removeLineListener(LineListener listener)
      Removes the specified listener from this line's list of listeners.

    • 方法详细信息

      • getLineInfo

        Line.Info getLineInfo()
        Obtains the Line.Info object describing this line.
        返回：
        description of the line

      • open

        void open()
          throws LineUnavailableException
        Opens the line, indicating that it should acquire any required system resources and become operational. If this operation succeeds, the line is marked as open, and an OPEN event is dispatched to the line's listeners.

        Note that some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in an LineUnavailableException.

        Some types of lines have configurable properties that may affect resource allocation. For example, a DataLine must be opened with a particular format and buffer size. Such lines should provide a mechanism for configuring these properties, such as an additional open method or methods which allow an application to specify the desired settings.

        This method takes no arguments, and opens the line with the current settings. For SourceDataLine and TargetDataLine objects, this means that the line is opened with default settings. For a Clip, however, the buffer size is determined when data is loaded. Since this method does not allow the application to specify any data to load, an IllegalArgumentException is thrown. Therefore, you should instead use one of the open methods provided in the Clip interface to load data into the Clip.

        For DataLine's, if the DataLine.Info object which was used to retrieve the line, specifies at least one fully qualified audio format, the last one will be used as the default format.

        抛出：
        IllegalArgumentException - if this method is called on a Clip instance.
        LineUnavailableException - if the line cannot be opened due to resource restrictions.
        SecurityException - if the line cannot be opened due to security restrictions.
        另请参见：
        close(), isOpen(), LineEvent, DataLine, Clip.open(AudioFormat, byte[], int, int), Clip.open(AudioInputStream)

      • close

        void close()
        Closes the line, indicating that any system resources in use by the line can be released. If this operation succeeds, the line is marked closed and a CLOSE event is dispatched to the line's listeners.
        指定者：
        close in interface AutoCloseable
        抛出：
        SecurityException - if the line cannot be closed due to security restrictions.
        另请参见：
        open(), isOpen(), LineEvent

      • isOpen

        boolean isOpen()
        Indicates whether the line is open, meaning that it has reserved system resources and is operational, although it might not currently be playing or capturing sound.
        返回：
        true if the line is open, otherwise false
        另请参见：
        open(), close()

      • getControls

        Control[] getControls()
        Obtains the set of controls associated with this line. Some controls may only be available when the line is open. If there are no controls, this method returns an array of length 0.
        返回：
        the array of controls
        另请参见：
        getControl(javax.sound.sampled.Control.Type)

      • isControlSupported

        boolean isControlSupported(Control.Type control)
        Indicates whether the line supports a control of the specified type. Some controls may only be available when the line is open.
        参数：
        control - the type of the control for which support is queried
        返回：
        true if at least one control of the specified type is supported, otherwise false.

      • getControl

        Control getControl(Control.Type control)
        Obtains a control of the specified type, if there is any. Some controls may only be available when the line is open.
        参数：
        control - the type of the requested control
        返回：
        a control of the specified type
        抛出：
        IllegalArgumentException - if a control of the specified type is not supported
        另请参见：
        getControls(), isControlSupported(Control.Type control)

      • addLineListener

        void addLineListener(LineListener listener)
        Adds a listener to this line. Whenever the line's status changes, the listener's update() method is called with a LineEvent object that describes the change.
        参数：
        listener - the object to add as a listener to this line
        另请参见：
        removeLineListener(javax.sound.sampled.LineListener), LineListener.update(javax.sound.sampled.LineEvent), LineEvent

      • removeLineListener

        void removeLineListener(LineListener listener)
        Removes the specified listener from this line's list of listeners.
        参数：
        listener - listener to remove
        另请参见：
        addLineListener(javax.sound.sampled.LineListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rttxrxuhlmu gge/.


Line.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 Line.Info

  • java.lang.Object
    • javax.sound.sampled.Line.Info
  • 直接已知子类：
    DataLine.Info, Port.Info
    Enclosing interface:
    Line

    public static class Line.Info
extends Object
    A Line.Info object contains information about a line. The only information provided by Line.Info itself is the Java class of the line. A subclass of Line.Info adds other kinds of information about the line. This additional information depends on which Line subinterface is implemented by the kind of line that the Line.Info subclass describes.

    A Line.Info can be retrieved using various methods of the Line, Mixer, and AudioSystem interfaces. Other such methods let you pass a Line.Info as an argument, to learn whether lines matching the specified configuration are available and to obtain them.

    从以下版本开始：
    1.3
    另请参见：
    Line.getLineInfo(),
Mixer.getSourceLineInfo(),
Mixer.getTargetLineInfo(),
Mixer.getLine(Line.Info),
Mixer.getSourceLineInfo(Line.Info),
Mixer.getTargetLineInfo(Line.Info),
Mixer.isLineSupported(Line.Info),
AudioSystem.getLine(Line.Info),
AudioSystem.getSourceLineInfo(Line.Info),
AudioSystem.getTargetLineInfo(Line.Info),
AudioSystem.isLineSupported(Line.Info)

    • 构造方法摘要

      Constructors
      构造方法与描述
      Line.Info(类<?> lineClass)
      Constructs an info object that describes a line of the specified class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<?> getLineClass()
      Obtains the class of the line that this Line.Info object describes.
      boolean matches(Line.Info info)
      Indicates whether the specified info object matches this one.
      String toString()
      Obtains a textual description of the line info.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Line.Info

        public Line.Info(类<?> lineClass)
        Constructs an info object that describes a line of the specified class. This constructor is typically used by an application to describe a desired line.
        参数：
        lineClass - the class of the line that the new Line.Info object describes

    • 方法详细信息

      • getLineClass

        public 类<?> getLineClass()
        Obtains the class of the line that this Line.Info object describes.
        返回：
        the described line's class

      • matches

        public boolean matches(Line.Info info)
        Indicates whether the specified info object matches this one. To match, the specified object must be identical to or a special case of this one. The specified info object must be either an instance of the same class as this one, or an instance of a sub-type of this one. In addition, the attributes of the specified object must be compatible with the capabilities of this one. Specifically, the routing configuration for the specified info object must be compatible with that of this one. Subclasses may add other criteria to determine whether the two objects match.
        参数：
        info - the info object which is being compared to this one
        返回：
        true if the specified object matches this one, false otherwise

      • toString

        public String toString()
        Obtains a textual description of the line info.
        重载：
        toString in class Object
        返回：
        a string description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ehmudxndxa//xaa."<


LineEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 LineEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.sound.sampled.LineEvent
  • 所有已实现的接口：
    Serializable

    public class LineEvent
extends EventObject
    The LineEvent class encapsulates information that a line sends its listeners whenever the line opens, closes, starts, or stops. Each of these four state changes is represented by a corresponding type of event. A listener receives the event as a parameter to its update method. By querying the event, the listener can learn the type of event, the line responsible for the event, and how much data the line had processed when the event occurred.

    Although this class implements Serializable, attempts to serialize a LineEvent object will fail.

    从以下版本开始：
    1.3
    另请参见：
    Line, LineListener.update(javax.sound.sampled.LineEvent)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  LineEvent.Type
      The LineEvent.Type inner class identifies what kind of event occurred on a line.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      LineEvent(Line line, LineEvent.Type type, long position)
      Constructs a new event of the specified type, originating from the specified line.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      long getFramePosition()
      Obtains the position in the line's audio data when the event occurred, expressed in sample frames.
      Line getLine()
      Obtains the audio line that is the source of this event.
      LineEvent.Type getType()
      Obtains the event's type.
      String toString()
      Obtains a string representation of the event.

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LineEvent

        public LineEvent(Line line,
         LineEvent.Type type,
         long position)
        Constructs a new event of the specified type, originating from the specified line.
        参数：
        line - the source of this event
        type - the event type (OPEN, CLOSE, START, or STOP)
        position - the number of sample frames that the line had already processed when the event occurred, or AudioSystem.NOT_SPECIFIED
        抛出：
        IllegalArgumentException - if line is null.

    • 方法详细信息

      • getLine

        public final Line getLine()
        Obtains the audio line that is the source of this event.
        返回：
        the line responsible for this event

      • getType

        public final LineEvent.Type getType()
        Obtains the event's type.
        返回：
        this event's type (LineEvent.Type.OPEN, LineEvent.Type.CLOSE, LineEvent.Type.START, or LineEvent.Type.STOP)

      • getFramePosition

        public final long getFramePosition()
        Obtains the position in the line's audio data when the event occurred, expressed in sample frames. For example, if a source line had already played back 14 sample frames at the time it was paused, the pause event would report the line's position as 14. The next frame to be processed would be frame number 14 using zero-based numbering, or 15 using one-based numbering.

        Note that this field is relevant only to certain events generated by data lines, such as START and STOP. For events generated by lines that do not count sample frames, and for any other events for which this value is not known, the position value should be AudioSystem.NOT_SPECIFIED.

        返回：
        the line's position as a sample frame number

      • toString

        public String toString()
        Obtains a string representation of the event. The contents of the string may vary between implementations of Java Sound.
        重载：
        toString in class EventObject
        返回：
        a string describing the event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

colLmlpldn//dnnx/ /.=aj/.e/ <>dsss


LineEvent.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 LineEvent.Type

  • java.lang.Object
    • javax.sound.sampled.LineEvent.Type
  • 封闭类：
    LineEvent

    public static class LineEvent.Type
extends Object
    The LineEvent.Type inner class identifies what kind of event occurred on a line. Static instances are provided for the common types (OPEN, CLOSE, START, and STOP).
    另请参见：
    LineEvent.getType()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static LineEvent.Type CLOSE
      A type of event that is sent when a line closes, freeing the system resources it had obtained when it was opened.
      static LineEvent.Type OPEN
      A type of event that is sent when a line opens, reserving system resources for itself.
      static LineEvent.Type START
      A type of event that is sent when a line begins to engage in active input or output of audio data in response to a start request.
      static LineEvent.Type STOP
      A type of event that is sent when a line ceases active input or output of audio data in response to a stop request, or because the end of media has been reached.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected LineEvent.Type(String name)
      Constructs a new event type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Indicates whether the specified object is equal to this event type, returning true if the objects are identical.
      int hashCode()
      Finalizes the hashcode method.
      String toString()
      Returns the type name as the string representation.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OPEN

        public static final LineEvent.Type OPEN
        A type of event that is sent when a line opens, reserving system resources for itself.
        另请参见：
        CLOSE, Line.open()

      • CLOSE

        public static final LineEvent.Type CLOSE
        A type of event that is sent when a line closes, freeing the system resources it had obtained when it was opened.
        另请参见：
        OPEN, Line.close()

      • START

        public static final LineEvent.Type START
        A type of event that is sent when a line begins to engage in active input or output of audio data in response to a start request.
        另请参见：
        STOP, DataLine.start()

      • STOP

        public static final LineEvent.Type STOP
        A type of event that is sent when a line ceases active input or output of audio data in response to a stop request, or because the end of media has been reached.
        另请参见：
        START, DataLine.stop()

    • 构造方法详细信息

      • LineEvent.Type

        protected LineEvent.Type(String name)
        Constructs a new event type.
        参数：
        name - name of the type

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Indicates whether the specified object is equal to this event type, returning true if the objects are identical.
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare
        返回：
        true if this event type is the same as obj; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashcode method.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns the type name as the string representation.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lloit>d">kcLLkcc=u u/maa� " //p.dpul


LineListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface LineListener

  • All Superinterfaces:
    EventListener

    public interface LineListener
extends EventListener
    Instances of classes that implement the LineListener interface can register to receive events when a line's status changes.
    从以下版本开始：
    1.3
    另请参见：
    Line, Line.addLineListener(javax.sound.sampled.LineListener), Line.removeLineListener(javax.sound.sampled.LineListener), LineEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void update(LineEvent event)
      Informs the listener that a line's state has changed.

    • 方法详细信息

      • update

        void update(LineEvent event)
        Informs the listener that a line's state has changed. The listener can then invoke LineEvent methods to obtain information about the event.
        参数：
        event - a line event that describes the change
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C/oc><< << //< <.hhdohsahoaovv l<


LineUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 LineUnavailableException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.sound.sampled.LineUnavailableException
  • 所有已实现的接口：
    Serializable

    public class LineUnavailableException
extends Exception
    A LineUnavailableException is an exception indicating that a line cannot be opened because it is unavailable. This situation arises most commonly when a requested line is already in use by another application.
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      LineUnavailableException()
      Constructs a LineUnavailableException that has null as its error detail message.
      LineUnavailableException(String message)
      Constructs a LineUnavailableException that has the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LineUnavailableException

        public LineUnavailableException()
        Constructs a LineUnavailableException that has null as its error detail message.

      • LineUnavailableException

        public LineUnavailableException(String message)
        Constructs a LineUnavailableException that has the specified detail message.
        参数：
        message - a string containing the error detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

E&blcls鵤ll<-PP#)eddcscaf>a /</


Mixer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface Mixer

  • All Superinterfaces:
    AutoCloseable, Line

    public interface Mixer
extends Line
    A mixer is an audio device with one or more lines. It need not be designed for mixing audio signals. A mixer that actually mixes audio has multiple input (source) lines and at least one output (target) line. The former are often instances of classes that implement SourceDataLine, and the latter, TargetDataLine. Port objects, too, are either source lines or target lines. A mixer can accept prerecorded, loopable sound as input, by having some of its source lines be instances of objects that implement the Clip interface.

    Through methods of the Line interface, which Mixer extends, a mixer might provide a set of controls that are global to the mixer. For example, the mixer can have a master gain control. These global controls are distinct from the controls belonging to each of the mixer's individual lines.

    Some mixers, especially those with internal digital mixing capabilities, may provide additional capabilities by implementing the DataLine interface.

    A mixer can support synchronization of its lines. When one line in a synchronized group is started or stopped, the other lines in the group automatically start or stop simultaneously with the explicitly affected one.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Mixer.Info
      The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Line getLine(Line.Info info)
      Obtains a line that is available for use and that matches the description in the specified Line.Info object.
      int getMaxLines(Line.Info info)
      Obtains the approximate maximum number of lines of the requested type that can be open simultaneously on the mixer.
      Mixer.Info getMixerInfo()
      Obtains information about this mixer, including the product's name, version, vendor, etc.
      Line.Info[] getSourceLineInfo()
      Obtains information about the set of source lines supported by this mixer.
      Line.Info[] getSourceLineInfo(Line.Info info)
      Obtains information about source lines of a particular type supported by the mixer.
      Line[] getSourceLines()
      Obtains the set of all source lines currently open to this mixer.
      Line.Info[] getTargetLineInfo()
      Obtains information about the set of target lines supported by this mixer.
      Line.Info[] getTargetLineInfo(Line.Info info)
      Obtains information about target lines of a particular type supported by the mixer.
      Line[] getTargetLines()
      Obtains the set of all target lines currently open from this mixer.
      boolean isLineSupported(Line.Info info)
      Indicates whether the mixer supports a line (or lines) that match the specified Line.Info object.
      boolean isSynchronizationSupported(Line[] lines, boolean maintainSync)
      Reports whether this mixer supports synchronization of the specified set of lines.
      void synchronize(Line[] lines, boolean maintainSync)
      Synchronizes two or more lines.
      void unsynchronize(Line[] lines)
      Releases synchronization for the specified lines.

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

    • 方法详细信息

      • getMixerInfo

        Mixer.Info getMixerInfo()
        Obtains information about this mixer, including the product's name, version, vendor, etc.
        返回：
        a mixer info object that describes this mixer
        另请参见：
        Mixer.Info

      • getSourceLineInfo

        Line.Info[] getSourceLineInfo()
        Obtains information about the set of source lines supported by this mixer. Some source lines may only be available when this mixer is open.
        返回：
        array of Line.Info objects representing source lines for this mixer. If no source lines are supported, an array of length 0 is returned.

      • getTargetLineInfo

        Line.Info[] getTargetLineInfo()
        Obtains information about the set of target lines supported by this mixer. Some target lines may only be available when this mixer is open.
        返回：
        array of Line.Info objects representing target lines for this mixer. If no target lines are supported, an array of length 0 is returned.

      • getSourceLineInfo

        Line.Info[] getSourceLineInfo(Line.Info info)
        Obtains information about source lines of a particular type supported by the mixer. Some source lines may only be available when this mixer is open.
        参数：
        info - a Line.Info object describing lines about which information is queried
        返回：
        an array of Line.Info objects describing source lines matching the type requested. If no matching source lines are supported, an array of length 0 is returned.

      • getTargetLineInfo

        Line.Info[] getTargetLineInfo(Line.Info info)
        Obtains information about target lines of a particular type supported by the mixer. Some target lines may only be available when this mixer is open.
        参数：
        info - a Line.Info object describing lines about which information is queried
        返回：
        an array of Line.Info objects describing target lines matching the type requested. If no matching target lines are supported, an array of length 0 is returned.

      • isLineSupported

        boolean isLineSupported(Line.Info info)
        Indicates whether the mixer supports a line (or lines) that match the specified Line.Info object. Some lines may only be supported when this mixer is open.
        参数：
        info - describes the line for which support is queried
        返回：
        true if at least one matching line is supported, false otherwise

      • getLine

        Line getLine(Line.Info info)
             throws LineUnavailableException
        Obtains a line that is available for use and that matches the description in the specified Line.Info object.

        If a DataLine is requested, and info is an instance of DataLine.Info specifying at least one fully qualified audio format, the last one will be used as the default format of the returned DataLine.

        参数：
        info - describes the desired line
        抛出：
        LineUnavailableException - if a matching line is not available due to resource restrictions
        IllegalArgumentException - if this mixer does not support any lines matching the description
        SecurityException - if a matching line is not available due to security restrictions

      • getMaxLines

        int getMaxLines(Line.Info info)
        Obtains the approximate maximum number of lines of the requested type that can be open simultaneously on the mixer. Certain types of mixers do not have a hard bound and may allow opening more lines. Since certain lines are a shared resource, a mixer may not be able to open the maximum number of lines if another process has opened lines of this mixer. The requested type is any line that matches the description in the provided Line.Info object. For example, if the info object represents a speaker port, and the mixer supports exactly one speaker port, this method should return 1. If the info object represents a source data line and the mixer supports the use of 32 source data lines simultaneously, the return value should be 32. If there is no limit, this function returns AudioSystem.NOT_SPECIFIED.
        参数：
        info - a Line.Info that describes the line for which the number of supported instances is queried
        返回：
        the maximum number of matching lines supported, or AudioSystem.NOT_SPECIFIED

      • getSourceLines

        Line[] getSourceLines()
        Obtains the set of all source lines currently open to this mixer.
        返回：
        the source lines currently open to the mixer. If no source lines are currently open to this mixer, an array of length 0 is returned.
        抛出：
        SecurityException - if the matching lines are not available due to security restrictions

      • getTargetLines

        Line[] getTargetLines()
        Obtains the set of all target lines currently open from this mixer.
        返回：
        target lines currently open from the mixer. If no target lines are currently open from this mixer, an array of length 0 is returned.
        抛出：
        SecurityException - if the matching lines are not available due to security restrictions

      • synchronize

        void synchronize(Line[] lines,
               boolean maintainSync)
        Synchronizes two or more lines. Any subsequent command that starts or stops audio playback or capture for one of these lines will exert the same effect on the other lines in the group, so that they start or stop playing or capturing data simultaneously.
        参数：
        lines - the lines that should be synchronized
        maintainSync - true if the synchronization must be precisely maintained (i.e., the synchronization must be sample-accurate) at all times during operation of the lines , or false if precise synchronization is required only during start and stop operations
        抛出：
        IllegalArgumentException - if the lines cannot be synchronized. This may occur if the lines are of different types or have different formats for which this mixer does not support synchronization, or if all lines specified do not belong to this mixer.

      • unsynchronize

        void unsynchronize(Line[] lines)
        Releases synchronization for the specified lines. The array must be identical to one for which synchronization has already been established; otherwise an exception may be thrown. However, null may be specified, in which case all currently synchronized lines that belong to this mixer are unsynchronized.
        参数：
        lines - the synchronized lines for which synchronization should be released, or null for all this mixer's synchronized lines
        抛出：
        IllegalArgumentException - if the lines cannot be unsynchronized. This may occur if the argument specified does not exactly match a set of lines for which synchronization has already been established.

      • isSynchronizationSupported

        boolean isSynchronizationSupported(Line[] lines,
                                 boolean maintainSync)
        Reports whether this mixer supports synchronization of the specified set of lines.
        参数：
        lines - the set of lines for which synchronization support is queried
        maintainSync - true if the synchronization must be precisely maintained (i.e., the synchronization must be sample-accurate) at all times during operation of the lines , or false if precise synchronization is required only during start and stop operations
        返回：
        true if the lines can be synchronized, false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/sver踊 龆:�


Mixer.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 Mixer.Info

  • java.lang.Object
    • javax.sound.sampled.Mixer.Info
  • Enclosing interface:
    Mixer

    public static class Mixer.Info
extends Object
    The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description. This information may be retrieved through the getMixerInfo method of the Mixer interface.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Mixer.Info(String name, String vendor, String description, String version)
      Constructs a mixer's info object, passing it the given textual information.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Indicates whether two info objects are equal, returning true if they are identical.
      String getDescription()
      Obtains the description of the mixer.
      String getName()
      Obtains the name of the mixer.
      String getVendor()
      Obtains the vendor of the mixer.
      String getVersion()
      Obtains the version of the mixer.
      int hashCode()
      Finalizes the hashcode method.
      String toString()
      Provides a string representation of the mixer info.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Mixer.Info

        protected Mixer.Info(String name,
          String vendor,
          String description,
          String version)
        Constructs a mixer's info object, passing it the given textual information.
        参数：
        name - the name of the mixer
        vendor - the company who manufactures or creates the hardware or software mixer
        描述 - descriptive text about the mixer
        version - version information for the mixer

    • 方法详细信息

      • equals

        public final boolean equals(Object obj)
        Indicates whether two info objects are equal, returning true if they are identical.
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare this info object
        返回：
        true if this info object is the same as the obj argument; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashcode method.
        重载：
        hashCode in class Object
        返回：
        the hashcode for this object
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • getName

        public final String getName()
        Obtains the name of the mixer.
        返回：
        a string that names the mixer

      • getVendor

        public final String getVendor()
        Obtains the vendor of the mixer.
        返回：
        a string that names the mixer's vendor

      • getDescription

        public final String getDescription()
        Obtains the description of the mixer.
        返回：
        a textual description of the mixer

      • getVersion

        public final String getVersion()
        Obtains the version of the mixer.
        返回：
        textual version information for the mixer

      • toString

        public final String toString()
        Provides a string representation of the mixer info.
        重载：
        toString in class Object
        返回：
        a string describing the info object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gfeba[f>[fnoofnnimvv>e/a.=ra/.ree >eTnTLat/


Port

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.sound.sampled

Interface Port

  • All Superinterfaces:
    AutoCloseable, Line

    public interface Port
extends Line
    Ports are simple lines for input or output of audio to or from audio devices. Common examples of ports that act as source lines (mixer inputs) include the microphone, line input, and CD-ROM drive. Ports that act as target lines (mixer outputs) include the speaker, headphone, and line output. You can access port using a Port.Info object.
    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Port.Info
      The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer.

    • 方法摘要

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/nbanLnaL/i/u--csjji


Port.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 Port.Info

  • java.lang.Object
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.Port.Info
  • Enclosing interface:
    Port

    public static class Port.Info
extends Line.Info
    The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer. By definition, a port acts as either a source or a target to its mixer, but not both. (Audio input ports are sources; audio output ports are targets.)

    To learn what ports are available, you can retrieve port info objects through the getSourceLineInfo and getTargetLineInfo methods of the Mixer interface. Instances of the Port.Info class may also be constructed and used to obtain lines matching the parameters specified in the Port.Info object.

    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Port.Info COMPACT_DISC
      A type of port that gets audio from a CD-ROM drive.
      static Port.Info HEADPHONE
      A type of port that sends audio to a headphone jack.
      static Port.Info LINE_IN
      A type of port that gets audio from a line-level audio input jack.
      static Port.Info LINE_OUT
      A type of port that sends audio to a line-level audio output jack.
      static Port.Info MICROPHONE
      A type of port that gets audio from a built-in microphone or a microphone jack.
      static Port.Info SPEAKER
      A type of port that sends audio to a built-in speaker or a speaker jack.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Port.Info(类<?> lineClass, String name, boolean isSource)
      Constructs a port's info object from the information given.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Finalizes the equals method
      String getName()
      Obtains the name of the port.
      int hashCode()
      Finalizes the hashCode method
      boolean isSource()
      Indicates whether the port is a source or a target for its mixer.
      boolean matches(Line.Info info)
      Indicates whether this info object specified matches this one.
      String toString()
      Provides a String representation of the port.

      • 方法 - 继承于类 javax.sound.sampled.Line.Info

        getLineClass

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MICROPHONE

        public static final Port.Info MICROPHONE
        A type of port that gets audio from a built-in microphone or a microphone jack.

      • LINE_IN

        public static final Port.Info LINE_IN
        A type of port that gets audio from a line-level audio input jack.

      • COMPACT_DISC

        public static final Port.Info COMPACT_DISC
        A type of port that gets audio from a CD-ROM drive.

      • SPEAKER

        public static final Port.Info SPEAKER
        A type of port that sends audio to a built-in speaker or a speaker jack.

      • HEADPHONE

        public static final Port.Info HEADPHONE
        A type of port that sends audio to a headphone jack.

      • LINE_OUT

        public static final Port.Info LINE_OUT
        A type of port that sends audio to a line-level audio output jack.

    • 构造方法详细信息

      • Port.Info

        public Port.Info(类<?> lineClass,
         String name,
         boolean isSource)
        Constructs a port's info object from the information given. This constructor is typically used by an implementation of Java Sound to describe a supported line.
        参数：
        lineClass - the class of the port described by the info object.
        name - the string that names the port
        isSource - true if the port is a source port (such as a microphone), false if the port is a target port (such as a speaker).

    • 方法详细信息

      • getName

        public String getName()
        Obtains the name of the port.
        返回：
        the string that names the port

      • isSource

        public boolean isSource()
        Indicates whether the port is a source or a target for its mixer.
        返回：
        true if the port is a source port (such as a microphone), false if the port is a target port (such as a speaker).

      • matches

        public boolean matches(Line.Info info)
        Indicates whether this info object specified matches this one. To match, the match requirements of the superclass must be met and the types must be equal.
        重载：
        matches in class Line.Info
        参数：
        info - the info object for which the match is queried
        返回：
        true if the specified object matches this one, false otherwise

      • equals

        public final boolean equals(Object obj)
        Finalizes the equals method
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare.
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashCode method
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides a String representation of the port.
        重载：
        toString in class Line.Info
        返回：
        a string that describes the port
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cal < h > S<.clE/-rcrce�.= hr眅ip>crb.


ReverbType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled

类 ReverbType

  • java.lang.Object
    • javax.sound.sampled.ReverbType

  • public class ReverbType
extends Object
    The ReverbType class provides methods for accessing various reverberation settings to be applied to an audio signal.

    Reverberation simulates the reflection of sound off of the walls, ceiling, and floor of a room. Depending on the size of the room, and how absorbent or reflective the materials in the room's surfaces are, the sound might bounce around for a long time before dying away.

    The reverberation parameters provided by ReverbType consist of the delay time and intensity of early reflections, the delay time and intensity of late reflections, and an overall decay time. Early reflections are the initial individual low-order reflections of the direct signal off the surfaces in the room. The late Relections are the dense, high-order reflections that characterize the room's reverberation. The delay times for the start of these two reflection types give the listener a sense of the overall size and complexity of the room's shape and contents. The larger the room, the longer the reflection delay times. The early and late reflections' intensities define the gain (in decibels) of the reflected signals as compared to the direct signal. These intensities give the listener an impression of the absorptive nature of the surfaces and objects in the room. The decay time defines how long the reverberation takes to exponentially decay until it is no longer perceptible ("effective zero"). The larger and less absorbent the surfaces, the longer the decay time.

    The set of parameters defined here may not include all aspects of reverberation as specified by some systems. For example, the Midi Manufacturer's Association (MMA) has an Interactive Audio Special Interest Group (IASIG), which has a 3-D Working Group that has defined a Level 2 Spec (I3DL2). I3DL2 supports filtering of reverberation and control of reverb density. These properties are not included in the JavaSound 1.0 definition of a reverb control. In such a case, the implementing system should either extend the defined reverb control to include additional parameters, or else interpret the system's additional capabilities in a way that fits the model described here.

    If implementing JavaSound on a I3DL2-compliant device:

    • Filtering is disabled (high-frequency attenuations are set to 0.0 dB)
    • Density parameters are set to midway between minimum and maximum

    The following table shows what parameter values an implementation might use for a representative set of reverberation settings.

    Reverberation Types and Parameters

    Type | Decay Time (ms) | Late Intensity (dB) | Late Delay (ms) | Early Intensity (dB) | Early Delay(ms)
    Cavern | 2250 | -2.0 | 41.3 | -1.4 | 10.3
    Dungeon | 1600 | -1.0 | 10.3 | -0.7 | 2.6
    Garage | 900 | -6.0 | 14.7 | -4.0 | 3.9
    Acoustic Lab | 280 | -3.0 | 8.0 | -2.0 | 2.0
    Closet | 150 | -10.0 | 2.5 | -7.0 | 0.6
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ReverbType(String name, int earlyReflectionDelay, float earlyReflectionIntensity, int lateReflectionDelay, float lateReflectionIntensity, int decayTime)
      Constructs a new reverb type that has the specified reverberation parameter values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Indicates whether the specified object is equal to this reverb type, returning true if the objects are identical.
      int getDecayTime()
      Obtains the decay time, which is the amount of time over which the late reflections attenuate to effective zero.
      int getEarlyReflectionDelay()
      Returns the early reflection delay time in microseconds.
      float getEarlyReflectionIntensity()
      Returns the early reflection intensity in decibels.
      int getLateReflectionDelay()
      Returns the late reflection delay time in microseconds.
      float getLateReflectionIntensity()
      Returns the late reflection intensity in decibels.
      String getName()
      Obtains the name of this reverb type.
      int hashCode()
      Finalizes the hashcode method.
      String toString()
      Provides a String representation of the reverb type, including its name and its parameter settings.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ReverbType

        protected ReverbType(String name,
          int earlyReflectionDelay,
          float earlyReflectionIntensity,
          int lateReflectionDelay,
          float lateReflectionIntensity,
          int decayTime)
        Constructs a new reverb type that has the specified reverberation parameter values.
        参数：
        name - the name of the new reverb type, or a zero-length String
        earlyReflectionDelay - the new type's early reflection delay time in microseconds
        earlyReflectionIntensity - the new type's early reflection intensity in dB
        lateReflectionDelay - the new type's late reflection delay time in microseconds
        lateReflectionIntensity - the new type's late reflection intensity in dB
        decayTime - the new type's decay time in microseconds

    • 方法详细信息

      • getName

        public String getName()
        Obtains the name of this reverb type.
        返回：
        the name of this reverb type
        从以下版本开始：
        1.5

      • getEarlyReflectionDelay

        public final int getEarlyReflectionDelay()
        Returns the early reflection delay time in microseconds. This is the amount of time between when the direct signal is heard and when the first early reflections are heard.
        返回：
        early reflection delay time for this reverb type, in microseconds

      • getEarlyReflectionIntensity

        public final float getEarlyReflectionIntensity()
        Returns the early reflection intensity in decibels. This is the amplitude attenuation of the first early reflections relative to the direct signal.
        返回：
        early reflection intensity for this reverb type, in dB

      • getLateReflectionDelay

        public final int getLateReflectionDelay()
        Returns the late reflection delay time in microseconds. This is the amount of time between when the first early reflections are heard and when the first late reflections are heard.
        返回：
        late reflection delay time for this reverb type, in microseconds

      • getLateReflectionIntensity

        public final float getLateReflectionIntensity()
        Returns the late reflection intensity in decibels. This is the amplitude attenuation of the first late reflections relative to the direct signal.
        返回：
        late reflection intensity for this reverb type, in dB

      • getDecayTime

        public final int getDecayTime()
        Obtains the decay time, which is the amount of time over which the late reflections attenuate to effective zero. The effective zero value is implementation-dependent.
        返回：
        the decay time of the late reflections, in microseconds

      • equals

        public final boolean equals(Object obj)
        Indicates whether the specified object is equal to this reverb type, returning true if the objects are identical.
        重载：
        equals in class Object
        参数：
        obj - the reference object with which to compare
        返回：
        true if this reverb type is the same as obj; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()
        Finalizes the hashcode method.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public final String toString()
        Provides a String representation of the reverb type, including its name and its parameter settings. The exact contents of the string may vary between implementations of Java Sound.
        重载：
        toString in class Object
        返回：
        reverberation type name and description
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_ dmemhmdm#tod_tof>>bp<|


SourceDataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface SourceDataLine

  • All Superinterfaces:
    AutoCloseable, DataLine, Line

    public interface SourceDataLine
extends DataLine
    A source data line is a data line to which data may be written. It acts as a source to its mixer. An application writes audio bytes to a source data line, which handles the buffering of the bytes and delivers them to the mixer. The mixer may mix the samples with those from other sources and then deliver the mix to a target such as an output port (which may represent an audio output device on a sound card).

    Note that the naming convention for this interface reflects the relationship between the line and its mixer. From the perspective of an application, a source data line may act as a target for audio data.

    A source data line can be obtained from a mixer by invoking the getLine method of Mixer with an appropriate DataLine.Info object.

    The SourceDataLine interface provides a method for writing audio data to the data line's buffer. Applications that play or mix audio should write data to the source data line quickly enough to keep the buffer from underflowing (emptying), which could cause discontinuities in the audio that are perceived as clicks. Applications can use the available method defined in the DataLine interface to determine the amount of data currently queued in the data line's buffer. The amount of data which can be written to the buffer without blocking is the difference between the buffer size and the amount of queued data. If the delivery of audio output stops due to underflow, a STOP event is generated. A START event is generated when the audio output resumes.

    从以下版本开始：
    1.3
    另请参见：
    Mixer, DataLine, TargetDataLine

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.sound.sampled.DataLine

        DataLine.Info

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and suggested buffer size, causing the line to acquire any required system resources and become operational.
      int write(byte[] b, int off, int len)
      Writes audio data to the mixer via this source data line.

      • 方法 - 继承于接口 javax.sound.sampled.DataLine

        available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

    • 方法详细信息

      • open

        void open(AudioFormat format,
        int bufferSize)
          throws LineUnavailableException
        Opens the line with the specified format and suggested buffer size, causing the line to acquire any required system resources and become operational.

        The buffer size is specified in bytes, but must represent an integral number of sample frames. Invoking this method with a requested buffer size that does not meet this requirement may result in an IllegalArgumentException. The actual buffer size for the open line may differ from the requested buffer size. The value actually set may be queried by subsequently calling DataLine.getBufferSize().

        If this operation succeeds, the line is marked as open, and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line which is already open is illegal and may result in an IllegalStateException.

        Note that some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        format - the desired audio format
        bufferSize - the desired buffer size
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IllegalArgumentException - if the buffer size does not represent an integral number of sample frames, or if format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        open(AudioFormat),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

      • open

        void open(AudioFormat format)
          throws LineUnavailableException
        Opens the line with the specified format, causing the line to acquire any required system resources and become operational.

        The implementation chooses a buffer size, which is measured in bytes but which encompasses an integral number of sample frames. The buffer size that the system has chosen may be queried by subsequently calling DataLine.getBufferSize().

        If this operation succeeds, the line is marked as open, and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line which is already open is illegal and may result in an IllegalStateException.

        Note that some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        format - the desired audio format
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IllegalArgumentException - if format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        open(AudioFormat, int),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

      • write

        int write(byte[] b,
        int off,
        int len)
        Writes audio data to the mixer via this source data line. The requested number of bytes of data are read from the specified array, starting at the given offset into the array, and written to the data line's buffer. If the caller attempts to write more data than can currently be written (see available), this method blocks until the requested amount of data has been written. This applies even if the requested amount of data to write is greater than the data line's buffer size. However, if the data line is closed, stopped, or flushed before the requested amount has been written, the method no longer blocks, but returns the number of bytes written thus far.

        The number of bytes that can be written without blocking can be ascertained using the available method of the DataLine interface. (While it is guaranteed that this number of bytes can be written without blocking, there is no guarantee that attempts to write additional data will block.)

        The number of bytes to write must represent an integral number of sample frames, such that:

        [ bytes written ] % [frame size in bytes ] == 0

        The return value will always meet this requirement. A request to write a number of bytes representing a non-integral number of sample frames cannot be fulfilled and may result in an IllegalArgumentException.
        参数：
        b - a byte array containing data to be written to the data line
        len - the length, in bytes, of the valid data in the array (in other words, the requested amount of data to write, in bytes)
        off - the offset from the beginning of the array, in bytes
        返回：
        the number of bytes actually written
        抛出：
        IllegalArgumentException - if the requested number of bytes does not represent an integral number of sample frames, or if len is negative
        ArrayIndexOutOfBoundsException - if off is negative, or off+len is greater than the length of the array b.
        另请参见：
        TargetDataLine.read(byte[], int, int), DataLine.available()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osa/t/t/l//onlo.cooo


TargetDataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sound.sampled

Interface TargetDataLine

  • All Superinterfaces:
    AutoCloseable, DataLine, Line

    public interface TargetDataLine
extends DataLine
    A target data line is a type of DataLine from which audio data can be read. The most common example is a data line that gets its data from an audio capture device. (The device is implemented as a mixer that writes to the target data line.)

    Note that the naming convention for this interface reflects the relationship between the line and its mixer. From the perspective of an application, a target data line may act as a source for audio data.

    The target data line can be obtained from a mixer by invoking the getLine method of Mixer with an appropriate DataLine.Info object.

    The TargetDataLine interface provides a method for reading the captured data from the target data line's buffer.Applications that record audio should read data from the target data line quickly enough to keep the buffer from overflowing, which could cause discontinuities in the captured data that are perceived as clicks. Applications can use the available method defined in the DataLine interface to determine the amount of data currently queued in the data line's buffer. If the buffer does overflow, the oldest queued data is discarded and replaced by new data.

    从以下版本开始：
    1.3
    另请参见：
    Mixer, DataLine, SourceDataLine

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.sound.sampled.DataLine

        DataLine.Info

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and requested buffer size, causing the line to acquire any required system resources and become operational.
      int read(byte[] b, int off, int len)
      Reads audio data from the data line's input buffer.

      • 方法 - 继承于接口 javax.sound.sampled.DataLine

        available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop

      • 方法 - 继承于接口 javax.sound.sampled.Line

        addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

    • 方法详细信息

      • open

        void open(AudioFormat format,
        int bufferSize)
          throws LineUnavailableException
        Opens the line with the specified format and requested buffer size, causing the line to acquire any required system resources and become operational.

        The buffer size is specified in bytes, but must represent an integral number of sample frames. Invoking this method with a requested buffer size that does not meet this requirement may result in an IllegalArgumentException. The actual buffer size for the open line may differ from the requested buffer size. The value actually set may be queried by subsequently calling DataLine.getBufferSize()

        If this operation succeeds, the line is marked as open, and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line that is already open is illegal and may result in an IllegalStateException.

        Some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        format - the desired audio format
        bufferSize - the desired buffer size, in bytes.
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IllegalArgumentException - if the buffer size does not represent an integral number of sample frames, or if format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        open(AudioFormat),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

      • open

        void open(AudioFormat format)
          throws LineUnavailableException
        Opens the line with the specified format, causing the line to acquire any required system resources and become operational.

        The implementation chooses a buffer size, which is measured in bytes but which encompasses an integral number of sample frames. The buffer size that the system has chosen may be queried by subsequently calling DataLine.getBufferSize()

        If this operation succeeds, the line is marked as open, and an OPEN event is dispatched to the line's listeners.

        Invoking this method on a line that is already open is illegal and may result in an IllegalStateException.

        Some lines, once closed, cannot be reopened. Attempts to reopen such a line will always result in a LineUnavailableException.

        参数：
        format - the desired audio format
        抛出：
        LineUnavailableException - if the line cannot be opened due to resource restrictions
        IllegalArgumentException - if format is not fully specified or invalid
        IllegalStateException - if the line is already open
        SecurityException - if the line cannot be opened due to security restrictions
        另请参见：
        open(AudioFormat, int),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

      • read

        int read(byte[] b,
       int off,
       int len)
        Reads audio data from the data line's input buffer. The requested number of bytes is read into the specified array, starting at the specified offset into the array in bytes. This method blocks until the requested amount of data has been read. However, if the data line is closed, stopped, drained, or flushed before the requested amount has been read, the method no longer blocks, but returns the number of bytes read thus far.

        The number of bytes that can be read without blocking can be ascertained using the available method of the DataLine interface. (While it is guaranteed that this number of bytes can be read without blocking, there is no guarantee that attempts to read additional data will block.)

        The number of bytes to be read must represent an integral number of sample frames, such that:

        [ bytes read ] % [frame size in bytes ] == 0

        The return value will always meet this requirement. A request to read a number of bytes representing a non-integral number of sample frames cannot be fulfilled and may result in an IllegalArgumentException.
        参数：
        b - a byte array that will contain the requested input data when this method returns
        off - the offset from the beginning of the array, in bytes
        len - the requested number of bytes to read
        返回：
        the number of bytes actually read
        抛出：
        IllegalArgumentException - if the requested number of bytes does not represent an integral number of sample frames. or if len is negative.
        ArrayIndexOutOfBoundsException - if off is negative, or off+len is greater than the length of the array b.
        另请参见：
        SourceDataLine.write(byte[], int, int), DataLine.available()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&-nC CiCrC>ntr&st<&&>///u/ us>bulc�=N�


UnsupportedAudioFileException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sound.sampled

类 UnsupportedAudioFileException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.sound.sampled.UnsupportedAudioFileException
  • 所有已实现的接口：
    Serializable

    public class UnsupportedAudioFileException
extends Exception
    An UnsupportedAudioFileException is an exception indicating that an operation failed because a file did not contain valid data of a recognized file type and format.
    从以下版本开始：
    1.3
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnsupportedAudioFileException()
      Constructs a UnsupportedAudioFileException that has null as its error detail message.
      UnsupportedAudioFileException(String message)
      Constructs a UnsupportedAudioFileException that has the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnsupportedAudioFileException

        public UnsupportedAudioFileException()
        Constructs a UnsupportedAudioFileException that has null as its error detail message.

      • UnsupportedAudioFileException

        public UnsupportedAudioFileException(String message)
        Constructs a UnsupportedAudioFileException that has the specified detail message.
        参数：
        message - a string containing the error detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< ceeBmtBmtllmttie//sl muqe ya tssala.


Uses of Package javax.sound.sampled

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sound.sampled

  • Packages that use javax.sound.sampled
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.
  • Classes in javax.sound.sampled used by javax.sound.sampled
    类与描述
    AudioFileFormat
    An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.
    AudioFileFormat.Type
    An instance of the Type class represents one of the standard types of audio file.
    AudioFormat
    AudioFormat is the class that specifies a particular arrangement of data in a sound stream.
    AudioFormat.Encoding
    The Encoding class names the specific type of data representation used for an audio stream.
    AudioInputStream
    An audio input stream is an input stream with a specified audio format and length.
    BooleanControl.Type
    An instance of the BooleanControl.Type class identifies one kind of boolean control.
    Clip
    The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
    CompoundControl.Type
    An instance of the CompoundControl.Type inner class identifies one kind of compound control.
    Control
    Lines often have a set of controls, such as gain and pan, that affect the audio signal passing through the line.
    Control.Type
    An instance of the Type class represents the type of the control.
    DataLine
    DataLine adds media-related functionality to its superinterface, Line.
    EnumControl.Type
    An instance of the EnumControl.Type inner class identifies one kind of enumerated control.
    FloatControl.Type
    An instance of the FloatControl.Type inner class identifies one kind of float control.
    Line
    The Line interface represents a mono or multi-channel audio feed.
    Line.Info
    A Line.Info object contains information about a line.
    LineEvent
    The LineEvent class encapsulates information that a line sends its listeners whenever the line opens, closes, starts, or stops.
    LineEvent.Type
    The LineEvent.Type inner class identifies what kind of event occurred on a line.
    LineListener
    Instances of classes that implement the LineListener interface can register to receive events when a line's status changes.
    LineUnavailableException
    A LineUnavailableException is an exception indicating that a line cannot be opened because it is unavailable.
    Mixer
    A mixer is an audio device with one or more lines.
    Mixer.Info
    The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description.
    Port.Info
    The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer.
    SourceDataLine
    A source data line is a data line to which data may be written.
    TargetDataLine
    A target data line is a type of DataLine from which audio data can be read.
    UnsupportedAudioFileException
    An UnsupportedAudioFileException is an exception indicating that an operation failed because a file did not contain valid data of a recognized file type and format.
  • Classes in javax.sound.sampled used by javax.sound.sampled.spi
    类与描述
    AudioFileFormat
    An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.
    AudioFileFormat.Type
    An instance of the Type class represents one of the standard types of audio file.
    AudioFormat
    AudioFormat is the class that specifies a particular arrangement of data in a sound stream.
    AudioFormat.Encoding
    The Encoding class names the specific type of data representation used for an audio stream.
    AudioInputStream
    An audio input stream is an input stream with a specified audio format and length.
    Mixer
    A mixer is an audio device with one or more lines.
    Mixer.Info
    The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description.
    UnsupportedAudioFileException
    An UnsupportedAudioFileException is an exception indicating that an operation failed because a file did not contain valid data of a recognized file type and format.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.h/rlihil<<< /rrl


Uses of Class javax.sound.sampled.AudioFileFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioFileFormat

  • Packages that use AudioFileFormat
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of AudioFileFormat in javax.sound.sampled

      Methods in javax.sound.sampled that return AudioFileFormat
      修饰符与类型 方法与描述
      static AudioFileFormat AudioSystem.getAudioFileFormat(File file)
      Obtains the audio file format of the specified File.
      static AudioFileFormat AudioSystem.getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the provided input stream.
      static AudioFileFormat AudioSystem.getAudioFileFormat(URL url)
      Obtains the audio file format of the specified URL.

    • Uses of AudioFileFormat in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return AudioFileFormat
      修饰符与类型 方法与描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(File file)
      Obtains the audio file format of the File provided.
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the input stream provided.
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(URL url)
      Obtains the audio file format of the URL provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rann Dcal">


Uses of Class javax.sound.sampled.AudioFileFormat.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioFileFormat.Type

  • Packages that use AudioFileFormat.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of AudioFileFormat.Type in javax.sound.sampled

      Fields in javax.sound.sampled declared as AudioFileFormat.Type
      修饰符与类型 字段与描述
      static AudioFileFormat.Type AudioFileFormat.Type.AIFC
      Specifies an AIFF-C file.
      static AudioFileFormat.Type AudioFileFormat.Type.AIFF
      Specifies an AIFF file.
      static AudioFileFormat.Type AudioFileFormat.Type.AU
      Specifies an AU file.
      static AudioFileFormat.Type AudioFileFormat.Type.SND
      Specifies a SND file.
      static AudioFileFormat.Type AudioFileFormat.Type.WAVE
      Specifies a WAVE file.
      Methods in javax.sound.sampled that return AudioFileFormat.Type
      修饰符与类型 方法与描述
      static AudioFileFormat.Type[] AudioSystem.getAudioFileTypes()
      Obtains the file types for which file writing support is provided by the system.
      static AudioFileFormat.Type[] AudioSystem.getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that the system can write from the audio input stream specified.
      AudioFileFormat.Type AudioFileFormat.getType()
      Obtains the audio file type, such as WAVE or AU.
      Methods in javax.sound.sampled with parameters of type AudioFileFormat.Type
      修饰符与类型 方法与描述
      static boolean AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType)
      Indicates whether file writing support for the specified file type is provided by the system.
      static boolean AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
      static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the specified file type to the external file provided.
      static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the specified file type to the output stream provided.
      Constructors in javax.sound.sampled with parameters of type AudioFileFormat.Type
      构造方法与描述
      AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
      Constructs an audio file format object.
      AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
      Construct an audio file format object with a set of defined properties.
      AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
      Constructs an audio file format object.

    • Uses of AudioFileFormat.Type in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return AudioFileFormat.Type
      修饰符与类型 方法与描述
      abstract AudioFileFormat.Type[] AudioFileWriter.getAudioFileTypes()
      Obtains the file types for which file writing support is provided by this audio file writer.
      abstract AudioFileFormat.Type[] AudioFileWriter.getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that this audio file writer can write from the audio input stream specified.
      Methods in javax.sound.sampled.spi with parameters of type AudioFileFormat.Type
      修饰符与类型 方法与描述
      boolean AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType)
      Indicates whether file writing support for the specified file type is provided by this audio file writer.
      boolean AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
      abstract int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the file format indicated to the external file provided.
      abstract int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the file type indicated to the output stream provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ie/e"=tt m.t/."cr=.tl>n


Uses of Class javax.sound.sampled.AudioFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioFormat

  • Packages that use AudioFormat
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of AudioFormat in javax.sound.sampled

      Fields in javax.sound.sampled declared as AudioFormat
      修饰符与类型 字段与描述
      protected AudioFormat AudioInputStream.format
      The format of the audio data contained in the stream.
      Methods in javax.sound.sampled that return AudioFormat
      修饰符与类型 方法与描述
      AudioFormat AudioFileFormat.getFormat()
      Obtains the format of the audio data contained in the audio file.
      AudioFormat AudioInputStream.getFormat()
      Obtains the audio format of the sound data in this audio input stream.
      AudioFormat DataLine.getFormat()
      Obtains the current format (encoding, sample rate, number of channels, etc.) of the data line's audio data.
      AudioFormat[] DataLine.Info.getFormats()
      Obtains a set of audio formats supported by the data line.
      static AudioFormat[] AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.
      Methods in javax.sound.sampled with parameters of type AudioFormat
      修饰符与类型 方法与描述
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated format, by converting the provided audio input stream.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static AudioFormat.Encoding[] AudioSystem.getTargetEncodings(AudioFormat sourceFormat)
      Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.
      static AudioFormat[] AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.
      static boolean AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
      static boolean AudioSystem.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat)
      Indicates whether an audio input stream of a specified format can be obtained from an audio input stream of another specified format.
      boolean DataLine.Info.isFormatSupported(AudioFormat format)
      Indicates whether this data line supports a particular audio format.
      boolean AudioFormat.matches(AudioFormat format)
      Indicates whether this format matches the one specified.
      void TargetDataLine.open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void SourceDataLine.open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize)
      Opens the clip, meaning that it should acquire any required system resources and become operational.
      void TargetDataLine.open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and requested buffer size, causing the line to acquire any required system resources and become operational.
      void SourceDataLine.open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and suggested buffer size, causing the line to acquire any required system resources and become operational.
      Constructors in javax.sound.sampled with parameters of type AudioFormat
      构造方法与描述
      AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
      Constructs an audio file format object.
      AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
      Construct an audio file format object with a set of defined properties.
      AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
      Constructs an audio file format object.
      AudioInputStream(InputStream stream, AudioFormat format, long length)
      Constructs an audio input stream that has the requested format and length in sample frames, using audio data from the specified input stream.
      DataLine.Info(类<?> lineClass, AudioFormat format)
      Constructs a data line's info object from the specified information, which includes a single audio format.
      DataLine.Info(类<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
      Constructs a data line's info object from the specified information, which includes a set of supported audio formats and a range for the buffer size.
      DataLine.Info(类<?> lineClass, AudioFormat format, int bufferSize)
      Constructs a data line's info object from the specified information, which includes a single audio format and a desired buffer size.

    • Uses of AudioFormat in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return AudioFormat
      修饰符与类型 方法与描述
      abstract AudioFormat[] FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.
      Methods in javax.sound.sampled.spi with parameters of type AudioFormat
      修饰符与类型 方法与描述
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified format from the given audio input stream.
      abstract AudioFormat.Encoding[] FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat)
      Obtains the set of target format encodings supported by the format converter given a particular source format.
      abstract AudioFormat[] FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.
      boolean FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether the format converter supports conversion to a particular encoding from a particular format.
      boolean FormatConversionProvider.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat)
      Indicates whether the format converter supports conversion to one particular format from another.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.sound.sampled.AudioFormat.Encoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioFormat.Encoding

  • Packages that use AudioFormat.Encoding
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of AudioFormat.Encoding in javax.sound.sampled

      Fields in javax.sound.sampled declared as AudioFormat.Encoding
      修饰符与类型 字段与描述
      static AudioFormat.Encoding AudioFormat.Encoding.ALAW
      Specifies a-law encoded data.
      protected AudioFormat.Encoding AudioFormat.encoding
      The audio encoding technique used by this format.
      static AudioFormat.Encoding AudioFormat.Encoding.PCM_FLOAT
      Specifies floating-point PCM data.
      static AudioFormat.Encoding AudioFormat.Encoding.PCM_SIGNED
      Specifies signed, linear PCM data.
      static AudioFormat.Encoding AudioFormat.Encoding.PCM_UNSIGNED
      Specifies unsigned, linear PCM data.
      static AudioFormat.Encoding AudioFormat.Encoding.ULAW
      Specifies u-law encoded data.
      Methods in javax.sound.sampled that return AudioFormat.Encoding
      修饰符与类型 方法与描述
      AudioFormat.Encoding AudioFormat.getEncoding()
      Obtains the type of encoding for sounds in this format.
      static AudioFormat.Encoding[] AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding)
      Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.
      static AudioFormat.Encoding[] AudioSystem.getTargetEncodings(AudioFormat sourceFormat)
      Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.
      Methods in javax.sound.sampled with parameters of type AudioFormat.Encoding
      修饰符与类型 方法与描述
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.
      static AudioFormat.Encoding[] AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding)
      Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.
      static AudioFormat[] AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.
      static boolean AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
      Constructors in javax.sound.sampled with parameters of type AudioFormat.Encoding
      构造方法与描述
      AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian)
      Constructs an AudioFormat with the given parameters.
      AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
      Constructs an AudioFormat with the given parameters.

    • Uses of AudioFormat.Encoding in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return AudioFormat.Encoding
      修饰符与类型 方法与描述
      abstract AudioFormat.Encoding[] FormatConversionProvider.getSourceEncodings()
      Obtains the set of source format encodings from which format conversion services are provided by this provider.
      abstract AudioFormat.Encoding[] FormatConversionProvider.getTargetEncodings()
      Obtains the set of target format encodings to which format conversion services are provided by this provider.
      abstract AudioFormat.Encoding[] FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat)
      Obtains the set of target format encodings supported by the format converter given a particular source format.
      Methods in javax.sound.sampled.spi with parameters of type AudioFormat.Encoding
      修饰符与类型 方法与描述
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified encoding from the given audio input stream.
      abstract AudioFormat[] FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.
      boolean FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether the format converter supports conversion to a particular encoding from a particular format.
      boolean FormatConversionProvider.isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding)
      Indicates whether the format converter supports conversion from the specified source format encoding.
      boolean FormatConversionProvider.isTargetEncodingSupported(AudioFormat.Encoding targetEncoding)
      Indicates whether the format converter supports conversion to the specified target format encoding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ph;ne/-s il u;a r ls><> tvc


Uses of Class javax.sound.sampled.AudioInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioInputStream

  • Packages that use AudioInputStream
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of AudioInputStream in javax.sound.sampled

      Methods in javax.sound.sampled that return AudioInputStream
      修饰符与类型 方法与描述
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated format, by converting the provided audio input stream.
      static AudioInputStream AudioSystem.getAudioInputStream(File file)
      Obtains an audio input stream from the provided File.
      static AudioInputStream AudioSystem.getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the provided input stream.
      static AudioInputStream AudioSystem.getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.
      Methods in javax.sound.sampled with parameters of type AudioInputStream
      修饰符与类型 方法与描述
      static AudioFileFormat.Type[] AudioSystem.getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that the system can write from the audio input stream specified.
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.
      static AudioInputStream AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream of the indicated format, by converting the provided audio input stream.
      static boolean AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
      void Clip.open(AudioInputStream stream)
      Opens the clip with the format and audio data present in the provided audio input stream.
      static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the specified file type to the external file provided.
      static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the specified file type to the output stream provided.

    • Uses of AudioInputStream in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return AudioInputStream
      修饰符与类型 方法与描述
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified encoding from the given audio input stream.
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified format from the given audio input stream.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(File file)
      Obtains an audio input stream from the File provided.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the input stream provided.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.
      Methods in javax.sound.sampled.spi with parameters of type AudioInputStream
      修饰符与类型 方法与描述
      abstract AudioFileFormat.Type[] AudioFileWriter.getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that this audio file writer can write from the audio input stream specified.
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified encoding from the given audio input stream.
      abstract AudioInputStream FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified format from the given audio input stream.
      boolean AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
      abstract int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the file format indicated to the external file provided.
      abstract int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the file type indicated to the output stream provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xe.se="t iiimommrjlao"e"p


Uses of Class javax.sound.sampled.AudioPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioPermission

No usage of javax.sound.sampled.AudioPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.c.(tro>a<<


Uses of Class javax.sound.sampled.AudioSystem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.AudioSystem

No usage of javax.sound.sampled.AudioSystem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

- motsn>sl><<>g/s


Uses of Class javax.sound.sampled.BooleanControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.BooleanControl

No usage of javax.sound.sampled.BooleanControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>oair<> a<< 芿sotb


Uses of Class javax.sound.sampled.BooleanControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.BooleanControl.Type

  • Packages that use BooleanControl.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of BooleanControl.Type in javax.sound.sampled

      Fields in javax.sound.sampled declared as BooleanControl.Type
      修饰符与类型 字段与描述
      static BooleanControl.Type BooleanControl.Type.APPLY_REVERB
      Represents a control for whether reverberation is applied to a line.
      static BooleanControl.Type BooleanControl.Type.MUTE
      Represents a control for the mute status of a line.
      Constructors in javax.sound.sampled with parameters of type BooleanControl.Type
      构造方法与描述
      BooleanControl(BooleanControl.Type type, boolean initialValue)
      Constructs a new boolean control object with the given parameters.
      BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
      Constructs a new boolean control object with the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cx>dsx ot=lxs=t>/itt re


Uses of Class javax.sound.sampled.CompoundControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.CompoundControl

No usage of javax.sound.sampled.CompoundControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nhd ass=e"""i.ddi"t//


Uses of Class javax.sound.sampled.CompoundControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.CompoundControl.Type

  • Packages that use CompoundControl.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of CompoundControl.Type in javax.sound.sampled

      Constructors in javax.sound.sampled with parameters of type CompoundControl.Type
      构造方法与描述
      CompoundControl(CompoundControl.Type type, Control[] memberControls)
      Constructs a new compound control object with the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yt>xc


Uses of Class javax.sound.sampled.Control

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.Control

  • Packages that use Control
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Control in javax.sound.sampled

      Subclasses of Control in javax.sound.sampled
      修饰符与类型 类与描述
      class  BooleanControl
      A BooleanControl provides the ability to switch between two possible settings that affect a line's audio.
      class  CompoundControl
      A CompoundControl, such as a graphic equalizer, provides control over two or more related properties, each of which is itself represented as a Control.
      class  EnumControl
      A EnumControl provides control over a set of discrete possible values, each represented by an object.
      class  FloatControl
      A FloatControl object provides control over a range of floating-point values.
      Methods in javax.sound.sampled that return Control
      修饰符与类型 方法与描述
      Control Line.getControl(Control.Type control)
      Obtains a control of the specified type, if there is any.
      Control[] Line.getControls()
      Obtains the set of controls associated with this line.
      Control[] CompoundControl.getMemberControls()
      Returns the set of member controls that comprise the compound control.
      Constructors in javax.sound.sampled with parameters of type Control
      构造方法与描述
      CompoundControl(CompoundControl.Type type, Control[] memberControls)
      Constructs a new compound control object with the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kr/ ir.ua a=peanr縜asf/o


Uses of Class javax.sound.sampled.Control.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.Control.Type

  • Packages that use Control.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Control.Type in javax.sound.sampled

      Subclasses of Control.Type in javax.sound.sampled
      修饰符与类型 类与描述
      static class  BooleanControl.Type
      An instance of the BooleanControl.Type class identifies one kind of boolean control.
      static class  CompoundControl.Type
      An instance of the CompoundControl.Type inner class identifies one kind of compound control.
      static class  EnumControl.Type
      An instance of the EnumControl.Type inner class identifies one kind of enumerated control.
      static class  FloatControl.Type
      An instance of the FloatControl.Type inner class identifies one kind of float control.
      Methods in javax.sound.sampled that return Control.Type
      修饰符与类型 方法与描述
      Control.Type Control.getType()
      Obtains the control's type.
      Methods in javax.sound.sampled with parameters of type Control.Type
      修饰符与类型 方法与描述
      Control Line.getControl(Control.Type control)
      Obtains a control of the specified type, if there is any.
      boolean Line.isControlSupported(Control.Type control)
      Indicates whether the line supports a control of the specified type.
      Constructors in javax.sound.sampled with parameters of type Control.Type
      构造方法与描述
      Control(Control.Type type)
      Constructs a Control with the specified type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tlh>lsaant


Uses of Class javax.sound.sampled.DataLine.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.DataLine.Info

No usage of javax.sound.sampled.DataLine.Info
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eLr>Fir"=ccca>ss netr


Uses of Class javax.sound.sampled.EnumControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.EnumControl

No usage of javax.sound.sampled.EnumControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.sound.sampled.EnumControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.EnumControl.Type

  • Packages that use EnumControl.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of EnumControl.Type in javax.sound.sampled

      Fields in javax.sound.sampled declared as EnumControl.Type
      修饰符与类型 字段与描述
      static EnumControl.Type EnumControl.Type.REVERB
      Represents a control over a set of possible reverberation settings.
      Constructors in javax.sound.sampled with parameters of type EnumControl.Type
      构造方法与描述
      EnumControl(EnumControl.Type type, Object[] values, Object value)
      Constructs a new enumerated control object with the given parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssfgonf lsv<


Uses of Class javax.sound.sampled.FloatControl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.FloatControl

No usage of javax.sound.sampled.FloatControl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./. ypeo fffe llv.//l


Uses of Class javax.sound.sampled.FloatControl.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.FloatControl.Type

  • Packages that use FloatControl.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of FloatControl.Type in javax.sound.sampled

      Fields in javax.sound.sampled declared as FloatControl.Type
      修饰符与类型 字段与描述
      static FloatControl.Type FloatControl.Type.AUX_RETURN
      Represents a control for the auxiliary return gain on a line.
      static FloatControl.Type FloatControl.Type.AUX_SEND
      Represents a control for the auxiliary send gain on a line.
      static FloatControl.Type FloatControl.Type.BALANCE
      Represents a control for the relative balance of a stereo signal between two stereo speakers.
      static FloatControl.Type FloatControl.Type.MASTER_GAIN
      Represents a control for the overall gain on a line.
      static FloatControl.Type FloatControl.Type.PAN
      Represents a control for the relative pan (left-right positioning) of the signal.
      static FloatControl.Type FloatControl.Type.REVERB_RETURN
      Represents a control for the post-reverb gain on a line.
      static FloatControl.Type FloatControl.Type.REVERB_SEND
      Represents a control for the pre-reverb gain on a line.
      static FloatControl.Type FloatControl.Type.SAMPLE_RATE
      Represents a control that changes the sample rate of audio playback.
      static FloatControl.Type FloatControl.Type.VOLUME
      Represents a control for the volume on a line.
      Constructors in javax.sound.sampled with parameters of type FloatControl.Type
      构造方法与描述
      FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
      Constructs a new float control object with the given parameters.
      FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
      Constructs a new float control object with the given parameters
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sgl t>鵲uvt asd e>=sa


Uses of Class javax.sound.sampled.Line.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.Line.Info

  • Packages that use Line.Info
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Line.Info in javax.sound.sampled

      Subclasses of Line.Info in javax.sound.sampled
      修饰符与类型 类与描述
      static class  DataLine.Info
      Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines.
      static class  Port.Info
      The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer.
      Methods in javax.sound.sampled that return Line.Info
      修饰符与类型 方法与描述
      Line.Info Line.getLineInfo()
      Obtains the Line.Info object describing this line.
      Line.Info[] Mixer.getSourceLineInfo()
      Obtains information about the set of source lines supported by this mixer.
      static Line.Info[] AudioSystem.getSourceLineInfo(Line.Info info)
      Obtains information about all source lines of a particular type that are supported by the installed mixers.
      Line.Info[] Mixer.getSourceLineInfo(Line.Info info)
      Obtains information about source lines of a particular type supported by the mixer.
      Line.Info[] Mixer.getTargetLineInfo()
      Obtains information about the set of target lines supported by this mixer.
      static Line.Info[] AudioSystem.getTargetLineInfo(Line.Info info)
      Obtains information about all target lines of a particular type that are supported by the installed mixers.
      Line.Info[] Mixer.getTargetLineInfo(Line.Info info)
      Obtains information about target lines of a particular type supported by the mixer.
      Methods in javax.sound.sampled with parameters of type Line.Info
      修饰符与类型 方法与描述
      static Line AudioSystem.getLine(Line.Info info)
      Obtains a line that matches the description in the specified Line.Info object.
      Line Mixer.getLine(Line.Info info)
      Obtains a line that is available for use and that matches the description in the specified Line.Info object.
      int Mixer.getMaxLines(Line.Info info)
      Obtains the approximate maximum number of lines of the requested type that can be open simultaneously on the mixer.
      static Line.Info[] AudioSystem.getSourceLineInfo(Line.Info info)
      Obtains information about all source lines of a particular type that are supported by the installed mixers.
      Line.Info[] Mixer.getSourceLineInfo(Line.Info info)
      Obtains information about source lines of a particular type supported by the mixer.
      static Line.Info[] AudioSystem.getTargetLineInfo(Line.Info info)
      Obtains information about all target lines of a particular type that are supported by the installed mixers.
      Line.Info[] Mixer.getTargetLineInfo(Line.Info info)
      Obtains information about target lines of a particular type supported by the mixer.
      static boolean AudioSystem.isLineSupported(Line.Info info)
      Indicates whether the system supports any lines that match the specified Line.Info object.
      boolean Mixer.isLineSupported(Line.Info info)
      Indicates whether the mixer supports a line (or lines) that match the specified Line.Info object.
      boolean Port.Info.matches(Line.Info info)
      Indicates whether this info object specified matches this one.
      boolean Line.Info.matches(Line.Info info)
      Indicates whether the specified info object matches this one.
      boolean DataLine.Info.matches(Line.Info info)
      Determines whether the specified info object matches this one.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s8 l=opJ


Uses of Class javax.sound.sampled.LineEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.LineEvent

  • Packages that use LineEvent
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of LineEvent in javax.sound.sampled

      Methods in javax.sound.sampled with parameters of type LineEvent
      修饰符与类型 方法与描述
      void LineListener.update(LineEvent event)
      Informs the listener that a line's state has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toinLinlpeeesx.....xdefi/


Uses of Class javax.sound.sampled.LineEvent.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.LineEvent.Type

  • Packages that use LineEvent.Type
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of LineEvent.Type in javax.sound.sampled

      Fields in javax.sound.sampled declared as LineEvent.Type
      修饰符与类型 字段与描述
      static LineEvent.Type LineEvent.Type.CLOSE
      A type of event that is sent when a line closes, freeing the system resources it had obtained when it was opened.
      static LineEvent.Type LineEvent.Type.OPEN
      A type of event that is sent when a line opens, reserving system resources for itself.
      static LineEvent.Type LineEvent.Type.START
      A type of event that is sent when a line begins to engage in active input or output of audio data in response to a start request.
      static LineEvent.Type LineEvent.Type.STOP
      A type of event that is sent when a line ceases active input or output of audio data in response to a stop request, or because the end of media has been reached.
      Methods in javax.sound.sampled that return LineEvent.Type
      修饰符与类型 方法与描述
      LineEvent.Type LineEvent.getType()
      Obtains the event's type.
      Constructors in javax.sound.sampled with parameters of type LineEvent.Type
      构造方法与描述
      LineEvent(Line line, LineEvent.Type type, long position)
      Constructs a new event of the specified type, originating from the specified line.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>lu=/a.


Uses of Class javax.sound.sampled.LineUnavailableException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.LineUnavailableException

  • Packages that use LineUnavailableException
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of LineUnavailableException in javax.sound.sampled

      Methods in javax.sound.sampled that throw LineUnavailableException
      修饰符与类型 方法与描述
      static Clip AudioSystem.getClip()
      Obtains a clip that can be used for playing back an audio file or an audio stream.
      static Clip AudioSystem.getClip(Mixer.Info mixerInfo)
      Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.
      static Line AudioSystem.getLine(Line.Info info)
      Obtains a line that matches the description in the specified Line.Info object.
      Line Mixer.getLine(Line.Info info)
      Obtains a line that is available for use and that matches the description in the specified Line.Info object.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      void Line.open()
      Opens the line, indicating that it should acquire any required system resources and become operational.
      void TargetDataLine.open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void SourceDataLine.open(AudioFormat format)
      Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
      void Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize)
      Opens the clip, meaning that it should acquire any required system resources and become operational.
      void TargetDataLine.open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and requested buffer size, causing the line to acquire any required system resources and become operational.
      void SourceDataLine.open(AudioFormat format, int bufferSize)
      Opens the line with the specified format and suggested buffer size, causing the line to acquire any required system resources and become operational.
      void Clip.open(AudioInputStream stream)
      Opens the clip with the format and audio data present in the provided audio input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/assl\aai>./>=.


Uses of Class javax.sound.sampled.Mixer.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.Mixer.Info

  • Packages that use Mixer.Info
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of Mixer.Info in javax.sound.sampled

      Methods in javax.sound.sampled that return Mixer.Info
      修饰符与类型 方法与描述
      static Mixer.Info[] AudioSystem.getMixerInfo()
      Obtains an array of mixer info objects that represents the set of audio mixers that are currently installed on the system.
      Mixer.Info Mixer.getMixerInfo()
      Obtains information about this mixer, including the product's name, version, vendor, etc.
      Methods in javax.sound.sampled with parameters of type Mixer.Info
      修饰符与类型 方法与描述
      static Clip AudioSystem.getClip(Mixer.Info mixerInfo)
      Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.
      static Mixer AudioSystem.getMixer(Mixer.Info info)
      Obtains the requested audio mixer.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

    • Uses of Mixer.Info in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return Mixer.Info
      修饰符与类型 方法与描述
      abstract Mixer.Info[] MixerProvider.getMixerInfo()
      Obtains the set of info objects representing the mixer or mixers provided by this MixerProvider.
      Methods in javax.sound.sampled.spi with parameters of type Mixer.Info
      修饰符与类型 方法与描述
      abstract Mixer MixerProvider.getMixer(Mixer.Info info)
      Obtains an instance of the mixer represented by the info object.
      boolean MixerProvider.isMixerSupported(Mixer.Info info)
      Indicates whether the mixer provider supports the mixer represented by the specified mixer info object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r<>"l/ .aV�.//lepdde


Uses of Class javax.sound.sampled.Port.Info

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.Port.Info

  • Packages that use Port.Info
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Port.Info in javax.sound.sampled

      Fields in javax.sound.sampled declared as Port.Info
      修饰符与类型 字段与描述
      static Port.Info Port.Info.COMPACT_DISC
      A type of port that gets audio from a CD-ROM drive.
      static Port.Info Port.Info.HEADPHONE
      A type of port that sends audio to a headphone jack.
      static Port.Info Port.Info.LINE_IN
      A type of port that gets audio from a line-level audio input jack.
      static Port.Info Port.Info.LINE_OUT
      A type of port that sends audio to a line-level audio output jack.
      static Port.Info Port.Info.MICROPHONE
      A type of port that gets audio from a built-in microphone or a microphone jack.
      static Port.Info Port.Info.SPEAKER
      A type of port that sends audio to a built-in speaker or a speaker jack.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea/esutp/.ts


Uses of Class javax.sound.sampled.ReverbType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.ReverbType

No usage of javax.sound.sampled.ReverbType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nedr oft yyy"seeednPe


Uses of Class javax.sound.sampled.UnsupportedAudioFileException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.UnsupportedAudioFileException

  • Packages that use UnsupportedAudioFileException
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of UnsupportedAudioFileException in javax.sound.sampled

      Methods in javax.sound.sampled that throw UnsupportedAudioFileException
      修饰符与类型 方法与描述
      static AudioFileFormat AudioSystem.getAudioFileFormat(File file)
      Obtains the audio file format of the specified File.
      static AudioFileFormat AudioSystem.getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the provided input stream.
      static AudioFileFormat AudioSystem.getAudioFileFormat(URL url)
      Obtains the audio file format of the specified URL.
      static AudioInputStream AudioSystem.getAudioInputStream(File file)
      Obtains an audio input stream from the provided File.
      static AudioInputStream AudioSystem.getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the provided input stream.
      static AudioInputStream AudioSystem.getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.

    • Uses of UnsupportedAudioFileException in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that throw UnsupportedAudioFileException
      修饰符与类型 方法与描述
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(File file)
      Obtains the audio file format of the File provided.
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the input stream provided.
      abstract AudioFileFormat AudioFileReader.getAudioFileFormat(URL url)
      Obtains the audio file format of the URL provided.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(File file)
      Obtains an audio input stream from the File provided.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the input stream provided.
      abstract AudioInputStream AudioFileReader.getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uc>i/C"/d/.n<="t so


Uses of Interface javax.sound.sampled.Clip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.Clip

  • Packages that use Clip
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Clip in javax.sound.sampled

      Methods in javax.sound.sampled that return Clip
      修饰符与类型 方法与描述
      static Clip AudioSystem.getClip()
      Obtains a clip that can be used for playing back an audio file or an audio stream.
      static Clip AudioSystem.getClip(Mixer.Info mixerInfo)
      Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ctenassil >


Uses of Interface javax.sound.sampled.DataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.DataLine

  • Packages that use DataLine
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of DataLine in javax.sound.sampled

      Subinterfaces of DataLine in javax.sound.sampled
      修饰符与类型 Interface and Description
      interface  Clip
      The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
      interface  SourceDataLine
      A source data line is a data line to which data may be written.
      interface  TargetDataLine
      A target data line is a type of DataLine from which audio data can be read.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dni th , ycll/>)e osi


Uses of Interface javax.sound.sampled.Line

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.Line

  • Packages that use Line
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of Line in javax.sound.sampled

      Subinterfaces of Line in javax.sound.sampled
      修饰符与类型 Interface and Description
      interface  Clip
      The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
      interface  DataLine
      DataLine adds media-related functionality to its superinterface, Line.
      interface  Mixer
      A mixer is an audio device with one or more lines.
      interface  Port
      Ports are simple lines for input or output of audio to or from audio devices.
      interface  SourceDataLine
      A source data line is a data line to which data may be written.
      interface  TargetDataLine
      A target data line is a type of DataLine from which audio data can be read.
      Methods in javax.sound.sampled that return Line
      修饰符与类型 方法与描述
      Line LineEvent.getLine()
      Obtains the audio line that is the source of this event.
      static Line AudioSystem.getLine(Line.Info info)
      Obtains a line that matches the description in the specified Line.Info object.
      Line Mixer.getLine(Line.Info info)
      Obtains a line that is available for use and that matches the description in the specified Line.Info object.
      Line[] Mixer.getSourceLines()
      Obtains the set of all source lines currently open to this mixer.
      Line[] Mixer.getTargetLines()
      Obtains the set of all target lines currently open from this mixer.
      Methods in javax.sound.sampled with parameters of type Line
      修饰符与类型 方法与描述
      boolean Mixer.isSynchronizationSupported(Line[] lines, boolean maintainSync)
      Reports whether this mixer supports synchronization of the specified set of lines.
      void Mixer.synchronize(Line[] lines, boolean maintainSync)
      Synchronizes two or more lines.
      void Mixer.unsynchronize(Line[] lines)
      Releases synchronization for the specified lines.
      Constructors in javax.sound.sampled with parameters of type Line
      构造方法与描述
      LineEvent(Line line, LineEvent.Type type, long position)
      Constructs a new event of the specified type, originating from the specified line.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jCtee_Icvu蝒>mAe"broa�


Uses of Interface javax.sound.sampled.LineListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.LineListener

  • Packages that use LineListener
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of LineListener in javax.sound.sampled

      Methods in javax.sound.sampled with parameters of type LineListener
      修饰符与类型 方法与描述
      void Line.addLineListener(LineListener listener)
      Adds a listener to this line.
      void Line.removeLineListener(LineListener listener)
      Removes the specified listener from this line's list of listeners.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"omarys-uuualxxnsaoc>i j


Uses of Interface javax.sound.sampled.Mixer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.Mixer

  • Packages that use Mixer
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.
    javax.sound.sampled.spi
    Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

    • Uses of Mixer in javax.sound.sampled

      Methods in javax.sound.sampled that return Mixer
      修饰符与类型 方法与描述
      static Mixer AudioSystem.getMixer(Mixer.Info info)
      Obtains the requested audio mixer.

    • Uses of Mixer in javax.sound.sampled.spi

      Methods in javax.sound.sampled.spi that return Mixer
      修饰符与类型 方法与描述
      abstract Mixer MixerProvider.getMixer(Mixer.Info info)
      Obtains an instance of the mixer represented by the info object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Fuold.ss.ooovs""/


Uses of Interface javax.sound.sampled.Port

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.Port

No usage of javax.sound.sampled.Port
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"f eser eeehbmmt


Uses of Interface javax.sound.sampled.SourceDataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.SourceDataLine

  • Packages that use SourceDataLine
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of SourceDataLine in javax.sound.sampled

      Methods in javax.sound.sampled that return SourceDataLine
      修饰符与类型 方法与描述
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.
      static SourceDataLine AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b"or=nsR=i op-.ai--i


Uses of Interface javax.sound.sampled.TargetDataLine

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sound.sampled.TargetDataLine

  • Packages that use TargetDataLine
    软件包 描述
    javax.sound.sampled
    Provides interfaces and classes for capture, processing, and playback of sampled audio data.

    • Uses of TargetDataLine in javax.sound.sampled

      Methods in javax.sound.sampled that return TargetDataLine
      修饰符与类型 方法与描述
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.
      static TargetDataLine AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo)
      Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.
      Constructors in javax.sound.sampled with parameters of type TargetDataLine
      构造方法与描述
      AudioInputStream(TargetDataLine line)
      Constructs an audio input stream that reads its data from the target data line indicated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/smehne".p /na/snk/


AudioFileReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled.spi

类 AudioFileReader

  • java.lang.Object
    • javax.sound.sampled.spi.AudioFileReader

  • public abstract class AudioFileReader
extends Object
    Provider for audio file reading services. Classes providing concrete implementations can parse the format information from one or more types of audio file, and can produce audio input streams from files of these types.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioFileReader()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract AudioFileFormat getAudioFileFormat(File file)
      Obtains the audio file format of the File provided.
      abstract AudioFileFormat getAudioFileFormat(InputStream stream)
      Obtains the audio file format of the input stream provided.
      abstract AudioFileFormat getAudioFileFormat(URL url)
      Obtains the audio file format of the URL provided.
      abstract AudioInputStream getAudioInputStream(File file)
      Obtains an audio input stream from the File provided.
      abstract AudioInputStream getAudioInputStream(InputStream stream)
      Obtains an audio input stream from the input stream provided.
      abstract AudioInputStream getAudioInputStream(URL url)
      Obtains an audio input stream from the URL provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AudioFileReader

        public AudioFileReader()

    • 方法详细信息

      • getAudioFileFormat

        public abstract AudioFileFormat getAudioFileFormat(InputStream stream)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains the audio file format of the input stream provided. The stream must point to valid audio file data. In general, audio file readers may need to read some data from the stream before determining whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support this, this method may fail with an IOException.
        参数：
        stream - the input stream from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the audio file format
        抛出：
        UnsupportedAudioFileException - if the stream does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getAudioFileFormat

        public abstract AudioFileFormat getAudioFileFormat(URL url)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains the audio file format of the URL provided. The URL must point to valid audio file data.
        参数：
        url - the URL from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the audio file format
        抛出：
        UnsupportedAudioFileException - if the URL does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioFileFormat

        public abstract AudioFileFormat getAudioFileFormat(File file)
                                            throws UnsupportedAudioFileException,
                                                   IOException
        Obtains the audio file format of the File provided. The File must point to valid audio file data.
        参数：
        file - the File from which file format information should be extracted
        返回：
        an AudioFileFormat object describing the audio file format
        抛出：
        UnsupportedAudioFileException - if the File does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioInputStream

        public abstract AudioInputStream getAudioInputStream(InputStream stream)
                                              throws UnsupportedAudioFileException,
                                                     IOException
        Obtains an audio input stream from the input stream provided. The stream must point to valid audio file data. In general, audio file readers may need to read some data from the stream before determining whether they support it. These parsers must be able to mark the stream, read enough data to determine whether they support the stream, and, if not, reset the stream's read pointer to its original position. If the input stream does not support this, this method may fail with an IOException.
        参数：
        stream - the input stream from which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data contained in the input stream.
        抛出：
        UnsupportedAudioFileException - if the stream does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs
        另请参见：
        InputStream.markSupported(), InputStream.mark(int)

      • getAudioInputStream

        public abstract AudioInputStream getAudioInputStream(URL url)
                                              throws UnsupportedAudioFileException,
                                                     IOException
        Obtains an audio input stream from the URL provided. The URL must point to valid audio file data.
        参数：
        url - the URL for which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data pointed to by the URL
        抛出：
        UnsupportedAudioFileException - if the URL does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs

      • getAudioInputStream

        public abstract AudioInputStream getAudioInputStream(File file)
                                              throws UnsupportedAudioFileException,
                                                     IOException
        Obtains an audio input stream from the File provided. The File must point to valid audio file data.
        参数：
        file - the File for which the AudioInputStream should be constructed
        返回：
        an AudioInputStream object based on the audio file data pointed to by the File
        抛出：
        UnsupportedAudioFileException - if the File does not point to valid audio file data recognized by the system
        IOException - if an I/O exception occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AudioFileWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled.spi

类 AudioFileWriter

  • java.lang.Object
    • javax.sound.sampled.spi.AudioFileWriter

  • public abstract class AudioFileWriter
extends Object
    Provider for audio file writing services. Classes providing concrete implementations can write one or more types of audio file from an audio stream.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      AudioFileWriter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract AudioFileFormat.Type[] getAudioFileTypes()
      Obtains the file types for which file writing support is provided by this audio file writer.
      abstract AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
      Obtains the file types that this audio file writer can write from the audio input stream specified.
      boolean isFileTypeSupported(AudioFileFormat.Type fileType)
      Indicates whether file writing support for the specified file type is provided by this audio file writer.
      boolean isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream)
      Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
      abstract int write(AudioInputStream stream, AudioFileFormat.Type fileType, File out)
      Writes a stream of bytes representing an audio file of the file format indicated to the external file provided.
      abstract int write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
      Writes a stream of bytes representing an audio file of the file type indicated to the output stream provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AudioFileWriter

        public AudioFileWriter()

    • 方法详细信息

      • getAudioFileTypes

        public abstract AudioFileFormat.Type[] getAudioFileTypes()
        Obtains the file types for which file writing support is provided by this audio file writer.
        返回：
        array of file types. If no file types are supported, an array of length 0 is returned.

      • isFileTypeSupported

        public boolean isFileTypeSupported(AudioFileFormat.Type fileType)
        Indicates whether file writing support for the specified file type is provided by this audio file writer.
        参数：
        fileType - the file type for which write capabilities are queried
        返回：
        true if the file type is supported, otherwise false

      • getAudioFileTypes

        public abstract AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
        Obtains the file types that this audio file writer can write from the audio input stream specified.
        参数：
        stream - the audio input stream for which audio file type support is queried
        返回：
        array of file types. If no file types are supported, an array of length 0 is returned.

      • isFileTypeSupported

        public boolean isFileTypeSupported(AudioFileFormat.Type fileType,
                          AudioInputStream stream)
        Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
        参数：
        fileType - file type for which write capabilities are queried
        stream - for which file writing support is queried
        返回：
        true if the file type is supported for this audio input stream, otherwise false

      • write

        public abstract int write(AudioInputStream stream,
        AudioFileFormat.Type fileType,
        OutputStream out)
                   throws IOException
        Writes a stream of bytes representing an audio file of the file type indicated to the output stream provided. Some file types require that the length be written into the file header, and cannot be written from start to finish unless the length is known in advance. An attempt to write such a file type will fail with an IOException if the length in the audio file format is AudioSystem.NOT_SPECIFIED.
        参数：
        stream - the audio input stream containing audio data to be written to the output stream
        fileType - file type to be written to the output stream
        out - stream to which the file data should be written
        返回：
        the number of bytes written to the output stream
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file type is not supported by the system
        另请参见：
        isFileTypeSupported(AudioFileFormat.Type, AudioInputStream), getAudioFileTypes()

      • write

        public abstract int write(AudioInputStream stream,
        AudioFileFormat.Type fileType,
        File out)
                   throws IOException
        Writes a stream of bytes representing an audio file of the file format indicated to the external file provided.
        参数：
        stream - the audio input stream containing audio data to be written to the file
        fileType - file type to be written to the file
        out - external file to which the file data should be written
        返回：
        the number of bytes written to the file
        抛出：
        IOException - if an I/O exception occurs
        IllegalArgumentException - if the file format is not supported by the system
        另请参见：
        isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

astbdbrblbnsn&nna>>>. .e/...//ohc.. �.l/�"


FormatConversionProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled.spi

类 FormatConversionProvider

  • java.lang.Object
    • javax.sound.sampled.spi.FormatConversionProvider

  • public abstract class FormatConversionProvider
extends Object
    A format conversion provider provides format conversion services from one or more input formats to one or more output formats. Converters include codecs, which encode and/or decode audio data, as well as transcoders, etc. Format converters provide methods for determining what conversions are supported and for obtaining an audio stream from which converted data can be read.

    The source format represents the format of the incoming audio data, which will be converted.

    The target format represents the format of the processed, converted audio data. This is the format of the data that can be read from the stream returned by one of the getAudioInputStream methods.

    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      FormatConversionProvider()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified encoding from the given audio input stream.
      abstract AudioInputStream getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream)
      Obtains an audio input stream with the specified format from the given audio input stream.
      abstract AudioFormat.Encoding[] getSourceEncodings()
      Obtains the set of source format encodings from which format conversion services are provided by this provider.
      abstract AudioFormat.Encoding[] getTargetEncodings()
      Obtains the set of target format encodings to which format conversion services are provided by this provider.
      abstract AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
      Obtains the set of target format encodings supported by the format converter given a particular source format.
      abstract AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.
      boolean isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
      Indicates whether the format converter supports conversion to a particular encoding from a particular format.
      boolean isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat)
      Indicates whether the format converter supports conversion to one particular format from another.
      boolean isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding)
      Indicates whether the format converter supports conversion from the specified source format encoding.
      boolean isTargetEncodingSupported(AudioFormat.Encoding targetEncoding)
      Indicates whether the format converter supports conversion to the specified target format encoding.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FormatConversionProvider

        public FormatConversionProvider()

    • 方法详细信息

      • getSourceEncodings

        public abstract AudioFormat.Encoding[] getSourceEncodings()
        Obtains the set of source format encodings from which format conversion services are provided by this provider.
        返回：
        array of source format encodings. If for some reason provider does not provide any conversion services, an array of length 0 is returned.

      • getTargetEncodings

        public abstract AudioFormat.Encoding[] getTargetEncodings()
        Obtains the set of target format encodings to which format conversion services are provided by this provider.
        返回：
        array of target format encodings. If for some reason provider does not provide any conversion services, an array of length 0 is returned.

      • isSourceEncodingSupported

        public boolean isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding)
        Indicates whether the format converter supports conversion from the specified source format encoding.
        参数：
        sourceEncoding - the source format encoding for which support is queried
        返回：
        true if the encoding is supported, otherwise false

      • isTargetEncodingSupported

        public boolean isTargetEncodingSupported(AudioFormat.Encoding targetEncoding)
        Indicates whether the format converter supports conversion to the specified target format encoding.
        参数：
        targetEncoding - the target format encoding for which support is queried
        返回：
        true if the encoding is supported, otherwise false

      • getTargetEncodings

        public abstract AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
        Obtains the set of target format encodings supported by the format converter given a particular source format. If no target format encodings are supported for this source format, an array of length 0 is returned.
        返回：
        array of supported target format encodings.

      • isConversionSupported

        public boolean isConversionSupported(AudioFormat.Encoding targetEncoding,
                            AudioFormat sourceFormat)
        Indicates whether the format converter supports conversion to a particular encoding from a particular format.
        参数：
        targetEncoding - desired encoding of the outgoing data
        sourceFormat - format of the incoming data
        返回：
        true if the conversion is supported, otherwise false

      • getTargetFormats

        public abstract AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding,
                             AudioFormat sourceFormat)
        Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.
        返回：
        array of supported target formats.

      • isConversionSupported

        public boolean isConversionSupported(AudioFormat targetFormat,
                            AudioFormat sourceFormat)
        Indicates whether the format converter supports conversion to one particular format from another.
        参数：
        targetFormat - desired format of outgoing data
        sourceFormat - format of the incoming data
        返回：
        true if the conversion is supported, otherwise false

      • getAudioInputStream

        public abstract AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding,
                                   AudioInputStream sourceStream)
        Obtains an audio input stream with the specified encoding from the given audio input stream.
        参数：
        targetEncoding - desired encoding of the stream after processing
        sourceStream - stream from which data to be processed should be read
        返回：
        stream from which processed data with the specified target encoding may be read
        抛出：
        IllegalArgumentException - if the format combination supplied is not supported.

      • getAudioInputStream

        public abstract AudioInputStream getAudioInputStream(AudioFormat targetFormat,
                                   AudioInputStream sourceStream)
        Obtains an audio input stream with the specified format from the given audio input stream.
        参数：
        targetFormat - desired data format of the stream after processing
        sourceStream - stream from which data to be processed should be read
        返回：
        stream from which processed data with the specified format may be read
        抛出：
        IllegalArgumentException - if the format combination supplied is not supported.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

re觛ltr/ ae=s� os0>籯籹 /uhCl a./.>x<图


javax.sound.sampled.spi

Classes

  • AudioFileReader
  • AudioFileWriter
  • FormatConversionProvider
  • MixerProvider


javax.sound.sampled.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sound.sampled.spi

Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

请参见： 描述

  • Class Summary
    类 描述
    AudioFileReader
    Provider for audio file reading services.
    AudioFileWriter
    Provider for audio file writing services.
    FormatConversionProvider
    A format conversion provider provides format conversion services from one or more input formats to one or more output formats.
    MixerProvider
    A provider or factory for a particular mixer type.

软件包 javax.sound.sampled.spi Description

Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.

Related Documentation

For overviews, tutorials, examples, and guides, please see:
  • Sound
从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sea/se/ct/gOcc/a..gaa/la)�


javax.sound.sampled.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sound.sampled.spi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sound.sampled.spi.AudioFileReader
    • javax.sound.sampled.spi.AudioFileWriter
    • javax.sound.sampled.spi.FormatConversionProvider
    • javax.sound.sampled.spi.MixerProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.."a.er=== >kkL== f.


MixerProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sound.sampled.spi

类 MixerProvider

  • java.lang.Object
    • javax.sound.sampled.spi.MixerProvider

  • public abstract class MixerProvider
extends Object
    A provider or factory for a particular mixer type. This mechanism allows the implementation to determine how resources are managed in creation / management of a mixer.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      MixerProvider()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Mixer getMixer(Mixer.Info info)
      Obtains an instance of the mixer represented by the info object.
      abstract Mixer.Info[] getMixerInfo()
      Obtains the set of info objects representing the mixer or mixers provided by this MixerProvider.
      boolean isMixerSupported(Mixer.Info info)
      Indicates whether the mixer provider supports the mixer represented by the specified mixer info object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MixerProvider

        public MixerProvider()

    • 方法详细信息

      • isMixerSupported

        public boolean isMixerSupported(Mixer.Info info)
        Indicates whether the mixer provider supports the mixer represented by the specified mixer info object.

        The full set of mixer info objects that represent the mixers supported by this MixerProvider may be obtained through the getMixerInfo method.

        参数：
        info - an info object that describes the mixer for which support is queried
        返回：
        true if the specified mixer is supported, otherwise false
        另请参见：
        getMixerInfo()

      • getMixerInfo

        public abstract Mixer.Info[] getMixerInfo()
        Obtains the set of info objects representing the mixer or mixers provided by this MixerProvider.

        The isMixerSupported method returns true for all the info objects returned by this method. The corresponding mixer instances for the info objects are returned by the getMixer method.

        返回：
        a set of mixer info objects
        另请参见：
        getMixer(Mixer.Info), isMixerSupported(Mixer.Info)

      • getMixer

        public abstract Mixer getMixer(Mixer.Info info)
        Obtains an instance of the mixer represented by the info object.

        The full set of the mixer info objects that represent the mixers supported by this MixerProvider may be obtained through the getMixerInfo method. Use the isMixerSupported method to test whether this MixerProvider supports a particular mixer.

        参数：
        info - an info object that describes the desired mixer
        返回：
        mixer instance
        抛出：
        IllegalArgumentException - if the info object specified does not match the info object for a mixer supported by this MixerProvider.
        另请参见：
        getMixerInfo(), isMixerSupported(Mixer.Info)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/a.=ahs hsbppsbbai44>-c ll<=lto"bbbl->blh


Uses of Package javax.sound.sampled.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sound.sampled.spi

No usage of javax.sound.sampled.spi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nNdalmvmt???..fflac/s


Uses of Class javax.sound.sampled.spi.AudioFileReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.spi.AudioFileReader

No usage of javax.sound.sampled.spi.AudioFileReader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< 萳lael


Uses of Class javax.sound.sampled.spi.AudioFileWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.spi.AudioFileWriter

No usage of javax.sound.sampled.spi.AudioFileWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ao�`lpC& l


Uses of Class javax.sound.sampled.spi.FormatConversionProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.spi.FormatConversionProvider

No usage of javax.sound.sampled.spi.FormatConversionProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.a co #s""t.aslaati


Uses of Class javax.sound.sampled.spi.MixerProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sound.sampled.spi.MixerProvider

No usage of javax.sound.sampled.spi.MixerProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


CommonDataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface CommonDataSource

  • All Known Subinterfaces:
    ConnectionPoolDataSource, DataSource, XADataSource

    public interface CommonDataSource
    Interface that defines the methods which are common between DataSource, XADataSource and ConnectionPoolDataSource.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getLoginTimeout()
      Gets the maximum time in seconds that this data source can wait while attempting to connect to a database.
      PrintWriter getLogWriter()
      Retrieves the log writer for this DataSource object.
      Logger getParentLogger()
      Return the parent Logger of all the Loggers used by this data source.
      void setLoginTimeout(int seconds)
      Sets the maximum time in seconds that this data source will wait while attempting to connect to a database.
      void setLogWriter(PrintWriter out)
      Sets the log writer for this DataSource object to the given java.io.PrintWriter object.

    • 方法详细信息

      • getLogWriter

        PrintWriter getLogWriter()
                         throws SQLException

        Retrieves the log writer for this DataSource object.

        The log writer is a character output stream to which all logging and tracing messages for this data source will be printed. This includes messages printed by the methods of this object, messages printed by methods of other objects manufactured by this object, and so on. Messages printed to a data source specific log writer are not printed to the log writer associated with the java.sql.DriverManager class. When a DataSource object is created, the log writer is initially null; in other words, the default is for logging to be disabled.

        返回：
        the log writer for this data source or null if logging is disabled
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.4
        另请参见：
        setLogWriter(java.io.PrintWriter)

      • setLogWriter

        void setLogWriter(PrintWriter out)
                  throws SQLException

        Sets the log writer for this DataSource object to the given java.io.PrintWriter object.

        The log writer is a character output stream to which all logging and tracing messages for this data source will be printed. This includes messages printed by the methods of this object, messages printed by methods of other objects manufactured by this object, and so on. Messages printed to a data source- specific log writer are not printed to the log writer associated with the java.sql.DriverManager class. When a DataSource object is created the log writer is initially null; in other words, the default is for logging to be disabled.

        参数：
        out - the new log writer; to disable logging, set to null
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.4
        另请参见：
        getLogWriter()

      • setLoginTimeout

        void setLoginTimeout(int seconds)
                     throws SQLException

        Sets the maximum time in seconds that this data source will wait while attempting to connect to a database. A value of zero specifies that the timeout is the default system timeout if there is one; otherwise, it specifies that there is no timeout. When a DataSource object is created, the login timeout is initially zero.

        参数：
        seconds - the data source login time limit
        抛出：
        SQLException - if a database access error occurs.
        从以下版本开始：
        1.4
        另请参见：
        getLoginTimeout()

      • getLoginTimeout

        int getLoginTimeout()
                    throws SQLException
        Gets the maximum time in seconds that this data source can wait while attempting to connect to a database. A value of zero means that the timeout is the default system timeout if there is one; otherwise, it means that there is no timeout. When a DataSource object is created, the login timeout is initially zero.
        返回：
        the data source login time limit
        抛出：
        SQLException - if a database access error occurs.
        从以下版本开始：
        1.4
        另请参见：
        setLoginTimeout(int)

      • getParentLogger

        Logger getParentLogger()
                       throws SQLFeatureNotSupportedException
        Return the parent Logger of all the Loggers used by this data source. This should be the Logger farthest from the root Logger that is still an ancestor of all of the Loggers used by this data source. Configuring this Logger will affect all of the log messages generated by the data source. In the worst case, this may be the root Logger.
        返回：
        the parent Logger for this data source
        抛出：
        SQLFeatureNotSupportedException - if the data source does not use java.util.logging.
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acoc nlaap.ea盿


ConnectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql

类 ConnectionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.sql.ConnectionEvent
  • 所有已实现的接口：
    Serializable

    public class ConnectionEvent
extends EventObject

    An Event object that provides information about the source of a connection-related event. ConnectionEvent objects are generated when an application closes a pooled connection and when an error occurs. The ConnectionEvent object contains two kinds of information:

    • The pooled connection closed by the application
    • In the case of an error event, the SQLException about to be thrown to the application
    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      ConnectionEvent(PooledConnection con)
      Constructs a ConnectionEvent object initialized with the given PooledConnection object.
      ConnectionEvent(PooledConnection con, SQLException ex)
      Constructs a ConnectionEvent object initialized with the given PooledConnection object and SQLException object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SQLException getSQLException()
      Retrieves the SQLException for this ConnectionEvent object.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ConnectionEvent

        public ConnectionEvent(PooledConnection con)

        Constructs a ConnectionEvent object initialized with the given PooledConnection object. SQLException defaults to null.

        参数：
        con - the pooled connection that is the source of the event
        抛出：
        IllegalArgumentException - if con is null.

      • ConnectionEvent

        public ConnectionEvent(PooledConnection con,
               SQLException ex)

        Constructs a ConnectionEvent object initialized with the given PooledConnection object and SQLException object.

        参数：
        con - the pooled connection that is the source of the event
        ex - the SQLException about to be thrown to the application
        抛出：
        IllegalArgumentException - if con is null.

    • 方法详细信息

      • getSQLException

        public SQLException getSQLException()

        Retrieves the SQLException for this ConnectionEvent object. May be null.

        返回：
        the SQLException about to be thrown or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osmrnrsrtrabr_o)taaa irxtex"e sc>>> <<>//onr/


ConnectionEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface ConnectionEventListener

  • All Superinterfaces:
    EventListener

    public interface ConnectionEventListener
extends EventListener

    An object that registers to be notified of events generated by a PooledConnection object.

    The ConnectionEventListener interface is implemented by a connection pooling component. A connection pooling component will usually be provided by a JDBC driver vendor or another system software vendor. A JDBC driver notifies a ConnectionEventListener object when an application is finished using a pooled connection with which the listener has registered. The notification occurs after the application calls the method close on its representation of a PooledConnection object. A ConnectionEventListener is also notified when a connection error occurs due to the fact that the PooledConnection is unfit for future use---the server has crashed, for example. The listener is notified by the JDBC driver just before the driver throws an SQLException to the application using the PooledConnection object.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void connectionClosed(ConnectionEvent event)
      Notifies this ConnectionEventListener that the application has called the method close on its representation of a pooled connection.
      void connectionErrorOccurred(ConnectionEvent event)
      Notifies this ConnectionEventListener that a fatal error has occurred and the pooled connection can no longer be used.

    • 方法详细信息

      • connectionClosed

        void connectionClosed(ConnectionEvent event)
        Notifies this ConnectionEventListener that the application has called the method close on its representation of a pooled connection.
        参数：
        event - an event object describing the source of the event

      • connectionErrorOccurred

        void connectionErrorOccurred(ConnectionEvent event)
        Notifies this ConnectionEventListener that a fatal error has occurred and the pooled connection can no longer be used. The driver makes this notification just before it throws the application the SQLException contained in the given ConnectionEvent object.
        参数：
        event - an event object describing the source of the event and containing the SQLException that the driver is about to throw
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/mxuelmelaAAlaaIveeip a


ConnectionPoolDataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface ConnectionPoolDataSource

  • All Superinterfaces:
    CommonDataSource

    public interface ConnectionPoolDataSource
extends CommonDataSource
    A factory for PooledConnection objects. An object that implements this interface will typically be registered with a naming service that is based on the JavaTM Naming and Directory Interface (JNDI).
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      PooledConnection getPooledConnection()
      Attempts to establish a physical database connection that can be used as a pooled connection.
      PooledConnection getPooledConnection(String user, String password)
      Attempts to establish a physical database connection that can be used as a pooled connection.

      • 方法 - 继承于接口 javax.sql.CommonDataSource

        getLoginTimeout, getLogWriter, getParentLogger, setLoginTimeout, setLogWriter

    • 方法详细信息

      • getPooledConnection

        PooledConnection getPooledConnection()
                                     throws SQLException
        Attempts to establish a physical database connection that can be used as a pooled connection.
        返回：
        a PooledConnection object that is a physical connection to the database that this ConnectionPoolDataSource object represents
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • getPooledConnection

        PooledConnection getPooledConnection(String user,
                                   String password)
                                     throws SQLException
        Attempts to establish a physical database connection that can be used as a pooled connection.
        参数：
        user - the database user on whose behalf the connection is being made
        password - the user's password
        返回：
        a PooledConnection object that is a physical connection to the database that this ConnectionPoolDataSource object represents
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ncatnvsavsasssao>""brer==


DataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface DataSource

  • All Superinterfaces:
    CommonDataSource, Wrapper

    public interface DataSource
extends CommonDataSource, Wrapper

    A factory for connections to the physical data source that this DataSource object represents. An alternative to the DriverManager facility, a DataSource object is the preferred means of getting a connection. An object that implements the DataSource interface will typically be registered with a naming service based on the JavaTM Naming and Directory (JNDI) API.

    The DataSource interface is implemented by a driver vendor. There are three types of implementations:

    1. Basic implementation -- produces a standard Connection object
    2. Connection pooling implementation -- produces a Connection object that will automatically participate in connection pooling. This implementation works with a middle-tier connection pooling manager.
    3. Distributed transaction implementation -- produces a Connection object that may be used for distributed transactions and almost always participates in connection pooling. This implementation works with a middle-tier transaction manager and almost always with a connection pooling manager.

    A DataSource object has properties that can be modified when necessary. For example, if the data source is moved to a different server, the property for the server can be changed. The benefit is that because the data source's properties can be changed, any code accessing that data source does not need to be changed.

    A driver that is accessed via a DataSource object does not register itself with the DriverManager. Rather, a DataSource object is retrieved though a lookup operation and then used to create a Connection object. With a basic implementation, the connection obtained through a DataSource object is identical to a connection obtained through the DriverManager facility.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Connection getConnection()
      Attempts to establish a connection with the data source that this DataSource object represents.
      Connection getConnection(String username, String password)
      Attempts to establish a connection with the data source that this DataSource object represents.

      • 方法 - 继承于接口 javax.sql.CommonDataSource

        getLoginTimeout, getLogWriter, getParentLogger, setLoginTimeout, setLogWriter

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

    • 方法详细信息

      • getConnection

        Connection getConnection()
                         throws SQLException

        Attempts to establish a connection with the data source that this DataSource object represents.

        返回：
        a connection to the data source
        抛出：
        SQLException - if a database access error occurs

      • getConnection

        Connection getConnection(String username,
                       String password)
                         throws SQLException

        Attempts to establish a connection with the data source that this DataSource object represents.

        参数：
        username - the database user on whose behalf the connection is being made
        password - the user's password
        返回：
        a connection to the data source
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eudelctntni=ited )"ss<齭t蘮蘤sc


javax.sql

Interfaces

  • CommonDataSource
  • ConnectionEventListener
  • ConnectionPoolDataSource
  • DataSource
  • PooledConnection
  • RowSet
  • RowSetInternal
  • RowSetListener
  • RowSetMetaData
  • RowSetReader
  • RowSetWriter
  • StatementEventListener
  • XAConnection
  • XADataSource

Classes

  • ConnectionEvent
  • RowSetEvent
  • StatementEvent
e


javax.sql

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sql

Provides the API for server side data source access and processing from the JavaTM programming language.

请参见： 描述

  • 接口摘要
    接口 描述
    CommonDataSource
    Interface that defines the methods which are common between DataSource, XADataSource and ConnectionPoolDataSource.
    ConnectionEventListener
    An object that registers to be notified of events generated by a PooledConnection object.
    ConnectionPoolDataSource
    A factory for PooledConnection objects.
    DataSource
    A factory for connections to the physical data source that this DataSource object represents.
    PooledConnection
    An object that provides hooks for connection pool management.
    RowSet
    The interface that adds support to the JDBC API for the JavaBeansTM component model.
    RowSetInternal
    The interface that a RowSet object implements in order to present itself to a RowSetReader or RowSetWriter object.
    RowSetListener
    An interface that must be implemented by a component that wants to be notified when a significant event happens in the life of a RowSet object.
    RowSetMetaData
    An object that contains information about the columns in a RowSet object.
    RowSetReader
    The facility that a disconnected RowSet object calls on to populate itself with rows of data.
    RowSetWriter
    An object that implements the RowSetWriter interface, called a writer.
    StatementEventListener
    An object that registers to be notified of events that occur on PreparedStatements that are in the Statement pool.
    XAConnection
    An object that provides support for distributed transactions.
    XADataSource
    A factory for XAConnection objects that is used internally.
  • Class Summary
    类 描述
    ConnectionEvent
    An Event object that provides information about the source of a connection-related event.
    RowSetEvent
    An Event object generated when an event occurs to a RowSet object.
    StatementEvent
    A StatementEvent is sent to all StatementEventListeners which were registered with a PooledConnection.

软件包 javax.sql Description

Provides the API for server side data source access and processing from the JavaTM programming language. This package supplements the java.sql package and, as of the version 1.4 release, is included in the Java Platform, Standard Edition (Java SETM). It remains an essential part of the Java Platform, Enterprise Edition (Java EETM).

The javax.sql package provides for the following:

  1. The DataSource interface as an alternative to the DriverManager for establishing a connection with a data source
  2. Connection pooling and Statement pooling
  3. Distributed transactions
  4. Rowsets

Applications use the DataSource and RowSet APIs directly, but the connection pooling and distributed transaction APIs are used internally by the middle-tier infrastructure.

Using a DataSource Object to Make a Connection

The javax.sql package provides the preferred way to make a connection with a data source. The DriverManager class, the original mechanism, is still valid, and code using it will continue to run. However, the newer DataSource mechanism is preferred because it offers many advantages over the DriverManager mechanism.

These are the main advantages of using a DataSource object to make a connection:

  • Changes can be made to a data source's properties, which means that it is not necessary to make changes in application code when something about the data source or driver changes.
  • Connection and Statement pooling and distributed transactions are available through a DataSource object that is implemented to work with the middle-tier infrastructure. Connections made through the DriverManager do not have connection and statement pooling or distributed transaction capabilities.

Driver vendors provide DataSource implementations. A particular DataSource object represents a particular physical data source, and each connection the DataSource object creates is a connection to that physical data source.

A logical name for the data source is registered with a naming service that uses the Java Naming and Directory InterfaceTM (JNDI) API, usually by a system administrator or someone performing the duties of a system administrator. An application can retrieve the DataSource object it wants by doing a lookup on the logical name that has been registered for it. The application can then use the DataSource object to create a connection to the physical data source it represents.

A DataSource object can be implemented to work with the middle tier infrastructure so that the connections it produces will be pooled for reuse. An application that uses such a DataSource implementation will automatically get a connection that participates in connection pooling. A DataSource object can also be implemented to work with the middle tier infrastructure so that the connections it produces can be used for distributed transactions without any special coding.

Connection Pooling and Statement Pooling

Connections made via a DataSource object that is implemented to work with a middle tier connection pool manager will participate in connection pooling. This can improve performance dramatically because creating new connections is very expensive. Connection pooling allows a connection to be used and reused, thus cutting down substantially on the number of new connections that need to be created.

Connection pooling is totally transparent. It is done automatically in the middle tier of a Java EE configuration, so from an application's viewpoint, no change in code is required. An application simply uses the DataSource.getConnection method to get the pooled connection and uses it the same way it uses any Connection object.

The classes and interfaces used for connection pooling are:

  • ConnectionPoolDataSource
  • PooledConnection
  • ConnectionEvent
  • ConnectionEventListener
  • StatementEvent
  • StatementEventListener
The connection pool manager, a facility in the middle tier of a three-tier architecture, uses these classes and interfaces behind the scenes. When a ConnectionPoolDataSource object is called on to create a PooledConnection object, the connection pool manager will register as a ConnectionEventListener object with the new PooledConnection object. When the connection is closed or there is an error, the connection pool manager (being a listener) gets a notification that includes a ConnectionEvent object.

If the connection pool manager supports Statement pooling, for PreparedStatements, which can be determined by invoking the method DatabaseMetaData.supportsStatementPooling, the connection pool manager will register as a StatementEventListener object with the new PooledConnection object. When the PreparedStatement is closed or there is an error, the connection pool manager (being a listener) gets a notification that includes a StatementEvent object.

Distributed Transactions

As with pooled connections, connections made via a DataSource object that is implemented to work with the middle tier infrastructure may participate in distributed transactions. This gives an application the ability to involve data sources on multiple servers in a single transaction.

The classes and interfaces used for distributed transactions are:

  • XADataSource
  • XAConnection
These interfaces are used by the transaction manager; an application does not use them directly.

The XAConnection interface is derived from the PooledConnection interface, so what applies to a pooled connection also applies to a connection that is part of a distributed transaction. A transaction manager in the middle tier handles everything transparently. The only change in application code is that an application cannot do anything that would interfere with the transaction manager's handling of the transaction. Specifically, an application cannot call the methods Connection.commit or Connection.rollback, and it cannot set the connection to be in auto-commit mode (that is, it cannot call Connection.setAutoCommit(true)).

An application does not need to do anything special to participate in a distributed transaction. It simply creates connections to the data sources it wants to use via the DataSource.getConnection method, just as it normally does. The transaction manager manages the transaction behind the scenes. The XADataSource interface creates XAConnection objects, and each XAConnection object creates an XAResource object that the transaction manager uses to manage the connection.

Rowsets

The RowSet interface works with various other classes and interfaces behind the scenes. These can be grouped into three categories.
  1. Event Notification
    • RowSetListener
      A RowSet object is a JavaBeansTM component because it has properties and participates in the JavaBeans event notification mechanism. The RowSetListener interface is implemented by a component that wants to be notified about events that occur to a particular RowSet object. Such a component registers itself as a listener with a rowset via the RowSet.addRowSetListener method.

      When the RowSet object changes one of its rows, changes all of it rows, or moves its cursor, it also notifies each listener that is registered with it. The listener reacts by carrying out its implementation of the notification method called on it.

    • RowSetEvent
      As part of its internal notification process, a RowSet object creates an instance of RowSetEvent and passes it to the listener. The listener can use this RowSetEvent object to find out which rowset had the event.

  2. Metadata
    • RowSetMetaData
      This interface, derived from the ResultSetMetaData interface, provides information about the columns in a RowSet object. An application can use RowSetMetaData methods to find out how many columns the rowset contains and what kind of data each column can contain.

      The RowSetMetaData interface provides methods for setting the information about columns, but an application would not normally use these methods. When an application calls the RowSet method execute, the RowSet object will contain a new set of rows, and its RowSetMetaData object will have been internally updated to contain information about the new columns.

  3. The Reader/Writer Facility
    A RowSet object that implements the RowSetInternal interface can call on the RowSetReader object associated with it to populate itself with data. It can also call on the RowSetWriter object associated with it to write any changes to its rows back to the data source from which it originally got the rows. A rowset that remains connected to its data source does not need to use a reader and writer because it can simply operate on the data source directly.
    • RowSetInternal
      By implementing the RowSetInternal interface, a RowSet object gets access to its internal state and is able to call on its reader and writer. A rowset keeps track of the values in its current rows and of the values that immediately preceded the current ones, referred to as the original values. A rowset also keeps track of (1) the parameters that have been set for its command and (2) the connection that was passed to it, if any. A rowset uses the RowSetInternal methods behind the scenes to get access to this information. An application does not normally invoke these methods directly.

    • RowSetReader
      A disconnected RowSet object that has implemented the RowSetInternal interface can call on its reader (the RowSetReader object associated with it) to populate it with data. When an application calls the RowSet.execute method, that method calls on the rowset's reader to do much of the work. Implementations can vary widely, but generally a reader makes a connection to the data source, reads data from the data source and populates the rowset with it, and closes the connection. A reader may also update the RowSetMetaData object for its rowset. The rowset's internal state is also updated, either by the reader or directly by the method RowSet.execute.
    • RowSetWriter
      A disconnected RowSet object that has implemented the RowSetInternal interface can call on its writer (the RowSetWriter object associated with it) to write changes back to the underlying data source. Implementations may vary widely, but generally, a writer will do the following:

      • Make a connection to the data source
      • Check to see whether there is a conflict, that is, whether a value that has been changed in the rowset has also been changed in the data source
      • Write the new values to the data source if there is no conflict
      • Close the connection

The RowSet interface may be implemented in any number of ways, and anyone may write an implementation. Developers are encouraged to use their imaginations in coming up with new ways to use rowsets.

IMPORTANT NOTE: Code that uses API marked "Since 1.6" must be run using a JDBC technology driver that implements the JDBC 4.0 API. You must check your driver documentation to be sure that it implements the particular features you want to use.

Package Specification

  • Specification of the JDBC 4.0 API

Related Documentation

The Java Series book published by Addison-Wesley Longman provides detailed information about the classes and interfaces in the javax.sql package:
  • JDBCTM API Tutorial and Reference, Third Edition:

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne scerig.r/.e苨mgnedc琤g�


javax.sql Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sql

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.sql.ConnectionEvent
      • javax.sql.RowSetEvent
      • javax.sql.StatementEvent

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.sql.RowSet
  • javax.sql.CommonDataSource
    • javax.sql.ConnectionPoolDataSource
    • javax.sql.DataSource (also extends java.sql.Wrapper)
    • javax.sql.XADataSource
  • java.util.EventListener
    • javax.sql.ConnectionEventListener
    • javax.sql.RowSetListener
    • javax.sql.StatementEventListener
  • javax.sql.PooledConnection
    • javax.sql.XAConnection
  • javax.sql.RowSetInternal
  • javax.sql.RowSetReader
  • javax.sql.RowSetWriter
  • java.sql.Wrapper
    • javax.sql.DataSource (also extends javax.sql.CommonDataSource)
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.sql.RowSet
    • java.sql.ResultSetMetaData
      • javax.sql.RowSetMetaData
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

HcydcsI t iPPnt


PooledConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface PooledConnection

  • All Known Subinterfaces:
    XAConnection

    public interface PooledConnection
    An object that provides hooks for connection pool management. A PooledConnection object represents a physical connection to a data source. The connection can be recycled rather than being closed when an application is finished with it, thus reducing the number of connections that need to be made.

    An application programmer does not use the PooledConnection interface directly; rather, it is used by a middle tier infrastructure that manages the pooling of connections.

    When an application calls the method DataSource.getConnection, it gets back a Connection object. If connection pooling is being done, that Connection object is actually a handle to a PooledConnection object, which is a physical connection.

    The connection pool manager, typically the application server, maintains a pool of PooledConnection objects. If there is a PooledConnection object available in the pool, the connection pool manager returns a Connection object that is a handle to that physical connection. If no PooledConnection object is available, the connection pool manager calls the ConnectionPoolDataSource method getPoolConnection to create a new physical connection. The JDBC driver implementing ConnectionPoolDataSource creates a new PooledConnection object and returns a handle to it.

    When an application closes a connection, it calls the Connection method close. When connection pooling is being done, the connection pool manager is notified because it has registered itself as a ConnectionEventListener object using the ConnectionPool method addConnectionEventListener. The connection pool manager deactivates the handle to the PooledConnection object and returns the PooledConnection object to the pool of connections so that it can be used again. Thus, when an application closes its connection, the underlying physical connection is recycled rather than being closed.

    The physical connection is not closed until the connection pool manager calls the PooledConnection method close. This method is generally called to have an orderly shutdown of the server or if a fatal error has made the connection unusable.

    A connection pool manager is often also a statement pool manager, maintining a pool of PreparedStatement objects. When an application closes a prepared statement, it calls the PreparedStatement method close. When Statement pooling is being done, the pool manager is notified because it has registered itself as a StatementEventListener object using the ConnectionPool method addStatementEventListener. Thus, when an application closes its PreparedStatement, the underlying prepared statement is recycled rather than being closed.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addConnectionEventListener(ConnectionEventListener listener)
      Registers the given event listener so that it will be notified when an event occurs on this PooledConnection object.
      void addStatementEventListener(StatementEventListener listener)
      Registers a StatementEventListener with this PooledConnection object.
      void close()
      Closes the physical connection that this PooledConnection object represents.
      Connection getConnection()
      Creates and returns a Connection object that is a handle for the physical connection that this PooledConnection object represents.
      void removeConnectionEventListener(ConnectionEventListener listener)
      Removes the given event listener from the list of components that will be notified when an event occurs on this PooledConnection object.
      void removeStatementEventListener(StatementEventListener listener)
      Removes the specified StatementEventListener from the list of components that will be notified when the driver detects that a PreparedStatement has been closed or is invalid.

    • 方法详细信息

      • getConnection

        Connection getConnection()
                         throws SQLException
        Creates and returns a Connection object that is a handle for the physical connection that this PooledConnection object represents. The connection pool manager calls this method when an application has called the method DataSource.getConnection and there are no PooledConnection objects available. See the interface description for more information.
        返回：
        a Connection object that is a handle to this PooledConnection object
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • close

        void close()
           throws SQLException
        Closes the physical connection that this PooledConnection object represents. An application never calls this method directly; it is called by the connection pool module, or manager.

        See the interface description for more information.

        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • addConnectionEventListener

        void addConnectionEventListener(ConnectionEventListener listener)
        Registers the given event listener so that it will be notified when an event occurs on this PooledConnection object.
        参数：
        listener - a component, usually the connection pool manager, that has implemented the ConnectionEventListener interface and wants to be notified when the connection is closed or has an error
        另请参见：
        removeConnectionEventListener(javax.sql.ConnectionEventListener)

      • removeConnectionEventListener

        void removeConnectionEventListener(ConnectionEventListener listener)
        Removes the given event listener from the list of components that will be notified when an event occurs on this PooledConnection object.
        参数：
        listener - a component, usually the connection pool manager, that has implemented the ConnectionEventListener interface and been registered with this PooledConnection object as a listener
        另请参见：
        addConnectionEventListener(javax.sql.ConnectionEventListener)

      • addStatementEventListener

        void addStatementEventListener(StatementEventListener listener)
        Registers a StatementEventListener with this PooledConnection object. Components that wish to be notified when PreparedStatements created by the connection are closed or are detected to be invalid may use this method to register a StatementEventListener with this PooledConnection object.

        参数：
        listener - an component which implements the StatementEventListener interface that is to be registered with this PooledConnection object

        从以下版本开始：
        1.6

      • removeStatementEventListener

        void removeStatementEventListener(StatementEventListener listener)
        Removes the specified StatementEventListener from the list of components that will be notified when the driver detects that a PreparedStatement has been closed or is invalid.

        参数：
        listener - the component which implements the StatementEventListener interface that was previously registered with this PooledConnection object

        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ce pu u ase tl TheeoeAnAonssesyai


RowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSet

  • All Superinterfaces:
    AutoCloseable, ResultSet, Wrapper
    All Known Subinterfaces:
    CachedRowSet, FilteredRowSet, JdbcRowSet, JoinRowSet, SyncResolver, WebRowSet

    public interface RowSet
extends ResultSet
    The interface that adds support to the JDBC API for the JavaBeansTM component model. A rowset, which can be used as a JavaBeans component in a visual Bean development environment, can be created and configured at design time and executed at run time.

    The RowSet interface provides a set of JavaBeans properties that allow a RowSet instance to be configured to connect to a JDBC data source and read some data from the data source. A group of setter methods (setInt, setBytes, setString, and so on) provide a way to pass input parameters to a rowset's command property. This command is the SQL query the rowset uses when it gets its data from a relational database, which is generally the case.

    The RowSet interface supports JavaBeans events, allowing other components in an application to be notified when an event occurs on a rowset, such as a change in its value.

    The RowSet interface is unique in that it is intended to be implemented using the rest of the JDBC API. In other words, a RowSet implementation is a layer of software that executes "on top" of a JDBC driver. Implementations of the RowSet interface can be provided by anyone, including JDBC driver vendors who want to provide a RowSet implementation as part of their JDBC products.

    A RowSet object may make a connection with a data source and maintain that connection throughout its life cycle, in which case it is called a connected rowset. A rowset may also make a connection with a data source, get data from it, and then close the connection. Such a rowset is called a disconnected rowset. A disconnected rowset may make changes to its data while it is disconnected and then send the changes back to the original source of the data, but it must reestablish a connection to do so.

    A disconnected rowset may have a reader (a RowSetReader object) and a writer (a RowSetWriter object) associated with it. The reader may be implemented in many different ways to populate a rowset with data, including getting data from a non-relational data source. The writer can also be implemented in many different ways to propagate changes made to the rowset's data back to the underlying data source.

    Rowsets are easy to use. The RowSet interface extends the standard java.sql.ResultSet interface. The RowSetMetaData interface extends the java.sql.ResultSetMetaData interface. Thus, developers familiar with the JDBC API will have to learn a minimal number of new APIs to use rowsets. In addition, third-party software tools that work with JDBC ResultSet objects will also easily be made to work with rowsets.

    从以下版本开始：
    1.4

    • 字段摘要

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRowSetListener(RowSetListener listener)
      Registers the given listener so that it will be notified of events that occur on this RowSet object.
      void clearParameters()
      Clears the parameters set for this RowSet object's command.
      void execute()
      Fills this RowSet object with data.
      String getCommand()
      Retrieves this RowSet object's command property.
      String getDataSourceName()
      Retrieves the logical name that identifies the data source for this RowSet object.
      boolean getEscapeProcessing()
      Retrieves whether escape processing is enabled for this RowSet object.
      int getMaxFieldSize()
      Retrieves the maximum number of bytes that may be returned for certain column values.
      int getMaxRows()
      Retrieves the maximum number of rows that this RowSet object can contain.
      String getPassword()
      Retrieves the password used to create a database connection.
      int getQueryTimeout()
      Retrieves the maximum number of seconds the driver will wait for a statement to execute.
      int getTransactionIsolation()
      Retrieves the transaction isolation level set for this RowSet object.
      Map<String,类<?>> getTypeMap()
      Retrieves the Map object associated with this RowSet object, which specifies the custom mapping of SQL user-defined types, if any.
      String getUrl()
      Retrieves the url property this RowSet object will use to create a connection if it uses the DriverManager instead of a DataSource object to establish the connection.
      String getUsername()
      Retrieves the username used to create a database connection for this RowSet object.
      boolean isReadOnly()
      Retrieves whether this RowSet object is read-only.
      void removeRowSetListener(RowSetListener listener)
      Removes the specified listener from the list of components that will be notified when an event occurs on this RowSet object.
      void setArray(int i, Array x)
      Sets the designated parameter in this RowSet object's command with the given Array value.
      void setAsciiStream(int parameterIndex, InputStream x)
      Sets the designated parameter in this RowSet object's command to the given input stream.
      void setAsciiStream(int parameterIndex, InputStream x, int length)
      Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value.
      void setAsciiStream(String parameterName, InputStream x)
      Sets the designated parameter to the given input stream.
      void setAsciiStream(String parameterName, InputStream x, int length)
      Sets the designated parameter to the given input stream, which will have the specified number of bytes.
      void setBigDecimal(int parameterIndex, BigDecimal x)
      Sets the designated parameter in this RowSet object's command to the given java.math.BigDeciaml value.
      void setBigDecimal(String parameterName, BigDecimal x)
      Sets the designated parameter to the given java.math.BigDecimal value.
      void setBinaryStream(int parameterIndex, InputStream x)
      Sets the designated parameter in this RowSet object's command to the given input stream.
      void setBinaryStream(int parameterIndex, InputStream x, int length)
      Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value.
      void setBinaryStream(String parameterName, InputStream x)
      Sets the designated parameter to the given input stream.
      void setBinaryStream(String parameterName, InputStream x, int length)
      Sets the designated parameter to the given input stream, which will have the specified number of bytes.
      void setBlob(int i, Blob x)
      Sets the designated parameter in this RowSet object's command with the given Blob value.
      void setBlob(int parameterIndex, InputStream inputStream)
      Sets the designated parameter to a InputStream object.
      void setBlob(int parameterIndex, InputStream inputStream, long length)
      Sets the designated parameter to a InputStream object.
      void setBlob(String parameterName, Blob x)
      Sets the designated parameter to the given java.sql.Blob object.
      void setBlob(String parameterName, InputStream inputStream)
      Sets the designated parameter to a InputStream object.
      void setBlob(String parameterName, InputStream inputStream, long length)
      Sets the designated parameter to a InputStream object.
      void setBoolean(int parameterIndex, boolean x)
      Sets the designated parameter in this RowSet object's command to the given Java boolean value.
      void setBoolean(String parameterName, boolean x)
      Sets the designated parameter to the given Java boolean value.
      void setByte(int parameterIndex, byte x)
      Sets the designated parameter in this RowSet object's command to the given Java byte value.
      void setByte(String parameterName, byte x)
      Sets the designated parameter to the given Java byte value.
      void setBytes(int parameterIndex, byte[] x)
      Sets the designated parameter in this RowSet object's command to the given Java array of byte values.
      void setBytes(String parameterName, byte[] x)
      Sets the designated parameter to the given Java array of bytes.
      void setCharacterStream(int parameterIndex, Reader reader)
      Sets the designated parameter in this RowSet object's command to the given Reader object.
      void setCharacterStream(int parameterIndex, Reader reader, int length)
      Sets the designated parameter in this RowSet object's command to the given java.io.Reader value.
      void setCharacterStream(String parameterName, Reader reader)
      Sets the designated parameter to the given Reader object.
      void setCharacterStream(String parameterName, Reader reader, int length)
      Sets the designated parameter to the given Reader object, which is the given number of characters long.
      void setClob(int i, Clob x)
      Sets the designated parameter in this RowSet object's command with the given Clob value.
      void setClob(int parameterIndex, Reader reader)
      Sets the designated parameter to a Reader object.
      void setClob(int parameterIndex, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setClob(String parameterName, Clob x)
      Sets the designated parameter to the given java.sql.Clob object.
      void setClob(String parameterName, Reader reader)
      Sets the designated parameter to a Reader object.
      void setClob(String parameterName, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setCommand(String cmd)
      Sets this RowSet object's command property to the given SQL query.
      void setConcurrency(int concurrency)
      Sets the concurrency of this RowSet object to the given concurrency level.
      void setDataSourceName(String name)
      Sets the data source name property for this RowSet object to the given String.
      void setDate(int parameterIndex, Date x)
      Sets the designated parameter in this RowSet object's command to the given java.sql.Date value.
      void setDate(int parameterIndex, Date x, Calendar cal)
      Sets the designated parameter in this RowSet object's command with the given java.sql.Date value.
      void setDate(String parameterName, Date x)
      Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.
      void setDate(String parameterName, Date x, Calendar cal)
      Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.
      void setDouble(int parameterIndex, double x)
      Sets the designated parameter in this RowSet object's command to the given Java double value.
      void setDouble(String parameterName, double x)
      Sets the designated parameter to the given Java double value.
      void setEscapeProcessing(boolean enable)
      Sets escape processing for this RowSet object on or off.
      void setFloat(int parameterIndex, float x)
      Sets the designated parameter in this RowSet object's command to the given Java float value.
      void setFloat(String parameterName, float x)
      Sets the designated parameter to the given Java float value.
      void setInt(int parameterIndex, int x)
      Sets the designated parameter in this RowSet object's command to the given Java int value.
      void setInt(String parameterName, int x)
      Sets the designated parameter to the given Java int value.
      void setLong(int parameterIndex, long x)
      Sets the designated parameter in this RowSet object's command to the given Java long value.
      void setLong(String parameterName, long x)
      Sets the designated parameter to the given Java long value.
      void setMaxFieldSize(int max)
      Sets the maximum number of bytes that can be returned for a column value to the given number of bytes.
      void setMaxRows(int max)
      Sets the maximum number of rows that this RowSet object can contain to the specified number.
      void setNCharacterStream(int parameterIndex, Reader value)
      Sets the designated parameter in this RowSet object's command to a Reader object.
      void setNCharacterStream(int parameterIndex, Reader value, long length)
      Sets the designated parameter to a Reader object.
      void setNCharacterStream(String parameterName, Reader value)
      Sets the designated parameter to a Reader object.
      void setNCharacterStream(String parameterName, Reader value, long length)
      Sets the designated parameter to a Reader object.
      void setNClob(int parameterIndex, NClob value)
      Sets the designated parameter to a java.sql.NClob object.
      void setNClob(int parameterIndex, Reader reader)
      Sets the designated parameter to a Reader object.
      void setNClob(int parameterIndex, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setNClob(String parameterName, NClob value)
      Sets the designated parameter to a java.sql.NClob object.
      void setNClob(String parameterName, Reader reader)
      Sets the designated parameter to a Reader object.
      void setNClob(String parameterName, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setNString(int parameterIndex, String value)
      Sets the designated paramter to the given String object.
      void setNString(String parameterName, String value)
      Sets the designated paramter to the given String object.
      void setNull(int parameterIndex, int sqlType)
      Sets the designated parameter in this RowSet object's SQL command to SQL NULL.
      void setNull(int paramIndex, int sqlType, String typeName)
      Sets the designated parameter in this RowSet object's SQL command to SQL NULL.
      void setNull(String parameterName, int sqlType)
      Sets the designated parameter to SQL NULL.
      void setNull(String parameterName, int sqlType, String typeName)
      Sets the designated parameter to SQL NULL.
      void setObject(int parameterIndex, Object x)
      Sets the designated parameter in this RowSet object's command with a Java Object.
      void setObject(int parameterIndex, Object x, int targetSqlType)
      Sets the designated parameter in this RowSet object's command with a Java Object.
      void setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
      Sets the designated parameter in this RowSet object's command with the given Java Object.
      void setObject(String parameterName, Object x)
      Sets the value of the designated parameter with the given object.
      void setObject(String parameterName, Object x, int targetSqlType)
      Sets the value of the designated parameter with the given object.
      void setObject(String parameterName, Object x, int targetSqlType, int scale)
      Sets the value of the designated parameter with the given object.
      void setPassword(String password)
      Sets the database password for this RowSet object to the given String.
      void setQueryTimeout(int seconds)
      Sets the maximum time the driver will wait for a statement to execute to the given number of seconds.
      void setReadOnly(boolean value)
      Sets whether this RowSet object is read-only to the given boolean.
      void setRef(int i, Ref x)
      Sets the designated parameter in this RowSet object's command with the given Ref value.
      void setRowId(int parameterIndex, RowId x)
      Sets the designated parameter to the given java.sql.RowId object.
      void setRowId(String parameterName, RowId x)
      Sets the designated parameter to the given java.sql.RowId object.
      void setShort(int parameterIndex, short x)
      Sets the designated parameter in this RowSet object's command to the given Java short value.
      void setShort(String parameterName, short x)
      Sets the designated parameter to the given Java short value.
      void setSQLXML(int parameterIndex, SQLXML xmlObject)
      Sets the designated parameter to the given java.sql.SQLXML object.
      void setSQLXML(String parameterName, SQLXML xmlObject)
      Sets the designated parameter to the given java.sql.SQLXML object.
      void setString(int parameterIndex, String x)
      Sets the designated parameter in this RowSet object's command to the given Java String value.
      void setString(String parameterName, String x)
      Sets the designated parameter to the given Java String value.
      void setTime(int parameterIndex, Time x)
      Sets the designated parameter in this RowSet object's command to the given java.sql.Time value.
      void setTime(int parameterIndex, Time x, Calendar cal)
      Sets the designated parameter in this RowSet object's command with the given java.sql.Time value.
      void setTime(String parameterName, Time x)
      Sets the designated parameter to the given java.sql.Time value.
      void setTime(String parameterName, Time x, Calendar cal)
      Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.
      void setTimestamp(int parameterIndex, Timestamp x)
      Sets the designated parameter in this RowSet object's command to the given java.sql.Timestamp value.
      void setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
      Sets the designated parameter in this RowSet object's command with the given java.sql.Timestamp value.
      void setTimestamp(String parameterName, Timestamp x)
      Sets the designated parameter to the given java.sql.Timestamp value.
      void setTimestamp(String parameterName, Timestamp x, Calendar cal)
      Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.
      void setTransactionIsolation(int level)
      Sets the transaction isolation level for this RowSet obejct.
      void setType(int type)
      Sets the type of this RowSet object to the given type.
      void setTypeMap(Map<String,类<?>> map)
      Installs the given java.util.Map object as the default type map for this RowSet object.
      void setURL(int parameterIndex, URL x)
      Sets the designated parameter to the given java.net.URL value.
      void setUrl(String url)
      Sets the URL this RowSet object will use when it uses the DriverManager to create a connection.
      void setUsername(String name)
      Sets the username property for this RowSet object to the given String.

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

    • 方法详细信息

      • getUrl

        String getUrl()
              throws SQLException
        Retrieves the url property this RowSet object will use to create a connection if it uses the DriverManager instead of a DataSource object to establish the connection. The default value is null.
        返回：
        a string url
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setUrl(java.lang.String)

      • setUrl

        void setUrl(String url)
            throws SQLException
        Sets the URL this RowSet object will use when it uses the DriverManager to create a connection. Setting this property is optional. If a URL is used, a JDBC driver that accepts the URL must be loaded before the rowset is used to connect to a database. The rowset will use the URL internally to create a database connection when reading or writing data. Either a URL or a data source name is used to create a connection, whichever was set to non null value most recently.
        参数：
        url - a string value; may be null
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getUrl()

      • getDataSourceName

        String getDataSourceName()
        Retrieves the logical name that identifies the data source for this RowSet object.
        返回：
        a data source name
        另请参见：
        setDataSourceName(java.lang.String), setUrl(java.lang.String)

      • setDataSourceName

        void setDataSourceName(String name)
                       throws SQLException
        Sets the data source name property for this RowSet object to the given String.

        The value of the data source name property can be used to do a lookup of a DataSource object that has been registered with a naming service. After being retrieved, the DataSource object can be used to create a connection to the data source that it represents.

        参数：
        name - the logical name of the data source for this RowSet object; may be null
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getDataSourceName()

      • getUsername

        String getUsername()
        Retrieves the username used to create a database connection for this RowSet object. The username property is set at run time before calling the method execute. It is not usually part of the serialized state of a RowSet object.
        返回：
        the username property
        另请参见：
        setUsername(java.lang.String)

      • setUsername

        void setUsername(String name)
                 throws SQLException
        Sets the username property for this RowSet object to the given String.
        参数：
        name - a user name
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getUsername()

      • getPassword

        String getPassword()
        Retrieves the password used to create a database connection. The password property is set at run time before calling the method execute. It is not usually part of the serialized state of a RowSet object.
        返回：
        the password for making a database connection
        另请参见：
        setPassword(java.lang.String)

      • setPassword

        void setPassword(String password)
                 throws SQLException
        Sets the database password for this RowSet object to the given String.
        参数：
        password - the password string
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getPassword()

      • getTransactionIsolation

        int getTransactionIsolation()
        Retrieves the transaction isolation level set for this RowSet object.
        返回：
        the transaction isolation level; one of Connection.TRANSACTION_READ_UNCOMMITTED, Connection.TRANSACTION_READ_COMMITTED, Connection.TRANSACTION_REPEATABLE_READ, or Connection.TRANSACTION_SERIALIZABLE
        另请参见：
        setTransactionIsolation(int)

      • setTransactionIsolation

        void setTransactionIsolation(int level)
                             throws SQLException
        Sets the transaction isolation level for this RowSet obejct.
        参数：
        level - the transaction isolation level; one of Connection.TRANSACTION_READ_UNCOMMITTED, Connection.TRANSACTION_READ_COMMITTED, Connection.TRANSACTION_REPEATABLE_READ, or Connection.TRANSACTION_SERIALIZABLE
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getTransactionIsolation()

      • getTypeMap

        Map<String,类<?>> getTypeMap()
                                throws SQLException
        Retrieves the Map object associated with this RowSet object, which specifies the custom mapping of SQL user-defined types, if any. The default is for the type map to be empty.
        返回：
        a java.util.Map object containing the names of SQL user-defined types and the Java classes to which they are to be mapped
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setTypeMap(java.util.Map>)

      • setTypeMap

        void setTypeMap(Map<String,类<?>> map)
                throws SQLException
        Installs the given java.util.Map object as the default type map for this RowSet object. This type map will be used unless another type map is supplied as a method parameter.
        参数：
        map - a java.util.Map object containing the names of SQL user-defined types and the Java classes to which they are to be mapped
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getTypeMap()

      • getCommand

        String getCommand()
        Retrieves this RowSet object's command property. The command property contains a command string, which must be an SQL query, that can be executed to fill the rowset with data. The default value is null.
        返回：
        the command string; may be null
        另请参见：
        setCommand(java.lang.String)

      • setCommand

        void setCommand(String cmd)
                throws SQLException
        Sets this RowSet object's command property to the given SQL query. This property is optional when a rowset gets its data from a data source that does not support commands, such as a spreadsheet.
        参数：
        cmd - the SQL query that will be used to get the data for this RowSet object; may be null
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getCommand()

      • isReadOnly

        boolean isReadOnly()
        Retrieves whether this RowSet object is read-only. If updates are possible, the default is for a rowset to be updatable.

        Attempts to update a read-only rowset will result in an SQLException being thrown.

        返回：
        true if this RowSet object is read-only; false if it is updatable
        另请参见：
        setReadOnly(boolean)

      • setReadOnly

        void setReadOnly(boolean value)
                 throws SQLException
        Sets whether this RowSet object is read-only to the given boolean.
        参数：
        value - true if read-only; false if updatable
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        isReadOnly()

      • getMaxFieldSize

        int getMaxFieldSize()
                    throws SQLException
        Retrieves the maximum number of bytes that may be returned for certain column values. This limit applies only to BINARY, VARBINARY, LONGVARBINARYBINARY, CHAR, VARCHAR, LONGVARCHAR, NCHAR and NVARCHAR columns. If the limit is exceeded, the excess data is silently discarded.
        返回：
        the current maximum column size limit; zero means that there is no limit
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setMaxFieldSize(int)

      • setMaxFieldSize

        void setMaxFieldSize(int max)
                     throws SQLException
        Sets the maximum number of bytes that can be returned for a column value to the given number of bytes. This limit applies only to BINARY, VARBINARY, LONGVARBINARYBINARY, CHAR, VARCHAR, LONGVARCHAR, NCHAR and NVARCHAR columns. If the limit is exceeded, the excess data is silently discarded. For maximum portability, use values greater than 256.
        参数：
        max - the new max column size limit in bytes; zero means unlimited
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getMaxFieldSize()

      • getMaxRows

        int getMaxRows()
               throws SQLException
        Retrieves the maximum number of rows that this RowSet object can contain. If the limit is exceeded, the excess rows are silently dropped.
        返回：
        the current maximum number of rows that this RowSet object can contain; zero means unlimited
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setMaxRows(int)

      • setMaxRows

        void setMaxRows(int max)
                throws SQLException
        Sets the maximum number of rows that this RowSet object can contain to the specified number. If the limit is exceeded, the excess rows are silently dropped.
        参数：
        max - the new maximum number of rows; zero means unlimited
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getMaxRows()

      • getEscapeProcessing

        boolean getEscapeProcessing()
                            throws SQLException
        Retrieves whether escape processing is enabled for this RowSet object. If escape scanning is enabled, which is the default, the driver will do escape substitution before sending an SQL statement to the database.
        返回：
        true if escape processing is enabled; false if it is disabled
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setEscapeProcessing(boolean)

      • setEscapeProcessing

        void setEscapeProcessing(boolean enable)
                         throws SQLException
        Sets escape processing for this RowSet object on or off. If escape scanning is on (the default), the driver will do escape substitution before sending an SQL statement to the database.
        参数：
        enable - true to enable escape processing; false to disable it
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getEscapeProcessing()

      • getQueryTimeout

        int getQueryTimeout()
                    throws SQLException
        Retrieves the maximum number of seconds the driver will wait for a statement to execute. If this limit is exceeded, an SQLException is thrown.
        返回：
        the current query timeout limit in seconds; zero means unlimited
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        setQueryTimeout(int)

      • setQueryTimeout

        void setQueryTimeout(int seconds)
                     throws SQLException
        Sets the maximum time the driver will wait for a statement to execute to the given number of seconds. If this limit is exceeded, an SQLException is thrown.
        参数：
        seconds - the new query timeout limit in seconds; zero means that there is no limit
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        getQueryTimeout()

      • setType

        void setType(int type)
             throws SQLException
        Sets the type of this RowSet object to the given type. This method is used to change the type of a rowset, which is by default read-only and non-scrollable.
        参数：
        type - one of the ResultSet constants specifying a type: ResultSet.TYPE_FORWARD_ONLY, ResultSet.TYPE_SCROLL_INSENSITIVE, or ResultSet.TYPE_SCROLL_SENSITIVE
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        ResultSet.getType()

      • setConcurrency

        void setConcurrency(int concurrency)
                    throws SQLException
        Sets the concurrency of this RowSet object to the given concurrency level. This method is used to change the concurrency level of a rowset, which is by default ResultSet.CONCUR_READ_ONLY
        参数：
        concurrency - one of the ResultSet constants specifying a concurrency level: ResultSet.CONCUR_READ_ONLY or ResultSet.CONCUR_UPDATABLE
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        ResultSet.getConcurrency()

      • setNull

        void setNull(int parameterIndex,
           int sqlType)
             throws SQLException
        Sets the designated parameter in this RowSet object's SQL command to SQL NULL.

        Note: You must specify the parameter's SQL type.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        sqlType - a SQL type code defined by java.sql.Types
        抛出：
        SQLException - if a database access error occurs

      • setNull

        void setNull(String parameterName,
           int sqlType)
             throws SQLException
        Sets the designated parameter to SQL NULL.

        Note: You must specify the parameter's SQL type.

        参数：
        parameterName - the name of the parameter
        sqlType - the SQL type code defined in java.sql.Types
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setNull

        void setNull(int paramIndex,
           int sqlType,
           String typeName)
             throws SQLException
        Sets the designated parameter in this RowSet object's SQL command to SQL NULL. This version of the method setNull should be used for SQL user-defined types (UDTs) and REF type parameters. Examples of UDTs include: STRUCT, DISTINCT, JAVA_OBJECT, and named array types.

        Note: To be portable, applications must give the SQL type code and the fully qualified SQL type name when specifying a NULL UDT or REF parameter. In the case of a UDT, the name is the type name of the parameter itself. For a REF parameter, the name is the type name of the referenced type. If a JDBC driver does not need the type code or type name information, it may ignore it. Although it is intended for UDT and REF parameters, this method may be used to set a null parameter of any JDBC type. If the parameter does not have a user-defined or REF type, the typeName parameter is ignored.

        参数：
        paramIndex - the first parameter is 1, the second is 2, ...
        sqlType - a value from java.sql.Types
        typeName - the fully qualified name of an SQL UDT or the type name of the SQL structured type being referenced by a REF type; ignored if the parameter is not a UDT or REF type
        抛出：
        SQLException - if a database access error occurs

      • setNull

        void setNull(String parameterName,
           int sqlType,
           String typeName)
             throws SQLException
        Sets the designated parameter to SQL NULL. This version of the method setNull should be used for user-defined types and REF type parameters. Examples of user-defined types include: STRUCT, DISTINCT, JAVA_OBJECT, and named array types.

        Note: To be portable, applications must give the SQL type code and the fully-qualified SQL type name when specifying a NULL user-defined or REF parameter. In the case of a user-defined type the name is the type name of the parameter itself. For a REF parameter, the name is the type name of the referenced type. If a JDBC driver does not need the type code or type name information, it may ignore it. Although it is intended for user-defined and Ref parameters, this method may be used to set a null parameter of any JDBC type. If the parameter does not have a user-defined or REF type, the given typeName is ignored.

        参数：
        parameterName - the name of the parameter
        sqlType - a value from java.sql.Types
        typeName - the fully-qualified name of an SQL user-defined type; ignored if the parameter is not a user-defined type or SQL REF value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setBoolean

        void setBoolean(int parameterIndex,
              boolean x)
                throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java boolean value. The driver converts this to an SQL BIT value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setBoolean

        void setBoolean(String parameterName,
              boolean x)
                throws SQLException
        Sets the designated parameter to the given Java boolean value. The driver converts this to an SQL BIT or BOOLEAN value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getBoolean(int)

      • setByte

        void setByte(int parameterIndex,
           byte x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java byte value. The driver converts this to an SQL TINYINT value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setByte

        void setByte(String parameterName,
           byte x)
             throws SQLException
        Sets the designated parameter to the given Java byte value. The driver converts this to an SQL TINYINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getByte(int)

      • setShort

        void setShort(int parameterIndex,
            short x)
              throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java short value. The driver converts this to an SQL SMALLINT value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setShort

        void setShort(String parameterName,
            short x)
              throws SQLException
        Sets the designated parameter to the given Java short value. The driver converts this to an SQL SMALLINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getShort(int)

      • setInt

        void setInt(int parameterIndex,
          int x)
            throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java int value. The driver converts this to an SQL INTEGER value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setInt

        void setInt(String parameterName,
          int x)
            throws SQLException
        Sets the designated parameter to the given Java int value. The driver converts this to an SQL INTEGER value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getInt(int)

      • setLong

        void setLong(int parameterIndex,
           long x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java long value. The driver converts this to an SQL BIGINT value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setLong

        void setLong(String parameterName,
           long x)
             throws SQLException
        Sets the designated parameter to the given Java long value. The driver converts this to an SQL BIGINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getLong(int)

      • setFloat

        void setFloat(int parameterIndex,
            float x)
              throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java float value. The driver converts this to an SQL REAL value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setFloat

        void setFloat(String parameterName,
            float x)
              throws SQLException
        Sets the designated parameter to the given Java float value. The driver converts this to an SQL FLOAT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getFloat(int)

      • setDouble

        void setDouble(int parameterIndex,
             double x)
               throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java double value. The driver converts this to an SQL DOUBLE value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setDouble

        void setDouble(String parameterName,
             double x)
               throws SQLException
        Sets the designated parameter to the given Java double value. The driver converts this to an SQL DOUBLE value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getDouble(int)

      • setBigDecimal

        void setBigDecimal(int parameterIndex,
                 BigDecimal x)
                   throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.math.BigDeciaml value. The driver converts this to an SQL NUMERIC value before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setBigDecimal

        void setBigDecimal(String parameterName,
                 BigDecimal x)
                   throws SQLException
        Sets the designated parameter to the given java.math.BigDecimal value. The driver converts this to an SQL NUMERIC value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getBigDecimal(int, int)

      • setString

        void setString(int parameterIndex,
             String x)
               throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java String value. Before sending it to the database, the driver converts this to an SQL VARCHAR or LONGVARCHAR value, depending on the argument's size relative to the driver's limits on VARCHAR values.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setString

        void setString(String parameterName,
             String x)
               throws SQLException
        Sets the designated parameter to the given Java String value. The driver converts this to an SQL VARCHAR or LONGVARCHAR value (depending on the argument's size relative to the driver's limits on VARCHAR values) when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getString(int)

      • setBytes

        void setBytes(int parameterIndex,
            byte[] x)
              throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Java array of byte values. Before sending it to the database, the driver converts this to an SQL VARBINARY or LONGVARBINARY value, depending on the argument's size relative to the driver's limits on VARBINARY values.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setBytes

        void setBytes(String parameterName,
            byte[] x)
              throws SQLException
        Sets the designated parameter to the given Java array of bytes. The driver converts this to an SQL VARBINARY or LONGVARBINARY (depending on the argument's size relative to the driver's limits on VARBINARY values) when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getBytes(int)

      • setDate

        void setDate(int parameterIndex,
           Date x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.sql.Date value. The driver converts this to an SQL DATE value before sending it to the database, using the default java.util.Calendar to calculate the date.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setTime

        void setTime(int parameterIndex,
           Time x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.sql.Time value. The driver converts this to an SQL TIME value before sending it to the database, using the default java.util.Calendar to calculate it.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setTimestamp

        void setTimestamp(int parameterIndex,
                Timestamp x)
                  throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.sql.Timestamp value. The driver converts this to an SQL TIMESTAMP value before sending it to the database, using the default java.util.Calendar to calculate it.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs

      • setTimestamp

        void setTimestamp(String parameterName,
                Timestamp x)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp value. The driver converts this to an SQL TIMESTAMP value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getTimestamp(int)

      • setAsciiStream

        void setAsciiStream(int parameterIndex,
                  InputStream x,
                  int length)
                    throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value. It may be more practical to send a very large ASCII value via a java.io.InputStream rather than as a LONGVARCHAR parameter. The driver will read the data from the stream as needed until it reaches end-of-file.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the Java input stream that contains the ASCII parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs

      • setAsciiStream

        void setAsciiStream(String parameterName,
                  InputStream x,
                  int length)
                    throws SQLException
        Sets the designated parameter to the given input stream, which will have the specified number of bytes. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        x - the Java input stream that contains the ASCII parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setBinaryStream

        void setBinaryStream(int parameterIndex,
                   InputStream x,
                   int length)
                     throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value. It may be more practical to send a very large binary value via a java.io.InputStream rather than as a LONGVARBINARY parameter. The driver will read the data from the stream as needed until it reaches end-of-file.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the java input stream which contains the binary parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs

      • setBinaryStream

        void setBinaryStream(String parameterName,
                   InputStream x,
                   int length)
                     throws SQLException
        Sets the designated parameter to the given input stream, which will have the specified number of bytes. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        x - the java input stream which contains the binary parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setCharacterStream

        void setCharacterStream(int parameterIndex,
                      Reader reader,
                      int length)
                        throws SQLException
        Sets the designated parameter in this RowSet object's command to the given java.io.Reader value. It may be more practical to send a very large UNICODE value via a java.io.Reader rather than as a LONGVARCHAR parameter. The driver will read the data from the stream as needed until it reaches end-of-file.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        reader - the Reader object that contains the UNICODE data to be set
        length - the number of characters in the stream
        抛出：
        SQLException - if a database access error occurs

      • setCharacterStream

        void setCharacterStream(String parameterName,
                      Reader reader,
                      int length)
                        throws SQLException
        Sets the designated parameter to the given Reader object, which is the given number of characters long. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        reader - the java.io.Reader object that contains the UNICODE data used as the designated parameter
        length - the number of characters in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setAsciiStream

        void setAsciiStream(int parameterIndex,
                  InputStream x)
                    throws SQLException
        Sets the designated parameter in this RowSet object's command to the given input stream. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setAsciiStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the Java input stream that contains the ASCII parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setAsciiStream

        void setAsciiStream(String parameterName,
                  InputStream x)
                    throws SQLException
        Sets the designated parameter to the given input stream. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setAsciiStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        x - the Java input stream that contains the ASCII parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream(int parameterIndex,
                   InputStream x)
                     throws SQLException
        Sets the designated parameter in this RowSet object's command to the given input stream. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBinaryStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the java input stream which contains the binary parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBinaryStream

        void setBinaryStream(String parameterName,
                   InputStream x)
                     throws SQLException
        Sets the designated parameter to the given input stream. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBinaryStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        x - the java input stream which contains the binary parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream(int parameterIndex,
                      Reader reader)
                        throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Reader object. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setCharacterStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        reader - the java.io.Reader object that contains the Unicode data
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setCharacterStream

        void setCharacterStream(String parameterName,
                      Reader reader)
                        throws SQLException
        Sets the designated parameter to the given Reader object. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setCharacterStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - the java.io.Reader object that contains the Unicode data
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream(int parameterIndex,
                       Reader value)
                         throws SQLException
        Sets the designated parameter in this RowSet object's command to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNCharacterStream which takes a length parameter.

        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; if a database access error occurs; or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setObject

        void setObject(int parameterIndex,
             Object x,
             int targetSqlType,
             int scaleOrLength)
               throws SQLException
        Sets the designated parameter in this RowSet object's command with the given Java Object. For integral values, the java.lang equivalent objects should be used (for example, an instance of the class Integer for an int). If the second argument is an InputStream then the stream must contain the number of bytes specified by scaleOrLength. If the second argument is a Reader then the reader must contain the number of characters specified * by scaleOrLength. If these conditions are not true the driver will generate a SQLException when the prepared statement is executed.

        The given Java object will be converted to the targetSqlType before being sent to the database.

        If the object is of a class implementing SQLData, the rowset should call the method SQLData.writeSQL to write the object to an SQLOutput data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        Note that this method may be used to pass datatabase-specific abstract data types.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database. The scale argument may further qualify this type.
        scaleOrLength - for java.sql.Types.DECIMAL or java.sql.Types.NUMERIC types, this is the number of digits after the decimal point. For Java Object types InputStream and Reader, this is the length of the data in the stream or reader. For all other types, this value will be ignored.
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        Types

      • setObject

        void setObject(String parameterName,
             Object x,
             int targetSqlType,
             int scale)
               throws SQLException
        Sets the value of the designated parameter with the given object. The second argument must be an object type; for integral values, the java.lang equivalent objects should be used.

        The given Java object will be converted to the given targetSqlType before being sent to the database. If the object has a custom mapping (is of a class implementing the interface SQLData), the JDBC driver should call the method SQLData.writeSQL to write it to the SQL data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        Note that this method may be used to pass datatabase- specific abstract data types.

        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database. The scale argument may further qualify this type.
        scale - for java.sql.Types.DECIMAL or java.sql.Types.NUMERIC types, this is the number of digits after the decimal point. For all other types, this value will be ignored.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if targetSqlType is a ARRAY, BLOB, CLOB, DATALINK, JAVA_OBJECT, NCHAR, NCLOB, NVARCHAR, LONGNVARCHAR, REF, ROWID, SQLXML or STRUCT data type and the JDBC driver does not support this data type
        从以下版本开始：
        1.4
        另请参见：
        Types, ResultSet.getObject(int)

      • setObject

        void setObject(int parameterIndex,
             Object x,
             int targetSqlType)
               throws SQLException
        Sets the designated parameter in this RowSet object's command with a Java Object. For integral values, the java.lang equivalent objects should be used. This method is like setObject above, but the scale used is the scale of the second parameter. Scalar values have a scale of zero. Literal values have the scale present in the literal.

        Even though it is supported, it is not recommended that this method be called with floating point input values.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database
        抛出：
        SQLException - if a database access error occurs

      • setObject

        void setObject(String parameterName,
             Object x,
             int targetSqlType)
               throws SQLException
        Sets the value of the designated parameter with the given object. This method is like the method setObject above, except that it assumes a scale of zero.
        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if targetSqlType is a ARRAY, BLOB, CLOB, DATALINK, JAVA_OBJECT, NCHAR, NCLOB, NVARCHAR, LONGNVARCHAR, REF, ROWID, SQLXML or STRUCT data type and the JDBC driver does not support this data type
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getObject(int)

      • setObject

        void setObject(String parameterName,
             Object x)
               throws SQLException
        Sets the value of the designated parameter with the given object. The second parameter must be of type Object; therefore, the java.lang equivalent objects should be used for built-in types.

        The JDBC specification specifies a standard mapping from Java Object types to SQL types. The given argument will be converted to the corresponding SQL type before being sent to the database.

        Note that this method may be used to pass datatabase- specific abstract data types, by using a driver-specific Java type. If the object is of a class implementing the interface SQLData, the JDBC driver should call the method SQLData.writeSQL to write it to the SQL data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        This method throws an exception if there is an ambiguity, for example, if the object is of a class implementing more than one of the interfaces named above.

        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed CallableStatement or if the given Object parameter is ambiguous
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getObject(int)

      • setObject

        void setObject(int parameterIndex,
             Object x)
               throws SQLException
        Sets the designated parameter in this RowSet object's command with a Java Object. For integral values, the java.lang equivalent objects should be used.

        The JDBC specification provides a standard mapping from Java Object types to SQL types. The driver will convert the given Java object to its standard SQL mapping before sending it to the database.

        Note that this method may be used to pass datatabase-specific abstract data types by using a driver-specific Java type. If the object is of a class implementing SQLData, the rowset should call the method SQLData.writeSQL to write the object to an SQLOutput data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        An exception is thrown if there is an ambiguity, for example, if the object is of a class implementing more than one of these interfaces.

        参数：
        parameterIndex - The first parameter is 1, the second is 2, ...
        x - The object containing the input parameter value
        抛出：
        SQLException - if a database access error occurs

      • setRef

        void setRef(int i,
          Ref x)
            throws SQLException
        Sets the designated parameter in this RowSet object's command with the given Ref value. The driver will convert this to the appropriate REF(<structured-type>) value.
        参数：
        i - the first parameter is 1, the second is 2, ...
        x - an object representing data of an SQL REF type
        抛出：
        SQLException - if a database access error occurs

      • setBlob

        void setBlob(int i,
           Blob x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command with the given Blob value. The driver will convert this to the BLOB value that the Blob object represents before sending it to the database.
        参数：
        i - the first parameter is 1, the second is 2, ...
        x - an object representing a BLOB
        抛出：
        SQLException - if a database access error occurs

      • setBlob

        void setBlob(int parameterIndex,
           InputStream inputStream,
           long length)
             throws SQLException
        Sets the designated parameter to a InputStream object. The inputstream must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setBinaryStream (int, InputStream, int) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        length - the number of bytes in the parameter data.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement, if parameterIndex does not correspond to a parameter marker in the SQL statement, if the length specified is less than zero or if the number of bytes in the inputstream does not match the specfied length.
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        void setBlob(int parameterIndex,
           InputStream inputStream)
             throws SQLException
        Sets the designated parameter to a InputStream object. This method differs from the setBinaryStream (int, InputStream) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBlob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement or if parameterIndex does not correspond to a parameter marker in the SQL statement,
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        void setBlob(String parameterName,
           InputStream inputStream,
           long length)
             throws SQLException
        Sets the designated parameter to a InputStream object. The inputstream must contain the number of characters specified by length, otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setBinaryStream (int, InputStream, int) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB
        参数：
        parameterName - the name of the parameter to be set the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        length - the number of bytes in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement, or if the length specified is less than zero; if the number of bytes in the inputstream does not match the specfied length; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        void setBlob(String parameterName,
           Blob x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Blob object. The driver converts this to an SQL BLOB value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - a Blob object that maps an SQL BLOB value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        void setBlob(String parameterName,
           InputStream inputStream)
             throws SQLException
        Sets the designated parameter to a InputStream object. This method differs from the setBinaryStream (int, InputStream) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARBINARY or a BLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBlob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        inputStream - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        void setClob(int i,
           Clob x)
             throws SQLException
        Sets the designated parameter in this RowSet object's command with the given Clob value. The driver will convert this to the CLOB value that the Clob object represents before sending it to the database.
        参数：
        i - the first parameter is 1, the second is 2, ...
        x - an object representing a CLOB
        抛出：
        SQLException - if a database access error occurs

      • setClob

        void setClob(int parameterIndex,
           Reader reader,
           long length)
             throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARCHAR or a CLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement, if parameterIndex does not correspond to a parameter marker in the SQL statement, or if the length specified is less than zero.
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        void setClob(int parameterIndex,
           Reader reader)
             throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARCHAR or a CLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setClob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatementor if parameterIndex does not correspond to a parameter marker in the SQL statement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        void setClob(String parameterName,
           Reader reader,
           long length)
             throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARCHAR or a CLOB
        参数：
        parameterName - the name of the parameter to be set
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        void setClob(String parameterName,
           Clob x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Clob object. The driver converts this to an SQL CLOB value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - a Clob object that maps an SQL CLOB value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        void setClob(String parameterName,
           Reader reader)
             throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARCHAR or a CLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setClob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setArray

        void setArray(int i,
            Array x)
              throws SQLException
        Sets the designated parameter in this RowSet object's command with the given Array value. The driver will convert this to the ARRAY value that the Array object represents before sending it to the database.
        参数：
        i - the first parameter is 1, the second is 2, ...
        x - an object representing an SQL array
        抛出：
        SQLException - if a database access error occurs

      • setDate

        void setDate(int parameterIndex,
           Date x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter in this RowSet object's command with the given java.sql.Date value. The driver will convert this to an SQL DATE value, using the given java.util.Calendar object to calculate the date.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        cal - the java.util.Calendar object to use for calculating the date
        抛出：
        SQLException - if a database access error occurs

      • setDate

        void setDate(String parameterName,
           Date x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application. The driver converts this to an SQL DATE value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getDate(int)

      • setDate

        void setDate(String parameterName,
           Date x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date value, using the given Calendar object. The driver uses the Calendar object to construct an SQL DATE value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the date taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the date
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getDate(int)

      • setTime

        void setTime(int parameterIndex,
           Time x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter in this RowSet object's command with the given java.sql.Time value. The driver will convert this to an SQL TIME value, using the given java.util.Calendar object to calculate it, before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        cal - the java.util.Calendar object to use for calculating the time
        抛出：
        SQLException - if a database access error occurs

      • setTime

        void setTime(String parameterName,
           Time x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time value. The driver converts this to an SQL TIME value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getTime(int)

      • setTime

        void setTime(String parameterName,
           Time x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time value, using the given Calendar object. The driver uses the Calendar object to construct an SQL TIME value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the time taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the time
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getTime(int)

      • setTimestamp

        void setTimestamp(int parameterIndex,
                Timestamp x,
                Calendar cal)
                  throws SQLException
        Sets the designated parameter in this RowSet object's command with the given java.sql.Timestamp value. The driver will convert this to an SQL TIMESTAMP value, using the given java.util.Calendar object to calculate it, before sending it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        cal - the java.util.Calendar object to use for calculating the timestamp
        抛出：
        SQLException - if a database access error occurs

      • setTimestamp

        void setTimestamp(String parameterName,
                Timestamp x,
                Calendar cal)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object. The driver uses the Calendar object to construct an SQL TIMESTAMP value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the timestamp taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the timestamp
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        ResultSet.getTimestamp(int)

      • clearParameters

        void clearParameters()
                     throws SQLException
        Clears the parameters set for this RowSet object's command.

        In general, parameter values remain in force for repeated use of a RowSet object. Setting a parameter value automatically clears its previous value. However, in some cases it is useful to immediately release the resources used by the current parameter values, which can be done by calling the method clearParameters.

        抛出：
        SQLException - if a database access error occurs

      • execute

        void execute()
             throws SQLException
        Fills this RowSet object with data.

        The execute method may use the following properties to create a connection for reading data: url, data source name, user name, password, transaction isolation, and type map. The execute method may use the following properties to create a statement to execute a command: command, read only, maximum field size, maximum rows, escape processing, and query timeout.

        If the required properties have not been set, an exception is thrown. If this method is successful, the current contents of the rowset are discarded and the rowset's metadata is also (re)set. If there are outstanding updates, they are ignored.

        If this RowSet object does not maintain a continuous connection with its source of data, it may use a reader (a RowSetReader object) to fill itself with data. In this case, a reader will have been registered with this RowSet object, and the method execute will call on the reader's readData method as part of its implementation.

        抛出：
        SQLException - if a database access error occurs or any of the properties necessary for making a connection and creating a statement have not been set

      • addRowSetListener

        void addRowSetListener(RowSetListener listener)
        Registers the given listener so that it will be notified of events that occur on this RowSet object.
        参数：
        listener - a component that has implemented the RowSetListener interface and wants to be notified when events occur on this RowSet object
        另请参见：
        removeRowSetListener(javax.sql.RowSetListener)

      • removeRowSetListener

        void removeRowSetListener(RowSetListener listener)
        Removes the specified listener from the list of components that will be notified when an event occurs on this RowSet object.
        参数：
        listener - a component that has been registered as a listener for this RowSet object
        另请参见：
        addRowSetListener(javax.sql.RowSetListener)

      • setSQLXML

        void setSQLXML(int parameterIndex,
             SQLXML xmlObject)
               throws SQLException
        Sets the designated parameter to the given java.sql.SQLXML object. The driver converts this to an SQL XML value when it sends it to the database.
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        xmlObject - a SQLXML object that maps an SQL XML value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed result set, the java.xml.transform.Result, Writer or OutputStream has not been closed for the SQLXML object or if there is an error processing the XML value. The getCause method of the exception may provide a more detailed exception, for example, if the stream does not contain valid XML.
        从以下版本开始：
        1.6

      • setSQLXML

        void setSQLXML(String parameterName,
             SQLXML xmlObject)
               throws SQLException
        Sets the designated parameter to the given java.sql.SQLXML object. The driver converts this to an SQL XML value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        xmlObject - a SQLXML object that maps an SQL XML value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed result set, the java.xml.transform.Result, Writer or OutputStream has not been closed for the SQLXML object or if there is an error processing the XML value. The getCause method of the exception may provide a more detailed exception, for example, if the stream does not contain valid XML.
        从以下版本开始：
        1.6

      • setRowId

        void setRowId(int parameterIndex,
            RowId x)
              throws SQLException
        Sets the designated parameter to the given java.sql.RowId object. The driver converts this to a SQL ROWID value when it sends it to the database
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • setRowId

        void setRowId(String parameterName,
            RowId x)
              throws SQLException
        Sets the designated parameter to the given java.sql.RowId object. The driver converts this to a SQL ROWID when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • setNString

        void setNString(int parameterIndex,
              String value)
                throws SQLException
        Sets the designated paramter to the given String object. The driver converts this to a SQL NCHAR or NVARCHAR or LONGNVARCHAR value (depending on the argument's size relative to the driver's limits on NVARCHAR values) when it sends it to the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNString

        void setNString(String parameterName,
              String value)
                throws SQLException
        Sets the designated paramter to the given String object. The driver converts this to a SQL NCHAR or NVARCHAR or LONGNVARCHAR
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream(int parameterIndex,
                       Reader value,
                       long length)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream(String parameterName,
                       Reader value,
                       long length)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        void setNCharacterStream(String parameterName,
                       Reader value)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNCharacterStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; if a database access error occurs; or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(String parameterName,
            NClob value)
              throws SQLException
        Sets the designated parameter to a java.sql.NClob object. The object implements the java.sql.NClob interface. This NClob object maps to a SQL NCLOB.
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(String parameterName,
            Reader reader,
            long length)
              throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGNVARCHAR or a NCLOB
        参数：
        parameterName - the name of the parameter to be set
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(String parameterName,
            Reader reader)
              throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGNVARCHAR or a NCLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNClob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(int parameterIndex,
            Reader reader,
            long length)
              throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGNVARCHAR or a NCLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(int parameterIndex,
            NClob value)
              throws SQLException
        Sets the designated parameter to a java.sql.NClob object. The driver converts this to a SQL NCLOB value when it sends it to the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNClob

        void setNClob(int parameterIndex,
            Reader reader)
              throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGNVARCHAR or a NCLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNClob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setURL

        void setURL(int parameterIndex,
          URL x)
            throws SQLException
        Sets the designated parameter to the given java.net.URL value. The driver converts this to an SQL DATALINK value when it sends it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the java.net.URL object to be set
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


RowSetEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sql

类 RowSetEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.sql.RowSetEvent
  • 所有已实现的接口：
    Serializable

    public class RowSetEvent
extends EventObject
    An Event object generated when an event occurs to a RowSet object. A RowSetEvent object is generated when a single row in a rowset is changed, the whole rowset is changed, or the rowset cursor moves.

    When an event occurs on a RowSet object, one of the RowSetListener methods will be sent to all registered listeners to notify them of the event. An Event object is supplied to the RowSetListener method so that the listener can use it to find out which RowSet object is the source of the event.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSetEvent(RowSet source)
      Constructs a RowSetEvent object initialized with the given RowSet object.

    • 方法摘要

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RowSetEvent

        public RowSetEvent(RowSet source)
        Constructs a RowSetEvent object initialized with the given RowSet object.
        参数：
        source - the RowSet object whose data has changed or whose cursor has moved
        抛出：
        IllegalArgumentException - if source is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cTdo"el"ep==epp"c iac>>thMnia


RowSetInternal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSetInternal

  • public interface RowSetInternal
    The interface that a RowSet object implements in order to present itself to a RowSetReader or RowSetWriter object. The RowSetInternal interface contains methods that let the reader or writer access and modify the internal state of the rowset.
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Connection getConnection()
      Retrieves the Connection object that was passed to this RowSet object.
      ResultSet getOriginal()
      Retrieves a ResultSet object containing the original value of this RowSet object.
      ResultSet getOriginalRow()
      Retrieves a ResultSet object containing the original value of the current row only.
      Object[] getParams()
      Retrieves the parameters that have been set for this RowSet object's command.
      void setMetaData(RowSetMetaData md)
      Sets the given RowSetMetaData object as the RowSetMetaData object for this RowSet object.

    • 方法详细信息

      • getParams

        Object[] getParams()
                   throws SQLException
        Retrieves the parameters that have been set for this RowSet object's command.
        返回：
        an array of the current parameter values for this RowSet object's command
        抛出：
        SQLException - if a database access error occurs

      • getConnection

        Connection getConnection()
                         throws SQLException
        Retrieves the Connection object that was passed to this RowSet object.
        返回：
        the Connection object passed to the rowset or null if none was passed
        抛出：
        SQLException - if a database access error occurs

      • setMetaData

        void setMetaData(RowSetMetaData md)
                 throws SQLException
        Sets the given RowSetMetaData object as the RowSetMetaData object for this RowSet object. The RowSetReader object associated with the rowset will use RowSetMetaData methods to set the values giving information about the rowset's columns.
        参数：
        md - the RowSetMetaData object that will be set with information about the rowset's columns
        抛出：
        SQLException - if a database access error occurs

      • getOriginal

        ResultSet getOriginal()
                      throws SQLException
        Retrieves a ResultSet object containing the original value of this RowSet object.

        The cursor is positioned before the first row in the result set. Only rows contained in the result set returned by the method getOriginal are said to have an original value.

        返回：
        the original value of the rowset
        抛出：
        SQLException - if a database access error occurs

      • getOriginalRow

        ResultSet getOriginalRow()
                         throws SQLException
        Retrieves a ResultSet object containing the original value of the current row only. If the current row has no original value, an empty result set is returned. If there is no current row, an exception is thrown.
        返回：
        the original value of the current row as a ResultSet object
        抛出：
        SQLException - if a database access error occurs or this method is called while the cursor is on the insert row, before the first row, or after the last row
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

er=oto mriicpjlbe)aL� x&tovaa t


RowSetListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSetListener

  • All Superinterfaces:
    EventListener

    public interface RowSetListener
extends EventListener
    An interface that must be implemented by a component that wants to be notified when a significant event happens in the life of a RowSet object. A component becomes a listener by being registered with a RowSet object via the method RowSet.addRowSetListener. How a registered component implements this interface determines what it does when it is notified of an event.
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void cursorMoved(RowSetEvent event)
      Notifies registered listeners that a RowSet object's cursor has moved.
      void rowChanged(RowSetEvent event)
      Notifies registered listeners that a RowSet object has had a change in one of its rows.
      void rowSetChanged(RowSetEvent event)
      Notifies registered listeners that a RowSet object in the given RowSetEvent object has changed its entire contents.

    • 方法详细信息

      • rowSetChanged

        void rowSetChanged(RowSetEvent event)
        Notifies registered listeners that a RowSet object in the given RowSetEvent object has changed its entire contents.

        The source of the event can be retrieved with the method event.getSource.

        参数：
        event - a RowSetEvent object that contains the RowSet object that is the source of the event

      • rowChanged

        void rowChanged(RowSetEvent event)
        Notifies registered listeners that a RowSet object has had a change in one of its rows.

        The source of the event can be retrieved with the method event.getSource.

        参数：
        event - a RowSetEvent object that contains the RowSet object that is the source of the event

      • cursorMoved

        void cursorMoved(RowSetEvent event)
        Notifies registered listeners that a RowSet object's cursor has moved.

        The source of the event can be retrieved with the method event.getSource.

        参数：
        event - a RowSetEvent object that contains the RowSet object that is the source of the event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vtalte"le"l "llnEjjd>odd>


RowSetMetaData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSetMetaData

  • All Superinterfaces:
    ResultSetMetaData, Wrapper
    All Known Implementing Classes:
    RowSetMetaDataImpl

    public interface RowSetMetaData
extends ResultSetMetaData
    An object that contains information about the columns in a RowSet object. This interface is an extension of the ResultSetMetaData interface with methods for setting the values in a RowSetMetaData object. When a RowSetReader object reads data into a RowSet object, it creates a RowSetMetaData object and initializes it using the methods in the RowSetMetaData interface. Then the reader passes the RowSetMetaData object to the rowset.

    The methods in this interface are invoked internally when an application calls the method RowSet.execute; an application programmer would not use them directly.

    从以下版本开始：
    1.4

    • 字段摘要

      • 字段 - 继承于接口 java.sql.ResultSetMetaData

        columnNoNulls, columnNullable, columnNullableUnknown

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void setAutoIncrement(int columnIndex, boolean property)
      Sets whether the designated column is automatically numbered, The default is for a RowSet object's columns not to be automatically numbered.
      void setCaseSensitive(int columnIndex, boolean property)
      Sets whether the designated column is case sensitive.
      void setCatalogName(int columnIndex, String catalogName)
      Sets the designated column's table's catalog name, if any, to the given String.
      void setColumnCount(int columnCount)
      Sets the number of columns in the RowSet object to the given number.
      void setColumnDisplaySize(int columnIndex, int size)
      Sets the designated column's normal maximum width in chars to the given int.
      void setColumnLabel(int columnIndex, String label)
      Sets the suggested column title for use in printouts and displays, if any, to the given String.
      void setColumnName(int columnIndex, String columnName)
      Sets the name of the designated column to the given String.
      void setColumnType(int columnIndex, int SQLType)
      Sets the designated column's SQL type to the one given.
      void setColumnTypeName(int columnIndex, String typeName)
      Sets the designated column's type name that is specific to the data source, if any, to the given String.
      void setCurrency(int columnIndex, boolean property)
      Sets whether the designated column is a cash value.
      void setNullable(int columnIndex, int property)
      Sets whether the designated column's value can be set to NULL.
      void setPrecision(int columnIndex, int precision)
      Sets the designated column's number of decimal digits to the given int.
      void setScale(int columnIndex, int scale)
      Sets the designated column's number of digits to the right of the decimal point to the given int.
      void setSchemaName(int columnIndex, String schemaName)
      Sets the name of the designated column's table's schema, if any, to the given String.
      void setSearchable(int columnIndex, boolean property)
      Sets whether the designated column can be used in a where clause.
      void setSigned(int columnIndex, boolean property)
      Sets whether the designated column is a signed number.
      void setTableName(int columnIndex, String tableName)
      Sets the designated column's table name, if any, to the given String.

      • 方法 - 继承于接口 java.sql.ResultSetMetaData

        getCatalogName, getColumnClassName, getColumnCount, getColumnDisplaySize, getColumnLabel, getColumnName, getColumnType, getColumnTypeName, getPrecision, getScale, getSchemaName, getTableName, isAutoIncrement, isCaseSensitive, isCurrency, isDefinitelyWritable, isNullable, isReadOnly, isSearchable, isSigned, isWritable

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

    • 方法详细信息

      • setColumnCount

        void setColumnCount(int columnCount)
                    throws SQLException
        Sets the number of columns in the RowSet object to the given number.
        参数：
        columnCount - the number of columns in the RowSet object
        抛出：
        SQLException - if a database access error occurs

      • setAutoIncrement

        void setAutoIncrement(int columnIndex,
                    boolean property)
                      throws SQLException
        Sets whether the designated column is automatically numbered, The default is for a RowSet object's columns not to be automatically numbered.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - true if the column is automatically numbered; false if it is not
        抛出：
        SQLException - if a database access error occurs

      • setCaseSensitive

        void setCaseSensitive(int columnIndex,
                    boolean property)
                      throws SQLException
        Sets whether the designated column is case sensitive. The default is false.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - true if the column is case sensitive; false if it is not
        抛出：
        SQLException - if a database access error occurs

      • setSearchable

        void setSearchable(int columnIndex,
                 boolean property)
                   throws SQLException
        Sets whether the designated column can be used in a where clause. The default is false.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - true if the column can be used in a WHERE clause; false if it cannot
        抛出：
        SQLException - if a database access error occurs

      • setCurrency

        void setCurrency(int columnIndex,
               boolean property)
                 throws SQLException
        Sets whether the designated column is a cash value. The default is false.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - true if the column is a cash value; false if it is not
        抛出：
        SQLException - if a database access error occurs

      • setNullable

        void setNullable(int columnIndex,
               int property)
                 throws SQLException
        Sets whether the designated column's value can be set to NULL. The default is ResultSetMetaData.columnNullableUnknown
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - one of the following constants: ResultSetMetaData.columnNoNulls, ResultSetMetaData.columnNullable, or ResultSetMetaData.columnNullableUnknown
        抛出：
        SQLException - if a database access error occurs

      • setSigned

        void setSigned(int columnIndex,
             boolean property)
               throws SQLException
        Sets whether the designated column is a signed number. The default is false.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        property - true if the column is a signed number; false if it is not
        抛出：
        SQLException - if a database access error occurs

      • setColumnDisplaySize

        void setColumnDisplaySize(int columnIndex,
                        int size)
                          throws SQLException
        Sets the designated column's normal maximum width in chars to the given int.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        size - the normal maximum number of characters for the designated column
        抛出：
        SQLException - if a database access error occurs

      • setColumnLabel

        void setColumnLabel(int columnIndex,
                  String label)
                    throws SQLException
        Sets the suggested column title for use in printouts and displays, if any, to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        label - the column title
        抛出：
        SQLException - if a database access error occurs

      • setColumnName

        void setColumnName(int columnIndex,
                 String columnName)
                   throws SQLException
        Sets the name of the designated column to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        columnName - the designated column's name
        抛出：
        SQLException - if a database access error occurs

      • setSchemaName

        void setSchemaName(int columnIndex,
                 String schemaName)
                   throws SQLException
        Sets the name of the designated column's table's schema, if any, to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        schemaName - the schema name
        抛出：
        SQLException - if a database access error occurs

      • setPrecision

        void setPrecision(int columnIndex,
                int precision)
                  throws SQLException
        Sets the designated column's number of decimal digits to the given int.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        precision - the total number of decimal digits
        抛出：
        SQLException - if a database access error occurs

      • setScale

        void setScale(int columnIndex,
            int scale)
              throws SQLException
        Sets the designated column's number of digits to the right of the decimal point to the given int.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        scale - the number of digits to right of decimal point
        抛出：
        SQLException - if a database access error occurs

      • setTableName

        void setTableName(int columnIndex,
                String tableName)
                  throws SQLException
        Sets the designated column's table name, if any, to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        tableName - the column's table name
        抛出：
        SQLException - if a database access error occurs

      • setCatalogName

        void setCatalogName(int columnIndex,
                  String catalogName)
                    throws SQLException
        Sets the designated column's table's catalog name, if any, to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        catalogName - the column's catalog name
        抛出：
        SQLException - if a database access error occurs

      • setColumnType

        void setColumnType(int columnIndex,
                 int SQLType)
                   throws SQLException
        Sets the designated column's SQL type to the one given.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        SQLType - the column's SQL type
        抛出：
        SQLException - if a database access error occurs
        另请参见：
        Types

      • setColumnTypeName

        void setColumnTypeName(int columnIndex,
                     String typeName)
                       throws SQLException
        Sets the designated column's type name that is specific to the data source, if any, to the given String.
        参数：
        columnIndex - the first column is 1, the second is 2, ...
        typeName - data source specific type name.
        抛出：
        SQLException - if a database access error occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s=/ l


RowSetReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSetReader

  • All Known Subinterfaces:
    XmlReader

    public interface RowSetReader
    The facility that a disconnected RowSet object calls on to populate itself with rows of data. A reader (an object implementing the RowSetReader interface) may be registered with a RowSet object that supports the reader/writer paradigm. When the RowSet object's execute method is called, it in turn calls the reader's readData method.
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void readData(RowSetInternal caller)
      Reads the new contents of the calling RowSet object.

    • 方法详细信息

      • readData

        void readData(RowSetInternal caller)
              throws SQLException
        Reads the new contents of the calling RowSet object. In order to call this method, a RowSet object must have implemented the RowSetInternal interface and registered this RowSetReader object as its reader. The readData method is invoked internally by the RowSet.execute method for rowsets that support the reader/writer paradigm.

        The readData method adds rows to the caller. It can be implemented in a wide variety of ways and can even populate the caller with rows from a nonrelational data source. In general, a reader may invoke any of the rowset's methods, with one exception. Calling the method execute will cause an SQLException to be thrown because execute may not be called recursively. Also, when a reader invokes RowSet methods, no listeners are notified; that is, no RowSetEvent objects are generated and no RowSetListener methods are invoked. This is true because listeners are already being notified by the method execute.

        参数：
        caller - the RowSet object (1) that has implemented the RowSetInternal interface, (2) with which this reader is registered, and (3) whose execute method called this reader
        抛出：
        SQLException - if a database access error occurs or this method invokes the RowSet.execute method
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

T=y#aha.hatDDattS/""lFclo"d><


RowSetWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface RowSetWriter

  • All Known Subinterfaces:
    TransactionalWriter, XmlWriter

    public interface RowSetWriter
    An object that implements the RowSetWriter interface, called a writer. A writer may be registered with a RowSet object that supports the reader/writer paradigm.

    If a disconnected RowSet object modifies some of its data, and it has a writer associated with it, it may be implemented so that it calls on the writer's writeData method internally to write the updates back to the data source. In order to do this, the writer must first establish a connection with the rowset's data source.

    If the data to be updated has already been changed in the data source, there is a conflict, in which case the writer will not write the changes to the data source. The algorithm the writer uses for preventing or limiting conflicts depends entirely on its implementation.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean writeData(RowSetInternal caller)
      Writes the changes in this RowSetWriter object's rowset back to the data source from which it got its data.

    • 方法详细信息

      • writeData

        boolean writeData(RowSetInternal caller)
                  throws SQLException
        Writes the changes in this RowSetWriter object's rowset back to the data source from which it got its data.
        参数：
        caller - the RowSet object (1) that has implemented the RowSetInternal interface, (2) with which this writer is registered, and (3) that called this method internally
        返回：
        true if the modified data was written; false if not, which will be the case if there is a conflict
        抛出：
        SQLException - if a database access error occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t e-l-v-e-raget cieㄔ礒牡


StatementEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql

类 StatementEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.sql.StatementEvent
  • 所有已实现的接口：
    Serializable

    public class StatementEvent
extends EventObject
    A StatementEvent is sent to all StatementEventListeners which were registered with a PooledConnection. This occurs when the driver determines that a PreparedStatement that is associated with the PooledConnection has been closed or the driver determines is invalid.

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      StatementEvent(PooledConnection con, PreparedStatement statement)
      Constructs a StatementEvent with the specified PooledConnection and PreparedStatement.
      StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
      Constructs a StatementEvent with the specified PooledConnection, PreparedStatement and SQLException

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SQLException getSQLException()
      Returns the SQLException the driver is about to throw
      PreparedStatement getStatement()
      Returns the PreparedStatement that is being closed or is invalid

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StatementEvent

        public StatementEvent(PooledConnection con,
              PreparedStatement statement)
        Constructs a StatementEvent with the specified PooledConnection and PreparedStatement. The SQLException contained in the event defaults to null.

        参数：
        con - The PooledConnection that the closed or invalid PreparedStatementis associated with.
        statement - The PreparedStatement that is bieng closed or is invalid

        抛出：
        IllegalArgumentException - if con is null.
        从以下版本开始：
        1.6

      • StatementEvent

        public StatementEvent(PooledConnection con,
              PreparedStatement statement,
              SQLException exception)
        Constructs a StatementEvent with the specified PooledConnection, PreparedStatement and SQLException

        参数：
        con - The PooledConnection that the closed or invalid PreparedStatement is associated with.
        statement - The PreparedStatement that is being closed or is invalid
        exception - The SQLException the driver is about to throw to the application
        抛出：
        IllegalArgumentException - if con is null.

        从以下版本开始：
        1.6

    • 方法详细信息

      • getStatement

        public PreparedStatement getStatement()
        Returns the PreparedStatement that is being closed or is invalid

        返回：
        The PreparedStatement that is being closed or is invalid

        从以下版本开始：
        1.6

      • getSQLException

        public SQLException getSQLException()
        Returns the SQLException the driver is about to throw

        返回：
        The SQLException the driver is about to throw

        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/e>oena t(mdataaneat>stc<


StatementEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface StatementEventListener

  • All Superinterfaces:
    EventListener

    public interface StatementEventListener
extends EventListener
    An object that registers to be notified of events that occur on PreparedStatements that are in the Statement pool.

    The JDBC 3.0 specification added the maxStatements ConnectionPooledDataSource property to provide a standard mechanism for enabling the pooling of PreparedStatements and to specify the size of the statement pool. However, there was no way for a driver to notify an external statement pool when a PreparedStatement becomes invalid. For some databases, a statement becomes invalid if a DDL operation is performed that affects the table. For example an application may create a temporary table to do some work on the table and then destroy it. It may later recreate the same table when it is needed again. Some databases will invalidate any prepared statements that reference the temporary table when the table is dropped.

    Similar to the methods defined in the ConnectionEventListener interface, the driver will call the StatementEventListener.statementErrorOccurred method prior to throwing any exceptions when it detects a statement is invalid. The driver will also call the StatementEventListener.statementClosed method when a PreparedStatement is closed.

    Methods which allow a component to register a StatementEventListener with a PooledConnection have been added to the PooledConnection interface.

    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void statementClosed(StatementEvent event)
      The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is closed.
      void statementErrorOccurred(StatementEvent event)
      The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is invalid.

    • 方法详细信息

      • statementClosed

        void statementClosed(StatementEvent event)
        The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is closed.
        参数：
        event - an event object describing the source of the event and that the PreparedStatement was closed.
        从以下版本开始：
        1.6

      • statementErrorOccurred

        void statementErrorOccurred(StatementEvent event)
        The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is invalid. The driver calls this method just before it throws the SQLException, contained in the given event, to the application.

        参数：
        event - an event object describing the source of the event, the statement that is invalid and the exception the driver is about to throw. The source of the event is the PooledConnection which the invalid PreparedStatement is associated with.

        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c l<>> ehfiCop<>oop


Uses of Package javax.sql

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sql

  • Packages that use javax.sql
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
  • Classes in javax.sql used by javax.sql
    类与描述
    CommonDataSource
    Interface that defines the methods which are common between DataSource, XADataSource and ConnectionPoolDataSource.
    ConnectionEvent
    An Event object that provides information about the source of a connection-related event.
    ConnectionEventListener
    An object that registers to be notified of events generated by a PooledConnection object.
    PooledConnection
    An object that provides hooks for connection pool management.
    RowSet
    The interface that adds support to the JDBC API for the JavaBeansTM component model.
    RowSetEvent
    An Event object generated when an event occurs to a RowSet object.
    RowSetInternal
    The interface that a RowSet object implements in order to present itself to a RowSetReader or RowSetWriter object.
    RowSetListener
    An interface that must be implemented by a component that wants to be notified when a significant event happens in the life of a RowSet object.
    RowSetMetaData
    An object that contains information about the columns in a RowSet object.
    StatementEvent
    A StatementEvent is sent to all StatementEventListeners which were registered with a PooledConnection.
    StatementEventListener
    An object that registers to be notified of events that occur on PreparedStatements that are in the Statement pool.
    XAConnection
    An object that provides support for distributed transactions.
  • Classes in javax.sql used by javax.sql.rowset
    类与描述
    RowSet
    The interface that adds support to the JDBC API for the JavaBeansTM component model.
    RowSetEvent
    An Event object generated when an event occurs to a RowSet object.
    RowSetListener
    An interface that must be implemented by a component that wants to be notified when a significant event happens in the life of a RowSet object.
    RowSetMetaData
    An object that contains information about the columns in a RowSet object.
  • Classes in javax.sql used by javax.sql.rowset.spi
    类与描述
    RowSet
    The interface that adds support to the JDBC API for the JavaBeansTM component model.
    RowSetReader
    The facility that a disconnected RowSet object calls on to populate itself with rows of data.
    RowSetWriter
    An object that implements the RowSetWriter interface, called a writer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn"apparttstlairtcc>a m


XAConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface XAConnection

  • All Superinterfaces:
    PooledConnection

    public interface XAConnection
extends PooledConnection
    An object that provides support for distributed transactions. An XAConnection object may be enlisted in a distributed transaction by means of an XAResource object. A transaction manager, usually part of a middle tier server, manages an XAConnection object through the XAResource object.

    An application programmer does not use this interface directly; rather, it is used by a transaction manager working in the middle tier server.

    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XAResource getXAResource()
      Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.

      • 方法 - 继承于接口 javax.sql.PooledConnection

        addConnectionEventListener, addStatementEventListener, close, getConnection, removeConnectionEventListener, removeStatementEventListener

    • 方法详细信息

      • getXAResource

        XAResource getXAResource()
                         throws SQLException
        Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.
        返回：
        the XAResource object
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_xnl"ldlslcses_veaaaemretmnLeLlee t


XADataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql

Interface XADataSource

  • All Superinterfaces:
    CommonDataSource

    public interface XADataSource
extends CommonDataSource
    A factory for XAConnection objects that is used internally. An object that implements the XADataSource interface is typically registered with a naming service that uses the Java Naming and Directory InterfaceTM (JNDI).
    从以下版本开始：
    1.4

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XAConnection getXAConnection()
      Attempts to establish a physical database connection that can be used in a distributed transaction.
      XAConnection getXAConnection(String user, String password)
      Attempts to establish a physical database connection, using the given user name and password.

      • 方法 - 继承于接口 javax.sql.CommonDataSource

        getLoginTimeout, getLogWriter, getParentLogger, setLoginTimeout, setLogWriter

    • 方法详细信息

      • getXAConnection

        XAConnection getXAConnection()
                             throws SQLException
        Attempts to establish a physical database connection that can be used in a distributed transaction.
        返回：
        an XAConnection object, which represents a physical connection to a data source, that can be used in a distributed transaction
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • getXAConnection

        XAConnection getXAConnection(String user,
                           String password)
                             throws SQLException
        Attempts to establish a physical database connection, using the given user name and password. The connection that is returned is one that can be used in a distributed transaction.
        参数：
        user - the database user on whose behalf the connection is being made
        password - the user's password
        返回：
        an XAConnection object, which represents a physical connection to a data source, that can be used in a distributed transaction
        抛出：
        SQLException - if a database access error occurs
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//cotlt/ldoeedooho<


Uses of Class javax.sql.ConnectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.ConnectionEvent

  • Packages that use ConnectionEvent
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of ConnectionEvent in javax.sql

      Methods in javax.sql with parameters of type ConnectionEvent
      修饰符与类型 方法与描述
      void ConnectionEventListener.connectionClosed(ConnectionEvent event)
      Notifies this ConnectionEventListener that the application has called the method close on its representation of a pooled connection.
      void ConnectionEventListener.connectionErrorOccurred(ConnectionEvent event)
      Notifies this ConnectionEventListener that a fatal error has occurred and the pooled connection can no longer be used.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rteli/7esime襬rode"st j�


Uses of Class javax.sql.RowSetEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.RowSetEvent

  • Packages that use RowSetEvent
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of RowSetEvent in javax.sql

      Methods in javax.sql with parameters of type RowSetEvent
      修饰符与类型 方法与描述
      void RowSetListener.cursorMoved(RowSetEvent event)
      Notifies registered listeners that a RowSet object's cursor has moved.
      void RowSetListener.rowChanged(RowSetEvent event)
      Notifies registered listeners that a RowSet object has had a change in one of its rows.
      void RowSetListener.rowSetChanged(RowSetEvent event)
      Notifies registered listeners that a RowSet object in the given RowSetEvent object has changed its entire contents.

    • Uses of RowSetEvent in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type RowSetEvent
      修饰符与类型 方法与描述
      void CachedRowSet.rowSetPopulated(RowSetEvent event, int numRows)
      Notifies registered listeners that a RowSet object in the given RowSetEvent object has populated a number of additional rows.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eccIdxlouuupn,,talmtt"te


Uses of Class javax.sql.StatementEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.StatementEvent

  • Packages that use StatementEvent
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of StatementEvent in javax.sql

      Methods in javax.sql with parameters of type StatementEvent
      修饰符与类型 方法与描述
      void StatementEventListener.statementClosed(StatementEvent event)
      The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is closed.
      void StatementEventListener.statementErrorOccurred(StatementEvent event)
      The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is invalid.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i!naaCeClasLa }} o(m dd


Uses of Interface javax.sql.CommonDataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.CommonDataSource

  • Packages that use CommonDataSource
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of CommonDataSource in javax.sql

      Subinterfaces of CommonDataSource in javax.sql
      修饰符与类型 Interface and Description
      interface  ConnectionPoolDataSource
      A factory for PooledConnection objects.
      interface  DataSource
      A factory for connections to the physical data source that this DataSource object represents.
      interface  XADataSource
      A factory for XAConnection objects that is used internally.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ve.emtat


Uses of Interface javax.sql.ConnectionEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.ConnectionEventListener

  • Packages that use ConnectionEventListener
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of ConnectionEventListener in javax.sql

      Methods in javax.sql with parameters of type ConnectionEventListener
      修饰符与类型 方法与描述
      void PooledConnection.addConnectionEventListener(ConnectionEventListener listener)
      Registers the given event listener so that it will be notified when an event occurs on this PooledConnection object.
      void PooledConnection.removeConnectionEventListener(ConnectionEventListener listener)
      Removes the given event listener from the list of components that will be notified when an event occurs on this PooledConnection object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n& vtp.羖serncg a<


Uses of Interface javax.sql.ConnectionPoolDataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.ConnectionPoolDataSource

No usage of javax.sql.ConnectionPoolDataSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.imtmloinnneojjoreea


Uses of Interface javax.sql.PooledConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.PooledConnection

  • Packages that use PooledConnection
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of PooledConnection in javax.sql

      Subinterfaces of PooledConnection in javax.sql
      修饰符与类型 Interface and Description
      interface  XAConnection
      An object that provides support for distributed transactions.
      Methods in javax.sql that return PooledConnection
      修饰符与类型 方法与描述
      PooledConnection ConnectionPoolDataSource.getPooledConnection()
      Attempts to establish a physical database connection that can be used as a pooled connection.
      PooledConnection ConnectionPoolDataSource.getPooledConnection(String user, String password)
      Attempts to establish a physical database connection that can be used as a pooled connection.
      Constructors in javax.sql with parameters of type PooledConnection
      构造方法与描述
      ConnectionEvent(PooledConnection con)
      Constructs a ConnectionEvent object initialized with the given PooledConnection object.
      ConnectionEvent(PooledConnection con, SQLException ex)
      Constructs a ConnectionEvent object initialized with the given PooledConnection object and SQLException object.
      StatementEvent(PooledConnection con, PreparedStatement statement)
      Constructs a StatementEvent with the specified PooledConnection and PreparedStatement.
      StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
      Constructs a StatementEvent with the specified PooledConnection, PreparedStatement and SQLException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i veoa"ae.lco� csito


Uses of Interface javax.sql.RowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSet

  • Packages that use RowSet
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of RowSet in javax.sql

      Constructors in javax.sql with parameters of type RowSet
      构造方法与描述
      RowSetEvent(RowSet source)
      Constructs a RowSetEvent object initialized with the given RowSet object.

    • Uses of RowSet in javax.sql.rowset

      Subinterfaces of RowSet in javax.sql.rowset
      修饰符与类型 Interface and Description
      interface  CachedRowSet
      The interface that all standard implementations of CachedRowSet must implement.
      interface  FilteredRowSet
      The standard interface that all standard implementations of FilteredRowSet must implement.
      interface  JdbcRowSet
      The standard interface that all standard implementations of JdbcRowSet must implement.
      interface  JoinRowSet
      The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
      interface  WebRowSet
      The standard interface that all implementations of a WebRowSet must implement.
      Methods in javax.sql.rowset that return RowSet
      修饰符与类型 方法与描述
      RowSet CachedRowSet.createShared()
      Returns a new RowSet object backed by the same data as that of this CachedRowSet object.
      Methods in javax.sql.rowset with parameters of type RowSet
      修饰符与类型 方法与描述
      void JoinRowSet.addRowSet(RowSet[] rowset, int[] columnIdx)
      Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column indexes.
      void JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName)
      Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column names.
      void JoinRowSet.addRowSet(RowSet rowset, int columnIdx)
      Adds the given RowSet object to this JoinRowSet object and sets the designated column as the match column for the RowSet object.
      void JoinRowSet.addRowSet(RowSet rowset, String columnName)
      Adds rowset to this JoinRowSet object and sets the designated column as the match column.
      boolean Predicate.evaluate(RowSet rs)
      This method is typically called a FilteredRowSet object internal methods (not public) that control the RowSet object's cursor moving from row to the next.

    • Uses of RowSet in javax.sql.rowset.spi

      Subinterfaces of RowSet in javax.sql.rowset.spi
      修饰符与类型 Interface and Description
      interface  SyncResolver
      Defines a framework that allows applications to use a manual decision tree to decide what should be done when a synchronization conflict occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ldbjS藄ts md/s


Uses of Interface javax.sql.RowSetInternal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSetInternal

  • Packages that use RowSetInternal
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of RowSetInternal in javax.sql

      Methods in javax.sql with parameters of type RowSetInternal
      修饰符与类型 方法与描述
      void RowSetReader.readData(RowSetInternal caller)
      Reads the new contents of the calling RowSet object.
      boolean RowSetWriter.writeData(RowSetInternal caller)
      Writes the changes in this RowSetWriter object's rowset back to the data source from which it got its data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>hniga"=NNNtLlln=>kam <


Uses of Interface javax.sql.RowSetListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSetListener

  • Packages that use RowSetListener
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of RowSetListener in javax.sql

      Methods in javax.sql with parameters of type RowSetListener
      修饰符与类型 方法与描述
      void RowSet.addRowSetListener(RowSetListener listener)
      Registers the given listener so that it will be notified of events that occur on this RowSet object.
      void RowSet.removeRowSetListener(RowSetListener listener)
      Removes the specified listener from the list of components that will be notified when an event occurs on this RowSet object.

    • Uses of RowSetListener in javax.sql.rowset

      Methods in javax.sql.rowset with parameters of type RowSetListener
      修饰符与类型 方法与描述
      void BaseRowSet.addRowSetListener(RowSetListener listener)
      The listener will be notified whenever an event occurs on this RowSet object.
      void BaseRowSet.removeRowSetListener(RowSetListener listener)
      Removes the designated object from this RowSet object's list of listeners.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=let loSw襠yu e<= iasO


Uses of Interface javax.sql.RowSetMetaData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSetMetaData

  • Packages that use RowSetMetaData
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of RowSetMetaData in javax.sql

      Methods in javax.sql with parameters of type RowSetMetaData
      修饰符与类型 方法与描述
      void RowSetInternal.setMetaData(RowSetMetaData md)
      Sets the given RowSetMetaData object as the RowSetMetaData object for this RowSet object.

    • Uses of RowSetMetaData in javax.sql.rowset

      Classes in javax.sql.rowset that implement RowSetMetaData
      修饰符与类型 类与描述
      class  RowSetMetaDataImpl
      Provides implementations for the methods that set and get metadata information about a RowSet object's columns.
      Methods in javax.sql.rowset with parameters of type RowSetMetaData
      修饰符与类型 方法与描述
      void CachedRowSet.setMetaData(RowSetMetaData md)
      Sets the metadata for this CachedRowSet object with the given RowSetMetaData object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n 芶1OeO al剂醗<狴芆 眉r2<


Uses of Interface javax.sql.RowSetReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSetReader

  • Packages that use RowSetReader
    软件包 描述
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of RowSetReader in javax.sql.rowset.spi

      Subinterfaces of RowSetReader in javax.sql.rowset.spi
      修饰符与类型 Interface and Description
      interface  XmlReader
      A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
      Methods in javax.sql.rowset.spi that return RowSetReader
      修饰符与类型 方法与描述
      abstract RowSetReader SyncProvider.getRowSetReader()
      Returns a javax.sql.RowSetReader object, which can be used to populate a RowSet object with data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>iJs<>o>m<<<>all>/f>e.cha


Uses of Interface javax.sql.RowSetWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.RowSetWriter

  • Packages that use RowSetWriter
    软件包 描述
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of RowSetWriter in javax.sql.rowset.spi

      Subinterfaces of RowSetWriter in javax.sql.rowset.spi
      修饰符与类型 Interface and Description
      interface  TransactionalWriter
      A specialized interface that facilitates an extension of the standard SyncProvider abstract class so that it has finer grained transaction control.
      interface  XmlWriter
      A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
      Methods in javax.sql.rowset.spi that return RowSetWriter
      修饰符与类型 方法与描述
      abstract RowSetWriter SyncProvider.getRowSetWriter()
      Returns a javax.sql.RowSetWriter object, which can be used to write a RowSet object's data back to the underlying data source.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>Drsaro/mh.s..t=Lln>sa.


Uses of Interface javax.sql.StatementEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.StatementEventListener

  • Packages that use StatementEventListener
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of StatementEventListener in javax.sql

      Methods in javax.sql with parameters of type StatementEventListener
      修饰符与类型 方法与描述
      void PooledConnection.addStatementEventListener(StatementEventListener listener)
      Registers a StatementEventListener with this PooledConnection object.
      void PooledConnection.removeStatementEventListener(StatementEventListener listener)
      Removes the specified StatementEventListener from the list of components that will be notified when the driver detects that a PreparedStatement has been closed or is invalid.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>


Uses of Interface javax.sql.XAConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.XAConnection

  • Packages that use XAConnection
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.

    • Uses of XAConnection in javax.sql

      Methods in javax.sql that return XAConnection
      修饰符与类型 方法与描述
      XAConnection XADataSource.getXAConnection()
      Attempts to establish a physical database connection that can be used in a distributed transaction.
      XAConnection XADataSource.getXAConnection(String user, String password)
      Attempts to establish a physical database connection, using the given user name and password.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,, noro esoorc识⒆曙锸.


Uses of Interface javax.sql.XADataSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.XADataSource

No usage of javax.sql.XADataSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r.era>


BaseRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset

类 BaseRowSet

  • java.lang.Object
    • javax.sql.rowset.BaseRowSet
  • 所有已实现的接口：
    Serializable, Cloneable

    public abstract class BaseRowSet
extends Object
implements Serializable, Cloneable
    An abstract class providing a RowSet object with its basic functionality. The basic functions include having properties and sending event notifications, which all JavaBeansTM components must implement.

    1.0 Overview

    The BaseRowSet class provides the core functionality for all RowSet implementations, and all standard implementations may use this class in combination with one or more RowSet interfaces in order to provide a standard vendor-specific implementation. To clarify, all implementations must implement at least one of the RowSet interfaces (JdbcRowSet, CachedRowSet, JoinRowSet, FilteredRowSet, or WebRowSet). This means that any implementation that extends the BaseRowSet class must also implement one of the RowSet interfaces.

    The BaseRowSet class provides the following:

    • Properties
      • Fields for storing current properties
      • Methods for getting and setting properties

    • Event notification

    • A complete set of setter methods for setting the parameters in a RowSet object's command

    • Streams
      • Fields for storing stream instances
      • Constants for indicating the type of a stream

    2.0 Setting Properties

    All rowsets maintain a set of properties, which will usually be set using a tool. The number and kinds of properties a rowset has will vary, depending on what the RowSet implementation does and how it gets its data. For example, rowsets that get their data from a ResultSet object need to set the properties that are required for making a database connection. If a RowSet object uses the DriverManager facility to make a connection, it needs to set a property for the JDBC URL that identifies the appropriate driver, and it needs to set the properties that give the user name and password. If, on the other hand, the rowset uses a DataSource object to make the connection, which is the preferred method, it does not need to set the property for the JDBC URL. Instead, it needs to set the property for the logical name of the data source along with the properties for the user name and password.

    NOTE: In order to use a DataSource object for making a connection, the DataSource object must have been registered with a naming service that uses the Java Naming and Directory InterfaceTM (JNDI) API. This registration is usually done by a person acting in the capacity of a system administrator.

    3.0 Setting the Command and Its Parameters

    When a rowset gets its data from a relational database, it executes a command (a query) that produces a ResultSet object. This query is the command that is set for the RowSet object's command property. The rowset populates itself with data by reading the data from the ResultSet object into itself. If the query contains placeholders for values to be set, the BaseRowSet setter methods are used to set these values. All setter methods allow these values to be set to null if required.

    The following code fragment illustrates how the CachedRowSetTM object crs might have its command property set. Note that if a tool is used to set properties, this is the code that the tool would use.

        crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");

    In this example, the values for CREDIT_LIMIT and REGION are placeholder parameters, which are indicated with a question mark (?). The first question mark is placeholder parameter number 1, the second question mark is placeholder parameter number 2, and so on. Any placeholder parameters must be set with values before the query can be executed. To set these placeholder parameters, the BaseRowSet class provides a set of setter methods, similar to those provided by the PreparedStatement interface, for setting values of each data type. A RowSet object stores the parameter values internally, and its execute method uses them internally to set values for the placeholder parameters before it sends the command to the DBMS to be executed.

    The following code fragment demonstrates setting the two parameters in the query from the previous example.

        crs.setInt(1, 5000);
    crs.setString(2, "West");
    If the execute method is called at this point, the query sent to the DBMS will be:
        "SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > 5000 AND REGION = 'West'"
    NOTE: Setting Array, Clob, Blob and Ref objects as a command parameter, stores these values as SerialArray, SerialClob, SerialBlob and SerialRef objects respectively.

    4.0 Handling of Parameters Behind the Scenes

    NOTE: The BaseRowSet class provides two kinds of setter methods, those that set properties and those that set placeholder parameters. The setter methods discussed in this section are those that set placeholder parameters.

    The placeholder parameters set with the BaseRowSet setter methods are stored as objects in an internal Hashtable object. Primitives are stored as their Object type. For example, byte is stored as Byte object, and int is stored as an Integer object. When the method execute is called, the values in the Hashtable object are substituted for the appropriate placeholder parameters in the command. A call to the method getParams returns the values stored in the Hashtable object as an array of Object instances. An element in this array may be a simple Object instance or an array (which is a type of Object). The particular setter method used determines whether an element in this array is an Object or an array.

    The majority of methods for setting placeholder parameters take two parameters, with the first parameter indicating which placeholder parameter is to be set, and the second parameter giving the value to be set. Methods such as setInt, setString, setBoolean, and setLong fall into this category. After these methods have been called, a call to the method getParams will return an array with the values that have been set. Each element in the array is an Object instance representing the values that have been set. The order of these values in the array is determined by the int (the first parameter) passed to the setter method. The values in the array are the values (the second parameter) passed to the setter method. In other words, the first element in the array is the value to be set for the first placeholder parameter in the RowSet object's command. The second element is the value to be set for the second placeholder parameter, and so on.

    Several setter methods send the driver and DBMS information beyond the value to be set. When the method getParams is called after one of these setter methods has been used, the elements in the array will themselves be arrays to accommodate the additional information. In this category, the method setNull is a special case because one version takes only two parameters (setNull(int parameterIndex, int SqlType)). Nevertheless, it requires an array to contain the information that will be passed to the driver and DBMS. The first element in this array is the value to be set, which is null, and the second element is the int supplied for sqlType, which indicates the type of SQL value that is being set to null. This information is needed by some DBMSs and is therefore required in order to ensure that applications are portable. The other version is intended to be used when the value to be set to null is a user-defined type. It takes three parameters (setNull(int parameterIndex, int sqlType, String typeName)) and also requires an array to contain the information to be passed to the driver and DBMS. The first two elements in this array are the same as for the first version of setNull. The third element, typeName, gives the SQL name of the user-defined type. As is true with the other setter methods, the number of the placeholder parameter to be set is indicated by an element's position in the array returned by getParams. So, for example, if the parameter supplied to setNull is 2, the second element in the array returned by getParams will be an array of two or three elements.

    Some methods, such as setObject and setDate have versions that take more than two parameters, with the extra parameters giving information to the driver or the DBMS. For example, the methods setDate, setTime, and setTimestamp can take a Calendar object as their third parameter. If the DBMS does not store time zone information, the drivern uses the Calendar object to construct the Date, Time, or Timestamp object being set. As is true with other methods that provide additional information, the element in the array returned by getParams is an array instead of a simple Object instance.

    The methods setAsciiStream, setBinaryStream, setCharacterStream, and setUnicodeStream (which is deprecated, so applications should use getCharacterStream instead) take three parameters, so for them, the element in the array returned by getParams is also an array. What is different about these setter methods is that in addition to the information provided by parameters, the array contains one of the BaseRowSet constants indicating the type of stream being set.

    NOTE: The method getParams is called internally by RowSet implementations extending this class; it is not normally called by an application programmer directly.

    5.0 Event Notification

    The BaseRowSet class provides the event notification mechanism for rowsets. It contains the field listeners, methods for adding and removing listeners, and methods for notifying listeners of changes.

    A listener is an object that has implemented the RowSetListener interface. If it has been added to a RowSet object's list of listeners, it will be notified when an event occurs on that RowSet object. Each listener's implementation of the RowSetListener methods defines what that object will do when it is notified that an event has occurred.

    There are three possible events for a RowSet object:

    1. the cursor moves
    2. an individual row is changed (updated, deleted, or inserted)
    3. the contents of the entire RowSet object are changed

    The BaseRowSet method used for the notification indicates the type of event that has occurred. For example, the method notifyRowChanged indicates that a row has been updated, deleted, or inserted. Each of the notification methods creates a RowSetEvent object, which is supplied to the listener in order to identify the RowSet object on which the event occurred. What the listener does with this information, which may be nothing, depends on how it was implemented.

    6.0 Default Behavior

    A default BaseRowSet object is initialized with many starting values. The following is true of a default RowSet instance that extends the BaseRowSet class:
    • Has a scrollable cursor and does not show changes made by others.
    • Is updatable.
    • Does not show rows that have been deleted.
    • Has no time limit for how long a driver may take to execute the RowSet object's command.
    • Has no limit for the number of rows it may contain.
    • Has no limit for the number of bytes a column may contain. NOTE: This limit applies only to columns that hold values of the following types: BINARY, VARBINARY, LONGVARBINARY, CHAR, VARCHAR, and LONGVARCHAR.
    • Will not see uncommitted data (make "dirty" reads).
    • Has escape processing turned on.
    • Has its connection's type map set to null.
    • Has an empty Vector object for storing the values set for the placeholder parameters in the RowSet object's command.

    If other values are desired, an application must set the property values explicitly. For example, the following line of code sets the maximum number of rows for the CachedRowSet object crs to 500.

        crs.setMaxRows(500);
    Methods implemented in extensions of this BaseRowSet class must throw an SQLException object for any violation of the defined assertions. Also, if the extending class overrides and reimplements any BaseRowSet method and encounters connectivity or underlying data source issues, that method may in addition throw an SQLException object for that reason.
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ASCII_STREAM_PARAM
      A constant indicating to a RowSetReaderImpl object that a given parameter is an ASCII stream.
      protected InputStream asciiStream
      The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.
      static int BINARY_STREAM_PARAM
      A constant indicating to a RowSetReaderImpl object that a given parameter is a binary stream.
      protected InputStream binaryStream
      The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.
      protected Reader charStream
      The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.
      static int UNICODE_STREAM_PARAM
      A constant indicating to a RowSetReaderImpl object that a given parameter is a Unicode stream.
      protected InputStream unicodeStream
      The InputStream object that will be returned by the method getUnicodeStream, which is specified in the ResultSet interface.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BaseRowSet()
      Constructs a new BaseRowSet object initialized with a default Vector object for its listeners field.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRowSetListener(RowSetListener listener)
      The listener will be notified whenever an event occurs on this RowSet object.
      void clearParameters()
      Clears all of the current parameter values in this RowSet object's internal representation of the parameters to be set in this RowSet object's command when it is executed.
      String getCommand()
      Retrieves the SQL query that is the command for this RowSet object.
      int getConcurrency()
      Returns the concurrency for this RowSet object.
      String getDataSourceName()
      Returns the logical name that when supplied to a naming service that uses the Java Naming and Directory Interface (JNDI) API, will retrieve a javax.sql.DataSource object.
      boolean getEscapeProcessing()
      Ascertains whether escape processing is enabled for this RowSet object.
      int getFetchDirection()
      Retrieves this RowSet object's current setting for the fetch direction.
      int getFetchSize()
      Returns the fetch size for this RowSet object.
      int getMaxFieldSize()
      Retrieves the maximum number of bytes that can be used for a column value in this RowSet object.
      int getMaxRows()
      Retrieves the maximum number of rows that this RowSet object may contain.
      Object[] getParams()
      Retrieves an array containing the parameter values (both Objects and primitives) that have been set for this RowSet object's command and throws an SQLException object if all parameters have not been set.
      String getPassword()
      Returns the password used to create a database connection for this RowSet object.
      int getQueryTimeout()
      Retrieves the maximum number of seconds the driver will wait for a query to execute.
      boolean getShowDeleted()
      Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.
      int getTransactionIsolation()
      Returns the transaction isolation property for this RowSet object's connection.
      int getType()
      Returns the type of this RowSet object.
      Map<String,类<?>> getTypeMap()
      Retrieves the type map associated with the Connection object for this RowSet object.
      String getUrl()
      Retrieves the JDBC URL that this RowSet object's javax.sql.Reader object uses to make a connection with a relational database using a JDBC technology-enabled driver.
      String getUsername()
      Returns the user name used to create a database connection.
      protected void initParams()
      Performs the necessary internal configurations and initializations to allow any JDBC RowSet implementation to start using the standard facilities provided by a BaseRowSet instance.
      boolean isReadOnly()
      Returns a boolean indicating whether this RowSet object is read-only.
      protected void notifyCursorMoved()
      Notifies all of the listeners registered with this RowSet object that its cursor has moved.
      protected void notifyRowChanged()
      Notifies all of the listeners registered with this RowSet object that one of its rows has changed.
      protected void notifyRowSetChanged()
      Notifies all of the listeners registered with this RowSet object that its entire contents have changed.
      void removeRowSetListener(RowSetListener listener)
      Removes the designated object from this RowSet object's list of listeners.
      void setArray(int parameterIndex, Array array)
      Sets the designated parameter to an Array object in the Java programming language.
      void setAsciiStream(int parameterIndex, InputStream x)
      Sets the designated parameter in this RowSet object's command to the given input stream.
      void setAsciiStream(int parameterIndex, InputStream x, int length)
      Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes.
      void setAsciiStream(String parameterName, InputStream x)
      Sets the designated parameter to the given input stream.
      void setAsciiStream(String parameterName, InputStream x, int length)
      Sets the designated parameter to the given input stream, which will have the specified number of bytes.
      void setBigDecimal(int parameterIndex, BigDecimal x)
      Sets the designated parameter to the given java.lang.BigDecimal value.
      void setBigDecimal(String parameterName, BigDecimal x)
      Sets the designated parameter to the given java.math.BigDecimal value.
      void setBinaryStream(int parameterIndex, InputStream x)
      Sets the designated parameter in this RowSet object's command to the given input stream.
      void setBinaryStream(int parameterIndex, InputStream x, int length)
      Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes.
      void setBinaryStream(String parameterName, InputStream x)
      Sets the designated parameter to the given input stream.
      void setBinaryStream(String parameterName, InputStream x, int length)
      Sets the designated parameter to the given input stream, which will have the specified number of bytes.
      void setBlob(int parameterIndex, Blob x)
      Sets the designated parameter to the given Blob object in the Java programming language.
      void setBlob(int parameterIndex, InputStream inputStream)
      Sets the designated parameter to a InputStream object.
      void setBlob(int parameterIndex, InputStream inputStream, long length)
      Sets the designated parameter to a InputStream object.
      void setBlob(String parameterName, Blob x)
      Sets the designated parameter to the given java.sql.Blob object.
      void setBlob(String parameterName, InputStream inputStream)
      Sets the designated parameter to a InputStream object.
      void setBlob(String parameterName, InputStream inputStream, long length)
      Sets the designated parameter to a InputStream object.
      void setBoolean(int parameterIndex, boolean x)
      Sets the designated parameter to the given boolean in the Java programming language.
      void setBoolean(String parameterName, boolean x)
      Sets the designated parameter to the given Java boolean value.
      void setByte(int parameterIndex, byte x)
      Sets the designated parameter to the given byte in the Java programming language.
      void setByte(String parameterName, byte x)
      Sets the designated parameter to the given Java byte value.
      void setBytes(int parameterIndex, byte[] x)
      Sets the designated parameter to the given array of bytes.
      void setBytes(String parameterName, byte[] x)
      Sets the designated parameter to the given Java array of bytes.
      void setCharacterStream(int parameterIndex, Reader reader)
      Sets the designated parameter in this RowSet object's command to the given Reader object.
      void setCharacterStream(int parameterIndex, Reader reader, int length)
      Sets the designated parameter to the given java.io.Reader object, which will have the specified number of characters.
      void setCharacterStream(String parameterName, Reader reader)
      Sets the designated parameter to the given Reader object.
      void setCharacterStream(String parameterName, Reader reader, int length)
      Sets the designated parameter to the given Reader object, which is the given number of characters long.
      void setClob(int parameterIndex, Clob x)
      Sets the designated parameter to the given Clob object in the Java programming language.
      void setClob(int parameterIndex, Reader reader)
      Sets the designated parameter to a Reader object.
      void setClob(int parameterIndex, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setClob(String parameterName, Clob x)
      Sets the designated parameter to the given java.sql.Clob object.
      void setClob(String parameterName, Reader reader)
      Sets the designated parameter to a Reader object.
      void setClob(String parameterName, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setCommand(String cmd)
      Sets this RowSet object's command property to the given String object and clears the parameters, if any, that were set for the previous command.
      void setConcurrency(int concurrency)
      Sets the concurrency for this RowSet object to the specified concurrency.
      void setDataSourceName(String name)
      Sets the DataSource name property for this RowSet object to the given logical name and sets this RowSet object's Url property to null.
      void setDate(int parameterIndex, Date x)
      Sets the designated parameter to the given java.sql.Date value.
      void setDate(int parameterIndex, Date x, Calendar cal)
      Sets the designated parameter to the given java.sql.Date object.
      void setDate(String parameterName, Date x)
      Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.
      void setDate(String parameterName, Date x, Calendar cal)
      Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.
      void setDouble(int parameterIndex, double x)
      Sets the designated parameter to the given double in the Java programming language.
      void setDouble(String parameterName, double x)
      Sets the designated parameter to the given Java double value.
      void setEscapeProcessing(boolean enable)
      Sets to the given boolean whether or not the driver will scan for escape syntax and do escape substitution before sending SQL statements to the database.
      void setFetchDirection(int direction)
      Gives the driver a performance hint as to the direction in which the rows in this RowSet object will be processed.
      void setFetchSize(int rows)
      Sets the fetch size for this RowSet object to the given number of rows.
      void setFloat(int parameterIndex, float x)
      Sets the designated parameter to the given float in the Java programming language.
      void setFloat(String parameterName, float x)
      Sets the designated parameter to the given Java float value.
      void setInt(int parameterIndex, int x)
      Sets the designated parameter to an int in the Java programming language.
      void setInt(String parameterName, int x)
      Sets the designated parameter to the given Java int value.
      void setLong(int parameterIndex, long x)
      Sets the designated parameter to the given long in the Java programming language.
      void setLong(String parameterName, long x)
      Sets the designated parameter to the given Java long value.
      void setMaxFieldSize(int max)
      Sets the maximum number of bytes that can be used for a column value in this RowSet object to the given number.
      void setMaxRows(int max)
      Sets the maximum number of rows that this RowSet object may contain to the given number.
      void setNCharacterStream(int parameterIndex, Reader value)
      Sets the designated parameter in this RowSet object's command to a Reader object.
      void setNCharacterStream(int parameterIndex, Reader value, long length)
      Sets the designated parameter to a Reader object.
      void setNCharacterStream(String parameterName, Reader value)
      Sets the designated parameter to a Reader object.
      void setNCharacterStream(String parameterName, Reader value, long length)
      Sets the designated parameter to a Reader object.
      void setNClob(int parameterIndex, NClob value)
      Sets the designated parameter to a java.sql.NClob object.
      void setNClob(int parameterIndex, Reader reader)
      Sets the designated parameter to a Reader object.
      void setNClob(int parameterIndex, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setNClob(String parameterName, NClob value)
      Sets the designated parameter to a java.sql.NClob object.
      void setNClob(String parameterName, Reader reader)
      Sets the designated parameter to a Reader object.
      void setNClob(String parameterName, Reader reader, long length)
      Sets the designated parameter to a Reader object.
      void setNString(int parameterIndex, String value)
      Sets the designated paramter to the given String object.
      void setNString(String parameterName, String value)
      Sets the designated paramter to the given String object.
      void setNull(int parameterIndex, int sqlType)
      Sets the designated parameter to SQL NULL.
      void setNull(int parameterIndex, int sqlType, String typeName)
      Sets the designated parameter to SQL NULL.
      void setNull(String parameterName, int sqlType)
      Sets the designated parameter to SQL NULL.
      void setNull(String parameterName, int sqlType, String typeName)
      Sets the designated parameter to SQL NULL.
      void setObject(int parameterIndex, Object x)
      Sets the designated parameter to an Object in the Java programming language.
      void setObject(int parameterIndex, Object x, int targetSqlType)
      Sets the value of the designated parameter with the given Object value.
      void setObject(int parameterIndex, Object x, int targetSqlType, int scale)
      Sets the designated parameter to an Object in the Java programming language.
      void setObject(String parameterName, Object x)
      Sets the value of the designated parameter with the given object.
      void setObject(String parameterName, Object x, int targetSqlType)
      Sets the value of the designated parameter with the given object.
      void setObject(String parameterName, Object x, int targetSqlType, int scale)
      Sets the value of the designated parameter with the given object.
      void setPassword(String pass)
      Sets the password used to create a database connection for this RowSet object to the given String object.
      void setQueryTimeout(int seconds)
      Sets to the given number the maximum number of seconds the driver will wait for a query to execute.
      void setReadOnly(boolean value)
      Sets this RowSet object's readOnly property to the given boolean.
      void setRef(int parameterIndex, Ref ref)
      Sets the designated parameter to the given Ref object in the Java programming language.
      void setRowId(int parameterIndex, RowId x)
      Sets the designated parameter to the given java.sql.RowId object.
      void setRowId(String parameterName, RowId x)
      Sets the designated parameter to the given java.sql.RowId object.
      void setShort(int parameterIndex, short x)
      Sets the designated parameter to the given short in the Java programming language.
      void setShort(String parameterName, short x)
      Sets the designated parameter to the given Java short value.
      void setShowDeleted(boolean value)
      Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows.
      void setSQLXML(int parameterIndex, SQLXML xmlObject)
      Sets the designated parameter to the given java.sql.SQLXML object.
      void setSQLXML(String parameterName, SQLXML xmlObject)
      Sets the designated parameter to the given java.sql.SQLXML object.
      void setString(int parameterIndex, String x)
      Sets the designated parameter to the given String value.
      void setString(String parameterName, String x)
      Sets the designated parameter to the given Java String value.
      void setTime(int parameterIndex, Time x)
      Sets the designated parameter to the given java.sql.Time value.
      void setTime(int parameterIndex, Time x, Calendar cal)
      Sets the designated parameter to the given java.sql.Time object.
      void setTime(String parameterName, Time x)
      Sets the designated parameter to the given java.sql.Time value.
      void setTime(String parameterName, Time x, Calendar cal)
      Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.
      void setTimestamp(int parameterIndex, Timestamp x)
      Sets the designated parameter to the given java.sql.Timestamp value.
      void setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
      Sets the designated parameter to the given java.sql.Timestamp object.
      void setTimestamp(String parameterName, Timestamp x)
      Sets the designated parameter to the given java.sql.Timestamp value.
      void setTimestamp(String parameterName, Timestamp x, Calendar cal)
      Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.
      void setTransactionIsolation(int level)
      Sets the transaction isolation property for this JDBC RowSet object to the given constant.
      void setType(int type)
      Sets the type for this RowSet object to the specified type.
      void setTypeMap(Map<String,类<?>> map)
      Installs the given java.util.Map object as the type map associated with the Connection object for this RowSet object.
      void setUnicodeStream(int parameterIndex, InputStream x, int length)
      Deprecated.
      getCharacterStream should be used in its place
      void setURL(int parameterIndex, URL x)
      Sets the designated parameter to the given java.net.URL value.
      void setUrl(String url)
      Sets the Url property for this RowSet object to the given String object and sets the dataSource name property to null.
      void setUsername(String name)
      Sets the username property for this RowSet object to the given user name.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • UNICODE_STREAM_PARAM

        public static final int UNICODE_STREAM_PARAM
        A constant indicating to a RowSetReaderImpl object that a given parameter is a Unicode stream. This RowSetReaderImpl object is provided as an extension of the SyncProvider abstract class defined in the SyncFactory static factory SPI mechanism.
        另请参见：
        Constant Field Values

      • BINARY_STREAM_PARAM

        public static final int BINARY_STREAM_PARAM
        A constant indicating to a RowSetReaderImpl object that a given parameter is a binary stream. A RowSetReaderImpl object is provided as an extension of the SyncProvider abstract class defined in the SyncFactory static factory SPI mechanism.
        另请参见：
        Constant Field Values

      • ASCII_STREAM_PARAM

        public static final int ASCII_STREAM_PARAM
        A constant indicating to a RowSetReaderImpl object that a given parameter is an ASCII stream. A RowSetReaderImpl object is provided as an extension of the SyncProvider abstract class defined in the SyncFactory static factory SPI mechanism.
        另请参见：
        Constant Field Values

      • binaryStream

        protected InputStream binaryStream
        The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.

      • unicodeStream

        protected InputStream unicodeStream
        The InputStream object that will be returned by the method getUnicodeStream, which is specified in the ResultSet interface.

      • asciiStream

        protected InputStream asciiStream
        The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.

      • charStream

        protected Reader charStream
        The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.

    • 构造方法详细信息

      • BaseRowSet

        public BaseRowSet()
        Constructs a new BaseRowSet object initialized with a default Vector object for its listeners field. The other default values with which it is initialized are listed in Section 6.0 of the class comment for this class.

    • 方法详细信息

      • initParams

        protected void initParams()
        Performs the necessary internal configurations and initializations to allow any JDBC RowSet implementation to start using the standard facilities provided by a BaseRowSet instance. This method should be called after the RowSet object has been instantiated to correctly initialize all parameters. This method should never be called by an application, but is called from with a RowSet implementation extending this class.

      • addRowSetListener

        public void addRowSetListener(RowSetListener listener)
        The listener will be notified whenever an event occurs on this RowSet object.

        A listener might, for example, be a table or graph that needs to be updated in order to accurately reflect the current state of the RowSet object.

        Note: if the RowSetListener object is null, this method silently discards the null value and does not add a null reference to the set of listeners.

        Note: if the listener is already set, and the new RowSetListerner instance is added to the set of listeners already registered to receive event notifications from this RowSet.

        参数：
        listener - an object that has implemented the javax.sql.RowSetListener interface and wants to be notified of any events that occur on this RowSet object; May be null.
        另请参见：
        removeRowSetListener(javax.sql.RowSetListener)

      • removeRowSetListener

        public void removeRowSetListener(RowSetListener listener)
        Removes the designated object from this RowSet object's list of listeners. If the given argument is not a registered listener, this method does nothing. Note: if the RowSetListener object is null, this method silently discards the null value.
        参数：
        listener - a RowSetListener object that is on the list of listeners for this RowSet object
        另请参见：
        addRowSetListener(javax.sql.RowSetListener)

      • notifyCursorMoved

        protected void notifyCursorMoved()
                          throws SQLException
        Notifies all of the listeners registered with this RowSet object that its cursor has moved.

        When an application calls a method to move the cursor, that method moves the cursor and then calls this method internally. An application should never invoke this method directly.

        抛出：
        SQLException - if the class extending the BaseRowSet abstract class does not implement the RowSet interface or one of it's sub-interfaces.

      • notifyRowChanged

        protected void notifyRowChanged()
                         throws SQLException
        Notifies all of the listeners registered with this RowSet object that one of its rows has changed.

        When an application calls a method that changes a row, such as the CachedRowSet methods insertRow, updateRow, or deleteRow, that method calls notifyRowChanged internally. An application should never invoke this method directly.

        抛出：
        SQLException - if the class extending the BaseRowSet abstract class does not implement the RowSet interface or one of it's sub-interfaces.

      • notifyRowSetChanged

        protected void notifyRowSetChanged()
                            throws SQLException
        Notifies all of the listeners registered with this RowSet object that its entire contents have changed.

        When an application calls methods that change the entire contents of the RowSet object, such as the CachedRowSet methods execute, populate, restoreOriginal, or release, that method calls notifyRowSetChanged internally (either directly or indirectly). An application should never invoke this method directly.

        抛出：
        SQLException - if the class extending the BaseRowSet abstract class does not implement the RowSet interface or one of it's sub-interfaces.

      • getCommand

        public String getCommand()
        Retrieves the SQL query that is the command for this RowSet object. The command property contains the query that will be executed to populate this RowSet object.

        The SQL query returned by this method is used by RowSet methods such as execute and populate, which may be implemented by any class that extends the BaseRowSet abstract class and implements one or more of the standard JSR-114 RowSet interfaces.

        The command is used by the RowSet object's reader to obtain a ResultSet object. The reader then reads the data from the ResultSet object and uses it to to populate this RowSet object.

        The default value for the command property is null.

        返回：
        the String that is the value for this RowSet object's command property; may be null
        另请参见：
        setCommand(java.lang.String)

      • setCommand

        public void setCommand(String cmd)
                throws SQLException
        Sets this RowSet object's command property to the given String object and clears the parameters, if any, that were set for the previous command.

        The command property may not be needed if the RowSet object gets its data from a source that does not support commands, such as a spreadsheet or other tabular file. Thus, this property is optional and may be null.

        参数：
        cmd - a String object containing an SQL query that will be set as this RowSet object's command property; may be null but may not be an empty string
        抛出：
        SQLException - if an empty string is provided as the command value
        另请参见：
        getCommand()

      • getUrl

        public String getUrl()
              throws SQLException
        Retrieves the JDBC URL that this RowSet object's javax.sql.Reader object uses to make a connection with a relational database using a JDBC technology-enabled driver.

        The Url property will be null if the underlying data source is a non-SQL data source, such as a spreadsheet or an XML data source.

        返回：
        a String object that contains the JDBC URL used to establish the connection for this RowSet object; may be null (default value) if not set
        抛出：
        SQLException - if an error occurs retrieving the URL value
        另请参见：
        setUrl(java.lang.String)

      • setUrl

        public void setUrl(String url)
            throws SQLException
        Sets the Url property for this RowSet object to the given String object and sets the dataSource name property to null. The Url property is a JDBC URL that is used when the connection is created using a JDBC technology-enabled driver ("JDBC driver") and the DriverManager. The correct JDBC URL for the specific driver to be used can be found in the driver documentation. Although there are guidelines for for how a JDBC URL is formed, a driver vendor can specify any String object except one with a length of 0 (an empty string).

        Setting the Url property is optional if connections are established using a DataSource object instead of the DriverManager. The driver will use either the URL property or the dataSourceName property to create a connection, whichever was specified most recently. If an application uses a JDBC URL, it must load a JDBC driver that accepts the JDBC URL before it uses the RowSet object to connect to a database. The RowSet object will use the URL internally to create a database connection in order to read or write data.

        参数：
        url - a String object that contains the JDBC URL that will be used to establish the connection to a database for this RowSet object; may be null but must not be an empty string
        抛出：
        SQLException - if an error occurs setting the Url property or the parameter supplied is a string with a length of 0 (an empty string)
        另请参见：
        getUrl()

      • getDataSourceName

        public String getDataSourceName()
        Returns the logical name that when supplied to a naming service that uses the Java Naming and Directory Interface (JNDI) API, will retrieve a javax.sql.DataSource object. This DataSource object can be used to establish a connection to the data source that it represents.

        Users should set either the url or the data source name property. The driver will use the property set most recently to establish a connection.

        返回：
        a String object that identifies the DataSource object to be used for making a connection; if no logical name has been set, null is returned.
        另请参见：
        setDataSourceName(java.lang.String)

      • setDataSourceName

        public void setDataSourceName(String name)
                       throws SQLException
        Sets the DataSource name property for this RowSet object to the given logical name and sets this RowSet object's Url property to null. The name must have been bound to a DataSource object in a JNDI naming service so that an application can do a lookup using that name to retrieve the DataSource object bound to it. The DataSource object can then be used to establish a connection to the data source it represents.

        Users should set either the Url property or the dataSourceName property. If both properties are set, the driver will use the property set most recently.

        参数：
        name - a String object with the name that can be supplied to a naming service based on JNDI technology to retrieve the DataSource object that can be used to get a connection; may be null but must not be an empty string
        抛出：
        SQLException - if an empty string is provided as the DataSource name
        另请参见：
        getDataSourceName()

      • getUsername

        public String getUsername()
        Returns the user name used to create a database connection. Because it is not serialized, the username property is set at runtime before calling the method execute.
        返回：
        the String object containing the user name that is supplied to the data source to create a connection; may be null (default value) if not set
        另请参见：
        setUsername(java.lang.String)

      • setUsername

        public void setUsername(String name)
        Sets the username property for this RowSet object to the given user name. Because it is not serialized, the username property is set at run time before calling the method execute.
        参数：
        name - the String object containing the user name that is supplied to the data source to create a connection. It may be null.
        另请参见：
        getUsername()

      • getPassword

        public String getPassword()
        Returns the password used to create a database connection for this RowSet object. Because the password property is not serialized, it is set at run time before calling the method execute. The default value is null
        返回：
        the String object that represents the password that must be supplied to the database to create a connection
        另请参见：
        setPassword(java.lang.String)

      • setPassword

        public void setPassword(String pass)
        Sets the password used to create a database connection for this RowSet object to the given String object. Because the password property is not serialized, it is set at run time before calling the method execute.
        参数：
        pass - the String object that represents the password that is supplied to the database to create a connection. It may be null.
        另请参见：
        getPassword()

      • setType

        public void setType(int type)
             throws SQLException
        Sets the type for this RowSet object to the specified type. The default type is ResultSet.TYPE_SCROLL_INSENSITIVE.
        参数：
        type - one of the following constants: ResultSet.TYPE_FORWARD_ONLY, ResultSet.TYPE_SCROLL_INSENSITIVE, or ResultSet.TYPE_SCROLL_SENSITIVE
        抛出：
        SQLException - if the parameter supplied is not one of the following constants: ResultSet.TYPE_FORWARD_ONLY or ResultSet.TYPE_SCROLL_INSENSITIVE ResultSet.TYPE_SCROLL_SENSITIVE
        另请参见：
        getConcurrency(), getType()

      • getType

        public int getType()
            throws SQLException
        Returns the type of this RowSet object. The type is initially determined by the statement that created the RowSet object. The RowSet object can call the method setType at any time to change its type. The default is TYPE_SCROLL_INSENSITIVE.
        返回：
        the type of this JDBC RowSet object, which must be one of the following: ResultSet.TYPE_FORWARD_ONLY, ResultSet.TYPE_SCROLL_INSENSITIVE, or ResultSet.TYPE_SCROLL_SENSITIVE
        抛出：
        SQLException - if an error occurs getting the type of of this RowSet object
        另请参见：
        setType(int)

      • setConcurrency

        public void setConcurrency(int concurrency)
                    throws SQLException
        Sets the concurrency for this RowSet object to the specified concurrency. The default concurrency for any RowSet object (connected or disconnected) is ResultSet.CONCUR_UPDATABLE, but this method may be called at any time to change the concurrency.

        参数：
        concurrency - one of the following constants: ResultSet.CONCUR_READ_ONLY or ResultSet.CONCUR_UPDATABLE
        抛出：
        SQLException - if the parameter supplied is not one of the following constants: ResultSet.CONCUR_UPDATABLE or ResultSet.CONCUR_READ_ONLY
        另请参见：
        getConcurrency(), isReadOnly()

      • isReadOnly

        public boolean isReadOnly()
        Returns a boolean indicating whether this RowSet object is read-only. Any attempts to update a read-only RowSet object will result in an SQLException being thrown. By default, rowsets are updatable if updates are possible.
        返回：
        true if this RowSet object cannot be updated; false otherwise
        另请参见：
        setConcurrency(int), setReadOnly(boolean)

      • setReadOnly

        public void setReadOnly(boolean value)
        Sets this RowSet object's readOnly property to the given boolean.
        参数：
        value - true to indicate that this RowSet object is read-only; false to indicate that it is updatable

      • getTransactionIsolation

        public int getTransactionIsolation()
        Returns the transaction isolation property for this RowSet object's connection. This property represents the transaction isolation level requested for use in transactions.

        For RowSet implementations such as the CachedRowSet that operate in a disconnected environment, the SyncProvider object offers complementary locking and data integrity options. The options described below are pertinent only to connected RowSet objects (JdbcRowSet objects).

        返回：
        one of the following constants: Connection.TRANSACTION_NONE, Connection.TRANSACTION_READ_UNCOMMITTED, Connection.TRANSACTION_READ_COMMITTED, Connection.TRANSACTION_REPEATABLE_READ, or Connection.TRANSACTION_SERIALIZABLE
        另请参见：
        SyncFactory, SyncProvider, setTransactionIsolation(int)

      • setTransactionIsolation

        public void setTransactionIsolation(int level)
                             throws SQLException
        Sets the transaction isolation property for this JDBC RowSet object to the given constant. The DBMS will use this transaction isolation level for transactions if it can.

        For RowSet implementations such as the CachedRowSet that operate in a disconnected environment, the SyncProvider object being used offers complementary locking and data integrity options. The options described below are pertinent only to connected RowSet objects (JdbcRowSet objects).

        参数：
        level - one of the following constants, listed in ascending order: Connection.TRANSACTION_NONE, Connection.TRANSACTION_READ_UNCOMMITTED, Connection.TRANSACTION_READ_COMMITTED, Connection.TRANSACTION_REPEATABLE_READ, or Connection.TRANSACTION_SERIALIZABLE
        抛出：
        SQLException - if the given parameter is not one of the Connection constants
        另请参见：
        SyncFactory, SyncProvider, getTransactionIsolation()

      • getTypeMap

        public Map<String,类<?>> getTypeMap()
        Retrieves the type map associated with the Connection object for this RowSet object.

        Drivers that support the JDBC 3.0 API will create Connection objects with an associated type map. This type map, which is initially empty, can contain one or more fully-qualified SQL names and 类 objects indicating the class to which the named SQL value will be mapped. The type mapping specified in the connection's type map is used for custom type mapping when no other type map supersedes it.

        If a type map is explicitly supplied to a method that can perform custom mapping, that type map supersedes the connection's type map.

        返回：
        the java.util.Map object that is the type map for this RowSet object's connection

      • setTypeMap

        public void setTypeMap(Map<String,类<?>> map)
        Installs the given java.util.Map object as the type map associated with the Connection object for this RowSet object. The custom mapping indicated in this type map will be used unless a different type map is explicitly supplied to a method, in which case the type map supplied will be used.
        参数：
        map - a java.util.Map object that contains the mapping from SQL type names for user defined types (UDT) to classes in the Java programming language. Each entry in the Map object consists of the fully qualified SQL name of a UDT and the 类 object for the SQLData implementation of that UDT. May be null.

      • getMaxFieldSize

        public int getMaxFieldSize()
                    throws SQLException
        Retrieves the maximum number of bytes that can be used for a column value in this RowSet object. This limit applies only to columns that hold values of the following types: BINARY, VARBINARY, LONGVARBINARY, CHAR, VARCHAR, and LONGVARCHAR. If the limit is exceeded, the excess data is silently discarded.
        返回：
        an int indicating the current maximum column size limit; zero means that there is no limit
        抛出：
        SQLException - if an error occurs internally determining the maximum limit of the column size

      • setMaxFieldSize

        public void setMaxFieldSize(int max)
                     throws SQLException
        Sets the maximum number of bytes that can be used for a column value in this RowSet object to the given number. This limit applies only to columns that hold values of the following types: BINARY, VARBINARY, LONGVARBINARY, CHAR, VARCHAR, and LONGVARCHAR. If the limit is exceeded, the excess data is silently discarded. For maximum portability, it is advisable to use values greater than 256.
        参数：
        max - an int indicating the new maximum column size limit; zero means that there is no limit
        抛出：
        SQLException - if (1) an error occurs internally setting the maximum limit of the column size or (2) a size of less than 0 is set

      • getMaxRows

        public int getMaxRows()
               throws SQLException
        Retrieves the maximum number of rows that this RowSet object may contain. If this limit is exceeded, the excess rows are silently dropped.
        返回：
        an int indicating the current maximum number of rows; zero means that there is no limit
        抛出：
        SQLException - if an error occurs internally determining the maximum limit of rows that a Rowset object can contain

      • setMaxRows

        public void setMaxRows(int max)
                throws SQLException
        Sets the maximum number of rows that this RowSet object may contain to the given number. If this limit is exceeded, the excess rows are silently dropped.
        参数：
        max - an int indicating the current maximum number of rows; zero means that there is no limit
        抛出：
        SQLException - if an error occurs internally setting the maximum limit on the number of rows that a JDBC RowSet object can contain; or if max is less than 0; or if max is less than the fetchSize of the RowSet

      • setEscapeProcessing

        public void setEscapeProcessing(boolean enable)
                         throws SQLException
        Sets to the given boolean whether or not the driver will scan for escape syntax and do escape substitution before sending SQL statements to the database. The default is for the driver to do escape processing.

        Note: Since PreparedStatement objects have usually been parsed prior to making this call, disabling escape processing for prepared statements will likely have no effect.

        参数：
        enable - true to enable escape processing; false to disable it
        抛出：
        SQLException - if an error occurs setting the underlying JDBC technology-enabled driver to process the escape syntax

      • getQueryTimeout

        public int getQueryTimeout()
                    throws SQLException
        Retrieves the maximum number of seconds the driver will wait for a query to execute. If the limit is exceeded, an SQLException is thrown.
        返回：
        the current query timeout limit in seconds; zero means that there is no limit
        抛出：
        SQLException - if an error occurs in determining the query time-out value

      • setQueryTimeout

        public void setQueryTimeout(int seconds)
                     throws SQLException
        Sets to the given number the maximum number of seconds the driver will wait for a query to execute. If the limit is exceeded, an SQLException is thrown.
        参数：
        seconds - the new query time-out limit in seconds; zero means that there is no limit; must not be less than zero
        抛出：
        SQLException - if an error occurs setting the query time-out or if the query time-out value is less than 0

      • getShowDeleted

        public boolean getShowDeleted()
                       throws SQLException
        Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows. The default value is false.

        Note: Allowing deleted rows to remain visible complicates the behavior of some of the methods. However, most RowSet object users can simply ignore this extra detail because only sophisticated applications will likely want to take advantage of this feature.

        返回：
        true if deleted rows are visible; false otherwise
        抛出：
        SQLException - if an error occurs determining if deleted rows are visible or not
        另请参见：
        setShowDeleted(boolean)

      • setShowDeleted

        public void setShowDeleted(boolean value)
                    throws SQLException
        Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows.
        参数：
        value - true if deleted rows should be shown; false otherwise
        抛出：
        SQLException - if an error occurs setting whether deleted rows are visible or not
        另请参见：
        getShowDeleted()

      • getEscapeProcessing

        public boolean getEscapeProcessing()
                            throws SQLException
        Ascertains whether escape processing is enabled for this RowSet object.
        返回：
        true if escape processing is turned on; false otherwise
        抛出：
        SQLException - if an error occurs determining if escape processing is enabled or not or if the internal escape processing trigger has not been enabled

      • setFetchDirection

        public void setFetchDirection(int direction)
                       throws SQLException
        Gives the driver a performance hint as to the direction in which the rows in this RowSet object will be processed. The driver may ignore this hint.

        A RowSet object inherits the default properties of the ResultSet object from which it got its data. That ResultSet object's default fetch direction is set by the Statement object that created it.

        This method applies to a RowSet object only while it is connected to a database using a JDBC driver.

        A RowSet object may use this method at any time to change its setting for the fetch direction.

        参数：
        direction - one of ResultSet.FETCH_FORWARD, ResultSet.FETCH_REVERSE, or ResultSet.FETCH_UNKNOWN
        抛出：
        SQLException - if (1) the RowSet type is TYPE_FORWARD_ONLY and the given fetch direction is not FETCH_FORWARD or (2) the given fetch direction is not one of the following: ResultSet.FETCH_FORWARD, ResultSet.FETCH_REVERSE, or ResultSet.FETCH_UNKNOWN
        另请参见：
        getFetchDirection()

      • getFetchDirection

        public int getFetchDirection()
                      throws SQLException
        Retrieves this RowSet object's current setting for the fetch direction. The default type is ResultSet.FETCH_FORWARD
        返回：
        one of ResultSet.FETCH_FORWARD, ResultSet.FETCH_REVERSE, or ResultSet.FETCH_UNKNOWN
        抛出：
        SQLException - if an error occurs in determining the current fetch direction for fetching rows
        另请参见：
        setFetchDirection(int)

      • setFetchSize

        public void setFetchSize(int rows)
                  throws SQLException
        Sets the fetch size for this RowSet object to the given number of rows. The fetch size gives a JDBC technology-enabled driver ("JDBC driver") a hint as to the number of rows that should be fetched from the database when more rows are needed for this RowSet object. If the fetch size specified is zero, the driver ignores the value and is free to make its own best guess as to what the fetch size should be.

        A RowSet object inherits the default properties of the ResultSet object from which it got its data. That ResultSet object's default fetch size is set by the Statement object that created it.

        This method applies to a RowSet object only while it is connected to a database using a JDBC driver. For connected RowSet implementations such as JdbcRowSet, this method has a direct and immediate effect on the underlying JDBC driver.

        A RowSet object may use this method at any time to change its setting for the fetch size.

        For RowSet implementations such as CachedRowSet, which operate in a disconnected environment, the SyncProvider object being used may leverage the fetch size to poll the data source and retrieve a number of rows that do not exceed the fetch size and that may form a subset of the actual rows returned by the original query. This is an implementation variance determined by the specific SyncProvider object employed by the disconnected RowSet object.

        参数：
        rows - the number of rows to fetch; 0 to let the driver decide what the best fetch size is; must not be less than 0 or more than the maximum number of rows allowed for this RowSet object (the number returned by a call to the method getMaxRows())
        抛出：
        SQLException - if the specified fetch size is less than 0 or more than the limit for the maximum number of rows
        另请参见：
        getFetchSize()

      • getFetchSize

        public int getFetchSize()
                 throws SQLException
        Returns the fetch size for this RowSet object. The default value is zero.
        返回：
        the number of rows suggested as the fetch size when this RowSet object needs more rows from the database
        抛出：
        SQLException - if an error occurs determining the number of rows in the current fetch size
        另请参见：
        setFetchSize(int)

      • getConcurrency

        public int getConcurrency()
                   throws SQLException
        Returns the concurrency for this RowSet object. The default is CONCUR_UPDATABLE for both connected and disconnected RowSet objects.

        An application can call the method setConcurrency at any time to change a RowSet object's concurrency.

        返回：
        the concurrency type for this RowSet object, which must be one of the following: ResultSet.CONCUR_READ_ONLY or ResultSet.CONCUR_UPDATABLE
        抛出：
        SQLException - if an error occurs getting the concurrency of this RowSet object
        另请参见：
        setConcurrency(int), isReadOnly()

      • setNull

        public void setNull(int parameterIndex,
           int sqlType)
             throws SQLException
        Sets the designated parameter to SQL NULL. Note that the parameter's SQL type must be specified using one of the type codes defined in java.sql.Types. This SQL type is specified in the second parameter.

        Note that the second parameter tells the DBMS the data type of the value being set to NULL. Some DBMSs require this information, so it is required in order to make code more portable.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setNull has been called will return an Object array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is null. The second element is the value set for sqlType. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the second placeholder parameter is being set to null, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        sqlType - an int that is one of the SQL type codes defined in the class Types. If a non-standard sqlType is supplied, this method will not throw a SQLException. This allows implicit support for non-standard SQL types.
        抛出：
        SQLException - if a database access error occurs or the given parameter index is out of bounds
        另请参见：
        getParams()

      • setNull

        public void setNull(int parameterIndex,
           int sqlType,
           String typeName)
             throws SQLException
        Sets the designated parameter to SQL NULL. Although this version of the method setNull is intended for user-defined and REF parameters, this method may be used to set a null parameter for any JDBC type. The following are user-defined types: STRUCT, DISTINCT, and JAVA_OBJECT, and named array types.

        Note: To be portable, applications must give the SQL type code and the fully qualified SQL type name when specifying a NULL user-defined or REF parameter. In the case of a user-defined type, the name is the type name of the parameter itself. For a REF parameter, the name is the type name of the referenced type. If a JDBC technology-enabled driver does not need the type code or type name information, it may ignore it.

        If the parameter does not have a user-defined or REF type, the given typeName parameter is ignored.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setNull has been called will return an Object array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is null. The second element is the value set for sqlType, and the third element is the value set for typeName. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the second placeholder parameter is being set to null, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        sqlType - a value from java.sql.Types
        typeName - the fully qualified name of an SQL user-defined type, which is ignored if the parameter is not a user-defined type or REF value
        抛出：
        SQLException - if an error occurs or the given parameter index is out of bounds
        另请参见：
        getParams()

      • setBoolean

        public void setBoolean(int parameterIndex,
              boolean x)
                throws SQLException
        Sets the designated parameter to the given boolean in the Java programming language. The driver converts this to an SQL BIT value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute, populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setByte

        public void setByte(int parameterIndex,
           byte x)
             throws SQLException
        Sets the designated parameter to the given byte in the Java programming language. The driver converts this to an SQL TINYINT value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setShort

        public void setShort(int parameterIndex,
            short x)
              throws SQLException
        Sets the designated parameter to the given short in the Java programming language. The driver converts this to an SQL SMALLINT value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setInt

        public void setInt(int parameterIndex,
          int x)
            throws SQLException
        Sets the designated parameter to an int in the Java programming language. The driver converts this to an SQL INTEGER value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setLong

        public void setLong(int parameterIndex,
           long x)
             throws SQLException
        Sets the designated parameter to the given long in the Java programming language. The driver converts this to an SQL BIGINT value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setFloat

        public void setFloat(int parameterIndex,
            float x)
              throws SQLException
        Sets the designated parameter to the given float in the Java programming language. The driver converts this to an SQL FLOAT value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setDouble

        public void setDouble(int parameterIndex,
             double x)
               throws SQLException
        Sets the designated parameter to the given double in the Java programming language. The driver converts this to an SQL DOUBLE value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class. S

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setBigDecimal

        public void setBigDecimal(int parameterIndex,
                 BigDecimal x)
                   throws SQLException
        Sets the designated parameter to the given java.lang.BigDecimal value. The driver converts this to an SQL NUMERIC value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        Note: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setString

        public void setString(int parameterIndex,
             String x)
               throws SQLException
        Sets the designated parameter to the given String value. The driver converts this to an SQL VARCHAR or LONGVARCHAR value (depending on the argument's size relative to the driver's limits on VARCHAR values) when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setBytes

        public void setBytes(int parameterIndex,
            byte[] x)
              throws SQLException
        Sets the designated parameter to the given array of bytes. The driver converts this to an SQL VARBINARY or LONGVARBINARY value (depending on the argument's size relative to the driver's limits on VARBINARY values) when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setDate

        public void setDate(int parameterIndex,
           Date x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date value. The driver converts this to an SQL DATE value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setDate has been called will return an array with the value to be set for placeholder parameter number parameterIndex being the Date object supplied as the second parameter. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the parameter value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setTime

        public void setTime(int parameterIndex,
           Time x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time value. The driver converts this to an SQL TIME value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of the method setTime has been called will return an array of the parameters that have been set. The parameter to be set for parameter placeholder number parameterIndex will be the Time object that was set as the second parameter to this method.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a java.sql.Time object, which is to be set as the value for placeholder parameter parameterIndex
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setTimestamp

        public void setTimestamp(int parameterIndex,
                Timestamp x)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp value. The driver converts this to an SQL TIMESTAMP value when it sends it to the database.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setTimestamp has been called will return an array with the value for parameter placeholder number parameterIndex being the Timestamp object that was supplied as the second parameter to this method. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a java.sql.Timestamp object
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setAsciiStream

        public void setAsciiStream(int parameterIndex,
                  InputStream x,
                  int length)
                    throws SQLException
        Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes. The contents of the stream will be read and sent to the database. This method throws an SQLException object if the number of bytes read and sent to the database is not equal to length.

        When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream object. A JDBC technology-enabled driver will read the data from the stream as needed until it reaches end-of-file. The driver will do any necessary conversion from ASCII to the database CHAR format.

        Note: This stream object can be either a standard Java stream object or your own subclass that implements the standard interface.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        Note: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after setAsciiStream has been called will return an array containing the parameter values that have been set. The element in the array that represents the values set with this method will itself be an array. The first element of that array is the given java.io.InputStream object. The second element is the value set for length. The third element is an internal BaseRowSet constant specifying that the stream passed to this method is an ASCII stream. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the input stream being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the Java input stream that contains the ASCII parameter value
        length - the number of bytes in the stream. This is the number of bytes the driver will send to the DBMS; lengths of 0 or less are are undefined but will cause an invalid length exception to be thrown in the underlying JDBC driver.
        抛出：
        SQLException - if an error occurs, the parameter index is out of bounds, or when connected to a data source, the number of bytes the driver reads and sends to the database is not equal to the number of bytes specified in length
        另请参见：
        getParams()

      • setAsciiStream

        public void setAsciiStream(int parameterIndex,
                  InputStream x)
                    throws SQLException
        Sets the designated parameter in this RowSet object's command to the given input stream. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setAsciiStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the Java input stream that contains the ASCII parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBinaryStream

        public void setBinaryStream(int parameterIndex,
                   InputStream x,
                   int length)
                     throws SQLException
        Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes. The contents of the stream will be read and sent to the database. This method throws an SQLException object if the number of bytes read and sent to the database is not equal to length.

        When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. A JDBC technology-enabled driver will read the data from the stream as needed until it reaches end-of-file.

        Note: This stream object can be either a standard Java stream object or your own subclass that implements the standard interface.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after setBinaryStream has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.io.InputStream object. The second element is the value set for length. The third element is an internal BaseRowSet constant specifying that the stream passed to this method is a binary stream. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the input stream being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the input stream that contains the binary value to be set
        length - the number of bytes in the stream; lengths of 0 or less are are undefined but will cause an invalid length exception to be thrown in the underlying JDBC driver.
        抛出：
        SQLException - if an error occurs, the parameter index is out of bounds, or when connected to a data source, the number of bytes the driver reads and sends to the database is not equal to the number of bytes specified in length
        另请参见：
        getParams()

      • setBinaryStream

        public void setBinaryStream(int parameterIndex,
                   InputStream x)
                     throws SQLException
        Sets the designated parameter in this RowSet object's command to the given input stream. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBinaryStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the java input stream which contains the binary parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setUnicodeStream

        public void setUnicodeStream(int parameterIndex,
                    InputStream x,
                    int length)
                      throws SQLException
        Deprecated. getCharacterStream should be used in its place
        Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes. The contents of the stream will be read and sent to the database. This method throws an SQLException if the number of bytes read and sent to the database is not equal to length.

        When a very large Unicode value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream object. A JDBC technology-enabled driver will read the data from the stream as needed, until it reaches end-of-file. The driver will do any necessary conversion from Unicode to the database CHAR format. The byte format of the Unicode stream must be Java UTF-8, as defined in the Java Virtual Machine Specification.

        Note: This stream object can be either a standard Java stream object or your own subclass that implements the standard interface.

        This method is deprecated; the method getCharacterStream should be used in its place.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Calls made to the method getParams after setUnicodeStream has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.io.InputStream object. The second element is the value set for length. The third element is an internal BaseRowSet constant specifying that the stream passed to this method is a Unicode stream. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the input stream being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the java.io.InputStream object that contains the UNICODE parameter value
        length - the number of bytes in the input stream
        抛出：
        SQLException - if an error occurs, the parameter index is out of bounds, or the number of bytes the driver reads and sends to the database is not equal to the number of bytes specified in length
        另请参见：
        getParams()

      • setCharacterStream

        public void setCharacterStream(int parameterIndex,
                      Reader reader,
                      int length)
                        throws SQLException
        Sets the designated parameter to the given java.io.Reader object, which will have the specified number of characters. The contents of the reader will be read and sent to the database. This method throws an SQLException if the number of bytes read and sent to the database is not equal to length.

        When a very large Unicode value is input to a LONGVARCHAR parameter, it may be more practical to send it via a Reader object. A JDBC technology-enabled driver will read the data from the stream as needed until it reaches end-of-file. The driver will do any necessary conversion from Unicode to the database CHAR format. The byte format of the Unicode stream must be Java UTF-8, as defined in the Java Virtual Machine Specification.

        Note: This stream object can be either a standard Java stream object or your own subclass that implements the standard interface.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after setCharacterStream has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.io.Reader object. The second element is the value set for length. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the reader being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        reader - the Reader object that contains the Unicode data
        length - the number of characters in the stream; lengths of 0 or less are undefined but will cause an invalid length exception to be thrown in the underlying JDBC driver.
        抛出：
        SQLException - if an error occurs, the parameter index is out of bounds, or when connected to a data source, the number of bytes the driver reads and sends to the database is not equal to the number of bytes specified in length
        另请参见：
        getParams()

      • setCharacterStream

        public void setCharacterStream(int parameterIndex,
                      Reader reader)
                        throws SQLException
        Sets the designated parameter in this RowSet object's command to the given Reader object. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setCharacterStream which takes a length parameter.

        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        reader - the java.io.Reader object that contains the Unicode data
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setObject

        public void setObject(int parameterIndex,
             Object x,
             int targetSqlType,
             int scale)
               throws SQLException
        Sets the designated parameter to an Object in the Java programming language. The second parameter must be an Object type. For integral values, the java.lang equivalent objects should be used. For example, use the class Integer for an int.

        The driver converts this object to the specified target SQL type before sending it to the database. If the object has a custom mapping (is of a class implementing SQLData), the driver should call the method SQLData.writeSQL to write the object to the SQL data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, Struct, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        Note that this method may be used to pass database- specific abstract data types.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSetexecute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setObject has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given Object instance, and the second element is the value set for targetSqlType. The third element is the value set for scale, which the driver will ignore if the type of the object being set is not java.sql.Types.NUMERIC or java.sql.Types.DECIMAL. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the object being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the Object containing the input parameter value; must be an Object type
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database. The scale argument may further qualify this type. If a non-standard targetSqlType is supplied, this method will not throw a SQLException. This allows implicit support for non-standard SQL types.
        scale - for the types java.sql.Types.DECIMAL and java.sql.Types.NUMERIC, this is the number of digits after the decimal point. For all other types, this value will be ignored.
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setObject

        public void setObject(int parameterIndex,
             Object x,
             int targetSqlType)
               throws SQLException
        Sets the value of the designated parameter with the given Object value. This method is like setObject(int parameterIndex, Object x, int targetSqlType, int scale) except that it assumes a scale of zero.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setObject has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given Object instance. The second element is the value set for targetSqlType. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the object being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the Object containing the input parameter value; must be an Object type
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database. If a non-standard targetSqlType is supplied, this method will not throw a SQLException. This allows implicit support for non-standard SQL types.
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setObject

        public void setObject(int parameterIndex,
             Object x)
               throws SQLException
        Sets the designated parameter to an Object in the Java programming language. The second parameter must be an Object type. For integral values, the java.lang equivalent objects should be used. For example, use the class Integer for an int.

        The JDBC specification defines a standard mapping from Java Object types to SQL types. The driver will use this standard mapping to convert the given object to its corresponding SQL type before sending it to the database. If the object has a custom mapping (is of a class implementing SQLData), the driver should call the method SQLData.writeSQL to write the object to the SQL data stream.

        If, on the other hand, the object is of a class implementing Ref, Blob, Clob, Struct, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        This method throws an exception if there is an ambiguity, for example, if the object is of a class implementing more than one interface.

        Note that this method may be used to pass database-specific abstract data types.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        After this method has been called, a call to the method getParams will return an object array of the current command parameters, which will include the Object set for placeholder parameter number parameterIndex. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - the object containing the input parameter value
        抛出：
        SQLException - if an error occurs the parameter index is out of bounds, or there is ambiguity in the implementation of the object being set
        另请参见：
        getParams()

      • setRef

        public void setRef(int parameterIndex,
          Ref ref)
            throws SQLException
        Sets the designated parameter to the given Ref object in the Java programming language. The driver converts this to an SQL REF value when it sends it to the database. Internally, the Ref is represented as a SerialRef to ensure serializability.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        After this method has been called, a call to the method getParams will return an object array of the current command parameters, which will include the Ref object set for placeholder parameter number parameterIndex. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        ref - a Ref object representing an SQL REF value; cannot be null
        抛出：
        SQLException - if an error occurs; the parameter index is out of bounds or the Ref object is null; or the Ref object returns a null base type name.
        另请参见：
        getParams(), SerialRef

      • setBlob

        public void setBlob(int parameterIndex,
           Blob x)
             throws SQLException
        Sets the designated parameter to the given Blob object in the Java programming language. The driver converts this to an SQL BLOB value when it sends it to the database. Internally, the Blob is represented as a SerialBlob to ensure serializability.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces. NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        After this method has been called, a call to the method getParams will return an object array of the current command parameters, which will include the Blob object set for placeholder parameter number parameterIndex. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a Blob object representing an SQL BLOB value
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams(), SerialBlob

      • setClob

        public void setClob(int parameterIndex,
           Clob x)
             throws SQLException
        Sets the designated parameter to the given Clob object in the Java programming language. The driver converts this to an SQL CLOB value when it sends it to the database. Internally, the Clob is represented as a SerialClob to ensure serializability.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        After this method has been called, a call to the method getParams will return an object array of the current command parameters, which will include the Clob object set for placeholder parameter number parameterIndex. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a Clob object representing an SQL CLOB value; cannot be null
        抛出：
        SQLException - if an error occurs; the parameter index is out of bounds or the Clob is null
        另请参见：
        getParams(), SerialBlob

      • setArray

        public void setArray(int parameterIndex,
            Array array)
              throws SQLException
        Sets the designated parameter to an Array object in the Java programming language. The driver converts this to an SQL ARRAY value when it sends it to the database. Internally, the Array is represented as a SerialArray to ensure serializability.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        Note: JdbcRowSet does not require the populate method as it is undefined in this class.

        After this method has been called, a call to the method getParams will return an object array of the current command parameters, which will include the Array object set for placeholder parameter number parameterIndex. Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is element number parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        array - an Array object representing an SQL ARRAY value; cannot be null. The Array object passed to this method must return a non-null Object for all getArray() method calls. A null value will cause a SQLException to be thrown.
        抛出：
        SQLException - if an error occurs; the parameter index is out of bounds or the ARRAY is null
        另请参见：
        getParams(), SerialArray

      • setDate

        public void setDate(int parameterIndex,
           Date x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date object. When the DBMS does not store time zone information, the driver will use the given Calendar object to construct the SQL DATE value to send to the database. With a Calendar object, the driver can calculate the date taking into account a custom time zone. If no Calendar object is specified, the driver uses the time zone of the Virtual Machine that is running the application.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setDate has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.sql.Date object. The second element is the value set for cal. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the date being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a java.sql.Date object representing an SQL DATE value
        cal - a java.util.Calendar object to use when when constructing the date
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setTime

        public void setTime(int parameterIndex,
           Time x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time object. The driver converts this to an SQL TIME value when it sends it to the database.

        When the DBMS does not store time zone information, the driver will use the given Calendar object to construct the SQL TIME value to send to the database. With a Calendar object, the driver can calculate the date taking into account a custom time zone. If no Calendar object is specified, the driver uses the time zone of the Virtual Machine that is running the application.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setTime has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.sql.Time object. The second element is the value set for cal. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the time being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a java.sql.Time object
        cal - the java.util.Calendar object the driver can use to construct the time
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • setTimestamp

        public void setTimestamp(int parameterIndex,
                Timestamp x,
                Calendar cal)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp object. The driver converts this to an SQL TIMESTAMP value when it sends it to the database.

        When the DBMS does not store time zone information, the driver will use the given Calendar object to construct the SQL TIMESTAMP value to send to the database. With a Calendar object, the driver can calculate the timestamp taking into account a custom time zone. If no Calendar object is specified, the driver uses the time zone of the Virtual Machine that is running the application.

        The parameter value set by this method is stored internally and will be supplied as the appropriate parameter in this RowSet object's command when the method execute is called. Methods such as execute and populate must be provided in any class that extends this class and implements one or more of the standard JSR-114 RowSet interfaces.

        NOTE: JdbcRowSet does not require the populate method as it is undefined in this class.

        Calls made to the method getParams after this version of setTimestamp has been called will return an array containing the parameter values that have been set. In that array, the element that represents the values set with this method will itself be an array. The first element of that array is the given java.sql.Timestamp object. The second element is the value set for cal. The parameter number is indicated by an element's position in the array returned by the method getParams, with the first element being the value for the first placeholder parameter, the second element being the value for the second placeholder parameter, and so on. In other words, if the timestamp being set is the value for the second placeholder parameter, the array containing it will be the second element in the array returned by getParams.

        Note that because the numbering of elements in an array starts at zero, the array element that corresponds to placeholder parameter number parameterIndex is parameterIndex -1.

        参数：
        parameterIndex - the ordinal number of the placeholder parameter in this RowSet object's command that is to be set. The first parameter is 1, the second is 2, and so on; must be 1 or greater
        x - a java.sql.Timestamp object
        cal - the java.util.Calendar object the driver can use to construct the timestamp
        抛出：
        SQLException - if an error occurs or the parameter index is out of bounds
        另请参见：
        getParams()

      • clearParameters

        public void clearParameters()
                     throws SQLException
        Clears all of the current parameter values in this RowSet object's internal representation of the parameters to be set in this RowSet object's command when it is executed.

        In general, parameter values remain in force for repeated use in this RowSet object's command. Setting a parameter value with the setter methods automatically clears the value of the designated parameter and replaces it with the new specified value.

        This method is called internally by the setCommand method to clear all of the parameters set for the previous command.

        Furthermore, this method differs from the initParams method in that it maintains the schema of the RowSet object.

        抛出：
        SQLException - if an error occurs clearing the parameters

      • getParams

        public Object[] getParams()
                   throws SQLException
        Retrieves an array containing the parameter values (both Objects and primitives) that have been set for this RowSet object's command and throws an SQLException object if all parameters have not been set. Before the command is sent to the DBMS to be executed, these parameters will be substituted for placeholder parameters in the PreparedStatement object that is the command for a RowSet implementation extending the BaseRowSet class.

        Each element in the array that is returned is an Object instance that contains the values of the parameters supplied to a setter method. The order of the elements is determined by the value supplied for parameterIndex. If the setter method takes only the parameter index and the value to be set (possibly null), the array element will contain the value to be set (which will be expressed as an Object). If there are additional parameters, the array element will itself be an array containing the value to be set plus any additional parameter values supplied to the setter method. If the method sets a stream, the array element includes the type of stream being supplied to the method. These additional parameters are for the use of the driver or the DBMS and may or may not be used.

        NOTE: Stored parameter values of types Array, Blob, Clob and Ref are returned as SerialArray, SerialBlob, SerialClob and SerialRef respectively.

        返回：
        an array of Object instances that includes the parameter values that may be set in this RowSet object's command; an empty array if no parameters have been set
        抛出：
        SQLException - if an error occurs retrieveing the object array of parameters of this RowSet object or if not all parameters have been set

      • setNull

        public void setNull(String parameterName,
           int sqlType)
             throws SQLException
        Sets the designated parameter to SQL NULL.

        Note: You must specify the parameter's SQL type.

        参数：
        parameterName - the name of the parameter
        sqlType - the SQL type code defined in java.sql.Types
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setNull

        public void setNull(String parameterName,
           int sqlType,
           String typeName)
             throws SQLException
        Sets the designated parameter to SQL NULL. This version of the method setNull should be used for user-defined types and REF type parameters. Examples of user-defined types include: STRUCT, DISTINCT, JAVA_OBJECT, and named array types.

        Note: To be portable, applications must give the SQL type code and the fully-qualified SQL type name when specifying a NULL user-defined or REF parameter. In the case of a user-defined type the name is the type name of the parameter itself. For a REF parameter, the name is the type name of the referenced type. If a JDBC driver does not need the type code or type name information, it may ignore it. Although it is intended for user-defined and Ref parameters, this method may be used to set a null parameter of any JDBC type. If the parameter does not have a user-defined or REF type, the given typeName is ignored.

        参数：
        parameterName - the name of the parameter
        sqlType - a value from java.sql.Types
        typeName - the fully-qualified name of an SQL user-defined type; ignored if the parameter is not a user-defined type or SQL REF value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setBoolean

        public void setBoolean(String parameterName,
              boolean x)
                throws SQLException
        Sets the designated parameter to the given Java boolean value. The driver converts this to an SQL BIT or BOOLEAN value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setByte

        public void setByte(String parameterName,
           byte x)
             throws SQLException
        Sets the designated parameter to the given Java byte value. The driver converts this to an SQL TINYINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setShort

        public void setShort(String parameterName,
            short x)
              throws SQLException
        Sets the designated parameter to the given Java short value. The driver converts this to an SQL SMALLINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setInt

        public void setInt(String parameterName,
          int x)
            throws SQLException
        Sets the designated parameter to the given Java int value. The driver converts this to an SQL INTEGER value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setLong

        public void setLong(String parameterName,
           long x)
             throws SQLException
        Sets the designated parameter to the given Java long value. The driver converts this to an SQL BIGINT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setFloat

        public void setFloat(String parameterName,
            float x)
              throws SQLException
        Sets the designated parameter to the given Java float value. The driver converts this to an SQL FLOAT value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setDouble

        public void setDouble(String parameterName,
             double x)
               throws SQLException
        Sets the designated parameter to the given Java double value. The driver converts this to an SQL DOUBLE value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setBigDecimal

        public void setBigDecimal(String parameterName,
                 BigDecimal x)
                   throws SQLException
        Sets the designated parameter to the given java.math.BigDecimal value. The driver converts this to an SQL NUMERIC value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setString

        public void setString(String parameterName,
             String x)
               throws SQLException
        Sets the designated parameter to the given Java String value. The driver converts this to an SQL VARCHAR or LONGVARCHAR value (depending on the argument's size relative to the driver's limits on VARCHAR values) when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setBytes

        public void setBytes(String parameterName,
            byte[] x)
              throws SQLException
        Sets the designated parameter to the given Java array of bytes. The driver converts this to an SQL VARBINARY or LONGVARBINARY (depending on the argument's size relative to the driver's limits on VARBINARY values) when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setTimestamp

        public void setTimestamp(String parameterName,
                Timestamp x)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp value. The driver converts this to an SQL TIMESTAMP value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setAsciiStream

        public void setAsciiStream(String parameterName,
                  InputStream x,
                  int length)
                    throws SQLException
        Sets the designated parameter to the given input stream, which will have the specified number of bytes. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        x - the Java input stream that contains the ASCII parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setBinaryStream

        public void setBinaryStream(String parameterName,
                   InputStream x,
                   int length)
                     throws SQLException
        Sets the designated parameter to the given input stream, which will have the specified number of bytes. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        x - the java input stream which contains the binary parameter value
        length - the number of bytes in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setCharacterStream

        public void setCharacterStream(String parameterName,
                      Reader reader,
                      int length)
                        throws SQLException
        Sets the designated parameter to the given Reader object, which is the given number of characters long. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        参数：
        parameterName - the name of the parameter
        reader - the java.io.Reader object that contains the UNICODE data used as the designated parameter
        length - the number of characters in the stream
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4

      • setAsciiStream

        public void setAsciiStream(String parameterName,
                  InputStream x)
                    throws SQLException
        Sets the designated parameter to the given input stream. When a very large ASCII value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.InputStream. Data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from ASCII to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setAsciiStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        x - the Java input stream that contains the ASCII parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBinaryStream

        public void setBinaryStream(String parameterName,
                   InputStream x)
                     throws SQLException
        Sets the designated parameter to the given input stream. When a very large binary value is input to a LONGVARBINARY parameter, it may be more practical to send it via a java.io.InputStream object. The data will be read from the stream as needed until end-of-file is reached.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBinaryStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        x - the java input stream which contains the binary parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setCharacterStream

        public void setCharacterStream(String parameterName,
                      Reader reader)
                        throws SQLException
        Sets the designated parameter to the given Reader object. When a very large UNICODE value is input to a LONGVARCHAR parameter, it may be more practical to send it via a java.io.Reader object. The data will be read from the stream as needed until end-of-file is reached. The JDBC driver will do any necessary conversion from UNICODE to the database char format.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setCharacterStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - the java.io.Reader object that contains the Unicode data
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNCharacterStream

        public void setNCharacterStream(int parameterIndex,
                       Reader value)
                         throws SQLException
        Sets the designated parameter in this RowSet object's command to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNCharacterStream which takes a length parameter.

        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; if a database access error occurs; or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setObject

        public void setObject(String parameterName,
             Object x,
             int targetSqlType,
             int scale)
               throws SQLException
        Sets the value of the designated parameter with the given object. The second argument must be an object type; for integral values, the java.lang equivalent objects should be used.

        The given Java object will be converted to the given targetSqlType before being sent to the database. If the object has a custom mapping (is of a class implementing the interface SQLData), the JDBC driver should call the method SQLData.writeSQL to write it to the SQL data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        Note that this method may be used to pass datatabase- specific abstract data types.

        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database. The scale argument may further qualify this type.
        scale - for java.sql.Types.DECIMAL or java.sql.Types.NUMERIC types, this is the number of digits after the decimal point. For all other types, this value will be ignored.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if targetSqlType is a ARRAY, BLOB, CLOB, DATALINK, JAVA_OBJECT, NCHAR, NCLOB, NVARCHAR, LONGNVARCHAR, REF, ROWID, SQLXML or STRUCT data type and the JDBC driver does not support this data type
        从以下版本开始：
        1.4
        另请参见：
        Types, getParams()

      • setObject

        public void setObject(String parameterName,
             Object x,
             int targetSqlType)
               throws SQLException
        Sets the value of the designated parameter with the given object. This method is like the method setObject above, except that it assumes a scale of zero.
        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        targetSqlType - the SQL type (as defined in java.sql.Types) to be sent to the database
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if targetSqlType is a ARRAY, BLOB, CLOB, DATALINK, JAVA_OBJECT, NCHAR, NCLOB, NVARCHAR, LONGNVARCHAR, REF, ROWID, SQLXML or STRUCT data type and the JDBC driver does not support this data type
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setObject

        public void setObject(String parameterName,
             Object x)
               throws SQLException
        Sets the value of the designated parameter with the given object. The second parameter must be of type Object; therefore, the java.lang equivalent objects should be used for built-in types.

        The JDBC specification specifies a standard mapping from Java Object types to SQL types. The given argument will be converted to the corresponding SQL type before being sent to the database.

        Note that this method may be used to pass datatabase- specific abstract data types, by using a driver-specific Java type. If the object is of a class implementing the interface SQLData, the JDBC driver should call the method SQLData.writeSQL to write it to the SQL data stream. If, on the other hand, the object is of a class implementing Ref, Blob, Clob, NClob, Struct, java.net.URL, or Array, the driver should pass it to the database as a value of the corresponding SQL type.

        This method throws an exception if there is an ambiguity, for example, if the object is of a class implementing more than one of the interfaces named above.

        参数：
        parameterName - the name of the parameter
        x - the object containing the input parameter value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed CallableStatement or if the given Object parameter is ambiguous
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setBlob

        public void setBlob(int parameterIndex,
           InputStream inputStream,
           long length)
             throws SQLException
        Sets the designated parameter to a InputStream object. The inputstream must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setBinaryStream (int, InputStream, int) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        length - the number of bytes in the parameter data.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement, if parameterIndex does not correspond to a parameter marker in the SQL statement, if the length specified is less than zero or if the number of bytes in the inputstream does not match the specfied length.
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        public void setBlob(int parameterIndex,
           InputStream inputStream)
             throws SQLException
        Sets the designated parameter to a InputStream object. This method differs from the setBinaryStream (int, InputStream) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBlob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement or if parameterIndex does not correspond to a parameter marker in the SQL statement,
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        public void setBlob(String parameterName,
           InputStream inputStream,
           long length)
             throws SQLException
        Sets the designated parameter to a InputStream object. The inputstream must contain the number of characters specified by length, otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setBinaryStream (int, InputStream, int) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARBINARY or a BLOB
        参数：
        parameterName - the name of the parameter to be set the second is 2, ...
        inputStream - An object that contains the data to set the parameter value to.
        length - the number of bytes in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement, or if the length specified is less than zero; if the number of bytes in the inputstream does not match the specfied length; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        public void setBlob(String parameterName,
           Blob x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Blob object. The driver converts this to an SQL BLOB value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - a Blob object that maps an SQL BLOB value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setBlob

        public void setBlob(String parameterName,
           InputStream inputStream)
             throws SQLException
        Sets the designated parameter to a InputStream object. This method differs from the setBinaryStream (int, InputStream) method because it informs the driver that the parameter value should be sent to the server as a BLOB. When the setBinaryStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARBINARY or a BLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setBlob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        inputStream - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        public void setClob(int parameterIndex,
           Reader reader,
           long length)
             throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARCHAR or a CLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatement, if parameterIndex does not correspond to a parameter marker in the SQL statement, or if the length specified is less than zero.
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        public void setClob(int parameterIndex,
           Reader reader)
             throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGVARCHAR or a CLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setClob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed PreparedStatementor if parameterIndex does not correspond to a parameter marker in the SQL statement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        public void setClob(String parameterName,
           Reader reader,
           long length)
             throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARCHAR or a CLOB
        参数：
        parameterName - the name of the parameter to be set
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        public void setClob(String parameterName,
           Clob x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Clob object. The driver converts this to an SQL CLOB value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - a Clob object that maps an SQL CLOB value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setClob

        public void setClob(String parameterName,
           Reader reader)
             throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a CLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGVARCHAR or a CLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setClob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setDate

        public void setDate(String parameterName,
           Date x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application. The driver converts this to an SQL DATE value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setDate

        public void setDate(String parameterName,
           Date x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Date value, using the given Calendar object. The driver uses the Calendar object to construct an SQL DATE value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the date taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the date
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setTime

        public void setTime(String parameterName,
           Time x)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time value. The driver converts this to an SQL TIME value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setTime

        public void setTime(String parameterName,
           Time x,
           Calendar cal)
             throws SQLException
        Sets the designated parameter to the given java.sql.Time value, using the given Calendar object. The driver uses the Calendar object to construct an SQL TIME value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the time taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the time
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setTimestamp

        public void setTimestamp(String parameterName,
                Timestamp x,
                Calendar cal)
                  throws SQLException
        Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object. The driver uses the Calendar object to construct an SQL TIMESTAMP value, which the driver then sends to the database. With a a Calendar object, the driver can calculate the timestamp taking into account a custom timezone. If no Calendar object is specified, the driver uses the default timezone, which is that of the virtual machine running the application.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        cal - the Calendar object the driver will use to construct the timestamp
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
        另请参见：
        getParams()

      • setSQLXML

        public void setSQLXML(int parameterIndex,
             SQLXML xmlObject)
               throws SQLException
        Sets the designated parameter to the given java.sql.SQLXML object. The driver converts this to an SQL XML value when it sends it to the database.
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        xmlObject - a SQLXML object that maps an SQL XML value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed result set, the java.xml.transform.Result, Writer or OutputStream has not been closed for the SQLXML object or if there is an error processing the XML value. The getCause method of the exception may provide a more detailed exception, for example, if the stream does not contain valid XML.
        从以下版本开始：
        1.6

      • setSQLXML

        public void setSQLXML(String parameterName,
             SQLXML xmlObject)
               throws SQLException
        Sets the designated parameter to the given java.sql.SQLXML object. The driver converts this to an SQL XML value when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        xmlObject - a SQLXML object that maps an SQL XML value
        抛出：
        SQLException - if a database access error occurs, this method is called on a closed result set, the java.xml.transform.Result, Writer or OutputStream has not been closed for the SQLXML object or if there is an error processing the XML value. The getCause method of the exception may provide a more detailed exception, for example, if the stream does not contain valid XML.
        从以下版本开始：
        1.6

      • setRowId

        public void setRowId(int parameterIndex,
            RowId x)
              throws SQLException
        Sets the designated parameter to the given java.sql.RowId object. The driver converts this to a SQL ROWID value when it sends it to the database
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • setRowId

        public void setRowId(String parameterName,
            RowId x)
              throws SQLException
        Sets the designated parameter to the given java.sql.RowId object. The driver converts this to a SQL ROWID when it sends it to the database.
        参数：
        parameterName - the name of the parameter
        x - the parameter value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • setNString

        public void setNString(int parameterIndex,
              String value)
                throws SQLException
        Sets the designated paramter to the given String object. The driver converts this to a SQL NCHAR or NVARCHAR or LONGNVARCHAR value (depending on the argument's size relative to the driver's limits on NVARCHAR values) when it sends it to the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNString

        public void setNString(String parameterName,
              String value)
                throws SQLException
        Sets the designated paramter to the given String object. The driver converts this to a SQL NCHAR or NVARCHAR or LONGNVARCHAR
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        public void setNCharacterStream(int parameterIndex,
                       Reader value,
                       long length)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        public void setNCharacterStream(String parameterName,
                       Reader value,
                       long length)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNCharacterStream

        public void setNCharacterStream(String parameterName,
                       Reader value)
                         throws SQLException
        Sets the designated parameter to a Reader object. The Reader reads the data till end-of-file is reached. The driver does the necessary conversion from Java character format to the national character set in the database.

        Note: This stream object can either be a standard Java stream object or your own subclass that implements the standard interface.

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNCharacterStream which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; if a database access error occurs; or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(String parameterName,
            NClob value)
              throws SQLException
        Sets the designated parameter to a java.sql.NClob object. The object implements the java.sql.NClob interface. This NClob object maps to a SQL NCLOB.
        参数：
        parameterName - the name of the column to be set
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(String parameterName,
            Reader reader,
            long length)
              throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain * the number of characters specified by length otherwise a SQLException will be generated when the CallableStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGNVARCHAR or a NCLOB
        参数：
        parameterName - the name of the parameter to be set
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(String parameterName,
            Reader reader)
              throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be send to the server as a LONGNVARCHAR or a NCLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNClob which takes a length parameter.

        参数：
        parameterName - the name of the parameter
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed CallableStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(int parameterIndex,
            Reader reader,
            long length)
              throws SQLException
        Sets the designated parameter to a Reader object. The reader must contain the number of characters specified by length otherwise a SQLException will be generated when the PreparedStatement is executed. This method differs from the setCharacterStream (int, Reader, int) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGNVARCHAR or a NCLOB
        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        length - the number of characters in the parameter data.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the length specified is less than zero; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(int parameterIndex,
            NClob value)
              throws SQLException
        Sets the designated parameter to a java.sql.NClob object. The driver converts this oa SQL NCLOB value when it sends it to the database.
        参数：
        parameterIndex - of the first parameter is 1, the second is 2, ...
        value - the parameter value
        抛出：
        SQLException - if the driver does not support national character sets; if the driver can detect that a data conversion error could occur ; or if a database access error occurs
        从以下版本开始：
        1.6

      • setNClob

        public void setNClob(int parameterIndex,
            Reader reader)
              throws SQLException
        Sets the designated parameter to a Reader object. This method differs from the setCharacterStream (int, Reader) method because it informs the driver that the parameter value should be sent to the server as a NCLOB. When the setCharacterStream method is used, the driver may have to do extra work to determine whether the parameter data should be sent to the server as a LONGNVARCHAR or a NCLOB

        Note: Consult your JDBC driver documentation to determine if it might be more efficient to use a version of setNClob which takes a length parameter.

        参数：
        parameterIndex - index of the first parameter is 1, the second is 2, ...
        reader - An object that contains the data to set the parameter value to.
        抛出：
        SQLException - if parameterIndex does not correspond to a parameter marker in the SQL statement; if the driver does not support national character sets; if the driver can detect that a data conversion error could occur; if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • setURL

        public void setURL(int parameterIndex,
          URL x)
            throws SQLException
        Sets the designated parameter to the given java.net.URL value. The driver converts this to an SQL DATALINK value when it sends it to the database.
        参数：
        parameterIndex - the first parameter is 1, the second is 2, ...
        x - the java.net.URL object to be set
        抛出：
        SQLException - if a database access error occurs or this method is called on a closed PreparedStatement
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CachedRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface CachedRowSet

  • All Superinterfaces:
    AutoCloseable, Joinable, ResultSet, RowSet, Wrapper
    All Known Subinterfaces:
    FilteredRowSet, JoinRowSet, WebRowSet

    public interface CachedRowSet
extends RowSet, Joinable
    The interface that all standard implementations of CachedRowSet must implement.

    The reference implementation of the CachedRowSet interface provided by Oracle Corporation is a standard implementation. Developers may use this implementation just as it is, they may extend it, or they may choose to write their own implementations of this interface.

    A CachedRowSet object is a container for rows of data that caches its rows in memory, which makes it possible to operate without always being connected to its data source. Further, it is a JavaBeansTM component and is scrollable, updatable, and serializable. A CachedRowSet object typically contains rows from a result set, but it can also contain rows from any file with a tabular format, such as a spread sheet. The reference implementation supports getting data only from a ResultSet object, but developers can extend the SyncProvider implementations to provide access to other tabular data sources.

    An application can modify the data in a CachedRowSet object, and those modifications can then be propagated back to the source of the data.

    A CachedRowSet object is a disconnected rowset, which means that it makes use of a connection to its data source only briefly. It connects to its data source while it is reading data to populate itself with rows and again while it is propagating changes back to its underlying data source. The rest of the time, a CachedRowSet object is disconnected, including while its data is being modified. Being disconnected makes a RowSet object much leaner and therefore much easier to pass to another component. For example, a disconnected RowSet object can be serialized and passed over the wire to a thin client such as a personal digital assistant (PDA).

    1.0 Creating a CachedRowSet Object

    The following line of code uses the default constructor for CachedRowSet supplied in the reference implementation (RI) to create a default CachedRowSet object.
         CachedRowSetImpl crs = new CachedRowSetImpl();
    This new CachedRowSet object will have its properties set to the default properties of a BaseRowSet object, and, in addition, it will have an RIOptimisticProvider object as its synchronization provider. RIOptimisticProvider, one of two SyncProvider implementations included in the RI, is the default provider that the SyncFactory singleton will supply when no synchronization provider is specified.

    A SyncProvider object provides a CachedRowSet object with a reader (a RowSetReader object) for reading data from a data source to populate itself with data. A reader can be implemented to read data from a ResultSet object or from a file with a tabular format. A SyncProvider object also provides a writer (a RowSetWriter object) for synchronizing any modifications to the CachedRowSet object's data made while it was disconnected with the data in the underlying data source.

    A writer can be implemented to exercise various degrees of care in checking for conflicts and in avoiding them. (A conflict occurs when a value in the data source has been changed after the rowset populated itself with that value.) The RIOptimisticProvider implementation assumes there will be few or no conflicts and therefore sets no locks. It updates the data source with values from the CachedRowSet object only if there are no conflicts. Other writers can be implemented so that they always write modified data to the data source, which can be accomplished either by not checking for conflicts or, on the other end of the spectrum, by setting locks sufficient to prevent data in the data source from being changed. Still other writer implementations can be somewhere in between.

    A CachedRowSet object may use any SyncProvider implementation that has been registered with the SyncFactory singleton. An application can find out which SyncProvider implementations have been registered by calling the following line of code.

          java.util.Enumeration providers = SyncFactory.getRegisteredProviders();

    There are two ways for a CachedRowSet object to specify which SyncProvider object it will use. Supplying the name of the implementation to the constructor
    The following line of code creates the CachedRowSet object crs2 that is initialized with default values except that its SyncProvider object is the one specified.

              CachedRowSetImpl crs2 = new CachedRowSetImpl(
                                 "com.fred.providers.HighAvailabilityProvider");
  • Setting the SyncProvider using the CachedRowSet method setSyncProvider
    The following line of code resets the SyncProvider object for crs, the CachedRowSet object created with the default constructor.
               crs.setSyncProvider("com.fred.providers.HighAvailabilityProvider");
    SyncFactory and SyncProvider for more details.

    2.0 Retrieving Data from a CachedRowSet Object

    Data is retrieved from a CachedRowSet object by using the getter methods inherited from the ResultSet interface. The following examples, in which crs is a CachedRowSet object, demonstrate how to iterate through the rows, retrieving the column values in each row. The first example uses the version of the getter methods that take a column number; the second example uses the version that takes a column name. Column numbers are generally used when the RowSet object's command is of the form SELECT * FROM TABLENAME; column names are most commonly used when the command specifies columns by name.
        while (crs.next()) {
        String name = crs.getString(1);
        int id = crs.getInt(2);
        Clob comment = crs.getClob(3);
        short dept = crs.getShort(4);
        System.out.println(name + "  " + id + "  " + comment + "  " + dept);
    }

        while (crs.next()) {
        String name = crs.getString("NAME");
        int id = crs.getInt("ID");
        Clob comment = crs.getClob("COM");
        short dept = crs.getShort("DEPT");
        System.out.println(name + "  " + id + "  " + comment + "  " + dept);
    }

    2.1 Retrieving RowSetMetaData

    An application can get information about the columns in a CachedRowSet object by calling ResultSetMetaData and RowSetMetaData methods on a RowSetMetaData object. The following code fragment, in which crs is a CachedRowSet object, illustrates the process. The first line creates a RowSetMetaData object with information about the columns in crs. The method getMetaData, inherited from the ResultSet interface, returns a ResultSetMetaData object, which is cast to a RowSetMetaData object before being assigned to the variable rsmd. The second line finds out how many columns jrs has, and the third line gets the JDBC type of values stored in the second column of jrs.
         RowSetMetaData rsmd = (RowSetMetaData)crs.getMetaData();
     int count = rsmd.getColumnCount();
     int type = rsmd.getColumnType(2);
    The RowSetMetaData interface differs from the ResultSetMetaData interface in two ways.
    • It includes setter methods: A RowSet object uses these methods internally when it is populated with data from a different ResultSet object.

    • It contains fewer getter methods: Some ResultSetMetaData methods to not apply to a RowSet object. For example, methods retrieving whether a column value is writable or read only do not apply because all of a RowSet object's columns will be writable or read only, depending on whether the rowset is updatable or not.
    NOTE: In order to return a RowSetMetaData object, implementations must override the getMetaData() method defined in java.sql.ResultSet and return a RowSetMetaData object.

    3.0 Updating a CachedRowSet Object

    Updating a CachedRowSet object is similar to updating a ResultSet object, but because the rowset is not connected to its data source while it is being updated, it must take an additional step to effect changes in its underlying data source. After calling the method updateRow or insertRow, a CachedRowSet object must also call the method acceptChanges to have updates written to the data source. The following example, in which the cursor is on a row in the CachedRowSet object crs, shows the code required to update two column values in the current row and also update the RowSet object's underlying data source.
         crs.updateShort(3, 58);
     crs.updateInt(4, 150000);
     crs.updateRow();
     crs.acceptChanges();

    The next example demonstrates moving to the insert row, building a new row on the insert row, inserting it into the rowset, and then calling the method acceptChanges to add the new row to the underlying data source. Note that as with the getter methods, the updater methods may take either a column index or a column name to designate the column being acted upon.

         crs.moveToInsertRow();
     crs.updateString("Name", "Shakespeare");
     crs.updateInt("ID", 10098347);
     crs.updateShort("Age", 58);
     crs.updateInt("Sal", 150000);
     crs.insertRow();
     crs.moveToCurrentRow();
     crs.acceptChanges();

    NOTE: Where the insertRow() method inserts the contents of a CachedRowSet object's insert row is implementation-defined. The reference implementation for the CachedRowSet interface inserts a new row immediately following the current row, but it could be implemented to insert new rows in any number of other places.

    Another thing to note about these examples is how they use the method acceptChanges. It is this method that propagates changes in a CachedRowSet object back to the underlying data source, calling on the RowSet object's writer internally to write changes to the data source. To do this, the writer has to incur the expense of establishing a connection with that data source. The preceding two code fragments call the method acceptChanges immediately after calling updateRow or insertRow. However, when there are multiple rows being changed, it is more efficient to call acceptChanges after all calls to updateRow and insertRow have been made. If acceptChanges is called only once, only one connection needs to be established.

    4.0 Updating the Underlying Data Source

    When the method acceptChanges is executed, the CachedRowSet object's writer, a RowSetWriterImpl object, is called behind the scenes to write the changes made to the rowset to the underlying data source. The writer is implemented to make a connection to the data source and write updates to it.

    A writer is made available through an implementation of the SyncProvider interface, as discussed in section 1, "Creating a CachedRowSet Object." The default reference implementation provider, RIOptimisticProvider, has its writer implemented to use an optimistic concurrency control mechanism. That is, it maintains no locks in the underlying database while the rowset is disconnected from the database and simply checks to see if there are any conflicts before writing data to the data source. If there are any conflicts, it does not write anything to the data source.

    The reader/writer facility provided by the SyncProvider class is pluggable, allowing for the customization of data retrieval and updating. If a different concurrency control mechanism is desired, a different implementation of SyncProvider can be plugged in using the method setSyncProvider.

    In order to use the optimistic concurrency control routine, the RIOptismisticProvider maintains both its current value and its original value (the value it had immediately preceding the current value). Note that if no changes have been made to the data in a RowSet object, its current values and its original values are the same, both being the values with which the RowSet object was initially populated. However, once any values in the RowSet object have been changed, the current values and the original values will be different, though at this stage, the original values are still the initial values. With any subsequent changes to data in a RowSet object, its original values and current values will still differ, but its original values will be the values that were previously the current values.

    Keeping track of original values allows the writer to compare the RowSet object's original value with the value in the database. If the values in the database differ from the RowSet object's original values, which means that the values in the database have been changed, there is a conflict. Whether a writer checks for conflicts, what degree of checking it does, and how it handles conflicts all depend on how it is implemented.

    5.0 Registering and Notifying Listeners

    Being JavaBeans components, all rowsets participate in the JavaBeans event model, inheriting methods for registering listeners and notifying them of changes from the BaseRowSet class. A listener for a CachedRowSet object is a component that wants to be notified whenever there is a change in the rowset. For example, if a CachedRowSet object contains the results of a query and those results are being displayed in, say, a table and a bar graph, the table and bar graph could be registered as listeners with the rowset so that they can update themselves to reflect changes. To become listeners, the table and bar graph classes must implement the RowSetListener interface. Then they can be added to the CachedRowSet object's list of listeners, as is illustrated in the following lines of code.
        crs.addRowSetListener(table);
    crs.addRowSetListener(barGraph);
    Each CachedRowSet method that moves the cursor or changes data also notifies registered listeners of the changes, so table and barGraph will be notified when there is a change in crs.

    6.0 Passing Data to Thin Clients

    One of the main reasons to use a CachedRowSet object is to pass data between different components of an application. Because it is serializable, a CachedRowSet object can be used, for example, to send the result of a query executed by an enterprise JavaBeans component running in a server environment over a network to a client running in a web browser.

    While a CachedRowSet object is disconnected, it can be much leaner than a ResultSet object with the same data. As a result, it can be especially suitable for sending data to a thin client such as a PDA, where it would be inappropriate to use a JDBC driver due to resource limitations or security considerations. Thus, a CachedRowSet object provides a means to "get rows in" without the need to implement the full JDBC API.

    7.0 Scrolling and Updating

    A second major use for CachedRowSet objects is to provide scrolling and updating for ResultSet objects that do not provide these capabilities themselves. In other words, a CachedRowSet object can be used to augment the capabilities of a JDBC technology-enabled driver (hereafter called a "JDBC driver") when the DBMS does not provide full support for scrolling and updating. To achieve the effect of making a non-scrollble and read-only ResultSet object scrollable and updatable, a programmer simply needs to create a CachedRowSet object populated with that ResultSet object's data. This is demonstrated in the following code fragment, where stmt is a Statement object.
        ResultSet rs = stmt.executeQuery("SELECT * FROM EMPLOYEES");
    CachedRowSetImpl crs = new CachedRowSetImpl();
    crs.populate(rs);

    The object crs now contains the data from the table EMPLOYEES, just as the object rs does. The difference is that the cursor for crs can be moved forward, backward, or to a particular row even if the cursor for rs can move only forward. In addition, crs is updatable even if rs is not because by default, a CachedRowSet object is both scrollable and updatable.

    In summary, a CachedRowSet object can be thought of as simply a disconnected set of rows that are being cached outside of a data source. Being thin and serializable, it can easily be sent across a wire, and it is well suited to sending data to a thin client. However, a CachedRowSet object does have a limitation: It is limited in size by the amount of data it can store in memory at one time.

    8.0 Getting Universal Data Access

    Another advantage of the CachedRowSet class is that it makes it possible to retrieve and store data from sources other than a relational database. The reader for a rowset can be implemented to read and populate its rowset with data from any tabular data source, including a spreadsheet or flat file. Because both a CachedRowSet object and its metadata can be created from scratch, a component that acts as a factory for rowsets can use this capability to create a rowset containing data from non-SQL data sources. Nevertheless, it is expected that most of the time, CachedRowSet objects will contain data that was fetched from an SQL database using the JDBC API.

    9.0 Setting Properties

    All rowsets maintain a set of properties, which will usually be set using a tool. The number and kinds of properties a rowset has will vary, depending on what the rowset does and how it gets its data. For example, rowsets that get their data from a ResultSet object need to set the properties that are required for making a database connection. If a rowset uses the DriverManager facility to make a connection, it needs to set a property for the JDBC URL that identifies the appropriate driver, and it needs to set the properties that give the user name and password. If, on the other hand, the rowset uses a DataSource object to make the connection, which is the preferred method, it does not need to set the property for the JDBC URL. Instead, it needs to set properties for the logical name of the data source, for the user name, and for the password.

    NOTE: In order to use a DataSource object for making a connection, the DataSource object must have been registered with a naming service that uses the Java Naming and Directory InterfaceTM (JNDI) API. This registration is usually done by a person acting in the capacity of a system administrator.

    In order to be able to populate itself with data from a database, a rowset needs to set a command property. This property is a query that is a PreparedStatement object, which allows the query to have parameter placeholders that are set at run time, as opposed to design time. To set these placeholder parameters with values, a rowset provides setter methods for setting values of each data type, similar to the setter methods provided by the PreparedStatement interface.

    The following code fragment illustrates how the CachedRowSet object crs might have its command property set. Note that if a tool is used to set properties, this is the code that the tool would use.

        crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS " +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");

    The values that will be used to set the command's placeholder parameters are contained in the RowSet object's params field, which is a Vector object. The CachedRowSet class provides a set of setter methods for setting the elements in its params field. The following code fragment demonstrates setting the two parameters in the query from the previous example.

        crs.setInt(1, 5000);
    crs.setString(2, "West");

    The params field now contains two elements, each of which is an array two elements long. The first element is the parameter number; the second is the value to be set. In this case, the first element of params is 1, 5000, and the second element is 2, "West". When an application calls the method execute, it will in turn call on this RowSet object's reader, which will in turn invoke its readData method. As part of its implementation, readData will get the values in params and use them to set the command's placeholder parameters. The following code fragment gives an idea of how the reader does this, after obtaining the Connection object con.

        PreparedStatement pstmt = con.prepareStatement(crs.getCommand());
    reader.decodeParams();
    // decodeParams figures out which setter methods to use and does something
    // like the following:
    //    for (i = 0; i < params.length; i++) {
    //        pstmt.setObject(i + 1, params[i]);
    //    }

    At this point, the command for crs is the query "SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS WHERE CREDIT_LIMIT > 5000 AND REGION = "West". After the readData method executes this command with the following line of code, it will have the data from rs with which to populate crs.

         ResultSet rs = pstmt.executeQuery();

    The preceding code fragments give an idea of what goes on behind the scenes; they would not appear in an application, which would not invoke methods like readData and decodeParams. In contrast, the following code fragment shows what an application might do. It sets the rowset's command, sets the command's parameters, and executes the command. Simply by calling the execute method, crs populates itself with the requested data from the table CUSTOMERS.

        crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");
    crs.setInt(1, 5000);
    crs.setString(2, "West");
    crs.execute();

    10.0 Paging Data

    Because a CachedRowSet object stores data in memory, the amount of data that it can contain at any one time is determined by the amount of memory available. To get around this limitation, a CachedRowSet object can retrieve data from a ResultSet object in chunks of data, called pages. To take advantage of this mechanism, an application sets the number of rows to be included in a page using the method setPageSize. In other words, if the page size is set to five, a chunk of five rows of data will be fetched from the data source at one time. An application can also optionally set the maximum number of rows that may be fetched at one time. If the maximum number of rows is set to zero, or no maximum number of rows is set, there is no limit to the number of rows that may be fetched at a time.

    After properties have been set, the CachedRowSet object must be populated with data using either the method populate or the method execute. The following lines of code demonstrate using the method populate. Note that this version of the method takes two parameters, a ResultSet handle and the row in the ResultSet object from which to start retrieving rows.

         CachedRowSet crs = new CachedRowSetImpl();
     crs.setMaxRows(20);
     crs.setPageSize(4);
     crs.populate(rsHandle, 10);
    When this code runs, crs will be populated with four rows from rsHandle starting with the tenth row.

    The next code fragment shows populating a CachedRowSet object using the method execute, which may or may not take a Connection object as a parameter. This code passes execute the Connection object conHandle.

    Note that there are two differences between the following code fragment and the previous one. First, the method setMaxRows is not called, so there is no limit set for the number of rows that crs may contain. (Remember that crs always has the overriding limit of how much data it can store in memory.) The second difference is that the you cannot pass the method execute the number of the row in the ResultSet object from which to start retrieving rows. This method always starts with the first row.

         CachedRowSet crs = new CachedRowSetImpl();
     crs.setPageSize(5);
     crs.execute(conHandle);
    After this code has run, crs will contain five rows of data from the ResultSet object produced by the command for crs. The writer for crs will use conHandle to connect to the data source and execute the command for crs. An application is then able to operate on the data in crs in the same way that it would operate on data in any other CachedRowSet object.

    To access the next page (chunk of data), an application calls the method nextPage. This method creates a new CachedRowSet object and fills it with the next page of data. For example, assume that the CachedRowSet object's command returns a ResultSet object rs with 1000 rows of data. If the page size has been set to 100, the first call to the method nextPage will create a CachedRowSet object containing the first 100 rows of rs. After doing what it needs to do with the data in these first 100 rows, the application can again call the method nextPage to create another CachedRowSet object with the second 100 rows from rs. The data from the first CachedRowSet object will no longer be in memory because it is replaced with the data from the second CachedRowSet object. After the tenth call to the method nextPage, the tenth CachedRowSet object will contain the last 100 rows of data from rs, which are stored in memory. At any given time, the data from only one CachedRowSet object is stored in memory.

    The method nextPage returns true as long as the current page is not the last page of rows and false when there are no more pages. It can therefore be used in a while loop to retrieve all of the pages, as is demonstrated in the following lines of code.

         CachedRowSet crs = CachedRowSetImpl();
     crs.setPageSize(100);
     crs.execute(conHandle);

     while(crs.nextPage()) {
         while(crs.next()) {
             . . . // operate on chunks (of 100 rows each) in crs,
                   // row by row
         }
     }
    After this code fragment has been run, the application will have traversed all 1000 rows, but it will have had no more than 100 rows in memory at a time.

    The CachedRowSet interface also defines the method previousPage. Just as the method nextPage is analogous to the ResultSet method 下一个, the method previousPage is analogous to the ResultSet method previous. Similar to the method nextPage, previousPage creates a CachedRowSet object containing the number of rows set as the page size. So, for instance, the method previousPage could be used in a while loop at the end of the preceding code fragment to navigate back through the pages from the last page to the first page. The method previousPage is also similar to nextPage in that it can be used in a while loop, except that it returns true as long as there is another page preceding it and false when there are no more pages ahead of it.

    By positioning the cursor after the last row for each page, as is done in the following code fragment, the method previous navigates from the last row to the first row in each page. The code could also have left the cursor before the first row on each page and then used the method 下一个 in a while loop to navigate each page from the first row to the last row.

    The following code fragment assumes a continuation from the previous code fragment, meaning that the cursor for the tenth CachedRowSet object is on the last row. The code moves the cursor to after the last row so that the first call to the method previous will put the cursor back on the last row. After going through all of the rows in the last page (the CachedRowSet object crs), the code then enters the while loop to get to the ninth page, go through the rows backwards, go to the eighth page, go through the rows backwards, and so on to the first row of the first page.

         crs.afterLast();
     while(crs.previous())  {
         . . . // navigate through the rows, last to first
     {
     while(crs.previousPage())  {
         crs.afterLast();
         while(crs.previous())  {
             . . . // go from the last row to the first row of each page
         }
     }

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static boolean COMMIT_ON_ACCEPT_CHANGES
      Deprecated.
      Because this field is final (it is part of an interface), its value cannot be changed.

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void acceptChanges()
      Propagates row update, insert and delete changes made to this CachedRowSet object to the underlying data source.
      void acceptChanges(Connection con)
      Propagates all row update, insert and delete changes to the data source backing this CachedRowSet object using the specified Connection object to establish a connection to the data source.
      boolean columnUpdated(int idx)
      Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
      boolean columnUpdated(String columnName)
      Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
      void commit()
      Each CachedRowSet object's SyncProvider contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
      CachedRowSet createCopy()
      Creates a RowSet object that is a deep copy of the data in this CachedRowSet object.
      CachedRowSet createCopyNoConstraints()
      Creates a CachedRowSet object that is a deep copy of this CachedRowSet object's data but is independent of it.
      CachedRowSet createCopySchema()
      Creates a CachedRowSet object that is an empty copy of this CachedRowSet object.
      RowSet createShared()
      Returns a new RowSet object backed by the same data as that of this CachedRowSet object.
      void execute(Connection conn)
      Populates this CachedRowSet object with data, using the given connection to produce the result set from which the data will be read.
      int[] getKeyColumns()
      Returns an array containing one or more column numbers indicating the columns that form a key that uniquely identifies a row in this CachedRowSet object.
      ResultSet getOriginal()
      Returns a ResultSet object containing the original value of this CachedRowSet object.
      ResultSet getOriginalRow()
      Returns a ResultSet object containing the original value for the current row only of this CachedRowSet object.
      int getPageSize()
      Returns the page-size for the CachedRowSet object
      RowSetWarning getRowSetWarnings()
      Retrieves the first warning reported by calls on this RowSet object.
      boolean getShowDeleted()
      Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.
      SyncProvider getSyncProvider()
      Retrieves the SyncProvider implementation for this CachedRowSet object.
      String getTableName()
      Returns an identifier for the object (table) that was used to create this CachedRowSet object.
      boolean nextPage()
      Increments the current page of the CachedRowSet.
      void populate(ResultSet data)
      Populates this CachedRowSet object with data from the given ResultSet object.
      void populate(ResultSet rs, int startRow)
      Populates this CachedRowSet object with data from the given ResultSet object.
      boolean previousPage()
      Decrements the current page of the CachedRowSet.
      void release()
      Releases the current contents of this CachedRowSet object and sends a rowSetChanged event to all registered listeners.
      void restoreOriginal()
      Restores this CachedRowSet object to its original value, that is, its value before the last set of changes.
      void rollback()
      Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.
      void rollback(Savepoint s)
      Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.
      void rowSetPopulated(RowSetEvent event, int numRows)
      Notifies registered listeners that a RowSet object in the given RowSetEvent object has populated a number of additional rows.
      void setKeyColumns(int[] keys)
      Sets this CachedRowSet object's keyCols field with the given array of column numbers, which forms a key for uniquely identifying a row in this CachedRowSet object.
      void setMetaData(RowSetMetaData md)
      Sets the metadata for this CachedRowSet object with the given RowSetMetaData object.
      void setOriginalRow()
      Sets the current row in this CachedRowSet object as the original row.
      void setPageSize(int size)
      Sets the CachedRowSet object's page-size.
      void setShowDeleted(boolean b)
      Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows.
      void setSyncProvider(String provider)
      Sets the SyncProvider objec for this CachedRowSet object to the one specified.
      void setTableName(String tabName)
      Sets the identifier for the table from which this CachedRowSet object was derived to the given table name.
      int size()
      Returns the number of rows in this CachedRowSet object.
      Collection<?> toCollection()
      Converts this CachedRowSet object to a Collection object that contains all of this CachedRowSet object's data.
      Collection<?> toCollection(int column)
      Converts the designated column in this CachedRowSet object to a Collection object.
      Collection<?> toCollection(String column)
      Converts the designated column in this CachedRowSet object to a Collection object.
      void undoDelete()
      Cancels the deletion of the current row and notifies listeners that a row has changed.
      void undoInsert()
      Immediately removes the current row from this CachedRowSet object if the row has been inserted, and also notifies listeners that a row has changed.
      void undoUpdate()
      Immediately reverses the last update operation if the row has been modified.

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

      • 方法 - 继承于接口 javax.sql.rowset.Joinable

        getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    • 字段详细信息

      • COMMIT_ON_ACCEPT_CHANGES

        @Deprecated
static final boolean COMMIT_ON_ACCEPT_CHANGES
        Deprecated. Because this field is final (it is part of an interface), its value cannot be changed.
        Causes the CachedRowSet object's SyncProvider to commit the changes when acceptChanges() is called. If set to false, the changes will not be committed until one of the CachedRowSet interface transaction methods is called.
        另请参见：
        commit(), rollback(), Constant Field Values

    • 方法详细信息

      • populate

        void populate(ResultSet data)
              throws SQLException
        Populates this CachedRowSet object with data from the given ResultSet object.

        This method can be used as an alternative to the execute method when an application has a connection to an open ResultSet object. Using the method populate can be more efficient than using the version of the execute method that takes no parameters because it does not open a new connection and re-execute this CachedRowSet object's command. Using the populate method is more a matter of convenience when compared to using the version of execute that takes a ResultSet object.

        参数：
        data - the ResultSet object containing the data to be read into this CachedRowSet object
        抛出：
        SQLException - if a null ResultSet object is supplied or this CachedRowSet object cannot retrieve the associated ResultSetMetaData object
        另请参见：
        execute(java.sql.Connection), ResultSet, ResultSetMetaData

      • execute

        void execute(Connection conn)
             throws SQLException
        Populates this CachedRowSet object with data, using the given connection to produce the result set from which the data will be read. This method should close any database connections that it creates to ensure that this CachedRowSet object is disconnected except when it is reading data from its data source or writing data to its data source.

        The reader for this CachedRowSet object will use conn to establish a connection to the data source so that it can execute the rowset's command and read data from the the resulting ResultSet object into this CachedRowSet object. This method also closes conn after it has populated this CachedRowSet object.

        If this method is called when an implementation has already been populated, the contents and the metadata are (re)set. Also, if this method is called before the method acceptChanges has been called to commit outstanding updates, those updates are lost.

        参数：
        conn - a standard JDBC Connection object with valid properties
        抛出：
        SQLException - if an invalid Connection object is supplied or an error occurs in establishing the connection to the data source
        另请参见：
        populate(java.sql.ResultSet), Connection

      • acceptChanges

        void acceptChanges()
                   throws SyncProviderException
        Propagates row update, insert and delete changes made to this CachedRowSet object to the underlying data source.

        This method calls on this CachedRowSet object's writer to do the work behind the scenes. Standard CachedRowSet implementations should use the SyncFactory singleton to obtain a SyncProvider instance providing a RowSetWriter object (writer). The writer will attempt to propagate changes made in this CachedRowSet object back to the data source.

        When the method acceptChanges executes successfully, in addition to writing changes to the data source, it makes the values in the current row be the values in the original row.

        Depending on the synchronization level of the SyncProvider implementation being used, the writer will compare the original values with those in the data source to check for conflicts. When there is a conflict, the RIOptimisticProvider implementation, for example, throws a SyncProviderException and does not write anything to the data source.

        An application may choose to catch the SyncProviderException object and retrieve the SyncResolver object it contains. The SyncResolver object lists the conflicts row by row and sets a lock on the data source to avoid further conflicts while the current conflicts are being resolved. Further, for each conflict, it provides methods for examining the conflict and setting the value that should be persisted in the data source. After all conflicts have been resolved, an application must call the acceptChanges method again to write resolved values to the data source. If all of the values in the data source are already the values to be persisted, the method acceptChanges does nothing.

        Some provider implementations may use locks to ensure that there are no conflicts. In such cases, it is guaranteed that the writer will succeed in writing changes to the data source when the method acceptChanges is called. This method may be called immediately after the methods updateRow, insertRow, or deleteRow have been called, but it is more efficient to call it only once after all changes have been made so that only one connection needs to be established.

        Note: The acceptChanges() method will determine if the COMMIT_ON_ACCEPT_CHANGES is set to true or not. If it is set to true, all updates in the synchronization are committed to the data source. Otherwise, the application must explicity call the commit() or rollback() methods as appropriate.

        抛出：
        SQLException - if the cursor is on the insert row
        SyncProviderException - if the underlying synchronization provider's writer fails to write the updates back to the data source
        另请参见：
        acceptChanges(java.sql.Connection), RowSetWriter, SyncFactory, SyncProvider, SyncProviderException, SyncResolver

      • acceptChanges

        void acceptChanges(Connection con)
                   throws SyncProviderException
        Propagates all row update, insert and delete changes to the data source backing this CachedRowSet object using the specified Connection object to establish a connection to the data source.

        The other version of the acceptChanges method is not passed a connection because it uses the Connection object already defined within the RowSet object, which is the connection used for populating it initially.

        This form of the method acceptChanges is similar to the form that takes no arguments; however, unlike the other form, this form can be used only when the underlying data source is a JDBC data source. The updated Connection properties must be used by the SyncProvider to reset the RowSetWriter configuration to ensure that the contents of the CachedRowSet object are synchronized correctly.

        When the method acceptChanges executes successfully, in addition to writing changes to the data source, it makes the values in the current row be the values in the original row.

        Depending on the synchronization level of the SyncProvider implementation being used, the writer will compare the original values with those in the data source to check for conflicts. When there is a conflict, the RIOptimisticProvider implementation, for example, throws a SyncProviderException and does not write anything to the data source.

        An application may choose to catch the SyncProviderException object and retrieve the SyncResolver object it contains. The SyncResolver object lists the conflicts row by row and sets a lock on the data source to avoid further conflicts while the current conflicts are being resolved. Further, for each conflict, it provides methods for examining the conflict and setting the value that should be persisted in the data source. After all conflicts have been resolved, an application must call the acceptChanges method again to write resolved values to the data source. If all of the values in the data source are already the values to be persisted, the method acceptChanges does nothing.

        Some provider implementations may use locks to ensure that there are no conflicts. In such cases, it is guaranteed that the writer will succeed in writing changes to the data source when the method acceptChanges is called. This method may be called immediately after the methods updateRow, insertRow, or deleteRow have been called, but it is more efficient to call it only once after all changes have been made so that only one connection needs to be established.

        Note: The acceptChanges() method will determine if the COMMIT_ON_ACCEPT_CHANGES is set to true or not. If it is set to true, all updates in the synchronization are committed to the data source. Otherwise, the application must explicity call the commit or rollback methods as appropriate.

        参数：
        con - a standard JDBC Connection object
        抛出：
        SQLException - if the cursor is on the insert row
        SyncProviderException - if the underlying synchronization provider's writer fails to write the updates back to the data source
        另请参见：
        acceptChanges(), RowSetWriter, SyncFactory, SyncProvider, SyncProviderException, SyncResolver

      • restoreOriginal

        void restoreOriginal()
                     throws SQLException
        Restores this CachedRowSet object to its original value, that is, its value before the last set of changes. If there have been no changes to the rowset or only one set of changes, the original value is the value with which this CachedRowSet object was populated; otherwise, the original value is the value it had immediately before its current value.

        When this method is called, a CachedRowSet implementation must ensure that all updates, inserts, and deletes to the current rowset instance are replaced by the previous values. In addition, the cursor should be reset to the first row and a rowSetChanged event should be fired to notify all registered listeners.

        抛出：
        SQLException - if an error occurs rolling back the current value of this CachedRowSet object to its previous value
        另请参见：
        RowSetListener.rowSetChanged(javax.sql.RowSetEvent)

      • release

        void release()
             throws SQLException
        Releases the current contents of this CachedRowSet object and sends a rowSetChanged event to all registered listeners. Any outstanding updates are discarded and the rowset contains no rows after this method is called. There are no interactions with the underlying data source, and any rowset content, metadata, and content updates should be non-recoverable.

        This CachedRowSet object should lock until its contents and associated updates are fully cleared, thus preventing 'dirty' reads by other components that hold a reference to this RowSet object. In addition, the contents cannot be released until all all components reading this CachedRowSet object have completed their reads. This CachedRowSet object should be returned to normal behavior after firing the rowSetChanged event.

        The metadata, including JDBC properties and Synchronization SPI properties, are maintained for future use. It is important that properties such as the command property be relevant to the originating data source from which this CachedRowSet object was originally established.

        This method empties a rowset, as opposed to the close method, which marks the entire rowset as recoverable to allow the garbage collector the rowset's Java VM resources.

        抛出：
        SQLException - if an error occurs flushing the contents of this CachedRowSet object
        另请参见：
        RowSetListener.rowSetChanged(javax.sql.RowSetEvent), ResultSet.close()

      • undoDelete

        void undoDelete()
                throws SQLException
        Cancels the deletion of the current row and notifies listeners that a row has changed. After this method is called, the current row is no longer marked for deletion. This method can be called at any time during the lifetime of the rowset.

        In addition, multiple cancellations of row deletions can be made by adjusting the position of the cursor using any of the cursor position control methods such as:

        • CachedRowSet.absolute
        • CachedRowSet.first
        • CachedRowSet.last
        抛出：
        SQLException - if (1) the current row has not been deleted or (2) the cursor is on the insert row, before the first row, or after the last row
        另请参见：
        undoInsert(), ResultSet.cancelRowUpdates()

      • undoInsert

        void undoInsert()
                throws SQLException
        Immediately removes the current row from this CachedRowSet object if the row has been inserted, and also notifies listeners that a row has changed. This method can be called at any time during the lifetime of a rowset and assuming the current row is within the exception limitations (see below), it cancels the row insertion of the current row.

        In addition, multiple cancellations of row insertions can be made by adjusting the position of the cursor using any of the cursor position control methods such as:

        • CachedRowSet.absolute
        • CachedRowSet.first
        • CachedRowSet.last
        抛出：
        SQLException - if (1) the current row has not been inserted or (2) the cursor is before the first row, after the last row, or on the insert row
        另请参见：
        undoDelete(), ResultSet.cancelRowUpdates()

      • undoUpdate

        void undoUpdate()
                throws SQLException
        Immediately reverses the last update operation if the row has been modified. This method can be called to reverse updates on all columns until all updates in a row have been rolled back to their state just prior to the last synchronization (acceptChanges) or population. This method may also be called while performing updates to the insert row.

        undoUpdate may be called at any time during the lifetime of a rowset; however, after a synchronization has occurred, this method has no effect until further modification to the rowset data has occurred.

        抛出：
        SQLException - if the cursor is before the first row or after the last row in in this CachedRowSet object
        另请参见：
        undoDelete(),
undoInsert(),
ResultSet.cancelRowUpdates()

      • columnUpdated

        boolean columnUpdated(int idx)
                      throws SQLException
        Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
        参数：
        idx - an int identifying the column to be checked for updates
        返回：
        true if the designated column has been visibly updated; false otherwise
        抛出：
        SQLException - if the cursor is on the insert row, before the first row, or after the last row
        另请参见：
        DatabaseMetaData.updatesAreDetected(int)

      • columnUpdated

        boolean columnUpdated(String columnName)
                      throws SQLException
        Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
        参数：
        columnName - a String object giving the name of the column to be checked for updates
        返回：
        true if the column has been visibly updated; false otherwise
        抛出：
        SQLException - if the cursor is on the insert row, before the first row, or after the last row
        另请参见：
        DatabaseMetaData.updatesAreDetected(int)

      • toCollection

        Collection<?> toCollection()
                           throws SQLException
        Converts this CachedRowSet object to a Collection object that contains all of this CachedRowSet object's data. Implementations have some latitude in how they can represent this Collection object because of the abstract nature of the Collection framework. Each row must be fully represented in either a general purpose Collection implementation or a specialized Collection implementation, such as a TreeMap object or a Vector object. An SQL NULL column value must be represented as a null in the Java programming language.

        The standard reference implementation for the CachedRowSet interface uses a TreeMap object for the rowset, with the values in each row being contained in Vector objects. It is expected that most implementations will do the same.

        The TreeMap type of collection guarantees that the map will be in ascending key order, sorted according to the natural order for the key's class. Each key references a Vector object that corresponds to one row of a RowSet object. Therefore, the size of each Vector object must be exactly equal to the number of columns in the RowSet object. The key used by the TreeMap collection is determined by the implementation, which may choose to leverage a set key that is available within the internal RowSet tabular structure by virtue of a key already set either on the RowSet object itself or on the underlying SQL data.

        返回：
        a Collection object that contains the values in each row in this CachedRowSet object
        抛出：
        SQLException - if an error occurs generating the collection
        另请参见：
        toCollection(int), toCollection(String)

      • toCollection

        Collection<?> toCollection(int column)
                           throws SQLException
        Converts the designated column in this CachedRowSet object to a Collection object. Implementations have some latitude in how they can represent this Collection object because of the abstract nature of the Collection framework. Each column value should be fully represented in either a general purpose Collection implementation or a specialized Collection implementation, such as a Vector object. An SQL NULL column value must be represented as a null in the Java programming language.

        The standard reference implementation uses a Vector object to contain the column values, and it is expected that most implementations will do the same. If a Vector object is used, it size must be exactly equal to the number of rows in this CachedRowSet object.

        参数：
        column - an int indicating the column whose values are to be represented in a Collection object
        返回：
        a Collection object that contains the values stored in the specified column of this CachedRowSet object
        抛出：
        SQLException - if an error occurs generating the collection or an invalid column id is provided
        另请参见：
        toCollection(), toCollection(String)

      • toCollection

        Collection<?> toCollection(String column)
                           throws SQLException
        Converts the designated column in this CachedRowSet object to a Collection object. Implementations have some latitude in how they can represent this Collection object because of the abstract nature of the Collection framework. Each column value should be fully represented in either a general purpose Collection implementation or a specialized Collection implementation, such as a Vector object. An SQL NULL column value must be represented as a null in the Java programming language.

        The standard reference implementation uses a Vector object to contain the column values, and it is expected that most implementations will do the same. If a Vector object is used, it size must be exactly equal to the number of rows in this CachedRowSet object.

        参数：
        column - a String object giving the name of the column whose values are to be represented in a collection
        返回：
        a Collection object that contains the values stored in the specified column of this CachedRowSet object
        抛出：
        SQLException - if an error occurs generating the collection or an invalid column id is provided
        另请参见：
        toCollection(), toCollection(int)

      • getSyncProvider

        SyncProvider getSyncProvider()
                             throws SQLException
        Retrieves the SyncProvider implementation for this CachedRowSet object. Internally, this method is used by a rowset to trigger read or write actions between the rowset and the data source. For example, a rowset may need to get a handle on the the rowset reader (RowSetReader object) from the SyncProvider to allow the rowset to be populated.
             RowSetReader rowsetReader = null;
     SyncProvider provider =
         SyncFactory.getInstance("javax.sql.rowset.provider.RIOptimisticProvider");
         if (provider instanceof RIOptimisticProvider) {
             rowsetReader = provider.getRowSetReader();
         }
        Assuming rowsetReader is a private, accessible field within the rowset implementation, when an application calls the execute method, it in turn calls on the reader's readData method to populate the RowSet object.
             rowsetReader.readData((RowSetInternal)this);

        In addition, an application can use the SyncProvider object returned by this method to call methods that return information about the SyncProvider object, including information about the vendor, version, provider identification, synchronization grade, and locks it currently has set.

        返回：
        the SyncProvider object that was set when the rowset was instantiated, or if none was was set, the default provider
        抛出：
        SQLException - if an error occurs while returning the SyncProvider object
        另请参见：
        setSyncProvider(java.lang.String)

      • setSyncProvider

        void setSyncProvider(String provider)
                     throws SQLException
        Sets the SyncProvider objec for this CachedRowSet object to the one specified. This method allows the SyncProvider object to be reset.

        A CachedRowSet implementation should always be instantiated with an available SyncProvider mechanism, but there are cases where resetting the SyncProvider object is desirable or necessary. For example, an application might want to use the default SyncProvider object for a time and then choose to use a provider that has more recently become available and better fits its needs.

        Resetting the SyncProvider object causes the RowSet object to request a new SyncProvider implementation from the SyncFactory. This has the effect of resetting all previous connections and relationships with the originating data source and can potentially drastically change the synchronization behavior of a disconnected rowset.

        参数：
        provider - a String object giving the fully qualified class name of a SyncProvider implementation
        抛出：
        SQLException - if an error occurs while attempting to reset the SyncProvider implementation
        另请参见：
        getSyncProvider()

      • size

        int size()
        Returns the number of rows in this CachedRowSet object.
        返回：
        number of rows in the rowset

      • setMetaData

        void setMetaData(RowSetMetaData md)
                 throws SQLException
        Sets the metadata for this CachedRowSet object with the given RowSetMetaData object. When a RowSetReader object is reading the contents of a rowset, it creates a RowSetMetaData object and initializes it using the methods in the RowSetMetaData implementation. The reference implementation uses the RowSetMetaDataImpl class. When the reader has completed reading the rowset contents, this method is called internally to pass the RowSetMetaData object to the rowset.
        参数：
        md - a RowSetMetaData object containing metadata about the columns in this CachedRowSet object
        抛出：
        SQLException - if invalid metadata is supplied to the rowset

      • getOriginal

        ResultSet getOriginal()
                      throws SQLException
        Returns a ResultSet object containing the original value of this CachedRowSet object.

        The cursor for the ResultSet object should be positioned before the first row. In addition, the returned ResultSet object should have the following properties:

        • ResultSet.TYPE_SCROLL_INSENSITIVE
        • ResultSet.CONCUR_UPDATABLE

        The original value for a RowSet object is the value it had before the last synchronization with the underlying data source. If there have been no synchronizations, the original value will be the value with which the RowSet object was populated. This method is called internally when an aplication calls the method acceptChanges and the SyncProvider object has been implemented to check for conflicts. If this is the case, the writer compares the original value with the value currently in the data source to check for conflicts.

        返回：
        a ResultSet object that contains the original value for this CachedRowSet object
        抛出：
        SQLException - if an error occurs producing the ResultSet object

      • getOriginalRow

        ResultSet getOriginalRow()
                         throws SQLException
        Returns a ResultSet object containing the original value for the current row only of this CachedRowSet object.

        The cursor for the ResultSet object should be positioned before the first row. In addition, the returned ResultSet object should have the following properties:

        • ResultSet.TYPE_SCROLL_INSENSITIVE
        • ResultSet.CONCUR_UPDATABLE
        返回：
        the original result set of the row
        抛出：
        SQLException - if there is no current row
        另请参见：
        setOriginalRow()

      • setOriginalRow

        void setOriginalRow()
                    throws SQLException
        Sets the current row in this CachedRowSet object as the original row.

        This method is called internally after the any modified values in the current row have been synchronized with the data source. The current row must be tagged as no longer inserted, deleted or updated.

        A call to setOriginalRow is irreversible.

        抛出：
        SQLException - if there is no current row or an error is encountered resetting the contents of the original row
        另请参见：
        getOriginalRow()

      • getTableName

        String getTableName()
                    throws SQLException
        Returns an identifier for the object (table) that was used to create this CachedRowSet object. This name may be set on multiple occasions, and the specification imposes no limits on how many times this may occur or whether standard implementations should keep track of previous table names.
        返回：
        a String object giving the name of the table that is the source of data for this CachedRowSet object or null if no name has been set for the table
        抛出：
        SQLException - if an error is encountered returning the table name
        另请参见：
        ResultSetMetaData.getTableName(int)

      • setTableName

        void setTableName(String tabName)
                  throws SQLException
        Sets the identifier for the table from which this CachedRowSet object was derived to the given table name. The writer uses this name to determine which table to use when comparing the values in the data source with the CachedRowSet object's values during a synchronization attempt. The table identifier also indicates where modified values from this CachedRowSet object should be written.

        The implementation of this CachedRowSet object may obtain the the name internally from the RowSetMetaDataImpl object.

        参数：
        tabName - a String object identifying the table from which this CachedRowSet object was derived; cannot be null but may be an empty string
        抛出：
        SQLException - if an error is encountered naming the table or tabName is null
        另请参见：
        RowSetMetaData.setTableName(int, java.lang.String), RowSetWriter, SyncProvider

      • getKeyColumns

        int[] getKeyColumns()
                    throws SQLException
        Returns an array containing one or more column numbers indicating the columns that form a key that uniquely identifies a row in this CachedRowSet object.
        返回：
        an array containing the column number or numbers that indicate which columns constitute a primary key for a row in this CachedRowSet object. This array should be empty if no columns are representative of a primary key.
        抛出：
        SQLException - if this CachedRowSet object is empty
        另请参见：
        setKeyColumns(int[]), Joinable.getMatchColumnIndexes(), Joinable.getMatchColumnNames()

      • setKeyColumns

        void setKeyColumns(int[] keys)
                   throws SQLException
        Sets this CachedRowSet object's keyCols field with the given array of column numbers, which forms a key for uniquely identifying a row in this CachedRowSet object.

        If a CachedRowSet object becomes part of a JoinRowSet object, the keys defined by this method and the resulting constraints are maintained if the columns designated as key columns also become match columns.

        参数：
        keys - an array of int indicating the columns that form a primary key for this CachedRowSet object; every element in the array must be greater than 0 and less than or equal to the number of columns in this rowset
        抛出：
        SQLException - if any of the numbers in the given array are not valid for this rowset
        另请参见：
        getKeyColumns(),
Joinable.setMatchColumn(String),
Joinable.setMatchColumn(int)

      • createShared

        RowSet createShared()
                    throws SQLException
        Returns a new RowSet object backed by the same data as that of this CachedRowSet object. In effect, both CachedRowSet objects have a cursor over the same data. As a result, any changes made by a duplicate are visible to the original and to any other duplicates, just as a change made by the original is visible to all of its duplicates. If a duplicate calls a method that changes the underlying data, the method it calls notifies all registered listeners just as it would when it is called by the original CachedRowSet object.

        In addition, any RowSet object created by this method will have the same properties as this CachedRowSet object. For example, if this CachedRowSet object is read-only, all of its duplicates will also be read-only. If it is changed to be updatable, the duplicates also become updatable.

        NOTE: If multiple threads access RowSet objects created from the createShared() method, the following behavior is specified to preserve shared data integrity: reads and writes of all shared RowSet objects should be made serially between each object and the single underlying tabular structure.

        返回：
        a new shared RowSet object that has the same properties as this CachedRowSet object and that has a cursor over the same data
        抛出：
        SQLException - if an error occurs or cloning is not supported in the underlying platform
        另请参见：
        RowSetEvent, RowSetListener

      • createCopy

        CachedRowSet createCopy()
                        throws SQLException
        Creates a RowSet object that is a deep copy of the data in this CachedRowSet object. In contrast to the RowSet object generated from a createShared call, updates made to the copy of the original RowSet object must not be visible to the original RowSet object. Also, any event listeners that are registered with the original RowSet must not have scope over the new RowSet copies. In addition, any constraint restrictions established must be maintained.
        返回：
        a new RowSet object that is a deep copy of this CachedRowSet object and is completely independent of this CachedRowSet object
        抛出：
        SQLException - if an error occurs in generating the copy of the of this CachedRowSet object
        另请参见：
        createShared(),
createCopySchema(),
createCopyNoConstraints(),
RowSetEvent,
RowSetListener

      • createCopySchema

        CachedRowSet createCopySchema()
                              throws SQLException
        Creates a CachedRowSet object that is an empty copy of this CachedRowSet object. The copy must not contain any contents but only represent the table structure of the original CachedRowSet object. In addition, primary or foreign key constraints set in the originating CachedRowSet object must be equally enforced in the new empty CachedRowSet object. In contrast to the RowSet object generated from a createShared method call, updates made to a copy of this CachedRowSet object with the createCopySchema method must not be visible to it.

        Applications can form a WebRowSet object from the CachedRowSet object returned by this method in order to export the RowSet schema definition to XML for future use.

        抛出：
        SQLException - if an error occurs in cloning the structure of this CachedRowSet object
        另请参见：
        createShared(),
createCopySchema(),
createCopyNoConstraints(),
RowSetEvent,
RowSetListener

      • createCopyNoConstraints

        CachedRowSet createCopyNoConstraints()
                                     throws SQLException
        Creates a CachedRowSet object that is a deep copy of this CachedRowSet object's data but is independent of it. In contrast to the RowSet object generated from a createShared method call, updates made to a copy of this CachedRowSet object must not be visible to it. Also, any event listeners that are registered with this CachedRowSet object must not have scope over the new RowSet object. In addition, any constraint restrictions established for this CachedRowSet object must not be maintained in the copy.
        返回：
        a new CachedRowSet object that is a deep copy of this CachedRowSet object and is completely independent of this CachedRowSet object
        抛出：
        SQLException - if an error occurs in generating the copy of the of this CachedRowSet object
        另请参见：
        createCopy(),
createShared(),
createCopySchema(),
RowSetEvent,
RowSetListener

      • getRowSetWarnings

        RowSetWarning getRowSetWarnings()
                                throws SQLException
        Retrieves the first warning reported by calls on this RowSet object. Subsequent warnings on this RowSet object will be chained to the RowSetWarning object that this method returns. The warning chain is automatically cleared each time a new row is read. This method may not be called on a RowSet object that has been closed; doing so will cause a SQLException to be thrown.
        返回：
        RowSetWarning the first RowSetWarning object reported or null if there are none
        抛出：
        SQLException - if this method is called on a closed RowSet
        另请参见：
        RowSetWarning

      • getShowDeleted

        boolean getShowDeleted()
                       throws SQLException
        Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows. If true is returned, deleted rows are visible with the current rows. If false is returned, rows are not visible with the set of current rows. The default value is false.

        Standard rowset implementations may choose to restrict this behavior due to security considerations or to better fit certain deployment scenarios. This is left as implementation defined and does not represent standard behavior.

        Note: Allowing deleted rows to remain visible complicates the behavior of some standard JDBC RowSet Implementations methods. However, most rowset users can simply ignore this extra detail because only very specialized applications will likely want to take advantage of this feature.

        返回：
        true if deleted rows are visible; false otherwise
        抛出：
        SQLException - if a rowset implementation is unable to to determine whether rows marked for deletion are visible
        另请参见：
        setShowDeleted(boolean)

      • setShowDeleted

        void setShowDeleted(boolean b)
                    throws SQLException
        Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows. If the value is set to true, deleted rows are immediately visible with the set of current rows. If the value is set to false, the deleted rows are set as invisible with the current set of rows.

        Standard rowset implementations may choose to restrict this behavior due to security considerations or to better fit certain deployment scenarios. This is left as implementations defined and does not represent standard behavior.

        参数：
        b - true if deleted rows should be shown; false otherwise
        抛出：
        SQLException - if a rowset implementation is unable to to reset whether deleted rows should be visible
        另请参见：
        getShowDeleted()

      • commit

        void commit()
            throws SQLException
        Each CachedRowSet object's SyncProvider contains a Connection object from the ResultSet or JDBC properties passed to it's constructors. This method wraps the Connection commit method to allow flexible auto commit or non auto commit transactional control support.

        Makes all changes that are performed by the acceptChanges() method since the previous commit/rollback permanent. This method should be used only when auto-commit mode has been disabled.

        抛出：
        SQLException - if a database access error occurs or this Connection object within this CachedRowSet is in auto-commit mode
        另请参见：
        Connection.setAutoCommit(boolean)

      • rollback

        void rollback()
              throws SQLException
        Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.

        Undoes all changes made in the current transaction. This method should be used only when auto-commit mode has been disabled.

        抛出：
        SQLException - if a database access error occurs or this Connection object within this CachedRowSet is in auto-commit mode.

      • rollback

        void rollback(Savepoint s)
              throws SQLException
        Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.

        Undoes all changes made in the current transaction back to the last Savepoint transaction marker. This method should be used only when auto-commit mode has been disabled.

        参数：
        s - A Savepoint transaction marker
        抛出：
        SQLException - if a database access error occurs or this Connection object within this CachedRowSet is in auto-commit mode.

      • rowSetPopulated

        void rowSetPopulated(RowSetEvent event,
                   int numRows)
                     throws SQLException
        Notifies registered listeners that a RowSet object in the given RowSetEvent object has populated a number of additional rows. The numRows parameter ensures that this event will only be fired every numRow.

        The source of the event can be retrieved with the method event.getSource.

        参数：
        event - a RowSetEvent object that contains the RowSet object that is the source of the events
        numRows - when populating, the number of rows interval on which the CachedRowSet populated should fire; the default value is zero; cannot be less than fetchSize or zero
        抛出：
        SQLException

      • populate

        void populate(ResultSet rs,
            int startRow)
              throws SQLException
        Populates this CachedRowSet object with data from the given ResultSet object. While related to the populate(ResultSet) method, an additional parameter is provided to allow starting position within the ResultSet from where to populate the CachedRowSet instance.

        This method can be used as an alternative to the execute method when an application has a connection to an open ResultSet object. Using the method populate can be more efficient than using the version of the execute method that takes no parameters because it does not open a new connection and re-execute this CachedRowSet object's command. Using the populate method is more a matter of convenience when compared to using the version of execute that takes a ResultSet object.

        参数：
        startRow - the position in the ResultSet from where to start populating the records in this CachedRowSet
        rs - the ResultSet object containing the data to be read into this CachedRowSet object
        抛出：
        SQLException - if a null ResultSet object is supplied or this CachedRowSet object cannot retrieve the associated ResultSetMetaData object
        另请参见：
        execute(java.sql.Connection), populate(ResultSet), ResultSet, ResultSetMetaData

      • setPageSize

        void setPageSize(int size)
                 throws SQLException
        Sets the CachedRowSet object's page-size. A CachedRowSet may be configured to populate itself in page-size sized batches of rows. When either populate() or execute() are called, the CachedRowSet fetches an additional page according to the original SQL query used to populate the RowSet.
        参数：
        size - the page-size of the CachedRowSet
        抛出：
        SQLException - if an error occurs setting the CachedRowSet page size or if the page size is less than 0.

      • getPageSize

        int getPageSize()
        Returns the page-size for the CachedRowSet object
        返回：
        an int page size

      • nextPage

        boolean nextPage()
                 throws SQLException
        Increments the current page of the CachedRowSet. This causes the CachedRowSet implementation to fetch the next page-size rows and populate the RowSet, if remaining rows remain within scope of the original SQL query used to populated the RowSet.
        返回：
        true if more pages exist; false if this is the last page
        抛出：
        SQLException - if an error occurs fetching the next page, or if this method is called prematurely before populate or execute.

      • previousPage

        boolean previousPage()
                     throws SQLException
        Decrements the current page of the CachedRowSet. This causes the CachedRowSet implementation to fetch the previous page-size rows and populate the RowSet. The amount of rows returned in the previous page must always remain within scope of the original SQL query used to populate the RowSet.
        返回：
        true if the previous page is successfully retrieved; false if this is the first page.
        抛出：
        SQLException - if an error occurs fetching the previous page, or if this method is called prematurely before populate or execute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tceT Psieo dierrrreh ihrb


FilteredRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface FilteredRowSet

  • All Superinterfaces:
    AutoCloseable, CachedRowSet, Joinable, ResultSet, RowSet, WebRowSet, Wrapper

    public interface FilteredRowSet
extends WebRowSet
    The standard interface that all standard implementations of FilteredRowSet must implement. The FilteredRowSetImpl class provides the reference implementation which may be extended if required. Alternatively, a vendor is free to implement its own version by implementing this interface.

    1.0 Background

    There are occasions when a RowSet object has a need to provide a degree of filtering to its contents. One possible solution is to provide a query language for all standard RowSet implementations; however, this is an impractical approach for lightweight components such as disconnected RowSet objects. The FilteredRowSet interface seeks to address this need without supplying a heavyweight query language along with the processing that such a query language would require.

    A JDBC FilteredRowSet standard implementation implements the RowSet interfaces and extends the CachedRowSetTM class. The CachedRowSet class provides a set of protected cursor manipulation methods, which a FilteredRowSet implementation can override to supply filtering support.

    2.0 Predicate Sharing

    If a FilteredRowSet implementation is shared using the inherited createShared method in parent interfaces, the Predicate should be shared without modification by all FilteredRowSet instance clones.

    3.0 Usage

    By implementing a Predicate (see example in Predicate class JavaDoc), a FilteredRowSet could then be used as described below.

         FilteredRowSet frs = new FilteredRowSetImpl();
     frs.populate(rs);

     Range name = new Range("Alpha", "Bravo", "columnName");
     frs.setFilter(name);

     frs.next() // only names from "Alpha" to "Bravo" will be returned
    In the example above, we initialize a Range object which implements the Predicate interface. This object expresses the following constraints: All rows outputted or modified from this FilteredRowSet object must fall between the values 'Alpha' and 'Bravo' both values inclusive, in the column 'columnName'. If a filter is applied to a FilteredRowSet object that contains no data that falls within the range of the filter, no rows are returned.

    This framework allows multiple classes implementing predicates to be used in combination to achieved the required filtering result with out the need for query language processing.

    4.0 Updating a FilteredRowSet Object

    The predicate set on a FilteredRowSet object applies a criterion on all rows in a RowSet object to manage a subset of rows in a RowSet object. This criterion governs the subset of rows that are visible and also defines which rows can be modified, deleted or inserted.

    Therefore, the predicate set on a FilteredRowSet object must be considered as bi-directional and the set criterion as the gating mechanism for all views and updates to the FilteredRowSet object. Any attempt to update the FilteredRowSet that violates the criterion will result in a SQLException object being thrown.

    The FilteredRowSet range criterion can be modified by applying a new Predicate object to the FilteredRowSet instance at any time. This is possible if no additional references to the FilteredRowSet object are detected. A new filter has has an immediate effect on criterion enforcement within the FilteredRowSet object, and all subsequent views and updates will be subject to similar enforcement.

    5.0 Behavior of Rows Outside the Filter

    Rows that fall outside of the filter set on a FilteredRowSet object cannot be modified until the filter is removed or a new filter is applied.

    Furthermore, only rows that fall within the bounds of a filter will be synchronized with the data source.

    • 字段摘要

      • 字段 - 继承于接口 javax.sql.rowset.WebRowSet

        PUBLIC_XML_SCHEMA, SCHEMA_SYSTEM_ID

      • 字段 - 继承于接口 javax.sql.rowset.CachedRowSet

        COMMIT_ON_ACCEPT_CHANGES

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Predicate getFilter()
      Retrieves the active filter for this FilteredRowSet object.
      void setFilter(Predicate p)
      Applies the given Predicate object to this FilteredRowSet object.

      • 方法 - 继承于接口 javax.sql.rowset.WebRowSet

        readXml, readXml, writeXml, writeXml, writeXml, writeXml

      • 方法 - 继承于接口 javax.sql.rowset.CachedRowSet

        acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

      • 方法 - 继承于接口 javax.sql.rowset.Joinable

        getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    • 方法详细信息

      • setFilter

        void setFilter(Predicate p)
               throws SQLException
        Applies the given Predicate object to this FilteredRowSet object. The filter applies controls both to inbound and outbound views, constraining which rows are visible and which rows can be manipulated.

        A new Predicate object may be set at any time. This has the effect of changing constraints on the RowSet object's data. In addition, modifying the filter at runtime presents issues whereby multiple components may be operating on one FilteredRowSet object. Application developers must take responsibility for managing multiple handles to FilteredRowSet objects when their underling Predicate objects change.

        参数：
        p - a Predicate object defining the filter for this FilteredRowSet object. Setting a null value will clear the predicate, allowing all rows to become visible.
        抛出：
        SQLException - if an error occurs when setting the Predicate object

      • getFilter

        Predicate getFilter()
        Retrieves the active filter for this FilteredRowSet object.
        返回：
        p the Predicate for this FilteredRowSet object; null if no filter has been set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cjoos"lt"loFFloos ==r yr oteyrnn yysdm


javax.sql.rowset

Interfaces

  • CachedRowSet
  • FilteredRowSet
  • JdbcRowSet
  • Joinable
  • JoinRowSet
  • Predicate
  • RowSetFactory
  • WebRowSet

Classes

  • BaseRowSet
  • RowSetMetaDataImpl
  • RowSetProvider

Exceptions

  • RowSetWarning
>


javax.sql.rowset

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sql.rowset

Standard interfaces and base classes for JDBC RowSet implementations.

请参见： 描述

  • 接口摘要
    接口 描述
    CachedRowSet
    The interface that all standard implementations of CachedRowSet must implement.
    FilteredRowSet
    The standard interface that all standard implementations of FilteredRowSet must implement.
    JdbcRowSet
    The standard interface that all standard implementations of JdbcRowSet must implement.
    Joinable
    1.0 Background
    JoinRowSet
    The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
    Predicate
    The standard interface that provides the framework for all FilteredRowSet objects to describe their filters.
    RowSetFactory
    An interface that defines the implementation of a factory that is used to obtain different types of RowSet implementations.
    WebRowSet
    The standard interface that all implementations of a WebRowSet must implement.
  • Class Summary
    类 描述
    BaseRowSet
    An abstract class providing a RowSet object with its basic functionality.
    RowSetMetaDataImpl
    Provides implementations for the methods that set and get metadata information about a RowSet object's columns.
    RowSetProvider
    A factory API that enables applications to obtain a RowSetFactory implementation that can be used to create different types of RowSet implementations.
  • Exception Summary
    Exception 描述
    RowSetWarning
    An extension of SQLException that provides information about database warnings set on RowSet objects.

软件包 javax.sql.rowset Description

Standard interfaces and base classes for JDBC RowSet implementations. This package contains interfaces and classes that a standard RowSet implementation either implements or extends.

Table of Contents

  • 1.0 Package Specification
  • 2.0 Standard RowSet Definitions
  • 3.0 Implementater's Guide
  • 4.0 Related Specifications
  • 5.0 Related Documentation

1.0 Package Specification

This package specifies five standard JDBC RowSet interfaces. All five extend the RowSet interface described in the JDBC 3.0 specification. It is anticipated that additional definitions of more specialized JDBC RowSet types will emerge as this technology matures. Future definitions should be specified as subinterfaces using inheritance similar to the way it is used in this specification.

Note: The interface definitions provided in this package form the basis for all compliant JDBC RowSet implementations. Vendors and more advanced developers who intend to provide their own compliant RowSet implementations should pay particular attention to the assertions detailed in specification interfaces.

2.0 Standard RowSet Definitions

  • JdbcRowSet - A wrapper around a ResultSet object that makes it possible to use the result set as a JavaBeansTM component. Thus, a JdbcRowSet object can be a Bean that any tool makes available for assembling an application as part of a component based architecture . A JdbcRowSet object is a connected RowSet object, that is, it must continually maintain its connection to its data source using a JDBC technology-enabled driver ("JDBC driver"). In addition, a JdbcRowSet object provides a fully updatable and scrollable tabular data structure as defined in the JDBC 3.0 specification.

  • CachedRowSet™ - A CachedRowSet object is a JavaBeansTM component that is scrollable, updatable, serializable, and generally disconnected from the source of its data. A CachedRowSet object typically contains rows from a result set, but it can also contain rows from any file with a tabular format, such as a spreadsheet. CachedRowSet implementations must use the SyncFactory to manage and obtain pluggable SyncProvider objects to provide synchronization between the disconnected RowSet object and the originating data source. Typically a SyncProvider implementation relies upon a JDBC driver to obtain connectivity to a particular data source. Further details on this mechanism are discussed in the javax.sql.rowset.spi package specification.

  • WebRowSet - A WebRowSet object is an extension of CachedRowSet that can read and write a RowSet object in a well formed XML format. This class calls an XmlReader object (an extension of the RowSetReader interface) to read a rowset in XML format. It calls an XmlWriter object (an extension of the RowSetWriter interface) to write a rowset in XML format. The reader and writer required by WebRowSet objects are provided by the SyncFactory in the form of SyncProvider implementations. In order to ensure well formed XML usage, a standard generic XML Schema is defined and published at http://java.sun.com/xml/ns/jdbc/webrowset.xsd.

  • FilteredRowSet - A FilteredRowSet object provides filtering functionality in a programmatic and extensible way. There are many instances when a RowSet object has a need to provide filtering in its contents without sacrificing the disconnected environment, thus saving the expense of having to create a connection to the data source. Solutions to this need vary from providing heavyweight full scale SQL query abilities, to portable components, to more lightweight approaches. A FilteredRowSet object consumes an implementation of the Predicate interface, which may define a filter at run time. In turn, a FilteredRowSet object is tasked with enforcing the set filter for both inbound and outbound read and write operations. That is, all filters can be considered as bi-directional. No standard filters are defined; however, sufficient mechanics are specified to permit any required filter to be implemented.

  • JoinRowSet - The JoinRowSet interface describes a mechanism by which relationships can be established between two or more standard RowSet implementations. Any number of RowSet objects can be added to a JoinRowSet object provided the RowSetobjects can be related in a SQL JOIN like fashion. By definition, the SQL JOIN statement is used to combine the data contained in two (or more) relational database tables based upon a common attribute. By establishing and then enforcing column matches, a JoinRowSet object establishes relationships between RowSet instances without the need to touch the originating data source.

3.0 Implementer's Guide

Compliant implementations of JDBC RowSet Implementations must follow the assertions described in this specification. In accordance with the terms of the Java Community Process, a Test Compatibility Kit (TCK) can be licensed to ensure compatibility with the specification. The following paragraphs outline a number of starting points for implementers of the standard JDBC RowSet definitions. Implementers should also consult the Implementer's Guide in the javax.sql.rowset.spi package for guidelines on SyncProvider implementations.

  • 3.1 Constructor

    All RowSet implementations must provide a no-argument constructor.

  • 3.2 Role of the BaseRowSet Class

    A compliant JDBC RowSet implementation must implement one or more standard interfaces specified in this package and and may extend the BaseRowSet abstract class. For example, a CachedRowSet implementation must implement the CachedRowSet interface and extend the BaseRowSet abstract class. The BaseRowSet class provides the standard architecture on which all RowSet implementations should be built, regardless of whether the RowSet objects exist in a connected or disconnected environment. The BaseRowSet abstract class provides any RowSet implementation with its base functionality, including property manipulation and event notification that is fully compliant with JavaBeans component requirements. As an example, all implementations provided in the reference implementations (contained in the com.sun.rowset package) use the BaseRowSet class as a basis for their implementations.

    The following table illustrates the features that the BaseRowSet abstract class provides.

    Feature
             Details
    Properties
             Provides standard JavaBeans property manipulation mechanisms to allow applications to get and set RowSet command and property values. Refer to the documentation of the javax.sql.RowSet interface (available in the JDBC 3.0 specification) for more details on the standard RowSet properties.
    Event notification
             Provides standard JavaBeans event notifications to registered event listeners. Refer to the documentation of javax.sql.RowSetEvent interface (available in the JDBC 3.0 specification) for more details on how to register and handle standard RowSet events generated by compliant implementations.
    Setters for a RowSet object's command
             Provides a complete set of setter methods for setting RowSet command parameters.
    Streams
             Provides fields for storing of stream instances in addition to providing a set of constants for stream type designation.

  • 3.3 Connected RowSet Requirements

    The JdbcRowSet describes a RowSet object that must always be connected to the originating data source. Implementations of the JdbcRowSet should ensure that this connection is provided solely by a JDBC driver. Furthermore, RowSet objects that are implementations of the JdbcRowSet interface and are therefore operating in a connected environment do not use the SyncFactory to obtain a RowSetReader object or a RowSetWriter object. They can safely rely on the JDBC driver to supply their needs by virtue of the presence of an underlying updatable and scrollable ResultSet implementation.

  • 3.4 Disconnected RowSet Requirements

    A disconnected RowSet object, such as a CachedRowSet object, should delegate connection management to a SyncProvider object provided by the SyncFactory. To ensure fully disconnected semantics, all disconnected RowSet objects must ensure that the original connection made to the data source to populate the RowSet object is closed to permit the garbage collector to recover and release resources. The SyncProvider object ensures that the critical JDBC properties are maintained in order to re-establish a connection to the data source when a synchronization is required. A disconnected RowSet object should therefore ensure that no extraneous references remain on the Connection object.

  • 3.5 Role of RowSetMetaDataImpl

    The RowsetMetaDataImpl class is a utility class that provides an implementation of the RowSetMetaData interface, supplying standard setter method implementations for metadata for both connected and disconnected RowSet objects. All implementations are free to use this standard implementation but are not required to do so.

  • 3.6 RowSetWarning Class

    The RowSetWarning class provides warnings that can be set on RowSet implementations. Similar to SQLWarning objects, RowSetWarning objects are silently chained to the object whose method caused the warning to be thrown. All RowSet implementations should ensure that this chaining occurs if a warning is generated and also ensure that the warnings are available via the getRowSetWarnings method defined in either the JdbcRowSet interface or the CachedRowSet interface. After a warning has been retrieved with one of the getRowSetWarnings methods, the RowSetWarning method getNextWarning can be called on it to retrieve any warnings that might be chained on it. If a warning is returned, getNextWarning can be called on it, and so on until there are no more warnings.

  • 3.7 The Joinable Interface

    The Joinable interface provides both connected and disconnected RowSet objects with the capability to be added to a JoinRowSet object in an SQL JOIN operation. A RowSet object that has implemented the Joinable interface can set a match column, retrieve a match column, or unset a match column. A JoinRowSet object can then use the RowSet object's match column as a basis for adding the RowSet object.

  • 3.8 The RowSetFactory Interface

    A RowSetFactory implementation must be provided.

4.0 Related Specifications

  • JDBC 3.0 Specification
  • XML Schema
  • SyncML

5.0 Related Documentation

  • JDBC RowSet Tutorial
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vlad


javax.sql.rowset Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sql.rowset

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sql.rowset.BaseRowSet (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.RowSetMetaDataImpl (implements javax.sql.RowSetMetaData, java.io.Serializable)
    • javax.sql.rowset.RowSetProvider
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.RowSetWarning

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
  • javax.sql.rowset.Joinable
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.RowSet)
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.RowSet)
  • javax.sql.rowset.Predicate
  • javax.sql.rowset.RowSetFactory
  • java.sql.Wrapper
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eSb/cxnu...at mlnnev


JdbcRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface JdbcRowSet

  • All Superinterfaces:
    AutoCloseable, Joinable, ResultSet, RowSet, Wrapper

    public interface JdbcRowSet
extends RowSet, Joinable
    The standard interface that all standard implementations of JdbcRowSet must implement.

    1.0 Overview

    A wrapper around a ResultSet object that makes it possible to use the result set as a JavaBeansTM component. Thus, a JdbcRowSet object can be one of the Beans that a tool makes available for composing an application. Because a JdbcRowSet is a connected rowset, that is, it continually maintains its connection to a database using a JDBC technology-enabled driver, it also effectively makes the driver a JavaBeans component.

    Because it is always connected to its database, an instance of JdbcRowSet can simply take calls invoked on it and in turn call them on its ResultSet object. As a consequence, a result set can, for example, be a component in a Swing application.

    Another advantage of a JdbcRowSet object is that it can be used to make a ResultSet object scrollable and updatable. All RowSet objects are by default scrollable and updatable. If the driver and database being used do not support scrolling and/or updating of result sets, an application can populate a JdbcRowSet object with the data of a ResultSet object and then operate on the JdbcRowSet object as if it were the ResultSet object.

    2.0 Creating a JdbcRowSet Object

    The reference implementation of the JdbcRowSet interface, JdbcRowSetImpl, provides an implementation of the default constructor. A new instance is initialized with default values, which can be set with new values as needed. A new instance is not really functional until its execute method is called. In general, this method does the following:
    • establishes a connection with a database
    • creates a PreparedStatement object and sets any of its placeholder parameters
    • executes the statement to create a ResultSet object
    If the execute method is successful, it will set the appropriate private JdbcRowSet fields with the following:
    • a Connection object -- the connection between the rowset and the database
    • a PreparedStatement object -- the query that produces the result set
    • a ResultSet object -- the result set that the rowset's command produced and that is being made, in effect, a JavaBeans component
    If these fields have not been set, meaning that the execute method has not executed successfully, no methods other than execute and close may be called on the rowset. All other public methods will throw an exception.

    Before calling the execute method, however, the command and properties needed for establishing a connection must be set. The following code fragment creates a JdbcRowSetImpl object, sets the command and connection properties, sets the placeholder parameter, and then invokes the method execute.

         JdbcRowSetImpl jrs = new JdbcRowSetImpl();
     jrs.setCommand("SELECT * FROM TITLES WHERE TYPE = ?");
     jrs.setURL("jdbc:myDriver:myAttribute");
     jrs.setUsername("cervantes");
     jrs.setPassword("sancho");
     jrs.setString(1, "BIOGRAPHY");
     jrs.execute();
    The variable jrs now represents an instance of JdbcRowSetImpl that is a thin wrapper around the ResultSet object containing all the rows in the table TITLES where the type of book is biography. At this point, operations called on jrs will affect the rows in the result set, which is effectively a JavaBeans component.

    The implementation of the RowSet method execute in the JdbcRowSet reference implementation differs from that in the CachedRowSetTM reference implementation to account for the different requirements of connected and disconnected RowSet objects.

    • 字段摘要

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void commit()
      Each JdbcRowSet contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
      boolean getAutoCommit()
      Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
      RowSetWarning getRowSetWarnings()
      Retrieves the first warning reported by calls on this JdbcRowSet object.
      boolean getShowDeleted()
      Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.
      void rollback()
      Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
      void rollback(Savepoint s)
      Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
      void setAutoCommit(boolean autoCommit)
      Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
      void setShowDeleted(boolean b)
      Sets the property showDeleted to the given boolean value.

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

      • 方法 - 继承于接口 javax.sql.rowset.Joinable

        getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    • 方法详细信息

      • getShowDeleted

        boolean getShowDeleted()
                       throws SQLException
        Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows. If true is returned, deleted rows are visible with the current rows. If false is returned, rows are not visible with the set of current rows. The default value is false.

        Standard rowset implementations may choose to restrict this behavior for security considerations or for certain deployment scenarios. The visibility of deleted rows is implementation-defined and does not represent standard behavior.

        Note: Allowing deleted rows to remain visible complicates the behavior of some standard JDBC RowSet implementations methods. However, most rowset users can simply ignore this extra detail because only very specialized applications will likely want to take advantage of this feature.

        返回：
        true if deleted rows are visible; false otherwise
        抛出：
        SQLException - if a rowset implementation is unable to to determine whether rows marked for deletion remain visible
        另请参见：
        setShowDeleted(boolean)

      • setShowDeleted

        void setShowDeleted(boolean b)
                    throws SQLException
        Sets the property showDeleted to the given boolean value. This property determines whether rows marked for deletion continue to appear in the set of current rows. If the value is set to true, deleted rows are immediately visible with the set of current rows. If the value is set to false, the deleted rows are set as invisible with the current set of rows.

        Standard rowset implementations may choose to restrict this behavior for security considerations or for certain deployment scenarios. This is left as implementation-defined and does not represent standard behavior.

        参数：
        b - true if deleted rows should be shown; false otherwise
        抛出：
        SQLException - if a rowset implementation is unable to to reset whether deleted rows should be visible
        另请参见：
        getShowDeleted()

      • getRowSetWarnings

        RowSetWarning getRowSetWarnings()
                                throws SQLException
        Retrieves the first warning reported by calls on this JdbcRowSet object. If a second warning was reported on this JdbcRowSet object, it will be chained to the first warning and can be retrieved by calling the method RowSetWarning.getNextWarning on the first warning. Subsequent warnings on this JdbcRowSet object will be chained to the RowSetWarning objects returned by the method RowSetWarning.getNextWarning. The warning chain is automatically cleared each time a new row is read. This method may not be called on a RowSet object that has been closed; doing so will cause an SQLException to be thrown.

        Because it is always connected to its data source, a JdbcRowSet object can rely on the presence of active Statement, Connection, and ResultSet instances. This means that applications can obtain additional SQLWarning notifications by calling the getNextWarning methods that they provide. Disconnected Rowset objects, such as a CachedRowSet object, do not have access to these getNextWarning methods.

        返回：
        the first RowSetWarning object reported on this JdbcRowSet object or null if there are none
        抛出：
        SQLException - if this method is called on a closed JdbcRowSet object
        另请参见：
        RowSetWarning

      • commit

        void commit()
            throws SQLException
        Each JdbcRowSet contains a Connection object from the ResultSet or JDBC properties passed to it's constructors. This method wraps the Connection commit method to allow flexible auto commit or non auto commit transactional control support.

        Makes all changes made since the previous commit/rollback permanent and releases any database locks currently held by this Connection object. This method should be used only when auto-commit mode has been disabled.

        抛出：
        SQLException - if a database access error occurs or this Connection object within this JdbcRowSet is in auto-commit mode
        另请参见：
        Connection.setAutoCommit(boolean)

      • getAutoCommit

        boolean getAutoCommit()
                      throws SQLException
        Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it. This method wraps the Connection's getAutoCommit method to allow an application to determine the JdbcRowSet transaction behavior.

        Sets this connection's auto-commit mode to the given state. If a connection is in auto-commit mode, then all its SQL statements will be executed and committed as individual transactions. Otherwise, its SQL statements are grouped into transactions that are terminated by a call to either the method commit or the method rollback. By default, new connections are in auto-commit mode.

        抛出：
        SQLException - if a database access error occurs
        另请参见：
        Connection.getAutoCommit()

      • setAutoCommit

        void setAutoCommit(boolean autoCommit)
                   throws SQLException
        Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it. This method wraps the Connection's getAutoCommit method to allow an application to set the JdbcRowSet transaction behavior.

        Sets the current auto-commit mode for this Connection object.

        抛出：
        SQLException - if a database access error occurs
        另请参见：
        Connection.setAutoCommit(boolean)

      • rollback

        void rollback()
              throws SQLException
        Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it. Undoes all changes made in the current transaction and releases any database locks currently held by this Connection object. This method should be used only when auto-commit mode has been disabled.
        抛出：
        SQLException - if a database access error occurs or this Connection object within this JdbcRowSet is in auto-commit mode.
        另请参见：
        rollback(Savepoint)

      • rollback

        void rollback(Savepoint s)
              throws SQLException
        Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it. Undoes all changes made in the current transaction to the last set savepoint and releases any database locks currently held by this Connection object. This method should be used only when auto-commit mode has been disabled.
        抛出：
        SQLException - if a database access error occurs or this Connection object within this JdbcRowSet is in auto-commit mode.
        另请参见：
        rollback()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n


Joinable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface Joinable

  • All Known Subinterfaces:
    CachedRowSet, FilteredRowSet, JdbcRowSet, JoinRowSet, WebRowSet

    public interface Joinable

    1.0 Background

    The Joinable interface provides the methods for getting and setting a match column, which is the basis for forming the SQL JOIN formed by adding RowSet objects to a JoinRowSet object.

    Any standard RowSet implementation may implement the Joinable interface in order to be added to a JoinRowSet object. Implementing this interface gives a RowSet object the ability to use Joinable methods, which set, retrieve, and get information about match columns. An application may add a RowSet object that has not implemented the Joinable interface to a JoinRowSet object, but to do so it must use one of the JoinRowSet.addRowSet methods that takes both a RowSet object and a match column or an array of RowSet objects and an array of match columns.

    To get access to the methods in the Joinable interface, a RowSet object implements at least one of the five standard RowSet interfaces and also implements the Joinable interface. In addition, most RowSet objects extend the BaseRowSet class. For example:

         class MyRowSetImpl extends BaseRowSet implements CachedRowSet, Joinable {
         :
         :
     }

    2.0 Usage Guidelines

    The methods in the Joinable interface allow a RowSet object to set a match column, retrieve a match column, or unset a match column, which is the column upon which an SQL JOIN can be based. An instance of a class that implements these methods can be added to a JoinRowSet object to allow an SQL JOIN relationship to be established.

         CachedRowSet crs = new MyRowSetImpl();
     crs.populate((ResultSet)rs);
     (Joinable)crs.setMatchColumnIndex(1);

     JoinRowSet jrs = new JoinRowSetImpl();
     jrs.addRowSet(crs);
    In the previous example, crs is a CachedRowSet object that has emplemented the Joinable interface. In the following example, crs2 has not, so it must supply the match column as an argument to the addRowSet method. This example assumes that column 1 is the match column.
         CachedRowSet crs2 = new MyRowSetImpl();
     crs2.populate((ResultSet)rs);

     JoinRowSet jrs2 = new JoinRowSetImpl();
     jrs2.addRowSet(crs2, 1);

    The JoinRowSet interface makes it possible to get data from one or more RowSet objects consolidated into one table without having to incur the expense of creating a connection to a database. It is therefore ideally suited for use by disconnected RowSet objects. Nevertheless, any RowSet object may implement this interface regardless of whether it is connected or disconnected. Note that a JdbcRowSet object, being always connected to its data source, can become part of an SQL JOIN directly without having to become part of a JoinRowSet object.

    3.0 Managing Multiple Match Columns

    The index array passed into the setMatchColumn methods indicates how many match columns are being set (the length of the array) in addition to which columns will be used for the match. For example:
         int[] i = {1, 2, 4, 7}; // indicates four match columns, with column
                             // indexes 1, 2, 4, 7 participating in the JOIN.
     Joinable.setMatchColumn(i);
    Subsequent match columns may be added as follows to a different Joinable object (a RowSet object that has implemented the Joinable interface).
         int[] w = {3, 2, 5, 3};
     Joinable2.setMatchColumn(w);
    When an application adds two or more RowSet objects to a JoinRowSet object, the order of the indexes in the array is particularly important. Each index of the array maps directly to the corresponding index of the previously added RowSet object. If overlap or underlap occurs, the match column data is maintained in the event an additional Joinable RowSet is added and needs to relate to the match column data. Therefore, applications can set multiple match columns in any order, but this order has a direct effect on the outcome of the SQL JOIN.

    This assertion applies in exactly the same manner when column names are used rather than column indexes to indicate match columns.

    另请参见：
    JoinRowSet

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int[] getMatchColumnIndexes()
      Retrieves the indexes of the match columns that were set for this RowSet object with the method setMatchColumn(int[] columnIdxes).
      String[] getMatchColumnNames()
      Retrieves the names of the match columns that were set for this RowSet object with the method setMatchColumn(String [] columnNames).
      void setMatchColumn(int columnIdx)
      Sets the designated column as the match column for this RowSet object.
      void setMatchColumn(int[] columnIdxes)
      Sets the designated columns as the match column for this RowSet object.
      void setMatchColumn(String columnName)
      Sets the designated column as the match column for this RowSet object.
      void setMatchColumn(String[] columnNames)
      Sets the designated columns as the match column for this RowSet object.
      void unsetMatchColumn(int columnIdx)
      Unsets the designated column as the match column for this RowSet object.
      void unsetMatchColumn(int[] columnIdxes)
      Unsets the designated columns as the match column for this RowSet object.
      void unsetMatchColumn(String columnName)
      Unsets the designated column as the match column for this RowSet object.
      void unsetMatchColumn(String[] columnName)
      Unsets the designated columns as the match columns for this RowSet object.

    • 方法详细信息

      • setMatchColumn

        void setMatchColumn(int columnIdx)
                    throws SQLException
        Sets the designated column as the match column for this RowSet object. A JoinRowSet object can now add this RowSet object based on the match column.

        Sub-interfaces such as the CachedRowSetTM interface define the method CachedRowSet.setKeyColumns, which allows primary key semantics to be enforced on specific columns. Implementations of the setMatchColumn(int columnIdx) method should ensure that the constraints on the key columns are maintained when a CachedRowSet object sets a primary key column as a match column.

        参数：
        columnIdx - an int identifying the index of the column to be set as the match column
        抛出：
        SQLException - if an invalid column index is set
        另请参见：
        setMatchColumn(int[]), unsetMatchColumn(int)

      • setMatchColumn

        void setMatchColumn(int[] columnIdxes)
                    throws SQLException
        Sets the designated columns as the match column for this RowSet object. A JoinRowSet object can now add this RowSet object based on the match column.
        参数：
        columnIdxes - an array of int identifying the indexes of the columns to be set as the match columns
        抛出：
        SQLException - if an invalid column index is set
        另请参见：
        setMatchColumn(int[]), unsetMatchColumn(int[])

      • setMatchColumn

        void setMatchColumn(String columnName)
                    throws SQLException
        Sets the designated column as the match column for this RowSet object. A JoinRowSet object can now add this RowSet object based on the match column.

        Subinterfaces such as the CachedRowSet interface define the method CachedRowSet.setKeyColumns, which allows primary key semantics to be enforced on specific columns. Implementations of the setMatchColumn(String columnIdx) method should ensure that the constraints on the key columns are maintained when a CachedRowSet object sets a primary key column as a match column.

        参数：
        columnName - a String object giving the name of the column to be set as the match column
        抛出：
        SQLException - if an invalid column name is set, the column name is a null, or the column name is an empty string
        另请参见：
        unsetMatchColumn(int), setMatchColumn(int[])

      • setMatchColumn

        void setMatchColumn(String[] columnNames)
                    throws SQLException
        Sets the designated columns as the match column for this RowSet object. A JoinRowSet object can now add this RowSet object based on the match column.
        参数：
        columnNames - an array of String objects giving the names of the column to be set as the match columns
        抛出：
        SQLException - if an invalid column name is set, the column name is a null, or the column name is an empty string
        另请参见：
        unsetMatchColumn(int), setMatchColumn(int[])

      • getMatchColumnIndexes

        int[] getMatchColumnIndexes()
                            throws SQLException
        Retrieves the indexes of the match columns that were set for this RowSet object with the method setMatchColumn(int[] columnIdxes).
        返回：
        an int array identifying the indexes of the columns that were set as the match columns for this RowSet object
        抛出：
        SQLException - if no match column has been set
        另请参见：
        setMatchColumn(int), unsetMatchColumn(int)

      • getMatchColumnNames

        String[] getMatchColumnNames()
                             throws SQLException
        Retrieves the names of the match columns that were set for this RowSet object with the method setMatchColumn(String [] columnNames).
        返回：
        an array of String objects giving the names of the columns set as the match columns for this RowSet object
        抛出：
        SQLException - if no match column has been set
        另请参见：
        setMatchColumn(int), unsetMatchColumn(int)

      • unsetMatchColumn

        void unsetMatchColumn(int columnIdx)
                      throws SQLException
        Unsets the designated column as the match column for this RowSet object.

        RowSet objects that implement the Joinable interface must ensure that a key-like constraint continues to be enforced until the method CachedRowSet.unsetKeyColumns has been called on the designated column.

        参数：
        columnIdx - an int that identifies the index of the column that is to be unset as a match column
        抛出：
        SQLException - if an invalid column index is designated or if the designated column was not previously set as a match column
        另请参见：
        setMatchColumn(int)

      • unsetMatchColumn

        void unsetMatchColumn(int[] columnIdxes)
                      throws SQLException
        Unsets the designated columns as the match column for this RowSet object.
        参数：
        columnIdxes - an arrary of int that identifies the indexes of the columns that are to be unset as match columns
        抛出：
        SQLException - if an invalid column index is designated or if the designated column was not previously set as a match column
        另请参见：
        setMatchColumn(int)

      • unsetMatchColumn

        void unsetMatchColumn(String columnName)
                      throws SQLException
        Unsets the designated column as the match column for this RowSet object.

        RowSet objects that implement the Joinable interface must ensure that a key-like constraint continues to be enforced until the method CachedRowSet.unsetKeyColumns has been called on the designated column.

        参数：
        columnName - a String object giving the name of the column that is to be unset as a match column
        抛出：
        SQLException - if an invalid column name is designated or the designated column was not previously set as a match column
        另请参见：
        setMatchColumn(int)

      • unsetMatchColumn

        void unsetMatchColumn(String[] columnName)
                      throws SQLException
        Unsets the designated columns as the match columns for this RowSet object.
        参数：
        columnName - an array of String objects giving the names of the columns that are to be unset as the match columns
        抛出：
        SQLException - if an invalid column name is designated or the designated column was not previously set as a match column
        另请参见：
        setMatchColumn(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l(">(dii(ddt.qq..f.//S)oRRfhR"


JoinRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface JoinRowSet

  • All Superinterfaces:
    AutoCloseable, CachedRowSet, Joinable, ResultSet, RowSet, WebRowSet, Wrapper

    public interface JoinRowSet
extends WebRowSet
    The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN. In other words, a JoinRowSet object acts as a container for the data from RowSet objects that form an SQL JOIN relationship.

    The Joinable interface provides the methods for setting, retrieving, and unsetting a match column, the basis for establishing an SQL JOIN relationship. The match column may alternatively be set by supplying it to the appropriate version of the JointRowSet method addRowSet.

    1.0 Overview

    Disconnected RowSet objects (CachedRowSet objects and implementations extending the CachedRowSet interface) do not have a standard way to establish an SQL JOIN between RowSet objects without the expensive operation of reconnecting to the data source. The JoinRowSet interface is specifically designed to address this need.

    Any RowSet object can be added to a JoinRowSet object to become part of an SQL JOIN relationship. This means that both connected and disconnected RowSet objects can be part of a JOIN. RowSet objects operating in a connected environment (JdbcRowSet objects) are encouraged to use the database to which they are already connected to establish SQL JOIN relationships between tables directly. However, it is possible for a JdbcRowSet object to be added to a JoinRowSet object if necessary.

    Any number of RowSet objects can be added to an instance of JoinRowSet provided that they can be related in an SQL JOIN. By definition, the SQL JOIN statement is used to combine the data contained in two or more relational database tables based upon a common attribute. The Joinable interface provides the methods for establishing a common attribute, which is done by setting a match column. The match column commonly coincides with the primary key, but there is no requirement that the match column be the same as the primary key. By establishing and then enforcing column matches, a JoinRowSet object establishes JOIN relationships between RowSet objects without the assistance of an available relational database.

    The type of JOIN to be established is determined by setting one of the JoinRowSet constants using the method setJoinType. The following SQL JOIN types can be set:

    • CROSS_JOIN
    • FULL_JOIN
    • INNER_JOIN - the default if no JOIN type has been set
    • LEFT_OUTER_JOIN
    • RIGHT_OUTER_JOIN
    Note that if no type is set, the JOIN will automatically be an inner join. The comments for the fields in the JoinRowSet interface explain these JOIN types, which are standard SQL JOIN types.

    2.0 Using a JoinRowSet Object for Creating a JOIN

    When a JoinRowSet object is created, it is empty. The first RowSet object to be added becomes the basis for the JOIN relationship. Applications must determine which column in each of the RowSet objects to be added to the JoinRowSet object should be the match column. All of the RowSet objects must contain a match column, and the values in each match column must be ones that can be compared to values in the other match columns. The columns do not have to have the same name, though they often do, and they do not have to store the exact same data type as long as the data types can be compared.

    A match column can be be set in two ways:

    • By calling the Joinable method setMatchColumn
      This is the only method that can set the match column before a RowSet object is added to a JoinRowSet object. The RowSet object must have implemented the Joinable interface in order to use the method setMatchColumn. Once the match column value has been set, this method can be used to reset the match column at any time.
    • By calling one of the versions of the JoinRowSet method addRowSet that takes a column name or number (or an array of column names or numbers)
      Four of the five addRowSet methods take a match column as a parameter. These four methods set or reset the match column at the time a RowSet object is being added to a JoinRowSet object.

    3.0 Sample Usage

    The following code fragment adds two CachedRowSet objects to a JoinRowSet object. Note that in this example, no SQL JOIN type is set, so the default JOIN type, which is INNER_JOIN, is established.

    In the following code fragment, the table EMPLOYEES, whose match column is set to the first column (EMP_ID), is added to the JoinRowSet object jrs. Then the table ESSP_BONUS_PLAN, whose match column is likewise the EMP_ID column, is added. When this second table is added to jrs, only the rows in ESSP_BONUS_PLAN whose EMP_ID value matches an EMP_ID value in the EMPLOYEES table are added. In this case, everyone in the bonus plan is an employee, so all of the rows in the table ESSP_BONUS_PLAN are added to the JoinRowSet object. In this example, both CachedRowSet objects being added have implemented the Joinable interface and can therefore call the Joinable method setMatchColumn.

         JoinRowSet jrs = new JoinRowSetImpl();

     ResultSet rs1 = stmt.executeQuery("SELECT * FROM EMPLOYEES");
     CachedRowSet empl = new CachedRowSetImpl();
     empl.populate(rs1);
     empl.setMatchColumn(1);
     jrs.addRowSet(empl);

     ResultSet rs2 = stmt.executeQuery("SELECT * FROM ESSP_BONUS_PLAN");
     CachedRowSet bonus = new CachedRowSetImpl();
     bonus.populate(rs2);
     bonus.setMatchColumn(1); // EMP_ID is the first column
     jrs.addRowSet(bonus);

    At this point, jrs is an inside JOIN of the two RowSet objects based on their EMP_ID columns. The application can now browse the combined data as if it were browsing one single RowSet object. Because jrs is itself a RowSet object, an application can navigate or modify it using RowSet methods.

         jrs.first();
     int employeeID = jrs.getInt(1);
     String employeeName = jrs.getString(2);

    Note that because the SQL JOIN must be enforced when an application adds a second or subsequent RowSet object, there may be an initial degradation in performance while the JOIN is being performed.

    The following code fragment adds an additional CachedRowSet object. In this case, the match column (EMP_ID) is set when the CachedRowSet object is added to the JoinRowSet object.

         ResultSet rs3 = stmt.executeQuery("SELECT * FROM 401K_CONTRIB");
     CachedRowSet fourO1k = new CachedRowSetImpl();
     four01k.populate(rs3);
     jrs.addRowSet(four01k, 1);

    The JoinRowSet object jrs now contains values from all three tables. The data in each row in four01k in which the value for the EMP_ID column matches a value for the EMP_ID column in jrs has been added to jrs.

    4.0 JoinRowSet Methods

    The JoinRowSet interface supplies several methods for adding RowSet objects and for getting information about the JoinRowSet object.
    • Methods for adding one or more RowSet objects
      These methods allow an application to add one RowSet object at a time or to add multiple RowSet objects at one time. In either case, the methods may specify the match column for each RowSet object being added.
    • Methods for getting information
      One method retrieves the RowSet objects in the JoinRowSet object, and another method retrieves the RowSet names. A third method retrieves either the SQL WHERE clause used behind the scenes to form the JOIN or a text description of what the WHERE clause does.
    • Methods related to the type of JOIN
      One method sets the JOIN type, and five methods find out whether the JoinRowSet object supports a given type.
    • A method to make a separate copy of the JoinRowSet object
      This method creates a copy that can be persisted to the data source.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int CROSS_JOIN
      An ANSI-style JOIN providing a cross product of two tables
      static int FULL_JOIN
      An ANSI-style JOIN providing a a full JOIN.
      static int INNER_JOIN
      An ANSI-style JOIN providing a inner join between two tables.
      static int LEFT_OUTER_JOIN
      An ANSI-style JOIN providing a left outer join between two tables.
      static int RIGHT_OUTER_JOIN
      An ANSI-style JOIN providing a right outer join between two tables.

      • 字段 - 继承于接口 javax.sql.rowset.WebRowSet

        PUBLIC_XML_SCHEMA, SCHEMA_SYSTEM_ID

      • 字段 - 继承于接口 javax.sql.rowset.CachedRowSet

        COMMIT_ON_ACCEPT_CHANGES

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRowSet(Joinable rowset)
      Adds the given RowSet object to this JoinRowSet object.
      void addRowSet(RowSet[] rowset, int[] columnIdx)
      Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column indexes.
      void addRowSet(RowSet[] rowset, String[] columnName)
      Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column names.
      void addRowSet(RowSet rowset, int columnIdx)
      Adds the given RowSet object to this JoinRowSet object and sets the designated column as the match column for the RowSet object.
      void addRowSet(RowSet rowset, String columnName)
      Adds rowset to this JoinRowSet object and sets the designated column as the match column.
      int getJoinType()
      Returns a int describing the set SQL JOIN type governing this JoinRowSet instance.
      String[] getRowSetNames()
      Returns a String array containing the names of the RowSet objects added to this JoinRowSet object.
      Collection<?> getRowSets()
      Returns a Collection object containing the RowSet objects that have been added to this JoinRowSet object.
      String getWhereClause()
      Return a SQL-like description of the WHERE clause being used in a JoinRowSet object.
      void setJoinType(int joinType)
      Allow the application to adjust the type of JOIN imposed on tables contained within the JoinRowSet object instance.
      boolean supportsCrossJoin()
      Indicates if CROSS_JOIN is supported by a JoinRowSet implementation
      boolean supportsFullJoin()
      Indicates if FULL_JOIN is supported by a JoinRowSet implementation
      boolean supportsInnerJoin()
      Indicates if INNER_JOIN is supported by a JoinRowSet implementation
      boolean supportsLeftOuterJoin()
      Indicates if LEFT_OUTER_JOIN is supported by a JoinRowSet implementation
      boolean supportsRightOuterJoin()
      Indicates if RIGHT_OUTER_JOIN is supported by a JoinRowSet implementation
      CachedRowSet toCachedRowSet()
      Creates a new CachedRowSet object containing the data in this JoinRowSet object, which can be saved to a data source using the SyncProvider object for the CachedRowSet object.

      • 方法 - 继承于接口 javax.sql.rowset.WebRowSet

        readXml, readXml, writeXml, writeXml, writeXml, writeXml

      • 方法 - 继承于接口 javax.sql.rowset.CachedRowSet

        acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

      • 方法 - 继承于接口 javax.sql.rowset.Joinable

        getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    • 字段详细信息

      • CROSS_JOIN

        static final int CROSS_JOIN
        An ANSI-style JOIN providing a cross product of two tables
        另请参见：
        Constant Field Values

      • INNER_JOIN

        static final int INNER_JOIN
        An ANSI-style JOIN providing a inner join between two tables. Any unmatched rows in either table of the join should be discarded.
        另请参见：
        Constant Field Values

      • LEFT_OUTER_JOIN

        static final int LEFT_OUTER_JOIN
        An ANSI-style JOIN providing a left outer join between two tables. In SQL, this is described where all records should be returned from the left side of the JOIN statement.
        另请参见：
        Constant Field Values

      • RIGHT_OUTER_JOIN

        static final int RIGHT_OUTER_JOIN
        An ANSI-style JOIN providing a right outer join between two tables. In SQL, this is described where all records from the table on the right side of the JOIN statement even if the table on the left has no matching record.
        另请参见：
        Constant Field Values

      • FULL_JOIN

        static final int FULL_JOIN
        An ANSI-style JOIN providing a a full JOIN. Specifies that all rows from either table be returned regardless of matching records on the other table.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • addRowSet

        void addRowSet(Joinable rowset)
               throws SQLException
        Adds the given RowSet object to this JoinRowSet object. If the RowSet object is the first to be added to this JoinRowSet object, it forms the basis of the JOIN relationship to be established.

        This method should be used only when the given RowSet object already has a match column that was set with the Joinable method setMatchColumn.

        Note: A Joinable object is any RowSet object that has implemented the Joinable interface.

        参数：
        rowset - the RowSet object that is to be added to this JoinRowSet object; it must implement the Joinable interface and have a match column set
        抛出：
        SQLException - if (1) an empty rowset is added to the to this JoinRowSet object, (2) a match column has not been set for rowset, or (3) rowset violates the active JOIN
        另请参见：
        Joinable.setMatchColumn(int)

      • addRowSet

        void addRowSet(RowSet rowset,
             int columnIdx)
               throws SQLException
        Adds the given RowSet object to this JoinRowSet object and sets the designated column as the match column for the RowSet object. If the RowSet object is the first to be added to this JoinRowSet object, it forms the basis of the JOIN relationship to be established.

        This method should be used when RowSet does not already have a match column set.

        参数：
        rowset - the RowSet object that is to be added to this JoinRowSet object; it may implement the Joinable interface
        columnIdx - an int that identifies the column to become the match column
        抛出：
        SQLException - if (1) rowset is an empty rowset or (2) rowset violates the active JOIN
        另请参见：
        Joinable.unsetMatchColumn(int)

      • addRowSet

        void addRowSet(RowSet rowset,
             String columnName)
               throws SQLException
        Adds rowset to this JoinRowSet object and sets the designated column as the match column. If rowset is the first to be added to this JoinRowSet object, it forms the basis for the JOIN relationship to be established.

        This method should be used when the given RowSet object does not already have a match column.

        参数：
        rowset - the RowSet object that is to be added to this JoinRowSet object; it may implement the Joinable interface
        columnName - the String object giving the name of the column to be set as the match column
        抛出：
        SQLException - if (1) rowset is an empty rowset or (2) the match column for rowset does not satisfy the conditions of the JOIN

      • addRowSet

        void addRowSet(RowSet[] rowset,
             int[] columnIdx)
               throws SQLException
        Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column indexes. The first element in columnIdx is set as the match column for the first RowSet object in rowset, the second element of columnIdx is set as the match column for the second element in rowset, and so on.

        The first RowSet object added to this JoinRowSet object forms the basis for the JOIN relationship.

        This method should be used when the given RowSet object does not already have a match column.

        参数：
        rowset - an array of one or more RowSet objects to be added to the JOIN; it may implement the Joinable interface
        columnIdx - an array of int values indicating the index(es) of the columns to be set as the match columns for the RowSet objects in rowset
        抛出：
        SQLException - if (1) an empty rowset is added to this JoinRowSet object, (2) a match column is not set for a RowSet object in rowset, or (3) a RowSet object being added violates the active JOIN

      • addRowSet

        void addRowSet(RowSet[] rowset,
             String[] columnName)
               throws SQLException
        Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column names. The first element in columnName is set as the match column for the first RowSet object in rowset, the second element of columnName is set as the match column for the second element in rowset, and so on.

        The first RowSet object added to this JoinRowSet object forms the basis for the JOIN relationship.

        This method should be used when the given RowSet object(s) does not already have a match column.

        参数：
        rowset - an array of one or more RowSet objects to be added to the JOIN; it may implement the Joinable interface
        columnName - an array of String values indicating the names of the columns to be set as the match columns for the RowSet objects in rowset
        抛出：
        SQLException - if (1) an empty rowset is added to this JoinRowSet object, (2) a match column is not set for a RowSet object in rowset, or (3) a RowSet object being added violates the active JOIN

      • getRowSets

        Collection<?> getRowSets()
                         throws SQLException
        Returns a Collection object containing the RowSet objects that have been added to this JoinRowSet object. This should return the 'n' number of RowSet contained within the JOIN and maintain any updates that have occured while in this union.
        返回：
        a Collection object consisting of the RowSet objects added to this JoinRowSet object
        抛出：
        SQLException - if an error occurs generating the Collection object to be returned

      • getRowSetNames

        String[] getRowSetNames()
                        throws SQLException
        Returns a String array containing the names of the RowSet objects added to this JoinRowSet object.
        返回：
        a String array of the names of the RowSet objects in this JoinRowSet object
        抛出：
        SQLException - if an error occurs retrieving the names of the RowSet objects
        另请参见：
        CachedRowSet.setTableName(java.lang.String)

      • toCachedRowSet

        CachedRowSet toCachedRowSet()
                            throws SQLException
        Creates a new CachedRowSet object containing the data in this JoinRowSet object, which can be saved to a data source using the SyncProvider object for the CachedRowSet object.

        If any updates or modifications have been applied to the JoinRowSet the CachedRowSet returned by the method will not be able to persist it's changes back to the originating rows and tables in the in the datasource. The CachedRowSet instance returned should not contain modification data and it should clear all properties of it's originating SQL statement. An application should reset the SQL statement using the RowSet.setCommand method.

        In order to allow changes to be persisted back to the datasource to the originating tables, the acceptChanges method should be used and called on a JoinRowSet object instance. Implementations can leverage the internal data and update tracking in their implementations to interact with the SyncProvider to persist any changes.

        返回：
        a CachedRowSet containing the contents of the JoinRowSet
        抛出：
        SQLException - if an error occurs assembling the CachedRowSet object
        另请参见：
        RowSet, CachedRowSet, SyncProvider

      • supportsCrossJoin

        boolean supportsCrossJoin()
        Indicates if CROSS_JOIN is supported by a JoinRowSet implementation
        返回：
        true if the CROSS_JOIN is supported; false otherwise

      • supportsInnerJoin

        boolean supportsInnerJoin()
        Indicates if INNER_JOIN is supported by a JoinRowSet implementation
        返回：
        true is the INNER_JOIN is supported; false otherwise

      • supportsLeftOuterJoin

        boolean supportsLeftOuterJoin()
        Indicates if LEFT_OUTER_JOIN is supported by a JoinRowSet implementation
        返回：
        true is the LEFT_OUTER_JOIN is supported; false otherwise

      • supportsRightOuterJoin

        boolean supportsRightOuterJoin()
        Indicates if RIGHT_OUTER_JOIN is supported by a JoinRowSet implementation
        返回：
        true is the RIGHT_OUTER_JOIN is supported; false otherwise

      • supportsFullJoin

        boolean supportsFullJoin()
        Indicates if FULL_JOIN is supported by a JoinRowSet implementation
        返回：
        true is the FULL_JOIN is supported; false otherwise

      • setJoinType

        void setJoinType(int joinType)
                 throws SQLException
        Allow the application to adjust the type of JOIN imposed on tables contained within the JoinRowSet object instance. Implementations should throw a SQLException if they do not support a given JOIN type.
        参数：
        joinType - the standard JoinRowSet.XXX static field definition of a SQL JOIN to re-configure a JoinRowSet instance on the fly.
        抛出：
        SQLException - if an unsupported JOIN type is set
        另请参见：
        getJoinType()

      • getWhereClause

        String getWhereClause()
                      throws SQLException
        Return a SQL-like description of the WHERE clause being used in a JoinRowSet object. An implementation can describe the WHERE clause of the SQL JOIN by supplying a SQL strings description of JOIN or provide a textual description to assist applications using a JoinRowSet
        返回：
        whereClause a textual or SQL description of the logical WHERE clause used in the JoinRowSet instance
        抛出：
        SQLException - if an error occurs in generating a representation of the WHERE clause.

      • getJoinType

        int getJoinType()
                throws SQLException
        Returns a int describing the set SQL JOIN type governing this JoinRowSet instance. The returned type will be one of standard JoinRowSet types: CROSS_JOIN, INNER_JOIN, LEFT_OUTER_JOIN, RIGHT_OUTER_JOIN or FULL_JOIN.
        返回：
        joinType one of the standard JoinRowSet static field definitions of a SQL JOIN. JoinRowSet.INNER_JOIN is returned as the default JOIN type is no type has been explicitly set.
        抛出：
        SQLException - if an error occurs determining the SQL JOIN type supported by the JoinRowSet instance.
        另请参见：
        setJoinType(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Predicate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface Predicate

  • public interface Predicate
    The standard interface that provides the framework for all FilteredRowSet objects to describe their filters.

    1.0 Background

    The Predicate interface is a standard interface that applications can implement to define the filter they wish to apply to a a FilteredRowSet object. A FilteredRowSet object consumes implementations of this interface and enforces the constraints defined in the implementation of the method evaluate. A FilteredRowSet object enforces the filter constraints in a bi-directional manner: It outputs only rows that are within the constraints of the filter; and conversely, it inserts, modifies, or updates only rows that are within the constraints of the filter.

    2.0 Implementation Guidelines

    In order to supply a predicate for the FilteredRowSet. this interface must be implemented. At this time, the JDBC RowSet Implementations (JSR-114) does not specify any standard filters definitions. By specifying a standard means and mechanism for a range of filters to be defined and deployed with both the reference and vendor implementations of the FilteredRowSet interface, this allows for a flexible and application motivated implementations of Predicate to emerge.

    A sample implementation would look something like this:

    public class Range implements Predicate {

       private Object lo[];
       private Object hi[];
       private int idx[];

       public Range(Object[] lo, Object[] hi, int[] idx) {
          this.lo = lo;
          this.hi = hi;
          this.idx = idx;
       }

      public boolean evaluate(RowSet rs) {
          CachedRowSet crs = (CachedRowSet)rs;
          boolean bool1,bool2;

          // Check the present row determine if it lies
          // within the filtering criteria.

          for (int i = 0; i < idx.length; i++) {

              if ((rs.getObject(idx[i]) >= lo[i]) &&
                  (rs.getObject(idx[i]) >= hi[i]) {
                  bool1 = true; // within filter constraints
          } else {
            bool2 = true; // outside of filter constraints
          }
      }

      if (bool2) {
         return false;
      } else {
         return true;
      }
  }

    The example above implements a simple range predicate. Note, that implementations should but are not required to provider String and integer index based constructors to provide for JDBC RowSet Implementation applications that use both column identification conventions.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean evaluate(Object value, int column)
      This method is called by a FilteredRowSet object to check whether the value lies between the filtering criterion (or criteria if multiple constraints exist) set using the setFilter() method.
      boolean evaluate(Object value, String columnName)
      This method is called by the FilteredRowSet object to check whether the value lies between the filtering criteria set using the setFilter method.
      boolean evaluate(RowSet rs)
      This method is typically called a FilteredRowSet object internal methods (not public) that control the RowSet object's cursor moving from row to the next.

    • 方法详细信息

      • evaluate

        boolean evaluate(RowSet rs)
        This method is typically called a FilteredRowSet object internal methods (not public) that control the RowSet object's cursor moving from row to the next. In addition, if this internal method moves the cursor onto a row that has been deleted, the internal method will continue to ove the cursor until a valid row is found.
        返回：
        true if there are more rows in the filter; false otherwise

      • evaluate

        boolean evaluate(Object value,
               int column)
                 throws SQLException
        This method is called by a FilteredRowSet object to check whether the value lies between the filtering criterion (or criteria if multiple constraints exist) set using the setFilter() method.

        The FilteredRowSet object will use this method internally while inserting new rows to a FilteredRowSet instance.

        参数：
        value - An Object value which needs to be checked, whether it can be part of this FilterRowSet object.
        column - a int object that must match the SQL index of a column in this RowSet object. This must have been passed to Predicate as one of the columns for filtering while initializing a Predicate
        返回：
        true ifrow value lies within the filter; false otherwise
        抛出：
        SQLException - if the column is not part of filtering criteria

      • evaluate

        boolean evaluate(Object value,
               String columnName)
                 throws SQLException
        This method is called by the FilteredRowSet object to check whether the value lies between the filtering criteria set using the setFilter method.

        The FilteredRowSet object will use this method internally while inserting new rows to a FilteredRowSet instance.

        参数：
        value - An Object value which needs to be checked, whether it can be part of this FilterRowSet.
        columnName - a String object that must match the SQL name of a column in this RowSet, ignoring case. This must have been passed to Predicate as one of the columns for filtering while initializing a Predicate
        返回：
        true if value lies within the filter; false otherwise
        抛出：
        SQLException - if the column is not part of filtering criteria
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsdccunutooattloddBdTd


RowSetFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface RowSetFactory

  • public interface RowSetFactory
    An interface that defines the implementation of a factory that is used to obtain different types of RowSet implementations.
    从以下版本开始：
    1.7

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CachedRowSet createCachedRowSet()
      Creates a new instance of a CachedRowSet.
      FilteredRowSet createFilteredRowSet()
      Creates a new instance of a FilteredRowSet.
      JdbcRowSet createJdbcRowSet()
      Creates a new instance of a JdbcRowSet.
      JoinRowSet createJoinRowSet()
      Creates a new instance of a JoinRowSet.
      WebRowSet createWebRowSet()
      Creates a new instance of a WebRowSet.

    • 方法详细信息

      • createCachedRowSet

        CachedRowSet createCachedRowSet()
                                throws SQLException

        Creates a new instance of a CachedRowSet.

        返回：
        A new instance of a CachedRowSet.
        抛出：
        SQLException - if a CachedRowSet cannot be created.
        从以下版本开始：
        1.7

      • createFilteredRowSet

        FilteredRowSet createFilteredRowSet()
                                    throws SQLException

        Creates a new instance of a FilteredRowSet.

        返回：
        A new instance of a FilteredRowSet.
        抛出：
        SQLException - if a FilteredRowSet cannot be created.
        从以下版本开始：
        1.7

      • createJdbcRowSet

        JdbcRowSet createJdbcRowSet()
                            throws SQLException

        Creates a new instance of a JdbcRowSet.

        返回：
        A new instance of a JdbcRowSet.
        抛出：
        SQLException - if a JdbcRowSet cannot be created.
        从以下版本开始：
        1.7

      • createJoinRowSet

        JoinRowSet createJoinRowSet()
                            throws SQLException

        Creates a new instance of a JoinRowSet.

        返回：
        A new instance of a JoinRowSet.
        抛出：
        SQLException - if a JoinRowSet cannot be created.
        从以下版本开始：
        1.7

      • createWebRowSet

        WebRowSet createWebRowSet()
                          throws SQLException

        Creates a new instance of a WebRowSet.

        返回：
        A new instance of a WebRowSet.
        抛出：
        SQLException - if a WebRowSet cannot be created.
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aFveeenejecii eeetSSNalNba"cN"uRno


RowSetMetaDataImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset

类 RowSetMetaDataImpl

  • java.lang.Object
    • javax.sql.rowset.RowSetMetaDataImpl
  • 所有已实现的接口：
    Serializable, ResultSetMetaData, Wrapper, RowSetMetaData

    public class RowSetMetaDataImpl
extends Object
implements RowSetMetaData, Serializable
    Provides implementations for the methods that set and get metadata information about a RowSet object's columns. A RowSetMetaDataImpl object keeps track of the number of columns in the rowset and maintains an internal array of column attributes for each column.

    A RowSet object creates a RowSetMetaDataImpl object internally in order to set and retrieve information about its columns.

    NOTE: All metadata in a RowSetMetaDataImpl object should be considered as unavailable until the RowSet object that it describes is populated. Therefore, any RowSetMetaDataImpl method that retrieves information is defined as having unspecified behavior when it is called before the RowSet object contains data.

    另请参见：
    Serialized Form

    • 字段摘要

      • 字段 - 继承于接口 java.sql.ResultSetMetaData

        columnNoNulls, columnNullable, columnNullableUnknown

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSetMetaDataImpl()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getCatalogName(int columnIndex)
      Retrieves the catalog name of the table from which the value in the designated column was derived.
      String getColumnClassName(int columnIndex)
      Retrieves the fully-qualified name of the class in the Java programming language to which a value in the designated column will be mapped.
      int getColumnCount()
      Retrieves the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.
      int getColumnDisplaySize(int columnIndex)
      Retrieves the normal maximum width in chars of the designated column.
      String getColumnLabel(int columnIndex)
      Retrieves the the suggested column title for the designated column for use in printouts and displays.
      String getColumnName(int columnIndex)
      Retrieves the name of the designated column.
      int getColumnType(int columnIndex)
      Retrieves the type code (one of the java.sql.Types constants) for the SQL type of the value stored in the designated column.
      String getColumnTypeName(int columnIndex)
      Retrieves the DBMS-specific type name for values stored in the designated column.
      int getPrecision(int columnIndex)
      Retrieves the total number of digits for values stored in the designated column.
      int getScale(int columnIndex)
      Retrieves the number of digits to the right of the decimal point for values stored in the designated column.
      String getSchemaName(int columnIndex)
      Retrieves the schema name of the table from which the value in the designated column was derived.
      String getTableName(int columnIndex)
      Retrieves the name of the table from which the value in the designated column was derived.
      boolean isAutoIncrement(int columnIndex)
      Retrieves whether a value stored in the designated column is automatically numbered, and thus readonly.
      boolean isCaseSensitive(int columnIndex)
      Indicates whether the case of the designated column's name matters.
      boolean isCurrency(int columnIndex)
      Indicates whether a value stored in the designated column is a cash value.
      boolean isDefinitelyWritable(int columnIndex)
      Indicates whether a write operation on the designated column will definitely succeed.
      int isNullable(int columnIndex)
      Retrieves a constant indicating whether it is possible to store a NULL value in the designated column.
      boolean isReadOnly(int columnIndex)
      Indicates whether the designated column is definitely not writable, thus readonly.
      boolean isSearchable(int columnIndex)
      Indicates whether a value stored in the designated column can be used in a WHERE clause.
      boolean isSigned(int columnIndex)
      Indicates whether a value stored in the designated column is a signed number.
      boolean isWrapperFor(类<?> interfaces)
      Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does.
      boolean isWritable(int columnIndex)
      Indicates whether it is possible for a write operation on the designated column to succeed.
      void setAutoIncrement(int columnIndex, boolean property)
      Sets whether the designated column is automatically numbered, thus read-only, to the given boolean value.
      void setCaseSensitive(int columnIndex, boolean property)
      Sets whether the name of the designated column is case sensitive to the given boolean.
      void setCatalogName(int columnIndex, String catalogName)
      Sets the catalog name of the table from which the designated column was derived to catalogName.
      void setColumnCount(int columnCount)
      Sets to the given number the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.
      void setColumnDisplaySize(int columnIndex, int size)
      Sets the normal maximum number of chars in the designated column to the given number.
      void setColumnLabel(int columnIndex, String label)
      Sets the suggested column label for use in printouts and displays, if any, to label.
      void setColumnName(int columnIndex, String columnName)
      Sets the column name of the designated column to the given name.
      void setColumnType(int columnIndex, int SQLType)
      Sets the SQL type code for values stored in the designated column to the given type code from the class java.sql.Types.
      void setColumnTypeName(int columnIndex, String typeName)
      Sets the type name used by the data source for values stored in the designated column to the given type name.
      void setCurrency(int columnIndex, boolean property)
      Sets whether a value stored in the designated column is a cash value to the given boolean.
      void setNullable(int columnIndex, int property)
      Sets whether a value stored in the designated column can be set to NULL to the given constant from the interface ResultSetMetaData.
      void setPrecision(int columnIndex, int precision)
      Sets the total number of decimal digits in a value stored in the designated column to the given number.
      void setScale(int columnIndex, int scale)
      Sets the number of digits to the right of the decimal point in a value stored in the designated column to the given number.
      void setSchemaName(int columnIndex, String schemaName)
      Sets the designated column's table's schema name, if any, to schemaName.
      void setSearchable(int columnIndex, boolean property)
      Sets whether a value stored in the designated column can be used in a WHERE clause to the given boolean value.
      void setSigned(int columnIndex, boolean property)
      Sets whether a value stored in the designated column is a signed number to the given boolean.
      void setTableName(int columnIndex, String tableName)
      Sets the name of the table from which the designated column was derived to the given table name.
      <T> T unwrap(类<T> iface)
      Returns an object that implements the given interface to allow access to non-standard methods, or standard methods not exposed by the proxy.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowSetMetaDataImpl

        public RowSetMetaDataImpl()

    • 方法详细信息

      • setColumnCount

        public void setColumnCount(int columnCount)
                    throws SQLException
        Sets to the given number the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.
        指定者：
        setColumnCount in interface RowSetMetaData
        参数：
        columnCount - an int giving the number of columns in the RowSet object
        抛出：
        SQLException - if the given number is equal to or less than zero

      • setAutoIncrement

        public void setAutoIncrement(int columnIndex,
                    boolean property)
                      throws SQLException
        Sets whether the designated column is automatically numbered, thus read-only, to the given boolean value.
        指定者：
        setAutoIncrement in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns in the rowset, inclusive
        property - true if the given column is automatically incremented; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given index is out of bounds
        SQLException - if a database access error occurs

      • setCaseSensitive

        public void setCaseSensitive(int columnIndex,
                    boolean property)
                      throws SQLException
        Sets whether the name of the designated column is case sensitive to the given boolean.
        指定者：
        setCaseSensitive in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns in the rowset, inclusive
        property - true to indicate that the column name is case sensitive; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • setSearchable

        public void setSearchable(int columnIndex,
                 boolean property)
                   throws SQLException
        Sets whether a value stored in the designated column can be used in a WHERE clause to the given boolean value.
        指定者：
        setSearchable in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns in the rowset, inclusive
        property - true to indicate that a column value can be used in a WHERE clause; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds
        SQLException - if a database access error occurs

      • setCurrency

        public void setCurrency(int columnIndex,
               boolean property)
                 throws SQLException
        Sets whether a value stored in the designated column is a cash value to the given boolean.
        指定者：
        setCurrency in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive between 1 and the number of columns, inclusive
        property - true if the value is a cash value; false otherwise.
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds
        SQLException - if a database access error occurs

      • setNullable

        public void setNullable(int columnIndex,
               int property)
                 throws SQLException
        Sets whether a value stored in the designated column can be set to NULL to the given constant from the interface ResultSetMetaData.
        指定者：
        setNullable in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        property - one of the following ResultSetMetaData constants: columnNoNulls, columnNullable, or columnNullableUnknown
        抛出：
        SQLException - if a database access error occurs, the given column number is out of bounds, or the value supplied for the property parameter is not one of the following constants: ResultSetMetaData.columnNoNulls, ResultSetMetaData.columnNullable, or ResultSetMetaData.columnNullableUnknown
        SQLException - if a database access error occurs

      • setSigned

        public void setSigned(int columnIndex,
             boolean property)
               throws SQLException
        Sets whether a value stored in the designated column is a signed number to the given boolean.
        指定者：
        setSigned in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        property - true to indicate that a column value is a signed number; false to indicate that it is not
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • setColumnDisplaySize

        public void setColumnDisplaySize(int columnIndex,
                        int size)
                          throws SQLException
        Sets the normal maximum number of chars in the designated column to the given number.
        指定者：
        setColumnDisplaySize in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        size - the maximum size of the column in chars; must be 0 or more
        抛出：
        SQLException - if a database access error occurs, the given column number is out of bounds, or size is less than 0

      • setColumnLabel

        public void setColumnLabel(int columnIndex,
                  String label)
                    throws SQLException
        Sets the suggested column label for use in printouts and displays, if any, to label. If label is null, the column label is set to an empty string ("").
        指定者：
        setColumnLabel in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        label - the column label to be used in printouts and displays; if the column label is null, an empty String is set
        抛出：
        SQLException - if a database access error occurs or the given column index is out of bounds

      • setColumnName

        public void setColumnName(int columnIndex,
                 String columnName)
                   throws SQLException
        Sets the column name of the designated column to the given name.
        指定者：
        setColumnName in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        columnName - a String object indicating the column name; if the given name is null, an empty String is set
        抛出：
        SQLException - if a database access error occurs or the given column index is out of bounds

      • setSchemaName

        public void setSchemaName(int columnIndex,
                 String schemaName)
                   throws SQLException
        Sets the designated column's table's schema name, if any, to schemaName. If schemaName is null, the schema name is set to an empty string ("").
        指定者：
        setSchemaName in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        schemaName - the schema name for the table from which a value in the designated column was derived; may be an empty String or null
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • setPrecision

        public void setPrecision(int columnIndex,
                int precision)
                  throws SQLException
        Sets the total number of decimal digits in a value stored in the designated column to the given number.
        指定者：
        setPrecision in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        precision - the total number of decimal digits; must be 0 or more
        抛出：
        SQLException - if a database access error occurs, columnIndex is out of bounds, or precision is less than 0

      • setScale

        public void setScale(int columnIndex,
            int scale)
              throws SQLException
        Sets the number of digits to the right of the decimal point in a value stored in the designated column to the given number.
        指定者：
        setScale in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        scale - the number of digits to the right of the decimal point; must be zero or greater
        抛出：
        SQLException - if a database access error occurs, columnIndex is out of bounds, or scale is less than 0

      • setTableName

        public void setTableName(int columnIndex,
                String tableName)
                  throws SQLException
        Sets the name of the table from which the designated column was derived to the given table name.
        指定者：
        setTableName in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        tableName - the column's table name; may be null or an empty string
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • setCatalogName

        public void setCatalogName(int columnIndex,
                  String catalogName)
                    throws SQLException
        Sets the catalog name of the table from which the designated column was derived to catalogName. If catalogName is null, the catalog name is set to an empty string.
        指定者：
        setCatalogName in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        catalogName - the column's table's catalog name; if the catalogName is null, an empty String is set
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • setColumnType

        public void setColumnType(int columnIndex,
                 int SQLType)
                   throws SQLException
        Sets the SQL type code for values stored in the designated column to the given type code from the class java.sql.Types.
        指定者：
        setColumnType in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        SQLType - the designated column's SQL type, which must be one of the constants in the class java.sql.Types
        抛出：
        SQLException - if a database access error occurs, the given column number is out of bounds, or the column type specified is not one of the constants in java.sql.Types
        另请参见：
        Types

      • setColumnTypeName

        public void setColumnTypeName(int columnIndex,
                     String typeName)
                       throws SQLException
        Sets the type name used by the data source for values stored in the designated column to the given type name.
        指定者：
        setColumnTypeName in interface RowSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        typeName - the data source-specific type name; if typeName is null, an empty String is set
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnCount

        public int getColumnCount()
                   throws SQLException
        Retrieves the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.
        指定者：
        getColumnCount in interface ResultSetMetaData
        返回：
        the number of columns
        抛出：
        SQLException - if an error occurs determining the column count

      • isAutoIncrement

        public boolean isAutoIncrement(int columnIndex)
                        throws SQLException
        Retrieves whether a value stored in the designated column is automatically numbered, and thus readonly.
        指定者：
        isAutoIncrement in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if the column is automatically numbered; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isCaseSensitive

        public boolean isCaseSensitive(int columnIndex)
                        throws SQLException
        Indicates whether the case of the designated column's name matters.
        指定者：
        isCaseSensitive in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if the column name is case sensitive; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isSearchable

        public boolean isSearchable(int columnIndex)
                     throws SQLException
        Indicates whether a value stored in the designated column can be used in a WHERE clause.
        指定者：
        isSearchable in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if a value in the designated column can be used in a WHERE clause; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isCurrency

        public boolean isCurrency(int columnIndex)
                   throws SQLException
        Indicates whether a value stored in the designated column is a cash value.
        指定者：
        isCurrency in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if a value in the designated column is a cash value; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isNullable

        public int isNullable(int columnIndex)
               throws SQLException
        Retrieves a constant indicating whether it is possible to store a NULL value in the designated column.
        指定者：
        isNullable in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        a constant from the ResultSetMetaData interface; either columnNoNulls, columnNullable, or columnNullableUnknown
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isSigned

        public boolean isSigned(int columnIndex)
                 throws SQLException
        Indicates whether a value stored in the designated column is a signed number.
        指定者：
        isSigned in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if if a value in the designated column is a signed number; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnDisplaySize

        public int getColumnDisplaySize(int columnIndex)
                         throws SQLException
        Retrieves the normal maximum width in chars of the designated column.
        指定者：
        getColumnDisplaySize in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the maximum number of chars that can be displayed in the designated column
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnLabel

        public String getColumnLabel(int columnIndex)
                      throws SQLException
        Retrieves the the suggested column title for the designated column for use in printouts and displays.
        指定者：
        getColumnLabel in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the suggested column name to use in printouts and displays
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnName

        public String getColumnName(int columnIndex)
                     throws SQLException
        Retrieves the name of the designated column.
        指定者：
        getColumnName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the column name of the designated column
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getSchemaName

        public String getSchemaName(int columnIndex)
                     throws SQLException
        Retrieves the schema name of the table from which the value in the designated column was derived.
        指定者：
        getSchemaName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the schema name or an empty String if no schema name is available
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getPrecision

        public int getPrecision(int columnIndex)
                 throws SQLException
        Retrieves the total number of digits for values stored in the designated column.
        指定者：
        getPrecision in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the precision for values stored in the designated column
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getScale

        public int getScale(int columnIndex)
             throws SQLException
        Retrieves the number of digits to the right of the decimal point for values stored in the designated column.
        指定者：
        getScale in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the scale for values stored in the designated column
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getTableName

        public String getTableName(int columnIndex)
                    throws SQLException
        Retrieves the name of the table from which the value in the designated column was derived.
        指定者：
        getTableName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the table name or an empty String if no table name is available
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getCatalogName

        public String getCatalogName(int columnIndex)
                      throws SQLException
        Retrieves the catalog name of the table from which the value in the designated column was derived.
        指定者：
        getCatalogName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the catalog name of the column's table or an empty String if no catalog name is available
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnType

        public int getColumnType(int columnIndex)
                  throws SQLException
        Retrieves the type code (one of the java.sql.Types constants) for the SQL type of the value stored in the designated column.
        指定者：
        getColumnType in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        an int representing the SQL type of values stored in the designated column
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds
        另请参见：
        Types

      • getColumnTypeName

        public String getColumnTypeName(int columnIndex)
                         throws SQLException
        Retrieves the DBMS-specific type name for values stored in the designated column.
        指定者：
        getColumnTypeName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the type name used by the data source
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isReadOnly

        public boolean isReadOnly(int columnIndex)
                   throws SQLException
        Indicates whether the designated column is definitely not writable, thus readonly.
        指定者：
        isReadOnly in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if this RowSet object is read-Only and thus not updatable; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isWritable

        public boolean isWritable(int columnIndex)
                   throws SQLException
        Indicates whether it is possible for a write operation on the designated column to succeed. A return value of true means that a write operation may or may not succeed.
        指定者：
        isWritable in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if a write operation on the designated column may will succeed; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • isDefinitelyWritable

        public boolean isDefinitelyWritable(int columnIndex)
                             throws SQLException
        Indicates whether a write operation on the designated column will definitely succeed.
        指定者：
        isDefinitelyWritable in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        true if a write operation on the designated column will definitely succeed; false otherwise
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • getColumnClassName

        public String getColumnClassName(int columnIndex)
                          throws SQLException
        Retrieves the fully-qualified name of the class in the Java programming language to which a value in the designated column will be mapped. For example, if the value is an int, the class name returned by this method will be java.lang.Integer.

        If the value in the designated column has a custom mapping, this method returns the name of the class that implements SQLData. When the method ResultSet.getObject is called to retrieve a value from the designated column, it will create an instance of this class or one of its subclasses.

        指定者：
        getColumnClassName in interface ResultSetMetaData
        参数：
        columnIndex - the first column is 1, the second is 2, and so on; must be between 1 and the number of columns, inclusive
        返回：
        the fully-qualified name of the class in the Java programming language that would be used by the method RowSet.getObject to retrieve the value in the specified column. This is the class name used for custom mapping when there is a custom mapping.
        抛出：
        SQLException - if a database access error occurs or the given column number is out of bounds

      • unwrap

        public <T> T unwrap(类<T> iface)
         throws SQLException
        Returns an object that implements the given interface to allow access to non-standard methods, or standard methods not exposed by the proxy. The result may be either the object found to implement the interface or a proxy for that object. If the receiver implements the interface then that is the object. If the receiver is a wrapper and the wrapped object implements the interface then that is the object. Otherwise the object is the result of calling unwrap recursively on the wrapped object. If the receiver is not a wrapper and does not implement the interface, then an SQLException is thrown.
        指定者：
        unwrap in interface Wrapper
        参数：
        iface - A Class defining an interface that the result must implement.
        返回：
        an object that implements the interface. May be a proxy for the actual implementing object.
        抛出：
        SQLException - If no object found that implements the interface
        从以下版本开始：
        1.6

      • isWrapperFor

        public boolean isWrapperFor(类<?> interfaces)
                     throws SQLException
        Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does. Returns false otherwise. If this implements the interface then return true, else if this is a wrapper then return the result of recursively calling isWrapperFor on the wrapped object. If this does not implement the interface and is not a wrapper, return false. This method should be implemented as a low-cost operation compared to unwrap so that callers can use this method to avoid expensive unwrap calls that may fail. If this method returns true then calling unwrap with the same argument should succeed.
        指定者：
        isWrapperFor in interface Wrapper
        参数：
        interfaces - a Class defining an interface.
        返回：
        true if this implements the interface or directly or indirectly wraps an object that does.
        抛出：
        SQLException - if an error occurs while determining whether this is a wrapper for an object with the given interface.
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RowSetProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset

类 RowSetProvider

  • java.lang.Object
    • javax.sql.rowset.RowSetProvider

  • public class RowSetProvider
extends Object
    A factory API that enables applications to obtain a RowSetFactory implementation that can be used to create different types of RowSet implementations.

    Example:

     RowSetFactory aFactory = RowSetProvider.newFactory();
 CachedRowSet crs = aFactory.createCachedRowSet();
 ...
 RowSetFactory rsf = RowSetProvider.newFactory("com.sun.rowset.RowSetFactoryImpl", null);
 WebRowSet wrs = rsf.createWebRowSet();

    Tracing of this class may be enabled by setting the System property javax.sql.rowset.RowSetFactory.debug to any value but false.

    从以下版本开始：
    1.7

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | RowSetProvider()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static RowSetFactory newFactory()
      Creates a new instance of a RowSetFactory implementation.
      static RowSetFactory newFactory(String factoryClassName, ClassLoader cl)
      Creates a new instance of a RowSetFactory from the specified factory class name.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowSetProvider

        protected RowSetProvider()

    • 方法详细信息

      • newFactory

        public static RowSetFactory newFactory()
                                throws SQLException

        Creates a new instance of a RowSetFactory implementation. This method uses the following look up order to determine the RowSetFactory implementation class to load:

        • The System property javax.sql.rowset.RowSetFactory. For example:
          • -Djavax.sql.rowset.RowSetFactory=com.sun.rowset.RowSetFactoryImpl
        • The ServiceLoader API. The ServiceLoader API will look for a class name in the file META-INF/services/javax.sql.rowset.RowSetFactory in jars available to the runtime. For example, to have the the RowSetFactory implementation com.sun.rowset.RowSetFactoryImpl loaded, the entry in META-INF/services/javax.sql.rowset.RowSetFactory would be:
          • com.sun.rowset.RowSetFactoryImpl
        • Platform default RowSetFactory instance.

        Once an application has obtained a reference to a RowSetFactory, it can use the factory to obtain RowSet instances.

        返回：
        New instance of a RowSetFactory
        抛出：
        SQLException - if the default factory class cannot be loaded, instantiated. The cause will be set to actual Exception
        从以下版本开始：
        1.7
        另请参见：
        ServiceLoader

      • newFactory

        public static RowSetFactory newFactory(String factoryClassName,
                       ClassLoader cl)
                                throws SQLException

        Creates a new instance of a RowSetFactory from the specified factory class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a RowSetFactory it can use the factory to obtain RowSet instances.

        参数：
        factoryClassName - fully qualified factory class name that provides an implementation of javax.sql.rowset.RowSetFactory.
        cl - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a RowSetFactory
        抛出：
        SQLException - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        从以下版本开始：
        1.7
        另请参见：
        newFactory()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o<= l cl ><< >>>nrriiy leec


RowSetWarning

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset

类 RowSetWarning

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • javax.sql.rowset.RowSetWarning
  • 所有已实现的接口：
    Serializable, Iterable<Throwable>

    public class RowSetWarning
extends SQLException
    An extension of SQLException that provides information about database warnings set on RowSet objects. Warnings are silently chained to the object whose method call caused it to be reported. This class complements the SQLWarning class.

    Rowset warnings may be retrieved from JdbcRowSet, CachedRowSetTM, WebRowSet, FilteredRowSet, or JoinRowSet implementations. To retrieve the first warning reported on any RowSet implementation, use the method getRowSetWarnings defined in the JdbcRowSet interface or the CachedRowSet interface. To retrieve a warning chained to the first warning, use the RowSetWarning method getNextWarning. To retrieve subsequent warnings, call getNextWarning on each RowSetWarning object that is returned.

    The inherited methods getMessage, getSQLState, and getErrorCode retrieve information contained in a RowSetWarning object.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSetWarning()
      Constructs a default RowSetWarning object.
      RowSetWarning(String reason)
      Constructs a RowSetWarning object with the given value for the reason; SQLState defaults to null, and vendorCode defaults to 0.
      RowSetWarning(String reason, String SQLState)
      Constructs a RowSetWarning object initialized with the given values for the reason and SQLState.
      RowSetWarning(String reason, String SQLState, int vendorCode)
      Constructs a fully specified RowSetWarning object initialized with the given values for the reason, SQLState and vendorCode.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      RowSetWarning getNextWarning()
      Retrieves the warning chained to this RowSetWarning object.
      void setNextWarning(RowSetWarning warning)
      Sets warning as the next warning, that is, the warning chained to this RowSetWarning object.

      • 方法 - 继承于类 java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RowSetWarning

        public RowSetWarning(String reason)
        Constructs a RowSetWarning object with the given value for the reason; SQLState defaults to null, and vendorCode defaults to 0.
        参数：
        reason - a String object giving a description of the warning; if the String is null, this constructor behaves like the default (zero parameter) RowSetWarning constructor

      • RowSetWarning

        public RowSetWarning()
        Constructs a default RowSetWarning object. The reason defaults to null, SQLState defaults to null and vendorCode defaults to 0.

      • RowSetWarning

        public RowSetWarning(String reason,
             String SQLState)
        Constructs a RowSetWarning object initialized with the given values for the reason and SQLState. The vendor code defaults to 0. If the reason or SQLState parameters are null, this constructor behaves like the default (zero parameter) RowSetWarning constructor.
        参数：
        reason - a String giving a description of the warning;
        SQLState - an XOPEN code identifying the warning; if a non standard XOPEN SQLState is supplied, no exception is thrown.

      • RowSetWarning

        public RowSetWarning(String reason,
             String SQLState,
             int vendorCode)
        Constructs a fully specified RowSetWarning object initialized with the given values for the reason, SQLState and vendorCode. If the reason, or the SQLState parameters are null, this constructor behaves like the default (zero parameter) RowSetWarning constructor.
        参数：
        reason - a String giving a description of the warning;
        SQLState - an XOPEN code identifying the warning; if a non standard XPOEN SQLState is supplied, no exception is thrown.
        vendorCode - a database vendor-specific warning code

    • 方法详细信息

      • getNextWarning

        public RowSetWarning getNextWarning()
        Retrieves the warning chained to this RowSetWarning object.
        返回：
        the RowSetWarning object chained to this one; if no RowSetWarning object is chained to this one, null is returned (default value)
        另请参见：
        setNextWarning(javax.sql.rowset.RowSetWarning)

      • setNextWarning

        public void setNextWarning(RowSetWarning warning)
        Sets warning as the next warning, that is, the warning chained to this RowSetWarning object.
        参数：
        warning - the RowSetWarning object to be set as the next warning; if the RowSetWarning is null, this represents the finish point in the warning chain
        另请参见：
        getNextWarning()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lcan


Uses of Package javax.sql.rowset

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sql.rowset

  • Packages that use javax.sql.rowset
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
  • Classes in javax.sql.rowset used by javax.sql.rowset
    类与描述
    CachedRowSet
    The interface that all standard implementations of CachedRowSet must implement.
    FilteredRowSet
    The standard interface that all standard implementations of FilteredRowSet must implement.
    JdbcRowSet
    The standard interface that all standard implementations of JdbcRowSet must implement.
    Joinable
    1.0 Background
    JoinRowSet
    The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
    Predicate
    The standard interface that provides the framework for all FilteredRowSet objects to describe their filters.
    RowSetFactory
    An interface that defines the implementation of a factory that is used to obtain different types of RowSet implementations.
    RowSetWarning
    An extension of SQLException that provides information about database warnings set on RowSet objects.
    WebRowSet
    The standard interface that all implementations of a WebRowSet must implement.
  • Classes in javax.sql.rowset used by javax.sql.rowset.spi
    类与描述
    WebRowSet
    The standard interface that all implementations of a WebRowSet must implement.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt>>apaeStttRn /.aa.rxw


WebRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset

Interface WebRowSet

  • All Superinterfaces:
    AutoCloseable, CachedRowSet, Joinable, ResultSet, RowSet, Wrapper
    All Known Subinterfaces:
    FilteredRowSet, JoinRowSet

    public interface WebRowSet
extends CachedRowSet
    The standard interface that all implementations of a WebRowSet must implement.

    1.0 Overview

    The WebRowSetImpl provides the standard reference implementation, which may be extended if required.

    The standard WebRowSet XML Schema definition is available at the following URI:

       http://java.sun.com/xml/ns/jdbc/webrowset.xsd
    It describes the standard XML document format required when describing a RowSet object in XML and must be used be all standard implementations of the WebRowSet interface to ensure interoperability. In addition, the WebRowSet schema uses specific SQL/XML Schema annotations, thus ensuring greater cross platform inter-operability. This is an effort currently under way at the ISO organization. The SQL/XML definition is available at the following URI:
       http://standards.iso.org/iso/9075/2002/12/sqlxml
    The schema definition describes the internal data of a RowSet object in three distinct areas:
    • properties
      • These properties describe the standard synchronization provider properties in addition to the more general RowSet properties.

    • metadata
      • This describes the metadata associated with the tabular structure governed by a WebRowSet object. The metadata described is closely aligned with the metadata accessible in the underlying java.sql.ResultSet interface.

    • data
      • This describes the original data (the state of data since the last population or last synchronization of the WebRowSet object) and the current data. By keeping track of the delta between the original data and the current data, a WebRowSet maintains the ability to synchronize changes in its data back to the originating data source.

    2.0 WebRowSet States

    The following sections demonstrates how a WebRowSet implementation should use the XML Schema to describe update, insert, and delete operations and to describe the state of a WebRowSet object in XML.

    2.1 State 1 - Outputting a WebRowSet Object to XML

    In this example, a WebRowSet object is created and populated with a simple 2 column, 5 row table from a data source. Having the 5 rows in a WebRowSet object makes it possible to describe them in XML. The metadata describing the various standard JavaBeans properties as defined in the RowSet interface plus the standard properties defined in the CachedRowSetTM interface provide key details that describe WebRowSet properties. Outputting the WebRowSet object to XML using the standard writeXml methods describes the internal properties as follows:
     <properties>
       <command>select co1, col2 from test_table</command>
      <concurrency>1</concurrency>
      <datasource/>
      <escape-processing>true</escape-processing>
      <fetch-direction>0</fetch-direction>
      <fetch-size>0</fetch-size>
      <isolation-level>1</isolation-level>
      <key-columns/>
      <map/>
      <max-field-size>0</max-field-size>
      <max-rows>0</max-rows>
      <query-timeout>0</query-timeout>
      <read-only>false</read-only>
      <rowset-type>TRANSACTION_READ_UNCOMMITED</rowset-type>
      <show-deleted>false</show-deleted>
      <table-name/>
      <url>jdbc:thin:oracle</url>
      <sync-provider>
              <sync-provider-name>.com.rowset.provider.RIOptimisticProvider</sync-provider-name>
              <sync-provider-vendor>Oracle Corporation</sync-provider-vendor>
              <sync-provider-version>1.0</sync-provider-name>
              <sync-provider-grade>LOW</sync-provider-grade>
              <data-source-lock>NONE</data-source-lock>
      </sync-provider>
 </properties>
    The meta-data describing the make up of the WebRowSet is described in XML as detailed below. Note both columns are described between the column-definition tags.
     <metadata>
      <column-count>2</column-count>
      <column-definition>
              <column-index>1</column-index>
              <auto-increment>false</auto-increment>
              <case-sensitive>true</case-sensitive>
              <currency>false</currency>
              <nullable>1</nullable>
              <signed>false</signed>
              <searchable>true</searchable>
              <column-display-size>10</column-display-size>
              <column-label>COL1</column-label>
              <column-name>COL1</column-name>
              <schema-name/>
              <column-precision>10</column-precision>
              <column-scale>0</column-scale>
              <table-name/>
              <catalog-name/>
              <column-type>1</column-type>
              <column-type-name>CHAR</column-type-name>
      </column-definition>
      <column-definition>
              <column-index>2</column-index>
              <auto-increment>false</auto-increment>
              <case-sensitive>false</case-sensitive>
              <currency>false</currency>
              <nullable>1</nullable>
              <signed>true</signed>
              <searchable>true</searchable>
              <column-display-size>39</column-display-size>
              <column-label>COL2</column-label>
              <column-name>COL2</column-name>
              <schema-name/>
              <column-precision>38</column-precision>
              <column-scale>0</column-scale>
              <table-name/>
              <catalog-name/>
              <column-type>3</column-type>
              <column-type-name>NUMBER</column-type-name>
      </column-definition>
 </metadata>
    Having detailed how the properties and metadata are described, the following details how the contents of a WebRowSet object is described in XML. Note, that this describes a WebRowSet object that has not undergone any modifications since its instantiation. A currentRow tag is mapped to each row of the table structure that the WebRowSet object provides. A columnValue tag may contain either the stringData or binaryData tag, according to the SQL type that the XML value is mapping back to. The binaryData tag contains data in the Base64 encoding and is typically used for BLOB and CLOB type data.
     <data>
      <currentRow>
              <columnValue>
                      firstrow
              </columnValue>
              <columnValue>
                      1
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      secondrow
              </columnValue>
              <columnValue>
                      2
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      thirdrow
              </columnValue>
              <columnValue>
                      3
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      fourthrow
              </columnValue>
              <columnValue>
                      4
              </columnValue>
      </currentRow>
 </data>

    2.2 State 2 - Deleting a Row

    Deleting a row in a WebRowSet object involves simply moving to the row to be deleted and then calling the method deleteRow, as in any other RowSet object. The following two lines of code, in which wrs is a WebRowSet object, delete the third row.
         wrs.absolute(3);
     wrs.deleteRow();
    The XML description shows the third row is marked as a deleteRow, which eliminates the third row in the WebRowSet object.
     <data>
      <currentRow>
              <columnValue>
                      firstrow
              </columnValue>
              <columnValue>
                      1
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      secondrow
              </columnValue>
              <columnValue>
                      2
              </columnValue>
      </currentRow>
      <deleteRow>
              <columnValue>
                      thirdrow
              </columnValue>
              <columnValue>
                      3
              </columnValue>
      </deleteRow>
      <currentRow>
              <columnValue>
                      fourthrow
              </columnValue>
              <columnValue>
                      4
              </columnValue>
      </currentRow>
 </data>

    2.3 State 3 - Inserting a Row

    A WebRowSet object can insert a new row by moving to the insert row, calling the appropriate updater methods for each column in the row, and then calling the method insertRow.
     wrs.moveToInsertRow();
 wrs.updateString(1, "fifththrow");
 wrs.updateString(2, "5");
 wrs.insertRow();
    The following code fragment changes the second column value in the row just inserted. Note that this code applies when new rows are inserted right after the current row, which is why the method 下一个 moves the cursor to the correct row. Calling the method acceptChanges writes the change to the data source.
     wrs.moveToCurrentRow();
 wrs.next();
 wrs.updateString(2, "V");
 wrs.acceptChanges();
 :
    Describing this in XML demonstrates where the Java code inserts a new row and then performs an update on the newly inserted row on an individual field.
     <data>
      <currentRow>
              <columnValue>
                      firstrow
              </columnValue>
              <columnValue>
                      1
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      secondrow
              </columnValue>
              <columnValue>
                      2
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      newthirdrow
              </columnValue>
              <columnValue>
                      III
              </columnValue>
      </currentRow>
      <insertRow>
              <columnValue>
                      fifthrow
              </columnValue>
              <columnValue>
                      5
              </columnValue>
              <updateValue>
                      V
              </updateValue>
      </insertRow>
      <currentRow>
              <columnValue>
                      fourthrow
              </columnValue>
              <columnValue>
                      4
              </columnValue>
      </currentRow>
 </date>

    2.4 State 4 - Modifying a Row

    Modifying a row produces specific XML that records both the new value and the value that was replaced. The value that was replaced becomes the original value, and the new value becomes the current value. The following code moves the cursor to a specific row, performs some modifications, and updates the row when complete.
     wrs.absolute(5);
 wrs.updateString(1, "new4thRow");
 wrs.updateString(2, "IV");
 wrs.updateRow();
    In XML, this is described by the modifyRow tag. Both the original and new values are contained within the tag for original row tracking purposes.
     <data>
      <currentRow>
              <columnValue>
                      firstrow
              </columnValue>
              <columnValue>
                      1
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      secondrow
              </columnValue>
              <columnValue>
                      2
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      newthirdrow
              </columnValue>
              <columnValue>
                      III
              </columnValue>
      </currentRow>
      <currentRow>
              <columnValue>
                      fifthrow
              </columnValue>
              <columnValue>
                      5
              </columnValue>
      </currentRow>
      <modifyRow>
              <columnValue>
                      fourthrow
              </columnValue>
              <updateValue>
                      new4thRow
              </updateValue>
              <columnValue>
                      4
              </columnValue>
              <updateValue>
                      IV
              </updateValue>
      </modifyRow>
 </data>
    另请参见：
    JdbcRowSet, CachedRowSet, FilteredRowSet, JoinRowSet

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String PUBLIC_XML_SCHEMA
      The public identifier for the XML Schema definition that defines the XML tags and their valid values for a WebRowSet implementation.
      static String SCHEMA_SYSTEM_ID
      The URL for the XML Schema definition file that defines the XML tags and their valid values for a WebRowSet implementation.

      • 字段 - 继承于接口 javax.sql.rowset.CachedRowSet

        COMMIT_ON_ACCEPT_CHANGES

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void readXml(InputStream iStream)
      Reads a stream based XML input to populate this WebRowSet object.
      void readXml(Reader reader)
      Reads a WebRowSet object in its XML format from the given Reader object.
      void writeXml(OutputStream oStream)
      Writes the data, properties, and metadata for this WebRowSet object to the given OutputStream object in XML format.
      void writeXml(ResultSet rs, OutputStream oStream)
      Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given OutputStream object in XML format.
      void writeXml(ResultSet rs, Writer writer)
      Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given Writer object in XML format.
      void writeXml(Writer writer)
      Writes the data, properties, and metadata for this WebRowSet object to the given Writer object in XML format.

      • 方法 - 继承于接口 javax.sql.rowset.CachedRowSet

        acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

      • 方法 - 继承于接口 javax.sql.rowset.Joinable

        getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    • 字段详细信息

      • PUBLIC_XML_SCHEMA

        static final String PUBLIC_XML_SCHEMA
        The public identifier for the XML Schema definition that defines the XML tags and their valid values for a WebRowSet implementation.
        另请参见：
        Constant Field Values

      • SCHEMA_SYSTEM_ID

        static final String SCHEMA_SYSTEM_ID
        The URL for the XML Schema definition file that defines the XML tags and their valid values for a WebRowSet implementation.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • readXml

        void readXml(Reader reader)
             throws SQLException
        Reads a WebRowSet object in its XML format from the given Reader object.
        参数：
        reader - the java.io.Reader stream from which this WebRowSet object will be populated
        抛出：
        SQLException - if a database access error occurs

      • readXml

        void readXml(InputStream iStream)
             throws SQLException,
                    IOException
        Reads a stream based XML input to populate this WebRowSet object.
        参数：
        iStream - the java.io.InputStream from which this WebRowSet object will be populated
        抛出：
        SQLException - if a data source access error occurs
        IOException - if an IO exception occurs

      • writeXml

        void writeXml(ResultSet rs,
            Writer writer)
              throws SQLException
        Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given Writer object in XML format.

        NOTE: The WebRowSet cursor may be moved to write out the contents to the XML data source. If implemented in this way, the cursor must be returned to its position just prior to the writeXml() call.

        参数：
        rs - the ResultSet object with which to populate this WebRowSet object
        writer - the java.io.Writer object to write to.
        抛出：
        SQLException - if an error occurs writing out the rowset contents in XML format

      • writeXml

        void writeXml(ResultSet rs,
            OutputStream oStream)
              throws SQLException,
                     IOException
        Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given OutputStream object in XML format.

        NOTE: The WebRowSet cursor may be moved to write out the contents to the XML data source. If implemented in this way, the cursor must be returned to its position just prior to the writeXml() call.

        参数：
        rs - the ResultSet object with which to populate this WebRowSet object
        oStream - the java.io.OutputStream to write to
        抛出：
        SQLException - if a data source access error occurs
        IOException - if a IO exception occurs

      • writeXml

        void writeXml(Writer writer)
              throws SQLException
        Writes the data, properties, and metadata for this WebRowSet object to the given Writer object in XML format.
        参数：
        writer - the java.io.Writer stream to write to
        抛出：
        SQLException - if an error occurs writing out the rowset contents to XML

      • writeXml

        void writeXml(OutputStream oStream)
              throws SQLException,
                     IOException
        Writes the data, properties, and metadata for this WebRowSet object to the given OutputStream object in XML format.
        参数：
        oStream - the java.io.OutputStream stream to write to
        抛出：
        SQLException - if a data source access error occurs
        IOException - if a IO exception occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Uses of Class javax.sql.rowset.BaseRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.BaseRowSet

No usage of javax.sql.rowset.BaseRowSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>1�


Uses of Class javax.sql.rowset.RowSetMetaDataImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.RowSetMetaDataImpl

No usage of javax.sql.rowset.RowSetMetaDataImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g >/ctoenwww)saaw/etv


Uses of Class javax.sql.rowset.RowSetProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.RowSetProvider

No usage of javax.sql.rowset.RowSetProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s


Uses of Class javax.sql.rowset.RowSetWarning

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.RowSetWarning

  • Packages that use RowSetWarning
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of RowSetWarning in javax.sql.rowset

      Methods in javax.sql.rowset that return RowSetWarning
      修饰符与类型 方法与描述
      RowSetWarning RowSetWarning.getNextWarning()
      Retrieves the warning chained to this RowSetWarning object.
      RowSetWarning JdbcRowSet.getRowSetWarnings()
      Retrieves the first warning reported by calls on this JdbcRowSet object.
      RowSetWarning CachedRowSet.getRowSetWarnings()
      Retrieves the first warning reported by calls on this RowSet object.
      Methods in javax.sql.rowset with parameters of type RowSetWarning
      修饰符与类型 方法与描述
      void RowSetWarning.setNextWarning(RowSetWarning warning)
      Sets warning as the next warning, that is, the warning chained to this RowSetWarning object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j /ptlnicdys so>縫bgr


Uses of Interface javax.sql.rowset.CachedRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.CachedRowSet

  • Packages that use CachedRowSet
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of CachedRowSet in javax.sql.rowset

      Subinterfaces of CachedRowSet in javax.sql.rowset
      修饰符与类型 Interface and Description
      interface  FilteredRowSet
      The standard interface that all standard implementations of FilteredRowSet must implement.
      interface  JoinRowSet
      The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
      interface  WebRowSet
      The standard interface that all implementations of a WebRowSet must implement.
      Methods in javax.sql.rowset that return CachedRowSet
      修饰符与类型 方法与描述
      CachedRowSet RowSetFactory.createCachedRowSet()
      Creates a new instance of a CachedRowSet.
      CachedRowSet CachedRowSet.createCopy()
      Creates a RowSet object that is a deep copy of the data in this CachedRowSet object.
      CachedRowSet CachedRowSet.createCopyNoConstraints()
      Creates a CachedRowSet object that is a deep copy of this CachedRowSet object's data but is independent of it.
      CachedRowSet CachedRowSet.createCopySchema()
      Creates a CachedRowSet object that is an empty copy of this CachedRowSet object.
      CachedRowSet JoinRowSet.toCachedRowSet()
      Creates a new CachedRowSet object containing the data in this JoinRowSet object, which can be saved to a data source using the SyncProvider object for the CachedRowSet object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_.c)jt/-lo."pPa � o


Uses of Interface javax.sql.rowset.FilteredRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.FilteredRowSet

  • Packages that use FilteredRowSet
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of FilteredRowSet in javax.sql.rowset

      Methods in javax.sql.rowset that return FilteredRowSet
      修饰符与类型 方法与描述
      FilteredRowSet RowSetFactory.createFilteredRowSet()
      Creates a new instance of a FilteredRowSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s


Uses of Interface javax.sql.rowset.JdbcRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.JdbcRowSet

  • Packages that use JdbcRowSet
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of JdbcRowSet in javax.sql.rowset

      Methods in javax.sql.rowset that return JdbcRowSet
      修饰符与类型 方法与描述
      JdbcRowSet RowSetFactory.createJdbcRowSet()
      Creates a new instance of a JdbcRowSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s><>


Uses of Interface javax.sql.rowset.Joinable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.Joinable

  • Packages that use Joinable
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of Joinable in javax.sql.rowset

      Subinterfaces of Joinable in javax.sql.rowset
      修饰符与类型 Interface and Description
      interface  CachedRowSet
      The interface that all standard implementations of CachedRowSet must implement.
      interface  FilteredRowSet
      The standard interface that all standard implementations of FilteredRowSet must implement.
      interface  JdbcRowSet
      The standard interface that all standard implementations of JdbcRowSet must implement.
      interface  JoinRowSet
      The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
      interface  WebRowSet
      The standard interface that all implementations of a WebRowSet must implement.
      Methods in javax.sql.rowset with parameters of type Joinable
      修饰符与类型 方法与描述
      void JoinRowSet.addRowSet(Joinable rowset)
      Adds the given RowSet object to this JoinRowSet object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f"m"b>r/3/h/bns=a.agxo


Uses of Interface javax.sql.rowset.JoinRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.JoinRowSet

  • Packages that use JoinRowSet
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of JoinRowSet in javax.sql.rowset

      Methods in javax.sql.rowset that return JoinRowSet
      修饰符与类型 方法与描述
      JoinRowSet RowSetFactory.createJoinRowSet()
      Creates a new instance of a JoinRowSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eetxn jcaeeeetbbd


Uses of Interface javax.sql.rowset.Predicate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.Predicate

  • Packages that use Predicate
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of Predicate in javax.sql.rowset

      Methods in javax.sql.rowset that return Predicate
      修饰符与类型 方法与描述
      Predicate FilteredRowSet.getFilter()
      Retrieves the active filter for this FilteredRowSet object.
      Methods in javax.sql.rowset with parameters of type Predicate
      修饰符与类型 方法与描述
      void FilteredRowSet.setFilter(Predicate p)
      Applies the given Predicate object to this FilteredRowSet object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d" Enp&sad/tcP 癮


Uses of Interface javax.sql.rowset.RowSetFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.RowSetFactory

  • Packages that use RowSetFactory
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.

    • Uses of RowSetFactory in javax.sql.rowset

      Methods in javax.sql.rowset that return RowSetFactory
      修饰符与类型 方法与描述
      static RowSetFactory RowSetProvider.newFactory()
      Creates a new instance of a RowSetFactory implementation.
      static RowSetFactory RowSetProvider.newFactory(String factoryClassName, ClassLoader cl)
      Creates a new instance of a RowSetFactory from the specified factory class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alnurrsraud is媲r蔮b舒


Uses of Interface javax.sql.rowset.WebRowSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.WebRowSet

  • Packages that use WebRowSet
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of WebRowSet in javax.sql.rowset

      Subinterfaces of WebRowSet in javax.sql.rowset
      修饰符与类型 Interface and Description
      interface  FilteredRowSet
      The standard interface that all standard implementations of FilteredRowSet must implement.
      interface  JoinRowSet
      The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
      Methods in javax.sql.rowset that return WebRowSet
      修饰符与类型 方法与描述
      WebRowSet RowSetFactory.createWebRowSet()
      Creates a new instance of a WebRowSet.

    • Uses of WebRowSet in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi with parameters of type WebRowSet
      修饰符与类型 方法与描述
      void XmlReader.readXML(WebRowSet caller, Reader reader)
      Reads and parses the given WebRowSet object from the given input stream in XML format.
      void XmlWriter.writeXML(WebRowSet caller, Writer writer)
      Writes the given WebRowSet object to the specified java.io.Writer output stream as an XML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l&a_ =cv ns=ht< t�>>


javax.sql.rowset.serial

Classes

  • SerialArray
  • SerialBlob
  • SerialClob
  • SerialDatalink
  • SerialJavaObject
  • SerialRef
  • SerialStruct
  • SQLInputImpl
  • SQLOutputImpl

Exceptions

  • SerialException


javax.sql.rowset.serial

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sql.rowset.serial

Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.

请参见： 描述

  • Class Summary
    类 描述
    SerialArray
    A serialized version of an Array object, which is the mapping in the Java programming language of an SQL ARRAY value.
    SerialBlob
    A serialized mapping in the Java programming language of an SQL BLOB value.
    SerialClob
    A serialized mapping in the Java programming language of an SQL CLOB value.
    SerialDatalink
    A serialized mapping in the Java programming language of an SQL DATALINK value.
    SerialJavaObject
    A serializable mapping in the Java programming language of an SQL JAVA_OBJECT value.
    SerialRef
    A serialized mapping of a Ref object, which is the mapping in the Java programming language of an SQL REF value.
    SerialStruct
    A serialized mapping in the Java programming language of an SQL structured type.
    SQLInputImpl
    An input stream used for custom mapping user-defined types (UDTs).
    SQLOutputImpl
    The output stream for writing the attributes of a custom-mapped user-defined type (UDT) back to the database.
  • Exception Summary
    Exception 描述
    SerialException
    Indicates and an error with the serialization or de-serialization of SQL types such as BLOB, CLOB, STRUCT or ARRAY in addition to SQL types such as DATALINK and JAVAOBJECT

软件包 javax.sql.rowset.serial Description

Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.

Standard JDBC RowSet implementations may use these utility classes to assist in the serialization of disconnected RowSet objects. This is useful when transmitting a disconnected RowSet object over the wire to a different VM or across layers within an application.

1.0 SerialArray

A serializable mapping in the Java programming language of an SQL ARRAY value.

The SerialArray class provides a constructor for creating a SerialArray instance from an Array object, methods for getting the base type and the SQL name for the base type, and methods for copying all or part of a SerialArray object.

2.0 SerialBlob

A serializable mapping in the Java programming language of an SQL BLOB value.

The SerialBlob class provides a constructor for creating an instance from a Blob object. Note that the Blob object should have brought the SQL BLOB value's data over to the client before a SerialBlob object is constructed from it. The data of an SQL BLOB value can be materialized on the client as an array of bytes (using the method Blob.getBytes) or as a stream of uninterpreted bytes (using the method Blob.getBinaryStream).

SerialBlob methods make it possible to make a copy of a SerialBlob object as an array of bytes or as a stream. They also make it possible to locate a given pattern of bytes or a Blob object within a SerialBlob object.

3.0 SerialClob

A serializable mapping in the Java programming language of an SQL CLOB value.

The SerialClob class provides a constructor for creating an instance from a Clob object. Note that the Clob object should have brought the SQL CLOB value's data over to the client before a SerialClob object is constructed from it. The data of an SQL CLOB value can be materialized on the client as a stream of Unicode characters.

SerialClob methods make it possible to get a substring from a SerialClob object or to locate the start of a pattern of characters.

5.0 SerialDatalink

A serializable mapping in the Java programming language of an SQL DATALINK value. A DATALINK value references a file outside of the underlying data source that the the originating data source manages.

RowSet implementations can use the method RowSet.getURL() to retrieve a java.net.URL object, which can be used to manipulate the external data.

    java.net.URL url = rowset.getURL(1);

6.0 SerialJavaObject

A serializable mapping in the Java programming language of an SQL JAVA_OBJECT value. Assuming the Java object instance implements the Serializable interface, this simply wraps the serialization process.

If however, the serialization is not possible in the case where the Java object is not immediately serializable, this class will attempt to serialize all non static members to permit the object instance state to be serialized. Static or transient fields cannot be serialized and attempting to do so will result in a SerialException being thrown.

7.0 SerialRef

A serializable mapping between the SQL REF type and the Java programming language.

The SerialRef class provides a constructor for creating a SerialRef instance from a Ref type and provides methods for getting and setting the Ref object type.

8.0 SerialStruct

A serializable mapping in the Java programming language of an SQL structured type. Each attribute that is not already serializable is mapped to a serializable form, and if an attribute is itself a structured type, each of its attributes that is not already serializable is mapped to a serializable form.

In addition, if a Map object is passed to one of the constructors or to the method getAttributes, the structured type is custom mapped according to the mapping specified in the Map object.
The SerialStruct class provides a constructor for creating an instance from a Struct object, a method for retrieving the SQL type name of the SQL structured type in the database, and methods for retrieving its attribute values.

9.0 SQLInputImpl

An input stream used for custom mapping user-defined types (UDTs). An SQLInputImpl object is an input stream that contains a stream of values that are the attributes of a UDT. This class is used by the driver behind the scenes when the method getObject is called on an SQL structured or distinct type that has a custom mapping; a programmer never invokes SQLInputImpl methods directly.

The SQLInputImpl class provides a set of reader methods analogous to the ResultSet getter methods. These methods make it possible to read the values in an SQLInputImpl object. The method wasNull is used to determine whether the the last value read was SQL NULL.

When a constructor or getter method that takes a Map object is called, the JDBC driver calls the method SQLData.getSQLType to determine the SQL type of the UDT being custom mapped. The driver creates an instance of SQLInputImpl, populating it with the attributes of the UDT. The driver then passes the input stream to the method SQLData.readSQL, which in turn calls the SQLInputImpl methods to read the attributes from the input stream.

10.0 SQLOutputImpl

The output stream for writing the attributes of a custom mapped user-defined type (UDT) back to the database. The driver uses this interface internally, and its methods are never directly invoked by an application programmer.

When an application calls the method PreparedStatement.setObject, the driver checks to see whether the value to be written is a UDT with a custom mapping. If it is, there will be an entry in a type map containing the Class object for the class that implements SQLData for this UDT. If the value to be written is an instance of SQLData, the driver will create an instance of SQLOutputImpl and pass it to the method SQLData.writeSQL. The method writeSQL in turn calls the appropriate SQLOutputImpl writer methods to write data from the SQLData object to the SQLOutputImpl output stream as the representation of an SQL user-defined type.

Custom Mapping

The JDBC API provides mechanisms for mapping an SQL structured type or DISTINCT type to the Java programming language. Typically, a structured type is mapped to a class, and its attributes are mapped to fields in the class. (A DISTINCT type can thought of as having one attribute.) However, there are many other possibilities, and there may be any number of different mappings.

A programmer defines the mapping by implementing the interface SQLData. For example, if an SQL structured type named AUTHORS has the attributes NAME, TITLE, and PUBLISHER, it could be mapped to a Java class named Authors. The Authors class could have the fields name, title, and publisher, to which the attributes of AUTHORS are mapped. In such a case, the implementation of SQLData could look like the following:

   public class Authors implements SQLData {
       public String name;
       public String title;
       public String publisher;

       private String sql_type;
       public String getSQLTypeName() {
           return sql_type;
       }

       public void readSQL(SQLInput stream, String type)
                                  throws SQLException  {
           sql_type = type;
           name = stream.readString();
           title = stream.readString();
           publisher = stream.readString();
       }

       public void writeSQL(SQLOutput stream) throws SQLException {
           stream.writeString(name);
           stream.writeString(title);
           stream.writeString(publisher);
       }
   }
A java.util.Map object is used to associate the SQL structured type with its mapping to the class Authors. The following code fragment shows how a Map object might be created and given an entry associating AUTHORS and Authors.
    java.util.Map map = new java.util.HashMap();
    map.put("SCHEMA_NAME.AUTHORS", Class.forName("Authors");
The Map object map now contains an entry with the fully qualified name of the SQL structured type and the 类 object for the class Authors. It can be passed to a method to tell the driver how to map AUTHORS to Authors.

For a disconnected RowSet object, custom mapping can be done only when a Map object is passed to the method or constructor that will be doing the custom mapping. The situation is different for connected RowSet objects because they maintain a connection with the data source. A method that does custom mapping and is called by a disconnected RowSet object may use the Map object that is associated with the Connection object being used. So, in other words, if no map is specified, the connection's type map can be used by default.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn rgoidcsn yc/< ed


javax.sql.rowset.serial Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sql.rowset.serial

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sql.rowset.serial.SerialArray (implements java.sql.Array, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialBlob (implements java.sql.Blob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialClob (implements java.sql.Clob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialDatalink (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialJavaObject (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialRef (implements java.lang.Cloneable, java.sql.Ref, java.io.Serializable)
    • javax.sql.rowset.serial.SerialStruct (implements java.lang.Cloneable, java.io.Serializable, java.sql.Struct)
    • javax.sql.rowset.serial.SQLInputImpl (implements java.sql.SQLInput)
    • javax.sql.rowset.serial.SQLOutputImpl (implements java.sql.SQLOutput)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.serial.SerialException
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

usam gvaaaaeniiu.)U1a


SerialArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialArray

  • java.lang.Object
    • javax.sql.rowset.serial.SerialArray
  • 所有已实现的接口：
    Serializable, Cloneable, Array

    public class SerialArray
extends Object
implements Array, Serializable, Cloneable
    A serialized version of an Array object, which is the mapping in the Java programming language of an SQL ARRAY value.

    The SerialArray class provides a constructor for creating a SerialArray instance from an Array object, methods for getting the base type and the SQL name for the base type, and methods for copying all or part of a SerialArray object.

    Note: In order for this class to function correctly, a connection to the data source must be available in order for the SQL Array object to be materialized (have all of its elements brought to the client server) if necessary. At this time, logical pointers to the data in the data source, such as locators, are not currently supported.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialArray(Array array)
      Constructs a new SerialArray object from the given Array object.
      SerialArray(Array array, Map<String,类<?>> map)
      Constructs a new SerialArray object from the given Array object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void free()
      This method frees the Array object and releases the resources that it holds.
      Object getArray()
      Returns a new array that is a copy of this SerialArray object.
      Object getArray(long index, int count)
      Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.
      Object getArray(long index, int count, Map<String,类<?>> map)
      Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.
      Object getArray(Map<String,类<?>> map)
      Returns a new array that is a copy of this SerialArray object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.
      int getBaseType()
      Retrieves the SQL type of the elements in this SerialArray object.
      String getBaseTypeName()
      Retrieves the DBMS-specific type name for the elements in this SerialArray object.
      ResultSet getResultSet()
      Retrieves a ResultSet object that contains all of the elements in the ARRAY value that this SerialArray object represents.
      ResultSet getResultSet(long index, int count)
      Retrieves a ResultSet object holding the elements of the subarray that starts at index index and contains up to count successive elements.
      ResultSet getResultSet(long index, int count, Map<String,类<?>> map)
      Retrieves a result set holding the elements of the subarray that starts at Retrieves a ResultSet object that contains a subarray of the elements in this SerialArray object, starting at index index and containing up to count successive elements.
      ResultSet getResultSet(Map<String,类<?>> map)
      Retrieves a ResultSet object that contains all of the elements of the SQL ARRAY value represented by this SerialArray object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialArray

        public SerialArray(Array array,
           Map<String,类<?>> map)
            throws SerialException,
                   SQLException
        Constructs a new SerialArray object from the given Array object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

        This method does custom mapping if the array elements are a UDT and the given type map has an entry for that UDT. Custom mapping is recursive, meaning that if, for instance, an element of an SQL structured type is an SQL structured type that itself has an element that is an SQL structured type, each structured type that has a custom mapping will be mapped according to the given type map.

        The new SerialArray object contains the same elements as the Array object from which it is built, except when the base type is the SQL type STRUCT, ARRAY, BLOB, CLOB, DATALINK or JAVA_OBJECT. In this case, each element in the new SerialArray object is the appropriate serialized form, that is, a SerialStruct, SerialArray, SerialBlob, SerialClob, SerialDatalink, or SerialJavaObject object.

        Note: (1) The Array object from which a SerialArray object is created must have materialized the SQL ARRAY value's data on the client before it is passed to the constructor. Otherwise, the new SerialArray object will contain no data.

        Note: (2) If the Array contains java.sql.Types.JAVA_OBJECT types, the SerialJavaObject constructor is called where checks are made to ensure this object is serializable.

        Note: (3) The Array object supplied to this constructor cannot return null for any Array.getArray() methods. SerialArray cannot serialize null array values.

        参数：
        array - the Array object to be serialized
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT (an SQL structured type or distinct type) and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped. The map parameter does not have any effect for Blob, Clob, DATALINK, or JAVA_OBJECT types.
        抛出：
        SerialException - if an error occurs serializing the Array object
        SQLException - if a database access error occurs or if the array or the map values are null

      • SerialArray

        public SerialArray(Array array)
            throws SerialException,
                   SQLException
        Constructs a new SerialArray object from the given Array object.

        This constructor does not do custom mapping. If the base type of the array is an SQL structured type and custom mapping is desired, the constructor SerialArray(Array array, Map map) should be used.

        The new SerialArray object contains the same elements as the Array object from which it is built, except when the base type is the SQL type BLOB, CLOB, DATALINK or JAVA_OBJECT. In this case, each element in the new SerialArray object is the appropriate serialized form, that is, a SerialBlob, SerialClob, SerialDatalink, or SerialJavaObject object.

        Note: (1) The Array object from which a SerialArray object is created must have materialized the SQL ARRAY value's data on the client before it is passed to the constructor. Otherwise, the new SerialArray object will contain no data.

        Note: (2) The Array object supplied to this constructor cannot return null for any Array.getArray() methods. SerialArray cannot serialize null array values.

        参数：
        array - the Array object to be serialized
        抛出：
        SerialException - if an error occurs serializing the Array object
        SQLException - if a database access error occurs or the array parameter is null.

    • 方法详细信息

      • free

        public void free()
          throws SQLException
        This method frees the Array object and releases the resources that it holds. The object is invalid once the free method is called.

        After free has been called, any attempt to invoke a method other than free will result in a SQLException being thrown. If free is called multiple times, the subsequent calls to free are treated as a no-op.

        指定者：
        free in interface Array
        抛出：
        SQLException - if an error occurs releasing the Array's resources
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
        从以下版本开始：
        1.6

      • getArray

        public Object getArray()
                throws SerialException
        Returns a new array that is a copy of this SerialArray object.
        指定者：
        getArray in interface Array
        返回：
        a copy of this SerialArray object as an Object in the Java programming language
        抛出：
        SerialException - if an error occurs retrieving a copy of this SerialArray object

      • getArray

        public Object getArray(Map<String,类<?>> map)
                throws SerialException
        Returns a new array that is a copy of this SerialArray object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

        This method does custom mapping if the array elements are a UDT and the given type map has an entry for that UDT. Custom mapping is recursive, meaning that if, for instance, an element of an SQL structured type is an SQL structured type that itself has an element that is an SQL structured type, each structured type that has a custom mapping will be mapped according to the given type map.

        指定者：
        getArray in interface Array
        参数：
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        a copy of this SerialArray object as an Object in the Java programming language
        抛出：
        SerialException - if an error occurs

      • getArray

        public Object getArray(long index,
              int count)
                throws SerialException
        Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.
        指定者：
        getArray in interface Array
        参数：
        index - the index into this SerialArray object of the first element to be copied; the index of the first element is 0
        count - the number of consecutive elements to be copied, starting at the given index
        返回：
        a copy of the designated elements in this SerialArray object as an Object in the Java programming language
        抛出：
        SerialException - if an error occurs

      • getArray

        public Object getArray(long index,
              int count,
              Map<String,类<?>> map)
                throws SerialException
        Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.

        This method does custom mapping if the array elements are a UDT and the given type map has an entry for that UDT. Custom mapping is recursive, meaning that if, for instance, an element of an SQL structured type is an SQL structured type that itself has an element that is an SQL structured type, each structured type that has a custom mapping will be mapped according to the given type map.

        指定者：
        getArray in interface Array
        参数：
        index - the index into this SerialArray object of the first element to be copied; the index of the first element in the array is 0
        count - the number of consecutive elements to be copied, starting at the given index
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        a copy of the designated elements in this SerialArray object as an Object in the Java programming language
        抛出：
        SerialException - if an error occurs

      • getBaseType

        public int getBaseType()
                throws SerialException
        Retrieves the SQL type of the elements in this SerialArray object. The int returned is one of the constants in the class java.sql.Types.
        指定者：
        getBaseType in interface Array
        返回：
        one of the constants in java.sql.Types, indicating the SQL type of the elements in this SerialArray object
        抛出：
        SerialException - if an error occurs

      • getBaseTypeName

        public String getBaseTypeName()
                       throws SerialException
        Retrieves the DBMS-specific type name for the elements in this SerialArray object.
        指定者：
        getBaseTypeName in interface Array
        返回：
        the SQL type name used by the DBMS for the base type of this SerialArray object
        抛出：
        SerialException - if an error occurs

      • getResultSet

        public ResultSet getResultSet(long index,
                     int count)
                       throws SerialException
        Retrieves a ResultSet object holding the elements of the subarray that starts at index index and contains up to count successive elements. This method uses the connection's type map to map the elements of the array if the map contains an entry for the base type. Otherwise, the standard mapping is used.
        指定者：
        getResultSet in interface Array
        参数：
        index - the index into this SerialArray object of the first element to be copied; the index of the first element in the array is 0
        count - the number of consecutive elements to be copied, starting at the given index
        返回：
        a ResultSet object containing the designated elements in this SerialArray object, with a separate row for each element
        抛出：
        SerialException, - which in turn throws an UnsupportedOperationException, if this method is called
        SerialException

      • getResultSet

        public ResultSet getResultSet(Map<String,类<?>> map)
                       throws SerialException
        Retrieves a ResultSet object that contains all of the elements of the SQL ARRAY value represented by this SerialArray object. This method uses the specified map for type map customizations unless the base type of the array does not match a user-defined type (UDT) in map, in which case it uses the standard mapping. This version of the method getResultSet uses either the given type map or the standard mapping; it never uses the type map associated with the connection.
        指定者：
        getResultSet in interface Array
        参数：
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        a ResultSet object containing all of the elements in this SerialArray object, with a separate row for each element
        抛出：
        SerialException, - which in turn throws an UnsupportedOperationException, if this method is called
        SerialException

      • getResultSet

        public ResultSet getResultSet()
                       throws SerialException
        Retrieves a ResultSet object that contains all of the elements in the ARRAY value that this SerialArray object represents. If appropriate, the elements of the array are mapped using the connection's type map; otherwise, the standard mapping is used.
        指定者：
        getResultSet in interface Array
        返回：
        a ResultSet object containing all of the elements in this SerialArray object, with a separate row for each element
        抛出：
        SerialException - if called, which in turn throws an UnsupportedOperationException, if this method is called

      • getResultSet

        public ResultSet getResultSet(long index,
                     int count,
                     Map<String,类<?>> map)
                       throws SerialException
        Retrieves a result set holding the elements of the subarray that starts at Retrieves a ResultSet object that contains a subarray of the elements in this SerialArray object, starting at index index and containing up to count successive elements. This method uses the specified map for type map customizations unless the base type of the array does not match a user-defined type (UDT) in map, in which case it uses the standard mapping. This version of the method getResultSet uses either the given type map or the standard mapping; it never uses the type map associated with the connection.
        指定者：
        getResultSet in interface Array
        参数：
        index - the index into this SerialArray object of the first element to be copied; the index of the first element in the array is 0
        count - the number of consecutive elements to be copied, starting at the given index
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        a ResultSet object containing the designated elements in this SerialArray object, with a separate row for each element
        抛出：
        SerialException - if called, which in turn throws an UnsupportedOperationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SerialBlob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialBlob

  • java.lang.Object
    • javax.sql.rowset.serial.SerialBlob
  • 所有已实现的接口：
    Serializable, Cloneable, Blob

    public class SerialBlob
extends Object
implements Blob, Serializable, Cloneable
    A serialized mapping in the Java programming language of an SQL BLOB value.

    The SerialBlob class provides a constructor for creating an instance from a Blob object. Note that the Blob object should have brought the SQL BLOB value's data over to the client before a SerialBlob object is constructed from it. The data of an SQL BLOB value can be materialized on the client as an array of bytes (using the method Blob.getBytes) or as a stream of uninterpreted bytes (using the method Blob.getBinaryStream).

    SerialBlob methods make it possible to make a copy of a SerialBlob object as an array of bytes or as a stream. They also make it possible to locate a given pattern of bytes or a Blob object within a SerialBlob object and to update or truncate a Blob object.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialBlob(Blob blob)
      Constructs a SerialBlob object that is a serialized version of the given Blob object.
      SerialBlob(byte[] b)
      Constructs a SerialBlob object that is a serialized version of the given byte array.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void free()
      This method frees the Blob object and releases the resources that it holds.
      InputStream getBinaryStream()
      Returns this SerialBlob object as an input stream.
      InputStream getBinaryStream(long pos, long length)
      Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.
      byte[] getBytes(long pos, int length)
      Copies the specified number of bytes, starting at the given position, from this SerialBlob object to another array of bytes.
      long length()
      Retrieves the number of bytes in this SerialBlob object's array of bytes.
      long position(Blob pattern, long start)
      Returns the position in this SerialBlob object where the given Blob object begins, starting the search at the specified position.
      long position(byte[] pattern, long start)
      Returns the position in this SerialBlob object where the given pattern of bytes begins, starting the search at the specified position.
      OutputStream setBinaryStream(long pos)
      Retrieves a stream that can be used to write to the BLOB value that this Blob object represents.
      int setBytes(long pos, byte[] bytes)
      Writes the given array of bytes to the BLOB value that this Blob object represents, starting at position pos, and returns the number of bytes written.
      int setBytes(long pos, byte[] bytes, int offset, int length)
      Writes all or part of the given byte array to the BLOB value that this Blob object represents and returns the number of bytes written.
      void truncate(long length)
      Truncates the BLOB value that this Blob object represents to be len bytes in length.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialBlob

        public SerialBlob(byte[] b)
           throws SerialException,
                  SQLException
        Constructs a SerialBlob object that is a serialized version of the given byte array.

        The new SerialBlob object is initialized with the data from the byte array, thus allowing disconnected RowSet objects to establish serialized Blob objects without touching the data source.

        参数：
        b - the byte array containing the data for the Blob object to be serialized
        抛出：
        SerialException - if an error occurs during serialization
        SQLException - if a SQL errors occurs

      • SerialBlob

        public SerialBlob(Blob blob)
           throws SerialException,
                  SQLException
        Constructs a SerialBlob object that is a serialized version of the given Blob object.

        The new SerialBlob object is initialized with the data from the Blob object; therefore, the Blob object should have previously brought the SQL BLOB value's data over to the client from the database. Otherwise, the new SerialBlob object will contain no data.

        参数：
        blob - the Blob object from which this SerialBlob object is to be constructed; cannot be null.
        抛出：
        SerialException - if an error occurs during serialization
        SQLException - if the Blob passed to this to this constructor is a null.
        另请参见：
        Blob

    • 方法详细信息

      • getBytes

        public byte[] getBytes(long pos,
              int length)
                throws SerialException
        Copies the specified number of bytes, starting at the given position, from this SerialBlob object to another array of bytes.

        Note that if the given number of bytes to be copied is larger than the length of this SerialBlob object's array of bytes, the given number will be shortened to the array's length.

        指定者：
        getBytes in interface Blob
        参数：
        pos - the ordinal position of the first byte in this SerialBlob object to be copied; numbering starts at 1; must not be less than 1 and must be less than or equal to the length of this SerialBlob object
        length - the number of bytes to be copied
        返回：
        an array of bytes that is a copy of a region of this SerialBlob object, starting at the given position and containing the given number of consecutive bytes
        抛出：
        SerialException - if the given starting position is out of bounds
        另请参见：
        Blob.setBytes(long, byte[])

      • length

        public long length()
            throws SerialException
        Retrieves the number of bytes in this SerialBlob object's array of bytes.
        指定者：
        length in interface Blob
        返回：
        a long indicating the length in bytes of this SerialBlob object's array of bytes
        抛出：
        SerialException - if an error occurs

      • getBinaryStream

        public InputStream getBinaryStream()
                            throws SerialException
        Returns this SerialBlob object as an input stream. Unlike the related method, setBinaryStream, a stream is produced regardless of whether the SerialBlob was created with a Blob object or a byte array.
        指定者：
        getBinaryStream in interface Blob
        返回：
        a java.io.InputStream object that contains this SerialBlob object's array of bytes
        抛出：
        SerialException - if an error occurs
        另请参见：
        setBinaryStream(long)

      • position

        public long position(byte[] pattern,
            long start)
              throws SerialException,
                     SQLException
        Returns the position in this SerialBlob object where the given pattern of bytes begins, starting the search at the specified position.
        指定者：
        position in interface Blob
        参数：
        pattern - the pattern of bytes for which to search
        start - the position of the byte in this SerialBlob object from which to begin the search; the first position is 1; must not be less than 1 nor greater than the length of this SerialBlob object
        返回：
        the position in this SerialBlob object where the given pattern begins, starting at the specified position; -1 if the pattern is not found or the given starting position is out of bounds; position numbering for the return value starts at 1
        抛出：
        SerialException - if an error occurs when serializing the blob
        SQLException - if there is an error accessing the BLOB value from the database

      • position

        public long position(Blob pattern,
            long start)
              throws SerialException,
                     SQLException
        Returns the position in this SerialBlob object where the given Blob object begins, starting the search at the specified position.
        指定者：
        position in interface Blob
        参数：
        pattern - the Blob object for which to search;
        start - the position of the byte in this SerialBlob object from which to begin the search; the first position is 1; must not be less than 1 nor greater than the length of this SerialBlob object
        返回：
        the position in this SerialBlob object where the given Blob object begins, starting at the specified position; -1 if the pattern is not found or the given starting position is out of bounds; position numbering for the return value starts at 1
        抛出：
        SerialException - if an error occurs when serializing the blob
        SQLException - if there is an error accessing the BLOB value from the database

      • setBytes

        public int setBytes(long pos,
           byte[] bytes)
             throws SerialException,
                    SQLException
        Writes the given array of bytes to the BLOB value that this Blob object represents, starting at position pos, and returns the number of bytes written.
        指定者：
        setBytes in interface Blob
        参数：
        pos - the position in the SQL BLOB value at which to start writing. The first position is 1; must not be less than 1 nor greater than the length of this SerialBlob object.
        bytes - the array of bytes to be written to the BLOB value that this Blob object represents
        返回：
        the number of bytes written
        抛出：
        SerialException - if there is an error accessing the BLOB value; or if an invalid position is set; if an invalid offset value is set
        SQLException - if there is an error accessing the BLOB value from the database
        另请参见：
        getBytes(long, int)

      • setBytes

        public int setBytes(long pos,
           byte[] bytes,
           int offset,
           int length)
             throws SerialException,
                    SQLException
        Writes all or part of the given byte array to the BLOB value that this Blob object represents and returns the number of bytes written. Writing starts at position pos in the BLOB value; len bytes from the given byte array are written.
        指定者：
        setBytes in interface Blob
        参数：
        pos - the position in the BLOB object at which to start writing. The first position is 1; must not be less than 1 nor greater than the length of this SerialBlob object.
        bytes - the array of bytes to be written to the BLOB value
        offset - the offset in the byte array at which to start reading the bytes. The first offset position is 0; must not be less than 0 nor greater than the length of the byte array
        length - the number of bytes to be written to the BLOB value from the array of bytes bytes.
        返回：
        the number of bytes written
        抛出：
        SerialException - if there is an error accessing the BLOB value; if an invalid position is set; if an invalid offset value is set; if number of bytes to be written is greater than the SerialBlob length; or the combined values of the length and offset is greater than the Blob buffer
        SQLException - if there is an error accessing the BLOB value from the database.
        另请参见：
        getBytes(long, int)

      • setBinaryStream

        public OutputStream setBinaryStream(long pos)
                             throws SerialException,
                                    SQLException
        Retrieves a stream that can be used to write to the BLOB value that this Blob object represents. The stream begins at position pos. This method forwards the setBinaryStream() call to the underlying Blob in the event that this SerialBlob object is instantiated with a Blob. If this SerialBlob is instantiated with a byte array, a SerialException is thrown.
        指定者：
        setBinaryStream in interface Blob
        参数：
        pos - the position in the BLOB value at which to start writing
        返回：
        a java.io.OutputStream object to which data can be written
        抛出：
        SQLException - if there is an error accessing the BLOB value
        SerialException - if the SerialBlob in not instantiated with a Blob object that supports setBinaryStream()
        另请参见：
        getBinaryStream()

      • truncate

        public void truncate(long length)
              throws SerialException
        Truncates the BLOB value that this Blob object represents to be len bytes in length.
        指定者：
        truncate in interface Blob
        参数：
        length - the length, in bytes, to which the BLOB value that this Blob object represents should be truncated
        抛出：
        SerialException - if there is an error accessing the Blob value; or the length to truncate is greater that the SerialBlob length

      • getBinaryStream

        public InputStream getBinaryStream(long pos,
                          long length)
                            throws SQLException
        Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.
        指定者：
        getBinaryStream in interface Blob
        参数：
        pos - the offset to the first byte of the partial value to be retrieved. The first byte in the Blob is at position 1
        length - the length in bytes of the partial value to be retrieved
        返回：
        InputStream through which the partial Blob value can be read.
        抛出：
        SQLException - if pos is less than 1 or if pos is greater than the number of bytes in the Blob or if pos + length is greater than the number of bytes in the Blob
        从以下版本开始：
        1.6

      • free

        public void free()
          throws SQLException
        This method frees the Blob object and releases the resources that it holds. Blob object. The object is invalid once the free method is called. If free is called multiple times, the subsequent calls to free are treated as a no-op.
        指定者：
        free in interface Blob
        抛出：
        SQLException - if an error occurs releasing the Blob's resources
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-odtntootoded ddrf hetsemmus hiefttomtlec


SerialClob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialClob

  • java.lang.Object
    • javax.sql.rowset.serial.SerialClob
  • 所有已实现的接口：
    Serializable, Cloneable, Clob

    public class SerialClob
extends Object
implements Clob, Serializable, Cloneable
    A serialized mapping in the Java programming language of an SQL CLOB value.

    The SerialClob class provides a constructor for creating an instance from a Clob object. Note that the Clob object should have brought the SQL CLOB value's data over to the client before a SerialClob object is constructed from it. The data of an SQL CLOB value can be materialized on the client as a stream of Unicode characters.

    SerialClob methods make it possible to get a substring from a SerialClob object or to locate the start of a pattern of characters.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialClob(char[] ch)
      Constructs a SerialClob object that is a serialized version of the given char array.
      SerialClob(Clob clob)
      Constructs a SerialClob object that is a serialized version of the given Clob object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void free()
      This method frees the Clob object and releases the resources the resources that it holds.
      InputStream getAsciiStream()
      Retrieves the CLOB value designated by this SerialClob object as an ascii stream.
      Reader getCharacterStream()
      Returns this SerialClob object's data as a stream of Unicode characters.
      Reader getCharacterStream(long pos, long length)
      Returns a Reader object that contains a partial Clob value, starting with the character specified by pos, which is length characters in length.
      String getSubString(long pos, int length)
      Returns a copy of the substring contained in this SerialClob object, starting at the given position and continuing for the specified number or characters.
      long length()
      Retrieves the number of characters in this SerialClob object's array of characters.
      long position(Clob searchStr, long start)
      Returns the position in this SerialClob object where the given Clob signature begins, starting the search at the specified position.
      long position(String searchStr, long start)
      Returns the position in this SerialClob object where the given String object begins, starting the search at the specified position.
      OutputStream setAsciiStream(long pos)
      Retrieves a stream to be used to write Ascii characters to the CLOB value that this SerialClob object represents, starting at position pos.
      Writer setCharacterStream(long pos)
      Retrieves a stream to be used to write a stream of Unicode characters to the CLOB value that this SerialClob object represents, at position pos.
      int setString(long pos, String str)
      Writes the given Java String to the CLOB value that this SerialClob object represents, at the position pos.
      int setString(long pos, String str, int offset, int length)
      Writes len characters of str, starting at character offset, to the CLOB value that this Clob represents.
      void truncate(long length)
      Truncates the CLOB value that this SerialClob object represents so that it has a length of len characters.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialClob

        public SerialClob(char[] ch)
           throws SerialException,
                  SQLException
        Constructs a SerialClob object that is a serialized version of the given char array.

        The new SerialClob object is initialized with the data from the char array, thus allowing disconnected RowSet objects to establish a serialized Clob object without touching the data source.

        参数：
        ch - the char array representing the Clob object to be serialized
        抛出：
        SerialException - if an error occurs during serialization
        SQLException - if a SQL error occurs

      • SerialClob

        public SerialClob(Clob clob)
           throws SerialException,
                  SQLException
        Constructs a SerialClob object that is a serialized version of the given Clob object.

        The new SerialClob object is initialized with the data from the Clob object; therefore, the Clob object should have previously brought the SQL CLOB value's data over to the client from the database. Otherwise, the new SerialClob object object will contain no data.

        Note: The Clob object supplied to this constructor must return non-null for both the Clob.getCharacterStream() and Clob.getAsciiStream methods. This SerialClob constructor cannot serialize a Clob object in this instance and will throw an SQLException object.

        参数：
        clob - the Clob object from which this SerialClob object is to be constructed; cannot be null
        抛出：
        SerialException - if an error occurs during serialization
        SQLException - if a SQL error occurs in capturing the CLOB; if the Clob object is a null; or if either of the Clob.getCharacterStream() and Clob.getAsciiStream() methods on the Clob returns a null
        另请参见：
        Clob

    • 方法详细信息

      • length

        public long length()
            throws SerialException
        Retrieves the number of characters in this SerialClob object's array of characters.
        指定者：
        length in interface Clob
        返回：
        a long indicating the length in characters of this SerialClob object's array of character
        抛出：
        SerialException - if an error occurs

      • getCharacterStream

        public Reader getCharacterStream()
                          throws SerialException
        Returns this SerialClob object's data as a stream of Unicode characters. Unlike the related method, getAsciiStream, a stream is produced regardless of whether the SerialClob object was created with a Clob object or a char array.
        指定者：
        getCharacterStream in interface Clob
        返回：
        a java.io.Reader object containing this SerialClob object's data
        抛出：
        SerialException - if an error occurs
        另请参见：
        Clob.setCharacterStream(long)

      • getAsciiStream

        public InputStream getAsciiStream()
                           throws SerialException,
                                  SQLException
        Retrieves the CLOB value designated by this SerialClob object as an ascii stream. This method forwards the getAsciiStream call to the underlying Clob object in the event that this SerialClob object is instantiated with a Clob object. If this SerialClob object is instantiated with a char array, a SerialException object is thrown.
        指定者：
        getAsciiStream in interface Clob
        返回：
        a java.io.InputStream object containing this SerialClob object's data
        抛出：
        SerialException - if this SerialClob object was not instantiated with a Clob object
        SQLException - if there is an error accessing the CLOB value represented by the Clob object that was used to create this SerialClob object
        另请参见：
        Clob.setAsciiStream(long)

      • getSubString

        public String getSubString(long pos,
                  int length)
                    throws SerialException
        Returns a copy of the substring contained in this SerialClob object, starting at the given position and continuing for the specified number or characters.
        指定者：
        getSubString in interface Clob
        参数：
        pos - the position of the first character in the substring to be copied; the first character of the SerialClob object is at position 1; must not be less than 1, and the sum of the starting position and the length of the substring must be less than the length of this SerialClob object
        length - the number of characters in the substring to be returned; must not be greater than the length of this SerialClob object, and the sum of the starting position and the length of the substring must be less than the length of this SerialClob object
        返回：
        a String object containing a substring of this SerialClob object beginning at the given position and containing the specified number of consecutive characters
        抛出：
        SerialException - if either of the arguments is out of bounds

      • position

        public long position(String searchStr,
            long start)
              throws SerialException,
                     SQLException
        Returns the position in this SerialClob object where the given String object begins, starting the search at the specified position. This method returns -1 if the pattern is not found.
        指定者：
        position in interface Clob
        参数：
        searchStr - the String object for which to search
        start - the position in this SerialClob object at which to start the search; the first position is 1; must not be less than 1 nor greater than the length of this SerialClob object
        返回：
        the position at which the given String object begins, starting the search at the specified position; -1 if the given String object is not found or the starting position is out of bounds; position numbering for the return value starts at 1
        抛出：
        SerialException - if an error occurs locating the String signature
        SQLException - if there is an error accessing the Blob value from the database.

      • position

        public long position(Clob searchStr,
            long start)
              throws SerialException,
                     SQLException
        Returns the position in this SerialClob object where the given Clob signature begins, starting the search at the specified position. This method returns -1 if the pattern is not found.
        指定者：
        position in interface Clob
        参数：
        searchStr - the Clob object for which to search
        start - the position in this SerialClob object at which to begin the search; the first position is 1; must not be less than 1 nor greater than the length of this SerialClob object
        返回：
        the position at which the given Clob object begins in this SerialClob object, at or after the specified starting position
        抛出：
        SerialException - if an error occurs locating the Clob signature
        SQLException - if there is an error accessing the Blob value from the database

      • setString

        public int setString(long pos,
            String str)
              throws SerialException
        Writes the given Java String to the CLOB value that this SerialClob object represents, at the position pos.
        指定者：
        setString in interface Clob
        参数：
        pos - the position at which to start writing to the CLOB value that this SerialClob object represents; the first position is 1; must not be less than 1 nor greater than the length of this SerialClob object
        str - the string to be written to the CLOB value that this SerialClob object represents
        返回：
        the number of characters written
        抛出：
        SerialException - if there is an error accessing the CLOB value; if an invalid position is set; if an invalid offset value is set; if number of bytes to be written is greater than the SerialClob length; or the combined values of the length and offset is greater than the Clob buffer

      • setString

        public int setString(long pos,
            String str,
            int offset,
            int length)
              throws SerialException
        Writes len characters of str, starting at character offset, to the CLOB value that this Clob represents.
        指定者：
        setString in interface Clob
        参数：
        pos - the position at which to start writing to the CLOB value that this SerialClob object represents; the first position is 1; must not be less than 1 nor greater than the length of this SerialClob object
        str - the string to be written to the CLOB value that this Clob object represents
        offset - the offset into str to start reading the characters to be written
        length - the number of characters to be written
        返回：
        the number of characters written
        抛出：
        SerialException - if there is an error accessing the CLOB value; if an invalid position is set; if an invalid offset value is set; if number of bytes to be written is greater than the SerialClob length; or the combined values of the length and offset is greater than the Clob buffer

      • setAsciiStream

        public OutputStream setAsciiStream(long pos)
                            throws SerialException,
                                   SQLException
        Retrieves a stream to be used to write Ascii characters to the CLOB value that this SerialClob object represents, starting at position pos. This method forwards the setAsciiStream() call to the underlying Clob object in the event that this SerialClob object is instantiated with a Clob object. If this SerialClob object is instantiated with a char array, a SerialException object is thrown.
        指定者：
        setAsciiStream in interface Clob
        参数：
        pos - the position at which to start writing to the CLOB object
        返回：
        the stream to which ASCII encoded characters can be written
        抛出：
        SerialException - if SerialClob is not instantiated with a Clob object that supports setAsciiStream
        SQLException - if there is an error accessing the CLOB value
        另请参见：
        getAsciiStream()

      • setCharacterStream

        public Writer setCharacterStream(long pos)
                          throws SerialException,
                                 SQLException
        Retrieves a stream to be used to write a stream of Unicode characters to the CLOB value that this SerialClob object represents, at position pos. This method forwards the setCharacterStream() call to the underlying Clob object in the event that this SerialClob object is instantiated with a Clob object. If this SerialClob object is instantiated with a char array, a SerialException is thrown.
        指定者：
        setCharacterStream in interface Clob
        参数：
        pos - the position at which to start writing to the CLOB value
        返回：
        a stream to which Unicode encoded characters can be written
        抛出：
        SerialException - if the SerialClob is not instantiated with a Clob object that supports setCharacterStream
        SQLException - if there is an error accessing the CLOB value
        另请参见：
        getCharacterStream()

      • truncate

        public void truncate(long length)
              throws SerialException
        Truncates the CLOB value that this SerialClob object represents so that it has a length of len characters.

        Truncating a SerialClob object to length 0 has the effect of clearing its contents.

        指定者：
        truncate in interface Clob
        参数：
        length - the length, in bytes, to which the CLOB value should be truncated
        抛出：
        SQLException - if there is an error accessing the CLOB value
        SerialException

      • getCharacterStream

        public Reader getCharacterStream(long pos,
                        long length)
                          throws SQLException
        从接口复制的描述： Clob
        Returns a Reader object that contains a partial Clob value, starting with the character specified by pos, which is length characters in length.
        指定者：
        getCharacterStream in interface Clob
        参数：
        pos - the offset to the first character of the partial value to be retrieved. The first character in the Clob is at position 1.
        length - the length in characters of the partial value to be retrieved.
        返回：
        Reader through which the partial Clob value can be read.
        抛出：
        SQLException - if pos is less than 1 or if pos is greater than the number of characters in the Clob or if pos + length is greater than the number of characters in the Clob
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method

      • free

        public void free()
          throws SQLException
        从接口复制的描述： Clob
        This method frees the Clob object and releases the resources the resources that it holds. The object is invalid once the free method is called.

        After free has been called, any attempt to invoke a method other than free will result in a SQLException being thrown. If free is called multiple times, the subsequent calls to free are treated as a no-op.

        指定者：
        free in interface Clob
        抛出：
        SQLException - if an error occurs releasing the Clob's resources
        SQLFeatureNotSupportedException - if the JDBC driver does not support this method
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SerialDatalink

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialDatalink

  • java.lang.Object
    • javax.sql.rowset.serial.SerialDatalink
  • 所有已实现的接口：
    Serializable, Cloneable

    public class SerialDatalink
extends Object
implements Serializable, Cloneable
    A serialized mapping in the Java programming language of an SQL DATALINK value. A DATALINK value references a file outside of the underlying data source that the data source manages.

    RowSet implementations can use the method RowSet.getURL to retrieve a java.net.URL object, which can be used to manipulate the external data.

          java.net.URL url = rowset.getURL(1);
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialDatalink(URL url)
      Constructs a new SerialDatalink object from the given java.net.URL object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      URL getDatalink()
      Returns a new URL that is a copy of this SerialDatalink object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialDatalink

        public SerialDatalink(URL url)
               throws SerialException
        Constructs a new SerialDatalink object from the given java.net.URL object.

        抛出：
        SerialException - if url parameter is a null

    • 方法详细信息

      • getDatalink

        public URL getDatalink()
                throws SerialException
        Returns a new URL that is a copy of this SerialDatalink object.
        返回：
        a copy of this SerialDatalink object as a URL object in the Java programming language.
        抛出：
        SerialException - if the URL object cannot be de-serialized
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(pl>igtngteSSteet ll. .e/..//.jqal.//..fC


SerialException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sql.rowset.serial

类 SerialException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • javax.sql.rowset.serial.SerialException
  • 所有已实现的接口：
    Serializable, Iterable<Throwable>

    public class SerialException
extends SQLException
    Indicates and an error with the serialization or de-serialization of SQL types such as BLOB, CLOB, STRUCT or ARRAY in addition to SQL types such as DATALINK and JAVAOBJECT
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialException()
      Creates a new SerialException without a message.
      SerialException(String msg)
      Creates a new SerialException with the specified message.

    • 方法摘要

      • 方法 - 继承于类 java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SerialException

        public SerialException()
        Creates a new SerialException without a message.

      • SerialException

        public SerialException(String msg)
        Creates a new SerialException with the specified message.
        参数：
        msg - the detail message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i>ovhh>ddntte:ScLttlmtfm穝hft>e>e


SerialJavaObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialJavaObject

  • java.lang.Object
    • javax.sql.rowset.serial.SerialJavaObject
  • 所有已实现的接口：
    Serializable, Cloneable

    public class SerialJavaObject
extends Object
implements Serializable, Cloneable
    A serializable mapping in the Java programming language of an SQL JAVA_OBJECT value. Assuming the Java object implements the Serializable interface, this class simply wraps the serialization process.

    If however, the serialization is not possible because the Java object is not immediately serializable, this class will attempt to serialize all non-static members to permit the object state to be serialized. Static or transient fields cannot be serialized; an attempt to serialize them will result in a SerialException object being thrown.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialJavaObject(Object obj)
      Constructor for SerialJavaObject helper class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      字段[] getFields()
      Returns an array of Field objects that contains each field of the object that this helper class is serializing.
      Object getObject()
      Returns an Object that is a copy of this SerialJavaObject object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialJavaObject

        public SerialJavaObject(Object obj)
                 throws SerialException
        Constructor for SerialJavaObject helper class.

        参数：
        obj - the Java Object to be serialized
        抛出：
        SerialException - if the object is found not to be serializable

    • 方法详细信息

      • getObject

        public Object getObject()
                 throws SerialException
        Returns an Object that is a copy of this SerialJavaObject object.
        返回：
        a copy of this SerialJavaObject object as an Object in the Java programming language
        抛出：
        SerialException - if the instance is corrupt

      • getFields

        public 字段[] getFields()
                  throws SerialException
        Returns an array of Field objects that contains each field of the object that this helper class is serializing.
        返回：
        an array of Field objects
        抛出：
        SerialException - if an error is encountered accessing the serialized object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yuNTelPhu/ Ca t>-gt n/tun.


SerialRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialRef

  • java.lang.Object
    • javax.sql.rowset.serial.SerialRef
  • 所有已实现的接口：
    Serializable, Cloneable, Ref

    public class SerialRef
extends Object
implements Ref, Serializable, Cloneable
    A serialized mapping of a Ref object, which is the mapping in the Java programming language of an SQL REF value.

    The SerialRef class provides a constructor for creating a SerialRef instance from a Ref object and provides methods for getting and setting the Ref object.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialRef(Ref ref)
      Constructs a SerialRef object from the given Ref object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getBaseTypeName()
      Returns a string describing the base type name of the Ref.
      Object getObject()
      Returns an Object representing the SQL structured type to which this SerialRef object refers.
      Object getObject(Map<String,类<?>> map)
      Returns an Object representing the SQL structured type to which this SerialRef object refers.
      void setObject(Object obj)
      Sets the SQL structured type that this SerialRef object references to the given Object object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialRef

        public SerialRef(Ref ref)
          throws SerialException,
                 SQLException
        Constructs a SerialRef object from the given Ref object.
        参数：
        ref - a Ref object; cannot be null
        抛出：
        SQLException - if a database access occurs; if ref is null; or if the Ref object returns a null value base type name.
        SerialException - if an error occurs serializing the Ref object

    • 方法详细信息

      • getBaseTypeName

        public String getBaseTypeName()
                       throws SerialException
        Returns a string describing the base type name of the Ref.
        指定者：
        getBaseTypeName in interface Ref
        返回：
        a string of the base type name of the Ref
        抛出：
        SerialException - in no Ref object has been set

      • getObject

        public Object getObject(Map<String,类<?>> map)
                 throws SerialException
        Returns an Object representing the SQL structured type to which this SerialRef object refers. The attributes of the structured type are mapped according to the given type map.
        指定者：
        getObject in interface Ref
        参数：
        map - a java.util.Map object containing zero or more entries, with each entry consisting of 1) a String giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        an object instance resolved from the Ref reference and mapped according to the supplied type map
        抛出：
        SerialException - if an error is encountered in the reference resolution
        另请参见：
        Ref.setObject(java.lang.Object)

      • getObject

        public Object getObject()
                 throws SerialException
        Returns an Object representing the SQL structured type to which this SerialRef object refers.
        指定者：
        getObject in interface Ref
        返回：
        an object instance resolved from the Ref reference
        抛出：
        SerialException - if an error is encountered in the reference resolution
        另请参见：
        Ref.setObject(java.lang.Object)

      • setObject

        public void setObject(Object obj)
               throws SerialException
        Sets the SQL structured type that this SerialRef object references to the given Object object.
        指定者：
        setObject in interface Ref
        参数：
        obj - an Object representing the SQL structured type to be referenced
        抛出：
        SerialException - if an error is encountered generating the the structured type referenced by this SerialRef object
        另请参见：
        Ref.getObject(),
Ref.getObject(Map),
PreparedStatement.setObject(int, Object),
CallableStatement.setObject(String, Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a addor>Vf/ ua


SerialStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SerialStruct

  • java.lang.Object
    • javax.sql.rowset.serial.SerialStruct
  • 所有已实现的接口：
    Serializable, Cloneable, Struct

    public class SerialStruct
extends Object
implements Struct, Serializable, Cloneable
    A serialized mapping in the Java programming language of an SQL structured type. Each attribute that is not already serialized is mapped to a serialized form, and if an attribute is itself a structured type, each of its attributes that is not already serialized is mapped to a serialized form.

    In addition, the structured type is custom mapped to a class in the Java programming language if there is such a mapping, as are its attributes, if appropriate.

    The SerialStruct class provides a constructor for creating an instance from a Struct object, a method for retrieving the SQL type name of the SQL structured type in the database, and methods for retrieving its attribute values.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SerialStruct(SQLData in, Map<String,类<?>> map)
      Constructs a SerialStruct object from the given SQLData object, using the given type map to custom map it to a class in the Java programming language.
      SerialStruct(Struct in, Map<String,类<?>> map)
      Constructs a SerialStruct object from the given Struct object, using the given java.util.Map object for custom mapping the SQL structured type or any of its attributes that are SQL structured types.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object[] getAttributes()
      Retrieves an array of Object values containing the attributes of the SQL structured type that this SerialStruct object represents.
      Object[] getAttributes(Map<String,类<?>> map)
      Retrieves the attributes for the SQL structured type that this SerialStruct represents as an array of Object values, using the given type map for custom mapping if appropriate.
      String getSQLTypeName()
      Retrieves the SQL type name for this SerialStruct object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SerialStruct

        public SerialStruct(Struct in,
            Map<String,类<?>> map)
             throws SerialException
        Constructs a SerialStruct object from the given Struct object, using the given java.util.Map object for custom mapping the SQL structured type or any of its attributes that are SQL structured types.
        参数：
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        抛出：
        SerialException - if an error occurs
        另请参见：
        Struct

      • SerialStruct

        public SerialStruct(SQLData in,
            Map<String,类<?>> map)
             throws SerialException
        Constructs a SerialStruct object from the given SQLData object, using the given type map to custom map it to a class in the Java programming language. The type map gives the SQL type and the class to which it is mapped. The SQLData object defines the class to which the SQL type will be mapped.
        参数：
        in - an instance of the SQLData class that defines the mapping of the SQL structured type to one or more objects in the Java programming language
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        抛出：
        SerialException - if an error occurs

    • 方法详细信息

      • getSQLTypeName

        public String getSQLTypeName()
                      throws SerialException
        Retrieves the SQL type name for this SerialStruct object. This is the name used in the SQL definition of the structured type
        指定者：
        getSQLTypeName in interface Struct
        返回：
        a String object representing the SQL type name for the SQL structured type that this SerialStruct object represents
        抛出：
        SerialException - if an error occurs

      • getAttributes

        public Object[] getAttributes()
                       throws SerialException
        Retrieves an array of Object values containing the attributes of the SQL structured type that this SerialStruct object represents.
        指定者：
        getAttributes in interface Struct
        返回：
        an array of Object values, with each element being an attribute of the SQL structured type that this SerialStruct object represents
        抛出：
        SerialException - if an error occurs

      • getAttributes

        public Object[] getAttributes(Map<String,类<?>> map)
                       throws SerialException
        Retrieves the attributes for the SQL structured type that this SerialStruct represents as an array of Object values, using the given type map for custom mapping if appropriate.
        指定者：
        getAttributes in interface Struct
        参数：
        map - a java.util.Map object in which each entry consists of 1) a String object giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        返回：
        an array of Object values, with each element being an attribute of the SQL structured type that this SerialStruct object represents
        抛出：
        SerialException - if an error occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oa-.9mgToi poi Te!/iem/sd>


SQLInputImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SQLInputImpl

  • java.lang.Object
    • javax.sql.rowset.serial.SQLInputImpl
  • 所有已实现的接口：
    SQLInput

    public class SQLInputImpl
extends Object
implements SQLInput
    An input stream used for custom mapping user-defined types (UDTs). An SQLInputImpl object is an input stream that contains a stream of values that are the attributes of a UDT.

    This class is used by the driver behind the scenes when the method getObject is called on an SQL structured or distinct type that has a custom mapping; a programmer never invokes SQLInputImpl methods directly. They are provided here as a convenience for those who write RowSet implementations.

    The SQLInputImpl class provides a set of reader methods analogous to the ResultSet getter methods. These methods make it possible to read the values in an SQLInputImpl object.

    The method wasNull is used to determine whether the the last value read was SQL NULL.

    When the method getObject is called with an object of a class implementing the interface SQLData, the JDBC driver calls the method SQLData.getSQLType to determine the SQL type of the UDT being custom mapped. The driver creates an instance of SQLInputImpl, populating it with the attributes of the UDT. The driver then passes the input stream to the method SQLData.readSQL, which in turn calls the SQLInputImpl reader methods to read the attributes from the input stream.

    另请参见：
    SQLData

    • 构造方法摘要

      Constructors
      构造方法与描述
      SQLInputImpl(Object[] attributes, Map<String,类<?>> map)
      Creates an SQLInputImpl object initialized with the given array of attributes and the given type map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Array readArray()
      Reads an SQL ARRAY value from the stream and returns it as an Array object in the Java programming language.
      InputStream readAsciiStream()
      Returns the next attribute in this SQLInputImpl object as a stream of ASCII characters.
      BigDecimal readBigDecimal()
      Retrieves the next attribute in this SQLInputImpl object as a java.math.BigDecimal.
      InputStream readBinaryStream()
      Returns the next attribute in this SQLInputImpl object as a stream of uninterpreted bytes.
      Blob readBlob()
      Retrieves the BLOB value at the head of this SQLInputImpl object as a Blob object in the Java programming language.
      boolean readBoolean()
      Retrieves the next attribute in this SQLInputImpl object as a boolean in the Java programming language.
      byte readByte()
      Retrieves the next attribute in this SQLInputImpl object as a byte in the Java programming language.
      byte[] readBytes()
      Retrieves the next attribute in this SQLInputImpl object as an array of bytes.
      Reader readCharacterStream()
      Retrieves the next attribute in this SQLInputImpl object as a stream of Unicode characters.
      Clob readClob()
      Retrieves the CLOB value at the head of this SQLInputImpl object as a Clob object in the Java programming language.
      Date readDate()
      Retrieves the next attribute in this SQLInputImpl as a java.sql.Date object.
      double readDouble()
      Retrieves the next attribute in this SQLInputImpl object as a double in the Java programming language.
      float readFloat()
      Retrieves the next attribute in this SQLInputImpl object as a float in the Java programming language.
      int readInt()
      Retrieves the next attribute in this SQLInputImpl object as an int in the Java programming language.
      long readLong()
      Retrieves the next attribute in this SQLInputImpl object as a long in the Java programming language.
      NClob readNClob()
      Reads an SQL NCLOB value from the stream and returns it as a Clob object in the Java programming language.
      String readNString()
      Reads the next attribute in the stream and returns it as a String in the Java programming language.
      Object readObject()
      Retrieves the value at the head of this SQLInputImpl object as an Object in the Java programming language.
      Ref readRef()
      Retrieves the value at the head of this SQLInputImpl object as a Ref object in the Java programming language.
      RowId readRowId()
      Reads an SQL ROWID value from the stream and returns it as a RowId object in the Java programming language.
      short readShort()
      Retrieves the next attribute in this SQLInputImpl object as a short in the Java programming language.
      SQLXML readSQLXML()
      Reads an SQL XML value from the stream and returns it as a SQLXML object in the Java programming language.
      String readString()
      Retrieves the next attribute in this SQLInputImpl object as a String in the Java programming language.
      Time readTime()
      Retrieves the next attribute in this SQLInputImpl object as a java.sql.Time object.
      Timestamp readTimestamp()
      Retrieves the next attribute in this SQLInputImpl object as a java.sql.Timestamp object.
      URL readURL()
      Reads an SQL DATALINK value from the stream and returns it as an URL object in the Java programming language.
      boolean wasNull()
      Ascertains whether the last value read from this SQLInputImpl object was null.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SQLInputImpl

        public SQLInputImpl(Object[] attributes,
            Map<String,类<?>> map)
             throws SQLException
        Creates an SQLInputImpl object initialized with the given array of attributes and the given type map. If any of the attributes is a UDT whose name is in an entry in the type map, the attribute will be mapped according to the corresponding SQLData implementation.
        参数：
        attributes - an array of Object instances in which each element is an attribute of a UDT. The order of the attributes in the array is the same order in which the attributes were defined in the UDT definition.
        map - a java.util.Map object containing zero or more entries, with each entry consisting of 1) a String giving the fully qualified name of the UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        抛出：
        SQLException - if the attributes or the map is a null value

    • 方法详细信息

      • readString

        public String readString()
                  throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a String in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readString in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no further values in the stream.

      • readBoolean

        public boolean readBoolean()
                    throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a boolean in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readBoolean in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no further values in the stream.

      • readByte

        public byte readByte()
              throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a byte in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readByte in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no further values in the stream

      • readShort

        public short readShort()
                throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a short in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readShort in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readInt

        public int readInt()
            throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as an int in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readInt in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readLong

        public long readLong()
              throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a long in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readLong in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readFloat

        public float readFloat()
                throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a float in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readFloat in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readDouble

        public double readDouble()
                  throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a double in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readDouble in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readBigDecimal

        public BigDecimal readBigDecimal()
                          throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a java.math.BigDecimal.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readBigDecimal in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readBytes

        public byte[] readBytes()
                 throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as an array of bytes.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readBytes in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readDate

        public Date readDate()
              throws SQLException
        Retrieves the next attribute in this SQLInputImpl as a java.sql.Date object.

        This method does not perform type-safe checking to determine if the returned type is the expected type; this responsibility is delegated to the UDT mapping as defined by a SQLData implementation.

        指定者：
        readDate in interface SQLInput
        返回：
        the next attribute in this SQLInputImpl object; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position or if there are no more values in the stream

      • readTime

        public Time readTime()
              throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a java.sql.Time object.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readTime in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readTimestamp

        public Timestamp readTimestamp()
                        throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a java.sql.Timestamp object.
        指定者：
        readTimestamp in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readCharacterStream

        public Reader readCharacterStream()
                           throws SQLException
        Retrieves the next attribute in this SQLInputImpl object as a stream of Unicode characters.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readCharacterStream in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readAsciiStream

        public InputStream readAsciiStream()
                            throws SQLException
        Returns the next attribute in this SQLInputImpl object as a stream of ASCII characters.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readAsciiStream in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readBinaryStream

        public InputStream readBinaryStream()
                             throws SQLException
        Returns the next attribute in this SQLInputImpl object as a stream of uninterpreted bytes.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readBinaryStream in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readObject

        public Object readObject()
                  throws SQLException
        Retrieves the value at the head of this SQLInputImpl object as an Object in the Java programming language. The actual type of the object returned is determined by the default mapping of SQL types to types in the Java programming language unless there is a custom mapping, in which case the type of the object returned is determined by this stream's type map.

        The JDBC technology-enabled driver registers a type map with the stream before passing the stream to the application.

        When the datum at the head of the stream is an SQL NULL, this method returns null. If the datum is an SQL structured or distinct type with a custom mapping, this method determines the SQL type of the datum at the head of the stream, constructs an object of the appropriate class, and calls the method SQLData.readSQL on that object. The readSQL method then calls the appropriate SQLInputImpl.readXXX methods to retrieve the attribute values from the stream.

        指定者：
        readObject in interface SQLInput
        返回：
        the value at the head of the stream as an Object in the Java programming language; null if the value is SQL NULL
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readRef

        public Ref readRef()
            throws SQLException
        Retrieves the value at the head of this SQLInputImpl object as a Ref object in the Java programming language.
        指定者：
        readRef in interface SQLInput
        返回：
        a Ref object representing the SQL REF value at the head of the stream; if the value is SQL NULL return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readBlob

        public Blob readBlob()
              throws SQLException
        Retrieves the BLOB value at the head of this SQLInputImpl object as a Blob object in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readBlob in interface SQLInput
        返回：
        a Blob object representing the SQL BLOB value at the head of this stream; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readClob

        public Clob readClob()
              throws SQLException
        Retrieves the CLOB value at the head of this SQLInputImpl object as a Clob object in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readClob in interface SQLInput
        返回：
        a Clob object representing the SQL CLOB value at the head of the stream; if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readArray

        public Array readArray()
                throws SQLException
        Reads an SQL ARRAY value from the stream and returns it as an Array object in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readArray in interface SQLInput
        返回：
        an Array object representing the SQL ARRAY value at the head of the stream; * if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • wasNull

        public boolean wasNull()
                throws SQLException
        Ascertains whether the last value read from this SQLInputImpl object was null.
        指定者：
        wasNull in interface SQLInput
        返回：
        true if the SQL value read most recently was null; otherwise, false; by default it will return false
        抛出：
        SQLException - if an error occurs determining the last value read was a null value or not;

      • readURL

        public URL readURL()
            throws SQLException
        Reads an SQL DATALINK value from the stream and returns it as an URL object in the Java programming language.

        This method does not perform type-safe checking to determine if the returned type is the expected type as this responsibility is delegated to the UDT mapping as implemented by a SQLData implementation.

        指定者：
        readURL in interface SQLInput
        返回：
        an URL object representing the SQL DATALINK value at the head of the stream; * if the value is SQL NULL, return null
        抛出：
        SQLException - if the read position is located at an invalid position; or if there are no further values in the stream.

      • readNClob

        public NClob readNClob()
                throws SQLException
        Reads an SQL NCLOB value from the stream and returns it as a Clob object in the Java programming language.
        指定者：
        readNClob in interface SQLInput
        返回：
        a NClob object representing data of the SQL NCLOB value at the head of the stream; null if the value read is SQL NULL
        抛出：
        SQLException - if a database access error occurs

      • readNString

        public String readNString()
                   throws SQLException
        Reads the next attribute in the stream and returns it as a String in the Java programming language. It is intended for use when accessing NCHAR,NVARCHAR and LONGNVARCHAR columns.
        指定者：
        readNString in interface SQLInput
        返回：
        the attribute; if the value is SQL NULL, returns null
        抛出：
        SQLException - if a database access error occurs

      • readSQLXML

        public SQLXML readSQLXML()
                  throws SQLException
        Reads an SQL XML value from the stream and returns it as a SQLXML object in the Java programming language.
        指定者：
        readSQLXML in interface SQLInput
        返回：
        a SQLXML object representing data of the SQL XML value at the head of the stream; null if the value read is SQL NULL
        抛出：
        SQLException - if a database access error occurs

      • readRowId

        public RowId readRowId()
                throws SQLException
        Reads an SQL ROWID value from the stream and returns it as a RowId object in the Java programming language.
        指定者：
        readRowId in interface SQLInput
        返回：
        a RowId object representing data of the SQL ROWID value at the head of the stream; null if the value read is SQL NULL
        抛出：
        SQLException - if a database access error occurs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SQLOutputImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.serial

类 SQLOutputImpl

  • java.lang.Object
    • javax.sql.rowset.serial.SQLOutputImpl
  • 所有已实现的接口：
    SQLOutput

    public class SQLOutputImpl
extends Object
implements SQLOutput
    The output stream for writing the attributes of a custom-mapped user-defined type (UDT) back to the database. The driver uses this interface internally, and its methods are never directly invoked by an application programmer.

    When an application calls the method PreparedStatement.setObject, the driver checks to see whether the value to be written is a UDT with a custom mapping. If it is, there will be an entry in a type map containing the 类 object for the class that implements SQLData for this UDT. If the value to be written is an instance of SQLData, the driver will create an instance of SQLOutputImpl and pass it to the method SQLData.writeSQL. The method writeSQL in turn calls the appropriate SQLOutputImpl.writeXXX methods to write data from the SQLData object to the SQLOutputImpl output stream as the representation of an SQL user-defined type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
      Creates a new SQLOutputImpl object initialized with the given vector of attributes and type map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void writeArray(Array x)
      Writes an Array object in the Java programming language to this SQLOutputImpl object.
      void writeAsciiStream(InputStream x)
      Writes a stream of ASCII characters to this SQLOutputImpl object.
      void writeBigDecimal(BigDecimal x)
      Writes a java.math.BigDecimal object in the Java programming language to this SQLOutputImpl object.
      void writeBinaryStream(InputStream x)
      Writes a stream of uninterpreted bytes to this SQLOutputImpl object.
      void writeBlob(Blob x)
      Writes a Blob object in the Java programming language to this SQLOutputImpl object.
      void writeBoolean(boolean x)
      Writes a boolean in the Java programming language to this SQLOutputImpl object.
      void writeByte(byte x)
      Writes a byte in the Java programming language to this SQLOutputImpl object.
      void writeBytes(byte[] x)
      Writes an array of bytes in the Java programming language to this SQLOutputImpl object.
      void writeCharacterStream(Reader x)
      Writes a stream of Unicode characters to this SQLOutputImpl object.
      void writeClob(Clob x)
      Writes a Clob object in the Java programming language to this SQLOutputImpl object.
      void writeDate(Date x)
      Writes a java.sql.Date object in the Java programming language to this SQLOutputImpl object.
      void writeDouble(double x)
      Writes a double in the Java programming language to this SQLOutputImpl object.
      void writeFloat(float x)
      Writes a float in the Java programming language to this SQLOutputImpl object.
      void writeInt(int x)
      Writes an int in the Java programming language to this SQLOutputImpl object.
      void writeLong(long x)
      Writes a long in the Java programming language to this SQLOutputImpl object.
      void writeNClob(NClob x)
      Writes an SQL NCLOB value to the stream.
      void writeNString(String x)
      Writes the next attribute to the stream as a String in the Java programming language.
      void writeObject(SQLData x)
      Writes to the stream the data contained in the given SQLData object.
      void writeRef(Ref x)
      Writes a Ref object in the Java programming language to this SQLOutputImpl object.
      void writeRowId(RowId x)
      Writes an SQL ROWID value to the stream.
      void writeShort(short x)
      Writes a short in the Java programming language to this SQLOutputImpl object.
      void writeSQLXML(SQLXML x)
      Writes an SQL XML value to the stream.
      void writeString(String x)
      Writes a String in the Java programming language to this SQLOutputImpl object.
      void writeStruct(Struct x)
      Writes a Struct object in the Java programming language to this SQLOutputImpl object.
      void writeTime(Time x)
      Writes a java.sql.Time object in the Java programming language to this SQLOutputImpl object.
      void writeTimestamp(Timestamp x)
      Writes a java.sql.Timestamp object in the Java programming language to this SQLOutputImpl object.
      void writeURL(URL url)
      Writes an java.sql.Type.DATALINK object in the Java programming language to this SQLOutputImpl object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SQLOutputImpl

        public SQLOutputImpl(Vector<?> attributes,
             Map<String,?> map)
              throws SQLException
        Creates a new SQLOutputImpl object initialized with the given vector of attributes and type map. The driver will use the type map to determine which SQLData.writeSQL method to invoke. This method will then call the appropriate SQLOutputImpl writer methods in order and thereby write the attributes to the new output stream.
        参数：
        attributes - a Vector object containing the attributes of the UDT to be mapped to one or more objects in the Java programming language
        map - a java.util.Map object containing zero or more entries, with each entry consisting of 1) a String giving the fully qualified name of a UDT and 2) the 类 object for the SQLData implementation that defines how the UDT is to be mapped
        抛出：
        SQLException - if the attributes or the map is a null value

    • 方法详细信息

      • writeString

        public void writeString(String x)
                 throws SQLException
        Writes a String in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL CHAR, VARCHAR, or LONGVARCHAR before returning it to the database.
        指定者：
        writeString in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeBoolean

        public void writeBoolean(boolean x)
                  throws SQLException
        Writes a boolean in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL BIT before returning it to the database.
        指定者：
        writeBoolean in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeByte

        public void writeByte(byte x)
               throws SQLException
        Writes a byte in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL BIT before returning it to the database.
        指定者：
        writeByte in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeShort

        public void writeShort(short x)
                throws SQLException
        Writes a short in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL SMALLINT before returning it to the database.
        指定者：
        writeShort in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeInt

        public void writeInt(int x)
              throws SQLException
        Writes an int in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL INTEGER before returning it to the database.
        指定者：
        writeInt in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeLong

        public void writeLong(long x)
               throws SQLException
        Writes a long in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL BIGINT before returning it to the database.
        指定者：
        writeLong in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeFloat

        public void writeFloat(float x)
                throws SQLException
        Writes a float in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL REAL before returning it to the database.
        指定者：
        writeFloat in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeDouble

        public void writeDouble(double x)
                 throws SQLException
        Writes a double in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL DOUBLE before returning it to the database.
        指定者：
        writeDouble in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeBigDecimal

        public void writeBigDecimal(BigDecimal x)
                     throws SQLException
        Writes a java.math.BigDecimal object in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL NUMERIC before returning it to the database.
        指定者：
        writeBigDecimal in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeBytes

        public void writeBytes(byte[] x)
                throws SQLException
        Writes an array of bytes in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL VARBINARY or LONGVARBINARY before returning it to the database.
        指定者：
        writeBytes in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeDate

        public void writeDate(Date x)
               throws SQLException
        Writes a java.sql.Date object in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL DATE before returning it to the database.
        指定者：
        writeDate in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeTime

        public void writeTime(Time x)
               throws SQLException
        Writes a java.sql.Time object in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL TIME before returning it to the database.
        指定者：
        writeTime in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeTimestamp

        public void writeTimestamp(Timestamp x)
                    throws SQLException
        Writes a java.sql.Timestamp object in the Java programming language to this SQLOutputImpl object. The driver converts it to an SQL TIMESTAMP before returning it to the database.
        指定者：
        writeTimestamp in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeCharacterStream

        public void writeCharacterStream(Reader x)
                          throws SQLException
        Writes a stream of Unicode characters to this SQLOutputImpl object. The driver will do any necessary conversion from Unicode to the database CHAR format.
        指定者：
        writeCharacterStream in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeAsciiStream

        public void writeAsciiStream(InputStream x)
                      throws SQLException
        Writes a stream of ASCII characters to this SQLOutputImpl object. The driver will do any necessary conversion from ASCII to the database CHAR format.
        指定者：
        writeAsciiStream in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeBinaryStream

        public void writeBinaryStream(InputStream x)
                       throws SQLException
        Writes a stream of uninterpreted bytes to this SQLOutputImpl object.
        指定者：
        writeBinaryStream in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeObject

        public void writeObject(SQLData x)
                 throws SQLException
        Writes to the stream the data contained in the given SQLData object. When the SQLData object is null, this method writes an SQL NULL to the stream. Otherwise, it calls the SQLData.writeSQL method of the given object, which writes the object's attributes to the stream.

        The implementation of the method SQLData.writeSQ calls the appropriate SQLOutputImpl.writeXXX method(s) for writing each of the object's attributes in order. The attributes must be read from an SQLInput input stream and written to an SQLOutputImpl output stream in the same order in which they were listed in the SQL definition of the user-defined type.

        指定者：
        writeObject in interface SQLOutput
        参数：
        x - the object representing data of an SQL structured or distinct type
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeRef

        public void writeRef(Ref x)
              throws SQLException
        Writes a Ref object in the Java programming language to this SQLOutputImpl object. The driver converts it to a serializable SerialRef SQL REF value before returning it to the database.
        指定者：
        writeRef in interface SQLOutput
        参数：
        x - an object representing an SQL REF value
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeBlob

        public void writeBlob(Blob x)
               throws SQLException
        Writes a Blob object in the Java programming language to this SQLOutputImpl object. The driver converts it to a serializable SerialBlob SQL BLOB value before returning it to the database.
        指定者：
        writeBlob in interface SQLOutput
        参数：
        x - an object representing an SQL BLOB value
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeClob

        public void writeClob(Clob x)
               throws SQLException
        Writes a Clob object in the Java programming language to this SQLOutputImpl object. The driver converts it to a serializable SerialClob SQL CLOB value before returning it to the database.
        指定者：
        writeClob in interface SQLOutput
        参数：
        x - an object representing an SQL CLOB value
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeStruct

        public void writeStruct(Struct x)
                 throws SQLException
        Writes a Struct object in the Java programming language to this SQLOutputImpl object. The driver converts this value to an SQL structured type before returning it to the database.

        This method should be used when an SQL structured type has been mapped to a Struct object in the Java programming language (the standard mapping). The method writeObject should be used if an SQL structured type has been custom mapped to a class in the Java programming language.

        指定者：
        writeStruct in interface SQLOutput
        参数：
        x - an object representing the attributes of an SQL structured type
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeArray

        public void writeArray(Array x)
                throws SQLException
        Writes an Array object in the Java programming language to this SQLOutputImpl object. The driver converts this value to a serializable SerialArray SQL ARRAY value before returning it to the database.
        指定者：
        writeArray in interface SQLOutput
        参数：
        x - an object representing an SQL ARRAY value
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeURL

        public void writeURL(URL url)
              throws SQLException
        Writes an java.sql.Type.DATALINK object in the Java programming language to this SQLOutputImpl object. The driver converts this value to a serializable SerialDatalink SQL DATALINK value before return it to the database.
        指定者：
        writeURL in interface SQLOutput
        参数：
        url - an object representing a SQL DATALINK value
        抛出：
        SQLException - if the SQLOutputImpl object is in use by a SQLData object attempting to write the attribute values of a UDT to the database.

      • writeNString

        public void writeNString(String x)
                  throws SQLException
        Writes the next attribute to the stream as a String in the Java programming language. The driver converts this to a SQL NCHAR or NVARCHAR or LONGNVARCHAR value (depending on the argument's size relative to the driver's limits on NVARCHAR values) when it sends it to the stream.
        指定者：
        writeNString in interface SQLOutput
        参数：
        x - the value to pass to the database
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • writeNClob

        public void writeNClob(NClob x)
                throws SQLException
        Writes an SQL NCLOB value to the stream.
        指定者：
        writeNClob in interface SQLOutput
        参数：
        x - a NClob object representing data of an SQL NCLOB value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • writeRowId

        public void writeRowId(RowId x)
                throws SQLException
        Writes an SQL ROWID value to the stream.
        指定者：
        writeRowId in interface SQLOutput
        参数：
        x - a RowId object representing data of an SQL ROWID value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6

      • writeSQLXML

        public void writeSQLXML(SQLXML x)
                 throws SQLException
        Writes an SQL XML value to the stream.
        指定者：
        writeSQLXML in interface SQLOutput
        参数：
        x - a SQLXML object representing data of an SQL XML value
        抛出：
        SQLException - if a database access error occurs
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raeiii/ihil>>illl襵xa/ipl--tsh裻�.."hac.h=>


Uses of Package javax.sql.rowset.serial

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sql.rowset.serial

  • Packages that use javax.sql.rowset.serial
    软件包 描述
    javax.sql.rowset.serial
    Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.
  • Classes in javax.sql.rowset.serial used by javax.sql.rowset.serial
    类与描述
    SerialException
    Indicates and an error with the serialization or de-serialization of SQL types such as BLOB, CLOB, STRUCT or ARRAY in addition to SQL types such as DATALINK and JAVAOBJECT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s


Uses of Class javax.sql.rowset.serial.SerialArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialArray

No usage of javax.sql.rowset.serial.SerialArray
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


Uses of Class javax.sql.rowset.serial.SerialBlob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialBlob

No usage of javax.sql.rowset.serial.SerialBlob
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>蛅>>lee


Uses of Class javax.sql.rowset.serial.SerialClob

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialClob

No usage of javax.sql.rowset.serial.SerialClob
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b<爀琹;p e�


Uses of Class javax.sql.rowset.serial.SerialDatalink

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialDatalink

No usage of javax.sql.rowset.serial.SerialDatalink
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ot.. s(> "n�.or�


Uses of Class javax.sql.rowset.serial.SerialException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialException

  • Packages that use SerialException
    软件包 描述
    javax.sql.rowset.serial
    Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.

    • Uses of SerialException in javax.sql.rowset.serial

      Methods in javax.sql.rowset.serial that throw SerialException
      修饰符与类型 方法与描述
      Object SerialArray.getArray()
      Returns a new array that is a copy of this SerialArray object.
      Object SerialArray.getArray(long index, int count)
      Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.
      Object SerialArray.getArray(long index, int count, Map<String,类<?>> map)
      Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.
      Object SerialArray.getArray(Map<String,类<?>> map)
      Returns a new array that is a copy of this SerialArray object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.
      InputStream SerialClob.getAsciiStream()
      Retrieves the CLOB value designated by this SerialClob object as an ascii stream.
      Object[] SerialStruct.getAttributes()
      Retrieves an array of Object values containing the attributes of the SQL structured type that this SerialStruct object represents.
      Object[] SerialStruct.getAttributes(Map<String,类<?>> map)
      Retrieves the attributes for the SQL structured type that this SerialStruct represents as an array of Object values, using the given type map for custom mapping if appropriate.
      int SerialArray.getBaseType()
      Retrieves the SQL type of the elements in this SerialArray object.
      String SerialRef.getBaseTypeName()
      Returns a string describing the base type name of the Ref.
      String SerialArray.getBaseTypeName()
      Retrieves the DBMS-specific type name for the elements in this SerialArray object.
      InputStream SerialBlob.getBinaryStream()
      Returns this SerialBlob object as an input stream.
      byte[] SerialBlob.getBytes(long pos, int length)
      Copies the specified number of bytes, starting at the given position, from this SerialBlob object to another array of bytes.
      Reader SerialClob.getCharacterStream()
      Returns this SerialClob object's data as a stream of Unicode characters.
      URL SerialDatalink.getDatalink()
      Returns a new URL that is a copy of this SerialDatalink object.
      字段[] SerialJavaObject.getFields()
      Returns an array of Field objects that contains each field of the object that this helper class is serializing.
      Object SerialRef.getObject()
      Returns an Object representing the SQL structured type to which this SerialRef object refers.
      Object SerialJavaObject.getObject()
      Returns an Object that is a copy of this SerialJavaObject object.
      Object SerialRef.getObject(Map<String,类<?>> map)
      Returns an Object representing the SQL structured type to which this SerialRef object refers.
      ResultSet SerialArray.getResultSet()
      Retrieves a ResultSet object that contains all of the elements in the ARRAY value that this SerialArray object represents.
      ResultSet SerialArray.getResultSet(long index, int count)
      Retrieves a ResultSet object holding the elements of the subarray that starts at index index and contains up to count successive elements.
      ResultSet SerialArray.getResultSet(long index, int count, Map<String,类<?>> map)
      Retrieves a result set holding the elements of the subarray that starts at Retrieves a ResultSet object that contains a subarray of the elements in this SerialArray object, starting at index index and containing up to count successive elements.
      ResultSet SerialArray.getResultSet(Map<String,类<?>> map)
      Retrieves a ResultSet object that contains all of the elements of the SQL ARRAY value represented by this SerialArray object.
      String SerialStruct.getSQLTypeName()
      Retrieves the SQL type name for this SerialStruct object.
      String SerialClob.getSubString(long pos, int length)
      Returns a copy of the substring contained in this SerialClob object, starting at the given position and continuing for the specified number or characters.
      long SerialClob.length()
      Retrieves the number of characters in this SerialClob object's array of characters.
      long SerialBlob.length()
      Retrieves the number of bytes in this SerialBlob object's array of bytes.
      long SerialBlob.position(Blob pattern, long start)
      Returns the position in this SerialBlob object where the given Blob object begins, starting the search at the specified position.
      long SerialBlob.position(byte[] pattern, long start)
      Returns the position in this SerialBlob object where the given pattern of bytes begins, starting the search at the specified position.
      long SerialClob.position(Clob searchStr, long start)
      Returns the position in this SerialClob object where the given Clob signature begins, starting the search at the specified position.
      long SerialClob.position(String searchStr, long start)
      Returns the position in this SerialClob object where the given String object begins, starting the search at the specified position.
      OutputStream SerialClob.setAsciiStream(long pos)
      Retrieves a stream to be used to write Ascii characters to the CLOB value that this SerialClob object represents, starting at position pos.
      OutputStream SerialBlob.setBinaryStream(long pos)
      Retrieves a stream that can be used to write to the BLOB value that this Blob object represents.
      int SerialBlob.setBytes(long pos, byte[] bytes)
      Writes the given array of bytes to the BLOB value that this Blob object represents, starting at position pos, and returns the number of bytes written.
      int SerialBlob.setBytes(long pos, byte[] bytes, int offset, int length)
      Writes all or part of the given byte array to the BLOB value that this Blob object represents and returns the number of bytes written.
      Writer SerialClob.setCharacterStream(long pos)
      Retrieves a stream to be used to write a stream of Unicode characters to the CLOB value that this SerialClob object represents, at position pos.
      void SerialRef.setObject(Object obj)
      Sets the SQL structured type that this SerialRef object references to the given Object object.
      int SerialClob.setString(long pos, String str)
      Writes the given Java String to the CLOB value that this SerialClob object represents, at the position pos.
      int SerialClob.setString(long pos, String str, int offset, int length)
      Writes len characters of str, starting at character offset, to the CLOB value that this Clob represents.
      void SerialClob.truncate(long length)
      Truncates the CLOB value that this SerialClob object represents so that it has a length of len characters.
      void SerialBlob.truncate(long length)
      Truncates the BLOB value that this Blob object represents to be len bytes in length.
      Constructors in javax.sql.rowset.serial that throw SerialException
      构造方法与描述
      SerialArray(Array array)
      Constructs a new SerialArray object from the given Array object.
      SerialArray(Array array, Map<String,类<?>> map)
      Constructs a new SerialArray object from the given Array object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.
      SerialBlob(Blob blob)
      Constructs a SerialBlob object that is a serialized version of the given Blob object.
      SerialBlob(byte[] b)
      Constructs a SerialBlob object that is a serialized version of the given byte array.
      SerialClob(char[] ch)
      Constructs a SerialClob object that is a serialized version of the given char array.
      SerialClob(Clob clob)
      Constructs a SerialClob object that is a serialized version of the given Clob object.
      SerialDatalink(URL url)
      Constructs a new SerialDatalink object from the given java.net.URL object.
      SerialJavaObject(Object obj)
      Constructor for SerialJavaObject helper class.
      SerialRef(Ref ref)
      Constructs a SerialRef object from the given Ref object.
      SerialStruct(SQLData in, Map<String,类<?>> map)
      Constructs a SerialStruct object from the given SQLData object, using the given type map to custom map it to a class in the Java programming language.
      SerialStruct(Struct in, Map<String,类<?>> map)
      Constructs a SerialStruct object from the given Struct object, using the given java.util.Map object for custom mapping the SQL structured type or any of its attributes that are SQL structured types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.sql.rowset.serial.SerialJavaObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialJavaObject

No usage of javax.sql.rowset.serial.SerialJavaObject
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ya<)g, (ylllrteetchnr


Uses of Class javax.sql.rowset.serial.SerialRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialRef

No usage of javax.sql.rowset.serial.SerialRef
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r&se�>皉/


Uses of Class javax.sql.rowset.serial.SerialStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SerialStruct

No usage of javax.sql.rowset.serial.SerialStruct
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rb <>xs >>=>en�"s�


Uses of Class javax.sql.rowset.serial.SQLInputImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SQLInputImpl

No usage of javax.sql.rowset.serial.SQLInputImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t 潹~ss �覔>Q纺


Uses of Class javax.sql.rowset.serial.SQLOutputImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.serial.SQLOutputImpl

No usage of javax.sql.rowset.serial.SQLOutputImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

P�!�dlctpS\ga


javax.sql.rowset.spi

Interfaces

  • SyncResolver
  • TransactionalWriter
  • XmlReader
  • XmlWriter

Classes

  • SyncFactory
  • SyncProvider

Exceptions

  • SyncFactoryException
  • SyncProviderException


javax.sql.rowset.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.sql.rowset.spi

The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

请参见： 描述

  • 接口摘要
    接口 描述
    SyncResolver
    Defines a framework that allows applications to use a manual decision tree to decide what should be done when a synchronization conflict occurs.
    TransactionalWriter
    A specialized interface that facilitates an extension of the standard SyncProvider abstract class so that it has finer grained transaction control.
    XmlReader
    A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
    XmlWriter
    A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
  • Class Summary
    类 描述
    SyncFactory
    The Service Provider Interface (SPI) mechanism that generates SyncProvider instances to be used by disconnected RowSet objects.
    SyncProvider
    The synchronization mechanism that provides reader/writer capabilities for disconnected RowSet objects.
  • Exception Summary
    Exception 描述
    SyncFactoryException
    Indicates an error with SyncFactory mechanism.
    SyncProviderException
    Indicates an error with the SyncProvider mechanism.

软件包 javax.sql.rowset.spi Description

The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider. These classes and interfaces are referred to as the Service Provider Interface (SPI). A vendor may have its implementation included on the JDBC web page that lists available SyncProvider implementations by sending email to jdbc@sun.com. Doing this helps make developers aware of the implementation. To make it possible for a RowSet object to use an implementation, the vendor must register it with the SyncFactory singleton. (See the class comment for SyncProvider for a full explanation of the registration process and the naming convention to be used.)

Table of Contents

  • 1.0 Package Specification
  • 2.0 Service Provider Architecture
  • 3.0 Implementer's Guide
  • 4.0 Resolving Synchronization Conflicts
  • 5.0 Related Specifications
  • 6.0 Related Documentation

1.0 Package Specification

The following classes and interfaces make up the javax.sql.rowset.spi package:

  • SyncFactory
  • SyncProvider
  • SyncFactoryException
  • SyncProviderException
  • SyncResolver
  • XmlReader
  • XmlWriter
  • TransactionalWriter
The following interfaces, in the javax.sql package, are also part of the SPI:
  • RowSetReader
  • RowSetWriter

A SyncProvider implementation provides a disconnected RowSet object with the mechanisms for reading data into it and for writing data that has been modified in it back to the underlying data source. A reader, a RowSetReader or XMLReader object, reads data into a RowSet object when the CachedRowSet methods execute or populate are called. A writer, a RowSetWriter or XMLWriter object, writes changes back to the underlying data source when the CachedRowSet method acceptChanges is called.

The process of writing changes in a RowSet object to its data source is known as synchronization. The SyncProvider implementation that a RowSet object is using determines the level of synchronization that the RowSet object's writer uses. The various levels of synchronization are referred to as grades.

The lower grades of synchronization are known as optimistic concurrency levels because they optimistically assume that there will be no conflicts or very few conflicts. A conflict exists when the same data modified in the RowSet object has also been modified in the data source. Using the optimistic concurrency model means that if there is a conflict, modifications to either the data source or the RowSet object will be lost.

Higher grades of synchronization are called pessimistic because they assume that others will be accessing the data source and making modifications. These grades set varying levels of locks to increase the chances that no conflicts occur.

The lowest level of synchronization is simply writing any changes made to the RowSet object to its underlying data source. The writer does nothing to check for conflicts. If there is a conflict and the data source values are overwritten, the changes other parties have made by to the data source are lost.

The RIXMLProvider implementation uses the lowest level of synchronization and just writes RowSet changes to the data source. This is true because typically XML data sources do not enable transaction techniques for maintaining the integrity of data. However, specific standards groups have considered offering XML-based synchronization. For details, see

     http://www.syncml.org

For the the next level up, the writer checks to see if there are any conflicts, and if there are, it does not write anything to the data source. The problem with this concurrency level is that if another party has modified the corresponding data in the data source since the RowSet object got its data, the changes made to the RowSet object are lost. The RIOptimisticProvider implementation uses this level of synchronization.

At higher levels of synchronization, referred to as pessimistic concurrency, the writer take steps to avoid conflicts by setting locks. Setting locks can vary from setting a lock on a single row to setting a lock on a table or the entire data source. The level of synchronization is therefore a tradeoff between the ability of users to access the data source concurrently and the ability of the writer to keep the data in the RowSet object and its data source synchronized.

It is a requirement that all disconnected RowSet objects (CachedRowSet, FilteredRowSet, JoinRowSet, and WebRowSet objects) obtain their SyncProvider objects from the SyncFactory mechanism.

The reference implementation (RI) provides two synchronization providers.

  • RIOptimisticProvider
    The default provider that the SyncFactory instance will supply to a disconnected RowSet object when no provider implementation is specified.
    This synchronization provider uses an optimistic concurrency model, assuming that there will be few conflicts among users who are accessing the same data in a database. It avoids using locks; rather, it checks to see if there is a conflict before trying to synchronize the RowSet object and the data source. If there is a conflict, it does nothing, meaning that changes to the RowSet object are not persisted to the data source.
  • RIXMLProvider
    A synchronization provider that can be used with a WebRowSet object, which is a rowset that can be written in XML format or read from XML format. The RIXMLProvider implementation does no checking at all for conflicts and simply writes any updated data in the WebRowSet object to the underlying data source. WebRowSet objects use this provider when they are dealing with XML data.
These SyncProvider implementations are bundled with the reference implementation, which makes them always available to RowSet implementations. SyncProvider implementations make themselves available by being registered with the SyncFactory singleton. When a RowSet object requests a provider, by specifying it in the constructor or as an argument to the CachedRowSet method setSyncProvider, the SyncFactory singleton checks to see if the requested provider has been registered with it. If it has, the SyncFactory creates an instance of it and passes it to the requesting RowSet object. If the SyncProvider implementation that is specified has not been registered, the SyncFactory singleton causes a SyncFactoryException object to be thrown. If no provider is specified, the SyncFactory singleton will create an instance of the default provider implementation, RIOptimisticProvider, and pass it to the requesting RowSet object.

If a WebRowSet object does not specify a provider in its constructor, the SyncFactory will give it an instance of RIOptimisticProvider. However, the constructor for WebRowSet is implemented to set the provider to the RIXMLProvider, which reads and writes a RowSet object in XML format.

See the SyncProvider class specification for further details.

Vendors may develop a SyncProvider implementation with any one of the possible levels of synchronization, thus giving RowSet objects a choice of synchronization mechanisms. A vendor can make its implementation available by registering the fully qualified class name with Oracle Corporation at jdbc@sun.com. This process is discussed in further detail below.

2.0 Service Provider Interface Architecture

    2.1 Overview

    The Service Provider Interface provides a pluggable mechanism by which SyncProvider implementations can be registered and then generated when required. The lazy reference mechanism employed by the SyncFactory limits unnecessary resource consumption by not creating an instance until it is required by a disconnected RowSet object. The SyncFactory class also provides a standard API to configure logging options and streams that may be provided by a particular SyncProvider implementation.

    2.2 Registering with the SyncFactory

    A third party SyncProvider implementation must be registered with the SyncFactory in order for a disconnected RowSet object to obtain it and thereby use its javax.sql.RowSetReader and javax.sql.RowSetWriter implementations. The following registration mechanisms are available to all SyncProvider implementations:

    • System properties - Properties set at the command line. These properties are set at run time and apply system-wide per invocation of the Java application. See the section "Related Documentation" further related information.

    • Property Files - Properties specified in a standard property file. This can be specified using a System Property or by modifying a standard property file located in the platform run-time. The reference implementation of this technology includes a standard property file than can be edited to add additional SyncProvider objects.

    • JNDI Context - Available providers can be registered on a JNDI context. The SyncFactory will attempt to load SyncProvider objects bound to the context and register them with the factory. This context must be supplied to the SyncFactory for the mechanism to function correctly.

    Details on how to specify the system properties or properties in a property file and how to configure the JNDI Context are explained in detail in the SyncFactory class description.

    2.3 SyncFactory Provider Instance Generation Policies

    The SyncFactory generates a requested SyncProvider object if the provider has been correctly registered. The following policies are adhered to when either a disconnected RowSet object is instantiated with a specified SyncProvider implementation or is reconfigured at runtime with an alternative SyncProvider object.

    • If a SyncProvider object is specified and the SyncFactory contains no reference to the provider, a SyncFactoryException is thrown.

    • If a SyncProvider object is specified and the SyncFactory contains a reference to the provider, the requested provider is supplied.

    • If no SyncProvider object is specified, the reference implementation provider RIOptimisticProvider is supplied.

    These policies are explored in more detail in the SyncFactory class.

  • 3.0 SyncProvider Implementer's Guide

      3.1 Requirements

      A compliant SyncProvider implementation that is fully pluggable into the SyncFactory must extend and implement all abstract methods in the SyncProvider class. In addition, an implementation must determine the grade, locking and updatable view capabilities defined in the SyncProvider class definition. One or more of the SyncProvider description criteria must be supported. It is expected that vendor implementations will offer a range of grade, locking, and updatable view capabilities.

      Furthermore, the SyncProvider naming convention must be followed as detailed in the SyncProvider class description.

      3.2 Grades

      JSR 114 defines a set of grades to describe the quality of synchronization a SyncProvider object can offer a disconnected RowSet object. These grades are listed from the lowest quality of service to the highest.

      • GRADE_NONE - No synchronization with the originating data source is provided. A SyncProvider implementation returning this grade will simply attempt to write any data that has changed in the RowSet object to the underlying data source, overwriting whatever is there. No attempt is made to compare original values with current values to see if there is a conflict. The RIXMLProvider is implemented with this grade.

      • GRADE_CHECK_MODIFIED_AT_COMMIT - A low grade of optimistic synchronization. A SyncProvider implementation returning this grade will check for conflicts in rows that have changed between the last synchronization and the current synchronization under way. Any changes in the originating data source that have been modified will not be reflected in the disconnected RowSet object. If there are no conflicts, changes in the RowSet object will be written to the data source. If there are conflicts, no changes are written. The RIOptimisticProvider implementation uses this grade.

      • GRADE_CHECK_ALL_AT_COMMIT - A high grade of optimistic synchronization. A SyncProvider implementation returning this grade will check all rows, including rows that have not changed in the disconnected RowSet object. In this way, any changes to rows in the underlying data source will be reflected in the disconnected RowSet object when the synchronization finishes successfully.

      • GRADE_LOCK_WHEN_MODIFIED - A pessimistic grade of synchronization. SyncProvider implementations returning this grade will lock the row in the originating data source that corresponds to the row being changed in the RowSet object to reduce the possibility of other processes modifying the same data in the data source.

      • GRADE_LOCK_WHEN_LOADED - A higher pessimistic synchronization grade. A SyncProvider implementation returning this grade will lock the entire view and/or table affected by the original query used to populate a RowSet object.

      3.3 Locks

      JSR 114 defines a set of constants that specify whether any locks have been placed on a RowSet object's underlying data source and, if so, on which constructs the locks are placed. These locks will remain on the data source while the RowSet object is disconnected from the data source.

      These constants should be considered complementary to the grade constants. The default setting for the majority of grade settings requires that no data source locks remain when a RowSet object is disconnected from its data source. The grades GRADE_LOCK_WHEN_MODIFIED and GRADE_LOCK_WHEN_LOADED allow a disconnected RowSet object to have a fine-grained control over the degree of locking.

      • DATASOURCE_NO_LOCK - No locks remain on the originating data source. This is the default lock setting for all SyncProvider implementations unless otherwise directed by a RowSet object.

      • DATASOURCE_ROW_LOCK - A lock is placed on the rows that are touched by the original SQL query used to populate the RowSet object.

      • DATASOURCE_TABLE_LOCK - A lock is placed on all tables that are touched by the query that was used to populate the RowSet object.

      • DATASOURCE_DB_LOCK A lock is placed on the entire data source that is used by the RowSet object.

      3.4 Updatable Views

      A RowSet object may be populated with data from an SQL VIEW. The following constants indicate whether a SyncProvider object can update data in the table or tables from which the VIEW was derived.

      • UPDATABLE_VIEW_SYNC Indicates that a SyncProvider implementation supports synchronization to the table or tables from which the SQL VIEW used to populate a a RowSet object is derived.

      • NONUPDATABLE_VIEW_SYNC Indicates that a SyncProvider implementation does not support synchronization to the table or tables from which the SQL VIEW used to populate a RowSet object is derived.

      3.5 Usage of SyncProvider Grading and Locking

      In the example below, the reference CachedRowSetImpl implementation reconfigures its current SyncProvider object by calling the setSyncProvider method.

          CachedRowSetImpl crs = new CachedRowSetImpl();
    crs.setSyncProvider("com.foo.bar.HASyncProvider");
      An application can retrieve the SyncProvider object currently in use by a disconnected RowSet object. It can also retrieve the grade of synchronization with which the provider was implemented and the degree of locking currently in use. In addition, an application has the flexibility to set the degree of locking to be used, which can increase the possibilities for successful synchronization. These operation are shown in the following code fragment.
          SyncProvider sync = crs.getSyncProvider();

    switch (sync.getProviderGrade()) {
    case: SyncProvider.GRADE_CHECK_ALL_AT_COMMIT
         //A high grade of optimistic synchronization
    break;
    case: SyncProvider.GRADE_CHECK_MODIFIED_AT_COMMIT
         //A low grade of optimistic synchronization
    break;
    case: SyncProvider.GRADE_LOCK_WHEN_LOADED
         // A pessimistic synchronization grade
    break;
    case: SyncProvider.GRADE_LOCK_WHEN_MODIFIED
         // A pessimistic synchronization grade
    break;
    case: SyncProvider.GRADE_NONE
      // No synchronization with the originating data source provided
    break;
    }

    switch (sync.getDataSourcLock() {
      case: SyncProvider.DATASOURCE_DB_LOCK
       // A lock is placed on the entire datasource that is used by the
       // RowSet object
       break;

      case: SyncProvider.DATASOURCE_NO_LOCK
       // No locks remain on the  originating data source.
      break;

      case: SyncProvider.DATASOURCE_ROW_LOCK
       // A lock is placed on the rows that are  touched by the original
       // SQL statement used to populate
       // the RowSet object that is using the SyncProvider
       break;

      case: DATASOURCE_TABLE_LOCK
       // A lock is placed on  all tables that are touched by the original
       // SQL statement used to populated
       // the RowSet object that is using the SyncProvider
       break;
      It is also possible using the static utility method in the SyncFactory class to determine the list of SyncProvider implementations currently registered with the SyncFactory.
              Enumeration e = SyncFactory.getRegisteredProviders();

    4.0 Resolving Synchronization Conflicts

    The interface SyncResolver provides a way for an application to decide manually what to do when a conflict occurs. When the CachedRowSet method acceptChanges finishes and has detected one or more conflicts, it throws a SyncProviderException object. An application can catch the exception and have it retrieve a SyncResolver object by calling the method SyncProviderException.getSyncResolver().

    A SyncResolver object, which is a special kind of CachedRowSet object or a JdbcRowSet object that has implemented the SyncResolver interface, examines the conflicts row by row. It is a duplicate of the RowSet object being synchronized except that it contains only the data from the data source this is causing a conflict. All of the other column values are set to null. To navigate from one conflict value to another, a SyncResolver object provides the methods nextConflict and previousConflict.

    The SyncResolver interface also provides methods for doing the following:

    • finding out whether the conflict involved an update, a delete, or an insert
    • getting the value in the data source that caused the conflict
    • setting the value that should be in the data source if it needs to be changed or setting the value that should be in the RowSet object if it needs to be changed

    When the CachedRowSet method acceptChanges is called, it delegates to the RowSet object's SyncProvider object. How the writer provided by that SyncProvider object is implemented determines what level (grade) of checking for conflicts will be done. After all checking for conflicts is completed and one or more conflicts has been found, the method acceptChanges throws a SyncProviderException object. The application can catch the exception and use it to obtain a SyncResolver object.

    The application can then use SyncResolver methods to get information about each conflict and decide what to do. If the application logic or the user decides that a value in the RowSet object should be the one to persist, the application or user can overwrite the data source value with it.

    The comment for the SyncResolver interface has more detail.

    5.0 Related Specifications

    • JNDI 1.3
    • Java Logging APIs

    6.0 Related Documentation

    • System properties
    • Resource Files
    • DataSource for JDBC Connections
    • 概述
    • 软件包
    • 类
    • 使用
    • 树
    • 已过时
    • 索引
    • 帮助
    Java™ Platform
    Standard Ed. 7
    草案 ea-b138
    • 上一个软件包
    • 下一个软件包
    • 框架
    • 无框架
    • 所有的类


javax.sql.rowset.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.sql.rowset.spi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.sql.rowset.spi.SyncFactory
    • javax.sql.rowset.spi.SyncProvider
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.spi.SyncFactoryException
          • javax.sql.rowset.spi.SyncProviderException

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.sql.RowSet
        • javax.sql.rowset.spi.SyncResolver
  • javax.sql.RowSetReader
    • javax.sql.rowset.spi.XmlReader
  • javax.sql.RowSetWriter
    • javax.sql.rowset.spi.TransactionalWriter
    • javax.sql.rowset.spi.XmlWriter
  • java.sql.Wrapper
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.sql.RowSet
        • javax.sql.rowset.spi.SyncResolver
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dccebocdddrXeepc


SyncFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset.spi

类 SyncFactory

  • java.lang.Object
    • javax.sql.rowset.spi.SyncFactory

  • public class SyncFactory
extends Object
    The Service Provider Interface (SPI) mechanism that generates SyncProvider instances to be used by disconnected RowSet objects. The SyncProvider instances in turn provide the javax.sql.RowSetReader object the RowSet object needs to populate itself with data and the javax.sql.RowSetWriter object it needs to propagate changes to its data back to the underlying data source.

    Because the methods in the SyncFactory class are all static, there is only one SyncFactory object per Java VM at any one time. This ensures that there is a single source from which a RowSet implementation can obtain its SyncProvider implementation.

    1.0 Overview

    The SyncFactory class provides an internal registry of available synchronization provider implementations (SyncProvider objects). This registry may be queried to determine which synchronization providers are available. The following line of code gets an enumeration of the providers currently registered.
         java.util.Enumeration e = SyncFactory.getRegisteredProviders();
    All standard RowSet implementations must provide at least two providers:
    • an optimistic provider for use with a CachedRowSet implementation or an implementation derived from it
    • an XML provider, which is used for reading and writing XML, such as with WebRowSet objects
    Note that the JDBC RowSet Implementations include the SyncProvider implemtations RIOptimisticProvider and RIXmlProvider, which satisfy this requirement.

    The SyncFactory class provides accessor methods to assist applications in determining which synchronization providers are currently registered with the SyncFactory.

    Other methods let RowSet persistence providers be registered or de-registered with the factory mechanism. This allows additional synchronization provider implementations to be made available to RowSet objects at run time.

    Applications can apply a degree of filtering to determine the level of synchronization that a SyncProvider implementation offers. The following criteria determine whether a provider is made available to a RowSet object:

    1. If a particular provider is specified by a RowSet object, and the SyncFactory does not contain a reference to this provider, a SyncFactoryException is thrown stating that the synchronization provider could not be found.

    2. If a RowSet implementation is instantiated with a specified provider and the specified provider has been properly registered, the requested provider is supplied. Otherwise a SyncFactoryException is thrown.

    3. If a RowSet object does not specify a SyncProvider implementation and no additional SyncProvider implementations are available, the reference implementation providers are supplied.

    2.0 Registering SyncProvider Implementations

    Both vendors and developers can register SyncProvider implementations using one of the following mechanisms.

    • Using the command line
      The name of the provider is supplied on the command line, which will add the provider to the system properties. For example:
          -Drowset.provider.classname=com.fred.providers.HighAvailabilityProvider
    • Using the Standard Properties File
      The reference implementation is targeted to ship with J2SE 1.5, which will include an additional resource file that may be edited by hand. Here is an example of the properties file included in the reference implementation:
         #Default JDBC RowSet sync providers listing
   #

   # Optimistic synchronization provider
   rowset.provider.classname.0=com.sun.rowset.providers.RIOptimisticProvider
   rowset.provider.vendor.0=Oracle Corporation
   rowset.provider.version.0=1.0

   # XML Provider using standard XML schema
   rowset.provider.classname.1=com.sun.rowset.providers.RIXMLProvider
   rowset.provider.vendor.1=Oracle Corporation
   rowset.provider.version.1=1.0
      The SyncFactory checks this file and registers the SyncProvider implementations that it contains. A developer or vendor can add other implementations to this file. For example, here is a possible addition:
           rowset.provider.classname.2=com.fred.providers.HighAvailabilityProvider
     rowset.provider.vendor.2=Fred, Inc.
     rowset.provider.version.2=1.0

    • Using a JNDI Context
      Available providers can be registered on a JNDI context, and the SyncFactory will attempt to load SyncProvider implementations from that JNDI context. For example, the following code fragment registers a provider implementation on a JNDI context. This is something a deployer would normally do. In this example, MyProvider is being registered on a CosNaming namespace, which is the namespace used by J2EE resources.
          import javax.naming.*;

    Hashtable svrEnv = new  Hashtable();
    srvEnv.put(Context.INITIAL_CONTEXT_FACTORY, "CosNaming");

    Context ctx = new InitialContext(svrEnv);
    com.fred.providers.MyProvider = new MyProvider();
    ctx.rebind("providers/MyProvider", syncProvider);
    Next, an application will register the JNDI context with the SyncFactory instance. This allows the SyncFactory to browse within the JNDI context looking for SyncProvider implementations.
        Hashtable appEnv = new Hashtable();
    appEnv.put(Context.INITIAL_CONTEXT_FACTORY, "CosNaming");
    appEnv.put(Context.PROVIDER_URL, "iiop://hostname/providers");
    Context ctx = new InitialContext(appEnv);

    SyncFactory.registerJNDIContext(ctx);
    If a RowSet object attempts to obtain a MyProvider object, the SyncFactory will try to locate it. First it searches for it in the system properties, then it looks in the resource files, and finally it checks the JNDI context that has been set. The SyncFactory instance verifies that the requested provider is a valid extension of the SyncProvider abstract class and then gives it to the RowSet object. In the following code fragment, a new CachedRowSet object is created and initialized with env, which contains the binding to MyProvider.
        Hashtable env = new Hashtable();
    env.put(SyncFactory.ROWSET_SYNC_PROVIDER, "com.fred.providers.MyProvider");
    CachedRowSet crs = new com.sun.rowset.CachedRowSetImpl(env);
    Further details on these mechanisms are available in the javax.sql.rowset.spi package specification.
    另请参见：
    SyncProvider, SyncFactoryException

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ROWSET_SYNC_PROVIDER
      The standard property-id for a synchronization provider implementation name.
      static String ROWSET_SYNC_PROVIDER_VERSION
      The standard property-id for a synchronization provider implementation version tag.
      static String ROWSET_SYNC_VENDOR
      The standard property-id for a synchronization provider implementation vendor name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SyncProvider getInstance(String providerID)
      Returns the SyncProvider instance identified by providerID.
      static Logger getLogger()
      Returns the logging object for applications to retrieve synchronization events posted by SyncProvider implementations.
      static Enumeration<SyncProvider> getRegisteredProviders()
      Returns an Enumeration of currently registered synchronization providers.
      static SyncFactory getSyncFactory()
      Returns the SyncFactory singleton.
      static void registerProvider(String providerID)
      Adds the the given synchronization provider to the factory register.
      static void setJNDIContext(Context ctx)
      Sets the initial JNDI context from which SyncProvider implementations can be retrieved from a JNDI namespace
      static void setLogger(Logger logger)
      Sets the logging object to be used by the SyncProvider implementation provided by the SyncFactory.
      static void setLogger(Logger logger, Level level)
      Sets the logging object that is used by SyncProvider implementations provided by the SyncFactory SPI.
      static void unregisterProvider(String providerID)
      Removes the designated currently registered synchronization provider from the Factory SPI register.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ROWSET_SYNC_PROVIDER

        public static final String ROWSET_SYNC_PROVIDER
        The standard property-id for a synchronization provider implementation name.
        另请参见：
        Constant Field Values

      • ROWSET_SYNC_VENDOR

        public static final String ROWSET_SYNC_VENDOR
        The standard property-id for a synchronization provider implementation vendor name.
        另请参见：
        Constant Field Values

      • ROWSET_SYNC_PROVIDER_VERSION

        public static final String ROWSET_SYNC_PROVIDER_VERSION
        The standard property-id for a synchronization provider implementation version tag.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • registerProvider

        public static void registerProvider(String providerID)
                             throws SyncFactoryException
        Adds the the given synchronization provider to the factory register. Guidelines are provided in the SyncProvider specification for the required naming conventions for SyncProvider implementations.

        Synchronization providers bound to a JNDI context can be registered by binding a SyncProvider instance to a JNDI namespace.

           SyncProvider p = new MySyncProvider();
 InitialContext ic = new InitialContext();
 ic.bind ("jdbc/rowset/MySyncProvider", p);
        Furthermore, an initial JNDI context should be set with the SyncFactory using the setJNDIContext method. The SyncFactory leverages this context to search for available SyncProvider objects bound to the JNDI context and its child nodes.
        参数：
        providerID - A String object with the unique ID of the synchronization provider being registered
        抛出：
        SyncFactoryException - if an attempt is made to supply an empty or null provider name
        另请参见：
        setJNDIContext(javax.naming.Context)

      • getSyncFactory

        public static SyncFactory getSyncFactory()
        Returns the SyncFactory singleton.
        返回：
        the SyncFactory instance

      • unregisterProvider

        public static void unregisterProvider(String providerID)
                               throws SyncFactoryException
        Removes the designated currently registered synchronization provider from the Factory SPI register.
        参数：
        providerID - The unique-id of the synchronization provider
        抛出：
        SyncFactoryException - If an attempt is made to unregister a SyncProvider implementation that was not registered.

      • getInstance

        public static SyncProvider getInstance(String providerID)
                                throws SyncFactoryException
        Returns the SyncProvider instance identified by providerID.
        参数：
        providerID - the unique identifier of the provider
        返回：
        a SyncProvider implementation
        抛出：
        SyncFactoryException - If the SyncProvider cannot be found, the providerID is null, or some error was encountered when trying to invoke this provider.

      • getRegisteredProviders

        public static Enumeration<SyncProvider> getRegisteredProviders()
                                                        throws SyncFactoryException
        Returns an Enumeration of currently registered synchronization providers. A RowSet implementation may use any provider in the enumeration as its SyncProvider object.

        At a minimum, the reference synchronization provider allowing RowSet content data to be stored using a JDBC driver should be possible.

        返回：
        Enumeration A enumeration of available synchronization providers that are registered with this Factory
        抛出：
        SyncFactoryException

      • setLogger

        public static void setLogger(Logger logger)
        Sets the logging object to be used by the SyncProvider implementation provided by the SyncFactory. All SyncProvider implementations can log their events to this object and the application can retrieve a handle to this object using the getLogger method.

        This method checks to see that there is an SQLPermission object which grants the permission setSyncFactory before allowing the method to succeed. If a SecurityManager exists and its checkPermission method denies calling setLogger, this method throws a java.lang.SecurityException.

        参数：
        logger - A Logger object instance
        抛出：
        SecurityException - if a security manager exists and its checkPermission method denies calling setLogger
        NullPointerException - if the logger is null
        另请参见：
        SecurityManager.checkPermission(java.security.Permission)

      • setLogger

        public static void setLogger(Logger logger,
             Level level)
        Sets the logging object that is used by SyncProvider implementations provided by the SyncFactory SPI. All SyncProvider implementations can log their events to this object and the application can retrieve a handle to this object using the getLogger method.

        This method checks to see that there is an SQLPermission object which grants the permission setSyncFactory before allowing the method to succeed. If a SecurityManager exists and its checkPermission method denies calling setLogger, this method throws a java.lang.SecurityException.

        参数：
        logger - a Logger object instance
        level - a Level object instance indicating the degree of logging required
        抛出：
        SecurityException - if a security manager exists and its checkPermission method denies calling setLogger
        LoggingPermission - if a security manager exists and its checkPermission method denies calling setLevel
        NullPointerException - if the logger is null
        另请参见：
        SecurityManager.checkPermission(java.security.Permission), LoggingPermission

      • getLogger

        public static Logger getLogger()
                        throws SyncFactoryException
        Returns the logging object for applications to retrieve synchronization events posted by SyncProvider implementations.
        抛出：
        SyncFactoryException - if no logging object has been set.

      • setJNDIContext

        public static void setJNDIContext(Context ctx)
                           throws SyncFactoryException
        Sets the initial JNDI context from which SyncProvider implementations can be retrieved from a JNDI namespace

        This method checks to see that there is an SQLPermission object which grants the permission setSyncFactory before allowing the method to succeed. If a SecurityManager exists and its checkPermission method denies calling setJNDIContext, this method throws a java.lang.SecurityException.

        参数：
        ctx - a valid JNDI context
        抛出：
        SyncFactoryException - if the supplied JNDI context is null
        SecurityException - if a security manager exists and its checkPermission method denies calling setJNDIContext
        另请参见：
        SecurityManager.checkPermission(java.security.Permission)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SyncFactoryException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.sql.rowset.spi

类 SyncFactoryException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • javax.sql.rowset.spi.SyncFactoryException
  • 所有已实现的接口：
    Serializable, Iterable<Throwable>

    public class SyncFactoryException
extends SQLException
    Indicates an error with SyncFactory mechanism. A disconnected RowSet implementation cannot be used without a SyncProvider being successfully instantiated
    另请参见：
    SyncFactory, SyncFactoryException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SyncFactoryException()
      Creates new SyncFactoryException without detail message.
      SyncFactoryException(String msg)
      Constructs an SyncFactoryException with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SyncFactoryException

        public SyncFactoryException()
        Creates new SyncFactoryException without detail message.

      • SyncFactoryException

        public SyncFactoryException(String msg)
        Constructs an SyncFactoryException with the specified detail message.
        参数：
        msg - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oin o Md M>e>">>""aatpt


SyncProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.spi

类 SyncProvider

  • java.lang.Object
    • javax.sql.rowset.spi.SyncProvider

  • public abstract class SyncProvider
extends Object
    The synchronization mechanism that provides reader/writer capabilities for disconnected RowSet objects. A SyncProvider implementation is a class that extends the SyncProvider abstract class.

    A SyncProvider implementation is identified by a unique ID, which is its fully qualified class name. This name must be registered with the SyncFactory SPI, thus making the implementation available to all RowSet implementations. The factory mechanism in the reference implementation uses this name to instantiate the implementation, which can then provide a RowSet object with its reader (a javax.sql.RowSetReader object) and its writer (a javax.sql.RowSetWriter object).

    The Jdbc RowSet Implementations specification provides two reference implementations of the SyncProvider abstract class: RIOptimisticProvider and RIXMLProvider. The RIOptimisticProvider can set any RowSet implementation with a RowSetReader object and a RowSetWriter object. However, only the RIXMLProvider implementation can set an XmlReader object and an XmlWriter object. A WebRowSet object uses the XmlReader object to read data in XML format to populate itself with that data. It uses the XmlWriter object to write itself to a stream or java.io.Writer object in XML format.

    1.0 Naming Convention for Implementations

    As a guide to naming SyncProvider implementations, the following should be noted:
    • The name for a SyncProvider implementation is its fully qualified class name.
    • It is recommended that vendors supply a SyncProvider implementation in a package named providers.

    For instance, if a vendor named Fred, Inc. offered a SyncProvider implementation, you could have the following:

         Vendor name:  Fred, Inc.
     Domain name of vendor:  com.fred
     Package name:  com.fred.providers
     SyncProvider implementation class name:  HighAvailabilityProvider

     Fully qualified class name of SyncProvider implementation:
                        com.fred.providers.HighAvailabilityProvider

    The following line of code uses the fully qualified name to register this implementation with the SyncFactory static instance.

         SyncFactory.registerProvider(
                          "com.fred.providers.HighAvailabilityProvider");

    The default SyncProvider object provided with the reference implementation uses the following name:

         com.sun.rowset.providers.RIOptimisticProvider

    A vendor can register a SyncProvider implementation class name with Oracle Corporation by sending email to jdbc@sun.com. Oracle will maintain a database listing the available SyncProvider implementations for use with compliant RowSet implementations. This database will be similar to the one already maintained to list available JDBC drivers.

    Vendors should refer to the reference implementation synchronization providers for additional guidance on how to implement a new SyncProvider implementation.

    2.0 How a RowSet Object Gets Its Provider

    A disconnected Rowset object may get access to a SyncProvider object in one of the following two ways:
    • Using a constructor
             CachedRowSet crs = new CachedRowSet(
                  "com.fred.providers.HighAvailabilitySyncProvider");
    • Using the setSyncProvider method
             CachedRowSet crs = new CachedRowSet();
       crs.setSyncProvider("com.fred.providers.HighAvailabilitySyncProvider");

    By default, the reference implementations of the RowSet synchronization providers are always available to the Java platform. If no other pluggable synchronization providers have been correctly registered, the SyncFactory will automatically generate an instance of the default SyncProvider reference implementation. Thus, in the preceding code fragment, if no implementation named com.fred.providers.HighAvailabilitySyncProvider has been registered with the SyncFactory instance, crs will be assigned the default provider in the reference implementation, which is com.sun.rowset.providers.RIOptimisticProvider.

    3.0 Violations and Synchronization Issues

    If an update between a disconnected RowSet object and a data source violates the original query or the underlying data source constraints, this will result in undefined behavior for all disconnected RowSet implementations and their designated SyncProvider implementations. Not defining the behavior when such violations occur offers greater flexibility for a SyncProvider implementation to determine its own best course of action.

    A SyncProvider implementation may choose to implement a specific handler to handle a subset of query violations. However if an original query violation or a more general data source constraint violation is not handled by the SyncProvider implementation, all SyncProvider objects must throw a SyncProviderException.

    4.0 Updatable SQL VIEWs

    It is possible for any disconnected or connected RowSet object to be populated from an SQL query that is formulated originally from an SQL VIEW. While in many cases it is possible for an update to be performed to an underlying view, such an update requires additional metadata, which may vary. The SyncProvider class provides two constants to indicate whether an implementation supports updating an SQL VIEW.
    • NONUPDATABLE_VIEW_SYNC - Indicates that a SyncProvider implementation does not support synchronization with an SQL VIEW as the underlying source of data for the RowSet object.
    • UPDATABLE_VIEW_SYNC - Indicates that a SyncProvider implementation supports synchronization with an SQL VIEW as the underlying source of data.

    The default is for a RowSet object not to be updatable if it was populated with data from an SQL VIEW.

    5.0 SyncProvider Constants

    The SyncProvider class provides three sets of constants that are used as return values or parameters for SyncProvider methods. SyncProvider objects may be implemented to perform synchronization between a RowSet object and its underlying data source with varying degrees of of care. The first group of constants indicate how synchronization is handled. For example, GRADE_NONE indicates that a SyncProvider object will not take any care to see what data is valid and will simply write the RowSet data to the data source. GRADE_MODIFIED_AT_COMMIT indicates that the provider will check only modified data for validity. Other grades check all data for validity or set locks when data is modified or loaded.
    1. Constants to indicate the synchronization grade of a SyncProvider object
      • SyncProvider.GRADE_NONE
      • SyncProvider.GRADE_MODIFIED_AT_COMMIT
      • SyncProvider.GRADE_CHECK_ALL_AT_COMMIT
      • SyncProvider.GRADE_LOCK_WHEN_MODIFIED
      • SyncProvider.GRADE_LOCK_WHEN_LOADED
    2. Constants to indicate what locks are set on the data source
      • SyncProvider.DATASOURCE_NO_LOCK
      • SyncProvider.DATASOURCE_ROW_LOCK
      • SyncProvider.DATASOURCE_TABLE_LOCK
      • SyncProvider.DATASOURCE_DB_LOCK
    3. Constants to indicate whether a SyncProvider object can perform updates to an SQL VIEW
      These constants are explained in the preceding section (4.0).
      • SyncProvider.UPDATABLE_VIEW_SYNC
      • SyncProvider.NONUPDATABLE_VIEW_SYNC
    另请参见：
    SyncFactory, SyncFactoryException

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DATASOURCE_DB_LOCK
      Indicates that a lock is placed on the entire data source that is the source of data for the RowSet object that is using this SyncProvider object.
      static int DATASOURCE_NO_LOCK
      Indicates that no locks remain on the originating data source.
      static int DATASOURCE_ROW_LOCK
      Indicates that a lock is placed on the rows that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
      static int DATASOURCE_TABLE_LOCK
      Indicates that a lock is placed on all tables that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
      static int GRADE_CHECK_ALL_AT_COMMIT
      Indicates a high level optimistic synchronization grade with respect to the originating data source.
      static int GRADE_CHECK_MODIFIED_AT_COMMIT
      Indicates a low level optimistic synchronization grade with respect to the originating data source.
      static int GRADE_LOCK_WHEN_LOADED
      Indicates the most pessimistic synchronization grade with respect to the originating data source.
      static int GRADE_LOCK_WHEN_MODIFIED
      Indicates a pessimistic synchronization grade with respect to the originating data source.
      static int GRADE_NONE
      Indicates that no synchronization with the originating data source is provided.
      static int NONUPDATABLE_VIEW_SYNC
      Indicates that a SyncProvider implementation does not support synchronization between a RowSet object and the SQL VIEW used to populate it.
      static int UPDATABLE_VIEW_SYNC
      Indicates that a SyncProvider implementation supports synchronization between a RowSet object and the SQL VIEW used to populate it.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SyncProvider()
      Creates a default SyncProvider object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int getDataSourceLock()
      Returns the current data source lock severity level active in this SyncProvider implementation.
      abstract int getProviderGrade()
      Returns a constant indicating the grade of synchronization a RowSet object can expect from this SyncProvider object.
      abstract String getProviderID()
      Returns the unique identifier for this SyncProvider object.
      abstract RowSetReader getRowSetReader()
      Returns a javax.sql.RowSetReader object, which can be used to populate a RowSet object with data.
      abstract RowSetWriter getRowSetWriter()
      Returns a javax.sql.RowSetWriter object, which can be used to write a RowSet object's data back to the underlying data source.
      abstract String getVendor()
      Returns the vendor name of this SyncProvider instance
      abstract String getVersion()
      Returns the release version of this SyncProvider instance.
      abstract void setDataSourceLock(int datasource_lock)
      Sets a lock on the underlying data source at the level indicated by datasource_lock.
      abstract int supportsUpdatableView()
      Returns whether this SyncProvider implementation can perform synchronization between a RowSet object and the SQL VIEW in the data source from which the RowSet object got its data.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • GRADE_NONE

        public static final int GRADE_NONE
        Indicates that no synchronization with the originating data source is provided. A SyncProvider implementation returning this grade will simply attempt to write updates in the RowSet object to the underlying data source without checking the validity of any data.
        另请参见：
        Constant Field Values

      • GRADE_CHECK_MODIFIED_AT_COMMIT

        public static final int GRADE_CHECK_MODIFIED_AT_COMMIT
        Indicates a low level optimistic synchronization grade with respect to the originating data source. A SyncProvider implementation returning this grade will check only rows that have changed.
        另请参见：
        Constant Field Values

      • GRADE_CHECK_ALL_AT_COMMIT

        public static final int GRADE_CHECK_ALL_AT_COMMIT
        Indicates a high level optimistic synchronization grade with respect to the originating data source. A SyncProvider implementation returning this grade will check all rows, including rows that have not changed.
        另请参见：
        Constant Field Values

      • GRADE_LOCK_WHEN_MODIFIED

        public static final int GRADE_LOCK_WHEN_MODIFIED
        Indicates a pessimistic synchronization grade with respect to the originating data source. A SyncProvider implementation returning this grade will lock the row in the originating data source.
        另请参见：
        Constant Field Values

      • GRADE_LOCK_WHEN_LOADED

        public static final int GRADE_LOCK_WHEN_LOADED
        Indicates the most pessimistic synchronization grade with respect to the originating data source. A SyncProvider implementation returning this grade will lock the entire view and/or table affected by the original statement used to populate a RowSet object.
        另请参见：
        Constant Field Values

      • DATASOURCE_NO_LOCK

        public static final int DATASOURCE_NO_LOCK
        Indicates that no locks remain on the originating data source. This is the default lock setting for all SyncProvider implementations unless otherwise directed by a RowSet object.
        另请参见：
        Constant Field Values

      • DATASOURCE_ROW_LOCK

        public static final int DATASOURCE_ROW_LOCK
        Indicates that a lock is placed on the rows that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
        另请参见：
        Constant Field Values

      • DATASOURCE_TABLE_LOCK

        public static final int DATASOURCE_TABLE_LOCK
        Indicates that a lock is placed on all tables that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
        另请参见：
        Constant Field Values

      • DATASOURCE_DB_LOCK

        public static final int DATASOURCE_DB_LOCK
        Indicates that a lock is placed on the entire data source that is the source of data for the RowSet object that is using this SyncProvider object.
        另请参见：
        Constant Field Values

      • UPDATABLE_VIEW_SYNC

        public static final int UPDATABLE_VIEW_SYNC
        Indicates that a SyncProvider implementation supports synchronization between a RowSet object and the SQL VIEW used to populate it.
        另请参见：
        Constant Field Values

      • NONUPDATABLE_VIEW_SYNC

        public static final int NONUPDATABLE_VIEW_SYNC
        Indicates that a SyncProvider implementation does not support synchronization between a RowSet object and the SQL VIEW used to populate it.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SyncProvider

        public SyncProvider()
        Creates a default SyncProvider object.

    • 方法详细信息

      • getProviderID

        public abstract String getProviderID()
        Returns the unique identifier for this SyncProvider object.
        返回：
        a String object with the fully qualified class name of this SyncProvider object

      • getRowSetReader

        public abstract RowSetReader getRowSetReader()
        Returns a javax.sql.RowSetReader object, which can be used to populate a RowSet object with data.
        返回：
        a javax.sql.RowSetReader object

      • getRowSetWriter

        public abstract RowSetWriter getRowSetWriter()
        Returns a javax.sql.RowSetWriter object, which can be used to write a RowSet object's data back to the underlying data source.
        返回：
        a javax.sql.RowSetWriter object

      • getProviderGrade

        public abstract int getProviderGrade()
        Returns a constant indicating the grade of synchronization a RowSet object can expect from this SyncProvider object.
        返回：
        an int that is one of the following constants: SyncProvider.GRADE_NONE, SyncProvider.GRADE_CHECK_MODIFIED_AT_COMMIT, SyncProvider.GRADE_CHECK_ALL_AT_COMMIT, SyncProvider.GRADE_LOCK_WHEN_MODIFIED, SyncProvider.GRADE_LOCK_WHEN_LOADED

      • setDataSourceLock

        public abstract void setDataSourceLock(int datasource_lock)
                                throws SyncProviderException
        Sets a lock on the underlying data source at the level indicated by datasource_lock. This should cause the SyncProvider to adjust its behavior by increasing or decreasing the level of optimism it provides for a successful synchronization.
        参数：
        datasource_lock - one of the following constants indicating the severity level of data source lock required:
                   SyncProvider.DATASOURCE_NO_LOCK,
           SyncProvider.DATASOURCE_ROW_LOCK,
           SyncProvider.DATASOURCE_TABLE_LOCK,
           SyncProvider.DATASOURCE_DB_LOCK,
        抛出：
        SyncProviderException - if an unsupported data source locking level is set.
        另请参见：
        getDataSourceLock()

      • getDataSourceLock

        public abstract int getDataSourceLock()
                               throws SyncProviderException
        Returns the current data source lock severity level active in this SyncProvider implementation.
        返回：
        a constant indicating the current level of data source lock active in this SyncProvider object; one of the following:
                   SyncProvider.DATASOURCE_NO_LOCK,
           SyncProvider.DATASOURCE_ROW_LOCK,
           SyncProvider.DATASOURCE_TABLE_LOCK,
           SyncProvider.DATASOURCE_DB_LOCK
        抛出：
        SyncProviderExceptiom - if an error occurs determining the data source locking level.
        SyncProviderException
        另请参见：
        setDataSourceLock(int)

      • supportsUpdatableView

        public abstract int supportsUpdatableView()
        Returns whether this SyncProvider implementation can perform synchronization between a RowSet object and the SQL VIEW in the data source from which the RowSet object got its data.
        返回：
        an int saying whether this SyncProvider object supports updating an SQL VIEW; one of the following: SyncProvider.UPDATABLE_VIEW_SYNC, SyncProvider.NONUPDATABLE_VIEW_SYNC

      • getVersion

        public abstract String getVersion()
        Returns the release version of this SyncProvider instance.
        返回：
        a String detailing the release version of the SyncProvider implementation

      • getVendor

        public abstract String getVendor()
        Returns the vendor name of this SyncProvider instance
        返回：
        a String detailing the vendor name of this SyncProvider implementation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SyncProviderException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.sql.rowset.spi

类 SyncProviderException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.sql.SQLException
          • javax.sql.rowset.spi.SyncProviderException
  • 所有已实现的接口：
    Serializable, Iterable<Throwable>

    public class SyncProviderException
extends SQLException
    Indicates an error with the SyncProvider mechanism. This exception is created by a SyncProvider abstract class extension if it encounters violations in reading from or writing to the originating data source.

    If it is implemented to do so, the SyncProvider object may also create a SyncResolver object and either initialize the SyncProviderException object with it at construction time or set it with the SyncProvider object at a later time.

    The method acceptChanges will throw this exception after the writer has finished checking for conflicts and has found one or more conflicts. An application may catch a SyncProviderException object and call its getSyncResolver method to get its SyncResolver object. See the code fragment in the interface comment for SyncResolver for an example. This SyncResolver object will mirror the RowSet object that generated the exception, except that it will contain only the values from the data source that are in conflict. All other values in the SyncResolver object will be null.

    The SyncResolver object may be used to examine and resolve each conflict in a row and then go to the next row with a conflict to repeat the procedure.

    A SyncProviderException object may or may not contain a description of the condition causing the exception. The inherited method getMessage may be called to retrieve the description if there is one.

    另请参见：
    SyncFactory, SyncResolver, SyncFactoryException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SyncProviderException()
      Creates a new SyncProviderException object without a detail message.
      SyncProviderException(String msg)
      Constructs a SyncProviderException object with the specified detail message.
      SyncProviderException(SyncResolver syncResolver)
      Constructs a SyncProviderException object with the specified SyncResolver instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SyncResolver getSyncResolver()
      Retrieves the SyncResolver object that has been set for this SyncProviderException object, or if none has been set, an instance of the default SyncResolver implementation included in the reference implementation.
      void setSyncResolver(SyncResolver syncResolver)
      Sets the SyncResolver object for this SyncProviderException object to the one supplied.

      • 方法 - 继承于类 java.sql.SQLException

        getErrorCode, getNextException, getSQLState, iterator, setNextException

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SyncProviderException

        public SyncProviderException()
        Creates a new SyncProviderException object without a detail message.

      • SyncProviderException

        public SyncProviderException(String msg)
        Constructs a SyncProviderException object with the specified detail message.
        参数：
        msg - the detail message

      • SyncProviderException

        public SyncProviderException(SyncResolver syncResolver)
        Constructs a SyncProviderException object with the specified SyncResolver instance.
        参数：
        syncResolver - the SyncResolver instance used to to process the synchronization conflicts
        抛出：
        IllegalArgumentException - if the SyncResolver object is null.

    • 方法详细信息

      • getSyncResolver

        public SyncResolver getSyncResolver()
        Retrieves the SyncResolver object that has been set for this SyncProviderException object, or if none has been set, an instance of the default SyncResolver implementation included in the reference implementation.

        If a SyncProviderException object is thrown, an application may use this method to generate a SyncResolver object with which to resolve the conflict or conflicts that caused the exception to be thrown.

        返回：
        the SyncResolver object set for this SyncProviderException object or, if none has been set, an instance of the default SyncResolver implementation. In addition, the default SyncResolver implementation is also returned if the SyncResolver() or SyncResolver(String) constructors are used to instantiate the SyncResolver instance.

      • setSyncResolver

        public void setSyncResolver(SyncResolver syncResolver)
        Sets the SyncResolver object for this SyncProviderException object to the one supplied. If the argument supplied is null, a call to the method getSyncResolver will return the default reference implementation of the SyncResolver interface.
        参数：
        syncResolver - the SyncResolver object to be set; cannot be null
        抛出：
        IllegalArgumentException - if the SyncResolver object is null.
        另请参见：
        getSyncResolver()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iRv


SyncResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset.spi

Interface SyncResolver

  • All Superinterfaces:
    AutoCloseable, ResultSet, RowSet, Wrapper

    public interface SyncResolver
extends RowSet
    Defines a framework that allows applications to use a manual decision tree to decide what should be done when a synchronization conflict occurs. Although it is not mandatory for applications to resolve synchronization conflicts manually, this framework provides the means to delegate to the application when conflicts arise.

    Note that a conflict is a situation where the RowSet object's original values for a row do not match the values in the data source, which indicates that the data source row has been modified since the last synchronization. Note also that a RowSet object's original values are the values it had just prior to the the last synchronization, which are not necessarily its initial values.

    Description of a SyncResolver Object

    A SyncResolver object is a specialized RowSet object that implements the SyncResolver interface. It may operate as either a connected RowSet object (an implementation of the JdbcRowSet interface) or a connected RowSet object (an implementation of the CachedRowSet interface or one of its subinterfaces). For information on the subinterfaces, see the javax.sql.rowset package description. The reference implementation for SyncResolver implements the CachedRowSet interface, but other implementations may choose to implement the JdbcRowSet interface to satisfy particular needs.

    After an application has attempted to synchronize a RowSet object with the data source (by calling the CachedRowSet method acceptChanges), and one or more conflicts have been found, a rowset's SyncProvider object creates an instance of SyncResolver. This new SyncResolver object has the same number of rows and columns as the RowSet object that was attempting the synchronization. The SyncResolver object contains the values from the data source that caused the conflict(s) and null for all other values. In addition, it contains information about each conflict.

    Getting and Using a SyncResolver Object

    When the method acceptChanges encounters conflicts, the SyncProvider object creates a SyncProviderException object and sets it with the new SyncResolver object. The method acceptChanges will throw this exception, which the application can then catch and use to retrieve the SyncResolver object it contains. The following code snippet uses the SyncProviderException method getSyncResolver to get the SyncResolver object resolver.
         } catch (SyncProviderException spe) {
         SyncResolver resolver = spe.getSyncResolver();
     ...
     }

    With resolver in hand, an application can use it to get the information it contains about the conflict or conflicts. A SyncResolver object such as resolver keeps track of the conflicts for each row in which there is a conflict. It also places a lock on the table or tables affected by the rowset's command so that no more conflicts can occur while the current conflicts are being resolved.

    The following kinds of information can be obtained from a SyncResolver object:

  • What operation was being attempted when a conflict occurred
    The SyncProvider interface defines four constants describing states that may occur. Three constants describe the type of operation (update, delete, or insert) that a RowSet object was attempting to perform when a conflict was discovered, and the fourth indicates that there is no conflict. These constants are the possible return values when a SyncResolver object calls the method getStatus.
         int operation = resolver.getStatus();

  • The value in the data source that caused a conflict
    A conflict exists when a value that a RowSet object has changed and is attempting to write to the data source has also been changed in the data source since the last synchronization. An application can call the SyncResolver method getConflictValue to retrieve the value in the data source that is the cause of the conflict because the values in a SyncResolver object are the conflict values from the data source.
         java.lang.Object conflictValue = resolver.getConflictValue(2);
    Note that the column in resolver can be designated by the column number, as is done in the preceding line of code, or by the column name.

With the information retrieved from the methods getStatus and getConflictValue, the application may make a determination as to which value should be persisted in the data source. The application then calls the SyncResolver method setResolvedValue, which sets the value to be persisted in the RowSet object and also in the data source.

     resolver.setResolvedValue("DEPT", 8390426);
In the preceding line of code, the column name designates the column in the RowSet object that is to be set with the given value. The column number can also be used to designate the column.

An application calls the method setResolvedValue after it has resolved all of the conflicts in the current conflict row and repeats this process for each conflict row in the SyncResolver object.

Navigating a SyncResolver Object

Because a SyncResolver object is a RowSet object, an application can use all of the RowSet methods for moving the cursor to navigate a SyncResolver object. For example, an application can use the RowSet method 下一个 to get to each row and then call the SyncResolver method getStatus to see if the row contains a conflict. In a row with one or more conflicts, the application can iterate through the columns to find any non-null values, which will be the values from the data source that are in conflict.

To make it easier to navigate a SyncResolver object, especially when there are large numbers of rows with no conflicts, the SyncResolver interface defines the methods nextConflict and previousConflict, which move only to rows that contain at least one conflict value. Then an application can call the SyncResolver method getConflictValue, supplying it with the column number, to get the conflict value itself. The code fragment in the next section gives an example.

Code Example

The following code fragment demonstrates how a disconnected RowSet object crs might attempt to synchronize itself with the underlying data source and then resolve the conflicts. In the try block, crs calls the method acceptChanges, passing it the Connection object con. If there are no conflicts, the changes in crs are simply written to the data source. However, if there is a conflict, the method acceptChanges throws a SyncProviderException object, and the catch block takes effect. In this example, which illustrates one of the many ways a SyncResolver object can be used, the SyncResolver method nextConflict is used in a while loop. The loop will end when nextConflict returns false, which will occur when there are no more conflict rows in the SyncResolver object resolver. In This particular code fragment, resolver looks for rows that have update conflicts (rows with the status SyncResolver.UPDATE_ROW_CONFLICT), and the rest of this code fragment executes only for rows where conflicts occurred because crs was attempting an update.

After the cursor for resolver has moved to the next conflict row that has an update conflict, the method getRow indicates the number of the current row, and the cursor for the CachedRowSet object crs is moved to the comparable row in crs. By iterating through the columns of that row in both resolver and crs, the conflicting values can be retrieved and compared to decide which one should be persisted. In this code fragment, the value in crs is the one set as the resolved value, which means that it will be used to overwrite the conflict value in the data source.

     try {

         crs.acceptChanges(con);

     } catch (SyncProviderException spe) {

         SyncResolver resolver = spe.getSyncResolver();

         Object crsValue;  // value in the RowSet object
         Object resolverValue:  // value in the SyncResolver object
         Object resolvedValue:  // value to be persisted

         while(resolver.nextConflict())  {
             if(resolver.getStatus() == SyncResolver.UPDATE_ROW_CONFLICT)  {
                 int row = resolver.getRow();
                 crs.absolute(row);

                 int colCount = crs.getMetaData().getColumnCount();
                 for(int j = 1; j <= colCount; j++) {
                     if (resolver.getConflictValue(j) != null)  {
                         crsValue = crs.getObject(j);
                         resolverValue = resolver.getConflictValue(j);
                         . . .
                         // compare crsValue and resolverValue to determine
                         // which should be the resolved value (the value to persist)
                         resolvedValue = crsValue;

                         resolver.setResolvedValue(j, resolvedValue);
                      }
                  }
              }
          }
      }

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DELETE_ROW_CONFLICT
      Indicates that a conflict occurred while the RowSet object was attempting to delete a row in the data source.
      static int INSERT_ROW_CONFLICT
      Indicates that a conflict occurred while the RowSet object was attempting to insert a row into the data source.
      static int NO_ROW_CONFLICT
      Indicates that no conflict occured while the RowSet object was attempting to update, delete or insert a row in the data source.
      static int UPDATE_ROW_CONFLICT
      Indicates that a conflict occurred while the RowSet object was attempting to update a row in the data source.

      • 字段 - 继承于接口 java.sql.ResultSet

        CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getConflictValue(int index)
      Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.
      Object getConflictValue(String columnName)
      Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.
      int getStatus()
      Retrieves the conflict status of the current row of this SyncResolver, which indicates the operation the RowSet object was attempting when the conflict occurred.
      boolean nextConflict()
      Moves the cursor down from its current position to the next row that contains a conflict value.
      boolean previousConflict()
      Moves the cursor up from its current position to the previous conflict row in this SyncResolver object.
      void setResolvedValue(int index, Object obj)
      Sets obj as the value in column index in the current row of the RowSet object that is being synchronized.
      void setResolvedValue(String columnName, Object obj)
      Sets obj as the value in column columnName in the current row of the RowSet object that is being synchronized.

      • 方法 - 继承于接口 javax.sql.RowSet

        addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername

      • 方法 - 继承于接口 java.sql.ResultSet

        absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, 下一个, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

      • 方法 - 继承于接口 java.sql.Wrapper

        isWrapperFor, unwrap

    • 字段详细信息

      • UPDATE_ROW_CONFLICT

        static final int UPDATE_ROW_CONFLICT
        Indicates that a conflict occurred while the RowSet object was attempting to update a row in the data source. The values in the data source row to be updated differ from the RowSet object's original values for that row, which means that the row in the data source has been updated or deleted since the last synchronization.
        另请参见：
        Constant Field Values

      • DELETE_ROW_CONFLICT

        static final int DELETE_ROW_CONFLICT
        Indicates that a conflict occurred while the RowSet object was attempting to delete a row in the data source. The values in the data source row to be updated differ from the RowSet object's original values for that row, which means that the row in the data source has been updated or deleted since the last synchronization.
        另请参见：
        Constant Field Values

      • INSERT_ROW_CONFLICT

        static final int INSERT_ROW_CONFLICT
        Indicates that a conflict occurred while the RowSet object was attempting to insert a row into the data source. This means that a row with the same primary key as the row to be inserted has been inserted into the data source since the last synchronization.
        另请参见：
        Constant Field Values

      • NO_ROW_CONFLICT

        static final int NO_ROW_CONFLICT
        Indicates that no conflict occured while the RowSet object was attempting to update, delete or insert a row in the data source. The values in the SyncResolver will contain null values only as an indication that no information in pertitent to the conflict resolution in this row.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getStatus

        int getStatus()
        Retrieves the conflict status of the current row of this SyncResolver, which indicates the operation the RowSet object was attempting when the conflict occurred.
        返回：
        one of the following constants: SyncResolver.UPDATE_ROW_CONFLICT, SyncResolver.DELETE_ROW_CONFLICT, SyncResolver.INSERT_ROW_CONFLICT, or SyncResolver.NO_ROW_CONFLICT

      • getConflictValue

        Object getConflictValue(int index)
                        throws SQLException
        Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.
        参数：
        index - an int designating the column in this row of this SyncResolver object from which to retrieve the value causing a conflict
        返回：
        the value of the designated column in the current row of this SyncResolver object
        抛出：
        SQLException - if a database access error occurs

      • getConflictValue

        Object getConflictValue(String columnName)
                        throws SQLException
        Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.
        参数：
        columnName - a String object designating the column in this row of this SyncResolver object from which to retrieve the value causing a conflict
        返回：
        the value of the designated column in the current row of this SyncResolver object
        抛出：
        SQLException - if a database access error occurs

      • setResolvedValue

        void setResolvedValue(int index,
                    Object obj)
                      throws SQLException
        Sets obj as the value in column index in the current row of the RowSet object that is being synchronized. obj is set as the value in the data source internally.
        参数：
        index - an int giving the number of the column into which to set the value to be persisted
        obj - an Object that is the value to be set in the RowSet object and persisted in the data source
        抛出：
        SQLException - if a database access error occurs

      • setResolvedValue

        void setResolvedValue(String columnName,
                    Object obj)
                      throws SQLException
        Sets obj as the value in column columnName in the current row of the RowSet object that is being synchronized. obj is set as the value in the data source internally.
        参数：
        columnName - a String object giving the name of the column into which to set the value to be persisted
        obj - an Object that is the value to be set in the RowSet object and persisted in the data source
        抛出：
        SQLException - if a database access error occurs

      • nextConflict

        boolean nextConflict()
                     throws SQLException
        Moves the cursor down from its current position to the next row that contains a conflict value. A SyncResolver object's cursor is initially positioned before the first conflict row; the first call to the method nextConflict makes the first conflict row the current row; the second call makes the second conflict row the current row, and so on.

        A call to the method nextConflict will implicitly close an input stream if one is open and will clear the SyncResolver object's warning chain.

        返回：
        true if the new current row is valid; false if there are no more rows
        抛出：
        SQLException - if a database access error occurs or the result set type is TYPE_FORWARD_ONLY

      • previousConflict

        boolean previousConflict()
                         throws SQLException
        Moves the cursor up from its current position to the previous conflict row in this SyncResolver object.

        A call to the method previousConflict will implicitly close an input stream if one is open and will clear the SyncResolver object's warning chain.

        返回：
        true if the cursor is on a valid row; false if it is off the result set
        抛出：
        SQLException - if a database access error occurs or the result set type is TYPE_FORWARD_ONLY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


TransactionalWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset.spi

Interface TransactionalWriter

  • All Superinterfaces:
    RowSetWriter

    public interface TransactionalWriter
extends RowSetWriter
    A specialized interface that facilitates an extension of the standard SyncProvider abstract class so that it has finer grained transaction control.

    If one or more disconnected RowSet objects are particating in a global transaction, they may wish to coordinate their synchronization commits to preserve data integrity and reduce the number of sychronization exceptions. If this is the case, an application should set the CachedRowSet constant COMMIT_ON_ACCEPT_CHANGES to false and use the commit and rollback methods defined in this interface to manage transaction boundaries.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void commit()
      Makes permanent all changes that have been performed by the acceptChanges method since the last call to either the commit or rollback methods.
      void rollback()
      Undoes all changes made in the current transaction.
      void rollback(Savepoint s)
      Undoes all changes made in the current transaction made prior to the given Savepoint object.

      • 方法 - 继承于接口 javax.sql.RowSetWriter

        writeData

    • 方法详细信息

      • commit

        void commit()
            throws SQLException
        Makes permanent all changes that have been performed by the acceptChanges method since the last call to either the commit or rollback methods. This method should be used only when auto-commit mode has been disabled.
        抛出：
        SQLException - if a database access error occurs or the Connection object within this CachedRowSet object is in auto-commit mode

      • rollback

        void rollback()
              throws SQLException
        Undoes all changes made in the current transaction. This method should be used only when auto-commit mode has been disabled.
        抛出：
        SQLException - if a database access error occurs or the Connection object within this CachedRowSet object is in auto-commit mode

      • rollback

        void rollback(Savepoint s)
              throws SQLException
        Undoes all changes made in the current transaction made prior to the given Savepoint object. This method should be used only when auto-commit mode has been disabled.
        参数：
        s - a Savepoint object marking a savepoint in the current transaction. All changes made before s was set will be undone. All changes made after s was set will be made permanent.
        抛出：
        SQLException - if a database access error occurs or the Connection object within this CachedRowSet object is in auto-commit mode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atgi frofr eer ddCCvutvat >>rv,


Uses of Package javax.sql.rowset.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.sql.rowset.spi

  • Packages that use javax.sql.rowset.spi
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
  • Classes in javax.sql.rowset.spi used by javax.sql.rowset
    类与描述
    SyncProvider
    The synchronization mechanism that provides reader/writer capabilities for disconnected RowSet objects.
    SyncProviderException
    Indicates an error with the SyncProvider mechanism.
  • Classes in javax.sql.rowset.spi used by javax.sql.rowset.spi
    类与描述
    SyncFactory
    The Service Provider Interface (SPI) mechanism that generates SyncProvider instances to be used by disconnected RowSet objects.
    SyncFactoryException
    Indicates an error with SyncFactory mechanism.
    SyncProvider
    The synchronization mechanism that provides reader/writer capabilities for disconnected RowSet objects.
    SyncProviderException
    Indicates an error with the SyncProvider mechanism.
    SyncResolver
    Defines a framework that allows applications to use a manual decision tree to decide what should be done when a synchronization conflict occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ciorololna.a.j..�/bb


XmlReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset.spi

Interface XmlReader

  • All Superinterfaces:
    RowSetReader

    public interface XmlReader
extends RowSetReader
    A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.

    SyncProvider implementations that supply XML data reader capabilities such as output XML stream capabilities can implement this interface to provider standard XmlReader objects to WebRowSet implementations.

    An XmlReader object is registered as the XML reader for a WebRowSet by being assigned to the rowset's xmlReader field. When the WebRowSet object's readXml method is invoked, it in turn invokes its XML reader's readXML method.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void readXML(WebRowSet caller, Reader reader)
      Reads and parses the given WebRowSet object from the given input stream in XML format.

      • 方法 - 继承于接口 javax.sql.RowSetReader

        readData

    • 方法详细信息

      • readXML

        void readXML(WebRowSet caller,
           Reader reader)
             throws SQLException
        Reads and parses the given WebRowSet object from the given input stream in XML format. The xmlReader field of the given WebRowSet object must contain this XmlReader object.

        If a parsing error occurs, the exception that is thrown will include information about the location of the error in the original XML document.

        参数：
        caller - the WebRowSet object to be parsed, whose xmlReader field must contain a reference to this XmlReader object
        reader - the java.io.Reader object from which caller will be read
        抛出：
        SQLException - if a database access error occurs or this XmlReader object is not the reader for the given rowset
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

satlpl


XmlWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.sql.rowset.spi

Interface XmlWriter

  • All Superinterfaces:
    RowSetWriter

    public interface XmlWriter
extends RowSetWriter
    A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.

    SyncProvider implementations that supply XML data writer capabilities such as output XML stream capabilities can implement this interface to provider standard XmlWriter objects to WebRowSet implementations.

    Writing a WebRowSet object includes printing the rowset's data, metadata, and properties, all with the appropriate XML tags.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void writeXML(WebRowSet caller, Writer writer)
      Writes the given WebRowSet object to the specified java.io.Writer output stream as an XML document.

      • 方法 - 继承于接口 javax.sql.RowSetWriter

        writeData

    • 方法详细信息

      • writeXML

        void writeXML(WebRowSet caller,
            Writer writer)
              throws SQLException
        Writes the given WebRowSet object to the specified java.io.Writer output stream as an XML document. This document includes the rowset's data, metadata, and properties plus the appropriate XML tags.

        The caller parameter must be a WebRowSet object whose XmlWriter field contains a reference to this XmlWriter object.

        参数：
        caller - the WebRowSet instance to be written, for which this XmlWriter object is the writer
        writer - the java.io.Writer object that serves as the output stream for writing caller as an XML document
        抛出：
        SQLException - if a database access error occurs or this XmlWriter object is not the writer for the given WebRowSet object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

meet.tatutadcumtone�7s/oc/nmseigt.


Uses of Class javax.sql.rowset.spi.SyncFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.spi.SyncFactory

  • Packages that use SyncFactory
    软件包 描述
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of SyncFactory in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that return SyncFactory
      修饰符与类型 方法与描述
      static SyncFactory SyncFactory.getSyncFactory()
      Returns the SyncFactory singleton.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lL


Uses of Class javax.sql.rowset.spi.SyncFactoryException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.spi.SyncFactoryException

  • Packages that use SyncFactoryException
    软件包 描述
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of SyncFactoryException in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that throw SyncFactoryException
      修饰符与类型 方法与描述
      static SyncProvider SyncFactory.getInstance(String providerID)
      Returns the SyncProvider instance identified by providerID.
      static Logger SyncFactory.getLogger()
      Returns the logging object for applications to retrieve synchronization events posted by SyncProvider implementations.
      static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
      Returns an Enumeration of currently registered synchronization providers.
      static void SyncFactory.registerProvider(String providerID)
      Adds the the given synchronization provider to the factory register.
      static void SyncFactory.setJNDIContext(Context ctx)
      Sets the initial JNDI context from which SyncProvider implementations can be retrieved from a JNDI namespace
      static void SyncFactory.unregisterProvider(String providerID)
      Removes the designated currently registered synchronization provider from the Factory SPI register.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/""ti < >) g<">b/r>in


Uses of Class javax.sql.rowset.spi.SyncProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.spi.SyncProvider

  • Packages that use SyncProvider
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of SyncProvider in javax.sql.rowset

      Methods in javax.sql.rowset that return SyncProvider
      修饰符与类型 方法与描述
      SyncProvider CachedRowSet.getSyncProvider()
      Retrieves the SyncProvider implementation for this CachedRowSet object.

    • Uses of SyncProvider in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that return SyncProvider
      修饰符与类型 方法与描述
      static SyncProvider SyncFactory.getInstance(String providerID)
      Returns the SyncProvider instance identified by providerID.
      Methods in javax.sql.rowset.spi that return types with arguments of type SyncProvider
      修饰符与类型 方法与描述
      static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
      Returns an Enumeration of currently registered synchronization providers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>肩t�< o � g>o>< <


Uses of Class javax.sql.rowset.spi.SyncProviderException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.sql.rowset.spi.SyncProviderException

  • Packages that use SyncProviderException
    软件包 描述
    javax.sql.rowset
    Standard interfaces and base classes for JDBC RowSet implementations.
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of SyncProviderException in javax.sql.rowset

      Methods in javax.sql.rowset that throw SyncProviderException
      修饰符与类型 方法与描述
      void CachedRowSet.acceptChanges()
      Propagates row update, insert and delete changes made to this CachedRowSet object to the underlying data source.
      void CachedRowSet.acceptChanges(Connection con)
      Propagates all row update, insert and delete changes to the data source backing this CachedRowSet object using the specified Connection object to establish a connection to the data source.

    • Uses of SyncProviderException in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that throw SyncProviderException
      修饰符与类型 方法与描述
      abstract int SyncProvider.getDataSourceLock()
      Returns the current data source lock severity level active in this SyncProvider implementation.
      abstract void SyncProvider.setDataSourceLock(int datasource_lock)
      Sets a lock on the underlying data source at the level indicated by datasource_lock.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Oaooadakon,dkdl�"坤�<<雔


Uses of Interface javax.sql.rowset.spi.SyncResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.spi.SyncResolver

  • Packages that use SyncResolver
    软件包 描述
    javax.sql.rowset.spi
    The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.

    • Uses of SyncResolver in javax.sql.rowset.spi

      Methods in javax.sql.rowset.spi that return SyncResolver
      修饰符与类型 方法与描述
      SyncResolver SyncProviderException.getSyncResolver()
      Retrieves the SyncResolver object that has been set for this SyncProviderException object, or if none has been set, an instance of the default SyncResolver implementation included in the reference implementation.
      Methods in javax.sql.rowset.spi with parameters of type SyncResolver
      修饰符与类型 方法与描述
      void SyncProviderException.setSyncResolver(SyncResolver syncResolver)
      Sets the SyncResolver object for this SyncProviderException object to the one supplied.
      Constructors in javax.sql.rowset.spi with parameters of type SyncResolver
      构造方法与描述
      SyncProviderException(SyncResolver syncResolver)
      Constructs a SyncProviderException object with the specified SyncResolver instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hrrre<<<.r f/<,/ /r耄aa（


Uses of Interface javax.sql.rowset.spi.TransactionalWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.spi.TransactionalWriter

No usage of javax.sql.rowset.spi.TransactionalWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

at tpanno>>>poaal==pn


Uses of Interface javax.sql.rowset.spi.XmlReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.spi.XmlReader

No usage of javax.sql.rowset.spi.XmlReader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

at—间讳篇嗽冰籶Ｃ粼3


Uses of Interface javax.sql.rowset.spi.XmlWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.sql.rowset.spi.XmlWriter

No usage of javax.sql.rowset.spi.XmlWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tm碅|�*�i堸p�


AbstractAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractAction

  • java.lang.Object
    • javax.swing.AbstractAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    直接已知子类：
    BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicSliderUI.ActionScroller, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreePageAction, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, MetalFileChooserUI.DirectoryComboBoxAction, TextAction

    public abstract class AbstractAction
extends Object
implements Action, Cloneable, Serializable
    This class provides default implementations for the JFC Action interface. Standard behaviors like the get and set methods for Action object properties (icon, text, and enabled) are defined here. The developer need only subclass this abstract class and define the actionPerformed method.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Action

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected SwingPropertyChangeSupport changeSupport
      If any PropertyChangeListeners have been registered, the changeSupport field describes them.
      protected boolean enabled
      Specifies whether action is enabled; the default is true.

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractAction()
      Creates an Action.
      AbstractAction(String name)
      Creates an Action with the specified name.
      AbstractAction(String name, Icon icon)
      Creates an Action with the specified name and small icon.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      protected Object clone()
      Clones the abstract action.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Supports reporting bound property changes.
      Object[] getKeys()
      Returns an array of Objects which are keys for which values have been set for this AbstractAction, or null if no keys have values set.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the PropertyChangeListeners added to this AbstractAction with addPropertyChangeListener().
      Object getValue(String key)
      Gets the Object associated with the specified key.
      boolean isEnabled()
      Returns true if the action is enabled.
      void putValue(String key, Object newValue)
      Sets the Value associated with the specified key.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void setEnabled(boolean newValue)
      Sets whether the Action is enabled.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.ActionListener

        actionPerformed

    • 字段详细信息

      • enabled

        protected boolean enabled
        Specifies whether action is enabled; the default is true.

      • changeSupport

        protected SwingPropertyChangeSupport changeSupport
        If any PropertyChangeListeners have been registered, the changeSupport field describes them.

    • 构造方法详细信息

      • AbstractAction

        public AbstractAction()
        Creates an Action.

      • AbstractAction

        public AbstractAction(String name)
        Creates an Action with the specified name.
        参数：
        name - the name (Action.NAME) for the action; a value of null is ignored

      • AbstractAction

        public AbstractAction(String name,
              Icon icon)
        Creates an Action with the specified name and small icon.
        参数：
        name - the name (Action.NAME) for the action; a value of null is ignored
        icon - the small icon (Action.SMALL_ICON) for the action; a value of null is ignored

    • 方法详细信息

      • getValue

        public Object getValue(String key)
        Gets the Object associated with the specified key.
        指定者：
        getValue in interface Action
        参数：
        key - a string containing the specified key
        返回：
        the binding Object stored with this key; if there are no keys, it will return null
        另请参见：
        Action.getValue(java.lang.String)

      • putValue

        public void putValue(String key,
            Object newValue)
        Sets the Value associated with the specified key.
        指定者：
        putValue in interface Action
        参数：
        key - the String that identifies the stored object
        newValue - the Object to store using this key
        另请参见：
        Action.putValue(java.lang.String, java.lang.Object)

      • isEnabled

        public boolean isEnabled()
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()

      • setEnabled

        public void setEnabled(boolean newValue)
        Sets whether the Action is enabled. The default is true.
        指定者：
        setEnabled in interface Action
        参数：
        newValue - true to enable the action, false to disable it
        另请参见：
        Action.setEnabled(boolean)

      • getKeys

        public Object[] getKeys()
        Returns an array of Objects which are keys for which values have been set for this AbstractAction, or null if no keys have values set.
        返回：
        an array of key objects, or null if no keys have values set
        从以下版本开始：
        1.3

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Supports reporting bound property changes. This method can be called when a bound property has changed and it will send the appropriate PropertyChangeEvent to any registered PropertyChangeListeners.

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired in response to setting a bound property, e.g. setFont, setBackground, or setForeground. Note that if the current component is inheriting its foreground, background, or font from its container, then no event will be fired in response to a change in the inherited property.

        指定者：
        addPropertyChangeListener in interface Action
        参数：
        listener - The PropertyChangeListener to be added
        另请参见：
        Action.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        指定者：
        removePropertyChangeListener in interface Action
        参数：
        listener - the PropertyChangeListener to be removed
        另请参见：
        Action.removePropertyChangeListener(java.beans.PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the PropertyChangeListeners added to this AbstractAction with addPropertyChangeListener().
        返回：
        all of the PropertyChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • clone

        protected Object clone()
                throws CloneNotSupportedException
        Clones the abstract action. This gives the clone its own copy of the key/value list, which is not handled for you by Object.clone().
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        抛出：
        CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, SwingConstants
    直接已知子类：
    JButton, JMenuItem, JToggleButton

    public abstract class AbstractButton
extends JComponent
implements ItemSelectable, SwingConstants
    Defines common behaviors for buttons and menu items.

    Buttons can be configured, and to some degree controlled, by Actions. Using an Action with a button has many benefits beyond directly configuring a button. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    For further information see How to Use Buttons, Check Boxes, and Radio Buttons, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  AbstractButton.AccessibleAbstractButton
      This class implements accessibility support for the AbstractButton class.
      protected class  AbstractButton.ButtonChangeListener
      Extends ChangeListener to be serializable.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ActionListener actionListener
      The button model's ActionListener.
      static String BORDER_PAINTED_CHANGED_PROPERTY
      Identifies a change to having the border drawn, or having it not drawn.
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per button instance since the event's only state is the source property.
      protected ChangeListener changeListener
      The button model's changeListener.
      static String CONTENT_AREA_FILLED_CHANGED_PROPERTY
      Identifies a change to having the button paint the content area.
      static String DISABLED_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the button has been disabled.
      static String DISABLED_SELECTED_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the button has been disabled and selected.
      static String FOCUS_PAINTED_CHANGED_PROPERTY
      Identifies a change to having the border highlighted when focused, or not.
      static String HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY
      Identifies a change in the button's horizontal alignment.
      static String HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY
      Identifies a change in the button's horizontal text position.
      static String ICON_CHANGED_PROPERTY
      Identifies a change to the icon that represents the button.
      protected ItemListener itemListener
      The button model's ItemListener.
      static String MARGIN_CHANGED_PROPERTY
      Identifies a change in the button's margins.
      static String MNEMONIC_CHANGED_PROPERTY
      Identifies a change to the button's mnemonic.
      protected ButtonModel model
      The data model that determines the button's state.
      static String MODEL_CHANGED_PROPERTY
      Identifies a change in the button model.
      static String PRESSED_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the button has been pressed.
      static String ROLLOVER_ENABLED_CHANGED_PROPERTY
      Identifies a change from rollover enabled to disabled or back to enabled.
      static String ROLLOVER_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the cursor is over the button.
      static String ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the cursor is over the button and it has been selected.
      static String SELECTED_ICON_CHANGED_PROPERTY
      Identifies a change to the icon used when the button has been selected.
      static String TEXT_CHANGED_PROPERTY
      Identifies a change in the button's text.
      static String VERTICAL_ALIGNMENT_CHANGED_PROPERTY
      Identifies a change in the button's vertical alignment.
      static String VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
      Identifies a change in the button's vertical text position.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractButton()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void actionPropertyChanged(Action action, String propertyName)
      Updates the button's state in response to property changes in the associated action.
      void addActionListener(ActionListener l)
      Adds an ActionListener to the button.
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified component to this container at the specified index, refer to Container.addImpl(Component, Object, int) for a complete description of this method.
      void addItemListener(ItemListener l)
      Adds an ItemListener to the checkbox.
      protected int checkHorizontalKey(int key, String exception)
      Verify that the key argument is a legal value for the horizontalAlignment and horizontalTextPosition properties.
      protected int checkVerticalKey(int key, String exception)
      Verify that the key argument is a legal value for the vertical properties.
      protected void configurePropertiesFromAction(Action a)
      Sets the properties on this button to match those in the specified Action.
      protected ActionListener | createActionListener()
      protected PropertyChangeListener createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      protected ChangeListener createChangeListener()
      Subclasses that want to handle ChangeEvents differently can override this to return another ChangeListener implementation.
      protected ItemListener | createItemListener()
      void doClick()
      Programmatically perform a "click".
      void doClick(int pressTime)
      Programmatically perform a "click".
      protected void fireActionPerformed(ActionEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireItemStateChanged(ItemEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      Action getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      String getActionCommand()
      Returns the action command for this button.
      ActionListener[] getActionListeners()
      Returns an array of all the ActionListeners added to this AbstractButton with addActionListener().
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this AbstractButton with addChangeListener().
      Icon getDisabledIcon()
      Returns the icon used by the button when it's disabled.
      Icon getDisabledSelectedIcon()
      Returns the icon used by the button when it's disabled and selected.
      int getDisplayedMnemonicIndex()
      Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
      boolean getHideActionText()
      Returns the value of the hideActionText property, which determines whether the button displays text from the Action.
      int getHorizontalAlignment()
      Returns the horizontal alignment of the icon and text.
      int getHorizontalTextPosition()
      Returns the horizontal position of the text relative to the icon.
      Icon getIcon()
      Returns the default icon.
      int getIconTextGap()
      Returns the amount of space between the text and the icon displayed in this button.
      ItemListener[] getItemListeners()
      Returns an array of all the ItemListeners added to this AbstractButton with addItemListener().
      String getLabel()
      Deprecated.
      - Replaced by getText
      Insets getMargin()
      Returns the margin between the button's border and the label.
      int getMnemonic()
      Returns the keyboard mnemonic from the the current model.
      ButtonModel getModel()
      Returns the model that this button represents.
      long getMultiClickThreshhold()
      Gets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.
      Icon getPressedIcon()
      Returns the pressed icon for the button.
      Icon getRolloverIcon()
      Returns the rollover icon for the button.
      Icon getRolloverSelectedIcon()
      Returns the rollover selection icon for the button.
      Icon getSelectedIcon()
      Returns the selected icon for the button.
      Object[] getSelectedObjects()
      Returns an array (length 1) containing the label or null if the button is not selected.
      String getText()
      Returns the button's text.
      ButtonUI getUI()
      Returns the L&F object that renders this component.
      int getVerticalAlignment()
      Returns the vertical alignment of the text and icon.
      int getVerticalTextPosition()
      Returns the vertical position of the text relative to the icon.
      boolean imageUpdate(Image img, int infoflags, int x, int y, int w, int h)
      This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
      protected void | init(String text, Icon icon)
      boolean isBorderPainted()
      Gets the borderPainted property.
      boolean isContentAreaFilled()
      Gets the contentAreaFilled property.
      boolean isFocusPainted()
      Gets the paintFocus property.
      boolean isRolloverEnabled()
      Gets the rolloverEnabled property.
      boolean isSelected()
      Returns the state of the button.
      protected void paintBorder(Graphics g)
      Paint the button's border if BorderPainted property is true and the button has a border.
      protected String paramString()
      Returns a string representation of this AbstractButton.
      void removeActionListener(ActionListener l)
      Removes an ActionListener from the button.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.
      void removeItemListener(ItemListener l)
      Removes an ItemListener from the button.
      void removeNotify()
      Notifies this component that it no longer has a parent component.
      void setAction(Action a)
      Sets the Action.
      void setActionCommand(String actionCommand)
      Sets the action command for this button.
      void setBorderPainted(boolean b)
      Sets the borderPainted property.
      void setContentAreaFilled(boolean b)
      Sets the contentAreaFilled property.
      void setDisabledIcon(Icon disabledIcon)
      Sets the disabled icon for the button.
      void setDisabledSelectedIcon(Icon disabledSelectedIcon)
      Sets the disabled selection icon for the button.
      void setDisplayedMnemonicIndex(int index)
      Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.
      void setEnabled(boolean b)
      Enables (or disables) the button.
      void setFocusPainted(boolean b)
      Sets the paintFocus property, which must be true for the focus state to be painted.
      void setHideActionText(boolean hideActionText)
      Sets the hideActionText property, which determines whether the button displays text from the Action.
      void setHorizontalAlignment(int alignment)
      Sets the horizontal alignment of the icon and text.
      void setHorizontalTextPosition(int textPosition)
      Sets the horizontal position of the text relative to the icon.
      void setIcon(Icon defaultIcon)
      Sets the button's default icon.
      void setIconTextGap(int iconTextGap)
      If both the icon and text properties are set, this property defines the space between them.
      void setLabel(String label)
      Deprecated.
      - Replaced by setText(text)
      void setLayout(LayoutManager mgr)
      Sets the layout manager for this container, refer to Container.setLayout(LayoutManager) for a complete description of this method.
      void setMargin(Insets m)
      Sets space for margin between the button's border and the label.
      void setMnemonic(char mnemonic)
      This method is now obsolete, please use setMnemonic(int) to set the mnemonic for a button.
      void setMnemonic(int mnemonic)
      Sets the keyboard mnemonic on the current model.
      void setModel(ButtonModel newModel)
      Sets the model that this button represents.
      void setMultiClickThreshhold(long threshhold)
      Sets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.
      void setPressedIcon(Icon pressedIcon)
      Sets the pressed icon for the button.
      void setRolloverEnabled(boolean b)
      Sets the rolloverEnabled property, which must be true for rollover effects to occur.
      void setRolloverIcon(Icon rolloverIcon)
      Sets the rollover icon for the button.
      void setRolloverSelectedIcon(Icon rolloverSelectedIcon)
      Sets the rollover selected icon for the button.
      void setSelected(boolean b)
      Sets the state of the button.
      void setSelectedIcon(Icon selectedIcon)
      Sets the selected icon for the button.
      void setText(String text)
      Sets the button's text.
      void setUI(ButtonUI ui)
      Sets the L&F object that renders this component.
      void setVerticalAlignment(int alignment)
      Sets the vertical alignment of the icon and text.
      void setVerticalTextPosition(int textPosition)
      Sets the vertical position of the text relative to the icon.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • MODEL_CHANGED_PROPERTY

        public static final String MODEL_CHANGED_PROPERTY
        Identifies a change in the button model.
        另请参见：
        Constant Field Values

      • TEXT_CHANGED_PROPERTY

        public static final String TEXT_CHANGED_PROPERTY
        Identifies a change in the button's text.
        另请参见：
        Constant Field Values

      • MNEMONIC_CHANGED_PROPERTY

        public static final String MNEMONIC_CHANGED_PROPERTY
        Identifies a change to the button's mnemonic.
        另请参见：
        Constant Field Values

      • MARGIN_CHANGED_PROPERTY

        public static final String MARGIN_CHANGED_PROPERTY
        Identifies a change in the button's margins.
        另请参见：
        Constant Field Values

      • VERTICAL_ALIGNMENT_CHANGED_PROPERTY

        public static final String VERTICAL_ALIGNMENT_CHANGED_PROPERTY
        Identifies a change in the button's vertical alignment.
        另请参见：
        Constant Field Values

      • HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY

        public static final String HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY
        Identifies a change in the button's horizontal alignment.
        另请参见：
        Constant Field Values

      • VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

        public static final String VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
        Identifies a change in the button's vertical text position.
        另请参见：
        Constant Field Values

      • HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY

        public static final String HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY
        Identifies a change in the button's horizontal text position.
        另请参见：
        Constant Field Values

      • BORDER_PAINTED_CHANGED_PROPERTY

        public static final String BORDER_PAINTED_CHANGED_PROPERTY
        Identifies a change to having the border drawn, or having it not drawn.
        另请参见：
        Constant Field Values

      • FOCUS_PAINTED_CHANGED_PROPERTY

        public static final String FOCUS_PAINTED_CHANGED_PROPERTY
        Identifies a change to having the border highlighted when focused, or not.
        另请参见：
        Constant Field Values

      • ROLLOVER_ENABLED_CHANGED_PROPERTY

        public static final String ROLLOVER_ENABLED_CHANGED_PROPERTY
        Identifies a change from rollover enabled to disabled or back to enabled.
        另请参见：
        Constant Field Values

      • CONTENT_AREA_FILLED_CHANGED_PROPERTY

        public static final String CONTENT_AREA_FILLED_CHANGED_PROPERTY
        Identifies a change to having the button paint the content area.
        另请参见：
        Constant Field Values

      • ICON_CHANGED_PROPERTY

        public static final String ICON_CHANGED_PROPERTY
        Identifies a change to the icon that represents the button.
        另请参见：
        Constant Field Values

      • PRESSED_ICON_CHANGED_PROPERTY

        public static final String PRESSED_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the button has been pressed.
        另请参见：
        Constant Field Values

      • SELECTED_ICON_CHANGED_PROPERTY

        public static final String SELECTED_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the button has been selected.
        另请参见：
        Constant Field Values

      • ROLLOVER_ICON_CHANGED_PROPERTY

        public static final String ROLLOVER_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the cursor is over the button.
        另请参见：
        Constant Field Values

      • ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY

        public static final String ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the cursor is over the button and it has been selected.
        另请参见：
        Constant Field Values

      • DISABLED_ICON_CHANGED_PROPERTY

        public static final String DISABLED_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the button has been disabled.
        另请参见：
        Constant Field Values

      • DISABLED_SELECTED_ICON_CHANGED_PROPERTY

        public static final String DISABLED_SELECTED_ICON_CHANGED_PROPERTY
        Identifies a change to the icon used when the button has been disabled and selected.
        另请参见：
        Constant Field Values

      • model

        protected ButtonModel model
        The data model that determines the button's state.

      • changeListener

        protected ChangeListener changeListener
        The button model's changeListener.

      • actionListener

        protected ActionListener actionListener
        The button model's ActionListener.

      • itemListener

        protected ItemListener itemListener
        The button model's ItemListener.

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per button instance since the event's only state is the source property. The source of events generated is always "this".

    • 构造方法详细信息

      • AbstractButton

        public AbstractButton()

    • 方法详细信息

      • setHideActionText

        public void setHideActionText(boolean hideActionText)
        Sets the hideActionText property, which determines whether the button displays text from the Action. This is useful only if an Action has been installed on the button.
        参数：
        hideActionText - true if the button's text property should not reflect that of the Action; the default is false
        从以下版本开始：
        1.6
        另请参见：
        Swing Components Supporting Action

      • getHideActionText

        public boolean getHideActionText()
        Returns the value of the hideActionText property, which determines whether the button displays text from the Action. This is useful only if an Action has been installed on the button.
        返回：
        true if the button's text property should not reflect that of the Action; the default is false
        从以下版本开始：
        1.6

      • getText

        public String getText()
        Returns the button's text.
        返回：
        the buttons text
        另请参见：
        setText(java.lang.String)

      • setText

        public void setText(String text)
        Sets the button's text.
        参数：
        text - the string used to set the text
        另请参见：
        getText()

      • isSelected

        public boolean isSelected()
        Returns the state of the button. True if the toggle button is selected, false if it's not.
        返回：
        true if the toggle button is selected, otherwise false

      • setSelected

        public void setSelected(boolean b)
        Sets the state of the button. Note that this method does not trigger an actionEvent. Call doClick to perform a programatic action change.
        参数：
        b - true if the button is selected, otherwise false

      • doClick

        public void doClick()
        Programmatically perform a "click". This does the same thing as if the user had pressed and released the button.

      • doClick

        public void doClick(int pressTime)
        Programmatically perform a "click". This does the same thing as if the user had pressed and released the button. The button stays visually "pressed" for pressTime milliseconds.
        参数：
        pressTime - the time to "hold down" the button, in milliseconds

      • setMargin

        public void setMargin(Insets m)
        Sets space for margin between the button's border and the label. Setting to null will cause the button to use the default margin. The button's default Border object will use this value to create the proper margin. However, if a non-default border is set on the button, it is that Border object's responsibility to create the appropriate margin space (else this property will effectively be ignored).
        参数：
        m - the space between the border and the label

      • getMargin

        public Insets getMargin()
        Returns the margin between the button's border and the label.
        返回：
        an Insets object specifying the margin between the botton's border and the label
        另请参见：
        setMargin(java.awt.Insets)

      • getIcon

        public Icon getIcon()
        Returns the default icon.
        返回：
        the default Icon
        另请参见：
        setIcon(javax.swing.Icon)

      • setIcon

        public void setIcon(Icon defaultIcon)
        Sets the button's default icon. This icon is also used as the "pressed" and "disabled" icon if there is no explicitly set pressed icon.
        参数：
        defaultIcon - the icon used as the default image
        另请参见：
        getIcon(), setPressedIcon(javax.swing.Icon)

      • getPressedIcon

        public Icon getPressedIcon()
        Returns the pressed icon for the button.
        返回：
        the pressedIcon property
        另请参见：
        setPressedIcon(javax.swing.Icon)

      • setPressedIcon

        public void setPressedIcon(Icon pressedIcon)
        Sets the pressed icon for the button.
        参数：
        pressedIcon - the icon used as the "pressed" image
        另请参见：
        getPressedIcon()

      • getSelectedIcon

        public Icon getSelectedIcon()
        Returns the selected icon for the button.
        返回：
        the selectedIcon property
        另请参见：
        setSelectedIcon(javax.swing.Icon)

      • setSelectedIcon

        public void setSelectedIcon(Icon selectedIcon)
        Sets the selected icon for the button.
        参数：
        selectedIcon - the icon used as the "selected" image
        另请参见：
        getSelectedIcon()

      • getRolloverIcon

        public Icon getRolloverIcon()
        Returns the rollover icon for the button.
        返回：
        the rolloverIcon property
        另请参见：
        setRolloverIcon(javax.swing.Icon)

      • setRolloverIcon

        public void setRolloverIcon(Icon rolloverIcon)
        Sets the rollover icon for the button.
        参数：
        rolloverIcon - the icon used as the "rollover" image
        另请参见：
        getRolloverIcon()

      • getRolloverSelectedIcon

        public Icon getRolloverSelectedIcon()
        Returns the rollover selection icon for the button.
        返回：
        the rolloverSelectedIcon property
        另请参见：
        setRolloverSelectedIcon(javax.swing.Icon)

      • setRolloverSelectedIcon

        public void setRolloverSelectedIcon(Icon rolloverSelectedIcon)
        Sets the rollover selected icon for the button.
        参数：
        rolloverSelectedIcon - the icon used as the "selected rollover" image
        另请参见：
        getRolloverSelectedIcon()

      • getDisabledIcon

        public Icon getDisabledIcon()
        Returns the icon used by the button when it's disabled. If no disabled icon has been set this will forward the call to the look and feel to construct an appropriate disabled Icon.

        Some look and feels might not render the disabled Icon, in which case they will ignore this.

        返回：
        the disabledIcon property
        另请参见：
        getPressedIcon(),
setDisabledIcon(javax.swing.Icon),
LookAndFeel.getDisabledIcon(javax.swing.JComponent, javax.swing.Icon)

      • setDisabledIcon

        public void setDisabledIcon(Icon disabledIcon)
        Sets the disabled icon for the button.
        参数：
        disabledIcon - the icon used as the disabled image
        另请参见：
        getDisabledIcon()

      • getDisabledSelectedIcon

        public Icon getDisabledSelectedIcon()
        Returns the icon used by the button when it's disabled and selected. If no disabled selection icon has been set, this will forward the call to the LookAndFeel to construct an appropriate disabled Icon from the selection icon if it has been set and to getDisabledIcon() otherwise.

        Some look and feels might not render the disabled selected Icon, in which case they will ignore this.

        返回：
        the disabledSelectedIcon property
        另请参见：
        getDisabledIcon(),
setDisabledSelectedIcon(javax.swing.Icon),
LookAndFeel.getDisabledSelectedIcon(javax.swing.JComponent, javax.swing.Icon)

      • setDisabledSelectedIcon

        public void setDisabledSelectedIcon(Icon disabledSelectedIcon)
        Sets the disabled selection icon for the button.
        参数：
        disabledSelectedIcon - the icon used as the disabled selection image
        另请参见：
        getDisabledSelectedIcon()

      • getVerticalAlignment

        public int getVerticalAlignment()
        Returns the vertical alignment of the text and icon.
        返回：
        the verticalAlignment property, one of the following values:
        • SwingConstants.CENTER (the default)
        • SwingConstants.TOP
        • SwingConstants.BOTTOM

      • setVerticalAlignment

        public void setVerticalAlignment(int alignment)
        Sets the vertical alignment of the icon and text.
        参数：
        alignment - one of the following values:
        • SwingConstants.CENTER (the default)
        • SwingConstants.TOP
        • SwingConstants.BOTTOM
        抛出：
        IllegalArgumentException - if the alignment is not one of the legal values listed above

      • getHorizontalAlignment

        public int getHorizontalAlignment()
        Returns the horizontal alignment of the icon and text. AbstractButton's default is SwingConstants.CENTER, but subclasses such as JCheckBox may use a different default.
        返回：
        the horizontalAlignment property, one of the following values:
        • SwingConstants.RIGHT
        • SwingConstants.LEFT
        • SwingConstants.CENTER
        • SwingConstants.LEADING
        • SwingConstants.TRAILING

      • setHorizontalAlignment

        public void setHorizontalAlignment(int alignment)
        Sets the horizontal alignment of the icon and text. AbstractButton's default is SwingConstants.CENTER, but subclasses such as JCheckBox may use a different default.
        参数：
        alignment - the alignment value, one of the following values:
        • SwingConstants.RIGHT
        • SwingConstants.LEFT
        • SwingConstants.CENTER
        • SwingConstants.LEADING
        • SwingConstants.TRAILING
        抛出：
        IllegalArgumentException - if the alignment is not one of the valid values

      • getVerticalTextPosition

        public int getVerticalTextPosition()
        Returns the vertical position of the text relative to the icon.
        返回：
        the verticalTextPosition property, one of the following values:
        • SwingConstants.CENTER (the default)
        • SwingConstants.TOP
        • SwingConstants.BOTTOM

      • setVerticalTextPosition

        public void setVerticalTextPosition(int textPosition)
        Sets the vertical position of the text relative to the icon.
        参数：
        textPosition - one of the following values:
        • SwingConstants.CENTER (the default)
        • SwingConstants.TOP
        • SwingConstants.BOTTOM

      • getHorizontalTextPosition

        public int getHorizontalTextPosition()
        Returns the horizontal position of the text relative to the icon.
        返回：
        the horizontalTextPosition property, one of the following values:
        • SwingConstants.RIGHT
        • SwingConstants.LEFT
        • SwingConstants.CENTER
        • SwingConstants.LEADING
        • SwingConstants.TRAILING (the default)

      • setHorizontalTextPosition

        public void setHorizontalTextPosition(int textPosition)
        Sets the horizontal position of the text relative to the icon.
        参数：
        textPosition - one of the following values:
        • SwingConstants.RIGHT
        • SwingConstants.LEFT
        • SwingConstants.CENTER
        • SwingConstants.LEADING
        • SwingConstants.TRAILING (the default)
        抛出：
        IllegalArgumentException - if textPosition is not one of the legal values listed above

      • getIconTextGap

        public int getIconTextGap()
        Returns the amount of space between the text and the icon displayed in this button.
        返回：
        an int equal to the number of pixels between the text and the icon.
        从以下版本开始：
        1.4
        另请参见：
        setIconTextGap(int)

      • setIconTextGap

        public void setIconTextGap(int iconTextGap)
        If both the icon and text properties are set, this property defines the space between them.

        The default value of this property is 4 pixels.

        This is a JavaBeans bound property.

        从以下版本开始：
        1.4
        另请参见：
        getIconTextGap()

      • checkHorizontalKey

        protected int checkHorizontalKey(int key,
                     String exception)
        Verify that the key argument is a legal value for the horizontalAlignment and horizontalTextPosition properties. Valid values are:
        • SwingConstants.RIGHT
        • SwingConstants.LEFT
        • SwingConstants.CENTER
        • SwingConstants.LEADING
        • SwingConstants.TRAILING
        参数：
        key - the property value to check
        exception - the message to use in the IllegalArgumentException that is thrown for an invalid value
        抛出：
        IllegalArgumentException - if key is not one of the legal values listed above
        另请参见：
        setHorizontalTextPosition(int), setHorizontalAlignment(int)

      • checkVerticalKey

        protected int checkVerticalKey(int key,
                   String exception)
        Verify that the key argument is a legal value for the vertical properties. Valid values are:
        • SwingConstants.CENTER
        • SwingConstants.TOP
        • SwingConstants.BOTTOM
        参数：
        key - the property value to check
        exception - the message to use in the IllegalArgumentException that is thrown for an invalid value
        抛出：
        IllegalArgumentException - if key is not one of the legal values listed above

      • removeNotify

        public void removeNotify()
        Notifies this component that it no longer has a parent component. When this method is invoked, any KeyboardActions set up in the the chain of parent components are removed. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        removeNotify in class JComponent
        从以下版本开始：
        1.6
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • setActionCommand

        public void setActionCommand(String actionCommand)
        Sets the action command for this button.
        参数：
        actionCommand - the action command for this button

      • getActionCommand

        public String getActionCommand()
        Returns the action command for this button.
        返回：
        the action command for this button

      • setAction

        public void setAction(Action a)
        Sets the Action. The new Action replaces any previously set Action but does not affect ActionListeners independently added with addActionListener. If the Action is already a registered ActionListener for the button, it is not re-registered.

        Setting the Action results in immediately changing all the properties described in Swing Components Supporting Action. Subsequently, the button's properties are automatically updated as the Action's properties change.

        This method uses three other methods to set and help track the Action's property values. It uses the configurePropertiesFromAction method to immediately change the button's properties. To track changes in the Action's property values, this method registers the PropertyChangeListener returned by createActionPropertyChangeListener. The default PropertyChangeListener invokes the actionPropertyChanged method when a property in the Action changes.

        参数：
        a - the Action for the AbstractButton, or null
        从以下版本开始：
        1.3
        另请参见：
        Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

      • getAction

        public Action getAction()
        Returns the currently set Action for this ActionEvent source, or null if no Action is set.
        返回：
        the Action for this ActionEvent source, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • configurePropertiesFromAction

        protected void configurePropertiesFromAction(Action a)
        Sets the properties on this button to match those in the specified Action. Refer to Swing Components Supporting Action for more details as to which properties this sets.
        参数：
        a - the Action from which to get the properties, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • actionPropertyChanged

        protected void actionPropertyChanged(Action action,
                         String propertyName)
        Updates the button's state in response to property changes in the associated action. This method is invoked from the PropertyChangeListener returned from createActionPropertyChangeListener. Subclasses do not normally need to invoke this. Subclasses that support additional Action properties should override this and configurePropertiesFromAction.

        Refer to the table at Swing Components Supporting Action for a list of the properties this method sets.

        参数：
        action - the Action associated with this button
        propertyName - the name of the property that changed
        从以下版本开始：
        1.6
        另请参见：
        Action, configurePropertiesFromAction(javax.swing.Action)

      • createActionPropertyChangeListener

        protected PropertyChangeListener createActionPropertyChangeListener(Action a)
        Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.

        警告： If you subclass this do not create an anonymous inner class. If you do the lifetime of the button will be tied to that of the Action.

        参数：
        a - the button's action
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • isBorderPainted

        public boolean isBorderPainted()
        Gets the borderPainted property.
        返回：
        the value of the borderPainted property
        另请参见：
        setBorderPainted(boolean)

      • setBorderPainted

        public void setBorderPainted(boolean b)
        Sets the borderPainted property. If true and the button has a border, the border is painted. The default value for the borderPainted property is true.

        Some look and feels might not support the borderPainted property, in which case they ignore this.

        参数：
        b - if true and border property is not null, the border is painted
        另请参见：
        isBorderPainted()

      • paintBorder

        protected void paintBorder(Graphics g)
        Paint the button's border if BorderPainted property is true and the button has a border.
        重载：
        paintBorder in class JComponent
        参数：
        g - the Graphics context in which to paint
        另请参见：
        JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

      • isFocusPainted

        public boolean isFocusPainted()
        Gets the paintFocus property.
        返回：
        the paintFocus property
        另请参见：
        setFocusPainted(boolean)

      • setFocusPainted

        public void setFocusPainted(boolean b)
        Sets the paintFocus property, which must be true for the focus state to be painted. The default value for the paintFocus property is true. Some look and feels might not paint focus state; they will ignore this property.
        参数：
        b - if true, the focus state should be painted
        另请参见：
        isFocusPainted()

      • isContentAreaFilled

        public boolean isContentAreaFilled()
        Gets the contentAreaFilled property.
        返回：
        the contentAreaFilled property
        另请参见：
        setContentAreaFilled(boolean)

      • setContentAreaFilled

        public void setContentAreaFilled(boolean b)
        Sets the contentAreaFilled property. If true the button will paint the content area. If you wish to have a transparent button, such as an icon only button, for example, then you should set this to false. Do not call setOpaque(false). The default value for the the contentAreaFilled property is true.

        This function may cause the component's opaque property to change.

        The exact behavior of calling this function varies on a component-by-component and L&F-by-L&F basis.

        参数：
        b - if true, the content should be filled; if false the content area is not filled
        另请参见：
        isContentAreaFilled(), JComponent.setOpaque(boolean)

      • isRolloverEnabled

        public boolean isRolloverEnabled()
        Gets the rolloverEnabled property.
        返回：
        the value of the rolloverEnabled property
        另请参见：
        setRolloverEnabled(boolean)

      • setRolloverEnabled

        public void setRolloverEnabled(boolean b)
        Sets the rolloverEnabled property, which must be true for rollover effects to occur. The default value for the rolloverEnabled property is false. Some look and feels might not implement rollover effects; they will ignore this property.
        参数：
        b - if true, rollover effects should be painted
        另请参见：
        isRolloverEnabled()

      • getMnemonic

        public int getMnemonic()
        Returns the keyboard mnemonic from the the current model.
        返回：
        the keyboard mnemonic from the model

      • setMnemonic

        public void setMnemonic(int mnemonic)
        Sets the keyboard mnemonic on the current model. The mnemonic is the key which when combined with the look and feel's mouseless modifier (usually Alt) will activate this button if focus is contained somewhere within this button's ancestor window.

        A mnemonic must correspond to a single key on the keyboard and should be specified using one of the VK_XXX keycodes defined in java.awt.event.KeyEvent. These codes and the wider array of codes for international keyboards may be obtained through java.awt.event.KeyEvent.getExtendedKeyCodeForChar. Mnemonics are case-insensitive, therefore a key event with the corresponding keycode would cause the button to be activated whether or not the Shift modifier was pressed.

        If the character defined by the mnemonic is found within the button's label string, the first occurrence of it will be underlined to indicate the mnemonic to the user.

        参数：
        mnemonic - the key code which represents the mnemonic
        另请参见：
        KeyEvent, setDisplayedMnemonicIndex(int)

      • setMnemonic

        public void setMnemonic(char mnemonic)
        This method is now obsolete, please use setMnemonic(int) to set the mnemonic for a button. This method is only designed to handle character values which fall between 'a' and 'z' or 'A' and 'Z'.
        参数：
        mnemonic - a char specifying the mnemonic value
        另请参见：
        setMnemonic(int)

      • setDisplayedMnemonicIndex

        public void setDisplayedMnemonicIndex(int index)
                               throws IllegalArgumentException
        Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic. Not all look and feels may support this. A value of -1 indicates either there is no mnemonic, the mnemonic character is not contained in the string, or the developer does not wish the mnemonic to be displayed.

        The value of this is updated as the properties relating to the mnemonic change (such as the mnemonic itself, the text...). You should only ever have to call this if you do not wish the default character to be underlined. For example, if the text was 'Save As', with a mnemonic of 'a', and you wanted the 'A' to be decorated, as 'Save As', you would have to invoke setDisplayedMnemonicIndex(5) after invoking setMnemonic(KeyEvent.VK_A).

        参数：
        index - Index into the String to underline
        抛出：
        IllegalArgumentException - will be thrown if index is >= length of the text, or < -1
        从以下版本开始：
        1.4
        另请参见：
        getDisplayedMnemonicIndex()

      • getDisplayedMnemonicIndex

        public int getDisplayedMnemonicIndex()
        Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
        返回：
        index representing mnemonic character
        从以下版本开始：
        1.4
        另请参见：
        setDisplayedMnemonicIndex(int)

      • setMultiClickThreshhold

        public void setMultiClickThreshhold(long threshhold)
        Sets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events. After the initial mouse press occurs (and action event generated) any subsequent mouse press events which occur on intervals less than the threshhold will be ignored and no corresponding action event generated. By default the threshhold is 0, which means that for each mouse press, an action event will be fired, no matter how quickly the mouse clicks occur. In buttons where this behavior is not desirable (for example, the "OK" button in a dialog), this threshhold should be set to an appropriate positive value.
        参数：
        threshhold - the amount of time required between mouse press events to generate corresponding action events
        抛出：
        IllegalArgumentException - if threshhold < 0
        从以下版本开始：
        1.4
        另请参见：
        getMultiClickThreshhold()

      • getMultiClickThreshhold

        public long getMultiClickThreshhold()
        Gets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.
        返回：
        the amount of time required between mouse press events to generate corresponding action events
        从以下版本开始：
        1.4
        另请参见：
        setMultiClickThreshhold(long)

      • getModel

        public ButtonModel getModel()
        Returns the model that this button represents.
        返回：
        the model property
        另请参见：
        setModel(javax.swing.ButtonModel)

      • setModel

        public void setModel(ButtonModel newModel)
        Sets the model that this button represents.
        参数：
        newModel - the new ButtonModel
        另请参见：
        getModel()

      • getUI

        public ButtonUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the ButtonUI object
        另请参见：
        setUI(javax.swing.plaf.ButtonUI)

      • setUI

        public void setUI(ButtonUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ButtonUI L&F object
        另请参见：
        getUI()

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel. Subtypes of AbstractButton should override this to update the UI. For example, JButton might do the following:
              setUI((ButtonUI)UIManager.getUI(
          "ButtonUI", "javax.swing.plaf.basic.BasicButtonUI", this));
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified component to this container at the specified index, refer to Container.addImpl(Component, Object, int) for a complete description of this method.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be added
        constraints - an object expressing layout constraints for this component
        index - the position in the container's list at which to insert the component, where -1 means append to the end
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        从以下版本开始：
        1.5
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • setLayout

        public void setLayout(LayoutManager mgr)
        Sets the layout manager for this container, refer to Container.setLayout(LayoutManager) for a complete description of this method.
        重载：
        setLayout in class Container
        参数：
        mgr - the specified layout manager
        从以下版本开始：
        1.5
        另请参见：
        Container.doLayout(),
Container.getLayout(),
Container.invalidate()

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the button.
        参数：
        l - the listener to be added

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the button.
        参数：
        l - the listener to be removed

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this AbstractButton with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created.
        另请参见：
        EventListenerList

      • addActionListener

        public void addActionListener(ActionListener l)
        Adds an ActionListener to the button.
        参数：
        l - the ActionListener to be added

      • removeActionListener

        public void removeActionListener(ActionListener l)
        Removes an ActionListener from the button. If the listener is the currently set Action for the button, then the Action is set to null.
        参数：
        l - the listener to be removed

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the ActionListeners added to this AbstractButton with addActionListener().
        返回：
        all of the ActionListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • createChangeListener

        protected ChangeListener createChangeListener()
        Subclasses that want to handle ChangeEvents differently can override this to return another ChangeListener implementation.
        返回：
        the new ChangeListener

      • fireActionPerformed

        protected void fireActionPerformed(ActionEvent event)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the event parameter.
        参数：
        event - the ActionEvent object
        另请参见：
        EventListenerList

      • fireItemStateChanged

        protected void fireItemStateChanged(ItemEvent event)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the event parameter.
        参数：
        event - the ItemEvent object
        另请参见：
        EventListenerList

      • createActionListener

        protected ActionListener createActionListener()

      • createItemListener

        protected ItemListener createItemListener()

      • setEnabled

        public void setEnabled(boolean b)
        Enables (or disables) the button.
        重载：
        setEnabled in class JComponent
        参数：
        b - true to enable the button, otherwise false
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • getLabel

        @Deprecated
public String getLabel()
        Deprecated. - Replaced by getText
        Returns the label text.
        返回：
        a String containing the label

      • setLabel

        @Deprecated
public void setLabel(String label)
        Deprecated. - Replaced by setText(text)
        Sets the label text.
        参数：
        label - a String containing the text

      • addItemListener

        public void addItemListener(ItemListener l)
        Adds an ItemListener to the checkbox.
        指定者：
        addItemListener in interface ItemSelectable
        参数：
        l - the ItemListener to be added
        另请参见：
        ItemEvent

      • removeItemListener

        public void removeItemListener(ItemListener l)
        Removes an ItemListener from the button.
        指定者：
        removeItemListener in interface ItemSelectable
        参数：
        l - the ItemListener to be removed
        另请参见：
        ItemEvent

      • getItemListeners

        public ItemListener[] getItemListeners()
        Returns an array of all the ItemListeners added to this AbstractButton with addItemListener().
        返回：
        all of the ItemListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • getSelectedObjects

        public Object[] getSelectedObjects()
        Returns an array (length 1) containing the label or null if the button is not selected.
        指定者：
        getSelectedObjects in interface ItemSelectable
        返回：
        an array containing 1 Object: the text of the button, if the item is selected; otherwise null

      • init

        protected void init(String text,
        Icon icon)

      • imageUpdate

        public boolean imageUpdate(Image img,
                  int infoflags,
                  int x,
                  int y,
                  int w,
                  int h)
        This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
        指定者：
        imageUpdate in interface ImageObserver
        重载：
        imageUpdate in class Component
        参数：
        img - the Image to be compared
        infoflags - flags used to repaint the button when the image is updated and which determine how much is to be painted
        x - the x coordinate
        y - the y coordinate
        w - the width
        h - the height
        返回：
        false if the infoflags indicate that the image is completely loaded; true otherwise.
        另请参见：
        ImageObserver, Component.imageUpdate(java.awt.Image, int, int, int, int, int)

      • paramString

        protected String paramString()
        Returns a string representation of this AbstractButton. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.

        Overriding paramString to provide information about the specific new aspects of the JFC components.

        重载：
        paramString in class JComponent
        返回：
        a string representation of this AbstractButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractButton.AccessibleAbstractButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractButton.AccessibleAbstractButton

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
  • 所有已实现的接口：
    Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
    直接已知子类：
    JButton.AccessibleJButton, JMenuItem.AccessibleJMenuItem, JToggleButton.AccessibleJToggleButton
    封闭类：
    AbstractButton

    protected abstract class AbstractButton.AccessibleAbstractButton
extends JComponent.AccessibleJComponent
implements AccessibleAction, AccessibleValue, AccessibleText, AccessibleExtendedComponent
    This class implements accessibility support for the AbstractButton class. It provides an implementation of the Java Accessibility API appropriate to button and menu item user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | AbstractButton.AccessibleAbstractButton()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean doAccessibleAction(int i)
      Perform the specified Action on the object
      AccessibleAction getAccessibleAction()
      Get the AccessibleAction associated with this object.
      int getAccessibleActionCount()
      Returns the number of Actions available in this object.
      String getAccessibleActionDescription(int i)
      Return a description of the specified action of the object.
      AccessibleIcon[] getAccessibleIcon()
      Get the AccessibleIcons associated with this object if one or more exist.
      AccessibleKeyBinding getAccessibleKeyBinding()
      Returns key bindings associated with this object
      String getAccessibleName()
      Returns the accessible name of this object.
      AccessibleRelationSet getAccessibleRelationSet()
      Get the AccessibleRelationSet associated with this object if one exists.
      AccessibleStateSet getAccessibleStateSet()
      Get the state set of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      AccessibleValue getAccessibleValue()
      Get the AccessibleValue associated with this object.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      int getCaretPosition()
      Return the zero-based offset of the caret.
      AttributeSet getCharacterAttribute(int i)
      Return the AttributeSet for a given character at a given index
      Rectangle getCharacterBounds(int i)
      Determine the bounding box of the character at the given index into the string.
      int getCharCount()
      Return the number of characters (valid indicies)
      Number getCurrentAccessibleValue()
      Get the value of this object as a Number.
      int getIndexAtPoint(Point p)
      Given a point in local coordinates, return the zero-based index of the character under that Point.
      Number getMaximumAccessibleValue()
      Get the maximum value of this object as a Number.
      Number getMinimumAccessibleValue()
      Get the minimum value of this object as a Number.
      String getSelectedText()
      Returns the portion of the text that is selected.
      int getSelectionEnd()
      Returns the end offset within the selected text.
      int getSelectionStart()
      Returns the start offset within the selected text.
      String getTitledBorderText()
      Returns the titled border text
      String getToolTipText()
      Returns the tool tip text
      boolean setCurrentAccessibleValue(Number n)
      Set the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleRole, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • AbstractButton.AccessibleAbstractButton

        protected AbstractButton.AccessibleAbstractButton()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Returns the accessible name of this object.
        重载：
        getAccessibleName in class JComponent.AccessibleJComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleIcon

        public AccessibleIcon[] getAccessibleIcon()
        Get the AccessibleIcons associated with this object if one or more exist. Otherwise return null.
        重载：
        getAccessibleIcon in class AccessibleContext
        返回：
        an array of AccessibleIcon if supported by object; otherwise return null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleIcon

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRelationSet

        public AccessibleRelationSet getAccessibleRelationSet()
        Get the AccessibleRelationSet associated with this object if one exists. Otherwise return null.
        重载：
        getAccessibleRelationSet in class AccessibleContext
        返回：
        an AccessibleRelationSet if supported by object; otherwise return null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleRelation

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Get the AccessibleAction associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleAction interface on behalf of itself.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleAction

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Get the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of Actions available in this object. The default behavior of a button is to have one action - toggle the button.
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        返回：
        1, the number of Actions in this object

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Return a description of the specified action of the object.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        参数：
        i - zero-based index of the actions
        返回：
        a String description of the action
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Perform the specified Action on the object
        指定者：
        doAccessibleAction in interface AccessibleAction
        参数：
        i - zero-based index of actions
        返回：
        true if the the action was performed; else false.
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Get the value of this object as a Number.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        An Integer of 0 if this isn't selected or an Integer of 1 if this is selected.
        另请参见：
        AbstractButton.isSelected()

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Set the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        True if the value was set.
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Get the minimum value of this object as a Number.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        an Integer of 0.
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Get the maximum value of this object as a Number.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        An Integer of 1.
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Description copied from class: AccessibleContext
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getIndexAtPoint

        public int getIndexAtPoint(Point p)
        Given a point in local coordinates, return the zero-based index of the character under that Point. If the point is invalid, this method returns -1. Note: the AbstractButton must have a valid size (e.g. have been added to a parent container whose ancestor container is a valid top-level window) for this method to be able to return a meaningful value.
        指定者：
        getIndexAtPoint in interface AccessibleText
        参数：
        p - the Point in local coordinates
        返回：
        the zero-based index of the character under Point p; if Point is invalid returns -1.
        从以下版本开始：
        1.3

      • getCharacterBounds

        public Rectangle getCharacterBounds(int i)
        Determine the bounding box of the character at the given index into the string. The bounds are returned in local coordinates. If the index is invalid an empty rectangle is returned. Note: the AbstractButton must have a valid size (e.g. have been added to a parent container whose ancestor container is a valid top-level window) for this method to be able to return a meaningful value.
        指定者：
        getCharacterBounds in interface AccessibleText
        参数：
        i - the index into the String
        返回：
        the screen coordinates of the character's the bounding box, if index is invalid returns an empty rectangle.
        从以下版本开始：
        1.3

      • getCharCount

        public int getCharCount()
        Return the number of characters (valid indicies)
        指定者：
        getCharCount in interface AccessibleText
        返回：
        the number of characters
        从以下版本开始：
        1.3

      • getCaretPosition

        public int getCaretPosition()
        Return the zero-based offset of the caret. Note: That to the right of the caret will have the same index value as the offset (the caret is between two characters).
        指定者：
        getCaretPosition in interface AccessibleText
        返回：
        the zero-based offset of the caret.
        从以下版本开始：
        1.3

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index.
        指定者：
        getAtIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index.
        指定者：
        getAfterIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index.
        指定者：
        getBeforeIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute(int i)
        Return the AttributeSet for a given character at a given index
        指定者：
        getCharacterAttribute in interface AccessibleText
        参数：
        i - the zero-based index into the text
        返回：
        the AttributeSet of the character
        从以下版本开始：
        1.3

      • getSelectionStart

        public int getSelectionStart()
        Returns the start offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionStart in interface AccessibleText
        返回：
        the index into the text of the start of the selection
        从以下版本开始：
        1.3

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the end offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionEnd in interface AccessibleText
        返回：
        the index into teh text of the end of the selection
        从以下版本开始：
        1.3

      • getSelectedText

        public String getSelectedText()
        Returns the portion of the text that is selected.
        指定者：
        getSelectedText in interface AccessibleText
        返回：
        the String portion of the text that is selected
        从以下版本开始：
        1.3

      • getToolTipText

        public String getToolTipText()
        Returns the tool tip text
        指定者：
        getToolTipText in interface AccessibleExtendedComponent
        重载：
        getToolTipText in class JComponent.AccessibleJComponent
        返回：
        the tool tip text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getTitledBorderText

        public String getTitledBorderText()
        Returns the titled border text
        指定者：
        getTitledBorderText in interface AccessibleExtendedComponent
        重载：
        getTitledBorderText in class JComponent.AccessibleJComponent
        返回：
        the titled border text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getAccessibleKeyBinding

        public AccessibleKeyBinding getAccessibleKeyBinding()
        Returns key bindings associated with this object
        指定者：
        getAccessibleKeyBinding in interface AccessibleExtendedComponent
        重载：
        getAccessibleKeyBinding in class JComponent.AccessibleJComponent
        返回：
        the key bindings, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4
        另请参见：
        AccessibleKeyBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractButton.ButtonChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 AbstractButton.ButtonChangeListener

  • java.lang.Object
    • javax.swing.AbstractButton.ButtonChangeListener
  • 所有已实现的接口：
    Serializable, EventListener, ChangeListener
    封闭类：
    AbstractButton

    protected class AbstractButton.ButtonChangeListener
extends Object
implements ChangeListener, Serializable
    Extends ChangeListener to be serializable.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nodosbcibcacccaaliee<<<>//o


AbstractCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractCellEditor

  • java.lang.Object
    • javax.swing.AbstractCellEditor
  • 所有已实现的接口：
    Serializable, CellEditor
    直接已知子类：
    DefaultCellEditor

    public abstract class AbstractCellEditor
extends Object
implements CellEditor, Serializable
    A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue(). Like the other abstract implementations in Swing, also manages a list of listeners.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeEvent | changeEvent
      protected EventListenerList | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractCellEditor()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addCellEditorListener(CellEditorListener l)
      Adds a CellEditorListener to the listener list.
      void cancelCellEditing()
      Calls fireEditingCanceled.
      protected void fireEditingCanceled()
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireEditingStopped()
      Notifies all listeners that have registered interest for notification on this event type.
      CellEditorListener[] getCellEditorListeners()
      Returns an array of all the CellEditorListeners added to this AbstractCellEditor with addCellEditorListener().
      boolean isCellEditable(EventObject e)
      Returns true.
      void removeCellEditorListener(CellEditorListener l)
      Removes a CellEditorListener from the listener list.
      boolean shouldSelectCell(EventObject anEvent)
      Returns true.
      boolean stopCellEditing()
      Calls fireEditingStopped and returns true.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.CellEditor

        getCellEditorValue

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList

      • changeEvent

        protected transient ChangeEvent changeEvent

    • 构造方法详细信息

      • AbstractCellEditor

        public AbstractCellEditor()

    • 方法详细信息

      • isCellEditable

        public boolean isCellEditable(EventObject e)
        Returns true.
        指定者：
        isCellEditable in interface CellEditor
        参数：
        e - an event object
        返回：
        true
        另请参见：
        CellEditor.shouldSelectCell(java.util.EventObject)

      • shouldSelectCell

        public boolean shouldSelectCell(EventObject anEvent)
        Returns true.
        指定者：
        shouldSelectCell in interface CellEditor
        参数：
        anEvent - an event object
        返回：
        true
        另请参见：
        CellEditor.isCellEditable(java.util.EventObject)

      • stopCellEditing

        public boolean stopCellEditing()
        Calls fireEditingStopped and returns true.
        指定者：
        stopCellEditing in interface CellEditor
        返回：
        true

      • cancelCellEditing

        public void cancelCellEditing()
        Calls fireEditingCanceled.
        指定者：
        cancelCellEditing in interface CellEditor

      • addCellEditorListener

        public void addCellEditorListener(CellEditorListener l)
        Adds a CellEditorListener to the listener list.
        指定者：
        addCellEditorListener in interface CellEditor
        参数：
        l - the new listener to be added

      • removeCellEditorListener

        public void removeCellEditorListener(CellEditorListener l)
        Removes a CellEditorListener from the listener list.
        指定者：
        removeCellEditorListener in interface CellEditor
        参数：
        l - the listener to be removed

      • getCellEditorListeners

        public CellEditorListener[] getCellEditorListeners()
        Returns an array of all the CellEditorListeners added to this AbstractCellEditor with addCellEditorListener().
        返回：
        all of the CellEditorListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireEditingStopped

        protected void fireEditingStopped()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        另请参见：
        EventListenerList

      • fireEditingCanceled

        protected void fireEditingCanceled()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        另请参见：
        EventListenerList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aIlcsocss==sssvo<LO


AbstractListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractListModel<E>

  • java.lang.Object
    • javax.swing.AbstractListModel<E>
  • 类型参数：
    E - the type of the elements of this model
    所有已实现的接口：
    Serializable, ListModel<E>
    直接已知子类：
    BasicDirectoryModel, DefaultComboBoxModel, DefaultListModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel

    public abstract class AbstractListModel<E>
extends Object
implements ListModel<E>, Serializable
    The abstract definition for the data model that provides a List with its contents.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected EventListenerList | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractListModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addListDataListener(ListDataListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      protected void fireContentsChanged(Object source, int index0, int index1)
      AbstractListModel subclasses must call this method after one or more elements of the list change.
      protected void fireIntervalAdded(Object source, int index0, int index1)
      AbstractListModel subclasses must call this method after one or more elements are added to the model.
      protected void fireIntervalRemoved(Object source, int index0, int index1)
      AbstractListModel subclasses must call this method after one or more elements are removed from the model.
      ListDataListener[] getListDataListeners()
      Returns an array of all the list data listeners registered on this AbstractListModel.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      void removeListDataListener(ListDataListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.ListModel

        getElementAt, getSize

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList

    • 构造方法详细信息

      • AbstractListModel

        public AbstractListModel()

    • 方法详细信息

      • addListDataListener

        public void addListDataListener(ListDataListener l)
        Adds a listener to the list that's notified each time a change to the data model occurs.
        指定者：
        addListDataListener in interface ListModel<E>
        参数：
        l - the ListDataListener to be added

      • removeListDataListener

        public void removeListDataListener(ListDataListener l)
        Removes a listener from the list that's notified each time a change to the data model occurs.
        指定者：
        removeListDataListener in interface ListModel<E>
        参数：
        l - the ListDataListener to be removed

      • getListDataListeners

        public ListDataListener[] getListDataListeners()
        Returns an array of all the list data listeners registered on this AbstractListModel.
        返回：
        all of this model's ListDataListeners, or an empty array if no list data listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addListDataListener(javax.swing.event.ListDataListener), removeListDataListener(javax.swing.event.ListDataListener)

      • fireContentsChanged

        protected void fireContentsChanged(Object source,
                       int index0,
                       int index1)
        AbstractListModel subclasses must call this method after one or more elements of the list change. The changed elements are specified by the closed interval index0, index1 -- the endpoints are included. Note that index0 need not be less than or equal to index1.
        参数：
        source - the ListModel that changed, typically "this"
        index0 - one end of the new interval
        index1 - the other end of the new interval
        另请参见：
        EventListenerList, DefaultListModel

      • fireIntervalAdded

        protected void fireIntervalAdded(Object source,
                     int index0,
                     int index1)
        AbstractListModel subclasses must call this method after one or more elements are added to the model. The new elements are specified by a closed interval index0, index1 -- the enpoints are included. Note that index0 need not be less than or equal to index1.
        参数：
        source - the ListModel that changed, typically "this"
        index0 - one end of the new interval
        index1 - the other end of the new interval
        另请参见：
        EventListenerList, DefaultListModel

      • fireIntervalRemoved

        protected void fireIntervalRemoved(Object source,
                       int index0,
                       int index1)
        AbstractListModel subclasses must call this method after one or more elements are removed from the model. index0 and index1 are the end points of the interval that's been removed. Note that index0 need not be less than or equal to index1.
        参数：
        source - the ListModel that changed, typically "this"
        index0 - one end of the removed interval, including index0
        index1 - the other end of the removed interval, including index1
        另请参见：
        EventListenerList, DefaultListModel

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a list model m for its list data listeners with the following code:

        ListDataListener[] ldls = (ListDataListener[])(m.getListeners(ListDataListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getListDataListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lioL" etac=j&.l<穐vo u>


AbstractSpinnerModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 AbstractSpinnerModel

  • java.lang.Object
    • javax.swing.AbstractSpinnerModel
  • 所有已实现的接口：
    Serializable, SpinnerModel
    直接已知子类：
    SpinnerDateModel, SpinnerListModel, SpinnerNumberModel

    public abstract class AbstractSpinnerModel
extends Object
implements SpinnerModel, Serializable
    This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations. Subclasses must provide an implementation of the setValue, getValue, getNextValue and getPreviousValue methods.
    从以下版本开始：
    1.4
    另请参见：
    JSpinner, SpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected EventListenerList listenerList
      The list of ChangeListeners for this model.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractSpinnerModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model's listener list.
      protected void fireStateChanged()
      Run each ChangeListeners stateChanged() method.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this AbstractSpinnerModel with addChangeListener().
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Return an array of all the listeners of the given type that were added to this model.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model's listener list.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.SpinnerModel

        getNextValue, getPreviousValue, getValue, setValue

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList
        The list of ChangeListeners for this model. Subclasses may store their own listeners here.

    • 构造方法详细信息

      • AbstractSpinnerModel

        public AbstractSpinnerModel()

    • 方法详细信息

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the model's listener list. The ChangeListeners must be notified when the models value changes.
        指定者：
        addChangeListener in interface SpinnerModel
        参数：
        l - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener), SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the model's listener list.
        指定者：
        removeChangeListener in interface SpinnerModel
        参数：
        l - the ChangeListener to remove
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), SpinnerModel.removeChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this AbstractSpinnerModel with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Run each ChangeListeners stateChanged() method.
        另请参见：
        SpinnerModel.setValue(java.lang.Object), EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Return an array of all the listeners of the given type that were added to this model. For example to find all of the ChangeListeners added to this model:
         myAbstractSpinnerModel.getListeners(ChangeListener.class);
        参数：
        listenerType - the type of listeners to return, e.g. ChangeListener.class
        返回：
        all of the objects receiving listenerType notifications from this model
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

idcahteated>>eddlL-->ld<>>>catatos>tPsss>s蝦srd<<


Action

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface Action

  • All Superinterfaces:
    ActionListener, EventListener
    All Known Implementing Classes:
    AbstractAction, BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicSliderUI.ActionScroller, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreePageAction, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, HTMLEditorKit.HTMLTextAction, HTMLEditorKit.InsertHTMLTextAction, MetalFileChooserUI.DirectoryComboBoxAction, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction, TextAction

    public interface Action
extends ActionListener
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.

    In addition to the actionPerformed method defined by the ActionListener interface, this interface allows the application to define, in a single place:

    • One or more text strings that describe the function. These strings can be used, for example, to display the flyover text for a button or to set the text in a menu item.
    • One or more icons that depict the function. These icons can be used for the images in a menu control, or for composite entries in a more sophisticated user interface.
    • The enabled/disabled state of the functionality. Instead of having to separately disable the menu item and the toolbar button, the application can disable the function that implements this interface. All components which are registered as listeners for the state change then know to disable event generation for that item and to modify the display accordingly.

    This interface can be added to an existing class or used to create an adapter (typically, by subclassing AbstractAction). The Action object can then be added to multiple Action-aware containers and connected to Action-capable components. The GUI controls can then be activated or deactivated all at once by invoking the Action object's setEnabled method.

    Note that Action implementations tend to be more expensive in terms of storage than a typical ActionListener, which does not offer the benefits of centralized control of functionality and broadcast of property changes. For this reason, you should take care to only use Actions where their benefits are desired, and use simple ActionListeners elsewhere.

    Swing Components Supporting Action

    Many of Swing's components have an Action property. When an Action is set on a component, the following things happen:

    • The Action is added as an ActionListener to the component.
    • The component configures some of its properties to match the Action.
    • The component installs a PropertyChangeListener on the Action so that the component can change its properties to reflect changes in the Action's properties.

    The following table describes the properties used by Swing components that support Actions. In the table, button refers to any AbstractButton subclass, which includes not only JButton but also classes such as JMenuItem. Unless otherwise stated, a null property value in an Action (or a Action that is null) results in the button's corresponding property being set to null.

    Component Property | Components | Action Key | Notes
    enabled | All | The isEnabled method
    toolTipText | All | SHORT_DESCRIPTION
    actionCommand | All | ACTION_COMMAND_KEY
    mnemonic | All buttons | MNEMONIC_KEY | A null value or Action results in the button's mnemonic property being set to '\0'.
    text | All buttons | NAME | If you do not want the text of the button to mirror that of the Action, set the property hideActionText to true. If hideActionText is true, setting the Action changes the text of the button to null and any changes to NAME are ignored. hideActionText is useful for tool bar buttons that typically only show an Icon. JToolBar.add(Action) sets the property to true if the Action has a non-null value for LARGE_ICON_KEY or SMALL_ICON.
    displayedMnemonicIndex | All buttons | DISPLAYED_MNEMONIC_INDEX_KEY | If the value of DISPLAYED_MNEMONIC_INDEX_KEY is beyond the bounds of the text, it is ignored. When setAction is called, if the value from the Action is null, the displayed mnemonic index is not updated. In any subsequent changes to DISPLAYED_MNEMONIC_INDEX_KEY, null is treated as -1.
    icon | All buttons except of JCheckBox, JToggleButton and JRadioButton. | either LARGE_ICON_KEY or SMALL_ICON | The JMenuItem subclasses only use SMALL_ICON. All other buttons will use LARGE_ICON_KEY; if the value is null they use SMALL_ICON.
    accelerator | All JMenuItem subclasses, with the exception of JMenu. | ACCELERATOR_KEY
    selected JToggleButton, JCheckBox, JRadioButton, JCheckBoxMenuItem and JRadioButtonMenuItem SELECTED_KEY Components that honor this property only use the value if it is non-null. For example, if you set an Action that has a null value for SELECTED_KEY on a JToggleButton, the JToggleButton will not update it's selected state in any way. Similarly, any time the JToggleButton's selected state changes it will only set the value back on the Action if the Action has a non-null value for SELECTED_KEY.
    Components that honor this property keep their selected state in sync with this property. When the same Action is used with multiple components, all the components keep their selected state in sync with this property. Mutually exclusive buttons, such as JToggleButtons in a ButtonGroup, force only one of the buttons to be selected. As such, do not use the same Action that defines a value for the SELECTED_KEY property with multiple mutually exclusive buttons.

    JPopupMenu, JToolBar and JMenu all provide convenience methods for creating a component and setting the Action on the corresponding component. Refer to each of these classes for more information.

    Action uses PropertyChangeListener to inform listeners the Action has changed. The beans specification indicates that a null property name can be used to indicate multiple values have changed. By default Swing components that take an Action do not handle such a change. To indicate that Swing should treat null according to the beans specification set the system property swing.actions.reconfigureOnNull to the String value true.

    另请参见：
    AbstractAction

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ACCELERATOR_KEY
      The key used for storing a KeyStroke to be used as the accelerator for the action.
      static String ACTION_COMMAND_KEY
      The key used to determine the command String for the ActionEvent that will be created when an Action is going to be notified as the result of residing in a Keymap associated with a JComponent.
      static String DEFAULT
      Not currently used.
      static String DISPLAYED_MNEMONIC_INDEX_KEY
      The key used for storing an Integer that corresponds to the index in the text (identified by the NAME property) that the decoration for a mnemonic should be rendered at.
      static String LARGE_ICON_KEY
      The key used for storing an Icon.
      static String LONG_DESCRIPTION
      The key used for storing a longer String description for the action, could be used for context-sensitive help.
      static String MNEMONIC_KEY
      The key used for storing an Integer that corresponds to one of the KeyEvent key codes.
      static String NAME
      The key used for storing the String name for the action, used for a menu or button.
      static String SELECTED_KEY
      The key used for storing a Boolean that corresponds to the selected state.
      static String SHORT_DESCRIPTION
      The key used for storing a short String description for the action, used for tooltip text.
      static String SMALL_ICON
      The key used for storing a small Icon, such as ImageIcon.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChange listener.
      Object getValue(String key)
      Gets one of this object's properties using the associated key.
      boolean isEnabled()
      Returns the enabled state of the Action.
      void putValue(String key, Object value)
      Sets one of this object's properties using the associated key.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChange listener.
      void setEnabled(boolean b)
      Sets the enabled state of the Action.

      • 方法 - 继承于接口 java.awt.event.ActionListener

        actionPerformed

    • 字段详细信息

      • DEFAULT

        static final String DEFAULT
        Not currently used.
        另请参见：
        Constant Field Values

      • NAME

        static final String NAME
        The key used for storing the String name for the action, used for a menu or button.
        另请参见：
        Constant Field Values

      • SHORT_DESCRIPTION

        static final String SHORT_DESCRIPTION
        The key used for storing a short String description for the action, used for tooltip text.
        另请参见：
        Constant Field Values

      • LONG_DESCRIPTION

        static final String LONG_DESCRIPTION
        The key used for storing a longer String description for the action, could be used for context-sensitive help.
        另请参见：
        Constant Field Values

      • SMALL_ICON

        static final String SMALL_ICON
        The key used for storing a small Icon, such as ImageIcon. This is typically used with menus such as JMenuItem.

        If the same Action is used with menus and buttons you'll typically specify both a SMALL_ICON and a LARGE_ICON_KEY. The menu will use the SMALL_ICON and the button will use the LARGE_ICON_KEY.

        另请参见：
        Constant Field Values

      • ACTION_COMMAND_KEY

        static final String ACTION_COMMAND_KEY
        The key used to determine the command String for the ActionEvent that will be created when an Action is going to be notified as the result of residing in a Keymap associated with a JComponent.
        另请参见：
        Constant Field Values

      • ACCELERATOR_KEY

        static final String ACCELERATOR_KEY
        The key used for storing a KeyStroke to be used as the accelerator for the action.
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • MNEMONIC_KEY

        static final String MNEMONIC_KEY
        The key used for storing an Integer that corresponds to one of the KeyEvent key codes. The value is commonly used to specify a mnemonic. For example: myAction.putValue(Action.MNEMONIC_KEY, KeyEvent.VK_A) sets the mnemonic of myAction to 'a', while myAction.putValue(Action.MNEMONIC_KEY, KeyEvent.getExtendedKeyCodeForChar('?')) sets the mnemonic of myAction to Cyrillic letter "Ef".
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • SELECTED_KEY

        static final String SELECTED_KEY
        The key used for storing a Boolean that corresponds to the selected state. This is typically used only for components that have a meaningful selection state. For example, JRadioButton and JCheckBox make use of this but instances of JMenu don't.

        This property differs from the others in that it is both read by the component and set by the component. For example, if an Action is attached to a JCheckBox the selected state of the JCheckBox will be set from that of the Action. If the user clicks on the JCheckBox the selected state of the JCheckBox and the Action will both be updated.

        Note: the value of this field is prefixed with 'Swing' to avoid possible collisions with existing Actions.

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • DISPLAYED_MNEMONIC_INDEX_KEY

        static final String DISPLAYED_MNEMONIC_INDEX_KEY
        The key used for storing an Integer that corresponds to the index in the text (identified by the NAME property) that the decoration for a mnemonic should be rendered at. If the value of this property is greater than or equal to the length of the text, it will treated as -1.

        Note: the value of this field is prefixed with 'Swing' to avoid possible collisions with existing Actions.

        从以下版本开始：
        1.6
        另请参见：
        AbstractButton.setDisplayedMnemonicIndex(int), Constant Field Values

      • LARGE_ICON_KEY

        static final String LARGE_ICON_KEY
        The key used for storing an Icon. This is typically used by buttons, such as JButton and JToggleButton.

        If the same Action is used with menus and buttons you'll typically specify both a SMALL_ICON and a LARGE_ICON_KEY. The menu will use the SMALL_ICON and the button the LARGE_ICON_KEY.

        Note: the value of this field is prefixed with 'Swing' to avoid possible collisions with existing Actions.

        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getValue

        Object getValue(String key)
        Gets one of this object's properties using the associated key.
        另请参见：
        putValue(java.lang.String, java.lang.Object)

      • putValue

        void putValue(String key,
            Object value)
        Sets one of this object's properties using the associated key. If the value has changed, a PropertyChangeEvent is sent to listeners.
        参数：
        key - a String containing the key
        value - an Object value

      • setEnabled

        void setEnabled(boolean b)
        Sets the enabled state of the Action. When enabled, any component associated with this object is active and able to fire this object's actionPerformed method. If the value has changed, a PropertyChangeEvent is sent to listeners.
        参数：
        b - true to enable this Action, false to disable it

      • isEnabled

        boolean isEnabled()
        Returns the enabled state of the Action. When enabled, any component associated with this object is active and able to fire this object's actionPerformed method.
        返回：
        true if this Action is enabled

      • addPropertyChangeListener

        void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChange listener. Containers and attached components use these methods to register interest in this Action object. When its enabled state or other property changes, the registered listeners are informed of the change.
        参数：
        listener - a PropertyChangeListener object

      • removePropertyChangeListener

        void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChange listener.
        参数：
        listener - a PropertyChangeListener object
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


ActionMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ActionMap

  • java.lang.Object
    • javax.swing.ActionMap
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    ActionMapUIResource

    public class ActionMap
extends Object
implements Serializable
    ActionMap provides mappings from Objects (called keys or Action names) to Actions. An ActionMap is usually used with an InputMap to locate a particular action when a key is pressed. As with InputMap, an ActionMap can have a parent that is searched for keys not defined in the ActionMap.

    As with InputMap if you create a cycle, eg:

       ActionMap am = new ActionMap();
   ActionMap bm = new ActionMap():
   am.setParent(bm);
   bm.setParent(am);
    some of the methods will cause a StackOverflowError to be thrown.
    从以下版本开始：
    1.3
    另请参见：
    InputMap

    • 构造方法摘要

      Constructors
      构造方法与描述
      ActionMap()
      Creates an ActionMap with no parent and no mappings.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object[] allKeys()
      Returns an array of the keys defined in this ActionMap and its parent.
      void clear()
      Removes all the mappings from this ActionMap.
      Action get(Object key)
      Returns the binding for key, messaging the parent ActionMap if the binding is not locally defined.
      ActionMap getParent()
      Returns this ActionMap's parent.
      Object[] keys()
      Returns the Action names that are bound in this ActionMap.
      void put(Object key, Action action)
      Adds a binding for key to action.
      void remove(Object key)
      Removes the binding for key from this ActionMap.
      void setParent(ActionMap map)
      Sets this ActionMap's parent.
      int size()
      Returns the number of bindings in this ActionMap.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActionMap

        public ActionMap()
        Creates an ActionMap with no parent and no mappings.

    • 方法详细信息

      • setParent

        public void setParent(ActionMap map)
        Sets this ActionMap's parent.
        参数：
        map - the ActionMap that is the parent of this one

      • getParent

        public ActionMap getParent()
        Returns this ActionMap's parent.
        返回：
        the ActionMap that is the parent of this one, or null if this ActionMap has no parent

      • put

        public void put(Object key,
       Action action)
        Adds a binding for key to action. If action is null, this removes the current binding for key.

        In most instances, key will be action.getValue(NAME).

      • get

        public Action get(Object key)
        Returns the binding for key, messaging the parent ActionMap if the binding is not locally defined.

      • remove

        public void remove(Object key)
        Removes the binding for key from this ActionMap.

      • clear

        public void clear()
        Removes all the mappings from this ActionMap.

      • keys

        public Object[] keys()
        Returns the Action names that are bound in this ActionMap.

      • size

        public int size()
        Returns the number of bindings in this ActionMap.
        返回：
        the number of bindings in this ActionMap

      • allKeys

        public Object[] allKeys()
        Returns an array of the keys defined in this ActionMap and its parent. This method differs from keys() in that this method includes the keys defined in the parent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sui n nnaeaaoT/gotBld neY>< l


BorderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 BorderFactory

  • java.lang.Object
    • javax.swing.BorderFactory

  • public class BorderFactory
extends Object
    Factory class for vending standard Border objects. Wherever possible, this factory will hand out references to shared Border instances. For further information and examples see How to Use Borders, a section in The Java Tutorial.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Border createBevelBorder(int type)
      Creates a beveled border of the specified type, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border createBevelBorder(int type, Color highlight, Color shadow)
      Creates a beveled border of the specified type, using the specified highlighting and shadowing.
      static Border createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      Creates a beveled border of the specified type, using the specified colors for the inner and outer highlight and shadow areas.
      static CompoundBorder createCompoundBorder()
      Creates a compound border with a null inside edge and a null outside edge.
      static CompoundBorder createCompoundBorder(Border outsideBorder, Border insideBorder)
      Creates a compound border specifying the border objects to use for the outside and inside edges.
      static Border createDashedBorder(Paint paint)
      Creates a dashed border of the specified paint.
      static Border createDashedBorder(Paint paint, float length, float spacing)
      Creates a dashed border of the specified paint, relative length, and relative spacing.
      static Border createDashedBorder(Paint paint, float thickness, float length, float spacing, boolean rounded)
      Creates a dashed border of the specified paint, thickness, line shape, relative length, and relative spacing.
      static Border createEmptyBorder()
      Creates an empty border that takes up no space.
      static Border createEmptyBorder(int top, int left, int bottom, int right)
      Creates an empty border that takes up space but which does no drawing, specifying the width of the top, left, bottom, and right sides.
      static Border createEtchedBorder()
      Creates a border with an "etched" look using the component's current background color for highlighting and shading.
      static Border createEtchedBorder(Color highlight, Color shadow)
      Creates a border with an "etched" look using the specified highlighting and shading colors.
      static Border createEtchedBorder(int type)
      Creates a border with an "etched" look using the component's current background color for highlighting and shading.
      static Border createEtchedBorder(int type, Color highlight, Color shadow)
      Creates a border with an "etched" look using the specified highlighting and shading colors.
      static Border createLineBorder(Color color)
      Creates a line border withe the specified color.
      static Border createLineBorder(Color color, int thickness)
      Creates a line border with the specified color and width.
      static Border createLineBorder(Color color, int thickness, boolean rounded)
      Creates a line border with the specified color, thickness, and corner shape.
      static Border createLoweredBevelBorder()
      Creates a border with a lowered beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border createLoweredSoftBevelBorder()
      Creates a beveled border with a lowered edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static MatteBorder createMatteBorder(int top, int left, int bottom, int right, Color color)
      Creates a matte-look border using a solid color.
      static MatteBorder createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
      Creates a matte-look border that consists of multiple tiles of a specified icon.
      static Border createRaisedBevelBorder()
      Creates a border with a raised beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border createRaisedSoftBevelBorder()
      Creates a beveled border with a raised edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border createSoftBevelBorder(int type)
      Creates a beveled border of the specified type with softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border createSoftBevelBorder(int type, Color highlight, Color shadow)
      Creates a beveled border of the specified type with softened corners, using the specified highlighting and shadowing.
      static Border createSoftBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      Creates a beveled border of the specified type with softened corners, using the specified colors for the inner and outer edges of the highlight and the shadow areas.
      static Border createStrokeBorder(BasicStroke stroke)
      Creates a border of the specified stroke.
      static Border createStrokeBorder(BasicStroke stroke, Paint paint)
      Creates a border of the specified stroke and paint.
      static TitledBorder createTitledBorder(Border border)
      Creates a new titled border with an empty title, the specified border object, the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
      static TitledBorder createTitledBorder(Border border, String title)
      Adds a title to an existing border, with default positioning (sitting on the top line), default justification (leading) and the default font and text color (determined by the current look and feel).
      static TitledBorder createTitledBorder(Border border, String title, int titleJustification, int titlePosition)
      Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
      static TitledBorder createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
      static TitledBorder createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      Adds a title to an existing border, with the specified positioning, font and color.
      static TitledBorder createTitledBorder(String title)
      Creates a new titled border with the specified title, the default border type (determined by the current look and feel), the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • createLineBorder

        public static Border createLineBorder(Color color)
        Creates a line border withe the specified color.
        参数：
        color - a Color to use for the line
        返回：
        the Border object

      • createLineBorder

        public static Border createLineBorder(Color color,
                      int thickness)
        Creates a line border with the specified color and width. The width applies to all four sides of the border. To specify widths individually for the top, bottom, left, and right, use createMatteBorder(int,int,int,int,Color).
        参数：
        color - a Color to use for the line
        thickness - an integer specifying the width in pixels
        返回：
        the Border object

      • createLineBorder

        public static Border createLineBorder(Color color,
                      int thickness,
                      boolean rounded)
        Creates a line border with the specified color, thickness, and corner shape.
        参数：
        color - the color of the border
        thickness - the thickness of the border
        rounded - whether or not border corners should be round
        返回：
        the Border object
        从以下版本开始：
        1.7
        另请参见：
        LineBorder.LineBorder(Color, int, boolean)

      • createRaisedBevelBorder

        public static Border createRaisedBevelBorder()
        Creates a border with a raised beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. (In a raised border, highlights are on top and shadows are underneath.)
        返回：
        the Border object

      • createLoweredBevelBorder

        public static Border createLoweredBevelBorder()
        Creates a border with a lowered beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. (In a lowered border, shadows are on top and highlights are underneath.)
        返回：
        the Border object

      • createBevelBorder

        public static Border createBevelBorder(int type)
        Creates a beveled border of the specified type, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. (In a lowered border, shadows are on top and highlights are underneath.)
        参数：
        type - an integer specifying either BevelBorder.LOWERED or BevelBorder.RAISED
        返回：
        the Border object

      • createBevelBorder

        public static Border createBevelBorder(int type,
                       Color highlight,
                       Color shadow)
        Creates a beveled border of the specified type, using the specified highlighting and shadowing. The outer edge of the highlighted area uses a brighter shade of the highlight color. The inner edge of the shadow area uses a brighter shade of the shadow color.
        参数：
        type - an integer specifying either BevelBorder.LOWERED or BevelBorder.RAISED
        highlight - a Color object for highlights
        shadow - a Color object for shadows
        返回：
        the Border object

      • createBevelBorder

        public static Border createBevelBorder(int type,
                       Color highlightOuter,
                       Color highlightInner,
                       Color shadowOuter,
                       Color shadowInner)
        Creates a beveled border of the specified type, using the specified colors for the inner and outer highlight and shadow areas.
        参数：
        type - an integer specifying either BevelBorder.LOWERED or BevelBorder.RAISED
        highlightOuter - a Color object for the outer edge of the highlight area
        highlightInner - a Color object for the inner edge of the highlight area
        shadowOuter - a Color object for the outer edge of the shadow area
        shadowInner - a Color object for the inner edge of the shadow area
        返回：
        the Border object

      • createRaisedSoftBevelBorder

        public static Border createRaisedSoftBevelBorder()
        Creates a beveled border with a raised edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. In a raised border, highlights are on top and shadows are underneath.
        返回：
        the Border object
        从以下版本开始：
        1.7

      • createLoweredSoftBevelBorder

        public static Border createLoweredSoftBevelBorder()
        Creates a beveled border with a lowered edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. In a lowered border, shadows are on top and highlights are underneath.
        返回：
        the Border object
        从以下版本开始：
        1.7

      • createSoftBevelBorder

        public static Border createSoftBevelBorder(int type)
        Creates a beveled border of the specified type with softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows. The type is either BevelBorder.RAISED or BevelBorder.LOWERED.
        参数：
        type - a type of a bevel
        返回：
        the Border object or null if the specified type is not valid
        从以下版本开始：
        1.7
        另请参见：
        BevelBorder.BevelBorder(int)

      • createSoftBevelBorder

        public static Border createSoftBevelBorder(int type,
                           Color highlight,
                           Color shadow)
        Creates a beveled border of the specified type with softened corners, using the specified highlighting and shadowing. The type is either BevelBorder.RAISED or BevelBorder.LOWERED. The outer edge of the highlight area uses a brighter shade of the highlight color. The inner edge of the shadow area uses a brighter shade of the shadow color.
        参数：
        type - a type of a bevel
        highlight - a basic color of the highlight area
        shadow - a basic color of the shadow area
        返回：
        the Border object
        从以下版本开始：
        1.7
        另请参见：
        BevelBorder.BevelBorder(int, Color, Color)

      • createSoftBevelBorder

        public static Border createSoftBevelBorder(int type,
                           Color highlightOuter,
                           Color highlightInner,
                           Color shadowOuter,
                           Color shadowInner)
        Creates a beveled border of the specified type with softened corners, using the specified colors for the inner and outer edges of the highlight and the shadow areas. The type is either BevelBorder.RAISED or BevelBorder.LOWERED. Note: The shadow inner and outer colors are switched for a lowered bevel border.
        参数：
        type - a type of a bevel
        highlightOuter - a color of the outer edge of the highlight area
        highlightInner - a color of the inner edge of the highlight area
        shadowOuter - a color of the outer edge of the shadow area
        shadowInner - a color of the inner edge of the shadow area
        返回：
        the Border object
        从以下版本开始：
        1.7
        另请参见：
        BevelBorder.BevelBorder(int, Color, Color, Color, Color)

      • createEtchedBorder

        public static Border createEtchedBorder()
        Creates a border with an "etched" look using the component's current background color for highlighting and shading.
        返回：
        the Border object

      • createEtchedBorder

        public static Border createEtchedBorder(Color highlight,
                        Color shadow)
        Creates a border with an "etched" look using the specified highlighting and shading colors.
        参数：
        highlight - a Color object for the border highlights
        shadow - a Color object for the border shadows
        返回：
        the Border object

      • createEtchedBorder

        public static Border createEtchedBorder(int type)
        Creates a border with an "etched" look using the component's current background color for highlighting and shading.
        参数：
        type - one of EtchedBorder.RAISED, or EtchedBorder.LOWERED
        返回：
        the Border object
        抛出：
        IllegalArgumentException - if type is not either EtchedBorder.RAISED or EtchedBorder.LOWERED
        从以下版本开始：
        1.3

      • createEtchedBorder

        public static Border createEtchedBorder(int type,
                        Color highlight,
                        Color shadow)
        Creates a border with an "etched" look using the specified highlighting and shading colors.
        参数：
        type - one of EtchedBorder.RAISED, or EtchedBorder.LOWERED
        highlight - a Color object for the border highlights
        shadow - a Color object for the border shadows
        返回：
        the Border object
        从以下版本开始：
        1.3

      • createTitledBorder

        public static TitledBorder createTitledBorder(String title)
        Creates a new titled border with the specified title, the default border type (determined by the current look and feel), the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
        参数：
        title - a String containing the text of the title
        返回：
        the TitledBorder object

      • createTitledBorder

        public static TitledBorder createTitledBorder(Border border)
        Creates a new titled border with an empty title, the specified border object, the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
        参数：
        border - the Border object to add the title to; if null the Border is determined by the current look and feel.
        返回：
        the TitledBorder object

      • createTitledBorder

        public static TitledBorder createTitledBorder(Border border,
                              String title)
        Adds a title to an existing border, with default positioning (sitting on the top line), default justification (leading) and the default font and text color (determined by the current look and feel).
        参数：
        border - the Border object to add the title to
        title - a String containing the text of the title
        返回：
        the TitledBorder object

      • createTitledBorder

        public static TitledBorder createTitledBorder(Border border,
                              String title,
                              int titleJustification,
                              int titlePosition)
        Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
        参数：
        border - the Border object to add the title to
        title - a String containing the text of the title
        titleJustification - an integer specifying the justification of the title -- one of the following:
        • TitledBorder.LEFT
        • TitledBorder.CENTER
        • TitledBorder.RIGHT
        • TitledBorder.LEADING
        • TitledBorder.TRAILING
        • TitledBorder.DEFAULT_JUSTIFICATION (leading)
        titlePosition - an integer specifying the vertical position of the text in relation to the border -- one of the following:
        • TitledBorder.ABOVE_TOP
        • TitledBorder.TOP (sitting on the top line)
        • TitledBorder.BELOW_TOP
        • TitledBorder.ABOVE_BOTTOM
        • TitledBorder.BOTTOM (sitting on the bottom line)
        • TitledBorder.BELOW_BOTTOM
        • TitledBorder.DEFAULT_POSITION (top)
        返回：
        the TitledBorder object

      • createTitledBorder

        public static TitledBorder createTitledBorder(Border border,
                              String title,
                              int titleJustification,
                              int titlePosition,
                              Font titleFont)
        Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
        参数：
        border - the Border object to add the title to
        title - a String containing the text of the title
        titleJustification - an integer specifying the justification of the title -- one of the following:
        • TitledBorder.LEFT
        • TitledBorder.CENTER
        • TitledBorder.RIGHT
        • TitledBorder.LEADING
        • TitledBorder.TRAILING
        • TitledBorder.DEFAULT_JUSTIFICATION (leading)
        titlePosition - an integer specifying the vertical position of the text in relation to the border -- one of the following:
        • TitledBorder.ABOVE_TOP
        • TitledBorder.TOP (sitting on the top line)
        • TitledBorder.BELOW_TOP
        • TitledBorder.ABOVE_BOTTOM
        • TitledBorder.BOTTOM (sitting on the bottom line)
        • TitledBorder.BELOW_BOTTOM
        • TitledBorder.DEFAULT_POSITION (top)
        titleFont - a Font object specifying the title font
        返回：
        the TitledBorder object

      • createTitledBorder

        public static TitledBorder createTitledBorder(Border border,
                              String title,
                              int titleJustification,
                              int titlePosition,
                              Font titleFont,
                              Color titleColor)
        Adds a title to an existing border, with the specified positioning, font and color.
        参数：
        border - the Border object to add the title to
        title - a String containing the text of the title
        titleJustification - an integer specifying the justification of the title -- one of the following:
        • TitledBorder.LEFT
        • TitledBorder.CENTER
        • TitledBorder.RIGHT
        • TitledBorder.LEADING
        • TitledBorder.TRAILING
        • TitledBorder.DEFAULT_JUSTIFICATION (leading)
        titlePosition - an integer specifying the vertical position of the text in relation to the border -- one of the following:
        • TitledBorder.ABOVE_TOP
        • TitledBorder.TOP (sitting on the top line)
        • TitledBorder.BELOW_TOP
        • TitledBorder.ABOVE_BOTTOM
        • TitledBorder.BOTTOM (sitting on the bottom line)
        • TitledBorder.BELOW_BOTTOM
        • TitledBorder.DEFAULT_POSITION (top)
        titleFont - a Font object specifying the title font
        titleColor - a Color object specifying the title color
        返回：
        the TitledBorder object

      • createEmptyBorder

        public static Border createEmptyBorder()
        Creates an empty border that takes up no space. (The width of the top, bottom, left, and right sides are all zero.)
        返回：
        the Border object

      • createEmptyBorder

        public static Border createEmptyBorder(int top,
                       int left,
                       int bottom,
                       int right)
        Creates an empty border that takes up space but which does no drawing, specifying the width of the top, left, bottom, and right sides.
        参数：
        top - an integer specifying the width of the top, in pixels
        left - an integer specifying the width of the left side, in pixels
        bottom - an integer specifying the width of the bottom, in pixels
        right - an integer specifying the width of the right side, in pixels
        返回：
        the Border object

      • createCompoundBorder

        public static CompoundBorder createCompoundBorder()
        Creates a compound border with a null inside edge and a null outside edge.
        返回：
        the CompoundBorder object

      • createCompoundBorder

        public static CompoundBorder createCompoundBorder(Border outsideBorder,
                                  Border insideBorder)
        Creates a compound border specifying the border objects to use for the outside and inside edges.
        参数：
        outsideBorder - a Border object for the outer edge of the compound border
        insideBorder - a Border object for the inner edge of the compound border
        返回：
        the CompoundBorder object

      • createMatteBorder

        public static MatteBorder createMatteBorder(int top,
                            int left,
                            int bottom,
                            int right,
                            Color color)
        Creates a matte-look border using a solid color. (The difference between this border and a line border is that you can specify the individual border dimensions.)
        参数：
        top - an integer specifying the width of the top, in pixels
        left - an integer specifying the width of the left side, in pixels
        bottom - an integer specifying the width of the right side, in pixels
        right - an integer specifying the width of the bottom, in pixels
        color - a Color to use for the border
        返回：
        the MatteBorder object

      • createMatteBorder

        public static MatteBorder createMatteBorder(int top,
                            int left,
                            int bottom,
                            int right,
                            Icon tileIcon)
        Creates a matte-look border that consists of multiple tiles of a specified icon. Multiple copies of the icon are placed side-by-side to fill up the border area.

        Note:
        If the icon doesn't load, the border area is painted gray.

        参数：
        top - an integer specifying the width of the top, in pixels
        left - an integer specifying the width of the left side, in pixels
        bottom - an integer specifying the width of the right side, in pixels
        right - an integer specifying the width of the bottom, in pixels
        tileIcon - the Icon object used for the border tiles
        返回：
        the MatteBorder object

      • createStrokeBorder

        public static Border createStrokeBorder(BasicStroke stroke)
        Creates a border of the specified stroke. The component's foreground color will be used to render the border.
        参数：
        stroke - the BasicStroke object used to stroke a shape
        返回：
        the Border object
        抛出：
        NullPointerException - if the specified stroke is null
        从以下版本开始：
        1.7

      • createStrokeBorder

        public static Border createStrokeBorder(BasicStroke stroke,
                        Paint paint)
        Creates a border of the specified stroke and paint. If the specified paint is null, the component's foreground color will be used to render the border.
        参数：
        stroke - the BasicStroke object used to stroke a shape
        paint - the Paint object used to generate a color
        返回：
        the Border object
        抛出：
        NullPointerException - if the specified stroke is null
        从以下版本开始：
        1.7

      • createDashedBorder

        public static Border createDashedBorder(Paint paint)
        Creates a dashed border of the specified paint. If the specified paint is null, the component's foreground color will be used to render the border. The width of a dash line is equal to 1. The relative length of a dash line and the relative spacing between dash lines are equal to 1. A dash line is not rounded.
        参数：
        paint - the Paint object used to generate a color
        返回：
        the Border object
        从以下版本开始：
        1.7

      • createDashedBorder

        public static Border createDashedBorder(Paint paint,
                        float length,
                        float spacing)
        Creates a dashed border of the specified paint, relative length, and relative spacing. If the specified paint is null, the component's foreground color will be used to render the border. The width of a dash line is equal to 1. A dash line is not rounded.
        参数：
        paint - the Paint object used to generate a color
        length - the relative length of a dash line
        spacing - the relative spacing between dash lines
        返回：
        the Border object
        抛出：
        IllegalArgumentException - if the specified length is less than 1, or if the specified spacing is less than 0
        从以下版本开始：
        1.7

      • createDashedBorder

        public static Border createDashedBorder(Paint paint,
                        float thickness,
                        float length,
                        float spacing,
                        boolean rounded)
        Creates a dashed border of the specified paint, thickness, line shape, relative length, and relative spacing. If the specified paint is null, the component's foreground color will be used to render the border.
        参数：
        paint - the Paint object used to generate a color
        thickness - the width of a dash line
        length - the relative length of a dash line
        spacing - the relative spacing between dash lines
        rounded - whether or not line ends should be round
        返回：
        the Border object
        抛出：
        IllegalArgumentException - if the specified thickness is less than 1, or if the specified length is less than 1, or if the specified spacing is less than 0
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


BoundedRangeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface BoundedRangeModel

  • All Known Implementing Classes:
    DefaultBoundedRangeModel

    public interface BoundedRangeModel
    Defines the data model used by components like Sliders and ProgressBars. Defines four interrelated integer properties: minimum, maximum, extent and value. These four integers define two nested ranges like this:
     minimum <= value <= value+extent <= maximum
    The outer range is minimum,maximum and the inner range is value,value+extent. The inner range must lie within the outer one, i.e. value must be less than or equal to maximum and value+extent must greater than or equal to minimum, and maximum must be greater than or equal to minimum. There are a few features of this model that one might find a little surprising. These quirks exist for the convenience of the Swing BoundedRangeModel clients, such as Slider and ScrollBar.
    • The minimum and maximum set methods "correct" the other three properties to accommodate their new value argument. For example setting the model's minimum may change its maximum, value, and extent properties (in that order), to maintain the constraints specified above.
    • The value and extent set methods "correct" their argument to fit within the limits defined by the other three properties. For example if value == maximum, setExtent(10) would change the extent (back) to zero.
    • The four BoundedRangeModel values are defined as Java Beans properties however Swing ChangeEvents are used to notify clients of changes rather than PropertyChangeEvents. This was done to keep the overhead of monitoring a BoundedRangeModel low. Changes are often reported at MouseDragged rates.

    For an example of specifying custom bounded range models used by sliders, see The Anatomy of a Swing-Based Program in The Java Tutorial.

    另请参见：
    DefaultBoundedRangeModel

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener x)
      Adds a ChangeListener to the model's listener list.
      int getExtent()
      Returns the model's extent, the length of the inner range that begins at the model's value.
      int getMaximum()
      Returns the model's maximum.
      int getMinimum()
      Returns the minimum acceptable value.
      int getValue()
      Returns the model's current value.
      boolean getValueIsAdjusting()
      Returns true if the current changes to the value property are part of a series of changes.
      void removeChangeListener(ChangeListener x)
      Removes a ChangeListener from the model's listener list.
      void setExtent(int newExtent)
      Sets the model's extent.
      void setMaximum(int newMaximum)
      Sets the model's maximum to newMaximum.
      void setMinimum(int newMinimum)
      Sets the model's minimum to newMinimum.
      void setRangeProperties(int value, int extent, int min, int max, boolean adjusting)
      This method sets all of the model's data with a single method call.
      void setValue(int newValue)
      Sets the model's current value to newValue if newValue satisfies the model's constraints.
      void setValueIsAdjusting(boolean b)
      This attribute indicates that any upcoming changes to the value of the model should be considered a single event.

    • 方法详细信息

      • getMinimum

        int getMinimum()
        Returns the minimum acceptable value.
        返回：
        the value of the minimum property
        另请参见：
        setMinimum(int)

      • setMinimum

        void setMinimum(int newMinimum)
        Sets the model's minimum to newMinimum. The other three properties may be changed as well, to ensure that:
         minimum <= value <= value+extent <= maximum

        Notifies any listeners if the model changes.

        参数：
        newMinimum - the model's new minimum
        另请参见：
        getMinimum(), addChangeListener(javax.swing.event.ChangeListener)

      • getMaximum

        int getMaximum()
        Returns the model's maximum. Note that the upper limit on the model's value is (maximum - extent).
        返回：
        the value of the maximum property.
        另请参见：
        setMaximum(int), setExtent(int)

      • setMaximum

        void setMaximum(int newMaximum)
        Sets the model's maximum to newMaximum. The other three properties may be changed as well, to ensure that
         minimum <= value <= value+extent <= maximum

        Notifies any listeners if the model changes.

        参数：
        newMaximum - the model's new maximum
        另请参见：
        getMaximum(), addChangeListener(javax.swing.event.ChangeListener)

      • getValue

        int getValue()
        Returns the model's current value. Note that the upper limit on the model's value is maximum - extent and the lower limit is minimum.
        返回：
        the model's value
        另请参见：
        setValue(int)

      • setValue

        void setValue(int newValue)
        Sets the model's current value to newValue if newValue satisfies the model's constraints. Those constraints are:
         minimum <= value <= value+extent <= maximum
        Otherwise, if newValue is less than minimum it's set to minimum, if its greater than maximum then it's set to maximum, and if it's greater than value+extent then it's set to value+extent.

        When a BoundedRange model is used with a scrollbar the value specifies the origin of the scrollbar knob (aka the "thumb" or "elevator"). The value usually represents the origin of the visible part of the object being scrolled.

        Notifies any listeners if the model changes.

        参数：
        newValue - the model's new value
        另请参见：
        getValue()

      • setValueIsAdjusting

        void setValueIsAdjusting(boolean b)
        This attribute indicates that any upcoming changes to the value of the model should be considered a single event. This attribute will be set to true at the start of a series of changes to the value, and will be set to false when the value has finished changing. Normally this allows a listener to only take action when the final value change in committed, instead of having to do updates for all intermediate values.

        Sliders and scrollbars use this property when a drag is underway.

        参数：
        b - true if the upcoming changes to the value property are part of a series

      • getValueIsAdjusting

        boolean getValueIsAdjusting()
        Returns true if the current changes to the value property are part of a series of changes.
        返回：
        the valueIsAdjustingProperty.
        另请参见：
        setValueIsAdjusting(boolean)

      • getExtent

        int getExtent()
        Returns the model's extent, the length of the inner range that begins at the model's value.
        返回：
        the value of the model's extent property
        另请参见：
        setExtent(int), setValue(int)

      • setExtent

        void setExtent(int newExtent)
        Sets the model's extent. The newExtent is forced to be greater than or equal to zero and less than or equal to maximum - value.

        When a BoundedRange model is used with a scrollbar the extent defines the length of the scrollbar knob (aka the "thumb" or "elevator"). The extent usually represents how much of the object being scrolled is visible. When used with a slider, the extent determines how much the value can "jump", for example when the user presses PgUp or PgDn.

        Notifies any listeners if the model changes.

        参数：
        newExtent - the model's new extent
        另请参见：
        getExtent(), setValue(int)

      • setRangeProperties

        void setRangeProperties(int value,
                      int extent,
                      int min,
                      int max,
                      boolean adjusting)
        This method sets all of the model's data with a single method call. The method results in a single change event being generated. This is convenient when you need to adjust all the model data simultaneously and do not want individual change events to occur.
        参数：
        value - an int giving the current value
        extent - an int giving the amount by which the value can "jump"
        min - an int giving the minimum value
        max - an int giving the maximum value
        adjusting - a boolean, true if a series of changes are in progress
        另请参见：
        setValue(int), setExtent(int), setMinimum(int), setMaximum(int), setValueIsAdjusting(boolean)

      • addChangeListener

        void addChangeListener(ChangeListener x)
        Adds a ChangeListener to the model's listener list.
        参数：
        x - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        void removeChangeListener(ChangeListener x)
        Removes a ChangeListener from the model's listener list.
        参数：
        x - the ChangeListener to remove
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> &>.ajlaj aaj stiir"iree;o sscns


Box

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Box

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.Box
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class Box
extends JComponent
implements Accessible
    A lightweight container that uses a BoxLayout object as its layout manager. Box provides several class methods that are useful for containers using BoxLayout -- even non-Box containers.

    The Box class can create several kinds of invisible components that affect layout: glue, struts, and rigid areas. If all the components your Box contains have a fixed size, you might want to use a glue component (returned by createGlue) to control the components' positions. If you need a fixed amount of space between two components, try using a strut (createHorizontalStrut or createVerticalStrut). If you need an invisible component that always takes up the same amount of space, get it by invoking createRigidArea.

    If you are implementing a BoxLayout you can find further information and examples in How to Use BoxLayout, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BoxLayout

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  Box.AccessibleBox
      This class implements accessibility support for the Box class.
      static class  Box.Filler
      An implementation of a lightweight component that participates in layout but has no view.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      Box(int axis)
      Creates a Box that displays its components along the the specified axis.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Component createGlue()
      Creates an invisible "glue" component that can be useful in a Box whose visible components have a maximum width (for a horizontal box) or height (for a vertical box).
      static Box createHorizontalBox()
      Creates a Box that displays its components from left to right.
      static Component createHorizontalGlue()
      Creates a horizontal glue component.
      static Component createHorizontalStrut(int width)
      Creates an invisible, fixed-width component.
      static Component createRigidArea(Dimension d)
      Creates an invisible component that's always the specified size.
      static Box createVerticalBox()
      Creates a Box that displays its components from top to bottom.
      static Component createVerticalGlue()
      Creates a vertical glue component.
      static Component createVerticalStrut(int height)
      Creates an invisible, fixed-height component.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this Box.
      protected void paintComponent(Graphics g)
      Paints this Box.
      void setLayout(LayoutManager l)
      Throws an AWTError, since a Box can use only a BoxLayout.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Box

        public Box(int axis)
        Creates a Box that displays its components along the the specified axis.
        参数：
        axis - can be BoxLayout.X_AXIS, BoxLayout.Y_AXIS, BoxLayout.LINE_AXIS or BoxLayout.PAGE_AXIS.
        抛出：
        AWTError - if the axis is invalid
        另请参见：
        createHorizontalBox(), createVerticalBox()

    • 方法详细信息

      • createHorizontalBox

        public static Box createHorizontalBox()
        Creates a Box that displays its components from left to right. If you want a Box that respects the component orientation you should create the Box using the constructor and pass in BoxLayout.LINE_AXIS, eg:
           Box lineBox = new Box(BoxLayout.LINE_AXIS);
        返回：
        the box

      • createVerticalBox

        public static Box createVerticalBox()
        Creates a Box that displays its components from top to bottom. If you want a Box that respects the component orientation you should create the Box using the constructor and pass in BoxLayout.PAGE_AXIS, eg:
           Box lineBox = new Box(BoxLayout.PAGE_AXIS);
        返回：
        the box

      • createRigidArea

        public static Component createRigidArea(Dimension d)
        Creates an invisible component that's always the specified size.
        参数：
        d - the dimensions of the invisible component
        返回：
        the component
        另请参见：
        createGlue(), createHorizontalStrut(int), createVerticalStrut(int)

      • createHorizontalStrut

        public static Component createHorizontalStrut(int width)
        Creates an invisible, fixed-width component. In a horizontal box, you typically use this method to force a certain amount of space between two components. In a vertical box, you might use this method to force the box to be at least the specified width. The invisible component has no height unless excess space is available, in which case it takes its share of available space, just like any other component that has no maximum height.
        参数：
        width - the width of the invisible component, in pixels >= 0
        返回：
        the component
        另请参见：
        createVerticalStrut(int), createGlue(), createRigidArea(java.awt.Dimension)

      • createVerticalStrut

        public static Component createVerticalStrut(int height)
        Creates an invisible, fixed-height component. In a vertical box, you typically use this method to force a certain amount of space between two components. In a horizontal box, you might use this method to force the box to be at least the specified height. The invisible component has no width unless excess space is available, in which case it takes its share of available space, just like any other component that has no maximum width.
        参数：
        height - the height of the invisible component, in pixels >= 0
        返回：
        the component
        另请参见：
        createHorizontalStrut(int), createGlue(), createRigidArea(java.awt.Dimension)

      • createGlue

        public static Component createGlue()
        Creates an invisible "glue" component that can be useful in a Box whose visible components have a maximum width (for a horizontal box) or height (for a vertical box). You can think of the glue component as being a gooey substance that expands as much as necessary to fill the space between its neighboring components.

        For example, suppose you have a horizontal box that contains two fixed-size components. If the box gets extra space, the fixed-size components won't become larger, so where does the extra space go? Without glue, the extra space goes to the right of the second component. If you put glue between the fixed-size components, then the extra space goes there. If you put glue before the first fixed-size component, the extra space goes there, and the fixed-size components are shoved against the right edge of the box. If you put glue before the first fixed-size component and after the second fixed-size component, the fixed-size components are centered in the box.

        To use glue, call Box.createGlue and add the returned component to a container. The glue component has no minimum or preferred size, so it takes no space unless excess space is available. If excess space is available, then the glue component takes its share of available horizontal or vertical space, just like any other component that has no maximum width or height.

        返回：
        the component

      • createHorizontalGlue

        public static Component createHorizontalGlue()
        Creates a horizontal glue component.
        返回：
        the component

      • createVerticalGlue

        public static Component createVerticalGlue()
        Creates a vertical glue component.
        返回：
        the component

      • setLayout

        public void setLayout(LayoutManager l)
        Throws an AWTError, since a Box can use only a BoxLayout.
        重载：
        setLayout in class Container
        参数：
        l - the layout manager to use
        另请参见：
        Container.doLayout(),
Container.getLayout(),
Container.invalidate()

      • paintComponent

        protected void paintComponent(Graphics g)
        Paints this Box. If this Box has a UI this method invokes super's implementation, otherwise if this Box is opaque the Graphics is filled using the background.
        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics to paint to
        抛出：
        NullPointerException - if g is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this Box. For boxes, the AccessibleContext takes the form of an AccessibleBox. A new AccessibleAWTBox instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleBox that serves as the AccessibleContext of this Box
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Box.AccessibleBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Box.AccessibleBox

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    Box

    protected class Box.AccessibleBox
extends Container.AccessibleAWTContainer
    This class implements accessibility support for the Box class.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | Box.AccessibleBox()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Box.AccessibleBox

        protected Box.AccessibleBox()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class Component.AccessibleAWTComponent
        返回：
        an instance of AccessibleRole describing the role of the object (AccessibleRole.FILLER)
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/odhrh h/h"t://waa//笪右r�>峄刺obrccA 鄌sut�


Box.Filler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Box.Filler

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.Box.Filler
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible
    封闭类：
    Box

    public static class Box.Filler
extends JComponent
implements Accessible
    An implementation of a lightweight component that participates in layout but has no view.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  Box.Filler.AccessibleBoxFiller
      This class implements accessibility support for the Box.Filler class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      Box.Filler(Dimension min, Dimension pref, Dimension max)
      Constructor to create shape with the given size ranges.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void changeShape(Dimension min, Dimension pref, Dimension max)
      Change the size requests for this shape.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this Box.Filler.
      protected void paintComponent(Graphics g)
      Paints this Filler.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Box.Filler

        @ConstructorProperties(value={"minimumSize","preferredSize","maximumSize"})
public Box.Filler(Dimension min,
                                     Dimension pref,
                                     Dimension max)
        Constructor to create shape with the given size ranges.
        参数：
        min - Minimum size
        pref - Preferred size
        max - Maximum size

    • 方法详细信息

      • changeShape

        public void changeShape(Dimension min,
               Dimension pref,
               Dimension max)
        Change the size requests for this shape. An invalidate() is propagated upward as a result so that layout will eventually happen with using the new sizes.
        参数：
        min - Value to return for getMinimumSize
        pref - Value to return for getPreferredSize
        max - Value to return for getMaximumSize

      • paintComponent

        protected void paintComponent(Graphics g)
        Paints this Filler. If this Filler has a UI this method invokes super's implementation, otherwise if this Filler is opaque the Graphics is filled using the background.
        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics to paint to
        抛出：
        NullPointerException - if g is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this Box.Filler. For box fillers, the AccessibleContext takes the form of an AccessibleBoxFiller. A new AccessibleAWTBoxFiller instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleBoxFiller that serves as the AccessibleContext of this Box.Filler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Box.Filler.AccessibleBoxFiller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Box.Filler.AccessibleBoxFiller

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • javax.swing.Box.Filler.AccessibleBoxFiller
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    Box.Filler

    protected class Box.Filler.AccessibleBoxFiller
extends Component.AccessibleAWTComponent
    This class implements accessibility support for the Box.Filler class.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | Box.Filler.AccessibleBoxFiller()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Box.Filler.AccessibleBoxFiller

        protected Box.Filler.AccessibleBoxFiller()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class Component.AccessibleAWTComponent
        返回：
        an instance of AccessibleRole describing the role of the object (AccessibleRole.FILLER)
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sc_mdmtmsmocassaa_eeu<> aicabcsua>v NNvslb/


BoxLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 BoxLayout

  • java.lang.Object
    • javax.swing.BoxLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2, Serializable
    直接已知子类：
    DefaultMenuLayout

    public class BoxLayout
extends Object
implements LayoutManager2, Serializable
    A layout manager that allows multiple components to be laid out either vertically or horizontally. The components will not wrap so, for example, a vertical arrangement of components will stay vertically arranged when the frame is resized.

    The following text describes this graphic.

    Nesting multiple panels with different combinations of horizontal and vertical gives an effect similar to GridBagLayout, without the complexity. The diagram shows two panels arranged horizontally, each of which contains 3 components arranged vertically.

    The BoxLayout manager is constructed with an axis parameter that specifies the type of layout that will be done. There are four choices:

    X_AXIS - Components are laid out horizontally from left to right.
    Y_AXIS - Components are laid out vertically from top to bottom.
    LINE_AXIS - Components are laid out the way words are laid out in a line, based on the container's ComponentOrientation property. If the container's ComponentOrientation is horizontal then components are laid out horizontally, otherwise they are laid out vertically. For horizontal orientations, if the container's ComponentOrientation is left to right then components are laid out left to right, otherwise they are laid out right to left. For vertical orientations components are always laid out from top to bottom.
    PAGE_AXIS - Components are laid out the way text lines are laid out on a page, based on the container's ComponentOrientation property. If the container's ComponentOrientation is horizontal then components are laid out vertically, otherwise they are laid out horizontally. For horizontal orientations, if the container's ComponentOrientation is left to right then components are laid out left to right, otherwise they are laid out right to left. For vertical orientations components are always laid out from top to bottom.

    For all directions, components are arranged in the same order as they were added to the container.

    BoxLayout attempts to arrange components at their preferred widths (for horizontal layout) or heights (for vertical layout). For a horizontal layout, if not all the components are the same height, BoxLayout attempts to make all the components as high as the highest component. If that's not possible for a particular component, then BoxLayout aligns that component vertically, according to the component's Y alignment. By default, a component has a Y alignment of 0.5, which means that the vertical center of the component should have the same Y coordinate as the vertical centers of other components with 0.5 Y alignment.

    Similarly, for a vertical layout, BoxLayout attempts to make all components in the column as wide as the widest component. If that fails, it aligns them horizontally according to their X alignments. For PAGE_AXIS layout, horizontal alignment is done based on the leading edge of the component. In other words, an X alignment value of 0.0 means the left edge of a component if the container's ComponentOrientation is left to right and it means the right edge of the component otherwise.

    Instead of using BoxLayout directly, many programs use the Box class. The Box class is a lightweight container that uses a BoxLayout. It also provides handy methods to help you use BoxLayout well. Adding components to multiple nested boxes is a powerful way to get the arrangement you want.

    For further information and examples see How to Use BoxLayout, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Box, ComponentOrientation, JComponent.getAlignmentX(), JComponent.getAlignmentY()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int LINE_AXIS
      Specifies that components should be laid out in the direction of a line of text as determined by the target container's ComponentOrientation property.
      static int PAGE_AXIS
      Specifies that components should be laid out in the direction that lines flow across a page as determined by the target container's ComponentOrientation property.
      static int X_AXIS
      Specifies that components should be laid out left to right.
      static int Y_AXIS
      Specifies that components should be laid out top to bottom.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BoxLayout(Container target, int axis)
      Creates a layout manager that will lay out components along the given axis.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component comp, Object constraints)
      Not used by this class.
      void addLayoutComponent(String name, Component comp)
      Not used by this class.
      int getAxis()
      Returns the axis that was used to lay out components.
      float getLayoutAlignmentX(Container target)
      Returns the alignment along the X axis for the container.
      float getLayoutAlignmentY(Container target)
      Returns the alignment along the Y axis for the container.
      Container getTarget()
      Returns the container that uses this layout manager.
      void invalidateLayout(Container target)
      Indicates that a child has changed its layout related information, and thus any cached calculations should be flushed.
      void layoutContainer(Container target)
      Called by the AWT when the specified container needs to be laid out.
      Dimension maximumLayoutSize(Container target)
      Returns the maximum dimensions the target container can use to lay out the components it contains.
      Dimension minimumLayoutSize(Container target)
      Returns the minimum dimensions needed to lay out the components contained in the specified target container.
      Dimension preferredLayoutSize(Container target)
      Returns the preferred dimensions for this layout, given the components in the specified target container.
      void removeLayoutComponent(Component comp)
      Not used by this class.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • X_AXIS

        public static final int X_AXIS
        Specifies that components should be laid out left to right.
        另请参见：
        Constant Field Values

      • Y_AXIS

        public static final int Y_AXIS
        Specifies that components should be laid out top to bottom.
        另请参见：
        Constant Field Values

      • LINE_AXIS

        public static final int LINE_AXIS
        Specifies that components should be laid out in the direction of a line of text as determined by the target container's ComponentOrientation property.
        另请参见：
        Constant Field Values

      • PAGE_AXIS

        public static final int PAGE_AXIS
        Specifies that components should be laid out in the direction that lines flow across a page as determined by the target container's ComponentOrientation property.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BoxLayout

        @ConstructorProperties(value={"target","axis"})
public BoxLayout(Container target,
                                    int axis)
        Creates a layout manager that will lay out components along the given axis.
        参数：
        target - the container that needs to be laid out
        axis - the axis to lay out components along. Can be one of: BoxLayout.X_AXIS, BoxLayout.Y_AXIS, BoxLayout.LINE_AXIS or BoxLayout.PAGE_AXIS
        抛出：
        AWTError - if the value of axis is invalid

    • 方法详细信息

      • getTarget

        public final Container getTarget()
        Returns the container that uses this layout manager.
        返回：
        the container that uses this layout manager
        从以下版本开始：
        1.6

      • getAxis

        public final int getAxis()
        Returns the axis that was used to lay out components. Returns one of: BoxLayout.X_AXIS, BoxLayout.Y_AXIS, BoxLayout.LINE_AXIS or BoxLayout.PAGE_AXIS
        返回：
        the axis that was used to lay out components
        从以下版本开始：
        1.6

      • invalidateLayout

        public void invalidateLayout(Container target)
        Indicates that a child has changed its layout related information, and thus any cached calculations should be flushed.

        This method is called by AWT when the invalidate method is called on the Container. Since the invalidate method may be called asynchronously to the event thread, this method may be called asynchronously.

        指定者：
        invalidateLayout in interface LayoutManager2
        参数：
        target - the affected container
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component comp)
        Not used by this class.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the name of the component
        comp - the component

      • removeLayoutComponent

        public void removeLayoutComponent(Component comp)
        Not used by this class.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        comp - the component

      • addLayoutComponent

        public void addLayoutComponent(Component comp,
                      Object constraints)
        Not used by this class.
        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        comp - the component
        constraints - constraints

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container target)
        Returns the preferred dimensions for this layout, given the components in the specified target container.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        target - the container that needs to be laid out
        返回：
        the dimensions >= 0 && <= Integer.MAX_VALUE
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor
        另请参见：
        Container, minimumLayoutSize(java.awt.Container), maximumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container target)
        Returns the minimum dimensions needed to lay out the components contained in the specified target container.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        target - the container that needs to be laid out
        返回：
        the dimensions >= 0 && <= Integer.MAX_VALUE
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor
        另请参见：
        preferredLayoutSize(java.awt.Container), maximumLayoutSize(java.awt.Container)

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container target)
        Returns the maximum dimensions the target container can use to lay out the components it contains.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        参数：
        target - the container that needs to be laid out
        返回：
        the dimenions >= 0 && <= Integer.MAX_VALUE
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor
        另请参见：
        preferredLayoutSize(java.awt.Container), minimumLayoutSize(java.awt.Container)

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container target)
        Returns the alignment along the X axis for the container. If the box is horizontal, the default alignment will be returned. Otherwise, the alignment needed to place the children along the X axis will be returned.
        指定者：
        getLayoutAlignmentX in interface LayoutManager2
        参数：
        target - the container
        返回：
        the alignment >= 0.0f && <= 1.0f
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container target)
        Returns the alignment along the Y axis for the container. If the box is vertical, the default alignment will be returned. Otherwise, the alignment needed to place the children along the Y axis will be returned.
        指定者：
        getLayoutAlignmentY in interface LayoutManager2
        参数：
        target - the container
        返回：
        the alignment >= 0.0f && <= 1.0f
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor

      • layoutContainer

        public void layoutContainer(Container target)
        Called by the AWT when the specified container needs to be laid out.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        target - the container to lay out
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltaaetPrtPerrPeelnvvll,ba..,ga eaOaO.bjajjinr ntc


ButtonGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ButtonGroup

  • java.lang.Object
    • javax.swing.ButtonGroup
  • 所有已实现的接口：
    Serializable

    public class ButtonGroup
extends Object
implements Serializable
    This class is used to create a multiple-exclusion scope for a set of buttons. Creating a set of buttons with the same ButtonGroup object means that turning "on" one of those buttons turns off all other buttons in the group.

    A ButtonGroup can be used with any set of objects that inherit from AbstractButton. Typically a button group contains instances of JRadioButton, JRadioButtonMenuItem, or JToggleButton. It wouldn't make sense to put an instance of JButton or JMenuItem in a button group because JButton and JMenuItem don't implement the selected state.

    Initially, all buttons in the group are unselected.

    For examples and further information on using button groups see How to Use Radio Buttons, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Vector<AbstractButton> | buttons

    • 构造方法摘要

      Constructors
      构造方法与描述
      ButtonGroup()
      Creates a new ButtonGroup.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(AbstractButton b)
      Adds the button to the group.
      void clearSelection()
      Clears the selection such that none of the buttons in the ButtonGroup are selected.
      int getButtonCount()
      Returns the number of buttons in the group.
      Enumeration<AbstractButton> getElements()
      Returns all the buttons that are participating in this group.
      ButtonModel getSelection()
      Returns the model of the selected button.
      boolean isSelected(ButtonModel m)
      Returns whether a ButtonModel is selected.
      void remove(AbstractButton b)
      Removes the button from the group.
      void setSelected(ButtonModel m, boolean b)
      Sets the selected value for the ButtonModel.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buttons

        protected Vector<AbstractButton> buttons

    • 构造方法详细信息

      • ButtonGroup

        public ButtonGroup()
        Creates a new ButtonGroup.

    • 方法详细信息

      • add

        public void add(AbstractButton b)
        Adds the button to the group.
        参数：
        b - the button to be added

      • remove

        public void remove(AbstractButton b)
        Removes the button from the group.
        参数：
        b - the button to be removed

      • clearSelection

        public void clearSelection()
        Clears the selection such that none of the buttons in the ButtonGroup are selected.
        从以下版本开始：
        1.6

      • getElements

        public Enumeration<AbstractButton> getElements()
        Returns all the buttons that are participating in this group.
        返回：
        an Enumeration of the buttons in this group

      • getSelection

        public ButtonModel getSelection()
        Returns the model of the selected button.
        返回：
        the selected button model

      • setSelected

        public void setSelected(ButtonModel m,
               boolean b)
        Sets the selected value for the ButtonModel. Only one button in the group may be selected at a time.
        参数：
        m - the ButtonModel
        b - true if this button is to be selected, otherwise false

      • isSelected

        public boolean isSelected(ButtonModel m)
        Returns whether a ButtonModel is selected.
        返回：
        true if the button is selected, otherwise returns false

      • getButtonCount

        public int getButtonCount()
        Returns the number of buttons in the group.
        返回：
        the button count
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

daem>ai


ButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ButtonModel

  • All Superinterfaces:
    ItemSelectable
    All Known Implementing Classes:
    DefaultButtonModel, JToggleButton.ToggleButtonModel

    public interface ButtonModel
extends ItemSelectable
    State model for buttons.

    This model is used for regular buttons, as well as check boxes and radio buttons, which are special kinds of buttons. In practice, a button's UI takes the responsibility of calling methods on its model to manage the state, as detailed below:

    In simple terms, pressing and releasing the mouse over a regular button triggers the button and causes and ActionEvent to be fired. The same behavior can be produced via a keyboard key defined by the look and feel of the button (typically the SPACE BAR). Pressing and releasing this key while the button has focus will give the same results. For check boxes and radio buttons, the mouse or keyboard equivalent sequence just described causes the button to become selected.

    In details, the state model for buttons works as follows when used with the mouse:
    Pressing the mouse on top of a button makes the model both armed and pressed. As long as the mouse remains down, the model remains pressed, even if the mouse moves outside the button. On the contrary, the model is only armed while the mouse remains pressed within the bounds of the button (it can move in or out of the button, but the model is only armed during the portion of time spent within the button). A button is triggered, and an ActionEvent is fired, when the mouse is released while the model is armed - meaning when it is released over top of the button after the mouse has previously been pressed on that button (and not already released). Upon mouse release, the model becomes unarmed and unpressed.

    In details, the state model for buttons works as follows when used with the keyboard:
    Pressing the look and feel defined keyboard key while the button has focus makes the model both armed and pressed. As long as this key remains down, the model remains in this state. Releasing the key sets the model to unarmed and unpressed, triggers the button, and causes an ActionEvent to be fired.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionListener(ActionListener l)
      Adds an ActionListener to the model.
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      void addItemListener(ItemListener l)
      Adds an ItemListener to the model.
      String getActionCommand()
      Returns the action command string for the button.
      int getMnemonic()
      Gets the keyboard mnemonic for the button.
      boolean isArmed()
      Indicates partial commitment towards triggering the button.
      boolean isEnabled()
      Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
      boolean isPressed()
      Indicates if the button is pressed.
      boolean isRollover()
      Indicates that the mouse is over the button.
      boolean isSelected()
      Indicates if the button has been selected.
      void removeActionListener(ActionListener l)
      Removes an ActionListener from the model.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void removeItemListener(ItemListener l)
      Removes an ItemListener from the model.
      void setActionCommand(String s)
      Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.
      void setArmed(boolean b)
      Marks the button as armed or unarmed.
      void setEnabled(boolean b)
      Enables or disables the button.
      void setGroup(ButtonGroup group)
      Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
      void setMnemonic(int key)
      Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.
      void setPressed(boolean b)
      Sets the button to pressed or unpressed.
      void setRollover(boolean b)
      Sets or clears the button's rollover state
      void setSelected(boolean b)
      Selects or deselects the button.

      • 方法 - 继承于接口 java.awt.ItemSelectable

        getSelectedObjects

    • 方法详细信息

      • isArmed

        boolean isArmed()
        Indicates partial commitment towards triggering the button.
        返回：
        true if the button is armed, and ready to be triggered
        另请参见：
        setArmed(boolean)

      • isSelected

        boolean isSelected()
        Indicates if the button has been selected. Only needed for certain types of buttons - such as radio buttons and check boxes.
        返回：
        true if the button is selected

      • isEnabled

        boolean isEnabled()
        Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
        返回：
        true if the button is enabled

      • isPressed

        boolean isPressed()
        Indicates if the button is pressed.
        返回：
        true if the button is pressed

      • isRollover

        boolean isRollover()
        Indicates that the mouse is over the button.
        返回：
        true if the mouse is over the button

      • setArmed

        void setArmed(boolean b)
        Marks the button as armed or unarmed.
        参数：
        b - whether or not the button should be armed

      • setSelected

        void setSelected(boolean b)
        Selects or deselects the button.
        参数：
        b - true selects the button, false deselects the button

      • setEnabled

        void setEnabled(boolean b)
        Enables or disables the button.
        参数：
        b - whether or not the button should be enabled
        另请参见：
        isEnabled()

      • setPressed

        void setPressed(boolean b)
        Sets the button to pressed or unpressed.
        参数：
        b - whether or not the button should be pressed
        另请参见：
        isPressed()

      • setRollover

        void setRollover(boolean b)
        Sets or clears the button's rollover state
        参数：
        b - whether or not the button is in the rollover state
        另请参见：
        isRollover()

      • setMnemonic

        void setMnemonic(int key)
        Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.
        参数：
        key - an int specifying the accelerator key

      • getMnemonic

        int getMnemonic()
        Gets the keyboard mnemonic for the button.
        返回：
        an int specifying the accelerator key
        另请参见：
        setMnemonic(int)

      • setActionCommand

        void setActionCommand(String s)
        Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.
        参数：
        s - the String that identifies the generated event
        另请参见：
        getActionCommand(), ActionEvent.getActionCommand()

      • getActionCommand

        String getActionCommand()
        Returns the action command string for the button.
        返回：
        the String that identifies the generated event
        另请参见：
        setActionCommand(java.lang.String)

      • setGroup

        void setGroup(ButtonGroup group)
        Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
        参数：
        group - the ButtonGroup the button belongs to

      • addActionListener

        void addActionListener(ActionListener l)
        Adds an ActionListener to the model.
        参数：
        l - the listener to add

      • removeActionListener

        void removeActionListener(ActionListener l)
        Removes an ActionListener from the model.
        参数：
        l - the listener to remove

      • addItemListener

        void addItemListener(ItemListener l)
        Adds an ItemListener to the model.
        指定者：
        addItemListener in interface ItemSelectable
        参数：
        l - the listener to add
        另请参见：
        ItemEvent

      • removeItemListener

        void removeItemListener(ItemListener l)
        Removes an ItemListener from the model.
        指定者：
        removeItemListener in interface ItemSelectable
        参数：
        l - the listener to remove
        另请参见：
        ItemEvent

      • addChangeListener

        void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the model.
        参数：
        l - the listener to add

      • removeChangeListener

        void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the model.
        参数：
        l - the listener to remove
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Clrb;> >/>aesomnsa///lic=�


CellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface CellEditor

  • All Known Subinterfaces:
    TableCellEditor, TreeCellEditor
    All Known Implementing Classes:
    AbstractCellEditor, DefaultCellEditor, DefaultTreeCellEditor

    public interface CellEditor
    This interface defines the methods any general editor should be able to implement.

    Having this interface enables complex components (the client of the editor) such as JTree and JTable to allow any generic editor to edit values in a table cell, or tree cell, etc. Without this generic editor interface, JTable would have to know about specific editors, such as JTextField, JCheckBox, JComboBox, etc. In addition, without this interface, clients of editors such as JTable would not be able to work with any editors developed in the future by the user or a 3rd party ISV.

    To use this interface, a developer creating a new editor can have the new component implement the interface. Or the developer can choose a wrapper based approach and provide a companion object which implements the CellEditor interface (See JCellEditor for example). The wrapper approach is particularly useful if the user want to use a 3rd party ISV editor with JTable, but the ISV didn't implement the CellEditor interface. The user can simply create an object that contains an instance of the 3rd party editor object and "translate" the CellEditor API into the 3rd party editor's API.

    另请参见：
    CellEditorListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addCellEditorListener(CellEditorListener l)
      Adds a listener to the list that's notified when the editor stops, or cancels editing.
      void cancelCellEditing()
      Tells the editor to cancel editing and not accept any partially edited value.
      Object getCellEditorValue()
      Returns the value contained in the editor.
      boolean isCellEditable(EventObject anEvent)
      Asks the editor if it can start editing using anEvent.
      void removeCellEditorListener(CellEditorListener l)
      Removes a listener from the list that's notified
      boolean shouldSelectCell(EventObject anEvent)
      Returns true if the editing cell should be selected, false otherwise.
      boolean stopCellEditing()
      Tells the editor to stop editing and accept any partially edited value as the value of the editor.

    • 方法详细信息

      • getCellEditorValue

        Object getCellEditorValue()
        Returns the value contained in the editor.
        返回：
        the value contained in the editor

      • isCellEditable

        boolean isCellEditable(EventObject anEvent)
        Asks the editor if it can start editing using anEvent. anEvent is in the invoking component coordinate system. The editor can not assume the Component returned by getCellEditorComponent is installed. This method is intended for the use of client to avoid the cost of setting up and installing the editor component if editing is not possible. If editing can be started this method returns true.
        参数：
        anEvent - the event the editor should use to consider whether to begin editing or not
        返回：
        true if editing can be started
        另请参见：
        shouldSelectCell(java.util.EventObject)

      • shouldSelectCell

        boolean shouldSelectCell(EventObject anEvent)
        Returns true if the editing cell should be selected, false otherwise. Typically, the return value is true, because is most cases the editing cell should be selected. However, it is useful to return false to keep the selection from changing for some types of edits. eg. A table that contains a column of check boxes, the user might want to be able to change those checkboxes without altering the selection. (See Netscape Communicator for just such an example) Of course, it is up to the client of the editor to use the return value, but it doesn't need to if it doesn't want to.
        参数：
        anEvent - the event the editor should use to start editing
        返回：
        true if the editor would like the editing cell to be selected; otherwise returns false
        另请参见：
        isCellEditable(java.util.EventObject)

      • stopCellEditing

        boolean stopCellEditing()
        Tells the editor to stop editing and accept any partially edited value as the value of the editor. The editor returns false if editing was not stopped; this is useful for editors that validate and can not accept invalid entries.
        返回：
        true if editing was stopped; false otherwise

      • cancelCellEditing

        void cancelCellEditing()
        Tells the editor to cancel editing and not accept any partially edited value.

      • addCellEditorListener

        void addCellEditorListener(CellEditorListener l)
        Adds a listener to the list that's notified when the editor stops, or cancels editing.
        参数：
        l - the CellEditorListener

      • removeCellEditorListener

        void removeCellEditorListener(CellEditorListener l)
        Removes a listener from the list that's notified
        参数：
        l - the CellEditorListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


CellRendererPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 CellRendererPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.CellRendererPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class CellRendererPane
extends Container
implements Accessible
    This class is inserted in between cell renderers and the components that use them. It just exists to thwart the repaint() and invalidate() methods which would otherwise propagate up the tree when the renderer was configured. It's used by the implementations of JTable, JTree, and JList. For example, here's how CellRendererPane is used in the code the paints each row in a JList:
       cellRendererPane = new CellRendererPane();
   ...
   Component rendererComponent = renderer.getListCellRendererComponent();
   renderer.configureListCellRenderer(dataModel.getElementAt(row), row);
   cellRendererPane.paintComponent(g, rendererComponent, this, x, y, w, h);

    A renderer component must override isShowing() and unconditionally return true to work correctly because the Swing paint does nothing for components with isShowing false.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  CellRendererPane.AccessibleCellRendererPane
      This class implements accessibility support for the CellRendererPane class.

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected AccessibleContext | accessibleContext

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      CellRendererPane()
      Construct a CellRendererPane object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component x, Object constraints, int index)
      If the specified component is already a child of this then we don't bother doing anything - stacking order doesn't matter for cell renderer components (CellRendererPane doesn't paint anyway).<
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this CellRendererPane.
      void invalidate()
      Overridden to avoid propagating a invalidate up the tree when the cell renderer child is configured.
      void paint(Graphics g)
      Shouldn't be called.
      void paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
      Calls this.paintComponent(g, c, p, x, y, w, h, false).
      void paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
      Paint a cell renderer component c on graphics object g.
      void paintComponent(Graphics g, Component c, Container p, Rectangle r)
      Calls this.paintComponent() with the rectangles x,y,width,height fields.
      void update(Graphics g)
      Shouldn't be called.

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • accessibleContext

        protected AccessibleContext accessibleContext

    • 构造方法详细信息

      • CellRendererPane

        public CellRendererPane()
        Construct a CellRendererPane object.

    • 方法详细信息

      • invalidate

        public void invalidate()
        Overridden to avoid propagating a invalidate up the tree when the cell renderer child is configured.
        重载：
        invalidate in class Container
        另请参见：
        Container.validate(), Container.layout(), LayoutManager2

      • paint

        public void paint(Graphics g)
        Shouldn't be called.
        重载：
        paint in class Container
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • update

        public void update(Graphics g)
        Shouldn't be called.
        重载：
        update in class Container
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • addImpl

        protected void addImpl(Component x,
           Object constraints,
           int index)
        If the specified component is already a child of this then we don't bother doing anything - stacking order doesn't matter for cell renderer components (CellRendererPane doesn't paint anyway).<
        重载：
        addImpl in class Container
        参数：
        x - the component to be added
        constraints - an object expressing layout constraints for this component
        index - the position in the container's list at which to insert the component, where -1 means append to the end
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • paintComponent

        public void paintComponent(Graphics g,
                  Component c,
                  Container p,
                  int x,
                  int y,
                  int w,
                  int h,
                  boolean shouldValidate)
        Paint a cell renderer component c on graphics object g. Before the component is drawn it's reparented to this (if that's necessary), it's bounds are set to w,h and the graphics object is (effectively) translated to x,y. If it's a JComponent, double buffering is temporarily turned off. After the component is painted it's bounds are reset to -w, -h, 0, 0 so that, if it's the last renderer component painted, it will not start consuming input. The Container p is the component we're actually drawing on, typically it's equal to this.getParent(). If shouldValidate is true the component c will be validated before painted.

      • paintComponent

        public void paintComponent(Graphics g,
                  Component c,
                  Container p,
                  int x,
                  int y,
                  int w,
                  int h)
        Calls this.paintComponent(g, c, p, x, y, w, h, false).

      • paintComponent

        public void paintComponent(Graphics g,
                  Component c,
                  Container p,
                  Rectangle r)
        Calls this.paintComponent() with the rectangles x,y,width,height fields.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this CellRendererPane. For CellRendererPanes, the AccessibleContext takes the form of an AccessibleCellRendererPane. A new AccessibleCellRendererPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class Component
        返回：
        an AccessibleCellRendererPane that serves as the AccessibleContext of this CellRendererPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CellRendererPane.AccessibleCellRendererPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 CellRendererPane.AccessibleCellRendererPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    CellRendererPane

    protected class CellRendererPane.AccessibleCellRendererPane
extends Container.AccessibleAWTContainer
    This class implements accessibility support for the CellRendererPane class.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | CellRendererPane.AccessibleCellRendererPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CellRendererPane.AccessibleCellRendererPane

        protected CellRendererPane.AccessibleCellRendererPane()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class Component.AccessibleAWTComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iasnn/fg//xss/xx/fttc>"" ="s=Liosusaadi>>s<


ComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ComboBoxEditor

  • All Known Implementing Classes:
    BasicComboBoxEditor, BasicComboBoxEditor.UIResource, MetalComboBoxEditor, MetalComboBoxEditor.UIResource

    public interface ComboBoxEditor
    The editor component used for JComboBox components.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionListener(ActionListener l)
      Add an ActionListener.
      Component getEditorComponent()
      Return the component that should be added to the tree hierarchy for this editor
      Object getItem()
      Return the edited item
      void removeActionListener(ActionListener l)
      Remove an ActionListener
      void selectAll()
      Ask the editor to start editing and to select everything
      void setItem(Object anObject)
      Set the item that should be edited.

    • 方法详细信息

      • getEditorComponent

        Component getEditorComponent()
        Return the component that should be added to the tree hierarchy for this editor

      • setItem

        void setItem(Object anObject)
        Set the item that should be edited. Cancel any editing if necessary

      • getItem

        Object getItem()
        Return the edited item

      • selectAll

        void selectAll()
        Ask the editor to start editing and to select everything

      • addActionListener

        void addActionListener(ActionListener l)
        Add an ActionListener. An action event is generated when the edited item changes

      • removeActionListener

        void removeActionListener(ActionListener l)
        Remove an ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sPtst "d "r>>"rrtl anMrfo o


ComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ComboBoxModel

  • All Superinterfaces:
    ListModel
    All Known Subinterfaces:
    MutableComboBoxModel
    All Known Implementing Classes:
    DefaultComboBoxModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel

    public interface ComboBoxModel
extends ListModel
    A data model for a combo box. This interface extends ListDataModel and adds the concept of a selected item. The selected item is generally the item which is visible in the combo box display area.

    The selected item may not necessarily be managed by the underlying ListModel. This disjoint behavior allows for the temporary storage and retrieval of a selected item in the model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getSelectedItem()
      Returns the selected item
      void setSelectedItem(Object anItem)
      Set the selected item.

      • 方法 - 继承于接口 javax.swing.ListModel

        addListDataListener, getElementAt, getSize, removeListDataListener

    • 方法详细信息

      • setSelectedItem

        void setSelectedItem(Object anItem)
        Set the selected item. The implementation of this method should notify all registered ListDataListeners that the contents have changed.
        参数：
        anItem - the list object to select or null to clear the selection

      • getSelectedItem

        Object getSelectedItem()
        Returns the selected item
        返回：
        The selected item or null if there is no selection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=o"tst tetptpe=epcuutoatto"


ComponentInputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ComponentInputMap

  • java.lang.Object
    • javax.swing.InputMap
      • javax.swing.ComponentInputMap
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    ComponentInputMapUIResource

    public class ComponentInputMap
extends InputMap
    A ComponentInputMap is an InputMap associated with a particular JComponent. The component is automatically notified whenever the ComponentInputMap changes. ComponentInputMaps are used for WHEN_IN_FOCUSED_WINDOW bindings.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComponentInputMap(JComponent component)
      Creates a ComponentInputMap associated with the specified component.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void clear()
      Removes all the mappings from this object.
      JComponent getComponent()
      Returns the component the InputMap was created for.
      void put(KeyStroke keyStroke, Object actionMapKey)
      Adds a binding for keyStroke to actionMapKey.
      void remove(KeyStroke key)
      Removes the binding for key from this object.
      void setParent(InputMap map)
      Sets the parent, which must be a ComponentInputMap associated with the same component as this ComponentInputMap.

      • 方法 - 继承于类 javax.swing.InputMap

        allKeys, get, getParent, keys, size

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentInputMap

        public ComponentInputMap(JComponent component)
        Creates a ComponentInputMap associated with the specified component.
        参数：
        component - a non-null JComponent
        抛出：
        IllegalArgumentException - if component is null

    • 方法详细信息

      • setParent

        public void setParent(InputMap map)
        Sets the parent, which must be a ComponentInputMap associated with the same component as this ComponentInputMap.
        重载：
        setParent in class InputMap
        参数：
        map - a ComponentInputMap
        抛出：
        IllegalArgumentException - if map is not a ComponentInputMap or is not associated with the same component

      • getComponent

        public JComponent getComponent()
        Returns the component the InputMap was created for.

      • put

        public void put(KeyStroke keyStroke,
       Object actionMapKey)
        Adds a binding for keyStroke to actionMapKey. If actionMapKey is null, this removes the current binding for keyStroke.
        重载：
        put in class InputMap

      • remove

        public void remove(KeyStroke key)
        Removes the binding for key from this object.
        重载：
        remove in class InputMap

      • clear

        public void clear()
        Removes all the mappings from this object.
        重载：
        clear in class InputMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rl ompwattwcaj=T=A//M.lgn.>o


DebugGraphics

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DebugGraphics

  • java.lang.Object
    • java.awt.Graphics
      • javax.swing.DebugGraphics

  • public class DebugGraphics
extends Graphics
    Graphics subclass supporting graphics debugging. Overrides most methods from Graphics. DebugGraphics objects are rarely created by hand. They are most frequently created automatically when a JComponent's debugGraphicsOptions are changed using the setDebugGraphicsOptions() method.

    NOTE: You must turn off double buffering to use DebugGraphics: RepaintManager repaintManager = RepaintManager.currentManager(component); repaintManager.setDoubleBufferingEnabled(false);

    另请参见：
    JComponent.setDebugGraphicsOptions(int),
RepaintManager.currentManager(java.awt.Component),
RepaintManager.setDoubleBufferingEnabled(boolean)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int BUFFERED_OPTION
      Show buffered operations in a separate Frame.
      static int FLASH_OPTION
      Flash graphics operations.
      static int LOG_OPTION
      Log graphics operations.
      static int NONE_OPTION
      Don't debug graphics operations.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DebugGraphics()
      Constructs a new debug graphics context that supports slowed down drawing.
      DebugGraphics(Graphics graphics)
      Constructs a debug graphics context from an existing graphics context that supports slowed down drawing.
      DebugGraphics(Graphics graphics, JComponent component)
      Constructs a debug graphics context from an existing graphics context that slows down drawing for the specified component.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void clearRect(int x, int y, int width, int height)
      Overrides Graphics.clearRect.
      void clipRect(int x, int y, int width, int height)
      Overrides Graphics.clipRect.
      void copyArea(int x, int y, int width, int height, int destX, int destY)
      Overrides Graphics.copyArea.
      Graphics create()
      Overrides Graphics.create to return a DebugGraphics object.
      Graphics create(int x, int y, int width, int height)
      Overrides Graphics.create to return a DebugGraphics object.
      void dispose()
      Overrides Graphics.dispose.
      void draw3DRect(int x, int y, int width, int height, boolean raised)
      Overrides Graphics.draw3DRect.
      void drawArc(int x, int y, int width, int height, int startAngle, int arcAngle)
      Overrides Graphics.drawArc.
      void drawBytes(byte[] data, int offset, int length, int x, int y)
      Overrides Graphics.drawBytes.
      void drawChars(char[] data, int offset, int length, int x, int y)
      Overrides Graphics.drawChars.
      boolean drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer)
      Overrides Graphics.drawImage.
      boolean drawImage(Image img, int x, int y, ImageObserver observer)
      Overrides Graphics.drawImage.
      boolean drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
      Overrides Graphics.drawImage.
      boolean drawImage(Image img, int x, int y, int width, int height, ImageObserver observer)
      Overrides Graphics.drawImage.
      boolean drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
      Overrides Graphics.drawImage.
      boolean drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
      Overrides Graphics.drawImage.
      void drawLine(int x1, int y1, int x2, int y2)
      Overrides Graphics.drawLine.
      void drawOval(int x, int y, int width, int height)
      Overrides Graphics.drawOval.
      void drawPolygon(int[] xPoints, int[] yPoints, int nPoints)
      Overrides Graphics.drawPolygon.
      void drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
      Overrides Graphics.drawPolyline.
      void drawRect(int x, int y, int width, int height)
      Overrides Graphics.drawRect.
      void drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
      Overrides Graphics.drawRoundRect.
      void drawString(AttributedCharacterIterator iterator, int x, int y)
      Overrides Graphics.drawString.
      void drawString(String aString, int x, int y)
      Overrides Graphics.drawString.
      void fill3DRect(int x, int y, int width, int height, boolean raised)
      Overrides Graphics.fill3DRect.
      void fillArc(int x, int y, int width, int height, int startAngle, int arcAngle)
      Overrides Graphics.fillArc.
      void fillOval(int x, int y, int width, int height)
      Overrides Graphics.fillOval.
      void fillPolygon(int[] xPoints, int[] yPoints, int nPoints)
      Overrides Graphics.fillPolygon.
      void fillRect(int x, int y, int width, int height)
      Overrides Graphics.fillRect.
      void fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
      Overrides Graphics.fillRoundRect.
      static Color flashColor()
      Returns the Color used to flash drawing operations.
      static int flashCount()
      Returns the number of times that drawing operations will flash.
      static int flashTime()
      Returns the time delay of drawing operation flashing.
      Shape getClip()
      Overrides Graphics.getClip.
      Rectangle getClipBounds()
      Overrides Graphics.getClipBounds.
      Color getColor()
      Returns the Color used for text drawing operations.
      int getDebugOptions()
      Returns the current debugging options for this DebugGraphics.
      Font getFont()
      Returns the Font used for text drawing operations.
      FontMetrics getFontMetrics()
      Overrides Graphics.getFontMetrics.
      FontMetrics getFontMetrics(Font f)
      Overrides Graphics.getFontMetrics.
      boolean isDrawingBuffer()
      Returns the drawingBuffer value.
      static PrintStream logStream()
      Returns the stream to which the DebugGraphics logs drawing operations.
      void setClip(int x, int y, int width, int height)
      Overrides Graphics.setClip.
      void setClip(Shape clip)
      Overrides Graphics.setClip.
      void setColor(Color aColor)
      Sets the color to be used for drawing and filling lines and shapes.
      void setDebugOptions(int options)
      Enables/disables diagnostic information about every graphics operation.
      static void setFlashColor(Color flashColor)
      Sets the Color used to flash drawing operations.
      static void setFlashCount(int flashCount)
      Sets the number of times that drawing operations will flash.
      static void setFlashTime(int flashTime)
      Sets the time delay of drawing operation flashing.
      void setFont(Font aFont)
      Sets the Font used for text drawing operations.
      static void setLogStream(PrintStream stream)
      Sets the stream to which the DebugGraphics logs drawing operations.
      void setPaintMode()
      Overrides Graphics.setPaintMode.
      void setXORMode(Color aColor)
      Overrides Graphics.setXORMode.
      void translate(int x, int y)
      Overrides Graphics.translate.

      • 方法 - 继承于类 java.awt.Graphics

        drawPolygon, fillPolygon, finalize, getClipBounds, getClipRect, hitClip, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LOG_OPTION

        public static final int LOG_OPTION
        Log graphics operations.
        另请参见：
        Constant Field Values

      • FLASH_OPTION

        public static final int FLASH_OPTION
        Flash graphics operations.
        另请参见：
        Constant Field Values

      • BUFFERED_OPTION

        public static final int BUFFERED_OPTION
        Show buffered operations in a separate Frame.
        另请参见：
        Constant Field Values

      • NONE_OPTION

        public static final int NONE_OPTION
        Don't debug graphics operations.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DebugGraphics

        public DebugGraphics()
        Constructs a new debug graphics context that supports slowed down drawing.

      • DebugGraphics

        public DebugGraphics(Graphics graphics,
             JComponent component)
        Constructs a debug graphics context from an existing graphics context that slows down drawing for the specified component.
        参数：
        graphics - the Graphics context to slow down
        component - the JComponent to draw slowly

      • DebugGraphics

        public DebugGraphics(Graphics graphics)
        Constructs a debug graphics context from an existing graphics context that supports slowed down drawing.
        参数：
        graphics - the Graphics context to slow down

    • 方法详细信息

      • create

        public Graphics create()
        Overrides Graphics.create to return a DebugGraphics object.
        指定者：
        create in class Graphics
        返回：
        a new graphics context that is a copy of this graphics context.

      • create

        public Graphics create(int x,
              int y,
              int width,
              int height)
        Overrides Graphics.create to return a DebugGraphics object.
        重载：
        create in class Graphics
        参数：
        x - the x coordinate.
        y - the y coordinate.
        width - the width of the clipping rectangle.
        height - the height of the clipping rectangle.
        返回：
        a new graphics context.
        另请参见：
        Graphics.translate(int, int), Graphics.clipRect(int, int, int, int)

      • setFlashColor

        public static void setFlashColor(Color flashColor)
        Sets the Color used to flash drawing operations.

      • flashColor

        public static Color flashColor()
        Returns the Color used to flash drawing operations.
        另请参见：
        setFlashColor(java.awt.Color)

      • setFlashTime

        public static void setFlashTime(int flashTime)
        Sets the time delay of drawing operation flashing.

      • flashTime

        public static int flashTime()
        Returns the time delay of drawing operation flashing.
        另请参见：
        setFlashTime(int)

      • setFlashCount

        public static void setFlashCount(int flashCount)
        Sets the number of times that drawing operations will flash.

      • flashCount

        public static int flashCount()
        Returns the number of times that drawing operations will flash.
        另请参见：
        setFlashCount(int)

      • setLogStream

        public static void setLogStream(PrintStream stream)
        Sets the stream to which the DebugGraphics logs drawing operations.

      • logStream

        public static PrintStream logStream()
        Returns the stream to which the DebugGraphics logs drawing operations.
        另请参见：
        setLogStream(java.io.PrintStream)

      • setFont

        public void setFont(Font aFont)
        Sets the Font used for text drawing operations.
        指定者：
        setFont in class Graphics
        参数：
        aFont - the font.
        另请参见：
        Graphics.getFont(),
Graphics.drawString(java.lang.String, int, int),
Graphics.drawBytes(byte[], int, int, int, int),
Graphics.drawChars(char[], int, int, int, int)

      • getFont

        public Font getFont()
        Returns the Font used for text drawing operations.
        指定者：
        getFont in class Graphics
        返回：
        this graphics context's current font.
        另请参见：
        setFont(java.awt.Font)

      • setColor

        public void setColor(Color aColor)
        Sets the color to be used for drawing and filling lines and shapes.
        指定者：
        setColor in class Graphics
        参数：
        aColor - the new rendering color.
        另请参见：
        Color, Graphics.getColor()

      • getColor

        public Color getColor()
        Returns the Color used for text drawing operations.
        指定者：
        getColor in class Graphics
        返回：
        this graphics context's current color.
        另请参见：
        setColor(java.awt.Color)

      • getFontMetrics

        public FontMetrics getFontMetrics()
        Overrides Graphics.getFontMetrics.
        重载：
        getFontMetrics in class Graphics
        返回：
        the font metrics of this graphics context's current font.
        另请参见：
        Graphics.getFont(), FontMetrics, Graphics.getFontMetrics(Font)

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        Overrides Graphics.getFontMetrics.
        指定者：
        getFontMetrics in class Graphics
        参数：
        f - the specified font
        返回：
        the font metrics for the specified font.
        另请参见：
        Graphics.getFont(), FontMetrics, Graphics.getFontMetrics()

      • translate

        public void translate(int x,
             int y)
        Overrides Graphics.translate.
        指定者：
        translate in class Graphics
        参数：
        x - the x coordinate.
        y - the y coordinate.

      • setPaintMode

        public void setPaintMode()
        Overrides Graphics.setPaintMode.
        指定者：
        setPaintMode in class Graphics

      • setXORMode

        public void setXORMode(Color aColor)
        Overrides Graphics.setXORMode.
        指定者：
        setXORMode in class Graphics
        参数：
        aColor - the XOR alternation color

      • getClipBounds

        public Rectangle getClipBounds()
        Overrides Graphics.getClipBounds.
        指定者：
        getClipBounds in class Graphics
        返回：
        the bounding rectangle of the current clipping area, or null if no clip is set.
        另请参见：
        Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

      • clipRect

        public void clipRect(int x,
            int y,
            int width,
            int height)
        Overrides Graphics.clipRect.
        指定者：
        clipRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to intersect the clip with
        y - the y coordinate of the rectangle to intersect the clip with
        width - the width of the rectangle to intersect the clip with
        height - the height of the rectangle to intersect the clip with
        另请参见：
        Graphics.setClip(int, int, int, int), Graphics.setClip(Shape)

      • setClip

        public void setClip(int x,
           int y,
           int width,
           int height)
        Overrides Graphics.setClip.
        指定者：
        setClip in class Graphics
        参数：
        x - the x coordinate of the new clip rectangle.
        y - the y coordinate of the new clip rectangle.
        width - the width of the new clip rectangle.
        height - the height of the new clip rectangle.
        另请参见：
        Graphics.clipRect(int, int, int, int),
Graphics.setClip(Shape),
Graphics.getClip()

      • getClip

        public Shape getClip()
        Overrides Graphics.getClip.
        指定者：
        getClip in class Graphics
        返回：
        a Shape object representing the current clipping area, or null if no clip is set.
        另请参见：
        Graphics.getClipBounds(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

      • setClip

        public void setClip(Shape clip)
        Overrides Graphics.setClip.
        指定者：
        setClip in class Graphics
        参数：
        clip - the Shape to use to set the clip
        另请参见：
        Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int)

      • drawRect

        public void drawRect(int x,
            int y,
            int width,
            int height)
        Overrides Graphics.drawRect.
        重载：
        drawRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be drawn.
        y - the y coordinate of the rectangle to be drawn.
        width - the width of the rectangle to be drawn.
        height - the height of the rectangle to be drawn.
        另请参见：
        Graphics.fillRect(int, int, int, int), Graphics.clearRect(int, int, int, int)

      • fillRect

        public void fillRect(int x,
            int y,
            int width,
            int height)
        Overrides Graphics.fillRect.
        指定者：
        fillRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be filled.
        y - the y coordinate of the rectangle to be filled.
        width - the width of the rectangle to be filled.
        height - the height of the rectangle to be filled.
        另请参见：
        Graphics.clearRect(int, int, int, int), Graphics.drawRect(int, int, int, int)

      • clearRect

        public void clearRect(int x,
             int y,
             int width,
             int height)
        Overrides Graphics.clearRect.
        指定者：
        clearRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to clear.
        y - the y coordinate of the rectangle to clear.
        width - the width of the rectangle to clear.
        height - the height of the rectangle to clear.
        另请参见：
        Graphics.fillRect(int, int, int, int),
Graphics.drawRect(int, int, int, int),
Graphics.setColor(java.awt.Color),
Graphics.setPaintMode(),
Graphics.setXORMode(java.awt.Color)

      • drawRoundRect

        public void drawRoundRect(int x,
                 int y,
                 int width,
                 int height,
                 int arcWidth,
                 int arcHeight)
        Overrides Graphics.drawRoundRect.
        指定者：
        drawRoundRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be drawn.
        y - the y coordinate of the rectangle to be drawn.
        width - the width of the rectangle to be drawn.
        height - the height of the rectangle to be drawn.
        arcWidth - the horizontal diameter of the arc at the four corners.
        arcHeight - the vertical diameter of the arc at the four corners.
        另请参见：
        Graphics.fillRoundRect(int, int, int, int, int, int)

      • fillRoundRect

        public void fillRoundRect(int x,
                 int y,
                 int width,
                 int height,
                 int arcWidth,
                 int arcHeight)
        Overrides Graphics.fillRoundRect.
        指定者：
        fillRoundRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be filled.
        y - the y coordinate of the rectangle to be filled.
        width - the width of the rectangle to be filled.
        height - the height of the rectangle to be filled.
        arcWidth - the horizontal diameter of the arc at the four corners.
        arcHeight - the vertical diameter of the arc at the four corners.
        另请参见：
        Graphics.drawRoundRect(int, int, int, int, int, int)

      • drawLine

        public void drawLine(int x1,
            int y1,
            int x2,
            int y2)
        Overrides Graphics.drawLine.
        指定者：
        drawLine in class Graphics
        参数：
        x1 - the first point's x coordinate.
        y1 - the first point's y coordinate.
        x2 - the second point's x coordinate.
        y2 - the second point's y coordinate.

      • draw3DRect

        public void draw3DRect(int x,
              int y,
              int width,
              int height,
              boolean raised)
        Overrides Graphics.draw3DRect.
        重载：
        draw3DRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be drawn.
        y - the y coordinate of the rectangle to be drawn.
        width - the width of the rectangle to be drawn.
        height - the height of the rectangle to be drawn.
        raised - a boolean that determines whether the rectangle appears to be raised above the surface or sunk into the surface.
        另请参见：
        Graphics.fill3DRect(int, int, int, int, boolean)

      • fill3DRect

        public void fill3DRect(int x,
              int y,
              int width,
              int height,
              boolean raised)
        Overrides Graphics.fill3DRect.
        重载：
        fill3DRect in class Graphics
        参数：
        x - the x coordinate of the rectangle to be filled.
        y - the y coordinate of the rectangle to be filled.
        width - the width of the rectangle to be filled.
        height - the height of the rectangle to be filled.
        raised - a boolean value that determines whether the rectangle appears to be raised above the surface or etched into the surface.
        另请参见：
        Graphics.draw3DRect(int, int, int, int, boolean)

      • drawOval

        public void drawOval(int x,
            int y,
            int width,
            int height)
        Overrides Graphics.drawOval.
        指定者：
        drawOval in class Graphics
        参数：
        x - the x coordinate of the upper left corner of the oval to be drawn.
        y - the y coordinate of the upper left corner of the oval to be drawn.
        width - the width of the oval to be drawn.
        height - the height of the oval to be drawn.
        另请参见：
        Graphics.fillOval(int, int, int, int)

      • fillOval

        public void fillOval(int x,
            int y,
            int width,
            int height)
        Overrides Graphics.fillOval.
        指定者：
        fillOval in class Graphics
        参数：
        x - the x coordinate of the upper left corner of the oval to be filled.
        y - the y coordinate of the upper left corner of the oval to be filled.
        width - the width of the oval to be filled.
        height - the height of the oval to be filled.
        另请参见：
        Graphics.drawOval(int, int, int, int)

      • drawArc

        public void drawArc(int x,
           int y,
           int width,
           int height,
           int startAngle,
           int arcAngle)
        Overrides Graphics.drawArc.
        指定者：
        drawArc in class Graphics
        参数：
        x - the x coordinate of the upper-left corner of the arc to be drawn.
        y - the y coordinate of the upper-left corner of the arc to be drawn.
        width - the width of the arc to be drawn.
        height - the height of the arc to be drawn.
        startAngle - the beginning angle.
        arcAngle - the angular extent of the arc, relative to the start angle.
        另请参见：
        Graphics.fillArc(int, int, int, int, int, int)

      • fillArc

        public void fillArc(int x,
           int y,
           int width,
           int height,
           int startAngle,
           int arcAngle)
        Overrides Graphics.fillArc.
        指定者：
        fillArc in class Graphics
        参数：
        x - the x coordinate of the upper-left corner of the arc to be filled.
        y - the y coordinate of the upper-left corner of the arc to be filled.
        width - the width of the arc to be filled.
        height - the height of the arc to be filled.
        startAngle - the beginning angle.
        arcAngle - the angular extent of the arc, relative to the start angle.
        另请参见：
        Graphics.drawArc(int, int, int, int, int, int)

      • drawPolyline

        public void drawPolyline(int[] xPoints,
                int[] yPoints,
                int nPoints)
        Overrides Graphics.drawPolyline.
        指定者：
        drawPolyline in class Graphics
        参数：
        xPoints - an array of x points
        yPoints - an array of y points
        nPoints - the total number of points
        另请参见：
        Graphics.drawPolygon(int[], int[], int)

      • drawPolygon

        public void drawPolygon(int[] xPoints,
               int[] yPoints,
               int nPoints)
        Overrides Graphics.drawPolygon.
        指定者：
        drawPolygon in class Graphics
        参数：
        xPoints - a an array of x coordinates.
        yPoints - a an array of y coordinates.
        nPoints - a the total number of points.
        另请参见：
        Graphics.fillPolygon(int[], int[], int), Graphics.drawPolyline(int[], int[], int)

      • fillPolygon

        public void fillPolygon(int[] xPoints,
               int[] yPoints,
               int nPoints)
        Overrides Graphics.fillPolygon.
        指定者：
        fillPolygon in class Graphics
        参数：
        xPoints - a an array of x coordinates.
        yPoints - a an array of y coordinates.
        nPoints - a the total number of points.
        另请参见：
        Graphics.drawPolygon(int[], int[], int)

      • drawString

        public void drawString(String aString,
              int x,
              int y)
        Overrides Graphics.drawString.
        指定者：
        drawString in class Graphics
        参数：
        aString - the string to be drawn.
        x - the x coordinate.
        y - the y coordinate.
        另请参见：
        Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

      • drawString

        public void drawString(AttributedCharacterIterator iterator,
              int x,
              int y)
        Overrides Graphics.drawString.
        指定者：
        drawString in class Graphics
        参数：
        iterator - the iterator whose text is to be drawn
        x - the x coordinate.
        y - the y coordinate.
        另请参见：
        Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

      • drawBytes

        public void drawBytes(byte[] data,
             int offset,
             int length,
             int x,
             int y)
        Overrides Graphics.drawBytes.
        重载：
        drawBytes in class Graphics
        参数：
        data - the data to be drawn
        offset - the start offset in the data
        length - the number of bytes that are drawn
        x - the x coordinate of the baseline of the text
        y - the y coordinate of the baseline of the text
        另请参见：
        Graphics.drawChars(char[], int, int, int, int), Graphics.drawString(java.lang.String, int, int)

      • drawChars

        public void drawChars(char[] data,
             int offset,
             int length,
             int x,
             int y)
        Overrides Graphics.drawChars.
        重载：
        drawChars in class Graphics
        参数：
        data - the array of characters to be drawn
        offset - the start offset in the data
        length - the number of characters to be drawn
        x - the x coordinate of the baseline of the text
        y - the y coordinate of the baseline of the text
        另请参见：
        Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawString(java.lang.String, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int x,
                int y,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        x - the x coordinate.
        y - the y coordinate.
        observer - object to be notified as more of the image is converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int x,
                int y,
                int width,
                int height,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        x - the x coordinate.
        y - the y coordinate.
        width - the width of the rectangle.
        height - the height of the rectangle.
        observer - object to be notified as more of the image is converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int x,
                int y,
                Color bgcolor,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        x - the x coordinate.
        y - the y coordinate.
        bgcolor - the background color to paint under the non-opaque portions of the image.
        observer - object to be notified as more of the image is converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int x,
                int y,
                int width,
                int height,
                Color bgcolor,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        x - the x coordinate.
        y - the y coordinate.
        width - the width of the rectangle.
        height - the height of the rectangle.
        bgcolor - the background color to paint under the non-opaque portions of the image.
        observer - object to be notified as more of the image is converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int dx1,
                int dy1,
                int dx2,
                int dy2,
                int sx1,
                int sy1,
                int sx2,
                int sy2,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        dx1 - the x coordinate of the first corner of the destination rectangle.
        dy1 - the y coordinate of the first corner of the destination rectangle.
        dx2 - the x coordinate of the second corner of the destination rectangle.
        dy2 - the y coordinate of the second corner of the destination rectangle.
        sx1 - the x coordinate of the first corner of the source rectangle.
        sy1 - the y coordinate of the first corner of the source rectangle.
        sx2 - the x coordinate of the second corner of the source rectangle.
        sy2 - the y coordinate of the second corner of the source rectangle.
        observer - object to be notified as more of the image is scaled and converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • drawImage

        public boolean drawImage(Image img,
                int dx1,
                int dy1,
                int dx2,
                int dy2,
                int sx1,
                int sy1,
                int sx2,
                int sy2,
                Color bgcolor,
                ImageObserver observer)
        Overrides Graphics.drawImage.
        指定者：
        drawImage in class Graphics
        参数：
        img - the specified image to be drawn. This method does nothing if img is null.
        dx1 - the x coordinate of the first corner of the destination rectangle.
        dy1 - the y coordinate of the first corner of the destination rectangle.
        dx2 - the x coordinate of the second corner of the destination rectangle.
        dy2 - the y coordinate of the second corner of the destination rectangle.
        sx1 - the x coordinate of the first corner of the source rectangle.
        sy1 - the y coordinate of the first corner of the source rectangle.
        sx2 - the x coordinate of the second corner of the source rectangle.
        sy2 - the y coordinate of the second corner of the source rectangle.
        bgcolor - the background color to paint under the non-opaque portions of the image.
        observer - object to be notified as more of the image is scaled and converted.
        返回：
        false if the image pixels are still changing; true otherwise.
        另请参见：
        Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • copyArea

        public void copyArea(int x,
            int y,
            int width,
            int height,
            int destX,
            int destY)
        Overrides Graphics.copyArea.
        指定者：
        copyArea in class Graphics
        参数：
        x - the x coordinate of the source rectangle.
        y - the y coordinate of the source rectangle.
        width - the width of the source rectangle.
        height - the height of the source rectangle.
        destX - the horizontal distance to copy the pixels.
        destY - the vertical distance to copy the pixels.

      • dispose

        public void dispose()
        Overrides Graphics.dispose.
        指定者：
        dispose in class Graphics
        另请参见：
        Graphics.finalize(),
Component.paint(java.awt.Graphics),
Component.update(java.awt.Graphics),
Component.getGraphics(),
Graphics.create()

      • isDrawingBuffer

        public boolean isDrawingBuffer()
        Returns the drawingBuffer value.
        返回：
        true if this object is drawing from a Buffer

      • setDebugOptions

        public void setDebugOptions(int options)
        Enables/disables diagnostic information about every graphics operation. The value of options indicates how this information should be displayed. LOG_OPTION causes a text message to be printed. FLASH_OPTION causes the drawing to flash several times. BUFFERED_OPTION creates a new Frame that shows each operation on an offscreen buffer. The value of options is bitwise OR'd into the current value. To disable debugging use NONE_OPTION.

      • getDebugOptions

        public int getDebugOptions()
        Returns the current debugging options for this DebugGraphics.
        另请参见：
        setDebugOptions(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultBoundedRangeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultBoundedRangeModel

  • java.lang.Object
    • javax.swing.DefaultBoundedRangeModel
  • 所有已实现的接口：
    Serializable, BoundedRangeModel

    public class DefaultBoundedRangeModel
extends Object
implements BoundedRangeModel, Serializable
    A generic implementation of BoundedRangeModel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BoundedRangeModel

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
      protected EventListenerList listenerList
      The listeners waiting for model changes.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultBoundedRangeModel()
      Initializes all of the properties with default values.
      DefaultBoundedRangeModel(int value, int extent, int min, int max)
      Initializes value, extent, minimum and maximum.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener.
      protected void fireStateChanged()
      Runs each ChangeListener's stateChanged method.
      ChangeListener[] getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultBoundedRangeModel.
      int getExtent()
      Returns the model's extent.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getMaximum()
      Returns the model's maximum.
      int getMinimum()
      Returns the model's minimum.
      int getValue()
      Returns the model's current value.
      boolean getValueIsAdjusting()
      Returns true if the value is in the process of changing as a result of actions being taken by the user.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener.
      void setExtent(int n)
      Sets the extent to n after ensuring that n is greater than or equal to zero and falls within the model's constraints:
      void setMaximum(int n)
      Sets the maximum to n after ensuring that n that the other three properties obey the model's constraints:
      void setMinimum(int n)
      Sets the minimum to n after ensuring that n that the other three properties obey the model's constraints:
      void setRangeProperties(int newValue, int newExtent, int newMin, int newMax, boolean adjusting)
      Sets all of the BoundedRangeModel properties after forcing the arguments to obey the usual constraints:
      void setValue(int n)
      Sets the current value of the model.
      void setValueIsAdjusting(boolean b)
      Sets the valueIsAdjusting property.
      String toString()
      Returns a string that displays all of the BoundedRangeModel properties.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property. The source of events generated here is always "this".

      • listenerList

        protected EventListenerList listenerList
        The listeners waiting for model changes.

    • 构造方法详细信息

      • DefaultBoundedRangeModel

        public DefaultBoundedRangeModel()
        Initializes all of the properties with default values. Those values are:
        • value = 0
        • extent = 0
        • minimum = 0
        • maximum = 100
        • adjusting = false

      • DefaultBoundedRangeModel

        public DefaultBoundedRangeModel(int value,
                        int extent,
                        int min,
                        int max)
        Initializes value, extent, minimum and maximum. Adjusting is false. Throws an IllegalArgumentException if the following constraints aren't satisfied:
         min <= value <= value+extent <= max

    • 方法详细信息

      • getValue

        public int getValue()
        Returns the model's current value.
        指定者：
        getValue in interface BoundedRangeModel
        返回：
        the model's current value
        另请参见：
        setValue(int), BoundedRangeModel.getValue()

      • getExtent

        public int getExtent()
        Returns the model's extent.
        指定者：
        getExtent in interface BoundedRangeModel
        返回：
        the model's extent
        另请参见：
        setExtent(int), BoundedRangeModel.getExtent()

      • getMinimum

        public int getMinimum()
        Returns the model's minimum.
        指定者：
        getMinimum in interface BoundedRangeModel
        返回：
        the model's minimum
        另请参见：
        setMinimum(int), BoundedRangeModel.getMinimum()

      • getMaximum

        public int getMaximum()
        Returns the model's maximum.
        指定者：
        getMaximum in interface BoundedRangeModel
        返回：
        the model's maximum
        另请参见：
        setMaximum(int), BoundedRangeModel.getMaximum()

      • setValue

        public void setValue(int n)
        Sets the current value of the model. For a slider, that determines where the knob appears. Ensures that the new value, n falls within the model's constraints:
             minimum <= value <= value+extent <= maximum
        指定者：
        setValue in interface BoundedRangeModel
        参数：
        n - the model's new value
        另请参见：
        BoundedRangeModel.setValue(int)

      • setExtent

        public void setExtent(int n)
        Sets the extent to n after ensuring that n is greater than or equal to zero and falls within the model's constraints:
             minimum <= value <= value+extent <= maximum
        指定者：
        setExtent in interface BoundedRangeModel
        参数：
        n - the model's new extent
        另请参见：
        BoundedRangeModel.setExtent(int)

      • setMinimum

        public void setMinimum(int n)
        Sets the minimum to n after ensuring that n that the other three properties obey the model's constraints:
             minimum <= value <= value+extent <= maximum
        指定者：
        setMinimum in interface BoundedRangeModel
        参数：
        n - the model's new minimum
        另请参见：
        getMinimum(), BoundedRangeModel.setMinimum(int)

      • setMaximum

        public void setMaximum(int n)
        Sets the maximum to n after ensuring that n that the other three properties obey the model's constraints:
             minimum <= value <= value+extent <= maximum
        指定者：
        setMaximum in interface BoundedRangeModel
        参数：
        n - the model's new maximum
        另请参见：
        BoundedRangeModel.setMaximum(int)

      • setValueIsAdjusting

        public void setValueIsAdjusting(boolean b)
        Sets the valueIsAdjusting property.
        指定者：
        setValueIsAdjusting in interface BoundedRangeModel
        参数：
        b - true if the upcoming changes to the value property are part of a series
        另请参见：
        getValueIsAdjusting(), setValue(int), BoundedRangeModel.setValueIsAdjusting(boolean)

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        Returns true if the value is in the process of changing as a result of actions being taken by the user.
        指定者：
        getValueIsAdjusting in interface BoundedRangeModel
        返回：
        the value of the valueIsAdjusting property
        另请参见：
        setValue(int), BoundedRangeModel.getValueIsAdjusting()

      • setRangeProperties

        public void setRangeProperties(int newValue,
                      int newExtent,
                      int newMin,
                      int newMax,
                      boolean adjusting)
        Sets all of the BoundedRangeModel properties after forcing the arguments to obey the usual constraints:
             minimum <= value <= value+extent <= maximum

        At most, one ChangeEvent is generated.

        指定者：
        setRangeProperties in interface BoundedRangeModel
        参数：
        newValue - an int giving the current value
        newExtent - an int giving the amount by which the value can "jump"
        newMin - an int giving the minimum value
        newMax - an int giving the maximum value
        adjusting - a boolean, true if a series of changes are in progress
        另请参见：
        BoundedRangeModel.setRangeProperties(int, int, int, int, boolean), setValue(int), setExtent(int), setMinimum(int), setMaximum(int), setValueIsAdjusting(boolean)

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener. The change listeners are run each time any one of the Bounded Range model properties changes.
        指定者：
        addChangeListener in interface BoundedRangeModel
        参数：
        l - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener), BoundedRangeModel.addChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener.
        指定者：
        removeChangeListener in interface BoundedRangeModel
        参数：
        l - the ChangeListener to remove
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), BoundedRangeModel.removeChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the change listeners registered on this DefaultBoundedRangeModel.
        返回：
        all of this model's ChangeListeners or an empty array if no change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

      • fireStateChanged

        protected void fireStateChanged()
        Runs each ChangeListener's stateChanged method.
        另请参见：
        setRangeProperties(int, int, int, int, boolean), EventListenerList

      • toString

        public String toString()
        Returns a string that displays all of the BoundedRangeModel properties.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultBoundedRangeModel instance m for its change listeners with the following code:

        ChangeListener[] cls = (ChangeListener[])(m.getListeners(ChangeListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getChangeListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sitrh>o4>olrrolla>== >iafooC"o>aCC lkdseros<


DefaultButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultButtonModel

  • java.lang.Object
    • javax.swing.DefaultButtonModel
  • 所有已实现的接口：
    ItemSelectable, Serializable, ButtonModel
    直接已知子类：
    JToggleButton.ToggleButtonModel

    public class DefaultButtonModel
extends Object
implements ButtonModel, Serializable
    The default implementation of a Button component's data model.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected String actionCommand
      The action command string fired by the button.
      static int ARMED
      Identifies the "armed" bit in the bitmask, which indicates partial commitment towards choosing/triggering the button.
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
      static int ENABLED
      Identifies the "enabled" bit in the bitmask, which indicates that the button can be selected by an input device (such as a mouse pointer).
      protected ButtonGroup group
      The button group that the button belongs to.
      protected EventListenerList listenerList
      Stores the listeners on this model.
      protected int mnemonic
      The button's mnemonic.
      static int PRESSED
      Identifies the "pressed" bit in the bitmask, which indicates that the button is pressed.
      static int ROLLOVER
      Identifies the "rollover" bit in the bitmask, which indicates that the mouse is over the button.
      static int SELECTED
      Identifies the "selected" bit in the bitmask, which indicates that the button has been selected.
      protected int stateMask
      The bitmask used to store the state of the button.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultButtonModel()
      Constructs a DefaultButtonModel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionListener(ActionListener l)
      Adds an ActionListener to the model.
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      void addItemListener(ItemListener l)
      Adds an ItemListener to the model.
      protected void fireActionPerformed(ActionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireItemStateChanged(ItemEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      String getActionCommand()
      Returns the action command string for the button.
      ActionListener[] getActionListeners()
      Returns an array of all the action listeners registered on this DefaultButtonModel.
      ChangeListener[] getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultButtonModel.
      ButtonGroup getGroup()
      Returns the group that the button belongs to.
      ItemListener[] getItemListeners()
      Returns an array of all the item listeners registered on this DefaultButtonModel.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getMnemonic()
      Gets the keyboard mnemonic for the button.
      Object[] getSelectedObjects()
      Overridden to return null.
      boolean isArmed()
      Indicates partial commitment towards triggering the button.
      boolean isEnabled()
      Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
      boolean isPressed()
      Indicates if the button is pressed.
      boolean isRollover()
      Indicates that the mouse is over the button.
      boolean isSelected()
      Indicates if the button has been selected.
      void removeActionListener(ActionListener l)
      Removes an ActionListener from the model.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void removeItemListener(ItemListener l)
      Removes an ItemListener from the model.
      void setActionCommand(String actionCommand)
      Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.
      void setArmed(boolean b)
      Marks the button as armed or unarmed.
      void setEnabled(boolean b)
      Enables or disables the button.
      void setGroup(ButtonGroup group)
      Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
      void setMnemonic(int key)
      Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.
      void setPressed(boolean b)
      Sets the button to pressed or unpressed.
      void setRollover(boolean b)
      Sets or clears the button's rollover state
      void setSelected(boolean b)
      Selects or deselects the button.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • stateMask

        protected int stateMask
        The bitmask used to store the state of the button.

      • actionCommand

        protected String actionCommand
        The action command string fired by the button.

      • group

        protected ButtonGroup group
        The button group that the button belongs to.

      • mnemonic

        protected int mnemonic
        The button's mnemonic.

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per button model instance since the event's only state is the source property. The source of events generated is always "this".

      • listenerList

        protected EventListenerList listenerList
        Stores the listeners on this model.

      • ARMED

        public static final int ARMED
        Identifies the "armed" bit in the bitmask, which indicates partial commitment towards choosing/triggering the button.
        另请参见：
        Constant Field Values

      • SELECTED

        public static final int SELECTED
        Identifies the "selected" bit in the bitmask, which indicates that the button has been selected. Only needed for certain types of buttons - such as radio button or check box.
        另请参见：
        Constant Field Values

      • PRESSED

        public static final int PRESSED
        Identifies the "pressed" bit in the bitmask, which indicates that the button is pressed.
        另请参见：
        Constant Field Values

      • ENABLED

        public static final int ENABLED
        Identifies the "enabled" bit in the bitmask, which indicates that the button can be selected by an input device (such as a mouse pointer).
        另请参见：
        Constant Field Values

      • ROLLOVER

        public static final int ROLLOVER
        Identifies the "rollover" bit in the bitmask, which indicates that the mouse is over the button.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DefaultButtonModel

        public DefaultButtonModel()
        Constructs a DefaultButtonModel.

    • 方法详细信息

      • setActionCommand

        public void setActionCommand(String actionCommand)
        Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.
        指定者：
        setActionCommand in interface ButtonModel
        参数：
        actionCommand - the String that identifies the generated event
        另请参见：
        ButtonModel.getActionCommand(), ActionEvent.getActionCommand()

      • getActionCommand

        public String getActionCommand()
        Returns the action command string for the button.
        指定者：
        getActionCommand in interface ButtonModel
        返回：
        the String that identifies the generated event
        另请参见：
        ButtonModel.setActionCommand(java.lang.String)

      • isArmed

        public boolean isArmed()
        Indicates partial commitment towards triggering the button.
        指定者：
        isArmed in interface ButtonModel
        返回：
        true if the button is armed, and ready to be triggered
        另请参见：
        ButtonModel.setArmed(boolean)

      • isSelected

        public boolean isSelected()
        Indicates if the button has been selected. Only needed for certain types of buttons - such as radio buttons and check boxes.
        指定者：
        isSelected in interface ButtonModel
        返回：
        true if the button is selected

      • isEnabled

        public boolean isEnabled()
        Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
        指定者：
        isEnabled in interface ButtonModel
        返回：
        true if the button is enabled

      • isPressed

        public boolean isPressed()
        Indicates if the button is pressed.
        指定者：
        isPressed in interface ButtonModel
        返回：
        true if the button is pressed

      • isRollover

        public boolean isRollover()
        Indicates that the mouse is over the button.
        指定者：
        isRollover in interface ButtonModel
        返回：
        true if the mouse is over the button

      • setArmed

        public void setArmed(boolean b)
        Marks the button as armed or unarmed.
        指定者：
        setArmed in interface ButtonModel
        参数：
        b - whether or not the button should be armed

      • setEnabled

        public void setEnabled(boolean b)
        Enables or disables the button.
        指定者：
        setEnabled in interface ButtonModel
        参数：
        b - whether or not the button should be enabled
        另请参见：
        ButtonModel.isEnabled()

      • setSelected

        public void setSelected(boolean b)
        Selects or deselects the button.
        指定者：
        setSelected in interface ButtonModel
        参数：
        b - true selects the button, false deselects the button

      • setPressed

        public void setPressed(boolean b)
        Sets the button to pressed or unpressed.
        指定者：
        setPressed in interface ButtonModel
        参数：
        b - whether or not the button should be pressed
        另请参见：
        ButtonModel.isPressed()

      • setRollover

        public void setRollover(boolean b)
        Sets or clears the button's rollover state
        指定者：
        setRollover in interface ButtonModel
        参数：
        b - whether or not the button is in the rollover state
        另请参见：
        ButtonModel.isRollover()

      • setMnemonic

        public void setMnemonic(int key)
        Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.
        指定者：
        setMnemonic in interface ButtonModel
        参数：
        key - an int specifying the accelerator key

      • getMnemonic

        public int getMnemonic()
        Gets the keyboard mnemonic for the button.
        指定者：
        getMnemonic in interface ButtonModel
        返回：
        an int specifying the accelerator key
        另请参见：
        ButtonModel.setMnemonic(int)

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the model.
        指定者：
        addChangeListener in interface ButtonModel
        参数：
        l - the listener to add

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the model.
        指定者：
        removeChangeListener in interface ButtonModel
        参数：
        l - the listener to remove

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the change listeners registered on this DefaultButtonModel.
        返回：
        all of this model's ChangeListeners or an empty array if no change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        另请参见：
        EventListenerList

      • addActionListener

        public void addActionListener(ActionListener l)
        Adds an ActionListener to the model.
        指定者：
        addActionListener in interface ButtonModel
        参数：
        l - the listener to add

      • removeActionListener

        public void removeActionListener(ActionListener l)
        Removes an ActionListener from the model.
        指定者：
        removeActionListener in interface ButtonModel
        参数：
        l - the listener to remove

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the action listeners registered on this DefaultButtonModel.
        返回：
        all of this model's ActionListeners or an empty array if no action listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

      • fireActionPerformed

        protected void fireActionPerformed(ActionEvent e)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        e - the ActionEvent to deliver to listeners
        另请参见：
        EventListenerList

      • addItemListener

        public void addItemListener(ItemListener l)
        Adds an ItemListener to the model.
        指定者：
        addItemListener in interface ItemSelectable
        指定者：
        addItemListener in interface ButtonModel
        参数：
        l - the listener to add
        另请参见：
        ItemEvent

      • removeItemListener

        public void removeItemListener(ItemListener l)
        Removes an ItemListener from the model.
        指定者：
        removeItemListener in interface ItemSelectable
        指定者：
        removeItemListener in interface ButtonModel
        参数：
        l - the listener to remove
        另请参见：
        ItemEvent

      • getItemListeners

        public ItemListener[] getItemListeners()
        Returns an array of all the item listeners registered on this DefaultButtonModel.
        返回：
        all of this model's ItemListeners or an empty array if no item listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener)

      • fireItemStateChanged

        protected void fireItemStateChanged(ItemEvent e)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        e - the ItemEvent to deliver to listeners
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultButtonModel instance m for its action listeners with the following code:

        ActionListener[] als = (ActionListener[])(m.getListeners(ActionListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getActionListeners(),
getChangeListeners(),
getItemListeners()

      • getSelectedObjects

        public Object[] getSelectedObjects()
        Overridden to return null.
        指定者：
        getSelectedObjects in interface ItemSelectable

      • setGroup

        public void setGroup(ButtonGroup group)
        Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
        指定者：
        setGroup in interface ButtonModel
        参数：
        group - the ButtonGroup the button belongs to

      • getGroup

        public ButtonGroup getGroup()
        Returns the group that the button belongs to. Normally used with radio buttons, which are mutually exclusive within their group.
        返回：
        the ButtonGroup that the button belongs to
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultCellEditor

  • java.lang.Object
    • javax.swing.AbstractCellEditor
      • javax.swing.DefaultCellEditor
  • 所有已实现的接口：
    Serializable, CellEditor, TableCellEditor, TreeCellEditor

    public class DefaultCellEditor
extends AbstractCellEditor
implements TableCellEditor, TreeCellEditor
    The default editor for table and tree cells.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  DefaultCellEditor.EditorDelegate
      The protected EditorDelegate class.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int clickCountToStart
      An integer specifying the number of clicks needed to start editing.
      protected DefaultCellEditor.EditorDelegate delegate
      The delegate class which handles all methods sent from the CellEditor.
      protected JComponent editorComponent
      The Swing component being edited.

      • Fields inherited from class javax.swing.AbstractCellEditor

        changeEvent, listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultCellEditor(JCheckBox checkBox)
      Constructs a DefaultCellEditor object that uses a check box.
      DefaultCellEditor(JComboBox comboBox)
      Constructs a DefaultCellEditor object that uses a combo box.
      DefaultCellEditor(JTextField textField)
      Constructs a DefaultCellEditor that uses a text field.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void cancelCellEditing()
      Forwards the message from the CellEditor to the delegate.
      Object getCellEditorValue()
      Forwards the message from the CellEditor to the delegate.
      int getClickCountToStart()
      Returns the number of clicks needed to start editing.
      Component getComponent()
      Returns a reference to the editor component.
      Component getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
      Implements the TableCellEditor interface.
      Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Implements the TreeCellEditor interface.
      boolean isCellEditable(EventObject anEvent)
      Forwards the message from the CellEditor to the delegate.
      void setClickCountToStart(int count)
      Specifies the number of clicks needed to start editing.
      boolean shouldSelectCell(EventObject anEvent)
      Forwards the message from the CellEditor to the delegate.
      boolean stopCellEditing()
      Forwards the message from the CellEditor to the delegate.

      • 方法 - 继承于类 javax.swing.AbstractCellEditor

        addCellEditorListener, fireEditingCanceled, fireEditingStopped, getCellEditorListeners, removeCellEditorListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.CellEditor

        addCellEditorListener, removeCellEditorListener

    • 字段详细信息

      • editorComponent

        protected JComponent editorComponent
        The Swing component being edited.

      • delegate

        protected DefaultCellEditor.EditorDelegate delegate
        The delegate class which handles all methods sent from the CellEditor.

      • clickCountToStart

        protected int clickCountToStart
        An integer specifying the number of clicks needed to start editing. Even if clickCountToStart is defined as zero, it will not initiate until a click occurs.

    • 构造方法详细信息

      • DefaultCellEditor

        @ConstructorProperties(value="component")
public DefaultCellEditor(JTextField textField)
        Constructs a DefaultCellEditor that uses a text field.
        参数：
        textField - a JTextField object

      • DefaultCellEditor

        public DefaultCellEditor(JCheckBox checkBox)
        Constructs a DefaultCellEditor object that uses a check box.
        参数：
        checkBox - a JCheckBox object

      • DefaultCellEditor

        public DefaultCellEditor(JComboBox comboBox)
        Constructs a DefaultCellEditor object that uses a combo box.
        参数：
        comboBox - a JComboBox object

    • 方法详细信息

      • getComponent

        public Component getComponent()
        Returns a reference to the editor component.
        返回：
        the editor Component

      • setClickCountToStart

        public void setClickCountToStart(int count)
        Specifies the number of clicks needed to start editing.
        参数：
        count - an int specifying the number of clicks needed to start editing
        另请参见：
        getClickCountToStart()

      • getClickCountToStart

        public int getClickCountToStart()
        Returns the number of clicks needed to start editing.
        返回：
        the number of clicks needed to start editing

      • getCellEditorValue

        public Object getCellEditorValue()
        Forwards the message from the CellEditor to the delegate.
        指定者：
        getCellEditorValue in interface CellEditor
        返回：
        the value contained in the editor
        另请参见：
        DefaultCellEditor.EditorDelegate.getCellEditorValue()

      • isCellEditable

        public boolean isCellEditable(EventObject anEvent)
        Forwards the message from the CellEditor to the delegate.
        指定者：
        isCellEditable in interface CellEditor
        重载：
        isCellEditable in class AbstractCellEditor
        参数：
        anEvent - an event object
        返回：
        true
        另请参见：
        DefaultCellEditor.EditorDelegate.isCellEditable(EventObject)

      • shouldSelectCell

        public boolean shouldSelectCell(EventObject anEvent)
        Forwards the message from the CellEditor to the delegate.
        指定者：
        shouldSelectCell in interface CellEditor
        重载：
        shouldSelectCell in class AbstractCellEditor
        参数：
        anEvent - an event object
        返回：
        true
        另请参见：
        DefaultCellEditor.EditorDelegate.shouldSelectCell(EventObject)

      • stopCellEditing

        public boolean stopCellEditing()
        Forwards the message from the CellEditor to the delegate.
        指定者：
        stopCellEditing in interface CellEditor
        重载：
        stopCellEditing in class AbstractCellEditor
        返回：
        true
        另请参见：
        DefaultCellEditor.EditorDelegate.stopCellEditing()

      • cancelCellEditing

        public void cancelCellEditing()
        Forwards the message from the CellEditor to the delegate.
        指定者：
        cancelCellEditing in interface CellEditor
        重载：
        cancelCellEditing in class AbstractCellEditor
        另请参见：
        DefaultCellEditor.EditorDelegate.cancelCellEditing()

      • getTreeCellEditorComponent

        public Component getTreeCellEditorComponent(JTree tree,
                                   Object value,
                                   boolean isSelected,
                                   boolean expanded,
                                   boolean leaf,
                                   int row)
        Implements the TreeCellEditor interface.
        指定者：
        getTreeCellEditorComponent in interface TreeCellEditor
        参数：
        tree - the JTree that is asking the editor to edit; this parameter can be null
        value - the value of the cell to be edited
        isSelected - true if the cell is to be rendered with selection highlighting
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - the row index of the node being edited
        返回：
        the component for editing

      • getTableCellEditorComponent

        public Component getTableCellEditorComponent(JTable table,
                                    Object value,
                                    boolean isSelected,
                                    int row,
                                    int column)
        Implements the TableCellEditor interface.
        指定者：
        getTableCellEditorComponent in interface TableCellEditor
        参数：
        table - the JTable that is asking the editor to edit; can be null
        value - the value of the cell to be edited; it is up to the specific editor to interpret and draw the value. For example, if value is the string "true", it could be rendered as a string or it could be rendered as a check box that is checked. null is a valid value
        isSelected - true if the cell is to be rendered with highlighting
        row - the row of the cell being edited
        column - the column of the cell being edited
        返回：
        the component for editing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultCellEditor.EditorDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultCellEditor.EditorDelegate

  • java.lang.Object
    • javax.swing.DefaultCellEditor.EditorDelegate
  • 所有已实现的接口：
    ActionListener, ItemListener, Serializable, EventListener
    封闭类：
    DefaultCellEditor

    protected class DefaultCellEditor.EditorDelegate
extends Object
implements ActionListener, ItemListener, Serializable
    The protected EditorDelegate class.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Object value
      The value of this cell.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | DefaultCellEditor.EditorDelegate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      When an action is performed, editing is ended.
      void cancelCellEditing()
      Cancels editing.
      Object getCellEditorValue()
      Returns the value of this cell.
      boolean isCellEditable(EventObject anEvent)
      Returns true if anEvent is not a MouseEvent.
      void itemStateChanged(ItemEvent e)
      When an item's state changes, editing is ended.
      void setValue(Object value)
      Sets the value of this cell.
      boolean shouldSelectCell(EventObject anEvent)
      Returns true to indicate that the editing cell may be selected.
      boolean startCellEditing(EventObject anEvent)
      Returns true to indicate that editing has begun.
      boolean stopCellEditing()
      Stops editing and returns true to indicate that editing has stopped.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        protected Object value
        The value of this cell.

    • 构造方法详细信息

      • DefaultCellEditor.EditorDelegate

        protected DefaultCellEditor.EditorDelegate()

    • 方法详细信息

      • getCellEditorValue

        public Object getCellEditorValue()
        Returns the value of this cell.
        返回：
        the value of this cell

      • setValue

        public void setValue(Object value)
        Sets the value of this cell.
        参数：
        value - the new value of this cell

      • isCellEditable

        public boolean isCellEditable(EventObject anEvent)
        Returns true if anEvent is not a MouseEvent. Otherwise, it returns true if the necessary number of clicks have occurred, and returns false otherwise.
        参数：
        anEvent - the event
        返回：
        true if cell is ready for editing, false otherwise
        另请参见：
        DefaultCellEditor.setClickCountToStart(int), shouldSelectCell(java.util.EventObject)

      • shouldSelectCell

        public boolean shouldSelectCell(EventObject anEvent)
        Returns true to indicate that the editing cell may be selected.
        参数：
        anEvent - the event
        返回：
        true
        另请参见：
        isCellEditable(java.util.EventObject)

      • startCellEditing

        public boolean startCellEditing(EventObject anEvent)
        Returns true to indicate that editing has begun.
        参数：
        anEvent - the event

      • stopCellEditing

        public boolean stopCellEditing()
        Stops editing and returns true to indicate that editing has stopped. This method calls fireEditingStopped.
        返回：
        true

      • cancelCellEditing

        public void cancelCellEditing()
        Cancels editing. This method calls fireEditingCanceled.

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        When an action is performed, editing is ended.
        指定者：
        actionPerformed in interface ActionListener
        参数：
        e - the action event
        另请参见：
        stopCellEditing()

      • itemStateChanged

        public void itemStateChanged(ItemEvent e)
        When an item's state changes, editing is ended.
        指定者：
        itemStateChanged in interface ItemListener
        参数：
        e - the action event
        另请参见：
        stopCellEditing()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>/"oedlede((deeelll>ei>/ddcs"e""l>a


DefaultComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultComboBoxModel

  • java.lang.Object
    • javax.swing.AbstractListModel
      • javax.swing.DefaultComboBoxModel
  • 所有已实现的接口：
    Serializable, ComboBoxModel, ListModel, MutableComboBoxModel

    public class DefaultComboBoxModel
extends AbstractListModel
implements MutableComboBoxModel, Serializable
    The default model for combo boxes.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractListModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultComboBoxModel()
      Constructs an empty DefaultComboBoxModel object.
      DefaultComboBoxModel(Object[] items)
      Constructs a DefaultComboBoxModel object initialized with an array of objects.
      DefaultComboBoxModel(Vector<?> v)
      Constructs a DefaultComboBoxModel object initialized with a vector.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addElement(Object anObject)
      Adds an item at the end of the model.
      Object getElementAt(int index)
      Returns the value at the specified index.
      int getIndexOf(Object anObject)
      Returns the index-position of the specified object in the list.
      Object getSelectedItem()
      Returns the selected item
      int getSize()
      Returns the length of the list.
      void insertElementAt(Object anObject, int index)
      Adds an item at a specific index.
      void removeAllElements()
      Empties the list.
      void removeElement(Object anObject)
      Removes an item from the model.
      void removeElementAt(int index)
      Removes an item at a specific index.
      void setSelectedItem(Object anObject)
      Set the value of the selected item.

      • 方法 - 继承于类 javax.swing.AbstractListModel

        addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.ListModel

        addListDataListener, removeListDataListener

    • 构造方法详细信息

      • DefaultComboBoxModel

        public DefaultComboBoxModel()
        Constructs an empty DefaultComboBoxModel object.

      • DefaultComboBoxModel

        public DefaultComboBoxModel(Object[] items)
        Constructs a DefaultComboBoxModel object initialized with an array of objects.
        参数：
        items - an array of Object objects

      • DefaultComboBoxModel

        public DefaultComboBoxModel(Vector<?> v)
        Constructs a DefaultComboBoxModel object initialized with a vector.
        参数：
        v - a Vector object ...

    • 方法详细信息

      • setSelectedItem

        public void setSelectedItem(Object anObject)
        Set the value of the selected item. The selected item may be null.

        指定者：
        setSelectedItem in interface ComboBoxModel
        参数：
        anObject - The combo box value or null for no selection.

      • getSelectedItem

        public Object getSelectedItem()
        从接口复制的描述： ComboBoxModel
        Returns the selected item
        指定者：
        getSelectedItem in interface ComboBoxModel
        返回：
        The selected item or null if there is no selection

      • getSize

        public int getSize()
        从接口复制的描述： ListModel
        Returns the length of the list.
        指定者：
        getSize in interface ListModel
        返回：
        the length of the list

      • getElementAt

        public Object getElementAt(int index)
        从接口复制的描述： ListModel
        Returns the value at the specified index.
        指定者：
        getElementAt in interface ListModel
        参数：
        index - the requested index
        返回：
        the value at index

      • getIndexOf

        public int getIndexOf(Object anObject)
        Returns the index-position of the specified object in the list.
        参数：
        anObject -
        返回：
        an int representing the index position, where 0 is the first position

      • addElement

        public void addElement(Object anObject)
        从接口复制的描述： MutableComboBoxModel
        Adds an item at the end of the model. The implementation of this method should notify all registered ListDataListeners that the item has been added.
        指定者：
        addElement in interface MutableComboBoxModel
        参数：
        anObject - the Object to be added

      • insertElementAt

        public void insertElementAt(Object anObject,
                   int index)
        从接口复制的描述： MutableComboBoxModel
        Adds an item at a specific index. The implementation of this method should notify all registered ListDataListeners that the item has been added.
        指定者：
        insertElementAt in interface MutableComboBoxModel
        参数：
        anObject - the Object to be added
        index - location to add the object

      • removeElementAt

        public void removeElementAt(int index)
        从接口复制的描述： MutableComboBoxModel
        Removes an item at a specific index. The implementation of this method should notify all registered ListDataListeners that the item has been removed.
        指定者：
        removeElementAt in interface MutableComboBoxModel
        参数：
        index - location of object to be removed

      • removeElement

        public void removeElement(Object anObject)
        从接口复制的描述： MutableComboBoxModel
        Removes an item from the model. The implementation of this method should should notify all registered ListDataListeners that the item has been removed.
        指定者：
        removeElement in interface MutableComboBoxModel
        参数：
        anObject - the Object to be removed

      • removeAllElements

        public void removeAllElements()
        Empties the list.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>rrn>sg>s


DefaultDesktopManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultDesktopManager

  • java.lang.Object
    • javax.swing.DefaultDesktopManager
  • 所有已实现的接口：
    Serializable, DesktopManager

    public class DefaultDesktopManager
extends Object
implements DesktopManager, Serializable
    This is an implementation of the DesktopManager. It currently implements the basic behaviors for managing JInternalFrames in an arbitrary parent. JInternalFrames that are not children of a JDesktop will use this component to handle their desktop-like actions.

    This class provides a policy for the various JInternalFrame methods, it is not meant to be called directly rather the various JInternalFrame methods will call into the DesktopManager.

    另请参见：
    JDesktopPane, JInternalFrame

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultDesktopManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void activateFrame(JInternalFrame f)
      This will activate f moving it to the front.
      void beginDraggingFrame(JComponent f)
      This method is normally called when the user has indicated that they will begin dragging a component around.
      void beginResizingFrame(JComponent f, int direction)
      This methods is normally called when the user has indicated that they will begin resizing the frame.
      void closeFrame(JInternalFrame f)
      Removes the frame, and, if necessary, the desktopIcon, from its parent.
      void deactivateFrame(JInternalFrame f)
      Generally, indicate that this frame has lost focus.
      void deiconifyFrame(JInternalFrame f)
      Removes the desktopIcon from its parent and adds its frame to the parent.
      void dragFrame(JComponent f, int newX, int newY)
      Moves the visible location of the frame being dragged to the location specified.
      void endDraggingFrame(JComponent f)
      This method signals the end of the dragging session.
      void endResizingFrame(JComponent f)
      This method signals the end of the resize session.
      protected Rectangle getBoundsForIconOf(JInternalFrame f)
      The iconifyFrame() code calls this to determine the proper bounds for the desktopIcon.
      protected Rectangle getPreviousBounds(JInternalFrame f)
      Gets the normal bounds of the component prior to the component being maximized.
      void iconifyFrame(JInternalFrame f)
      Removes the frame from its parent and adds its desktopIcon to the parent.
      void maximizeFrame(JInternalFrame f)
      Resizes the frame to fill its parents bounds.
      void minimizeFrame(JInternalFrame f)
      Restores the frame back to its size and position prior to a maximizeFrame call.
      void openFrame(JInternalFrame f)
      Normally this method will not be called.
      protected void removeIconFor(JInternalFrame f)
      Convenience method to remove the desktopIcon of f is necessary.
      void resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      Calls setBoundsForFrame with the new values.
      void setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      This moves the JComponent and repaints the damaged areas.
      protected void setPreviousBounds(JInternalFrame f, Rectangle r)
      Stores the bounds of the component just before a maximize call.
      protected void setWasIcon(JInternalFrame f, Boolean value)
      Sets that the component has been iconized and the bounds of the desktopIcon are valid.
      protected boolean wasIcon(JInternalFrame f)
      Returns true if the component has been iconized and the bounds of the desktopIcon are valid, otherwise returns false.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultDesktopManager

        public DefaultDesktopManager()

    • 方法详细信息

      • openFrame

        public void openFrame(JInternalFrame f)
        Normally this method will not be called. If it is, it try to determine the appropriate parent from the desktopIcon of the frame. Will remove the desktopIcon from its parent if it successfully adds the frame.
        指定者：
        openFrame in interface DesktopManager

      • closeFrame

        public void closeFrame(JInternalFrame f)
        Removes the frame, and, if necessary, the desktopIcon, from its parent.
        指定者：
        closeFrame in interface DesktopManager
        参数：
        f - the JInternalFrame to be removed

      • maximizeFrame

        public void maximizeFrame(JInternalFrame f)
        Resizes the frame to fill its parents bounds.
        指定者：
        maximizeFrame in interface DesktopManager
        参数：
        f - the frame to be resized

      • minimizeFrame

        public void minimizeFrame(JInternalFrame f)
        Restores the frame back to its size and position prior to a maximizeFrame call.
        指定者：
        minimizeFrame in interface DesktopManager
        参数：
        f - the JInternalFrame to be restored

      • iconifyFrame

        public void iconifyFrame(JInternalFrame f)
        Removes the frame from its parent and adds its desktopIcon to the parent.
        指定者：
        iconifyFrame in interface DesktopManager
        参数：
        f - the JInternalFrame to be iconified

      • deiconifyFrame

        public void deiconifyFrame(JInternalFrame f)
        Removes the desktopIcon from its parent and adds its frame to the parent.
        指定者：
        deiconifyFrame in interface DesktopManager
        参数：
        f - the JInternalFrame to be de-iconified

      • activateFrame

        public void activateFrame(JInternalFrame f)
        This will activate f moving it to the front. It will set the current active frame's (if any) IS_SELECTED_PROPERTY to false. There can be only one active frame across all Layers.
        指定者：
        activateFrame in interface DesktopManager
        参数：
        f - the JInternalFrame to be activated

      • deactivateFrame

        public void deactivateFrame(JInternalFrame f)
        从接口复制的描述： DesktopManager
        Generally, indicate that this frame has lost focus. This is usually called after the JInternalFrame's IS_SELECTED_PROPERTY has been set to false.
        指定者：
        deactivateFrame in interface DesktopManager

      • beginDraggingFrame

        public void beginDraggingFrame(JComponent f)
        从接口复制的描述： DesktopManager
        This method is normally called when the user has indicated that they will begin dragging a component around. This method should be called prior to any dragFrame() calls to allow the DesktopManager to prepare any necessary state. Normally f will be a JInternalFrame.
        指定者：
        beginDraggingFrame in interface DesktopManager

      • dragFrame

        public void dragFrame(JComponent f,
             int newX,
             int newY)
        Moves the visible location of the frame being dragged to the location specified. The means by which this occurs can vary depending on the dragging algorithm being used. The actual logical location of the frame might not change until endDraggingFrame is called.
        指定者：
        dragFrame in interface DesktopManager

      • endDraggingFrame

        public void endDraggingFrame(JComponent f)
        从接口复制的描述： DesktopManager
        This method signals the end of the dragging session. Any state maintained by the DesktopManager can be removed here. Normally f will be a JInternalFrame.
        指定者：
        endDraggingFrame in interface DesktopManager

      • beginResizingFrame

        public void beginResizingFrame(JComponent f,
                      int direction)
        从接口复制的描述： DesktopManager
        This methods is normally called when the user has indicated that they will begin resizing the frame. This method should be called prior to any resizeFrame() calls to allow the DesktopManager to prepare any necessary state. Normally f will be a JInternalFrame.
        指定者：
        beginResizingFrame in interface DesktopManager

      • resizeFrame

        public void resizeFrame(JComponent f,
               int newX,
               int newY,
               int newWidth,
               int newHeight)
        Calls setBoundsForFrame with the new values.
        指定者：
        resizeFrame in interface DesktopManager
        参数：
        f - the component to be resized
        newX - the new x-coordinate
        newY - the new y-coordinate
        newWidth - the new width
        newHeight - the new height

      • endResizingFrame

        public void endResizingFrame(JComponent f)
        从接口复制的描述： DesktopManager
        This method signals the end of the resize session. Any state maintained by the DesktopManager can be removed here. Normally f will be a JInternalFrame.
        指定者：
        endResizingFrame in interface DesktopManager

      • setBoundsForFrame

        public void setBoundsForFrame(JComponent f,
                     int newX,
                     int newY,
                     int newWidth,
                     int newHeight)
        This moves the JComponent and repaints the damaged areas.
        指定者：
        setBoundsForFrame in interface DesktopManager

      • removeIconFor

        protected void removeIconFor(JInternalFrame f)
        Convenience method to remove the desktopIcon of f is necessary.

      • getBoundsForIconOf

        protected Rectangle getBoundsForIconOf(JInternalFrame f)
        The iconifyFrame() code calls this to determine the proper bounds for the desktopIcon.

      • setPreviousBounds

        protected void setPreviousBounds(JInternalFrame f,
                     Rectangle r)
        Stores the bounds of the component just before a maximize call.
        参数：
        f - the component about to be resized
        r - the normal bounds to be saved away

      • getPreviousBounds

        protected Rectangle getPreviousBounds(JInternalFrame f)
        Gets the normal bounds of the component prior to the component being maximized.
        参数：
        f - the JInternalFrame of interest
        返回：
        the normal bounds of the component

      • setWasIcon

        protected void setWasIcon(JInternalFrame f,
              Boolean value)
        Sets that the component has been iconized and the bounds of the desktopIcon are valid.

      • wasIcon

        protected boolean wasIcon(JInternalFrame f)
        Returns true if the component has been iconized and the bounds of the desktopIcon are valid, otherwise returns false.
        参数：
        f - the JInternalFrame of interest
        返回：
        true if the component has been iconized; otherwise returns false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultFocusManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultFocusManager

  • java.lang.Object
    • java.awt.KeyboardFocusManager
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
  • 所有已实现的接口：
    KeyEventDispatcher, KeyEventPostProcessor

    public class DefaultFocusManager
extends FocusManager
    This class has been obsoleted by the 1.4 focus APIs. While client code may still use this class, developers are strongly encouraged to use java.awt.KeyboardFocusManager and java.awt.DefaultKeyboardFocusManager instead.

    Please see How to Use the Focus Subsystem, a section in The Java Tutorial, and the Focus Specification for more information.

    • 字段摘要

      • Fields inherited from class javax.swing.FocusManager

        FOCUS_MANAGER_CLASS_PROPERTY

      • Fields inherited from class java.awt.KeyboardFocusManager

        BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultFocusManager()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      boolean | compareTabOrder(Component a, Component b)
      Component | getComponentAfter(Container aContainer, Component aComponent)
      Component | getComponentBefore(Container aContainer, Component aComponent)
      Component | getFirstComponent(Container aContainer)
      Component | getLastComponent(Container aContainer)

      • 方法 - 继承于类 javax.swing.FocusManager

        disableSwingFocusManager, getCurrentManager, isFocusManagerEnabled, setCurrentManager

      • 方法 - 继承于类 java.awt.DefaultKeyboardFocusManager

        dequeueKeyEvents, discardKeyEvents, dispatchEvent, dispatchKeyEvent, downFocusCycle, enqueueKeyEvents, focusNextComponent, focusPreviousComponent, postProcessKeyEvent, processKeyEvent, upFocusCycle

      • 方法 - 继承于类 java.awt.KeyboardFocusManager

        addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultFocusManager

        public DefaultFocusManager()

    • 方法详细信息

      • getComponentAfter

        public Component getComponentAfter(Container aContainer,
                          Component aComponent)

      • getComponentBefore

        public Component getComponentBefore(Container aContainer,
                           Component aComponent)

      • getFirstComponent

        public Component getFirstComponent(Container aContainer)

      • getLastComponent

        public Component getLastComponent(Container aContainer)

      • compareTabOrder

        public boolean compareTabOrder(Component a,
                      Component b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

spu fcoocolssoll iccs>aM)pMMaahv


DefaultListCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultListCellRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.DefaultListCellRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer<Object>, SwingConstants
    直接已知子类：
    DefaultListCellRenderer.UIResource, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer

    public class DefaultListCellRenderer
extends JLabel
implements ListCellRenderer<Object>, Serializable
    Renders an item in a list.

    Implementation Note: This class overrides invalidate, validate, revalidate, repaint, isOpaque, and firePropertyChange solely to improve performance. If not overridden, these frequently called methods would execute code paths that are unnecessary for the default list cell renderer. If you write your own renderer, take care to weigh the benefits and drawbacks of overriding these methods.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Border | noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultListCellRenderer()
      Constructs a default renderer object for an item in a list.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, byte oldValue, byte newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, char oldValue, char newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, double oldValue, double newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, float oldValue, float newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, int oldValue, int newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, long oldValue, long newValue)
      Overridden for performance reasons.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, short oldValue, short newValue)
      Overridden for performance reasons.
      Component getListCellRendererComponent(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Return a component that has been configured to display the specified value.
      void invalidate()
      Overridden for performance reasons.
      boolean isOpaque()
      Overridden for performance reasons.
      void repaint()
      Overridden for performance reasons.
      void repaint(long tm, int x, int y, int width, int height)
      Overridden for performance reasons.
      void repaint(Rectangle r)
      Overridden for performance reasons.
      void revalidate()
      Overridden for performance reasons.
      void validate()
      Overridden for performance reasons.

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • noFocusBorder

        protected static Border noFocusBorder

    • 构造方法详细信息

      • DefaultListCellRenderer

        public DefaultListCellRenderer()
        Constructs a default renderer object for an item in a list.

    • 方法详细信息

      • getListCellRendererComponent

        public Component getListCellRendererComponent(JList<?> list,
                                     Object value,
                                     int index,
                                     boolean isSelected,
                                     boolean cellHasFocus)
        从接口复制的描述： ListCellRenderer
        Return a component that has been configured to display the specified value. That component's paint method is then called to "render" the cell. If it is necessary to compute the dimensions of a list because the list cells do not have a fixed size, this method is called to generate a component on which getPreferredSize can be invoked.
        指定者：
        getListCellRendererComponent in interface ListCellRenderer<Object>
        参数：
        list - The JList we're painting.
        value - The value returned by list.getModel().getElementAt(index).
        index - The cells index.
        isSelected - True if the specified cell was selected.
        cellHasFocus - True if the specified cell has the focus.
        返回：
        A component whose paint() method will render the specified value.
        另请参见：
        JList, ListSelectionModel, ListModel

      • isOpaque

        public boolean isOpaque()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        isOpaque in class JComponent
        返回：
        true if the background is completely opaque and differs from the JList's background; false otherwise
        从以下版本开始：
        1.5
        另请参见：
        JComponent.setOpaque(boolean)

      • validate

        public void validate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        validate in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.isValidateRoot(),
JComponent.revalidate(),
Container.validateTree()

      • invalidate

        public void invalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        invalidate in class Container
        从以下版本开始：
        1.5
        另请参见：
        Container.validate(), Container.layout(), LayoutManager2

      • repaint

        public void repaint()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class Component
        从以下版本开始：
        1.5
        另请参见：
        Component.update(Graphics)

      • revalidate

        public void revalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        revalidate in class JComponent
        另请参见：
        Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

      • repaint

        public void repaint(long tm,
           int x,
           int y,
           int width,
           int height)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        tm - this parameter is not used
        x - the x value of the dirty region
        y - the y value of the dirty region
        width - the width of the dirty region
        height - the height of the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint(Rectangle r)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        r - a Rectangle containing the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      byte oldValue,
                      byte newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a byte)
        newValue - the new value of the property (as a byte)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      char oldValue,
                      char newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a char)
        newValue - the new value of the property (as a char)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      short oldValue,
                      short newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a short)
        newValue - the old value of the property (as a short)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      int oldValue,
                      int newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      long oldValue,
                      long newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a long)
        newValue - the new value of the property (as a long)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      float oldValue,
                      float newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a float)
        newValue - the new value of the property (as a float)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      double oldValue,
                      double newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a double)
        newValue - the new value of the property (as a double)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      boolean oldValue,
                      boolean newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultListCellRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing

类 DefaultListCellRenderer.UIResource

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.DefaultListCellRenderer
              • javax.swing.DefaultListCellRenderer.UIResource
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer<Object>, UIResource, SwingConstants
    封闭类：
    DefaultListCellRenderer

    public static class DefaultListCellRenderer.UIResource
extends DefaultListCellRenderer
implements UIResource
    A subclass of DefaultListCellRenderer that implements UIResource. DefaultListCellRenderer doesn't implement UIResource directly so that applications can safely override the cellRenderer property with DefaultListCellRenderer subclasses.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.DefaultListCellRenderer

        DefaultListCellRenderer.UIResource

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.DefaultListCellRenderer

        noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultListCellRenderer.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.DefaultListCellRenderer

        firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getListCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DefaultListCellRenderer.UIResource

        public DefaultListCellRenderer.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oCpae(sr(sittsiiaotttsih"t>euhLma/vCaa<=/h


DefaultListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultListModel<E>

  • java.lang.Object
    • javax.swing.AbstractListModel<E>
      • javax.swing.DefaultListModel<E>
  • 类型参数：
    E - the type of the elements of this model
    所有已实现的接口：
    Serializable, ListModel<E>

    public class DefaultListModel<E>
extends AbstractListModel<E>
    This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur. Presently it delegates to a Vector, in a future release it will be a real Collection implementation.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractListModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultListModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(int index, E element)
      Inserts the specified element at the specified position in this list.
      void addElement(E element)
      Adds the specified component to the end of this list.
      int capacity()
      Returns the current capacity of this list.
      void clear()
      Removes all of the elements from this list.
      boolean contains(Object elem)
      Tests whether the specified object is a component in this list.
      void copyInto(Object[] anArray)
      Copies the components of this list into the specified array.
      E elementAt(int index)
      Returns the component at the specified index.
      Enumeration<E> elements()
      Returns an enumeration of the components of this list.
      void ensureCapacity(int minCapacity)
      Increases the capacity of this list, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
      E firstElement()
      Returns the first component of this list.
      E get(int index)
      Returns the element at the specified position in this list.
      E getElementAt(int index)
      Returns the component at the specified index.
      int getSize()
      Returns the number of components in this list.
      int indexOf(Object elem)
      Searches for the first occurrence of elem.
      int indexOf(Object elem, int index)
      Searches for the first occurrence of elem, beginning the search at index.
      void insertElementAt(E element, int index)
      Inserts the specified element as a component in this list at the specified index.
      boolean isEmpty()
      Tests whether this list has any components.
      E lastElement()
      Returns the last component of the list.
      int lastIndexOf(Object elem)
      Returns the index of the last occurrence of elem.
      int lastIndexOf(Object elem, int index)
      Searches backwards for elem, starting from the specified index, and returns an index to it.
      E remove(int index)
      Removes the element at the specified position in this list.
      void removeAllElements()
      Removes all components from this list and sets its size to zero.
      boolean removeElement(Object obj)
      Removes the first (lowest-indexed) occurrence of the argument from this list.
      void removeElementAt(int index)
      Deletes the component at the specified index.
      void removeRange(int fromIndex, int toIndex)
      Deletes the components at the specified range of indexes.
      E set(int index, E element)
      Replaces the element at the specified position in this list with the specified element.
      void setElementAt(E element, int index)
      Sets the component at the specified index of this list to be the specified element.
      void setSize(int newSize)
      Sets the size of this list.
      int size()
      Returns the number of components in this list.
      Object[] toArray()
      Returns an array containing all of the elements in this list in the correct order.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void trimToSize()
      Trims the capacity of this list to be the list's current size.

      • 方法 - 继承于类 javax.swing.AbstractListModel

        addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DefaultListModel

        public DefaultListModel()

    • 方法详细信息

      • getSize

        public int getSize()
        Returns the number of components in this list.

        This method is identical to size, which implements the List interface defined in the 1.2 Collections framework. This method exists in conjunction with setSize so that size is identifiable as a JavaBean property.

        返回：
        the number of components in this list
        另请参见：
        size()

      • getElementAt

        public E getElementAt(int index)
        Returns the component at the specified index.
        Note: Although this method is not deprecated, the preferred method to use is get(int), which implements the List interface defined in the 1.2 Collections framework.
        参数：
        index - an index into this list
        返回：
        the component at the specified index
        抛出：
        ArrayIndexOutOfBoundsException - if the index is negative or greater than the current size of this list
        另请参见：
        get(int)

      • copyInto

        public void copyInto(Object[] anArray)
        Copies the components of this list into the specified array. The array must be big enough to hold all the objects in this list, else an IndexOutOfBoundsException is thrown.
        参数：
        anArray - the array into which the components get copied
        另请参见：
        Vector.copyInto(Object[])

      • trimToSize

        public void trimToSize()
        Trims the capacity of this list to be the list's current size.
        另请参见：
        Vector.trimToSize()

      • ensureCapacity

        public void ensureCapacity(int minCapacity)
        Increases the capacity of this list, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
        参数：
        minCapacity - the desired minimum capacity
        另请参见：
        Vector.ensureCapacity(int)

      • setSize

        public void setSize(int newSize)
        Sets the size of this list.
        参数：
        newSize - the new size of this list
        另请参见：
        Vector.setSize(int)

      • capacity

        public int capacity()
        Returns the current capacity of this list.
        返回：
        the current capacity
        另请参见：
        Vector.capacity()

      • size

        public int size()
        Returns the number of components in this list.
        返回：
        the number of components in this list
        另请参见：
        Vector.size()

      • isEmpty

        public boolean isEmpty()
        Tests whether this list has any components.
        返回：
        true if and only if this list has no components, that is, its size is zero; false otherwise
        另请参见：
        Vector.isEmpty()

      • elements

        public Enumeration<E> elements()
        Returns an enumeration of the components of this list.
        返回：
        an enumeration of the components of this list
        另请参见：
        Vector.elements()

      • contains

        public boolean contains(Object elem)
        Tests whether the specified object is a component in this list.
        参数：
        elem - an object
        返回：
        true if the specified object is the same as a component in this list
        另请参见：
        Vector.contains(Object)

      • indexOf

        public int indexOf(Object elem)
        Searches for the first occurrence of elem.
        参数：
        elem - an object
        返回：
        the index of the first occurrence of the argument in this list; returns -1 if the object is not found
        另请参见：
        Vector.indexOf(Object)

      • indexOf

        public int indexOf(Object elem,
          int index)
        Searches for the first occurrence of elem, beginning the search at index.
        参数：
        elem - an desired component
        index - the index from which to begin searching
        返回：
        the index where the first occurrence of elem is found after index; returns -1 if the elem is not found in the list
        另请参见：
        Vector.indexOf(Object,int)

      • lastIndexOf

        public int lastIndexOf(Object elem)
        Returns the index of the last occurrence of elem.
        参数：
        elem - the desired component
        返回：
        the index of the last occurrence of elem in the list; returns -1 if the object is not found
        另请参见：
        Vector.lastIndexOf(Object)

      • lastIndexOf

        public int lastIndexOf(Object elem,
              int index)
        Searches backwards for elem, starting from the specified index, and returns an index to it.
        参数：
        elem - the desired component
        index - the index to start searching from
        返回：
        the index of the last occurrence of the elem in this list at position less than index; returns -1 if the object is not found
        另请参见：
        Vector.lastIndexOf(Object,int)

      • elementAt

        public E elementAt(int index)
        Returns the component at the specified index. Throws an ArrayIndexOutOfBoundsException if the index is negative or not less than the size of the list.
        Note: Although this method is not deprecated, the preferred method to use is get(int), which implements the List interface defined in the 1.2 Collections framework.
        参数：
        index - an index into this list
        返回：
        the component at the specified index
        另请参见：
        get(int), Vector.elementAt(int)

      • firstElement

        public E firstElement()
        Returns the first component of this list. Throws a NoSuchElementException if this vector has no components.
        返回：
        the first component of this list
        另请参见：
        Vector.firstElement()

      • lastElement

        public E lastElement()
        Returns the last component of the list. Throws a NoSuchElementException if this vector has no components.
        返回：
        the last component of the list
        另请参见：
        Vector.lastElement()

      • setElementAt

        public void setElementAt(E element,
                int index)
        Sets the component at the specified index of this list to be the specified element. The previous component at that position is discarded.

        Throws an ArrayIndexOutOfBoundsException if the index is invalid.

        Note: Although this method is not deprecated, the preferred method to use is set(int,Object), which implements the List interface defined in the 1.2 Collections framework.
        参数：
        element - what the component is to be set to
        index - the specified index
        另请参见：
        set(int,Object), Vector.setElementAt(Object,int)

      • removeElementAt

        public void removeElementAt(int index)
        Deletes the component at the specified index.

        Throws an ArrayIndexOutOfBoundsException if the index is invalid.

        Note: Although this method is not deprecated, the preferred method to use is remove(int), which implements the List interface defined in the 1.2 Collections framework.
        参数：
        index - the index of the object to remove
        另请参见：
        remove(int), Vector.removeElementAt(int)

      • insertElementAt

        public void insertElementAt(E element,
                   int index)
        Inserts the specified element as a component in this list at the specified index.

        Throws an ArrayIndexOutOfBoundsException if the index is invalid.

        Note: Although this method is not deprecated, the preferred method to use is add(int,Object), which implements the List interface defined in the 1.2 Collections framework.
        参数：
        element - the component to insert
        index - where to insert the new component
        抛出：
        ArrayIndexOutOfBoundsException - if the index was invalid
        另请参见：
        add(int,Object), Vector.insertElementAt(Object,int)

      • addElement

        public void addElement(E element)
        Adds the specified component to the end of this list.
        参数：
        element - the component to be added
        另请参见：
        Vector.addElement(Object)

      • removeElement

        public boolean removeElement(Object obj)
        Removes the first (lowest-indexed) occurrence of the argument from this list.
        参数：
        obj - the component to be removed
        返回：
        true if the argument was a component of this list; false otherwise
        另请参见：
        Vector.removeElement(Object)

      • removeAllElements

        public void removeAllElements()
        Removes all components from this list and sets its size to zero.
        Note: Although this method is not deprecated, the preferred method to use is clear, which implements the List interface defined in the 1.2 Collections framework.
        另请参见：
        clear(), Vector.removeAllElements()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object

      • toArray

        public Object[] toArray()
        Returns an array containing all of the elements in this list in the correct order.
        返回：
        an array containing the elements of the list
        另请参见：
        Vector.toArray()

      • get

        public E get(int index)
        Returns the element at the specified position in this list.

        Throws an ArrayIndexOutOfBoundsException if the index is out of range (index < 0 || index >= size()).

        参数：
        index - index of element to return

      • set

        public E set(int index,
    E element)
        Replaces the element at the specified position in this list with the specified element.

        Throws an ArrayIndexOutOfBoundsException if the index is out of range (index < 0 || index >= size()).

        参数：
        index - index of element to replace
        element - element to be stored at the specified position
        返回：
        the element previously at the specified position

      • add

        public void add(int index,
       E element)
        Inserts the specified element at the specified position in this list.

        Throws an ArrayIndexOutOfBoundsException if the index is out of range (index < 0 || index > size()).

        参数：
        index - index at which the specified element is to be inserted
        element - element to be inserted

      • remove

        public E remove(int index)
        Removes the element at the specified position in this list. Returns the element that was removed from the list.

        Throws an ArrayIndexOutOfBoundsException if the index is out of range (index < 0 || index >= size()).

        参数：
        index - the index of the element to removed
        返回：
        the element previously at the specified position

      • clear

        public void clear()
        Removes all of the elements from this list. The list will be empty after this call returns (unless it throws an exception).

      • removeRange

        public void removeRange(int fromIndex,
               int toIndex)
        Deletes the components at the specified range of indexes. The removal is inclusive, so specifying a range of (1,5) removes the component at index 1 and the component at index 5, as well as all components in between.

        Throws an ArrayIndexOutOfBoundsException if the index was invalid. Throws an IllegalArgumentException if fromIndex > toIndex.

        参数：
        fromIndex - the index of the lower end of the range
        toIndex - the index of the upper end of the range
        另请参见：
        remove(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/rC.=.h".h rrh >tttmmwttennmenr


DefaultListSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultListSelectionModel

  • java.lang.Object
    • javax.swing.DefaultListSelectionModel
  • 所有已实现的接口：
    Serializable, Cloneable, ListSelectionModel

    public class DefaultListSelectionModel
extends Object
implements ListSelectionModel, Cloneable, Serializable
    Default data model for list selections.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    ListSelectionModel

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean | leadAnchorNotificationEnabled
      protected EventListenerList | listenerList

      • 字段 - 继承于接口 javax.swing.ListSelectionModel

        MULTIPLE_INTERVAL_SELECTION, SINGLE_INTERVAL_SELECTION, SINGLE_SELECTION

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultListSelectionModel()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addListSelectionListener(ListSelectionListener l)
      Add a listener to the list that's notified each time a change to the selection occurs.
      void addSelectionInterval(int index0, int index1)
      Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
      void clearSelection()
      Change the selection to the empty set.
      Object clone()
      Returns a clone of this selection model with the same selection.
      protected void fireValueChanged(boolean isAdjusting)
      Notifies listeners that we have ended a series of adjustments.
      protected void fireValueChanged(int firstIndex, int lastIndex)
      Notifies ListSelectionListeners that the value of the selection, in the closed interval firstIndex, lastIndex, has changed.
      protected void | fireValueChanged(int firstIndex, int lastIndex, boolean isAdjusting)
      int getAnchorSelectionIndex()
      Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
      int getLeadSelectionIndex()
      Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      ListSelectionListener[] getListSelectionListeners()
      Returns an array of all the list selection listeners registered on this DefaultListSelectionModel.
      int getMaxSelectionIndex()
      Returns the last selected index or -1 if the selection is empty.
      int getMinSelectionIndex()
      Returns the first selected index or -1 if the selection is empty.
      int getSelectionMode()
      Returns the current selection mode.
      boolean getValueIsAdjusting()
      Returns true if the selection is undergoing a series of changes.
      void insertIndexInterval(int index, int length, boolean before)
      Insert length indices beginning before/after index.
      boolean isLeadAnchorNotificationEnabled()
      Returns the value of the leadAnchorNotificationEnabled flag.
      boolean isSelectedIndex(int index)
      Returns true if the specified index is selected.
      boolean isSelectionEmpty()
      Returns true if no indices are selected.
      void moveLeadSelectionIndex(int leadIndex)
      Set the lead selection index, leaving all selection values unchanged.
      void removeIndexInterval(int index0, int index1)
      Remove the indices in the interval index0,index1 (inclusive) from the selection model.
      void removeListSelectionListener(ListSelectionListener l)
      Remove a listener from the list that's notified each time a change to the selection occurs.
      void removeSelectionInterval(int index0, int index1)
      Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive.
      void setAnchorSelectionIndex(int anchorIndex)
      Set the anchor selection index, leaving all selection values unchanged.
      void setLeadAnchorNotificationEnabled(boolean flag)
      Sets the value of the leadAnchorNotificationEnabled flag.
      void setLeadSelectionIndex(int leadIndex)
      Sets the lead selection index, ensuring that values between the anchor and the new lead are either all selected or all deselected.
      void setSelectionInterval(int index0, int index1)
      Changes the selection to be between index0 and index1 inclusive.
      void setSelectionMode(int selectionMode)
      Sets the selection mode.
      void setValueIsAdjusting(boolean isAdjusting)
      Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList

      • leadAnchorNotificationEnabled

        protected boolean leadAnchorNotificationEnabled

    • 构造方法详细信息

      • DefaultListSelectionModel

        public DefaultListSelectionModel()

    • 方法详细信息

      • getMinSelectionIndex

        public int getMinSelectionIndex()
        Returns the first selected index or -1 if the selection is empty.
        指定者：
        getMinSelectionIndex in interface ListSelectionModel

      • getMaxSelectionIndex

        public int getMaxSelectionIndex()
        Returns the last selected index or -1 if the selection is empty.
        指定者：
        getMaxSelectionIndex in interface ListSelectionModel

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        Returns true if the selection is undergoing a series of changes.
        指定者：
        getValueIsAdjusting in interface ListSelectionModel
        返回：
        true if the selection is undergoing a series of changes
        另请参见：
        ListSelectionModel.setValueIsAdjusting(boolean)

      • getSelectionMode

        public int getSelectionMode()
        Returns the current selection mode.
        指定者：
        getSelectionMode in interface ListSelectionModel
        返回：
        the current selection mode
        另请参见：
        ListSelectionModel.setSelectionMode(int)

      • setSelectionMode

        public void setSelectionMode(int selectionMode)
        Sets the selection mode. The following list describes the accepted selection modes:
        • ListSelectionModel.SINGLE_SELECTION - Only one list index can be selected at a time. In this mode, setSelectionInterval and addSelectionInterval are equivalent, both replacing the current selection with the index represented by the second argument (the "lead").
        • ListSelectionModel.SINGLE_INTERVAL_SELECTION - Only one contiguous interval can be selected at a time. In this mode, addSelectionInterval behaves like setSelectionInterval (replacing the current selection), unless the given interval is immediately adjacent to or overlaps the existing selection, and can therefore be used to grow it.
        • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - In this mode, there's no restriction on what can be selected.
        指定者：
        setSelectionMode in interface ListSelectionModel
        抛出：
        IllegalArgumentException - if the selection mode isn't one of those allowed
        另请参见：
        ListSelectionModel.getSelectionMode()

      • isSelectedIndex

        public boolean isSelectedIndex(int index)
        Returns true if the specified index is selected.
        指定者：
        isSelectedIndex in interface ListSelectionModel

      • isSelectionEmpty

        public boolean isSelectionEmpty()
        Returns true if no indices are selected.
        指定者：
        isSelectionEmpty in interface ListSelectionModel

      • addListSelectionListener

        public void addListSelectionListener(ListSelectionListener l)
        Add a listener to the list that's notified each time a change to the selection occurs.
        指定者：
        addListSelectionListener in interface ListSelectionModel
        参数：
        l - the ListSelectionListener
        另请参见：
        ListSelectionModel.removeListSelectionListener(javax.swing.event.ListSelectionListener),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int),
ListSelectionModel.removeSelectionInterval(int, int),
ListSelectionModel.clearSelection(),
ListSelectionModel.insertIndexInterval(int, int, boolean),
ListSelectionModel.removeIndexInterval(int, int)

      • removeListSelectionListener

        public void removeListSelectionListener(ListSelectionListener l)
        Remove a listener from the list that's notified each time a change to the selection occurs.
        指定者：
        removeListSelectionListener in interface ListSelectionModel
        参数：
        l - the ListSelectionListener
        另请参见：
        ListSelectionModel.addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getListSelectionListeners

        public ListSelectionListener[] getListSelectionListeners()
        Returns an array of all the list selection listeners registered on this DefaultListSelectionModel.
        返回：
        all of this model's ListSelectionListeners or an empty array if no list selection listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener), removeListSelectionListener(javax.swing.event.ListSelectionListener)

      • fireValueChanged

        protected void fireValueChanged(boolean isAdjusting)
        Notifies listeners that we have ended a series of adjustments.

      • fireValueChanged

        protected void fireValueChanged(int firstIndex,
                    int lastIndex)
        Notifies ListSelectionListeners that the value of the selection, in the closed interval firstIndex, lastIndex, has changed.

      • fireValueChanged

        protected void fireValueChanged(int firstIndex,
                    int lastIndex,
                    boolean isAdjusting)
        参数：
        firstIndex - the first index in the interval
        lastIndex - the last index in the interval
        isAdjusting - true if this is the final change in a series of adjustments
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultListSelectionModel instance m for its list selection listeners with the following code:

        ListSelectionListener[] lsls = (ListSelectionListener[])(m.getListeners(ListSelectionListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getListSelectionListeners()

      • setLeadAnchorNotificationEnabled

        public void setLeadAnchorNotificationEnabled(boolean flag)
        Sets the value of the leadAnchorNotificationEnabled flag.
        另请参见：
        isLeadAnchorNotificationEnabled()

      • isLeadAnchorNotificationEnabled

        public boolean isLeadAnchorNotificationEnabled()
        Returns the value of the leadAnchorNotificationEnabled flag. When leadAnchorNotificationEnabled is true the model generates notification events with bounds that cover all the changes to the selection plus the changes to the lead and anchor indices. Setting the flag to false causes a narrowing of the event's bounds to include only the elements that have been selected or deselected since the last change. Either way, the model continues to maintain the lead and anchor variables internally. The default is true.

        Note: It is possible for the lead or anchor to be changed without a change to the selection. Notification of these changes is often important, such as when the new lead or anchor needs to be updated in the view. Therefore, caution is urged when changing the default value.

        返回：
        the value of the leadAnchorNotificationEnabled flag
        另请参见：
        setLeadAnchorNotificationEnabled(boolean)

      • clearSelection

        public void clearSelection()
        Change the selection to the empty set. If this represents a change to the current selection then notify each ListSelectionListener.
        指定者：
        clearSelection in interface ListSelectionModel
        另请参见：
        ListSelectionModel.addListSelectionListener(javax.swing.event.ListSelectionListener)

      • setSelectionInterval

        public void setSelectionInterval(int index0,
                        int index1)
        Changes the selection to be between index0 and index1 inclusive. index0 doesn't have to be less than or equal to index1.

        In SINGLE_SELECTION selection mode, only the second index is used.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change.

        If either index is -1, this method does nothing and returns without exception. Otherwise, if either index is less than -1, an IndexOutOfBoundsException is thrown.

        指定者：
        setSelectionInterval in interface ListSelectionModel
        参数：
        index0 - one end of the interval.
        index1 - other end of the interval
        抛出：
        IndexOutOfBoundsException - if either index is less than -1 (and neither index is -1)
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • addSelectionInterval

        public void addSelectionInterval(int index0,
                        int index1)
        Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.

        In SINGLE_SELECTION selection mode, this is equivalent to calling setSelectionInterval, and only the second index is used. In SINGLE_INTERVAL_SELECTION selection mode, this method behaves like setSelectionInterval, unless the given interval is immediately adjacent to or overlaps the existing selection, and can therefore be used to grow it.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change. Note that index0 doesn't have to be less than or equal to index1.

        If either index is -1, this method does nothing and returns without exception. Otherwise, if either index is less than -1, an IndexOutOfBoundsException is thrown.

        指定者：
        addSelectionInterval in interface ListSelectionModel
        参数：
        index0 - one end of the interval.
        index1 - other end of the interval
        抛出：
        IndexOutOfBoundsException - if either index is less than -1 (and neither index is -1)
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener), setSelectionInterval(int, int)

      • removeSelectionInterval

        public void removeSelectionInterval(int index0,
                           int index1)
        Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive. index0 doesn't have to be less than or equal to index1.

        In SINGLE_INTERVAL_SELECTION selection mode, if the removal would produce two disjoint selections, the removal is extended through the greater end of the selection. For example, if the selection is 0-10 and you supply indices 5,6 (in any order) the resulting selection is 0-4.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change.

        If either index is -1, this method does nothing and returns without exception. Otherwise, if either index is less than -1, an IndexOutOfBoundsException is thrown.

        指定者：
        removeSelectionInterval in interface ListSelectionModel
        参数：
        index0 - one end of the interval
        index1 - other end of the interval
        抛出：
        IndexOutOfBoundsException - if either index is less than -1 (and neither index is -1)
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • insertIndexInterval

        public void insertIndexInterval(int index,
                       int length,
                       boolean before)
        Insert length indices beginning before/after index. If the value at index is itself selected and the selection mode is not SINGLE_SELECTION, set all of the newly inserted items as selected. Otherwise leave them unselected. This method is typically called to sync the selection model with a corresponding change in the data model.
        指定者：
        insertIndexInterval in interface ListSelectionModel

      • removeIndexInterval

        public void removeIndexInterval(int index0,
                       int index1)
        Remove the indices in the interval index0,index1 (inclusive) from the selection model. This is typically called to sync the selection model width a corresponding change in the data model. Note that (as always) index0 need not be <= index1.
        指定者：
        removeIndexInterval in interface ListSelectionModel

      • setValueIsAdjusting

        public void setValueIsAdjusting(boolean isAdjusting)
        Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change. The value of this property is used to initialize the valueIsAdjusting property of the ListSelectionEvents that are generated.

        For example, if the selection is being updated in response to a user drag, this property can be set to true when the drag is initiated and set to false when the drag is finished. During the drag, listeners receive events with a valueIsAdjusting property set to true. At the end of the drag, when the change is finalized, listeners receive an event with the value set to false. Listeners can use this pattern if they wish to update only when a change has been finalized.

        Setting this property to true begins a series of changes that is to be considered part of a single change. When the property is changed back to false, an event is sent out characterizing the entire selection change (if there was one), with the event's valueIsAdjusting property set to false.

        指定者：
        setValueIsAdjusting in interface ListSelectionModel
        参数：
        isAdjusting - the new value of the property
        另请参见：
        ListSelectionModel.getValueIsAdjusting(), ListSelectionEvent.getValueIsAdjusting()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object

      • clone

        public Object clone()
             throws CloneNotSupportedException
        Returns a clone of this selection model with the same selection. listenerLists are not duplicated.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        抛出：
        CloneNotSupportedException - if the selection model does not both (a) implement the Cloneable interface and (b) define a clone method.
        另请参见：
        Cloneable

      • getAnchorSelectionIndex

        public int getAnchorSelectionIndex()
        Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval(). The most recent index0 is considered the "anchor" and the most recent index1 is considered the "lead". Some interfaces display these indices specially, e.g. Windows95 displays the lead index with a dotted yellow outline.
        指定者：
        getAnchorSelectionIndex in interface ListSelectionModel
        另请参见：
        ListSelectionModel.getLeadSelectionIndex(),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int)

      • getLeadSelectionIndex

        public int getLeadSelectionIndex()
        Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
        指定者：
        getLeadSelectionIndex in interface ListSelectionModel
        另请参见：
        ListSelectionModel.getAnchorSelectionIndex(),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int)

      • setAnchorSelectionIndex

        public void setAnchorSelectionIndex(int anchorIndex)
        Set the anchor selection index, leaving all selection values unchanged. If leadAnchorNotificationEnabled is true, send a notification covering the old and new anchor cells.
        指定者：
        setAnchorSelectionIndex in interface ListSelectionModel
        另请参见：
        getAnchorSelectionIndex(), setLeadSelectionIndex(int)

      • moveLeadSelectionIndex

        public void moveLeadSelectionIndex(int leadIndex)
        Set the lead selection index, leaving all selection values unchanged. If leadAnchorNotificationEnabled is true, send a notification covering the old and new lead cells.
        参数：
        leadIndex - the new lead selection index
        从以下版本开始：
        1.5
        另请参见：
        setAnchorSelectionIndex(int), setLeadSelectionIndex(int), getLeadSelectionIndex()

      • setLeadSelectionIndex

        public void setLeadSelectionIndex(int leadIndex)
        Sets the lead selection index, ensuring that values between the anchor and the new lead are either all selected or all deselected. If the value at the anchor index is selected, first clear all the values in the range [anchor, oldLeadIndex], then select all the values values in the range [anchor, newLeadIndex], where oldLeadIndex is the old leadIndex and newLeadIndex is the new one.

        If the value at the anchor index is not selected, do the same thing in reverse selecting values in the old range and deslecting values in the new one.

        Generate a single event for this change and notify all listeners. For the purposes of generating minimal bounds in this event, do the operation in a single pass; that way the first and last index inside the ListSelectionEvent that is broadcast will refer to cells that actually changed value because of this method. If, instead, this operation were done in two steps the effect on the selection state would be the same but two events would be generated and the bounds around the changed values would be wider, including cells that had been first cleared only to later be set.

        This method can be used in the mouseDragged method of a UI class to extend a selection.

        指定者：
        setLeadSelectionIndex in interface ListSelectionModel
        另请参见：
        getLeadSelectionIndex(), setAnchorSelectionIndex(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v


DefaultRowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultRowSorter<M,I>

  • java.lang.Object
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
  • 类型参数：
    M - the type of the model
    I - the type of the identifier passed to the RowFilter
    直接已知子类：
    TableRowSorter

    public abstract class DefaultRowSorter<M,I>
extends RowSorter<M>
    An implementation of RowSorter that provides sorting and filtering around a grid-based data model. Beyond creating and installing a RowSorter, you very rarely need to interact with one directly. Refer to TableRowSorter for a concrete implementation of RowSorter for JTable.

    Sorting is done based on the current SortKeys, in order. If two objects are equal (the Comparator for the column returns 0) the next SortKey is used. If no SortKeys remain or the order is UNSORTED, then the order of the rows in the model is used.

    Sorting of each column is done by way of a Comparator that you can specify using the setComparator method. If a Comparator has not been specified, the Comparator returned by Collator.getInstance() is used on the results of calling toString on the underlying objects. The Comparator is never passed null. A null value is treated as occuring before a non-null value, and two null values are considered equal.

    If you specify a Comparator that casts its argument to a type other than that provided by the model, a ClassCastException will be thrown when the data is sorted.

    In addition to sorting, DefaultRowSorter provides the ability to filter rows. Filtering is done by way of a RowFilter that is specified using the setRowFilter method. If no filter has been specified all rows are included.

    By default, rows are in unsorted order (the same as the model) and every column is sortable. The default Comparators are documented in the subclasses (for example, TableRowSorter).

    If the underlying model structure changes (the modelStructureChanged method is invoked) the following are reset to their default values: Comparators by column, current sort order, and whether each column is sortable. To find the default Comparators, see the concrete implementation (for example, TableRowSorter). The default sort order is unsorted (the same as the model), and columns are sortable by default.

    If the underlying model structure changes (the modelStructureChanged method is invoked) the following are reset to their default values: Comparators by column, current sort order and whether a column is sortable.

    DefaultRowSorter is an abstract class. Concrete subclasses must provide access to the underlying data by invoking setModelWrapper. The setModelWrapper method must be invoked soon after the constructor is called, ideally from within the subclass's constructor. Undefined behavior will result if you use a DefaultRowSorter without specifying a ModelWrapper.

    DefaultRowSorter has two formal type parameters. The first type parameter corresponds to the class of the model, for example DefaultTableModel. The second type parameter corresponds to the class of the identifier passed to the RowFilter. Refer to TableRowSorter and RowFilter for more details on the type parameters.

    从以下版本开始：
    1.6
    另请参见：
    TableRowSorter, DefaultTableModel, Collator

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected static class  DefaultRowSorter.ModelWrapper<M,I>
      DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter.

      • Nested classes/interfaces inherited from class javax.swing.RowSorter

        RowSorter.SortKey

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultRowSorter()
      Creates an empty DefaultRowSorter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void allRowsChanged()
      Invoked when the contents of the underlying model have completely changed.
      int convertRowIndexToModel(int index)
      Returns the location of index in terms of the underlying model.
      int convertRowIndexToView(int index)
      Returns the location of index in terms of the view.
      Comparator<?> getComparator(int column)
      Returns the Comparator for the specified column.
      int getMaxSortKeys()
      Returns the maximum number of sort keys.
      M getModel()
      Returns the underlying model.
      int getModelRowCount()
      Returns the number of rows in the underlying model.
      protected DefaultRowSorter.ModelWrapper<M,I> getModelWrapper()
      Returns the model wrapper providing the data that is being sorted and filtered.
      RowFilter<? super M,? super I> getRowFilter()
      Returns the filter that determines which rows, if any, should be hidden from view.
      List<? extends RowSorter.SortKey> getSortKeys()
      Returns the current sort keys.
      boolean getSortsOnUpdates()
      Returns true if a sort should happen when the underlying model is updated; otherwise, returns false.
      int getViewRowCount()
      Returns the number of rows in the view.
      boolean isSortable(int column)
      Returns true if the specified column is sortable; otherwise, false.
      void modelStructureChanged()
      Invoked when the underlying model structure has completely changed.
      void rowsDeleted(int firstRow, int endRow)
      Invoked when rows have been deleted from the underlying model in the specified range (inclusive).
      void rowsInserted(int firstRow, int endRow)
      Invoked when rows have been inserted into the underlying model in the specified range (inclusive).
      void rowsUpdated(int firstRow, int endRow)
      Invoked when rows have been changed in the underlying model between the specified range (inclusive).
      void rowsUpdated(int firstRow, int endRow, int column)
      Invoked when the column in the rows have been updated in the underlying model between the specified range.
      void setComparator(int column, Comparator<?> comparator)
      Sets the Comparator to use when sorting the specified column.
      void setMaxSortKeys(int max)
      Sets the maximum number of sort keys.
      protected void setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
      Sets the model wrapper providing the data that is being sorted and filtered.
      void setRowFilter(RowFilter<? super M,? super I> filter)
      Sets the filter that determines which rows, if any, should be hidden from the view.
      void setSortable(int column, boolean sortable)
      Sets whether or not the specified column is sortable.
      void setSortKeys(List<? extends RowSorter.SortKey> sortKeys)
      Sets the sort keys.
      void setSortsOnUpdates(boolean sortsOnUpdates)
      If true, specifies that a sort should happen when the underlying model is updated (rowsUpdated is invoked).
      void sort()
      Sorts and filters the rows in the view based on the sort keys of the columns currently being sorted and the filter, if any, associated with this sorter.
      void toggleSortOrder(int column)
      Reverses the sort order from ascending to descending (or descending to ascending) if the specified column is already the primary sorted column; otherwise, makes the specified column the primary sorted column, with an ascending sort order.
      protected boolean useToString(int column)
      Returns whether or not to convert the value to a string before doing comparisons when sorting.

      • 方法 - 继承于类 javax.swing.RowSorter

        addRowSorterListener, fireRowSorterChanged, fireSortOrderChanged, removeRowSorterListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultRowSorter

        public DefaultRowSorter()
        Creates an empty DefaultRowSorter.

    • 方法详细信息

      • setModelWrapper

        protected final void setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
        Sets the model wrapper providing the data that is being sorted and filtered.
        参数：
        modelWrapper - the model wrapper responsible for providing the data that gets sorted and filtered
        抛出：
        IllegalArgumentException - if modelWrapper is null

      • getModelWrapper

        protected final DefaultRowSorter.ModelWrapper<M,I> getModelWrapper()
        Returns the model wrapper providing the data that is being sorted and filtered.
        返回：
        the model wrapper responsible for providing the data that gets sorted and filtered

      • getModel

        public final M getModel()
        Returns the underlying model.
        指定者：
        getModel in class RowSorter<M>
        返回：
        the underlying model

      • setSortable

        public void setSortable(int column,
               boolean sortable)
        Sets whether or not the specified column is sortable. The specified value is only checked when toggleSortOrder is invoked. It is still possible to sort on a column that has been marked as unsortable by directly setting the sort keys. The default is true.
        参数：
        column - the column to enable or disable sorting on, in terms of the underlying model
        sortable - whether or not the specified column is sortable
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the model
        另请参见：
        toggleSortOrder(int), setSortKeys(java.util.List)

      • isSortable

        public boolean isSortable(int column)
        Returns true if the specified column is sortable; otherwise, false.
        参数：
        column - the column to check sorting for, in terms of the underlying model
        返回：
        true if the column is sortable
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model

      • setSortKeys

        public void setSortKeys(List<? extends RowSorter.SortKey> sortKeys)
        Sets the sort keys. This creates a copy of the supplied List; subsequent changes to the supplied List do not effect this DefaultRowSorter. If the sort keys have changed this triggers a sort.
        指定者：
        setSortKeys in class RowSorter<M>
        参数：
        sortKeys - the new SortKeys; null is a shorthand for specifying an empty list, indicating that the view should be unsorted
        抛出：
        IllegalArgumentException - if any of the values in sortKeys are null or have a column index outside the range of the model

      • getSortKeys

        public List<? extends RowSorter.SortKey> getSortKeys()
        Returns the current sort keys. This returns an unmodifiable non-null List. If you need to change the sort keys, make a copy of the returned List, mutate the copy and invoke setSortKeys with the new list.
        指定者：
        getSortKeys in class RowSorter<M>
        返回：
        the current sort order

      • setMaxSortKeys

        public void setMaxSortKeys(int max)
        Sets the maximum number of sort keys. The number of sort keys determines how equal values are resolved when sorting. For example, assume a table row sorter is created and setMaxSortKeys(2) is invoked on it. The user clicks the header for column 1, causing the table rows to be sorted based on the items in column 1. Next, the user clicks the header for column 2, causing the table to be sorted based on the items in column 2; if any items in column 2 are equal, then those particular rows are ordered based on the items in column 1. In this case, we say that the rows are primarily sorted on column 2, and secondarily on column 1. If the user then clicks the header for column 3, then the items are primarily sorted on column 3 and secondarily sorted on column 2. Because the maximum number of sort keys has been set to 2 with setMaxSortKeys, column 1 no longer has an effect on the order.

        The maximum number of sort keys is enforced by toggleSortOrder. You can specify more sort keys by invoking setSortKeys directly and they will all be honored. However if toggleSortOrder is subsequently invoked the maximum number of sort keys will be enforced. The default value is 3.

        参数：
        max - the maximum number of sort keys
        抛出：
        IllegalArgumentException - if max < 1

      • getMaxSortKeys

        public int getMaxSortKeys()
        Returns the maximum number of sort keys.
        返回：
        the maximum number of sort keys

      • setSortsOnUpdates

        public void setSortsOnUpdates(boolean sortsOnUpdates)
        If true, specifies that a sort should happen when the underlying model is updated (rowsUpdated is invoked). For example, if this is true and the user edits an entry the location of that item in the view may change. The default is false.
        参数：
        sortsOnUpdates - whether or not to sort on update events

      • getSortsOnUpdates

        public boolean getSortsOnUpdates()
        Returns true if a sort should happen when the underlying model is updated; otherwise, returns false.
        返回：
        whether or not to sort when the model is updated

      • setRowFilter

        public void setRowFilter(RowFilter<? super M,? super I> filter)
        Sets the filter that determines which rows, if any, should be hidden from the view. The filter is applied before sorting. A value of null indicates all values from the model should be included.

        RowFilter's include method is passed an Entry that wraps the underlying model. The number of columns in the Entry corresponds to the number of columns in the ModelWrapper. The identifier comes from the ModelWrapper as well.

        This method triggers a sort.

        参数：
        filter - the filter used to determine what entries should be included

      • getRowFilter

        public RowFilter<? super M,? super I> getRowFilter()
        Returns the filter that determines which rows, if any, should be hidden from view.
        返回：
        the filter

      • toggleSortOrder

        public void toggleSortOrder(int column)
        Reverses the sort order from ascending to descending (or descending to ascending) if the specified column is already the primary sorted column; otherwise, makes the specified column the primary sorted column, with an ascending sort order. If the specified column is not sortable, this method has no effect.
        指定者：
        toggleSortOrder in class RowSorter<M>
        参数：
        column - index of the column to make the primary sorted column, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model
        另请参见：
        setSortable(int,boolean), setMaxSortKeys(int)

      • convertRowIndexToView

        public int convertRowIndexToView(int index)
        Returns the location of index in terms of the view. That is, for the row index in the coordinates of the underlying model this returns the row index in terms of the view.
        指定者：
        convertRowIndexToView in class RowSorter<M>
        参数：
        index - the row index in terms of the underlying model
        返回：
        row index in terms of the view, or -1 if index has been filtered out of the view
        抛出：
        IndexOutOfBoundsException - if index is outside the range of the model

      • convertRowIndexToModel

        public int convertRowIndexToModel(int index)
        Returns the location of index in terms of the underlying model. That is, for the row index in the coordinates of the view this returns the row index in terms of the underlying model.
        指定者：
        convertRowIndexToModel in class RowSorter<M>
        参数：
        index - the row index in terms of the underlying view
        返回：
        row index in terms of the view
        抛出：
        IndexOutOfBoundsException - if index is outside the range of the view

      • sort

        public void sort()
        Sorts and filters the rows in the view based on the sort keys of the columns currently being sorted and the filter, if any, associated with this sorter. An empty sortKeys list indicates that the view should unsorted, the same as the model.
        另请参见：
        setRowFilter(javax.swing.RowFilter), setSortKeys(java.util.List)

      • useToString

        protected boolean useToString(int column)
        Returns whether or not to convert the value to a string before doing comparisons when sorting. If true ModelWrapper.getStringValueAt will be used, otherwise ModelWrapper.getValueAt will be used. It is up to subclasses, such as TableRowSorter, to honor this value in their ModelWrapper implementation.
        参数：
        column - the index of the column to test, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if column is not valid

      • setComparator

        public void setComparator(int column,
                 Comparator<?> comparator)
        Sets the Comparator to use when sorting the specified column. This does not trigger a sort. If you want to sort after setting the comparator you need to explicitly invoke sort.
        参数：
        column - the index of the column the Comparator is to be used for, in terms of the underlying model
        comparator - the Comparator to use
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model

      • getComparator

        public Comparator<?> getComparator(int column)
        Returns the Comparator for the specified column. This will return null if a Comparator has not been specified for the column.
        参数：
        column - the column to fetch the Comparator for, in terms of the underlying model
        返回：
        the Comparator for the specified column
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model

      • getViewRowCount

        public int getViewRowCount()
        Returns the number of rows in the view. If the contents have been filtered this might differ from the row count of the underlying model.
        指定者：
        getViewRowCount in class RowSorter<M>
        返回：
        number of rows in the view
        另请参见：
        RowSorter.getModelRowCount()

      • getModelRowCount

        public int getModelRowCount()
        Returns the number of rows in the underlying model.
        指定者：
        getModelRowCount in class RowSorter<M>
        返回：
        number of rows in the underlying model
        另请参见：
        RowSorter.getViewRowCount()

      • modelStructureChanged

        public void modelStructureChanged()
        Invoked when the underlying model structure has completely changed. For example, if the number of columns in a TableModel changed, this method would be invoked.

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        modelStructureChanged in class RowSorter<M>

      • allRowsChanged

        public void allRowsChanged()
        Invoked when the contents of the underlying model have completely changed. The structure of the table is the same, only the contents have changed. This is typically sent when it is too expensive to characterize the change in terms of the other methods.

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        allRowsChanged in class RowSorter<M>

      • rowsInserted

        public void rowsInserted(int firstRow,
                int endRow)
        Invoked when rows have been inserted into the underlying model in the specified range (inclusive).

        The arguments give the indices of the effected range. The first argument is in terms of the model before the change, and must be less than or equal to the size of the model before the change. The second argument is in terms of the model after the change and must be less than the size of the model after the change. For example, if you have a 5-row model and add 3 items to the end of the model the indices are 5, 7.

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        rowsInserted in class RowSorter<M>
        参数：
        firstRow - the first row
        endRow - the last row
        抛出：
        IndexOutOfBoundsException - if either argument is invalid, or firstRow > endRow

      • rowsDeleted

        public void rowsDeleted(int firstRow,
               int endRow)
        Invoked when rows have been deleted from the underlying model in the specified range (inclusive).

        The arguments give the indices of the effected range and are in terms of the model before the change. For example, if you have a 5-row model and delete 3 items from the end of the model the indices are 2, 4.

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        rowsDeleted in class RowSorter<M>
        参数：
        firstRow - the first row
        endRow - the last row
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the model before the change, or firstRow > endRow

      • rowsUpdated

        public void rowsUpdated(int firstRow,
               int endRow)
        Invoked when rows have been changed in the underlying model between the specified range (inclusive).

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        rowsUpdated in class RowSorter<M>
        参数：
        firstRow - the first row, in terms of the underlying model
        endRow - the last row, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the underlying model, or firstRow > endRow

      • rowsUpdated

        public void rowsUpdated(int firstRow,
               int endRow,
               int column)
        Invoked when the column in the rows have been updated in the underlying model between the specified range.

        You normally do not call this method. This method is public to allow view classes to call it.

        指定者：
        rowsUpdated in class RowSorter<M>
        参数：
        firstRow - the first row, in terms of the underlying model
        endRow - the last row, in terms of the underlying model
        column - the column that has changed, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the underlying model after the change, firstRow > endRow, or column is outside the range of the underlying model
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>x" r hr , ,,>(llgwva/Dfs=f.ehtllS<#L>aia


DefaultRowSorter.ModelWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultRowSorter.ModelWrapper<M,I>

  • java.lang.Object
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
  • 类型参数：
    M - the type of the underlying model
    I - the identifier supplied to the filter
    封闭类：
    DefaultRowSorter<M,I>

    protected abstract static class DefaultRowSorter.ModelWrapper<M,I>
extends Object
    DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter. You normally do not interact directly with ModelWrapper. Subclasses of DefaultRowSorter provide an implementation of ModelWrapper wrapping another model. For example, TableRowSorter provides a ModelWrapper that wraps a TableModel.

    ModelWrapper makes a distinction between values as Objects and Strings. This allows implementations to provide a custom string converter to be used instead of invoking toString on the object.

    从以下版本开始：
    1.6
    另请参见：
    RowFilter, RowFilter.Entry

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DefaultRowSorter.ModelWrapper()
      Creates a new ModelWrapper.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int getColumnCount()
      Returns the number of columns in the model.
      abstract I getIdentifier(int row)
      Returns the identifier for the specified row.
      abstract M getModel()
      Returns the underlying model that this Model is wrapping.
      abstract int getRowCount()
      Returns the number of rows in the model.
      String getStringValueAt(int row, int column)
      Returns the value as a String at the specified index.
      abstract Object getValueAt(int row, int column)
      Returns the value at the specified index.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultRowSorter.ModelWrapper

        protected DefaultRowSorter.ModelWrapper()
        Creates a new ModelWrapper.

    • 方法详细信息

      • getModel

        public abstract M getModel()
        Returns the underlying model that this Model is wrapping.
        返回：
        the underlying model

      • getColumnCount

        public abstract int getColumnCount()
        Returns the number of columns in the model.
        返回：
        the number of columns in the model

      • getRowCount

        public abstract int getRowCount()
        Returns the number of rows in the model.
        返回：
        the number of rows in the model

      • getValueAt

        public abstract Object getValueAt(int row,
                int column)
        Returns the value at the specified index.
        参数：
        row - the row index
        column - the column index
        返回：
        the value at the specified index
        抛出：
        IndexOutOfBoundsException - if the indices are outside the range of the model

      • getStringValueAt

        public String getStringValueAt(int row,
                      int column)
        Returns the value as a String at the specified index. This implementation uses toString on the result from getValueAt (making sure to return an empty string for null values). Subclasses that override this method should never return null.
        参数：
        row - the row index
        column - the column index
        返回：
        the value at the specified index as a String
        抛出：
        IndexOutOfBoundsException - if the indices are outside the range of the model

      • getIdentifier

        public abstract I getIdentifier(int row)
        Returns the identifier for the specified row. The return value of this is used as the identifier for the RowFilter.Entry that is passed to the RowFilter.
        参数：
        row - the row to return the identifier for, in terms of the underlying model
        返回：
        the identifier
        另请参见：
        RowFilter.Entry.getIdentifier()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cioclstast/rt >ddg hetanlr


DefaultSingleSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 DefaultSingleSelectionModel

  • java.lang.Object
    • javax.swing.DefaultSingleSelectionModel
  • 所有已实现的接口：
    Serializable, SingleSelectionModel

    public class DefaultSingleSelectionModel
extends Object
implements SingleSelectionModel, Serializable
    A generic implementation of SingleSelectionModel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeEvent | changeEvent
      protected EventListenerList listenerList
      The collection of registered listeners

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultSingleSelectionModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      void clearSelection()
      Clears the selection (to -1).
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      ChangeListener[] getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultSingleSelectionModel.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getSelectedIndex()
      Returns the model's selection.
      boolean isSelected()
      Returns true if the selection model currently has a selected value.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.
      void setSelectedIndex(int index)
      Sets the model's selected index to index.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • changeEvent

        protected transient ChangeEvent changeEvent

      • listenerList

        protected EventListenerList listenerList
        The collection of registered listeners

    • 构造方法详细信息

      • DefaultSingleSelectionModel

        public DefaultSingleSelectionModel()

    • 方法详细信息

      • getSelectedIndex

        public int getSelectedIndex()
        从接口复制的描述： SingleSelectionModel
        Returns the model's selection.
        指定者：
        getSelectedIndex in interface SingleSelectionModel
        返回：
        the model's selection, or -1 if there is no selection
        另请参见：
        SingleSelectionModel.setSelectedIndex(int)

      • setSelectedIndex

        public void setSelectedIndex(int index)
        从接口复制的描述： SingleSelectionModel
        Sets the model's selected index to index. Notifies any listeners if the model changes
        指定者：
        setSelectedIndex in interface SingleSelectionModel
        参数：
        index - an int specifying the model selection
        另请参见：
        SingleSelectionModel.getSelectedIndex(), SingleSelectionModel.addChangeListener(javax.swing.event.ChangeListener)

      • clearSelection

        public void clearSelection()
        从接口复制的描述： SingleSelectionModel
        Clears the selection (to -1).
        指定者：
        clearSelection in interface SingleSelectionModel

      • isSelected

        public boolean isSelected()
        从接口复制的描述： SingleSelectionModel
        Returns true if the selection model currently has a selected value.
        指定者：
        isSelected in interface SingleSelectionModel
        返回：
        true if a value is currently selected

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the button.
        指定者：
        addChangeListener in interface SingleSelectionModel
        参数：
        l - the ChangeListener to add

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the button.
        指定者：
        removeChangeListener in interface SingleSelectionModel
        参数：
        l - the ChangeListener to remove

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the change listeners registered on this DefaultSingleSelectionModel.
        返回：
        all of this model's ChangeListeners or an empty array if no change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultSingleSelectionModel instance m for its change listeners with the following code:

        ChangeListener[] cls = (ChangeListener[])(m.getListeners(ChangeListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getChangeListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ed>cds講n鬃t>hpl=b


DesktopManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface DesktopManager

  • All Known Implementing Classes:
    DefaultDesktopManager

    public interface DesktopManager
    DesktopManager objects are owned by a JDesktopPane object. They are responsible for implementing L&F specific behaviors for the JDesktopPane. JInternalFrame implementations should delegate specific behaviors to the DesktopManager. For instance, if a JInternalFrame was asked to iconify, it should try:
        getDesktopPane().getDesktopManager().iconifyFrame(frame);
    This delegation allows each L&F to provide custom behaviors for desktop-specific actions. (For example, how and where the internal frame's icon would appear.)

    This class provides a policy for the various JInternalFrame methods, it is not meant to be called directly rather the various JInternalFrame methods will call into the DesktopManager.

    另请参见：
    JDesktopPane, JInternalFrame, JInternalFrame.JDesktopIcon

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void activateFrame(JInternalFrame f)
      Generally, indicate that this frame has focus.
      void beginDraggingFrame(JComponent f)
      This method is normally called when the user has indicated that they will begin dragging a component around.
      void beginResizingFrame(JComponent f, int direction)
      This methods is normally called when the user has indicated that they will begin resizing the frame.
      void closeFrame(JInternalFrame f)
      Generally, this call should remove the frame from it's parent.
      void deactivateFrame(JInternalFrame f)
      Generally, indicate that this frame has lost focus.
      void deiconifyFrame(JInternalFrame f)
      Generally, remove any iconic representation that is present and restore the frame to it's original size and location.
      void dragFrame(JComponent f, int newX, int newY)
      The user has moved the frame.
      void endDraggingFrame(JComponent f)
      This method signals the end of the dragging session.
      void endResizingFrame(JComponent f)
      This method signals the end of the resize session.
      void iconifyFrame(JInternalFrame f)
      Generally, remove this frame from it's parent and add an iconic representation.
      void maximizeFrame(JInternalFrame f)
      Generally, the frame should be resized to match it's parents bounds.
      void minimizeFrame(JInternalFrame f)
      Generally, this indicates that the frame should be restored to it's size and position prior to a maximizeFrame() call.
      void openFrame(JInternalFrame f)
      If possible, display this frame in an appropriate location.
      void resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      The user has resized the component.
      void setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      This is a primitive reshape method.

    • 方法详细信息

      • openFrame

        void openFrame(JInternalFrame f)
        If possible, display this frame in an appropriate location. Normally, this is not called, as the creator of the JInternalFrame will add the frame to the appropriate parent.

      • closeFrame

        void closeFrame(JInternalFrame f)
        Generally, this call should remove the frame from it's parent.

      • maximizeFrame

        void maximizeFrame(JInternalFrame f)
        Generally, the frame should be resized to match it's parents bounds.

      • minimizeFrame

        void minimizeFrame(JInternalFrame f)
        Generally, this indicates that the frame should be restored to it's size and position prior to a maximizeFrame() call.

      • iconifyFrame

        void iconifyFrame(JInternalFrame f)
        Generally, remove this frame from it's parent and add an iconic representation.

      • deiconifyFrame

        void deiconifyFrame(JInternalFrame f)
        Generally, remove any iconic representation that is present and restore the frame to it's original size and location.

      • activateFrame

        void activateFrame(JInternalFrame f)
        Generally, indicate that this frame has focus. This is usually called after the JInternalFrame's IS_SELECTED_PROPERTY has been set to true.

      • deactivateFrame

        void deactivateFrame(JInternalFrame f)
        Generally, indicate that this frame has lost focus. This is usually called after the JInternalFrame's IS_SELECTED_PROPERTY has been set to false.

      • beginDraggingFrame

        void beginDraggingFrame(JComponent f)
        This method is normally called when the user has indicated that they will begin dragging a component around. This method should be called prior to any dragFrame() calls to allow the DesktopManager to prepare any necessary state. Normally f will be a JInternalFrame.

      • dragFrame

        void dragFrame(JComponent f,
             int newX,
             int newY)
        The user has moved the frame. Calls to this method will be preceded by calls to beginDraggingFrame(). Normally f will be a JInternalFrame.

      • endDraggingFrame

        void endDraggingFrame(JComponent f)
        This method signals the end of the dragging session. Any state maintained by the DesktopManager can be removed here. Normally f will be a JInternalFrame.

      • beginResizingFrame

        void beginResizingFrame(JComponent f,
                      int direction)
        This methods is normally called when the user has indicated that they will begin resizing the frame. This method should be called prior to any resizeFrame() calls to allow the DesktopManager to prepare any necessary state. Normally f will be a JInternalFrame.

      • resizeFrame

        void resizeFrame(JComponent f,
               int newX,
               int newY,
               int newWidth,
               int newHeight)
        The user has resized the component. Calls to this method will be preceded by calls to beginResizingFrame(). Normally f will be a JInternalFrame.

      • endResizingFrame

        void endResizingFrame(JComponent f)
        This method signals the end of the resize session. Any state maintained by the DesktopManager can be removed here. Normally f will be a JInternalFrame.

      • setBoundsForFrame

        void setBoundsForFrame(JComponent f,
                     int newX,
                     int newY,
                     int newWidth,
                     int newHeight)
        This is a primitive reshape method.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sstad>dt>dd>>ddd1>:: t


DropMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum DropMode

  • java.lang.Object
    • java.lang.Enum<DropMode>
      • javax.swing.DropMode
  • 所有已实现的接口：
    Serializable, Comparable<DropMode>

    public enum DropMode
extends Enum<DropMode>
    Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
    从以下版本开始：
    1.6
    另请参见：
    JTable.setDropMode(javax.swing.DropMode),
JList.setDropMode(javax.swing.DropMode),
JTree.setDropMode(javax.swing.DropMode),
JTextComponent.setDropMode(javax.swing.DropMode)

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      INSERT
      The drop location should be tracked in terms of the position where new data should be inserted.
      INSERT_COLS
      The drop location should be tracked in terms of the column index where new columns should be inserted to accommodate the dropped data.
      INSERT_ROWS
      The drop location should be tracked in terms of the row index where new rows should be inserted to accommodate the dropped data.
      ON
      The drop location should be tracked in terms of the index of existing items.
      ON_OR_INSERT
      This mode is a combination of ON and INSERT, specifying that data can be dropped on existing items, or in insert locations as specified by INSERT.
      ON_OR_INSERT_COLS
      This mode is a combination of ON and INSERT_COLS, specifying that data can be dropped on existing items, or as insert columns as specified by INSERT_COLS.
      ON_OR_INSERT_ROWS
      This mode is a combination of ON and INSERT_ROWS, specifying that data can be dropped on existing items, or as insert rows as specified by INSERT_ROWS.
      USE_SELECTION
      A component's own internal selection mechanism (or caret for text components) should be used to track the drop location.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static DropMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DropMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • USE_SELECTION

        public static final DropMode USE_SELECTION
        A component's own internal selection mechanism (or caret for text components) should be used to track the drop location.

      • ON

        public static final DropMode ON
        The drop location should be tracked in terms of the index of existing items. Useful for dropping on items in tables, lists, and trees.

      • INSERT

        public static final DropMode INSERT
        The drop location should be tracked in terms of the position where new data should be inserted. For components that manage a list of items (list and tree for example), the drop location should indicate the index where new data should be inserted. For text components the location should represent a position between characters. For components that manage tabular data (table for example), the drop location should indicate where to insert new rows, columns, or both, to accommodate the dropped data.

      • INSERT_ROWS

        public static final DropMode INSERT_ROWS
        The drop location should be tracked in terms of the row index where new rows should be inserted to accommodate the dropped data. This is useful for components that manage tabular data.

      • INSERT_COLS

        public static final DropMode INSERT_COLS
        The drop location should be tracked in terms of the column index where new columns should be inserted to accommodate the dropped data. This is useful for components that manage tabular data.

      • ON_OR_INSERT

        public static final DropMode ON_OR_INSERT
        This mode is a combination of ON and INSERT, specifying that data can be dropped on existing items, or in insert locations as specified by INSERT.

      • ON_OR_INSERT_ROWS

        public static final DropMode ON_OR_INSERT_ROWS
        This mode is a combination of ON and INSERT_ROWS, specifying that data can be dropped on existing items, or as insert rows as specified by INSERT_ROWS.

      • ON_OR_INSERT_COLS

        public static final DropMode ON_OR_INSERT_COLS
        This mode is a combination of ON and INSERT_COLS, specifying that data can be dropped on existing items, or as insert columns as specified by INSERT_COLS.

    • 方法详细信息

      • values

        public static DropMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (DropMode c : DropMode.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static DropMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tit" a"na"v>>"vvta ND=NE=-==O===-==>=


FocusManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 FocusManager

  • java.lang.Object
    • java.awt.KeyboardFocusManager
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
  • 所有已实现的接口：
    KeyEventDispatcher, KeyEventPostProcessor
    直接已知子类：
    DefaultFocusManager

    public abstract class FocusManager
extends DefaultKeyboardFocusManager
    This class has been obsoleted by the 1.4 focus APIs. While client code may still use this class, developers are strongly encouraged to use java.awt.KeyboardFocusManager and java.awt.DefaultKeyboardFocusManager instead.

    Please see How to Use the Focus Subsystem, a section in The Java Tutorial, and the Focus Specification for more information.

    另请参见：
    Focus Specification

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FOCUS_MANAGER_CLASS_PROPERTY
      This field is obsolete, and its use is discouraged since its specification is incompatible with the 1.4 focus APIs.

      • Fields inherited from class java.awt.KeyboardFocusManager

        BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS

    • 构造方法摘要

      Constructors
      构造方法与描述
      FocusManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static void disableSwingFocusManager()
      Deprecated.
      as of 1.4, replaced by KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)
      static FocusManager getCurrentManager()
      Returns the current KeyboardFocusManager instance for the calling thread's context.
      static boolean isFocusManagerEnabled()
      Deprecated.
      As of 1.4, replaced by KeyboardFocusManager.getDefaultFocusTraversalPolicy()
      static void setCurrentManager(FocusManager aFocusManager)
      Sets the current KeyboardFocusManager instance for the calling thread's context.

      • 方法 - 继承于类 java.awt.DefaultKeyboardFocusManager

        dequeueKeyEvents, discardKeyEvents, dispatchEvent, dispatchKeyEvent, downFocusCycle, enqueueKeyEvents, focusNextComponent, focusPreviousComponent, postProcessKeyEvent, processKeyEvent, upFocusCycle

      • 方法 - 继承于类 java.awt.KeyboardFocusManager

        addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FOCUS_MANAGER_CLASS_PROPERTY

        public static final String FOCUS_MANAGER_CLASS_PROPERTY
        This field is obsolete, and its use is discouraged since its specification is incompatible with the 1.4 focus APIs. The current FocusManager is no longer a property of the UI. Client code must query for the current FocusManager using KeyboardFocusManager.getCurrentKeyboardFocusManager(). See the Focus Specification for more information.
        另请参见：
        KeyboardFocusManager.getCurrentKeyboardFocusManager(), Focus Specification, Constant Field Values

    • 构造方法详细信息

      • FocusManager

        public FocusManager()

    • 方法详细信息

      • getCurrentManager

        public static FocusManager getCurrentManager()
        Returns the current KeyboardFocusManager instance for the calling thread's context.
        返回：
        this thread's context's KeyboardFocusManager
        另请参见：
        setCurrentManager(javax.swing.FocusManager)

      • setCurrentManager

        public static void setCurrentManager(FocusManager aFocusManager)
                              throws SecurityException
        Sets the current KeyboardFocusManager instance for the calling thread's context. If null is specified, then the current KeyboardFocusManager is replaced with a new instance of DefaultKeyboardFocusManager.

        If a SecurityManager is installed, the calling thread must be granted the AWTPermission "replaceKeyboardFocusManager" in order to replace the the current KeyboardFocusManager. If this permission is not granted, this method will throw a SecurityException, and the current KeyboardFocusManager will be unchanged.

        参数：
        aFocusManager - the new KeyboardFocusManager for this thread's context
        抛出：
        SecurityException - if the calling thread does not have permission to replace the current KeyboardFocusManager
        另请参见：
        getCurrentManager(), DefaultKeyboardFocusManager

      • disableSwingFocusManager

        @Deprecated
public static void disableSwingFocusManager()
        Deprecated. as of 1.4, replaced by KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)
        Changes the current KeyboardFocusManager's default FocusTraversalPolicy to DefaultFocusTraversalPolicy.
        另请参见：
        DefaultFocusTraversalPolicy, KeyboardFocusManager.setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy)

      • isFocusManagerEnabled

        @Deprecated
public static boolean isFocusManagerEnabled()
        Deprecated. As of 1.4, replaced by KeyboardFocusManager.getDefaultFocusTraversalPolicy()
        Returns whether the application has invoked disableSwingFocusManager().
        另请参见：
        disableSwingFocusManager()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ya dtdtdad.slay lyaag/uegn=En/Li� c/rt.ea)a"sa


GrayFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 GrayFilter

  • java.lang.Object
    • java.awt.image.ImageFilter
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
  • 所有已实现的接口：
    ImageConsumer, Cloneable

    public class GrayFilter
extends RGBImageFilter
    An image filter that "disables" an image by turning it into a grayscale image, and brightening the pixels in the image. Used by buttons to create an image for a disabled button.

    • 字段摘要

      • Fields inherited from class java.awt.image.RGBImageFilter

        canFilterIndexColorModel, newmodel, origmodel

      • Fields inherited from class java.awt.image.ImageFilter

        consumer

      • 字段 - 继承于接口 java.awt.image.ImageConsumer

        COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT

    • 构造方法摘要

      Constructors
      构造方法与描述
      GrayFilter(boolean b, int p)
      Constructs a GrayFilter object that filters a color image to a grayscale image.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Image createDisabledImage(Image i)
      Creates a disabled image
      int filterRGB(int x, int y, int rgb)
      Overrides RGBImageFilter.filterRGB.

      • 方法 - 继承于类 java.awt.image.RGBImageFilter

        filterIndexColorModel, filterRGBPixels, setColorModel, setPixels, setPixels, substituteColorModel

      • 方法 - 继承于类 java.awt.image.ImageFilter

        clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setDimensions, setHints, setProperties

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GrayFilter

        public GrayFilter(boolean b,
          int p)
        Constructs a GrayFilter object that filters a color image to a grayscale image. Used by buttons to create disabled ("grayed out") button images.
        参数：
        b - a boolean -- true if the pixels should be brightened
        p - an int in the range 0..100 that determines the percentage of gray, where 100 is the darkest gray, and 0 is the lightest

    • 方法详细信息

      • createDisabledImage

        public static Image createDisabledImage(Image i)
        Creates a disabled image

      • filterRGB

        public int filterRGB(int x,
            int y,
            int rgb)
        Overrides RGBImageFilter.filterRGB.
        指定者：
        filterRGB in class RGBImageFilter
        参数：
        x - the X coordinate of the pixel
        y - the Y coordinate of the pixel
        rgb - the integer pixel representation in the default RGB color model
        返回：
        a filtered pixel in the default RGB color model.
        另请参见：
        ColorModel.getRGBdefault(), RGBImageFilter.filterRGBPixels(int, int, int, int, int[], int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ohcPGo#lo#lss#llru//nwoasjaa.CneltFGo>""owon/


GroupLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 GroupLayout

  • java.lang.Object
    • javax.swing.GroupLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2

    public class GroupLayout
extends Object
implements LayoutManager2
    GroupLayout is a LayoutManager that hierarchically groups components in order to position them in a Container. GroupLayout is intended for use by builders, but may be hand-coded as well. Grouping is done by instances of the Group class. GroupLayout supports two types of groups. A sequential group positions its child elements sequentially, one after another. A parallel group aligns its child elements in one of four ways.

    Each group may contain any number of elements, where an element is a Group, Component, or gap. A gap can be thought of as an invisible component with a minimum, preferred and maximum size. In addition GroupLayout supports a preferred gap, whose value comes from LayoutStyle.

    Elements are similar to a spring. Each element has a range as specified by a minimum, preferred and maximum. Gaps have either a developer-specified range, or a range determined by LayoutStyle. The range for Components is determined from the Component's getMinimumSize, getPreferredSize and getMaximumSize methods. In addition, when adding Components you may specify a particular range to use instead of that from the component. The range for a Group is determined by the type of group. A ParallelGroup's range is the maximum of the ranges of its elements. A SequentialGroup's range is the sum of the ranges of its elements.

    GroupLayout treats each axis independently. That is, there is a group representing the horizontal axis, and a group representing the vertical axis. The horizontal group is responsible for determining the minimum, preferred and maximum size along the horizontal axis as well as setting the x and width of the components contained in it. The vertical group is responsible for determining the minimum, preferred and maximum size along the vertical axis as well as setting the y and height of the components contained in it. Each Component must exist in both a horizontal and vertical group, otherwise an IllegalStateException is thrown during layout, or when the minimum, preferred or maximum size is requested.

    The following diagram shows a sequential group along the horizontal axis. The sequential group contains three components. A parallel group was used along the vertical axis.

    To reinforce that each axis is treated independently the diagram shows the range of each group and element along each axis. The range of each component has been projected onto the axes, and the groups are rendered in blue (horizontal) and red (vertical). For readability there is a gap between each of the elements in the sequential group.

    The sequential group along the horizontal axis is rendered as a solid blue line. Notice the sequential group is the sum of the children elements it contains.

    Along the vertical axis the parallel group is the maximum of the height of each of the components. As all three components have the same height, the parallel group has the same height.

    The following diagram shows the same three components, but with the parallel group along the horizontal axis and the sequential group along the vertical axis.

    As c1 is the largest of the three components, the parallel group is sized to c1. As c2 and c3 are smaller than c1 they are aligned based on the alignment specified for the component (if specified) or the default alignment of the parallel group. In the diagram c2 and c3 were created with an alignment of LEADING. If the component orientation were right-to-left then c2 and c3 would be positioned on the opposite side.

    The following diagram shows a sequential group along both the horizontal and vertical axis.

    GroupLayout provides the ability to insert gaps between Components. The size of the gap is determined by an instance of LayoutStyle. This may be turned on using the setAutoCreateGaps method. Similarly, you may use the setAutoCreateContainerGaps method to insert gaps between components that touch the edge of the parent container and the container.

    The following builds a panel consisting of two labels in one column, followed by two textfields in the next column:

       JComponent panel = ...;
   GroupLayout layout = new GroupLayout(panel);
   panel.setLayout(layout);

   // Turn on automatically adding gaps between components
   layout.setAutoCreateGaps(true);

   // Turn on automatically creating gaps between components that touch
   // the edge of the container and the container.
   layout.setAutoCreateContainerGaps(true);

   // Create a sequential group for the horizontal axis.

   GroupLayout.SequentialGroup hGroup = layout.createSequentialGroup();

   // The sequential group in turn contains two parallel groups.
   // One parallel group contains the labels, the other the text fields.
   // Putting the labels in a parallel group along the horizontal axis
   // positions them at the same x location.
   //
   // Variable indentation is used to reinforce the level of grouping.
   hGroup.addGroup(layout.createParallelGroup().
            addComponent(label1).addComponent(label2));
   hGroup.addGroup(layout.createParallelGroup().
            addComponent(tf1).addComponent(tf2));
   layout.setHorizontalGroup(hGroup);

   // Create a sequential group for the vertical axis.
   GroupLayout.SequentialGroup vGroup = layout.createSequentialGroup();

   // The sequential group contains two parallel groups that align
   // the contents along the baseline. The first parallel group contains
   // the first label and text field, and the second parallel group contains
   // the second label and text field. By using a sequential group
   // the labels and text fields are positioned vertically after one another.
   vGroup.addGroup(layout.createParallelGroup(Alignment.BASELINE).
            addComponent(label1).addComponent(tf1));
   vGroup.addGroup(layout.createParallelGroup(Alignment.BASELINE).
            addComponent(label2).addComponent(tf2));
   layout.setVerticalGroup(vGroup);

    When run the following is produced.

    This layout consists of the following.

    • The horizontal axis consists of a sequential group containing two parallel groups. The first parallel group contains the labels, and the second parallel group contains the text fields.
    • The vertical axis consists of a sequential group containing two parallel groups. The parallel groups are configured to align their components along the baseline. The first parallel group contains the first label and first text field, and the second group consists of the second label and second text field.
    There are a couple of things to notice in this code:
    • You need not explicitly add the components to the container; this is indirectly done by using one of the add methods of Group.
    • The various add methods return the caller. This allows for easy chaining of invocations. For example, group.addComponent(label1).addComponent(label2); is equivalent to group.addComponent(label1); group.addComponent(label2);.
    • There are no public constructors for Groups; instead use the create methods of GroupLayout.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  GroupLayout.Alignment
      Enumeration of the possible ways ParallelGroup can align its children.
      class  GroupLayout.Group
      Group provides the basis for the two types of operations supported by GroupLayout: laying out components one after another (SequentialGroup) or aligned (ParallelGroup).
      class  GroupLayout.ParallelGroup
      A Group that aligns and sizes it's children.
      class  GroupLayout.SequentialGroup
      A Group that positions and sizes its elements sequentially, one after another.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DEFAULT_SIZE
      Indicates the size from the component or gap should be used for a particular range value.
      static int PREFERRED_SIZE
      Indicates the preferred size from the component or gap should be used for a particular range value.

    • 构造方法摘要

      Constructors
      构造方法与描述
      GroupLayout(Container host)
      Creates a GroupLayout for the specified Container.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component component, Object constraints)
      Notification that a Component has been added to the parent container.
      void addLayoutComponent(String name, Component component)
      Notification that a Component has been added to the parent container.
      GroupLayout.ParallelGroup createBaselineGroup(boolean resizable, boolean anchorBaselineToTop)
      Creates and returns a ParallelGroup that aligns it's elements along the baseline.
      GroupLayout.ParallelGroup createParallelGroup()
      Creates and returns a ParallelGroup with an alignment of Alignment.LEADING.
      GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment)
      Creates and returns a ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment, boolean resizable)
      Creates and returns a ParallelGroup with the specified alignment and resize behavior.
      GroupLayout.SequentialGroup createSequentialGroup()
      Creates and returns a SequentialGroup.
      boolean getAutoCreateContainerGaps()
      Returns true if gaps between the container and components that border the container are automatically created.
      boolean getAutoCreateGaps()
      Returns true if gaps between components are automatically created.
      boolean getHonorsVisibility()
      Returns whether component visiblity is considered when sizing and positioning components.
      float getLayoutAlignmentX(Container parent)
      Returns the alignment along the x axis.
      float getLayoutAlignmentY(Container parent)
      Returns the alignment along the y axis.
      LayoutStyle getLayoutStyle()
      Returns the LayoutStyle used for calculating the preferred gap between components.
      void invalidateLayout(Container parent)
      Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
      void layoutContainer(Container parent)
      Lays out the specified container.
      void linkSize(Component... components)
      Forces the specified components to have the same size regardless of their preferred, minimum or maximum sizes.
      void linkSize(int axis, Component... components)
      Forces the specified components to have the same size along the specified axis regardless of their preferred, minimum or maximum sizes.
      Dimension maximumLayoutSize(Container parent)
      Returns the maximum size for the specified container.
      Dimension minimumLayoutSize(Container parent)
      Returns the minimum size for the specified container.
      Dimension preferredLayoutSize(Container parent)
      Returns the preferred size for the specified container.
      void removeLayoutComponent(Component component)
      Notification that a Component has been removed from the parent container.
      void replace(Component existingComponent, Component newComponent)
      Replaces an existing component with a new one.
      void setAutoCreateContainerGaps(boolean autoCreateContainerPadding)
      Sets whether a gap between the container and components that touch the border of the container should automatically be created.
      void setAutoCreateGaps(boolean autoCreatePadding)
      Sets whether a gap between components should automatically be created.
      void setHonorsVisibility(boolean honorsVisibility)
      Sets whether component visiblity is considered when sizing and positioning components.
      void setHonorsVisibility(Component component, Boolean honorsVisibility)
      Sets whether the component's visiblity is considered for sizing and positioning.
      void setHorizontalGroup(GroupLayout.Group group)
      Sets the Group that positions and sizes components along the horizontal axis.
      void setLayoutStyle(LayoutStyle layoutStyle)
      Sets the LayoutStyle used to calculate the preferred gaps between components.
      void setVerticalGroup(GroupLayout.Group group)
      Sets the Group that positions and sizes components along the vertical axis.
      String toString()
      Returns a string representation of this GroupLayout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT_SIZE

        public static final int DEFAULT_SIZE
        Indicates the size from the component or gap should be used for a particular range value.
        另请参见：
        GroupLayout.Group, Constant Field Values

      • PREFERRED_SIZE

        public static final int PREFERRED_SIZE
        Indicates the preferred size from the component or gap should be used for a particular range value.
        另请参见：
        GroupLayout.Group, Constant Field Values

    • 构造方法详细信息

      • GroupLayout

        public GroupLayout(Container host)
        Creates a GroupLayout for the specified Container.
        参数：
        host - the Container the GroupLayout is the LayoutManager for
        抛出：
        IllegalArgumentException - if host is null

    • 方法详细信息

      • setHonorsVisibility

        public void setHonorsVisibility(boolean honorsVisibility)
        Sets whether component visiblity is considered when sizing and positioning components. A value of true indicates that non-visible components should not be treated as part of the layout. A value of false indicates that components should be positioned and sized regardless of visibility.

        A value of false is useful when the visibility of components is dynamically adjusted and you don't want surrounding components and the sizing to change.

        The specified value is used for components that do not have an explicit visibility specified.

        The default is true.

        参数：
        honorsVisibility - whether component visiblity is considered when sizing and positioning components
        另请参见：
        setHonorsVisibility(Component,Boolean)

      • getHonorsVisibility

        public boolean getHonorsVisibility()
        Returns whether component visiblity is considered when sizing and positioning components.
        返回：
        whether component visiblity is considered when sizing and positioning components

      • setHonorsVisibility

        public void setHonorsVisibility(Component component,
                       Boolean honorsVisibility)
        Sets whether the component's visiblity is considered for sizing and positioning. A value of Boolean.TRUE indicates that if component is not visible it should not be treated as part of the layout. A value of false indicates that component is positioned and sized regardless of it's visibility. A value of null indicates the value specified by the single argument method setHonorsVisibility should be used.

        If component is not a child of the Container this GroupLayout is managine, it will be added to the Container.

        参数：
        component - the component
        honorsVisibility - whether component's visiblity should be considered for sizing and positioning
        抛出：
        IllegalArgumentException - if component is null
        另请参见：
        setHonorsVisibility(Component,Boolean)

      • setAutoCreateGaps

        public void setAutoCreateGaps(boolean autoCreatePadding)
        Sets whether a gap between components should automatically be created. For example, if this is true and you add two components to a SequentialGroup a gap between the two components is automatically be created. The default is false.
        参数：
        autoCreatePadding - whether a gap between components is automatically created

      • getAutoCreateGaps

        public boolean getAutoCreateGaps()
        Returns true if gaps between components are automatically created.
        返回：
        true if gaps between components are automatically created

      • setAutoCreateContainerGaps

        public void setAutoCreateContainerGaps(boolean autoCreateContainerPadding)
        Sets whether a gap between the container and components that touch the border of the container should automatically be created. The default is false.
        参数：
        autoCreateContainerPadding - whether a gap between the container and components that touch the border of the container should automatically be created

      • getAutoCreateContainerGaps

        public boolean getAutoCreateContainerGaps()
        Returns true if gaps between the container and components that border the container are automatically created.
        返回：
        true if gaps between the container and components that border the container are automatically created

      • setHorizontalGroup

        public void setHorizontalGroup(GroupLayout.Group group)
        Sets the Group that positions and sizes components along the horizontal axis.
        参数：
        group - the Group that positions and sizes components along the horizontal axis
        抛出：
        IllegalArgumentException - if group is null

      • setVerticalGroup

        public void setVerticalGroup(GroupLayout.Group group)
        Sets the Group that positions and sizes components along the vertical axis.
        参数：
        group - the Group that positions and sizes components along the vertical axis
        抛出：
        IllegalArgumentException - if group is null

      • createSequentialGroup

        public GroupLayout.SequentialGroup createSequentialGroup()
        Creates and returns a SequentialGroup.
        返回：
        a new SequentialGroup

      • createParallelGroup

        public GroupLayout.ParallelGroup createParallelGroup()
        Creates and returns a ParallelGroup with an alignment of Alignment.LEADING. This is a cover method for the more general createParallelGroup(Alignment) method.
        返回：
        a new ParallelGroup
        另请参见：
        createParallelGroup(Alignment)

      • createParallelGroup

        public GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment)
        Creates and returns a ParallelGroup with the specified alignment. This is a cover method for the more general createParallelGroup(Alignment,boolean) method with true supplied for the second argument.
        参数：
        alignment - the alignment for the elements of the group
        返回：
        a new ParallelGroup
        抛出：
        IllegalArgumentException - if alignment is null
        另请参见：
        createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

      • createParallelGroup

        public GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment,
                                            boolean resizable)
        Creates and returns a ParallelGroup with the specified alignment and resize behavior. The alignment argument specifies how children elements are positioned that do not fill the group. For example, if a ParallelGroup with an alignment of TRAILING is given 100 and a child only needs 50, the child is positioned at the position 50 (with a component orientation of left-to-right).

        Baseline alignment is only useful when used along the vertical axis. A ParallelGroup created with a baseline alignment along the horizontal axis is treated as LEADING.

        Refer to ParallelGroup for details on the behavior of baseline groups.

        参数：
        alignment - the alignment for the elements of the group
        resizable - true if the group is resizable; if the group is not resizable the preferred size is used for the minimum and maximum size of the group
        返回：
        a new ParallelGroup
        抛出：
        IllegalArgumentException - if alignment is null
        另请参见：
        createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

      • createBaselineGroup

        public GroupLayout.ParallelGroup createBaselineGroup(boolean resizable,
                                            boolean anchorBaselineToTop)
        Creates and returns a ParallelGroup that aligns it's elements along the baseline.
        参数：
        resizable - whether the group is resizable
        anchorBaselineToTop - whether the baseline is anchored to the top or bottom of the group
        另请参见：
        createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

      • linkSize

        public void linkSize(Component... components)
        Forces the specified components to have the same size regardless of their preferred, minimum or maximum sizes. Components that are linked are given the maximum of the preferred size of each of the linked components. For example, if you link two components with a preferred width of 10 and 20, both components are given a width of 20.

        This can be used multiple times to force any number of components to share the same size.

        Linked Components are not be resizable.

        参数：
        components - the Components that are to have the same size
        抛出：
        IllegalArgumentException - if components is null, or contains null
        另请参见：
        linkSize(int,Component[])

      • linkSize

        public void linkSize(int axis,
            Component... components)
        Forces the specified components to have the same size along the specified axis regardless of their preferred, minimum or maximum sizes. Components that are linked are given the maximum of the preferred size of each of the linked components. For example, if you link two components along the horizontal axis and the preferred width is 10 and 20, both components are given a width of 20.

        This can be used multiple times to force any number of components to share the same size.

        Linked Components are not be resizable.

        参数：
        components - the Components that are to have the same size
        axis - the axis to link the size along; one of SwingConstants.HORIZONTAL or SwingConstans.VERTICAL
        抛出：
        IllegalArgumentException - if components is null, or contains null; or axis is not SwingConstants.HORIZONTAL or SwingConstants.VERTICAL

      • replace

        public void replace(Component existingComponent,
           Component newComponent)
        Replaces an existing component with a new one.
        参数：
        existingComponent - the component that should be removed and replaced with newComponent
        newComponent - the component to put in existingComponent's place
        抛出：
        IllegalArgumentException - if either of the components are null or existingComponent is not being managed by this layout manager

      • setLayoutStyle

        public void setLayoutStyle(LayoutStyle layoutStyle)
        Sets the LayoutStyle used to calculate the preferred gaps between components. A value of null indicates the shared instance of LayoutStyle should be used.
        参数：
        layoutStyle - the LayoutStyle to use
        另请参见：
        LayoutStyle

      • getLayoutStyle

        public LayoutStyle getLayoutStyle()
        Returns the LayoutStyle used for calculating the preferred gap between components. This returns the value specified to setLayoutStyle, which may be null.
        返回：
        the LayoutStyle used for calculating the preferred gap between components

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component component)
        Notification that a Component has been added to the parent container. You should not invoke this method directly, instead you should use one of the Group methods to add a Component.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        component - the Component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component component)
        Notification that a Component has been removed from the parent container. You should not invoke this method directly, instead invoke remove on the parent Container.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        component - the component to be removed
        另请参见：
        Component.remove(java.awt.MenuComponent)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        Returns the preferred size for the specified container.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the container to return the preferred size for
        返回：
        the preferred size for parent
        抛出：
        IllegalArgumentException - if parent is not the same Container this was created with
        IllegalStateException - if any of the components added to this layout are not in both a horizontal and vertical group
        另请参见：
        Container.getPreferredSize()

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        Returns the minimum size for the specified container.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the container to return the size for
        返回：
        the minimum size for parent
        抛出：
        IllegalArgumentException - if parent is not the same Container that this was created with
        IllegalStateException - if any of the components added to this layout are not in both a horizontal and vertical group
        另请参见：
        Container.getMinimumSize()

      • layoutContainer

        public void layoutContainer(Container parent)
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to be laid out
        抛出：
        IllegalStateException - if any of the components added to this layout are not in both a horizontal and vertical group

      • addLayoutComponent

        public void addLayoutComponent(Component component,
                      Object constraints)
        Notification that a Component has been added to the parent container. You should not invoke this method directly, instead you should use one of the Group methods to add a Component.
        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        component - the component added
        constraints - description of where to place the component

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container parent)
        Returns the maximum size for the specified container.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        参数：
        parent - the container to return the size for
        返回：
        the maximum size for parent
        抛出：
        IllegalArgumentException - if parent is not the same Container that this was created with
        IllegalStateException - if any of the components added to this layout are not in both a horizontal and vertical group
        另请参见：
        Container.getMaximumSize()

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container parent)
        Returns the alignment along the x axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentX in interface LayoutManager2
        参数：
        parent - the Container hosting this LayoutManager
        返回：
        the alignment; this implementation returns .5
        抛出：
        IllegalArgumentException - if parent is not the same Container that this was created with

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container parent)
        Returns the alignment along the y axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentY in interface LayoutManager2
        参数：
        parent - the Container hosting this LayoutManager
        返回：
        alignment; this implementation returns .5
        抛出：
        IllegalArgumentException - if parent is not the same Container that this was created with

      • invalidateLayout

        public void invalidateLayout(Container parent)
        Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
        指定者：
        invalidateLayout in interface LayoutManager2
        参数：
        parent - the Container hosting this LayoutManager
        抛出：
        IllegalArgumentException - if parent is not the same Container that this was created with

      • toString

        public String toString()
        Returns a string representation of this GroupLayout. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class Object
        返回：
        a string representation of this GroupLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GroupLayout.Alignment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum GroupLayout.Alignment

  • java.lang.Object
    • java.lang.Enum<GroupLayout.Alignment>
      • javax.swing.GroupLayout.Alignment
  • 所有已实现的接口：
    Serializable, Comparable<GroupLayout.Alignment>
    封闭类：
    GroupLayout

    public static enum GroupLayout.Alignment
extends Enum<GroupLayout.Alignment>
    Enumeration of the possible ways ParallelGroup can align its children.
    从以下版本开始：
    1.6
    另请参见：
    GroupLayout.createParallelGroup(Alignment)

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      BASELINE
      Indicates the elements should be aligned along their baseline.
      CENTER
      Indicates the elements should be centered in the region.
      LEADING
      Indicates the elements should be aligned to the origin.
      TRAILING
      Indicates the elements should be aligned to the end of the region.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static GroupLayout.Alignment valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static GroupLayout.Alignment[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • LEADING

        public static final GroupLayout.Alignment LEADING
        Indicates the elements should be aligned to the origin. For the horizontal axis with a left to right orientation this means aligned to the left edge. For the vertical axis leading means aligned to the top edge.
        另请参见：
        GroupLayout.createParallelGroup(Alignment)

      • TRAILING

        public static final GroupLayout.Alignment TRAILING
        Indicates the elements should be aligned to the end of the region. For the horizontal axis with a left to right orientation this means aligned to the right edge. For the vertical axis trailing means aligned to the bottom edge.
        另请参见：
        GroupLayout.createParallelGroup(Alignment)

      • CENTER

        public static final GroupLayout.Alignment CENTER
        Indicates the elements should be centered in the region.
        另请参见：
        GroupLayout.createParallelGroup(Alignment)

      • BASELINE

        public static final GroupLayout.Alignment BASELINE
        Indicates the elements should be aligned along their baseline.
        另请参见：
        GroupLayout.createParallelGroup(Alignment), GroupLayout.createBaselineGroup(boolean,boolean)

    • 方法详细信息

      • values

        public static GroupLayout.Alignment[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (GroupLayout.Alignment c : GroupLayout.Alignment.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static GroupLayout.Alignment valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slematwtajvvajjwnllbo teo=amssFaan.na


GroupLayout.Group

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 GroupLayout.Group

  • java.lang.Object
    • javax.swing.GroupLayout.Group
  • 直接已知子类：
    GroupLayout.ParallelGroup, GroupLayout.SequentialGroup
    封闭类：
    GroupLayout

    public abstract class GroupLayout.Group
extends Object
    Group provides the basis for the two types of operations supported by GroupLayout: laying out components one after another (SequentialGroup) or aligned (ParallelGroup). Group and its subclasses have no public constructor; to create one use one of createSequentialGroup or createParallelGroup. Additionally, taking a Group created from one GroupLayout and using it with another will produce undefined results.

    Various methods in Group and its subclasses allow you to explicitly specify the range. The arguments to these methods can take two forms, either a value greater than or equal to 0, or one of DEFAULT_SIZE or PREFERRED_SIZE. A value greater than or equal to 0 indicates a specific size. DEFAULT_SIZE indicates the corresponding size from the component should be used. For example, if DEFAULT_SIZE is passed as the minimum size argument, the minimum size is obtained from invoking getMinimumSize on the component. Likewise, PREFERRED_SIZE indicates the value from getPreferredSize should be used. The following example adds myComponent to group with specific values for the range. That is, the minimum is explicitly specified as 100, preferred as 200, and maximum as 300.

       group.addComponent(myComponent, 100, 200, 300);
    The following example adds myComponent to group using a combination of the forms. The minimum size is forced to be the same as the preferred size, the preferred size is determined by using myComponent.getPreferredSize and the maximum is determined by invoking getMaximumSize on the component.
       group.addComponent(myComponent, GroupLayout.PREFERRED_SIZE,
             GroupLayout.PREFERRED_SIZE, GroupLayout.DEFAULT_SIZE);

    Unless otherwise specified all the methods of Group and its subclasses that allow you to specify a range throw an IllegalArgumentException if passed an invalid range. An invalid range is one in which any of the values are < 0 and not one of PREFERRED_SIZE or DEFAULT_SIZE, or the following is not met (for specific values): min <= pref <= max.

    Similarly any methods that take a Component throw a IllegalArgumentException if passed null and any methods that take a Group throw an NullPointerException if passed null.

    从以下版本开始：
    1.6
    另请参见：
    GroupLayout.createSequentialGroup(), GroupLayout.createParallelGroup()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      GroupLayout.Group addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.Group addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.Group addGap(int size)
      Adds a rigid gap to this Group.
      GroupLayout.Group addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.Group addGroup(GroupLayout.Group group)
      Adds a Group to this Group.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • addGroup

        public GroupLayout.Group addGroup(GroupLayout.Group group)
        Adds a Group to this Group.
        参数：
        group - the Group to add
        返回：
        this Group

      • addComponent

        public GroupLayout.Group addComponent(Component component)
        Adds a Component to this Group.
        参数：
        component - the Component to add
        返回：
        this Group

      • addComponent

        public GroupLayout.Group addComponent(Component component,
                             int min,
                             int pref,
                             int max)
        Adds a Component to this Group with the specified size.
        参数：
        component - the Component to add
        min - the minimum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        pref - the preferred size or one of DEFAULT_SIZE or PREFERRED_SIZE
        max - the maximum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        返回：
        this Group

      • addGap

        public GroupLayout.Group addGap(int size)
        Adds a rigid gap to this Group.
        参数：
        size - the size of the gap
        返回：
        this Group
        抛出：
        IllegalArgumentException - if size is less than 0

      • addGap

        public GroupLayout.Group addGap(int min,
                       int pref,
                       int max)
        Adds a gap to this Group with the specified size.
        参数：
        min - the minimum size of the gap
        pref - the preferred size of the gap
        max - the maximum size of the gap
        返回：
        this Group
        抛出：
        IllegalArgumentException - if any of the values are less than 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=<=tokeck=s""=ss saaed/<<>� atv><"=c


GroupLayout.ParallelGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 GroupLayout.ParallelGroup

  • java.lang.Object
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
  • 封闭类：
    GroupLayout

    public class GroupLayout.ParallelGroup
extends GroupLayout.Group
    A Group that aligns and sizes it's children. ParallelGroup aligns it's children in four possible ways: along the baseline, centered, anchored to the leading edge, or anchored to the trailing edge.

    Baseline

    A ParallelGroup that aligns it's children along the baseline must first decide where the baseline is anchored. The baseline can either be anchored to the top, or anchored to the bottom of the group. That is, the distance between the baseline and the beginning of the group can be a constant distance, or the distance between the end of the group and the baseline can be a constant distance. The possible choices correspond to the BaselineResizeBehavior constants CONSTANT_ASCENT and CONSTANT_DESCENT.

    The baseline anchor may be explicitly specified by the createBaselineGroup method, or determined based on the elements. If not explicitly specified, the baseline will be anchored to the bottom if all the elements with a baseline, and that are aligned to the baseline, have a baseline resize behavior of CONSTANT_DESCENT; otherwise the baseline is anchored to the top of the group.

    Elements aligned to the baseline are resizable if they have have a baseline resize behavior of CONSTANT_ASCENT or CONSTANT_DESCENT. Elements with a baseline resize behavior of OTHER or CENTER_OFFSET are not resizable.

    The baseline is calculated based on the preferred height of each of the elements that have a baseline. The baseline is calculated using the following algorithm: max(maxNonBaselineHeight, maxAscent + maxDescent), where the maxNonBaselineHeight is the maximum height of all elements that do not have a baseline, or are not aligned along the baseline. maxAscent is the maximum ascent (baseline) of all elements that have a baseline and are aligned along the baseline. maxDescent is the maximum descent (preferred height - baseline) of all elements that have a baseline and are aligned along the baseline.

    A ParallelGroup that aligns it's elements along the baseline is only useful along the vertical axis. If you create a baseline group and use it along the horizontal axis an IllegalStateException is thrown when you ask GroupLayout for the minimum, preferred or maximum size or attempt to layout the components.

    Elements that are not aligned to the baseline and smaller than the size of the ParallelGroup are positioned in one of three ways: centered, anchored to the leading edge, or anchored to the trailing edge.

    Non-baseline ParallelGroup

    ParallelGroups created with an alignment other than BASELINE align elements that are smaller than the size of the group in one of three ways: centered, anchored to the leading edge, or anchored to the trailing edge.

    The leading edge is based on the axis and ComponentOrientation. For the vertical axis the top edge is always the leading edge, and the bottom edge is always the trailing edge. When the ComponentOrientation is LEFT_TO_RIGHT, the leading edge is the left edge and the trailing edge the right edge. A ComponentOrientation of RIGHT_TO_LEFT flips the left and right edges. Child elements are aligned based on the specified alignment the element was added with. If you do not specify an alignment, the alignment specified for the ParallelGroup is used.

    To align elements along the baseline you createBaselineGroup, or createParallelGroup with an alignment of BASELINE. If the group was not created with a baseline alignment, and you attempt to add an element specifying a baseline alignment, an IllegalArgumentException is thrown.

    从以下版本开始：
    1.6
    另请参见：
    GroupLayout.createParallelGroup(), GroupLayout.createBaselineGroup(boolean,boolean)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      GroupLayout.ParallelGroup addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.ParallelGroup addComponent(Component component, GroupLayout.Alignment alignment)
      Adds a Component to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
      Adds a Component to this ParallelGroup with the specified alignment and size.
      GroupLayout.ParallelGroup addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.ParallelGroup addGap(int pref)
      Adds a rigid gap to this Group.
      GroupLayout.ParallelGroup addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.ParallelGroup addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group)
      Adds a Group to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup addGroup(GroupLayout.Group group)
      Adds a Group to this Group.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • addGroup

        public GroupLayout.ParallelGroup addGroup(GroupLayout.Group group)
        Adds a Group to this Group.
        重载：
        addGroup in class GroupLayout.Group
        参数：
        group - the Group to add
        返回：
        this Group

      • addComponent

        public GroupLayout.ParallelGroup addComponent(Component component)
        Adds a Component to this Group.
        重载：
        addComponent in class GroupLayout.Group
        参数：
        component - the Component to add
        返回：
        this Group

      • addComponent

        public GroupLayout.ParallelGroup addComponent(Component component,
                                     int min,
                                     int pref,
                                     int max)
        Adds a Component to this Group with the specified size.
        重载：
        addComponent in class GroupLayout.Group
        参数：
        component - the Component to add
        min - the minimum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        pref - the preferred size or one of DEFAULT_SIZE or PREFERRED_SIZE
        max - the maximum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        返回：
        this Group

      • addGap

        public GroupLayout.ParallelGroup addGap(int pref)
        Adds a rigid gap to this Group.
        重载：
        addGap in class GroupLayout.Group
        参数：
        pref - the size of the gap
        返回：
        this Group

      • addGap

        public GroupLayout.ParallelGroup addGap(int min,
                               int pref,
                               int max)
        Adds a gap to this Group with the specified size.
        重载：
        addGap in class GroupLayout.Group
        参数：
        min - the minimum size of the gap
        pref - the preferred size of the gap
        max - the maximum size of the gap
        返回：
        this Group

      • addGroup

        public GroupLayout.ParallelGroup addGroup(GroupLayout.Alignment alignment,
                                 GroupLayout.Group group)
        Adds a Group to this ParallelGroup with the specified alignment. If the child is smaller than the Group it is aligned based on the specified alignment.
        参数：
        alignment - the alignment
        group - the Group to add
        返回：
        this ParallelGroup
        抛出：
        IllegalArgumentException - if alignment is null

      • addComponent

        public GroupLayout.ParallelGroup addComponent(Component component,
                                     GroupLayout.Alignment alignment)
        Adds a Component to this ParallelGroup with the specified alignment.
        参数：
        alignment - the alignment
        component - the Component to add
        返回：
        this Group
        抛出：
        IllegalArgumentException - if alignment is null

      • addComponent

        public GroupLayout.ParallelGroup addComponent(Component component,
                                     GroupLayout.Alignment alignment,
                                     int min,
                                     int pref,
                                     int max)
        Adds a Component to this ParallelGroup with the specified alignment and size.
        参数：
        alignment - the alignment
        component - the Component to add
        min - the minimum size
        pref - the preferred size
        max - the maximum size
        返回：
        this Group
        抛出：
        IllegalArgumentException - if alignment is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cdojs "s "=cc"==traaavo(iiaer/<


GroupLayout.SequentialGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 GroupLayout.SequentialGroup

  • java.lang.Object
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.SequentialGroup
  • 封闭类：
    GroupLayout

    public class GroupLayout.SequentialGroup
extends GroupLayout.Group
    A Group that positions and sizes its elements sequentially, one after another. This class has no public constructor, use the createSequentialGroup method to create one.

    In order to align a SequentialGroup along the baseline of a baseline aligned ParallelGroup you need to specify which of the elements of the SequentialGroup is used to determine the baseline. The element used to calculate the baseline is specified using one of the add methods that take a boolean. The last element added with a value of true for useAsBaseline is used to calculate the baseline.

    从以下版本开始：
    1.6
    另请参见：
    GroupLayout.createSequentialGroup()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      GroupLayout.SequentialGroup addComponent(boolean useAsBaseline, Component component)
      Adds a Component to this Group.
      GroupLayout.SequentialGroup addComponent(boolean useAsBaseline, Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.SequentialGroup addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.SequentialGroup addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.SequentialGroup addContainerGap()
      Adds an element representing the preferred gap between an edge the container and components that touch the border of the container.
      GroupLayout.SequentialGroup addContainerGap(int pref, int max)
      Adds an element representing the preferred gap between one edge of the container and the next or previous Component with the specified size.
      GroupLayout.SequentialGroup addGap(int size)
      Adds a rigid gap to this Group.
      GroupLayout.SequentialGroup addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.SequentialGroup addGroup(boolean useAsBaseline, GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.SequentialGroup addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.SequentialGroup addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between the nearest components.
      GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between the nearest components.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • addGroup

        public GroupLayout.SequentialGroup addGroup(GroupLayout.Group group)
        Adds a Group to this Group.
        重载：
        addGroup in class GroupLayout.Group
        参数：
        group - the Group to add
        返回：
        this Group

      • addGroup

        public GroupLayout.SequentialGroup addGroup(boolean useAsBaseline,
                                   GroupLayout.Group group)
        Adds a Group to this Group.
        参数：
        group - the Group to add
        useAsBaseline - whether the specified Group should be used to calculate the baseline for this Group
        返回：
        this Group

      • addComponent

        public GroupLayout.SequentialGroup addComponent(Component component)
        Adds a Component to this Group.
        重载：
        addComponent in class GroupLayout.Group
        参数：
        component - the Component to add
        返回：
        this Group

      • addComponent

        public GroupLayout.SequentialGroup addComponent(boolean useAsBaseline,
                                       Component component)
        Adds a Component to this Group.
        参数：
        useAsBaseline - whether the specified Component should be used to calculate the baseline for this Group
        component - the Component to add
        返回：
        this Group

      • addComponent

        public GroupLayout.SequentialGroup addComponent(Component component,
                                       int min,
                                       int pref,
                                       int max)
        Adds a Component to this Group with the specified size.
        重载：
        addComponent in class GroupLayout.Group
        参数：
        component - the Component to add
        min - the minimum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        pref - the preferred size or one of DEFAULT_SIZE or PREFERRED_SIZE
        max - the maximum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        返回：
        this Group

      • addComponent

        public GroupLayout.SequentialGroup addComponent(boolean useAsBaseline,
                                       Component component,
                                       int min,
                                       int pref,
                                       int max)
        Adds a Component to this Group with the specified size.
        参数：
        useAsBaseline - whether the specified Component should be used to calculate the baseline for this Group
        component - the Component to add
        min - the minimum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        pref - the preferred size or one of DEFAULT_SIZE or PREFERRED_SIZE
        max - the maximum size or one of DEFAULT_SIZE or PREFERRED_SIZE
        返回：
        this Group

      • addGap

        public GroupLayout.SequentialGroup addGap(int size)
        Adds a rigid gap to this Group.
        重载：
        addGap in class GroupLayout.Group
        参数：
        size - the size of the gap
        返回：
        this Group

      • addGap

        public GroupLayout.SequentialGroup addGap(int min,
                                 int pref,
                                 int max)
        Adds a gap to this Group with the specified size.
        重载：
        addGap in class GroupLayout.Group
        参数：
        min - the minimum size of the gap
        pref - the preferred size of the gap
        max - the maximum size of the gap
        返回：
        this Group

      • addPreferredGap

        public GroupLayout.SequentialGroup addPreferredGap(JComponent comp1,
                                          JComponent comp2,
                                          LayoutStyle.ComponentPlacement type)
        Adds an element representing the preferred gap between two components. The element created to represent the gap is not resizable.
        参数：
        comp1 - the first component
        comp2 - the second component
        type - the type of gap; one of the constants defined by LayoutStyle
        返回：
        this SequentialGroup
        抛出：
        IllegalArgumentException - if type, comp1 or comp2 is null
        另请参见：
        LayoutStyle

      • addPreferredGap

        public GroupLayout.SequentialGroup addPreferredGap(JComponent comp1,
                                          JComponent comp2,
                                          LayoutStyle.ComponentPlacement type,
                                          int pref,
                                          int max)
        Adds an element representing the preferred gap between two components.
        参数：
        comp1 - the first component
        comp2 - the second component
        type - the type of gap
        pref - the preferred size of the grap; one of DEFAULT_SIZE or a value >= 0
        max - the maximum size of the gap; one of DEFAULT_SIZE, PREFERRED_SIZE or a value >= 0
        返回：
        this SequentialGroup
        抛出：
        IllegalArgumentException - if type, comp1 or comp2 is null
        另请参见：
        LayoutStyle

      • addPreferredGap

        public GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type)
        Adds an element representing the preferred gap between the nearest components. During layout, neighboring components are found, and the size of the added gap is set based on the preferred gap between the components. If no neighboring components are found the gap has a size of 0.

        The element created to represent the gap is not resizable.

        参数：
        type - the type of gap; one of LayoutStyle.ComponentPlacement.RELATED or LayoutStyle.ComponentPlacement.UNRELATED
        返回：
        this SequentialGroup
        抛出：
        IllegalArgumentException - if type is not one of LayoutStyle.ComponentPlacement.RELATED or LayoutStyle.ComponentPlacement.UNRELATED
        另请参见：
        LayoutStyle

      • addPreferredGap

        public GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type,
                                          int pref,
                                          int max)
        Adds an element representing the preferred gap between the nearest components. During layout, neighboring components are found, and the minimum of this gap is set based on the size of the preferred gap between the neighboring components. If no neighboring components are found the minimum size is set to 0.
        参数：
        type - the type of gap; one of LayoutStyle.ComponentPlacement.RELATED or LayoutStyle.ComponentPlacement.UNRELATED
        pref - the preferred size of the grap; one of DEFAULT_SIZE or a value >= 0
        max - the maximum size of the gap; one of DEFAULT_SIZE, PREFERRED_SIZE or a value >= 0
        返回：
        this SequentialGroup
        抛出：
        IllegalArgumentException - if type is not one of LayoutStyle.ComponentPlacement.RELATED or LayoutStyle.ComponentPlacement.UNRELATED
        另请参见：
        LayoutStyle

      • addContainerGap

        public GroupLayout.SequentialGroup addContainerGap()
        Adds an element representing the preferred gap between an edge the container and components that touch the border of the container. This has no effect if the added gap does not touch an edge of the parent container.

        The element created to represent the gap is not resizable.

        返回：
        this SequentialGroup

      • addContainerGap

        public GroupLayout.SequentialGroup addContainerGap(int pref,
                                          int max)
        Adds an element representing the preferred gap between one edge of the container and the next or previous Component with the specified size. This has no effect if the next or previous element is not a Component and does not touch one edge of the parent container.
        参数：
        pref - the preferred size; one of DEFAULT_SIZE or a value >= 0
        max - the maximum size; one of DEFAULT_SIZE, PREFERRED_SIZE or a value >= 0
        返回：
        this SequentialGroup
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Icon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface Icon

  • All Known Implementing Classes:
    IconUIResource, ImageIcon, MetalCheckBoxIcon, MetalComboBoxIcon, MetalIconFactory.FileIcon16, MetalIconFactory.FolderIcon16, MetalIconFactory.PaletteCloseIcon, MetalIconFactory.TreeControlIcon, MetalIconFactory.TreeFolderIcon, MetalIconFactory.TreeLeafIcon

    public interface Icon
    A small fixed size picture, typically used to decorate components.
    另请参见：
    ImageIcon

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

    • 方法详细信息

      • paintIcon

        void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.

      • getIconWidth

        int getIconWidth()
        Returns the icon's width.
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        int getIconHeight()
        Returns the icon's height.
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tGr"oLslLss==sssd


ImageIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ImageIcon

  • java.lang.Object
    • javax.swing.ImageIcon
  • 所有已实现的接口：
    Serializable, Accessible, Icon

    public class ImageIcon
extends Object
implements Icon, Serializable, Accessible
    An implementation of the Icon interface that paints Icons from Images. Images that are created from a URL, filename or byte array are preloaded using MediaTracker to monitor the loaded state of the image.

    For further information and examples of using image icons, see How to Use Icons in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  ImageIcon.AccessibleImageIcon
      This class implements accessibility support for the ImageIcon class.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Component | component
      protected static MediaTracker | tracker

    • 构造方法摘要

      Constructors
      构造方法与描述
      ImageIcon()
      Creates an uninitialized image icon.
      ImageIcon(byte[] imageData)
      Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
      ImageIcon(byte[] imageData, String description)
      Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
      ImageIcon(Image image)
      Creates an ImageIcon from an image object.
      ImageIcon(Image image, String description)
      Creates an ImageIcon from the image.
      ImageIcon(String filename)
      Creates an ImageIcon from the specified file.
      ImageIcon(String filename, String description)
      Creates an ImageIcon from the specified file.
      ImageIcon(URL location)
      Creates an ImageIcon from the specified URL.
      ImageIcon(URL location, String description)
      Creates an ImageIcon from the specified URL.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this ImageIcon.
      String getDescription()
      Gets the description of the image.
      int getIconHeight()
      Gets the height of the icon.
      int getIconWidth()
      Gets the width of the icon.
      Image getImage()
      Returns this icon's Image.
      int getImageLoadStatus()
      Returns the status of the image loading operation.
      ImageObserver getImageObserver()
      Returns the image observer for the image.
      protected void loadImage(Image image)
      Loads the image, returning only when the image is loaded.
      void paintIcon(Component c, Graphics g, int x, int y)
      Paints the icon.
      void setDescription(String description)
      Sets the description of the image.
      void setImage(Image image)
      Sets the image displayed by this icon.
      void setImageObserver(ImageObserver observer)
      Sets the image observer for the image.
      String toString()
      Returns a string representation of this image.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • component

        protected static final Component component

      • tracker

        protected static final MediaTracker tracker

    • 构造方法详细信息

      • ImageIcon

        public ImageIcon(String filename,
         String description)
        Creates an ImageIcon from the specified file. The image will be preloaded by using MediaTracker to monitor the loading state of the image.
        参数：
        filename - the name of the file containing the image
        描述 - a brief textual description of the image
        另请参见：
        ImageIcon(String)

      • ImageIcon

        @ConstructorProperties(value="description")
public ImageIcon(String filename)
        Creates an ImageIcon from the specified file. The image will be preloaded by using MediaTracker to monitor the loading state of the image. The specified String can be a file name or a file path. When specifying a path, use the Internet-standard forward-slash ("/") as a separator. (The string is converted to an URL, so the forward-slash works on all systems.) For example, specify:
            new ImageIcon("images/myImage.gif")
        The description is initialized to the filename string.
        参数：
        filename - a String specifying a filename or path
        另请参见：
        getDescription()

      • ImageIcon

        public ImageIcon(URL location,
         String description)
        Creates an ImageIcon from the specified URL. The image will be preloaded by using MediaTracker to monitor the loaded state of the image.
        参数：
        location - the URL for the image
        描述 - a brief textual description of the image
        另请参见：
        ImageIcon(String)

      • ImageIcon

        public ImageIcon(URL location)
        Creates an ImageIcon from the specified URL. The image will be preloaded by using MediaTracker to monitor the loaded state of the image. The icon's description is initialized to be a string representation of the URL.
        参数：
        location - the URL for the image
        另请参见：
        getDescription()

      • ImageIcon

        public ImageIcon(Image image,
         String description)
        Creates an ImageIcon from the image.
        参数：
        image - the image
        描述 - a brief textual description of the image

      • ImageIcon

        public ImageIcon(Image image)
        Creates an ImageIcon from an image object. If the image has a "comment" property that is a string, then the string is used as the description of this icon.
        参数：
        image - the image
        另请参见：
        getDescription(), Image.getProperty(java.lang.String, java.awt.image.ImageObserver)

      • ImageIcon

        public ImageIcon(byte[] imageData,
         String description)
        Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG. Normally this array is created by reading an image using Class.getResourceAsStream(), but the byte array may also be statically stored in a class.
        参数：
        imageData - an array of pixels in an image format supported by the AWT Toolkit, such as GIF, JPEG, or (as of 1.3) PNG
        描述 - a brief textual description of the image
        另请参见：
        Toolkit.createImage(java.lang.String)

      • ImageIcon

        public ImageIcon(byte[] imageData)
        Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG. Normally this array is created by reading an image using Class.getResourceAsStream(), but the byte array may also be statically stored in a class. If the resulting image has a "comment" property that is a string, then the string is used as the description of this icon.
        参数：
        imageData - an array of pixels in an image format supported by the AWT Toolkit, such as GIF, JPEG, or (as of 1.3) PNG
        另请参见：
        Toolkit.createImage(java.lang.String),
getDescription(),
Image.getProperty(java.lang.String, java.awt.image.ImageObserver)

      • ImageIcon

        public ImageIcon()
        Creates an uninitialized image icon.

    • 方法详细信息

      • loadImage

        protected void loadImage(Image image)
        Loads the image, returning only when the image is loaded.
        参数：
        image - the image

      • getImageLoadStatus

        public int getImageLoadStatus()
        Returns the status of the image loading operation.
        返回：
        the loading status as defined by java.awt.MediaTracker
        另请参见：
        MediaTracker.ABORTED, MediaTracker.ERRORED, MediaTracker.COMPLETE

      • getImage

        public Image getImage()
        Returns this icon's Image.
        返回：
        the Image object for this ImageIcon

      • setImage

        public void setImage(Image image)
        Sets the image displayed by this icon.
        参数：
        image - the image

      • getDescription

        public String getDescription()
        Gets the description of the image. This is meant to be a brief textual description of the object. For example, it might be presented to a blind user to give an indication of the purpose of the image. The description may be null.
        返回：
        a brief textual description of the image

      • setDescription

        public void setDescription(String description)
        Sets the description of the image. This is meant to be a brief textual description of the object. For example, it might be presented to a blind user to give an indication of the purpose of the image.
        参数：
        描述 - a brief textual description of the image

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        Paints the icon. The top-left corner of the icon is drawn at the point (x, y) in the coordinate space of the graphics context g. If this icon has no image observer, this method uses the c component as the observer.
        指定者：
        paintIcon in interface Icon
        参数：
        c - the component to be used as the observer if this icon has no image observer
        g - the graphics context
        x - the X coordinate of the icon's top-left corner
        y - the Y coordinate of the icon's top-left corner

      • getIconWidth

        public int getIconWidth()
        Gets the width of the icon.
        指定者：
        getIconWidth in interface Icon
        返回：
        the width in pixels of this icon

      • getIconHeight

        public int getIconHeight()
        Gets the height of the icon.
        指定者：
        getIconHeight in interface Icon
        返回：
        the height in pixels of this icon

      • setImageObserver

        public void setImageObserver(ImageObserver observer)
        Sets the image observer for the image. Set this property if the ImageIcon contains an animated GIF, so the observer is notified to update its display. For example:
             icon = new ImageIcon(...)
     button.setIcon(icon);
     icon.setImageObserver(button);
        参数：
        observer - the image observer

      • getImageObserver

        public ImageObserver getImageObserver()
        Returns the image observer for the image.
        返回：
        the image observer, which may be null

      • toString

        public String toString()
        Returns a string representation of this image.
        重载：
        toString in class Object
        返回：
        a string representing this image

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this ImageIcon. For image icons, the AccessibleContext takes the form of an AccessibleImageIcon. A new AccessibleImageIcon instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        an AccessibleImageIcon that serves as the AccessibleContext of this ImageIcon
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b=


ImageIcon.AccessibleImageIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ImageIcon.AccessibleImageIcon

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.ImageIcon.AccessibleImageIcon
  • 所有已实现的接口：
    Serializable, AccessibleIcon
    封闭类：
    ImageIcon

    protected class ImageIcon.AccessibleImageIcon
extends AccessibleContext
implements AccessibleIcon, Serializable
    This class implements accessibility support for the ImageIcon class. It provides an implementation of the Java Accessibility API appropriate to image icon user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.3

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ImageIcon.AccessibleImageIcon()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Accessible getAccessibleChild(int i)
      Returns the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      String getAccessibleIconDescription()
      Gets the description of the icon.
      int getAccessibleIconHeight()
      Gets the height of the icon.
      int getAccessibleIconWidth()
      Gets the width of the icon.
      int getAccessibleIndexInParent()
      Gets the index of this object in its accessible parent.
      Accessible getAccessibleParent()
      Gets the Accessible parent of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state of this object.
      Locale getLocale()
      Returns the locale of this object.
      void setAccessibleIconDescription(String description)
      Sets the description of the icon.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleComponent, getAccessibleDescription, getAccessibleEditableText, getAccessibleIcon, getAccessibleName, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageIcon.AccessibleImageIcon

        protected ImageIcon.AccessibleImageIcon()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state of this object.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleParent

        public Accessible getAccessibleParent()
        Gets the Accessible parent of this object. If the parent of this object implements Accessible, this method should simply return getParent().
        重载：
        getAccessibleParent in class AccessibleContext
        返回：
        the Accessible parent of this object -- can be null if this object does not have an Accessible parent

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Gets the index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the index of this object in its parent; -1 if this object does not have an accessible parent.
        另请参见：
        getAccessibleParent()

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the nth Accessible child of the object.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
                 throws IllegalComponentStateException
        Returns the locale of this object.
        指定者：
        getLocale in class AccessibleContext
        返回：
        the locale of this object
        抛出：
        IllegalComponentStateException - If the Component does not have its own locale and has not yet been added to a containment hierarchy such that the locale can be determined from the containing parent.

      • getAccessibleIconDescription

        public String getAccessibleIconDescription()
        Gets the description of the icon. This is meant to be a brief textual description of the object. For example, it might be presented to a blind user to give an indication of the purpose of the icon.
        指定者：
        getAccessibleIconDescription in interface AccessibleIcon
        返回：
        the description of the icon

      • setAccessibleIconDescription

        public void setAccessibleIconDescription(String description)
        Sets the description of the icon. This is meant to be a brief textual description of the object. For example, it might be presented to a blind user to give an indication of the purpose of the icon.
        指定者：
        setAccessibleIconDescription in interface AccessibleIcon
        参数：
        描述 - the description of the icon

      • getAccessibleIconHeight

        public int getAccessibleIconHeight()
        Gets the height of the icon.
        指定者：
        getAccessibleIconHeight in interface AccessibleIcon
        返回：
        the height of the icon

      • getAccessibleIconWidth

        public int getAccessibleIconWidth()
        Gets the width of the icon.
        指定者：
        getAccessibleIconWidth in interface AccessibleIcon
        返回：
        the width of the icon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

teeo


InputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 InputMap

  • java.lang.Object
    • javax.swing.InputMap
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    ComponentInputMap, InputMapUIResource

    public class InputMap
extends Object
implements Serializable
    InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object. InputMaps are usually used with an ActionMap, to determine an Action to perform when a key is pressed. An InputMap can have a parent that is searched for bindings not defined in the InputMap.

    As with ActionMap if you create a cycle, eg:

       InputMap am = new InputMap();
   InputMap bm = new InputMap():
   am.setParent(bm);
   bm.setParent(am);
    some of the methods will cause a StackOverflowError to be thrown.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputMap()
      Creates an InputMap with no parent and no mappings.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      KeyStroke[] allKeys()
      Returns an array of the KeyStrokes defined in this InputMap and its parent.
      void clear()
      Removes all the mappings from this InputMap.
      Object get(KeyStroke keyStroke)
      Returns the binding for keyStroke, messaging the parent InputMap if the binding is not locally defined.
      InputMap getParent()
      Gets this InputMap's parent.
      KeyStroke[] keys()
      Returns the KeyStrokes that are bound in this InputMap.
      void put(KeyStroke keyStroke, Object actionMapKey)
      Adds a binding for keyStroke to actionMapKey.
      void remove(KeyStroke key)
      Removes the binding for key from this InputMap.
      void setParent(InputMap map)
      Sets this InputMap's parent.
      int size()
      Returns the number of KeyStroke bindings.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputMap

        public InputMap()
        Creates an InputMap with no parent and no mappings.

    • 方法详细信息

      • setParent

        public void setParent(InputMap map)
        Sets this InputMap's parent.
        参数：
        map - the InputMap that is the parent of this one

      • getParent

        public InputMap getParent()
        Gets this InputMap's parent.
        返回：
        map the InputMap that is the parent of this one, or null if this InputMap has no parent

      • put

        public void put(KeyStroke keyStroke,
       Object actionMapKey)
        Adds a binding for keyStroke to actionMapKey. If actionMapKey is null, this removes the current binding for keyStroke.

      • get

        public Object get(KeyStroke keyStroke)
        Returns the binding for keyStroke, messaging the parent InputMap if the binding is not locally defined.

      • remove

        public void remove(KeyStroke key)
        Removes the binding for key from this InputMap.

      • clear

        public void clear()
        Removes all the mappings from this InputMap.

      • keys

        public KeyStroke[] keys()
        Returns the KeyStrokes that are bound in this InputMap.

      • size

        public int size()
        Returns the number of KeyStroke bindings.

      • allKeys

        public KeyStroke[] allKeys()
        Returns an array of the KeyStrokes defined in this InputMap and its parent. This differs from keys() in that this method includes the keys defined in the parent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

npths"ct"cokkcoos


InputVerifier

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 InputVerifier

  • java.lang.Object
    • javax.swing.InputVerifier

  • public abstract class InputVerifier
extends Object
    The purpose of this class is to help clients support smooth focus navigation through GUIs with text fields. Such GUIs often need to ensure that the text entered by the user is valid (for example, that it's in the proper format) before allowing the user to navigate out of the text field. To do this, clients create a subclass of InputVerifier and, using JComponent's setInputVerifier method, attach an instance of their subclass to the JComponent whose input they want to validate. Before focus is transfered to another Swing component that requests it, the input verifier's shouldYieldFocus method is called. Focus is transfered only if that method returns true.

    The following example has two text fields, with the first one expecting the string "pass" to be entered by the user. If that string is entered in the first text field, then the user can advance to the second text field either by clicking in it or by pressing TAB. However, if another string is entered in the first text field, then the user will be unable to transfer focus to the second text field.

     import java.awt.*;
 import java.util.*;
 import java.awt.event.*;
 import javax.swing.*;

 // This program demonstrates the use of the Swing InputVerifier class.
 // It creates two text fields; the first of the text fields expects the
 // string "pass" as input, and will allow focus to advance out of it
 // only after that string is typed in by the user.

 public class VerifierTest extends JFrame {
     public VerifierTest() {
         JTextField tf1 = new JTextField ("Type \"pass\" here");
         getContentPane().add (tf1, BorderLayout.NORTH);
         tf1.setInputVerifier(new PassVerifier());

         JTextField tf2 = new JTextField ("TextField2");
         getContentPane().add (tf2, BorderLayout.SOUTH);

         WindowListener l = new WindowAdapter() {
             public void windowClosing(WindowEvent e) {
                 System.exit(0);
             }
         };
         addWindowListener(l);
     }

     class PassVerifier extends InputVerifier {
         public boolean verify(JComponent input) {
             JTextField tf = (JTextField) input;
             return "pass".equals(tf.getText());
         }
     }

     public static void main(String[] args) {
         Frame f = new VerifierTest();
         f.pack();
         f.setVisible(true);
     }
 }
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputVerifier()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean shouldYieldFocus(JComponent input)
      Calls verify(input) to ensure that the input is valid.
      abstract boolean verify(JComponent input)
      Checks whether the JComponent's input is valid.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputVerifier

        public InputVerifier()

    • 方法详细信息

      • verify

        public abstract boolean verify(JComponent input)
        Checks whether the JComponent's input is valid. This method should have no side effects. It returns a boolean indicating the status of the argument's input.
        参数：
        input - the JComponent to verify
        返回：
        true when valid, false when invalid
        另请参见：
        JComponent.setInputVerifier(javax.swing.InputVerifier), JComponent.getInputVerifier()

      • shouldYieldFocus

        public boolean shouldYieldFocus(JComponent input)
        Calls verify(input) to ensure that the input is valid. This method can have side effects. In particular, this method is called when the user attempts to advance focus out of the argument component into another Swing component in this window. If this method returns true, then the focus is transfered normally; if it returns false, then the focus remains in the argument component.
        参数：
        input - the JComponent to verify
        返回：
        true when valid, false when invalid
        另请参见：
        JComponent.setInputVerifier(javax.swing.InputVerifier), JComponent.getInputVerifier()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)lnseeeeo>eed


InternalFrameFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 InternalFrameFocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
  • 直接已知子类：
    SortingFocusTraversalPolicy

    public abstract class InternalFrameFocusTraversalPolicy
extends FocusTraversalPolicy
    A FocusTraversalPolicy which can optionally provide an algorithm for determining a JInternalFrame's initial Component. The initial Component is the first to receive focus when the JInternalFrame is first selected. By default, this is the same as the JInternalFrame's default Component to focus.
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      InternalFrameFocusTraversalPolicy()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getInitialComponent(JInternalFrame frame)
      Returns the Component that should receive the focus when a JInternalFrame is selected for the first time.

      • 方法 - 继承于类 java.awt.FocusTraversalPolicy

        getComponentAfter, getComponentBefore, getDefaultComponent, getFirstComponent, getInitialComponent, getLastComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InternalFrameFocusTraversalPolicy

        public InternalFrameFocusTraversalPolicy()

    • 方法详细信息

      • getInitialComponent

        public Component getInitialComponent(JInternalFrame frame)
        Returns the Component that should receive the focus when a JInternalFrame is selected for the first time. Once the JInternalFrame has been selected by a call to setSelected(true), the initial Component will not be used again. Instead, if the JInternalFrame loses and subsequently regains selection, or is made invisible or undisplayable and subsequently made visible and displayable, the JInternalFrame's most recently focused Component will become the focus owner. The default implementation of this method returns the JInternalFrame's default Component to focus.
        参数：
        frame - the JInternalFrame whose initial Component is to be returned
        返回：
        the Component that should receive the focus when frame is selected for the first time, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if window is null
        另请参见：
        JInternalFrame.getMostRecentFocusOwner()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= =w w;www(now=oo __ct>a"ttiear!i-cc--s-stt


JApplet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JApplet

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Panel
          • java.applet.Applet
            • javax.swing.JApplet
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer

    public class JApplet
extends Applet
implements Accessible, RootPaneContainer
    An extended version of java.applet.Applet that adds support for the JFC/Swing component architecture. You can find task-oriented documentation about using JApplet in The Java Tutorial, in the section How to Make Applets.

    The JApplet class is slightly incompatible with java.applet.Applet. JApplet contains a JRootPane as its only child. The contentPane should be the parent of any children of the JApplet. As a convenience add and its variants, remove and setLayout have been overridden to forward to the contentPane as necessary. This means you can write:

           applet.add(child);
    And the child will be added to the contentPane. The contentPane will always be non-null. Attempting to set it to null will cause the JApplet to throw an exception. The default contentPane will have a BorderLayout manager set on it. Refer to RootPaneContainer for details on adding, removing and setting the LayoutManager of a JApplet.

    Please see the JRootPane documentation for a complete description of the contentPane, glassPane, and layeredPane properties.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    RootPaneContainer

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JApplet.AccessibleJApplet
      This class implements accessibility support for the JApplet class.

      • Nested classes/interfaces inherited from class java.applet.Applet

        Applet.AccessibleApplet

      • Nested classes/interfaces inherited from class java.awt.Panel

        Panel.AccessibleAWTPanel

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected AccessibleContext | accessibleContext
      protected JRootPane | rootPane
      protected boolean rootPaneCheckingEnabled
      If true then calls to add and setLayout will be forwarded to the contentPane.

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JApplet()
      Creates a swing applet instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified child Component.
      protected JRootPane createRootPane()
      Called by the constructor methods to create the default rootPane.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JApplet.
      Container getContentPane()
      Returns the contentPane object for this applet.
      Component getGlassPane()
      Returns the glassPane object for this applet.
      Graphics getGraphics()
      Creates a graphics context for this component.
      JMenuBar getJMenuBar()
      Returns the menubar set on this applet.
      JLayeredPane getLayeredPane()
      Returns the layeredPane object for this applet.
      JRootPane getRootPane()
      Returns the rootPane object for this applet.
      TransferHandler getTransferHandler()
      Gets the transferHandler property.
      protected boolean isRootPaneCheckingEnabled()
      Returns whether calls to add and setLayout are forwarded to the contentPane.
      protected String paramString()
      Returns a string representation of this JApplet.
      void remove(Component comp)
      Removes the specified component from the container.
      void repaint(long time, int x, int y, int width, int height)
      Repaints the specified rectangle of this component within time milliseconds.
      void setContentPane(Container contentPane)
      Sets the contentPane property.
      void setGlassPane(Component glassPane)
      Sets the glassPane property.
      void setJMenuBar(JMenuBar menuBar)
      Sets the menubar for this applet.
      void setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void setLayout(LayoutManager manager)
      Sets the LayoutManager.
      protected void setRootPane(JRootPane root)
      Sets the rootPane property.
      protected void setRootPaneCheckingEnabled(boolean enabled)
      Sets whether calls to add and setLayout are forwarded to the contentPane.
      void setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void update(Graphics g)
      Just calls paint(g).

      • 方法 - 继承于类 java.applet.Applet

        destroy, getAppletContext, getAppletInfo, getAudioClip, getAudioClip, getCodeBase, getDocumentBase, getImage, getImage, getLocale, getParameter, getParameterInfo, init, isActive, isValidateRoot, newAudioClip, play, play, resize, resize, setStub, showStatus, start, stop

      • 方法 - 继承于类 java.awt.Panel

        addNotify

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • rootPane

        protected JRootPane rootPane
        另请参见：
        getRootPane(), setRootPane(javax.swing.JRootPane)

      • rootPaneCheckingEnabled

        protected boolean rootPaneCheckingEnabled
        If true then calls to add and setLayout will be forwarded to the contentPane. This is initially false, but is set to true when the JApplet is constructed.
        另请参见：
        isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • accessibleContext

        protected AccessibleContext accessibleContext

    • 构造方法详细信息

      • JApplet

        public JApplet()
        throws HeadlessException
        Creates a swing applet instance.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

    • 方法详细信息

      • createRootPane

        protected JRootPane createRootPane()
        Called by the constructor methods to create the default rootPane.

      • setTransferHandler

        public void setTransferHandler(TransferHandler newHandler)
        Sets the transferHandler property, which is a mechanism to support transfer of data into this component. Use null if the component does not support data transfer operations.

        If the system property suppressSwingDropSupport is false (the default) and the current drop target on this component is either null or not a user-set drop target, this method will change the drop target as follows: If newHandler is null it will clear the drop target. If not null it will install a new DropTarget.

        Note: When used with JApplet, TransferHandler only provides data import capability, as the data export related methods are currently typed to JComponent.

        Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

        参数：
        newHandler - the new TransferHandler
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

      • getTransferHandler

        public TransferHandler getTransferHandler()
        Gets the transferHandler property.
        返回：
        the value of the transferHandler property
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, setTransferHandler(javax.swing.TransferHandler)

      • update

        public void update(Graphics g)
        Just calls paint(g). This method was overridden to prevent an unnecessary call to clear the background.
        重载：
        update in class Container
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • setJMenuBar

        public void setJMenuBar(JMenuBar menuBar)
        Sets the menubar for this applet.
        参数：
        menuBar - the menubar being placed in the applet
        另请参见：
        getJMenuBar()

      • getJMenuBar

        public JMenuBar getJMenuBar()
        Returns the menubar set on this applet.
        另请参见：
        setJMenuBar(javax.swing.JMenuBar)

      • isRootPaneCheckingEnabled

        protected boolean isRootPaneCheckingEnabled()
        Returns whether calls to add and setLayout are forwarded to the contentPane.
        返回：
        true if add and setLayout are fowarded; false otherwise
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • setRootPaneCheckingEnabled

        protected void setRootPaneCheckingEnabled(boolean enabled)
        Sets whether calls to add and setLayout are forwarded to the contentPane.
        参数：
        enabled - true if add and setLayout are forwarded, false if they should operate directly on the JApplet.
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified child Component. This method is overridden to conditionally forward calls to the contentPane. By default, children are added to the contentPane instead of the frame, refer to RootPaneContainer for details.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • remove

        public void remove(Component comp)
        Removes the specified component from the container. If comp is not the rootPane, this will forward the call to the contentPane. This will do nothing if comp is not a child of the JFrame or contentPane.
        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        抛出：
        NullPointerException - if comp is null
        另请参见：
        Container.add(java.awt.Component), RootPaneContainer

      • setLayout

        public void setLayout(LayoutManager manager)
        Sets the LayoutManager. Overridden to conditionally forward the call to the contentPane. Refer to RootPaneContainer for more information.
        重载：
        setLayout in class Container
        参数：
        manager - the LayoutManager
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • getRootPane

        public JRootPane getRootPane()
        Returns the rootPane object for this applet.
        指定者：
        getRootPane in interface RootPaneContainer
        返回：
        this components single JRootPane child.
        另请参见：
        setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

      • setRootPane

        protected void setRootPane(JRootPane root)
        Sets the rootPane property. This method is called by the constructor.
        参数：
        root - the rootPane object for this applet
        另请参见：
        getRootPane()

      • getContentPane

        public Container getContentPane()
        Returns the contentPane object for this applet.
        指定者：
        getContentPane in interface RootPaneContainer
        返回：
        the value of the contentPane property.
        另请参见：
        setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

      • setContentPane

        public void setContentPane(Container contentPane)
        Sets the contentPane property. This method is called by the constructor.
        指定者：
        setContentPane in interface RootPaneContainer
        参数：
        contentPane - the contentPane object for this applet
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Returns the layeredPane object for this applet.
        指定者：
        getLayeredPane in interface RootPaneContainer
        返回：
        the value of the layeredPane property.
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null
        另请参见：
        setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layeredPane)
        Sets the layeredPane property. This method is called by the constructor.
        指定者：
        setLayeredPane in interface RootPaneContainer
        参数：
        layeredPane - the layeredPane object for this applet
        另请参见：
        getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

      • getGlassPane

        public Component getGlassPane()
        Returns the glassPane object for this applet.
        指定者：
        getGlassPane in interface RootPaneContainer
        返回：
        the value of the glassPane property.
        另请参见：
        setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

      • setGlassPane

        public void setGlassPane(Component glassPane)
        Sets the glassPane property. This method is called by the constructor.
        指定者：
        setGlassPane in interface RootPaneContainer
        参数：
        glassPane - the glassPane object for this applet
        另请参见：
        getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

      • getGraphics

        public Graphics getGraphics()
        Creates a graphics context for this component. This method will return null if this component is currently not displayable.
        重载：
        getGraphics in class Component
        返回：
        a graphics context for this component, or null if it has none
        从以下版本开始：
        1.6
        另请参见：
        Component.paint(java.awt.Graphics)

      • repaint

        public void repaint(long time,
           int x,
           int y,
           int width,
           int height)
        Repaints the specified rectangle of this component within time milliseconds. Refer to RepaintManager for details on how the repaint is handled.
        重载：
        repaint in class Component
        参数：
        time - maximum time in milliseconds before update
        x - the x coordinate
        y - the y coordinate
        width - the width
        height - the height
        从以下版本开始：
        1.6
        另请参见：
        RepaintManager

      • paramString

        protected String paramString()
        Returns a string representation of this JApplet. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class Container
        返回：
        a string representation of this JApplet.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JApplet. For JApplets, the AccessibleContext takes the form of an AccessibleJApplet. A new AccessibleJApplet instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class Applet
        返回：
        an AccessibleJApplet that serves as the AccessibleContext of this JApplet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JApplet.AccessibleJApplet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing

类 JApplet.AccessibleJApplet

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    JApplet

    protected class JApplet.AccessibleJApplet
extends Applet.AccessibleApplet
    This class implements accessibility support for the JApplet class.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JApplet.AccessibleJApplet()

    • 方法摘要

      • 方法 - 继承于类 java.applet.Applet.AccessibleApplet

        getAccessibleRole, getAccessibleStateSet

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JApplet.AccessibleJApplet

        protected JApplet.AccessibleJApplet()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/c ><" h�


javax.swing

Interfaces

  • Action
  • BoundedRangeModel
  • ButtonModel
  • CellEditor
  • ComboBoxEditor
  • ComboBoxModel
  • DesktopManager
  • Icon
  • JComboBox.KeySelectionManager
  • ListCellRenderer
  • ListModel
  • ListSelectionModel
  • MenuElement
  • MutableComboBoxModel
  • Painter
  • Renderer
  • RootPaneContainer
  • Scrollable
  • ScrollPaneConstants
  • SingleSelectionModel
  • SpinnerModel
  • SwingConstants
  • UIDefaults.ActiveValue
  • UIDefaults.LazyValue
  • WindowConstants

Classes

  • AbstractAction
  • AbstractButton
  • AbstractCellEditor
  • AbstractListModel
  • AbstractSpinnerModel
  • ActionMap
  • BorderFactory
  • Box
  • Box.Filler
  • BoxLayout
  • ButtonGroup
  • CellRendererPane
  • ComponentInputMap
  • DebugGraphics
  • DefaultBoundedRangeModel
  • DefaultButtonModel
  • DefaultCellEditor
  • DefaultComboBoxModel
  • DefaultDesktopManager
  • DefaultFocusManager
  • DefaultListCellRenderer
  • DefaultListCellRenderer.UIResource
  • DefaultListModel
  • DefaultListSelectionModel
  • DefaultRowSorter
  • DefaultRowSorter.ModelWrapper
  • DefaultSingleSelectionModel
  • FocusManager
  • GrayFilter
  • GroupLayout
  • ImageIcon
  • InputMap
  • InputVerifier
  • InternalFrameFocusTraversalPolicy
  • JApplet
  • JButton
  • JCheckBox
  • JCheckBoxMenuItem
  • JColorChooser
  • JComboBox
  • JComponent
  • JDesktopPane
  • JDialog
  • JEditorPane
  • JFileChooser
  • JFormattedTextField
  • JFormattedTextField.AbstractFormatter
  • JFormattedTextField.AbstractFormatterFactory
  • JFrame
  • JInternalFrame
  • JInternalFrame.JDesktopIcon
  • JLabel
  • JLayer
  • JLayeredPane
  • JList
  • JList.DropLocation
  • JMenu
  • JMenuBar
  • JMenuItem
  • JOptionPane
  • JPanel
  • JPasswordField
  • JPopupMenu
  • JPopupMenu.Separator
  • JProgressBar
  • JRadioButton
  • JRadioButtonMenuItem
  • JRootPane
  • JScrollBar
  • JScrollPane
  • JSeparator
  • JSlider
  • JSpinner
  • JSpinner.DateEditor
  • JSpinner.DefaultEditor
  • JSpinner.ListEditor
  • JSpinner.NumberEditor
  • JSplitPane
  • JTabbedPane
  • JTable
  • JTable.DropLocation
  • JTextArea
  • JTextField
  • JTextPane
  • JToggleButton
  • JToggleButton.ToggleButtonModel
  • JToolBar
  • JToolBar.Separator
  • JToolTip
  • JTree
  • JTree.DropLocation
  • JTree.DynamicUtilTreeNode
  • JTree.EmptySelectionModel
  • JViewport
  • JWindow
  • KeyStroke
  • LayoutFocusTraversalPolicy
  • LayoutStyle
  • LookAndFeel
  • MenuSelectionManager
  • OverlayLayout
  • Popup
  • PopupFactory
  • ProgressMonitor
  • ProgressMonitorInputStream
  • RepaintManager
  • RowFilter
  • RowFilter.Entry
  • RowSorter
  • RowSorter.SortKey
  • ScrollPaneLayout
  • ScrollPaneLayout.UIResource
  • SizeRequirements
  • SizeSequence
  • SortingFocusTraversalPolicy
  • SpinnerDateModel
  • SpinnerListModel
  • SpinnerNumberModel
  • Spring
  • SpringLayout
  • SpringLayout.Constraints
  • SwingUtilities
  • SwingWorker
  • Timer
  • ToolTipManager
  • TransferHandler
  • TransferHandler.DropLocation
  • TransferHandler.TransferSupport
  • UIDefaults
  • UIDefaults.LazyInputMap
  • UIDefaults.ProxyLazyValue
  • UIManager
  • UIManager.LookAndFeelInfo
  • ViewportLayout

Enums

  • DropMode
  • GroupLayout.Alignment
  • JTable.PrintMode
  • LayoutStyle.ComponentPlacement
  • RowFilter.ComparisonType
  • SortOrder
  • SwingWorker.StateValue

Exceptions

  • UnsupportedLookAndFeelException
s


javax.swing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing

Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

请参见： 描述

  • 接口摘要
    接口 描述
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    BoundedRangeModel
    Defines the data model used by components like Sliders and ProgressBars.
    ButtonModel
    State model for buttons.
    CellEditor
    This interface defines the methods any general editor should be able to implement.
    ComboBoxEditor
    The editor component used for JComboBox components.
    ComboBoxModel
    A data model for a combo box.
    DesktopManager
    DesktopManager objects are owned by a JDesktopPane object.
    Icon
    A small fixed size picture, typically used to decorate components.
    JComboBox.KeySelectionManager
    The interface that defines a KeySelectionManager.
    ListCellRenderer<E>
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
    ListModel<E>
    This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list.
    ListSelectionModel
    This interface represents the current state of the selection for any of the components that display a list of values with stable indices.
    MenuElement
    Any component that can be placed into a menu should implement this interface.
    MutableComboBoxModel
    A mutable version of ComboBoxModel.
    Painter<T>
    A painting delegate.
    Renderer
    Defines the requirements for an object responsible for "rendering" (displaying) a value.
    RootPaneContainer
    This interface is implemented by components that have a single JRootPane child: JDialog, JFrame, JWindow, JApplet, JInternalFrame.
    Scrollable
    An interface that provides information to a scrolling container like JScrollPane.
    ScrollPaneConstants
    Constants used with the JScrollPane component.
    SingleSelectionModel
    A model that supports at most one indexed selection.
    SpinnerModel
    A model for a potentially unbounded sequence of object values.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    UIDefaults.ActiveValue
    This class enables one to store an entry in the defaults table that's constructed each time it's looked up with one of the getXXX(key) methods.
    UIDefaults.LazyValue
    This class enables one to store an entry in the defaults table that isn't constructed until the first time it's looked up with one of the getXXX(key) methods.
    WindowConstants
    Constants used to control the window-closing operation.
  • Class Summary
    类 描述
    AbstractAction
    This class provides default implementations for the JFC Action interface.
    AbstractButton
    Defines common behaviors for buttons and menu items.
    AbstractCellEditor
    A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue().
    AbstractListModel<E>
    The abstract definition for the data model that provides a List with its contents.
    AbstractSpinnerModel
    This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations.
    ActionMap
    ActionMap provides mappings from Objects (called keys or Action names) to Actions.
    BorderFactory
    Factory class for vending standard Border objects.
    Box
    A lightweight container that uses a BoxLayout object as its layout manager.
    Box.Filler
    An implementation of a lightweight component that participates in layout but has no view.
    BoxLayout
    A layout manager that allows multiple components to be laid out either vertically or horizontally.
    ButtonGroup
    This class is used to create a multiple-exclusion scope for a set of buttons.
    CellRendererPane
    This class is inserted in between cell renderers and the components that use them.
    ComponentInputMap
    A ComponentInputMap is an InputMap associated with a particular JComponent.
    DebugGraphics
    Graphics subclass supporting graphics debugging.
    DefaultBoundedRangeModel
    A generic implementation of BoundedRangeModel.
    DefaultButtonModel
    The default implementation of a Button component's data model.
    DefaultCellEditor
    The default editor for table and tree cells.
    DefaultComboBoxModel
    The default model for combo boxes.
    DefaultDesktopManager
    This is an implementation of the DesktopManager.
    DefaultFocusManager
    This class has been obsoleted by the 1.4 focus APIs.
    DefaultListCellRenderer
    Renders an item in a list.
    DefaultListCellRenderer.UIResource
    A subclass of DefaultListCellRenderer that implements UIResource.
    DefaultListModel<E>
    This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur.
    DefaultListSelectionModel
    Default data model for list selections.
    DefaultRowSorter<M,I>
    An implementation of RowSorter that provides sorting and filtering around a grid-based data model.
    DefaultRowSorter.ModelWrapper<M,I>
    DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter.
    DefaultSingleSelectionModel
    A generic implementation of SingleSelectionModel.
    FocusManager
    This class has been obsoleted by the 1.4 focus APIs.
    GrayFilter
    An image filter that "disables" an image by turning it into a grayscale image, and brightening the pixels in the image.
    GroupLayout
    GroupLayout is a LayoutManager that hierarchically groups components in order to position them in a Container.
    ImageIcon
    An implementation of the Icon interface that paints Icons from Images.
    InputMap
    InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object.
    InputVerifier
    The purpose of this class is to help clients support smooth focus navigation through GUIs with text fields.
    InternalFrameFocusTraversalPolicy
    A FocusTraversalPolicy which can optionally provide an algorithm for determining a JInternalFrame's initial Component.
    JApplet
    An extended version of java.applet.Applet that adds support for the JFC/Swing component architecture.
    JButton
    An implementation of a "push" button.
    JCheckBox
    An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
    JCheckBoxMenuItem
    A menu item that can be selected or deselected.
    JColorChooser
    JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComponent
    The base class for all Swing components except top-level containers.
    JDesktopPane
    A container used to create a multiple-document interface or a virtual desktop.
    JDialog
    The main class for creating a dialog window.
    JEditorPane
    A text component to edit various kinds of content.
    JFileChooser
    JFileChooser provides a simple mechanism for the user to choose a file.
    JFormattedTextField
    JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
    JFormattedTextField.AbstractFormatter
    Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object.
    JFormattedTextField.AbstractFormatterFactory
    Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values.
    JFrame
    An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    JInternalFrame.JDesktopIcon
    This component represents an iconified version of a JInternalFrame.
    JLabel
    A display area for a short text string or an image, or both.
    JLayer<V extends Component>
    JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.
    JLayeredPane
    JLayeredPane adds depth to a JFC/Swing container, allowing components to overlap each other when needed.
    JList<E>
    A component that displays a list of objects and allows the user to select one or more items.
    JList.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JList.
    JMenu
    An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
    JMenuBar
    An implementation of a menu bar.
    JMenuItem
    An implementation of an item in a menu.
    JOptionPane
    JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
    JPanel
    JPanel is a generic lightweight container.
    JPasswordField
    JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JPopupMenu.Separator
    A popup menu-specific separator.
    JProgressBar
    A component that visually displays the progress of some task.
    JRadioButton
    An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
    JRadioButtonMenuItem
    An implementation of a radio button menu item.
    JRootPane
    A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
    JScrollBar
    An implementation of a scrollbar.
    JScrollPane
    Provides a scrollable view of a lightweight component.
    JSeparator
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
    JSlider
    A component that lets the user graphically select a value by sliding a knob within a bounded interval.
    JSpinner
    A single line input field that lets the user select a number or an object value from an ordered sequence.
    JSpinner.DateEditor
    An editor for a JSpinner whose model is a SpinnerDateModel.
    JSpinner.DefaultEditor
    A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
    JSpinner.ListEditor
    An editor for a JSpinner whose model is a SpinnerListModel.
    JSpinner.NumberEditor
    An editor for a JSpinner whose model is a SpinnerNumberModel.
    JSplitPane
    JSplitPane is used to divide two (and only two) Components.
    JTabbedPane
    A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
    JTable
    The JTable is used to display and edit regular two-dimensional tables of cells.
    JTable.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
    JTextArea
    A JTextArea is a multi-line area that displays plain text.
    JTextField
    JTextField is a lightweight component that allows the editing of a single line of text.
    JTextPane
    A text component that can be marked up with attributes that are represented graphically.
    JToggleButton
    An implementation of a two-state button.
    JToggleButton.ToggleButtonModel
    The ToggleButton model
    JToolBar
    JToolBar provides a component that is useful for displaying commonly used Actions or controls.
    JToolBar.Separator
    A toolbar-specific separator.
    JToolTip
    Used to display a "Tip" for a Component.
    JTree
    A control that displays a set of hierarchical data as an outline.
    JTree.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
    JTree.DynamicUtilTreeNode
    DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
    JTree.EmptySelectionModel
    EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
    JViewport
    The "viewport" or "porthole" through which you see the underlying information.
    JWindow
    A JWindow is a container that can be displayed anywhere on the user's desktop.
    KeyStroke
    A KeyStroke represents a key action on the keyboard, or equivalent input device.
    LayoutFocusTraversalPolicy
    A SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation.
    LayoutStyle
    LayoutStyle provides information about how to position components.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    MenuSelectionManager
    A MenuSelectionManager owns the selection in menu hierarchy.
    OverlayLayout
    A layout manager to arrange components over the top of each other.
    Popup
    Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy.
    PopupFactory
    PopupFactory, as the name implies, is used to obtain instances of Popups.
    ProgressMonitor
    A class to monitor the progress of some operation.
    ProgressMonitorInputStream
    Monitors the progress of reading from some InputStream.
    RepaintManager
    This class manages repaint requests, allowing the number of repaints to be minimized, for example by collapsing multiple requests into a single repaint for members of a component tree.
    RowFilter<M,I>
    RowFilter is used to filter out entries from the model so that they are not shown in the view.
    RowFilter.Entry<M,I>
    An Entry object is passed to instances of RowFilter, allowing the filter to get the value of the entry's data, and thus to determine whether the entry should be shown.
    RowSorter<M>
    RowSorter provides the basis for sorting and filtering.
    RowSorter.SortKey
    SortKey describes the sort order for a particular column.
    ScrollPaneLayout
    The layout manager used by JScrollPane.
    ScrollPaneLayout.UIResource
    The UI resource version of ScrollPaneLayout.
    SizeRequirements
    For the convenience of layout managers, calculates information about the size and position of components.
    SizeSequence
    A SizeSequence object efficiently maintains an ordered list of sizes and corresponding positions.
    SortingFocusTraversalPolicy
    A FocusTraversalPolicy that determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator.
    SpinnerDateModel
    A SpinnerModel for sequences of Dates.
    SpinnerListModel
    A simple implementation of SpinnerModel whose values are defined by an array or a List.
    SpinnerNumberModel
    A SpinnerModel for sequences of numbers.
    Spring
    An instance of the Spring class holds three properties that characterize its behavior: the minimum, preferred, and maximum values.
    SpringLayout
    A SpringLayout lays out the children of its associated container according to a set of constraints.
    SpringLayout.Constraints
    A Constraints object holds the constraints that govern the way a component's size and position change in a container controlled by a SpringLayout.
    SwingUtilities
    A collection of utility methods for Swing.
    SwingWorker<T,V>
    An abstract class to perform lengthy GUI-interaction tasks in a background thread.
    Timer
    Fires one or more ActionEvents at specified intervals.
    ToolTipManager
    Manages all the ToolTips in the system.
    TransferHandler
    This class is used to handle the transfer of a Transferable to and from Swing components.
    TransferHandler.DropLocation
    Represents a location where dropped data should be inserted.
    TransferHandler.TransferSupport
    This class encapsulates all relevant details of a clipboard or drag and drop transfer, and also allows for customizing aspects of the drag and drop experience.
    UIDefaults
    A table of defaults for Swing components.
    UIDefaults.LazyInputMap
    LazyInputMap will create a InputMap in its createValue method.
    UIDefaults.ProxyLazyValue
    This class provides an implementation of LazyValue which can be used to delay loading of the Class for the instance to be created.
    UIManager
    UIManager manages the current look and feel, the set of available look and feels, PropertyChangeListeners that are notified when the look and feel changes, look and feel defaults, and convenience methods for obtaining various default values.
    UIManager.LookAndFeelInfo
    Provides a little information about an installed LookAndFeel for the sake of configuring a menu or for initial application set up.
    ViewportLayout
    The default layout manager for JViewport.
  • Enum Summary
    Enum 描述
    DropMode
    Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
    GroupLayout.Alignment
    Enumeration of the possible ways ParallelGroup can align its children.
    JTable.PrintMode
    Printing modes, used in printing JTables.
    LayoutStyle.ComponentPlacement
    ComponentPlacement is an enumeration of the possible ways two components can be placed relative to each other.
    RowFilter.ComparisonType
    Enumeration of the possible comparison values supported by some of the default RowFilters.
    SortOrder
    SortOrder is an enumeration of the possible sort orderings.
    SwingWorker.StateValue
    Values for the state bound property.
  • Exception Summary
    Exception 描述
    UnsupportedLookAndFeelException
    An exception that indicates the requested look & feel management classes are not present on the user's system.

软件包 javax.swing Description

Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms. For a programmer's guide to using these components, see Creating a GUI with JFC/Swing, a trail in The Java Tutorial. For other resources, see Related Documentation.

Swing's Threading Policy

In general Swing is not thread safe. All Swing components and related classes, unless otherwise documented, must be accessed on the event dispatching thread.

Typical Swing applications do processing in response to an event generated from a user gesture. For example, clicking on a JButton notifies all ActionListeners added to the JButton. As all events generated from a user gesture are dispatched on the event dispatching thread, most developers are not impacted by the restriction.

Where the impact lies, however, is in constructing and showing a Swing application. Calls to an application's main method, or methods in Applet, are not invoked on the event dispatching thread. As such, care must be taken to transfer control to the event dispatching thread when constructing and showing an application or applet. The preferred way to transfer control and begin working with Swing is to use invokeLater. The invokeLater method schedules a Runnable to be processed on the event dispatching thread. The following two examples work equally well for transferring control and starting up a Swing application:

public class MyApp implements Runnable {
    public void run() {
        // Invoked on the event dispatching thread.
        // Construct and show GUI.
    }

    public static void main(String[] args) {
        SwingUtilities.invokeLater(new MyApp(args));
    }
}
Or:
public class MyApp {
    MyApp(String[] args) {
        // Invoked on the event dispatching thread. Do any initialization
        // here.
    }

    public void show() {
        // Show the UI.
    }

    public static void main(final String[] args) {
        // Schedule a job for the event-dispatching thread:
        // creating and showing this application's GUI.
        SwingUtilities.invokeLater(new Runnable() {
            public void run() {
                new MyApp(args).show();
            }
        });
    }
}
This restriction also applies to models attached to Swing components. For example, if a TableModel is attached to a JTable, the TableModel should only be modified on the event dispatching thread. If you modify the model on a separate thread you run the risk of exceptions and possible display corruption.

As all events are delivered on the event dispatching thread, care must be taken in event processing. In particular, a long running task, such as network io or computational intensive processing, executed on the event dispatching thread blocks the event dispatching thread from dispatching any other events. While the event dispatching thread is blocked the application is completely unresponsive to user input. Refer to SwingWorker for the preferred way to do such processing when working with Swing.

More information on this topic can be found in the Swing tutorial, in particular the section on How to Use Threads.

Related Documentation

For overviews, tutorials, examples, guides, and other documentation, please see:

  • The Swing Connection
  • The Java Tutorial
  • Online Training at the Java Developer ConnectionSM
  • Java Foundation Classes (JFC) home page
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.swing Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
    • javax.swing.AbstractButton.ButtonChangeListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.AbstractCellEditor (implements javax.swing.CellEditor, java.io.Serializable)
      • javax.swing.DefaultCellEditor (implements javax.swing.table.TableCellEditor, javax.swing.tree.TreeCellEditor)
    • javax.swing.AbstractListModel<E> (implements javax.swing.ListModel<E>, java.io.Serializable)
      • javax.swing.DefaultComboBoxModel (implements javax.swing.MutableComboBoxModel, java.io.Serializable)
      • javax.swing.DefaultListModel<E>
    • javax.swing.AbstractSpinnerModel (implements java.io.Serializable, javax.swing.SpinnerModel)
      • javax.swing.SpinnerDateModel (implements java.io.Serializable)
      • javax.swing.SpinnerListModel (implements java.io.Serializable)
      • javax.swing.SpinnerNumberModel (implements java.io.Serializable)
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • javax.swing.Box.Filler.AccessibleBoxFiller
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.AbstractButton.AccessibleAbstractButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue)
              • javax.swing.JButton.AccessibleJButton
              • javax.swing.JMenuItem.AccessibleJMenuItem (implements javax.swing.event.ChangeListener)
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
                • javax.swing.JMenu.AccessibleJMenu (implements javax.accessibility.AccessibleSelection)
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
              • javax.swing.JToggleButton.AccessibleJToggleButton (implements java.awt.event.ItemListener)
                • javax.swing.JCheckBox.AccessibleJCheckBox
                • javax.swing.JRadioButton.AccessibleJRadioButton
            • javax.swing.JColorChooser.AccessibleJColorChooser
            • javax.swing.JComboBox.AccessibleJComboBox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleSelection)
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
            • javax.swing.JFileChooser.AccessibleJFileChooser
            • javax.swing.JInternalFrame.AccessibleJInternalFrame (implements javax.accessibility.AccessibleValue)
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (implements javax.accessibility.AccessibleValue)
            • javax.swing.JLabel.AccessibleJLabel (implements javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText)
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
            • javax.swing.JList.AccessibleJList (implements javax.accessibility.AccessibleSelection, javax.swing.event.ListDataListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener)
            • javax.swing.JMenuBar.AccessibleJMenuBar (implements javax.accessibility.AccessibleSelection)
            • javax.swing.JOptionPane.AccessibleJOptionPane
            • javax.swing.JPanel.AccessibleJPanel
            • javax.swing.JPopupMenu.AccessibleJPopupMenu (implements java.beans.PropertyChangeListener)
            • javax.swing.JProgressBar.AccessibleJProgressBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JRootPane.AccessibleJRootPane
            • javax.swing.JScrollBar.AccessibleJScrollBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JScrollPane.AccessibleJScrollPane (implements javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
            • javax.swing.JSeparator.AccessibleJSeparator
            • javax.swing.JSlider.AccessibleJSlider (implements javax.accessibility.AccessibleValue)
            • javax.swing.JSpinner.AccessibleJSpinner (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue, javax.swing.event.ChangeListener)
            • javax.swing.JSplitPane.AccessibleJSplitPane (implements javax.accessibility.AccessibleValue)
            • javax.swing.JTabbedPane.AccessibleJTabbedPane (implements javax.accessibility.AccessibleSelection, javax.swing.event.ChangeListener)
            • javax.swing.JTable.AccessibleJTable (implements javax.accessibility.AccessibleExtendedTable, javax.accessibility.AccessibleSelection, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport (implements javax.accessibility.AccessibleHypertext)
              • javax.swing.JTextArea.AccessibleJTextArea
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
            • javax.swing.JToolBar.AccessibleJToolBar
            • javax.swing.JToolTip.AccessibleJToolTip
            • javax.swing.JTree.AccessibleJTree (implements javax.accessibility.AccessibleSelection, javax.swing.event.TreeExpansionListener, javax.swing.event.TreeModelListener, javax.swing.event.TreeSelectionListener)
            • javax.swing.JViewport.AccessibleJViewport
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
            • javax.swing.JWindow.AccessibleJWindow
      • javax.swing.ImageIcon.AccessibleImageIcon (implements javax.accessibility.AccessibleIcon, java.io.Serializable)
      • javax.swing.JList.AccessibleJList.AccessibleJListChild (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode (implements javax.accessibility.Accessible, javax.accessibility.AccessibleAction, javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection)
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor (implements javax.accessibility.AccessibleText, javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
    • javax.swing.ActionMap (implements java.io.Serializable)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
      • javax.swing.KeyStroke
    • javax.swing.BorderFactory
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.ButtonGroup (implements java.io.Serializable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.CellRendererPane (implements javax.accessibility.Accessible)
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
            • javax.swing.JMenuItem (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JCheckBoxMenuItem (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
              • javax.swing.JMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JRadioButtonMenuItem (implements javax.accessibility.Accessible)
            • javax.swing.JToggleButton (implements javax.accessibility.Accessible)
              • javax.swing.JCheckBox (implements javax.accessibility.Accessible)
              • javax.swing.JRadioButton (implements javax.accessibility.Accessible)
          • javax.swing.Box (implements javax.accessibility.Accessible)
          • javax.swing.Box.Filler (implements javax.accessibility.Accessible)
          • javax.swing.JColorChooser (implements javax.accessibility.Accessible)
          • javax.swing.JComboBox (implements javax.accessibility.Accessible, java.awt.event.ActionListener, java.awt.ItemSelectable, javax.swing.event.ListDataListener)
          • javax.swing.JFileChooser (implements javax.accessibility.Accessible)
          • javax.swing.JInternalFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JInternalFrame.JDesktopIcon (implements javax.accessibility.Accessible)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer<E>, java.io.Serializable)
              • javax.swing.DefaultListCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.JLayer<V> (implements javax.accessibility.Accessible, java.beans.PropertyChangeListener, javax.swing.Scrollable)
          • javax.swing.JLayeredPane (implements javax.accessibility.Accessible)
            • javax.swing.JDesktopPane (implements javax.accessibility.Accessible)
          • javax.swing.JList<E> (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
          • javax.swing.JOptionPane (implements javax.accessibility.Accessible)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.JSpinner.DefaultEditor (implements javax.swing.event.ChangeListener, java.awt.LayoutManager, java.beans.PropertyChangeListener)
              • javax.swing.JSpinner.DateEditor
              • javax.swing.JSpinner.ListEditor
              • javax.swing.JSpinner.NumberEditor
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
          • javax.swing.JProgressBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JRootPane (implements javax.accessibility.Accessible)
          • javax.swing.JScrollBar (implements javax.accessibility.Accessible, java.awt.Adjustable)
            • javax.swing.JScrollPane.ScrollBar (implements javax.swing.plaf.UIResource)
          • javax.swing.JScrollPane (implements javax.accessibility.Accessible, javax.swing.ScrollPaneConstants)
          • javax.swing.JSeparator (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.JPopupMenu.Separator
            • javax.swing.JToolBar.Separator
          • javax.swing.JSlider (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JSpinner (implements javax.accessibility.Accessible)
          • javax.swing.JSplitPane (implements javax.accessibility.Accessible)
          • javax.swing.JTabbedPane (implements javax.accessibility.Accessible, java.io.Serializable, javax.swing.SwingConstants)
          • javax.swing.JTable (implements javax.accessibility.Accessible, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, javax.swing.event.RowSorterListener, javax.swing.Scrollable, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
            • javax.swing.JTextArea
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.JFormattedTextField
              • javax.swing.JPasswordField
          • javax.swing.JToolBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JToolTip (implements javax.accessibility.Accessible)
          • javax.swing.JTree (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JViewport (implements javax.accessibility.Accessible)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • java.awt.Dialog
            • javax.swing.JDialog (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • java.awt.Frame (implements java.awt.MenuContainer)
            • javax.swing.JFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JWindow (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.JViewport.ViewListener (implements java.io.Serializable)
    • javax.swing.DefaultBoundedRangeModel (implements javax.swing.BoundedRangeModel, java.io.Serializable)
    • javax.swing.DefaultButtonModel (implements javax.swing.ButtonModel, java.io.Serializable)
      • javax.swing.JToggleButton.ToggleButtonModel
    • javax.swing.DefaultCellEditor.EditorDelegate (implements java.awt.event.ActionListener, java.awt.event.ItemListener, java.io.Serializable)
    • javax.swing.DefaultDesktopManager (implements javax.swing.DesktopManager, java.io.Serializable)
    • javax.swing.DefaultListSelectionModel (implements java.lang.Cloneable, javax.swing.ListSelectionModel, java.io.Serializable)
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
      • javax.swing.JTree.DynamicUtilTreeNode
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
    • javax.swing.DefaultSingleSelectionModel (implements java.io.Serializable, javax.swing.SingleSelectionModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
      • javax.swing.JTree.EmptySelectionModel
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • javax.swing.UIDefaults
    • java.awt.FocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy (implements java.io.Serializable)
    • java.awt.Graphics
      • javax.swing.DebugGraphics
    • javax.swing.GroupLayout (implements java.awt.LayoutManager2)
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
      • javax.swing.GroupLayout.SequentialGroup
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
    • javax.swing.ImageIcon (implements javax.accessibility.Accessible, javax.swing.Icon, java.io.Serializable)
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • javax.swing.ProgressMonitorInputStream
    • javax.swing.InputVerifier
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
    • javax.swing.JRootPane.RootLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.JTabbedPane.ModelListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange (implements javax.accessibility.AccessibleTableModelChange)
    • javax.swing.JTree.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.JTree.TreeSelectionRedirector (implements java.io.Serializable, javax.swing.event.TreeSelectionListener)
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
    • javax.swing.LayoutStyle
    • javax.swing.LookAndFeel
    • javax.swing.MenuSelectionManager
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.ToolTipManager (implements java.awt.event.MouseMotionListener)
    • javax.swing.OverlayLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.Popup
    • javax.swing.PopupFactory
    • javax.swing.ProgressMonitor (implements javax.accessibility.Accessible)
    • javax.swing.RepaintManager
    • javax.swing.RowFilter<M,I>
    • javax.swing.RowFilter.Entry<M,I>
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
    • javax.swing.RowSorter.SortKey
    • javax.swing.ScrollPaneLayout (implements java.awt.LayoutManager, javax.swing.ScrollPaneConstants, java.io.Serializable)
      • javax.swing.ScrollPaneLayout.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.SizeRequirements (implements java.io.Serializable)
    • javax.swing.SizeSequence
    • javax.swing.Spring
    • javax.swing.SpringLayout (implements java.awt.LayoutManager2)
    • javax.swing.SpringLayout.Constraints
    • javax.swing.SwingUtilities (implements javax.swing.SwingConstants)
    • javax.swing.SwingWorker<T,V> (implements java.util.concurrent.RunnableFuture<V>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.UnsupportedLookAndFeelException
    • javax.swing.Timer (implements java.io.Serializable)
    • javax.swing.ToolTipManager.insideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.outsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.stillInsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.TransferHandler (implements java.io.Serializable)
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
      • javax.swing.JTable.DropLocation
      • javax.swing.JTree.DropLocation
    • javax.swing.TransferHandler.TransferSupport
    • javax.swing.UIDefaults.LazyInputMap (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIDefaults.ProxyLazyValue (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIManager (implements java.io.Serializable)
    • javax.swing.UIManager.LookAndFeelInfo
    • javax.swing.ViewportLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.JMenu.WinListener (implements java.io.Serializable)

Interface Hierarchy

  • javax.swing.BoundedRangeModel
  • javax.swing.CellEditor
  • javax.swing.ComboBoxEditor
  • javax.swing.DesktopManager
  • java.util.EventListener
    • java.awt.event.ActionListener
      • javax.swing.Action
  • javax.swing.Icon
  • java.awt.ItemSelectable
    • javax.swing.ButtonModel
  • javax.swing.JComboBox.KeySelectionManager
  • javax.swing.ListCellRenderer<E>
  • javax.swing.ListModel<E>
    • javax.swing.ComboBoxModel
      • javax.swing.MutableComboBoxModel
  • javax.swing.ListSelectionModel
  • javax.swing.MenuElement
  • javax.swing.Painter<T>
  • javax.swing.Renderer
  • javax.swing.RootPaneContainer
  • javax.swing.Scrollable
  • javax.swing.ScrollPaneConstants
  • javax.swing.SingleSelectionModel
  • javax.swing.SpinnerModel
  • javax.swing.SwingConstants
  • javax.swing.UIDefaults.ActiveValue
  • javax.swing.UIDefaults.LazyValue
  • javax.swing.WindowConstants

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.GroupLayout.Alignment
      • javax.swing.LayoutStyle.ComponentPlacement
      • javax.swing.RowFilter.ComparisonType
      • javax.swing.SortOrder
      • javax.swing.JTable.PrintMode
      • javax.swing.SwingWorker.StateValue
      • javax.swing.DropMode
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


JButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
    直接已知子类：
    BasicArrowButton, MetalComboBoxButton

    public class JButton
extends AbstractButton
implements Accessible
    An implementation of a "push" button.

    Buttons can be configured, and to some degree controlled, by Actions. Using an Action with a button has many benefits beyond directly configuring a button. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    See How to Use Buttons, Check Boxes, and Radio Buttons in The Java Tutorial for information and examples of using buttons.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JButton.AccessibleJButton
      This class implements accessibility support for the JButton class.

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JButton()
      Creates a button with no set text or icon.
      JButton(Action a)
      Creates a button where properties are taken from the Action supplied.
      JButton(Icon icon)
      Creates a button with an icon.
      JButton(String text)
      Creates a button with text.
      JButton(String text, Icon icon)
      Creates a button with initial text and an icon.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JButton.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      boolean isDefaultButton()
      Gets the value of the defaultButton property, which if true means that this button is the current default button for its JRootPane.
      boolean isDefaultCapable()
      Gets the value of the defaultCapable property.
      protected String paramString()
      Returns a string representation of this JButton.
      void removeNotify()
      Overrides JComponent.removeNotify to check if this button is currently set as the default button on the RootPane, and if so, sets the RootPane's default button to null to ensure the RootPane doesn't hold onto an invalid button reference.
      void setDefaultCapable(boolean defaultCapable)
      Sets the defaultCapable property, which determines whether this button can be made the default button for its root pane.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JButton

        public JButton()
        Creates a button with no set text or icon.

      • JButton

        public JButton(Icon icon)
        Creates a button with an icon.
        参数：
        icon - the Icon image to display on the button

      • JButton

        @ConstructorProperties(value="text")
public JButton(String text)
        Creates a button with text.
        参数：
        text - the text of the button

      • JButton

        public JButton(Action a)
        Creates a button where properties are taken from the Action supplied.
        参数：
        a - the Action used to specify the new button
        从以下版本开始：
        1.3

      • JButton

        public JButton(String text,
       Icon icon)
        Creates a button with initial text and an icon.
        参数：
        text - the text of the button
        icon - the Icon image to display on the button

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class AbstractButton
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ButtonUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • isDefaultButton

        public boolean isDefaultButton()
        Gets the value of the defaultButton property, which if true means that this button is the current default button for its JRootPane. Most look and feels render the default button differently, and may potentially provide bindings to access the default button.
        返回：
        the value of the defaultButton property
        另请参见：
        JRootPane.setDefaultButton(javax.swing.JButton), isDefaultCapable()

      • isDefaultCapable

        public boolean isDefaultCapable()
        Gets the value of the defaultCapable property.
        返回：
        the value of the defaultCapable property
        另请参见：
        setDefaultCapable(boolean), isDefaultButton(), JRootPane.setDefaultButton(javax.swing.JButton)

      • setDefaultCapable

        public void setDefaultCapable(boolean defaultCapable)
        Sets the defaultCapable property, which determines whether this button can be made the default button for its root pane. The default value of the defaultCapable property is true unless otherwise specified by the look and feel.
        参数：
        defaultCapable - true if this button will be capable of being the default button on the RootPane; otherwise false
        另请参见：
        isDefaultCapable()

      • removeNotify

        public void removeNotify()
        Overrides JComponent.removeNotify to check if this button is currently set as the default button on the RootPane, and if so, sets the RootPane's default button to null to ensure the RootPane doesn't hold onto an invalid button reference.
        重载：
        removeNotify in class AbstractButton
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • paramString

        protected String paramString()
        Returns a string representation of this JButton. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class AbstractButton
        返回：
        a string representation of this JButton

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JButton. For JButtons, the AccessibleContext takes the form of an AccessibleJButton. A new AccessibleJButton instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJButton that serves as the AccessibleContext of this JButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JButton.AccessibleJButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JButton.AccessibleJButton

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JButton.AccessibleJButton
  • 所有已实现的接口：
    Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
    封闭类：
    JButton

    protected class JButton.AccessibleJButton
extends AbstractButton.AccessibleAbstractButton
    This class implements accessibility support for the JButton class. It provides an implementation of the Java Accessibility API appropriate to button user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JButton.AccessibleJButton()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JButton.AccessibleJButton

        protected JButton.AccessibleJButton()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g evg,.e,.tII.ttvItta/a.ma/otom.sr(n)dnuuoo.af.hn


JCheckBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JCheckBox

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JToggleButton
              • javax.swing.JCheckBox
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants

    public class JCheckBox
extends JToggleButton
implements Accessible
    An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user. By convention, any number of check boxes in a group can be selected. See How to Use Buttons, Check Boxes, and Radio Buttons in The Java Tutorial for examples and information on using check boxes.

    Buttons can be configured, and to some degree controlled, by Actions. Using an Action with a button has many benefits beyond directly configuring a button. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JRadioButton

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JCheckBox.AccessibleJCheckBox
      This class implements accessibility support for the JCheckBox class.

      • Nested classes/interfaces inherited from class javax.swing.JToggleButton

        JToggleButton.AccessibleJToggleButton, JToggleButton.ToggleButtonModel

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String BORDER_PAINTED_FLAT_CHANGED_PROPERTY
      Identifies a change to the flat property.

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JCheckBox()
      Creates an initially unselected check box button with no text, no icon.
      JCheckBox(Action a)
      Creates a check box where properties are taken from the Action supplied.
      JCheckBox(Icon icon)
      Creates an initially unselected check box with an icon.
      JCheckBox(Icon icon, boolean selected)
      Creates a check box with an icon and specifies whether or not it is initially selected.
      JCheckBox(String text)
      Creates an initially unselected check box with text.
      JCheckBox(String text, boolean selected)
      Creates a check box with text and specifies whether or not it is initially selected.
      JCheckBox(String text, Icon icon)
      Creates an initially unselected check box with the specified text and icon.
      JCheckBox(String text, Icon icon, boolean selected)
      Creates a check box with text and icon, and specifies whether or not it is initially selected.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JCheckBox.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      boolean isBorderPaintedFlat()
      Gets the value of the borderPaintedFlat property.
      protected String paramString()
      Returns a string representation of this JCheckBox.
      void setBorderPaintedFlat(boolean b)
      Sets the borderPaintedFlat property, which gives a hint to the look and feel as to the appearance of the check box border.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BORDER_PAINTED_FLAT_CHANGED_PROPERTY

        public static final String BORDER_PAINTED_FLAT_CHANGED_PROPERTY
        Identifies a change to the flat property.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JCheckBox

        public JCheckBox()
        Creates an initially unselected check box button with no text, no icon.

      • JCheckBox

        public JCheckBox(Icon icon)
        Creates an initially unselected check box with an icon.
        参数：
        icon - the Icon image to display

      • JCheckBox

        public JCheckBox(Icon icon,
         boolean selected)
        Creates a check box with an icon and specifies whether or not it is initially selected.
        参数：
        icon - the Icon image to display
        selected - a boolean value indicating the initial selection state. If true the check box is selected

      • JCheckBox

        public JCheckBox(String text)
        Creates an initially unselected check box with text.
        参数：
        text - the text of the check box.

      • JCheckBox

        public JCheckBox(Action a)
        Creates a check box where properties are taken from the Action supplied.
        从以下版本开始：
        1.3

      • JCheckBox

        public JCheckBox(String text,
         boolean selected)
        Creates a check box with text and specifies whether or not it is initially selected.
        参数：
        text - the text of the check box.
        selected - a boolean value indicating the initial selection state. If true the check box is selected

      • JCheckBox

        public JCheckBox(String text,
         Icon icon)
        Creates an initially unselected check box with the specified text and icon.
        参数：
        text - the text of the check box.
        icon - the Icon image to display

      • JCheckBox

        public JCheckBox(String text,
         Icon icon,
         boolean selected)
        Creates a check box with text and icon, and specifies whether or not it is initially selected.
        参数：
        text - the text of the check box.
        icon - the Icon image to display
        selected - a boolean value indicating the initial selection state. If true the check box is selected

    • 方法详细信息

      • setBorderPaintedFlat

        public void setBorderPaintedFlat(boolean b)
        Sets the borderPaintedFlat property, which gives a hint to the look and feel as to the appearance of the check box border. This is usually set to true when a JCheckBox instance is used as a renderer in a component such as a JTable or JTree. The default value for the borderPaintedFlat property is false. This method fires a property changed event. Some look and feels might not implement flat borders; they will ignore this property.
        参数：
        b - true requests that the border be painted flat; false requests normal borders
        从以下版本开始：
        1.3
        另请参见：
        isBorderPaintedFlat()

      • isBorderPaintedFlat

        public boolean isBorderPaintedFlat()
        Gets the value of the borderPaintedFlat property.
        返回：
        the value of the borderPaintedFlat property
        从以下版本开始：
        1.3
        另请参见：
        setBorderPaintedFlat(boolean)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JToggleButton
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JToggleButton
        返回：
        the string "CheckBoxUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • paramString

        protected String paramString()
        Returns a string representation of this JCheckBox. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null. specific new aspects of the JFC components.
        重载：
        paramString in class JToggleButton
        返回：
        a string representation of this JCheckBox.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JCheckBox. For JCheckBoxes, the AccessibleContext takes the form of an AccessibleJCheckBox. A new AccessibleJCheckBox instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JToggleButton
        返回：
        an AccessibleJCheckBox that serves as the AccessibleContext of this JCheckBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JCheckBox.AccessibleJCheckBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JCheckBox.AccessibleJCheckBox

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JToggleButton.AccessibleJToggleButton
                • javax.swing.JCheckBox.AccessibleJCheckBox
  • 所有已实现的接口：
    ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
    封闭类：
    JCheckBox

    protected class JCheckBox.AccessibleJCheckBox
extends JToggleButton.AccessibleJToggleButton
    This class implements accessibility support for the JCheckBox class. It provides an implementation of the Java Accessibility API appropriate to check box user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JCheckBox.AccessibleJCheckBox()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JToggleButton.AccessibleJToggleButton

        itemStateChanged

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JCheckBox.AccessibleJCheckBox

        protected JCheckBox.AccessibleJCheckBox()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JToggleButton.AccessibleJToggleButton
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

maS>iemzemiuumiietnnmt.otngtoavP"etoLn>"")h e<,em


JCheckBoxMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JCheckBoxMenuItem

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JMenuItem
              • javax.swing.JCheckBoxMenuItem
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants

    public class JCheckBoxMenuItem
extends JMenuItem
implements SwingConstants, Accessible
    A menu item that can be selected or deselected. If selected, the menu item typically appears with a checkmark next to it. If unselected or deselected, the menu item appears without a checkmark. Like a regular menu item, a check box menu item can have either text or a graphic icon associated with it, or both.

    Either isSelected/setSelected or getState/setState can be used to determine/specify the menu item's selection state. The preferred methods are isSelected and setSelected, which work for all menus and buttons. The getState and setState methods exist for compatibility with other component sets.

    Menu items can be configured, and to some degree controlled, by Actions. Using an Action with a menu item has many benefits beyond directly configuring a menu item. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    For further information and examples of using check box menu items, see How to Use Menus, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      This class implements accessibility support for the JCheckBoxMenuItem class.

      • Nested classes/interfaces inherited from class javax.swing.JMenuItem

        JMenuItem.AccessibleJMenuItem

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JCheckBoxMenuItem()
      Creates an initially unselected check box menu item with no set text or icon.
      JCheckBoxMenuItem(Action a)
      Creates a menu item whose properties are taken from the Action supplied.
      JCheckBoxMenuItem(Icon icon)
      Creates an initially unselected check box menu item with an icon.
      JCheckBoxMenuItem(String text)
      Creates an initially unselected check box menu item with text.
      JCheckBoxMenuItem(String text, boolean b)
      Creates a check box menu item with the specified text and selection state.
      JCheckBoxMenuItem(String text, Icon icon)
      Creates an initially unselected check box menu item with the specified text and icon.
      JCheckBoxMenuItem(String text, Icon icon, boolean b)
      Creates a check box menu item with the specified text, icon, and selection state.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JCheckBoxMenuItem.
      Object[] getSelectedObjects()
      Returns an array (length 1) containing the check box menu item label or null if the check box is not selected.
      boolean getState()
      Returns the selected-state of the item.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JCheckBoxMenuItem.
      void setState(boolean b)
      Sets the selected-state of the item.

      • 方法 - 继承于类 javax.swing.JMenuItem

        actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getComponent, getMenuDragMouseListeners, getMenuKeyListeners, getSubElements, init, isArmed, menuSelectionChanged, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setAccelerator, setArmed, setEnabled, setModel, setUI, updateUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem()
        Creates an initially unselected check box menu item with no set text or icon.

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(Icon icon)
        Creates an initially unselected check box menu item with an icon.
        参数：
        icon - the icon of the CheckBoxMenuItem.

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(String text)
        Creates an initially unselected check box menu item with text.
        参数：
        text - the text of the CheckBoxMenuItem

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(Action a)
        Creates a menu item whose properties are taken from the Action supplied.
        从以下版本开始：
        1.3

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(String text,
                 Icon icon)
        Creates an initially unselected check box menu item with the specified text and icon.
        参数：
        text - the text of the CheckBoxMenuItem
        icon - the icon of the CheckBoxMenuItem

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(String text,
                 boolean b)
        Creates a check box menu item with the specified text and selection state.
        参数：
        text - the text of the check box menu item.
        b - the selected state of the check box menu item

      • JCheckBoxMenuItem

        public JCheckBoxMenuItem(String text,
                 Icon icon,
                 boolean b)
        Creates a check box menu item with the specified text, icon, and selection state.
        参数：
        text - the text of the check box menu item
        icon - the icon of the check box menu item
        b - the selected state of the check box menu item

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JMenuItem
        返回：
        "CheckBoxMenuItemUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getState

        public boolean getState()
        Returns the selected-state of the item. This method exists for AWT compatibility only. New code should use isSelected() instead.
        返回：
        true if the item is selected

      • setState

        public void setState(boolean b)
        Sets the selected-state of the item. This method exists for AWT compatibility only. New code should use setSelected() instead.
        参数：
        b - a boolean value indicating the item's selected-state, where true=selected

      • getSelectedObjects

        public Object[] getSelectedObjects()
        Returns an array (length 1) containing the check box menu item label or null if the check box is not selected.
        指定者：
        getSelectedObjects in interface ItemSelectable
        重载：
        getSelectedObjects in class AbstractButton
        返回：
        an array containing one Object -- the text of the menu item -- if the item is selected; otherwise null

      • paramString

        protected String paramString()
        Returns a string representation of this JCheckBoxMenuItem. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JMenuItem
        返回：
        a string representation of this JCheckBoxMenuItem.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JCheckBoxMenuItem. For JCheckBoxMenuItems, the AccessibleContext takes the form of an AccessibleJCheckBoxMenuItem. A new AccessibleJCheckBoxMenuItem instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JMenuItem
        返回：
        an AccessibleJCheckBoxMenuItem that serves as the AccessibleContext of this AccessibleJCheckBoxMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JMenuItem.AccessibleJMenuItem
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
    封闭类：
    JCheckBoxMenuItem

    protected class JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
extends JMenuItem.AccessibleJMenuItem
    This class implements accessibility support for the JCheckBoxMenuItem class. It provides an implementation of the Java Accessibility API appropriate to checkbox menu item user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JMenuItem.AccessibleJMenuItem

        stateChanged

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

        protected JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JMenuItem.AccessibleJMenuItem
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

npg/".r..rheerhh,lnncsoe


JColorChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JColorChooser

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JColorChooser
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JColorChooser
extends JComponent
implements Accessible
    JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color. For information about using color choosers, see How to Use Color Choosers, a section in The Java Tutorial.

    This class provides three levels of API:

    1. A static convenience method which shows a modal color-chooser dialog and returns the color selected by the user.
    2. A static convenience method for creating a color-chooser dialog where ActionListeners can be specified to be invoked when the user presses one of the dialog buttons.
    3. The ability to create instances of JColorChooser panes directly (within any container). PropertyChange listeners can be added to detect when the current "color" property changes.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JColorChooser.AccessibleJColorChooser
      This class implements accessibility support for the JColorChooser class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected AccessibleContext | accessibleContext
      static String CHOOSER_PANELS_PROPERTY
      The chooserPanel array property name.
      static String PREVIEW_PANEL_PROPERTY
      The preview panel property name.
      static String SELECTION_MODEL_PROPERTY
      The selection model property name.

      • Fields inherited from class javax.swing.JComponent

        listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JColorChooser()
      Creates a color chooser pane with an initial color of white.
      JColorChooser(Color initialColor)
      Creates a color chooser pane with the specified initial color.
      JColorChooser(ColorSelectionModel model)
      Creates a color chooser pane with the specified ColorSelectionModel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChooserPanel(AbstractColorChooserPanel panel)
      Adds a color chooser panel to the color chooser.
      static JDialog createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JColorChooser.
      AbstractColorChooserPanel[] getChooserPanels()
      Returns the specified color panels.
      Color getColor()
      Gets the current color value from the color chooser.
      boolean getDragEnabled()
      Gets the value of the dragEnabled property.
      JComponent getPreviewPanel()
      Returns the preview panel that shows a chosen color.
      ColorSelectionModel getSelectionModel()
      Returns the data model that handles color selections.
      ColorChooserUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JColorChooser.
      AbstractColorChooserPanel removeChooserPanel(AbstractColorChooserPanel panel)
      Removes the Color Panel specified.
      void setChooserPanels(AbstractColorChooserPanel[] panels)
      Specifies the Color Panels used to choose a color value.
      void setColor(Color color)
      Sets the current color of the color chooser to the specified color.
      void setColor(int c)
      Sets the current color of the color chooser to the specified color.
      void setColor(int r, int g, int b)
      Sets the current color of the color chooser to the specified RGB color.
      void setDragEnabled(boolean b)
      Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component.
      void setPreviewPanel(JComponent preview)
      Sets the current preview panel.
      void setSelectionModel(ColorSelectionModel newModel)
      Sets the model containing the selected color.
      void setUI(ColorChooserUI ui)
      Sets the L&F object that renders this component.
      static Color showDialog(Component component, String title, Color initialColor)
      Shows a modal color-chooser dialog and blocks until the dialog is hidden.
      void updateUI()
      Notification from the UIManager that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SELECTION_MODEL_PROPERTY

        public static final String SELECTION_MODEL_PROPERTY
        The selection model property name.
        另请参见：
        Constant Field Values

      • PREVIEW_PANEL_PROPERTY

        public static final String PREVIEW_PANEL_PROPERTY
        The preview panel property name.
        另请参见：
        Constant Field Values

      • CHOOSER_PANELS_PROPERTY

        public static final String CHOOSER_PANELS_PROPERTY
        The chooserPanel array property name.
        另请参见：
        Constant Field Values

      • accessibleContext

        protected AccessibleContext accessibleContext

    • 构造方法详细信息

      • JColorChooser

        public JColorChooser()
        Creates a color chooser pane with an initial color of white.

      • JColorChooser

        public JColorChooser(Color initialColor)
        Creates a color chooser pane with the specified initial color.
        参数：
        initialColor - the initial color set in the chooser

      • JColorChooser

        public JColorChooser(ColorSelectionModel model)
        Creates a color chooser pane with the specified ColorSelectionModel.
        参数：
        model - the ColorSelectionModel to be used

    • 方法详细信息

      • showDialog

        public static Color showDialog(Component component,
               String title,
               Color initialColor)
                        throws HeadlessException
        Shows a modal color-chooser dialog and blocks until the dialog is hidden. If the user presses the "OK" button, then this method hides/disposes the dialog and returns the selected color. If the user presses the "Cancel" button or closes the dialog without pressing "OK", then this method hides/disposes the dialog and returns null.
        参数：
        component - the parent Component for the dialog
        title - the String containing the dialog's title
        initialColor - the initial Color set when the color-chooser is shown
        返回：
        the selected color or null if the user opted out
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless()

      • createDialog

        public static JDialog createDialog(Component c,
                   String title,
                   boolean modal,
                   JColorChooser chooserPane,
                   ActionListener okListener,
                   ActionListener cancelListener)
                            throws HeadlessException
        Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons. If the "OK" or "Cancel" buttons are pressed, the dialog is automatically hidden (but not disposed). If the "Reset" button is pressed, the color-chooser's color will be reset to the color which was set the last time show was invoked on the dialog and the dialog will remain showing.
        参数：
        c - the parent component for the dialog
        title - the title for the dialog
        modal - a boolean. When true, the remainder of the program is inactive until the dialog is closed.
        chooserPane - the color-chooser to be placed inside the dialog
        okListener - the ActionListener invoked when "OK" is pressed
        cancelListener - the ActionListener invoked when "Cancel" is pressed
        返回：
        a new dialog containing the color-chooser pane
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getUI

        public ColorChooserUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the ColorChooserUI object that renders this component

      • setUI

        public void setUI(ColorChooserUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ColorChooserUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ColorChooserUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getColor

        public Color getColor()
        Gets the current color value from the color chooser. By default, this delegates to the model.
        返回：
        the current color value of the color chooser

      • setColor

        public void setColor(Color color)
        Sets the current color of the color chooser to the specified color. The ColorSelectionModel will fire a ChangeEvent
        参数：
        color - the color to be set in the color chooser
        另请参见：
        Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • setColor

        public void setColor(int r,
            int g,
            int b)
        Sets the current color of the color chooser to the specified RGB color. Note that the values of red, green, and blue should be between the numbers 0 and 255, inclusive.
        参数：
        r - an int specifying the amount of Red
        g - an int specifying the amount of Green
        b - an int specifying the amount of Blue
        抛出：
        IllegalArgumentException - if r,g,b values are out of range
        另请参见：
        Color

      • setColor

        public void setColor(int c)
        Sets the current color of the color chooser to the specified color.
        参数：
        c - an integer value that sets the current color in the chooser where the low-order 8 bits specify the Blue value, the next 8 bits specify the Green value, and the 8 bits above that specify the Red value.

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component. The transferHandler property needs to be set to a non-null value for the drag to do anything. The default value of the dragEnabled property is false.

        When automatic drag handling is enabled, most look and feels begin a drag-and-drop operation when the user presses the mouse button over the preview panel. Some look and feels might not support automatic drag and drop; they will ignore this property. You can work around such look and feels by modifying the component to directly call the exportAsDrag method of a TransferHandler.

        参数：
        b - the value to set the dragEnabled property to
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Gets the value of the dragEnabled property.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • setPreviewPanel

        public void setPreviewPanel(JComponent preview)
        Sets the current preview panel. This will fire a PropertyChangeEvent for the property named "previewPanel".
        参数：
        preview - the JComponent which displays the current color
        另请参见：
        Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getPreviewPanel

        public JComponent getPreviewPanel()
        Returns the preview panel that shows a chosen color.
        返回：
        a JComponent object -- the preview panel

      • addChooserPanel

        public void addChooserPanel(AbstractColorChooserPanel panel)
        Adds a color chooser panel to the color chooser.
        参数：
        panel - the AbstractColorChooserPanel to be added

      • removeChooserPanel

        public AbstractColorChooserPanel removeChooserPanel(AbstractColorChooserPanel panel)
        Removes the Color Panel specified.
        参数：
        panel - a string that specifies the panel to be removed
        返回：
        the color panel
        抛出：
        IllegalArgumentException - if panel is not in list of known chooser panels

      • setChooserPanels

        public void setChooserPanels(AbstractColorChooserPanel[] panels)
        Specifies the Color Panels used to choose a color value.
        参数：
        panels - an array of AbstractColorChooserPanel objects

      • getChooserPanels

        public AbstractColorChooserPanel[] getChooserPanels()
        Returns the specified color panels.
        返回：
        an array of AbstractColorChooserPanel objects

      • getSelectionModel

        public ColorSelectionModel getSelectionModel()
        Returns the data model that handles color selections.
        返回：
        a ColorSelectionModel object

      • setSelectionModel

        public void setSelectionModel(ColorSelectionModel newModel)
        Sets the model containing the selected color.
        参数：
        newModel - the new ColorSelectionModel object

      • paramString

        protected String paramString()
        Returns a string representation of this JColorChooser. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JColorChooser

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JColorChooser. For color choosers, the AccessibleContext takes the form of an AccessibleJColorChooser. A new AccessibleJColorChooser instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJColorChooser that serves as the AccessibleContext of this JColorChooser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JColorChooser.AccessibleJColorChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JColorChooser.AccessibleJColorChooser

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JColorChooser.AccessibleJColorChooser
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JColorChooser

    protected class JColorChooser.AccessibleJColorChooser
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JColorChooser class. It provides an implementation of the Java Accessibility API appropriate to color chooser user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JColorChooser.AccessibleJColorChooser()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JColorChooser.AccessibleJColorChooser

        protected JColorChooser.AccessibleJColorChooser()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>c,dc(ok(odCCoddhtwwh.otctlctaLea" .,>>axrtnmtr


JComboBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComboBox

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JComboBox
  • 所有已实现的接口：
    ActionListener, ImageObserver, ItemSelectable, MenuContainer, Serializable, EventListener, Accessible, ListDataListener

    public class JComboBox
extends JComponent
implements ItemSelectable, ListDataListener, ActionListener, Accessible
    A component that combines a button or editable field and a drop-down list. The user can select a value from the drop-down list, which appears at the user's request. If you make the combo box editable, then the combo box includes an editable field into which the user can type a value.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    See How to Use Combo Boxes in The Java Tutorial for further information.

    另请参见：
    ComboBoxModel, DefaultComboBoxModel

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JComboBox.AccessibleJComboBox
      This class implements accessibility support for the JComboBox class.
      static interface  JComboBox.KeySelectionManager
      The interface that defines a KeySelectionManager.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected String actionCommand
      This protected field is implementation specific.
      protected ComboBoxModel dataModel
      This protected field is implementation specific.
      protected ComboBoxEditor editor
      This protected field is implementation specific.
      protected boolean isEditable
      This protected field is implementation specific.
      protected JComboBox.KeySelectionManager keySelectionManager
      This protected field is implementation specific.
      protected boolean lightWeightPopupEnabled
      This protected field is implementation specific.
      protected int maximumRowCount
      This protected field is implementation specific.
      protected ListCellRenderer renderer
      This protected field is implementation specific.
      protected Object selectedItemReminder
      This protected field is implementation specific.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JComboBox()
      Creates a JComboBox with a default data model.
      JComboBox(ComboBoxModel aModel)
      Creates a JComboBox that takes its items from an existing ComboBoxModel.
      JComboBox(Object[] items)
      Creates a JComboBox that contains the elements in the specified array.
      JComboBox(Vector<?> items)
      Creates a JComboBox that contains the elements in the specified Vector.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void actionPerformed(ActionEvent e)
      This method is public as an implementation side effect.
      protected void actionPropertyChanged(Action action, String propertyName)
      Updates the combobox's state in response to property changes in associated action.
      void addActionListener(ActionListener l)
      Adds an ActionListener.
      void addItem(Object anObject)
      Adds an item to the item list.
      void addItemListener(ItemListener aListener)
      Adds an ItemListener.
      void addPopupMenuListener(PopupMenuListener l)
      Adds a PopupMenu listener which will listen to notification messages from the popup portion of the combo box.
      void configureEditor(ComboBoxEditor anEditor, Object anItem)
      Initializes the editor with the specified item.
      protected void configurePropertiesFromAction(Action a)
      Sets the properties on this combobox to match those in the specified Action.
      void contentsChanged(ListDataEvent e)
      This method is public as an implementation side effect.
      protected PropertyChangeListener createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      protected JComboBox.KeySelectionManager createDefaultKeySelectionManager()
      Returns an instance of the default key-selection manager.
      protected void fireActionEvent()
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireItemStateChanged(ItemEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      void firePopupMenuCanceled()
      Notifies PopupMenuListeners that the popup portion of the combo box has been canceled.
      void firePopupMenuWillBecomeInvisible()
      Notifies PopupMenuListeners that the popup portion of the combo box has become invisible.
      void firePopupMenuWillBecomeVisible()
      Notifies PopupMenuListeners that the popup portion of the combo box will become visible.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JComboBox.
      Action getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      String getActionCommand()
      Returns the action command that is included in the event sent to action listeners.
      ActionListener[] getActionListeners()
      Returns an array of all the ActionListeners added to this JComboBox with addActionListener().
      ComboBoxEditor getEditor()
      Returns the editor used to paint and edit the selected item in the JComboBox field.
      Object getItemAt(int index)
      Returns the list item at the specified index.
      int getItemCount()
      Returns the number of items in the list.
      ItemListener[] getItemListeners()
      Returns an array of all the ItemListeners added to this JComboBox with addItemListener().
      JComboBox.KeySelectionManager getKeySelectionManager()
      Returns the list's key-selection manager.
      int getMaximumRowCount()
      Returns the maximum number of items the combo box can display without a scrollbar
      ComboBoxModel getModel()
      Returns the data model currently used by the JComboBox.
      PopupMenuListener[] getPopupMenuListeners()
      Returns an array of all the PopupMenuListeners added to this JComboBox with addPopupMenuListener().
      Object getPrototypeDisplayValue()
      Returns the "prototypical display" value - an Object used for the calculation of the display height and width.
      ListCellRenderer getRenderer()
      Returns the renderer used to display the selected item in the JComboBox field.
      int getSelectedIndex()
      Returns the first item in the list that matches the given item.
      Object getSelectedItem()
      Returns the current selected item.
      Object[] getSelectedObjects()
      Returns an array containing the selected item.
      ComboBoxUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      void hidePopup()
      Causes the combo box to close its popup window.
      void insertItemAt(Object anObject, int index)
      Inserts an item into the item list at a given index.
      protected void | installAncestorListener()
      void intervalAdded(ListDataEvent e)
      This method is public as an implementation side effect.
      void intervalRemoved(ListDataEvent e)
      This method is public as an implementation side effect.
      boolean isEditable()
      Returns true if the JComboBox is editable.
      boolean isLightWeightPopupEnabled()
      Gets the value of the lightWeightPopupEnabled property.
      boolean isPopupVisible()
      Determines the visibility of the popup.
      protected String paramString()
      Returns a string representation of this JComboBox.
      void processKeyEvent(KeyEvent e)
      Handles KeyEvents, looking for the Tab key.
      void removeActionListener(ActionListener l)
      Removes an ActionListener.
      void removeAllItems()
      Removes all items from the item list.
      void removeItem(Object anObject)
      Removes an item from the item list.
      void removeItemAt(int anIndex)
      Removes the item at anIndex This method works only if the JComboBox uses a mutable data model.
      void removeItemListener(ItemListener aListener)
      Removes an ItemListener.
      void removePopupMenuListener(PopupMenuListener l)
      Removes a PopupMenuListener.
      protected void selectedItemChanged()
      This protected method is implementation specific.
      boolean selectWithKeyChar(char keyChar)
      Selects the list item that corresponds to the specified keyboard character and returns true, if there is an item corresponding to that character.
      void setAction(Action a)
      Sets the Action for the ActionEvent source.
      void setActionCommand(String aCommand)
      Sets the action command that should be included in the event sent to action listeners.
      void setEditable(boolean aFlag)
      Determines whether the JComboBox field is editable.
      void setEditor(ComboBoxEditor anEditor)
      Sets the editor used to paint and edit the selected item in the JComboBox field.
      void setEnabled(boolean b)
      Enables the combo box so that items can be selected.
      void setKeySelectionManager(JComboBox.KeySelectionManager aManager)
      Sets the object that translates a keyboard character into a list selection.
      void setLightWeightPopupEnabled(boolean aFlag)
      Sets the lightWeightPopupEnabled property, which provides a hint as to whether or not a lightweight Component should be used to contain the JComboBox, versus a heavyweight Component such as a Panel or a Window.
      void setMaximumRowCount(int count)
      Sets the maximum number of rows the JComboBox displays.
      void setModel(ComboBoxModel aModel)
      Sets the data model that the JComboBox uses to obtain the list of items.
      void setPopupVisible(boolean v)
      Sets the visibility of the popup.
      void setPrototypeDisplayValue(Object prototypeDisplayValue)
      Sets the prototype display value used to calculate the size of the display for the UI portion.
      void setRenderer(ListCellRenderer aRenderer)
      Sets the renderer that paints the list items and the item selected from the list in the JComboBox field.
      void setSelectedIndex(int anIndex)
      Selects the item at index anIndex.
      void setSelectedItem(Object anObject)
      Sets the selected item in the combo box display area to the object in the argument.
      void setUI(ComboBoxUI ui)
      Sets the L&F object that renders this component.
      void showPopup()
      Causes the combo box to display its popup window.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • dataModel

        protected ComboBoxModel dataModel
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        getModel(), setModel(javax.swing.ComboBoxModel)

      • renderer

        protected ListCellRenderer renderer
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        getRenderer(), setRenderer(javax.swing.ListCellRenderer)

      • editor

        protected ComboBoxEditor editor
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        getEditor(), setEditor(javax.swing.ComboBoxEditor)

      • maximumRowCount

        protected int maximumRowCount
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        getMaximumRowCount(), setMaximumRowCount(int)

      • isEditable

        protected boolean isEditable
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        isEditable, setEditable(boolean)

      • keySelectionManager

        protected JComboBox.KeySelectionManager keySelectionManager
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        setKeySelectionManager(javax.swing.JComboBox.KeySelectionManager), getKeySelectionManager()

      • actionCommand

        protected String actionCommand
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        setActionCommand(java.lang.String), getActionCommand()

      • lightWeightPopupEnabled

        protected boolean lightWeightPopupEnabled
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        setLightWeightPopupEnabled(boolean), isLightWeightPopupEnabled()

      • selectedItemReminder

        protected Object selectedItemReminder
        This protected field is implementation specific. Do not access directly or override.

    • 构造方法详细信息

      • JComboBox

        public JComboBox(ComboBoxModel aModel)
        Creates a JComboBox that takes its items from an existing ComboBoxModel. Since the ComboBoxModel is provided, a combo box created using this constructor does not create a default combo box model and may impact how the insert, remove and add methods behave.
        参数：
        aModel - the ComboBoxModel that provides the displayed list of items
        另请参见：
        DefaultComboBoxModel

      • JComboBox

        public JComboBox(Object[] items)
        Creates a JComboBox that contains the elements in the specified array. By default the first item in the array (and therefore the data model) becomes selected.
        参数：
        items - an array of objects to insert into the combo box
        另请参见：
        DefaultComboBoxModel

      • JComboBox

        public JComboBox(Vector<?> items)
        Creates a JComboBox that contains the elements in the specified Vector. By default the first item in the vector (and therefore the data model) becomes selected.
        参数：
        items - an array of vectors to insert into the combo box
        另请参见：
        DefaultComboBoxModel

      • JComboBox

        public JComboBox()
        Creates a JComboBox with a default data model. The default data model is an empty list of objects. Use addItem to add items. By default the first item in the data model becomes selected.
        另请参见：
        DefaultComboBoxModel

    • 方法详细信息

      • installAncestorListener

        protected void installAncestorListener()

      • setUI

        public void setUI(ComboBoxUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ComboBoxUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ComboBoxUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getUI

        public ComboBoxUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the ComboBoxUI object that renders this component

      • setModel

        public void setModel(ComboBoxModel aModel)
        Sets the data model that the JComboBox uses to obtain the list of items.
        参数：
        aModel - the ComboBoxModel that provides the displayed list of items

      • getModel

        public ComboBoxModel getModel()
        Returns the data model currently used by the JComboBox.
        返回：
        the ComboBoxModel that provides the displayed list of items

      • setLightWeightPopupEnabled

        public void setLightWeightPopupEnabled(boolean aFlag)
        Sets the lightWeightPopupEnabled property, which provides a hint as to whether or not a lightweight Component should be used to contain the JComboBox, versus a heavyweight Component such as a Panel or a Window. The decision of lightweight versus heavyweight is ultimately up to the JComboBox. Lightweight windows are more efficient than heavyweight windows, but lightweight and heavyweight components do not mix well in a GUI. If your application mixes lightweight and heavyweight components, you should disable lightweight popups. The default value for the lightWeightPopupEnabled property is true, unless otherwise specified by the look and feel. Some look and feels always use heavyweight popups, no matter what the value of this property.

        See the article Mixing Heavy and Light Components on The Swing Connection This method fires a property changed event.

        参数：
        aFlag - if true, lightweight popups are desired

      • isLightWeightPopupEnabled

        public boolean isLightWeightPopupEnabled()
        Gets the value of the lightWeightPopupEnabled property.
        返回：
        the value of the lightWeightPopupEnabled property
        另请参见：
        setLightWeightPopupEnabled(boolean)

      • setEditable

        public void setEditable(boolean aFlag)
        Determines whether the JComboBox field is editable. An editable JComboBox allows the user to type into the field or selected an item from the list to initialize the field, after which it can be edited. (The editing affects only the field, the list item remains intact.) A non editable JComboBox displays the selected item in the field, but the selection cannot be modified.
        参数：
        aFlag - a boolean value, where true indicates that the field is editable

      • isEditable

        public boolean isEditable()
        Returns true if the JComboBox is editable. By default, a combo box is not editable.
        返回：
        true if the JComboBox is editable, else false

      • setMaximumRowCount

        public void setMaximumRowCount(int count)
        Sets the maximum number of rows the JComboBox displays. If the number of objects in the model is greater than count, the combo box uses a scrollbar.
        参数：
        count - an integer specifying the maximum number of items to display in the list before using a scrollbar

      • getMaximumRowCount

        public int getMaximumRowCount()
        Returns the maximum number of items the combo box can display without a scrollbar
        返回：
        an integer specifying the maximum number of items that are displayed in the list before using a scrollbar

      • setRenderer

        public void setRenderer(ListCellRenderer aRenderer)
        Sets the renderer that paints the list items and the item selected from the list in the JComboBox field. The renderer is used if the JComboBox is not editable. If it is editable, the editor is used to render and edit the selected item.

        The default renderer displays a string or an icon. Other renderers can handle graphic images and composite items.

        To display the selected item, aRenderer.getListCellRendererComponent is called, passing the list object and an index of -1.

        参数：
        aRenderer - the ListCellRenderer that displays the selected item
        另请参见：
        setEditor(javax.swing.ComboBoxEditor)

      • getRenderer

        public ListCellRenderer getRenderer()
        Returns the renderer used to display the selected item in the JComboBox field.
        返回：
        the ListCellRenderer that displays the selected item.

      • setEditor

        public void setEditor(ComboBoxEditor anEditor)
        Sets the editor used to paint and edit the selected item in the JComboBox field. The editor is used only if the receiving JComboBox is editable. If not editable, the combo box uses the renderer to paint the selected item.
        参数：
        anEditor - the ComboBoxEditor that displays the selected item
        另请参见：
        setRenderer(javax.swing.ListCellRenderer)

      • getEditor

        public ComboBoxEditor getEditor()
        Returns the editor used to paint and edit the selected item in the JComboBox field.
        返回：
        the ComboBoxEditor that displays the selected item

      • setSelectedItem

        public void setSelectedItem(Object anObject)
        Sets the selected item in the combo box display area to the object in the argument. If anObject is in the list, the display area shows anObject selected.

        If anObject is not in the list and the combo box is uneditable, it will not change the current selection. For editable combo boxes, the selection will change to anObject.

        If this constitutes a change in the selected item, ItemListeners added to the combo box will be notified with one or two ItemEvents. If there is a current selected item, an ItemEvent will be fired and the state change will be ItemEvent.DESELECTED. If anObject is in the list and is not currently selected then an ItemEvent will be fired and the state change will be ItemEvent.SELECTED.

        ActionListeners added to the combo box will be notified with an ActionEvent when this method is called.

        参数：
        anObject - the list object to select; use null to clear the selection

      • getSelectedItem

        public Object getSelectedItem()
        Returns the current selected item.

        If the combo box is editable, then this value may not have been added to the combo box with addItem, insertItemAt or the data constructors.

        返回：
        the current selected Object
        另请参见：
        setSelectedItem(java.lang.Object)

      • setSelectedIndex

        public void setSelectedIndex(int anIndex)
        Selects the item at index anIndex.
        参数：
        anIndex - an integer specifying the list item to select, where 0 specifies the first item in the list and -1 indicates no selection
        抛出：
        IllegalArgumentException - if anIndex < -1 or anIndex is greater than or equal to size

      • getSelectedIndex

        public int getSelectedIndex()
        Returns the first item in the list that matches the given item. The result is not always defined if the JComboBox allows selected items that are not in the list. Returns -1 if there is no selected item or if the user specified an item which is not in the list.
        返回：
        an integer specifying the currently selected list item, where 0 specifies the first item in the list; or -1 if no item is selected or if the currently selected item is not in the list

      • getPrototypeDisplayValue

        public Object getPrototypeDisplayValue()
        Returns the "prototypical display" value - an Object used for the calculation of the display height and width.
        返回：
        the value of the prototypeDisplayValue property
        从以下版本开始：
        1.4
        另请参见：
        setPrototypeDisplayValue(java.lang.Object)

      • setPrototypeDisplayValue

        public void setPrototypeDisplayValue(Object prototypeDisplayValue)
        Sets the prototype display value used to calculate the size of the display for the UI portion.

        If a prototype display value is specified, the preferred size of the combo box is calculated by configuring the renderer with the prototype display value and obtaining its preferred size. Specifying the preferred display value is often useful when the combo box will be displaying large amounts of data. If no prototype display value has been specified, the renderer must be configured for each value from the model and its preferred size obtained, which can be relatively expensive.

        参数：
        prototypeDisplayValue -
        从以下版本开始：
        1.4
        另请参见：
        getPrototypeDisplayValue()

      • addItem

        public void addItem(Object anObject)
        Adds an item to the item list. This method works only if the JComboBox uses a mutable data model.

        警告： Focus and keyboard navigation problems may arise if you add duplicate String objects. A workaround is to add new objects instead of String objects and make sure that the toString() method is defined. For example:

           comboBox.addItem(makeObj("Item 1"));
   comboBox.addItem(makeObj("Item 1"));
   ...
   private Object makeObj(final String item)  {
     return new Object() { public String toString() { return item; } };
   }
        参数：
        anObject - the Object to add to the list
        另请参见：
        MutableComboBoxModel

      • insertItemAt

        public void insertItemAt(Object anObject,
                int index)
        Inserts an item into the item list at a given index. This method works only if the JComboBox uses a mutable data model.
        参数：
        anObject - the Object to add to the list
        index - an integer specifying the position at which to add the item
        另请参见：
        MutableComboBoxModel

      • removeItem

        public void removeItem(Object anObject)
        Removes an item from the item list. This method works only if the JComboBox uses a mutable data model.
        参数：
        anObject - the object to remove from the item list
        另请参见：
        MutableComboBoxModel

      • removeItemAt

        public void removeItemAt(int anIndex)
        Removes the item at anIndex This method works only if the JComboBox uses a mutable data model.
        参数：
        anIndex - an int specifying the index of the item to remove, where 0 indicates the first item in the list
        另请参见：
        MutableComboBoxModel

      • removeAllItems

        public void removeAllItems()
        Removes all items from the item list.

      • showPopup

        public void showPopup()
        Causes the combo box to display its popup window.
        另请参见：
        setPopupVisible(boolean)

      • hidePopup

        public void hidePopup()
        Causes the combo box to close its popup window.
        另请参见：
        setPopupVisible(boolean)

      • setPopupVisible

        public void setPopupVisible(boolean v)
        Sets the visibility of the popup.

      • isPopupVisible

        public boolean isPopupVisible()
        Determines the visibility of the popup.
        返回：
        true if the popup is visible, otherwise returns false

      • addItemListener

        public void addItemListener(ItemListener aListener)
        Adds an ItemListener.

        aListener will receive one or two ItemEvents when the selected item changes.

        指定者：
        addItemListener in interface ItemSelectable
        参数：
        aListener - the ItemListener that is to be notified
        另请参见：
        setSelectedItem(java.lang.Object)

      • removeItemListener

        public void removeItemListener(ItemListener aListener)
        Removes an ItemListener.
        指定者：
        removeItemListener in interface ItemSelectable
        参数：
        aListener - the ItemListener to remove
        另请参见：
        ItemEvent

      • getItemListeners

        public ItemListener[] getItemListeners()
        Returns an array of all the ItemListeners added to this JComboBox with addItemListener().
        返回：
        all of the ItemListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • addActionListener

        public void addActionListener(ActionListener l)
        Adds an ActionListener.

        The ActionListener will receive an ActionEvent when a selection has been made. If the combo box is editable, then an ActionEvent will be fired when editing has stopped.

        参数：
        l - the ActionListener that is to be notified
        另请参见：
        setSelectedItem(java.lang.Object)

      • removeActionListener

        public void removeActionListener(ActionListener l)
        Removes an ActionListener.
        参数：
        l - the ActionListener to remove

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the ActionListeners added to this JComboBox with addActionListener().
        返回：
        all of the ActionListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • addPopupMenuListener

        public void addPopupMenuListener(PopupMenuListener l)
        Adds a PopupMenu listener which will listen to notification messages from the popup portion of the combo box.

        For all standard look and feels shipped with Java, the popup list portion of combo box is implemented as a JPopupMenu. A custom look and feel may not implement it this way and will therefore not receive the notification.

        参数：
        l - the PopupMenuListener to add
        从以下版本开始：
        1.4

      • removePopupMenuListener

        public void removePopupMenuListener(PopupMenuListener l)
        Removes a PopupMenuListener.
        参数：
        l - the PopupMenuListener to remove
        从以下版本开始：
        1.4
        另请参见：
        addPopupMenuListener(javax.swing.event.PopupMenuListener)

      • getPopupMenuListeners

        public PopupMenuListener[] getPopupMenuListeners()
        Returns an array of all the PopupMenuListeners added to this JComboBox with addPopupMenuListener().
        返回：
        all of the PopupMenuListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • firePopupMenuWillBecomeVisible

        public void firePopupMenuWillBecomeVisible()
        Notifies PopupMenuListeners that the popup portion of the combo box will become visible.

        This method is public but should not be called by anything other than the UI delegate.

        从以下版本开始：
        1.4
        另请参见：
        addPopupMenuListener(javax.swing.event.PopupMenuListener)

      • firePopupMenuWillBecomeInvisible

        public void firePopupMenuWillBecomeInvisible()
        Notifies PopupMenuListeners that the popup portion of the combo box has become invisible.

        This method is public but should not be called by anything other than the UI delegate.

        从以下版本开始：
        1.4
        另请参见：
        addPopupMenuListener(javax.swing.event.PopupMenuListener)

      • firePopupMenuCanceled

        public void firePopupMenuCanceled()
        Notifies PopupMenuListeners that the popup portion of the combo box has been canceled.

        This method is public but should not be called by anything other than the UI delegate.

        从以下版本开始：
        1.4
        另请参见：
        addPopupMenuListener(javax.swing.event.PopupMenuListener)

      • setActionCommand

        public void setActionCommand(String aCommand)
        Sets the action command that should be included in the event sent to action listeners.
        参数：
        aCommand - a string containing the "command" that is sent to action listeners; the same listener can then do different things depending on the command it receives

      • getActionCommand

        public String getActionCommand()
        Returns the action command that is included in the event sent to action listeners.
        返回：
        the string containing the "command" that is sent to action listeners.

      • setAction

        public void setAction(Action a)
        Sets the Action for the ActionEvent source. The new Action replaces any previously set Action but does not affect ActionListeners independently added with addActionListener. If the Action is already a registered ActionListener for the ActionEvent source, it is not re-registered.

        Setting the Action results in immediately changing all the properties described in Swing Components Supporting Action. Subsequently, the combobox's properties are automatically updated as the Action's properties change.

        This method uses three other methods to set and help track the Action's property values. It uses the configurePropertiesFromAction method to immediately change the combobox's properties. To track changes in the Action's property values, this method registers the PropertyChangeListener returned by createActionPropertyChangeListener. The default PropertyChangeListener invokes the actionPropertyChanged method when a property in the Action changes.

        参数：
        a - the Action for the JComboBox, or null.
        从以下版本开始：
        1.3
        另请参见：
        Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

      • getAction

        public Action getAction()
        Returns the currently set Action for this ActionEvent source, or null if no Action is set.
        返回：
        the Action for this ActionEvent source; or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • configurePropertiesFromAction

        protected void configurePropertiesFromAction(Action a)
        Sets the properties on this combobox to match those in the specified Action. Refer to Swing Components Supporting Action for more details as to which properties this sets.
        参数：
        a - the Action from which to get the properties, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • createActionPropertyChangeListener

        protected PropertyChangeListener createActionPropertyChangeListener(Action a)
        Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.

        警告： If you subclass this do not create an anonymous inner class. If you do the lifetime of the combobox will be tied to that of the Action.

        参数：
        a - the combobox's action
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • actionPropertyChanged

        protected void actionPropertyChanged(Action action,
                         String propertyName)
        Updates the combobox's state in response to property changes in associated action. This method is invoked from the PropertyChangeListener returned from createActionPropertyChangeListener. Subclasses do not normally need to invoke this. Subclasses that support additional Action properties should override this and configurePropertiesFromAction.

        Refer to the table at Swing Components Supporting Action for a list of the properties this method sets.

        参数：
        action - the Action associated with this combobox
        propertyName - the name of the property that changed
        从以下版本开始：
        1.6
        另请参见：
        Action, configurePropertiesFromAction(javax.swing.Action)

      • fireItemStateChanged

        protected void fireItemStateChanged(ItemEvent e)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        e - the event of interest
        另请参见：
        EventListenerList

      • fireActionEvent

        protected void fireActionEvent()
        Notifies all listeners that have registered interest for notification on this event type.
        另请参见：
        EventListenerList

      • selectedItemChanged

        protected void selectedItemChanged()
        This protected method is implementation specific. Do not access directly or override.

      • getSelectedObjects

        public Object[] getSelectedObjects()
        Returns an array containing the selected item. This method is implemented for compatibility with ItemSelectable.
        指定者：
        getSelectedObjects in interface ItemSelectable
        返回：
        an array of Objects containing one element -- the selected item

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        This method is public as an implementation side effect. do not call or override.
        指定者：
        actionPerformed in interface ActionListener

      • contentsChanged

        public void contentsChanged(ListDataEvent e)
        This method is public as an implementation side effect. do not call or override.
        指定者：
        contentsChanged in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        This method is public as an implementation side effect. do not call or override.
        指定者：
        intervalAdded in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        This method is public as an implementation side effect. do not call or override.
        指定者：
        intervalRemoved in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • selectWithKeyChar

        public boolean selectWithKeyChar(char keyChar)
        Selects the list item that corresponds to the specified keyboard character and returns true, if there is an item corresponding to that character. Otherwise, returns false.
        参数：
        keyChar - a char, typically this is a keyboard key typed by the user

      • setEnabled

        public void setEnabled(boolean b)
        Enables the combo box so that items can be selected. When the combo box is disabled, items cannot be selected and values cannot be typed into its field (if it is editable).
        重载：
        setEnabled in class JComponent
        参数：
        b - a boolean value, where true enables the component and false disables it
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • configureEditor

        public void configureEditor(ComboBoxEditor anEditor,
                   Object anItem)
        Initializes the editor with the specified item.
        参数：
        anEditor - the ComboBoxEditor that displays the list item in the combo box field and allows it to be edited
        anItem - the object to display and edit in the field

      • processKeyEvent

        public void processKeyEvent(KeyEvent e)
        Handles KeyEvents, looking for the Tab key. If the Tab key is found, the popup window is closed.
        重载：
        processKeyEvent in class JComponent
        参数：
        e - the KeyEvent containing the keyboard key that was pressed
        另请参见：
        KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

      • setKeySelectionManager

        public void setKeySelectionManager(JComboBox.KeySelectionManager aManager)
        Sets the object that translates a keyboard character into a list selection. Typically, the first selection with a matching first character becomes the selected item.

      • getKeySelectionManager

        public JComboBox.KeySelectionManager getKeySelectionManager()
        Returns the list's key-selection manager.
        返回：
        the KeySelectionManager currently in use

      • getItemCount

        public int getItemCount()
        Returns the number of items in the list.
        返回：
        an integer equal to the number of items in the list

      • getItemAt

        public Object getItemAt(int index)
        Returns the list item at the specified index. If index is out of range (less than zero or greater than or equal to size) it will return null.
        参数：
        index - an integer indicating the list position, where the first item starts at zero
        返回：
        the Object at that list position; or null if out of range

      • createDefaultKeySelectionManager

        protected JComboBox.KeySelectionManager createDefaultKeySelectionManager()
        Returns an instance of the default key-selection manager.
        返回：
        the KeySelectionManager currently used by the list
        另请参见：
        setKeySelectionManager(javax.swing.JComboBox.KeySelectionManager)

      • paramString

        protected String paramString()
        Returns a string representation of this JComboBox. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JComboBox

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JComboBox. For combo boxes, the AccessibleContext takes the form of an AccessibleJComboBox. A new AccessibleJComboBox instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJComboBox that serves as the AccessibleContext of this JComboBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JComboBox.AccessibleJComboBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComboBox.AccessibleJComboBox

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JComboBox.AccessibleJComboBox
  • 所有已实现的接口：
    Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection
    封闭类：
    JComboBox

    protected class JComboBox.AccessibleJComboBox
extends JComponent.AccessibleJComponent
implements AccessibleAction, AccessibleSelection
    This class implements accessibility support for the JComboBox class. It provides an implementation of the Java Accessibility API appropriate to Combo Box user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

    • 构造方法摘要

      Constructors
      构造方法与描述
      JComboBox.AccessibleJComboBox()
      Returns an AccessibleJComboBox instance

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified Accessible child of the object to the object's selection.
      void clearAccessibleSelection()
      Clears the selection in the object, so that no children in the object are selected.
      boolean doAccessibleAction(int i)
      Perform the specified Action on the object
      AccessibleAction getAccessibleAction()
      Get the AccessibleAction associated with this object.
      int getAccessibleActionCount()
      Returns the number of Actions available in this object.
      String getAccessibleActionDescription(int i)
      Return a description of the specified action of the object.
      Accessible getAccessibleChild(int i)
      Returns the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected child in the popup.
      int getAccessibleSelectionCount()
      Returns the number of Accessible children currently selected.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      boolean isAccessibleChildSelected(int i)
      Determines if the current child of this object is selected.
      void removeAccessibleSelection(int i)
      Removes the specified child of the object from the object's selection.
      void selectAllAccessibleSelection()
      Causes every child of the object to be selected if the object supports multiple selections.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JComboBox.AccessibleJComboBox

        public JComboBox.AccessibleJComboBox()
        Returns an AccessibleJComboBox instance
        从以下版本开始：
        1.4

    • 方法详细信息

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the nth Accessible child of the object. The child at index zero represents the popup. If the combo box is editable, the child at index one represents the editor.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object. The AccessibleStateSet of an object is composed of a set of unique AccessibleStates. A change in the AccessibleStateSet of an object will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_STATE_PROPERTY property.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleStateSet, AccessibleState, JComponent.AccessibleJComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Get the AccessibleAction associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleAction interface on behalf of itself.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleAction

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Return a description of the specified action of the object.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        参数：
        i - zero-based index of the actions
        返回：
        a String description of the action
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of Actions available in this object. The default behavior of a combo box is to have one action.
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        返回：
        1, the number of Actions in this object

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Perform the specified Action on the object
        指定者：
        doAccessibleAction in interface AccessibleAction
        参数：
        i - zero-based index of actions
        返回：
        true if the the action was performed; else false.
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns the number of Accessible children currently selected. If no children are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected.
        从以下版本开始：
        1.3

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns an Accessible representing the specified selected child in the popup. If there isn't a selection, or there are fewer children selected than the integer passed in, the return value will be null.

        Note that the index represents the i-th selected child, which is different from the i-th child.

        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected children
        返回：
        the i-th selected child
        从以下版本开始：
        1.3
        另请参见：
        getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Determines if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false
        从以下版本开始：
        1.3
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Adds the specified Accessible child of the object to the object's selection. If the object supports multiple selections, the specified child is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified child is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        从以下版本开始：
        1.3
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the specified child of the object from the object's selection. If the specified item isn't currently selected, this method has no effect.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        从以下版本开始：
        1.3
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that no children in the object are selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection
        从以下版本开始：
        1.3

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Causes every child of the object to be selected if the object supports multiple selections.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

melmatawtajvvajj. tt ,>ue/ r/=f/hta.vGlll/nfamno.l.


JComboBox.KeySelectionManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface JComboBox.KeySelectionManager

  • 封闭类：
    JComboBox

    public static interface JComboBox.KeySelectionManager
    The interface that defines a KeySelectionManager. To qualify as a KeySelectionManager, the class needs to implement the method that identifies the list index given a character and the combo box data model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int selectionForKey(char aKey, ComboBoxModel aModel)
      Given aKey and the model, returns the row that should become selected.

    • 方法详细信息

      • selectionForKey

        int selectionForKey(char aKey,
                  ComboBoxModel aModel)
        Given aKey and the model, returns the row that should become selected. Return -1 if no match was found.
        参数：
        aKey - a char value, usually indicating a keyboard key that was pressed
        aModel - a ComboBoxModel -- the component's data model, containing the list of selectable items
        返回：
        an int equal to the selected row, where 0 is the first item and -1 is none.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"eimbeeleelccelltveepowo/np/jj/."c


JComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComponent

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable
    直接已知子类：
    AbstractButton, BasicInternalFrameTitlePane, Box, Box.Filler, JColorChooser, JComboBox, JFileChooser, JInternalFrame, JInternalFrame.JDesktopIcon, JLabel, JLayer, JLayeredPane, JList, JMenuBar, JOptionPane, JPanel, JPopupMenu, JProgressBar, JRootPane, JScrollBar, JScrollPane, JSeparator, JSlider, JSpinner, JSplitPane, JTabbedPane, JTable, JTableHeader, JTextComponent, JToolBar, JToolTip, JTree, JViewport

    public abstract class JComponent
extends Container
implements Serializable
    The base class for all Swing components except top-level containers. To use a component that inherits from JComponent, you must place the component in a containment hierarchy whose root is a top-level Swing container. Top-level Swing containers -- such as JFrame, JDialog, and JApplet -- are specialized components that provide a place for other Swing components to paint themselves. For an explanation of containment hierarchies, see Swing Components and the Containment Hierarchy, a section in The Java Tutorial.

    The JComponent class provides:

    • The base class for both standard and custom components that use the Swing architecture.
    • A "pluggable look and feel" (L&F) that can be specified by the programmer or (optionally) selected by the user at runtime. The look and feel for each component is provided by a UI delegate -- an object that descends from ComponentUI. See How to Set the Look and Feel in The Java Tutorial for more information.
    • Comprehensive keystroke handling. See the document Keyboard Bindings in Swing, an article in The Swing Connection, for more information.
    • Support for tool tips -- short descriptions that pop up when the cursor lingers over a component. See How to Use Tool Tips in The Java Tutorial for more information.
    • Support for accessibility. JComponent contains all of the methods in the Accessible interface, but it doesn't actually implement the interface. That is the responsibility of the individual classes that extend JComponent.
    • Support for component-specific properties. With the putClientProperty(java.lang.Object, java.lang.Object) and getClientProperty(java.lang.Object) methods, you can associate name-object pairs with any object that descends from JComponent.
    • An infrastructure for painting that includes double buffering and support for borders. For more information see Painting and How to Use Borders, both of which are sections in The Java Tutorial.
    For more information on these subjects, see the Swing package description and The Java Tutorial section The JComponent Class.

    JComponent and its subclasses document default values for certain properties. For example, JTable documents the default row height as 16. Each JComponent subclass that has a ComponentUI will create the ComponentUI as part of its constructor. In order to provide a particular look and feel each ComponentUI may set properties back on the JComponent that created it. For example, a custom look and feel may require JTables to have a row height of 24. The documented defaults are the value of a property BEFORE the ComponentUI has been installed. If you need a specific value for a particular property you should explicitly set it.

    In release 1.4, the focus subsystem was rearchitected. For more information, see How to Use the Focus Subsystem, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    KeyStroke, Action, setBorder(javax.swing.border.Border), registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int), JOptionPane, setDebugGraphicsOptions(int), setToolTipText(java.lang.String), setAutoscrolls(boolean)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  JComponent.AccessibleJComponent
      Inner class of JComponent used to provide default support for accessibility.

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AccessibleContext accessibleContext
      The AccessibleContext associated with this JComponent.
      protected EventListenerList listenerList
      A list of event listeners for this component.
      static String TOOL_TIP_TEXT_KEY
      The comment to display when the cursor is over the component, also known as a "value tip", "flyover help", or "flyover label".
      protected ComponentUI ui
      The look and feel delegate for this component.
      static int UNDEFINED_CONDITION
      Constant used by some of the APIs to mean that no condition is defined.
      static int WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
      Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is an ancestor of the focused component or is itself the focused component.
      static int WHEN_FOCUSED
      Constant used for registerKeyboardAction that means that the command should be invoked when the component has the focus.
      static int WHEN_IN_FOCUSED_WINDOW
      Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is in the window that has the focus or is itself the focused component.

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JComponent()
      Default JComponent constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAncestorListener(AncestorListener listener)
      Registers listener so that it will receive AncestorEvents when it or any of its ancestors move or are made visible or invisible.
      void addNotify()
      Notifies this component that it now has a parent component.
      void addVetoableChangeListener(VetoableChangeListener listener)
      Adds a VetoableChangeListener to the listener list.
      void computeVisibleRect(Rectangle visibleRect)
      Returns the Component's "visible rect rectangle" - the intersection of the visible rectangles for this component and all of its ancestors.
      boolean contains(int x, int y)
      Gives the UI delegate an opportunity to define the precise shape of this component for the sake of mouse processing.
      JToolTip createToolTip()
      Returns the instance of JToolTip that should be used to display the tooltip.
      void disable()
      Deprecated.
      As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
      void enable()
      Deprecated.
      As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
      void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
      Support for reporting bound property changes for boolean properties.
      void firePropertyChange(String propertyName, char oldValue, char newValue)
      Reports a bound property change.
      void firePropertyChange(String propertyName, int oldValue, int newValue)
      Support for reporting bound property changes for integer properties.
      protected void fireVetoableChange(String propertyName, Object oldValue, Object newValue)
      Supports reporting constrained property changes.
      AccessibleContext getAccessibleContext()
      Returns the AccessibleContext associated with this JComponent.
      ActionListener getActionForKeyStroke(KeyStroke aKeyStroke)
      Returns the object that will perform the action registered for a given keystroke.
      ActionMap getActionMap()
      Returns the ActionMap used to determine what Action to fire for particular KeyStroke binding.
      float getAlignmentX()
      Overrides Container.getAlignmentX to return the vertical alignment.
      float getAlignmentY()
      Overrides Container.getAlignmentY to return the horizontal alignment.
      AncestorListener[] getAncestorListeners()
      Returns an array of all the ancestor listeners registered on this component.
      boolean getAutoscrolls()
      Gets the autoscrolls property.
      int getBaseline(int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior()
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Border getBorder()
      Returns the border of this component or null if no border is currently set.
      Rectangle getBounds(Rectangle rv)
      Stores the bounds of this component into "return value" rv and returns rv.
      Object getClientProperty(Object key)
      Returns the value of the property with the specified key.
      protected Graphics getComponentGraphics(Graphics g)
      Returns the graphics object used to paint this component.
      JPopupMenu getComponentPopupMenu()
      Returns JPopupMenu that assigned for this component.
      int getConditionForKeyStroke(KeyStroke aKeyStroke)
      Returns the condition that determines whether a registered action occurs in response to the specified keystroke.
      int getDebugGraphicsOptions()
      Returns the state of graphics debugging.
      static Locale getDefaultLocale()
      Returns the default locale used to initialize each JComponent's locale property upon creation.
      FontMetrics getFontMetrics(Font font)
      Gets the FontMetrics for the specified Font.
      Graphics getGraphics()
      Returns this component's graphics context, which lets you draw on a component.
      int getHeight()
      Returns the current height of this component.
      boolean getInheritsPopupMenu()
      Returns true if the JPopupMenu should be inherited from the parent.
      InputMap getInputMap()
      Returns the InputMap that is used when the component has focus.
      InputMap getInputMap(int condition)
      Returns the InputMap that is used during condition.
      InputVerifier getInputVerifier()
      Returns the input verifier for this component.
      Insets getInsets()
      If a border has been set on this component, returns the border's insets; otherwise calls super.getInsets.
      Insets getInsets(Insets insets)
      Returns an Insets object containing this component's inset values.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this JComponent.
      Point getLocation(Point rv)
      Stores the x,y origin of this component into "return value" rv and returns rv.
      Dimension getMaximumSize()
      If the maximum size has been set to a non-null value just returns it.
      Dimension getMinimumSize()
      If the minimum size has been set to a non-null value just returns it.
      Component getNextFocusableComponent()
      Deprecated.
      As of 1.4, replaced by FocusTraversalPolicy.
      Point getPopupLocation(MouseEvent event)
      Returns the preferred location to display the popup menu in this component's coordinate system.
      Dimension getPreferredSize()
      If the preferredSize has been set to a non-null value just returns it.
      KeyStroke[] getRegisteredKeyStrokes()
      Returns the KeyStrokes that will initiate registered actions.
      JRootPane getRootPane()
      Returns the JRootPane ancestor for this component.
      Dimension getSize(Dimension rv)
      Stores the width/height of this component into "return value" rv and returns rv.
      Point getToolTipLocation(MouseEvent event)
      Returns the tooltip location in this component's coordinate system.
      String getToolTipText()
      Returns the tooltip string that has been set with setToolTipText.
      String getToolTipText(MouseEvent event)
      Returns the string to be used as the tooltip for event.
      Container getTopLevelAncestor()
      Returns the top-level ancestor of this component (either the containing Window or Applet), or null if this component has not been added to any container.
      TransferHandler getTransferHandler()
      Gets the transferHandler property.
      String getUIClassID()
      Returns the UIDefaults key used to look up the name of the swing.plaf.ComponentUI class that defines the look and feel for this component.
      boolean getVerifyInputWhenFocusTarget()
      Returns the value that indicates whether the input verifier for the current focus owner will be called before this component requests focus.
      VetoableChangeListener[] getVetoableChangeListeners()
      Returns an array of all the vetoable change listeners registered on this component.
      Rectangle getVisibleRect()
      Returns the Component's "visible rectangle" - the intersection of this component's visible rectangle, new Rectangle(0, 0, getWidth(), getHeight()), and all of its ancestors' visible rectangles.
      int getWidth()
      Returns the current width of this component.
      int getX()
      Returns the current x coordinate of the component's origin.
      int getY()
      Returns the current y coordinate of the component's origin.
      void grabFocus()
      Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window.
      boolean isDoubleBuffered()
      Returns whether this component should use a buffer to paint.
      static boolean isLightweightComponent(Component c)
      Returns true if this component is lightweight, that is, if it doesn't have a native window system peer.
      boolean isManagingFocus()
      Deprecated.
      As of 1.4, replaced by Component.setFocusTraversalKeys(int, Set) and Container.setFocusCycleRoot(boolean).
      boolean isOpaque()
      Returns true if this component is completely opaque.
      boolean isOptimizedDrawingEnabled()
      Returns true if this component tiles its children -- that is, if it can guarantee that the children will not overlap.
      boolean isPaintingForPrint()
      Returns true if the current painting operation on this component is part of a print operation.
      protected boolean isPaintingOrigin()
      Returns true if a paint triggered on a child component should cause painting to originate from this Component, or one of its ancestors.
      boolean isPaintingTile()
      Returns true if the component is currently painting a tile.
      boolean isRequestFocusEnabled()
      Returns true if this JComponent should get focus; otherwise returns false.
      boolean isValidateRoot()
      If this method returns true, revalidate calls by descendants of this component will cause the entire tree beginning with this root to be validated.
      void paint(Graphics g)
      Invoked by Swing to draw components.
      protected void paintBorder(Graphics g)
      Paints the component's border.
      protected void paintChildren(Graphics g)
      Paints this component's children.
      protected void paintComponent(Graphics g)
      Calls the UI delegate's paint method, if the UI delegate is non-null.
      void paintImmediately(int x, int y, int w, int h)
      Paints the specified region in this component and all of its descendants that overlap the region, immediately.
      void paintImmediately(Rectangle r)
      Paints the specified region now.
      protected String paramString()
      Returns a string representation of this JComponent.
      void print(Graphics g)
      Invoke this method to print the component to the specified Graphics.
      void printAll(Graphics g)
      Invoke this method to print the component.
      protected void printBorder(Graphics g)
      Prints the component's border.
      protected void printChildren(Graphics g)
      Prints this component's children.
      protected void printComponent(Graphics g)
      This is invoked during a printing operation.
      protected void processComponentKeyEvent(KeyEvent e)
      Processes any key events that the component itself recognizes.
      protected boolean processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      Invoked to process the key bindings for ks as the result of the KeyEvent e.
      protected void processKeyEvent(KeyEvent e)
      Overrides processKeyEvent to process events.
      protected void processMouseEvent(MouseEvent e)
      Processes mouse events occurring on this component by dispatching them to any registered MouseListener objects, refer to Component.processMouseEvent(MouseEvent) for a complete description of this method.
      protected void processMouseMotionEvent(MouseEvent e)
      Processes mouse motion events, such as MouseEvent.MOUSE_DRAGGED.
      void putClientProperty(Object key, Object value)
      Adds an arbitrary key/value "client property" to this component.
      void registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
      This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior.
      void registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
      This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior.
      void removeAncestorListener(AncestorListener listener)
      Unregisters listener so that it will no longer receive AncestorEvents.
      void removeNotify()
      Notifies this component that it no longer has a parent component.
      void removeVetoableChangeListener(VetoableChangeListener listener)
      Removes a VetoableChangeListener from the listener list.
      void repaint(long tm, int x, int y, int width, int height)
      Adds the specified region to the dirty region list if the component is showing.
      void repaint(Rectangle r)
      Adds the specified region to the dirty region list if the component is showing.
      boolean requestDefaultFocus()
      Deprecated.
      As of 1.4, replaced by FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()
      void requestFocus()
      Requests that this Component gets the input focus.
      boolean requestFocus(boolean temporary)
      Requests that this Component gets the input focus.
      boolean requestFocusInWindow()
      Requests that this Component gets the input focus.
      protected boolean requestFocusInWindow(boolean temporary)
      Requests that this Component gets the input focus.
      void resetKeyboardActions()
      Unregisters all the bindings in the first tier InputMaps and ActionMap.
      void reshape(int x, int y, int w, int h)
      Deprecated.
      As of JDK 5, replaced by Component.setBounds(int, int, int, int).

      Moves and resizes this component.
      void revalidate()
      Supports deferred automatic layout.
      void scrollRectToVisible(Rectangle aRect)
      Forwards the scrollRectToVisible() message to the JComponent's parent.
      void setActionMap(ActionMap am)
      Sets the ActionMap to am.
      void setAlignmentX(float alignmentX)
      Sets the the vertical alignment.
      void setAlignmentY(float alignmentY)
      Sets the the horizontal alignment.
      void setAutoscrolls(boolean autoscrolls)
      Sets the autoscrolls property.
      void setBackground(Color bg)
      Sets the background color of this component.
      void setBorder(Border border)
      Sets the border of this component.
      void setComponentPopupMenu(JPopupMenu popup)
      Sets the JPopupMenu for this JComponent.
      void setDebugGraphicsOptions(int debugOptions)
      Enables or disables diagnostic information about every graphics operation performed within the component or one of its children.
      static void setDefaultLocale(Locale l)
      Sets the default locale used to initialize each JComponent's locale property upon creation.
      void setDoubleBuffered(boolean aFlag)
      Sets whether this component should use a buffer to paint.
      void setEnabled(boolean enabled)
      Sets whether or not this component is enabled.
      void setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
      Sets the focus traversal keys for a given traversal operation for this Component.
      void setFont(Font font)
      Sets the font for this component.
      void setForeground(Color fg)
      Sets the foreground color of this component.
      void setInheritsPopupMenu(boolean value)
      Sets whether or not getComponentPopupMenu should delegate to the parent if this component does not have a JPopupMenu assigned to it.
      void setInputMap(int condition, InputMap map)
      Sets the InputMap to use under the condition condition to map.
      void setInputVerifier(InputVerifier inputVerifier)
      Sets the input verifier for this component.
      void setMaximumSize(Dimension maximumSize)
      Sets the maximum size of this component to a constant value.
      void setMinimumSize(Dimension minimumSize)
      Sets the minimum size of this component to a constant value.
      void setNextFocusableComponent(Component aComponent)
      Deprecated.
      As of 1.4, replaced by FocusTraversalPolicy
      void setOpaque(boolean isOpaque)
      If true the component paints every pixel within its bounds.
      void setPreferredSize(Dimension preferredSize)
      Sets the preferred size of this component.
      void setRequestFocusEnabled(boolean requestFocusEnabled)
      Provides a hint as to whether or not this JComponent should get focus.
      void setToolTipText(String text)
      Registers the text to display in a tool tip.
      void setTransferHandler(TransferHandler newHandler)
      Sets the TransferHandler, which provides support for transfer of data into and out of this component via cut/copy/paste and drag and drop.
      protected void setUI(ComponentUI newUI)
      Sets the look and feel delegate for this component.
      void setVerifyInputWhenFocusTarget(boolean verifyInputWhenFocusTarget)
      Sets the value to indicate whether input verifier for the current focus owner will be called before this component requests focus.
      void setVisible(boolean aFlag)
      Makes the component visible or invisible.
      void unregisterKeyboardAction(KeyStroke aKeyStroke)
      This method is now obsolete.
      void update(Graphics g)
      Calls paint.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ui

        protected transient ComponentUI ui
        The look and feel delegate for this component.

      • listenerList

        protected EventListenerList listenerList
        A list of event listeners for this component.

      • WHEN_FOCUSED

        public static final int WHEN_FOCUSED
        Constant used for registerKeyboardAction that means that the command should be invoked when the component has the focus.
        另请参见：
        Constant Field Values

      • WHEN_ANCESTOR_OF_FOCUSED_COMPONENT

        public static final int WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is an ancestor of the focused component or is itself the focused component.
        另请参见：
        Constant Field Values

      • WHEN_IN_FOCUSED_WINDOW

        public static final int WHEN_IN_FOCUSED_WINDOW
        Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is in the window that has the focus or is itself the focused component.
        另请参见：
        Constant Field Values

      • UNDEFINED_CONDITION

        public static final int UNDEFINED_CONDITION
        Constant used by some of the APIs to mean that no condition is defined.
        另请参见：
        Constant Field Values

      • TOOL_TIP_TEXT_KEY

        public static final String TOOL_TIP_TEXT_KEY
        The comment to display when the cursor is over the component, also known as a "value tip", "flyover help", or "flyover label".
        另请参见：
        Constant Field Values

      • accessibleContext

        protected AccessibleContext accessibleContext
        The AccessibleContext associated with this JComponent.

    • 构造方法详细信息

      • JComponent

        public JComponent()
        Default JComponent constructor. This constructor does very little initialization beyond calling the Container constructor. For example, the initial layout manager is null. It does, however, set the component's locale property to the value returned by JComponent.getDefaultLocale.
        另请参见：
        getDefaultLocale()

    • 方法详细信息

      • setInheritsPopupMenu

        public void setInheritsPopupMenu(boolean value)
        Sets whether or not getComponentPopupMenu should delegate to the parent if this component does not have a JPopupMenu assigned to it.

        The default value for this is false, but some JComponent subclasses that are implemented as a number of JComponents may set this to true.

        This is a bound property.

        参数：
        value - whether or not the JPopupMenu is inherited
        从以下版本开始：
        1.5
        另请参见：
        setComponentPopupMenu(javax.swing.JPopupMenu)

      • getInheritsPopupMenu

        public boolean getInheritsPopupMenu()
        Returns true if the JPopupMenu should be inherited from the parent.
        从以下版本开始：
        1.5
        另请参见：
        setComponentPopupMenu(javax.swing.JPopupMenu)

      • setComponentPopupMenu

        public void setComponentPopupMenu(JPopupMenu popup)
        Sets the JPopupMenu for this JComponent. The UI is responsible for registering bindings and adding the necessary listeners such that the JPopupMenu will be shown at the appropriate time. When the JPopupMenu is shown depends upon the look and feel: some may show it on a mouse event, some may enable a key binding.

        If popup is null, and getInheritsPopupMenu returns true, then getComponentPopupMenu will be delegated to the parent. This provides for a way to make all child components inherit the popupmenu of the parent.

        This is a bound property.

        参数：
        popup - - the popup that will be assigned to this component may be null
        从以下版本开始：
        1.5
        另请参见：
        getComponentPopupMenu()

      • getComponentPopupMenu

        public JPopupMenu getComponentPopupMenu()
        Returns JPopupMenu that assigned for this component. If this component does not have a JPopupMenu assigned to it and getInheritsPopupMenu is true, this will return getParent().getComponentPopupMenu() (assuming the parent is valid.)
        返回：
        JPopupMenu assigned for this component or null if no popup assigned
        从以下版本开始：
        1.5
        另请参见：
        setComponentPopupMenu(javax.swing.JPopupMenu)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel. JComponent subclasses must override this method like this:
           public void updateUI() {
      setUI((SliderUI)UIManager.getUI(this);
   }
        另请参见：
        setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • setUI

        protected void setUI(ComponentUI newUI)
        Sets the look and feel delegate for this component. JComponent subclasses generally override this method to narrow the argument type. For example, in JSlider:
         public void setUI(SliderUI newUI) {
     super.setUI(newUI);
 }

        Additionally JComponent subclasses must provide a getUI method that returns the correct type. For example:

         public SliderUI getUI() {
     return (SliderUI)ui;
 }
        参数：
        newUI - the new UI delegate
        另请参见：
        updateUI(),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • getUIClassID

        public String getUIClassID()
        Returns the UIDefaults key used to look up the name of the swing.plaf.ComponentUI class that defines the look and feel for this component. Most applications will never need to call this method. Subclasses of JComponent that support pluggable look and feel should override this method to return a UIDefaults key that maps to the ComponentUI subclass that defines their look and feel.
        返回：
        the UIDefaults key for a ComponentUI subclass
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getComponentGraphics

        protected Graphics getComponentGraphics(Graphics g)
        Returns the graphics object used to paint this component. If DebugGraphics is turned on we create a new DebugGraphics object if necessary. Otherwise we just configure the specified graphics object's foreground and font.
        参数：
        g - the original Graphics object
        返回：
        a Graphics object configured for this component

      • paintComponent

        protected void paintComponent(Graphics g)
        Calls the UI delegate's paint method, if the UI delegate is non-null. We pass the delegate a copy of the Graphics object to protect the rest of the paint code from irrevocable changes (for example, Graphics.translate).

        If you override this in a subclass you should not make permanent changes to the passed in Graphics. For example, you should not alter the clip Rectangle or modify the transform. If you need to do these operations you may find it easier to create a new Graphics from the passed in Graphics and manipulate it. Further, if you do not invoker super's implementation you must honor the opaque property, that is if this component is opaque, you must completely fill in the background in a non-opaque color. If you do not honor the opaque property you will likely see visual artifacts.

        The passed in Graphics object might have a transform other than the identify transform installed on it. In this case, you might get unexpected results if you cumulatively apply another transform.

        参数：
        g - the Graphics object to protect
        另请参见：
        paint(java.awt.Graphics), ComponentUI

      • paintChildren

        protected void paintChildren(Graphics g)
        Paints this component's children. If shouldUseBuffer is true, no component ancestor has a buffer and the component children can use a buffer if they have one. Otherwise, one ancestor has a buffer currently in use and children should not use a buffer to paint.
        参数：
        g - the Graphics context in which to paint
        另请参见：
        paint(java.awt.Graphics), Container.paint(java.awt.Graphics)

      • paintBorder

        protected void paintBorder(Graphics g)
        Paints the component's border.

        If you override this in a subclass you should not make permanent changes to the passed in Graphics. For example, you should not alter the clip Rectangle or modify the transform. If you need to do these operations you may find it easier to create a new Graphics from the passed in Graphics and manipulate it.

        参数：
        g - the Graphics context in which to paint
        另请参见：
        paint(java.awt.Graphics), setBorder(javax.swing.border.Border)

      • update

        public void update(Graphics g)
        Calls paint. Doesn't clear the background but see ComponentUI.update, which is called by paintComponent.
        重载：
        update in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        paint(java.awt.Graphics), paintComponent(java.awt.Graphics), ComponentUI

      • paint

        public void paint(Graphics g)
        Invoked by Swing to draw components. Applications should not invoke paint directly, but should instead use the repaint method to schedule the component for redrawing.

        This method actually delegates the work of painting to three protected methods: paintComponent, paintBorder, and paintChildren. They're called in the order listed to ensure that children appear on top of component itself. Generally speaking, the component and its children should not paint in the insets area allocated to the border. Subclasses can just override this method, as always. A subclass that just wants to specialize the UI (look and feel) delegate's paint method should just override paintComponent.

        重载：
        paint in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        paintComponent(java.awt.Graphics),
paintBorder(java.awt.Graphics),
paintChildren(java.awt.Graphics),
getComponentGraphics(java.awt.Graphics),
repaint(long, int, int, int, int)

      • printAll

        public void printAll(Graphics g)
        Invoke this method to print the component. This method invokes print on the component.
        重载：
        printAll in class Component
        参数：
        g - the Graphics context in which to paint
        另请参见：
        print(java.awt.Graphics),
printComponent(java.awt.Graphics),
printBorder(java.awt.Graphics),
printChildren(java.awt.Graphics)

      • print

        public void print(Graphics g)
        Invoke this method to print the component to the specified Graphics. This method will result in invocations of printComponent, printBorder and printChildren. It is recommended that you override one of the previously mentioned methods rather than this one if your intention is to customize the way printing looks. However, it can be useful to override this method should you want to prepare state before invoking the superclass behavior. As an example, if you wanted to change the component's background color before printing, you could do the following:
             public void print(Graphics g) {
         Color orig = getBackground();
         setBackground(Color.WHITE);

         // wrap in try/finally so that we always restore the state
         try {
             super.print(g);
         } finally {
             setBackground(orig);
         }
     }

        Alternatively, or for components that delegate painting to other objects, you can query during painting whether or not the component is in the midst of a print operation. The isPaintingForPrint method provides this ability and its return value will be changed by this method: to true immediately before rendering and to false immediately after. With each change a property change event is fired on this component with the name "paintingForPrint".

        This method sets the component's state such that the double buffer will not be used: painting will be done directly on the passed in Graphics.

        重载：
        print in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        printComponent(java.awt.Graphics),
printBorder(java.awt.Graphics),
printChildren(java.awt.Graphics),
isPaintingForPrint()

      • printComponent

        protected void printComponent(Graphics g)
        This is invoked during a printing operation. This is implemented to invoke paintComponent on the component. Override this if you wish to add special painting behavior when printing.
        参数：
        g - the Graphics context in which to paint
        从以下版本开始：
        1.3
        另请参见：
        print(java.awt.Graphics)

      • printChildren

        protected void printChildren(Graphics g)
        Prints this component's children. This is implemented to invoke paintChildren on the component. Override this if you wish to print the children differently than painting.
        参数：
        g - the Graphics context in which to paint
        从以下版本开始：
        1.3
        另请参见：
        print(java.awt.Graphics)

      • printBorder

        protected void printBorder(Graphics g)
        Prints the component's border. This is implemented to invoke paintBorder on the component. Override this if you wish to print the border differently that it is painted.
        参数：
        g - the Graphics context in which to paint
        从以下版本开始：
        1.3
        另请参见：
        print(java.awt.Graphics)

      • isPaintingTile

        public boolean isPaintingTile()
        Returns true if the component is currently painting a tile. If this method returns true, paint will be called again for another tile. This method returns false if you are not painting a tile or if the last tile is painted. Use this method to keep some state you might need between tiles.
        返回：
        true if the component is currently painting a tile, false otherwise

      • isPaintingForPrint

        public final boolean isPaintingForPrint()
        Returns true if the current painting operation on this component is part of a print operation. This method is useful when you want to customize what you print versus what you show on the screen.

        You can detect changes in the value of this property by listening for property change events on this component with name "paintingForPrint".

        Note: This method provides complimentary functionality to that provided by other high level Swing printing APIs. However, it deals strictly with painting and should not be confused as providing information on higher level print processes. For example, a JTable.print() operation doesn't necessarily result in a continuous rendering of the full component, and the return value of this method can change multiple times during that operation. It is even possible for the component to be painted to the screen while the printing process is ongoing. In such a case, the return value of this method is true when, and only when, the table is being painted as part of the printing process.

        返回：
        true if the current painting operation on this component is part of a print operation
        从以下版本开始：
        1.6
        另请参见：
        print(java.awt.Graphics)

      • isManagingFocus

        @Deprecated
public boolean isManagingFocus()
        Deprecated. As of 1.4, replaced by Component.setFocusTraversalKeys(int, Set) and Container.setFocusCycleRoot(boolean).
        In release 1.4, the focus subsystem was rearchitected. For more information, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        Changes this JComponent's focus traversal keys to CTRL+TAB and CTRL+SHIFT+TAB. Also prevents SortingFocusTraversalPolicy from considering descendants of this JComponent when computing a focus traversal cycle.

        另请参见：
        Component.setFocusTraversalKeys(int, java.util.Set), SortingFocusTraversalPolicy

      • setNextFocusableComponent

        @Deprecated
public void setNextFocusableComponent(Component aComponent)
        Deprecated. As of 1.4, replaced by FocusTraversalPolicy
        In release 1.4, the focus subsystem was rearchitected. For more information, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        Overrides the default FocusTraversalPolicy for this JComponent's focus traversal cycle by unconditionally setting the specified Component as the next Component in the cycle, and this JComponent as the specified Component's previous Component in the cycle.

        参数：
        aComponent - the Component that should follow this JComponent in the focus traversal cycle
        另请参见：
        getNextFocusableComponent(), FocusTraversalPolicy

      • getNextFocusableComponent

        @Deprecated
public Component getNextFocusableComponent()
        Deprecated. As of 1.4, replaced by FocusTraversalPolicy.
        In release 1.4, the focus subsystem was rearchitected. For more information, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        Returns the Component set by a prior call to setNextFocusableComponent(Component) on this JComponent.

        返回：
        the Component that will follow this JComponent in the focus traversal cycle, or null if none has been explicitly specified
        另请参见：
        setNextFocusableComponent(java.awt.Component)

      • setRequestFocusEnabled

        public void setRequestFocusEnabled(boolean requestFocusEnabled)
        Provides a hint as to whether or not this JComponent should get focus. This is only a hint, and it is up to consumers that are requesting focus to honor this property. This is typically honored for mouse operations, but not keyboard operations. For example, look and feels could verify this property is true before requesting focus during a mouse operation. This would often times be used if you did not want a mouse press on a JComponent to steal focus, but did want the JComponent to be traversable via the keyboard. If you do not want this JComponent focusable at all, use the setFocusable method instead.

        Please see How to Use the Focus Subsystem, a section in The Java Tutorial, for more information.

        参数：
        requestFocusEnabled - indicates whether you want this JComponent to be focusable or not
        另请参见：
        Focus Specification, Component.setFocusable(boolean)

      • isRequestFocusEnabled

        public boolean isRequestFocusEnabled()
        Returns true if this JComponent should get focus; otherwise returns false.

        Please see How to Use the Focus Subsystem, a section in The Java Tutorial, for more information.

        返回：
        true if this component should get focus, otherwise returns false
        另请参见：
        setRequestFocusEnabled(boolean), Focus Specification, Component.isFocusable()

      • requestFocus

        public void requestFocus()
        Requests that this Component gets the input focus. Refer to Component.requestFocus() for a complete description of this method.

        Note that the use of this method is discouraged because its behavior is platform dependent. Instead we recommend the use of requestFocusInWindow(). If you would like more information on focus, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        重载：
        requestFocus in class Component
        从以下版本开始：
        1.4
        另请参见：
        Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

      • requestFocus

        public boolean requestFocus(boolean temporary)
        Requests that this Component gets the input focus. Refer to Component.requestFocus(boolean) for a complete description of this method.

        Note that the use of this method is discouraged because its behavior is platform dependent. Instead we recommend the use of requestFocusInWindow(boolean). If you would like more information on focus, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        重载：
        requestFocus in class Component
        参数：
        temporary - boolean indicating if the focus change is temporary
        返回：
        false if the focus change request is guaranteed to fail; true if it is likely to succeed
        从以下版本开始：
        1.4
        另请参见：
        Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

      • requestFocusInWindow

        public boolean requestFocusInWindow()
        Requests that this Component gets the input focus. Refer to Component.requestFocusInWindow() for a complete description of this method.

        If you would like more information on focus, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        重载：
        requestFocusInWindow in class Component
        返回：
        false if the focus change request is guaranteed to fail; true if it is likely to succeed
        从以下版本开始：
        1.4
        另请参见：
        Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

      • requestFocusInWindow

        protected boolean requestFocusInWindow(boolean temporary)
        Requests that this Component gets the input focus. Refer to Component.requestFocusInWindow(boolean) for a complete description of this method.

        If you would like more information on focus, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        重载：
        requestFocusInWindow in class Component
        参数：
        temporary - boolean indicating if the focus change is temporary
        返回：
        false if the focus change request is guaranteed to fail; true if it is likely to succeed
        从以下版本开始：
        1.4
        另请参见：
        Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

      • grabFocus

        public void grabFocus()
        Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window. This component must be displayable, visible, and focusable for the request to be granted.

        This method is intended for use by focus implementations. Client code should not use this method; instead, it should use requestFocusInWindow().

        另请参见：
        requestFocusInWindow()

      • setVerifyInputWhenFocusTarget

        public void setVerifyInputWhenFocusTarget(boolean verifyInputWhenFocusTarget)
        Sets the value to indicate whether input verifier for the current focus owner will be called before this component requests focus. The default is true. Set to false on components such as a Cancel button or a scrollbar, which should activate even if the input in the current focus owner is not "passed" by the input verifier for that component.
        参数：
        verifyInputWhenFocusTarget - value for the verifyInputWhenFocusTarget property
        从以下版本开始：
        1.3
        另请参见：
        InputVerifier,
setInputVerifier(javax.swing.InputVerifier),
getInputVerifier(),
getVerifyInputWhenFocusTarget()

      • getVerifyInputWhenFocusTarget

        public boolean getVerifyInputWhenFocusTarget()
        Returns the value that indicates whether the input verifier for the current focus owner will be called before this component requests focus.
        返回：
        value of the verifyInputWhenFocusTarget property
        从以下版本开始：
        1.3
        另请参见：
        InputVerifier,
setInputVerifier(javax.swing.InputVerifier),
getInputVerifier(),
setVerifyInputWhenFocusTarget(boolean)

      • getFontMetrics

        public FontMetrics getFontMetrics(Font font)
        Gets the FontMetrics for the specified Font.
        重载：
        getFontMetrics in class Component
        参数：
        font - the font for which font metrics is to be obtained
        返回：
        the font metrics for font
        抛出：
        NullPointerException - if font is null
        从以下版本开始：
        1.5
        另请参见：
        Component.getFont(),
Component.getPeer(),
ComponentPeer.getFontMetrics(Font),
Toolkit.getFontMetrics(Font)

      • setPreferredSize

        public void setPreferredSize(Dimension preferredSize)
        Sets the preferred size of this component. If preferredSize is null, the UI will be asked for the preferred size.
        重载：
        setPreferredSize in class Component
        参数：
        preferredSize - The new preferred size, or null
        另请参见：
        Component.getPreferredSize(), Component.isPreferredSizeSet()

      • getPreferredSize

        public Dimension getPreferredSize()
        If the preferredSize has been set to a non-null value just returns it. If the UI delegate's getPreferredSize method returns a non null value then return that; otherwise defer to the component's layout manager.
        重载：
        getPreferredSize in class Container
        返回：
        the value of the preferredSize property
        另请参见：
        setPreferredSize(java.awt.Dimension), ComponentUI

      • setMaximumSize

        public void setMaximumSize(Dimension maximumSize)
        Sets the maximum size of this component to a constant value. Subsequent calls to getMaximumSize will always return this value; the component's UI will not be asked to compute it. Setting the maximum size to null restores the default behavior.
        重载：
        setMaximumSize in class Component
        参数：
        maximumSize - a Dimension containing the desired maximum allowable size
        另请参见：
        getMaximumSize()

      • getMaximumSize

        public Dimension getMaximumSize()
        If the maximum size has been set to a non-null value just returns it. If the UI delegate's getMaximumSize method returns a non-null value then return that; otherwise defer to the component's layout manager.
        重载：
        getMaximumSize in class Container
        返回：
        the value of the maximumSize property
        另请参见：
        setMaximumSize(java.awt.Dimension), ComponentUI

      • setMinimumSize

        public void setMinimumSize(Dimension minimumSize)
        Sets the minimum size of this component to a constant value. Subsequent calls to getMinimumSize will always return this value; the component's UI will not be asked to compute it. Setting the minimum size to null restores the default behavior.
        重载：
        setMinimumSize in class Component
        参数：
        minimumSize - the new minimum size of this component
        另请参见：
        getMinimumSize()

      • getMinimumSize

        public Dimension getMinimumSize()
        If the minimum size has been set to a non-null value just returns it. If the UI delegate's getMinimumSize method returns a non-null value then return that; otherwise defer to the component's layout manager.
        重载：
        getMinimumSize in class Container
        返回：
        the value of the minimumSize property
        另请参见：
        setMinimumSize(java.awt.Dimension), ComponentUI

      • contains

        public boolean contains(int x,
               int y)
        Gives the UI delegate an opportunity to define the precise shape of this component for the sake of mouse processing.
        重载：
        contains in class Component
        参数：
        x - the x coordinate of the point
        y - the y coordinate of the point
        返回：
        true if this component logically contains x,y
        另请参见：
        Component.contains(int, int), ComponentUI

      • setBorder

        public void setBorder(Border border)
        Sets the border of this component. The Border object is responsible for defining the insets for the component (overriding any insets set directly on the component) and for optionally rendering any border decorations within the bounds of those insets. Borders should be used (rather than insets) for creating both decorative and non-decorative (such as margins and padding) regions for a swing component. Compound borders can be used to nest multiple borders within a single component.

        Although technically you can set the border on any object that inherits from JComponent, the look and feel implementation of many standard Swing components doesn't work well with user-set borders. In general, when you want to set a border on a standard Swing component other than JPanel or JLabel, we recommend that you put the component in a JPanel and set the border on the JPanel.

        This is a bound property.

        参数：
        border - the border to be rendered for this component
        另请参见：
        Border, CompoundBorder

      • getBorder

        public Border getBorder()
        Returns the border of this component or null if no border is currently set.
        返回：
        the border object for this component
        另请参见：
        setBorder(javax.swing.border.Border)

      • getInsets

        public Insets getInsets()
        If a border has been set on this component, returns the border's insets; otherwise calls super.getInsets.
        重载：
        getInsets in class Container
        返回：
        the value of the insets property
        另请参见：
        setBorder(javax.swing.border.Border)

      • getInsets

        public Insets getInsets(Insets insets)
        Returns an Insets object containing this component's inset values. The passed-in Insets object will be reused if possible. Calling methods cannot assume that the same object will be returned, however. All existing values within this object are overwritten. If insets is null, this will allocate a new one.
        参数：
        insets - the Insets object, which can be reused
        返回：
        the Insets object
        另请参见：
        getInsets()

      • getAlignmentY

        public float getAlignmentY()
        Overrides Container.getAlignmentY to return the horizontal alignment.
        重载：
        getAlignmentY in class Container
        返回：
        the value of the alignmentY property
        另请参见：
        setAlignmentY(float), Component.getAlignmentY()

      • setAlignmentY

        public void setAlignmentY(float alignmentY)
        Sets the the horizontal alignment.
        参数：
        alignmentY - the new horizontal alignment
        另请参见：
        getAlignmentY()

      • getAlignmentX

        public float getAlignmentX()
        Overrides Container.getAlignmentX to return the vertical alignment.
        重载：
        getAlignmentX in class Container
        返回：
        the value of the alignmentX property
        另请参见：
        setAlignmentX(float), Component.getAlignmentX()

      • setAlignmentX

        public void setAlignmentX(float alignmentX)
        Sets the the vertical alignment.
        参数：
        alignmentX - the new vertical alignment
        另请参见：
        getAlignmentX()

      • setInputVerifier

        public void setInputVerifier(InputVerifier inputVerifier)
        Sets the input verifier for this component.
        参数：
        inputVerifier - the new input verifier
        从以下版本开始：
        1.3
        另请参见：
        InputVerifier

      • getInputVerifier

        public InputVerifier getInputVerifier()
        Returns the input verifier for this component.
        返回：
        the inputVerifier property
        从以下版本开始：
        1.3
        另请参见：
        InputVerifier

      • getGraphics

        public Graphics getGraphics()
        Returns this component's graphics context, which lets you draw on a component. Use this method to get a Graphics object and then invoke operations on that object to draw on the component.
        重载：
        getGraphics in class Component
        返回：
        this components graphics context
        另请参见：
        Component.paint(java.awt.Graphics)

      • setDebugGraphicsOptions

        public void setDebugGraphicsOptions(int debugOptions)
        Enables or disables diagnostic information about every graphics operation performed within the component or one of its children.
        参数：
        debugOptions - determines how the component should display the information; one of the following options:
        • DebugGraphics.LOG_OPTION - causes a text message to be printed.
        • DebugGraphics.FLASH_OPTION - causes the drawing to flash several times.
        • DebugGraphics.BUFFERED_OPTION - creates an ExternalWindow that displays the operations performed on the View's offscreen buffer.
        • DebugGraphics.NONE_OPTION disables debugging.
        • A value of 0 causes no changes to the debugging options.
        debugOptions is bitwise OR'd into the current value

      • getDebugGraphicsOptions

        public int getDebugGraphicsOptions()
        Returns the state of graphics debugging.
        返回：
        a bitwise OR'd flag of zero or more of the following options:
        • DebugGraphics.LOG_OPTION - causes a text message to be printed.
        • DebugGraphics.FLASH_OPTION - causes the drawing to flash several times.
        • DebugGraphics.BUFFERED_OPTION - creates an ExternalWindow that displays the operations performed on the View's offscreen buffer.
        • DebugGraphics.NONE_OPTION disables debugging.
        • A value of 0 causes no changes to the debugging options.
        另请参见：
        setDebugGraphicsOptions(int)

      • registerKeyboardAction

        public void registerKeyboardAction(ActionListener anAction,
                          String aCommand,
                          KeyStroke aKeyStroke,
                          int aCondition)
        This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior. For example, to bind the KeyStroke aKeyStroke to the Action anAction now use:
           component.getInputMap().put(aKeyStroke, aCommand);
   component.getActionMap().put(aCommmand, anAction);
        The above assumes you want the binding to be applicable for WHEN_FOCUSED. To register bindings for other focus states use the getInputMap method that takes an integer.

        Register a new keyboard action. anAction will be invoked if a key event matching aKeyStroke occurs and aCondition is verified. The KeyStroke object defines a particular combination of a keyboard key and one or more modifiers (alt, shift, ctrl, meta).

        The aCommand will be set in the delivered event if specified.

        The aCondition can be one of:

        WHEN_FOCUSED
        The action will be invoked only when the keystroke occurs while the component has the focus.
        WHEN_IN_FOCUSED_WINDOW
        The action will be invoked when the keystroke occurs while the component has the focus or if the component is in the window that has the focus. Note that the component need not be an immediate descendent of the window -- it can be anywhere in the window's containment hierarchy. In other words, whenever any component in the window has the focus, the action registered with this component is invoked.
        WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        The action will be invoked when the keystroke occurs while the component has the focus or if the component is an ancestor of the component that has the focus.

        The combination of keystrokes and conditions lets you define high level (semantic) action events for a specified keystroke+modifier combination (using the KeyStroke class) and direct to a parent or child of a component that has the focus, or to the component itself. In other words, in any hierarchical structure of components, an arbitrary key-combination can be immediately directed to the appropriate component in the hierarchy, and cause a specific method to be invoked (usually by way of adapter objects).

        If an action has already been registered for the receiving container, with the same charCode and the same modifiers, anAction will replace the action.

        参数：
        anAction - the Action to be registered
        aCommand - the command to be set in the delivered event
        aKeyStroke - the KeyStroke to bind to the action
        aCondition - the condition that needs to be met, see above
        另请参见：
        KeyStroke

      • registerKeyboardAction

        public void registerKeyboardAction(ActionListener anAction,
                          KeyStroke aKeyStroke,
                          int aCondition)
        This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior.

      • unregisterKeyboardAction

        public void unregisterKeyboardAction(KeyStroke aKeyStroke)
        This method is now obsolete. To unregister an existing binding you can either remove the binding from the ActionMap/InputMap, or place a dummy binding the InputMap. Removing the binding from the InputMap allows bindings in parent InputMaps to be active, whereas putting a dummy binding in the InputMap effectively disables the binding from ever happening.

        Unregisters a keyboard action. This will remove the binding from the ActionMap (if it exists) as well as the InputMaps.

      • getRegisteredKeyStrokes

        public KeyStroke[] getRegisteredKeyStrokes()
        Returns the KeyStrokes that will initiate registered actions.
        返回：
        an array of KeyStroke objects
        另请参见：
        registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • getConditionForKeyStroke

        public int getConditionForKeyStroke(KeyStroke aKeyStroke)
        Returns the condition that determines whether a registered action occurs in response to the specified keystroke.

        For Java 2 platform v1.3, a KeyStroke can be associated with more than one condition. For example, 'a' could be bound for the two conditions WHEN_FOCUSED and WHEN_IN_FOCUSED_WINDOW condition.

        返回：
        the action-keystroke condition

      • getActionForKeyStroke

        public ActionListener getActionForKeyStroke(KeyStroke aKeyStroke)
        Returns the object that will perform the action registered for a given keystroke.
        返回：
        the ActionListener object invoked when the keystroke occurs

      • resetKeyboardActions

        public void resetKeyboardActions()
        Unregisters all the bindings in the first tier InputMaps and ActionMap. This has the effect of removing any local bindings, and allowing the bindings defined in parent InputMap/ActionMaps (the UI is usually defined in the second tier) to persist.

      • setInputMap

        public final void setInputMap(int condition,
               InputMap map)
        Sets the InputMap to use under the condition condition to map. A null value implies you do not want any bindings to be used, even from the UI. This will not reinstall the UI InputMap (if there was one). condition has one of the following values:
        • WHEN_IN_FOCUSED_WINDOW
        • WHEN_FOCUSED
        • WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        If condition is WHEN_IN_FOCUSED_WINDOW and map is not a ComponentInputMap, an IllegalArgumentException will be thrown. Similarly, if condition is not one of the values listed, an IllegalArgumentException will be thrown.
        参数：
        condition - one of the values listed above
        map - the InputMap to use for the given condition
        抛出：
        IllegalArgumentException - if condition is WHEN_IN_FOCUSED_WINDOW and map is not an instance of ComponentInputMap; or if condition is not one of the legal values specified above
        从以下版本开始：
        1.3

      • getInputMap

        public final InputMap getInputMap(int condition)
        Returns the InputMap that is used during condition.
        参数：
        condition - one of WHEN_IN_FOCUSED_WINDOW, WHEN_FOCUSED, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        返回：
        the InputMap for the specified condition
        从以下版本开始：
        1.3

      • getInputMap

        public final InputMap getInputMap()
        Returns the InputMap that is used when the component has focus. This is convenience method for getInputMap(WHEN_FOCUSED).
        返回：
        the InputMap used when the component has focus
        从以下版本开始：
        1.3

      • setActionMap

        public final void setActionMap(ActionMap am)
        Sets the ActionMap to am. This does not set the parent of the am to be the ActionMap from the UI (if there was one), it is up to the caller to have done this.
        参数：
        am - the new ActionMap
        从以下版本开始：
        1.3

      • getActionMap

        public final ActionMap getActionMap()
        Returns the ActionMap used to determine what Action to fire for particular KeyStroke binding. The returned ActionMap, unless otherwise set, will have the ActionMap from the UI set as the parent.
        返回：
        the ActionMap containing the key/action bindings
        从以下版本开始：
        1.3

      • getBaseline

        public int getBaseline(int width,
              int height)
        Returns the baseline. The baseline is measured from the top of the component. This method is primarily meant for LayoutManagers to align components along their baseline. A return value less than 0 indicates this component does not have a reasonable baseline and that LayoutManagers should not align this component on its baseline.

        This method calls into the ComponentUI method of the same name. If this component does not have a ComponentUI -1 will be returned. If a value >= 0 is returned, then the component has a valid baseline for any size >= the minimum size and getBaselineResizeBehavior can be used to determine how the baseline changes with size.

        重载：
        getBaseline in class Component
        参数：
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        the baseline or < 0 indicating there is no reasonable baseline
        抛出：
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        getBaselineResizeBehavior(), FontMetrics

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior()
        Returns an enum indicating how the baseline of the component changes as the size changes. This method is primarily meant for layout managers and GUI builders.

        This method calls into the ComponentUI method of the same name. If this component does not have a ComponentUI BaselineResizeBehavior.OTHER will be returned. Subclasses should never return null; if the baseline can not be calculated return BaselineResizeBehavior.OTHER. Callers should first ask for the baseline using getBaseline and if a value >= 0 is returned use this method. It is acceptable for this method to return a value other than BaselineResizeBehavior.OTHER even if getBaseline returns a value less than 0.

        重载：
        getBaselineResizeBehavior in class Component
        返回：
        an enum indicating how the baseline changes as the component size changes
        从以下版本开始：
        1.6
        另请参见：
        getBaseline(int, int)

      • requestDefaultFocus

        @Deprecated
public boolean requestDefaultFocus()
        Deprecated. As of 1.4, replaced by FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()
        In release 1.4, the focus subsystem was rearchitected. For more information, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        Requests focus on this JComponent's FocusTraversalPolicy's default Component. If this JComponent is a focus cycle root, then its FocusTraversalPolicy is used. Otherwise, the FocusTraversalPolicy of this JComponent's focus-cycle-root ancestor is used.

        另请参见：
        FocusTraversalPolicy.getDefaultComponent(java.awt.Container)

      • setVisible

        public void setVisible(boolean aFlag)
        Makes the component visible or invisible. Overrides Component.setVisible.
        重载：
        setVisible in class Component
        参数：
        aFlag - true to make the component visible; false to make it invisible
        另请参见：
        Component.isVisible(), Component.invalidate()

      • setEnabled

        public void setEnabled(boolean enabled)
        Sets whether or not this component is enabled. A component that is enabled may respond to user input, while a component that is not enabled cannot respond to user input. Some components may alter their visual representation when they are disabled in order to provide feedback to the user that they cannot take input.

        Note: Disabling a component does not disable its children.

        Note: Disabling a lightweight component does not prevent it from receiving MouseEvents.

        重载：
        setEnabled in class Component
        参数：
        enabled - true if this component should be enabled, false otherwise
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • setForeground

        public void setForeground(Color fg)
        Sets the foreground color of this component. It is up to the look and feel to honor this property, some may choose to ignore it.
        重载：
        setForeground in class Component
        参数：
        fg - the desired foreground Color
        另请参见：
        Component.getForeground()

      • setBackground

        public void setBackground(Color bg)
        Sets the background color of this component. The background color is used only if the component is opaque, and only by subclasses of JComponent or ComponentUI implementations. Direct subclasses of JComponent must override paintComponent to honor this property.

        It is up to the look and feel to honor this property, some may choose to ignore it.

        重载：
        setBackground in class Component
        参数：
        bg - the desired background Color
        另请参见：
        Component.getBackground(), setOpaque(boolean)

      • setFont

        public void setFont(Font font)
        Sets the font for this component.
        重载：
        setFont in class Container
        参数：
        font - the desired Font for this component
        另请参见：
        Component.getFont()

      • getDefaultLocale

        public static Locale getDefaultLocale()
        Returns the default locale used to initialize each JComponent's locale property upon creation. The default locale has "AppContext" scope so that applets (and potentially multiple lightweight applications running in a single VM) can have their own setting. An applet can safely alter its default locale because it will have no affect on other applets (or the browser).
        返回：
        the default Locale.
        从以下版本开始：
        1.4
        另请参见：
        setDefaultLocale(java.util.Locale),
Component.getLocale(),
Component.setLocale(java.util.Locale)

      • setDefaultLocale

        public static void setDefaultLocale(Locale l)
        Sets the default locale used to initialize each JComponent's locale property upon creation. The initial value is the VM's default locale. The default locale has "AppContext" scope so that applets (and potentially multiple lightweight applications running in a single VM) can have their own setting. An applet can safely alter its default locale because it will have no affect on other applets (or the browser).
        参数：
        l - the desired default Locale for new components.
        从以下版本开始：
        1.4
        另请参见：
        getDefaultLocale(),
Component.getLocale(),
Component.setLocale(java.util.Locale)

      • processComponentKeyEvent

        protected void processComponentKeyEvent(KeyEvent e)
        Processes any key events that the component itself recognizes. This is called after the focus manager and any interested listeners have been given a chance to steal away the event. This method is called only if the event has not yet been consumed. This method is called prior to the keyboard UI logic.

        This method is implemented to do nothing. Subclasses would normally override this method if they process some key events themselves. If the event is processed, it should be consumed.

      • processKeyEvent

        protected void processKeyEvent(KeyEvent e)
        Overrides processKeyEvent to process events.
        重载：
        processKeyEvent in class Component
        参数：
        e - the key event
        另请参见：
        KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

      • processKeyBinding

        protected boolean processKeyBinding(KeyStroke ks,
                        KeyEvent e,
                        int condition,
                        boolean pressed)
        Invoked to process the key bindings for ks as the result of the KeyEvent e. This obtains the appropriate InputMap, gets the binding, gets the action from the ActionMap, and then (if the action is found and the component is enabled) invokes notifyAction to notify the action.
        参数：
        ks - the KeyStroke queried
        e - the KeyEvent
        condition - one of the following values:
        • JComponent.WHEN_FOCUSED
        • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        • JComponent.WHEN_IN_FOCUSED_WINDOW
        pressed - true if the key is pressed
        返回：
        true if there was a binding to an action, and the action was enabled
        从以下版本开始：
        1.3

      • setToolTipText

        public void setToolTipText(String text)
        Registers the text to display in a tool tip. The text displays when the cursor lingers over the component.

        See How to Use Tool Tips in The Java Tutorial for further documentation.

        参数：
        text - the string to display; if the text is null, the tool tip is turned off for this component
        另请参见：
        TOOL_TIP_TEXT_KEY

      • getToolTipText

        public String getToolTipText()
        Returns the tooltip string that has been set with setToolTipText.
        返回：
        the text of the tool tip
        另请参见：
        TOOL_TIP_TEXT_KEY

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Returns the string to be used as the tooltip for event. By default this returns any string set using setToolTipText. If a component provides more extensive API to support differing tooltips at different locations, this method should be overridden.

      • getToolTipLocation

        public Point getToolTipLocation(MouseEvent event)
        Returns the tooltip location in this component's coordinate system. If null is returned, Swing will choose a location. The default implementation returns null.
        参数：
        event - the MouseEvent that caused the ToolTipManager to show the tooltip
        返回：
        always returns null

      • getPopupLocation

        public Point getPopupLocation(MouseEvent event)
        Returns the preferred location to display the popup menu in this component's coordinate system. It is up to the look and feel to honor this property, some may choose to ignore it. If null, the look and feel will choose a suitable location.
        参数：
        event - the MouseEvent that triggered the popup to be shown, or null if the popup is not being shown as the result of a mouse event
        返回：
        location to display the JPopupMenu, or null
        从以下版本开始：
        1.5

      • createToolTip

        public JToolTip createToolTip()
        Returns the instance of JToolTip that should be used to display the tooltip. Components typically would not override this method, but it can be used to cause different tooltips to be displayed differently.
        返回：
        the JToolTip used to display this toolTip

      • scrollRectToVisible

        public void scrollRectToVisible(Rectangle aRect)
        Forwards the scrollRectToVisible() message to the JComponent's parent. Components that can service the request, such as JViewport, override this method and perform the scrolling.
        参数：
        aRect - the visible Rectangle
        另请参见：
        JViewport

      • setAutoscrolls

        public void setAutoscrolls(boolean autoscrolls)
        Sets the autoscrolls property. If true mouse dragged events will be synthetically generated when the mouse is dragged outside of the component's bounds and mouse motion has paused (while the button continues to be held down). The synthetic events make it appear that the drag gesture has resumed in the direction established when the component's boundary was crossed. Components that support autoscrolling must handle mouseDragged events by calling scrollRectToVisible with a rectangle that contains the mouse event's location. All of the Swing components that support item selection and are typically displayed in a JScrollPane (JTable, JList, JTree, JTextArea, and JEditorPane) already handle mouse dragged events in this way. To enable autoscrolling in any other component, add a mouse motion listener that calls scrollRectToVisible. For example, given a JPanel, myPanel:
         MouseMotionListener doScrollRectToVisible = new MouseMotionAdapter() {
     public void mouseDragged(MouseEvent e) {
        Rectangle r = new Rectangle(e.getX(), e.getY(), 1, 1);
        ((JPanel)e.getSource()).scrollRectToVisible(r);
    }
 };
 myPanel.addMouseMotionListener(doScrollRectToVisible);
        The default value of the autoScrolls property is false.
        参数：
        autoscrolls - if true, synthetic mouse dragged events are generated when the mouse is dragged outside of a component's bounds and the mouse button continues to be held down; otherwise false
        另请参见：
        getAutoscrolls(), JViewport, JScrollPane

      • getAutoscrolls

        public boolean getAutoscrolls()
        Gets the autoscrolls property.
        返回：
        the value of the autoscrolls property
        另请参见：
        JViewport, setAutoscrolls(boolean)

      • setTransferHandler

        public void setTransferHandler(TransferHandler newHandler)
        Sets the TransferHandler, which provides support for transfer of data into and out of this component via cut/copy/paste and drag and drop. This may be null if the component does not support data transfer operations.

        If the new TransferHandler is not null, this method also installs a new DropTarget on the component to activate drop handling through the TransferHandler and activate any built-in support (such as calculating and displaying potential drop locations). If you do not wish for this component to respond in any way to drops, you can disable drop support entirely either by removing the drop target (setDropTarget(null)) or by de-activating it (getDropTaget().setActive(false)).

        If the new TransferHandler is null, this method removes the drop target.

        Under two circumstances, this method does not modify the drop target: First, if the existing drop target on this component was explicitly set by the developer to a non-null value. Second, if the system property suppressSwingDropSupport is true. The default value for the system property is false.

        Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

        参数：
        newHandler - the new TransferHandler
        从以下版本开始：
        1.4
        另请参见：
        TransferHandler, getTransferHandler()

      • getTransferHandler

        public TransferHandler getTransferHandler()
        Gets the transferHandler property.
        返回：
        the value of the transferHandler property
        从以下版本开始：
        1.4
        另请参见：
        TransferHandler, setTransferHandler(javax.swing.TransferHandler)

      • processMouseEvent

        protected void processMouseEvent(MouseEvent e)
        Processes mouse events occurring on this component by dispatching them to any registered MouseListener objects, refer to Component.processMouseEvent(MouseEvent) for a complete description of this method.
        重载：
        processMouseEvent in class Component
        参数：
        e - the mouse event
        从以下版本开始：
        1.5
        另请参见：
        Component.processMouseEvent(java.awt.event.MouseEvent)

      • processMouseMotionEvent

        protected void processMouseMotionEvent(MouseEvent e)
        Processes mouse motion events, such as MouseEvent.MOUSE_DRAGGED.
        重载：
        processMouseMotionEvent in class Component
        参数：
        e - the MouseEvent
        另请参见：
        MouseEvent

      • enable

        @Deprecated
public void enable()
        Deprecated. As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
        重载：
        enable in class Component

      • disable

        @Deprecated
public void disable()
        Deprecated. As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
        重载：
        disable in class Component

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Returns the AccessibleContext associated with this JComponent. The method implemented by this base class returns null. Classes that extend JComponent should implement this method to return the AccessibleContext associated with the subclass.
        重载：
        getAccessibleContext in class Component
        返回：
        the AccessibleContext of this JComponent

      • getClientProperty

        public final Object getClientProperty(Object key)
        Returns the value of the property with the specified key. Only properties added with putClientProperty will return a non-null value.
        参数：
        key - the being queried
        返回：
        the value of this property or null
        另请参见：
        putClientProperty(java.lang.Object, java.lang.Object)

      • putClientProperty

        public final void putClientProperty(Object key,
                     Object value)
        Adds an arbitrary key/value "client property" to this component.

        The get/putClientProperty methods provide access to a small per-instance hashtable. Callers can use get/putClientProperty to annotate components that were created by another module. For example, a layout manager might store per child constraints this way. For example:

         componentA.putClientProperty("to the left of", componentB);
        If value is null this method will remove the property. Changes to client properties are reported with PropertyChange events. The name of the property (for the sake of PropertyChange events) is key.toString().

        The clientProperty dictionary is not intended to support large scale extensions to JComponent nor should be it considered an alternative to subclassing when designing a new component.

        参数：
        key - the new client property key
        value - the new client property value; if null this method will remove the property
        另请参见：
        getClientProperty(java.lang.Object), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • setFocusTraversalKeys

        public void setFocusTraversalKeys(int id,
                         Set<? extends AWTKeyStroke> keystrokes)
        Sets the focus traversal keys for a given traversal operation for this Component. Refer to Component.setFocusTraversalKeys(int, java.util.Set) for a complete description of this method.
        重载：
        setFocusTraversalKeys in class Container
        参数：
        id - one of KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, or KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS
        keystrokes - the Set of AWTKeyStroke for the specified operation
        抛出：
        IllegalArgumentException - if id is not one of KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, or KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS, or if keystrokes contains null, or if any Object in keystrokes is not an AWTKeyStroke, or if any keystroke represents a KEY_TYPED event, or if any keystroke already maps to another focus traversal operation for this Component
        从以下版本开始：
        1.5
        另请参见：
        KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

      • isLightweightComponent

        public static boolean isLightweightComponent(Component c)
        Returns true if this component is lightweight, that is, if it doesn't have a native window system peer.
        返回：
        true if this component is lightweight

      • reshape

        @Deprecated
public void reshape(int x,
                      int y,
                      int w,
                      int h)
        Deprecated. As of JDK 5, replaced by Component.setBounds(int, int, int, int).

        Moves and resizes this component.

        重载：
        reshape in class Component
        参数：
        x - the new horizontal location
        y - the new vertical location
        w - the new width
        h - the new height
        另请参见：
        Component.setBounds(int, int, int, int)

      • getBounds

        public Rectangle getBounds(Rectangle rv)
        Stores the bounds of this component into "return value" rv and returns rv. If rv is null a new Rectangle is allocated. This version of getBounds is useful if the caller wants to avoid allocating a new Rectangle object on the heap.
        重载：
        getBounds in class Component
        参数：
        rv - the return value, modified to the component's bounds
        返回：
        rv; if rv is null return a newly created Rectangle with this component's bounds

      • getSize

        public Dimension getSize(Dimension rv)
        Stores the width/height of this component into "return value" rv and returns rv. If rv is null a new Dimension object is allocated. This version of getSize is useful if the caller wants to avoid allocating a new Dimension object on the heap.
        重载：
        getSize in class Component
        参数：
        rv - the return value, modified to the component's size
        返回：
        rv

      • getLocation

        public Point getLocation(Point rv)
        Stores the x,y origin of this component into "return value" rv and returns rv. If rv is null a new Point is allocated. This version of getLocation is useful if the caller wants to avoid allocating a new Point object on the heap.
        重载：
        getLocation in class Component
        参数：
        rv - the return value, modified to the component's location
        返回：
        rv

      • getX

        public int getX()
        Returns the current x coordinate of the component's origin. This method is preferable to writing component.getBounds().x, or component.getLocation().x because it doesn't cause any heap allocations.
        重载：
        getX in class Component
        返回：
        the current x coordinate of the component's origin

      • getY

        public int getY()
        Returns the current y coordinate of the component's origin. This method is preferable to writing component.getBounds().y, or component.getLocation().y because it doesn't cause any heap allocations.
        重载：
        getY in class Component
        返回：
        the current y coordinate of the component's origin

      • getWidth

        public int getWidth()
        Returns the current width of this component. This method is preferable to writing component.getBounds().width, or component.getSize().width because it doesn't cause any heap allocations.
        重载：
        getWidth in class Component
        返回：
        the current width of this component

      • getHeight

        public int getHeight()
        Returns the current height of this component. This method is preferable to writing component.getBounds().height, or component.getSize().height because it doesn't cause any heap allocations.
        重载：
        getHeight in class Component
        返回：
        the current height of this component

      • isOpaque

        public boolean isOpaque()
        Returns true if this component is completely opaque.

        An opaque component paints every pixel within its rectangular bounds. A non-opaque component paints only a subset of its pixels or none at all, allowing the pixels underneath it to "show through". Therefore, a component that does not fully paint its pixels provides a degree of transparency.

        Subclasses that guarantee to always completely paint their contents should override this method and return true.

        重载：
        isOpaque in class Component
        返回：
        true if this component is completely opaque
        另请参见：
        setOpaque(boolean)

      • setOpaque

        public void setOpaque(boolean isOpaque)
        If true the component paints every pixel within its bounds. Otherwise, the component may not paint some or all of its pixels, allowing the underlying pixels to show through.

        The default value of this property is false for JComponent. However, the default value for this property on most standard JComponent subclasses (such as JButton and JTree) is look-and-feel dependent.

        参数：
        isOpaque - true if this component should be opaque
        另请参见：
        isOpaque()

      • computeVisibleRect

        public void computeVisibleRect(Rectangle visibleRect)
        Returns the Component's "visible rect rectangle" - the intersection of the visible rectangles for this component and all of its ancestors. The return value is stored in visibleRect.
        参数：
        visibleRect - a Rectangle computed as the intersection of all visible rectangles for this component and all of its ancestors -- this is the return value for this method
        另请参见：
        getVisibleRect()

      • getVisibleRect

        public Rectangle getVisibleRect()
        Returns the Component's "visible rectangle" - the intersection of this component's visible rectangle, new Rectangle(0, 0, getWidth(), getHeight()), and all of its ancestors' visible rectangles.
        返回：
        the visible rectangle

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      boolean oldValue,
                      boolean newValue)
        Support for reporting bound property changes for boolean properties. This method can be called when a bound property has changed and it will send the appropriate PropertyChangeEvent to any registered PropertyChangeListeners.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      int oldValue,
                      int newValue)
        Support for reporting bound property changes for integer properties. This method can be called when a bound property has changed and it will send the appropriate PropertyChangeEvent to any registered PropertyChangeListeners.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      char oldValue,
                      char newValue)
        Description copied from class: Component
        Reports a bound property change.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a char)
        newValue - the new value of the property (as a char)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • fireVetoableChange

        protected void fireVetoableChange(String propertyName,
                      Object oldValue,
                      Object newValue)
                           throws PropertyVetoException
        Supports reporting constrained property changes. This method can be called when a constrained property has changed and it will send the appropriate PropertyChangeEvent to any registered VetoableChangeListeners.
        参数：
        propertyName - the name of the property that was listened on
        oldValue - the old value of the property
        newValue - the new value of the property
        抛出：
        PropertyVetoException - when the attempt to set the property is vetoed by the component

      • addVetoableChangeListener

        public void addVetoableChangeListener(VetoableChangeListener listener)
        Adds a VetoableChangeListener to the listener list. The listener is registered for all properties.
        参数：
        listener - the VetoableChangeListener to be added

      • removeVetoableChangeListener

        public void removeVetoableChangeListener(VetoableChangeListener listener)
        Removes a VetoableChangeListener from the listener list. This removes a VetoableChangeListener that was registered for all properties.
        参数：
        listener - the VetoableChangeListener to be removed

      • getVetoableChangeListeners

        public VetoableChangeListener[] getVetoableChangeListeners()
        Returns an array of all the vetoable change listeners registered on this component.
        返回：
        all of the component's VetoableChangeListeners or an empty array if no vetoable change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addVetoableChangeListener(java.beans.VetoableChangeListener), removeVetoableChangeListener(java.beans.VetoableChangeListener)

      • getTopLevelAncestor

        public Container getTopLevelAncestor()
        Returns the top-level ancestor of this component (either the containing Window or Applet), or null if this component has not been added to any container.
        返回：
        the top-level Container that this component is in, or null if not in any container

      • addAncestorListener

        public void addAncestorListener(AncestorListener listener)
        Registers listener so that it will receive AncestorEvents when it or any of its ancestors move or are made visible or invisible. Events are also sent when the component or its ancestors are added or removed from the containment hierarchy.
        参数：
        listener - the AncestorListener to register
        另请参见：
        AncestorEvent

      • removeAncestorListener

        public void removeAncestorListener(AncestorListener listener)
        Unregisters listener so that it will no longer receive AncestorEvents.
        参数：
        listener - the AncestorListener to be removed
        另请参见：
        addAncestorListener(javax.swing.event.AncestorListener)

      • getAncestorListeners

        public AncestorListener[] getAncestorListeners()
        Returns an array of all the ancestor listeners registered on this component.
        返回：
        all of the component's AncestorListeners or an empty array if no ancestor listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addAncestorListener(javax.swing.event.AncestorListener), removeAncestorListener(javax.swing.event.AncestorListener)

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this JComponent. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a JComponent c for its mouse listeners with the following code:

        MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
        If no such listeners exist, this method returns an empty array.
        重载：
        getListeners in class Container
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getVetoableChangeListeners(), getAncestorListeners()

      • addNotify

        public void addNotify()
        Notifies this component that it now has a parent component. When this method is invoked, the chain of parent components is set up with KeyboardAction event listeners. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        addNotify in class Container
        另请参见：
        registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • removeNotify

        public void removeNotify()
        Notifies this component that it no longer has a parent component. When this method is invoked, any KeyboardActions set up in the the chain of parent components are removed. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        removeNotify in class Container
        另请参见：
        registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • repaint

        public void repaint(long tm,
           int x,
           int y,
           int width,
           int height)
        Adds the specified region to the dirty region list if the component is showing. The component will be repainted after all of the currently pending events have been dispatched.
        重载：
        repaint in class Component
        参数：
        tm - this parameter is not used
        x - the x value of the dirty region
        y - the y value of the dirty region
        width - the width of the dirty region
        height - the height of the dirty region
        另请参见：
        isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint(Rectangle r)
        Adds the specified region to the dirty region list if the component is showing. The component will be repainted after all of the currently pending events have been dispatched.
        参数：
        r - a Rectangle containing the dirty region
        另请参见：
        isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • revalidate

        public void revalidate()
        Supports deferred automatic layout.

        Calls invalidate and then adds this component's validateRoot to a list of components that need to be validated. Validation will occur after all currently pending events have been dispatched. In other words after this method is called, the first validateRoot (if any) found when walking up the containment hierarchy of this component will be validated. By default, JRootPane, JScrollPane, and JTextField return true from isValidateRoot.

        This method will automatically be called on this component when a property value changes such that size, location, or internal layout of this component has been affected. This automatic updating differs from the AWT because programs generally no longer need to invoke validate to get the contents of the GUI to update.

        另请参见：
        Component.invalidate(),
Container.validate(),
isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

      • isValidateRoot

        public boolean isValidateRoot()
        If this method returns true, revalidate calls by descendants of this component will cause the entire tree beginning with this root to be validated. Returns false by default. JScrollPane overrides this method and returns true.
        重载：
        isValidateRoot in class Container
        返回：
        always returns false
        另请参见：
        revalidate(),
Component.invalidate(),
Container.validate(),
Container.isValidateRoot()

      • isOptimizedDrawingEnabled

        public boolean isOptimizedDrawingEnabled()
        Returns true if this component tiles its children -- that is, if it can guarantee that the children will not overlap. The repainting system is substantially more efficient in this common case. JComponent subclasses that can't make this guarantee, such as JLayeredPane, should override this method to return false.
        返回：
        always returns true

      • isPaintingOrigin

        protected boolean isPaintingOrigin()
        Returns true if a paint triggered on a child component should cause painting to originate from this Component, or one of its ancestors.

        Calling repaint(long, int, int, int, int) or paintImmediately(int, int, int, int) on a Swing component will result in calling the paintImmediately(int, int, int, int) method of the first ancestor which isPaintingOrigin() returns true, if there are any.

        JComponent subclasses that need to be painted when any of their children are repainted should override this method to return true.

        返回：
        always returns false
        另请参见：
        paintImmediately(int, int, int, int)

      • paintImmediately

        public void paintImmediately(int x,
                    int y,
                    int w,
                    int h)
        Paints the specified region in this component and all of its descendants that overlap the region, immediately.

        It's rarely necessary to call this method. In most cases it's more efficient to call repaint, which defers the actual painting and can collapse redundant requests into a single paint call. This method is useful if one needs to update the display while the current event is being dispatched.

        This method is to be overridden when the dirty region needs to be changed for components that are painting origins.

        参数：
        x - the x value of the region to be painted
        y - the y value of the region to be painted
        w - the width of the region to be painted
        h - the height of the region to be painted
        另请参见：
        repaint(long, int, int, int, int), isPaintingOrigin()

      • paintImmediately

        public void paintImmediately(Rectangle r)
        Paints the specified region now.
        参数：
        r - a Rectangle containing the region to be painted

      • setDoubleBuffered

        public void setDoubleBuffered(boolean aFlag)
        Sets whether this component should use a buffer to paint. If set to true, all the drawing from this component will be done in an offscreen painting buffer. The offscreen painting buffer will the be copied onto the screen. If a Component is buffered and one of its ancestor is also buffered, the ancestor buffer will be used.
        参数：
        aFlag - if true, set this component to be double buffered

      • isDoubleBuffered

        public boolean isDoubleBuffered()
        Returns whether this component should use a buffer to paint.
        重载：
        isDoubleBuffered in class Component
        返回：
        true if this component is double buffered, otherwise false

      • getRootPane

        public JRootPane getRootPane()
        Returns the JRootPane ancestor for this component.
        返回：
        the JRootPane that contains this component, or null if no JRootPane is found

      • paramString

        protected String paramString()
        Returns a string representation of this JComponent. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class Container
        返回：
        a string representation of this JComponent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JComponent.AccessibleJComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComponent.AccessibleJComponent

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    直接已知子类：
    AbstractButton.AccessibleAbstractButton, JColorChooser.AccessibleJColorChooser, JComboBox.AccessibleJComboBox, JDesktopPane.AccessibleJDesktopPane, JFileChooser.AccessibleJFileChooser, JInternalFrame.AccessibleJInternalFrame, JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon, JLabel.AccessibleJLabel, JLayeredPane.AccessibleJLayeredPane, JList.AccessibleJList, JMenuBar.AccessibleJMenuBar, JOptionPane.AccessibleJOptionPane, JPanel.AccessibleJPanel, JPopupMenu.AccessibleJPopupMenu, JProgressBar.AccessibleJProgressBar, JRootPane.AccessibleJRootPane, JScrollBar.AccessibleJScrollBar, JScrollPane.AccessibleJScrollPane, JSeparator.AccessibleJSeparator, JSlider.AccessibleJSlider, JSpinner.AccessibleJSpinner, JSplitPane.AccessibleJSplitPane, JTabbedPane.AccessibleJTabbedPane, JTable.AccessibleJTable, JTableHeader.AccessibleJTableHeader, JTextComponent.AccessibleJTextComponent, JToolBar.AccessibleJToolBar, JToolTip.AccessibleJToolTip, JTree.AccessibleJTree, JViewport.AccessibleJViewport
    封闭类：
    JComponent

    public abstract class JComponent.AccessibleJComponent
extends Container.AccessibleAWTContainer
implements AccessibleExtendedComponent
    Inner class of JComponent used to provide default support for accessibility. This class is not meant to be used directly by application developers, but is instead meant only to be subclassed by component developers.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JComponent.AccessibleJComponent.AccessibleContainerHandler
      Fire PropertyChange listener, if one is registered, when children added/removed.
      protected class  JComponent.AccessibleJComponent.AccessibleFocusHandler
      Fire PropertyChange listener, if one is registered, when focus events happen

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ContainerListener | accessibleContainerHandler
      protected FocusListener | accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JComponent.AccessibleJComponent()
      Though the class is abstract, this should be called by all sub-classes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      Accessible getAccessibleChild(int i)
      Returns the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      String getAccessibleDescription()
      Gets the accessible description of this object.
      AccessibleKeyBinding getAccessibleKeyBinding()
      Returns key bindings associated with this object
      String getAccessibleName()
      Gets the accessible name of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state of this object.
      protected String getBorderTitle(Border b)
      Recursively search through the border hierarchy (if it exists) for a TitledBorder with a non-null title.
      String getTitledBorderText()
      Returns the titled border text
      String getToolTipText()
      Returns the tool tip text
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 字段详细信息

      • accessibleContainerHandler

        protected ContainerListener accessibleContainerHandler

      • accessibleFocusHandler

        protected FocusListener accessibleFocusHandler

    • 构造方法详细信息

      • JComponent.AccessibleJComponent

        protected JComponent.AccessibleJComponent()
        Though the class is abstract, this should be called by all sub-classes.

    • 方法详细信息

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list.
        重载：
        addPropertyChangeListener in class Container.AccessibleAWTContainer
        参数：
        listener - the PropertyChangeListener to be added
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        重载：
        removePropertyChangeListener in class Component.AccessibleAWTComponent
        参数：
        listener - the PropertyChangeListener to be removed

      • getBorderTitle

        protected String getBorderTitle(Border b)
        Recursively search through the border hierarchy (if it exists) for a TitledBorder with a non-null title. This does a depth first search on first the inside borders then the outside borders. The assumption is that titles make really pretty inside borders but not very pretty outside borders in compound border situations. It's rather arbitrary, but hopefully decent UI programmers will not create multiple titled borders for the same component.

      • getAccessibleName

        public String getAccessibleName()
        Gets the accessible name of this object. This should almost never return java.awt.Component.getName(), as that generally isn't a localized name, and doesn't have meaning for the user. If the object is fundamentally a text object (such as a menu item), the accessible name should be the text of the object (for example, "save"). If the object has a tooltip, the tooltip text may also be an appropriate String to return.
        重载：
        getAccessibleName in class Component.AccessibleAWTComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Gets the accessible description of this object. This should be a concise, localized description of what this object is - what is its meaning to the user. If the object has a tooltip, the tooltip text may be an appropriate string to return, assuming it contains a concise description of the object (instead of just the name of the object - for example a "Save" icon on a toolbar that had "save" as the tooltip text shouldn't return the tooltip text as the description, but something like "Saves the current text document" instead).
        重载：
        getAccessibleDescription in class Component.AccessibleAWTComponent
        返回：
        the localized description of the object -- can be null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class Component.AccessibleAWTComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state of this object.
        重载：
        getAccessibleStateSet in class Component.AccessibleAWTComponent
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class Container.AccessibleAWTContainer
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the nth Accessible child of the object.
        重载：
        getAccessibleChild in class Container.AccessibleAWTContainer
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getToolTipText

        public String getToolTipText()
        Returns the tool tip text
        指定者：
        getToolTipText in interface AccessibleExtendedComponent
        返回：
        the tool tip text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getTitledBorderText

        public String getTitledBorderText()
        Returns the titled border text
        指定者：
        getTitledBorderText in interface AccessibleExtendedComponent
        返回：
        the titled border text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getAccessibleKeyBinding

        public AccessibleKeyBinding getAccessibleKeyBinding()
        Returns key bindings associated with this object
        指定者：
        getAccessibleKeyBinding in interface AccessibleExtendedComponent
        返回：
        the key bindings, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4
        另请参见：
        AccessibleKeyBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JComponent.AccessibleJComponent.AccessibleContainerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComponent.AccessibleJComponent.AccessibleContainerHandler

  • java.lang.Object
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
  • 所有已实现的接口：
    ContainerListener, EventListener
    封闭类：
    JComponent.AccessibleJComponent

    protected class JComponent.AccessibleJComponent.AccessibleContainerHandler
extends Object
implements ContainerListener
    Fire PropertyChange listener, if one is registered, when children added/removed.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JComponent.AccessibleJComponent.AccessibleContainerHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void componentAdded(ContainerEvent e)
      Invoked when a component has been added to the container.
      void componentRemoved(ContainerEvent e)
      Invoked when a component has been removed from the container.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JComponent.AccessibleJComponent.AccessibleContainerHandler

        protected JComponent.AccessibleJComponent.AccessibleContainerHandler()

    • 方法详细信息

      • componentAdded

        public void componentAdded(ContainerEvent e)
        从接口复制的描述： ContainerListener
        Invoked when a component has been added to the container.
        指定者：
        componentAdded in interface ContainerListener

      • componentRemoved

        public void componentRemoved(ContainerEvent e)
        从接口复制的描述： ContainerListener
        Invoked when a component has been removed from the container.
        指定者：
        componentRemoved in interface ContainerListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

==t hC.gf_r>


JComponent.AccessibleJComponent.AccessibleFocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JComponent.AccessibleJComponent.AccessibleFocusHandler

  • java.lang.Object
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    JComponent.AccessibleJComponent

    protected class JComponent.AccessibleJComponent.AccessibleFocusHandler
extends Object
implements FocusListener
    Fire PropertyChange listener, if one is registered, when focus events happen
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JComponent.AccessibleJComponent.AccessibleFocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent event)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent event)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JComponent.AccessibleJComponent.AccessibleFocusHandler

        protected JComponent.AccessibleJComponent.AccessibleFocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent event)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent event)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

prt s e hocepavet５迪骀泉辱耸ⅱ鋈√抛


JDesktopPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JDesktopPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLayeredPane
            • javax.swing.JDesktopPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JDesktopPane
extends JLayeredPane
implements Accessible
    A container used to create a multiple-document interface or a virtual desktop. You create JInternalFrame objects and add them to the JDesktopPane. JDesktopPane extends JLayeredPane to manage the potentially overlapping internal frames. It also maintains a reference to an instance of DesktopManager that is set by the UI class for the current look and feel (L&F). Note that JDesktopPane does not support borders.

    This class is normally used as the parent of JInternalFrames to provide a pluggable DesktopManager object to the JInternalFrames. The installUI of the L&F specific implementation is responsible for setting the desktopManager variable appropriately. When the parent of a JInternalFrame is a JDesktopPane, it should delegate most of its behavior to the desktopManager (closing, resizing, etc).

    For further documentation and examples see How to Use Internal Frames, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JInternalFrame, JInternalFrame.JDesktopIcon, DesktopManager

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JDesktopPane.AccessibleJDesktopPane
      This class implements accessibility support for the JDesktopPane class.

      • Nested classes/interfaces inherited from class javax.swing.JLayeredPane

        JLayeredPane.AccessibleJLayeredPane

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int LIVE_DRAG_MODE
      Indicates that the entire contents of the item being dragged should appear inside the desktop pane.
      static int OUTLINE_DRAG_MODE
      Indicates that an outline only of the item being dragged should appear inside the desktop pane.

      • Fields inherited from class javax.swing.JLayeredPane

        DEFAULT_LAYER, DRAG_LAYER, FRAME_CONTENT_LAYER, LAYER_PROPERTY, MODAL_LAYER, PALETTE_LAYER, POPUP_LAYER

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JDesktopPane()
      Creates a new JDesktopPane.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified component to this container at the specified index.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JDesktopPane.
      JInternalFrame[] getAllFrames()
      Returns all JInternalFrames currently displayed in the desktop.
      JInternalFrame[] getAllFramesInLayer(int layer)
      Returns all JInternalFrames currently displayed in the specified layer of the desktop.
      DesktopManager getDesktopManager()
      Returns the DesktopManger that handles desktop-specific UI actions.
      int getDragMode()
      Gets the current "dragging style" used by the desktop pane.
      JInternalFrame getSelectedFrame()
      Returns the currently active JInternalFrame in this JDesktopPane, or null if no JInternalFrame is currently active.
      DesktopPaneUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JDesktopPane.
      void remove(int index)
      Remove the indexed component from this pane.
      void removeAll()
      Removes all the components from this container.
      JInternalFrame selectFrame(boolean forward)
      Selects the next JInternalFrame in this desktop pane.
      void setComponentZOrder(Component comp, int index)
      Moves the specified component to the specified z-order index in the container.
      void setDesktopManager(DesktopManager d)
      Sets the DesktopManger that will handle desktop-specific UI actions.
      void setDragMode(int dragMode)
      Sets the "dragging style" used by the desktop pane.
      void setSelectedFrame(JInternalFrame f)
      Sets the currently active JInternalFrame in this JDesktopPane.
      void setUI(DesktopPaneUI ui)
      Sets the L&F object that renders this component.
      void updateUI()
      Notification from the UIManager that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JLayeredPane

        getComponentCountInLayer, getComponentsInLayer, getComponentToLayer, getIndexOf, getLayer, getLayer, getLayeredPaneAbove, getObjectForLayer, getPosition, highestLayer, insertIndexForLayer, isOptimizedDrawingEnabled, lowestLayer, moveToBack, moveToFront, paint, putLayer, setLayer, setLayer, setPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeContainerListener, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • LIVE_DRAG_MODE

        public static final int LIVE_DRAG_MODE
        Indicates that the entire contents of the item being dragged should appear inside the desktop pane.
        另请参见：
        OUTLINE_DRAG_MODE, setDragMode(int), Constant Field Values

      • OUTLINE_DRAG_MODE

        public static final int OUTLINE_DRAG_MODE
        Indicates that an outline only of the item being dragged should appear inside the desktop pane.
        另请参见：
        LIVE_DRAG_MODE, setDragMode(int), Constant Field Values

    • 构造方法详细信息

      • JDesktopPane

        public JDesktopPane()
        Creates a new JDesktopPane.

    • 方法详细信息

      • getUI

        public DesktopPaneUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the DesktopPaneUI object that renders this component

      • setUI

        public void setUI(DesktopPaneUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the DesktopPaneUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • setDragMode

        public void setDragMode(int dragMode)
        Sets the "dragging style" used by the desktop pane. You may want to change to one mode or another for performance or aesthetic reasons.
        参数：
        dragMode - the style of drag to use for items in the Desktop
        从以下版本开始：
        1.3
        另请参见：
        LIVE_DRAG_MODE, OUTLINE_DRAG_MODE

      • getDragMode

        public int getDragMode()
        Gets the current "dragging style" used by the desktop pane.
        返回：
        either Live_DRAG_MODE or OUTLINE_DRAG_MODE
        从以下版本开始：
        1.3
        另请参见：
        setDragMode(int)

      • getDesktopManager

        public DesktopManager getDesktopManager()
        Returns the DesktopManger that handles desktop-specific UI actions.

      • setDesktopManager

        public void setDesktopManager(DesktopManager d)
        Sets the DesktopManger that will handle desktop-specific UI actions. This may be overridden by LookAndFeel.
        参数：
        d - the DesktopManager to use

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "DesktopPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getAllFrames

        public JInternalFrame[] getAllFrames()
        Returns all JInternalFrames currently displayed in the desktop. Returns iconified frames as well as expanded frames.
        返回：
        an array of JInternalFrame objects

      • getSelectedFrame

        public JInternalFrame getSelectedFrame()
        Returns the currently active JInternalFrame in this JDesktopPane, or null if no JInternalFrame is currently active.
        返回：
        the currently active JInternalFrame or null
        从以下版本开始：
        1.3

      • setSelectedFrame

        public void setSelectedFrame(JInternalFrame f)
        Sets the currently active JInternalFrame in this JDesktopPane. This method is used to bridge the package gap between JDesktopPane and the platform implementation code and should not be called directly. To visually select the frame the client must call JInternalFrame.setSelected(true) to activate the frame.
        参数：
        f - the internal frame that's currently selected
        从以下版本开始：
        1.3
        另请参见：
        JInternalFrame.setSelected(boolean)

      • getAllFramesInLayer

        public JInternalFrame[] getAllFramesInLayer(int layer)
        Returns all JInternalFrames currently displayed in the specified layer of the desktop. Returns iconified frames as well expanded frames.
        参数：
        layer - an int specifying the desktop layer
        返回：
        an array of JInternalFrame objects
        另请参见：
        JLayeredPane

      • selectFrame

        public JInternalFrame selectFrame(boolean forward)
        Selects the next JInternalFrame in this desktop pane.
        参数：
        forward - a boolean indicating which direction to select in; true for forward, false for backward
        返回：
        the JInternalFrame that was selected or null if nothing was selected
        从以下版本开始：
        1.6

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified component to this container at the specified index. This method also notifies the layout manager to add the component to this container's layout using the specified constraints object via the addLayoutComponent method.

        The constraints are defined by the particular layout manager being used. For example, the BorderLayout class defines five constraints: BorderLayout.NORTH, BorderLayout.SOUTH, BorderLayout.EAST, BorderLayout.WEST, and BorderLayout.CENTER.

        The GridBagLayout class requires a GridBagConstraints object. Failure to pass the correct type of constraints object results in an IllegalArgumentException.

        If the current layout manager implements LayoutManager2, then LayoutManager2.addLayoutComponent(Component,Object) is invoked on it. If the current layout manager does not implement LayoutManager2, and constraints is a String, then LayoutManager.addLayoutComponent(String,Component) is invoked on it.

        If the component is not an ancestor of this container and has a non-null parent, it is removed from its current parent before it is added to this container.

        This is the method to override if a program needs to track every add request to a container as all other add methods defer to this one. An overriding method should usually include a call to the superclass's version of the method:

        super.addImpl(comp, constraints, index)

        This method changes layout-related information, and therefore, invalidates the component hierarchy. If the container has already been displayed, the hierarchy must be validated thereafter in order to display the added component.

        重载：
        addImpl in class JLayeredPane
        参数：
        comp - the component to be added
        constraints - an object expressing layout constraints for this component
        index - the position in the container's list at which to insert the component, where -1 means append to the end
        从以下版本开始：
        1.6
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • remove

        public void remove(int index)
        Remove the indexed component from this pane. This is the absolute index, ignoring layers.
        重载：
        remove in class JLayeredPane
        参数：
        index - an int specifying the component to remove
        从以下版本开始：
        1.6
        另请参见：
        JLayeredPane.getIndexOf(java.awt.Component)

      • removeAll

        public void removeAll()
        Removes all the components from this container.
        重载：
        removeAll in class JLayeredPane
        从以下版本开始：
        1.6
        另请参见：
        Container.add(java.awt.Component),
Container.remove(int),
Container.invalidate()

      • setComponentZOrder

        public void setComponentZOrder(Component comp,
                      int index)
        Moves the specified component to the specified z-order index in the container. The z-order determines the order that components are painted; the component with the highest z-order paints first and the component with the lowest z-order paints last. Where components overlap, the component with the lower z-order paints over the component with the higher z-order.

        If the component is a child of some other container, it is removed from that container before being added to this container. The important difference between this method and java.awt.Container.add(Component, int) is that this method doesn't call removeNotify on the component while removing it from its previous container unless necessary and when allowed by the underlying native windowing system. This way, if the component has the keyboard focus, it maintains the focus when moved to the new position.

        This property is guaranteed to apply only to lightweight non-Container components.

        This method changes layout-related information, and therefore, invalidates the component hierarchy.

        Note: Not all platforms support changing the z-order of heavyweight components from one container into another without the call to removeNotify. There is no way to detect whether a platform supports this, so developers shouldn't make any assumptions.

        重载：
        setComponentZOrder in class Container
        参数：
        comp - the component to be moved
        index - the position in the container's list to insert the component, where getComponentCount() appends to the end
        从以下版本开始：
        1.6
        另请参见：
        Container.getComponentZOrder(java.awt.Component), Container.invalidate()

      • paramString

        protected String paramString()
        Returns a string representation of this JDesktopPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JLayeredPane
        返回：
        a string representation of this JDesktopPane

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JDesktopPane. For desktop panes, the AccessibleContext takes the form of an AccessibleJDesktopPane. A new AccessibleJDesktopPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JLayeredPane
        返回：
        an AccessibleJDesktopPane that serves as the AccessibleContext of this JDesktopPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ocn;n e k e>e/jArawe)


JDesktopPane.AccessibleJDesktopPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JDesktopPane.AccessibleJDesktopPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JDesktopPane

    protected class JDesktopPane.AccessibleJDesktopPane
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JDesktopPane class. It provides an implementation of the Java Accessibility API appropriate to desktop pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JDesktopPane.AccessibleJDesktopPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JDesktopPane.AccessibleJDesktopPane

        protected JDesktopPane.AccessibleJDesktopPane()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iurl tol


JDialog

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JDialog

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • java.awt.Dialog
            • javax.swing.JDialog
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants

    public class JDialog
extends Dialog
implements WindowConstants, Accessible, RootPaneContainer
    The main class for creating a dialog window. You can use this class to create a custom dialog, or invoke the many class methods in JOptionPane to create a variety of standard dialogs. For information about creating dialogs, see The Java Tutorial section How to Make Dialogs.

    The JDialog component contains a JRootPane as its only child. The contentPane should be the parent of any children of the JDialog. As a convenience add and its variants, remove and setLayout have been overridden to forward to the contentPane as necessary. This means you can write:

           dialog.add(child);
    And the child will be added to the contentPane. The contentPane is always non-null. Attempting to set it to null generates an exception. The default contentPane has a BorderLayout manager set on it. Refer to RootPaneContainer for details on adding, removing and setting the LayoutManager of a JDialog.

    Please see the JRootPane documentation for a complete description of the contentPane, glassPane, and layeredPane components.

    In a multi-screen environment, you can create a JDialog on a different screen device than its owner. See Frame for more information.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JOptionPane, JRootPane, RootPaneContainer

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JDialog.AccessibleJDialog
      This class implements accessibility support for the JDialog class.

      • Nested classes/interfaces inherited from class java.awt.Dialog

        Dialog.AccessibleAWTDialog, Dialog.ModalExclusionType, Dialog.ModalityType

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected AccessibleContext | accessibleContext
      protected JRootPane | rootPane
      protected boolean rootPaneCheckingEnabled
      If true then calls to add and setLayout will be forwarded to the contentPane.

      • Fields inherited from class java.awt.Dialog

        DEFAULT_MODALITY_TYPE

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.WindowConstants

        DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, EXIT_ON_CLOSE, HIDE_ON_CLOSE

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JDialog()
      Creates a modeless dialog without a title and without a specified Frame owner.
      JDialog(Dialog owner)
      Creates a modeless dialog with the specified Dialog as its owner and an empty title.
      JDialog(Dialog owner, boolean modal)
      Creates a dialog with an empty title and the specified modality and Dialog as its owner.
      JDialog(Dialog owner, String title)
      Creates a modeless dialog with the specified title and with the specified owner dialog.
      JDialog(Dialog owner, String title, boolean modal)
      Creates a dialog with the specified title, modality and the specified owner Dialog.
      JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
      Creates a dialog with the specified title, owner Dialog, modality and GraphicsConfiguration.
      JDialog(Frame owner)
      Creates a modeless dialog with the specified Frame as its owner and an empty title.
      JDialog(Frame owner, boolean modal)
      Creates a dialog with an empty title and the specified modality and Frame as its owner.
      JDialog(Frame owner, String title)
      Creates a modeless dialog with the specified title and with the specified owner frame.
      JDialog(Frame owner, String title, boolean modal)
      Creates a dialog with the specified title, owner Frame and modality.
      JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
      Creates a dialog with the specified title, owner Frame, modality and GraphicsConfiguration.
      JDialog(Window owner)
      Creates a modeless dialog with the specified Window as its owner and an empty title.
      JDialog(Window owner, Dialog.ModalityType modalityType)
      Creates a dialog with an empty title and the specified modality and Window as its owner.
      JDialog(Window owner, String title)
      Creates a modeless dialog with the specified title and owner Window.
      JDialog(Window owner, String title, Dialog.ModalityType modalityType)
      Creates a dialog with the specified title, owner Window and modality.
      JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
      Creates a dialog with the specified title, owner Window, modality and GraphicsConfiguration.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified child Component.
      protected JRootPane createRootPane()
      Called by the constructor methods to create the default rootPane.
      protected void dialogInit()
      Called by the constructors to init the JDialog properly.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JDialog.
      Container getContentPane()
      Returns the contentPane object for this dialog.
      int getDefaultCloseOperation()
      Returns the operation which occurs when the user initiates a "close" on this dialog.
      Component getGlassPane()
      Returns the glassPane object for this dialog.
      Graphics getGraphics()
      Creates a graphics context for this component.
      JMenuBar getJMenuBar()
      Returns the menubar set on this dialog.
      JLayeredPane getLayeredPane()
      Returns the layeredPane object for this dialog.
      JRootPane getRootPane()
      Returns the rootPane object for this dialog.
      TransferHandler getTransferHandler()
      Gets the transferHandler property.
      static boolean isDefaultLookAndFeelDecorated()
      Returns true if newly created JDialogs should have their Window decorations provided by the current look and feel.
      protected boolean isRootPaneCheckingEnabled()
      Returns whether calls to add and setLayout are forwarded to the contentPane.
      protected String paramString()
      Returns a string representation of this JDialog.
      protected void processWindowEvent(WindowEvent e)
      Handles window events depending on the state of the defaultCloseOperation property.
      void remove(Component comp)
      Removes the specified component from the container.
      void repaint(long time, int x, int y, int width, int height)
      Repaints the specified rectangle of this component within time milliseconds.
      void setContentPane(Container contentPane)
      Sets the contentPane property.
      void setDefaultCloseOperation(int operation)
      Sets the operation that will happen by default when the user initiates a "close" on this dialog.
      static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
      Provides a hint as to whether or not newly created JDialogs should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel.
      void setGlassPane(Component glassPane)
      Sets the glassPane property.
      void setJMenuBar(JMenuBar menu)
      Sets the menubar for this dialog.
      void setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void setLayout(LayoutManager manager)
      Sets the LayoutManager.
      protected void setRootPane(JRootPane root)
      Sets the rootPane property.
      protected void setRootPaneCheckingEnabled(boolean enabled)
      Sets whether calls to add and setLayout are forwarded to the contentPane.
      void setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void update(Graphics g)
      Calls paint(g).

      • 方法 - 继承于类 java.awt.Dialog

        addNotify, getModalityType, getTitle, hide, isModal, isResizable, isUndecorated, setBackground, setModal, setModalityType, setOpacity, setResizable, setShape, setTitle, setUndecorated, setVisible, show, toBack

      • 方法 - 继承于类 java.awt.Window

        addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setType, toFront

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • rootPane

        protected JRootPane rootPane
        另请参见：
        getRootPane(), setRootPane(javax.swing.JRootPane)

      • rootPaneCheckingEnabled

        protected boolean rootPaneCheckingEnabled
        If true then calls to add and setLayout will be forwarded to the contentPane. This is initially false, but is set to true when the JDialog is constructed.
        另请参见：
        isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • accessibleContext

        protected AccessibleContext accessibleContext

    • 构造方法详细信息

      • JDialog

        public JDialog()
        Creates a modeless dialog without a title and without a specified Frame owner. A shared, hidden frame will be set as the owner of the dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Frame owner)
        Creates a modeless dialog with the specified Frame as its owner and an empty title. If owner is null, a shared, hidden frame will be set as the owner of the dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        参数：
        owner - the Frame from which the dialog is displayed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Frame owner,
       boolean modal)
        Creates a dialog with an empty title and the specified modality and Frame as its owner. If owner is null, a shared, hidden frame will be set as the owner of the dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        参数：
        owner - the Frame from which the dialog is displayed
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE, otherwise the dialog is modeless.
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Frame owner,
       String title)
        Creates a modeless dialog with the specified title and with the specified owner frame. If owner is null, a shared, hidden frame will be set as the owner of the dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        参数：
        owner - the Frame from which the dialog is displayed
        title - the String to display in the dialog's title bar
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Frame owner,
       String title,
       boolean modal)
        Creates a dialog with the specified title, owner Frame and modality. If owner is null, a shared, hidden frame will be set as the owner of this dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: Any popup components (JComboBox, JPopupMenu, JMenuBar) created within a modal dialog will be forced to be lightweight.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        参数：
        owner - the Frame from which the dialog is displayed
        title - the String to display in the dialog's title bar
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE otherwise the dialog is modeless
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Frame owner,
       String title,
       boolean modal,
       GraphicsConfiguration gc)
        Creates a dialog with the specified title, owner Frame, modality and GraphicsConfiguration. If owner is null, a shared, hidden frame will be set as the owner of this dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        NOTE: Any popup components (JComboBox, JPopupMenu, JMenuBar) created within a modal dialog will be forced to be lightweight.

        NOTE: This constructor does not allow you to create an unowned JDialog. To create an unowned JDialog you must use either the JDialog(Window) or JDialog(Dialog) constructor with an argument of null.

        参数：
        owner - the Frame from which the dialog is displayed
        title - the String to display in the dialog's title bar
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE, otherwise the dialog is modeless.
        gc - the GraphicsConfiguration of the target screen device; if null, the default system GraphicsConfiguration is assumed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        从以下版本开始：
        1.4
        另请参见：
        Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Dialog owner)
        Creates a modeless dialog with the specified Dialog as its owner and an empty title.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the owner Dialog from which the dialog is displayed or null if this dialog has no owner
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Dialog owner,
       boolean modal)
        Creates a dialog with an empty title and the specified modality and Dialog as its owner.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the owner Dialog from which the dialog is displayed or null if this dialog has no owner
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE, otherwise the dialog is modeless.
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Dialog owner,
       String title)
        Creates a modeless dialog with the specified title and with the specified owner dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the owner Dialog from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Dialog owner,
       String title,
       boolean modal)
        Creates a dialog with the specified title, modality and the specified owner Dialog.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the owner Dialog from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE, otherwise the dialog is modeless
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Dialog owner,
       String title,
       boolean modal,
       GraphicsConfiguration gc)
        Creates a dialog with the specified title, owner Dialog, modality and GraphicsConfiguration.

        NOTE: Any popup components (JComboBox, JPopupMenu, JMenuBar) created within a modal dialog will be forced to be lightweight.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the owner Dialog from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar
        modal - specifies whether dialog blocks user input to other top-level windows when shown. If true, the modality type property is set to DEFAULT_MODALITY_TYPE, otherwise the dialog is modeless
        gc - the GraphicsConfiguration of the target screen device; if null, the default system GraphicsConfiguration is assumed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        从以下版本开始：
        1.4
        另请参见：
        Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Window owner)
        Creates a modeless dialog with the specified Window as its owner and an empty title.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the Window from which the dialog is displayed or null if this dialog has no owner
        抛出：
        IllegalArgumentException - if the owner is not an instance of Dialog or Frame
        IllegalArgumentException - if the owner's GraphicsConfiguration is not from a screen device
        HeadlessException - when GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.6
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Window owner,
       Dialog.ModalityType modalityType)
        Creates a dialog with an empty title and the specified modality and Window as its owner.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the Window from which the dialog is displayed or null if this dialog has no owner
        modalityType - specifies whether dialog blocks input to other windows when shown. null value and unsupported modality types are equivalent to MODELESS
        抛出：
        IllegalArgumentException - if the owner is not an instance of Dialog or Frame
        IllegalArgumentException - if the owner's GraphicsConfiguration is not from a screen device
        HeadlessException - when GraphicsEnvironment.isHeadless() returns true
        SecurityException - if the calling thread does not have permission to create modal dialogs with the given modalityType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Window owner,
       String title)
        Creates a modeless dialog with the specified title and owner Window.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the Window from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar or null if the dialog has no title
        抛出：
        IllegalArgumentException - if the owner is not an instance of Dialog or Frame
        IllegalArgumentException - if the owner's GraphicsConfiguration is not from a screen device
        HeadlessException - when GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.6
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Window owner,
       String title,
       Dialog.ModalityType modalityType)
        Creates a dialog with the specified title, owner Window and modality.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the Window from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar or null if the dialog has no title
        modalityType - specifies whether dialog blocks input to other windows when shown. null value and unsupported modality types are equivalent to MODELESS
        抛出：
        IllegalArgumentException - if the owner is not an instance of Dialog or Frame
        IllegalArgumentException - if the owner's GraphicsConfiguration is not from a screen device
        HeadlessException - when GraphicsEnvironment.isHeadless() returns true
        SecurityException - if the calling thread does not have permission to create modal dialogs with the given modalityType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()

      • JDialog

        public JDialog(Window owner,
       String title,
       Dialog.ModalityType modalityType,
       GraphicsConfiguration gc)
        Creates a dialog with the specified title, owner Window, modality and GraphicsConfiguration.

        NOTE: Any popup components (JComboBox, JPopupMenu, JMenuBar) created within a modal dialog will be forced to be lightweight.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the Window from which the dialog is displayed or null if this dialog has no owner
        title - the String to display in the dialog's title bar or null if the dialog has no title
        modalityType - specifies whether dialog blocks input to other windows when shown. null value and unsupported modality types are equivalent to MODELESS
        gc - the GraphicsConfiguration of the target screen device; if null, the default system GraphicsConfiguration is assumed
        抛出：
        IllegalArgumentException - if the owner is not an instance of Dialog or Frame
        IllegalArgumentException - if the owner's GraphicsConfiguration is not from a screen device
        HeadlessException - when GraphicsEnvironment.isHeadless() returns true
        SecurityException - if the calling thread does not have permission to create modal dialogs with the given modalityType
        从以下版本开始：
        1.6
        另请参见：
        Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()

    • 方法详细信息

      • dialogInit

        protected void dialogInit()
        Called by the constructors to init the JDialog properly.

      • createRootPane

        protected JRootPane createRootPane()
        Called by the constructor methods to create the default rootPane.

      • processWindowEvent

        protected void processWindowEvent(WindowEvent e)
        Handles window events depending on the state of the defaultCloseOperation property.
        重载：
        processWindowEvent in class Window
        参数：
        e - the window event
        另请参见：
        setDefaultCloseOperation(int)

      • setDefaultCloseOperation

        public void setDefaultCloseOperation(int operation)
        Sets the operation that will happen by default when the user initiates a "close" on this dialog. You must specify one of the following choices:

        • DO_NOTHING_ON_CLOSE (defined in WindowConstants): Don't do anything; require the program to handle the operation in the windowClosing method of a registered WindowListener object.
        • HIDE_ON_CLOSE (defined in WindowConstants): Automatically hide the dialog after invoking any registered WindowListener objects.
        • DISPOSE_ON_CLOSE (defined in WindowConstants): Automatically hide and dispose the dialog after invoking any registered WindowListener objects.

        The value is set to HIDE_ON_CLOSE by default. Changes to the value of this property cause the firing of a property change event, with property name "defaultCloseOperation".

        Note: When the last displayable window within the Java virtual machine (VM) is disposed of, the VM may terminate. See AWT Threading Issues for more information.

        参数：
        operation - the operation which should be performed when the user closes the dialog
        抛出：
        IllegalArgumentException - if defaultCloseOperation value isn't one of the above valid values
        另请参见：
        Window.addWindowListener(java.awt.event.WindowListener), getDefaultCloseOperation(), WindowConstants

      • getDefaultCloseOperation

        public int getDefaultCloseOperation()
        Returns the operation which occurs when the user initiates a "close" on this dialog.
        返回：
        an integer indicating the window-close operation
        另请参见：
        setDefaultCloseOperation(int)

      • setTransferHandler

        public void setTransferHandler(TransferHandler newHandler)
        Sets the transferHandler property, which is a mechanism to support transfer of data into this component. Use null if the component does not support data transfer operations.

        If the system property suppressSwingDropSupport is false (the default) and the current drop target on this component is either null or not a user-set drop target, this method will change the drop target as follows: If newHandler is null it will clear the drop target. If not null it will install a new DropTarget.

        Note: When used with JDialog, TransferHandler only provides data import capability, as the data export related methods are currently typed to JComponent.

        Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

        参数：
        newHandler - the new TransferHandler
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

      • getTransferHandler

        public TransferHandler getTransferHandler()
        Gets the transferHandler property.
        返回：
        the value of the transferHandler property
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, setTransferHandler(javax.swing.TransferHandler)

      • update

        public void update(Graphics g)
        Calls paint(g). This method was overridden to prevent an unnecessary call to clear the background.
        重载：
        update in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        Component.update(Graphics)

      • setJMenuBar

        public void setJMenuBar(JMenuBar menu)
        Sets the menubar for this dialog.
        参数：
        menu - the menubar being placed in the dialog
        另请参见：
        getJMenuBar()

      • getJMenuBar

        public JMenuBar getJMenuBar()
        Returns the menubar set on this dialog.
        另请参见：
        setJMenuBar(javax.swing.JMenuBar)

      • isRootPaneCheckingEnabled

        protected boolean isRootPaneCheckingEnabled()
        Returns whether calls to add and setLayout are forwarded to the contentPane.
        返回：
        true if add and setLayout are fowarded; false otherwise
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • setRootPaneCheckingEnabled

        protected void setRootPaneCheckingEnabled(boolean enabled)
        Sets whether calls to add and setLayout are forwarded to the contentPane.
        参数：
        enabled - true if add and setLayout are forwarded, false if they should operate directly on the JDialog.
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified child Component. This method is overridden to conditionally forward calls to the contentPane. By default, children are added to the contentPane instead of the frame, refer to RootPaneContainer for details.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • remove

        public void remove(Component comp)
        Removes the specified component from the container. If comp is not the rootPane, this will forward the call to the contentPane. This will do nothing if comp is not a child of the JDialog or contentPane.
        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        抛出：
        NullPointerException - if comp is null
        另请参见：
        Container.add(java.awt.Component), RootPaneContainer

      • setLayout

        public void setLayout(LayoutManager manager)
        Sets the LayoutManager. Overridden to conditionally forward the call to the contentPane. Refer to RootPaneContainer for more information.
        重载：
        setLayout in class Container
        参数：
        manager - the LayoutManager
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • getRootPane

        public JRootPane getRootPane()
        Returns the rootPane object for this dialog.
        指定者：
        getRootPane in interface RootPaneContainer
        返回：
        this components single JRootPane child.
        另请参见：
        setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

      • setRootPane

        protected void setRootPane(JRootPane root)
        Sets the rootPane property. This method is called by the constructor.
        参数：
        root - the rootPane object for this dialog
        另请参见：
        getRootPane()

      • getContentPane

        public Container getContentPane()
        Returns the contentPane object for this dialog.
        指定者：
        getContentPane in interface RootPaneContainer
        返回：
        the contentPane property
        另请参见：
        setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

      • setContentPane

        public void setContentPane(Container contentPane)
        Sets the contentPane property. This method is called by the constructor.

        Swing's painting architecture requires an opaque JComponent in the containment hiearchy. This is typically provided by the content pane. If you replace the content pane it is recommended you replace it with an opaque JComponent.

        指定者：
        setContentPane in interface RootPaneContainer
        参数：
        contentPane - the contentPane object for this dialog
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        JRootPane, getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Returns the layeredPane object for this dialog.
        指定者：
        getLayeredPane in interface RootPaneContainer
        返回：
        the layeredPane property
        另请参见：
        setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layeredPane)
        Sets the layeredPane property. This method is called by the constructor.
        指定者：
        setLayeredPane in interface RootPaneContainer
        参数：
        layeredPane - the new layeredPane property
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null
        另请参见：
        getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

      • getGlassPane

        public Component getGlassPane()
        Returns the glassPane object for this dialog.
        指定者：
        getGlassPane in interface RootPaneContainer
        返回：
        the glassPane property
        另请参见：
        setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

      • setGlassPane

        public void setGlassPane(Component glassPane)
        Sets the glassPane property. This method is called by the constructor.
        指定者：
        setGlassPane in interface RootPaneContainer
        参数：
        glassPane - the glassPane object for this dialog
        另请参见：
        getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

      • getGraphics

        public Graphics getGraphics()
        Creates a graphics context for this component. This method will return null if this component is currently not displayable.
        重载：
        getGraphics in class Component
        返回：
        a graphics context for this component, or null if it has none
        从以下版本开始：
        1.6
        另请参见：
        Component.paint(java.awt.Graphics)

      • repaint

        public void repaint(long time,
           int x,
           int y,
           int width,
           int height)
        Repaints the specified rectangle of this component within time milliseconds. Refer to RepaintManager for details on how the repaint is handled.
        重载：
        repaint in class Component
        参数：
        time - maximum time in milliseconds before update
        x - the x coordinate
        y - the y coordinate
        width - the width
        height - the height
        从以下版本开始：
        1.6
        另请参见：
        RepaintManager

      • setDefaultLookAndFeelDecorated

        public static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
        Provides a hint as to whether or not newly created JDialogs should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel. If defaultLookAndFeelDecorated is true, the current LookAndFeel supports providing window decorations, and the current window manager supports undecorated windows, then newly created JDialogs will have their Window decorations provided by the current LookAndFeel. Otherwise, newly created JDialogs will have their Window decorations provided by the current window manager.

        You can get the same effect on a single JDialog by doing the following:

            JDialog dialog = new JDialog();
    dialog.setUndecorated(true);
    dialog.getRootPane().setWindowDecorationStyle(JRootPane.PLAIN_DIALOG);
        参数：
        defaultLookAndFeelDecorated - A hint as to whether or not current look and feel should provide window decorations
        从以下版本开始：
        1.4
        另请参见：
        LookAndFeel.getSupportsWindowDecorations()

      • isDefaultLookAndFeelDecorated

        public static boolean isDefaultLookAndFeelDecorated()
        Returns true if newly created JDialogs should have their Window decorations provided by the current look and feel. This is only a hint, as certain look and feels may not support this feature.
        返回：
        true if look and feel should provide Window decorations.
        从以下版本开始：
        1.4

      • paramString

        protected String paramString()
        Returns a string representation of this JDialog. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class Dialog
        返回：
        a string representation of this JDialog.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JDialog. For JDialogs, the AccessibleContext takes the form of an AccessibleJDialog. A new AccessibleJDialog instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class Dialog
        返回：
        an AccessibleJDialog that serves as the AccessibleContext of this JDialog
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v


JDialog.AccessibleJDialog

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JDialog.AccessibleJDialog

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    JDialog

    protected class JDialog.AccessibleJDialog
extends Dialog.AccessibleAWTDialog
    This class implements accessibility support for the JDialog class. It provides an implementation of the Java Accessibility API appropriate to dialog user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JDialog.AccessibleJDialog()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAccessibleName()
      Get the accessible name of this object.
      AccessibleStateSet getAccessibleStateSet()
      Get the state of this object.

      • 方法 - 继承于类 java.awt.Dialog.AccessibleAWTDialog

        getAccessibleRole

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JDialog.AccessibleJDialog

        protected JDialog.AccessibleJDialog()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Get the accessible name of this object.
        重载：
        getAccessibleName in class Component.AccessibleAWTComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state of this object.
        重载：
        getAccessibleStateSet in class Dialog.AccessibleAWTDialog
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Ladtlnmlnettneeos..renLxtaag.voe>n,iLLt aie.e


JEditorPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JEditorPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JEditorPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
    直接已知子类：
    JTextPane

    public class JEditorPane
extends JTextComponent
    A text component to edit various kinds of content. You can find how-to information and examples of using editor panes in Using Text Components, a section in The Java Tutorial.

    This component uses implementations of the EditorKit to accomplish its behavior. It effectively morphs into the proper kind of text editor for the kind of content it is given. The content type that editor is bound to at any given time is determined by the EditorKit currently installed. If the content is set to a new URL, its type is used to determine the EditorKit that should be used to load the content.

    By default, the following types of content are known:

    text/plain
    Plain text, which is the default the type given isn't recognized. The kit used in this case is an extension of DefaultEditorKit that produces a wrapped plain text view.
    text/html
    HTML text. The kit used in this case is the class javax.swing.text.html.HTMLEditorKit which provides HTML 3.2 support.
    text/rtf
    RTF text. The kit used in this case is the class javax.swing.text.rtf.RTFEditorKit which provides a limited support of the Rich Text Format.

    There are several ways to load content into this component.

    1. The setText method can be used to initialize the component from a string. In this case the current EditorKit will be used, and the content type will be expected to be of this type.
    2. The read method can be used to initialize the component from a Reader. Note that if the content type is HTML, relative references (e.g. for things like images) can't be resolved unless the <base> tag is used or the Base property on HTMLDocument is set. In this case the current EditorKit will be used, and the content type will be expected to be of this type.
    3. The setPage method can be used to initialize the component from a URL. In this case, the content type will be determined from the URL, and the registered EditorKit for that content type will be set.

    Some kinds of content may provide hyperlink support by generating hyperlink events. The HTML EditorKit will generate hyperlink events if the JEditorPane is not editable (JEditorPane.setEditable(false); has been called). If HTML frames are embedded in the document, the typical response would be to change a portion of the current document. The following code fragment is a possible hyperlink listener implementation, that treats HTML frame events specially, and simply displays any other activated hyperlinks.

     class Hyperactive implements HyperlinkListener {

         public void hyperlinkUpdate(HyperlinkEvent e) {
             if (e.getEventType() == HyperlinkEvent.EventType.ACTIVATED) {
                 JEditorPane pane = (JEditorPane) e.getSource();
                 if (e instanceof HTMLFrameHyperlinkEvent) {
                     HTMLFrameHyperlinkEvent  evt = (HTMLFrameHyperlinkEvent)e;
                     HTMLDocument doc = (HTMLDocument)pane.getDocument();
                     doc.processHTMLFrameHyperlinkEvent(evt);
                 } else {
                     try {
                         pane.setPage(e.getURL());
                     } catch (Throwable t) {
                         t.printStackTrace();
                     }
                 }
             }
         }
     }

    For information on customizing how text/html is rendered please see W3C_LENGTH_UNITS and HONOR_DISPLAY_PROPERTIES

    Culturally dependent information in some documents is handled through a mechanism called character encoding. Character encoding is an unambiguous mapping of the members of a character set (letters, ideographs, digits, symbols, or control functions) to specific numeric code values. It represents the way the file is stored. Example character encodings are ISO-8859-1, ISO-8859-5, Shift-jis, Euc-jp, and UTF-8. When the file is passed to an user agent (JEditorPane) it is converted to the document character set (ISO-10646 aka Unicode).

    There are multiple ways to get a character set mapping to happen with JEditorPane.

    1. One way is to specify the character set as a parameter of the MIME type. This will be established by a call to the setContentType method. If the content is loaded by the setPage method the content type will have been set according to the specification of the URL. It the file is loaded directly, the content type would be expected to have been set prior to loading.
    2. Another way the character set can be specified is in the document itself. This requires reading the document prior to determining the character set that is desired. To handle this, it is expected that the EditorKit.read operation throw a ChangedCharSetException which will be caught. The read is then restarted with a new Reader that uses the character set specified in the ChangedCharSetException (which is an IOException).

    Newlines
    For a discussion on how newlines are handled, see DefaultEditorKit.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JEditorPane.AccessibleJEditorPane
      This class implements accessibility support for the JEditorPane class.
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String HONOR_DISPLAY_PROPERTIES
      Key for a client property used to indicate whether the default font and foreground color from the component are used if a font or foreground color is not specified in the styled text.
      static String W3C_LENGTH_UNITS
      Key for a client property used to indicate whether w3c compliant length units are used for html rendering.

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JEditorPane()
      Creates a new JEditorPane.
      JEditorPane(String url)
      Creates a JEditorPane based on a string containing a URL specification.
      JEditorPane(String type, String text)
      Creates a JEditorPane that has been initialized to the given text.
      JEditorPane(URL initialPage)
      Creates a JEditorPane based on a specified URL for input.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addHyperlinkListener(HyperlinkListener listener)
      Adds a hyperlink listener for notification of any changes, for example when a link is selected and entered.
      protected EditorKit createDefaultEditorKit()
      Creates the default editor kit (PlainEditorKit) for when the component is first created.
      static EditorKit createEditorKitForContentType(String type)
      Creates a handler for the given type from the default registry of editor kits.
      void fireHyperlinkUpdate(HyperlinkEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JEditorPane.
      String getContentType()
      Gets the type of content that this editor is currently set to deal with.
      EditorKit getEditorKit()
      Fetches the currently installed kit for handling content.
      static String getEditorKitClassNameForContentType(String type)
      Returns the currently registered EditorKit class name for the type type.
      EditorKit getEditorKitForContentType(String type)
      Fetches the editor kit to use for the given type of content.
      HyperlinkListener[] getHyperlinkListeners()
      Returns an array of all the HyperLinkListeners added to this JEditorPane with addHyperlinkListener().
      URL getPage()
      Gets the current URL being displayed.
      Dimension getPreferredSize()
      Returns the preferred size for the JEditorPane.
      boolean getScrollableTracksViewportHeight()
      Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.
      boolean getScrollableTracksViewportWidth()
      Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.
      protected InputStream getStream(URL page)
      Fetches a stream for the given URL, which is about to be loaded by the setPage method.
      String getText()
      Returns the text contained in this TextComponent in terms of the content type of this editor.
      String getUIClassID()
      Gets the class ID for the UI.
      protected String paramString()
      Returns a string representation of this JEditorPane.
      void read(InputStream in, Object desc)
      This method initializes from a stream.
      static void registerEditorKitForContentType(String type, String classname)
      Establishes the default bindings of type to classname.
      static void registerEditorKitForContentType(String type, String classname, ClassLoader loader)
      Establishes the default bindings of type to classname.
      void removeHyperlinkListener(HyperlinkListener listener)
      Removes a hyperlink listener.
      void replaceSelection(String content)
      Replaces the currently selected content with new content represented by the given string.
      void scrollToReference(String reference)
      Scrolls the view to the given reference location (that is, the value returned by the UL.getRef method for the URL being displayed).
      void setContentType(String type)
      Sets the type of content that this editor handles.
      void setEditorKit(EditorKit kit)
      Sets the currently installed kit for handling content.
      void setEditorKitForContentType(String type, EditorKit k)
      Directly sets the editor kit to use for the given type.
      void setPage(String url)
      Sets the current URL being displayed.
      void setPage(URL page)
      Sets the current URL being displayed.
      void setText(String t)
      Sets the text of this TextComponent to the specified content, which is expected to be in the format of the content type of this editor.

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDocument, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • W3C_LENGTH_UNITS

        public static final String W3C_LENGTH_UNITS
        Key for a client property used to indicate whether w3c compliant length units are used for html rendering.

        By default this is not enabled; to enable it set the client property with this name to Boolean.TRUE.

        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

      • HONOR_DISPLAY_PROPERTIES

        public static final String HONOR_DISPLAY_PROPERTIES
        Key for a client property used to indicate whether the default font and foreground color from the component are used if a font or foreground color is not specified in the styled text.

        The default varies based on the look and feel; to enable it set the client property with this name to Boolean.TRUE.

        从以下版本开始：
        1.5
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JEditorPane

        public JEditorPane()
        Creates a new JEditorPane. The document model is set to null.

      • JEditorPane

        public JEditorPane(URL initialPage)
            throws IOException
        Creates a JEditorPane based on a specified URL for input.
        参数：
        initialPage - the URL
        抛出：
        IOException - if the URL is null or cannot be accessed

      • JEditorPane

        public JEditorPane(String url)
            throws IOException
        Creates a JEditorPane based on a string containing a URL specification.
        参数：
        url - the URL
        抛出：
        IOException - if the URL is null or cannot be accessed

      • JEditorPane

        public JEditorPane(String type,
           String text)
        Creates a JEditorPane that has been initialized to the given text. This is a convenience constructor that calls the setContentType and setText methods.
        参数：
        type - mime type of the given text
        text - the text to initialize with; may be null
        抛出：
        NullPointerException - if the type parameter is null

    • 方法详细信息

      • addHyperlinkListener

        public void addHyperlinkListener(HyperlinkListener listener)
        Adds a hyperlink listener for notification of any changes, for example when a link is selected and entered.
        参数：
        listener - the listener

      • removeHyperlinkListener

        public void removeHyperlinkListener(HyperlinkListener listener)
        Removes a hyperlink listener.
        参数：
        listener - the listener

      • getHyperlinkListeners

        public HyperlinkListener[] getHyperlinkListeners()
        Returns an array of all the HyperLinkListeners added to this JEditorPane with addHyperlinkListener().
        返回：
        all of the HyperLinkListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireHyperlinkUpdate

        public void fireHyperlinkUpdate(HyperlinkEvent e)
        Notifies all listeners that have registered interest for notification on this event type. This is normally called by the currently installed EditorKit if a content type that supports hyperlinks is currently active and there was activity with a link. The listener list is processed last to first.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • setPage

        public void setPage(URL page)
             throws IOException
        Sets the current URL being displayed. The content type of the pane is set, and if the editor kit for the pane is non-null, then a new default document is created and the URL is read into it. If the URL contains and reference location, the location will be scrolled to by calling the scrollToReference method. If the desired URL is the one currently being displayed, the document will not be reloaded. To force a document reload it is necessary to clear the stream description property of the document. The following code shows how this can be done:
           Document doc = jEditorPane.getDocument();
   doc.putProperty(Document.StreamDescriptionProperty, null);
        If the desired URL is not the one currently being displayed, the getStream method is called to give subclasses control over the stream provided.

        This may load either synchronously or asynchronously depending upon the document returned by the EditorKit. If the Document is of type AbstractDocument and has a value returned by AbstractDocument.getAsynchronousLoadPriority that is greater than or equal to zero, the page will be loaded on a separate thread using that priority.

        If the document is loaded synchronously, it will be filled in with the stream prior to being installed into the editor with a call to setDocument, which is bound and will fire a property change event. If an IOException is thrown the partially loaded document will be discarded and neither the document or page property change events will be fired. If the document is successfully loaded and installed, a view will be built for it by the UI which will then be scrolled if necessary, and then the page property change event will be fired.

        If the document is loaded asynchronously, the document will be installed into the editor immediately using a call to setDocument which will fire a document property change event, then a thread will be created which will begin doing the actual loading. In this case, the page property change event will not be fired by the call to this method directly, but rather will be fired when the thread doing the loading has finished. It will also be fired on the event-dispatch thread. Since the calling thread can not throw an IOException in the event of failure on the other thread, the page property change event will be fired when the other thread is done whether the load was successful or not.

        参数：
        page - the URL of the page
        抛出：
        IOException - for a null or invalid page specification, or exception from the stream being read
        另请参见：
        getPage()

      • read

        public void read(InputStream in,
        Object desc)
          throws IOException
        This method initializes from a stream. If the kit is set to be of type HTMLEditorKit, and the desc parameter is an HTMLDocument, then it invokes the HTMLEditorKit to initiate the read. Otherwise it calls the superclass method which loads the model as plain text.
        参数：
        in - the stream from which to read
        desc - an object describing the stream
        抛出：
        IOException - as thrown by the stream being used to initialize
        另请参见：
        JTextComponent.read(java.io.Reader, java.lang.Object), JTextComponent.setDocument(javax.swing.text.Document)

      • getStream

        protected InputStream getStream(URL page)
                         throws IOException
        Fetches a stream for the given URL, which is about to be loaded by the setPage method. By default, this simply opens the URL and returns the stream. This can be reimplemented to do useful things like fetch the stream from a cache, monitor the progress of the stream, etc.

        This method is expected to have the the side effect of establishing the content type, and therefore setting the appropriate EditorKit to use for loading the stream.

        If this the stream was an http connection, redirects will be followed and the resulting URL will be set as the Document.StreamDescriptionProperty so that relative URL's can be properly resolved.

        参数：
        page - the URL of the page
        抛出：
        IOException

      • scrollToReference

        public void scrollToReference(String reference)
        Scrolls the view to the given reference location (that is, the value returned by the UL.getRef method for the URL being displayed). By default, this method only knows how to locate a reference in an HTMLDocument. The implementation calls the scrollRectToVisible method to accomplish the actual scrolling. If scrolling to a reference location is needed for document types other than HTML, this method should be reimplemented. This method will have no effect if the component is not visible.
        参数：
        reference - the named location to scroll to

      • getPage

        public URL getPage()
        Gets the current URL being displayed. If a URL was not specified in the creation of the document, this will return null, and relative URL's will not be resolved.
        返回：
        the URL, or null if none

      • setPage

        public void setPage(String url)
             throws IOException
        Sets the current URL being displayed.
        参数：
        url - the URL for display
        抛出：
        IOException - for a null or invalid URL specification

      • getUIClassID

        public String getUIClassID()
        Gets the class ID for the UI.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "EditorPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createDefaultEditorKit

        protected EditorKit createDefaultEditorKit()
        Creates the default editor kit (PlainEditorKit) for when the component is first created.
        返回：
        the editor kit

      • getEditorKit

        public EditorKit getEditorKit()
        Fetches the currently installed kit for handling content. createDefaultEditorKit is called to set up a default if necessary.
        返回：
        the editor kit

      • getContentType

        public final String getContentType()
        Gets the type of content that this editor is currently set to deal with. This is defined to be the type associated with the currently installed EditorKit.
        返回：
        the content type, null if no editor kit set

      • setContentType

        public final void setContentType(String type)
        Sets the type of content that this editor handles. This calls getEditorKitForContentType, and then setEditorKit if an editor kit can be successfully located. This is mostly convenience method that can be used as an alternative to calling setEditorKit directly.

        If there is a charset definition specified as a parameter of the content type specification, it will be used when loading input streams using the associated EditorKit. For example if the type is specified as text/html; charset=EUC-JP the content will be loaded using the EditorKit registered for text/html and the Reader provided to the EditorKit to load unicode into the document will use the EUC-JP charset for translating to unicode. If the type is not recognized, the content will be loaded using the EditorKit registered for plain text, text/plain.

        参数：
        type - the non-null mime type for the content editing support
        抛出：
        NullPointerException - if the type parameter is null
        另请参见：
        getContentType()

      • setEditorKit

        public void setEditorKit(EditorKit kit)
        Sets the currently installed kit for handling content. This is the bound property that establishes the content type of the editor. Any old kit is first deinstalled, then if kit is non-null, the new kit is installed, and a default document created for it. A PropertyChange event ("editorKit") is always fired when setEditorKit is called.

        NOTE: This has the side effect of changing the model, because the EditorKit is the source of how a particular type of content is modeled. This method will cause setDocument to be called on behalf of the caller to ensure integrity of the internal state.

        参数：
        kit - the desired editor behavior
        另请参见：
        getEditorKit()

      • getEditorKitForContentType

        public EditorKit getEditorKitForContentType(String type)
        Fetches the editor kit to use for the given type of content. This is called when a type is requested that doesn't match the currently installed type. If the component doesn't have an EditorKit registered for the given type, it will try to create an EditorKit from the default EditorKit registry. If that fails, a PlainEditorKit is used on the assumption that all text documents can be represented as plain text.

        This method can be reimplemented to use some other kind of type registry. This can be reimplemented to use the Java Activation Framework, for example.

        参数：
        type - the non-null content type
        返回：
        the editor kit

      • setEditorKitForContentType

        public void setEditorKitForContentType(String type,
                              EditorKit k)
        Directly sets the editor kit to use for the given type. A look-and-feel implementation might use this in conjunction with createEditorKitForContentType to install handlers for content types with a look-and-feel bias.
        参数：
        type - the non-null content type
        k - the editor kit to be set

      • replaceSelection

        public void replaceSelection(String content)
        Replaces the currently selected content with new content represented by the given string. If there is no selection this amounts to an insert of the given text. If there is no replacement text (i.e. the content string is empty or null) this amounts to a removal of the current selection. The replacement text will have the attributes currently defined for input. If the component is not editable, beep and return.
        重载：
        replaceSelection in class JTextComponent
        参数：
        content - the content to replace the selection with. This value can be null

      • createEditorKitForContentType

        public static EditorKit createEditorKitForContentType(String type)
        Creates a handler for the given type from the default registry of editor kits. The registry is created if necessary. If the registered class has not yet been loaded, an attempt is made to dynamically load the prototype of the kit for the given type. If the type was registered with a ClassLoader, that ClassLoader will be used to load the prototype. If there was no registered ClassLoader, Class.forName will be used to load the prototype.

        Once a prototype EditorKit instance is successfully located, it is cloned and the clone is returned.

        参数：
        type - the content type
        返回：
        the editor kit, or null if there is nothing registered for the given type

      • registerEditorKitForContentType

        public static void registerEditorKitForContentType(String type,
                                   String classname)
        Establishes the default bindings of type to classname. The class will be dynamically loaded later when actually needed, and can be safely changed before attempted uses to avoid loading unwanted classes. The prototype EditorKit will be loaded with Class.forName when registered with this method.
        参数：
        type - the non-null content type
        classname - the class to load later

      • registerEditorKitForContentType

        public static void registerEditorKitForContentType(String type,
                                   String classname,
                                   ClassLoader loader)
        Establishes the default bindings of type to classname. The class will be dynamically loaded later when actually needed using the given ClassLoader, and can be safely changed before attempted uses to avoid loading unwanted classes.
        参数：
        type - the non-null content type
        classname - the class to load later
        loader - the ClassLoader to use to load the name

      • getEditorKitClassNameForContentType

        public static String getEditorKitClassNameForContentType(String type)
        Returns the currently registered EditorKit class name for the type type.
        参数：
        type - the non-null content type
        从以下版本开始：
        1.3

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size for the JEditorPane. The preferred size for JEditorPane is slightly altered from the preferred size of the superclass. If the size of the viewport has become smaller than the minimum size of the component, the scrollable definition for tracking width or height will turn to false. The default viewport layout will give the preferred size, and that is not desired in the case where the scrollable is tracking. In that case the normal preferred size is adjusted to the minimum size. This allows things like HTML tables to shrink down to their minimum size and then be laid out at their minimum size, refusing to shrink any further.
        重载：
        getPreferredSize in class JComponent
        返回：
        a Dimension containing the preferred size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • setText

        public void setText(String t)
        Sets the text of this TextComponent to the specified content, which is expected to be in the format of the content type of this editor. For example, if the type is set to text/html the string should be specified in terms of HTML.

        This is implemented to remove the contents of the current document, and replace them by parsing the given string using the current EditorKit. This gives the semantics of the superclass by not changing out the model, while supporting the content type currently set on this component. The assumption is that the previous content is relatively small, and that the previous content doesn't have side effects. Both of those assumptions can be violated and cause undesirable results. To avoid this, create a new document, getEditorKit().createDefaultDocument(), and replace the existing Document with the new one. You are then assured the previous Document won't have any lingering state.

        1. Leaving the existing model in place means that the old view will be torn down, and a new view created, where replacing the document would avoid the tear down of the old view.
        2. Some formats (such as HTML) can install things into the document that can influence future contents. HTML can have style information embedded that would influence the next content installed unexpectedly.

        An alternative way to load this component with a string would be to create a StringReader and call the read method. In this case the model would be replaced after it was initialized with the contents of the string.

        重载：
        setText in class JTextComponent
        参数：
        t - the new text to be set; if null the old text will be deleted
        另请参见：
        getText()

      • getText

        public String getText()
        Returns the text contained in this TextComponent in terms of the content type of this editor. If an exception is thrown while attempting to retrieve the text, null will be returned. This is implemented to call JTextComponent.write with a StringWriter.
        重载：
        getText in class JTextComponent
        返回：
        the text
        另请参见：
        setText(java.lang.String)

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.
        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        重载：
        getScrollableTracksViewportWidth in class JTextComponent
        返回：
        true if a viewport should force the Scrollables width to match its own, false otherwise

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.
        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        重载：
        getScrollableTracksViewportHeight in class JTextComponent
        返回：
        true if a viewport should force the Scrollable's height to match its own, false otherwise

      • paramString

        protected String paramString()
        Returns a string representation of this JEditorPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JTextComponent
        返回：
        a string representation of this JEditorPane

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JEditorPane. For editor panes, the AccessibleContext takes the form of an AccessibleJEditorPane. A new AccessibleJEditorPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JTextComponent
        返回：
        an AccessibleJEditorPane that serves as the AccessibleContext of this JEditorPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JEditorPane.AccessibleJEditorPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JEditorPane.AccessibleJEditorPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JEditorPane.AccessibleJEditorPane
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    直接已知子类：
    JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport
    封闭类：
    JEditorPane

    protected class JEditorPane.AccessibleJEditorPane
extends JTextComponent.AccessibleJTextComponent
    This class implements accessibility support for the JEditorPane class. It provides an implementation of the Java Accessibility API appropriate to editor pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JEditorPane.AccessibleJEditorPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAccessibleDescription()
      Gets the accessibleDescription property of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JEditorPane.AccessibleJEditorPane

        protected JEditorPane.AccessibleJEditorPane()

    • 方法详细信息

      • getAccessibleDescription

        public String getAccessibleDescription()
        Gets the accessibleDescription property of this object. If this property isn't set, returns the content type of this JEditorPane instead (e.g. "plain/text", "html/text").
        重载：
        getAccessibleDescription in class JComponent.AccessibleJComponent
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        重载：
        getAccessibleStateSet in class JTextComponent.AccessibleJTextComponent
        返回：
        an instance of AccessibleStateSet describing the states of the object
        另请参见：
        AccessibleStateSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a.,luu>a/ehr< .aa< .e/wjt/..=n.a.nat


JEditorPane.AccessibleJEditorPaneHTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JEditorPane.AccessibleJEditorPaneHTML

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    封闭类：
    JEditorPane

    protected class JEditorPane.AccessibleJEditorPaneHTML
extends JEditorPane.AccessibleJEditorPane
    This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JEditorPane.AccessibleJEditorPaneHTML()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleText getAccessibleText()
      Get the AccessibleText associated with this object.

      • 方法 - 继承于类 javax.swing.JEditorPane.AccessibleJEditorPane

        getAccessibleDescription, getAccessibleStateSet

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JEditorPane.AccessibleJEditorPaneHTML

        protected JEditorPane.AccessibleJEditorPaneHTML()

    • 方法详细信息

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Description copied from class: JTextComponent.AccessibleJTextComponent
        Get the AccessibleText associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleText interface on behalf of itself.
        重载：
        getAccessibleText in class JTextComponent.AccessibleJTextComponent
        返回：
        this object
        另请参见：
        AccessibleText

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children of the object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        getAccessibleChildrenCount()

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - The point relative to the coordinate system of this object.
        返回：
        the Accessible, if it exists, at the specified location; otherwise null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m.dn.rneot=oioch


JEditorPane.JEditorPaneAccessibleHypertextSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JEditorPane.JEditorPaneAccessibleHypertextSupport

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleHypertext, AccessibleText, CaretListener, DocumentListener
    封闭类：
    JEditorPane

    protected class JEditorPane.JEditorPaneAccessibleHypertextSupport
extends JEditorPane.AccessibleJEditorPane
implements AccessibleHypertext
    What's returned by AccessibleJEditorPaneHTML.getAccessibleText. Provides support for AccessibleHypertext in case there is an HTML document being displayed in this JEditorPane.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      class  | JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      构造方法与描述
      JEditorPane.JEditorPaneAccessibleHypertextSupport()
      Make one of these puppies

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleHyperlink getLink(int linkIndex)
      Returns the index into an array of hyperlinks that index.
      int getLinkCount()
      Returns the number of links within this hypertext doc.
      int getLinkIndex(int charIndex)
      Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.
      String getLinkText(int linkIndex)
      Returns the contiguous text within the document that is associated with this hyperlink.

      • 方法 - 继承于类 javax.swing.JEditorPane.AccessibleJEditorPane

        getAccessibleDescription, getAccessibleStateSet

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleText

        getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JEditorPane.JEditorPaneAccessibleHypertextSupport

        public JEditorPane.JEditorPaneAccessibleHypertextSupport()
        Make one of these puppies

    • 方法详细信息

      • getLinkCount

        public int getLinkCount()
        Returns the number of links within this hypertext doc.
        指定者：
        getLinkCount in interface AccessibleHypertext
        返回：
        number of links in this hypertext doc.

      • getLinkIndex

        public int getLinkIndex(int charIndex)
        Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.
        指定者：
        getLinkIndex in interface AccessibleHypertext
        参数：
        charIndex - index within the text
        返回：
        index into the set of hyperlinks for this hypertext doc.

      • getLink

        public AccessibleHyperlink getLink(int linkIndex)
        Returns the index into an array of hyperlinks that index. If there is no hyperlink at this index, it returns null.
        指定者：
        getLink in interface AccessibleHypertext
        参数：
        linkIndex - into the set of hyperlinks for this hypertext doc.
        返回：
        string representation of the hyperlink

      • getLinkText

        public String getLinkText(int linkIndex)
        Returns the contiguous text within the document that is associated with this hyperlink.
        参数：
        linkIndex - into the set of hyperlinks for this hypertext doc.
        返回：
        the contiguous text sharing the link at this index
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etttnnoenoCmmoCCJn..opmehCn.erCCrre(teemg/oj/n.C


JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

  • java.lang.Object
    • javax.accessibility.AccessibleHyperlink
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
  • 所有已实现的接口：
    AccessibleAction
    封闭类：
    JEditorPane.JEditorPaneAccessibleHypertextSupport

    public class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
extends AccessibleHyperlink

    • 字段摘要

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

    • 构造方法摘要

      Constructors
      构造方法与描述
      JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean doAccessibleAction(int i)
      Perform the specified Action on the object
      Object getAccessibleActionAnchor(int i)
      Return an object that represents the link anchor, as appropriate for that link.
      int getAccessibleActionCount()
      Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g.
      String getAccessibleActionDescription(int i)
      Return a String description of this particular link action.
      Object getAccessibleActionObject(int i)
      Returns a URL object that represents the link.
      int getEndIndex()
      Get the index with the hypertext document at which this link ends
      int getStartIndex()
      Get the index with the hypertext document at which this link begins
      boolean isValid()
      Since the document a link is associated with may have changed, this method returns whether this Link is valid anymore (with respect to the document it references).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

        public JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)

    • 方法详细信息

      • isValid

        public boolean isValid()
        Since the document a link is associated with may have changed, this method returns whether this Link is valid anymore (with respect to the document it references).
        指定者：
        isValid in class AccessibleHyperlink
        返回：
        a flag indicating whether this link is still valid with respect to the AccessibleHypertext it belongs to

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g. in an HTML imagemap). In general, links will have only one AccessibleAction in them.
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        指定者：
        getAccessibleActionCount in class AccessibleHyperlink
        返回：
        the zero-based number of Actions in this object

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Perform the specified Action on the object
        指定者：
        doAccessibleAction in interface AccessibleAction
        指定者：
        doAccessibleAction in class AccessibleHyperlink
        参数：
        i - zero-based index of actions
        返回：
        true if the the action was performed; else false.
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Return a String description of this particular link action. The string returned is the text within the document associated with the element which contains this link.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        指定者：
        getAccessibleActionDescription in class AccessibleHyperlink
        参数：
        i - zero-based index of the actions
        返回：
        a String description of the action
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionObject

        public Object getAccessibleActionObject(int i)
        Returns a URL object that represents the link.
        指定者：
        getAccessibleActionObject in class AccessibleHyperlink
        参数：
        i - zero-based index of the actions
        返回：
        an URL representing the HTML link itself
        另请参见：
        getAccessibleActionCount()

      • getAccessibleActionAnchor

        public Object getAccessibleActionAnchor(int i)
        Return an object that represents the link anchor, as appropriate for that link. E.g. from HTML: Accessibility this method would return a String containing the text: 'Accessibility'. Similarly, from this HTML: <a HREF="#top"><img src="top-hat.gif" alt="top hat"></a> this might return the object ImageIcon("top-hat.gif", "top hat");
        指定者：
        getAccessibleActionAnchor in class AccessibleHyperlink
        参数：
        i - zero-based index of the actions
        返回：
        an Object representing the hypertext anchor
        另请参见：
        getAccessibleActionCount()

      • getStartIndex

        public int getStartIndex()
        Get the index with the hypertext document at which this link begins
        指定者：
        getStartIndex in class AccessibleHyperlink
        返回：
        index of start of link

      • getEndIndex

        public int getEndIndex()
        Get the index with the hypertext document at which this link ends
        指定者：
        getEndIndex in class AccessibleHyperlink
        返回：
        index of end of link
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>mewnainavxxavv.ree.nAtelltmi(eitb)tAA,teAtt


JFileChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFileChooser

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JFileChooser
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JFileChooser
extends JComponent
implements Accessible
    JFileChooser provides a simple mechanism for the user to choose a file. For information about using JFileChooser, see How to Use File Choosers, a section in The Java Tutorial.

    The following code pops up a file chooser for the user's home directory that sees only .jpg and .gif images:

        JFileChooser chooser = new JFileChooser();
    FileNameExtensionFilter filter = new FileNameExtensionFilter(
        "JPG & GIF Images", "jpg", "gif");
    chooser.setFileFilter(filter);
    int returnVal = chooser.showOpenDialog(parent);
    if(returnVal == JFileChooser.APPROVE_OPTION) {
       System.out.println("You chose to open this file: " +
            chooser.getSelectedFile().getName());
    }

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JFileChooser.AccessibleJFileChooser
      This class implements accessibility support for the JFileChooser class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static String ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY
      Identifies whether a the AcceptAllFileFilter is used or not.
      protected AccessibleContext | accessibleContext
      static String ACCESSORY_CHANGED_PROPERTY
      Says that a different accessory component is in use (for example, to preview files).
      static String APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY
      Identifies change in the mnemonic for the approve (yes, ok) button.
      static String APPROVE_BUTTON_TEXT_CHANGED_PROPERTY
      Identifies change in the text on the approve (yes, ok) button.
      static String APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY
      Identifies change in the tooltip text for the approve (yes, ok) button.
      static int APPROVE_OPTION
      Return value if approve (yes, ok) is chosen.
      static String APPROVE_SELECTION
      Instruction to approve the current selection (same as pressing yes or ok).
      static int CANCEL_OPTION
      Return value if cancel is chosen.
      static String CANCEL_SELECTION
      Instruction to cancel the current selection.
      static String CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY
      Identifies a change in the list of predefined file filters the user can choose from.
      static String CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY
      Instruction to display the control buttons.
      static int CUSTOM_DIALOG
      Type value indicating that the JFileChooser supports a developer-specified file operation.
      static String DIALOG_TITLE_CHANGED_PROPERTY
      Identifies a change in the dialog title.
      static String DIALOG_TYPE_CHANGED_PROPERTY
      Identifies a change in the type of files displayed (files only, directories only, or both files and directories).
      static int DIRECTORIES_ONLY
      Instruction to display only directories.
      static String DIRECTORY_CHANGED_PROPERTY
      Identifies user's directory change.
      static int ERROR_OPTION
      Return value if an error occured.
      static String FILE_FILTER_CHANGED_PROPERTY
      User changed the kind of files to display.
      static String FILE_HIDING_CHANGED_PROPERTY
      Identifies a change in the display-hidden-files property.
      static String FILE_SELECTION_MODE_CHANGED_PROPERTY
      Identifies a change in the kind of selection (single, multiple, etc.).
      static String FILE_SYSTEM_VIEW_CHANGED_PROPERTY
      Says that a different object is being used to find available drives on the system.
      static String FILE_VIEW_CHANGED_PROPERTY
      Says that a different object is being used to retrieve file information.
      static int FILES_AND_DIRECTORIES
      Instruction to display both files and directories.
      static int FILES_ONLY
      Instruction to display only files.
      static String MULTI_SELECTION_ENABLED_CHANGED_PROPERTY
      Enables multiple-file selections.
      static int OPEN_DIALOG
      Type value indicating that the JFileChooser supports an "Open" file operation.
      static int SAVE_DIALOG
      Type value indicating that the JFileChooser supports a "Save" file operation.
      static String SELECTED_FILE_CHANGED_PROPERTY
      Identifies change in user's single-file selection.
      static String SELECTED_FILES_CHANGED_PROPERTY
      Identifies change in user's multiple-file selection.

      • Fields inherited from class javax.swing.JComponent

        listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JFileChooser()
      Constructs a JFileChooser pointing to the user's default directory.
      JFileChooser(File currentDirectory)
      Constructs a JFileChooser using the given File as the path.
      JFileChooser(File currentDirectory, FileSystemView fsv)
      Constructs a JFileChooser using the given current directory and FileSystemView.
      JFileChooser(FileSystemView fsv)
      Constructs a JFileChooser using the given FileSystemView.
      JFileChooser(String currentDirectoryPath)
      Constructs a JFileChooser using the given path.
      JFileChooser(String currentDirectoryPath, FileSystemView fsv)
      Constructs a JFileChooser using the given current directory path and FileSystemView.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean accept(File f)
      Returns true if the file should be displayed.
      void addActionListener(ActionListener l)
      Adds an ActionListener to the file chooser.
      void addChoosableFileFilter(FileFilter filter)
      Adds a filter to the list of user choosable file filters.
      void approveSelection()
      Called by the UI when the user hits the Approve button (labeled "Open" or "Save", by default).
      void cancelSelection()
      Called by the UI when the user chooses the Cancel button.
      void changeToParentDirectory()
      Changes the directory to be set to the parent of the current directory.
      protected JDialog createDialog(Component parent)
      Creates and returns a new JDialog wrapping this centered on the parent in the parent's frame.
      void ensureFileIsVisible(File f)
      Makes sure that the specified file is viewable, and not hidden.
      protected void fireActionPerformed(String command)
      Notifies all listeners that have registered interest for notification on this event type.
      FileFilter getAcceptAllFileFilter()
      Returns the AcceptAll file filter.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JFileChooser.
      JComponent getAccessory()
      Returns the accessory component.
      ActionListener[] getActionListeners()
      Returns an array of all the action listeners registered on this file chooser.
      int getApproveButtonMnemonic()
      Returns the approve button's mnemonic.
      String getApproveButtonText()
      Returns the text used in the ApproveButton in the FileChooserUI.
      String getApproveButtonToolTipText()
      Returns the tooltip text used in the ApproveButton.
      FileFilter[] getChoosableFileFilters()
      Gets the list of user choosable file filters.
      boolean getControlButtonsAreShown()
      Returns the value of the controlButtonsAreShown property.
      File getCurrentDirectory()
      Returns the current directory.
      String getDescription(File f)
      Returns the file description.
      String getDialogTitle()
      Gets the string that goes in the JFileChooser's titlebar.
      int getDialogType()
      Returns the type of this dialog.
      boolean getDragEnabled()
      Gets the value of the dragEnabled property.
      FileFilter getFileFilter()
      Returns the currently selected file filter.
      int getFileSelectionMode()
      Returns the current file-selection mode.
      FileSystemView getFileSystemView()
      Returns the file system view.
      FileView getFileView()
      Returns the current file view.
      Icon getIcon(File f)
      Returns the icon for this file or type of file, depending on the system.
      String getName(File f)
      Returns the filename.
      File getSelectedFile()
      Returns the selected file.
      File[] getSelectedFiles()
      Returns a list of selected files if the file chooser is set to allow multiple selection.
      String getTypeDescription(File f)
      Returns the file type.
      FileChooserUI getUI()
      Gets the UI object which implements the L&F for this component.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      boolean isAcceptAllFileFilterUsed()
      Returns whether the AcceptAll FileFilter is used.
      boolean isDirectorySelectionEnabled()
      Convenience call that determines if directories are selectable based on the current file selection mode.
      boolean isFileHidingEnabled()
      Returns true if hidden files are not shown in the file chooser; otherwise, returns false.
      boolean isFileSelectionEnabled()
      Convenience call that determines if files are selectable based on the current file selection mode.
      boolean isMultiSelectionEnabled()
      Returns true if multiple files can be selected.
      boolean isTraversable(File f)
      Returns true if the file (directory) can be visited.
      protected String paramString()
      Returns a string representation of this JFileChooser.
      void removeActionListener(ActionListener l)
      Removes an ActionListener from the file chooser.
      boolean removeChoosableFileFilter(FileFilter f)
      Removes a filter from the list of user choosable file filters.
      void rescanCurrentDirectory()
      Tells the UI to rescan its files list from the current directory.
      void resetChoosableFileFilters()
      Resets the choosable file filter list to its starting state.
      void setAcceptAllFileFilterUsed(boolean b)
      Determines whether the AcceptAll FileFilter is used as an available choice in the choosable filter list.
      void setAccessory(JComponent newAccessory)
      Sets the accessory component.
      void setApproveButtonMnemonic(char mnemonic)
      Sets the approve button's mnemonic using a character.
      void setApproveButtonMnemonic(int mnemonic)
      Sets the approve button's mnemonic using a numeric keycode.
      void setApproveButtonText(String approveButtonText)
      Sets the text used in the ApproveButton in the FileChooserUI.
      void setApproveButtonToolTipText(String toolTipText)
      Sets the tooltip text used in the ApproveButton.
      void setControlButtonsAreShown(boolean b)
      Sets the property that indicates whether the approve and cancel buttons are shown in the file chooser.
      void setCurrentDirectory(File dir)
      Sets the current directory.
      void setDialogTitle(String dialogTitle)
      Sets the string that goes in the JFileChooser window's title bar.
      void setDialogType(int dialogType)
      Sets the type of this dialog.
      void setDragEnabled(boolean b)
      Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component.
      void setFileFilter(FileFilter filter)
      Sets the current file filter.
      void setFileHidingEnabled(boolean b)
      Sets file hiding on or off.
      void setFileSelectionMode(int mode)
      Sets the JFileChooser to allow the user to just select files, just select directories, or select both files and directories.
      void setFileSystemView(FileSystemView fsv)
      Sets the file system view that the JFileChooser uses for accessing and creating file system resources, such as finding the floppy drive and getting a list of root drives.
      void setFileView(FileView fileView)
      Sets the file view to used to retrieve UI information, such as the icon that represents a file or the type description of a file.
      void setMultiSelectionEnabled(boolean b)
      Sets the file chooser to allow multiple file selections.
      void setSelectedFile(File file)
      Sets the selected file.
      void setSelectedFiles(File[] selectedFiles)
      Sets the list of selected files if the file chooser is set to allow multiple selection.
      protected void setup(FileSystemView view)
      Performs common constructor initialization and setup.
      int showDialog(Component parent, String approveButtonText)
      Pops a custom file chooser dialog with a custom approve button.
      int showOpenDialog(Component parent)
      Pops up an "Open File" file chooser dialog.
      int showSaveDialog(Component parent)
      Pops up a "Save File" file chooser dialog.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • OPEN_DIALOG

        public static final int OPEN_DIALOG
        Type value indicating that the JFileChooser supports an "Open" file operation.
        另请参见：
        Constant Field Values

      • SAVE_DIALOG

        public static final int SAVE_DIALOG
        Type value indicating that the JFileChooser supports a "Save" file operation.
        另请参见：
        Constant Field Values

      • CUSTOM_DIALOG

        public static final int CUSTOM_DIALOG
        Type value indicating that the JFileChooser supports a developer-specified file operation.
        另请参见：
        Constant Field Values

      • CANCEL_OPTION

        public static final int CANCEL_OPTION
        Return value if cancel is chosen.
        另请参见：
        Constant Field Values

      • APPROVE_OPTION

        public static final int APPROVE_OPTION
        Return value if approve (yes, ok) is chosen.
        另请参见：
        Constant Field Values

      • ERROR_OPTION

        public static final int ERROR_OPTION
        Return value if an error occured.
        另请参见：
        Constant Field Values

      • FILES_ONLY

        public static final int FILES_ONLY
        Instruction to display only files.
        另请参见：
        Constant Field Values

      • DIRECTORIES_ONLY

        public static final int DIRECTORIES_ONLY
        Instruction to display only directories.
        另请参见：
        Constant Field Values

      • FILES_AND_DIRECTORIES

        public static final int FILES_AND_DIRECTORIES
        Instruction to display both files and directories.
        另请参见：
        Constant Field Values

      • CANCEL_SELECTION

        public static final String CANCEL_SELECTION
        Instruction to cancel the current selection.
        另请参见：
        Constant Field Values

      • APPROVE_SELECTION

        public static final String APPROVE_SELECTION
        Instruction to approve the current selection (same as pressing yes or ok).
        另请参见：
        Constant Field Values

      • APPROVE_BUTTON_TEXT_CHANGED_PROPERTY

        public static final String APPROVE_BUTTON_TEXT_CHANGED_PROPERTY
        Identifies change in the text on the approve (yes, ok) button.
        另请参见：
        Constant Field Values

      • APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY

        public static final String APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY
        Identifies change in the tooltip text for the approve (yes, ok) button.
        另请参见：
        Constant Field Values

      • APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY

        public static final String APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY
        Identifies change in the mnemonic for the approve (yes, ok) button.
        另请参见：
        Constant Field Values

      • CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

        public static final String CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY
        Instruction to display the control buttons.
        另请参见：
        Constant Field Values

      • DIRECTORY_CHANGED_PROPERTY

        public static final String DIRECTORY_CHANGED_PROPERTY
        Identifies user's directory change.
        另请参见：
        Constant Field Values

      • SELECTED_FILE_CHANGED_PROPERTY

        public static final String SELECTED_FILE_CHANGED_PROPERTY
        Identifies change in user's single-file selection.
        另请参见：
        Constant Field Values

      • SELECTED_FILES_CHANGED_PROPERTY

        public static final String SELECTED_FILES_CHANGED_PROPERTY
        Identifies change in user's multiple-file selection.
        另请参见：
        Constant Field Values

      • MULTI_SELECTION_ENABLED_CHANGED_PROPERTY

        public static final String MULTI_SELECTION_ENABLED_CHANGED_PROPERTY
        Enables multiple-file selections.
        另请参见：
        Constant Field Values

      • FILE_SYSTEM_VIEW_CHANGED_PROPERTY

        public static final String FILE_SYSTEM_VIEW_CHANGED_PROPERTY
        Says that a different object is being used to find available drives on the system.
        另请参见：
        Constant Field Values

      • FILE_VIEW_CHANGED_PROPERTY

        public static final String FILE_VIEW_CHANGED_PROPERTY
        Says that a different object is being used to retrieve file information.
        另请参见：
        Constant Field Values

      • FILE_HIDING_CHANGED_PROPERTY

        public static final String FILE_HIDING_CHANGED_PROPERTY
        Identifies a change in the display-hidden-files property.
        另请参见：
        Constant Field Values

      • FILE_FILTER_CHANGED_PROPERTY

        public static final String FILE_FILTER_CHANGED_PROPERTY
        User changed the kind of files to display.
        另请参见：
        Constant Field Values

      • FILE_SELECTION_MODE_CHANGED_PROPERTY

        public static final String FILE_SELECTION_MODE_CHANGED_PROPERTY
        Identifies a change in the kind of selection (single, multiple, etc.).
        另请参见：
        Constant Field Values

      • ACCESSORY_CHANGED_PROPERTY

        public static final String ACCESSORY_CHANGED_PROPERTY
        Says that a different accessory component is in use (for example, to preview files).
        另请参见：
        Constant Field Values

      • ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY

        public static final String ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY
        Identifies whether a the AcceptAllFileFilter is used or not.
        另请参见：
        Constant Field Values

      • DIALOG_TITLE_CHANGED_PROPERTY

        public static final String DIALOG_TITLE_CHANGED_PROPERTY
        Identifies a change in the dialog title.
        另请参见：
        Constant Field Values

      • DIALOG_TYPE_CHANGED_PROPERTY

        public static final String DIALOG_TYPE_CHANGED_PROPERTY
        Identifies a change in the type of files displayed (files only, directories only, or both files and directories).
        另请参见：
        Constant Field Values

      • CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY

        public static final String CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY
        Identifies a change in the list of predefined file filters the user can choose from.
        另请参见：
        Constant Field Values

      • accessibleContext

        protected AccessibleContext accessibleContext

    • 构造方法详细信息

      • JFileChooser

        public JFileChooser()
        Constructs a JFileChooser pointing to the user's default directory. This default depends on the operating system. It is typically the "My Documents" folder on Windows, and the user's home directory on Unix.

      • JFileChooser

        public JFileChooser(String currentDirectoryPath)
        Constructs a JFileChooser using the given path. Passing in a null string causes the file chooser to point to the user's default directory. This default depends on the operating system. It is typically the "My Documents" folder on Windows, and the user's home directory on Unix.
        参数：
        currentDirectoryPath - a String giving the path to a file or directory

      • JFileChooser

        public JFileChooser(File currentDirectory)
        Constructs a JFileChooser using the given File as the path. Passing in a null file causes the file chooser to point to the user's default directory. This default depends on the operating system. It is typically the "My Documents" folder on Windows, and the user's home directory on Unix.
        参数：
        currentDirectory - a File object specifying the path to a file or directory

      • JFileChooser

        public JFileChooser(FileSystemView fsv)
        Constructs a JFileChooser using the given FileSystemView.

      • JFileChooser

        public JFileChooser(File currentDirectory,
            FileSystemView fsv)
        Constructs a JFileChooser using the given current directory and FileSystemView.

      • JFileChooser

        public JFileChooser(String currentDirectoryPath,
            FileSystemView fsv)
        Constructs a JFileChooser using the given current directory path and FileSystemView.

    • 方法详细信息

      • setup

        protected void setup(FileSystemView view)
        Performs common constructor initialization and setup.

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component. The transferHandler property needs to be set to a non-null value for the drag to do anything. The default value of the dragEnabled property is false.

        When automatic drag handling is enabled, most look and feels begin a drag-and-drop operation whenever the user presses the mouse button over an item and then moves the mouse a few pixels. Setting this property to true can therefore have a subtle effect on how selections behave.

        Some look and feels might not support automatic drag and drop; they will ignore this property. You can work around such look and feels by modifying the component to directly call the exportAsDrag method of a TransferHandler.

        参数：
        b - the value to set the dragEnabled property to
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Gets the value of the dragEnabled property.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • getSelectedFile

        public File getSelectedFile()
        Returns the selected file. This can be set either by the programmer via setSelectedFile or by a user action, such as either typing the filename into the UI or selecting the file from a list in the UI.
        返回：
        the selected file
        另请参见：
        setSelectedFile(java.io.File)

      • setSelectedFile

        public void setSelectedFile(File file)
        Sets the selected file. If the file's parent directory is not the current directory, changes the current directory to be the file's parent directory.
        参数：
        file - the selected file
        另请参见：
        getSelectedFile()

      • getSelectedFiles

        public File[] getSelectedFiles()
        Returns a list of selected files if the file chooser is set to allow multiple selection.

      • setSelectedFiles

        public void setSelectedFiles(File[] selectedFiles)
        Sets the list of selected files if the file chooser is set to allow multiple selection.

      • getCurrentDirectory

        public File getCurrentDirectory()
        Returns the current directory.
        返回：
        the current directory
        另请参见：
        setCurrentDirectory(java.io.File)

      • setCurrentDirectory

        public void setCurrentDirectory(File dir)
        Sets the current directory. Passing in null sets the file chooser to point to the user's default directory. This default depends on the operating system. It is typically the "My Documents" folder on Windows, and the user's home directory on Unix. If the file passed in as currentDirectory is not a directory, the parent of the file will be used as the currentDirectory. If the parent is not traversable, then it will walk up the parent tree until it finds a traversable directory, or hits the root of the file system.
        参数：
        dir - the current directory to point to
        另请参见：
        getCurrentDirectory()

      • changeToParentDirectory

        public void changeToParentDirectory()
        Changes the directory to be set to the parent of the current directory.
        另请参见：
        getCurrentDirectory()

      • rescanCurrentDirectory

        public void rescanCurrentDirectory()
        Tells the UI to rescan its files list from the current directory.

      • ensureFileIsVisible

        public void ensureFileIsVisible(File f)
        Makes sure that the specified file is viewable, and not hidden.
        参数：
        f - a File object

      • showOpenDialog

        public int showOpenDialog(Component parent)
                   throws HeadlessException
        Pops up an "Open File" file chooser dialog. Note that the text that appears in the approve button is determined by the L&F.
        参数：
        parent - the parent component of the dialog, can be null; see showDialog for details
        返回：
        the return state of the file chooser on popdown:
        • JFileChooser.CANCEL_OPTION
        • JFileChooser.APPROVE_OPTION
        • JFileChooser.ERROR_OPTION if an error occurs or the dialog is dismissed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), showDialog(java.awt.Component, java.lang.String)

      • showSaveDialog

        public int showSaveDialog(Component parent)
                   throws HeadlessException
        Pops up a "Save File" file chooser dialog. Note that the text that appears in the approve button is determined by the L&F.
        参数：
        parent - the parent component of the dialog, can be null; see showDialog for details
        返回：
        the return state of the file chooser on popdown:
        • JFileChooser.CANCEL_OPTION
        • JFileChooser.APPROVE_OPTION
        • JFileChooser.ERROR_OPTION if an error occurs or the dialog is dismissed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(), showDialog(java.awt.Component, java.lang.String)

      • showDialog

        public int showDialog(Component parent,
             String approveButtonText)
               throws HeadlessException
        Pops a custom file chooser dialog with a custom approve button. For example, the following code pops up a file chooser with a "Run Application" button (instead of the normal "Save" or "Open" button):
         filechooser.showDialog(parentFrame, "Run Application");
        Alternatively, the following code does the same thing:
            JFileChooser chooser = new JFileChooser(null);
    chooser.setApproveButtonText("Run Application");
    chooser.showDialog(parentFrame, null);

        The parent argument determines two things: the frame on which the open dialog depends and the component whose position the look and feel should consider when placing the dialog. If the parent is a Frame object (such as a JFrame) then the dialog depends on the frame and the look and feel positions the dialog relative to the frame (for example, centered over the frame). If the parent is a component, then the dialog depends on the frame containing the component, and is positioned relative to the component (for example, centered over the component). If the parent is null, then the dialog depends on no visible window, and it's placed in a look-and-feel-dependent position such as the center of the screen.

        参数：
        parent - the parent component of the dialog; can be null
        approveButtonText - the text of the ApproveButton
        返回：
        the return state of the file chooser on popdown:
        • JFileChooser.CANCEL_OPTION
        • JFileChooser.APPROVE_OPTION
        • JFileChooser.ERROR_OPTION if an error occurs or the dialog is dismissed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless()

      • createDialog

        protected JDialog createDialog(Component parent)
                        throws HeadlessException
        Creates and returns a new JDialog wrapping this centered on the parent in the parent's frame. This method can be overriden to further manipulate the dialog, to disable resizing, set the location, etc. Example:
             class MyFileChooser extends JFileChooser {
         protected JDialog createDialog(Component parent) throws HeadlessException {
             JDialog dialog = super.createDialog(parent);
             dialog.setLocation(300, 200);
             dialog.setResizable(false);
             return dialog;
         }
     }
        参数：
        parent - the parent component of the dialog; can be null
        返回：
        a new JDialog containing this instance
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless()

      • getControlButtonsAreShown

        public boolean getControlButtonsAreShown()
        Returns the value of the controlButtonsAreShown property.
        返回：
        the value of the controlButtonsAreShown property
        从以下版本开始：
        1.3
        另请参见：
        setControlButtonsAreShown(boolean)

      • setControlButtonsAreShown

        public void setControlButtonsAreShown(boolean b)
        Sets the property that indicates whether the approve and cancel buttons are shown in the file chooser. This property is true by default. Look and feels that always show these buttons will ignore the value of this property. This method fires a property-changed event, using the string value of CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY as the name of the property.
        参数：
        b - false if control buttons should not be shown; otherwise, true
        从以下版本开始：
        1.3
        另请参见：
        getControlButtonsAreShown(), CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

      • getDialogType

        public int getDialogType()
        Returns the type of this dialog. The default is JFileChooser.OPEN_DIALOG.
        返回：
        the type of dialog to be displayed:
        • JFileChooser.OPEN_DIALOG
        • JFileChooser.SAVE_DIALOG
        • JFileChooser.CUSTOM_DIALOG
        另请参见：
        setDialogType(int)

      • setDialogType

        public void setDialogType(int dialogType)
        Sets the type of this dialog. Use OPEN_DIALOG when you want to bring up a file chooser that the user can use to open a file. Likewise, use SAVE_DIALOG for letting the user choose a file for saving. Use CUSTOM_DIALOG when you want to use the file chooser in a context other than "Open" or "Save". For instance, you might want to bring up a file chooser that allows the user to choose a file to execute. Note that you normally would not need to set the JFileChooser to use CUSTOM_DIALOG since a call to setApproveButtonText does this for you. The default dialog type is JFileChooser.OPEN_DIALOG.
        参数：
        dialogType - the type of dialog to be displayed:
        • JFileChooser.OPEN_DIALOG
        • JFileChooser.SAVE_DIALOG
        • JFileChooser.CUSTOM_DIALOG
        抛出：
        IllegalArgumentException - if dialogType is not legal
        另请参见：
        getDialogType(), setApproveButtonText(java.lang.String)

      • setDialogTitle

        public void setDialogTitle(String dialogTitle)
        Sets the string that goes in the JFileChooser window's title bar.
        参数：
        dialogTitle - the new String for the title bar
        另请参见：
        getDialogTitle()

      • getDialogTitle

        public String getDialogTitle()
        Gets the string that goes in the JFileChooser's titlebar.
        另请参见：
        setDialogTitle(java.lang.String)

      • setApproveButtonToolTipText

        public void setApproveButtonToolTipText(String toolTipText)
        Sets the tooltip text used in the ApproveButton. If null, the UI object will determine the button's text.
        参数：
        toolTipText - the tooltip text for the approve button
        另请参见：
        setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

      • getApproveButtonToolTipText

        public String getApproveButtonToolTipText()
        Returns the tooltip text used in the ApproveButton. If null, the UI object will determine the button's text.
        返回：
        the tooltip text used for the approve button
        另请参见：
        setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

      • getApproveButtonMnemonic

        public int getApproveButtonMnemonic()
        Returns the approve button's mnemonic.
        返回：
        an integer value for the mnemonic key
        另请参见：
        setApproveButtonMnemonic(int)

      • setApproveButtonMnemonic

        public void setApproveButtonMnemonic(int mnemonic)
        Sets the approve button's mnemonic using a numeric keycode.
        参数：
        mnemonic - an integer value for the mnemonic key
        另请参见：
        getApproveButtonMnemonic()

      • setApproveButtonMnemonic

        public void setApproveButtonMnemonic(char mnemonic)
        Sets the approve button's mnemonic using a character.
        参数：
        mnemonic - a character value for the mnemonic key
        另请参见：
        getApproveButtonMnemonic()

      • setApproveButtonText

        public void setApproveButtonText(String approveButtonText)
        Sets the text used in the ApproveButton in the FileChooserUI.
        参数：
        approveButtonText - the text used in the ApproveButton
        另请参见：
        getApproveButtonText(), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

      • getApproveButtonText

        public String getApproveButtonText()
        Returns the text used in the ApproveButton in the FileChooserUI. If null, the UI object will determine the button's text. Typically, this would be "Open" or "Save".
        返回：
        the text used in the ApproveButton
        另请参见：
        setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

      • getChoosableFileFilters

        public FileFilter[] getChoosableFileFilters()
        Gets the list of user choosable file filters.
        返回：
        a FileFilter array containing all the choosable file filters
        另请参见：
        addChoosableFileFilter(javax.swing.filechooser.FileFilter),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter),
resetChoosableFileFilters()

      • addChoosableFileFilter

        public void addChoosableFileFilter(FileFilter filter)
        Adds a filter to the list of user choosable file filters. For information on setting the file selection mode, see setFileSelectionMode.
        参数：
        filter - the FileFilter to add to the choosable file filter list
        另请参见：
        getChoosableFileFilters(),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter),
resetChoosableFileFilters(),
setFileSelectionMode(int)

      • removeChoosableFileFilter

        public boolean removeChoosableFileFilter(FileFilter f)
        Removes a filter from the list of user choosable file filters. Returns true if the file filter was removed.
        另请参见：
        addChoosableFileFilter(javax.swing.filechooser.FileFilter),
getChoosableFileFilters(),
resetChoosableFileFilters()

      • resetChoosableFileFilters

        public void resetChoosableFileFilters()
        Resets the choosable file filter list to its starting state. Normally, this removes all added file filters while leaving the AcceptAll file filter.
        另请参见：
        addChoosableFileFilter(javax.swing.filechooser.FileFilter),
getChoosableFileFilters(),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter)

      • getAcceptAllFileFilter

        public FileFilter getAcceptAllFileFilter()
        Returns the AcceptAll file filter. For example, on Microsoft Windows this would be All Files (*.*).

      • isAcceptAllFileFilterUsed

        public boolean isAcceptAllFileFilterUsed()
        Returns whether the AcceptAll FileFilter is used.
        返回：
        true if the AcceptAll FileFilter is used
        从以下版本开始：
        1.3
        另请参见：
        setAcceptAllFileFilterUsed(boolean)

      • setAcceptAllFileFilterUsed

        public void setAcceptAllFileFilterUsed(boolean b)
        Determines whether the AcceptAll FileFilter is used as an available choice in the choosable filter list. If false, the AcceptAll file filter is removed from the list of available file filters. If true, the AcceptAll file filter will become the the actively used file filter.
        从以下版本开始：
        1.3
        另请参见：
        isAcceptAllFileFilterUsed(),
getAcceptAllFileFilter(),
setFileFilter(javax.swing.filechooser.FileFilter)

      • getAccessory

        public JComponent getAccessory()
        Returns the accessory component.
        返回：
        this JFileChooser's accessory component, or null
        另请参见：
        setAccessory(javax.swing.JComponent)

      • setAccessory

        public void setAccessory(JComponent newAccessory)
        Sets the accessory component. An accessory is often used to show a preview image of the selected file; however, it can be used for anything that the programmer wishes, such as extra custom file chooser controls.

        Note: if there was a previous accessory, you should unregister any listeners that the accessory might have registered with the file chooser.

      • setFileSelectionMode

        public void setFileSelectionMode(int mode)
        Sets the JFileChooser to allow the user to just select files, just select directories, or select both files and directories. The default is JFilesChooser.FILES_ONLY.
        参数：
        mode - the type of files to be displayed:
        • JFileChooser.FILES_ONLY
        • JFileChooser.DIRECTORIES_ONLY
        • JFileChooser.FILES_AND_DIRECTORIES
        抛出：
        IllegalArgumentException - if mode is an illegal file selection mode
        另请参见：
        getFileSelectionMode()

      • getFileSelectionMode

        public int getFileSelectionMode()
        Returns the current file-selection mode. The default is JFilesChooser.FILES_ONLY.
        返回：
        the type of files to be displayed, one of the following:
        • JFileChooser.FILES_ONLY
        • JFileChooser.DIRECTORIES_ONLY
        • JFileChooser.FILES_AND_DIRECTORIES
        另请参见：
        setFileSelectionMode(int)

      • isFileSelectionEnabled

        public boolean isFileSelectionEnabled()
        Convenience call that determines if files are selectable based on the current file selection mode.
        另请参见：
        setFileSelectionMode(int), getFileSelectionMode()

      • isDirectorySelectionEnabled

        public boolean isDirectorySelectionEnabled()
        Convenience call that determines if directories are selectable based on the current file selection mode.
        另请参见：
        setFileSelectionMode(int), getFileSelectionMode()

      • setMultiSelectionEnabled

        public void setMultiSelectionEnabled(boolean b)
        Sets the file chooser to allow multiple file selections.
        参数：
        b - true if multiple files may be selected
        另请参见：
        isMultiSelectionEnabled()

      • isMultiSelectionEnabled

        public boolean isMultiSelectionEnabled()
        Returns true if multiple files can be selected.
        返回：
        true if multiple files can be selected
        另请参见：
        setMultiSelectionEnabled(boolean)

      • isFileHidingEnabled

        public boolean isFileHidingEnabled()
        Returns true if hidden files are not shown in the file chooser; otherwise, returns false.
        返回：
        the status of the file hiding property
        另请参见：
        setFileHidingEnabled(boolean)

      • setFileHidingEnabled

        public void setFileHidingEnabled(boolean b)
        Sets file hiding on or off. If true, hidden files are not shown in the file chooser. The job of determining which files are shown is done by the FileView.
        参数：
        b - the boolean value that determines whether file hiding is turned on
        另请参见：
        isFileHidingEnabled()

      • setFileFilter

        public void setFileFilter(FileFilter filter)
        Sets the current file filter. The file filter is used by the file chooser to filter out files from the user's view.
        参数：
        filter - the new current file filter to use
        另请参见：
        getFileFilter()

      • getFileFilter

        public FileFilter getFileFilter()
        Returns the currently selected file filter.
        返回：
        the current file filter
        另请参见：
        setFileFilter(javax.swing.filechooser.FileFilter), addChoosableFileFilter(javax.swing.filechooser.FileFilter)

      • setFileView

        public void setFileView(FileView fileView)
        Sets the file view to used to retrieve UI information, such as the icon that represents a file or the type description of a file.
        另请参见：
        getFileView()

      • getFileView

        public FileView getFileView()
        Returns the current file view.
        另请参见：
        setFileView(javax.swing.filechooser.FileView)

      • getName

        public String getName(File f)
        Returns the filename.
        参数：
        f - the File
        返回：
        the String containing the filename for f
        另请参见：
        FileView.getName(java.io.File)

      • getDescription

        public String getDescription(File f)
        Returns the file description.
        参数：
        f - the File
        返回：
        the String containing the file description for f
        另请参见：
        FileView.getDescription(java.io.File)

      • getTypeDescription

        public String getTypeDescription(File f)
        Returns the file type.
        参数：
        f - the File
        返回：
        the String containing the file type description for f
        另请参见：
        FileView.getTypeDescription(java.io.File)

      • getIcon

        public Icon getIcon(File f)
        Returns the icon for this file or type of file, depending on the system.
        参数：
        f - the File
        返回：
        the Icon for this file, or type of file
        另请参见：
        FileView.getIcon(java.io.File)

      • isTraversable

        public boolean isTraversable(File f)
        Returns true if the file (directory) can be visited. Returns false if the directory cannot be traversed.
        参数：
        f - the File
        返回：
        true if the file/directory can be traversed, otherwise false
        另请参见：
        FileView.isTraversable(java.io.File)

      • accept

        public boolean accept(File f)
        Returns true if the file should be displayed.
        参数：
        f - the File
        返回：
        true if the file should be displayed, otherwise false
        另请参见：
        FileFilter.accept(java.io.File)

      • setFileSystemView

        public void setFileSystemView(FileSystemView fsv)
        Sets the file system view that the JFileChooser uses for accessing and creating file system resources, such as finding the floppy drive and getting a list of root drives.
        参数：
        fsv - the new FileSystemView
        另请参见：
        FileSystemView

      • getFileSystemView

        public FileSystemView getFileSystemView()
        Returns the file system view.
        返回：
        the FileSystemView object
        另请参见：
        setFileSystemView(javax.swing.filechooser.FileSystemView)

      • approveSelection

        public void approveSelection()
        Called by the UI when the user hits the Approve button (labeled "Open" or "Save", by default). This can also be called by the programmer. This method causes an action event to fire with the command string equal to APPROVE_SELECTION.
        另请参见：
        APPROVE_SELECTION

      • cancelSelection

        public void cancelSelection()
        Called by the UI when the user chooses the Cancel button. This can also be called by the programmer. This method causes an action event to fire with the command string equal to CANCEL_SELECTION.
        另请参见：
        CANCEL_SELECTION

      • addActionListener

        public void addActionListener(ActionListener l)
        Adds an ActionListener to the file chooser.
        参数：
        l - the listener to be added
        另请参见：
        approveSelection(), cancelSelection()

      • removeActionListener

        public void removeActionListener(ActionListener l)
        Removes an ActionListener from the file chooser.
        参数：
        l - the listener to be removed
        另请参见：
        addActionListener(java.awt.event.ActionListener)

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the action listeners registered on this file chooser.
        返回：
        all of this file chooser's ActionListeners or an empty array if no action listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

      • fireActionPerformed

        protected void fireActionPerformed(String command)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the command parameter.
        另请参见：
        EventListenerList

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "FileChooserUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getUI

        public FileChooserUI getUI()
        Gets the UI object which implements the L&F for this component.
        返回：
        the FileChooserUI object that implements the FileChooserUI L&F

      • paramString

        protected String paramString()
        Returns a string representation of this JFileChooser. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JFileChooser

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JFileChooser. For file choosers, the AccessibleContext takes the form of an AccessibleJFileChooser. A new AccessibleJFileChooser instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJFileChooser that serves as the AccessibleContext of this JFileChooser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JFileChooser.AccessibleJFileChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFileChooser.AccessibleJFileChooser

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JFileChooser.AccessibleJFileChooser
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JFileChooser

    protected class JFileChooser.AccessibleJFileChooser
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JFileChooser class. It provides an implementation of the Java Accessibility API appropriate to file chooser user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JFileChooser.AccessibleJFileChooser()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JFileChooser.AccessibleJFileChooser

        protected JFileChooser.AccessibleJFileChooser()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ml<<<d>"i蘭perit祎aol


JFormattedTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFormattedTextField

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextField
              • javax.swing.JFormattedTextField
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants

    public class JFormattedTextField
extends JTextField
    JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text. The following illustrates configuring a JFormattedTextField to edit dates:
       JFormattedTextField ftf = new JFormattedTextField();
   ftf.setValue(new Date());

    Once a JFormattedTextField has been created, you can listen for editing changes by way of adding a PropertyChangeListener and listening for PropertyChangeEvents with the property name value.

    JFormattedTextField allows configuring what action should be taken when focus is lost. The possible configurations are:

    Value

    描述

    JFormattedTextField.REVERT | Revert the display to match that of getValue, possibly losing the current edit.
    JFormattedTextField.COMMIT | Commits the current value. If the value being edited isn't considered a legal value by the AbstractFormatter that is, a ParseException is thrown, then the value will not change, and then edited value will persist.
    JFormattedTextField.COMMIT_OR_REVERT | Similar to COMMIT, but if the value isn't legal, behave like REVERT.
    JFormattedTextField.PERSIST | Do nothing, don't obtain a new AbstractFormatter, and don't update the value.
    The default is JFormattedTextField.COMMIT_OR_REVERT, refer to setFocusLostBehavior(int) for more information on this.

    JFormattedTextField allows the focus to leave, even if the currently edited value is invalid. To lock the focus down while the JFormattedTextField is an invalid edit state you can attach an InputVerifier. The following code snippet shows a potential implementation of such an InputVerifier:

     public class FormattedTextFieldVerifier extends InputVerifier {
     public boolean verify(JComponent input) {
         if (input instanceof JFormattedTextField) {
             JFormattedTextField ftf = (JFormattedTextField)input;
             AbstractFormatter formatter = ftf.getFormatter();
             if (formatter != null) {
                 String text = ftf.getText();
                 try {
                      formatter.stringToValue(text);
                      return true;
                  } catch (ParseException pe) {
                      return false;
                  }
              }
          }
          return true;
      }
      public boolean shouldYieldFocus(JComponent input) {
          return verify(input);
      }
  }

    Alternatively, you could invoke commitEdit, which would also commit the value.

    JFormattedTextField does not do the formatting it self, rather formatting is done through an instance of JFormattedTextField.AbstractFormatter which is obtained from an instance of JFormattedTextField.AbstractFormatterFactory. Instances of JFormattedTextField.AbstractFormatter are notified when they become active by way of the install method, at which point the JFormattedTextField.AbstractFormatter can install whatever it needs to, typically a DocumentFilter. Similarly when JFormattedTextField no longer needs the AbstractFormatter, it will invoke uninstall.

    JFormattedTextField typically queries the AbstractFormatterFactory for an AbstractFormat when it gains or loses focus. Although this can change based on the focus lost policy. If the focus lost policy is JFormattedTextField.PERSIST and the JFormattedTextField has been edited, the AbstractFormatterFactory will not be queried until the value has been commited. Similarly if the focus lost policy is JFormattedTextField.COMMIT and an exception is thrown from stringToValue, the AbstractFormatterFactory will not be querired when focus is lost or gained.

    JFormattedTextField.AbstractFormatter is also responsible for determining when values are commited to the JFormattedTextField. Some JFormattedTextField.AbstractFormatters will make new values available on every edit, and others will never commit the value. You can force the current value to be obtained from the current JFormattedTextField.AbstractFormatter by way of invoking commitEdit. commitEdit will be invoked whenever return is pressed in the JFormattedTextField.

    If an AbstractFormatterFactory has not been explicitly set, one will be set based on the 类 of the value type after setValue has been invoked (assuming value is non-null). For example, in the following code an appropriate AbstractFormatterFactory and AbstractFormatter will be created to handle formatting of numbers:

       JFormattedTextField tf = new JFormattedTextField();
   tf.setValue(new Number(100));

    警告： As the AbstractFormatter will typically install a DocumentFilter on the Document, and a NavigationFilter on the JFormattedTextField you should not install your own. If you do, you are likely to see odd behavior in that the editing policy of the AbstractFormatter will not be enforced.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  JFormattedTextField.AbstractFormatter
      Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object.
      static class  JFormattedTextField.AbstractFormatterFactory
      Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values.

      • Nested classes/interfaces inherited from class javax.swing.JTextField

        JTextField.AccessibleJTextField

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int COMMIT
      Constant identifying that when focus is lost, commitEdit should be invoked.
      static int COMMIT_OR_REVERT
      Constant identifying that when focus is lost, commitEdit should be invoked.
      static int PERSIST
      Constant identifying that when focus is lost, the edited value should be left.
      static int REVERT
      Constant identifying that when focus is lost, editing value should be reverted to current value set on the JFormattedTextField.

      • Fields inherited from class javax.swing.JTextField

        notifyAction

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JFormattedTextField()
      Creates a JFormattedTextField with no AbstractFormatterFactory.
      JFormattedTextField(Format format)
      Creates a JFormattedTextField.
      JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
      Creates a JFormattedTextField with the specified AbstractFormatter.
      JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
      Creates a JFormattedTextField with the specified AbstractFormatterFactory.
      JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
      Creates a JFormattedTextField with the specified AbstractFormatterFactory and initial value.
      JFormattedTextField(Object value)
      Creates a JFormattedTextField with the specified value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void commitEdit()
      Forces the current value to be taken from the AbstractFormatter and set as the current value.
      Action[] getActions()
      Fetches the command list for the editor.
      int getFocusLostBehavior()
      Returns the behavior when focus is lost.
      JFormattedTextField.AbstractFormatter getFormatter()
      Returns the AbstractFormatter that is used to format and parse the current value.
      JFormattedTextField.AbstractFormatterFactory getFormatterFactory()
      Returns the current AbstractFormatterFactory.
      String getUIClassID()
      Gets the class ID for a UI.
      Object getValue()
      Returns the last valid value.
      protected void invalidEdit()
      Invoked when the user inputs an invalid value.
      boolean isEditValid()
      Returns true if the current value being edited is valid.
      protected void processFocusEvent(FocusEvent e)
      Processes any focus events, such as FocusEvent.FOCUS_GAINED or FocusEvent.FOCUS_LOST.
      protected void processInputMethodEvent(InputMethodEvent e)
      Processes any input method events, such as InputMethodEvent.INPUT_METHOD_TEXT_CHANGED or InputMethodEvent.CARET_POSITION_CHANGED.
      void setDocument(Document doc)
      Associates the editor with a text document.
      void setFocusLostBehavior(int behavior)
      Sets the behavior when focus is lost.
      protected void setFormatter(JFormattedTextField.AbstractFormatter format)
      Sets the current AbstractFormatter.
      void setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
      Sets the AbstractFormatterFactory.
      void setValue(Object value)
      Sets the value that will be formatted by an AbstractFormatter obtained from the current AbstractFormatterFactory.

      • 方法 - 继承于类 javax.swing.JTextField

        actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAccessibleContext, getAction, getActionListeners, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getPreferredSize, getScrollOffset, isValidateRoot, paramString, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setFont, setHorizontalAlignment, setScrollOffset

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • COMMIT

        public static final int COMMIT
        Constant identifying that when focus is lost, commitEdit should be invoked. If in commiting the new value a ParseException is thrown, the invalid value will remain.
        另请参见：
        setFocusLostBehavior(int), Constant Field Values

      • COMMIT_OR_REVERT

        public static final int COMMIT_OR_REVERT
        Constant identifying that when focus is lost, commitEdit should be invoked. If in commiting the new value a ParseException is thrown, the value will be reverted.
        另请参见：
        setFocusLostBehavior(int), Constant Field Values

      • REVERT

        public static final int REVERT
        Constant identifying that when focus is lost, editing value should be reverted to current value set on the JFormattedTextField.
        另请参见：
        setFocusLostBehavior(int), Constant Field Values

      • PERSIST

        public static final int PERSIST
        Constant identifying that when focus is lost, the edited value should be left.
        另请参见：
        setFocusLostBehavior(int), Constant Field Values

    • 构造方法详细信息

      • JFormattedTextField

        public JFormattedTextField()
        Creates a JFormattedTextField with no AbstractFormatterFactory. Use setMask or setFormatterFactory to configure the JFormattedTextField to edit a particular type of value.

      • JFormattedTextField

        public JFormattedTextField(Object value)
        Creates a JFormattedTextField with the specified value. This will create an AbstractFormatterFactory based on the type of value.
        参数：
        value - Initial value for the JFormattedTextField

      • JFormattedTextField

        public JFormattedTextField(Format format)
        Creates a JFormattedTextField. format is wrapped in an appropriate AbstractFormatter which is then wrapped in an AbstractFormatterFactory.
        参数：
        format - Format used to look up an AbstractFormatter

      • JFormattedTextField

        public JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
        Creates a JFormattedTextField with the specified AbstractFormatter. The AbstractFormatter is placed in an AbstractFormatterFactory.
        参数：
        formatter - AbstractFormatter to use for formatting.

      • JFormattedTextField

        public JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
        Creates a JFormattedTextField with the specified AbstractFormatterFactory.
        参数：
        factory - AbstractFormatterFactory used for formatting.

      • JFormattedTextField

        public JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory,
                   Object currentValue)
        Creates a JFormattedTextField with the specified AbstractFormatterFactory and initial value.
        参数：
        factory - AbstractFormatterFactory used for formatting.
        currentValue - Initial value to use

    • 方法详细信息

      • setFocusLostBehavior

        public void setFocusLostBehavior(int behavior)
        Sets the behavior when focus is lost. This will be one of JFormattedTextField.COMMIT_OR_REVERT, JFormattedTextField.REVERT, JFormattedTextField.COMMIT or JFormattedTextField.PERSIST Note that some AbstractFormatters may push changes as they occur, so that the value of this will have no effect.

        This will throw an IllegalArgumentException if the object passed in is not one of the afore mentioned values.

        The default value of this property is JFormattedTextField.COMMIT_OR_REVERT.

        参数：
        behavior - Identifies behavior when focus is lost
        抛出：
        IllegalArgumentException - if behavior is not one of the known values

      • getFocusLostBehavior

        public int getFocusLostBehavior()
        Returns the behavior when focus is lost. This will be one of COMMIT_OR_REVERT, COMMIT, REVERT or PERSIST Note that some AbstractFormatters may push changes as they occur, so that the value of this will have no effect.
        返回：
        returns behavior when focus is lost

      • setFormatterFactory

        public void setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
        Sets the AbstractFormatterFactory. AbstractFormatterFactory is able to return an instance of AbstractFormatter that is used to format a value for display, as well an enforcing an editing policy.

        If you have not explicitly set an AbstractFormatterFactory by way of this method (or a constructor) an AbstractFormatterFactory and consequently an AbstractFormatter will be used based on the 类 of the value. NumberFormatter will be used for Numbers, DateFormatter will be used for Dates, otherwise DefaultFormatter will be used.

        This is a JavaBeans bound property.

        参数：
        tf - AbstractFormatterFactory used to lookup instances of AbstractFormatter

      • getFormatterFactory

        public JFormattedTextField.AbstractFormatterFactory getFormatterFactory()
        Returns the current AbstractFormatterFactory.
        返回：
        AbstractFormatterFactory used to determine AbstractFormatters
        另请参见：
        setFormatterFactory(javax.swing.JFormattedTextField.AbstractFormatterFactory)

      • setFormatter

        protected void setFormatter(JFormattedTextField.AbstractFormatter format)
        Sets the current AbstractFormatter.

        You should not normally invoke this, instead set the AbstractFormatterFactory or set the value. JFormattedTextField will invoke this as the state of the JFormattedTextField changes and requires the value to be reset. JFormattedTextField passes in the AbstractFormatter obtained from the AbstractFormatterFactory.

        This is a JavaBeans bound property.

        参数：
        format - AbstractFormatter to use for formatting
        另请参见：
        setFormatterFactory(javax.swing.JFormattedTextField.AbstractFormatterFactory)

      • getFormatter

        public JFormattedTextField.AbstractFormatter getFormatter()
        Returns the AbstractFormatter that is used to format and parse the current value.
        返回：
        AbstractFormatter used for formatting

      • setValue

        public void setValue(Object value)
        Sets the value that will be formatted by an AbstractFormatter obtained from the current AbstractFormatterFactory. If no AbstractFormatterFactory has been specified, this will attempt to create one based on the type of value.

        The default value of this property is null.

        This is a JavaBeans bound property.

        参数：
        value - Current value to display

      • getValue

        public Object getValue()
        Returns the last valid value. Based on the editing policy of the AbstractFormatter this may not return the current value. The currently edited value can be obtained by invoking commitEdit followed by getValue.
        返回：
        Last valid value

      • commitEdit

        public void commitEdit()
                throws ParseException
        Forces the current value to be taken from the AbstractFormatter and set as the current value. This has no effect if there is no current AbstractFormatter installed.
        抛出：
        ParseException - if the AbstractFormatter is not able to format the current value

      • isEditValid

        public boolean isEditValid()
        Returns true if the current value being edited is valid. The value of this is managed by the current AbstractFormatter, as such there is no public setter for it.
        返回：
        true if the current value being edited is valid.

      • invalidEdit

        protected void invalidEdit()
        Invoked when the user inputs an invalid value. This gives the component a chance to provide feedback. The default implementation beeps.

      • processInputMethodEvent

        protected void processInputMethodEvent(InputMethodEvent e)
        Processes any input method events, such as InputMethodEvent.INPUT_METHOD_TEXT_CHANGED or InputMethodEvent.CARET_POSITION_CHANGED.
        重载：
        processInputMethodEvent in class JTextComponent
        参数：
        e - the InputMethodEvent
        另请参见：
        InputMethodEvent

      • processFocusEvent

        protected void processFocusEvent(FocusEvent e)
        Processes any focus events, such as FocusEvent.FOCUS_GAINED or FocusEvent.FOCUS_LOST.
        重载：
        processFocusEvent in class Component
        参数：
        e - the FocusEvent
        另请参见：
        FocusEvent

      • getActions

        public Action[] getActions()
        Fetches the command list for the editor. This is the list of commands supported by the plugged-in UI augmented by the collection of commands that the editor itself supports. These are useful for binding to events, such as in a keymap.
        重载：
        getActions in class JTextField
        返回：
        the command list

      • getUIClassID

        public String getUIClassID()
        Gets the class ID for a UI.
        重载：
        getUIClassID in class JTextField
        返回：
        the string "FormattedTextFieldUI"
        另请参见：
        JComponent.getUIClassID()

      • setDocument

        public void setDocument(Document doc)
        Associates the editor with a text document. The currently registered factory is used to build a view for the document, which gets displayed by the editor after revalidation. A PropertyChange event ("document") is propagated to each listener.
        重载：
        setDocument in class JTextField
        参数：
        doc - the document to display/edit
        另请参见：
        JTextComponent.getDocument()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n


JFormattedTextField.AbstractFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFormattedTextField.AbstractFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    DefaultFormatter
    封闭类：
    JFormattedTextField

    public abstract static class JFormattedTextField.AbstractFormatter
extends Object
implements Serializable
    Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object. AbstractFormatters can also enfore editing policies, or navigation policies, or manipulate the JFormattedTextField in any way it sees fit to enforce the desired policy.

    An AbstractFormatter can only be active in one JFormattedTextField at a time. JFormattedTextField invokes install when it is ready to use it followed by uninstall when done. Subclasses that wish to install additional state should override install and message super appropriately.

    Subclasses must override the conversion methods stringToValue and valueToString. Optionally they can override getActions, getNavigationFilter and getDocumentFilter to restrict the JFormattedTextField in a particular way.

    Subclasses that allow the JFormattedTextField to be in a temporarily invalid state should invoke setEditValid at the appropriate times.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      JFormattedTextField.AbstractFormatter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Object clone()
      Clones the AbstractFormatter.
      protected Action[] getActions()
      Subclass and override if you wish to provide a custom set of Actions.
      protected DocumentFilter getDocumentFilter()
      Subclass and override if you wish to provide a DocumentFilter to restrict what can be input.
      protected JFormattedTextField getFormattedTextField()
      Returns the current JFormattedTextField the AbstractFormatter is installed on.
      protected NavigationFilter getNavigationFilter()
      Subclass and override if you wish to provide a filter to restrict where the user can navigate to.
      void install(JFormattedTextField ftf)
      Installs the AbstractFormatter onto a particular JFormattedTextField.
      protected void invalidEdit()
      This should be invoked when the user types an invalid character.
      protected void setEditValid(boolean valid)
      Invoke this to update the editValid property of the JFormattedTextField.
      abstract Object stringToValue(String text)
      Parses text returning an arbitrary Object.
      void uninstall()
      Uninstalls any state the AbstractFormatter may have installed on the JFormattedTextField.
      abstract String valueToString(Object value)
      Returns the string value to display for value.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JFormattedTextField.AbstractFormatter

        public JFormattedTextField.AbstractFormatter()

    • 方法详细信息

      • install

        public void install(JFormattedTextField ftf)
        Installs the AbstractFormatter onto a particular JFormattedTextField. This will invoke valueToString to convert the current value from the JFormattedTextField to a String. This will then install the Actions from getActions, the DocumentFilter returned from getDocumentFilter and the NavigationFilter returned from getNavigationFilter onto the JFormattedTextField.

        Subclasses will typically only need to override this if they wish to install additional listeners on the JFormattedTextField.

        If there is a ParseException in converting the current value to a String, this will set the text to an empty String, and mark the JFormattedTextField as being in an invalid state.

        While this is a public method, this is typically only useful for subclassers of JFormattedTextField. JFormattedTextField will invoke this method at the appropriate times when the value changes, or its internal state changes. You will only need to invoke this yourself if you are subclassing JFormattedTextField and installing/uninstalling AbstractFormatter at a different time than JFormattedTextField does.

        参数：
        ftf - JFormattedTextField to format for, may be null indicating uninstall from current JFormattedTextField.

      • uninstall

        public void uninstall()
        Uninstalls any state the AbstractFormatter may have installed on the JFormattedTextField. This resets the DocumentFilter, NavigationFilter and additional Actions installed on the JFormattedTextField.

      • stringToValue

        public abstract Object stringToValue(String text)
                              throws ParseException
        Parses text returning an arbitrary Object. Some formatters may return null.
        参数：
        text - String to convert
        返回：
        Object representation of text
        抛出：
        ParseException - if there is an error in the conversion

      • valueToString

        public abstract String valueToString(Object value)
                              throws ParseException
        Returns the string value to display for value.
        参数：
        value - Value to convert
        返回：
        String representation of value
        抛出：
        ParseException - if there is an error in the conversion

      • getFormattedTextField

        protected JFormattedTextField getFormattedTextField()
        Returns the current JFormattedTextField the AbstractFormatter is installed on.
        返回：
        JFormattedTextField formatting for.

      • invalidEdit

        protected void invalidEdit()
        This should be invoked when the user types an invalid character. This forwards the call to the current JFormattedTextField.

      • setEditValid

        protected void setEditValid(boolean valid)
        Invoke this to update the editValid property of the JFormattedTextField. If you an enforce a policy such that the JFormattedTextField is always in a valid state, you will never need to invoke this.
        参数：
        valid - Valid state of the JFormattedTextField

      • getActions

        protected Action[] getActions()
        Subclass and override if you wish to provide a custom set of Actions. install will install these on the JFormattedTextField's ActionMap.
        返回：
        Array of Actions to install on JFormattedTextField

      • getDocumentFilter

        protected DocumentFilter getDocumentFilter()
        Subclass and override if you wish to provide a DocumentFilter to restrict what can be input. install will install the returned value onto the JFormattedTextField.
        返回：
        DocumentFilter to restrict edits

      • getNavigationFilter

        protected NavigationFilter getNavigationFilter()
        Subclass and override if you wish to provide a filter to restrict where the user can navigate to. install will install the returned value onto the JFormattedTextField.
        返回：
        NavigationFilter to restrict navigation

      • clone

        protected Object clone()
                throws CloneNotSupportedException
        Clones the AbstractFormatter. The returned instance is not associated with a JFormattedTextField.
        重载：
        clone in class Object
        返回：
        Copy of the AbstractFormatter
        抛出：
        CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

E_Ftmo/po/gJJ/gg/.<


JFormattedTextField.AbstractFormatterFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFormattedTextField.AbstractFormatterFactory

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
  • 直接已知子类：
    DefaultFormatterFactory
    封闭类：
    JFormattedTextField

    public abstract static class JFormattedTextField.AbstractFormatterFactory
extends Object
    Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values. AbstractFormatterFactory can return different AbstractFormatters based on the state of the JFormattedTextField, perhaps returning different AbstractFormatters when the JFormattedTextField has focus vs when it doesn't have focus.
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      JFormattedTextField.AbstractFormatterFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField tf)
      Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JFormattedTextField.AbstractFormatterFactory

        public JFormattedTextField.AbstractFormatterFactory()

    • 方法详细信息

      • getFormatter

        public abstract JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField tf)
        Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.
        参数：
        tf - JFormattedTextField requesting AbstractFormatter
        返回：
        AbstractFormatter to handle formatting duties, a null return value implies the JFormattedTextField should behave like a normal JTextField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>mhosMdsM>eeM>>> eei"m>eiLLlll af


JFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFrame

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • java.awt.Frame
            • javax.swing.JFrame
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants

    public class JFrame
extends Frame
implements WindowConstants, Accessible, RootPaneContainer
    An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture. You can find task-oriented documentation about using JFrame in The Java Tutorial, in the section How to Make Frames.

    The JFrame class is slightly incompatible with Frame. Like all other JFC/Swing top-level containers, a JFrame contains a JRootPane as its only child. The content pane provided by the root pane should, as a rule, contain all the non-menu components displayed by the JFrame. This is different from the AWT Frame case. As a conveniance add and its variants, remove and setLayout have been overridden to forward to the contentPane as necessary. This means you can write:

           frame.add(child);
    And the child will be added to the contentPane. The content pane will always be non-null. Attempting to set it to null will cause the JFrame to throw an exception. The default content pane will have a BorderLayout manager set on it. Refer to RootPaneContainer for details on adding, removing and setting the LayoutManager of a JFrame.

    Unlike a Frame, a JFrame has some notion of how to respond when the user attempts to close the window. The default behavior is to simply hide the JFrame when the user closes the window. To change the default behavior, you invoke the method setDefaultCloseOperation(int). To make the JFrame behave the same as a Frame instance, use setDefaultCloseOperation(WindowConstants.DO_NOTHING_ON_CLOSE).

    For more information on content panes and other features that root panes provide, see Using Top-Level Containers in The Java Tutorial.

    In a multi-screen environment, you can create a JFrame on a different screen device. See Frame for more information.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JRootPane, setDefaultCloseOperation(int), WindowListener.windowClosing(java.awt.event.WindowEvent), RootPaneContainer

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JFrame.AccessibleJFrame
      This class implements accessibility support for the JFrame class.

      • Nested classes/interfaces inherited from class java.awt.Frame

        Frame.AccessibleAWTFrame

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AccessibleContext accessibleContext
      The accessible context property.
      static int EXIT_ON_CLOSE
      The exit application default window close operation.
      protected JRootPane rootPane
      The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
      protected boolean rootPaneCheckingEnabled
      If true then calls to add and setLayout will be forwarded to the contentPane.

      • Fields inherited from class java.awt.Frame

        CROSSHAIR_CURSOR, DEFAULT_CURSOR, E_RESIZE_CURSOR, HAND_CURSOR, ICONIFIED, MAXIMIZED_BOTH, MAXIMIZED_HORIZ, MAXIMIZED_VERT, MOVE_CURSOR, N_RESIZE_CURSOR, NE_RESIZE_CURSOR, NORMAL, NW_RESIZE_CURSOR, S_RESIZE_CURSOR, SE_RESIZE_CURSOR, SW_RESIZE_CURSOR, TEXT_CURSOR, W_RESIZE_CURSOR, WAIT_CURSOR

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.WindowConstants

        DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, HIDE_ON_CLOSE

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JFrame()
      Constructs a new frame that is initially invisible.
      JFrame(GraphicsConfiguration gc)
      Creates a Frame in the specified GraphicsConfiguration of a screen device and a blank title.
      JFrame(String title)
      Creates a new, initially invisible Frame with the specified title.
      JFrame(String title, GraphicsConfiguration gc)
      Creates a JFrame with the specified title and the specified GraphicsConfiguration of a screen device.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified child Component.
      protected JRootPane createRootPane()
      Called by the constructor methods to create the default rootPane.
      protected void frameInit()
      Called by the constructors to init the JFrame properly.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JFrame.
      Container getContentPane()
      Returns the contentPane object for this frame.
      int getDefaultCloseOperation()
      Returns the operation that occurs when the user initiates a "close" on this frame.
      Component getGlassPane()
      Returns the glassPane object for this frame.
      Graphics getGraphics()
      Creates a graphics context for this component.
      JMenuBar getJMenuBar()
      Returns the menubar set on this frame.
      JLayeredPane getLayeredPane()
      Returns the layeredPane object for this frame.
      JRootPane getRootPane()
      Returns the rootPane object for this frame.
      TransferHandler getTransferHandler()
      Gets the transferHandler property.
      static boolean isDefaultLookAndFeelDecorated()
      Returns true if newly created JFrames should have their Window decorations provided by the current look and feel.
      protected boolean isRootPaneCheckingEnabled()
      Returns whether calls to add and setLayout are forwarded to the contentPane.
      protected String paramString()
      Returns a string representation of this JFrame.
      protected void processWindowEvent(WindowEvent e)
      Processes window events occurring on this component.
      void remove(Component comp)
      Removes the specified component from the container.
      void repaint(long time, int x, int y, int width, int height)
      Repaints the specified rectangle of this component within time milliseconds.
      void setContentPane(Container contentPane)
      Sets the contentPane property.
      void setDefaultCloseOperation(int operation)
      Sets the operation that will happen by default when the user initiates a "close" on this frame.
      static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
      Provides a hint as to whether or not newly created JFrames should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel.
      void setGlassPane(Component glassPane)
      Sets the glassPane property.
      void setIconImage(Image image)
      Sets the image to be displayed as the icon for this window.
      void setJMenuBar(JMenuBar menubar)
      Sets the menubar for this frame.
      void setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void setLayout(LayoutManager manager)
      Sets the LayoutManager.
      protected void setRootPane(JRootPane root)
      Sets the rootPane property.
      protected void setRootPaneCheckingEnabled(boolean enabled)
      Sets whether calls to add and setLayout are forwarded to the contentPane.
      void setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void update(Graphics g)
      Just calls paint(g).

      • 方法 - 继承于类 java.awt.Frame

        addNotify, getCursorType, getExtendedState, getFrames, getIconImage, getMaximizedBounds, getMenuBar, getState, getTitle, isResizable, isUndecorated, remove, removeNotify, setBackground, setCursor, setExtendedState, setMaximizedBounds, setMenuBar, setOpacity, setResizable, setShape, setState, setTitle, setUndecorated

      • 方法 - 继承于类 java.awt.Window

        addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowFocusEvent, processWindowStateEvent, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setType, setVisible, show, toBack, toFront

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.awt.MenuContainer

        getFont, postEvent

    • 字段详细信息

      • EXIT_ON_CLOSE

        public static final int EXIT_ON_CLOSE
        The exit application default window close operation. If a window has this set as the close operation and is closed in an applet, a SecurityException may be thrown. It is recommended you only use this in an application.

        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • rootPane

        protected JRootPane rootPane
        The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
        另请参见：
        JRootPane, RootPaneContainer

      • rootPaneCheckingEnabled

        protected boolean rootPaneCheckingEnabled
        If true then calls to add and setLayout will be forwarded to the contentPane. This is initially false, but is set to true when the JFrame is constructed.
        另请参见：
        isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • accessibleContext

        protected AccessibleContext accessibleContext
        The accessible context property.

    • 构造方法详细信息

      • JFrame

        public JFrame()
       throws HeadlessException
        Constructs a new frame that is initially invisible.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
JComponent.getDefaultLocale()

      • JFrame

        public JFrame(GraphicsConfiguration gc)
        Creates a Frame in the specified GraphicsConfiguration of a screen device and a blank title.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        gc - the GraphicsConfiguration that is used to construct the new Frame; if gc is null, the system default GraphicsConfiguration is assumed
        抛出：
        IllegalArgumentException - if gc is not from a screen device. This exception is always thrown when GraphicsEnvironment.isHeadless() returns true.
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

      • JFrame

        public JFrame(String title)
       throws HeadlessException
        Creates a new, initially invisible Frame with the specified title.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        title - the title for the frame
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
JComponent.getDefaultLocale()

      • JFrame

        public JFrame(String title,
      GraphicsConfiguration gc)
        Creates a JFrame with the specified title and the specified GraphicsConfiguration of a screen device.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        title - the title to be displayed in the frame's border. A null value is treated as an empty string, "".
        gc - the GraphicsConfiguration that is used to construct the new JFrame with; if gc is null, the system default GraphicsConfiguration is assumed
        抛出：
        IllegalArgumentException - if gc is not from a screen device. This exception is always thrown when GraphicsEnvironment.isHeadless() returns true.
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

    • 方法详细信息

      • frameInit

        protected void frameInit()
        Called by the constructors to init the JFrame properly.

      • createRootPane

        protected JRootPane createRootPane()
        Called by the constructor methods to create the default rootPane.

      • processWindowEvent

        protected void processWindowEvent(WindowEvent e)
        Processes window events occurring on this component. Hides the window or disposes of it, as specified by the setting of the defaultCloseOperation property.
        重载：
        processWindowEvent in class Window
        参数：
        e - the window event
        另请参见：
        setDefaultCloseOperation(int), Window.processWindowEvent(java.awt.event.WindowEvent)

      • setDefaultCloseOperation

        public void setDefaultCloseOperation(int operation)
        Sets the operation that will happen by default when the user initiates a "close" on this frame. You must specify one of the following choices:

        • DO_NOTHING_ON_CLOSE (defined in WindowConstants): Don't do anything; require the program to handle the operation in the windowClosing method of a registered WindowListener object.
        • HIDE_ON_CLOSE (defined in WindowConstants): Automatically hide the frame after invoking any registered WindowListener objects.
        • DISPOSE_ON_CLOSE (defined in WindowConstants): Automatically hide and dispose the frame after invoking any registered WindowListener objects.
        • EXIT_ON_CLOSE (defined in JFrame): Exit the application using the System exit method. Use this only in applications.

        The value is set to HIDE_ON_CLOSE by default. Changes to the value of this property cause the firing of a property change event, with property name "defaultCloseOperation".

        Note: When the last displayable window within the Java virtual machine (VM) is disposed of, the VM may terminate. See AWT Threading Issues for more information.

        参数：
        operation - the operation which should be performed when the user closes the frame
        抛出：
        IllegalArgumentException - if defaultCloseOperation value isn't one of the above valid values
        SecurityException - if EXIT_ON_CLOSE has been specified and the SecurityManager will not allow the caller to invoke System.exit
        另请参见：
        Window.addWindowListener(java.awt.event.WindowListener), getDefaultCloseOperation(), WindowConstants, Runtime.exit(int)

      • getDefaultCloseOperation

        public int getDefaultCloseOperation()
        Returns the operation that occurs when the user initiates a "close" on this frame.
        返回：
        an integer indicating the window-close operation
        另请参见：
        setDefaultCloseOperation(int)

      • setTransferHandler

        public void setTransferHandler(TransferHandler newHandler)
        Sets the transferHandler property, which is a mechanism to support transfer of data into this component. Use null if the component does not support data transfer operations.

        If the system property suppressSwingDropSupport is false (the default) and the current drop target on this component is either null or not a user-set drop target, this method will change the drop target as follows: If newHandler is null it will clear the drop target. If not null it will install a new DropTarget.

        Note: When used with JFrame, TransferHandler only provides data import capability, as the data export related methods are currently typed to JComponent.

        Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

        参数：
        newHandler - the new TransferHandler
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

      • getTransferHandler

        public TransferHandler getTransferHandler()
        Gets the transferHandler property.
        返回：
        the value of the transferHandler property
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, setTransferHandler(javax.swing.TransferHandler)

      • update

        public void update(Graphics g)
        Just calls paint(g). This method was overridden to prevent an unnecessary call to clear the background.
        重载：
        update in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        Component.update(Graphics)

      • setJMenuBar

        public void setJMenuBar(JMenuBar menubar)
        Sets the menubar for this frame.
        参数：
        menubar - the menubar being placed in the frame
        另请参见：
        getJMenuBar()

      • getJMenuBar

        public JMenuBar getJMenuBar()
        Returns the menubar set on this frame.
        返回：
        the menubar for this frame
        另请参见：
        setJMenuBar(javax.swing.JMenuBar)

      • isRootPaneCheckingEnabled

        protected boolean isRootPaneCheckingEnabled()
        Returns whether calls to add and setLayout are forwarded to the contentPane.
        返回：
        true if add and setLayout are fowarded; false otherwise
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • setRootPaneCheckingEnabled

        protected void setRootPaneCheckingEnabled(boolean enabled)
        Sets whether calls to add and setLayout are forwarded to the contentPane.
        参数：
        enabled - true if add and setLayout are forwarded, false if they should operate directly on the JFrame.
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified child Component. This method is overridden to conditionally forward calls to the contentPane. By default, children are added to the contentPane instead of the frame, refer to RootPaneContainer for details.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • remove

        public void remove(Component comp)
        Removes the specified component from the container. If comp is not the rootPane, this will forward the call to the contentPane. This will do nothing if comp is not a child of the JFrame or contentPane.
        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        抛出：
        NullPointerException - if comp is null
        另请参见：
        Container.add(java.awt.Component), RootPaneContainer

      • setLayout

        public void setLayout(LayoutManager manager)
        Sets the LayoutManager. Overridden to conditionally forward the call to the contentPane. Refer to RootPaneContainer for more information.
        重载：
        setLayout in class Container
        参数：
        manager - the LayoutManager
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • getRootPane

        public JRootPane getRootPane()
        Returns the rootPane object for this frame.
        指定者：
        getRootPane in interface RootPaneContainer
        返回：
        the rootPane property
        另请参见：
        setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

      • setRootPane

        protected void setRootPane(JRootPane root)
        Sets the rootPane property. This method is called by the constructor.
        参数：
        root - the rootPane object for this frame
        另请参见：
        getRootPane()

      • setIconImage

        public void setIconImage(Image image)
        Sets the image to be displayed as the icon for this window.

        This method can be used instead of setIconImages() to specify a single image as a window's icon.

        The following statement:

             setIconImage(image);
        is equivalent to:
             ArrayList<Image> imageList = new ArrayList<Image>();
     imageList.add(image);
     setIconImages(imageList);

        Note : Native windowing systems may use different images of differing dimensions to represent a window, depending on the context (e.g. window decoration, window list, taskbar, etc.). They could also use just a single image for all contexts or no image at all.

        重载：
        setIconImage in class Frame
        参数：
        image - the icon image to be displayed.
        另请参见：
        Window.setIconImages(java.util.List), Window.getIconImages()

      • getContentPane

        public Container getContentPane()
        Returns the contentPane object for this frame.
        指定者：
        getContentPane in interface RootPaneContainer
        返回：
        the contentPane property
        另请参见：
        setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

      • setContentPane

        public void setContentPane(Container contentPane)
        Sets the contentPane property. This method is called by the constructor.

        Swing's painting architecture requires an opaque JComponent in the containment hiearchy. This is typically provided by the content pane. If you replace the content pane it is recommended you replace it with an opaque JComponent.

        指定者：
        setContentPane in interface RootPaneContainer
        参数：
        contentPane - the contentPane object for this frame
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        getContentPane(), RootPaneContainer.setContentPane(java.awt.Container), JRootPane

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Returns the layeredPane object for this frame.
        指定者：
        getLayeredPane in interface RootPaneContainer
        返回：
        the layeredPane property
        另请参见：
        setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layeredPane)
        Sets the layeredPane property. This method is called by the constructor.
        指定者：
        setLayeredPane in interface RootPaneContainer
        参数：
        layeredPane - the layeredPane object for this frame
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null
        另请参见：
        getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

      • getGlassPane

        public Component getGlassPane()
        Returns the glassPane object for this frame.
        指定者：
        getGlassPane in interface RootPaneContainer
        返回：
        the glassPane property
        另请参见：
        setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

      • setGlassPane

        public void setGlassPane(Component glassPane)
        Sets the glassPane property. This method is called by the constructor.
        指定者：
        setGlassPane in interface RootPaneContainer
        参数：
        glassPane - the glassPane object for this frame
        另请参见：
        getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

      • getGraphics

        public Graphics getGraphics()
        Creates a graphics context for this component. This method will return null if this component is currently not displayable.
        重载：
        getGraphics in class Component
        返回：
        a graphics context for this component, or null if it has none
        从以下版本开始：
        1.6
        另请参见：
        Component.paint(java.awt.Graphics)

      • repaint

        public void repaint(long time,
           int x,
           int y,
           int width,
           int height)
        Repaints the specified rectangle of this component within time milliseconds. Refer to RepaintManager for details on how the repaint is handled.
        重载：
        repaint in class Component
        参数：
        time - maximum time in milliseconds before update
        x - the x coordinate
        y - the y coordinate
        width - the width
        height - the height
        从以下版本开始：
        1.6
        另请参见：
        RepaintManager

      • setDefaultLookAndFeelDecorated

        public static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
        Provides a hint as to whether or not newly created JFrames should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel. If defaultLookAndFeelDecorated is true, the current LookAndFeel supports providing window decorations, and the current window manager supports undecorated windows, then newly created JFrames will have their Window decorations provided by the current LookAndFeel. Otherwise, newly created JFrames will have their Window decorations provided by the current window manager.

        You can get the same effect on a single JFrame by doing the following:

            JFrame frame = new JFrame();
    frame.setUndecorated(true);
    frame.getRootPane().setWindowDecorationStyle(JRootPane.FRAME);
        参数：
        defaultLookAndFeelDecorated - A hint as to whether or not current look and feel should provide window decorations
        从以下版本开始：
        1.4
        另请参见：
        LookAndFeel.getSupportsWindowDecorations()

      • isDefaultLookAndFeelDecorated

        public static boolean isDefaultLookAndFeelDecorated()
        Returns true if newly created JFrames should have their Window decorations provided by the current look and feel. This is only a hint, as certain look and feels may not support this feature.
        返回：
        true if look and feel should provide Window decorations.
        从以下版本开始：
        1.4

      • paramString

        protected String paramString()
        Returns a string representation of this JFrame. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class Frame
        返回：
        a string representation of this JFrame

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JFrame. For JFrames, the AccessibleContext takes the form of an AccessibleJFrame. A new AccessibleJFrame instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class Frame
        返回：
        an AccessibleJFrame that serves as the AccessibleContext of this JFrame
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JFrame.AccessibleJFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JFrame.AccessibleJFrame

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    JFrame

    protected class JFrame.AccessibleJFrame
extends Frame.AccessibleAWTFrame
    This class implements accessibility support for the JFrame class. It provides an implementation of the Java Accessibility API appropriate to frame user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JFrame.AccessibleJFrame()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAccessibleName()
      Get the accessible name of this object.
      AccessibleStateSet getAccessibleStateSet()
      Get the state of this object.

      • 方法 - 继承于类 java.awt.Frame.AccessibleAWTFrame

        getAccessibleRole

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JFrame.AccessibleJFrame

        protected JFrame.AccessibleJFrame()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Get the accessible name of this object.
        重载：
        getAccessibleName in class Component.AccessibleAWTComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state of this object.
        重载：
        getAccessibleStateSet in class Frame.AccessibleAWTFrame
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"ldr>C">CwooCwws<<


JInternalFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JInternalFrame

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JInternalFrame
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants

    public class JInternalFrame
extends JComponent
implements Accessible, WindowConstants, RootPaneContainer
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar. For task-oriented documentation and examples of using internal frames, see How to Use Internal Frames, a section in The Java Tutorial.

    Generally, you add JInternalFrames to a JDesktopPane. The UI delegates the look-and-feel-specific actions to the DesktopManager object maintained by the JDesktopPane.

    The JInternalFrame content pane is where you add child components. As a conveniance add and its variants, remove and setLayout have been overridden to forward to the contentPane as necessary. This means you can write:

           internalFrame.add(child);
    And the child will be added to the contentPane. The content pane is actually managed by an instance of JRootPane, which also manages a layout pane, glass pane, and optional menu bar for the internal frame. Please see the JRootPane documentation for a complete description of these components. Refer to RootPaneContainer for details on adding, removing and setting the LayoutManager of a JInternalFrame.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    InternalFrameEvent, JDesktopPane, DesktopManager, JInternalFrame.JDesktopIcon, JRootPane, RootPaneContainer

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JInternalFrame.AccessibleJInternalFrame
      This class implements accessibility support for the JInternalFrame class.
      static class  JInternalFrame.JDesktopIcon
      This component represents an iconified version of a JInternalFrame.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean closable
      The frame can be closed.
      static String CONTENT_PANE_PROPERTY
      Bound property name.
      protected JInternalFrame.JDesktopIcon desktopIcon
      The icon that is displayed when this internal frame is iconified.
      static String FRAME_ICON_PROPERTY
      Bound property name.
      protected Icon frameIcon
      The icon shown in the top-left corner of this internal frame.
      static String GLASS_PANE_PROPERTY
      Bound property name.
      protected boolean iconable
      The frame can "iconified" (shrunk down and displayed as an icon-image).
      static String IS_CLOSED_PROPERTY
      Constrained property name indicating that the internal frame is closed.
      static String IS_ICON_PROPERTY
      Constrained property name indicating that the internal frame is iconified.
      static String IS_MAXIMUM_PROPERTY
      Constrained property name indicating that the internal frame is maximized.
      static String IS_SELECTED_PROPERTY
      Constrained property name indicated that this frame has selected status.
      protected boolean isClosed
      The frame has been closed.
      protected boolean isIcon
      The frame has been iconified.
      protected boolean isMaximum
      The frame has been expanded to its maximum size.
      protected boolean isSelected
      The frame is currently selected.
      static String LAYERED_PANE_PROPERTY
      Bound property name.
      protected boolean maximizable
      The frame can be expanded to the size of the desktop pane.
      static String MENU_BAR_PROPERTY
      Bound property name.
      protected boolean resizable
      The frame's size can be changed.
      static String ROOT_PANE_PROPERTY
      Bound property name.
      protected JRootPane rootPane
      The JRootPane instance that manages the content pane and optional menu bar for this internal frame, as well as the glass pane.
      protected boolean rootPaneCheckingEnabled
      If true then calls to add and setLayout will be forwarded to the contentPane.
      protected String title
      The title displayed in this internal frame's title bar.
      static String TITLE_PROPERTY
      Bound property name.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.WindowConstants

        DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, EXIT_ON_CLOSE, HIDE_ON_CLOSE

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JInternalFrame()
      Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with no title.
      JInternalFrame(String title)
      Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title.
      JInternalFrame(String title, boolean resizable)
      Creates a non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title and resizability.
      JInternalFrame(String title, boolean resizable, boolean closable)
      Creates a non-maximizable, non-iconifiable JInternalFrame with the specified title, resizability, and closability.
      JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable)
      Creates a non-iconifiable JInternalFrame with the specified title, resizability, closability, and maximizability.
      JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable)
      Creates a JInternalFrame with the specified title, resizability, closability, maximizability, and iconifiability.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified child Component.
      void addInternalFrameListener(InternalFrameListener l)
      Adds the specified listener to receive internal frame events from this internal frame.
      protected JRootPane createRootPane()
      Called by the constructor to set up the JRootPane.
      void dispose()
      Makes this internal frame invisible, unselected, and closed.
      void doDefaultCloseAction()
      Fires an INTERNAL_FRAME_CLOSING event and then performs the action specified by the internal frame's default close operation.
      protected void fireInternalFrameEvent(int id)
      Fires an internal frame event.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JInternalFrame.
      Container getContentPane()
      Returns the content pane for this internal frame.
      int getDefaultCloseOperation()
      Returns the default operation that occurs when the user initiates a "close" on this internal frame.
      JInternalFrame.JDesktopIcon getDesktopIcon()
      Returns the JDesktopIcon used when this JInternalFrame is iconified.
      JDesktopPane getDesktopPane()
      Convenience method that searches the ancestor hierarchy for a JDesktop instance.
      Container getFocusCycleRootAncestor()
      Always returns null because JInternalFrames must always be roots of a focus traversal cycle.
      Component getFocusOwner()
      If this JInternalFrame is active, returns the child that has focus.
      Icon getFrameIcon()
      Returns the image displayed in the title bar of this internal frame (usually in the top-left corner).
      Component getGlassPane()
      Returns the glass pane for this internal frame.
      InternalFrameListener[] getInternalFrameListeners()
      Returns an array of all the InternalFrameListeners added to this JInternalFrame with addInternalFrameListener.
      JMenuBar getJMenuBar()
      Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.
      Cursor getLastCursor()
      Returns the last Cursor that was set by the setCursor method that is not a resizable Cursor.
      int getLayer()
      Convenience method for getting the layer attribute of this component.
      JLayeredPane getLayeredPane()
      Returns the layered pane for this internal frame.
      JMenuBar getMenuBar()
      Deprecated.
      As of Swing version 1.0.3, replaced by getJMenuBar().
      Component getMostRecentFocusOwner()
      Returns the child component of this JInternalFrame that will receive the focus when this JInternalFrame is selected.
      Rectangle getNormalBounds()
      If the JInternalFrame is not in maximized state, returns getBounds(); otherwise, returns the bounds that the JInternalFrame would be restored to.
      JRootPane getRootPane()
      Returns the rootPane object for this internal frame.
      String getTitle()
      Returns the title of the JInternalFrame.
      InternalFrameUI getUI()
      Returns the look-and-feel object that renders this component.
      String getUIClassID()
      Returns the name of the look-and-feel class that renders this component.
      String getWarningString()
      Gets the warning string that is displayed with this internal frame.
      void | hide()
      boolean isClosable()
      Returns whether this JInternalFrame can be closed by some user action.
      boolean isClosed()
      Returns whether this JInternalFrame is currently closed.
      boolean isFocusCycleRoot()
      Always returns true because all JInternalFrames must be roots of a focus traversal cycle.
      boolean isIcon()
      Returns whether the JInternalFrame is currently iconified.
      boolean isIconifiable()
      Gets the iconable property, which by default is false.
      boolean isMaximizable()
      Gets the value of the maximizable property.
      boolean isMaximum()
      Returns whether the JInternalFrame is currently maximized.
      boolean isResizable()
      Returns whether the JInternalFrame can be resized by some user action.
      protected boolean isRootPaneCheckingEnabled()
      Returns whether calls to add and setLayout are forwarded to the contentPane.
      boolean isSelected()
      Returns whether the JInternalFrame is the currently "selected" or active frame.
      void moveToBack()
      Convenience method that moves this component to position -1 if its parent is a JLayeredPane.
      void moveToFront()
      Convenience method that moves this component to position 0 if its parent is a JLayeredPane.
      void pack()
      Causes subcomponents of this JInternalFrame to be laid out at their preferred size.
      protected void paintComponent(Graphics g)
      Overridden to allow optimized painting when the internal frame is being dragged.
      protected String paramString()
      Returns a string representation of this JInternalFrame.
      void remove(Component comp)
      Removes the specified component from the container.
      void removeInternalFrameListener(InternalFrameListener l)
      Removes the specified internal frame listener so that it no longer receives internal frame events from this internal frame.
      void reshape(int x, int y, int width, int height)
      Moves and resizes this component.
      void restoreSubcomponentFocus()
      Requests the internal frame to restore focus to the last subcomponent that had focus.
      void setClosable(boolean b)
      Sets whether this JInternalFrame can be closed by some user action.
      void setClosed(boolean b)
      Closes this internal frame if the argument is true.
      void setContentPane(Container c)
      Sets this JInternalFrame's contentPane property.
      void setCursor(Cursor cursor)
      Sets the cursor image to the specified cursor.
      void setDefaultCloseOperation(int operation)
      Sets the operation that will happen by default when the user initiates a "close" on this internal frame.
      void setDesktopIcon(JInternalFrame.JDesktopIcon d)
      Sets the JDesktopIcon associated with this JInternalFrame.
      void setFocusCycleRoot(boolean focusCycleRoot)
      Does nothing because JInternalFrames must always be roots of a focus traversal cycle.
      void setFrameIcon(Icon icon)
      Sets an image to be displayed in the titlebar of this internal frame (usually in the top-left corner).
      void setGlassPane(Component glass)
      Sets this JInternalFrame's glassPane property.
      void setIcon(boolean b)
      Iconifies or de-iconifies this internal frame, if the look and feel supports iconification.
      void setIconifiable(boolean b)
      Sets the iconable property, which must be true for the user to be able to make the JInternalFrame an icon.
      void setJMenuBar(JMenuBar m)
      Sets the menuBar property for this JInternalFrame.
      void setLayer(int layer)
      Convenience method for setting the layer attribute of this component.
      void setLayer(Integer layer)
      Convenience method for setting the layer attribute of this component.
      void setLayeredPane(JLayeredPane layered)
      Sets this JInternalFrame's layeredPane property.
      void setLayout(LayoutManager manager)
      Ensures that, by default, the layout of this component cannot be set.
      void setMaximizable(boolean b)
      Sets the maximizable property, which determines whether the JInternalFrame can be maximized by some user action.
      void setMaximum(boolean b)
      Maximizes and restores this internal frame.
      void setMenuBar(JMenuBar m)
      Deprecated.
      As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar m).
      void setNormalBounds(Rectangle r)
      Sets the normal bounds for this internal frame, the bounds that this internal frame would be restored to from its maximized state.
      void setResizable(boolean b)
      Sets whether the JInternalFrame can be resized by some user action.
      protected void setRootPane(JRootPane root)
      Sets the rootPane property for this JInternalFrame.
      protected void setRootPaneCheckingEnabled(boolean enabled)
      Sets whether calls to add and setLayout are forwarded to the contentPane.
      void setSelected(boolean selected)
      Selects or deselects the internal frame if it's showing.
      void setTitle(String title)
      Sets the JInternalFrame title.
      void setUI(InternalFrameUI ui)
      Sets the UI delegate for this JInternalFrame.
      void show()
      If the internal frame is not visible, brings the internal frame to the front, makes it visible, and attempts to select it.
      void toBack()
      Sends this internal frame to the back.
      void toFront()
      Brings this internal frame to the front.
      void updateUI()
      Notification from the UIManager that the look and feel has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • rootPane

        protected JRootPane rootPane
        The JRootPane instance that manages the content pane and optional menu bar for this internal frame, as well as the glass pane.
        另请参见：
        JRootPane, RootPaneContainer

      • rootPaneCheckingEnabled

        protected boolean rootPaneCheckingEnabled
        If true then calls to add and setLayout will be forwarded to the contentPane. This is initially false, but is set to true when the JInternalFrame is constructed.
        另请参见：
        isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • closable

        protected boolean closable
        The frame can be closed.

      • isClosed

        protected boolean isClosed
        The frame has been closed.

      • maximizable

        protected boolean maximizable
        The frame can be expanded to the size of the desktop pane.

      • isMaximum

        protected boolean isMaximum
        The frame has been expanded to its maximum size.
        另请参见：
        maximizable

      • iconable

        protected boolean iconable
        The frame can "iconified" (shrunk down and displayed as an icon-image).
        另请参见：
        JInternalFrame.JDesktopIcon, setIconifiable(boolean)

      • isIcon

        protected boolean isIcon
        The frame has been iconified.
        另请参见：
        isIcon()

      • resizable

        protected boolean resizable
        The frame's size can be changed.

      • isSelected

        protected boolean isSelected
        The frame is currently selected.

      • frameIcon

        protected Icon frameIcon
        The icon shown in the top-left corner of this internal frame.

      • title

        protected String title
        The title displayed in this internal frame's title bar.

      • desktopIcon

        protected JInternalFrame.JDesktopIcon desktopIcon
        The icon that is displayed when this internal frame is iconified.
        另请参见：
        iconable

      • CONTENT_PANE_PROPERTY

        public static final String CONTENT_PANE_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • MENU_BAR_PROPERTY

        public static final String MENU_BAR_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • TITLE_PROPERTY

        public static final String TITLE_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • LAYERED_PANE_PROPERTY

        public static final String LAYERED_PANE_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • ROOT_PANE_PROPERTY

        public static final String ROOT_PANE_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • GLASS_PANE_PROPERTY

        public static final String GLASS_PANE_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • FRAME_ICON_PROPERTY

        public static final String FRAME_ICON_PROPERTY
        Bound property name.
        另请参见：
        Constant Field Values

      • IS_SELECTED_PROPERTY

        public static final String IS_SELECTED_PROPERTY
        Constrained property name indicated that this frame has selected status.
        另请参见：
        Constant Field Values

      • IS_CLOSED_PROPERTY

        public static final String IS_CLOSED_PROPERTY
        Constrained property name indicating that the internal frame is closed.
        另请参见：
        Constant Field Values

      • IS_MAXIMUM_PROPERTY

        public static final String IS_MAXIMUM_PROPERTY
        Constrained property name indicating that the internal frame is maximized.
        另请参见：
        Constant Field Values

      • IS_ICON_PROPERTY

        public static final String IS_ICON_PROPERTY
        Constrained property name indicating that the internal frame is iconified.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JInternalFrame

        public JInternalFrame()
        Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with no title.

      • JInternalFrame

        public JInternalFrame(String title)
        Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title. Note that passing in a null title results in unspecified behavior and possibly an exception.
        参数：
        title - the non-null String to display in the title bar

      • JInternalFrame

        public JInternalFrame(String title,
              boolean resizable)
        Creates a non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title and resizability.
        参数：
        title - the String to display in the title bar
        resizable - if true, the internal frame can be resized

      • JInternalFrame

        public JInternalFrame(String title,
              boolean resizable,
              boolean closable)
        Creates a non-maximizable, non-iconifiable JInternalFrame with the specified title, resizability, and closability.
        参数：
        title - the String to display in the title bar
        resizable - if true, the internal frame can be resized
        closable - if true, the internal frame can be closed

      • JInternalFrame

        public JInternalFrame(String title,
              boolean resizable,
              boolean closable,
              boolean maximizable)
        Creates a non-iconifiable JInternalFrame with the specified title, resizability, closability, and maximizability.
        参数：
        title - the String to display in the title bar
        resizable - if true, the internal frame can be resized
        closable - if true, the internal frame can be closed
        maximizable - if true, the internal frame can be maximized

      • JInternalFrame

        public JInternalFrame(String title,
              boolean resizable,
              boolean closable,
              boolean maximizable,
              boolean iconifiable)
        Creates a JInternalFrame with the specified title, resizability, closability, maximizability, and iconifiability. All JInternalFrame constructors use this one.
        参数：
        title - the String to display in the title bar
        resizable - if true, the internal frame can be resized
        closable - if true, the internal frame can be closed
        maximizable - if true, the internal frame can be maximized
        iconifiable - if true, the internal frame can be iconified

    • 方法详细信息

      • createRootPane

        protected JRootPane createRootPane()
        Called by the constructor to set up the JRootPane.
        返回：
        a new JRootPane
        另请参见：
        JRootPane

      • getUI

        public InternalFrameUI getUI()
        Returns the look-and-feel object that renders this component.
        返回：
        the InternalFrameUI object that renders this component

      • setUI

        public void setUI(InternalFrameUI ui)
        Sets the UI delegate for this JInternalFrame.
        参数：
        ui - the UI delegate

      • updateUI

        public void updateUI()
        Notification from the UIManager that the look and feel has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the look-and-feel class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "InternalFrameUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • isRootPaneCheckingEnabled

        protected boolean isRootPaneCheckingEnabled()
        Returns whether calls to add and setLayout are forwarded to the contentPane.
        返回：
        true if add and setLayout are fowarded; false otherwise
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • setRootPaneCheckingEnabled

        protected void setRootPaneCheckingEnabled(boolean enabled)
        Sets whether calls to add and setLayout are forwarded to the contentPane.
        参数：
        enabled - true if add and setLayout are forwarded, false if they should operate directly on the JInternalFrame.
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified child Component. This method is overridden to conditionally forward calls to the contentPane. By default, children are added to the contentPane instead of the frame, refer to RootPaneContainer for details.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • remove

        public void remove(Component comp)
        Removes the specified component from the container. If comp is not a child of the JInternalFrame this will forward the call to the contentPane.
        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        抛出：
        NullPointerException - if comp is null
        另请参见：
        Container.add(java.awt.Component), RootPaneContainer

      • setLayout

        public void setLayout(LayoutManager manager)
        Ensures that, by default, the layout of this component cannot be set. Overridden to conditionally forward the call to the contentPane. Refer to RootPaneContainer for more information.
        重载：
        setLayout in class Container
        参数：
        manager - the LayoutManager
        另请参见：
        setRootPaneCheckingEnabled(boolean)

      • getMenuBar

        @Deprecated
public JMenuBar getMenuBar()
        Deprecated. As of Swing version 1.0.3, replaced by getJMenuBar().
        Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.
        返回：
        the current menu bar, or null if none has been set

      • getJMenuBar

        public JMenuBar getJMenuBar()
        Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.
        返回：
        the JMenuBar used by this internal frame
        另请参见：
        setJMenuBar(javax.swing.JMenuBar)

      • setMenuBar

        @Deprecated
public void setMenuBar(JMenuBar m)
        Deprecated. As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar m).
        Sets the menuBar property for this JInternalFrame.
        参数：
        m - the JMenuBar to use in this internal frame
        另请参见：
        getJMenuBar()

      • setJMenuBar

        public void setJMenuBar(JMenuBar m)
        Sets the menuBar property for this JInternalFrame.
        参数：
        m - the JMenuBar to use in this internal frame
        另请参见：
        getJMenuBar()

      • getContentPane

        public Container getContentPane()
        Returns the content pane for this internal frame.
        指定者：
        getContentPane in interface RootPaneContainer
        返回：
        the content pane
        另请参见：
        RootPaneContainer.setContentPane(java.awt.Container)

      • setContentPane

        public void setContentPane(Container c)
        Sets this JInternalFrame's contentPane property.
        指定者：
        setContentPane in interface RootPaneContainer
        参数：
        c - the content pane for this internal frame
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        RootPaneContainer.getContentPane()

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Returns the layered pane for this internal frame.
        指定者：
        getLayeredPane in interface RootPaneContainer
        返回：
        a JLayeredPane object
        另请参见：
        RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layered)
        Sets this JInternalFrame's layeredPane property.
        指定者：
        setLayeredPane in interface RootPaneContainer
        参数：
        layered - the JLayeredPane for this internal frame
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null
        另请参见：
        RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

      • getGlassPane

        public Component getGlassPane()
        Returns the glass pane for this internal frame.
        指定者：
        getGlassPane in interface RootPaneContainer
        返回：
        the glass pane
        另请参见：
        RootPaneContainer.setGlassPane(java.awt.Component)

      • setGlassPane

        public void setGlassPane(Component glass)
        Sets this JInternalFrame's glassPane property.
        指定者：
        setGlassPane in interface RootPaneContainer
        参数：
        glass - the glass pane for this internal frame
        另请参见：
        RootPaneContainer.getGlassPane()

      • getRootPane

        public JRootPane getRootPane()
        Returns the rootPane object for this internal frame.
        指定者：
        getRootPane in interface RootPaneContainer
        重载：
        getRootPane in class JComponent
        返回：
        the rootPane property
        另请参见：
        RootPaneContainer.getRootPane()

      • setRootPane

        protected void setRootPane(JRootPane root)
        Sets the rootPane property for this JInternalFrame. This method is called by the constructor.
        参数：
        root - the new JRootPane object

      • setClosable

        public void setClosable(boolean b)
        Sets whether this JInternalFrame can be closed by some user action.
        参数：
        b - a boolean value, where true means this internal frame can be closed

      • isClosable

        public boolean isClosable()
        Returns whether this JInternalFrame can be closed by some user action.
        返回：
        true if this internal frame can be closed

      • isClosed

        public boolean isClosed()
        Returns whether this JInternalFrame is currently closed.
        返回：
        true if this internal frame is closed, false otherwise

      • setClosed

        public void setClosed(boolean b)
               throws PropertyVetoException
        Closes this internal frame if the argument is true. Do not invoke this method with a false argument; the result of invoking setClosed(false) is unspecified.

        If the internal frame is already closed, this method does nothing and returns immediately. Otherwise, this method begins by firing an INTERNAL_FRAME_CLOSING event. Then this method sets the closed property to true unless a listener vetoes the property change. This method finishes by making the internal frame invisible and unselected, and then firing an INTERNAL_FRAME_CLOSED event.

        Note: To reuse an internal frame that has been closed, you must add it to a container (even if you never removed it from its previous container). Typically, this container will be the JDesktopPane that previously contained the internal frame.

        参数：
        b - must be true
        抛出：
        PropertyVetoException - when the attempt to set the property is vetoed by the JInternalFrame
        另请参见：
        isClosed(), setDefaultCloseOperation(int), dispose(), InternalFrameEvent.INTERNAL_FRAME_CLOSING

      • setResizable

        public void setResizable(boolean b)
        Sets whether the JInternalFrame can be resized by some user action.
        参数：
        b - a boolean, where true means this internal frame can be resized

      • isResizable

        public boolean isResizable()
        Returns whether the JInternalFrame can be resized by some user action.
        返回：
        true if this internal frame can be resized, false otherwise

      • setIconifiable

        public void setIconifiable(boolean b)
        Sets the iconable property, which must be true for the user to be able to make the JInternalFrame an icon. Some look and feels might not implement iconification; they will ignore this property.
        参数：
        b - a boolean, where true means this internal frame can be iconified

      • isIconifiable

        public boolean isIconifiable()
        Gets the iconable property, which by default is false.
        返回：
        the value of the iconable property.
        另请参见：
        setIconifiable(boolean)

      • isIcon

        public boolean isIcon()
        Returns whether the JInternalFrame is currently iconified.
        返回：
        true if this internal frame is iconified

      • setIcon

        public void setIcon(boolean b)
             throws PropertyVetoException
        Iconifies or de-iconifies this internal frame, if the look and feel supports iconification. If the internal frame's state changes to iconified, this method fires an INTERNAL_FRAME_ICONIFIED event. If the state changes to de-iconified, an INTERNAL_FRAME_DEICONIFIED event is fired.
        参数：
        b - a boolean, where true means to iconify this internal frame and false means to de-iconify it
        抛出：
        PropertyVetoException - when the attempt to set the property is vetoed by the JInternalFrame
        另请参见：
        InternalFrameEvent.INTERNAL_FRAME_ICONIFIED, InternalFrameEvent.INTERNAL_FRAME_DEICONIFIED

      • setMaximizable

        public void setMaximizable(boolean b)
        Sets the maximizable property, which determines whether the JInternalFrame can be maximized by some user action. Some look and feels might not support maximizing internal frames; they will ignore this property.
        参数：
        b - true to specify that this internal frame should be maximizable; false to specify that it should not be

      • isMaximizable

        public boolean isMaximizable()
        Gets the value of the maximizable property.
        返回：
        the value of the maximizable property
        另请参见：
        setMaximizable(boolean)

      • isMaximum

        public boolean isMaximum()
        Returns whether the JInternalFrame is currently maximized.
        返回：
        true if this internal frame is maximized, false otherwise

      • setMaximum

        public void setMaximum(boolean b)
                throws PropertyVetoException
        Maximizes and restores this internal frame. A maximized frame is resized to fully fit the JDesktopPane area associated with the JInternalFrame. A restored frame's size is set to the JInternalFrame's actual size.
        参数：
        b - a boolean, where true maximizes this internal frame and false restores it
        抛出：
        PropertyVetoException - when the attempt to set the property is vetoed by the JInternalFrame

      • getTitle

        public String getTitle()
        Returns the title of the JInternalFrame.
        返回：
        a String containing this internal frame's title
        另请参见：
        setTitle(java.lang.String)

      • setTitle

        public void setTitle(String title)
        Sets the JInternalFrame title. title may have a null value.
        参数：
        title - the String to display in the title bar
        另请参见：
        getTitle()

      • setSelected

        public void setSelected(boolean selected)
                 throws PropertyVetoException
        Selects or deselects the internal frame if it's showing. A JInternalFrame normally draws its title bar differently if it is the selected frame, which indicates to the user that this internal frame has the focus. When this method changes the state of the internal frame from deselected to selected, it fires an InternalFrameEvent.INTERNAL_FRAME_ACTIVATED event. If the change is from selected to deselected, an InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED event is fired.
        参数：
        selected - a boolean, where true means this internal frame should become selected (currently active) and false means it should become deselected
        抛出：
        PropertyVetoException - when the attempt to set the property is vetoed by the JInternalFrame
        另请参见：
        Component.isShowing(), InternalFrameEvent.INTERNAL_FRAME_ACTIVATED, InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED

      • isSelected

        public boolean isSelected()
        Returns whether the JInternalFrame is the currently "selected" or active frame.
        返回：
        true if this internal frame is currently selected (active)
        另请参见：
        setSelected(boolean)

      • setFrameIcon

        public void setFrameIcon(Icon icon)
        Sets an image to be displayed in the titlebar of this internal frame (usually in the top-left corner). This image is not the desktopIcon object, which is the image displayed in the JDesktop when this internal frame is iconified. Passing null to this function is valid, but the look and feel can choose the appropriate behavior for that situation, such as displaying no icon or a default icon for the look and feel.
        参数：
        icon - the Icon to display in the title bar
        另请参见：
        getFrameIcon()

      • getFrameIcon

        public Icon getFrameIcon()
        Returns the image displayed in the title bar of this internal frame (usually in the top-left corner).
        返回：
        the Icon displayed in the title bar
        另请参见：
        setFrameIcon(javax.swing.Icon)

      • moveToFront

        public void moveToFront()
        Convenience method that moves this component to position 0 if its parent is a JLayeredPane.

      • moveToBack

        public void moveToBack()
        Convenience method that moves this component to position -1 if its parent is a JLayeredPane.

      • getLastCursor

        public Cursor getLastCursor()
        Returns the last Cursor that was set by the setCursor method that is not a resizable Cursor.
        返回：
        the last non-resizable Cursor
        从以下版本开始：
        1.6

      • setCursor

        public void setCursor(Cursor cursor)
        Sets the cursor image to the specified cursor. This cursor image is displayed when the contains method for this component returns true for the current cursor location, and this Component is visible, displayable, and enabled. Setting the cursor of a Container causes that cursor to be displayed within all of the container's subcomponents, except for those that have a non-null cursor.

        The method may have no visual effect if the Java platform implementation and/or the native system do not support changing the mouse cursor shape.

        重载：
        setCursor in class Component
        参数：
        cursor - One of the constants defined by the Cursor class; if this parameter is null then this component will inherit the cursor of its parent
        从以下版本开始：
        1.6
        另请参见：
        Component.isEnabled(),
Component.isShowing(),
Component.getCursor(),
Component.contains(int, int),
Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String),
Cursor

      • setLayer

        public void setLayer(Integer layer)
        Convenience method for setting the layer attribute of this component.
        参数：
        layer - an Integer object specifying this frame's desktop layer
        另请参见：
        JLayeredPane

      • setLayer

        public void setLayer(int layer)
        Convenience method for setting the layer attribute of this component. The method setLayer(Integer) should be used for layer values predefined in JLayeredPane. When using setLayer(int), care must be taken not to accidentally clash with those values.
        参数：
        layer - an integer specifying this internal frame's desktop layer
        从以下版本开始：
        1.3
        另请参见：
        setLayer(Integer), JLayeredPane

      • getLayer

        public int getLayer()
        Convenience method for getting the layer attribute of this component.
        返回：
        an Integer object specifying this frame's desktop layer
        另请参见：
        JLayeredPane

      • getDesktopPane

        public JDesktopPane getDesktopPane()
        Convenience method that searches the ancestor hierarchy for a JDesktop instance. If JInternalFrame finds none, the desktopIcon tree is searched.
        返回：
        the JDesktopPane this internal frame belongs to, or null if none is found

      • setDesktopIcon

        public void setDesktopIcon(JInternalFrame.JDesktopIcon d)
        Sets the JDesktopIcon associated with this JInternalFrame.
        参数：
        d - the JDesktopIcon to display on the desktop
        另请参见：
        getDesktopIcon()

      • getDesktopIcon

        public JInternalFrame.JDesktopIcon getDesktopIcon()
        Returns the JDesktopIcon used when this JInternalFrame is iconified.
        返回：
        the JDesktopIcon displayed on the desktop
        另请参见：
        setDesktopIcon(javax.swing.JInternalFrame.JDesktopIcon)

      • getNormalBounds

        public Rectangle getNormalBounds()
        If the JInternalFrame is not in maximized state, returns getBounds(); otherwise, returns the bounds that the JInternalFrame would be restored to.
        返回：
        a Rectangle containing the bounds of this frame when in the normal state
        从以下版本开始：
        1.3

      • setNormalBounds

        public void setNormalBounds(Rectangle r)
        Sets the normal bounds for this internal frame, the bounds that this internal frame would be restored to from its maximized state. This method is intended for use only by desktop managers.
        参数：
        r - the bounds that this internal frame should be restored to
        从以下版本开始：
        1.3

      • getFocusOwner

        public Component getFocusOwner()
        If this JInternalFrame is active, returns the child that has focus. Otherwise, returns null.
        返回：
        the component with focus, or null if no children have focus
        从以下版本开始：
        1.3

      • getMostRecentFocusOwner

        public Component getMostRecentFocusOwner()
        Returns the child component of this JInternalFrame that will receive the focus when this JInternalFrame is selected. If this JInternalFrame is currently selected, this method returns the same component as the getFocusOwner method. If this JInternalFrame is not selected, then the child component that most recently requested focus will be returned. If no child component has ever requested focus, then this JInternalFrame's initial focusable component is returned. If no such child exists, then this JInternalFrame's default component to focus is returned.
        返回：
        the child component that will receive focus when this JInternalFrame is selected
        从以下版本开始：
        1.4
        另请参见：
        getFocusOwner(), isSelected

      • restoreSubcomponentFocus

        public void restoreSubcomponentFocus()
        Requests the internal frame to restore focus to the last subcomponent that had focus. This is used by the UI when the user selected this internal frame -- for example, by clicking on the title bar.
        从以下版本开始：
        1.3

      • reshape

        public void reshape(int x,
           int y,
           int width,
           int height)
        Moves and resizes this component. Unlike other components, this implementation also forces re-layout, so that frame decorations such as the title bar are always redisplayed.
        重载：
        reshape in class JComponent
        参数：
        x - an integer giving the component's new horizontal position measured in pixels from the left of its container
        y - an integer giving the component's new vertical position, measured in pixels from the bottom of its container
        width - an integer giving the component's new width in pixels
        height - an integer giving the component's new height in pixels
        另请参见：
        Component.setBounds(int, int, int, int)

      • addInternalFrameListener

        public void addInternalFrameListener(InternalFrameListener l)
        Adds the specified listener to receive internal frame events from this internal frame.
        参数：
        l - the internal frame listener

      • removeInternalFrameListener

        public void removeInternalFrameListener(InternalFrameListener l)
        Removes the specified internal frame listener so that it no longer receives internal frame events from this internal frame.
        参数：
        l - the internal frame listener

      • getInternalFrameListeners

        public InternalFrameListener[] getInternalFrameListeners()
        Returns an array of all the InternalFrameListeners added to this JInternalFrame with addInternalFrameListener.
        返回：
        all of the InternalFrameListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4
        另请参见：
        addInternalFrameListener(javax.swing.event.InternalFrameListener)

      • fireInternalFrameEvent

        protected void fireInternalFrameEvent(int id)
        Fires an internal frame event.
        参数：
        id - the type of the event being fired; one of the following:
        • InternalFrameEvent.INTERNAL_FRAME_OPENED
        • InternalFrameEvent.INTERNAL_FRAME_CLOSING
        • InternalFrameEvent.INTERNAL_FRAME_CLOSED
        • InternalFrameEvent.INTERNAL_FRAME_ICONIFIED
        • InternalFrameEvent.INTERNAL_FRAME_DEICONIFIED
        • InternalFrameEvent.INTERNAL_FRAME_ACTIVATED
        • InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED
        If the event type is not one of the above, nothing happens.

      • doDefaultCloseAction

        public void doDefaultCloseAction()
        Fires an INTERNAL_FRAME_CLOSING event and then performs the action specified by the internal frame's default close operation. This method is typically invoked by the look-and-feel-implemented action handler for the internal frame's close button.
        从以下版本开始：
        1.3
        另请参见：
        setDefaultCloseOperation(int), InternalFrameEvent.INTERNAL_FRAME_CLOSING

      • setDefaultCloseOperation

        public void setDefaultCloseOperation(int operation)
        Sets the operation that will happen by default when the user initiates a "close" on this internal frame. The possible choices are:

        DO_NOTHING_ON_CLOSE
        Do nothing. This requires the program to handle the operation in the windowClosing method of a registered InternalFrameListener object.
        HIDE_ON_CLOSE
        Automatically make the internal frame invisible.
        DISPOSE_ON_CLOSE
        Automatically dispose of the internal frame.

        The default value is DISPOSE_ON_CLOSE. Before performing the specified close operation, the internal frame fires an INTERNAL_FRAME_CLOSING event.

        参数：
        operation - one of the following constants defined in javax.swing.WindowConstants (an interface implemented by JInternalFrame): DO_NOTHING_ON_CLOSE, HIDE_ON_CLOSE, or DISPOSE_ON_CLOSE
        另请参见：
        addInternalFrameListener(javax.swing.event.InternalFrameListener),
getDefaultCloseOperation(),
JComponent.setVisible(boolean),
dispose(),
InternalFrameEvent.INTERNAL_FRAME_CLOSING

      • getDefaultCloseOperation

        public int getDefaultCloseOperation()
        Returns the default operation that occurs when the user initiates a "close" on this internal frame.
        返回：
        the operation that will occur when the user closes the internal frame
        另请参见：
        setDefaultCloseOperation(int)

      • pack

        public void pack()
        Causes subcomponents of this JInternalFrame to be laid out at their preferred size. Internal frames that are iconized or maximized are first restored and then packed. If the internal frame is unable to be restored its state is not changed and will not be packed.
        另请参见：
        Window.pack()

      • show

        public void show()
        If the internal frame is not visible, brings the internal frame to the front, makes it visible, and attempts to select it. The first time the internal frame is made visible, this method also fires an INTERNAL_FRAME_OPENED event. This method does nothing if the internal frame is already visible. Invoking this method has the same result as invoking setVisible(true).
        重载：
        show in class Component
        另请参见：
        moveToFront(), setSelected(boolean), InternalFrameEvent.INTERNAL_FRAME_OPENED, JComponent.setVisible(boolean)

      • hide

        public void hide()
        重载：
        hide in class Component

      • dispose

        public void dispose()
        Makes this internal frame invisible, unselected, and closed. If the frame is not already closed, this method fires an INTERNAL_FRAME_CLOSED event. The results of invoking this method are similar to setClosed(true), but dispose always succeeds in closing the internal frame and does not fire an INTERNAL_FRAME_CLOSING event.
        另请参见：
        InternalFrameEvent.INTERNAL_FRAME_CLOSED, JComponent.setVisible(boolean), setSelected(boolean), setClosed(boolean)

      • toFront

        public void toFront()
        Brings this internal frame to the front. Places this internal frame at the top of the stacking order and makes the corresponding adjustment to other visible internal frames.
        另请参见：
        Window.toFront(), moveToFront()

      • toBack

        public void toBack()
        Sends this internal frame to the back. Places this internal frame at the bottom of the stacking order and makes the corresponding adjustment to other visible internal frames.
        另请参见：
        Window.toBack(), moveToBack()

      • setFocusCycleRoot

        public final void setFocusCycleRoot(boolean focusCycleRoot)
        Does nothing because JInternalFrames must always be roots of a focus traversal cycle.
        重载：
        setFocusCycleRoot in class Container
        参数：
        focusCycleRoot - this value is ignored
        从以下版本开始：
        1.4
        另请参见：
        isFocusCycleRoot(),
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy()

      • isFocusCycleRoot

        public final boolean isFocusCycleRoot()
        Always returns true because all JInternalFrames must be roots of a focus traversal cycle.
        重载：
        isFocusCycleRoot in class Container
        返回：
        true
        从以下版本开始：
        1.4
        另请参见：
        setFocusCycleRoot(boolean), Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), Container.getFocusTraversalPolicy()

      • getFocusCycleRootAncestor

        public final Container getFocusCycleRootAncestor()
        Always returns null because JInternalFrames must always be roots of a focus traversal cycle.
        重载：
        getFocusCycleRootAncestor in class Component
        返回：
        null
        从以下版本开始：
        1.4
        另请参见：
        Container.isFocusCycleRoot()

      • getWarningString

        public final String getWarningString()
        Gets the warning string that is displayed with this internal frame. Since an internal frame is always secure (since it's fully contained within a window that might need a warning string) this method always returns null.
        返回：
        null
        另请参见：
        Window.getWarningString()

      • paramString

        protected String paramString()
        Returns a string representation of this JInternalFrame. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JInternalFrame

      • paintComponent

        protected void paintComponent(Graphics g)
        Overridden to allow optimized painting when the internal frame is being dragged.
        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics object to protect
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JInternalFrame. For internal frames, the AccessibleContext takes the form of an AccessibleJInternalFrame object. A new AccessibleJInternalFrame instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJInternalFrame that serves as the AccessibleContext of this JInternalFrame
        另请参见：
        JInternalFrame.AccessibleJInternalFrame
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JInternalFrame.AccessibleJInternalFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JInternalFrame.AccessibleJInternalFrame

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JInternalFrame.AccessibleJInternalFrame
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JInternalFrame

    protected class JInternalFrame.AccessibleJInternalFrame
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JInternalFrame class. It provides an implementation of the Java Accessibility API appropriate to internal frame user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JInternalFrame.AccessibleJInternalFrame()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAccessibleName()
      Get the accessible name of this object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Get the value of this object as a Number.
      Number getMaximumAccessibleValue()
      Get the maximum value of this object as a Number.
      Number getMinimumAccessibleValue()
      Get the minimum value of this object as a Number.
      boolean setCurrentAccessibleValue(Number n)
      Set the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JInternalFrame.AccessibleJInternalFrame

        protected JInternalFrame.AccessibleJInternalFrame()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Get the accessible name of this object.
        重载：
        getAccessibleName in class JComponent.AccessibleJComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, returns this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Get the value of this object as a Number.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        value of the object -- can be null if this object does not have a value
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Set the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        true if the value was set
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Get the minimum value of this object as a Number.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        Minimum value of the object; null if this object does not have a minimum value
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Get the maximum value of this object as a Number.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        Maximum value of the object; null if this object does not have a maximum value
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ar.#whi.hiWnniWW// i>"od(aiotd .,e f/<


JInternalFrame.JDesktopIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JInternalFrame.JDesktopIcon

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JInternalFrame.JDesktopIcon
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible
    封闭类：
    JInternalFrame

    public static class JInternalFrame.JDesktopIcon
extends JComponent
implements Accessible
    This component represents an iconified version of a JInternalFrame. This API should NOT BE USED by Swing applications, as it will go away in future versions of Swing as its functionality is moved into JInternalFrame. This class is public only so that UI objects can display a desktop icon. If an application wants to display a desktop icon, it should create a JInternalFrame instance and iconify it.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      This class implements accessibility support for the JInternalFrame.JDesktopIcon class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JInternalFrame.JDesktopIcon(JInternalFrame f)
      Creates an icon for an internal frame.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JDesktopIcon.
      JDesktopPane getDesktopPane()
      Convenience method to ask the icon for the Desktop object it belongs to.
      JInternalFrame getInternalFrame()
      Returns the JInternalFrame that this DesktopIcon is associated with.
      DesktopIconUI getUI()
      Returns the look-and-feel object that renders this component.
      String getUIClassID()
      Returns the name of the look-and-feel class that renders this component.
      void setInternalFrame(JInternalFrame f)
      Sets the JInternalFrame with which this DesktopIcon is associated.
      void setUI(DesktopIconUI ui)
      Sets the look-and-feel object that renders this component.
      void updateUI()
      Notification from the UIManager that the look and feel has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JInternalFrame.JDesktopIcon

        public JInternalFrame.JDesktopIcon(JInternalFrame f)
        Creates an icon for an internal frame.
        参数：
        f - the JInternalFrame for which the icon is created

    • 方法详细信息

      • getUI

        public DesktopIconUI getUI()
        Returns the look-and-feel object that renders this component.
        返回：
        the DesktopIconUI object that renders this component

      • setUI

        public void setUI(DesktopIconUI ui)
        Sets the look-and-feel object that renders this component.
        参数：
        ui - the DesktopIconUI look-and-feel object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getInternalFrame

        public JInternalFrame getInternalFrame()
        Returns the JInternalFrame that this DesktopIcon is associated with.
        返回：
        the JInternalFrame with which this icon is associated

      • setInternalFrame

        public void setInternalFrame(JInternalFrame f)
        Sets the JInternalFrame with which this DesktopIcon is associated.
        参数：
        f - the JInternalFrame with which this icon is associated

      • getDesktopPane

        public JDesktopPane getDesktopPane()
        Convenience method to ask the icon for the Desktop object it belongs to.
        返回：
        the JDesktopPane that contains this icon's internal frame, or null if none found

      • updateUI

        public void updateUI()
        Notification from the UIManager that the look and feel has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the look-and-feel class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "DesktopIconUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JDesktopIcon. For desktop icons, the AccessibleContext takes the form of an AccessibleJDesktopIcon. A new AccessibleJDesktopIcon instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJDesktopIcon that serves as the AccessibleContext of this JDesktopIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<)wct stdesr;sne m> >trtn e l


JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JInternalFrame.JDesktopIcon

    protected class JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JInternalFrame.JDesktopIcon class. It provides an implementation of the Java Accessibility API appropriate to desktop icon user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Gets the value of this object as a Number.
      Number getMaximumAccessibleValue()
      Gets the maximum value of this object as a Number.
      Number getMinimumAccessibleValue()
      Gets the minimum value of this object as a Number.
      boolean setCurrentAccessibleValue(Number n)
      Sets the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

        protected JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, returns this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Gets the value of this object as a Number.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        value of the object -- can be null if this object does not have a value
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Sets the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        true if the value was set
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Gets the minimum value of this object as a Number.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        minimum value of the object; null if this object does not have a minimum value
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Gets the maximum value of this object as a Number.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        maximum value of the object; null if this object does not have a maximum value
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ol< e nfBc>rr


JLabel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JLabel

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
    直接已知子类：
    BasicComboBoxRenderer, DefaultListCellRenderer, DefaultTableCellRenderer, DefaultTreeCellRenderer

    public class JLabel
extends JComponent
implements SwingConstants, Accessible
    A display area for a short text string or an image, or both. A label does not react to input events. As a result, it cannot get the keyboard focus. A label can, however, display a keyboard alternative as a convenience for a nearby component that has a keyboard alternative but can't display it.

    A JLabel object can display either text, an image, or both. You can specify where in the label's display area the label's contents are aligned by setting the vertical and horizontal alignment. By default, labels are vertically centered in their display area. Text-only labels are leading edge aligned, by default; image-only labels are horizontally centered, by default.

    You can also specify the position of the text relative to the image. By default, text is on the trailing edge of the image, with the text and image vertically aligned.

    A label's leading and trailing edge are determined from the value of its ComponentOrientation property. At present, the default ComponentOrientation setting maps the leading edge to left and the trailing edge to right.

    Finally, you can use the setIconTextGap method to specify how many pixels should appear between the text and the image. The default is 4 pixels.

    See How to Use Labels in The Java Tutorial for further documentation.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JLabel.AccessibleJLabel
      The class used to obtain the accessible role for this object.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Component | labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JLabel()
      Creates a JLabel instance with no image and with an empty string for the title.
      JLabel(Icon image)
      Creates a JLabel instance with the specified image.
      JLabel(Icon image, int horizontalAlignment)
      Creates a JLabel instance with the specified image and horizontal alignment.
      JLabel(String text)
      Creates a JLabel instance with the specified text.
      JLabel(String text, Icon icon, int horizontalAlignment)
      Creates a JLabel instance with the specified text, image, and horizontal alignment.
      JLabel(String text, int horizontalAlignment)
      Creates a JLabel instance with the specified text and horizontal alignment.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected int checkHorizontalKey(int key, String message)
      Verify that key is a legal value for the horizontalAlignment properties.
      protected int checkVerticalKey(int key, String message)
      Verify that key is a legal value for the verticalAlignment or verticalTextPosition properties.
      AccessibleContext getAccessibleContext()
      Get the AccessibleContext of this object
      Icon getDisabledIcon()
      Returns the icon used by the label when it's disabled.
      int getDisplayedMnemonic()
      Return the keycode that indicates a mnemonic key.
      int getDisplayedMnemonicIndex()
      Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
      int getHorizontalAlignment()
      Returns the alignment of the label's contents along the X axis.
      int getHorizontalTextPosition()
      Returns the horizontal position of the label's text, relative to its image.
      Icon getIcon()
      Returns the graphic image (glyph, icon) that the label displays.
      int getIconTextGap()
      Returns the amount of space between the text and the icon displayed in this label.
      Component getLabelFor()
      Get the component this is labelling.
      String getText()
      Returns the text string that the label displays.
      LabelUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns a string that specifies the name of the l&f class that renders this component.
      int getVerticalAlignment()
      Returns the alignment of the label's contents along the Y axis.
      int getVerticalTextPosition()
      Returns the vertical position of the label's text, relative to its image.
      boolean imageUpdate(Image img, int infoflags, int x, int y, int w, int h)
      This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
      protected String paramString()
      Returns a string representation of this JLabel.
      void setDisabledIcon(Icon disabledIcon)
      Set the icon to be displayed if this JLabel is "disabled" (JLabel.setEnabled(false)).
      void setDisplayedMnemonic(char aChar)
      Specifies the displayedMnemonic as a char value.
      void setDisplayedMnemonic(int key)
      Specify a keycode that indicates a mnemonic key.
      void setDisplayedMnemonicIndex(int index)
      Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.
      void setHorizontalAlignment(int alignment)
      Sets the alignment of the label's contents along the X axis.
      void setHorizontalTextPosition(int textPosition)
      Sets the horizontal position of the label's text, relative to its image.
      void setIcon(Icon icon)
      Defines the icon this component will display.
      void setIconTextGap(int iconTextGap)
      If both the icon and text properties are set, this property defines the space between them.
      void setLabelFor(Component c)
      Set the component this is labelling.
      void setText(String text)
      Defines the single line of text this component will display.
      void setUI(LabelUI ui)
      Sets the L&F object that renders this component.
      void setVerticalAlignment(int alignment)
      Sets the alignment of the label's contents along the Y axis.
      void setVerticalTextPosition(int textPosition)
      Sets the vertical position of the label's text, relative to its image.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • labelFor

        protected Component labelFor

    • 构造方法详细信息

      • JLabel

        public JLabel(String text,
      Icon icon,
      int horizontalAlignment)
        Creates a JLabel instance with the specified text, image, and horizontal alignment. The label is centered vertically in its display area. The text is on the trailing edge of the image.
        参数：
        text - The text to be displayed by the label.
        icon - The image to be displayed by the label.
        horizontalAlignment - One of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING or TRAILING.

      • JLabel

        public JLabel(String text,
      int horizontalAlignment)
        Creates a JLabel instance with the specified text and horizontal alignment. The label is centered vertically in its display area.
        参数：
        text - The text to be displayed by the label.
        horizontalAlignment - One of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING or TRAILING.

      • JLabel

        public JLabel(String text)
        Creates a JLabel instance with the specified text. The label is aligned against the leading edge of its display area, and centered vertically.
        参数：
        text - The text to be displayed by the label.

      • JLabel

        public JLabel(Icon image,
      int horizontalAlignment)
        Creates a JLabel instance with the specified image and horizontal alignment. The label is centered vertically in its display area.
        参数：
        image - The image to be displayed by the label.
        horizontalAlignment - One of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING or TRAILING.

      • JLabel

        public JLabel(Icon image)
        Creates a JLabel instance with the specified image. The label is centered vertically and horizontally in its display area.
        参数：
        image - The image to be displayed by the label.

      • JLabel

        public JLabel()
        Creates a JLabel instance with no image and with an empty string for the title. The label is centered vertically in its display area. The label's contents, once set, will be displayed on the leading edge of the label's display area.

    • 方法详细信息

      • getUI

        public LabelUI getUI()
        Returns the L&F object that renders this component.
        返回：
        LabelUI object

      • setUI

        public void setUI(LabelUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the LabelUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the l&f class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        String "LabelUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getText

        public String getText()
        Returns the text string that the label displays.
        返回：
        a String
        另请参见：
        setText(java.lang.String)

      • setText

        public void setText(String text)
        Defines the single line of text this component will display. If the value of text is null or empty string, nothing is displayed.

        The default value of this property is null.

        This is a JavaBeans bound property.

        另请参见：
        setVerticalTextPosition(int), setHorizontalTextPosition(int), setIcon(javax.swing.Icon)

      • getIcon

        public Icon getIcon()
        Returns the graphic image (glyph, icon) that the label displays.
        返回：
        an Icon
        另请参见：
        setIcon(javax.swing.Icon)

      • setIcon

        public void setIcon(Icon icon)
        Defines the icon this component will display. If the value of icon is null, nothing is displayed.

        The default value of this property is null.

        This is a JavaBeans bound property.

        另请参见：
        setVerticalTextPosition(int), setHorizontalTextPosition(int), getIcon()

      • getDisabledIcon

        public Icon getDisabledIcon()
        Returns the icon used by the label when it's disabled. If no disabled icon has been set this will forward the call to the look and feel to construct an appropriate disabled Icon.

        Some look and feels might not render the disabled Icon, in which case they will ignore this.

        返回：
        the disabledIcon property
        另请参见：
        setDisabledIcon(javax.swing.Icon), LookAndFeel.getDisabledIcon(javax.swing.JComponent, javax.swing.Icon), ImageIcon

      • setDisabledIcon

        public void setDisabledIcon(Icon disabledIcon)
        Set the icon to be displayed if this JLabel is "disabled" (JLabel.setEnabled(false)).

        The default value of this property is null.

        参数：
        disabledIcon - the Icon to display when the component is disabled
        另请参见：
        getDisabledIcon(), JComponent.setEnabled(boolean)

      • setDisplayedMnemonic

        public void setDisplayedMnemonic(int key)
        Specify a keycode that indicates a mnemonic key. This property is used when the label is part of a larger component. If the labelFor property of the label is not null, the label will call the requestFocus method of the component specified by the labelFor property when the mnemonic is activated.
        另请参见：
        getLabelFor(), setLabelFor(java.awt.Component)

      • setDisplayedMnemonic

        public void setDisplayedMnemonic(char aChar)
        Specifies the displayedMnemonic as a char value.
        参数：
        aChar - a char specifying the mnemonic to display
        另请参见：
        setDisplayedMnemonic(int)

      • getDisplayedMnemonic

        public int getDisplayedMnemonic()
        Return the keycode that indicates a mnemonic key. This property is used when the label is part of a larger component. If the labelFor property of the label is not null, the label will call the requestFocus method of the component specified by the labelFor property when the mnemonic is activated.
        返回：
        int value for the mnemonic key
        另请参见：
        getLabelFor(), setLabelFor(java.awt.Component)

      • setDisplayedMnemonicIndex

        public void setDisplayedMnemonicIndex(int index)
                               throws IllegalArgumentException
        Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic. Not all look and feels may support this. A value of -1 indicates either there is no mnemonic, the mnemonic character is not contained in the string, or the developer does not wish the mnemonic to be displayed.

        The value of this is updated as the properties relating to the mnemonic change (such as the mnemonic itself, the text...). You should only ever have to call this if you do not wish the default character to be underlined. For example, if the text was 'Save As', with a mnemonic of 'a', and you wanted the 'A' to be decorated, as 'Save As', you would have to invoke setDisplayedMnemonicIndex(5) after invoking setDisplayedMnemonic(KeyEvent.VK_A).

        参数：
        index - Index into the String to underline
        抛出：
        IllegalArgumentException - will be thrown if index= length of the text, or < -1
        从以下版本开始：
        1.4

      • getDisplayedMnemonicIndex

        public int getDisplayedMnemonicIndex()
        Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
        返回：
        index representing mnemonic character
        从以下版本开始：
        1.4
        另请参见：
        setDisplayedMnemonicIndex(int)

      • checkHorizontalKey

        protected int checkHorizontalKey(int key,
                     String message)
        Verify that key is a legal value for the horizontalAlignment properties.
        参数：
        key - the property value to check
        message - the IllegalArgumentException detail message
        抛出：
        IllegalArgumentException - if key isn't LEFT, CENTER, RIGHT, LEADING or TRAILING.
        另请参见：
        setHorizontalTextPosition(int), setHorizontalAlignment(int)

      • checkVerticalKey

        protected int checkVerticalKey(int key,
                   String message)
        Verify that key is a legal value for the verticalAlignment or verticalTextPosition properties.
        参数：
        key - the property value to check
        message - the IllegalArgumentException detail message
        抛出：
        IllegalArgumentException - if key isn't TOP, CENTER, or BOTTOM.
        另请参见：
        setVerticalAlignment(int), setVerticalTextPosition(int)

      • getIconTextGap

        public int getIconTextGap()
        Returns the amount of space between the text and the icon displayed in this label.
        返回：
        an int equal to the number of pixels between the text and the icon.
        另请参见：
        setIconTextGap(int)

      • setIconTextGap

        public void setIconTextGap(int iconTextGap)
        If both the icon and text properties are set, this property defines the space between them.

        The default value of this property is 4 pixels.

        This is a JavaBeans bound property.

        另请参见：
        getIconTextGap()

      • getVerticalAlignment

        public int getVerticalAlignment()
        Returns the alignment of the label's contents along the Y axis.
        返回：
        The value of the verticalAlignment property, one of the following constants defined in SwingConstants: TOP, CENTER, or BOTTOM.
        另请参见：
        SwingConstants, setVerticalAlignment(int)

      • setVerticalAlignment

        public void setVerticalAlignment(int alignment)
        Sets the alignment of the label's contents along the Y axis.

        The default value of this property is CENTER.

        参数：
        alignment - One of the following constants defined in SwingConstants: TOP, CENTER (the default), or BOTTOM.
        另请参见：
        SwingConstants, getVerticalAlignment()

      • getHorizontalAlignment

        public int getHorizontalAlignment()
        Returns the alignment of the label's contents along the X axis.
        返回：
        The value of the horizontalAlignment property, one of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING or TRAILING.
        另请参见：
        setHorizontalAlignment(int), SwingConstants

      • setHorizontalAlignment

        public void setHorizontalAlignment(int alignment)
        Sets the alignment of the label's contents along the X axis.

        This is a JavaBeans bound property.

        参数：
        alignment - One of the following constants defined in SwingConstants: LEFT, CENTER (the default for image-only labels), RIGHT, LEADING (the default for text-only labels) or TRAILING.
        另请参见：
        SwingConstants, getHorizontalAlignment()

      • getVerticalTextPosition

        public int getVerticalTextPosition()
        Returns the vertical position of the label's text, relative to its image.
        返回：
        One of the following constants defined in SwingConstants: TOP, CENTER, or BOTTOM.
        另请参见：
        setVerticalTextPosition(int), SwingConstants

      • setVerticalTextPosition

        public void setVerticalTextPosition(int textPosition)
        Sets the vertical position of the label's text, relative to its image.

        The default value of this property is CENTER.

        This is a JavaBeans bound property.

        参数：
        textPosition - One of the following constants defined in SwingConstants: TOP, CENTER (the default), or BOTTOM.
        另请参见：
        SwingConstants, getVerticalTextPosition()

      • getHorizontalTextPosition

        public int getHorizontalTextPosition()
        Returns the horizontal position of the label's text, relative to its image.
        返回：
        One of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING or TRAILING.
        另请参见：
        SwingConstants

      • setHorizontalTextPosition

        public void setHorizontalTextPosition(int textPosition)
        Sets the horizontal position of the label's text, relative to its image.
        参数：
        textPosition - One of the following constants defined in SwingConstants: LEFT, CENTER, RIGHT, LEADING, or TRAILING (the default).
        抛出：
        IllegalArgumentException
        另请参见：
        SwingConstants

      • imageUpdate

        public boolean imageUpdate(Image img,
                  int infoflags,
                  int x,
                  int y,
                  int w,
                  int h)
        This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
        指定者：
        imageUpdate in interface ImageObserver
        重载：
        imageUpdate in class Component
        参数：
        img - the image being observed
        infoflags - see imageUpdate for more information
        x - the x coordinate
        y - the y coordinate
        w - the width
        h - the height
        返回：
        false if the infoflags indicate that the image is completely loaded; true otherwise.
        另请参见：
        ImageObserver, Component.imageUpdate(java.awt.Image, int, int, int, int, int)

      • paramString

        protected String paramString()
        Returns a string representation of this JLabel. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JLabel.

      • getLabelFor

        public Component getLabelFor()
        Get the component this is labelling.
        返回：
        the Component this is labelling. Can be null if this does not label a Component. If the displayedMnemonic property is set and the labelFor property is also set, the label will call the requestFocus method of the component specified by the labelFor property when the mnemonic is activated.
        另请参见：
        getDisplayedMnemonic(), setDisplayedMnemonic(int)

      • setLabelFor

        public void setLabelFor(Component c)
        Set the component this is labelling. Can be null if this does not label a Component. If the displayedMnemonic property is set and the labelFor property is also set, the label will call the requestFocus method of the component specified by the labelFor property when the mnemonic is activated.
        参数：
        c - the Component this label is for, or null if the label is not the label for a component
        另请参见：
        getDisplayedMnemonic(), setDisplayedMnemonic(int)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Get the AccessibleContext of this object
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        the AccessibleContext of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JLabel.AccessibleJLabel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JLabel.AccessibleJLabel

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JLabel.AccessibleJLabel
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleText
    封闭类：
    JLabel

    protected class JLabel.AccessibleJLabel
extends JComponent.AccessibleJComponent
implements AccessibleText, AccessibleExtendedComponent
    The class used to obtain the accessible role for this object.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JLabel.AccessibleJLabel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleIcon[] getAccessibleIcon()
      Get the AccessibleIcons associated with this object if one or more exist.
      AccessibleKeyBinding getAccessibleKeyBinding()
      Returns key bindings associated with this object
      String getAccessibleName()
      Get the accessible name of this object.
      AccessibleRelationSet getAccessibleRelationSet()
      Get the AccessibleRelationSet associated with this object if one exists.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      int getCaretPosition()
      Return the zero-based offset of the caret.
      AttributeSet getCharacterAttribute(int i)
      Return the AttributeSet for a given character at a given index
      Rectangle getCharacterBounds(int i)
      Determine the bounding box of the character at the given index into the string.
      int getCharCount()
      Return the number of characters (valid indicies)
      int getIndexAtPoint(Point p)
      Given a point in local coordinates, return the zero-based index of the character under that Point.
      String getSelectedText()
      Returns the portion of the text that is selected.
      int getSelectionEnd()
      Returns the end offset within the selected text.
      int getSelectionStart()
      Returns the start offset within the selected text.
      String getTitledBorderText()
      Returns the titled border text
      String getToolTipText()
      Returns the tool tip text

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleStateSet, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JLabel.AccessibleJLabel

        protected JLabel.AccessibleJLabel()

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Get the accessible name of this object.
        重载：
        getAccessibleName in class JComponent.AccessibleJComponent
        返回：
        the localized name of the object -- can be null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleIcon

        public AccessibleIcon[] getAccessibleIcon()
        Get the AccessibleIcons associated with this object if one or more exist. Otherwise return null.
        重载：
        getAccessibleIcon in class AccessibleContext
        返回：
        an array of AccessibleIcon if supported by object; otherwise return null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleIcon

      • getAccessibleRelationSet

        public AccessibleRelationSet getAccessibleRelationSet()
        Get the AccessibleRelationSet associated with this object if one exists. Otherwise return null.
        重载：
        getAccessibleRelationSet in class AccessibleContext
        返回：
        an AccessibleRelationSet if supported by object; otherwise return null
        从以下版本开始：
        1.3
        另请参见：
        AccessibleRelation

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Description copied from class: AccessibleContext
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getIndexAtPoint

        public int getIndexAtPoint(Point p)
        Given a point in local coordinates, return the zero-based index of the character under that Point. If the point is invalid, this method returns -1.
        指定者：
        getIndexAtPoint in interface AccessibleText
        参数：
        p - the Point in local coordinates
        返回：
        the zero-based index of the character under Point p; if Point is invalid returns -1.
        从以下版本开始：
        1.3

      • getCharacterBounds

        public Rectangle getCharacterBounds(int i)
        Determine the bounding box of the character at the given index into the string. The bounds are returned in local coordinates. If the index is invalid an empty rectangle is returned.
        指定者：
        getCharacterBounds in interface AccessibleText
        参数：
        i - the index into the String
        返回：
        the screen coordinates of the character's the bounding box, if index is invalid returns an empty rectangle.
        从以下版本开始：
        1.3

      • getCharCount

        public int getCharCount()
        Return the number of characters (valid indicies)
        指定者：
        getCharCount in interface AccessibleText
        返回：
        the number of characters
        从以下版本开始：
        1.3

      • getCaretPosition

        public int getCaretPosition()
        Return the zero-based offset of the caret. Note: That to the right of the caret will have the same index value as the offset (the caret is between two characters).
        指定者：
        getCaretPosition in interface AccessibleText
        返回：
        the zero-based offset of the caret.
        从以下版本开始：
        1.3

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index.
        指定者：
        getAtIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index.
        指定者：
        getAfterIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index.
        指定者：
        getBeforeIndex in interface AccessibleText
        参数：
        part - the AccessibleText.CHARACTER, AccessibleText.WORD, or AccessibleText.SENTENCE to retrieve
        index - an index within the text >= 0
        返回：
        the letter, word, or sentence, null for an invalid index or part
        从以下版本开始：
        1.3

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute(int i)
        Return the AttributeSet for a given character at a given index
        指定者：
        getCharacterAttribute in interface AccessibleText
        参数：
        i - the zero-based index into the text
        返回：
        the AttributeSet of the character
        从以下版本开始：
        1.3

      • getSelectionStart

        public int getSelectionStart()
        Returns the start offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionStart in interface AccessibleText
        返回：
        the index into the text of the start of the selection
        从以下版本开始：
        1.3

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the end offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionEnd in interface AccessibleText
        返回：
        the index into teh text of the end of the selection
        从以下版本开始：
        1.3

      • getSelectedText

        public String getSelectedText()
        Returns the portion of the text that is selected.
        指定者：
        getSelectedText in interface AccessibleText
        返回：
        the String portion of the text that is selected
        从以下版本开始：
        1.3

      • getToolTipText

        public String getToolTipText()
        Returns the tool tip text
        指定者：
        getToolTipText in interface AccessibleExtendedComponent
        重载：
        getToolTipText in class JComponent.AccessibleJComponent
        返回：
        the tool tip text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getTitledBorderText

        public String getTitledBorderText()
        Returns the titled border text
        指定者：
        getTitledBorderText in interface AccessibleExtendedComponent
        重载：
        getTitledBorderText in class JComponent.AccessibleJComponent
        返回：
        the titled border text, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4

      • getAccessibleKeyBinding

        public AccessibleKeyBinding getAccessibleKeyBinding()
        Returns key bindings associated with this object
        指定者：
        getAccessibleKeyBinding in interface AccessibleExtendedComponent
        重载：
        getAccessibleKeyBinding in class JComponent.AccessibleJComponent
        返回：
        the key bindings, if supported, of the object; otherwise, null
        从以下版本开始：
        1.4
        另请参见：
        AccessibleKeyBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ili>"览>""la<rie>fllkav-e


JLayer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JLayer<V extends Component>

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLayer<V>
  • 类型参数：
    V - the type of JLayer's view component
    所有已实现的接口：
    ImageObserver, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, Scrollable

    public final class JLayer<V extends Component>
extends JComponent
implements Scrollable, PropertyChangeListener, Accessible
    JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.

    JLayer delegates the handling of painting and input events to a LayerUI object, which performs the actual decoration.

    The custom painting implemented in the LayerUI and events notification work for the JLayer itself and all its subcomponents. This combination enables you to enrich existing components by adding new advanced functionality such as temporary locking of a hierarchy, data tips for compound components, enhanced mouse scrolling etc and so on.

    JLayer is a good solution if you only need to do custom painting over compound component or catch input events from its subcomponents.

     import javax.swing.*;
 import javax.swing.plaf.LayerUI;
 import java.awt.*;

 public class JLayerSample {

     private static JLayer<JComponent> createLayer() {
         // This custom layerUI will fill the layer with translucent green
         // and print out all mouseMotion events generated within its borders
         LayerUI<JComponent> layerUI = new LayerUI<JComponent>() {

             public void paint(Graphics g, JComponent c) {
                 // paint the layer as is
                 super.paint(g, c);
                 // fill it with the translucent green
                 g.setColor(new Color(0, 128, 0, 128));
                 g.fillRect(0, 0, c.getWidth(), c.getHeight());
             }

             public void installUI(JComponent c) {
                 super.installUI(c);
                 // enable mouse motion events for the layer's subcomponents
                 ((JLayer) c).setLayerEventMask(AWTEvent.MOUSE_MOTION_EVENT_MASK);
             }

             public void uninstallUI(JComponent c) {
                 super.uninstallUI(c);
                 // reset the layer event mask
                 ((JLayer) c).setLayerEventMask(0);
             }

             // overridden method which catches MouseMotion events
             public void eventDispatched(AWTEvent e, JLayer<? extends JComponent> l) {
                 System.out.println("AWTEvent detected: " + e);
             }
         };
         // create a component to be decorated with the layer
         JPanel panel = new JPanel();
         panel.add(new JButton("JButton"));

         // create the layer for the panel using our custom layerUI
         return new JLayer<JComponent>(panel, layerUI);
     }

     private static void createAndShowGUI() {
         final JFrame frame = new JFrame();
         frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);

         // work with the layer as with any other Swing component
         frame.add(createLayer());

         frame.setSize(200, 200);
         frame.setLocationRelativeTo(null);
         frame.setVisible(true);
     }

     public static void main(String[] args) throws Exception {
         SwingUtilities.invokeAndWait(new Runnable() {
             public void run() {
                 createAndShowGUI();
             }
         });
     }
 }
    Note: JLayer doesn't support the following methods:
    • Container.add(java.awt.Component)
    • Container.add(String, java.awt.Component)
    • Container.add(java.awt.Component, int)
    • Container.add(java.awt.Component, Object)
    • Container.add(java.awt.Component, Object, int)
    using any of of them will cause UnsupportedOperationException to be thrown, to add a component to JLayer use setView(Component) or setGlassPane(JPanel).
    从以下版本开始：
    1.7
    另请参见：
    JLayer(Component), setView(Component), getView(), LayerUI, JLayer(Component, LayerUI), setUI(javax.swing.plaf.LayerUI), getUI()

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JLayer()
      Creates a new JLayer object with a null view component and default LayerUI.
      JLayer(V view)
      Creates a new JLayer object with default LayerUI.
      JLayer(V view, LayerUI<V> ui)
      Creates a new JLayer object with the specified view component and LayerUI object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      This method is not supported by JLayer and always throws UnsupportedOperationException
      void addNotify()
      Notifies this component that it now has a parent component.
      JPanel createGlassPane()
      Called by the constructor methods to create a default glassPane.
      void doLayout()
      Delegates its functionality to the LayerUI.doLayout(JLayer) method, if LayerUI is set.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JLayer.
      JPanel getGlassPane()
      Returns the JLayer's glassPane component or null.
      long getLayerEventMask()
      Returns the bitmap of event mask to receive by this JLayer and its LayerUI.
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred size of the viewport for a view component.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one block of rows or columns, depending on the value of orientation.
      boolean getScrollableTracksViewportHeight()
      Returns false to indicate that the height of the viewport does not determine the height of the layer, unless the preferred height of the layer is smaller than the height of the viewport.
      boolean getScrollableTracksViewportWidth()
      Returns false to indicate that the width of the viewport does not determine the width of the layer, unless the preferred width of the layer is smaller than the width of the viewport.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one new row or column, depending on the value of orientation.
      LayerUI<? super V> getUI()
      Returns the LayerUI for this JLayer.
      V getView()
      Returns the JLayer's view component or null.
      boolean isOptimizedDrawingEnabled()
      The JLayer overrides the default implementation of this method (in JComponent) to return false.
      protected boolean isPaintingOrigin()
      Always returns true to cause painting to originate from JLayer, or one of its ancestors.
      void paint(Graphics g)
      Delegates all painting to the LayerUI object.
      protected void paintComponent(Graphics g)
      This method is empty, because all painting is done by paint(Graphics) and ComponentUI.update(Graphics, JComponent) methods
      void paintImmediately(int x, int y, int w, int h)
      Delegates its functionality to the LayerUI.paintImmediately(int, int, int, int, JLayer) method, if LayerUI is set.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      void remove(Component comp)
      Removes the specified component from this container.
      void removeAll()
      Removes all the components from this container.
      void removeNotify()
      Notifies this component that it no longer has a parent component.
      void setBorder(Border border)
      A non-null border, or non-zero insets, isn't supported, to prevent the geometry of this component from becoming complex enough to inhibit subclassing of LayerUI class.
      void setGlassPane(JPanel glassPane)
      Sets the JLayer's glassPane component, which can be null.
      void setLayerEventMask(long layerEventMask)
      Enables the events from JLayer and all its descendants defined by the specified event mask parameter to be delivered to the LayerUI.eventDispatched(AWTEvent, JLayer) method.
      void setLayout(LayoutManager mgr)
      Sets the layout manager for this container.
      void setUI(LayerUI<? super V> ui)
      Sets the LayerUI which will perform painting and receive input events for this JLayer.
      void setView(V view)
      Sets the JLayer's view component, which can be null.
      void updateUI()
      Delegates its functionality to the LayerUI.updateUI(JLayer) method, if LayerUI is set.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JLayer

        public JLayer()
        Creates a new JLayer object with a null view component and default LayerUI.
        另请参见：
        setView(V), setUI(javax.swing.plaf.LayerUI)

      • JLayer

        public JLayer(V view)
        Creates a new JLayer object with default LayerUI.
        参数：
        view - the component to be decorated by this JLayer
        另请参见：
        setUI(javax.swing.plaf.LayerUI)

      • JLayer

        public JLayer(V view,
      LayerUI<V> ui)
        Creates a new JLayer object with the specified view component and LayerUI object.
        参数：
        view - the component to be decorated
        ui - the LayerUI delegate to be used by this JLayer

    • 方法详细信息

      • getView

        public V getView()
        Returns the JLayer's view component or null.
        This is a bound property.
        返回：
        the JLayer's view component or null if none exists
        另请参见：
        setView(Component)

      • setView

        public void setView(V view)
        Sets the JLayer's view component, which can be null.
        This is a bound property.
        参数：
        view - the view component for this JLayer
        另请参见：
        getView()

      • setUI

        public void setUI(LayerUI<? super V> ui)
        Sets the LayerUI which will perform painting and receive input events for this JLayer.
        参数：
        ui - the LayerUI for this JLayer

      • getUI

        public LayerUI<? super V> getUI()
        Returns the LayerUI for this JLayer.
        返回：
        the LayerUI for this JLayer

      • getGlassPane

        public JPanel getGlassPane()
        Returns the JLayer's glassPane component or null.
        This is a bound property.
        返回：
        the JLayer's glassPane component or null if none exists
        另请参见：
        setGlassPane(JPanel)

      • setGlassPane

        public void setGlassPane(JPanel glassPane)
        Sets the JLayer's glassPane component, which can be null.
        This is a bound property.
        参数：
        glassPane - the glassPane component of this JLayer
        另请参见：
        getGlassPane()

      • createGlassPane

        public JPanel createGlassPane()
        Called by the constructor methods to create a default glassPane. By default this method creates a new JPanel with visibility set to true and opacity set to false.
        返回：
        the default glassPane

      • setLayout

        public void setLayout(LayoutManager mgr)
        Sets the layout manager for this container. This method is overridden to prevent the layout manager from being set.

        Note: If mgr is non-null, this method will throw an exception as layout managers are not supported on a JLayer.

        重载：
        setLayout in class Container
        参数：
        mgr - the specified layout manager
        抛出：
        IllegalArgumentException - this method is not supported
        另请参见：
        Container.doLayout(),
Container.getLayout(),
Container.invalidate()

      • setBorder

        public void setBorder(Border border)
        A non-null border, or non-zero insets, isn't supported, to prevent the geometry of this component from becoming complex enough to inhibit subclassing of LayerUI class. To create a JLayer with a border, add it to a JPanel that has a border.

        Note: If border is non-null, this method will throw an exception as borders are not supported on a JLayer.

        重载：
        setBorder in class JComponent
        参数：
        border - the Border to set
        抛出：
        IllegalArgumentException - this method is not supported
        另请参见：
        Border, CompoundBorder

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        This method is not supported by JLayer and always throws UnsupportedOperationException
        重载：
        addImpl in class Container
        参数：
        comp - the component to be added
        constraints - an object expressing layout constraints for this component
        index - the position in the container's list at which to insert the component, where -1 means append to the end
        抛出：
        UnsupportedOperationException - this method is not supported
        另请参见：
        setView(Component), setGlassPane(JPanel)

      • remove

        public void remove(Component comp)
        Removes the specified component from this container. This method also notifies the layout manager to remove the component from this container's layout via the removeLayoutComponent method.

        This method changes layout-related information, and therefore, invalidates the component hierarchy. If the container has already been displayed, the hierarchy must be validated thereafter in order to reflect the changes.

        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.remove(int)

      • removeAll

        public void removeAll()
        Removes all the components from this container. This method also notifies the layout manager to remove the components from this container's layout via the removeLayoutComponent method.

        This method changes layout-related information, and therefore, invalidates the component hierarchy. If the container has already been displayed, the hierarchy must be validated thereafter in order to reflect the changes.

        重载：
        removeAll in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.remove(int),
Container.invalidate()

      • isPaintingOrigin

        protected boolean isPaintingOrigin()
        Always returns true to cause painting to originate from JLayer, or one of its ancestors.
        重载：
        isPaintingOrigin in class JComponent
        返回：
        true
        另请参见：
        JComponent.isPaintingOrigin()

      • paintImmediately

        public void paintImmediately(int x,
                    int y,
                    int w,
                    int h)
        Delegates its functionality to the LayerUI.paintImmediately(int, int, int, int, JLayer) method, if LayerUI is set.
        重载：
        paintImmediately in class JComponent
        参数：
        x - the x value of the region to be painted
        y - the y value of the region to be painted
        w - the width of the region to be painted
        h - the height of the region to be painted
        另请参见：
        JComponent.repaint(long, int, int, int, int), JComponent.isPaintingOrigin()

      • paint

        public void paint(Graphics g)
        Delegates all painting to the LayerUI object.
        重载：
        paint in class JComponent
        参数：
        g - the Graphics to render to
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • paintComponent

        protected void paintComponent(Graphics g)
        This method is empty, because all painting is done by paint(Graphics) and ComponentUI.update(Graphics, JComponent) methods
        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics object to protect
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • isOptimizedDrawingEnabled

        public boolean isOptimizedDrawingEnabled()
        The JLayer overrides the default implementation of this method (in JComponent) to return false. This ensures that the drawing machinery will call the JLayer's paint implementation rather than messaging the JLayer's children directly.
        重载：
        isOptimizedDrawingEnabled in class JComponent
        返回：
        false

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.

      • setLayerEventMask

        public void setLayerEventMask(long layerEventMask)
        Enables the events from JLayer and all its descendants defined by the specified event mask parameter to be delivered to the LayerUI.eventDispatched(AWTEvent, JLayer) method.

        Events are delivered provided that LayerUI is set for this JLayer and the JLayer is displayable.

        The following example shows how to correctly use this method in the LayerUI implementations:

            public void installUI(JComponent c) {
       super.installUI(c);
       JLayer l = (JLayer) c;
       // this LayerUI will receive only key and focus events
       l.setLayerEventMask(AWTEvent.KEY_EVENT_MASK | AWTEvent.FOCUS_EVENT_MASK);
    }

    public void uninstallUI(JComponent c) {
       super.uninstallUI(c);
       JLayer l = (JLayer) c;
       // JLayer must be returned to its initial state
       l.setLayerEventMask(0);
    }
        By default JLayer receives no events and its event mask is 0.
        参数：
        layerEventMask - the bitmask of event types to receive
        另请参见：
        getLayerEventMask(),
LayerUI.eventDispatched(AWTEvent, JLayer),
Component.isDisplayable()

      • getLayerEventMask

        public long getLayerEventMask()
        Returns the bitmap of event mask to receive by this JLayer and its LayerUI.

        It means that LayerUI.eventDispatched(AWTEvent, JLayer) method will only receive events that match the event mask.

        By default JLayer receives no events.

        返回：
        the bitmask of event types to receive for this JLayer

      • updateUI

        public void updateUI()
        Delegates its functionality to the LayerUI.updateUI(JLayer) method, if LayerUI is set.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Returns the preferred size of the viewport for a view component.

        If the view component of this layer implements Scrollable, this method delegates its implementation to the view component.

        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        返回：
        the preferred size of the viewport for a view component
        另请参见：
        Scrollable

      • getScrollableBlockIncrement

        public int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one block of rows or columns, depending on the value of orientation.

        If the view component of this layer implements Scrollable, this method delegates its implementation to the view component.

        指定者：
        getScrollableBlockIncrement in interface Scrollable
        参数：
        visibleRect - The view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        the "block" increment for scrolling in the specified direction
        另请参见：
        Scrollable

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns false to indicate that the height of the viewport does not determine the height of the layer, unless the preferred height of the layer is smaller than the height of the viewport.

        If the view component of this layer implements Scrollable, this method delegates its implementation to the view component.

        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        返回：
        whether the layer should track the height of the viewport
        另请参见：
        Scrollable

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns false to indicate that the width of the viewport does not determine the width of the layer, unless the preferred width of the layer is smaller than the width of the viewport.

        If the view component of this layer implements Scrollable, this method delegates its implementation to the view component.

        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        返回：
        whether the layer should track the width of the viewport
        另请参见：
        Scrollable

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one new row or column, depending on the value of orientation. Ideally, components should handle a partially exposed row or column by returning the distance required to completely expose the item.

        Scrolling containers, like JScrollPane, will use this method each time the user requests a unit scroll.

        If the view component of this layer implements Scrollable, this method delegates its implementation to the view component.

        指定者：
        getScrollableUnitIncrement in interface Scrollable
        参数：
        visibleRect - The view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        The "unit" increment for scrolling in the specified direction. This value should always be positive.
        另请参见：
        Scrollable

      • addNotify

        public void addNotify()
        Notifies this component that it now has a parent component. When this method is invoked, the chain of parent components is set up with KeyboardAction event listeners. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        addNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • removeNotify

        public void removeNotify()
        Notifies this component that it no longer has a parent component. When this method is invoked, any KeyboardActions set up in the the chain of parent components are removed. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        removeNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • doLayout

        public void doLayout()
        Delegates its functionality to the LayerUI.doLayout(JLayer) method, if LayerUI is set.
        重载：
        doLayout in class Container
        另请参见：
        LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JLayer.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        the AccessibleContext associated with this JLayer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JLayeredPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JLayeredPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLayeredPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible
    直接已知子类：
    JDesktopPane

    public class JLayeredPane
extends JComponent
implements Accessible
    JLayeredPane adds depth to a JFC/Swing container, allowing components to overlap each other when needed. An Integer object specifies each component's depth in the container, where higher-numbered components sit "on top" of other components. For task-oriented documentation and examples of using layered panes see How to Use a Layered Pane, a section in The Java Tutorial.

    The following text describes this image.

    For convenience, JLayeredPane divides the depth-range into several different layers. Putting a component into one of those layers makes it easy to ensure that components overlap properly, without having to worry about specifying numbers for specific depths:
    DEFAULT_LAYER
    The standard layer, where most components go. This the bottommost layer.
    PALETTE_LAYER
    The palette layer sits over the default layer. Useful for floating toolbars and palettes, so they can be positioned above other components.
    MODAL_LAYER
    The layer used for modal dialogs. They will appear on top of any toolbars, palettes, or standard components in the container.
    POPUP_LAYER
    The popup layer displays above dialogs. That way, the popup windows associated with combo boxes, tooltips, and other help text will appear above the component, palette, or dialog that generated them.
    DRAG_LAYER
    When dragging a component, reassigning it to the drag layer ensures that it is positioned over every other component in the container. When finished dragging, it can be reassigned to its normal layer.
    The JLayeredPane methods moveToFront(Component), moveToBack(Component) and setPosition can be used to reposition a component within its layer. The setLayer method can also be used to change the component's current layer.

    Details

    JLayeredPane manages its list of children like Container, but allows for the definition of a several layers within itself. Children in the same layer are managed exactly like the normal Container object, with the added feature that when children components overlap, children in higher layers display above the children in lower layers.

    Each layer is a distinct integer number. The layer attribute can be set on a Component by passing an Integer object during the add call.
    For example:

         layeredPane.add(child, JLayeredPane.DEFAULT_LAYER);
 or
     layeredPane.add(child, new Integer(10));
    The layer attribute can also be set on a Component by calling
         layeredPaneParent.setLayer(child, 10)
    on the JLayeredPane that is the parent of component. The layer should be set before adding the child to the parent.

    Higher number layers display above lower number layers. So, using numbers for the layers and letters for individual components, a representative list order would look like this:

           5a, 5b, 5c, 2a, 2b, 2c, 1a
    where the leftmost components are closest to the top of the display.

    A component can be moved to the top or bottom position within its layer by calling moveToFront or moveToBack.

    The position of a component within a layer can also be specified directly. Valid positions range from 0 up to one less than the number of components in that layer. A value of -1 indicates the bottommost position. A value of 0 indicates the topmost position. Unlike layer numbers, higher position values are lower in the display.

    Note: This sequence (defined by java.awt.Container) is the reverse of the layer numbering sequence. Usually though, you will use moveToFront, moveToBack, and setLayer.
    Here are some examples using the method add(Component, layer, position): Calling add(5x, 5, -1) results in:
           5a, 5b, 5c, 5x, 2a, 2b, 2c, 1a
    Calling add(5z, 5, 2) results in:
           5a, 5b, 5z, 5c, 5x, 2a, 2b, 2c, 1a
    Calling add(3a, 3, 7) results in:
           5a, 5b, 5z, 5c, 5x, 3a, 2a, 2b, 2c, 1a
    Using normal paint/event mechanics results in 1a appearing at the bottom and 5a being above all other components.

    Note: that these layers are simply a logical construct and LayoutManagers will affect all child components of this container without regard for layer settings.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JLayeredPane.AccessibleJLayeredPane
      This class implements accessibility support for the JLayeredPane class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Integer DEFAULT_LAYER
      Convenience object defining the Default layer.
      static Integer DRAG_LAYER
      Convenience object defining the Drag layer.
      static Integer FRAME_CONTENT_LAYER
      Convenience object defining the Frame Content layer.
      static String LAYER_PROPERTY
      Bound property
      static Integer MODAL_LAYER
      Convenience object defining the Modal layer.
      static Integer PALETTE_LAYER
      Convenience object defining the Palette layer.
      static Integer POPUP_LAYER
      Convenience object defining the Popup layer.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JLayeredPane()
      Create a new JLayeredPane

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified component to this container at the specified index.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JLayeredPane.
      int getComponentCountInLayer(int layer)
      Returns the number of children currently in the specified layer.
      Component[] getComponentsInLayer(int layer)
      Returns an array of the components in the specified layer.
      protected Hashtable<Component,Integer> getComponentToLayer()
      Returns the hashtable that maps components to layers.
      int getIndexOf(Component c)
      Returns the index of the specified Component.
      int getLayer(Component c)
      Returns the layer attribute for the specified Component.
      static int getLayer(JComponent c)
      Gets the layer property for a JComponent, it does not cause any side effects like setLayer().
      static JLayeredPane getLayeredPaneAbove(Component c)
      Convenience method that returns the first JLayeredPane which contains the specified component.
      protected Integer getObjectForLayer(int layer)
      Returns the Integer object associated with a specified layer.
      int getPosition(Component c)
      Get the relative position of the component within its layer.
      int highestLayer()
      Returns the highest layer value from all current children.
      protected int insertIndexForLayer(int layer, int position)
      Primitive method that determines the proper location to insert a new child based on layer and position requests.
      boolean isOptimizedDrawingEnabled()
      Returns false if components in the pane can overlap, which makes optimized drawing impossible.
      int lowestLayer()
      Returns the lowest layer value from all current children.
      void moveToBack(Component c)
      Moves the component to the bottom of the components in its current layer (position -1).
      void moveToFront(Component c)
      Moves the component to the top of the components in its current layer (position 0).
      void paint(Graphics g)
      Paints this JLayeredPane within the specified graphics context.
      protected String paramString()
      Returns a string representation of this JLayeredPane.
      static void putLayer(JComponent c, int layer)
      Sets the layer property on a JComponent.
      void remove(int index)
      Remove the indexed component from this pane.
      void removeAll()
      Removes all the components from this container.
      void setLayer(Component c, int layer)
      Sets the layer attribute on the specified component, making it the bottommost component in that layer.
      void setLayer(Component c, int layer, int position)
      Sets the layer attribute for the specified component and also sets its position within that layer.
      void setPosition(Component c, int position)
      Moves the component to position within its current layer, where 0 is the topmost position within the layer and -1 is the bottommost position.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT_LAYER

        public static final Integer DEFAULT_LAYER
        Convenience object defining the Default layer. Equivalent to new Integer(0).

      • PALETTE_LAYER

        public static final Integer PALETTE_LAYER
        Convenience object defining the Palette layer. Equivalent to new Integer(100).

      • MODAL_LAYER

        public static final Integer MODAL_LAYER
        Convenience object defining the Modal layer. Equivalent to new Integer(200).

      • POPUP_LAYER

        public static final Integer POPUP_LAYER
        Convenience object defining the Popup layer. Equivalent to new Integer(300).

      • DRAG_LAYER

        public static final Integer DRAG_LAYER
        Convenience object defining the Drag layer. Equivalent to new Integer(400).

      • FRAME_CONTENT_LAYER

        public static final Integer FRAME_CONTENT_LAYER
        Convenience object defining the Frame Content layer. This layer is normally only use to positon the contentPane and menuBar components of JFrame. Equivalent to new Integer(-30000).
        另请参见：
        JFrame

      • LAYER_PROPERTY

        public static final String LAYER_PROPERTY
        Bound property
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JLayeredPane

        public JLayeredPane()
        Create a new JLayeredPane

    • 方法详细信息

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Description copied from class: Container
        Adds the specified component to this container at the specified index. This method also notifies the layout manager to add the component to this container's layout using the specified constraints object via the addLayoutComponent method.

        The constraints are defined by the particular layout manager being used. For example, the BorderLayout class defines five constraints: BorderLayout.NORTH, BorderLayout.SOUTH, BorderLayout.EAST, BorderLayout.WEST, and BorderLayout.CENTER.

        The GridBagLayout class requires a GridBagConstraints object. Failure to pass the correct type of constraints object results in an IllegalArgumentException.

        If the current layout manager implements LayoutManager2, then LayoutManager2.addLayoutComponent(Component,Object) is invoked on it. If the current layout manager does not implement LayoutManager2, and constraints is a String, then LayoutManager.addLayoutComponent(String,Component) is invoked on it.

        If the component is not an ancestor of this container and has a non-null parent, it is removed from its current parent before it is added to this container.

        This is the method to override if a program needs to track every add request to a container as all other add methods defer to this one. An overriding method should usually include a call to the superclass's version of the method:

        super.addImpl(comp, constraints, index)

        This method changes layout-related information, and therefore, invalidates the component hierarchy. If the container has already been displayed, the hierarchy must be validated thereafter in order to display the added component.

        重载：
        addImpl in class Container
        参数：
        comp - the component to be added
        constraints - an object expressing layout constraints for this component
        index - the position in the container's list at which to insert the component, where -1 means append to the end
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • remove

        public void remove(int index)
        Remove the indexed component from this pane. This is the absolute index, ignoring layers.
        重载：
        remove in class Container
        参数：
        index - an int specifying the component to remove
        另请参见：
        getIndexOf(java.awt.Component)

      • removeAll

        public void removeAll()
        Removes all the components from this container.
        重载：
        removeAll in class Container
        从以下版本开始：
        1.5
        另请参见：
        Container.add(java.awt.Component),
Container.remove(int),
Container.invalidate()

      • isOptimizedDrawingEnabled

        public boolean isOptimizedDrawingEnabled()
        Returns false if components in the pane can overlap, which makes optimized drawing impossible. Otherwise, returns true.
        重载：
        isOptimizedDrawingEnabled in class JComponent
        返回：
        false if components can overlap, else true
        另请参见：
        JComponent.isOptimizedDrawingEnabled()

      • putLayer

        public static void putLayer(JComponent c,
            int layer)
        Sets the layer property on a JComponent. This method does not cause any side effects like setLayer() (painting, add/remove, etc). Normally you should use the instance method setLayer(), in order to get the desired side-effects (like repainting).
        参数：
        c - the JComponent to move
        layer - an int specifying the layer to move it to
        另请参见：
        setLayer(java.awt.Component, int)

      • getLayer

        public static int getLayer(JComponent c)
        Gets the layer property for a JComponent, it does not cause any side effects like setLayer(). (painting, add/remove, etc) Normally you should use the instance method getLayer().
        参数：
        c - the JComponent to check
        返回：
        an int specifying the component's layer

      • getLayeredPaneAbove

        public static JLayeredPane getLayeredPaneAbove(Component c)
        Convenience method that returns the first JLayeredPane which contains the specified component. Note that all JFrames have a JLayeredPane at their root, so any component in a JFrame will have a JLayeredPane parent.
        参数：
        c - the Component to check
        返回：
        the JLayeredPane that contains the component, or null if no JLayeredPane is found in the component hierarchy
        另请参见：
        JFrame, JRootPane

      • setLayer

        public void setLayer(Component c,
            int layer)
        Sets the layer attribute on the specified component, making it the bottommost component in that layer. Should be called before adding to parent.
        参数：
        c - the Component to set the layer for
        layer - an int specifying the layer to set, where lower numbers are closer to the bottom

      • setLayer

        public void setLayer(Component c,
            int layer,
            int position)
        Sets the layer attribute for the specified component and also sets its position within that layer.
        参数：
        c - the Component to set the layer for
        layer - an int specifying the layer to set, where lower numbers are closer to the bottom
        position - an int specifying the position within the layer, where 0 is the topmost position and -1 is the bottommost position

      • getLayer

        public int getLayer(Component c)
        Returns the layer attribute for the specified Component.
        参数：
        c - the Component to check
        返回：
        an int specifying the component's current layer

      • getIndexOf

        public int getIndexOf(Component c)
        Returns the index of the specified Component. This is the absolute index, ignoring layers. Index numbers, like position numbers, have the topmost component at index zero. Larger numbers are closer to the bottom.
        参数：
        c - the Component to check
        返回：
        an int specifying the component's index

      • moveToFront

        public void moveToFront(Component c)
        Moves the component to the top of the components in its current layer (position 0).
        参数：
        c - the Component to move
        另请参见：
        setPosition(Component, int)

      • moveToBack

        public void moveToBack(Component c)
        Moves the component to the bottom of the components in its current layer (position -1).
        参数：
        c - the Component to move
        另请参见：
        setPosition(Component, int)

      • setPosition

        public void setPosition(Component c,
               int position)
        Moves the component to position within its current layer, where 0 is the topmost position within the layer and -1 is the bottommost position.

        Note: Position numbering is defined by java.awt.Container, and is the opposite of layer numbering. Lower position numbers are closer to the top (0 is topmost), and higher position numbers are closer to the bottom.

        参数：
        c - the Component to move
        position - an int in the range -1..N-1, where N is the number of components in the component's current layer

      • getPosition

        public int getPosition(Component c)
        Get the relative position of the component within its layer.
        参数：
        c - the Component to check
        返回：
        an int giving the component's position, where 0 is the topmost position and the highest index value = the count count of components at that layer, minus 1
        另请参见：
        getComponentCountInLayer(int)

      • highestLayer

        public int highestLayer()
        Returns the highest layer value from all current children. Returns 0 if there are no children.
        返回：
        an int indicating the layer of the topmost component in the pane, or zero if there are no children

      • lowestLayer

        public int lowestLayer()
        Returns the lowest layer value from all current children. Returns 0 if there are no children.
        返回：
        an int indicating the layer of the bottommost component in the pane, or zero if there are no children

      • getComponentCountInLayer

        public int getComponentCountInLayer(int layer)
        Returns the number of children currently in the specified layer.
        参数：
        layer - an int specifying the layer to check
        返回：
        an int specifying the number of components in that layer

      • getComponentsInLayer

        public Component[] getComponentsInLayer(int layer)
        Returns an array of the components in the specified layer.
        参数：
        layer - an int specifying the layer to check
        返回：
        an array of Components contained in that layer

      • paint

        public void paint(Graphics g)
        Paints this JLayeredPane within the specified graphics context.
        重载：
        paint in class JComponent
        参数：
        g - the Graphics context within which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • getComponentToLayer

        protected Hashtable<Component,Integer> getComponentToLayer()
        Returns the hashtable that maps components to layers.
        返回：
        the Hashtable used to map components to their layers

      • getObjectForLayer

        protected Integer getObjectForLayer(int layer)
        Returns the Integer object associated with a specified layer.
        参数：
        layer - an int specifying the layer
        返回：
        an Integer object for that layer

      • insertIndexForLayer

        protected int insertIndexForLayer(int layer,
                      int position)
        Primitive method that determines the proper location to insert a new child based on layer and position requests.
        参数：
        layer - an int specifying the layer
        position - an int specifying the position within the layer
        返回：
        an int giving the (absolute) insertion-index
        另请参见：
        getIndexOf(java.awt.Component)

      • paramString

        protected String paramString()
        Returns a string representation of this JLayeredPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JLayeredPane.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JLayeredPane. For layered panes, the AccessibleContext takes the form of an AccessibleJLayeredPane. A new AccessibleJLayeredPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJLayeredPane that serves as the AccessibleContext of this JLayeredPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JLayeredPane.AccessibleJLayeredPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JLayeredPane.AccessibleJLayeredPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JLayeredPane

    protected class JLayeredPane.AccessibleJLayeredPane
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JLayeredPane class. It provides an implementation of the Java Accessibility API appropriate to layered pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JLayeredPane.AccessibleJLayeredPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JLayeredPane.AccessibleJLayeredPane

        protected JLayeredPane.AccessibleJLayeredPane()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otddt>F">FliiFlls<""enPgpsop mcntclolebb is>vcPa


JList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JList<E>

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JList<E>
  • 类型参数：
    E - the type of the elements of this list
    所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable

    public class JList<E>
extends JComponent
implements Scrollable, Accessible
    A component that displays a list of objects and allows the user to select one or more items. A separate model, ListModel, maintains the contents of the list.

    It's easy to display an array or Vector of objects, using the JList constructor that automatically builds a read-only ListModel instance for you:

     // Create a JList that displays strings from an array

 String[] data = {"one", "two", "three", "four"};
 JList<String> myList = new JList<String>(data);

 // Create a JList that displays the superclasses of JList.class, by
 // creating it with a Vector populated with this data

 Vector<Class<?>> superClasses = new Vector<Class<?>>();
 Class<JList> rootClass = javax.swing.JList.class;
 for(Class<?> cls = rootClass; cls != null; cls = cls.getSuperclass()) {
     superClasses.addElement(cls);
 }
 JList<Class<?>> myList = new JList<Class<?>>(superClasses);

 // The automatically created model is stored in JList's "model"
 // property, which you can retrieve

 ListModel<Class<?>> model = myList.getModel();
 for(int i = 0; i < model.getSize(); i++) {
     System.out.println(model.getElementAt(i));
 }

    A ListModel can be supplied directly to a JList by way of a constructor or the setModel method. The contents need not be static - the number of items, and the values of items can change over time. A correct ListModel implementation notifies the set of javax.swing.event.ListDataListeners that have been added to it, each time a change occurs. These changes are characterized by a javax.swing.event.ListDataEvent, which identifies the range of list indices that have been modified, added, or removed. JList's ListUI is responsible for keeping the visual representation up to date with changes, by listening to the model.

    Simple, dynamic-content, JList applications can use the DefaultListModel class to maintain list elements. This class implements the ListModel interface and also provides a java.util.Vector-like API. Applications that need a more custom ListModel implementation may instead wish to subclass AbstractListModel, which provides basic support for managing and notifying listeners. For example, a read-only implementation of AbstractListModel:

     // This list model has about 2^16 elements.  Enjoy scrolling.

 ListModel<String> bigData = new AbstractListModel<String>() {
     public int getSize() { return Short.MAX_VALUE; }
     public String getElementAt(int index) { return "Index " + index; }
 };

    The selection state of a JList is managed by another separate model, an instance of ListSelectionModel. JList is initialized with a selection model on construction, and also contains methods to query or set this selection model. Additionally, JList provides convenient methods for easily managing the selection. These methods, such as setSelectedIndex and getSelectedValue, are cover methods that take care of the details of interacting with the selection model. By default, JList's selection model is configured to allow any combination of items to be selected at a time; selection mode MULTIPLE_INTERVAL_SELECTION. The selection mode can be changed on the selection model directly, or via JList's cover method. Responsibility for updating the selection model in response to user gestures lies with the list's ListUI.

    A correct ListSelectionModel implementation notifies the set of javax.swing.event.ListSelectionListeners that have been added to it each time a change to the selection occurs. These changes are characterized by a javax.swing.event.ListSelectionEvent, which identifies the range of the selection change.

    The preferred way to listen for changes in list selection is to add ListSelectionListeners directly to the JList. JList then takes care of listening to the the selection model and notifying your listeners of change.

    Responsibility for listening to selection changes in order to keep the list's visual representation up to date lies with the list's ListUI.

    Painting of cells in a JList is handled by a delegate called a cell renderer, installed on the list as the cellRenderer property. The renderer provides a java.awt.Component that is used like a "rubber stamp" to paint the cells. Each time a cell needs to be painted, the list's ListUI asks the cell renderer for the component, moves it into place, and has it paint the contents of the cell by way of its paint method. A default cell renderer, which uses a JLabel component to render, is installed by the lists's ListUI. You can substitute your own renderer using code like this:

     // Display an icon and a string for each object in the list.

 class MyCellRenderer extends JLabel implements ListCellRenderer<Object> {
     final static ImageIcon longIcon = new ImageIcon("long.gif");
     final static ImageIcon shortIcon = new ImageIcon("short.gif");

     // This is the only method defined by ListCellRenderer.
     // We just reconfigure the JLabel each time we're called.

     public Component getListCellRendererComponent(
       JList<?> list,           // the list
       Object value,            // value to display
       int index,               // cell index
       boolean isSelected,      // is the cell selected
       boolean cellHasFocus)    // does the cell have focus
     {
         String s = value.toString();
         setText(s);
         setIcon((s.length() > 10) ? longIcon : shortIcon);
         if (isSelected) {
             setBackground(list.getSelectionBackground());
             setForeground(list.getSelectionForeground());
         } else {
             setBackground(list.getBackground());
             setForeground(list.getForeground());
         }
         setEnabled(list.isEnabled());
         setFont(list.getFont());
         setOpaque(true);
         return this;
     }
 }

 myList.setCellRenderer(new MyCellRenderer());

    Another job for the cell renderer is in helping to determine sizing information for the list. By default, the list's ListUI determines the size of cells by asking the cell renderer for its preferred size for each list item. This can be expensive for large lists of items. To avoid these calculations, you can set a fixedCellWidth and fixedCellHeight on the list, or have these values calculated automatically based on a single prototype value:

     JList<String> bigDataList = new JList<String>(bigData);

 // We don't want the JList implementation to compute the width
 // or height of all of the list cells, so we give it a string
 // that's as big as we'll need for any cell.  It uses this to
 // compute values for the fixedCellWidth and fixedCellHeight
 // properties.

 bigDataList.setPrototypeCellValue("Index 1234567890");

    JList doesn't implement scrolling directly. To create a list that scrolls, make it the viewport view of a JScrollPane. For example:

     JScrollPane scrollPane = new JScrollPane(myList);

 // Or in two steps:
 JScrollPane scrollPane = new JScrollPane();
 scrollPane.getViewport().setView(myList);

    JList doesn't provide any special handling of double or triple (or N) mouse clicks, but it's easy to add a MouseListener if you wish to take action on these events. Use the locationToIndex method to determine what cell was clicked. For example:

     MouseListener mouseListener = new MouseAdapter() {
     public void mouseClicked(MouseEvent e) {
         if (e.getClickCount() == 2) {
             int index = list.locationToIndex(e.getPoint());
             System.out.println("Double clicked on Item " + index);
          }
     }
 };
 list.addMouseListener(mouseListener);

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    See How to Use Lists in The Java Tutorial for further documentation. Also see the article Advanced JList Programming in The Swing Connection.

    另请参见：
    ListModel, AbstractListModel, DefaultListModel, ListSelectionModel, DefaultListSelectionModel, ListCellRenderer, DefaultListCellRenderer

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JList.AccessibleJList
      This class implements accessibility support for the JList class.
      static class  JList.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JList.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int HORIZONTAL_WRAP
      Indicates a "newspaper style" layout with cells flowing horizontally then vertically.
      static int VERTICAL
      Indicates a vertical layout of cells, in a single column; the default layout.
      static int VERTICAL_WRAP
      Indicates a "newspaper style" layout with cells flowing vertically then horizontally.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JList()
      Constructs a JList with an empty, read-only, model.
      JList(E[] listData)
      Constructs a JList that displays the elements in the specified array.
      JList(ListModel<E> dataModel)
      Constructs a JList that displays elements from the specified, non-null, model.
      JList(Vector<? extends E> listData)
      Constructs a JList that displays the elements in the specified Vector.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addListSelectionListener(ListSelectionListener listener)
      Adds a listener to the list, to be notified each time a change to the selection occurs; the preferred way of listening for selection state changes.
      void addSelectionInterval(int anchor, int lead)
      Sets the selection to be the union of the specified interval with current selection.
      void clearSelection()
      Clears the selection; after calling this method, isSelectionEmpty will return true.
      protected ListSelectionModel createSelectionModel()
      Returns an instance of DefaultListSelectionModel; called during construction to initialize the list's selection model property.
      void ensureIndexIsVisible(int index)
      Scrolls the list within an enclosing viewport to make the specified cell completely visible.
      protected void fireSelectionValueChanged(int firstIndex, int lastIndex, boolean isAdjusting)
      Notifies ListSelectionListeners added directly to the list of selection changes made to the selection model.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JList.
      int getAnchorSelectionIndex()
      Returns the anchor selection index.
      Rectangle getCellBounds(int index0, int index1)
      Returns the bounding rectangle, in the list's coordinate system, for the range of cells specified by the two indices.
      ListCellRenderer<? super E> getCellRenderer()
      Returns the object responsible for painting list items.
      boolean getDragEnabled()
      Returns whether or not automatic drag handling is enabled.
      JList.DropLocation getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
      DropMode getDropMode()
      Returns the drop mode for this component.
      int getFirstVisibleIndex()
      Returns the smallest list index that is currently visible.
      int getFixedCellHeight()
      Returns the value of the fixedCellHeight property.
      int getFixedCellWidth()
      Returns the value of the fixedCellWidth property.
      int getLastVisibleIndex()
      Returns the largest list index that is currently visible.
      int getLayoutOrientation()
      Returns the layout orientation property for the list: VERTICAL if the layout is a single column of cells, VERTICAL_WRAP if the layout is "newspaper style" with the content flowing vertically then horizontally, or HORIZONTAL_WRAP if the layout is "newspaper style" with the content flowing horizontally then vertically.
      int getLeadSelectionIndex()
      Returns the lead selection index.
      ListSelectionListener[] getListSelectionListeners()
      Returns an array of all the ListSelectionListeners added to this JList by way of addListSelectionListener.
      int getMaxSelectionIndex()
      Returns the largest selected cell index, or -1 if the selection is empty.
      int getMinSelectionIndex()
      Returns the smallest selected cell index, or -1 if the selection is empty.
      ListModel<E> getModel()
      Returns the data model that holds the list of items displayed by the JList component.
      int getNextMatch(String prefix, int startIndex, Position.Bias bias)
      Returns the next list element whose toString value starts with the given prefix.
      Dimension getPreferredScrollableViewportSize()
      Computes the size of viewport needed to display visibleRowCount rows.
      E getPrototypeCellValue()
      Returns the "prototypical" cell value -- a value used to calculate a fixed width and height for cells.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns the distance to scroll to expose the next or previous block.
      boolean getScrollableTracksViewportHeight()
      Returns true if this JList is displayed in a JViewport and the viewport is taller than the list's preferred height, or if the layout orientation is VERTICAL_WRAP and visibleRowCount <= 0; otherwise returns false.
      boolean getScrollableTracksViewportWidth()
      Returns true if this JList is displayed in a JViewport and the viewport is wider than the list's preferred width, or if the layout orientation is HORIZONTAL_WRAP and visibleRowCount <= 0; otherwise returns false.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns the distance to scroll to expose the next or previous row (for vertical scrolling) or column (for horizontal scrolling).
      int getSelectedIndex()
      Returns the smallest selected cell index; the selection when only a single item is selected in the list.
      int[] getSelectedIndices()
      Returns an array of all of the selected indices, in increasing order.
      E getSelectedValue()
      Returns the value for the smallest selected cell index; the selected value when only a single item is selected in the list.
      Object[] getSelectedValues()
      Deprecated.
      As of JDK 1.7, replaced by getSelectedValuesList()
      List<E> getSelectedValuesList()
      Returns a list of all the selected items, in increasing order based on their indices in the list.
      Color getSelectionBackground()
      Returns the color used to draw the background of selected items.
      Color getSelectionForeground()
      Returns the color used to draw the foreground of selected items.
      int getSelectionMode()
      Returns the current selection mode for the list.
      ListSelectionModel getSelectionModel()
      Returns the current selection model.
      String getToolTipText(MouseEvent event)
      Returns the tooltip text to be used for the given event.
      ListUI getUI()
      Returns the ListUI, the look and feel object that renders this component.
      String getUIClassID()
      Returns "ListUI", the UIDefaults key used to look up the name of the javax.swing.plaf.ListUI class that defines the look and feel for this component.
      boolean getValueIsAdjusting()
      Returns the value of the selection model's isAdjusting property.
      int getVisibleRowCount()
      Returns the value of the visibleRowCount property.
      Point indexToLocation(int index)
      Returns the origin of the specified item in the list's coordinate system.
      boolean isSelectedIndex(int index)
      Returns true if the specified index is selected, else false.
      boolean isSelectionEmpty()
      Returns true if nothing is selected, else false.
      int locationToIndex(Point location)
      Returns the cell index closest to the given location in the list's coordinate system.
      protected String paramString()
      Returns a String representation of this JList.
      void removeListSelectionListener(ListSelectionListener listener)
      Removes a selection listener from the list.
      void removeSelectionInterval(int index0, int index1)
      Sets the selection to be the set difference of the specified interval and the current selection.
      void setCellRenderer(ListCellRenderer<? super E> cellRenderer)
      Sets the delegate that is used to paint each cell in the list.
      void setDragEnabled(boolean b)
      Turns on or off automatic drag handling.
      void setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void setFixedCellHeight(int height)
      Sets a fixed value to be used for the height of every cell in the list.
      void setFixedCellWidth(int width)
      Sets a fixed value to be used for the width of every cell in the list.
      void setLayoutOrientation(int layoutOrientation)
      Defines the way list cells are layed out.
      void setListData(E[] listData)
      Constructs a read-only ListModel from an array of items, and calls setModel with this model.
      void setListData(Vector<? extends E> listData)
      Constructs a read-only ListModel from a Vector and calls setModel with this model.
      void setModel(ListModel<E> model)
      Sets the model that represents the contents or "value" of the list, notifies property change listeners, and then clears the list's selection.
      void setPrototypeCellValue(E prototypeCellValue)
      Sets the prototypeCellValue property, and then (if the new value is non-null), computes the fixedCellWidth and fixedCellHeight properties by requesting the cell renderer component for the given value (and index 0) from the cell renderer, and using that component's preferred size.
      void setSelectedIndex(int index)
      Selects a single cell.
      void setSelectedIndices(int[] indices)
      Changes the selection to be the set of indices specified by the given array.
      void setSelectedValue(Object anObject, boolean shouldScroll)
      Selects the specified object from the list.
      void setSelectionBackground(Color selectionBackground)
      Sets the color used to draw the background of selected items, which cell renderers can use fill selected cells.
      void setSelectionForeground(Color selectionForeground)
      Sets the color used to draw the foreground of selected items, which cell renderers can use to render text and graphics.
      void setSelectionInterval(int anchor, int lead)
      Selects the specified interval.
      void setSelectionMode(int selectionMode)
      Sets the selection mode for the list.
      void setSelectionModel(ListSelectionModel selectionModel)
      Sets the selectionModel for the list to a non-null ListSelectionModel implementation.
      void setUI(ListUI ui)
      Sets the ListUI, the look and feel object that renders this component.
      void setValueIsAdjusting(boolean b)
      Sets the selection model's valueIsAdjusting property.
      void setVisibleRowCount(int visibleRowCount)
      Sets the visibleRowCount property, which has different meanings depending on the layout orientation: For a VERTICAL layout orientation, this sets the preferred number of rows to display without requiring scrolling; for other orientations, it affects the wrapping of cells.
      void updateUI()
      Resets the ListUI property by setting it to the value provided by the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • VERTICAL

        public static final int VERTICAL
        Indicates a vertical layout of cells, in a single column; the default layout.
        从以下版本开始：
        1.4
        另请参见：
        setLayoutOrientation(int), Constant Field Values

      • VERTICAL_WRAP

        public static final int VERTICAL_WRAP
        Indicates a "newspaper style" layout with cells flowing vertically then horizontally.
        从以下版本开始：
        1.4
        另请参见：
        setLayoutOrientation(int), Constant Field Values

      • HORIZONTAL_WRAP

        public static final int HORIZONTAL_WRAP
        Indicates a "newspaper style" layout with cells flowing horizontally then vertically.
        从以下版本开始：
        1.4
        另请参见：
        setLayoutOrientation(int), Constant Field Values

    • 构造方法详细信息

      • JList

        public JList(ListModel<E> dataModel)
        Constructs a JList that displays elements from the specified, non-null, model. All JList constructors delegate to this one.

        This constructor registers the list with the ToolTipManager, allowing for tooltips to be provided by the cell renderers.

        参数：
        dataModel - the model for the list
        抛出：
        IllegalArgumentException - if the model is null

      • JList

        public JList(E[] listData)
        Constructs a JList that displays the elements in the specified array. This constructor creates a read-only model for the given array, and then delegates to the constructor that takes a ListModel.

        Attempts to pass a null value to this method results in undefined behavior and, most likely, exceptions. The created model references the given array directly. Attempts to modify the array after constructing the list results in undefined behavior.

        参数：
        listData - the array of Objects to be loaded into the data model, non-null

      • JList

        public JList(Vector<? extends E> listData)
        Constructs a JList that displays the elements in the specified Vector. This constructor creates a read-only model for the given Vector, and then delegates to the constructor that takes a ListModel.

        Attempts to pass a null value to this method results in undefined behavior and, most likely, exceptions. The created model references the given Vector directly. Attempts to modify the Vector after constructing the list results in undefined behavior.

        参数：
        listData - the Vector to be loaded into the data model, non-null

      • JList

        public JList()
        Constructs a JList with an empty, read-only, model.

    • 方法详细信息

      • getUI

        public ListUI getUI()
        Returns the ListUI, the look and feel object that renders this component.
        返回：
        the ListUI object that renders this component

      • setUI

        public void setUI(ListUI ui)
        Sets the ListUI, the look and feel object that renders this component.
        参数：
        ui - the ListUI object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the ListUI property by setting it to the value provided by the current look and feel. If the current cell renderer was installed by the developer (rather than the look and feel itself), this also causes the cell renderer and its children to be updated, by calling SwingUtilities.updateComponentTreeUI on it.
        重载：
        updateUI in class JComponent
        另请参见：
        UIManager.getUI(javax.swing.JComponent), SwingUtilities.updateComponentTreeUI(java.awt.Component)

      • getUIClassID

        public String getUIClassID()
        Returns "ListUI", the UIDefaults key used to look up the name of the javax.swing.plaf.ListUI class that defines the look and feel for this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ListUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getPrototypeCellValue

        public E getPrototypeCellValue()
        Returns the "prototypical" cell value -- a value used to calculate a fixed width and height for cells. This can be null if there is no such value.
        返回：
        the value of the prototypeCellValue property
        另请参见：
        setPrototypeCellValue(E)

      • setPrototypeCellValue

        public void setPrototypeCellValue(E prototypeCellValue)
        Sets the prototypeCellValue property, and then (if the new value is non-null), computes the fixedCellWidth and fixedCellHeight properties by requesting the cell renderer component for the given value (and index 0) from the cell renderer, and using that component's preferred size.

        This method is useful when the list is too long to allow the ListUI to compute the width/height of each cell, and there is a single cell value that is known to occupy as much space as any of the others, a so-called prototype.

        While all three of the prototypeCellValue, fixedCellHeight, and fixedCellWidth properties may be modified by this method, PropertyChangeEvent notifications are only sent when the prototypeCellValue property changes.

        To see an example which sets this property, see the class description above.

        The default value of this property is null.

        This is a JavaBeans bound property.

        参数：
        prototypeCellValue - the value on which to base fixedCellWidth and fixedCellHeight
        另请参见：
        getPrototypeCellValue(), setFixedCellWidth(int), setFixedCellHeight(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getFixedCellWidth

        public int getFixedCellWidth()
        Returns the value of the fixedCellWidth property.
        返回：
        the fixed cell width
        另请参见：
        setFixedCellWidth(int)

      • setFixedCellWidth

        public void setFixedCellWidth(int width)
        Sets a fixed value to be used for the width of every cell in the list. If width is -1, cell widths are computed in the ListUI by applying getPreferredSize to the cell renderer component for each list element.

        The default value of this property is -1.

        This is a JavaBeans bound property.

        参数：
        width - the width to be used for all cells in the list
        另请参见：
        setPrototypeCellValue(E), setFixedCellWidth(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getFixedCellHeight

        public int getFixedCellHeight()
        Returns the value of the fixedCellHeight property.
        返回：
        the fixed cell height
        另请参见：
        setFixedCellHeight(int)

      • setFixedCellHeight

        public void setFixedCellHeight(int height)
        Sets a fixed value to be used for the height of every cell in the list. If height is -1, cell heights are computed in the ListUI by applying getPreferredSize to the cell renderer component for each list element.

        The default value of this property is -1.

        This is a JavaBeans bound property.

        参数：
        height - the height to be used for for all cells in the list
        另请参见：
        setPrototypeCellValue(E), setFixedCellWidth(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getCellRenderer

        public ListCellRenderer<? super E> getCellRenderer()
        Returns the object responsible for painting list items.
        返回：
        the value of the cellRenderer property
        另请参见：
        setCellRenderer(javax.swing.ListCellRenderer)

      • setCellRenderer

        public void setCellRenderer(ListCellRenderer<? super E> cellRenderer)
        Sets the delegate that is used to paint each cell in the list. The job of a cell renderer is discussed in detail in the class level documentation.

        If the prototypeCellValue property is non-null, setting the cell renderer also causes the fixedCellWidth and fixedCellHeight properties to be re-calculated. Only one PropertyChangeEvent is generated however - for the cellRenderer property.

        The default value of this property is provided by the ListUI delegate, i.e. by the look and feel implementation.

        This is a JavaBeans bound property.

        参数：
        cellRenderer - the ListCellRenderer that paints list cells
        另请参见：
        getCellRenderer()

      • getSelectionForeground

        public Color getSelectionForeground()
        Returns the color used to draw the foreground of selected items. DefaultListCellRenderer uses this color to draw the foreground of items in the selected state, as do the renderers installed by most ListUI implementations.
        返回：
        the color to draw the foreground of selected items
        另请参见：
        setSelectionForeground(java.awt.Color), DefaultListCellRenderer

      • setSelectionForeground

        public void setSelectionForeground(Color selectionForeground)
        Sets the color used to draw the foreground of selected items, which cell renderers can use to render text and graphics. DefaultListCellRenderer uses this color to draw the foreground of items in the selected state, as do the renderers installed by most ListUI implementations.

        The default value of this property is defined by the look and feel implementation.

        This is a JavaBeans bound property.

        参数：
        selectionForeground - the Color to use in the foreground for selected list items
        另请参见：
        getSelectionForeground(),
setSelectionBackground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font),
DefaultListCellRenderer

      • getSelectionBackground

        public Color getSelectionBackground()
        Returns the color used to draw the background of selected items. DefaultListCellRenderer uses this color to draw the background of items in the selected state, as do the renderers installed by most ListUI implementations.
        返回：
        the color to draw the background of selected items
        另请参见：
        setSelectionBackground(java.awt.Color), DefaultListCellRenderer

      • setSelectionBackground

        public void setSelectionBackground(Color selectionBackground)
        Sets the color used to draw the background of selected items, which cell renderers can use fill selected cells. DefaultListCellRenderer uses this color to fill the background of items in the selected state, as do the renderers installed by most ListUI implementations.

        The default value of this property is defined by the look and feel implementation.

        This is a JavaBeans bound property.

        参数：
        selectionBackground - the Color to use for the background of selected cells
        另请参见：
        getSelectionBackground(),
setSelectionForeground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font),
DefaultListCellRenderer

      • getVisibleRowCount

        public int getVisibleRowCount()
        Returns the value of the visibleRowCount property. See the documentation for setVisibleRowCount(int) for details on how to interpret this value.
        返回：
        the value of the visibleRowCount property.
        另请参见：
        setVisibleRowCount(int)

      • setVisibleRowCount

        public void setVisibleRowCount(int visibleRowCount)
        Sets the visibleRowCount property, which has different meanings depending on the layout orientation: For a VERTICAL layout orientation, this sets the preferred number of rows to display without requiring scrolling; for other orientations, it affects the wrapping of cells.

        In VERTICAL orientation:
        Setting this property affects the return value of the getPreferredScrollableViewportSize() method, which is used to calculate the preferred size of an enclosing viewport. See that method's documentation for more details.

        In HORIZONTAL_WRAP and VERTICAL_WRAP orientations:
        This affects how cells are wrapped. See the documentation of setLayoutOrientation(int) for more details.

        The default value of this property is 8.

        Calling this method with a negative value results in the property being set to 0.

        This is a JavaBeans bound property.

        参数：
        visibleRowCount - an integer specifying the preferred number of rows to display without requiring scrolling
        另请参见：
        getVisibleRowCount(), getPreferredScrollableViewportSize(), setLayoutOrientation(int), JComponent.getVisibleRect(), JViewport

      • getLayoutOrientation

        public int getLayoutOrientation()
        Returns the layout orientation property for the list: VERTICAL if the layout is a single column of cells, VERTICAL_WRAP if the layout is "newspaper style" with the content flowing vertically then horizontally, or HORIZONTAL_WRAP if the layout is "newspaper style" with the content flowing horizontally then vertically.
        返回：
        the value of the layoutOrientation property
        从以下版本开始：
        1.4
        另请参见：
        setLayoutOrientation(int)

      • setLayoutOrientation

        public void setLayoutOrientation(int layoutOrientation)
        Defines the way list cells are layed out. Consider a JList with five cells. Cells can be layed out in one of the following ways:

         VERTICAL:          0
                    1
                    2
                    3
                    4

 HORIZONTAL_WRAP:   0  1  2
                    3  4

 VERTICAL_WRAP:     0  3
                    1  4
                    2

        A description of these layouts follows:

        Value

        描述

        VERTICAL | Cells are layed out vertically in a single column.
        HORIZONTAL_WRAP | Cells are layed out horizontally, wrapping to a new row as necessary. If the visibleRowCount property is less than or equal to zero, wrapping is determined by the width of the list; otherwise wrapping is done in such a way as to ensure visibleRowCount rows in the list.
        VERTICAL_WRAP | Cells are layed out vertically, wrapping to a new column as necessary. If the visibleRowCount property is less than or equal to zero, wrapping is determined by the height of the list; otherwise wrapping is done at visibleRowCount rows.

        The default value of this property is VERTICAL.

        参数：
        layoutOrientation - the new layout orientation, one of: VERTICAL, HORIZONTAL_WRAP or VERTICAL_WRAP
        抛出：
        IllegalArgumentException - if layoutOrientation isn't one of the allowable values
        从以下版本开始：
        1.4
        另请参见：
        getLayoutOrientation(), setVisibleRowCount(int), getScrollableTracksViewportHeight(), getScrollableTracksViewportWidth()

      • getFirstVisibleIndex

        public int getFirstVisibleIndex()
        Returns the smallest list index that is currently visible. In a left-to-right componentOrientation, the first visible cell is found closest to the list's upper-left corner. In right-to-left orientation, it is found closest to the upper-right corner. If nothing is visible or the list is empty, -1 is returned. Note that the returned cell may only be partially visible.
        返回：
        the index of the first visible cell
        另请参见：
        getLastVisibleIndex(), JComponent.getVisibleRect()

      • getLastVisibleIndex

        public int getLastVisibleIndex()
        Returns the largest list index that is currently visible. If nothing is visible or the list is empty, -1 is returned. Note that the returned cell may only be partially visible.
        返回：
        the index of the last visible cell
        另请参见：
        getFirstVisibleIndex(), JComponent.getVisibleRect()

      • ensureIndexIsVisible

        public void ensureIndexIsVisible(int index)
        Scrolls the list within an enclosing viewport to make the specified cell completely visible. This calls scrollRectToVisible with the bounds of the specified cell. For this method to work, the JList must be within a JViewport.

        If the given index is outside the list's range of cells, this method results in nothing.

        参数：
        index - the index of the cell to make visible
        另请参见：
        JComponent.scrollRectToVisible(java.awt.Rectangle), JComponent.getVisibleRect()

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Turns on or off automatic drag handling. In order to enable automatic drag handling, this property should be set to true, and the list's TransferHandler needs to be non-null. The default value of the dragEnabled property is false.

        The job of honoring this property, and recognizing a user drag gesture, lies with the look and feel implementation, and in particular, the list's ListUI. When automatic drag handling is enabled, most look and feels (including those that subclass BasicLookAndFeel) begin a drag and drop operation whenever the user presses the mouse button over an item and then moves the mouse a few pixels. Setting this property to true can therefore have a subtle effect on how selections behave.

        If a look and feel is used that ignores this property, you can still begin a drag and drop operation by calling exportAsDrag on the list's TransferHandler.

        参数：
        b - whether or not to enable automatic drag handling
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Returns whether or not automatic drag handling is enabled.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • setDropMode

        public final void setDropMode(DropMode dropMode)
        Sets the drop mode for this component. For backward compatibility, the default for this property is DropMode.USE_SELECTION. Usage of one of the other modes is recommended, however, for an improved user experience. DropMode.ON, for instance, offers similar behavior of showing items as selected, but does so without affecting the actual selection in the list.

        JList supports the following drop modes:

        • DropMode.USE_SELECTION
        • DropMode.ON
        • DropMode.INSERT
        • DropMode.ON_OR_INSERT
        The drop mode is only meaningful if this component has a TransferHandler that accepts drops.
        参数：
        dropMode - the drop mode to use
        抛出：
        IllegalArgumentException - if the drop mode is unsupported or null
        从以下版本开始：
        1.6
        另请参见：
        getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDropMode

        public final DropMode getDropMode()
        Returns the drop mode for this component.
        返回：
        the drop mode for this component
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode)

      • getDropLocation

        public final JList.DropLocation getDropLocation()
        Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

        This method is not meant for querying the drop location from a TransferHandler, as the drop location is only set after the TransferHandler's canImport has returned and has allowed for the location to be shown.

        When this property changes, a property change event with name "dropLocation" is fired by the component.

        By default, responsibility for listening for changes to this property and indicating the drop location visually lies with the list's ListUI, which may paint it directly and/or install a cell renderer to do so. Developers wishing to implement custom drop location painting and/or replace the default cell renderer, may need to honor this property.

        返回：
        the drop location
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

      • getNextMatch

        public int getNextMatch(String prefix,
               int startIndex,
               Position.Bias bias)
        Returns the next list element whose toString value starts with the given prefix.
        参数：
        prefix - the string to test for a match
        startIndex - the index for starting the search
        bias - the search direction, either Position.Bias.Forward or Position.Bias.Backward.
        返回：
        the index of the next list element that starts with the prefix; otherwise -1
        抛出：
        IllegalArgumentException - if prefix is null or startIndex is out of bounds
        从以下版本开始：
        1.4

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Returns the tooltip text to be used for the given event. This overrides JComponent's getToolTipText to first check the cell renderer component for the cell over which the event occurred, returning its tooltip text, if any. This implementation allows you to specify tooltip text on the cell level, by using setToolTipText on your cell renderer component.

        Note: For JList to properly display the tooltips of its renderers in this manner, JList must be a registered component with the ToolTipManager. This registration is done automatically in the constructor. However, if at a later point JList is unregistered, by way of a call to setToolTipText(null), tips from the renderers will no longer display.

        重载：
        getToolTipText in class JComponent
        参数：
        event - the MouseEvent to fetch the tooltip text for
        另请参见：
        JComponent.setToolTipText(java.lang.String), JComponent.getToolTipText()

      • locationToIndex

        public int locationToIndex(Point location)
        Returns the cell index closest to the given location in the list's coordinate system. To determine if the cell actually contains the specified location, compare the point against the cell's bounds, as provided by getCellBounds. This method returns -1 if the model is empty

        This is a cover method that delegates to the method of the same name in the list's ListUI. It returns -1 if the list has no ListUI.

        参数：
        location - the coordinates of the point
        返回：
        the cell index closest to the given location, or -1

      • indexToLocation

        public Point indexToLocation(int index)
        Returns the origin of the specified item in the list's coordinate system. This method returns null if the index isn't valid.

        This is a cover method that delegates to the method of the same name in the list's ListUI. It returns null if the list has no ListUI.

        参数：
        index - the cell index
        返回：
        the origin of the cell, or null

      • getCellBounds

        public Rectangle getCellBounds(int index0,
                      int index1)
        Returns the bounding rectangle, in the list's coordinate system, for the range of cells specified by the two indices. These indices can be supplied in any order.

        If the smaller index is outside the list's range of cells, this method returns null. If the smaller index is valid, but the larger index is outside the list's range, the bounds of just the first index is returned. Otherwise, the bounds of the valid range is returned.

        This is a cover method that delegates to the method of the same name in the list's ListUI. It returns null if the list has no ListUI.

        参数：
        index0 - the first index in the range
        index1 - the second index in the range
        返回：
        the bounding rectangle for the range of cells, or null

      • getModel

        public ListModel<E> getModel()
        Returns the data model that holds the list of items displayed by the JList component.
        返回：
        the ListModel that provides the displayed list of items
        另请参见：
        setModel(javax.swing.ListModel)

      • setModel

        public void setModel(ListModel<E> model)
        Sets the model that represents the contents or "value" of the list, notifies property change listeners, and then clears the list's selection.

        This is a JavaBeans bound property.

        参数：
        model - the ListModel that provides the list of items for display
        抛出：
        IllegalArgumentException - if model is null
        另请参见：
        getModel(), clearSelection()

      • setListData

        public void setListData(E[] listData)
        Constructs a read-only ListModel from an array of items, and calls setModel with this model.

        Attempts to pass a null value to this method results in undefined behavior and, most likely, exceptions. The created model references the given array directly. Attempts to modify the array after invoking this method results in undefined behavior.

        参数：
        listData - an array of E containing the items to display in the list
        另请参见：
        setModel(javax.swing.ListModel)

      • setListData

        public void setListData(Vector<? extends E> listData)
        Constructs a read-only ListModel from a Vector and calls setModel with this model.

        Attempts to pass a null value to this method results in undefined behavior and, most likely, exceptions. The created model references the given Vector directly. Attempts to modify the Vector after invoking this method results in undefined behavior.

        参数：
        listData - a Vector containing the items to display in the list
        另请参见：
        setModel(javax.swing.ListModel)

      • createSelectionModel

        protected ListSelectionModel createSelectionModel()
        Returns an instance of DefaultListSelectionModel; called during construction to initialize the list's selection model property.
        返回：
        a DefaultListSelecitonModel, used to initialize the list's selection model property during construction
        另请参见：
        setSelectionModel(javax.swing.ListSelectionModel), DefaultListSelectionModel

      • getSelectionModel

        public ListSelectionModel getSelectionModel()
        Returns the current selection model. The selection model maintains the selection state of the list. See the class level documentation for more details.
        返回：
        the ListSelectionModel that maintains the list's selections
        另请参见：
        setSelectionModel(javax.swing.ListSelectionModel), ListSelectionModel

      • fireSelectionValueChanged

        protected void fireSelectionValueChanged(int firstIndex,
                             int lastIndex,
                             boolean isAdjusting)
        Notifies ListSelectionListeners added directly to the list of selection changes made to the selection model. JList listens for changes made to the selection in the selection model, and forwards notification to listeners added to the list directly, by calling this method.

        This method constructs a ListSelectionEvent with this list as the source, and the specified arguments, and sends it to the registered ListSelectionListeners.

        参数：
        firstIndex - the first index in the range, <= lastIndex
        lastIndex - the last index in the range, >= firstIndex
        isAdjusting - whether or not this is one in a series of multiple events, where changes are still being made
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener), removeListSelectionListener(javax.swing.event.ListSelectionListener), ListSelectionEvent, EventListenerList

      • addListSelectionListener

        public void addListSelectionListener(ListSelectionListener listener)
        Adds a listener to the list, to be notified each time a change to the selection occurs; the preferred way of listening for selection state changes. JList takes care of listening for selection state changes in the selection model, and notifies the given listener of each change. ListSelectionEvents sent to the listener have a source property set to this list.
        参数：
        listener - the ListSelectionListener to add
        另请参见：
        getSelectionModel(), getListSelectionListeners()

      • removeListSelectionListener

        public void removeListSelectionListener(ListSelectionListener listener)
        Removes a selection listener from the list.
        参数：
        listener - the ListSelectionListener to remove
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener), getSelectionModel()

      • getListSelectionListeners

        public ListSelectionListener[] getListSelectionListeners()
        Returns an array of all the ListSelectionListeners added to this JList by way of addListSelectionListener.
        返回：
        all of the ListSelectionListeners on this list, or an empty array if no listeners have been added
        从以下版本开始：
        1.4
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • setSelectionModel

        public void setSelectionModel(ListSelectionModel selectionModel)
        Sets the selectionModel for the list to a non-null ListSelectionModel implementation. The selection model handles the task of making single selections, selections of contiguous ranges, and non-contiguous selections.

        This is a JavaBeans bound property.

        参数：
        selectionModel - the ListSelectionModel that implements the selections
        抛出：
        IllegalArgumentException - if selectionModel is null
        另请参见：
        getSelectionModel()

      • setSelectionMode

        public void setSelectionMode(int selectionMode)
        Sets the selection mode for the list. This is a cover method that sets the selection mode directly on the selection model.

        The following list describes the accepted selection modes:

        • ListSelectionModel.SINGLE_SELECTION - Only one list index can be selected at a time. In this mode, setSelectionInterval and addSelectionInterval are equivalent, both replacing the current selection with the index represented by the second argument (the "lead").
        • ListSelectionModel.SINGLE_INTERVAL_SELECTION - Only one contiguous interval can be selected at a time. In this mode, addSelectionInterval behaves like setSelectionInterval (replacing the current selection}, unless the given interval is immediately adjacent to or overlaps the existing selection, and can be used to grow the selection.
        • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - In this mode, there's no restriction on what can be selected. This mode is the default.
        参数：
        selectionMode - the selection mode
        抛出：
        IllegalArgumentException - if the selection mode isn't one of those allowed
        另请参见：
        getSelectionMode()

      • getSelectionMode

        public int getSelectionMode()
        Returns the current selection mode for the list. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        the current selection mode
        另请参见：
        setSelectionMode(int)

      • getAnchorSelectionIndex

        public int getAnchorSelectionIndex()
        Returns the anchor selection index. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        the anchor selection index
        另请参见：
        ListSelectionModel.getAnchorSelectionIndex()

      • getLeadSelectionIndex

        public int getLeadSelectionIndex()
        Returns the lead selection index. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        the lead selection index
        另请参见：
        ListSelectionModel.getLeadSelectionIndex()

      • getMinSelectionIndex

        public int getMinSelectionIndex()
        Returns the smallest selected cell index, or -1 if the selection is empty. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        the smallest selected cell index, or -1
        另请参见：
        ListSelectionModel.getMinSelectionIndex()

      • getMaxSelectionIndex

        public int getMaxSelectionIndex()
        Returns the largest selected cell index, or -1 if the selection is empty. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        the largest selected cell index
        另请参见：
        ListSelectionModel.getMaxSelectionIndex()

      • isSelectedIndex

        public boolean isSelectedIndex(int index)
        Returns true if the specified index is selected, else false. This is a cover method that delegates to the method of the same name on the list's selection model.
        参数：
        index - index to be queried for selection state
        返回：
        true if the specified index is selected, else false
        另请参见：
        ListSelectionModel.isSelectedIndex(int), setSelectedIndex(int)

      • isSelectionEmpty

        public boolean isSelectionEmpty()
        Returns true if nothing is selected, else false. This is a cover method that delegates to the method of the same name on the list's selection model.
        返回：
        true if nothing is selected, else false
        另请参见：
        ListSelectionModel.isSelectionEmpty(), clearSelection()

      • clearSelection

        public void clearSelection()
        Clears the selection; after calling this method, isSelectionEmpty will return true. This is a cover method that delegates to the method of the same name on the list's selection model.
        另请参见：
        ListSelectionModel.clearSelection(), isSelectionEmpty()

      • setSelectionInterval

        public void setSelectionInterval(int anchor,
                        int lead)
        Selects the specified interval. Both anchor and lead indices are included. anchor doesn't have to be less than or equal to lead. This is a cover method that delegates to the method of the same name on the list's selection model.

        Refer to the documentation of the selection model class being used for details on how values less than 0 are handled.

        参数：
        anchor - the first index to select
        lead - the last index to select
        另请参见：
        ListSelectionModel.setSelectionInterval(int, int),
DefaultListSelectionModel.setSelectionInterval(int, int),
createSelectionModel(),
addSelectionInterval(int, int),
removeSelectionInterval(int, int)

      • addSelectionInterval

        public void addSelectionInterval(int anchor,
                        int lead)
        Sets the selection to be the union of the specified interval with current selection. Both the anchor and lead indices are included. anchor doesn't have to be less than or equal to lead. This is a cover method that delegates to the method of the same name on the list's selection model.

        Refer to the documentation of the selection model class being used for details on how values less than 0 are handled.

        参数：
        anchor - the first index to add to the selection
        lead - the last index to add to the selection
        另请参见：
        ListSelectionModel.addSelectionInterval(int, int),
DefaultListSelectionModel.addSelectionInterval(int, int),
createSelectionModel(),
setSelectionInterval(int, int),
removeSelectionInterval(int, int)

      • removeSelectionInterval

        public void removeSelectionInterval(int index0,
                           int index1)
        Sets the selection to be the set difference of the specified interval and the current selection. Both the index0 and index1 indices are removed. index0 doesn't have to be less than or equal to index1. This is a cover method that delegates to the method of the same name on the list's selection model.

        Refer to the documentation of the selection model class being used for details on how values less than 0 are handled.

        参数：
        index0 - the first index to remove from the selection
        index1 - the last index to remove from the selection
        另请参见：
        ListSelectionModel.removeSelectionInterval(int, int),
DefaultListSelectionModel.removeSelectionInterval(int, int),
createSelectionModel(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

      • setValueIsAdjusting

        public void setValueIsAdjusting(boolean b)
        Sets the selection model's valueIsAdjusting property. When true, upcoming changes to selection should be considered part of a single change. This property is used internally and developers typically need not call this method. For example, when the model is being updated in response to a user drag, the value of the property is set to true when the drag is initiated and set to false when the drag is finished. This allows listeners to update only when a change has been finalized, rather than handling all of the intermediate values.

        You may want to use this directly if making a series of changes that should be considered part of a single change.

        This is a cover method that delegates to the method of the same name on the list's selection model. See the documentation for ListSelectionModel.setValueIsAdjusting(boolean) for more details.

        参数：
        b - the new value for the property
        另请参见：
        ListSelectionModel.setValueIsAdjusting(boolean),
ListSelectionEvent.getValueIsAdjusting(),
getValueIsAdjusting()

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        Returns the value of the selection model's isAdjusting property.

        This is a cover method that delegates to the method of the same name on the list's selection model.

        返回：
        the value of the selection model's isAdjusting property.
        另请参见：
        setValueIsAdjusting(boolean), ListSelectionModel.getValueIsAdjusting()

      • getSelectedIndices

        public int[] getSelectedIndices()
        Returns an array of all of the selected indices, in increasing order.
        返回：
        all of the selected indices, in increasing order, or an empty array if nothing is selected
        另请参见：
        removeSelectionInterval(int, int), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • setSelectedIndex

        public void setSelectedIndex(int index)
        Selects a single cell. Does nothing if the given index is greater than or equal to the model size. This is a convenience method that uses setSelectionInterval on the selection model. Refer to the documentation for the selection model class being used for details on how values less than 0 are handled.
        参数：
        index - the index of the cell to select
        另请参见：
        ListSelectionModel.setSelectionInterval(int, int), isSelectedIndex(int), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • setSelectedIndices

        public void setSelectedIndices(int[] indices)
        Changes the selection to be the set of indices specified by the given array. Indices greater than or equal to the model size are ignored. This is a convenience method that clears the selection and then uses addSelectionInterval on the selection model to add the indices. Refer to the documentation of the selection model class being used for details on how values less than 0 are handled.
        参数：
        indices - an array of the indices of the cells to select, non-null
        抛出：
        NullPointerException - if the given array is null
        另请参见：
        ListSelectionModel.addSelectionInterval(int, int), isSelectedIndex(int), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getSelectedValues

        @Deprecated
public Object[] getSelectedValues()
        Deprecated. As of JDK 1.7, replaced by getSelectedValuesList()
        Returns an array of all the selected values, in increasing order based on their indices in the list.
        返回：
        the selected values, or an empty array if nothing is selected
        另请参见：
        isSelectedIndex(int), getModel(), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getSelectedValuesList

        public List<E> getSelectedValuesList()
        Returns a list of all the selected items, in increasing order based on their indices in the list.
        返回：
        the selected items, or an empty list if nothing is selected
        从以下版本开始：
        1.7
        另请参见：
        isSelectedIndex(int), getModel(), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getSelectedIndex

        public int getSelectedIndex()
        Returns the smallest selected cell index; the selection when only a single item is selected in the list. When multiple items are selected, it is simply the smallest selected index. Returns -1 if there is no selection.

        This method is a cover that delegates to getMinSelectionIndex.

        返回：
        the smallest selected cell index
        另请参见：
        getMinSelectionIndex(), addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getSelectedValue

        public E getSelectedValue()
        Returns the value for the smallest selected cell index; the selected value when only a single item is selected in the list. When multiple items are selected, it is simply the value for the smallest selected index. Returns null if there is no selection.

        This is a convenience method that simply returns the model value for getMinSelectionIndex.

        返回：
        the first selected value
        另请参见：
        getMinSelectionIndex(),
getModel(),
addListSelectionListener(javax.swing.event.ListSelectionListener)

      • setSelectedValue

        public void setSelectedValue(Object anObject,
                    boolean shouldScroll)
        Selects the specified object from the list.
        参数：
        anObject - the object to select
        shouldScroll - true if the list should scroll to display the selected object, if one exists; otherwise false

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Computes the size of viewport needed to display visibleRowCount rows. The value returned by this method depends on the layout orientation:

        VERTICAL:
        This is trivial if both fixedCellWidth and fixedCellHeight have been set (either explicitly or by specifying a prototype cell value). The width is simply the fixedCellWidth plus the list's horizontal insets. The height is the fixedCellHeight multiplied by the visibleRowCount, plus the list's vertical insets.

        If either fixedCellWidth or fixedCellHeight haven't been specified, heuristics are used. If the model is empty, the width is the fixedCellWidth, if greater than 0, or a hard-coded value of 256. The height is the fixedCellHeight multiplied by visibleRowCount, if fixedCellHeight is greater than 0, otherwise it is a hard-coded value of 16 multiplied by visibleRowCount.

        If the model isn't empty, the width is the preferred size's width, typically the width of the widest list element. The height is the fixedCellHeight multiplied by the visibleRowCount, plus the list's vertical insets.

        VERTICAL_WRAP or HORIZONTAL_WRAP:
        This method simply returns the value from getPreferredSize. The list's ListUI is expected to override getPreferredSize to return an appropriate value.

        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        返回：
        a dimension containing the size of the viewport needed to display visibleRowCount rows
        另请参见：
        getPreferredScrollableViewportSize(), setPrototypeCellValue(E)

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Returns the distance to scroll to expose the next or previous row (for vertical scrolling) or column (for horizontal scrolling).

        For horizontal scrolling, if the layout orientation is VERTICAL, then the list's font size is returned (or 1 if the font is null).

        指定者：
        getScrollableUnitIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - SwingConstants.HORIZONTAL or SwingConstants.VERTICAL
        direction - less or equal to zero to scroll up/back, greater than zero for down/forward
        返回：
        the "unit" increment for scrolling in the specified direction; always positive
        抛出：
        IllegalArgumentException - if visibleRect is null, or orientation isn't one of SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        另请参见：
        getScrollableBlockIncrement(java.awt.Rectangle, int, int), Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

      • getScrollableBlockIncrement

        public int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Returns the distance to scroll to expose the next or previous block.

        For vertical scrolling, the following rules are used:

        • if scrolling down, returns the distance to scroll so that the last visible element becomes the first completely visible element
        • if scrolling up, returns the distance to scroll so that the first visible element becomes the last completely visible element
        • returns visibleRect.height if the list is empty

        For horizontal scrolling, when the layout orientation is either VERTICAL_WRAP or HORIZONTAL_WRAP:

        • if scrolling right, returns the distance to scroll so that the last visible element becomes the first completely visible element
        • if scrolling left, returns the distance to scroll so that the first visible element becomes the last completely visible element
        • returns visibleRect.width if the list is empty

        For horizontal scrolling and VERTICAL orientation, returns visibleRect.width.

        Note that the value of visibleRect must be the equal to this.getVisibleRect().

        指定者：
        getScrollableBlockIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - SwingConstants.HORIZONTAL or SwingConstants.VERTICAL
        direction - less or equal to zero to scroll up/back, greater than zero for down/forward
        返回：
        the "block" increment for scrolling in the specified direction; always positive
        抛出：
        IllegalArgumentException - if visibleRect is null, or orientation isn't one of SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        另请参见：
        getScrollableUnitIncrement(java.awt.Rectangle, int, int), Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns true if this JList is displayed in a JViewport and the viewport is wider than the list's preferred width, or if the layout orientation is HORIZONTAL_WRAP and visibleRowCount <= 0; otherwise returns false.

        If false, then don't track the viewport's width. This allows horizontal scrolling if the JViewport is itself embedded in a JScrollPane.

        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        返回：
        whether or not an enclosing viewport should force the list's width to match its own
        另请参见：
        Scrollable.getScrollableTracksViewportWidth()

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns true if this JList is displayed in a JViewport and the viewport is taller than the list's preferred height, or if the layout orientation is VERTICAL_WRAP and visibleRowCount <= 0; otherwise returns false.

        If false, then don't track the viewport's height. This allows vertical scrolling if the JViewport is itself embedded in a JScrollPane.

        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        返回：
        whether or not an enclosing viewport should force the list's height to match its own
        另请参见：
        Scrollable.getScrollableTracksViewportHeight()

      • paramString

        protected String paramString()
        Returns a String representation of this JList. This method is intended to be used only for debugging purposes, and the content and format of the returned String may vary between implementations. The returned String may be empty, but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a String representation of this JList.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JList. For JList, the AccessibleContext takes the form of an AccessibleJList.

        A new AccessibleJList instance is created if necessary.

        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJList that serves as the AccessibleContext of this JList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JList.AccessibleJList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JList.AccessibleJList

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JList.AccessibleJList
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, ListDataListener, ListSelectionListener
    封闭类：
    JList<E>

    protected class JList.AccessibleJList
extends JComponent.AccessibleJComponent
implements AccessibleSelection, PropertyChangeListener, ListSelectionListener, ListDataListener
    This class implements accessibility support for the JList class. It provides an implementation of the Java Accessibility API appropriate to list user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JList.AccessibleJList.AccessibleJListChild
      This class implements accessibility support appropriate for list children.

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JList.AccessibleJList()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified selected item in the object to the object's selection.
      void clearAccessibleSelection()
      Clears the selection in the object, so that nothing in the object is selected.
      void contentsChanged(ListDataEvent e)
      List Data Listener contents changed method.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child contained at the local coordinate Point, if one exists.
      Accessible getAccessibleChild(int i)
      Return the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected item in the object.
      int getAccessibleSelectionCount()
      Returns the number of items currently selected.
      AccessibleStateSet getAccessibleStateSet()
      Get the state set of this object.
      void intervalAdded(ListDataEvent e)
      List Data Listener interval added method.
      void intervalRemoved(ListDataEvent e)
      List Data Listener interval removed method.
      boolean isAccessibleChildSelected(int i)
      Returns true if the current child of this object is selected.
      void propertyChange(PropertyChangeEvent e)
      Property Change Listener change method.
      void removeAccessibleSelection(int i)
      Removes the specified selected item in the object from the object's selection.
      void selectAllAccessibleSelection()
      Causes every selected item in the object to be selected if the object supports multiple selections.
      void valueChanged(ListSelectionEvent e)
      List Selection Listener value change method.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JList.AccessibleJList

        public JList.AccessibleJList()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Property Change Listener change method. Used to track changes to the DataModel and ListSelectionModel, in order to re-set listeners to those for reporting changes there via the Accessibility PropertyChange mechanism.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - PropertyChangeEvent

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        List Selection Listener value change method. Used to fire the property change
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - ListSelectionEvent

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        List Data Listener interval added method. Used to fire the visible data property change
        指定者：
        intervalAdded in interface ListDataListener
        参数：
        e - ListDataEvent

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        List Data Listener interval removed method. Used to fire the visible data property change
        指定者：
        intervalRemoved in interface ListDataListener
        参数：
        e - ListDataEvent

      • contentsChanged

        public void contentsChanged(ListDataEvent e)
        List Data Listener contents changed method. Used to fire the visible data property change
        指定者：
        contentsChanged in interface ListDataListener
        参数：
        e - ListDataEvent

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child contained at the local coordinate Point, if one exists. Otherwise returns null.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - the point defining the top-left corner of the Accessible, given in the coordinate space of the object's parent
        返回：
        the Accessible at the specified location, if it exists

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Return the nth Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns the number of items currently selected. If no items are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected.

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns an Accessible representing the specified selected item in the object. If there isn't a selection, or there are fewer items selected than the integer passed in, the return value will be null.
        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected items
        返回：
        an Accessible containing the selected item
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Returns true if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Adds the specified selected item in the object to the object's selection. If the object supports multiple selections, the specified item is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified item is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the specified selected item in the object from the object's selection. If the specified item isn't currently selected, this method has no effect.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that nothing in the object is selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Causes every selected item in the object to be selected if the object supports multiple selections.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

syilx.ot.oCnnoCCst// i/el.< t>.dt


JList.AccessibleJList.AccessibleJListChild

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JList.AccessibleJList.AccessibleJListChild

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.JList.AccessibleJList.AccessibleJListChild
  • 所有已实现的接口：
    Accessible, AccessibleComponent
    封闭类：
    JList.AccessibleJList

    protected class JList.AccessibleJList.AccessibleJListChild
extends AccessibleContext
implements Accessible, AccessibleComponent
    This class implements accessibility support appropriate for list children.

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JList.AccessibleJList.AccessibleJListChild(JList<E> parent, int indexInParent)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addFocusListener(FocusListener l)
      Adds the specified focus listener to receive focus events from this component.
      void addPropertyChangeListener(PropertyChangeListener l)
      Adds a PropertyChangeListener to the listener list.
      boolean contains(Point p)
      Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
      AccessibleAction getAccessibleAction()
      Gets the AccessibleAction associated with this object that supports one or more actions.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleComponent getAccessibleComponent()
      Get the AccessibleComponent associated with this object.
      AccessibleContext getAccessibleContext()
      Get the AccessibleContext for this object.
      String getAccessibleDescription()
      Gets the accessibleDescription property of this object.
      AccessibleIcon[] getAccessibleIcon()
      Returns the icon for the element renderer, as the only item of an array of AccessibleIcons or a null array if the renderer component contains no icons.
      int getAccessibleIndexInParent()
      Gets the 0-based index of this object in its accessible parent.
      String getAccessibleName()
      Gets the accessibleName property of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleSelection getAccessibleSelection()
      Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object that supports a Numerical value.
      Color getBackground()
      Gets the background color of this object.
      Rectangle getBounds()
      Gets the bounds of this object in the form of a Rectangle object.
      Cursor getCursor()
      Gets the Cursor of this object.
      Font getFont()
      Gets the Font of this object.
      FontMetrics getFontMetrics(Font f)
      Gets the FontMetrics of this object.
      Color getForeground()
      Gets the foreground color of this object.
      Locale getLocale()
      Gets the locale of the component.
      Point getLocation()
      Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
      Point getLocationOnScreen()
      Returns the location of the object on the screen.
      Dimension getSize()
      Returns the size of this object in the form of a Dimension object.
      boolean isEnabled()
      Determines if the object is enabled.
      boolean isFocusTraversable()
      Returns whether this object can accept focus or not.
      boolean isShowing()
      Determines if the object is showing.
      boolean isVisible()
      Determines if the object is visible.
      void removeFocusListener(FocusListener l)
      Removes the specified focus listener so it no longer receives focus events from this component.
      void removePropertyChangeListener(PropertyChangeListener l)
      Removes a PropertyChangeListener from the listener list.
      void requestFocus()
      Requests focus for this object.
      void setAccessibleDescription(String s)
      Sets the accessible description of this object.
      void setAccessibleName(String s)
      Sets the localized accessible name of this object.
      void setBackground(Color c)
      Sets the background color of this object.
      void setBounds(Rectangle r)
      Sets the bounds of this object in the form of a Rectangle object.
      void setCursor(Cursor c)
      Sets the Cursor of this object.
      void setEnabled(boolean b)
      Sets the enabled state of the object.
      void setFont(Font f)
      Sets the Font of this object.
      void setForeground(Color c)
      Sets the foreground color of this object.
      void setLocation(Point p)
      Sets the location of the object relative to the parent.
      void setSize(Dimension d)
      Resizes this object so that it has width and height.
      void setVisible(boolean b)
      Sets the visible state of the object.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JList.AccessibleJList.AccessibleJListChild

        public JList.AccessibleJList.AccessibleJListChild(JList<E> parent,
                                          int indexInParent)

    • 方法详细信息

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Get the AccessibleContext for this object. In the implementation of the Java Accessibility API for this class, returns this object, which is its own AccessibleContext.
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        this object

      • getAccessibleName

        public String getAccessibleName()
        Description copied from class: AccessibleContext
        Gets the accessibleName property of this object. The accessibleName property of an object is a localized String that designates the purpose of the object. For example, the accessibleName property of a label or button might be the text of the label or button itself. In the case of an object that doesn't display its name, the accessibleName should still be set. For example, in the case of a text field used to enter the name of a city, the accessibleName for the en_US locale could be 'city.'
        重载：
        getAccessibleName in class AccessibleContext
        返回：
        the localized name of the object; null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • setAccessibleName

        public void setAccessibleName(String s)
        Description copied from class: AccessibleContext
        Sets the localized accessible name of this object. Changing the name will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_NAME_PROPERTY property.
        重载：
        setAccessibleName in class AccessibleContext
        参数：
        s - the new localized name of the object.
        另请参见：
        AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Description copied from class: AccessibleContext
        Gets the accessibleDescription property of this object. The accessibleDescription property of this object is a short localized phrase describing the purpose of the object. For example, in the case of a 'Cancel' button, the accessibleDescription could be 'Ignore changes and close dialog box.'
        重载：
        getAccessibleDescription in class AccessibleContext
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        public void setAccessibleDescription(String s)
        Description copied from class: AccessibleContext
        Sets the accessible description of this object. Changing the name will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_DESCRIPTION_PROPERTY property.
        重载：
        setAccessibleDescription in class AccessibleContext
        参数：
        s - the new localized description of the object
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Description copied from class: AccessibleContext
        Gets the role of this object. The role of the object is the generic purpose or use of the class of this object. For example, the role of a push button is AccessibleRole.PUSH_BUTTON. The roles in AccessibleRole are provided so component developers can pick from a set of predefined roles. This enables assistive technologies to provide a consistent interface to various tweaked subclasses of components (e.g., use AccessibleRole.PUSH_BUTTON for all components that act like a push button) as well as distinguish between sublasses that behave differently (e.g., AccessibleRole.CHECK_BOX for check boxes and AccessibleRole.RADIO_BUTTON for radio buttons).

        Note that the AccessibleRole class is also extensible, so custom component developers can define their own AccessibleRole's if the set of predefined roles is inadequate.

        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Description copied from class: AccessibleContext
        Gets the state set of this object. The AccessibleStateSet of an object is composed of a set of unique AccessibleStates. A change in the AccessibleStateSet of an object will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_STATE_PROPERTY property.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Description copied from class: AccessibleContext
        Gets the 0-based index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the 0-based index of this object in its parent; -1 if this object does not have an accessible parent.
        另请参见：
        AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Description copied from class: AccessibleContext
        Returns the number of accessible children of the object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Description copied from class: AccessibleContext
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
        Description copied from class: AccessibleContext
        Gets the locale of the component. If the component does not have a locale, then the locale of its parent is returned.
        指定者：
        getLocale in class AccessibleContext
        返回：
        this component's locale. If this component does not have a locale, the locale of its parent is returned.

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener l)
        Description copied from class: AccessibleContext
        Adds a PropertyChangeListener to the listener list. The listener is registered for all Accessible properties and will be called when those properties change.
        重载：
        addPropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be added
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener l)
        Description copied from class: AccessibleContext
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        重载：
        removePropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be removed

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Description copied from class: AccessibleContext
        Gets the AccessibleAction associated with this object that supports one or more actions.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        AccessibleAction if supported by object; else return null
        另请参见：
        AccessibleAction

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent()
        Get the AccessibleComponent associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleComponent interface on behalf of itself.
        重载：
        getAccessibleComponent in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleComponent

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Description copied from class: AccessibleContext
        Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        AccessibleSelection if supported by object; else return null
        另请参见：
        AccessibleSelection

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Description copied from class: AccessibleContext
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Description copied from class: AccessibleContext
        Gets the AccessibleValue associated with this object that supports a Numerical value.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        AccessibleValue if supported by object; else return null
        另请参见：
        AccessibleValue

      • getBackground

        public Color getBackground()
        从接口复制的描述： AccessibleComponent
        Gets the background color of this object.
        指定者：
        getBackground in interface AccessibleComponent
        返回：
        the background color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground(Color c)
        从接口复制的描述： AccessibleComponent
        Sets the background color of this object.
        指定者：
        setBackground in interface AccessibleComponent
        参数：
        c - the new Color for the background
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • getForeground

        public Color getForeground()
        从接口复制的描述： AccessibleComponent
        Gets the foreground color of this object.
        指定者：
        getForeground in interface AccessibleComponent
        返回：
        the foreground color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground(Color c)
        从接口复制的描述： AccessibleComponent
        Sets the foreground color of this object.
        指定者：
        setForeground in interface AccessibleComponent
        参数：
        c - the new Color for the foreground
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor()
        从接口复制的描述： AccessibleComponent
        Gets the Cursor of this object.
        指定者：
        getCursor in interface AccessibleComponent
        返回：
        the Cursor, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor(Cursor c)
        从接口复制的描述： AccessibleComponent
        Sets the Cursor of this object.
        指定者：
        setCursor in interface AccessibleComponent
        参数：
        c - the new Cursor for the object
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont()
        从接口复制的描述： AccessibleComponent
        Gets the Font of this object.
        指定者：
        getFont in interface AccessibleComponent
        返回：
        the Font,if supported, for the object; otherwise, null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont(Font f)
        从接口复制的描述： AccessibleComponent
        Sets the Font of this object.
        指定者：
        setFont in interface AccessibleComponent
        参数：
        f - the new Font for the object
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        从接口复制的描述： AccessibleComponent
        Gets the FontMetrics of this object.
        指定者：
        getFontMetrics in interface AccessibleComponent
        参数：
        f - the Font
        返回：
        the FontMetrics, if supported, the object; otherwise, null
        另请参见：
        AccessibleComponent.getFont()

      • isEnabled

        public boolean isEnabled()
        从接口复制的描述： AccessibleComponent
        Determines if the object is enabled. Objects that are enabled will also have the AccessibleState.ENABLED state set in their AccessibleStateSets.
        指定者：
        isEnabled in interface AccessibleComponent
        返回：
        true if object is enabled; otherwise, false
        另请参见：
        AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

      • setEnabled

        public void setEnabled(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the enabled state of the object.
        指定者：
        setEnabled in interface AccessibleComponent
        参数：
        b - if true, enables this object; otherwise, disables it
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible()
        从接口复制的描述： AccessibleComponent
        Determines if the object is visible. Note: this means that the object intends to be visible; however, it may not be showing on the screen because one of the objects that this object is contained by is currently not visible. To determine if an object is showing on the screen, use isShowing().

        Objects that are visible will also have the AccessibleState.VISIBLE state set in their AccessibleStateSets.

        指定者：
        isVisible in interface AccessibleComponent
        返回：
        true if object is visible; otherwise, false
        另请参见：
        AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

      • setVisible

        public void setVisible(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the visible state of the object.
        指定者：
        setVisible in interface AccessibleComponent
        参数：
        b - if true, shows this object; otherwise, hides it
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing()
        从接口复制的描述： AccessibleComponent
        Determines if the object is showing. This is determined by checking the visibility of the object and its ancestors. Note: this will return true even if the object is obscured by another (for example, it is underneath a menu that was pulled down).
        指定者：
        isShowing in interface AccessibleComponent
        返回：
        true if object is showing; otherwise, false

      • contains

        public boolean contains(Point p)
        从接口复制的描述： AccessibleComponent
        Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
        指定者：
        contains in interface AccessibleComponent
        参数：
        p - the Point relative to the coordinate system of the object
        返回：
        true if object contains Point; otherwise false
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen()
        从接口复制的描述： AccessibleComponent
        Returns the location of the object on the screen.
        指定者：
        getLocationOnScreen in interface AccessibleComponent
        返回：
        the location of the object on screen; null if this object is not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation()
        从接口复制的描述： AccessibleComponent
        Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
        指定者：
        getLocation in interface AccessibleComponent
        返回：
        An instance of Point representing the top-left corner of the object's bounds in the coordinate space of the screen; null if this object or its parent are not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation(Point p)
        从接口复制的描述： AccessibleComponent
        Sets the location of the object relative to the parent.
        指定者：
        setLocation in interface AccessibleComponent
        参数：
        p - the new position for the top-left corner
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds()
        从接口复制的描述： AccessibleComponent
        Gets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        getBounds in interface AccessibleComponent
        返回：
        A rectangle indicating this component's bounds; null if this object is not on the screen.
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds(Rectangle r)
        从接口复制的描述： AccessibleComponent
        Sets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        setBounds in interface AccessibleComponent
        参数：
        r - rectangle indicating this component's bounds
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize()
        从接口复制的描述： AccessibleComponent
        Returns the size of this object in the form of a Dimension object. The height field of the Dimension object contains this object's height, and the width field of the Dimension object contains this object's width.
        指定者：
        getSize in interface AccessibleComponent
        返回：
        A Dimension object that indicates the size of this component; null if this object is not on the screen
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize(Dimension d)
        从接口复制的描述： AccessibleComponent
        Resizes this object so that it has width and height.
        指定者：
        setSize in interface AccessibleComponent
        参数：
        d - The dimension specifying the new size of the object.
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        从接口复制的描述： AccessibleComponent
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        参数：
        p - The point relative to the coordinate system of this object.
        返回：
        the Accessible, if it exists, at the specified location; otherwise null

      • isFocusTraversable

        public boolean isFocusTraversable()
        从接口复制的描述： AccessibleComponent
        Returns whether this object can accept focus or not. Objects that can accept focus will also have the AccessibleState.FOCUSABLE state set in their AccessibleStateSets.
        指定者：
        isFocusTraversable in interface AccessibleComponent
        返回：
        true if object can accept focus; otherwise false
        另请参见：
        AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

      • requestFocus

        public void requestFocus()
        从接口复制的描述： AccessibleComponent
        Requests focus for this object. If this object cannot accept focus, nothing will happen. Otherwise, the object will attempt to take focus.
        指定者：
        requestFocus in interface AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Adds the specified focus listener to receive focus events from this component.
        指定者：
        addFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Removes the specified focus listener so it no longer receives focus events from this component.
        指定者：
        removeFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

      • getAccessibleIcon

        public AccessibleIcon[] getAccessibleIcon()
        Returns the icon for the element renderer, as the only item of an array of AccessibleIcons or a null array if the renderer component contains no icons.
        重载：
        getAccessibleIcon in class AccessibleContext
        返回：
        an array containing the accessible icon or a null array if none
        从以下版本开始：
        1.3
        另请参见：
        AccessibleIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JList.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 JList.DropLocation

  • java.lang.Object
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
  • 封闭类：
    JList<E>

    public static final class JList.DropLocation
extends TransferHandler.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JList.
    从以下版本开始：
    1.6
    另请参见：
    JList.getDropLocation()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIndex()
      Returns the index where dropped data should be placed in the list.
      boolean isInsert()
      Returns whether or not this location represents an insert location.
      String toString()
      Returns a string representation of this drop location.

      • 方法 - 继承于类 javax.swing.TransferHandler.DropLocation

        getDropPoint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getIndex

        public int getIndex()
        Returns the index where dropped data should be placed in the list. Interpretation of the value depends on the drop mode set on the associated component. If the drop mode is either DropMode.USE_SELECTION or DropMode.ON, the return value is an index of a row in the list. If the drop mode is DropMode.INSERT, the return value refers to the index where the data should be inserted. If the drop mode is DropMode.ON_OR_INSERT, the value of isInsert() indicates whether the index is an index of a row, or an insert index.

        -1 indicates that the drop occurred over empty space, and no index could be calculated.

        返回：
        the drop index

      • isInsert

        public boolean isInsert()
        Returns whether or not this location represents an insert location.
        返回：
        whether or not this is an insert location

      • toString

        public String toString()
        Returns a string representation of this drop location. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class TransferHandler.DropLocation
        返回：
        a string representation of this drop location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.<. a,E>,EGDDEGG_TBBiixieeyCicss/ibftE


JMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenu

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JMenuItem
              • javax.swing.JMenu
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants

    public class JMenu
extends JMenuItem
implements Accessible, MenuElement
    An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar. In addition to JMenuItems, a JMenu can also contain JSeparators.

    In essence, a menu is a button with an associated JPopupMenu. When the "button" is pressed, the JPopupMenu appears. If the "button" is on the JMenuBar, the menu is a top-level window. If the "button" is another menu item, then the JPopupMenu is "pull-right" menu.

    Menus can be configured, and to some degree controlled, by Actions. Using an Action with a menu has many benefits beyond directly configuring a menu. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    For information and examples of using menus see How to Use Menus, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JMenuItem, JSeparator, JMenuBar, JPopupMenu

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JMenu.AccessibleJMenu
      This class implements accessibility support for the JMenu class.
      protected class  JMenu.WinListener
      A listener class that watches for a popup window closing.

      • Nested classes/interfaces inherited from class javax.swing.JMenuItem

        JMenuItem.AccessibleJMenuItem

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JMenu.WinListener popupListener
      The window-closing listener for the popup.

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMenu()
      Constructs a new JMenu with no text.
      JMenu(Action a)
      Constructs a menu whose properties are taken from the Action supplied.
      JMenu(String s)
      Constructs a new JMenu with the supplied string as its text.
      JMenu(String s, boolean b)
      Constructs a new JMenu with the supplied string as its text and specified as a tear-off menu or not.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMenuItem add(Action a)
      Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
      Component add(Component c)
      Appends a component to the end of this menu.
      Component add(Component c, int index)
      Adds the specified component to this container at the given position.
      JMenuItem add(JMenuItem menuItem)
      Appends a menu item to the end of this menu.
      JMenuItem add(String s)
      Creates a new menu item with the specified text and appends it to the end of this menu.
      void addMenuListener(MenuListener l)
      Adds a listener for menu events.
      void addSeparator()
      Appends a new separator to the end of the menu.
      void applyComponentOrientation(ComponentOrientation o)
      Sets the ComponentOrientation property of this menu and all components contained within it.
      protected PropertyChangeListener createActionChangeListener(JMenuItem b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
      protected JMenuItem createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JMenu.
      protected JMenu.WinListener createWinListener(JPopupMenu p)
      Creates a window-closing listener for the popup.
      void doClick(int pressTime)
      Programmatically performs a "click".
      protected void fireMenuCanceled()
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuDeselected()
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuSelected()
      Notifies all listeners that have registered interest for notification on this event type.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JMenu.
      Component getComponent()
      Returns the java.awt.Component used to paint this MenuElement.
      int getDelay()
      Returns the suggested delay, in milliseconds, before submenus are popped up or down.
      JMenuItem getItem(int pos)
      Returns the JMenuItem at the specified position.
      int getItemCount()
      Returns the number of items on the menu, including separators.
      Component getMenuComponent(int n)
      Returns the component at position n.
      int getMenuComponentCount()
      Returns the number of components on the menu.
      Component[] getMenuComponents()
      Returns an array of Components of the menu's subcomponents.
      MenuListener[] getMenuListeners()
      Returns an array of all the MenuListeners added to this JMenu with addMenuListener().
      JPopupMenu getPopupMenu()
      Returns the popupmenu associated with this menu.
      protected Point getPopupMenuOrigin()
      Computes the origin for the JMenu's popup menu.
      MenuElement[] getSubElements()
      Returns an array of MenuElements containing the submenu for this menu component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      JMenuItem insert(Action a, int pos)
      Inserts a new menu item attached to the specified Action object at a given position.
      JMenuItem insert(JMenuItem mi, int pos)
      Inserts the specified JMenuitem at a given position.
      void insert(String s, int pos)
      Inserts a new menu item with the specified text at a given position.
      void insertSeparator(int index)
      Inserts a separator at the specified position.
      boolean isMenuComponent(Component c)
      Returns true if the specified component exists in the submenu hierarchy.
      boolean isPopupMenuVisible()
      Returns true if the menu's popup window is visible.
      boolean isSelected()
      Returns true if the menu is currently selected (highlighted).
      boolean isTearOff()
      Returns true if the menu can be torn off.
      boolean isTopLevelMenu()
      Returns true if the menu is a 'top-level menu', that is, if it is the direct child of a menubar.
      void menuSelectionChanged(boolean isIncluded)
      Messaged when the menubar selection changes to activate or deactivate this menu.
      protected String paramString()
      Returns a string representation of this JMenu.
      protected void processKeyEvent(KeyEvent evt)
      Processes key stroke events such as mnemonics and accelerators.
      void remove(Component c)
      Removes the component c from this menu.
      void remove(int pos)
      Removes the menu item at the specified index from this menu.
      void remove(JMenuItem item)
      Removes the specified menu item from this menu.
      void removeAll()
      Removes all menu items from this menu.
      void removeMenuListener(MenuListener l)
      Removes a listener for menu events.
      void setAccelerator(KeyStroke keyStroke)
      setAccelerator is not defined for JMenu.
      void setComponentOrientation(ComponentOrientation o)
      Sets the language-sensitive orientation that is to be used to order the elements or text within this component.
      void setDelay(int d)
      Sets the suggested delay before the menu's PopupMenu is popped up or down.
      void setMenuLocation(int x, int y)
      Sets the location of the popup component.
      void setModel(ButtonModel newModel)
      Sets the data model for the "menu button" -- the label that the user clicks to open or close the menu.
      void setPopupMenuVisible(boolean b)
      Sets the visibility of the menu's popup.
      void setSelected(boolean b)
      Sets the selection status of the menu.
      void updateUI()
      Resets the UI property with a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JMenuItem

        actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getMenuDragMouseListeners, getMenuKeyListeners, init, isArmed, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setArmed, setEnabled, setUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.MenuElement

        processKeyEvent, processMouseEvent

    • 字段详细信息

      • popupListener

        protected JMenu.WinListener popupListener
        The window-closing listener for the popup.
        另请参见：
        JMenu.WinListener

    • 构造方法详细信息

      • JMenu

        public JMenu()
        Constructs a new JMenu with no text.

      • JMenu

        public JMenu(String s)
        Constructs a new JMenu with the supplied string as its text.
        参数：
        s - the text for the menu label

      • JMenu

        public JMenu(Action a)
        Constructs a menu whose properties are taken from the Action supplied.
        参数：
        a - an Action
        从以下版本开始：
        1.3

      • JMenu

        public JMenu(String s,
     boolean b)
        Constructs a new JMenu with the supplied string as its text and specified as a tear-off menu or not.
        参数：
        s - the text for the menu label
        b - can the menu be torn off (not yet implemented)

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property with a value from the current look and feel.
        重载：
        updateUI in class JMenuItem
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JMenuItem
        返回：
        the string "MenuUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setModel

        public void setModel(ButtonModel newModel)
        Sets the data model for the "menu button" -- the label that the user clicks to open or close the menu.
        重载：
        setModel in class JMenuItem
        参数：
        newModel - the ButtonModel
        另请参见：
        AbstractButton.getModel()

      • isSelected

        public boolean isSelected()
        Returns true if the menu is currently selected (highlighted).
        重载：
        isSelected in class AbstractButton
        返回：
        true if the menu is selected, else false

      • setSelected

        public void setSelected(boolean b)
        Sets the selection status of the menu.
        重载：
        setSelected in class AbstractButton
        参数：
        b - true to select (highlight) the menu; false to de-select the menu

      • isPopupMenuVisible

        public boolean isPopupMenuVisible()
        Returns true if the menu's popup window is visible.
        返回：
        true if the menu is visible, else false

      • setPopupMenuVisible

        public void setPopupMenuVisible(boolean b)
        Sets the visibility of the menu's popup. If the menu is not enabled, this method will have no effect.
        参数：
        b - a boolean value -- true to make the menu visible, false to hide it

      • getPopupMenuOrigin

        protected Point getPopupMenuOrigin()
        Computes the origin for the JMenu's popup menu. This method uses Look and Feel properties named Menu.menuPopupOffsetX, Menu.menuPopupOffsetY, Menu.submenuPopupOffsetX, and Menu.submenuPopupOffsetY to adjust the exact location of popup.
        返回：
        a Point in the coordinate space of the menu which should be used as the origin of the JMenu's popup menu
        从以下版本开始：
        1.3

      • getDelay

        public int getDelay()
        Returns the suggested delay, in milliseconds, before submenus are popped up or down. Each look and feel (L&F) may determine its own policy for observing the delay property. In most cases, the delay is not observed for top level menus or while dragging. The default for delay is 0. This method is a property of the look and feel code and is used to manage the idiosyncracies of the various UI implementations.
        返回：
        the delay property

      • setDelay

        public void setDelay(int d)
        Sets the suggested delay before the menu's PopupMenu is popped up or down. Each look and feel (L&F) may determine it's own policy for observing the delay property. In most cases, the delay is not observed for top level menus or while dragging. This method is a property of the look and feel code and is used to manage the idiosyncracies of the various UI implementations.
        参数：
        d - the number of milliseconds to delay
        抛出：
        IllegalArgumentException - if d is less than 0

      • setMenuLocation

        public void setMenuLocation(int x,
                   int y)
        Sets the location of the popup component.
        参数：
        x - the x coordinate of the popup's new position
        y - the y coordinate of the popup's new position

      • add

        public JMenuItem add(JMenuItem menuItem)
        Appends a menu item to the end of this menu. Returns the menu item added.
        参数：
        menuItem - the JMenuitem to be added
        返回：
        the JMenuItem added

      • add

        public Component add(Component c)
        Appends a component to the end of this menu. Returns the component added.
        重载：
        add in class Container
        参数：
        c - the Component to add
        返回：
        the Component added
        另请参见：
        Container.addImpl(java.awt.Component, java.lang.Object, int),
Container.invalidate(),
Container.validate(),
JComponent.revalidate()

      • add

        public Component add(Component c,
            int index)
        Adds the specified component to this container at the given position. If index equals -1, the component will be appended to the end.
        重载：
        add in class Container
        参数：
        c - the Component to add
        index - the position at which to insert the component
        返回：
        the Component added
        另请参见：
        remove(javax.swing.JMenuItem), Container.add(Component, int)

      • add

        public JMenuItem add(String s)
        Creates a new menu item with the specified text and appends it to the end of this menu.
        参数：
        s - the string for the menu item to be added

      • add

        public JMenuItem add(Action a)
        Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
        参数：
        a - the Action for the menu item to be added
        另请参见：
        Action

      • createActionComponent

        protected JMenuItem createActionComponent(Action a)
        Factory method which creates the JMenuItem for Actions added to the JMenu.
        参数：
        a - the Action for the menu item to be added
        返回：
        the new menu item
        从以下版本开始：
        1.3
        另请参见：
        Action

      • createActionChangeListener

        protected PropertyChangeListener createActionChangeListener(JMenuItem b)
        Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.

      • addSeparator

        public void addSeparator()
        Appends a new separator to the end of the menu.

      • insert

        public void insert(String s,
          int pos)
        Inserts a new menu item with the specified text at a given position.
        参数：
        s - the text for the menu item to add
        pos - an integer specifying the position at which to add the new menu item
        抛出：
        IllegalArgumentException - when the value of pos < 0

      • insert

        public JMenuItem insert(JMenuItem mi,
               int pos)
        Inserts the specified JMenuitem at a given position.
        参数：
        mi - the JMenuitem to add
        pos - an integer specifying the position at which to add the new JMenuitem
        返回：
        the new menu item
        抛出：
        IllegalArgumentException - if the value of pos < 0

      • insert

        public JMenuItem insert(Action a,
               int pos)
        Inserts a new menu item attached to the specified Action object at a given position.
        参数：
        a - the Action object for the menu item to add
        pos - an integer specifying the position at which to add the new menu item
        抛出：
        IllegalArgumentException - if the value of pos < 0

      • insertSeparator

        public void insertSeparator(int index)
        Inserts a separator at the specified position.
        参数：
        index - an integer specifying the position at which to insert the menu separator
        抛出：
        IllegalArgumentException - if the value of index < 0

      • getItem

        public JMenuItem getItem(int pos)
        Returns the JMenuItem at the specified position. If the component at pos is not a menu item, null is returned. This method is included for AWT compatibility.
        参数：
        pos - an integer specifying the position
        返回：
        the menu item at the specified position; or null if the item as the specified position is not a menu item
        抛出：
        IllegalArgumentException - if the value of pos < 0

      • getItemCount

        public int getItemCount()
        Returns the number of items on the menu, including separators. This method is included for AWT compatibility.
        返回：
        an integer equal to the number of items on the menu
        另请参见：
        getMenuComponentCount()

      • isTearOff

        public boolean isTearOff()
        Returns true if the menu can be torn off. This method is not yet implemented.
        返回：
        true if the menu can be torn off, else false
        抛出：
        Error - if invoked -- this method is not yet implemented

      • remove

        public void remove(JMenuItem item)
        Removes the specified menu item from this menu. If there is no popup menu, this method will have no effect.
        参数：
        item - the JMenuItem to be removed from the menu

      • remove

        public void remove(int pos)
        Removes the menu item at the specified index from this menu.
        重载：
        remove in class Container
        参数：
        pos - the position of the item to be removed
        抛出：
        IllegalArgumentException - if the value of pos < 0, or if pos is greater than the number of menu items
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.getComponentCount()

      • remove

        public void remove(Component c)
        Removes the component c from this menu.
        重载：
        remove in class Container
        参数：
        c - the component to be removed
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.remove(int)

      • removeAll

        public void removeAll()
        Removes all menu items from this menu.
        重载：
        removeAll in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.remove(int),
Container.invalidate()

      • getMenuComponentCount

        public int getMenuComponentCount()
        Returns the number of components on the menu.
        返回：
        an integer containing the number of components on the menu

      • getMenuComponent

        public Component getMenuComponent(int n)
        Returns the component at position n.
        参数：
        n - the position of the component to be returned
        返回：
        the component requested, or null if there is no popup menu

      • getMenuComponents

        public Component[] getMenuComponents()
        Returns an array of Components of the menu's subcomponents. Note that this returns all Components in the popup menu, including separators.
        返回：
        an array of Components or an empty array if there is no popup menu

      • isTopLevelMenu

        public boolean isTopLevelMenu()
        Returns true if the menu is a 'top-level menu', that is, if it is the direct child of a menubar.
        返回：
        true if the menu is activated from the menu bar; false if the menu is activated from a menu item on another menu

      • isMenuComponent

        public boolean isMenuComponent(Component c)
        Returns true if the specified component exists in the submenu hierarchy.
        参数：
        c - the Component to be tested
        返回：
        true if the Component exists, false otherwise

      • getPopupMenu

        public JPopupMenu getPopupMenu()
        Returns the popupmenu associated with this menu. If there is no popupmenu, it will create one.

      • addMenuListener

        public void addMenuListener(MenuListener l)
        Adds a listener for menu events.
        参数：
        l - the listener to be added

      • removeMenuListener

        public void removeMenuListener(MenuListener l)
        Removes a listener for menu events.
        参数：
        l - the listener to be removed

      • getMenuListeners

        public MenuListener[] getMenuListeners()
        Returns an array of all the MenuListeners added to this JMenu with addMenuListener().
        返回：
        all of the MenuListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireMenuSelected

        protected void fireMenuSelected()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        抛出：
        Error - if there is a null listener
        另请参见：
        EventListenerList

      • fireMenuDeselected

        protected void fireMenuDeselected()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        抛出：
        Error - if there is a null listener
        另请参见：
        EventListenerList

      • fireMenuCanceled

        protected void fireMenuCanceled()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        抛出：
        Error - if there is a null listener
        另请参见：
        EventListenerList

      • createWinListener

        protected JMenu.WinListener createWinListener(JPopupMenu p)
        Creates a window-closing listener for the popup.
        参数：
        p - the JPopupMenu
        返回：
        the new window-closing listener
        另请参见：
        JMenu.WinListener

      • menuSelectionChanged

        public void menuSelectionChanged(boolean isIncluded)
        Messaged when the menubar selection changes to activate or deactivate this menu. Overrides JMenuItem.menuSelectionChanged.
        指定者：
        menuSelectionChanged in interface MenuElement
        重载：
        menuSelectionChanged in class JMenuItem
        参数：
        isIncluded - true if this menu is active, false if it is not
        另请参见：
        MenuSelectionManager.setSelectedPath(MenuElement[])

      • getSubElements

        public MenuElement[] getSubElements()
        Returns an array of MenuElements containing the submenu for this menu component. If popup menu is null returns an empty array. This method is required to conform to the MenuElement interface. Note that since JSeparators do not conform to the MenuElement interface, this array will only contain JMenuItems.
        指定者：
        getSubElements in interface MenuElement
        重载：
        getSubElements in class JMenuItem
        返回：
        an array of MenuElement objects

      • getComponent

        public Component getComponent()
        Returns the java.awt.Component used to paint this MenuElement. The returned component is used to convert events and detect if an event is inside a menu component.
        指定者：
        getComponent in interface MenuElement
        重载：
        getComponent in class JMenuItem
        返回：
        the Component that paints this menu item

      • applyComponentOrientation

        public void applyComponentOrientation(ComponentOrientation o)
        Sets the ComponentOrientation property of this menu and all components contained within it. This includes all components returned by getMenuComponents.
        重载：
        applyComponentOrientation in class Container
        参数：
        o - the new component orientation of this menu and the components contained within it.
        抛出：
        NullPointerException - if orientation is null.
        从以下版本开始：
        1.4
        另请参见：
        Component.setComponentOrientation(java.awt.ComponentOrientation), Component.getComponentOrientation()

      • setComponentOrientation

        public void setComponentOrientation(ComponentOrientation o)
        Description copied from class: Component
        Sets the language-sensitive orientation that is to be used to order the elements or text within this component. Language-sensitive LayoutManager and Component subclasses will use this property to determine how to lay out and draw components.

        At construction time, a component's orientation is set to ComponentOrientation.UNKNOWN, indicating that it has not been specified explicitly. The UNKNOWN orientation behaves the same as ComponentOrientation.LEFT_TO_RIGHT.

        To set the orientation of a single component, use this method. To set the orientation of an entire component hierarchy, use applyComponentOrientation.

        This method changes layout-related information, and therefore, invalidates the component hierarchy.

        重载：
        setComponentOrientation in class Component
        另请参见：
        ComponentOrientation, Component.invalidate()

      • setAccelerator

        public void setAccelerator(KeyStroke keyStroke)
        setAccelerator is not defined for JMenu. Use setMnemonic instead.
        重载：
        setAccelerator in class JMenuItem
        参数：
        keyStroke - the keystroke combination which will invoke the JMenuItem's actionlisteners without navigating the menu hierarchy
        抛出：
        Error - if invoked -- this method is not defined for JMenu. Use setMnemonic instead

      • processKeyEvent

        protected void processKeyEvent(KeyEvent evt)
        Processes key stroke events such as mnemonics and accelerators.
        重载：
        processKeyEvent in class JComponent
        参数：
        evt - the key event to be processed
        另请参见：
        KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

      • doClick

        public void doClick(int pressTime)
        Programmatically performs a "click". This overrides the method AbstractButton.doClick in order to make the menu pop up.
        重载：
        doClick in class AbstractButton
        参数：
        pressTime - indicates the number of milliseconds the button was pressed for

      • paramString

        protected String paramString()
        Returns a string representation of this JMenu. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JMenuItem
        返回：
        a string representation of this JMenu.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JMenu. For JMenus, the AccessibleContext takes the form of an AccessibleJMenu. A new AccessibleJMenu instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JMenuItem
        返回：
        an AccessibleJMenu that serves as the AccessibleContext of this JMenu
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JMenu.AccessibleJMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenu.AccessibleJMenu

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JMenuItem.AccessibleJMenuItem
                • javax.swing.JMenu.AccessibleJMenu
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, AccessibleText, AccessibleValue, ChangeListener
    封闭类：
    JMenu

    protected class JMenu.AccessibleJMenu
extends JMenuItem.AccessibleJMenuItem
implements AccessibleSelection
    This class implements accessibility support for the JMenu class. It provides an implementation of the Java Accessibility API appropriate to menu user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JMenu.AccessibleJMenu()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Selects the ith menu in the menu.
      void clearAccessibleSelection()
      Clears the selection in the object, so that nothing in the object is selected.
      Accessible getAccessibleChild(int i)
      Returns the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns the currently selected sub-menu if one is selected, otherwise null (there can only be one selection, and it can only be a sub-menu, as otherwise menu items don't remain selected).
      int getAccessibleSelectionCount()
      Returns 1 if a sub-menu is currently selected in this menu.
      boolean isAccessibleChildSelected(int i)
      Returns true if the current child of this object is selected (that is, if this child is a popped-up submenu).
      void removeAccessibleSelection(int i)
      Removes the nth item from the selection.
      void selectAllAccessibleSelection()
      Normally causes every selected item in the object to be selected if the object supports multiple selections.

      • 方法 - 继承于类 javax.swing.JMenuItem.AccessibleJMenuItem

        stateChanged

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JMenu.AccessibleJMenu

        protected JMenu.AccessibleJMenu()

    • 方法详细信息

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the nth Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JMenuItem.AccessibleJMenuItem
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns 1 if a sub-menu is currently selected in this menu.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        1 if a menu is currently selected, else 0

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns the currently selected sub-menu if one is selected, otherwise null (there can only be one selection, and it can only be a sub-menu, as otherwise menu items don't remain selected).
        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected children
        返回：
        the i-th selected child
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Returns true if the current child of this object is selected (that is, if this child is a popped-up submenu).
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Selects the ith menu in the menu. If that item is a submenu, it will pop up in response. If a different item is already popped up, this will force it to close. If this is a sub-menu that is already popped up (selected), this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the index of the item to be selected
        另请参见：
        AbstractButton.AccessibleAbstractButton.getAccessibleStateSet()

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the nth item from the selection. In general, menus can only have one item within them selected at a time (e.g. one sub-menu popped open).
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the selected item
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that nothing in the object is selected. This will close any open sub-menu.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Normally causes every selected item in the object to be selected if the object supports multiple selections. This method makes no sense in a menu bar, and so does nothing.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iietc ee efrrefftell 0 idseoxdi;;


JMenu.WinListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenu.WinListener

  • java.lang.Object
    • java.awt.event.WindowAdapter
      • javax.swing.JMenu.WinListener
  • 所有已实现的接口：
    WindowFocusListener, WindowListener, WindowStateListener, Serializable, EventListener
    封闭类：
    JMenu

    protected class JMenu.WinListener
extends WindowAdapter
implements Serializable
    A listener class that watches for a popup window closing. When the popup is closing, the listener deselects the menu.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMenu.WinListener(JPopupMenu p)
      Create the window listener for the specified popup.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void windowClosing(WindowEvent e)
      Deselect the menu when the popup is closed from outside.

      • 方法 - 继承于类 java.awt.event.WindowAdapter

        windowActivated, windowClosed, windowDeactivated, windowDeiconified, windowGainedFocus, windowIconified, windowLostFocus, windowOpened, windowStateChanged

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JMenu.WinListener

        public JMenu.WinListener(JPopupMenu p)
        Create the window listener for the specified popup.
        从以下版本开始：
        1.4

    • 方法详细信息

      • windowClosing

        public void windowClosing(WindowEvent e)
        Deselect the menu when the popup is closed from outside.
        指定者：
        windowClosing in interface WindowListener
        重载：
        windowClosing in class WindowAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

teia,ae aeilleiiil v=mvSiiaS aelb要>/-猟


JMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenuBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JMenuBar
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
    直接已知子类：
    BasicInternalFrameTitlePane.SystemMenuBar

    public class JMenuBar
extends JComponent
implements Accessible, MenuElement
    An implementation of a menu bar. You add JMenu objects to the menu bar to construct a menu. When the user selects a JMenu object, its associated JPopupMenu is displayed, allowing the user to select one of the JMenuItems on it.

    For information and examples of using menu bars see How to Use Menus, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JMenu, JPopupMenu, JMenuItem

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JMenuBar.AccessibleJMenuBar
      This class implements accessibility support for the JMenuBar class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMenuBar()
      Creates a new menu bar.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMenu add(JMenu c)
      Appends the specified menu to the end of the menu bar.
      void addNotify()
      Overrides JComponent.addNotify to register this menu bar with the current keyboard manager.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JMenuBar.
      Component getComponent()
      Implemented to be a MenuElement.
      Component getComponentAtIndex(int i)
      Deprecated.
      replaced by getComponent(int i)
      int getComponentIndex(Component c)
      Returns the index of the specified component.
      JMenu getHelpMenu()
      Gets the help menu for the menu bar.
      Insets getMargin()
      Returns the margin between the menubar's border and its menus.
      JMenu getMenu(int index)
      Returns the menu at the specified position in the menu bar.
      int getMenuCount()
      Returns the number of items in the menu bar.
      SingleSelectionModel getSelectionModel()
      Returns the model object that handles single selections.
      MenuElement[] getSubElements()
      Implemented to be a MenuElement -- returns the menus in this menu bar.
      MenuBarUI getUI()
      Returns the menubar's current UI.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      boolean isBorderPainted()
      Returns true if the menu bars border should be painted.
      boolean isSelected()
      Returns true if the menu bar currently has a component selected.
      void menuSelectionChanged(boolean isIncluded)
      Implemented to be a MenuElement -- does nothing.
      protected void paintBorder(Graphics g)
      Paints the menubar's border if BorderPainted property is true.
      protected String paramString()
      Returns a string representation of this JMenuBar.
      protected boolean processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      Subclassed to check all the child menus.
      void processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.
      void processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.
      void removeNotify()
      Overrides JComponent.removeNotify to unregister this menu bar with the current keyboard manager.
      void setBorderPainted(boolean b)
      Sets whether the border should be painted.
      void setHelpMenu(JMenu menu)
      Sets the help menu that appears when the user selects the "help" option in the menu bar.
      void setMargin(Insets m)
      Sets the margin between the menubar's border and its menus.
      void setSelected(Component sel)
      Sets the currently selected component, producing a a change to the selection model.
      void setSelectionModel(SingleSelectionModel model)
      Sets the model object to handle single selections.
      void setUI(MenuBarUI ui)
      Sets the L&F object that renders this component.
      void updateUI()
      Resets the UI property with a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMenuBar

        public JMenuBar()
        Creates a new menu bar.

    • 方法详细信息

      • getUI

        public MenuBarUI getUI()
        Returns the menubar's current UI.
        另请参见：
        setUI(javax.swing.plaf.MenuBarUI)

      • setUI

        public void setUI(MenuBarUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the new MenuBarUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property with a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "MenuBarUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getSelectionModel

        public SingleSelectionModel getSelectionModel()
        Returns the model object that handles single selections.
        返回：
        the SingleSelectionModel property
        另请参见：
        SingleSelectionModel

      • setSelectionModel

        public void setSelectionModel(SingleSelectionModel model)
        Sets the model object to handle single selections.
        参数：
        model - the SingleSelectionModel to use
        另请参见：
        SingleSelectionModel

      • add

        public JMenu add(JMenu c)
        Appends the specified menu to the end of the menu bar.
        参数：
        c - the JMenu component to add
        返回：
        the menu component

      • getMenu

        public JMenu getMenu(int index)
        Returns the menu at the specified position in the menu bar.
        参数：
        index - an integer giving the position in the menu bar, where 0 is the first position
        返回：
        the JMenu at that position, or null if if there is no JMenu at that position (ie. if it is a JMenuItem)

      • getMenuCount

        public int getMenuCount()
        Returns the number of items in the menu bar.
        返回：
        the number of items in the menu bar

      • setHelpMenu

        public void setHelpMenu(JMenu menu)
        Sets the help menu that appears when the user selects the "help" option in the menu bar. This method is not yet implemented and will throw an exception.
        参数：
        menu - the JMenu that delivers help to the user

      • getHelpMenu

        public JMenu getHelpMenu()
        Gets the help menu for the menu bar. This method is not yet implemented and will throw an exception.
        返回：
        the JMenu that delivers help to the user

      • getComponentAtIndex

        @Deprecated
public Component getComponentAtIndex(int i)
        Deprecated. replaced by getComponent(int i)
        Returns the component at the specified index.
        参数：
        i - an integer specifying the position, where 0 is first
        返回：
        the Component at the position, or null for an invalid index

      • getComponentIndex

        public int getComponentIndex(Component c)
        Returns the index of the specified component.
        参数：
        c - the Component to find
        返回：
        an integer giving the component's position, where 0 is first; or -1 if it can't be found

      • setSelected

        public void setSelected(Component sel)
        Sets the currently selected component, producing a a change to the selection model.
        参数：
        sel - the Component to select

      • isSelected

        public boolean isSelected()
        Returns true if the menu bar currently has a component selected.
        返回：
        true if a selection has been made, else false

      • isBorderPainted

        public boolean isBorderPainted()
        Returns true if the menu bars border should be painted.
        返回：
        true if the border should be painted, else false

      • setBorderPainted

        public void setBorderPainted(boolean b)
        Sets whether the border should be painted.
        参数：
        b - if true and border property is not null, the border is painted.
        另请参见：
        isBorderPainted()

      • paintBorder

        protected void paintBorder(Graphics g)
        Paints the menubar's border if BorderPainted property is true.
        重载：
        paintBorder in class JComponent
        参数：
        g - the Graphics context to use for painting
        另请参见：
        JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

      • setMargin

        public void setMargin(Insets m)
        Sets the margin between the menubar's border and its menus. Setting to null will cause the menubar to use the default margins.
        参数：
        m - an Insets object containing the margin values
        另请参见：
        Insets

      • getMargin

        public Insets getMargin()
        Returns the margin between the menubar's border and its menus. If there is no previous margin, it will create a default margin with zero size.
        返回：
        an Insets object containing the margin values
        另请参见：
        Insets

      • processMouseEvent

        public void processMouseEvent(MouseEvent event,
                     MenuElement[] path,
                     MenuSelectionManager manager)
        Implemented to be a MenuElement -- does nothing.
        指定者：
        processMouseEvent in interface MenuElement
        另请参见：
        getSubElements()

      • processKeyEvent

        public void processKeyEvent(KeyEvent e,
                   MenuElement[] path,
                   MenuSelectionManager manager)
        Implemented to be a MenuElement -- does nothing.
        指定者：
        processKeyEvent in interface MenuElement
        另请参见：
        getSubElements()

      • menuSelectionChanged

        public void menuSelectionChanged(boolean isIncluded)
        Implemented to be a MenuElement -- does nothing.
        指定者：
        menuSelectionChanged in interface MenuElement
        另请参见：
        getSubElements()

      • getSubElements

        public MenuElement[] getSubElements()
        Implemented to be a MenuElement -- returns the menus in this menu bar. This is the reason for implementing the MenuElement interface -- so that the menu bar can be treated the same as other menu elements.
        指定者：
        getSubElements in interface MenuElement
        返回：
        an array of menu items in the menu bar.

      • getComponent

        public Component getComponent()
        Implemented to be a MenuElement. Returns this object.
        指定者：
        getComponent in interface MenuElement
        返回：
        the current Component (this)
        另请参见：
        getSubElements()

      • paramString

        protected String paramString()
        Returns a string representation of this JMenuBar. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JMenuBar

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JMenuBar. For JMenuBars, the AccessibleContext takes the form of an AccessibleJMenuBar. A new AccessibleJMenuBar instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJMenuBar that serves as the AccessibleContext of this JMenuBar

      • processKeyBinding

        protected boolean processKeyBinding(KeyStroke ks,
                        KeyEvent e,
                        int condition,
                        boolean pressed)
        Subclassed to check all the child menus.
        重载：
        processKeyBinding in class JComponent
        参数：
        ks - the KeyStroke queried
        e - the KeyEvent
        condition - one of the following values:
        • JComponent.WHEN_FOCUSED
        • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        • JComponent.WHEN_IN_FOCUSED_WINDOW
        pressed - true if the key is pressed
        返回：
        true if there was a binding to an action, and the action was enabled
        从以下版本开始：
        1.3

      • addNotify

        public void addNotify()
        Overrides JComponent.addNotify to register this menu bar with the current keyboard manager.
        重载：
        addNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • removeNotify

        public void removeNotify()
        Overrides JComponent.removeNotify to unregister this menu bar with the current keyboard manager.
        重载：
        removeNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JMenuBar.AccessibleJMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenuBar.AccessibleJMenuBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JMenuBar.AccessibleJMenuBar
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection
    封闭类：
    JMenuBar

    protected class JMenuBar.AccessibleJMenuBar
extends JComponent.AccessibleJComponent
implements AccessibleSelection
    This class implements accessibility support for the JMenuBar class. It provides an implementation of the Java Accessibility API appropriate to menu bar user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JMenuBar.AccessibleJMenuBar()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Selects the nth menu in the menu bar, forcing it to pop up.
      void clearAccessibleSelection()
      Clears the selection in the object, so that nothing in the object is selected.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns the currently selected menu if one is selected, otherwise null.
      int getAccessibleSelectionCount()
      Returns 1 if a menu is currently selected in this menu bar.
      AccessibleStateSet getAccessibleStateSet()
      Get the accessible state set of this object.
      boolean isAccessibleChildSelected(int i)
      Returns true if the current child of this object is selected.
      void removeAccessibleSelection(int i)
      Removes the nth selected item in the object from the object's selection.
      void selectAllAccessibleSelection()
      Normally causes every selected item in the object to be selected if the object supports multiple selections.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JMenuBar.AccessibleJMenuBar

        protected JMenuBar.AccessibleJMenuBar()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the accessible state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns 1 if a menu is currently selected in this menu bar.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        1 if a menu is currently selected, else 0

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns the currently selected menu if one is selected, otherwise null.
        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected children
        返回：
        the i-th selected child
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Returns true if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Selects the nth menu in the menu bar, forcing it to pop up. If another menu is popped up, this will force it to close. If the nth menu is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        getAccessibleStateSet()

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the nth selected item in the object from the object's selection. If the nth item isn't currently selected, this method has no effect. Otherwise, it closes the popup menu.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that nothing in the object is selected. This will close any open menu.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Normally causes every selected item in the object to be selected if the object supports multiple selections. This method makes no sense in a menu bar, and so does nothing.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JMenuItem

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JMenuItem
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants
    直接已知子类：
    JCheckBoxMenuItem, JMenu, JRadioButtonMenuItem

    public class JMenuItem
extends AbstractButton
implements Accessible, MenuElement
    An implementation of an item in a menu. A menu item is essentially a button sitting in a list. When the user selects the "button", the action associated with the menu item is performed. A JMenuItem contained in a JPopupMenu performs exactly that function.

    Menu items can be configured, and to some degree controlled, by Actions. Using an Action with a menu item has many benefits beyond directly configuring a menu item. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    For further documentation and for examples, see How to Use Menus in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JPopupMenu, JMenu, JCheckBoxMenuItem, JRadioButtonMenuItem

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JMenuItem.AccessibleJMenuItem
      This class implements accessibility support for the JMenuItem class.

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JMenuItem()
      Creates a JMenuItem with no set text or icon.
      JMenuItem(Action a)
      Creates a menu item whose properties are taken from the specified Action.
      JMenuItem(Icon icon)
      Creates a JMenuItem with the specified icon.
      JMenuItem(String text)
      Creates a JMenuItem with the specified text.
      JMenuItem(String text, Icon icon)
      Creates a JMenuItem with the specified text and icon.
      JMenuItem(String text, int mnemonic)
      Creates a JMenuItem with the specified text and keyboard mnemonic.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void actionPropertyChanged(Action action, String propertyName)
      Updates the button's state in response to property changes in the associated action.
      void addMenuDragMouseListener(MenuDragMouseListener l)
      Adds a MenuDragMouseListener to the menu item.
      void addMenuKeyListener(MenuKeyListener l)
      Adds a MenuKeyListener to the menu item.
      protected void configurePropertiesFromAction(Action a)
      Sets the properties on this button to match those in the specified Action.
      protected void fireMenuDragMouseDragged(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuDragMouseEntered(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuDragMouseExited(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuDragMouseReleased(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuKeyPressed(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuKeyReleased(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireMenuKeyTyped(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      KeyStroke getAccelerator()
      Returns the KeyStroke which serves as an accelerator for the menu item.
      AccessibleContext getAccessibleContext()
      Returns the AccessibleContext associated with this JMenuItem.
      Component getComponent()
      Returns the java.awt.Component used to paint this object.
      MenuDragMouseListener[] getMenuDragMouseListeners()
      Returns an array of all the MenuDragMouseListeners added to this JMenuItem with addMenuDragMouseListener().
      MenuKeyListener[] getMenuKeyListeners()
      Returns an array of all the MenuKeyListeners added to this JMenuItem with addMenuKeyListener().
      MenuElement[] getSubElements()
      This method returns an array containing the sub-menu components for this menu component.
      String getUIClassID()
      Returns the suffix used to construct the name of the L&F class used to render this component.
      protected void init(String text, Icon icon)
      Initializes the menu item with the specified text and icon.
      boolean isArmed()
      Returns whether the menu item is "armed".
      void menuSelectionChanged(boolean isIncluded)
      Called by the MenuSelectionManager when the MenuElement is selected or unselected.
      protected String paramString()
      Returns a string representation of this JMenuItem.
      void processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void processMenuDragMouseEvent(MenuDragMouseEvent e)
      Handles mouse drag in a menu.
      void processMenuKeyEvent(MenuKeyEvent e)
      Handles a keystroke in a menu.
      void processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using the MenuSelectionManager's API.
      void removeMenuDragMouseListener(MenuDragMouseListener l)
      Removes a MenuDragMouseListener from the menu item.
      void removeMenuKeyListener(MenuKeyListener l)
      Removes a MenuKeyListener from the menu item.
      void setAccelerator(KeyStroke keyStroke)
      Sets the key combination which invokes the menu item's action listeners without navigating the menu hierarchy.
      void setArmed(boolean b)
      Identifies the menu item as "armed".
      void setEnabled(boolean b)
      Enables or disables the menu item.
      void setModel(ButtonModel newModel)
      Sets the model that this button represents.
      void setUI(MenuItemUI ui)
      Sets the look and feel object that renders this component.
      void updateUI()
      Resets the UI property with a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.AbstractButton

        addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JMenuItem

        public JMenuItem()
        Creates a JMenuItem with no set text or icon.

      • JMenuItem

        public JMenuItem(Icon icon)
        Creates a JMenuItem with the specified icon.
        参数：
        icon - the icon of the JMenuItem

      • JMenuItem

        public JMenuItem(String text)
        Creates a JMenuItem with the specified text.
        参数：
        text - the text of the JMenuItem

      • JMenuItem

        public JMenuItem(Action a)
        Creates a menu item whose properties are taken from the specified Action.
        参数：
        a - the action of the JMenuItem
        从以下版本开始：
        1.3

      • JMenuItem

        public JMenuItem(String text,
         Icon icon)
        Creates a JMenuItem with the specified text and icon.
        参数：
        text - the text of the JMenuItem
        icon - the icon of the JMenuItem

      • JMenuItem

        public JMenuItem(String text,
         int mnemonic)
        Creates a JMenuItem with the specified text and keyboard mnemonic.
        参数：
        text - the text of the JMenuItem
        mnemonic - the keyboard mnemonic for the JMenuItem

    • 方法详细信息

      • setModel

        public void setModel(ButtonModel newModel)
        Sets the model that this button represents.
        重载：
        setModel in class AbstractButton
        参数：
        newModel - the new ButtonModel
        另请参见：
        AbstractButton.getModel()

      • init

        protected void init(String text,
        Icon icon)
        Initializes the menu item with the specified text and icon.
        重载：
        init in class AbstractButton
        参数：
        text - the text of the JMenuItem
        icon - the icon of the JMenuItem

      • setUI

        public void setUI(MenuItemUI ui)
        Sets the look and feel object that renders this component.
        参数：
        ui - the JMenuItemUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property with a value from the current look and feel.
        重载：
        updateUI in class AbstractButton
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the suffix used to construct the name of the L&F class used to render this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "MenuItemUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setArmed

        public void setArmed(boolean b)
        Identifies the menu item as "armed". If the mouse button is released while it is over this item, the menu's action event will fire. If the mouse button is released elsewhere, the event will not fire and the menu item will be disarmed.
        参数：
        b - true to arm the menu item so it can be selected

      • isArmed

        public boolean isArmed()
        Returns whether the menu item is "armed".
        返回：
        true if the menu item is armed, and it can be selected
        另请参见：
        setArmed(boolean)

      • setEnabled

        public void setEnabled(boolean b)
        Enables or disables the menu item.
        重载：
        setEnabled in class AbstractButton
        参数：
        b - true to enable the item
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • setAccelerator

        public void setAccelerator(KeyStroke keyStroke)
        Sets the key combination which invokes the menu item's action listeners without navigating the menu hierarchy. It is the UI's responsibility to install the correct action. Note that when the keyboard accelerator is typed, it will work whether or not the menu is currently displayed.
        参数：
        keyStroke - the KeyStroke which will serve as an accelerator

      • getAccelerator

        public KeyStroke getAccelerator()
        Returns the KeyStroke which serves as an accelerator for the menu item.
        返回：
        a KeyStroke object identifying the accelerator key

      • configurePropertiesFromAction

        protected void configurePropertiesFromAction(Action a)
        Sets the properties on this button to match those in the specified Action. Refer to Swing Components Supporting Action for more details as to which properties this sets.
        重载：
        configurePropertiesFromAction in class AbstractButton
        参数：
        a - the Action from which to get the properties, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, AbstractButton.setAction(javax.swing.Action)

      • actionPropertyChanged

        protected void actionPropertyChanged(Action action,
                         String propertyName)
        Updates the button's state in response to property changes in the associated action. This method is invoked from the PropertyChangeListener returned from createActionPropertyChangeListener. Subclasses do not normally need to invoke this. Subclasses that support additional Action properties should override this and configurePropertiesFromAction.

        Refer to the table at Swing Components Supporting Action for a list of the properties this method sets.

        重载：
        actionPropertyChanged in class AbstractButton
        参数：
        action - the Action associated with this button
        propertyName - the name of the property that changed
        从以下版本开始：
        1.6
        另请参见：
        Action, AbstractButton.configurePropertiesFromAction(javax.swing.Action)

      • processMouseEvent

        public void processMouseEvent(MouseEvent e,
                     MenuElement[] path,
                     MenuSelectionManager manager)
        Processes a mouse event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using the MenuSelectionManager's API.

        Note: you do not have to forward the event to sub-components. This is done automatically by the MenuSelectionManager.

        指定者：
        processMouseEvent in interface MenuElement
        参数：
        e - a MouseEvent
        path - the MenuElement path array
        manager - the MenuSelectionManager

      • processKeyEvent

        public void processKeyEvent(KeyEvent e,
                   MenuElement[] path,
                   MenuSelectionManager manager)
        Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.

        Note: you do not have to forward the event to sub-components. This is done automatically by the MenuSelectionManager.

        指定者：
        processKeyEvent in interface MenuElement
        参数：
        e - a KeyEvent
        path - the MenuElement path array
        manager - the MenuSelectionManager

      • processMenuDragMouseEvent

        public void processMenuDragMouseEvent(MenuDragMouseEvent e)
        Handles mouse drag in a menu.
        参数：
        e - a MenuDragMouseEvent object

      • processMenuKeyEvent

        public void processMenuKeyEvent(MenuKeyEvent e)
        Handles a keystroke in a menu.
        参数：
        e - a MenuKeyEvent object

      • fireMenuDragMouseEntered

        protected void fireMenuDragMouseEntered(MenuDragMouseEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuMouseDragEvent
        另请参见：
        EventListenerList

      • fireMenuDragMouseExited

        protected void fireMenuDragMouseExited(MenuDragMouseEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuDragMouseEvent
        另请参见：
        EventListenerList

      • fireMenuDragMouseDragged

        protected void fireMenuDragMouseDragged(MenuDragMouseEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuDragMouseEvent
        另请参见：
        EventListenerList

      • fireMenuDragMouseReleased

        protected void fireMenuDragMouseReleased(MenuDragMouseEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuDragMouseEvent
        另请参见：
        EventListenerList

      • fireMenuKeyPressed

        protected void fireMenuKeyPressed(MenuKeyEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuKeyEvent
        另请参见：
        EventListenerList

      • fireMenuKeyReleased

        protected void fireMenuKeyReleased(MenuKeyEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuKeyEvent
        另请参见：
        EventListenerList

      • fireMenuKeyTyped

        protected void fireMenuKeyTyped(MenuKeyEvent event)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        event - a MenuKeyEvent
        另请参见：
        EventListenerList

      • menuSelectionChanged

        public void menuSelectionChanged(boolean isIncluded)
        Called by the MenuSelectionManager when the MenuElement is selected or unselected.
        指定者：
        menuSelectionChanged in interface MenuElement
        参数：
        isIncluded - true if this menu item is on the part of the menu path that changed, false if this menu is part of the a menu path that changed, but this particular part of that path is still the same
        另请参见：
        MenuSelectionManager.setSelectedPath(MenuElement[])

      • getSubElements

        public MenuElement[] getSubElements()
        This method returns an array containing the sub-menu components for this menu component.
        指定者：
        getSubElements in interface MenuElement
        返回：
        an array of MenuElements

      • getComponent

        public Component getComponent()
        Returns the java.awt.Component used to paint this object. The returned component will be used to convert events and detect if an event is inside a menu component.
        指定者：
        getComponent in interface MenuElement
        返回：
        the Component that paints this menu item

      • addMenuDragMouseListener

        public void addMenuDragMouseListener(MenuDragMouseListener l)
        Adds a MenuDragMouseListener to the menu item.
        参数：
        l - the MenuDragMouseListener to be added

      • removeMenuDragMouseListener

        public void removeMenuDragMouseListener(MenuDragMouseListener l)
        Removes a MenuDragMouseListener from the menu item.
        参数：
        l - the MenuDragMouseListener to be removed

      • getMenuDragMouseListeners

        public MenuDragMouseListener[] getMenuDragMouseListeners()
        Returns an array of all the MenuDragMouseListeners added to this JMenuItem with addMenuDragMouseListener().
        返回：
        all of the MenuDragMouseListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • addMenuKeyListener

        public void addMenuKeyListener(MenuKeyListener l)
        Adds a MenuKeyListener to the menu item.
        参数：
        l - the MenuKeyListener to be added

      • removeMenuKeyListener

        public void removeMenuKeyListener(MenuKeyListener l)
        Removes a MenuKeyListener from the menu item.
        参数：
        l - the MenuKeyListener to be removed

      • getMenuKeyListeners

        public MenuKeyListener[] getMenuKeyListeners()
        Returns an array of all the MenuKeyListeners added to this JMenuItem with addMenuKeyListener().
        返回：
        all of the MenuKeyListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • paramString

        protected String paramString()
        Returns a string representation of this JMenuItem. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class AbstractButton
        返回：
        a string representation of this JMenuItem

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Returns the AccessibleContext associated with this JMenuItem. For JMenuItems, the AccessibleContext takes the form of an AccessibleJMenuItem. A new AccessibleJMenuItme instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJMenuItem that serves as the AccessibleContext of this JMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JMenuItem.AccessibleJMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 JMenuItem.AccessibleJMenuItem

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JMenuItem.AccessibleJMenuItem
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
    直接已知子类：
    JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JMenu.AccessibleJMenu, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
    封闭类：
    JMenuItem

    protected class JMenuItem.AccessibleJMenuItem
extends AbstractButton.AccessibleAbstractButton
implements ChangeListener
    This class implements accessibility support for the JMenuItem class. It provides an implementation of the Java Accessibility API appropriate to menu item user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      void stateChanged(ChangeEvent e)
      Supports the change listener interface and fires property changes.

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • stateChanged

        public void stateChanged(ChangeEvent e)
        Supports the change listener interface and fires property changes.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#


JOptionPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JOptionPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JOptionPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JOptionPane
extends JComponent
implements Accessible
    JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something. For information about using JOptionPane, see How to Make Dialogs, a section in The Java Tutorial.

    While the JOptionPane class may appear complex because of the large number of methods, almost all uses of this class are one-line calls to one of the static showXxxDialog methods shown below:

    Method Name | 描述
    showConfirmDialog | Asks a confirming question, like yes/no/cancel.
    showInputDialog | Prompt for some input.
    showMessageDialog | Tell the user about something that has happened.
    showOptionDialog | The Grand Unification of the above three.
    Each of these methods also comes in a showInternalXXX flavor, which uses an internal frame to hold the dialog box (see JInternalFrame). Multiple convenience methods have also been defined -- overloaded versions of the basic methods that use different parameter lists.

    All dialogs are modal. Each showXxxDialog method blocks the caller until the user's interaction is complete.

    icon message
    input value
    option buttons
    The basic appearance of one of these dialog boxes is generally similar to the picture at the right, although the various look-and-feels are ultimately responsible for the final result. In particular, the look-and-feels will adjust the layout to accommodate the option pane's ComponentOrientation property.

    参数：
    The parameters to these methods follow consistent patterns:

    parentComponent
    Defines the Component that is to be the parent of this dialog box. It is used in two ways: the Frame that contains it is used as the Frame parent for the dialog box, and its screen coordinates are used in the placement of the dialog box. In general, the dialog box is placed just below the component. This parameter may be null, in which case a default Frame is used as the parent, and the dialog will be centered on the screen (depending on the L&F).
    message
    A descriptive message to be placed in the dialog box. In the most common usage, message is just a String or String constant. However, the type of this parameter is actually Object. Its interpretation depends on its type:
    Object[]
    An array of objects is interpreted as a series of messages (one per object) arranged in a vertical stack. The interpretation is recursive -- each object in the array is interpreted according to its type.
    Component
    The Component is displayed in the dialog.
    Icon
    The Icon is wrapped in a JLabel and displayed in the dialog.
    others
    The object is converted to a String by calling its toString method. The result is wrapped in a JLabel and displayed.
    messageType
    Defines the style of the message. The Look and Feel manager may lay out the dialog differently depending on this value, and will often provide a default icon. The possible values are:
    • ERROR_MESSAGE
    • INFORMATION_MESSAGE
    • WARNING_MESSAGE
    • QUESTION_MESSAGE
    • PLAIN_MESSAGE
    optionType
    Defines the set of option buttons that appear at the bottom of the dialog box:
    • DEFAULT_OPTION
    • YES_NO_OPTION
    • YES_NO_CANCEL_OPTION
    • OK_CANCEL_OPTION
    You aren't limited to this set of option buttons. You can provide any buttons you want using the options parameter.
    options
    A more detailed description of the set of option buttons that will appear at the bottom of the dialog box. The usual value for the options parameter is an array of Strings. But the parameter type is an array of Objects. A button is created for each object depending on its type:
    Component
    The component is added to the button row directly.
    Icon
    A JButton is created with this as its label.
    other
    The Object is converted to a string using its toString method and the result is used to label a JButton.
    icon
    A decorative icon to be placed in the dialog box. A default value for this is determined by the messageType parameter.
    title
    The title for the dialog box.
    initialValue
    The default selection (input value).

    When the selection is changed, setValue is invoked, which generates a PropertyChangeEvent.

    If a JOptionPane has configured to all input setWantsInput the bound property JOptionPane.INPUT_VALUE_PROPERTY can also be listened to, to determine when the user has input or selected a value.

    When one of the showXxxDialog methods returns an integer, the possible values are:

    • YES_OPTION
    • NO_OPTION
    • CANCEL_OPTION
    • OK_OPTION
    • CLOSED_OPTION
    Examples:
    Show an error dialog that displays the message, 'alert':
    JOptionPane.showMessageDialog(null, "alert", "alert", JOptionPane.ERROR_MESSAGE);

    Show an internal information dialog with the message, 'information':
    JOptionPane.showInternalMessageDialog(frame, "information",
        "information", JOptionPane.INFORMATION_MESSAGE);

    Show an information panel with the options yes/no and message 'choose one':
    JOptionPane.showConfirmDialog(null,
        "choose one", "choose one", JOptionPane.YES_NO_OPTION);

    Show an internal information dialog with the options yes/no/cancel and message 'please choose one' and title information:
    JOptionPane.showInternalConfirmDialog(frame,
        "please choose one", "information",
        JOptionPane.YES_NO_CANCEL_OPTION, JOptionPane.INFORMATION_MESSAGE);

    Show a warning dialog with the options OK, CANCEL, title 'Warning', and message 'Click OK to continue':
    Object[] options = { "OK", "CANCEL" };
    JOptionPane.showOptionDialog(null, "Click OK to continue", "Warning",
        JOptionPane.DEFAULT_OPTION, JOptionPane.WARNING_MESSAGE,
        null, options, options[0]);

    Show a dialog asking the user to type in a String:
    String inputValue = JOptionPane.showInputDialog("Please input a value");

    Show a dialog asking the user to select a String:
    Object[] possibleValues = { "First", "Second", "Third" };
    Object selectedValue = JOptionPane.showInputDialog(null,
        "Choose one", "Input",
        JOptionPane.INFORMATION_MESSAGE, null,
        possibleValues, possibleValues[0]);

    Direct Use:
    To create and use an JOptionPane directly, the standard pattern is roughly as follows:
         JOptionPane pane = new JOptionPane(arguments);
     pane.set.Xxxx(...); // Configure
     JDialog dialog = pane.createDialog(parentComponent, title);
     dialog.show();
     Object selectedValue = pane.getValue();
     if(selectedValue == null)
       return CLOSED_OPTION;
     //If there is not an array of option buttons:
     if(options == null) {
       if(selectedValue instanceof Integer)
          return ((Integer)selectedValue).intValue();
       return CLOSED_OPTION;
     }
     //If there is an array of option buttons:
     for(int counter = 0, maxCounter = options.length;
        counter < maxCounter; counter++) {
        if(options[counter].equals(selectedValue))
        return counter;
     }
     return CLOSED_OPTION;

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JInternalFrame

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JOptionPane.AccessibleJOptionPane
      This class implements accessibility support for the JOptionPane class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int CANCEL_OPTION
      Return value from class method if CANCEL is chosen.
      static int CLOSED_OPTION
      Return value from class method if user closes window without selecting anything, more than likely this should be treated as either a CANCEL_OPTION or NO_OPTION.
      static int DEFAULT_OPTION
      Type meaning Look and Feel should not supply any options -- only use the options from the JOptionPane.
      static int ERROR_MESSAGE
      Used for error messages.
      protected Icon icon
      Icon used in pane.
      static String ICON_PROPERTY
      Bound property name for icon.
      static int INFORMATION_MESSAGE
      Used for information messages.
      static String INITIAL_SELECTION_VALUE_PROPERTY
      Bound property name for initialSelectionValue.
      static String INITIAL_VALUE_PROPERTY
      Bound property name for initialValue.
      protected Object initialSelectionValue
      Initial value to select in selectionValues.
      protected Object initialValue
      Value that should be initially selected in options.
      static String INPUT_VALUE_PROPERTY
      Bound property name for inputValue.
      protected Object inputValue
      Value the user has input.
      protected Object message
      Message to display.
      static String MESSAGE_PROPERTY
      Bound property name for message.
      static String MESSAGE_TYPE_PROPERTY
      Bound property name for type.
      protected int messageType
      Message type.
      static int NO_OPTION
      Return value from class method if NO is chosen.
      static int OK_CANCEL_OPTION
      Type used for showConfirmDialog.
      static int OK_OPTION
      Return value form class method if OK is chosen.
      static String OPTION_TYPE_PROPERTY
      Bound property name for optionType.
      protected Object[] options
      Options to display to the user.
      static String OPTIONS_PROPERTY
      Bound property name for option.
      protected int optionType
      Option type, one of DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION.
      static int PLAIN_MESSAGE
      No icon is used.
      static int QUESTION_MESSAGE
      Used for questions.
      static String SELECTION_VALUES_PROPERTY
      Bound property name for selectionValues.
      protected Object[] selectionValues
      Array of values the user can choose from.
      static Object UNINITIALIZED_VALUE
      Indicates that the user has not yet selected a value.
      protected Object value
      Currently selected value, will be a valid option, or UNINITIALIZED_VALUE or null.
      static String VALUE_PROPERTY
      Bound property name for value.
      static String WANTS_INPUT_PROPERTY
      Bound property name for wantsInput.
      protected boolean wantsInput
      If true, a UI widget will be provided to the user to get input.
      static int WARNING_MESSAGE
      Used for warning messages.
      static int YES_NO_CANCEL_OPTION
      Type used for showConfirmDialog.
      static int YES_NO_OPTION
      Type used for showConfirmDialog.
      static int YES_OPTION
      Return value from class method if YES is chosen.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JOptionPane()
      Creates a JOptionPane with a test message.
      JOptionPane(Object message)
      Creates a instance of JOptionPane to display a message using the plain-message message type and the default options delivered by the UI.
      JOptionPane(Object message, int messageType)
      Creates an instance of JOptionPane to display a message with the specified message type and the default options,
      JOptionPane(Object message, int messageType, int optionType)
      Creates an instance of JOptionPane to display a message with the specified message type and options.
      JOptionPane(Object message, int messageType, int optionType, Icon icon)
      Creates an instance of JOptionPane to display a message with the specified message type, options, and icon.
      JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
      Creates an instance of JOptionPane to display a message with the specified message type, icon, and options.
      JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
      Creates an instance of JOptionPane to display a message with the specified message type, icon, and options, with the initially-selected option specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JDialog createDialog(Component parentComponent, String title)
      Creates and returns a new JDialog wrapping this centered on the parentComponent in the parentComponent's frame.
      JDialog createDialog(String title)
      Creates and returns a new parentless JDialog with the specified title.
      JInternalFrame createInternalFrame(Component parentComponent, String title)
      Creates and returns an instance of JInternalFrame.
      AccessibleContext getAccessibleContext()
      Returns the AccessibleContext associated with this JOptionPane.
      static JDesktopPane getDesktopPaneForComponent(Component parentComponent)
      Returns the specified component's desktop pane.
      static Frame getFrameForComponent(Component parentComponent)
      Returns the specified component's Frame.
      Icon getIcon()
      Returns the icon this pane displays.
      Object getInitialSelectionValue()
      Returns the input value that is displayed as initially selected to the user.
      Object getInitialValue()
      Returns the initial value.
      Object getInputValue()
      Returns the value the user has input, if wantsInput is true.
      int getMaxCharactersPerLineCount()
      Returns the maximum number of characters to place on a line in a message.
      Object getMessage()
      Returns the message-object this pane displays.
      int getMessageType()
      Returns the message type.
      Object[] getOptions()
      Returns the choices the user can make.
      int getOptionType()
      Returns the type of options that are displayed.
      static Frame getRootFrame()
      Returns the Frame to use for the class methods in which a frame is not provided.
      Object[] getSelectionValues()
      Returns the input selection values.
      OptionPaneUI getUI()
      Returns the UI object which implements the L&F for this component.
      String getUIClassID()
      Returns the name of the UI class that implements the L&F for this component.
      Object getValue()
      Returns the value the user has selected.
      boolean getWantsInput()
      Returns the value of the wantsInput property.
      protected String paramString()
      Returns a string representation of this JOptionPane.
      void selectInitialValue()
      Requests that the initial value be selected, which will set focus to the initial value.
      void setIcon(Icon newIcon)
      Sets the icon to display.
      void setInitialSelectionValue(Object newValue)
      Sets the input value that is initially displayed as selected to the user.
      void setInitialValue(Object newInitialValue)
      Sets the initial value that is to be enabled -- the Component that has the focus when the pane is initially displayed.
      void setInputValue(Object newValue)
      Sets the input value that was selected or input by the user.
      void setMessage(Object newMessage)
      Sets the option pane's message-object.
      void setMessageType(int newType)
      Sets the option pane's message type.
      void setOptions(Object[] newOptions)
      Sets the options this pane displays.
      void setOptionType(int newType)
      Sets the options to display.
      static void setRootFrame(Frame newRootFrame)
      Sets the frame to use for class methods in which a frame is not provided.
      void setSelectionValues(Object[] newValues)
      Sets the input selection values for a pane that provides the user with a list of items to choose from.
      void setUI(OptionPaneUI ui)
      Sets the UI object which implements the L&F for this component.
      void setValue(Object newValue)
      Sets the value the user has chosen.
      void setWantsInput(boolean newValue)
      Sets the wantsInput property.
      static int showConfirmDialog(Component parentComponent, Object message)
      Brings up a dialog with the options Yes, No and Cancel; with the title, Select an Option.
      static int showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
      Brings up a dialog where the number of choices is determined by the optionType parameter.
      static int showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
      Brings up a dialog where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display.
      static int showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      Brings up a dialog with a specified icon, where the number of choices is determined by the optionType parameter.
      static String showInputDialog(Component parentComponent, Object message)
      Shows a question-message dialog requesting input from the user parented to parentComponent.
      static String showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
      Shows a question-message dialog requesting input from the user and parented to parentComponent.
      static String showInputDialog(Component parentComponent, Object message, String title, int messageType)
      Shows a dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.
      static Object showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      Prompts the user for input in a blocking dialog where the initial selection, possible selections, and all other options can be specified.
      static String showInputDialog(Object message)
      Shows a question-message dialog requesting input from the user.
      static String showInputDialog(Object message, Object initialSelectionValue)
      Shows a question-message dialog requesting input from the user, with the input value initialized to initialSelectionValue.
      static int showInternalConfirmDialog(Component parentComponent, Object message)
      Brings up an internal dialog panel with the options Yes, No and Cancel; with the title, Select an Option.
      static int showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
      Brings up a internal dialog panel where the number of choices is determined by the optionType parameter.
      static int showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
      Brings up an internal dialog panel where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display.
      static int showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      Brings up an internal dialog panel with a specified icon, where the number of choices is determined by the optionType parameter.
      static String showInternalInputDialog(Component parentComponent, Object message)
      Shows an internal question-message dialog requesting input from the user parented to parentComponent.
      static String showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
      Shows an internal dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.
      static Object showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      Prompts the user for input in a blocking internal dialog where the initial selection, possible selections, and all other options can be specified.
      static void showInternalMessageDialog(Component parentComponent, Object message)
      Brings up an internal confirmation dialog panel.
      static void showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
      Brings up an internal dialog panel that displays a message using a default icon determined by the messageType parameter.
      static void showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
      Brings up an internal dialog panel displaying a message, specifying all parameters.
      static int showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      Brings up an internal dialog panel with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.
      static void showMessageDialog(Component parentComponent, Object message)
      Brings up an information-message dialog titled "Message".
      static void showMessageDialog(Component parentComponent, Object message, String title, int messageType)
      Brings up a dialog that displays a message using a default icon determined by the messageType parameter.
      static void showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
      Brings up a dialog displaying a message, specifying all parameters.
      static int showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      Brings up a dialog with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.
      void updateUI()
      Notification from the UIManager that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UNINITIALIZED_VALUE

        public static final Object UNINITIALIZED_VALUE
        Indicates that the user has not yet selected a value.

      • DEFAULT_OPTION

        public static final int DEFAULT_OPTION
        Type meaning Look and Feel should not supply any options -- only use the options from the JOptionPane.
        另请参见：
        Constant Field Values

      • YES_NO_OPTION

        public static final int YES_NO_OPTION
        Type used for showConfirmDialog.
        另请参见：
        Constant Field Values

      • YES_NO_CANCEL_OPTION

        public static final int YES_NO_CANCEL_OPTION
        Type used for showConfirmDialog.
        另请参见：
        Constant Field Values

      • OK_CANCEL_OPTION

        public static final int OK_CANCEL_OPTION
        Type used for showConfirmDialog.
        另请参见：
        Constant Field Values

      • YES_OPTION

        public static final int YES_OPTION
        Return value from class method if YES is chosen.
        另请参见：
        Constant Field Values

      • NO_OPTION

        public static final int NO_OPTION
        Return value from class method if NO is chosen.
        另请参见：
        Constant Field Values

      • CANCEL_OPTION

        public static final int CANCEL_OPTION
        Return value from class method if CANCEL is chosen.
        另请参见：
        Constant Field Values

      • OK_OPTION

        public static final int OK_OPTION
        Return value form class method if OK is chosen.
        另请参见：
        Constant Field Values

      • CLOSED_OPTION

        public static final int CLOSED_OPTION
        Return value from class method if user closes window without selecting anything, more than likely this should be treated as either a CANCEL_OPTION or NO_OPTION.
        另请参见：
        Constant Field Values

      • ERROR_MESSAGE

        public static final int ERROR_MESSAGE
        Used for error messages.
        另请参见：
        Constant Field Values

      • INFORMATION_MESSAGE

        public static final int INFORMATION_MESSAGE
        Used for information messages.
        另请参见：
        Constant Field Values

      • WARNING_MESSAGE

        public static final int WARNING_MESSAGE
        Used for warning messages.
        另请参见：
        Constant Field Values

      • QUESTION_MESSAGE

        public static final int QUESTION_MESSAGE
        Used for questions.
        另请参见：
        Constant Field Values

      • PLAIN_MESSAGE

        public static final int PLAIN_MESSAGE
        No icon is used.
        另请参见：
        Constant Field Values

      • ICON_PROPERTY

        public static final String ICON_PROPERTY
        Bound property name for icon.
        另请参见：
        Constant Field Values

      • MESSAGE_PROPERTY

        public static final String MESSAGE_PROPERTY
        Bound property name for message.
        另请参见：
        Constant Field Values

      • VALUE_PROPERTY

        public static final String VALUE_PROPERTY
        Bound property name for value.
        另请参见：
        Constant Field Values

      • OPTIONS_PROPERTY

        public static final String OPTIONS_PROPERTY
        Bound property name for option.
        另请参见：
        Constant Field Values

      • INITIAL_VALUE_PROPERTY

        public static final String INITIAL_VALUE_PROPERTY
        Bound property name for initialValue.
        另请参见：
        Constant Field Values

      • MESSAGE_TYPE_PROPERTY

        public static final String MESSAGE_TYPE_PROPERTY
        Bound property name for type.
        另请参见：
        Constant Field Values

      • OPTION_TYPE_PROPERTY

        public static final String OPTION_TYPE_PROPERTY
        Bound property name for optionType.
        另请参见：
        Constant Field Values

      • SELECTION_VALUES_PROPERTY

        public static final String SELECTION_VALUES_PROPERTY
        Bound property name for selectionValues.
        另请参见：
        Constant Field Values

      • INITIAL_SELECTION_VALUE_PROPERTY

        public static final String INITIAL_SELECTION_VALUE_PROPERTY
        Bound property name for initialSelectionValue.
        另请参见：
        Constant Field Values

      • INPUT_VALUE_PROPERTY

        public static final String INPUT_VALUE_PROPERTY
        Bound property name for inputValue.
        另请参见：
        Constant Field Values

      • WANTS_INPUT_PROPERTY

        public static final String WANTS_INPUT_PROPERTY
        Bound property name for wantsInput.
        另请参见：
        Constant Field Values

      • icon

        protected transient Icon icon
        Icon used in pane.

      • message

        protected transient Object message
        Message to display.

      • options

        protected transient Object[] options
        Options to display to the user.

      • initialValue

        protected transient Object initialValue
        Value that should be initially selected in options.

      • messageType

        protected int messageType
        Message type.

      • optionType

        protected int optionType
        Option type, one of DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION.

      • value

        protected transient Object value
        Currently selected value, will be a valid option, or UNINITIALIZED_VALUE or null.

      • selectionValues

        protected transient Object[] selectionValues
        Array of values the user can choose from. Look and feel will provide the UI component to choose this from.

      • inputValue

        protected transient Object inputValue
        Value the user has input.

      • initialSelectionValue

        protected transient Object initialSelectionValue
        Initial value to select in selectionValues.

      • wantsInput

        protected boolean wantsInput
        If true, a UI widget will be provided to the user to get input.

    • 构造方法详细信息

      • JOptionPane

        public JOptionPane()
        Creates a JOptionPane with a test message.

      • JOptionPane

        public JOptionPane(Object message)
        Creates a instance of JOptionPane to display a message using the plain-message message type and the default options delivered by the UI.
        参数：
        message - the Object to display

      • JOptionPane

        public JOptionPane(Object message,
           int messageType)
        Creates an instance of JOptionPane to display a message with the specified message type and the default options,
        参数：
        message - the Object to display
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE

      • JOptionPane

        public JOptionPane(Object message,
           int messageType,
           int optionType)
        Creates an instance of JOptionPane to display a message with the specified message type and options.
        参数：
        message - the Object to display
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        optionType - the options to display in the pane: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, OK_CANCEL_OPTION

      • JOptionPane

        public JOptionPane(Object message,
           int messageType,
           int optionType,
           Icon icon)
        Creates an instance of JOptionPane to display a message with the specified message type, options, and icon.
        参数：
        message - the Object to display
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        optionType - the options to display in the pane: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, OK_CANCEL_OPTION
        icon - the Icon image to display

      • JOptionPane

        public JOptionPane(Object message,
           int messageType,
           int optionType,
           Icon icon,
           Object[] options)
        Creates an instance of JOptionPane to display a message with the specified message type, icon, and options. None of the options is initially selected.

        The options objects should contain either instances of Components, (which are added directly) or Strings (which are wrapped in a JButton). If you provide Components, you must ensure that when the Component is clicked it messages setValue in the created JOptionPane.

        参数：
        message - the Object to display
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        optionType - the options to display in the pane: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, OK_CANCEL_OPTION
        icon - the Icon image to display
        options - the choices the user can select

      • JOptionPane

        public JOptionPane(Object message,
           int messageType,
           int optionType,
           Icon icon,
           Object[] options,
           Object initialValue)
        Creates an instance of JOptionPane to display a message with the specified message type, icon, and options, with the initially-selected option specified.
        参数：
        message - the Object to display
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        optionType - the options to display in the pane: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, OK_CANCEL_OPTION
        icon - the Icon image to display
        options - the choices the user can select
        initialValue - the choice that is initially selected; if null, then nothing will be initially selected; only meaningful if options is used

    • 方法详细信息

      • showInputDialog

        public static String showInputDialog(Object message)
                              throws HeadlessException
        Shows a question-message dialog requesting input from the user. The dialog uses the default frame, which usually means it is centered on the screen.
        参数：
        message - the Object to display
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showInputDialog

        public static String showInputDialog(Object message,
                     Object initialSelectionValue)
        Shows a question-message dialog requesting input from the user, with the input value initialized to initialSelectionValue. The dialog uses the default frame, which usually means it is centered on the screen.
        参数：
        message - the Object to display
        initialSelectionValue - the value used to initialize the input field
        从以下版本开始：
        1.4

      • showInputDialog

        public static String showInputDialog(Component parentComponent,
                     Object message)
                              throws HeadlessException
        Shows a question-message dialog requesting input from the user parented to parentComponent. The dialog is displayed on top of the Component's frame, and is usually positioned below the Component.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showInputDialog

        public static String showInputDialog(Component parentComponent,
                     Object message,
                     Object initialSelectionValue)
        Shows a question-message dialog requesting input from the user and parented to parentComponent. The input value will be initialized to initialSelectionValue. The dialog is displayed on top of the Component's frame, and is usually positioned below the Component.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        initialSelectionValue - the value used to initialize the input field
        从以下版本开始：
        1.4

      • showInputDialog

        public static String showInputDialog(Component parentComponent,
                     Object message,
                     String title,
                     int messageType)
                              throws HeadlessException
        Shows a dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        title - the String to display in the dialog title bar
        messageType - the type of message that is to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showInputDialog

        public static Object showInputDialog(Component parentComponent,
                     Object message,
                     String title,
                     int messageType,
                     Icon icon,
                     Object[] selectionValues,
                     Object initialSelectionValue)
                              throws HeadlessException
        Prompts the user for input in a blocking dialog where the initial selection, possible selections, and all other options can be specified. The user will able to choose from selectionValues, where null implies the user can input whatever they wish, usually by means of a JTextField. initialSelectionValue is the initial value to prompt the user with. It is up to the UI to decide how best to represent the selectionValues, but usually a JComboBox, JList, or JTextField will be used.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        title - the String to display in the dialog title bar
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the Icon image to display
        selectionValues - an array of Objects that gives the possible selections
        initialSelectionValue - the value used to initialize the input field
        返回：
        user's input, or null meaning the user canceled the input
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showMessageDialog

        public static void showMessageDialog(Component parentComponent,
                     Object message)
                              throws HeadlessException
        Brings up an information-message dialog titled "Message".
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showMessageDialog

        public static void showMessageDialog(Component parentComponent,
                     Object message,
                     String title,
                     int messageType)
                              throws HeadlessException
        Brings up a dialog that displays a message using a default icon determined by the messageType parameter.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showMessageDialog

        public static void showMessageDialog(Component parentComponent,
                     Object message,
                     String title,
                     int messageType,
                     Icon icon)
                              throws HeadlessException
        Brings up a dialog displaying a message, specifying all parameters.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - an icon to display in the dialog that helps the user identify the kind of message that is being displayed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showConfirmDialog

        public static int showConfirmDialog(Component parentComponent,
                    Object message)
                             throws HeadlessException
        Brings up a dialog with the options Yes, No and Cancel; with the title, Select an Option.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        返回：
        an integer indicating the option selected by the user
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showConfirmDialog

        public static int showConfirmDialog(Component parentComponent,
                    Object message,
                    String title,
                    int optionType)
                             throws HeadlessException
        Brings up a dialog where the number of choices is determined by the optionType parameter.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        optionType - an int designating the options available on the dialog: YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION
        返回：
        an int indicating the option selected by the user
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showConfirmDialog

        public static int showConfirmDialog(Component parentComponent,
                    Object message,
                    String title,
                    int optionType,
                    int messageType)
                             throws HeadlessException
        Brings up a dialog where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display. The messageType parameter is primarily used to supply a default icon from the Look and Feel.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used.
        message - the Object to display
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION
        messageType - an integer designating the kind of message this is; primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        返回：
        an integer indicating the option selected by the user
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showConfirmDialog

        public static int showConfirmDialog(Component parentComponent,
                    Object message,
                    String title,
                    int optionType,
                    int messageType,
                    Icon icon)
                             throws HeadlessException
        Brings up a dialog with a specified icon, where the number of choices is determined by the optionType parameter. The messageType parameter is primarily used to supply a default icon from the look and feel.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        optionType - an int designating the options available on the dialog: YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION
        messageType - an int designating the kind of message this is, primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the icon to display in the dialog
        返回：
        an int indicating the option selected by the user
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showOptionDialog

        public static int showOptionDialog(Component parentComponent,
                   Object message,
                   String title,
                   int optionType,
                   int messageType,
                   Icon icon,
                   Object[] options,
                   Object initialValue)
                            throws HeadlessException
        Brings up a dialog with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.

        If optionType is YES_NO_OPTION, or YES_NO_CANCEL_OPTION and the options parameter is null, then the options are supplied by the look and feel.

        The messageType parameter is primarily used to supply a default icon from the look and feel.

        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION
        messageType - an integer designating the kind of message this is, primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the icon to display in the dialog
        options - an array of objects indicating the possible choices the user can make; if the objects are components, they are rendered properly; non-String objects are rendered using their toString methods; if this parameter is null, the options are determined by the Look and Feel
        initialValue - the object that represents the default selection for the dialog; only meaningful if options is used; can be null
        返回：
        an integer indicating the option chosen by the user, or CLOSED_OPTION if the user closed the dialog
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • createDialog

        public JDialog createDialog(Component parentComponent,
                   String title)
                     throws HeadlessException
        Creates and returns a new JDialog wrapping this centered on the parentComponent in the parentComponent's frame. title is the title of the returned dialog. The returned JDialog will not be resizable by the user, however programs can invoke setResizable on the JDialog instance to change this property. The returned JDialog will be set up such that once it is closed, or the user clicks on one of the buttons, the optionpane's value property will be set accordingly and the dialog will be closed. Each time the dialog is made visible, it will reset the option pane's value property to JOptionPane.UNINITIALIZED_VALUE to ensure the user's subsequent action closes the dialog properly.
        参数：
        parentComponent - determines the frame in which the dialog is displayed; if the parentComponent has no Frame, a default Frame is used
        title - the title string for the dialog
        返回：
        a new JDialog containing this instance
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        GraphicsEnvironment.isHeadless()

      • createDialog

        public JDialog createDialog(String title)
                     throws HeadlessException
        Creates and returns a new parentless JDialog with the specified title. The returned JDialog will not be resizable by the user, however programs can invoke setResizable on the JDialog instance to change this property. The returned JDialog will be set up such that once it is closed, or the user clicks on one of the buttons, the optionpane's value property will be set accordingly and the dialog will be closed. Each time the dialog is made visible, it will reset the option pane's value property to JOptionPane.UNINITIALIZED_VALUE to ensure the user's subsequent action closes the dialog properly.
        参数：
        title - the title string for the dialog
        返回：
        a new JDialog containing this instance
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        从以下版本开始：
        1.6
        另请参见：
        GraphicsEnvironment.isHeadless()

      • showInternalMessageDialog

        public static void showInternalMessageDialog(Component parentComponent,
                             Object message)
        Brings up an internal confirmation dialog panel. The dialog is a information-message dialog titled "Message".
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the object to display

      • showInternalMessageDialog

        public static void showInternalMessageDialog(Component parentComponent,
                             Object message,
                             String title,
                             int messageType)
        Brings up an internal dialog panel that displays a message using a default icon determined by the messageType parameter.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE

      • showInternalMessageDialog

        public static void showInternalMessageDialog(Component parentComponent,
                             Object message,
                             String title,
                             int messageType,
                             Icon icon)
        Brings up an internal dialog panel displaying a message, specifying all parameters.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        title - the title string for the dialog
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - an icon to display in the dialog that helps the user identify the kind of message that is being displayed

      • showInternalConfirmDialog

        public static int showInternalConfirmDialog(Component parentComponent,
                            Object message)
        Brings up an internal dialog panel with the options Yes, No and Cancel; with the title, Select an Option.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the Object to display
        返回：
        an integer indicating the option selected by the user

      • showInternalConfirmDialog

        public static int showInternalConfirmDialog(Component parentComponent,
                            Object message,
                            String title,
                            int optionType)
        Brings up a internal dialog panel where the number of choices is determined by the optionType parameter.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the object to display in the dialog; a Component object is rendered as a Component; a String object is rendered as a string; other objects are converted to a String using the toString method
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: YES_NO_OPTION, or YES_NO_CANCEL_OPTION
        返回：
        an integer indicating the option selected by the user

      • showInternalConfirmDialog

        public static int showInternalConfirmDialog(Component parentComponent,
                            Object message,
                            String title,
                            int optionType,
                            int messageType)
        Brings up an internal dialog panel where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display. The messageType parameter is primarily used to supply a default icon from the Look and Feel.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the object to display in the dialog; a Component object is rendered as a Component; a String object is rendered as a string; other objects are converted to a String using the toString method
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: YES_NO_OPTION, or YES_NO_CANCEL_OPTION
        messageType - an integer designating the kind of message this is, primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        返回：
        an integer indicating the option selected by the user

      • showInternalConfirmDialog

        public static int showInternalConfirmDialog(Component parentComponent,
                            Object message,
                            String title,
                            int optionType,
                            int messageType,
                            Icon icon)
        Brings up an internal dialog panel with a specified icon, where the number of choices is determined by the optionType parameter. The messageType parameter is primarily used to supply a default icon from the look and feel.
        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the object to display in the dialog; a Component object is rendered as a Component; a String object is rendered as a string; other objects are converted to a String using the toString method
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: YES_NO_OPTION, or YES_NO_CANCEL_OPTION.
        messageType - an integer designating the kind of message this is, primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the icon to display in the dialog
        返回：
        an integer indicating the option selected by the user

      • showInternalOptionDialog

        public static int showInternalOptionDialog(Component parentComponent,
                           Object message,
                           String title,
                           int optionType,
                           int messageType,
                           Icon icon,
                           Object[] options,
                           Object initialValue)
        Brings up an internal dialog panel with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.

        If optionType is YES_NO_OPTION, or YES_NO_CANCEL_OPTION and the options parameter is null, then the options are supplied by the Look and Feel.

        The messageType parameter is primarily used to supply a default icon from the look and feel.

        参数：
        parentComponent - determines the Frame in which the dialog is displayed; if null, or if the parentComponent has no Frame, a default Frame is used
        message - the object to display in the dialog; a Component object is rendered as a Component; a String object is rendered as a string. Other objects are converted to a String using the toString method
        title - the title string for the dialog
        optionType - an integer designating the options available on the dialog: YES_NO_OPTION, or YES_NO_CANCEL_OPTION
        messageType - an integer designating the kind of message this is; primarily used to determine the icon from the pluggable Look and Feel: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the icon to display in the dialog
        options - an array of objects indicating the possible choices the user can make; if the objects are components, they are rendered properly; non-String objects are rendered using their toString methods; if this parameter is null, the options are determined by the Look and Feel
        initialValue - the object that represents the default selection for the dialog; only meaningful if options is used; can be null
        返回：
        an integer indicating the option chosen by the user, or CLOSED_OPTION if the user closed the Dialog

      • showInternalInputDialog

        public static String showInternalInputDialog(Component parentComponent,
                             Object message)
        Shows an internal question-message dialog requesting input from the user parented to parentComponent. The dialog is displayed in the Component's frame, and is usually positioned below the Component.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display

      • showInternalInputDialog

        public static String showInternalInputDialog(Component parentComponent,
                             Object message,
                             String title,
                             int messageType)
        Shows an internal dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        title - the String to display in the dialog title bar
        messageType - the type of message that is to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE

      • showInternalInputDialog

        public static Object showInternalInputDialog(Component parentComponent,
                             Object message,
                             String title,
                             int messageType,
                             Icon icon,
                             Object[] selectionValues,
                             Object initialSelectionValue)
        Prompts the user for input in a blocking internal dialog where the initial selection, possible selections, and all other options can be specified. The user will able to choose from selectionValues, where null implies the user can input whatever they wish, usually by means of a JTextField. initialSelectionValue is the initial value to prompt the user with. It is up to the UI to decide how best to represent the selectionValues, but usually a JComboBox, JList, or JTextField will be used.
        参数：
        parentComponent - the parent Component for the dialog
        message - the Object to display
        title - the String to display in the dialog title bar
        messageType - the type of message to be displayed: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        icon - the Icon image to display
        selectionValues - an array of Objects that gives the possible selections
        initialSelectionValue - the value used to initialize the input field
        返回：
        user's input, or null meaning the user canceled the input

      • createInternalFrame

        public JInternalFrame createInternalFrame(Component parentComponent,
                                 String title)
        Creates and returns an instance of JInternalFrame. The internal frame is created with the specified title, and wrapping the JOptionPane. The returned JInternalFrame is added to the JDesktopPane ancestor of parentComponent, or components parent if one its ancestors isn't a JDesktopPane, or if parentComponent doesn't have a parent then a RuntimeException is thrown.
        参数：
        parentComponent - the parent Component for the internal frame
        title - the String to display in the frame's title bar
        返回：
        a JInternalFrame containing a JOptionPane
        抛出：
        RuntimeException - if parentComponent does not have a valid parent

      • getFrameForComponent

        public static Frame getFrameForComponent(Component parentComponent)
                                  throws HeadlessException
        Returns the specified component's Frame.
        参数：
        parentComponent - the Component to check for a Frame
        返回：
        the Frame that contains the component, or getRootFrame if the component is null, or does not have a valid Frame parent
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        getRootFrame(), GraphicsEnvironment.isHeadless()

      • getDesktopPaneForComponent

        public static JDesktopPane getDesktopPaneForComponent(Component parentComponent)
        Returns the specified component's desktop pane.
        参数：
        parentComponent - the Component to check for a desktop
        返回：
        the JDesktopPane that contains the component, or null if the component is null or does not have an ancestor that is a JInternalFrame

      • setRootFrame

        public static void setRootFrame(Frame newRootFrame)
        Sets the frame to use for class methods in which a frame is not provided.

        Note: It is recommended that rather than using this method you supply a valid parent.

        参数：
        newRootFrame - the default Frame to use

      • getRootFrame

        public static Frame getRootFrame()
                          throws HeadlessException
        Returns the Frame to use for the class methods in which a frame is not provided.
        返回：
        the default Frame to use
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless returns true
        另请参见：
        setRootFrame(java.awt.Frame), GraphicsEnvironment.isHeadless()

      • setUI

        public void setUI(OptionPaneUI ui)
        Sets the UI object which implements the L&F for this component.
        参数：
        ui - the OptionPaneUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getUI

        public OptionPaneUI getUI()
        Returns the UI object which implements the L&F for this component.
        返回：
        the OptionPaneUI object

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the UI class that implements the L&F for this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "OptionPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setMessage

        public void setMessage(Object newMessage)
        Sets the option pane's message-object.
        参数：
        newMessage - the Object to display
        另请参见：
        getMessage()

      • getMessage

        public Object getMessage()
        Returns the message-object this pane displays.
        返回：
        the Object that is displayed
        另请参见：
        setMessage(java.lang.Object)

      • setIcon

        public void setIcon(Icon newIcon)
        Sets the icon to display. If non-null, the look and feel does not provide an icon.
        参数：
        newIcon - the Icon to display
        另请参见：
        getIcon()

      • getIcon

        public Icon getIcon()
        Returns the icon this pane displays.
        返回：
        the Icon that is displayed
        另请参见：
        setIcon(javax.swing.Icon)

      • setValue

        public void setValue(Object newValue)
        Sets the value the user has chosen.
        参数：
        newValue - the chosen value
        另请参见：
        getValue()

      • getValue

        public Object getValue()
        Returns the value the user has selected. UNINITIALIZED_VALUE implies the user has not yet made a choice, null means the user closed the window with out choosing anything. Otherwise the returned value will be one of the options defined in this object.
        返回：
        the Object chosen by the user, UNINITIALIZED_VALUE if the user has not yet made a choice, or null if the user closed the window without making a choice
        另请参见：
        setValue(java.lang.Object)

      • setOptions

        public void setOptions(Object[] newOptions)
        Sets the options this pane displays. If an element in newOptions is a Component it is added directly to the pane, otherwise a button is created for the element.
        参数：
        newOptions - an array of Objects that create the buttons the user can click on, or arbitrary Components to add to the pane
        另请参见：
        getOptions()

      • getOptions

        public Object[] getOptions()
        Returns the choices the user can make.
        返回：
        the array of Objects that give the user's choices
        另请参见：
        setOptions(java.lang.Object[])

      • setInitialValue

        public void setInitialValue(Object newInitialValue)
        Sets the initial value that is to be enabled -- the Component that has the focus when the pane is initially displayed.
        参数：
        newInitialValue - the Object that gets the initial keyboard focus
        另请参见：
        getInitialValue()

      • getInitialValue

        public Object getInitialValue()
        Returns the initial value.
        返回：
        the Object that gets the initial keyboard focus
        另请参见：
        setInitialValue(java.lang.Object)

      • setMessageType

        public void setMessageType(int newType)
        Sets the option pane's message type. The message type is used by the Look and Feel to determine the icon to display (if not supplied) as well as potentially how to lay out the parentComponent.
        参数：
        newType - an integer specifying the kind of message to display: ERROR_MESSAGE, INFORMATION_MESSAGE, WARNING_MESSAGE, QUESTION_MESSAGE, or PLAIN_MESSAGE
        抛出：
        RuntimeException - if newType is not one of the legal values listed above
        另请参见：
        getMessageType()

      • getMessageType

        public int getMessageType()
        Returns the message type.
        返回：
        an integer specifying the message type
        另请参见：
        setMessageType(int)

      • setOptionType

        public void setOptionType(int newType)
        Sets the options to display. The option type is used by the Look and Feel to determine what buttons to show (unless options are supplied).
        参数：
        newType - an integer specifying the options the L&F is to display: DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION, or OK_CANCEL_OPTION
        抛出：
        RuntimeException - if newType is not one of the legal values listed above
        另请参见：
        getOptionType(), setOptions(java.lang.Object[])

      • getOptionType

        public int getOptionType()
        Returns the type of options that are displayed.
        返回：
        an integer specifying the user-selectable options
        另请参见：
        setOptionType(int)

      • setSelectionValues

        public void setSelectionValues(Object[] newValues)
        Sets the input selection values for a pane that provides the user with a list of items to choose from. (The UI provides a widget for choosing one of the values.) A null value implies the user can input whatever they wish, usually by means of a JTextField.

        Sets wantsInput to true. Use setInitialSelectionValue to specify the initially-chosen value. After the pane as been enabled, inputValue is set to the value the user has selected.

        参数：
        newValues - an array of Objects the user to be displayed (usually in a list or combo-box) from which the user can make a selection
        另请参见：
        setWantsInput(boolean), setInitialSelectionValue(java.lang.Object), getSelectionValues()

      • getSelectionValues

        public Object[] getSelectionValues()
        Returns the input selection values.
        返回：
        the array of Objects the user can select
        另请参见：
        setSelectionValues(java.lang.Object[])

      • setInitialSelectionValue

        public void setInitialSelectionValue(Object newValue)
        Sets the input value that is initially displayed as selected to the user. Only used if wantsInput is true.
        参数：
        newValue - the initially selected value
        另请参见：
        setSelectionValues(java.lang.Object[]), getInitialSelectionValue()

      • getInitialSelectionValue

        public Object getInitialSelectionValue()
        Returns the input value that is displayed as initially selected to the user.
        返回：
        the initially selected value
        另请参见：
        setInitialSelectionValue(java.lang.Object), setSelectionValues(java.lang.Object[])

      • setInputValue

        public void setInputValue(Object newValue)
        Sets the input value that was selected or input by the user. Only used if wantsInput is true. Note that this method is invoked internally by the option pane (in response to user action) and should generally not be called by client programs. To set the input value initially displayed as selected to the user, use setInitialSelectionValue.
        参数：
        newValue - the Object used to set the value that the user specified (usually in a text field)
        另请参见：
        setSelectionValues(java.lang.Object[]), setInitialSelectionValue(java.lang.Object), setWantsInput(boolean), getInputValue()

      • getInputValue

        public Object getInputValue()
        Returns the value the user has input, if wantsInput is true.
        返回：
        the Object the user specified, if it was one of the objects, or a String if it was a value typed into a field
        另请参见：
        setSelectionValues(java.lang.Object[]), setWantsInput(boolean), setInputValue(java.lang.Object)

      • getMaxCharactersPerLineCount

        public int getMaxCharactersPerLineCount()
        Returns the maximum number of characters to place on a line in a message. Default is to return Integer.MAX_VALUE. The value can be changed by overriding this method in a subclass.
        返回：
        an integer giving the maximum number of characters on a line

      • setWantsInput

        public void setWantsInput(boolean newValue)
        Sets the wantsInput property. If newValue is true, an input component (such as a text field or combo box) whose parent is parentComponent is provided to allow the user to input a value. If getSelectionValues returns a non-null array, the input value is one of the objects in that array. Otherwise the input value is whatever the user inputs.

        This is a bound property.

        另请参见：
        setSelectionValues(java.lang.Object[]), setInputValue(java.lang.Object)

      • getWantsInput

        public boolean getWantsInput()
        Returns the value of the wantsInput property.
        返回：
        true if an input component will be provided
        另请参见：
        setWantsInput(boolean)

      • selectInitialValue

        public void selectInitialValue()
        Requests that the initial value be selected, which will set focus to the initial value. This method should be invoked after the window containing the option pane is made visible.

      • paramString

        protected String paramString()
        Returns a string representation of this JOptionPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JOptionPane

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Returns the AccessibleContext associated with this JOptionPane. For option panes, the AccessibleContext takes the form of an AccessibleJOptionPane. A new AccessibleJOptionPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJOptionPane that serves as the AccessibleContext of this AccessibleJOptionPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JOptionPane.AccessibleJOptionPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JOptionPane.AccessibleJOptionPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JOptionPane.AccessibleJOptionPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JOptionPane

    protected class JOptionPane.AccessibleJOptionPane
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JOptionPane class. It provides an implementation of the Java Accessibility API appropriate to option pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JOptionPane.AccessibleJOptionPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JOptionPane.AccessibleJOptionPane

        protected JOptionPane.AccessibleJOptionPane()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=/" >/c


JPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPanel

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible
    直接已知子类：
    AbstractColorChooserPanel, JSpinner.DefaultEditor

    public class JPanel
extends JComponent
implements Accessible
    JPanel is a generic lightweight container. For examples and task-oriented documentation for JPanel, see How to Use Panels, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JPanel.AccessibleJPanel
      This class implements accessibility support for the JPanel class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JPanel()
      Creates a new JPanel with a double buffer and a flow layout.
      JPanel(boolean isDoubleBuffered)
      Creates a new JPanel with FlowLayout and the specified buffering strategy.
      JPanel(LayoutManager layout)
      Create a new buffered JPanel with the specified layout manager
      JPanel(LayoutManager layout, boolean isDoubleBuffered)
      Creates a new JPanel with the specified layout manager and buffering strategy.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JPanel.
      PanelUI getUI()
      Returns the look and feel (L&F) object that renders this component.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JPanel.
      void setUI(PanelUI ui)
      Sets the look and feel (L&F) object that renders this component.
      void updateUI()
      Resets the UI property with a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JPanel

        public JPanel(LayoutManager layout,
      boolean isDoubleBuffered)
        Creates a new JPanel with the specified layout manager and buffering strategy.
        参数：
        layout - the LayoutManager to use
        isDoubleBuffered - a boolean, true for double-buffering, which uses additional memory space to achieve fast, flicker-free updates

      • JPanel

        public JPanel(LayoutManager layout)
        Create a new buffered JPanel with the specified layout manager
        参数：
        layout - the LayoutManager to use

      • JPanel

        public JPanel(boolean isDoubleBuffered)
        Creates a new JPanel with FlowLayout and the specified buffering strategy. If isDoubleBuffered is true, the JPanel will use a double buffer.
        参数：
        isDoubleBuffered - a boolean, true for double-buffering, which uses additional memory space to achieve fast, flicker-free updates

      • JPanel

        public JPanel()
        Creates a new JPanel with a double buffer and a flow layout.

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property with a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUI

        public PanelUI getUI()
        Returns the look and feel (L&F) object that renders this component.
        返回：
        the PanelUI object that renders this component
        从以下版本开始：
        1.4

      • setUI

        public void setUI(PanelUI ui)
        Sets the look and feel (L&F) object that renders this component.
        参数：
        ui - the PanelUI L&F object
        从以下版本开始：
        1.4
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        "PanelUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • paramString

        protected String paramString()
        Returns a string representation of this JPanel. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JPanel.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JPanel. For JPanels, the AccessibleContext takes the form of an AccessibleJPanel. A new AccessibleJPanel instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJPanel that serves as the AccessibleContext of this JPanel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltdstt foih


JPanel.AccessibleJPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPanel.AccessibleJPanel

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JPanel.AccessibleJPanel
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JPanel

    protected class JPanel.AccessibleJPanel
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JPanel class. It provides an implementation of the Java Accessibility API appropriate to panel user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JPanel.AccessibleJPanel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JPanel.AccessibleJPanel

        protected JPanel.AccessibleJPanel()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcr"oLslLss==sssd / <


JPasswordField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPasswordField

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextField
              • javax.swing.JPasswordField
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants

    public class JPasswordField
extends JTextField
    JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters. You can find further information and examples in How to Use Text Fields, a section in The Java Tutorial.

    JPasswordField is intended to be source-compatible with java.awt.TextField used with echoChar set. It is provided separately to make it easier to safely change the UI for the JTextField without affecting password entries.

    NOTE: By default, JPasswordField disables input methods; otherwise, input characters could be visible while they were composed using input methods. If an application needs the input methods support, please use the inherited method, enableInputMethods(true).

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.

      • Nested classes/interfaces inherited from class javax.swing.JTextField

        JTextField.AccessibleJTextField

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JTextField

        notifyAction

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JPasswordField()
      Constructs a new JPasswordField, with a default document, null starting text string, and 0 column width.
      JPasswordField(Document doc, String txt, int columns)
      Constructs a new JPasswordField that uses the given text storage model and the given number of columns.
      JPasswordField(int columns)
      Constructs a new empty JPasswordField with the specified number of columns.
      JPasswordField(String text)
      Constructs a new JPasswordField initialized with the specified text.
      JPasswordField(String text, int columns)
      Constructs a new JPasswordField initialized with the specified text and columns.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void copy()
      Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
      void cut()
      Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
      boolean echoCharIsSet()
      Returns true if this JPasswordField has a character set for echoing.
      AccessibleContext getAccessibleContext()
      Returns the AccessibleContext associated with this JPasswordField.
      char getEchoChar()
      Returns the character to be used for echoing.
      char[] getPassword()
      Returns the text contained in this TextComponent.
      String getText()
      Deprecated.
      As of Java 2 platform v1.2, replaced by getPassword.
      String getText(int offs, int len)
      Deprecated.
      As of Java 2 platform v1.2, replaced by getPassword.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JPasswordField.
      void setEchoChar(char c)
      Sets the echo character for this JPasswordField.
      void updateUI()
      Reloads the pluggable UI.

      • 方法 - 继承于类 javax.swing.JTextField

        actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAction, getActionListeners, getActions, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getPreferredSize, getScrollOffset, isValidateRoot, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setDocument, setFont, setHorizontalAlignment, setScrollOffset

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JPasswordField

        public JPasswordField()
        Constructs a new JPasswordField, with a default document, null starting text string, and 0 column width.

      • JPasswordField

        public JPasswordField(String text)
        Constructs a new JPasswordField initialized with the specified text. The document model is set to the default, and the number of columns to 0.
        参数：
        text - the text to be displayed, null if none

      • JPasswordField

        public JPasswordField(int columns)
        Constructs a new empty JPasswordField with the specified number of columns. A default model is created, and the initial string is set to null.
        参数：
        columns - the number of columns >= 0

      • JPasswordField

        public JPasswordField(String text,
              int columns)
        Constructs a new JPasswordField initialized with the specified text and columns. The document model is set to the default.
        参数：
        text - the text to be displayed, null if none
        columns - the number of columns >= 0

      • JPasswordField

        public JPasswordField(Document doc,
              String txt,
              int columns)
        Constructs a new JPasswordField that uses the given text storage model and the given number of columns. This is the constructor through which the other constructors feed. The echo character is set to '*', but may be changed by the current Look and Feel. If the document model is null, a default one will be created.
        参数：
        doc - the text storage to use
        txt - the text to be displayed, null if none
        columns - the number of columns to use to calculate the preferred width >= 0; if columns is set to zero, the preferred width will be whatever naturally results from the component implementation

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JTextField
        返回：
        the string "PasswordFieldUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Reloads the pluggable UI. The key used to fetch the new interface is getUIClassID(). The type of the UI is TextUI. invalidate is called after setting the UI.
        重载：
        updateUI in class JTextComponent
        从以下版本开始：
        1.6
        另请参见：
        JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • getEchoChar

        public char getEchoChar()
        Returns the character to be used for echoing. The default is '*'. The default may be different depending on the currently running Look and Feel. For example, Metal/Ocean's default is a bullet character.
        返回：
        the echo character, 0 if unset
        另请参见：
        setEchoChar(char), echoCharIsSet()

      • setEchoChar

        public void setEchoChar(char c)
        Sets the echo character for this JPasswordField. Note that this is largely a suggestion, since the view that gets installed can use whatever graphic techniques it desires to represent the field. Setting a value of 0 indicates that you wish to see the text as it is typed, similar to the behavior of a standard JTextField.
        参数：
        c - the echo character to display
        另请参见：
        echoCharIsSet(), getEchoChar()

      • echoCharIsSet

        public boolean echoCharIsSet()
        Returns true if this JPasswordField has a character set for echoing. A character is considered to be set if the echo character is not 0.
        返回：
        true if a character is set for echoing
        另请参见：
        setEchoChar(char), getEchoChar()

      • cut

        public void cut()
        Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep. The normal behavior of transferring the currently selected range in the associated text model to the system clipboard, and removing the contents from the model, is not acceptable for a password field.
        重载：
        cut in class JTextComponent
        另请参见：
        Toolkit.getSystemClipboard(), Clipboard

      • copy

        public void copy()
        Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep. The normal behavior of transferring the currently selected range in the associated text model to the system clipboard, and leaving the contents from the model, is not acceptable for a password field.
        重载：
        copy in class JTextComponent
        另请参见：
        Toolkit.getSystemClipboard(), Clipboard

      • getText

        @Deprecated
public String getText()
        Deprecated. As of Java 2 platform v1.2, replaced by getPassword.
        Returns the text contained in this TextComponent. If the underlying document is null, will give a NullPointerException.

        For security reasons, this method is deprecated. Use the * getPassword method instead.

        重载：
        getText in class JTextComponent
        返回：
        the text
        另请参见：
        JTextComponent.setText(java.lang.String)

      • getText

        @Deprecated
public String getText(int offs,
                        int len)
               throws BadLocationException
        Deprecated. As of Java 2 platform v1.2, replaced by getPassword.
        Fetches a portion of the text represented by the component. Returns an empty string if length is 0.

        For security reasons, this method is deprecated. Use the getPassword method instead.

        重载：
        getText in class JTextComponent
        参数：
        offs - the offset >= 0
        len - the length >= 0
        返回：
        the text
        抛出：
        BadLocationException - if the offset or length are invalid

      • getPassword

        public char[] getPassword()
        Returns the text contained in this TextComponent. If the underlying document is null, will give a NullPointerException. For stronger security, it is recommended that the returned character array be cleared after use by setting each character to zero.
        返回：
        the text

      • paramString

        protected String paramString()
        Returns a string representation of this JPasswordField. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JTextField
        返回：
        a string representation of this JPasswordField

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Returns the AccessibleContext associated with this JPasswordField. For password fields, the AccessibleContext takes the form of an AccessibleJPasswordField. A new AccessibleJPasswordField instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JTextField
        返回：
        an AccessibleJPasswordField that serves as the AccessibleContext of this JPasswordField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c


JPasswordField.AccessibleJPasswordField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPasswordField.AccessibleJPasswordField

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    封闭类：
    JPasswordField

    protected class JPasswordField.AccessibleJPasswordField
extends JTextField.AccessibleJTextField
    This class implements accessibility support for the JPasswordField class. It provides an implementation of the Java Accessibility API appropriate to password field user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JPasswordField.AccessibleJPasswordField()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText for the JPasswordField.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      String getTextRange(int startIndex, int endIndex)
      Returns the text between two indices.
      AccessibleTextSequence getTextSequenceAfter(int part, int index)
      Returns the AccessibleTextSequence after a given index.
      AccessibleTextSequence getTextSequenceAt(int part, int index)
      Returns the AccessibleTextSequence at a given index.
      AccessibleTextSequence getTextSequenceBefore(int part, int index)
      Returns the AccessibleTextSequence before a given index.

      • 方法 - 继承于类 javax.swing.JTextField.AccessibleJTextField

        getAccessibleStateSet

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JPasswordField.AccessibleJPasswordField

        protected JPasswordField.AccessibleJPasswordField()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JTextComponent.AccessibleJTextComponent
        返回：
        an instance of AccessibleRole describing the role of the object (AccessibleRole.PASSWORD_TEXT)
        另请参见：
        AccessibleRole

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Gets the AccessibleText for the JPasswordField. The returned object also implements the AccessibleExtendedText interface.
        重载：
        getAccessibleText in class JTextComponent.AccessibleJTextComponent
        返回：
        AccessibleText for the JPasswordField
        从以下版本开始：
        1.6
        另请参见：
        AccessibleContext, AccessibleContext.getAccessibleText(), AccessibleText, AccessibleExtendedText

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index.
        指定者：
        getAtIndex in interface AccessibleText
        重载：
        getAtIndex in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD or SENTENCE to retrieve
        index - an index within the text
        返回：
        a String if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index.
        指定者：
        getAfterIndex in interface AccessibleText
        重载：
        getAfterIndex in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD or SENTENCE to retrieve
        index - an index within the text
        返回：
        a String if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index.
        指定者：
        getBeforeIndex in interface AccessibleText
        重载：
        getBeforeIndex in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD or SENTENCE to retrieve
        index - an index within the text
        返回：
        a String if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

      • getTextRange

        public String getTextRange(int startIndex,
                  int endIndex)
        Returns the text between two indices.
        指定者：
        getTextRange in interface AccessibleEditableText
        指定者：
        getTextRange in interface AccessibleExtendedText
        重载：
        getTextRange in class JTextComponent.AccessibleJTextComponent
        参数：
        startIndex - the start index in the text
        endIndex - the end index in the text
        返回：
        the text string if the indices are valid. Otherwise, null is returned
        从以下版本开始：
        1.6

      • getTextSequenceAt

        public AccessibleTextSequence getTextSequenceAt(int part,
                                       int index)
        Returns the AccessibleTextSequence at a given index.
        指定者：
        getTextSequenceAt in interface AccessibleExtendedText
        重载：
        getTextSequenceAt in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

      • getTextSequenceAfter

        public AccessibleTextSequence getTextSequenceAfter(int part,
                                          int index)
        Returns the AccessibleTextSequence after a given index.
        指定者：
        getTextSequenceAfter in interface AccessibleExtendedText
        重载：
        getTextSequenceAfter in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

      • getTextSequenceBefore

        public AccessibleTextSequence getTextSequenceBefore(int part,
                                           int index)
        Returns the AccessibleTextSequence before a given index.
        指定者：
        getTextSequenceBefore in interface AccessibleExtendedText
        重载：
        getTextSequenceBefore in class JTextComponent.AccessibleJTextComponent
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v >l>lllilu divl


JPopupMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPopupMenu

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPopupMenu
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
    直接已知子类：
    BasicComboPopup

    public class JPopupMenu
extends JComponent
implements Accessible, MenuElement
    An implementation of a popup menu -- a small window that pops up and displays a series of choices. A JPopupMenu is used for the menu that appears when the user selects an item on the menu bar. It is also used for "pull-right" menu that appears when the selects a menu item that activates it. Finally, a JPopupMenu can also be used anywhere else you want a menu to appear. For example, when the user right-clicks in a specified area.

    For information and examples of using popup menus, see How to Use Menus in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JPopupMenu.AccessibleJPopupMenu
      This class implements accessibility support for the JPopupMenu class.
      static class  JPopupMenu.Separator
      A popup menu-specific separator.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JPopupMenu()
      Constructs a JPopupMenu without an "invoker".
      JPopupMenu(String label)
      Constructs a JPopupMenu with the specified title.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JMenuItem add(Action a)
      Appends a new menu item to the end of the menu which dispatches the specified Action object.
      JMenuItem add(JMenuItem menuItem)
      Appends the specified menu item to the end of this menu.
      JMenuItem add(String s)
      Creates a new menu item with the specified text and appends it to the end of this menu.
      void addMenuKeyListener(MenuKeyListener l)
      Adds a MenuKeyListener to the popup menu.
      void addPopupMenuListener(PopupMenuListener l)
      Adds a PopupMenu listener.
      void addSeparator()
      Appends a new separator at the end of the menu.
      protected PropertyChangeListener createActionChangeListener(JMenuItem b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
      protected JMenuItem createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
      protected void firePopupMenuCanceled()
      Notifies PopupMenuListeners that this popup menu is cancelled.
      protected void firePopupMenuWillBecomeInvisible()
      Notifies PopupMenuListeners that this popup menu will become invisible.
      protected void firePopupMenuWillBecomeVisible()
      Notifies PopupMenuListeners that this popup menu will become visible.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JPopupMenu.
      Component getComponent()
      Returns this JPopupMenu component.
      Component getComponentAtIndex(int i)
      Deprecated.
      replaced by Container.getComponent(int)
      int getComponentIndex(Component c)
      Returns the index of the specified component.
      static boolean getDefaultLightWeightPopupEnabled()
      Gets the defaultLightWeightPopupEnabled property, which by default is true.
      Component getInvoker()
      Returns the component which is the 'invoker' of this popup menu.
      String getLabel()
      Returns the popup menu's label
      Insets getMargin()
      Returns the margin, in pixels, between the popup menu's border and its containees.
      MenuKeyListener[] getMenuKeyListeners()
      Returns an array of all the MenuKeyListeners added to this JPopupMenu with addMenuKeyListener().
      PopupMenuListener[] getPopupMenuListeners()
      Returns an array of all the PopupMenuListeners added to this JMenuItem with addPopupMenuListener().
      SingleSelectionModel getSelectionModel()
      Returns the model object that handles single selections.
      MenuElement[] getSubElements()
      Returns an array of MenuElements containing the submenu for this menu component.
      PopupMenuUI getUI()
      Returns the look and feel (L&F) object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      void insert(Action a, int index)
      Inserts a menu item for the specified Action object at a given position.
      void insert(Component component, int index)
      Inserts the specified component into the menu at a given position.
      boolean isBorderPainted()
      Checks whether the border should be painted.
      boolean isLightWeightPopupEnabled()
      Gets the lightWeightPopupEnabled property.
      boolean isPopupTrigger(MouseEvent e)
      Returns true if the MouseEvent is considered a popup trigger by the JPopupMenu's currently installed UI.
      boolean isVisible()
      Returns true if the popup menu is visible (currently being displayed).
      void menuSelectionChanged(boolean isIncluded)
      Messaged when the menubar selection changes to activate or deactivate this menu.
      void pack()
      Lays out the container so that it uses the minimum space needed to display its contents.
      protected void paintBorder(Graphics g)
      Paints the popup menu's border if the borderPainted property is true.
      protected String paramString()
      Returns a string representation of this JPopupMenu.
      protected void processFocusEvent(FocusEvent evt)
      Processes focus events occurring on this component by dispatching them to any registered FocusListener objects.
      protected void processKeyEvent(KeyEvent evt)
      Processes key stroke events such as mnemonics and accelerators.
      void processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      This method is required to conform to the MenuElement interface, but it not implemented.
      void remove(int pos)
      Removes the component at the specified index from this popup menu.
      void removeMenuKeyListener(MenuKeyListener l)
      Removes a MenuKeyListener from the popup menu.
      void removePopupMenuListener(PopupMenuListener l)
      Removes a PopupMenu listener.
      void setBorderPainted(boolean b)
      Sets whether the border should be painted.
      static void setDefaultLightWeightPopupEnabled(boolean aFlag)
      Sets the default value of the lightWeightPopupEnabled property.
      void setInvoker(Component invoker)
      Sets the invoker of this popup menu -- the component in which the popup menu menu is to be displayed.
      void setLabel(String label)
      Sets the popup menu's label.
      void setLightWeightPopupEnabled(boolean aFlag)
      Sets the value of the lightWeightPopupEnabled property, which by default is true.
      void setLocation(int x, int y)
      Sets the location of the upper left corner of the popup menu using x, y coordinates.
      void setPopupSize(Dimension d)
      Sets the size of the Popup window using a Dimension object.
      void setPopupSize(int width, int height)
      Sets the size of the Popup window to the specified width and height.
      void setSelected(Component sel)
      Sets the currently selected component, This will result in a change to the selection model.
      void setSelectionModel(SingleSelectionModel model)
      Sets the model object to handle single selections.
      void setUI(PopupMenuUI ui)
      Sets the L&F object that renders this component.
      void setVisible(boolean b)
      Sets the visibility of the popup menu.
      void show(Component invoker, int x, int y)
      Displays the popup menu at the position x,y in the coordinate space of the component invoker.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JPopupMenu

        public JPopupMenu()
        Constructs a JPopupMenu without an "invoker".

      • JPopupMenu

        public JPopupMenu(String label)
        Constructs a JPopupMenu with the specified title.
        参数：
        label - the string that a UI may use to display as a title for the popup menu.

    • 方法详细信息

      • setDefaultLightWeightPopupEnabled

        public static void setDefaultLightWeightPopupEnabled(boolean aFlag)
        Sets the default value of the lightWeightPopupEnabled property.
        参数：
        aFlag - true if popups can be lightweight, otherwise false
        另请参见：
        getDefaultLightWeightPopupEnabled(), setLightWeightPopupEnabled(boolean)

      • getDefaultLightWeightPopupEnabled

        public static boolean getDefaultLightWeightPopupEnabled()
        Gets the defaultLightWeightPopupEnabled property, which by default is true.
        返回：
        the value of the defaultLightWeightPopupEnabled property
        另请参见：
        setDefaultLightWeightPopupEnabled(boolean)

      • getUI

        public PopupMenuUI getUI()
        Returns the look and feel (L&F) object that renders this component.
        返回：
        the PopupMenuUI object that renders this component

      • setUI

        public void setUI(PopupMenuUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the new PopupMenuUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "PopupMenuUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • processFocusEvent

        protected void processFocusEvent(FocusEvent evt)
        Description copied from class: Component
        Processes focus events occurring on this component by dispatching them to any registered FocusListener objects.

        This method is not called unless focus events are enabled for this component. Focus events are enabled when one of the following occurs:

        • A FocusListener object is registered via addFocusListener.
        • Focus events are enabled via enableEvents.

        If focus events are enabled for a Component, the current KeyboardFocusManager determines whether or not a focus event should be dispatched to registered FocusListener objects. If the events are to be dispatched, the KeyboardFocusManager calls the Component's dispatchEvent method, which results in a call to the Component's processFocusEvent method.

        If focus events are enabled for a Component, calling the Component's dispatchEvent method with a FocusEvent as the argument will result in a call to the Component's processFocusEvent method regardless of the current KeyboardFocusManager.

        Note that if the event parameter is null the behavior is unspecified and may result in an exception.

        重载：
        processFocusEvent in class Component
        参数：
        evt - the focus event
        另请参见：
        FocusEvent, FocusListener, KeyboardFocusManager, Component.addFocusListener(java.awt.event.FocusListener), Component.enableEvents(long), Component.dispatchEvent(java.awt.AWTEvent)

      • processKeyEvent

        protected void processKeyEvent(KeyEvent evt)
        Processes key stroke events such as mnemonics and accelerators.
        重载：
        processKeyEvent in class JComponent
        参数：
        evt - the key event to be processed
        另请参见：
        KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

      • getSelectionModel

        public SingleSelectionModel getSelectionModel()
        Returns the model object that handles single selections.
        返回：
        the selectionModel property
        另请参见：
        SingleSelectionModel

      • setSelectionModel

        public void setSelectionModel(SingleSelectionModel model)
        Sets the model object to handle single selections.
        参数：
        model - the new SingleSelectionModel
        另请参见：
        SingleSelectionModel

      • add

        public JMenuItem add(JMenuItem menuItem)
        Appends the specified menu item to the end of this menu.
        参数：
        menuItem - the JMenuItem to add
        返回：
        the JMenuItem added

      • add

        public JMenuItem add(String s)
        Creates a new menu item with the specified text and appends it to the end of this menu.
        参数：
        s - the string for the menu item to be added

      • add

        public JMenuItem add(Action a)
        Appends a new menu item to the end of the menu which dispatches the specified Action object.
        参数：
        a - the Action to add to the menu
        返回：
        the new menu item
        另请参见：
        Action

      • createActionComponent

        protected JMenuItem createActionComponent(Action a)
        Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
        参数：
        a - the Action for the menu item to be added
        返回：
        the new menu item
        从以下版本开始：
        1.3
        另请参见：
        Action

      • createActionChangeListener

        protected PropertyChangeListener createActionChangeListener(JMenuItem b)
        Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.

      • remove

        public void remove(int pos)
        Removes the component at the specified index from this popup menu.
        重载：
        remove in class Container
        参数：
        pos - the position of the item to be removed
        抛出：
        IllegalArgumentException - if the value of pos < 0, or if the value of pos is greater than the number of items
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.getComponentCount()

      • setLightWeightPopupEnabled

        public void setLightWeightPopupEnabled(boolean aFlag)
        Sets the value of the lightWeightPopupEnabled property, which by default is true. By default, when a look and feel displays a popup, it can choose to use a lightweight (all-Java) popup. Lightweight popup windows are more efficient than heavyweight (native peer) windows, but lightweight and heavyweight components do not mix well in a GUI. If your application mixes lightweight and heavyweight components, you should disable lightweight popups. Some look and feels might always use heavyweight popups, no matter what the value of this property.
        参数：
        aFlag - false to disable lightweight popups
        另请参见：
        isLightWeightPopupEnabled()

      • isLightWeightPopupEnabled

        public boolean isLightWeightPopupEnabled()
        Gets the lightWeightPopupEnabled property.
        返回：
        the value of the lightWeightPopupEnabled property
        另请参见：
        setLightWeightPopupEnabled(boolean)

      • getLabel

        public String getLabel()
        Returns the popup menu's label
        返回：
        a string containing the popup menu's label
        另请参见：
        setLabel(java.lang.String)

      • setLabel

        public void setLabel(String label)
        Sets the popup menu's label. Different look and feels may choose to display or not display this.
        参数：
        label - a string specifying the label for the popup menu
        另请参见：
        setLabel(java.lang.String)

      • addSeparator

        public void addSeparator()
        Appends a new separator at the end of the menu.

      • insert

        public void insert(Action a,
          int index)
        Inserts a menu item for the specified Action object at a given position.
        参数：
        a - the Action object to insert
        index - specifies the position at which to insert the Action, where 0 is the first
        抛出：
        IllegalArgumentException - if index < 0
        另请参见：
        Action

      • insert

        public void insert(Component component,
          int index)
        Inserts the specified component into the menu at a given position.
        参数：
        component - the Component to insert
        index - specifies the position at which to insert the component, where 0 is the first
        抛出：
        IllegalArgumentException - if index < 0

      • addPopupMenuListener

        public void addPopupMenuListener(PopupMenuListener l)
        Adds a PopupMenu listener.
        参数：
        l - the PopupMenuListener to add

      • removePopupMenuListener

        public void removePopupMenuListener(PopupMenuListener l)
        Removes a PopupMenu listener.
        参数：
        l - the PopupMenuListener to remove

      • getPopupMenuListeners

        public PopupMenuListener[] getPopupMenuListeners()
        Returns an array of all the PopupMenuListeners added to this JMenuItem with addPopupMenuListener().
        返回：
        all of the PopupMenuListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • addMenuKeyListener

        public void addMenuKeyListener(MenuKeyListener l)
        Adds a MenuKeyListener to the popup menu.
        参数：
        l - the MenuKeyListener to be added
        从以下版本开始：
        1.5

      • removeMenuKeyListener

        public void removeMenuKeyListener(MenuKeyListener l)
        Removes a MenuKeyListener from the popup menu.
        参数：
        l - the MenuKeyListener to be removed
        从以下版本开始：
        1.5

      • getMenuKeyListeners

        public MenuKeyListener[] getMenuKeyListeners()
        Returns an array of all the MenuKeyListeners added to this JPopupMenu with addMenuKeyListener().
        返回：
        all of the MenuKeyListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.5

      • firePopupMenuWillBecomeVisible

        protected void firePopupMenuWillBecomeVisible()
        Notifies PopupMenuListeners that this popup menu will become visible.

      • firePopupMenuWillBecomeInvisible

        protected void firePopupMenuWillBecomeInvisible()
        Notifies PopupMenuListeners that this popup menu will become invisible.

      • firePopupMenuCanceled

        protected void firePopupMenuCanceled()
        Notifies PopupMenuListeners that this popup menu is cancelled.

      • pack

        public void pack()
        Lays out the container so that it uses the minimum space needed to display its contents.

      • setVisible

        public void setVisible(boolean b)
        Sets the visibility of the popup menu.
        重载：
        setVisible in class JComponent
        参数：
        b - true to make the popup visible, or false to hide it
        另请参见：
        Component.isVisible(), Component.invalidate()

      • isVisible

        public boolean isVisible()
        Returns true if the popup menu is visible (currently being displayed).
        重载：
        isVisible in class Component
        返回：
        true if the component is visible, false otherwise
        另请参见：
        Component.setVisible(boolean)

      • setLocation

        public void setLocation(int x,
               int y)
        Sets the location of the upper left corner of the popup menu using x, y coordinates.
        重载：
        setLocation in class Component
        参数：
        x - the x coordinate of the popup's new position in the screen's coordinate space
        y - the y coordinate of the popup's new position in the screen's coordinate space
        另请参见：
        Component.getLocation(),
Component.setBounds(int, int, int, int),
Component.invalidate()

      • getInvoker

        public Component getInvoker()
        Returns the component which is the 'invoker' of this popup menu.
        返回：
        the Component in which the popup menu is displayed

      • setInvoker

        public void setInvoker(Component invoker)
        Sets the invoker of this popup menu -- the component in which the popup menu menu is to be displayed.
        参数：
        invoker - the Component in which the popup menu is displayed

      • show

        public void show(Component invoker,
        int x,
        int y)
        Displays the popup menu at the position x,y in the coordinate space of the component invoker.
        参数：
        invoker - the component in whose space the popup menu is to appear
        x - the x coordinate in invoker's coordinate space at which the popup menu is to be displayed
        y - the y coordinate in invoker's coordinate space at which the popup menu is to be displayed

      • getComponentAtIndex

        @Deprecated
public Component getComponentAtIndex(int i)
        Deprecated. replaced by Container.getComponent(int)
        Returns the component at the specified index.
        参数：
        i - the index of the component, where 0 is the first
        返回：
        the Component at that index

      • getComponentIndex

        public int getComponentIndex(Component c)
        Returns the index of the specified component.
        参数：
        c - the Component to find
        返回：
        the index of the component, where 0 is the first; or -1 if the component is not found

      • setPopupSize

        public void setPopupSize(Dimension d)
        Sets the size of the Popup window using a Dimension object. This is equivalent to setPreferredSize(d).
        参数：
        d - the Dimension specifying the new size of this component.

      • setPopupSize

        public void setPopupSize(int width,
                int height)
        Sets the size of the Popup window to the specified width and height. This is equivalent to setPreferredSize(new Dimension(width, height)).
        参数：
        width - the new width of the Popup in pixels
        height - the new height of the Popup in pixels

      • setSelected

        public void setSelected(Component sel)
        Sets the currently selected component, This will result in a change to the selection model.
        参数：
        sel - the Component to select

      • isBorderPainted

        public boolean isBorderPainted()
        Checks whether the border should be painted.
        返回：
        true if the border is painted, false otherwise
        另请参见：
        setBorderPainted(boolean)

      • setBorderPainted

        public void setBorderPainted(boolean b)
        Sets whether the border should be painted.
        参数：
        b - if true, the border is painted.
        另请参见：
        isBorderPainted()

      • paintBorder

        protected void paintBorder(Graphics g)
        Paints the popup menu's border if the borderPainted property is true.
        重载：
        paintBorder in class JComponent
        参数：
        g - the Graphics object
        另请参见：
        JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

      • getMargin

        public Insets getMargin()
        Returns the margin, in pixels, between the popup menu's border and its containees.
        返回：
        an Insets object containing the margin values.

      • paramString

        protected String paramString()
        Returns a string representation of this JPopupMenu. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JPopupMenu.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JPopupMenu. For JPopupMenus, the AccessibleContext takes the form of an AccessibleJPopupMenu. A new AccessibleJPopupMenu instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJPopupMenu that serves as the AccessibleContext of this JPopupMenu

      • processMouseEvent

        public void processMouseEvent(MouseEvent event,
                     MenuElement[] path,
                     MenuSelectionManager manager)
        This method is required to conform to the MenuElement interface, but it not implemented.
        指定者：
        processMouseEvent in interface MenuElement
        另请参见：
        MenuElement.processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager)

      • processKeyEvent

        public void processKeyEvent(KeyEvent e,
                   MenuElement[] path,
                   MenuSelectionManager manager)
        Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.

        Note: you do not have to forward the event to sub-components. This is done automatically by the MenuSelectionManager.

        指定者：
        processKeyEvent in interface MenuElement
        参数：
        e - a KeyEvent
        path - the MenuElement path array
        manager - the MenuSelectionManager

      • menuSelectionChanged

        public void menuSelectionChanged(boolean isIncluded)
        Messaged when the menubar selection changes to activate or deactivate this menu. This implements the javax.swing.MenuElement interface. Overrides MenuElement.menuSelectionChanged.
        指定者：
        menuSelectionChanged in interface MenuElement
        参数：
        isIncluded - true if this menu is active, false if it is not
        另请参见：
        MenuElement.menuSelectionChanged(boolean)

      • getSubElements

        public MenuElement[] getSubElements()
        Returns an array of MenuElements containing the submenu for this menu component. It will only return items conforming to the JMenuElement interface. If popup menu is null returns an empty array. This method is required to conform to the MenuElement interface.
        指定者：
        getSubElements in interface MenuElement
        返回：
        an array of MenuElement objects
        另请参见：
        MenuElement.getSubElements()

      • getComponent

        public Component getComponent()
        Returns this JPopupMenu component.
        指定者：
        getComponent in interface MenuElement
        返回：
        this JPopupMenu object
        另请参见：
        MenuElement.getComponent()

      • isPopupTrigger

        public boolean isPopupTrigger(MouseEvent e)
        Returns true if the MouseEvent is considered a popup trigger by the JPopupMenu's currently installed UI.
        返回：
        true if the mouse event is a popup trigger
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JPopupMenu.AccessibleJPopupMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPopupMenu.AccessibleJPopupMenu

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JPopupMenu.AccessibleJPopupMenu
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JPopupMenu

    protected class JPopupMenu.AccessibleJPopupMenu
extends JComponent.AccessibleJComponent
implements PropertyChangeListener
    This class implements accessibility support for the JPopupMenu class. It provides an implementation of the Java Accessibility API appropriate to popup menu user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JPopupMenu.AccessibleJPopupMenu()
      AccessibleJPopupMenu constructor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JPopupMenu.AccessibleJPopupMenu

        protected JPopupMenu.AccessibleJPopupMenu()
        AccessibleJPopupMenu constructor
        从以下版本开始：
        1.5

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/ laesres>ees>>larr")etCaeCae eteCnTJJeninnahe/ eo


JPopupMenu.Separator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JPopupMenu.Separator

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSeparator
            • javax.swing.JPopupMenu.Separator
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
    封闭类：
    JPopupMenu

    public static class JPopupMenu.Separator
extends JSeparator
    A popup menu-specific separator.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JSeparator

        JSeparator.AccessibleJSeparator

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JPopupMenu.Separator()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getUIClassID()
      Returns the name of the L&F class that renders this component.

      • 方法 - 继承于类 javax.swing.JSeparator

        getAccessibleContext, getOrientation, getUI, paramString, setOrientation, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JPopupMenu.Separator

        public JPopupMenu.Separator()

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JSeparator
        返回：
        the string "PopupMenuSeparatorUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

whiorAydAyebbyeeslooobtTngenVIes>uotcIyyfnteeyp


JProgressBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JProgressBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JProgressBar
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants

    public class JProgressBar
extends JComponent
implements SwingConstants, Accessible
    A component that visually displays the progress of some task. As the task progresses towards completion, the progress bar displays the task's percentage of completion. This percentage is typically represented visually by a rectangle which starts out empty and gradually becomes filled in as the task progresses. In addition, the progress bar can display a textual representation of this percentage.

    JProgressBar uses a BoundedRangeModel as its data model, with the value property representing the "current" state of the task, and the minimum and maximum properties representing the beginning and end points, respectively.

    To indicate that a task of unknown length is executing, you can put a progress bar into indeterminate mode. While the bar is in indeterminate mode, it animates constantly to show that work is occurring. As soon as you can determine the task's length and amount of progress, you should update the progress bar's value and switch it back to determinate mode.

    Here is an example of creating a progress bar, where task is an object (representing some piece of work) which returns information about the progress of the task:

    progressBar = new JProgressBar(0, task.getLengthOfTask());
progressBar.setValue(0);
progressBar.setStringPainted(true);
    Here is an example of querying the current state of the task, and using the returned value to update the progress bar:
    progressBar.setValue(task.getCurrent());
    Here is an example of putting a progress bar into indeterminate mode, and then switching back to determinate mode once the length of the task is known:
    progressBar = new JProgressBar();
...//when the task of (initially) unknown length begins:
progressBar.setIndeterminate(true);
...//do some work; get length of task...
progressBar.setMaximum(newLength);
progressBar.setValue(newValue);
progressBar.setIndeterminate(false);

    For complete examples and further documentation see How to Monitor Progress, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BasicProgressBarUI, BoundedRangeModel, SwingWorker

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JProgressBar.AccessibleJProgressBar
      This class implements accessibility support for the JProgressBar class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per instance since the event's only interesting property is the immutable source, which is the progress bar.
      protected ChangeListener changeListener
      Listens for change events sent by the progress bar's model, redispatching them to change-event listeners registered upon this progress bar.
      protected BoundedRangeModel model
      The object that holds the data for the progress bar.
      protected int orientation
      Whether the progress bar is horizontal or vertical.
      protected boolean paintBorder
      Whether to display a border around the progress bar.
      protected boolean paintString
      Whether to display a string of text on the progress bar.
      protected String progressString
      An optional string that can be displayed on the progress bar.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JProgressBar()
      Creates a horizontal progress bar that displays a border but no progress string.
      JProgressBar(BoundedRangeModel newModel)
      Creates a horizontal progress bar that uses the specified model to hold the progress bar's data.
      JProgressBar(int orient)
      Creates a progress bar with the specified orientation, which can be either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
      JProgressBar(int min, int max)
      Creates a horizontal progress bar with the specified minimum and maximum.
      JProgressBar(int orient, int min, int max)
      Creates a progress bar using the specified orientation, minimum, and maximum.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds the specified ChangeListener to the progress bar.
      protected ChangeListener createChangeListener()
      Subclasses that want to handle change events from the model differently can override this to return an instance of a custom ChangeListener implementation.
      protected void fireStateChanged()
      Send a ChangeEvent, whose source is this JProgressBar, to all ChangeListeners that have registered interest in ChangeEvents.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JProgressBar.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this progress bar with addChangeListener.
      int getMaximum()
      Returns the progress bar's maximum value from the BoundedRangeModel.
      int getMinimum()
      Returns the progress bar's minimum value from the BoundedRangeModel.
      BoundedRangeModel getModel()
      Returns the data model used by this progress bar.
      int getOrientation()
      Returns SwingConstants.VERTICAL or SwingConstants.HORIZONTAL, depending on the orientation of the progress bar.
      double getPercentComplete()
      Returns the percent complete for the progress bar.
      String getString()
      Returns a String representation of the current progress.
      ProgressBarUI getUI()
      Returns the look-and-feel object that renders this component.
      String getUIClassID()
      Returns the name of the look-and-feel class that renders this component.
      int getValue()
      Returns the progress bar's current value from the BoundedRangeModel.
      boolean isBorderPainted()
      Returns the borderPainted property.
      boolean isIndeterminate()
      Returns the value of the indeterminate property.
      boolean isStringPainted()
      Returns the value of the stringPainted property.
      protected void paintBorder(Graphics g)
      Paints the progress bar's border if the borderPainted property is true.
      protected String paramString()
      Returns a string representation of this JProgressBar.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the progress bar.
      void setBorderPainted(boolean b)
      Sets the borderPainted property, which is true if the progress bar should paint its border.
      void setIndeterminate(boolean newValue)
      Sets the indeterminate property of the progress bar, which determines whether the progress bar is in determinate or indeterminate mode.
      void setMaximum(int n)
      Sets the progress bar's maximum value (stored in the progress bar's data model) to n.
      void setMinimum(int n)
      Sets the progress bar's minimum value (stored in the progress bar's data model) to n.
      void setModel(BoundedRangeModel newModel)
      Sets the data model used by the JProgressBar.
      void setOrientation(int newOrientation)
      Sets the progress bar's orientation to newOrientation, which must be SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
      void setString(String s)
      Sets the value of the progress string.
      void setStringPainted(boolean b)
      Sets the value of the stringPainted property, which determines whether the progress bar should render a progress string.
      void setUI(ProgressBarUI ui)
      Sets the look-and-feel object that renders this component.
      void setValue(int n)
      Sets the progress bar's current value to n.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • orientation

        protected int orientation
        Whether the progress bar is horizontal or vertical. The default is HORIZONTAL.
        另请参见：
        setOrientation(int)

      • paintBorder

        protected boolean paintBorder
        Whether to display a border around the progress bar. The default is true.
        另请参见：
        setBorderPainted(boolean)

      • model

        protected BoundedRangeModel model
        The object that holds the data for the progress bar.
        另请参见：
        setModel(javax.swing.BoundedRangeModel)

      • progressString

        protected String progressString
        An optional string that can be displayed on the progress bar. The default is null. Setting this to a non-null value does not imply that the string will be displayed. To display the string, paintString must be true.
        另请参见：
        setString(java.lang.String), setStringPainted(boolean)

      • paintString

        protected boolean paintString
        Whether to display a string of text on the progress bar. The default is false. Setting this to true causes a textual display of the progress to be rendered on the progress bar. If the progressString is null, the percentage of completion is displayed on the progress bar. Otherwise, the progressString is rendered on the progress bar.
        另请参见：
        setStringPainted(boolean), setString(java.lang.String)

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per instance since the event's only interesting property is the immutable source, which is the progress bar. The event is lazily created the first time that an event notification is fired.
        另请参见：
        fireStateChanged()

      • changeListener

        protected ChangeListener changeListener
        Listens for change events sent by the progress bar's model, redispatching them to change-event listeners registered upon this progress bar.
        另请参见：
        createChangeListener()

    • 构造方法详细信息

      • JProgressBar

        public JProgressBar()
        Creates a horizontal progress bar that displays a border but no progress string. The initial and minimum values are 0, and the maximum is 100.
        另请参见：
        setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

      • JProgressBar

        public JProgressBar(int orient)
        Creates a progress bar with the specified orientation, which can be either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL. By default, a border is painted but a progress string is not. The initial and minimum values are 0, and the maximum is 100.
        参数：
        orient - the desired orientation of the progress bar
        抛出：
        IllegalArgumentException - if orient is an illegal value
        另请参见：
        setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

      • JProgressBar

        public JProgressBar(int min,
            int max)
        Creates a horizontal progress bar with the specified minimum and maximum. Sets the initial value of the progress bar to the specified minimum. By default, a border is painted but a progress string is not.

        The BoundedRangeModel that holds the progress bar's data handles any issues that may arise from improperly setting the minimum, initial, and maximum values on the progress bar. See the BoundedRangeModel documentation for details.

        参数：
        min - the minimum value of the progress bar
        max - the maximum value of the progress bar
        另请参见：
        BoundedRangeModel, setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

      • JProgressBar

        public JProgressBar(int orient,
            int min,
            int max)
        Creates a progress bar using the specified orientation, minimum, and maximum. By default, a border is painted but a progress string is not. Sets the initial value of the progress bar to the specified minimum.

        The BoundedRangeModel that holds the progress bar's data handles any issues that may arise from improperly setting the minimum, initial, and maximum values on the progress bar. See the BoundedRangeModel documentation for details.

        参数：
        orient - the desired orientation of the progress bar
        min - the minimum value of the progress bar
        max - the maximum value of the progress bar
        抛出：
        IllegalArgumentException - if orient is an illegal value
        另请参见：
        BoundedRangeModel, setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

      • JProgressBar

        public JProgressBar(BoundedRangeModel newModel)
        Creates a horizontal progress bar that uses the specified model to hold the progress bar's data. By default, a border is painted but a progress string is not.
        参数：
        newModel - the data model for the progress bar
        另请参见：
        setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

    • 方法详细信息

      • getOrientation

        public int getOrientation()
        Returns SwingConstants.VERTICAL or SwingConstants.HORIZONTAL, depending on the orientation of the progress bar. The default orientation is SwingConstants.HORIZONTAL.
        返回：
        HORIZONTAL or VERTICAL
        另请参见：
        setOrientation(int)

      • setOrientation

        public void setOrientation(int newOrientation)
        Sets the progress bar's orientation to newOrientation, which must be SwingConstants.VERTICAL or SwingConstants.HORIZONTAL. The default orientation is SwingConstants.HORIZONTAL.
        参数：
        newOrientation - HORIZONTAL or VERTICAL
        抛出：
        IllegalArgumentException - if newOrientation is an illegal value
        另请参见：
        getOrientation()

      • isStringPainted

        public boolean isStringPainted()
        Returns the value of the stringPainted property.
        返回：
        the value of the stringPainted property
        另请参见：
        setStringPainted(boolean), setString(java.lang.String)

      • setStringPainted

        public void setStringPainted(boolean b)
        Sets the value of the stringPainted property, which determines whether the progress bar should render a progress string. The default is false, meaning no string is painted. Some look and feels might not support progress strings or might support them only when the progress bar is in determinate mode.
        参数：
        b - true if the progress bar should render a string
        另请参见：
        isStringPainted(), setString(java.lang.String)

      • getString

        public String getString()
        Returns a String representation of the current progress. By default, this returns a simple percentage String based on the value returned from getPercentComplete. An example would be the "42%". You can change this by calling setString.
        返回：
        the value of the progress string, or a simple percentage string if the progress string is null
        另请参见：
        setString(java.lang.String)

      • setString

        public void setString(String s)
        Sets the value of the progress string. By default, this string is null, implying the built-in behavior of using a simple percent string. If you have provided a custom progress string and want to revert to the built-in behavior, set the string back to null.

        The progress string is painted only if the isStringPainted method returns true.

        参数：
        s - the value of the progress string
        另请参见：
        getString(), setStringPainted(boolean), isStringPainted()

      • getPercentComplete

        public double getPercentComplete()
        Returns the percent complete for the progress bar. Note that this number is between 0.0 and 1.0.
        返回：
        the percent complete for this progress bar

      • isBorderPainted

        public boolean isBorderPainted()
        Returns the borderPainted property.
        返回：
        the value of the borderPainted property
        另请参见：
        setBorderPainted(boolean)

      • setBorderPainted

        public void setBorderPainted(boolean b)
        Sets the borderPainted property, which is true if the progress bar should paint its border. The default value for this property is true. Some look and feels might not implement painted borders; they will ignore this property.
        参数：
        b - true if the progress bar should paint its border; otherwise, false
        另请参见：
        isBorderPainted()

      • paintBorder

        protected void paintBorder(Graphics g)
        Paints the progress bar's border if the borderPainted property is true.
        重载：
        paintBorder in class JComponent
        参数：
        g - the Graphics context within which to paint the border
        另请参见：
        JComponent.paint(java.awt.Graphics),
JComponent.setBorder(javax.swing.border.Border),
isBorderPainted(),
setBorderPainted(boolean)

      • getUI

        public ProgressBarUI getUI()
        Returns the look-and-feel object that renders this component.
        返回：
        the ProgressBarUI object that renders this component

      • setUI

        public void setUI(ProgressBarUI ui)
        Sets the look-and-feel object that renders this component.
        参数：
        ui - a ProgressBarUI object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the look-and-feel class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ProgressBarUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createChangeListener

        protected ChangeListener createChangeListener()
        Subclasses that want to handle change events from the model differently can override this to return an instance of a custom ChangeListener implementation. The default ChangeListener simply calls the fireStateChanged method to forward ChangeEvents to the ChangeListeners that have been added directly to the progress bar.
        另请参见：
        changeListener, fireStateChanged(), ChangeListener, BoundedRangeModel

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds the specified ChangeListener to the progress bar.
        参数：
        l - the ChangeListener to add

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the progress bar.
        参数：
        l - the ChangeListener to remove

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this progress bar with addChangeListener.
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Send a ChangeEvent, whose source is this JProgressBar, to all ChangeListeners that have registered interest in ChangeEvents. This method is called each time a ChangeEvent is received from the model.

        The event instance is created if necessary, and stored in changeEvent.

        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), EventListenerList

      • getModel

        public BoundedRangeModel getModel()
        Returns the data model used by this progress bar.
        返回：
        the BoundedRangeModel currently in use
        另请参见：
        setModel(javax.swing.BoundedRangeModel), BoundedRangeModel

      • setModel

        public void setModel(BoundedRangeModel newModel)
        Sets the data model used by the JProgressBar. Note that the BoundedRangeModel's extent is not used, and is set to 0.
        参数：
        newModel - the BoundedRangeModel to use

      • getValue

        public int getValue()
        Returns the progress bar's current value from the BoundedRangeModel. The value is always between the minimum and maximum values, inclusive.
        返回：
        the current value of the progress bar
        另请参见：
        setValue(int), BoundedRangeModel.getValue()

      • getMinimum

        public int getMinimum()
        Returns the progress bar's minimum value from the BoundedRangeModel.
        返回：
        the progress bar's minimum value
        另请参见：
        setMinimum(int), BoundedRangeModel.getMinimum()

      • getMaximum

        public int getMaximum()
        Returns the progress bar's maximum value from the BoundedRangeModel.
        返回：
        the progress bar's maximum value
        另请参见：
        setMaximum(int), BoundedRangeModel.getMaximum()

      • setValue

        public void setValue(int n)
        Sets the progress bar's current value to n. This method forwards the new value to the model.

        The data model (an instance of BoundedRangeModel) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the new value is different from the previous value, all change listeners are notified.

        参数：
        n - the new value
        另请参见：
        getValue(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setValue(int)

      • setMinimum

        public void setMinimum(int n)
        Sets the progress bar's minimum value (stored in the progress bar's data model) to n.

        The data model (a BoundedRangeModel instance) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the minimum value is different from the previous minimum, all change listeners are notified.

        参数：
        n - the new minimum
        另请参见：
        getMinimum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMinimum(int)

      • setMaximum

        public void setMaximum(int n)
        Sets the progress bar's maximum value (stored in the progress bar's data model) to n.

        The underlying BoundedRangeModel handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the maximum value is different from the previous maximum, all change listeners are notified.

        参数：
        n - the new maximum
        另请参见：
        getMaximum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMaximum(int)

      • setIndeterminate

        public void setIndeterminate(boolean newValue)
        Sets the indeterminate property of the progress bar, which determines whether the progress bar is in determinate or indeterminate mode. An indeterminate progress bar continuously displays animation indicating that an operation of unknown length is occurring. By default, this property is false. Some look and feels might not support indeterminate progress bars; they will ignore this property.

        See How to Monitor Progress for examples of using indeterminate progress bars.

        参数：
        newValue - true if the progress bar should change to indeterminate mode; false if it should revert to normal.
        从以下版本开始：
        1.4
        另请参见：
        isIndeterminate(), BasicProgressBarUI

      • isIndeterminate

        public boolean isIndeterminate()
        Returns the value of the indeterminate property.
        返回：
        the value of the indeterminate property
        从以下版本开始：
        1.4
        另请参见：
        setIndeterminate(boolean)

      • paramString

        protected String paramString()
        Returns a string representation of this JProgressBar. This method is intended to be used only for debugging purposes. The content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JProgressBar

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JProgressBar. For progress bars, the AccessibleContext takes the form of an AccessibleJProgressBar. A new AccessibleJProgressBar instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJProgressBar that serves as the AccessibleContext of this JProgressBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JProgressBar.AccessibleJProgressBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JProgressBar.AccessibleJProgressBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JProgressBar.AccessibleJProgressBar
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JProgressBar

    protected class JProgressBar.AccessibleJProgressBar
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JProgressBar class. It provides an implementation of the Java Accessibility API appropriate to progress bar user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JProgressBar.AccessibleJProgressBar()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Gets the accessible value of this object.
      Number getMaximumAccessibleValue()
      Gets the maximum accessible value of this object.
      Number getMinimumAccessibleValue()
      Gets the minimum accessible value of this object.
      boolean setCurrentAccessibleValue(Number n)
      Sets the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JProgressBar.AccessibleJProgressBar

        protected JProgressBar.AccessibleJProgressBar()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, returns this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Gets the accessible value of this object.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        the current value of this object
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Sets the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        true if the value was set
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Gets the minimum accessible value of this object.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        the minimum value of this object
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Gets the maximum accessible value of this object.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        the maximum value of this object
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>fiu#shish.tth..oa""feh,/a./a..t/iasb)((nau/>Eseo


JRadioButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRadioButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JToggleButton
              • javax.swing.JRadioButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants

    public class JRadioButton
extends JToggleButton
implements Accessible
    An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user. Used with a ButtonGroup object to create a group of buttons in which only one button at a time can be selected. (Create a ButtonGroup object and use its add method to include the JRadioButton objects in the group.)
    Note: The ButtonGroup object is a logical grouping -- not a physical grouping. To create a button panel, you should still create a JPanel or similar container-object and add a Border to it to set it off from surrounding components.

    Buttons can be configured, and to some degree controlled, by Actions. Using an Action with a button has many benefits beyond directly configuring a button. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    See How to Use Buttons, Check Boxes, and Radio Buttons in The Java Tutorial for further documentation.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    ButtonGroup, JCheckBox

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JRadioButton.AccessibleJRadioButton
      This class implements accessibility support for the JRadioButton class.

      • Nested classes/interfaces inherited from class javax.swing.JToggleButton

        JToggleButton.AccessibleJToggleButton, JToggleButton.ToggleButtonModel

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JRadioButton()
      Creates an initially unselected radio button with no set text.
      JRadioButton(Action a)
      Creates a radiobutton where properties are taken from the Action supplied.
      JRadioButton(Icon icon)
      Creates an initially unselected radio button with the specified image but no text.
      JRadioButton(Icon icon, boolean selected)
      Creates a radio button with the specified image and selection state, but no text.
      JRadioButton(String text)
      Creates an unselected radio button with the specified text.
      JRadioButton(String text, boolean selected)
      Creates a radio button with the specified text and selection state.
      JRadioButton(String text, Icon icon)
      Creates a radio button that has the specified text and image, and that is initially unselected.
      JRadioButton(String text, Icon icon, boolean selected)
      Creates a radio button that has the specified text, image, and selection state.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JRadioButton.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JRadioButton.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JRadioButton

        public JRadioButton()
        Creates an initially unselected radio button with no set text.

      • JRadioButton

        public JRadioButton(Icon icon)
        Creates an initially unselected radio button with the specified image but no text.
        参数：
        icon - the image that the button should display

      • JRadioButton

        public JRadioButton(Action a)
        Creates a radiobutton where properties are taken from the Action supplied.
        从以下版本开始：
        1.3

      • JRadioButton

        public JRadioButton(Icon icon,
            boolean selected)
        Creates a radio button with the specified image and selection state, but no text.
        参数：
        icon - the image that the button should display
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

      • JRadioButton

        public JRadioButton(String text)
        Creates an unselected radio button with the specified text.
        参数：
        text - the string displayed on the radio button

      • JRadioButton

        public JRadioButton(String text,
            boolean selected)
        Creates a radio button with the specified text and selection state.
        参数：
        text - the string displayed on the radio button
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

      • JRadioButton

        public JRadioButton(String text,
            Icon icon)
        Creates a radio button that has the specified text and image, and that is initially unselected.
        参数：
        text - the string displayed on the radio button
        icon - the image that the button should display

      • JRadioButton

        public JRadioButton(String text,
            Icon icon,
            boolean selected)
        Creates a radio button that has the specified text, image, and selection state.
        参数：
        text - the string displayed on the radio button
        icon - the image that the button should display

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JToggleButton
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JToggleButton
        返回：
        String "RadioButtonUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • paramString

        protected String paramString()
        Returns a string representation of this JRadioButton. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JToggleButton
        返回：
        a string representation of this JRadioButton.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JRadioButton. For JRadioButtons, the AccessibleContext takes the form of an AccessibleJRadioButton. A new AccessibleJRadioButton instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JToggleButton
        返回：
        an AccessibleJRadioButton that serves as the AccessibleContext of this JRadioButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


JRadioButton.AccessibleJRadioButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRadioButton.AccessibleJRadioButton

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JToggleButton.AccessibleJToggleButton
                • javax.swing.JRadioButton.AccessibleJRadioButton
  • 所有已实现的接口：
    ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
    封闭类：
    JRadioButton

    protected class JRadioButton.AccessibleJRadioButton
extends JToggleButton.AccessibleJToggleButton
    This class implements accessibility support for the JRadioButton class. It provides an implementation of the Java Accessibility API appropriate to radio button user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JRadioButton.AccessibleJRadioButton()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JToggleButton.AccessibleJToggleButton

        itemStateChanged

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JRadioButton.AccessibleJRadioButton

        protected JRadioButton.AccessibleJRadioButton()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JToggleButton.AccessibleJToggleButton
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/#.a/>Ma>MnaaMnnAp##ekoett>enctFeC"j.aerrh.tCpnCK


JRadioButtonMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRadioButtonMenuItem

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JMenuItem
              • javax.swing.JRadioButtonMenuItem
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants

    public class JRadioButtonMenuItem
extends JMenuItem
implements Accessible
    An implementation of a radio button menu item. A JRadioButtonMenuItem is a menu item that is part of a group of menu items in which only one item in the group can be selected. The selected item displays its selected state. Selecting it causes any other selected item to switch to the unselected state. To control the selected state of a group of radio button menu items, use a ButtonGroup object.

    Menu items can be configured, and to some degree controlled, by Actions. Using an Action with a menu item has many benefits beyond directly configuring a menu item. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    For further documentation and examples see How to Use Menus, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    ButtonGroup

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      This class implements accessibility support for the JRadioButtonMenuItem class.

      • Nested classes/interfaces inherited from class javax.swing.JMenuItem

        JMenuItem.AccessibleJMenuItem

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JRadioButtonMenuItem()
      Creates a JRadioButtonMenuItem with no set text or icon.
      JRadioButtonMenuItem(Action a)
      Creates a radio button menu item whose properties are taken from the Action supplied.
      JRadioButtonMenuItem(Icon icon)
      Creates a JRadioButtonMenuItem with an icon.
      JRadioButtonMenuItem(Icon icon, boolean selected)
      Creates a radio button menu item with the specified image and selection state, but no text.
      JRadioButtonMenuItem(String text)
      Creates a JRadioButtonMenuItem with text.
      JRadioButtonMenuItem(String text, boolean selected)
      Creates a radio button menu item with the specified text and selection state.
      JRadioButtonMenuItem(String text, Icon icon)
      Creates a radio button menu item with the specified text and Icon.
      JRadioButtonMenuItem(String text, Icon icon, boolean selected)
      Creates a radio button menu item that has the specified text, image, and selection state.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JRadioButtonMenuItem.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JRadioButtonMenuItem.

      • 方法 - 继承于类 javax.swing.JMenuItem

        actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getComponent, getMenuDragMouseListeners, getMenuKeyListeners, getSubElements, init, isArmed, menuSelectionChanged, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setAccelerator, setArmed, setEnabled, setModel, setUI, updateUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem()
        Creates a JRadioButtonMenuItem with no set text or icon.

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(Icon icon)
        Creates a JRadioButtonMenuItem with an icon.
        参数：
        icon - the Icon to display on the JRadioButtonMenuItem

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(String text)
        Creates a JRadioButtonMenuItem with text.
        参数：
        text - the text of the JRadioButtonMenuItem

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(Action a)
        Creates a radio button menu item whose properties are taken from the Action supplied.
        参数：
        a - the Action on which to base the radio button menu item
        从以下版本开始：
        1.3

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(String text,
                    Icon icon)
        Creates a radio button menu item with the specified text and Icon.
        参数：
        text - the text of the JRadioButtonMenuItem
        icon - the icon to display on the JRadioButtonMenuItem

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(String text,
                    boolean selected)
        Creates a radio button menu item with the specified text and selection state.
        参数：
        text - the text of the CheckBoxMenuItem
        selected - the selected state of the CheckBoxMenuItem

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(Icon icon,
                    boolean selected)
        Creates a radio button menu item with the specified image and selection state, but no text.
        参数：
        icon - the image that the button should display
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

      • JRadioButtonMenuItem

        public JRadioButtonMenuItem(String text,
                    Icon icon,
                    boolean selected)
        Creates a radio button menu item that has the specified text, image, and selection state. All other constructors defer to this one.
        参数：
        text - the string displayed on the radio button
        icon - the image that the button should display

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JMenuItem
        返回：
        the string "RadioButtonMenuItemUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • paramString

        protected String paramString()
        Returns a string representation of this JRadioButtonMenuItem. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JMenuItem
        返回：
        a string representation of this JRadioButtonMenuItem

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JRadioButtonMenuItem. For JRadioButtonMenuItems, the AccessibleContext takes the form of an AccessibleJRadioButtonMenuItem. A new AccessibleJRadioButtonMenuItem instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JMenuItem
        返回：
        an AccessibleJRadioButtonMenuItem that serves as the AccessibleContext of this JRadioButtonMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JMenuItem.AccessibleJMenuItem
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
    封闭类：
    JRadioButtonMenuItem

    protected class JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
extends JMenuItem.AccessibleJMenuItem
    This class implements accessibility support for the JRadioButtonMenuItem class. It provides an implementation of the Java Accessibility API appropriate to JRadioButtonMenuItem user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JMenuItem.AccessibleJMenuItem

        stateChanged

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

        protected JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JMenuItem.AccessibleJMenuItem
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hatCwnainavxxavv.rnnavj.i.sim/np.tlb#uh..tO>KSkK=


JRootPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRootPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JRootPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JRootPane
extends JComponent
implements Accessible
    A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame. For task-oriented information on functionality provided by root panes see How to Use Root Panes, a section in The Java Tutorial.

    The following image shows the relationships between the classes that use root panes.

    The following text describes this graphic.

    The "heavyweight" components (those that delegate to a peer, or native component on the host system) are shown with a darker, heavier box. The four heavyweight JFC/Swing containers (JFrame, JDialog, JWindow, and JApplet) are shown in relation to the AWT classes they extend. These four components are the only heavyweight containers in the Swing library. The lightweight container JInternalFrame is also shown. All five of these JFC/Swing containers implement the RootPaneContainer interface, and they all delegate their operations to a JRootPane (shown with a little "handle" on top).
    Note: The JComponent method getRootPane can be used to obtain the JRootPane that contains a given component.
    The following text describes this graphic.
    The diagram at right shows the structure of a JRootPane. A JRootpane is made up of a glassPane, an optional menuBar, and a contentPane. (The JLayeredPane manages the menuBar and the contentPane.) The glassPane sits over the top of everything, where it is in a position to intercept mouse movements. Since the glassPane (like the contentPane) can be an arbitrary component, it is also possible to set up the glassPane for drawing. Lines and images on the glassPane can then range over the frames underneath without being limited by their boundaries.

    Although the menuBar component is optional, the layeredPane, contentPane, and glassPane always exist. Attempting to set them to null generates an exception.

    To add components to the JRootPane (other than the optional menu bar), you add the object to the contentPane of the JRootPane, like this:

           rootPane.getContentPane().add(child);
    The same principle holds true for setting layout managers, removing components, listing children, etc. All these methods are invoked on the contentPane instead of on the JRootPane.
    Note: The default layout manager for the contentPane is a BorderLayout manager. However, the JRootPane uses a custom LayoutManager. So, when you want to change the layout manager for the components you added to a JRootPane, be sure to use code like this:
        rootPane.getContentPane().setLayout(new BoxLayout());
    If a JMenuBar component is set on the JRootPane, it is positioned along the upper edge of the frame. The contentPane is adjusted in location and size to fill the remaining area. (The JMenuBar and the contentPane are added to the layeredPane component at the JLayeredPane.FRAME_CONTENT_LAYER layer.)

    The layeredPane is the parent of all children in the JRootPane -- both as the direct parent of the menu and the grandparent of all components added to the contentPane. It is an instance of JLayeredPane, which provides the ability to add components at several layers. This capability is very useful when working with menu popups, dialog boxes, and dragging -- situations in which you need to place a component on top of all other components in the pane.

    The glassPane sits on top of all other components in the JRootPane. That provides a convenient place to draw above all other components, and makes it possible to intercept mouse events, which is useful both for dragging and for drawing. Developers can use setVisible on the glassPane to control when the glassPane displays over the other children. By default the glassPane is not visible.

    The custom LayoutManager used by JRootPane ensures that:

    1. The glassPane fills the entire viewable area of the JRootPane (bounds - insets).
    2. The layeredPane fills the entire viewable area of the JRootPane. (bounds - insets)
    3. The menuBar is positioned at the upper edge of the layeredPane.
    4. The contentPane fills the entire viewable area, minus the menuBar, if present.
    Any other views in the JRootPane view hierarchy are ignored.

    If you replace the LayoutManager of the JRootPane, you are responsible for managing all of these views. So ordinarily you will want to be sure that you change the layout manager for the contentPane rather than for the JRootPane itself!

    The painting architecture of Swing requires an opaque JComponent to exist in the containment hieararchy above all other components. This is typically provided by way of the content pane. If you replace the content pane, it is recommended that you make the content pane opaque by way of setOpaque(true). Additionally, if the content pane overrides paintComponent, it will need to completely fill in the background in an opaque color in paintComponent.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JLayeredPane, JMenuBar, JWindow, JFrame, JDialog, JApplet, JInternalFrame, JComponent, BoxLayout, Mixing Heavy and Light Components

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JRootPane.AccessibleJRootPane
      This class implements accessibility support for the JRootPane class.
      protected class  JRootPane.RootLayout
      A custom layout manager that is responsible for the layout of layeredPane, glassPane, and menuBar.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int COLOR_CHOOSER_DIALOG
      Constant used for the windowDecorationStyle property.
      protected Container contentPane
      The content pane.
      protected JButton defaultButton
      The button that gets activated when the pane has the focus and a UI-specific action like pressing the Enter key occurs.
      protected javax.swing.JRootPane.DefaultAction defaultPressAction
      Deprecated.
      As of Java 2 platform v1.3.
      protected javax.swing.JRootPane.DefaultAction defaultReleaseAction
      Deprecated.
      As of Java 2 platform v1.3.
      static int ERROR_DIALOG
      Constant used for the windowDecorationStyle property.
      static int FILE_CHOOSER_DIALOG
      Constant used for the windowDecorationStyle property.
      static int FRAME
      Constant used for the windowDecorationStyle property.
      protected Component glassPane
      The glass pane that overlays the menu bar and content pane, so it can intercept mouse movements and such.
      static int INFORMATION_DIALOG
      Constant used for the windowDecorationStyle property.
      protected JLayeredPane layeredPane
      The layered pane that manages the menu bar and content pane.
      protected JMenuBar menuBar
      The menu bar.
      static int NONE
      Constant used for the windowDecorationStyle property.
      static int PLAIN_DIALOG
      Constant used for the windowDecorationStyle property.
      static int QUESTION_DIALOG
      Constant used for the windowDecorationStyle property.
      static int WARNING_DIALOG
      Constant used for the windowDecorationStyle property.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JRootPane()
      Creates a JRootPane, setting up its glassPane, layeredPane, and contentPane.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Overridden to enforce the position of the glass component as the zero child.
      void addNotify()
      Notifies this component that it now has a parent component.
      protected Container createContentPane()
      Called by the constructor methods to create the default contentPane.
      protected Component createGlassPane()
      Called by the constructor methods to create the default glassPane.
      protected JLayeredPane createLayeredPane()
      Called by the constructor methods to create the default layeredPane.
      protected LayoutManager createRootLayout()
      Called by the constructor methods to create the default layoutManager.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JRootPane.
      Container getContentPane()
      Returns the content pane -- the container that holds the components parented by the root pane.
      JButton getDefaultButton()
      Returns the value of the defaultButton property.
      Component getGlassPane()
      Returns the current glass pane for this JRootPane.
      JMenuBar getJMenuBar()
      Returns the menu bar from the layered pane.
      JLayeredPane getLayeredPane()
      Gets the layered pane used by the root pane.
      JMenuBar getMenuBar()
      Deprecated.
      As of Swing version 1.0.3 replaced by getJMenuBar().
      RootPaneUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      int getWindowDecorationStyle()
      Returns a constant identifying the type of Window decorations the JRootPane is providing.
      boolean isOptimizedDrawingEnabled()
      The glassPane and contentPane have the same bounds, which means JRootPane does not tiles its children and this should return false.
      boolean isValidateRoot()
      If a descendant of this JRootPane calls revalidate, validate from here on down.
      protected String paramString()
      Returns a string representation of this JRootPane.
      void removeNotify()
      Notifies this component that it no longer has a parent component.
      void setContentPane(Container content)
      Sets the content pane -- the container that holds the components parented by the root pane.
      void setDefaultButton(JButton defaultButton)
      Sets the defaultButton property, which determines the current default button for this JRootPane.
      void setDoubleBuffered(boolean aFlag)
      Sets whether this component should use a buffer to paint.
      void setGlassPane(Component glass)
      Sets a specified Component to be the glass pane for this root pane.
      void setJMenuBar(JMenuBar menu)
      Adds or changes the menu bar used in the layered pane.
      void setLayeredPane(JLayeredPane layered)
      Sets the layered pane for the root pane.
      void setMenuBar(JMenuBar menu)
      Deprecated.
      As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar menu).
      void setUI(RootPaneUI ui)
      Sets the L&F object that renders this component.
      void setWindowDecorationStyle(int windowDecorationStyle)
      Sets the type of Window decorations (such as borders, widgets for closing a Window, title ...) the JRootPane should provide.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final int NONE
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should not provide any sort of Window decorations.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FRAME

        public static final int FRAME
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Frame.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • PLAIN_DIALOG

        public static final int PLAIN_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • INFORMATION_DIALOG

        public static final int INFORMATION_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to display an informational message.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • ERROR_DIALOG

        public static final int ERROR_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to display an error message.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • COLOR_CHOOSER_DIALOG

        public static final int COLOR_CHOOSER_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to display a JColorChooser.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • FILE_CHOOSER_DIALOG

        public static final int FILE_CHOOSER_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to display a JFileChooser.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • QUESTION_DIALOG

        public static final int QUESTION_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to present a question to the user.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • WARNING_DIALOG

        public static final int WARNING_DIALOG
        Constant used for the windowDecorationStyle property. Indicates that the JRootPane should provide decorations appropriate for a Dialog used to display a warning message.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • menuBar

        protected JMenuBar menuBar
        The menu bar.

      • contentPane

        protected Container contentPane
        The content pane.

      • layeredPane

        protected JLayeredPane layeredPane
        The layered pane that manages the menu bar and content pane.

      • glassPane

        protected Component glassPane
        The glass pane that overlays the menu bar and content pane, so it can intercept mouse movements and such.

      • defaultButton

        protected JButton defaultButton
        The button that gets activated when the pane has the focus and a UI-specific action like pressing the Enter key occurs.

      • defaultPressAction

        @Deprecated
protected javax.swing.JRootPane.DefaultAction defaultPressAction
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this unusable field is no longer used. To override the default button you should replace the Action in the JRootPane's ActionMap. Please refer to the key bindings specification for further details.
        另请参见：
        defaultButton

      • defaultReleaseAction

        @Deprecated
protected javax.swing.JRootPane.DefaultAction defaultReleaseAction
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this unusable field is no longer used. To override the default button you should replace the Action in the JRootPane's ActionMap. Please refer to the key bindings specification for further details.
        另请参见：
        defaultButton

    • 构造方法详细信息

      • JRootPane

        public JRootPane()
        Creates a JRootPane, setting up its glassPane, layeredPane, and contentPane.

    • 方法详细信息

      • setDoubleBuffered

        public void setDoubleBuffered(boolean aFlag)
        Sets whether this component should use a buffer to paint. If set to true, all the drawing from this component will be done in an offscreen painting buffer. The offscreen painting buffer will the be copied onto the screen. If a Component is buffered and one of its ancestor is also buffered, the ancestor buffer will be used.
        重载：
        setDoubleBuffered in class JComponent
        参数：
        aFlag - if true, set this component to be double buffered
        从以下版本开始：
        1.6

      • getWindowDecorationStyle

        public int getWindowDecorationStyle()
        Returns a constant identifying the type of Window decorations the JRootPane is providing.
        返回：
        One of NONE, FRAME, PLAIN_DIALOG, INFORMATION_DIALOG, ERROR_DIALOG, COLOR_CHOOSER_DIALOG, FILE_CHOOSER_DIALOG, QUESTION_DIALOG or WARNING_DIALOG.
        从以下版本开始：
        1.4
        另请参见：
        setWindowDecorationStyle(int)

      • setWindowDecorationStyle

        public void setWindowDecorationStyle(int windowDecorationStyle)
        Sets the type of Window decorations (such as borders, widgets for closing a Window, title ...) the JRootPane should provide. The default is to provide no Window decorations (NONE).

        This is only a hint, and some look and feels may not support this. This is a bound property.

        参数：
        windowDecorationStyle - Constant identifying Window decorations to provide.
        抛出：
        IllegalArgumentException - if style is not one of: NONE, FRAME, PLAIN_DIALOG, INFORMATION_DIALOG, ERROR_DIALOG, COLOR_CHOOSER_DIALOG, FILE_CHOOSER_DIALOG, QUESTION_DIALOG, or WARNING_DIALOG.
        从以下版本开始：
        1.4
        另请参见：
        JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
LookAndFeel.getSupportsWindowDecorations()

      • getUI

        public RootPaneUI getUI()
        Returns the L&F object that renders this component.
        返回：
        LabelUI object
        从以下版本开始：
        1.3

      • setUI

        public void setUI(RootPaneUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the LabelUI L&F object
        从以下版本开始：
        1.3
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "RootPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createLayeredPane

        protected JLayeredPane createLayeredPane()
        Called by the constructor methods to create the default layeredPane. Bt default it creates a new JLayeredPane.
        返回：
        the default layeredPane

      • createContentPane

        protected Container createContentPane()
        Called by the constructor methods to create the default contentPane. By default this method creates a new JComponent add sets a BorderLayout as its LayoutManager.
        返回：
        the default contentPane

      • createGlassPane

        protected Component createGlassPane()
        Called by the constructor methods to create the default glassPane. By default this method creates a new JComponent with visibility set to false.
        返回：
        the default glassPane

      • createRootLayout

        protected LayoutManager createRootLayout()
        Called by the constructor methods to create the default layoutManager.
        返回：
        the default layoutManager.

      • setJMenuBar

        public void setJMenuBar(JMenuBar menu)
        Adds or changes the menu bar used in the layered pane.
        参数：
        menu - the JMenuBar to add

      • setMenuBar

        @Deprecated
public void setMenuBar(JMenuBar menu)
        Deprecated. As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar menu).
        Specifies the menu bar value.
        参数：
        menu - the JMenuBar to add.

      • getJMenuBar

        public JMenuBar getJMenuBar()
        Returns the menu bar from the layered pane.
        返回：
        the JMenuBar used in the pane

      • getMenuBar

        @Deprecated
public JMenuBar getMenuBar()
        Deprecated. As of Swing version 1.0.3 replaced by getJMenuBar().
        Returns the menu bar value.
        返回：
        the JMenuBar used in the pane

      • setContentPane

        public void setContentPane(Container content)
        Sets the content pane -- the container that holds the components parented by the root pane.

        Swing's painting architecture requires an opaque JComponent in the containment hiearchy. This is typically provided by the content pane. If you replace the content pane it is recommended you replace it with an opaque JComponent.

        参数：
        content - the Container to use for component-contents
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null

      • getContentPane

        public Container getContentPane()
        Returns the content pane -- the container that holds the components parented by the root pane.
        返回：
        the Container that holds the component-contents

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layered)
        Sets the layered pane for the root pane. The layered pane typically holds a content pane and an optional JMenuBar.
        参数：
        layered - the JLayeredPane to use
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Gets the layered pane used by the root pane. The layered pane typically holds a content pane and an optional JMenuBar.
        返回：
        the JLayeredPane currently in use

      • setGlassPane

        public void setGlassPane(Component glass)
        Sets a specified Component to be the glass pane for this root pane. The glass pane should normally be a lightweight, transparent component, because it will be made visible when ever the root pane needs to grab input events.

        The new glass pane's visibility is changed to match that of the current glass pane. An implication of this is that care must be taken when you want to replace the glass pane and make it visible. Either of the following will work:

           root.setGlassPane(newGlassPane);
   newGlassPane.setVisible(true);
        or:
           root.getGlassPane().setVisible(true);
   root.setGlassPane(newGlassPane);
        参数：
        glass - the Component to use as the glass pane for this JRootPane
        抛出：
        NullPointerException - if the glass parameter is null

      • getGlassPane

        public Component getGlassPane()
        Returns the current glass pane for this JRootPane.
        返回：
        the current glass pane
        另请参见：
        setGlassPane(java.awt.Component)

      • isValidateRoot

        public boolean isValidateRoot()
        If a descendant of this JRootPane calls revalidate, validate from here on down.

        Deferred requests to layout a component and its descendents again. For example, calls to revalidate, are pushed upwards to either a JRootPane or a JScrollPane because both classes override isValidateRoot to return true.

        重载：
        isValidateRoot in class JComponent
        返回：
        true
        另请参见：
        JComponent.isValidateRoot(), Container.isValidateRoot()

      • isOptimizedDrawingEnabled

        public boolean isOptimizedDrawingEnabled()
        The glassPane and contentPane have the same bounds, which means JRootPane does not tiles its children and this should return false. On the other hand, the glassPane is normally not visible, and so this can return true if the glassPane isn't visible. Therefore, the return value here depends upon the visiblity of the glassPane.
        重载：
        isOptimizedDrawingEnabled in class JComponent
        返回：
        true if this component's children don't overlap

      • addNotify

        public void addNotify()
        Notifies this component that it now has a parent component. When this method is invoked, the chain of parent components is set up with KeyboardAction event listeners. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        addNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • removeNotify

        public void removeNotify()
        Notifies this component that it no longer has a parent component. When this method is invoked, any KeyboardActions set up in the the chain of parent components are removed. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        removeNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • setDefaultButton

        public void setDefaultButton(JButton defaultButton)
        Sets the defaultButton property, which determines the current default button for this JRootPane. The default button is the button which will be activated when a UI-defined activation event (typically the Enter key) occurs in the root pane regardless of whether or not the button has keyboard focus (unless there is another component within the root pane which consumes the activation event, such as a JTextPane). For default activation to work, the button must be an enabled descendent of the root pane when activation occurs. To remove a default button from this root pane, set this property to null.
        参数：
        defaultButton - the JButton which is to be the default button
        另请参见：
        JButton.isDefaultButton()

      • getDefaultButton

        public JButton getDefaultButton()
        Returns the value of the defaultButton property.
        返回：
        the JButton which is currently the default button
        另请参见：
        setDefaultButton(javax.swing.JButton)

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Overridden to enforce the position of the glass component as the zero child.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • paramString

        protected String paramString()
        Returns a string representation of this JRootPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JRootPane.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JRootPane. For root panes, the AccessibleContext takes the form of an AccessibleJRootPane. A new AccessibleJRootPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJRootPane that serves as the AccessibleContext of this JRootPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JRootPane.AccessibleJRootPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRootPane.AccessibleJRootPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JRootPane.AccessibleJRootPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JRootPane

    protected class JRootPane.AccessibleJRootPane
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JRootPane class. It provides an implementation of the Java Accessibility API appropriate to root pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JRootPane.AccessibleJRootPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JRootPane.AccessibleJRootPane

        protected JRootPane.AccessibleJRootPane()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children of the object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        getAccessibleChildrenCount()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

voejtnmenmeLLmeeohttC.ngevneesL)o"j.aerr


JRootPane.RootLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JRootPane.RootLayout

  • java.lang.Object
    • javax.swing.JRootPane.RootLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2, Serializable
    封闭类：
    JRootPane

    protected class JRootPane.RootLayout
extends Object
implements LayoutManager2, Serializable
    A custom layout manager that is responsible for the layout of layeredPane, glassPane, and menuBar.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JRootPane.RootLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component comp, Object constraints)
      Adds the specified component to the layout, using the specified constraint object.
      void addLayoutComponent(String name, Component comp)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      float getLayoutAlignmentX(Container target)
      Returns the alignment along the x axis.
      float getLayoutAlignmentY(Container target)
      Returns the alignment along the y axis.
      void invalidateLayout(Container target)
      Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
      void layoutContainer(Container parent)
      Instructs the layout manager to perform the layout for the specified container.
      Dimension maximumLayoutSize(Container target)
      Returns the maximum amount of space the layout can use.
      Dimension minimumLayoutSize(Container parent)
      Returns the minimum amount of space the layout needs.
      Dimension preferredLayoutSize(Container parent)
      Returns the amount of space the layout would like to have.
      void removeLayoutComponent(Component comp)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JRootPane.RootLayout

        protected JRootPane.RootLayout()

    • 方法详细信息

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        Returns the amount of space the layout would like to have.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the Container for which this layout manager is being used
        返回：
        a Dimension object containing the layout's preferred size
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        Returns the minimum amount of space the layout needs.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the Container for which this layout manager is being used
        返回：
        a Dimension object containing the layout's minimum size
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container target)
        Returns the maximum amount of space the layout can use.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        参数：
        target - the Container for which this layout manager is being used
        返回：
        a Dimension object containing the layout's maximum size
        另请参见：
        Component.getMaximumSize(), LayoutManager

      • layoutContainer

        public void layoutContainer(Container parent)
        Instructs the layout manager to perform the layout for the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the Container for which this layout manager is being used

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component comp)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        comp - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component comp)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        comp - the component to be removed

      • addLayoutComponent

        public void addLayoutComponent(Component comp,
                      Object constraints)
        从接口复制的描述： LayoutManager2
        Adds the specified component to the layout, using the specified constraint object.
        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        comp - the component to be added
        constraints - where/how the component is added to the layout.

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container target)
        从接口复制的描述： LayoutManager2
        Returns the alignment along the x axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentX in interface LayoutManager2

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container target)
        从接口复制的描述： LayoutManager2
        Returns the alignment along the y axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentY in interface LayoutManager2

      • invalidateLayout

        public void invalidateLayout(Container target)
        从接口复制的描述： LayoutManager2
        Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
        指定者：
        invalidateLayout in interface LayoutManager2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=cshd>od>nMM>nn>


JScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JScrollBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JScrollBar
  • 所有已实现的接口：
    Adjustable, ImageObserver, MenuContainer, Serializable, Accessible
    直接已知子类：
    JScrollPane.ScrollBar

    public class JScrollBar
extends JComponent
implements Adjustable, Accessible
    An implementation of a scrollbar. The user positions the knob in the scrollbar to determine the contents of the viewing area. The program typically adjusts the display so that the end of the scrollbar represents the end of the displayable contents, or 100% of the contents. The start of the scrollbar is the beginning of the displayable contents, or 0%. The position of the knob within those bounds then translates to the corresponding percentage of the displayable contents.

    Typically, as the position of the knob in the scrollbar changes a corresponding change is made to the position of the JViewport on the underlying view, changing the contents of the JViewport.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JScrollPane

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JScrollBar.AccessibleJScrollBar
      This class implements accessibility support for the JScrollBar class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | blockIncrement
      protected BoundedRangeModel model
      The model that represents the scrollbar's minimum, maximum, extent (aka "visibleAmount") and current value.
      protected int | orientation
      protected int | unitIncrement

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.Adjustable

        HORIZONTAL, NO_ORIENTATION, VERTICAL

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JScrollBar()
      Creates a vertical scrollbar with the following initial values:
      JScrollBar(int orientation)
      Creates a scrollbar with the specified orientation and the following initial values:
      JScrollBar(int orientation, int value, int extent, int min, int max)
      Creates a scrollbar with the specified orientation, value, extent, minimum, and maximum.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAdjustmentListener(AdjustmentListener l)
      Adds an AdjustmentListener.
      protected void fireAdjustmentValueChanged(int id, int type, int value)
      Notify listeners that the scrollbar's model has changed.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JScrollBar.
      AdjustmentListener[] getAdjustmentListeners()
      Returns an array of all the AdjustmentListeners added to this JScrollBar with addAdjustmentListener().
      int getBlockIncrement()
      For backwards compatibility with java.awt.Scrollbar.
      int getBlockIncrement(int direction)
      Returns the amount to change the scrollbar's value by, given a block (usually "page") up/down request.
      int getMaximum()
      The maximum value of the scrollbar is maximum - extent.
      Dimension getMaximumSize()
      The scrollbar is flexible along it's scrolling axis and rigid along the other axis.
      int getMinimum()
      Returns the minimum value supported by the scrollbar (usually zero).
      Dimension getMinimumSize()
      The scrollbar is flexible along it's scrolling axis and rigid along the other axis.
      BoundedRangeModel getModel()
      Returns data model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
      int getOrientation()
      Returns the component's orientation (horizontal or vertical).
      ScrollBarUI getUI()
      Returns the delegate that implements the look and feel for this component.
      String getUIClassID()
      Returns the name of the LookAndFeel class for this component.
      int getUnitIncrement()
      For backwards compatibility with java.awt.Scrollbar.
      int getUnitIncrement(int direction)
      Returns the amount to change the scrollbar's value by, given a unit up/down request.
      int getValue()
      Returns the scrollbar's value.
      boolean getValueIsAdjusting()
      True if the scrollbar knob is being dragged.
      int getVisibleAmount()
      Returns the scrollbar's extent, aka its "visibleAmount".
      protected String paramString()
      Returns a string representation of this JScrollBar.
      void removeAdjustmentListener(AdjustmentListener l)
      Removes an AdjustmentEvent listener.
      void setBlockIncrement(int blockIncrement)
      Sets the blockIncrement property.
      void setEnabled(boolean x)
      Enables the component so that the knob position can be changed.
      void setMaximum(int maximum)
      Sets the model's maximum property.
      void setMinimum(int minimum)
      Sets the model's minimum property.
      void setModel(BoundedRangeModel newModel)
      Sets the model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
      void setOrientation(int orientation)
      Set the scrollbar's orientation to either VERTICAL or HORIZONTAL.
      void setUI(ScrollBarUI ui)
      Sets the L&F object that renders this component.
      void setUnitIncrement(int unitIncrement)
      Sets the unitIncrement property.
      void setValue(int value)
      Sets the scrollbar's value.
      void setValueIsAdjusting(boolean b)
      Sets the model's valueIsAdjusting property.
      void setValues(int newValue, int newExtent, int newMin, int newMax)
      Sets the four BoundedRangeModel properties after forcing the arguments to obey the usual constraints:
      void setVisibleAmount(int extent)
      Set the model's extent property.
      void updateUI()
      Overrides JComponent.updateUI.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • model

        protected BoundedRangeModel model
        The model that represents the scrollbar's minimum, maximum, extent (aka "visibleAmount") and current value.
        另请参见：
        setModel(javax.swing.BoundedRangeModel)

      • orientation

        protected int orientation
        另请参见：
        setOrientation(int)

      • unitIncrement

        protected int unitIncrement
        另请参见：
        setUnitIncrement(int)

      • blockIncrement

        protected int blockIncrement
        另请参见：
        setBlockIncrement(int)

    • 构造方法详细信息

      • JScrollBar

        public JScrollBar(int orientation,
          int value,
          int extent,
          int min,
          int max)
        Creates a scrollbar with the specified orientation, value, extent, minimum, and maximum. The "extent" is the size of the viewable area. It is also known as the "visible amount".

        Note: Use setBlockIncrement to set the block increment to a size slightly smaller than the view's extent. That way, when the user jumps the knob to an adjacent position, one or two lines of the original contents remain in view.

        抛出：
        IllegalArgumentException - if orientation is not one of VERTICAL, HORIZONTAL
        另请参见：
        setOrientation(int), setValue(int), setVisibleAmount(int), setMinimum(int), setMaximum(int)

      • JScrollBar

        public JScrollBar(int orientation)
        Creates a scrollbar with the specified orientation and the following initial values:
         minimum = 0
 maximum = 100
 value = 0
 extent = 10

      • JScrollBar

        public JScrollBar()
        Creates a vertical scrollbar with the following initial values:
         minimum = 0
 maximum = 100
 value = 0
 extent = 10

    • 方法详细信息

      • setUI

        public void setUI(ScrollBarUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ScrollBarUI L&F object
        从以下版本开始：
        1.4
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getUI

        public ScrollBarUI getUI()
        Returns the delegate that implements the look and feel for this component.
        另请参见：
        JComponent.setUI(javax.swing.plaf.ComponentUI)

      • updateUI

        public void updateUI()
        Overrides JComponent.updateUI.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the LookAndFeel class for this component.
        重载：
        getUIClassID in class JComponent
        返回：
        "ScrollBarUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getOrientation

        public int getOrientation()
        Returns the component's orientation (horizontal or vertical).
        指定者：
        getOrientation in interface Adjustable
        返回：
        VERTICAL or HORIZONTAL
        另请参见：
        setOrientation(int), Adjustable.getOrientation()

      • setOrientation

        public void setOrientation(int orientation)
        Set the scrollbar's orientation to either VERTICAL or HORIZONTAL.
        抛出：
        IllegalArgumentException - if orientation is not one of VERTICAL, HORIZONTAL
        另请参见：
        getOrientation()

      • getModel

        public BoundedRangeModel getModel()
        Returns data model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
        另请参见：
        setModel(javax.swing.BoundedRangeModel)

      • setModel

        public void setModel(BoundedRangeModel newModel)
        Sets the model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
        另请参见：
        getModel()

      • getUnitIncrement

        public int getUnitIncrement(int direction)
        Returns the amount to change the scrollbar's value by, given a unit up/down request. A ScrollBarUI implementation typically calls this method when the user clicks on a scrollbar up/down arrow and uses the result to update the scrollbar's value. Subclasses my override this method to compute a value, e.g. the change required to scroll up or down one (variable height) line text or one row in a table.

        The JScrollPane component creates scrollbars (by default) that override this method and delegate to the viewports Scrollable view, if it has one. The Scrollable interface provides a more specialized version of this method.

        参数：
        direction - is -1 or 1 for up/down respectively
        返回：
        the value of the unitIncrement property
        另请参见：
        setUnitIncrement(int), setValue(int), Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

      • setUnitIncrement

        public void setUnitIncrement(int unitIncrement)
        Sets the unitIncrement property.

        Note, that if the argument is equal to the value of Integer.MIN_VALUE, the most look and feels will not provide the scrolling to the right/down.

        指定者：
        setUnitIncrement in interface Adjustable
        参数：
        unitIncrement - the unit increment
        另请参见：
        getUnitIncrement(int)

      • getBlockIncrement

        public int getBlockIncrement(int direction)
        Returns the amount to change the scrollbar's value by, given a block (usually "page") up/down request. A ScrollBarUI implementation typically calls this method when the user clicks above or below the scrollbar "knob" to change the value up or down by large amount. Subclasses my override this method to compute a value, e.g. the change required to scroll up or down one paragraph in a text document.

        The JScrollPane component creates scrollbars (by default) that override this method and delegate to the viewports Scrollable view, if it has one. The Scrollable interface provides a more specialized version of this method.

        参数：
        direction - is -1 or 1 for up/down respectively
        返回：
        the value of the blockIncrement property
        另请参见：
        setBlockIncrement(int), setValue(int), Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

      • setBlockIncrement

        public void setBlockIncrement(int blockIncrement)
        Sets the blockIncrement property.

        Note, that if the argument is equal to the value of Integer.MIN_VALUE, the most look and feels will not provide the scrolling to the right/down.

        指定者：
        setBlockIncrement in interface Adjustable
        参数：
        blockIncrement - the block increment
        另请参见：
        getBlockIncrement()

      • getUnitIncrement

        public int getUnitIncrement()
        For backwards compatibility with java.awt.Scrollbar.
        指定者：
        getUnitIncrement in interface Adjustable
        返回：
        the unit value increment for the adjustable object
        另请参见：
        Adjustable.getUnitIncrement(), getUnitIncrement(int)

      • getBlockIncrement

        public int getBlockIncrement()
        For backwards compatibility with java.awt.Scrollbar.
        指定者：
        getBlockIncrement in interface Adjustable
        返回：
        the block value increment for the adjustable object
        另请参见：
        Adjustable.getBlockIncrement(), getBlockIncrement(int)

      • getValue

        public int getValue()
        Returns the scrollbar's value.
        指定者：
        getValue in interface Adjustable
        返回：
        the model's value property
        另请参见：
        setValue(int)

      • setValue

        public void setValue(int value)
        Sets the scrollbar's value. This method just forwards the value to the model.
        指定者：
        setValue in interface Adjustable
        参数：
        value - the current value, between minimum and maximum - visibleAmount
        另请参见：
        getValue(), BoundedRangeModel.setValue(int)

      • getVisibleAmount

        public int getVisibleAmount()
        Returns the scrollbar's extent, aka its "visibleAmount". In many scrollbar look and feel implementations the size of the scrollbar "knob" or "thumb" is proportional to the extent.
        指定者：
        getVisibleAmount in interface Adjustable
        返回：
        the value of the model's extent property
        另请参见：
        setVisibleAmount(int)

      • setVisibleAmount

        public void setVisibleAmount(int extent)
        Set the model's extent property.
        指定者：
        setVisibleAmount in interface Adjustable
        参数：
        extent - the length of the indicator
        另请参见：
        getVisibleAmount(), BoundedRangeModel.setExtent(int)

      • getMinimum

        public int getMinimum()
        Returns the minimum value supported by the scrollbar (usually zero).
        指定者：
        getMinimum in interface Adjustable
        返回：
        the value of the model's minimum property
        另请参见：
        setMinimum(int)

      • setMinimum

        public void setMinimum(int minimum)
        Sets the model's minimum property.
        指定者：
        setMinimum in interface Adjustable
        参数：
        minimum - the minimum value
        另请参见：
        getMinimum(), BoundedRangeModel.setMinimum(int)

      • getMaximum

        public int getMaximum()
        The maximum value of the scrollbar is maximum - extent.
        指定者：
        getMaximum in interface Adjustable
        返回：
        the value of the model's maximum property
        另请参见：
        setMaximum(int)

      • setMaximum

        public void setMaximum(int maximum)
        Sets the model's maximum property. Note that the scrollbar's value can only be set to maximum - extent.
        指定者：
        setMaximum in interface Adjustable
        参数：
        maximum - the maximum value
        另请参见：
        getMaximum(), BoundedRangeModel.setMaximum(int)

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        True if the scrollbar knob is being dragged.
        返回：
        the value of the model's valueIsAdjusting property
        另请参见：
        setValueIsAdjusting(boolean)

      • setValueIsAdjusting

        public void setValueIsAdjusting(boolean b)
        Sets the model's valueIsAdjusting property. Scrollbar look and feel implementations should set this property to true when a knob drag begins, and to false when the drag ends. The scrollbar model will not generate ChangeEvents while valueIsAdjusting is true.
        另请参见：
        getValueIsAdjusting(), BoundedRangeModel.setValueIsAdjusting(boolean)

      • setValues

        public void setValues(int newValue,
             int newExtent,
             int newMin,
             int newMax)
        Sets the four BoundedRangeModel properties after forcing the arguments to obey the usual constraints:
         minimum <= value <= value+extent <= maximum

        另请参见：
        BoundedRangeModel.setRangeProperties(int, int, int, int, boolean), setValue(int), setVisibleAmount(int), setMinimum(int), setMaximum(int)

      • addAdjustmentListener

        public void addAdjustmentListener(AdjustmentListener l)
        Adds an AdjustmentListener. Adjustment listeners are notified each time the scrollbar's model changes. Adjustment events are provided for backwards compatibility with java.awt.Scrollbar.

        Note that the AdjustmentEvents type property will always have a placeholder value of AdjustmentEvent.TRACK because all changes to a BoundedRangeModels value are considered equivalent. To change the value of a BoundedRangeModel one just sets its value property, i.e. model.setValue(123). No information about the origin of the change, e.g. it's a block decrement, is provided. We don't try fabricate the origin of the change here.

        指定者：
        addAdjustmentListener in interface Adjustable
        参数：
        l - the AdjustmentLister to add
        另请参见：
        removeAdjustmentListener(java.awt.event.AdjustmentListener), BoundedRangeModel.addChangeListener(javax.swing.event.ChangeListener)

      • removeAdjustmentListener

        public void removeAdjustmentListener(AdjustmentListener l)
        Removes an AdjustmentEvent listener.
        指定者：
        removeAdjustmentListener in interface Adjustable
        参数：
        l - the AdjustmentLister to remove
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener)

      • getAdjustmentListeners

        public AdjustmentListener[] getAdjustmentListeners()
        Returns an array of all the AdjustmentListeners added to this JScrollBar with addAdjustmentListener().
        返回：
        all of the AdjustmentListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireAdjustmentValueChanged

        protected void fireAdjustmentValueChanged(int id,
                              int type,
                              int value)
        Notify listeners that the scrollbar's model has changed.
        另请参见：
        addAdjustmentListener(java.awt.event.AdjustmentListener), EventListenerList

      • getMinimumSize

        public Dimension getMinimumSize()
        The scrollbar is flexible along it's scrolling axis and rigid along the other axis.
        重载：
        getMinimumSize in class JComponent
        返回：
        the value of the minimumSize property
        另请参见：
        JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

      • getMaximumSize

        public Dimension getMaximumSize()
        The scrollbar is flexible along it's scrolling axis and rigid along the other axis.
        重载：
        getMaximumSize in class JComponent
        返回：
        the value of the maximumSize property
        另请参见：
        JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

      • setEnabled

        public void setEnabled(boolean x)
        Enables the component so that the knob position can be changed. When the disabled, the knob position cannot be changed.
        重载：
        setEnabled in class JComponent
        参数：
        x - a boolean value, where true enables the component and false disables it
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • paramString

        protected String paramString()
        Returns a string representation of this JScrollBar. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JScrollBar.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JScrollBar. For JScrollBar, the AccessibleContext takes the form of an AccessibleJScrollBar. A new AccessibleJScrollBar instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJScrollBar that serves as the AccessibleContext of this JScrollBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JScrollBar.AccessibleJScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JScrollBar.AccessibleJScrollBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JScrollBar.AccessibleJScrollBar
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JScrollBar

    protected class JScrollBar.AccessibleJScrollBar
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JScrollBar class. It provides an implementation of the Java Accessibility API appropriate to scroll bar user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JScrollBar.AccessibleJScrollBar()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Get the state set of this object.
      AccessibleValue getAccessibleValue()
      Get the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Get the accessible value of this object.
      Number getMaximumAccessibleValue()
      Get the maximum accessible value of this object.
      Number getMinimumAccessibleValue()
      Get the minimum accessible value of this object.
      boolean setCurrentAccessibleValue(Number n)
      Set the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JScrollBar.AccessibleJScrollBar

        protected JScrollBar.AccessibleJScrollBar()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Get the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Get the accessible value of this object.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        The current value of this object.
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Set the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        True if the value was set.
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Get the minimum accessible value of this object.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        The minimum value of this object.
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Get the maximum accessible value of this object.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        The maximum value of this object.
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>s e/acce


JScrollPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JScrollPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JScrollPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ScrollPaneConstants

    public class JScrollPane
extends JComponent
implements ScrollPaneConstants, Accessible
    Provides a scrollable view of a lightweight component. A JScrollPane manages a viewport, optional vertical and horizontal scroll bars, and optional row and column heading viewports. You can find task-oriented documentation of JScrollPane in How to Use Scroll Panes, a section in The Java Tutorial. Note that JScrollPane does not support heavyweight components.

    The following text describes this image.

    The JViewport provides a window, or "viewport" onto a data source -- for example, a text file. That data source is the "scrollable client" (aka data model) displayed by the JViewport view. A JScrollPane basically consists of JScrollBars, a JViewport, and the wiring between them, as shown in the diagram at right.

    In addition to the scroll bars and viewport, a JScrollPane can have a column header and a row header. Each of these is a JViewport object that you specify with setRowHeaderView, and setColumnHeaderView. The column header viewport automatically scrolls left and right, tracking the left-right scrolling of the main viewport. (It never scrolls vertically, however.) The row header acts in a similar fashion.

    Where two scroll bars meet, the row header meets the column header, or a scroll bar meets one of the headers, both components stop short of the corner, leaving a rectangular space which is, by default, empty. These spaces can potentially exist in any number of the four corners. In the previous diagram, the top right space is present and identified by the label "corner component".

    Any number of these empty spaces can be replaced by using the setCorner method to add a component to a particular corner. (Note: The same component cannot be added to multiple corners.) This is useful if there's some extra decoration or function you'd like to add to the scroll pane. The size of each corner component is entirely determined by the size of the headers and/or scroll bars that surround it.

    A corner component will only be visible if there is an empty space in that corner for it to exist in. For example, consider a component set into the top right corner of a scroll pane with a column header. If the scroll pane's vertical scrollbar is not present, perhaps because the view component hasn't grown large enough to require it, then the corner component will not be shown (since there is no empty space in that corner created by the meeting of the header and vertical scroll bar). Forcing the scroll bar to always be shown, using setVerticalScrollBarPolicy(VERTICAL_SCROLLBAR_ALWAYS), will ensure that the space for the corner component always exists.

    To add a border around the main viewport, you can use setViewportBorder. (Of course, you can also add a border around the whole scroll pane using setBorder.)

    A common operation to want to do is to set the background color that will be used if the main viewport view is smaller than the viewport, or is not opaque. This can be accomplished by setting the background color of the viewport, via scrollPane.getViewport().setBackground(). The reason for setting the color of the viewport and not the scrollpane is that by default JViewport is opaque which, among other things, means it will completely fill in its background using its background color. Therefore when JScrollPane draws its background the viewport will usually draw over it.

    By default JScrollPane uses ScrollPaneLayout to handle the layout of its child Components. ScrollPaneLayout determines the size to make the viewport view in one of two ways:

    1. If the view implements Scrollable a combination of getPreferredScrollableViewportSize, getScrollableTracksViewportWidth and getScrollableTracksViewportHeightis used, otherwise
    2. getPreferredSize is used.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JScrollBar,
JViewport,
ScrollPaneLayout,
Scrollable,
Component.getPreferredSize(),
setViewportView(java.awt.Component),
setRowHeaderView(java.awt.Component),
setColumnHeaderView(java.awt.Component),
setCorner(java.lang.String, java.awt.Component),
setViewportBorder(javax.swing.border.Border)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JScrollPane.AccessibleJScrollPane
      This class implements accessibility support for the JScrollPane class.
      protected class  JScrollPane.ScrollBar
      By default JScrollPane creates scrollbars that are instances of this class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JViewport columnHeader
      The column header child.
      protected JScrollBar horizontalScrollBar
      The scrollpane's horizontal scrollbar child.
      protected int horizontalScrollBarPolicy
      The display policy for the horizontal scrollbar.
      protected Component lowerLeft
      The component to display in the lower left corner.
      protected Component lowerRight
      The component to display in the lower right corner.
      protected JViewport rowHeader
      The row header child.
      protected Component upperLeft
      The component to display in the upper left corner.
      protected Component upperRight
      The component to display in the upper right corner.
      protected JScrollBar verticalScrollBar
      The scrollpane's vertical scrollbar child.
      protected int verticalScrollBarPolicy
      The display policy for the vertical scrollbar.
      protected JViewport viewport
      The scrollpane's viewport child.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JScrollPane()
      Creates an empty (no viewport view) JScrollPane where both horizontal and vertical scrollbars appear when needed.
      JScrollPane(Component view)
      Creates a JScrollPane that displays the contents of the specified component, where both horizontal and vertical scrollbars appear whenever the component's contents are larger than the view.
      JScrollPane(Component view, int vsbPolicy, int hsbPolicy)
      Creates a JScrollPane that displays the view component in a viewport whose view position can be controlled with a pair of scrollbars.
      JScrollPane(int vsbPolicy, int hsbPolicy)
      Creates an empty (no viewport view) JScrollPane with specified scrollbar policies.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JScrollBar createHorizontalScrollBar()
      Returns a JScrollPane.ScrollBar by default.
      JScrollBar createVerticalScrollBar()
      Returns a JScrollPane.ScrollBar by default.
      protected JViewport createViewport()
      Returns a new JViewport by default.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JScrollPane.
      JViewport getColumnHeader()
      Returns the column header.
      Component getCorner(String key)
      Returns the component at the specified corner.
      JScrollBar getHorizontalScrollBar()
      Returns the horizontal scroll bar that controls the viewport's horizontal view position.
      int getHorizontalScrollBarPolicy()
      Returns the horizontal scroll bar policy value.
      JViewport getRowHeader()
      Returns the row header.
      ScrollPaneUI getUI()
      Returns the look and feel (L&F) object that renders this component.
      String getUIClassID()
      Returns the suffix used to construct the name of the L&F class used to render this component.
      JScrollBar getVerticalScrollBar()
      Returns the vertical scroll bar that controls the viewports vertical view position.
      int getVerticalScrollBarPolicy()
      Returns the vertical scroll bar policy value.
      JViewport getViewport()
      Returns the current JViewport.
      Border getViewportBorder()
      Returns the Border object that surrounds the viewport.
      Rectangle getViewportBorderBounds()
      Returns the bounds of the viewport's border.
      boolean isValidateRoot()
      Overridden to return true so that any calls to revalidate on any descendants of this JScrollPane will cause the entire tree beginning with this JScrollPane to be validated.
      boolean isWheelScrollingEnabled()
      Indicates whether or not scrolling will take place in response to the mouse wheel.
      protected String paramString()
      Returns a string representation of this JScrollPane.
      void setColumnHeader(JViewport columnHeader)
      Removes the old columnHeader, if it exists; if the new columnHeader isn't null, syncs the x coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.
      void setColumnHeaderView(Component view)
      Creates a column-header viewport if necessary, sets its view, and then adds the column-header viewport to the scrollpane.
      void setComponentOrientation(ComponentOrientation co)
      Sets the orientation for the vertical and horizontal scrollbars as determined by the ComponentOrientation argument.
      void setCorner(String key, Component corner)
      Adds a child that will appear in one of the scroll panes corners, if there's room.
      void setHorizontalScrollBar(JScrollBar horizontalScrollBar)
      Adds the scrollbar that controls the viewport's horizontal view position to the scrollpane.
      void setHorizontalScrollBarPolicy(int policy)
      Determines when the horizontal scrollbar appears in the scrollpane.
      void setLayout(LayoutManager layout)
      Sets the layout manager for this JScrollPane.
      void setRowHeader(JViewport rowHeader)
      Removes the old rowHeader, if it exists; if the new rowHeader isn't null, syncs the y coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.
      void setRowHeaderView(Component view)
      Creates a row-header viewport if necessary, sets its view and then adds the row-header viewport to the scrollpane.
      void setUI(ScrollPaneUI ui)
      Sets the ScrollPaneUI object that provides the look and feel (L&F) for this component.
      void setVerticalScrollBar(JScrollBar verticalScrollBar)
      Adds the scrollbar that controls the viewports vertical view position to the scrollpane.
      void setVerticalScrollBarPolicy(int policy)
      Determines when the vertical scrollbar appears in the scrollpane.
      void setViewport(JViewport viewport)
      Removes the old viewport (if there is one); forces the viewPosition of the new viewport to be in the +x,+y quadrant; syncs up the row and column headers (if there are any) with the new viewport; and finally syncs the scrollbars and headers with the new viewport.
      void setViewportBorder(Border viewportBorder)
      Adds a border around the viewport.
      void setViewportView(Component view)
      Creates a viewport if necessary and then sets its view.
      void setWheelScrollingEnabled(boolean handleWheel)
      Enables/disables scrolling in response to movement of the mouse wheel.
      void updateUI()
      Replaces the current ScrollPaneUI object with a version from the current default look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • verticalScrollBarPolicy

        protected int verticalScrollBarPolicy
        The display policy for the vertical scrollbar. The default is ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED.
        另请参见：
        setVerticalScrollBarPolicy(int)

      • horizontalScrollBarPolicy

        protected int horizontalScrollBarPolicy
        The display policy for the horizontal scrollbar. The default is ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED.
        另请参见：
        setHorizontalScrollBarPolicy(int)

      • viewport

        protected JViewport viewport
        The scrollpane's viewport child. Default is an empty JViewport.
        另请参见：
        setViewport(javax.swing.JViewport)

      • verticalScrollBar

        protected JScrollBar verticalScrollBar
        The scrollpane's vertical scrollbar child. Default is a JScrollBar.
        另请参见：
        setVerticalScrollBar(javax.swing.JScrollBar)

      • horizontalScrollBar

        protected JScrollBar horizontalScrollBar
        The scrollpane's horizontal scrollbar child. Default is a JScrollBar.
        另请参见：
        setHorizontalScrollBar(javax.swing.JScrollBar)

      • rowHeader

        protected JViewport rowHeader
        The row header child. Default is null.
        另请参见：
        setRowHeader(javax.swing.JViewport)

      • columnHeader

        protected JViewport columnHeader
        The column header child. Default is null.
        另请参见：
        setColumnHeader(javax.swing.JViewport)

      • lowerLeft

        protected Component lowerLeft
        The component to display in the lower left corner. Default is null.
        另请参见：
        setCorner(java.lang.String, java.awt.Component)

      • lowerRight

        protected Component lowerRight
        The component to display in the lower right corner. Default is null.
        另请参见：
        setCorner(java.lang.String, java.awt.Component)

      • upperLeft

        protected Component upperLeft
        The component to display in the upper left corner. Default is null.
        另请参见：
        setCorner(java.lang.String, java.awt.Component)

      • upperRight

        protected Component upperRight
        The component to display in the upper right corner. Default is null.
        另请参见：
        setCorner(java.lang.String, java.awt.Component)

    • 构造方法详细信息

      • JScrollPane

        public JScrollPane(Component view,
           int vsbPolicy,
           int hsbPolicy)
        Creates a JScrollPane that displays the view component in a viewport whose view position can be controlled with a pair of scrollbars. The scrollbar policies specify when the scrollbars are displayed, For example, if vsbPolicy is VERTICAL_SCROLLBAR_AS_NEEDED then the vertical scrollbar only appears if the view doesn't fit vertically. The available policy settings are listed at setVerticalScrollBarPolicy(int) and setHorizontalScrollBarPolicy(int).
        参数：
        view - the component to display in the scrollpanes viewport
        vsbPolicy - an integer that specifies the vertical scrollbar policy
        hsbPolicy - an integer that specifies the horizontal scrollbar policy
        另请参见：
        setViewportView(java.awt.Component)

      • JScrollPane

        public JScrollPane(Component view)
        Creates a JScrollPane that displays the contents of the specified component, where both horizontal and vertical scrollbars appear whenever the component's contents are larger than the view.
        参数：
        view - the component to display in the scrollpane's viewport
        另请参见：
        setViewportView(java.awt.Component)

      • JScrollPane

        public JScrollPane(int vsbPolicy,
           int hsbPolicy)
        Creates an empty (no viewport view) JScrollPane with specified scrollbar policies. The available policy settings are listed at setVerticalScrollBarPolicy(int) and setHorizontalScrollBarPolicy(int).
        参数：
        vsbPolicy - an integer that specifies the vertical scrollbar policy
        hsbPolicy - an integer that specifies the horizontal scrollbar policy
        另请参见：
        setViewportView(java.awt.Component)

      • JScrollPane

        public JScrollPane()
        Creates an empty (no viewport view) JScrollPane where both horizontal and vertical scrollbars appear when needed.

    • 方法详细信息

      • getUI

        public ScrollPaneUI getUI()
        Returns the look and feel (L&F) object that renders this component.
        返回：
        the ScrollPaneUI object that renders this component
        另请参见：
        setUI(javax.swing.plaf.ScrollPaneUI)

      • setUI

        public void setUI(ScrollPaneUI ui)
        Sets the ScrollPaneUI object that provides the look and feel (L&F) for this component.
        参数：
        ui - the ScrollPaneUI L&F object
        另请参见：
        getUI()

      • updateUI

        public void updateUI()
        Replaces the current ScrollPaneUI object with a version from the current default look and feel. To be called when the default look and feel changes.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI(), UIManager.getUI(javax.swing.JComponent)

      • getUIClassID

        public String getUIClassID()
        Returns the suffix used to construct the name of the L&F class used to render this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ScrollPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setLayout

        public void setLayout(LayoutManager layout)
        Sets the layout manager for this JScrollPane. This method overrides setLayout in java.awt.Container to ensure that only LayoutManagers which are subclasses of ScrollPaneLayout can be used in a JScrollPane. If layout is non-null, this will invoke syncWithScrollPane on it.
        重载：
        setLayout in class Container
        参数：
        layout - the specified layout manager
        抛出：
        ClassCastException - if layout is not a ScrollPaneLayout
        另请参见：
        Container.getLayout(), Container.setLayout(java.awt.LayoutManager)

      • isValidateRoot

        public boolean isValidateRoot()
        Overridden to return true so that any calls to revalidate on any descendants of this JScrollPane will cause the entire tree beginning with this JScrollPane to be validated.
        重载：
        isValidateRoot in class JComponent
        返回：
        true
        另请参见：
        Container.validate(),
JComponent.revalidate(),
JComponent.isValidateRoot(),
Container.isValidateRoot()

      • getVerticalScrollBarPolicy

        public int getVerticalScrollBarPolicy()
        Returns the vertical scroll bar policy value.
        返回：
        the verticalScrollBarPolicy property
        另请参见：
        setVerticalScrollBarPolicy(int)

      • setVerticalScrollBarPolicy

        public void setVerticalScrollBarPolicy(int policy)
        Determines when the vertical scrollbar appears in the scrollpane. Legal values are:
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_NEVER
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_ALWAYS
        参数：
        policy - one of the three values listed above
        抛出：
        IllegalArgumentException - if policy is not one of the legal values shown above
        另请参见：
        getVerticalScrollBarPolicy()

      • getHorizontalScrollBarPolicy

        public int getHorizontalScrollBarPolicy()
        Returns the horizontal scroll bar policy value.
        返回：
        the horizontalScrollBarPolicy property
        另请参见：
        setHorizontalScrollBarPolicy(int)

      • setHorizontalScrollBarPolicy

        public void setHorizontalScrollBarPolicy(int policy)
        Determines when the horizontal scrollbar appears in the scrollpane. The options are:
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_NEVER
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_ALWAYS
        参数：
        policy - one of the three values listed above
        抛出：
        IllegalArgumentException - if policy is not one of the legal values shown above
        另请参见：
        getHorizontalScrollBarPolicy()

      • getViewportBorder

        public Border getViewportBorder()
        Returns the Border object that surrounds the viewport.
        返回：
        the viewportBorder property
        另请参见：
        setViewportBorder(javax.swing.border.Border)

      • setViewportBorder

        public void setViewportBorder(Border viewportBorder)
        Adds a border around the viewport. Note that the border isn't set on the viewport directly, JViewport doesn't support the JComponent border property. Similarly setting the JScrollPanes viewport doesn't affect the viewportBorder property.

        The default value of this property is computed by the look and feel implementation.

        参数：
        viewportBorder - the border to be added
        另请参见：
        getViewportBorder(), setViewport(javax.swing.JViewport)

      • getViewportBorderBounds

        public Rectangle getViewportBorderBounds()
        Returns the bounds of the viewport's border.
        返回：
        a Rectangle object specifying the viewport border

      • createHorizontalScrollBar

        public JScrollBar createHorizontalScrollBar()
        Returns a JScrollPane.ScrollBar by default. Subclasses may override this method to force ScrollPaneUI implementations to use a JScrollBar subclass. Used by ScrollPaneUI implementations to create the horizontal scrollbar.
        返回：
        a JScrollBar with a horizontal orientation
        另请参见：
        JScrollBar

      • getHorizontalScrollBar

        public JScrollBar getHorizontalScrollBar()
        Returns the horizontal scroll bar that controls the viewport's horizontal view position.
        返回：
        the horizontalScrollBar property
        另请参见：
        setHorizontalScrollBar(javax.swing.JScrollBar)

      • setHorizontalScrollBar

        public void setHorizontalScrollBar(JScrollBar horizontalScrollBar)
        Adds the scrollbar that controls the viewport's horizontal view position to the scrollpane. This is usually unnecessary, as JScrollPane creates horizontal and vertical scrollbars by default.
        参数：
        horizontalScrollBar - the horizontal scrollbar to be added
        另请参见：
        createHorizontalScrollBar(), getHorizontalScrollBar()

      • createVerticalScrollBar

        public JScrollBar createVerticalScrollBar()
        Returns a JScrollPane.ScrollBar by default. Subclasses may override this method to force ScrollPaneUI implementations to use a JScrollBar subclass. Used by ScrollPaneUI implementations to create the vertical scrollbar.
        返回：
        a JScrollBar with a vertical orientation
        另请参见：
        JScrollBar

      • getVerticalScrollBar

        public JScrollBar getVerticalScrollBar()
        Returns the vertical scroll bar that controls the viewports vertical view position.
        返回：
        the verticalScrollBar property
        另请参见：
        setVerticalScrollBar(javax.swing.JScrollBar)

      • setVerticalScrollBar

        public void setVerticalScrollBar(JScrollBar verticalScrollBar)
        Adds the scrollbar that controls the viewports vertical view position to the scrollpane. This is usually unnecessary, as JScrollPane creates vertical and horizontal scrollbars by default.
        参数：
        verticalScrollBar - the new vertical scrollbar to be added
        另请参见：
        createVerticalScrollBar(), getVerticalScrollBar()

      • createViewport

        protected JViewport createViewport()
        Returns a new JViewport by default. Used to create the viewport (as needed) in setViewportView, setRowHeaderView, and setColumnHeaderView. Subclasses may override this method to return a subclass of JViewport.
        返回：
        a new JViewport

      • getViewport

        public JViewport getViewport()
        Returns the current JViewport.
        返回：
        the viewport property
        另请参见：
        setViewport(javax.swing.JViewport)

      • setViewport

        public void setViewport(JViewport viewport)
        Removes the old viewport (if there is one); forces the viewPosition of the new viewport to be in the +x,+y quadrant; syncs up the row and column headers (if there are any) with the new viewport; and finally syncs the scrollbars and headers with the new viewport.

        Most applications will find it more convenient to use setViewportView to add a viewport and a view to the scrollpane.

        参数：
        viewport - the new viewport to be used; if viewport is null, the old viewport is still removed and the new viewport is set to null
        另请参见：
        createViewport(),
getViewport(),
setViewportView(java.awt.Component)

      • setViewportView

        public void setViewportView(Component view)
        Creates a viewport if necessary and then sets its view. Applications that don't provide the view directly to the JScrollPane constructor should use this method to specify the scrollable child that's going to be displayed in the scrollpane. For example:
         JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
        Applications should not add children directly to the scrollpane.
        参数：
        view - the component to add to the viewport
        另请参见：
        setViewport(javax.swing.JViewport), JViewport.setView(java.awt.Component)

      • getRowHeader

        public JViewport getRowHeader()
        Returns the row header.
        返回：
        the rowHeader property
        另请参见：
        setRowHeader(javax.swing.JViewport)

      • setRowHeader

        public void setRowHeader(JViewport rowHeader)
        Removes the old rowHeader, if it exists; if the new rowHeader isn't null, syncs the y coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.

        Most applications will find it more convenient to use setRowHeaderView to add a row header component and its viewport to the scroll pane.

        参数：
        rowHeader - the new row header to be used; if null the old row header is still removed and the new rowHeader is set to null
        另请参见：
        getRowHeader(), setRowHeaderView(java.awt.Component)

      • setRowHeaderView

        public void setRowHeaderView(Component view)
        Creates a row-header viewport if necessary, sets its view and then adds the row-header viewport to the scrollpane. For example:
         JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
 scrollpane.setRowHeaderView(myBigComponentsRowHeader);
        参数：
        view - the component to display as the row header
        另请参见：
        setRowHeader(javax.swing.JViewport), JViewport.setView(java.awt.Component)

      • getColumnHeader

        public JViewport getColumnHeader()
        Returns the column header.
        返回：
        the columnHeader property
        另请参见：
        setColumnHeader(javax.swing.JViewport)

      • setColumnHeader

        public void setColumnHeader(JViewport columnHeader)
        Removes the old columnHeader, if it exists; if the new columnHeader isn't null, syncs the x coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.

        Most applications will find it more convenient to use setColumnHeaderView to add a column header component and its viewport to the scroll pane.

        另请参见：
        getColumnHeader(), setColumnHeaderView(java.awt.Component)

      • setColumnHeaderView

        public void setColumnHeaderView(Component view)
        Creates a column-header viewport if necessary, sets its view, and then adds the column-header viewport to the scrollpane. For example:
         JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
 scrollpane.setColumnHeaderView(myBigComponentsColumnHeader);
        参数：
        view - the component to display as the column header
        另请参见：
        setColumnHeader(javax.swing.JViewport), JViewport.setView(java.awt.Component)

      • getCorner

        public Component getCorner(String key)
        Returns the component at the specified corner. The key value specifying the corner is one of:
        • ScrollPaneConstants.LOWER_LEFT_CORNER
        • ScrollPaneConstants.LOWER_RIGHT_CORNER
        • ScrollPaneConstants.UPPER_LEFT_CORNER
        • ScrollPaneConstants.UPPER_RIGHT_CORNER
        • ScrollPaneConstants.LOWER_LEADING_CORNER
        • ScrollPaneConstants.LOWER_TRAILING_CORNER
        • ScrollPaneConstants.UPPER_LEADING_CORNER
        • ScrollPaneConstants.UPPER_TRAILING_CORNER
        参数：
        key - one of the values as shown above
        返回：
        the corner component (which may be null) identified by the given key, or null if the key is invalid
        另请参见：
        setCorner(java.lang.String, java.awt.Component)

      • setCorner

        public void setCorner(String key,
             Component corner)
        Adds a child that will appear in one of the scroll panes corners, if there's room. For example with both scrollbars showing (on the right and bottom edges of the scrollpane) the lower left corner component will be shown in the space between ends of the two scrollbars. Legal values for the key are:
        • ScrollPaneConstants.LOWER_LEFT_CORNER
        • ScrollPaneConstants.LOWER_RIGHT_CORNER
        • ScrollPaneConstants.UPPER_LEFT_CORNER
        • ScrollPaneConstants.UPPER_RIGHT_CORNER
        • ScrollPaneConstants.LOWER_LEADING_CORNER
        • ScrollPaneConstants.LOWER_TRAILING_CORNER
        • ScrollPaneConstants.UPPER_LEADING_CORNER
        • ScrollPaneConstants.UPPER_TRAILING_CORNER

        Although "corner" doesn't match any beans property signature, PropertyChange events are generated with the property name set to the corner key.

        参数：
        key - identifies which corner the component will appear in
        corner - one of the following components:
        • lowerLeft
        • lowerRight
        • upperLeft
        • upperRight
        抛出：
        IllegalArgumentException - if corner key is invalid

      • setComponentOrientation

        public void setComponentOrientation(ComponentOrientation co)
        Sets the orientation for the vertical and horizontal scrollbars as determined by the ComponentOrientation argument.
        重载：
        setComponentOrientation in class Component
        参数：
        co - one of the following values:
        • java.awt.ComponentOrientation.LEFT_TO_RIGHT
        • java.awt.ComponentOrientation.RIGHT_TO_LEFT
        • java.awt.ComponentOrientation.UNKNOWN
        另请参见：
        ComponentOrientation

      • isWheelScrollingEnabled

        public boolean isWheelScrollingEnabled()
        Indicates whether or not scrolling will take place in response to the mouse wheel. Wheel scrolling is enabled by default.
        从以下版本开始：
        1.4
        另请参见：
        setWheelScrollingEnabled(boolean)

      • setWheelScrollingEnabled

        public void setWheelScrollingEnabled(boolean handleWheel)
        Enables/disables scrolling in response to movement of the mouse wheel. Wheel scrolling is enabled by default.
        参数：
        handleWheel - true if scrolling should be done automatically for a MouseWheelEvent, false otherwise.
        从以下版本开始：
        1.4
        另请参见：
        isWheelScrollingEnabled(), MouseWheelEvent, MouseWheelListener

      • paramString

        protected String paramString()
        Returns a string representation of this JScrollPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JScrollPane.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JScrollPane. For scroll panes, the AccessibleContext takes the form of an AccessibleJScrollPane. A new AccessibleJScrollPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJScrollPane that serves as the AccessibleContext of this JScrollPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JScrollPane.AccessibleJScrollPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JScrollPane.AccessibleJScrollPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JScrollPane.AccessibleJScrollPane
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, ChangeListener
    封闭类：
    JScrollPane

    protected class JScrollPane.AccessibleJScrollPane
extends JComponent.AccessibleJComponent
implements ChangeListener, PropertyChangeListener
    This class implements accessibility support for the JScrollPane class. It provides an implementation of the Java Accessibility API appropriate to scroll pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JViewport | viewPort

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JScrollPane.AccessibleJScrollPane()
      AccessibleJScrollPane constructor

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      void | resetViewPort()
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 字段详细信息

      • viewPort

        protected JViewport viewPort

    • 构造方法详细信息

      • JScrollPane.AccessibleJScrollPane

        public JScrollPane.AccessibleJScrollPane()
        AccessibleJScrollPane constructor

    • 方法详细信息

      • resetViewPort

        public void resetViewPort()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • stateChanged

        public void stateChanged(ChangeEvent e)
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ernac)as)arpparrae##wa.erjr)nad rotm./J//v"=avJjaorr


JScrollPane.ScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JScrollPane.ScrollBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JScrollBar
            • javax.swing.JScrollPane.ScrollBar
  • 所有已实现的接口：
    Adjustable, ImageObserver, MenuContainer, Serializable, Accessible, UIResource
    封闭类：
    JScrollPane

    protected class JScrollPane.ScrollBar
extends JScrollBar
implements UIResource
    By default JScrollPane creates scrollbars that are instances of this class. Scrollbar overrides the getUnitIncrement and getBlockIncrement methods so that, if the viewport's view is a Scrollable, the view is asked to compute these values. Unless the unit/block increment have been explicitly set.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Scrollable, JScrollPane.createVerticalScrollBar(), JScrollPane.createHorizontalScrollBar()

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JScrollBar

        JScrollBar.AccessibleJScrollBar

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JScrollBar

        blockIncrement, model, orientation, unitIncrement

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.Adjustable

        HORIZONTAL, NO_ORIENTATION, VERTICAL

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JScrollPane.ScrollBar(int orientation)
      Creates a scrollbar with the specified orientation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getBlockIncrement(int direction)
      Computes the block increment for scrolling if the viewport's view is a Scrollable object.
      int getUnitIncrement(int direction)
      Computes the unit increment for scrolling if the viewport's view is a Scrollable object.
      void setBlockIncrement(int blockIncrement)
      Messages super to set the value, and resets the blockIncrementSet instance variable to true.
      void setUnitIncrement(int unitIncrement)
      Messages super to set the value, and resets the unitIncrementSet instance variable to true.

      • 方法 - 继承于类 javax.swing.JScrollBar

        addAdjustmentListener, fireAdjustmentValueChanged, getAccessibleContext, getAdjustmentListeners, getBlockIncrement, getMaximum, getMaximumSize, getMinimum, getMinimumSize, getModel, getOrientation, getUI, getUIClassID, getUnitIncrement, getValue, getValueIsAdjusting, getVisibleAmount, paramString, removeAdjustmentListener, setEnabled, setMaximum, setMinimum, setModel, setOrientation, setUI, setValue, setValueIsAdjusting, setValues, setVisibleAmount, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JScrollPane.ScrollBar

        public JScrollPane.ScrollBar(int orientation)
        Creates a scrollbar with the specified orientation. The options are:
        • ScrollPaneConstants.VERTICAL
        • ScrollPaneConstants.HORIZONTAL
        参数：
        orientation - an integer specifying one of the legal orientation values shown above
        从以下版本开始：
        1.4

    • 方法详细信息

      • setUnitIncrement

        public void setUnitIncrement(int unitIncrement)
        Messages super to set the value, and resets the unitIncrementSet instance variable to true.
        指定者：
        setUnitIncrement in interface Adjustable
        重载：
        setUnitIncrement in class JScrollBar
        参数：
        unitIncrement - the new unit increment value, in pixels
        另请参见：
        JScrollBar.getUnitIncrement(int)

      • getUnitIncrement

        public int getUnitIncrement(int direction)
        Computes the unit increment for scrolling if the viewport's view is a Scrollable object. Otherwise return super.getUnitIncrement.
        重载：
        getUnitIncrement in class JScrollBar
        参数：
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        an integer, in pixels, containing the unit increment
        另请参见：
        Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

      • setBlockIncrement

        public void setBlockIncrement(int blockIncrement)
        Messages super to set the value, and resets the blockIncrementSet instance variable to true.
        指定者：
        setBlockIncrement in interface Adjustable
        重载：
        setBlockIncrement in class JScrollBar
        参数：
        blockIncrement - the new block increment value, in pixels
        另请参见：
        JScrollBar.getBlockIncrement()

      • getBlockIncrement

        public int getBlockIncrement(int direction)
        Computes the block increment for scrolling if the viewport's view is a Scrollable object. Otherwise the blockIncrement equals the viewport's width or height. If there's no viewport return super.getBlockIncrement.
        重载：
        getBlockIncrement in class JScrollBar
        参数：
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        an integer, in pixels, containing the block increment
        另请参见：
        Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mzlnatawtajvvajj. SSl>"


JSeparator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSeparator

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSeparator
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
    直接已知子类：
    JPopupMenu.Separator, JToolBar.Separator

    public class JSeparator
extends JComponent
implements SwingConstants, Accessible
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings. Instead of using JSeparator directly, you can use the JMenu or JPopupMenu addSeparator method to create and add a separator. JSeparators may also be used elsewhere in a GUI wherever a visual divider is useful.

    For more information and examples see How to Use Menus, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JSeparator.AccessibleJSeparator
      This class implements accessibility support for the JSeparator class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSeparator()
      Creates a new horizontal separator.
      JSeparator(int orientation)
      Creates a new separator with the specified horizontal or vertical orientation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JSeparator.
      int getOrientation()
      Returns the orientation of this separator.
      SeparatorUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JSeparator.
      void setOrientation(int orientation)
      Sets the orientation of the separator.
      void setUI(SeparatorUI ui)
      Sets the L&F object that renders this component.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSeparator

        public JSeparator()
        Creates a new horizontal separator.

      • JSeparator

        public JSeparator(int orientation)
        Creates a new separator with the specified horizontal or vertical orientation.
        参数：
        orientation - an integer specifying SwingConstants.HORIZONTAL or SwingConstants.VERTICAL
        抛出：
        IllegalArgumentException - if orientation is neither SwingConstants.HORIZONTAL nor SwingConstants.VERTICAL

    • 方法详细信息

      • getUI

        public SeparatorUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the SeparatorUI object that renders this component

      • setUI

        public void setUI(SeparatorUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the SeparatorUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "SeparatorUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getOrientation

        public int getOrientation()
        Returns the orientation of this separator.
        返回：
        The value of the orientation property, one of the following constants defined in SwingConstants: VERTICAL, or HORIZONTAL.
        另请参见：
        SwingConstants, setOrientation(int)

      • setOrientation

        public void setOrientation(int orientation)
        Sets the orientation of the separator. The default value of this property is HORIZONTAL.
        参数：
        orientation - either SwingConstants.HORIZONTAL or SwingConstants.VERTICAL
        抛出：
        IllegalArgumentException - if orientation is neither SwingConstants.HORIZONTAL nor SwingConstants.VERTICAL
        另请参见：
        SwingConstants, getOrientation()

      • paramString

        protected String paramString()
        Returns a string representation of this JSeparator. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JSeparator

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JSeparator. For separators, the AccessibleContext takes the form of an AccessibleJSeparator. A new AccessibleJSeparator instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJSeparator that serves as the AccessibleContext of this JSeparator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JSeparator.AccessibleJSeparator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSeparator.AccessibleJSeparator

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JSeparator.AccessibleJSeparator
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JSeparator

    protected class JSeparator.AccessibleJSeparator
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JSeparator class. It provides an implementation of the Java Accessibility API appropriate to separator user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JSeparator.AccessibleJSeparator()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JSeparator.AccessibleJSeparator

        protected JSeparator.AccessibleJSeparator()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.w. d/a f<,ef.ehtennocitef>/


JSlider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSlider

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSlider
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants

    public class JSlider
extends JComponent
implements SwingConstants, Accessible
    A component that lets the user graphically select a value by sliding a knob within a bounded interval. The knob is always positioned at the points that match integer values within the specified interval.

    The slider can show both major tick marks, and minor tick marks between the major ones. The number of values between the tick marks is controlled with setMajorTickSpacing and setMinorTickSpacing. Painting of tick marks is controlled by setPaintTicks.

    Sliders can also print text labels at regular intervals (or at arbitrary locations) along the slider track. Painting of labels is controlled by setLabelTable and setPaintLabels.

    For further information and examples see How to Use Sliders, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JSlider.AccessibleJSlider
      This class implements accessibility support for the JSlider class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per slider instance since the event's only (read-only) state is the source property.
      protected ChangeListener changeListener
      The changeListener (no suffix) is the listener we add to the slider's model.
      protected int majorTickSpacing
      The number of values between the major tick marks -- the larger marks that break up the minor tick marks.
      protected int minorTickSpacing
      The number of values between the minor tick marks -- the smaller marks that occur between the major tick marks.
      protected int orientation
      Whether the slider is horizontal or vertical The default is horizontal.
      protected BoundedRangeModel sliderModel
      The data model that handles the numeric maximum value, minimum value, and current-position value for the slider.
      protected boolean snapToTicks
      If true, the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSlider()
      Creates a horizontal slider with the range 0 to 100 and an initial value of 50.
      JSlider(BoundedRangeModel brm)
      Creates a horizontal slider using the specified BoundedRangeModel.
      JSlider(int orientation)
      Creates a slider using the specified orientation with the range 0 to 100 and an initial value of 50.
      JSlider(int min, int max)
      Creates a horizontal slider using the specified min and max with an initial value equal to the average of the min plus max.
      JSlider(int min, int max, int value)
      Creates a horizontal slider using the specified min, max and value.
      JSlider(int orientation, int min, int max, int value)
      Creates a slider with the specified orientation and the specified minimum, maximum, and initial values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the slider.
      protected ChangeListener createChangeListener()
      Subclasses that want to handle ChangeEvents from the model differently can override this to return an instance of a custom ChangeListener implementation.
      Hashtable createStandardLabels(int increment)
      Creates a Hashtable of numerical text labels, starting at the slider minimum, and using the increment specified.
      Hashtable createStandardLabels(int increment, int start)
      Creates a Hashtable of numerical text labels, starting at the starting point specified, and using the increment specified.
      protected void fireStateChanged()
      Send a ChangeEvent, whose source is this JSlider, to all ChangeListeners that have registered interest in ChangeEvents.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JSlider.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this JSlider with addChangeListener().
      int getExtent()
      Returns the "extent" from the BoundedRangeModel.
      boolean getInverted()
      Returns true if the value-range shown for the slider is reversed,
      Dictionary getLabelTable()
      Returns the dictionary of what labels to draw at which values.
      int getMajorTickSpacing()
      This method returns the major tick spacing.
      int getMaximum()
      Returns the maximum value supported by the slider from the BoundedRangeModel.
      int getMinimum()
      Returns the minimum value supported by the slider from the BoundedRangeModel.
      int getMinorTickSpacing()
      This method returns the minor tick spacing.
      BoundedRangeModel getModel()
      Returns the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.
      int getOrientation()
      Return this slider's vertical or horizontal orientation.
      boolean getPaintLabels()
      Tells if labels are to be painted.
      boolean getPaintTicks()
      Tells if tick marks are to be painted.
      boolean getPaintTrack()
      Tells if the track (area the slider slides in) is to be painted.
      boolean getSnapToTicks()
      Returns true if the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.
      SliderUI getUI()
      Gets the UI object which implements the L&F for this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      int getValue()
      Returns the slider's current value from the BoundedRangeModel.
      boolean getValueIsAdjusting()
      Returns the valueIsAdjusting property from the model.
      boolean imageUpdate(Image img, int infoflags, int x, int y, int w, int h)
      Repaints the component when the image has changed.
      protected String paramString()
      Returns a string representation of this JSlider.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the slider.
      void setExtent(int extent)
      Sets the size of the range "covered" by the knob.
      void setFont(Font font)
      Sets the font for this component.
      void setInverted(boolean b)
      Specify true to reverse the value-range shown for the slider and false to put the value range in the normal order.
      void setLabelTable(Dictionary labels)
      Used to specify what label will be drawn at any given value.
      void setMajorTickSpacing(int n)
      This method sets the major tick spacing.
      void setMaximum(int maximum)
      Sets the slider's maximum value to maximum.
      void setMinimum(int minimum)
      Sets the slider's minimum value to minimum.
      void setMinorTickSpacing(int n)
      This method sets the minor tick spacing.
      void setModel(BoundedRangeModel newModel)
      Sets the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.
      void setOrientation(int orientation)
      Set the slider's orientation to either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
      void setPaintLabels(boolean b)
      Determines whether labels are painted on the slider.
      void setPaintTicks(boolean b)
      Determines whether tick marks are painted on the slider.
      void setPaintTrack(boolean b)
      Determines whether the track is painted on the slider.
      void setSnapToTicks(boolean b)
      Specifying true makes the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.
      void setUI(SliderUI ui)
      Sets the UI object which implements the L&F for this component.
      void setValue(int n)
      Sets the slider's current value to n.
      void setValueIsAdjusting(boolean b)
      Sets the model's valueIsAdjusting property.
      protected void updateLabelUIs()
      Updates the UIs for the labels in the label table by calling updateUI on each label.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • sliderModel

        protected BoundedRangeModel sliderModel
        The data model that handles the numeric maximum value, minimum value, and current-position value for the slider.

      • majorTickSpacing

        protected int majorTickSpacing
        The number of values between the major tick marks -- the larger marks that break up the minor tick marks.

      • minorTickSpacing

        protected int minorTickSpacing
        The number of values between the minor tick marks -- the smaller marks that occur between the major tick marks.
        另请参见：
        setMinorTickSpacing(int)

      • snapToTicks

        protected boolean snapToTicks
        If true, the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob. The default is false.
        另请参见：
        setSnapToTicks(boolean)

      • orientation

        protected int orientation
        Whether the slider is horizontal or vertical The default is horizontal.
        另请参见：
        setOrientation(int)

      • changeListener

        protected ChangeListener changeListener
        The changeListener (no suffix) is the listener we add to the slider's model. This listener is initialized to the ChangeListener returned from createChangeListener, which by default just forwards events to ChangeListeners (if any) added directly to the slider.
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), createChangeListener()

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per slider instance since the event's only (read-only) state is the source property. The source of events generated here is always "this". The event is lazily created the first time that an event notification is fired.
        另请参见：
        fireStateChanged()

    • 构造方法详细信息

      • JSlider

        public JSlider()
        Creates a horizontal slider with the range 0 to 100 and an initial value of 50.

      • JSlider

        public JSlider(int orientation)
        Creates a slider using the specified orientation with the range 0 to 100 and an initial value of 50. The orientation can be either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        参数：
        orientation - the orientation of the slider
        抛出：
        IllegalArgumentException - if orientation is not one of VERTICAL, HORIZONTAL
        另请参见：
        setOrientation(int)

      • JSlider

        public JSlider(int min,
       int max)
        Creates a horizontal slider using the specified min and max with an initial value equal to the average of the min plus max.

        The BoundedRangeModel that holds the slider's data handles any issues that may arise from improperly setting the minimum and maximum values on the slider. See the BoundedRangeModel documentation for details.

        参数：
        min - the minimum value of the slider
        max - the maximum value of the slider
        另请参见：
        BoundedRangeModel, setMinimum(int), setMaximum(int)

      • JSlider

        public JSlider(int min,
       int max,
       int value)
        Creates a horizontal slider using the specified min, max and value.

        The BoundedRangeModel that holds the slider's data handles any issues that may arise from improperly setting the minimum, initial, and maximum values on the slider. See the BoundedRangeModel documentation for details.

        参数：
        min - the minimum value of the slider
        max - the maximum value of the slider
        value - the initial value of the slider
        另请参见：
        BoundedRangeModel, setMinimum(int), setMaximum(int), setValue(int)

      • JSlider

        public JSlider(int orientation,
       int min,
       int max,
       int value)
        Creates a slider with the specified orientation and the specified minimum, maximum, and initial values. The orientation can be either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.

        The BoundedRangeModel that holds the slider's data handles any issues that may arise from improperly setting the minimum, initial, and maximum values on the slider. See the BoundedRangeModel documentation for details.

        参数：
        orientation - the orientation of the slider
        min - the minimum value of the slider
        max - the maximum value of the slider
        value - the initial value of the slider
        抛出：
        IllegalArgumentException - if orientation is not one of VERTICAL, HORIZONTAL
        另请参见：
        BoundedRangeModel, setOrientation(int), setMinimum(int), setMaximum(int), setValue(int)

      • JSlider

        public JSlider(BoundedRangeModel brm)
        Creates a horizontal slider using the specified BoundedRangeModel.

    • 方法详细信息

      • getUI

        public SliderUI getUI()
        Gets the UI object which implements the L&F for this component.
        返回：
        the SliderUI object that implements the Slider L&F

      • setUI

        public void setUI(SliderUI ui)
        Sets the UI object which implements the L&F for this component.
        参数：
        ui - the SliderUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        "SliderUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createChangeListener

        protected ChangeListener createChangeListener()
        Subclasses that want to handle ChangeEvents from the model differently can override this to return an instance of a custom ChangeListener implementation. The default ChangeListener simply calls the fireStateChanged method to forward ChangeEvents to the ChangeListeners that have been added directly to the slider.
        另请参见：
        changeListener, fireStateChanged(), ChangeListener, BoundedRangeModel

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the slider.
        参数：
        l - the ChangeListener to add
        另请参见：
        fireStateChanged(), removeChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the slider.
        参数：
        l - the ChangeListener to remove
        另请参见：
        fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this JSlider with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Send a ChangeEvent, whose source is this JSlider, to all ChangeListeners that have registered interest in ChangeEvents. This method is called each time a ChangeEvent is received from the model.

        The event instance is created if necessary, and stored in changeEvent.

        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), EventListenerList

      • getModel

        public BoundedRangeModel getModel()
        Returns the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.
        返回：
        the data model for this component
        另请参见：
        setModel(javax.swing.BoundedRangeModel), BoundedRangeModel

      • setModel

        public void setModel(BoundedRangeModel newModel)
        Sets the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.

        Attempts to pass a null model to this method result in undefined behavior, and, most likely, exceptions.

        参数：
        newModel - the new, non-null BoundedRangeModel to use
        另请参见：
        getModel(), BoundedRangeModel

      • getValue

        public int getValue()
        Returns the slider's current value from the BoundedRangeModel.
        返回：
        the current value of the slider
        另请参见：
        setValue(int), BoundedRangeModel.getValue()

      • setValue

        public void setValue(int n)
        Sets the slider's current value to n. This method forwards the new value to the model.

        The data model (an instance of BoundedRangeModel) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the new value is different from the previous value, all change listeners are notified.

        参数：
        n - the new value
        另请参见：
        getValue(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setValue(int)

      • getMinimum

        public int getMinimum()
        Returns the minimum value supported by the slider from the BoundedRangeModel.
        返回：
        the value of the model's minimum property
        另请参见：
        setMinimum(int), BoundedRangeModel.getMinimum()

      • setMinimum

        public void setMinimum(int minimum)
        Sets the slider's minimum value to minimum. This method forwards the new minimum value to the model.

        The data model (an instance of BoundedRangeModel) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the new minimum value is different from the previous minimum value, all change listeners are notified.

        参数：
        minimum - the new minimum
        另请参见：
        getMinimum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMinimum(int)

      • getMaximum

        public int getMaximum()
        Returns the maximum value supported by the slider from the BoundedRangeModel.
        返回：
        the value of the model's maximum property
        另请参见：
        setMaximum(int), BoundedRangeModel.getMaximum()

      • setMaximum

        public void setMaximum(int maximum)
        Sets the slider's maximum value to maximum. This method forwards the new maximum value to the model.

        The data model (an instance of BoundedRangeModel) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the new maximum value is different from the previous maximum value, all change listeners are notified.

        参数：
        maximum - the new maximum
        另请参见：
        getMaximum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMaximum(int)

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        Returns the valueIsAdjusting property from the model. For details on how this is used, see the setValueIsAdjusting documentation.
        返回：
        the value of the model's valueIsAdjusting property
        另请参见：
        setValueIsAdjusting(boolean)

      • setValueIsAdjusting

        public void setValueIsAdjusting(boolean b)
        Sets the model's valueIsAdjusting property. Slider look and feel implementations should set this property to true when a knob drag begins, and to false when the drag ends.
        参数：
        b - the new value for the valueIsAdjusting property
        另请参见：
        getValueIsAdjusting(), BoundedRangeModel.setValueIsAdjusting(boolean)

      • getExtent

        public int getExtent()
        Returns the "extent" from the BoundedRangeModel. This respresents the range of values "covered" by the knob.
        返回：
        an int representing the extent
        另请参见：
        setExtent(int), BoundedRangeModel.getExtent()

      • setExtent

        public void setExtent(int extent)
        Sets the size of the range "covered" by the knob. Most look and feel implementations will change the value by this amount if the user clicks on either side of the knob. This method just forwards the new extent value to the model.

        The data model (an instance of BoundedRangeModel) handles any mathematical issues arising from assigning faulty values. See the BoundedRangeModel documentation for details.

        If the new extent value is different from the previous extent value, all change listeners are notified.

        参数：
        extent - the new extent
        另请参见：
        getExtent(), BoundedRangeModel.setExtent(int)

      • getOrientation

        public int getOrientation()
        Return this slider's vertical or horizontal orientation.
        返回：
        SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        另请参见：
        setOrientation(int)

      • setOrientation

        public void setOrientation(int orientation)
        Set the slider's orientation to either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        参数：
        orientation - HORIZONTAL or VERTICAL
        抛出：
        IllegalArgumentException - if orientation is not one of VERTICAL, HORIZONTAL
        另请参见：
        getOrientation()

      • setFont

        public void setFont(Font font)
        Sets the font for this component.
        重载：
        setFont in class JComponent
        参数：
        font - the desired Font for this component
        从以下版本开始：
        1.6
        另请参见：
        Component.getFont()

      • imageUpdate

        public boolean imageUpdate(Image img,
                  int infoflags,
                  int x,
                  int y,
                  int w,
                  int h)
        Repaints the component when the image has changed. This imageUpdate method of an ImageObserver is called when more information about an image which had been previously requested using an asynchronous routine such as the drawImage method of Graphics becomes available. See the definition of imageUpdate for more information on this method and its arguments.

        The imageUpdate method of Component incrementally draws an image on the component as more of the bits of the image are available.

        If the system property awt.image.incrementaldraw is missing or has the value true, the image is incrementally drawn. If the system property has any other value, then the image is not drawn until it has been completely loaded.

        Also, if incremental drawing is in effect, the value of the system property awt.image.redrawrate is interpreted as an integer to give the maximum redraw rate, in milliseconds. If the system property is missing or cannot be interpreted as an integer, the redraw rate is once every 100ms.

        The interpretation of the x, y, width, and height arguments depends on the value of the infoflags argument.

        指定者：
        imageUpdate in interface ImageObserver
        重载：
        imageUpdate in class Component
        参数：
        img - the image being observed
        infoflags - see imageUpdate for more information
        x - the x coordinate
        y - the y coordinate
        w - the width
        h - the height
        返回：
        false if the infoflags indicate that the image is completely loaded; true otherwise.
        从以下版本开始：
        1.7
        另请参见：
        ImageObserver, Graphics.drawImage(Image, int, int, Color, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, int, int, Color, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, int, int, java.awt.image.ImageObserver), ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

      • getLabelTable

        public Dictionary getLabelTable()
        Returns the dictionary of what labels to draw at which values.
        返回：
        the Dictionary containing labels and where to draw them

      • setLabelTable

        public void setLabelTable(Dictionary labels)
        Used to specify what label will be drawn at any given value. The key-value pairs are of this format: { Integer value, java.swing.JComponent label }.

        An easy way to generate a standard table of value labels is by using the createStandardLabels method.

        Once the labels have been set, this method calls updateLabelUIs(). Note that the labels are only painted if the paintLabels property is true.

        参数：
        labels - new Dictionary of labels, or null to remove all labels
        另请参见：
        createStandardLabels(int), getLabelTable(), setPaintLabels(boolean)

      • updateLabelUIs

        protected void updateLabelUIs()
        Updates the UIs for the labels in the label table by calling updateUI on each label. The UIs are updated from the current look and feel. The labels are also set to their preferred size.
        另请参见：
        setLabelTable(java.util.Dictionary), JComponent.updateUI()

      • createStandardLabels

        public Hashtable createStandardLabels(int increment)
        Creates a Hashtable of numerical text labels, starting at the slider minimum, and using the increment specified. For example, if you call createStandardLabels( 10 ) and the slider minimum is zero, then labels will be created for the values 0, 10, 20, 30, and so on.

        For the labels to be drawn on the slider, the returned Hashtable must be passed into setLabelTable, and setPaintLabels must be set to true.

        For further details on the makeup of the returned Hashtable, see the setLabelTable documentation.

        参数：
        increment - distance between labels in the generated hashtable
        返回：
        a new Hashtable of labels
        抛出：
        IllegalArgumentException - if increment is less than or equal to zero
        另请参见：
        setLabelTable(java.util.Dictionary), setPaintLabels(boolean)

      • createStandardLabels

        public Hashtable createStandardLabels(int increment,
                             int start)
        Creates a Hashtable of numerical text labels, starting at the starting point specified, and using the increment specified. For example, if you call createStandardLabels( 10, 2 ), then labels will be created for the values 2, 12, 22, 32, and so on.

        For the labels to be drawn on the slider, the returned Hashtable must be passed into setLabelTable, and setPaintLabels must be set to true.

        For further details on the makeup of the returned Hashtable, see the setLabelTable documentation.

        参数：
        increment - distance between labels in the generated hashtable
        start - value at which the labels will begin
        返回：
        a new Hashtable of labels
        抛出：
        IllegalArgumentException - if start is out of range, or if increment is less than or equal to zero
        另请参见：
        setLabelTable(java.util.Dictionary), setPaintLabels(boolean)

      • getInverted

        public boolean getInverted()
        Returns true if the value-range shown for the slider is reversed,
        返回：
        true if the slider values are reversed from their normal order
        另请参见：
        setInverted(boolean)

      • setInverted

        public void setInverted(boolean b)
        Specify true to reverse the value-range shown for the slider and false to put the value range in the normal order. The order depends on the slider's ComponentOrientation property. Normal (non-inverted) horizontal sliders with a ComponentOrientation value of LEFT_TO_RIGHT have their maximum on the right. Normal horizontal sliders with a ComponentOrientation value of RIGHT_TO_LEFT have their maximum on the left. Normal vertical sliders have their maximum on the top. These labels are reversed when the slider is inverted.

        By default, the value of this property is false.

        参数：
        b - true to reverse the slider values from their normal order

      • getMajorTickSpacing

        public int getMajorTickSpacing()
        This method returns the major tick spacing. The number that is returned represents the distance, measured in values, between each major tick mark. If you have a slider with a range from 0 to 50 and the major tick spacing is set to 10, you will get major ticks next to the following values: 0, 10, 20, 30, 40, 50.
        返回：
        the number of values between major ticks
        另请参见：
        setMajorTickSpacing(int)

      • setMajorTickSpacing

        public void setMajorTickSpacing(int n)
        This method sets the major tick spacing. The number that is passed in represents the distance, measured in values, between each major tick mark. If you have a slider with a range from 0 to 50 and the major tick spacing is set to 10, you will get major ticks next to the following values: 0, 10, 20, 30, 40, 50.

        In order for major ticks to be painted, setPaintTicks must be set to true.

        This method will also set up a label table for you. If there is not already a label table, and the major tick spacing is > 0, and getPaintLabels returns true, a standard label table will be generated (by calling createStandardLabels) with labels at the major tick marks. For the example above, you would get text labels: "0", "10", "20", "30", "40", "50". The label table is then set on the slider by calling setLabelTable.

        参数：
        n - new value for the majorTickSpacing property
        另请参见：
        getMajorTickSpacing(), setPaintTicks(boolean), setLabelTable(java.util.Dictionary), createStandardLabels(int)

      • getMinorTickSpacing

        public int getMinorTickSpacing()
        This method returns the minor tick spacing. The number that is returned represents the distance, measured in values, between each minor tick mark. If you have a slider with a range from 0 to 50 and the minor tick spacing is set to 10, you will get minor ticks next to the following values: 0, 10, 20, 30, 40, 50.
        返回：
        the number of values between minor ticks
        另请参见：
        getMinorTickSpacing()

      • setMinorTickSpacing

        public void setMinorTickSpacing(int n)
        This method sets the minor tick spacing. The number that is passed in represents the distance, measured in values, between each minor tick mark. If you have a slider with a range from 0 to 50 and the minor tick spacing is set to 10, you will get minor ticks next to the following values: 0, 10, 20, 30, 40, 50.

        In order for minor ticks to be painted, setPaintTicks must be set to true.

        参数：
        n - new value for the minorTickSpacing property
        另请参见：
        getMinorTickSpacing(), setPaintTicks(boolean)

      • getSnapToTicks

        public boolean getSnapToTicks()
        Returns true if the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.
        返回：
        true if the value snaps to the nearest tick mark, else false
        另请参见：
        setSnapToTicks(boolean)

      • setSnapToTicks

        public void setSnapToTicks(boolean b)
        Specifying true makes the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob. By default, this property is false.
        参数：
        b - true to snap the knob to the nearest tick mark
        另请参见：
        getSnapToTicks()

      • getPaintTicks

        public boolean getPaintTicks()
        Tells if tick marks are to be painted.
        返回：
        true if tick marks are painted, else false
        另请参见：
        setPaintTicks(boolean)

      • setPaintTicks

        public void setPaintTicks(boolean b)
        Determines whether tick marks are painted on the slider. By default, this property is false.
        参数：
        b - whether or not tick marks should be painted
        另请参见：
        getPaintTicks()

      • getPaintTrack

        public boolean getPaintTrack()
        Tells if the track (area the slider slides in) is to be painted.
        返回：
        true if track is painted, else false
        另请参见：
        setPaintTrack(boolean)

      • setPaintTrack

        public void setPaintTrack(boolean b)
        Determines whether the track is painted on the slider. By default, this property is true.
        参数：
        b - whether or not to paint the slider track
        另请参见：
        getPaintTrack()

      • getPaintLabels

        public boolean getPaintLabels()
        Tells if labels are to be painted.
        返回：
        true if labels are painted, else false
        另请参见：
        setPaintLabels(boolean)

      • setPaintLabels

        public void setPaintLabels(boolean b)
        Determines whether labels are painted on the slider.

        This method will also set up a label table for you. If there is not already a label table, and the major tick spacing is > 0, a standard label table will be generated (by calling createStandardLabels) with labels at the major tick marks. The label table is then set on the slider by calling setLabelTable.

        By default, this property is false.

        参数：
        b - whether or not to paint labels
        另请参见：
        getPaintLabels(),
getLabelTable(),
createStandardLabels(int)

      • paramString

        protected String paramString()
        Returns a string representation of this JSlider. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JSlider.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JSlider. For sliders, the AccessibleContext takes the form of an AccessibleJSlider. A new AccessibleJSlider instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJSlider that serves as the AccessibleContext of this JSlider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JSlider.AccessibleJSlider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSlider.AccessibleJSlider

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JSlider.AccessibleJSlider
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JSlider

    protected class JSlider.AccessibleJSlider
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JSlider class. It provides an implementation of the Java Accessibility API appropriate to slider user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JSlider.AccessibleJSlider()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Get the state set of this object.
      AccessibleValue getAccessibleValue()
      Get the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Get the accessible value of this object.
      Number getMaximumAccessibleValue()
      Get the maximum accessible value of this object.
      Number getMinimumAccessibleValue()
      Get the minimum accessible value of this object.
      boolean setCurrentAccessibleValue(Number n)
      Set the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JSlider.AccessibleJSlider

        protected JSlider.AccessibleJSlider()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Get the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Get the accessible value of this object.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        The current value of this object.
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Set the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        True if the value was set.
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Get the minimum accessible value of this object.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        The minimum value of this object.
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Get the maximum accessible value of this object.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        The maximum value of this object.
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rfol,du duobbuoonahherfte"oen>a.jpaenPee/.#"beyb.


JSpinner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSpinner
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JSpinner
extends JComponent
implements Accessible
    A single line input field that lets the user select a number or an object value from an ordered sequence. Spinners typically provide a pair of tiny arrow buttons for stepping through the elements of the sequence. The keyboard up/down arrow keys also cycle through the elements. The user may also be allowed to type a (legal) value directly into the spinner. Although combo boxes provide similar functionality, spinners are sometimes preferred because they don't require a drop down list that can obscure important data.

    A JSpinner's sequence value is defined by its SpinnerModel. The model can be specified as a constructor argument and changed with the model property. SpinnerModel classes for some common types are provided: SpinnerListModel, SpinnerNumberModel, and SpinnerDateModel.

    A JSpinner has a single child component that's responsible for displaying and potentially changing the current element or value of the model, which is called the editor. The editor is created by the JSpinner's constructor and can be changed with the editor property. The JSpinner's editor stays in sync with the model by listening for ChangeEvents. If the user has changed the value displayed by the editor it is possible for the model's value to differ from that of the editor. To make sure the model has the same value as the editor use the commitEdit method, eg:

       try {
       spinner.commitEdit();
   }
   catch (ParseException pe) {{
       // Edited value is invalid, spinner.getValue() will return
       // the last valid value, you could revert the spinner to show that:
       JComponent editor = spinner.getEditor()
       if (editor instanceof DefaultEditor) {
           ((DefaultEditor)editor).getTextField().setValue(spinner.getValue();
       }
       // reset the value to some known value:
       spinner.setValue(fallbackValue);
       // or treat the last valid value as the current, in which
       // case you don't need to do anything.
   }
   return spinner.getValue();

    For information and examples of using spinner see How to Use Spinners, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel, JFormattedTextField

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner implements accessibility support for the JSpinner class.
      static class  JSpinner.DateEditor
      An editor for a JSpinner whose model is a SpinnerDateModel.
      static class  JSpinner.DefaultEditor
      A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
      static class  JSpinner.ListEditor
      An editor for a JSpinner whose model is a SpinnerListModel.
      static class  JSpinner.NumberEditor
      An editor for a JSpinner whose model is a SpinnerNumberModel.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSpinner()
      Constructs a spinner with an Integer SpinnerNumberModel with initial value 0 and no minimum or maximum limits.
      JSpinner(SpinnerModel model)
      Constructs a spinner for the given model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener listener)
      Adds a listener to the list that is notified each time a change to the model occurs.
      void commitEdit()
      Commits the currently edited value to the SpinnerModel.
      protected JComponent createEditor(SpinnerModel model)
      This method is called by the constructors to create the JComponent that displays the current value of the sequence.
      protected void fireStateChanged()
      Sends a ChangeEvent, whose source is this JSpinner, to each ChangeListener.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext for the JSpinner
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this JSpinner with addChangeListener().
      JComponent getEditor()
      Returns the component that displays and potentially changes the model's value.
      SpinnerModel getModel()
      Returns the SpinnerModel that defines this spinners sequence of values.
      Object getNextValue()
      Returns the object in the sequence that comes after the object returned by getValue().
      Object getPreviousValue()
      Returns the object in the sequence that comes before the object returned by getValue().
      SpinnerUI getUI()
      Returns the look and feel (L&F) object that renders this component.
      String getUIClassID()
      Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.
      Object getValue()
      Returns the current value of the model, typically this value is displayed by the editor.
      void removeChangeListener(ChangeListener listener)
      Removes a ChangeListener from this spinner.
      void setEditor(JComponent editor)
      Changes the JComponent that displays the current value of the SpinnerModel.
      void setModel(SpinnerModel model)
      Changes the model that represents the value of this spinner.
      void setUI(SpinnerUI ui)
      Sets the look and feel (L&F) object that renders this component.
      void setValue(Object value)
      Changes current value of the model, typically this value is displayed by the editor.
      void updateUI()
      Resets the UI property with the value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSpinner

        public JSpinner(SpinnerModel model)
        Constructs a spinner for the given model. The spinner has a set of previous/next buttons, and an editor appropriate for the model.
        抛出：
        NullPointerException - if the model is null

      • JSpinner

        public JSpinner()
        Constructs a spinner with an Integer SpinnerNumberModel with initial value 0 and no minimum or maximum limits.

    • 方法详细信息

      • getUI

        public SpinnerUI getUI()
        Returns the look and feel (L&F) object that renders this component.
        返回：
        the SpinnerUI object that renders this component

      • setUI

        public void setUI(SpinnerUI ui)
        Sets the look and feel (L&F) object that renders this component.
        参数：
        ui - the SpinnerUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getUIClassID

        public String getUIClassID()
        Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "SpinnerUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property with the value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        UIManager.getUI(javax.swing.JComponent)

      • createEditor

        protected JComponent createEditor(SpinnerModel model)
        This method is called by the constructors to create the JComponent that displays the current value of the sequence. The editor may also allow the user to enter an element of the sequence directly. An editor must listen for ChangeEvents on the model and keep the value it displays in sync with the value of the model.

        Subclasses may override this method to add support for new SpinnerModel classes. Alternatively one can just replace the editor created here with the setEditor method. The default mapping from model type to editor is:

        • SpinnerNumberModel => JSpinner.NumberEditor
        • SpinnerDateModel => JSpinner.DateEditor
        • SpinnerListModel => JSpinner.ListEditor
        • all others => JSpinner.DefaultEditor
        参数：
        model - the value of getModel
        返回：
        a component that displays the current value of the sequence
        另请参见：
        getModel(), setEditor(javax.swing.JComponent)

      • setModel

        public void setModel(SpinnerModel model)
        Changes the model that represents the value of this spinner. If the editor property has not been explicitly set, the editor property is (implicitly) set after the "model" PropertyChangeEvent has been fired. The editor property is set to the value returned by createEditor, as in:
         setEditor(createEditor(model));
        参数：
        model - the new SpinnerModel
        抛出：
        IllegalArgumentException - if model is null
        另请参见：
        getModel(),
getEditor(),
setEditor(javax.swing.JComponent)

      • getModel

        public SpinnerModel getModel()
        Returns the SpinnerModel that defines this spinners sequence of values.
        返回：
        the value of the model property
        另请参见：
        setModel(javax.swing.SpinnerModel)

      • getValue

        public Object getValue()
        Returns the current value of the model, typically this value is displayed by the editor. If the user has changed the value displayed by the editor it is possible for the model's value to differ from that of the editor, refer to the class level javadoc for examples of how to deal with this.

        This method simply delegates to the model. It is equivalent to:

         getModel().getValue()
        另请参见：
        setValue(java.lang.Object), SpinnerModel.getValue()

      • setValue

        public void setValue(Object value)
        Changes current value of the model, typically this value is displayed by the editor. If the SpinnerModel implementation doesn't support the specified value then an IllegalArgumentException is thrown.

        This method simply delegates to the model. It is equivalent to:

         getModel().setValue(value)
        抛出：
        IllegalArgumentException - if value isn't allowed
        另请参见：
        getValue(), SpinnerModel.setValue(java.lang.Object)

      • getNextValue

        public Object getNextValue()
        Returns the object in the sequence that comes after the object returned by getValue(). If the end of the sequence has been reached then return null. Calling this method does not effect value.

        This method simply delegates to the model. It is equivalent to:

         getModel().getNextValue()
        返回：
        the next legal value or null if one doesn't exist
        另请参见：
        getValue(),
getPreviousValue(),
SpinnerModel.getNextValue()

      • addChangeListener

        public void addChangeListener(ChangeListener listener)
        Adds a listener to the list that is notified each time a change to the model occurs. The source of ChangeEvents delivered to ChangeListeners will be this JSpinner. Note also that replacing the model will not affect listeners added directly to JSpinner. Applications can add listeners to the model directly. In that case is that the source of the event would be the SpinnerModel.
        参数：
        listener - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener), getModel()

      • removeChangeListener

        public void removeChangeListener(ChangeListener listener)
        Removes a ChangeListener from this spinner.
        参数：
        listener - the ChangeListener to remove
        另请参见：
        fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this JSpinner with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Sends a ChangeEvent, whose source is this JSpinner, to each ChangeListener. When a ChangeListener has been added to the spinner, this method method is called each time a ChangeEvent is received from the model.
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener), EventListenerList

      • getPreviousValue

        public Object getPreviousValue()
        Returns the object in the sequence that comes before the object returned by getValue(). If the end of the sequence has been reached then return null. Calling this method does not effect value.

        This method simply delegates to the model. It is equivalent to:

         getModel().getPreviousValue()
        返回：
        the previous legal value or null if one doesn't exist
        另请参见：
        getValue(),
getNextValue(),
SpinnerModel.getPreviousValue()

      • setEditor

        public void setEditor(JComponent editor)
        Changes the JComponent that displays the current value of the SpinnerModel. It is the responsibility of this method to disconnect the old editor from the model and to connect the new editor. This may mean removing the old editors ChangeListener from the model or the spinner itself and adding one for the new editor.
        参数：
        editor - the new editor
        抛出：
        IllegalArgumentException - if editor is null
        另请参见：
        getEditor(),
createEditor(javax.swing.SpinnerModel),
getModel()

      • getEditor

        public JComponent getEditor()
        Returns the component that displays and potentially changes the model's value.
        返回：
        the component that displays and potentially changes the model's value
        另请参见：
        setEditor(javax.swing.JComponent), createEditor(javax.swing.SpinnerModel)

      • commitEdit

        public void commitEdit()
                throws ParseException
        Commits the currently edited value to the SpinnerModel.

        If the editor is an instance of DefaultEditor, the call if forwarded to the editor, otherwise this does nothing.

        抛出：
        ParseException - if the currently edited value couldn't be commited.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext for the JSpinner
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        the AccessibleContext for the JSpinner
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JSpinner.AccessibleJSpinner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner.AccessibleJSpinner

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JSpinner.AccessibleJSpinner
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
    封闭类：
    JSpinner

    protected class JSpinner.AccessibleJSpinner
extends JComponent.AccessibleJComponent
implements AccessibleValue, AccessibleAction, AccessibleText, AccessibleEditableText, ChangeListener
    AccessibleJSpinner implements accessibility support for the JSpinner class.
    从以下版本开始：
    1.5

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JSpinner.AccessibleJSpinner()
      AccessibleJSpinner constructor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void cut(int startIndex, int endIndex)
      Cuts the text between two indices into the system clipboard.
      void delete(int startIndex, int endIndex)
      Deletes the text between two indices
      boolean doAccessibleAction(int i)
      Performs the specified Action on the object
      AccessibleAction getAccessibleAction()
      Gets the AccessibleAction associated with this object that supports one or more actions.
      int getAccessibleActionCount()
      Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.
      String getAccessibleActionDescription(int i)
      Returns a description of the specified action of the object.
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      int getCaretPosition()
      Returns the zero-based offset of the caret.
      AttributeSet getCharacterAttribute(int i)
      Returns the AttributeSet for a given character at a given index
      Rectangle getCharacterBounds(int i)
      Determines the bounding box of the character at the given index into the string.
      int getCharCount()
      Returns the number of characters (valid indicies)
      Number getCurrentAccessibleValue()
      Get the value of this object as a Number.
      int getIndexAtPoint(Point p)
      Given a point in local coordinates, return the zero-based index of the character under that Point.
      Number getMaximumAccessibleValue()
      Get the maximum value of this object as a Number.
      Number getMinimumAccessibleValue()
      Get the minimum value of this object as a Number.
      String getSelectedText()
      Returns the portion of the text that is selected.
      int getSelectionEnd()
      Returns the end offset within the selected text.
      int getSelectionStart()
      Returns the start offset within the selected text.
      String getTextRange(int startIndex, int endIndex)
      Returns the text string between two indices.
      void insertTextAtIndex(int index, String s)
      Inserts the specified string at the given index/
      void paste(int startIndex)
      Pastes the text from the system clipboard into the text starting at the specified index.
      void replaceText(int startIndex, int endIndex, String s)
      Replaces the text between two indices with the specified string.
      void selectText(int startIndex, int endIndex)
      Selects the text between two indices.
      void setAttributes(int startIndex, int endIndex, AttributeSet as)
      Sets attributes for the text between two indices.
      boolean setCurrentAccessibleValue(Number n)
      Set the value of this object as a Number.
      void setTextContents(String s)
      Sets the text contents to the specified string.
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JSpinner.AccessibleJSpinner

        protected JSpinner.AccessibleJSpinner()
        AccessibleJSpinner constructor

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object. The role of the object is the generic purpose or use of the class of this object. For example, the role of a push button is AccessibleRole.PUSH_BUTTON. The roles in AccessibleRole are provided so component developers can pick from a set of predefined roles. This enables assistive technologies to provide a consistent interface to various tweaked subclasses of components (e.g., use AccessibleRole.PUSH_BUTTON for all components that act like a push button) as well as distinguish between sublasses that behave differently (e.g., AccessibleRole.CHECK_BOX for check boxes and AccessibleRole.RADIO_BUTTON for radio buttons).

        Note that the AccessibleRole class is also extensible, so custom component developers can define their own AccessibleRole's if the set of predefined roles is inadequate.

        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children of the object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        getAccessibleChildrenCount()

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Gets the AccessibleAction associated with this object that supports one or more actions.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        AccessibleAction if supported by object; else return null
        另请参见：
        AccessibleAction

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        AccessibleValue if supported by object; else return null
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Get the value of this object as a Number. If the value has not been set, the return value will be null.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        value of the object
        另请参见：
        setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Set the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        参数：
        n - the value to set for this object
        返回：
        true if the value was set; else False
        另请参见：
        getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Get the minimum value of this object as a Number.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        Minimum value of the object; null if this object does not have a minimum value
        另请参见：
        getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Get the maximum value of this object as a Number.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        Maximum value of the object; null if this object does not have a maximum value
        另请参见：
        getMinimumAccessibleValue()

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object. Two actions are supported: AccessibleAction.INCREMENT which increments the spinner value and AccessibleAction.DECREMENT which decrements the spinner value
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        返回：
        the zero-based number of Actions in this object

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Returns a description of the specified action of the object.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        参数：
        i - zero-based index of the actions
        返回：
        a String description of the action
        另请参见：
        getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Performs the specified Action on the object
        指定者：
        doAccessibleAction in interface AccessibleAction
        参数：
        i - zero-based index of actions. The first action (index 0) is AccessibleAction.INCREMENT and the second action (index 1) is AccessibleAction.DECREMENT.
        返回：
        true if the action was performed; otherwise false.
        另请参见：
        getAccessibleActionCount()

      • getIndexAtPoint

        public int getIndexAtPoint(Point p)
        Given a point in local coordinates, return the zero-based index of the character under that Point. If the point is invalid, this method returns -1.
        指定者：
        getIndexAtPoint in interface AccessibleText
        参数：
        p - the Point in local coordinates
        返回：
        the zero-based index of the character under Point p; if Point is invalid return -1.

      • getCharacterBounds

        public Rectangle getCharacterBounds(int i)
        Determines the bounding box of the character at the given index into the string. The bounds are returned in local coordinates. If the index is invalid an empty rectangle is returned.
        指定者：
        getCharacterBounds in interface AccessibleText
        参数：
        i - the index into the String
        返回：
        the screen coordinates of the character's bounding box, if index is invalid return an empty rectangle.

      • getCharCount

        public int getCharCount()
        Returns the number of characters (valid indicies)
        指定者：
        getCharCount in interface AccessibleText
        返回：
        the number of characters

      • getCaretPosition

        public int getCaretPosition()
        Returns the zero-based offset of the caret. Note: That to the right of the caret will have the same index value as the offset (the caret is between two characters).
        指定者：
        getCaretPosition in interface AccessibleText
        返回：
        the zero-based offset of the caret.

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index.
        指定者：
        getAtIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index.
        指定者：
        getAfterIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index.
        指定者：
        getBeforeIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute(int i)
        Returns the AttributeSet for a given character at a given index
        指定者：
        getCharacterAttribute in interface AccessibleText
        参数：
        i - the zero-based index into the text
        返回：
        the AttributeSet of the character

      • getSelectionStart

        public int getSelectionStart()
        Returns the start offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionStart in interface AccessibleText
        返回：
        the index into the text of the start of the selection

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the end offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionEnd in interface AccessibleText
        返回：
        the index into teh text of the end of the selection

      • getSelectedText

        public String getSelectedText()
        Returns the portion of the text that is selected.
        指定者：
        getSelectedText in interface AccessibleText
        返回：
        the String portion of the text that is selected

      • setTextContents

        public void setTextContents(String s)
        Sets the text contents to the specified string.
        指定者：
        setTextContents in interface AccessibleEditableText
        参数：
        s - the string to set the text contents

      • insertTextAtIndex

        public void insertTextAtIndex(int index,
                     String s)
        Inserts the specified string at the given index/
        指定者：
        insertTextAtIndex in interface AccessibleEditableText
        参数：
        index - the index in the text where the string will be inserted
        s - the string to insert in the text

      • getTextRange

        public String getTextRange(int startIndex,
                  int endIndex)
        Returns the text string between two indices.
        指定者：
        getTextRange in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        返回：
        the text string between the indices

      • delete

        public void delete(int startIndex,
          int endIndex)
        Deletes the text between two indices
        指定者：
        delete in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text

      • cut

        public void cut(int startIndex,
       int endIndex)
        Cuts the text between two indices into the system clipboard.
        指定者：
        cut in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text

      • paste

        public void paste(int startIndex)
        Pastes the text from the system clipboard into the text starting at the specified index.
        指定者：
        paste in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text

      • replaceText

        public void replaceText(int startIndex,
               int endIndex,
               String s)
        Replaces the text between two indices with the specified string.
        指定者：
        replaceText in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        s - the string to replace the text between two indices

      • selectText

        public void selectText(int startIndex,
              int endIndex)
        Selects the text between two indices.
        指定者：
        selectText in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text

      • setAttributes

        public void setAttributes(int startIndex,
                 int endIndex,
                 AttributeSet as)
        Sets attributes for the text between two indices.
        指定者：
        setAttributes in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        as - the attribute set
        另请参见：
        AttributeSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e. > >, >e<<>ee


JSpinner.DateEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner.DateEditor

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
            • javax.swing.JSpinner.DefaultEditor
              • javax.swing.JSpinner.DateEditor
  • 所有已实现的接口：
    ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
    封闭类：
    JSpinner

    public static class JSpinner.DateEditor
extends JSpinner.DefaultEditor
    An editor for a JSpinner whose model is a SpinnerDateModel. The value of the editor is displayed with a JFormattedTextField whose format is defined by a DateFormatter instance whose minimum and maximum properties are mapped to the SpinnerDateModel.
    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JPanel

        JPanel.AccessibleJPanel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSpinner.DateEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.
      JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SimpleDateFormat getFormat()
      Returns the java.text.SimpleDateFormat object the JFormattedTextField uses to parse and format numbers.
      SpinnerDateModel getModel()
      Return our spinner ancestor's SpinnerDateModel.

      • 方法 - 继承于类 javax.swing.JSpinner.DefaultEditor

        addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged

      • 方法 - 继承于类 javax.swing.JPanel

        getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSpinner.DateEditor

        public JSpinner.DateEditor(JSpinner spinner)
        Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField. This DateEditor becomes both a ChangeListener on the spinners model and a PropertyChangeListener on the new JFormattedTextField.
        参数：
        spinner - the spinner whose model this editor will monitor
        抛出：
        IllegalArgumentException - if the spinners model is not an instance of SpinnerDateModel
        另请参见：
        getModel(), getFormat(), SpinnerDateModel

      • JSpinner.DateEditor

        public JSpinner.DateEditor(JSpinner spinner,
                   String dateFormatPattern)
        Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField. This DateEditor becomes both a ChangeListener on the spinner and a PropertyChangeListener on the new JFormattedTextField.
        参数：
        spinner - the spinner whose model this editor will monitor
        dateFormatPattern - the initial pattern for the SimpleDateFormat object that's used to display and parse the value of the text field.
        抛出：
        IllegalArgumentException - if the spinners model is not an instance of SpinnerDateModel
        另请参见：
        getModel(), getFormat(), SpinnerDateModel, SimpleDateFormat

    • 方法详细信息

      • getFormat

        public SimpleDateFormat getFormat()
        Returns the java.text.SimpleDateFormat object the JFormattedTextField uses to parse and format numbers.
        返回：
        the value of getTextField().getFormatter().getFormat().
        另请参见：
        JSpinner.DefaultEditor.getTextField(), SimpleDateFormat

      • getModel

        public SpinnerDateModel getModel()
        Return our spinner ancestor's SpinnerDateModel.
        返回：
        getSpinner().getModel()
        另请参见：
        JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.><>n<<>nndar<>rt>trrwfao t鹍uwJ/l


JSpinner.DefaultEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner.DefaultEditor

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
            • javax.swing.JSpinner.DefaultEditor
  • 所有已实现的接口：
    ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
    直接已知子类：
    JSpinner.DateEditor, JSpinner.ListEditor, JSpinner.NumberEditor
    封闭类：
    JSpinner

    public static class JSpinner.DefaultEditor
extends JPanel
implements ChangeListener, PropertyChangeListener, LayoutManager
    A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField. Subclasses can configure the JFormattedTextField to create an editor that's appropriate for the type of model they support and they may want to override the stateChanged and propertyChanged methods, which keep the model and the text field in sync.

    This class defines a dismiss method that removes the editors ChangeListener from the JSpinner that it's part of. The setEditor method knows about DefaultEditor.dismiss, so if the developer replaces an editor that's derived from JSpinner.DefaultEditor its ChangeListener connection back to the JSpinner will be removed. However after that, it's up to the developer to manage their editor listeners. Similarly, if a subclass overrides createEditor, it's up to the subclasser to deal with their editor subsequently being replaced (with setEditor). We expect that in most cases, and in editor installed with setEditor or created by a createEditor override, will not be replaced anyway.

    This class is the LayoutManager for it's single JFormattedTextField child. By default the child is just centered with the parents insets.

    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JPanel

        JPanel.AccessibleJPanel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSpinner.DefaultEditor(JSpinner spinner)
      Constructs an editor component for the specified JSpinner.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String name, Component child)
      This LayoutManager method does nothing.
      void commitEdit()
      Pushes the currently edited value to the SpinnerModel.
      void dismiss(JSpinner spinner)
      Disconnect this editor from the specified JSpinner.
      int getBaseline(int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior()
      Returns an enum indicating how the baseline of the component changes as the size changes.
      JSpinner getSpinner()
      Returns the JSpinner ancestor of this editor or null if none of the ancestors are a JSpinner.
      JFormattedTextField getTextField()
      Returns the JFormattedTextField child of this editor.
      void layoutContainer(Container parent)
      Resize the one (and only) child to completely fill the area within the parents insets.
      Dimension minimumLayoutSize(Container parent)
      Returns the minimum size of first (and only) child plus the size of the parents insets.
      Dimension preferredLayoutSize(Container parent)
      Returns the preferred size of first (and only) child plus the size of the parents insets.
      void propertyChange(PropertyChangeEvent e)
      Called by the JFormattedTextField PropertyChangeListener.
      void removeLayoutComponent(Component child)
      This LayoutManager method does nothing.
      void stateChanged(ChangeEvent e)
      This method is called when the spinner's model's state changes.

      • 方法 - 继承于类 javax.swing.JPanel

        getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSpinner.DefaultEditor

        public JSpinner.DefaultEditor(JSpinner spinner)
        Constructs an editor component for the specified JSpinner. This DefaultEditor is it's own layout manager and it is added to the spinner's ChangeListener list. The constructor creates a single JFormattedTextField child, initializes it's value to be the spinner model's current value and adds it to this DefaultEditor.
        参数：
        spinner - the spinner whose model this editor will monitor
        另请参见：
        getTextField(), JSpinner.addChangeListener(javax.swing.event.ChangeListener)

    • 方法详细信息

      • dismiss

        public void dismiss(JSpinner spinner)
        Disconnect this editor from the specified JSpinner. By default, this method removes itself from the spinners ChangeListener list.
        参数：
        spinner - the JSpinner to disconnect this editor from; the same spinner as was passed to the constructor.

      • getSpinner

        public JSpinner getSpinner()
        Returns the JSpinner ancestor of this editor or null if none of the ancestors are a JSpinner. Typically the editor's parent is a JSpinner however subclasses of JSpinner may override the the createEditor method and insert one or more containers between the JSpinner and it's editor.
        返回：
        JSpinner ancestor; null if none of the ancestors are a JSpinner
        另请参见：
        JSpinner.createEditor(javax.swing.SpinnerModel)

      • getTextField

        public JFormattedTextField getTextField()
        Returns the JFormattedTextField child of this editor. By default the text field is the first and only child of editor.
        返回：
        the JFormattedTextField that gives the user access to the SpinnerDateModel's value.
        另请参见：
        getSpinner(), JSpinner.getModel()

      • stateChanged

        public void stateChanged(ChangeEvent e)
        This method is called when the spinner's model's state changes. It sets the value of the text field to the current value of the spinners model.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - the ChangeEvent whose source is the JSpinner whose model has changed.
        另请参见：
        getTextField(), JSpinner.getValue()

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Called by the JFormattedTextField PropertyChangeListener. When the "value" property changes, which implies that the user has typed a new number, we set the value of the spinners model.

        This class ignores PropertyChangeEvents whose source is not the JFormattedTextField, so subclasses may safely make this DefaultEditor a PropertyChangeListener on other objects.

        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - the PropertyChangeEvent whose source is the JFormattedTextField created by this class.
        另请参见：
        getTextField()

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component child)
        This LayoutManager method does nothing. We're only managing a single child and there's no support for layout constraints.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - ignored
        child - ignored

      • removeLayoutComponent

        public void removeLayoutComponent(Component child)
        This LayoutManager method does nothing. There isn't any per-child state.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        child - ignored

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        Returns the preferred size of first (and only) child plus the size of the parents insets.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the Container that's managing the layout
        返回：
        the preferred dimensions to lay out the subcomponents of the specified container.
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        Returns the minimum size of first (and only) child plus the size of the parents insets.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the Container that's managing the layout
        返回：
        the minimum dimensions needed to lay out the subcomponents of the specified container.
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container parent)
        Resize the one (and only) child to completely fill the area within the parents insets.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to be laid out

      • commitEdit

        public void commitEdit()
                throws ParseException
        Pushes the currently edited value to the SpinnerModel.

        The default implementation invokes commitEdit on the JFormattedTextField.

        抛出：
        ParseException - if the edited value is not legal

      • getBaseline

        public int getBaseline(int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class JComponent
        参数：
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        the baseline or < 0 indicating there is no reasonable baseline
        抛出：
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int,int), JComponent.getBaselineResizeBehavior()

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior()
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class JComponent
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r


JSpinner.ListEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner.ListEditor

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
            • javax.swing.JSpinner.DefaultEditor
              • javax.swing.JSpinner.ListEditor
  • 所有已实现的接口：
    ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
    封闭类：
    JSpinner

    public static class JSpinner.ListEditor
extends JSpinner.DefaultEditor
    An editor for a JSpinner whose model is a SpinnerListModel.
    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JPanel

        JPanel.AccessibleJPanel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSpinner.ListEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerListModel with a JFormattedTextField.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SpinnerListModel getModel()
      Return our spinner ancestor's SpinnerNumberModel.

      • 方法 - 继承于类 javax.swing.JSpinner.DefaultEditor

        addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged

      • 方法 - 继承于类 javax.swing.JPanel

        getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSpinner.ListEditor

        public JSpinner.ListEditor(JSpinner spinner)
        Construct a JSpinner editor that supports displaying and editing the value of a SpinnerListModel with a JFormattedTextField. This ListEditor becomes both a ChangeListener on the spinner and a PropertyChangeListener on the new JFormattedTextField.
        参数：
        spinner - the spinner whose model this editor will monitor
        抛出：
        IllegalArgumentException - if the spinners model is not an instance of SpinnerListModel
        另请参见：
        getModel(), SpinnerListModel

    • 方法详细信息

      • getModel

        public SpinnerListModel getModel()
        Return our spinner ancestor's SpinnerNumberModel.
        返回：
        getSpinner().getModel()
        另请参见：
        JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v h>a,,>aaarOOj/.=a.aaptemIrmealmmtwta> fg


JSpinner.NumberEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSpinner.NumberEditor

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
            • javax.swing.JSpinner.DefaultEditor
              • javax.swing.JSpinner.NumberEditor
  • 所有已实现的接口：
    ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
    封闭类：
    JSpinner

    public static class JSpinner.NumberEditor
extends JSpinner.DefaultEditor
    An editor for a JSpinner whose model is a SpinnerNumberModel. The value of the editor is displayed with a JFormattedTextField whose format is defined by a NumberFormatter instance whose minimum and maximum properties are mapped to the SpinnerNumberModel.
    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JPanel

        JPanel.AccessibleJPanel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSpinner.NumberEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.
      JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DecimalFormat getFormat()
      Returns the java.text.DecimalFormat object the JFormattedTextField uses to parse and format numbers.
      SpinnerNumberModel getModel()
      Return our spinner ancestor's SpinnerNumberModel.

      • 方法 - 继承于类 javax.swing.JSpinner.DefaultEditor

        addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged

      • 方法 - 继承于类 javax.swing.JPanel

        getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JSpinner.NumberEditor

        public JSpinner.NumberEditor(JSpinner spinner)
        Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField. This NumberEditor becomes both a ChangeListener on the spinner and a PropertyChangeListener on the new JFormattedTextField.
        参数：
        spinner - the spinner whose model this editor will monitor
        抛出：
        IllegalArgumentException - if the spinners model is not an instance of SpinnerNumberModel
        另请参见：
        getModel(), getFormat(), SpinnerNumberModel

      • JSpinner.NumberEditor

        public JSpinner.NumberEditor(JSpinner spinner,
                     String decimalFormatPattern)
        Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField. This NumberEditor becomes both a ChangeListener on the spinner and a PropertyChangeListener on the new JFormattedTextField.
        参数：
        spinner - the spinner whose model this editor will monitor
        decimalFormatPattern - the initial pattern for the DecimalFormat object that's used to display and parse the value of the text field.
        抛出：
        IllegalArgumentException - if the spinners model is not an instance of SpinnerNumberModel or if decimalFormatPattern is not a legal argument to DecimalFormat
        另请参见：
        JSpinner.DefaultEditor.getTextField(), SpinnerNumberModel, DecimalFormat

    • 方法详细信息

      • getFormat

        public DecimalFormat getFormat()
        Returns the java.text.DecimalFormat object the JFormattedTextField uses to parse and format numbers.
        返回：
        the value of getTextField().getFormatter().getFormat().
        另请参见：
        JSpinner.DefaultEditor.getTextField(), DecimalFormat

      • getModel

        public SpinnerNumberModel getModel()
        Return our spinner ancestor's SpinnerNumberModel.
        返回：
        getSpinner().getModel()
        另请参见：
        JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JSplitPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSplitPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSplitPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JSplitPane
extends JComponent
implements Accessible
    JSplitPane is used to divide two (and only two) Components. The two Components are graphically divided based on the look and feel implementation, and the two Components can then be interactively resized by the user. Information on using JSplitPane is in How to Use Split Panes in The Java Tutorial.

    The two Components in a split pane can be aligned left to right using JSplitPane.HORIZONTAL_SPLIT, or top to bottom using JSplitPane.VERTICAL_SPLIT. The preferred way to change the size of the Components is to invoke setDividerLocation where location is either the new x or y position, depending on the orientation of the JSplitPane.

    To resize the Components to their preferred sizes invoke resetToPreferredSizes.

    When the user is resizing the Components the minimum size of the Components is used to determine the maximum/minimum position the Components can be set to. If the minimum size of the two components is greater than the size of the split pane the divider will not allow you to resize it. To alter the minimum size of a JComponent, see JComponent.setMinimumSize(java.awt.Dimension).

    When the user resizes the split pane the new space is distributed between the two components based on the resizeWeight property. A value of 0, the default, indicates the right/bottom component gets all the space, where as a value of 1 indicates the left/top component gets all the space.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    setDividerLocation(double), resetToPreferredSizes()

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JSplitPane.AccessibleJSplitPane
      This class implements accessibility support for the JSplitPane class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String BOTTOM
      Used to add a Component below the other Component.
      static String CONTINUOUS_LAYOUT_PROPERTY
      Bound property name for continuousLayout.
      protected boolean continuousLayout
      Whether or not the views are continuously redisplayed while resizing.
      static String DIVIDER
      Used to add a Component that will represent the divider.
      static String DIVIDER_LOCATION_PROPERTY
      Bound property for the dividerLocation.
      static String DIVIDER_SIZE_PROPERTY
      Bound property name for border.
      protected int dividerSize
      Size of the divider.
      static int HORIZONTAL_SPLIT
      Horizontal split indicates the Components are split along the x axis.
      static String LAST_DIVIDER_LOCATION_PROPERTY
      Bound property for lastLocation.
      protected int lastDividerLocation
      Previous location of the split pane.
      static String LEFT
      Used to add a Component to the left of the other Component.
      protected Component leftComponent
      The left or top component.
      static String ONE_TOUCH_EXPANDABLE_PROPERTY
      Bound property for oneTouchExpandable.
      protected boolean oneTouchExpandable
      Is a little widget provided to quickly expand/collapse the split pane?
      protected int orientation
      How the views are split.
      static String ORIENTATION_PROPERTY
      Bound property name for orientation (horizontal or vertical).
      static String RESIZE_WEIGHT_PROPERTY
      Bound property for weight.
      static String RIGHT
      Used to add a Component to the right of the other Component.
      protected Component rightComponent
      The right or bottom component.
      static String TOP
      Used to add a Component above the other Component.
      static int VERTICAL_SPLIT
      Vertical split indicates the Components are split along the y axis.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JSplitPane()
      Creates a new JSplitPane configured to arrange the child components side-by-side horizontally, using two buttons for the components.
      JSplitPane(int newOrientation)
      Creates a new JSplitPane configured with the specified orientation.
      JSplitPane(int newOrientation, boolean newContinuousLayout)
      Creates a new JSplitPane with the specified orientation and redrawing style.
      JSplitPane(int newOrientation, boolean newContinuousLayout, Component newLeftComponent, Component newRightComponent)
      Creates a new JSplitPane with the specified orientation and redrawing style, and with the specified components.
      JSplitPane(int newOrientation, Component newLeftComponent, Component newRightComponent)
      Creates a new JSplitPane with the specified orientation and the specified components.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified component to this split pane.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JSplitPane.
      Component getBottomComponent()
      Returns the component below, or to the right of the divider.
      int getDividerLocation()
      Returns the last value passed to setDividerLocation.
      int getDividerSize()
      Returns the size of the divider.
      int getLastDividerLocation()
      Returns the last location the divider was at.
      Component getLeftComponent()
      Returns the component to the left (or above) the divider.
      int getMaximumDividerLocation()
      Returns the maximum location of the divider from the look and feel implementation.
      int getMinimumDividerLocation()
      Returns the minimum location of the divider from the look and feel implementation.
      int getOrientation()
      Returns the orientation.
      double getResizeWeight()
      Returns the number that determines how extra space is distributed.
      Component getRightComponent()
      Returns the component to the right (or below) the divider.
      Component getTopComponent()
      Returns the component above, or to the left of the divider.
      SplitPaneUI getUI()
      Returns the SplitPaneUI that is providing the current look and feel.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      boolean isContinuousLayout()
      Gets the continuousLayout property.
      boolean isOneTouchExpandable()
      Gets the oneTouchExpandable property.
      boolean isValidateRoot()
      Returns true, so that calls to revalidate on any descendant of this JSplitPane will cause a request to be queued that will validate the JSplitPane and all its descendants.
      protected void paintChildren(Graphics g)
      Subclassed to message the UI with finishedPaintingChildren after super has been messaged, as well as painting the border.
      protected String paramString()
      Returns a string representation of this JSplitPane.
      void remove(Component component)
      Removes the child component, component from the pane.
      void remove(int index)
      Removes the Component at the specified index.
      void removeAll()
      Removes all the child components from the split pane.
      void resetToPreferredSizes()
      Lays out the JSplitPane layout based on the preferred size of the children components.
      void setBottomComponent(Component comp)
      Sets the component below, or to the right of the divider.
      void setContinuousLayout(boolean newContinuousLayout)
      Sets the value of the continuousLayout property, which must be true for the child components to be continuously redisplayed and laid out during user intervention.
      void setDividerLocation(double proportionalLocation)
      Sets the divider location as a percentage of the JSplitPane's size.
      void setDividerLocation(int location)
      Sets the location of the divider.
      void setDividerSize(int newSize)
      Sets the size of the divider.
      void setLastDividerLocation(int newLastLocation)
      Sets the last location the divider was at to newLastLocation.
      void setLeftComponent(Component comp)
      Sets the component to the left (or above) the divider.
      void setOneTouchExpandable(boolean newValue)
      Sets the value of the oneTouchExpandable property, which must be true for the JSplitPane to provide a UI widget on the divider to quickly expand/collapse the divider.
      void setOrientation(int orientation)
      Sets the orientation, or how the splitter is divided.
      void setResizeWeight(double value)
      Specifies how to distribute extra space when the size of the split pane changes.
      void setRightComponent(Component comp)
      Sets the component to the right (or below) the divider.
      void setTopComponent(Component comp)
      Sets the component above, or to the left of the divider.
      void setUI(SplitPaneUI ui)
      Sets the L&F object that renders this component.
      void updateUI()
      Notification from the UIManager that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • VERTICAL_SPLIT

        public static final int VERTICAL_SPLIT
        Vertical split indicates the Components are split along the y axis. For example the two Components will be split one on top of the other.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SPLIT

        public static final int HORIZONTAL_SPLIT
        Horizontal split indicates the Components are split along the x axis. For example the two Components will be split one to the left of the other.
        另请参见：
        Constant Field Values

      • LEFT

        public static final String LEFT
        Used to add a Component to the left of the other Component.
        另请参见：
        Constant Field Values

      • RIGHT

        public static final String RIGHT
        Used to add a Component to the right of the other Component.
        另请参见：
        Constant Field Values

      • TOP

        public static final String TOP
        Used to add a Component above the other Component.
        另请参见：
        Constant Field Values

      • BOTTOM

        public static final String BOTTOM
        Used to add a Component below the other Component.
        另请参见：
        Constant Field Values

      • DIVIDER

        public static final String DIVIDER
        Used to add a Component that will represent the divider.
        另请参见：
        Constant Field Values

      • ORIENTATION_PROPERTY

        public static final String ORIENTATION_PROPERTY
        Bound property name for orientation (horizontal or vertical).
        另请参见：
        Constant Field Values

      • CONTINUOUS_LAYOUT_PROPERTY

        public static final String CONTINUOUS_LAYOUT_PROPERTY
        Bound property name for continuousLayout.
        另请参见：
        Constant Field Values

      • DIVIDER_SIZE_PROPERTY

        public static final String DIVIDER_SIZE_PROPERTY
        Bound property name for border.
        另请参见：
        Constant Field Values

      • ONE_TOUCH_EXPANDABLE_PROPERTY

        public static final String ONE_TOUCH_EXPANDABLE_PROPERTY
        Bound property for oneTouchExpandable.
        另请参见：
        Constant Field Values

      • LAST_DIVIDER_LOCATION_PROPERTY

        public static final String LAST_DIVIDER_LOCATION_PROPERTY
        Bound property for lastLocation.
        另请参见：
        Constant Field Values

      • DIVIDER_LOCATION_PROPERTY

        public static final String DIVIDER_LOCATION_PROPERTY
        Bound property for the dividerLocation.
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • RESIZE_WEIGHT_PROPERTY

        public static final String RESIZE_WEIGHT_PROPERTY
        Bound property for weight.
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • orientation

        protected int orientation
        How the views are split.

      • continuousLayout

        protected boolean continuousLayout
        Whether or not the views are continuously redisplayed while resizing.

      • leftComponent

        protected Component leftComponent
        The left or top component.

      • rightComponent

        protected Component rightComponent
        The right or bottom component.

      • dividerSize

        protected int dividerSize
        Size of the divider.

      • oneTouchExpandable

        protected boolean oneTouchExpandable
        Is a little widget provided to quickly expand/collapse the split pane?

      • lastDividerLocation

        protected int lastDividerLocation
        Previous location of the split pane.

    • 构造方法详细信息

      • JSplitPane

        public JSplitPane()
        Creates a new JSplitPane configured to arrange the child components side-by-side horizontally, using two buttons for the components.

      • JSplitPane

        @ConstructorProperties(value="orientation")
public JSplitPane(int newOrientation)
        Creates a new JSplitPane configured with the specified orientation.
        参数：
        newOrientation - JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT
        抛出：
        IllegalArgumentException - if orientation is not one of HORIZONTAL_SPLIT or VERTICAL_SPLIT.

      • JSplitPane

        public JSplitPane(int newOrientation,
          boolean newContinuousLayout)
        Creates a new JSplitPane with the specified orientation and redrawing style.
        参数：
        newOrientation - JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT
        newContinuousLayout - a boolean, true for the components to redraw continuously as the divider changes position, false to wait until the divider position stops changing to redraw
        抛出：
        IllegalArgumentException - if orientation is not one of HORIZONTAL_SPLIT or VERTICAL_SPLIT

      • JSplitPane

        public JSplitPane(int newOrientation,
          Component newLeftComponent,
          Component newRightComponent)
        Creates a new JSplitPane with the specified orientation and the specified components.
        参数：
        newOrientation - JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT
        newLeftComponent - the Component that will appear on the left of a horizontally-split pane, or at the top of a vertically-split pane
        newRightComponent - the Component that will appear on the right of a horizontally-split pane, or at the bottom of a vertically-split pane
        抛出：
        IllegalArgumentException - if orientation is not one of: HORIZONTAL_SPLIT or VERTICAL_SPLIT

      • JSplitPane

        public JSplitPane(int newOrientation,
          boolean newContinuousLayout,
          Component newLeftComponent,
          Component newRightComponent)
        Creates a new JSplitPane with the specified orientation and redrawing style, and with the specified components.
        参数：
        newOrientation - JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT
        newContinuousLayout - a boolean, true for the components to redraw continuously as the divider changes position, false to wait until the divider position stops changing to redraw
        newLeftComponent - the Component that will appear on the left of a horizontally-split pane, or at the top of a vertically-split pane
        newRightComponent - the Component that will appear on the right of a horizontally-split pane, or at the bottom of a vertically-split pane
        抛出：
        IllegalArgumentException - if orientation is not one of HORIZONTAL_SPLIT or VERTICAL_SPLIT

    • 方法详细信息

      • setUI

        public void setUI(SplitPaneUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the SplitPaneUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getUI

        public SplitPaneUI getUI()
        Returns the SplitPaneUI that is providing the current look and feel.
        返回：
        the SplitPaneUI object that renders this component

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "SplitPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setDividerSize

        public void setDividerSize(int newSize)
        Sets the size of the divider.
        参数：
        newSize - an integer giving the size of the divider in pixels

      • getDividerSize

        public int getDividerSize()
        Returns the size of the divider.
        返回：
        an integer giving the size of the divider in pixels

      • setLeftComponent

        public void setLeftComponent(Component comp)
        Sets the component to the left (or above) the divider.
        参数：
        comp - the Component to display in that position

      • getLeftComponent

        public Component getLeftComponent()
        Returns the component to the left (or above) the divider.
        返回：
        the Component displayed in that position

      • setTopComponent

        public void setTopComponent(Component comp)
        Sets the component above, or to the left of the divider.
        参数：
        comp - the Component to display in that position

      • getTopComponent

        public Component getTopComponent()
        Returns the component above, or to the left of the divider.
        返回：
        the Component displayed in that position

      • setRightComponent

        public void setRightComponent(Component comp)
        Sets the component to the right (or below) the divider.
        参数：
        comp - the Component to display in that position

      • getRightComponent

        public Component getRightComponent()
        Returns the component to the right (or below) the divider.
        返回：
        the Component displayed in that position

      • setBottomComponent

        public void setBottomComponent(Component comp)
        Sets the component below, or to the right of the divider.
        参数：
        comp - the Component to display in that position

      • getBottomComponent

        public Component getBottomComponent()
        Returns the component below, or to the right of the divider.
        返回：
        the Component displayed in that position

      • setOneTouchExpandable

        public void setOneTouchExpandable(boolean newValue)
        Sets the value of the oneTouchExpandable property, which must be true for the JSplitPane to provide a UI widget on the divider to quickly expand/collapse the divider. The default value of this property is false. Some look and feels might not support one-touch expanding; they will ignore this property.
        参数：
        newValue - true to specify that the split pane should provide a collapse/expand widget
        另请参见：
        isOneTouchExpandable()

      • isOneTouchExpandable

        public boolean isOneTouchExpandable()
        Gets the oneTouchExpandable property.
        返回：
        the value of the oneTouchExpandable property
        另请参见：
        setOneTouchExpandable(boolean)

      • setLastDividerLocation

        public void setLastDividerLocation(int newLastLocation)
        Sets the last location the divider was at to newLastLocation.
        参数：
        newLastLocation - an integer specifying the last divider location in pixels, from the left (or upper) edge of the pane to the left (or upper) edge of the divider

      • getLastDividerLocation

        public int getLastDividerLocation()
        Returns the last location the divider was at.
        返回：
        an integer specifying the last divider location as a count of pixels from the left (or upper) edge of the pane to the left (or upper) edge of the divider

      • setOrientation

        public void setOrientation(int orientation)
        Sets the orientation, or how the splitter is divided. The options are:
        • JSplitPane.VERTICAL_SPLIT (above/below orientation of components)
        • JSplitPane.HORIZONTAL_SPLIT (left/right orientation of components)
        参数：
        orientation - an integer specifying the orientation
        抛出：
        IllegalArgumentException - if orientation is not one of: HORIZONTAL_SPLIT or VERTICAL_SPLIT.

      • getOrientation

        public int getOrientation()
        Returns the orientation.
        返回：
        an integer giving the orientation
        另请参见：
        setOrientation(int)

      • setContinuousLayout

        public void setContinuousLayout(boolean newContinuousLayout)
        Sets the value of the continuousLayout property, which must be true for the child components to be continuously redisplayed and laid out during user intervention. The default value of this property is false. Some look and feels might not support continuous layout; they will ignore this property.
        参数：
        newContinuousLayout - true if the components should continuously be redrawn as the divider changes position
        另请参见：
        isContinuousLayout()

      • isContinuousLayout

        public boolean isContinuousLayout()
        Gets the continuousLayout property.
        返回：
        the value of the continuousLayout property
        另请参见：
        setContinuousLayout(boolean)

      • setResizeWeight

        public void setResizeWeight(double value)
        Specifies how to distribute extra space when the size of the split pane changes. A value of 0, the default, indicates the right/bottom component gets all the extra space (the left/top component acts fixed), where as a value of 1 specifies the left/top component gets all the extra space (the right/bottom component acts fixed). Specifically, the left/top component gets (weight * diff) extra space and the right/bottom component gets (1 - weight) * diff extra space.
        参数：
        value - as described above
        抛出：
        IllegalArgumentException - if value is < 0 or > 1
        从以下版本开始：
        1.3

      • getResizeWeight

        public double getResizeWeight()
        Returns the number that determines how extra space is distributed.
        返回：
        how extra space is to be distributed on a resize of the split pane
        从以下版本开始：
        1.3

      • resetToPreferredSizes

        public void resetToPreferredSizes()
        Lays out the JSplitPane layout based on the preferred size of the children components. This will likely result in changing the divider location.

      • setDividerLocation

        public void setDividerLocation(double proportionalLocation)
        Sets the divider location as a percentage of the JSplitPane's size.

        This method is implemented in terms of setDividerLocation(int). This method immediately changes the size of the split pane based on its current size. If the split pane is not correctly realized and on screen, this method will have no effect (new divider location will become (current size * proportionalLocation) which is 0).

        参数：
        proportionalLocation - a double-precision floating point value that specifies a percentage, from zero (top/left) to 1.0 (bottom/right)
        抛出：
        IllegalArgumentException - if the specified location is < 0 or > 1.0

      • setDividerLocation

        public void setDividerLocation(int location)
        Sets the location of the divider. This is passed off to the look and feel implementation, and then listeners are notified. A value less than 0 implies the divider should be reset to a value that attempts to honor the preferred size of the left/top component. After notifying the listeners, the last divider location is updated, via setLastDividerLocation.
        参数：
        location - an int specifying a UI-specific value (typically a pixel count)

      • getDividerLocation

        public int getDividerLocation()
        Returns the last value passed to setDividerLocation. The value returned from this method may differ from the actual divider location (if setDividerLocation was passed a value bigger than the curent size).
        返回：
        an integer specifying the location of the divider

      • getMinimumDividerLocation

        public int getMinimumDividerLocation()
        Returns the minimum location of the divider from the look and feel implementation.
        返回：
        an integer specifying a UI-specific value for the minimum location (typically a pixel count); or -1 if the UI is null

      • getMaximumDividerLocation

        public int getMaximumDividerLocation()
        Returns the maximum location of the divider from the look and feel implementation.
        返回：
        an integer specifying a UI-specific value for the maximum location (typically a pixel count); or -1 if the UI is null

      • remove

        public void remove(Component component)
        Removes the child component, component from the pane. Resets the leftComponent or rightComponent instance variable, as necessary.
        重载：
        remove in class Container
        参数：
        component - the Component to remove
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.remove(int)

      • remove

        public void remove(int index)
        Removes the Component at the specified index. Updates the leftComponent and rightComponent instance variables as necessary, and then messages super.
        重载：
        remove in class Container
        参数：
        index - an integer specifying the component to remove, where 1 specifies the left/top component and 2 specifies the bottom/right component
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.validate(),
Container.getComponentCount()

      • removeAll

        public void removeAll()
        Removes all the child components from the split pane. Resets the leftComonent and rightComponent instance variables.
        重载：
        removeAll in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.remove(int),
Container.invalidate()

      • isValidateRoot

        public boolean isValidateRoot()
        Returns true, so that calls to revalidate on any descendant of this JSplitPane will cause a request to be queued that will validate the JSplitPane and all its descendants.
        重载：
        isValidateRoot in class JComponent
        返回：
        true
        另请参见：
        JComponent.revalidate(), Container.isValidateRoot()

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified component to this split pane. If constraints identifies the left/top or right/bottom child component, and a component with that identifier was previously added, it will be removed and then comp will be added in its place. If constraints is not one of the known identifiers the layout manager may throw an IllegalArgumentException.

        The possible constraints objects (Strings) are:

        • JSplitPane.TOP
        • JSplitPane.LEFT
        • JSplitPane.BOTTOM
        • JSplitPane.RIGHT
        If the constraints object is null, the component is added in the first available position (left/top if open, else right/bottom).
        重载：
        addImpl in class Container
        参数：
        comp - the component to add
        constraints - an Object specifying the layout constraints (position) for this component
        index - an integer specifying the index in the container's list.
        抛出：
        IllegalArgumentException - if the constraints object does not match an existing component
        另请参见：
        Container.addImpl(Component, Object, int)

      • paintChildren

        protected void paintChildren(Graphics g)
        Subclassed to message the UI with finishedPaintingChildren after super has been messaged, as well as painting the border.
        重载：
        paintChildren in class JComponent
        参数：
        g - the Graphics context within which to paint
        另请参见：
        JComponent.paint(java.awt.Graphics), Container.paint(java.awt.Graphics)

      • paramString

        protected String paramString()
        Returns a string representation of this JSplitPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JSplitPane.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JSplitPane. For split panes, the AccessibleContext takes the form of an AccessibleJSplitPane. A new AccessibleJSplitPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJSplitPane that serves as the AccessibleContext of this JSplitPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JSplitPane.AccessibleJSplitPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JSplitPane.AccessibleJSplitPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JSplitPane.AccessibleJSplitPane
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
    封闭类：
    JSplitPane

    protected class JSplitPane.AccessibleJSplitPane
extends JComponent.AccessibleJComponent
implements AccessibleValue
    This class implements accessibility support for the JSplitPane class. It provides an implementation of the Java Accessibility API appropriate to split pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JSplitPane.AccessibleJSplitPane()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleValue getAccessibleValue()
      Get the AccessibleValue associated with this object.
      Number getCurrentAccessibleValue()
      Gets the accessible value of this object.
      Number getMaximumAccessibleValue()
      Gets the maximum accessible value of this object.
      Number getMinimumAccessibleValue()
      Gets the minimum accessible value of this object.
      boolean setCurrentAccessibleValue(Number n)
      Sets the value of this object as a Number.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JSplitPane.AccessibleJSplitPane

        protected JSplitPane.AccessibleJSplitPane()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleState containing the current state of the object
        另请参见：
        AccessibleState

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Get the AccessibleValue associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleValue interface on behalf of itself.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleValue

      • getCurrentAccessibleValue

        public Number getCurrentAccessibleValue()
        Gets the accessible value of this object.
        指定者：
        getCurrentAccessibleValue in interface AccessibleValue
        返回：
        a localized String describing the value of this object
        另请参见：
        AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

      • setCurrentAccessibleValue

        public boolean setCurrentAccessibleValue(Number n)
        Sets the value of this object as a Number.
        指定者：
        setCurrentAccessibleValue in interface AccessibleValue
        返回：
        True if the value was set.
        另请参见：
        AccessibleValue.getCurrentAccessibleValue()

      • getMinimumAccessibleValue

        public Number getMinimumAccessibleValue()
        Gets the minimum accessible value of this object.
        指定者：
        getMinimumAccessibleValue in interface AccessibleValue
        返回：
        The minimum value of this object.
        另请参见：
        AccessibleValue.getMaximumAccessibleValue()

      • getMaximumAccessibleValue

        public Number getMaximumAccessibleValue()
        Gets the maximum accessible value of this object.
        指定者：
        getMaximumAccessibleValue in interface AccessibleValue
        返回：
        The maximum value of this object.
        另请参见：
        AccessibleValue.getMinimumAccessibleValue()

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsp.pn/on/tCC/ttv.>>h


JTabbedPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTabbedPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JTabbedPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants

    public class JTabbedPane
extends JComponent
implements Serializable, Accessible, SwingConstants
    A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon. For examples and information on using tabbed panes see How to Use Tabbed Panes, a section in The Java Tutorial.

    Tabs/components are added to a TabbedPane object by using the addTab and insertTab methods. A tab is represented by an index corresponding to the position it was added in, where the first tab has an index equal to 0 and the last tab has an index equal to the tab count minus 1.

    The TabbedPane uses a SingleSelectionModel to represent the set of tab indices and the currently selected index. If the tab count is greater than 0, then there will always be a selected index, which by default will be initialized to the first tab. If the tab count is 0, then the selected index will be -1.

    The tab title can be rendered by a Component. For example, the following produce similar results:

     // In this case the look and feel renders the title for the tab.
 tabbedPane.addTab("Tab", myComponent);
 // In this case the custom component is responsible for rendering the
 // title of the tab.
 tabbedPane.addTab(null, myComponent);
 tabbedPane.setTabComponentAt(0, new JLabel("Tab"));
    The latter is typically used when you want a more complex user interaction that requires custom components on the tab. For example, you could provide a custom component that animates or one that has widgets for closing the tab.

    If you specify a component for a tab, the JTabbedPane will not render any text or icon you have specified for the tab.

    Note: Do not use setVisible directly on a tab component to make it visible, use setSelectedComponent or setSelectedIndex methods instead.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    SingleSelectionModel

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTabbedPane.AccessibleJTabbedPane
      This class implements accessibility support for the JTabbedPane class.
      protected class  JTabbedPane.ModelListener
      We pass ModelChanged events along to the listeners with the tabbedpane (instead of the model itself) as the event source.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per TabPane instance since the event's only (read-only) state is the source property.
      protected ChangeListener changeListener
      The changeListener is the listener we add to the model.
      protected SingleSelectionModel model
      The default selection model
      static int SCROLL_TAB_LAYOUT
      Tab layout policy for providing a subset of available tabs when all the tabs will not fit within a single run.
      protected int tabPlacement
      Where the tabs are placed.
      static int WRAP_TAB_LAYOUT
      The tab layout policy for wrapping tabs in multiple runs when all tabs will not fit within a single run.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTabbedPane()
      Creates an empty TabbedPane with a default tab placement of JTabbedPane.TOP.
      JTabbedPane(int tabPlacement)
      Creates an empty TabbedPane with the specified tab placement of either: JTabbedPane.TOP, JTabbedPane.BOTTOM, JTabbedPane.LEFT, or JTabbedPane.RIGHT.
      JTabbedPane(int tabPlacement, int tabLayoutPolicy)
      Creates an empty TabbedPane with the specified tab placement and tab layout policy.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component add(Component component)
      Adds a component with a tab title defaulting to the name of the component which is the result of calling component.getName.
      Component add(Component component, int index)
      Adds a component at the specified tab index with a tab title defaulting to the name of the component.
      void add(Component component, Object constraints)
      Adds a component to the tabbed pane.
      void add(Component component, Object constraints, int index)
      Adds a component at the specified tab index.
      Component add(String title, Component component)
      Adds a component with the specified tab title.
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to this tabbedpane.
      void addTab(String title, Component component)
      Adds a component represented by a title and no icon.
      void addTab(String title, Icon icon, Component component)
      Adds a component represented by a title and/or icon, either of which can be null.
      void addTab(String title, Icon icon, Component component, String tip)
      Adds a component and tip represented by a title and/or icon, either of which can be null.
      protected ChangeListener createChangeListener()
      Subclasses that want to handle ChangeEvents differently can override this to return a subclass of ModelListener or another ChangeListener implementation.
      protected void fireStateChanged()
      Sends a ChangeEvent, with this JTabbedPane as the source, to each registered listener.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTabbedPane.
      Color getBackgroundAt(int index)
      Returns the tab background color at index.
      Rectangle getBoundsAt(int index)
      Returns the tab bounds at index.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this JTabbedPane with addChangeListener.
      Component getComponentAt(int index)
      Returns the component at index.
      Icon getDisabledIconAt(int index)
      Returns the tab disabled icon at index.
      int getDisplayedMnemonicIndexAt(int tabIndex)
      Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
      Color getForegroundAt(int index)
      Returns the tab foreground color at index.
      Icon getIconAt(int index)
      Returns the tab icon at index.
      int getMnemonicAt(int tabIndex)
      Returns the keyboard mnemonic for accessing the specified tab.
      SingleSelectionModel getModel()
      Returns the model associated with this tabbedpane.
      Component getSelectedComponent()
      Returns the currently selected component for this tabbedpane.
      int getSelectedIndex()
      Returns the currently selected index for this tabbedpane.
      Component getTabComponentAt(int index)
      Returns the tab component at index.
      int getTabCount()
      Returns the number of tabs in this tabbedpane.
      int getTabLayoutPolicy()
      Returns the policy used by the tabbedpane to layout the tabs when all the tabs will not fit within a single run.
      int getTabPlacement()
      Returns the placement of the tabs for this tabbedpane.
      int getTabRunCount()
      Returns the number of tab runs currently used to display the tabs.
      String getTitleAt(int index)
      Returns the tab title at index.
      String getToolTipText(MouseEvent event)
      Returns the tooltip text for the component determined by the mouse event location.
      String getToolTipTextAt(int index)
      Returns the tab tooltip text at index.
      TabbedPaneUI getUI()
      Returns the UI object which implements the L&F for this component.
      String getUIClassID()
      Returns the name of the UI class that implements the L&F for this component.
      int indexAtLocation(int x, int y)
      Returns the tab index corresponding to the tab whose bounds intersect the specified location.
      int indexOfComponent(Component component)
      Returns the index of the tab for the specified component.
      int indexOfTab(Icon icon)
      Returns the first tab index with a given icon, or -1 if no tab has this icon.
      int indexOfTab(String title)
      Returns the first tab index with a given title, or -1 if no tab has this title.
      int indexOfTabComponent(Component tabComponent)
      Returns the index of the tab for the specified tab component.
      void insertTab(String title, Icon icon, Component component, String tip, int index)
      Inserts a new tab for the given component, at the given index, represented by the given title and/or icon, either of which may be null.
      boolean isEnabledAt(int index)
      Returns whether or not the tab at index is currently enabled.
      protected String paramString()
      Returns a string representation of this JTabbedPane.
      void remove(Component component)
      Removes the specified Component from the JTabbedPane.
      void remove(int index)
      Removes the tab and component which corresponds to the specified index.
      void removeAll()
      Removes all the tabs and their corresponding components from the tabbedpane.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from this tabbedpane.
      void removeTabAt(int index)
      Removes the tab at index.
      void setBackgroundAt(int index, Color background)
      Sets the background color at index to background which can be null, in which case the tab's background color will default to the background color of the tabbedpane.
      void setComponentAt(int index, Component component)
      Sets the component at index to component.
      void setDisabledIconAt(int index, Icon disabledIcon)
      Sets the disabled icon at index to icon which can be null.
      void setDisplayedMnemonicIndexAt(int tabIndex, int mnemonicIndex)
      Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.
      void setEnabledAt(int index, boolean enabled)
      Sets whether or not the tab at index is enabled.
      void setForegroundAt(int index, Color foreground)
      Sets the foreground color at index to foreground which can be null, in which case the tab's foreground color will default to the foreground color of this tabbedpane.
      void setIconAt(int index, Icon icon)
      Sets the icon at index to icon which can be null.
      void setMnemonicAt(int tabIndex, int mnemonic)
      Sets the keyboard mnemonic for accessing the specified tab.
      void setModel(SingleSelectionModel model)
      Sets the model to be used with this tabbedpane.
      void setSelectedComponent(Component c)
      Sets the selected component for this tabbedpane.
      void setSelectedIndex(int index)
      Sets the selected index for this tabbedpane.
      void setTabComponentAt(int index, Component component)
      Sets the component that is responsible for rendering the title for the specified tab.
      void setTabLayoutPolicy(int tabLayoutPolicy)
      Sets the policy which the tabbedpane will use in laying out the tabs when all the tabs will not fit within a single run.
      void setTabPlacement(int tabPlacement)
      Sets the tab placement for this tabbedpane.
      void setTitleAt(int index, String title)
      Sets the title at index to title which can be null.
      void setToolTipTextAt(int index, String toolTipText)
      Sets the tooltip text at index to toolTipText which can be null.
      void setUI(TabbedPaneUI ui)
      Sets the UI object which implements the L&F for this component.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • WRAP_TAB_LAYOUT

        public static final int WRAP_TAB_LAYOUT
        The tab layout policy for wrapping tabs in multiple runs when all tabs will not fit within a single run.
        另请参见：
        Constant Field Values

      • SCROLL_TAB_LAYOUT

        public static final int SCROLL_TAB_LAYOUT
        Tab layout policy for providing a subset of available tabs when all the tabs will not fit within a single run. If all the tabs do not fit within a single run the look and feel will provide a way to navigate to hidden tabs.
        另请参见：
        Constant Field Values

      • tabPlacement

        protected int tabPlacement
        Where the tabs are placed.
        另请参见：
        setTabPlacement(int)

      • model

        protected SingleSelectionModel model
        The default selection model

      • changeListener

        protected ChangeListener changeListener
        The changeListener is the listener we add to the model.

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per TabPane instance since the event's only (read-only) state is the source property. The source of events generated here is always "this".

    • 构造方法详细信息

      • JTabbedPane

        public JTabbedPane()
        Creates an empty TabbedPane with a default tab placement of JTabbedPane.TOP.
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)

      • JTabbedPane

        public JTabbedPane(int tabPlacement)
        Creates an empty TabbedPane with the specified tab placement of either: JTabbedPane.TOP, JTabbedPane.BOTTOM, JTabbedPane.LEFT, or JTabbedPane.RIGHT.
        参数：
        tabPlacement - the placement for the tabs relative to the content
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)

      • JTabbedPane

        public JTabbedPane(int tabPlacement,
           int tabLayoutPolicy)
        Creates an empty TabbedPane with the specified tab placement and tab layout policy. Tab placement may be either: JTabbedPane.TOP, JTabbedPane.BOTTOM, JTabbedPane.LEFT, or JTabbedPane.RIGHT. Tab layout policy may be either: JTabbedPane.WRAP_TAB_LAYOUT or JTabbedPane.SCROLL_TAB_LAYOUT.
        参数：
        tabPlacement - the placement for the tabs relative to the content
        tabLayoutPolicy - the policy for laying out tabs when all tabs will not fit on one run
        抛出：
        IllegalArgumentException - if tab placement or tab layout policy are not one of the above supported values
        从以下版本开始：
        1.4
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)

    • 方法详细信息

      • getUI

        public TabbedPaneUI getUI()
        Returns the UI object which implements the L&F for this component.
        返回：
        a TabbedPaneUI object
        另请参见：
        setUI(javax.swing.plaf.TabbedPaneUI)

      • setUI

        public void setUI(TabbedPaneUI ui)
        Sets the UI object which implements the L&F for this component.
        参数：
        ui - the new UI object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the UI class that implements the L&F for this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "TabbedPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createChangeListener

        protected ChangeListener createChangeListener()
        Subclasses that want to handle ChangeEvents differently can override this to return a subclass of ModelListener or another ChangeListener implementation.
        另请参见：
        fireStateChanged()

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to this tabbedpane.
        参数：
        l - the ChangeListener to add
        另请参见：
        fireStateChanged(), removeChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from this tabbedpane.
        参数：
        l - the ChangeListener to remove
        另请参见：
        fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this JTabbedPane with addChangeListener.
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Sends a ChangeEvent, with this JTabbedPane as the source, to each registered listener. This method is called each time there is a change to either the selected index or the selected tab in the JTabbedPane. Usually, the selected index and selected tab change together. However, there are some cases, such as tab addition, where the selected index changes and the same tab remains selected. There are other cases, such as deleting the selected tab, where the index remains the same, but a new tab moves to that index. Events are fired for all of these cases.
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), EventListenerList

      • getModel

        public SingleSelectionModel getModel()
        Returns the model associated with this tabbedpane.
        另请参见：
        setModel(javax.swing.SingleSelectionModel)

      • setModel

        public void setModel(SingleSelectionModel model)
        Sets the model to be used with this tabbedpane.
        参数：
        model - the model to be used
        另请参见：
        getModel()

      • getTabPlacement

        public int getTabPlacement()
        Returns the placement of the tabs for this tabbedpane.
        另请参见：
        setTabPlacement(int)

      • setTabPlacement

        public void setTabPlacement(int tabPlacement)
        Sets the tab placement for this tabbedpane. Possible values are:
        • JTabbedPane.TOP
        • JTabbedPane.BOTTOM
        • JTabbedPane.LEFT
        • JTabbedPane.RIGHT
        The default value, if not set, is SwingConstants.TOP.
        参数：
        tabPlacement - the placement for the tabs relative to the content
        抛出：
        IllegalArgumentException - if tab placement value isn't one of the above valid values

      • getTabLayoutPolicy

        public int getTabLayoutPolicy()
        Returns the policy used by the tabbedpane to layout the tabs when all the tabs will not fit within a single run.
        从以下版本开始：
        1.4
        另请参见：
        setTabLayoutPolicy(int)

      • setTabLayoutPolicy

        public void setTabLayoutPolicy(int tabLayoutPolicy)
        Sets the policy which the tabbedpane will use in laying out the tabs when all the tabs will not fit within a single run. Possible values are:
        • JTabbedPane.WRAP_TAB_LAYOUT
        • JTabbedPane.SCROLL_TAB_LAYOUT
        The default value, if not set by the UI, is JTabbedPane.WRAP_TAB_LAYOUT.

        Some look and feels might only support a subset of the possible layout policies, in which case the value of this property may be ignored.

        参数：
        tabLayoutPolicy - the policy used to layout the tabs
        抛出：
        IllegalArgumentException - if layoutPolicy value isn't one of the above valid values
        从以下版本开始：
        1.4
        另请参见：
        getTabLayoutPolicy()

      • getSelectedIndex

        public int getSelectedIndex()
        Returns the currently selected index for this tabbedpane. Returns -1 if there is no currently selected tab.
        返回：
        the index of the selected tab
        另请参见：
        setSelectedIndex(int)

      • setSelectedIndex

        public void setSelectedIndex(int index)
        Sets the selected index for this tabbedpane. The index must be a valid tab index or -1, which indicates that no tab should be selected (can also be used when there are no tabs in the tabbedpane). If a -1 value is specified when the tabbedpane contains one or more tabs, then the results will be implementation defined.
        参数：
        index - the index to be selected
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < -1 || index >= tab count)
        另请参见：
        getSelectedIndex(), SingleSelectionModel.setSelectedIndex(int)

      • getSelectedComponent

        public Component getSelectedComponent()
        Returns the currently selected component for this tabbedpane. Returns null if there is no currently selected tab.
        返回：
        the component corresponding to the selected tab
        另请参见：
        setSelectedComponent(java.awt.Component)

      • setSelectedComponent

        public void setSelectedComponent(Component c)
        Sets the selected component for this tabbedpane. This will automatically set the selectedIndex to the index corresponding to the specified component.
        抛出：
        IllegalArgumentException - if component not found in tabbed pane
        另请参见：
        getSelectedComponent()

      • insertTab

        public void insertTab(String title,
             Icon icon,
             Component component,
             String tip,
             int index)
        Inserts a new tab for the given component, at the given index, represented by the given title and/or icon, either of which may be null.
        参数：
        title - the title to be displayed on the tab
        icon - the icon to be displayed on the tab
        component - the component to be displayed when this tab is clicked.
        tip - the tooltip to be displayed for this tab
        index - the position to insert this new tab (> 0 and <= getTabCount())
        抛出：
        IndexOutOfBoundsException - if the index is out of range (< 0 or > getTabCount())
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

      • addTab

        public void addTab(String title,
          Icon icon,
          Component component,
          String tip)
        Adds a component and tip represented by a title and/or icon, either of which can be null. Cover method for insertTab.
        参数：
        title - the title to be displayed in this tab
        icon - the icon to be displayed in this tab
        component - the component to be displayed when this tab is clicked
        tip - the tooltip to be displayed for this tab
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • addTab

        public void addTab(String title,
          Icon icon,
          Component component)
        Adds a component represented by a title and/or icon, either of which can be null. Cover method for insertTab.
        参数：
        title - the title to be displayed in this tab
        icon - the icon to be displayed in this tab
        component - the component to be displayed when this tab is clicked
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • addTab

        public void addTab(String title,
          Component component)
        Adds a component represented by a title and no icon. Cover method for insertTab.
        参数：
        title - the title to be displayed in this tab
        component - the component to be displayed when this tab is clicked
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • add

        public Component add(Component component)
        Adds a component with a tab title defaulting to the name of the component which is the result of calling component.getName. Cover method for insertTab.
        重载：
        add in class Container
        参数：
        component - the component to be displayed when this tab is clicked
        返回：
        the component
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • add

        public Component add(String title,
            Component component)
        Adds a component with the specified tab title. Cover method for insertTab.
        重载：
        add in class Container
        参数：
        title - the title to be displayed in this tab
        component - the component to be displayed when this tab is clicked
        返回：
        the component
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • add

        public Component add(Component component,
            int index)
        Adds a component at the specified tab index with a tab title defaulting to the name of the component. Cover method for insertTab.
        重载：
        add in class Container
        参数：
        component - the component to be displayed when this tab is clicked
        index - the position to insert this new tab
        返回：
        the component
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • add

        public void add(Component component,
       Object constraints)
        Adds a component to the tabbed pane. If constraints is a String or an Icon, it will be used for the tab title, otherwise the component's name will be used as the tab title. Cover method for insertTab.
        重载：
        add in class Container
        参数：
        component - the component to be displayed when this tab is clicked
        constraints - the object to be displayed in the tab
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • add

        public void add(Component component,
       Object constraints,
       int index)
        Adds a component at the specified tab index. If constraints is a String or an Icon, it will be used for the tab title, otherwise the component's name will be used as the tab title. Cover method for insertTab.
        重载：
        add in class Container
        参数：
        component - the component to be displayed when this tab is clicked
        constraints - the object to be displayed in the tab
        index - the position to insert this new tab
        另请参见：
        insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

      • removeTabAt

        public void removeTabAt(int index)
        Removes the tab at index. After the component associated with index is removed, its visibility is reset to true to ensure it will be visible if added to other containers.
        参数：
        index - the index of the tab to be removed
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int)

      • remove

        public void remove(Component component)
        Removes the specified Component from the JTabbedPane. The method does nothing if the component is null.
        重载：
        remove in class Container
        参数：
        component - the component to remove from the tabbedpane
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

      • remove

        public void remove(int index)
        Removes the tab and component which corresponds to the specified index.
        重载：
        remove in class Container
        参数：
        index - the index of the component to remove from the tabbedpane
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

      • removeAll

        public void removeAll()
        Removes all the tabs and their corresponding components from the tabbedpane.
        重载：
        removeAll in class Container
        另请参见：
        addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

      • getTabCount

        public int getTabCount()
        Returns the number of tabs in this tabbedpane.
        返回：
        an integer specifying the number of tabbed pages

      • getTabRunCount

        public int getTabRunCount()
        Returns the number of tab runs currently used to display the tabs.
        返回：
        an integer giving the number of rows if the tabPlacement is TOP or BOTTOM and the number of columns if tabPlacement is LEFT or RIGHT, or 0 if there is no UI set on this tabbedpane

      • getTitleAt

        public String getTitleAt(int index)
        Returns the tab title at index.
        参数：
        index - the index of the item being queried
        返回：
        the title at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setTitleAt(int, java.lang.String)

      • getIconAt

        public Icon getIconAt(int index)
        Returns the tab icon at index.
        参数：
        index - the index of the item being queried
        返回：
        the icon at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setIconAt(int, javax.swing.Icon)

      • getDisabledIconAt

        public Icon getDisabledIconAt(int index)
        Returns the tab disabled icon at index. If the tab disabled icon doesn't exist at index this will forward the call to the look and feel to construct an appropriate disabled Icon from the corresponding enabled Icon. Some look and feels might not render the disabled Icon, in which case it won't be created.
        参数：
        index - the index of the item being queried
        返回：
        the icon at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setDisabledIconAt(int, javax.swing.Icon)

      • getToolTipTextAt

        public String getToolTipTextAt(int index)
        Returns the tab tooltip text at index.
        参数：
        index - the index of the item being queried
        返回：
        a string containing the tool tip text at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        从以下版本开始：
        1.3
        另请参见：
        setToolTipTextAt(int, java.lang.String)

      • getBackgroundAt

        public Color getBackgroundAt(int index)
        Returns the tab background color at index.
        参数：
        index - the index of the item being queried
        返回：
        the Color of the tab background at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setBackgroundAt(int, java.awt.Color)

      • getForegroundAt

        public Color getForegroundAt(int index)
        Returns the tab foreground color at index.
        参数：
        index - the index of the item being queried
        返回：
        the Color of the tab foreground at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setForegroundAt(int, java.awt.Color)

      • isEnabledAt

        public boolean isEnabledAt(int index)
        Returns whether or not the tab at index is currently enabled.
        参数：
        index - the index of the item being queried
        返回：
        true if the tab at index is enabled; false otherwise
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setEnabledAt(int, boolean)

      • getComponentAt

        public Component getComponentAt(int index)
        Returns the component at index.
        参数：
        index - the index of the item being queried
        返回：
        the Component at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setComponentAt(int, java.awt.Component)

      • getMnemonicAt

        public int getMnemonicAt(int tabIndex)
        Returns the keyboard mnemonic for accessing the specified tab. The mnemonic is the key which when combined with the look and feel's mouseless modifier (usually Alt) will activate the specified tab.
        参数：
        tabIndex - the index of the tab that the mnemonic refers to
        返回：
        the key code which represents the mnemonic; -1 if a mnemonic is not specified for the tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (tabIndex < 0 || tabIndex >= tab count)
        从以下版本开始：
        1.4
        另请参见：
        setDisplayedMnemonicIndexAt(int,int), setMnemonicAt(int,int)

      • getDisplayedMnemonicIndexAt

        public int getDisplayedMnemonicIndexAt(int tabIndex)
        Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.
        参数：
        tabIndex - the index of the tab that the mnemonic refers to
        返回：
        index representing mnemonic character if one exists; otherwise returns -1
        抛出：
        IndexOutOfBoundsException - if index is out of range (tabIndex < 0 || tabIndex >= tab count)
        从以下版本开始：
        1.4
        另请参见：
        setDisplayedMnemonicIndexAt(int,int), setMnemonicAt(int,int)

      • getBoundsAt

        public Rectangle getBoundsAt(int index)
        Returns the tab bounds at index. If the tab at this index is not currently visible in the UI, then returns null. If there is no UI set on this tabbedpane, then returns null.
        参数：
        index - the index to be queried
        返回：
        a Rectangle containing the tab bounds at index, or null if tab at index is not currently visible in the UI, or if there is no UI set on this tabbedpane
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)

      • setTitleAt

        public void setTitleAt(int index,
              String title)
        Sets the title at index to title which can be null. The title is not shown if a tab component for this tab was specified. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index where the title should be set
        title - the title to be displayed in the tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        getTitleAt(int), setTabComponentAt(int, java.awt.Component)

      • setIconAt

        public void setIconAt(int index,
             Icon icon)
        Sets the icon at index to icon which can be null. This does not set disabled icon at icon. If the new Icon is different than the current Icon and disabled icon is not explicitly set, the LookAndFeel will be asked to generate a disabled Icon. To explicitly set disabled icon, use setDisableIconAt(). The icon is not shown if a tab component for this tab was specified. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index where the icon should be set
        icon - the icon to be displayed in the tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        setDisabledIconAt(int, javax.swing.Icon), getIconAt(int), getDisabledIconAt(int), setTabComponentAt(int, java.awt.Component)

      • setDisabledIconAt

        public void setDisabledIconAt(int index,
                     Icon disabledIcon)
        Sets the disabled icon at index to icon which can be null. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index where the disabled icon should be set
        disabledIcon - the icon to be displayed in the tab when disabled
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        getDisabledIconAt(int)

      • setToolTipTextAt

        public void setToolTipTextAt(int index,
                    String toolTipText)
        Sets the tooltip text at index to toolTipText which can be null. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index where the tooltip text should be set
        toolTipText - the tooltip text to be displayed for the tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        从以下版本开始：
        1.3
        另请参见：
        getToolTipTextAt(int)

      • setBackgroundAt

        public void setBackgroundAt(int index,
                   Color background)
        Sets the background color at index to background which can be null, in which case the tab's background color will default to the background color of the tabbedpane. An internal exception is raised if there is no tab at that index.

        It is up to the look and feel to honor this property, some may choose to ignore it.

        参数：
        index - the tab index where the background should be set
        background - the color to be displayed in the tab's background
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        getBackgroundAt(int)

      • setForegroundAt

        public void setForegroundAt(int index,
                   Color foreground)
        Sets the foreground color at index to foreground which can be null, in which case the tab's foreground color will default to the foreground color of this tabbedpane. An internal exception is raised if there is no tab at that index.

        It is up to the look and feel to honor this property, some may choose to ignore it.

        参数：
        index - the tab index where the foreground should be set
        foreground - the color to be displayed as the tab's foreground
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        getForegroundAt(int)

      • setEnabledAt

        public void setEnabledAt(int index,
                boolean enabled)
        Sets whether or not the tab at index is enabled. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index which should be enabled/disabled
        enabled - whether or not the tab should be enabled
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        isEnabledAt(int)

      • setComponentAt

        public void setComponentAt(int index,
                  Component component)
        Sets the component at index to component. An internal exception is raised if there is no tab at that index.
        参数：
        index - the tab index where this component is being placed
        component - the component for the tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        另请参见：
        getComponentAt(int)

      • setDisplayedMnemonicIndexAt

        public void setDisplayedMnemonicIndexAt(int tabIndex,
                               int mnemonicIndex)
        Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic. Not all look and feels may support this. A value of -1 indicates either there is no mnemonic for this tab, or you do not wish the mnemonic to be displayed for this tab.

        The value of this is updated as the properties relating to the mnemonic change (such as the mnemonic itself, the text...). You should only ever have to call this if you do not wish the default character to be underlined. For example, if the text at tab index 3 was 'Apple Price', with a mnemonic of 'p', and you wanted the 'P' to be decorated, as 'Apple Price', you would have to invoke setDisplayedMnemonicIndex(3, 6) after invoking setMnemonicAt(3, KeyEvent.VK_P).

        Note that it is the programmer's responsibility to ensure that each tab has a unique mnemonic or unpredictable results may occur.

        参数：
        tabIndex - the index of the tab that the mnemonic refers to
        mnemonicIndex - index into the String to underline
        抛出：
        IndexOutOfBoundsException - if tabIndex is out of range (tabIndex < 0 || tabIndex >= tab count)
        IllegalArgumentException - will be thrown if mnemonicIndex is >= length of the tab title , or < -1
        从以下版本开始：
        1.4
        另请参见：
        setMnemonicAt(int,int), getDisplayedMnemonicIndexAt(int)

      • setMnemonicAt

        public void setMnemonicAt(int tabIndex,
                 int mnemonic)
        Sets the keyboard mnemonic for accessing the specified tab. The mnemonic is the key which when combined with the look and feel's mouseless modifier (usually Alt) will activate the specified tab.

        A mnemonic must correspond to a single key on the keyboard and should be specified using one of the VK_XXX keycodes defined in java.awt.event.KeyEvent or one of the extended keycodes obtained through java.awt.event.KeyEvent.getExtendedKeyCodeForChar. Mnemonics are case-insensitive, therefore a key event with the corresponding keycode would cause the button to be activated whether or not the Shift modifier was pressed.

        This will update the displayed mnemonic property for the specified tab.

        参数：
        tabIndex - the index of the tab that the mnemonic refers to
        mnemonic - the key code which represents the mnemonic
        抛出：
        IndexOutOfBoundsException - if tabIndex is out of range (tabIndex < 0 || tabIndex >= tab count)
        从以下版本开始：
        1.4
        另请参见：
        getMnemonicAt(int), setDisplayedMnemonicIndexAt(int,int)

      • indexOfTab

        public int indexOfTab(String title)
        Returns the first tab index with a given title, or -1 if no tab has this title.
        参数：
        title - the title for the tab
        返回：
        the first tab index which matches title, or -1 if no tab has this title

      • indexOfTab

        public int indexOfTab(Icon icon)
        Returns the first tab index with a given icon, or -1 if no tab has this icon.
        参数：
        icon - the icon for the tab
        返回：
        the first tab index which matches icon, or -1 if no tab has this icon

      • indexOfComponent

        public int indexOfComponent(Component component)
        Returns the index of the tab for the specified component. Returns -1 if there is no tab for this component.
        参数：
        component - the component for the tab
        返回：
        the first tab which matches this component, or -1 if there is no tab for this component

      • indexAtLocation

        public int indexAtLocation(int x,
                  int y)
        Returns the tab index corresponding to the tab whose bounds intersect the specified location. Returns -1 if no tab intersects the location.
        参数：
        x - the x location relative to this tabbedpane
        y - the y location relative to this tabbedpane
        返回：
        the tab index which intersects the location, or -1 if no tab intersects the location
        从以下版本开始：
        1.4

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Returns the tooltip text for the component determined by the mouse event location.
        重载：
        getToolTipText in class JComponent
        参数：
        event - the MouseEvent that tells where the cursor is lingering
        返回：
        the String containing the tooltip text

      • paramString

        protected String paramString()
        Returns a string representation of this JTabbedPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JTabbedPane.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTabbedPane. For tabbed panes, the AccessibleContext takes the form of an AccessibleJTabbedPane. A new AccessibleJTabbedPane instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJTabbedPane that serves as the AccessibleContext of this JTabbedPane

      • setTabComponentAt

        public void setTabComponentAt(int index,
                     Component component)
        Sets the component that is responsible for rendering the title for the specified tab. A null value means JTabbedPane will render the title and/or icon for the specified tab. A non-null value means the component will render the title and JTabbedPane will not render the title and/or icon.

        Note: The component must not be one that the developer has already added to the tabbed pane.

        参数：
        index - the tab index where the component should be set
        component - the component to render the title for the specified tab
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        IllegalArgumentException - if component has already been added to this JTabbedPane
        从以下版本开始：
        1.6
        另请参见：
        getTabComponentAt(int)

      • getTabComponentAt

        public Component getTabComponentAt(int index)
        Returns the tab component at index.
        参数：
        index - the index of the item being queried
        返回：
        the tab component at index
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        从以下版本开始：
        1.6
        另请参见：
        setTabComponentAt(int, java.awt.Component)

      • indexOfTabComponent

        public int indexOfTabComponent(Component tabComponent)
        Returns the index of the tab for the specified tab component. Returns -1 if there is no tab for this tab component.
        参数：
        tabComponent - the tab component for the tab
        返回：
        the first tab which matches this tab component, or -1 if there is no tab for this tab component
        从以下版本开始：
        1.6
        另请参见：
        setTabComponentAt(int, java.awt.Component), getTabComponentAt(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTabbedPane.AccessibleJTabbedPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTabbedPane.AccessibleJTabbedPane

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JTabbedPane.AccessibleJTabbedPane
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, ChangeListener
    封闭类：
    JTabbedPane

    protected class JTabbedPane.AccessibleJTabbedPane
extends JComponent.AccessibleJComponent
implements AccessibleSelection, ChangeListener
    This class implements accessibility support for the JTabbedPane class. It provides an implementation of the Java Accessibility API appropriate to tabbed pane user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTabbedPane.AccessibleJTabbedPane()
      Constructs an AccessibleJTabbedPane

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified Accessible child of the object to the object's selection.
      void clearAccessibleSelection()
      Clears the selection in the object, so that no children in the object are selected.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child contained at the local coordinate Point, if one exists.
      Accessible getAccessibleChild(int i)
      Return the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      String getAccessibleName()
      Returns the accessible name of this object, or null if there is no accessible name.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Gets the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected child of the object.
      int getAccessibleSelectionCount()
      Returns the number of Accessible children currently selected.
      boolean isAccessibleChildSelected(int i)
      Determines if the current child of this object is selected.
      void removeAccessibleSelection(int i)
      Removes the specified child of the object from the object's selection.
      void selectAllAccessibleSelection()
      Causes every child of the object to be selected if the object supports multiple selections.
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTabbedPane.AccessibleJTabbedPane

        public JTabbedPane.AccessibleJTabbedPane()
        Constructs an AccessibleJTabbedPane

    • 方法详细信息

      • getAccessibleName

        public String getAccessibleName()
        Returns the accessible name of this object, or null if there is no accessible name.
        重载：
        getAccessibleName in class JComponent.AccessibleJComponent
        返回：
        the accessible name of this object, nor null.
        从以下版本开始：
        1.6
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Return the specified Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        抛出：
        IllegalArgumentException - if index is out of bounds
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Gets the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, returns this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child contained at the local coordinate Point, if one exists. Otherwise returns the currently selected tab.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - the point defining the top-left corner of the Accessible, given in the coordinate space of the object's parent
        返回：
        the Accessible at the specified location, if it exists

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        从接口复制的描述： AccessibleSelection
        Returns the number of Accessible children currently selected. If no children are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected.

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        从接口复制的描述： AccessibleSelection
        Returns an Accessible representing the specified selected child of the object. If there isn't a selection, or there are fewer children selected than the integer passed in, the return value will be null.

        Note that the index represents the i-th selected child, which is different from the i-th child.

        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected children
        返回：
        the i-th selected child
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        从接口复制的描述： AccessibleSelection
        Determines if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        从接口复制的描述： AccessibleSelection
        Adds the specified Accessible child of the object to the object's selection. If the object supports multiple selections, the specified child is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified child is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        从接口复制的描述： AccessibleSelection
        Removes the specified child of the object from the object's selection. If the specified item isn't currently selected, this method has no effect.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        从接口复制的描述： AccessibleSelection
        Clears the selection in the object, so that no children in the object are selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        从接口复制的描述： AccessibleSelection
        Causes every child of the object to be selected if the object supports multiple selections.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

unt.(afjafiiifiiulooni(uva aixvtnjwai.//MnaJJvooebu>


JTabbedPane.ModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTabbedPane.ModelListener

  • java.lang.Object
    • javax.swing.JTabbedPane.ModelListener
  • 所有已实现的接口：
    Serializable, EventListener, ChangeListener
    封闭类：
    JTabbedPane

    protected class JTabbedPane.ModelListener
extends Object
implements ChangeListener, Serializable
    We pass ModelChanged events along to the listeners with the tabbedpane (instead of the model itself) as the event source.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTabbedPane.ModelListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTabbedPane.ModelListener

        protected JTabbedPane.ModelListener()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hrtslloosrtv >>cnJ


JTable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTable

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JTable
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, EventListener, Accessible, CellEditorListener, ListSelectionListener, RowSorterListener, TableColumnModelListener, TableModelListener, Scrollable

    public class JTable
extends JComponent
implements TableModelListener, Scrollable, TableColumnModelListener, ListSelectionListener, CellEditorListener, Accessible, RowSorterListener
    The JTable is used to display and edit regular two-dimensional tables of cells. See How to Use Tables in The Java Tutorial for task-oriented documentation and examples of using JTable.

    The JTable has many facilities that make it possible to customize its rendering and editing but provides defaults for these features so that simple tables can be set up easily. For example, to set up a table with 10 rows and 10 columns of numbers:

          TableModel dataModel = new AbstractTableModel() {
          public int getColumnCount() { return 10; }
          public int getRowCount() { return 10;}
          public Object getValueAt(int row, int col) { return new Integer(row*col); }
      };
      JTable table = new JTable(dataModel);
      JScrollPane scrollpane = new JScrollPane(table);

    JTables are typically placed inside of a JScrollPane. By default, a JTable will adjust its width such that a horizontal scrollbar is unnecessary. To allow for a horizontal scrollbar, invoke setAutoResizeMode(int) with AUTO_RESIZE_OFF. Note that if you wish to use a JTable in a standalone view (outside of a JScrollPane) and want the header displayed, you can get it using getTableHeader() and display it separately.

    To enable sorting and filtering of rows, use a RowSorter. You can set up a row sorter in either of two ways:

    • Directly set the RowSorter. For example: table.setRowSorter(new TableRowSorter(model)).
    • Set the autoCreateRowSorter property to true, so that the JTable creates a RowSorter for you. For example: setAutoCreateRowSorter(true).

    When designing applications that use the JTable it is worth paying close attention to the data structures that will represent the table's data. The DefaultTableModel is a model implementation that uses a Vector of Vectors of Objects to store the cell values. As well as copying the data from an application into the DefaultTableModel, it is also possible to wrap the data in the methods of the TableModel interface so that the data can be passed to the JTable directly, as in the example above. This often results in more efficient applications because the model is free to choose the internal representation that best suits the data. A good rule of thumb for deciding whether to use the AbstractTableModel or the DefaultTableModel is to use the AbstractTableModel as the base class for creating subclasses and the DefaultTableModel when subclassing is not required.

    The "TableExample" directory in the demo area of the source distribution gives a number of complete examples of JTable usage, covering how the JTable can be used to provide an editable view of data taken from a database and how to modify the columns in the display to use specialized renderers and editors.

    The JTable uses integers exclusively to refer to both the rows and the columns of the model that it displays. The JTable simply takes a tabular range of cells and uses getValueAt(int, int) to retrieve the values from the model during painting. It is important to remember that the column and row indexes returned by various JTable methods are in terms of the JTable (the view) and are not necessarily the same indexes used by the model.

    By default, columns may be rearranged in the JTable so that the view's columns appear in a different order to the columns in the model. This does not affect the implementation of the model at all: when the columns are reordered, the JTable maintains the new order of the columns internally and converts its column indices before querying the model.

    So, when writing a TableModel, it is not necessary to listen for column reordering events as the model will be queried in its own coordinate system regardless of what is happening in the view. In the examples area there is a demonstration of a sorting algorithm making use of exactly this technique to interpose yet another coordinate system where the order of the rows is changed, rather than the order of the columns.

    Similarly when using the sorting and filtering functionality provided by RowSorter the underlying TableModel does not need to know how to do sorting, rather RowSorter will handle it. Coordinate conversions will be necessary when using the row based methods of JTable with the underlying TableModel. All of JTables row based methods are in terms of the RowSorter, which is not necessarily the same as that of the underlying TableModel. For example, the selection is always in terms of JTable so that when using RowSorter you will need to convert using convertRowIndexToView or convertRowIndexToModel. The following shows how to convert coordinates from JTable to that of the underlying model:

       int[] selection = table.getSelectedRows();
   for (int i = 0; i < selection.length; i++) {
     selection[i] = table.convertRowIndexToModel(selection[i]);
   }
   // selection is now in terms of the underlying TableModel

    By default if sorting is enabled JTable will persist the selection and variable row heights in terms of the model on sorting. For example if row 0, in terms of the underlying model, is currently selected, after the sort row 0, in terms of the underlying model will be selected. Visually the selection may change, but in terms of the underlying model it will remain the same. The one exception to that is if the model index is no longer visible or was removed. For example, if row 0 in terms of model was filtered out the selection will be empty after the sort.

    J2SE 5 adds methods to JTable to provide convenient access to some common printing needs. Simple new print() methods allow for quick and easy addition of printing support to your application. In addition, a new getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat) method is available for more advanced printing needs.

    As for all JComponent classes, you can use InputMap and ActionMap to associate an Action object with a KeyStroke and execute the action under specified conditions.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultTableModel, TableRowSorter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.
      static class  JTable.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
      static class  JTable.PrintMode
      Printing modes, used in printing JTables.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int AUTO_RESIZE_ALL_COLUMNS
      During all resize operations, proportionately resize all columns.
      static int AUTO_RESIZE_LAST_COLUMN
      During all resize operations, apply adjustments to the last column only.
      static int AUTO_RESIZE_NEXT_COLUMN
      When a column is adjusted in the UI, adjust the next column the opposite way.
      static int AUTO_RESIZE_OFF
      Do not adjust column widths automatically; use a horizontal scrollbar instead.
      static int AUTO_RESIZE_SUBSEQUENT_COLUMNS
      During UI adjustment, change subsequent columns to preserve the total width; this is the default behavior.
      protected boolean autoCreateColumnsFromModel
      The table will query the TableModel to build the default set of columns if this is true.
      protected int autoResizeMode
      Determines if the table automatically resizes the width of the table's columns to take up the entire width of the table, and how it does the resizing.
      protected TableCellEditor cellEditor
      The active cell editor object, that overwrites the screen real estate occupied by the current cell and allows the user to change its contents.
      protected boolean cellSelectionEnabled
      Obsolete as of Java 2 platform v1.3.
      protected TableColumnModel columnModel
      The TableColumnModel of the table.
      protected TableModel dataModel
      The TableModel of the table.
      protected Hashtable defaultEditorsByColumnClass
      A table of objects that display and edit the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
      protected Hashtable defaultRenderersByColumnClass
      A table of objects that display the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
      protected int editingColumn
      Identifies the column of the cell being edited.
      protected int editingRow
      Identifies the row of the cell being edited.
      protected Component editorComp
      If editing, the Component that is handling the editing.
      protected Color gridColor
      The color of the grid.
      protected Dimension preferredViewportSize
      Used by the Scrollable interface to determine the initial visible area.
      protected int rowHeight
      The height in pixels of each row in the table.
      protected int rowMargin
      The height in pixels of the margin between the cells in each row.
      protected boolean rowSelectionAllowed
      True if row selection is allowed in this table.
      protected Color selectionBackground
      The background color of selected cells.
      protected Color selectionForeground
      The foreground color of selected cells.
      protected ListSelectionModel selectionModel
      The ListSelectionModel of the table, used to keep track of row selections.
      protected boolean showHorizontalLines
      The table draws horizontal lines between cells if showHorizontalLines is true.
      protected boolean showVerticalLines
      The table draws vertical lines between cells if showVerticalLines is true.
      protected JTableHeader tableHeader
      The TableHeader working with the table.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTable()
      Constructs a default JTable that is initialized with a default data model, a default column model, and a default selection model.
      JTable(int numRows, int numColumns)
      Constructs a JTable with numRows and numColumns of empty cells using DefaultTableModel.
      JTable(Object[][] rowData, Object[] columnNames)
      Constructs a JTable to display the values in the two dimensional array, rowData, with column names, columnNames.
      JTable(TableModel dm)
      Constructs a JTable that is initialized with dm as the data model, a default column model, and a default selection model.
      JTable(TableModel dm, TableColumnModel cm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and a default selection model.
      JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model.
      JTable(Vector rowData, Vector columnNames)
      Constructs a JTable to display the values in the Vector of Vectors, rowData, with column names, columnNames.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addColumn(TableColumn aColumn)
      Appends aColumn to the end of the array of columns held by this JTable's column model.
      void addColumnSelectionInterval(int index0, int index1)
      Adds the columns from index0 to index1, inclusive, to the current selection.
      void addNotify()
      Calls the configureEnclosingScrollPane method.
      void addRowSelectionInterval(int index0, int index1)
      Adds the rows from index0 to index1, inclusive, to the current selection.
      void changeSelection(int rowIndex, int columnIndex, boolean toggle, boolean extend)
      Updates the selection models of the table, depending on the state of the two flags: toggle and extend.
      void clearSelection()
      Deselects all selected columns and rows.
      void columnAdded(TableColumnModelEvent e)
      Invoked when a column is added to the table column model.
      int columnAtPoint(Point point)
      Returns the index of the column that point lies in, or -1 if the result is not in the range [0, getColumnCount()-1].
      void columnMarginChanged(ChangeEvent e)
      Invoked when a column is moved due to a margin change.
      void columnMoved(TableColumnModelEvent e)
      Invoked when a column is repositioned.
      void columnRemoved(TableColumnModelEvent e)
      Invoked when a column is removed from the table column model.
      void columnSelectionChanged(ListSelectionEvent e)
      Invoked when the selection model of the TableColumnModel is changed.
      protected void configureEnclosingScrollPane()
      If this JTable is the viewportView of an enclosing JScrollPane (the usual situation), configure this ScrollPane by, amongst other things, installing the table's tableHeader as the columnHeaderView of the scroll pane.
      int convertColumnIndexToModel(int viewColumnIndex)
      Maps the index of the column in the view at viewColumnIndex to the index of the column in the table model.
      int convertColumnIndexToView(int modelColumnIndex)
      Maps the index of the column in the table model at modelColumnIndex to the index of the column in the view.
      int convertRowIndexToModel(int viewRowIndex)
      Maps the index of the row in terms of the view to the underlying TableModel.
      int convertRowIndexToView(int modelRowIndex)
      Maps the index of the row in terms of the TableModel to the view.
      protected TableColumnModel createDefaultColumnModel()
      Returns the default column model object, which is a DefaultTableColumnModel.
      void createDefaultColumnsFromModel()
      Creates default columns for the table from the data model using the getColumnCount method defined in the TableModel interface.
      protected TableModel createDefaultDataModel()
      Returns the default table model object, which is a DefaultTableModel.
      protected void createDefaultEditors()
      Creates default cell editors for objects, numbers, and boolean values.
      protected void createDefaultRenderers()
      Creates default cell renderers for objects, numbers, doubles, dates, booleans, and icons.
      protected ListSelectionModel createDefaultSelectionModel()
      Returns the default selection model object, which is a DefaultListSelectionModel.
      protected JTableHeader createDefaultTableHeader()
      Returns the default table header object, which is a JTableHeader.
      static JScrollPane createScrollPaneForTable(JTable aTable)
      Deprecated.
      As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
      void doLayout()
      Causes this table to lay out its rows and columns.
      boolean editCellAt(int row, int column)
      Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
      boolean editCellAt(int row, int column, EventObject e)
      Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
      void editingCanceled(ChangeEvent e)
      Invoked when editing is canceled.
      void editingStopped(ChangeEvent e)
      Invoked when editing is finished.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTable.
      boolean getAutoCreateColumnsFromModel()
      Determines whether the table will create default columns from the model.
      boolean getAutoCreateRowSorter()
      Returns true if whenever the model changes, a new RowSorter should be created and installed as the table's sorter; otherwise, returns false.
      int getAutoResizeMode()
      Returns the auto resize mode of the table.
      TableCellEditor getCellEditor()
      Returns the active cell editor, which is null if the table is not currently editing.
      TableCellEditor getCellEditor(int row, int column)
      Returns an appropriate editor for the cell specified by row and column.
      Rectangle getCellRect(int row, int column, boolean includeSpacing)
      Returns a rectangle for the cell that lies at the intersection of row and column.
      TableCellRenderer getCellRenderer(int row, int column)
      Returns an appropriate renderer for the cell specified by this row and column.
      boolean getCellSelectionEnabled()
      Returns true if both row and column selection models are enabled.
      TableColumn getColumn(Object identifier)
      Returns the TableColumn object for the column in the table whose identifier is equal to identifier, when compared using equals.
      类<?> getColumnClass(int column)
      Returns the type of the column appearing in the view at column position column.
      int getColumnCount()
      Returns the number of columns in the column model.
      TableColumnModel getColumnModel()
      Returns the TableColumnModel that contains all column information of this table.
      String getColumnName(int column)
      Returns the name of the column appearing in the view at column position column.
      boolean getColumnSelectionAllowed()
      Returns true if columns can be selected.
      TableCellEditor getDefaultEditor(类<?> columnClass)
      Returns the editor to be used when no editor has been set in a TableColumn.
      TableCellRenderer getDefaultRenderer(类<?> columnClass)
      Returns the cell renderer to be used when no renderer has been set in a TableColumn.
      boolean getDragEnabled()
      Returns whether or not automatic drag handling is enabled.
      JTable.DropLocation getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
      DropMode getDropMode()
      Returns the drop mode for this component.
      int getEditingColumn()
      Returns the index of the column that contains the cell currently being edited.
      int getEditingRow()
      Returns the index of the row that contains the cell currently being edited.
      Component getEditorComponent()
      Returns the component that is handling the editing session.
      boolean getFillsViewportHeight()
      Returns whether or not this table is always made large enough to fill the height of an enclosing viewport.
      Color getGridColor()
      Returns the color used to draw grid lines.
      Dimension getIntercellSpacing()
      Returns the horizontal and vertical space between cells.
      TableModel getModel()
      Returns the TableModel that provides the data displayed by this JTable.
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred size of the viewport for this table.
      Printable getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      Return a Printable for use in printing this JTable.
      int getRowCount()
      Returns the number of rows that can be shown in the JTable, given unlimited space.
      int getRowHeight()
      Returns the height of a table row, in pixels.
      int getRowHeight(int row)
      Returns the height, in pixels, of the cells in row.
      int getRowMargin()
      Gets the amount of empty space, in pixels, between cells.
      boolean getRowSelectionAllowed()
      Returns true if rows can be selected.
      RowSorter<? extends TableModel> getRowSorter()
      Returns the object responsible for sorting.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns visibleRect.height or visibleRect.width, depending on this table's orientation.
      boolean getScrollableTracksViewportHeight()
      Returns false to indicate that the height of the viewport does not determine the height of the table, unless getFillsViewportHeight is true and the preferred height of the table is smaller than the viewport's height.
      boolean getScrollableTracksViewportWidth()
      Returns false if autoResizeMode is set to AUTO_RESIZE_OFF, which indicates that the width of the viewport does not determine the width of the table.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns the scroll increment (in pixels) that completely exposes one new row or column (depending on the orientation).
      int getSelectedColumn()
      Returns the index of the first selected column, -1 if no column is selected.
      int getSelectedColumnCount()
      Returns the number of selected columns.
      int[] getSelectedColumns()
      Returns the indices of all selected columns.
      int getSelectedRow()
      Returns the index of the first selected row, -1 if no row is selected.
      int getSelectedRowCount()
      Returns the number of selected rows.
      int[] getSelectedRows()
      Returns the indices of all selected rows.
      Color getSelectionBackground()
      Returns the background color for selected cells.
      Color getSelectionForeground()
      Returns the foreground color for selected cells.
      ListSelectionModel getSelectionModel()
      Returns the ListSelectionModel that is used to maintain row selection state.
      boolean getShowHorizontalLines()
      Returns true if the table draws horizontal lines between cells, false if it doesn't.
      boolean getShowVerticalLines()
      Returns true if the table draws vertical lines between cells, false if it doesn't.
      boolean getSurrendersFocusOnKeystroke()
      Returns true if the editor should get the focus when keystrokes cause the editor to be activated
      JTableHeader getTableHeader()
      Returns the tableHeader used by this JTable.
      String getToolTipText(MouseEvent event)
      Overrides JComponent's getToolTipText method in order to allow the renderer's tips to be used if it has text set.
      TableUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the suffix used to construct the name of the L&F class used to render this component.
      boolean getUpdateSelectionOnSort()
      Returns true if the selection should be updated after sorting.
      Object getValueAt(int row, int column)
      Returns the cell value at row and column.
      protected void initializeLocalVars()
      Initializes table properties to their default values.
      boolean isCellEditable(int row, int column)
      Returns true if the cell at row and column is editable.
      boolean isCellSelected(int row, int column)
      Returns true if the specified indices are in the valid range of rows and columns and the cell at the specified position is selected.
      boolean isColumnSelected(int column)
      Returns true if the specified index is in the valid range of columns, and the column at that index is selected.
      boolean isEditing()
      Returns true if a cell is being edited.
      boolean isRowSelected(int row)
      Returns true if the specified index is in the valid range of rows, and the row at that index is selected.
      void moveColumn(int column, int targetColumn)
      Moves the column column to the position currently occupied by the column targetColumn in the view.
      protected String paramString()
      Returns a string representation of this table.
      Component prepareEditor(TableCellEditor editor, int row, int column)
      Prepares the editor by querying the data model for the value and selection state of the cell at row, column.
      Component prepareRenderer(TableCellRenderer renderer, int row, int column)
      Prepares the renderer by querying the data model for the value and selection state of the cell at row, column.
      boolean print()
      A convenience method that displays a printing dialog, and then prints this JTable in mode PrintMode.FIT_WIDTH, with no header or footer text.
      boolean print(JTable.PrintMode printMode)
      A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with no header or footer text.
      boolean print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with the specified header and footer text.
      boolean print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      Prints this table, as specified by the fully featured print method, with the default printer specified as the print service.
      boolean print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      Prints this JTable.
      protected boolean processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      Invoked to process the key bindings for ks as the result of the KeyEvent e.
      void removeColumn(TableColumn aColumn)
      Removes aColumn from this JTable's array of columns.
      void removeColumnSelectionInterval(int index0, int index1)
      Deselects the columns from index0 to index1, inclusive.
      void removeEditor()
      Discards the editor object and frees the real estate it used for cell rendering.
      void removeNotify()
      Calls the unconfigureEnclosingScrollPane method.
      void removeRowSelectionInterval(int index0, int index1)
      Deselects the rows from index0 to index1, inclusive.
      protected void resizeAndRepaint()
      Equivalent to revalidate followed by repaint.
      int rowAtPoint(Point point)
      Returns the index of the row that point lies in, or -1 if the result is not in the range [0, getRowCount()-1].
      void selectAll()
      Selects all rows, columns, and cells in the table.
      void setAutoCreateColumnsFromModel(boolean autoCreateColumnsFromModel)
      Sets this table's autoCreateColumnsFromModel flag.
      void setAutoCreateRowSorter(boolean autoCreateRowSorter)
      Specifies whether a RowSorter should be created for the table whenever its model changes.
      void setAutoResizeMode(int mode)
      Sets the table's auto resize mode when the table is resized.
      void setCellEditor(TableCellEditor anEditor)
      Sets the active cell editor.
      void setCellSelectionEnabled(boolean cellSelectionEnabled)
      Sets whether this table allows both a column selection and a row selection to exist simultaneously.
      void setColumnModel(TableColumnModel columnModel)
      Sets the column model for this table to newModel and registers for listener notifications from the new column model.
      void setColumnSelectionAllowed(boolean columnSelectionAllowed)
      Sets whether the columns in this model can be selected.
      void setColumnSelectionInterval(int index0, int index1)
      Selects the columns from index0 to index1, inclusive.
      void setDefaultEditor(类<?> columnClass, TableCellEditor editor)
      Sets a default cell editor to be used if no editor has been set in a TableColumn.
      void setDefaultRenderer(类<?> columnClass, TableCellRenderer renderer)
      Sets a default cell renderer to be used if no renderer has been set in a TableColumn.
      void setDragEnabled(boolean b)
      Turns on or off automatic drag handling.
      void setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void setEditingColumn(int aColumn)
      Sets the editingColumn variable.
      void setEditingRow(int aRow)
      Sets the editingRow variable.
      void setFillsViewportHeight(boolean fillsViewportHeight)
      Sets whether or not this table is always made large enough to fill the height of an enclosing viewport.
      void setGridColor(Color gridColor)
      Sets the color used to draw grid lines to gridColor and redisplays.
      void setIntercellSpacing(Dimension intercellSpacing)
      Sets the rowMargin and the columnMargin -- the height and width of the space between cells -- to intercellSpacing.
      void setModel(TableModel dataModel)
      Sets the data model for this table to newModel and registers with it for listener notifications from the new data model.
      void setPreferredScrollableViewportSize(Dimension size)
      Sets the preferred size of the viewport for this table.
      void setRowHeight(int rowHeight)
      Sets the height, in pixels, of all cells to rowHeight, revalidates, and repaints.
      void setRowHeight(int row, int rowHeight)
      Sets the height for row to rowHeight, revalidates, and repaints.
      void setRowMargin(int rowMargin)
      Sets the amount of empty space between cells in adjacent rows.
      void setRowSelectionAllowed(boolean rowSelectionAllowed)
      Sets whether the rows in this model can be selected.
      void setRowSelectionInterval(int index0, int index1)
      Selects the rows from index0 to index1, inclusive.
      void setRowSorter(RowSorter<? extends TableModel> sorter)
      Sets the RowSorter.
      void setSelectionBackground(Color selectionBackground)
      Sets the background color for selected cells.
      void setSelectionForeground(Color selectionForeground)
      Sets the foreground color for selected cells.
      void setSelectionMode(int selectionMode)
      Sets the table's selection mode to allow only single selections, a single contiguous interval, or multiple intervals.
      void setSelectionModel(ListSelectionModel newModel)
      Sets the row selection model for this table to newModel and registers for listener notifications from the new selection model.
      void setShowGrid(boolean showGrid)
      Sets whether the table draws grid lines around cells.
      void setShowHorizontalLines(boolean showHorizontalLines)
      Sets whether the table draws horizontal lines between cells.
      void setShowVerticalLines(boolean showVerticalLines)
      Sets whether the table draws vertical lines between cells.
      void setSurrendersFocusOnKeystroke(boolean surrendersFocusOnKeystroke)
      Sets whether editors in this JTable get the keyboard focus when an editor is activated as a result of the JTable forwarding keyboard events for a cell.
      void setTableHeader(JTableHeader tableHeader)
      Sets the tableHeader working with this JTable to newHeader.
      void setUI(TableUI ui)
      Sets the L&F object that renders this component and repaints.
      void setUpdateSelectionOnSort(boolean update)
      Specifies whether the selection should be updated after sorting.
      void setValueAt(Object aValue, int row, int column)
      Sets the value for the cell in the table model at row and column.
      void sizeColumnsToFit(boolean lastColumnOnly)
      Deprecated.
      As of Swing version 1.0.3, replaced by doLayout().
      void sizeColumnsToFit(int resizingColumn)
      Obsolete as of Java 2 platform v1.4.
      void sorterChanged(RowSorterEvent e)
      RowSorterListener notification that the RowSorter has changed in some way.
      void tableChanged(TableModelEvent e)
      Invoked when this table's TableModel generates a TableModelEvent.
      protected void unconfigureEnclosingScrollPane()
      Reverses the effect of configureEnclosingScrollPane by replacing the columnHeaderView of the enclosing scroll pane with null.
      void updateUI()
      Notification from the UIManager that the L&F has changed.
      void valueChanged(ListSelectionEvent e)
      Invoked when the row selection changes -- repaints to show the new selection.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • AUTO_RESIZE_OFF

        public static final int AUTO_RESIZE_OFF
        Do not adjust column widths automatically; use a horizontal scrollbar instead.
        另请参见：
        Constant Field Values

      • AUTO_RESIZE_NEXT_COLUMN

        public static final int AUTO_RESIZE_NEXT_COLUMN
        When a column is adjusted in the UI, adjust the next column the opposite way.
        另请参见：
        Constant Field Values

      • AUTO_RESIZE_SUBSEQUENT_COLUMNS

        public static final int AUTO_RESIZE_SUBSEQUENT_COLUMNS
        During UI adjustment, change subsequent columns to preserve the total width; this is the default behavior.
        另请参见：
        Constant Field Values

      • AUTO_RESIZE_LAST_COLUMN

        public static final int AUTO_RESIZE_LAST_COLUMN
        During all resize operations, apply adjustments to the last column only.
        另请参见：
        Constant Field Values

      • AUTO_RESIZE_ALL_COLUMNS

        public static final int AUTO_RESIZE_ALL_COLUMNS
        During all resize operations, proportionately resize all columns.
        另请参见：
        Constant Field Values

      • dataModel

        protected TableModel dataModel
        The TableModel of the table.

      • columnModel

        protected TableColumnModel columnModel
        The TableColumnModel of the table.

      • selectionModel

        protected ListSelectionModel selectionModel
        The ListSelectionModel of the table, used to keep track of row selections.

      • tableHeader

        protected JTableHeader tableHeader
        The TableHeader working with the table.

      • rowHeight

        protected int rowHeight
        The height in pixels of each row in the table.

      • rowMargin

        protected int rowMargin
        The height in pixels of the margin between the cells in each row.

      • gridColor

        protected Color gridColor
        The color of the grid.

      • showHorizontalLines

        protected boolean showHorizontalLines
        The table draws horizontal lines between cells if showHorizontalLines is true.

      • showVerticalLines

        protected boolean showVerticalLines
        The table draws vertical lines between cells if showVerticalLines is true.

      • autoResizeMode

        protected int autoResizeMode
        Determines if the table automatically resizes the width of the table's columns to take up the entire width of the table, and how it does the resizing.

      • autoCreateColumnsFromModel

        protected boolean autoCreateColumnsFromModel
        The table will query the TableModel to build the default set of columns if this is true.

      • preferredViewportSize

        protected Dimension preferredViewportSize
        Used by the Scrollable interface to determine the initial visible area.

      • rowSelectionAllowed

        protected boolean rowSelectionAllowed
        True if row selection is allowed in this table.

      • cellSelectionEnabled

        protected boolean cellSelectionEnabled
        Obsolete as of Java 2 platform v1.3. Please use the rowSelectionAllowed property and the columnSelectionAllowed property of the columnModel instead. Or use the method getCellSelectionEnabled.

      • editorComp

        protected transient Component editorComp
        If editing, the Component that is handling the editing.

      • cellEditor

        protected transient TableCellEditor cellEditor
        The active cell editor object, that overwrites the screen real estate occupied by the current cell and allows the user to change its contents. null if the table isn't currently editing.

      • editingColumn

        protected transient int editingColumn
        Identifies the column of the cell being edited.

      • editingRow

        protected transient int editingRow
        Identifies the row of the cell being edited.

      • defaultRenderersByColumnClass

        protected transient Hashtable defaultRenderersByColumnClass
        A table of objects that display the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.

      • defaultEditorsByColumnClass

        protected transient Hashtable defaultEditorsByColumnClass
        A table of objects that display and edit the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.

      • selectionForeground

        protected Color selectionForeground
        The foreground color of selected cells.

      • selectionBackground

        protected Color selectionBackground
        The background color of selected cells.

    • 构造方法详细信息

      • JTable

        public JTable()
        Constructs a default JTable that is initialized with a default data model, a default column model, and a default selection model.
        另请参见：
        createDefaultDataModel(),
createDefaultColumnModel(),
createDefaultSelectionModel()

      • JTable

        public JTable(TableModel dm)
        Constructs a JTable that is initialized with dm as the data model, a default column model, and a default selection model.
        参数：
        dm - the data model for the table
        另请参见：
        createDefaultColumnModel(), createDefaultSelectionModel()

      • JTable

        public JTable(TableModel dm,
      TableColumnModel cm)
        Constructs a JTable that is initialized with dm as the data model, cm as the column model, and a default selection model.
        参数：
        dm - the data model for the table
        cm - the column model for the table
        另请参见：
        createDefaultSelectionModel()

      • JTable

        public JTable(TableModel dm,
      TableColumnModel cm,
      ListSelectionModel sm)
        Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model. If any of the parameters are null this method will initialize the table with the corresponding default model. The autoCreateColumnsFromModel flag is set to false if cm is non-null, otherwise it is set to true and the column model is populated with suitable TableColumns for the columns in dm.
        参数：
        dm - the data model for the table
        cm - the column model for the table
        sm - the row selection model for the table
        另请参见：
        createDefaultDataModel(),
createDefaultColumnModel(),
createDefaultSelectionModel()

      • JTable

        public JTable(int numRows,
      int numColumns)
        Constructs a JTable with numRows and numColumns of empty cells using DefaultTableModel. The columns will have names of the form "A", "B", "C", etc.
        参数：
        numRows - the number of rows the table holds
        numColumns - the number of columns the table holds
        另请参见：
        DefaultTableModel

      • JTable

        public JTable(Vector rowData,
      Vector columnNames)
        Constructs a JTable to display the values in the Vector of Vectors, rowData, with column names, columnNames. The Vectors contained in rowData should contain the values for that row. In other words, the value of the cell at row 1, column 5 can be obtained with the following code:

        ((Vector)rowData.elementAt(1)).elementAt(5);

        参数：
        rowData - the data for the new table
        columnNames - names of each column

      • JTable

        public JTable(Object[][] rowData,
      Object[] columnNames)
        Constructs a JTable to display the values in the two dimensional array, rowData, with column names, columnNames. rowData is an array of rows, so the value of the cell at row 1, column 5 can be obtained with the following code:

         rowData[1][5];

        All rows must be of the same length as columnNames.

        参数：
        rowData - the data for the new table
        columnNames - names of each column

    • 方法详细信息

      • addNotify

        public void addNotify()
        Calls the configureEnclosingScrollPane method.
        重载：
        addNotify in class JComponent
        另请参见：
        configureEnclosingScrollPane()

      • configureEnclosingScrollPane

        protected void configureEnclosingScrollPane()
        If this JTable is the viewportView of an enclosing JScrollPane (the usual situation), configure this ScrollPane by, amongst other things, installing the table's tableHeader as the columnHeaderView of the scroll pane. When a JTable is added to a JScrollPane in the usual way, using new JScrollPane(myTable), addNotify is called in the JTable (when the table is added to the viewport). JTable's addNotify method in turn calls this method, which is protected so that this default installation procedure can be overridden by a subclass.
        另请参见：
        addNotify()

      • removeNotify

        public void removeNotify()
        Calls the unconfigureEnclosingScrollPane method.
        重载：
        removeNotify in class JComponent
        另请参见：
        unconfigureEnclosingScrollPane()

      • unconfigureEnclosingScrollPane

        protected void unconfigureEnclosingScrollPane()
        Reverses the effect of configureEnclosingScrollPane by replacing the columnHeaderView of the enclosing scroll pane with null. JTable's removeNotify method calls this method, which is protected so that this default uninstallation procedure can be overridden by a subclass.
        从以下版本开始：
        1.3
        另请参见：
        removeNotify(), configureEnclosingScrollPane()

      • createScrollPaneForTable

        @Deprecated
public static JScrollPane createScrollPaneForTable(JTable aTable)
        Deprecated. As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
        Equivalent to new JScrollPane(aTable).

      • setTableHeader

        public void setTableHeader(JTableHeader tableHeader)
        Sets the tableHeader working with this JTable to newHeader. It is legal to have a null tableHeader.
        参数：
        tableHeader - new tableHeader
        另请参见：
        getTableHeader()

      • getTableHeader

        public JTableHeader getTableHeader()
        Returns the tableHeader used by this JTable.
        返回：
        the tableHeader used by this table
        另请参见：
        setTableHeader(javax.swing.table.JTableHeader)

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height, in pixels, of all cells to rowHeight, revalidates, and repaints. The height of the cells will be equal to the row height minus the row margin.
        参数：
        rowHeight - new row height
        抛出：
        IllegalArgumentException - if rowHeight is less than 1
        另请参见：
        getRowHeight()

      • getRowHeight

        public int getRowHeight()
        Returns the height of a table row, in pixels.
        返回：
        the height in pixels of a table row
        另请参见：
        setRowHeight(int)

      • setRowHeight

        public void setRowHeight(int row,
                int rowHeight)
        Sets the height for row to rowHeight, revalidates, and repaints. The height of the cells in this row will be equal to the row height minus the row margin.
        参数：
        row - the row whose height is being changed
        rowHeight - new row height, in pixels
        抛出：
        IllegalArgumentException - if rowHeight is less than 1
        从以下版本开始：
        1.3

      • getRowHeight

        public int getRowHeight(int row)
        Returns the height, in pixels, of the cells in row.
        参数：
        row - the row whose height is to be returned
        返回：
        the height, in pixels, of the cells in the row
        从以下版本开始：
        1.3

      • setRowMargin

        public void setRowMargin(int rowMargin)
        Sets the amount of empty space between cells in adjacent rows.
        参数：
        rowMargin - the number of pixels between cells in a row
        另请参见：
        getRowMargin()

      • getRowMargin

        public int getRowMargin()
        Gets the amount of empty space, in pixels, between cells. Equivalent to: getIntercellSpacing().height.
        返回：
        the number of pixels between cells in a row
        另请参见：
        setRowMargin(int)

      • setIntercellSpacing

        public void setIntercellSpacing(Dimension intercellSpacing)
        Sets the rowMargin and the columnMargin -- the height and width of the space between cells -- to intercellSpacing.
        参数：
        intercellSpacing - a Dimension specifying the new width and height between cells
        另请参见：
        getIntercellSpacing()

      • getIntercellSpacing

        public Dimension getIntercellSpacing()
        Returns the horizontal and vertical space between cells. The default spacing is look and feel dependent.
        返回：
        the horizontal and vertical spacing between cells
        另请参见：
        setIntercellSpacing(java.awt.Dimension)

      • setGridColor

        public void setGridColor(Color gridColor)
        Sets the color used to draw grid lines to gridColor and redisplays. The default color is look and feel dependent.
        参数：
        gridColor - the new color of the grid lines
        抛出：
        IllegalArgumentException - if gridColor is null
        另请参见：
        getGridColor()

      • getGridColor

        public Color getGridColor()
        Returns the color used to draw grid lines. The default color is look and feel dependent.
        返回：
        the color used to draw grid lines
        另请参见：
        setGridColor(java.awt.Color)

      • setShowGrid

        public void setShowGrid(boolean showGrid)
        Sets whether the table draws grid lines around cells. If showGrid is true it does; if it is false it doesn't. There is no getShowGrid method as this state is held in two variables -- showHorizontalLines and showVerticalLines -- each of which can be queried independently.
        参数：
        showGrid - true if table view should draw grid lines
        另请参见：
        setShowVerticalLines(boolean), setShowHorizontalLines(boolean)

      • setShowHorizontalLines

        public void setShowHorizontalLines(boolean showHorizontalLines)
        Sets whether the table draws horizontal lines between cells. If showHorizontalLines is true it does; if it is false it doesn't.
        参数：
        showHorizontalLines - true if table view should draw horizontal lines
        另请参见：
        getShowHorizontalLines(), setShowGrid(boolean), setShowVerticalLines(boolean)

      • setShowVerticalLines

        public void setShowVerticalLines(boolean showVerticalLines)
        Sets whether the table draws vertical lines between cells. If showVerticalLines is true it does; if it is false it doesn't.
        参数：
        showVerticalLines - true if table view should draw vertical lines
        另请参见：
        getShowVerticalLines(), setShowGrid(boolean), setShowHorizontalLines(boolean)

      • getShowHorizontalLines

        public boolean getShowHorizontalLines()
        Returns true if the table draws horizontal lines between cells, false if it doesn't. The default value is look and feel dependent.
        返回：
        true if the table draws horizontal lines between cells, false if it doesn't
        另请参见：
        setShowHorizontalLines(boolean)

      • getShowVerticalLines

        public boolean getShowVerticalLines()
        Returns true if the table draws vertical lines between cells, false if it doesn't. The default value is look and feel dependent.
        返回：
        true if the table draws vertical lines between cells, false if it doesn't
        另请参见：
        setShowVerticalLines(boolean)

      • setAutoResizeMode

        public void setAutoResizeMode(int mode)
        Sets the table's auto resize mode when the table is resized. For further information on how the different resize modes work, see doLayout().
        参数：
        mode - One of 5 legal values: AUTO_RESIZE_OFF, AUTO_RESIZE_NEXT_COLUMN, AUTO_RESIZE_SUBSEQUENT_COLUMNS, AUTO_RESIZE_LAST_COLUMN, AUTO_RESIZE_ALL_COLUMNS
        另请参见：
        getAutoResizeMode(), doLayout()

      • getAutoResizeMode

        public int getAutoResizeMode()
        Returns the auto resize mode of the table. The default mode is AUTO_RESIZE_SUBSEQUENT_COLUMNS.
        返回：
        the autoResizeMode of the table
        另请参见：
        setAutoResizeMode(int), doLayout()

      • setAutoCreateColumnsFromModel

        public void setAutoCreateColumnsFromModel(boolean autoCreateColumnsFromModel)
        Sets this table's autoCreateColumnsFromModel flag. This method calls createDefaultColumnsFromModel if autoCreateColumnsFromModel changes from false to true.
        参数：
        autoCreateColumnsFromModel - true if JTable should automatically create columns
        另请参见：
        getAutoCreateColumnsFromModel(), createDefaultColumnsFromModel()

      • getAutoCreateColumnsFromModel

        public boolean getAutoCreateColumnsFromModel()
        Determines whether the table will create default columns from the model. If true, setModel will clear any existing columns and create new columns from the new model. Also, if the event in the tableChanged notification specifies that the entire table changed, then the columns will be rebuilt. The default is true.
        返回：
        the autoCreateColumnsFromModel of the table
        另请参见：
        setAutoCreateColumnsFromModel(boolean), createDefaultColumnsFromModel()

      • createDefaultColumnsFromModel

        public void createDefaultColumnsFromModel()
        Creates default columns for the table from the data model using the getColumnCount method defined in the TableModel interface.

        Clears any existing columns before creating the new columns based on information from the model.

        另请参见：
        getAutoCreateColumnsFromModel()

      • setDefaultRenderer

        public void setDefaultRenderer(类<?> columnClass,
                      TableCellRenderer renderer)
        Sets a default cell renderer to be used if no renderer has been set in a TableColumn. If renderer is null, removes the default renderer for this column class.
        参数：
        columnClass - set the default cell renderer for this columnClass
        renderer - default cell renderer to be used for this columnClass
        另请参见：
        getDefaultRenderer(java.lang.Class), setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor)

      • getDefaultRenderer

        public TableCellRenderer getDefaultRenderer(类<?> columnClass)
        Returns the cell renderer to be used when no renderer has been set in a TableColumn. During the rendering of cells the renderer is fetched from a Hashtable of entries according to the class of the cells in the column. If there is no entry for this columnClass the method returns the entry for the most specific superclass. The JTable installs entries for Object, Number, and Boolean, all of which can be modified or replaced.
        参数：
        columnClass - return the default cell renderer for this columnClass
        返回：
        the renderer for this columnClass
        另请参见：
        setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer), getColumnClass(int)

      • setDefaultEditor

        public void setDefaultEditor(类<?> columnClass,
                    TableCellEditor editor)
        Sets a default cell editor to be used if no editor has been set in a TableColumn. If no editing is required in a table, or a particular column in a table, uses the isCellEditable method in the TableModel interface to ensure that this JTable will not start an editor in these columns. If editor is null, removes the default editor for this column class.
        参数：
        columnClass - set the default cell editor for this columnClass
        editor - default cell editor to be used for this columnClass
        另请参见：
        TableModel.isCellEditable(int, int),
getDefaultEditor(java.lang.Class),
setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

      • getDefaultEditor

        public TableCellEditor getDefaultEditor(类<?> columnClass)
        Returns the editor to be used when no editor has been set in a TableColumn. During the editing of cells the editor is fetched from a Hashtable of entries according to the class of the cells in the column. If there is no entry for this columnClass the method returns the entry for the most specific superclass. The JTable installs entries for Object, Number, and Boolean, all of which can be modified or replaced.
        参数：
        columnClass - return the default cell editor for this columnClass
        返回：
        the default cell editor to be used for this columnClass
        另请参见：
        setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor), getColumnClass(int)

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Turns on or off automatic drag handling. In order to enable automatic drag handling, this property should be set to true, and the table's TransferHandler needs to be non-null. The default value of the dragEnabled property is false.

        The job of honoring this property, and recognizing a user drag gesture, lies with the look and feel implementation, and in particular, the table's TableUI. When automatic drag handling is enabled, most look and feels (including those that subclass BasicLookAndFeel) begin a drag and drop operation whenever the user presses the mouse button over an item (in single selection mode) or a selection (in other selection modes) and then moves the mouse a few pixels. Setting this property to true can therefore have a subtle effect on how selections behave.

        If a look and feel is used that ignores this property, you can still begin a drag and drop operation by calling exportAsDrag on the table's TransferHandler.

        参数：
        b - whether or not to enable automatic drag handling
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Returns whether or not automatic drag handling is enabled.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • setDropMode

        public final void setDropMode(DropMode dropMode)
        Sets the drop mode for this component. For backward compatibility, the default for this property is DropMode.USE_SELECTION. Usage of one of the other modes is recommended, however, for an improved user experience. DropMode.ON, for instance, offers similar behavior of showing items as selected, but does so without affecting the actual selection in the table.

        JTable supports the following drop modes:

        • DropMode.USE_SELECTION
        • DropMode.ON
        • DropMode.INSERT
        • DropMode.INSERT_ROWS
        • DropMode.INSERT_COLS
        • DropMode.ON_OR_INSERT
        • DropMode.ON_OR_INSERT_ROWS
        • DropMode.ON_OR_INSERT_COLS

        The drop mode is only meaningful if this component has a TransferHandler that accepts drops.

        参数：
        dropMode - the drop mode to use
        抛出：
        IllegalArgumentException - if the drop mode is unsupported or null
        从以下版本开始：
        1.6
        另请参见：
        getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDropMode

        public final DropMode getDropMode()
        Returns the drop mode for this component.
        返回：
        the drop mode for this component
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode)

      • getDropLocation

        public final JTable.DropLocation getDropLocation()
        Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

        This method is not meant for querying the drop location from a TransferHandler, as the drop location is only set after the TransferHandler's canImport has returned and has allowed for the location to be shown.

        When this property changes, a property change event with name "dropLocation" is fired by the component.

        返回：
        the drop location
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

      • setAutoCreateRowSorter

        public void setAutoCreateRowSorter(boolean autoCreateRowSorter)
        Specifies whether a RowSorter should be created for the table whenever its model changes.

        When setAutoCreateRowSorter(true) is invoked, a TableRowSorter is immediately created and installed on the table. While the autoCreateRowSorter property remains true, every time the model is changed, a new TableRowSorter is created and set as the table's row sorter.

        参数：
        autoCreateRowSorter - whether or not a RowSorter should be automatically created
        从以下版本开始：
        1.6
        另请参见：
        TableRowSorter

      • getAutoCreateRowSorter

        public boolean getAutoCreateRowSorter()
        Returns true if whenever the model changes, a new RowSorter should be created and installed as the table's sorter; otherwise, returns false.
        返回：
        true if a RowSorter should be created when the model changes
        从以下版本开始：
        1.6

      • setUpdateSelectionOnSort

        public void setUpdateSelectionOnSort(boolean update)
        Specifies whether the selection should be updated after sorting. If true, on sorting the selection is reset such that the same rows, in terms of the model, remain selected. The default is true.
        参数：
        update - whether or not to update the selection on sorting
        从以下版本开始：
        1.6

      • getUpdateSelectionOnSort

        public boolean getUpdateSelectionOnSort()
        Returns true if the selection should be updated after sorting.
        返回：
        whether to update the selection on a sort
        从以下版本开始：
        1.6

      • setRowSorter

        public void setRowSorter(RowSorter<? extends TableModel> sorter)
        Sets the RowSorter. RowSorter is used to provide sorting and filtering to a JTable.

        This method clears the selection and resets any variable row heights.

        This method fires a PropertyChangeEvent when appropriate, with the property name "rowSorter". For backward-compatibility, this method fires an additional event with the property name "sorter".

        If the underlying model of the RowSorter differs from that of this JTable undefined behavior will result.

        参数：
        sorter - the RowSorter; null turns sorting off
        从以下版本开始：
        1.6
        另请参见：
        TableRowSorter

      • getRowSorter

        public RowSorter<? extends TableModel> getRowSorter()
        Returns the object responsible for sorting.
        返回：
        the object responsible for sorting
        从以下版本开始：
        1.6

      • setSelectionMode

        public void setSelectionMode(int selectionMode)
        Sets the table's selection mode to allow only single selections, a single contiguous interval, or multiple intervals.

        Note: JTable provides all the methods for handling column and row selection. When setting states, such as setSelectionMode, it not only updates the mode for the row selection model but also sets similar values in the selection model of the columnModel. If you want to have the row and column selection models operating in different modes, set them both directly.

        Both the row and column selection models for JTable default to using a DefaultListSelectionModel so that JTable works the same way as the JList. See the setSelectionMode method in JList for details about the modes.

        另请参见：
        JList.setSelectionMode(int)

      • setRowSelectionAllowed

        public void setRowSelectionAllowed(boolean rowSelectionAllowed)
        Sets whether the rows in this model can be selected.
        参数：
        rowSelectionAllowed - true if this model will allow row selection
        另请参见：
        getRowSelectionAllowed()

      • getRowSelectionAllowed

        public boolean getRowSelectionAllowed()
        Returns true if rows can be selected.
        返回：
        true if rows can be selected, otherwise false
        另请参见：
        setRowSelectionAllowed(boolean)

      • setColumnSelectionAllowed

        public void setColumnSelectionAllowed(boolean columnSelectionAllowed)
        Sets whether the columns in this model can be selected.
        参数：
        columnSelectionAllowed - true if this model will allow column selection
        另请参见：
        getColumnSelectionAllowed()

      • getColumnSelectionAllowed

        public boolean getColumnSelectionAllowed()
        Returns true if columns can be selected.
        返回：
        true if columns can be selected, otherwise false
        另请参见：
        setColumnSelectionAllowed(boolean)

      • setCellSelectionEnabled

        public void setCellSelectionEnabled(boolean cellSelectionEnabled)
        Sets whether this table allows both a column selection and a row selection to exist simultaneously. When set, the table treats the intersection of the row and column selection models as the selected cells. Override isCellSelected to change this default behavior. This method is equivalent to setting both the rowSelectionAllowed property and columnSelectionAllowed property of the columnModel to the supplied value.
        参数：
        cellSelectionEnabled - true if simultaneous row and column selection is allowed
        另请参见：
        getCellSelectionEnabled(), isCellSelected(int, int)

      • getCellSelectionEnabled

        public boolean getCellSelectionEnabled()
        Returns true if both row and column selection models are enabled. Equivalent to getRowSelectionAllowed() && getColumnSelectionAllowed().
        返回：
        true if both row and column selection models are enabled
        另请参见：
        setCellSelectionEnabled(boolean)

      • selectAll

        public void selectAll()
        Selects all rows, columns, and cells in the table.

      • clearSelection

        public void clearSelection()
        Deselects all selected columns and rows.

      • setRowSelectionInterval

        public void setRowSelectionInterval(int index0,
                           int index1)
        Selects the rows from index0 to index1, inclusive.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getRowCount()-1]

      • setColumnSelectionInterval

        public void setColumnSelectionInterval(int index0,
                              int index1)
        Selects the columns from index0 to index1, inclusive.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getColumnCount()-1]

      • addRowSelectionInterval

        public void addRowSelectionInterval(int index0,
                           int index1)
        Adds the rows from index0 to index1, inclusive, to the current selection.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getRowCount()-1]

      • addColumnSelectionInterval

        public void addColumnSelectionInterval(int index0,
                              int index1)
        Adds the columns from index0 to index1, inclusive, to the current selection.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getColumnCount()-1]

      • removeRowSelectionInterval

        public void removeRowSelectionInterval(int index0,
                              int index1)
        Deselects the rows from index0 to index1, inclusive.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getRowCount()-1]

      • removeColumnSelectionInterval

        public void removeColumnSelectionInterval(int index0,
                                 int index1)
        Deselects the columns from index0 to index1, inclusive.
        参数：
        index0 - one end of the interval
        index1 - the other end of the interval
        抛出：
        IllegalArgumentException - if index0 or index1 lie outside [0, getColumnCount()-1]

      • getSelectedRow

        public int getSelectedRow()
        Returns the index of the first selected row, -1 if no row is selected.
        返回：
        the index of the first selected row

      • getSelectedColumn

        public int getSelectedColumn()
        Returns the index of the first selected column, -1 if no column is selected.
        返回：
        the index of the first selected column

      • getSelectedRows

        public int[] getSelectedRows()
        Returns the indices of all selected rows.
        返回：
        an array of integers containing the indices of all selected rows, or an empty array if no row is selected
        另请参见：
        getSelectedRow()

      • getSelectedColumns

        public int[] getSelectedColumns()
        Returns the indices of all selected columns.
        返回：
        an array of integers containing the indices of all selected columns, or an empty array if no column is selected
        另请参见：
        getSelectedColumn()

      • getSelectedRowCount

        public int getSelectedRowCount()
        Returns the number of selected rows.
        返回：
        the number of selected rows, 0 if no rows are selected

      • getSelectedColumnCount

        public int getSelectedColumnCount()
        Returns the number of selected columns.
        返回：
        the number of selected columns, 0 if no columns are selected

      • isRowSelected

        public boolean isRowSelected(int row)
        Returns true if the specified index is in the valid range of rows, and the row at that index is selected.
        返回：
        true if row is a valid index and the row at that index is selected (where 0 is the first row)

      • isColumnSelected

        public boolean isColumnSelected(int column)
        Returns true if the specified index is in the valid range of columns, and the column at that index is selected.
        参数：
        column - the column in the column model
        返回：
        true if column is a valid index and the column at that index is selected (where 0 is the first column)

      • isCellSelected

        public boolean isCellSelected(int row,
                     int column)
        Returns true if the specified indices are in the valid range of rows and columns and the cell at the specified position is selected.
        参数：
        row - the row being queried
        column - the column being queried
        返回：
        true if row and column are valid indices and the cell at index (row, column) is selected, where the first row and first column are at index 0

      • changeSelection

        public void changeSelection(int rowIndex,
                   int columnIndex,
                   boolean toggle,
                   boolean extend)
        Updates the selection models of the table, depending on the state of the two flags: toggle and extend. Most changes to the selection that are the result of keyboard or mouse events received by the UI are channeled through this method so that the behavior may be overridden by a subclass. Some UIs may need more functionality than this method provides, such as when manipulating the lead for discontiguous selection, and may not call into this method for some selection changes.

        This implementation uses the following conventions:

        • toggle: false, extend: false. Clear the previous selection and ensure the new cell is selected.
        • toggle: false, extend: true. Extend the previous selection from the anchor to the specified cell, clearing all other selections.
        • toggle: true, extend: false. If the specified cell is selected, deselect it. If it is not selected, select it.
        • toggle: true, extend: true. Apply the selection state of the anchor to all cells between it and the specified cell.
        参数：
        rowIndex - affects the selection at row
        columnIndex - affects the selection at column
        toggle - see description above
        extend - if true, extend the current selection
        从以下版本开始：
        1.3

      • getSelectionForeground

        public Color getSelectionForeground()
        Returns the foreground color for selected cells.
        返回：
        the Color object for the foreground property
        另请参见：
        setSelectionForeground(java.awt.Color), setSelectionBackground(java.awt.Color)

      • setSelectionForeground

        public void setSelectionForeground(Color selectionForeground)
        Sets the foreground color for selected cells. Cell renderers can use this color to render text and graphics for selected cells.

        The default value of this property is defined by the look and feel implementation.

        This is a JavaBeans bound property.

        参数：
        selectionForeground - the Color to use in the foreground for selected list items
        另请参见：
        getSelectionForeground(),
setSelectionBackground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font)

      • getSelectionBackground

        public Color getSelectionBackground()
        Returns the background color for selected cells.
        返回：
        the Color used for the background of selected list items
        另请参见：
        setSelectionBackground(java.awt.Color), setSelectionForeground(java.awt.Color)

      • setSelectionBackground

        public void setSelectionBackground(Color selectionBackground)
        Sets the background color for selected cells. Cell renderers can use this color to the fill selected cells.

        The default value of this property is defined by the look and feel implementation.

        This is a JavaBeans bound property.

        参数：
        selectionBackground - the Color to use for the background of selected cells
        另请参见：
        getSelectionBackground(),
setSelectionForeground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font)

      • getColumn

        public TableColumn getColumn(Object identifier)
        Returns the TableColumn object for the column in the table whose identifier is equal to identifier, when compared using equals.
        参数：
        identifier - the identifier object
        返回：
        the TableColumn object that matches the identifier
        抛出：
        IllegalArgumentException - if identifier is null or no TableColumn has this identifier

      • convertColumnIndexToModel

        public int convertColumnIndexToModel(int viewColumnIndex)
        Maps the index of the column in the view at viewColumnIndex to the index of the column in the table model. Returns the index of the corresponding column in the model. If viewColumnIndex is less than zero, returns viewColumnIndex.
        参数：
        viewColumnIndex - the index of the column in the view
        返回：
        the index of the corresponding column in the model
        另请参见：
        convertColumnIndexToView(int)

      • convertColumnIndexToView

        public int convertColumnIndexToView(int modelColumnIndex)
        Maps the index of the column in the table model at modelColumnIndex to the index of the column in the view. Returns the index of the corresponding column in the view; returns -1 if this column is not being displayed. If modelColumnIndex is less than zero, returns modelColumnIndex.
        参数：
        modelColumnIndex - the index of the column in the model
        返回：
        the index of the corresponding column in the view
        另请参见：
        convertColumnIndexToModel(int)

      • convertRowIndexToView

        public int convertRowIndexToView(int modelRowIndex)
        Maps the index of the row in terms of the TableModel to the view. If the contents of the model are not sorted the model and view indices are the same.
        参数：
        modelRowIndex - the index of the row in terms of the model
        返回：
        the index of the corresponding row in the view, or -1 if the row isn't visible
        抛出：
        IndexOutOfBoundsException - if sorting is enabled and passed an index outside the number of rows of the TableModel
        从以下版本开始：
        1.6
        另请参见：
        TableRowSorter

      • convertRowIndexToModel

        public int convertRowIndexToModel(int viewRowIndex)
        Maps the index of the row in terms of the view to the underlying TableModel. If the contents of the model are not sorted the model and view indices are the same.
        参数：
        viewRowIndex - the index of the row in the view
        返回：
        the index of the corresponding row in the model
        抛出：
        IndexOutOfBoundsException - if sorting is enabled and passed an index outside the range of the JTable as determined by the method getRowCount
        从以下版本开始：
        1.6
        另请参见：
        TableRowSorter, getRowCount()

      • getRowCount

        public int getRowCount()
        Returns the number of rows that can be shown in the JTable, given unlimited space. If a RowSorter with a filter has been specified, the number of rows returned may differ from that of the underlying TableModel.
        返回：
        the number of rows shown in the JTable
        另请参见：
        getColumnCount()

      • getColumnCount

        public int getColumnCount()
        Returns the number of columns in the column model. Note that this may be different from the number of columns in the table model.
        返回：
        the number of columns in the table
        另请参见：
        getRowCount(), removeColumn(javax.swing.table.TableColumn)

      • getColumnName

        public String getColumnName(int column)
        Returns the name of the column appearing in the view at column position column.
        参数：
        column - the column in the view being queried
        返回：
        the name of the column at position column in the view where the first column is column 0

      • getColumnClass

        public 类<?> getColumnClass(int column)
        Returns the type of the column appearing in the view at column position column.
        参数：
        column - the column in the view being queried
        返回：
        the type of the column at position column in the view where the first column is column 0

      • getValueAt

        public Object getValueAt(int row,
                int column)
        Returns the cell value at row and column.

        Note: The column is specified in the table view's display order, and not in the TableModel's column order. This is an important distinction because as the user rearranges the columns in the table, the column at a given index in the view will change. Meanwhile the user's actions never affect the model's column ordering.

        参数：
        row - the row whose value is to be queried
        column - the column whose value is to be queried
        返回：
        the Object at the specified cell

      • setValueAt

        public void setValueAt(Object aValue,
              int row,
              int column)
        Sets the value for the cell in the table model at row and column.

        Note: The column is specified in the table view's display order, and not in the TableModel's column order. This is an important distinction because as the user rearranges the columns in the table, the column at a given index in the view will change. Meanwhile the user's actions never affect the model's column ordering. aValue is the new value.

        参数：
        aValue - the new value
        row - the row of the cell to be changed
        column - the column of the cell to be changed
        另请参见：
        getValueAt(int, int)

      • isCellEditable

        public boolean isCellEditable(int row,
                     int column)
        Returns true if the cell at row and column is editable. Otherwise, invoking setValueAt on the cell will have no effect.

        Note: The column is specified in the table view's display order, and not in the TableModel's column order. This is an important distinction because as the user rearranges the columns in the table, the column at a given index in the view will change. Meanwhile the user's actions never affect the model's column ordering.

        参数：
        row - the row whose value is to be queried
        column - the column whose value is to be queried
        返回：
        true if the cell is editable
        另请参见：
        setValueAt(java.lang.Object, int, int)

      • addColumn

        public void addColumn(TableColumn aColumn)
        Appends aColumn to the end of the array of columns held by this JTable's column model. If the column name of aColumn is null, sets the column name of aColumn to the name returned by getModel().getColumnName().

        To add a column to this JTable to display the modelColumn'th column of data in the model with a given width, cellRenderer, and cellEditor you can use:

      addColumn(new TableColumn(modelColumn, width, cellRenderer, cellEditor));
        [Any of the TableColumn constructors can be used instead of this one.] The model column number is stored inside the TableColumn and is used during rendering and editing to locate the appropriates data values in the model. The model column number does not change when columns are reordered in the view.
        参数：
        aColumn - the TableColumn to be added
        另请参见：
        removeColumn(javax.swing.table.TableColumn)

      • removeColumn

        public void removeColumn(TableColumn aColumn)
        Removes aColumn from this JTable's array of columns. Note: this method does not remove the column of data from the model; it just removes the TableColumn that was responsible for displaying it.
        参数：
        aColumn - the TableColumn to be removed
        另请参见：
        addColumn(javax.swing.table.TableColumn)

      • moveColumn

        public void moveColumn(int column,
              int targetColumn)
        Moves the column column to the position currently occupied by the column targetColumn in the view. The old column at targetColumn is shifted left or right to make room.
        参数：
        column - the index of column to be moved
        targetColumn - the new index of the column

      • columnAtPoint

        public int columnAtPoint(Point point)
        Returns the index of the column that point lies in, or -1 if the result is not in the range [0, getColumnCount()-1].
        参数：
        point - the location of interest
        返回：
        the index of the column that point lies in, or -1 if the result is not in the range [0, getColumnCount()-1]
        另请参见：
        rowAtPoint(java.awt.Point)

      • rowAtPoint

        public int rowAtPoint(Point point)
        Returns the index of the row that point lies in, or -1 if the result is not in the range [0, getRowCount()-1].
        参数：
        point - the location of interest
        返回：
        the index of the row that point lies in, or -1 if the result is not in the range [0, getRowCount()-1]
        另请参见：
        columnAtPoint(java.awt.Point)

      • getCellRect

        public Rectangle getCellRect(int row,
                    int column,
                    boolean includeSpacing)
        Returns a rectangle for the cell that lies at the intersection of row and column. If includeSpacing is true then the value returned has the full height and width of the row and column specified. If it is false, the returned rectangle is inset by the intercell spacing to return the true bounds of the rendering or editing component as it will be set during rendering.

        If the column index is valid but the row index is less than zero the method returns a rectangle with the y and height values set appropriately and the x and width values both set to zero. In general, when either the row or column indices indicate a cell outside the appropriate range, the method returns a rectangle depicting the closest edge of the closest cell that is within the table's range. When both row and column indices are out of range the returned rectangle covers the closest point of the closest cell.

        In all cases, calculations that use this method to calculate results along one axis will not fail because of anomalies in calculations along the other axis. When the cell is not valid the includeSpacing parameter is ignored.

        参数：
        row - the row index where the desired cell is located
        column - the column index where the desired cell is located in the display; this is not necessarily the same as the column index in the data model for the table; the convertColumnIndexToView(int) method may be used to convert a data model column index to a display column index
        includeSpacing - if false, return the true cell bounds - computed by subtracting the intercell spacing from the height and widths of the column and row models
        返回：
        the rectangle containing the cell at location row,column
        另请参见：
        getIntercellSpacing()

      • doLayout

        public void doLayout()
        Causes this table to lay out its rows and columns. Overridden so that columns can be resized to accomodate a change in the size of a containing parent. Resizes one or more of the columns in the table so that the total width of all of this JTable's columns is equal to the width of the table.

        Before the layout begins the method gets the resizingColumn of the tableHeader. When the method is called as a result of the resizing of an enclosing window, the resizingColumn is null. This means that resizing has taken place "outside" the JTable and the change - or "delta" - should be distributed to all of the columns regardless of this JTable's automatic resize mode.

        If the resizingColumn is not null, it is one of the columns in the table that has changed size rather than the table itself. In this case the auto-resize modes govern the way the extra (or deficit) space is distributed amongst the available columns.

        The modes are:

        • AUTO_RESIZE_OFF: Don't automatically adjust the column's widths at all. Use a horizontal scrollbar to accomodate the columns when their sum exceeds the width of the Viewport. If the JTable is not enclosed in a JScrollPane this may leave parts of the table invisible.
        • AUTO_RESIZE_NEXT_COLUMN: Use just the column after the resizing column. This results in the "boundary" or divider between adjacent cells being independently adjustable.
        • AUTO_RESIZE_SUBSEQUENT_COLUMNS: Use all columns after the one being adjusted to absorb the changes. This is the default behavior.
        • AUTO_RESIZE_LAST_COLUMN: Automatically adjust the size of the last column only. If the bounds of the last column prevent the desired size from being allocated, set the width of the last column to the appropriate limit and make no further adjustments.
        • AUTO_RESIZE_ALL_COLUMNS: Spread the delta amongst all the columns in the JTable, including the one that is being adjusted.

        Note: When a JTable makes adjustments to the widths of the columns it respects their minimum and maximum values absolutely. It is therefore possible that, even after this method is called, the total width of the columns is still not equal to the width of the table. When this happens the JTable does not put itself in AUTO_RESIZE_OFF mode to bring up a scroll bar, or break other commitments of its current auto-resize mode -- instead it allows its bounds to be set larger (or smaller) than the total of the column minimum or maximum, meaning, either that there will not be enough room to display all of the columns, or that the columns will not fill the JTable's bounds. These respectively, result in the clipping of some columns or an area being painted in the JTable's background color during painting.

        The mechanism for distributing the delta amongst the available columns is provided in a private method in the JTable class:

           adjustSizes(long targetSize, final Resizable3 r, boolean inverse)
        an explanation of which is provided in the following section. Resizable3 is a private interface that allows any data structure containing a collection of elements with a size, preferred size, maximum size and minimum size to have its elements manipulated by the algorithm.

        Distributing the delta

        Overview

        Call "DELTA" the difference between the target size and the sum of the preferred sizes of the elements in r. The individual sizes are calculated by taking the original preferred sizes and adding a share of the DELTA - that share being based on how far each preferred size is from its limiting bound (minimum or maximum).

        Definition

        Call the individual constraints min[i], max[i], and pref[i].

        Call their respective sums: MIN, MAX, and PREF.

        Each new size will be calculated using:

                  size[i] = pref[i] + delta[i]
        where each individual delta[i] is calculated according to:

        If (DELTA < 0) we are in shrink mode where:

                                DELTA
          delta[i] = ------------ * (pref[i] - min[i])
                     (PREF - MIN)
        If (DELTA > 0) we are in expand mode where:

                                DELTA
          delta[i] = ------------ * (max[i] - pref[i])
                      (MAX - PREF)

        The overall effect is that the total size moves that same percentage, k, towards the total minimum or maximum and that percentage guarantees accomodation of the required space, DELTA.

        Details

        Naive evaluation of the formulae presented here would be subject to the aggregated rounding errors caused by doing this operation in finite precision (using ints). To deal with this, the multiplying factor above, is constantly recalculated and this takes account of the rounding errors in the previous iterations. The result is an algorithm that produces a set of integers whose values exactly sum to the supplied targetSize, and does so by spreading the rounding errors evenly over the given elements.

        When the MAX and MIN bounds are hit

        When targetSize is outside the [MIN, MAX] range, the algorithm sets all sizes to their appropriate limiting value (maximum or minimum).

        重载：
        doLayout in class Container
        另请参见：
        LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

      • sizeColumnsToFit

        @Deprecated
public void sizeColumnsToFit(boolean lastColumnOnly)
        Deprecated. As of Swing version 1.0.3, replaced by doLayout().
        Sizes the table columns to fit the available space.
        另请参见：
        doLayout()

      • sizeColumnsToFit

        public void sizeColumnsToFit(int resizingColumn)
        Obsolete as of Java 2 platform v1.4. Please use the doLayout() method instead.
        参数：
        resizingColumn - the column whose resizing made this adjustment necessary or -1 if there is no such column
        另请参见：
        doLayout()

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Overrides JComponent's getToolTipText method in order to allow the renderer's tips to be used if it has text set.

        Note: For JTable to properly display tooltips of its renderers JTable must be a registered component with the ToolTipManager. This is done automatically in initializeLocalVars, but if at a later point JTable is told setToolTipText(null) it will unregister the table component, and no tips from renderers will display anymore.

        重载：
        getToolTipText in class JComponent
        另请参见：
        JComponent.getToolTipText()

      • setSurrendersFocusOnKeystroke

        public void setSurrendersFocusOnKeystroke(boolean surrendersFocusOnKeystroke)
        Sets whether editors in this JTable get the keyboard focus when an editor is activated as a result of the JTable forwarding keyboard events for a cell. By default, this property is false, and the JTable retains the focus unless the cell is clicked.
        参数：
        surrendersFocusOnKeystroke - true if the editor should get the focus when keystrokes cause the editor to be activated
        从以下版本开始：
        1.4
        另请参见：
        getSurrendersFocusOnKeystroke()

      • getSurrendersFocusOnKeystroke

        public boolean getSurrendersFocusOnKeystroke()
        Returns true if the editor should get the focus when keystrokes cause the editor to be activated
        返回：
        true if the editor should get the focus when keystrokes cause the editor to be activated
        从以下版本开始：
        1.4
        另请参见：
        setSurrendersFocusOnKeystroke(boolean)

      • editCellAt

        public boolean editCellAt(int row,
                 int column)
        Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable. Note that this is a convenience method for editCellAt(int, int, null).
        参数：
        row - the row to be edited
        column - the column to be edited
        返回：
        false if for any reason the cell cannot be edited, or if the indices are invalid

      • editCellAt

        public boolean editCellAt(int row,
                 int column,
                 EventObject e)
        Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable. To prevent the JTable from editing a particular table, column or cell value, return false from the isCellEditable method in the TableModel interface.
        参数：
        row - the row to be edited
        column - the column to be edited
        e - event to pass into shouldSelectCell; note that as of Java 2 platform v1.2, the call to shouldSelectCell is no longer made
        返回：
        false if for any reason the cell cannot be edited, or if the indices are invalid

      • isEditing

        public boolean isEditing()
        Returns true if a cell is being edited.
        返回：
        true if the table is editing a cell
        另请参见：
        editingColumn, editingRow

      • getEditorComponent

        public Component getEditorComponent()
        Returns the component that is handling the editing session. If nothing is being edited, returns null.
        返回：
        Component handling editing session

      • getEditingColumn

        public int getEditingColumn()
        Returns the index of the column that contains the cell currently being edited. If nothing is being edited, returns -1.
        返回：
        the index of the column that contains the cell currently being edited; returns -1 if nothing being edited
        另请参见：
        editingRow

      • getEditingRow

        public int getEditingRow()
        Returns the index of the row that contains the cell currently being edited. If nothing is being edited, returns -1.
        返回：
        the index of the row that contains the cell currently being edited; returns -1 if nothing being edited
        另请参见：
        editingColumn

      • getUI

        public TableUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the TableUI object that renders this component

      • setUI

        public void setUI(TableUI ui)
        Sets the L&F object that renders this component and repaints.
        参数：
        ui - the TableUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the suffix used to construct the name of the L&F class used to render this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "TableUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setModel

        public void setModel(TableModel dataModel)
        Sets the data model for this table to newModel and registers with it for listener notifications from the new data model.
        参数：
        dataModel - the new data source for this table
        抛出：
        IllegalArgumentException - if newModel is null
        另请参见：
        getModel()

      • getModel

        public TableModel getModel()
        Returns the TableModel that provides the data displayed by this JTable.
        返回：
        the TableModel that provides the data displayed by this JTable
        另请参见：
        setModel(javax.swing.table.TableModel)

      • setColumnModel

        public void setColumnModel(TableColumnModel columnModel)
        Sets the column model for this table to newModel and registers for listener notifications from the new column model. Also sets the column model of the JTableHeader to columnModel.
        参数：
        columnModel - the new data source for this table
        抛出：
        IllegalArgumentException - if columnModel is null
        另请参见：
        getColumnModel()

      • getColumnModel

        public TableColumnModel getColumnModel()
        Returns the TableColumnModel that contains all column information of this table.
        返回：
        the object that provides the column state of the table
        另请参见：
        setColumnModel(javax.swing.table.TableColumnModel)

      • setSelectionModel

        public void setSelectionModel(ListSelectionModel newModel)
        Sets the row selection model for this table to newModel and registers for listener notifications from the new selection model.
        参数：
        newModel - the new selection model
        抛出：
        IllegalArgumentException - if newModel is null
        另请参见：
        getSelectionModel()

      • getSelectionModel

        public ListSelectionModel getSelectionModel()
        Returns the ListSelectionModel that is used to maintain row selection state.
        返回：
        the object that provides row selection state, null if row selection is not allowed
        另请参见：
        setSelectionModel(javax.swing.ListSelectionModel)

      • sorterChanged

        public void sorterChanged(RowSorterEvent e)
        RowSorterListener notification that the RowSorter has changed in some way.
        指定者：
        sorterChanged in interface RowSorterListener
        参数：
        e - the RowSorterEvent describing the change
        抛出：
        NullPointerException - if e is null
        从以下版本开始：
        1.6

      • tableChanged

        public void tableChanged(TableModelEvent e)
        Invoked when this table's TableModel generates a TableModelEvent. The TableModelEvent should be constructed in the coordinate system of the model; the appropriate mapping to the view coordinate system is performed by this JTable when it receives the event.

        Application code will not use these methods explicitly, they are used internally by JTable.

        Note that as of 1.3, this method clears the selection, if any.

        指定者：
        tableChanged in interface TableModelListener

      • columnAdded

        public void columnAdded(TableColumnModelEvent e)
        Invoked when a column is added to the table column model.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnAdded in interface TableColumnModelListener
        另请参见：
        TableColumnModelListener

      • columnRemoved

        public void columnRemoved(TableColumnModelEvent e)
        Invoked when a column is removed from the table column model.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnRemoved in interface TableColumnModelListener
        另请参见：
        TableColumnModelListener

      • columnMoved

        public void columnMoved(TableColumnModelEvent e)
        Invoked when a column is repositioned. If a cell is being edited, then editing is stopped and the cell is redrawn.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnMoved in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnMarginChanged

        public void columnMarginChanged(ChangeEvent e)
        Invoked when a column is moved due to a margin change. If a cell is being edited, then editing is stopped and the cell is redrawn.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnMarginChanged in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnSelectionChanged

        public void columnSelectionChanged(ListSelectionEvent e)
        Invoked when the selection model of the TableColumnModel is changed.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnSelectionChanged in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        Invoked when the row selection changes -- repaints to show the new selection.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the event received
        另请参见：
        ListSelectionListener

      • editingStopped

        public void editingStopped(ChangeEvent e)
        Invoked when editing is finished. The changes are saved and the editor is discarded.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        editingStopped in interface CellEditorListener
        参数：
        e - the event received
        另请参见：
        CellEditorListener

      • editingCanceled

        public void editingCanceled(ChangeEvent e)
        Invoked when editing is canceled. The editor object is discarded and the cell is rendered once again.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        editingCanceled in interface CellEditorListener
        参数：
        e - the event received
        另请参见：
        CellEditorListener

      • setPreferredScrollableViewportSize

        public void setPreferredScrollableViewportSize(Dimension size)
        Sets the preferred size of the viewport for this table.
        参数：
        size - a Dimension object specifying the preferredSize of a JViewport whose view is this table
        另请参见：
        Scrollable.getPreferredScrollableViewportSize()

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Returns the preferred size of the viewport for this table.
        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        返回：
        a Dimension object containing the preferredSize of the JViewport which displays this table
        另请参见：
        Scrollable.getPreferredScrollableViewportSize()

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Returns the scroll increment (in pixels) that completely exposes one new row or column (depending on the orientation).

        This method is called each time the user requests a unit scroll.

        指定者：
        getScrollableUnitIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        the "unit" increment for scrolling in the specified direction
        另请参见：
        Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

      • getScrollableBlockIncrement

        public int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Returns visibleRect.height or visibleRect.width, depending on this table's orientation. Note that as of Swing 1.1.1 (Java 2 v 1.2.2) the value returned will ensure that the viewport is cleanly aligned on a row boundary.
        指定者：
        getScrollableBlockIncrement in interface Scrollable
        参数：
        visibleRect - The view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        visibleRect.height or visibleRect.width per the orientation
        另请参见：
        Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns false if autoResizeMode is set to AUTO_RESIZE_OFF, which indicates that the width of the viewport does not determine the width of the table. Otherwise returns true.
        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        返回：
        false if autoResizeMode is set to AUTO_RESIZE_OFF, otherwise returns true
        另请参见：
        Scrollable.getScrollableTracksViewportWidth()

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns false to indicate that the height of the viewport does not determine the height of the table, unless getFillsViewportHeight is true and the preferred height of the table is smaller than the viewport's height.
        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        返回：
        false unless getFillsViewportHeight is true and the table needs to be stretched to fill the viewport
        另请参见：
        Scrollable.getScrollableTracksViewportHeight(), setFillsViewportHeight(boolean), getFillsViewportHeight()

      • setFillsViewportHeight

        public void setFillsViewportHeight(boolean fillsViewportHeight)
        Sets whether or not this table is always made large enough to fill the height of an enclosing viewport. If the preferred height of the table is smaller than the viewport, then the table will be stretched to fill the viewport. In other words, this ensures the table is never smaller than the viewport. The default for this property is false.
        参数：
        fillsViewportHeight - whether or not this table is always made large enough to fill the height of an enclosing viewport
        从以下版本开始：
        1.6
        另请参见：
        getFillsViewportHeight(), getScrollableTracksViewportHeight()

      • getFillsViewportHeight

        public boolean getFillsViewportHeight()
        Returns whether or not this table is always made large enough to fill the height of an enclosing viewport.
        返回：
        whether or not this table is always made large enough to fill the height of an enclosing viewport
        从以下版本开始：
        1.6
        另请参见：
        setFillsViewportHeight(boolean)

      • processKeyBinding

        protected boolean processKeyBinding(KeyStroke ks,
                        KeyEvent e,
                        int condition,
                        boolean pressed)
        Description copied from class: JComponent
        Invoked to process the key bindings for ks as the result of the KeyEvent e. This obtains the appropriate InputMap, gets the binding, gets the action from the ActionMap, and then (if the action is found and the component is enabled) invokes notifyAction to notify the action.
        重载：
        processKeyBinding in class JComponent
        参数：
        ks - the KeyStroke queried
        e - the KeyEvent
        condition - one of the following values:
        • JComponent.WHEN_FOCUSED
        • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
        • JComponent.WHEN_IN_FOCUSED_WINDOW
        pressed - true if the key is pressed
        返回：
        true if there was a binding to an action, and the action was enabled

      • createDefaultRenderers

        protected void createDefaultRenderers()
        Creates default cell renderers for objects, numbers, doubles, dates, booleans, and icons.
        另请参见：
        DefaultTableCellRenderer

      • createDefaultEditors

        protected void createDefaultEditors()
        Creates default cell editors for objects, numbers, and boolean values.
        另请参见：
        DefaultCellEditor

      • initializeLocalVars

        protected void initializeLocalVars()
        Initializes table properties to their default values.

      • createDefaultDataModel

        protected TableModel createDefaultDataModel()
        Returns the default table model object, which is a DefaultTableModel. A subclass can override this method to return a different table model object.
        返回：
        the default table model object
        另请参见：
        DefaultTableModel

      • createDefaultColumnModel

        protected TableColumnModel createDefaultColumnModel()
        Returns the default column model object, which is a DefaultTableColumnModel. A subclass can override this method to return a different column model object.
        返回：
        the default column model object
        另请参见：
        DefaultTableColumnModel

      • createDefaultSelectionModel

        protected ListSelectionModel createDefaultSelectionModel()
        Returns the default selection model object, which is a DefaultListSelectionModel. A subclass can override this method to return a different selection model object.
        返回：
        the default selection model object
        另请参见：
        DefaultListSelectionModel

      • createDefaultTableHeader

        protected JTableHeader createDefaultTableHeader()
        Returns the default table header object, which is a JTableHeader. A subclass can override this method to return a different table header object.
        返回：
        the default table header object
        另请参见：
        JTableHeader

      • resizeAndRepaint

        protected void resizeAndRepaint()
        Equivalent to revalidate followed by repaint.

      • getCellEditor

        public TableCellEditor getCellEditor()
        Returns the active cell editor, which is null if the table is not currently editing.
        返回：
        the TableCellEditor that does the editing, or null if the table is not currently editing.
        另请参见：
        cellEditor, getCellEditor(int, int)

      • setCellEditor

        public void setCellEditor(TableCellEditor anEditor)
        Sets the active cell editor.
        参数：
        anEditor - the active cell editor
        另请参见：
        cellEditor

      • setEditingColumn

        public void setEditingColumn(int aColumn)
        Sets the editingColumn variable.
        参数：
        aColumn - the column of the cell to be edited
        另请参见：
        editingColumn

      • setEditingRow

        public void setEditingRow(int aRow)
        Sets the editingRow variable.
        参数：
        aRow - the row of the cell to be edited
        另请参见：
        editingRow

      • getCellRenderer

        public TableCellRenderer getCellRenderer(int row,
                                int column)
        Returns an appropriate renderer for the cell specified by this row and column. If the TableColumn for this column has a non-null renderer, returns that. If not, finds the class of the data in this column (using getColumnClass) and returns the default renderer for this type of data.

        Note: Throughout the table package, the internal implementations always use this method to provide renderers so that this default behavior can be safely overridden by a subclass.

        参数：
        row - the row of the cell to render, where 0 is the first row
        column - the column of the cell to render, where 0 is the first column
        返回：
        the assigned renderer; if null returns the default renderer for this type of object
        另请参见：
        DefaultTableCellRenderer, TableColumn.setCellRenderer(javax.swing.table.TableCellRenderer), setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

      • prepareRenderer

        public Component prepareRenderer(TableCellRenderer renderer,
                        int row,
                        int column)
        Prepares the renderer by querying the data model for the value and selection state of the cell at row, column. Returns the component (may be a Component or a JComponent) under the event location.

        During a printing operation, this method will configure the renderer without indicating selection or focus, to prevent them from appearing in the printed output. To do other customizations based on whether or not the table is being printed, you can check the value of JComponent.isPaintingForPrint(), either here or within custom renderers.

        Note: Throughout the table package, the internal implementations always use this method to prepare renderers so that this default behavior can be safely overridden by a subclass.

        参数：
        renderer - the TableCellRenderer to prepare
        row - the row of the cell to render, where 0 is the first row
        column - the column of the cell to render, where 0 is the first column
        返回：
        the Component under the event location

      • getCellEditor

        public TableCellEditor getCellEditor(int row,
                            int column)
        Returns an appropriate editor for the cell specified by row and column. If the TableColumn for this column has a non-null editor, returns that. If not, finds the class of the data in this column (using getColumnClass) and returns the default editor for this type of data.

        Note: Throughout the table package, the internal implementations always use this method to provide editors so that this default behavior can be safely overridden by a subclass.

        参数：
        row - the row of the cell to edit, where 0 is the first row
        column - the column of the cell to edit, where 0 is the first column
        返回：
        the editor for this cell; if null return the default editor for this type of cell
        另请参见：
        DefaultCellEditor

      • prepareEditor

        public Component prepareEditor(TableCellEditor editor,
                      int row,
                      int column)
        Prepares the editor by querying the data model for the value and selection state of the cell at row, column.

        Note: Throughout the table package, the internal implementations always use this method to prepare editors so that this default behavior can be safely overridden by a subclass.

        参数：
        editor - the TableCellEditor to set up
        row - the row of the cell to edit, where 0 is the first row
        column - the column of the cell to edit, where 0 is the first column
        返回：
        the Component being edited

      • removeEditor

        public void removeEditor()
        Discards the editor object and frees the real estate it used for cell rendering.

      • paramString

        protected String paramString()
        Returns a string representation of this table. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this table

      • print

        public boolean print()
              throws PrinterException
        A convenience method that displays a printing dialog, and then prints this JTable in mode PrintMode.FIT_WIDTH, with no header or footer text. A modal progress dialog, with an abort option, will be shown for the duration of printing.

        Note: In headless mode, no dialogs are shown and printing occurs on the default printer.

        返回：
        true, unless printing is cancelled by the user
        抛出：
        SecurityException - if this thread is not allowed to initiate a print job request
        PrinterException - if an error in the print system causes the job to be aborted
        从以下版本开始：
        1.5
        另请参见：
        print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

      • print

        public boolean print(JTable.PrintMode printMode)
              throws PrinterException
        A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with no header or footer text. A modal progress dialog, with an abort option, will be shown for the duration of printing.

        Note: In headless mode, no dialogs are shown and printing occurs on the default printer.

        参数：
        printMode - the printing mode that the printable should use
        返回：
        true, unless printing is cancelled by the user
        抛出：
        SecurityException - if this thread is not allowed to initiate a print job request
        PrinterException - if an error in the print system causes the job to be aborted
        从以下版本开始：
        1.5
        另请参见：
        print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

      • print

        public boolean print(JTable.PrintMode printMode,
            MessageFormat headerFormat,
            MessageFormat footerFormat)
              throws PrinterException
        A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with the specified header and footer text. A modal progress dialog, with an abort option, will be shown for the duration of printing.

        Note: In headless mode, no dialogs are shown and printing occurs on the default printer.

        参数：
        printMode - the printing mode that the printable should use
        headerFormat - a MessageFormat specifying the text to be used in printing a header, or null for none
        footerFormat - a MessageFormat specifying the text to be used in printing a footer, or null for none
        返回：
        true, unless printing is cancelled by the user
        抛出：
        SecurityException - if this thread is not allowed to initiate a print job request
        PrinterException - if an error in the print system causes the job to be aborted
        从以下版本开始：
        1.5
        另请参见：
        print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

      • print

        public boolean print(JTable.PrintMode printMode,
            MessageFormat headerFormat,
            MessageFormat footerFormat,
            boolean showPrintDialog,
            PrintRequestAttributeSet attr,
            boolean interactive)
              throws PrinterException,
                     HeadlessException
        Prints this table, as specified by the fully featured print method, with the default printer specified as the print service.
        参数：
        printMode - the printing mode that the printable should use
        headerFormat - a MessageFormat specifying the text to be used in printing a header, or null for none
        footerFormat - a MessageFormat specifying the text to be used in printing a footer, or null for none
        showPrintDialog - whether or not to display a print dialog
        attr - a PrintRequestAttributeSet specifying any printing attributes, or null for none
        interactive - whether or not to print in an interactive mode
        返回：
        true, unless printing is cancelled by the user
        抛出：
        HeadlessException - if the method is asked to show a printing dialog or run interactively, and GraphicsEnvironment.isHeadless returns true
        SecurityException - if this thread is not allowed to initiate a print job request
        PrinterException - if an error in the print system causes the job to be aborted
        从以下版本开始：
        1.5
        另请参见：
        print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

      • print

        public boolean print(JTable.PrintMode printMode,
            MessageFormat headerFormat,
            MessageFormat footerFormat,
            boolean showPrintDialog,
            PrintRequestAttributeSet attr,
            boolean interactive,
            PrintService service)
              throws PrinterException,
                     HeadlessException
        Prints this JTable. Takes steps that the majority of developers would take in order to print a JTable. In short, it prepares the table, calls getPrintable to fetch an appropriate Printable, and then sends it to the printer.

        A boolean parameter allows you to specify whether or not a printing dialog is displayed to the user. When it is, the user may use the dialog to change the destination printer or printing attributes, or even to cancel the print. Another two parameters allow for a PrintService and printing attributes to be specified. These parameters can be used either to provide initial values for the print dialog, or to specify values when the dialog is not shown.

        A second boolean parameter allows you to specify whether or not to perform printing in an interactive mode. If true, a modal progress dialog, with an abort option, is displayed for the duration of printing . This dialog also prevents any user action which may affect the table. However, it can not prevent the table from being modified by code (for example, another thread that posts updates using SwingUtilities.invokeLater). It is therefore the responsibility of the developer to ensure that no other code modifies the table in any way during printing (invalid modifications include changes in: size, renderers, or underlying data). Printing behavior is undefined when the table is changed during printing.

        If false is specified for this parameter, no dialog will be displayed and printing will begin immediately on the event-dispatch thread. This blocks any other events, including repaints, from being processed until printing is complete. Although this effectively prevents the table from being changed, it doesn't provide a good user experience. For this reason, specifying false is only recommended when printing from an application with no visible GUI.

        Note: Attempting to show the printing dialog or run interactively, while in headless mode, will result in a HeadlessException.

        Before fetching the printable, this method will gracefully terminate editing, if necessary, to prevent an editor from showing in the printed result. Additionally, JTable will prepare its renderers during printing such that selection and focus are not indicated. As far as customizing further how the table looks in the printout, developers can provide custom renderers or paint code that conditionalize on the value of JComponent.isPaintingForPrint().

        See getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat) for more description on how the table is printed.

        参数：
        printMode - the printing mode that the printable should use
        headerFormat - a MessageFormat specifying the text to be used in printing a header, or null for none
        footerFormat - a MessageFormat specifying the text to be used in printing a footer, or null for none
        showPrintDialog - whether or not to display a print dialog
        attr - a PrintRequestAttributeSet specifying any printing attributes, or null for none
        interactive - whether or not to print in an interactive mode
        service - the destination PrintService, or null to use the default printer
        返回：
        true, unless printing is cancelled by the user
        抛出：
        HeadlessException - if the method is asked to show a printing dialog or run interactively, and GraphicsEnvironment.isHeadless returns true
        SecurityException - if a security manager exists and its SecurityManager.checkPrintJobAccess() method disallows this thread from creating a print job request
        PrinterException - if an error in the print system causes the job to be aborted
        从以下版本开始：
        1.6
        另请参见：
        getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat), GraphicsEnvironment.isHeadless()

      • getPrintable

        public Printable getPrintable(JTable.PrintMode printMode,
                     MessageFormat headerFormat,
                     MessageFormat footerFormat)
        Return a Printable for use in printing this JTable.

        This method is meant for those wishing to customize the default Printable implementation used by JTable's print methods. Developers wanting simply to print the table should use one of those methods directly.

        The Printable can be requested in one of two printing modes. In both modes, it spreads table rows naturally in sequence across multiple pages, fitting as many rows as possible per page. PrintMode.NORMAL specifies that the table be printed at its current size. In this mode, there may be a need to spread columns across pages in a similar manner to that of the rows. When the need arises, columns are distributed in an order consistent with the table's ComponentOrientation. PrintMode.FIT_WIDTH specifies that the output be scaled smaller, if necessary, to fit the table's entire width (and thereby all columns) on each page. Width and height are scaled equally, maintaining the aspect ratio of the output.

        The Printable heads the portion of table on each page with the appropriate section from the table's JTableHeader, if it has one.

        Header and footer text can be added to the output by providing MessageFormat arguments. The printing code requests Strings from the formats, providing a single item which may be included in the formatted string: an Integer representing the current page number.

        You are encouraged to read the documentation for MessageFormat as some characters, such as single-quote, are special and need to be escaped.

        Here's an example of creating a MessageFormat that can be used to print "Duke's Table: Page - " and the current page number:

             // notice the escaping of the single quote
     // notice how the page number is included with "{0}"
     MessageFormat format = new MessageFormat("Duke''s Table: Page - {0}");

        The Printable constrains what it draws to the printable area of each page that it prints. Under certain circumstances, it may find it impossible to fit all of a page's content into that area. In these cases the output may be clipped, but the implementation makes an effort to do something reasonable. Here are a few situations where this is known to occur, and how they may be handled by this particular implementation:

        • In any mode, when the header or footer text is too wide to fit completely in the printable area -- print as much of the text as possible starting from the beginning, as determined by the table's ComponentOrientation.
        • In any mode, when a row is too tall to fit in the printable area -- print the upper-most portion of the row and paint no lower border on the table.
        • In PrintMode.NORMAL when a column is too wide to fit in the printable area -- print the center portion of the column and leave the left and right borders off the table.

        It is entirely valid for this Printable to be wrapped inside another in order to create complex reports and documents. You may even request that different pages be rendered into different sized printable areas. The implementation must be prepared to handle this (possibly by doing its layout calculations on the fly). However, providing different heights to each page will likely not work well with PrintMode.NORMAL when it has to spread columns across pages.

        As far as customizing how the table looks in the printed result, JTable itself will take care of hiding the selection and focus during printing. For additional customizations, your renderers or painting code can customize the look based on the value of JComponent.isPaintingForPrint()

        Also, before calling this method you may wish to first modify the state of the table, such as to cancel cell editing or have the user size the table appropriately. However, you must not modify the state of the table after this Printable has been fetched (invalid modifications include changes in size or underlying data). The behavior of the returned Printable is undefined once the table has been changed.

        参数：
        printMode - the printing mode that the printable should use
        headerFormat - a MessageFormat specifying the text to be used in printing a header, or null for none
        footerFormat - a MessageFormat specifying the text to be used in printing a footer, or null for none
        返回：
        a Printable for printing this JTable
        从以下版本开始：
        1.5
        另请参见：
        print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean), Printable, PrinterJob

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTable. For tables, the AccessibleContext takes the form of an AccessibleJTable. A new AccessibleJTable instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJTable that serves as the AccessibleContext of this JTable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTable.AccessibleJTable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTable.AccessibleJTable

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JTable.AccessibleJTable
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleExtendedTable, AccessibleSelection, AccessibleTable, CellEditorListener, ListSelectionListener, TableColumnModelListener, TableModelListener
    封闭类：
    JTable

    protected class JTable.AccessibleJTable
extends JComponent.AccessibleJComponent
implements AccessibleSelection, ListSelectionListener, TableModelListener, TableColumnModelListener, CellEditorListener, PropertyChangeListener, AccessibleExtendedTable
    This class implements accessibility support for the JTable class. It provides an implementation of the Java Accessibility API appropriate to table user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  JTable.AccessibleJTable.AccessibleJTableCell
      The class provides an implementation of the Java Accessibility API appropriate to table cells.
      protected class  | JTable.AccessibleJTable.AccessibleJTableModelChange

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected JTable.AccessibleJTable()
      AccessibleJTable constructor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified Accessible child of the object to the object's selection.
      void clearAccessibleSelection()
      Clears the selection in the object, so that no children in the object are selected.
      void columnAdded(TableColumnModelEvent e)
      Track changes to the table contents (column insertions)
      void columnMarginChanged(ChangeEvent e)
      Track changes of a column moving due to margin changes.
      void columnMoved(TableColumnModelEvent e)
      Track changes of a column repositioning.
      void columnRemoved(TableColumnModelEvent e)
      Track changes to the table contents (column deletions)
      void columnSelectionChanged(ListSelectionEvent e)
      Track that the selection model of the TableColumnModel changed.
      void editingCanceled(ChangeEvent e)
      Invoked when editing is canceled.
      void editingStopped(ChangeEvent e)
      Track changes to a cell's contents.
      Accessible getAccessibleAt(int r, int c)
      Returns the Accessible at a specified row and column in the table.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleCaption()
      Returns the caption for the table.
      Accessible getAccessibleChild(int i)
      Returns the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      int getAccessibleColumn(int index)
      Returns the column number of an index in the table.
      int getAccessibleColumnAtIndex(int i)
      Returns the column at a given index into the table.
      int getAccessibleColumnCount()
      Returns the number of columns in the table.
      Accessible getAccessibleColumnDescription(int c)
      Returns the description of the specified column in the table.
      int getAccessibleColumnExtentAt(int r, int c)
      Returns the number of columns occupied by the Accessible at a given (row, column).
      AccessibleTable getAccessibleColumnHeader()
      Returns the column headers as an AccessibleTable.
      int getAccessibleIndex(int r, int c)
      Returns the index at a row and column in the table.
      int getAccessibleIndexAt(int r, int c)
      Returns the index at a given (row, column) in the table.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      int getAccessibleRow(int index)
      Returns the row number of an index in the table.
      int getAccessibleRowAtIndex(int i)
      Returns the row at a given index into the table.
      int getAccessibleRowCount()
      Returns the number of rows in the table.
      Accessible getAccessibleRowDescription(int r)
      Returns the description of the specified row in the table.
      int getAccessibleRowExtentAt(int r, int c)
      Returns the number of rows occupied by the Accessible at a specified row and column in the table.
      AccessibleTable getAccessibleRowHeader()
      Returns the row headers as an AccessibleTable.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected child in the object.
      int getAccessibleSelectionCount()
      Returns the number of Accessible children currently selected.
      Accessible getAccessibleSummary()
      Returns the summary description of the table.
      AccessibleTable getAccessibleTable()
      Gets the AccessibleTable associated with this object.
      int[] getSelectedAccessibleColumns()
      Returns the selected columns in a table.
      int[] getSelectedAccessibleRows()
      Returns the selected rows in a table.
      boolean isAccessibleChildSelected(int i)
      Determines if the current child of this object is selected.
      boolean isAccessibleColumnSelected(int c)
      Returns a boolean value indicating whether the specified column is selected.
      boolean isAccessibleRowSelected(int r)
      Returns a boolean value indicating whether the specified row is selected.
      boolean isAccessibleSelected(int r, int c)
      Returns a boolean value indicating whether the accessible at a given (row, column) is selected.
      void propertyChange(PropertyChangeEvent e)
      Track changes to selection model, column model, etc.
      void removeAccessibleSelection(int i)
      Removes the specified child of the object from the object's selection.
      void selectAllAccessibleSelection()
      Causes every child of the object to be selected, but only if the JTable supports multiple selections, and if individual cell selection is enabled.
      void setAccessibleCaption(Accessible a)
      Sets the caption for the table.
      void setAccessibleColumnDescription(int c, Accessible a)
      Sets the description text of the specified column of the table.
      void setAccessibleColumnHeader(AccessibleTable a)
      Sets the column headers as an AccessibleTable.
      void setAccessibleRowDescription(int r, Accessible a)
      Sets the description text of the specified row of the table.
      void setAccessibleRowHeader(AccessibleTable a)
      Sets the row headers as an AccessibleTable.
      void setAccessibleSummary(Accessible a)
      Sets the summary description of the table.
      void tableChanged(TableModelEvent e)
      Track changes to the table contents
      void tableRowsDeleted(TableModelEvent e)
      Track changes to the table contents (row deletions)
      void tableRowsInserted(TableModelEvent e)
      Track changes to the table contents (row insertions)
      void valueChanged(ListSelectionEvent e)
      Track changes to table cell selections

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTable.AccessibleJTable

        protected JTable.AccessibleJTable()
        AccessibleJTable constructor
        从以下版本开始：
        1.5

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Track changes to selection model, column model, etc. so as to be able to re-place listeners on those in order to pass on information to the Accessibility PropertyChange mechanism
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • tableChanged

        public void tableChanged(TableModelEvent e)
        Track changes to the table contents
        指定者：
        tableChanged in interface TableModelListener

      • tableRowsInserted

        public void tableRowsInserted(TableModelEvent e)
        Track changes to the table contents (row insertions)

      • tableRowsDeleted

        public void tableRowsDeleted(TableModelEvent e)
        Track changes to the table contents (row deletions)

      • columnAdded

        public void columnAdded(TableColumnModelEvent e)
        Track changes to the table contents (column insertions)
        指定者：
        columnAdded in interface TableColumnModelListener

      • columnRemoved

        public void columnRemoved(TableColumnModelEvent e)
        Track changes to the table contents (column deletions)
        指定者：
        columnRemoved in interface TableColumnModelListener

      • columnMoved

        public void columnMoved(TableColumnModelEvent e)
        Track changes of a column repositioning.
        指定者：
        columnMoved in interface TableColumnModelListener
        另请参见：
        TableColumnModelListener

      • columnMarginChanged

        public void columnMarginChanged(ChangeEvent e)
        Track changes of a column moving due to margin changes.
        指定者：
        columnMarginChanged in interface TableColumnModelListener
        另请参见：
        TableColumnModelListener

      • columnSelectionChanged

        public void columnSelectionChanged(ListSelectionEvent e)
        Track that the selection model of the TableColumnModel changed.
        指定者：
        columnSelectionChanged in interface TableColumnModelListener
        另请参见：
        TableColumnModelListener

      • editingStopped

        public void editingStopped(ChangeEvent e)
        Track changes to a cell's contents. Invoked when editing is finished. The changes are saved, the editor object is discarded, and the cell is rendered once again.
        指定者：
        editingStopped in interface CellEditorListener
        另请参见：
        CellEditorListener

      • editingCanceled

        public void editingCanceled(ChangeEvent e)
        Invoked when editing is canceled. The editor object is discarded and the cell is rendered once again.
        指定者：
        editingCanceled in interface CellEditorListener
        另请参见：
        CellEditorListener

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        Track changes to table cell selections
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the event that characterizes the change.

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - the point defining the top-left corner of the Accessible, given in the coordinate space of the object's parent
        返回：
        the Accessible, if it exists, at the specified location; else null

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, then this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the nth Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns the number of Accessible children currently selected. If no children are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns an Accessible representing the specified selected child in the object. If there isn't a selection, or there are fewer children selected than the integer passed in, the return value will be null.

        Note that the index represents the i-th selected child, which is different from the i-th child.

        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected children
        返回：
        the i-th selected child
        另请参见：
        getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Determines if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object
        返回：
        true if the current child of this object is selected
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Adds the specified Accessible child of the object to the object's selection. If the object supports multiple selections, the specified child is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified child is already selected, this method has no effect.

        This method only works on JTables which have individual cell selection enabled.

        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the specified child of the object from the object's selection. If the specified item isn't currently selected, this method has no effect.

        This method only works on JTables which have individual cell selection enabled.

        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of the child
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that no children in the object are selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Causes every child of the object to be selected, but only if the JTable supports multiple selections, and if individual cell selection is enabled.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection

      • getAccessibleRow

        public int getAccessibleRow(int index)
        Returns the row number of an index in the table.
        指定者：
        getAccessibleRow in interface AccessibleExtendedTable
        参数：
        index - the zero-based index in the table
        返回：
        the zero-based row of the table if one exists; otherwise -1.
        从以下版本开始：
        1.4

      • getAccessibleColumn

        public int getAccessibleColumn(int index)
        Returns the column number of an index in the table.
        指定者：
        getAccessibleColumn in interface AccessibleExtendedTable
        参数：
        index - the zero-based index in the table
        返回：
        the zero-based column of the table if one exists; otherwise -1.
        从以下版本开始：
        1.4

      • getAccessibleIndex

        public int getAccessibleIndex(int r,
                     int c)
        Returns the index at a row and column in the table.
        指定者：
        getAccessibleIndex in interface AccessibleExtendedTable
        参数：
        r - zero-based row of the table
        c - zero-based column of the table
        返回：
        the zero-based index in the table if one exists; otherwise -1.
        从以下版本开始：
        1.4

      • getAccessibleTable

        public AccessibleTable getAccessibleTable()
        Gets the AccessibleTable associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleTables interface on behalf of itself.
        重载：
        getAccessibleTable in class AccessibleContext
        返回：
        this object
        从以下版本开始：
        1.3
        另请参见：
        AccessibleTable

      • getAccessibleCaption

        public Accessible getAccessibleCaption()
        Returns the caption for the table.
        指定者：
        getAccessibleCaption in interface AccessibleTable
        返回：
        the caption for the table
        从以下版本开始：
        1.3

      • setAccessibleCaption

        public void setAccessibleCaption(Accessible a)
        Sets the caption for the table.
        指定者：
        setAccessibleCaption in interface AccessibleTable
        参数：
        a - the caption for the table
        从以下版本开始：
        1.3

      • getAccessibleSummary

        public Accessible getAccessibleSummary()
        Returns the summary description of the table.
        指定者：
        getAccessibleSummary in interface AccessibleTable
        返回：
        the summary description of the table
        从以下版本开始：
        1.3

      • setAccessibleSummary

        public void setAccessibleSummary(Accessible a)
        Sets the summary description of the table.
        指定者：
        setAccessibleSummary in interface AccessibleTable
        参数：
        a - the summary description of the table
        从以下版本开始：
        1.3

      • getAccessibleRowCount

        public int getAccessibleRowCount()
        从接口复制的描述： AccessibleTable
        Returns the number of rows in the table.
        指定者：
        getAccessibleRowCount in interface AccessibleTable
        返回：
        the number of rows in the table

      • getAccessibleColumnCount

        public int getAccessibleColumnCount()
        从接口复制的描述： AccessibleTable
        Returns the number of columns in the table.
        指定者：
        getAccessibleColumnCount in interface AccessibleTable
        返回：
        the number of columns in the table

      • getAccessibleAt

        public Accessible getAccessibleAt(int r,
                         int c)
        从接口复制的描述： AccessibleTable
        Returns the Accessible at a specified row and column in the table.
        指定者：
        getAccessibleAt in interface AccessibleTable
        参数：
        r - zero-based row of the table
        c - zero-based column of the table
        返回：
        the Accessible at the specified row and column

      • getAccessibleRowExtentAt

        public int getAccessibleRowExtentAt(int r,
                           int c)
        Returns the number of rows occupied by the Accessible at a specified row and column in the table.
        指定者：
        getAccessibleRowExtentAt in interface AccessibleTable
        返回：
        the number of rows occupied by the Accessible at a specified row and column in the table
        从以下版本开始：
        1.3

      • getAccessibleColumnExtentAt

        public int getAccessibleColumnExtentAt(int r,
                              int c)
        Returns the number of columns occupied by the Accessible at a given (row, column).
        指定者：
        getAccessibleColumnExtentAt in interface AccessibleTable
        返回：
        the number of columns occupied by the Accessible at a specified row and column in the table
        从以下版本开始：
        1.3

      • getAccessibleRowHeader

        public AccessibleTable getAccessibleRowHeader()
        Returns the row headers as an AccessibleTable.
        指定者：
        getAccessibleRowHeader in interface AccessibleTable
        返回：
        an AccessibleTable representing the row headers
        从以下版本开始：
        1.3

      • setAccessibleRowHeader

        public void setAccessibleRowHeader(AccessibleTable a)
        Sets the row headers as an AccessibleTable.
        指定者：
        setAccessibleRowHeader in interface AccessibleTable
        参数：
        a - an AccessibleTable representing the row headers
        从以下版本开始：
        1.3

      • getAccessibleColumnHeader

        public AccessibleTable getAccessibleColumnHeader()
        Returns the column headers as an AccessibleTable.
        指定者：
        getAccessibleColumnHeader in interface AccessibleTable
        返回：
        an AccessibleTable representing the column headers, or null if the table header is null
        从以下版本开始：
        1.3

      • setAccessibleColumnHeader

        public void setAccessibleColumnHeader(AccessibleTable a)
        Sets the column headers as an AccessibleTable.
        指定者：
        setAccessibleColumnHeader in interface AccessibleTable
        参数：
        a - an AccessibleTable representing the column headers
        从以下版本开始：
        1.3

      • getAccessibleRowDescription

        public Accessible getAccessibleRowDescription(int r)
        Returns the description of the specified row in the table.
        指定者：
        getAccessibleRowDescription in interface AccessibleTable
        参数：
        r - zero-based row of the table
        返回：
        the description of the row
        从以下版本开始：
        1.3

      • setAccessibleRowDescription

        public void setAccessibleRowDescription(int r,
                               Accessible a)
        Sets the description text of the specified row of the table.
        指定者：
        setAccessibleRowDescription in interface AccessibleTable
        参数：
        r - zero-based row of the table
        a - the description of the row
        从以下版本开始：
        1.3

      • getAccessibleColumnDescription

        public Accessible getAccessibleColumnDescription(int c)
        Returns the description of the specified column in the table.
        指定者：
        getAccessibleColumnDescription in interface AccessibleTable
        参数：
        c - zero-based column of the table
        返回：
        the description of the column
        从以下版本开始：
        1.3

      • setAccessibleColumnDescription

        public void setAccessibleColumnDescription(int c,
                                  Accessible a)
        Sets the description text of the specified column of the table.
        指定者：
        setAccessibleColumnDescription in interface AccessibleTable
        参数：
        c - zero-based column of the table
        a - the description of the column
        从以下版本开始：
        1.3

      • isAccessibleSelected

        public boolean isAccessibleSelected(int r,
                           int c)
        Returns a boolean value indicating whether the accessible at a given (row, column) is selected.
        指定者：
        isAccessibleSelected in interface AccessibleTable
        参数：
        r - zero-based row of the table
        c - zero-based column of the table
        返回：
        the boolean value true if the accessible at (row, column) is selected; otherwise, the boolean value false
        从以下版本开始：
        1.3

      • isAccessibleRowSelected

        public boolean isAccessibleRowSelected(int r)
        Returns a boolean value indicating whether the specified row is selected.
        指定者：
        isAccessibleRowSelected in interface AccessibleTable
        参数：
        r - zero-based row of the table
        返回：
        the boolean value true if the specified row is selected; otherwise, false
        从以下版本开始：
        1.3

      • isAccessibleColumnSelected

        public boolean isAccessibleColumnSelected(int c)
        Returns a boolean value indicating whether the specified column is selected.
        指定者：
        isAccessibleColumnSelected in interface AccessibleTable
        参数：
        c - zero-based column of the table
        返回：
        the boolean value true if the specified column is selected; otherwise, false
        从以下版本开始：
        1.3

      • getSelectedAccessibleRows

        public int[] getSelectedAccessibleRows()
        Returns the selected rows in a table.
        指定者：
        getSelectedAccessibleRows in interface AccessibleTable
        返回：
        an array of selected rows where each element is a zero-based row of the table
        从以下版本开始：
        1.3

      • getSelectedAccessibleColumns

        public int[] getSelectedAccessibleColumns()
        Returns the selected columns in a table.
        指定者：
        getSelectedAccessibleColumns in interface AccessibleTable
        返回：
        an array of selected columns where each element is a zero-based column of the table
        从以下版本开始：
        1.3

      • getAccessibleRowAtIndex

        public int getAccessibleRowAtIndex(int i)
        Returns the row at a given index into the table.
        参数：
        i - zero-based index into the table
        返回：
        the row at a given index
        从以下版本开始：
        1.3

      • getAccessibleColumnAtIndex

        public int getAccessibleColumnAtIndex(int i)
        Returns the column at a given index into the table.
        参数：
        i - zero-based index into the table
        返回：
        the column at a given index
        从以下版本开始：
        1.3

      • getAccessibleIndexAt

        public int getAccessibleIndexAt(int r,
                       int c)
        Returns the index at a given (row, column) in the table.
        参数：
        r - zero-based row of the table
        c - zero-based column of the table
        返回：
        the index into the table
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTable.AccessibleJTable.AccessibleJTableCell

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTable.AccessibleJTable.AccessibleJTableCell

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
  • 所有已实现的接口：
    Accessible, AccessibleComponent
    封闭类：
    JTable.AccessibleJTable

    protected class JTable.AccessibleJTable.AccessibleJTableCell
extends AccessibleContext
implements Accessible, AccessibleComponent
    The class provides an implementation of the Java Accessibility API appropriate to table cells.

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
      Constructs an AccessibleJTableHeaderEntry.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addFocusListener(FocusListener l)
      Adds the specified focus listener to receive focus events from this component.
      void addPropertyChangeListener(PropertyChangeListener l)
      Adds a PropertyChangeListener to the listener list.
      boolean contains(Point p)
      Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
      AccessibleAction getAccessibleAction()
      Gets the AccessibleAction associated with this object if one exists.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleComponent getAccessibleComponent()
      Gets the AccessibleComponent associated with this object if one exists.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this component.
      String getAccessibleDescription()
      Gets the accessible description of this object.
      int getAccessibleIndexInParent()
      Gets the index of this object in its accessible parent.
      String getAccessibleName()
      Gets the accessible name of this object.
      Accessible getAccessibleParent()
      Gets the Accessible parent of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleSelection getAccessibleSelection()
      Gets the AccessibleSelection associated with this object if one exists.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object if one exists.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object if one exists.
      Color getBackground()
      Gets the background color of this object.
      Rectangle getBounds()
      Gets the bounds of this object in the form of a Rectangle object.
      protected AccessibleContext getCurrentAccessibleContext()
      Gets the AccessibleContext for the table cell renderer.
      protected Component getCurrentComponent()
      Gets the table cell renderer component.
      Cursor getCursor()
      Gets the Cursor of this object.
      Font getFont()
      Gets the Font of this object.
      FontMetrics getFontMetrics(Font f)
      Gets the FontMetrics of this object.
      Color getForeground()
      Gets the foreground color of this object.
      Locale getLocale()
      Gets the locale of the component.
      Point getLocation()
      Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
      Point getLocationOnScreen()
      Returns the location of the object on the screen.
      Dimension getSize()
      Returns the size of this object in the form of a Dimension object.
      boolean isEnabled()
      Determines if the object is enabled.
      boolean isFocusTraversable()
      Returns whether this object can accept focus or not.
      boolean isShowing()
      Determines if the object is showing.
      boolean isVisible()
      Determines if this object is visible.
      void removeFocusListener(FocusListener l)
      Removes the specified focus listener so it no longer receives focus events from this component.
      void removePropertyChangeListener(PropertyChangeListener l)
      Removes a PropertyChangeListener from the listener list.
      void requestFocus()
      Requests focus for this object.
      void setAccessibleDescription(String s)
      Sets the accessible description of this object.
      void setAccessibleName(String s)
      Sets the localized accessible name of this object.
      void setBackground(Color c)
      Sets the background color of this object.
      void setBounds(Rectangle r)
      Sets the bounds of this object in the form of a Rectangle object.
      void setCursor(Cursor c)
      Sets the Cursor of this object.
      void setEnabled(boolean b)
      Sets the enabled state of the object.
      void setFont(Font f)
      Sets the Font of this object.
      void setForeground(Color c)
      Sets the foreground color of this object.
      void setLocation(Point p)
      Sets the location of the object relative to the parent.
      void setSize(Dimension d)
      Resizes this object so that it has width and height.
      void setVisible(boolean b)
      Sets the visible state of the object.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTable.AccessibleJTable.AccessibleJTableCell

        public JTable.AccessibleJTable.AccessibleJTableCell(JTable t,
                                            int r,
                                            int c,
                                            int i)
        Constructs an AccessibleJTableHeaderEntry.
        从以下版本开始：
        1.4

    • 方法详细信息

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this component. In the implementation of the Java Accessibility API for this class, return this object, which is its own AccessibleContext.
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        this object

      • getCurrentAccessibleContext

        protected AccessibleContext getCurrentAccessibleContext()
        Gets the AccessibleContext for the table cell renderer.
        返回：
        the AccessibleContext for the table cell renderer if one exists; otherwise, returns null.
        从以下版本开始：
        1.6

      • getCurrentComponent

        protected Component getCurrentComponent()
        Gets the table cell renderer component.
        返回：
        the table cell renderer component if one exists; otherwise, returns null.
        从以下版本开始：
        1.6

      • getAccessibleName

        public String getAccessibleName()
        Gets the accessible name of this object.
        重载：
        getAccessibleName in class AccessibleContext
        返回：
        the localized name of the object; null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • setAccessibleName

        public void setAccessibleName(String s)
        Sets the localized accessible name of this object.
        重载：
        setAccessibleName in class AccessibleContext
        参数：
        s - the new localized name of the object
        另请参见：
        AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Gets the accessible description of this object.
        重载：
        getAccessibleDescription in class AccessibleContext
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        public void setAccessibleDescription(String s)
        Sets the accessible description of this object.
        重载：
        setAccessibleDescription in class AccessibleContext
        参数：
        s - the new localized description of the object
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleParent

        public Accessible getAccessibleParent()
        Gets the Accessible parent of this object.
        重载：
        getAccessibleParent in class AccessibleContext
        返回：
        the Accessible parent of this object; null if this object does not have an Accessible parent

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Gets the index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the index of this object in its parent; -1 if this object does not have an accessible parent
        另请参见：
        getAccessibleParent()

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children in the object

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the specified Accessible child of the object.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
        Gets the locale of the component. If the component does not have a locale, then the locale of its parent is returned.
        指定者：
        getLocale in class AccessibleContext
        返回：
        this component's locale; if this component does not have a locale, the locale of its parent is returned
        抛出：
        IllegalComponentStateException - if the Component does not have its own locale and has not yet been added to a containment hierarchy such that the locale can be determined from the containing parent
        另请参见：
        Component.setLocale(java.util.Locale)

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener l)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.
        重载：
        addPropertyChangeListener in class AccessibleContext
        参数：
        l - the PropertyChangeListener to be added
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener l)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        重载：
        removePropertyChangeListener in class AccessibleContext
        参数：
        l - the PropertyChangeListener to be removed

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Gets the AccessibleAction associated with this object if one exists. Otherwise returns null.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        the AccessibleAction, or null
        另请参见：
        AccessibleAction

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent()
        Gets the AccessibleComponent associated with this object if one exists. Otherwise returns null.
        重载：
        getAccessibleComponent in class AccessibleContext
        返回：
        the AccessibleComponent, or null
        另请参见：
        AccessibleComponent

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Gets the AccessibleSelection associated with this object if one exists. Otherwise returns null.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        the AccessibleSelection, or null
        另请参见：
        AccessibleSelection

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Gets the AccessibleText associated with this object if one exists. Otherwise returns null.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        the AccessibleText, or null
        另请参见：
        AccessibleText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object if one exists. Otherwise returns null.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        the AccessibleValue, or null
        另请参见：
        AccessibleValue

      • getBackground

        public Color getBackground()
        Gets the background color of this object.
        指定者：
        getBackground in interface AccessibleComponent
        返回：
        the background color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground(Color c)
        Sets the background color of this object.
        指定者：
        setBackground in interface AccessibleComponent
        参数：
        c - the new Color for the background
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • getForeground

        public Color getForeground()
        Gets the foreground color of this object.
        指定者：
        getForeground in interface AccessibleComponent
        返回：
        the foreground color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground(Color c)
        Sets the foreground color of this object.
        指定者：
        setForeground in interface AccessibleComponent
        参数：
        c - the new Color for the foreground
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor()
        Gets the Cursor of this object.
        指定者：
        getCursor in interface AccessibleComponent
        返回：
        the Cursor, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor(Cursor c)
        Sets the Cursor of this object.
        指定者：
        setCursor in interface AccessibleComponent
        参数：
        c - the new Cursor for the object
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont()
        Gets the Font of this object.
        指定者：
        getFont in interface AccessibleComponent
        返回：
        the Font,if supported, for the object; otherwise, null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont(Font f)
        Sets the Font of this object.
        指定者：
        setFont in interface AccessibleComponent
        参数：
        f - the new Font for the object
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        Gets the FontMetrics of this object.
        指定者：
        getFontMetrics in interface AccessibleComponent
        参数：
        f - the Font
        返回：
        the FontMetrics object, if supported; otherwise null
        另请参见：
        getFont()

      • isEnabled

        public boolean isEnabled()
        Determines if the object is enabled.
        指定者：
        isEnabled in interface AccessibleComponent
        返回：
        true if object is enabled; otherwise, false
        另请参见：
        AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

      • setEnabled

        public void setEnabled(boolean b)
        Sets the enabled state of the object.
        指定者：
        setEnabled in interface AccessibleComponent
        参数：
        b - if true, enables this object; otherwise, disables it
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible()
        Determines if this object is visible. Note: this means that the object intends to be visible; however, it may not in fact be showing on the screen because one of the objects that this object is contained by is not visible. To determine if an object is showing on the screen, use isShowing.
        指定者：
        isVisible in interface AccessibleComponent
        返回：
        true if object is visible; otherwise, false
        另请参见：
        AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

      • setVisible

        public void setVisible(boolean b)
        Sets the visible state of the object.
        指定者：
        setVisible in interface AccessibleComponent
        参数：
        b - if true, shows this object; otherwise, hides it
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing()
        Determines if the object is showing. This is determined by checking the visibility of the object and ancestors of the object. Note: this will return true even if the object is obscured by another (for example, it happens to be underneath a menu that was pulled down).
        指定者：
        isShowing in interface AccessibleComponent
        返回：
        true if the object is showing; otherwise, false

      • contains

        public boolean contains(Point p)
        Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
        指定者：
        contains in interface AccessibleComponent
        参数：
        p - the Point relative to the coordinate system of the object
        返回：
        true if object contains Point; otherwise false
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen()
        Returns the location of the object on the screen.
        指定者：
        getLocationOnScreen in interface AccessibleComponent
        返回：
        location of object on screen -- can be null if this object is not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation()
        Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
        指定者：
        getLocation in interface AccessibleComponent
        返回：
        an instance of Point representing the top-left corner of the object's bounds in the coordinate space of the screen; null if this object or its parent are not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation(Point p)
        Sets the location of the object relative to the parent.
        指定者：
        setLocation in interface AccessibleComponent
        参数：
        p - the new position for the top-left corner
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds()
        从接口复制的描述： AccessibleComponent
        Gets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        getBounds in interface AccessibleComponent
        返回：
        A rectangle indicating this component's bounds; null if this object is not on the screen.
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds(Rectangle r)
        从接口复制的描述： AccessibleComponent
        Sets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        setBounds in interface AccessibleComponent
        参数：
        r - rectangle indicating this component's bounds
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize()
        从接口复制的描述： AccessibleComponent
        Returns the size of this object in the form of a Dimension object. The height field of the Dimension object contains this object's height, and the width field of the Dimension object contains this object's width.
        指定者：
        getSize in interface AccessibleComponent
        返回：
        A Dimension object that indicates the size of this component; null if this object is not on the screen
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize(Dimension d)
        从接口复制的描述： AccessibleComponent
        Resizes this object so that it has width and height.
        指定者：
        setSize in interface AccessibleComponent
        参数：
        d - The dimension specifying the new size of the object.
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        从接口复制的描述： AccessibleComponent
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        参数：
        p - The point relative to the coordinate system of this object.
        返回：
        the Accessible, if it exists, at the specified location; otherwise null

      • isFocusTraversable

        public boolean isFocusTraversable()
        从接口复制的描述： AccessibleComponent
        Returns whether this object can accept focus or not. Objects that can accept focus will also have the AccessibleState.FOCUSABLE state set in their AccessibleStateSets.
        指定者：
        isFocusTraversable in interface AccessibleComponent
        返回：
        true if object can accept focus; otherwise false
        另请参见：
        AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

      • requestFocus

        public void requestFocus()
        从接口复制的描述： AccessibleComponent
        Requests focus for this object. If this object cannot accept focus, nothing will happen. Otherwise, the object will attempt to take focus.
        指定者：
        requestFocus in interface AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Adds the specified focus listener to receive focus events from this component.
        指定者：
        addFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Removes the specified focus listener so it no longer receives focus events from this component.
        指定者：
        removeFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bua.


JTable.AccessibleJTable.AccessibleJTableModelChange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTable.AccessibleJTable.AccessibleJTableModelChange

  • java.lang.Object
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
  • 所有已实现的接口：
    AccessibleTableModelChange
    封闭类：
    JTable.AccessibleJTable

    protected class JTable.AccessibleJTable.AccessibleJTableModelChange
extends Object
implements AccessibleTableModelChange

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | firstColumn
      protected int | firstRow
      protected int | lastColumn
      protected int | lastRow
      protected int | type

      • 字段 - 继承于接口 javax.accessibility.AccessibleTableModelChange

        DELETE, INSERT, UPDATE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTable.AccessibleJTable.AccessibleJTableModelChange(int type, int firstRow, int lastRow, int firstColumn, int lastColumn)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getFirstColumn()
      Returns the first column that changed.
      int getFirstRow()
      Returns the first row that changed.
      int getLastColumn()
      Returns the last column that changed.
      int getLastRow()
      Returns the last row that changed.
      int getType()
      Returns the type of event

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • type

        protected int type

      • firstRow

        protected int firstRow

      • lastRow

        protected int lastRow

      • firstColumn

        protected int firstColumn

      • lastColumn

        protected int lastColumn

    • 构造方法详细信息

      • JTable.AccessibleJTable.AccessibleJTableModelChange

        protected JTable.AccessibleJTable.AccessibleJTableModelChange(int type,
                                                   int firstRow,
                                                   int lastRow,
                                                   int firstColumn,
                                                   int lastColumn)

    • 方法详细信息

      • getType

        public int getType()
        从接口复制的描述： AccessibleTableModelChange
        Returns the type of event
        指定者：
        getType in interface AccessibleTableModelChange
        另请参见：
        AccessibleTableModelChange.INSERT, AccessibleTableModelChange.UPDATE, AccessibleTableModelChange.DELETE

      • getFirstRow

        public int getFirstRow()
        从接口复制的描述： AccessibleTableModelChange
        Returns the first row that changed.
        指定者：
        getFirstRow in interface AccessibleTableModelChange

      • getLastRow

        public int getLastRow()
        从接口复制的描述： AccessibleTableModelChange
        Returns the last row that changed.
        指定者：
        getLastRow in interface AccessibleTableModelChange

      • getFirstColumn

        public int getFirstColumn()
        从接口复制的描述： AccessibleTableModelChange
        Returns the first column that changed.
        指定者：
        getFirstColumn in interface AccessibleTableModelChange

      • getLastColumn

        public int getLastColumn()
        从接口复制的描述： AccessibleTableModelChange
        Returns the last column that changed.
        指定者：
        getLastColumn in interface AccessibleTableModelChange
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ee>r"C.>C.aaa.aan"hhacr"<""o=los>>


JTable.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 JTable.DropLocation

  • java.lang.Object
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JTable.DropLocation
  • 封闭类：
    JTable

    public static final class JTable.DropLocation
extends TransferHandler.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
    从以下版本开始：
    1.6
    另请参见：
    JTable.getDropLocation()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumn()
      Returns the column index where a dropped item should be placed in the table.
      int getRow()
      Returns the row index where a dropped item should be placed in the table.
      boolean isInsertColumn()
      Returns whether or not this location represents an insert of a column.
      boolean isInsertRow()
      Returns whether or not this location represents an insert of a row.
      String toString()
      Returns a string representation of this drop location.

      • 方法 - 继承于类 javax.swing.TransferHandler.DropLocation

        getDropPoint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getRow

        public int getRow()
        Returns the row index where a dropped item should be placed in the table. Interpretation of the value depends on the return of isInsertRow(). If that method returns true this value indicates the index where a new row should be inserted. Otherwise, it represents the value of an existing row on which the data was dropped. This index is in terms of the view.

        -1 indicates that the drop occurred over empty space, and no row could be calculated.

        返回：
        the drop row

      • getColumn

        public int getColumn()
        Returns the column index where a dropped item should be placed in the table. Interpretation of the value depends on the return of isInsertColumn(). If that method returns true this value indicates the index where a new column should be inserted. Otherwise, it represents the value of an existing column on which the data was dropped. This index is in terms of the view.

        -1 indicates that the drop occurred over empty space, and no column could be calculated.

        返回：
        the drop row

      • isInsertRow

        public boolean isInsertRow()
        Returns whether or not this location represents an insert of a row.
        返回：
        whether or not this is an insert row

      • isInsertColumn

        public boolean isInsertColumn()
        Returns whether or not this location represents an insert of a column.
        返回：
        whether or not this is an insert column

      • toString

        public String toString()
        Returns a string representation of this drop location. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class TransferHandler.DropLocation
        返回：
        a string representation of this drop location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sl_a"


JTable.PrintMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum JTable.PrintMode

  • java.lang.Object
    • java.lang.Enum<JTable.PrintMode>
      • javax.swing.JTable.PrintMode
  • 所有已实现的接口：
    Serializable, Comparable<JTable.PrintMode>
    封闭类：
    JTable

    public static enum JTable.PrintMode
extends Enum<JTable.PrintMode>
    Printing modes, used in printing JTables.
    从以下版本开始：
    1.5
    另请参见：
    JTable.print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean), JTable.getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FIT_WIDTH
      Printing mode that scales the output smaller, if necessary, to fit the table's entire width (and thereby all columns) on each page; Rows are spread across multiple pages as necessary.
      NORMAL
      Printing mode that prints the table at its current size, spreading both columns and rows across multiple pages if necessary.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static JTable.PrintMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JTable.PrintMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NORMAL

        public static final JTable.PrintMode NORMAL
        Printing mode that prints the table at its current size, spreading both columns and rows across multiple pages if necessary.

      • FIT_WIDTH

        public static final JTable.PrintMode FIT_WIDTH
        Printing mode that scales the output smaller, if necessary, to fit the table's entire width (and thereby all columns) on each page; Rows are spread across multiple pages as necessary.

    • 方法详细信息

      • values

        public static JTable.PrintMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JTable.PrintMode c : JTable.PrintMode.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JTable.PrintMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nserts tst stteottmaos hs>/ooe JJdes


JTextArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTextArea

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextArea
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable

    public class JTextArea
extends JTextComponent
    A JTextArea is a multi-line area that displays plain text. It is intended to be a lightweight component that provides source compatibility with the java.awt.TextArea class where it can reasonably do so. You can find information and examples of using all the text components in Using Text Components, a section in The Java Tutorial.

    This component has capabilities not found in the java.awt.TextArea class. The superclass should be consulted for additional capabilities. Alternative multi-line text classes with more capabilities are JTextPane and JEditorPane.

    The java.awt.TextArea internally handles scrolling. JTextArea is different in that it doesn't manage scrolling, but implements the swing Scrollable interface. This allows it to be placed inside a JScrollPane if scrolling behavior is desired, and used directly if scrolling is not desired.

    The java.awt.TextArea has the ability to do line wrapping. This was controlled by the horizontal scrolling policy. Since scrolling is not done by JTextArea directly, backward compatibility must be provided another way. JTextArea has a bound property for line wrapping that controls whether or not it will wrap lines. By default, the line wrapping property is set to false (not wrapped).

    java.awt.TextArea has two properties rows and columns that are used to determine the preferred size. JTextArea uses these properties to indicate the preferred size of the viewport when placed inside a JScrollPane to match the functionality provided by java.awt.TextArea. JTextArea has a preferred size of what is needed to display all of the text, so that it functions properly inside of a JScrollPane. If the value for rows or columns is equal to zero, the preferred size along that axis is used for the viewport preferred size along the same axis.

    The java.awt.TextArea could be monitored for changes by adding a TextListener for TextEvents. In the JTextComponent based components, changes are broadcasted from the model via a DocumentEvent to DocumentListeners. The DocumentEvent gives the location of the change and the kind of change if desired. The code fragment might look something like:

        DocumentListener myListener = ??;
    JTextArea myArea = ??;
    myArea.getDocument().addDocumentListener(myListener);

    Newlines
    For a discussion on how newlines are handled, see DefaultEditorKit.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTextPane, JEditorPane

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTextArea.AccessibleJTextArea
      This class implements accessibility support for the JTextArea class.

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextArea()
      Constructs a new TextArea.
      JTextArea(Document doc)
      Constructs a new JTextArea with the given document model, and defaults for all of the other arguments (null, 0, 0).
      JTextArea(Document doc, String text, int rows, int columns)
      Constructs a new JTextArea with the specified number of rows and columns, and the given model.
      JTextArea(int rows, int columns)
      Constructs a new empty TextArea with the specified number of rows and columns.
      JTextArea(String text)
      Constructs a new TextArea with the specified text displayed.
      JTextArea(String text, int rows, int columns)
      Constructs a new TextArea with the specified text and number of rows and columns.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void append(String str)
      Appends the given text to the end of the document.
      protected Document createDefaultModel()
      Creates the default implementation of the model to be used at construction if one isn't explicitly given.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTextArea.
      int getColumns()
      Returns the number of columns in the TextArea.
      protected int getColumnWidth()
      Gets column width.
      int getLineCount()
      Determines the number of lines contained in the area.
      int getLineEndOffset(int line)
      Determines the offset of the end of the given line.
      int getLineOfOffset(int offset)
      Translates an offset into the components text to a line number.
      int getLineStartOffset(int line)
      Determines the offset of the start of the given line.
      boolean getLineWrap()
      Gets the line-wrapping policy of the text area.
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred size of the viewport if this component is embedded in a JScrollPane.
      Dimension getPreferredSize()
      Returns the preferred size of the TextArea.
      protected int getRowHeight()
      Defines the meaning of the height of a row.
      int getRows()
      Returns the number of rows in the TextArea.
      boolean getScrollableTracksViewportWidth()
      Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.
      int getTabSize()
      Gets the number of characters used to expand tabs.
      String getUIClassID()
      Returns the class ID for the UI.
      boolean getWrapStyleWord()
      Gets the style of wrapping used if the text area is wrapping lines.
      void insert(String str, int pos)
      Inserts the specified text at the specified position.
      protected String paramString()
      Returns a string representation of this JTextArea.
      void replaceRange(String str, int start, int end)
      Replaces text from the indicated start to end position with the new text specified.
      void setColumns(int columns)
      Sets the number of columns for this TextArea.
      void setFont(Font f)
      Sets the current font.
      void setLineWrap(boolean wrap)
      Sets the line-wrapping policy of the text area.
      void setRows(int rows)
      Sets the number of rows for this TextArea.
      void setTabSize(int size)
      Sets the number of characters to expand tabs to.
      void setWrapStyleWord(boolean word)
      Sets the style of wrapping used if the text area is wrapping lines.

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDocument, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JTextArea

        public JTextArea()
        Constructs a new TextArea. A default model is set, the initial string is null, and rows/columns are set to 0.

      • JTextArea

        public JTextArea(String text)
        Constructs a new TextArea with the specified text displayed. A default model is created and rows/columns are set to 0.
        参数：
        text - the text to be displayed, or null

      • JTextArea

        public JTextArea(int rows,
         int columns)
        Constructs a new empty TextArea with the specified number of rows and columns. A default model is created, and the initial string is null.
        参数：
        rows - the number of rows >= 0
        columns - the number of columns >= 0
        抛出：
        IllegalArgumentException - if the rows or columns arguments are negative.

      • JTextArea

        public JTextArea(String text,
         int rows,
         int columns)
        Constructs a new TextArea with the specified text and number of rows and columns. A default model is created.
        参数：
        text - the text to be displayed, or null
        rows - the number of rows >= 0
        columns - the number of columns >= 0
        抛出：
        IllegalArgumentException - if the rows or columns arguments are negative.

      • JTextArea

        public JTextArea(Document doc)
        Constructs a new JTextArea with the given document model, and defaults for all of the other arguments (null, 0, 0).
        参数：
        doc - the model to use

      • JTextArea

        public JTextArea(Document doc,
         String text,
         int rows,
         int columns)
        Constructs a new JTextArea with the specified number of rows and columns, and the given model. All of the constructors feed through this constructor.
        参数：
        doc - the model to use, or create a default one if null
        text - the text to be displayed, null if none
        rows - the number of rows >= 0
        columns - the number of columns >= 0
        抛出：
        IllegalArgumentException - if the rows or columns arguments are negative.

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the class ID for the UI.
        重载：
        getUIClassID in class JComponent
        返回：
        the ID ("TextAreaUI")
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • createDefaultModel

        protected Document createDefaultModel()
        Creates the default implementation of the model to be used at construction if one isn't explicitly given. A new instance of PlainDocument is returned.
        返回：
        the default document model

      • setTabSize

        public void setTabSize(int size)
        Sets the number of characters to expand tabs to. This will be multiplied by the maximum advance for variable width fonts. A PropertyChange event ("tabSize") is fired when the tab size changes.
        参数：
        size - number of characters to expand to
        另请参见：
        getTabSize()

      • getTabSize

        public int getTabSize()
        Gets the number of characters used to expand tabs. If the document is null or doesn't have a tab setting, return a default of 8.
        返回：
        the number of characters

      • setLineWrap

        public void setLineWrap(boolean wrap)
        Sets the line-wrapping policy of the text area. If set to true the lines will be wrapped if they are too long to fit within the allocated width. If set to false, the lines will always be unwrapped. A PropertyChange event ("lineWrap") is fired when the policy is changed. By default this property is false.
        参数：
        wrap - indicates if lines should be wrapped
        另请参见：
        getLineWrap()

      • getLineWrap

        public boolean getLineWrap()
        Gets the line-wrapping policy of the text area. If set to true the lines will be wrapped if they are too long to fit within the allocated width. If set to false, the lines will always be unwrapped.
        返回：
        if lines will be wrapped

      • setWrapStyleWord

        public void setWrapStyleWord(boolean word)
        Sets the style of wrapping used if the text area is wrapping lines. If set to true the lines will be wrapped at word boundaries (whitespace) if they are too long to fit within the allocated width. If set to false, the lines will be wrapped at character boundaries. By default this property is false.
        参数：
        word - indicates if word boundaries should be used for line wrapping
        另请参见：
        getWrapStyleWord()

      • getWrapStyleWord

        public boolean getWrapStyleWord()
        Gets the style of wrapping used if the text area is wrapping lines. If set to true the lines will be wrapped at word boundaries (ie whitespace) if they are too long to fit within the allocated width. If set to false, the lines will be wrapped at character boundaries.
        返回：
        if the wrap style should be word boundaries instead of character boundaries
        另请参见：
        setWrapStyleWord(boolean)

      • getLineOfOffset

        public int getLineOfOffset(int offset)
                    throws BadLocationException
        Translates an offset into the components text to a line number.
        参数：
        offset - the offset >= 0
        返回：
        the line number >= 0
        抛出：
        BadLocationException - thrown if the offset is less than zero or greater than the document length.

      • getLineCount

        public int getLineCount()
        Determines the number of lines contained in the area.
        返回：
        the number of lines > 0

      • getLineStartOffset

        public int getLineStartOffset(int line)
                       throws BadLocationException
        Determines the offset of the start of the given line.
        参数：
        line - the line number to translate >= 0
        返回：
        the offset >= 0
        抛出：
        BadLocationException - thrown if the line is less than zero or greater or equal to the number of lines contained in the document (as reported by getLineCount).

      • getLineEndOffset

        public int getLineEndOffset(int line)
                     throws BadLocationException
        Determines the offset of the end of the given line.
        参数：
        line - the line >= 0
        返回：
        the offset >= 0
        抛出：
        BadLocationException - Thrown if the line is less than zero or greater or equal to the number of lines contained in the document (as reported by getLineCount).

      • insert

        public void insert(String str,
          int pos)
        Inserts the specified text at the specified position. Does nothing if the model is null or if the text is null or empty.
        参数：
        str - the text to insert
        pos - the position at which to insert >= 0
        抛出：
        IllegalArgumentException - if pos is an invalid position in the model
        另请参见：
        TextComponent.setText(java.lang.String), replaceRange(java.lang.String, int, int)

      • append

        public void append(String str)
        Appends the given text to the end of the document. Does nothing if the model is null or the string is null or empty.
        参数：
        str - the text to insert
        另请参见：
        insert(java.lang.String, int)

      • replaceRange

        public void replaceRange(String str,
                int start,
                int end)
        Replaces text from the indicated start to end position with the new text specified. Does nothing if the model is null. Simply does a delete if the new string is null or empty.
        参数：
        str - the text to use as the replacement
        start - the start position >= 0
        end - the end position >= start
        抛出：
        IllegalArgumentException - if part of the range is an invalid position in the model
        另请参见：
        insert(java.lang.String, int), replaceRange(java.lang.String, int, int)

      • getRows

        public int getRows()
        Returns the number of rows in the TextArea.
        返回：
        the number of rows >= 0

      • setRows

        public void setRows(int rows)
        Sets the number of rows for this TextArea. Calls invalidate() after setting the new value.
        参数：
        rows - the number of rows >= 0
        抛出：
        IllegalArgumentException - if rows is less than 0
        另请参见：
        getRows()

      • getRowHeight

        protected int getRowHeight()
        Defines the meaning of the height of a row. This defaults to the height of the font.
        返回：
        the height >= 1

      • getColumns

        public int getColumns()
        Returns the number of columns in the TextArea.
        返回：
        number of columns >= 0

      • setColumns

        public void setColumns(int columns)
        Sets the number of columns for this TextArea. Does an invalidate() after setting the new value.
        参数：
        columns - the number of columns >= 0
        抛出：
        IllegalArgumentException - if columns is less than 0
        另请参见：
        getColumns()

      • getColumnWidth

        protected int getColumnWidth()
        Gets column width. The meaning of what a column is can be considered a fairly weak notion for some fonts. This method is used to define the width of a column. By default this is defined to be the width of the character m for the font used. This method can be redefined to be some alternative amount.
        返回：
        the column width >= 1

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size of the TextArea. This is the maximum of the size needed to display the text and the size requested for the viewport.
        重载：
        getPreferredSize in class JComponent
        返回：
        the size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • setFont

        public void setFont(Font f)
        Sets the current font. This removes cached row height and column width so the new font will be reflected, and calls revalidate().
        重载：
        setFont in class JComponent
        参数：
        f - the font to use as the current font
        另请参见：
        Component.getFont()

      • paramString

        protected String paramString()
        Returns a string representation of this JTextArea. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JTextComponent
        返回：
        a string representation of this JTextArea.

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport. This is implemented to return true if the line wrapping policy is true, and false if lines are not being wrapped.
        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        重载：
        getScrollableTracksViewportWidth in class JTextComponent
        返回：
        true if a viewport should force the Scrollables width to match its own.

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Returns the preferred size of the viewport if this component is embedded in a JScrollPane. This uses the desired column and row settings if they have been set, otherwise the superclass behavior is used.
        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        重载：
        getPreferredScrollableViewportSize in class JTextComponent
        返回：
        The preferredSize of a JViewport whose view is this Scrollable.
        另请参见：
        JComponent.getPreferredSize()

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation. This is implemented to use the values returned by the getRowHeight and getColumnWidth methods.

        Scrolling containers, like JScrollPane, will use this method each time the user requests a unit scroll.

        指定者：
        getScrollableUnitIncrement in interface Scrollable
        重载：
        getScrollableUnitIncrement in class JTextComponent
        参数：
        visibleRect - the view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        The "unit" increment for scrolling in the specified direction
        抛出：
        IllegalArgumentException - for an invalid orientation
        另请参见：
        JScrollBar.setUnitIncrement(int),
getRowHeight(),
getColumnWidth()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTextArea. For JTextAreas, the AccessibleContext takes the form of an AccessibleJTextArea. A new AccessibleJTextArea instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JTextComponent
        返回：
        an AccessibleJTextArea that serves as the AccessibleContext of this JTextArea
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


JTextArea.AccessibleJTextArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTextArea.AccessibleJTextArea

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JTextArea.AccessibleJTextArea
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    封闭类：
    JTextArea

    protected class JTextArea.AccessibleJTextArea
extends JTextComponent.AccessibleJTextComponent
    This class implements accessibility support for the JTextArea class. It provides an implementation of the Java Accessibility API appropriate to text area user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTextArea.AccessibleJTextArea()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTextArea.AccessibleJTextArea

        protected JTextArea.AccessibleJTextArea()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        重载：
        getAccessibleStateSet in class JTextComponent.AccessibleJTextComponent
        返回：
        an instance of AccessibleStateSet describing the states of the object
        另请参见：
        AccessibleStateSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


JTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTextField

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextField
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
    直接已知子类：
    DefaultTreeCellEditor.DefaultTextField, JFormattedTextField, JPasswordField

    public class JTextField
extends JTextComponent
implements SwingConstants
    JTextField is a lightweight component that allows the editing of a single line of text. For information on and examples of using text fields, see How to Use Text Fields in The Java Tutorial.

    JTextField is intended to be source-compatible with java.awt.TextField where it is reasonable to do so. This component has capabilities not found in the java.awt.TextField class. The superclass should be consulted for additional capabilities.

    JTextField has a method to establish the string used as the command string for the action event that gets fired. The java.awt.TextField used the text of the field as the command string for the ActionEvent. JTextField will use the command string set with the setActionCommand method if not null, otherwise it will use the text of the field as a compatibility with java.awt.TextField.

    The method setEchoChar and getEchoChar are not provided directly to avoid a new implementation of a pluggable look-and-feel inadvertently exposing password characters. To provide password-like services a separate class JPasswordField extends JTextField to provide this service with an independently pluggable look-and-feel.

    The java.awt.TextField could be monitored for changes by adding a TextListener for TextEvent's. In the JTextComponent based components, changes are broadcasted from the model via a DocumentEvent to DocumentListeners. The DocumentEvent gives the location of the change and the kind of change if desired. The code fragment might look something like:

     DocumentListener myListener = ??;
     JTextField myArea = ??;
     myArea.getDocument().addDocumentListener(myListener);

    The horizontal alignment of JTextField can be set to be left justified, leading justified, centered, right justified or trailing justified. Right/trailing justification is useful if the required size of the field text is smaller than the size allocated to it. This is determined by the setHorizontalAlignment and getHorizontalAlignment methods. The default is to be leading justified.

    How the text field consumes VK_ENTER events depends on whether the text field has any action listeners. If so, then VK_ENTER results in the listeners getting an ActionEvent, and the VK_ENTER event is consumed. This is compatible with how AWT text fields handle VK_ENTER events. If the text field has no action listeners, then as of v 1.3 the VK_ENTER event is not consumed. Instead, the bindings of ancestor components are processed, which enables the default button feature of JFC/Swing to work.

    Customized fields can easily be created by extending the model and changing the default model provided. For example, the following piece of code will create a field that holds only upper case characters. It will work even if text is pasted into from the clipboard or it is altered via programmatic changes.

 public class UpperCaseField extends JTextField {

     public UpperCaseField(int cols) {
         super(cols);
     }

     protected Document createDefaultModel() {
         return new UpperCaseDocument();
     }

     static class UpperCaseDocument extends PlainDocument {

         public void insertString(int offs, String str, AttributeSet a)
             throws BadLocationException {

             if (str == null) {
                 return;
             }
             char[] upper = str.toCharArray();
             for (int i = 0; i < upper.length; i++) {
                 upper[i] = Character.toUpperCase(upper[i]);
             }
             super.insertString(offs, new String(upper), a);
         }
     }
 }

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    setActionCommand(java.lang.String), JPasswordField, addActionListener(java.awt.event.ActionListener)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTextField.AccessibleJTextField
      This class implements accessibility support for the JTextField class.

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String notifyAction
      Name of the action to send notification that the contents of the field have been accepted.

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextField()
      Constructs a new TextField.
      JTextField(Document doc, String text, int columns)
      Constructs a new JTextField that uses the given text storage model and the given number of columns.
      JTextField(int columns)
      Constructs a new empty TextField with the specified number of columns.
      JTextField(String text)
      Constructs a new TextField initialized with the specified text.
      JTextField(String text, int columns)
      Constructs a new TextField initialized with the specified text and columns.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void actionPropertyChanged(Action action, String propertyName)
      Updates the textfield's state in response to property changes in associated action.
      void addActionListener(ActionListener l)
      Adds the specified action listener to receive action events from this textfield.
      protected void configurePropertiesFromAction(Action a)
      Sets the properties on this textfield to match those in the specified Action.
      protected PropertyChangeListener createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      protected Document createDefaultModel()
      Creates the default implementation of the model to be used at construction if one isn't explicitly given.
      protected void fireActionPerformed()
      Notifies all listeners that have registered interest for notification on this event type.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTextField.
      Action getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      ActionListener[] getActionListeners()
      Returns an array of all the ActionListeners added to this JTextField with addActionListener().
      Action[] getActions()
      Fetches the command list for the editor.
      int getColumns()
      Returns the number of columns in this TextField.
      protected int getColumnWidth()
      Returns the column width.
      int getHorizontalAlignment()
      Returns the horizontal alignment of the text.
      BoundedRangeModel getHorizontalVisibility()
      Gets the visibility of the text field.
      Dimension getPreferredSize()
      Returns the preferred size Dimensions needed for this TextField.
      int getScrollOffset()
      Gets the scroll offset, in pixels.
      String getUIClassID()
      Gets the class ID for a UI.
      boolean isValidateRoot()
      Calls to revalidate that come from within the textfield itself will be handled by validating the textfield, unless the textfield is contained within a JViewport, in which case this returns false.
      protected String paramString()
      Returns a string representation of this JTextField.
      void postActionEvent()
      Processes action events occurring on this textfield by dispatching them to any registered ActionListener objects.
      void removeActionListener(ActionListener l)
      Removes the specified action listener so that it no longer receives action events from this textfield.
      void scrollRectToVisible(Rectangle r)
      Scrolls the field left or right.
      void setAction(Action a)
      Sets the Action for the ActionEvent source.
      void setActionCommand(String command)
      Sets the command string used for action events.
      void setColumns(int columns)
      Sets the number of columns in this TextField, and then invalidate the layout.
      void setDocument(Document doc)
      Associates the editor with a text document.
      void setFont(Font f)
      Sets the current font.
      void setHorizontalAlignment(int alignment)
      Sets the horizontal alignment of the text.
      void setScrollOffset(int scrollOffset)
      Sets the scroll offset, in pixels.

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • notifyAction

        public static final String notifyAction
        Name of the action to send notification that the contents of the field have been accepted. Typically this is bound to a carriage-return.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JTextField

        public JTextField()
        Constructs a new TextField. A default model is created, the initial string is null, and the number of columns is set to 0.

      • JTextField

        public JTextField(String text)
        Constructs a new TextField initialized with the specified text. A default model is created and the number of columns is 0.
        参数：
        text - the text to be displayed, or null

      • JTextField

        public JTextField(int columns)
        Constructs a new empty TextField with the specified number of columns. A default model is created and the initial string is set to null.
        参数：
        columns - the number of columns to use to calculate the preferred width; if columns is set to zero, the preferred width will be whatever naturally results from the component implementation

      • JTextField

        public JTextField(String text,
          int columns)
        Constructs a new TextField initialized with the specified text and columns. A default model is created.
        参数：
        text - the text to be displayed, or null
        columns - the number of columns to use to calculate the preferred width; if columns is set to zero, the preferred width will be whatever naturally results from the component implementation

      • JTextField

        public JTextField(Document doc,
          String text,
          int columns)
        Constructs a new JTextField that uses the given text storage model and the given number of columns. This is the constructor through which the other constructors feed. If the document is null, a default model is created.
        参数：
        doc - the text storage to use; if this is null, a default will be provided by calling the createDefaultModel method
        text - the initial string to display, or null
        columns - the number of columns to use to calculate the preferred width >= 0; if columns is set to zero, the preferred width will be whatever naturally results from the component implementation
        抛出：
        IllegalArgumentException - if columns < 0

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Gets the class ID for a UI.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "TextFieldUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setDocument

        public void setDocument(Document doc)
        Associates the editor with a text document. The currently registered factory is used to build a view for the document, which gets displayed by the editor after revalidation. A PropertyChange event ("document") is propagated to each listener.
        重载：
        setDocument in class JTextComponent
        参数：
        doc - the document to display/edit
        另请参见：
        JTextComponent.getDocument()

      • isValidateRoot

        public boolean isValidateRoot()
        Calls to revalidate that come from within the textfield itself will be handled by validating the textfield, unless the textfield is contained within a JViewport, in which case this returns false.
        重载：
        isValidateRoot in class JComponent
        返回：
        if the parent of this textfield is a JViewPort return false, otherwise return true
        另请参见：
        JComponent.revalidate(),
JComponent.isValidateRoot(),
Container.isValidateRoot()

      • getHorizontalAlignment

        public int getHorizontalAlignment()
        Returns the horizontal alignment of the text. Valid keys are:
        • JTextField.LEFT
        • JTextField.CENTER
        • JTextField.RIGHT
        • JTextField.LEADING
        • JTextField.TRAILING
        返回：
        the horizontal alignment

      • setHorizontalAlignment

        public void setHorizontalAlignment(int alignment)
        Sets the horizontal alignment of the text. Valid keys are:
        • JTextField.LEFT
        • JTextField.CENTER
        • JTextField.RIGHT
        • JTextField.LEADING
        • JTextField.TRAILING
        invalidate and repaint are called when the alignment is set, and a PropertyChange event ("horizontalAlignment") is fired.
        参数：
        alignment - the alignment
        抛出：
        IllegalArgumentException - if alignment is not a valid key

      • createDefaultModel

        protected Document createDefaultModel()
        Creates the default implementation of the model to be used at construction if one isn't explicitly given. An instance of PlainDocument is returned.
        返回：
        the default model implementation

      • getColumns

        public int getColumns()
        Returns the number of columns in this TextField.
        返回：
        the number of columns >= 0

      • setColumns

        public void setColumns(int columns)
        Sets the number of columns in this TextField, and then invalidate the layout.
        参数：
        columns - the number of columns >= 0
        抛出：
        IllegalArgumentException - if columns is less than 0

      • getColumnWidth

        protected int getColumnWidth()
        Returns the column width. The meaning of what a column is can be considered a fairly weak notion for some fonts. This method is used to define the width of a column. By default this is defined to be the width of the character m for the font used. This method can be redefined to be some alternative amount
        返回：
        the column width >= 1

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size Dimensions needed for this TextField. If a non-zero number of columns has been set, the width is set to the columns multiplied by the column width.
        重载：
        getPreferredSize in class JComponent
        返回：
        the dimension of this textfield
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • setFont

        public void setFont(Font f)
        Sets the current font. This removes cached row height and column width so the new font will be reflected. revalidate is called after setting the font.
        重载：
        setFont in class JComponent
        参数：
        f - the new font
        另请参见：
        Component.getFont()

      • addActionListener

        public void addActionListener(ActionListener l)
        Adds the specified action listener to receive action events from this textfield.
        参数：
        l - the action listener to be added

      • removeActionListener

        public void removeActionListener(ActionListener l)
        Removes the specified action listener so that it no longer receives action events from this textfield.
        参数：
        l - the action listener to be removed

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the ActionListeners added to this JTextField with addActionListener().
        返回：
        all of the ActionListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireActionPerformed

        protected void fireActionPerformed()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created. The listener list is processed in last to first order.
        另请参见：
        EventListenerList

      • setActionCommand

        public void setActionCommand(String command)
        Sets the command string used for action events.
        参数：
        command - the command string

      • setAction

        public void setAction(Action a)
        Sets the Action for the ActionEvent source. The new Action replaces any previously set Action but does not affect ActionListeners independently added with addActionListener. If the Action is already a registered ActionListener for the ActionEvent source, it is not re-registered.

        Setting the Action results in immediately changing all the properties described in Swing Components Supporting Action. Subsequently, the textfield's properties are automatically updated as the Action's properties change.

        This method uses three other methods to set and help track the Action's property values. It uses the configurePropertiesFromAction method to immediately change the textfield's properties. To track changes in the Action's property values, this method registers the PropertyChangeListener returned by createActionPropertyChangeListener. The default PropertyChangeListener invokes the actionPropertyChanged method when a property in the Action changes.

        参数：
        a - the Action for the JTextField, or null
        从以下版本开始：
        1.3
        另请参见：
        Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

      • getAction

        public Action getAction()
        Returns the currently set Action for this ActionEvent source, or null if no Action is set.
        返回：
        the Action for this ActionEvent source, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • configurePropertiesFromAction

        protected void configurePropertiesFromAction(Action a)
        Sets the properties on this textfield to match those in the specified Action. Refer to Swing Components Supporting Action for more details as to which properties this sets.
        参数：
        a - the Action from which to get the properties, or null
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • actionPropertyChanged

        protected void actionPropertyChanged(Action action,
                         String propertyName)
        Updates the textfield's state in response to property changes in associated action. This method is invoked from the PropertyChangeListener returned from createActionPropertyChangeListener. Subclasses do not normally need to invoke this. Subclasses that support additional Action properties should override this and configurePropertiesFromAction.

        Refer to the table at Swing Components Supporting Action for a list of the properties this method sets.

        参数：
        action - the Action associated with this textfield
        propertyName - the name of the property that changed
        从以下版本开始：
        1.6
        另请参见：
        Action, configurePropertiesFromAction(javax.swing.Action)

      • createActionPropertyChangeListener

        protected PropertyChangeListener createActionPropertyChangeListener(Action a)
        Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.

        警告： If you subclass this do not create an anonymous inner class. If you do the lifetime of the textfield will be tied to that of the Action.

        参数：
        a - the textfield's action
        从以下版本开始：
        1.3
        另请参见：
        Action, setAction(javax.swing.Action)

      • getActions

        public Action[] getActions()
        Fetches the command list for the editor. This is the list of commands supported by the plugged-in UI augmented by the collection of commands that the editor itself supports. These are useful for binding to events, such as in a keymap.
        重载：
        getActions in class JTextComponent
        返回：
        the command list

      • postActionEvent

        public void postActionEvent()
        Processes action events occurring on this textfield by dispatching them to any registered ActionListener objects. This is normally called by the controller registered with textfield.

      • getHorizontalVisibility

        public BoundedRangeModel getHorizontalVisibility()
        Gets the visibility of the text field. This can be adjusted to change the location of the visible area if the size of the field is greater than the area that was allocated to the field.

        The fields look-and-feel implementation manages the values of the minimum, maximum, and extent properties on the BoundedRangeModel.

        返回：
        the visibility
        另请参见：
        BoundedRangeModel

      • getScrollOffset

        public int getScrollOffset()
        Gets the scroll offset, in pixels.
        返回：
        the offset >= 0

      • setScrollOffset

        public void setScrollOffset(int scrollOffset)
        Sets the scroll offset, in pixels.
        参数：
        scrollOffset - the offset >= 0

      • scrollRectToVisible

        public void scrollRectToVisible(Rectangle r)
        Scrolls the field left or right.
        重载：
        scrollRectToVisible in class JComponent
        参数：
        r - the region to scroll
        另请参见：
        JViewport

      • paramString

        protected String paramString()
        Returns a string representation of this JTextField. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JTextComponent
        返回：
        a string representation of this JTextField

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTextField. For JTextFields, the AccessibleContext takes the form of an AccessibleJTextField. A new AccessibleJTextField instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JTextComponent
        返回：
        an AccessibleJTextField that serves as the AccessibleContext of this JTextField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTextField.AccessibleJTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTextField.AccessibleJTextField

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
              • javax.swing.JTextField.AccessibleJTextField
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    直接已知子类：
    JPasswordField.AccessibleJPasswordField
    封闭类：
    JTextField

    protected class JTextField.AccessibleJTextField
extends JTextComponent.AccessibleJTextComponent
    This class implements accessibility support for the JTextField class. It provides an implementation of the Java Accessibility API appropriate to text field user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTextField.AccessibleJTextField()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.

      • 方法 - 继承于类 javax.swing.text.JTextComponent.AccessibleJTextComponent

        caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTextField.AccessibleJTextField

        protected JTextField.AccessibleJTextField()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object.
        重载：
        getAccessibleStateSet in class JTextComponent.AccessibleJTextComponent
        返回：
        an instance of AccessibleStateSet describing the states of the object
        另请参见：
        AccessibleState
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ya(ln.pt.pmoopmmgveetsLe(oe(srsLrxeasdtmtthr<>pnCn


JTextPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTextPane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable

    public class JTextPane
extends JEditorPane
    A text component that can be marked up with attributes that are represented graphically. You can find how-to information and examples of using text panes in Using Text Components, a section in The Java Tutorial.

    This component models paragraphs that are composed of runs of character level attributes. Each paragraph may have a logical style attached to it which contains the default attributes to use if not overridden by attributes set on the paragraph or character run. Components and images may be embedded in the flow of text.

    Newlines
    For a discussion on how newlines are handled, see DefaultEditorKit.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    StyledEditorKit

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JEditorPane

        JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JEditorPane

        HONOR_DISPLAY_PROPERTIES, W3C_LENGTH_UNITS

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextPane()
      Creates a new JTextPane.
      JTextPane(StyledDocument doc)
      Creates a new JTextPane, with a specified document model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Style addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      protected EditorKit createDefaultEditorKit()
      Creates the EditorKit to use by default.
      AttributeSet getCharacterAttributes()
      Fetches the character attributes in effect at the current location of the caret, or null.
      MutableAttributeSet getInputAttributes()
      Gets the input attributes for the pane.
      Style getLogicalStyle()
      Fetches the logical style assigned to the paragraph represented by the current position of the caret, or null.
      AttributeSet getParagraphAttributes()
      Fetches the current paragraph attributes in effect at the location of the caret, or null if none.
      Style getStyle(String nm)
      Fetches a named non-null style previously added.
      StyledDocument getStyledDocument()
      Fetches the model associated with the editor.
      protected StyledEditorKit getStyledEditorKit()
      Gets the editor kit.
      String getUIClassID()
      Returns the class ID for the UI.
      void insertComponent(Component c)
      Inserts a component into the document as a replacement for the currently selected content.
      void insertIcon(Icon g)
      Inserts an icon into the document as a replacement for the currently selected content.
      protected String paramString()
      Returns a string representation of this JTextPane.
      void removeStyle(String nm)
      Removes a named non-null style previously added to the document.
      void replaceSelection(String content)
      Replaces the currently selected content with new content represented by the given string.
      void setCharacterAttributes(AttributeSet attr, boolean replace)
      Applies the given attributes to character content.
      void setDocument(Document doc)
      Associates the editor with a text document.
      void setEditorKit(EditorKit kit)
      Sets the currently installed kit for handling content.
      void setLogicalStyle(Style s)
      Sets the logical style to use for the paragraph at the current caret position.
      void setParagraphAttributes(AttributeSet attr, boolean replace)
      Applies the given attributes to paragraphs.
      void setStyledDocument(StyledDocument doc)
      Associates the editor with a text document.

      • 方法 - 继承于类 javax.swing.JEditorPane

        addHyperlinkListener, createEditorKitForContentType, fireHyperlinkUpdate, getAccessibleContext, getContentType, getEditorKit, getEditorKitClassNameForContentType, getEditorKitForContentType, getHyperlinkListeners, getPage, getPreferredSize, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getStream, getText, read, registerEditorKitForContentType, registerEditorKitForContentType, removeHyperlinkListener, scrollToReference, setContentType, setEditorKitForContentType, setPage, setPage, setText

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JTextPane

        public JTextPane()
        Creates a new JTextPane. A new instance of StyledEditorKit is created and set, and the document model set to null.

      • JTextPane

        public JTextPane(StyledDocument doc)
        Creates a new JTextPane, with a specified document model. A new instance of javax.swing.text.StyledEditorKit is created and set.
        参数：
        doc - the document model

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the class ID for the UI.
        重载：
        getUIClassID in class JEditorPane
        返回：
        the string "TextPaneUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setDocument

        public void setDocument(Document doc)
        Associates the editor with a text document. This must be a StyledDocument.
        重载：
        setDocument in class JTextComponent
        参数：
        doc - the document to display/edit
        抛出：
        IllegalArgumentException - if doc can't be narrowed to a StyledDocument which is the required type of model for this text component
        另请参见：
        JTextComponent.getDocument()

      • setStyledDocument

        public void setStyledDocument(StyledDocument doc)
        Associates the editor with a text document. The currently registered factory is used to build a view for the document, which gets displayed by the editor.
        参数：
        doc - the document to display/edit

      • getStyledDocument

        public StyledDocument getStyledDocument()
        Fetches the model associated with the editor.
        返回：
        the model

      • replaceSelection

        public void replaceSelection(String content)
        Replaces the currently selected content with new content represented by the given string. If there is no selection this amounts to an insert of the given text. If there is no replacement text this amounts to a removal of the current selection. The replacement text will have the attributes currently defined for input at the point of insertion. If the document is not editable, beep and return.
        重载：
        replaceSelection in class JEditorPane
        参数：
        content - the content to replace the selection with

      • insertComponent

        public void insertComponent(Component c)
        Inserts a component into the document as a replacement for the currently selected content. If there is no selection the component is effectively inserted at the current position of the caret. This is represented in the associated document as an attribute of one character of content.

        The component given is the actual component used by the JTextPane. Since components cannot be a child of more than one container, this method should not be used in situations where the model is shared by text components.

        The component is placed relative to the text baseline according to the value returned by Component.getAlignmentY. For Swing components this value can be conveniently set using the method JComponent.setAlignmentY. For example, setting a value of 0.75 will cause 75 percent of the component to be above the baseline, and 25 percent of the component to be below the baseline.

        参数：
        c - the component to insert

      • insertIcon

        public void insertIcon(Icon g)
        Inserts an icon into the document as a replacement for the currently selected content. If there is no selection the icon is effectively inserted at the current position of the caret. This is represented in the associated document as an attribute of one character of content.
        参数：
        g - the icon to insert
        另请参见：
        Icon

      • addStyle

        public Style addStyle(String nm,
             Style parent)
        Adds a new style into the logical style hierarchy. Style attributes resolve from bottom up so an attribute specified in a child will override an attribute specified in the parent.
        参数：
        nm - the name of the style (must be unique within the collection of named styles). The name may be null if the style is unnamed, but the caller is responsible for managing the reference returned as an unnamed style can't be fetched by name. An unnamed style may be useful for things like character attribute overrides such as found in a style run.
        parent - the parent style. This may be null if unspecified attributes need not be resolved in some other style.
        返回：
        the new Style

      • removeStyle

        public void removeStyle(String nm)
        Removes a named non-null style previously added to the document.
        参数：
        nm - the name of the style to remove

      • getStyle

        public Style getStyle(String nm)
        Fetches a named non-null style previously added.
        参数：
        nm - the name of the style
        返回：
        the Style

      • setLogicalStyle

        public void setLogicalStyle(Style s)
        Sets the logical style to use for the paragraph at the current caret position. If attributes aren't explicitly set for character and paragraph attributes they will resolve through the logical style assigned to the paragraph, which in term may resolve through some hierarchy completely independent of the element hierarchy in the document.
        参数：
        s - the logical style to assign to the paragraph, or null for no style

      • getLogicalStyle

        public Style getLogicalStyle()
        Fetches the logical style assigned to the paragraph represented by the current position of the caret, or null.
        返回：
        the Style

      • getCharacterAttributes

        public AttributeSet getCharacterAttributes()
        Fetches the character attributes in effect at the current location of the caret, or null.
        返回：
        the attributes, or null

      • setCharacterAttributes

        public void setCharacterAttributes(AttributeSet attr,
                          boolean replace)
        Applies the given attributes to character content. If there is a selection, the attributes are applied to the selection range. If there is no selection, the attributes are applied to the input attribute set which defines the attributes for any new text that gets inserted.
        参数：
        attr - the attributes
        replace - if true, then replace the existing attributes first

      • getParagraphAttributes

        public AttributeSet getParagraphAttributes()
        Fetches the current paragraph attributes in effect at the location of the caret, or null if none.
        返回：
        the attributes

      • setParagraphAttributes

        public void setParagraphAttributes(AttributeSet attr,
                          boolean replace)
        Applies the given attributes to paragraphs. If there is a selection, the attributes are applied to the paragraphs that intersect the selection. If there is no selection, the attributes are applied to the paragraph at the current caret position.
        参数：
        attr - the non-null attributes
        replace - if true, replace the existing attributes first

      • getInputAttributes

        public MutableAttributeSet getInputAttributes()
        Gets the input attributes for the pane.
        返回：
        the attributes

      • getStyledEditorKit

        protected final StyledEditorKit getStyledEditorKit()
        Gets the editor kit.
        返回：
        the editor kit

      • createDefaultEditorKit

        protected EditorKit createDefaultEditorKit()
        Creates the EditorKit to use by default. This is implemented to return javax.swing.text.StyledEditorKit.
        重载：
        createDefaultEditorKit in class JEditorPane
        返回：
        the editor kit

      • setEditorKit

        public final void setEditorKit(EditorKit kit)
        Sets the currently installed kit for handling content. This is the bound property that establishes the content type of the editor.
        重载：
        setEditorKit in class JEditorPane
        参数：
        kit - the desired editor behavior
        抛出：
        IllegalArgumentException - if kit is not a StyledEditorKit
        另请参见：
        JEditorPane.getEditorKit()

      • paramString

        protected String paramString()
        Returns a string representation of this JTextPane. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JEditorPane
        返回：
        a string representation of this JTextPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>L blslasl>a< <=laecias. <-!-


JToggleButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToggleButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JToggleButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
    直接已知子类：
    JCheckBox, JRadioButton

    public class JToggleButton
extends AbstractButton
implements Accessible
    An implementation of a two-state button. The JRadioButton and JCheckBox classes are subclasses of this class. For information on using them see How to Use Buttons, Check Boxes, and Radio Buttons, a section in The Java Tutorial.

    Buttons can be configured, and to some degree controlled, by Actions. Using an Action with a button has many benefits beyond directly configuring a button. Refer to Swing Components Supporting Action for more details, and you can find more information in How to Use Actions, a section in The Java Tutorial.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JRadioButton, JCheckBox

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JToggleButton.AccessibleJToggleButton
      This class implements accessibility support for the JToggleButton class.
      static class  JToggleButton.ToggleButtonModel
      The ToggleButton model

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToggleButton()
      Creates an initially unselected toggle button without setting the text or image.
      JToggleButton(Action a)
      Creates a toggle button where properties are taken from the Action supplied.
      JToggleButton(Icon icon)
      Creates an initially unselected toggle button with the specified image but no text.
      JToggleButton(Icon icon, boolean selected)
      Creates a toggle button with the specified image and selection state, but no text.
      JToggleButton(String text)
      Creates an unselected toggle button with the specified text.
      JToggleButton(String text, boolean selected)
      Creates a toggle button with the specified text and selection state.
      JToggleButton(String text, Icon icon)
      Creates a toggle button that has the specified text and image, and that is initially unselected.
      JToggleButton(String text, Icon icon, boolean selected)
      Creates a toggle button with the specified text, image, and selection state.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JToggleButton.
      String getUIClassID()
      Returns a string that specifies the name of the l&f class that renders this component.
      protected String paramString()
      Returns a string representation of this JToggleButton.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JToggleButton

        public JToggleButton()
        Creates an initially unselected toggle button without setting the text or image.

      • JToggleButton

        public JToggleButton(Icon icon)
        Creates an initially unselected toggle button with the specified image but no text.
        参数：
        icon - the image that the button should display

      • JToggleButton

        public JToggleButton(Icon icon,
             boolean selected)
        Creates a toggle button with the specified image and selection state, but no text.
        参数：
        icon - the image that the button should display
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

      • JToggleButton

        public JToggleButton(String text)
        Creates an unselected toggle button with the specified text.
        参数：
        text - the string displayed on the toggle button

      • JToggleButton

        public JToggleButton(String text,
             boolean selected)
        Creates a toggle button with the specified text and selection state.
        参数：
        text - the string displayed on the toggle button
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

      • JToggleButton

        public JToggleButton(Action a)
        Creates a toggle button where properties are taken from the Action supplied.
        从以下版本开始：
        1.3

      • JToggleButton

        public JToggleButton(String text,
             Icon icon)
        Creates a toggle button that has the specified text and image, and that is initially unselected.
        参数：
        text - the string displayed on the button
        icon - the image that the button should display

      • JToggleButton

        public JToggleButton(String text,
             Icon icon,
             boolean selected)
        Creates a toggle button with the specified text, image, and selection state.
        参数：
        text - the text of the toggle button
        icon - the image that the button should display
        selected - if true, the button is initially selected; otherwise, the button is initially unselected

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class AbstractButton
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the l&f class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        String "ToggleButtonUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • paramString

        protected String paramString()
        Returns a string representation of this JToggleButton. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class AbstractButton
        返回：
        a string representation of this JToggleButton.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JToggleButton. For toggle buttons, the AccessibleContext takes the form of an AccessibleJToggleButton. A new AccessibleJToggleButton instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJToggleButton that serves as the AccessibleContext of this JToggleButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JToggleButton.AccessibleJToggleButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToggleButton.AccessibleJToggleButton

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.AbstractButton.AccessibleAbstractButton
              • javax.swing.JToggleButton.AccessibleJToggleButton
  • 所有已实现的接口：
    ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
    直接已知子类：
    JCheckBox.AccessibleJCheckBox, JRadioButton.AccessibleJRadioButton
    封闭类：
    JToggleButton

    protected class JToggleButton.AccessibleJToggleButton
extends AbstractButton.AccessibleAbstractButton
implements ItemListener
    This class implements accessibility support for the JToggleButton class. It provides an implementation of the Java Accessibility API appropriate to toggle button user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToggleButton.AccessibleJToggleButton()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      void itemStateChanged(ItemEvent e)
      Fire accessible property change events when the state of the toggle button changes.

      • 方法 - 继承于类 javax.swing.AbstractButton.AccessibleAbstractButton

        doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JToggleButton.AccessibleJToggleButton

        public JToggleButton.AccessibleJToggleButton()

    • 方法详细信息

      • itemStateChanged

        public void itemStateChanged(ItemEvent e)
        Fire accessible property change events when the state of the toggle button changes.
        指定者：
        itemStateChanged in interface ItemListener

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t.,n


JToggleButton.ToggleButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToggleButton.ToggleButtonModel

  • java.lang.Object
    • javax.swing.DefaultButtonModel
      • javax.swing.JToggleButton.ToggleButtonModel
  • 所有已实现的接口：
    ItemSelectable, Serializable, ButtonModel
    封闭类：
    JToggleButton

    public static class JToggleButton.ToggleButtonModel
extends DefaultButtonModel
    The ToggleButton model

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.DefaultButtonModel

        actionCommand, ARMED, changeEvent, ENABLED, group, listenerList, mnemonic, PRESSED, ROLLOVER, SELECTED, stateMask

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToggleButton.ToggleButtonModel()
      Creates a new ToggleButton Model

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isSelected()
      Checks if the button is selected.
      void setPressed(boolean b)
      Sets the pressed state of the toggle button.
      void setSelected(boolean b)
      Sets the selected state of the button.

      • 方法 - 继承于类 javax.swing.DefaultButtonModel

        addActionListener, addChangeListener, addItemListener, fireActionPerformed, fireItemStateChanged, fireStateChanged, getActionCommand, getActionListeners, getChangeListeners, getGroup, getItemListeners, getListeners, getMnemonic, getSelectedObjects, isArmed, isEnabled, isPressed, isRollover, removeActionListener, removeChangeListener, removeItemListener, setActionCommand, setArmed, setEnabled, setGroup, setMnemonic, setRollover

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JToggleButton.ToggleButtonModel

        public JToggleButton.ToggleButtonModel()
        Creates a new ToggleButton Model

    • 方法详细信息

      • isSelected

        public boolean isSelected()
        Checks if the button is selected.
        指定者：
        isSelected in interface ButtonModel
        重载：
        isSelected in class DefaultButtonModel
        返回：
        true if the button is selected

      • setSelected

        public void setSelected(boolean b)
        Sets the selected state of the button.
        指定者：
        setSelected in interface ButtonModel
        重载：
        setSelected in class DefaultButtonModel
        参数：
        b - true selects the toggle button, false deselects the toggle button.

      • setPressed

        public void setPressed(boolean b)
        Sets the pressed state of the toggle button.
        指定者：
        setPressed in interface ButtonModel
        重载：
        setPressed in class DefaultButtonModel
        参数：
        b - whether or not the button should be pressed
        另请参见：
        ButtonModel.isPressed()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eosos= s= vcc vv>n//hh>/a.""jsx/Ijwee ""I..aeot


JToolBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToolBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JToolBar
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants

    public class JToolBar
extends JComponent
implements SwingConstants, Accessible
    JToolBar provides a component that is useful for displaying commonly used Actions or controls. For examples and information on using tool bars see How to Use Tool Bars, a section in The Java Tutorial.

    With most look and feels, the user can drag out a tool bar into a separate window (unless the floatable property is set to false). For drag-out to work correctly, it is recommended that you add JToolBar instances to one of the four "sides" of a container whose layout manager is a BorderLayout, and do not add children to any of the other four "sides".

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Action

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JToolBar.AccessibleJToolBar
      This class implements accessibility support for the JToolBar class.
      static class  JToolBar.Separator
      A toolbar-specific separator.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToolBar()
      Creates a new tool bar; orientation defaults to HORIZONTAL.
      JToolBar(int orientation)
      Creates a new tool bar with the specified orientation.
      JToolBar(String name)
      Creates a new tool bar with the specified name.
      JToolBar(String name, int orientation)
      Creates a new tool bar with a specified name and orientation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JButton add(Action a)
      Adds a new JButton which dispatches the action.
      protected void addImpl(Component comp, Object constraints, int index)
      If a JButton is being added, it is initially set to be disabled.
      void addSeparator()
      Appends a separator of default size to the end of the tool bar.
      void addSeparator(Dimension size)
      Appends a separator of a specified size to the end of the tool bar.
      protected PropertyChangeListener createActionChangeListener(JButton b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur, or null if the default property change listener for the control is desired.
      protected JButton createActionComponent(Action a)
      Factory method which creates the JButton for Actions added to the JToolBar.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JToolBar.
      Component getComponentAtIndex(int i)
      Returns the component at the specified index.
      int getComponentIndex(Component c)
      Returns the index of the specified component.
      Insets getMargin()
      Returns the margin between the tool bar's border and its buttons.
      int getOrientation()
      Returns the current orientation of the tool bar.
      ToolBarUI getUI()
      Returns the tool bar's current UI.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      boolean isBorderPainted()
      Gets the borderPainted property.
      boolean isFloatable()
      Gets the floatable property.
      boolean isRollover()
      Returns the rollover state.
      protected void paintBorder(Graphics g)
      Paints the tool bar's border if the borderPainted property is true.
      protected String paramString()
      Returns a string representation of this JToolBar.
      void setBorderPainted(boolean b)
      Sets the borderPainted property, which is true if the border should be painted.
      void setFloatable(boolean b)
      Sets the floatable property, which must be true for the user to move the tool bar.
      void setLayout(LayoutManager mgr)
      Sets the layout manager for this container.
      void setMargin(Insets m)
      Sets the margin between the tool bar's border and its buttons.
      void setOrientation(int o)
      Sets the orientation of the tool bar.
      void setRollover(boolean rollover)
      Sets the rollover state of this toolbar.
      void setUI(ToolBarUI ui)
      Sets the L&F object that renders this component.
      void updateUI()
      Notification from the UIFactory that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JToolBar

        public JToolBar()
        Creates a new tool bar; orientation defaults to HORIZONTAL.

      • JToolBar

        public JToolBar(int orientation)
        Creates a new tool bar with the specified orientation. The orientation must be either HORIZONTAL or VERTICAL.
        参数：
        orientation - the orientation desired

      • JToolBar

        public JToolBar(String name)
        Creates a new tool bar with the specified name. The name is used as the title of the undocked tool bar. The default orientation is HORIZONTAL.
        参数：
        name - the name of the tool bar
        从以下版本开始：
        1.3

      • JToolBar

        public JToolBar(String name,
        int orientation)
        Creates a new tool bar with a specified name and orientation. All other constructors call this constructor. If orientation is an invalid value, an exception will be thrown.
        参数：
        name - the name of the tool bar
        orientation - the initial orientation -- it must be either HORIZONTAL or VERTICAL
        抛出：
        IllegalArgumentException - if orientation is neither HORIZONTAL nor VERTICAL
        从以下版本开始：
        1.3

    • 方法详细信息

      • getUI

        public ToolBarUI getUI()
        Returns the tool bar's current UI.
        另请参见：
        setUI(javax.swing.plaf.ToolBarUI)

      • setUI

        public void setUI(ToolBarUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ToolBarUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Notification from the UIFactory that the L&F has changed. Called to replace the UI with the latest version from the UIFactory.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ToolBarUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getComponentIndex

        public int getComponentIndex(Component c)
        Returns the index of the specified component. (Note: Separators occupy index positions.)
        参数：
        c - the Component to find
        返回：
        an integer indicating the component's position, where 0 is first

      • getComponentAtIndex

        public Component getComponentAtIndex(int i)
        Returns the component at the specified index.
        参数：
        i - the component's position, where 0 is first
        返回：
        the Component at that position, or null for an invalid index

      • setMargin

        public void setMargin(Insets m)
        Sets the margin between the tool bar's border and its buttons. Setting to null causes the tool bar to use the default margins. The tool bar's default Border object uses this value to create the proper margin. However, if a non-default border is set on the tool bar, it is that Border object's responsibility to create the appropriate margin space (otherwise this property will effectively be ignored).
        参数：
        m - an Insets object that defines the space between the border and the buttons
        另请参见：
        Insets

      • getMargin

        public Insets getMargin()
        Returns the margin between the tool bar's border and its buttons.
        返回：
        an Insets object containing the margin values
        另请参见：
        Insets

      • isBorderPainted

        public boolean isBorderPainted()
        Gets the borderPainted property.
        返回：
        the value of the borderPainted property
        另请参见：
        setBorderPainted(boolean)

      • setBorderPainted

        public void setBorderPainted(boolean b)
        Sets the borderPainted property, which is true if the border should be painted. The default value for this property is true. Some look and feels might not implement painted borders; they will ignore this property.
        参数：
        b - if true, the border is painted
        另请参见：
        isBorderPainted()

      • paintBorder

        protected void paintBorder(Graphics g)
        Paints the tool bar's border if the borderPainted property is true.
        重载：
        paintBorder in class JComponent
        参数：
        g - the Graphics context in which the painting is done
        另请参见：
        JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

      • isFloatable

        public boolean isFloatable()
        Gets the floatable property.
        返回：
        the value of the floatable property
        另请参见：
        setFloatable(boolean)

      • setFloatable

        public void setFloatable(boolean b)
        Sets the floatable property, which must be true for the user to move the tool bar. Typically, a floatable tool bar can be dragged into a different position within the same container or out into its own window. The default value of this property is true. Some look and feels might not implement floatable tool bars; they will ignore this property.
        参数：
        b - if true, the tool bar can be moved; false otherwise
        另请参见：
        isFloatable()

      • getOrientation

        public int getOrientation()
        Returns the current orientation of the tool bar. The value is either HORIZONTAL or VERTICAL.
        返回：
        an integer representing the current orientation -- either HORIZONTAL or VERTICAL
        另请参见：
        setOrientation(int)

      • setOrientation

        public void setOrientation(int o)
        Sets the orientation of the tool bar. The orientation must have either the value HORIZONTAL or VERTICAL. If orientation is an invalid value, an exception will be thrown.
        参数：
        o - the new orientation -- either HORIZONTAL or VERTICAL
        抛出：
        IllegalArgumentException - if orientation is neither HORIZONTAL nor VERTICAL
        另请参见：
        getOrientation()

      • setRollover

        public void setRollover(boolean rollover)
        Sets the rollover state of this toolbar. If the rollover state is true then the border of the toolbar buttons will be drawn only when the mouse pointer hovers over them. The default value of this property is false.

        The implementation of a look and feel may choose to ignore this property.

        参数：
        rollover - true for rollover toolbar buttons; otherwise false
        从以下版本开始：
        1.4

      • isRollover

        public boolean isRollover()
        Returns the rollover state.
        返回：
        true if rollover toolbar buttons are to be drawn; otherwise false
        从以下版本开始：
        1.4
        另请参见：
        setRollover(boolean)

      • addSeparator

        public void addSeparator()
        Appends a separator of default size to the end of the tool bar. The default size is determined by the current look and feel.

      • addSeparator

        public void addSeparator(Dimension size)
        Appends a separator of a specified size to the end of the tool bar.
        参数：
        size - the Dimension of the separator

      • add

        public JButton add(Action a)
        Adds a new JButton which dispatches the action.
        参数：
        a - the Action object to add as a new menu item
        返回：
        the new button which dispatches the action

      • createActionComponent

        protected JButton createActionComponent(Action a)
        Factory method which creates the JButton for Actions added to the JToolBar. The default name is empty if a null action is passed.
        参数：
        a - the Action for the button to be added
        返回：
        the newly created button
        从以下版本开始：
        1.3
        另请参见：
        Action

      • createActionChangeListener

        protected PropertyChangeListener createActionChangeListener(JButton b)
        Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur, or null if the default property change listener for the control is desired.
        返回：
        null

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        If a JButton is being added, it is initially set to be disabled.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be enforced on the component
        index - the index of the component
        另请参见：
        Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
Container.invalidate(),
LayoutManager,
LayoutManager2

      • paramString

        protected String paramString()
        Returns a string representation of this JToolBar. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JToolBar.

      • setLayout

        public void setLayout(LayoutManager mgr)
        Description copied from class: Container
        Sets the layout manager for this container.

        This method changes layout-related information, and therefore, invalidates the component hierarchy.

        重载：
        setLayout in class Container
        参数：
        mgr - the specified layout manager
        另请参见：
        Container.doLayout(),
Container.getLayout(),
Container.invalidate()

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JToolBar. For tool bars, the AccessibleContext takes the form of an AccessibleJToolBar. A new AccessibleJToolBar instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJToolBar that serves as the AccessibleContext of this JToolBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JToolBar.AccessibleJToolBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToolBar.AccessibleJToolBar

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JToolBar.AccessibleJToolBar
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JToolBar

    protected class JToolBar.AccessibleJToolBar
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JToolBar class. It provides an implementation of the Java Accessibility API appropriate to toolbar user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JToolBar.AccessibleJToolBar()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Get the state of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JToolBar.AccessibleJToolBar

        protected JToolBar.AccessibleJToolBar()

    • 方法详细信息

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state of this object.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vu


JToolBar.Separator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToolBar.Separator

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JSeparator
            • javax.swing.JToolBar.Separator
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
    封闭类：
    JToolBar

    public static class JToolBar.Separator
extends JSeparator
    A toolbar-specific separator. An object with dimension but no contents used to divide buttons on a tool bar into groups.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JSeparator

        JSeparator.AccessibleJSeparator

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToolBar.Separator()
      Creates a new toolbar separator with the default size as defined by the current look and feel.
      JToolBar.Separator(Dimension size)
      Creates a new toolbar separator with the specified size.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Dimension getMaximumSize()
      Returns the maximum size for the separator.
      Dimension getMinimumSize()
      Returns the minimum size for the separator.
      Dimension getPreferredSize()
      Returns the preferred size for the separator.
      Dimension getSeparatorSize()
      Returns the size of the separator
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      void setSeparatorSize(Dimension size)
      Sets the size of the separator.

      • 方法 - 继承于类 javax.swing.JSeparator

        getAccessibleContext, getOrientation, getUI, paramString, setOrientation, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JToolBar.Separator

        public JToolBar.Separator()
        Creates a new toolbar separator with the default size as defined by the current look and feel.

      • JToolBar.Separator

        public JToolBar.Separator(Dimension size)
        Creates a new toolbar separator with the specified size.
        参数：
        size - the Dimension of the separator

    • 方法详细信息

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JSeparator
        返回：
        the string "ToolBarSeparatorUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setSeparatorSize

        public void setSeparatorSize(Dimension size)
        Sets the size of the separator.
        参数：
        size - the new Dimension of the separator

      • getSeparatorSize

        public Dimension getSeparatorSize()
        Returns the size of the separator
        返回：
        the Dimension object containing the separator's size (This is a reference, NOT a copy!)

      • getMinimumSize

        public Dimension getMinimumSize()
        Returns the minimum size for the separator.
        重载：
        getMinimumSize in class JComponent
        返回：
        the Dimension object containing the separator's minimum size
        另请参见：
        JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

      • getMaximumSize

        public Dimension getMaximumSize()
        Returns the maximum size for the separator.
        重载：
        getMaximumSize in class JComponent
        返回：
        the Dimension object containing the separator's maximum size
        另请参见：
        JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size for the separator.
        重载：
        getPreferredSize in class JComponent
        返回：
        the Dimension object containing the separator's preferred size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/(l.he.re.g<<.ggan reno__e_lrjab naas_jbci>.


JToolTip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToolTip

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JToolTip
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JToolTip
extends JComponent
implements Accessible
    Used to display a "Tip" for a Component. Typically components provide api to automate the process of using ToolTips. For example, any Swing component can use the JComponent setToolTipText method to specify the text for a standard tooltip. A component that wants to create a custom ToolTip display can override JComponent's createToolTip method and use a subclass of this class.

    See How to Use Tool Tips in The Java Tutorial for further documentation.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JComponent.setToolTipText(java.lang.String), JComponent.createToolTip()

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JToolTip.AccessibleJToolTip
      This class implements accessibility support for the JToolTip class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JToolTip()
      Creates a tool tip.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JToolTip.
      JComponent getComponent()
      Returns the component the tooltip applies to.
      String getTipText()
      Returns the text that is shown when the tool tip is displayed.
      ToolTipUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      protected String paramString()
      Returns a string representation of this JToolTip.
      void setComponent(JComponent c)
      Specifies the component that the tooltip describes.
      void setTipText(String tipText)
      Sets the text to show when the tool tip is displayed.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JToolTip

        public JToolTip()
        Creates a tool tip.

    • 方法详细信息

      • getUI

        public ToolTipUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the ToolTipUI object that renders this component

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ToolTipUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setTipText

        public void setTipText(String tipText)
        Sets the text to show when the tool tip is displayed. The string tipText may be null.
        参数：
        tipText - the String to display

      • getTipText

        public String getTipText()
        Returns the text that is shown when the tool tip is displayed. The returned value may be null.
        返回：
        the String that is displayed

      • setComponent

        public void setComponent(JComponent c)
        Specifies the component that the tooltip describes. The component c may be null and will have no effect.

        This is a bound property.

        参数：
        c - the JComponent being described
        另请参见：
        JComponent.createToolTip()

      • getComponent

        public JComponent getComponent()
        Returns the component the tooltip applies to. The returned value may be null.
        返回：
        the component that the tooltip describes
        另请参见：
        JComponent.createToolTip()

      • paramString

        protected String paramString()
        Returns a string representation of this JToolTip. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JToolTip

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JToolTip. For tool tips, the AccessibleContext takes the form of an AccessibleJToolTip. A new AccessibleJToolTip instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJToolTip that serves as the AccessibleContext of this JToolTip
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JToolTip.AccessibleJToolTip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JToolTip.AccessibleJToolTip

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JToolTip.AccessibleJToolTip
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JToolTip

    protected class JToolTip.AccessibleJToolTip
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JToolTip class. It provides an implementation of the Java Accessibility API appropriate to tool tip user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JToolTip.AccessibleJToolTip()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAccessibleDescription()
      Get the accessible description of this object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JToolTip.AccessibleJToolTip

        protected JToolTip.AccessibleJToolTip()

    • 方法详细信息

      • getAccessibleDescription

        public String getAccessibleDescription()
        Get the accessible description of this object.
        重载：
        getAccessibleDescription in class JComponent.AccessibleJComponent
        返回：
        a localized String describing this object.
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

piovdrtertnZZtnnmmCCno/aewie#nil#


JTree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JTree
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable

    public class JTree
extends JComponent
implements Scrollable, Accessible
    A control that displays a set of hierarchical data as an outline. You can find task-oriented documentation and examples of using trees in How to Use Trees, a section in The Java Tutorial.

    A specific node in a tree can be identified either by a TreePath (an object that encapsulates a node and all of its ancestors), or by its display row, where each row in the display area displays one node. An expanded node is a non-leaf node (as identified by TreeModel.isLeaf(node) returning false) that will displays its children when all its ancestors are expanded. A collapsed node is one which hides them. A hidden node is one which is under a collapsed ancestor. All of a viewable nodes parents are expanded, but may or may not be displayed. A displayed node is both viewable and in the display area, where it can be seen.

    The following JTree methods use "visible" to mean "displayed":

    • isRootVisible()
    • setRootVisible()
    • scrollPathToVisible()
    • scrollRowToVisible()
    • getVisibleRowCount()
    • setVisibleRowCount()

    The next group of JTree methods use "visible" to mean "viewable" (under an expanded parent):

    • isVisible()
    • makeVisible()

    If you are interested in knowing when the selection changes implement the TreeSelectionListener interface and add the instance using the method addTreeSelectionListener. valueChanged will be invoked when the selection changes, that is if the user clicks twice on the same node valueChanged will only be invoked once.

    If you are interested in detecting either double-click events or when a user clicks on a node, regardless of whether or not it was selected, we recommend you do the following:

     final JTree tree = ...;

 MouseListener ml = new MouseAdapter() {
     public void mousePressed(MouseEvent e) {
         int selRow = tree.getRowForLocation(e.getX(), e.getY());
         TreePath selPath = tree.getPathForLocation(e.getX(), e.getY());
         if(selRow != -1) {
             if(e.getClickCount() == 1) {
                 mySingleClick(selRow, selPath);
             }
             else if(e.getClickCount() == 2) {
                 myDoubleClick(selRow, selPath);
             }
         }
     }
 };
 tree.addMouseListener(ml);
    NOTE: This example obtains both the path and row, but you only need to get the one you're interested in.

    To use JTree to display compound nodes (for example, nodes containing both a graphic icon and text), subclass TreeCellRenderer and use setCellRenderer(javax.swing.tree.TreeCellRenderer) to tell the tree to use it. To edit such nodes, subclass TreeCellEditor and use setCellEditor(javax.swing.tree.TreeCellEditor).

    Like all JComponent classes, you can use InputMap and ActionMap to associate an Action object with a KeyStroke and execute the action under specified conditions.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTree.AccessibleJTree
      This class implements accessibility support for the JTree class.
      static class  JTree.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
      protected class  JTree.TreeModelHandler
      Listens to the model and updates the expandedState accordingly when nodes are removed, or changed.
      protected class  JTree.TreeSelectionRedirector
      Handles creating a new TreeSelectionEvent with the JTree as the source and passing it off to all the listeners.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ANCHOR_SELECTION_PATH_PROPERTY
      Bound property name for anchor selection path.
      static String CELL_EDITOR_PROPERTY
      Bound property name for cellEditor.
      static String CELL_RENDERER_PROPERTY
      Bound property name for cellRenderer.
      protected TreeCellEditor cellEditor
      Editor for the entries.
      protected TreeCellRenderer cellRenderer
      The cell used to draw nodes.
      protected boolean editable
      Is the tree editable? Default is false.
      static String EDITABLE_PROPERTY
      Bound property name for editable.
      static String EXPANDS_SELECTED_PATHS_PROPERTY
      Bound property name for expands selected paths property
      static String INVOKES_STOP_CELL_EDITING_PROPERTY
      Bound property name for messagesStopCellEditing.
      protected boolean invokesStopCellEditing
      If true, when editing is to be stopped by way of selection changing, data in tree changing or other means stopCellEditing is invoked, and changes are saved.
      static String LARGE_MODEL_PROPERTY
      Bound property name for largeModel.
      protected boolean largeModel
      Is this tree a large model? This is a code-optimization setting.
      static String LEAD_SELECTION_PATH_PROPERTY
      Bound property name for leadSelectionPath.
      static String ROOT_VISIBLE_PROPERTY
      Bound property name for rootVisible.
      protected boolean rootVisible
      True if the root node is displayed, false if its children are the highest visible nodes.
      static String ROW_HEIGHT_PROPERTY
      Bound property name for rowHeight.
      protected int rowHeight
      Height to use for each display row.
      static String SCROLLS_ON_EXPAND_PROPERTY
      Bound property name for scrollsOnExpand.
      protected boolean scrollsOnExpand
      If true, when a node is expanded, as many of the descendants are scrolled to be visible.
      static String SELECTION_MODEL_PROPERTY
      Bound property name for selectionModel.
      protected TreeSelectionModel selectionModel
      Models the set of selected nodes in this tree.
      protected JTree.TreeSelectionRedirector selectionRedirector
      Creates a new event and passed it off the selectionListeners.
      static String SHOWS_ROOT_HANDLES_PROPERTY
      Bound property name for showsRootHandles.
      protected boolean showsRootHandles
      True if handles are displayed at the topmost level of the tree.
      static String TOGGLE_CLICK_COUNT_PROPERTY
      Bound property name for toggleClickCount.
      protected int toggleClickCount
      Number of mouse clicks before a node is expanded.
      static String TREE_MODEL_PROPERTY
      Bound property name for treeModel.
      protected TreeModel treeModel
      The model that defines the tree displayed by this object.
      protected TreeModelListener treeModelListener
      Updates the expandedState.
      static String VISIBLE_ROW_COUNT_PROPERTY
      Bound property name for visibleRowCount.
      protected int visibleRowCount
      Number of rows to make visible at one time.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTree()
      Returns a JTree with a sample model.
      JTree(Hashtable<?,?> value)
      Returns a JTree created from a Hashtable which does not display with root.
      JTree(Object[] value)
      Returns a JTree with each element of the specified array as the child of a new root node which is not displayed.
      JTree(TreeModel newModel)
      Returns an instance of JTree which displays the root node -- the tree is created using the specified data model.
      JTree(TreeNode root)
      Returns a JTree with the specified TreeNode as its root, which displays the root node.
      JTree(TreeNode root, boolean asksAllowsChildren)
      Returns a JTree with the specified TreeNode as its root, which displays the root node and which decides whether a node is a leaf node in the specified manner.
      JTree(Vector<?> value)
      Returns a JTree with each element of the specified Vector as the child of a new root node which is not displayed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addSelectionInterval(int index0, int index1)
      Adds the specified rows (inclusive) to the selection.
      void addSelectionPath(TreePath path)
      Adds the node identified by the specified TreePath to the current selection.
      void addSelectionPaths(TreePath[] paths)
      Adds each path in the array of paths to the current selection.
      void addSelectionRow(int row)
      Adds the path at the specified row to the current selection.
      void addSelectionRows(int[] rows)
      Adds the paths at each of the specified rows to the current selection.
      void addTreeExpansionListener(TreeExpansionListener tel)
      Adds a listener for TreeExpansion events.
      void addTreeSelectionListener(TreeSelectionListener tsl)
      Adds a listener for TreeSelection events.
      void addTreeWillExpandListener(TreeWillExpandListener tel)
      Adds a listener for TreeWillExpand events.
      void cancelEditing()
      Cancels the current editing session.
      void clearSelection()
      Clears the selection.
      protected void clearToggledPaths()
      Clears the cache of toggled tree paths.
      void collapsePath(TreePath path)
      Ensures that the node identified by the specified path is collapsed and viewable.
      void collapseRow(int row)
      Ensures that the node in the specified row is collapsed.
      String convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Called by the renderers to convert the specified value to text.
      protected static TreeModel createTreeModel(Object value)
      Returns a TreeModel wrapping the specified object.
      protected TreeModelListener createTreeModelListener()
      Creates and returns an instance of TreeModelHandler.
      void expandPath(TreePath path)
      Ensures that the node identified by the specified path is expanded and viewable.
      void expandRow(int row)
      Ensures that the node in the specified row is expanded and viewable.
      void fireTreeCollapsed(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void fireTreeExpanded(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void fireTreeWillCollapse(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void fireTreeWillExpand(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireValueChanged(TreeSelectionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTree.
      TreePath getAnchorSelectionPath()
      Returns the path identified as the anchor.
      TreeCellEditor getCellEditor()
      Returns the editor used to edit entries in the tree.
      TreeCellRenderer getCellRenderer()
      Returns the current TreeCellRenderer that is rendering each cell.
      TreePath getClosestPathForLocation(int x, int y)
      Returns the path to the node that is closest to x,y.
      int getClosestRowForLocation(int x, int y)
      Returns the row to the node that is closest to x,y.
      protected static TreeModel getDefaultTreeModel()
      Creates and returns a sample TreeModel.
      protected Enumeration<TreePath> getDescendantToggledPaths(TreePath parent)
      Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.
      boolean getDragEnabled()
      Returns whether or not automatic drag handling is enabled.
      JTree.DropLocation getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
      DropMode getDropMode()
      Returns the drop mode for this component.
      TreePath getEditingPath()
      Returns the path to the element that is currently being edited.
      Enumeration<TreePath> getExpandedDescendants(TreePath parent)
      Returns an Enumeration of the descendants of the path parent that are currently expanded.
      boolean getExpandsSelectedPaths()
      Returns the expandsSelectedPaths property.
      boolean getInvokesStopCellEditing()
      Returns the indicator that tells what happens when editing is interrupted.
      Object getLastSelectedPathComponent()
      Returns the last path component of the selected path.
      TreePath getLeadSelectionPath()
      Returns the path identified as the lead.
      int getLeadSelectionRow()
      Returns the row index corresponding to the lead path.
      int getMaxSelectionRow()
      Returns the largest selected row.
      int getMinSelectionRow()
      Returns the smallest selected row.
      TreeModel getModel()
      Returns the TreeModel that is providing the data.
      TreePath getNextMatch(String prefix, int startingRow, Position.Bias bias)
      Returns the TreePath to the next tree element that begins with a prefix.
      protected TreePath[] getPathBetweenRows(int index0, int index1)
      Returns the paths (inclusive) between the specified rows.
      Rectangle getPathBounds(TreePath path)
      Returns the Rectangle that the specified node will be drawn into.
      TreePath getPathForLocation(int x, int y)
      Returns the path for the node at the specified location.
      TreePath getPathForRow(int row)
      Returns the path for the specified row.
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred display size of a JTree.
      Rectangle getRowBounds(int row)
      Returns the Rectangle that the node at the specified row is drawn in.
      int getRowCount()
      Returns the number of viewable nodes.
      int getRowForLocation(int x, int y)
      Returns the row for the specified location.
      int getRowForPath(TreePath path)
      Returns the row that displays the node identified by the specified path.
      int getRowHeight()
      Returns the height of each row.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns the amount for a block increment, which is the height or width of visibleRect, based on orientation.
      boolean getScrollableTracksViewportHeight()
      Returns false to indicate that the height of the viewport does not determine the height of the table, unless the preferred height of the tree is smaller than the viewports height.
      boolean getScrollableTracksViewportWidth()
      Returns false to indicate that the width of the viewport does not determine the width of the table, unless the preferred width of the tree is smaller than the viewports width.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Returns the amount to increment when scrolling.
      boolean getScrollsOnExpand()
      Returns the value of the scrollsOnExpand property.
      int getSelectionCount()
      Returns the number of nodes selected.
      TreeSelectionModel getSelectionModel()
      Returns the model for selections.
      TreePath getSelectionPath()
      Returns the path to the first selected node.
      TreePath[] getSelectionPaths()
      Returns the paths of all selected values.
      int[] getSelectionRows()
      Returns all of the currently selected rows.
      boolean getShowsRootHandles()
      Returns the value of the showsRootHandles property.
      int getToggleClickCount()
      Returns the number of mouse clicks needed to expand or close a node.
      String getToolTipText(MouseEvent event)
      Overrides JComponent's getToolTipText method in order to allow renderer's tips to be used if it has text set.
      TreeExpansionListener[] getTreeExpansionListeners()
      Returns an array of all the TreeExpansionListeners added to this JTree with addTreeExpansionListener().
      TreeSelectionListener[] getTreeSelectionListeners()
      Returns an array of all the TreeSelectionListeners added to this JTree with addTreeSelectionListener().
      TreeWillExpandListener[] getTreeWillExpandListeners()
      Returns an array of all the TreeWillExpandListeners added to this JTree with addTreeWillExpandListener().
      TreeUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns the name of the L&F class that renders this component.
      int getVisibleRowCount()
      Returns the number of rows that are displayed in the display area.
      boolean hasBeenExpanded(TreePath path)
      Returns true if the node identified by the path has ever been expanded.
      boolean isCollapsed(int row)
      Returns true if the node at the specified display row is collapsed.
      boolean isCollapsed(TreePath path)
      Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
      boolean isEditable()
      Returns true if the tree is editable.
      boolean isEditing()
      Returns true if the tree is being edited.
      boolean isExpanded(int row)
      Returns true if the node at the specified display row is currently expanded.
      boolean isExpanded(TreePath path)
      Returns true if the node identified by the path is currently expanded,
      boolean isFixedRowHeight()
      Returns true if the height of each display row is a fixed size.
      boolean isLargeModel()
      Returns true if the tree is configured for a large model.
      boolean isPathEditable(TreePath path)
      Returns isEditable.
      boolean isPathSelected(TreePath path)
      Returns true if the item identified by the path is currently selected.
      boolean isRootVisible()
      Returns true if the root node of the tree is displayed.
      boolean isRowSelected(int row)
      Returns true if the node identified by row is selected.
      boolean isSelectionEmpty()
      Returns true if the selection is currently empty.
      boolean isVisible(TreePath path)
      Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded.
      void makeVisible(TreePath path)
      Ensures that the node identified by path is currently viewable.
      protected String paramString()
      Returns a string representation of this JTree.
      protected boolean removeDescendantSelectedPaths(TreePath path, boolean includePath)
      Removes any paths in the selection that are descendants of path.
      protected void removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
      Removes any descendants of the TreePaths in toRemove that have been expanded.
      void removeSelectionInterval(int index0, int index1)
      Removes the specified rows (inclusive) from the selection.
      void removeSelectionPath(TreePath path)
      Removes the node identified by the specified path from the current selection.
      void removeSelectionPaths(TreePath[] paths)
      Removes the nodes identified by the specified paths from the current selection.
      void removeSelectionRow(int row)
      Removes the row at the index row from the current selection.
      void removeSelectionRows(int[] rows)
      Removes the rows that are selected at each of the specified rows.
      void removeTreeExpansionListener(TreeExpansionListener tel)
      Removes a listener for TreeExpansion events.
      void removeTreeSelectionListener(TreeSelectionListener tsl)
      Removes a TreeSelection listener.
      void removeTreeWillExpandListener(TreeWillExpandListener tel)
      Removes a listener for TreeWillExpand events.
      void scrollPathToVisible(TreePath path)
      Makes sure all the path components in path are expanded (except for the last path component) and scrolls so that the node identified by the path is displayed.
      void scrollRowToVisible(int row)
      Scrolls the item identified by row until it is displayed.
      void setAnchorSelectionPath(TreePath newPath)
      Sets the path identified as the anchor.
      void setCellEditor(TreeCellEditor cellEditor)
      Sets the cell editor.
      void setCellRenderer(TreeCellRenderer x)
      Sets the TreeCellRenderer that will be used to draw each cell.
      void setDragEnabled(boolean b)
      Turns on or off automatic drag handling.
      void setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void setEditable(boolean flag)
      Determines whether the tree is editable.
      protected void setExpandedState(TreePath path, boolean state)
      Sets the expanded state of this JTree.
      void setExpandsSelectedPaths(boolean newValue)
      Configures the expandsSelectedPaths property.
      void setInvokesStopCellEditing(boolean newValue)
      Determines what happens when editing is interrupted by selecting another node in the tree, a change in the tree's data, or by some other means.
      void setLargeModel(boolean newValue)
      Specifies whether the UI should use a large model.
      void setLeadSelectionPath(TreePath newPath)
      Sets the path identifies as the lead.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell, in pixels.
      void setScrollsOnExpand(boolean newValue)
      Sets the scrollsOnExpand property, which determines whether the tree might scroll to show previously hidden children.
      void setSelectionInterval(int index0, int index1)
      Selects the rows in the specified interval (inclusive).
      void setSelectionModel(TreeSelectionModel selectionModel)
      Sets the tree's selection model.
      void setSelectionPath(TreePath path)
      Selects the node identified by the specified path.
      void setSelectionPaths(TreePath[] paths)
      Selects the nodes identified by the specified array of paths.
      void setSelectionRow(int row)
      Selects the node at the specified row in the display.
      void setSelectionRows(int[] rows)
      Selects the nodes corresponding to each of the specified rows in the display.
      void setShowsRootHandles(boolean newValue)
      Sets the value of the showsRootHandles property, which specifies whether the node handles should be displayed.
      void setToggleClickCount(int clickCount)
      Sets the number of mouse clicks before a node will expand or close.
      void setUI(TreeUI ui)
      Sets the L&F object that renders this component.
      void setVisibleRowCount(int newCount)
      Sets the number of rows that are to be displayed.
      void startEditingAtPath(TreePath path)
      Selects the node identified by the specified path and initiates editing.
      boolean stopEditing()
      Ends the current editing session.
      void treeDidChange()
      Sent when the tree has changed enough that we need to resize the bounds, but not enough that we need to remove the expanded node set (e.g nodes were expanded or collapsed, or nodes were inserted into the tree).
      void updateUI()
      Notification from the UIManager that the L&F has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • treeModel

        protected transient TreeModel treeModel
        The model that defines the tree displayed by this object.

      • selectionModel

        protected transient TreeSelectionModel selectionModel
        Models the set of selected nodes in this tree.

      • rootVisible

        protected boolean rootVisible
        True if the root node is displayed, false if its children are the highest visible nodes.

      • cellRenderer

        protected transient TreeCellRenderer cellRenderer
        The cell used to draw nodes. If null, the UI uses a default cellRenderer.

      • rowHeight

        protected int rowHeight
        Height to use for each display row. If this is <= 0 the renderer determines the height for each row.

      • showsRootHandles

        protected boolean showsRootHandles
        True if handles are displayed at the topmost level of the tree.

        A handle is a small icon that displays adjacent to the node which allows the user to click once to expand or collapse the node. A common interface shows a plus sign (+) for a node which can be expanded and a minus sign (-) for a node which can be collapsed. Handles are always shown for nodes below the topmost level.

        If the rootVisible setting specifies that the root node is to be displayed, then that is the only node at the topmost level. If the root node is not displayed, then all of its children are at the topmost level of the tree. Handles are always displayed for nodes other than the topmost.

        If the root node isn't visible, it is generally a good to make this value true. Otherwise, the tree looks exactly like a list, and users may not know that the "list entries" are actually tree nodes.

        另请参见：
        rootVisible

      • selectionRedirector

        protected transient JTree.TreeSelectionRedirector selectionRedirector
        Creates a new event and passed it off the selectionListeners.

      • cellEditor

        protected transient TreeCellEditor cellEditor
        Editor for the entries. Default is null (tree is not editable).

      • editable

        protected boolean editable
        Is the tree editable? Default is false.

      • largeModel

        protected boolean largeModel
        Is this tree a large model? This is a code-optimization setting. A large model can be used when the cell height is the same for all nodes. The UI will then cache very little information and instead continually message the model. Without a large model the UI caches most of the information, resulting in fewer method calls to the model.

        This value is only a suggestion to the UI. Not all UIs will take advantage of it. Default value is false.

      • visibleRowCount

        protected int visibleRowCount
        Number of rows to make visible at one time. This value is used for the Scrollable interface. It determines the preferred size of the display area.

      • invokesStopCellEditing

        protected boolean invokesStopCellEditing
        If true, when editing is to be stopped by way of selection changing, data in tree changing or other means stopCellEditing is invoked, and changes are saved. If false, cancelCellEditing is invoked, and changes are discarded. Default is false.

      • scrollsOnExpand

        protected boolean scrollsOnExpand
        If true, when a node is expanded, as many of the descendants are scrolled to be visible.

      • toggleClickCount

        protected int toggleClickCount
        Number of mouse clicks before a node is expanded.

      • treeModelListener

        protected transient TreeModelListener treeModelListener
        Updates the expandedState.

      • CELL_RENDERER_PROPERTY

        public static final String CELL_RENDERER_PROPERTY
        Bound property name for cellRenderer.
        另请参见：
        Constant Field Values

      • TREE_MODEL_PROPERTY

        public static final String TREE_MODEL_PROPERTY
        Bound property name for treeModel.
        另请参见：
        Constant Field Values

      • ROOT_VISIBLE_PROPERTY

        public static final String ROOT_VISIBLE_PROPERTY
        Bound property name for rootVisible.
        另请参见：
        Constant Field Values

      • SHOWS_ROOT_HANDLES_PROPERTY

        public static final String SHOWS_ROOT_HANDLES_PROPERTY
        Bound property name for showsRootHandles.
        另请参见：
        Constant Field Values

      • ROW_HEIGHT_PROPERTY

        public static final String ROW_HEIGHT_PROPERTY
        Bound property name for rowHeight.
        另请参见：
        Constant Field Values

      • CELL_EDITOR_PROPERTY

        public static final String CELL_EDITOR_PROPERTY
        Bound property name for cellEditor.
        另请参见：
        Constant Field Values

      • EDITABLE_PROPERTY

        public static final String EDITABLE_PROPERTY
        Bound property name for editable.
        另请参见：
        Constant Field Values

      • LARGE_MODEL_PROPERTY

        public static final String LARGE_MODEL_PROPERTY
        Bound property name for largeModel.
        另请参见：
        Constant Field Values

      • SELECTION_MODEL_PROPERTY

        public static final String SELECTION_MODEL_PROPERTY
        Bound property name for selectionModel.
        另请参见：
        Constant Field Values

      • VISIBLE_ROW_COUNT_PROPERTY

        public static final String VISIBLE_ROW_COUNT_PROPERTY
        Bound property name for visibleRowCount.
        另请参见：
        Constant Field Values

      • INVOKES_STOP_CELL_EDITING_PROPERTY

        public static final String INVOKES_STOP_CELL_EDITING_PROPERTY
        Bound property name for messagesStopCellEditing.
        另请参见：
        Constant Field Values

      • SCROLLS_ON_EXPAND_PROPERTY

        public static final String SCROLLS_ON_EXPAND_PROPERTY
        Bound property name for scrollsOnExpand.
        另请参见：
        Constant Field Values

      • TOGGLE_CLICK_COUNT_PROPERTY

        public static final String TOGGLE_CLICK_COUNT_PROPERTY
        Bound property name for toggleClickCount.
        另请参见：
        Constant Field Values

      • LEAD_SELECTION_PATH_PROPERTY

        public static final String LEAD_SELECTION_PATH_PROPERTY
        Bound property name for leadSelectionPath.
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • ANCHOR_SELECTION_PATH_PROPERTY

        public static final String ANCHOR_SELECTION_PATH_PROPERTY
        Bound property name for anchor selection path.
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

      • EXPANDS_SELECTED_PATHS_PROPERTY

        public static final String EXPANDS_SELECTED_PATHS_PROPERTY
        Bound property name for expands selected paths property
        从以下版本开始：
        1.3
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JTree

        public JTree()
        Returns a JTree with a sample model. The default model used by the tree defines a leaf node as any node without children.
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        public JTree(Object[] value)
        Returns a JTree with each element of the specified array as the child of a new root node which is not displayed. By default, the tree defines a leaf node as any node without children.
        参数：
        value - an array of Objects
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        public JTree(Vector<?> value)
        Returns a JTree with each element of the specified Vector as the child of a new root node which is not displayed. By default, the tree defines a leaf node as any node without children.
        参数：
        value - a Vector
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        public JTree(Hashtable<?,?> value)
        Returns a JTree created from a Hashtable which does not display with root. Each value-half of the key/value pairs in the HashTable becomes a child of the new root node. By default, the tree defines a leaf node as any node without children.
        参数：
        value - a Hashtable
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        public JTree(TreeNode root)
        Returns a JTree with the specified TreeNode as its root, which displays the root node. By default, the tree defines a leaf node as any node without children.
        参数：
        root - a TreeNode object
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        public JTree(TreeNode root,
     boolean asksAllowsChildren)
        Returns a JTree with the specified TreeNode as its root, which displays the root node and which decides whether a node is a leaf node in the specified manner.
        参数：
        root - a TreeNode object
        asksAllowsChildren - if false, any node without children is a leaf node; if true, only nodes that do not allow children are leaf nodes
        另请参见：
        DefaultTreeModel.asksAllowsChildren

      • JTree

        @ConstructorProperties(value="model")
public JTree(TreeModel newModel)
        Returns an instance of JTree which displays the root node -- the tree is created using the specified data model.
        参数：
        newModel - the TreeModel to use as the data model

    • 方法详细信息

      • getDefaultTreeModel

        protected static TreeModel getDefaultTreeModel()
        Creates and returns a sample TreeModel. Used primarily for beanbuilders to show something interesting.
        返回：
        the default TreeModel

      • createTreeModel

        protected static TreeModel createTreeModel(Object value)
        Returns a TreeModel wrapping the specified object. If the object is:
        • an array of Objects,
        • a Hashtable, or
        • a Vector
        then a new root node is created with each of the incoming objects as children. Otherwise, a new root is created with a value of "root".
        参数：
        value - the Object used as the foundation for the TreeModel
        返回：
        a TreeModel wrapping the specified object

      • getUI

        public TreeUI getUI()
        Returns the L&F object that renders this component.
        返回：
        the TreeUI object that renders this component

      • setUI

        public void setUI(TreeUI ui)
        Sets the L&F object that renders this component.

        This is a bound property.

        参数：
        ui - the TreeUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Notification from the UIManager that the L&F has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "TreeUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • getCellRenderer

        public TreeCellRenderer getCellRenderer()
        Returns the current TreeCellRenderer that is rendering each cell.
        返回：
        the TreeCellRenderer that is rendering each cell

      • setCellRenderer

        public void setCellRenderer(TreeCellRenderer x)
        Sets the TreeCellRenderer that will be used to draw each cell.

        This is a bound property.

        参数：
        x - the TreeCellRenderer that is to render each cell

      • setEditable

        public void setEditable(boolean flag)
        Determines whether the tree is editable. Fires a property change event if the new setting is different from the existing setting.

        This is a bound property.

        参数：
        flag - a boolean value, true if the tree is editable

      • isEditable

        public boolean isEditable()
        Returns true if the tree is editable.
        返回：
        true if the tree is editable

      • setCellEditor

        public void setCellEditor(TreeCellEditor cellEditor)
        Sets the cell editor. A null value implies that the tree cannot be edited. If this represents a change in the cellEditor, the propertyChange method is invoked on all listeners.

        This is a bound property.

        参数：
        cellEditor - the TreeCellEditor to use

      • getCellEditor

        public TreeCellEditor getCellEditor()
        Returns the editor used to edit entries in the tree.
        返回：
        the TreeCellEditor in use, or null if the tree cannot be edited

      • getModel

        public TreeModel getModel()
        Returns the TreeModel that is providing the data.
        返回：
        the TreeModel that is providing the data

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.

        This is a bound property.

        参数：
        newModel - the TreeModel that is to provide the data

      • isRootVisible

        public boolean isRootVisible()
        Returns true if the root node of the tree is displayed.
        返回：
        true if the root node of the tree is displayed
        另请参见：
        rootVisible

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.

        This is a bound property.

        参数：
        rootVisible - true if the root node of the tree is to be displayed
        另请参见：
        rootVisible

      • setShowsRootHandles

        public void setShowsRootHandles(boolean newValue)
        Sets the value of the showsRootHandles property, which specifies whether the node handles should be displayed. The default value of this property depends on the constructor used to create the JTree. Some look and feels might not support handles; they will ignore this property.

        This is a bound property.

        参数：
        newValue - true if root handles should be displayed; otherwise, false
        另请参见：
        showsRootHandles, getShowsRootHandles()

      • getShowsRootHandles

        public boolean getShowsRootHandles()
        Returns the value of the showsRootHandles property.
        返回：
        the value of the showsRootHandles property
        另请参见：
        showsRootHandles

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell, in pixels. If the specified value is less than or equal to zero the current cell renderer is queried for each row's height.

        This is a bound property.

        参数：
        rowHeight - the height of each cell, in pixels

      • getRowHeight

        public int getRowHeight()
        Returns the height of each row. If the returned value is less than or equal to 0 the height for each row is determined by the renderer.

      • isFixedRowHeight

        public boolean isFixedRowHeight()
        Returns true if the height of each display row is a fixed size.
        返回：
        true if the height of each row is a fixed size

      • setLargeModel

        public void setLargeModel(boolean newValue)
        Specifies whether the UI should use a large model. (Not all UIs will implement this.) Fires a property change for the LARGE_MODEL_PROPERTY.

        This is a bound property.

        参数：
        newValue - true to suggest a large model to the UI
        另请参见：
        largeModel

      • isLargeModel

        public boolean isLargeModel()
        Returns true if the tree is configured for a large model.
        返回：
        true if a large model is suggested
        另请参见：
        largeModel

      • setInvokesStopCellEditing

        public void setInvokesStopCellEditing(boolean newValue)
        Determines what happens when editing is interrupted by selecting another node in the tree, a change in the tree's data, or by some other means. Setting this property to true causes the changes to be automatically saved when editing is interrupted.

        Fires a property change for the INVOKES_STOP_CELL_EDITING_PROPERTY.

        参数：
        newValue - true means that stopCellEditing is invoked when editing is interrupted, and data is saved; false means that cancelCellEditing is invoked, and changes are lost

      • getInvokesStopCellEditing

        public boolean getInvokesStopCellEditing()
        Returns the indicator that tells what happens when editing is interrupted.
        返回：
        the indicator that tells what happens when editing is interrupted
        另请参见：
        setInvokesStopCellEditing(boolean)

      • setScrollsOnExpand

        public void setScrollsOnExpand(boolean newValue)
        Sets the scrollsOnExpand property, which determines whether the tree might scroll to show previously hidden children. If this property is true (the default), when a node expands the tree can use scrolling to make the maximum possible number of the node's descendants visible. In some look and feels, trees might not need to scroll when expanded; those look and feels will ignore this property.

        This is a bound property.

        参数：
        newValue - false to disable scrolling on expansion; true to enable it
        另请参见：
        getScrollsOnExpand()

      • getScrollsOnExpand

        public boolean getScrollsOnExpand()
        Returns the value of the scrollsOnExpand property.
        返回：
        the value of the scrollsOnExpand property

      • setToggleClickCount

        public void setToggleClickCount(int clickCount)
        Sets the number of mouse clicks before a node will expand or close. The default is two.

        This is a bound property.

        从以下版本开始：
        1.3

      • getToggleClickCount

        public int getToggleClickCount()
        Returns the number of mouse clicks needed to expand or close a node.
        返回：
        number of mouse clicks before node is expanded
        从以下版本开始：
        1.3

      • setExpandsSelectedPaths

        public void setExpandsSelectedPaths(boolean newValue)
        Configures the expandsSelectedPaths property. If true, any time the selection is changed, either via the TreeSelectionModel, or the cover methods provided by JTree, the TreePaths parents will be expanded to make them visible (visible meaning the parent path is expanded, not necessarily in the visible rectangle of the JTree). If false, when the selection changes the nodes parent is not made visible (all its parents expanded). This is useful if you wish to have your selection model maintain paths that are not always visible (all parents expanded).

        This is a bound property.

        参数：
        newValue - the new value for expandsSelectedPaths
        从以下版本开始：
        1.3

      • getExpandsSelectedPaths

        public boolean getExpandsSelectedPaths()
        Returns the expandsSelectedPaths property.
        返回：
        true if selection changes result in the parent path being expanded
        从以下版本开始：
        1.3
        另请参见：
        setExpandsSelectedPaths(boolean)

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Turns on or off automatic drag handling. In order to enable automatic drag handling, this property should be set to true, and the tree's TransferHandler needs to be non-null. The default value of the dragEnabled property is false.

        The job of honoring this property, and recognizing a user drag gesture, lies with the look and feel implementation, and in particular, the tree's TreeUI. When automatic drag handling is enabled, most look and feels (including those that subclass BasicLookAndFeel) begin a drag and drop operation whenever the user presses the mouse button over an item and then moves the mouse a few pixels. Setting this property to true can therefore have a subtle effect on how selections behave.

        If a look and feel is used that ignores this property, you can still begin a drag and drop operation by calling exportAsDrag on the tree's TransferHandler.

        参数：
        b - whether or not to enable automatic drag handling
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Returns whether or not automatic drag handling is enabled.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • setDropMode

        public final void setDropMode(DropMode dropMode)
        Sets the drop mode for this component. For backward compatibility, the default for this property is DropMode.USE_SELECTION. Usage of one of the other modes is recommended, however, for an improved user experience. DropMode.ON, for instance, offers similar behavior of showing items as selected, but does so without affecting the actual selection in the tree.

        JTree supports the following drop modes:

        • DropMode.USE_SELECTION
        • DropMode.ON
        • DropMode.INSERT
        • DropMode.ON_OR_INSERT

        The drop mode is only meaningful if this component has a TransferHandler that accepts drops.

        参数：
        dropMode - the drop mode to use
        抛出：
        IllegalArgumentException - if the drop mode is unsupported or null
        从以下版本开始：
        1.6
        另请参见：
        getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDropMode

        public final DropMode getDropMode()
        Returns the drop mode for this component.
        返回：
        the drop mode for this component
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode)

      • getDropLocation

        public final JTree.DropLocation getDropLocation()
        Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

        This method is not meant for querying the drop location from a TransferHandler, as the drop location is only set after the TransferHandler's canImport has returned and has allowed for the location to be shown.

        When this property changes, a property change event with name "dropLocation" is fired by the component.

        返回：
        the drop location
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

      • isPathEditable

        public boolean isPathEditable(TreePath path)
        Returns isEditable. This is invoked from the UI before editing begins to insure that the given path can be edited. This is provided as an entry point for subclassers to add filtered editing without having to resort to creating a new editor.
        返回：
        true if every parent node and the node itself is editable
        另请参见：
        isEditable()

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Overrides JComponent's getToolTipText method in order to allow renderer's tips to be used if it has text set.

        NOTE: For JTree to properly display tooltips of its renderers, JTree must be a registered component with the ToolTipManager. This can be done by invoking ToolTipManager.sharedInstance().registerComponent(tree). This is not done automatically!

        重载：
        getToolTipText in class JComponent
        参数：
        event - the MouseEvent that initiated the ToolTip display
        返回：
        a string containing the tooltip or null if event is null

      • convertValueToText

        public String convertValueToText(Object value,
                        boolean selected,
                        boolean expanded,
                        boolean leaf,
                        int row,
                        boolean hasFocus)
        Called by the renderers to convert the specified value to text. This implementation returns value.toString, ignoring all other arguments. To control the conversion, subclass this method and use any of the arguments you need.
        参数：
        value - the Object to convert to text
        selected - true if the node is selected
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - an integer specifying the node's display row, where 0 is the first row in the display
        hasFocus - true if the node has the focus
        返回：
        the String representation of the node's value

      • getRowCount

        public int getRowCount()
        Returns the number of viewable nodes. A node is viewable if all of its parents are expanded. The root is only included in this count if isRootVisible() is true. This returns 0 if the UI has not been set.
        返回：
        the number of viewable nodes

      • setSelectionPath

        public void setSelectionPath(TreePath path)
        Selects the node identified by the specified path. If any component of the path is hidden (under a collapsed node), and getExpandsSelectedPaths is true it is exposed (made viewable).
        参数：
        path - the TreePath specifying the node to select

      • setSelectionPaths

        public void setSelectionPaths(TreePath[] paths)
        Selects the nodes identified by the specified array of paths. If any component in any of the paths is hidden (under a collapsed node), and getExpandsSelectedPaths is true it is exposed (made viewable).
        参数：
        paths - an array of TreePath objects that specifies the nodes to select

      • setLeadSelectionPath

        public void setLeadSelectionPath(TreePath newPath)
        Sets the path identifies as the lead. The lead may not be selected. The lead is not maintained by JTree, rather the UI will update it.

        This is a bound property.

        参数：
        newPath - the new lead path
        从以下版本开始：
        1.3

      • setAnchorSelectionPath

        public void setAnchorSelectionPath(TreePath newPath)
        Sets the path identified as the anchor. The anchor is not maintained by JTree, rather the UI will update it.

        This is a bound property.

        参数：
        newPath - the new anchor path
        从以下版本开始：
        1.3

      • setSelectionRow

        public void setSelectionRow(int row)
        Selects the node at the specified row in the display.
        参数：
        row - the row to select, where 0 is the first row in the display

      • setSelectionRows

        public void setSelectionRows(int[] rows)
        Selects the nodes corresponding to each of the specified rows in the display. If a particular element of rows is < 0 or >= getRowCount, it will be ignored. If none of the elements in rows are valid rows, the selection will be cleared. That is it will be as if clearSelection was invoked.
        参数：
        rows - an array of ints specifying the rows to select, where 0 indicates the first row in the display

      • addSelectionPath

        public void addSelectionPath(TreePath path)
        Adds the node identified by the specified TreePath to the current selection. If any component of the path isn't viewable, and getExpandsSelectedPaths is true it is made viewable.

        Note that JTree does not allow duplicate nodes to exist as children under the same parent -- each sibling must be a unique object.

        参数：
        path - the TreePath to add

      • addSelectionPaths

        public void addSelectionPaths(TreePath[] paths)
        Adds each path in the array of paths to the current selection. If any component of any of the paths isn't viewable and getExpandsSelectedPaths is true, it is made viewable.

        Note that JTree does not allow duplicate nodes to exist as children under the same parent -- each sibling must be a unique object.

        参数：
        paths - an array of TreePath objects that specifies the nodes to add

      • addSelectionRow

        public void addSelectionRow(int row)
        Adds the path at the specified row to the current selection.
        参数：
        row - an integer specifying the row of the node to add, where 0 is the first row in the display

      • addSelectionRows

        public void addSelectionRows(int[] rows)
        Adds the paths at each of the specified rows to the current selection.
        参数：
        rows - an array of ints specifying the rows to add, where 0 indicates the first row in the display

      • getLastSelectedPathComponent

        public Object getLastSelectedPathComponent()
        Returns the last path component of the selected path. This is a convenience method for getSelectionModel().getSelectionPath().getLastPathComponent(). This is typically only useful if the selection has one path.
        返回：
        the last path component of the selected path, or null if nothing is selected
        另请参见：
        TreePath.getLastPathComponent()

      • getLeadSelectionPath

        public TreePath getLeadSelectionPath()
        Returns the path identified as the lead.
        返回：
        path identified as the lead

      • getAnchorSelectionPath

        public TreePath getAnchorSelectionPath()
        Returns the path identified as the anchor.
        返回：
        path identified as the anchor
        从以下版本开始：
        1.3

      • getSelectionPath

        public TreePath getSelectionPath()
        Returns the path to the first selected node.
        返回：
        the TreePath for the first selected node, or null if nothing is currently selected

      • getSelectionPaths

        public TreePath[] getSelectionPaths()
        Returns the paths of all selected values.
        返回：
        an array of TreePath objects indicating the selected nodes, or null if nothing is currently selected

      • getSelectionRows

        public int[] getSelectionRows()
        Returns all of the currently selected rows. This method is simply forwarded to the TreeSelectionModel. If nothing is selected null or an empty array will be returned, based on the TreeSelectionModel implementation.
        返回：
        an array of integers that identifies all currently selected rows where 0 is the first row in the display

      • getSelectionCount

        public int getSelectionCount()
        Returns the number of nodes selected.
        返回：
        the number of nodes selected

      • getMinSelectionRow

        public int getMinSelectionRow()
        Returns the smallest selected row. If the selection is empty, or none of the selected paths are viewable, -1 is returned.
        返回：
        the smallest selected row

      • getMaxSelectionRow

        public int getMaxSelectionRow()
        Returns the largest selected row. If the selection is empty, or none of the selected paths are viewable, -1 is returned.
        返回：
        the largest selected row

      • getLeadSelectionRow

        public int getLeadSelectionRow()
        Returns the row index corresponding to the lead path.
        返回：
        an integer giving the row index of the lead path, where 0 is the first row in the display; or -1 if leadPath is null

      • isPathSelected

        public boolean isPathSelected(TreePath path)
        Returns true if the item identified by the path is currently selected.
        参数：
        path - a TreePath identifying a node
        返回：
        true if the node is selected

      • isRowSelected

        public boolean isRowSelected(int row)
        Returns true if the node identified by row is selected.
        参数：
        row - an integer specifying a display row, where 0 is the first row in the display
        返回：
        true if the node is selected

      • getExpandedDescendants

        public Enumeration<TreePath> getExpandedDescendants(TreePath parent)
        Returns an Enumeration of the descendants of the path parent that are currently expanded. If parent is not currently expanded, this will return null. If you expand/collapse nodes while iterating over the returned Enumeration this may not return all the expanded paths, or may return paths that are no longer expanded.
        参数：
        parent - the path which is to be examined
        返回：
        an Enumeration of the descendents of parent, or null if parent is not currently expanded

      • hasBeenExpanded

        public boolean hasBeenExpanded(TreePath path)
        Returns true if the node identified by the path has ever been expanded.
        返回：
        true if the path has ever been expanded

      • isExpanded

        public boolean isExpanded(TreePath path)
        Returns true if the node identified by the path is currently expanded,
        参数：
        path - the TreePath specifying the node to check
        返回：
        false if any of the nodes in the node's path are collapsed, true if all nodes in the path are expanded

      • isExpanded

        public boolean isExpanded(int row)
        Returns true if the node at the specified display row is currently expanded.
        参数：
        row - the row to check, where 0 is the first row in the display
        返回：
        true if the node is currently expanded, otherwise false

      • isCollapsed

        public boolean isCollapsed(TreePath path)
        Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
        参数：
        path - the TreePath to check
        返回：
        true if any of the nodes in the node's path are collapsed, false if all nodes in the path are expanded

      • isCollapsed

        public boolean isCollapsed(int row)
        Returns true if the node at the specified display row is collapsed.
        参数：
        row - the row to check, where 0 is the first row in the display
        返回：
        true if the node is currently collapsed, otherwise false

      • makeVisible

        public void makeVisible(TreePath path)
        Ensures that the node identified by path is currently viewable.
        参数：
        path - the TreePath to make visible

      • isVisible

        public boolean isVisible(TreePath path)
        Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded. Otherwise, this method returns false.
        返回：
        true if the node is viewable, otherwise false

      • getPathBounds

        public Rectangle getPathBounds(TreePath path)
        Returns the Rectangle that the specified node will be drawn into. Returns null if any component in the path is hidden (under a collapsed parent).

        Note:
        This method returns a valid rectangle, even if the specified node is not currently displayed.

        参数：
        path - the TreePath identifying the node
        返回：
        the Rectangle the node is drawn in, or null

      • getRowBounds

        public Rectangle getRowBounds(int row)
        Returns the Rectangle that the node at the specified row is drawn in.
        参数：
        row - the row to be drawn, where 0 is the first row in the display
        返回：
        the Rectangle the node is drawn in

      • scrollPathToVisible

        public void scrollPathToVisible(TreePath path)
        Makes sure all the path components in path are expanded (except for the last path component) and scrolls so that the node identified by the path is displayed. Only works when this JTree is contained in a JScrollPane.
        参数：
        path - the TreePath identifying the node to bring into view

      • scrollRowToVisible

        public void scrollRowToVisible(int row)
        Scrolls the item identified by row until it is displayed. The minimum of amount of scrolling necessary to bring the row into view is performed. Only works when this JTree is contained in a JScrollPane.
        参数：
        row - an integer specifying the row to scroll, where 0 is the first row in the display

      • getPathForRow

        public TreePath getPathForRow(int row)
        Returns the path for the specified row. If row is not visible, or a TreeUI has not been set, null is returned.
        参数：
        row - an integer specifying a row
        返回：
        the TreePath to the specified node, null if row < 0 or row >= getRowCount()

      • getRowForPath

        public int getRowForPath(TreePath path)
        Returns the row that displays the node identified by the specified path.
        参数：
        path - the TreePath identifying a node
        返回：
        an integer specifying the display row, where 0 is the first row in the display, or -1 if any of the elements in path are hidden under a collapsed parent.

      • expandPath

        public void expandPath(TreePath path)
        Ensures that the node identified by the specified path is expanded and viewable. If the last item in the path is a leaf, this will have no effect.
        参数：
        path - the TreePath identifying a node

      • expandRow

        public void expandRow(int row)
        Ensures that the node in the specified row is expanded and viewable.

        If row is < 0 or >= getRowCount this will have no effect.

        参数：
        row - an integer specifying a display row, where 0 is the first row in the display

      • collapsePath

        public void collapsePath(TreePath path)
        Ensures that the node identified by the specified path is collapsed and viewable.
        参数：
        path - the TreePath identifying a node

      • collapseRow

        public void collapseRow(int row)
        Ensures that the node in the specified row is collapsed.

        If row is < 0 or >= getRowCount this will have no effect.

        参数：
        row - an integer specifying a display row, where 0 is the first row in the display

      • getPathForLocation

        public TreePath getPathForLocation(int x,
                          int y)
        Returns the path for the node at the specified location.
        参数：
        x - an integer giving the number of pixels horizontally from the left edge of the display area, minus any left margin
        y - an integer giving the number of pixels vertically from the top of the display area, minus any top margin
        返回：
        the TreePath for the node at that location

      • getRowForLocation

        public int getRowForLocation(int x,
                    int y)
        Returns the row for the specified location.
        参数：
        x - an integer giving the number of pixels horizontally from the left edge of the display area, minus any left margin
        y - an integer giving the number of pixels vertically from the top of the display area, minus any top margin
        返回：
        the row corresponding to the location, or -1 if the location is not within the bounds of a displayed cell
        另请参见：
        getClosestRowForLocation(int, int)

      • getClosestPathForLocation

        public TreePath getClosestPathForLocation(int x,
                                 int y)
        Returns the path to the node that is closest to x,y. If no nodes are currently viewable, or there is no model, returns null, otherwise it always returns a valid path. To test if the node is exactly at x, y, get the node's bounds and test x, y against that.
        参数：
        x - an integer giving the number of pixels horizontally from the left edge of the display area, minus any left margin
        y - an integer giving the number of pixels vertically from the top of the display area, minus any top margin
        返回：
        the TreePath for the node closest to that location, null if nothing is viewable or there is no model
        另请参见：
        getPathForLocation(int, int), getPathBounds(javax.swing.tree.TreePath)

      • getClosestRowForLocation

        public int getClosestRowForLocation(int x,
                           int y)
        Returns the row to the node that is closest to x,y. If no nodes are viewable or there is no model, returns -1. Otherwise, it always returns a valid row. To test if the returned object is exactly at x, y, get the bounds for the node at the returned row and test x, y against that.
        参数：
        x - an integer giving the number of pixels horizontally from the left edge of the display area, minus any left margin
        y - an integer giving the number of pixels vertically from the top of the display area, minus any top margin
        返回：
        the row closest to the location, -1 if nothing is viewable or there is no model
        另请参见：
        getRowForLocation(int, int), getRowBounds(int)

      • isEditing

        public boolean isEditing()
        Returns true if the tree is being edited. The item that is being edited can be obtained using getSelectionPath.
        返回：
        true if the user is currently editing a node
        另请参见：
        getSelectionPath()

      • stopEditing

        public boolean stopEditing()
        Ends the current editing session. (The DefaultTreeCellEditor object saves any edits that are currently in progress on a cell. Other implementations may operate differently.) Has no effect if the tree isn't being edited.
        Note:
        To make edit-saves automatic whenever the user changes their position in the tree, use setInvokesStopCellEditing(boolean).
        返回：
        true if editing was in progress and is now stopped, false if editing was not in progress

      • cancelEditing

        public void cancelEditing()
        Cancels the current editing session. Has no effect if the tree isn't being edited.

      • startEditingAtPath

        public void startEditingAtPath(TreePath path)
        Selects the node identified by the specified path and initiates editing. The edit-attempt fails if the CellEditor does not allow editing for the specified item.
        参数：
        path - the TreePath identifying a node

      • getEditingPath

        public TreePath getEditingPath()
        Returns the path to the element that is currently being edited.
        返回：
        the TreePath for the node being edited

      • setSelectionModel

        public void setSelectionModel(TreeSelectionModel selectionModel)
        Sets the tree's selection model. When a null value is specified an empty selectionModel is used, which does not allow selections.

        This is a bound property.

        参数：
        selectionModel - the TreeSelectionModel to use, or null to disable selections
        另请参见：
        TreeSelectionModel

      • getSelectionModel

        public TreeSelectionModel getSelectionModel()
        Returns the model for selections. This should always return a non-null value. If you don't want to allow anything to be selected set the selection model to null, which forces an empty selection model to be used.
        另请参见：
        setSelectionModel(javax.swing.tree.TreeSelectionModel)

      • getPathBetweenRows

        protected TreePath[] getPathBetweenRows(int index0,
                            int index1)
        Returns the paths (inclusive) between the specified rows. If the specified indices are within the viewable set of rows, or bound the viewable set of rows, then the indices are constrained by the viewable set of rows. If the specified indices are not within the viewable set of rows, or do not bound the viewable set of rows, then an empty array is returned. For example, if the row count is 10, and this method is invoked with -1, 20, then the specified indices are constrained to the viewable set of rows, and this is treated as if invoked with 0, 9. On the other hand, if this were invoked with -10, -1, then the specified indices do not bound the viewable set of rows, and an empty array is returned.

        The parameters are not order dependent. That is, getPathBetweenRows(x, y) is equivalent to getPathBetweenRows(y, x).

        An empty array is returned if the row count is 0, or the specified indices do not bound the viewable set of rows.

        参数：
        index0 - the first index in the range
        index1 - the last index in the range
        返回：
        the paths (inclusive) between the specified row indices

      • setSelectionInterval

        public void setSelectionInterval(int index0,
                        int index1)
        Selects the rows in the specified interval (inclusive). If the specified indices are within the viewable set of rows, or bound the viewable set of rows, then the specified rows are constrained by the viewable set of rows. If the specified indices are not within the viewable set of rows, or do not bound the viewable set of rows, then the selection is cleared. For example, if the row count is 10, and this method is invoked with -1, 20, then the specified indices bounds the viewable range, and this is treated as if invoked with 0, 9. On the other hand, if this were invoked with -10, -1, then the specified indices do not bound the viewable set of rows, and the selection is cleared.

        The parameters are not order dependent. That is, setSelectionInterval(x, y) is equivalent to setSelectionInterval(y, x).

        参数：
        index0 - the first index in the range to select
        index1 - the last index in the range to select

      • addSelectionInterval

        public void addSelectionInterval(int index0,
                        int index1)
        Adds the specified rows (inclusive) to the selection. If the specified indices are within the viewable set of rows, or bound the viewable set of rows, then the specified indices are constrained by the viewable set of rows. If the indices are not within the viewable set of rows, or do not bound the viewable set of rows, then the selection is unchanged. For example, if the row count is 10, and this method is invoked with -1, 20, then the specified indices bounds the viewable range, and this is treated as if invoked with 0, 9. On the other hand, if this were invoked with -10, -1, then the specified indices do not bound the viewable set of rows, and the selection is unchanged.

        The parameters are not order dependent. That is, addSelectionInterval(x, y) is equivalent to addSelectionInterval(y, x).

        参数：
        index0 - the first index in the range to add to the selection
        index1 - the last index in the range to add to the selection

      • removeSelectionInterval

        public void removeSelectionInterval(int index0,
                           int index1)
        Removes the specified rows (inclusive) from the selection. If the specified indices are within the viewable set of rows, or bound the viewable set of rows, then the specified indices are constrained by the viewable set of rows. If the specified indices are not within the viewable set of rows, or do not bound the viewable set of rows, then the selection is unchanged. For example, if the row count is 10, and this method is invoked with -1, 20, then the specified range bounds the viewable range, and this is treated as if invoked with 0, 9. On the other hand, if this were invoked with -10, -1, then the specified range does not bound the viewable set of rows, and the selection is unchanged.

        The parameters are not order dependent. That is, removeSelectionInterval(x, y) is equivalent to removeSelectionInterval(y, x).

        参数：
        index0 - the first row to remove from the selection
        index1 - the last row to remove from the selection

      • removeSelectionPath

        public void removeSelectionPath(TreePath path)
        Removes the node identified by the specified path from the current selection.
        参数：
        path - the TreePath identifying a node

      • removeSelectionPaths

        public void removeSelectionPaths(TreePath[] paths)
        Removes the nodes identified by the specified paths from the current selection.
        参数：
        paths - an array of TreePath objects that specifies the nodes to remove

      • removeSelectionRow

        public void removeSelectionRow(int row)
        Removes the row at the index row from the current selection.
        参数：
        row - the row to remove

      • removeSelectionRows

        public void removeSelectionRows(int[] rows)
        Removes the rows that are selected at each of the specified rows.
        参数：
        rows - an array of ints specifying display rows, where 0 is the first row in the display

      • clearSelection

        public void clearSelection()
        Clears the selection.

      • isSelectionEmpty

        public boolean isSelectionEmpty()
        Returns true if the selection is currently empty.
        返回：
        true if the selection is currently empty

      • addTreeExpansionListener

        public void addTreeExpansionListener(TreeExpansionListener tel)
        Adds a listener for TreeExpansion events.
        参数：
        tel - a TreeExpansionListener that will be notified when a tree node is expanded or collapsed (a "negative expansion")

      • removeTreeExpansionListener

        public void removeTreeExpansionListener(TreeExpansionListener tel)
        Removes a listener for TreeExpansion events.
        参数：
        tel - the TreeExpansionListener to remove

      • getTreeExpansionListeners

        public TreeExpansionListener[] getTreeExpansionListeners()
        Returns an array of all the TreeExpansionListeners added to this JTree with addTreeExpansionListener().
        返回：
        all of the TreeExpansionListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • addTreeWillExpandListener

        public void addTreeWillExpandListener(TreeWillExpandListener tel)
        Adds a listener for TreeWillExpand events.
        参数：
        tel - a TreeWillExpandListener that will be notified when a tree node will be expanded or collapsed (a "negative expansion")

      • removeTreeWillExpandListener

        public void removeTreeWillExpandListener(TreeWillExpandListener tel)
        Removes a listener for TreeWillExpand events.
        参数：
        tel - the TreeWillExpandListener to remove

      • getTreeWillExpandListeners

        public TreeWillExpandListener[] getTreeWillExpandListeners()
        Returns an array of all the TreeWillExpandListeners added to this JTree with addTreeWillExpandListener().
        返回：
        all of the TreeWillExpandListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireTreeExpanded

        public void fireTreeExpanded(TreePath path)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the path parameter.
        参数：
        path - the TreePath indicating the node that was expanded
        另请参见：
        EventListenerList

      • fireTreeCollapsed

        public void fireTreeCollapsed(TreePath path)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the path parameter.
        参数：
        path - the TreePath indicating the node that was collapsed
        另请参见：
        EventListenerList

      • fireTreeWillExpand

        public void fireTreeWillExpand(TreePath path)
                        throws ExpandVetoException
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the path parameter.
        参数：
        path - the TreePath indicating the node that was expanded
        抛出：
        ExpandVetoException
        另请参见：
        EventListenerList

      • fireTreeWillCollapse

        public void fireTreeWillCollapse(TreePath path)
                          throws ExpandVetoException
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the path parameter.
        参数：
        path - the TreePath indicating the node that was expanded
        抛出：
        ExpandVetoException
        另请参见：
        EventListenerList

      • addTreeSelectionListener

        public void addTreeSelectionListener(TreeSelectionListener tsl)
        Adds a listener for TreeSelection events.
        参数：
        tsl - the TreeSelectionListener that will be notified when a node is selected or deselected (a "negative selection")

      • removeTreeSelectionListener

        public void removeTreeSelectionListener(TreeSelectionListener tsl)
        Removes a TreeSelection listener.
        参数：
        tsl - the TreeSelectionListener to remove

      • getTreeSelectionListeners

        public TreeSelectionListener[] getTreeSelectionListeners()
        Returns an array of all the TreeSelectionListeners added to this JTree with addTreeSelectionListener().
        返回：
        all of the TreeSelectionListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireValueChanged

        protected void fireValueChanged(TreeSelectionEvent e)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        e - the TreeSelectionEvent to be fired; generated by the TreeSelectionModel when a node is selected or deselected
        另请参见：
        EventListenerList

      • treeDidChange

        public void treeDidChange()
        Sent when the tree has changed enough that we need to resize the bounds, but not enough that we need to remove the expanded node set (e.g nodes were expanded or collapsed, or nodes were inserted into the tree). You should never have to invoke this, the UI will invoke this as it needs to.

      • setVisibleRowCount

        public void setVisibleRowCount(int newCount)
        Sets the number of rows that are to be displayed. This will only work if the tree is contained in a JScrollPane, and will adjust the preferred size and size of that scrollpane.

        This is a bound property.

        参数：
        newCount - the number of rows to display

      • getVisibleRowCount

        public int getVisibleRowCount()
        Returns the number of rows that are displayed in the display area.
        返回：
        the number of rows displayed

      • getNextMatch

        public TreePath getNextMatch(String prefix,
                    int startingRow,
                    Position.Bias bias)
        Returns the TreePath to the next tree element that begins with a prefix. To handle the conversion of a TreePath into a String, convertValueToText is used.
        参数：
        prefix - the string to test for a match
        startingRow - the row for starting the search
        bias - the search direction, either Position.Bias.Forward or Position.Bias.Backward.
        返回：
        the TreePath of the next tree element that starts with the prefix; otherwise null
        抛出：
        IllegalArgumentException - if prefix is null or startingRow is out of bounds
        从以下版本开始：
        1.4

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Returns the preferred display size of a JTree. The height is determined from getVisibleRowCount and the width is the current preferred width.
        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        返回：
        a Dimension object containing the preferred size
        另请参见：
        JComponent.getPreferredSize()

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Returns the amount to increment when scrolling. The amount is the height of the first displayed row that isn't completely in view or, if it is totally displayed, the height of the next row in the scrolling direction.
        指定者：
        getScrollableUnitIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        the "unit" increment for scrolling in the specified direction
        另请参见：
        JScrollBar.setUnitIncrement(int)

      • getScrollableBlockIncrement

        public int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Returns the amount for a block increment, which is the height or width of visibleRect, based on orientation.
        指定者：
        getScrollableBlockIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        direction - less than zero to scroll up/left, greater than zero for down/right.
        返回：
        the "block" increment for scrolling in the specified direction
        另请参见：
        JScrollBar.setBlockIncrement(int)

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns false to indicate that the width of the viewport does not determine the width of the table, unless the preferred width of the tree is smaller than the viewports width. In other words: ensure that the tree is never smaller than its viewport.
        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        返回：
        whether the tree should track the width of the viewport
        另请参见：
        Scrollable.getScrollableTracksViewportWidth()

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns false to indicate that the height of the viewport does not determine the height of the table, unless the preferred height of the tree is smaller than the viewports height. In other words: ensure that the tree is never smaller than its viewport.
        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        返回：
        whether the tree should track the height of the viewport
        另请参见：
        Scrollable.getScrollableTracksViewportHeight()

      • setExpandedState

        protected void setExpandedState(TreePath path,
                    boolean state)
        Sets the expanded state of this JTree. If state is true, all parents of path and path are marked as expanded. If state is false, all parents of path are marked EXPANDED, but path itself is marked collapsed.

        This will fail if a TreeWillExpandListener vetos it.

      • getDescendantToggledPaths

        protected Enumeration<TreePath> getDescendantToggledPaths(TreePath parent)
        Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.

      • removeDescendantToggledPaths

        protected void removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
        Removes any descendants of the TreePaths in toRemove that have been expanded.
        参数：
        toRemove - an enumeration of the paths to remove; a value of null is ignored
        抛出：
        ClassCastException - if toRemove contains an element that is not a TreePath; null values are ignored

      • clearToggledPaths

        protected void clearToggledPaths()
        Clears the cache of toggled tree paths. This does NOT send out any TreeExpansionListener events.

      • createTreeModelListener

        protected TreeModelListener createTreeModelListener()
        Creates and returns an instance of TreeModelHandler. The returned object is responsible for updating the expanded state when the TreeModel changes.

        For more information on what expanded state means, see the JTree description above.

      • removeDescendantSelectedPaths

        protected boolean removeDescendantSelectedPaths(TreePath path,
                                    boolean includePath)
        Removes any paths in the selection that are descendants of path. If includePath is true and path is selected, it will be removed from the selection.
        返回：
        true if a descendant was selected
        从以下版本开始：
        1.3

      • paramString

        protected String paramString()
        Returns a string representation of this JTree. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JTree.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTree. For JTrees, the AccessibleContext takes the form of an AccessibleJTree. A new AccessibleJTree instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJTree that serves as the AccessibleContext of this JTree
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTree.AccessibleJTree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.AccessibleJTree

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JTree.AccessibleJTree
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, TreeExpansionListener, TreeModelListener, TreeSelectionListener
    封闭类：
    JTree

    protected class JTree.AccessibleJTree
extends JComponent.AccessibleJComponent
implements AccessibleSelection, TreeSelectionListener, TreeModelListener, TreeExpansionListener
    This class implements accessibility support for the JTree class. It provides an implementation of the Java Accessibility API appropriate to tree user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTree.AccessibleJTree.AccessibleJTreeNode
      This class implements accessibility support for the JTree child.

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTree.AccessibleJTree()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified selected item in the object to the object's selection.
      void clearAccessibleSelection()
      Clears the selection in the object, so that nothing in the object is selected.
      void fireVisibleDataPropertyChange()
      Fire a visible data property change notification.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Return the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of top-level children nodes of this JTree.
      int getAccessibleIndexInParent()
      Get the index of this object in its accessible parent.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected item in the object.
      int getAccessibleSelectionCount()
      Returns the number of items currently selected.
      boolean isAccessibleChildSelected(int i)
      Returns true if the current child of this object is selected.
      void removeAccessibleSelection(int i)
      Removes the specified selected item in the object from the object's selection.
      void selectAllAccessibleSelection()
      Causes every selected item in the object to be selected if the object supports multiple selections.
      void treeCollapsed(TreeExpansionEvent e)
      Tree Collapsed notification.
      void treeExpanded(TreeExpansionEvent e)
      Tree Model Expansion notification.
      void treeNodesChanged(TreeModelEvent e)
      Tree Model Node change notification.
      void treeNodesInserted(TreeModelEvent e)
      Tree Model Node change notification.
      void treeNodesRemoved(TreeModelEvent e)
      Tree Model Node change notification.
      void treeStructureChanged(TreeModelEvent e)
      Tree Model structure change change notification.
      void valueChanged(TreeSelectionEvent e)
      Tree Selection Listener value change method.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTree.AccessibleJTree

        public JTree.AccessibleJTree()

    • 方法详细信息

      • valueChanged

        public void valueChanged(TreeSelectionEvent e)
        Tree Selection Listener value change method. Used to fire the property change
        指定者：
        valueChanged in interface TreeSelectionListener
        参数：
        e - ListSelectionEvent

      • fireVisibleDataPropertyChange

        public void fireVisibleDataPropertyChange()
        Fire a visible data property change notification. A 'visible' data property is one that represents something about the way the component appears on the display, where that appearance isn't bound to any other property. It notifies screen readers that the visual appearance of the component has changed, so they can notify the user.

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)
        Tree Model Node change notification.
        指定者：
        treeNodesChanged in interface TreeModelListener
        参数：
        e - a Tree Model event

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)
        Tree Model Node change notification.
        指定者：
        treeNodesInserted in interface TreeModelListener
        参数：
        e - a Tree node insertion event

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)
        Tree Model Node change notification.
        指定者：
        treeNodesRemoved in interface TreeModelListener
        参数：
        e - a Tree node(s) removal event

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)
        Tree Model structure change change notification.
        指定者：
        treeStructureChanged in interface TreeModelListener
        参数：
        e - a Tree Model event

      • treeCollapsed

        public void treeCollapsed(TreeExpansionEvent e)
        Tree Collapsed notification.
        指定者：
        treeCollapsed in interface TreeExpansionListener
        参数：
        e - a TreeExpansionEvent

      • treeExpanded

        public void treeExpanded(TreeExpansionEvent e)
        Tree Model Expansion notification.
        指定者：
        treeExpanded in interface TreeExpansionListener
        参数：
        e - a Tree node insertion event

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child, if one exists, contained at the local coordinate Point. Otherwise returns null.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - point in local coordinates of this Accessible
        返回：
        the Accessible, if it exists, at the specified location; else null

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of top-level children nodes of this JTree. Each of these nodes may in turn have children nodes.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children nodes in the tree.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Return the nth Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Get the index of this object in its accessible parent.
        重载：
        getAccessibleIndexInParent in class Component.AccessibleAWTComponent
        返回：
        the index of this object in its parent. Since a JTree top-level object does not have an accessible parent.
        另请参见：
        Component.AccessibleAWTComponent.getAccessibleParent()

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleSelection interface on behalf of itself.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleSelection

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns the number of items currently selected. If no items are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected.

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns an Accessible representing the specified selected item in the object. If there isn't a selection, or there are fewer items selected than the integer passed in, the return value will be null.
        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected items
        返回：
        an Accessible containing the selected item
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Returns true if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Adds the specified selected item in the object to the object's selection. If the object supports multiple selections, the specified item is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified item is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the specified selected item in the object from the object's selection. If the specified item isn't currently selected, this method has no effect.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that nothing in the object is selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Causes every selected item in the object to be selected if the object supports multiple selections.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olst


JTree.AccessibleJTree.AccessibleJTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.AccessibleJTree.AccessibleJTreeNode

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
  • 所有已实现的接口：
    Accessible, AccessibleAction, AccessibleComponent, AccessibleSelection
    封闭类：
    JTree.AccessibleJTree

    protected class JTree.AccessibleJTree.AccessibleJTreeNode
extends AccessibleContext
implements Accessible, AccessibleComponent, AccessibleSelection, AccessibleAction
    This class implements accessibility support for the JTree child. It provides an implementation of the Java Accessibility API appropriate to tree nodes.

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
      Constructs an AccessibleJTreeNode

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addAccessibleSelection(int i)
      Adds the specified selected item in the object to the object's selection.
      void addFocusListener(FocusListener l)
      Adds the specified focus listener to receive focus events from this component.
      void addPropertyChangeListener(PropertyChangeListener l)
      Add a PropertyChangeListener to the listener list.
      void clearAccessibleSelection()
      Clears the selection in the object, so that nothing in the object is selected.
      boolean contains(Point p)
      Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
      boolean doAccessibleAction(int i)
      Perform the specified Action on the tree node.
      AccessibleAction getAccessibleAction()
      Get the AccessibleAction associated with this object.
      int getAccessibleActionCount()
      Returns the number of accessible actions available in this tree node.
      String getAccessibleActionDescription(int i)
      Return a description of the specified action of the tree node.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Return the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleComponent getAccessibleComponent()
      Get the AccessibleComponent associated with this object.
      AccessibleContext getAccessibleContext()
      Get the AccessibleContext associated with this tree node.
      String getAccessibleDescription()
      Get the accessible description of this object.
      int getAccessibleIndexInParent()
      Get the index of this object in its accessible parent.
      String getAccessibleName()
      Get the accessible name of this object.
      Accessible getAccessibleParent()
      Get the Accessible parent of this object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.
      AccessibleSelection getAccessibleSelection()
      Get the AccessibleSelection associated with this object if one exists.
      Accessible getAccessibleSelection(int i)
      Returns an Accessible representing the specified selected item in the object.
      int getAccessibleSelectionCount()
      Returns the number of items currently selected.
      AccessibleStateSet getAccessibleStateSet()
      Get the state set of this object.
      AccessibleText getAccessibleText()
      Get the AccessibleText associated with this object if one exists.
      AccessibleValue getAccessibleValue()
      Get the AccessibleValue associated with this object if one exists.
      Color getBackground()
      Get the background color of this object.
      Rectangle getBounds()
      Gets the bounds of this object in the form of a Rectangle object.
      Cursor getCursor()
      Gets the Cursor of this object.
      Font getFont()
      Gets the Font of this object.
      FontMetrics getFontMetrics(Font f)
      Gets the FontMetrics of this object.
      Color getForeground()
      Get the foreground color of this object.
      Locale getLocale()
      Gets the locale of the component.
      Point getLocation()
      Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
      protected Point | getLocationInJTree()
      Point getLocationOnScreen()
      Returns the location of the object on the screen.
      Dimension getSize()
      Returns the size of this object in the form of a Dimension object.
      boolean isAccessibleChildSelected(int i)
      Returns true if the current child of this object is selected.
      boolean isEnabled()
      Determines if the object is enabled.
      boolean isFocusTraversable()
      Returns whether this object can accept focus or not.
      boolean isShowing()
      Determines if the object is showing.
      boolean isVisible()
      Determines if the object is visible.
      void removeAccessibleSelection(int i)
      Removes the specified selected item in the object from the object's selection.
      void removeFocusListener(FocusListener l)
      Removes the specified focus listener so it no longer receives focus events from this component.
      void removePropertyChangeListener(PropertyChangeListener l)
      Remove a PropertyChangeListener from the listener list.
      void requestFocus()
      Requests focus for this object.
      void selectAllAccessibleSelection()
      Causes every selected item in the object to be selected if the object supports multiple selections.
      void setAccessibleDescription(String s)
      Set the accessible description of this object.
      void setAccessibleName(String s)
      Set the localized accessible name of this object.
      void setBackground(Color c)
      Set the background color of this object.
      void setBounds(Rectangle r)
      Sets the bounds of this object in the form of a Rectangle object.
      void setCursor(Cursor c)
      Sets the Cursor of this object.
      void setEnabled(boolean b)
      Sets the enabled state of the object.
      void setFont(Font f)
      Sets the Font of this object.
      void setForeground(Color c)
      Sets the foreground color of this object.
      void setLocation(Point p)
      Sets the location of the object relative to the parent.
      void setSize(Dimension d)
      Resizes this object so that it has width and height.
      void setVisible(boolean b)
      Sets the visible state of the object.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTree.AccessibleJTree.AccessibleJTreeNode

        public JTree.AccessibleJTree.AccessibleJTreeNode(JTree t,
                                         TreePath p,
                                         Accessible ap)
        Constructs an AccessibleJTreeNode
        从以下版本开始：
        1.4

    • 方法详细信息

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Get the AccessibleContext associated with this tree node. In the implementation of the Java Accessibility API for this class, return this object, which is its own AccessibleContext.
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        this object

      • getAccessibleName

        public String getAccessibleName()
        Get the accessible name of this object.
        重载：
        getAccessibleName in class AccessibleContext
        返回：
        the localized name of the object; null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • setAccessibleName

        public void setAccessibleName(String s)
        Set the localized accessible name of this object.
        重载：
        setAccessibleName in class AccessibleContext
        参数：
        s - the new localized name of the object.
        另请参见：
        AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Get the accessible description of this object.
        重载：
        getAccessibleDescription in class AccessibleContext
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        public void setAccessibleDescription(String s)
        Set the accessible description of this object.
        重载：
        setAccessibleDescription in class AccessibleContext
        参数：
        s - the new localized description of the object
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Get the state set of this object.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleParent

        public Accessible getAccessibleParent()
        Get the Accessible parent of this object.
        重载：
        getAccessibleParent in class AccessibleContext
        返回：
        the Accessible parent of this object; null if this object does not have an Accessible parent

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Get the index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the index of this object in its parent; -1 if this object does not have an accessible parent.
        另请参见：
        getAccessibleParent()

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Return the specified Accessible child of the object.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
        Gets the locale of the component. If the component does not have a locale, then the locale of its parent is returned.
        指定者：
        getLocale in class AccessibleContext
        返回：
        This component's locale. If this component does not have a locale, the locale of its parent is returned.
        抛出：
        IllegalComponentStateException - If the Component does not have its own locale and has not yet been added to a containment hierarchy such that the locale can be determined from the containing parent.
        另请参见：
        Component.setLocale(java.util.Locale)

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener l)
        Add a PropertyChangeListener to the listener list. The listener is registered for all properties.
        重载：
        addPropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be added
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener l)
        Remove a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        重载：
        removePropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be removed

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Get the AccessibleAction associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleAction interface on behalf of itself.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleAction

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent()
        Get the AccessibleComponent associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleComponent interface on behalf of itself.
        重载：
        getAccessibleComponent in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleComponent

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Get the AccessibleSelection associated with this object if one exists. Otherwise return null.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        the AccessibleSelection, or null
        另请参见：
        AccessibleSelection

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Get the AccessibleText associated with this object if one exists. Otherwise return null.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        the AccessibleText, or null
        另请参见：
        AccessibleText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Get the AccessibleValue associated with this object if one exists. Otherwise return null.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        the AccessibleValue, or null
        另请参见：
        AccessibleValue

      • getBackground

        public Color getBackground()
        Get the background color of this object.
        指定者：
        getBackground in interface AccessibleComponent
        返回：
        the background color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground(Color c)
        Set the background color of this object.
        指定者：
        setBackground in interface AccessibleComponent
        参数：
        c - the new Color for the background
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • getForeground

        public Color getForeground()
        Get the foreground color of this object.
        指定者：
        getForeground in interface AccessibleComponent
        返回：
        the foreground color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground(Color c)
        从接口复制的描述： AccessibleComponent
        Sets the foreground color of this object.
        指定者：
        setForeground in interface AccessibleComponent
        参数：
        c - the new Color for the foreground
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor()
        从接口复制的描述： AccessibleComponent
        Gets the Cursor of this object.
        指定者：
        getCursor in interface AccessibleComponent
        返回：
        the Cursor, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor(Cursor c)
        从接口复制的描述： AccessibleComponent
        Sets the Cursor of this object.
        指定者：
        setCursor in interface AccessibleComponent
        参数：
        c - the new Cursor for the object
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont()
        从接口复制的描述： AccessibleComponent
        Gets the Font of this object.
        指定者：
        getFont in interface AccessibleComponent
        返回：
        the Font,if supported, for the object; otherwise, null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont(Font f)
        从接口复制的描述： AccessibleComponent
        Sets the Font of this object.
        指定者：
        setFont in interface AccessibleComponent
        参数：
        f - the new Font for the object
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        从接口复制的描述： AccessibleComponent
        Gets the FontMetrics of this object.
        指定者：
        getFontMetrics in interface AccessibleComponent
        参数：
        f - the Font
        返回：
        the FontMetrics, if supported, the object; otherwise, null
        另请参见：
        AccessibleComponent.getFont()

      • isEnabled

        public boolean isEnabled()
        从接口复制的描述： AccessibleComponent
        Determines if the object is enabled. Objects that are enabled will also have the AccessibleState.ENABLED state set in their AccessibleStateSets.
        指定者：
        isEnabled in interface AccessibleComponent
        返回：
        true if object is enabled; otherwise, false
        另请参见：
        AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

      • setEnabled

        public void setEnabled(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the enabled state of the object.
        指定者：
        setEnabled in interface AccessibleComponent
        参数：
        b - if true, enables this object; otherwise, disables it
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible()
        从接口复制的描述： AccessibleComponent
        Determines if the object is visible. Note: this means that the object intends to be visible; however, it may not be showing on the screen because one of the objects that this object is contained by is currently not visible. To determine if an object is showing on the screen, use isShowing().

        Objects that are visible will also have the AccessibleState.VISIBLE state set in their AccessibleStateSets.

        指定者：
        isVisible in interface AccessibleComponent
        返回：
        true if object is visible; otherwise, false
        另请参见：
        AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

      • setVisible

        public void setVisible(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the visible state of the object.
        指定者：
        setVisible in interface AccessibleComponent
        参数：
        b - if true, shows this object; otherwise, hides it
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing()
        从接口复制的描述： AccessibleComponent
        Determines if the object is showing. This is determined by checking the visibility of the object and its ancestors. Note: this will return true even if the object is obscured by another (for example, it is underneath a menu that was pulled down).
        指定者：
        isShowing in interface AccessibleComponent
        返回：
        true if object is showing; otherwise, false

      • contains

        public boolean contains(Point p)
        从接口复制的描述： AccessibleComponent
        Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
        指定者：
        contains in interface AccessibleComponent
        参数：
        p - the Point relative to the coordinate system of the object
        返回：
        true if object contains Point; otherwise false
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen()
        从接口复制的描述： AccessibleComponent
        Returns the location of the object on the screen.
        指定者：
        getLocationOnScreen in interface AccessibleComponent
        返回：
        the location of the object on screen; null if this object is not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

      • getLocationInJTree

        protected Point getLocationInJTree()

      • getLocation

        public Point getLocation()
        从接口复制的描述： AccessibleComponent
        Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
        指定者：
        getLocation in interface AccessibleComponent
        返回：
        An instance of Point representing the top-left corner of the object's bounds in the coordinate space of the screen; null if this object or its parent are not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation(Point p)
        从接口复制的描述： AccessibleComponent
        Sets the location of the object relative to the parent.
        指定者：
        setLocation in interface AccessibleComponent
        参数：
        p - the new position for the top-left corner
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds()
        从接口复制的描述： AccessibleComponent
        Gets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        getBounds in interface AccessibleComponent
        返回：
        A rectangle indicating this component's bounds; null if this object is not on the screen.
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds(Rectangle r)
        从接口复制的描述： AccessibleComponent
        Sets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        setBounds in interface AccessibleComponent
        参数：
        r - rectangle indicating this component's bounds
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize()
        从接口复制的描述： AccessibleComponent
        Returns the size of this object in the form of a Dimension object. The height field of the Dimension object contains this object's height, and the width field of the Dimension object contains this object's width.
        指定者：
        getSize in interface AccessibleComponent
        返回：
        A Dimension object that indicates the size of this component; null if this object is not on the screen
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize(Dimension d)
        从接口复制的描述： AccessibleComponent
        Resizes this object so that it has width and height.
        指定者：
        setSize in interface AccessibleComponent
        参数：
        d - The dimension specifying the new size of the object.
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child, if one exists, contained at the local coordinate Point. Otherwise returns null.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        参数：
        p - point in local coordinates of this Accessible
        返回：
        the Accessible, if it exists, at the specified location; else null

      • isFocusTraversable

        public boolean isFocusTraversable()
        从接口复制的描述： AccessibleComponent
        Returns whether this object can accept focus or not. Objects that can accept focus will also have the AccessibleState.FOCUSABLE state set in their AccessibleStateSets.
        指定者：
        isFocusTraversable in interface AccessibleComponent
        返回：
        true if object can accept focus; otherwise false
        另请参见：
        AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

      • requestFocus

        public void requestFocus()
        从接口复制的描述： AccessibleComponent
        Requests focus for this object. If this object cannot accept focus, nothing will happen. Otherwise, the object will attempt to take focus.
        指定者：
        requestFocus in interface AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Adds the specified focus listener to receive focus events from this component.
        指定者：
        addFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Removes the specified focus listener so it no longer receives focus events from this component.
        指定者：
        removeFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

      • getAccessibleSelectionCount

        public int getAccessibleSelectionCount()
        Returns the number of items currently selected. If no items are selected, the return value will be 0.
        指定者：
        getAccessibleSelectionCount in interface AccessibleSelection
        返回：
        the number of items currently selected.

      • getAccessibleSelection

        public Accessible getAccessibleSelection(int i)
        Returns an Accessible representing the specified selected item in the object. If there isn't a selection, or there are fewer items selected than the integer passed in, the return value will be null.
        指定者：
        getAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selected items
        返回：
        an Accessible containing the selected item
        另请参见：
        AccessibleSelection.getAccessibleSelectionCount()

      • isAccessibleChildSelected

        public boolean isAccessibleChildSelected(int i)
        Returns true if the current child of this object is selected.
        指定者：
        isAccessibleChildSelected in interface AccessibleSelection
        参数：
        i - the zero-based index of the child in this Accessible object.
        返回：
        true if the current child of this object is selected; else false.
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • addAccessibleSelection

        public void addAccessibleSelection(int i)
        Adds the specified selected item in the object to the object's selection. If the object supports multiple selections, the specified item is added to any existing selection, otherwise it replaces any existing selection in the object. If the specified item is already selected, this method has no effect.
        指定者：
        addAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • removeAccessibleSelection

        public void removeAccessibleSelection(int i)
        Removes the specified selected item in the object from the object's selection. If the specified item isn't currently selected, this method has no effect.
        指定者：
        removeAccessibleSelection in interface AccessibleSelection
        参数：
        i - the zero-based index of selectable items
        另请参见：
        AccessibleContext.getAccessibleChild(int)

      • clearAccessibleSelection

        public void clearAccessibleSelection()
        Clears the selection in the object, so that nothing in the object is selected.
        指定者：
        clearAccessibleSelection in interface AccessibleSelection

      • selectAllAccessibleSelection

        public void selectAllAccessibleSelection()
        Causes every selected item in the object to be selected if the object supports multiple selections.
        指定者：
        selectAllAccessibleSelection in interface AccessibleSelection

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of accessible actions available in this tree node. If this node is not a leaf, there is at least one action (toggle expand), in addition to any available on the object behind the TreeCellRenderer.
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        返回：
        the number of Actions in this object

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Return a description of the specified action of the tree node. If this node is not a leaf, there is at least one action description (toggle expand), in addition to any available on the object behind the TreeCellRenderer.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        参数：
        i - zero-based index of the actions
        返回：
        a description of the action
        另请参见：
        AccessibleAction.getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Perform the specified Action on the tree node. If this node is not a leaf, there is at least one action which can be done (toggle expand), in addition to any available on the object behind the TreeCellRenderer.
        指定者：
        doAccessibleAction in interface AccessibleAction
        参数：
        i - zero-based index of actions
        返回：
        true if the the action was performed; else false.
        另请参见：
        AccessibleAction.getAccessibleActionCount()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTree.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 JTree.DropLocation

  • java.lang.Object
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JTree.DropLocation
  • 封闭类：
    JTree

    public static final class JTree.DropLocation
extends TransferHandler.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
    从以下版本开始：
    1.6
    另请参见：
    JTree.getDropLocation()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getChildIndex()
      Returns the index where the dropped data should be inserted with respect to the path returned by getPath().
      TreePath getPath()
      Returns the path where dropped data should be placed in the tree.
      String toString()
      Returns a string representation of this drop location.

      • 方法 - 继承于类 javax.swing.TransferHandler.DropLocation

        getDropPoint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getChildIndex

        public int getChildIndex()
        Returns the index where the dropped data should be inserted with respect to the path returned by getPath().

        For drop modes DropMode.USE_SELECTION and DropMode.ON, this index is unimportant (and it will always be -1) as the only interesting data is the path over which the drop operation occurred.

        For drop mode DropMode.INSERT, this index indicates the index at which the data should be inserted into the parent path represented by getPath(). -1 indicates that the drop occurred over the parent itself, and in most cases should be treated as inserting into either the beginning or the end of the parent's list of children.

        For DropMode.ON_OR_INSERT, this value will be an insert index, as described above, or -1 if the drop occurred over the path itself.

        返回：
        the child index
        另请参见：
        getPath()

      • getPath

        public TreePath getPath()
        Returns the path where dropped data should be placed in the tree.

        Interpretation of this value depends on the drop mode set on the component. If the drop mode is DropMode.USE_SELECTION or DropMode.ON, the return value is the path in the tree over which the data has been (or will be) dropped. null indicates that the drop is over empty space, not associated with a particular path.

        If the drop mode is DropMode.INSERT, the return value refers to the path that should become the parent of the new data, in which case getChildIndex() indicates where the new item should be inserted into this parent path. A null path indicates that no parent path has been determined, which can happen for multiple reasons:

        • The tree has no model
        • There is no root in the tree
        • The root is collapsed
        • The root is a leaf node
        It is up to the developer to decide if and how they wish to handle the null case.

        If the drop mode is DropMode.ON_OR_INSERT, getChildIndex can be used to determine whether the drop is on top of the path itself (-1) or the index at which it should be inserted into the path (values other than -1).

        返回：
        the drop path
        另请参见：
        getChildIndex()

      • toString

        public String toString()
        Returns a string representation of this drop location. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class TransferHandler.DropLocation
        返回：
        a string representation of this drop location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/RaSRB_IB_TAA_TTECSS..<"ee/bex""h//AjA


JTree.DynamicUtilTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.DynamicUtilTreeNode

  • java.lang.Object
    • javax.swing.tree.DefaultMutableTreeNode
      • javax.swing.JTree.DynamicUtilTreeNode
  • 所有已实现的接口：
    Serializable, Cloneable, MutableTreeNode, TreeNode
    封闭类：
    JTree

    public static class JTree.DynamicUtilTreeNode
extends DefaultMutableTreeNode
    DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary. It is dynamic in that it will only create the children as necessary.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Object childValue
      Value to create children with.
      protected boolean hasChildren
      Does the this JTree have children? This property is currently not implemented.
      protected boolean loadedChildren
      Have the children been loaded yet?

      • Fields inherited from class javax.swing.tree.DefaultMutableTreeNode

        allowsChildren, children, EMPTY_ENUMERATION, parent, userObject

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTree.DynamicUtilTreeNode(Object value, Object children)
      Creates a node with the specified object as its value and with the specified children.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Enumeration children()
      Subclassed to load the children, if necessary.
      static void createChildren(DefaultMutableTreeNode parent, Object children)
      Adds to parent all the children in children.
      TreeNode getChildAt(int index)
      Subclassed to load the children, if necessary.
      int getChildCount()
      Returns the number of child nodes.
      boolean isLeaf()
      Returns true if this node allows children.
      protected void loadChildren()
      Loads the children based on childValue.

      • 方法 - 继承于类 javax.swing.tree.DefaultMutableTreeNode

        add, breadthFirstEnumeration, clone, depthFirstEnumeration, getAllowsChildren, getChildAfter, getChildBefore, getDepth, getFirstChild, getFirstLeaf, getIndex, getLastChild, getLastLeaf, getLeafCount, getLevel, getNextLeaf, getNextNode, getNextSibling, getParent, getPath, getPathToRoot, getPreviousLeaf, getPreviousNode, getPreviousSibling, getRoot, getSharedAncestor, getSiblingCount, getUserObject, getUserObjectPath, insert, isNodeAncestor, isNodeChild, isNodeDescendant, isNodeRelated, isNodeSibling, isRoot, pathFromAncestorEnumeration, postorderEnumeration, preorderEnumeration, remove, remove, removeAllChildren, removeFromParent, setAllowsChildren, setParent, setUserObject, toString

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • hasChildren

        protected boolean hasChildren
        Does the this JTree have children? This property is currently not implemented.

      • childValue

        protected Object childValue
        Value to create children with.

      • loadedChildren

        protected boolean loadedChildren
        Have the children been loaded yet?

    • 构造方法详细信息

      • JTree.DynamicUtilTreeNode

        public JTree.DynamicUtilTreeNode(Object value,
                         Object children)
        Creates a node with the specified object as its value and with the specified children. For the node to allow children, the children-object must be an array of objects, a Vector, or a Hashtable -- even if empty. Otherwise, the node is not allowed to have children.
        参数：
        value - the Object that is the value for the new node
        children - an array of Objects, a Vector, or a Hashtable used to create the child nodes; if any other object is specified, or if the value is null, then the node is not allowed to have children

    • 方法详细信息

      • createChildren

        public static void createChildren(DefaultMutableTreeNode parent,
                  Object children)
        Adds to parent all the children in children. If children is an array or vector all of its elements are added is children, otherwise if children is a hashtable all the key/value pairs are added in the order Enumeration returns them.

      • isLeaf

        public boolean isLeaf()
        Returns true if this node allows children. Whether the node allows children depends on how it was created.
        指定者：
        isLeaf in interface TreeNode
        重载：
        isLeaf in class DefaultMutableTreeNode
        返回：
        true if this node allows children, false otherwise
        另请参见：
        JTree.DynamicUtilTreeNode(java.lang.Object, java.lang.Object)

      • getChildCount

        public int getChildCount()
        Returns the number of child nodes.
        指定者：
        getChildCount in interface TreeNode
        重载：
        getChildCount in class DefaultMutableTreeNode
        返回：
        the number of child nodes

      • loadChildren

        protected void loadChildren()
        Loads the children based on childValue. If childValue is a Vector or array each element is added as a child, if childValue is a Hashtable each key/value pair is added in the order that Enumeration returns the keys.

      • getChildAt

        public TreeNode getChildAt(int index)
        Subclassed to load the children, if necessary.
        指定者：
        getChildAt in interface TreeNode
        重载：
        getChildAt in class DefaultMutableTreeNode
        参数：
        index - an index into this node's child array
        返回：
        the TreeNode in this node's child array at the specified index

      • children

        public Enumeration children()
        Subclassed to load the children, if necessary.
        指定者：
        children in interface TreeNode
        重载：
        children in class DefaultMutableTreeNode
        返回：
        an Enumeration of this node's children
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tll/sgi/ vwa==s篸on


JTree.EmptySelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.EmptySelectionModel

  • java.lang.Object
    • javax.swing.tree.DefaultTreeSelectionModel
      • javax.swing.JTree.EmptySelectionModel
  • 所有已实现的接口：
    Serializable, Cloneable, TreeSelectionModel
    封闭类：
    JTree

    protected static class JTree.EmptySelectionModel
extends DefaultTreeSelectionModel
    EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static JTree.EmptySelectionModel sharedInstance
      The single instance of EmptySelectionModel.

      • Fields inherited from class javax.swing.tree.DefaultTreeSelectionModel

        changeSupport, leadIndex, leadPath, leadRow, listenerList, listSelectionModel, rowMapper, selection, SELECTION_MODE_PROPERTY, selectionMode

      • 字段 - 继承于接口 javax.swing.tree.TreeSelectionModel

        CONTIGUOUS_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION, SINGLE_TREE_SELECTION

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTree.EmptySelectionModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void addSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void addTreeSelectionListener(TreeSelectionListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void removePropertyChangeListener(PropertyChangeListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void removeSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void removeTreeSelectionListener(TreeSelectionListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void setRowMapper(RowMapper mapper)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void setSelectionMode(int mode)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void setSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      static JTree.EmptySelectionModel sharedInstance()
      Returns the single instance of EmptySelectionModel.

      • 方法 - 继承于类 javax.swing.tree.DefaultTreeSelectionModel

        addSelectionPath, arePathsContiguous, canPathsBeAdded, canPathsBeRemoved, clearSelection, clone, fireValueChanged, getLeadSelectionPath, getLeadSelectionRow, getListeners, getMaxSelectionRow, getMinSelectionRow, getPropertyChangeListeners, getRowMapper, getSelectionCount, getSelectionMode, getSelectionPath, getSelectionPaths, getSelectionRows, getTreeSelectionListeners, insureRowContinuity, insureUniqueness, isPathSelected, isRowSelected, isSelectionEmpty, notifyPathChange, removeSelectionPath, resetRowSelection, setSelectionPath, toString, updateLeadIndex

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • sharedInstance

        protected static final JTree.EmptySelectionModel sharedInstance
        The single instance of EmptySelectionModel.

    • 构造方法详细信息

      • JTree.EmptySelectionModel

        protected JTree.EmptySelectionModel()

    • 方法详细信息

      • sharedInstance

        public static JTree.EmptySelectionModel sharedInstance()
        Returns the single instance of EmptySelectionModel.
        返回：
        single instance of EmptySelectionModel

      • setSelectionPaths

        public void setSelectionPaths(TreePath[] paths)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        setSelectionPaths in interface TreeSelectionModel
        重载：
        setSelectionPaths in class DefaultTreeSelectionModel
        参数：
        paths - the paths to select; this is ignored

      • addSelectionPaths

        public void addSelectionPaths(TreePath[] paths)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        addSelectionPaths in interface TreeSelectionModel
        重载：
        addSelectionPaths in class DefaultTreeSelectionModel
        参数：
        paths - the paths to add to the selection; this is ignored

      • removeSelectionPaths

        public void removeSelectionPaths(TreePath[] paths)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        removeSelectionPaths in interface TreeSelectionModel
        重载：
        removeSelectionPaths in class DefaultTreeSelectionModel
        参数：
        paths - the paths to remove; this is ignored

      • setSelectionMode

        public void setSelectionMode(int mode)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        setSelectionMode in interface TreeSelectionModel
        重载：
        setSelectionMode in class DefaultTreeSelectionModel
        参数：
        mode - the selection mode; this is ignored
        从以下版本开始：
        1.7

      • setRowMapper

        public void setRowMapper(RowMapper mapper)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        setRowMapper in interface TreeSelectionModel
        重载：
        setRowMapper in class DefaultTreeSelectionModel
        参数：
        mapper - the RowMapper instance; this is ignored
        从以下版本开始：
        1.7

      • addTreeSelectionListener

        public void addTreeSelectionListener(TreeSelectionListener listener)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        addTreeSelectionListener in interface TreeSelectionModel
        重载：
        addTreeSelectionListener in class DefaultTreeSelectionModel
        参数：
        listener - the listener to add; this is ignored
        从以下版本开始：
        1.7

      • removeTreeSelectionListener

        public void removeTreeSelectionListener(TreeSelectionListener listener)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        removeTreeSelectionListener in interface TreeSelectionModel
        重载：
        removeTreeSelectionListener in class DefaultTreeSelectionModel
        参数：
        listener - the listener to remove; this is ignored
        从以下版本开始：
        1.7

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        addPropertyChangeListener in interface TreeSelectionModel
        重载：
        addPropertyChangeListener in class DefaultTreeSelectionModel
        参数：
        listener - the listener to add; this is ignored
        从以下版本开始：
        1.7

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        This is overriden to do nothing; EmptySelectionModel does not allow a selection.
        指定者：
        removePropertyChangeListener in interface TreeSelectionModel
        重载：
        removePropertyChangeListener in class DefaultTreeSelectionModel
        参数：
        listener - the listener to remove; this is ignored
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTree.TreeModelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.TreeModelHandler

  • java.lang.Object
    • javax.swing.JTree.TreeModelHandler
  • 所有已实现的接口：
    EventListener, TreeModelListener
    封闭类：
    JTree

    protected class JTree.TreeModelHandler
extends Object
implements TreeModelListener
    Listens to the model and updates the expandedState accordingly when nodes are removed, or changed.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTree.TreeModelHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTree.TreeModelHandler

        protected JTree.TreeModelHandler()

    • 方法详细信息

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        To indicate the root has changed, childIndices and children will be null.

        Use e.getPath() to get the parent of the changed node(s). e.getChildIndices() returns the index(es) of the changed node(s).

        指定者：
        treeNodesChanged in interface TreeModelListener

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after nodes have been inserted into the tree.

        Use e.getPath() to get the parent of the new node(s). e.getChildIndices() returns the index(es) of the new node(s) in ascending order.

        指定者：
        treeNodesInserted in interface TreeModelListener

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        Use e.getPath() to get the path to the node. e.getChildIndices() returns null.

        指定者：
        treeStructureChanged in interface TreeModelListener

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        Use e.getPath() to get the former parent of the deleted node(s). e.getChildIndices() returns, in ascending order, the index(es) the node(s) had before being deleted.

        指定者：
        treeNodesRemoved in interface TreeModelListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esn aesges tts oppip it fteplsfooSs鎜ra


JTree.TreeSelectionRedirector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JTree.TreeSelectionRedirector

  • java.lang.Object
    • javax.swing.JTree.TreeSelectionRedirector
  • 所有已实现的接口：
    Serializable, EventListener, TreeSelectionListener
    封闭类：
    JTree

    protected class JTree.TreeSelectionRedirector
extends Object
implements Serializable, TreeSelectionListener
    Handles creating a new TreeSelectionEvent with the JTree as the source and passing it off to all the listeners.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTree.TreeSelectionRedirector()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(TreeSelectionEvent e)
      Invoked by the TreeSelectionModel when the selection changes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTree.TreeSelectionRedirector

        protected JTree.TreeSelectionRedirector()

    • 方法详细信息

      • valueChanged

        public void valueChanged(TreeSelectionEvent e)
        Invoked by the TreeSelectionModel when the selection changes.
        指定者：
        valueChanged in interface TreeSelectionListener
        参数：
        e - the TreeSelectionEvent generated by the TreeSelectionModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nlgi r dr ehh eeea>>d.neevvTEt>dTe"""MeMeec


JViewport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JViewport

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JViewport
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public class JViewport
extends JComponent
implements Accessible
    The "viewport" or "porthole" through which you see the underlying information. When you scroll, what moves is the viewport. It is like peering through a camera's viewfinder. Moving the viewfinder upwards brings new things into view at the top of the picture and loses things that were at the bottom.

    By default, JViewport is opaque. To change this, use the setOpaque method.

    NOTE:We have implemented a faster scrolling algorithm that does not require a buffer to draw in. The algorithm works as follows:

    1. The view and parent view and checked to see if they are JComponents, if they aren't, stop and repaint the whole viewport.
    2. If the viewport is obscured by an ancestor, stop and repaint the whole viewport.
    3. Compute the region that will become visible, if it is as big as the viewport, stop and repaint the whole view region.
    4. Obtain the ancestor Window's graphics and do a copyArea on the scrolled region.
    5. Message the view to repaint the newly visible region.
    6. The next time paint is invoked on the viewport, if the clip region is smaller than the viewport size a timer is kicked off to repaint the whole region.
    In general this approach is much faster. Compared to the backing store approach this avoids the overhead of maintaining an offscreen buffer and having to do two copyAreas. Compared to the non backing store case this approach will greatly reduce the painted region.

    This approach can cause slower times than the backing store approach when the viewport is obscured by another window, or partially offscreen. When another window obscures the viewport the copyArea will copy garbage and a paint event will be generated by the system to inform us we need to paint the newly exposed region. The only way to handle this is to repaint the whole viewport, which can cause slower performance than the backing store case. In most applications very rarely will the user be scrolling while the viewport is obscured by another window or offscreen, so this optimization is usually worth the performance hit when obscured.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JScrollPane

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JViewport.AccessibleJViewport
      This class implements accessibility support for the JViewport class.
      protected class  JViewport.ViewListener
      A listener for the view.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean backingStore
      Deprecated.
      As of Java 2 platform v1.3
      static int BACKINGSTORE_SCROLL_MODE
      Draws viewport contents into an offscreen image.
      protected Image backingStoreImage
      The view image used for a backing store.
      static int BLIT_SCROLL_MODE
      Use graphics.copyArea to implement scrolling.
      protected boolean isViewSizeSet
      True when the viewport dimensions have been determined.
      protected Point lastPaintPosition
      The last viewPosition that we've painted, so we know how much of the backing store image is valid.
      protected boolean scrollUnderway
      The scrollUnderway flag is used for components like JList.
      static int SIMPLE_SCROLL_MODE
      This mode uses the very simple method of redrawing the entire contents of the scrollpane each time it is scrolled.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JViewport()
      Creates a JViewport.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the list that is notified each time the view's size, position, or the viewport's extent size has changed.
      protected void addImpl(Component child, Object constraints, int index)
      Sets the JViewport's one lightweight child, which can be null.
      protected boolean computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
      Computes the parameters for a blit where the backing store image currently contains oldLoc in the upper left hand corner and we're scrolling to newLoc.
      protected LayoutManager createLayoutManager()
      Subclassers can override this to install a different layout manager (or null) in the constructor.
      protected JViewport.ViewListener createViewListener()
      Creates a listener for the view.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Notifies listeners of a property change.
      protected void fireStateChanged()
      Notifies all ChangeListeners when the views size, position, or the viewports extent size has changed.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JViewport.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this JViewport with addChangeListener().
      Dimension getExtentSize()
      Returns the size of the visible part of the view in view coordinates.
      Insets getInsets()
      Returns the insets (border) dimensions as (0,0,0,0), since borders are not supported on a JViewport.
      Insets getInsets(Insets insets)
      Returns an Insets object containing this JViewports inset values.
      int getScrollMode()
      Returns the current scrolling mode.
      ViewportUI getUI()
      Returns the L&F object that renders this component.
      String getUIClassID()
      Returns a string that specifies the name of the L&F class that renders this component.
      Component getView()
      Returns the JViewport's one child or null.
      Point getViewPosition()
      Returns the view coordinates that appear in the upper left hand corner of the viewport, or 0,0 if there's no view.
      Rectangle getViewRect()
      Returns a rectangle whose origin is getViewPosition and size is getExtentSize.
      Dimension getViewSize()
      If the view's size hasn't been explicitly set, return the preferred size, otherwise return the view's current size.
      boolean isBackingStoreEnabled()
      Deprecated.
      As of Java 2 platform v1.3, replaced by getScrollMode().
      boolean isOptimizedDrawingEnabled()
      The JViewport overrides the default implementation of this method (in JComponent) to return false.
      protected boolean isPaintingOrigin()
      Returns true if scroll mode is a BACKINGSTORE_SCROLL_MODE to cause painting to originate from JViewport, or one of its ancestors.
      void paint(Graphics g)
      Depending on whether the backingStore is enabled, either paint the image through the backing store or paint just the recently exposed part, using the backing store to "blit" the remainder.
      protected String paramString()
      Returns a string representation of this JViewport.
      void remove(Component child)
      Removes the Viewports one lightweight child.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the list that's notified each time the views size, position, or the viewports extent size has changed.
      void repaint(long tm, int x, int y, int w, int h)
      Always repaint in the parents coordinate system to make sure only one paint is performed by the RepaintManager.
      void reshape(int x, int y, int w, int h)
      Sets the bounds of this viewport.
      void scrollRectToVisible(Rectangle contentRect)
      Scrolls the view so that Rectangle within the view becomes visible.
      void setBackingStoreEnabled(boolean enabled)
      Deprecated.
      As of Java 2 platform v1.3, replaced by setScrollMode().
      void setBorder(Border border)
      The viewport "scrolls" its child (called the "view") by the normal parent/child clipping (typically the view is moved in the opposite direction of the scroll).
      void setExtentSize(Dimension newExtent)
      Sets the size of the visible part of the view using view coordinates.
      void setScrollMode(int mode)
      Used to control the method of scrolling the viewport contents.
      void setUI(ViewportUI ui)
      Sets the L&F object that renders this component.
      void setView(Component view)
      Sets the JViewport's one lightweight child (view), which can be null.
      void setViewPosition(Point p)
      Sets the view coordinates that appear in the upper left hand corner of the viewport, does nothing if there's no view.
      void setViewSize(Dimension newSize)
      Sets the size of the view.
      Dimension toViewCoordinates(Dimension size)
      Converts a size in pixel coordinates to view coordinates.
      Point toViewCoordinates(Point p)
      Converts a point in pixel coordinates to view coordinates.
      void updateUI()
      Resets the UI property to a value from the current look and feel.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • isViewSizeSet

        protected boolean isViewSizeSet
        True when the viewport dimensions have been determined. The default is false.

      • lastPaintPosition

        protected Point lastPaintPosition
        The last viewPosition that we've painted, so we know how much of the backing store image is valid.

      • backingStore

        @Deprecated
protected boolean backingStore
        Deprecated. As of Java 2 platform v1.3
        True when this viewport is maintaining an offscreen image of its contents, so that some scrolling can take place using fast "bit-blit" operations instead of by accessing the view object to construct the display. The default is false.
        另请参见：
        setScrollMode(int)

      • backingStoreImage

        protected transient Image backingStoreImage
        The view image used for a backing store.

      • scrollUnderway

        protected boolean scrollUnderway
        The scrollUnderway flag is used for components like JList. When the downarrow key is pressed on a JList and the selected cell is the last in the list, the scrollpane autoscrolls. Here, the old selected cell needs repainting and so we need a flag to make the viewport do the optimized painting only when there is an explicit call to setViewPosition(Point). When setBounds is called through other routes, the flag is off and the view repaints normally. Another approach would be to remove this from the JViewport class and have the JList manage this case by using setBackingStoreEnabled. The default is false.

      • BLIT_SCROLL_MODE

        public static final int BLIT_SCROLL_MODE
        Use graphics.copyArea to implement scrolling. This is the fastest for most applications.
        从以下版本开始：
        1.3
        另请参见：
        setScrollMode(int), Constant Field Values

      • BACKINGSTORE_SCROLL_MODE

        public static final int BACKINGSTORE_SCROLL_MODE
        Draws viewport contents into an offscreen image. This was previously the default mode for JTable. This mode may offer advantages over "blit mode" in some cases, but it requires a large chunk of extra RAM.
        从以下版本开始：
        1.3
        另请参见：
        setScrollMode(int), Constant Field Values

      • SIMPLE_SCROLL_MODE

        public static final int SIMPLE_SCROLL_MODE
        This mode uses the very simple method of redrawing the entire contents of the scrollpane each time it is scrolled. This was the default behavior in Swing 1.0 and Swing 1.1. Either of the other two options will provide better performance in most cases.
        从以下版本开始：
        1.3
        另请参见：
        setScrollMode(int), Constant Field Values

    • 构造方法详细信息

      • JViewport

        public JViewport()
        Creates a JViewport.

    • 方法详细信息

      • getUI

        public ViewportUI getUI()
        Returns the L&F object that renders this component.
        返回：
        a ViewportUI object
        从以下版本开始：
        1.3

      • setUI

        public void setUI(ViewportUI ui)
        Sets the L&F object that renders this component.
        参数：
        ui - the ViewportUI L&F object
        从以下版本开始：
        1.3
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns a string that specifies the name of the L&F class that renders this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "ViewportUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • addImpl

        protected void addImpl(Component child,
           Object constraints,
           int index)
        Sets the JViewport's one lightweight child, which can be null. (Since there is only one child which occupies the entire viewport, the constraints and index arguments are ignored.)
        重载：
        addImpl in class Container
        参数：
        child - the lightweight child of the viewport
        constraints - the constraints to be respected
        index - the index
        另请参见：
        setView(java.awt.Component)

      • remove

        public void remove(Component child)
        Removes the Viewports one lightweight child.
        重载：
        remove in class Container
        参数：
        child - the component to be removed
        另请参见：
        setView(java.awt.Component)

      • scrollRectToVisible

        public void scrollRectToVisible(Rectangle contentRect)
        Scrolls the view so that Rectangle within the view becomes visible.

        This attempts to validate the view before scrolling if the view is currently not valid - isValid returns false. To avoid excessive validation when the containment hierarchy is being created this will not validate if one of the ancestors does not have a peer, or there is no validate root ancestor, or one of the ancestors is not a Window or Applet.

        Note that this method will not scroll outside of the valid viewport; for example, if contentRect is larger than the viewport, scrolling will be confined to the viewport's bounds.

        重载：
        scrollRectToVisible in class JComponent
        参数：
        contentRect - the Rectangle to display
        另请参见：
        JComponent.isValidateRoot(),
Component.isValid(),
Component.getPeer()

      • setBorder

        public final void setBorder(Border border)
        The viewport "scrolls" its child (called the "view") by the normal parent/child clipping (typically the view is moved in the opposite direction of the scroll). A non-null border, or non-zero insets, isn't supported, to prevent the geometry of this component from becoming complex enough to inhibit subclassing. To create a JViewport with a border, add it to a JPanel that has a border.

        Note: If border is non-null, this method will throw an exception as borders are not supported on a JViewPort.

        重载：
        setBorder in class JComponent
        参数：
        border - the Border to set
        抛出：
        IllegalArgumentException - this method is not implemented
        另请参见：
        Border, CompoundBorder

      • getInsets

        public final Insets getInsets()
        Returns the insets (border) dimensions as (0,0,0,0), since borders are not supported on a JViewport.
        重载：
        getInsets in class JComponent
        返回：
        a Rectange of zero dimension and zero origin
        另请参见：
        setBorder(javax.swing.border.Border)

      • getInsets

        public final Insets getInsets(Insets insets)
        Returns an Insets object containing this JViewports inset values. The passed-in Insets object will be reinitialized, and all existing values within this object are overwritten.
        重载：
        getInsets in class JComponent
        参数：
        insets - the Insets object which can be reused
        返回：
        this viewports inset values
        另请参见：
        getInsets()

      • isOptimizedDrawingEnabled

        public boolean isOptimizedDrawingEnabled()
        The JViewport overrides the default implementation of this method (in JComponent) to return false. This ensures that the drawing machinery will call the Viewport's paint implementation rather than messaging the JViewport's children directly.
        重载：
        isOptimizedDrawingEnabled in class JComponent
        返回：
        false

      • isPaintingOrigin

        protected boolean isPaintingOrigin()
        Returns true if scroll mode is a BACKINGSTORE_SCROLL_MODE to cause painting to originate from JViewport, or one of its ancestors. Otherwise returns false.
        重载：
        isPaintingOrigin in class JComponent
        返回：
        true if if scroll mode is a BACKINGSTORE_SCROLL_MODE.
        另请参见：
        JComponent.isPaintingOrigin()

      • paint

        public void paint(Graphics g)
        Depending on whether the backingStore is enabled, either paint the image through the backing store or paint just the recently exposed part, using the backing store to "blit" the remainder.
        The term "blit" is the pronounced version of the PDP-10 BLT (BLock Transfer) instruction, which copied a block of bits. (In case you were curious.)
        重载：
        paint in class JComponent
        参数：
        g - the Graphics context within which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • reshape

        public void reshape(int x,
           int y,
           int w,
           int h)
        Sets the bounds of this viewport. If the viewport's width or height has changed, fire a StateChanged event.
        重载：
        reshape in class JComponent
        参数：
        x - left edge of the origin
        y - top edge of the origin
        w - width in pixels
        h - height in pixels
        另请参见：
        JComponent.reshape(int, int, int, int)

      • setScrollMode

        public void setScrollMode(int mode)
        Used to control the method of scrolling the viewport contents. You may want to change this mode to get maximum performance for your use case.
        参数：
        mode - one of the following values:
        • JViewport.BLIT_SCROLL_MODE
        • JViewport.BACKINGSTORE_SCROLL_MODE
        • JViewport.SIMPLE_SCROLL_MODE
        从以下版本开始：
        1.3
        另请参见：
        BLIT_SCROLL_MODE, BACKINGSTORE_SCROLL_MODE, SIMPLE_SCROLL_MODE

      • getScrollMode

        public int getScrollMode()
        Returns the current scrolling mode.
        返回：
        the scrollMode property
        从以下版本开始：
        1.3
        另请参见：
        setScrollMode(int)

      • isBackingStoreEnabled

        @Deprecated
public boolean isBackingStoreEnabled()
        Deprecated. As of Java 2 platform v1.3, replaced by getScrollMode().
        Returns true if this viewport is maintaining an offscreen image of its contents.
        返回：
        true if scrollMode is BACKINGSTORE_SCROLL_MODE

      • setBackingStoreEnabled

        @Deprecated
public void setBackingStoreEnabled(boolean enabled)
        Deprecated. As of Java 2 platform v1.3, replaced by setScrollMode().
        If true if this viewport will maintain an offscreen image of its contents. The image is used to reduce the cost of small one dimensional changes to the viewPosition. Rather than repainting the entire viewport we use Graphics.copyArea to effect some of the scroll.
        参数：
        enabled - if true, maintain an offscreen backing store

      • getView

        public Component getView()
        Returns the JViewport's one child or null.
        返回：
        the viewports child, or null if none exists
        另请参见：
        setView(java.awt.Component)

      • setView

        public void setView(Component view)
        Sets the JViewport's one lightweight child (view), which can be null.
        参数：
        view - the viewport's new lightweight child
        另请参见：
        getView()

      • getViewSize

        public Dimension getViewSize()
        If the view's size hasn't been explicitly set, return the preferred size, otherwise return the view's current size. If there is no view, return 0,0.
        返回：
        a Dimension object specifying the size of the view

      • setViewSize

        public void setViewSize(Dimension newSize)
        Sets the size of the view. A state changed event will be fired.
        参数：
        newSize - a Dimension object specifying the new size of the view

      • getViewPosition

        public Point getViewPosition()
        Returns the view coordinates that appear in the upper left hand corner of the viewport, or 0,0 if there's no view.
        返回：
        a Point object giving the upper left coordinates

      • setViewPosition

        public void setViewPosition(Point p)
        Sets the view coordinates that appear in the upper left hand corner of the viewport, does nothing if there's no view.
        参数：
        p - a Point object giving the upper left coordinates

      • getViewRect

        public Rectangle getViewRect()
        Returns a rectangle whose origin is getViewPosition and size is getExtentSize. This is the visible part of the view, in view coordinates.
        返回：
        a Rectangle giving the visible part of the view using view coordinates.

      • computeBlit

        protected boolean computeBlit(int dx,
                  int dy,
                  Point blitFrom,
                  Point blitTo,
                  Dimension blitSize,
                  Rectangle blitPaint)
        Computes the parameters for a blit where the backing store image currently contains oldLoc in the upper left hand corner and we're scrolling to newLoc. The parameters are modified to return the values required for the blit.
        参数：
        dx - the horizontal delta
        dy - the vertical delta
        blitFrom - the Point we're blitting from
        blitTo - the Point we're blitting to
        blitSize - the Dimension of the area to blit
        blitPaint - the area to blit
        返回：
        true if the parameters are modified and we're ready to blit; false otherwise

      • getExtentSize

        public Dimension getExtentSize()
        Returns the size of the visible part of the view in view coordinates.
        返回：
        a Dimension object giving the size of the view

      • toViewCoordinates

        public Dimension toViewCoordinates(Dimension size)
        Converts a size in pixel coordinates to view coordinates. Subclasses of viewport that support "logical coordinates" will override this method.
        参数：
        size - a Dimension object using pixel coordinates
        返回：
        a Dimension object converted to view coordinates

      • toViewCoordinates

        public Point toViewCoordinates(Point p)
        Converts a point in pixel coordinates to view coordinates. Subclasses of viewport that support "logical coordinates" will override this method.
        参数：
        p - a Point object using pixel coordinates
        返回：
        a Point object converted to view coordinates

      • setExtentSize

        public void setExtentSize(Dimension newExtent)
        Sets the size of the visible part of the view using view coordinates.
        参数：
        newExtent - a Dimension object specifying the size of the view

      • createViewListener

        protected JViewport.ViewListener createViewListener()
        Creates a listener for the view.
        返回：
        a ViewListener

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Subclassers can override this to install a different layout manager (or null) in the constructor. Returns the LayoutManager to install on the JViewport.
        返回：
        a LayoutManager

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the list that is notified each time the view's size, position, or the viewport's extent size has changed.
        参数：
        l - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener),
setViewPosition(java.awt.Point),
setViewSize(java.awt.Dimension),
setExtentSize(java.awt.Dimension)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the list that's notified each time the views size, position, or the viewports extent size has changed.
        参数：
        l - the ChangeListener to remove
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this JViewport with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all ChangeListeners when the views size, position, or the viewports extent size has changed.
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener), EventListenerList

      • repaint

        public void repaint(long tm,
           int x,
           int y,
           int w,
           int h)
        Always repaint in the parents coordinate system to make sure only one paint is performed by the RepaintManager.
        重载：
        repaint in class JComponent
        参数：
        tm - maximum time in milliseconds before update
        x - the x coordinate (pixels over from left)
        y - the y coordinate (pixels down from top)
        w - the width
        h - the height
        另请参见：
        Component.update(java.awt.Graphics)

      • paramString

        protected String paramString()
        Returns a string representation of this JViewport. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class JComponent
        返回：
        a string representation of this JViewport

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Notifies listeners of a property change. This is subclassed to update the windowBlit property. (The putClientProperty property is final).
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - a string containing the property name
        oldValue - the old value of the property
        newValue - the new value of the property

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JViewport. For viewports, the AccessibleContext takes the form of an AccessibleJViewport. A new AccessibleJViewport instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJViewport that serves as the AccessibleContext of this JViewport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JViewport.AccessibleJViewport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JViewport.AccessibleJViewport

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.JViewport.AccessibleJViewport
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JViewport

    protected class JViewport.AccessibleJViewport
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JViewport class. It provides an implementation of the Java Accessibility API appropriate to viewport user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JViewport.AccessibleJViewport()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JViewport.AccessibleJViewport

        protected JViewport.AccessibleJViewport()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irssl/sca>ces rii-rocfn


JViewport.ViewListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JViewport.ViewListener

  • java.lang.Object
    • java.awt.event.ComponentAdapter
      • javax.swing.JViewport.ViewListener
  • 所有已实现的接口：
    ComponentListener, Serializable, EventListener
    封闭类：
    JViewport

    protected class JViewport.ViewListener
extends ComponentAdapter
implements Serializable
    A listener for the view.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JViewport.ViewListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void componentResized(ComponentEvent e)
      Invoked when the component's size changes.

      • 方法 - 继承于类 java.awt.event.ComponentAdapter

        componentHidden, componentMoved, componentShown

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JViewport.ViewListener

        protected JViewport.ViewListener()

    • 方法详细信息

      • componentResized

        public void componentResized(ComponentEvent e)
        Description copied from class: ComponentAdapter
        Invoked when the component's size changes.
        指定者：
        componentResized in interface ComponentListener
        重载：
        componentResized in class ComponentAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nldlp= e= "ss ""llee;bc;>ppa>oaa"aappnscda>


JWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 JWindow

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • javax.swing.JWindow
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer

    public class JWindow
extends Window
implements Accessible, RootPaneContainer
    A JWindow is a container that can be displayed anywhere on the user's desktop. It does not have the title bar, window-management buttons, or other trimmings associated with a JFrame, but it is still a "first-class citizen" of the user's desktop, and can exist anywhere on it.

    The JWindow component contains a JRootPane as its only child. The contentPane should be the parent of any children of the JWindow. As a conveniance add and its variants, remove and setLayout have been overridden to forward to the contentPane as necessary. This means you can write:

           window.add(child);
    And the child will be added to the contentPane. The contentPane will always be non-null. Attempting to set it to null will cause the JWindow to throw an exception. The default contentPane will have a BorderLayout manager set on it. Refer to RootPaneContainer for details on adding, removing and setting the LayoutManager of a JWindow.

    Please see the JRootPane documentation for a complete description of the contentPane, glassPane, and layeredPane components.

    In a multi-screen environment, you can create a JWindow on a different screen device. See Window for more information.

    警告： Swing is not thread safe. For more information see Swing's Threading Policy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JRootPane

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JWindow.AccessibleJWindow
      This class implements accessibility support for the JWindow class.

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AccessibleContext accessibleContext
      The accessible context property.
      protected JRootPane rootPane
      The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
      protected boolean rootPaneCheckingEnabled
      If true then calls to add and setLayout will be forwarded to the contentPane.

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JWindow()
      Creates a window with no specified owner.
      JWindow(Frame owner)
      Creates a window with the specified owner frame.
      JWindow(GraphicsConfiguration gc)
      Creates a window with the specified GraphicsConfiguration of a screen device.
      JWindow(Window owner)
      Creates a window with the specified owner window.
      JWindow(Window owner, GraphicsConfiguration gc)
      Creates a window with the specified owner window and GraphicsConfiguration of a screen device.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void addImpl(Component comp, Object constraints, int index)
      Adds the specified child Component.
      protected JRootPane createRootPane()
      Called by the constructor methods to create the default rootPane.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JWindow.
      Container getContentPane()
      Returns the Container which is the contentPane for this window.
      Component getGlassPane()
      Returns the glassPane Component for this window.
      Graphics getGraphics()
      Creates a graphics context for this component.
      JLayeredPane getLayeredPane()
      Returns the layeredPane object for this window.
      JRootPane getRootPane()
      Returns the rootPane object for this window.
      TransferHandler getTransferHandler()
      Gets the transferHandler property.
      protected boolean isRootPaneCheckingEnabled()
      Returns whether calls to add and setLayout are forwarded to the contentPane.
      protected String paramString()
      Returns a string representation of this JWindow.
      void remove(Component comp)
      Removes the specified component from the container.
      void repaint(long time, int x, int y, int width, int height)
      Repaints the specified rectangle of this component within time milliseconds.
      void setContentPane(Container contentPane)
      Sets the contentPane property for this window.
      void setGlassPane(Component glassPane)
      Sets the glassPane property.
      void setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void setLayout(LayoutManager manager)
      Sets the LayoutManager.
      protected void setRootPane(JRootPane root)
      Sets the new rootPane object for this window.
      protected void setRootPaneCheckingEnabled(boolean enabled)
      Sets whether calls to add and setLayout are forwarded to the contentPane.
      void setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void update(Graphics g)
      Calls paint(g).
      protected void windowInit()
      Called by the constructors to init the JWindow properly.

      • 方法 - 继承于类 java.awt.Window

        addNotify, addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, paint, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBackground, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setOpacity, setShape, setSize, setSize, setType, setVisible, show, toBack, toFront

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • rootPane

        protected JRootPane rootPane
        The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
        另请参见：
        getRootPane(), setRootPane(javax.swing.JRootPane)

      • rootPaneCheckingEnabled

        protected boolean rootPaneCheckingEnabled
        If true then calls to add and setLayout will be forwarded to the contentPane. This is initially false, but is set to true when the JWindow is constructed.
        另请参见：
        isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • accessibleContext

        protected AccessibleContext accessibleContext
        The accessible context property.

    • 构造方法详细信息

      • JWindow

        public JWindow()
        Creates a window with no specified owner. This window will not be focusable.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

      • JWindow

        public JWindow(GraphicsConfiguration gc)
        Creates a window with the specified GraphicsConfiguration of a screen device. This window will not be focusable.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        gc - the GraphicsConfiguration that is used to construct the new window with; if gc is null, the system default GraphicsConfiguration is assumed
        抛出：
        HeadlessException - If GraphicsEnvironment.isHeadless() returns true.
        IllegalArgumentException - if gc is not from a screen device.
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

      • JWindow

        public JWindow(Frame owner)
        Creates a window with the specified owner frame. If owner is null, the shared owner will be used and this window will not be focusable. Also, this window will not be focusable unless its owner is showing on the screen.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the frame from which the window is displayed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

      • JWindow

        public JWindow(Window owner)
        Creates a window with the specified owner window. This window will not be focusable unless its owner is showing on the screen. If owner is null, the shared owner will be used and this window will not be focusable.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the window from which the window is displayed
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        另请参见：
        GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

      • JWindow

        public JWindow(Window owner,
       GraphicsConfiguration gc)
        Creates a window with the specified owner window and GraphicsConfiguration of a screen device. If owner is null, the shared owner will be used and this window will not be focusable.

        This constructor sets the component's locale property to the value returned by JComponent.getDefaultLocale.

        参数：
        owner - the window from which the window is displayed
        gc - the GraphicsConfiguration that is used to construct the new window with; if gc is null, the system default GraphicsConfiguration is assumed, unless owner is also null, in which case the GraphicsConfiguration from the shared owner frame will be used.
        抛出：
        HeadlessException - if GraphicsEnvironment.isHeadless() returns true.
        IllegalArgumentException - if gc is not from a screen device.
        从以下版本开始：
        1.3
        另请参见：
        GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

    • 方法详细信息

      • windowInit

        protected void windowInit()
        Called by the constructors to init the JWindow properly.

      • createRootPane

        protected JRootPane createRootPane()
        Called by the constructor methods to create the default rootPane.

      • isRootPaneCheckingEnabled

        protected boolean isRootPaneCheckingEnabled()
        Returns whether calls to add and setLayout are forwarded to the contentPane.
        返回：
        true if add and setLayout are fowarded; false otherwise
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • setTransferHandler

        public void setTransferHandler(TransferHandler newHandler)
        Sets the transferHandler property, which is a mechanism to support transfer of data into this component. Use null if the component does not support data transfer operations.

        If the system property suppressSwingDropSupport is false (the default) and the current drop target on this component is either null or not a user-set drop target, this method will change the drop target as follows: If newHandler is null it will clear the drop target. If not null it will install a new DropTarget.

        Note: When used with JWindow, TransferHandler only provides data import capability, as the data export related methods are currently typed to JComponent.

        Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

        参数：
        newHandler - the new TransferHandler
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

      • getTransferHandler

        public TransferHandler getTransferHandler()
        Gets the transferHandler property.
        返回：
        the value of the transferHandler property
        从以下版本开始：
        1.6
        另请参见：
        TransferHandler, setTransferHandler(javax.swing.TransferHandler)

      • update

        public void update(Graphics g)
        Calls paint(g). This method was overridden to prevent an unnecessary call to clear the background.
        重载：
        update in class Container
        参数：
        g - the Graphics context in which to paint
        另请参见：
        Component.update(Graphics)

      • setRootPaneCheckingEnabled

        protected void setRootPaneCheckingEnabled(boolean enabled)
        Sets whether calls to add and setLayout are forwarded to the contentPane.
        参数：
        enabled - true if add and setLayout are forwarded, false if they should operate directly on the JWindow.
        另请参见：
        addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

      • addImpl

        protected void addImpl(Component comp,
           Object constraints,
           int index)
        Adds the specified child Component. This method is overridden to conditionally forward calls to the contentPane. By default, children are added to the contentPane instead of the frame, refer to RootPaneContainer for details.
        重载：
        addImpl in class Container
        参数：
        comp - the component to be enhanced
        constraints - the constraints to be respected
        index - the index
        抛出：
        IllegalArgumentException - if index is invalid
        IllegalArgumentException - if adding the container's parent to itself
        IllegalArgumentException - if adding a window to a container
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • remove

        public void remove(Component comp)
        Removes the specified component from the container. If comp is not the rootPane, this will forward the call to the contentPane. This will do nothing if comp is not a child of the JWindow or contentPane.
        重载：
        remove in class Container
        参数：
        comp - the component to be removed
        抛出：
        NullPointerException - if comp is null
        另请参见：
        Container.add(java.awt.Component), RootPaneContainer

      • setLayout

        public void setLayout(LayoutManager manager)
        Sets the LayoutManager. Overridden to conditionally forward the call to the contentPane. Refer to RootPaneContainer for more information.
        重载：
        setLayout in class Container
        参数：
        manager - the LayoutManager
        另请参见：
        setRootPaneCheckingEnabled(boolean), RootPaneContainer

      • getRootPane

        public JRootPane getRootPane()
        Returns the rootPane object for this window.
        指定者：
        getRootPane in interface RootPaneContainer
        返回：
        the rootPane property for this window
        另请参见：
        setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

      • setRootPane

        protected void setRootPane(JRootPane root)
        Sets the new rootPane object for this window. This method is called by the constructor.
        参数：
        root - the new rootPane property
        另请参见：
        getRootPane()

      • getContentPane

        public Container getContentPane()
        Returns the Container which is the contentPane for this window.
        指定者：
        getContentPane in interface RootPaneContainer
        返回：
        the contentPane property
        另请参见：
        setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

      • setContentPane

        public void setContentPane(Container contentPane)
        Sets the contentPane property for this window. This method is called by the constructor.
        指定者：
        setContentPane in interface RootPaneContainer
        参数：
        contentPane - the new contentPane
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

      • getLayeredPane

        public JLayeredPane getLayeredPane()
        Returns the layeredPane object for this window.
        指定者：
        getLayeredPane in interface RootPaneContainer
        返回：
        the layeredPane property
        另请参见：
        setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

      • setLayeredPane

        public void setLayeredPane(JLayeredPane layeredPane)
        Sets the layeredPane property. This method is called by the constructor.
        指定者：
        setLayeredPane in interface RootPaneContainer
        参数：
        layeredPane - the new layeredPane object
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

      • getGlassPane

        public Component getGlassPane()
        Returns the glassPane Component for this window.
        指定者：
        getGlassPane in interface RootPaneContainer
        返回：
        the glassPane property
        另请参见：
        setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

      • setGlassPane

        public void setGlassPane(Component glassPane)
        Sets the glassPane property. This method is called by the constructor.
        指定者：
        setGlassPane in interface RootPaneContainer
        参数：
        glassPane - the glassPane object for this window
        另请参见：
        getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

      • getGraphics

        public Graphics getGraphics()
        Creates a graphics context for this component. This method will return null if this component is currently not displayable.
        重载：
        getGraphics in class Component
        返回：
        a graphics context for this component, or null if it has none
        从以下版本开始：
        1.6
        另请参见：
        Component.paint(java.awt.Graphics)

      • repaint

        public void repaint(long time,
           int x,
           int y,
           int width,
           int height)
        Repaints the specified rectangle of this component within time milliseconds. Refer to RepaintManager for details on how the repaint is handled.
        重载：
        repaint in class Component
        参数：
        time - maximum time in milliseconds before update
        x - the x coordinate
        y - the y coordinate
        width - the width
        height - the height
        从以下版本开始：
        1.6
        另请参见：
        RepaintManager

      • paramString

        protected String paramString()
        Returns a string representation of this JWindow. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        paramString in class Container
        返回：
        a string representation of this JWindow

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JWindow. For JWindows, the AccessibleContext takes the form of an AccessibleJWindow. A new AccessibleJWindow instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class Window
        返回：
        an AccessibleJWindow that serves as the AccessibleContext of this JWindow
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JWindow.AccessibleJWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing

类 JWindow.AccessibleJWindow

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Window.AccessibleAWTWindow
            • javax.swing.JWindow.AccessibleJWindow
  • 所有已实现的接口：
    Serializable, AccessibleComponent
    封闭类：
    JWindow

    protected class JWindow.AccessibleJWindow
extends Window.AccessibleAWTWindow
    This class implements accessibility support for the JWindow class. It provides an implementation of the Java Accessibility API appropriate to window user-interface elements.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container.AccessibleAWTContainer

        Container.AccessibleAWTContainer.AccessibleContainerHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class java.awt.Container.AccessibleAWTContainer

        accessibleContainerHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JWindow.AccessibleJWindow()

    • 方法摘要

      • 方法 - 继承于类 java.awt.Window.AccessibleAWTWindow

        getAccessibleRole, getAccessibleStateSet

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JWindow.AccessibleJWindow

        protected JWindow.AccessibleJWindow()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gt neoiCosiissasj/ieAsbcetmctal


KeyStroke

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 KeyStroke

  • java.lang.Object
    • java.awt.AWTKeyStroke
      • javax.swing.KeyStroke
  • 所有已实现的接口：
    Serializable

    public class KeyStroke
extends AWTKeyStroke
    A KeyStroke represents a key action on the keyboard, or equivalent input device. KeyStrokes can correspond to only a press or release of a particular key, just as KEY_PRESSED and KEY_RELEASED KeyEvents do; alternately, they can correspond to typing a specific Java character, just as KEY_TYPED KeyEvents do. In all cases, KeyStrokes can specify modifiers (alt, shift, control, meta, altGraph, or a combination thereof) which must be present during the action for an exact match.

    KeyStrokes are used to define high-level (semantic) action events. Instead of trapping every keystroke and throwing away the ones you are not interested in, those keystrokes you care about automatically initiate actions on the Components with which they are registered.

    KeyStrokes are immutable, and are intended to be unique. Client code cannot create a KeyStroke; a variant of getKeyStroke must be used instead. These factory methods allow the KeyStroke implementation to cache and share instances efficiently.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Keymap, getKeyStroke(char)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static KeyStroke getKeyStroke(char keyChar)
      Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified character.
      static KeyStroke getKeyStroke(Character keyChar, int modifiers)
      Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.
      static KeyStroke getKeyStroke(char keyChar, boolean onKeyRelease)
      Deprecated.
      use getKeyStroke(char)
      static KeyStroke getKeyStroke(int keyCode, int modifiers)
      Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers.
      static KeyStroke getKeyStroke(int keyCode, int modifiers, boolean onKeyRelease)
      Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.
      static KeyStroke getKeyStroke(String s)
      Parses a string and returns a KeyStroke.
      static KeyStroke getKeyStrokeForEvent(KeyEvent anEvent)
      Returns a KeyStroke which represents the stroke which generated a given KeyEvent.

      • 方法 - 继承于类 java.awt.AWTKeyStroke

        equals, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStrokeForEvent, getKeyChar, getKeyCode, getKeyEventType, getModifiers, hashCode, isOnKeyRelease, readResolve, registerSubclass, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getKeyStroke

        public static KeyStroke getKeyStroke(char keyChar)
        Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified character.
        参数：
        keyChar - the character value for a keyboard key
        返回：
        a KeyStroke object for that key

      • getKeyStroke

        @Deprecated
public static KeyStroke getKeyStroke(char keyChar,
                                boolean onKeyRelease)
        Deprecated. use getKeyStroke(char)
        Returns an instance of a KeyStroke, specifying whether the key is considered to be activated when it is pressed or released. Unlike all other factory methods in this class, the instances returned by this method are not necessarily cached or shared.
        参数：
        keyChar - the character value for a keyboard key
        onKeyRelease - true if this KeyStroke corresponds to a key release; false otherwise.
        返回：
        a KeyStroke object for that key

      • getKeyStroke

        public static KeyStroke getKeyStroke(Character keyChar,
                     int modifiers)
        Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers. Note that the first parameter is of type Character rather than char. This is to avoid inadvertent clashes with calls to getKeyStroke(int keyCode, int modifiers). The modifiers consist of any combination of following:
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        The old modifiers listed below also can be used, but they are mapped to _DOWN_ modifiers.
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        also can be used, but they are mapped to _DOWN_ modifiers. Since these numbers are all different powers of two, any combination of them is an integer in which each bit represents a different modifier key. Use 0 to specify no modifiers.
        参数：
        keyChar - the Character object for a keyboard character
        modifiers - a bitwise-ored combination of any modifiers
        返回：
        an KeyStroke object for that key
        抛出：
        IllegalArgumentException - if keyChar is null
        从以下版本开始：
        1.3
        另请参见：
        InputEvent

      • getKeyStroke

        public static KeyStroke getKeyStroke(int keyCode,
                     int modifiers,
                     boolean onKeyRelease)
        Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.

        The "virtual key" constants defined in java.awt.event.KeyEvent can be used to specify the key code. For example:

        • java.awt.event.KeyEvent.VK_ENTER
        • java.awt.event.KeyEvent.VK_TAB
        • java.awt.event.KeyEvent.VK_SPACE
        Alternatively, the key code may be obtained by calling java.awt.event.KeyEvent.getExtendedKeyCodeForChar. The modifiers consist of any combination of:
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        The old modifiers
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        also can be used, but they are mapped to _DOWN_ modifiers. Since these numbers are all different powers of two, any combination of them is an integer in which each bit represents a different modifier key. Use 0 to specify no modifiers.
        参数：
        keyCode - an int specifying the numeric code for a keyboard key
        modifiers - a bitwise-ored combination of any modifiers
        onKeyRelease - true if the KeyStroke should represent a key release; false otherwise.
        返回：
        a KeyStroke object for that key
        另请参见：
        KeyEvent, InputEvent

      • getKeyStroke

        public static KeyStroke getKeyStroke(int keyCode,
                     int modifiers)
        Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers. The returned KeyStroke will correspond to a key press.

        The "virtual key" constants defined in java.awt.event.KeyEvent can be used to specify the key code. For example:

        • java.awt.event.KeyEvent.VK_ENTER
        • java.awt.event.KeyEvent.VK_TAB
        • java.awt.event.KeyEvent.VK_SPACE
        Alternatively, the key code may be obtained by calling java.awt.event.KeyEvent.getExtendedKeyCodeForChar. The modifiers consist of any combination of:
        • java.awt.event.InputEvent.SHIFT_DOWN_MASK
        • java.awt.event.InputEvent.CTRL_DOWN_MASK
        • java.awt.event.InputEvent.META_DOWN_MASK
        • java.awt.event.InputEvent.ALT_DOWN_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
        The old modifiers
        • java.awt.event.InputEvent.SHIFT_MASK
        • java.awt.event.InputEvent.CTRL_MASK
        • java.awt.event.InputEvent.META_MASK
        • java.awt.event.InputEvent.ALT_MASK
        • java.awt.event.InputEvent.ALT_GRAPH_MASK
        also can be used, but they are mapped to _DOWN_ modifiers. Since these numbers are all different powers of two, any combination of them is an integer in which each bit represents a different modifier key. Use 0 to specify no modifiers.
        参数：
        keyCode - an int specifying the numeric code for a keyboard key
        modifiers - a bitwise-ored combination of any modifiers
        返回：
        a KeyStroke object for that key
        另请参见：
        KeyEvent, InputEvent

      • getKeyStrokeForEvent

        public static KeyStroke getKeyStrokeForEvent(KeyEvent anEvent)
        Returns a KeyStroke which represents the stroke which generated a given KeyEvent.

        This method obtains the keyChar from a KeyTyped event, and the keyCode from a KeyPressed or KeyReleased event. The KeyEvent modifiers are obtained for all three types of KeyEvent.

        参数：
        anEvent - the KeyEvent from which to obtain the KeyStroke
        返回：
        the KeyStroke that precipitated the event
        抛出：
        NullPointerException - if anEvent is null

      • getKeyStroke

        public static KeyStroke getKeyStroke(String s)
        Parses a string and returns a KeyStroke. The string must have the following syntax:
            <modifiers>* (<typedID> | <pressedReleasedID>)

    modifiers := shift | control | ctrl | meta | alt | altGraph
    typedID := typed <typedKey>
    typedKey := string of length 1 giving Unicode character.
    pressedReleasedID := (pressed | released) key
    key := KeyEvent key code name, i.e. the name following "VK_".
        If typed, pressed or released is not specified, pressed is assumed. Here are some examples:
             "INSERT" => getKeyStroke(KeyEvent.VK_INSERT, 0);
     "control DELETE" => getKeyStroke(KeyEvent.VK_DELETE, InputEvent.CTRL_MASK);
     "alt shift X" => getKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK);
     "alt shift released X" => getKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK, true);
     "typed a" => getKeyStroke('a');
        In order to maintain backward-compatibility, specifying a null String, or a String which is formatted incorrectly, returns null.
        参数：
        s - a String formatted as described above
        返回：
        a KeyStroke object for that String, or null if the specified String is null, or is formatted incorrectly
        另请参见：
        KeyEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sttet"y)"yg((yggtewwjacennvedlitwwe>r>au


LayoutFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 LayoutFocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy
  • 所有已实现的接口：
    Serializable

    public class LayoutFocusTraversalPolicy
extends SortingFocusTraversalPolicy
implements Serializable
    A SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation. Based on their size and position, Components are roughly categorized into rows and columns. For a Container with horizontal orientation, columns run left-to-right or right-to-left, and rows run top- to-bottom. For a Container with vertical orientation, columns run top-to- bottom and rows run left-to-right or right-to-left. See ComponentOrientation for more information. All columns in a row are fully traversed before proceeding to the next row.
    从以下版本开始：
    1.4
    另请参见：
    ComponentOrientation

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayoutFocusTraversalPolicy()
      Constructs a LayoutFocusTraversalPolicy.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected boolean accept(Component aComponent)
      Determines whether the specified Component is an acceptable choice as the new focus owner.
      Component getComponentAfter(Container aContainer, Component aComponent)
      Returns the Component that should receive the focus after aComponent.
      Component getComponentBefore(Container aContainer, Component aComponent)
      Returns the Component that should receive the focus before aComponent.
      Component getFirstComponent(Container aContainer)
      Returns the first Component in the traversal cycle.
      Component getLastComponent(Container aContainer)
      Returns the last Component in the traversal cycle.

      • 方法 - 继承于类 javax.swing.SortingFocusTraversalPolicy

        getComparator, getDefaultComponent, getImplicitDownCycleTraversal, setComparator, setImplicitDownCycleTraversal

      • 方法 - 继承于类 javax.swing.InternalFrameFocusTraversalPolicy

        getInitialComponent

      • 方法 - 继承于类 java.awt.FocusTraversalPolicy

        getInitialComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LayoutFocusTraversalPolicy

        public LayoutFocusTraversalPolicy()
        Constructs a LayoutFocusTraversalPolicy.

    • 方法详细信息

      • getComponentAfter

        public Component getComponentAfter(Container aContainer,
                          Component aComponent)
        Returns the Component that should receive the focus after aComponent. aContainer must be a focus cycle root of aComponent.

        By default, LayoutFocusTraversalPolicy implicitly transfers focus down- cycle. That is, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This behavior can be disabled using the setImplicitDownCycleTraversal method.

        If aContainer is focus traversal policy provider, the focus is always transferred down-cycle.

        重载：
        getComponentAfter in class SortingFocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider
        aComponent - a (possibly indirect) child of aContainer, or aContainer itself
        返回：
        the Component that should receive the focus after aComponent, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is not a focus cycle root of aComponent or a focus traversal policy provider, or if either aContainer or aComponent is null

      • getComponentBefore

        public Component getComponentBefore(Container aContainer,
                           Component aComponent)
        Returns the Component that should receive the focus before aComponent. aContainer must be a focus cycle root of aComponent.

        By default, LayoutFocusTraversalPolicy implicitly transfers focus down- cycle. That is, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This behavior can be disabled using the setImplicitDownCycleTraversal method.

        If aContainer is focus traversal policy provider, the focus is always transferred down-cycle.

        重载：
        getComponentBefore in class SortingFocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider
        aComponent - a (possibly indirect) child of aContainer, or aContainer itself
        返回：
        the Component that should receive the focus before aComponent, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is not a focus cycle root of aComponent or a focus traversal policy provider, or if either aContainer or aComponent is null

      • getFirstComponent

        public Component getFirstComponent(Container aContainer)
        Returns the first Component in the traversal cycle. This method is used to determine the next Component to focus when traversal wraps in the forward direction.
        重载：
        getFirstComponent in class SortingFocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider whose first Component is to be returned
        返回：
        the first Component in the traversal cycle of aContainer, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is null

      • getLastComponent

        public Component getLastComponent(Container aContainer)
        Returns the last Component in the traversal cycle. This method is used to determine the next Component to focus when traversal wraps in the reverse direction.
        重载：
        getLastComponent in class SortingFocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider whose last Component is to be returned
        返回：
        the last Component in the traversal cycle of aContainer, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is null

      • accept

        protected boolean accept(Component aComponent)
        Determines whether the specified Component is an acceptable choice as the new focus owner. This method performs the following sequence of operations:
        1. Checks whether aComponent is visible, displayable, enabled, and focusable. If any of these properties is false, this method returns false.
        2. If aComponent is an instance of JTable, returns true.
        3. If aComponent is an instance of JComboBox, then returns the value of aComponent.getUI().isFocusTraversable(aComponent).
        4. If aComponent is a JComponent with a JComponent.WHEN_FOCUSED InputMap that is neither null nor empty, returns true.
        5. Returns the value of DefaultFocusTraversalPolicy.accept(aComponent).
        重载：
        accept in class SortingFocusTraversalPolicy
        参数：
        aComponent - the Component whose fitness as a focus owner is to be tested
        返回：
        true if aComponent is a valid choice for a focus owner; otherwise false
        另请参见：
        Component.isVisible(),
Component.isDisplayable(),
Component.isEnabled(),
Component.isFocusable(),
ComboBoxUI.isFocusTraversable(javax.swing.JComboBox),
JComponent.getInputMap(int),
DefaultFocusTraversalPolicy.accept(java.awt.Component)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>NMeheee"edal">tlo pnFsliin>秈lbi＃


LayoutStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 LayoutStyle

  • java.lang.Object
    • javax.swing.LayoutStyle

  • public abstract class LayoutStyle
extends Object
    LayoutStyle provides information about how to position components. This class is primarily useful for visual tools and layout managers. Most developers will not need to use this class.

    You typically don't set or create a LayoutStyle. Instead use the static method getInstance to obtain the current instance.

    从以下版本开始：
    1.6

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  LayoutStyle.ComponentPlacement
      ComponentPlacement is an enumeration of the possible ways two components can be placed relative to each other.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayoutStyle()
      Creates a new LayoutStyle.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int getContainerGap(JComponent component, int position, Container parent)
      Returns the amount of space to place between the component and specified edge of its parent.
      static LayoutStyle getInstance()
      Returns the shared instance of LayoutStyle.
      abstract int getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
      Returns the amount of space to use between two components.
      static void setInstance(LayoutStyle style)
      Sets the shared instance of LayoutStyle.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LayoutStyle

        public LayoutStyle()
        Creates a new LayoutStyle. You generally don't create a LayoutStyle. Instead use the method getInstance to obtain the current LayoutStyle.

    • 方法详细信息

      • setInstance

        public static void setInstance(LayoutStyle style)
        Sets the shared instance of LayoutStyle. Specifying null results in using the LayoutStyle from the current LookAndFeel.
        参数：
        style - the LayoutStyle, or null
        另请参见：
        getInstance()

      • getInstance

        public static LayoutStyle getInstance()
        Returns the shared instance of LayoutStyle. If an instance has not been specified in setInstance, this will return the LayoutStyle from the current LookAndFeel.
        返回：
        the shared instance of LayoutStyle
        另请参见：
        LookAndFeel.getLayoutStyle()

      • getPreferredGap

        public abstract int getPreferredGap(JComponent component1,
                  JComponent component2,
                  LayoutStyle.ComponentPlacement type,
                  int position,
                  Container parent)
        Returns the amount of space to use between two components. The return value indicates the distance to place component2 relative to component1. For example, the following returns the amount of space to place between component2 and component1 when component2 is placed vertically above component1:
           int gap = getPreferredGap(component1, component2,
                             ComponentPlacement.RELATED,
                             SwingConstants.NORTH, parent);
        The type parameter indicates the relation between the two components. If the two components will be contained in the same parent and are showing similar logically related items, use RELATED. If the two components will be contained in the same parent but show logically unrelated items use UNRELATED. Some look and feels may not distinguish between the RELATED and UNRELATED types.

        The return value is not intended to take into account the current size and position of component2 or component1. The return value may take into consideration various properties of the components. For example, the space may vary based on font size, or the preferred size of the component.

        参数：
        component1 - the JComponent component2 is being placed relative to
        component2 - the JComponent being placed
        position - the position component2 is being placed relative to component1; one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
        type - how the two components are being placed
        parent - the parent of component2; this may differ from the actual parent and it may be null
        返回：
        the amount of space to place between the two components
        抛出：
        NullPointerException - if component1, component2 or type is null
        IllegalArgumentException - if position is not one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
        从以下版本开始：
        1.6
        另请参见：
        LookAndFeel.getLayoutStyle()

      • getContainerGap

        public abstract int getContainerGap(JComponent component,
                  int position,
                  Container parent)
        Returns the amount of space to place between the component and specified edge of its parent.
        参数：
        component - the JComponent being positioned
        position - the position component is being placed relative to its parent; one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
        parent - the parent of component; this may differ from the actual parent and may be null
        返回：
        the amount of space to place between the component and specified edge
        抛出：
        IllegalArgumentException - if position is not one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dp&<4 => tp<saatcaavjvteib


LayoutStyle.ComponentPlacement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum LayoutStyle.ComponentPlacement

  • java.lang.Object
    • java.lang.Enum<LayoutStyle.ComponentPlacement>
      • javax.swing.LayoutStyle.ComponentPlacement
  • 所有已实现的接口：
    Serializable, Comparable<LayoutStyle.ComponentPlacement>
    封闭类：
    LayoutStyle

    public static enum LayoutStyle.ComponentPlacement
extends Enum<LayoutStyle.ComponentPlacement>
    ComponentPlacement is an enumeration of the possible ways two components can be placed relative to each other. ComponentPlacement is used by the LayoutStyle method getPreferredGap. Refer to LayoutStyle for more information.
    从以下版本开始：
    1.6
    另请参见：
    LayoutStyle.getPreferredGap(JComponent,JComponent, ComponentPlacement,int,Container)

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      INDENT
      Enumeration value indicating the distance to indent a component is being requested.
      RELATED
      Enumeration value indicating the two components are visually related and will be placed in the same parent.
      UNRELATED
      Enumeration value indicating the two components are visually unrelated and will be placed in the same parent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static LayoutStyle.ComponentPlacement valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LayoutStyle.ComponentPlacement[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • RELATED

        public static final LayoutStyle.ComponentPlacement RELATED
        Enumeration value indicating the two components are visually related and will be placed in the same parent. For example, a JLabel providing a label for a JTextField is typically visually associated with the JTextField; the constant RELATED is used for this.

      • UNRELATED

        public static final LayoutStyle.ComponentPlacement UNRELATED
        Enumeration value indicating the two components are visually unrelated and will be placed in the same parent. For example, groupings of components are usually visually separated; the constant UNRELATED is used for this.

      • INDENT

        public static final LayoutStyle.ComponentPlacement INDENT
        Enumeration value indicating the distance to indent a component is being requested. For example, often times the children of a label will be horizontally indented from the label. To determine the preferred distance for such a gap use the INDENT type.

        This value is typically only useful with a direction of EAST or WEST.

    • 方法详细信息

      • values

        public static LayoutStyle.ComponentPlacement[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (LayoutStyle.ComponentPlacement c : LayoutStyle.ComponentPlacement.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static LayoutStyle.ComponentPlacement valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n glsadpado/c


ListCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ListCellRenderer<E>

  • 类型参数：
    E - the type of values this renderer can be used for
    All Known Implementing Classes:
    BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer

    public interface ListCellRenderer<E>
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList. For example, to use a JLabel as a ListCellRenderer, you would write something like this:
     class MyCellRenderer extends JLabel implements ListCellRenderer<Object> {
     public MyCellRenderer() {
         setOpaque(true);
     }

     public Component getListCellRendererComponent(JList<?> list,
                                                   Object value,
                                                   int index,
                                                   boolean isSelected,
                                                   boolean cellHasFocus) {

         setText(value.toString());

         Color background;
         Color foreground;

         // check if this cell represents the current DnD drop location
         JList.DropLocation dropLocation = list.getDropLocation();
         if (dropLocation != null
                 && !dropLocation.isInsert()
                 && dropLocation.getIndex() == index) {

             background = Color.BLUE;
             foreground = Color.WHITE;

         // check if this cell is selected
         } else if (isSelected) {
             background = Color.RED;
             foreground = Color.WHITE;

         // unselected, and not the DnD drop location
         } else {
             background = Color.WHITE;
             foreground = Color.BLACK;
         };

         setBackground(background);
         setForeground(foreground);

         return this;
     }
 }
    另请参见：
    JList, DefaultListCellRenderer

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getListCellRendererComponent(JList<? extends E> list, E value, int index, boolean isSelected, boolean cellHasFocus)
      Return a component that has been configured to display the specified value.

    • 方法详细信息

      • getListCellRendererComponent

        Component getListCellRendererComponent(JList<? extends E> list,
                                     E value,
                                     int index,
                                     boolean isSelected,
                                     boolean cellHasFocus)
        Return a component that has been configured to display the specified value. That component's paint method is then called to "render" the cell. If it is necessary to compute the dimensions of a list because the list cells do not have a fixed size, this method is called to generate a component on which getPreferredSize can be invoked.
        参数：
        list - The JList we're painting.
        value - The value returned by list.getModel().getElementAt(index).
        index - The cells index.
        isSelected - True if the specified cell was selected.
        cellHasFocus - True if the specified cell has the focus.
        返回：
        A component whose paint() method will render the specified value.
        另请参见：
        JList, ListSelectionModel, ListModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt m am stt sselppecna tde rialas


ListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ListModel<E>

  • 类型参数：
    E - the type of the elements of this model
    All Known Subinterfaces:
    ComboBoxModel, MutableComboBoxModel
    All Known Implementing Classes:
    AbstractListModel, BasicDirectoryModel, DefaultComboBoxModel, DefaultListModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel

    public interface ListModel<E>
    This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list. Logically the model is a vector, indices vary from 0 to ListDataModel.getSize() - 1. Any change to the contents or length of the data model must be reported to all of the ListDataListeners.
    另请参见：
    JList

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addListDataListener(ListDataListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      E getElementAt(int index)
      Returns the value at the specified index.
      int getSize()
      Returns the length of the list.
      void removeListDataListener(ListDataListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.

    • 方法详细信息

      • getSize

        int getSize()
        Returns the length of the list.
        返回：
        the length of the list

      • getElementAt

        E getElementAt(int index)
        Returns the value at the specified index.
        参数：
        index - the requested index
        返回：
        the value at index

      • addListDataListener

        void addListDataListener(ListDataListener l)
        Adds a listener to the list that's notified each time a change to the data model occurs.
        参数：
        l - the ListDataListener to be added

      • removeListDataListener

        void removeListDataListener(ListDataListener l)
        Removes a listener from the list that's notified each time a change to the data model occurs.
        参数：
        l - the ListDataListener to be removed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iOldmd"dadodtai>te>>np阯b


ListSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface ListSelectionModel

  • All Known Implementing Classes:
    DefaultListSelectionModel

    public interface ListSelectionModel
    This interface represents the current state of the selection for any of the components that display a list of values with stable indices. The selection is modeled as a set of intervals, each interval represents a contiguous range of selected list elements. The methods for modifying the set of selected intervals all take a pair of indices, index0 and index1, that represent a closed interval, i.e. the interval includes both index0 and index1.
    另请参见：
    DefaultListSelectionModel

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int MULTIPLE_INTERVAL_SELECTION
      A value for the selectionMode property: select one or more contiguous ranges of indices at a time.
      static int SINGLE_INTERVAL_SELECTION
      A value for the selectionMode property: select one contiguous range of indices at a time.
      static int SINGLE_SELECTION
      A value for the selectionMode property: select one list index at a time.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addListSelectionListener(ListSelectionListener x)
      Add a listener to the list that's notified each time a change to the selection occurs.
      void addSelectionInterval(int index0, int index1)
      Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
      void clearSelection()
      Change the selection to the empty set.
      int getAnchorSelectionIndex()
      Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
      int getLeadSelectionIndex()
      Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
      int getMaxSelectionIndex()
      Returns the last selected index or -1 if the selection is empty.
      int getMinSelectionIndex()
      Returns the first selected index or -1 if the selection is empty.
      int getSelectionMode()
      Returns the current selection mode.
      boolean getValueIsAdjusting()
      Returns true if the selection is undergoing a series of changes.
      void insertIndexInterval(int index, int length, boolean before)
      Insert length indices beginning before/after index.
      boolean isSelectedIndex(int index)
      Returns true if the specified index is selected.
      boolean isSelectionEmpty()
      Returns true if no indices are selected.
      void removeIndexInterval(int index0, int index1)
      Remove the indices in the interval index0,index1 (inclusive) from the selection model.
      void removeListSelectionListener(ListSelectionListener x)
      Remove a listener from the list that's notified each time a change to the selection occurs.
      void removeSelectionInterval(int index0, int index1)
      Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive.
      void setAnchorSelectionIndex(int index)
      Set the anchor selection index.
      void setLeadSelectionIndex(int index)
      Set the lead selection index.
      void setSelectionInterval(int index0, int index1)
      Changes the selection to be between index0 and index1 inclusive.
      void setSelectionMode(int selectionMode)
      Sets the selection mode.
      void setValueIsAdjusting(boolean valueIsAdjusting)
      Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change.

    • 字段详细信息

      • SINGLE_SELECTION

        static final int SINGLE_SELECTION
        A value for the selectionMode property: select one list index at a time.
        另请参见：
        setSelectionMode(int), Constant Field Values

      • SINGLE_INTERVAL_SELECTION

        static final int SINGLE_INTERVAL_SELECTION
        A value for the selectionMode property: select one contiguous range of indices at a time.
        另请参见：
        setSelectionMode(int), Constant Field Values

      • MULTIPLE_INTERVAL_SELECTION

        static final int MULTIPLE_INTERVAL_SELECTION
        A value for the selectionMode property: select one or more contiguous ranges of indices at a time.
        另请参见：
        setSelectionMode(int), Constant Field Values

    • 方法详细信息

      • setSelectionInterval

        void setSelectionInterval(int index0,
                        int index1)
        Changes the selection to be between index0 and index1 inclusive. index0 doesn't have to be less than or equal to index1.

        In SINGLE_SELECTION selection mode, only the second index is used.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change.

        参数：
        index0 - one end of the interval.
        index1 - other end of the interval
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • addSelectionInterval

        void addSelectionInterval(int index0,
                        int index1)
        Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive. index0 doesn't have to be less than or equal to index1.

        In SINGLE_SELECTION selection mode, this is equivalent to calling setSelectionInterval, and only the second index is used. In SINGLE_INTERVAL_SELECTION selection mode, this method behaves like setSelectionInterval, unless the given interval is immediately adjacent to or overlaps the existing selection, and can therefore be used to grow the selection.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change.

        参数：
        index0 - one end of the interval.
        index1 - other end of the interval
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener), setSelectionInterval(int, int)

      • removeSelectionInterval

        void removeSelectionInterval(int index0,
                           int index1)
        Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive. index0 doesn't have to be less than or equal to index1.

        In SINGLE_INTERVAL_SELECTION selection mode, if the removal would produce two disjoint selections, the removal is extended through the greater end of the selection. For example, if the selection is 0-10 and you supply indices 5,6 (in any order) the resulting selection is 0-4.

        If this represents a change to the current selection, then each ListSelectionListener is notified of the change.

        参数：
        index0 - one end of the interval.
        index1 - other end of the interval
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • getMinSelectionIndex

        int getMinSelectionIndex()
        Returns the first selected index or -1 if the selection is empty.

      • getMaxSelectionIndex

        int getMaxSelectionIndex()
        Returns the last selected index or -1 if the selection is empty.

      • isSelectedIndex

        boolean isSelectedIndex(int index)
        Returns true if the specified index is selected.

      • getAnchorSelectionIndex

        int getAnchorSelectionIndex()
        Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval(). The most recent index0 is considered the "anchor" and the most recent index1 is considered the "lead". Some interfaces display these indices specially, e.g. Windows95 displays the lead index with a dotted yellow outline.
        另请参见：
        getLeadSelectionIndex(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

      • setAnchorSelectionIndex

        void setAnchorSelectionIndex(int index)
        Set the anchor selection index.
        另请参见：
        getAnchorSelectionIndex()

      • getLeadSelectionIndex

        int getLeadSelectionIndex()
        Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().
        另请参见：
        getAnchorSelectionIndex(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

      • setLeadSelectionIndex

        void setLeadSelectionIndex(int index)
        Set the lead selection index.
        另请参见：
        getLeadSelectionIndex()

      • clearSelection

        void clearSelection()
        Change the selection to the empty set. If this represents a change to the current selection then notify each ListSelectionListener.
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)

      • isSelectionEmpty

        boolean isSelectionEmpty()
        Returns true if no indices are selected.

      • insertIndexInterval

        void insertIndexInterval(int index,
                       int length,
                       boolean before)
        Insert length indices beginning before/after index. This is typically called to sync the selection model with a corresponding change in the data model.

      • removeIndexInterval

        void removeIndexInterval(int index0,
                       int index1)
        Remove the indices in the interval index0,index1 (inclusive) from the selection model. This is typically called to sync the selection model width a corresponding change in the data model.

      • setValueIsAdjusting

        void setValueIsAdjusting(boolean valueIsAdjusting)
        Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change. The value of this property is used to initialize the valueIsAdjusting property of the ListSelectionEvents that are generated.

        For example, if the selection is being updated in response to a user drag, this property can be set to true when the drag is initiated and set to false when the drag is finished. During the drag, listeners receive events with a valueIsAdjusting property set to true. At the end of the drag, when the change is finalized, listeners receive an event with the value set to false. Listeners can use this pattern if they wish to update only when a change has been finalized.

        Setting this property to true begins a series of changes that is to be considered part of a single change. When the property is changed back to false, an event is sent out characterizing the entire selection change (if there was one), with the event's valueIsAdjusting property set to false.

        参数：
        valueIsAdjusting - the new value of the property
        另请参见：
        getValueIsAdjusting(), ListSelectionEvent.getValueIsAdjusting()

      • getValueIsAdjusting

        boolean getValueIsAdjusting()
        Returns true if the selection is undergoing a series of changes.
        返回：
        true if the selection is undergoing a series of changes
        另请参见：
        setValueIsAdjusting(boolean)

      • setSelectionMode

        void setSelectionMode(int selectionMode)
        Sets the selection mode. The following list describes the accepted selection modes:
        • ListSelectionModel.SINGLE_SELECTION - Only one list index can be selected at a time. In this mode, setSelectionInterval and addSelectionInterval are equivalent, both replacing the current selection with the index represented by the second argument (the "lead").
        • ListSelectionModel.SINGLE_INTERVAL_SELECTION - Only one contiguous interval can be selected at a time. In this mode, addSelectionInterval behaves like setSelectionInterval (replacing the current selection), unless the given interval is immediately adjacent to or overlaps the existing selection, and can therefore be used to grow it.
        • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - In this mode, there's no restriction on what can be selected.
        抛出：
        IllegalArgumentException - if the selection mode isn't one of those allowed
        另请参见：
        getSelectionMode()

      • getSelectionMode

        int getSelectionMode()
        Returns the current selection mode.
        返回：
        the current selection mode
        另请参见：
        setSelectionMode(int)

      • addListSelectionListener

        void addListSelectionListener(ListSelectionListener x)
        Add a listener to the list that's notified each time a change to the selection occurs.
        参数：
        x - the ListSelectionListener
        另请参见：
        removeListSelectionListener(javax.swing.event.ListSelectionListener),
setSelectionInterval(int, int),
addSelectionInterval(int, int),
removeSelectionInterval(int, int),
clearSelection(),
insertIndexInterval(int, int, boolean),
removeIndexInterval(int, int)

      • removeListSelectionListener

        void removeListSelectionListener(ListSelectionListener x)
        Remove a listener from the list that's notified each time a change to the selection occurs.
        参数：
        x - the ListSelectionListener
        另请参见：
        addListSelectionListener(javax.swing.event.ListSelectionListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


LookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 LookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
  • 直接已知子类：
    BasicLookAndFeel, MultiLookAndFeel

    public abstract class LookAndFeel
extends Object
    LookAndFeel, as the name implies, encapsulates a look and feel. Beyond installing a look and feel most developers never need to interact directly with LookAndFeel. In general only developers creating a custom look and feel need to concern themselves with this class.

    Swing is built upon the foundation that each JComponent subclass has an implementation of a specific ComponentUI subclass. The ComponentUI is often referred to as "the ui", "component ui", or "look and feel delegate". The ComponentUI subclass is responsible for providing the look and feel specific functionality of the component. For example, JTree requires an implementation of the ComponentUI subclass TreeUI. The implementation of the specific ComponentUI subclass is provided by the LookAndFeel. Each JComponent subclass identifies the ComponentUI subclass it requires by way of the JComponent method getUIClassID.

    Each LookAndFeel implementation must provide an implementation of the appropriate ComponentUI subclass by specifying a value for each of Swing's ui class ids in the UIDefaults object returned from getDefaults. For example, BasicLookAndFeel uses BasicTreeUI as the concrete implementation for TreeUI. This is accomplished by BasicLookAndFeel providing the key-value pair "TreeUI"-"javax.swing.plaf.basic.BasicTreeUI", in the UIDefaults returned from getDefaults. Refer to UIDefaults.getUI(JComponent) for defails on how the implementation of the ComponentUI subclass is obtained.

    When a LookAndFeel is installed the UIManager does not check that an entry exists for all ui class ids. As such, random exceptions will occur if the current look and feel has not provided a value for a particular ui class id and an instance of the JComponent subclass is created.

    Recommendations for Look and Feels

    As noted in UIManager each LookAndFeel has the opportunity to provide a set of defaults that are layered in with developer and system defaults. Some of Swing's components require the look and feel to provide a specific set of defaults. These are documented in the classes that require the specific default.

    ComponentUIs and defaults

    All ComponentUIs typically need to set various properties on the JComponent the ComponentUI is providing the look and feel for. This is typically done when the ComponentUI is installed on the JComponent. Setting a property should only be done if the developer has not set the property. For non-primitive values it is recommended that the ComponentUI only change the property on the JComponent if the current value is null or implements UIResource. If the current value is null or implements UIResource it indicates the property has not been set by the developer, and the ui is free to change it. For example, BasicButtonUI.installDefaults only changes the font on the JButton if the return value from button.getFont() is null or implements UIResource. On the other hand if button.getFont() returned a non-null value that did not implement UIResource then BasicButtonUI.installDefaults would not change the JButton's font.

    For primitive values, such as opaque, the method installProperty should be invoked. installProperty only changes the correspoding property if the value has not been changed by the developer.

    ComponentUI implementations should use the various install methods provided by this class as they handle the necessary checking and install the property using the recommended guidelines.

    Exceptions

    All of the install methods provided by LookAndFeel need to access the defaults if the value of the property being changed is null or a UIResource. For example, installing the font does the following:
       JComponent c;
   Font font = c.getFont();
   if (font == null || (font instanceof UIResource)) {
       c.setFont(UIManager.getFont("fontKey"));
   }
    If the font is null or a UIResource, the defaults table is queried with the key fontKey. All of UIDefault's get methods throw a NullPointerException if passed in null. As such, unless otherwise noted each of the various install methods of LookAndFeel throw a NullPointerException if the current value is null or a UIResource and the supplied defaults key is null. In addition, unless otherwise specified all of the install methods throw a NullPointerException if a null component is passed in.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LookAndFeel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      UIDefaults getDefaults()
      Returns the look and feel defaults.
      abstract String getDescription()
      Return a one line description of this look and feel implementation, e.g.
      static Object getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
      Returns the value of the specified system desktop property by invoking Toolkit.getDefaultToolkit().getDesktopProperty().
      Icon getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      abstract String getID()
      Return a string that identifies this look and feel.
      LayoutStyle getLayoutStyle()
      Returns the LayoutStyle for this look and feel.
      abstract String getName()
      Return a short string that identifies this look and feel, e.g.
      boolean getSupportsWindowDecorations()
      Returns true if the LookAndFeel returned RootPaneUI instances support providing Window decorations in a JRootPane.
      void initialize()
      Initializes the look and feel.
      static void installBorder(JComponent c, String defaultBorderName)
      Convenience method for setting a component's border property with a value from the defaults.
      static void installColors(JComponent c, String defaultBgName, String defaultFgName)
      Convenience method for setting a component's foreground and background color properties with values from the defaults.
      static void installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
      Convenience method for setting a component's foreground, background and font properties with values from the defaults.
      static void installProperty(JComponent c, String propertyName, Object propertyValue)
      Convenience method for installing a property with the specified name and value on a component if that property has not already been set by the developer.
      abstract boolean isNativeLookAndFeel()
      If the underlying platform has a "native" look and feel, and this is an implementation of it, return true.
      abstract boolean isSupportedLookAndFeel()
      Return true if the underlying platform supports and or permits this look and feel.
      static void loadKeyBindings(InputMap retMap, Object[] keys)
      Populates an InputMap with the specified bindings.
      static ComponentInputMap makeComponentInputMap(JComponent c, Object[] keys)
      Creates a ComponentInputMapUIResource from keys.
      static Object makeIcon(类<?> baseClass, String gifFile)
      Creates and returns a UIDefault.LazyValue that loads an image.
      static InputMap makeInputMap(Object[] keys)
      Creates a InputMapUIResource from keys.
      static JTextComponent.KeyBinding[] makeKeyBindings(Object[] keyBindingList)
      Convenience method for building an array of KeyBindings.
      void provideErrorFeedback(Component component)
      Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void uninitialize()
      Uninitializes the look and feel.
      static void uninstallBorder(JComponent c)
      Convenience method for uninstalling a border.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • LookAndFeel

        public LookAndFeel()

    • 方法详细信息

      • installColors

        public static void installColors(JComponent c,
                 String defaultBgName,
                 String defaultFgName)
        Convenience method for setting a component's foreground and background color properties with values from the defaults. The properties are only set if the current value is either null or a UIResource.
        参数：
        c - component to set the colors on
        defaultBgName - key for the background
        defaultFgName - key for the foreground
        抛出：
        NullPointerException - as described in exceptions
        另请参见：
        installColorsAndFont(javax.swing.JComponent, java.lang.String, java.lang.String, java.lang.String), UIManager.getColor(java.lang.Object)

      • installColorsAndFont

        public static void installColorsAndFont(JComponent c,
                        String defaultBgName,
                        String defaultFgName,
                        String defaultFontName)
        Convenience method for setting a component's foreground, background and font properties with values from the defaults. The properties are only set if the current value is either null or a UIResource.
        参数：
        c - component set to the colors and font on
        defaultBgName - key for the background
        defaultFgName - key for the foreground
        defaultFontName - key for the font
        抛出：
        NullPointerException - as described in exceptions
        另请参见：
        installColors(javax.swing.JComponent, java.lang.String, java.lang.String),
UIManager.getColor(java.lang.Object),
UIManager.getFont(java.lang.Object)

      • installBorder

        public static void installBorder(JComponent c,
                 String defaultBorderName)
        Convenience method for setting a component's border property with a value from the defaults. The border is only set if the border is null or an instance of UIResource.
        参数：
        c - component to set the border on
        defaultBorderName - key specifying the border
        抛出：
        NullPointerException - as described in exceptions

      • uninstallBorder

        public static void uninstallBorder(JComponent c)
        Convenience method for uninstalling a border. If the border of the component is a UIResource, it is set to null.
        参数：
        c - component to uninstall the border on
        抛出：
        NullPointerException - if c is null

      • installProperty

        public static void installProperty(JComponent c,
                   String propertyName,
                   Object propertyValue)
        Convenience method for installing a property with the specified name and value on a component if that property has not already been set by the developer. This method is intended to be used by ui delegate instances that need to specify a default value for a property of primitive type (boolean, int, ..), but do not wish to override a value set by the client. Since primitive property values cannot be wrapped with the UIResource marker, this method uses private state to determine whether the property has been set by the client.
        参数：
        c - target component to set the property on
        propertyName - name of the property to set
        propertyValue - value of the property
        抛出：
        IllegalArgumentException - if the specified property is not one which can be set using this method
        ClassCastException - if the property value has not been set by the developer and the type does not match the property's type
        NullPointerException - if c is null, or the named property has not been set by the developer and propertyValue is null
        从以下版本开始：
        1.5

      • makeKeyBindings

        public static JTextComponent.KeyBinding[] makeKeyBindings(Object[] keyBindingList)
        Convenience method for building an array of KeyBindings. While this method is not deprecated, developers should instead use ActionMap and InputMap for supplying key bindings.

        This method returns an array of KeyBindings, one for each alternating key-action pair in keyBindingList. A key can either be a String in the format specified by the KeyStroke.getKeyStroke method, or a KeyStroke. The action part of the pair is a String that corresponds to the name of the Action.

        The following example illustrates creating a KeyBinding array from six alternating key-action pairs:

          JTextComponent.KeyBinding[] multilineBindings = makeKeyBindings( new Object[] {
          "UP", DefaultEditorKit.upAction,
        "DOWN", DefaultEditorKit.downAction,
     "PAGE_UP", DefaultEditorKit.pageUpAction,
   "PAGE_DOWN", DefaultEditorKit.pageDownAction,
       "ENTER", DefaultEditorKit.insertBreakAction,
         "TAB", DefaultEditorKit.insertTabAction
  });
        If keyBindingList's length is odd, the last element is ignored.

        Supplying a null value for either the key or action part of the key-action pair results in creating a KeyBinding with the corresponding value null. As other parts of Swing's expect non-null values in a KeyBinding, you should avoid supplying null as either the key or action part of the key-action pair.

        参数：
        keyBindingList - an array of key-action pairs
        返回：
        an array of KeyBindings
        抛出：
        NullPointerException - if keyBindingList is null
        ClassCastException - if the key part of the pair is not a KeyStroke or String, or the action part of the pair is not a String
        另请参见：
        ActionMap, InputMap, KeyStroke.getKeyStroke(char)

      • makeInputMap

        public static InputMap makeInputMap(Object[] keys)
        Creates a InputMapUIResource from keys. This is a convenience method for creating a new InputMapUIResource, invoking loadKeyBindings(map, keys), and returning the InputMapUIResource.
        参数：
        keys - alternating pairs of keystroke-action key pairs as described in loadKeyBindings(javax.swing.InputMap, java.lang.Object[])
        返回：
        newly created and populated InputMapUIResource
        从以下版本开始：
        1.3
        另请参见：
        loadKeyBindings(javax.swing.InputMap, java.lang.Object[])

      • makeComponentInputMap

        public static ComponentInputMap makeComponentInputMap(JComponent c,
                                      Object[] keys)
        Creates a ComponentInputMapUIResource from keys. This is a convenience method for creating a new ComponentInputMapUIResource, invoking loadKeyBindings(map, keys), and returning the ComponentInputMapUIResource.
        参数：
        c - component to create the ComponentInputMapUIResource with
        keys - alternating pairs of keystroke-action key pairs as described in loadKeyBindings(javax.swing.InputMap, java.lang.Object[])
        返回：
        newly created and populated InputMapUIResource
        抛出：
        IllegalArgumentException - if c is null
        从以下版本开始：
        1.3
        另请参见：
        loadKeyBindings(javax.swing.InputMap, java.lang.Object[]), ComponentInputMapUIResource

      • loadKeyBindings

        public static void loadKeyBindings(InputMap retMap,
                   Object[] keys)
        Populates an InputMap with the specified bindings. The bindings are supplied as a list of alternating keystroke-action key pairs. The keystroke is either an instance of KeyStroke, or a String that identifies the KeyStroke for the binding. Refer to KeyStroke.getKeyStroke(String) for the specific format. The action key part of the pair is the key registered in the InputMap for the KeyStroke.

        The following illustrates loading an InputMap with two key-action pairs:

           LookAndFeel.loadKeyBindings(inputMap, new Object[] {
     "control X", "cut",
     "control V", "paste"
   });

        Supplying a null list of bindings (keys) does not change retMap in any way.

        Specifying a null action key results in removing the keystroke's entry from the InputMap. A null keystroke is ignored.

        参数：
        retMap - InputMap to add the key-action pairs to
        keys - bindings to add to retMap
        抛出：
        NullPointerException - if keys is non-null, not empty, and retMap is null
        从以下版本开始：
        1.3
        另请参见：
        KeyStroke.getKeyStroke(String), InputMap

      • makeIcon

        public static Object makeIcon(类<?> baseClass,
              String gifFile)
        Creates and returns a UIDefault.LazyValue that loads an image. The returned value is an implementation of UIDefaults.LazyValue. When createValue is invoked on the returned object, the image is loaded. If the image is non-null, it is then wrapped in an Icon that implements UIResource. The image is loaded using Class.getResourceAsStream(gifFile).

        This method does not check the arguments in any way. It is strongly recommended that non-null values are supplied else exceptions may occur when createValue is invoked on the returned object.

        参数：
        baseClass - 类 used to load the resource
        gifFile - path to the image to load
        返回：
        a UIDefaults.LazyValue; when resolved the LazyValue loads the specified image
        另请参见：
        UIDefaults.LazyValue, Icon, Class.getResourceAsStream(String)

      • getLayoutStyle

        public LayoutStyle getLayoutStyle()
        Returns the LayoutStyle for this look and feel. This never returns null.

        You generally don't use the LayoutStyle from the look and feel, instead use the LayoutStyle method getInstance.

        返回：
        the LayoutStyle for this look and feel
        从以下版本开始：
        1.6
        另请参见：
        LayoutStyle.getInstance()

      • provideErrorFeedback

        public void provideErrorFeedback(Component component)
        Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus. The default implementation beeps. Subclasses that wish different behavior should override this and provide the additional feedback.
        参数：
        component - the Component the error occurred in, may be null indicating the error condition is not directly associated with a Component
        从以下版本开始：
        1.4

      • getDesktopPropertyValue

        public static Object getDesktopPropertyValue(String systemPropertyName,
                             Object fallbackValue)
        Returns the value of the specified system desktop property by invoking Toolkit.getDefaultToolkit().getDesktopProperty(). If the value of the specified property is null, fallbackValue is returned.
        参数：
        systemPropertyName - the name of the system desktop property being queried
        fallbackValue - the object to be returned as the value if the system value is null
        返回：
        the current value of the desktop property
        从以下版本开始：
        1.4
        另请参见：
        Toolkit.getDesktopProperty(java.lang.String)

      • getDisabledIcon

        public Icon getDisabledIcon(JComponent component,
                   Icon icon)
        Returns an Icon with a disabled appearance. This method is used to generate a disabled Icon when one has not been specified. For example, if you create a JButton and only specify an Icon via setIcon this method will be called to generate the disabled Icon. If null is passed as icon this method returns null.

        Some look and feels might not render the disabled Icon, in which case they will ignore this.

        参数：
        component - JComponent that will display the Icon, may be null
        icon - Icon to generate the disabled icon from
        返回：
        disabled Icon, or null if a suitable Icon can not be generated
        从以下版本开始：
        1.5

      • getDisabledSelectedIcon

        public Icon getDisabledSelectedIcon(JComponent component,
                           Icon icon)
        Returns an Icon for use by disabled components that are also selected. This method is used to generate an Icon for components that are in both the disabled and selected states but do not have a specific Icon for this state. For example, if you create a JButton and only specify an Icon via setIcon this method will be called to generate the disabled and selected Icon. If null is passed as icon this methods returns null.

        Some look and feels might not render the disabled and selected Icon, in which case they will ignore this.

        参数：
        component - JComponent that will display the Icon, may be null
        icon - Icon to generate disabled and selected icon from
        返回：
        disabled and selected icon, or null if a suitable Icon can not be generated.
        从以下版本开始：
        1.5

      • getName

        public abstract String getName()
        Return a short string that identifies this look and feel, e.g. "CDE/Motif". This string should be appropriate for a menu item. Distinct look and feels should have different names, e.g. a subclass of MotifLookAndFeel that changes the way a few components are rendered should be called "CDE/Motif My Way"; something that would be useful to a user trying to select a L&F from a list of names.
        返回：
        short identifier for the look and feel

      • getID

        public abstract String getID()
        Return a string that identifies this look and feel. This string will be used by applications/services that want to recognize well known look and feel implementations. Presently the well known names are "Motif", "Windows", "Mac", "Metal". Note that a LookAndFeel derived from a well known superclass that doesn't make any fundamental changes to the look or feel shouldn't override this method.
        返回：
        identifier for the look and feel

      • getDescription

        public abstract String getDescription()
        Return a one line description of this look and feel implementation, e.g. "The CDE/Motif Look and Feel". This string is intended for the user, e.g. in the title of a window or in a ToolTip message.
        返回：
        short description for the look and feel

      • getSupportsWindowDecorations

        public boolean getSupportsWindowDecorations()
        Returns true if the LookAndFeel returned RootPaneUI instances support providing Window decorations in a JRootPane.

        The default implementation returns false, subclasses that support Window decorations should override this and return true.

        返回：
        true if the RootPaneUI instances created by this look and feel support client side decorations
        从以下版本开始：
        1.4
        另请参见：
        JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
JRootPane.setWindowDecorationStyle(int)

      • isNativeLookAndFeel

        public abstract boolean isNativeLookAndFeel()
        If the underlying platform has a "native" look and feel, and this is an implementation of it, return true. For example, when the underlying platform is Solaris running CDE a CDE/Motif look and feel implementation would return true.
        返回：
        true if this look and feel represents the underlying platform look and feel

      • isSupportedLookAndFeel

        public abstract boolean isSupportedLookAndFeel()
        Return true if the underlying platform supports and or permits this look and feel. This method returns false if the look and feel depends on special resources or legal agreements that aren't defined for the current platform.
        返回：
        true if this is a supported look and feel
        另请参见：
        UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • initialize

        public void initialize()
        Initializes the look and feel. While this method is public, it should only be invoked by the UIManager when a look and feel is installed as the current look and feel. This method is invoked before the UIManager invokes getDefaults. This method is intended to perform any initialization for the look and feel. Subclasses should do any one-time setup they need here, rather than in a static initializer, because look and feel class objects may be loaded just to discover that isSupportedLookAndFeel() returns false.
        另请参见：
        uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • uninitialize

        public void uninitialize()
        Uninitializes the look and feel. While this method is public, it should only be invoked by the UIManager when the look and feel is uninstalled. For example, UIManager.setLookAndFeel invokes this when the look and feel is changed.

        Subclasses may choose to free up some resources here.

        另请参见：
        initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • getDefaults

        public UIDefaults getDefaults()
        Returns the look and feel defaults. While this method is public, it should only be invoked by the UIManager when the look and feel is set as the current look and feel and after initialize has been invoked.
        返回：
        the look and feel defaults
        另请参见：
        initialize(),
uninitialize(),
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface MenuElement

  • All Known Implementing Classes:
    BasicComboPopup, BasicInternalFrameTitlePane.SystemMenuBar, JCheckBoxMenuItem, JMenu, JMenuBar, JMenuItem, JPopupMenu, JRadioButtonMenuItem, MetalComboBoxUI.MetalComboPopup

    public interface MenuElement
    Any component that can be placed into a menu should implement this interface. This interface is used by MenuSelectionManager to handle selection and navigation in menu hierarchies.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getComponent()
      This method should return the java.awt.Component used to paint the receiving element.
      MenuElement[] getSubElements()
      This method should return an array containing the sub-elements for the receiving menu element
      void menuSelectionChanged(boolean isIncluded)
      Call by the MenuSelectionManager when the MenuElement is added or remove from the menu selection.
      void processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager)
      Process a key event.
      void processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event.

    • 方法详细信息

      • processMouseEvent

        void processMouseEvent(MouseEvent event,
                     MenuElement[] path,
                     MenuSelectionManager manager)
        Processes a mouse event. event is a MouseEvent with source being the receiving element's component. path is the path of the receiving element in the menu hierarchy including the receiving element itself. manager is the MenuSelectionManager for the menu hierarchy. This method should process the MouseEvent and change the menu selection if necessary by using MenuSelectionManager's API Note: you do not have to forward the event to sub-components. This is done automatically by the MenuSelectionManager.

      • processKeyEvent

        void processKeyEvent(KeyEvent event,
                   MenuElement[] path,
                   MenuSelectionManager manager)
        Process a key event.

      • menuSelectionChanged

        void menuSelectionChanged(boolean isIncluded)
        Call by the MenuSelectionManager when the MenuElement is added or remove from the menu selection.

      • getSubElements

        MenuElement[] getSubElements()
        This method should return an array containing the sub-elements for the receiving menu element
        返回：
        an array of MenuElements

      • getComponent

        Component getComponent()
        This method should return the java.awt.Component used to paint the receiving element. The returned component will be used to convert events and detect if an event is inside a MenuElement's component.
        返回：
        the Component value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a , ,t ,ttpnmmh<<(>.n"pppm


MenuSelectionManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 MenuSelectionManager

  • java.lang.Object
    • javax.swing.MenuSelectionManager

  • public class MenuSelectionManager
extends Object
    A MenuSelectionManager owns the selection in menu hierarchy.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
      protected EventListenerList | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuSelectionManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      void clearSelectedPath()
      Tell the menu selection to close and unselect all the menu components.
      Component componentForPoint(Component source, Point sourcePoint)
      Returns the component in the currently selected path which contains sourcePoint.
      static MenuSelectionManager defaultManager()
      Returns the default menu selection manager.
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this MenuSelectionManager with addChangeListener().
      MenuElement[] getSelectedPath()
      Returns the path to the currently selected menu item
      boolean isComponentPartOfCurrentMenu(Component c)
      Return true if c is part of the currently used menu
      void processKeyEvent(KeyEvent e)
      When a MenuElement receives an event from a KeyListener, it should never process the event directly.
      void processMouseEvent(MouseEvent event)
      When a MenuElement receives an event from a MouseListener, it should never process the event directly.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.
      void setSelectedPath(MenuElement[] path)
      Changes the selection in the menu hierarchy.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per button model instance since the event's only state is the source property. The source of events generated is always "this".

      • listenerList

        protected EventListenerList listenerList

    • 构造方法详细信息

      • MenuSelectionManager

        public MenuSelectionManager()

    • 方法详细信息

      • defaultManager

        public static MenuSelectionManager defaultManager()
        Returns the default menu selection manager.
        返回：
        a MenuSelectionManager object

      • setSelectedPath

        public void setSelectedPath(MenuElement[] path)
        Changes the selection in the menu hierarchy. The elements in the array are sorted in order from the root menu element to the currently selected menu element.

        Note that this method is public but is used by the look and feel engine and should not be called by client applications.

        参数：
        path - an array of MenuElement objects specifying the selected path

      • getSelectedPath

        public MenuElement[] getSelectedPath()
        Returns the path to the currently selected menu item
        返回：
        an array of MenuElement objects representing the selected path

      • clearSelectedPath

        public void clearSelectedPath()
        Tell the menu selection to close and unselect all the menu components. Call this method when a choice has been made

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the button.
        参数：
        l - the listener to add

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the button.
        参数：
        l - the listener to remove

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this MenuSelectionManager with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is created lazily.
        另请参见：
        EventListenerList

      • processMouseEvent

        public void processMouseEvent(MouseEvent event)
        When a MenuElement receives an event from a MouseListener, it should never process the event directly. Instead all MenuElements should call this method with the event.
        参数：
        event - a MouseEvent object

      • componentForPoint

        public Component componentForPoint(Component source,
                          Point sourcePoint)
        Returns the component in the currently selected path which contains sourcePoint.
        参数：
        source - The component in whose coordinate space sourcePoint is given
        sourcePoint - The point which is being tested
        返回：
        The component in the currently selected path which contains sourcePoint (relative to the source component's coordinate space. If sourcePoint is not inside a component on the currently selected path, null is returned.

      • processKeyEvent

        public void processKeyEvent(KeyEvent e)
        When a MenuElement receives an event from a KeyListener, it should never process the event directly. Instead all MenuElements should call this method with the event.
        参数：
        e - a KeyEvent object

      • isComponentPartOfCurrentMenu

        public boolean isComponentPartOfCurrentMenu(Component c)
        Return true if c is part of the currently used menu
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t=Fsi/ug/o/oogvn>襝籧n鄓鯽s


MutableComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface MutableComboBoxModel

  • All Superinterfaces:
    ComboBoxModel, ListModel
    All Known Implementing Classes:
    DefaultComboBoxModel

    public interface MutableComboBoxModel
extends ComboBoxModel
    A mutable version of ComboBoxModel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addElement(Object obj)
      Adds an item at the end of the model.
      void insertElementAt(Object obj, int index)
      Adds an item at a specific index.
      void removeElement(Object obj)
      Removes an item from the model.
      void removeElementAt(int index)
      Removes an item at a specific index.

      • 方法 - 继承于接口 javax.swing.ComboBoxModel

        getSelectedItem, setSelectedItem

      • 方法 - 继承于接口 javax.swing.ListModel

        addListDataListener, getElementAt, getSize, removeListDataListener

    • 方法详细信息

      • addElement

        void addElement(Object obj)
        Adds an item at the end of the model. The implementation of this method should notify all registered ListDataListeners that the item has been added.
        参数：
        obj - the Object to be added

      • removeElement

        void removeElement(Object obj)
        Removes an item from the model. The implementation of this method should should notify all registered ListDataListeners that the item has been removed.
        参数：
        obj - the Object to be removed

      • insertElementAt

        void insertElementAt(Object obj,
                   int index)
        Adds an item at a specific index. The implementation of this method should notify all registered ListDataListeners that the item has been added.
        参数：
        obj - the Object to be added
        index - location to add the object

      • removeElementAt

        void removeElementAt(int index)
        Removes an item at a specific index. The implementation of this method should notify all registered ListDataListeners that the item has been removed.
        参数：
        index - location of object to be removed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"al"fz>fzieeziifcvv/a"j/c>


OverlayLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 OverlayLayout

  • java.lang.Object
    • javax.swing.OverlayLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2, Serializable

    public class OverlayLayout
extends Object
implements LayoutManager2, Serializable
    A layout manager to arrange components over the top of each other. The requested size of the container will be the largest requested size of the children, taking alignment needs into consideration. The alignment is based upon what is needed to properly fit the children in the allocation area. The children will be placed such that their alignment points are all on top of each other.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      OverlayLayout(Container target)
      Constructs a layout manager that performs overlay arrangement of the children.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component comp, Object constraints)
      Adds the specified component to the layout, using the specified constraint object.
      void addLayoutComponent(String name, Component comp)
      Adds the specified component to the layout.
      float getLayoutAlignmentX(Container target)
      Returns the alignment along the x axis for the container.
      float getLayoutAlignmentY(Container target)
      Returns the alignment along the y axis for the container.
      Container getTarget()
      Returns the container that uses this layout manager.
      void invalidateLayout(Container target)
      Indicates a child has changed its layout related information, which causes any cached calculations to be flushed.
      void layoutContainer(Container target)
      Called by the AWT when the specified container needs to be laid out.
      Dimension maximumLayoutSize(Container target)
      Returns the maximum dimensions needed to lay out the components contained in the specified target container.
      Dimension minimumLayoutSize(Container target)
      Returns the minimum dimensions needed to lay out the components contained in the specified target container.
      Dimension preferredLayoutSize(Container target)
      Returns the preferred dimensions for this layout given the components in the specified target container.
      void removeLayoutComponent(Component comp)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OverlayLayout

        @ConstructorProperties(value="target")
public OverlayLayout(Container target)
        Constructs a layout manager that performs overlay arrangement of the children. The layout manager created is dedicated to the given container.
        参数：
        target - the container to do layout against

    • 方法详细信息

      • getTarget

        public final Container getTarget()
        Returns the container that uses this layout manager.
        返回：
        the container that uses this layout manager
        从以下版本开始：
        1.6

      • invalidateLayout

        public void invalidateLayout(Container target)
        Indicates a child has changed its layout related information, which causes any cached calculations to be flushed.
        指定者：
        invalidateLayout in interface LayoutManager2
        参数：
        target - the container

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component comp)
        Adds the specified component to the layout. Used by this class to know when to invalidate layout.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the name of the component
        comp - the the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component comp)
        Removes the specified component from the layout. Used by this class to know when to invalidate layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        comp - the component to remove

      • addLayoutComponent

        public void addLayoutComponent(Component comp,
                      Object constraints)
        Adds the specified component to the layout, using the specified constraint object. Used by this class to know when to invalidate layout.
        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        comp - the component to be added
        constraints - where/how the component is added to the layout.

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container target)
        Returns the preferred dimensions for this layout given the components in the specified target container. Recomputes the layout if it has been invalidated. Factors in the current inset setting returned by getInsets().
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        target - the component which needs to be laid out
        返回：
        a Dimension object containing the preferred dimensions
        另请参见：
        minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container target)
        Returns the minimum dimensions needed to lay out the components contained in the specified target container. Recomputes the layout if it has been invalidated, and factors in the current inset setting.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        target - the component which needs to be laid out
        返回：
        a Dimension object containing the minimum dimensions
        另请参见：
        preferredLayoutSize(java.awt.Container)

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container target)
        Returns the maximum dimensions needed to lay out the components contained in the specified target container. Recomputes the layout if it has been invalidated, and factors in the inset setting returned by getInset.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        参数：
        target - the component that needs to be laid out
        返回：
        a Dimension object containing the maximum dimensions
        另请参见：
        preferredLayoutSize(java.awt.Container)

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container target)
        Returns the alignment along the x axis for the container.
        指定者：
        getLayoutAlignmentX in interface LayoutManager2
        参数：
        target - the container
        返回：
        the alignment >= 0.0f && <= 1.0f

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container target)
        Returns the alignment along the y axis for the container.
        指定者：
        getLayoutAlignmentY in interface LayoutManager2
        参数：
        target - the container
        返回：
        the alignment >= 0.0f && <= 1.0f

      • layoutContainer

        public void layoutContainer(Container target)
        Called by the AWT when the specified container needs to be laid out.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        target - the container to lay out
        抛出：
        AWTError - if the target isn't the container specified to the constructor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�/a觝"i"."=../..el>>rMt""╰t╨av assrsJ&


Painter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface Painter<T>

  • All Known Implementing Classes:
    AbstractRegionPainter

    public interface Painter<T>

    A painting delegate. The Painter interface defines exactly one method, paint. It is used in situations where the developer can change the painting routine of a component without having to resort to subclassing the component. It is also generically useful when doing any form of painting delegation.

    Painters are simply encapsulations of Java2D code and make it fairly trivial to reuse existing Painters or to combine them together. Implementations of this interface are also trivial to write, such that if you can't find a Painter that does what you need, you can write one with minimal effort. Writing a Painter requires knowledge of Java2D.

    A Painter may be created with a type parameter. This type will be expected in the paint method. For example, you may wish to write a Painter that only works with subclasses of Component. In that case, when the Painter is declared, you may declare that it requires a Component, allowing the paint method to be type safe. Ex:

     Painter p = new Painter() {
         public void paint(Graphics2D g, Component c, int width, int height) {
             g.setColor(c.getBackground());
             //and so forth
         }
     }

    This interface makes no guarantees of threadsafety.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paint(Graphics2D g, T object, int width, int height)
      Renders to the given Graphics2D object.

    • 方法详细信息

      • paint

        void paint(Graphics2D g,
         T object,
         int width,
         int height)

        Renders to the given Graphics2D object. Implementations of this method may modify state on the Graphics2D, and are not required to restore that state upon completion. In most cases, it is recommended that the caller pass in a scratch graphics object. The Graphics2D must never be null.

        State on the graphics object may be honored by the paint method, but may not be. For instance, setting the antialiasing rendering hint on the graphics may or may not be respected by the Painter implementation.

        The supplied object parameter acts as an optional configuration argument. For example, it could be of type Component. A Painter that expected it could then read state from that Component and use the state for painting. For example, an implementation may read the backgroundColor and use that.

        Generally, to enhance reusability, most standard Painters ignore this parameter. They can thus be reused in any context. The object may be null. Implementations must not throw a NullPointerException if the object parameter is null.

        Finally, the width and height arguments specify the width and height that the Painter should paint into. More specifically, the specified width and height instruct the painter that it should paint fully within this width and height. Any specified clip on the g param will further constrain the region.

        For example, suppose I have a Painter implementation that draws a gradient. The gradient goes from white to black. It "stretches" to fill the painted region. Thus, if I use this Painter to paint a 500 x 500 region, the far left would be black, the far right would be white, and a smooth gradient would be painted between. I could then, without modification, reuse the Painter to paint a region that is 20x20 in size. This region would also be black on the left, white on the right, and a smooth gradient painted between.

        参数：
        g - The Graphics2D to render to. This must not be null.
        object - an optional configuration parameter. This may be null.
        width - width of the area to paint.
        height - height of the area to paint.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

D ecs/j/sj/a//..eecc/odoue


Popup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Popup

  • java.lang.Object
    • javax.swing.Popup

  • public class Popup
extends Object
    Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy. Popups have a very small life cycle. Once you have obtained a Popup, and hidden it (invoked the hide method), you should no longer invoke any methods on it. This allows the PopupFactory to cache Popups for later use.

    The general contract is that if you need to change the size of the Component, or location of the Popup, you should obtain a new Popup.

    Popup does not descend from Component, rather implementations of Popup are responsible for creating and maintaining their own Components to render the requested Component to the user.

    You typically do not explicitly create an instance of Popup, instead obtain one from a PopupFactory.

    从以下版本开始：
    1.4
    另请参见：
    PopupFactory

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Popup()
      Creates a Popup.
      protected Popup(Component owner, Component contents, int x, int y)
      Creates a Popup for the Component owner containing the Component contents.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void hide()
      Hides and disposes of the Popup.
      void show()
      Makes the Popup visible.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Popup

        protected Popup(Component owner,
     Component contents,
     int x,
     int y)
        Creates a Popup for the Component owner containing the Component contents. owner is used to determine which Window the new Popup will parent the Component the Popup creates to. A null owner implies there is no valid parent. x and y specify the preferred initial location to place the Popup at. Based on screen size, or other paramaters, the Popup may not display at x and y.
        参数：
        owner - Component mouse coordinates are relative to, may be null
        contents - Contents of the Popup
        x - Initial x screen coordinate
        y - Initial y screen coordinate
        抛出：
        IllegalArgumentException - if contents is null

      • Popup

        protected Popup()
        Creates a Popup. This is provided for subclasses.

    • 方法详细信息

      • show

        public void show()
        Makes the Popup visible. If the Popup is currently visible, this has no effect.

      • hide

        public void hide()
        Hides and disposes of the Popup. Once a Popup has been disposed you should no longer invoke methods on it. A disposed Popup may be reclaimed and later used based on the PopupFactory. As such, if you invoke methods on a disposed Popup, indeterminate behavior will result.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=uA O w.d avs=Reteoroailtoo=s<


PopupFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 PopupFactory

  • java.lang.Object
    • javax.swing.PopupFactory

  • public class PopupFactory
extends Object
    PopupFactory, as the name implies, is used to obtain instances of Popups. Popups are used to display a Component above all other Components in a particular containment hierarchy. The general contract is that once you have obtained a Popup from a PopupFactory, you must invoke hide on the Popup. The typical usage is:
       PopupFactory factory = PopupFactory.getSharedInstance();
   Popup popup = factory.getPopup(owner, contents, x, y);
   popup.show();
   ...
   popup.hide();
    从以下版本开始：
    1.4
    另请参见：
    Popup

    • 构造方法摘要

      Constructors
      构造方法与描述
      PopupFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Popup getPopup(Component owner, Component contents, int x, int y)
      Creates a Popup for the Component owner containing the Component contents.
      static PopupFactory getSharedInstance()
      Returns the shared PopupFactory which can be used to obtain Popups.
      static void setSharedInstance(PopupFactory factory)
      Sets the PopupFactory that will be used to obtain Popups.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PopupFactory

        public PopupFactory()

    • 方法详细信息

      • setSharedInstance

        public static void setSharedInstance(PopupFactory factory)
        Sets the PopupFactory that will be used to obtain Popups. This will throw an IllegalArgumentException if factory is null.
        参数：
        factory - Shared PopupFactory
        抛出：
        IllegalArgumentException - if factory is null
        另请参见：
        getPopup(java.awt.Component, java.awt.Component, int, int)

      • getSharedInstance

        public static PopupFactory getSharedInstance()
        Returns the shared PopupFactory which can be used to obtain Popups.
        返回：
        Shared PopupFactory

      • getPopup

        public Popup getPopup(Component owner,
             Component contents,
             int x,
             int y)
               throws IllegalArgumentException
        Creates a Popup for the Component owner containing the Component contents. owner is used to determine which Window the new Popup will parent the Component the Popup creates to. A null owner implies there is no valid parent. x and y specify the preferred initial location to place the Popup at. Based on screen size, or other paramaters, the Popup may not display at x and y.
        参数：
        owner - Component mouse coordinates are relative to, may be null
        contents - Contents of the Popup
        x - Initial x screen coordinate
        y - Initial y screen coordinate
        返回：
        Popup containing Contents
        抛出：
        IllegalArgumentException - if contents is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ldea=e.i>>>>tcp#zarcaao ia l>clne琲h


ProgressMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ProgressMonitor

  • java.lang.Object
    • javax.swing.ProgressMonitor
  • 所有已实现的接口：
    Accessible

    public class ProgressMonitor
extends Object
implements Accessible
    A class to monitor the progress of some operation. If it looks like the operation will take a while, a progress dialog will be popped up. When the ProgressMonitor is created it is given a numeric range and a descriptive string. As the operation progresses, call the setProgress method to indicate how far along the [min,max] range the operation is. Initially, there is no ProgressDialog. After the first millisToDecideToPopup milliseconds (default 500) the progress monitor will predict how long the operation will take. If it is longer than millisToPopup (default 2000, 2 seconds) a ProgressDialog will be popped up.

    From time to time, when the Dialog box is visible, the progress bar will be updated when setProgress is called. setProgress won't always update the progress bar, it will only be done if the amount of progress is visibly significant.

    For further documentation and examples see How to Monitor Progress, a section in The Java Tutorial.

    另请参见：
    ProgressMonitorInputStream

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor implements accessibility support for the ProgressMonitor class.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AccessibleContext accessibleContext
      The AccessibleContext for the ProgressMonitor

    • 构造方法摘要

      Constructors
      构造方法与描述
      ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
      Constructs a graphic object that shows progress, typically by filling in a rectangular bar as the process nears completion.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Indicate that the operation is complete.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext for the ProgressMonitor
      int getMaximum()
      Returns the maximum value -- the higher end of the progress value.
      int getMillisToDecideToPopup()
      Returns the amount of time this object waits before deciding whether or not to popup a progress monitor.
      int getMillisToPopup()
      Returns the amount of time it will take for the popup to appear.
      int getMinimum()
      Returns the minimum value -- the lower end of the progress value.
      String getNote()
      Specifies the additional note that is displayed along with the progress message.
      boolean isCanceled()
      Returns true if the user hits the Cancel button in the progress dialog.
      void setMaximum(int m)
      Specifies the maximum value.
      void setMillisToDecideToPopup(int millisToDecideToPopup)
      Specifies the amount of time to wait before deciding whether or not to popup a progress monitor.
      void setMillisToPopup(int millisToPopup)
      Specifies the amount of time it will take for the popup to appear.
      void setMinimum(int m)
      Specifies the minimum value.
      void setNote(String note)
      Specifies the additional note that is displayed along with the progress message.
      void setProgress(int nv)
      Indicate the progress of the operation being monitored.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • accessibleContext

        protected AccessibleContext accessibleContext
        The AccessibleContext for the ProgressMonitor
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • ProgressMonitor

        public ProgressMonitor(Component parentComponent,
               Object message,
               String note,
               int min,
               int max)
        Constructs a graphic object that shows progress, typically by filling in a rectangular bar as the process nears completion.
        参数：
        parentComponent - the parent component for the dialog box
        message - a descriptive message that will be shown to the user to indicate what operation is being monitored. This does not change as the operation progresses. See the message parameters to methods in JOptionPane.message for the range of values.
        note - a short note describing the state of the operation. As the operation progresses, you can call setNote to change the note displayed. This is used, for example, in operations that iterate through a list of files to show the name of the file being processes. If note is initially null, there will be no note line in the dialog box and setNote will be ineffective
        min - the lower bound of the range
        max - the upper bound of the range
        另请参见：
        JDialog, JOptionPane

    • 方法详细信息

      • setProgress

        public void setProgress(int nv)
        Indicate the progress of the operation being monitored. If the specified value is >= the maximum, the progress monitor is closed.
        参数：
        nv - an int specifying the current value, between the maximum and minimum specified for this component
        另请参见：
        setMinimum(int), setMaximum(int), close()

      • close

        public void close()
        Indicate that the operation is complete. This happens automatically when the value set by setProgress is >= max, but it may be called earlier if the operation ends early.

      • getMinimum

        public int getMinimum()
        Returns the minimum value -- the lower end of the progress value.
        返回：
        an int representing the minimum value
        另请参见：
        setMinimum(int)

      • setMinimum

        public void setMinimum(int m)
        Specifies the minimum value.
        参数：
        m - an int specifying the minimum value
        另请参见：
        getMinimum()

      • getMaximum

        public int getMaximum()
        Returns the maximum value -- the higher end of the progress value.
        返回：
        an int representing the maximum value
        另请参见：
        setMaximum(int)

      • setMaximum

        public void setMaximum(int m)
        Specifies the maximum value.
        参数：
        m - an int specifying the maximum value
        另请参见：
        getMaximum()

      • isCanceled

        public boolean isCanceled()
        Returns true if the user hits the Cancel button in the progress dialog.

      • setMillisToDecideToPopup

        public void setMillisToDecideToPopup(int millisToDecideToPopup)
        Specifies the amount of time to wait before deciding whether or not to popup a progress monitor.
        参数：
        millisToDecideToPopup - an int specifying the time to wait, in milliseconds
        另请参见：
        getMillisToDecideToPopup()

      • getMillisToDecideToPopup

        public int getMillisToDecideToPopup()
        Returns the amount of time this object waits before deciding whether or not to popup a progress monitor.
        另请参见：
        setMillisToDecideToPopup(int)

      • setMillisToPopup

        public void setMillisToPopup(int millisToPopup)
        Specifies the amount of time it will take for the popup to appear. (If the predicted time remaining is less than this time, the popup won't be displayed.)
        参数：
        millisToPopup - an int specifying the time in milliseconds
        另请参见：
        getMillisToPopup()

      • getMillisToPopup

        public int getMillisToPopup()
        Returns the amount of time it will take for the popup to appear.
        另请参见：
        setMillisToPopup(int)

      • setNote

        public void setNote(String note)
        Specifies the additional note that is displayed along with the progress message. Used, for example, to show which file the is currently being copied during a multiple-file copy.
        参数：
        note - a String specifying the note to display
        另请参见：
        getNote()

      • getNote

        public String getNote()
        Specifies the additional note that is displayed along with the progress message.
        返回：
        a String specifying the note to display
        另请参见：
        setNote(java.lang.String)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext for the ProgressMonitor
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        the AccessibleContext for the ProgressMonitor
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

loee"p/ d莍/jft


ProgressMonitor.AccessibleProgressMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ProgressMonitor.AccessibleProgressMonitor

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, AccessibleText, ChangeListener
    封闭类：
    ProgressMonitor

    protected class ProgressMonitor.AccessibleProgressMonitor
extends AccessibleContext
implements AccessibleText, ChangeListener, PropertyChangeListener
    AccessibleProgressMonitor implements accessibility support for the ProgressMonitor class.
    从以下版本开始：
    1.5

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ProgressMonitor.AccessibleProgressMonitor()
      AccessibleProgressMonitor constructor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleComponent getAccessibleComponent()
      Gets the AccessibleComponent associated with this object that has a graphical representation.
      String getAccessibleDescription()
      Gets the accessibleDescription property of this object.
      int getAccessibleIndexInParent()
      Gets the 0-based index of this object in its accessible parent.
      String getAccessibleName()
      Gets the accessibleName property of this object.
      Accessible getAccessibleParent()
      Gets the Accessible parent of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object that supports a Numerical value.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      int getCaretPosition()
      Returns the zero-based offset of the caret.
      AttributeSet getCharacterAttribute(int i)
      Returns the AttributeSet for a given character at a given index
      Rectangle getCharacterBounds(int i)
      Determines the bounding box of the character at the given index into the string.
      int getCharCount()
      Returns the number of characters (valid indicies)
      int getIndexAtPoint(Point p)
      Given a point in local coordinates, return the zero-based index of the character under that Point.
      Locale getLocale()
      Gets the locale of the component.
      String getSelectedText()
      Returns the portion of the text that is selected.
      int getSelectionEnd()
      Returns the end offset within the selected text.
      int getSelectionStart()
      Returns the start offset within the selected text.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProgressMonitor.AccessibleProgressMonitor

        protected ProgressMonitor.AccessibleProgressMonitor()
        AccessibleProgressMonitor constructor

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed. Must not be null.
        抛出：
        NullPointerException - if the parameter is null.

      • getAccessibleName

        public String getAccessibleName()
        Gets the accessibleName property of this object. The accessibleName property of an object is a localized String that designates the purpose of the object. For example, the accessibleName property of a label or button might be the text of the label or button itself. In the case of an object that doesn't display its name, the accessibleName should still be set. For example, in the case of a text field used to enter the name of a city, the accessibleName for the en_US locale could be 'city.'
        重载：
        getAccessibleName in class AccessibleContext
        返回：
        the localized name of the object; null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Gets the accessibleDescription property of this object. The accessibleDescription property of this object is a short localized phrase describing the purpose of the object. For example, in the case of a 'Cancel' button, the accessibleDescription could be 'Ignore changes and close dialog box.'
        重载：
        getAccessibleDescription in class AccessibleContext
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object. The role of the object is the generic purpose or use of the class of this object. For example, the role of a push button is AccessibleRole.PUSH_BUTTON. The roles in AccessibleRole are provided so component developers can pick from a set of predefined roles. This enables assistive technologies to provide a consistent interface to various tweaked subclasses of components (e.g., use AccessibleRole.PUSH_BUTTON for all components that act like a push button) as well as distinguish between sublasses that behave differently (e.g., AccessibleRole.CHECK_BOX for check boxes and AccessibleRole.RADIO_BUTTON for radio buttons).

        Note that the AccessibleRole class is also extensible, so custom component developers can define their own AccessibleRole's if the set of predefined roles is inadequate.

        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of this object. The AccessibleStateSet of an object is composed of a set of unique AccessibleStates. A change in the AccessibleStateSet of an object will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_STATE_PROPERTY property.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleParent

        public Accessible getAccessibleParent()
        Gets the Accessible parent of this object.
        重载：
        getAccessibleParent in class AccessibleContext
        返回：
        the Accessible parent of this object; null if this object does not have an Accessible parent

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Gets the 0-based index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the 0-based index of this object in its parent; -1 if this object does not have an accessible parent.
        另请参见：
        getAccessibleParent(),
getAccessibleChildrenCount(),
getAccessibleChild(int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children of the object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
                 throws IllegalComponentStateException
        Gets the locale of the component. If the component does not have a locale, then the locale of its parent is returned.
        指定者：
        getLocale in class AccessibleContext
        返回：
        this component's locale. If this component does not have a locale, the locale of its parent is returned.
        抛出：
        IllegalComponentStateException - If the Component does not have its own locale and has not yet been added to a containment hierarchy such that the locale can be determined from the containing parent.

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent()
        Gets the AccessibleComponent associated with this object that has a graphical representation.
        重载：
        getAccessibleComponent in class AccessibleContext
        返回：
        AccessibleComponent if supported by object; else return null
        另请参见：
        AccessibleComponent

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Gets the AccessibleValue associated with this object that supports a Numerical value.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        AccessibleValue if supported by object; else return null
        另请参见：
        AccessibleValue

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getIndexAtPoint

        public int getIndexAtPoint(Point p)
        Given a point in local coordinates, return the zero-based index of the character under that Point. If the point is invalid, this method returns -1.
        指定者：
        getIndexAtPoint in interface AccessibleText
        参数：
        p - the Point in local coordinates
        返回：
        the zero-based index of the character under Point p; if Point is invalid return -1.

      • getCharacterBounds

        public Rectangle getCharacterBounds(int i)
        Determines the bounding box of the character at the given index into the string. The bounds are returned in local coordinates. If the index is invalid an empty rectangle is returned.
        指定者：
        getCharacterBounds in interface AccessibleText
        参数：
        i - the index into the String
        返回：
        the screen coordinates of the character's bounding box, if index is invalid return an empty rectangle.

      • getCharCount

        public int getCharCount()
        Returns the number of characters (valid indicies)
        指定者：
        getCharCount in interface AccessibleText
        返回：
        the number of characters

      • getCaretPosition

        public int getCaretPosition()
        Returns the zero-based offset of the caret. Note: That to the right of the caret will have the same index value as the offset (the caret is between two characters).
        指定者：
        getCaretPosition in interface AccessibleText
        返回：
        the zero-based offset of the caret.

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index.
        指定者：
        getAtIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index.
        指定者：
        getAfterIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index.
        指定者：
        getBeforeIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute(int i)
        Returns the AttributeSet for a given character at a given index
        指定者：
        getCharacterAttribute in interface AccessibleText
        参数：
        i - the zero-based index into the text
        返回：
        the AttributeSet of the character

      • getSelectionStart

        public int getSelectionStart()
        Returns the start offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionStart in interface AccessibleText
        返回：
        the index into the text of the start of the selection

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the end offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same.
        指定者：
        getSelectionEnd in interface AccessibleText
        返回：
        the index into teh text of the end of the selection

      • getSelectedText

        public String getSelectedText()
        Returns the portion of the text that is selected.
        指定者：
        getSelectedText in interface AccessibleText
        返回：
        the String portion of the text that is selected
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ProgressMonitorInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ProgressMonitorInputStream

  • java.lang.Object
    • java.io.InputStream
      • java.io.FilterInputStream
        • javax.swing.ProgressMonitorInputStream
  • 所有已实现的接口：
    Closeable, AutoCloseable

    public class ProgressMonitorInputStream
extends FilterInputStream
    Monitors the progress of reading from some InputStream. This ProgressMonitor is normally invoked in roughly this form:
     InputStream in = new BufferedInputStream(
                          new ProgressMonitorInputStream(
                                  parentComponent,
                                  "Reading " + fileName,
                                  new FileInputStream(fileName)));

    This creates a progress monitor to monitor the progress of reading the input stream. If it's taking a while, a ProgressDialog will be popped up to inform the user. If the user hits the Cancel button an InterruptedIOException will be thrown on the next read. All the right cleanup is done when the stream is closed.

    For further documentation and examples see How to Monitor Progress, a section in The Java Tutorial.

    另请参见：
    ProgressMonitor, JOptionPane

    • 字段摘要

      • Fields inherited from class java.io.FilterInputStream

        in

    • 构造方法摘要

      Constructors
      构造方法与描述
      ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
      Constructs an object to monitor the progress of an input stream.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Overrides FilterInputStream.close to close the progress monitor as well as the stream.
      ProgressMonitor getProgressMonitor()
      Get the ProgressMonitor object being used by this stream.
      int read()
      Overrides FilterInputStream.read to update the progress monitor after the read.
      int read(byte[] b)
      Overrides FilterInputStream.read to update the progress monitor after the read.
      int read(byte[] b, int off, int len)
      Overrides FilterInputStream.read to update the progress monitor after the read.
      void reset()
      Overrides FilterInputStream.reset to reset the progress monitor as well as the stream.
      long skip(long n)
      Overrides FilterInputStream.skip to update the progress monitor after the skip.

      • 方法 - 继承于类 java.io.FilterInputStream

        available, mark, markSupported

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProgressMonitorInputStream

        public ProgressMonitorInputStream(Component parentComponent,
                          Object message,
                          InputStream in)
        Constructs an object to monitor the progress of an input stream.
        参数：
        message - Descriptive text to be placed in the dialog box if one is popped up.
        parentComponent - The component triggering the operation being monitored.
        in - The input stream to be monitored.

    • 方法详细信息

      • getProgressMonitor

        public ProgressMonitor getProgressMonitor()
        Get the ProgressMonitor object being used by this stream. Normally this isn't needed unless you want to do something like change the descriptive text partway through reading the file.
        返回：
        the ProgressMonitor object used by this object

      • read

        public int read()
         throws IOException
        Overrides FilterInputStream.read to update the progress monitor after the read.
        重载：
        read in class FilterInputStream
        返回：
        the next byte of data, or -1 if the end of the stream is reached.
        抛出：
        IOException - if an I/O error occurs.
        另请参见：
        FilterInputStream.in

      • read

        public int read(byte[] b)
         throws IOException
        Overrides FilterInputStream.read to update the progress monitor after the read.
        重载：
        read in class FilterInputStream
        参数：
        b - the buffer into which the data is read.
        返回：
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached.
        抛出：
        IOException - if an I/O error occurs.
        另请参见：
        FilterInputStream.read(byte[], int, int)

      • read

        public int read(byte[] b,
       int off,
       int len)
         throws IOException
        Overrides FilterInputStream.read to update the progress monitor after the read.
        重载：
        read in class FilterInputStream
        参数：
        b - the buffer into which the data is read.
        off - the start offset in the destination array b
        len - the maximum number of bytes read.
        返回：
        the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached.
        抛出：
        IOException - if an I/O error occurs.
        另请参见：
        FilterInputStream.in

      • skip

        public long skip(long n)
          throws IOException
        Overrides FilterInputStream.skip to update the progress monitor after the skip.
        重载：
        skip in class FilterInputStream
        参数：
        n - the number of bytes to be skipped.
        返回：
        the actual number of bytes skipped.
        抛出：
        IOException - if the stream does not support seek, or if some other I/O error occurs.

      • close

        public void close()
           throws IOException
        Overrides FilterInputStream.close to close the progress monitor as well as the stream.
        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        重载：
        close in class FilterInputStream
        抛出：
        IOException - if an I/O error occurs.
        另请参见：
        FilterInputStream.in

      • reset

        public void reset()
           throws IOException
        Overrides FilterInputStream.reset to reset the progress monitor as well as the stream.
        重载：
        reset in class FilterInputStream
        抛出：
        IOException - if the stream has not been marked or if the mark has been invalidated.
        另请参见：
        FilterInputStream.in, FilterInputStream.mark(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-ifauierieiddeiigteeloe aiwwelwre,. gg oerhoep


Renderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface Renderer

  • public interface Renderer
    Defines the requirements for an object responsible for "rendering" (displaying) a value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getComponent()
      Returns the component used to render the value.
      void setValue(Object aValue, boolean isSelected)
      Specifies the value to display and whether or not the value should be portrayed as "currently selected".

    • 方法详细信息

      • setValue

        void setValue(Object aValue,
            boolean isSelected)
        Specifies the value to display and whether or not the value should be portrayed as "currently selected".
        参数：
        aValue - an Object object
        isSelected - a boolean

      • getComponent

        Component getComponent()
        Returns the component used to render the value.
        返回：
        the Component responsible for displaying the value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#ertIpinpinttinnen..rFcoctsacc


RepaintManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 RepaintManager

  • java.lang.Object
    • javax.swing.RepaintManager

  • public class RepaintManager
extends Object
    This class manages repaint requests, allowing the number of repaints to be minimized, for example by collapsing multiple requests into a single repaint for members of a component tree.

    As of 1.6 RepaintManager handles repaint requests for Swing's top level components (JApplet, JWindow, JFrame and JDialog). Any calls to repaint on one of these will call into the appropriate addDirtyRegion method.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RepaintManager()
      Create a new RepaintManager instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addDirtyRegion(Applet applet, int x, int y, int w, int h)
      Adds applet to the list of Components that need to be repainted.
      void addDirtyRegion(JComponent c, int x, int y, int w, int h)
      Add a component in the list of components that should be refreshed.
      void addDirtyRegion(Window window, int x, int y, int w, int h)
      Adds window to the list of Components that need to be repainted.
      void addInvalidComponent(JComponent invalidComponent)
      Mark the component as in need of layout and queue a runnable for the event dispatching thread that will validate the components first isValidateRoot() ancestor.
      static RepaintManager currentManager(Component c)
      Return the RepaintManager for the calling thread given a Component.
      static RepaintManager currentManager(JComponent c)
      Return the RepaintManager for the calling thread given a JComponent.
      Rectangle getDirtyRegion(JComponent aComponent)
      Return the current dirty region for a component.
      Dimension getDoubleBufferMaximumSize()
      Returns the maximum double buffer size.
      Image getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
      Return the offscreen buffer that should be used as a double buffer with the component c.
      Image getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
      Return a volatile offscreen buffer that should be used as a double buffer with the specified component c.
      boolean isCompletelyDirty(JComponent aComponent)
      Convenience method that returns true if aComponent will be completely painted during the next paintDirtyRegions().
      boolean isDoubleBufferingEnabled()
      Returns true if this RepaintManager is double buffered.
      void markCompletelyClean(JComponent aComponent)
      Mark a component completely clean.
      void markCompletelyDirty(JComponent aComponent)
      Mark a component completely dirty.
      void paintDirtyRegions()
      Paint all of the components that have been marked dirty.
      void removeInvalidComponent(JComponent component)
      Remove a component from the list of invalid components.
      static void setCurrentManager(RepaintManager aRepaintManager)
      Set the RepaintManager that should be used for the calling thread.
      void setDoubleBufferingEnabled(boolean aFlag)
      Enables or disables double buffering in this RepaintManager.
      void setDoubleBufferMaximumSize(Dimension d)
      Set the maximum double buffer size.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void validateInvalidComponents()
      Validate all of the components that have been marked invalid.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RepaintManager

        public RepaintManager()
        Create a new RepaintManager instance. You rarely call this constructor. directly. To get the default RepaintManager, use RepaintManager.currentManager(JComponent) (normally "this").

    • 方法详细信息

      • currentManager

        public static RepaintManager currentManager(Component c)
        Return the RepaintManager for the calling thread given a Component.
        参数：
        c - a Component -- unused in the default implementation, but could be used by an overridden version to return a different RepaintManager depending on the Component
        返回：
        the RepaintManager object

      • currentManager

        public static RepaintManager currentManager(JComponent c)
        Return the RepaintManager for the calling thread given a JComponent.

        Note: This method exists for backward binary compatibility with earlier versions of the Swing library. It simply returns the result returned by currentManager(Component).

        参数：
        c - a JComponent -- unused
        返回：
        the RepaintManager object

      • setCurrentManager

        public static void setCurrentManager(RepaintManager aRepaintManager)
        Set the RepaintManager that should be used for the calling thread. aRepaintManager will become the current RepaintManager for the calling thread's thread group.
        参数：
        aRepaintManager - the RepaintManager object to use

      • addInvalidComponent

        public void addInvalidComponent(JComponent invalidComponent)
        Mark the component as in need of layout and queue a runnable for the event dispatching thread that will validate the components first isValidateRoot() ancestor.
        另请参见：
        JComponent.isValidateRoot(), removeInvalidComponent(javax.swing.JComponent)

      • removeInvalidComponent

        public void removeInvalidComponent(JComponent component)
        Remove a component from the list of invalid components.
        另请参见：
        addInvalidComponent(javax.swing.JComponent)

      • addDirtyRegion

        public void addDirtyRegion(JComponent c,
                  int x,
                  int y,
                  int w,
                  int h)
        Add a component in the list of components that should be refreshed. If c already has a dirty region, the rectangle (x,y,w,h) will be unioned with the region that should be redrawn.
        参数：
        c - Component to repaint, null results in nothing happening.
        x - X coordinate of the region to repaint
        y - Y coordinate of the region to repaint
        w - Width of the region to repaint
        h - Height of the region to repaint
        另请参见：
        JComponent.repaint(long, int, int, int, int)

      • addDirtyRegion

        public void addDirtyRegion(Window window,
                  int x,
                  int y,
                  int w,
                  int h)
        Adds window to the list of Components that need to be repainted.
        参数：
        window - Window to repaint, null results in nothing happening.
        x - X coordinate of the region to repaint
        y - Y coordinate of the region to repaint
        w - Width of the region to repaint
        h - Height of the region to repaint
        从以下版本开始：
        1.6
        另请参见：
        JFrame.repaint(long, int, int, int, int),
JWindow.repaint(long, int, int, int, int),
JDialog.repaint(long, int, int, int, int)

      • addDirtyRegion

        public void addDirtyRegion(Applet applet,
                  int x,
                  int y,
                  int w,
                  int h)
        Adds applet to the list of Components that need to be repainted.
        参数：
        applet - Applet to repaint, null results in nothing happening.
        x - X coordinate of the region to repaint
        y - Y coordinate of the region to repaint
        w - Width of the region to repaint
        h - Height of the region to repaint
        从以下版本开始：
        1.6
        另请参见：
        JApplet.repaint(long, int, int, int, int)

      • getDirtyRegion

        public Rectangle getDirtyRegion(JComponent aComponent)
        Return the current dirty region for a component. Return an empty rectangle if the component is not dirty.

      • markCompletelyDirty

        public void markCompletelyDirty(JComponent aComponent)
        Mark a component completely dirty. aComponent will be completely painted during the next paintDirtyRegions() call.

      • markCompletelyClean

        public void markCompletelyClean(JComponent aComponent)
        Mark a component completely clean. aComponent will not get painted during the next paintDirtyRegions() call.

      • isCompletelyDirty

        public boolean isCompletelyDirty(JComponent aComponent)
        Convenience method that returns true if aComponent will be completely painted during the next paintDirtyRegions(). If computing dirty regions is expensive for your component, use this method and avoid computing dirty region if it return true.

      • validateInvalidComponents

        public void validateInvalidComponents()
        Validate all of the components that have been marked invalid.
        另请参见：
        addInvalidComponent(javax.swing.JComponent)

      • paintDirtyRegions

        public void paintDirtyRegions()
        Paint all of the components that have been marked dirty.
        另请参见：
        addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object

      • getOffscreenBuffer

        public Image getOffscreenBuffer(Component c,
                       int proposedWidth,
                       int proposedHeight)
        Return the offscreen buffer that should be used as a double buffer with the component c. By default there is a double buffer per RepaintManager. The buffer might be smaller than (proposedWidth,proposedHeight) This happens when the maximum double buffer size as been set for the receiving repaint manager.

      • getVolatileOffscreenBuffer

        public Image getVolatileOffscreenBuffer(Component c,
                               int proposedWidth,
                               int proposedHeight)
        Return a volatile offscreen buffer that should be used as a double buffer with the specified component c. The image returned will be an instance of VolatileImage, or null if a VolatileImage object could not be instantiated. This buffer might be smaller than (proposedWidth,proposedHeight). This happens when the maximum double buffer size has been set for this repaint manager.
        从以下版本开始：
        1.4
        另请参见：
        VolatileImage

      • setDoubleBufferMaximumSize

        public void setDoubleBufferMaximumSize(Dimension d)
        Set the maximum double buffer size.

      • getDoubleBufferMaximumSize

        public Dimension getDoubleBufferMaximumSize()
        Returns the maximum double buffer size.
        返回：
        a Dimension object representing the maximum size

      • setDoubleBufferingEnabled

        public void setDoubleBufferingEnabled(boolean aFlag)
        Enables or disables double buffering in this RepaintManager. CAUTION: The default value for this property is set for optimal paint performance on the given platform and it is not recommended that programs modify this property directly.
        参数：
        aFlag - true to activate double buffering
        另请参见：
        isDoubleBufferingEnabled()

      • isDoubleBufferingEnabled

        public boolean isDoubleBufferingEnabled()
        Returns true if this RepaintManager is double buffered. The default value for this property may vary from platform to platform. On platforms where native double buffering is supported in the AWT, the default value will be false to avoid unnecessary buffering in Swing. On platforms where native double buffering is not supported, the default value will be true.
        返回：
        true if this object is double buffered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RootPaneContainer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface RootPaneContainer

  • All Known Implementing Classes:
    JApplet, JDialog, JFrame, JInternalFrame, JWindow

    public interface RootPaneContainer
    This interface is implemented by components that have a single JRootPane child: JDialog, JFrame, JWindow, JApplet, JInternalFrame. The methods in this interface are just covers for the JRootPane properties, e.g. getContentPane() is generally implemented like this:
         public Container getContentPane() {
         return getRootPane().getContentPane();
     }
    This interface serves as a marker for Swing GUI builders that need to treat components like JFrame, that contain a single JRootPane, specially. For example in a GUI builder, dropping a component on a RootPaneContainer would be interpreted as frame.getContentPane().add(child).

    For conveniance JFrame, JDialog, JWindow, JApplet and JInternalFrame, by default, forward, by default, all calls to the add, remove and setLayout methods, to the contentPane. This means you can call:

     rootPaneContainer.add(component);
    instead of:
     rootPaneContainer.getContentPane().add(component);

    The behavior of the add and setLayout methods for JFrame, JDialog, JWindow, JApplet and JInternalFrame is controlled by the rootPaneCheckingEnabled property. If this property is true (the default), then calls to these methods are forwarded to the contentPane; if false, these methods operate directly on the RootPaneContainer. This property is only intended for subclasses, and is therefore protected.

    另请参见：
    JRootPane, JFrame, JDialog, JWindow, JApplet, JInternalFrame

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Container getContentPane()
      Returns the contentPane.
      Component getGlassPane()
      Returns the glassPane.
      JLayeredPane getLayeredPane()
      Returns the layeredPane.
      JRootPane getRootPane()
      Return this component's single JRootPane child.
      void setContentPane(Container contentPane)
      The "contentPane" is the primary container for application specific components.
      void setGlassPane(Component glassPane)
      The glassPane is always the first child of the rootPane and the rootPanes layout manager ensures that it's always as big as the rootPane.
      void setLayeredPane(JLayeredPane layeredPane)
      A Container that manages the contentPane and in some cases a menu bar.

    • 方法详细信息

      • getRootPane

        JRootPane getRootPane()
        Return this component's single JRootPane child. A conventional implementation of this interface will have all of the other methods indirect through this one. The rootPane has two children: the glassPane and the layeredPane.
        返回：
        this components single JRootPane child.
        另请参见：
        JRootPane

      • setContentPane

        void setContentPane(Container contentPane)
        The "contentPane" is the primary container for application specific components. Applications should add children to the contentPane, set its layout manager, and so on.

        The contentPane may not be null.

        Generally implemented with getRootPane().setContentPane(contentPane);

        参数：
        contentPane - the Container to use for the contents of this JRootPane
        抛出：
        IllegalComponentStateException - (a runtime exception) if the content pane parameter is null
        另请参见：
        JRootPane.getContentPane(), getContentPane()

      • getContentPane

        Container getContentPane()
        Returns the contentPane.
        返回：
        the value of the contentPane property.
        另请参见：
        setContentPane(java.awt.Container)

      • setLayeredPane

        void setLayeredPane(JLayeredPane layeredPane)
        A Container that manages the contentPane and in some cases a menu bar. The layeredPane can be used by descendants that want to add a child to the RootPaneContainer that isn't layout managed. For example an internal dialog or a drag and drop effect component.

        The layeredPane may not be null.

        Generally implemented with

            getRootPane().setLayeredPane(layeredPane);
        抛出：
        IllegalComponentStateException - (a runtime exception) if the layered pane parameter is null
        另请参见：
        getLayeredPane(), JRootPane.getLayeredPane()

      • getLayeredPane

        JLayeredPane getLayeredPane()
        Returns the layeredPane.
        返回：
        the value of the layeredPane property.
        另请参见：
        setLayeredPane(javax.swing.JLayeredPane)

      • setGlassPane

        void setGlassPane(Component glassPane)
        The glassPane is always the first child of the rootPane and the rootPanes layout manager ensures that it's always as big as the rootPane. By default it's transparent and not visible. It can be used to temporarily grab all keyboard and mouse input by adding listeners and then making it visible. by default it's not visible.

        The glassPane may not be null.

        Generally implemented with getRootPane().setGlassPane(glassPane);

        另请参见：
        getGlassPane(), JRootPane.setGlassPane(java.awt.Component)

      • getGlassPane

        Component getGlassPane()
        Returns the glassPane.
        返回：
        the value of the glassPane property.
        另请参见：
        setGlassPane(java.awt.Component)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

adcihd od smm ss:pooci)d<


RowFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 RowFilter<M,I>

  • java.lang.Object
    • javax.swing.RowFilter<M,I>
  • 类型参数：
    M - the type of the model; for example PersonModel
    I - the type of the identifier; when using TableRowSorter this will be Integer

    public abstract class RowFilter<M,I>
extends Object
    RowFilter is used to filter out entries from the model so that they are not shown in the view. For example, a RowFilter associated with a JTable might only allow rows that contain a column with a specific string. The meaning of entry depends on the component type. For example, when a filter is associated with a JTable, an entry corresponds to a row; when associated with a JTree, an entry corresponds to a node.

    Subclasses must override the include method to indicate whether the entry should be shown in the view. The Entry argument can be used to obtain the values in each of the columns in that entry. The following example shows an include method that allows only entries containing one or more values starting with the string "a":

     RowFilter<Object,Object> startsWithAFilter = new RowFilter<Object,Object>() {
   public boolean include(Entry<? extends Object, ? extends Object> entry) {
     for (int i = entry.getValueCount() - 1; i >= 0; i--) {
       if (entry.getStringValue(i).startsWith("a")) {
         // The value starts with "a", include it
         return true;
       }
     }
     // None of the columns start with "a"; return false so that this
     // entry is not shown
     return false;
   }
 };
    RowFilter has two formal type parameters that allow you to create a RowFilter for a specific model. For example, the following assumes a specific model that is wrapping objects of type Person. Only Persons with an age over 20 will be shown:
     RowFilter<PersonModel,Integer> ageFilter = new RowFilter<PersonModel,Integer>() {
   public boolean include(Entry<? extends PersonModel, ? extends Integer> entry) {
     PersonModel personModel = entry.getModel();
     Person person = personModel.getPerson(entry.getIdentifier());
     if (person.getAge() > 20) {
       // Returning true indicates this row should be shown.
       return true;
     }
     // Age is <= 20, don't show it.
     return false;
   }
 };
 PersonModel model = createPersonModel();
 TableRowSorter<PersonModel> sorter = new TableRowSorter<PersonModel>(model);
 sorter.setRowFilter(ageFilter);
    从以下版本开始：
    1.6
    另请参见：
    TableRowSorter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  RowFilter.ComparisonType
      Enumeration of the possible comparison values supported by some of the default RowFilters.
      static class  RowFilter.Entry<M,I>
      An Entry object is passed to instances of RowFilter, allowing the filter to get the value of the entry's data, and thus to determine whether the entry should be shown.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowFilter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static <M,I> RowFilter<M,I> andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if all of the supplied filters include the entry.
      static <M,I> RowFilter<M,I> dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
      Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria.
      abstract boolean include(RowFilter.Entry<? extends M,? extends I> entry)
      Returns true if the specified entry should be shown; returns false if the entry should be hidden.
      static <M,I> RowFilter<M,I> notFilter(RowFilter<M,I> filter)
      Returns a RowFilter that includes entries if the supplied filter does not include the entry.
      static <M,I> RowFilter<M,I> numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
      Returns a RowFilter that includes entries that have at least one Number value meeting the specified criteria.
      static <M,I> RowFilter<M,I> orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if any of the supplied filters includes the entry.
      static <M,I> RowFilter<M,I> regexFilter(String regex, int... indices)
      Returns a RowFilter that uses a regular expression to determine which entries to include.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowFilter

        public RowFilter()

    • 方法详细信息

      • regexFilter

        public static <M,I> RowFilter<M,I> regexFilter(String regex,
                               int... indices)
        Returns a RowFilter that uses a regular expression to determine which entries to include. Only entries with at least one matching value are included. For example, the following creates a RowFilter that includes entries with at least one value starting with "a":
           RowFilter.regexFilter("^a");

        The returned filter uses Matcher.find() to test for inclusion. To test for exact matches use the characters '^' and '$' to match the beginning and end of the string respectively. For example, "^foo$" includes only rows whose string is exactly "foo" and not, for example, "food". See Pattern for a complete description of the supported regular-expression constructs.

        参数：
        regex - the regular expression to filter on
        indices - the indices of the values to check. If not supplied all values are evaluated
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        NullPointerException - if regex is null
        IllegalArgumentException - if any of the indices are < 0
        PatternSyntaxException - if regex is not a valid regular expression.
        另请参见：
        Pattern

      • dateFilter

        public static <M,I> RowFilter<M,I> dateFilter(RowFilter.ComparisonType type,
                              Date date,
                              int... indices)
        Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria. For example, the following RowFilter includes only entries with at least one date value after the current date:
           RowFilter.dateFilter(ComparisonType.AFTER, new Date());
        参数：
        type - the type of comparison to perform
        date - the date to compare against
        indices - the indices of the values to check. If not supplied all values are evaluated
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        NullPointerException - if date is null
        IllegalArgumentException - if any of the indices are < 0 or type is null
        另请参见：
        Calendar, Date

      • numberFilter

        public static <M,I> RowFilter<M,I> numberFilter(RowFilter.ComparisonType type,
                                Number number,
                                int... indices)
        Returns a RowFilter that includes entries that have at least one Number value meeting the specified criteria. For example, the following filter will only include entries with at least one number value equal to 10:
           RowFilter.numberFilter(ComparisonType.EQUAL, 10);
        参数：
        type - the type of comparison to perform
        indices - the indices of the values to check. If not supplied all values are evaluated
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        IllegalArgumentException - if any of the indices are < 0, type is null or number is null

      • orFilter

        public static <M,I> RowFilter<M,I> orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
        Returns a RowFilter that includes entries if any of the supplied filters includes the entry.

        The following example creates a RowFilter that will include any entries containing the string "foo" or the string "bar":

           List<RowFilter<Object,Object>> filters = new ArrayList<RowFilter<Object,Object>>(2);
   filters.add(RowFilter.regexFilter("foo"));
   filters.add(RowFilter.regexFilter("bar"));
   RowFilter<Object,Object> fooBarFilter = RowFilter.orFilter(filters);
        参数：
        filters - the RowFilters to test
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        IllegalArgumentException - if any of the filters are null
        NullPointerException - if filters is null
        另请参见：
        Arrays.asList(T...)

      • andFilter

        public static <M,I> RowFilter<M,I> andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
        Returns a RowFilter that includes entries if all of the supplied filters include the entry.

        The following example creates a RowFilter that will include any entries containing the string "foo" and the string "bar":

           List<RowFilter<Object,Object>> filters = new ArrayList<RowFilter<Object,Object>>(2);
   filters.add(RowFilter.regexFilter("foo"));
   filters.add(RowFilter.regexFilter("bar"));
   RowFilter<Object,Object> fooBarFilter = RowFilter.andFilter(filters);
        参数：
        filters - the RowFilters to test
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        IllegalArgumentException - if any of the filters are null
        NullPointerException - if filters is null
        另请参见：
        Arrays.asList(T...)

      • notFilter

        public static <M,I> RowFilter<M,I> notFilter(RowFilter<M,I> filter)
        Returns a RowFilter that includes entries if the supplied filter does not include the entry.
        参数：
        filter - the RowFilter to negate
        返回：
        a RowFilter implementing the specified criteria
        抛出：
        IllegalArgumentException - if filter is null

      • include

        public abstract boolean include(RowFilter.Entry<? extends M,? extends I> entry)
        Returns true if the specified entry should be shown; returns false if the entry should be hidden.

        The entry argument is valid only for the duration of the invocation. Using entry after the call returns results in undefined behavior.

        参数：
        entry - a non-null object that wraps the underlying object from the model
        返回：
        true if the entry should be shown
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eBge-emeontedEpb< nr祌tsn�;b


RowFilter.ComparisonType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum RowFilter.ComparisonType

  • java.lang.Object
    • java.lang.Enum<RowFilter.ComparisonType>
      • javax.swing.RowFilter.ComparisonType
  • 所有已实现的接口：
    Serializable, Comparable<RowFilter.ComparisonType>
    封闭类：
    RowFilter<M,I>

    public static enum RowFilter.ComparisonType
extends Enum<RowFilter.ComparisonType>
    Enumeration of the possible comparison values supported by some of the default RowFilters.
    从以下版本开始：
    1.6
    另请参见：
    RowFilter

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      AFTER
      Indicates that entries with a value after the supplied value should be included.
      BEFORE
      Indicates that entries with a value before the supplied value should be included.
      EQUAL
      Indicates that entries with a value equal to the supplied value should be included.
      NOT_EQUAL
      Indicates that entries with a value not equal to the supplied value should be included.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static RowFilter.ComparisonType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RowFilter.ComparisonType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • BEFORE

        public static final RowFilter.ComparisonType BEFORE
        Indicates that entries with a value before the supplied value should be included.

      • AFTER

        public static final RowFilter.ComparisonType AFTER
        Indicates that entries with a value after the supplied value should be included.

      • EQUAL

        public static final RowFilter.ComparisonType EQUAL
        Indicates that entries with a value equal to the supplied value should be included.

      • NOT_EQUAL

        public static final RowFilter.ComparisonType NOT_EQUAL
        Indicates that entries with a value not equal to the supplied value should be included.

    • 方法详细信息

      • values

        public static RowFilter.ComparisonType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (RowFilter.ComparisonType c : RowFilter.ComparisonType.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static RowFilter.ComparisonType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iesaea/atedppedd. <


RowFilter.Entry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 RowFilter.Entry<M,I>

  • java.lang.Object
    • javax.swing.RowFilter.Entry<M,I>
  • 类型参数：
    M - the type of the model; for example PersonModel
    I - the type of the identifier; when using TableRowSorter this will be Integer
    封闭类：
    RowFilter<M,I>

    public abstract static class RowFilter.Entry<M,I>
extends Object
    An Entry object is passed to instances of RowFilter, allowing the filter to get the value of the entry's data, and thus to determine whether the entry should be shown. An Entry object contains information about the model as well as methods for getting the underlying values from the model.
    从以下版本开始：
    1.6
    另请参见：
    RowFilter, DefaultRowSorter.setRowFilter(javax.swing.RowFilter)

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowFilter.Entry()
      Creates an Entry.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract I getIdentifier()
      Returns the identifer (in the model) of the entry.
      abstract M getModel()
      Returns the underlying model.
      String getStringValue(int index)
      Returns the string value at the specified index.
      abstract Object getValue(int index)
      Returns the value at the specified index.
      abstract int getValueCount()
      Returns the number of values in the entry.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowFilter.Entry

        public RowFilter.Entry()
        Creates an Entry.

    • 方法详细信息

      • getModel

        public abstract M getModel()
        Returns the underlying model.
        返回：
        the model containing the data that this entry represents

      • getValueCount

        public abstract int getValueCount()
        Returns the number of values in the entry. For example, when used with a table this corresponds to the number of columns.
        返回：
        number of values in the object being filtered

      • getValue

        public abstract Object getValue(int index)
        Returns the value at the specified index. This may return null. When used with a table, index corresponds to the column number in the model.
        参数：
        index - the index of the value to get
        返回：
        value at the specified index
        抛出：
        IndexOutOfBoundsException - if index < 0 or >= getValueCount

      • getStringValue

        public String getStringValue(int index)
        Returns the string value at the specified index. If filtering is being done based on String values this method is preferred to that of getValue as getValue(index).toString() may return a different result than getStringValue(index).

        This implementation calls getValue(index).toString() after checking for null. Subclasses that provide different string conversion should override this method if necessary.

        参数：
        index - the index of the value to get
        返回：
        non-null string at the specified index
        抛出：
        IndexOutOfBoundsException - if index < 0 || >= getValueCount

      • getIdentifier

        public abstract I getIdentifier()
        Returns the identifer (in the model) of the entry. For a table this corresponds to the index of the row in the model, expressed as an Integer.
        返回：
        a model-based (not view-based) identifier for this entry
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.,non noneaionsoobn筢赐


RowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 RowSorter<M>

  • java.lang.Object
    • javax.swing.RowSorter<M>
  • 类型参数：
    M - the type of the underlying model
    直接已知子类：
    DefaultRowSorter

    public abstract class RowSorter<M>
extends Object
    RowSorter provides the basis for sorting and filtering. Beyond creating and installing a RowSorter, you very rarely need to interact with one directly. Refer to TableRowSorter for a concrete implementation of RowSorter for JTable.

    RowSorter's primary role is to provide a mapping between two coordinate systems: that of the view (for example a JTable) and that of the underlying data source, typically a model.

    The view invokes the following methods on the RowSorter:

    • toggleSortOrder — The view invokes this when the appropriate user gesture has occurred to trigger a sort. For example, the user clicked a column header in a table.
    • One of the model change methods — The view invokes a model change method when the underlying model has changed. There may be order dependencies in how the events are delivered, so a RowSorter should not update its mapping until one of these methods is invoked.
    Because the view makes extensive use of the convertRowIndexToModel, convertRowIndexToView and getViewRowCount methods, these methods need to be fast.

    RowSorter provides notification of changes by way of RowSorterListener. Two types of notification are sent:

    • RowSorterEvent.Type.SORT_ORDER_CHANGED — notifies listeners that the sort order has changed. This is typically followed by a notification that the sort has changed.
    • RowSorterEvent.Type.SORTED — notifies listeners that the mapping maintained by the RowSorter has changed in some way.
    RowSorter implementations typically don't have a one-to-one mapping with the underlying model, but they can. For example, if a database does the sorting, toggleSortOrder might call through to the database (on a background thread), and override the mapping methods to return the argument that is passed in.

    Concrete implementations of RowSorter need to reference a model such as TableModel or ListModel. The view classes, such as JTable and JList, will also have a reference to the model. To avoid ordering dependencies, RowSorter implementations should not install a listener on the model. Instead the view class will call into the RowSorter when the model changes. For example, if a row is updated in a TableModel JTable invokes rowsUpdated. When the model changes, the view may call into any of the following methods: modelStructureChanged, allRowsChanged, rowsInserted, rowsDeleted and rowsUpdated.

    从以下版本开始：
    1.6
    另请参见：
    TableRowSorter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  RowSorter.SortKey
      SortKey describes the sort order for a particular column.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSorter()
      Creates a RowSorter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addRowSorterListener(RowSorterListener l)
      Adds a RowSorterListener to receive notification about this RowSorter.
      abstract void allRowsChanged()
      Invoked when the contents of the underlying model have completely changed.
      abstract int convertRowIndexToModel(int index)
      Returns the location of index in terms of the underlying model.
      abstract int convertRowIndexToView(int index)
      Returns the location of index in terms of the view.
      protected void fireRowSorterChanged(int[] lastRowIndexToModel)
      Notifies listener that the mapping has changed.
      protected void fireSortOrderChanged()
      Notifies listener that the sort order has changed.
      abstract M getModel()
      Returns the underlying model.
      abstract int getModelRowCount()
      Returns the number of rows in the underlying model.
      abstract List<? extends RowSorter.SortKey> getSortKeys()
      Returns the current sort keys.
      abstract int getViewRowCount()
      Returns the number of rows in the view.
      abstract void modelStructureChanged()
      Invoked when the underlying model structure has completely changed.
      void removeRowSorterListener(RowSorterListener l)
      Removes a RowSorterListener.
      abstract void rowsDeleted(int firstRow, int endRow)
      Invoked when rows have been deleted from the underlying model in the specified range (inclusive).
      abstract void rowsInserted(int firstRow, int endRow)
      Invoked when rows have been inserted into the underlying model in the specified range (inclusive).
      abstract void rowsUpdated(int firstRow, int endRow)
      Invoked when rows have been changed in the underlying model between the specified range (inclusive).
      abstract void rowsUpdated(int firstRow, int endRow, int column)
      Invoked when the column in the rows have been updated in the underlying model between the specified range.
      abstract void setSortKeys(List<? extends RowSorter.SortKey> keys)
      Sets the current sort keys.
      abstract void toggleSortOrder(int column)
      Reverses the sort order of the specified column.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowSorter

        public RowSorter()
        Creates a RowSorter.

    • 方法详细信息

      • getModel

        public abstract M getModel()
        Returns the underlying model.
        返回：
        the underlying model

      • toggleSortOrder

        public abstract void toggleSortOrder(int column)
        Reverses the sort order of the specified column. It is up to subclasses to provide the exact behavior when invoked. Typically this will reverse the sort order from ascending to descending (or descending to ascending) if the specified column is already the primary sorted column; otherwise, makes the specified column the primary sorted column, with an ascending sort order. If the specified column is not sortable, this method has no effect.

        If this results in changing the sort order and sorting, the appropriate RowSorterListener notification will be sent.

        参数：
        column - the column to toggle the sort ordering of, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model

      • convertRowIndexToModel

        public abstract int convertRowIndexToModel(int index)
        Returns the location of index in terms of the underlying model. That is, for the row index in the coordinates of the view this returns the row index in terms of the underlying model.
        参数：
        index - the row index in terms of the underlying view
        返回：
        row index in terms of the view
        抛出：
        IndexOutOfBoundsException - if index is outside the range of the view

      • convertRowIndexToView

        public abstract int convertRowIndexToView(int index)
        Returns the location of index in terms of the view. That is, for the row index in the coordinates of the underlying model this returns the row index in terms of the view.
        参数：
        index - the row index in terms of the underlying model
        返回：
        row index in terms of the view, or -1 if index has been filtered out of the view
        抛出：
        IndexOutOfBoundsException - if index is outside the range of the model

      • setSortKeys

        public abstract void setSortKeys(List<? extends RowSorter.SortKey> keys)
        Sets the current sort keys.
        参数：
        keys - the new SortKeys; null is a shorthand for specifying an empty list, indicating that the view should be unsorted

      • getSortKeys

        public abstract List<? extends RowSorter.SortKey> getSortKeys()
        Returns the current sort keys. This must return a non-null List and may return an unmodifiable List. If you need to change the sort keys, make a copy of the returned List, mutate the copy and invoke setSortKeys with the new list.
        返回：
        the current sort order

      • getViewRowCount

        public abstract int getViewRowCount()
        Returns the number of rows in the view. If the contents have been filtered this might differ from the row count of the underlying model.
        返回：
        number of rows in the view
        另请参见：
        getModelRowCount()

      • getModelRowCount

        public abstract int getModelRowCount()
        Returns the number of rows in the underlying model.
        返回：
        number of rows in the underlying model
        另请参见：
        getViewRowCount()

      • modelStructureChanged

        public abstract void modelStructureChanged()
        Invoked when the underlying model structure has completely changed. For example, if the number of columns in a TableModel changed, this method would be invoked.

        You normally do not call this method. This method is public to allow view classes to call it.

      • allRowsChanged

        public abstract void allRowsChanged()
        Invoked when the contents of the underlying model have completely changed. The structure of the table is the same, only the contents have changed. This is typically sent when it is too expensive to characterize the change in terms of the other methods.

        You normally do not call this method. This method is public to allow view classes to call it.

      • rowsInserted

        public abstract void rowsInserted(int firstRow,
                int endRow)
        Invoked when rows have been inserted into the underlying model in the specified range (inclusive).

        The arguments give the indices of the effected range. The first argument is in terms of the model before the change, and must be less than or equal to the size of the model before the change. The second argument is in terms of the model after the change and must be less than the size of the model after the change. For example, if you have a 5-row model and add 3 items to the end of the model the indices are 5, 7.

        You normally do not call this method. This method is public to allow view classes to call it.

        参数：
        firstRow - the first row
        endRow - the last row
        抛出：
        IndexOutOfBoundsException - if either argument is invalid, or firstRow > endRow

      • rowsDeleted

        public abstract void rowsDeleted(int firstRow,
               int endRow)
        Invoked when rows have been deleted from the underlying model in the specified range (inclusive).

        The arguments give the indices of the effected range and are in terms of the model before the change. For example, if you have a 5-row model and delete 3 items from the end of the model the indices are 2, 4.

        You normally do not call this method. This method is public to allow view classes to call it.

        参数：
        firstRow - the first row
        endRow - the last row
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the model before the change, or firstRow > endRow

      • rowsUpdated

        public abstract void rowsUpdated(int firstRow,
               int endRow)
        Invoked when rows have been changed in the underlying model between the specified range (inclusive).

        You normally do not call this method. This method is public to allow view classes to call it.

        参数：
        firstRow - the first row, in terms of the underlying model
        endRow - the last row, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the underlying model, or firstRow > endRow

      • rowsUpdated

        public abstract void rowsUpdated(int firstRow,
               int endRow,
               int column)
        Invoked when the column in the rows have been updated in the underlying model between the specified range.

        You normally do not call this method. This method is public to allow view classes to call it.

        参数：
        firstRow - the first row, in terms of the underlying model
        endRow - the last row, in terms of the underlying model
        column - the column that has changed, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if either argument is outside the range of the underlying model after the change, firstRow > endRow, or column is outside the range of the underlying model

      • addRowSorterListener

        public void addRowSorterListener(RowSorterListener l)
        Adds a RowSorterListener to receive notification about this RowSorter. If the same listener is added more than once it will receive multiple notifications. If l is null nothing is done.
        参数：
        l - the RowSorterListener

      • removeRowSorterListener

        public void removeRowSorterListener(RowSorterListener l)
        Removes a RowSorterListener. If l is null nothing is done.
        参数：
        l - the RowSorterListener

      • fireSortOrderChanged

        protected void fireSortOrderChanged()
        Notifies listener that the sort order has changed.

      • fireRowSorterChanged

        protected void fireRowSorterChanged(int[] lastRowIndexToModel)
        Notifies listener that the mapping has changed.
        参数：
        lastRowIndexToModel - the mapping from model indices to view indices prior to the sort, may be null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


RowSorter.SortKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 RowSorter.SortKey

  • java.lang.Object
    • javax.swing.RowSorter.SortKey
  • 封闭类：
    RowSorter<M>

    public static class RowSorter.SortKey
extends Object
    SortKey describes the sort order for a particular column. The column index is in terms of the underlying model, which may differ from that of the view.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSorter.SortKey(int column, SortOrder sortOrder)
      Creates a SortKey for the specified column with the specified sort order.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object o)
      Returns true if this object equals the specified object.
      int getColumn()
      Returns the index of the column.
      SortOrder getSortOrder()
      Returns the sort order of the column.
      int hashCode()
      Returns the hash code for this SortKey.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RowSorter.SortKey

        public RowSorter.SortKey(int column,
                 SortOrder sortOrder)
        Creates a SortKey for the specified column with the specified sort order.
        参数：
        column - index of the column, in terms of the model
        sortOrder - the sorter order
        抛出：
        IllegalArgumentException - if sortOrder is null

    • 方法详细信息

      • getColumn

        public final int getColumn()
        Returns the index of the column.
        返回：
        index of column

      • getSortOrder

        public final SortOrder getSortOrder()
        Returns the sort order of the column.
        返回：
        the sort order of the column

      • hashCode

        public int hashCode()
        Returns the hash code for this SortKey.
        重载：
        hashCode in class Object
        返回：
        hash code
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object o)
        Returns true if this object equals the specified object. If the specified object is a SortKey and references the same column and sort order, the two objects are equal.
        重载：
        equals in class Object
        参数：
        o - the object to compare to
        返回：
        true if o is equal to this SortKey
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


Scrollable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface Scrollable

  • All Known Implementing Classes:
    DefaultTreeCellEditor.DefaultTextField, JEditorPane, JFormattedTextField, JLayer, JList, JPasswordField, JTable, JTextArea, JTextComponent, JTextField, JTextPane, JTree

    public interface Scrollable
    An interface that provides information to a scrolling container like JScrollPane. A complex component that's likely to be used as a viewing a JScrollPane viewport (or other scrolling container) should implement this interface.
    另请参见：
    JViewport, JScrollPane, JScrollBar

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred size of the viewport for a view component.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.
      boolean getScrollableTracksViewportHeight()
      Return true if a viewport should always force the height of this Scrollable to match the height of the viewport.
      boolean getScrollableTracksViewportWidth()
      Return true if a viewport should always force the width of this Scrollable to match the width of the viewport.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

    • 方法详细信息

      • getPreferredScrollableViewportSize

        Dimension getPreferredScrollableViewportSize()
        Returns the preferred size of the viewport for a view component. For example, the preferred size of a JList component is the size required to accommodate all of the cells in its list. However, the value of preferredScrollableViewportSize is the size required for JList.getVisibleRowCount rows. A component without any properties that would affect the viewport size should just return getPreferredSize here.
        返回：
        the preferredSize of a JViewport whose view is this Scrollable
        另请参见：
        JComponent.getPreferredSize()

      • getScrollableUnitIncrement

        int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation. Ideally, components should handle a partially exposed row or column by returning the distance required to completely expose the item.

        Scrolling containers, like JScrollPane, will use this method each time the user requests a unit scroll.

        参数：
        visibleRect - The view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        The "unit" increment for scrolling in the specified direction. This value should always be positive.
        另请参见：
        JScrollBar.setUnitIncrement(int)

      • getScrollableBlockIncrement

        int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

        Scrolling containers, like JScrollPane, will use this method each time the user requests a block scroll.

        参数：
        visibleRect - The view area visible within the viewport
        orientation - Either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
        direction - Less than zero to scroll up/left, greater than zero for down/right.
        返回：
        The "block" increment for scrolling in the specified direction. This value should always be positive.
        另请参见：
        JScrollBar.setBlockIncrement(int)

      • getScrollableTracksViewportWidth

        boolean getScrollableTracksViewportWidth()
        Return true if a viewport should always force the width of this Scrollable to match the width of the viewport. For example a normal text view that supported line wrapping would return true here, since it would be undesirable for wrapped lines to disappear beyond the right edge of the viewport. Note that returning true for a Scrollable whose ancestor is a JScrollPane effectively disables horizontal scrolling.

        Scrolling containers, like JViewport, will use this method each time they are validated.

        返回：
        True if a viewport should force the Scrollables width to match its own.

      • getScrollableTracksViewportHeight

        boolean getScrollableTracksViewportHeight()
        Return true if a viewport should always force the height of this Scrollable to match the height of the viewport. For example a columnar text view that flowed text in left to right columns could effectively disable vertical scrolling by returning true here.

        Scrolling containers, like JViewport, will use this method each time they are validated.

        返回：
        True if a viewport should force the Scrollables height to match its own.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oemple>>e otereat�"iot c.gp


ScrollPaneConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing

Interface ScrollPaneConstants

  • All Known Implementing Classes:
    BasicScrollPaneUI, JScrollPane, MetalScrollPaneUI, ScrollPaneLayout, ScrollPaneLayout.UIResource, SynthScrollPaneUI

    public interface ScrollPaneConstants
    Constants used with the JScrollPane component.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String COLUMN_HEADER
      Identifies the area at the top the viewport between the upper left corner and the upper right corner.
      static String HORIZONTAL_SCROLLBAR
      Identifies a horizonal scrollbar.
      static int HORIZONTAL_SCROLLBAR_ALWAYS
      Used to set the horizontal scroll bar policy so that horizontal scrollbars are always displayed.
      static int HORIZONTAL_SCROLLBAR_AS_NEEDED
      Used to set the horizontal scroll bar policy so that horizontal scrollbars are displayed only when needed.
      static int HORIZONTAL_SCROLLBAR_NEVER
      Used to set the horizontal scroll bar policy so that horizontal scrollbars are never displayed.
      static String HORIZONTAL_SCROLLBAR_POLICY
      Identifies the horizontal scroll bar policy property.
      static String LOWER_LEADING_CORNER
      Identifies the lower leading edge corner of the viewport.
      static String LOWER_LEFT_CORNER
      Identifies the lower left corner of the viewport.
      static String LOWER_RIGHT_CORNER
      Identifies the lower right corner of the viewport.
      static String LOWER_TRAILING_CORNER
      Identifies the lower trailing edge corner of the viewport.
      static String ROW_HEADER
      Identifies the area along the left side of the viewport between the upper left corner and the lower left corner.
      static String UPPER_LEADING_CORNER
      Identifies the upper leading edge corner of the viewport.
      static String UPPER_LEFT_CORNER
      Identifies the upper left corner of the viewport.
      static String UPPER_RIGHT_CORNER
      Identifies the upper right corner of the viewport.
      static String UPPER_TRAILING_CORNER
      Identifies the upper trailing edge corner of the viewport.
      static String VERTICAL_SCROLLBAR
      Identifies a vertical scrollbar.
      static int VERTICAL_SCROLLBAR_ALWAYS
      Used to set the vertical scroll bar policy so that vertical scrollbars are always displayed.
      static int VERTICAL_SCROLLBAR_AS_NEEDED
      Used to set the vertical scroll bar policy so that vertical scrollbars are displayed only when needed.
      static int VERTICAL_SCROLLBAR_NEVER
      Used to set the vertical scroll bar policy so that vertical scrollbars are never displayed.
      static String VERTICAL_SCROLLBAR_POLICY
      Identifies the vertical scroll bar policy property.
      static String VIEWPORT
      Identifies a "viewport" or display area, within which scrolled contents are visible.

    • 字段详细信息

      • VIEWPORT

        static final String VIEWPORT
        Identifies a "viewport" or display area, within which scrolled contents are visible.
        另请参见：
        Constant Field Values

      • VERTICAL_SCROLLBAR

        static final String VERTICAL_SCROLLBAR
        Identifies a vertical scrollbar.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SCROLLBAR

        static final String HORIZONTAL_SCROLLBAR
        Identifies a horizonal scrollbar.
        另请参见：
        Constant Field Values

      • ROW_HEADER

        static final String ROW_HEADER
        Identifies the area along the left side of the viewport between the upper left corner and the lower left corner.
        另请参见：
        Constant Field Values

      • COLUMN_HEADER

        static final String COLUMN_HEADER
        Identifies the area at the top the viewport between the upper left corner and the upper right corner.
        另请参见：
        Constant Field Values

      • LOWER_LEFT_CORNER

        static final String LOWER_LEFT_CORNER
        Identifies the lower left corner of the viewport.
        另请参见：
        Constant Field Values

      • LOWER_RIGHT_CORNER

        static final String LOWER_RIGHT_CORNER
        Identifies the lower right corner of the viewport.
        另请参见：
        Constant Field Values

      • UPPER_LEFT_CORNER

        static final String UPPER_LEFT_CORNER
        Identifies the upper left corner of the viewport.
        另请参见：
        Constant Field Values

      • UPPER_RIGHT_CORNER

        static final String UPPER_RIGHT_CORNER
        Identifies the upper right corner of the viewport.
        另请参见：
        Constant Field Values

      • LOWER_LEADING_CORNER

        static final String LOWER_LEADING_CORNER
        Identifies the lower leading edge corner of the viewport. The leading edge is determined relative to the Scroll Pane's ComponentOrientation property.
        另请参见：
        Constant Field Values

      • LOWER_TRAILING_CORNER

        static final String LOWER_TRAILING_CORNER
        Identifies the lower trailing edge corner of the viewport. The trailing edge is determined relative to the Scroll Pane's ComponentOrientation property.
        另请参见：
        Constant Field Values

      • UPPER_LEADING_CORNER

        static final String UPPER_LEADING_CORNER
        Identifies the upper leading edge corner of the viewport. The leading edge is determined relative to the Scroll Pane's ComponentOrientation property.
        另请参见：
        Constant Field Values

      • UPPER_TRAILING_CORNER

        static final String UPPER_TRAILING_CORNER
        Identifies the upper trailing edge corner of the viewport. The trailing edge is determined relative to the Scroll Pane's ComponentOrientation property.
        另请参见：
        Constant Field Values

      • VERTICAL_SCROLLBAR_POLICY

        static final String VERTICAL_SCROLLBAR_POLICY
        Identifies the vertical scroll bar policy property.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SCROLLBAR_POLICY

        static final String HORIZONTAL_SCROLLBAR_POLICY
        Identifies the horizontal scroll bar policy property.
        另请参见：
        Constant Field Values

      • VERTICAL_SCROLLBAR_AS_NEEDED

        static final int VERTICAL_SCROLLBAR_AS_NEEDED
        Used to set the vertical scroll bar policy so that vertical scrollbars are displayed only when needed.
        另请参见：
        Constant Field Values

      • VERTICAL_SCROLLBAR_NEVER

        static final int VERTICAL_SCROLLBAR_NEVER
        Used to set the vertical scroll bar policy so that vertical scrollbars are never displayed.
        另请参见：
        Constant Field Values

      • VERTICAL_SCROLLBAR_ALWAYS

        static final int VERTICAL_SCROLLBAR_ALWAYS
        Used to set the vertical scroll bar policy so that vertical scrollbars are always displayed.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SCROLLBAR_AS_NEEDED

        static final int HORIZONTAL_SCROLLBAR_AS_NEEDED
        Used to set the horizontal scroll bar policy so that horizontal scrollbars are displayed only when needed.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SCROLLBAR_NEVER

        static final int HORIZONTAL_SCROLLBAR_NEVER
        Used to set the horizontal scroll bar policy so that horizontal scrollbars are never displayed.
        另请参见：
        Constant Field Values

      • HORIZONTAL_SCROLLBAR_ALWAYS

        static final int HORIZONTAL_SCROLLBAR_ALWAYS
        Used to set the horizontal scroll bar policy so that horizontal scrollbars are always displayed.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vm. a o> >n >e--o o"rs苐ll< L�


ScrollPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ScrollPaneLayout

  • java.lang.Object
    • javax.swing.ScrollPaneLayout
  • 所有已实现的接口：
    LayoutManager, Serializable, ScrollPaneConstants
    直接已知子类：
    ScrollPaneLayout.UIResource

    public class ScrollPaneLayout
extends Object
implements LayoutManager, ScrollPaneConstants, Serializable
    The layout manager used by JScrollPane. JScrollPaneLayout is responsible for nine components: a viewport, two scrollbars, a row header, a column header, and four "corner" components.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JScrollPane, JViewport

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  ScrollPaneLayout.UIResource
      The UI resource version of ScrollPaneLayout.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JViewport colHead
      The column header child.
      protected JScrollBar hsb
      The scrollpane's horizontal scrollbar child.
      protected int hsbPolicy
      The display policy for the horizontal scrollbar.
      protected Component lowerLeft
      The component to display in the lower left corner.
      protected Component lowerRight
      The component to display in the lower right corner.
      protected JViewport rowHead
      The row header child.
      protected Component upperLeft
      The component to display in the upper left corner.
      protected Component upperRight
      The component to display in the upper right corner.
      protected JViewport viewport
      The scrollpane's viewport child.
      protected JScrollBar vsb
      The scrollpane's vertical scrollbar child.
      protected int vsbPolicy
      The display policy for the vertical scrollbar.

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScrollPaneLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String s, Component c)
      Adds the specified component to the layout.
      protected Component addSingletonComponent(Component oldC, Component newC)
      Removes an existing component.
      JViewport getColumnHeader()
      Returns the JViewport object that is the column header.
      Component getCorner(String key)
      Returns the Component at the specified corner.
      JScrollBar getHorizontalScrollBar()
      Returns the JScrollBar object that handles horizontal scrolling.
      int getHorizontalScrollBarPolicy()
      Returns the horizontal scrollbar-display policy.
      JViewport getRowHeader()
      Returns the JViewport object that is the row header.
      JScrollBar getVerticalScrollBar()
      Returns the JScrollBar object that handles vertical scrolling.
      int getVerticalScrollBarPolicy()
      Returns the vertical scrollbar-display policy.
      JViewport getViewport()
      Returns the JViewport object that displays the scrollable contents.
      Rectangle getViewportBorderBounds(JScrollPane scrollpane)
      Deprecated.
      As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().
      void layoutContainer(Container parent)
      Lays out the scrollpane.
      Dimension minimumLayoutSize(Container parent)
      The minimum size of a ScrollPane is the size of the insets plus minimum size of the viewport, plus the scrollpane's viewportBorder insets, plus the minimum size of the visible headers, plus the minimum size of the scrollbars whose displayPolicy isn't NEVER.
      Dimension preferredLayoutSize(Container parent)
      The preferred size of a ScrollPane is the size of the insets, plus the preferred size of the viewport, plus the preferred size of the visible headers, plus the preferred size of the scrollbars that will appear given the current view and the current scrollbar displayPolicies.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.
      void setHorizontalScrollBarPolicy(int x)
      Sets the horizontal scrollbar-display policy.
      void setVerticalScrollBarPolicy(int x)
      Sets the vertical scrollbar-display policy.
      void syncWithScrollPane(JScrollPane sp)
      This method is invoked after the ScrollPaneLayout is set as the LayoutManager of a JScrollPane.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • viewport

        protected JViewport viewport
        The scrollpane's viewport child. Default is an empty JViewport.
        另请参见：
        JScrollPane.setViewport(javax.swing.JViewport)

      • vsb

        protected JScrollBar vsb
        The scrollpane's vertical scrollbar child. Default is a JScrollBar.
        另请参见：
        JScrollPane.setVerticalScrollBar(javax.swing.JScrollBar)

      • hsb

        protected JScrollBar hsb
        The scrollpane's horizontal scrollbar child. Default is a JScrollBar.
        另请参见：
        JScrollPane.setHorizontalScrollBar(javax.swing.JScrollBar)

      • rowHead

        protected JViewport rowHead
        The row header child. Default is null.
        另请参见：
        JScrollPane.setRowHeader(javax.swing.JViewport)

      • colHead

        protected JViewport colHead
        The column header child. Default is null.
        另请参见：
        JScrollPane.setColumnHeader(javax.swing.JViewport)

      • lowerLeft

        protected Component lowerLeft
        The component to display in the lower left corner. Default is null.
        另请参见：
        JScrollPane.setCorner(java.lang.String, java.awt.Component)

      • lowerRight

        protected Component lowerRight
        The component to display in the lower right corner. Default is null.
        另请参见：
        JScrollPane.setCorner(java.lang.String, java.awt.Component)

      • upperLeft

        protected Component upperLeft
        The component to display in the upper left corner. Default is null.
        另请参见：
        JScrollPane.setCorner(java.lang.String, java.awt.Component)

      • upperRight

        protected Component upperRight
        The component to display in the upper right corner. Default is null.
        另请参见：
        JScrollPane.setCorner(java.lang.String, java.awt.Component)

      • vsbPolicy

        protected int vsbPolicy
        The display policy for the vertical scrollbar. The default is ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED.

        This field is obsolete, please use the JScrollPane field instead.

        另请参见：
        JScrollPane.setVerticalScrollBarPolicy(int)

      • hsbPolicy

        protected int hsbPolicy
        The display policy for the horizontal scrollbar. The default is ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED.

        This field is obsolete, please use the JScrollPane field instead.

        另请参见：
        JScrollPane.setHorizontalScrollBarPolicy(int)

    • 构造方法详细信息

      • ScrollPaneLayout

        public ScrollPaneLayout()

    • 方法详细信息

      • syncWithScrollPane

        public void syncWithScrollPane(JScrollPane sp)
        This method is invoked after the ScrollPaneLayout is set as the LayoutManager of a JScrollPane. It initializes all of the internal fields that are ordinarily set by addLayoutComponent. For example:
         ScrollPaneLayout mySPLayout = new ScrollPanelLayout() {
     public void layoutContainer(Container p) {
         super.layoutContainer(p);
         // do some extra work here ...
     }
 };
 scrollpane.setLayout(mySPLayout):

      • addSingletonComponent

        protected Component addSingletonComponent(Component oldC,
                              Component newC)
        Removes an existing component. When a new component, such as the left corner, or vertical scrollbar, is added, the old one, if it exists, must be removed.

        This method returns newC. If oldC is not equal to newC and is non-null, it will be removed from its parent.

        参数：
        oldC - the Component to replace
        newC - the Component to add
        返回：
        the newC

      • addLayoutComponent

        public void addLayoutComponent(String s,
                      Component c)
        Adds the specified component to the layout. The layout is identified using one of:
        • ScrollPaneConstants.VIEWPORT
        • ScrollPaneConstants.VERTICAL_SCROLLBAR
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR
        • ScrollPaneConstants.ROW_HEADER
        • ScrollPaneConstants.COLUMN_HEADER
        • ScrollPaneConstants.LOWER_LEFT_CORNER
        • ScrollPaneConstants.LOWER_RIGHT_CORNER
        • ScrollPaneConstants.UPPER_LEFT_CORNER
        • ScrollPaneConstants.UPPER_RIGHT_CORNER
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        s - the component identifier
        c - the the component to be added
        抛出：
        IllegalArgumentException - if s is an invalid key

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to remove

      • getVerticalScrollBarPolicy

        public int getVerticalScrollBarPolicy()
        Returns the vertical scrollbar-display policy.
        返回：
        an integer giving the display policy
        另请参见：
        setVerticalScrollBarPolicy(int)

      • setVerticalScrollBarPolicy

        public void setVerticalScrollBarPolicy(int x)
        Sets the vertical scrollbar-display policy. The options are:
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_NEVER
        • ScrollPaneConstants.VERTICAL_SCROLLBAR_ALWAYS
        Note: Applications should use the JScrollPane version of this method. It only exists for backwards compatibility with the Swing 1.0.2 (and earlier) versions of this class.
        参数：
        x - an integer giving the display policy
        抛出：
        IllegalArgumentException - if x is an invalid vertical scroll bar policy, as listed above

      • getHorizontalScrollBarPolicy

        public int getHorizontalScrollBarPolicy()
        Returns the horizontal scrollbar-display policy.
        返回：
        an integer giving the display policy
        另请参见：
        setHorizontalScrollBarPolicy(int)

      • setHorizontalScrollBarPolicy

        public void setHorizontalScrollBarPolicy(int x)
        Sets the horizontal scrollbar-display policy. The options are:
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_NEVER
        • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_ALWAYS
        Note: Applications should use the JScrollPane version of this method. It only exists for backwards compatibility with the Swing 1.0.2 (and earlier) versions of this class.
        参数：
        x - an int giving the display policy
        抛出：
        IllegalArgumentException - if x is not a valid horizontal scrollbar policy, as listed above

      • getViewport

        public JViewport getViewport()
        Returns the JViewport object that displays the scrollable contents.
        返回：
        the JViewport object that displays the scrollable contents
        另请参见：
        JScrollPane.getViewport()

      • getHorizontalScrollBar

        public JScrollBar getHorizontalScrollBar()
        Returns the JScrollBar object that handles horizontal scrolling.
        返回：
        the JScrollBar object that handles horizontal scrolling
        另请参见：
        JScrollPane.getHorizontalScrollBar()

      • getVerticalScrollBar

        public JScrollBar getVerticalScrollBar()
        Returns the JScrollBar object that handles vertical scrolling.
        返回：
        the JScrollBar object that handles vertical scrolling
        另请参见：
        JScrollPane.getVerticalScrollBar()

      • getRowHeader

        public JViewport getRowHeader()
        Returns the JViewport object that is the row header.
        返回：
        the JViewport object that is the row header
        另请参见：
        JScrollPane.getRowHeader()

      • getColumnHeader

        public JViewport getColumnHeader()
        Returns the JViewport object that is the column header.
        返回：
        the JViewport object that is the column header
        另请参见：
        JScrollPane.getColumnHeader()

      • getCorner

        public Component getCorner(String key)
        Returns the Component at the specified corner.
        参数：
        key - the String specifying the corner
        返回：
        the Component at the specified corner, as defined in ScrollPaneConstants; if key is not one of the four corners, null is returned
        另请参见：
        JScrollPane.getCorner(java.lang.String)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        The preferred size of a ScrollPane is the size of the insets, plus the preferred size of the viewport, plus the preferred size of the visible headers, plus the preferred size of the scrollbars that will appear given the current view and the current scrollbar displayPolicies.

        Note that the rowHeader is calculated as part of the preferred width and the colHeader is calculated as part of the preferred size.

        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the Container that will be laid out
        返回：
        a Dimension object specifying the preferred size of the viewport and any scrollbars
        另请参见：
        ViewportLayout, LayoutManager

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        The minimum size of a ScrollPane is the size of the insets plus minimum size of the viewport, plus the scrollpane's viewportBorder insets, plus the minimum size of the visible headers, plus the minimum size of the scrollbars whose displayPolicy isn't NEVER.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the Container that will be laid out
        返回：
        a Dimension object specifying the minimum size
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container parent)
        Lays out the scrollpane. The positioning of components depends on the following constraints:
        • The row header, if present and visible, gets its preferred width and the viewport's height.
        • The column header, if present and visible, gets its preferred height and the viewport's width.
        • If a vertical scrollbar is needed, i.e. if the viewport's extent height is smaller than its view height or if the displayPolicy is ALWAYS, it's treated like the row header with respect to its dimensions and is made visible.
        • If a horizontal scrollbar is needed, it is treated like the column header (see the paragraph above regarding the vertical scrollbar).
        • If the scrollpane has a non-null viewportBorder, then space is allocated for that.
        • The viewport gets the space available after accounting for the previous constraints.
        • The corner components, if provided, are aligned with the ends of the scrollbars and headers. If there is a vertical scrollbar, the right corners appear; if there is a horizontal scrollbar, the lower corners appear; a row header gets left corners, and a column header gets upper corners.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the Container to lay out

      • getViewportBorderBounds

        @Deprecated
public Rectangle getViewportBorderBounds(JScrollPane scrollpane)
        Deprecated. As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().
        Returns the bounds of the border around the specified scroll pane's viewport.
        返回：
        the size and position of the viewport border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ScrollPaneLayout.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing

类 ScrollPaneLayout.UIResource

  • java.lang.Object
    • javax.swing.ScrollPaneLayout
      • javax.swing.ScrollPaneLayout.UIResource
  • 所有已实现的接口：
    LayoutManager, Serializable, UIResource, ScrollPaneConstants
    封闭类：
    ScrollPaneLayout

    public static class ScrollPaneLayout.UIResource
extends ScrollPaneLayout
implements UIResource
    The UI resource version of ScrollPaneLayout.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.ScrollPaneLayout

        ScrollPaneLayout.UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.ScrollPaneLayout

        colHead, hsb, hsbPolicy, lowerLeft, lowerRight, rowHead, upperLeft, upperRight, viewport, vsb, vsbPolicy

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScrollPaneLayout.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.ScrollPaneLayout

        addLayoutComponent, addSingletonComponent, getColumnHeader, getCorner, getHorizontalScrollBar, getHorizontalScrollBarPolicy, getRowHeader, getVerticalScrollBar, getVerticalScrollBarPolicy, getViewport, getViewportBorderBounds, layoutContainer, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent, setHorizontalScrollBarPolicy, setVerticalScrollBarPolicy, syncWithScrollPane

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ScrollPaneLayout.UIResource

        public ScrollPaneLayout.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/gs.rfaa<>>"k"e>satp"calla/<>"


SingleSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface SingleSelectionModel

  • All Known Implementing Classes:
    DefaultSingleSelectionModel

    public interface SingleSelectionModel
    A model that supports at most one indexed selection.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener listener)
      Adds listener as a listener to changes in the model.
      void clearSelection()
      Clears the selection (to -1).
      int getSelectedIndex()
      Returns the model's selection.
      boolean isSelected()
      Returns true if the selection model currently has a selected value.
      void removeChangeListener(ChangeListener listener)
      Removes listener as a listener to changes in the model.
      void setSelectedIndex(int index)
      Sets the model's selected index to index.

    • 方法详细信息

      • getSelectedIndex

        int getSelectedIndex()
        Returns the model's selection.
        返回：
        the model's selection, or -1 if there is no selection
        另请参见：
        setSelectedIndex(int)

      • setSelectedIndex

        void setSelectedIndex(int index)
        Sets the model's selected index to index. Notifies any listeners if the model changes
        参数：
        index - an int specifying the model selection
        另请参见：
        getSelectedIndex(), addChangeListener(javax.swing.event.ChangeListener)

      • clearSelection

        void clearSelection()
        Clears the selection (to -1).

      • isSelected

        boolean isSelected()
        Returns true if the selection model currently has a selected value.
        返回：
        true if a value is currently selected

      • addChangeListener

        void addChangeListener(ChangeListener listener)
        Adds listener as a listener to changes in the model.
        参数：
        listener - the ChangeListener to add

      • removeChangeListener

        void removeChangeListener(ChangeListener listener)
        Removes listener as a listener to changes in the model.
        参数：
        listener - the ChangeListener to remove
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


SizeRequirements

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SizeRequirements

  • java.lang.Object
    • javax.swing.SizeRequirements
  • 所有已实现的接口：
    Serializable

    public class SizeRequirements
extends Object
implements Serializable
    For the convenience of layout managers, calculates information about the size and position of components. All size and position calculation methods are class methods that take arrays of SizeRequirements as arguments. The SizeRequirements class supports two types of layout:
    tiled
    The components are placed end-to-end, starting either at coordinate 0 (the leftmost or topmost position) or at the coordinate representing the end of the allocated span (the rightmost or bottommost position).
    aligned
    The components are aligned as specified by each component's X or Y alignment value.

    Each SizeRequirements object contains information about either the width (and X alignment) or height (and Y alignment) of a single component or a group of components:

    minimum
    The smallest reasonable width/height of the component or component group, in pixels.
    preferred
    The natural width/height of the component or component group, in pixels.
    maximum
    The largest reasonable width/height of the component or component group, in pixels.
    alignment
    The X/Y alignment of the component or component group.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Component.getMinimumSize(),
Component.getPreferredSize(),
Component.getMaximumSize(),
Component.getAlignmentX(),
Component.getAlignmentY()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      float alignment
      The alignment, specified as a value between 0.0 and 1.0, inclusive.
      int maximum
      The maximum size allowed.
      int minimum
      The minimum size required.
      int preferred
      The preferred (natural) size.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SizeRequirements()
      Creates a SizeRequirements object with the minimum, preferred, and maximum sizes set to zero and an alignment value of 0.5 (centered).
      SizeRequirements(int min, int pref, int max, float a)
      Creates a SizeRequirements object with the specified minimum, preferred, and maximum sizes and the specified alignment.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static int[] adjustSizes(int delta, SizeRequirements[] children)
      Adjust a specified array of sizes by a given amount.
      static void calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal)
      Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static void calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static SizeRequirements getAlignedSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to align a set of components.
      static SizeRequirements getTiledSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to place a set of components end-to-end.
      String toString()
      Returns a string describing the minimum, preferred, and maximum size requirements, along with the alignment.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • minimum

        public int minimum
        The minimum size required. For a component comp, this should be equal to either comp.getMinimumSize().width or comp.getMinimumSize().height.

      • preferred

        public int preferred
        The preferred (natural) size. For a component comp, this should be equal to either comp.getPreferredSize().width or comp.getPreferredSize().height.

      • maximum

        public int maximum
        The maximum size allowed. For a component comp, this should be equal to either comp.getMaximumSize().width or comp.getMaximumSize().height.

      • alignment

        public float alignment
        The alignment, specified as a value between 0.0 and 1.0, inclusive. To specify centering, the alignment should be 0.5.

    • 构造方法详细信息

      • SizeRequirements

        public SizeRequirements()
        Creates a SizeRequirements object with the minimum, preferred, and maximum sizes set to zero and an alignment value of 0.5 (centered).

      • SizeRequirements

        public SizeRequirements(int min,
                int pref,
                int max,
                float a)
        Creates a SizeRequirements object with the specified minimum, preferred, and maximum sizes and the specified alignment.
        参数：
        min - the minimum size >= 0
        pref - the preferred size >= 0
        max - the maximum size >= 0
        a - the alignment >= 0.0f && <= 1.0f

    • 方法详细信息

      • toString

        public String toString()
        Returns a string describing the minimum, preferred, and maximum size requirements, along with the alignment.
        重载：
        toString in class Object
        返回：
        the string

      • getTiledSizeRequirements

        public static SizeRequirements getTiledSizeRequirements(SizeRequirements[] children)
        Determines the total space necessary to place a set of components end-to-end. The needs of each component in the set are represented by an entry in the passed-in SizeRequirements array. The returned SizeRequirements object has an alignment of 0.5 (centered). The space requirement is never more than Integer.MAX_VALUE.
        参数：
        children - the space requirements for a set of components. The vector may be of zero length, which will result in a default SizeRequirements object instance being passed back.
        返回：
        the total space requirements.

      • getAlignedSizeRequirements

        public static SizeRequirements getAlignedSizeRequirements(SizeRequirements[] children)
        Determines the total space necessary to align a set of components. The needs of each component in the set are represented by an entry in the passed-in SizeRequirements array. The total space required will never be more than Integer.MAX_VALUE.
        参数：
        children - the set of child requirements. If of zero length, the returns result will be a default instance of SizeRequirements.
        返回：
        the total space requirements.

      • calculateTiledPositions

        public static void calculateTiledPositions(int allocated,
                           SizeRequirements total,
                           SizeRequirements[] children,
                           int[] offsets,
                           int[] spans)
        Creates a set of offset/span pairs representing how to lay out a set of components end-to-end. This method requires that you specify the total amount of space to be allocated, the size requirements for each component to be placed (specified as an array of SizeRequirements), and the total size requirement of the set of components. You can get the total size requirement by invoking the getTiledSizeRequirements method. The components will be tiled in the forward direction with offsets increasing from 0.
        参数：
        allocated - the total span to be allocated >= 0.
        total - the total of the children requests. This argument is optional and may be null.
        children - the size requirements for each component.
        offsets - the offset from 0 for each child where the spans were allocated (determines placement of the span).
        spans - the span allocated for each child to make the total target span.

      • calculateTiledPositions

        public static void calculateTiledPositions(int allocated,
                           SizeRequirements total,
                           SizeRequirements[] children,
                           int[] offsets,
                           int[] spans,
                           boolean forward)
        Creates a set of offset/span pairs representing how to lay out a set of components end-to-end. This method requires that you specify the total amount of space to be allocated, the size requirements for each component to be placed (specified as an array of SizeRequirements), and the total size requirement of the set of components. You can get the total size requirement by invoking the getTiledSizeRequirements method. This method also requires a flag indicating whether components should be tiled in the forward direction (offsets increasing from 0) or reverse direction (offsets decreasing from the end of the allocated space). The forward direction represents components tiled from left to right or top to bottom. The reverse direction represents components tiled from right to left or bottom to top.
        参数：
        allocated - the total span to be allocated >= 0.
        total - the total of the children requests. This argument is optional and may be null.
        children - the size requirements for each component.
        offsets - the offset from 0 for each child where the spans were allocated (determines placement of the span).
        spans - the span allocated for each child to make the total target span.
        forward - tile with offsets increasing from 0 if true and with offsets decreasing from the end of the allocated space if false.
        从以下版本开始：
        1.4

      • calculateAlignedPositions

        public static void calculateAlignedPositions(int allocated,
                             SizeRequirements total,
                             SizeRequirements[] children,
                             int[] offsets,
                             int[] spans)
        Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments. The resulting span allocations will overlap, with each one fitting as well as possible into the given total allocation. This method requires that you specify the total amount of space to be allocated, the size requirements for each component to be placed (specified as an array of SizeRequirements), and the total size requirements of the set of components (only the alignment field of which is actually used). You can get the total size requirement by invoking getAlignedSizeRequirements. Normal alignment will be done with an alignment value of 0.0f representing the left/top edge of a component.
        参数：
        allocated - the total span to be allocated >= 0.
        total - the total of the children requests.
        children - the size requirements for each component.
        offsets - the offset from 0 for each child where the spans were allocated (determines placement of the span).
        spans - the span allocated for each child to make the total target span.

      • calculateAlignedPositions

        public static void calculateAlignedPositions(int allocated,
                             SizeRequirements total,
                             SizeRequirements[] children,
                             int[] offsets,
                             int[] spans,
                             boolean normal)
        Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments. The resulting span allocations will overlap, with each one fitting as well as possible into the given total allocation. This method requires that you specify the total amount of space to be allocated, the size requirements for each component to be placed (specified as an array of SizeRequirements), and the total size requirements of the set of components (only the alignment field of which is actually used) You can get the total size requirement by invoking getAlignedSizeRequirements. This method also requires a flag indicating whether normal or reverse alignment should be performed. With normal alignment the value 0.0f represents the left/top edge of the component to be aligned. With reverse alignment, 0.0f represents the right/bottom edge.
        参数：
        allocated - the total span to be allocated >= 0.
        total - the total of the children requests.
        children - the size requirements for each component.
        offsets - the offset from 0 for each child where the spans were allocated (determines placement of the span).
        spans - the span allocated for each child to make the total target span.
        normal - when true, the alignment value 0.0f means left/top; when false, it means right/bottom.
        从以下版本开始：
        1.4

      • adjustSizes

        public static int[] adjustSizes(int delta,
                SizeRequirements[] children)
        Adjust a specified array of sizes by a given amount.
        参数：
        delta - an int specifying the size difference
        children - an array of SizeRequirements objects
        返回：
        an array of ints containing the final size for each item
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N


SizeSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SizeSequence

  • java.lang.Object
    • javax.swing.SizeSequence

  • public class SizeSequence
extends Object
    A SizeSequence object efficiently maintains an ordered list of sizes and corresponding positions. One situation for which SizeSequence might be appropriate is in a component that displays multiple rows of unequal size. In this case, a single SizeSequence object could be used to track the heights and Y positions of all rows.

    Another example would be a multi-column component, such as a JTable, in which the column sizes are not all equal. The JTable might use a single SizeSequence object to store the widths and X positions of all the columns. The JTable could then use the SizeSequence object to find the column corresponding to a certain position. The JTable could update the SizeSequence object whenever one or more column sizes changed.

    The following figure shows the relationship between size and position data for a multi-column component.

    The first item begins at position 0, the second at the position equal to the size of the previous item, and so on.

    In the figure, the first index (0) corresponds to the first column, the second index (1) to the second column, and so on. The first column's position starts at 0, and the column occupies size0 pixels, where size0 is the value returned by getSize(0). Thus, the first column ends at size0 - 1. The second column then begins at the position size0 and occupies size1 (getSize(1)) pixels.

    Note that a SizeSequence object simply represents intervals along an axis. In our examples, the intervals represent height or width in pixels. However, any other unit of measure (for example, time in days) could be just as valid.

    Implementation Notes

    Normally when storing the size and position of entries, one would choose between storing the sizes or storing their positions instead. The two common operations that are needed during rendering are: getIndex(position) and setSize(index, size). Whichever choice of internal format is made one of these operations is costly when the number of entries becomes large. If sizes are stored, finding the index of the entry that encloses a particular position is linear in the number of entries. If positions are stored instead, setting the size of an entry at a particular index requires updating the positions of the affected entries, which is also a linear calculation.

    Like the above techniques this class holds an array of N integers internally but uses a hybrid encoding, which is halfway between the size-based and positional-based approaches. The result is a data structure that takes the same space to store the information but can perform most operations in Log(N) time instead of O(N), where N is the number of entries in the list.

    Two operations that remain O(N) in the number of entries are the insertEntries and removeEntries methods, both of which are implemented by converting the internal array to a set of integer sizes, copying it into the new array, and then reforming the hybrid representation in place.

    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      SizeSequence()
      Creates a new SizeSequence object that contains no entries.
      SizeSequence(int numEntries)
      Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size 0.
      SizeSequence(int[] sizes)
      Creates a new SizeSequence object that contains the specified sizes.
      SizeSequence(int numEntries, int value)
      Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIndex(int position)
      Returns the index of the entry that corresponds to the specified position.
      int getPosition(int index)
      Returns the start position for the specified entry.
      int getSize(int index)
      Returns the size of the specified entry.
      int[] getSizes()
      Returns the size of all entries.
      void insertEntries(int start, int length, int value)
      Adds a contiguous group of entries to this SizeSequence.
      void removeEntries(int start, int length)
      Removes a contiguous group of entries from this SizeSequence.
      void setSize(int index, int size)
      Sets the size of the specified entry.
      void setSizes(int[] sizes)
      Resets this SizeSequence object, using the data in the sizes argument.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SizeSequence

        public SizeSequence()
        Creates a new SizeSequence object that contains no entries. To add entries, you can use insertEntries or setSizes.
        另请参见：
        insertEntries(int, int, int), setSizes(int[])

      • SizeSequence

        public SizeSequence(int numEntries)
        Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size 0.
        参数：
        numEntries - the number of sizes to track
        抛出：
        NegativeArraySizeException - if numEntries < 0

      • SizeSequence

        public SizeSequence(int numEntries,
            int value)
        Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size value.
        参数：
        numEntries - the number of sizes to track
        value - the initial value of each size

      • SizeSequence

        public SizeSequence(int[] sizes)
        Creates a new SizeSequence object that contains the specified sizes.
        参数：
        sizes - the array of sizes to be contained in the SizeSequence

    • 方法详细信息

      • setSizes

        public void setSizes(int[] sizes)
        Resets this SizeSequence object, using the data in the sizes argument. This method reinitializes this object so that it contains as many entries as the sizes array. Each entry's size is initialized to the value of the corresponding item in sizes.
        参数：
        sizes - the array of sizes to be contained in this SizeSequence

      • getSizes

        public int[] getSizes()
        Returns the size of all entries.
        返回：
        a new array containing the sizes in this object

      • getPosition

        public int getPosition(int index)
        Returns the start position for the specified entry. For example, getPosition(0) returns 0, getPosition(1) is equal to getSize(0), getPosition(2) is equal to getSize(0) + getSize(1), and so on.

        Note that if index is greater than length the value returned may be meaningless.

        参数：
        index - the index of the entry whose position is desired
        返回：
        the starting position of the specified entry

      • getIndex

        public int getIndex(int position)
        Returns the index of the entry that corresponds to the specified position. For example, getIndex(0) is 0, since the first entry always starts at position 0.
        参数：
        position - the position of the entry
        返回：
        the index of the entry that occupies the specified position

      • getSize

        public int getSize(int index)
        Returns the size of the specified entry. If index is out of the range (0 <= index < getSizes().length) the behavior is unspecified.
        参数：
        index - the index corresponding to the entry
        返回：
        the size of the entry

      • setSize

        public void setSize(int index,
           int size)
        Sets the size of the specified entry. Note that if the value of index does not fall in the range: (0 <= index < getSizes().length) the behavior is unspecified.
        参数：
        index - the index corresponding to the entry
        size - the size of the entry

      • insertEntries

        public void insertEntries(int start,
                 int length,
                 int value)
        Adds a contiguous group of entries to this SizeSequence. Note that the values of start and length must satisfy the following conditions: (0 <= start < getSizes().length) AND (length >= 0). If these conditions are not met, the behavior is unspecified and an exception may be thrown.
        参数：
        start - the index to be assigned to the first entry in the group
        length - the number of entries in the group
        value - the size to be assigned to each new entry
        抛出：
        ArrayIndexOutOfBoundsException - if the parameters are outside of the range: (0 <= start < (getSizes().length)) AND (length >= 0)

      • removeEntries

        public void removeEntries(int start,
                 int length)
        Removes a contiguous group of entries from this SizeSequence. Note that the values of start and length must satisfy the following conditions: (0 <= start < getSizes().length) AND (length >= 0). If these conditions are not met, the behavior is unspecified and an exception may be thrown.
        参数：
        start - the index of the first entry to be removed
        length - the number of entries to be removed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a&ree>Re>"SS>""sntt "wziesst a.e


SortingFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SortingFocusTraversalPolicy

  • java.lang.Object
    • java.awt.FocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
  • 直接已知子类：
    LayoutFocusTraversalPolicy

    public class SortingFocusTraversalPolicy
extends InternalFrameFocusTraversalPolicy
    A FocusTraversalPolicy that determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator. Portions of the Component hierarchy that are not visible and displayable will not be included.

    By default, SortingFocusTraversalPolicy implicitly transfers focus down- cycle. That is, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This behavior can be disabled using the setImplicitDownCycleTraversal method.

    By default, methods of this class with return a Component only if it is visible, displayable, enabled, and focusable. Subclasses can modify this behavior by overriding the accept method.

    This policy takes into account focus traversal policy providers. When searching for first/last/next/previous Component, if a focus traversal policy provider is encountered, its focus traversal policy is used to perform the search operation.

    从以下版本开始：
    1.4
    另请参见：
    Comparator

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SortingFocusTraversalPolicy()
      Constructs a SortingFocusTraversalPolicy without a Comparator.
        SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
      Constructs a SortingFocusTraversalPolicy with the specified Comparator.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected boolean accept(Component aComponent)
      Determines whether a Component is an acceptable choice as the new focus owner.
      protected Comparator<? super Component> getComparator()
      Returns the Comparator which will be used to sort the Components in a focus traversal cycle.
      Component getComponentAfter(Container aContainer, Component aComponent)
      Returns the Component that should receive the focus after aComponent.
      Component getComponentBefore(Container aContainer, Component aComponent)
      Returns the Component that should receive the focus before aComponent.
      Component getDefaultComponent(Container aContainer)
      Returns the default Component to focus.
      Component getFirstComponent(Container aContainer)
      Returns the first Component in the traversal cycle.
      boolean getImplicitDownCycleTraversal()
      Returns whether this SortingFocusTraversalPolicy transfers focus down- cycle implicitly.
      Component getLastComponent(Container aContainer)
      Returns the last Component in the traversal cycle.
      protected void setComparator(Comparator<? super Component> comparator)
      Sets the Comparator which will be used to sort the Components in a focus traversal cycle.
      void setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal)
      Sets whether this SortingFocusTraversalPolicy transfers focus down-cycle implicitly.

      • 方法 - 继承于类 javax.swing.InternalFrameFocusTraversalPolicy

        getInitialComponent

      • 方法 - 继承于类 java.awt.FocusTraversalPolicy

        getInitialComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SortingFocusTraversalPolicy

        protected SortingFocusTraversalPolicy()
        Constructs a SortingFocusTraversalPolicy without a Comparator. Subclasses must set the Comparator using setComparator before installing this FocusTraversalPolicy on a focus cycle root or KeyboardFocusManager.

      • SortingFocusTraversalPolicy

        public SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
        Constructs a SortingFocusTraversalPolicy with the specified Comparator.

    • 方法详细信息

      • getComponentAfter

        public Component getComponentAfter(Container aContainer,
                          Component aComponent)
        Returns the Component that should receive the focus after aComponent. aContainer must be a focus cycle root of aComponent or a focus traversal policy provider.

        By default, SortingFocusTraversalPolicy implicitly transfers focus down- cycle. That is, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This behavior can be disabled using the setImplicitDownCycleTraversal method.

        If aContainer is focus traversal policy provider, the focus is always transferred down-cycle.

        指定者：
        getComponentAfter in class FocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider
        aComponent - a (possibly indirect) child of aContainer, or aContainer itself
        返回：
        the Component that should receive the focus after aComponent, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is not a focus cycle root of aComponent or a focus traversal policy provider, or if either aContainer or aComponent is null

      • getComponentBefore

        public Component getComponentBefore(Container aContainer,
                           Component aComponent)
        Returns the Component that should receive the focus before aComponent. aContainer must be a focus cycle root of aComponent or a focus traversal policy provider.

        By default, SortingFocusTraversalPolicy implicitly transfers focus down- cycle. That is, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This behavior can be disabled using the setImplicitDownCycleTraversal method.

        If aContainer is focus traversal policy provider, the focus is always transferred down-cycle.

        指定者：
        getComponentBefore in class FocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider
        aComponent - a (possibly indirect) child of aContainer, or aContainer itself
        返回：
        the Component that should receive the focus before aComponent, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is not a focus cycle root of aComponent or a focus traversal policy provider, or if either aContainer or aComponent is null

      • getFirstComponent

        public Component getFirstComponent(Container aContainer)
        Returns the first Component in the traversal cycle. This method is used to determine the next Component to focus when traversal wraps in the forward direction.
        指定者：
        getFirstComponent in class FocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider whose first Component is to be returned
        返回：
        the first Component in the traversal cycle of aContainer, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is null

      • getLastComponent

        public Component getLastComponent(Container aContainer)
        Returns the last Component in the traversal cycle. This method is used to determine the next Component to focus when traversal wraps in the reverse direction.
        指定者：
        getLastComponent in class FocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider whose last Component is to be returned
        返回：
        the last Component in the traversal cycle of aContainer, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is null

      • getDefaultComponent

        public Component getDefaultComponent(Container aContainer)
        Returns the default Component to focus. This Component will be the first to receive focus when traversing down into a new focus traversal cycle rooted at aContainer. The default implementation of this method returns the same Component as getFirstComponent.
        指定者：
        getDefaultComponent in class FocusTraversalPolicy
        参数：
        aContainer - a focus cycle root of aComponent or a focus traversal policy provider whose default Component is to be returned
        返回：
        the default Component in the traversal cycle of aContainer, or null if no suitable Component can be found
        抛出：
        IllegalArgumentException - if aContainer is null
        另请参见：
        getFirstComponent(java.awt.Container)

      • setImplicitDownCycleTraversal

        public void setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal)
        Sets whether this SortingFocusTraversalPolicy transfers focus down-cycle implicitly. If true, during normal focus traversal, the Component traversed after a focus cycle root will be the focus- cycle-root's default Component to focus. If false, the next Component in the focus traversal cycle rooted at the specified focus cycle root will be traversed instead. The default value for this property is true.
        参数：
        implicitDownCycleTraversal - whether this SortingFocusTraversalPolicy transfers focus down-cycle implicitly
        另请参见：
        getImplicitDownCycleTraversal(), getFirstComponent(java.awt.Container)

      • getImplicitDownCycleTraversal

        public boolean getImplicitDownCycleTraversal()
        Returns whether this SortingFocusTraversalPolicy transfers focus down- cycle implicitly. If true, during normal focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. If false, the next Component in the focus traversal cycle rooted at the specified focus cycle root will be traversed instead.
        返回：
        whether this SortingFocusTraversalPolicy transfers focus down- cycle implicitly
        另请参见：
        setImplicitDownCycleTraversal(boolean), getFirstComponent(java.awt.Container)

      • setComparator

        protected void setComparator(Comparator<? super Component> comparator)
        Sets the Comparator which will be used to sort the Components in a focus traversal cycle.
        参数：
        comparator - the Comparator which will be used for sorting

      • getComparator

        protected Comparator<? super Component> getComparator()
        Returns the Comparator which will be used to sort the Components in a focus traversal cycle.
        返回：
        the Comparator which will be used for sorting

      • accept

        protected boolean accept(Component aComponent)
        Determines whether a Component is an acceptable choice as the new focus owner. By default, this method will accept a Component if and only if it is visible, displayable, enabled, and focusable.
        参数：
        aComponent - the Component whose fitness as a focus owner is to be tested
        返回：
        true if aComponent is visible, displayable, enabled, and focusable; false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i pa


SortOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum SortOrder

  • java.lang.Object
    • java.lang.Enum<SortOrder>
      • javax.swing.SortOrder
  • 所有已实现的接口：
    Serializable, Comparable<SortOrder>

    public enum SortOrder
extends Enum<SortOrder>
    SortOrder is an enumeration of the possible sort orderings.
    从以下版本开始：
    1.6
    另请参见：
    RowSorter

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ASCENDING
      Enumeration value indicating the items are sorted in increasing order.
      DESCENDING
      Enumeration value indicating the items are sorted in decreasing order.
      UNSORTED
      Enumeration value indicating the items are unordered.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SortOrder valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SortOrder[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ASCENDING

        public static final SortOrder ASCENDING
        Enumeration value indicating the items are sorted in increasing order. For example, the set 1, 4, 0 sorted in ASCENDING order is 0, 1, 4.

      • DESCENDING

        public static final SortOrder DESCENDING
        Enumeration value indicating the items are sorted in decreasing order. For example, the set 1, 4, 0 sorted in DESCENDING order is 4, 1, 0.

      • UNSORTED

        public static final SortOrder UNSORTED
        Enumeration value indicating the items are unordered. For example, the set 1, 4, 0 in UNSORTED order is 1, 4, 0.

    • 方法详细信息

      • values

        public static SortOrder[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SortOrder c : SortOrder.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SortOrder valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o Dutnctnossnoo<-ll> L====u


SpinnerDateModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SpinnerDateModel

  • java.lang.Object
    • javax.swing.AbstractSpinnerModel
      • javax.swing.SpinnerDateModel
  • 所有已实现的接口：
    Serializable, SpinnerModel

    public class SpinnerDateModel
extends AbstractSpinnerModel
implements Serializable
    A SpinnerModel for sequences of Dates. The upper and lower bounds of the sequence are defined by properties called start and end and the size of the increase or decrease computed by the nextValue and previousValue methods is defined by a property called calendarField. The start and end properties can be null to indicate that the sequence has no lower or upper limit.

    The value of the calendarField property must be one of the java.util.Calendar constants that specify a field within a Calendar. The getNextValue and getPreviousValue methods change the date forward or backwards by this amount. For example, if calendarField is Calendar.DAY_OF_WEEK, then nextValue produces a Date that's 24 hours after the current value, and previousValue produces a Date that's 24 hours earlier.

    The legal values for calendarField are:

    • Calendar.ERA
    • Calendar.YEAR
    • Calendar.MONTH
    • Calendar.WEEK_OF_YEAR
    • Calendar.WEEK_OF_MONTH
    • Calendar.DAY_OF_MONTH
    • Calendar.DAY_OF_YEAR
    • Calendar.DAY_OF_WEEK
    • Calendar.DAY_OF_WEEK_IN_MONTH
    • Calendar.AM_PM
    • Calendar.HOUR
    • Calendar.HOUR_OF_DAY
    • Calendar.MINUTE
    • Calendar.SECOND
    • Calendar.MILLISECOND
    However some UIs may set the calendarField before commiting the edit to spin the field under the cursor. If you only want one field to spin you can subclass and ignore the setCalendarField calls.

    This model inherits a ChangeListener. The ChangeListeners are notified whenever the models value, calendarField, start, or end properties changes.

    从以下版本开始：
    1.4
    另请参见：
    JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, Calendar.add(int, int)

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractSpinnerModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpinnerDateModel()
      Constructs a SpinnerDateModel whose initial value is the current date, calendarField is equal to Calendar.DAY_OF_MONTH, and for which there are no start/end limits.
      SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
      Creates a SpinnerDateModel that represents a sequence of dates between start and end.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getCalendarField()
      Returns the Calendar field that is added to or subtracted from by the nextValue and previousValue methods.
      Date getDate()
      Returns the current element in this sequence of Dates.
      Comparable getEnd()
      Returns the last Date in the sequence.
      Object getNextValue()
      Returns the next Date in the sequence, or null if the next date is after end.
      Object getPreviousValue()
      Returns the previous Date in the sequence, or null if the previous date is before start.
      Comparable getStart()
      Returns the first Date in the sequence.
      Object getValue()
      Returns the current element in this sequence of Dates.
      void setCalendarField(int calendarField)
      Changes the size of the date value change computed by the nextValue and previousValue methods.
      void setEnd(Comparable end)
      Changes the upper limit for Dates in this sequence.
      void setStart(Comparable start)
      Changes the lower limit for Dates in this sequence.
      void setValue(Object value)
      Sets the current Date for this sequence.

      • 方法 - 继承于类 javax.swing.AbstractSpinnerModel

        addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SpinnerDateModel

        public SpinnerDateModel(Date value,
                Comparable start,
                Comparable end,
                int calendarField)
        Creates a SpinnerDateModel that represents a sequence of dates between start and end. The nextValue and previousValue methods compute elements of the sequence by advancing or reversing the current date value by the calendarField time unit. For a precise description of what it means to increment or decrement a Calendar field, see the add method in java.util.Calendar.

        The start and end parameters can be null to indicate that the range doesn't have an upper or lower bound. If value or calendarField is null, or if both start and end are specified and mininum > maximum then an IllegalArgumentException is thrown. Similarly if (minimum <= value <= maximum) is false, an IllegalArgumentException is thrown.

        参数：
        value - the current (non null) value of the model
        start - the first date in the sequence or null
        end - the last date in the sequence or null
        calendarField - one of
        • Calendar.ERA
        • Calendar.YEAR
        • Calendar.MONTH
        • Calendar.WEEK_OF_YEAR
        • Calendar.WEEK_OF_MONTH
        • Calendar.DAY_OF_MONTH
        • Calendar.DAY_OF_YEAR
        • Calendar.DAY_OF_WEEK
        • Calendar.DAY_OF_WEEK_IN_MONTH
        • Calendar.AM_PM
        • Calendar.HOUR
        • Calendar.HOUR_OF_DAY
        • Calendar.MINUTE
        • Calendar.SECOND
        • Calendar.MILLISECOND
        抛出：
        IllegalArgumentException - if value or calendarField are null, if calendarField isn't valid, or if the following expression is false: (start <= value <= end).
        另请参见：
        Calendar.add(int, int),
setValue(java.lang.Object),
setStart(java.lang.Comparable),
setEnd(java.lang.Comparable),
setCalendarField(int)

      • SpinnerDateModel

        public SpinnerDateModel()
        Constructs a SpinnerDateModel whose initial value is the current date, calendarField is equal to Calendar.DAY_OF_MONTH, and for which there are no start/end limits.

    • 方法详细信息

      • setStart

        public void setStart(Comparable start)
        Changes the lower limit for Dates in this sequence. If start is null, then there is no lower limit. No bounds checking is done here: the new start value may invalidate the (start <= value <= end) invariant enforced by the constructors. This is to simplify updating the model. Naturally one should ensure that the invariant is true before calling the nextValue, previousValue, or setValue methods.

        Typically this property is a Date however it's possible to use a Comparable with a compareTo method for Dates. For example start might be an instance of a class like this:

         MyStartDate implements Comparable {
     long t = 12345;
     public int compareTo(Date d) {
            return (t < d.getTime() ? -1 : (t == d.getTime() ? 0 : 1));
     }
     public int compareTo(Object o) {
            return compareTo((Date)o);
     }
 }
        Note that the above example will throw a ClassCastException if the Object passed to compareTo(Object) is not a Date.

        This method fires a ChangeEvent if the start has changed.

        参数：
        start - defines the first date in the sequence
        另请参见：
        getStart(),
setEnd(java.lang.Comparable),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getStart

        public Comparable getStart()
        Returns the first Date in the sequence.
        返回：
        the value of the start property
        另请参见：
        setStart(java.lang.Comparable)

      • setEnd

        public void setEnd(Comparable end)
        Changes the upper limit for Dates in this sequence. If start is null, then there is no upper limit. No bounds checking is done here: the new start value may invalidate the (start <= value <= end) invariant enforced by the constructors. This is to simplify updating the model. Naturally, one should ensure that the invariant is true before calling the nextValue, previousValue, or setValue methods.

        Typically this property is a Date however it's possible to use Comparable with a compareTo method for Dates. See setStart for an example.

        This method fires a ChangeEvent if the end has changed.

        参数：
        end - defines the last date in the sequence
        另请参见：
        getEnd(),
setStart(java.lang.Comparable),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getEnd

        public Comparable getEnd()
        Returns the last Date in the sequence.
        返回：
        the value of the end property
        另请参见：
        setEnd(java.lang.Comparable)

      • setCalendarField

        public void setCalendarField(int calendarField)
        Changes the size of the date value change computed by the nextValue and previousValue methods. The calendarField parameter must be one of the Calendar field constants like Calendar.MONTH or Calendar.MINUTE. The nextValue and previousValue methods simply move the specified Calendar field forward or backward by one unit with the Calendar.add method. You should use this method with care as some UIs may set the calendarField before commiting the edit to spin the field under the cursor. If you only want one field to spin you can subclass and ignore the setCalendarField calls.
        参数：
        calendarField - one of
        • Calendar.ERA
        • Calendar.YEAR
        • Calendar.MONTH
        • Calendar.WEEK_OF_YEAR
        • Calendar.WEEK_OF_MONTH
        • Calendar.DAY_OF_MONTH
        • Calendar.DAY_OF_YEAR
        • Calendar.DAY_OF_WEEK
        • Calendar.DAY_OF_WEEK_IN_MONTH
        • Calendar.AM_PM
        • Calendar.HOUR
        • Calendar.HOUR_OF_DAY
        • Calendar.MINUTE
        • Calendar.SECOND
        • Calendar.MILLISECOND

        This method fires a ChangeEvent if the calendarField has changed.

        另请参见：
        getCalendarField(),
getNextValue(),
getPreviousValue(),
Calendar.add(int, int),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getCalendarField

        public int getCalendarField()
        Returns the Calendar field that is added to or subtracted from by the nextValue and previousValue methods.
        返回：
        the value of the calendarField property
        另请参见：
        setCalendarField(int)

      • getNextValue

        public Object getNextValue()
        Returns the next Date in the sequence, or null if the next date is after end.
        指定者：
        getNextValue in interface SpinnerModel
        返回：
        the next Date in the sequence, or null if the next date is after end.
        另请参见：
        SpinnerModel.getNextValue(),
getPreviousValue(),
setCalendarField(int)

      • getPreviousValue

        public Object getPreviousValue()
        Returns the previous Date in the sequence, or null if the previous date is before start.
        指定者：
        getPreviousValue in interface SpinnerModel
        返回：
        the previous Date in the sequence, or null if the previous date is before start
        另请参见：
        SpinnerModel.getPreviousValue(),
getNextValue(),
setCalendarField(int)

      • getDate

        public Date getDate()
        Returns the current element in this sequence of Dates. This method is equivalent to (Date)getValue.
        返回：
        the value property
        另请参见：
        setValue(java.lang.Object)

      • getValue

        public Object getValue()
        Returns the current element in this sequence of Dates.
        指定者：
        getValue in interface SpinnerModel
        返回：
        the value property
        另请参见：
        setValue(java.lang.Object), getDate()

      • setValue

        public void setValue(Object value)
        Sets the current Date for this sequence. If value is null, an IllegalArgumentException is thrown. No bounds checking is done here: the new value may invalidate the (start <= value < end) invariant enforced by the constructors. Naturally, one should ensure that the (start <= value <= maximum) invariant is true before calling the nextValue, previousValue, or setValue methods.

        This method fires a ChangeEvent if the value has changed.

        指定者：
        setValue in interface SpinnerModel
        参数：
        value - the current (non null) Date for this sequence
        抛出：
        IllegalArgumentException - if value is null or not a Date
        另请参见：
        getDate(),
getValue(),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpinnerListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SpinnerListModel

  • java.lang.Object
    • javax.swing.AbstractSpinnerModel
      • javax.swing.SpinnerListModel
  • 所有已实现的接口：
    Serializable, SpinnerModel

    public class SpinnerListModel
extends AbstractSpinnerModel
implements Serializable
    A simple implementation of SpinnerModel whose values are defined by an array or a List. For example to create a model defined by an array of the names of the days of the week:
     String[] days = new DateFormatSymbols().getWeekdays();
 SpinnerModel model = new SpinnerListModel(Arrays.asList(days).subList(1, 8));
    This class only stores a reference to the array or List so if an element of the underlying sequence changes, it's up to the application to notify the ChangeListeners by calling fireStateChanged.

    This model inherits a ChangeListener. The ChangeListeners are notified whenever the model's value or list properties changes.

    从以下版本开始：
    1.4
    另请参见：
    JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerNumberModel, SpinnerDateModel

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractSpinnerModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpinnerListModel()
      Constructs an effectively empty SpinnerListModel.
      SpinnerListModel(List<?> values)
      Constructs a SpinnerModel whose sequence of values is defined by the specified List.
      SpinnerListModel(Object[] values)
      Constructs a SpinnerModel whose sequence of values is defined by the specified array.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List<?> getList()
      Returns the List that defines the sequence for this model.
      Object getNextValue()
      Returns the next legal value of the underlying sequence or null if value is already the last element.
      Object getPreviousValue()
      Returns the previous element of the underlying sequence or null if value is already the first element.
      Object getValue()
      Returns the current element of the sequence.
      void setList(List<?> list)
      Changes the list that defines this sequence and resets the index of the models value to zero.
      void setValue(Object elt)
      Changes the current element of the sequence and notifies ChangeListeners.

      • 方法 - 继承于类 javax.swing.AbstractSpinnerModel

        addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SpinnerListModel

        public SpinnerListModel(List<?> values)
        Constructs a SpinnerModel whose sequence of values is defined by the specified List. The initial value (current element) of the model will be values.get(0). If values is null or has zero size, an IllegalArugmentException is thrown.
        参数：
        values - the sequence this model represents
        抛出：
        IllegalArugmentException - if values is null or zero size

      • SpinnerListModel

        public SpinnerListModel(Object[] values)
        Constructs a SpinnerModel whose sequence of values is defined by the specified array. The initial value of the model will be values[0]. If values is null or has zero length, an IllegalArugmentException is thrown.
        参数：
        values - the sequence this model represents
        抛出：
        IllegalArugmentException - if values is null or zero length

      • SpinnerListModel

        public SpinnerListModel()
        Constructs an effectively empty SpinnerListModel. The model's list will contain a single "empty" string element.

    • 方法详细信息

      • getList

        public List<?> getList()
        Returns the List that defines the sequence for this model.
        返回：
        the value of the list property
        另请参见：
        setList(java.util.List)

      • setList

        public void setList(List<?> list)
        Changes the list that defines this sequence and resets the index of the models value to zero. Note that list is not copied, the model just stores a reference to it.

        This method fires a ChangeEvent if list is not equal to the current list.

        参数：
        list - the sequence that this model represents
        抛出：
        IllegalArgumentException - if list is null or zero length
        另请参见：
        getList()

      • getValue

        public Object getValue()
        Returns the current element of the sequence.
        指定者：
        getValue in interface SpinnerModel
        返回：
        the value property
        另请参见：
        SpinnerModel.getValue(), setValue(java.lang.Object)

      • setValue

        public void setValue(Object elt)
        Changes the current element of the sequence and notifies ChangeListeners. If the specified value is not equal to an element of the underlying sequence then an IllegalArgumentException is thrown. In the following example the setValue call would cause an exception to be thrown:
         String[] values = {"one", "two", "free", "four"};
 SpinnerModel model = new SpinnerListModel(values);
 model.setValue("TWO");
        指定者：
        setValue in interface SpinnerModel
        参数：
        elt - the sequence element that will be model's current value
        抛出：
        IllegalArgumentException - if the specified value isn't allowed
        另请参见：
        SpinnerModel.setValue(java.lang.Object), getValue()

      • getNextValue

        public Object getNextValue()
        Returns the next legal value of the underlying sequence or null if value is already the last element.
        指定者：
        getNextValue in interface SpinnerModel
        返回：
        the next legal value of the underlying sequence or null if value is already the last element
        另请参见：
        SpinnerModel.getNextValue(), getPreviousValue()

      • getPreviousValue

        public Object getPreviousValue()
        Returns the previous element of the underlying sequence or null if value is already the first element.
        指定者：
        getPreviousValue in interface SpinnerModel
        返回：
        the previous element of the underlying sequence or null if value is already the first element
        另请参见：
        SpinnerModel.getPreviousValue(), getNextValue()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oi e es edffeddeetteons/haageed/ddl<<> ec c<<


SpinnerModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface SpinnerModel

  • All Known Implementing Classes:
    AbstractSpinnerModel, SpinnerDateModel, SpinnerListModel, SpinnerNumberModel

    public interface SpinnerModel
    A model for a potentially unbounded sequence of object values. This model is similar to ListModel however there are some important differences:
    • The number of sequence elements isn't neccessarily bounded.
    • The model doesn't support indexed random access to sequence elements. Only three sequence values are accessible at a time: current, next and previous.
    • The current sequence element, can be set.

    A SpinnerModel has three properties, only the first is read/write.

    value
    The current element of the sequence.
    nextValue
    The following element or null if value is the last element of the sequence.
    previousValue
    The preceeding element or null if value is the first element of the sequence.
    When the the value property changes, ChangeListeners are notified. SpinnerModel may choose to notify the ChangeListeners under other circumstances.
    从以下版本开始：
    1.4
    另请参见：
    JSpinner, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model's listener list.
      Object getNextValue()
      Return the object in the sequence that comes after the object returned by getValue().
      Object getPreviousValue()
      Return the object in the sequence that comes before the object returned by getValue().
      Object getValue()
      The current element of the sequence.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model's listener list.
      void setValue(Object value)
      Changes current value of the model, typically this value is displayed by the editor part of a JSpinner.

    • 方法详细信息

      • getValue

        Object getValue()
        The current element of the sequence. This element is usually displayed by the editor part of a JSpinner.
        返回：
        the current spinner value.
        另请参见：
        setValue(java.lang.Object)

      • setValue

        void setValue(Object value)
        Changes current value of the model, typically this value is displayed by the editor part of a JSpinner. If the SpinnerModel implementation doesn't support the specified value then an IllegalArgumentException is thrown. For example a SpinnerModel for numbers might only support values that are integer multiples of ten. In that case, model.setValue(new Number(11)) would throw an exception.
        抛出：
        IllegalArgumentException - if value isn't allowed
        另请参见：
        getValue()

      • getNextValue

        Object getNextValue()
        Return the object in the sequence that comes after the object returned by getValue(). If the end of the sequence has been reached then return null. Calling this method does not effect value.
        返回：
        the next legal value or null if one doesn't exist
        另请参见：
        getValue(), getPreviousValue()

      • getPreviousValue

        Object getPreviousValue()
        Return the object in the sequence that comes before the object returned by getValue(). If the end of the sequence has been reached then return null. Calling this method does not effect value.
        返回：
        the previous legal value or null if one doesn't exist
        另请参见：
        getValue(), getNextValue()

      • addChangeListener

        void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the model's listener list. The ChangeListeners must be notified when models value changes.
        参数：
        l - the ChangeListener to add
        另请参见：
        removeChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the model's listener list.
        参数：
        l - the ChangeListener to remove
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/n g>t">tsrrtssa c>ee/>


SpinnerNumberModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SpinnerNumberModel

  • java.lang.Object
    • javax.swing.AbstractSpinnerModel
      • javax.swing.SpinnerNumberModel
  • 所有已实现的接口：
    Serializable, SpinnerModel

    public class SpinnerNumberModel
extends AbstractSpinnerModel
implements Serializable
    A SpinnerModel for sequences of numbers. The upper and lower bounds of the sequence are defined by properties called minimum and maximum. The size of the increase or decrease computed by the nextValue and previousValue methods is defined by a property called stepSize. The minimum and maximum properties can be null to indicate that the sequence has no lower or upper limit. All of the properties in this class are defined in terms of two generic types: Number and Comparable, so that all Java numeric types may be accommodated. Internally, there's only support for values whose type is one of the primitive Number types: Double, Float, Long, Integer, Short, or Byte.

    To create a SpinnerNumberModel for the integer range zero to one hundred, with fifty as the initial value, one could write:

     Integer value = new Integer(50);
 Integer min = new Integer(0);
 Integer max = new Integer(100);
 Integer step = new Integer(1);
 SpinnerNumberModel model = new SpinnerNumberModel(value, min, max, step);
 int fifty = model.getNumber().intValue();

    Spinners for integers and doubles are common, so special constructors for these cases are provided. For example to create the model in the previous example, one could also write:

     SpinnerNumberModel model = new SpinnerNumberModel(50, 0, 100, 1);

    This model inherits a ChangeListener. The ChangeListeners are notified whenever the model's value, stepSize, minimum, or maximum properties changes.

    从以下版本开始：
    1.4
    另请参见：
    JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerDateModel

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractSpinnerModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpinnerNumberModel()
      Constructs a SpinnerNumberModel with no minimum or maximum value, stepSize equal to one, and an initial value of zero.
      SpinnerNumberModel(double value, double minimum, double maximum, double stepSize)
      Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.
      SpinnerNumberModel(int value, int minimum, int maximum, int stepSize)
      Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.
      SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
      Constructs a SpinnerModel that represents a closed sequence of numbers from minimum to maximum.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Comparable getMaximum()
      Returns the last number in the sequence.
      Comparable getMinimum()
      Returns the first number in this sequence.
      Object getNextValue()
      Returns the next number in the sequence.
      Number getNumber()
      Returns the value of the current element of the sequence.
      Object getPreviousValue()
      Returns the previous number in the sequence.
      Number getStepSize()
      Returns the size of the value change computed by the getNextValue and getPreviousValue methods.
      Object getValue()
      Returns the value of the current element of the sequence.
      void setMaximum(Comparable maximum)
      Changes the upper bound for numbers in this sequence.
      void setMinimum(Comparable minimum)
      Changes the lower bound for numbers in this sequence.
      void setStepSize(Number stepSize)
      Changes the size of the value change computed by the getNextValue and getPreviousValue methods.
      void setValue(Object value)
      Sets the current value for this sequence.

      • 方法 - 继承于类 javax.swing.AbstractSpinnerModel

        addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SpinnerNumberModel

        public SpinnerNumberModel(Number value,
                  Comparable minimum,
                  Comparable maximum,
                  Number stepSize)
        Constructs a SpinnerModel that represents a closed sequence of numbers from minimum to maximum. The nextValue and previousValue methods compute elements of the sequence by adding or subtracting stepSize respectively. All of the parameters must be mutually Comparable, value and stepSize must be instances of Integer Long, Float, or Double.

        The minimum and maximum parameters can be null to indicate that the range doesn't have an upper or lower bound. If value or stepSize is null, or if both minimum and maximum are specified and mininum > maximum then an IllegalArgumentException is thrown. Similarly if (minimum <= value <= maximum) is false, an IllegalArgumentException is thrown.

        参数：
        value - the current (non null) value of the model
        minimum - the first number in the sequence or null
        maximum - the last number in the sequence or null
        stepSize - the difference between elements of the sequence
        抛出：
        IllegalArgumentException - if stepSize or value is null or if the following expression is false: minimum <= value <= maximum

      • SpinnerNumberModel

        public SpinnerNumberModel(int value,
                  int minimum,
                  int maximum,
                  int stepSize)
        Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.
        参数：
        value - the current value of the model
        minimum - the first number in the sequence
        maximum - the last number in the sequence
        stepSize - the difference between elements of the sequence
        抛出：
        IllegalArgumentException - if the following expression is false: minimum <= value <= maximum

      • SpinnerNumberModel

        public SpinnerNumberModel(double value,
                  double minimum,
                  double maximum,
                  double stepSize)
        Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.
        参数：
        value - the current value of the model
        minimum - the first number in the sequence
        maximum - the last number in the sequence
        stepSize - the difference between elements of the sequence
        抛出：
        IllegalArgumentException - if the following expression is false: minimum <= value <= maximum

      • SpinnerNumberModel

        public SpinnerNumberModel()
        Constructs a SpinnerNumberModel with no minimum or maximum value, stepSize equal to one, and an initial value of zero.

    • 方法详细信息

      • setMinimum

        public void setMinimum(Comparable minimum)
        Changes the lower bound for numbers in this sequence. If minimum is null, then there is no lower bound. No bounds checking is done here; the new minimum value may invalidate the (minimum <= value <= maximum) invariant enforced by the constructors. This is to simplify updating the model, naturally one should ensure that the invariant is true before calling the getNextValue, getPreviousValue, or setValue methods.

        Typically this property is a Number of the same type as the value however it's possible to use any Comparable with a compareTo method for a Number with the same type as the value. For example if value was a Long, minimum might be a Date subclass defined like this:

         MyDate extends Date {  // Date already implements Comparable
     public int compareTo(Long o) {
         long t = getTime();
         return (t < o.longValue() ? -1 : (t == o.longValue() ? 0 : 1));
     }
 }

        This method fires a ChangeEvent if the minimum has changed.

        参数：
        minimum - a Comparable that has a compareTo method for Numbers with the same type as value
        另请参见：
        getMinimum(),
setMaximum(java.lang.Comparable),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getMinimum

        public Comparable getMinimum()
        Returns the first number in this sequence.
        返回：
        the value of the minimum property
        另请参见：
        setMinimum(java.lang.Comparable)

      • setMaximum

        public void setMaximum(Comparable maximum)
        Changes the upper bound for numbers in this sequence. If maximum is null, then there is no upper bound. No bounds checking is done here; the new maximum value may invalidate the (minimum <= value < maximum) invariant enforced by the constructors. This is to simplify updating the model, naturally one should ensure that the invariant is true before calling the 下一个, previous, or setValue methods.

        Typically this property is a Number of the same type as the value however it's possible to use any Comparable with a compareTo method for a Number with the same type as the value. See setMinimum for an example.

        This method fires a ChangeEvent if the maximum has changed.

        参数：
        maximum - a Comparable that has a compareTo method for Numbers with the same type as value
        另请参见：
        getMaximum(),
setMinimum(java.lang.Comparable),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getMaximum

        public Comparable getMaximum()
        Returns the last number in the sequence.
        返回：
        the value of the maximum property
        另请参见：
        setMaximum(java.lang.Comparable)

      • setStepSize

        public void setStepSize(Number stepSize)
        Changes the size of the value change computed by the getNextValue and getPreviousValue methods. An IllegalArgumentException is thrown if stepSize is null.

        This method fires a ChangeEvent if the stepSize has changed.

        参数：
        stepSize - the size of the value change computed by the getNextValue and getPreviousValue methods
        另请参见：
        getNextValue(),
getPreviousValue(),
getStepSize(),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

      • getStepSize

        public Number getStepSize()
        Returns the size of the value change computed by the getNextValue and getPreviousValue methods.
        返回：
        the value of the stepSize property
        另请参见：
        setStepSize(java.lang.Number)

      • getNextValue

        public Object getNextValue()
        Returns the next number in the sequence.
        指定者：
        getNextValue in interface SpinnerModel
        返回：
        value + stepSize or null if the sum exceeds maximum.
        另请参见：
        SpinnerModel.getNextValue(),
getPreviousValue(),
setStepSize(java.lang.Number)

      • getPreviousValue

        public Object getPreviousValue()
        Returns the previous number in the sequence.
        指定者：
        getPreviousValue in interface SpinnerModel
        返回：
        value - stepSize, or null if the sum is less than minimum.
        另请参见：
        SpinnerModel.getPreviousValue(),
getNextValue(),
setStepSize(java.lang.Number)

      • getNumber

        public Number getNumber()
        Returns the value of the current element of the sequence.
        返回：
        the value property
        另请参见：
        setValue(java.lang.Object)

      • getValue

        public Object getValue()
        Returns the value of the current element of the sequence.
        指定者：
        getValue in interface SpinnerModel
        返回：
        the value property
        另请参见：
        setValue(java.lang.Object), getNumber()

      • setValue

        public void setValue(Object value)
        Sets the current value for this sequence. If value is null, or not a Number, an IllegalArgumentException is thrown. No bounds checking is done here; the new value may invalidate the (minimum <= value <= maximum) invariant enforced by the constructors. It's also possible to set the value to be something that wouldn't naturally occur in the sequence, i.e. a value that's not modulo the stepSize. This is to simplify updating the model, and to accommodate spinners that don't want to restrict values that have been directly entered by the user. Naturally, one should ensure that the (minimum <= value <= maximum) invariant is true before calling the 下一个, previous, or setValue methods.

        This method fires a ChangeEvent if the value has changed.

        指定者：
        setValue in interface SpinnerModel
        参数：
        value - the current (non null) Number for this sequence
        抛出：
        IllegalArgumentException - if value is null or not a Number
        另请参见：
        getNumber(),
getValue(),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

T


Spring

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Spring

  • java.lang.Object
    • javax.swing.Spring

  • public abstract class Spring
extends Object
    An instance of the Spring class holds three properties that characterize its behavior: the minimum, preferred, and maximum values. Each of these properties may be involved in defining its fourth, value, property based on a series of rules.

    An instance of the Spring class can be visualized as a mechanical spring that provides a corrective force as the spring is compressed or stretched away from its preferred value. This force is modelled as linear function of the distance from the preferred value, but with two different constants -- one for the compressional force and one for the tensional one. Those constants are specified by the minimum and maximum values of the spring such that a spring at its minimum value produces an equal and opposite force to that which is created when it is at its maximum value. The difference between the preferred and minimum values, therefore, represents the ease with which the spring can be compressed and the difference between its maximum and preferred values, indicates the ease with which the Spring can be extended. See the sum(javax.swing.Spring, javax.swing.Spring) method for details.

    By defining simple arithmetic operations on Springs, the behavior of a collection of Springs can be reduced to that of an ordinary (non-compound) Spring. We define the "+", "-", max, and min operators on Springs so that, in each case, the result is a Spring whose characteristics bear a useful mathematical relationship to its constituent springs.

    A Spring can be treated as a pair of intervals with a single common point: the preferred value. The following rules define some of the arithmetic operators that can be applied to intervals ([a, b] refers to the interval from a to b, where a <= b).

              [a1, b1] + [a2, b2] = [a1 + a2, b1 + b2]

                      -[a, b] = [-b, -a]

      max([a1, b1], [a2, b2]) = [max(a1, a2), max(b1, b2)]

    If we denote Springs as [a, b, c], where a <= b <= c, we can define the same arithmetic operators on Springs:

              [a1, b1, c1] + [a2, b2, c2] = [a1 + a2, b1 + b2, c1 + c2]

                           -[a, b, c] = [-c, -b, -a]

      max([a1, b1, c1], [a2, b2, c2]) = [max(a1, a2), max(b1, b2), max(c1, c2)]

    With both intervals and Springs we can define "-" and min in terms of negation:

          X - Y = X + (-Y)

      min(X, Y) = -max(-X, -Y)

    For the static methods in this class that embody the arithmetic operators, we do not actually perform the operation in question as that would snapshot the values of the properties of the method's arguments at the time the static method is called. Instead, the static methods create a new Spring instance containing references to the method's arguments so that the characteristics of the new spring track the potentially changing characteristics of the springs from which it was made. This is a little like the idea of a lazy value in a functional language.

    If you are implementing a SpringLayout you can find further information and examples in How to Use SpringLayout, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    SpringLayout, SpringLayout.Constraints

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int UNSET
      An integer value signifying that a property value has not yet been calculated.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Spring()
      Used by factory methods to create a Spring.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Spring constant(int pref)
      Returns a strut -- a spring whose minimum, preferred, and maximum values each have the value pref.
      static Spring constant(int min, int pref, int max)
      Returns a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively.
      abstract int getMaximumValue()
      Returns the maximum value of this Spring.
      abstract int getMinimumValue()
      Returns the minimum value of this Spring.
      abstract int getPreferredValue()
      Returns the preferred value of this Spring.
      abstract int getValue()
      Returns the current value of this Spring.
      static Spring height(Component c)
      Returns a spring whose minimum, preferred, maximum and value properties are defined by the heights of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
      static Spring max(Spring s1, Spring s2)
      Returns max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2.
      static Spring minus(Spring s)
      Returns -s: a spring running in the opposite direction to s.
      static Spring scale(Spring s, float factor)
      Returns a spring whose minimum, preferred, maximum and value properties are each multiples of the properties of the argument spring, s.
      abstract void setValue(int value)
      Sets the current value of this Spring to value.
      static Spring sum(Spring s1, Spring s2)
      Returns s1+s2: a spring representing s1 and s2 in series.
      static Spring width(Component c)
      Returns a spring whose minimum, preferred, maximum and value properties are defined by the widths of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • UNSET

        public static final int UNSET
        An integer value signifying that a property value has not yet been calculated.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Spring

        protected Spring()
        Used by factory methods to create a Spring.
        另请参见：
        constant(int),
constant(int, int, int),
max(javax.swing.Spring, javax.swing.Spring),
minus(javax.swing.Spring),
sum(javax.swing.Spring, javax.swing.Spring),
SpringLayout.Constraints

    • 方法详细信息

      • getMinimumValue

        public abstract int getMinimumValue()
        Returns the minimum value of this Spring.
        返回：
        the minimumValue property of this Spring

      • getPreferredValue

        public abstract int getPreferredValue()
        Returns the preferred value of this Spring.
        返回：
        the preferredValue of this Spring

      • getMaximumValue

        public abstract int getMaximumValue()
        Returns the maximum value of this Spring.
        返回：
        the maximumValue property of this Spring

      • getValue

        public abstract int getValue()
        Returns the current value of this Spring.
        返回：
        the value property of this Spring
        另请参见：
        setValue(int)

      • setValue

        public abstract void setValue(int value)
        Sets the current value of this Spring to value.
        参数：
        value - the new setting of the value property
        另请参见：
        getValue()

      • constant

        public static Spring constant(int pref)
        Returns a strut -- a spring whose minimum, preferred, and maximum values each have the value pref.
        参数：
        pref - the minimum, preferred, and maximum values of the new spring
        返回：
        a spring whose minimum, preferred, and maximum values each have the value pref
        另请参见：
        Spring

      • constant

        public static Spring constant(int min,
              int pref,
              int max)
        Returns a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively.
        参数：
        min - the minimum value of the new spring
        pref - the preferred value of the new spring
        max - the maximum value of the new spring
        返回：
        a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively
        另请参见：
        Spring

      • minus

        public static Spring minus(Spring s)
        Returns -s: a spring running in the opposite direction to s.
        返回：
        -s: a spring running in the opposite direction to s
        另请参见：
        Spring

      • sum

        public static Spring sum(Spring s1,
         Spring s2)
        Returns s1+s2: a spring representing s1 and s2 in series. In a sum, s3, of two springs, s1 and s2, the strains of s1, s2, and s3 are maintained at the same level (to within the precision implied by their integer values). The strain of a spring in compression is:
                 value - pref
         ------------
          pref - min
        and the strain of a spring in tension is:
                 value - pref
         ------------
          max - pref
        When setValue is called on the sum spring, s3, the strain in s3 is calculated using one of the formulas above. Once the strain of the sum is known, the values of s1 and s2 are then set so that they are have a strain equal to that of the sum. The formulas are evaluated so as to take rounding errors into account and ensure that the sum of the values of s1 and s2 is exactly equal to the value of s3.
        返回：
        s1+s2: a spring representing s1 and s2 in series
        另请参见：
        Spring

      • max

        public static Spring max(Spring s1,
         Spring s2)
        Returns max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2.
        返回：
        max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2
        另请参见：
        Spring

      • scale

        public static Spring scale(Spring s,
           float factor)
        Returns a spring whose minimum, preferred, maximum and value properties are each multiples of the properties of the argument spring, s. Minimum and maximum properties are swapped when factor is negative (in accordance with the rules of interval arithmetic).

        When factor is, for example, 0.5f the result represents 'the mid-point' of its input - an operation that is useful for centering components in a container.

        参数：
        s - the spring to scale
        factor - amount to scale by.
        返回：
        a spring whose properties are those of the input spring s multiplied by factor
        抛出：
        NullPointerException - if s is null
        从以下版本开始：
        1.5

      • width

        public static Spring width(Component c)
        Returns a spring whose minimum, preferred, maximum and value properties are defined by the widths of the minimumSize, preferredSize, maximumSize and size properties of the supplied component. The returned spring is a 'wrapper' implementation whose methods call the appropriate size methods of the supplied component. The minimum, preferred, maximum and value properties of the returned spring therefore report the current state of the appropriate properties in the component and track them as they change.
        参数：
        c - Component used for calculating size
        返回：
        a spring whose properties are defined by the horizontal component of the component's size methods.
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.5

      • height

        public static Spring height(Component c)
        Returns a spring whose minimum, preferred, maximum and value properties are defined by the heights of the minimumSize, preferredSize, maximumSize and size properties of the supplied component. The returned spring is a 'wrapper' implementation whose methods call the appropriate size methods of the supplied component. The minimum, preferred, maximum and value properties of the returned spring therefore report the current state of the appropriate properties in the component and track them as they change.
        参数：
        c - Component used for calculating size
        返回：
        a spring whose properties are defined by the vertical component of the component's size methods.
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n ten/ag/av//avv.rdd eo oo ueto rs oost �>


SpringLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SpringLayout

  • java.lang.Object
    • javax.swing.SpringLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2

    public class SpringLayout
extends Object
implements LayoutManager2
    A SpringLayout lays out the children of its associated container according to a set of constraints. See How to Use SpringLayout in The Java Tutorial for examples of using SpringLayout.

    Each constraint, represented by a Spring object, controls the vertical or horizontal distance between two component edges. The edges can belong to any child of the container, or to the container itself. For example, the allowable width of a component can be expressed using a constraint that controls the distance between the west (left) and east (right) edges of the component. The allowable y coordinates for a component can be expressed by constraining the distance between the north (top) edge of the component and the north edge of its container.

    Every child of a SpringLayout-controlled container, as well as the container itself, has exactly one set of constraints associated with it. These constraints are represented by a SpringLayout.Constraints object. By default, SpringLayout creates constraints that make their associated component have the minimum, preferred, and maximum sizes returned by the component's Component.getMinimumSize(), Component.getPreferredSize(), and Component.getMaximumSize() methods. The x and y positions are initially not constrained, so that until you constrain them the Component will be positioned at 0,0 relative to the Insets of the parent Container.

    You can change a component's constraints in several ways. You can use one of the putConstraint methods to establish a spring linking the edges of two components within the same container. Or you can get the appropriate SpringLayout.Constraints object using getConstraints and then modify one or more of its springs. Or you can get the spring for a particular edge of a component using getConstraint, and modify it. You can also associate your own SpringLayout.Constraints object with a component by specifying the constraints object when you add the component to its container (using Container.add(Component, Object)).

    The Spring object representing each constraint has a minimum, preferred, maximum, and current value. The current value of the spring is somewhere between the minimum and maximum values, according to the formula given in the Spring.sum(javax.swing.Spring, javax.swing.Spring) method description. When the minimum, preferred, and maximum values are the same, the current value is always equal to them; this inflexible spring is called a strut. You can create struts using the factory method Spring.constant(int). The Spring class also provides factory methods for creating other kinds of springs, including springs that depend on other springs.

    In a SpringLayout, the position of each edge is dependent on the position of just one other edge. If a constraint is subsequently added to create a new binding for an edge, the previous binding is discarded and the edge remains dependent on a single edge. Springs should only be attached between edges of the container and its immediate children; the behavior of the SpringLayout when presented with constraints linking the edges of components from different containers (either internal or external) is undefined.

    SpringLayout vs. Other Layout Managers

    Note: Unlike many layout managers, SpringLayout doesn't automatically set the location of the components it manages. If you hand-code a GUI that uses SpringLayout, remember to initialize component locations by constraining the west/east and north/south locations.

    Depending on the constraints you use, you may also need to set the size of the container explicitly.

    Despite the simplicity of SpringLayout, it can emulate the behavior of most other layout managers. For some features, such as the line breaking provided by FlowLayout, you'll need to create a special-purpose subclass of the Spring class.

    SpringLayout also provides a way to solve many of the difficult layout problems that cannot be solved by nesting combinations of Boxes. That said, SpringLayout honors the LayoutManager2 contract correctly and so can be nested with other layout managers -- a technique that can be preferable to creating the constraints implied by the other layout managers.

    The asymptotic complexity of the layout operation of a SpringLayout is linear in the number of constraints (and/or components).

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    Spring, SpringLayout.Constraints

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  SpringLayout.Constraints
      A Constraints object holds the constraints that govern the way a component's size and position change in a container controlled by a SpringLayout.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String BASELINE
      Specifies the baseline of a component.
      static String EAST
      Specifies the right edge of a component's bounding rectangle.
      static String HEIGHT
      Specifies the height of a component's bounding rectangle.
      static String HORIZONTAL_CENTER
      Specifies the horizontal center of a component's bounding rectangle.
      static String NORTH
      Specifies the top edge of a component's bounding rectangle.
      static String SOUTH
      Specifies the bottom edge of a component's bounding rectangle.
      static String VERTICAL_CENTER
      Specifies the vertical center of a component's bounding rectangle.
      static String WEST
      Specifies the left edge of a component's bounding rectangle.
      static String WIDTH
      Specifies the width of a component's bounding rectangle.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpringLayout()
      Constructs a new SpringLayout.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component component, Object constraints)
      If constraints is an instance of SpringLayout.Constraints, associates the constraints with the specified component.
      void addLayoutComponent(String name, Component c)
      Has no effect, since this layout manager does not use a per-component string.
      Spring getConstraint(String edgeName, Component c)
      Returns the spring controlling the distance between the specified edge of the component and the top or left edge of its parent.
      SpringLayout.Constraints getConstraints(Component c)
      Returns the constraints for the specified component.
      float getLayoutAlignmentX(Container p)
      Returns 0.5f (centered).
      float getLayoutAlignmentY(Container p)
      Returns 0.5f (centered).
      void invalidateLayout(Container p)
      Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
      void layoutContainer(Container parent)
      Lays out the specified container.
      Dimension maximumLayoutSize(Container parent)
      Calculates the maximum size dimensions for the specified container, given the components it contains.
      Dimension minimumLayoutSize(Container parent)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container parent)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void putConstraint(String e1, Component c1, int pad, String e2, Component c2)
      Links edge e1 of component c1 to edge e2 of component c2, with a fixed distance between the edges.
      void putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
      Links edge e1 of component c1 to edge e2 of component c2.
      void removeLayoutComponent(Component c)
      Removes the constraints associated with the specified component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NORTH

        public static final String NORTH
        Specifies the top edge of a component's bounding rectangle.
        另请参见：
        Constant Field Values

      • SOUTH

        public static final String SOUTH
        Specifies the bottom edge of a component's bounding rectangle.
        另请参见：
        Constant Field Values

      • EAST

        public static final String EAST
        Specifies the right edge of a component's bounding rectangle.
        另请参见：
        Constant Field Values

      • WEST

        public static final String WEST
        Specifies the left edge of a component's bounding rectangle.
        另请参见：
        Constant Field Values

      • HORIZONTAL_CENTER

        public static final String HORIZONTAL_CENTER
        Specifies the horizontal center of a component's bounding rectangle.
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • VERTICAL_CENTER

        public static final String VERTICAL_CENTER
        Specifies the vertical center of a component's bounding rectangle.
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • BASELINE

        public static final String BASELINE
        Specifies the baseline of a component.
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • WIDTH

        public static final String WIDTH
        Specifies the width of a component's bounding rectangle.
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

      • HEIGHT

        public static final String HEIGHT
        Specifies the height of a component's bounding rectangle.
        从以下版本开始：
        1.6
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SpringLayout

        public SpringLayout()
        Constructs a new SpringLayout.

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component c)
        Has no effect, since this layout manager does not use a per-component string.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        c - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        Removes the constraints associated with the specified component.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component being removed from the container

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container parent)
        从接口复制的描述： LayoutManager2
        Calculates the maximum size dimensions for the specified container, given the components it contains.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        另请参见：
        Component.getMaximumSize(), LayoutManager

      • addLayoutComponent

        public void addLayoutComponent(Component component,
                      Object constraints)
        If constraints is an instance of SpringLayout.Constraints, associates the constraints with the specified component.

        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        component - the component being added
        constraints - the component's constraints
        另请参见：
        SpringLayout.Constraints

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container p)
        Returns 0.5f (centered).
        指定者：
        getLayoutAlignmentX in interface LayoutManager2

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container p)
        Returns 0.5f (centered).
        指定者：
        getLayoutAlignmentY in interface LayoutManager2

      • invalidateLayout

        public void invalidateLayout(Container p)
        从接口复制的描述： LayoutManager2
        Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
        指定者：
        invalidateLayout in interface LayoutManager2

      • putConstraint

        public void putConstraint(String e1,
                 Component c1,
                 int pad,
                 String e2,
                 Component c2)
        Links edge e1 of component c1 to edge e2 of component c2, with a fixed distance between the edges. This constraint will cause the assignment
             value(e1, c1) = value(e2, c2) + pad
        to take place during all subsequent layout operations.

        参数：
        e1 - the edge of the dependent
        c1 - the component of the dependent
        pad - the fixed distance between dependent and anchor
        e2 - the edge of the anchor
        c2 - the component of the anchor
        另请参见：
        putConstraint(String, Component, Spring, String, Component)

      • putConstraint

        public void putConstraint(String e1,
                 Component c1,
                 Spring s,
                 String e2,
                 Component c2)
        Links edge e1 of component c1 to edge e2 of component c2. As edge (e2, c2) changes value, edge (e1, c1) will be calculated by taking the (spring) sum of (e2, c2) and s. Each edge must have one of the following values: SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.VERTICAL_CENTER, SpringLayout.HORIZONTAL_CENTER or SpringLayout.BASELINE.

        参数：
        e1 - the edge of the dependent
        c1 - the component of the dependent
        s - the spring linking dependent and anchor
        e2 - the edge of the anchor
        c2 - the component of the anchor
        另请参见：
        putConstraint(String, Component, int, String, Component), NORTH, SOUTH, EAST, WEST, VERTICAL_CENTER, HORIZONTAL_CENTER, BASELINE

      • getConstraints

        public SpringLayout.Constraints getConstraints(Component c)
        Returns the constraints for the specified component. Note that, unlike the GridBagLayout getConstraints method, this method does not clone constraints. If no constraints have been associated with this component, this method returns a default constraints object positioned at 0,0 relative to the parent's Insets and its width/height constrained to the minimum, maximum, and preferred sizes of the component. The size characteristics are not frozen at the time this method is called; instead this method returns a constraints object whose characteristics track the characteristics of the component as they change.
        参数：
        c - the component whose constraints will be returned
        返回：
        the constraints for the specified component

      • getConstraint

        public Spring getConstraint(String edgeName,
                   Component c)
        Returns the spring controlling the distance between the specified edge of the component and the top or left edge of its parent. This method, instead of returning the current binding for the edge, returns a proxy that tracks the characteristics of the edge even if the edge is subsequently rebound. Proxies are intended to be used in builder envonments where it is useful to allow the user to define the constraints for a layout in any order. Proxies do, however, provide the means to create cyclic dependencies amongst the constraints of a layout. Such cycles are detected internally by SpringLayout so that the layout operation always terminates.
        参数：
        edgeName - must be one of SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.VERTICAL_CENTER, SpringLayout.HORIZONTAL_CENTER or SpringLayout.BASELINE
        c - the component whose edge spring is desired
        返回：
        a proxy for the spring controlling the distance between the specified edge and the top or left edge of its parent
        另请参见：
        NORTH, SOUTH, EAST, WEST, VERTICAL_CENTER, HORIZONTAL_CENTER, BASELINE

      • layoutContainer

        public void layoutContainer(Container parent)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to be laid out
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SpringLayout.Constraints

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SpringLayout.Constraints

  • java.lang.Object
    • javax.swing.SpringLayout.Constraints
  • 封闭类：
    SpringLayout

    public static class SpringLayout.Constraints
extends Object
    A Constraints object holds the constraints that govern the way a component's size and position change in a container controlled by a SpringLayout. A Constraints object is like a Rectangle, in that it has x, y, width, and height properties. In the Constraints object, however, these properties have Spring values instead of integers. In addition, a Constraints object can be manipulated as four edges -- north, south, east, and west -- using the constraint property.

    The following formulas are always true for a Constraints object (here WEST and x are synonyms, as are and NORTH and y):

                   EAST = WEST + WIDTH
              SOUTH = NORTH + HEIGHT
  HORIZONTAL_CENTER = WEST + WIDTH/2
    VERTICAL_CENTER = NORTH + HEIGHT/2
  ABSOLUTE_BASELINE = NORTH + RELATIVE_BASELINE*

    For example, if you have specified the WIDTH and WEST (X) location the EAST is calculated as WEST + WIDTH. If you instead specified the WIDTH and EAST locations the WEST (X) location is then calculated as EAST - WIDTH.

    [RELATIVE_BASELINE is a private constraint that is set automatically when the SpringLayout.Constraints(Component) constuctor is called or when a constraints object is registered with a SpringLayout object.]

    Note: In this document, operators represent methods in the Spring class. For example, "a + b" is equal to Spring.sum(a, b), and "a - b" is equal to Spring.sum(a, Spring.minus(b)). See the Spring API documentation for further details of spring arithmetic.

    Because a Constraints object's properties -- representing its edges, size, and location -- can all be set independently and yet are interrelated, a Constraints object can become over-constrained. For example, if the WEST, WIDTH and EAST edges are all set, steps must be taken to ensure that the first of the formulas above holds. To do this, the Constraints object throws away the least recently set constraint so as to make the formulas hold.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpringLayout.Constraints()
      Creates an empty Constraints object.
      SpringLayout.Constraints(Component c)
      Creates a Constraints object with suitable x, y, width and height springs for component, c.
      SpringLayout.Constraints(Spring x, Spring y)
      Creates a Constraints object with the specified values for its x and y properties.
      SpringLayout.Constraints(Spring x, Spring y, Spring width, Spring height)
      Creates a Constraints object with the specified values for its x, y, width, and height properties.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Spring getConstraint(String edgeName)
      Returns the value of the specified edge, which may be a derived value, or even null.
      Spring getHeight()
      Returns the value of the height property.
      Spring getWidth()
      Returns the value of the width property.
      Spring getX()
      Returns the value of the x property.
      Spring getY()
      Returns the value of the y property.
      void setConstraint(String edgeName, Spring s)
      Sets the spring controlling the specified edge.
      void setHeight(Spring height)
      Sets the height property, which controls the height of a component.
      void setWidth(Spring width)
      Sets the width property, which controls the width of a component.
      void setX(Spring x)
      Sets the x property, which controls the x value of a component's location.
      void setY(Spring y)
      Sets the y property, which controls the y value of a component's location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SpringLayout.Constraints

        public SpringLayout.Constraints()
        Creates an empty Constraints object.

      • SpringLayout.Constraints

        public SpringLayout.Constraints(Spring x,
                        Spring y)
        Creates a Constraints object with the specified values for its x and y properties. The height and width springs have null values.
        参数：
        x - the spring controlling the component's x value
        y - the spring controlling the component's y value

      • SpringLayout.Constraints

        public SpringLayout.Constraints(Spring x,
                        Spring y,
                        Spring width,
                        Spring height)
        Creates a Constraints object with the specified values for its x, y, width, and height properties. Note: If the SpringLayout class encounters null values in the Constraints object of a given component, it replaces them with suitable defaults.
        参数：
        x - the spring value for the x property
        y - the spring value for the y property
        width - the spring value for the width property
        height - the spring value for the height property

      • SpringLayout.Constraints

        public SpringLayout.Constraints(Component c)
        Creates a Constraints object with suitable x, y, width and height springs for component, c. The x and y springs are constant springs initialised with the component's location at the time this method is called. The width and height springs are special springs, created by the Spring.width() and Spring.height() methods, which track the size characteristics of the component when they change.
        参数：
        c - the component whose characteristics will be reflected by this Constraints object
        抛出：
        NullPointerException - if c is null.
        从以下版本开始：
        1.5

    • 方法详细信息

      • setX

        public void setX(Spring x)
        Sets the x property, which controls the x value of a component's location.
        参数：
        x - the spring controlling the x value of a component's location
        另请参见：
        getX(), SpringLayout.Constraints

      • getX

        public Spring getX()
        Returns the value of the x property.
        返回：
        the spring controlling the x value of a component's location
        另请参见：
        setX(javax.swing.Spring), SpringLayout.Constraints

      • setY

        public void setY(Spring y)
        Sets the y property, which controls the y value of a component's location.
        参数：
        y - the spring controlling the y value of a component's location
        另请参见：
        getY(), SpringLayout.Constraints

      • getY

        public Spring getY()
        Returns the value of the y property.
        返回：
        the spring controlling the y value of a component's location
        另请参见：
        setY(javax.swing.Spring), SpringLayout.Constraints

      • setWidth

        public void setWidth(Spring width)
        Sets the width property, which controls the width of a component.
        参数：
        width - the spring controlling the width of this Constraints object
        另请参见：
        getWidth(), SpringLayout.Constraints

      • getWidth

        public Spring getWidth()
        Returns the value of the width property.
        返回：
        the spring controlling the width of a component
        另请参见：
        setWidth(javax.swing.Spring), SpringLayout.Constraints

      • setHeight

        public void setHeight(Spring height)
        Sets the height property, which controls the height of a component.
        参数：
        height - the spring controlling the height of this Constraints object
        另请参见：
        getHeight(), SpringLayout.Constraints

      • getHeight

        public Spring getHeight()
        Returns the value of the height property.
        返回：
        the spring controlling the height of a component
        另请参见：
        setHeight(javax.swing.Spring), SpringLayout.Constraints

      • setConstraint

        public void setConstraint(String edgeName,
                 Spring s)
        Sets the spring controlling the specified edge. The edge must have one of the following values: SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH or SpringLayout.HEIGHT. For any other String value passed as the edge, no action is taken. For a null edge, a NullPointerException is thrown.

        Note: This method can affect x and y values previously set for this Constraints.

        参数：
        edgeName - the edge to be set
        s - the spring controlling the specified edge
        抛出：
        NullPointerException - if edgeName is null
        另请参见：
        getConstraint(java.lang.String), SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH, SpringLayout.HEIGHT, SpringLayout.Constraints

      • getConstraint

        public Spring getConstraint(String edgeName)
        Returns the value of the specified edge, which may be a derived value, or even null. The edge must have one of the following values: SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH or SpringLayout.HEIGHT. For any other String value passed as the edge, null will be returned. Throws NullPointerException for a null edge.
        参数：
        edgeName - the edge whose value is to be returned
        返回：
        the spring controlling the specified edge, may be null
        抛出：
        NullPointerException - if edgeName is null
        另请参见：
        setConstraint(java.lang.String, javax.swing.Spring), SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH, SpringLayout.HEIGHT, SpringLayout.Constraints
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_lbnsnlnrn_var_tasyycvp< ttia a s esia


SwingConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing

Interface SwingConstants

  • All Known Implementing Classes:
    AbstractButton, AsyncBoxView, BasicArrowButton, BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, BasicInternalFrameUI.BorderListener, BasicScrollBarUI, BasicTabbedPaneUI, BasicToolBarUI, BlockView, BoxView, ComponentView, CompositeView, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource, DefaultTreeCellEditor.DefaultTextField, DefaultTreeCellRenderer, FieldView, FlowView, FormView, GlyphView, IconView, ImageView, InlineView, JButton, JCheckBox, JCheckBoxMenuItem, JFormattedTextField, JLabel, JMenu, JMenuItem, JPasswordField, JPopupMenu.Separator, JProgressBar, JRadioButton, JRadioButtonMenuItem, JSeparator, JSlider, JTabbedPane, JTextField, JToggleButton, JToolBar, JToolBar.Separator, LabelView, ListView, MetalBorders.ToolBarBorder, MetalComboBoxButton, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer, MetalScrollBarUI, MetalScrollButton, MetalTabbedPaneUI, MetalToolBarUI, ObjectView, ParagraphView, ParagraphView, PasswordView, PlainView, SwingUtilities, SynthScrollBarUI, SynthTabbedPaneUI, SynthToolBarUI, TableView, TableView.TableCell, TableView.TableRow, View, WrappedPlainView, ZoneView

    public interface SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int BOTTOM
      Box-orientation constant used to specify the bottom of a box.
      static int CENTER
      The central position in an area.
      static int EAST
      Compass-direction east (right).
      static int HORIZONTAL
      Horizontal orientation.
      static int LEADING
      Identifies the leading edge of text for use with left-to-right and right-to-left languages.
      static int LEFT
      Box-orientation constant used to specify the left side of a box.
      static int 下一个
      Identifies the next direction in a sequence.
      static int NORTH
      Compass-direction North (up).
      static int NORTH_EAST
      Compass-direction north-east (upper right).
      static int NORTH_WEST
      Compass-direction north west (upper left).
      static int PREVIOUS
      Identifies the previous direction in a sequence.
      static int RIGHT
      Box-orientation constant used to specify the right side of a box.
      static int SOUTH
      Compass-direction south (down).
      static int SOUTH_EAST
      Compass-direction south-east (lower right).
      static int SOUTH_WEST
      Compass-direction south-west (lower left).
      static int TOP
      Box-orientation constant used to specify the top of a box.
      static int TRAILING
      Identifies the trailing edge of text for use with left-to-right and right-to-left languages.
      static int VERTICAL
      Vertical orientation.
      static int WEST
      Compass-direction west (left).

    • 字段详细信息

      • CENTER

        static final int CENTER
        The central position in an area. Used for both compass-direction constants (NORTH, etc.) and box-orientation constants (TOP, etc.).
        另请参见：
        Constant Field Values

      • TOP

        static final int TOP
        Box-orientation constant used to specify the top of a box.
        另请参见：
        Constant Field Values

      • LEFT

        static final int LEFT
        Box-orientation constant used to specify the left side of a box.
        另请参见：
        Constant Field Values

      • BOTTOM

        static final int BOTTOM
        Box-orientation constant used to specify the bottom of a box.
        另请参见：
        Constant Field Values

      • RIGHT

        static final int RIGHT
        Box-orientation constant used to specify the right side of a box.
        另请参见：
        Constant Field Values

      • NORTH

        static final int NORTH
        Compass-direction North (up).
        另请参见：
        Constant Field Values

      • NORTH_EAST

        static final int NORTH_EAST
        Compass-direction north-east (upper right).
        另请参见：
        Constant Field Values

      • EAST

        static final int EAST
        Compass-direction east (right).
        另请参见：
        Constant Field Values

      • SOUTH_EAST

        static final int SOUTH_EAST
        Compass-direction south-east (lower right).
        另请参见：
        Constant Field Values

      • SOUTH

        static final int SOUTH
        Compass-direction south (down).
        另请参见：
        Constant Field Values

      • SOUTH_WEST

        static final int SOUTH_WEST
        Compass-direction south-west (lower left).
        另请参见：
        Constant Field Values

      • WEST

        static final int WEST
        Compass-direction west (left).
        另请参见：
        Constant Field Values

      • NORTH_WEST

        static final int NORTH_WEST
        Compass-direction north west (upper left).
        另请参见：
        Constant Field Values

      • HORIZONTAL

        static final int HORIZONTAL
        Horizontal orientation. Used for scrollbars and sliders.
        另请参见：
        Constant Field Values

      • VERTICAL

        static final int VERTICAL
        Vertical orientation. Used for scrollbars and sliders.
        另请参见：
        Constant Field Values

      • LEADING

        static final int LEADING
        Identifies the leading edge of text for use with left-to-right and right-to-left languages. Used by buttons and labels.
        另请参见：
        Constant Field Values

      • TRAILING

        static final int TRAILING
        Identifies the trailing edge of text for use with left-to-right and right-to-left languages. Used by buttons and labels.
        另请参见：
        Constant Field Values

      • 下一个

        static final int NEXT
        Identifies the next direction in a sequence.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values

      • PREVIOUS

        static final int PREVIOUS
        Identifies the previous direction in a sequence.
        从以下版本开始：
        1.4
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i nle.vs.v-aav--s.ddinbgn o莚>tul


SwingUtilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 SwingUtilities

  • java.lang.Object
    • javax.swing.SwingUtilities
  • 所有已实现的接口：
    SwingConstants

    public class SwingUtilities
extends Object
implements SwingConstants
    A collection of utility methods for Swing.

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Rectangle calculateInnerArea(JComponent c, Rectangle r)
      Stores the position and size of the inner painting area of the specified component in r and returns r.
      static Rectangle[] computeDifference(Rectangle rectA, Rectangle rectB)
      Convenience returning an array of rect representing the regions within rectA that do not overlap with rectB.
      static Rectangle computeIntersection(int x, int y, int width, int height, Rectangle dest)
      Convenience to calculate the intersection of two rectangles without allocating a new rectangle.
      static int computeStringWidth(FontMetrics fm, String str)
      Compute the width of the string using a font with the specified "metrics" (sizes).
      static Rectangle computeUnion(int x, int y, int width, int height, Rectangle dest)
      Convenience method that calculates the union of two rectangles without allocating a new rectangle.
      static MouseEvent convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
      Returns a MouseEvent similar to sourceEvent except that its x and y members have been converted to destination's coordinate system.
      static Point convertPoint(Component source, int x, int y, Component destination)
      Convert the point (x,y) in source coordinate system to destination coordinate system.
      static Point convertPoint(Component source, Point aPoint, Component destination)
      Convert a aPoint in source coordinate system to destination coordinate system.
      static void convertPointFromScreen(Point p, Component c)
      Convert a point from a screen coordinates to a component's coordinate system
      static void convertPointToScreen(Point p, Component c)
      Convert a point from a component's coordinate system to screen coordinates.
      static Rectangle convertRectangle(Component source, Rectangle aRectangle, Component destination)
      Convert the rectangle aRectangle in source coordinate system to destination coordinate system.
      static Component findFocusOwner(Component c)
      Deprecated.
      As of 1.4, replaced by KeyboardFocusManager.getFocusOwner().
      static Accessible getAccessibleAt(Component c, Point p)
      Returns the Accessible child contained at the local coordinate Point, if one exists.
      static Accessible getAccessibleChild(Component c, int i)
      Return the nth Accessible child of the object.
      static int getAccessibleChildrenCount(Component c)
      Returns the number of accessible children in the object.
      static int getAccessibleIndexInParent(Component c)
      Get the index of this object in its accessible parent.
      static AccessibleStateSet getAccessibleStateSet(Component c)
      Get the state of this object.
      static Container getAncestorNamed(String name, Component comp)
      Convenience method for searching above comp in the component hierarchy and returns the first object of name it finds.
      static Container getAncestorOfClass(类<?> c, Component comp)
      Convenience method for searching above comp in the component hierarchy and returns the first object of class c it finds.
      static Component getDeepestComponentAt(Component parent, int x, int y)
      Returns the deepest visible descendent Component of parent that contains the location x, y.
      static Rectangle getLocalBounds(Component aComponent)
      Return the rectangle (0,0,bounds.width,bounds.height) for the component aComponent
      static Component getRoot(Component c)
      Returns the root component for the current component tree.
      static JRootPane getRootPane(Component c)
      If c is a JRootPane descendant return its JRootPane ancestor.
      static ActionMap getUIActionMap(JComponent component)
      Returns the ActionMap provided by the UI in component component.
      static InputMap getUIInputMap(JComponent component, int condition)
      Returns the InputMap provided by the UI for condition condition in component component.
      static Container getUnwrappedParent(Component component)
      Returns the first ancestor of the component which is not an instance of JLayer.
      static Component getUnwrappedView(JViewport viewport)
      Returns the first JViewport's descendant which is not an instance of JLayer.
      static Window getWindowAncestor(Component c)
      Returns the first Window ancestor of c, or null if c is not contained inside a Window.
      static void invokeAndWait(Runnable doRun)
      Causes doRun.run() to be executed synchronously on the AWT event dispatching thread.
      static void invokeLater(Runnable doRun)
      Causes doRun.run() to be executed asynchronously on the AWT event dispatching thread.
      static boolean isDescendingFrom(Component a, Component b)
      Return true if a component a descends from a component b
      static boolean isEventDispatchThread()
      Returns true if the current thread is an AWT event dispatching thread.
      static boolean isLeftMouseButton(MouseEvent anEvent)
      Returns true if the mouse event specifies the left mouse button.
      static boolean isMiddleMouseButton(MouseEvent anEvent)
      Returns true if the mouse event specifies the middle mouse button.
      static boolean isRectangleContainingRectangle(Rectangle a, Rectangle b)
      Return true if a contains b
      static boolean isRightMouseButton(MouseEvent anEvent)
      Returns true if the mouse event specifies the right mouse button.
      static String layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
      static String layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
      static boolean notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
      Invokes actionPerformed on action if action is enabled (and non-null).
      static void paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
      Paints a component to the specified Graphics.
      static void paintComponent(Graphics g, Component c, Container p, Rectangle r)
      Paints a component to the specified Graphics.
      static boolean processKeyBindings(KeyEvent event)
      Process the key bindings for the Component associated with event.
      static void replaceUIActionMap(JComponent component, ActionMap uiActionMap)
      Convenience method to change the UI ActionMap for component to uiActionMap.
      static void replaceUIInputMap(JComponent component, int type, InputMap uiInputMap)
      Convenience method to change the UI InputMap for component to uiInputMap.
      static void updateComponentTreeUI(Component c)
      A simple minded look and feel change: ask each node in the tree to updateUI() -- that is, to initialize its UI property with the current look and feel.
      static Window windowForComponent(Component c)
      Returns the first Window ancestor of c, or null if c is not contained inside a Window.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • isRectangleContainingRectangle

        public static final boolean isRectangleContainingRectangle(Rectangle a,
                                     Rectangle b)
        Return true if a contains b

      • getLocalBounds

        public static Rectangle getLocalBounds(Component aComponent)
        Return the rectangle (0,0,bounds.width,bounds.height) for the component aComponent

      • getWindowAncestor

        public static Window getWindowAncestor(Component c)
        Returns the first Window ancestor of c, or null if c is not contained inside a Window.
        参数：
        c - Component to get Window ancestor of.
        返回：
        the first Window ancestor of c, or null if c is not contained inside a Window.
        从以下版本开始：
        1.3

      • convertPoint

        public static Point convertPoint(Component source,
                 Point aPoint,
                 Component destination)
        Convert a aPoint in source coordinate system to destination coordinate system. If source is null, aPoint is assumed to be in destination's root component coordinate system. If destination is null, aPoint will be converted to source's root component coordinate system. If both source and destination are null, return aPoint without any conversion.

      • convertPoint

        public static Point convertPoint(Component source,
                 int x,
                 int y,
                 Component destination)
        Convert the point (x,y) in source coordinate system to destination coordinate system. If source is null, (x,y) is assumed to be in destination's root component coordinate system. If destination is null, (x,y) will be converted to source's root component coordinate system. If both source and destination are null, return (x,y) without any conversion.

      • convertRectangle

        public static Rectangle convertRectangle(Component source,
                         Rectangle aRectangle,
                         Component destination)
        Convert the rectangle aRectangle in source coordinate system to destination coordinate system. If source is null, aRectangle is assumed to be in destination's root component coordinate system. If destination is null, aRectangle will be converted to source's root component coordinate system. If both source and destination are null, return aRectangle without any conversion.

      • getAncestorOfClass

        public static Container getAncestorOfClass(类<?> c,
                           Component comp)
        Convenience method for searching above comp in the component hierarchy and returns the first object of class c it finds. Can return null, if a class c cannot be found.

      • getAncestorNamed

        public static Container getAncestorNamed(String name,
                         Component comp)
        Convenience method for searching above comp in the component hierarchy and returns the first object of name it finds. Can return null, if name cannot be found.

      • getDeepestComponentAt

        public static Component getDeepestComponentAt(Component parent,
                              int x,
                              int y)
        Returns the deepest visible descendent Component of parent that contains the location x, y. If parent does not contain the specified location, then null is returned. If parent is not a container, or none of parent's visible descendents contain the specified location, parent is returned.
        参数：
        parent - the root component to begin the search
        x - the x target location
        y - the y target location

      • convertMouseEvent

        public static MouseEvent convertMouseEvent(Component source,
                           MouseEvent sourceEvent,
                           Component destination)
        Returns a MouseEvent similar to sourceEvent except that its x and y members have been converted to destination's coordinate system. If source is null, sourceEvent x and y members are assumed to be into destination's root component coordinate system. If destination is null, the returned MouseEvent will be in source's coordinate system. sourceEvent will not be changed. A new event is returned. the source field of the returned event will be set to destination if destination is non-null use the translateMouseEvent() method to translate a mouse event from one component to another without changing the source.

      • convertPointToScreen

        public static void convertPointToScreen(Point p,
                        Component c)
        Convert a point from a component's coordinate system to screen coordinates.
        参数：
        p - a Point object (converted to the new coordinate system)
        c - a Component object

      • convertPointFromScreen

        public static void convertPointFromScreen(Point p,
                          Component c)
        Convert a point from a screen coordinates to a component's coordinate system
        参数：
        p - a Point object (converted to the new coordinate system)
        c - a Component object

      • windowForComponent

        public static Window windowForComponent(Component c)
        Returns the first Window ancestor of c, or null if c is not contained inside a Window.

        Note: This method provides the same functionality as getWindowAncestor.

        参数：
        c - Component to get Window ancestor of.
        返回：
        the first Window ancestor of c, or null if c is not contained inside a Window.

      • isDescendingFrom

        public static boolean isDescendingFrom(Component a,
                       Component b)
        Return true if a component a descends from a component b

      • computeIntersection

        public static Rectangle computeIntersection(int x,
                            int y,
                            int width,
                            int height,
                            Rectangle dest)
        Convenience to calculate the intersection of two rectangles without allocating a new rectangle. If the two rectangles don't intersect, then the returned rectangle begins at (0,0) and has zero width and height.
        参数：
        x - the X coordinate of the first rectangle's top-left point
        y - the Y coordinate of the first rectangle's top-left point
        width - the width of the first rectangle
        height - the height of the first rectangle
        dest - the second rectangle
        返回：
        dest, modified to specify the intersection

      • computeUnion

        public static Rectangle computeUnion(int x,
                     int y,
                     int width,
                     int height,
                     Rectangle dest)
        Convenience method that calculates the union of two rectangles without allocating a new rectangle.
        参数：
        x - the x-coordinate of the first rectangle
        y - the y-coordinate of the first rectangle
        width - the width of the first rectangle
        height - the height of the first rectangle
        dest - the coordinates of the second rectangle; the union of the two rectangles is returned in this rectangle
        返回：
        the dest Rectangle

      • computeDifference

        public static Rectangle[] computeDifference(Rectangle rectA,
                            Rectangle rectB)
        Convenience returning an array of rect representing the regions within rectA that do not overlap with rectB. If the two Rects do not overlap, returns an empty array

      • isLeftMouseButton

        public static boolean isLeftMouseButton(MouseEvent anEvent)
        Returns true if the mouse event specifies the left mouse button.
        参数：
        anEvent - a MouseEvent object
        返回：
        true if the left mouse button was active

      • isMiddleMouseButton

        public static boolean isMiddleMouseButton(MouseEvent anEvent)
        Returns true if the mouse event specifies the middle mouse button.
        参数：
        anEvent - a MouseEvent object
        返回：
        true if the middle mouse button was active

      • isRightMouseButton

        public static boolean isRightMouseButton(MouseEvent anEvent)
        Returns true if the mouse event specifies the right mouse button.
        参数：
        anEvent - a MouseEvent object
        返回：
        true if the right mouse button was active

      • computeStringWidth

        public static int computeStringWidth(FontMetrics fm,
                     String str)
        Compute the width of the string using a font with the specified "metrics" (sizes).
        参数：
        fm - a FontMetrics object to compute with
        str - the String to compute
        返回：
        an int containing the string width

      • layoutCompoundLabel

        public static String layoutCompoundLabel(JComponent c,
                         FontMetrics fm,
                         String text,
                         Icon icon,
                         int verticalAlignment,
                         int horizontalAlignment,
                         int verticalTextPosition,
                         int horizontalTextPosition,
                         Rectangle viewR,
                         Rectangle iconR,
                         Rectangle textR,
                         int textIconGap)
        Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string. Locations are computed relative to the viewR rectangle. The JComponents orientation (LEADING/TRAILING) will also be taken into account and translated into LEFT/RIGHT values accordingly.

      • layoutCompoundLabel

        public static String layoutCompoundLabel(FontMetrics fm,
                         String text,
                         Icon icon,
                         int verticalAlignment,
                         int horizontalAlignment,
                         int verticalTextPosition,
                         int horizontalTextPosition,
                         Rectangle viewR,
                         Rectangle iconR,
                         Rectangle textR,
                         int textIconGap)
        Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string. Locations are computed relative to the viewR rectangle. This layoutCompoundLabel() does not know how to handle LEADING/TRAILING values in horizontalTextPosition (they will default to RIGHT) and in horizontalAlignment (they will default to CENTER). Use the other version of layoutCompoundLabel() instead.

      • paintComponent

        public static void paintComponent(Graphics g,
                  Component c,
                  Container p,
                  int x,
                  int y,
                  int w,
                  int h)
        Paints a component to the specified Graphics. This method is primarily useful to render Components that don't exist as part of the visible containment hierarchy, but are used for rendering. For example, if you are doing your own rendering and want to render some text (or even HTML), you could make use of JLabel's text rendering support and have it paint directly by way of this method, without adding the label to the visible containment hierarchy.

        This method makes use of CellRendererPane to handle the actual painting, and is only recommended if you use one component for rendering. If you make use of multiple components to handle the rendering, as JTable does, use CellRendererPane directly. Otherwise, as described below, you could end up with a CellRendererPane per Component.

        If c's parent is not a CellRendererPane, a new CellRendererPane is created, c is added to it, and the CellRendererPane is added to p. If c's parent is a CellRendererPane and the CellRendererPanes parent is not p, it is added to p.

        The component should either descend from JComponent or be another kind of lightweight component. A lightweight component is one whose "lightweight" property (returned by the Component isLightweight method) is true. If the Component is not lightweight, bad things map happen: crashes, exceptions, painting problems...

        参数：
        g - the Graphics object to draw on
        c - the Component to draw
        p - the intermediate Container
        x - an int specifying the left side of the area draw in, in pixels, measured from the left edge of the graphics context
        y - an int specifying the top of the area to draw in, in pixels measured down from the top edge of the graphics context
        w - an int specifying the width of the area draw in, in pixels
        h - an int specifying the height of the area draw in, in pixels
        另请参见：
        CellRendererPane, Component.isLightweight()

      • paintComponent

        public static void paintComponent(Graphics g,
                  Component c,
                  Container p,
                  Rectangle r)
        Paints a component to the specified Graphics. This is a cover method for paintComponent(Graphics,Component,Container,int,int,int,int). Refer to it for more information.
        参数：
        g - the Graphics object to draw on
        c - the Component to draw
        p - the intermediate Container
        r - the Rectangle to draw in
        另请参见：
        paintComponent(Graphics,Component,Container,int,int,int,int), CellRendererPane

      • updateComponentTreeUI

        public static void updateComponentTreeUI(Component c)
        A simple minded look and feel change: ask each node in the tree to updateUI() -- that is, to initialize its UI property with the current look and feel.

      • invokeLater

        public static void invokeLater(Runnable doRun)
        Causes doRun.run() to be executed asynchronously on the AWT event dispatching thread. This will happen after all pending AWT events have been processed. This method should be used when an application thread needs to update the GUI. In the following example the invokeLater call queues the Runnable object doHelloWorld on the event dispatching thread and then prints a message.
         Runnable doHelloWorld = new Runnable() {
     public void run() {
         System.out.println("Hello World on " + Thread.currentThread());
     }
 };

 SwingUtilities.invokeLater(doHelloWorld);
 System.out.println("This might well be displayed before the other message.");
        If invokeLater is called from the event dispatching thread -- for example, from a JButton's ActionListener -- the doRun.run() will still be deferred until all pending events have been processed. Note that if the doRun.run() throws an uncaught exception the event dispatching thread will unwind (not the current thread).

        Additional documentation and examples for this method can be found in How to Use Threads, in The Java Tutorial.

        As of 1.3 this method is just a cover for java.awt.EventQueue.invokeLater().

        Unlike the rest of Swing, this method can be invoked from any thread.

        另请参见：
        invokeAndWait(java.lang.Runnable)

      • invokeAndWait

        public static void invokeAndWait(Runnable doRun)
                          throws InterruptedException,
                                 InvocationTargetException
        Causes doRun.run() to be executed synchronously on the AWT event dispatching thread. This call blocks until all pending AWT events have been processed and (then) doRun.run() returns. This method should be used when an application thread needs to update the GUI. It shouldn't be called from the event dispatching thread. Here's an example that creates a new application thread that uses invokeAndWait to print a string from the event dispatching thread and then, when that's finished, print a string from the application thread.
         final Runnable doHelloWorld = new Runnable() {
     public void run() {
         System.out.println("Hello World on " + Thread.currentThread());
     }
 };

 Thread appThread = new Thread() {
     public void run() {
         try {
             SwingUtilities.invokeAndWait(doHelloWorld);
         }
         catch (Exception e) {
             e.printStackTrace();
         }
         System.out.println("Finished on " + Thread.currentThread());
     }
 };
 appThread.start();
        Note that if the Runnable.run method throws an uncaught exception (on the event dispatching thread) it's caught and rethrown, as an InvocationTargetException, on the caller's thread.

        Additional documentation and examples for this method can be found in How to Use Threads, in The Java Tutorial.

        As of 1.3 this method is just a cover for java.awt.EventQueue.invokeAndWait().

        抛出：
        InterruptedException - if we're interrupted while waiting for the event dispatching thread to finish excecuting doRun.run()
        InvocationTargetException - if an exception is thrown while running doRun
        另请参见：
        invokeLater(java.lang.Runnable)

      • isEventDispatchThread

        public static boolean isEventDispatchThread()
        Returns true if the current thread is an AWT event dispatching thread.

        As of 1.3 this method is just a cover for java.awt.EventQueue.isDispatchThread().

        返回：
        true if the current thread is an AWT event dispatching thread

      • getAccessibleIndexInParent

        public static int getAccessibleIndexInParent(Component c)
        Get the index of this object in its accessible parent.

        Note: as of the Java 2 platform v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleIndexInParent() instead of using this method.

        返回：
        -1 of this object does not have an accessible parent. Otherwise, the index of the child in its accessible parent.

      • getAccessibleAt

        public static Accessible getAccessibleAt(Component c,
                         Point p)
        Returns the Accessible child contained at the local coordinate Point, if one exists. Otherwise returns null.
        返回：
        the Accessible at the specified location, if it exists; otherwise null

      • getAccessibleStateSet

        public static AccessibleStateSet getAccessibleStateSet(Component c)
        Get the state of this object.

        Note: as of the Java 2 platform v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleIndexInParent() instead of using this method.

        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleState

      • getAccessibleChildrenCount

        public static int getAccessibleChildrenCount(Component c)
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.

        Note: as of the Java 2 platform v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleIndexInParent() instead of using this method.

        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public static Accessible getAccessibleChild(Component c,
                            int i)
        Return the nth Accessible child of the object.

        Note: as of the Java 2 platform v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleIndexInParent() instead of using this method.

        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object

      • findFocusOwner

        @Deprecated
public static Component findFocusOwner(Component c)
        Deprecated. As of 1.4, replaced by KeyboardFocusManager.getFocusOwner().
        Return the child Component of the specified Component that is the focus owner, if any.
        参数：
        c - the root of the Component hierarchy to search for the focus owner
        返回：
        the focus owner, or null if there is no focus owner, or if the focus owner is not comp, or a descendant of comp
        另请参见：
        KeyboardFocusManager.getFocusOwner()

      • getRootPane

        public static JRootPane getRootPane(Component c)
        If c is a JRootPane descendant return its JRootPane ancestor. If c is a RootPaneContainer then return its JRootPane.
        返回：
        the JRootPane for Component c or null.

      • getRoot

        public static Component getRoot(Component c)
        Returns the root component for the current component tree.
        返回：
        the first ancestor of c that's a Window or the last Applet ancestor

      • processKeyBindings

        public static boolean processKeyBindings(KeyEvent event)
        Process the key bindings for the Component associated with event. This method is only useful if event.getComponent() does not descend from JComponent, or your are not invoking super.processKeyEvent from within your JComponent subclass. JComponent automatically processes bindings from within its processKeyEvent method, hence you rarely need to directly invoke this method.
        参数：
        event - KeyEvent used to identify which bindings to process, as well as which Component has focus.
        返回：
        true if a binding has found and processed
        从以下版本开始：
        1.4

      • notifyAction

        public static boolean notifyAction(Action action,
                   KeyStroke ks,
                   KeyEvent event,
                   Object sender,
                   int modifiers)
        Invokes actionPerformed on action if action is enabled (and non-null). The command for the ActionEvent is determined by:
        1. If the action was registered via registerKeyboardAction, then the command string passed in (null will be used if null was passed in).
        2. Action value with name Action.ACTION_COMMAND_KEY, unless null.
        3. String value of the KeyEvent, unless getKeyChar returns KeyEvent.CHAR_UNDEFINED..
        This will return true if action is non-null and actionPerformed is invoked on it.
        从以下版本开始：
        1.3

      • replaceUIInputMap

        public static void replaceUIInputMap(JComponent component,
                     int type,
                     InputMap uiInputMap)
        Convenience method to change the UI InputMap for component to uiInputMap. If uiInputMap is null, this removes any previously installed UI InputMap.
        从以下版本开始：
        1.3

      • replaceUIActionMap

        public static void replaceUIActionMap(JComponent component,
                      ActionMap uiActionMap)
        Convenience method to change the UI ActionMap for component to uiActionMap. If uiActionMap is null, this removes any previously installed UI ActionMap.
        从以下版本开始：
        1.3

      • getUIInputMap

        public static InputMap getUIInputMap(JComponent component,
                     int condition)
        Returns the InputMap provided by the UI for condition condition in component component.

        This will return null if the UI has not installed a InputMap of the specified type.

        从以下版本开始：
        1.3

      • getUIActionMap

        public static ActionMap getUIActionMap(JComponent component)
        Returns the ActionMap provided by the UI in component component.

        This will return null if the UI has not installed an ActionMap.

        从以下版本开始：
        1.3

      • calculateInnerArea

        public static Rectangle calculateInnerArea(JComponent c,
                           Rectangle r)
        Stores the position and size of the inner painting area of the specified component in r and returns r. The position and size specify the bounds of the component, adjusted so as not to include the border area (the insets). This method is useful for classes that implement painting code.
        参数：
        c - the JComponent in question; if null, this method returns null
        r - the Rectangle instance to be modified; may be null
        返回：
        null if the Component is null; otherwise, returns the passed-in rectangle (if non-null) or a new rectangle specifying position and size information
        从以下版本开始：
        1.4

      • getUnwrappedParent

        public static Container getUnwrappedParent(Component component)
        Returns the first ancestor of the component which is not an instance of JLayer.
        参数：
        component - Component to get the first ancestor of, which is not a JLayer instance.
        返回：
        the first ancestor of the component which is not an instance of JLayer. If such an ancestor can not be found, null is returned.
        抛出：
        NullPointerException - if component is null
        从以下版本开始：
        1.7
        另请参见：
        JLayer

      • getUnwrappedView

        public static Component getUnwrappedView(JViewport viewport)
        Returns the first JViewport's descendant which is not an instance of JLayer. If such a descendant can not be found, null is returned. If the viewport's view component is not a JLayer, this method is equivalent to JViewport.getView() otherwise JLayer.getView() will be recursively called on all descending JLayers.
        参数：
        viewport - JViewport to get the first descendant of, which in not a JLayer instance.
        返回：
        the first JViewport's descendant which is not an instance of JLayer. If such a descendant can not be found, null is returned.
        抛出：
        NullPointerException - if viewport is null
        从以下版本开始：
        1.7
        另请参见：
        JViewport.getView(), JLayer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SwingWorker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 SwingWorker<T,V>

  • java.lang.Object
    • javax.swing.SwingWorker<T,V>
  • 类型参数：
    T - the result type returned by this SwingWorker's doInBackground and get methods
    V - the type used for carrying out intermediate results by this SwingWorker's publish and process methods
    所有已实现的接口：
    Runnable, Future<T>, RunnableFuture<T>

    public abstract class SwingWorker<T,V>
extends Object
implements RunnableFuture<T>
    An abstract class to perform lengthy GUI-interaction tasks in a background thread. Several background threads can be used to execute such tasks. However, the exact strategy of choosing a thread for any particular SwingWorker is unspecified and should not be relied on.

    When writing a multi-threaded application using Swing, there are two constraints to keep in mind: (refer to How to Use Threads for more details):

    • Time-consuming tasks should not be run on the Event Dispatch Thread. Otherwise the application becomes unresponsive.
    • Swing components should be accessed on the Event Dispatch Thread only.

    These constraints mean that a GUI application with time intensive computing needs at least two threads: 1) a thread to perform the lengthy task and 2) the Event Dispatch Thread (EDT) for all GUI-related activities. This involves inter-thread communication which can be tricky to implement.

    SwingWorker is designed for situations where you need to have a long running task run in a background thread and provide updates to the UI either when done, or while processing. Subclasses of SwingWorker must implement the doInBackground() method to perform the background computation.

    Workflow

    There are three threads involved in the life cycle of a SwingWorker :

    • Current thread: The execute() method is called on this thread. It schedules SwingWorker for the execution on a worker thread and returns immediately. One can wait for the SwingWorker to complete using the get methods.

    • Worker thread: The doInBackground() method is called on this thread. This is where all background activities should happen. To notify PropertyChangeListeners about bound properties changes use the firePropertyChange and getPropertyChangeSupport() methods. By default there are two bound properties available: state and progress.

    • Event Dispatch Thread: All Swing related activities occur on this thread. SwingWorker invokes the process and done() methods and notifies any PropertyChangeListeners on this thread.

    Often, the Current thread is the Event Dispatch Thread.

    Before the doInBackground method is invoked on a worker thread, SwingWorker notifies any PropertyChangeListeners about the state property change to StateValue.STARTED. After the doInBackground method is finished the done method is executed. Then SwingWorker notifies any PropertyChangeListeners about the state property change to StateValue.DONE.

    SwingWorker is only designed to be executed once. Executing a SwingWorker more than once will not result in invoking the doInBackground method twice.

    Sample Usage

    The following example illustrates the simplest use case. Some processing is done in the background and when done you update a Swing component.

    Say we want to find the "Meaning of Life" and display the result in a JLabel.

       final JLabel label;
   class MeaningOfLifeFinder extends SwingWorker<String, Object> {
       @Override
       public String doInBackground() {
           return findTheMeaningOfLife();
       }

       @Override
       protected void done() {
           try {
               label.setText(get());
           } catch (Exception ignore) {
           }
       }
   }

   (new MeaningOfLifeFinder()).execute();

    The next example is useful in situations where you wish to process data as it is ready on the Event Dispatch Thread.

    Now we want to find the first N prime numbers and display the results in a JTextArea. While this is computing, we want to update our progress in a JProgressBar. Finally, we also want to print the prime numbers to System.out.

     class PrimeNumbersTask extends
         SwingWorker<List<Integer>, Integer> {
     PrimeNumbersTask(JTextArea textArea, int numbersToFind) {
         //initialize
     }

     @Override
     public List<Integer> doInBackground() {
         while (! enough && ! isCancelled()) {
                 number = nextPrimeNumber();
                 publish(number);
                 setProgress(100 * numbers.size() / numbersToFind);
             }
         }
         return numbers;
     }

     @Override
     protected void process(List<Integer> chunks) {
         for (int number : chunks) {
             textArea.append(number + "\n");
         }
     }
 }

 JTextArea textArea = new JTextArea();
 final JProgressBar progressBar = new JProgressBar(0, 100);
 PrimeNumbersTask task = new PrimeNumbersTask(textArea, N);
 task.addPropertyChangeListener(
     new PropertyChangeListener() {
         public  void propertyChange(PropertyChangeEvent evt) {
             if ("progress".equals(evt.getPropertyName())) {
                 progressBar.setValue((Integer)evt.getNewValue());
             }
         }
     });

 task.execute();
 System.out.println(task.get()); //prints all prime numbers we have got

    Because SwingWorker implements Runnable, a SwingWorker can be submitted to an Executor for execution.

    从以下版本开始：
    1.6

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  SwingWorker.StateValue
      Values for the state bound property.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SwingWorker()
      Constructs this SwingWorker.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      boolean cancel(boolean mayInterruptIfRunning)
      Attempts to cancel execution of this task.
      protected abstract T doInBackground()
      Computes a result, or throws an exception if unable to do so.
      protected void done()
      Executed on the Event Dispatch Thread after the doInBackground method is finished.
      void execute()
      Schedules this SwingWorker for execution on a worker thread.
      void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Reports a bound property update to any registered listeners.
      T get()
      Waits if necessary for the computation to complete, and then retrieves its result.
      T get(long timeout, TimeUnit unit)
      Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.
      int getProgress()
      Returns the progress bound property.
      PropertyChangeSupport getPropertyChangeSupport()
      Returns the PropertyChangeSupport for this SwingWorker.
      SwingWorker.StateValue getState()
      Returns the SwingWorker state bound property.
      boolean isCancelled()
      Returns true if this task was cancelled before it completed normally.
      boolean isDone()
      Returns true if this task completed.
      protected void process(List<V> chunks)
      Receives data chunks from the publish method asynchronously on the Event Dispatch Thread.
      protected void publish(V... chunks)
      Sends data chunks to the process(java.util.List) method.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void run()
      Sets this Future to the result of computation unless it has been cancelled.
      protected void setProgress(int progress)
      Sets the progress bound property.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SwingWorker

        public SwingWorker()
        Constructs this SwingWorker.

    • 方法详细信息

      • doInBackground

        protected abstract T doInBackground()
                             throws Exception
        Computes a result, or throws an exception if unable to do so.

        Note that this method is executed only once.

        Note: this method is executed in a background thread.

        返回：
        the computed result
        抛出：
        Exception - if unable to compute a result

      • run

        public final void run()
        Sets this Future to the result of computation unless it has been cancelled.
        指定者：
        run in interface Runnable
        指定者：
        run in interface RunnableFuture<T>
        另请参见：
        Thread.run()

      • publish

        @SafeVarargs
protected final void publish(V... chunks)
        Sends data chunks to the process(java.util.List) method. This method is to be used from inside the doInBackground method to deliver intermediate results for processing on the Event Dispatch Thread inside the process method.

        Because the process method is invoked asynchronously on the Event Dispatch Thread multiple invocations to the publish method might occur before the process method is executed. For performance purposes all these invocations are coalesced into one invocation with concatenated arguments.

        For example:

         publish("1");
 publish("2", "3");
 publish("4", "5", "6");
        might result in:
         process("1", "2", "3", "4", "5", "6")

        Sample Usage. This code snippet loads some tabular data and updates DefaultTableModel with it. Note that it safe to mutate the tableModel from inside the process method because it is invoked on the Event Dispatch Thread.

         class TableSwingWorker extends
         SwingWorker<DefaultTableModel, Object[]> {
     private final DefaultTableModel tableModel;

     public TableSwingWorker(DefaultTableModel tableModel) {
         this.tableModel = tableModel;
     }

     @Override
     protected DefaultTableModel doInBackground() throws Exception {
         for (Object[] row = loadData();
                  ! isCancelled() && row != null;
                  row = loadData()) {
             publish((Object[]) row);
         }
         return tableModel;
     }

     @Override
     protected void process(List<Object[]> chunks) {
         for (Object[] row : chunks) {
             tableModel.addRow(row);
         }
     }
 }
        参数：
        chunks - intermediate results to process
        另请参见：
        process(java.util.List)

      • process

        protected void process(List<V> chunks)
        Receives data chunks from the publish method asynchronously on the Event Dispatch Thread.

        Please refer to the publish(V...) method for more details.

        参数：
        chunks - intermediate results to process
        另请参见：
        publish(V...)

      • done

        protected void done()
        Executed on the Event Dispatch Thread after the doInBackground method is finished. The default implementation does nothing. Subclasses may override this method to perform completion actions on the Event Dispatch Thread. Note that you can query status inside the implementation of this method to determine the result of this task or whether this task has been cancelled.
        另请参见：
        doInBackground(),
isCancelled(),
get()

      • setProgress

        protected final void setProgress(int progress)
        Sets the progress bound property. The value should be from 0 to 100.

        Because PropertyChangeListeners are notified asynchronously on the Event Dispatch Thread multiple invocations to the setProgress method might occur before any PropertyChangeListeners are invoked. For performance purposes all these invocations are coalesced into one invocation with the last invocation argument only.

        For example, the following invokations:

         setProgress(1);
 setProgress(2);
 setProgress(3);
        might result in a single PropertyChangeListener notification with the value 3.
        参数：
        progress - the progress value to set
        抛出：
        IllegalArgumentException - is value not from 0 to 100

      • getProgress

        public final int getProgress()
        Returns the progress bound property.
        返回：
        the progress bound property.

      • execute

        public final void execute()
        Schedules this SwingWorker for execution on a worker thread. There are a number of worker threads available. In the event all worker threads are busy handling other SwingWorkers this SwingWorker is placed in a waiting queue.

        Note: SwingWorker is only designed to be executed once. Executing a SwingWorker more than once will not result in invoking the doInBackground method twice.

      • cancel

        public final boolean cancel(boolean mayInterruptIfRunning)
        Attempts to cancel execution of this task. This attempt will fail if the task has already completed, has already been cancelled, or could not be cancelled for some other reason. If successful, and this task has not started when cancel is called, this task should never run. If the task has already started, then the mayInterruptIfRunning parameter determines whether the thread executing this task should be interrupted in an attempt to stop the task.

        After this method returns, subsequent calls to Future.isDone() will always return true. Subsequent calls to Future.isCancelled() will always return true if this method returned true.

        指定者：
        cancel in interface Future<T>
        参数：
        mayInterruptIfRunning - true if the thread executing this task should be interrupted; otherwise, in-progress tasks are allowed to complete
        返回：
        false if the task could not be cancelled, typically because it has already completed normally; true otherwise

      • isCancelled

        public final boolean isCancelled()
        Returns true if this task was cancelled before it completed normally.
        指定者：
        isCancelled in interface Future<T>
        返回：
        true if this task was cancelled before it completed

      • isDone

        public final boolean isDone()
        Returns true if this task completed. Completion may be due to normal termination, an exception, or cancellation -- in all of these cases, this method will return true.
        指定者：
        isDone in interface Future<T>
        返回：
        true if this task completed

      • get

        public final T get()
            throws InterruptedException,
                   ExecutionException
        Waits if necessary for the computation to complete, and then retrieves its result.

        Note: calling get on the Event Dispatch Thread blocks all events, including repaints, from being processed until this SwingWorker is complete.

        When you want the SwingWorker to block on the Event Dispatch Thread we recommend that you use a modal dialog.

        For example:

         class SwingWorkerCompletionWaiter extends PropertyChangeListener {
     private JDialog dialog;

     public SwingWorkerCompletionWaiter(JDialog dialog) {
         this.dialog = dialog;
     }

     public void propertyChange(PropertyChangeEvent event) {
         if ("state".equals(event.getPropertyName())
                 && SwingWorker.StateValue.DONE == event.getNewValue()) {
             dialog.setVisible(false);
             dialog.dispose();
         }
     }
 }
 JDialog dialog = new JDialog(owner, true);
 swingWorker.addPropertyChangeListener(
     new SwingWorkerCompletionWaiter(dialog));
 swingWorker.execute();
 //the dialog will be visible until the SwingWorker is done
 dialog.setVisible(true);
        指定者：
        get in interface Future<T>
        返回：
        the computed result
        抛出：
        InterruptedException - if the current thread was interrupted while waiting
        ExecutionException - if the computation threw an exception

      • get

        public final T get(long timeout,
    TimeUnit unit)
            throws InterruptedException,
                   ExecutionException,
                   TimeoutException
        Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

        Please refer to get() for more details.

        指定者：
        get in interface Future<T>
        参数：
        timeout - the maximum time to wait
        unit - the time unit of the timeout argument
        返回：
        the computed result
        抛出：
        InterruptedException - if the current thread was interrupted while waiting
        ExecutionException - if the computation threw an exception
        TimeoutException - if the wait timed out

      • addPropertyChangeListener

        public final void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties. The same listener object may be added more than once, and will be called as many times as it is added. If listener is null, no exception is thrown and no action is taken.

        Note: This is merely a convenience wrapper. All work is delegated to PropertyChangeSupport from getPropertyChangeSupport().

        参数：
        listener - the PropertyChangeListener to be added

      • removePropertyChangeListener

        public final void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties. If listener was added more than once to the same event source, it will be notified one less time after being removed. If listener is null, or was never added, no exception is thrown and no action is taken.

        Note: This is merely a convenience wrapper. All work is delegated to PropertyChangeSupport from getPropertyChangeSupport().

        参数：
        listener - the PropertyChangeListener to be removed

      • firePropertyChange

        public final void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Reports a bound property update to any registered listeners. No event is fired if old and new are equal and non-null.

        This SwingWorker will be the source for any generated events.

        When called off the Event Dispatch Thread PropertyChangeListeners are notified asynchronously on the Event Dispatch Thread.

        Note: This is merely a convenience wrapper. All work is delegated to PropertyChangeSupport from getPropertyChangeSupport().

        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property
        newValue - the new value of the property

      • getPropertyChangeSupport

        public final PropertyChangeSupport getPropertyChangeSupport()
        Returns the PropertyChangeSupport for this SwingWorker. This method is used when flexible access to bound properties support is needed.

        This SwingWorker will be the source for any generated events.

        Note: The returned PropertyChangeSupport notifies any PropertyChangeListeners asynchronously on the Event Dispatch Thread in the event that firePropertyChange or fireIndexedPropertyChange are called off the Event Dispatch Thread.

        返回：
        PropertyChangeSupport for this SwingWorker

      • getState

        public final SwingWorker.StateValue getState()
        Returns the SwingWorker state bound property.
        返回：
        the current state
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oem>o>>eno>csvcnod r


SwingWorker.StateValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing

Enum SwingWorker.StateValue

  • java.lang.Object
    • java.lang.Enum<SwingWorker.StateValue>
      • javax.swing.SwingWorker.StateValue
  • 所有已实现的接口：
    Serializable, Comparable<SwingWorker.StateValue>
    封闭类：
    SwingWorker<T,V>

    public static enum SwingWorker.StateValue
extends Enum<SwingWorker.StateValue>
    Values for the state bound property.
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      DONE
      SwingWorker is DONE after doInBackground method is finished.
      PENDING
      Initial SwingWorker state.
      STARTED
      SwingWorker is STARTED before invoking doInBackground.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SwingWorker.StateValue valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SwingWorker.StateValue[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PENDING

        public static final SwingWorker.StateValue PENDING
        Initial SwingWorker state.

      • STARTED

        public static final SwingWorker.StateValue STARTED
        SwingWorker is STARTED before invoking doInBackground.

      • DONE

        public static final SwingWorker.StateValue DONE
        SwingWorker is DONE after doInBackground method is finished.

    • 方法详细信息

      • values

        public static SwingWorker.StateValue[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (SwingWorker.StateValue c : SwingWorker.StateValue.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static SwingWorker.StateValue valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ovldt>ed>ed>>edddc"">erd/eh


Timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 Timer

  • java.lang.Object
    • javax.swing.Timer
  • 所有已实现的接口：
    Serializable

    public class Timer
extends Object
implements Serializable
    Fires one or more ActionEvents at specified intervals. An example use is an animation object that uses a Timer as the trigger for drawing its frames.

    Setting up a timer involves creating a Timer object, registering one or more action listeners on it, and starting the timer using the start method. For example, the following code creates and starts a timer that fires an action event once per second (as specified by the first argument to the Timer constructor). The second argument to the Timer constructor specifies a listener to receive the timer's action events.

      int delay = 1000; //milliseconds
  ActionListener taskPerformer = new ActionListener() {
      public void actionPerformed(ActionEvent evt) {
          //...Perform a task...
      }
  };
  new Timer(delay, taskPerformer).start();

    Timers are constructed by specifying both a delay parameter and an ActionListener. The delay parameter is used to set both the initial delay and the delay between event firing, in milliseconds. Once the timer has been started, it waits for the initial delay before firing its first ActionEvent to registered listeners. After this first event, it continues to fire events every time the between-event delay has elapsed, until it is stopped.

    After construction, the initial delay and the between-event delay can be changed independently, and additional ActionListeners may be added.

    If you want the timer to fire only the first time and then stop, invoke setRepeats(false) on the timer.

    Although all Timers perform their waiting using a single, shared thread (created by the first Timer object that executes), the action event handlers for Timers execute on another thread -- the event-dispatching thread. This means that the action handlers for Timers can safely perform operations on Swing components. However, it also means that the handlers must execute quickly to keep the GUI responsive.

    In v 1.3, another Timer class was added to the Java platform: java.util.Timer. Both it and javax.swing.Timer provide the same basic functionality, but java.util.Timer is more general and has more features. The javax.swing.Timer has two features that can make it a little easier to use with GUIs. First, its event handling metaphor is familiar to GUI programmers and can make dealing with the event-dispatching thread a bit simpler. Second, its automatic thread sharing means that you don't have to take special steps to avoid spawning too many threads. Instead, your timer uses the same thread used to make cursors blink, tool tips appear, and so on.

    You can find further documentation and several examples of using timers by visiting How to Use Timers, a section in The Java Tutorial. For more examples and help in choosing between this Timer class and java.util.Timer, see Using Timers in Swing Applications, an article in The Swing Connection.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    java.util.Timer

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected EventListenerList | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      Timer(int delay, ActionListener listener)
      Creates a Timer and initializes both the initial delay and between-event delay to delay milliseconds.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionListener(ActionListener listener)
      Adds an action listener to the Timer.
      protected void fireActionPerformed(ActionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      String getActionCommand()
      Returns the string that will be delivered as the action command in ActionEvents fired by this timer.
      ActionListener[] getActionListeners()
      Returns an array of all the action listeners registered on this timer.
      int getDelay()
      Returns the delay, in milliseconds, between firings of action events.
      int getInitialDelay()
      Returns the Timer's initial delay.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this Timer.
      static boolean getLogTimers()
      Returns true if logging is enabled.
      boolean isCoalesce()
      Returns true if the Timer coalesces multiple pending action events.
      boolean isRepeats()
      Returns true (the default) if the Timer will send an action event to its listeners multiple times.
      boolean isRunning()
      Returns true if the Timer is running.
      void removeActionListener(ActionListener listener)
      Removes the specified action listener from the Timer.
      void restart()
      Restarts the Timer, canceling any pending firings and causing it to fire with its initial delay.
      void setActionCommand(String command)
      Sets the string that will be delivered as the action command in ActionEvents fired by this timer.
      void setCoalesce(boolean flag)
      Sets whether the Timer coalesces multiple pending ActionEvent firings.
      void setDelay(int delay)
      Sets the Timer's between-event delay, the number of milliseconds between successive action events.
      void setInitialDelay(int initialDelay)
      Sets the Timer's initial delay, the time in milliseconds to wait after the timer is started before firing the first event.
      static void setLogTimers(boolean flag)
      Enables or disables the timer log.
      void setRepeats(boolean flag)
      If flag is false, instructs the Timer to send only one action event to its listeners.
      void start()
      Starts the Timer, causing it to start sending action events to its listeners.
      void stop()
      Stops the Timer, causing it to stop sending action events to its listeners.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList

    • 构造方法详细信息

      • Timer

        public Timer(int delay,
     ActionListener listener)
        Creates a Timer and initializes both the initial delay and between-event delay to delay milliseconds. If delay is less than or equal to zero, the timer fires as soon as it is started. If listener is not null, it's registered as an action listener on the timer.
        参数：
        delay - milliseconds for the initial and between-event delay
        listener - an initial listener; can be null
        另请参见：
        addActionListener(java.awt.event.ActionListener), setInitialDelay(int), setRepeats(boolean)

    • 方法详细信息

      • addActionListener

        public void addActionListener(ActionListener listener)
        Adds an action listener to the Timer.
        参数：
        listener - the listener to add
        另请参见：
        Timer(int, java.awt.event.ActionListener)

      • removeActionListener

        public void removeActionListener(ActionListener listener)
        Removes the specified action listener from the Timer.
        参数：
        listener - the listener to remove

      • getActionListeners

        public ActionListener[] getActionListeners()
        Returns an array of all the action listeners registered on this timer.
        返回：
        all of the timer's ActionListeners or an empty array if no action listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

      • fireActionPerformed

        protected void fireActionPerformed(ActionEvent e)
        Notifies all listeners that have registered interest for notification on this event type.
        参数：
        e - the action event to fire
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this Timer. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a Timer instance t for its action listeners with the following code:

        ActionListener[] als = (ActionListener[])(t.getListeners(ActionListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this timer, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getActionListeners(),
addActionListener(java.awt.event.ActionListener),
removeActionListener(java.awt.event.ActionListener)

      • setLogTimers

        public static void setLogTimers(boolean flag)
        Enables or disables the timer log. When enabled, a message is posted to System.out whenever the timer goes off.
        参数：
        flag - true to enable logging
        另请参见：
        getLogTimers()

      • getLogTimers

        public static boolean getLogTimers()
        Returns true if logging is enabled.
        返回：
        true if logging is enabled; otherwise, false
        另请参见：
        setLogTimers(boolean)

      • setDelay

        public void setDelay(int delay)
        Sets the Timer's between-event delay, the number of milliseconds between successive action events. This does not affect the initial delay property, which can be set by the setInitialDelay method.
        参数：
        delay - the delay in milliseconds
        另请参见：
        setInitialDelay(int)

      • getDelay

        public int getDelay()
        Returns the delay, in milliseconds, between firings of action events.
        另请参见：
        setDelay(int), getInitialDelay()

      • setInitialDelay

        public void setInitialDelay(int initialDelay)
        Sets the Timer's initial delay, the time in milliseconds to wait after the timer is started before firing the first event. Upon construction, this is set to be the same as the between-event delay, but then its value is independent and remains unaffected by changes to the between-event delay.
        参数：
        initialDelay - the initial delay, in milliseconds
        另请参见：
        setDelay(int)

      • getInitialDelay

        public int getInitialDelay()
        Returns the Timer's initial delay.
        另请参见：
        setInitialDelay(int), setDelay(int)

      • setRepeats

        public void setRepeats(boolean flag)
        If flag is false, instructs the Timer to send only one action event to its listeners.
        参数：
        flag - specify false to make the timer stop after sending its first action event

      • isRepeats

        public boolean isRepeats()
        Returns true (the default) if the Timer will send an action event to its listeners multiple times.
        另请参见：
        setRepeats(boolean)

      • setCoalesce

        public void setCoalesce(boolean flag)
        Sets whether the Timer coalesces multiple pending ActionEvent firings. A busy application may not be able to keep up with a Timer's event generation, causing multiple action events to be queued. When processed, the application sends these events one after the other, causing the Timer's listeners to receive a sequence of events with no delay between them. Coalescing avoids this situation by reducing multiple pending events to a single event. Timers coalesce events by default.
        参数：
        flag - specify false to turn off coalescing

      • isCoalesce

        public boolean isCoalesce()
        Returns true if the Timer coalesces multiple pending action events.
        另请参见：
        setCoalesce(boolean)

      • setActionCommand

        public void setActionCommand(String command)
        Sets the string that will be delivered as the action command in ActionEvents fired by this timer. null is an acceptable value.
        参数：
        command - the action command
        从以下版本开始：
        1.6

      • getActionCommand

        public String getActionCommand()
        Returns the string that will be delivered as the action command in ActionEvents fired by this timer. May be null, which is also the default.
        返回：
        the action command used in firing events
        从以下版本开始：
        1.6

      • start

        public void start()
        Starts the Timer, causing it to start sending action events to its listeners.
        另请参见：
        stop()

      • isRunning

        public boolean isRunning()
        Returns true if the Timer is running.
        另请参见：
        start()

      • stop

        public void stop()
        Stops the Timer, causing it to stop sending action events to its listeners.
        另请参见：
        start()

      • restart

        public void restart()
        Restarts the Timer, canceling any pending firings and causing it to fire with its initial delay.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ToolTipManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

类 ToolTipManager

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.ToolTipManager
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener

    public class ToolTipManager
extends MouseAdapter
implements MouseMotionListener
    Manages all the ToolTips in the system.

    ToolTipManager contains numerous properties for configuring how long it will take for the tooltips to become visible, and how long till they hide. Consider a component that has a different tooltip based on where the mouse is, such as JTree. When the mouse moves into the JTree and over a region that has a valid tooltip, the tooltip will become visibile after initialDelay milliseconds. After dismissDelay milliseconds the tooltip will be hidden. If the mouse is over a region that has a valid tooltip, and the tooltip is currently visible, when the mouse moves to a region that doesn't have a valid tooltip the tooltip will be hidden. If the mouse then moves back into a region that has a valid tooltip within reshowDelay milliseconds, the tooltip will immediately be shown, otherwise the tooltip will be shown again after initialDelay milliseconds.

    另请参见：
    JComponent.createToolTip()

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | ToolTipManager.insideTimerAction
      protected class  | ToolTipManager.outsideTimerAction
      protected class  | ToolTipManager.stillInsideTimerAction

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean | heavyWeightPopupEnabled
      protected boolean | lightWeightPopupEnabled

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getDismissDelay()
      Returns the dismissal delay value.
      int getInitialDelay()
      Returns the initial delay value.
      int getReshowDelay()
      Returns the reshow delay property.
      boolean isEnabled()
      Returns true if this object is enabled.
      boolean isLightWeightPopupEnabled()
      Returns true if lightweight (all-Java) Tooltips are in use, or false if heavyweight (native peer) Tooltips are being used.
      void mouseDragged(MouseEvent event)
      Called when the mouse is pressed and dragged.
      void mouseEntered(MouseEvent event)
      Called when the mouse enters the region of a component.
      void mouseExited(MouseEvent event)
      Called when the mouse exits the region of a component.
      void mouseMoved(MouseEvent event)
      Called when the mouse is moved.
      void mousePressed(MouseEvent event)
      Called when the mouse is pressed.
      void registerComponent(JComponent component)
      Registers a component for tooltip management.
      void setDismissDelay(int milliseconds)
      Specifies the dismissal delay value.
      void setEnabled(boolean flag)
      Enables or disables the tooltip.
      void setInitialDelay(int milliseconds)
      Specifies the initial delay value.
      void setLightWeightPopupEnabled(boolean aFlag)
      When displaying the JToolTip, the ToolTipManager chooses to use a lightweight JPanel if it fits.
      void setReshowDelay(int milliseconds)
      Used to specify the amount of time before the user has to wait initialDelay milliseconds before a tooltip will be shown.
      static ToolTipManager sharedInstance()
      Returns a shared ToolTipManager instance.
      void unregisterComponent(JComponent component)
      Removes a component from tooltip control.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • lightWeightPopupEnabled

        protected boolean lightWeightPopupEnabled

      • heavyWeightPopupEnabled

        protected boolean heavyWeightPopupEnabled

    • 方法详细信息

      • setEnabled

        public void setEnabled(boolean flag)
        Enables or disables the tooltip.
        参数：
        flag - true to enable the tip, false otherwise

      • isEnabled

        public boolean isEnabled()
        Returns true if this object is enabled.
        返回：
        true if this object is enabled, false otherwise

      • setLightWeightPopupEnabled

        public void setLightWeightPopupEnabled(boolean aFlag)
        When displaying the JToolTip, the ToolTipManager chooses to use a lightweight JPanel if it fits. This method allows you to disable this feature. You have to do disable it if your application mixes light weight and heavy weights components.
        参数：
        aFlag - true if a lightweight panel is desired, false otherwise

      • isLightWeightPopupEnabled

        public boolean isLightWeightPopupEnabled()
        Returns true if lightweight (all-Java) Tooltips are in use, or false if heavyweight (native peer) Tooltips are being used.
        返回：
        true if lightweight ToolTips are in use

      • setInitialDelay

        public void setInitialDelay(int milliseconds)
        Specifies the initial delay value.
        参数：
        milliseconds - the number of milliseconds to delay (after the cursor has paused) before displaying the tooltip
        另请参见：
        getInitialDelay()

      • getInitialDelay

        public int getInitialDelay()
        Returns the initial delay value.
        返回：
        an integer representing the initial delay value, in milliseconds
        另请参见：
        setInitialDelay(int)

      • setDismissDelay

        public void setDismissDelay(int milliseconds)
        Specifies the dismissal delay value.
        参数：
        milliseconds - the number of milliseconds to delay before taking away the tooltip
        另请参见：
        getDismissDelay()

      • getDismissDelay

        public int getDismissDelay()
        Returns the dismissal delay value.
        返回：
        an integer representing the dismissal delay value, in milliseconds
        另请参见：
        setDismissDelay(int)

      • setReshowDelay

        public void setReshowDelay(int milliseconds)
        Used to specify the amount of time before the user has to wait initialDelay milliseconds before a tooltip will be shown. That is, if the tooltip is hidden, and the user moves into a region of the same Component that has a valid tooltip within milliseconds milliseconds the tooltip will immediately be shown. Otherwise, if the user moves into a region with a valid tooltip after milliseconds milliseconds, the user will have to wait an additional initialDelay milliseconds before the tooltip is shown again.
        参数：
        milliseconds - time in milliseconds
        另请参见：
        getReshowDelay()

      • getReshowDelay

        public int getReshowDelay()
        Returns the reshow delay property.
        返回：
        reshown delay property
        另请参见：
        setReshowDelay(int)

      • sharedInstance

        public static ToolTipManager sharedInstance()
        Returns a shared ToolTipManager instance.
        返回：
        a shared ToolTipManager object

      • registerComponent

        public void registerComponent(JComponent component)
        Registers a component for tooltip management.

        This will register key bindings to show and hide the tooltip text only if component has focus bindings. This is done so that components that are not normally focus traversable, such as JLabel, are not made focus traversable as a result of invoking this method.

        参数：
        component - a JComponent object to add
        另请参见：
        Component.isFocusTraversable()

      • unregisterComponent

        public void unregisterComponent(JComponent component)
        Removes a component from tooltip control.
        参数：
        component - a JComponent object to remove

      • mouseEntered

        public void mouseEntered(MouseEvent event)
        Called when the mouse enters the region of a component. This determines whether the tool tip should be shown.
        指定者：
        mouseEntered in interface MouseListener
        重载：
        mouseEntered in class MouseAdapter
        参数：
        event - the event in question

      • mouseExited

        public void mouseExited(MouseEvent event)
        Called when the mouse exits the region of a component. Any tool tip showing should be hidden.
        指定者：
        mouseExited in interface MouseListener
        重载：
        mouseExited in class MouseAdapter
        参数：
        event - the event in question

      • mousePressed

        public void mousePressed(MouseEvent event)
        Called when the mouse is pressed. Any tool tip showing should be hidden.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter
        参数：
        event - the event in question

      • mouseDragged

        public void mouseDragged(MouseEvent event)
        Called when the mouse is pressed and dragged. Does nothing.
        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter
        参数：
        event - the event in question

      • mouseMoved

        public void mouseMoved(MouseEvent event)
        Called when the mouse is moved. Determines whether the tool tip should be displayed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter
        参数：
        event - the event in question
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/snl"nc>ntth>t<>ndole f


ToolTipManager.insideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ToolTipManager.insideTimerAction

  • java.lang.Object
    • javax.swing.ToolTipManager.insideTimerAction
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    ToolTipManager

    protected class ToolTipManager.insideTimerAction
extends Object
implements ActionListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ToolTipManager.insideTimerAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ToolTipManager.insideTimerAction

        protected ToolTipManager.insideTimerAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tC/.f" =" ahh aanauuvaTsoggitsmglMppo/gTla


ToolTipManager.outsideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ToolTipManager.outsideTimerAction

  • java.lang.Object
    • javax.swing.ToolTipManager.outsideTimerAction
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    ToolTipManager

    protected class ToolTipManager.outsideTimerAction
extends Object
implements ActionListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ToolTipManager.outsideTimerAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ToolTipManager.outsideTimerAction

        protected ToolTipManager.outsideTimerAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ro "ll lv


ToolTipManager.stillInsideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ToolTipManager.stillInsideTimerAction

  • java.lang.Object
    • javax.swing.ToolTipManager.stillInsideTimerAction
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    ToolTipManager

    protected class ToolTipManager.stillInsideTimerAction
extends Object
implements ActionListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ToolTipManager.stillInsideTimerAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ToolTipManager.stillInsideTimerAction

        protected ToolTipManager.stillInsideTimerAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pt(wsveoJe.niMi p wesnC-/ / ars�


TransferHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 TransferHandler

  • java.lang.Object
    • javax.swing.TransferHandler
  • 所有已实现的接口：
    Serializable

    public class TransferHandler
extends Object
implements Serializable
    This class is used to handle the transfer of a Transferable to and from Swing components. The Transferable is used to represent data that is exchanged via a cut, copy, or paste to/from a clipboard. It is also used in drag-and-drop operations to represent a drag from a component, and a drop to a component. Swing provides functionality that automatically supports cut, copy, and paste keyboard bindings that use the functionality provided by an implementation of this class. Swing also provides functionality that automatically supports drag and drop that uses the functionality provided by an implementation of this class. The Swing developer can concentrate on specifying the semantics of a transfer primarily by setting the transferHandler property on a Swing component.

    This class is implemented to provide a default behavior of transferring a component property simply by specifying the name of the property in the constructor. For example, to transfer the foreground color from one component to another either via the clipboard or a drag and drop operation a TransferHandler can be constructed with the string "foreground". The built in support will use the color returned by getForeground as the source of the transfer, and setForeground for the target of a transfer.

    Please see How to Use Drag and Drop and Data Transfer, a section in The Java Tutorial, for more information.

    从以下版本开始：
    1.4

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  TransferHandler.DropLocation
      Represents a location where dropped data should be inserted.
      static class  TransferHandler.TransferSupport
      This class encapsulates all relevant details of a clipboard or drag and drop transfer, and also allows for customizing aspects of the drag and drop experience.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int COPY
      An int representing a "copy" transfer action.
      static int COPY_OR_MOVE
      An int representing a source action capability of either "copy" or "move".
      static int LINK
      An int representing a "link" transfer action.
      static int MOVE
      An int representing a "move" transfer action.
      static int NONE
      An int representing no transfer action.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TransferHandler()
      Convenience constructor for subclasses.
        TransferHandler(String property)
      Constructs a transfer handler that can transfer a Java Bean property from one component to another via the clipboard or a drag and drop operation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean canImport(JComponent comp, DataFlavor[] transferFlavors)
      Indicates whether a component will accept an import of the given set of data flavors prior to actually attempting to import it.
      boolean canImport(TransferHandler.TransferSupport support)
      This method is called repeatedly during a drag and drop operation to allow the developer to configure properties of, and to return the acceptability of transfers; with a return value of true indicating that the transfer represented by the given TransferSupport (which contains all of the details of the transfer) is acceptable at the current time, and a value of false rejecting the transfer.
      protected Transferable createTransferable(JComponent c)
      Creates a Transferable to use as the source for a data transfer.
      void exportAsDrag(JComponent comp, InputEvent e, int action)
      Causes the Swing drag support to be initiated.
      protected void exportDone(JComponent source, Transferable data, int action)
      Invoked after data has been exported.
      void exportToClipboard(JComponent comp, Clipboard clip, int action)
      Causes a transfer from the given component to the given clipboard.
      static Action getCopyAction()
      Returns an Action that performs copy operations to the clipboard.
      static Action getCutAction()
      Returns an Action that performs cut operations to the clipboard.
      Image getDragImage()
      Returns the drag image.
      Point getDragImageOffset()
      Returns an anchor offset for the image to drag.
      static Action getPasteAction()
      Returns an Action that performs paste operations from the clipboard.
      int getSourceActions(JComponent c)
      Returns the type of transfer actions supported by the source; any bitwise-OR combination of COPY, MOVE and LINK.
      Icon getVisualRepresentation(Transferable t)
      Returns an object that establishes the look of a transfer.
      boolean importData(JComponent comp, Transferable t)
      Causes a transfer to a component from a clipboard or a DND drop operation.
      boolean importData(TransferHandler.TransferSupport support)
      Causes a transfer to occur from a clipboard or a drag and drop operation.
      void setDragImage(Image img)
      Sets the drag image parameter.
      void setDragImageOffset(Point p)
      Sets an anchor offset for the image to drag.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NONE

        public static final int NONE
        An int representing no transfer action.
        另请参见：
        Constant Field Values

      • COPY

        public static final int COPY
        An int representing a "copy" transfer action. This value is used when data is copied to a clipboard or copied elsewhere in a drag and drop operation.
        另请参见：
        Constant Field Values

      • MOVE

        public static final int MOVE
        An int representing a "move" transfer action. This value is used when data is moved to a clipboard (i.e. a cut) or moved elsewhere in a drag and drop operation.
        另请参见：
        Constant Field Values

      • COPY_OR_MOVE

        public static final int COPY_OR_MOVE
        An int representing a source action capability of either "copy" or "move".
        另请参见：
        Constant Field Values

      • LINK

        public static final int LINK
        An int representing a "link" transfer action. This value is used to specify that data should be linked in a drag and drop operation.
        从以下版本开始：
        1.6
        另请参见：
        DnDConstants.ACTION_LINK, Constant Field Values

    • 构造方法详细信息

      • TransferHandler

        public TransferHandler(String property)
        Constructs a transfer handler that can transfer a Java Bean property from one component to another via the clipboard or a drag and drop operation.
        参数：
        property - the name of the property to transfer; this can be null if there is no property associated with the transfer handler (a subclass that performs some other kind of transfer, for example)

      • TransferHandler

        protected TransferHandler()
        Convenience constructor for subclasses.

    • 方法详细信息

      • getCutAction

        public static Action getCutAction()
        Returns an Action that performs cut operations to the clipboard. When performed, this action operates on the JComponent source of the ActionEvent by invoking exportToClipboard, with a MOVE action, on the component's TransferHandler.
        返回：
        an Action for performing cuts to the clipboard

      • getCopyAction

        public static Action getCopyAction()
        Returns an Action that performs copy operations to the clipboard. When performed, this action operates on the JComponent source of the ActionEvent by invoking exportToClipboard, with a COPY action, on the component's TransferHandler.
        返回：
        an Action for performing copies to the clipboard

      • getPasteAction

        public static Action getPasteAction()
        Returns an Action that performs paste operations from the clipboard. When performed, this action operates on the JComponent source of the ActionEvent by invoking importData, with the clipboard contents, on the component's TransferHandler.
        返回：
        an Action for performing pastes from the clipboard

      • setDragImage

        public void setDragImage(Image img)
        Sets the drag image parameter. The image has to be prepared for rendering by the moment of the call. The image is stored by reference because of some performance reasons.
        参数：
        img - an image to drag

      • getDragImage

        public Image getDragImage()
        Returns the drag image. If there is no image to drag, the returned value is null.
        返回：
        the reference to the drag image

      • setDragImageOffset

        public void setDragImageOffset(Point p)
        Sets an anchor offset for the image to drag. It can not be null.
        参数：
        p - a Point object that corresponds to coordinates of an anchor offset of the image relative to the upper left corner of the image

      • getDragImageOffset

        public Point getDragImageOffset()
        Returns an anchor offset for the image to drag.
        返回：
        a Point object that corresponds to coordinates of an anchor offset of the image relative to the upper left corner of the image. The point (0,0) returns by default.

      • exportAsDrag

        public void exportAsDrag(JComponent comp,
                InputEvent e,
                int action)
        Causes the Swing drag support to be initiated. This is called by the various UI implementations in the javax.swing.plaf.basic package if the dragEnabled property is set on the component. This can be called by custom UI implementations to use the Swing drag support. This method can also be called by a Swing extension written as a subclass of JComponent to take advantage of the Swing drag support.

        The transfer will not necessarily have been completed at the return of this call (i.e. the call does not block waiting for the drop). The transfer will take place through the Swing implementation of the java.awt.dnd mechanism, requiring no further effort from the developer. The exportDone method will be called when the transfer has completed.

        参数：
        comp - the component holding the data to be transferred; provided to enable sharing of TransferHandlers
        e - the event that triggered the transfer
        action - the transfer action initially requested; either COPY, MOVE or LINK; the DnD system may change the action used during the course of the drag operation

      • exportToClipboard

        public void exportToClipboard(JComponent comp,
                     Clipboard clip,
                     int action)
                       throws IllegalStateException
        Causes a transfer from the given component to the given clipboard. This method is called by the default cut and copy actions registered in a component's action map.

        The transfer will take place using the java.awt.datatransfer mechanism, requiring no further effort from the developer. Any data transfer will be complete and the exportDone method will be called with the action that occurred, before this method returns. Should the clipboard be unavailable when attempting to place data on it, the IllegalStateException thrown by Clipboard.setContents(Transferable, ClipboardOwner) will be propogated through this method. However, exportDone will first be called with an action of NONE for consistency.

        参数：
        comp - the component holding the data to be transferred; provided to enable sharing of TransferHandlers
        clip - the clipboard to transfer the data into
        action - the transfer action requested; this should be a value of either COPY or MOVE; the operation performed is the intersection of the transfer capabilities given by getSourceActions and the requested action; the intersection may result in an action of NONE if the requested action isn't supported
        抛出：
        IllegalStateException - if the clipboard is currently unavailable
        另请参见：
        Clipboard.setContents(Transferable, ClipboardOwner)

      • importData

        public boolean importData(TransferHandler.TransferSupport support)
        Causes a transfer to occur from a clipboard or a drag and drop operation. The Transferable to be imported and the component to transfer to are contained within the TransferSupport.

        While the drag and drop implementation calls canImport to determine the suitability of a transfer before calling this method, the implementation of paste does not. As such, it cannot be assumed that the transfer is acceptable upon a call to this method for paste. It is recommended that canImport be explicitly called to cover this case.

        Note: The TransferSupport object passed to this method is only valid for the duration of the method call. It is undefined what values it may contain after this method returns.

        参数：
        support - the object containing the details of the transfer, not null.
        返回：
        true if the data was inserted into the component, false otherwise
        抛出：
        NullPointerException - if support is null
        从以下版本开始：
        1.6
        另请参见：
        canImport(TransferHandler.TransferSupport)

      • importData

        public boolean importData(JComponent comp,
                 Transferable t)
        Causes a transfer to a component from a clipboard or a DND drop operation. The Transferable represents the data to be imported into the component.

        Note: Swing now calls the newer version of importData that takes a TransferSupport, which in turn calls this method (if the component in the TransferSupport is a JComponent). Developers are encouraged to call and override the newer version as it provides more information (and is the only version that supports use with a TransferHandler set directly on a JFrame or other non-JComponent).

        参数：
        comp - the component to receive the transfer; provided to enable sharing of TransferHandlers
        t - the data to import
        返回：
        true if the data was inserted into the component, false otherwise
        另请参见：
        importData(TransferHandler.TransferSupport)

      • canImport

        public boolean canImport(TransferHandler.TransferSupport support)
        This method is called repeatedly during a drag and drop operation to allow the developer to configure properties of, and to return the acceptability of transfers; with a return value of true indicating that the transfer represented by the given TransferSupport (which contains all of the details of the transfer) is acceptable at the current time, and a value of false rejecting the transfer.

        For those components that automatically display a drop location during drag and drop, accepting the transfer, by default, tells them to show the drop location. This can be changed by calling setShowDropLocation on the TransferSupport.

        By default, when the transfer is accepted, the chosen drop action is that picked by the user via their drag gesture. The developer can override this and choose a different action, from the supported source actions, by calling setDropAction on the TransferSupport.

        On every call to canImport, the TransferSupport contains fresh state. As such, any properties set on it must be set on every call. Upon a drop, canImport is called one final time before calling into importData. Any state set on the TransferSupport during that last call will be available in importData.

        This method is not called internally in response to paste operations. As such, it is recommended that implementations of importData explicitly call this method for such cases and that this method be prepared to return the suitability of paste operations as well.

        Note: The TransferSupport object passed to this method is only valid for the duration of the method call. It is undefined what values it may contain after this method returns.

        参数：
        support - the object containing the details of the transfer, not null.
        返回：
        true if the import can happen, false otherwise
        抛出：
        NullPointerException - if support is null
        从以下版本开始：
        1.6
        另请参见：
        importData(TransferHandler.TransferSupport),
TransferHandler.TransferSupport.setShowDropLocation(boolean),
TransferHandler.TransferSupport.setDropAction(int)

      • canImport

        public boolean canImport(JComponent comp,
                DataFlavor[] transferFlavors)
        Indicates whether a component will accept an import of the given set of data flavors prior to actually attempting to import it.

        Note: Swing now calls the newer version of canImport that takes a TransferSupport, which in turn calls this method (only if the component in the TransferSupport is a JComponent). Developers are encouraged to call and override the newer version as it provides more information (and is the only version that supports use with a TransferHandler set directly on a JFrame or other non-JComponent).

        参数：
        comp - the component to receive the transfer; provided to enable sharing of TransferHandlers
        transferFlavors - the data formats available
        返回：
        true if the data can be inserted into the component, false otherwise
        另请参见：
        canImport(TransferHandler.TransferSupport)

      • getSourceActions

        public int getSourceActions(JComponent c)
        Returns the type of transfer actions supported by the source; any bitwise-OR combination of COPY, MOVE and LINK.

        Some models are not mutable, so a transfer operation of MOVE should not be advertised in that case. Returning NONE disables transfers from the component.

        参数：
        c - the component holding the data to be transferred; provided to enable sharing of TransferHandlers
        返回：
        COPY if the transfer property can be found, otherwise returns NONE

      • getVisualRepresentation

        public Icon getVisualRepresentation(Transferable t)
        Returns an object that establishes the look of a transfer. This is useful for both providing feedback while performing a drag operation and for representing the transfer in a clipboard implementation that has a visual appearance. The implementation of the Icon interface should not alter the graphics clip or alpha level. The icon implementation need not be rectangular or paint all of the bounding rectangle and logic that calls the icons paint method should not assume the all bits are painted. null is a valid return value for this method and indicates there is no visual representation provided. In that case, the calling logic is free to represent the transferable however it wants.

        The default Swing logic will not do an alpha blended drag animation if the return is null.

        参数：
        t - the data to be transferred; this value is expected to have been created by the createTransferable method
        返回：
        null, indicating there is no default visual representation

      • createTransferable

        protected Transferable createTransferable(JComponent c)
        Creates a Transferable to use as the source for a data transfer. Returns the representation of the data to be transferred, or null if the component's property is null
        参数：
        c - the component holding the data to be transferred; provided to enable sharing of TransferHandlers
        返回：
        the representation of the data to be transferred, or null if the property associated with c is null

      • exportDone

        protected void exportDone(JComponent source,
              Transferable data,
              int action)
        Invoked after data has been exported. This method should remove the data that was transferred if the action was MOVE.

        This method is implemented to do nothing since MOVE is not a supported action of this implementation (getSourceActions does not include MOVE).

        参数：
        source - the component that was the source of the data
        data - The data that was transferred or possibly null if the action is NONE.
        action - the actual action that was performed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TransferHandler.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 TransferHandler.DropLocation

  • java.lang.Object
    • javax.swing.TransferHandler.DropLocation
  • 直接已知子类：
    JList.DropLocation, JTable.DropLocation, JTextComponent.DropLocation, JTree.DropLocation
    封闭类：
    TransferHandler

    public static class TransferHandler.DropLocation
extends Object
    Represents a location where dropped data should be inserted. This is a base class that only encapsulates a point. Components supporting drop may provide subclasses of this containing more information.

    Developers typically shouldn't create instances of, or extend, this class. Instead, these are something provided by the DnD implementation by TransferSupport instances and by components with a getDropLocation() method.

    从以下版本开始：
    1.6
    另请参见：
    TransferHandler.TransferSupport.getDropLocation()

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TransferHandler.DropLocation(Point dropPoint)
      Constructs a drop location for the given point.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Point getDropPoint()
      Returns the drop point, representing the mouse's current location within the component.
      String toString()
      Returns a string representation of this drop location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransferHandler.DropLocation

        protected TransferHandler.DropLocation(Point dropPoint)
        Constructs a drop location for the given point.
        参数：
        dropPoint - the drop point, representing the mouse's current location within the component.
        抛出：
        IllegalArgumentException - if the point is null

    • 方法详细信息

      • getDropPoint

        public final Point getDropPoint()
        Returns the drop point, representing the mouse's current location within the component.
        返回：
        the drop point.

      • toString

        public String toString()
        Returns a string representation of this drop location. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class Object
        返回：
        a string representation of this drop location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ittlseths=.l/bd=l/nc


TransferHandler.TransferSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 TransferHandler.TransferSupport

  • java.lang.Object
    • javax.swing.TransferHandler.TransferSupport
  • 封闭类：
    TransferHandler

    public static final class TransferHandler.TransferSupport
extends Object
    This class encapsulates all relevant details of a clipboard or drag and drop transfer, and also allows for customizing aspects of the drag and drop experience.

    The main purpose of this class is to provide the information needed by a developer to determine the suitability of a transfer or to import the data contained within. But it also doubles as a controller for customizing properties during drag and drop, such as whether or not to show the drop location, and which drop action to use.

    Developers typically need not create instances of this class. Instead, they are something provided by the DnD implementation to certain methods in TransferHandler.

    从以下版本开始：
    1.6
    另请参见：
    TransferHandler.canImport(TransferHandler.TransferSupport), TransferHandler.importData(TransferHandler.TransferSupport)

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransferHandler.TransferSupport(Component component, Transferable transferable)
      Create a TransferSupport with isDrop() false for the given component and Transferable.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getComponent()
      Returns the target component of this transfer.
      DataFlavor[] getDataFlavors()
      Returns the data flavors for this transfer.
      int getDropAction()
      Returns the action chosen for the drop, when this TransferSupport represents a drop.
      TransferHandler.DropLocation getDropLocation()
      Returns the current (non-null) drop location for the component, when this TransferSupport represents a drop.
      int getSourceDropActions()
      Returns the drag source's supported drop actions, when this TransferSupport represents a drop.
      Transferable getTransferable()
      Returns the Transferable associated with this transfer.
      int getUserDropAction()
      Returns the user drop action for the drop, when this TransferSupport represents a drop.
      boolean isDataFlavorSupported(DataFlavor df)
      Returns whether or not the given data flavor is supported.
      boolean isDrop()
      Returns whether or not this TransferSupport represents a drop operation.
      void setDropAction(int dropAction)
      Sets the drop action for the transfer - which must represent a drop - to the given action, instead of the default user drop action.
      void setShowDropLocation(boolean showDropLocation)
      Sets whether or not the drop location should be visually indicated for the transfer - which must represent a drop.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TransferHandler.TransferSupport

        public TransferHandler.TransferSupport(Component component,
                               Transferable transferable)
        Create a TransferSupport with isDrop() false for the given component and Transferable.
        参数：
        component - the target component
        transferable - the transferable
        抛出：
        NullPointerException - if either parameter is null

    • 方法详细信息

      • isDrop

        public boolean isDrop()
        Returns whether or not this TransferSupport represents a drop operation.
        返回：
        true if this is a drop operation, false otherwise.

      • getComponent

        public Component getComponent()
        Returns the target component of this transfer.
        返回：
        the target component

      • getDropLocation

        public TransferHandler.DropLocation getDropLocation()
        Returns the current (non-null) drop location for the component, when this TransferSupport represents a drop.

        Note: For components with built-in drop support, this location will be a subclass of DropLocation of the same type returned by that component's getDropLocation method.

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        返回：
        the drop location
        抛出：
        IllegalStateException - if this is not a drop
        另请参见：
        isDrop()

      • setShowDropLocation

        public void setShowDropLocation(boolean showDropLocation)
        Sets whether or not the drop location should be visually indicated for the transfer - which must represent a drop. This is applicable to those components that automatically show the drop location when appropriate during a drag and drop operation). By default, the drop location is shown only when the TransferHandler has said it can accept the import represented by this TransferSupport. With this method you can force the drop location to always be shown, or always not be shown.

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        参数：
        showDropLocation - whether or not to indicate the drop location
        抛出：
        IllegalStateException - if this is not a drop
        另请参见：
        isDrop()

      • setDropAction

        public void setDropAction(int dropAction)
        Sets the drop action for the transfer - which must represent a drop - to the given action, instead of the default user drop action. The action must be supported by the source's drop actions, and must be one of COPY, MOVE or LINK.

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        参数：
        dropAction - the drop action
        抛出：
        IllegalStateException - if this is not a drop
        IllegalArgumentException - if an invalid action is specified
        另请参见：
        getDropAction(),
getUserDropAction(),
getSourceDropActions(),
isDrop()

      • getDropAction

        public int getDropAction()
        Returns the action chosen for the drop, when this TransferSupport represents a drop.

        Unless explicitly chosen by way of setDropAction, this returns the user drop action provided by getUserDropAction.

        You may wish to query this in TransferHandler's importData method to customize processing based on the action.

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        返回：
        the action chosen for the drop
        抛出：
        IllegalStateException - if this is not a drop
        另请参见：
        setDropAction(int), getUserDropAction(), isDrop()

      • getUserDropAction

        public int getUserDropAction()
        Returns the user drop action for the drop, when this TransferSupport represents a drop.

        The user drop action is chosen for a drop as described in the documentation for DropTargetDragEvent and DropTargetDropEvent. A different action may be chosen as the drop action by way of the setDropAction method.

        You may wish to query this in TransferHandler's canImport method when determining the suitability of a drop or when deciding on a drop action to explicitly choose.

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        返回：
        the user drop action
        抛出：
        IllegalStateException - if this is not a drop
        另请参见：
        setDropAction(int), getDropAction(), isDrop()

      • getSourceDropActions

        public int getSourceDropActions()
        Returns the drag source's supported drop actions, when this TransferSupport represents a drop.

        The source actions represent the set of actions supported by the source of this transfer, and are represented as some bitwise-OR combination of COPY, MOVE and LINK. You may wish to query this in TransferHandler's canImport method when determining the suitability of a drop or when deciding on a drop action to explicitly choose. To determine if a particular action is supported by the source, bitwise-AND the action with the source drop actions, and then compare the result against the original action. For example:

         boolean copySupported = (COPY & getSourceDropActions()) == COPY;

        This method is only for use with drag and drop transfers. Calling it when isDrop() is false results in an IllegalStateException.

        返回：
        the drag source's supported drop actions
        抛出：
        IllegalStateException - if this is not a drop
        另请参见：
        isDrop()

      • getDataFlavors

        public DataFlavor[] getDataFlavors()
        Returns the data flavors for this transfer.
        返回：
        the data flavors for this transfer

      • isDataFlavorSupported

        public boolean isDataFlavorSupported(DataFlavor df)
        Returns whether or not the given data flavor is supported.
        参数：
        df - the DataFlavor to test
        返回：
        whether or not the given flavor is supported.

      • getTransferable

        public Transferable getTransferable()
        Returns the Transferable associated with this transfer.

        Note: Unless it is necessary to fetch the Transferable directly, use one of the other methods on this class to inquire about the transfer. This may perform better than fetching the Transferable and asking it directly.

        返回：
        the Transferable associated with this transfer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t ac nc faa fftceere< nntc>p>edo


UIDefaults

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 UIDefaults

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<Object,Object>
        • javax.swing.UIDefaults
  • 所有已实现的接口：
    Serializable, Cloneable, Map<Object,Object>

    public class UIDefaults
extends Hashtable<Object,Object>
    A table of defaults for Swing components. Applications can set/get default values via the UIManager.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    UIManager

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static interface  UIDefaults.ActiveValue
      This class enables one to store an entry in the defaults table that's constructed each time it's looked up with one of the getXXX(key) methods.
      static class  UIDefaults.LazyInputMap
      LazyInputMap will create a InputMap in its createValue method.
      static interface  UIDefaults.LazyValue
      This class enables one to store an entry in the defaults table that isn't constructed until the first time it's looked up with one of the getXXX(key) methods.
      static class  UIDefaults.ProxyLazyValue
      This class provides an implementation of LazyValue which can be used to delay loading of the Class for the instance to be created.

    • 构造方法摘要

      Constructors
      构造方法与描述
      UIDefaults()
      Creates an empty defaults table.
      UIDefaults(int initialCapacity, float loadFactor)
      Creates an empty defaults table with the specified initial capacity and load factor.
      UIDefaults(Object[] keyValueList)
      Creates a defaults table initialized with the specified key/value pairs.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addResourceBundle(String bundleName)
      Adds a resource bundle to the list of resource bundles that are searched for localized values.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Support for reporting bound property changes.
      Object get(Object key)
      Returns the value for key.
      Object get(Object key, Locale l)
      Returns the value for key associated with the given locale.
      boolean getBoolean(Object key)
      If the value of key is boolean, return the boolean value, otherwise return false.
      boolean getBoolean(Object key, Locale l)
      If the value of key for the given Locale is boolean, return the boolean value, otherwise return false.
      Border getBorder(Object key)
      If the value of key is a Border return it, otherwise return null.
      Border getBorder(Object key, Locale l)
      If the value of key for the given Locale is a Border return it, otherwise return null.
      Color getColor(Object key)
      If the value of key is a Color return it, otherwise return null.
      Color getColor(Object key, Locale l)
      If the value of key for the given Locale is a Color return it, otherwise return null.
      Locale getDefaultLocale()
      Returns the default locale.
      Dimension getDimension(Object key)
      If the value of key is a Dimension return it, otherwise return null.
      Dimension getDimension(Object key, Locale l)
      If the value of key for the given Locale is a Dimension return it, otherwise return null.
      Font getFont(Object key)
      If the value of key is a Font return it, otherwise return null.
      Font getFont(Object key, Locale l)
      If the value of key for the given Locale is a Font return it, otherwise return null.
      Icon getIcon(Object key)
      If the value of key is an Icon return it, otherwise return null.
      Icon getIcon(Object key, Locale l)
      If the value of key for the given Locale is an Icon return it, otherwise return null.
      Insets getInsets(Object key)
      If the value of key is an Insets return it, otherwise return null.
      Insets getInsets(Object key, Locale l)
      If the value of key for the given Locale is an Insets return it, otherwise return null.
      int getInt(Object key)
      If the value of key is an Integer return its integer value, otherwise return 0.
      int getInt(Object key, Locale l)
      If the value of key for the given Locale is an Integer return its integer value, otherwise return 0.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the PropertyChangeListeners added to this UIDefaults with addPropertyChangeListener().
      String getString(Object key)
      If the value of key is a String return it, otherwise return null.
      String getString(Object key, Locale l)
      If the value of key for the given Locale is a String return it, otherwise return null.
      ComponentUI getUI(JComponent target)
      Creates an ComponentUI implementation for the specified component.
      类<? extends ComponentUI> getUIClass(String uiClassID)
      Returns the L&F class that renders this component.
      类<? extends ComponentUI> getUIClass(String uiClassID, ClassLoader uiClassLoader)
      The value of get(uidClassID) must be the String name of a class that implements the corresponding ComponentUI class.
      protected void getUIError(String msg)
      If getUI() fails for any reason, it calls this method before returning null.
      Object put(Object key, Object value)
      Sets the value of key to value for all locales.
      void putDefaults(Object[] keyValueList)
      Puts all of the key/value pairs in the database and unconditionally generates one PropertyChangeEvent.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removeResourceBundle(String bundleName)
      Removes a resource bundle from the list of resource bundles that are searched for localized defaults.
      void setDefaultLocale(Locale l)
      Sets the default locale.

      • 方法 - 继承于类 java.util.Hashtable

        clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, hashCode, isEmpty, keys, keySet, putAll, rehash, remove, size, toString, values

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UIDefaults

        public UIDefaults()
        Creates an empty defaults table.

      • UIDefaults

        public UIDefaults(int initialCapacity,
          float loadFactor)
        Creates an empty defaults table with the specified initial capacity and load factor.
        参数：
        initialCapacity - the initial capacity of the defaults table
        loadFactor - the load factor of the defaults table
        从以下版本开始：
        1.6
        另请参见：
        Hashtable

      • UIDefaults

        public UIDefaults(Object[] keyValueList)
        Creates a defaults table initialized with the specified key/value pairs. For example:
                Object[] uiDefaults = {
             "Font", new Font("Dialog", Font.BOLD, 12),
            "Color", Color.red,
             "five", new Integer(5)
        }
        UIDefaults myDefaults = new UIDefaults(uiDefaults);
        参数：
        keyValueList - an array of objects containing the key/value pairs

    • 方法详细信息

      • get

        public Object get(Object key)
        Returns the value for key. If the value is a UIDefaults.LazyValue then the real value is computed with LazyValue.createValue(), the table entry is replaced, and the real value is returned. If the value is an UIDefaults.ActiveValue the table entry is not replaced - the value is computed with ActiveValue.createValue() for each get() call. If the key is not found in the table then it is searched for in the list of resource bundles maintained by this object. The resource bundles are searched most recently added first using the locale returned by getDefaultLocale. LazyValues and ActiveValues are not supported in the resource bundles.
        指定者：
        get in interface Map<Object,Object>
        重载：
        get in class Hashtable<Object,Object>
        参数：
        key - the desired key
        返回：
        the value for key
        从以下版本开始：
        1.4
        另请参见：
        UIDefaults.LazyValue,
UIDefaults.ActiveValue,
Hashtable.get(java.lang.Object),
getDefaultLocale(),
addResourceBundle(java.lang.String)

      • get

        public Object get(Object key,
         Locale l)
        Returns the value for key associated with the given locale. If the value is a UIDefaults.LazyValue then the real value is computed with LazyValue.createValue(), the table entry is replaced, and the real value is returned. If the value is an UIDefaults.ActiveValue the table entry is not replaced - the value is computed with ActiveValue.createValue() for each get() call. If the key is not found in the table then it is searched for in the list of resource bundles maintained by this object. The resource bundles are searched most recently added first using the given locale. LazyValues and ActiveValues are not supported in the resource bundles.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        the value for key
        从以下版本开始：
        1.4
        另请参见：
        UIDefaults.LazyValue, UIDefaults.ActiveValue, Hashtable.get(java.lang.Object), addResourceBundle(java.lang.String)

      • put

        public Object put(Object key,
         Object value)
        Sets the value of key to value for all locales. If key is a string and the new value isn't equal to the old one, fire a PropertyChangeEvent. If value is null, the key is removed from the table.
        指定者：
        put in interface Map<Object,Object>
        重载：
        put in class Hashtable<Object,Object>
        参数：
        key - the unique Object who's value will be used to retrieve the data value associated with it
        value - the new Object to store as data under that key
        返回：
        the previous Object value, or null
        另请参见：
        putDefaults(java.lang.Object[]), Hashtable.put(K, V)

      • putDefaults

        public void putDefaults(Object[] keyValueList)
        Puts all of the key/value pairs in the database and unconditionally generates one PropertyChangeEvent. The events oldValue and newValue will be null and its propertyName will be "UIDefaults". The key/value pairs are added for all locales.
        参数：
        keyValueList - an array of key/value pairs
        另请参见：
        put(java.lang.Object, java.lang.Object), Hashtable.put(K, V)

      • getFont

        public Font getFont(Object key)
        If the value of key is a Font return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is a Font, return the Font object; otherwise return null

      • getFont

        public Font getFont(Object key,
           Locale l)
        If the value of key for the given Locale is a Font return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is a Font, return the Font object; otherwise return null
        从以下版本开始：
        1.4

      • getColor

        public Color getColor(Object key)
        If the value of key is a Color return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is a Color, return the Color object; otherwise return null

      • getColor

        public Color getColor(Object key,
             Locale l)
        If the value of key for the given Locale is a Color return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is a Color, return the Color object; otherwise return null
        从以下版本开始：
        1.4

      • getIcon

        public Icon getIcon(Object key)
        If the value of key is an Icon return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is an Icon, return the Icon object; otherwise return null

      • getIcon

        public Icon getIcon(Object key,
           Locale l)
        If the value of key for the given Locale is an Icon return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is an Icon, return the Icon object; otherwise return null
        从以下版本开始：
        1.4

      • getBorder

        public Border getBorder(Object key)
        If the value of key is a Border return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is a Border, return the Border object; otherwise return null

      • getBorder

        public Border getBorder(Object key,
               Locale l)
        If the value of key for the given Locale is a Border return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is a Border, return the Border object; otherwise return null
        从以下版本开始：
        1.4

      • getString

        public String getString(Object key)
        If the value of key is a String return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is a String, return the String object; otherwise return null

      • getString

        public String getString(Object key,
               Locale l)
        If the value of key for the given Locale is a String return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired Locale
        返回：
        if the value for key for the given Locale is a String, return the String object; otherwise return null
        从以下版本开始：
        1.4

      • getInt

        public int getInt(Object key)
        If the value of key is an Integer return its integer value, otherwise return 0.
        参数：
        key - the desired key
        返回：
        if the value for key is an Integer, return its value, otherwise return 0

      • getInt

        public int getInt(Object key,
         Locale l)
        If the value of key for the given Locale is an Integer return its integer value, otherwise return 0.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is an Integer, return its value, otherwise return 0
        从以下版本开始：
        1.4

      • getBoolean

        public boolean getBoolean(Object key)
        If the value of key is boolean, return the boolean value, otherwise return false.
        参数：
        key - an Object specifying the key for the desired boolean value
        返回：
        if the value of key is boolean, return the boolean value, otherwise return false.
        从以下版本开始：
        1.4

      • getBoolean

        public boolean getBoolean(Object key,
                 Locale l)
        If the value of key for the given Locale is boolean, return the boolean value, otherwise return false.
        参数：
        key - an Object specifying the key for the desired boolean value
        l - the desired locale
        返回：
        if the value for key and Locale is boolean, return the boolean value, otherwise return false.
        从以下版本开始：
        1.4

      • getInsets

        public Insets getInsets(Object key)
        If the value of key is an Insets return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is an Insets, return the Insets object; otherwise return null

      • getInsets

        public Insets getInsets(Object key,
               Locale l)
        If the value of key for the given Locale is an Insets return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is an Insets, return the Insets object; otherwise return null
        从以下版本开始：
        1.4

      • getDimension

        public Dimension getDimension(Object key)
        If the value of key is a Dimension return it, otherwise return null.
        参数：
        key - the desired key
        返回：
        if the value for key is a Dimension, return the Dimension object; otherwise return null

      • getDimension

        public Dimension getDimension(Object key,
                     Locale l)
        If the value of key for the given Locale is a Dimension return it, otherwise return null.
        参数：
        key - the desired key
        l - the desired locale
        返回：
        if the value for key and Locale is a Dimension, return the Dimension object; otherwise return null
        从以下版本开始：
        1.4

      • getUIClass

        public 类<? extends ComponentUI> getUIClass(String uiClassID,
                                      ClassLoader uiClassLoader)
        The value of get(uidClassID) must be the String name of a class that implements the corresponding ComponentUI class. If the class hasn't been loaded before, this method looks up the class with uiClassLoader.loadClass() if a non null class loader is provided, classForName() otherwise.

        If a mapping for uiClassID exists or if the specified class can't be found, return null.

        This method is used by getUI, it's usually not necessary to call it directly.

        参数：
        uiClassID - a string containing the class ID
        uiClassLoader - the object which will load the class
        返回：
        the value of Class.forName(get(uidClassID))
        另请参见：
        getUI(javax.swing.JComponent)

      • getUIClass

        public 类<? extends ComponentUI> getUIClass(String uiClassID)
        Returns the L&F class that renders this component.
        参数：
        uiClassID - a string containing the class ID
        返回：
        the Class object returned by getUIClass(uiClassID, null)

      • getUIError

        protected void getUIError(String msg)
        If getUI() fails for any reason, it calls this method before returning null. Subclasses may choose to do more or less here.
        参数：
        msg - message string to print
        另请参见：
        getUI(javax.swing.JComponent)

      • getUI

        public ComponentUI getUI(JComponent target)
        Creates an ComponentUI implementation for the specified component. In other words create the look and feel specific delegate object for target. This is done in two steps:
        • Look up the name of the ComponentUI implementation class under the value returned by target.getUIClassID().
        • Use the implementation classes static createUI() method to construct a look and feel delegate.
        参数：
        target - the JComponent which needs a UI
        返回：
        the ComponentUI object

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired whenever a default is changed.

        参数：
        listener - the PropertyChangeListener to be added
        另请参见：
        PropertyChangeSupport

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        参数：
        listener - the PropertyChangeListener to be removed
        另请参见：
        PropertyChangeSupport

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the PropertyChangeListeners added to this UIDefaults with addPropertyChangeListener().
        返回：
        all of the PropertyChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Support for reporting bound property changes. If oldValue and newValue are not equal and the PropertyChangeEventx listener list isn't empty, then fire a PropertyChange event to each listener.
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property
        newValue - the new value of the property
        另请参见：
        PropertyChangeSupport

      • addResourceBundle

        public void addResourceBundle(String bundleName)
        Adds a resource bundle to the list of resource bundles that are searched for localized values. Resource bundles are searched in the reverse order they were added. In other words, the most recently added bundle is searched first.
        参数：
        bundleName - the base name of the resource bundle to be added
        从以下版本开始：
        1.4
        另请参见：
        ResourceBundle, removeResourceBundle(java.lang.String)

      • removeResourceBundle

        public void removeResourceBundle(String bundleName)
        Removes a resource bundle from the list of resource bundles that are searched for localized defaults.
        参数：
        bundleName - the base name of the resource bundle to be removed
        从以下版本开始：
        1.4
        另请参见：
        ResourceBundle, addResourceBundle(java.lang.String)

      • setDefaultLocale

        public void setDefaultLocale(Locale l)
        Sets the default locale. The default locale is used in retrieving localized values via get methods that do not take a locale argument. As of release 1.4, Swing UI objects should retrieve localized values using the locale of their component rather than the default locale. The default locale exists to provide compatibility with pre 1.4 behaviour.
        参数：
        l - the new default locale
        从以下版本开始：
        1.4
        另请参见：
        getDefaultLocale(), get(Object), get(Object,Locale)

      • getDefaultLocale

        public Locale getDefaultLocale()
        Returns the default locale. The default locale is used in retrieving localized values via get methods that do not take a locale argument. As of release 1.4, Swing UI objects should retrieve localized values using the locale of their component rather than the default locale. The default locale exists to provide compatibility with pre 1.4 behaviour.
        返回：
        the default locale
        从以下版本开始：
        1.4
        另请参见：
        setDefaultLocale(java.util.Locale), get(Object), get(Object,Locale)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UIDefaults.ActiveValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface UIDefaults.ActiveValue

  • 封闭类：
    UIDefaults

    public static interface UIDefaults.ActiveValue
    This class enables one to store an entry in the defaults table that's constructed each time it's looked up with one of the getXXX(key) methods. Here's an example of an ActiveValue that constructs a DefaultListCellRenderer:
      Object cellRendererActiveValue = new UIDefaults.ActiveValue() {
      public Object createValue(UIDefaults table) {
          return new DefaultListCellRenderer();
      }
  };

  uiDefaultsTable.put("MyRenderer", cellRendererActiveValue);
    另请参见：
    UIDefaults.get(java.lang.Object)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object createValue(UIDefaults table)
      Creates the value retrieved from the UIDefaults table.

    • 方法详细信息

      • createValue

        Object createValue(UIDefaults table)
        Creates the value retrieved from the UIDefaults table. The object is created each time it is accessed.
        参数：
        table - a UIDefaults table
        返回：
        the created Object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nvg/".r..rheerhhgeooctd< >llott"aCe


UIDefaults.LazyInputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 UIDefaults.LazyInputMap

  • java.lang.Object
    • javax.swing.UIDefaults.LazyInputMap
  • 所有已实现的接口：
    UIDefaults.LazyValue
    封闭类：
    UIDefaults

    public static class UIDefaults.LazyInputMap
extends Object
implements UIDefaults.LazyValue
    LazyInputMap will create a InputMap in its createValue method. The bindings are passed in in the constructor. The bindings are an array with the even number entries being string KeyStrokes (eg "alt SPACE") and the odd number entries being the value to use in the InputMap (and the key in the ActionMap).
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      UIDefaults.LazyInputMap(Object[] bindings)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object createValue(UIDefaults table)
      Creates an InputMap with the bindings that are passed in.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UIDefaults.LazyInputMap

        public UIDefaults.LazyInputMap(Object[] bindings)

    • 方法详细信息

      • createValue

        public Object createValue(UIDefaults table)
        Creates an InputMap with the bindings that are passed in.
        指定者：
        createValue in interface UIDefaults.LazyValue
        参数：
        table - a UIDefaults table
        返回：
        the InputMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Obbasic ic"llc""i.//ljrat""ganobpa//i>">So.


UIDefaults.LazyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing

Interface UIDefaults.LazyValue

  • All Known Implementing Classes:
    UIDefaults.LazyInputMap, UIDefaults.ProxyLazyValue
    封闭类：
    UIDefaults

    public static interface UIDefaults.LazyValue
    This class enables one to store an entry in the defaults table that isn't constructed until the first time it's looked up with one of the getXXX(key) methods. Lazy values are useful for defaults that are expensive to construct or are seldom retrieved. The first time a LazyValue is retrieved its "real value" is computed by calling LazyValue.createValue() and the real value is used to replace the LazyValue in the UIDefaults table. Subsequent lookups for the same key return the real value. Here's an example of a LazyValue that constructs a Border:
      Object borderLazyValue = new UIDefaults.LazyValue() {
      public Object createValue(UIDefaults table) {
          return new BorderFactory.createLoweredBevelBorder();
      }
  };

  uiDefaultsTable.put("MyBorder", borderLazyValue);
    另请参见：
    UIDefaults.get(java.lang.Object)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object createValue(UIDefaults table)
      Creates the actual value retrieved from the UIDefaults table.

    • 方法详细信息

      • createValue

        Object createValue(UIDefaults table)
        Creates the actual value retrieved from the UIDefaults table. When an object that implements this interface is retrieved from the table, this method is used to create the real value, which is then stored in the table and returned to the calling method.
        参数：
        table - a UIDefaults table
        返回：
        the created Object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Pal&r&&&;&;nn&;;tneeaial


UIDefaults.ProxyLazyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 UIDefaults.ProxyLazyValue

  • java.lang.Object
    • javax.swing.UIDefaults.ProxyLazyValue
  • 所有已实现的接口：
    UIDefaults.LazyValue
    封闭类：
    UIDefaults

    public static class UIDefaults.ProxyLazyValue
extends Object
implements UIDefaults.LazyValue
    This class provides an implementation of LazyValue which can be used to delay loading of the Class for the instance to be created. It also avoids creation of an anonymous inner class for the LazyValue subclass. Both of these improve performance at the time that a a Look and Feel is loaded, at the cost of a slight performance reduction the first time createValue is called (since Reflection APIs are used).
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      UIDefaults.ProxyLazyValue(String c)
      Creates a LazyValue which will construct an instance when asked.
      UIDefaults.ProxyLazyValue(String c, Object[] o)
      Creates a LazyValue which will construct an instance when asked.
      UIDefaults.ProxyLazyValue(String c, String m)
      Creates a LazyValue which will construct an instance when asked.
      UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
      Creates a LazyValue which will construct an instance when asked.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object createValue(UIDefaults table)
      Creates the value retrieved from the UIDefaults table.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UIDefaults.ProxyLazyValue

        public UIDefaults.ProxyLazyValue(String c)
        Creates a LazyValue which will construct an instance when asked.
        参数：
        c - a String specifying the classname of the instance to be created on demand

      • UIDefaults.ProxyLazyValue

        public UIDefaults.ProxyLazyValue(String c,
                         String m)
        Creates a LazyValue which will construct an instance when asked.
        参数：
        c - a String specifying the classname of the class containing a static method to be called for instance creation
        m - a String specifying the static method to be called on class c

      • UIDefaults.ProxyLazyValue

        public UIDefaults.ProxyLazyValue(String c,
                         Object[] o)
        Creates a LazyValue which will construct an instance when asked.
        参数：
        c - a String specifying the classname of the instance to be created on demand
        o - an array of Objects to be passed as paramaters to the constructor in class c

      • UIDefaults.ProxyLazyValue

        public UIDefaults.ProxyLazyValue(String c,
                         String m,
                         Object[] o)
        Creates a LazyValue which will construct an instance when asked.
        参数：
        c - a String specifying the classname of the class containing a static method to be called for instance creation.
        m - a String specifying the static method to be called on class c
        o - an array of Objects to be passed as paramaters to the static method in class c

    • 方法详细信息

      • createValue

        public Object createValue(UIDefaults table)
        Creates the value retrieved from the UIDefaults table. The object is created each time it is accessed.
        指定者：
        createValue in interface UIDefaults.LazyValue
        参数：
        table - a UIDefaults table
        返回：
        the created Object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.ileoD>(.dcr< Mfse/i/>"mm k< /Tma s<


UIManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 UIManager

  • java.lang.Object
    • javax.swing.UIManager
  • 所有已实现的接口：
    Serializable

    public class UIManager
extends Object
implements Serializable
    UIManager manages the current look and feel, the set of available look and feels, PropertyChangeListeners that are notified when the look and feel changes, look and feel defaults, and convenience methods for obtaining various default values.

    Specifying the look and feel

    The look and feel can be specified in two distinct ways: by specifying the fully qualified name of the class for the look and feel, or by creating an instance of LookAndFeel and passing it to setLookAndFeel. The following example illustrates setting the look and feel to the system look and feel:
       UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
    The following example illustrates setting the look and feel based on class name:
       UIManager.setLookAndFeel("javax.swing.plaf.metal.MetalLookAndFeel");
    Once the look and feel has been changed it is imperative to invoke updateUI on all JComponents. The method SwingUtilities.updateComponentTreeUI(java.awt.Component) makes it easy to apply updateUI to a containment hierarchy. Refer to it for details. The exact behavior of not invoking updateUI after changing the look and feel is unspecified. It is very possible to receive unexpected exceptions, painting problems, or worse.

    Default look and feel

    The class used for the default look and feel is chosen in the following manner:
    1. If the system property swing.defaultlaf is non-null, use its value as the default look and feel class name.
    2. If the Properties file swing.properties exists and contains the key swing.defaultlaf, use its value as the default look and feel class name. The location that is checked for swing.properties may vary depending upon the implementation of the Java platform. In Sun's implementation the location is ${java.home}/lib/swing.properties. Refer to the release notes of the implementation being used for further details.
    3. Otherwise use the cross platform look and feel.

    Defaults

    UIManager manages three sets of UIDefaults. In order, they are:
    1. Developer defaults. With few exceptions Swing does not alter the developer defaults; these are intended to be modified and used by the developer.
    2. Look and feel defaults. The look and feel defaults are supplied by the look and feel at the time it is installed as the current look and feel (setLookAndFeel() is invoked). The look and feel defaults can be obtained using the getLookAndFeelDefaults() method.
    3. Sytem defaults. The system defaults are provided by Swing.
    Invoking any of the various get methods results in checking each of the defaults, in order, returning the first non-null value. For example, invoking UIManager.getString("Table.foreground") results in first checking developer defaults. If the developer defaults contain a value for "Table.foreground" it is returned, otherwise the look and feel defaults are checked, followed by the system defaults.

    It's important to note that getDefaults returns a custom instance of UIDefaults with this resolution logic built into it. For example, UIManager.getDefaults().getString("Table.foreground") is equivalent to UIManager.getString("Table.foreground"). Both resolve using the algorithm just described. In many places the documentation uses the word defaults to refer to the custom instance of UIDefaults with the resolution logic as previously described.

    When the look and feel is changed, UIManager alters only the look and feel defaults; the developer and system defaults are not altered by the UIManager in any way.

    The set of defaults a particular look and feel supports is defined and documented by that look and feel. In addition, each look and feel, or ComponentUI provided by a look and feel, may access the defaults at different times in their life cycle. Some look and feels may agressively look up defaults, so that changing a default may not have an effect after installing the look and feel. Other look and feels may lazily access defaults so that a change to the defaults may effect an existing look and feel. Finally, other look and feels might not configure themselves from the defaults table in any way. None-the-less it is usually the case that a look and feel expects certain defaults, so that in general a ComponentUI provided by one look and feel will not work with another look and feel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  UIManager.LookAndFeelInfo
      Provides a little information about an installed LookAndFeel for the sake of configuring a menu or for initial application set up.

    • 构造方法摘要

      Constructors
      构造方法与描述
      UIManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static void addAuxiliaryLookAndFeel(LookAndFeel laf)
      Adds a LookAndFeel to the list of auxiliary look and feels.
      static void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      static Object get(Object key)
      Returns an object from the defaults.
      static Object get(Object key, Locale l)
      Returns an object from the defaults that is appropriate for the given locale.
      static LookAndFeel[] getAuxiliaryLookAndFeels()
      Returns the list of auxiliary look and feels (can be null).
      static boolean getBoolean(Object key)
      Returns a boolean from the defaults which is associated with the key value.
      static boolean getBoolean(Object key, Locale l)
      Returns a boolean from the defaults which is associated with the key value and the given Locale.
      static Border getBorder(Object key)
      Returns a border from the defaults.
      static Border getBorder(Object key, Locale l)
      Returns a border from the defaults that is appropriate for the given locale.
      static Color getColor(Object key)
      Returns a color from the defaults.
      static Color getColor(Object key, Locale l)
      Returns a color from the defaults that is appropriate for the given locale.
      static String getCrossPlatformLookAndFeelClassName()
      Returns the name of the LookAndFeel class that implements the default cross platform look and feel -- the Java Look and Feel (JLF).
      static UIDefaults getDefaults()
      Returns the defaults.
      static Dimension getDimension(Object key)
      Returns a dimension from the defaults.
      static Dimension getDimension(Object key, Locale l)
      Returns a dimension from the defaults that is appropriate for the given locale.
      static Font getFont(Object key)
      Returns a font from the defaults.
      static Font getFont(Object key, Locale l)
      Returns a font from the defaults that is appropriate for the given locale.
      static Icon getIcon(Object key)
      Returns an Icon from the defaults.
      static Icon getIcon(Object key, Locale l)
      Returns an Icon from the defaults that is appropriate for the given locale.
      static Insets getInsets(Object key)
      Returns an Insets object from the defaults.
      static Insets getInsets(Object key, Locale l)
      Returns an Insets object from the defaults that is appropriate for the given locale.
      static UIManager.LookAndFeelInfo[] getInstalledLookAndFeels()
      Returns an array of LookAndFeelInfos representing the LookAndFeel implementations currently available.
      static int getInt(Object key)
      Returns an integer from the defaults.
      static int getInt(Object key, Locale l)
      Returns an integer from the defaults that is appropriate for the given locale.
      static LookAndFeel getLookAndFeel()
      Returns the current look and feel or null.
      static UIDefaults getLookAndFeelDefaults()
      Returns the UIDefaults from the current look and feel, that were obtained at the time the look and feel was installed.
      static PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the PropertyChangeListeners added to this UIManager with addPropertyChangeListener().
      static String getString(Object key)
      Returns a string from the defaults.
      static String getString(Object key, Locale l)
      Returns a string from the defaults that is appropriate for the given locale.
      static String getSystemLookAndFeelClassName()
      Returns the name of the LookAndFeel class that implements the native system look and feel if there is one, otherwise the name of the default cross platform LookAndFeel class.
      static ComponentUI getUI(JComponent target)
      Returns the appropriate ComponentUI implementation for target.
      static void installLookAndFeel(String name, String className)
      Adds the specified look and feel to the set of available look and feels.
      static void installLookAndFeel(UIManager.LookAndFeelInfo info)
      Adds the specified look and feel to the set of available look and feels.
      static Object put(Object key, Object value)
      Stores an object in the developer defaults.
      static boolean removeAuxiliaryLookAndFeel(LookAndFeel laf)
      Removes a LookAndFeel from the list of auxiliary look and feels.
      static void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      static void setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos)
      Sets the set of available look and feels.
      static void setLookAndFeel(LookAndFeel newLookAndFeel)
      Sets the current look and feel to newLookAndFeel.
      static void setLookAndFeel(String className)
      Loads the LookAndFeel specified by the given class name, using the current thread's context class loader, and passes it to setLookAndFeel(LookAndFeel).

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UIManager

        public UIManager()

    • 方法详细信息

      • getInstalledLookAndFeels

        public static UIManager.LookAndFeelInfo[] getInstalledLookAndFeels()
        Returns an array of LookAndFeelInfos representing the LookAndFeel implementations currently available. The LookAndFeelInfo objects can be used by an application to construct a menu of look and feel options for the user, or to determine which look and feel to set at startup time. To avoid the penalty of creating numerous LookAndFeel objects, LookAndFeelInfo maintains the class name of the LookAndFeel class, not the actual LookAndFeel instance.

        The following example illustrates setting the current look and feel from an instance of LookAndFeelInfo:

           UIManager.setLookAndFeel(info.getClassName());
        返回：
        an array of LookAndFeelInfo objects
        另请参见：
        setLookAndFeel(javax.swing.LookAndFeel)

      • setInstalledLookAndFeels

        public static void setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos)
                                     throws SecurityException
        Sets the set of available look and feels. While this method does not check to ensure all of the LookAndFeelInfos are non-null, it is strongly recommended that only non-null values are supplied in the infos array.
        参数：
        infos - set of LookAndFeelInfo objects specifying the available look and feels
        抛出：
        NullPointerException - if infos is null
        SecurityException
        另请参见：
        getInstalledLookAndFeels()

      • installLookAndFeel

        public static void installLookAndFeel(UIManager.LookAndFeelInfo info)
        Adds the specified look and feel to the set of available look and feels. While this method allows a null info, it is strongly recommended that a non-null value be used.
        参数：
        info - a LookAndFeelInfo object that names the look and feel and identifies the class that implements it
        另请参见：
        setInstalledLookAndFeels(javax.swing.UIManager.LookAndFeelInfo[])

      • installLookAndFeel

        public static void installLookAndFeel(String name,
                      String className)
        Adds the specified look and feel to the set of available look and feels. While this method does not check the arguments in any way, it is strongly recommended that non-null values be supplied.
        参数：
        name - descriptive name of the look and feel
        className - name of the class that implements the look and feel
        另请参见：
        setInstalledLookAndFeels(javax.swing.UIManager.LookAndFeelInfo[])

      • getLookAndFeel

        public static LookAndFeel getLookAndFeel()
        Returns the current look and feel or null.
        返回：
        current look and feel, or null
        另请参见：
        setLookAndFeel(javax.swing.LookAndFeel)

      • setLookAndFeel

        public static void setLookAndFeel(LookAndFeel newLookAndFeel)
                           throws UnsupportedLookAndFeelException
        Sets the current look and feel to newLookAndFeel. If the current look and feel is non-null uninitialize is invoked on it. If newLookAndFeel is non-null, initialize is invoked on it followed by getDefaults. The defaults returned from newLookAndFeel.getDefaults() replace those of the defaults from the previous look and feel. If the newLookAndFeel is null, the look and feel defaults are set to null.

        A value of null can be used to set the look and feel to null. As the LookAndFeel is required for most of Swing to function, setting the LookAndFeel to null is strongly discouraged.

        This is a JavaBeans bound property.

        参数：
        newLookAndFeel - LookAndFeel to install
        抛出：
        UnsupportedLookAndFeelException - if newLookAndFeel is non-null and newLookAndFeel.isSupportedLookAndFeel() returns false
        另请参见：
        getLookAndFeel()

      • setLookAndFeel

        public static void setLookAndFeel(String className)
                           throws ClassNotFoundException,
                                  InstantiationException,
                                  IllegalAccessException,
                                  UnsupportedLookAndFeelException
        Loads the LookAndFeel specified by the given class name, using the current thread's context class loader, and passes it to setLookAndFeel(LookAndFeel).
        参数：
        className - a string specifying the name of the class that implements the look and feel
        抛出：
        ClassNotFoundException - if the LookAndFeel class could not be found
        InstantiationException - if a new instance of the class couldn't be created
        IllegalAccessException - if the class or initializer isn't accessible
        UnsupportedLookAndFeelException - if lnf.isSupportedLookAndFeel() is false
        ClassCastException - if className does not identify a class that extends LookAndFeel

      • getSystemLookAndFeelClassName

        public static String getSystemLookAndFeelClassName()
        Returns the name of the LookAndFeel class that implements the native system look and feel if there is one, otherwise the name of the default cross platform LookAndFeel class. This value can be overriden by setting the swing.systemlaf system property.
        返回：
        the String of the LookAndFeel class
        另请参见：
        setLookAndFeel(javax.swing.LookAndFeel), getCrossPlatformLookAndFeelClassName()

      • getCrossPlatformLookAndFeelClassName

        public static String getCrossPlatformLookAndFeelClassName()
        Returns the name of the LookAndFeel class that implements the default cross platform look and feel -- the Java Look and Feel (JLF). This value can be overriden by setting the swing.crossplatformlaf system property.
        返回：
        a string with the JLF implementation-class
        另请参见：
        setLookAndFeel(javax.swing.LookAndFeel), getSystemLookAndFeelClassName()

      • getDefaults

        public static UIDefaults getDefaults()
        Returns the defaults. The returned defaults resolve using the logic specified in the class documentation.
        返回：
        a UIDefaults object containing the default values

      • getFont

        public static Font getFont(Object key)
        Returns a font from the defaults. If the value for key is not a Font, null is returned.
        参数：
        key - an Object specifying the font
        返回：
        the Font object
        抛出：
        NullPointerException - if key is null

      • getFont

        public static Font getFont(Object key,
           Locale l)
        Returns a font from the defaults that is appropriate for the given locale. If the value for key is not a Font, null is returned.
        参数：
        key - an Object specifying the font
        l - the Locale for which the font is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Font object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getColor

        public static Color getColor(Object key)
        Returns a color from the defaults. If the value for key is not a Color, null is returned.
        参数：
        key - an Object specifying the color
        返回：
        the Color object
        抛出：
        NullPointerException - if key is null

      • getColor

        public static Color getColor(Object key,
             Locale l)
        Returns a color from the defaults that is appropriate for the given locale. If the value for key is not a Color, null is returned.
        参数：
        key - an Object specifying the color
        l - the Locale for which the color is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Color object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getIcon

        public static Icon getIcon(Object key)
        Returns an Icon from the defaults. If the value for key is not an Icon, null is returned.
        参数：
        key - an Object specifying the icon
        返回：
        the Icon object
        抛出：
        NullPointerException - if key is null

      • getIcon

        public static Icon getIcon(Object key,
           Locale l)
        Returns an Icon from the defaults that is appropriate for the given locale. If the value for key is not an Icon, null is returned.
        参数：
        key - an Object specifying the icon
        l - the Locale for which the icon is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Icon object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getBorder

        public static Border getBorder(Object key)
        Returns a border from the defaults. If the value for key is not a Border, null is returned.
        参数：
        key - an Object specifying the border
        返回：
        the Border object
        抛出：
        NullPointerException - if key is null

      • getBorder

        public static Border getBorder(Object key,
               Locale l)
        Returns a border from the defaults that is appropriate for the given locale. If the value for key is not a Border, null is returned.
        参数：
        key - an Object specifying the border
        l - the Locale for which the border is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Border object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getString

        public static String getString(Object key)
        Returns a string from the defaults. If the value for key is not a String, null is returned.
        参数：
        key - an Object specifying the string
        返回：
        the String
        抛出：
        NullPointerException - if key is null

      • getString

        public static String getString(Object key,
               Locale l)
        Returns a string from the defaults that is appropriate for the given locale. If the value for key is not a String, null is returned.
        参数：
        key - an Object specifying the string
        l - the Locale for which the string is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the String
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getInt

        public static int getInt(Object key)
        Returns an integer from the defaults. If the value for key is not an Integer, or does not exist, 0 is returned.
        参数：
        key - an Object specifying the int
        返回：
        the int
        抛出：
        NullPointerException - if key is null

      • getInt

        public static int getInt(Object key,
         Locale l)
        Returns an integer from the defaults that is appropriate for the given locale. If the value for key is not an Integer, or does not exist, 0 is returned.
        参数：
        key - an Object specifying the int
        l - the Locale for which the int is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the int
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getBoolean

        public static boolean getBoolean(Object key)
        Returns a boolean from the defaults which is associated with the key value. If the key is not found or the key doesn't represent a boolean value then false is returned.
        参数：
        key - an Object specifying the key for the desired boolean value
        返回：
        the boolean value corresponding to the key
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getBoolean

        public static boolean getBoolean(Object key,
                 Locale l)
        Returns a boolean from the defaults which is associated with the key value and the given Locale. If the key is not found or the key doesn't represent a boolean value then false will be returned.
        参数：
        key - an Object specifying the key for the desired boolean value
        l - the Locale for which the boolean is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the boolean value corresponding to the key
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getInsets

        public static Insets getInsets(Object key)
        Returns an Insets object from the defaults. If the value for key is not an Insets, null is returned.
        参数：
        key - an Object specifying the Insets object
        返回：
        the Insets object
        抛出：
        NullPointerException - if key is null

      • getInsets

        public static Insets getInsets(Object key,
               Locale l)
        Returns an Insets object from the defaults that is appropriate for the given locale. If the value for key is not an Insets, null is returned.
        参数：
        key - an Object specifying the Insets object
        l - the Locale for which the object is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Insets object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • getDimension

        public static Dimension getDimension(Object key)
        Returns a dimension from the defaults. If the value for key is not a Dimension, null is returned.
        参数：
        key - an Object specifying the dimension object
        返回：
        the Dimension object
        抛出：
        NullPointerException - if key is null

      • getDimension

        public static Dimension getDimension(Object key,
                     Locale l)
        Returns a dimension from the defaults that is appropriate for the given locale. If the value for key is not a Dimension, null is returned.
        参数：
        key - an Object specifying the dimension object
        l - the Locale for which the object is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Dimension object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • get

        public static Object get(Object key)
        Returns an object from the defaults.
        参数：
        key - an Object specifying the desired object
        返回：
        the Object
        抛出：
        NullPointerException - if key is null

      • get

        public static Object get(Object key,
         Locale l)
        Returns an object from the defaults that is appropriate for the given locale.
        参数：
        key - an Object specifying the desired object
        l - the Locale for which the object is desired; refer to UIDefaults for details on how a null Locale is handled
        返回：
        the Object
        抛出：
        NullPointerException - if key is null
        从以下版本开始：
        1.4

      • put

        public static Object put(Object key,
         Object value)
        Stores an object in the developer defaults. This is a cover method for getDefaults().put(key, value). This only effects the developer defaults, not the system or look and feel defaults.
        参数：
        key - an Object specifying the retrieval key
        value - the Object to store; refer to UIDefaults for details on how null is handled
        返回：
        the Object returned by UIDefaults.put(java.lang.Object, java.lang.Object)
        抛出：
        NullPointerException - if key is null
        另请参见：
        UIDefaults.put(java.lang.Object, java.lang.Object)

      • getUI

        public static ComponentUI getUI(JComponent target)
        Returns the appropriate ComponentUI implementation for target. Typically, this is a cover for getDefaults().getUI(target). However, if an auxiliary look and feel has been installed, this first invokes getUI(target) on the multiplexing look and feel's defaults, and returns that value if it is non-null.
        参数：
        target - the JComponent to return the ComponentUI for
        返回：
        the ComponentUI object for target
        抛出：
        NullPointerException - if target is null
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • getLookAndFeelDefaults

        public static UIDefaults getLookAndFeelDefaults()
        Returns the UIDefaults from the current look and feel, that were obtained at the time the look and feel was installed.

        In general, developers should use the UIDefaults returned from getDefaults(). As the current look and feel may expect certain values to exist, altering the UIDefaults returned from this method could have unexpected results.

        返回：
        UIDefaults from the current look and feel
        另请参见：
        getDefaults(), setLookAndFeel(LookAndFeel), LookAndFeel.getDefaults()

      • addAuxiliaryLookAndFeel

        public static void addAuxiliaryLookAndFeel(LookAndFeel laf)
        Adds a LookAndFeel to the list of auxiliary look and feels. The auxiliary look and feels tell the multiplexing look and feel what other LookAndFeel classes for a component instance are to be used in addition to the default LookAndFeel class when creating a multiplexing UI. The change will only take effect when a new UI class is created or when the default look and feel is changed on a component instance.

        Note these are not the same as the installed look and feels.

        参数：
        laf - the LookAndFeel object
        另请参见：
        removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
setLookAndFeel(javax.swing.LookAndFeel),
getAuxiliaryLookAndFeels(),
getInstalledLookAndFeels()

      • removeAuxiliaryLookAndFeel

        public static boolean removeAuxiliaryLookAndFeel(LookAndFeel laf)
        Removes a LookAndFeel from the list of auxiliary look and feels. The auxiliary look and feels tell the multiplexing look and feel what other LookAndFeel classes for a component instance are to be used in addition to the default LookAndFeel class when creating a multiplexing UI. The change will only take effect when a new UI class is created or when the default look and feel is changed on a component instance.

        Note these are not the same as the installed look and feels.

        返回：
        true if the LookAndFeel was removed from the list
        另请参见：
        removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
getAuxiliaryLookAndFeels(),
setLookAndFeel(javax.swing.LookAndFeel),
getInstalledLookAndFeels()

      • getAuxiliaryLookAndFeels

        public static LookAndFeel[] getAuxiliaryLookAndFeels()
        Returns the list of auxiliary look and feels (can be null). The auxiliary look and feels tell the multiplexing look and feel what other LookAndFeel classes for a component instance are to be used in addition to the default LookAndFeel class when creating a multiplexing UI.

        Note these are not the same as the installed look and feels.

        返回：
        list of auxiliary LookAndFeels or null
        另请参见：
        addAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
setLookAndFeel(javax.swing.LookAndFeel),
getInstalledLookAndFeels()

      • addPropertyChangeListener

        public static void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.
        参数：
        listener - the PropertyChangeListener to be added
        另请参见：
        PropertyChangeSupport

      • removePropertyChangeListener

        public static void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        参数：
        listener - the PropertyChangeListener to be removed
        另请参见：
        PropertyChangeSupport

      • getPropertyChangeListeners

        public static PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the PropertyChangeListeners added to this UIManager with addPropertyChangeListener().
        返回：
        all of the PropertyChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


UIManager.LookAndFeelInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 UIManager.LookAndFeelInfo

  • java.lang.Object
    • javax.swing.UIManager.LookAndFeelInfo
  • 封闭类：
    UIManager

    public static class UIManager.LookAndFeelInfo
extends Object
    Provides a little information about an installed LookAndFeel for the sake of configuring a menu or for initial application set up.
    另请参见：
    UIManager.getInstalledLookAndFeels(), LookAndFeel

    • 构造方法摘要

      Constructors
      构造方法与描述
      UIManager.LookAndFeelInfo(String name, String className)
      Constructs a UIManagers LookAndFeelInfo object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getClassName()
      Returns the name of the class that implements this look and feel.
      String getName()
      Returns the name of the look and feel in a form suitable for a menu or other presentation
      String toString()
      Returns a string that displays and identifies this object's properties.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UIManager.LookAndFeelInfo

        public UIManager.LookAndFeelInfo(String name,
                         String className)
        Constructs a UIManagers LookAndFeelInfo object.
        参数：
        name - a String specifying the name of the look and feel
        className - a String specifiying the name of the class that implements the look and feel

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of the look and feel in a form suitable for a menu or other presentation
        返回：
        a String containing the name
        另请参见：
        LookAndFeel.getName()

      • getClassName

        public String getClassName()
        Returns the name of the class that implements this look and feel.
        返回：
        the name of the class that implements this LookAndFeel
        另请参见：
        LookAndFeel

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gm/.=.h".h rrh g>ee.aivn..."h<>.a


UnsupportedLookAndFeelException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing

类 UnsupportedLookAndFeelException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.swing.UnsupportedLookAndFeelException
  • 所有已实现的接口：
    Serializable

    public class UnsupportedLookAndFeelException
extends Exception
    An exception that indicates the requested look & feel management classes are not present on the user's system.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnsupportedLookAndFeelException(String s)
      Constructs an UnsupportedLookAndFeelException object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnsupportedLookAndFeelException

        public UnsupportedLookAndFeelException(String s)
        Constructs an UnsupportedLookAndFeelException object.
        参数：
        s - a message String
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pb-.=.e.l./...//fi<ai.<�


Uses of Package javax.swing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing

  • Packages that use javax.swing
    软件包 描述
    java.awt.im.spi
    Provides interfaces that enable the development of input methods that can be used with any Java runtime environment.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.filechooser
    Contains classes and interfaces used by the JFileChooser component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
  • Classes in javax.swing used by java.awt.im.spi
    类与描述
    JFrame
    An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
  • Classes in javax.swing used by javax.swing
    类与描述
    AbstractButton
    Defines common behaviors for buttons and menu items.
    AbstractButton.AccessibleAbstractButton
    This class implements accessibility support for the AbstractButton class.
    AbstractCellEditor
    A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue().
    AbstractListModel
    The abstract definition for the data model that provides a List with its contents.
    AbstractSpinnerModel
    This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations.
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    ActionMap
    ActionMap provides mappings from Objects (called keys or Action names) to Actions.
    BoundedRangeModel
    Defines the data model used by components like Sliders and ProgressBars.
    Box
    A lightweight container that uses a BoxLayout object as its layout manager.
    ButtonGroup
    This class is used to create a multiple-exclusion scope for a set of buttons.
    ButtonModel
    State model for buttons.
    CellEditor
    This interface defines the methods any general editor should be able to implement.
    ComboBoxEditor
    The editor component used for JComboBox components.
    ComboBoxModel
    A data model for a combo box.
    ComponentInputMap
    A ComponentInputMap is an InputMap associated with a particular JComponent.
    DefaultButtonModel
    The default implementation of a Button component's data model.
    DefaultCellEditor.EditorDelegate
    The protected EditorDelegate class.
    DefaultListCellRenderer
    Renders an item in a list.
    DefaultRowSorter.ModelWrapper
    DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter.
    DesktopManager
    DesktopManager objects are owned by a JDesktopPane object.
    DropMode
    Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
    FocusManager
    This class has been obsoleted by the 1.4 focus APIs.
    GroupLayout.Alignment
    Enumeration of the possible ways ParallelGroup can align its children.
    GroupLayout.Group
    Group provides the basis for the two types of operations supported by GroupLayout: laying out components one after another (SequentialGroup) or aligned (ParallelGroup).
    GroupLayout.ParallelGroup
    A Group that aligns and sizes it's children.
    GroupLayout.SequentialGroup
    A Group that positions and sizes its elements sequentially, one after another.
    Icon
    A small fixed size picture, typically used to decorate components.
    InputMap
    InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object.
    InputVerifier
    The purpose of this class is to help clients support smooth focus navigation through GUIs with text fields.
    InternalFrameFocusTraversalPolicy
    A FocusTraversalPolicy which can optionally provide an algorithm for determining a JInternalFrame's initial Component.
    JButton
    An implementation of a "push" button.
    JCheckBox
    An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
    JColorChooser
    JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComboBox.KeySelectionManager
    The interface that defines a KeySelectionManager.
    JComponent
    The base class for all Swing components except top-level containers.
    JComponent.AccessibleJComponent
    Inner class of JComponent used to provide default support for accessibility.
    JDesktopPane
    A container used to create a multiple-document interface or a virtual desktop.
    JDialog
    The main class for creating a dialog window.
    JEditorPane
    A text component to edit various kinds of content.
    JEditorPane.AccessibleJEditorPane
    This class implements accessibility support for the JEditorPane class.
    JFormattedTextField
    JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
    JFormattedTextField.AbstractFormatter
    Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object.
    JFormattedTextField.AbstractFormatterFactory
    Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    JInternalFrame.JDesktopIcon
    This component represents an iconified version of a JInternalFrame.
    JLabel
    A display area for a short text string or an image, or both.
    JLayeredPane
    JLayeredPane adds depth to a JFC/Swing container, allowing components to overlap each other when needed.
    JList
    A component that displays a list of objects and allows the user to select one or more items.
    JList.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JList.
    JMenu
    An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
    JMenu.WinListener
    A listener class that watches for a popup window closing.
    JMenuBar
    An implementation of a menu bar.
    JMenuItem
    An implementation of an item in a menu.
    JMenuItem.AccessibleJMenuItem
    This class implements accessibility support for the JMenuItem class.
    JPanel
    JPanel is a generic lightweight container.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JRootPane
    A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
    JScrollBar
    An implementation of a scrollbar.
    JScrollPane
    Provides a scrollable view of a lightweight component.
    JSeparator
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
    JSpinner
    A single line input field that lets the user select a number or an object value from an ordered sequence.
    JSpinner.DefaultEditor
    A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
    JTable
    The JTable is used to display and edit regular two-dimensional tables of cells.
    JTable.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
    JTable.PrintMode
    Printing modes, used in printing JTables.
    JTextField
    JTextField is a lightweight component that allows the editing of a single line of text.
    JTextField.AccessibleJTextField
    This class implements accessibility support for the JTextField class.
    JToggleButton
    An implementation of a two-state button.
    JToggleButton.AccessibleJToggleButton
    This class implements accessibility support for the JToggleButton class.
    JToolTip
    Used to display a "Tip" for a Component.
    JTree
    A control that displays a set of hierarchical data as an outline.
    JTree.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
    JTree.EmptySelectionModel
    EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
    JTree.TreeSelectionRedirector
    Handles creating a new TreeSelectionEvent with the JTree as the source and passing it off to all the listeners.
    JViewport
    The "viewport" or "porthole" through which you see the underlying information.
    JViewport.ViewListener
    A listener for the view.
    KeyStroke
    A KeyStroke represents a key action on the keyboard, or equivalent input device.
    LayoutStyle
    LayoutStyle provides information about how to position components.
    LayoutStyle.ComponentPlacement
    ComponentPlacement is an enumeration of the possible ways two components can be placed relative to each other.
    ListCellRenderer
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
    ListModel
    This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list.
    ListSelectionModel
    This interface represents the current state of the selection for any of the components that display a list of values with stable indices.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    MenuElement
    Any component that can be placed into a menu should implement this interface.
    MenuSelectionManager
    A MenuSelectionManager owns the selection in menu hierarchy.
    MutableComboBoxModel
    A mutable version of ComboBoxModel.
    Popup
    Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy.
    PopupFactory
    PopupFactory, as the name implies, is used to obtain instances of Popups.
    ProgressMonitor
    A class to monitor the progress of some operation.
    RepaintManager
    This class manages repaint requests, allowing the number of repaints to be minimized, for example by collapsing multiple requests into a single repaint for members of a component tree.
    RootPaneContainer
    This interface is implemented by components that have a single JRootPane child: JDialog, JFrame, JWindow, JApplet, JInternalFrame.
    RowFilter
    RowFilter is used to filter out entries from the model so that they are not shown in the view.
    RowFilter.ComparisonType
    Enumeration of the possible comparison values supported by some of the default RowFilters.
    RowFilter.Entry
    An Entry object is passed to instances of RowFilter, allowing the filter to get the value of the entry's data, and thus to determine whether the entry should be shown.
    RowSorter
    RowSorter provides the basis for sorting and filtering.
    RowSorter.SortKey
    SortKey describes the sort order for a particular column.
    Scrollable
    An interface that provides information to a scrolling container like JScrollPane.
    ScrollPaneConstants
    Constants used with the JScrollPane component.
    ScrollPaneLayout
    The layout manager used by JScrollPane.
    SingleSelectionModel
    A model that supports at most one indexed selection.
    SizeRequirements
    For the convenience of layout managers, calculates information about the size and position of components.
    SortingFocusTraversalPolicy
    A FocusTraversalPolicy that determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator.
    SortOrder
    SortOrder is an enumeration of the possible sort orderings.
    SpinnerDateModel
    A SpinnerModel for sequences of Dates.
    SpinnerListModel
    A simple implementation of SpinnerModel whose values are defined by an array or a List.
    SpinnerModel
    A model for a potentially unbounded sequence of object values.
    SpinnerNumberModel
    A SpinnerModel for sequences of numbers.
    Spring
    An instance of the Spring class holds three properties that characterize its behavior: the minimum, preferred, and maximum values.
    SpringLayout.Constraints
    A Constraints object holds the constraints that govern the way a component's size and position change in a container controlled by a SpringLayout.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    SwingWorker.StateValue
    Values for the state bound property.
    ToolTipManager
    Manages all the ToolTips in the system.
    TransferHandler
    This class is used to handle the transfer of a Transferable to and from Swing components.
    TransferHandler.DropLocation
    Represents a location where dropped data should be inserted.
    TransferHandler.TransferSupport
    This class encapsulates all relevant details of a clipboard or drag and drop transfer, and also allows for customizing aspects of the drag and drop experience.
    UIDefaults
    A table of defaults for Swing components.
    UIDefaults.LazyValue
    This class enables one to store an entry in the defaults table that isn't constructed until the first time it's looked up with one of the getXXX(key) methods.
    UIManager.LookAndFeelInfo
    Provides a little information about an installed LookAndFeel for the sake of configuring a menu or for initial application set up.
    UnsupportedLookAndFeelException
    An exception that indicates the requested look & feel management classes are not present on the user's system.
    WindowConstants
    Constants used to control the window-closing operation.
  • Classes in javax.swing used by javax.swing.border
    类与描述
    Icon
    A small fixed size picture, typically used to decorate components.
  • Classes in javax.swing used by javax.swing.colorchooser
    类与描述
    Icon
    A small fixed size picture, typically used to decorate components.
    JColorChooser
    JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
    JComponent
    The base class for all Swing components except top-level containers.
    JPanel
    JPanel is a generic lightweight container.
  • Classes in javax.swing used by javax.swing.event
    类与描述
    JComponent
    The base class for all Swing components except top-level containers.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    MenuElement
    Any component that can be placed into a menu should implement this interface.
    MenuSelectionManager
    A MenuSelectionManager owns the selection in menu hierarchy.
    RowSorter
    RowSorter provides the basis for sorting and filtering.
  • Classes in javax.swing used by javax.swing.filechooser
    类与描述
    Icon
    A small fixed size picture, typically used to decorate components.
  • Classes in javax.swing used by javax.swing.plaf
    类与描述
    ActionMap
    ActionMap provides mappings from Objects (called keys or Action names) to Actions.
    ComponentInputMap
    A ComponentInputMap is an InputMap associated with a particular JComponent.
    Icon
    A small fixed size picture, typically used to decorate components.
    InputMap
    InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object.
    JButton
    An implementation of a "push" button.
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComponent
    The base class for all Swing components except top-level containers.
    JFileChooser
    JFileChooser provides a simple mechanism for the user to choose a file.
    JLayer
    JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.
    JList
    A component that displays a list of objects and allows the user to select one or more items.
    JOptionPane
    JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JSplitPane
    JSplitPane is used to divide two (and only two) Components.
    JTabbedPane
    A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
    JTree
    A control that displays a set of hierarchical data as an outline.
    Popup
    Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy.
  • Classes in javax.swing used by javax.swing.plaf.basic
    类与描述
    AbstractAction
    This class provides default implementations for the JFC Action interface.
    AbstractButton
    Defines common behaviors for buttons and menu items.
    AbstractListModel
    The abstract definition for the data model that provides a List with its contents.
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    ActionMap
    ActionMap provides mappings from Objects (called keys or Action names) to Actions.
    BoxLayout
    A layout manager that allows multiple components to be laid out either vertically or horizontally.
    CellRendererPane
    This class is inserted in between cell renderers and the components that use them.
    ComboBoxEditor
    The editor component used for JComboBox components.
    ComboBoxModel
    A data model for a combo box.
    DesktopManager
    DesktopManager objects are owned by a JDesktopPane object.
    Icon
    A small fixed size picture, typically used to decorate components.
    JButton
    An implementation of a "push" button.
    JColorChooser
    JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComponent
    The base class for all Swing components except top-level containers.
    JDesktopPane
    A container used to create a multiple-document interface or a virtual desktop.
    JFileChooser
    JFileChooser provides a simple mechanism for the user to choose a file.
    JFrame
    An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    JInternalFrame.JDesktopIcon
    This component represents an iconified version of a JInternalFrame.
    JLabel
    A display area for a short text string or an image, or both.
    JList
    A component that displays a list of objects and allows the user to select one or more items.
    JMenu
    An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
    JMenuBar
    An implementation of a menu bar.
    JMenuItem
    An implementation of an item in a menu.
    JOptionPane
    JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
    JPanel
    JPanel is a generic lightweight container.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JProgressBar
    A component that visually displays the progress of some task.
    JRootPane
    A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
    JScrollBar
    An implementation of a scrollbar.
    JScrollPane
    Provides a scrollable view of a lightweight component.
    JSeparator
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
    JSlider
    A component that lets the user graphically select a value by sliding a knob within a bounded interval.
    JSpinner
    A single line input field that lets the user select a number or an object value from an ordered sequence.
    JSplitPane
    JSplitPane is used to divide two (and only two) Components.
    JTabbedPane
    A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
    JTable
    The JTable is used to display and edit regular two-dimensional tables of cells.
    JTextField
    JTextField is a lightweight component that allows the editing of a single line of text.
    JToolBar
    JToolBar provides a component that is useful for displaying commonly used Actions or controls.
    JTree
    A control that displays a set of hierarchical data as an outline.
    JTree.DropLocation
    A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
    KeyStroke
    A KeyStroke represents a key action on the keyboard, or equivalent input device.
    ListCellRenderer
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
    ListModel
    This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list.
    ListSelectionModel
    This interface represents the current state of the selection for any of the components that display a list of values with stable indices.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    MenuElement
    Any component that can be placed into a menu should implement this interface.
    MenuSelectionManager
    A MenuSelectionManager owns the selection in menu hierarchy.
    RootPaneContainer
    This interface is implemented by components that have a single JRootPane child: JDialog, JFrame, JWindow, JApplet, JInternalFrame.
    ScrollPaneConstants
    Constants used with the JScrollPane component.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    Timer
    Fires one or more ActionEvents at specified intervals.
    UIDefaults
    A table of defaults for Swing components.
  • Classes in javax.swing used by javax.swing.plaf.metal
    类与描述
    AbstractAction
    This class provides default implementations for the JFC Action interface.
    AbstractButton
    Defines common behaviors for buttons and menu items.
    AbstractListModel
    The abstract definition for the data model that provides a List with its contents.
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    ActionMap
    ActionMap provides mappings from Objects (called keys or Action names) to Actions.
    CellRendererPane
    This class is inserted in between cell renderers and the components that use them.
    ComboBoxEditor
    The editor component used for JComboBox components.
    ComboBoxModel
    A data model for a combo box.
    DefaultListCellRenderer
    Renders an item in a list.
    Icon
    A small fixed size picture, typically used to decorate components.
    JButton
    An implementation of a "push" button.
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComponent
    The base class for all Swing components except top-level containers.
    JFileChooser
    JFileChooser provides a simple mechanism for the user to choose a file.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    JLabel
    A display area for a short text string or an image, or both.
    JList
    A component that displays a list of objects and allows the user to select one or more items.
    JMenu
    An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
    JPanel
    JPanel is a generic lightweight container.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JScrollPane
    Provides a scrollable view of a lightweight component.
    JSeparator
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
    JSlider
    A component that lets the user graphically select a value by sliding a knob within a bounded interval.
    JToolBar
    JToolBar provides a component that is useful for displaying commonly used Actions or controls.
    LayoutStyle
    LayoutStyle provides information about how to position components.
    ListCellRenderer
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
    ListModel
    This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    MenuElement
    Any component that can be placed into a menu should implement this interface.
    ScrollPaneConstants
    Constants used with the JScrollPane component.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    UIDefaults
    A table of defaults for Swing components.
  • Classes in javax.swing used by javax.swing.plaf.multi
    类与描述
    JComboBox
    A component that combines a button or editable field and a drop-down list.
    JComponent
    The base class for all Swing components except top-level containers.
    JFileChooser
    JFileChooser provides a simple mechanism for the user to choose a file.
    JList
    A component that displays a list of objects and allows the user to select one or more items.
    JOptionPane
    JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
    JPopupMenu
    An implementation of a popup menu -- a small window that pops up and displays a series of choices.
    JSplitPane
    JSplitPane is used to divide two (and only two) Components.
    JTabbedPane
    A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
    JTree
    A control that displays a set of hierarchical data as an outline.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    Popup
    Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy.
    UIDefaults
    A table of defaults for Swing components.
  • Classes in javax.swing used by javax.swing.plaf.nimbus
    类与描述
    Icon
    A small fixed size picture, typically used to decorate components.
    JComponent
    The base class for all Swing components except top-level containers.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    Painter
    A painting delegate.
    UIDefaults
    A table of defaults for Swing components.
  • Classes in javax.swing used by javax.swing.plaf.synth
    类与描述
    AbstractButton
    Defines common behaviors for buttons and menu items.
    ComboBoxEditor
    The editor component used for JComboBox components.
    Icon
    A small fixed size picture, typically used to decorate components.
    JButton
    An implementation of a "push" button.
    JComponent
    The base class for all Swing components except top-level containers.
    JInternalFrame
    A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
    JLabel
    A display area for a short text string or an image, or both.
    JPanel
    JPanel is a generic lightweight container.
    JRootPane
    A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
    JScrollPane
    Provides a scrollable view of a lightweight component.
    JSeparator
    JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
    JSlider
    A component that lets the user graphically select a value by sliding a knob within a bounded interval.
    JSplitPane
    JSplitPane is used to divide two (and only two) Components.
    ListCellRenderer
    Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
    LookAndFeel
    LookAndFeel, as the name implies, encapsulates a look and feel.
    ScrollPaneConstants
    Constants used with the JScrollPane component.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    UIDefaults
    A table of defaults for Swing components.
  • Classes in javax.swing used by javax.swing.table
    类与描述
    CellEditor
    This interface defines the methods any general editor should be able to implement.
    DefaultRowSorter
    An implementation of RowSorter that provides sorting and filtering around a grid-based data model.
    JComponent
    The base class for all Swing components except top-level containers.
    JComponent.AccessibleJComponent
    Inner class of JComponent used to provide default support for accessibility.
    JLabel
    A display area for a short text string or an image, or both.
    JTable
    The JTable is used to display and edit regular two-dimensional tables of cells.
    ListSelectionModel
    This interface represents the current state of the selection for any of the components that display a list of values with stable indices.
    RowSorter
    RowSorter provides the basis for sorting and filtering.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
  • Classes in javax.swing used by javax.swing.text
    类与描述
    AbstractAction
    This class provides default implementations for the JFC Action interface.
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    DropMode
    Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
    Icon
    A small fixed size picture, typically used to decorate components.
    JComponent
    The base class for all Swing components except top-level containers.
    JComponent.AccessibleJComponent
    Inner class of JComponent used to provide default support for accessibility.
    JEditorPane
    A text component to edit various kinds of content.
    JFormattedTextField
    JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
    JFormattedTextField.AbstractFormatter
    Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object.
    JFormattedTextField.AbstractFormatterFactory
    Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values.
    KeyStroke
    A KeyStroke represents a key action on the keyboard, or equivalent input device.
    Scrollable
    An interface that provides information to a scrolling container like JScrollPane.
    SizeRequirements
    For the convenience of layout managers, calculates information about the size and position of components.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    TransferHandler.DropLocation
    Represents a location where dropped data should be inserted.
  • Classes in javax.swing used by javax.swing.text.html
    类与描述
    AbstractAction
    This class provides default implementations for the JFC Action interface.
    Action
    The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
    Icon
    A small fixed size picture, typically used to decorate components.
    JEditorPane
    A text component to edit various kinds of content.
    SizeRequirements
    For the convenience of layout managers, calculates information about the size and position of components.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
  • Classes in javax.swing used by javax.swing.tree
    类与描述
    CellEditor
    This interface defines the methods any general editor should be able to implement.
    DefaultListSelectionModel
    Default data model for list selections.
    Icon
    A small fixed size picture, typically used to decorate components.
    JComponent
    The base class for all Swing components except top-level containers.
    JLabel
    A display area for a short text string or an image, or both.
    JTextField
    JTextField is a lightweight component that allows the editing of a single line of text.
    JTree
    A control that displays a set of hierarchical data as an outline.
    Scrollable
    An interface that provides information to a scrolling container like JScrollPane.
    SwingConstants
    A collection of constants generally used for positioning and orienting components on the screen.
    Timer
    Fires one or more ActionEvents at specified intervals.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


ViewportLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing

类 ViewportLayout

  • java.lang.Object
    • javax.swing.ViewportLayout
  • 所有已实现的接口：
    LayoutManager, Serializable

    public class ViewportLayout
extends Object
implements LayoutManager, Serializable
    The default layout manager for JViewport. ViewportLayout defines a policy for layout that should be useful for most applications. The viewport makes its view the same size as the viewport, however it will not make the view smaller than its minimum size. As the viewport grows the view is kept bottom justified until the entire view is visible, subsequently the view is kept top justified.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ViewportLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String name, Component c)
      Adds the specified component to the layout.
      void layoutContainer(Container parent)
      Called by the AWT when the specified container needs to be laid out.
      Dimension minimumLayoutSize(Container parent)
      Returns the minimum dimensions needed to layout the components contained in the specified target container.
      Dimension preferredLayoutSize(Container parent)
      Returns the preferred dimensions for this layout given the components in the specified target container.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ViewportLayout

        public ViewportLayout()

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component c)
        Adds the specified component to the layout. Not used by this class.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the name of the component
        c - the the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        Removes the specified component from the layout. Not used by this class.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to remove

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        Returns the preferred dimensions for this layout given the components in the specified target container.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the component which needs to be laid out
        返回：
        a Dimension object containing the preferred dimensions
        另请参见：
        minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        Returns the minimum dimensions needed to layout the components contained in the specified target container.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the component which needs to be laid out
        返回：
        a Dimension object containing the minimum dimensions
        另请参见：
        preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container parent)
        Called by the AWT when the specified container needs to be laid out.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to lay out
        抛出：
        AWTError - if the target isn't the container specified to the BoxLayout constructor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r lssaneos/"e u tsI-wlt= bs pice


WindowConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing

Interface WindowConstants

  • All Known Implementing Classes:
    JDialog, JFrame, JInternalFrame

    public interface WindowConstants
    Constants used to control the window-closing operation. The setDefaultCloseOperation and getDefaultCloseOperation methods provided by JFrame, JInternalFrame, and JDialog use these constants. For examples of setting the default window-closing operation, see Responding to Window-Closing Events, a section in The Java Tutorial.
    另请参见：
    JFrame.setDefaultCloseOperation(int),
JDialog.setDefaultCloseOperation(int),
JInternalFrame.setDefaultCloseOperation(int)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DISPOSE_ON_CLOSE
      The dispose-window default window close operation.
      static int DO_NOTHING_ON_CLOSE
      The do-nothing default window close operation.
      static int EXIT_ON_CLOSE
      The exit application default window close operation.
      static int HIDE_ON_CLOSE
      The hide-window default window close operation

    • 字段详细信息

      • DO_NOTHING_ON_CLOSE

        static final int DO_NOTHING_ON_CLOSE
        The do-nothing default window close operation.
        另请参见：
        Constant Field Values

      • HIDE_ON_CLOSE

        static final int HIDE_ON_CLOSE
        The hide-window default window close operation
        另请参见：
        Constant Field Values

      • DISPOSE_ON_CLOSE

        static final int DISPOSE_ON_CLOSE
        The dispose-window default window close operation.

        Note: When the last displayable window within the Java virtual machine (VM) is disposed of, the VM may terminate. See AWT Threading Issues for more information.

        另请参见：
        Window.dispose(), JInternalFrame.dispose(), Constant Field Values

      • EXIT_ON_CLOSE

        static final int EXIT_ON_CLOSE
        The exit application default window close operation. Attempting to set this on Windows that support this, such as JFrame, may throw a SecurityException based on the SecurityManager. It is recommended you only use this in an application.
        从以下版本开始：
        1.4
        另请参见：
        JFrame.setDefaultCloseOperation(int), Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/u#rhn.hnaaanaayafflsysdt> so/a


AbstractBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 AbstractBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BevelBorder, CompoundBorder, EmptyBorder, EtchedBorder, LineBorder, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TableHeaderBorder, MetalBorders.ToolBarBorder, StrokeBorder, TitledBorder

    public abstract class AbstractBorder
extends Object
implements Border, Serializable
    A class that implements an empty border with no size. This provides a convenient base class from which other border classes can be easily derived.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getBaseline(Component c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
      Returns an enum indicating how the baseline of a component changes as the size changes.
      Insets getBorderInsets(Component c)
      This default implementation returns a new Insets object that is initialized by the getBorderInsets(Component,Insets) method.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      static Rectangle getInteriorRectangle(Component c, Border b, int x, int y, int width, int height)
      Returns a rectangle using the arguments minus the insets of the border.
      Rectangle getInteriorRectangle(Component c, int x, int y, int width, int height)
      This convenience method calls the static method.
      boolean isBorderOpaque()
      This default implementation returns false.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractBorder

        public AbstractBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c)
        This default implementation returns a new Insets object that is initialized by the getBorderInsets(Component,Insets) method. By default the top, left, bottom, and right fields are set to 0.
        指定者：
        getBorderInsets in interface Border
        参数：
        c - the component for which this border insets value applies
        返回：
        a new Insets object

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitializes the insets parameter with this Border's current Insets.
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • isBorderOpaque

        public boolean isBorderOpaque()
        This default implementation returns false.
        指定者：
        isBorderOpaque in interface Border
        返回：
        false

      • getInteriorRectangle

        public Rectangle getInteriorRectangle(Component c,
                             int x,
                             int y,
                             int width,
                             int height)
        This convenience method calls the static method.
        参数：
        c - the component for which this border is being computed
        x - the x position of the border
        y - the y position of the border
        width - the width of the border
        height - the height of the border
        返回：
        a Rectangle containing the interior coordinates

      • getInteriorRectangle

        public static Rectangle getInteriorRectangle(Component c,
                             Border b,
                             int x,
                             int y,
                             int width,
                             int height)
        Returns a rectangle using the arguments minus the insets of the border. This is useful for determining the area that components should draw in that will not intersect the border.
        参数：
        c - the component for which this border is being computed
        b - the Border object
        x - the x position of the border
        y - the y position of the border
        width - the width of the border
        height - the height of the border
        返回：
        a Rectangle containing the interior coordinates

      • getBaseline

        public int getBaseline(Component c,
              int width,
              int height)
        Returns the baseline. A return value less than 0 indicates the border does not have a reasonable baseline.

        The default implementation returns -1. Subclasses that support baseline should override appropriately. If a value >= 0 is returned, then the component has a valid baseline for any size >= the minimum size and getBaselineResizeBehavior can be used to determine how the baseline changes with size.

        参数：
        c - Component baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        the baseline or < 0 indicating there is no reasonable baseline
        抛出：
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        Component.getBaseline(int,int), Component.getBaselineResizeBehavior()

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
        Returns an enum indicating how the baseline of a component changes as the size changes. This method is primarily meant for layout managers and GUI builders.

        The default implementation returns BaselineResizeBehavior.OTHER, subclasses that support baseline should override appropriately. Subclasses should never return null; if the baseline can not be calculated return BaselineResizeBehavior.OTHER. Callers should first ask for the baseline using getBaseline and if a value >= 0 is returned use this method. It is acceptable for this method to return a value other than BaselineResizeBehavior.OTHER even if getBaseline returns a value less than 0.

        参数：
        c - Component to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the border is resized
        从以下版本开始：
        1.6
        另请参见：
        Component.getBaseline(int,int), Component.getBaselineResizeBehavior()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

of< oe"±shp黪ep盯�


BevelBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 BevelBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.BevelBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.BevelBorderUIResource, SoftBevelBorder

    public class BevelBorder
extends AbstractBorder
    A class which implements a simple two-line bevel border.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | bevelType
      protected Color | highlightInner
      protected Color | highlightOuter
      static int LOWERED
      Lowered bevel type.
      static int RAISED
      Raised bevel type.
      protected Color | shadowInner
      protected Color | shadowOuter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BevelBorder(int bevelType)
      Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
      BevelBorder(int bevelType, Color highlight, Color shadow)
      Creates a bevel border with the specified type, highlight and shadow colors.
      BevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      Creates a bevel border with the specified type, highlight and shadow colors.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int getBevelType()
      Returns the type of the bevel border.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      Color getHighlightInnerColor()
      Returns the inner highlight color of the bevel border.
      Color getHighlightInnerColor(Component c)
      Returns the inner highlight color of the bevel border when rendered on the specified component.
      Color getHighlightOuterColor()
      Returns the outer highlight color of the bevel border.
      Color getHighlightOuterColor(Component c)
      Returns the outer highlight color of the bevel border when rendered on the specified component.
      Color getShadowInnerColor()
      Returns the inner shadow color of the bevel border.
      Color getShadowInnerColor(Component c)
      Returns the inner shadow color of the bevel border when rendered on the specified component.
      Color getShadowOuterColor()
      Returns the outer shadow color of the bevel border.
      Color getShadowOuterColor(Component c)
      Returns the outer shadow color of the bevel border when rendered on the specified component.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.
      protected void | paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
      protected void | paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • RAISED

        public static final int RAISED
        Raised bevel type.
        另请参见：
        Constant Field Values

      • LOWERED

        public static final int LOWERED
        Lowered bevel type.
        另请参见：
        Constant Field Values

      • bevelType

        protected int bevelType

      • highlightOuter

        protected Color highlightOuter

      • highlightInner

        protected Color highlightInner

      • shadowInner

        protected Color shadowInner

      • shadowOuter

        protected Color shadowOuter

    • 构造方法详细信息

      • BevelBorder

        public BevelBorder(int bevelType)
        Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
        参数：
        bevelType - the type of bevel for the border

      • BevelBorder

        public BevelBorder(int bevelType,
           Color highlight,
           Color shadow)
        Creates a bevel border with the specified type, highlight and shadow colors.
        参数：
        bevelType - the type of bevel for the border
        highlight - the color to use for the bevel highlight
        shadow - the color to use for the bevel shadow

      • BevelBorder

        @ConstructorProperties(value={"bevelType","highlightOuterColor","highlightInnerColor","shadowOuterColor","shadowInnerColor"})
public BevelBorder(int bevelType,
                                      Color highlightOuterColor,
                                      Color highlightInnerColor,
                                      Color shadowOuterColor,
                                      Color shadowInnerColor)
        Creates a bevel border with the specified type, highlight and shadow colors.
        参数：
        bevelType - the type of bevel for the border
        highlightOuterColor - the color to use for the bevel outer highlight
        highlightInnerColor - the color to use for the bevel inner highlight
        shadowOuterColor - the color to use for the bevel outer shadow
        shadowInnerColor - the color to use for the bevel inner shadow

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • getHighlightOuterColor

        public Color getHighlightOuterColor(Component c)
        Returns the outer highlight color of the bevel border when rendered on the specified component. If no highlight color was specified at instantiation, the highlight color is derived from the specified component's background color.
        参数：
        c - the component for which the highlight may be derived
        从以下版本开始：
        1.3

      • getHighlightInnerColor

        public Color getHighlightInnerColor(Component c)
        Returns the inner highlight color of the bevel border when rendered on the specified component. If no highlight color was specified at instantiation, the highlight color is derived from the specified component's background color.
        参数：
        c - the component for which the highlight may be derived
        从以下版本开始：
        1.3

      • getShadowInnerColor

        public Color getShadowInnerColor(Component c)
        Returns the inner shadow color of the bevel border when rendered on the specified component. If no shadow color was specified at instantiation, the shadow color is derived from the specified component's background color.
        参数：
        c - the component for which the shadow may be derived
        从以下版本开始：
        1.3

      • getShadowOuterColor

        public Color getShadowOuterColor(Component c)
        Returns the outer shadow color of the bevel border when rendered on the specified component. If no shadow color was specified at instantiation, the shadow color is derived from the specified component's background color.
        参数：
        c - the component for which the shadow may be derived
        从以下版本开始：
        1.3

      • getHighlightOuterColor

        public Color getHighlightOuterColor()
        Returns the outer highlight color of the bevel border. Will return null if no highlight color was specified at instantiation.
        从以下版本开始：
        1.3

      • getHighlightInnerColor

        public Color getHighlightInnerColor()
        Returns the inner highlight color of the bevel border. Will return null if no highlight color was specified at instantiation.
        从以下版本开始：
        1.3

      • getShadowInnerColor

        public Color getShadowInnerColor()
        Returns the inner shadow color of the bevel border. Will return null if no shadow color was specified at instantiation.
        从以下版本开始：
        1.3

      • getShadowOuterColor

        public Color getShadowOuterColor()
        Returns the outer shadow color of the bevel border. Will return null if no shadow color was specified at instantiation.
        从以下版本开始：
        1.3

      • getBevelType

        public int getBevelType()
        Returns the type of the bevel border.

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        false

      • paintRaisedBevel

        protected void paintRaisedBevel(Component c,
                    Graphics g,
                    int x,
                    int y,
                    int width,
                    int height)

      • paintLoweredBevel

        protected void paintLoweredBevel(Component c,
                     Graphics g,
                     int x,
                     int y,
                     int width,
                     int height)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Border

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.border

Interface Border

  • All Known Implementing Classes:
    AbstractBorder, BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.SplitPaneBorder, BasicBorders.ToggleButtonBorder, BevelBorder, BorderUIResource, BorderUIResource.BevelBorderUIResource, BorderUIResource.CompoundBorderUIResource, BorderUIResource.EmptyBorderUIResource, BorderUIResource.EtchedBorderUIResource, BorderUIResource.LineBorderUIResource, BorderUIResource.MatteBorderUIResource, BorderUIResource.TitledBorderUIResource, CompoundBorder, EmptyBorder, EtchedBorder, LineBorder, MatteBorder, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.RolloverButtonBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TableHeaderBorder, MetalBorders.TextFieldBorder, MetalBorders.ToggleButtonBorder, MetalBorders.ToolBarBorder, SoftBevelBorder, StrokeBorder, TitledBorder

    public interface Border
    Interface describing an object capable of rendering a border around the edges of a swing component. For examples of using borders see How to Use Borders, a section in The Java Tutorial.

    In the Swing component set, borders supercede Insets as the mechanism for creating a (decorated or plain) area around the edge of a component.

    Usage Notes:

    • Use EmptyBorder to create a plain border (this mechanism replaces its predecessor, setInsets).
    • Use CompoundBorder to nest multiple border objects, creating a single, combined border.
    • Border instances are designed to be shared. Rather than creating a new border object using one of border classes, use the BorderFactory methods, which produces a shared instance of the common border types.
    • Additional border styles include BevelBorder, SoftBevelBorder, EtchedBorder, LineBorder, TitledBorder, and MatteBorder.
    • To create a new border class, subclass AbstractBorder.
    另请参见：
    BorderFactory, EmptyBorder, CompoundBorder

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c)
      Returns the insets of the border.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

    • 方法详细信息

      • paintBorder

        void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        Insets getBorderInsets(Component c)
        Returns the insets of the border.
        参数：
        c - the component for which this border insets value applies

      • isBorderOpaque

        boolean isBorderOpaque()
        Returns whether or not the border is opaque. If the border is opaque, it is responsible for filling in it's own background when painting.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r sit nt ,ss a j.Gswwj


CompoundBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 CompoundBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.CompoundBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.CompoundBorderUIResource

    public class CompoundBorder
extends AbstractBorder
    A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object. For example, this class may be used to add blank margin space to a component with an existing decorative border:

        Border border = comp.getBorder();
    Border margin = new EmptyBorder(10,10,10,10);
    comp.setBorder(new CompoundBorder(border, margin));

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Border | insideBorder
      protected Border | outsideBorder

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompoundBorder()
      Creates a compound border with null outside and inside borders.
      CompoundBorder(Border outsideBorder, Border insideBorder)
      Creates a compound border with the specified outside and inside borders.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      Border getInsideBorder()
      Returns the inside border object.
      Border getOutsideBorder()
      Returns the outside border object.
      boolean isBorderOpaque()
      Returns whether or not the compound border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the compound border by painting the outside border with the specified position and size and then painting the inside border at the specified position and size offset by the insets of the outside border.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • outsideBorder

        protected Border outsideBorder

      • insideBorder

        protected Border insideBorder

    • 构造方法详细信息

      • CompoundBorder

        public CompoundBorder()
        Creates a compound border with null outside and inside borders.

      • CompoundBorder

        @ConstructorProperties(value={"outsideBorder","insideBorder"})
public CompoundBorder(Border outsideBorder,
                                         Border insideBorder)
        Creates a compound border with the specified outside and inside borders. Either border may be null.
        参数：
        outsideBorder - the outside border
        insideBorder - the inside border to be nested

    • 方法详细信息

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the compound border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        true if the inside and outside borders are each either null or opaque; or false otherwise

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the compound border by painting the outside border with the specified position and size and then painting the inside border at the specified position and size offset by the insets of the outside border.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • getOutsideBorder

        public Border getOutsideBorder()
        Returns the outside border object.

      • getInsideBorder

        public Border getInsideBorder()
        Returns the inside border object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne oh琧l =aote adsLc>>


EmptyBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 EmptyBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EmptyBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.EmptyBorderUIResource, MatteBorder

    public class EmptyBorder
extends AbstractBorder
implements Serializable
    A class which provides an empty, transparent border which takes up space but does no drawing.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | bottom
      protected int | left
      protected int | right
      protected int | top

    • 构造方法摘要

      Constructors
      构造方法与描述
      EmptyBorder(Insets borderInsets)
      Creates an empty border with the specified insets.
      EmptyBorder(int top, int left, int bottom, int right)
      Creates an empty border with the specified insets.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets()
      Returns the insets of the border.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Does no drawing by default.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • left

        protected int left

      • right

        protected int right

      • top

        protected int top

      • bottom

        protected int bottom

    • 构造方法详细信息

      • EmptyBorder

        public EmptyBorder(int top,
           int left,
           int bottom,
           int right)
        Creates an empty border with the specified insets.
        参数：
        top - the top inset of the border
        left - the left inset of the border
        bottom - the bottom inset of the border
        right - the right inset of the border

      • EmptyBorder

        @ConstructorProperties(value="borderInsets")
public EmptyBorder(Insets borderInsets)
        Creates an empty border with the specified insets.
        参数：
        borderInsets - the insets of the border

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Does no drawing by default.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • getBorderInsets

        public Insets getBorderInsets()
        Returns the insets of the border.
        从以下版本开始：
        1.3

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque. Returns false by default.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iustitstdtsl.dil.naamukg ..mneeydBlyleBBsaynainl


EtchedBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 EtchedBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EtchedBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.EtchedBorderUIResource

    public class EtchedBorder
extends AbstractBorder
    A class which implements a simple etched border which can either be etched-in or etched-out. If no highlight/shadow colors are initialized when the border is created, then these colors will be dynamically derived from the background color of the component argument passed into the paintBorder() method.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | etchType
      protected Color | highlight
      static int LOWERED
      Lowered etched type.
      static int RAISED
      Raised etched type.
      protected Color | shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      EtchedBorder()
      Creates a lowered etched border whose colors will be derived from the background color of the component passed into the paintBorder method.
      EtchedBorder(Color highlight, Color shadow)
      Creates a lowered etched border with the specified highlight and shadow colors.
      EtchedBorder(int etchType)
      Creates an etched border with the specified etch-type whose colors will be derived from the background color of the component passed into the paintBorder method.
      EtchedBorder(int etchType, Color highlight, Color shadow)
      Creates an etched border with the specified etch-type, highlight and shadow colors.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      int getEtchType()
      Returns which etch-type is set on the etched border.
      Color getHighlightColor()
      Returns the highlight color of the etched border.
      Color getHighlightColor(Component c)
      Returns the highlight color of the etched border when rendered on the specified component.
      Color getShadowColor()
      Returns the shadow color of the etched border.
      Color getShadowColor(Component c)
      Returns the shadow color of the etched border when rendered on the specified component.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • RAISED

        public static final int RAISED
        Raised etched type.
        另请参见：
        Constant Field Values

      • LOWERED

        public static final int LOWERED
        Lowered etched type.
        另请参见：
        Constant Field Values

      • etchType

        protected int etchType

      • highlight

        protected Color highlight

      • shadow

        protected Color shadow

    • 构造方法详细信息

      • EtchedBorder

        public EtchedBorder()
        Creates a lowered etched border whose colors will be derived from the background color of the component passed into the paintBorder method.

      • EtchedBorder

        public EtchedBorder(int etchType)
        Creates an etched border with the specified etch-type whose colors will be derived from the background color of the component passed into the paintBorder method.
        参数：
        etchType - the type of etch to be drawn by the border

      • EtchedBorder

        public EtchedBorder(Color highlight,
            Color shadow)
        Creates a lowered etched border with the specified highlight and shadow colors.
        参数：
        highlight - the color to use for the etched highlight
        shadow - the color to use for the etched shadow

      • EtchedBorder

        @ConstructorProperties(value={"etchType","highlightColor","shadowColor"})
public EtchedBorder(int etchType,
                                       Color highlight,
                                       Color shadow)
        Creates an etched border with the specified etch-type, highlight and shadow colors.
        参数：
        etchType - the type of etch to be drawn by the border
        highlight - the color to use for the etched highlight
        shadow - the color to use for the etched shadow

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        false

      • getEtchType

        public int getEtchType()
        Returns which etch-type is set on the etched border.

      • getHighlightColor

        public Color getHighlightColor(Component c)
        Returns the highlight color of the etched border when rendered on the specified component. If no highlight color was specified at instantiation, the highlight color is derived from the specified component's background color.
        参数：
        c - the component for which the highlight may be derived
        从以下版本开始：
        1.3

      • getHighlightColor

        public Color getHighlightColor()
        Returns the highlight color of the etched border. Will return null if no highlight color was specified at instantiation.
        从以下版本开始：
        1.3

      • getShadowColor

        public Color getShadowColor(Component c)
        Returns the shadow color of the etched border when rendered on the specified component. If no shadow color was specified at instantiation, the shadow color is derived from the specified component's background color.
        参数：
        c - the component for which the shadow may be derived
        从以下版本开始：
        1.3

      • getShadowColor

        public Color getShadowColor()
        Returns the shadow color of the etched border. Will return null if no shadow color was specified at instantiation.
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


javax.swing.border

Interfaces

  • Border

Classes

  • AbstractBorder
  • BevelBorder
  • CompoundBorder
  • EmptyBorder
  • EtchedBorder
  • LineBorder
  • MatteBorder
  • SoftBevelBorder
  • StrokeBorder
  • TitledBorder
/


javax.swing.border

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.border

Provides classes and interface for drawing specialized borders around a Swing component.

请参见： 描述

  • 接口摘要
    接口 描述
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
  • Class Summary
    类 描述
    AbstractBorder
    A class that implements an empty border with no size.
    BevelBorder
    A class which implements a simple two-line bevel border.
    CompoundBorder
    A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
    EmptyBorder
    A class which provides an empty, transparent border which takes up space but does no drawing.
    EtchedBorder
    A class which implements a simple etched border which can either be etched-in or etched-out.
    LineBorder
    A class which implements a line border of arbitrary thickness and of a single color.
    MatteBorder
    A class which provides a matte-like border of either a solid color or a tiled icon.
    SoftBevelBorder
    A class which implements a raised or lowered bevel with softened corners.
    StrokeBorder
    A class which implements a border of an arbitrary stroke.
    TitledBorder
    A class which implements an arbitrary border with the addition of a String title in a specified position and justification.

软件包 javax.swing.border Description

Provides classes and interface for drawing specialized borders around a Swing component. You can subclass these classes to create customized borders for your components instead of using the default borders provided by the look-and-feel being used.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use Borders, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


javax.swing.border Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.border

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.border.BevelBorder
        • javax.swing.border.SoftBevelBorder
      • javax.swing.border.CompoundBorder
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.border.MatteBorder
      • javax.swing.border.EtchedBorder
      • javax.swing.border.LineBorder
      • javax.swing.border.StrokeBorder
      • javax.swing.border.TitledBorder

Interface Hierarchy

  • javax.swing.border.Border
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mo>t,sa/>>>n ttapsss


LineBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 LineBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.LineBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.LineBorderUIResource

    public class LineBorder
extends AbstractBorder
    A class which implements a line border of arbitrary thickness and of a single color.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | lineColor
      protected boolean | roundedCorners
      protected int | thickness

    • 构造方法摘要

      Constructors
      构造方法与描述
      LineBorder(Color color)
      Creates a line border with the specified color and a thickness = 1.
      LineBorder(Color color, int thickness)
      Creates a line border with the specified color and thickness.
      LineBorder(Color color, int thickness, boolean roundedCorners)
      Creates a line border with the specified color, thickness, and corner shape.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Border createBlackLineBorder()
      Convenience method for getting the Color.black LineBorder of thickness 1.
      static Border createGrayLineBorder()
      Convenience method for getting the Color.gray LineBorder of thickness 1.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      Color getLineColor()
      Returns the color of the border.
      boolean getRoundedCorners()
      Returns whether this border will be drawn with rounded corners.
      int getThickness()
      Returns the thickness of the border.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • thickness

        protected int thickness

      • lineColor

        protected Color lineColor

      • roundedCorners

        protected boolean roundedCorners

    • 构造方法详细信息

      • LineBorder

        public LineBorder(Color color)
        Creates a line border with the specified color and a thickness = 1.
        参数：
        color - the color for the border

      • LineBorder

        public LineBorder(Color color,
          int thickness)
        Creates a line border with the specified color and thickness.
        参数：
        color - the color of the border
        thickness - the thickness of the border

      • LineBorder

        @ConstructorProperties(value={"lineColor","thickness","roundedCorners"})
public LineBorder(Color color,
                                     int thickness,
                                     boolean roundedCorners)
        Creates a line border with the specified color, thickness, and corner shape.
        参数：
        color - the color of the border
        thickness - the thickness of the border
        roundedCorners - whether or not border corners should be round
        从以下版本开始：
        1.3

    • 方法详细信息

      • createBlackLineBorder

        public static Border createBlackLineBorder()
        Convenience method for getting the Color.black LineBorder of thickness 1.

      • createGrayLineBorder

        public static Border createGrayLineBorder()
        Convenience method for getting the Color.gray LineBorder of thickness 1.

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • getLineColor

        public Color getLineColor()
        Returns the color of the border.

      • getThickness

        public int getThickness()
        Returns the thickness of the border.

      • getRoundedCorners

        public boolean getRoundedCorners()
        Returns whether this border will be drawn with rounded corners.
        从以下版本开始：
        1.3

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jea"ttmitmtllmttet..mtCiottcates ajsa"aap>.lrht.


MatteBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 MatteBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EmptyBorder
        • javax.swing.border.MatteBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.MatteBorderUIResource

    public class MatteBorder
extends EmptyBorder
    A class which provides a matte-like border of either a solid color or a tiled icon.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | color
      protected Icon | tileIcon

      • Fields inherited from class javax.swing.border.EmptyBorder

        bottom, left, right, top

    • 构造方法摘要

      Constructors
      构造方法与描述
      MatteBorder(Icon tileIcon)
      Creates a matte border with the specified tile icon.
      MatteBorder(Insets borderInsets, Color matteColor)
      Creates a matte border with the specified insets and color.
      MatteBorder(Insets borderInsets, Icon tileIcon)
      Creates a matte border with the specified insets and tile icon.
      MatteBorder(int top, int left, int bottom, int right, Color matteColor)
      Creates a matte border with the specified insets and color.
      MatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
      Creates a matte border with the specified insets and tile icon.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets()
      Returns the insets of the border.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      Color getMatteColor()
      Returns the color used for tiling the border or null if a tile icon is being used.
      Icon getTileIcon()
      Returns the icon used for tiling the border or null if a solid color is being used.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the matte border.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • color

        protected Color color

      • tileIcon

        protected Icon tileIcon

    • 构造方法详细信息

      • MatteBorder

        public MatteBorder(int top,
           int left,
           int bottom,
           int right,
           Color matteColor)
        Creates a matte border with the specified insets and color.
        参数：
        top - the top inset of the border
        left - the left inset of the border
        bottom - the bottom inset of the border
        right - the right inset of the border
        matteColor - the color rendered for the border

      • MatteBorder

        public MatteBorder(Insets borderInsets,
           Color matteColor)
        Creates a matte border with the specified insets and color.
        参数：
        borderInsets - the insets of the border
        matteColor - the color rendered for the border
        从以下版本开始：
        1.3

      • MatteBorder

        public MatteBorder(int top,
           int left,
           int bottom,
           int right,
           Icon tileIcon)
        Creates a matte border with the specified insets and tile icon.
        参数：
        top - the top inset of the border
        left - the left inset of the border
        bottom - the bottom inset of the border
        right - the right inset of the border
        tileIcon - the icon to be used for tiling the border

      • MatteBorder

        public MatteBorder(Insets borderInsets,
           Icon tileIcon)
        Creates a matte border with the specified insets and tile icon.
        参数：
        borderInsets - the insets of the border
        tileIcon - the icon to be used for tiling the border
        从以下版本开始：
        1.3

      • MatteBorder

        public MatteBorder(Icon tileIcon)
        Creates a matte border with the specified tile icon. The insets will be calculated dynamically based on the size of the tile icon, where the top and bottom will be equal to the tile icon's height, and the left and right will be equal to the tile icon's width.
        参数：
        tileIcon - the icon to be used for tiling the border

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the matte border.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class EmptyBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class EmptyBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
        从以下版本开始：
        1.3

      • getBorderInsets

        public Insets getBorderInsets()
        Returns the insets of the border.
        重载：
        getBorderInsets in class EmptyBorder
        从以下版本开始：
        1.3

      • getMatteColor

        public Color getMatteColor()
        Returns the color used for tiling the border or null if a tile icon is being used.
        从以下版本开始：
        1.3

      • getTileIcon

        public Icon getTileIcon()
        Returns the icon used for tiling the border or null if a solid color is being used.
        从以下版本开始：
        1.3

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class EmptyBorder
        返回：
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olboioioSobdr/ur>xee富=/ <\a ><>aa=>lsnv


SoftBevelBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 SoftBevelBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.BevelBorder
        • javax.swing.border.SoftBevelBorder
  • 所有已实现的接口：
    Serializable, Border

    public class SoftBevelBorder
extends BevelBorder
    A class which implements a raised or lowered bevel with softened corners.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.border.BevelBorder

        bevelType, highlightInner, highlightOuter, LOWERED, RAISED, shadowInner, shadowOuter

    • 构造方法摘要

      Constructors
      构造方法与描述
      SoftBevelBorder(int bevelType)
      Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
      SoftBevelBorder(int bevelType, Color highlight, Color shadow)
      Creates a bevel border with the specified type, highlight and shadow colors.
      SoftBevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
      Creates a bevel border with the specified type, highlight shadow colors.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 javax.swing.border.BevelBorder

        getBevelType, getHighlightInnerColor, getHighlightInnerColor, getHighlightOuterColor, getHighlightOuterColor, getShadowInnerColor, getShadowInnerColor, getShadowOuterColor, getShadowOuterColor, paintLoweredBevel, paintRaisedBevel

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SoftBevelBorder

        public SoftBevelBorder(int bevelType)
        Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
        参数：
        bevelType - the type of bevel for the border

      • SoftBevelBorder

        public SoftBevelBorder(int bevelType,
               Color highlight,
               Color shadow)
        Creates a bevel border with the specified type, highlight and shadow colors.
        参数：
        bevelType - the type of bevel for the border
        highlight - the color to use for the bevel highlight
        shadow - the color to use for the bevel shadow

      • SoftBevelBorder

        @ConstructorProperties(value={"bevelType","highlightOuterColor","highlightInnerColor","shadowOuterColor","shadowInnerColor"})
public SoftBevelBorder(int bevelType,
                                          Color highlightOuterColor,
                                          Color highlightInnerColor,
                                          Color shadowOuterColor,
                                          Color shadowInnerColor)
        Creates a bevel border with the specified type, highlight shadow colors.
        参数：
        bevelType - the type of bevel for the border
        highlightOuterColor - the color to use for the bevel outer highlight
        highlightInnerColor - the color to use for the bevel inner highlight
        shadowOuterColor - the color to use for the bevel outer shadow
        shadowInnerColor - the color to use for the bevel inner shadow

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class BevelBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class BevelBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class BevelBorder
        返回：
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>cs"u="c llc > eeS>|/Se::>t ./ull<<(al�>ad


StrokeBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 StrokeBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.StrokeBorder
  • 所有已实现的接口：
    Serializable, Border

    public class StrokeBorder
extends AbstractBorder
    A class which implements a border of an arbitrary stroke.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeans™ has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.7

    • 构造方法摘要

      Constructors
      构造方法与描述
      StrokeBorder(BasicStroke stroke)
      Creates a border of the specified stroke.
      StrokeBorder(BasicStroke stroke, Paint paint)
      Creates a border of the specified stroke and paint.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this border's current insets.
      Paint getPaint()
      Returns the Paint object used to generate a color during the border rendering.
      BasicStroke getStroke()
      Returns the BasicStroke object used to stroke a shape during the border rendering.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StrokeBorder

        public StrokeBorder(BasicStroke stroke)
        Creates a border of the specified stroke. The component's foreground color will be used to render the border.
        参数：
        stroke - the BasicStroke object used to stroke a shape
        抛出：
        NullPointerException - if the specified stroke is null

      • StrokeBorder

        @ConstructorProperties(value={"stroke","paint"})
public StrokeBorder(BasicStroke stroke,
                                       Paint paint)
        Creates a border of the specified stroke and paint. If the specified paint is null, the component's foreground color will be used to render the border.
        参数：
        stroke - the BasicStroke object used to stroke a shape
        paint - the Paint object used to generate a color
        抛出：
        NullPointerException - if the specified stroke is null

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size. If the border was not specified with a Paint object, the component's foreground color will be used to render the border. If the component's foreground color is not available, the default color of the Graphics object will be used.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border
        抛出：
        NullPointerException - if the specified g is null

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitializes the insets parameter with this border's current insets. Every inset is the smallest (closest to negative infinity) integer value that is greater than or equal to the line width of the stroke that is used to paint the border.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the Insets object to be reinitialized
        返回：
        the reinitialized insets parameter
        抛出：
        NullPointerException - if the specified insets is null
        另请参见：
        Math.ceil(double)

      • getStroke

        public BasicStroke getStroke()
        Returns the BasicStroke object used to stroke a shape during the border rendering.
        返回：
        the BasicStroke object

      • getPaint

        public Paint getPaint()
        Returns the Paint object used to generate a color during the border rendering.
        返回：
        the Paint object or null if the paint parameter is not set
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

txihrhBh h.mmthhr/ssv> /iddsidualv NN>""ls


TitledBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.border

类 TitledBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.TitledBorder
  • 所有已实现的接口：
    Serializable, Border
    直接已知子类：
    BorderUIResource.TitledBorderUIResource

    public class TitledBorder
extends AbstractBorder
    A class which implements an arbitrary border with the addition of a String title in a specified position and justification.

    If the border, font, or color property values are not specified in the constuctor or by invoking the appropriate set methods, the property values will be defined by the current look and feel, using the following property names in the Defaults Table:

    • "TitledBorder.border"
    • "TitledBorder.font"
    • "TitledBorder.titleColor"

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int ABOVE_BOTTOM
      Position the title above the border's bottom line.
      static int ABOVE_TOP
      Position the title above the border's top line.
      static int BELOW_BOTTOM
      Position the title below the border's bottom line.
      static int BELOW_TOP
      Position the title below the border's top line.
      protected Border | border
      static int BOTTOM
      Position the title in the middle of the border's bottom line.
      static int CENTER
      Position title text in the center of the border line.
      static int DEFAULT_JUSTIFICATION
      Use the default justification for the title text.
      static int DEFAULT_POSITION
      Use the default vertical orientation for the title text.
      protected static int | EDGE_SPACING
      static int LEADING
      Position title text at the left side of the border line for left to right orientation, at the right side of the border line for right to left orientation.
      static int LEFT
      Position title text at the left side of the border line.
      static int RIGHT
      Position title text at the right side of the border line.
      protected static int | TEXT_INSET_H
      protected static int | TEXT_SPACING
      protected String | title
      protected Color | titleColor
      protected Font | titleFont
      protected int | titleJustification
      protected int | titlePosition
      static int TOP
      Position the title in the middle of the border's top line.
      static int TRAILING
      Position title text at the right side of the border line for left to right orientation, at the left side of the border line for right to left orientation.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TitledBorder(Border border)
      Creates a TitledBorder instance with the specified border and an empty title.
      TitledBorder(Border border, String title)
      Creates a TitledBorder instance with the specified border and title.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition)
      Creates a TitledBorder instance with the specified border, title, title-justification, and title-position.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      Creates a TitledBorder instance with the specified border, title, title-justification, title-position, and title-font.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      Creates a TitledBorder instance with the specified border, title, title-justification, title-position, title-font, and title-color.
      TitledBorder(String title)
      Creates a TitledBorder instance.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int getBaseline(Component c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
      Returns an enum indicating how the baseline of the border changes as the size changes.
      Border getBorder()
      Returns the border of the titled border.
      Insets getBorderInsets(Component c, Insets insets)
      Reinitialize the insets parameter with this Border's current Insets.
      protected Font | getFont(Component c)
      Dimension getMinimumSize(Component c)
      Returns the minimum dimensions this border requires in order to fully display the border and title.
      String getTitle()
      Returns the title of the titled border.
      Color getTitleColor()
      Returns the title-color of the titled border.
      Font getTitleFont()
      Returns the title-font of the titled border.
      int getTitleJustification()
      Returns the title-justification of the titled border.
      int getTitlePosition()
      Returns the title-position of the titled border.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.
      void setBorder(Border border)
      Sets the border of the titled border.
      void setTitle(String title)
      Sets the title of the titled border.
      void setTitleColor(Color titleColor)
      Sets the title-color of the titled border.
      void setTitleFont(Font titleFont)
      Sets the title-font of the titled border.
      void setTitleJustification(int titleJustification)
      Sets the title-justification of the titled border.
      void setTitlePosition(int titlePosition)
      Sets the title-position of the titled border.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • title

        protected String title

      • border

        protected Border border

      • titlePosition

        protected int titlePosition

      • titleJustification

        protected int titleJustification

      • titleFont

        protected Font titleFont

      • titleColor

        protected Color titleColor

      • DEFAULT_POSITION

        public static final int DEFAULT_POSITION
        Use the default vertical orientation for the title text.
        另请参见：
        Constant Field Values

      • ABOVE_TOP

        public static final int ABOVE_TOP
        Position the title above the border's top line.
        另请参见：
        Constant Field Values

      • TOP

        public static final int TOP
        Position the title in the middle of the border's top line.
        另请参见：
        Constant Field Values

      • BELOW_TOP

        public static final int BELOW_TOP
        Position the title below the border's top line.
        另请参见：
        Constant Field Values

      • ABOVE_BOTTOM

        public static final int ABOVE_BOTTOM
        Position the title above the border's bottom line.
        另请参见：
        Constant Field Values

      • BOTTOM

        public static final int BOTTOM
        Position the title in the middle of the border's bottom line.
        另请参见：
        Constant Field Values

      • BELOW_BOTTOM

        public static final int BELOW_BOTTOM
        Position the title below the border's bottom line.
        另请参见：
        Constant Field Values

      • DEFAULT_JUSTIFICATION

        public static final int DEFAULT_JUSTIFICATION
        Use the default justification for the title text.
        另请参见：
        Constant Field Values

      • LEFT

        public static final int LEFT
        Position title text at the left side of the border line.
        另请参见：
        Constant Field Values

      • CENTER

        public static final int CENTER
        Position title text in the center of the border line.
        另请参见：
        Constant Field Values

      • RIGHT

        public static final int RIGHT
        Position title text at the right side of the border line.
        另请参见：
        Constant Field Values

      • LEADING

        public static final int LEADING
        Position title text at the left side of the border line for left to right orientation, at the right side of the border line for right to left orientation.
        另请参见：
        Constant Field Values

      • TRAILING

        public static final int TRAILING
        Position title text at the right side of the border line for left to right orientation, at the left side of the border line for right to left orientation.
        另请参见：
        Constant Field Values

      • EDGE_SPACING

        protected static final int EDGE_SPACING
        另请参见：
        Constant Field Values

      • TEXT_SPACING

        protected static final int TEXT_SPACING
        另请参见：
        Constant Field Values

      • TEXT_INSET_H

        protected static final int TEXT_INSET_H
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TitledBorder

        public TitledBorder(String title)
        Creates a TitledBorder instance.
        参数：
        title - the title the border should display

      • TitledBorder

        public TitledBorder(Border border)
        Creates a TitledBorder instance with the specified border and an empty title.
        参数：
        border - the border

      • TitledBorder

        public TitledBorder(Border border,
            String title)
        Creates a TitledBorder instance with the specified border and title.
        参数：
        border - the border
        title - the title the border should display

      • TitledBorder

        public TitledBorder(Border border,
            String title,
            int titleJustification,
            int titlePosition)
        Creates a TitledBorder instance with the specified border, title, title-justification, and title-position.
        参数：
        border - the border
        title - the title the border should display
        titleJustification - the justification for the title
        titlePosition - the position for the title

      • TitledBorder

        public TitledBorder(Border border,
            String title,
            int titleJustification,
            int titlePosition,
            Font titleFont)
        Creates a TitledBorder instance with the specified border, title, title-justification, title-position, and title-font.
        参数：
        border - the border
        title - the title the border should display
        titleJustification - the justification for the title
        titlePosition - the position for the title
        titleFont - the font for rendering the title

      • TitledBorder

        @ConstructorProperties(value={"border","title","titleJustification","titlePosition","titleFont","titleColor"})
public TitledBorder(Border border,
                                       String title,
                                       int titleJustification,
                                       int titlePosition,
                                       Font titleFont,
                                       Color titleColor)
        Creates a TitledBorder instance with the specified border, title, title-justification, title-position, title-font, and title-color.
        参数：
        border - the border
        title - the title the border should display
        titleJustification - the justification for the title
        titlePosition - the position for the title
        titleFont - the font of the title
        titleColor - the color of the title

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Reinitialize the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object

      • isBorderOpaque

        public boolean isBorderOpaque()
        Returns whether or not the border is opaque.
        指定者：
        isBorderOpaque in interface Border
        重载：
        isBorderOpaque in class AbstractBorder
        返回：
        false

      • getTitle

        public String getTitle()
        Returns the title of the titled border.
        返回：
        the title of the titled border

      • getBorder

        public Border getBorder()
        Returns the border of the titled border.
        返回：
        the border of the titled border

      • getTitlePosition

        public int getTitlePosition()
        Returns the title-position of the titled border.
        返回：
        the title-position of the titled border

      • getTitleJustification

        public int getTitleJustification()
        Returns the title-justification of the titled border.
        返回：
        the title-justification of the titled border

      • getTitleFont

        public Font getTitleFont()
        Returns the title-font of the titled border.
        返回：
        the title-font of the titled border

      • getTitleColor

        public Color getTitleColor()
        Returns the title-color of the titled border.
        返回：
        the title-color of the titled border

      • setTitle

        public void setTitle(String title)
        Sets the title of the titled border.
        参数：
        title - the title for the border

      • setBorder

        public void setBorder(Border border)
        Sets the border of the titled border.
        参数：
        border - the border

      • setTitlePosition

        public void setTitlePosition(int titlePosition)
        Sets the title-position of the titled border.
        参数：
        titlePosition - the position for the border

      • setTitleJustification

        public void setTitleJustification(int titleJustification)
        Sets the title-justification of the titled border.
        参数：
        titleJustification - the justification for the border

      • setTitleFont

        public void setTitleFont(Font titleFont)
        Sets the title-font of the titled border.
        参数：
        titleFont - the font for the border title

      • setTitleColor

        public void setTitleColor(Color titleColor)
        Sets the title-color of the titled border.
        参数：
        titleColor - the color for the border title

      • getMinimumSize

        public Dimension getMinimumSize(Component c)
        Returns the minimum dimensions this border requires in order to fully display the border and title.
        参数：
        c - the component where this border will be drawn
        返回：
        the Dimension object

      • getBaseline

        public int getBaseline(Component c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class AbstractBorder
        参数：
        c - Component baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        the baseline or < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
        Returns an enum indicating how the baseline of the border changes as the size changes.
        重载：
        getBaselineResizeBehavior in class AbstractBorder
        参数：
        c - Component to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the border is resized
        抛出：
        NullPointerException
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getFont

        protected Font getFont(Component c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.swing.border

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.border

  • Packages that use javax.swing.border
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
  • Classes in javax.swing.border used by javax.swing
    类与描述
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
    CompoundBorder
    A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
    MatteBorder
    A class which provides a matte-like border of either a solid color or a tiled icon.
    TitledBorder
    A class which implements an arbitrary border with the addition of a String title in a specified position and justification.
  • Classes in javax.swing.border used by javax.swing.border
    类与描述
    AbstractBorder
    A class that implements an empty border with no size.
    BevelBorder
    A class which implements a simple two-line bevel border.
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
    EmptyBorder
    A class which provides an empty, transparent border which takes up space but does no drawing.
  • Classes in javax.swing.border used by javax.swing.plaf
    类与描述
    AbstractBorder
    A class that implements an empty border with no size.
    BevelBorder
    A class which implements a simple two-line bevel border.
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
    CompoundBorder
    A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
    EmptyBorder
    A class which provides an empty, transparent border which takes up space but does no drawing.
    EtchedBorder
    A class which implements a simple etched border which can either be etched-in or etched-out.
    LineBorder
    A class which implements a line border of arbitrary thickness and of a single color.
    MatteBorder
    A class which provides a matte-like border of either a solid color or a tiled icon.
    TitledBorder
    A class which implements an arbitrary border with the addition of a String title in a specified position and justification.
  • Classes in javax.swing.border used by javax.swing.plaf.basic
    类与描述
    AbstractBorder
    A class that implements an empty border with no size.
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
  • Classes in javax.swing.border used by javax.swing.plaf.metal
    类与描述
    AbstractBorder
    A class that implements an empty border with no size.
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
  • Classes in javax.swing.border used by javax.swing.table
    类与描述
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
  • Classes in javax.swing.border used by javax.swing.tree
    类与描述
    Border
    Interface describing an object capable of rendering a border around the edges of a swing component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itn />/d<


Uses of Class javax.swing.border.AbstractBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.AbstractBorder

  • Packages that use AbstractBorder
    软件包 描述
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of AbstractBorder in javax.swing.border

      Subclasses of AbstractBorder in javax.swing.border
      修饰符与类型 类与描述
      class  BevelBorder
      A class which implements a simple two-line bevel border.
      class  CompoundBorder
      A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
      class  EmptyBorder
      A class which provides an empty, transparent border which takes up space but does no drawing.
      class  EtchedBorder
      A class which implements a simple etched border which can either be etched-in or etched-out.
      class  LineBorder
      A class which implements a line border of arbitrary thickness and of a single color.
      class  MatteBorder
      A class which provides a matte-like border of either a solid color or a tiled icon.
      class  SoftBevelBorder
      A class which implements a raised or lowered bevel with softened corners.
      class  StrokeBorder
      A class which implements a border of an arbitrary stroke.
      class  TitledBorder
      A class which implements an arbitrary border with the addition of a String title in a specified position and justification.

    • Uses of AbstractBorder in javax.swing.plaf

      Subclasses of AbstractBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.BevelBorderUIResource
      static class  | BorderUIResource.CompoundBorderUIResource
      static class  | BorderUIResource.EmptyBorderUIResource
      static class  | BorderUIResource.EtchedBorderUIResource
      static class  | BorderUIResource.LineBorderUIResource
      static class  | BorderUIResource.MatteBorderUIResource
      static class  | BorderUIResource.TitledBorderUIResource

    • Uses of AbstractBorder in javax.swing.plaf.basic

      Subclasses of AbstractBorder in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      static class  | BasicBorders.ButtonBorder
      static class  | BasicBorders.FieldBorder
      static class  | BasicBorders.MarginBorder
      static class  | BasicBorders.MenuBarBorder
      static class  | BasicBorders.RadioButtonBorder
      static class  BasicBorders.RolloverButtonBorder
      Special thin border for rollover toolbar buttons.
      static class  | BasicBorders.ToggleButtonBorder

    • Uses of AbstractBorder in javax.swing.plaf.metal

      Subclasses of AbstractBorder in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      static class  | MetalBorders.ButtonBorder
      static class  | MetalBorders.Flush3DBorder
      static class  | MetalBorders.InternalFrameBorder
      static class  | MetalBorders.MenuBarBorder
      static class  | MetalBorders.MenuItemBorder
      static class  | MetalBorders.OptionDialogBorder
      static class  MetalBorders.PaletteBorder
      Border for a Palette.
      static class  | MetalBorders.PopupMenuBorder
      static class  | MetalBorders.RolloverButtonBorder
      static class  | MetalBorders.ScrollPaneBorder
      static class  MetalBorders.TableHeaderBorder
      Border for a Table Header
      static class  | MetalBorders.TextFieldBorder
      static class  | MetalBorders.ToggleButtonBorder
      static class  | MetalBorders.ToolBarBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

act)aa /p


Uses of Class javax.swing.border.BevelBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.BevelBorder

  • Packages that use BevelBorder
    软件包 描述
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of BevelBorder in javax.swing.border

      Subclasses of BevelBorder in javax.swing.border
      修饰符与类型 类与描述
      class  SoftBevelBorder
      A class which implements a raised or lowered bevel with softened corners.

    • Uses of BevelBorder in javax.swing.plaf

      Subclasses of BevelBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.BevelBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/bttr>>d <.uueyrreh ng


Uses of Class javax.swing.border.CompoundBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.CompoundBorder

  • Packages that use CompoundBorder
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of CompoundBorder in javax.swing

      Methods in javax.swing that return CompoundBorder
      修饰符与类型 方法与描述
      static CompoundBorder BorderFactory.createCompoundBorder()
      Creates a compound border with a null inside edge and a null outside edge.
      static CompoundBorder BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder)
      Creates a compound border specifying the border objects to use for the outside and inside edges.

    • Uses of CompoundBorder in javax.swing.plaf

      Subclasses of CompoundBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.CompoundBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. /.hre(><<


Uses of Class javax.swing.border.EmptyBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.EmptyBorder

  • Packages that use EmptyBorder
    软件包 描述
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of EmptyBorder in javax.swing.border

      Subclasses of EmptyBorder in javax.swing.border
      修饰符与类型 类与描述
      class  MatteBorder
      A class which provides a matte-like border of either a solid color or a tiled icon.

    • Uses of EmptyBorder in javax.swing.plaf

      Subclasses of EmptyBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.EmptyBorderUIResource
      static class  | BorderUIResource.MatteBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

isvtsi


Uses of Class javax.swing.border.EtchedBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.EtchedBorder

  • Packages that use EtchedBorder
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of EtchedBorder in javax.swing.plaf

      Subclasses of EtchedBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.EtchedBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

am>aee�>"乙襱d..<>lieh-p.


Uses of Class javax.swing.border.LineBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.LineBorder

  • Packages that use LineBorder
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of LineBorder in javax.swing.plaf

      Subclasses of LineBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.LineBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t >a>s>s/l>p/><>/o>< >


Uses of Class javax.swing.border.MatteBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.MatteBorder

  • Packages that use MatteBorder
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of MatteBorder in javax.swing

      Methods in javax.swing that return MatteBorder
      修饰符与类型 方法与描述
      static MatteBorder BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Color color)
      Creates a matte-look border using a solid color.
      static MatteBorder BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
      Creates a matte-look border that consists of multiple tiles of a specified icon.

    • Uses of MatteBorder in javax.swing.plaf

      Subclasses of MatteBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.MatteBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nc .gl/l/ ctsni� v"a/s


Uses of Class javax.swing.border.SoftBevelBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.SoftBevelBorder

No usage of javax.swing.border.SoftBevelBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>"iclalteee ojj ;ta


Uses of Class javax.swing.border.StrokeBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.StrokeBorder

No usage of javax.swing.border.StrokeBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/>slplafy/


Uses of Class javax.swing.border.TitledBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.border.TitledBorder

  • Packages that use TitledBorder
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of TitledBorder in javax.swing

      Methods in javax.swing that return TitledBorder
      修饰符与类型 方法与描述
      static TitledBorder BorderFactory.createTitledBorder(Border border)
      Creates a new titled border with an empty title, the specified border object, the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title)
      Adds a title to an existing border, with default positioning (sitting on the top line), default justification (leading) and the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition)
      Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      Adds a title to an existing border, with the specified positioning, font and color.
      static TitledBorder BorderFactory.createTitledBorder(String title)
      Creates a new titled border with the specified title, the default border type (determined by the current look and feel), the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).

    • Uses of TitledBorder in javax.swing.plaf

      Subclasses of TitledBorder in javax.swing.plaf
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.TitledBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>lrafsl>


Uses of Interface javax.swing.border.Border

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.border.Border

  • Packages that use Border
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of Border in javax.swing

      Fields in javax.swing declared as Border
      修饰符与类型 | 字段与描述
      protected static Border | DefaultListCellRenderer.noFocusBorder
      Methods in javax.swing that return Border
      修饰符与类型 方法与描述
      static Border BorderFactory.createBevelBorder(int type)
      Creates a beveled border of the specified type, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createBevelBorder(int type, Color highlight, Color shadow)
      Creates a beveled border of the specified type, using the specified highlighting and shadowing.
      static Border BorderFactory.createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      Creates a beveled border of the specified type, using the specified colors for the inner and outer highlight and shadow areas.
      static Border BorderFactory.createDashedBorder(Paint paint)
      Creates a dashed border of the specified paint.
      static Border BorderFactory.createDashedBorder(Paint paint, float length, float spacing)
      Creates a dashed border of the specified paint, relative length, and relative spacing.
      static Border BorderFactory.createDashedBorder(Paint paint, float thickness, float length, float spacing, boolean rounded)
      Creates a dashed border of the specified paint, thickness, line shape, relative length, and relative spacing.
      static Border BorderFactory.createEmptyBorder()
      Creates an empty border that takes up no space.
      static Border BorderFactory.createEmptyBorder(int top, int left, int bottom, int right)
      Creates an empty border that takes up space but which does no drawing, specifying the width of the top, left, bottom, and right sides.
      static Border BorderFactory.createEtchedBorder()
      Creates a border with an "etched" look using the component's current background color for highlighting and shading.
      static Border BorderFactory.createEtchedBorder(Color highlight, Color shadow)
      Creates a border with an "etched" look using the specified highlighting and shading colors.
      static Border BorderFactory.createEtchedBorder(int type)
      Creates a border with an "etched" look using the component's current background color for highlighting and shading.
      static Border BorderFactory.createEtchedBorder(int type, Color highlight, Color shadow)
      Creates a border with an "etched" look using the specified highlighting and shading colors.
      static Border BorderFactory.createLineBorder(Color color)
      Creates a line border withe the specified color.
      static Border BorderFactory.createLineBorder(Color color, int thickness)
      Creates a line border with the specified color and width.
      static Border BorderFactory.createLineBorder(Color color, int thickness, boolean rounded)
      Creates a line border with the specified color, thickness, and corner shape.
      static Border BorderFactory.createLoweredBevelBorder()
      Creates a border with a lowered beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createLoweredSoftBevelBorder()
      Creates a beveled border with a lowered edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createRaisedBevelBorder()
      Creates a border with a raised beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createRaisedSoftBevelBorder()
      Creates a beveled border with a raised edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createSoftBevelBorder(int type)
      Creates a beveled border of the specified type with softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
      static Border BorderFactory.createSoftBevelBorder(int type, Color highlight, Color shadow)
      Creates a beveled border of the specified type with softened corners, using the specified highlighting and shadowing.
      static Border BorderFactory.createSoftBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
      Creates a beveled border of the specified type with softened corners, using the specified colors for the inner and outer edges of the highlight and the shadow areas.
      static Border BorderFactory.createStrokeBorder(BasicStroke stroke)
      Creates a border of the specified stroke.
      static Border BorderFactory.createStrokeBorder(BasicStroke stroke, Paint paint)
      Creates a border of the specified stroke and paint.
      Border JComponent.getBorder()
      Returns the border of this component or null if no border is currently set.
      static Border UIManager.getBorder(Object key)
      Returns a border from the defaults.
      Border UIDefaults.getBorder(Object key)
      If the value of key is a Border return it, otherwise return null.
      static Border UIManager.getBorder(Object key, Locale l)
      Returns a border from the defaults that is appropriate for the given locale.
      Border UIDefaults.getBorder(Object key, Locale l)
      If the value of key for the given Locale is a Border return it, otherwise return null.
      Border JScrollPane.getViewportBorder()
      Returns the Border object that surrounds the viewport.
      Methods in javax.swing with parameters of type Border
      修饰符与类型 方法与描述
      static CompoundBorder BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder)
      Creates a compound border specifying the border objects to use for the outside and inside edges.
      static TitledBorder BorderFactory.createTitledBorder(Border border)
      Creates a new titled border with an empty title, the specified border object, the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title)
      Adds a title to an existing border, with default positioning (sitting on the top line), default justification (leading) and the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition)
      Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
      static TitledBorder BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      Adds a title to an existing border, with the specified positioning, font and color.
      protected String JComponent.AccessibleJComponent.getBorderTitle(Border b)
      Recursively search through the border hierarchy (if it exists) for a TitledBorder with a non-null title.
      void JLayer.setBorder(Border border)
      A non-null border, or non-zero insets, isn't supported, to prevent the geometry of this component from becoming complex enough to inhibit subclassing of LayerUI class.
      void JViewport.setBorder(Border border)
      The viewport "scrolls" its child (called the "view") by the normal parent/child clipping (typically the view is moved in the opposite direction of the scroll).
      void JComponent.setBorder(Border border)
      Sets the border of this component.
      void JScrollPane.setViewportBorder(Border viewportBorder)
      Adds a border around the viewport.

    • Uses of Border in javax.swing.border

      Classes in javax.swing.border that implement Border
      修饰符与类型 类与描述
      class  AbstractBorder
      A class that implements an empty border with no size.
      class  BevelBorder
      A class which implements a simple two-line bevel border.
      class  CompoundBorder
      A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
      class  EmptyBorder
      A class which provides an empty, transparent border which takes up space but does no drawing.
      class  EtchedBorder
      A class which implements a simple etched border which can either be etched-in or etched-out.
      class  LineBorder
      A class which implements a line border of arbitrary thickness and of a single color.
      class  MatteBorder
      A class which provides a matte-like border of either a solid color or a tiled icon.
      class  SoftBevelBorder
      A class which implements a raised or lowered bevel with softened corners.
      class  StrokeBorder
      A class which implements a border of an arbitrary stroke.
      class  TitledBorder
      A class which implements an arbitrary border with the addition of a String title in a specified position and justification.
      Fields in javax.swing.border declared as Border
      修饰符与类型 | 字段与描述
      protected Border | TitledBorder.border
      protected Border | CompoundBorder.insideBorder
      protected Border | CompoundBorder.outsideBorder
      Methods in javax.swing.border that return Border
      修饰符与类型 方法与描述
      static Border LineBorder.createBlackLineBorder()
      Convenience method for getting the Color.black LineBorder of thickness 1.
      static Border LineBorder.createGrayLineBorder()
      Convenience method for getting the Color.gray LineBorder of thickness 1.
      Border TitledBorder.getBorder()
      Returns the border of the titled border.
      Border CompoundBorder.getInsideBorder()
      Returns the inside border object.
      Border CompoundBorder.getOutsideBorder()
      Returns the outside border object.
      Methods in javax.swing.border with parameters of type Border
      修饰符与类型 方法与描述
      static Rectangle AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height)
      Returns a rectangle using the arguments minus the insets of the border.
      void TitledBorder.setBorder(Border border)
      Sets the border of the titled border.
      Constructors in javax.swing.border with parameters of type Border
      构造方法与描述
      CompoundBorder(Border outsideBorder, Border insideBorder)
      Creates a compound border with the specified outside and inside borders.
      TitledBorder(Border border)
      Creates a TitledBorder instance with the specified border and an empty title.
      TitledBorder(Border border, String title)
      Creates a TitledBorder instance with the specified border and title.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition)
      Creates a TitledBorder instance with the specified border, title, title-justification, and title-position.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      Creates a TitledBorder instance with the specified border, title, title-justification, title-position, and title-font.
      TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      Creates a TitledBorder instance with the specified border, title, title-justification, title-position, title-font, and title-color.

    • Uses of Border in javax.swing.plaf

      Classes in javax.swing.plaf that implement Border
      修饰符与类型 | 类与描述
      class  | BorderUIResource
      static class  | BorderUIResource.BevelBorderUIResource
      static class  | BorderUIResource.CompoundBorderUIResource
      static class  | BorderUIResource.EmptyBorderUIResource
      static class  | BorderUIResource.EtchedBorderUIResource
      static class  | BorderUIResource.LineBorderUIResource
      static class  | BorderUIResource.MatteBorderUIResource
      static class  | BorderUIResource.TitledBorderUIResource
      Methods in javax.swing.plaf that return Border
      修饰符与类型 | 方法与描述
      static Border | BorderUIResource.getBlackLineBorderUIResource()
      static Border | BorderUIResource.getEtchedBorderUIResource()
      static Border | BorderUIResource.getLoweredBevelBorderUIResource()
      static Border | BorderUIResource.getRaisedBevelBorderUIResource()
      Constructors in javax.swing.plaf with parameters of type Border
      构造方法与描述
      BorderUIResource.CompoundBorderUIResource(Border outsideBorder, Border insideBorder)
      BorderUIResource.TitledBorderUIResource(Border border)
      BorderUIResource.TitledBorderUIResource(Border border, String title)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      BorderUIResource(Border delegate)
      Creates a UIResource border object which wraps an existing Border instance.

    • Uses of Border in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Border
      修饰符与类型 | 类与描述
      static class  | BasicBorders.ButtonBorder
      static class  | BasicBorders.FieldBorder
      static class  | BasicBorders.MarginBorder
      static class  | BasicBorders.MenuBarBorder
      static class  | BasicBorders.RadioButtonBorder
      static class  BasicBorders.RolloverButtonBorder
      Special thin border for rollover toolbar buttons.
      static class  BasicBorders.SplitPaneBorder
      Draws the border around the splitpane.
      static class  | BasicBorders.ToggleButtonBorder
      Fields in javax.swing.plaf.basic declared as Border
      修饰符与类型 字段与描述
      protected static Border BasicComboBoxRenderer.noFocusBorder
      An empty Border.
      Methods in javax.swing.plaf.basic that return Border
      修饰符与类型 | 方法与描述
      protected Border BasicToolBarUI.createNonRolloverBorder()
      Creates the non rollover border for toolbar components.
      protected Border BasicToolBarUI.createRolloverBorder()
      Creates a rollover border for toolbar components.
      Border BasicSplitPaneDivider.getBorder()
      Returns the border of this component or null if no border is currently set.
      static Border | BasicBorders.getButtonBorder()
      static Border | BasicBorders.getInternalFrameBorder()
      static Border | BasicBorders.getMenuBarBorder()
      protected Border BasicToolBarUI.getNonRolloverBorder(AbstractButton b)
      Returns a non-rollover border for the button.
      static Border | BasicBorders.getProgressBarBorder()
      static Border | BasicBorders.getRadioButtonBorder()
      protected Border BasicToolBarUI.getRolloverBorder(AbstractButton b)
      Returns a rollover border for the button.
      static Border | BasicBorders.getSplitPaneBorder()
      static Border BasicBorders.getSplitPaneDividerBorder()
      Returns a border instance for a JSplitPane divider
      static Border | BasicBorders.getTextFieldBorder()
      static Border | BasicBorders.getToggleButtonBorder()
      Methods in javax.swing.plaf.basic with parameters of type Border
      修饰符与类型 方法与描述
      void BasicSplitPaneDivider.setBorder(Border border)
      Sets the border of this component.

    • Uses of Border in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Border
      修饰符与类型 | 类与描述
      static class  | MetalBorders.ButtonBorder
      static class  | MetalBorders.Flush3DBorder
      static class  | MetalBorders.InternalFrameBorder
      static class  | MetalBorders.MenuBarBorder
      static class  | MetalBorders.MenuItemBorder
      static class  | MetalBorders.OptionDialogBorder
      static class  MetalBorders.PaletteBorder
      Border for a Palette.
      static class  | MetalBorders.PopupMenuBorder
      static class  | MetalBorders.RolloverButtonBorder
      static class  | MetalBorders.ScrollPaneBorder
      static class  MetalBorders.TableHeaderBorder
      Border for a Table Header
      static class  | MetalBorders.TextFieldBorder
      static class  | MetalBorders.ToggleButtonBorder
      static class  | MetalBorders.ToolBarBorder
      Methods in javax.swing.plaf.metal that return Border
      修饰符与类型 | 方法与描述
      protected Border | MetalToolBarUI.createNonRolloverBorder()
      protected Border | MetalToolBarUI.createRolloverBorder()
      static Border MetalBorders.getButtonBorder()
      Returns a border instance for a JButton
      static Border MetalBorders.getDesktopIconBorder()
      Returns a border instance for a Desktop Icon
      static Border MetalBorders.getTextBorder()
      Returns a border instance for a text component
      static Border MetalBorders.getTextFieldBorder()
      Returns a border instance for a JTextField
      static Border MetalBorders.getToggleButtonBorder()
      Returns a border instance for a JToggleButton

    • Uses of Border in javax.swing.table

      Fields in javax.swing.table declared as Border
      修饰符与类型 | 字段与描述
      protected static Border | DefaultTableCellRenderer.noFocusBorder

    • Uses of Border in javax.swing.tree

      Fields in javax.swing.tree declared as Border
      修饰符与类型 字段与描述
      protected Border DefaultTreeCellEditor.DefaultTextField.border
      Border to use.
      Methods in javax.swing.tree that return Border
      修饰符与类型 方法与描述
      Border DefaultTreeCellEditor.DefaultTextField.getBorder()
      Overrides JComponent.getBorder to returns the current border.
      Methods in javax.swing.tree with parameters of type Border
      修饰符与类型 方法与描述
      void DefaultTreeCellEditor.DefaultTextField.setBorder(Border border)
      Sets the border of this component.
      Constructors in javax.swing.tree with parameters of type Border
      构造方法与描述
      DefaultTreeCellEditor.DefaultTextField(Border border)
      Constructs a DefaultTreeCellEditor.DefaultTextField object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.AbstractAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractAction

  • Packages that use AbstractAction
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractAction in javax.swing.plaf.basic

      Subclasses of AbstractAction in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      protected class  BasicDesktopPaneUI.CloseAction
      Handles closing an internal frame.
      protected class  BasicDesktopPaneUI.MaximizeAction
      Handles maximizing an internal frame.
      protected class  BasicDesktopPaneUI.MinimizeAction
      Handles minimizing an internal frame.
      protected class  BasicDesktopPaneUI.NavigateAction
      Handles navigating to the next internal frame.
      protected class  BasicDesktopPaneUI.OpenAction
      Handles restoring a minimized or maximized internal frame.
      protected class  BasicFileChooserUI.ApproveSelectionAction
      Responds to an Open or Save request
      protected class  BasicFileChooserUI.CancelSelectionAction
      Responds to a cancel request.
      protected class  | BasicFileChooserUI.ChangeToParentDirectoryAction
      protected class  BasicFileChooserUI.GoHomeAction
      Acts on the "home" key event or equivalent event.
      protected class  BasicFileChooserUI.NewFolderAction
      Creates a new folder.
      protected class  BasicFileChooserUI.UpdateAction
      Rescans the files in the current directory
      class  BasicInternalFrameTitlePane.CloseAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.IconifyAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MaximizeAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MoveAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.RestoreAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.SizeAction
      This class should be treated as a "protected" inner class.
      class  BasicSliderUI.ActionScroller
      As of Java 2 platform v1.3 this undocumented class is no longer used.
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener that invokes cancelEditing when action performed.
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction is used to handle end/home actions.
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction is used to handle up/down actions.
      class  BasicTreeUI.TreePageAction
      TreePageAction handles page up and page down events.
      class  BasicTreeUI.TreeToggleAction
      For the first selected row expandedness will be toggled.
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction is the action used for left/right keys.

    • Uses of AbstractAction in javax.swing.plaf.metal

      Subclasses of AbstractAction in javax.swing.plaf.metal
      修饰符与类型 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      Acts when DirectoryComboBox has changed the selected item.

    • Uses of AbstractAction in javax.swing.text

      Subclasses of AbstractAction in javax.swing.text
      修饰符与类型 类与描述
      static class  DefaultEditorKit.BeepAction
      Creates a beep.
      static class  DefaultEditorKit.CopyAction
      Copies the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.CutAction
      Cuts the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.DefaultKeyTypedAction
      The action that is executed by default if a key typed event is received and there is no keymap entry.
      static class  DefaultEditorKit.InsertBreakAction
      Places a line/paragraph break into the document.
      static class  DefaultEditorKit.InsertContentAction
      Places content into the associated document.
      static class  DefaultEditorKit.InsertTabAction
      Places a tab character into the document.
      static class  DefaultEditorKit.PasteAction
      Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
      static class  StyledEditorKit.AlignmentAction
      An action to set paragraph alignment.
      static class  StyledEditorKit.BoldAction
      An action to toggle the bold attribute.
      static class  StyledEditorKit.FontFamilyAction
      An action to set the font family in the associated JEditorPane.
      static class  StyledEditorKit.FontSizeAction
      An action to set the font size in the associated JEditorPane.
      static class  StyledEditorKit.ForegroundAction
      An action to set foreground color.
      static class  StyledEditorKit.ItalicAction
      An action to toggle the italic attribute.
      static class  StyledEditorKit.StyledTextAction
      An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
      static class  StyledEditorKit.UnderlineAction
      An action to toggle the underline attribute.
      class  TextAction
      An Action implementation useful for key bindings that are shared across a number of different text components.

    • Uses of AbstractAction in javax.swing.text.html

      Subclasses of AbstractAction in javax.swing.text.html
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLTextAction
      An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d/d.d<=id


Uses of Class javax.swing.AbstractButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractButton

  • Packages that use AbstractButton
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of AbstractButton in javax.swing

      Subclasses of AbstractButton in javax.swing
      修饰符与类型 类与描述
      class  JButton
      An implementation of a "push" button.
      class  JCheckBox
      An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
      class  JCheckBoxMenuItem
      A menu item that can be selected or deselected.
      class  JMenu
      An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
      class  JMenuItem
      An implementation of an item in a menu.
      class  JRadioButton
      An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
      class  JRadioButtonMenuItem
      An implementation of a radio button menu item.
      class  JToggleButton
      An implementation of a two-state button.
      Fields in javax.swing with type parameters of type AbstractButton
      修饰符与类型 | 字段与描述
      protected Vector<AbstractButton> | ButtonGroup.buttons
      Methods in javax.swing that return types with arguments of type AbstractButton
      修饰符与类型 方法与描述
      Enumeration<AbstractButton> ButtonGroup.getElements()
      Returns all the buttons that are participating in this group.
      Methods in javax.swing with parameters of type AbstractButton
      修饰符与类型 方法与描述
      void ButtonGroup.add(AbstractButton b)
      Adds the button to the group.
      void ButtonGroup.remove(AbstractButton b)
      Removes the button from the group.

    • Uses of AbstractButton in javax.swing.plaf.basic

      Subclasses of AbstractButton in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicArrowButton
      JButton object that draws a scaled Arrow in one of the cardinal directions.
      Methods in javax.swing.plaf.basic with parameters of type AbstractButton
      修饰符与类型 | 方法与描述
      protected void | BasicButtonListener.checkOpacity(AbstractButton b)
      protected BasicButtonListener | BasicButtonUI.createButtonListener(AbstractButton b)
      int | BasicButtonUI.getDefaultTextIconGap(AbstractButton b)
      protected Border BasicToolBarUI.getNonRolloverBorder(AbstractButton b)
      Returns a non-rollover border for the button.
      static Dimension | BasicGraphicsUtils.getPreferredButtonSize(AbstractButton b, int textIconGap)
      protected Border BasicToolBarUI.getRolloverBorder(AbstractButton b)
      Returns a rollover border for the button.
      protected void | BasicRadioButtonUI.installDefaults(AbstractButton b)
      protected void | BasicButtonUI.installDefaults(AbstractButton b)
      protected void | BasicButtonUI.installKeyboardActions(AbstractButton b)
      protected void | BasicButtonUI.installListeners(AbstractButton b)
      protected void | BasicButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
      protected void | BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
      protected void BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
      Method which renders the text of the current button.
      protected void | BasicRadioButtonUI.uninstallDefaults(AbstractButton b)
      protected void | BasicButtonUI.uninstallDefaults(AbstractButton b)
      protected void | BasicButtonUI.uninstallKeyboardActions(AbstractButton b)
      protected void | BasicButtonUI.uninstallListeners(AbstractButton b)
      Constructors in javax.swing.plaf.basic with parameters of type AbstractButton
      构造方法与描述
      BasicButtonListener(AbstractButton b)

    • Uses of AbstractButton in javax.swing.plaf.metal

      Subclasses of AbstractButton in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxButton
      JButton subclass to help out MetalComboBoxUI
      class  MetalScrollButton
      JButton object for Metal scrollbar arrows.
      Methods in javax.swing.plaf.metal with parameters of type AbstractButton
      修饰符与类型 | 方法与描述
      protected BasicButtonListener | MetalButtonUI.createButtonListener(AbstractButton b)
      void | MetalToggleButtonUI.installDefaults(AbstractButton b)
      void | MetalRadioButtonUI.installDefaults(AbstractButton b)
      void | MetalCheckBoxUI.installDefaults(AbstractButton b)
      void | MetalButtonUI.installDefaults(AbstractButton b)
      protected void | MetalToggleButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
      protected void | MetalButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
      protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
      Paints the appropriate icon of the button b in the space iconRect.
      protected void | MetalToggleButtonUI.uninstallDefaults(AbstractButton b)
      protected void | MetalRadioButtonUI.uninstallDefaults(AbstractButton b)
      protected void | MetalCheckBoxUI.uninstallDefaults(AbstractButton b)
      void | MetalButtonUI.uninstallDefaults(AbstractButton b)

    • Uses of AbstractButton in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type AbstractButton
      修饰符与类型 | 方法与描述
      protected Icon SynthButtonUI.getDefaultIcon(AbstractButton b)
      Returns the default icon.
      protected Icon SynthButtonUI.getIcon(AbstractButton b)
      Returns the Icon to use for painting the button.
      protected Icon SynthRadioButtonUI.getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      protected Icon SynthButtonUI.getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      protected void | SynthButtonUI.installDefaults(AbstractButton b)
      protected void | SynthButtonUI.installListeners(AbstractButton b)
      protected void | SynthButtonUI.uninstallDefaults(AbstractButton b)
      protected void | SynthButtonUI.uninstallListeners(AbstractButton b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.AbstractButton.AccessibleAbstractButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractButton.AccessibleAbstractButton

  • Packages that use AbstractButton.AccessibleAbstractButton
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of AbstractButton.AccessibleAbstractButton in javax.swing

      Subclasses of AbstractButton.AccessibleAbstractButton in javax.swing
      修饰符与类型 类与描述
      protected class  JButton.AccessibleJButton
      This class implements accessibility support for the JButton class.
      protected class  JCheckBox.AccessibleJCheckBox
      This class implements accessibility support for the JCheckBox class.
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      This class implements accessibility support for the JCheckBoxMenuItem class.
      protected class  JMenu.AccessibleJMenu
      This class implements accessibility support for the JMenu class.
      protected class  JMenuItem.AccessibleJMenuItem
      This class implements accessibility support for the JMenuItem class.
      protected class  JRadioButton.AccessibleJRadioButton
      This class implements accessibility support for the JRadioButton class.
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      This class implements accessibility support for the JRadioButtonMenuItem class.
      protected class  JToggleButton.AccessibleJToggleButton
      This class implements accessibility support for the JToggleButton class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntearnaIcnnnab..B/fcIliii


Uses of Class javax.swing.AbstractButton.ButtonChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractButton.ButtonChangeListener

No usage of javax.swing.AbstractButton.ButtonChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>eede> <<


Uses of Class javax.swing.AbstractCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractCellEditor

  • Packages that use AbstractCellEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of AbstractCellEditor in javax.swing

      Subclasses of AbstractCellEditor in javax.swing
      修饰符与类型 类与描述
      class  DefaultCellEditor
      The default editor for table and tree cells.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oc --tutttofeevasjwR. l


Uses of Class javax.swing.AbstractListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractListModel

  • Packages that use AbstractListModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of AbstractListModel in javax.swing

      Subclasses of AbstractListModel in javax.swing
      修饰符与类型 类与描述
      class  DefaultComboBoxModel
      The default model for combo boxes.
      class  DefaultListModel<E>
      This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur.

    • Uses of AbstractListModel in javax.swing.plaf.basic

      Subclasses of AbstractListModel in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicDirectoryModel
      Basic implementation of a file list.

    • Uses of AbstractListModel in javax.swing.plaf.metal

      Subclasses of AbstractListModel in javax.swing.plaf.metal
      修饰符与类型 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      Data model for a type-face selection combo-box.
      protected class  MetalFileChooserUI.FilterComboBoxModel
      Data model for a type-face selection combo-box.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pa.ti(og> rsao


Uses of Class javax.swing.AbstractSpinnerModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.AbstractSpinnerModel

  • Packages that use AbstractSpinnerModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of AbstractSpinnerModel in javax.swing

      Subclasses of AbstractSpinnerModel in javax.swing
      修饰符与类型 类与描述
      class  SpinnerDateModel
      A SpinnerModel for sequences of Dates.
      class  SpinnerListModel
      A simple implementation of SpinnerModel whose values are defined by an array or a List.
      class  SpinnerNumberModel
      A SpinnerModel for sequences of numbers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cel


Uses of Class javax.swing.ActionMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ActionMap

  • Packages that use ActionMap
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of ActionMap in javax.swing

      Methods in javax.swing that return ActionMap
      修饰符与类型 方法与描述
      ActionMap JComponent.getActionMap()
      Returns the ActionMap used to determine what Action to fire for particular KeyStroke binding.
      ActionMap ActionMap.getParent()
      Returns this ActionMap's parent.
      static ActionMap SwingUtilities.getUIActionMap(JComponent component)
      Returns the ActionMap provided by the UI in component component.
      Methods in javax.swing with parameters of type ActionMap
      修饰符与类型 方法与描述
      static void SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap)
      Convenience method to change the UI ActionMap for component to uiActionMap.
      void JComponent.setActionMap(ActionMap am)
      Sets the ActionMap to am.
      void ActionMap.setParent(ActionMap map)
      Sets this ActionMap's parent.

    • Uses of ActionMap in javax.swing.plaf

      Subclasses of ActionMap in javax.swing.plaf
      修饰符与类型 类与描述
      class  ActionMapUIResource
      A subclass of javax.swing.ActionMap that implements UIResource.

    • Uses of ActionMap in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return ActionMap
      修饰符与类型 方法与描述
      protected ActionMap BasicLookAndFeel.getAudioActionMap()
      Returns an ActionMap containing the audio actions for this look and feel.

    • Uses of ActionMap in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return ActionMap
      修饰符与类型 | 方法与描述
      protected ActionMap | MetalFileChooserUI.createActionMap()
      protected ActionMap | MetalFileChooserUI.getActionMap()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

es>f sp otttd eenngano"tii


Uses of Class javax.swing.BorderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.BorderFactory

No usage of javax.swing.BorderFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< cclast


Uses of Class javax.swing.Box

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Box

  • Packages that use Box
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of Box in javax.swing

      Methods in javax.swing that return Box
      修饰符与类型 方法与描述
      static Box Box.createHorizontalBox()
      Creates a Box that displays its components from left to right.
      static Box Box.createVerticalBox()
      Creates a Box that displays its components from top to bottom.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.lstrRfdsglp""l>=xevevmlo


Uses of Class javax.swing.Box.AccessibleBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Box.AccessibleBox

No usage of javax.swing.Box.AccessibleBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>l dieroMdddlc""


Uses of Class javax.swing.Box.Filler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Box.Filler

No usage of javax.swing.Box.Filler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acoa i dokgdaix骷h


Uses of Class javax.swing.Box.Filler.AccessibleBoxFiller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Box.Filler.AccessibleBoxFiller

No usage of javax.swing.Box.Filler.AccessibleBoxFiller
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hg� lan


Uses of Class javax.swing.BoxLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.BoxLayout

  • Packages that use BoxLayout
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BoxLayout in javax.swing.plaf.basic

      Subclasses of BoxLayout in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  DefaultMenuLayout
      The default layout manager for Popup menus and menubars.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eot".mamt"tg"ntt琭詇tr模/


Uses of Class javax.swing.ButtonGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ButtonGroup

  • Packages that use ButtonGroup
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of ButtonGroup in javax.swing

      Fields in javax.swing declared as ButtonGroup
      修饰符与类型 字段与描述
      protected ButtonGroup DefaultButtonModel.group
      The button group that the button belongs to.
      Methods in javax.swing that return ButtonGroup
      修饰符与类型 方法与描述
      ButtonGroup DefaultButtonModel.getGroup()
      Returns the group that the button belongs to.
      Methods in javax.swing with parameters of type ButtonGroup
      修饰符与类型 方法与描述
      void DefaultButtonModel.setGroup(ButtonGroup group)
      Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
      void ButtonModel.setGroup(ButtonGroup group)
      Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>ponp " ler.蔵�


Uses of Class javax.swing.CellRendererPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.CellRendererPane

  • Packages that use CellRendererPane
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of CellRendererPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as CellRendererPane
      修饰符与类型 | 字段与描述
      protected CellRendererPane | BasicComboBoxUI.currentValuePane
      protected CellRendererPane | BasicTableHeaderUI.rendererPane
      protected CellRendererPane | BasicTableUI.rendererPane
      protected CellRendererPane | BasicListUI.rendererPane
      protected CellRendererPane BasicTreeUI.rendererPane
      Used to paint the TreeCellRenderer.
      Methods in javax.swing.plaf.basic that return CellRendererPane
      修饰符与类型 方法与描述
      protected CellRendererPane BasicTreeUI.createCellRendererPane()
      Returns the renderer pane that renderer components are placed in.

    • Uses of CellRendererPane in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as CellRendererPane
      修饰符与类型 | 字段与描述
      protected CellRendererPane | MetalComboBoxButton.rendererPane
      Constructors in javax.swing.plaf.metal with parameters of type CellRendererPane
      构造方法与描述
      MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
      MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

see>itar


Uses of Class javax.swing.CellRendererPane.AccessibleCellRendererPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.CellRendererPane.AccessibleCellRendererPane

No usage of javax.swing.CellRendererPane.AccessibleCellRendererPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sccong/


Uses of Class javax.swing.ComponentInputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ComponentInputMap

  • Packages that use ComponentInputMap
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of ComponentInputMap in javax.swing

      Methods in javax.swing that return ComponentInputMap
      修饰符与类型 方法与描述
      static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
      Creates a ComponentInputMapUIResource from keys.

    • Uses of ComponentInputMap in javax.swing.plaf

      Subclasses of ComponentInputMap in javax.swing.plaf
      修饰符与类型 类与描述
      class  ComponentInputMapUIResource
      A subclass of javax.swing.ComponentInputMap that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


Uses of Class javax.swing.DebugGraphics

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DebugGraphics

No usage of javax.swing.DebugGraphics
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ck,CCCna==g


Uses of Class javax.swing.DefaultBoundedRangeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultBoundedRangeModel

No usage of javax.swing.DefaultBoundedRangeModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/ lnbs>l[ttg =>=ri


Uses of Class javax.swing.DefaultButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultButtonModel

  • Packages that use DefaultButtonModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of DefaultButtonModel in javax.swing

      Subclasses of DefaultButtonModel in javax.swing
      修饰符与类型 类与描述
      static class  JToggleButton.ToggleButtonModel
      The ToggleButton model
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lnouslA/i is.t. Canowv


Uses of Class javax.swing.DefaultCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultCellEditor

No usage of javax.swing.DefaultCellEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>"clad


Uses of Class javax.swing.DefaultCellEditor.EditorDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultCellEditor.EditorDelegate

  • Packages that use DefaultCellEditor.EditorDelegate
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of DefaultCellEditor.EditorDelegate in javax.swing

      Fields in javax.swing declared as DefaultCellEditor.EditorDelegate
      修饰符与类型 字段与描述
      protected DefaultCellEditor.EditorDelegate DefaultCellEditor.delegate
      The delegate class which handles all methods sent from the CellEditor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>.a p//lomug8&c>e-uppd.n


Uses of Class javax.swing.DefaultComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultComboBoxModel

No usage of javax.swing.DefaultComboBoxModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--.hR"vf< =>=" /= r


Uses of Class javax.swing.DefaultDesktopManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultDesktopManager

No usage of javax.swing.DefaultDesktopManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Phnaah 1爃h �


Uses of Class javax.swing.DefaultFocusManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultFocusManager

No usage of javax.swing.DefaultFocusManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.DefaultListCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultListCellRenderer

  • Packages that use DefaultListCellRenderer
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of DefaultListCellRenderer in javax.swing

      Subclasses of DefaultListCellRenderer in javax.swing
      修饰符与类型 类与描述
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.

    • Uses of DefaultListCellRenderer in javax.swing.plaf.metal

      Subclasses of DefaultListCellRenderer in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalFileChooserUI.FileRenderer
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/e;rar>A">>T>l=b 琻eh


Uses of Class javax.swing.DefaultListCellRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultListCellRenderer.UIResource

No usage of javax.swing.DefaultListCellRenderer.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n. in>a/lLe


Uses of Class javax.swing.DefaultListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultListModel

No usage of javax.swing.DefaultListModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shbl. .sb>ae. cfr"a0


Uses of Class javax.swing.DefaultListSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultListSelectionModel

  • Packages that use DefaultListSelectionModel
    软件包 描述
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of DefaultListSelectionModel in javax.swing.tree

      Fields in javax.swing.tree declared as DefaultListSelectionModel
      修饰符与类型 字段与描述
      protected DefaultListSelectionModel DefaultTreeSelectionModel.listSelectionModel
      Handles maintaining the list selection model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iH-.S>im"p,t. /sne


Uses of Class javax.swing.DefaultRowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultRowSorter

  • Packages that use DefaultRowSorter
    软件包 描述
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of DefaultRowSorter in javax.swing.table

      Subclasses of DefaultRowSorter in javax.swing.table
      修饰符与类型 类与描述
      class  TableRowSorter<M extends TableModel>
      An implementation of RowSorter that provides sorting and filtering using a TableModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rt� rl苐c 傲唬芶恍∷Ｃa


Uses of Class javax.swing.DefaultRowSorter.ModelWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultRowSorter.ModelWrapper

  • Packages that use DefaultRowSorter.ModelWrapper
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of DefaultRowSorter.ModelWrapper in javax.swing

      Methods in javax.swing that return DefaultRowSorter.ModelWrapper
      修饰符与类型 方法与描述
      protected DefaultRowSorter.ModelWrapper<M,I> DefaultRowSorter.getModelWrapper()
      Returns the model wrapper providing the data that is being sorted and filtered.
      Methods in javax.swing with parameters of type DefaultRowSorter.ModelWrapper
      修饰符与类型 方法与描述
      protected void DefaultRowSorter.setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
      Sets the model wrapper providing the data that is being sorted and filtered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

er<" ath 睻dr1竢Mn


Uses of Class javax.swing.DefaultSingleSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DefaultSingleSelectionModel

No usage of javax.swing.DefaultSingleSelectionModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gr=cr="obrrrlltth i b


Uses of Class javax.swing.DropMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.DropMode

  • Packages that use DropMode
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DropMode in javax.swing

      Methods in javax.swing that return DropMode
      修饰符与类型 方法与描述
      DropMode JTree.getDropMode()
      Returns the drop mode for this component.
      DropMode JTable.getDropMode()
      Returns the drop mode for this component.
      DropMode JList.getDropMode()
      Returns the drop mode for this component.
      static DropMode DropMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static DropMode[] DropMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.swing with parameters of type DropMode
      修饰符与类型 方法与描述
      void JTree.setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void JTable.setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void JList.setDropMode(DropMode dropMode)
      Sets the drop mode for this component.

    • Uses of DropMode in javax.swing.text

      Methods in javax.swing.text that return DropMode
      修饰符与类型 方法与描述
      DropMode JTextComponent.getDropMode()
      Returns the drop mode for this component.
      Methods in javax.swing.text with parameters of type DropMode
      修饰符与类型 方法与描述
      void JTextComponent.setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ma<=es.en.ig"nih.xo"/ a


Uses of Class javax.swing.FocusManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.FocusManager

  • Packages that use FocusManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of FocusManager in javax.swing

      Subclasses of FocusManager in javax.swing
      修饰符与类型 类与描述
      class  DefaultFocusManager
      This class has been obsoleted by the 1.4 focus APIs.
      Methods in javax.swing that return FocusManager
      修饰符与类型 方法与描述
      static FocusManager FocusManager.getCurrentManager()
      Returns the current KeyboardFocusManager instance for the calling thread's context.
      Methods in javax.swing with parameters of type FocusManager
      修饰符与类型 方法与描述
      static void FocusManager.setCurrentManager(FocusManager aFocusManager)
      Sets the current KeyboardFocusManager instance for the calling thread's context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o plss= hccc oss sihteier>


Uses of Class javax.swing.GrayFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GrayFilter

No usage of javax.swing.GrayFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nvd"e="s cccsstt//st


Uses of Class javax.swing.GroupLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GroupLayout

No usage of javax.swing.GroupLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>=ale>/>>taei<


Uses of Class javax.swing.GroupLayout.Alignment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GroupLayout.Alignment

  • Packages that use GroupLayout.Alignment
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of GroupLayout.Alignment in javax.swing

      Methods in javax.swing that return GroupLayout.Alignment
      修饰符与类型 方法与描述
      static GroupLayout.Alignment GroupLayout.Alignment.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static GroupLayout.Alignment[] GroupLayout.Alignment.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.swing with parameters of type GroupLayout.Alignment
      修饰符与类型 方法与描述
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment)
      Adds a Component to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
      Adds a Component to this ParallelGroup with the specified alignment and size.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group)
      Adds a Group to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.createParallelGroup(GroupLayout.Alignment alignment)
      Creates and returns a ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable)
      Creates and returns a ParallelGroup with the specified alignment and resize behavior.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=eecu.mr紅pp iC<


Uses of Class javax.swing.GroupLayout.Group

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GroupLayout.Group

  • Packages that use GroupLayout.Group
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of GroupLayout.Group in javax.swing

      Subclasses of GroupLayout.Group in javax.swing
      修饰符与类型 类与描述
      class  GroupLayout.ParallelGroup
      A Group that aligns and sizes it's children.
      class  GroupLayout.SequentialGroup
      A Group that positions and sizes its elements sequentially, one after another.
      Methods in javax.swing that return GroupLayout.Group
      修饰符与类型 方法与描述
      GroupLayout.Group GroupLayout.Group.addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.Group GroupLayout.Group.addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.Group GroupLayout.Group.addGap(int size)
      Adds a rigid gap to this Group.
      GroupLayout.Group GroupLayout.Group.addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.Group GroupLayout.Group.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      Methods in javax.swing with parameters of type GroupLayout.Group
      修饰符与类型 方法与描述
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group)
      Adds a Group to this ParallelGroup with the specified alignment.
      GroupLayout.Group GroupLayout.Group.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      void GroupLayout.setHorizontalGroup(GroupLayout.Group group)
      Sets the Group that positions and sizes components along the horizontal axis.
      void GroupLayout.setVerticalGroup(GroupLayout.Group group)
      Sets the Group that positions and sizes components along the vertical axis.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ncj-onb=sts"onsbcd< m


Uses of Class javax.swing.GroupLayout.ParallelGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GroupLayout.ParallelGroup

  • Packages that use GroupLayout.ParallelGroup
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of GroupLayout.ParallelGroup in javax.swing

      Methods in javax.swing that return GroupLayout.ParallelGroup
      修饰符与类型 方法与描述
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment)
      Adds a Component to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
      Adds a Component to this ParallelGroup with the specified alignment and size.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGap(int pref)
      Adds a rigid gap to this Group.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group)
      Adds a Group to this ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.ParallelGroup GroupLayout.createBaselineGroup(boolean resizable, boolean anchorBaselineToTop)
      Creates and returns a ParallelGroup that aligns it's elements along the baseline.
      GroupLayout.ParallelGroup GroupLayout.createParallelGroup()
      Creates and returns a ParallelGroup with an alignment of Alignment.LEADING.
      GroupLayout.ParallelGroup GroupLayout.createParallelGroup(GroupLayout.Alignment alignment)
      Creates and returns a ParallelGroup with the specified alignment.
      GroupLayout.ParallelGroup GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable)
      Creates and returns a ParallelGroup with the specified alignment and resize behavior.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/y aaa l=tl. f {p


Uses of Class javax.swing.GroupLayout.SequentialGroup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.GroupLayout.SequentialGroup

  • Packages that use GroupLayout.SequentialGroup
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of GroupLayout.SequentialGroup in javax.swing

      Methods in javax.swing that return GroupLayout.SequentialGroup
      修饰符与类型 方法与描述
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component)
      Adds a Component to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component)
      Adds a Component to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component, int min, int pref, int max)
      Adds a Component to this Group with the specified size.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addContainerGap()
      Adds an element representing the preferred gap between an edge the container and components that touch the border of the container.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addContainerGap(int pref, int max)
      Adds an element representing the preferred gap between one edge of the container and the next or previous Component with the specified size.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGap(int size)
      Adds a rigid gap to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGap(int min, int pref, int max)
      Adds a gap to this Group with the specified size.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group)
      Adds a Group to this Group.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between the nearest components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between the nearest components.
      GroupLayout.SequentialGroup GroupLayout.createSequentialGroup()
      Creates and returns a SequentialGroup.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/# a = >"e?n �


Uses of Class javax.swing.ImageIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ImageIcon

No usage of javax.swing.ImageIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acoa i dokgdaix骷h


Uses of Class javax.swing.ImageIcon.AccessibleImageIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ImageIcon.AccessibleImageIcon

No usage of javax.swing.ImageIcon.AccessibleImageIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cco="alcaaat <


Uses of Class javax.swing.InputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.InputMap

  • Packages that use InputMap
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of InputMap in javax.swing

      Subclasses of InputMap in javax.swing
      修饰符与类型 类与描述
      class  ComponentInputMap
      A ComponentInputMap is an InputMap associated with a particular JComponent.
      Methods in javax.swing that return InputMap
      修饰符与类型 方法与描述
      InputMap JComponent.getInputMap()
      Returns the InputMap that is used when the component has focus.
      InputMap JComponent.getInputMap(int condition)
      Returns the InputMap that is used during condition.
      InputMap InputMap.getParent()
      Gets this InputMap's parent.
      static InputMap SwingUtilities.getUIInputMap(JComponent component, int condition)
      Returns the InputMap provided by the UI for condition condition in component component.
      static InputMap LookAndFeel.makeInputMap(Object[] keys)
      Creates a InputMapUIResource from keys.
      Methods in javax.swing with parameters of type InputMap
      修饰符与类型 方法与描述
      static void LookAndFeel.loadKeyBindings(InputMap retMap, Object[] keys)
      Populates an InputMap with the specified bindings.
      static void SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap)
      Convenience method to change the UI InputMap for component to uiInputMap.
      void JComponent.setInputMap(int condition, InputMap map)
      Sets the InputMap to use under the condition condition to map.
      void ComponentInputMap.setParent(InputMap map)
      Sets the parent, which must be a ComponentInputMap associated with the same component as this ComponentInputMap.
      void InputMap.setParent(InputMap map)
      Sets this InputMap's parent.

    • Uses of InputMap in javax.swing.plaf

      Subclasses of InputMap in javax.swing.plaf
      修饰符与类型 类与描述
      class  ComponentInputMapUIResource
      A subclass of javax.swing.ComponentInputMap that implements UIResource.
      class  InputMapUIResource
      A subclass of javax.swing.InputMap that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fo>l e"=tr> a;<


Uses of Class javax.swing.InputVerifier

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.InputVerifier

  • Packages that use InputVerifier
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of InputVerifier in javax.swing

      Methods in javax.swing that return InputVerifier
      修饰符与类型 方法与描述
      InputVerifier JComponent.getInputVerifier()
      Returns the input verifier for this component.
      Methods in javax.swing with parameters of type InputVerifier
      修饰符与类型 方法与描述
      void JComponent.setInputVerifier(InputVerifier inputVerifier)
      Sets the input verifier for this component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aop wiuu


Uses of Class javax.swing.InternalFrameFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.InternalFrameFocusTraversalPolicy

  • Packages that use InternalFrameFocusTraversalPolicy
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of InternalFrameFocusTraversalPolicy in javax.swing

      Subclasses of InternalFrameFocusTraversalPolicy in javax.swing
      修饰符与类型 类与描述
      class  LayoutFocusTraversalPolicy
      A SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation.
      class  SortingFocusTraversalPolicy
      A FocusTraversalPolicy that determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ceo istsn i cat搓拾霰亏


Uses of Class javax.swing.JApplet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JApplet

No usage of javax.swing.JApplet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shbl. .sb>ae. cfr"a0


Uses of Class javax.swing.JApplet.AccessibleJApplet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JApplet.AccessibleJApplet

No usage of javax.swing.JApplet.AccessibleJApplet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/veat yc oakkgaar>


Uses of Class javax.swing.JButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JButton

  • Packages that use JButton
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JButton in javax.swing

      Fields in javax.swing declared as JButton
      修饰符与类型 字段与描述
      protected JButton JRootPane.defaultButton
      The button that gets activated when the pane has the focus and a UI-specific action like pressing the Enter key occurs.
      Methods in javax.swing that return JButton
      修饰符与类型 方法与描述
      JButton JToolBar.add(Action a)
      Adds a new JButton which dispatches the action.
      protected JButton JToolBar.createActionComponent(Action a)
      Factory method which creates the JButton for Actions added to the JToolBar.
      JButton JRootPane.getDefaultButton()
      Returns the value of the defaultButton property.
      Methods in javax.swing with parameters of type JButton
      修饰符与类型 方法与描述
      protected PropertyChangeListener JToolBar.createActionChangeListener(JButton b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur, or null if the default property change listener for the control is desired.
      void JRootPane.setDefaultButton(JButton defaultButton)
      Sets the defaultButton property, which determines the current default button for this JRootPane.

    • Uses of JButton in javax.swing.plaf

      Methods in javax.swing.plaf that return JButton
      修饰符与类型 方法与描述
      JButton FileChooserUI.getDefaultButton(JFileChooser fc)
      Returns default button for current LookAndFeel.

    • Uses of JButton in javax.swing.plaf.basic

      Subclasses of JButton in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicArrowButton
      JButton object that draws a scaled Arrow in one of the cardinal directions.
      Fields in javax.swing.plaf.basic declared as JButton
      修饰符与类型 | 字段与描述
      protected JButton | BasicComboBoxUI.arrowButton
      protected JButton | BasicInternalFrameTitlePane.closeButton
      protected JButton | BasicScrollBarUI.decrButton
      protected JButton | BasicInternalFrameTitlePane.iconButton
      protected JButton | BasicScrollBarUI.incrButton
      protected JButton BasicSplitPaneDivider.leftButton
      Button for quickly toggling the left component.
      protected JButton | BasicInternalFrameTitlePane.maxButton
      protected JButton BasicSplitPaneDivider.rightButton
      Button for quickly toggling the right component.
      Methods in javax.swing.plaf.basic that return JButton
      修饰符与类型 | 方法与描述
      protected JButton BasicComboBoxUI.createArrowButton()
      Creates a button which will be used as the control to show or hide the popup portion of the combo box.
      protected JButton | BasicScrollBarUI.createDecreaseButton(int orientation)
      protected JButton | BasicScrollBarUI.createIncreaseButton(int orientation)
      protected JButton BasicSplitPaneDivider.createLeftOneTouchButton()
      Creates and return an instance of JButton that can be used to collapse the left component in the split pane.
      protected JButton BasicSplitPaneDivider.createRightOneTouchButton()
      Creates and return an instance of JButton that can be used to collapse the right component in the split pane.
      protected JButton BasicTabbedPaneUI.createScrollButton(int direction)
      Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
      protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)
      JButton | BasicFileChooserUI.getDefaultButton(JFileChooser fc)

    • Uses of JButton in javax.swing.plaf.metal

      Subclasses of JButton in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxButton
      JButton subclass to help out MetalComboBoxUI
      class  MetalScrollButton
      JButton object for Metal scrollbar arrows.
      Methods in javax.swing.plaf.metal that return JButton
      修饰符与类型 | 方法与描述
      protected JButton | MetalComboBoxUI.createArrowButton()
      protected JButton MetalScrollBarUI.createDecreaseButton(int orientation)
      Returns the view that represents the decrease view.
      protected JButton MetalScrollBarUI.createIncreaseButton(int orientation)
      Returns the view that represents the increase view.
      protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)

    • Uses of JButton in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return JButton
      修饰符与类型 | 方法与描述
      protected JButton | SynthComboBoxUI.createArrowButton()
      protected JButton | SynthScrollBarUI.createDecreaseButton(int orientation)
      protected JButton | SynthScrollBarUI.createIncreaseButton(int orientation)
      protected JButton | SynthTabbedPaneUI.createScrollButton(int direction)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/s/.eceeam�n=


Uses of Class javax.swing.JButton.AccessibleJButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JButton.AccessibleJButton

No usage of javax.swing.JButton.AccessibleJButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/ !pgye >tT鎘Ba s/


Uses of Class javax.swing.JCheckBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JCheckBox

  • Packages that use JCheckBox
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JCheckBox in javax.swing

      Constructors in javax.swing with parameters of type JCheckBox
      构造方法与描述
      DefaultCellEditor(JCheckBox checkBox)
      Constructs a DefaultCellEditor object that uses a check box.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"F ina><//h=mlel"


Uses of Class javax.swing.JCheckBox.AccessibleJCheckBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JCheckBox.AccessibleJCheckBox

No usage of javax.swing.JCheckBox.AccessibleJCheckBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ye>//thitooora""" "la


Uses of Class javax.swing.JCheckBoxMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JCheckBoxMenuItem

No usage of javax.swing.JCheckBoxMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drettt-redstt侗E姆�


Uses of Class javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

No usage of javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s pdar&rtaaavtuu."hlg


Uses of Class javax.swing.JColorChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JColorChooser

  • Packages that use JColorChooser
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JColorChooser in javax.swing

      Methods in javax.swing with parameters of type JColorChooser
      修饰符与类型 方法与描述
      static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons.

    • Uses of JColorChooser in javax.swing.colorchooser

      Methods in javax.swing.colorchooser with parameters of type JColorChooser
      修饰符与类型 方法与描述
      void AbstractColorChooserPanel.installChooserPanel(JColorChooser enclosingChooser)
      Invoked when the panel is added to the chooser.
      void AbstractColorChooserPanel.uninstallChooserPanel(JColorChooser enclosingChooser)
      Invoked when the panel is removed from the chooser.

    • Uses of JColorChooser in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JColorChooser
      修饰符与类型 字段与描述
      protected JColorChooser BasicColorChooserUI.chooser
      JColorChooser this BasicColorChooserUI is installed on.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

smg>;favppl> ttrma/.x l


Uses of Class javax.swing.JColorChooser.AccessibleJColorChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JColorChooser.AccessibleJColorChooser

No usage of javax.swing.JColorChooser.AccessibleJColorChooser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se=g� o�/db/>E


Uses of Class javax.swing.JComboBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComboBox

  • Packages that use JComboBox
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JComboBox in javax.swing

      Constructors in javax.swing with parameters of type JComboBox
      构造方法与描述
      DefaultCellEditor(JComboBox comboBox)
      Constructs a DefaultCellEditor object that uses a combo box.

    • Uses of JComboBox in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JComboBox
      修饰符与类型 方法与描述
      abstract boolean ComboBoxUI.isFocusTraversable(JComboBox c)
      Determine whether or not the combo box itself is traversable
      abstract boolean ComboBoxUI.isPopupVisible(JComboBox c)
      Determine the visibility of the popup
      abstract void ComboBoxUI.setPopupVisible(JComboBox c, boolean v)
      Set the visiblity of the popup

    • Uses of JComboBox in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JComboBox
      修饰符与类型 | 字段与描述
      protected JComboBox | BasicComboBoxUI.comboBox
      protected JComboBox | BasicComboPopup.comboBox
      Methods in javax.swing.plaf.basic with parameters of type JComboBox
      修饰符与类型 方法与描述
      boolean BasicComboBoxUI.isFocusTraversable(JComboBox c)
      Determines if the JComboBox is focus traversable.
      boolean BasicComboBoxUI.isPopupVisible(JComboBox c)
      Tells if the popup is visible or not.
      void BasicComboBoxUI.setPopupVisible(JComboBox c, boolean v)
      Hides the popup.
      Constructors in javax.swing.plaf.basic with parameters of type JComboBox
      构造方法与描述
      BasicComboPopup(JComboBox combo)

    • Uses of JComboBox in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as JComboBox
      修饰符与类型 | 字段与描述
      protected JComboBox | MetalComboBoxButton.comboBox
      Methods in javax.swing.plaf.metal that return JComboBox
      修饰符与类型 | 方法与描述
      JComboBox | MetalComboBoxButton.getComboBox()
      Methods in javax.swing.plaf.metal with parameters of type JComboBox
      修饰符与类型 | 方法与描述
      void | MetalComboBoxButton.setComboBox(JComboBox cb)
      Constructors in javax.swing.plaf.metal with parameters of type JComboBox
      构造方法与描述
      MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
      MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
      MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
      Deprecated.

    • Uses of JComboBox in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JComboBox
      修饰符与类型 方法与描述
      boolean MultiComboBoxUI.isFocusTraversable(JComboBox a)
      Invokes the isFocusTraversable method on each UI handled by this object.
      boolean MultiComboBoxUI.isPopupVisible(JComboBox a)
      Invokes the isPopupVisible method on each UI handled by this object.
      void MultiComboBoxUI.setPopupVisible(JComboBox a, boolean b)
      Invokes the setPopupVisible method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

srp.tc"g>>>rlaaag="lh/"tta


Uses of Class javax.swing.JComboBox.AccessibleJComboBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComboBox.AccessibleJComboBox

No usage of javax.swing.JComboBox.AccessibleJComboBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olna..//....=(//L. ta


Uses of Class javax.swing.JComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComponent

  • Packages that use JComponent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of JComponent in javax.swing

      Subclasses of JComponent in javax.swing
      修饰符与类型 类与描述
      class  AbstractButton
      Defines common behaviors for buttons and menu items.
      class  Box
      A lightweight container that uses a BoxLayout object as its layout manager.
      static class  Box.Filler
      An implementation of a lightweight component that participates in layout but has no view.
      class  DefaultListCellRenderer
      Renders an item in a list.
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.
      class  JButton
      An implementation of a "push" button.
      class  JCheckBox
      An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
      class  JCheckBoxMenuItem
      A menu item that can be selected or deselected.
      class  JColorChooser
      JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
      class  JComboBox
      A component that combines a button or editable field and a drop-down list.
      class  JDesktopPane
      A container used to create a multiple-document interface or a virtual desktop.
      class  JEditorPane
      A text component to edit various kinds of content.
      class  JFileChooser
      JFileChooser provides a simple mechanism for the user to choose a file.
      class  JFormattedTextField
      JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
      class  JInternalFrame
      A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
      static class  JInternalFrame.JDesktopIcon
      This component represents an iconified version of a JInternalFrame.
      class  JLabel
      A display area for a short text string or an image, or both.
      class  JLayer<V extends Component>
      JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.
      class  JLayeredPane
      JLayeredPane adds depth to a JFC/Swing container, allowing components to overlap each other when needed.
      class  JList<E>
      A component that displays a list of objects and allows the user to select one or more items.
      class  JMenu
      An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
      class  JMenuBar
      An implementation of a menu bar.
      class  JMenuItem
      An implementation of an item in a menu.
      class  JOptionPane
      JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
      class  JPanel
      JPanel is a generic lightweight container.
      class  JPasswordField
      JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
      class  JPopupMenu
      An implementation of a popup menu -- a small window that pops up and displays a series of choices.
      static class  JPopupMenu.Separator
      A popup menu-specific separator.
      class  JProgressBar
      A component that visually displays the progress of some task.
      class  JRadioButton
      An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
      class  JRadioButtonMenuItem
      An implementation of a radio button menu item.
      class  JRootPane
      A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
      class  JScrollBar
      An implementation of a scrollbar.
      class  JScrollPane
      Provides a scrollable view of a lightweight component.
      protected class  JScrollPane.ScrollBar
      By default JScrollPane creates scrollbars that are instances of this class.
      class  JSeparator
      JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
      class  JSlider
      A component that lets the user graphically select a value by sliding a knob within a bounded interval.
      class  JSpinner
      A single line input field that lets the user select a number or an object value from an ordered sequence.
      static class  JSpinner.DateEditor
      An editor for a JSpinner whose model is a SpinnerDateModel.
      static class  JSpinner.DefaultEditor
      A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
      static class  JSpinner.ListEditor
      An editor for a JSpinner whose model is a SpinnerListModel.
      static class  JSpinner.NumberEditor
      An editor for a JSpinner whose model is a SpinnerNumberModel.
      class  JSplitPane
      JSplitPane is used to divide two (and only two) Components.
      class  JTabbedPane
      A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      class  JTextArea
      A JTextArea is a multi-line area that displays plain text.
      class  JTextField
      JTextField is a lightweight component that allows the editing of a single line of text.
      class  JTextPane
      A text component that can be marked up with attributes that are represented graphically.
      class  JToggleButton
      An implementation of a two-state button.
      class  JToolBar
      JToolBar provides a component that is useful for displaying commonly used Actions or controls.
      static class  JToolBar.Separator
      A toolbar-specific separator.
      class  JToolTip
      Used to display a "Tip" for a Component.
      class  JTree
      A control that displays a set of hierarchical data as an outline.
      class  JViewport
      The "viewport" or "porthole" through which you see the underlying information.
      Fields in javax.swing declared as JComponent
      修饰符与类型 字段与描述
      protected JComponent DefaultCellEditor.editorComponent
      The Swing component being edited.
      Methods in javax.swing that return JComponent
      修饰符与类型 方法与描述
      protected JComponent JSpinner.createEditor(SpinnerModel model)
      This method is called by the constructors to create the JComponent that displays the current value of the sequence.
      JComponent JFileChooser.getAccessory()
      Returns the accessory component.
      JComponent JToolTip.getComponent()
      Returns the component the tooltip applies to.
      JComponent ComponentInputMap.getComponent()
      Returns the component the InputMap was created for.
      JComponent JSpinner.getEditor()
      Returns the component that displays and potentially changes the model's value.
      JComponent JColorChooser.getPreviewPanel()
      Returns the preview panel that shows a chosen color.
      Methods in javax.swing with parameters of type JComponent
      修饰符与类型 | 方法与描述
      void RepaintManager.addDirtyRegion(JComponent c, int x, int y, int w, int h)
      Add a component in the list of components that should be refreshed.
      void RepaintManager.addInvalidComponent(JComponent invalidComponent)
      Mark the component as in need of layout and queue a runnable for the event dispatching thread that will validate the components first isValidateRoot() ancestor.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between two components.
      void | DefaultDesktopManager.beginDraggingFrame(JComponent f)
      void DesktopManager.beginDraggingFrame(JComponent f)
      This method is normally called when the user has indicated that they will begin dragging a component around.
      void | DefaultDesktopManager.beginResizingFrame(JComponent f, int direction)
      void DesktopManager.beginResizingFrame(JComponent f, int direction)
      This methods is normally called when the user has indicated that they will begin resizing the frame.
      static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
      Stores the position and size of the inner painting area of the specified component in r and returns r.
      boolean TransferHandler.canImport(JComponent comp, DataFlavor[] transferFlavors)
      Indicates whether a component will accept an import of the given set of data flavors prior to actually attempting to import it.
      protected Transferable TransferHandler.createTransferable(JComponent c)
      Creates a Transferable to use as the source for a data transfer.
      static RepaintManager RepaintManager.currentManager(JComponent c)
      Return the RepaintManager for the calling thread given a JComponent.
      void DefaultDesktopManager.dragFrame(JComponent f, int newX, int newY)
      Moves the visible location of the frame being dragged to the location specified.
      void DesktopManager.dragFrame(JComponent f, int newX, int newY)
      The user has moved the frame.
      void | DefaultDesktopManager.endDraggingFrame(JComponent f)
      void DesktopManager.endDraggingFrame(JComponent f)
      This method signals the end of the dragging session.
      void | DefaultDesktopManager.endResizingFrame(JComponent f)
      void DesktopManager.endResizingFrame(JComponent f)
      This method signals the end of the resize session.
      void TransferHandler.exportAsDrag(JComponent comp, InputEvent e, int action)
      Causes the Swing drag support to be initiated.
      protected void TransferHandler.exportDone(JComponent source, Transferable data, int action)
      Invoked after data has been exported.
      void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
      Causes a transfer from the given component to the given clipboard.
      abstract int LayoutStyle.getContainerGap(JComponent component, int position, Container parent)
      Returns the amount of space to place between the component and specified edge of its parent.
      Rectangle RepaintManager.getDirtyRegion(JComponent aComponent)
      Return the current dirty region for a component.
      Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      static int JLayeredPane.getLayer(JComponent c)
      Gets the layer property for a JComponent, it does not cause any side effects like setLayer().
      abstract int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
      Returns the amount of space to use between two components.
      int TransferHandler.getSourceActions(JComponent c)
      Returns the type of transfer actions supported by the source; any bitwise-OR combination of COPY, MOVE and LINK.
      static ComponentUI UIManager.getUI(JComponent target)
      Returns the appropriate ComponentUI implementation for target.
      ComponentUI UIDefaults.getUI(JComponent target)
      Creates an ComponentUI implementation for the specified component.
      static ActionMap SwingUtilities.getUIActionMap(JComponent component)
      Returns the ActionMap provided by the UI in component component.
      static InputMap SwingUtilities.getUIInputMap(JComponent component, int condition)
      Returns the InputMap provided by the UI for condition condition in component component.
      boolean TransferHandler.importData(JComponent comp, Transferable t)
      Causes a transfer to a component from a clipboard or a DND drop operation.
      static void LookAndFeel.installBorder(JComponent c, String defaultBorderName)
      Convenience method for setting a component's border property with a value from the defaults.
      static void LookAndFeel.installColors(JComponent c, String defaultBgName, String defaultFgName)
      Convenience method for setting a component's foreground and background color properties with values from the defaults.
      static void LookAndFeel.installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
      Convenience method for setting a component's foreground, background and font properties with values from the defaults.
      static void LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
      Convenience method for installing a property with the specified name and value on a component if that property has not already been set by the developer.
      boolean RepaintManager.isCompletelyDirty(JComponent aComponent)
      Convenience method that returns true if aComponent will be completely painted during the next paintDirtyRegions().
      static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
      static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
      Creates a ComponentInputMapUIResource from keys.
      void RepaintManager.markCompletelyClean(JComponent aComponent)
      Mark a component completely clean.
      void RepaintManager.markCompletelyDirty(JComponent aComponent)
      Mark a component completely dirty.
      static void JLayeredPane.putLayer(JComponent c, int layer)
      Sets the layer property on a JComponent.
      void ToolTipManager.registerComponent(JComponent component)
      Registers a component for tooltip management.
      void RepaintManager.removeInvalidComponent(JComponent component)
      Remove a component from the list of invalid components.
      static void SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap)
      Convenience method to change the UI ActionMap for component to uiActionMap.
      static void SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap)
      Convenience method to change the UI InputMap for component to uiInputMap.
      void DefaultDesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      Calls setBoundsForFrame with the new values.
      void DesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      The user has resized the component.
      void JFileChooser.setAccessory(JComponent newAccessory)
      Sets the accessory component.
      void DefaultDesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      This moves the JComponent and repaints the damaged areas.
      void DesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
      This is a primitive reshape method.
      void JToolTip.setComponent(JComponent c)
      Specifies the component that the tooltip describes.
      void JSpinner.setEditor(JComponent editor)
      Changes the JComponent that displays the current value of the SpinnerModel.
      void JColorChooser.setPreviewPanel(JComponent preview)
      Sets the current preview panel.
      boolean InputVerifier.shouldYieldFocus(JComponent input)
      Calls verify(input) to ensure that the input is valid.
      static void LookAndFeel.uninstallBorder(JComponent c)
      Convenience method for uninstalling a border.
      void ToolTipManager.unregisterComponent(JComponent component)
      Removes a component from tooltip control.
      abstract boolean InputVerifier.verify(JComponent input)
      Checks whether the JComponent's input is valid.
      Constructors in javax.swing with parameters of type JComponent
      构造方法与描述
      ComponentInputMap(JComponent component)
      Creates a ComponentInputMap associated with the specified component.
      DebugGraphics(Graphics graphics, JComponent component)
      Constructs a debug graphics context from an existing graphics context that slows down drawing for the specified component.

    • Uses of JComponent in javax.swing.colorchooser

      Subclasses of JComponent in javax.swing.colorchooser
      修饰符与类型 类与描述
      class  AbstractColorChooserPanel
      This is the abstract superclass for color choosers.
      Methods in javax.swing.colorchooser that return JComponent
      修饰符与类型 | 方法与描述
      static JComponent | ColorChooserComponentFactory.getPreviewPanel()

    • Uses of JComponent in javax.swing.event

      Methods in javax.swing.event that return JComponent
      修饰符与类型 方法与描述
      JComponent AncestorEvent.getComponent()
      Returns the component that the listener was added to.
      Constructors in javax.swing.event with parameters of type JComponent
      构造方法与描述
      AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
      Constructs an AncestorEvent object to identify a change in an ancestor-component's display-status.

    • Uses of JComponent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JComponent
      修饰符与类型 方法与描述
      boolean ComponentUI.contains(JComponent c, int x, int y)
      Returns true if the specified x,y location is contained within the look and feel's defined shape of the specified component.
      static ComponentUI ComponentUI.createUI(JComponent c)
      Returns an instance of the UI delegate for the specified component.
      Accessible ComponentUI.getAccessibleChild(JComponent c, int i)
      Returns the ith Accessible child of the object.
      int ComponentUI.getAccessibleChildrenCount(JComponent c)
      Returns the number of accessible children in the object.
      int LayerUI.getBaseline(JComponent c, int width, int height)
      If the JLayer's view component is not null, this calls the view's getBaseline() method.
      int ComponentUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior LayerUI.getBaselineResizeBehavior(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getBaselineResizeBehavior() method.
      Component.BaselineResizeBehavior ComponentUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of he component changes as the size changes.
      Dimension LayerUI.getMaximumSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getMaximumSize() method.
      Dimension ComponentUI.getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension LayerUI.getMinimumSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getMinimalSize() method.
      Dimension ComponentUI.getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension LayerUI.getPreferredSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getPreferredSize() method.
      Dimension ComponentUI.getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void LayerUI.installUI(JComponent c)
      Configures the JLayer this LayerUI is set to.
      void ComponentUI.installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void LayerUI.paint(Graphics g, JComponent c)
      Paints the specified component.
      void ComponentUI.paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void LayerUI.uninstallUI(JComponent c)
      Reverses the configuration which was previously set in the LayerUI.installUI(JComponent) method.
      void ComponentUI.uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void ComponentUI.update(Graphics g, JComponent c)
      Notifies this UI delegate that it is time to paint the specified component.
      Constructors in javax.swing.plaf with parameters of type JComponent
      构造方法与描述
      ComponentInputMapUIResource(JComponent component)

    • Uses of JComponent in javax.swing.plaf.basic

      Subclasses of JComponent in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicArrowButton
      JButton object that draws a scaled Arrow in one of the cardinal directions.
      class  BasicComboBoxRenderer
      ComboBox renderer
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
      class  BasicComboPopup
      This is a basic implementation of the ComboPopup interface.
      class  BasicInternalFrameTitlePane
      The class that manages a basic title bar
      class  BasicInternalFrameTitlePane.SystemMenuBar
      This class should be treated as a "protected" inner class.
      Fields in javax.swing.plaf.basic declared as JComponent
      修饰符与类型 | 字段与描述
      protected JComponent | BasicInternalFrameUI.eastPane
      protected JComponent BasicDesktopIconUI.iconPane
      The title pane component used in the desktop icon.
      protected JComponent BasicOptionPaneUI.inputComponent
      JComponent provide for input if optionPane.getWantsInput() returns true.
      protected JComponent | BasicInternalFrameUI.northPane
      protected JComponent | BasicInternalFrameUI.southPane
      protected JComponent | BasicInternalFrameUI.westPane
      Methods in javax.swing.plaf.basic that return JComponent
      修饰符与类型 | 方法与描述
      protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
      protected JComponent BasicSpinnerUI.createEditor()
      This method is called by installUI to get the editor component of the JSpinner.
      protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
      JComponent | BasicInternalFrameUI.getEastPane()
      JComponent | BasicInternalFrameUI.getNorthPane()
      JComponent | BasicInternalFrameUI.getSouthPane()
      JComponent | BasicInternalFrameUI.getWestPane()
      Methods in javax.swing.plaf.basic with parameters of type JComponent
      修饰符与类型 | 方法与描述
      protected ChangeListener | BasicMenuUI.createChangeListener(JComponent c)
      static View BasicHTML.createHTMLView(JComponent c, String html)
      Create an html renderer for the given component and string of html.
      protected MenuDragMouseListener | BasicMenuUI.createMenuDragMouseListener(JComponent c)
      protected MenuDragMouseListener | BasicMenuItemUI.createMenuDragMouseListener(JComponent c)
      protected MenuKeyListener | BasicMenuUI.createMenuKeyListener(JComponent c)
      protected MenuKeyListener | BasicMenuItemUI.createMenuKeyListener(JComponent c)
      protected MenuListener | BasicMenuUI.createMenuListener(JComponent c)
      protected MouseInputListener | BasicMenuUI.createMouseInputListener(JComponent c)
      protected MouseInputListener | BasicMenuItemUI.createMouseInputListener(JComponent c)
      protected PropertyChangeListener | BasicMenuUI.createPropertyChangeListener(JComponent c)
      protected PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener(JComponent c)
      Creates a PropertyChangeListener which will be added to the menu item.
      static ComponentUI | BasicViewportUI.createUI(JComponent c)
      static ComponentUI BasicFormattedTextFieldUI.createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      static ComponentUI | BasicCheckBoxUI.createUI(JComponent b)
      static ComponentUI | BasicToolBarSeparatorUI.createUI(JComponent c)
      static ComponentUI | BasicPopupMenuSeparatorUI.createUI(JComponent c)
      static ComponentUI | BasicSeparatorUI.createUI(JComponent c)
      static ComponentUI BasicPasswordFieldUI.createUI(JComponent c)
      Creates a UI for a JPasswordField.
      static ComponentUI | BasicToggleButtonUI.createUI(JComponent b)
      static ComponentUI | BasicRadioButtonUI.createUI(JComponent b)
      static ComponentUI BasicTextPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI | BasicToolTipUI.createUI(JComponent c)
      static ComponentUI | BasicToolBarUI.createUI(JComponent c)
      static ComponentUI BasicTextAreaUI.createUI(JComponent ta)
      Creates a UI for a JTextArea.
      static ComponentUI | BasicTableHeaderUI.createUI(JComponent h)
      static ComponentUI | BasicTableUI.createUI(JComponent c)
      static ComponentUI | BasicTabbedPaneUI.createUI(JComponent c)
      static ComponentUI BasicSpinnerUI.createUI(JComponent c)
      Returns a new instance of BasicSpinnerUI.
      static ComponentUI | BasicSliderUI.createUI(JComponent b)
      static ComponentUI | BasicScrollPaneUI.createUI(JComponent x)
      static ComponentUI | BasicScrollBarUI.createUI(JComponent c)
      static ComponentUI | BasicProgressBarUI.createUI(JComponent x)
      static ComponentUI BasicOptionPaneUI.createUI(JComponent x)
      Creates a new BasicOptionPaneUI instance.
      static ComponentUI | BasicPanelUI.createUI(JComponent c)
      static ComponentUI BasicListUI.createUI(JComponent list)
      Returns a new instance of BasicListUI.
      static ComponentUI | BasicLabelUI.createUI(JComponent c)
      static ComponentUI | BasicInternalFrameUI.createUI(JComponent b)
      static ComponentUI BasicTextFieldUI.createUI(JComponent c)
      Creates a UI for a JTextField.
      static ComponentUI | BasicDesktopIconUI.createUI(JComponent c)
      static ComponentUI | BasicDesktopPaneUI.createUI(JComponent c)
      static ComponentUI | BasicColorChooserUI.createUI(JComponent c)
      static ComponentUI BasicFileChooserUI.createUI(JComponent c)
      Creates a BasicFileChooserUI implementation for the specified component.
      static ComponentUI BasicEditorPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI | BasicMenuBarUI.createUI(JComponent x)
      static ComponentUI | BasicButtonUI.createUI(JComponent c)
      static ComponentUI | BasicRadioButtonMenuItemUI.createUI(JComponent b)
      static ComponentUI | BasicCheckBoxMenuItemUI.createUI(JComponent c)
      static ComponentUI | BasicMenuUI.createUI(JComponent x)
      static ComponentUI | BasicTreeUI.createUI(JComponent x)
      static ComponentUI | BasicRootPaneUI.createUI(JComponent c)
      static ComponentUI | BasicComboBoxUI.createUI(JComponent c)
      static ComponentUI | BasicMenuItemUI.createUI(JComponent c)
      static ComponentUI BasicSplitPaneUI.createUI(JComponent x)
      Creates a new BasicSplitPaneUI instance
      static ComponentUI | BasicPopupMenuUI.createUI(JComponent x)
      protected void | BasicInternalFrameUI.deinstallMouseHandlers(JComponent c)
      Accessible | BasicComboBoxUI.getAccessibleChild(JComponent c, int i)
      int | BasicComboBoxUI.getAccessibleChildrenCount(JComponent c)
      int BasicTextAreaUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicTableHeaderUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicTableUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicTabbedPaneUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicSpinnerUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicSliderUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicScrollPaneUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicProgressBarUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicPanelUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicListUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicLabelUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicTextFieldUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicButtonUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicTreeUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      int BasicComboBoxUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior BasicTextAreaUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicTableUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicSpinnerUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicSliderUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicScrollPaneUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicProgressBarUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicPanelUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicListUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicLabelUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicTextFieldUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicButtonUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicTreeUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Component.BaselineResizeBehavior BasicComboBoxUI.getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Insets | BasicDesktopIconUI.getInsets(JComponent c)
      Insets BasicSplitPaneUI.getInsets(JComponent jc)
      Returns the insets.
      Dimension | BasicSeparatorUI.getMaximumSize(JComponent c)
      Dimension | BasicToolTipUI.getMaximumSize(JComponent c)
      Dimension BasicTableHeaderUI.getMaximumSize(JComponent c)
      Return the maximum size of the header.
      Dimension BasicTableUI.getMaximumSize(JComponent c)
      Return the maximum size of the table.
      Dimension | BasicTabbedPaneUI.getMaximumSize(JComponent c)
      Dimension | BasicSliderUI.getMaximumSize(JComponent c)
      Dimension | BasicScrollPaneUI.getMaximumSize(JComponent c)
      Dimension | BasicScrollBarUI.getMaximumSize(JComponent c)
      Dimension | BasicProgressBarUI.getMaximumSize(JComponent c)
      Dimension | BasicLabelUI.getMaximumSize(JComponent c)
      Dimension | BasicInternalFrameUI.getMaximumSize(JComponent x)
      Dimension BasicDesktopIconUI.getMaximumSize(JComponent c)
      Desktop icons can not be resized.
      Dimension | BasicDesktopPaneUI.getMaximumSize(JComponent c)
      Dimension BasicTextUI.getMaximumSize(JComponent c)
      Gets the maximum size for the editor component.
      Dimension | BasicMenuBarUI.getMaximumSize(JComponent c)
      Dimension | BasicButtonUI.getMaximumSize(JComponent c)
      Dimension | BasicMenuUI.getMaximumSize(JComponent c)
      Dimension BasicTreeUI.getMaximumSize(JComponent c)
      Returns the maximum size for this component, which will be the preferred size if the instance is currently in a JTree, or 0, 0.
      Dimension | BasicComboBoxUI.getMaximumSize(JComponent c)
      Dimension | BasicMenuItemUI.getMaximumSize(JComponent c)
      Dimension BasicSplitPaneUI.getMaximumSize(JComponent jc)
      Returns the maximum size for the passed in component, This is passed off to the current layoutmanager.
      Dimension | BasicSeparatorUI.getMinimumSize(JComponent c)
      Dimension | BasicToolTipUI.getMinimumSize(JComponent c)
      Dimension BasicTextAreaUI.getMinimumSize(JComponent c)
      The method is overridden to take into account caret width.
      Dimension BasicTableHeaderUI.getMinimumSize(JComponent c)
      Return the minimum size of the header.
      Dimension BasicTableUI.getMinimumSize(JComponent c)
      Return the minimum size of the table.
      Dimension | BasicTabbedPaneUI.getMinimumSize(JComponent c)
      Dimension | BasicSliderUI.getMinimumSize(JComponent c)
      Dimension BasicProgressBarUI.getMinimumSize(JComponent c)
      The Minimum size for this component is 10.
      Dimension | BasicLabelUI.getMinimumSize(JComponent c)
      Dimension | BasicInternalFrameUI.getMinimumSize(JComponent x)
      Dimension | BasicDesktopIconUI.getMinimumSize(JComponent c)
      Dimension | BasicDesktopPaneUI.getMinimumSize(JComponent c)
      Dimension BasicTextUI.getMinimumSize(JComponent c)
      Gets the minimum size for the editor component.
      Dimension | BasicMenuBarUI.getMinimumSize(JComponent c)
      Dimension | BasicButtonUI.getMinimumSize(JComponent c)
      Dimension BasicTreeUI.getMinimumSize(JComponent c)
      Returns the minimum size for this component.
      Dimension BasicComboBoxUI.getMinimumSize(JComponent c)
      The minumum size is the size of the display area plus insets plus the button.
      Dimension | BasicMenuItemUI.getMinimumSize(JComponent c)
      Dimension BasicSplitPaneUI.getMinimumSize(JComponent jc)
      Returns the minimum size for the passed in component, This is passed off to the current layoutmanager.
      protected Dimension | BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      Dimension | BasicToolBarSeparatorUI.getPreferredSize(JComponent c)
      Dimension | BasicPopupMenuSeparatorUI.getPreferredSize(JComponent c)
      Dimension | BasicSeparatorUI.getPreferredSize(JComponent c)
      Dimension BasicRadioButtonUI.getPreferredSize(JComponent c)
      The preferred size of the radio button
      Dimension | BasicToolTipUI.getPreferredSize(JComponent c)
      Dimension BasicTextAreaUI.getPreferredSize(JComponent c)
      The method is overridden to take into account caret width.
      Dimension BasicTableHeaderUI.getPreferredSize(JComponent c)
      Return the preferred size of the header.
      Dimension BasicTableUI.getPreferredSize(JComponent c)
      Return the preferred size of the table.
      Dimension | BasicSliderUI.getPreferredSize(JComponent c)
      Dimension BasicScrollBarUI.getPreferredSize(JComponent c)
      A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.
      Dimension | BasicProgressBarUI.getPreferredSize(JComponent c)
      Dimension BasicOptionPaneUI.getPreferredSize(JComponent c)
      If c is the JOptionPane the receiver is contained in, the preferred size that is returned is the maximum of the preferred size of the LayoutManager for the JOptionPane, and getMinimumOptionPaneSize.
      Dimension BasicListUI.getPreferredSize(JComponent c)
      The preferredSize of the list depends upon the layout orientation.
      Dimension | BasicLabelUI.getPreferredSize(JComponent c)
      Dimension | BasicInternalFrameUI.getPreferredSize(JComponent x)
      Dimension | BasicDesktopIconUI.getPreferredSize(JComponent c)
      Dimension | BasicDesktopPaneUI.getPreferredSize(JComponent c)
      Dimension BasicTextUI.getPreferredSize(JComponent c)
      Gets the preferred size for the editor component.
      Dimension | BasicButtonUI.getPreferredSize(JComponent c)
      Dimension BasicTreeUI.getPreferredSize(JComponent c)
      Returns the preferred size to properly display the tree, this is a cover method for getPreferredSize(c, true).
      Dimension | BasicComboBoxUI.getPreferredSize(JComponent c)
      Dimension | BasicMenuItemUI.getPreferredSize(JComponent c)
      Dimension BasicSplitPaneUI.getPreferredSize(JComponent jc)
      Returns the preferred size for the passed in component, This is passed off to the current layoutmanager.
      Dimension BasicTreeUI.getPreferredSize(JComponent c, boolean checkConsistency)
      Returns the preferred size to represent the tree in c.
      protected void | BasicViewportUI.installDefaults(JComponent c)
      protected void | BasicToolTipUI.installDefaults(JComponent c)
      void BasicButtonListener.installKeyboardActions(JComponent c)
      Register default key actions: pressing space to "click" a button and registring the keyboard mnemonic (if any).
      protected void | BasicToolTipUI.installListeners(JComponent c)
      protected void | BasicInternalFrameUI.installMouseHandlers(JComponent c)
      protected void BasicToolBarUI.installNonRolloverBorders(JComponent c)
      Installs non-rollover borders on all the child components of the JComponent.
      protected void BasicToolBarUI.installNormalBorders(JComponent c)
      Installs normal borders on all the child components of the JComponent.
      protected void BasicToolBarUI.installRolloverBorders(JComponent c)
      Installs rollover borders on all the child components of the JComponent.
      void | BasicViewportUI.installUI(JComponent c)
      void | BasicSeparatorUI.installUI(JComponent c)
      void | BasicTextPaneUI.installUI(JComponent c)
      void | BasicToolTipUI.installUI(JComponent c)
      void | BasicToolBarUI.installUI(JComponent c)
      void | BasicTableHeaderUI.installUI(JComponent c)
      void | BasicTableUI.installUI(JComponent c)
      void | BasicTabbedPaneUI.installUI(JComponent c)
      void BasicSpinnerUI.installUI(JComponent c)
      Calls installDefaults, installListeners, and then adds the components returned by createNextButton, createPreviousButton, and createEditor.
      void | BasicSliderUI.installUI(JComponent c)
      void | BasicScrollPaneUI.installUI(JComponent x)
      void | BasicScrollBarUI.installUI(JComponent c)
      void | BasicProgressBarUI.installUI(JComponent c)
      void BasicOptionPaneUI.installUI(JComponent c)
      Installs the receiver as the L&F for the passed in JOptionPane.
      void | BasicPanelUI.installUI(JComponent c)
      void BasicListUI.installUI(JComponent c)
      Initializes this.list by calling installDefaults(), installListeners(), and installKeyboardActions() in order.
      void | BasicLabelUI.installUI(JComponent c)
      void | BasicInternalFrameUI.installUI(JComponent c)
      void | BasicDesktopIconUI.installUI(JComponent c)
      void | BasicDesktopPaneUI.installUI(JComponent c)
      void | BasicColorChooserUI.installUI(JComponent c)
      void | BasicFileChooserUI.installUI(JComponent c)
      void BasicEditorPaneUI.installUI(JComponent c)
      Installs the UI for a component.
      void BasicTextUI.installUI(JComponent c)
      Installs the UI for a component.
      void | BasicMenuBarUI.installUI(JComponent c)
      void | BasicButtonUI.installUI(JComponent c)
      void | BasicTreeUI.installUI(JComponent c)
      void | BasicRootPaneUI.installUI(JComponent c)
      void | BasicComboBoxUI.installUI(JComponent c)
      void | BasicMenuItemUI.installUI(JComponent c)
      void BasicSplitPaneUI.installUI(JComponent c)
      Installs the UI.
      void | BasicPopupMenuUI.installUI(JComponent c)
      void | BasicDesktopIconUI.MouseInputHandler.moveAndRepaint(JComponent f, int newX, int newY, int newWidth, int newHeight)
      void | BasicToolBarSeparatorUI.paint(Graphics g, JComponent c)
      void | BasicPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
      void | BasicSeparatorUI.paint(Graphics g, JComponent c)
      void | BasicToggleButtonUI.paint(Graphics g, JComponent c)
      void BasicRadioButtonUI.paint(Graphics g, JComponent c)
      paint the radio button
      void | BasicToolTipUI.paint(Graphics g, JComponent c)
      void | BasicTableHeaderUI.paint(Graphics g, JComponent c)
      void BasicTableUI.paint(Graphics g, JComponent c)
      Paint a representation of the table instance that was set in installUI().
      void | BasicTabbedPaneUI.paint(Graphics g, JComponent c)
      void | BasicSliderUI.paint(Graphics g, JComponent c)
      void | BasicScrollPaneUI.paint(Graphics g, JComponent c)
      void | BasicScrollBarUI.paint(Graphics g, JComponent c)
      void BasicProgressBarUI.paint(Graphics g, JComponent c)
      Delegates painting to one of two methods: paintDeterminate or paintIndeterminate.
      void BasicListUI.paint(Graphics g, JComponent c)
      Paint the rows that intersect the Graphics objects clipRect.
      void BasicLabelUI.paint(Graphics g, JComponent c)
      Paints the label text with the foreground color, if the label is opaque then paints the entire background with the background color.
      void | BasicDesktopPaneUI.paint(Graphics g, JComponent c)
      void BasicTextUI.paint(Graphics g, JComponent c)
      Paints the interface.
      void | BasicButtonUI.paint(Graphics g, JComponent c)
      void | BasicTreeUI.paint(Graphics g, JComponent c)
      void | BasicComboBoxUI.paint(Graphics g, JComponent c)
      void | BasicMenuItemUI.paint(Graphics g, JComponent c)
      void | BasicSplitPaneUI.paint(Graphics g, JComponent jc)
      protected void BasicProgressBarUI.paintDeterminate(Graphics g, JComponent c)
      All purpose paint method that should do the right thing for almost all linear, determinate progress bars.
      protected void BasicTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
      Paints a horizontal line.
      protected void | BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
      protected void BasicProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
      All purpose paint method that should do the right thing for all linear bouncing-box progress bars.
      protected void | BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
      protected void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      As of Java 2 platform v 1.4 this method should not be used or overriden.
      protected void | BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
      protected void | BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
      protected void BasicTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
      Paints a vertical line.
      protected void BasicSpinnerUI.replaceEditor(JComponent oldEditor, JComponent newEditor)
      Called by the PropertyChangeListener when the JSpinner editor property changes.
      protected void BasicInternalFrameUI.replacePane(JComponent currentPane, JComponent newPane)
      Installs necessary mouse handlers on newPane and adds it to the frame.
      void | BasicInternalFrameUI.setEastPane(JComponent c)
      void | BasicInternalFrameUI.setNorthPane(JComponent c)
      void | BasicInternalFrameUI.setSouthPane(JComponent c)
      void | BasicInternalFrameUI.setWestPane(JComponent c)
      protected void | BasicViewportUI.uninstallDefaults(JComponent c)
      protected void | BasicToolTipUI.uninstallDefaults(JComponent c)
      void BasicButtonListener.uninstallKeyboardActions(JComponent c)
      Unregister's default key actions
      protected void | BasicToolTipUI.uninstallListeners(JComponent c)
      protected void | BasicScrollPaneUI.uninstallListeners(JComponent c)
      void | BasicViewportUI.uninstallUI(JComponent c)
      void | BasicSeparatorUI.uninstallUI(JComponent c)
      void | BasicToolTipUI.uninstallUI(JComponent c)
      void | BasicToolBarUI.uninstallUI(JComponent c)
      void | BasicTableHeaderUI.uninstallUI(JComponent c)
      void | BasicTableUI.uninstallUI(JComponent c)
      void | BasicTabbedPaneUI.uninstallUI(JComponent c)
      void BasicSpinnerUI.uninstallUI(JComponent c)
      Calls uninstallDefaults, uninstallListeners, and then removes all of the spinners children.
      void | BasicSliderUI.uninstallUI(JComponent c)
      void | BasicScrollPaneUI.uninstallUI(JComponent c)
      void | BasicScrollBarUI.uninstallUI(JComponent c)
      void | BasicProgressBarUI.uninstallUI(JComponent c)
      void BasicOptionPaneUI.uninstallUI(JComponent c)
      Removes the receiver from the L&F controller of the passed in split pane.
      void | BasicPanelUI.uninstallUI(JComponent c)
      void BasicListUI.uninstallUI(JComponent c)
      Uninitializes this.list by calling uninstallListeners(), uninstallKeyboardActions(), and uninstallDefaults() in order.
      void | BasicLabelUI.uninstallUI(JComponent c)
      void | BasicInternalFrameUI.uninstallUI(JComponent c)
      void | BasicDesktopIconUI.uninstallUI(JComponent c)
      void | BasicDesktopPaneUI.uninstallUI(JComponent c)
      void | BasicColorChooserUI.uninstallUI(JComponent c)
      void | BasicFileChooserUI.uninstallUI(JComponent c)
      void BasicEditorPaneUI.uninstallUI(JComponent c)
      Deinstalls the UI for a component.
      void BasicTextUI.uninstallUI(JComponent c)
      Deinstalls the UI for a component.
      void | BasicMenuBarUI.uninstallUI(JComponent c)
      void | BasicButtonUI.uninstallUI(JComponent c)
      void | BasicTreeUI.uninstallUI(JComponent c)
      void | BasicRootPaneUI.uninstallUI(JComponent c)
      void | BasicComboBoxUI.uninstallUI(JComponent c)
      void | BasicMenuItemUI.uninstallUI(JComponent c)
      void BasicSplitPaneUI.uninstallUI(JComponent c)
      Uninstalls the UI.
      void | BasicPopupMenuUI.uninstallUI(JComponent c)
      void BasicTextUI.update(Graphics g, JComponent c)
      Superclass paints background in an uncontrollable way (i.e.
      void BasicMenuItemUI.update(Graphics g, JComponent c)
      We draw the background in paintMenuItem() so override update (which fills the background of opaque components by default) to just call paint().
      static void BasicHTML.updateRenderer(JComponent c, String text)
      Stash the HTML render for the given text into the client properties of the given JComponent.

    • Uses of JComponent in javax.swing.plaf.metal

      Subclasses of JComponent in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      class  MetalComboBoxButton
      JButton subclass to help out MetalComboBoxUI
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.
      protected class  | MetalFileChooserUI.FileRenderer
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.
      class  MetalInternalFrameTitlePane
      Class that manages a JLF title bar
      class  MetalScrollButton
      JButton object for Metal scrollbar arrows.
      Methods in javax.swing.plaf.metal that return JComponent
      修饰符与类型 | 方法与描述
      protected JComponent | MetalInternalFrameUI.createNorthPane(JInternalFrame w)
      Methods in javax.swing.plaf.metal with parameters of type JComponent
      修饰符与类型 | 方法与描述
      static ComponentUI | MetalToolTipUI.createUI(JComponent c)
      static ComponentUI | MetalToolBarUI.createUI(JComponent c)
      static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
      static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
      static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
      static ComponentUI MetalSplitPaneUI.createUI(JComponent x)
      Creates a new MetalSplitPaneUI instance
      static ComponentUI | MetalTreeUI.createUI(JComponent x)
      static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
      static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
      static ComponentUI MetalRootPaneUI.createUI(JComponent c)
      Creates a UI for a JRootPane.
      static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
      static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
      static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
      static ComponentUI MetalMenuBarUI.createUI(JComponent x)
      Creates the ComponentUI implementation for the passed in component.
      static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
      static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
      static ComponentUI | MetalSliderUI.createUI(JComponent c)
      static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
      static ComponentUI | MetalLabelUI.createUI(JComponent c)
      static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
      static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
      static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
      static ComponentUI | MetalButtonUI.createUI(JComponent c)
      int MetalComboBoxUI.getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Icon MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      Dimension MetalFileChooserUI.getMaximumSize(JComponent c)
      Returns the maximum size of the JFileChooser.
      Dimension | MetalDesktopIconUI.getMaximumSize(JComponent c)
      Dimension MetalFileChooserUI.getMinimumSize(JComponent c)
      Returns the minimum size of the JFileChooser.
      Dimension | MetalDesktopIconUI.getMinimumSize(JComponent c)
      Dimension | MetalComboBoxUI.getMinimumSize(JComponent c)
      Dimension | MetalToolTipUI.getPreferredSize(JComponent c)
      Dimension | MetalScrollBarUI.getPreferredSize(JComponent c)
      Dimension | MetalSeparatorUI.getPreferredSize(JComponent c)
      Dimension | MetalPopupMenuSeparatorUI.getPreferredSize(JComponent c)
      Dimension MetalFileChooserUI.getPreferredSize(JComponent c)
      Returns the preferred size of the specified JFileChooser.
      Dimension | MetalDesktopIconUI.getPreferredSize(JComponent c)
      void | MetalToolTipUI.installUI(JComponent c)
      void | MetalToolBarUI.installUI(JComponent c)
      void | MetalTreeUI.installUI(JComponent c)
      void | MetalScrollPaneUI.installUI(JComponent c)
      void MetalRootPaneUI.installUI(JComponent c)
      Invokes supers implementation of installUI to install the necessary state onto the passed in JRootPane to render the metal look and feel implementation of RootPaneUI.
      void MetalMenuBarUI.installUI(JComponent c)
      Configures the specified component appropriate for the metal look and feel.
      void | MetalInternalFrameUI.installUI(JComponent c)
      void | MetalFileChooserUI.installUI(JComponent c)
      void | MetalSliderUI.installUI(JComponent c)
      void | MetalToolTipUI.paint(Graphics g, JComponent c)
      void | MetalTabbedPaneUI.paint(Graphics g, JComponent c)
      void | MetalTreeUI.paint(Graphics g, JComponent c)
      void | MetalSeparatorUI.paint(Graphics g, JComponent c)
      void | MetalPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
      void | MetalComboBoxUI.paint(Graphics g, JComponent c)
      void | MetalRadioButtonUI.paint(Graphics g, JComponent c)
      void MetalProgressBarUI.paintDeterminate(Graphics g, JComponent c)
      Draws a bit of special highlighting on the progress bar.
      protected void | MetalTreeUI.paintHorizontalSeparators(Graphics g, JComponent c)
      void MetalProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
      Draws a bit of special highlighting on the progress bar and bouncing box.
      protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
      protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
      protected void | MetalScrollPaneUI.uninstallListeners(JComponent c)
      void | MetalToolTipUI.uninstallUI(JComponent c)
      void | MetalToolBarUI.uninstallUI(JComponent c)
      void | MetalTreeUI.uninstallUI(JComponent c)
      void | MetalScrollPaneUI.uninstallUI(JComponent c)
      void MetalRootPaneUI.uninstallUI(JComponent c)
      Invokes supers implementation to uninstall any of its state.
      void MetalMenuBarUI.uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void | MetalInternalFrameUI.uninstallUI(JComponent c)
      void | MetalFileChooserUI.uninstallUI(JComponent c)
      void MetalToolBarUI.update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.
      void MetalToggleButtonUI.update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.
      void | MetalTabbedPaneUI.update(Graphics g, JComponent c)
      void MetalMenuBarUI.update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.
      void MetalButtonUI.update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.

    • Uses of JComponent in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JComponent
      修饰符与类型 方法与描述
      boolean MultiViewportUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiTreeUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiToolTipUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiToolBarUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiTextUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiTableUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiTableHeaderUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiTabbedPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiSplitPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiSpinnerUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiSliderUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiSeparatorUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiScrollPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiScrollBarUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiRootPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiProgressBarUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiPopupMenuUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiPanelUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiOptionPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiMenuItemUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiMenuBarUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiListUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiLabelUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiInternalFrameUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiFileChooserUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiDesktopPaneUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiDesktopIconUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiComboBoxUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiColorChooserUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean MultiButtonUI.contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI MultiViewportUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTreeUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiToolTipUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiToolBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTextUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTableUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTableHeaderUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTabbedPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSplitPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSpinnerUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSliderUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSeparatorUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiScrollPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiScrollBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiRootPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiProgressBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiPopupMenuUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiPanelUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiOptionPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiMenuItemUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiMenuBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiListUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiLabelUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiInternalFrameUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiFileChooserUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiDesktopPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiDesktopIconUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiComboBoxUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiColorChooserUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiButtonUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target)
      Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.
      Accessible MultiViewportUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiTreeUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiToolTipUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiToolBarUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiTextUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiTableUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiTableHeaderUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiTabbedPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiSplitPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiSpinnerUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiSliderUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiSeparatorUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiScrollPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiScrollBarUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiRootPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiProgressBarUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiPopupMenuUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiPanelUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiOptionPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiMenuItemUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiMenuBarUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiListUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiLabelUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiInternalFrameUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiFileChooserUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiDesktopPaneUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiDesktopIconUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiComboBoxUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiColorChooserUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      Accessible MultiButtonUI.getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int MultiViewportUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiTreeUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiToolTipUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiToolBarUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiTextUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiTableUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiTableHeaderUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiTabbedPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiSplitPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiSpinnerUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiSliderUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiSeparatorUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiScrollPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiScrollBarUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiRootPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiProgressBarUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiPopupMenuUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiPanelUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiOptionPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiMenuItemUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiMenuBarUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiListUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiLabelUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiInternalFrameUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiFileChooserUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiDesktopPaneUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiDesktopIconUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiComboBoxUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiColorChooserUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int MultiButtonUI.getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension MultiViewportUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiTreeUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiToolTipUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiToolBarUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiTextUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiTableUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiTableHeaderUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiTabbedPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiSplitPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiSpinnerUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiSliderUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiSeparatorUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiScrollPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiScrollBarUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiRootPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiProgressBarUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiPopupMenuUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiPanelUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiOptionPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiMenuItemUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiMenuBarUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiListUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiLabelUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiInternalFrameUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiFileChooserUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiDesktopPaneUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiDesktopIconUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiComboBoxUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiColorChooserUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiButtonUI.getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension MultiViewportUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiTreeUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiToolTipUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiToolBarUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiTextUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiTableUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiTableHeaderUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiTabbedPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiSplitPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiSpinnerUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiSliderUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiSeparatorUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiScrollPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiScrollBarUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiRootPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiProgressBarUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiPopupMenuUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiPanelUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiOptionPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiMenuItemUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiMenuBarUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiListUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiLabelUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiInternalFrameUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiFileChooserUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiDesktopPaneUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiDesktopIconUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiComboBoxUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiColorChooserUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiButtonUI.getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension MultiViewportUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiTreeUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiToolTipUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiToolBarUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiTextUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiTableUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiTableHeaderUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiTabbedPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiSplitPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiSpinnerUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiSliderUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiSeparatorUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiScrollPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiScrollBarUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiRootPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiProgressBarUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiPopupMenuUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiPanelUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiOptionPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiMenuItemUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiMenuBarUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiListUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiLabelUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiInternalFrameUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiFileChooserUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiDesktopPaneUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiDesktopIconUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiComboBoxUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiColorChooserUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Dimension MultiButtonUI.getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      void MultiViewportUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiTreeUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiToolTipUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiToolBarUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiTextUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiTableUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiTableHeaderUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiTabbedPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiSplitPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiSpinnerUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiSliderUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiSeparatorUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiScrollPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiScrollBarUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiRootPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiProgressBarUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiPopupMenuUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiPanelUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiOptionPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiMenuItemUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiMenuBarUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiListUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiLabelUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiInternalFrameUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiFileChooserUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiDesktopPaneUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiDesktopIconUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiComboBoxUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiColorChooserUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiButtonUI.installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void MultiViewportUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiTreeUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiToolTipUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiToolBarUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiTextUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiTableUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiTableHeaderUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiTabbedPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiSplitPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiSpinnerUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiSliderUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiSeparatorUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiScrollPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiScrollBarUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiRootPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiProgressBarUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiPopupMenuUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiPanelUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiOptionPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiMenuItemUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiMenuBarUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiListUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiLabelUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiInternalFrameUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiFileChooserUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiDesktopPaneUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiDesktopIconUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiComboBoxUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiColorChooserUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiButtonUI.paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void MultiViewportUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiTreeUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiToolTipUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiToolBarUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiTextUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiTableUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiTableHeaderUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiTabbedPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiSplitPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiSpinnerUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiSliderUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiSeparatorUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiScrollPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiScrollBarUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiRootPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiProgressBarUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiPopupMenuUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiPanelUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiOptionPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiMenuItemUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiMenuBarUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiListUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiLabelUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiInternalFrameUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiFileChooserUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiDesktopPaneUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiDesktopIconUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiComboBoxUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiColorChooserUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiButtonUI.uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void MultiViewportUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiTreeUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiToolTipUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiToolBarUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiTextUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiTableUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiTableHeaderUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiTabbedPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiSplitPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiSpinnerUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiSliderUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiSeparatorUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiScrollPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiScrollBarUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiRootPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiProgressBarUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiPopupMenuUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiPanelUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiOptionPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiMenuItemUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiMenuBarUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiListUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiLabelUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiInternalFrameUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiFileChooserUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiDesktopPaneUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiDesktopIconUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiComboBoxUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiColorChooserUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      void MultiButtonUI.update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

    • Uses of JComponent in javax.swing.plaf.nimbus

      Classes in javax.swing.plaf.nimbus with type parameters of type JComponent
      修饰符与类型 类与描述
      class  State<T extends JComponent>
      Represents a built in, or custom, state in Nimbus.
      Methods in javax.swing.plaf.nimbus with parameters of type JComponent
      修饰符与类型 | 方法与描述
      protected abstract void AbstractRegionPainter.doPaint(Graphics2D g, JComponent c, int width, int height, Object[] extendedCacheKeys)
      Actually performs the painting operation.
      protected Color AbstractRegionPainter.getComponentColor(JComponent c, String property, Color defaultColor, float saturationOffset, float brightnessOffset, int alphaOffset)
      Get a color property from the given JComponent.
      Icon | NimbusLookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      protected Object[] AbstractRegionPainter.getExtendedCacheKeys(JComponent c)
      Get any extra attributes which the painter implementation would like to include in the image cache lookups.
      static NimbusStyle NimbusLookAndFeel.getStyle(JComponent c, Region r)
      Gets the style associated with the given component and region.
      void | AbstractRegionPainter.paint(Graphics2D g, JComponent c, int w, int h)

    • Uses of JComponent in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return JComponent
      修饰符与类型 | 方法与描述
      protected JComponent SynthSpinnerUI.createEditor()
      This method is called by installUI to get the editor component of the JSpinner.
      protected JComponent | SynthInternalFrameUI.createNorthPane(JInternalFrame w)
      JComponent SynthContext.getComponent()
      Returns the hosting component containing the region.
      Methods in javax.swing.plaf.synth with parameters of type JComponent
      修饰符与类型 | 方法与描述
      static ComponentUI SynthViewportUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTreeUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthToolTipUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthToolBarUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTextPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI SynthTextAreaUI.createUI(JComponent ta)
      Creates a UI object for a JTextArea.
      static ComponentUI SynthTableHeaderUI.createUI(JComponent h)
      Creates a new UI object for the given component.
      static ComponentUI SynthTableUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTabbedPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthSplitPaneUI.createUI(JComponent x)
      Creates a new SynthSplitPaneUI instance
      static ComponentUI SynthSpinnerUI.createUI(JComponent c)
      Returns a new instance of SynthSpinnerUI.
      static ComponentUI SynthSliderUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthScrollPaneUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI | SynthScrollBarUI.createUI(JComponent c)
      static ComponentUI SynthRootPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthRadioButtonMenuItemUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthProgressBarUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthPopupMenuUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthPasswordFieldUI.createUI(JComponent c)
      Creates a UI for a JPasswordField.
      static ComponentUI SynthSeparatorUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthPanelUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthOptionPaneUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuBarUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthListUI.createUI(JComponent list)
      Creates a new UI object for the given component.
      static ComponentUI SynthInternalFrameUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthTextFieldUI.createUI(JComponent c)
      Creates a UI for a JTextField.
      static ComponentUI SynthFormattedTextFieldUI.createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      static ComponentUI SynthEditorPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthDesktopIconUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthDesktopPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthComboBoxUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthLabelUI.createUI(JComponent c)
      Returns the LabelUI implementation used for the skins look and feel.
      static ComponentUI SynthColorChooserUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuItemUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthCheckBoxMenuItemUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthToggleButtonUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthRadioButtonUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthCheckBoxUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthButtonUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthLookAndFeel.createUI(JComponent c)
      Creates the Synth look and feel ComponentUI for the passed in JComponent.
      int | SynthSliderUI.getBaseline(JComponent c, int width, int height)
      int | SynthProgressBarUI.getBaseline(JComponent c, int width, int height)
      int | SynthLabelUI.getBaseline(JComponent c, int width, int height)
      int | SynthButtonUI.getBaseline(JComponent c, int width, int height)
      SynthContext | SynthViewportUI.getContext(JComponent c)
      SynthContext | SynthTreeUI.getContext(JComponent c)
      SynthContext | SynthToolTipUI.getContext(JComponent c)
      SynthContext | SynthToolBarUI.getContext(JComponent c)
      SynthContext | SynthTextAreaUI.getContext(JComponent c)
      SynthContext | SynthTableHeaderUI.getContext(JComponent c)
      SynthContext | SynthTableUI.getContext(JComponent c)
      SynthContext | SynthTabbedPaneUI.getContext(JComponent c)
      SynthContext | SynthSplitPaneUI.getContext(JComponent c)
      SynthContext | SynthSpinnerUI.getContext(JComponent c)
      SynthContext | SynthSliderUI.getContext(JComponent c)
      SynthContext | SynthScrollPaneUI.getContext(JComponent c)
      SynthContext | SynthScrollBarUI.getContext(JComponent c)
      SynthContext | SynthRootPaneUI.getContext(JComponent c)
      SynthContext | SynthProgressBarUI.getContext(JComponent c)
      SynthContext | SynthPopupMenuUI.getContext(JComponent c)
      SynthContext | SynthSeparatorUI.getContext(JComponent c)
      SynthContext | SynthPanelUI.getContext(JComponent c)
      SynthContext | SynthOptionPaneUI.getContext(JComponent c)
      SynthContext | SynthMenuUI.getContext(JComponent c)
      SynthContext | SynthMenuBarUI.getContext(JComponent c)
      SynthContext | SynthListUI.getContext(JComponent c)
      SynthContext | SynthInternalFrameUI.getContext(JComponent c)
      SynthContext | SynthTextFieldUI.getContext(JComponent c)
      SynthContext | SynthEditorPaneUI.getContext(JComponent c)
      SynthContext | SynthDesktopIconUI.getContext(JComponent c)
      SynthContext | SynthDesktopPaneUI.getContext(JComponent c)
      SynthContext | SynthComboBoxUI.getContext(JComponent c)
      SynthContext | SynthLabelUI.getContext(JComponent c)
      SynthContext | SynthColorChooserUI.getContext(JComponent c)
      SynthContext | SynthMenuItemUI.getContext(JComponent c)
      SynthContext | SynthButtonUI.getContext(JComponent c)
      SynthContext SynthUI.getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension | SynthSeparatorUI.getMaximumSize(JComponent c)
      Dimension | SynthLabelUI.getMaximumSize(JComponent c)
      Dimension | SynthButtonUI.getMaximumSize(JComponent c)
      Dimension | SynthSliderUI.getMinimumSize(JComponent c)
      Dimension | SynthSeparatorUI.getMinimumSize(JComponent c)
      Dimension | SynthLabelUI.getMinimumSize(JComponent c)
      Dimension | SynthButtonUI.getMinimumSize(JComponent c)
      protected Dimension | SynthMenuUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      protected Dimension | SynthMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      Dimension | SynthToolTipUI.getPreferredSize(JComponent c)
      Dimension | SynthSliderUI.getPreferredSize(JComponent c)
      Dimension SynthScrollBarUI.getPreferredSize(JComponent c)
      A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.
      Dimension | SynthProgressBarUI.getPreferredSize(JComponent c)
      Dimension | SynthSeparatorUI.getPreferredSize(JComponent c)
      Dimension | SynthLabelUI.getPreferredSize(JComponent c)
      Dimension | SynthButtonUI.getPreferredSize(JComponent c)
      static Region SynthLookAndFeel.getRegion(JComponent c)
      Returns the Region for the JComponent c.
      abstract SynthStyle SynthStyleFactory.getStyle(JComponent c, Region id)
      Returns the style for the specified Component.
      static SynthStyle SynthLookAndFeel.getStyle(JComponent c, Region region)
      Gets a SynthStyle for the specified region of the specified component.
      protected void SynthViewportUI.installDefaults(JComponent c)
      Installs defaults for a viewport.
      protected void | SynthToolTipUI.installDefaults(JComponent c)
      protected void SynthViewportUI.installListeners(JComponent c)
      Installs listeners into the viewport.
      protected void | SynthToolTipUI.installListeners(JComponent c)
      void | SynthViewportUI.installUI(JComponent c)
      void SynthTextPaneUI.installUI(JComponent c)
      Installs the UI for a component.
      void | SynthSeparatorUI.installUI(JComponent c)
      void | SynthPanelUI.installUI(JComponent c)
      void | SynthComboBoxUI.installUI(JComponent c)
      void SynthViewportUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthTreeUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthToolTipUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthToolBarUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthTableHeaderUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthTableUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthTabbedPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthSplitPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthSpinnerUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthSliderUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthScrollPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthScrollBarUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthRootPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthProgressBarUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthPopupMenuUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthSeparatorUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthPanelUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthOptionPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthMenuUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthMenuBarUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthInternalFrameUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthDesktopIconUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthDesktopPaneUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthComboBoxUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthLabelUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthColorChooserUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthMenuItemUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      void SynthButtonUI.paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void | SynthTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
      protected void | SynthTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
      protected void SynthSpinnerUI.replaceEditor(JComponent oldEditor, JComponent newEditor)
      Called by the PropertyChangeListener when the JSpinner editor property changes.
      protected void SynthViewportUI.uninstallDefaults(JComponent c)
      Uninstalls defaults from a viewport.
      protected void | SynthToolTipUI.uninstallDefaults(JComponent c)
      protected void SynthViewportUI.uninstallListeners(JComponent c)
      Uninstalls listeners from the viewport.
      protected void | SynthToolTipUI.uninstallListeners(JComponent c)
      protected void | SynthScrollPaneUI.uninstallListeners(JComponent c)
      void | SynthViewportUI.uninstallUI(JComponent c)
      void | SynthSeparatorUI.uninstallUI(JComponent c)
      void | SynthPanelUI.uninstallUI(JComponent c)
      void | SynthMenuUI.uninstallUI(JComponent c)
      void | SynthComboBoxUI.uninstallUI(JComponent c)
      void | SynthMenuItemUI.uninstallUI(JComponent c)
      void SynthViewportUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTreeUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthToolTipUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthToolBarUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTextAreaUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTableHeaderUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTableUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTabbedPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthSplitPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthSpinnerUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthSliderUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthScrollPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthScrollBarUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthRootPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthProgressBarUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthPopupMenuUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthSeparatorUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthPanelUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthOptionPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthMenuUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthMenuBarUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthListUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthInternalFrameUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthTextFieldUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthEditorPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthDesktopIconUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthDesktopPaneUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthComboBoxUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthLabelUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthColorChooserUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthMenuItemUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      void SynthButtonUI.update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      Constructors in javax.swing.plaf.synth with parameters of type JComponent
      构造方法与描述
      SynthContext(JComponent component, Region region, SynthStyle style, int state)
      Creates a SynthContext with the specified values.

    • Uses of JComponent in javax.swing.table

      Subclasses of JComponent in javax.swing.table
      修饰符与类型 类与描述
      class  DefaultTableCellRenderer
      The standard class for rendering (displaying) individual cells in a JTable.
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.
      class  JTableHeader
      This is the object which manages the header of the JTable.

    • Uses of JComponent in javax.swing.text

      Subclasses of JComponent in javax.swing.text
      修饰符与类型 类与描述
      class  JTextComponent
      JTextComponent is the base class for swing text components.

    • Uses of JComponent in javax.swing.tree

      Subclasses of JComponent in javax.swing.tree
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.JComponent.AccessibleJComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComponent.AccessibleJComponent

  • Packages that use JComponent.AccessibleJComponent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JComponent.AccessibleJComponent in javax.swing

      Subclasses of JComponent.AccessibleJComponent in javax.swing
      修饰符与类型 类与描述
      protected class  AbstractButton.AccessibleAbstractButton
      This class implements accessibility support for the AbstractButton class.
      protected class  JButton.AccessibleJButton
      This class implements accessibility support for the JButton class.
      protected class  JCheckBox.AccessibleJCheckBox
      This class implements accessibility support for the JCheckBox class.
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      This class implements accessibility support for the JCheckBoxMenuItem class.
      protected class  JColorChooser.AccessibleJColorChooser
      This class implements accessibility support for the JColorChooser class.
      protected class  JComboBox.AccessibleJComboBox
      This class implements accessibility support for the JComboBox class.
      protected class  JDesktopPane.AccessibleJDesktopPane
      This class implements accessibility support for the JDesktopPane class.
      protected class  JEditorPane.AccessibleJEditorPane
      This class implements accessibility support for the JEditorPane class.
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
      protected class  JFileChooser.AccessibleJFileChooser
      This class implements accessibility support for the JFileChooser class.
      protected class  JInternalFrame.AccessibleJInternalFrame
      This class implements accessibility support for the JInternalFrame class.
      protected class  JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
      This class implements accessibility support for the JInternalFrame.JDesktopIcon class.
      protected class  JLabel.AccessibleJLabel
      The class used to obtain the accessible role for this object.
      protected class  JLayeredPane.AccessibleJLayeredPane
      This class implements accessibility support for the JLayeredPane class.
      protected class  JList.AccessibleJList
      This class implements accessibility support for the JList class.
      protected class  JMenu.AccessibleJMenu
      This class implements accessibility support for the JMenu class.
      protected class  JMenuBar.AccessibleJMenuBar
      This class implements accessibility support for the JMenuBar class.
      protected class  JMenuItem.AccessibleJMenuItem
      This class implements accessibility support for the JMenuItem class.
      protected class  JOptionPane.AccessibleJOptionPane
      This class implements accessibility support for the JOptionPane class.
      protected class  JPanel.AccessibleJPanel
      This class implements accessibility support for the JPanel class.
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.
      protected class  JPopupMenu.AccessibleJPopupMenu
      This class implements accessibility support for the JPopupMenu class.
      protected class  JProgressBar.AccessibleJProgressBar
      This class implements accessibility support for the JProgressBar class.
      protected class  JRadioButton.AccessibleJRadioButton
      This class implements accessibility support for the JRadioButton class.
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      This class implements accessibility support for the JRadioButtonMenuItem class.
      protected class  JRootPane.AccessibleJRootPane
      This class implements accessibility support for the JRootPane class.
      protected class  JScrollBar.AccessibleJScrollBar
      This class implements accessibility support for the JScrollBar class.
      protected class  JScrollPane.AccessibleJScrollPane
      This class implements accessibility support for the JScrollPane class.
      protected class  JSeparator.AccessibleJSeparator
      This class implements accessibility support for the JSeparator class.
      protected class  JSlider.AccessibleJSlider
      This class implements accessibility support for the JSlider class.
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner implements accessibility support for the JSpinner class.
      protected class  JSplitPane.AccessibleJSplitPane
      This class implements accessibility support for the JSplitPane class.
      protected class  JTabbedPane.AccessibleJTabbedPane
      This class implements accessibility support for the JTabbedPane class.
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.
      protected class  JTextArea.AccessibleJTextArea
      This class implements accessibility support for the JTextArea class.
      protected class  JTextField.AccessibleJTextField
      This class implements accessibility support for the JTextField class.
      protected class  JToggleButton.AccessibleJToggleButton
      This class implements accessibility support for the JToggleButton class.
      protected class  JToolBar.AccessibleJToolBar
      This class implements accessibility support for the JToolBar class.
      protected class  JToolTip.AccessibleJToolTip
      This class implements accessibility support for the JToolTip class.
      protected class  JTree.AccessibleJTree
      This class implements accessibility support for the JTree class.
      protected class  JViewport.AccessibleJViewport
      This class implements accessibility support for the JViewport class.

    • Uses of JComponent.AccessibleJComponent in javax.swing.table

      Subclasses of JComponent.AccessibleJComponent in javax.swing.table
      修饰符与类型 类与描述
      protected class  JTableHeader.AccessibleJTableHeader
      This class implements accessibility support for the JTableHeader class.

    • Uses of JComponent.AccessibleJComponent in javax.swing.text

      Subclasses of JComponent.AccessibleJComponent in javax.swing.text
      修饰符与类型 类与描述
      class  JTextComponent.AccessibleJTextComponent
      This class implements accessibility support for the JTextComponent class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w/rt T


Uses of Class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler

No usage of javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

exddt">Fliii"dll╫t胹


Uses of Class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler

No usage of javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><">g/sO


Uses of Class javax.swing.JDesktopPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JDesktopPane

  • Packages that use JDesktopPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JDesktopPane in javax.swing

      Methods in javax.swing that return JDesktopPane
      修饰符与类型 方法与描述
      JDesktopPane JInternalFrame.getDesktopPane()
      Convenience method that searches the ancestor hierarchy for a JDesktop instance.
      JDesktopPane JInternalFrame.JDesktopIcon.getDesktopPane()
      Convenience method to ask the icon for the Desktop object it belongs to.
      static JDesktopPane JOptionPane.getDesktopPaneForComponent(Component parentComponent)
      Returns the specified component's desktop pane.

    • Uses of JDesktopPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JDesktopPane
      修饰符与类型 | 字段与描述
      protected JDesktopPane | BasicDesktopPaneUI.desktop
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

poos >sM"/-Mafsilti c/r<


Uses of Class javax.swing.JDesktopPane.AccessibleJDesktopPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JDesktopPane.AccessibleJDesktopPane

No usage of javax.swing.JDesktopPane.AccessibleJDesktopPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aestsrv


Uses of Class javax.swing.JDialog

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JDialog

  • Packages that use JDialog
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JDialog in javax.swing

      Methods in javax.swing that return JDialog
      修饰符与类型 方法与描述
      protected JDialog JFileChooser.createDialog(Component parent)
      Creates and returns a new JDialog wrapping this centered on the parent in the parent's frame.
      JDialog JOptionPane.createDialog(Component parentComponent, String title)
      Creates and returns a new JDialog wrapping this centered on the parentComponent in the parentComponent's frame.
      static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
      Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons.
      JDialog JOptionPane.createDialog(String title)
      Creates and returns a new parentless JDialog with the specified title.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e ecoaao.tnviosogdh otms


Uses of Class javax.swing.JDialog.AccessibleJDialog

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JDialog.AccessibleJDialog

No usage of javax.swing.JDialog.AccessibleJDialog
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

horscodapnnn


Uses of Class javax.swing.JEditorPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JEditorPane

  • Packages that use JEditorPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of JEditorPane in javax.swing

      Subclasses of JEditorPane in javax.swing
      修饰符与类型 类与描述
      class  JTextPane
      A text component that can be marked up with attributes that are represented graphically.

    • Uses of JEditorPane in javax.swing.text

      Methods in javax.swing.text that return JEditorPane
      修饰符与类型 方法与描述
      protected JEditorPane StyledEditorKit.StyledTextAction.getEditor(ActionEvent e)
      Gets the target editor for an action.
      Methods in javax.swing.text with parameters of type JEditorPane
      修饰符与类型 方法与描述
      void StyledEditorKit.deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      void EditorKit.deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      protected StyledDocument StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e)
      Gets the document associated with an editor pane.
      protected StyledEditorKit StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e)
      Gets the editor kit associated with an editor pane.
      void StyledEditorKit.install(JEditorPane c)
      Called when the kit is being installed into a JEditorPane.
      void EditorKit.install(JEditorPane c)
      Called when the kit is being installed into the a JEditorPane.
      protected void StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to character content.
      protected void StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to paragraphs.

    • Uses of JEditorPane in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type JEditorPane
      修饰符与类型 | 方法与描述
      protected void HTMLEditorKit.LinkController.activateLink(int pos, JEditorPane editor)
      Calls linkActivated on the associated JEditorPane if the given position represents a link.
      void HTMLEditorKit.deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      protected HTMLDocument | HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)
      protected HTMLEditorKit | HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      protected void HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.
      void HTMLEditorKit.install(JEditorPane c)
      Called when the kit is being installed into the a JEditorPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

at acF"wIefl x/&. t>c=he


Uses of Class javax.swing.JEditorPane.AccessibleJEditorPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JEditorPane.AccessibleJEditorPane

  • Packages that use JEditorPane.AccessibleJEditorPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JEditorPane.AccessibleJEditorPane in javax.swing

      Subclasses of JEditorPane.AccessibleJEditorPane in javax.swing
      修饰符与类型 类与描述
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.sg.swajvvvi=..u"rl�"mg.


Uses of Class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JEditorPane.AccessibleJEditorPaneHTML

No usage of javax.swing.JEditorPane.AccessibleJEditorPaneHTML
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< />ortStuuutbrreitma


Uses of Class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

No usage of javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i oolan neeedh a/dci


Uses of Class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

No usage of javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i scselmt<.vwMjpl Mil


Uses of Class javax.swing.JFileChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFileChooser

  • Packages that use JFileChooser
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JFileChooser in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JFileChooser
      修饰符与类型 | 方法与描述
      abstract void | FileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
      abstract FileFilter | FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
      abstract String | FileChooserUI.getApproveButtonText(JFileChooser fc)
      JButton FileChooserUI.getDefaultButton(JFileChooser fc)
      Returns default button for current LookAndFeel.
      abstract String | FileChooserUI.getDialogTitle(JFileChooser fc)
      abstract FileView | FileChooserUI.getFileView(JFileChooser fc)
      abstract void | FileChooserUI.rescanCurrentDirectory(JFileChooser fc)

    • Uses of JFileChooser in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return JFileChooser
      修饰符与类型 | 方法与描述
      JFileChooser | BasicFileChooserUI.getFileChooser()
      Methods in javax.swing.plaf.basic with parameters of type JFileChooser
      修饰符与类型 | 方法与描述
      protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
      ListSelectionListener | BasicFileChooserUI.createListSelectionListener(JFileChooser fc)
      PropertyChangeListener | BasicFileChooserUI.createPropertyChangeListener(JFileChooser fc)
      void | BasicFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
      FileFilter BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
      Returns the default accept all file filter
      protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)
      int | BasicFileChooserUI.getApproveButtonMnemonic(JFileChooser fc)
      String | BasicFileChooserUI.getApproveButtonText(JFileChooser fc)
      String | BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser fc)
      JButton | BasicFileChooserUI.getDefaultButton(JFileChooser fc)
      String BasicFileChooserUI.getDialogTitle(JFileChooser fc)
      Returns the title of this dialog
      FileView | BasicFileChooserUI.getFileView(JFileChooser fc)
      void | BasicFileChooserUI.installComponents(JFileChooser fc)
      protected void | BasicFileChooserUI.installDefaults(JFileChooser fc)
      protected void | BasicFileChooserUI.installIcons(JFileChooser fc)
      protected void | BasicFileChooserUI.installListeners(JFileChooser fc)
      protected void | BasicFileChooserUI.installStrings(JFileChooser fc)
      void | BasicFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
      void | BasicFileChooserUI.uninstallComponents(JFileChooser fc)
      protected void | BasicFileChooserUI.uninstallDefaults(JFileChooser fc)
      protected void | BasicFileChooserUI.uninstallIcons(JFileChooser fc)
      protected void | BasicFileChooserUI.uninstallListeners(JFileChooser fc)
      protected void | BasicFileChooserUI.uninstallStrings(JFileChooser fc)
      Constructors in javax.swing.plaf.basic with parameters of type JFileChooser
      构造方法与描述
      BasicDirectoryModel(JFileChooser filechooser)
      BasicFileChooserUI(JFileChooser b)

    • Uses of JFileChooser in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JFileChooser
      修饰符与类型 | 方法与描述
      protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
      protected MetalFileChooserUI.DirectoryComboBoxModel | MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)
      protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer | MetalFileChooserUI.createDirectoryComboBoxRenderer(JFileChooser fc)
      protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
      ListSelectionListener MetalFileChooserUI.createListSelectionListener(JFileChooser fc)
      Creates a selection listener for the list of files and directories.
      PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener(JFileChooser fc)
      void | MetalFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
      protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)
      void | MetalFileChooserUI.installComponents(JFileChooser fc)
      protected void | MetalFileChooserUI.installListeners(JFileChooser fc)
      protected void | MetalFileChooserUI.installStrings(JFileChooser fc)
      void | MetalFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
      void | MetalFileChooserUI.uninstallComponents(JFileChooser fc)
      Constructors in javax.swing.plaf.metal with parameters of type JFileChooser
      构造方法与描述
      MetalFileChooserUI(JFileChooser filechooser)

    • Uses of JFileChooser in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JFileChooser
      修饰符与类型 方法与描述
      void MultiFileChooserUI.ensureFileIsVisible(JFileChooser a, File b)
      Invokes the ensureFileIsVisible method on each UI handled by this object.
      FileFilter MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a)
      Invokes the getAcceptAllFileFilter method on each UI handled by this object.
      String MultiFileChooserUI.getApproveButtonText(JFileChooser a)
      Invokes the getApproveButtonText method on each UI handled by this object.
      String MultiFileChooserUI.getDialogTitle(JFileChooser a)
      Invokes the getDialogTitle method on each UI handled by this object.
      FileView MultiFileChooserUI.getFileView(JFileChooser a)
      Invokes the getFileView method on each UI handled by this object.
      void MultiFileChooserUI.rescanCurrentDirectory(JFileChooser a)
      Invokes the rescanCurrentDirectory method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne "T.opnl#epur a


Uses of Class javax.swing.JFileChooser.AccessibleJFileChooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFileChooser.AccessibleJFileChooser

No usage of javax.swing.JFileChooser.AccessibleJFileChooser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f9 ifisininoe s/阻态


Uses of Class javax.swing.JFormattedTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFormattedTextField

  • Packages that use JFormattedTextField
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JFormattedTextField in javax.swing

      Methods in javax.swing that return JFormattedTextField
      修饰符与类型 方法与描述
      protected JFormattedTextField JFormattedTextField.AbstractFormatter.getFormattedTextField()
      Returns the current JFormattedTextField the AbstractFormatter is installed on.
      JFormattedTextField JSpinner.DefaultEditor.getTextField()
      Returns the JFormattedTextField child of this editor.
      Methods in javax.swing with parameters of type JFormattedTextField
      修饰符与类型 方法与描述
      abstract JFormattedTextField.AbstractFormatter JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf)
      Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.
      void JFormattedTextField.AbstractFormatter.install(JFormattedTextField ftf)
      Installs the AbstractFormatter onto a particular JFormattedTextField.

    • Uses of JFormattedTextField in javax.swing.text

      Methods in javax.swing.text with parameters of type JFormattedTextField
      修饰符与类型 方法与描述
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getFormatter(JFormattedTextField source)
      Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.
      void MaskFormatter.install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
      void DefaultFormatter.install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
      void InternationalFormatter.install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sgn MssesMlbd"s.wando/


Uses of Class javax.swing.JFormattedTextField.AbstractFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFormattedTextField.AbstractFormatter

  • Packages that use JFormattedTextField.AbstractFormatter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JFormattedTextField.AbstractFormatter in javax.swing

      Methods in javax.swing that return JFormattedTextField.AbstractFormatter
      修饰符与类型 方法与描述
      JFormattedTextField.AbstractFormatter JFormattedTextField.getFormatter()
      Returns the AbstractFormatter that is used to format and parse the current value.
      abstract JFormattedTextField.AbstractFormatter JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf)
      Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.
      Methods in javax.swing with parameters of type JFormattedTextField.AbstractFormatter
      修饰符与类型 方法与描述
      protected void JFormattedTextField.setFormatter(JFormattedTextField.AbstractFormatter format)
      Sets the current AbstractFormatter.
      Constructors in javax.swing with parameters of type JFormattedTextField.AbstractFormatter
      构造方法与描述
      JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
      Creates a JFormattedTextField with the specified AbstractFormatter.

    • Uses of JFormattedTextField.AbstractFormatter in javax.swing.text

      Subclasses of JFormattedTextField.AbstractFormatter in javax.swing.text
      修饰符与类型 类与描述
      class  DateFormatter
      DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
      class  DefaultFormatter
      DefaultFormatter formats aribtrary objects.
      class  InternationalFormatter
      InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
      class  MaskFormatter
      MaskFormatter is used to format and edit strings.
      class  NumberFormatter
      NumberFormatter subclasses InternationalFormatter adding special behavior for numbers.
      Methods in javax.swing.text that return JFormattedTextField.AbstractFormatter
      修饰符与类型 方法与描述
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getDefaultFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getDisplayFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getEditFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getFormatter(JFormattedTextField source)
      Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.
      JFormattedTextField.AbstractFormatter DefaultFormatterFactory.getNullFormatter()
      Returns the formatter to use if the value is null.
      Methods in javax.swing.text with parameters of type JFormattedTextField.AbstractFormatter
      修饰符与类型 方法与描述
      void DefaultFormatterFactory.setDefaultFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
      void DefaultFormatterFactory.setDisplayFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      void DefaultFormatterFactory.setEditFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      void DefaultFormatterFactory.setNullFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the formatter to use if the value of the JFormattedTextField is null.
      Constructors in javax.swing.text with parameters of type JFormattedTextField.AbstractFormatter
      构造方法与描述
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatter.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat, JFormattedTextField.AbstractFormatter nullFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pa;eeChJ>FFFna==(a/oetboa)e


Uses of Class javax.swing.JFormattedTextField.AbstractFormatterFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFormattedTextField.AbstractFormatterFactory

  • Packages that use JFormattedTextField.AbstractFormatterFactory
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JFormattedTextField.AbstractFormatterFactory in javax.swing

      Methods in javax.swing that return JFormattedTextField.AbstractFormatterFactory
      修饰符与类型 方法与描述
      JFormattedTextField.AbstractFormatterFactory JFormattedTextField.getFormatterFactory()
      Returns the current AbstractFormatterFactory.
      Methods in javax.swing with parameters of type JFormattedTextField.AbstractFormatterFactory
      修饰符与类型 方法与描述
      void JFormattedTextField.setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
      Sets the AbstractFormatterFactory.
      Constructors in javax.swing with parameters of type JFormattedTextField.AbstractFormatterFactory
      构造方法与描述
      JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
      Creates a JFormattedTextField with the specified AbstractFormatterFactory.
      JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
      Creates a JFormattedTextField with the specified AbstractFormatterFactory and initial value.

    • Uses of JFormattedTextField.AbstractFormatterFactory in javax.swing.text

      Subclasses of JFormattedTextField.AbstractFormatterFactory in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultFormatterFactory
      An implementation of JFormattedTextField.AbstractFormatterFactory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtnlassvi )aacarreolftt/


Uses of Class javax.swing.JFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFrame

  • Packages that use JFrame
    软件包 描述
    java.awt.im.spi
    Provides interfaces that enable the development of input methods that can be used with any Java runtime environment.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JFrame in java.awt.im.spi

      Methods in java.awt.im.spi that return JFrame
      修饰符与类型 方法与描述
      JFrame InputMethodContext.createInputMethodJFrame(String title, boolean attachToInputContext)
      Creates a top-level Swing JFrame for use by the input method.

    • Uses of JFrame in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return JFrame
      修饰符与类型 方法与描述
      protected JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
      No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/l>Ucoc=nst_l tfotToexn h


Uses of Class javax.swing.JFrame.AccessibleJFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JFrame.AccessibleJFrame

No usage of javax.swing.JFrame.AccessibleJFrame
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

te"sd c>" lsttb


Uses of Class javax.swing.JInternalFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JInternalFrame

  • Packages that use JInternalFrame
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JInternalFrame in javax.swing

      Methods in javax.swing that return JInternalFrame
      修饰符与类型 方法与描述
      JInternalFrame JOptionPane.createInternalFrame(Component parentComponent, String title)
      Creates and returns an instance of JInternalFrame.
      JInternalFrame[] JDesktopPane.getAllFrames()
      Returns all JInternalFrames currently displayed in the desktop.
      JInternalFrame[] JDesktopPane.getAllFramesInLayer(int layer)
      Returns all JInternalFrames currently displayed in the specified layer of the desktop.
      JInternalFrame JInternalFrame.JDesktopIcon.getInternalFrame()
      Returns the JInternalFrame that this DesktopIcon is associated with.
      JInternalFrame JDesktopPane.getSelectedFrame()
      Returns the currently active JInternalFrame in this JDesktopPane, or null if no JInternalFrame is currently active.
      JInternalFrame JDesktopPane.selectFrame(boolean forward)
      Selects the next JInternalFrame in this desktop pane.
      Methods in javax.swing with parameters of type JInternalFrame
      修饰符与类型 | 方法与描述
      void DefaultDesktopManager.activateFrame(JInternalFrame f)
      This will activate f moving it to the front.
      void DesktopManager.activateFrame(JInternalFrame f)
      Generally, indicate that this frame has focus.
      void DefaultDesktopManager.closeFrame(JInternalFrame f)
      Removes the frame, and, if necessary, the desktopIcon, from its parent.
      void DesktopManager.closeFrame(JInternalFrame f)
      Generally, this call should remove the frame from it's parent.
      void | DefaultDesktopManager.deactivateFrame(JInternalFrame f)
      void DesktopManager.deactivateFrame(JInternalFrame f)
      Generally, indicate that this frame has lost focus.
      void DefaultDesktopManager.deiconifyFrame(JInternalFrame f)
      Removes the desktopIcon from its parent and adds its frame to the parent.
      void DesktopManager.deiconifyFrame(JInternalFrame f)
      Generally, remove any iconic representation that is present and restore the frame to it's original size and location.
      protected Rectangle DefaultDesktopManager.getBoundsForIconOf(JInternalFrame f)
      The iconifyFrame() code calls this to determine the proper bounds for the desktopIcon.
      Component InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame frame)
      Returns the Component that should receive the focus when a JInternalFrame is selected for the first time.
      protected Rectangle DefaultDesktopManager.getPreviousBounds(JInternalFrame f)
      Gets the normal bounds of the component prior to the component being maximized.
      void DefaultDesktopManager.iconifyFrame(JInternalFrame f)
      Removes the frame from its parent and adds its desktopIcon to the parent.
      void DesktopManager.iconifyFrame(JInternalFrame f)
      Generally, remove this frame from it's parent and add an iconic representation.
      void DefaultDesktopManager.maximizeFrame(JInternalFrame f)
      Resizes the frame to fill its parents bounds.
      void DesktopManager.maximizeFrame(JInternalFrame f)
      Generally, the frame should be resized to match it's parents bounds.
      void DefaultDesktopManager.minimizeFrame(JInternalFrame f)
      Restores the frame back to its size and position prior to a maximizeFrame call.
      void DesktopManager.minimizeFrame(JInternalFrame f)
      Generally, this indicates that the frame should be restored to it's size and position prior to a maximizeFrame() call.
      void DefaultDesktopManager.openFrame(JInternalFrame f)
      Normally this method will not be called.
      void DesktopManager.openFrame(JInternalFrame f)
      If possible, display this frame in an appropriate location.
      protected void DefaultDesktopManager.removeIconFor(JInternalFrame f)
      Convenience method to remove the desktopIcon of f is necessary.
      void JInternalFrame.JDesktopIcon.setInternalFrame(JInternalFrame f)
      Sets the JInternalFrame with which this DesktopIcon is associated.
      protected void DefaultDesktopManager.setPreviousBounds(JInternalFrame f, Rectangle r)
      Stores the bounds of the component just before a maximize call.
      void JDesktopPane.setSelectedFrame(JInternalFrame f)
      Sets the currently active JInternalFrame in this JDesktopPane.
      protected void DefaultDesktopManager.setWasIcon(JInternalFrame f, Boolean value)
      Sets that the component has been iconized and the bounds of the desktopIcon are valid.
      protected boolean DefaultDesktopManager.wasIcon(JInternalFrame f)
      Returns true if the component has been iconized and the bounds of the desktopIcon are valid, otherwise returns false.
      Constructors in javax.swing with parameters of type JInternalFrame
      构造方法与描述
      JInternalFrame.JDesktopIcon(JInternalFrame f)
      Creates an icon for an internal frame.

    • Uses of JInternalFrame in javax.swing.event

      Methods in javax.swing.event that return JInternalFrame
      修饰符与类型 方法与描述
      JInternalFrame InternalFrameEvent.getInternalFrame()
      Returns the originator of the event.
      Constructors in javax.swing.event with parameters of type JInternalFrame
      构造方法与描述
      InternalFrameEvent(JInternalFrame source, int id)
      Constructs an InternalFrameEvent object.

    • Uses of JInternalFrame in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JInternalFrame
      修饰符与类型 | 字段与描述
      protected JInternalFrame | BasicInternalFrameTitlePane.frame
      protected JInternalFrame | BasicInternalFrameUI.frame
      protected JInternalFrame | BasicDesktopIconUI.frame
      Methods in javax.swing.plaf.basic with parameters of type JInternalFrame
      修饰符与类型 | 方法与描述
      protected void BasicInternalFrameUI.activateFrame(JInternalFrame f)
      This method is called when the frame becomes selected.
      protected void BasicInternalFrameUI.closeFrame(JInternalFrame f)
      This method is called when the user wants to close the frame.
      protected MouseInputAdapter | BasicInternalFrameUI.createBorderListener(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
      protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
      protected void BasicInternalFrameUI.deactivateFrame(JInternalFrame f)
      This method is called when the frame is no longer selected.
      protected void BasicInternalFrameUI.deiconifyFrame(JInternalFrame f)
      This method is called when the user wants to deiconify the frame.
      protected void BasicInternalFrameUI.iconifyFrame(JInternalFrame f)
      This method is called when the user wants to iconify the frame.
      protected void BasicInternalFrameUI.maximizeFrame(JInternalFrame f)
      This method is called when the user wants to maximize the frame.
      protected void BasicInternalFrameUI.minimizeFrame(JInternalFrame f)
      This method is called when the user wants to minimize the frame.
      protected void BasicInternalFrameTitlePane.postClosingEvent(JInternalFrame frame)
      Post a WINDOW_CLOSING-like event to the frame, so that it can be treated like a regular Frame.
      Constructors in javax.swing.plaf.basic with parameters of type JInternalFrame
      构造方法与描述
      BasicInternalFrameTitlePane(JInternalFrame f)
      BasicInternalFrameUI(JInternalFrame b)

    • Uses of JInternalFrame in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JInternalFrame
      修饰符与类型 | 方法与描述
      protected MouseInputAdapter MetalInternalFrameUI.createBorderListener(JInternalFrame w)
      Returns the MouseInputAdapter that will be installed on the TitlePane.
      protected JComponent | MetalInternalFrameUI.createNorthPane(JInternalFrame w)
      Constructors in javax.swing.plaf.metal with parameters of type JInternalFrame
      构造方法与描述
      MetalInternalFrameTitlePane(JInternalFrame f)
      MetalInternalFrameUI(JInternalFrame b)

    • Uses of JInternalFrame in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JInternalFrame
      修饰符与类型 | 方法与描述
      protected JComponent | SynthInternalFrameUI.createNorthPane(JInternalFrame w)
      Constructors in javax.swing.plaf.synth with parameters of type JInternalFrame
      构造方法与描述
      SynthInternalFrameUI(JInternalFrame b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.a a.liae=a>nI dbig


Uses of Class javax.swing.JInternalFrame.AccessibleJInternalFrame

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JInternalFrame.AccessibleJInternalFrame

No usage of javax.swing.JInternalFrame.AccessibleJInternalFrame
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ca ce=r"""rtcc/xia<


Uses of Class javax.swing.JInternalFrame.JDesktopIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JInternalFrame.JDesktopIcon

  • Packages that use JInternalFrame.JDesktopIcon
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JInternalFrame.JDesktopIcon in javax.swing

      Fields in javax.swing declared as JInternalFrame.JDesktopIcon
      修饰符与类型 字段与描述
      protected JInternalFrame.JDesktopIcon JInternalFrame.desktopIcon
      The icon that is displayed when this internal frame is iconified.
      Methods in javax.swing that return JInternalFrame.JDesktopIcon
      修饰符与类型 方法与描述
      JInternalFrame.JDesktopIcon JInternalFrame.getDesktopIcon()
      Returns the JDesktopIcon used when this JInternalFrame is iconified.
      Methods in javax.swing with parameters of type JInternalFrame.JDesktopIcon
      修饰符与类型 方法与描述
      void JInternalFrame.setDesktopIcon(JInternalFrame.JDesktopIcon d)
      Sets the JDesktopIcon associated with this JInternalFrame.

    • Uses of JInternalFrame.JDesktopIcon in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JInternalFrame.JDesktopIcon
      修饰符与类型 | 字段与描述
      protected JInternalFrame.JDesktopIcon | BasicDesktopIconUI.desktopIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sn/eaaIc"="sctilamuonco


Uses of Class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

No usage of javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pptslasapnnn>c elic<


Uses of Class javax.swing.JLabel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JLabel

  • Packages that use JLabel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of JLabel in javax.swing

      Subclasses of JLabel in javax.swing
      修饰符与类型 类与描述
      class  DefaultListCellRenderer
      Renders an item in a list.
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.

    • Uses of JLabel in javax.swing.plaf.basic

      Subclasses of JLabel in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicComboBoxRenderer
      ComboBox renderer
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
      Methods in javax.swing.plaf.basic with parameters of type JLabel
      修饰符与类型 | 方法与描述
      protected void | BasicLabelUI.installComponents(JLabel c)
      protected void | BasicLabelUI.installDefaults(JLabel c)
      protected void | BasicLabelUI.installKeyboardActions(JLabel l)
      protected void | BasicLabelUI.installListeners(JLabel c)
      protected String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
      Forwards the call to SwingUtilities.layoutCompoundLabel().
      protected void BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Paint clippedText at textX, textY with background.lighter() and then shifted down and to the right by one pixel with background.darker().
      protected void BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Paint clippedText at textX, textY with the labels foreground color.
      protected void | BasicLabelUI.uninstallComponents(JLabel c)
      protected void | BasicLabelUI.uninstallDefaults(JLabel c)
      protected void | BasicLabelUI.uninstallKeyboardActions(JLabel c)
      protected void | BasicLabelUI.uninstallListeners(JLabel c)

    • Uses of JLabel in javax.swing.plaf.metal

      Subclasses of JLabel in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalFileChooserUI.FileRenderer
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.
      Methods in javax.swing.plaf.metal with parameters of type JLabel
      修饰符与类型 方法与描述
      protected void MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Just paint the text gray (Label.disabledForeground) rather than in the labels foreground color.

    • Uses of JLabel in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JLabel
      修饰符与类型 | 方法与描述
      protected void | SynthLabelUI.installDefaults(JLabel c)
      protected void | SynthLabelUI.uninstallDefaults(JLabel c)

    • Uses of JLabel in javax.swing.table

      Subclasses of JLabel in javax.swing.table
      修饰符与类型 类与描述
      class  DefaultTableCellRenderer
      The standard class for rendering (displaying) individual cells in a JTable.
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.

    • Uses of JLabel in javax.swing.tree

      Subclasses of JLabel in javax.swing.tree
      修饰符与类型 类与描述
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nta.pxm=pot/oBo<


Uses of Class javax.swing.JLabel.AccessibleJLabel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JLabel.AccessibleJLabel

No usage of javax.swing.JLabel.AccessibleJLabel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"h


Uses of Class javax.swing.JLayer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JLayer

  • Packages that use JLayer
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

    • Uses of JLayer in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JLayer
      修饰符与类型 方法与描述
      void LayerUI.applyPropertyChange(PropertyChangeEvent evt, JLayer<? extends V> l)
      Notifies the LayerUI when any of its property are changed and enables updating every JLayer this LayerUI instance is set to.
      void LayerUI.doLayout(JLayer<? extends V> l)
      Causes the passed instance of JLayer to lay out its components.
      void LayerUI.eventDispatched(AWTEvent e, JLayer<? extends V> l)
      Processes AWTEvents for JLayer and all its descendants to this LayerUI instance.
      void LayerUI.paintImmediately(int x, int y, int width, int height, JLayer<? extends V> l)
      Paints the specified region in the JLayer this LayerUI is set to, immediately.
      protected void LayerUI.processComponentEvent(ComponentEvent e, JLayer<? extends V> l)
      Processes component events occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processFocusEvent(FocusEvent e, JLayer<? extends V> l)
      Processes focus events occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processHierarchyBoundsEvent(HierarchyEvent e, JLayer<? extends V> l)
      Processes hierarchy bounds event occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processHierarchyEvent(HierarchyEvent e, JLayer<? extends V> l)
      Processes hierarchy event occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processInputMethodEvent(InputMethodEvent e, JLayer<? extends V> l)
      Processes input event occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processKeyEvent(KeyEvent e, JLayer<? extends V> l)
      Processes key events occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processMouseEvent(MouseEvent e, JLayer<? extends V> l)
      Processes mouse events occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processMouseMotionEvent(MouseEvent e, JLayer<? extends V> l)
      Processes mouse motion event occurring on the JLayer or any of its subcomponents.
      protected void LayerUI.processMouseWheelEvent(MouseWheelEvent e, JLayer<? extends V> l)
      Processes mouse wheel event occurring on the JLayer or any of its subcomponents.
      void LayerUI.updateUI(JLayer<? extends V> l)
      Invoked when updateUI() is called by the JLayer this LayerUI is set to.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n"jjjtutt>"


Uses of Class javax.swing.JLayeredPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JLayeredPane

  • Packages that use JLayeredPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JLayeredPane in javax.swing

      Subclasses of JLayeredPane in javax.swing
      修饰符与类型 类与描述
      class  JDesktopPane
      A container used to create a multiple-document interface or a virtual desktop.
      Fields in javax.swing declared as JLayeredPane
      修饰符与类型 字段与描述
      protected JLayeredPane JRootPane.layeredPane
      The layered pane that manages the menu bar and content pane.
      Methods in javax.swing that return JLayeredPane
      修饰符与类型 方法与描述
      protected JLayeredPane JRootPane.createLayeredPane()
      Called by the constructor methods to create the default layeredPane.
      JLayeredPane JApplet.getLayeredPane()
      Returns the layeredPane object for this applet.
      JLayeredPane JInternalFrame.getLayeredPane()
      Returns the layered pane for this internal frame.
      JLayeredPane JDialog.getLayeredPane()
      Returns the layeredPane object for this dialog.
      JLayeredPane JWindow.getLayeredPane()
      Returns the layeredPane object for this window.
      JLayeredPane JRootPane.getLayeredPane()
      Gets the layered pane used by the root pane.
      JLayeredPane RootPaneContainer.getLayeredPane()
      Returns the layeredPane.
      JLayeredPane JFrame.getLayeredPane()
      Returns the layeredPane object for this frame.
      static JLayeredPane JLayeredPane.getLayeredPaneAbove(Component c)
      Convenience method that returns the first JLayeredPane which contains the specified component.
      Methods in javax.swing with parameters of type JLayeredPane
      修饰符与类型 方法与描述
      void JApplet.setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void JInternalFrame.setLayeredPane(JLayeredPane layered)
      Sets this JInternalFrame's layeredPane property.
      void JDialog.setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void JWindow.setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
      void JRootPane.setLayeredPane(JLayeredPane layered)
      Sets the layered pane for the root pane.
      void RootPaneContainer.setLayeredPane(JLayeredPane layeredPane)
      A Container that manages the contentPane and in some cases a menu bar.
      void JFrame.setLayeredPane(JLayeredPane layeredPane)
      Sets the layeredPane property.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>ebJ>aaao


Uses of Class javax.swing.JLayeredPane.AccessibleJLayeredPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JLayeredPane.AccessibleJLayeredPane

No usage of javax.swing.JLayeredPane.AccessibleJLayeredPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j a"titmtlllrn..aoJs.


Uses of Class javax.swing.JList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JList

  • Packages that use JList
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JList in javax.swing

      Methods in javax.swing with parameters of type JList
      修饰符与类型 | 方法与描述
      Component | DefaultListCellRenderer.getListCellRendererComponent(JList<?> list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Component ListCellRenderer.getListCellRendererComponent(JList<? extends E> list, E value, int index, boolean isSelected, boolean cellHasFocus)
      Return a component that has been configured to display the specified value.
      Constructors in javax.swing with parameters of type JList
      构造方法与描述
      JList.AccessibleJList.AccessibleJListChild(JList<E> parent, int indexInParent)

    • Uses of JList in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JList
      修饰符与类型 方法与描述
      abstract Rectangle ListUI.getCellBounds(JList list, int index1, int index2)
      Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.
      abstract Point ListUI.indexToLocation(JList list, int index)
      Returns the origin in the given JList, of the specified item, in the list's coordinate system.
      abstract int ListUI.locationToIndex(JList list, Point location)
      Returns the cell index in the specified JList closest to the given location in the list's coordinate system.

    • Uses of JList in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JList
      修饰符与类型 | 字段与描述
      protected JList | BasicListUI.list
      protected JList BasicComboPopup.list
      This protected field is implementation specific.
      protected JList | BasicComboBoxUI.listBox
      Methods in javax.swing.plaf.basic that return JList
      修饰符与类型 方法与描述
      protected JList BasicComboPopup.createList()
      Creates the JList used in the popup to display the items in the combo box model.
      JList ComboPopup.getList()
      Returns the list that is being used to draw the items in the combo box.
      JList BasicComboPopup.getList()
      Implementation of ComboPopup.getList().
      Methods in javax.swing.plaf.basic with parameters of type JList
      修饰符与类型 | 方法与描述
      protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
      Rectangle BasicListUI.getCellBounds(JList list, int index1, int index2)
      Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.
      Component | BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Point BasicListUI.indexToLocation(JList list, int index)
      Returns the origin in the given JList, of the specified item, in the list's coordinate system.
      int BasicListUI.locationToIndex(JList list, Point location)
      Returns the cell index in the specified JList closest to the given location in the list's coordinate system.
      Constructors in javax.swing.plaf.basic with parameters of type JList
      构造方法与描述
      BasicFileChooserUI.DoubleClickListener(JList list)

    • Uses of JList in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as JList
      修饰符与类型 | 字段与描述
      protected JList | MetalComboBoxButton.listBox
      Methods in javax.swing.plaf.metal with parameters of type JList
      修饰符与类型 | 方法与描述
      Component | MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Constructors in javax.swing.plaf.metal with parameters of type JList
      构造方法与描述
      MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
      MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
      MetalFileChooserUI.SingleClickListener(JList list)

    • Uses of JList in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JList
      修饰符与类型 方法与描述
      Rectangle MultiListUI.getCellBounds(JList a, int b, int c)
      Invokes the getCellBounds method on each UI handled by this object.
      Point MultiListUI.indexToLocation(JList a, int b)
      Invokes the indexToLocation method on each UI handled by this object.
      int MultiListUI.locationToIndex(JList a, Point b)
      Invokes the locationToIndex method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iipp/ =dy aoyi1


Uses of Class javax.swing.JList.AccessibleJList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JList.AccessibleJList

No usage of javax.swing.JList.AccessibleJList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aanurrsraud is擞锛錶


Uses of Class javax.swing.JList.AccessibleJList.AccessibleJListChild

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JList.AccessibleJList.AccessibleJListChild

No usage of javax.swing.JList.AccessibleJList.AccessibleJListChild
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a >ee">dePPPy.nnnJg


Uses of Class javax.swing.JList.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JList.DropLocation

  • Packages that use JList.DropLocation
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JList.DropLocation in javax.swing

      Methods in javax.swing that return JList.DropLocation
      修饰符与类型 方法与描述
      JList.DropLocation JList.getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o a.(sdr/l>--_endLPp<


Uses of Class javax.swing.JMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenu

  • Packages that use JMenu
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of JMenu in javax.swing

      Methods in javax.swing that return JMenu
      修饰符与类型 方法与描述
      JMenu JMenuBar.add(JMenu c)
      Appends the specified menu to the end of the menu bar.
      JMenu JMenuBar.getHelpMenu()
      Gets the help menu for the menu bar.
      JMenu JMenuBar.getMenu(int index)
      Returns the menu at the specified position in the menu bar.
      Methods in javax.swing with parameters of type JMenu
      修饰符与类型 方法与描述
      JMenu JMenuBar.add(JMenu c)
      Appends the specified menu to the end of the menu bar.
      void JMenuBar.setHelpMenu(JMenu menu)
      Sets the help menu that appears when the user selects the "help" option in the menu bar.

    • Uses of JMenu in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JMenu
      修饰符与类型 | 字段与描述
      JMenu | BasicMenuUI.ChangeHandler.menu
      protected JMenu | BasicInternalFrameTitlePane.windowMenu
      Methods in javax.swing.plaf.basic that return JMenu
      修饰符与类型 | 方法与描述
      protected JMenu | BasicInternalFrameTitlePane.createSystemMenu()
      Methods in javax.swing.plaf.basic with parameters of type JMenu
      修饰符与类型 | 方法与描述
      protected void | BasicInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
      protected void | BasicMenuUI.setupPostTimer(JMenu menu)
      Constructors in javax.swing.plaf.basic with parameters of type JMenu
      构造方法与描述
      BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

    • Uses of JMenu in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JMenu
      修饰符与类型 方法与描述
      protected void MetalInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
      Override the parent's method to do nothing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o<鋠/...// g<"e/=eRl


Uses of Class javax.swing.JMenu.AccessibleJMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenu.AccessibleJMenu

No usage of javax.swing.JMenu.AccessibleJMenu
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l"a/ Ty raaafossstnnt


Uses of Class javax.swing.JMenu.WinListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenu.WinListener

  • Packages that use JMenu.WinListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JMenu.WinListener in javax.swing

      Fields in javax.swing declared as JMenu.WinListener
      修饰符与类型 字段与描述
      protected JMenu.WinListener JMenu.popupListener
      The window-closing listener for the popup.
      Methods in javax.swing that return JMenu.WinListener
      修饰符与类型 方法与描述
      protected JMenu.WinListener JMenu.createWinListener(JPopupMenu p)
      Creates a window-closing listener for the popup.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.oclast


Uses of Class javax.swing.JMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenuBar

  • Packages that use JMenuBar
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JMenuBar in javax.swing

      Fields in javax.swing declared as JMenuBar
      修饰符与类型 字段与描述
      protected JMenuBar JRootPane.menuBar
      The menu bar.
      Methods in javax.swing that return JMenuBar
      修饰符与类型 方法与描述
      JMenuBar JApplet.getJMenuBar()
      Returns the menubar set on this applet.
      JMenuBar JInternalFrame.getJMenuBar()
      Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.
      JMenuBar JDialog.getJMenuBar()
      Returns the menubar set on this dialog.
      JMenuBar JRootPane.getJMenuBar()
      Returns the menu bar from the layered pane.
      JMenuBar JFrame.getJMenuBar()
      Returns the menubar set on this frame.
      JMenuBar JInternalFrame.getMenuBar()
      Deprecated.
      As of Swing version 1.0.3, replaced by getJMenuBar().
      JMenuBar JRootPane.getMenuBar()
      Deprecated.
      As of Swing version 1.0.3 replaced by getJMenuBar().
      Methods in javax.swing with parameters of type JMenuBar
      修饰符与类型 方法与描述
      void JApplet.setJMenuBar(JMenuBar menuBar)
      Sets the menubar for this applet.
      void JInternalFrame.setJMenuBar(JMenuBar m)
      Sets the menuBar property for this JInternalFrame.
      void JDialog.setJMenuBar(JMenuBar menu)
      Sets the menubar for this dialog.
      void JRootPane.setJMenuBar(JMenuBar menu)
      Adds or changes the menu bar used in the layered pane.
      void JFrame.setJMenuBar(JMenuBar menubar)
      Sets the menubar for this frame.
      void JInternalFrame.setMenuBar(JMenuBar m)
      Deprecated.
      As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar m).
      void JRootPane.setMenuBar(JMenuBar menu)
      Deprecated.
      As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar menu).

    • Uses of JMenuBar in javax.swing.plaf.basic

      Subclasses of JMenuBar in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicInternalFrameTitlePane.SystemMenuBar
      This class should be treated as a "protected" inner class.
      Fields in javax.swing.plaf.basic declared as JMenuBar
      修饰符与类型 | 字段与描述
      protected JMenuBar | BasicInternalFrameTitlePane.menuBar
      protected JMenuBar | BasicMenuBarUI.menuBar
      Methods in javax.swing.plaf.basic that return JMenuBar
      修饰符与类型 | 方法与描述
      protected JMenuBar | BasicInternalFrameTitlePane.createSystemMenuBar()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>u. sr


Uses of Class javax.swing.JMenuBar.AccessibleJMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenuBar.AccessibleJMenuBar

No usage of javax.swing.JMenuBar.AccessibleJMenuBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

W


Uses of Class javax.swing.JMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenuItem

  • Packages that use JMenuItem
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JMenuItem in javax.swing

      Subclasses of JMenuItem in javax.swing
      修饰符与类型 类与描述
      class  JCheckBoxMenuItem
      A menu item that can be selected or deselected.
      class  JMenu
      An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
      class  JRadioButtonMenuItem
      An implementation of a radio button menu item.
      Methods in javax.swing that return JMenuItem
      修饰符与类型 方法与描述
      JMenuItem JMenu.add(Action a)
      Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
      JMenuItem JPopupMenu.add(Action a)
      Appends a new menu item to the end of the menu which dispatches the specified Action object.
      JMenuItem JMenu.add(JMenuItem menuItem)
      Appends a menu item to the end of this menu.
      JMenuItem JPopupMenu.add(JMenuItem menuItem)
      Appends the specified menu item to the end of this menu.
      JMenuItem JMenu.add(String s)
      Creates a new menu item with the specified text and appends it to the end of this menu.
      JMenuItem JPopupMenu.add(String s)
      Creates a new menu item with the specified text and appends it to the end of this menu.
      protected JMenuItem JMenu.createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JMenu.
      protected JMenuItem JPopupMenu.createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
      JMenuItem JMenu.getItem(int pos)
      Returns the JMenuItem at the specified position.
      JMenuItem JMenu.insert(Action a, int pos)
      Inserts a new menu item attached to the specified Action object at a given position.
      JMenuItem JMenu.insert(JMenuItem mi, int pos)
      Inserts the specified JMenuitem at a given position.
      Methods in javax.swing with parameters of type JMenuItem
      修饰符与类型 方法与描述
      JMenuItem JMenu.add(JMenuItem menuItem)
      Appends a menu item to the end of this menu.
      JMenuItem JPopupMenu.add(JMenuItem menuItem)
      Appends the specified menu item to the end of this menu.
      protected PropertyChangeListener JMenu.createActionChangeListener(JMenuItem b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
      protected PropertyChangeListener JPopupMenu.createActionChangeListener(JMenuItem b)
      Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
      JMenuItem JMenu.insert(JMenuItem mi, int pos)
      Inserts the specified JMenuitem at a given position.
      void JMenu.remove(JMenuItem item)
      Removes the specified menu item from this menu.

    • Uses of JMenuItem in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JMenuItem
      修饰符与类型 | 字段与描述
      protected JMenuItem | BasicMenuItemUI.menuItem
      Methods in javax.swing.plaf.basic with parameters of type JMenuItem
      修饰符与类型 | 方法与描述
      protected void | BasicMenuItemUI.installComponents(JMenuItem menuItem)
      protected void BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor)
      Draws the background of the menu item.
      protected void BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
      Renders the text of the current menu item.
      void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      protected void | BasicMenuItemUI.uninstallComponents(JMenuItem menuItem)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cnha>鱯nigg.eeh


Uses of Class javax.swing.JMenuItem.AccessibleJMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JMenuItem.AccessibleJMenuItem

  • Packages that use JMenuItem.AccessibleJMenuItem
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JMenuItem.AccessibleJMenuItem in javax.swing

      Subclasses of JMenuItem.AccessibleJMenuItem in javax.swing
      修饰符与类型 类与描述
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      This class implements accessibility support for the JCheckBoxMenuItem class.
      protected class  JMenu.AccessibleJMenu
      This class implements accessibility support for the JMenu class.
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      This class implements accessibility support for the JRadioButtonMenuItem class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la#ong//xsssa/>>aaslta>lt


Uses of Class javax.swing.JOptionPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JOptionPane

  • Packages that use JOptionPane
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JOptionPane in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JOptionPane
      修饰符与类型 方法与描述
      abstract boolean OptionPaneUI.containsCustomComponents(JOptionPane op)
      Returns true if the user has supplied instances of Component for either the options or message.
      abstract void OptionPaneUI.selectInitialValue(JOptionPane op)
      Requests the component representing the default value to have focus.

    • Uses of JOptionPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JOptionPane
      修饰符与类型 字段与描述
      protected JOptionPane BasicOptionPaneUI.optionPane
      JOptionPane that the receiver is providing the look and feel for.
      Methods in javax.swing.plaf.basic with parameters of type JOptionPane
      修饰符与类型 方法与描述
      boolean BasicOptionPaneUI.containsCustomComponents(JOptionPane op)
      Returns true if in the last call to validateComponent the message or buttons contained a subclass of Component.
      void BasicOptionPaneUI.selectInitialValue(JOptionPane op)
      If inputComponent is non-null, the focus is requested on that, otherwise request focus on the default value

    • Uses of JOptionPane in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JOptionPane
      修饰符与类型 方法与描述
      boolean MultiOptionPaneUI.containsCustomComponents(JOptionPane a)
      Invokes the containsCustomComponents method on each UI handled by this object.
      void MultiOptionPaneUI.selectInitialValue(JOptionPane a)
      Invokes the selectInitialValue method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=xeoa"rcat><eMm;s


Uses of Class javax.swing.JOptionPane.AccessibleJOptionPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JOptionPane.AccessibleJOptionPane

No usage of javax.swing.JOptionPane.AccessibleJOptionPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g"/j../"=...ro""dodt<


Uses of Class javax.swing.JPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPanel

  • Packages that use JPanel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JPanel in javax.swing

      Subclasses of JPanel in javax.swing
      修饰符与类型 类与描述
      static class  JSpinner.DateEditor
      An editor for a JSpinner whose model is a SpinnerDateModel.
      static class  JSpinner.DefaultEditor
      A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
      static class  JSpinner.ListEditor
      An editor for a JSpinner whose model is a SpinnerListModel.
      static class  JSpinner.NumberEditor
      An editor for a JSpinner whose model is a SpinnerNumberModel.
      Methods in javax.swing that return JPanel
      修饰符与类型 方法与描述
      JPanel JLayer.createGlassPane()
      Called by the constructor methods to create a default glassPane.
      JPanel JLayer.getGlassPane()
      Returns the JLayer's glassPane component or null.
      Methods in javax.swing with parameters of type JPanel
      修饰符与类型 方法与描述
      void JLayer.setGlassPane(JPanel glassPane)
      Sets the JLayer's glassPane component, which can be null.

    • Uses of JPanel in javax.swing.colorchooser

      Subclasses of JPanel in javax.swing.colorchooser
      修饰符与类型 类与描述
      class  AbstractColorChooserPanel
      This is the abstract superclass for color choosers.

    • Uses of JPanel in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return JPanel
      修饰符与类型 | 方法与描述
      JPanel | BasicFileChooserUI.getAccessoryPanel()
      Methods in javax.swing.plaf.basic with parameters of type JPanel
      修饰符与类型 | 方法与描述
      protected void | BasicPanelUI.installDefaults(JPanel p)
      protected void | BasicPanelUI.uninstallDefaults(JPanel p)

    • Uses of JPanel in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return JPanel
      修饰符与类型 | 方法与描述
      protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
      protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
      protected JPanel | MetalFileChooserUI.getBottomPanel()
      protected JPanel | MetalFileChooserUI.getButtonPanel()

    • Uses of JPanel in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JPanel
      修饰符与类型 | 方法与描述
      protected void | SynthPanelUI.installDefaults(JPanel p)
      protected void SynthPanelUI.installListeners(JPanel p)
      Installs listeners into the panel.
      protected void | SynthPanelUI.uninstallDefaults(JPanel p)
      protected void SynthPanelUI.uninstallListeners(JPanel p)
      Uninstalls listeners from the panel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acl .thr1mw//envutv


Uses of Class javax.swing.JPanel.AccessibleJPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPanel.AccessibleJPanel

No usage of javax.swing.JPanel.AccessibleJPanel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h>a ruenrssseb<<" ad


Uses of Class javax.swing.JPasswordField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPasswordField

No usage of javax.swing.JPasswordField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elrunp peulvi >详磕�


Uses of Class javax.swing.JPasswordField.AccessibleJPasswordField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPasswordField.AccessibleJPasswordField

No usage of javax.swing.JPasswordField.AccessibleJPasswordField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nbg//..=f"""hrttsttd>


Uses of Class javax.swing.JPopupMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPopupMenu

  • Packages that use JPopupMenu
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JPopupMenu in javax.swing

      Methods in javax.swing that return JPopupMenu
      修饰符与类型 方法与描述
      JPopupMenu JComponent.getComponentPopupMenu()
      Returns JPopupMenu that assigned for this component.
      JPopupMenu JMenu.getPopupMenu()
      Returns the popupmenu associated with this menu.
      Methods in javax.swing with parameters of type JPopupMenu
      修饰符与类型 方法与描述
      protected JMenu.WinListener JMenu.createWinListener(JPopupMenu p)
      Creates a window-closing listener for the popup.
      void JComponent.setComponentPopupMenu(JPopupMenu popup)
      Sets the JPopupMenu for this JComponent.
      Constructors in javax.swing with parameters of type JPopupMenu
      构造方法与描述
      JMenu.WinListener(JPopupMenu p)
      Create the window listener for the specified popup.

    • Uses of JPopupMenu in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JPopupMenu
      修饰符与类型 方法与描述
      Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
      Returns the Popup that will be responsible for displaying the JPopupMenu.

    • Uses of JPopupMenu in javax.swing.plaf.basic

      Subclasses of JPopupMenu in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicComboPopup
      This is a basic implementation of the ComboPopup interface.
      Fields in javax.swing.plaf.basic declared as JPopupMenu
      修饰符与类型 | 字段与描述
      protected JPopupMenu | BasicPopupMenuUI.popupMenu

    • Uses of JPopupMenu in javax.swing.plaf.metal

      Subclasses of JPopupMenu in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.

    • Uses of JPopupMenu in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JPopupMenu
      修饰符与类型 方法与描述
      Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
      Invokes the getPopup method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mDenn"l_tfaac">fa


Uses of Class javax.swing.JPopupMenu.AccessibleJPopupMenu

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPopupMenu.AccessibleJPopupMenu

No usage of javax.swing.JPopupMenu.AccessibleJPopupMenu
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a9cb鹹tu>-h/>os>o=


Uses of Class javax.swing.JPopupMenu.Separator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JPopupMenu.Separator

No usage of javax.swing.JPopupMenu.Separator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ri>aan><;///bbaagaePn


Uses of Class javax.swing.JProgressBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JProgressBar

  • Packages that use JProgressBar
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JProgressBar in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JProgressBar
      修饰符与类型 | 字段与描述
      protected JProgressBar | BasicProgressBarUI.progressBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


Uses of Class javax.swing.JProgressBar.AccessibleJProgressBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JProgressBar.AccessibleJProgressBar

No usage of javax.swing.JProgressBar.AccessibleJProgressBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nv>tlo=listlc


Uses of Class javax.swing.JRadioButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRadioButton

No usage of javax.swing.JRadioButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f9 ifisininoe s/阻态


Uses of Class javax.swing.JRadioButton.AccessibleJRadioButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRadioButton.AccessibleJRadioButton

No usage of javax.swing.JRadioButton.AccessibleJRadioButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. /r> =a< l>lllri<>


Uses of Class javax.swing.JRadioButtonMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRadioButtonMenuItem

No usage of javax.swing.JRadioButtonMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

maotnonocti ean�"nt.�


Uses of Class javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

No usage of javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

FckElitrcsm.ani>nx


Uses of Class javax.swing.JRootPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRootPane

  • Packages that use JRootPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JRootPane in javax.swing

      Fields in javax.swing declared as JRootPane
      修饰符与类型 | 字段与描述
      protected JRootPane | JApplet.rootPane
      protected JRootPane JInternalFrame.rootPane
      The JRootPane instance that manages the content pane and optional menu bar for this internal frame, as well as the glass pane.
      protected JRootPane | JDialog.rootPane
      protected JRootPane JWindow.rootPane
      The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
      protected JRootPane JFrame.rootPane
      The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
      Methods in javax.swing that return JRootPane
      修饰符与类型 方法与描述
      protected JRootPane JApplet.createRootPane()
      Called by the constructor methods to create the default rootPane.
      protected JRootPane JInternalFrame.createRootPane()
      Called by the constructor to set up the JRootPane.
      protected JRootPane JDialog.createRootPane()
      Called by the constructor methods to create the default rootPane.
      protected JRootPane JWindow.createRootPane()
      Called by the constructor methods to create the default rootPane.
      protected JRootPane JFrame.createRootPane()
      Called by the constructor methods to create the default rootPane.
      JRootPane JApplet.getRootPane()
      Returns the rootPane object for this applet.
      JRootPane JInternalFrame.getRootPane()
      Returns the rootPane object for this internal frame.
      JRootPane JDialog.getRootPane()
      Returns the rootPane object for this dialog.
      JRootPane JWindow.getRootPane()
      Returns the rootPane object for this window.
      JRootPane JComponent.getRootPane()
      Returns the JRootPane ancestor for this component.
      JRootPane RootPaneContainer.getRootPane()
      Return this component's single JRootPane child.
      JRootPane JFrame.getRootPane()
      Returns the rootPane object for this frame.
      static JRootPane SwingUtilities.getRootPane(Component c)
      If c is a JRootPane descendant return its JRootPane ancestor.
      Methods in javax.swing with parameters of type JRootPane
      修饰符与类型 方法与描述
      protected void JApplet.setRootPane(JRootPane root)
      Sets the rootPane property.
      protected void JInternalFrame.setRootPane(JRootPane root)
      Sets the rootPane property for this JInternalFrame.
      protected void JDialog.setRootPane(JRootPane root)
      Sets the rootPane property.
      protected void JWindow.setRootPane(JRootPane root)
      Sets the new rootPane object for this window.
      protected void JFrame.setRootPane(JRootPane root)
      Sets the rootPane property.

    • Uses of JRootPane in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type JRootPane
      修饰符与类型 | 方法与描述
      protected void | BasicRootPaneUI.installComponents(JRootPane root)
      protected void | BasicRootPaneUI.installDefaults(JRootPane c)
      protected void | BasicRootPaneUI.installKeyboardActions(JRootPane root)
      protected void | BasicRootPaneUI.installListeners(JRootPane root)
      protected void | BasicRootPaneUI.uninstallComponents(JRootPane root)
      protected void | BasicRootPaneUI.uninstallDefaults(JRootPane root)
      protected void | BasicRootPaneUI.uninstallKeyboardActions(JRootPane root)
      protected void | BasicRootPaneUI.uninstallListeners(JRootPane root)

    • Uses of JRootPane in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JRootPane
      修饰符与类型 | 方法与描述
      protected void | SynthRootPaneUI.installDefaults(JRootPane c)
      protected void | SynthRootPaneUI.uninstallDefaults(JRootPane root)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Nd(cssn=rLggg>"s瞓a>


Uses of Class javax.swing.JRootPane.AccessibleJRootPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRootPane.AccessibleJRootPane

No usage of javax.swing.JRootPane.AccessibleJRootPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h=l� >.eas,csercl竩


Uses of Class javax.swing.JRootPane.RootLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JRootPane.RootLayout

No usage of javax.swing.JRootPane.RootLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>ss="cittttlP//c"ls/


Uses of Class javax.swing.JScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JScrollBar

  • Packages that use JScrollBar
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JScrollBar in javax.swing

      Subclasses of JScrollBar in javax.swing
      修饰符与类型 类与描述
      protected class  JScrollPane.ScrollBar
      By default JScrollPane creates scrollbars that are instances of this class.
      Fields in javax.swing declared as JScrollBar
      修饰符与类型 字段与描述
      protected JScrollBar JScrollPane.horizontalScrollBar
      The scrollpane's horizontal scrollbar child.
      protected JScrollBar ScrollPaneLayout.hsb
      The scrollpane's horizontal scrollbar child.
      protected JScrollBar JScrollPane.verticalScrollBar
      The scrollpane's vertical scrollbar child.
      protected JScrollBar ScrollPaneLayout.vsb
      The scrollpane's vertical scrollbar child.
      Methods in javax.swing that return JScrollBar
      修饰符与类型 方法与描述
      JScrollBar JScrollPane.createHorizontalScrollBar()
      Returns a JScrollPane.ScrollBar by default.
      JScrollBar JScrollPane.createVerticalScrollBar()
      Returns a JScrollPane.ScrollBar by default.
      JScrollBar ScrollPaneLayout.getHorizontalScrollBar()
      Returns the JScrollBar object that handles horizontal scrolling.
      JScrollBar JScrollPane.getHorizontalScrollBar()
      Returns the horizontal scroll bar that controls the viewport's horizontal view position.
      JScrollBar ScrollPaneLayout.getVerticalScrollBar()
      Returns the JScrollBar object that handles vertical scrolling.
      JScrollBar JScrollPane.getVerticalScrollBar()
      Returns the vertical scroll bar that controls the viewports vertical view position.
      Methods in javax.swing with parameters of type JScrollBar
      修饰符与类型 方法与描述
      void JScrollPane.setHorizontalScrollBar(JScrollBar horizontalScrollBar)
      Adds the scrollbar that controls the viewport's horizontal view position to the scrollpane.
      void JScrollPane.setVerticalScrollBar(JScrollBar verticalScrollBar)
      Adds the scrollbar that controls the viewports vertical view position to the scrollpane.

    • Uses of JScrollBar in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JScrollBar
      修饰符与类型 | 字段与描述
      protected JScrollBar | BasicScrollBarUI.scrollbar
      protected JScrollBar BasicTreeUI.ComponentHandler.scrollBar
      ScrollBar that is being adjusted.
      Methods in javax.swing.plaf.basic with parameters of type JScrollBar
      修饰符与类型 | 方法与描述
      protected void | BasicScrollBarUI.layoutHScrollbar(JScrollBar sb)
      protected void | BasicScrollBarUI.layoutVScrollbar(JScrollBar sb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

srlCl<


Uses of Class javax.swing.JScrollBar.AccessibleJScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JScrollBar.AccessibleJScrollBar

No usage of javax.swing.JScrollBar.AccessibleJScrollBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c> >.t.ee >o."s t"


Uses of Class javax.swing.JScrollPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JScrollPane

  • Packages that use JScrollPane
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JScrollPane in javax.swing

      Methods in javax.swing that return JScrollPane
      修饰符与类型 方法与描述
      static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
      Deprecated.
      As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
      Methods in javax.swing with parameters of type JScrollPane
      修饰符与类型 方法与描述
      Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
      Deprecated.
      As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().
      void ScrollPaneLayout.syncWithScrollPane(JScrollPane sp)
      This method is invoked after the ScrollPaneLayout is set as the LayoutManager of a JScrollPane.

    • Uses of JScrollPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JScrollPane
      修饰符与类型 | 字段与描述
      protected JScrollPane BasicComboPopup.scroller
      This protected field is implementation specific.
      protected JScrollPane | BasicScrollPaneUI.scrollpane
      Methods in javax.swing.plaf.basic that return JScrollPane
      修饰符与类型 方法与描述
      protected JScrollPane BasicComboPopup.createScroller()
      Creates the scroll pane which houses the scrollable list.
      protected JScrollPane BasicTreeUI.ComponentHandler.getScrollPane()
      Returns the JScrollPane housing the JTree, or null if one isn't found.
      Methods in javax.swing.plaf.basic with parameters of type JScrollPane
      修饰符与类型 | 方法与描述
      protected void | BasicScrollPaneUI.installDefaults(JScrollPane scrollpane)
      protected void | BasicScrollPaneUI.installKeyboardActions(JScrollPane c)
      protected void | BasicScrollPaneUI.installListeners(JScrollPane c)
      protected void | BasicScrollPaneUI.uninstallDefaults(JScrollPane c)
      protected void | BasicScrollPaneUI.uninstallKeyboardActions(JScrollPane c)

    • Uses of JScrollPane in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JScrollPane
      修饰符与类型 | 方法与描述
      void | MetalScrollPaneUI.installListeners(JScrollPane scrollPane)
      void MetalScrollPaneUI.uninstallListeners(JScrollPane scrollPane)
      Deprecated.
      - Replaced by MetalScrollPaneUI.uninstallListeners(JComponent)

    • Uses of JScrollPane in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JScrollPane
      修饰符与类型 | 方法与描述
      protected void | SynthScrollPaneUI.installDefaults(JScrollPane scrollpane)
      protected void | SynthScrollPaneUI.installListeners(JScrollPane c)
      protected void | SynthScrollPaneUI.uninstallDefaults(JScrollPane c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vb/agvg


Uses of Class javax.swing.JScrollPane.AccessibleJScrollPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JScrollPane.AccessibleJScrollPane

No usage of javax.swing.JScrollPane.AccessibleJScrollPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"">sLas"=ccca>aapdro�


Uses of Class javax.swing.JScrollPane.ScrollBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JScrollPane.ScrollBar

No usage of javax.swing.JScrollPane.ScrollBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w=iiclalteee nnna i=g


Uses of Class javax.swing.JSeparator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSeparator

  • Packages that use JSeparator
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JSeparator in javax.swing

      Subclasses of JSeparator in javax.swing
      修饰符与类型 类与描述
      static class  JPopupMenu.Separator
      A popup menu-specific separator.
      static class  JToolBar.Separator
      A toolbar-specific separator.

    • Uses of JSeparator in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type JSeparator
      修饰符与类型 | 方法与描述
      protected void | BasicToolBarSeparatorUI.installDefaults(JSeparator s)
      protected void | BasicSeparatorUI.installDefaults(JSeparator s)
      protected void | BasicSeparatorUI.installListeners(JSeparator s)
      protected void | BasicSeparatorUI.uninstallDefaults(JSeparator s)
      protected void | BasicSeparatorUI.uninstallListeners(JSeparator s)

    • Uses of JSeparator in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JSeparator
      修饰符与类型 | 方法与描述
      protected void | MetalSeparatorUI.installDefaults(JSeparator s)

    • Uses of JSeparator in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JSeparator
      修饰符与类型 方法与描述
      void SynthSeparatorUI.installDefaults(JSeparator c)
      Installs default setting.
      void SynthSeparatorUI.installListeners(JSeparator c)
      Installs listeners.
      void SynthSeparatorUI.uninstallDefaults(JSeparator c)
      Uninstalls default setting.
      void SynthSeparatorUI.uninstallListeners(JSeparator c)
      Uninstalls listeners.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toee>/ sh".ffP.Jt/ecx


Uses of Class javax.swing.JSeparator.AccessibleJSeparator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSeparator.AccessibleJSeparator

No usage of javax.swing.JSeparator.AccessibleJSeparator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=/ocxsm


Uses of Class javax.swing.JSlider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSlider

  • Packages that use JSlider
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JSlider in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JSlider
      修饰符与类型 | 字段与描述
      protected JSlider | BasicSliderUI.slider
      Methods in javax.swing.plaf.basic with parameters of type JSlider
      修饰符与类型 | 方法与描述
      protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
      protected ComponentListener | BasicSliderUI.createComponentListener(JSlider slider)
      protected FocusListener | BasicSliderUI.createFocusListener(JSlider slider)
      protected PropertyChangeListener | BasicSliderUI.createPropertyChangeListener(JSlider slider)
      protected BasicSliderUI.ScrollListener | BasicSliderUI.createScrollListener(JSlider slider)
      protected BasicSliderUI.TrackListener | BasicSliderUI.createTrackListener(JSlider slider)
      protected void | BasicSliderUI.installDefaults(JSlider slider)
      protected void | BasicSliderUI.installKeyboardActions(JSlider slider)
      protected void | BasicSliderUI.installListeners(JSlider slider)
      protected void | BasicSliderUI.uninstallDefaults(JSlider slider)
      protected void | BasicSliderUI.uninstallKeyboardActions(JSlider slider)
      protected void | BasicSliderUI.uninstallListeners(JSlider slider)
      Constructors in javax.swing.plaf.basic with parameters of type JSlider
      构造方法与描述
      BasicSliderUI.ActionScroller(JSlider slider, int dir, boolean block)
      BasicSliderUI(JSlider b)

    • Uses of JSlider in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type JSlider
      修饰符与类型 | 方法与描述
      protected PropertyChangeListener | MetalSliderUI.createPropertyChangeListener(JSlider slider)

    • Uses of JSlider in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JSlider
      修饰符与类型 | 方法与描述
      protected BasicSliderUI.TrackListener | SynthSliderUI.createTrackListener(JSlider s)
      protected void | SynthSliderUI.installDefaults(JSlider slider)
      protected void | SynthSliderUI.installListeners(JSlider slider)
      protected void SynthSliderUI.uninstallDefaults(JSlider slider)
      Uninstalls default setting.
      protected void | SynthSliderUI.uninstallListeners(JSlider slider)
      Constructors in javax.swing.plaf.synth with parameters of type JSlider
      构造方法与描述
      SynthSliderUI(JSlider c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ml=fsdeloel&/p=w


Uses of Class javax.swing.JSlider.AccessibleJSlider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSlider.AccessibleJSlider

No usage of javax.swing.JSlider.AccessibleJSlider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a vcitllm""".eJJdo>lo


Uses of Class javax.swing.JSpinner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner

  • Packages that use JSpinner
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JSpinner in javax.swing

      Methods in javax.swing that return JSpinner
      修饰符与类型 方法与描述
      JSpinner JSpinner.DefaultEditor.getSpinner()
      Returns the JSpinner ancestor of this editor or null if none of the ancestors are a JSpinner.
      Methods in javax.swing with parameters of type JSpinner
      修饰符与类型 方法与描述
      void JSpinner.DefaultEditor.dismiss(JSpinner spinner)
      Disconnect this editor from the specified JSpinner.
      Constructors in javax.swing with parameters of type JSpinner
      构造方法与描述
      JSpinner.DateEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.
      JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.
      JSpinner.DefaultEditor(JSpinner spinner)
      Constructs an editor component for the specified JSpinner.
      JSpinner.ListEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerListModel with a JFormattedTextField.
      JSpinner.NumberEditor(JSpinner spinner)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.
      JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
      Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.

    • Uses of JSpinner in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JSpinner
      修饰符与类型 字段与描述
      protected JSpinner BasicSpinnerUI.spinner
      The spinner that we're a UI delegate for.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>/>


Uses of Class javax.swing.JSpinner.AccessibleJSpinner

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner.AccessibleJSpinner

No usage of javax.swing.JSpinner.AccessibleJSpinner
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ppacon"naaaaxannergpn


Uses of Class javax.swing.JSpinner.DateEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner.DateEditor

No usage of javax.swing.JSpinner.DateEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sstＨ�/�o>


Uses of Class javax.swing.JSpinner.DefaultEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner.DefaultEditor

  • Packages that use JSpinner.DefaultEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JSpinner.DefaultEditor in javax.swing

      Subclasses of JSpinner.DefaultEditor in javax.swing
      修饰符与类型 类与描述
      static class  JSpinner.DateEditor
      An editor for a JSpinner whose model is a SpinnerDateModel.
      static class  JSpinner.ListEditor
      An editor for a JSpinner whose model is a SpinnerListModel.
      static class  JSpinner.NumberEditor
      An editor for a JSpinner whose model is a SpinnerNumberModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/ rlLl l c ve=/ht


Uses of Class javax.swing.JSpinner.ListEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner.ListEditor

No usage of javax.swing.JSpinner.ListEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rjykng//xsssa/ miah<


Uses of Class javax.swing.JSpinner.NumberEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSpinner.NumberEditor

No usage of javax.swing.JSpinner.NumberEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cislrt.y)nc>an


Uses of Class javax.swing.JSplitPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSplitPane

  • Packages that use JSplitPane
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of JSplitPane in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JSplitPane
      修饰符与类型 方法与描述
      abstract void SplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g)
      Messaged after the JSplitPane the receiver is providing the look and feel for paints its children.
      abstract int SplitPaneUI.getDividerLocation(JSplitPane jc)
      Returns the location of the divider.
      abstract int SplitPaneUI.getMaximumDividerLocation(JSplitPane jc)
      Returns the maximum possible location of the divider.
      abstract int SplitPaneUI.getMinimumDividerLocation(JSplitPane jc)
      Returns the minimum possible location of the divider.
      abstract void SplitPaneUI.resetToPreferredSizes(JSplitPane jc)
      Messaged to relayout the JSplitPane based on the preferred size of the children components.
      abstract void SplitPaneUI.setDividerLocation(JSplitPane jc, int location)
      Sets the location of the divider to location.

    • Uses of JSplitPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JSplitPane
      修饰符与类型 字段与描述
      protected JSplitPane BasicSplitPaneUI.splitPane
      JSplitPane instance this instance is providing the look and feel for.
      protected JSplitPane BasicSplitPaneDivider.splitPane
      JSplitPane the receiver is contained in.
      Methods in javax.swing.plaf.basic that return JSplitPane
      修饰符与类型 方法与描述
      JSplitPane BasicSplitPaneUI.getSplitPane()
      Returns the splitpane this instance is currently contained in.
      Methods in javax.swing.plaf.basic with parameters of type JSplitPane
      修饰符与类型 方法与描述
      void BasicSplitPaneUI.finishedPaintingChildren(JSplitPane sp, Graphics g)
      Called when the specified split pane has finished painting its children.
      int BasicSplitPaneUI.getDividerLocation(JSplitPane jc)
      Returns the location of the divider, which may differ from what the splitpane thinks the location of the divider is.
      int BasicSplitPaneUI.getMaximumDividerLocation(JSplitPane jc)
      Gets the maximum location of the divider.
      int BasicSplitPaneUI.getMinimumDividerLocation(JSplitPane jc)
      Gets the minimum location of the divider.
      void BasicSplitPaneUI.resetToPreferredSizes(JSplitPane jc)
      Messaged to reset the preferred sizes.
      void BasicSplitPaneUI.setDividerLocation(JSplitPane jc, int location)
      Sets the location of the divider to location.

    • Uses of JSplitPane in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JSplitPane
      修饰符与类型 方法与描述
      void MultiSplitPaneUI.finishedPaintingChildren(JSplitPane a, Graphics b)
      Invokes the finishedPaintingChildren method on each UI handled by this object.
      int MultiSplitPaneUI.getDividerLocation(JSplitPane a)
      Invokes the getDividerLocation method on each UI handled by this object.
      int MultiSplitPaneUI.getMaximumDividerLocation(JSplitPane a)
      Invokes the getMaximumDividerLocation method on each UI handled by this object.
      int MultiSplitPaneUI.getMinimumDividerLocation(JSplitPane a)
      Invokes the getMinimumDividerLocation method on each UI handled by this object.
      void MultiSplitPaneUI.resetToPreferredSizes(JSplitPane a)
      Invokes the resetToPreferredSizes method on each UI handled by this object.
      void MultiSplitPaneUI.setDividerLocation(JSplitPane a, int b)
      Invokes the setDividerLocation method on each UI handled by this object.

    • Uses of JSplitPane in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type JSplitPane
      修饰符与类型 | 方法与描述
      void | SynthSplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/alat>tde>kbr=i1癶><


Uses of Class javax.swing.JSplitPane.AccessibleJSplitPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JSplitPane.AccessibleJSplitPane

No usage of javax.swing.JSplitPane.AccessibleJSplitPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r "rsauvahd_nt


Uses of Class javax.swing.JTabbedPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTabbedPane

  • Packages that use JTabbedPane
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of JTabbedPane in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JTabbedPane
      修饰符与类型 | 方法与描述
      abstract Rectangle | TabbedPaneUI.getTabBounds(JTabbedPane pane, int index)
      abstract int | TabbedPaneUI.getTabRunCount(JTabbedPane pane)
      abstract int | TabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y)

    • Uses of JTabbedPane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JTabbedPane
      修饰符与类型 | 字段与描述
      protected JTabbedPane | BasicTabbedPaneUI.tabPane
      Methods in javax.swing.plaf.basic with parameters of type JTabbedPane
      修饰符与类型 | 方法与描述
      Rectangle BasicTabbedPaneUI.getTabBounds(JTabbedPane pane, int i)
      Returns the bounds of the specified tab index.
      int | BasicTabbedPaneUI.getTabRunCount(JTabbedPane pane)
      int BasicTabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y)
      Returns the tab index which intersects the specified point in the JTabbedPane's coordinate space.

    • Uses of JTabbedPane in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JTabbedPane
      修饰符与类型 方法与描述
      Rectangle MultiTabbedPaneUI.getTabBounds(JTabbedPane a, int b)
      Invokes the getTabBounds method on each UI handled by this object.
      int MultiTabbedPaneUI.getTabRunCount(JTabbedPane a)
      Invokes the getTabRunCount method on each UI handled by this object.
      int MultiTabbedPaneUI.tabForCoordinate(JTabbedPane a, int b, int c)
      Invokes the tabForCoordinate method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

secthpmaPbnl-<.nJei.Jner


Uses of Class javax.swing.JTabbedPane.AccessibleJTabbedPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTabbedPane.AccessibleJTabbedPane

No usage of javax.swing.JTabbedPane.AccessibleJTabbedPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. . ng>s/tttaieedixnd


Uses of Class javax.swing.JTabbedPane.ModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTabbedPane.ModelListener

No usage of javax.swing.JTabbedPane.ModelListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

& n apnnnse""v.//>


Uses of Class javax.swing.JTable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable

  • Packages that use JTable
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of JTable in javax.swing

      Methods in javax.swing with parameters of type JTable
      修饰符与类型 方法与描述
      static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
      Deprecated.
      As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
      Component DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
      Implements the TableCellEditor interface.
      Constructors in javax.swing with parameters of type JTable
      构造方法与描述
      JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
      Constructs an AccessibleJTableHeaderEntry.

    • Uses of JTable in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JTable
      修饰符与类型 | 字段与描述
      protected JTable | BasicTableUI.table

    • Uses of JTable in javax.swing.table

      Fields in javax.swing.table declared as JTable
      修饰符与类型 字段与描述
      protected JTable JTableHeader.table
      The table for which this object is the header; the default is null.
      Methods in javax.swing.table that return JTable
      修饰符与类型 方法与描述
      JTable JTableHeader.getTable()
      Returns the table associated with this header.
      Methods in javax.swing.table with parameters of type JTable
      修饰符与类型 方法与描述
      Component TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
      Sets an initial value for the editor.
      Component DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      Returns the default table cell renderer.
      Component TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      Returns the component used for drawing the cell.
      void JTableHeader.setTable(JTable table)
      Sets the table associated with this header.
      Constructors in javax.swing.table with parameters of type JTable
      构造方法与描述
      JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
      Constructs an AccessiblJTableHeaaderEntry
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dsd>onaeA.hz>ajnve錭l>/t


Uses of Class javax.swing.JTable.AccessibleJTable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable.AccessibleJTable

No usage of javax.swing.JTable.AccessibleJTable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drettt-redstt侗E姆�


Uses of Class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

No usage of javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/l]=ah 瞨>.2


Uses of Class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

No usage of javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

RlrgbeaJ.sTeDT_ a.ra


Uses of Class javax.swing.JTable.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable.DropLocation

  • Packages that use JTable.DropLocation
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTable.DropLocation in javax.swing

      Methods in javax.swing that return JTable.DropLocation
      修饰符与类型 方法与描述
      JTable.DropLocation JTable.getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aac皌h =da .osaa/�>lie/a


Uses of Class javax.swing.JTable.PrintMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTable.PrintMode

  • Packages that use JTable.PrintMode
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTable.PrintMode in javax.swing

      Methods in javax.swing that return JTable.PrintMode
      修饰符与类型 方法与描述
      static JTable.PrintMode JTable.PrintMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JTable.PrintMode[] JTable.PrintMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.swing with parameters of type JTable.PrintMode
      修饰符与类型 方法与描述
      Printable JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      Return a Printable for use in printing this JTable.
      boolean JTable.print(JTable.PrintMode printMode)
      A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with no header or footer text.
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
      A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with the specified header and footer text.
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive)
      Prints this table, as specified by the fully featured print method, with the default printer specified as the print service.
      boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
      Prints this JTable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a#s"olLss===ct//mtmaotn>c


Uses of Class javax.swing.JTextArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTextArea

No usage of javax.swing.JTextArea
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acoa i dokgdaix骷h


Uses of Class javax.swing.JTextArea.AccessibleJTextArea

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTextArea.AccessibleJTextArea

No usage of javax.swing.JTextArea.AccessibleJTextArea
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e3nsnsteh goss>lal


Uses of Class javax.swing.JTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTextField

  • Packages that use JTextField
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of JTextField in javax.swing

      Subclasses of JTextField in javax.swing
      修饰符与类型 类与描述
      class  JFormattedTextField
      JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
      class  JPasswordField
      JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
      Constructors in javax.swing with parameters of type JTextField
      构造方法与描述
      DefaultCellEditor(JTextField textField)
      Constructs a DefaultCellEditor that uses a text field.

    • Uses of JTextField in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JTextField
      修饰符与类型 | 字段与描述
      protected JTextField | BasicComboBoxEditor.editor
      Methods in javax.swing.plaf.basic that return JTextField
      修饰符与类型 方法与描述
      protected JTextField BasicComboBoxEditor.createEditorComponent()
      Creates the internal editor component.

    • Uses of JTextField in javax.swing.tree

      Subclasses of JTextField in javax.swing.tree
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a=約ki"s{,f" dE"v"e xid>


Uses of Class javax.swing.JTextField.AccessibleJTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTextField.AccessibleJTextField

  • Packages that use JTextField.AccessibleJTextField
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTextField.AccessibleJTextField in javax.swing

      Subclasses of JTextField.AccessibleJTextField in javax.swing
      修饰符与类型 类与描述
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-eail


Uses of Class javax.swing.JTextPane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTextPane

No usage of javax.swing.JTextPane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>rpg dadddeecccrk=d


Uses of Class javax.swing.JToggleButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToggleButton

  • Packages that use JToggleButton
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JToggleButton in javax.swing

      Subclasses of JToggleButton in javax.swing
      修饰符与类型 类与描述
      class  JCheckBox
      An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
      class  JRadioButton
      An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtgmeh h.m"atl""惮鹊蝖缘7


Uses of Class javax.swing.JToggleButton.AccessibleJToggleButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToggleButton.AccessibleJToggleButton

  • Packages that use JToggleButton.AccessibleJToggleButton
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JToggleButton.AccessibleJToggleButton in javax.swing

      Subclasses of JToggleButton.AccessibleJToggleButton in javax.swing
      修饰符与类型 类与描述
      protected class  JCheckBox.AccessibleJCheckBox
      This class implements accessibility support for the JCheckBox class.
      protected class  JRadioButton.AccessibleJRadioButton
      This class implements accessibility support for the JRadioButton class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

si<


Uses of Class javax.swing.JToggleButton.ToggleButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToggleButton.ToggleButtonModel

No usage of javax.swing.JToggleButton.ToggleButtonModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>< trof_iiitv>>< bia


Uses of Class javax.swing.JToolBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToolBar

  • Packages that use JToolBar
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of JToolBar in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JToolBar
      修饰符与类型 | 字段与描述
      protected JToolBar | BasicToolBarUI.toolBar
      protected JToolBar | BasicToolBarUI.DockingListener.toolBar
      Methods in javax.swing.plaf.basic with parameters of type JToolBar
      修饰符与类型 | 方法与描述
      protected BasicToolBarUI.DragWindow | BasicToolBarUI.createDragWindow(JToolBar toolbar)
      protected JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
      No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
      protected RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
      Creates a window which contains the toolbar after it has been dragged out from its container
      Constructors in javax.swing.plaf.basic with parameters of type JToolBar
      构造方法与描述
      BasicToolBarUI.DockingListener(JToolBar t)

    • Uses of JToolBar in javax.swing.plaf.metal

      Constructors in javax.swing.plaf.metal with parameters of type JToolBar
      构造方法与描述
      MetalToolBarUI.MetalDockingListener(JToolBar t)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lL3nl-lea


Uses of Class javax.swing.JToolBar.AccessibleJToolBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToolBar.AccessibleJToolBar

No usage of javax.swing.JToolBar.AccessibleJToolBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-tsn>sl><�>g/s�


Uses of Class javax.swing.JToolBar.Separator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToolBar.Separator

No usage of javax.swing.JToolBar.Separator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>v.hre>g<<


Uses of Class javax.swing.JToolTip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToolTip

  • Packages that use JToolTip
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JToolTip in javax.swing

      Methods in javax.swing that return JToolTip
      修饰符与类型 方法与描述
      JToolTip JComponent.createToolTip()
      Returns the instance of JToolTip that should be used to display the tooltip.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rid葀ih.a.>Lf詉 a


Uses of Class javax.swing.JToolTip.AccessibleJToolTip

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JToolTip.AccessibleJToolTip

No usage of javax.swing.JToolTip.AccessibleJToolTip
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fiepg/.sts/attca�>m


Uses of Class javax.swing.JTree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree

  • Packages that use JTree
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of JTree in javax.swing

      Methods in javax.swing with parameters of type JTree
      修饰符与类型 方法与描述
      Component DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Implements the TreeCellEditor interface.
      Constructors in javax.swing with parameters of type JTree
      构造方法与描述
      JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
      Constructs an AccessibleJTreeNode

    • Uses of JTree in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JTree
      修饰符与类型 方法与描述
      abstract void TreeUI.cancelEditing(JTree tree)
      Cancels the current editing session.
      abstract TreePath TreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath TreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      abstract Rectangle TreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      abstract TreePath TreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      abstract int TreeUI.getRowCount(JTree tree)
      Returns the number of rows that are being displayed.
      abstract int TreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract boolean TreeUI.isEditing(JTree tree)
      Returns true if the tree is being edited.
      abstract void TreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      abstract boolean TreeUI.stopEditing(JTree tree)
      Stops the current editing session.

    • Uses of JTree in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JTree
      修饰符与类型 字段与描述
      protected JTree BasicTreeUI.tree
      Component that we're going to be drawing into.
      Methods in javax.swing.plaf.basic with parameters of type JTree
      修饰符与类型 方法与描述
      void BasicTreeUI.cancelEditing(JTree tree)
      Cancels the current editing session.
      TreePath BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath BasicTreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      Rectangle BasicTreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      TreePath BasicTreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      int BasicTreeUI.getRowCount(JTree tree)
      Returns the number of rows that are being displayed.
      int BasicTreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      boolean BasicTreeUI.isEditing(JTree tree)
      Returns true if the tree is being edited.
      void BasicTreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      boolean BasicTreeUI.stopEditing(JTree tree)
      Stops the current editing session.

    • Uses of JTree in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JTree
      修饰符与类型 方法与描述
      void MultiTreeUI.cancelEditing(JTree a)
      Invokes the cancelEditing method on each UI handled by this object.
      TreePath MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c)
      Invokes the getClosestPathForLocation method on each UI handled by this object.
      TreePath MultiTreeUI.getEditingPath(JTree a)
      Invokes the getEditingPath method on each UI handled by this object.
      Rectangle MultiTreeUI.getPathBounds(JTree a, TreePath b)
      Invokes the getPathBounds method on each UI handled by this object.
      TreePath MultiTreeUI.getPathForRow(JTree a, int b)
      Invokes the getPathForRow method on each UI handled by this object.
      int MultiTreeUI.getRowCount(JTree a)
      Invokes the getRowCount method on each UI handled by this object.
      int MultiTreeUI.getRowForPath(JTree a, TreePath b)
      Invokes the getRowForPath method on each UI handled by this object.
      boolean MultiTreeUI.isEditing(JTree a)
      Invokes the isEditing method on each UI handled by this object.
      void MultiTreeUI.startEditingAtPath(JTree a, TreePath b)
      Invokes the startEditingAtPath method on each UI handled by this object.
      boolean MultiTreeUI.stopEditing(JTree a)
      Invokes the stopEditing method on each UI handled by this object.

    • Uses of JTree in javax.swing.tree

      Fields in javax.swing.tree declared as JTree
      修饰符与类型 字段与描述
      protected JTree DefaultTreeCellEditor.tree
      JTree instance listening too.
      Methods in javax.swing.tree with parameters of type JTree
      修饰符与类型 | 方法与描述
      protected void | DefaultTreeCellEditor.determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Component DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Configures the editor.
      Component TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Sets an initial value for the editor.
      Component DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Configures the renderer based on the passed in components.
      Component TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Sets the value of the current tree cell to value.
      protected void DefaultTreeCellEditor.setTree(JTree newTree)
      Sets the tree currently editing for.
      Constructors in javax.swing.tree with parameters of type JTree
      构造方法与描述
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.JTree.AccessibleJTree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.AccessibleJTree

No usage of javax.swing.JTree.AccessibleJTree
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acoa i dokgdaix骷h


Uses of Class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

No usage of javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

th>>i <薲dli>�-


Uses of Class javax.swing.JTree.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.DropLocation

  • Packages that use JTree.DropLocation
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of JTree.DropLocation in javax.swing

      Methods in javax.swing that return JTree.DropLocation
      修饰符与类型 方法与描述
      JTree.DropLocation JTree.getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

    • Uses of JTree.DropLocation in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type JTree.DropLocation
      修饰符与类型 方法与描述
      protected Rectangle BasicTreeUI.getDropLineRect(JTree.DropLocation loc)
      Returns a ubounding box for the drop line.
      protected boolean BasicTreeUI.isDropLine(JTree.DropLocation loc)
      Tells if a DropLocation should be indicated by a line between nodes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/i


Uses of Class javax.swing.JTree.DynamicUtilTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.DynamicUtilTreeNode

No usage of javax.swing.JTree.DynamicUtilTreeNode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cw"..swajvvve"ssoy>.=


Uses of Class javax.swing.JTree.EmptySelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.EmptySelectionModel

  • Packages that use JTree.EmptySelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTree.EmptySelectionModel in javax.swing

      Fields in javax.swing declared as JTree.EmptySelectionModel
      修饰符与类型 字段与描述
      protected static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance
      The single instance of EmptySelectionModel.
      Methods in javax.swing that return JTree.EmptySelectionModel
      修饰符与类型 方法与描述
      static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance()
      Returns the single instance of EmptySelectionModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oa tdoaic../ef>s=


Uses of Class javax.swing.JTree.TreeModelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.TreeModelHandler

No usage of javax.swing.JTree.TreeModelHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltoacclo有�


Uses of Class javax.swing.JTree.TreeSelectionRedirector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JTree.TreeSelectionRedirector

  • Packages that use JTree.TreeSelectionRedirector
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTree.TreeSelectionRedirector in javax.swing

      Fields in javax.swing declared as JTree.TreeSelectionRedirector
      修饰符与类型 字段与描述
      protected JTree.TreeSelectionRedirector JTree.selectionRedirector
      Creates a new event and passed it off the selectionListeners.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w"s/ahc =riesAm at


Uses of Class javax.swing.JViewport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JViewport

  • Packages that use JViewport
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JViewport in javax.swing

      Fields in javax.swing declared as JViewport
      修饰符与类型 | 字段与描述
      protected JViewport ScrollPaneLayout.colHead
      The column header child.
      protected JViewport JScrollPane.columnHeader
      The column header child.
      protected JViewport ScrollPaneLayout.rowHead
      The row header child.
      protected JViewport JScrollPane.rowHeader
      The row header child.
      protected JViewport ScrollPaneLayout.viewport
      The scrollpane's viewport child.
      protected JViewport JScrollPane.viewport
      The scrollpane's viewport child.
      protected JViewport | JScrollPane.AccessibleJScrollPane.viewPort
      Methods in javax.swing that return JViewport
      修饰符与类型 方法与描述
      protected JViewport JScrollPane.createViewport()
      Returns a new JViewport by default.
      JViewport ScrollPaneLayout.getColumnHeader()
      Returns the JViewport object that is the column header.
      JViewport JScrollPane.getColumnHeader()
      Returns the column header.
      JViewport ScrollPaneLayout.getRowHeader()
      Returns the JViewport object that is the row header.
      JViewport JScrollPane.getRowHeader()
      Returns the row header.
      JViewport ScrollPaneLayout.getViewport()
      Returns the JViewport object that displays the scrollable contents.
      JViewport JScrollPane.getViewport()
      Returns the current JViewport.
      Methods in javax.swing with parameters of type JViewport
      修饰符与类型 方法与描述
      static Component SwingUtilities.getUnwrappedView(JViewport viewport)
      Returns the first JViewport's descendant which is not an instance of JLayer.
      void JScrollPane.setColumnHeader(JViewport columnHeader)
      Removes the old columnHeader, if it exists; if the new columnHeader isn't null, syncs the x coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.
      void JScrollPane.setRowHeader(JViewport rowHeader)
      Removes the old rowHeader, if it exists; if the new rowHeader isn't null, syncs the y coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.
      void JScrollPane.setViewport(JViewport viewport)
      Removes the old viewport (if there is one); forces the viewPosition of the new viewport to be in the +x,+y quadrant; syncs up the row and column headers (if there are any) with the new viewport; and finally syncs the scrollbars and headers with the new viewport.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aar r 羣>;." cr-


Uses of Class javax.swing.JViewport.AccessibleJViewport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JViewport.AccessibleJViewport

No usage of javax.swing.JViewport.AccessibleJViewport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aattst"anvvvs< gini


Uses of Class javax.swing.JViewport.ViewListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JViewport.ViewListener

  • Packages that use JViewport.ViewListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JViewport.ViewListener in javax.swing

      Methods in javax.swing that return JViewport.ViewListener
      修饰符与类型 方法与描述
      protected JViewport.ViewListener JViewport.createViewListener()
      Creates a listener for the view.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oitml"tr...wi//sa/.x/ivr


Uses of Class javax.swing.JWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JWindow

No usage of javax.swing.JWindow
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shbl. .sb>ae. cfr"a0


Uses of Class javax.swing.JWindow.AccessibleJWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.JWindow.AccessibleJWindow

No usage of javax.swing.JWindow.AccessibleJWindow
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a g.ref<>aaa


Uses of Class javax.swing.KeyStroke

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.KeyStroke

  • Packages that use KeyStroke
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of KeyStroke in javax.swing

      Methods in javax.swing that return KeyStroke
      修饰符与类型 方法与描述
      KeyStroke[] InputMap.allKeys()
      Returns an array of the KeyStrokes defined in this InputMap and its parent.
      KeyStroke JMenuItem.getAccelerator()
      Returns the KeyStroke which serves as an accelerator for the menu item.
      static KeyStroke KeyStroke.getKeyStroke(char keyChar)
      Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified character.
      static KeyStroke KeyStroke.getKeyStroke(Character keyChar, int modifiers)
      Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.
      static KeyStroke KeyStroke.getKeyStroke(char keyChar, boolean onKeyRelease)
      Deprecated.
      use getKeyStroke(char)
      static KeyStroke KeyStroke.getKeyStroke(int keyCode, int modifiers)
      Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers.
      static KeyStroke KeyStroke.getKeyStroke(int keyCode, int modifiers, boolean onKeyRelease)
      Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.
      static KeyStroke KeyStroke.getKeyStroke(String s)
      Parses a string and returns a KeyStroke.
      static KeyStroke KeyStroke.getKeyStrokeForEvent(KeyEvent anEvent)
      Returns a KeyStroke which represents the stroke which generated a given KeyEvent.
      KeyStroke[] JComponent.getRegisteredKeyStrokes()
      Returns the KeyStrokes that will initiate registered actions.
      KeyStroke[] InputMap.keys()
      Returns the KeyStrokes that are bound in this InputMap.
      Methods in javax.swing with parameters of type KeyStroke
      修饰符与类型 | 方法与描述
      Object InputMap.get(KeyStroke keyStroke)
      Returns the binding for keyStroke, messaging the parent InputMap if the binding is not locally defined.
      ActionListener JComponent.getActionForKeyStroke(KeyStroke aKeyStroke)
      Returns the object that will perform the action registered for a given keystroke.
      int JComponent.getConditionForKeyStroke(KeyStroke aKeyStroke)
      Returns the condition that determines whether a registered action occurs in response to the specified keystroke.
      static boolean SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
      Invokes actionPerformed on action if action is enabled (and non-null).
      protected boolean | JTable.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      protected boolean JMenuBar.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      Subclassed to check all the child menus.
      protected boolean JComponent.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
      Invoked to process the key bindings for ks as the result of the KeyEvent e.
      void ComponentInputMap.put(KeyStroke keyStroke, Object actionMapKey)
      Adds a binding for keyStroke to actionMapKey.
      void InputMap.put(KeyStroke keyStroke, Object actionMapKey)
      Adds a binding for keyStroke to actionMapKey.
      void JComponent.registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
      This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior.
      void JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
      This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similiar behavior.
      void ComponentInputMap.remove(KeyStroke key)
      Removes the binding for key from this object.
      void InputMap.remove(KeyStroke key)
      Removes the binding for key from this InputMap.
      void JMenuItem.setAccelerator(KeyStroke keyStroke)
      Sets the key combination which invokes the menu item's action listeners without navigating the menu hierarchy.
      void JMenu.setAccelerator(KeyStroke keyStroke)
      setAccelerator is not defined for JMenu.
      void JComponent.unregisterKeyboardAction(KeyStroke aKeyStroke)
      This method is now obsolete.

    • Uses of KeyStroke in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as KeyStroke
      修饰符与类型 字段与描述
      protected KeyStroke BasicDesktopPaneUI.closeKey
      Deprecated.
      As of 1.3.
      protected KeyStroke BasicSplitPaneUI.dividerResizeToggleKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicToolBarUI.downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicTabbedPaneUI.downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.endKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.homeKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicToolBarUI.leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicTabbedPaneUI.leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicDesktopPaneUI.maximizeKey
      Deprecated.
      As of 1.3.
      protected KeyStroke BasicDesktopPaneUI.minimizeKey
      Deprecated.
      As of 1.3.
      protected KeyStroke BasicDesktopPaneUI.navigateKey
      Deprecated.
      As of 1.3.
      protected KeyStroke BasicDesktopPaneUI.navigateKey2
      Deprecated.
      As of 1.3.
      protected KeyStroke BasicInternalFrameUI.openMenuKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicToolBarUI.rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicTabbedPaneUI.rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicToolBarUI.upKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicTabbedPaneUI.upKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected KeyStroke BasicSplitPaneUI.upKey
      Deprecated.
      As of Java 2 platform v1.3.

    • Uses of KeyStroke in javax.swing.text

      Fields in javax.swing.text declared as KeyStroke
      修饰符与类型 字段与描述
      KeyStroke JTextComponent.KeyBinding.key
      The key.
      Methods in javax.swing.text that return KeyStroke
      修饰符与类型 方法与描述
      KeyStroke[] Keymap.getBoundKeyStrokes()
      Fetches all of the keystrokes in this map that are bound to some action.
      KeyStroke[] Keymap.getKeyStrokesForAction(Action a)
      Fetches the keystrokes that will result in the given action.
      Methods in javax.swing.text with parameters of type KeyStroke
      修饰符与类型 方法与描述
      void Keymap.addActionForKeyStroke(KeyStroke key, Action a)
      Adds a binding to the keymap.
      Action Keymap.getAction(KeyStroke key)
      Fetches the action appropriate for the given symbolic event sequence.
      boolean Keymap.isLocallyDefined(KeyStroke key)
      Determines if the given key sequence is locally defined.
      void Keymap.removeKeyStrokeBinding(KeyStroke keys)
      Removes a binding from the keymap.
      Constructors in javax.swing.text with parameters of type KeyStroke
      构造方法与描述
      JTextComponent.KeyBinding(KeyStroke key, String actionName)
      Creates a new key binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.LayoutFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.LayoutFocusTraversalPolicy

No usage of javax.swing.LayoutFocusTraversalPolicy
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gn/j../"=...roccnt


Uses of Class javax.swing.LayoutStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.LayoutStyle

  • Packages that use LayoutStyle
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of LayoutStyle in javax.swing

      Methods in javax.swing that return LayoutStyle
      修饰符与类型 方法与描述
      static LayoutStyle LayoutStyle.getInstance()
      Returns the shared instance of LayoutStyle.
      LayoutStyle GroupLayout.getLayoutStyle()
      Returns the LayoutStyle used for calculating the preferred gap between components.
      LayoutStyle LookAndFeel.getLayoutStyle()
      Returns the LayoutStyle for this look and feel.
      Methods in javax.swing with parameters of type LayoutStyle
      修饰符与类型 方法与描述
      static void LayoutStyle.setInstance(LayoutStyle style)
      Sets the shared instance of LayoutStyle.
      void GroupLayout.setLayoutStyle(LayoutStyle layoutStyle)
      Sets the LayoutStyle used to calculate the preferred gaps between components.

    • Uses of LayoutStyle in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return LayoutStyle
      修饰符与类型 方法与描述
      LayoutStyle MetalLookAndFeel.getLayoutStyle()
      Returns a LayoutStyle implementing the Java look and feel design guidelines as specified at http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=aiax. njjjmteel agmm.uv


Uses of Class javax.swing.LayoutStyle.ComponentPlacement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.LayoutStyle.ComponentPlacement

  • Packages that use LayoutStyle.ComponentPlacement
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of LayoutStyle.ComponentPlacement in javax.swing

      Methods in javax.swing that return LayoutStyle.ComponentPlacement
      修饰符与类型 方法与描述
      static LayoutStyle.ComponentPlacement LayoutStyle.ComponentPlacement.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static LayoutStyle.ComponentPlacement[] LayoutStyle.ComponentPlacement.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.swing with parameters of type LayoutStyle.ComponentPlacement
      修饰符与类型 方法与描述
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between two components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type)
      Adds an element representing the preferred gap between the nearest components.
      GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max)
      Adds an element representing the preferred gap between the nearest components.
      abstract int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
      Returns the amount of space to use between two components.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sogthlhi-BfAo/aEgrpa>l


Uses of Class javax.swing.LookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.LookAndFeel

  • Packages that use LookAndFeel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of LookAndFeel in javax.swing

      Methods in javax.swing that return LookAndFeel
      修饰符与类型 方法与描述
      static LookAndFeel[] UIManager.getAuxiliaryLookAndFeels()
      Returns the list of auxiliary look and feels (can be null).
      static LookAndFeel UIManager.getLookAndFeel()
      Returns the current look and feel or null.
      Methods in javax.swing with parameters of type LookAndFeel
      修饰符与类型 方法与描述
      static void UIManager.addAuxiliaryLookAndFeel(LookAndFeel laf)
      Adds a LookAndFeel to the list of auxiliary look and feels.
      static boolean UIManager.removeAuxiliaryLookAndFeel(LookAndFeel laf)
      Removes a LookAndFeel from the list of auxiliary look and feels.
      static void UIManager.setLookAndFeel(LookAndFeel newLookAndFeel)
      Sets the current look and feel to newLookAndFeel.

    • Uses of LookAndFeel in javax.swing.plaf.basic

      Subclasses of LookAndFeel in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicLookAndFeel
      A base class to use in creating a look and feel for Swing.

    • Uses of LookAndFeel in javax.swing.plaf.metal

      Subclasses of LookAndFeel in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalLookAndFeel
      The Java Look and Feel, otherwise known as Metal.

    • Uses of LookAndFeel in javax.swing.plaf.multi

      Subclasses of LookAndFeel in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiLookAndFeel
      A multiplexing look and feel that allows more than one UI to be associated with a component at the same time.

    • Uses of LookAndFeel in javax.swing.plaf.nimbus

      Subclasses of LookAndFeel in javax.swing.plaf.nimbus
      修饰符与类型 类与描述
      class  NimbusLookAndFeel
      The NimbusLookAndFeel class.

    • Uses of LookAndFeel in javax.swing.plaf.synth

      Subclasses of LookAndFeel in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthLookAndFeel
      SynthLookAndFeel provides the basis for creating a customized look and feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ns ntle"l ho//rcj//si"t/


Uses of Class javax.swing.MenuSelectionManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.MenuSelectionManager

  • Packages that use MenuSelectionManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of MenuSelectionManager in javax.swing

      Methods in javax.swing that return MenuSelectionManager
      修饰符与类型 方法与描述
      static MenuSelectionManager MenuSelectionManager.defaultManager()
      Returns the default menu selection manager.
      Methods in javax.swing with parameters of type MenuSelectionManager
      修饰符与类型 方法与描述
      void JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager)
      Process a key event.
      void JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.
      void JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using the MenuSelectionManager's API.
      void JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      This method is required to conform to the MenuElement interface, but it not implemented.
      void MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event.
      void JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.

    • Uses of MenuSelectionManager in javax.swing.event

      Methods in javax.swing.event that return MenuSelectionManager
      修饰符与类型 方法与描述
      MenuSelectionManager MenuDragMouseEvent.getMenuSelectionManager()
      Returns the current menu selection manager.
      MenuSelectionManager MenuKeyEvent.getMenuSelectionManager()
      Returns the current menu selection manager.
      Constructors in javax.swing.event with parameters of type MenuSelectionManager
      构造方法与描述
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.
      MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuKeyEvent object.

    • Uses of MenuSelectionManager in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type MenuSelectionManager
      修饰符与类型 | 方法与描述
      protected void BasicMenuItemUI.doClick(MenuSelectionManager msm)
      Call this method when a menu item is to be activated.
      void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/=.rn >>nevv..uh


Uses of Class javax.swing.OverlayLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.OverlayLayout

No usage of javax.swing.OverlayLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fe=<> <<>///


Uses of Class javax.swing.Popup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Popup

  • Packages that use Popup
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of Popup in javax.swing

      Methods in javax.swing that return Popup
      修饰符与类型 方法与描述
      Popup PopupFactory.getPopup(Component owner, Component contents, int x, int y)
      Creates a Popup for the Component owner containing the Component contents.

    • Uses of Popup in javax.swing.plaf

      Methods in javax.swing.plaf that return Popup
      修饰符与类型 方法与描述
      Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
      Returns the Popup that will be responsible for displaying the JPopupMenu.

    • Uses of Popup in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return Popup
      修饰符与类型 方法与描述
      Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
      Invokes the getPopup method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/ pEl/ /awfa>lvhit送a


Uses of Class javax.swing.PopupFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.PopupFactory

  • Packages that use PopupFactory
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of PopupFactory in javax.swing

      Methods in javax.swing that return PopupFactory
      修饰符与类型 方法与描述
      static PopupFactory PopupFactory.getSharedInstance()
      Returns the shared PopupFactory which can be used to obtain Popups.
      Methods in javax.swing with parameters of type PopupFactory
      修饰符与类型 方法与描述
      static void PopupFactory.setSharedInstance(PopupFactory factory)
      Sets the PopupFactory that will be used to obtain Popups.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oidecodhteeeek &,,&a pd


Uses of Class javax.swing.ProgressMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ProgressMonitor

  • Packages that use ProgressMonitor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of ProgressMonitor in javax.swing

      Methods in javax.swing that return ProgressMonitor
      修饰符与类型 方法与描述
      ProgressMonitor ProgressMonitorInputStream.getProgressMonitor()
      Get the ProgressMonitor object being used by this stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsio ytyt,ee<


Uses of Class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ProgressMonitor.AccessibleProgressMonitor

No usage of javax.swing.ProgressMonitor.AccessibleProgressMonitor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ooonsttto/ r


Uses of Class javax.swing.ProgressMonitorInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ProgressMonitorInputStream

No usage of javax.swing.ProgressMonitorInputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g /x/ja..///.a>>a>l/<


Uses of Class javax.swing.RepaintManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RepaintManager

  • Packages that use RepaintManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RepaintManager in javax.swing

      Methods in javax.swing that return RepaintManager
      修饰符与类型 方法与描述
      static RepaintManager RepaintManager.currentManager(Component c)
      Return the RepaintManager for the calling thread given a Component.
      static RepaintManager RepaintManager.currentManager(JComponent c)
      Return the RepaintManager for the calling thread given a JComponent.
      Methods in javax.swing with parameters of type RepaintManager
      修饰符与类型 方法与描述
      static void RepaintManager.setCurrentManager(RepaintManager aRepaintManager)
      Set the RepaintManager that should be used for the calling thread.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dpyg. /reta


Uses of Class javax.swing.RowFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RowFilter

  • Packages that use RowFilter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RowFilter in javax.swing

      Methods in javax.swing that return RowFilter
      修饰符与类型 方法与描述
      static <M,I> RowFilter<M,I> RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if all of the supplied filters include the entry.
      static <M,I> RowFilter<M,I> RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
      Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria.
      RowFilter<? super M,? super I> DefaultRowSorter.getRowFilter()
      Returns the filter that determines which rows, if any, should be hidden from view.
      static <M,I> RowFilter<M,I> RowFilter.notFilter(RowFilter<M,I> filter)
      Returns a RowFilter that includes entries if the supplied filter does not include the entry.
      static <M,I> RowFilter<M,I> RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
      Returns a RowFilter that includes entries that have at least one Number value meeting the specified criteria.
      static <M,I> RowFilter<M,I> RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if any of the supplied filters includes the entry.
      static <M,I> RowFilter<M,I> RowFilter.regexFilter(String regex, int... indices)
      Returns a RowFilter that uses a regular expression to determine which entries to include.
      Methods in javax.swing with parameters of type RowFilter
      修饰符与类型 方法与描述
      static <M,I> RowFilter<M,I> RowFilter.notFilter(RowFilter<M,I> filter)
      Returns a RowFilter that includes entries if the supplied filter does not include the entry.
      void DefaultRowSorter.setRowFilter(RowFilter<? super M,? super I> filter)
      Sets the filter that determines which rows, if any, should be hidden from the view.
      Method parameters in javax.swing with type arguments of type RowFilter
      修饰符与类型 方法与描述
      static <M,I> RowFilter<M,I> RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if all of the supplied filters include the entry.
      static <M,I> RowFilter<M,I> RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
      Returns a RowFilter that includes entries if any of the supplied filters includes the entry.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dmeNwsn


Uses of Class javax.swing.RowFilter.ComparisonType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RowFilter.ComparisonType

  • Packages that use RowFilter.ComparisonType
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RowFilter.ComparisonType in javax.swing

      Methods in javax.swing that return RowFilter.ComparisonType
      修饰符与类型 方法与描述
      static RowFilter.ComparisonType RowFilter.ComparisonType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RowFilter.ComparisonType[] RowFilter.ComparisonType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.swing with parameters of type RowFilter.ComparisonType
      修饰符与类型 方法与描述
      static <M,I> RowFilter<M,I> RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
      Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria.
      static <M,I> RowFilter<M,I> RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
      Returns a RowFilter that includes entries that have at least one Number value meeting the specified criteria.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

il话c � e颁迷ＡlＫ� e�


Uses of Class javax.swing.RowFilter.Entry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RowFilter.Entry

  • Packages that use RowFilter.Entry
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RowFilter.Entry in javax.swing

      Methods in javax.swing with parameters of type RowFilter.Entry
      修饰符与类型 方法与描述
      abstract boolean RowFilter.include(RowFilter.Entry<? extends M,? extends I> entry)
      Returns true if the specified entry should be shown; returns false if the entry should be hidden.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

besTariC.ooot" .Rx.agwa


Uses of Class javax.swing.RowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RowSorter

  • Packages that use RowSorter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of RowSorter in javax.swing

      Subclasses of RowSorter in javax.swing
      修饰符与类型 类与描述
      class  DefaultRowSorter<M,I>
      An implementation of RowSorter that provides sorting and filtering around a grid-based data model.
      Methods in javax.swing that return RowSorter
      修饰符与类型 方法与描述
      RowSorter<? extends TableModel> JTable.getRowSorter()
      Returns the object responsible for sorting.
      Methods in javax.swing with parameters of type RowSorter
      修饰符与类型 方法与描述
      void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
      Sets the RowSorter.

    • Uses of RowSorter in javax.swing.event

      Methods in javax.swing.event that return RowSorter
      修饰符与类型 方法与描述
      RowSorter RowSorterEvent.getSource()
      Returns the source of the event as a RowSorter.
      Constructors in javax.swing.event with parameters of type RowSorter
      构造方法与描述
      RowSorterEvent(RowSorter source)
      Creates a RowSorterEvent of type SORT_ORDER_CHANGED.
      RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
      Creates a RowSorterEvent.

    • Uses of RowSorter in javax.swing.table

      Subclasses of RowSorter in javax.swing.table
      修饰符与类型 类与描述
      class  TableRowSorter<M extends TableModel>
      An implementation of RowSorter that provides sorting and filtering using a TableModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

akvl/a>-->>> wttbab > < " n


Uses of Class javax.swing.RowSorter.SortKey

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.RowSorter.SortKey

  • Packages that use RowSorter.SortKey
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RowSorter.SortKey in javax.swing

      Methods in javax.swing that return types with arguments of type RowSorter.SortKey
      修饰符与类型 方法与描述
      List<? extends RowSorter.SortKey> DefaultRowSorter.getSortKeys()
      Returns the current sort keys.
      abstract List<? extends RowSorter.SortKey> RowSorter.getSortKeys()
      Returns the current sort keys.
      Method parameters in javax.swing with type arguments of type RowSorter.SortKey
      修饰符与类型 方法与描述
      void DefaultRowSorter.setSortKeys(List<? extends RowSorter.SortKey> sortKeys)
      Sets the sort keys.
      abstract void RowSorter.setSortKeys(List<? extends RowSorter.SortKey> keys)
      Sets the current sort keys.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x..ESor#lRRRhevv".odr .fS


Uses of Class javax.swing.ScrollPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ScrollPaneLayout

  • Packages that use ScrollPaneLayout
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of ScrollPaneLayout in javax.swing

      Subclasses of ScrollPaneLayout in javax.swing
      修饰符与类型 类与描述
      static class  ScrollPaneLayout.UIResource
      The UI resource version of ScrollPaneLayout.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>oo肺o枢>朕�


Uses of Class javax.swing.ScrollPaneLayout.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ScrollPaneLayout.UIResource

No usage of javax.swing.ScrollPaneLayout.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c/k"hre>i<<< Uaatnnll


Uses of Class javax.swing.SizeRequirements

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SizeRequirements

  • Packages that use SizeRequirements
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of SizeRequirements in javax.swing

      Methods in javax.swing that return SizeRequirements
      修饰符与类型 方法与描述
      static SizeRequirements SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to align a set of components.
      static SizeRequirements SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to place a set of components end-to-end.
      Methods in javax.swing with parameters of type SizeRequirements
      修饰符与类型 方法与描述
      static int[] SizeRequirements.adjustSizes(int delta, SizeRequirements[] children)
      Adjust a specified array of sizes by a given amount.
      static void SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal)
      Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal)
      Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments.
      static void SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static void SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static void SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static void SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward)
      Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
      static SizeRequirements SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to align a set of components.
      static SizeRequirements SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children)
      Determines the total space necessary to place a set of components end-to-end.

    • Uses of SizeRequirements in javax.swing.text

      Methods in javax.swing.text that return SizeRequirements
      修饰符与类型 方法与描述
      protected SizeRequirements BoxView.baselineRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for this BoxView by examining the size of each child view.
      protected SizeRequirements BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the major axis axis.
      protected SizeRequirements TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements for the minor axis.
      protected SizeRequirements BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the minor axis axis.
      protected SizeRequirements FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate equirements along the minor axis.
      protected SizeRequirements ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      Methods in javax.swing.text with parameters of type SizeRequirements
      修饰符与类型 方法与描述
      protected SizeRequirements BoxView.baselineRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for this BoxView by examining the size of each child view.
      protected SizeRequirements BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the major axis axis.
      protected SizeRequirements TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements for the minor axis.
      protected SizeRequirements BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the minor axis axis.
      protected SizeRequirements FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate equirements along the minor axis.
      protected SizeRequirements ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      protected void TableView.layoutColumns(int targetSpan, int[] offsets, int[] spans, SizeRequirements[] reqs)
      Lays out the columns to fit within the given target span.

    • Uses of SizeRequirements in javax.swing.text.html

      Methods in javax.swing.text.html that return SizeRequirements
      修饰符与类型 方法与描述
      protected SizeRequirements BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the major axis (i.e.
      protected SizeRequirements ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      protected SizeRequirements BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the minor axis (i.e.
      Methods in javax.swing.text.html with parameters of type SizeRequirements
      修饰符与类型 方法与描述
      protected SizeRequirements BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the major axis (i.e.
      protected SizeRequirements ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      protected SizeRequirements BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the minor axis (i.e.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.SizeSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SizeSequence

No usage of javax.swing.SizeSequence
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=i"n>


Uses of Class javax.swing.SortingFocusTraversalPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SortingFocusTraversalPolicy

  • Packages that use SortingFocusTraversalPolicy
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SortingFocusTraversalPolicy in javax.swing

      Subclasses of SortingFocusTraversalPolicy in javax.swing
      修饰符与类型 类与描述
      class  LayoutFocusTraversalPolicy
      A SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t =


Uses of Class javax.swing.SortOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SortOrder

  • Packages that use SortOrder
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SortOrder in javax.swing

      Methods in javax.swing that return SortOrder
      修饰符与类型 方法与描述
      SortOrder RowSorter.SortKey.getSortOrder()
      Returns the sort order of the column.
      static SortOrder SortOrder.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SortOrder[] SortOrder.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.swing with parameters of type SortOrder
      构造方法与描述
      RowSorter.SortKey(int column, SortOrder sortOrder)
      Creates a SortKey for the specified column with the specified sort order.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"oen<& l/t


Uses of Class javax.swing.SpinnerDateModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SpinnerDateModel

  • Packages that use SpinnerDateModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SpinnerDateModel in javax.swing

      Methods in javax.swing that return SpinnerDateModel
      修饰符与类型 方法与描述
      SpinnerDateModel JSpinner.DateEditor.getModel()
      Return our spinner ancestor's SpinnerDateModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h///


Uses of Class javax.swing.SpinnerListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SpinnerListModel

  • Packages that use SpinnerListModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SpinnerListModel in javax.swing

      Methods in javax.swing that return SpinnerListModel
      修饰符与类型 方法与描述
      SpinnerListModel JSpinner.ListEditor.getModel()
      Return our spinner ancestor's SpinnerNumberModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�>ゎr芳f@)輋�ci 


Uses of Class javax.swing.SpinnerNumberModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SpinnerNumberModel

  • Packages that use SpinnerNumberModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SpinnerNumberModel in javax.swing

      Methods in javax.swing that return SpinnerNumberModel
      修饰符与类型 方法与描述
      SpinnerNumberModel JSpinner.NumberEditor.getModel()
      Return our spinner ancestor's SpinnerNumberModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"hcs"coalsssh�


Uses of Class javax.swing.Spring

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Spring

  • Packages that use Spring
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of Spring in javax.swing

      Methods in javax.swing that return Spring
      修饰符与类型 方法与描述
      static Spring Spring.constant(int pref)
      Returns a strut -- a spring whose minimum, preferred, and maximum values each have the value pref.
      static Spring Spring.constant(int min, int pref, int max)
      Returns a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively.
      Spring SpringLayout.Constraints.getConstraint(String edgeName)
      Returns the value of the specified edge, which may be a derived value, or even null.
      Spring SpringLayout.getConstraint(String edgeName, Component c)
      Returns the spring controlling the distance between the specified edge of the component and the top or left edge of its parent.
      Spring SpringLayout.Constraints.getHeight()
      Returns the value of the height property.
      Spring SpringLayout.Constraints.getWidth()
      Returns the value of the width property.
      Spring SpringLayout.Constraints.getX()
      Returns the value of the x property.
      Spring SpringLayout.Constraints.getY()
      Returns the value of the y property.
      static Spring Spring.height(Component c)
      Returns a spring whose minimum, preferred, maximum and value properties are defined by the heights of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
      static Spring Spring.max(Spring s1, Spring s2)
      Returns max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2.
      static Spring Spring.minus(Spring s)
      Returns -s: a spring running in the opposite direction to s.
      static Spring Spring.scale(Spring s, float factor)
      Returns a spring whose minimum, preferred, maximum and value properties are each multiples of the properties of the argument spring, s.
      static Spring Spring.sum(Spring s1, Spring s2)
      Returns s1+s2: a spring representing s1 and s2 in series.
      static Spring Spring.width(Component c)
      Returns a spring whose minimum, preferred, maximum and value properties are defined by the widths of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
      Methods in javax.swing with parameters of type Spring
      修饰符与类型 方法与描述
      static Spring Spring.max(Spring s1, Spring s2)
      Returns max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2.
      static Spring Spring.minus(Spring s)
      Returns -s: a spring running in the opposite direction to s.
      void SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
      Links edge e1 of component c1 to edge e2 of component c2.
      static Spring Spring.scale(Spring s, float factor)
      Returns a spring whose minimum, preferred, maximum and value properties are each multiples of the properties of the argument spring, s.
      void SpringLayout.Constraints.setConstraint(String edgeName, Spring s)
      Sets the spring controlling the specified edge.
      void SpringLayout.Constraints.setHeight(Spring height)
      Sets the height property, which controls the height of a component.
      void SpringLayout.Constraints.setWidth(Spring width)
      Sets the width property, which controls the width of a component.
      void SpringLayout.Constraints.setX(Spring x)
      Sets the x property, which controls the x value of a component's location.
      void SpringLayout.Constraints.setY(Spring y)
      Sets the y property, which controls the y value of a component's location.
      static Spring Spring.sum(Spring s1, Spring s2)
      Returns s1+s2: a spring representing s1 and s2 in series.
      Constructors in javax.swing with parameters of type Spring
      构造方法与描述
      SpringLayout.Constraints(Spring x, Spring y)
      Creates a Constraints object with the specified values for its x and y properties.
      SpringLayout.Constraints(Spring x, Spring y, Spring width, Spring height)
      Creates a Constraints object with the specified values for its x, y, width, and height properties.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e渁_kngad�&lg狸c"uimu <�


Uses of Class javax.swing.SpringLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SpringLayout

No usage of javax.swing.SpringLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b>oi-->===== MAA


Uses of Class javax.swing.SpringLayout.Constraints

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SpringLayout.Constraints

  • Packages that use SpringLayout.Constraints
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SpringLayout.Constraints in javax.swing

      Methods in javax.swing that return SpringLayout.Constraints
      修饰符与类型 方法与描述
      SpringLayout.Constraints SpringLayout.getConstraints(Component c)
      Returns the constraints for the specified component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o=fttur"k>>>lc//iniawr//i


Uses of Class javax.swing.SwingUtilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SwingUtilities

No usage of javax.swing.SwingUtilities
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vca st"loFFF=trrnusc/


Uses of Class javax.swing.SwingWorker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SwingWorker

No usage of javax.swing.SwingWorker
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/>slplay/ <


Uses of Class javax.swing.SwingWorker.StateValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.SwingWorker.StateValue

  • Packages that use SwingWorker.StateValue
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SwingWorker.StateValue in javax.swing

      Methods in javax.swing that return SwingWorker.StateValue
      修饰符与类型 方法与描述
      SwingWorker.StateValue SwingWorker.getState()
      Returns the SwingWorker state bound property.
      static SwingWorker.StateValue SwingWorker.StateValue.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static SwingWorker.StateValue[] SwingWorker.StateValue.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

prtnoai alaj. v doe


Uses of Class javax.swing.Timer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.Timer

  • Packages that use Timer
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of Timer in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Timer
      修饰符与类型 | 字段与描述
      protected Timer BasicComboPopup.autoscrollTimer
      This protected field is implementation specific.
      protected Timer | BasicSliderUI.scrollTimer
      protected Timer | BasicScrollBarUI.scrollTimer
      protected Timer BasicTreeUI.ComponentHandler.timer
      Timer used when inside a scrollpane and the scrollbar is adjusting.

    • Uses of Timer in javax.swing.tree

      Fields in javax.swing.tree declared as Timer
      修饰符与类型 字段与描述
      protected Timer DefaultTreeCellEditor.timer
      Used before starting the editing session.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eiat<"aacae/mob L pd>


Uses of Class javax.swing.ToolTipManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ToolTipManager

  • Packages that use ToolTipManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of ToolTipManager in javax.swing

      Methods in javax.swing that return ToolTipManager
      修饰符与类型 方法与描述
      static ToolTipManager ToolTipManager.sharedInstance()
      Returns a shared ToolTipManager instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= ">>tr##o/f>e..h.


Uses of Class javax.swing.ToolTipManager.insideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ToolTipManager.insideTimerAction

No usage of javax.swing.ToolTipManager.insideTimerAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>hsssea rpits


Uses of Class javax.swing.ToolTipManager.outsideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ToolTipManager.outsideTimerAction

No usage of javax.swing.ToolTipManager.outsideTimerAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

靹 (@b3 o牬膃�H


Uses of Class javax.swing.ToolTipManager.stillInsideTimerAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ToolTipManager.stillInsideTimerAction

No usage of javax.swing.ToolTipManager.stillInsideTimerAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/. / n/ie/>ee


Uses of Class javax.swing.TransferHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.TransferHandler

  • Packages that use TransferHandler
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of TransferHandler in javax.swing

      Methods in javax.swing that return TransferHandler
      修饰符与类型 方法与描述
      TransferHandler JApplet.getTransferHandler()
      Gets the transferHandler property.
      TransferHandler JDialog.getTransferHandler()
      Gets the transferHandler property.
      TransferHandler JWindow.getTransferHandler()
      Gets the transferHandler property.
      TransferHandler JComponent.getTransferHandler()
      Gets the transferHandler property.
      TransferHandler JFrame.getTransferHandler()
      Gets the transferHandler property.
      Methods in javax.swing with parameters of type TransferHandler
      修饰符与类型 方法与描述
      void JApplet.setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void JDialog.setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void JWindow.setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
      void JComponent.setTransferHandler(TransferHandler newHandler)
      Sets the TransferHandler, which provides support for transfer of data into and out of this component via cut/copy/paste and drag and drop.
      void JFrame.setTransferHandler(TransferHandler newHandler)
      Sets the transferHandler property, which is a mechanism to support transfer of data into this component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea--ka"veh r"ct.bse


Uses of Class javax.swing.TransferHandler.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.TransferHandler.DropLocation

  • Packages that use TransferHandler.DropLocation
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TransferHandler.DropLocation in javax.swing

      Subclasses of TransferHandler.DropLocation in javax.swing
      修饰符与类型 类与描述
      static class  JList.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JList.
      static class  JTable.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
      static class  JTree.DropLocation
      A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
      Methods in javax.swing that return TransferHandler.DropLocation
      修饰符与类型 方法与描述
      TransferHandler.DropLocation TransferHandler.TransferSupport.getDropLocation()
      Returns the current (non-null) drop location for the component, when this TransferSupport represents a drop.

    • Uses of TransferHandler.DropLocation in javax.swing.text

      Subclasses of TransferHandler.DropLocation in javax.swing.text
      修饰符与类型 类与描述
      static class  JTextComponent.DropLocation
      Represents a drop location for JTextComponents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.TransferHandler.TransferSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.TransferHandler.TransferSupport

  • Packages that use TransferHandler.TransferSupport
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of TransferHandler.TransferSupport in javax.swing

      Methods in javax.swing with parameters of type TransferHandler.TransferSupport
      修饰符与类型 方法与描述
      boolean TransferHandler.canImport(TransferHandler.TransferSupport support)
      This method is called repeatedly during a drag and drop operation to allow the developer to configure properties of, and to return the acceptability of transfers; with a return value of true indicating that the transfer represented by the given TransferSupport (which contains all of the details of the transfer) is acceptable at the current time, and a value of false rejecting the transfer.
      boolean TransferHandler.importData(TransferHandler.TransferSupport support)
      Causes a transfer to occur from a clipboard or a drag and drop operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esw/ndlefrrrawss>j.h...=l


Uses of Class javax.swing.UIDefaults

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UIDefaults

  • Packages that use UIDefaults
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of UIDefaults in javax.swing

      Methods in javax.swing that return UIDefaults
      修饰符与类型 方法与描述
      UIDefaults LookAndFeel.getDefaults()
      Returns the look and feel defaults.
      static UIDefaults UIManager.getDefaults()
      Returns the defaults.
      static UIDefaults UIManager.getLookAndFeelDefaults()
      Returns the UIDefaults from the current look and feel, that were obtained at the time the look and feel was installed.
      Methods in javax.swing with parameters of type UIDefaults
      修饰符与类型 方法与描述
      Object UIDefaults.LazyValue.createValue(UIDefaults table)
      Creates the actual value retrieved from the UIDefaults table.
      Object UIDefaults.ActiveValue.createValue(UIDefaults table)
      Creates the value retrieved from the UIDefaults table.
      Object UIDefaults.ProxyLazyValue.createValue(UIDefaults table)
      Creates the value retrieved from the UIDefaults table.
      Object UIDefaults.LazyInputMap.createValue(UIDefaults table)
      Creates an InputMap with the bindings that are passed in.

    • Uses of UIDefaults in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return UIDefaults
      修饰符与类型 方法与描述
      UIDefaults BasicLookAndFeel.getDefaults()
      Returns the look and feel defaults.
      Methods in javax.swing.plaf.basic with parameters of type UIDefaults
      修饰符与类型 方法与描述
      protected void BasicLookAndFeel.initClassDefaults(UIDefaults table)
      Populates table with mappings from uiClassID to the fully qualified name of the ui class.
      protected void BasicLookAndFeel.initComponentDefaults(UIDefaults table)
      Populates table with the defaults for the basic look and feel.
      protected void BasicLookAndFeel.initSystemColorDefaults(UIDefaults table)
      Populates table with system colors.
      protected void BasicLookAndFeel.loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative)
      Populates table with the name-color pairs in systemColors.

    • Uses of UIDefaults in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return UIDefaults
      修饰符与类型 方法与描述
      UIDefaults MetalLookAndFeel.getDefaults()
      Returns the look and feel defaults.
      Methods in javax.swing.plaf.metal with parameters of type UIDefaults
      修饰符与类型 方法与描述
      void OceanTheme.addCustomEntriesToTable(UIDefaults table)
      Add this theme's custom entries to the defaults table.
      void MetalTheme.addCustomEntriesToTable(UIDefaults table)
      Adds values specific to this theme to the defaults table.
      protected void MetalLookAndFeel.initClassDefaults(UIDefaults table)
      Populates table with mappings from uiClassID to the fully qualified name of the ui class.
      protected void MetalLookAndFeel.initComponentDefaults(UIDefaults table)
      Populates table with the defaults for metal.
      protected void MetalLookAndFeel.initSystemColorDefaults(UIDefaults table)
      Populates table with system colors.

    • Uses of UIDefaults in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return UIDefaults
      修饰符与类型 方法与描述
      UIDefaults MultiLookAndFeel.getDefaults()
      Creates, initializes, and returns the look and feel specific defaults.

    • Uses of UIDefaults in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return UIDefaults
      修饰符与类型 | 方法与描述
      UIDefaults | NimbusLookAndFeel.getDefaults()

    • Uses of UIDefaults in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return UIDefaults
      修饰符与类型 方法与描述
      UIDefaults SynthLookAndFeel.getDefaults()
      Returns the defaults for this SynthLookAndFeel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pht.>


Uses of Class javax.swing.UIDefaults.LazyInputMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UIDefaults.LazyInputMap

No usage of javax.swing.UIDefaults.LazyInputMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jia" hrni da<


Uses of Class javax.swing.UIDefaults.ProxyLazyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UIDefaults.ProxyLazyValue

No usage of javax.swing.UIDefaults.ProxyLazyValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tob>>


Uses of Class javax.swing.UIManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UIManager

No usage of javax.swing.UIManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>l...l.../gchl藀.rgl


Uses of Class javax.swing.UIManager.LookAndFeelInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UIManager.LookAndFeelInfo

  • Packages that use UIManager.LookAndFeelInfo
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of UIManager.LookAndFeelInfo in javax.swing

      Methods in javax.swing that return UIManager.LookAndFeelInfo
      修饰符与类型 方法与描述
      static UIManager.LookAndFeelInfo[] UIManager.getInstalledLookAndFeels()
      Returns an array of LookAndFeelInfos representing the LookAndFeel implementations currently available.
      Methods in javax.swing with parameters of type UIManager.LookAndFeelInfo
      修饰符与类型 方法与描述
      static void UIManager.installLookAndFeel(UIManager.LookAndFeelInfo info)
      Adds the specified look and feel to the set of available look and feels.
      static void UIManager.setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos)
      Sets the set of available look and feels.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" oc ltg ait n"hil=


Uses of Class javax.swing.UnsupportedLookAndFeelException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.UnsupportedLookAndFeelException

  • Packages that use UnsupportedLookAndFeelException
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of UnsupportedLookAndFeelException in javax.swing

      Methods in javax.swing that throw UnsupportedLookAndFeelException
      修饰符与类型 方法与描述
      static void UIManager.setLookAndFeel(LookAndFeel newLookAndFeel)
      Sets the current look and feel to newLookAndFeel.
      static void UIManager.setLookAndFeel(String className)
      Loads the LookAndFeel specified by the given class name, using the current thread's context class loader, and passes it to setLookAndFeel(LookAndFeel).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p=ei c csityiill .=ir//rl


Uses of Class javax.swing.ViewportLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.ViewportLayout

No usage of javax.swing.ViewportLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

IeM"clapsaaa"">>l= "


Uses of Interface javax.swing.Action

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.Action

  • Packages that use Action
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Action in javax.swing

      Classes in javax.swing that implement Action
      修饰符与类型 类与描述
      class  AbstractAction
      This class provides default implementations for the JFC Action interface.
      Methods in javax.swing that return Action
      修饰符与类型 方法与描述
      Action ActionMap.get(Object key)
      Returns the binding for key, messaging the parent ActionMap if the binding is not locally defined.
      Action JTextField.getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      Action JComboBox.getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      Action AbstractButton.getAction()
      Returns the currently set Action for this ActionEvent source, or null if no Action is set.
      Action[] JFormattedTextField.getActions()
      Fetches the command list for the editor.
      protected Action[] JFormattedTextField.AbstractFormatter.getActions()
      Subclass and override if you wish to provide a custom set of Actions.
      Action[] JTextField.getActions()
      Fetches the command list for the editor.
      static Action TransferHandler.getCopyAction()
      Returns an Action that performs copy operations to the clipboard.
      static Action TransferHandler.getCutAction()
      Returns an Action that performs cut operations to the clipboard.
      static Action TransferHandler.getPasteAction()
      Returns an Action that performs paste operations from the clipboard.
      Methods in javax.swing with parameters of type Action
      修饰符与类型 方法与描述
      protected void JTextField.actionPropertyChanged(Action action, String propertyName)
      Updates the textfield's state in response to property changes in associated action.
      protected void JComboBox.actionPropertyChanged(Action action, String propertyName)
      Updates the combobox's state in response to property changes in associated action.
      protected void JMenuItem.actionPropertyChanged(Action action, String propertyName)
      Updates the button's state in response to property changes in the associated action.
      protected void AbstractButton.actionPropertyChanged(Action action, String propertyName)
      Updates the button's state in response to property changes in the associated action.
      JButton JToolBar.add(Action a)
      Adds a new JButton which dispatches the action.
      JMenuItem JMenu.add(Action a)
      Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
      JMenuItem JPopupMenu.add(Action a)
      Appends a new menu item to the end of the menu which dispatches the specified Action object.
      protected void JTextField.configurePropertiesFromAction(Action a)
      Sets the properties on this textfield to match those in the specified Action.
      protected void JComboBox.configurePropertiesFromAction(Action a)
      Sets the properties on this combobox to match those in the specified Action.
      protected void JMenuItem.configurePropertiesFromAction(Action a)
      Sets the properties on this button to match those in the specified Action.
      protected void AbstractButton.configurePropertiesFromAction(Action a)
      Sets the properties on this button to match those in the specified Action.
      protected JButton JToolBar.createActionComponent(Action a)
      Factory method which creates the JButton for Actions added to the JToolBar.
      protected JMenuItem JMenu.createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JMenu.
      protected JMenuItem JPopupMenu.createActionComponent(Action a)
      Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
      protected PropertyChangeListener JTextField.createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      protected PropertyChangeListener JComboBox.createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      protected PropertyChangeListener AbstractButton.createActionPropertyChangeListener(Action a)
      Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
      JMenuItem JMenu.insert(Action a, int pos)
      Inserts a new menu item attached to the specified Action object at a given position.
      void JPopupMenu.insert(Action a, int index)
      Inserts a menu item for the specified Action object at a given position.
      static boolean SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
      Invokes actionPerformed on action if action is enabled (and non-null).
      void ActionMap.put(Object key, Action action)
      Adds a binding for key to action.
      void JTextField.setAction(Action a)
      Sets the Action for the ActionEvent source.
      void JComboBox.setAction(Action a)
      Sets the Action for the ActionEvent source.
      void AbstractButton.setAction(Action a)
      Sets the Action.
      Constructors in javax.swing with parameters of type Action
      构造方法与描述
      JButton(Action a)
      Creates a button where properties are taken from the Action supplied.
      JCheckBox(Action a)
      Creates a check box where properties are taken from the Action supplied.
      JCheckBoxMenuItem(Action a)
      Creates a menu item whose properties are taken from the Action supplied.
      JMenu(Action a)
      Constructs a menu whose properties are taken from the Action supplied.
      JMenuItem(Action a)
      Creates a menu item whose properties are taken from the specified Action.
      JRadioButton(Action a)
      Creates a radiobutton where properties are taken from the Action supplied.
      JRadioButtonMenuItem(Action a)
      Creates a radio button menu item whose properties are taken from the Action supplied.
      JToggleButton(Action a)
      Creates a toggle button where properties are taken from the Action supplied.

    • Uses of Action in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Action
      修饰符与类型 | 类与描述
      protected class  BasicDesktopPaneUI.CloseAction
      Handles closing an internal frame.
      protected class  BasicDesktopPaneUI.MaximizeAction
      Handles maximizing an internal frame.
      protected class  BasicDesktopPaneUI.MinimizeAction
      Handles minimizing an internal frame.
      protected class  BasicDesktopPaneUI.NavigateAction
      Handles navigating to the next internal frame.
      protected class  BasicDesktopPaneUI.OpenAction
      Handles restoring a minimized or maximized internal frame.
      protected class  BasicFileChooserUI.ApproveSelectionAction
      Responds to an Open or Save request
      protected class  BasicFileChooserUI.CancelSelectionAction
      Responds to a cancel request.
      protected class  | BasicFileChooserUI.ChangeToParentDirectoryAction
      protected class  BasicFileChooserUI.GoHomeAction
      Acts on the "home" key event or equivalent event.
      protected class  BasicFileChooserUI.NewFolderAction
      Creates a new folder.
      protected class  BasicFileChooserUI.UpdateAction
      Rescans the files in the current directory
      class  BasicInternalFrameTitlePane.CloseAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.IconifyAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MaximizeAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MoveAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.RestoreAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.SizeAction
      This class should be treated as a "protected" inner class.
      class  BasicSliderUI.ActionScroller
      As of Java 2 platform v1.3 this undocumented class is no longer used.
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener that invokes cancelEditing when action performed.
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction is used to handle end/home actions.
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction is used to handle up/down actions.
      class  BasicTreeUI.TreePageAction
      TreePageAction handles page up and page down events.
      class  BasicTreeUI.TreeToggleAction
      For the first selected row expandedness will be toggled.
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction is the action used for left/right keys.
      Fields in javax.swing.plaf.basic declared as Action
      修饰符与类型 | 字段与描述
      protected Action | BasicInternalFrameTitlePane.closeAction
      protected Action | BasicInternalFrameTitlePane.iconifyAction
      protected Action | BasicInternalFrameTitlePane.maximizeAction
      protected Action | BasicInternalFrameTitlePane.moveAction
      protected Action BasicTreeUI.KeyHandler.repeatKeyAction
      Key code that is being generated for.
      protected Action | BasicInternalFrameTitlePane.restoreAction
      protected Action | BasicInternalFrameTitlePane.sizeAction
      Methods in javax.swing.plaf.basic that return Action
      修饰符与类型 | 方法与描述
      protected Action BasicLookAndFeel.createAudioAction(Object key)
      Creates and returns an Action used to play a sound.
      Action | BasicFileChooserUI.getApproveSelectionAction()
      Action | BasicFileChooserUI.getCancelSelectionAction()
      Action | BasicFileChooserUI.getChangeToParentDirectoryAction()
      Action | BasicFileChooserUI.getGoHomeAction()
      Action | BasicFileChooserUI.getNewFolderAction()
      Action | BasicFileChooserUI.getUpdateAction()
      Methods in javax.swing.plaf.basic with parameters of type Action
      修饰符与类型 方法与描述
      protected void BasicLookAndFeel.playSound(Action audioAction)
      If necessary, invokes actionPerformed on audioAction to play a sound.

    • Uses of Action in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Action
      修饰符与类型 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      Acts when DirectoryComboBox has changed the selected item.

    • Uses of Action in javax.swing.text

      Classes in javax.swing.text that implement Action
      修饰符与类型 类与描述
      static class  DefaultEditorKit.BeepAction
      Creates a beep.
      static class  DefaultEditorKit.CopyAction
      Copies the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.CutAction
      Cuts the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.DefaultKeyTypedAction
      The action that is executed by default if a key typed event is received and there is no keymap entry.
      static class  DefaultEditorKit.InsertBreakAction
      Places a line/paragraph break into the document.
      static class  DefaultEditorKit.InsertContentAction
      Places content into the associated document.
      static class  DefaultEditorKit.InsertTabAction
      Places a tab character into the document.
      static class  DefaultEditorKit.PasteAction
      Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
      static class  StyledEditorKit.AlignmentAction
      An action to set paragraph alignment.
      static class  StyledEditorKit.BoldAction
      An action to toggle the bold attribute.
      static class  StyledEditorKit.FontFamilyAction
      An action to set the font family in the associated JEditorPane.
      static class  StyledEditorKit.FontSizeAction
      An action to set the font size in the associated JEditorPane.
      static class  StyledEditorKit.ForegroundAction
      An action to set foreground color.
      static class  StyledEditorKit.ItalicAction
      An action to toggle the italic attribute.
      static class  StyledEditorKit.StyledTextAction
      An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
      static class  StyledEditorKit.UnderlineAction
      An action to toggle the underline attribute.
      class  TextAction
      An Action implementation useful for key bindings that are shared across a number of different text components.
      Methods in javax.swing.text that return Action
      修饰符与类型 方法与描述
      static Action[] TextAction.augmentList(Action[] list1, Action[] list2)
      Takes one list of commands and augments it with another list of commands.
      Action Keymap.getAction(KeyStroke key)
      Fetches the action appropriate for the given symbolic event sequence.
      protected Action[] InternationalFormatter.getActions()
      If getSupportsIncrement returns true, this returns two Actions suitable for incrementing/decrementing the value.
      Action[] StyledEditorKit.getActions()
      Fetches the command list for the editor.
      Action[] DefaultEditorKit.getActions()
      Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
      abstract Action[] EditorKit.getActions()
      Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
      Action[] JTextComponent.getActions()
      Fetches the command list for the editor.
      Action[] Keymap.getBoundActions()
      Fetches all of the actions defined in this keymap.
      Action Keymap.getDefaultAction()
      Fetches the default action to fire if a key is typed (i.e.
      Methods in javax.swing.text with parameters of type Action
      修饰符与类型 方法与描述
      void Keymap.addActionForKeyStroke(KeyStroke key, Action a)
      Adds a binding to the keymap.
      static Action[] TextAction.augmentList(Action[] list1, Action[] list2)
      Takes one list of commands and augments it with another list of commands.
      static Action[] TextAction.augmentList(Action[] list1, Action[] list2)
      Takes one list of commands and augments it with another list of commands.
      KeyStroke[] Keymap.getKeyStrokesForAction(Action a)
      Fetches the keystrokes that will result in the given action.
      static void JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
      Loads a keymap with a bunch of bindings.
      void Keymap.setDefaultAction(Action a)
      Set the default action to fire if a key is typed.

    • Uses of Action in javax.swing.text.html

      Classes in javax.swing.text.html that implement Action
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLTextAction
      An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
      Methods in javax.swing.text.html that return Action
      修饰符与类型 方法与描述
      Action[] HTMLEditorKit.getActions()
      Fetches the command list for the editor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.BoundedRangeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.BoundedRangeModel

  • Packages that use BoundedRangeModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of BoundedRangeModel in javax.swing

      Classes in javax.swing that implement BoundedRangeModel
      修饰符与类型 类与描述
      class  DefaultBoundedRangeModel
      A generic implementation of BoundedRangeModel.
      Fields in javax.swing declared as BoundedRangeModel
      修饰符与类型 字段与描述
      protected BoundedRangeModel JProgressBar.model
      The object that holds the data for the progress bar.
      protected BoundedRangeModel JScrollBar.model
      The model that represents the scrollbar's minimum, maximum, extent (aka "visibleAmount") and current value.
      protected BoundedRangeModel JSlider.sliderModel
      The data model that handles the numeric maximum value, minimum value, and current-position value for the slider.
      Methods in javax.swing that return BoundedRangeModel
      修饰符与类型 方法与描述
      BoundedRangeModel JTextField.getHorizontalVisibility()
      Gets the visibility of the text field.
      BoundedRangeModel JProgressBar.getModel()
      Returns the data model used by this progress bar.
      BoundedRangeModel JSlider.getModel()
      Returns the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.
      BoundedRangeModel JScrollBar.getModel()
      Returns data model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
      Methods in javax.swing with parameters of type BoundedRangeModel
      修饰符与类型 方法与描述
      void JProgressBar.setModel(BoundedRangeModel newModel)
      Sets the data model used by the JProgressBar.
      void JSlider.setModel(BoundedRangeModel newModel)
      Sets the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.
      void JScrollBar.setModel(BoundedRangeModel newModel)
      Sets the model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.
      Constructors in javax.swing with parameters of type BoundedRangeModel
      构造方法与描述
      JProgressBar(BoundedRangeModel newModel)
      Creates a horizontal progress bar that uses the specified model to hold the progress bar's data.
      JSlider(BoundedRangeModel brm)
      Creates a horizontal slider using the specified BoundedRangeModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn萢a=cTtt�/n91#�>a39觭


Uses of Interface javax.swing.ButtonModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ButtonModel

  • Packages that use ButtonModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of ButtonModel in javax.swing

      Classes in javax.swing that implement ButtonModel
      修饰符与类型 类与描述
      class  DefaultButtonModel
      The default implementation of a Button component's data model.
      static class  JToggleButton.ToggleButtonModel
      The ToggleButton model
      Fields in javax.swing declared as ButtonModel
      修饰符与类型 字段与描述
      protected ButtonModel AbstractButton.model
      The data model that determines the button's state.
      Methods in javax.swing that return ButtonModel
      修饰符与类型 方法与描述
      ButtonModel AbstractButton.getModel()
      Returns the model that this button represents.
      ButtonModel ButtonGroup.getSelection()
      Returns the model of the selected button.
      Methods in javax.swing with parameters of type ButtonModel
      修饰符与类型 方法与描述
      boolean ButtonGroup.isSelected(ButtonModel m)
      Returns whether a ButtonModel is selected.
      void JMenuItem.setModel(ButtonModel newModel)
      Sets the model that this button represents.
      void JMenu.setModel(ButtonModel newModel)
      Sets the data model for the "menu button" -- the label that the user clicks to open or close the menu.
      void AbstractButton.setModel(ButtonModel newModel)
      Sets the model that this button represents.
      void ButtonGroup.setSelected(ButtonModel m, boolean b)
      Sets the selected value for the ButtonModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>=.l= = hi. o<眕縭/> ih/


Uses of Interface javax.swing.CellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.CellEditor

  • Packages that use CellEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of CellEditor in javax.swing

      Classes in javax.swing that implement CellEditor
      修饰符与类型 类与描述
      class  AbstractCellEditor
      A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue().
      class  DefaultCellEditor
      The default editor for table and tree cells.

    • Uses of CellEditor in javax.swing.table

      Subinterfaces of CellEditor in javax.swing.table
      修饰符与类型 Interface and Description
      interface  TableCellEditor
      This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.

    • Uses of CellEditor in javax.swing.tree

      Subinterfaces of CellEditor in javax.swing.tree
      修饰符与类型 Interface and Description
      interface  TreeCellEditor
      Adds to CellEditor the extensions necessary to configure an editor in a tree.
      Classes in javax.swing.tree that implement CellEditor
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor
      A TreeCellEditor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aovhnxlxehhhn/>>> i/a


Uses of Interface javax.swing.ComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ComboBoxEditor

  • Packages that use ComboBoxEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ComboBoxEditor in javax.swing

      Fields in javax.swing declared as ComboBoxEditor
      修饰符与类型 字段与描述
      protected ComboBoxEditor JComboBox.editor
      This protected field is implementation specific.
      Methods in javax.swing that return ComboBoxEditor
      修饰符与类型 方法与描述
      ComboBoxEditor JComboBox.getEditor()
      Returns the editor used to paint and edit the selected item in the JComboBox field.
      Methods in javax.swing with parameters of type ComboBoxEditor
      修饰符与类型 方法与描述
      void JComboBox.configureEditor(ComboBoxEditor anEditor, Object anItem)
      Initializes the editor with the specified item.
      void JComboBox.setEditor(ComboBoxEditor anEditor)
      Sets the editor used to paint and edit the selected item in the JComboBox field.

    • Uses of ComboBoxEditor in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ComboBoxEditor
      修饰符与类型 类与描述
      class  BasicComboBoxEditor
      The default editor for editable combo boxes.
      static class  BasicComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
      Methods in javax.swing.plaf.basic that return ComboBoxEditor
      修饰符与类型 方法与描述
      protected ComboBoxEditor BasicComboBoxUI.createEditor()
      Creates the default editor that will be used in editable combo boxes.

    • Uses of ComboBoxEditor in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ComboBoxEditor
      修饰符与类型 类与描述
      class  MetalComboBoxEditor
      The default editor for Metal editable combo boxes
      static class  MetalComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
      Methods in javax.swing.plaf.metal that return ComboBoxEditor
      修饰符与类型 | 方法与描述
      protected ComboBoxEditor | MetalComboBoxUI.createEditor()

    • Uses of ComboBoxEditor in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return ComboBoxEditor
      修饰符与类型 | 方法与描述
      protected ComboBoxEditor | SynthComboBoxUI.createEditor()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lraeio"t-/us >/ b"..mlrv


Uses of Interface javax.swing.ComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ComboBoxModel

  • Packages that use ComboBoxModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of ComboBoxModel in javax.swing

      Subinterfaces of ComboBoxModel in javax.swing
      修饰符与类型 Interface and Description
      interface  MutableComboBoxModel
      A mutable version of ComboBoxModel.
      Classes in javax.swing that implement ComboBoxModel
      修饰符与类型 类与描述
      class  DefaultComboBoxModel
      The default model for combo boxes.
      Fields in javax.swing declared as ComboBoxModel
      修饰符与类型 字段与描述
      protected ComboBoxModel JComboBox.dataModel
      This protected field is implementation specific.
      Methods in javax.swing that return ComboBoxModel
      修饰符与类型 方法与描述
      ComboBoxModel JComboBox.getModel()
      Returns the data model currently used by the JComboBox.
      Methods in javax.swing with parameters of type ComboBoxModel
      修饰符与类型 方法与描述
      int JComboBox.KeySelectionManager.selectionForKey(char aKey, ComboBoxModel aModel)
      Given aKey and the model, returns the row that should become selected.
      void JComboBox.setModel(ComboBoxModel aModel)
      Sets the data model that the JComboBox uses to obtain the list of items.
      Constructors in javax.swing with parameters of type ComboBoxModel
      构造方法与描述
      JComboBox(ComboBoxModel aModel)
      Creates a JComboBox that takes its items from an existing ComboBoxModel.

    • Uses of ComboBoxModel in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ComboBoxModel
      修饰符与类型 方法与描述
      protected void BasicComboPopup.installComboBoxModelListeners(ComboBoxModel model)
      Installs the listeners on the combo box model.
      protected void BasicComboPopup.uninstallComboBoxModelListeners(ComboBoxModel model)
      Removes the listeners from the combo box model

    • Uses of ComboBoxModel in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ComboBoxModel
      修饰符与类型 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      Data model for a type-face selection combo-box.
      protected class  MetalFileChooserUI.FilterComboBoxModel
      Data model for a type-face selection combo-box.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nacr IeIPrfe 奎黳bf�.bo.籧r�


Uses of Interface javax.swing.DesktopManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.DesktopManager

  • Packages that use DesktopManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of DesktopManager in javax.swing

      Classes in javax.swing that implement DesktopManager
      修饰符与类型 类与描述
      class  DefaultDesktopManager
      This is an implementation of the DesktopManager.
      Methods in javax.swing that return DesktopManager
      修饰符与类型 方法与描述
      DesktopManager JDesktopPane.getDesktopManager()
      Returns the DesktopManger that handles desktop-specific UI actions.
      Methods in javax.swing with parameters of type DesktopManager
      修饰符与类型 方法与描述
      void JDesktopPane.setDesktopManager(DesktopManager d)
      Sets the DesktopManger that will handle desktop-specific UI actions.

    • Uses of DesktopManager in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as DesktopManager
      修饰符与类型 | 字段与描述
      protected DesktopManager | BasicDesktopPaneUI.desktopManager
      Methods in javax.swing.plaf.basic that return DesktopManager
      修饰符与类型 | 方法与描述
      protected DesktopManager | BasicInternalFrameUI.createDesktopManager()
      protected DesktopManager BasicInternalFrameUI.getDesktopManager()
      Returns the proper DesktopManager.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.Icon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.Icon

  • Packages that use Icon
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.border
    Provides classes and interface for drawing specialized borders around a Swing component.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.filechooser
    Contains classes and interfaces used by the JFileChooser component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of Icon in javax.swing

      Classes in javax.swing that implement Icon
      修饰符与类型 类与描述
      class  ImageIcon
      An implementation of the Icon interface that paints Icons from Images.
      Fields in javax.swing declared as Icon
      修饰符与类型 字段与描述
      protected Icon JInternalFrame.frameIcon
      The icon shown in the top-left corner of this internal frame.
      protected Icon JOptionPane.icon
      Icon used in pane.
      Methods in javax.swing that return Icon
      修饰符与类型 方法与描述
      Icon JLabel.getDisabledIcon()
      Returns the icon used by the label when it's disabled.
      Icon AbstractButton.getDisabledIcon()
      Returns the icon used by the button when it's disabled.
      Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon JTabbedPane.getDisabledIconAt(int index)
      Returns the tab disabled icon at index.
      Icon AbstractButton.getDisabledSelectedIcon()
      Returns the icon used by the button when it's disabled and selected.
      Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      Icon JInternalFrame.getFrameIcon()
      Returns the image displayed in the title bar of this internal frame (usually in the top-left corner).
      Icon JOptionPane.getIcon()
      Returns the icon this pane displays.
      Icon JLabel.getIcon()
      Returns the graphic image (glyph, icon) that the label displays.
      Icon AbstractButton.getIcon()
      Returns the default icon.
      Icon JFileChooser.getIcon(File f)
      Returns the icon for this file or type of file, depending on the system.
      static Icon UIManager.getIcon(Object key)
      Returns an Icon from the defaults.
      Icon UIDefaults.getIcon(Object key)
      If the value of key is an Icon return it, otherwise return null.
      static Icon UIManager.getIcon(Object key, Locale l)
      Returns an Icon from the defaults that is appropriate for the given locale.
      Icon UIDefaults.getIcon(Object key, Locale l)
      If the value of key for the given Locale is an Icon return it, otherwise return null.
      Icon JTabbedPane.getIconAt(int index)
      Returns the tab icon at index.
      Icon AbstractButton.getPressedIcon()
      Returns the pressed icon for the button.
      Icon AbstractButton.getRolloverIcon()
      Returns the rollover icon for the button.
      Icon AbstractButton.getRolloverSelectedIcon()
      Returns the rollover selection icon for the button.
      Icon AbstractButton.getSelectedIcon()
      Returns the selected icon for the button.
      Icon TransferHandler.getVisualRepresentation(Transferable t)
      Returns an object that establishes the look of a transfer.
      Methods in javax.swing with parameters of type Icon
      修饰符与类型 | 方法与描述
      void JTabbedPane.addTab(String title, Icon icon, Component component)
      Adds a component represented by a title and/or icon, either of which can be null.
      void JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
      Adds a component and tip represented by a title and/or icon, either of which can be null.
      static MatteBorder BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
      Creates a matte-look border that consists of multiple tiles of a specified icon.
      Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      int JTabbedPane.indexOfTab(Icon icon)
      Returns the first tab index with a given icon, or -1 if no tab has this icon.
      protected void JMenuItem.init(String text, Icon icon)
      Initializes the menu item with the specified text and icon.
      protected void | AbstractButton.init(String text, Icon icon)
      void JTextPane.insertIcon(Icon g)
      Inserts an icon into the document as a replacement for the currently selected content.
      void JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
      Inserts a new tab for the given component, at the given index, represented by the given title and/or icon, either of which may be null.
      static String SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
      static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
      Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
      void JLabel.setDisabledIcon(Icon disabledIcon)
      Set the icon to be displayed if this JLabel is "disabled" (JLabel.setEnabled(false)).
      void AbstractButton.setDisabledIcon(Icon disabledIcon)
      Sets the disabled icon for the button.
      void JTabbedPane.setDisabledIconAt(int index, Icon disabledIcon)
      Sets the disabled icon at index to icon which can be null.
      void AbstractButton.setDisabledSelectedIcon(Icon disabledSelectedIcon)
      Sets the disabled selection icon for the button.
      void JInternalFrame.setFrameIcon(Icon icon)
      Sets an image to be displayed in the titlebar of this internal frame (usually in the top-left corner).
      void JOptionPane.setIcon(Icon newIcon)
      Sets the icon to display.
      void JLabel.setIcon(Icon icon)
      Defines the icon this component will display.
      void AbstractButton.setIcon(Icon defaultIcon)
      Sets the button's default icon.
      void JTabbedPane.setIconAt(int index, Icon icon)
      Sets the icon at index to icon which can be null.
      void AbstractButton.setPressedIcon(Icon pressedIcon)
      Sets the pressed icon for the button.
      void AbstractButton.setRolloverIcon(Icon rolloverIcon)
      Sets the rollover icon for the button.
      void AbstractButton.setRolloverSelectedIcon(Icon rolloverSelectedIcon)
      Sets the rollover selected icon for the button.
      void AbstractButton.setSelectedIcon(Icon selectedIcon)
      Sets the selected icon for the button.
      static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      Brings up a dialog with a specified icon, where the number of choices is determined by the optionType parameter.
      static Object JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      Prompts the user for input in a blocking dialog where the initial selection, possible selections, and all other options can be specified.
      static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
      Brings up an internal dialog panel with a specified icon, where the number of choices is determined by the optionType parameter.
      static Object JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
      Prompts the user for input in a blocking internal dialog where the initial selection, possible selections, and all other options can be specified.
      static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
      Brings up an internal dialog panel displaying a message, specifying all parameters.
      static int JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      Brings up an internal dialog panel with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.
      static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
      Brings up a dialog displaying a message, specifying all parameters.
      static int JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
      Brings up a dialog with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.
      Constructors in javax.swing with parameters of type Icon
      构造方法与描述
      AbstractAction(String name, Icon icon)
      Creates an Action with the specified name and small icon.
      JButton(Icon icon)
      Creates a button with an icon.
      JButton(String text, Icon icon)
      Creates a button with initial text and an icon.
      JCheckBox(Icon icon)
      Creates an initially unselected check box with an icon.
      JCheckBox(Icon icon, boolean selected)
      Creates a check box with an icon and specifies whether or not it is initially selected.
      JCheckBox(String text, Icon icon)
      Creates an initially unselected check box with the specified text and icon.
      JCheckBox(String text, Icon icon, boolean selected)
      Creates a check box with text and icon, and specifies whether or not it is initially selected.
      JCheckBoxMenuItem(Icon icon)
      Creates an initially unselected check box menu item with an icon.
      JCheckBoxMenuItem(String text, Icon icon)
      Creates an initially unselected check box menu item with the specified text and icon.
      JCheckBoxMenuItem(String text, Icon icon, boolean b)
      Creates a check box menu item with the specified text, icon, and selection state.
      JLabel(Icon image)
      Creates a JLabel instance with the specified image.
      JLabel(Icon image, int horizontalAlignment)
      Creates a JLabel instance with the specified image and horizontal alignment.
      JLabel(String text, Icon icon, int horizontalAlignment)
      Creates a JLabel instance with the specified text, image, and horizontal alignment.
      JMenuItem(Icon icon)
      Creates a JMenuItem with the specified icon.
      JMenuItem(String text, Icon icon)
      Creates a JMenuItem with the specified text and icon.
      JOptionPane(Object message, int messageType, int optionType, Icon icon)
      Creates an instance of JOptionPane to display a message with the specified message type, options, and icon.
      JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
      Creates an instance of JOptionPane to display a message with the specified message type, icon, and options.
      JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
      Creates an instance of JOptionPane to display a message with the specified message type, icon, and options, with the initially-selected option specified.
      JRadioButton(Icon icon)
      Creates an initially unselected radio button with the specified image but no text.
      JRadioButton(Icon icon, boolean selected)
      Creates a radio button with the specified image and selection state, but no text.
      JRadioButton(String text, Icon icon)
      Creates a radio button that has the specified text and image, and that is initially unselected.
      JRadioButton(String text, Icon icon, boolean selected)
      Creates a radio button that has the specified text, image, and selection state.
      JRadioButtonMenuItem(Icon icon)
      Creates a JRadioButtonMenuItem with an icon.
      JRadioButtonMenuItem(Icon icon, boolean selected)
      Creates a radio button menu item with the specified image and selection state, but no text.
      JRadioButtonMenuItem(String text, Icon icon)
      Creates a radio button menu item with the specified text and Icon.
      JRadioButtonMenuItem(String text, Icon icon, boolean selected)
      Creates a radio button menu item that has the specified text, image, and selection state.
      JToggleButton(Icon icon)
      Creates an initially unselected toggle button with the specified image but no text.
      JToggleButton(Icon icon, boolean selected)
      Creates a toggle button with the specified image and selection state, but no text.
      JToggleButton(String text, Icon icon)
      Creates a toggle button that has the specified text and image, and that is initially unselected.
      JToggleButton(String text, Icon icon, boolean selected)
      Creates a toggle button with the specified text, image, and selection state.

    • Uses of Icon in javax.swing.border

      Fields in javax.swing.border declared as Icon
      修饰符与类型 | 字段与描述
      protected Icon | MatteBorder.tileIcon
      Methods in javax.swing.border that return Icon
      修饰符与类型 方法与描述
      Icon MatteBorder.getTileIcon()
      Returns the icon used for tiling the border or null if a solid color is being used.
      Constructors in javax.swing.border with parameters of type Icon
      构造方法与描述
      MatteBorder(Icon tileIcon)
      Creates a matte border with the specified tile icon.
      MatteBorder(Insets borderInsets, Icon tileIcon)
      Creates a matte border with the specified insets and tile icon.
      MatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
      Creates a matte border with the specified insets and tile icon.

    • Uses of Icon in javax.swing.colorchooser

      Methods in javax.swing.colorchooser that return Icon
      修饰符与类型 方法与描述
      abstract Icon AbstractColorChooserPanel.getLargeDisplayIcon()
      Returns the large display icon for the panel.
      abstract Icon AbstractColorChooserPanel.getSmallDisplayIcon()
      Returns the small display icon for the panel.

    • Uses of Icon in javax.swing.filechooser

      Methods in javax.swing.filechooser that return Icon
      修饰符与类型 方法与描述
      Icon FileView.getIcon(File f)
      The icon that represents this file in the JFileChooser.
      Icon FileSystemView.getSystemIcon(File f)
      Icon for a file, directory, or folder as it would be displayed in a system file browser.

    • Uses of Icon in javax.swing.plaf

      Classes in javax.swing.plaf that implement Icon
      修饰符与类型 类与描述
      class  IconUIResource
      An Icon wrapper class which implements UIResource.
      Constructors in javax.swing.plaf with parameters of type Icon
      构造方法与描述
      BorderUIResource.MatteBorderUIResource(Icon tileIcon)
      BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Icon tileIcon)
      IconUIResource(Icon delegate)
      Creates a UIResource icon object which wraps an existing Icon instance.

    • Uses of Icon in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as Icon
      修饰符与类型 | 字段与描述
      protected Icon | BasicMenuItemUI.arrowIcon
      protected Icon | BasicMenuItemUI.checkIcon
      protected Icon | BasicInternalFrameTitlePane.closeIcon
      protected Icon | BasicTreeUI.collapsedIcon
      protected Icon | BasicFileChooserUI.computerIcon
      protected Icon | BasicFileChooserUI.detailsViewIcon
      protected Icon | BasicFileChooserUI.directoryIcon
      protected Icon | BasicTreeUI.expandedIcon
      protected Icon | BasicFileChooserUI.fileIcon
      protected Icon | BasicFileChooserUI.floppyDriveIcon
      protected Icon | BasicFileChooserUI.hardDriveIcon
      protected Icon | BasicFileChooserUI.homeFolderIcon
      protected Icon | BasicRadioButtonUI.icon
      protected Icon | BasicInternalFrameTitlePane.iconIcon
      protected Icon | BasicFileChooserUI.listViewIcon
      protected Icon | BasicInternalFrameTitlePane.maxIcon
      protected Icon | BasicInternalFrameTitlePane.minIcon
      protected Icon | BasicFileChooserUI.newFolderIcon
      protected Icon | BasicFileChooserUI.upFolderIcon
      protected Icon | BasicFileChooserUI.viewMenuIcon
      Fields in javax.swing.plaf.basic with type parameters of type Icon
      修饰符与类型 | 字段与描述
      protected Hashtable<File,Icon> | BasicFileChooserUI.BasicFileView.iconCache
      Methods in javax.swing.plaf.basic that return Icon
      修饰符与类型 | 方法与描述
      static Icon | BasicIconFactory.createEmptyFrameIcon()
      Icon | BasicFileChooserUI.BasicFileView.getCachedIcon(File f)
      static Icon | BasicIconFactory.getCheckBoxIcon()
      static Icon | BasicIconFactory.getCheckBoxMenuItemIcon()
      Icon | BasicTreeUI.getCollapsedIcon()
      Icon | BasicRadioButtonUI.getDefaultIcon()
      Icon | BasicTreeUI.getExpandedIcon()
      protected Icon BasicOptionPaneUI.getIcon()
      Returns the icon from the JOptionPane the receiver is providing the look and feel for, or the default icon as returned from getDefaultIcon.
      Icon | BasicFileChooserUI.BasicFileView.getIcon(File f)
      protected Icon | BasicTabbedPaneUI.getIconForTab(int tabIndex)
      protected Icon BasicOptionPaneUI.getIconForType(int messageType)
      Returns the icon to use for the passed in type.
      static Icon | BasicIconFactory.getMenuArrowIcon()
      static Icon | BasicIconFactory.getMenuItemArrowIcon()
      static Icon | BasicIconFactory.getMenuItemCheckIcon()
      static Icon | BasicIconFactory.getRadioButtonIcon()
      static Icon | BasicIconFactory.getRadioButtonMenuItemIcon()
      Methods in javax.swing.plaf.basic with parameters of type Icon
      修饰符与类型 | 方法与描述
      void | BasicFileChooserUI.BasicFileView.cacheIcon(File f, Icon i)
      protected void | BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
      protected Dimension | BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      protected String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
      Forwards the call to SwingUtilities.layoutCompoundLabel().
      protected void | BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
      protected void | BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
      void | BasicTreeUI.setCollapsedIcon(Icon newG)
      void | BasicTreeUI.setExpandedIcon(Icon newG)

    • Uses of Icon in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement Icon
      修饰符与类型 | 类与描述
      class  MetalCheckBoxIcon
      CheckboxIcon implementation for OrganicCheckBoxUI
      class  MetalComboBoxIcon
      This utility class draws the horizontal bars which indicate a MetalComboBox
      static class  MetalIconFactory.FileIcon16
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.FolderIcon16
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.PaletteCloseIcon
      Defines an icon for Palette close
      static class  MetalIconFactory.TreeControlIcon
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.TreeFolderIcon
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  | MetalIconFactory.TreeLeafIcon
      Fields in javax.swing.plaf.metal declared as Icon
      修饰符与类型 | 字段与描述
      protected Icon | MetalComboBoxButton.comboIcon
      protected static Icon MetalSliderUI.horizThumbIcon
      A default horizontal thumb Icon.
      protected Icon | MetalInternalFrameTitlePane.paletteCloseIcon
      protected static Icon MetalSliderUI.vertThumbIcon
      A default vertical thumb Icon.
      Methods in javax.swing.plaf.metal that return Icon
      修饰符与类型 | 方法与描述
      static Icon MetalIconFactory.getCheckBoxIcon()
      Returns a checkbox icon.
      static Icon | MetalIconFactory.getCheckBoxMenuItemIcon()
      Icon | MetalComboBoxButton.getComboIcon()
      Icon MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      static Icon | MetalIconFactory.getFileChooserDetailViewIcon()
      static Icon | MetalIconFactory.getFileChooserHomeFolderIcon()
      static Icon | MetalIconFactory.getFileChooserListViewIcon()
      static Icon | MetalIconFactory.getFileChooserNewFolderIcon()
      static Icon | MetalIconFactory.getFileChooserUpFolderIcon()
      static Icon | MetalIconFactory.getHorizontalSliderThumbIcon()
      static Icon | MetalIconFactory.getInternalFrameAltMaximizeIcon(int size)
      static Icon | MetalIconFactory.getInternalFrameCloseIcon(int size)
      static Icon | MetalIconFactory.getInternalFrameDefaultMenuIcon()
      static Icon | MetalIconFactory.getInternalFrameMaximizeIcon(int size)
      static Icon | MetalIconFactory.getInternalFrameMinimizeIcon(int size)
      static Icon | MetalIconFactory.getMenuArrowIcon()
      static Icon | MetalIconFactory.getMenuItemArrowIcon()
      static Icon MetalIconFactory.getMenuItemCheckIcon()
      Returns an icon to be used by JCheckBoxMenuItem.
      static Icon | MetalIconFactory.getRadioButtonIcon()
      static Icon | MetalIconFactory.getRadioButtonMenuItemIcon()
      static Icon | MetalIconFactory.getTreeComputerIcon()
      static Icon | MetalIconFactory.getTreeControlIcon(boolean isCollapsed)
      static Icon | MetalIconFactory.getTreeFloppyDriveIcon()
      static Icon | MetalIconFactory.getTreeFolderIcon()
      static Icon | MetalIconFactory.getTreeHardDriveIcon()
      static Icon | MetalIconFactory.getTreeLeafIcon()
      static Icon | MetalIconFactory.getVerticalSliderThumbIcon()
      Methods in javax.swing.plaf.metal with parameters of type Icon
      修饰符与类型 | 方法与描述
      Icon MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      void | MetalComboBoxButton.setComboIcon(Icon i)
      Constructors in javax.swing.plaf.metal with parameters of type Icon
      构造方法与描述
      MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
      MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

    • Uses of Icon in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return Icon
      修饰符与类型 | 方法与描述
      Icon | NimbusLookAndFeel.getDisabledIcon(JComponent component, Icon icon)
      Methods in javax.swing.plaf.nimbus with parameters of type Icon
      修饰符与类型 | 方法与描述
      Icon | NimbusLookAndFeel.getDisabledIcon(JComponent component, Icon icon)

    • Uses of Icon in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return Icon
      修饰符与类型 | 方法与描述
      protected Icon SynthButtonUI.getDefaultIcon(AbstractButton b)
      Returns the default icon.
      Icon | SynthTreeUI.getExpandedIcon()
      protected Icon SynthButtonUI.getIcon(AbstractButton b)
      Returns the Icon to use for painting the button.
      Icon SynthStyle.getIcon(SynthContext context, Object key)
      Convenience method to get a specific style property whose value is an Icon.
      protected Icon SynthRadioButtonUI.getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      protected Icon SynthButtonUI.getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      Methods in javax.swing.plaf.synth with parameters of type Icon
      修饰符与类型 | 方法与描述
      protected void | SynthTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
      Dimension SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the maximum size needed to properly render an icon and text.
      Dimension SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the minimum size needed to properly render an icon and text.
      protected Dimension | SynthMenuUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      protected Dimension | SynthMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      Dimension SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the preferred size needed to properly render an icon and text.
      String SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
      Lays out text and an icon returning, by reference, the location to place the icon and text.
      void SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
      Paints an icon and text.

    • Uses of Icon in javax.swing.text

      Methods in javax.swing.text that return Icon
      修饰符与类型 方法与描述
      static Icon StyleConstants.getIcon(AttributeSet a)
      Gets the icon setting from the attribute list.
      Methods in javax.swing.text with parameters of type Icon
      修饰符与类型 方法与描述
      static void StyleConstants.setIcon(MutableAttributeSet a, Icon c)
      Sets the icon attribute.

    • Uses of Icon in javax.swing.text.html

      Methods in javax.swing.text.html that return Icon
      修饰符与类型 方法与描述
      Icon ImageView.getLoadingImageIcon()
      Returns the icon to use while in the process of loading the image.
      Icon ImageView.getNoImageIcon()
      Returns the icon to use if the image couldn't be found.

    • Uses of Icon in javax.swing.tree

      Fields in javax.swing.tree declared as Icon
      修饰符与类型 字段与描述
      protected Icon DefaultTreeCellRenderer.closedIcon
      Icon used to show non-leaf nodes that aren't expanded.
      protected Icon DefaultTreeCellEditor.editingIcon
      Icon to use when editing.
      protected Icon DefaultTreeCellRenderer.leafIcon
      Icon used to show leaf nodes.
      protected Icon DefaultTreeCellRenderer.openIcon
      Icon used to show non-leaf nodes that are expanded.
      Methods in javax.swing.tree that return Icon
      修饰符与类型 方法与描述
      Icon DefaultTreeCellRenderer.getClosedIcon()
      Returns the icon used to represent non-leaf nodes that are not expanded.
      Icon DefaultTreeCellRenderer.getDefaultClosedIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.
      Icon DefaultTreeCellRenderer.getDefaultLeafIcon()
      Returns the default icon, for the current laf, that is used to represent leaf nodes.
      Icon DefaultTreeCellRenderer.getDefaultOpenIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.
      Icon DefaultTreeCellRenderer.getLeafIcon()
      Returns the icon used to represent leaf nodes.
      Icon DefaultTreeCellRenderer.getOpenIcon()
      Returns the icon used to represent non-leaf nodes that are expanded.
      Methods in javax.swing.tree with parameters of type Icon
      修饰符与类型 方法与描述
      void DefaultTreeCellRenderer.setClosedIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are not expanded.
      void DefaultTreeCellRenderer.setLeafIcon(Icon newIcon)
      Sets the icon used to represent leaf nodes.
      void DefaultTreeCellRenderer.setOpenIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are expanded.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.JComboBox.KeySelectionManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.JComboBox.KeySelectionManager

  • Packages that use JComboBox.KeySelectionManager
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JComboBox.KeySelectionManager in javax.swing

      Fields in javax.swing declared as JComboBox.KeySelectionManager
      修饰符与类型 字段与描述
      protected JComboBox.KeySelectionManager JComboBox.keySelectionManager
      This protected field is implementation specific.
      Methods in javax.swing that return JComboBox.KeySelectionManager
      修饰符与类型 方法与描述
      protected JComboBox.KeySelectionManager JComboBox.createDefaultKeySelectionManager()
      Returns an instance of the default key-selection manager.
      JComboBox.KeySelectionManager JComboBox.getKeySelectionManager()
      Returns the list's key-selection manager.
      Methods in javax.swing with parameters of type JComboBox.KeySelectionManager
      修饰符与类型 方法与描述
      void JComboBox.setKeySelectionManager(JComboBox.KeySelectionManager aManager)
      Sets the object that translates a keyboard character into a list selection.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sgpbsic"g>>>rlaad >a lo= =


Uses of Interface javax.swing.ListCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ListCellRenderer

  • Packages that use ListCellRenderer
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ListCellRenderer in javax.swing

      Classes in javax.swing that implement ListCellRenderer
      修饰符与类型 类与描述
      class  DefaultListCellRenderer
      Renders an item in a list.
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.
      Fields in javax.swing declared as ListCellRenderer
      修饰符与类型 字段与描述
      protected ListCellRenderer JComboBox.renderer
      This protected field is implementation specific.
      Methods in javax.swing that return ListCellRenderer
      修饰符与类型 方法与描述
      ListCellRenderer<? super E> JList.getCellRenderer()
      Returns the object responsible for painting list items.
      ListCellRenderer JComboBox.getRenderer()
      Returns the renderer used to display the selected item in the JComboBox field.
      Methods in javax.swing with parameters of type ListCellRenderer
      修饰符与类型 方法与描述
      void JList.setCellRenderer(ListCellRenderer<? super E> cellRenderer)
      Sets the delegate that is used to paint each cell in the list.
      void JComboBox.setRenderer(ListCellRenderer aRenderer)
      Sets the renderer that paints the list items and the item selected from the list in the JComboBox field.

    • Uses of ListCellRenderer in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ListCellRenderer
      修饰符与类型 类与描述
      class  BasicComboBoxRenderer
      ComboBox renderer
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
      Methods in javax.swing.plaf.basic that return ListCellRenderer
      修饰符与类型 方法与描述
      protected ListCellRenderer BasicComboBoxUI.createRenderer()
      Creates the default renderer that will be used in a non-editiable combo box.
      Methods in javax.swing.plaf.basic with parameters of type ListCellRenderer
      修饰符与类型 方法与描述
      protected void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
      Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it.

    • Uses of ListCellRenderer in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ListCellRenderer
      修饰符与类型 | 类与描述
      protected class  | MetalFileChooserUI.FileRenderer
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.

    • Uses of ListCellRenderer in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return ListCellRenderer
      修饰符与类型 | 方法与描述
      protected ListCellRenderer | SynthComboBoxUI.createRenderer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=< iy/o/


Uses of Interface javax.swing.ListModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ListModel

  • Packages that use ListModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of ListModel in javax.swing

      Subinterfaces of ListModel in javax.swing
      修饰符与类型 Interface and Description
      interface  ComboBoxModel
      A data model for a combo box.
      interface  MutableComboBoxModel
      A mutable version of ComboBoxModel.
      Classes in javax.swing that implement ListModel
      修饰符与类型 类与描述
      class  AbstractListModel<E>
      The abstract definition for the data model that provides a List with its contents.
      class  DefaultComboBoxModel
      The default model for combo boxes.
      class  DefaultListModel<E>
      This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur.
      Methods in javax.swing that return ListModel
      修饰符与类型 方法与描述
      ListModel<E> JList.getModel()
      Returns the data model that holds the list of items displayed by the JList component.
      Methods in javax.swing with parameters of type ListModel
      修饰符与类型 方法与描述
      void JList.setModel(ListModel<E> model)
      Sets the model that represents the contents or "value" of the list, notifies property change listeners, and then clears the list's selection.
      Constructors in javax.swing with parameters of type ListModel
      构造方法与描述
      JList(ListModel<E> dataModel)
      Constructs a JList that displays elements from the specified, non-null, model.

    • Uses of ListModel in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ListModel
      修饰符与类型 类与描述
      class  BasicDirectoryModel
      Basic implementation of a file list.
      Methods in javax.swing.plaf.basic with parameters of type ListModel
      修饰符与类型 方法与描述
      protected void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
      Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it.

    • Uses of ListModel in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ListModel
      修饰符与类型 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      Data model for a type-face selection combo-box.
      protected class  MetalFileChooserUI.FilterComboBoxModel
      Data model for a type-face selection combo-box.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n_a>omNb"ooos< =/A>>v =-ii


Uses of Interface javax.swing.ListSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ListSelectionModel

  • Packages that use ListSelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of ListSelectionModel in javax.swing

      Classes in javax.swing that implement ListSelectionModel
      修饰符与类型 类与描述
      class  DefaultListSelectionModel
      Default data model for list selections.
      Fields in javax.swing declared as ListSelectionModel
      修饰符与类型 字段与描述
      protected ListSelectionModel JTable.selectionModel
      The ListSelectionModel of the table, used to keep track of row selections.
      Methods in javax.swing that return ListSelectionModel
      修饰符与类型 方法与描述
      protected ListSelectionModel JTable.createDefaultSelectionModel()
      Returns the default selection model object, which is a DefaultListSelectionModel.
      protected ListSelectionModel JList.createSelectionModel()
      Returns an instance of DefaultListSelectionModel; called during construction to initialize the list's selection model property.
      ListSelectionModel JTable.getSelectionModel()
      Returns the ListSelectionModel that is used to maintain row selection state.
      ListSelectionModel JList.getSelectionModel()
      Returns the current selection model.
      Methods in javax.swing with parameters of type ListSelectionModel
      修饰符与类型 方法与描述
      void JTable.setSelectionModel(ListSelectionModel newModel)
      Sets the row selection model for this table to newModel and registers for listener notifications from the new selection model.
      void JList.setSelectionModel(ListSelectionModel selectionModel)
      Sets the selectionModel for the list to a non-null ListSelectionModel implementation.
      Constructors in javax.swing with parameters of type ListSelectionModel
      构造方法与描述
      JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model.

    • Uses of ListSelectionModel in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ListSelectionModel
      修饰符与类型 方法与描述
      protected void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
      Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it.

    • Uses of ListSelectionModel in javax.swing.table

      Fields in javax.swing.table declared as ListSelectionModel
      修饰符与类型 字段与描述
      protected ListSelectionModel DefaultTableColumnModel.selectionModel
      Model for keeping track of column selections
      Methods in javax.swing.table that return ListSelectionModel
      修饰符与类型 方法与描述
      protected ListSelectionModel DefaultTableColumnModel.createSelectionModel()
      Creates a new default list selection model.
      ListSelectionModel DefaultTableColumnModel.getSelectionModel()
      Returns the ListSelectionModel that is used to maintain column selection state.
      ListSelectionModel TableColumnModel.getSelectionModel()
      Returns the current selection model.
      Methods in javax.swing.table with parameters of type ListSelectionModel
      修饰符与类型 方法与描述
      void DefaultTableColumnModel.setSelectionModel(ListSelectionModel newModel)
      Sets the selection model for this TableColumnModel to newModel and registers for listener notifications from the new selection model.
      void TableColumnModel.setSelectionModel(ListSelectionModel newModel)
      Sets the selection model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otdt.


Uses of Interface javax.swing.MenuElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.MenuElement

  • Packages that use MenuElement
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MenuElement in javax.swing

      Classes in javax.swing that implement MenuElement
      修饰符与类型 类与描述
      class  JCheckBoxMenuItem
      A menu item that can be selected or deselected.
      class  JMenu
      An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
      class  JMenuBar
      An implementation of a menu bar.
      class  JMenuItem
      An implementation of an item in a menu.
      class  JPopupMenu
      An implementation of a popup menu -- a small window that pops up and displays a series of choices.
      class  JRadioButtonMenuItem
      An implementation of a radio button menu item.
      Methods in javax.swing that return MenuElement
      修饰符与类型 方法与描述
      MenuElement[] MenuSelectionManager.getSelectedPath()
      Returns the path to the currently selected menu item
      MenuElement[] JMenuItem.getSubElements()
      This method returns an array containing the sub-menu components for this menu component.
      MenuElement[] JMenu.getSubElements()
      Returns an array of MenuElements containing the submenu for this menu component.
      MenuElement[] JPopupMenu.getSubElements()
      Returns an array of MenuElements containing the submenu for this menu component.
      MenuElement[] MenuElement.getSubElements()
      This method should return an array containing the sub-elements for the receiving menu element
      MenuElement[] JMenuBar.getSubElements()
      Implemented to be a MenuElement -- returns the menus in this menu bar.
      Methods in javax.swing with parameters of type MenuElement
      修饰符与类型 方法与描述
      void JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
      void MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager)
      Process a key event.
      void JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.
      void JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using the MenuSelectionManager's API.
      void JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      This method is required to conform to the MenuElement interface, but it not implemented.
      void MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Processes a mouse event.
      void JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
      Implemented to be a MenuElement -- does nothing.
      void MenuSelectionManager.setSelectedPath(MenuElement[] path)
      Changes the selection in the menu hierarchy.

    • Uses of MenuElement in javax.swing.event

      Methods in javax.swing.event that return MenuElement
      修饰符与类型 方法与描述
      MenuElement[] MenuDragMouseEvent.getPath()
      Returns the path to the selected menu item.
      MenuElement[] MenuKeyEvent.getPath()
      Returns the path to the menu item referenced by this event.
      Constructors in javax.swing.event with parameters of type MenuElement
      构造方法与描述
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.
      MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuKeyEvent object.

    • Uses of MenuElement in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MenuElement
      修饰符与类型 类与描述
      class  BasicComboPopup
      This is a basic implementation of the ComboPopup interface.
      class  BasicInternalFrameTitlePane.SystemMenuBar
      This class should be treated as a "protected" inner class.
      Methods in javax.swing.plaf.basic that return MenuElement
      修饰符与类型 | 方法与描述
      MenuElement[] | BasicMenuItemUI.getPath()
      Methods in javax.swing.plaf.basic with parameters of type MenuElement
      修饰符与类型 | 方法与描述
      void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
      void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

    • Uses of MenuElement in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MenuElement
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=At>onge�>7s


Uses of Interface javax.swing.MutableComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.MutableComboBoxModel

  • Packages that use MutableComboBoxModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of MutableComboBoxModel in javax.swing

      Classes in javax.swing that implement MutableComboBoxModel
      修饰符与类型 类与描述
      class  DefaultComboBoxModel
      The default model for combo boxes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yiE.va.ni steeon>o n/Ee


Uses of Interface javax.swing.Painter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.Painter

  • Packages that use Painter
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.

    • Uses of Painter in javax.swing.plaf.nimbus

      Classes in javax.swing.plaf.nimbus that implement Painter
      修饰符与类型 类与描述
      class  AbstractRegionPainter
      Convenient base class for defining Painter instances for rendering a region or component in Nimbus.
      Methods in javax.swing.plaf.nimbus that return Painter
      修饰符与类型 方法与描述
      Painter NimbusStyle.getBackgroundPainter(SynthContext ctx)
      Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext.
      Painter NimbusStyle.getBorderPainter(SynthContext ctx)
      Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext.
      Painter NimbusStyle.getForegroundPainter(SynthContext ctx)
      Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=eit/peg/< alge.Sgolv


Uses of Interface javax.swing.Renderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.Renderer

No usage of javax.swing.Renderer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/sc/..g.//elymg觬lhl


Uses of Interface javax.swing.RootPaneContainer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.RootPaneContainer

  • Packages that use RootPaneContainer
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of RootPaneContainer in javax.swing

      Classes in javax.swing that implement RootPaneContainer
      修饰符与类型 类与描述
      class  JApplet
      An extended version of java.applet.Applet that adds support for the JFC/Swing component architecture.
      class  JDialog
      The main class for creating a dialog window.
      class  JFrame
      An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
      class  JInternalFrame
      A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
      class  JWindow
      A JWindow is a container that can be displayed anywhere on the user's desktop.

    • Uses of RootPaneContainer in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return RootPaneContainer
      修饰符与类型 方法与描述
      protected RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
      Creates a window which contains the toolbar after it has been dragged out from its container
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dy=aL>t"l


Uses of Interface javax.swing.Scrollable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.Scrollable

  • Packages that use Scrollable
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of Scrollable in javax.swing

      Classes in javax.swing that implement Scrollable
      修饰符与类型 类与描述
      class  JEditorPane
      A text component to edit various kinds of content.
      class  JFormattedTextField
      JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
      class  JLayer<V extends Component>
      JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.
      class  JList<E>
      A component that displays a list of objects and allows the user to select one or more items.
      class  JPasswordField
      JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      class  JTextArea
      A JTextArea is a multi-line area that displays plain text.
      class  JTextField
      JTextField is a lightweight component that allows the editing of a single line of text.
      class  JTextPane
      A text component that can be marked up with attributes that are represented graphically.
      class  JTree
      A control that displays a set of hierarchical data as an outline.

    • Uses of Scrollable in javax.swing.text

      Classes in javax.swing.text that implement Scrollable
      修饰符与类型 类与描述
      class  JTextComponent
      JTextComponent is the base class for swing text components.

    • Uses of Scrollable in javax.swing.tree

      Classes in javax.swing.tree that implement Scrollable
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

W,aaruroaoua


Uses of Interface javax.swing.ScrollPaneConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.ScrollPaneConstants

  • Packages that use ScrollPaneConstants
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ScrollPaneConstants in javax.swing

      Classes in javax.swing that implement ScrollPaneConstants
      修饰符与类型 类与描述
      class  JScrollPane
      Provides a scrollable view of a lightweight component.
      class  ScrollPaneLayout
      The layout manager used by JScrollPane.
      static class  ScrollPaneLayout.UIResource
      The UI resource version of ScrollPaneLayout.

    • Uses of ScrollPaneConstants in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ScrollPaneConstants
      修饰符与类型 类与描述
      class  BasicScrollPaneUI
      A default L&F implementation of ScrollPaneUI.

    • Uses of ScrollPaneConstants in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ScrollPaneConstants
      修饰符与类型 类与描述
      class  MetalScrollPaneUI
      A Metal L&F implementation of ScrollPaneUI.

    • Uses of ScrollPaneConstants in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement ScrollPaneConstants
      修饰符与类型 类与描述
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lbies<


Uses of Interface javax.swing.SingleSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.SingleSelectionModel

  • Packages that use SingleSelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SingleSelectionModel in javax.swing

      Classes in javax.swing that implement SingleSelectionModel
      修饰符与类型 类与描述
      class  DefaultSingleSelectionModel
      A generic implementation of SingleSelectionModel.
      Fields in javax.swing declared as SingleSelectionModel
      修饰符与类型 字段与描述
      protected SingleSelectionModel JTabbedPane.model
      The default selection model
      Methods in javax.swing that return SingleSelectionModel
      修饰符与类型 方法与描述
      SingleSelectionModel JTabbedPane.getModel()
      Returns the model associated with this tabbedpane.
      SingleSelectionModel JPopupMenu.getSelectionModel()
      Returns the model object that handles single selections.
      SingleSelectionModel JMenuBar.getSelectionModel()
      Returns the model object that handles single selections.
      Methods in javax.swing with parameters of type SingleSelectionModel
      修饰符与类型 方法与描述
      void JTabbedPane.setModel(SingleSelectionModel model)
      Sets the model to be used with this tabbedpane.
      void JPopupMenu.setSelectionModel(SingleSelectionModel model)
      Sets the model object to handle single selections.
      void JMenuBar.setSelectionModel(SingleSelectionModel model)
      Sets the model object to handle single selections.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mrO,rptia"r


Uses of Interface javax.swing.SpinnerModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.SpinnerModel

  • Packages that use SpinnerModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of SpinnerModel in javax.swing

      Classes in javax.swing that implement SpinnerModel
      修饰符与类型 类与描述
      class  AbstractSpinnerModel
      This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations.
      class  SpinnerDateModel
      A SpinnerModel for sequences of Dates.
      class  SpinnerListModel
      A simple implementation of SpinnerModel whose values are defined by an array or a List.
      class  SpinnerNumberModel
      A SpinnerModel for sequences of numbers.
      Methods in javax.swing that return SpinnerModel
      修饰符与类型 方法与描述
      SpinnerModel JSpinner.getModel()
      Returns the SpinnerModel that defines this spinners sequence of values.
      Methods in javax.swing with parameters of type SpinnerModel
      修饰符与类型 方法与描述
      protected JComponent JSpinner.createEditor(SpinnerModel model)
      This method is called by the constructors to create the JComponent that displays the current value of the sequence.
      void JSpinner.setModel(SpinnerModel model)
      Changes the model that represents the value of this spinner.
      Constructors in javax.swing with parameters of type SpinnerModel
      构造方法与描述
      JSpinner(SpinnerModel model)
      Constructs a spinner for the given model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et蕋 s ;.a/jat l莃 >sao �


Uses of Interface javax.swing.SwingConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.SwingConstants

  • Packages that use SwingConstants
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of SwingConstants in javax.swing

      Classes in javax.swing that implement SwingConstants
      修饰符与类型 类与描述
      class  AbstractButton
      Defines common behaviors for buttons and menu items.
      class  DefaultListCellRenderer
      Renders an item in a list.
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.
      class  JButton
      An implementation of a "push" button.
      class  JCheckBox
      An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
      class  JCheckBoxMenuItem
      A menu item that can be selected or deselected.
      class  JFormattedTextField
      JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
      class  JLabel
      A display area for a short text string or an image, or both.
      class  JMenu
      An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
      class  JMenuItem
      An implementation of an item in a menu.
      class  JPasswordField
      JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
      static class  JPopupMenu.Separator
      A popup menu-specific separator.
      class  JProgressBar
      A component that visually displays the progress of some task.
      class  JRadioButton
      An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
      class  JRadioButtonMenuItem
      An implementation of a radio button menu item.
      class  JSeparator
      JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
      class  JSlider
      A component that lets the user graphically select a value by sliding a knob within a bounded interval.
      class  JTabbedPane
      A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
      class  JTextField
      JTextField is a lightweight component that allows the editing of a single line of text.
      class  JToggleButton
      An implementation of a two-state button.
      class  JToolBar
      JToolBar provides a component that is useful for displaying commonly used Actions or controls.
      static class  JToolBar.Separator
      A toolbar-specific separator.
      class  SwingUtilities
      A collection of utility methods for Swing.

    • Uses of SwingConstants in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement SwingConstants
      修饰符与类型 类与描述
      class  BasicArrowButton
      JButton object that draws a scaled Arrow in one of the cardinal directions.
      class  BasicComboBoxRenderer
      ComboBox renderer
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
      protected class  BasicInternalFrameUI.BorderListener
      Listens for border adjustments.
      class  BasicScrollBarUI
      Implementation of ScrollBarUI for the Basic Look and Feel
      class  BasicTabbedPaneUI
      A Basic L&F implementation of TabbedPaneUI.
      class  BasicToolBarUI
      A Basic L&F implementation of ToolBarUI.

    • Uses of SwingConstants in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement SwingConstants
      修饰符与类型 | 类与描述
      static class  | MetalBorders.ToolBarBorder
      class  MetalComboBoxButton
      JButton subclass to help out MetalComboBoxUI
      protected class  | MetalFileChooserUI.FileRenderer
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.
      class  MetalScrollBarUI
      Implementation of ScrollBarUI for the Metal Look and Feel
      class  MetalScrollButton
      JButton object for Metal scrollbar arrows.
      class  MetalTabbedPaneUI
      The Metal subclass of BasicTabbedPaneUI.
      class  MetalToolBarUI
      A Metal Look and Feel implementation of ToolBarUI.

    • Uses of SwingConstants in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement SwingConstants
      修饰符与类型 类与描述
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.

    • Uses of SwingConstants in javax.swing.table

      Classes in javax.swing.table that implement SwingConstants
      修饰符与类型 类与描述
      class  DefaultTableCellRenderer
      The standard class for rendering (displaying) individual cells in a JTable.
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.

    • Uses of SwingConstants in javax.swing.text

      Classes in javax.swing.text that implement SwingConstants
      修饰符与类型 类与描述
      class  AsyncBoxView
      A box that does layout asynchronously.
      class  BoxView
      A view that arranges its children into a box shape by tiling its children along an axis.
      class  ComponentView
      Component decorator that implements the view interface.
      class  CompositeView
      CompositeView is an abstract View implementation which manages one or more child views.
      class  FieldView
      Extends the multi-line plain text view to be suitable for a single-line editor view.
      class  FlowView
      A View that tries to flow it's children into some partially constrained space.
      class  GlyphView
      A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
      class  IconView
      Icon decorator that implements the view interface.
      class  LabelView
      A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      class  PasswordView
      Implements a View suitable for use in JPasswordField UI implementations.
      class  PlainView
      Implements View interface for a simple multi-line text view that has text in one font and color.
      class  TableView
      Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
      class  TableView.TableCell
      Deprecated.
      A table cell can now be any View implementation.
      class  TableView.TableRow
      View of a row in a row-centric table.
      class  View
      A very important part of the text package is the View class.
      class  WrappedPlainView
      View of plain text (text with only one font and color) that does line-wrapping.
      class  ZoneView
      ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.

    • Uses of SwingConstants in javax.swing.text.html

      Classes in javax.swing.text.html that implement SwingConstants
      修饰符与类型 类与描述
      class  BlockView
      A view implementation to display a block (as a box) with CSS specifications.
      class  FormView
      Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
      class  ImageView
      View of an Image, intended to support the HTML <IMG> tag.
      class  InlineView
      Displays the inline element styles based upon css attributes.
      class  ListView
      A view implementation to display an html list
      class  ObjectView
      Component decorator that implements the view interface for <object> elements.

    • Uses of SwingConstants in javax.swing.tree

      Classes in javax.swing.tree that implement SwingConstants
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.UIDefaults.ActiveValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.UIDefaults.ActiveValue

No usage of javax.swing.UIDefaults.ActiveValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tberranhteeeaaccictto


Uses of Interface javax.swing.UIDefaults.LazyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.UIDefaults.LazyValue

  • Packages that use UIDefaults.LazyValue
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of UIDefaults.LazyValue in javax.swing

      Classes in javax.swing that implement UIDefaults.LazyValue
      修饰符与类型 类与描述
      static class  UIDefaults.LazyInputMap
      LazyInputMap will create a InputMap in its createValue method.
      static class  UIDefaults.ProxyLazyValue
      This class provides an implementation of LazyValue which can be used to delay loading of the Class for the instance to be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.DcCsw v&as."ooLn蕂Dnan


Uses of Interface javax.swing.WindowConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.WindowConstants

  • Packages that use WindowConstants
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of WindowConstants in javax.swing

      Classes in javax.swing that implement WindowConstants
      修饰符与类型 类与描述
      class  JDialog
      The main class for creating a dialog window.
      class  JFrame
      An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
      class  JInternalFrame
      A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. no


AbstractColorChooserPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.colorchooser

类 AbstractColorChooserPanel

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPanel
            • javax.swing.colorchooser.AbstractColorChooserPanel
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible

    public abstract class AbstractColorChooserPanel
extends JPanel
    This is the abstract superclass for color choosers. If you want to add a new color chooser panel into a JColorChooser, subclass this class.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JPanel

        JPanel.AccessibleJPanel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractColorChooserPanel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract void buildChooser()
      Builds a new chooser panel.
      protected Color getColorFromModel()
      Returns the color that is currently selected.
      ColorSelectionModel getColorSelectionModel()
      Returns the model that the chooser panel is editing.
      int getDisplayedMnemonicIndex()
      Provides a hint to the look and feel as to the index of the character in getDisplayName that should be visually identified as the mnemonic.
      abstract String getDisplayName()
      Returns a string containing the display name of the panel.
      abstract Icon getLargeDisplayIcon()
      Returns the large display icon for the panel.
      int getMnemonic()
      Provides a hint to the look and feel as to the KeyEvent.VK constant that can be used as a mnemonic to access the panel.
      abstract Icon getSmallDisplayIcon()
      Returns the small display icon for the panel.
      void installChooserPanel(JColorChooser enclosingChooser)
      Invoked when the panel is added to the chooser.
      void paint(Graphics g)
      Draws the panel.
      void uninstallChooserPanel(JColorChooser enclosingChooser)
      Invoked when the panel is removed from the chooser.
      abstract void updateChooser()
      Invoked automatically when the model's state changes.

      • 方法 - 继承于类 javax.swing.JPanel

        getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractColorChooserPanel

        public AbstractColorChooserPanel()

    • 方法详细信息

      • updateChooser

        public abstract void updateChooser()
        Invoked automatically when the model's state changes. It is also called by installChooserPanel to allow you to set up the initial state of your chooser. Override this method to update your ChooserPanel.

      • buildChooser

        protected abstract void buildChooser()
        Builds a new chooser panel.

      • getDisplayName

        public abstract String getDisplayName()
        Returns a string containing the display name of the panel.
        返回：
        the name of the display panel

      • getMnemonic

        public int getMnemonic()
        Provides a hint to the look and feel as to the KeyEvent.VK constant that can be used as a mnemonic to access the panel. A return value <= 0 indicates there is no mnemonic.

        The return value here is a hint, it is ultimately up to the look and feel to honor the return value in some meaningful way.

        This implementation returns 0, indicating the AbstractColorChooserPanel does not support a mnemonic, subclasses wishing a mnemonic will need to override this.

        返回：
        KeyEvent.VK constant identifying the mnemonic; <= 0 for no mnemonic
        从以下版本开始：
        1.4
        另请参见：
        getDisplayedMnemonicIndex()

      • getDisplayedMnemonicIndex

        public int getDisplayedMnemonicIndex()
        Provides a hint to the look and feel as to the index of the character in getDisplayName that should be visually identified as the mnemonic. The look and feel should only use this if getMnemonic returns a value > 0.

        The return value here is a hint, it is ultimately up to the look and feel to honor the return value in some meaningful way. For example, a look and feel may wish to render each AbstractColorChooserPanel in a JTabbedPane, and further use this return value to underline a character in the getDisplayName.

        This implementation returns -1, indicating the AbstractColorChooserPanel does not support a mnemonic, subclasses wishing a mnemonic will need to override this.

        返回：
        Character index to render mnemonic for; -1 to provide no visual identifier for this panel.
        从以下版本开始：
        1.4
        另请参见：
        getMnemonic()

      • getSmallDisplayIcon

        public abstract Icon getSmallDisplayIcon()
        Returns the small display icon for the panel.
        返回：
        the small display icon

      • getLargeDisplayIcon

        public abstract Icon getLargeDisplayIcon()
        Returns the large display icon for the panel.
        返回：
        the large display icon

      • installChooserPanel

        public void installChooserPanel(JColorChooser enclosingChooser)
        Invoked when the panel is added to the chooser. If you override this, be sure to call super.
        参数：
        enclosingChooser - the panel to be added
        抛出：
        RuntimeException - if the chooser panel has already been installed

      • uninstallChooserPanel

        public void uninstallChooserPanel(JColorChooser enclosingChooser)
        Invoked when the panel is removed from the chooser. If override this, be sure to call super.

      • getColorSelectionModel

        public ColorSelectionModel getColorSelectionModel()
        Returns the model that the chooser panel is editing.
        返回：
        the ColorSelectionModel model this panel is editing

      • getColorFromModel

        protected Color getColorFromModel()
        Returns the color that is currently selected.
        返回：
        the Color that is selected

      • paint

        public void paint(Graphics g)
        Draws the panel.
        重载：
        paint in class JComponent
        参数：
        g - the Graphics object
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ColorChooserComponentFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.colorchooser

类 ColorChooserComponentFactory

  • java.lang.Object
    • javax.swing.colorchooser.ColorChooserComponentFactory

  • public class ColorChooserComponentFactory
extends Object
    A class designed to produce preconfigured "accessory" objects to insert into color choosers.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static AbstractColorChooserPanel[] | getDefaultChooserPanels()
      static JComponent | getPreviewPanel()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getDefaultChooserPanels

        public static AbstractColorChooserPanel[] getDefaultChooserPanels()

      • getPreviewPanel

        public static JComponent getPreviewPanel()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sw"treOveOebegee/w....>=rr./i/// "


ColorSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.colorchooser

Interface ColorSelectionModel

  • All Known Implementing Classes:
    DefaultColorSelectionModel

    public interface ColorSelectionModel
    A model that supports selecting a Color.
    另请参见：
    Color

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener listener)
      Adds listener as a listener to changes in the model.
      Color getSelectedColor()
      Returns the selected Color which should be non-null.
      void removeChangeListener(ChangeListener listener)
      Removes listener as a listener to changes in the model.
      void setSelectedColor(Color color)
      Sets the selected color to color.

    • 方法详细信息

      • getSelectedColor

        Color getSelectedColor()
        Returns the selected Color which should be non-null.
        返回：
        the selected Color
        另请参见：
        setSelectedColor(java.awt.Color)

      • setSelectedColor

        void setSelectedColor(Color color)
        Sets the selected color to color. Note that setting the color to null is undefined and may have unpredictable results. This method fires a state changed event if it sets the current color to a new non-null color.
        参数：
        color - the new Color
        另请参见：
        getSelectedColor(), addChangeListener(javax.swing.event.ChangeListener)

      • addChangeListener

        void addChangeListener(ChangeListener listener)
        Adds listener as a listener to changes in the model.
        参数：
        listener - the ChangeListener to be added

      • removeChangeListener

        void removeChangeListener(ChangeListener listener)
        Removes listener as a listener to changes in the model.
        参数：
        listener - the ChangeListener to be removed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

so�.=parei cg蝬erf糓=/ o <祊=b"


DefaultColorSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.colorchooser

类 DefaultColorSelectionModel

  • java.lang.Object
    • javax.swing.colorchooser.DefaultColorSelectionModel
  • 所有已实现的接口：
    Serializable, ColorSelectionModel

    public class DefaultColorSelectionModel
extends Object
implements ColorSelectionModel, Serializable
    A generic implementation of ColorSelectionModel.
    另请参见：
    Color

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
      protected EventListenerList | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultColorSelectionModel()
      Creates a DefaultColorSelectionModel with the current color set to Color.white.
      DefaultColorSelectionModel(Color color)
      Creates a DefaultColorSelectionModel with the current color set to color, which should be non-null.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      protected void fireStateChanged()
      Runs each ChangeListener's stateChanged method.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this DefaultColorSelectionModel with addChangeListener.
      Color getSelectedColor()
      Returns the selected Color which should be non-null.
      void removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void setSelectedColor(Color color)
      Sets the selected color to color.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property. The source of events generated here is always "this".

      • listenerList

        protected EventListenerList listenerList

    • 构造方法详细信息

      • DefaultColorSelectionModel

        public DefaultColorSelectionModel()
        Creates a DefaultColorSelectionModel with the current color set to Color.white. This is the default constructor.

      • DefaultColorSelectionModel

        public DefaultColorSelectionModel(Color color)
        Creates a DefaultColorSelectionModel with the current color set to color, which should be non-null. Note that setting the color to null is undefined and may have unpredictable results.
        参数：
        color - the new Color

    • 方法详细信息

      • getSelectedColor

        public Color getSelectedColor()
        Returns the selected Color which should be non-null.
        指定者：
        getSelectedColor in interface ColorSelectionModel
        返回：
        the selected Color
        另请参见：
        ColorSelectionModel.setSelectedColor(java.awt.Color)

      • setSelectedColor

        public void setSelectedColor(Color color)
        Sets the selected color to color. Note that setting the color to null is undefined and may have unpredictable results. This method fires a state changed event if it sets the current color to a new non-null color; if the new color is the same as the current color, no event is fired.
        指定者：
        setSelectedColor in interface ColorSelectionModel
        参数：
        color - the new Color
        另请参见：
        ColorSelectionModel.getSelectedColor(), ColorSelectionModel.addChangeListener(javax.swing.event.ChangeListener)

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a ChangeListener to the model.
        指定者：
        addChangeListener in interface ColorSelectionModel
        参数：
        l - the ChangeListener to be added

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a ChangeListener from the model.
        指定者：
        removeChangeListener in interface ColorSelectionModel
        参数：
        l - the ChangeListener to be removed

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this DefaultColorSelectionModel with addChangeListener.
        返回：
        all of the ChangeListeners added, or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Runs each ChangeListener's stateChanged method.
        另请参见：
        EventListenerList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&=ec<t/arn


javax.swing.colorchooser

Interfaces

  • ColorSelectionModel

Classes

  • AbstractColorChooserPanel
  • ColorChooserComponentFactory
  • DefaultColorSelectionModel
i


javax.swing.colorchooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.colorchooser

Contains classes and interfaces used by the JColorChooser component.

请参见： 描述

  • 接口摘要
    接口 描述
    ColorSelectionModel
    A model that supports selecting a Color.
  • Class Summary
    类 描述
    AbstractColorChooserPanel
    This is the abstract superclass for color choosers.
    ColorChooserComponentFactory
    A class designed to produce preconfigured "accessory" objects to insert into color choosers.
    DefaultColorSelectionModel
    A generic implementation of ColorSelectionModel.

软件包 javax.swing.colorchooser Description

Contains classes and interfaces used by the JColorChooser component.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

This document forms the complete API specification. For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use Color Choosers, a section in The Java Tutorial
  • Internationalization Documentation
  • Input Method Framework Documentation
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

svtd)dC)r"dd)Leenjig


javax.swing.colorchooser Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.colorchooser

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.colorchooser.ColorChooserComponentFactory
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.colorchooser.AbstractColorChooserPanel
    • javax.swing.colorchooser.DefaultColorSelectionModel (implements javax.swing.colorchooser.ColorSelectionModel, java.io.Serializable)

Interface Hierarchy

  • javax.swing.colorchooser.ColorSelectionModel
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k>.saslCseis wwl-ggd


Uses of Package javax.swing.colorchooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.colorchooser

  • Packages that use javax.swing.colorchooser
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
  • Classes in javax.swing.colorchooser used by javax.swing
    类与描述
    AbstractColorChooserPanel
    This is the abstract superclass for color choosers.
    ColorSelectionModel
    A model that supports selecting a Color.
  • Classes in javax.swing.colorchooser used by javax.swing.colorchooser
    类与描述
    AbstractColorChooserPanel
    This is the abstract superclass for color choosers.
    ColorSelectionModel
    A model that supports selecting a Color.
  • Classes in javax.swing.colorchooser used by javax.swing.plaf.basic
    类与描述
    AbstractColorChooserPanel
    This is the abstract superclass for color choosers.
  • Classes in javax.swing.colorchooser used by javax.swing.plaf.synth
    类与描述
    AbstractColorChooserPanel
    This is the abstract superclass for color choosers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>s/oe<>loo


Uses of Class javax.swing.colorchooser.AbstractColorChooserPanel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.colorchooser.AbstractColorChooserPanel

  • Packages that use AbstractColorChooserPanel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of AbstractColorChooserPanel in javax.swing

      Methods in javax.swing that return AbstractColorChooserPanel
      修饰符与类型 方法与描述
      AbstractColorChooserPanel[] JColorChooser.getChooserPanels()
      Returns the specified color panels.
      AbstractColorChooserPanel JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel)
      Removes the Color Panel specified.
      Methods in javax.swing with parameters of type AbstractColorChooserPanel
      修饰符与类型 方法与描述
      void JColorChooser.addChooserPanel(AbstractColorChooserPanel panel)
      Adds a color chooser panel to the color chooser.
      AbstractColorChooserPanel JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel)
      Removes the Color Panel specified.
      void JColorChooser.setChooserPanels(AbstractColorChooserPanel[] panels)
      Specifies the Color Panels used to choose a color value.

    • Uses of AbstractColorChooserPanel in javax.swing.colorchooser

      Methods in javax.swing.colorchooser that return AbstractColorChooserPanel
      修饰符与类型 | 方法与描述
      static AbstractColorChooserPanel[] | ColorChooserComponentFactory.getDefaultChooserPanels()

    • Uses of AbstractColorChooserPanel in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as AbstractColorChooserPanel
      修饰符与类型 | 字段与描述
      protected AbstractColorChooserPanel[] | BasicColorChooserUI.defaultChoosers
      Methods in javax.swing.plaf.basic that return AbstractColorChooserPanel
      修饰符与类型 | 方法与描述
      protected AbstractColorChooserPanel[] | BasicColorChooserUI.createDefaultChoosers()

    • Uses of AbstractColorChooserPanel in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return AbstractColorChooserPanel
      修饰符与类型 | 方法与描述
      protected AbstractColorChooserPanel[] | SynthColorChooserUI.createDefaultChoosers()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oelpnipcI /sx


Uses of Class javax.swing.colorchooser.ColorChooserComponentFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.colorchooser.ColorChooserComponentFactory

No usage of javax.swing.colorchooser.ColorChooserComponentFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.t/hde>>"<<


Uses of Class javax.swing.colorchooser.DefaultColorSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.colorchooser.DefaultColorSelectionModel

No usage of javax.swing.colorchooser.DefaultColorSelectionModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ejt tabU"sssr0ee>d>/l


Uses of Interface javax.swing.colorchooser.ColorSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.colorchooser.ColorSelectionModel

  • Packages that use ColorSelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.

    • Uses of ColorSelectionModel in javax.swing

      Methods in javax.swing that return ColorSelectionModel
      修饰符与类型 方法与描述
      ColorSelectionModel JColorChooser.getSelectionModel()
      Returns the data model that handles color selections.
      Methods in javax.swing with parameters of type ColorSelectionModel
      修饰符与类型 方法与描述
      void JColorChooser.setSelectionModel(ColorSelectionModel newModel)
      Sets the model containing the selected color.
      Constructors in javax.swing with parameters of type ColorSelectionModel
      构造方法与描述
      JColorChooser(ColorSelectionModel model)
      Creates a color chooser pane with the specified ColorSelectionModel.

    • Uses of ColorSelectionModel in javax.swing.colorchooser

      Classes in javax.swing.colorchooser that implement ColorSelectionModel
      修饰符与类型 类与描述
      class  DefaultColorSelectionModel
      A generic implementation of ColorSelectionModel.
      Methods in javax.swing.colorchooser that return ColorSelectionModel
      修饰符与类型 方法与描述
      ColorSelectionModel AbstractColorChooserPanel.getColorSelectionModel()
      Returns the model that the chooser panel is editing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eLc>a


AncestorEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 AncestorEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • javax.swing.event.AncestorEvent
  • 所有已实现的接口：
    Serializable

    public class AncestorEvent
extends AWTEvent
    An event reported to a child component that originated from an ancestor in the component hierarchy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ANCESTOR_ADDED
      An ancestor-component was added to the hierarchy of visible objects (made visible), and is currently being displayed.
      static int ANCESTOR_MOVED
      An ancestor-component changed its position on the screen.
      static int ANCESTOR_REMOVED
      An ancestor-component was removed from the hierarchy of visible objects (hidden) and is no longer being displayed.

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
      Constructs an AncestorEvent object to identify a change in an ancestor-component's display-status.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Container getAncestor()
      Returns the ancestor that the event actually occurred on.
      Container getAncestorParent()
      Returns the parent of the ancestor the event actually occurred on.
      JComponent getComponent()
      Returns the component that the listener was added to.

      • 方法 - 继承于类 java.awt.AWTEvent

        consume, getID, isConsumed, paramString, setSource, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ANCESTOR_ADDED

        public static final int ANCESTOR_ADDED
        An ancestor-component was added to the hierarchy of visible objects (made visible), and is currently being displayed.
        另请参见：
        Constant Field Values

      • ANCESTOR_REMOVED

        public static final int ANCESTOR_REMOVED
        An ancestor-component was removed from the hierarchy of visible objects (hidden) and is no longer being displayed.
        另请参见：
        Constant Field Values

      • ANCESTOR_MOVED

        public static final int ANCESTOR_MOVED
        An ancestor-component changed its position on the screen.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AncestorEvent

        public AncestorEvent(JComponent source,
             int id,
             Container ancestor,
             Container ancestorParent)
        Constructs an AncestorEvent object to identify a change in an ancestor-component's display-status.
        参数：
        source - the JComponent that originated the event (typically this)
        id - an int specifying ANCESTOR_ADDED, ANCESTOR_REMOVED or ANCESTOR_MOVED
        ancestor - a Container object specifying the ancestor-component whose display-status changed
        ancestorParent - a Container object specifying the ancestor's parent

    • 方法详细信息

      • getAncestor

        public Container getAncestor()
        Returns the ancestor that the event actually occurred on.

      • getAncestorParent

        public Container getAncestorParent()
        Returns the parent of the ancestor the event actually occurred on. This is most interesting in an ANCESTOR_REMOVED event, as the ancestor may no longer be in the component hierarchy.

      • getComponent

        public JComponent getComponent()
        Returns the component that the listener was added to.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oilnidFsl>s= s e


AncestorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface AncestorListener

  • All Superinterfaces:
    EventListener

    public interface AncestorListener
extends EventListener
    AncestorListener Interface to support notification when changes occur to a JComponent or one of its ancestors. These include movement and when the component becomes visible or invisible, either by the setVisible() method or by being added or removed from the component hierarchy.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void ancestorAdded(AncestorEvent event)
      Called when the source or one of its ancestors is made visible either by setVisible(true) being called or by its being added to the component hierarchy.
      void ancestorMoved(AncestorEvent event)
      Called when either the source or one of its ancestors is moved.
      void ancestorRemoved(AncestorEvent event)
      Called when the source or one of its ancestors is made invisible either by setVisible(false) being called or by its being remove from the component hierarchy.

    • 方法详细信息

      • ancestorAdded

        void ancestorAdded(AncestorEvent event)
        Called when the source or one of its ancestors is made visible either by setVisible(true) being called or by its being added to the component hierarchy. The method is only called if the source has actually become visible. For this to be true all its parents must be visible and it must be in a hierarchy rooted at a Window

      • ancestorRemoved

        void ancestorRemoved(AncestorEvent event)
        Called when the source or one of its ancestors is made invisible either by setVisible(false) being called or by its being remove from the component hierarchy. The method is only called if the source has actually become invisible. For this to be true at least one of its parents must by invisible or it is not in a hierarchy rooted at a Window

      • ancestorMoved

        void ancestorMoved(AncestorEvent event)
        Called when either the source or one of its ancestors is moved.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/itvn


CaretEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 CaretEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.CaretEvent
  • 所有已实现的接口：
    Serializable

    public abstract class CaretEvent
extends EventObject
    CaretEvent is used to notify interested parties that the text caret has changed in the event source.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      CaretEvent(Object source)
      Creates a new CaretEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int getDot()
      Fetches the location of the caret.
      abstract int getMark()
      Fetches the location of other end of a logical selection.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CaretEvent

        public CaretEvent(Object source)
        Creates a new CaretEvent object.
        参数：
        source - the object responsible for the event

    • 方法详细信息

      • getDot

        public abstract int getDot()
        Fetches the location of the caret.
        返回：
        the dot >= 0

      • getMark

        public abstract int getMark()
        Fetches the location of other end of a logical selection. If there is no selection, this will be the same as dot.
        返回：
        the mark >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/asge"hik/>ahh lfatiina衋


CaretListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface CaretListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField

    public interface CaretListener
extends EventListener
    Listener for changes in the caret position of a text component.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void caretUpdate(CaretEvent e)
      Called when the caret position is updated.

    • 方法详细信息

      • caretUpdate

        void caretUpdate(CaretEvent e)
        Called when the caret position is updated.
        参数：
        e - the caret event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

od>3MM>33a tt==D==all st�


CellEditorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface CellEditorListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicTreeUI.CellEditorHandler, JTable, JTable.AccessibleJTable

    public interface CellEditorListener
extends EventListener
    CellEditorListener defines the interface for an object that listens to changes in a CellEditor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void editingCanceled(ChangeEvent e)
      This tells the listeners the editor has canceled editing
      void editingStopped(ChangeEvent e)
      This tells the listeners the editor has ended editing

    • 方法详细信息

      • editingStopped

        void editingStopped(ChangeEvent e)
        This tells the listeners the editor has ended editing

      • editingCanceled

        void editingCanceled(ChangeEvent e)
        This tells the listeners the editor has canceled editing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toR=orn"orrsp>>gpsbnd ci>


ChangeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.event

类 ChangeEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.ChangeEvent
  • 所有已实现的接口：
    Serializable

    public class ChangeEvent
extends EventObject
    ChangeEvent is used to notify interested parties that state has changed in the event source.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      ChangeEvent(Object source)
      Constructs a ChangeEvent object.

    • 方法摘要

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ChangeEvent

        public ChangeEvent(Object source)
        Constructs a ChangeEvent object.
        参数：
        source - the Object that is the source of the event (typically this)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

."rr>fef>/.>el""isaeat" >a=g蟙


ChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface ChangeListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    AbstractButton.ButtonChangeListener, BasicButtonListener, BasicMenuUI.ChangeHandler, BasicProgressBarUI.ChangeHandler, BasicScrollBarUI.ModelListener, BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener, BasicSliderUI.ChangeHandler, BasicTabbedPaneUI.TabSelectionHandler, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JMenu.AccessibleJMenu, JMenuItem.AccessibleJMenuItem, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JScrollPane.AccessibleJScrollPane, JSpinner.AccessibleJSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JTabbedPane.AccessibleJTabbedPane, JTabbedPane.ModelListener, ProgressMonitor.AccessibleProgressMonitor

    public interface ChangeListener
extends EventListener
    Defines an object which listens for ChangeEvents.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

    • 方法详细信息

      • stateChanged

        void stateChanged(ChangeEvent e)
        Invoked when the target of the listener has changed its state.
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/vinat lasd>ahh toio>.ahe


DocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface DocumentEvent

  • All Known Implementing Classes:
    AbstractDocument.DefaultDocumentEvent

    public interface DocumentEvent
    Interface for document change notifications. This provides detailed information to Document observers about how the Document changed. It provides high level information such as type of change and where it occurred, as well as the more detailed structural changes (What Elements were inserted and removed).
    另请参见：
    Document, DocumentListener

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static interface  DocumentEvent.ElementChange
      Describes changes made to a specific element.
      static class  DocumentEvent.EventType
      Enumeration for document event types

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DocumentEvent.ElementChange getChange(Element elem)
      Gets the change information for the given element.
      Document getDocument()
      Gets the document that sourced the change event.
      int getLength()
      Returns the length of the change.
      int getOffset()
      Returns the offset within the document of the start of the change.
      DocumentEvent.EventType getType()
      Gets the type of event.

    • 方法详细信息

      • getOffset

        int getOffset()
        Returns the offset within the document of the start of the change.
        返回：
        the offset >= 0

      • getLength

        int getLength()
        Returns the length of the change.
        返回：
        the length >= 0

      • getDocument

        Document getDocument()
        Gets the document that sourced the change event.
        返回：
        the document

      • getType

        DocumentEvent.EventType getType()
        Gets the type of event.
        返回：
        the type

      • getChange

        DocumentEvent.ElementChange getChange(Element elem)
        Gets the change information for the given element. The change information describes what elements were added and removed and the location. If there were no changes, null is returned.

        This method is for observers to discover the structural changes that were made. This means that only elements that existed prior to the mutation (and still exist after the mutatino) need to have ElementChange records. The changes made available need not be recursive.

        For example, if the an element is removed from it's parent, this method should report that the parent changed and provide an ElementChange implementation that describes the change to the parent. If the child element removed had children, these elements do not need to be reported as removed.

        If an child element is insert into a parent element, the parent element should report a change. If the child element also had elements inserted into it (grandchildren to the parent) these elements need not report change.

        参数：
        elem - the element
        返回：
        the change information, or null if the element was not modified
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

coe>cesbhnrvmp


DocumentEvent.ElementChange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface DocumentEvent.ElementChange

  • All Known Implementing Classes:
    AbstractDocument.ElementEdit
    Enclosing interface:
    DocumentEvent

    public static interface DocumentEvent.ElementChange
    Describes changes made to a specific element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Element[] getChildrenAdded()
      Gets the child elements that were added to the given parent element.
      Element[] getChildrenRemoved()
      Gets the child elements that were removed from the given parent element.
      Element getElement()
      Returns the element represented.
      int getIndex()
      Fetches the index within the element represented.

    • 方法详细信息

      • getElement

        Element getElement()
        Returns the element represented. This is the element that was changed.
        返回：
        the element

      • getIndex

        int getIndex()
        Fetches the index within the element represented. This is the location that children were added and/or removed.
        返回：
        the index >= 0

      • getChildrenRemoved

        Element[] getChildrenRemoved()
        Gets the child elements that were removed from the given parent element. The element array returned is sorted in the order that the elements used to lie in the document, and must be contiguous.
        返回：
        the child elements

      • getChildrenAdded

        Element[] getChildrenAdded()
        Gets the child elements that were added to the given parent element. The element array returned is in the order that the elements lie in the document, and must be contiguous.
        返回：
        the child elements
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oonedeteiemttiocamn膇./exhmg."l�


DocumentEvent.EventType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

类 DocumentEvent.EventType

  • java.lang.Object
    • javax.swing.event.DocumentEvent.EventType
  • Enclosing interface:
    DocumentEvent

    public static final class DocumentEvent.EventType
extends Object
    Enumeration for document event types

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static DocumentEvent.EventType CHANGE
      Change type.
      static DocumentEvent.EventType INSERT
      Insert type.
      static DocumentEvent.EventType REMOVE
      Remove type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Converts the type to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSERT

        public static final DocumentEvent.EventType INSERT
        Insert type.

      • REMOVE

        public static final DocumentEvent.EventType REMOVE
        Remove type.

      • CHANGE

        public static final DocumentEvent.EventType CHANGE
        Change type.

    • 方法详细信息

      • toString

        public String toString()
        Converts the type to a string.
        重载：
        toString in class Object
        返回：
        the string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tl cer/oea/cr sm rr1-e 3ef<>kpt/ro>p�


DocumentListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface DocumentListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField

    public interface DocumentListener
extends EventListener
    Interface for an observer to register to receive notifications of changes to a text document.

    The default implementation of the Document interface (AbstractDocument) supports asynchronous mutations. If this feature is used (i.e. mutations are made from a thread other than the Swing event thread), the listeners will be notified via the mutating thread. This means that if asynchronous updates are made, the implementation of this interface must be threadsafe!

    The DocumentEvent notification is based upon the JavaBeans event model. There is no guarantee about the order of delivery to listeners, and all listeners must be notified prior to making further mutations to the Document. This means implementations of the DocumentListener may not mutate the source of the event (i.e. the associated Document).

    另请参见：
    Document, StyledDocument, DocumentEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void changedUpdate(DocumentEvent e)
      Gives notification that an attribute or set of attributes changed.
      void insertUpdate(DocumentEvent e)
      Gives notification that there was an insert into the document.
      void removeUpdate(DocumentEvent e)
      Gives notification that a portion of the document has been removed.

    • 方法详细信息

      • insertUpdate

        void insertUpdate(DocumentEvent e)
        Gives notification that there was an insert into the document. The range given by the DocumentEvent bounds the freshly inserted region.
        参数：
        e - the document event

      • removeUpdate

        void removeUpdate(DocumentEvent e)
        Gives notification that a portion of the document has been removed. The range is given in terms of what the view last saw (that is, before updating sticky positions).
        参数：
        e - the document event

      • changedUpdate

        void changedUpdate(DocumentEvent e)
        Gives notification that an attribute or set of attributes changed.
        参数：
        e - the document event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"too"> i"rllnhm.en"t"lrai


EventListenerList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 EventListenerList

  • java.lang.Object
    • javax.swing.event.EventListenerList
  • 所有已实现的接口：
    Serializable

    public class EventListenerList
extends Object
implements Serializable
    A class that holds a list of EventListeners. A single instance can be used to hold all listeners (of all types) for the instance using the list. It is the responsiblity of the class using the EventListenerList to provide type-safe API (preferably conforming to the JavaBeans spec) and methods which dispatch event notification methods to appropriate Event Listeners on the list. The main benefits that this class provides are that it is relatively cheap in the case of no listeners, and it provides serialization for event-listener lists in a single place, as well as a degree of MT safety (when used correctly). Usage example: Say one is defining a class that sends out FooEvents, and one wants to allow users of the class to register FooListeners and receive notification when FooEvents occur. The following should be added to the class definition:
     EventListenerList listenerList = new EventListenerList();
 FooEvent fooEvent = null;

 public void addFooListener(FooListener l) {
     listenerList.add(FooListener.class, l);
 }

 public void removeFooListener(FooListener l) {
     listenerList.remove(FooListener.class, l);
 }

 // Notify all listeners that have registered interest for
 // notification on this event type.  The event instance
 // is lazily created using the parameters passed into
 // the fire method.

 protected void fireFooXXX() {
     // Guaranteed to return a non-null array
     Object[] listeners = listenerList.getListenerList();
     // Process the listeners last to first, notifying
     // those that are interested in this event
     for (int i = listeners.length-2; i>=0; i-=2) {
         if (listeners[i]==FooListener.class) {
             // Lazily create the event:
             if (fooEvent == null)
                 fooEvent = new FooEvent(this);
             ((FooListener)listeners[i+1]).fooXXX(fooEvent);
         }
     }
 }
    foo should be changed to the appropriate name, and fireFooXxx to the appropriate method name. One fire method should exist for each notification method in the FooListener interface.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Object[] | listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      EventListenerList()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <T extends EventListener>
      void             		add(类<T> t, T l)
      Adds the listener as a listener of the specified type.
      int getListenerCount()
      Returns the total number of listeners for this listener list.
      int getListenerCount(类<?> t)
      Returns the total number of listeners of the supplied type for this listener list.
      Object[] getListenerList()
      Passes back the event listener list as an array of ListenerType-listener pairs.
      <T extends EventListener>
      T[]             		getListeners(类<T> t)
      Return an array of all the listeners of the given type.
      <T extends EventListener>
      void             		remove(类<T> t, T l)
      Removes the listener as a listener of the specified type.
      String toString()
      Returns a string representation of the EventListenerList.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected transient Object[] listenerList

    • 构造方法详细信息

      • EventListenerList

        public EventListenerList()

    • 方法详细信息

      • getListenerList

        public Object[] getListenerList()
        Passes back the event listener list as an array of ListenerType-listener pairs. Note that for performance reasons, this implementation passes back the actual data structure in which the listener data is stored internally! This method is guaranteed to pass back a non-null array, so that no null-checking is required in fire methods. A zero-length array of Object should be returned if there are currently no listeners. WARNING!!! Absolutely NO modification of the data contained in this array should be made -- if any such manipulation is necessary, it should be done on a copy of the array returned rather than the array itself.

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> t)
        Return an array of all the listeners of the given type.
        返回：
        all of the listeners of the specified type.
        抛出：
        ClassCastException - if the supplied class is not assignable to EventListener
        从以下版本开始：
        1.3

      • getListenerCount

        public int getListenerCount()
        Returns the total number of listeners for this listener list.

      • getListenerCount

        public int getListenerCount(类<?> t)
        Returns the total number of listeners of the supplied type for this listener list.

      • add

        public <T extends EventListener> void add(类<T> t,
                                 T l)
        Adds the listener as a listener of the specified type.
        参数：
        t - the type of the listener to be added
        l - the listener to be added

      • remove

        public <T extends EventListener> void remove(类<T> t,
                                    T l)
        Removes the listener as a listener of the specified type.
        参数：
        t - the type of the listener to be removed
        l - the listener to be removed

      • toString

        public String toString()
        Returns a string representation of the EventListenerList.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-hb./ssib,i-olnth=E�/p.w>i/:er>ta"蝍odb>Ml.p


HyperlinkEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 HyperlinkEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.HyperlinkEvent
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    HTMLFrameHyperlinkEvent

    public class HyperlinkEvent
extends EventObject
    HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  HyperlinkEvent.EventType
      Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)
      Creates a new object representing a hypertext link event.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDescription()
      Get the description of the link as a string.
      HyperlinkEvent.EventType getEventType()
      Gets the type of event.
      InputEvent getInputEvent()
      Returns the InputEvent that triggered the hyperlink event.
      Element getSourceElement()
      Returns the Element that corresponds to the source of the event.
      URL getURL()
      Gets the URL that the link refers to.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HyperlinkEvent

        public HyperlinkEvent(Object source,
              HyperlinkEvent.EventType type,
              URL u)
        Creates a new object representing a hypertext link event. The other constructor is preferred, as it provides more information if a URL could not be formed. This constructor is primarily for backward compatibility.
        参数：
        source - the object responsible for the event
        type - the event type
        u - the affected URL

      • HyperlinkEvent

        public HyperlinkEvent(Object source,
              HyperlinkEvent.EventType type,
              URL u,
              String desc)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        u - the affected URL. This may be null if a valid URL could not be created.
        desc - the description of the link. This may be useful when attempting to form a URL resulted in a MalformedURLException. The description provides the text used when attempting to form the URL.

      • HyperlinkEvent

        public HyperlinkEvent(Object source,
              HyperlinkEvent.EventType type,
              URL u,
              String desc,
              Element sourceElement)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        u - the affected URL. This may be null if a valid URL could not be created.
        desc - the description of the link. This may be useful when attempting to form a URL resulted in a MalformedURLException. The description provides the text used when attempting to form the URL.
        sourceElement - Element in the Document representing the anchor
        从以下版本开始：
        1.4

      • HyperlinkEvent

        public HyperlinkEvent(Object source,
              HyperlinkEvent.EventType type,
              URL u,
              String desc,
              Element sourceElement,
              InputEvent inputEvent)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        u - the affected URL. This may be null if a valid URL could not be created.
        desc - the description of the link. This may be useful when attempting to form a URL resulted in a MalformedURLException. The description provides the text used when attempting to form the URL.
        sourceElement - Element in the Document representing the anchor
        inputEvent - InputEvent that triggered the hyperlink event
        从以下版本开始：
        1.7

    • 方法详细信息

      • getEventType

        public HyperlinkEvent.EventType getEventType()
        Gets the type of event.
        返回：
        the type

      • getDescription

        public String getDescription()
        Get the description of the link as a string. This may be useful if a URL can't be formed from the description, in which case the associated URL would be null.

      • getURL

        public URL getURL()
        Gets the URL that the link refers to.
        返回：
        the URL

      • getSourceElement

        public Element getSourceElement()
        Returns the Element that corresponds to the source of the event. This will typically be an Element representing an anchor. If a constructur that is used that does not specify a source Element, or null was specified as the source Element, this will return null.
        返回：
        Element indicating source of event, or null
        从以下版本开始：
        1.4

      • getInputEvent

        public InputEvent getInputEvent()
        Returns the InputEvent that triggered the hyperlink event. This will typically be a MouseEvent. If a constructor is used that does not specify an InputEvent, or @{code null} was specified as the InputEvent, this returns null.
        返回：
        InputEvent that triggered the hyperlink event, or null
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a a=/ds;=sl�)goa"lnedb.st/rvj w=vm== aa�.a�


HyperlinkEvent.EventType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

类 HyperlinkEvent.EventType

  • java.lang.Object
    • javax.swing.event.HyperlinkEvent.EventType
  • 封闭类：
    HyperlinkEvent

    public static final class HyperlinkEvent.EventType
extends Object
    Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static HyperlinkEvent.EventType ACTIVATED
      Activated type.
      static HyperlinkEvent.EventType ENTERED
      Entered type.
      static HyperlinkEvent.EventType EXITED
      Exited type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Converts the type to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ENTERED

        public static final HyperlinkEvent.EventType ENTERED
        Entered type.

      • EXITED

        public static final HyperlinkEvent.EventType EXITED
        Exited type.

      • ACTIVATED

        public static final HyperlinkEvent.EventType ACTIVATED
        Activated type.

    • 方法详细信息

      • toString

        public String toString()
        Converts the type to a string.
        重载：
        toString in class Object
        返回：
        the string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcittlcmlcettceegjff ,/><<"/.c#ObbOlba.


HyperlinkListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface HyperlinkListener

  • All Superinterfaces:
    EventListener

    public interface HyperlinkListener
extends EventListener
    HyperlinkListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void hyperlinkUpdate(HyperlinkEvent e)
      Called when a hypertext link is updated.

    • 方法详细信息

      • hyperlinkUpdate

        void hyperlinkUpdate(HyperlinkEvent e)
        Called when a hypertext link is updated.
        参数：
        e - the event responsible for the update
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v s/>Ua>U>RRU>>. ttnnkvt fa .


InternalFrameAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 InternalFrameAdapter

  • java.lang.Object
    • javax.swing.event.InternalFrameAdapter
  • 所有已实现的接口：
    EventListener, InternalFrameListener

    public abstract class InternalFrameAdapter
extends Object
implements InternalFrameListener
    An abstract adapter class for receiving internal frame events. The methods in this class are empty. This class exists as convenience for creating listener objects, and is functionally equivalent to the WindowAdapter class in the AWT.

    See How to Write an Internal Frame Listener in The Java Tutorial

    另请参见：
    InternalFrameEvent, InternalFrameListener, WindowListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      InternalFrameAdapter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void internalFrameActivated(InternalFrameEvent e)
      Invoked when an internal frame is activated.
      void internalFrameClosed(InternalFrameEvent e)
      Invoked when an internal frame has been closed.
      void internalFrameClosing(InternalFrameEvent e)
      Invoked when an internal frame is in the process of being closed.
      void internalFrameDeactivated(InternalFrameEvent e)
      Invoked when an internal frame is de-activated.
      void internalFrameDeiconified(InternalFrameEvent e)
      Invoked when an internal frame is de-iconified.
      void internalFrameIconified(InternalFrameEvent e)
      Invoked when an internal frame is iconified.
      void internalFrameOpened(InternalFrameEvent e)
      Invoked when an internal frame has been opened.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InternalFrameAdapter

        public InternalFrameAdapter()

    • 方法详细信息

      • internalFrameOpened

        public void internalFrameOpened(InternalFrameEvent e)
        Invoked when an internal frame has been opened.
        指定者：
        internalFrameOpened in interface InternalFrameListener
        另请参见：
        JInternalFrame.show()

      • internalFrameClosing

        public void internalFrameClosing(InternalFrameEvent e)
        Invoked when an internal frame is in the process of being closed. The close operation can be overridden at this point.
        指定者：
        internalFrameClosing in interface InternalFrameListener
        另请参见：
        JInternalFrame.setDefaultCloseOperation(int)

      • internalFrameClosed

        public void internalFrameClosed(InternalFrameEvent e)
        Invoked when an internal frame has been closed.
        指定者：
        internalFrameClosed in interface InternalFrameListener
        另请参见：
        JInternalFrame.setClosed(boolean)

      • internalFrameIconified

        public void internalFrameIconified(InternalFrameEvent e)
        Invoked when an internal frame is iconified.
        指定者：
        internalFrameIconified in interface InternalFrameListener
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameDeiconified

        public void internalFrameDeiconified(InternalFrameEvent e)
        Invoked when an internal frame is de-iconified.
        指定者：
        internalFrameDeiconified in interface InternalFrameListener
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameActivated

        public void internalFrameActivated(InternalFrameEvent e)
        Invoked when an internal frame is activated.
        指定者：
        internalFrameActivated in interface InternalFrameListener
        另请参见：
        JInternalFrame.setSelected(boolean)

      • internalFrameDeactivated

        public void internalFrameDeactivated(InternalFrameEvent e)
        Invoked when an internal frame is de-activated.
        指定者：
        internalFrameDeactivated in interface InternalFrameListener
        另请参见：
        JInternalFrame.setSelected(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tetenhehtahtt GaatlUtLL lR/p;<


InternalFrameEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 InternalFrameEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • javax.swing.event.InternalFrameEvent
  • 所有已实现的接口：
    Serializable

    public class InternalFrameEvent
extends AWTEvent
    An AWTEvent that adds support for JInternalFrame objects as the event source. This class has the same event types as WindowEvent, although different IDs are used. Help on handling internal frame events is in How to Write an Internal Frame Listener, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    WindowEvent, WindowListener, JInternalFrame, InternalFrameListener

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int INTERNAL_FRAME_ACTIVATED
      The "window activated" event type.
      static int INTERNAL_FRAME_CLOSED
      The "window closed" event.
      static int INTERNAL_FRAME_CLOSING
      The "window is closing" event.
      static int INTERNAL_FRAME_DEACTIVATED
      The "window deactivated" event type.
      static int INTERNAL_FRAME_DEICONIFIED
      The "window deiconified" event type.
      static int INTERNAL_FRAME_FIRST
      The first number in the range of IDs used for internal frame events.
      static int INTERNAL_FRAME_ICONIFIED
      The "window iconified" event.
      static int INTERNAL_FRAME_LAST
      The last number in the range of IDs used for internal frame events.
      static int INTERNAL_FRAME_OPENED
      The "window opened" event.

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      InternalFrameEvent(JInternalFrame source, int id)
      Constructs an InternalFrameEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JInternalFrame getInternalFrame()
      Returns the originator of the event.
      String paramString()
      Returns a parameter string identifying this event.

      • 方法 - 继承于类 java.awt.AWTEvent

        consume, getID, isConsumed, setSource, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INTERNAL_FRAME_FIRST

        public static final int INTERNAL_FRAME_FIRST
        The first number in the range of IDs used for internal frame events.
        另请参见：
        Constant Field Values

      • INTERNAL_FRAME_LAST

        public static final int INTERNAL_FRAME_LAST
        The last number in the range of IDs used for internal frame events.
        另请参见：
        Constant Field Values

      • INTERNAL_FRAME_OPENED

        public static final int INTERNAL_FRAME_OPENED
        The "window opened" event. This event is delivered only the first time the internal frame is made visible.
        另请参见：
        JInternalFrame.show(), Constant Field Values

      • INTERNAL_FRAME_CLOSING

        public static final int INTERNAL_FRAME_CLOSING
        The "window is closing" event. This event is delivered when the user attempts to close the internal frame, such as by clicking the internal frame's close button, or when a program attempts to close the internal frame by invoking the setClosed method.
        另请参见：
        JInternalFrame.setDefaultCloseOperation(int),
JInternalFrame.doDefaultCloseAction(),
JInternalFrame.setClosed(boolean),
Constant Field Values

      • INTERNAL_FRAME_CLOSED

        public static final int INTERNAL_FRAME_CLOSED
        The "window closed" event. This event is delivered after the internal frame has been closed as the result of a call to the setClosed or dispose method.
        另请参见：
        JInternalFrame.setClosed(boolean), JInternalFrame.dispose(), Constant Field Values

      • INTERNAL_FRAME_ICONIFIED

        public static final int INTERNAL_FRAME_ICONIFIED
        The "window iconified" event. This event indicates that the internal frame was shrunk down to a small icon.
        另请参见：
        JInternalFrame.setIcon(boolean), Constant Field Values

      • INTERNAL_FRAME_DEICONIFIED

        public static final int INTERNAL_FRAME_DEICONIFIED
        The "window deiconified" event type. This event indicates that the internal frame has been restored to its normal size.
        另请参见：
        JInternalFrame.setIcon(boolean), Constant Field Values

      • INTERNAL_FRAME_ACTIVATED

        public static final int INTERNAL_FRAME_ACTIVATED
        The "window activated" event type. This event indicates that keystrokes and mouse clicks are directed towards this internal frame.
        另请参见：
        JInternalFrame.show(), JInternalFrame.setSelected(boolean), Constant Field Values

      • INTERNAL_FRAME_DEACTIVATED

        public static final int INTERNAL_FRAME_DEACTIVATED
        The "window deactivated" event type. This event indicates that keystrokes and mouse clicks are no longer directed to the internal frame.
        另请参见：
        JInternalFrame.setSelected(boolean), Constant Field Values

    • 构造方法详细信息

      • InternalFrameEvent

        public InternalFrameEvent(JInternalFrame source,
                  int id)
        Constructs an InternalFrameEvent object.
        参数：
        source - the JInternalFrame object that originated the event
        id - an integer indicating the type of event

    • 方法详细信息

      • paramString

        public String paramString()
        Returns a parameter string identifying this event. This method is useful for event logging and for debugging.
        重载：
        paramString in class AWTEvent
        返回：
        a string identifying the event and its attributes

      • getInternalFrame

        public JInternalFrame getInternalFrame()
        Returns the originator of the event.
        返回：
        the JInternalFrame object that originated the event
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et.o a"a
uv晗 al� �=易nhbs蕄o排衧/-


InternalFrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface InternalFrameListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicInternalFrameUI.BasicInternalFrameListener, InternalFrameAdapter

    public interface InternalFrameListener
extends EventListener
    The listener interface for receiving internal frame events. This class is functionally equivalent to the WindowListener class in the AWT.

    See How to Write an Internal Frame Listener in The Java Tutorial for further documentation.

    另请参见：
    WindowListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void internalFrameActivated(InternalFrameEvent e)
      Invoked when an internal frame is activated.
      void internalFrameClosed(InternalFrameEvent e)
      Invoked when an internal frame has been closed.
      void internalFrameClosing(InternalFrameEvent e)
      Invoked when an internal frame is in the process of being closed.
      void internalFrameDeactivated(InternalFrameEvent e)
      Invoked when an internal frame is de-activated.
      void internalFrameDeiconified(InternalFrameEvent e)
      Invoked when an internal frame is de-iconified.
      void internalFrameIconified(InternalFrameEvent e)
      Invoked when an internal frame is iconified.
      void internalFrameOpened(InternalFrameEvent e)
      Invoked when a internal frame has been opened.

    • 方法详细信息

      • internalFrameOpened

        void internalFrameOpened(InternalFrameEvent e)
        Invoked when a internal frame has been opened.
        另请参见：
        JInternalFrame.show()

      • internalFrameClosing

        void internalFrameClosing(InternalFrameEvent e)
        Invoked when an internal frame is in the process of being closed. The close operation can be overridden at this point.
        另请参见：
        JInternalFrame.setDefaultCloseOperation(int)

      • internalFrameClosed

        void internalFrameClosed(InternalFrameEvent e)
        Invoked when an internal frame has been closed.
        另请参见：
        JInternalFrame.setClosed(boolean)

      • internalFrameIconified

        void internalFrameIconified(InternalFrameEvent e)
        Invoked when an internal frame is iconified.
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameDeiconified

        void internalFrameDeiconified(InternalFrameEvent e)
        Invoked when an internal frame is de-iconified.
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameActivated

        void internalFrameActivated(InternalFrameEvent e)
        Invoked when an internal frame is activated.
        另请参见：
        JInternalFrame.setSelected(boolean)

      • internalFrameDeactivated

        void internalFrameDeactivated(InternalFrameEvent e)
        Invoked when an internal frame is de-activated.
        另请参见：
        JInternalFrame.setSelected(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=oit>k">kcLLkcc=u""tni,ga>


javax.swing.event

Interfaces

  • AncestorListener
  • CaretListener
  • CellEditorListener
  • ChangeListener
  • DocumentEvent
  • DocumentEvent.ElementChange
  • DocumentListener
  • HyperlinkListener
  • InternalFrameListener
  • ListDataListener
  • ListSelectionListener
  • MenuDragMouseListener
  • MenuKeyListener
  • MenuListener
  • MouseInputListener
  • PopupMenuListener
  • RowSorterListener
  • TableColumnModelListener
  • TableModelListener
  • TreeExpansionListener
  • TreeModelListener
  • TreeSelectionListener
  • TreeWillExpandListener
  • UndoableEditListener

Classes

  • AncestorEvent
  • CaretEvent
  • ChangeEvent
  • DocumentEvent.EventType
  • EventListenerList
  • HyperlinkEvent
  • HyperlinkEvent.EventType
  • InternalFrameAdapter
  • InternalFrameEvent
  • ListDataEvent
  • ListSelectionEvent
  • MenuDragMouseEvent
  • MenuEvent
  • MenuKeyEvent
  • MouseInputAdapter
  • PopupMenuEvent
  • RowSorterEvent
  • SwingPropertyChangeSupport
  • TableColumnModelEvent
  • TableModelEvent
  • TreeExpansionEvent
  • TreeModelEvent
  • TreeSelectionEvent
  • UndoableEditEvent

Enums

  • RowSorterEvent.Type
o


javax.swing.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.event

Provides for events fired by Swing components.

请参见： 描述

  • 接口摘要
    接口 描述
    AncestorListener
    AncestorListener Interface to support notification when changes occur to a JComponent or one of its ancestors.
    CaretListener
    Listener for changes in the caret position of a text component.
    CellEditorListener
    CellEditorListener defines the interface for an object that listens to changes in a CellEditor
    ChangeListener
    Defines an object which listens for ChangeEvents.
    DocumentEvent
    Interface for document change notifications.
    DocumentEvent.ElementChange
    Describes changes made to a specific element.
    DocumentListener
    Interface for an observer to register to receive notifications of changes to a text document.
    HyperlinkListener
    HyperlinkListener
    InternalFrameListener
    The listener interface for receiving internal frame events.
    ListDataListener
    ListDataListener
    ListSelectionListener
    The listener that's notified when a lists selection value changes.
    MenuDragMouseListener
    Defines a menu mouse-drag listener.
    MenuKeyListener
    MenuKeyListener
    MenuListener
    Defines a listener for menu events.
    MouseInputListener
    A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
    PopupMenuListener
    A popup menu listener
    RowSorterListener
    RowSorterListeners are notified of changes to a RowSorter.
    TableColumnModelListener
    TableColumnModelListener defines the interface for an object that listens to changes in a TableColumnModel.
    TableModelListener
    TableModelListener defines the interface for an object that listens to changes in a TableModel.
    TreeExpansionListener
    The listener that's notified when a tree expands or collapses a node.
    TreeModelListener
    Defines the interface for an object that listens to changes in a TreeModel.
    TreeSelectionListener
    The listener that's notified when the selection in a TreeSelectionModel changes.
    TreeWillExpandListener
    The listener that's notified when a tree expands or collapses a node.
    UndoableEditListener
    Interface implemented by a class interested in hearing about undoable operations.
  • Class Summary
    类 描述
    AncestorEvent
    An event reported to a child component that originated from an ancestor in the component hierarchy.
    CaretEvent
    CaretEvent is used to notify interested parties that the text caret has changed in the event source.
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    DocumentEvent.EventType
    Enumeration for document event types
    EventListenerList
    A class that holds a list of EventListeners.
    HyperlinkEvent
    HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
    HyperlinkEvent.EventType
    Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().
    InternalFrameAdapter
    An abstract adapter class for receiving internal frame events.
    InternalFrameEvent
    An AWTEvent that adds support for JInternalFrame objects as the event source.
    ListDataEvent
    Defines an event that encapsulates changes to a list.
    ListSelectionEvent
    An event that characterizes a change in selection.
    MenuDragMouseEvent
    MenuDragMouseEvent is used to notify interested parties that the menu element has received a MouseEvent forwarded to it under drag conditions.
    MenuEvent
    MenuEvent is used to notify interested parties that the menu which is the event source has been posted, selected, or canceled.
    MenuKeyEvent
    MenuKeyEvent is used to notify interested parties that the menu element has received a KeyEvent forwarded to it in a menu tree.
    MouseInputAdapter
    An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest.
    PopupMenuEvent
    PopupMenuEvent only contains the source of the event which is the JPoupMenu sending the event
    RowSorterEvent
    RowSorterEvent provides notification of changes to a RowSorter.
    SwingPropertyChangeSupport
    This subclass of java.beans.PropertyChangeSupport is almost identical in functionality.
    TableColumnModelEvent
    TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.
    TableModelEvent
    TableModelEvent is used to notify listeners that a table model has changed.
    TreeExpansionEvent
    An event used to identify a single path in a tree.
    TreeModelEvent
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
    TreeSelectionEvent
    An event that characterizes a change in the current selection.
    UndoableEditEvent
    An event indicating that an operation which can be undone has occurred.
  • Enum Summary
    Enum 描述
    RowSorterEvent.Type
    Enumeration of the types of RowSorterEvents.

软件包 javax.swing.event Description

Provides for events fired by Swing components. It contains event classes and corresponding event listener interfaces for events fired by Swing components in addition to those events in the java.awt.event package.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Writing Event Listeners, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.swing.event Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.event

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.event.DocumentEvent.EventType
    • javax.swing.event.EventListenerList (implements java.io.Serializable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • javax.swing.event.AncestorEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
        • javax.swing.event.InternalFrameEvent
      • javax.swing.event.CaretEvent
      • javax.swing.event.ChangeEvent
      • javax.swing.event.HyperlinkEvent
      • javax.swing.event.ListDataEvent
      • javax.swing.event.ListSelectionEvent
      • javax.swing.event.MenuEvent
      • javax.swing.event.PopupMenuEvent
      • javax.swing.event.RowSorterEvent
      • javax.swing.event.TableColumnModelEvent
      • javax.swing.event.TableModelEvent
      • javax.swing.event.TreeExpansionEvent
      • javax.swing.event.TreeModelEvent
      • javax.swing.event.TreeSelectionEvent
      • javax.swing.event.UndoableEditEvent
    • javax.swing.event.HyperlinkEvent.EventType
    • javax.swing.event.InternalFrameAdapter (implements javax.swing.event.InternalFrameListener)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
      • javax.swing.event.SwingPropertyChangeSupport

Interface Hierarchy

  • javax.swing.event.DocumentEvent
  • javax.swing.event.DocumentEvent.ElementChange
  • java.util.EventListener
    • javax.swing.event.AncestorListener
    • javax.swing.event.CaretListener
    • javax.swing.event.CellEditorListener
    • javax.swing.event.ChangeListener
    • javax.swing.event.DocumentListener
    • javax.swing.event.HyperlinkListener
    • javax.swing.event.InternalFrameListener
    • javax.swing.event.ListDataListener
    • javax.swing.event.ListSelectionListener
    • javax.swing.event.MenuDragMouseListener
    • javax.swing.event.MenuKeyListener
    • javax.swing.event.MenuListener
    • java.awt.event.MouseListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseMotionListener)
    • java.awt.event.MouseMotionListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseListener)
    • javax.swing.event.PopupMenuListener
    • javax.swing.event.RowSorterListener
    • javax.swing.event.TableColumnModelListener
    • javax.swing.event.TableModelListener
    • javax.swing.event.TreeExpansionListener
    • javax.swing.event.TreeModelListener
    • javax.swing.event.TreeSelectionListener
    • javax.swing.event.TreeWillExpandListener
    • javax.swing.event.UndoableEditListener

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.event.RowSorterEvent.Type
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lo" lsc"ooos aa iSSn>


ListDataEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 ListDataEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.ListDataEvent
  • 所有已实现的接口：
    Serializable

    public class ListDataEvent
extends EventObject
    Defines an event that encapsulates changes to a list.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int CONTENTS_CHANGED
      Identifies one or more changes in the lists contents.
      static int INTERVAL_ADDED
      Identifies the addition of one or more contiguous items to the list
      static int INTERVAL_REMOVED
      Identifies the removal of one or more contiguous items from the list

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      ListDataEvent(Object source, int type, int index0, int index1)
      Constructs a ListDataEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIndex0()
      Returns the lower index of the range.
      int getIndex1()
      Returns the upper index of the range.
      int getType()
      Returns the event type.
      String toString()
      Returns a string representation of this ListDataEvent.

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • CONTENTS_CHANGED

        public static final int CONTENTS_CHANGED
        Identifies one or more changes in the lists contents.
        另请参见：
        Constant Field Values

      • INTERVAL_ADDED

        public static final int INTERVAL_ADDED
        Identifies the addition of one or more contiguous items to the list
        另请参见：
        Constant Field Values

      • INTERVAL_REMOVED

        public static final int INTERVAL_REMOVED
        Identifies the removal of one or more contiguous items from the list
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ListDataEvent

        public ListDataEvent(Object source,
             int type,
             int index0,
             int index1)
        Constructs a ListDataEvent object. If index0 is > index1, index0 and index1 will be swapped such that index0 will always be <= index1.
        参数：
        source - the source Object (typically this)
        type - an int specifying CONTENTS_CHANGED, INTERVAL_ADDED, or INTERVAL_REMOVED
        index0 - one end of the new interval
        index1 - the other end of the new interval

    • 方法详细信息

      • getType

        public int getType()
        Returns the event type. The possible values are:
        • CONTENTS_CHANGED
        • INTERVAL_ADDED
        • INTERVAL_REMOVED
        返回：
        an int representing the type value

      • getIndex0

        public int getIndex0()
        Returns the lower index of the range. For a single element, this value is the same as that returned by getIndex1().
        返回：
        an int representing the lower index value

      • getIndex1

        public int getIndex1()
        Returns the upper index of the range. For a single element, this value is the same as that returned by getIndex0().
        返回：
        an int representing the upper index value

      • toString

        public String toString()
        Returns a string representation of this ListDataEvent. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.
        重载：
        toString in class EventObject
        返回：
        a string representation of this ListDataEvent.
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntal t r eer scmmhTbiwwciosdovse c nT r.


ListDataListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface ListDataListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicComboBoxUI.ListDataHandler, BasicComboPopup.ListDataHandler, BasicListUI.ListDataHandler, JComboBox, JList.AccessibleJList

    public interface ListDataListener
extends EventListener
    ListDataListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void contentsChanged(ListDataEvent e)
      Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
      void intervalAdded(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been inserted in the data model.
      void intervalRemoved(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been removed from the data model.

    • 方法详细信息

      • intervalAdded

        void intervalAdded(ListDataEvent e)
        Sent after the indices in the index0,index1 interval have been inserted in the data model. The new interval includes both index0 and index1.
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalRemoved

        void intervalRemoved(ListDataEvent e)
        Sent after the indices in the index0,index1 interval have been removed from the data model. The interval includes both index0 and index1.
        参数：
        e - a ListDataEvent encapsulating the event information

      • contentsChanged

        void contentsChanged(ListDataEvent e)
        Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods. For example, this is sent when an item has been replaced. Index0 and index1 bracket the change.
        参数：
        e - a ListDataEvent encapsulating the event information
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t<-../e./erfferr>


ListSelectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 ListSelectionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.ListSelectionEvent
  • 所有已实现的接口：
    Serializable

    public class ListSelectionEvent
extends EventObject
    An event that characterizes a change in selection. The change is limited to a a single inclusive interval. The selection of at least one index within the range will have changed. A decent ListSelectionModel implementation will keep the range as small as possible. ListSelectionListeners will generally query the source of the event for the new selected status of each potentially changed row.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    ListSelectionModel

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      ListSelectionEvent(Object source, int firstIndex, int lastIndex, boolean isAdjusting)
      Represents a change in selection status between firstIndex and lastIndex, inclusive.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getFirstIndex()
      Returns the index of the first row whose selection may have changed.
      int getLastIndex()
      Returns the index of the last row whose selection may have changed.
      boolean getValueIsAdjusting()
      Returns whether or not this is one in a series of multiple events, where changes are still being made.
      String toString()
      Returns a String that displays and identifies this object's properties.

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ListSelectionEvent

        public ListSelectionEvent(Object source,
                  int firstIndex,
                  int lastIndex,
                  boolean isAdjusting)
        Represents a change in selection status between firstIndex and lastIndex, inclusive. firstIndex is less than or equal to lastIndex. The selection of at least one index within the range will have changed.
        参数：
        firstIndex - the first index in the range, <= lastIndex
        lastIndex - the last index in the range, >= firstIndex
        isAdjusting - whether or not this is one in a series of multiple events, where changes are still being made

    • 方法详细信息

      • getFirstIndex

        public int getFirstIndex()
        Returns the index of the first row whose selection may have changed. getFirstIndex() &lt;= getLastIndex()
        返回：
        the first row whose selection value may have changed, where zero is the first row

      • getLastIndex

        public int getLastIndex()
        Returns the index of the last row whose selection may have changed. getLastIndex() &gt;= getFirstIndex()
        返回：
        the last row whose selection value may have changed, where zero is the first row

      • getValueIsAdjusting

        public boolean getValueIsAdjusting()
        Returns whether or not this is one in a series of multiple events, where changes are still being made. See the documentation for ListSelectionModel.setValueIsAdjusting(boolean) for more details on how this is used.
        返回：
        true if this is one in a series of multiple events, where changes are still being made

      • toString

        public String toString()
        Returns a String that displays and identifies this object's properties.
        重载：
        toString in class EventObject
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t-L=c=e=u=s""=ssu<lllaa/>�


ListSelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface ListSelectionListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicComboPopup.ListSelectionHandler, BasicFileChooserUI.SelectionListener, BasicListUI.ListSelectionHandler, DefaultTableColumnModel, JList.AccessibleJList, JTable, JTable.AccessibleJTable

    public interface ListSelectionListener
extends EventListener
    The listener that's notified when a lists selection value changes.
    另请参见：
    ListSelectionModel

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(ListSelectionEvent e)
      Called whenever the value of the selection changes.

    • 方法详细信息

      • valueChanged

        void valueChanged(ListSelectionEvent e)
        Called whenever the value of the selection changes.
        参数：
        e - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/s.r,<< <


MenuDragMouseEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 MenuDragMouseEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
  • 所有已实现的接口：
    Serializable

    public class MenuDragMouseEvent
extends MouseEvent
    MenuDragMouseEvent is used to notify interested parties that the menu element has received a MouseEvent forwarded to it under drag conditions.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.awt.event.MouseEvent

        BUTTON1, BUTTON2, BUTTON3, MOUSE_CLICKED, MOUSE_DRAGGED, MOUSE_ENTERED, MOUSE_EXITED, MOUSE_FIRST, MOUSE_LAST, MOUSE_MOVED, MOUSE_PRESSED, MOUSE_RELEASED, MOUSE_WHEEL, NOBUTTON

      • Fields inherited from class java.awt.event.InputEvent

        ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.
      MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuDragMouseEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MenuSelectionManager getMenuSelectionManager()
      Returns the current menu selection manager.
      MenuElement[] getPath()
      Returns the path to the selected menu item.

      • 方法 - 继承于类 java.awt.event.MouseEvent

        getButton, getClickCount, getLocationOnScreen, getModifiersEx, getMouseModifiersText, getPoint, getX, getXOnScreen, getY, getYOnScreen, isPopupTrigger, paramString, translatePoint

      • 方法 - 继承于类 java.awt.event.InputEvent

        consume, getMaskForButton, getModifiers, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown

      • 方法 - 继承于类 java.awt.event.ComponentEvent

        getComponent

      • 方法 - 继承于类 java.awt.AWTEvent

        getID, setSource, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuDragMouseEvent

        public MenuDragMouseEvent(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int clickCount,
                  boolean popupTrigger,
                  MenuElement[] p,
                  MenuSelectionManager m)
        Constructs a MenuDragMouseEvent object.

        Absolute coordinates xAbs and yAbs are set to source's location on screen plus relative coordinates x and y. xAbs and yAbs are set to zero if the source is not showing.

        参数：
        source - the Component that originated the event (typically this)
        id - an int specifying the type of event, as defined in MouseEvent
        when - a long identifying the time the event occurred
        modifiers - an int specifying any modifier keys held down, as specified in InputEvent
        x - an int specifying the horizontal position at which the event occurred, in pixels
        y - an int specifying the vertical position at which the event occurred, in pixels
        clickCount - an int specifying the number of mouse-clicks
        popupTrigger - a boolean -- true if the event {should?/did?} trigger a popup
        p - an array of MenuElement objects specifying a path to a menu item affected by the drag
        m - a MenuSelectionManager object that handles selections
        另请参见：
        MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

      • MenuDragMouseEvent

        public MenuDragMouseEvent(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int xAbs,
                  int yAbs,
                  int clickCount,
                  boolean popupTrigger,
                  MenuElement[] p,
                  MenuSelectionManager m)
        Constructs a MenuDragMouseEvent object.

        Even if inconsistent values for relative and absolute coordinates are passed to the constructor, the MenuDragMouseEvent instance is still created.

        参数：
        source - the Component that originated the event (typically this)
        id - an int specifying the type of event, as defined in MouseEvent
        when - a long identifying the time the event occurred
        modifiers - an int specifying any modifier keys held down, as specified in InputEvent
        x - an int specifying the horizontal position at which the event occurred, in pixels
        y - an int specifying the vertical position at which the event occurred, in pixels
        xAbs - an int specifying the horizontal absolute position at which the event occurred, in pixels
        yAbs - an int specifying the vertical absolute position at which the event occurred, in pixels
        clickCount - an int specifying the number of mouse-clicks
        popupTrigger - a boolean -- true if the event {should?/did?} trigger a popup
        p - an array of MenuElement objects specifying a path to a menu item affected by the drag
        m - a MenuSelectionManager object that handles selections
        从以下版本开始：
        1.6
        另请参见：
        MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

    • 方法详细信息

      • getPath

        public MenuElement[] getPath()
        Returns the path to the selected menu item.
        返回：
        an array of MenuElement objects representing the path value

      • getMenuSelectionManager

        public MenuSelectionManager getMenuSelectionManager()
        Returns the current menu selection manager.
        返回：
        a MenuSelectionManager object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


MenuDragMouseListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface MenuDragMouseListener

  • All Superinterfaces:
    EventListener

    public interface MenuDragMouseListener
extends EventListener
    Defines a menu mouse-drag listener.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void menuDragMouseDragged(MenuDragMouseEvent e)
      Invoked when the mouse is being dragged in a menu component's display area.
      void menuDragMouseEntered(MenuDragMouseEvent e)
      Invoked when the dragged mouse has entered a menu component's display area.
      void menuDragMouseExited(MenuDragMouseEvent e)
      Invoked when the dragged mouse has left a menu component's display area.
      void menuDragMouseReleased(MenuDragMouseEvent e)
      Invoked when a dragged mouse is release in a menu component's display area.

    • 方法详细信息

      • menuDragMouseEntered

        void menuDragMouseEntered(MenuDragMouseEvent e)
        Invoked when the dragged mouse has entered a menu component's display area.
        参数：
        e - a MenuDragMouseEvent object

      • menuDragMouseExited

        void menuDragMouseExited(MenuDragMouseEvent e)
        Invoked when the dragged mouse has left a menu component's display area.
        参数：
        e - a MenuDragMouseEvent object

      • menuDragMouseDragged

        void menuDragMouseDragged(MenuDragMouseEvent e)
        Invoked when the mouse is being dragged in a menu component's display area.
        参数：
        e - a MenuDragMouseEvent object

      • menuDragMouseReleased

        void menuDragMouseReleased(MenuDragMouseEvent e)
        Invoked when a dragged mouse is release in a menu component's display area.
        参数：
        e - a MenuDragMouseEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h.ras;sp;ss&&sssmiFF"esane_i>>lo


MenuEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.event

类 MenuEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.MenuEvent
  • 所有已实现的接口：
    Serializable

    public class MenuEvent
extends EventObject
    MenuEvent is used to notify interested parties that the menu which is the event source has been posted, selected, or canceled.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuEvent(Object source)
      Constructs a MenuEvent object.

    • 方法摘要

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuEvent

        public MenuEvent(Object source)
        Constructs a MenuEvent object.
        参数：
        source - the Object that originated the event (typically this)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f"eAtAuAeA Irefe 奎黨< b=gpgb"=" 1hrr<>


MenuKeyEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 MenuKeyEvent

  • java.lang.Object
    • java.util.EventObject
      • java.awt.AWTEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
  • 所有已实现的接口：
    Serializable

    public class MenuKeyEvent
extends KeyEvent
    MenuKeyEvent is used to notify interested parties that the menu element has received a KeyEvent forwarded to it in a menu tree.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.awt.event.KeyEvent

        CHAR_UNDEFINED, KEY_FIRST, KEY_LAST, KEY_LOCATION_LEFT, KEY_LOCATION_NUMPAD, KEY_LOCATION_RIGHT, KEY_LOCATION_STANDARD, KEY_LOCATION_UNKNOWN, KEY_PRESSED, KEY_RELEASED, KEY_TYPED, VK_0, VK_1, VK_2, VK_3, VK_4, VK_5, VK_6, VK_7, VK_8, VK_9, VK_A, VK_ACCEPT, VK_ADD, VK_AGAIN, VK_ALL_CANDIDATES, VK_ALPHANUMERIC, VK_ALT, VK_ALT_GRAPH, VK_AMPERSAND, VK_ASTERISK, VK_AT, VK_B, VK_BACK_QUOTE, VK_BACK_SLASH, VK_BACK_SPACE, VK_BEGIN, VK_BRACELEFT, VK_BRACERIGHT, VK_C, VK_CANCEL, VK_CAPS_LOCK, VK_CIRCUMFLEX, VK_CLEAR, VK_CLOSE_BRACKET, VK_CODE_INPUT, VK_COLON, VK_COMMA, VK_COMPOSE, VK_CONTEXT_MENU, VK_CONTROL, VK_CONVERT, VK_COPY, VK_CUT, VK_D, VK_DEAD_ABOVEDOT, VK_DEAD_ABOVERING, VK_DEAD_ACUTE, VK_DEAD_BREVE, VK_DEAD_CARON, VK_DEAD_CEDILLA, VK_DEAD_CIRCUMFLEX, VK_DEAD_DIAERESIS, VK_DEAD_DOUBLEACUTE, VK_DEAD_GRAVE, VK_DEAD_IOTA, VK_DEAD_MACRON, VK_DEAD_OGONEK, VK_DEAD_SEMIVOICED_SOUND, VK_DEAD_TILDE, VK_DEAD_VOICED_SOUND, VK_DECIMAL, VK_DELETE, VK_DIVIDE, VK_DOLLAR, VK_DOWN, VK_E, VK_END, VK_ENTER, VK_EQUALS, VK_ESCAPE, VK_EURO_SIGN, VK_EXCLAMATION_MARK, VK_F, VK_F1, VK_F10, VK_F11, VK_F12, VK_F13, VK_F14, VK_F15, VK_F16, VK_F17, VK_F18, VK_F19, VK_F2, VK_F20, VK_F21, VK_F22, VK_F23, VK_F24, VK_F3, VK_F4, VK_F5, VK_F6, VK_F7, VK_F8, VK_F9, VK_FINAL, VK_FIND, VK_FULL_WIDTH, VK_G, VK_GREATER, VK_H, VK_HALF_WIDTH, VK_HELP, VK_HIRAGANA, VK_HOME, VK_I, VK_INPUT_METHOD_ON_OFF, VK_INSERT, VK_INVERTED_EXCLAMATION_MARK, VK_J, VK_JAPANESE_HIRAGANA, VK_JAPANESE_KATAKANA, VK_JAPANESE_ROMAN, VK_K, VK_KANA, VK_KANA_LOCK, VK_KANJI, VK_KATAKANA, VK_KP_DOWN, VK_KP_LEFT, VK_KP_RIGHT, VK_KP_UP, VK_L, VK_LEFT, VK_LEFT_PARENTHESIS, VK_LESS, VK_M, VK_META, VK_MINUS, VK_MODECHANGE, VK_MULTIPLY, VK_N, VK_NONCONVERT, VK_NUM_LOCK, VK_NUMBER_SIGN, VK_NUMPAD0, VK_NUMPAD1, VK_NUMPAD2, VK_NUMPAD3, VK_NUMPAD4, VK_NUMPAD5, VK_NUMPAD6, VK_NUMPAD7, VK_NUMPAD8, VK_NUMPAD9, VK_O, VK_OPEN_BRACKET, VK_P, VK_PAGE_DOWN, VK_PAGE_UP, VK_PASTE, VK_PAUSE, VK_PERIOD, VK_PLUS, VK_PREVIOUS_CANDIDATE, VK_PRINTSCREEN, VK_PROPS, VK_Q, VK_QUOTE, VK_QUOTEDBL, VK_R, VK_RIGHT, VK_RIGHT_PARENTHESIS, VK_ROMAN_CHARACTERS, VK_S, VK_SCROLL_LOCK, VK_SEMICOLON, VK_SEPARATER, VK_SEPARATOR, VK_SHIFT, VK_SLASH, VK_SPACE, VK_STOP, VK_SUBTRACT, VK_T, VK_TAB, VK_U, VK_UNDEFINED, VK_UNDERSCORE, VK_UNDO, VK_UP, VK_V, VK_W, VK_WINDOWS, VK_X, VK_Y, VK_Z

      • Fields inherited from class java.awt.event.InputEvent

        ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK

      • Fields inherited from class java.awt.event.ComponentEvent

        COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN

      • Fields inherited from class java.awt.AWTEvent

        ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
      Constructs a MenuKeyEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MenuSelectionManager getMenuSelectionManager()
      Returns the current menu selection manager.
      MenuElement[] getPath()
      Returns the path to the menu item referenced by this event.

      • 方法 - 继承于类 java.awt.event.KeyEvent

        getExtendedKeyCode, getExtendedKeyCodeForChar, getKeyChar, getKeyCode, getKeyLocation, getKeyModifiersText, getKeyText, isActionKey, paramString, setKeyChar, setKeyCode, setModifiers

      • 方法 - 继承于类 java.awt.event.InputEvent

        consume, getMaskForButton, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown

      • 方法 - 继承于类 java.awt.event.ComponentEvent

        getComponent

      • 方法 - 继承于类 java.awt.AWTEvent

        getID, setSource, toString

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MenuKeyEvent

        public MenuKeyEvent(Component source,
            int id,
            long when,
            int modifiers,
            int keyCode,
            char keyChar,
            MenuElement[] p,
            MenuSelectionManager m)
        Constructs a MenuKeyEvent object.
        参数：
        source - the Component that originated the event (typically this)
        id - an int specifying the type of event, as defined in KeyEvent
        when - a long identifying the time the event occurred
        modifiers - an int specifying any modifier keys held down, as specified in InputEvent
        keyCode - an int specifying the specific key that was pressed
        keyChar - a char specifying the key's character value, if any -- null if the key has no character value
        p - an array of MenuElement objects specifying a path to a menu item affected by the drag
        m - a MenuSelectionManager object that handles selections

    • 方法详细信息

      • getPath

        public MenuElement[] getPath()
        Returns the path to the menu item referenced by this event.
        返回：
        an array of MenuElement objects representing the path value

      • getMenuSelectionManager

        public MenuSelectionManager getMenuSelectionManager()
        Returns the current menu selection manager.
        返回：
        a MenuSelectionManager object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MenuKeyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface MenuKeyListener

  • All Superinterfaces:
    EventListener

    public interface MenuKeyListener
extends EventListener
    MenuKeyListener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void menuKeyPressed(MenuKeyEvent e)
      Invoked when a key has been pressed.
      void menuKeyReleased(MenuKeyEvent e)
      Invoked when a key has been released.
      void menuKeyTyped(MenuKeyEvent e)
      Invoked when a key has been typed.

    • 方法详细信息

      • menuKeyTyped

        void menuKeyTyped(MenuKeyEvent e)
        Invoked when a key has been typed. This event occurs when a key press is followed by a key release.

      • menuKeyPressed

        void menuKeyPressed(MenuKeyEvent e)
        Invoked when a key has been pressed.

      • menuKeyReleased

        void menuKeyReleased(MenuKeyEvent e)
        Invoked when a key has been released.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ree<"VV>VV#KKV##.Kaa..h/.///f.>


MenuListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface MenuListener

  • All Superinterfaces:
    EventListener

    public interface MenuListener
extends EventListener
    Defines a listener for menu events.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void menuCanceled(MenuEvent e)
      Invoked when the menu is canceled.
      void menuDeselected(MenuEvent e)
      Invoked when the menu is deselected.
      void menuSelected(MenuEvent e)
      Invoked when a menu is selected.

    • 方法详细信息

      • menuSelected

        void menuSelected(MenuEvent e)
        Invoked when a menu is selected.
        参数：
        e - a MenuEvent object

      • menuDeselected

        void menuDeselected(MenuEvent e)
        Invoked when the menu is deselected.
        参数：
        e - a MenuEvent object

      • menuCanceled

        void menuCanceled(MenuEvent e)
        Invoked when the menu is canceled.
        参数：
        e - a MenuEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s eCai sl==nisutog


MouseInputAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.event

类 MouseInputAdapter

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.event.MouseInputAdapter
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
    直接已知子类：
    BasicDesktopIconUI.MouseInputHandler, BasicInternalFrameUI.BorderListener, BasicSliderUI.TrackListener

    public abstract class MouseInputAdapter
extends MouseAdapter
implements MouseInputListener
    An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest. This class also provides an empty implementation of the MouseWheelListener interface, through its extension from AWT's MouseAdapter.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MouseInputAdapter()

    • 方法摘要

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.MouseListener

        mouseClicked, mouseEntered, mouseExited, mousePressed, mouseReleased

      • 方法 - 继承于接口 java.awt.event.MouseMotionListener

        mouseDragged, mouseMoved

    • 构造方法详细信息

      • MouseInputAdapter

        public MouseInputAdapter()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v cj/sumshratt.eor>uoss .a 3s.t.x1


MouseInputListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.event

Interface MouseInputListener

  • All Superinterfaces:
    EventListener, MouseListener, MouseMotionListener
    All Known Implementing Classes:
    BasicDesktopIconUI.MouseInputHandler, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.GlassPaneDispatcher, BasicListUI.MouseInputHandler, BasicMenuItemUI.MouseInputHandler, BasicMenuUI.MouseInputHandler, BasicSliderUI.TrackListener, BasicTableHeaderUI.MouseInputHandler, BasicTableUI.MouseInputHandler, BasicToolBarUI.DockingListener, BasicTreeUI.MouseInputHandler, MetalToolBarUI.MetalDockingListener, MouseInputAdapter

    public interface MouseInputListener
extends MouseListener, MouseMotionListener
    A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
    另请参见：
    MouseInputAdapter

    • 方法摘要

      • 方法 - 继承于接口 java.awt.event.MouseListener

        mouseClicked, mouseEntered, mouseExited, mousePressed, mouseReleased

      • 方法 - 继承于接口 java.awt.event.MouseMotionListener

        mouseDragged, mouseMoved
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>eo=elot


PopupMenuEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.event

类 PopupMenuEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.PopupMenuEvent
  • 所有已实现的接口：
    Serializable

    public class PopupMenuEvent
extends EventObject
    PopupMenuEvent only contains the source of the event which is the JPoupMenu sending the event

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      PopupMenuEvent(Object source)
      Constructs a PopupMenuEvent object.

    • 方法摘要

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PopupMenuEvent

        public PopupMenuEvent(Object source)
        Constructs a PopupMenuEvent object.
        参数：
        source - the Object that originated the event (typically this)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

igcoi c ic/o/rooer..i>"ogtroPgn.#ShCenp


PopupMenuListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface PopupMenuListener

  • All Superinterfaces:
    EventListener

    public interface PopupMenuListener
extends EventListener
    A popup menu listener

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void popupMenuCanceled(PopupMenuEvent e)
      This method is called when the popup menu is canceled
      void popupMenuWillBecomeInvisible(PopupMenuEvent e)
      This method is called before the popup menu becomes invisible Note that a JPopupMenu can become invisible any time
      void popupMenuWillBecomeVisible(PopupMenuEvent e)
      This method is called before the popup menu becomes visible

    • 方法详细信息

      • popupMenuWillBecomeVisible

        void popupMenuWillBecomeVisible(PopupMenuEvent e)
        This method is called before the popup menu becomes visible

      • popupMenuWillBecomeInvisible

        void popupMenuWillBecomeInvisible(PopupMenuEvent e)
        This method is called before the popup menu becomes invisible Note that a JPopupMenu can become invisible any time

      • popupMenuCanceled

        void popupMenuCanceled(PopupMenuEvent e)
        This method is called when the popup menu is canceled
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntbd>dtd&dl/>&np>Fvvntie�;iflas


RowSorterEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 RowSorterEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.RowSorterEvent
  • 所有已实现的接口：
    Serializable

    public class RowSorterEvent
extends EventObject
    RowSorterEvent provides notification of changes to a RowSorter. Two types of notification are possible:
    • Type.SORT_ORDER_CHANGED: indicates the sort order has changed. This is typically followed by a notification of:
    • Type.SORTED: indicates the contents of the model have been transformed in some way. For example, the contents may have been sorted or filtered.
    从以下版本开始：
    1.6
    另请参见：
    RowSorter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  RowSorterEvent.Type
      Enumeration of the types of RowSorterEvents.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      RowSorterEvent(RowSorter source)
      Creates a RowSorterEvent of type SORT_ORDER_CHANGED.
      RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
      Creates a RowSorterEvent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int convertPreviousRowIndexToModel(int index)
      Returns the location of index in terms of the model prior to the sort.
      int getPreviousRowCount()
      Returns the number of rows before the sort.
      RowSorter getSource()
      Returns the source of the event as a RowSorter.
      RowSorterEvent.Type getType()
      Returns the type of event.

      • 方法 - 继承于类 java.util.EventObject

        toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RowSorterEvent

        public RowSorterEvent(RowSorter source)
        Creates a RowSorterEvent of type SORT_ORDER_CHANGED.
        参数：
        source - the source of the change
        抛出：
        IllegalArgumentException - if source is null

      • RowSorterEvent

        public RowSorterEvent(RowSorter source,
              RowSorterEvent.Type type,
              int[] previousRowIndexToModel)
        Creates a RowSorterEvent.
        参数：
        source - the source of the change
        type - the type of event
        previousRowIndexToModel - the mapping from model indices to view indices prior to the sort, may be null
        抛出：
        IllegalArgumentException - if source or type is null

    • 方法详细信息

      • getSource

        public RowSorter getSource()
        Returns the source of the event as a RowSorter.
        重载：
        getSource in class EventObject
        返回：
        the source of the event as a RowSorter

      • getType

        public RowSorterEvent.Type getType()
        Returns the type of event.
        返回：
        the type of event

      • convertPreviousRowIndexToModel

        public int convertPreviousRowIndexToModel(int index)
        Returns the location of index in terms of the model prior to the sort. This method is only useful for events of type SORTED. This method will return -1 if the index is not valid, or the locations prior to the sort have not been provided.
        参数：
        index - the index in terms of the view
        返回：
        the index in terms of the model prior to the sort, or -1 if the location is not valid or the mapping was not provided.

      • getPreviousRowCount

        public int getPreviousRowCount()
        Returns the number of rows before the sort. This method is only useful for events of type SORTED and if the last locations have not been provided will return 0.
        返回：
        the number of rows in terms of the view prior to the sort
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ffheteenr > nena>胷"redma"on eltnd/�


RowSorterEvent.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing.event

Enum RowSorterEvent.Type

  • java.lang.Object
    • java.lang.Enum<RowSorterEvent.Type>
      • javax.swing.event.RowSorterEvent.Type
  • 所有已实现的接口：
    Serializable, Comparable<RowSorterEvent.Type>
    封闭类：
    RowSorterEvent

    public static enum RowSorterEvent.Type
extends Enum<RowSorterEvent.Type>
    Enumeration of the types of RowSorterEvents.
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      SORT_ORDER_CHANGED
      Indicates the sort order has changed.
      SORTED
      Indicates the contents have been newly sorted or transformed in some way.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static RowSorterEvent.Type valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RowSorterEvent.Type[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SORT_ORDER_CHANGED

        public static final RowSorterEvent.Type SORT_ORDER_CHANGED
        Indicates the sort order has changed.

      • SORTED

        public static final RowSorterEvent.Type SORTED
        Indicates the contents have been newly sorted or transformed in some way.

    • 方法详细信息

      • values

        public static RowSorterEvent.Type[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (RowSorterEvent.Type c : RowSorterEvent.Type.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static RowSorterEvent.Type valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

idpn:an:s<<:ssetpp>>ea/t


RowSorterListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface RowSorterListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    JTable

    public interface RowSorterListener
extends EventListener
    RowSorterListeners are notified of changes to a RowSorter.
    从以下版本开始：
    1.6
    另请参见：
    RowSorter

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void sorterChanged(RowSorterEvent e)
      Notification that the RowSorter has changed.

    • 方法详细信息

      • sorterChanged

        void sorterChanged(RowSorterEvent e)
        Notification that the RowSorter has changed. The event describes the scope of the change.
        参数：
        e - the event, will not be null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h tnaa.va./...//.a>>tittoloi/>>l.e


SwingPropertyChangeSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 SwingPropertyChangeSupport

  • java.lang.Object
    • java.beans.PropertyChangeSupport
      • javax.swing.event.SwingPropertyChangeSupport
  • 所有已实现的接口：
    Serializable

    public final class SwingPropertyChangeSupport
extends PropertyChangeSupport
    This subclass of java.beans.PropertyChangeSupport is almost identical in functionality. The only difference is if constructed with SwingPropertyChangeSupport(sourceBean, true) it ensures listeners are only ever notified on the Event Dispatch Thread.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SwingPropertyChangeSupport(Object sourceBean)
      Constructs a SwingPropertyChangeSupport object.
      SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
      Constructs a SwingPropertyChangeSupport object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void firePropertyChange(PropertyChangeEvent evt)
      Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
      boolean isNotifyOnEDT()
      Returns notifyOnEDT property.

      • 方法 - 继承于类 java.beans.PropertyChangeSupport

        addPropertyChangeListener, addPropertyChangeListener, fireIndexedPropertyChange, fireIndexedPropertyChange, fireIndexedPropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getPropertyChangeListeners, getPropertyChangeListeners, hasListeners, removePropertyChangeListener, removePropertyChangeListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SwingPropertyChangeSupport

        public SwingPropertyChangeSupport(Object sourceBean)
        Constructs a SwingPropertyChangeSupport object.
        参数：
        sourceBean - The bean to be given as the source for any events.
        抛出：
        NullPointerException - if sourceBean is null

      • SwingPropertyChangeSupport

        public SwingPropertyChangeSupport(Object sourceBean,
                          boolean notifyOnEDT)
        Constructs a SwingPropertyChangeSupport object.
        参数：
        sourceBean - the bean to be given as the source for any events
        notifyOnEDT - whether to notify listeners on the Event Dispatch Thread only
        抛出：
        NullPointerException - if sourceBean is null
        从以下版本开始：
        1.6

    • 方法详细信息

      • firePropertyChange

        public void firePropertyChange(PropertyChangeEvent evt)
        Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.

        No event is fired if the given event's old and new values are equal and non-null.

        If isNotifyOnEDT() is true and called off the Event Dispatch Thread this implementation uses SwingUtilities.invokeLater to send out the notification on the Event Dispatch Thread. This ensures listeners are only ever notified on the Event Dispatch Thread.

        重载：
        firePropertyChange in class PropertyChangeSupport
        参数：
        evt - the PropertyChangeEvent to be fired
        抛出：
        NullPointerException - if evt is null
        从以下版本开始：
        1.6

      • isNotifyOnEDT

        public final boolean isNotifyOnEDT()
        Returns notifyOnEDT property.
        返回：
        notifyOnEDT property
        从以下版本开始：
        1.6
        另请参见：
        SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

# /h觝"h e="#n=>ss/>snlll=>Lt>蟬s舷x秐


TableColumnModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 TableColumnModelEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.TableColumnModelEvent
  • 所有已实现的接口：
    Serializable

    public class TableColumnModelEvent
extends EventObject
    TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    TableColumnModelListener

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int fromIndex
      The index of the column from where it was moved or removed
      protected int toIndex
      The index of the column to where it was moved or added

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableColumnModelEvent(TableColumnModel source, int from, int to)
      Constructs a TableColumnModelEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getFromIndex()
      Returns the fromIndex.
      int getToIndex()
      Returns the toIndex.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • fromIndex

        protected int fromIndex
        The index of the column from where it was moved or removed

      • toIndex

        protected int toIndex
        The index of the column to where it was moved or added

    • 构造方法详细信息

      • TableColumnModelEvent

        public TableColumnModelEvent(TableColumnModel source,
                     int from,
                     int to)
        Constructs a TableColumnModelEvent object.
        参数：
        source - the TableColumnModel that originated the event
        from - an int specifying the index from where the column was moved or removed
        to - an int specifying the index to where the column was moved or added
        另请参见：
        getFromIndex(), getToIndex()

    • 方法详细信息

      • getFromIndex

        public int getFromIndex()
        Returns the fromIndex. Valid for removed or moved events

      • getToIndex

        public int getToIndex()
        Returns the toIndex. Valid for add and moved events
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f"op;pdptps;;psseaee"ei/a..e/...ra" .iaa./ >


TableColumnModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TableColumnModelListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    JTable, JTable.AccessibleJTable, JTableHeader

    public interface TableColumnModelListener
extends EventListener
    TableColumnModelListener defines the interface for an object that listens to changes in a TableColumnModel.
    另请参见：
    TableColumnModelEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void columnAdded(TableColumnModelEvent e)
      Tells listeners that a column was added to the model.
      void columnMarginChanged(ChangeEvent e)
      Tells listeners that a column was moved due to a margin change.
      void columnMoved(TableColumnModelEvent e)
      Tells listeners that a column was repositioned.
      void columnRemoved(TableColumnModelEvent e)
      Tells listeners that a column was removed from the model.
      void columnSelectionChanged(ListSelectionEvent e)
      Tells listeners that the selection model of the TableColumnModel changed.

    • 方法详细信息

      • columnAdded

        void columnAdded(TableColumnModelEvent e)
        Tells listeners that a column was added to the model.

      • columnRemoved

        void columnRemoved(TableColumnModelEvent e)
        Tells listeners that a column was removed from the model.

      • columnMoved

        void columnMoved(TableColumnModelEvent e)
        Tells listeners that a column was repositioned.

      • columnMarginChanged

        void columnMarginChanged(ChangeEvent e)
        Tells listeners that a column was moved due to a margin change.

      • columnSelectionChanged

        void columnSelectionChanged(ListSelectionEvent e)
        Tells listeners that the selection model of the TableColumnModel changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e -v <> < //< / ut">" l> v/S


TableModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 TableModelEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.TableModelEvent
  • 所有已实现的接口：
    Serializable

    public class TableModelEvent
extends EventObject
    TableModelEvent is used to notify listeners that a table model has changed. The model event describes changes to a TableModel and all references to rows and columns are in the co-ordinate system of the model. Depending on the parameters used in the constructors, the TableModelevent can be used to specify the following types of changes:

     TableModelEvent(source);              //  The data, ie. all rows changed
 TableModelEvent(source, HEADER_ROW);  //  Structure change, reallocate TableColumns
 TableModelEvent(source, 1);           //  Row 1 changed
 TableModelEvent(source, 3, 6);        //  Rows 3 to 6 inclusive changed
 TableModelEvent(source, 2, 2, 6);     //  Cell at (2, 6) changed
 TableModelEvent(source, 3, 6, ALL_COLUMNS, INSERT); // Rows (3, 6) were inserted
 TableModelEvent(source, 3, 6, ALL_COLUMNS, DELETE); // Rows (3, 6) were deleted
    It is possible to use other combinations of the parameters, not all of them are meaningful. By subclassing, you can add other information, for example: whether the event WILL happen or DID happen. This makes the specification of rows in DELETE events more useful but has not been included in the swing package as the JTable only needs post-event notification.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    TableModel

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int ALL_COLUMNS
      Specifies all columns in a row or rows.
      protected int | column
      static int DELETE
      Identifies the removal of rows or columns.
      protected int | firstRow
      static int HEADER_ROW
      Identifies the header row.
      static int INSERT
      Identifies the addtion of new rows or columns.
      protected int | lastRow
      protected int | type
      static int UPDATE
      Identifies a change to existing data.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableModelEvent(TableModel source)
      All row data in the table has changed, listeners should discard any state that was based on the rows and requery the TableModel to get the new row count and all the appropriate values.
      TableModelEvent(TableModel source, int row)
      This row of data has been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow)
      The data in rows [firstRow, lastRow] have been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow, int column)
      The cells in column column in the range [firstRow, lastRow] have been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow, int column, int type)
      The cells from (firstRow, column) to (lastRow, column) have been changed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumn()
      Returns the column for the event.
      int getFirstRow()
      Returns the first row that changed.
      int getLastRow()
      Returns the last row that changed.
      int getType()
      Returns the type of event - one of: INSERT, UPDATE and DELETE.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INSERT

        public static final int INSERT
        Identifies the addtion of new rows or columns.
        另请参见：
        Constant Field Values

      • UPDATE

        public static final int UPDATE
        Identifies a change to existing data.
        另请参见：
        Constant Field Values

      • DELETE

        public static final int DELETE
        Identifies the removal of rows or columns.
        另请参见：
        Constant Field Values

      • HEADER_ROW

        public static final int HEADER_ROW
        Identifies the header row.
        另请参见：
        Constant Field Values

      • ALL_COLUMNS

        public static final int ALL_COLUMNS
        Specifies all columns in a row or rows.
        另请参见：
        Constant Field Values

      • type

        protected int type

      • firstRow

        protected int firstRow

      • lastRow

        protected int lastRow

      • column

        protected int column

    • 构造方法详细信息

      • TableModelEvent

        public TableModelEvent(TableModel source)
        All row data in the table has changed, listeners should discard any state that was based on the rows and requery the TableModel to get the new row count and all the appropriate values. The JTable will repaint the entire visible region on receiving this event, querying the model for the cell values that are visible. The structure of the table ie, the column names, types and order have not changed.

      • TableModelEvent

        public TableModelEvent(TableModel source,
               int row)
        This row of data has been updated. To denote the arrival of a completely new table with a different structure use HEADER_ROW as the value for the row. When the JTable receives this event and its autoCreateColumnsFromModel flag is set it discards any TableColumns that it had and reallocates default ones in the order they appear in the model. This is the same as calling setModel(TableModel) on the JTable.

      • TableModelEvent

        public TableModelEvent(TableModel source,
               int firstRow,
               int lastRow)
        The data in rows [firstRow, lastRow] have been updated.

      • TableModelEvent

        public TableModelEvent(TableModel source,
               int firstRow,
               int lastRow,
               int column)
        The cells in column column in the range [firstRow, lastRow] have been updated.

      • TableModelEvent

        public TableModelEvent(TableModel source,
               int firstRow,
               int lastRow,
               int column,
               int type)
        The cells from (firstRow, column) to (lastRow, column) have been changed. The column refers to the column index of the cell in the model's co-ordinate system. When column is ALL_COLUMNS, all cells in the specified range of rows are considered changed.

        The type should be one of: INSERT, UPDATE and DELETE.

    • 方法详细信息

      • getFirstRow

        public int getFirstRow()
        Returns the first row that changed. HEADER_ROW means the meta data, ie. names, types and order of the columns.

      • getLastRow

        public int getLastRow()
        Returns the last row that changed.

      • getColumn

        public int getColumn()
        Returns the column for the event. If the return value is ALL_COLUMNS; it means every column in the specified rows changed.

      • getType

        public int getType()
        Returns the type of event - one of: INSERT, UPDATE and DELETE.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d<. >psaNssau>i/s>ecs


TableModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TableModelListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    JTable, JTable.AccessibleJTable

    public interface TableModelListener
extends EventListener
    TableModelListener defines the interface for an object that listens to changes in a TableModel.
    另请参见：
    TableModel

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void tableChanged(TableModelEvent e)
      This fine grain notification tells listeners the exact range of cells, rows, or columns that changed.

    • 方法详细信息

      • tableChanged

        void tableChanged(TableModelEvent e)
        This fine grain notification tells listeners the exact range of cells, rows, or columns that changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cpoc>rcprc


TreeExpansionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 TreeExpansionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.TreeExpansionEvent
  • 所有已实现的接口：
    Serializable

    public class TreeExpansionEvent
extends EventObject
    An event used to identify a single path in a tree. The source returned by getSource will be an instance of JTree.

    For further documentation and examples see the following sections in The Java Tutorial: How to Write a Tree Expansion Listener and How to Write a Tree-Will-Expand Listener.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected TreePath path
      Path to the value this event represents.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TreeExpansionEvent(Object source, TreePath path)
      Constructs a TreeExpansionEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TreePath getPath()
      Returns the path to the value that has been expanded/collapsed.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • path

        protected TreePath path
        Path to the value this event represents.

    • 构造方法详细信息

      • TreeExpansionEvent

        public TreeExpansionEvent(Object source,
                  TreePath path)
        Constructs a TreeExpansionEvent object.
        参数：
        source - the Object that originated the event (typically this)
        path - a TreePath object identifying the newly expanded node

    • 方法详细信息

      • getPath

        public TreePath getPath()
        Returns the path to the value that has been expanded/collapsed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ctSr>"))rtvvvEabd&Ohbclgmol.h..Sl,


TreeExpansionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TreeExpansionListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicTreeUI.TreeExpansionHandler, JTree.AccessibleJTree

    public interface TreeExpansionListener
extends EventListener
    The listener that's notified when a tree expands or collapses a node. For further documentation and examples see How to Write a Tree Expansion Listener, a section in The Java Tutorial.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeCollapsed(TreeExpansionEvent event)
      Called whenever an item in the tree has been collapsed.
      void treeExpanded(TreeExpansionEvent event)
      Called whenever an item in the tree has been expanded.

    • 方法详细信息

      • treeExpanded

        void treeExpanded(TreeExpansionEvent event)
        Called whenever an item in the tree has been expanded.

      • treeCollapsed

        void treeCollapsed(TreeExpansionEvent event)
        Called whenever an item in the tree has been collapsed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acL"lablalssall<=AA< "sl>== =s


TreeModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 TreeModelEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.TreeModelEvent
  • 所有已实现的接口：
    Serializable

    public class TreeModelEvent
extends EventObject
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change. For more information and examples see How to Write a Tree Model Listener, a section in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int[] childIndices
      Indices identifying the position of where the children were.
      protected Object[] children
      Children that have been removed.
      protected TreePath path
      Path to the parent of the nodes that have changed.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TreeModelEvent(Object source, Object[] path)
      Used to create an event when the node structure has changed in some way, identifying the path to the root of a modified subtree as an array of Objects.
      TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
      Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as an array of Objects.
      TreeModelEvent(Object source, TreePath path)
      Used to create an event when the node structure has changed in some way, identifying the path to the root of the modified subtree as a TreePath object.
      TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
      Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as a TreePath object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int[] getChildIndices()
      Returns the values of the child indexes.
      Object[] getChildren()
      Returns the objects that are children of the node identified by getPath at the locations specified by getChildIndices.
      Object[] getPath()
      Convenience method to get the array of objects from the TreePath instance that this event wraps.
      TreePath getTreePath()
      For all events, except treeStructureChanged, returns the parent of the changed nodes.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • 方法 - 继承于类 java.util.EventObject

        getSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • path

        protected TreePath path
        Path to the parent of the nodes that have changed.

      • childIndices

        protected int[] childIndices
        Indices identifying the position of where the children were.

      • children

        protected Object[] children
        Children that have been removed.

    • 构造方法详细信息

      • TreeModelEvent

        public TreeModelEvent(Object source,
              Object[] path,
              int[] childIndices,
              Object[] children)
        Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as an array of Objects. All of the modified objects are siblings which are direct descendents (not grandchildren) of the specified parent. The positions at which the inserts, deletes, or changes occurred are specified by an array of int. The indexes in that array must be in order, from lowest to highest.

        For changes, the indexes in the model correspond exactly to the indexes of items currently displayed in the UI. As a result, it is not really critical if the indexes are not in their exact order. But after multiple inserts or deletes, the items currently in the UI no longer correspond to the items in the model. It is therefore critical to specify the indexes properly for inserts and deletes.

        For inserts, the indexes represent the final state of the tree, after the inserts have occurred. Since the indexes must be specified in order, the most natural processing methodology is to do the inserts starting at the lowest index and working towards the highest. Accumulate a Vector of Integer objects that specify the insert-locations as you go, then convert the Vector to an array of int to create the event. When the postition-index equals zero, the node is inserted at the beginning of the list. When the position index equals the size of the list, the node is "inserted" at (appended to) the end of the list.

        For deletes, the indexes represent the initial state of the tree, before the deletes have occurred. Since the indexes must be specified in order, the most natural processing methodology is to use a delete-counter. Start by initializing the counter to zero and start work through the list from lowest to higest. Every time you do a delete, add the current value of the delete-counter to the index-position where the delete occurred, and append the result to a Vector of delete-locations, using addElement(). Then increment the delete-counter. The index positions stored in the Vector therefore reflect the effects of all previous deletes, so they represent each object's position in the initial tree. (You could also start at the highest index and working back towards the lowest, accumulating a Vector of delete-locations as you go using the insertElementAt(Integer, 0).) However you produce the Vector of initial-positions, you then need to convert the Vector of Integer objects to an array of int to create the event.

        Notes:

        • Like the insertNodeInto method in the DefaultTreeModel class, insertElementAt appends to the Vector when the index matches the size of the vector. So you can use insertElementAt(Integer, 0) even when the vector is empty.
            To create a node changed event for the root node, specify the parent and the child indices as null.
        参数：
        source - the Object responsible for generating the event (typically the creator of the event object passes this for its value)
        path - an array of Object identifying the path to the parent of the modified item(s), where the first element of the array is the Object stored at the root node and the last element is the Object stored at the parent node
        childIndices - an array of int that specifies the index values of the removed items. The indices must be in sorted order, from lowest to highest
        children - an array of Object containing the inserted, removed, or changed objects
        另请参见：
        TreePath

      • TreeModelEvent

        public TreeModelEvent(Object source,
              TreePath path,
              int[] childIndices,
              Object[] children)
        Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as a TreePath object. For more information on how to specify the indexes and objects, see TreeModelEvent(Object,Object[],int[],Object[]).
        参数：
        source - the Object responsible for generating the event (typically the creator of the event object passes this for its value)
        path - a TreePath object that identifies the path to the parent of the modified item(s)
        childIndices - an array of int that specifies the index values of the modified items
        children - an array of Object containing the inserted, removed, or changed objects
        另请参见：
        TreeModelEvent(Object,Object[],int[],Object[])

      • TreeModelEvent

        public TreeModelEvent(Object source,
              Object[] path)
        Used to create an event when the node structure has changed in some way, identifying the path to the root of a modified subtree as an array of Objects. A structure change event might involve nodes swapping position, for example, or it might encapsulate multiple inserts and deletes in the subtree stemming from the node, where the changes may have taken place at different levels of the subtree.
        Note:
        JTree collapses all nodes under the specified node, so that only its immediate children are visible.
        参数：
        source - the Object responsible for generating the event (typically the creator of the event object passes this for its value)
        path - an array of Object identifying the path to the root of the modified subtree, where the first element of the array is the object stored at the root node and the last element is the object stored at the changed node
        另请参见：
        TreePath

      • TreeModelEvent

        public TreeModelEvent(Object source,
              TreePath path)
        Used to create an event when the node structure has changed in some way, identifying the path to the root of the modified subtree as a TreePath object. For more information on this event specification, see TreeModelEvent(Object,Object[]).
        参数：
        source - the Object responsible for generating the event (typically the creator of the event object passes this for its value)
        path - a TreePath object that identifies the path to the change. In the DefaultTreeModel, this object contains an array of user-data objects, but a subclass of TreePath could use some totally different mechanism -- for example, a node ID number
        另请参见：
        TreeModelEvent(Object,Object[])

    • 方法详细信息

      • getTreePath

        public TreePath getTreePath()
        For all events, except treeStructureChanged, returns the parent of the changed nodes. For treeStructureChanged events, returns the ancestor of the structure that has changed. This and getChildIndices are used to get a list of the effected nodes.

        The one exception to this is a treeNodesChanged event that is to identify the root, in which case this will return the root and getChildIndices will return null.

        返回：
        the TreePath used in identifying the changed nodes.
        另请参见：
        TreePath.getLastPathComponent()

      • getPath

        public Object[] getPath()
        Convenience method to get the array of objects from the TreePath instance that this event wraps.
        返回：
        an array of Objects, where the first Object is the one stored at the root and the last object is the one stored at the node identified by the path

      • getChildren

        public Object[] getChildren()
        Returns the objects that are children of the node identified by getPath at the locations specified by getChildIndices. If this is a removal event the returned objects are no longer children of the parent node.
        返回：
        an array of Object containing the children specified by the event
        另请参见：
        getPath(), getChildIndices()

      • getChildIndices

        public int[] getChildIndices()
        Returns the values of the child indexes. If this is a removal event the indexes point to locations in the initial list where items were removed. If it is an insert, the indices point to locations in the final list where the items were added. For node changes, the indices point to the locations of the modified nodes.
        返回：
        an array of int containing index locations for the children specified by the event

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class EventObject
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TreeModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TreeModelListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicTreeUI.TreeModelHandler, JTree.AccessibleJTree, JTree.TreeModelHandler

    public interface TreeModelListener
extends EventListener
    Defines the interface for an object that listens to changes in a TreeModel. For further information and examples see How to Write a Tree Model Listener, a section in The Java Tutorial.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

    • 方法详细信息

      • treeNodesChanged

        void treeNodesChanged(TreeModelEvent e)

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        To indicate the root has changed, childIndices and children will be null.

        Use e.getPath() to get the parent of the changed node(s). e.getChildIndices() returns the index(es) of the changed node(s).

      • treeNodesInserted

        void treeNodesInserted(TreeModelEvent e)

        Invoked after nodes have been inserted into the tree.

        Use e.getPath() to get the parent of the new node(s). e.getChildIndices() returns the index(es) of the new node(s) in ascending order.

      • treeNodesRemoved

        void treeNodesRemoved(TreeModelEvent e)

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        Use e.getPath() to get the former parent of the deleted node(s). e.getChildIndices() returns, in ascending order, the index(es) the node(s) had before being deleted.

      • treeStructureChanged

        void treeStructureChanged(TreeModelEvent e)

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        Use e.getPath() to get the path to the node. e.getChildIndices() returns null.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

neta.//.//.../..ed//./a"=O.EjOu


TreeSelectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 TreeSelectionEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.TreeSelectionEvent
  • 所有已实现的接口：
    Serializable

    public class TreeSelectionEvent
extends EventObject
    An event that characterizes a change in the current selection. The change is based on any number of paths. TreeSelectionListeners will generally query the source of the event for the new selected status of each potentially changed row.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    TreeSelectionListener, TreeSelectionModel

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean[] areNew
      For each path identifies if that path is in fact new.
      protected TreePath newLeadSelectionPath
      leadSelectionPath after the paths changed, may be null.
      protected TreePath oldLeadSelectionPath
      leadSelectionPath before the paths changed, may be null.
      protected TreePath[] paths
      Paths this event represents.

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.
      TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object cloneWithSource(Object newSource)
      Returns a copy of the receiver, but with the source being newSource.
      TreePath getNewLeadSelectionPath()
      Returns the current lead path.
      TreePath getOldLeadSelectionPath()
      Returns the path that was previously the lead path.
      TreePath getPath()
      Returns the first path element.
      TreePath[] getPaths()
      Returns the paths that have been added or removed from the selection.
      boolean isAddedPath()
      Returns whether the path identified by getPath was added to the selection.
      boolean isAddedPath(int index)
      Returns whether the path at getPaths()[index] was added to the selection.
      boolean isAddedPath(TreePath path)
      Returns whether the specified path was added to the selection.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • paths

        protected TreePath[] paths
        Paths this event represents.

      • areNew

        protected boolean[] areNew
        For each path identifies if that path is in fact new.

      • oldLeadSelectionPath

        protected TreePath oldLeadSelectionPath
        leadSelectionPath before the paths changed, may be null.

      • newLeadSelectionPath

        protected TreePath newLeadSelectionPath
        leadSelectionPath after the paths changed, may be null.

    • 构造方法详细信息

      • TreeSelectionEvent

        public TreeSelectionEvent(Object source,
                  TreePath[] paths,
                  boolean[] areNew,
                  TreePath oldLeadSelectionPath,
                  TreePath newLeadSelectionPath)
        Represents a change in the selection of a TreeSelectionModel. paths identifies the paths that have been either added or removed from the selection.
        参数：
        source - source of event
        paths - the paths that have changed in the selection

      • TreeSelectionEvent

        public TreeSelectionEvent(Object source,
                  TreePath path,
                  boolean isNew,
                  TreePath oldLeadSelectionPath,
                  TreePath newLeadSelectionPath)
        Represents a change in the selection of a TreeSelectionModel. path identifies the path that have been either added or removed from the selection.
        参数：
        source - source of event
        path - the path that has changed in the selection
        isNew - whether or not the path is new to the selection, false means path was removed from the selection.

    • 方法详细信息

      • getPaths

        public TreePath[] getPaths()
        Returns the paths that have been added or removed from the selection.

      • getPath

        public TreePath getPath()
        Returns the first path element.

      • isAddedPath

        public boolean isAddedPath()
        Returns whether the path identified by getPath was added to the selection. A return value of true indicates the path identified by getPath was added to the selection. A return value of false indicates getPath was selected, but is no longer selected.
        返回：
        true if getPath was added to the selection, false otherwise

      • isAddedPath

        public boolean isAddedPath(TreePath path)
        Returns whether the specified path was added to the selection. A return value of true indicates the path identified by path was added to the selection. A return value of false indicates path is no longer selected. This method is only valid for the paths returned from getPaths(); invoking with a path not included in getPaths() throws an IllegalArgumentException.
        参数：
        path - the path to test
        返回：
        true if path was added to the selection, false otherwise
        抛出：
        IllegalArgumentException - if path is not contained in getPaths
        另请参见：
        getPaths()

      • isAddedPath

        public boolean isAddedPath(int index)
        Returns whether the path at getPaths()[index] was added to the selection. A return value of true indicates the path was added to the selection. A return value of false indicates the path is no longer selected.
        参数：
        index - the index of the path to test
        返回：
        true if the path was added to the selection, false otherwise
        抛出：
        IllegalArgumentException - if index is outside the range of getPaths
        从以下版本开始：
        1.3
        另请参见：
        getPaths()

      • getOldLeadSelectionPath

        public TreePath getOldLeadSelectionPath()
        Returns the path that was previously the lead path.

      • getNewLeadSelectionPath

        public TreePath getNewLeadSelectionPath()
        Returns the current lead path.

      • cloneWithSource

        public Object cloneWithSource(Object newSource)
        Returns a copy of the receiver, but with the source being newSource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

覵唬� ！NNE鵅/� ece/sk=bae"n�9o"t nR xr/


TreeSelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TreeSelectionListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    BasicTreeUI.TreeSelectionHandler, DefaultTreeCellEditor, JTree.AccessibleJTree, JTree.TreeSelectionRedirector

    public interface TreeSelectionListener
extends EventListener
    The listener that's notified when the selection in a TreeSelectionModel changes. For more information and examples see How to Write a Tree Selection Listener, a section in The Java Tutorial.
    另请参见：
    TreeSelectionModel, JTree

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(TreeSelectionEvent e)
      Called whenever the value of the selection changes.

    • 方法详细信息

      • valueChanged

        void valueChanged(TreeSelectionEvent e)
        Called whenever the value of the selection changes.
        参数：
        e - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/eee.ge.gn..gnnxcvv"=nrh.wnoTT/a


TreeWillExpandListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface TreeWillExpandListener

  • All Superinterfaces:
    EventListener

    public interface TreeWillExpandListener
extends EventListener
    The listener that's notified when a tree expands or collapses a node. For further information and examples see How to Write a Tree-Will-Expand Listener, a section in The Java Tutorial.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeWillCollapse(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be collapsed.
      void treeWillExpand(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be expanded.

    • 方法详细信息

      • treeWillExpand

        void treeWillExpand(TreeExpansionEvent event)
                    throws ExpandVetoException
        Invoked whenever a node in the tree is about to be expanded.
        抛出：
        ExpandVetoException

      • treeWillCollapse

        void treeWillCollapse(TreeExpansionEvent event)
                      throws ExpandVetoException
        Invoked whenever a node in the tree is about to be collapsed.
        抛出：
        ExpandVetoException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t=h nsatsrpeeoppksddef


UndoableEditEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.event

类 UndoableEditEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.UndoableEditEvent
  • 所有已实现的接口：
    Serializable

    public class UndoableEditEvent
extends EventObject
    An event indicating that an operation which can be undone has occurred.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      UndoableEditEvent(Object source, UndoableEdit edit)
      Constructs an UndoableEditEvent object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      UndoableEdit getEdit()
      Returns the edit value.

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UndoableEditEvent

        public UndoableEditEvent(Object source,
                 UndoableEdit edit)
        Constructs an UndoableEditEvent object.
        参数：
        source - the Object that originated the event (typically this)
        edit - an UndoableEdit object

    • 方法详细信息

      • getEdit

        public UndoableEdit getEdit()
        Returns the edit value.
        返回：
        the UndoableEdit object encapsulating the edit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dse ehtthsn nnR" /t/


UndoableEditListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.event

Interface UndoableEditListener

  • All Superinterfaces:
    EventListener
    All Known Implementing Classes:
    UndoManager

    public interface UndoableEditListener
extends EventListener
    Interface implemented by a class interested in hearing about undoable operations.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void undoableEditHappened(UndoableEditEvent e)
      An undoable edit happened

    • 方法详细信息

      • undoableEditHappened

        void undoableEditHappened(UndoableEditEvent e)
        An undoable edit happened
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t#iy#ohnoh.tth..ba..,ah


Uses of Package javax.swing.event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.event

  • Packages that use javax.swing.event
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.
  • Classes in javax.swing.event used by javax.swing
    类与描述
    AncestorListener
    AncestorListener Interface to support notification when changes occur to a JComponent or one of its ancestors.
    CaretListener
    Listener for changes in the caret position of a text component.
    CellEditorListener
    CellEditorListener defines the interface for an object that listens to changes in a CellEditor
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    ChangeListener
    Defines an object which listens for ChangeEvents.
    DocumentListener
    Interface for an observer to register to receive notifications of changes to a text document.
    EventListenerList
    A class that holds a list of EventListeners.
    HyperlinkEvent
    HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
    HyperlinkListener
    HyperlinkListener
    InternalFrameListener
    The listener interface for receiving internal frame events.
    ListDataEvent
    Defines an event that encapsulates changes to a list.
    ListDataListener
    ListDataListener
    ListSelectionEvent
    An event that characterizes a change in selection.
    ListSelectionListener
    The listener that's notified when a lists selection value changes.
    MenuDragMouseEvent
    MenuDragMouseEvent is used to notify interested parties that the menu element has received a MouseEvent forwarded to it under drag conditions.
    MenuDragMouseListener
    Defines a menu mouse-drag listener.
    MenuKeyEvent
    MenuKeyEvent is used to notify interested parties that the menu element has received a KeyEvent forwarded to it in a menu tree.
    MenuKeyListener
    MenuKeyListener
    MenuListener
    Defines a listener for menu events.
    PopupMenuListener
    A popup menu listener
    RowSorterEvent
    RowSorterEvent provides notification of changes to a RowSorter.
    RowSorterListener
    RowSorterListeners are notified of changes to a RowSorter.
    SwingPropertyChangeSupport
    This subclass of java.beans.PropertyChangeSupport is almost identical in functionality.
    TableColumnModelEvent
    TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.
    TableColumnModelListener
    TableColumnModelListener defines the interface for an object that listens to changes in a TableColumnModel.
    TableModelEvent
    TableModelEvent is used to notify listeners that a table model has changed.
    TableModelListener
    TableModelListener defines the interface for an object that listens to changes in a TableModel.
    TreeExpansionEvent
    An event used to identify a single path in a tree.
    TreeExpansionListener
    The listener that's notified when a tree expands or collapses a node.
    TreeModelEvent
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
    TreeModelListener
    Defines the interface for an object that listens to changes in a TreeModel.
    TreeSelectionEvent
    An event that characterizes a change in the current selection.
    TreeSelectionListener
    The listener that's notified when the selection in a TreeSelectionModel changes.
    TreeWillExpandListener
    The listener that's notified when a tree expands or collapses a node.
  • Classes in javax.swing.event used by javax.swing.colorchooser
    类与描述
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    ChangeListener
    Defines an object which listens for ChangeEvents.
    EventListenerList
    A class that holds a list of EventListeners.
  • Classes in javax.swing.event used by javax.swing.event
    类与描述
    AncestorEvent
    An event reported to a child component that originated from an ancestor in the component hierarchy.
    CaretEvent
    CaretEvent is used to notify interested parties that the text caret has changed in the event source.
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    DocumentEvent
    Interface for document change notifications.
    DocumentEvent.ElementChange
    Describes changes made to a specific element.
    DocumentEvent.EventType
    Enumeration for document event types
    HyperlinkEvent
    HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
    HyperlinkEvent.EventType
    Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().
    InternalFrameEvent
    An AWTEvent that adds support for JInternalFrame objects as the event source.
    InternalFrameListener
    The listener interface for receiving internal frame events.
    ListDataEvent
    Defines an event that encapsulates changes to a list.
    ListSelectionEvent
    An event that characterizes a change in selection.
    MenuDragMouseEvent
    MenuDragMouseEvent is used to notify interested parties that the menu element has received a MouseEvent forwarded to it under drag conditions.
    MenuEvent
    MenuEvent is used to notify interested parties that the menu which is the event source has been posted, selected, or canceled.
    MenuKeyEvent
    MenuKeyEvent is used to notify interested parties that the menu element has received a KeyEvent forwarded to it in a menu tree.
    MouseInputListener
    A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
    PopupMenuEvent
    PopupMenuEvent only contains the source of the event which is the JPoupMenu sending the event
    RowSorterEvent
    RowSorterEvent provides notification of changes to a RowSorter.
    RowSorterEvent.Type
    Enumeration of the types of RowSorterEvents.
    TableColumnModelEvent
    TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.
    TableModelEvent
    TableModelEvent is used to notify listeners that a table model has changed.
    TreeExpansionEvent
    An event used to identify a single path in a tree.
    TreeModelEvent
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
    TreeSelectionEvent
    An event that characterizes a change in the current selection.
    UndoableEditEvent
    An event indicating that an operation which can be undone has occurred.
  • Classes in javax.swing.event used by javax.swing.plaf.basic
    类与描述
    CellEditorListener
    CellEditorListener defines the interface for an object that listens to changes in a CellEditor
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    ChangeListener
    Defines an object which listens for ChangeEvents.
    InternalFrameEvent
    An AWTEvent that adds support for JInternalFrame objects as the event source.
    InternalFrameListener
    The listener interface for receiving internal frame events.
    ListDataEvent
    Defines an event that encapsulates changes to a list.
    ListDataListener
    ListDataListener
    ListSelectionEvent
    An event that characterizes a change in selection.
    ListSelectionListener
    The listener that's notified when a lists selection value changes.
    MenuDragMouseListener
    Defines a menu mouse-drag listener.
    MenuKeyListener
    MenuKeyListener
    MenuListener
    Defines a listener for menu events.
    MouseInputAdapter
    An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest.
    MouseInputListener
    A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
    TreeExpansionEvent
    An event used to identify a single path in a tree.
    TreeExpansionListener
    The listener that's notified when a tree expands or collapses a node.
    TreeModelEvent
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
    TreeModelListener
    Defines the interface for an object that listens to changes in a TreeModel.
    TreeSelectionEvent
    An event that characterizes a change in the current selection.
    TreeSelectionListener
    The listener that's notified when the selection in a TreeSelectionModel changes.
  • Classes in javax.swing.event used by javax.swing.plaf.metal
    类与描述
    ListSelectionEvent
    An event that characterizes a change in selection.
    ListSelectionListener
    The listener that's notified when a lists selection value changes.
    MouseInputAdapter
    An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest.
    MouseInputListener
    A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
  • Classes in javax.swing.event used by javax.swing.table
    类与描述
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    EventListenerList
    A class that holds a list of EventListeners.
    ListSelectionEvent
    An event that characterizes a change in selection.
    ListSelectionListener
    The listener that's notified when a lists selection value changes.
    TableColumnModelEvent
    TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.
    TableColumnModelListener
    TableColumnModelListener defines the interface for an object that listens to changes in a TableColumnModel.
    TableModelEvent
    TableModelEvent is used to notify listeners that a table model has changed.
    TableModelListener
    TableModelListener defines the interface for an object that listens to changes in a TableModel.
  • Classes in javax.swing.event used by javax.swing.text
    类与描述
    CaretEvent
    CaretEvent is used to notify interested parties that the text caret has changed in the event source.
    CaretListener
    Listener for changes in the caret position of a text component.
    ChangeEvent
    ChangeEvent is used to notify interested parties that state has changed in the event source.
    ChangeListener
    Defines an object which listens for ChangeEvents.
    DocumentEvent
    Interface for document change notifications.
    DocumentEvent.ElementChange
    Describes changes made to a specific element.
    DocumentEvent.EventType
    Enumeration for document event types
    DocumentListener
    Interface for an observer to register to receive notifications of changes to a text document.
    EventListenerList
    A class that holds a list of EventListeners.
    UndoableEditEvent
    An event indicating that an operation which can be undone has occurred.
    UndoableEditListener
    Interface implemented by a class interested in hearing about undoable operations.
  • Classes in javax.swing.event used by javax.swing.text.html
    类与描述
    DocumentEvent
    Interface for document change notifications.
    HyperlinkEvent
    HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
    HyperlinkEvent.EventType
    Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().
    UndoableEditEvent
    An event indicating that an operation which can be undone has occurred.
  • Classes in javax.swing.event used by javax.swing.tree
    类与描述
    CellEditorListener
    CellEditorListener defines the interface for an object that listens to changes in a CellEditor
    EventListenerList
    A class that holds a list of EventListeners.
    SwingPropertyChangeSupport
    This subclass of java.beans.PropertyChangeSupport is almost identical in functionality.
    TreeExpansionEvent
    An event used to identify a single path in a tree.
    TreeModelEvent
    Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
    TreeModelListener
    Defines the interface for an object that listens to changes in a TreeModel.
    TreeSelectionEvent
    An event that characterizes a change in the current selection.
    TreeSelectionListener
    The listener that's notified when the selection in a TreeSelectionModel changes.
  • Classes in javax.swing.event used by javax.swing.undo
    类与描述
    UndoableEditEvent
    An event indicating that an operation which can be undone has occurred.
    UndoableEditListener
    Interface implemented by a class interested in hearing about undoable operations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.event.AncestorEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.AncestorEvent

  • Packages that use AncestorEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of AncestorEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type AncestorEvent
      修饰符与类型 方法与描述
      void AncestorListener.ancestorAdded(AncestorEvent event)
      Called when the source or one of its ancestors is made visible either by setVisible(true) being called or by its being added to the component hierarchy.
      void AncestorListener.ancestorMoved(AncestorEvent event)
      Called when either the source or one of its ancestors is moved.
      void AncestorListener.ancestorRemoved(AncestorEvent event)
      Called when the source or one of its ancestors is made invisible either by setVisible(false) being called or by its being remove from the component hierarchy.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ititonSliex.a>hh


Uses of Class javax.swing.event.CaretEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.CaretEvent

  • Packages that use CaretEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of CaretEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type CaretEvent
      修饰符与类型 方法与描述
      void CaretListener.caretUpdate(CaretEvent e)
      Called when the caret position is updated.

    • Uses of CaretEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type CaretEvent
      修饰符与类型 方法与描述
      void JTextComponent.AccessibleJTextComponent.caretUpdate(CaretEvent e)
      Handles caret updates (fire appropriate property change event, which are AccessibleContext.ACCESSIBLE_CARET_PROPERTY and AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY).
      protected void JTextComponent.fireCaretUpdate(CaretEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ete v.c/.t.f ilns ap


Uses of Class javax.swing.event.ChangeEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.ChangeEvent

  • Packages that use ChangeEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of ChangeEvent in javax.swing

      Fields in javax.swing declared as ChangeEvent
      修饰符与类型 | 字段与描述
      protected ChangeEvent JProgressBar.changeEvent
      Only one ChangeEvent is needed per instance since the event's only interesting property is the immutable source, which is the progress bar.
      protected ChangeEvent JSlider.changeEvent
      Only one ChangeEvent is needed per slider instance since the event's only (read-only) state is the source property.
      protected ChangeEvent JTabbedPane.changeEvent
      Only one ChangeEvent is needed per TabPane instance since the event's only (read-only) state is the source property.
      protected ChangeEvent DefaultBoundedRangeModel.changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
      protected ChangeEvent | DefaultSingleSelectionModel.changeEvent
      protected ChangeEvent DefaultButtonModel.changeEvent
      Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
      protected ChangeEvent | AbstractCellEditor.changeEvent
      protected ChangeEvent MenuSelectionManager.changeEvent
      Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
      protected ChangeEvent AbstractButton.changeEvent
      Only one ChangeEvent is needed per button instance since the event's only state is the source property.
      Methods in javax.swing with parameters of type ChangeEvent
      修饰符与类型 | 方法与描述
      void JTable.columnMarginChanged(ChangeEvent e)
      Invoked when a column is moved due to a margin change.
      void JTable.AccessibleJTable.columnMarginChanged(ChangeEvent e)
      Track changes of a column moving due to margin changes.
      void JTable.editingCanceled(ChangeEvent e)
      Invoked when editing is canceled.
      void JTable.AccessibleJTable.editingCanceled(ChangeEvent e)
      Invoked when editing is canceled.
      void JTable.editingStopped(ChangeEvent e)
      Invoked when editing is finished.
      void JTable.AccessibleJTable.editingStopped(ChangeEvent e)
      Track changes to a cell's contents.
      void ProgressMonitor.AccessibleProgressMonitor.stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.
      void JSpinner.DefaultEditor.stateChanged(ChangeEvent e)
      This method is called when the spinner's model's state changes.
      void JSpinner.AccessibleJSpinner.stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.
      void | JTabbedPane.ModelListener.stateChanged(ChangeEvent e)
      void | JTabbedPane.AccessibleJTabbedPane.stateChanged(ChangeEvent e)
      void JScrollPane.AccessibleJScrollPane.stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.
      void JMenuItem.AccessibleJMenuItem.stateChanged(ChangeEvent e)
      Supports the change listener interface and fires property changes.
      void | AbstractButton.ButtonChangeListener.stateChanged(ChangeEvent e)

    • Uses of ChangeEvent in javax.swing.colorchooser

      Fields in javax.swing.colorchooser declared as ChangeEvent
      修饰符与类型 字段与描述
      protected ChangeEvent DefaultColorSelectionModel.changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.

    • Uses of ChangeEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type ChangeEvent
      修饰符与类型 方法与描述
      void TableColumnModelListener.columnMarginChanged(ChangeEvent e)
      Tells listeners that a column was moved due to a margin change.
      void CellEditorListener.editingCanceled(ChangeEvent e)
      This tells the listeners the editor has canceled editing
      void CellEditorListener.editingStopped(ChangeEvent e)
      This tells the listeners the editor has ended editing
      void ChangeListener.stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

    • Uses of ChangeEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ChangeEvent
      修饰符与类型 | 方法与描述
      void BasicTreeUI.CellEditorHandler.editingCanceled(ChangeEvent e)
      Messaged when editing has been canceled in the tree.
      void BasicTreeUI.CellEditorHandler.editingStopped(ChangeEvent e)
      Messaged when editing has stopped in the tree.
      void | BasicTabbedPaneUI.TabSelectionHandler.stateChanged(ChangeEvent e)
      void | BasicSliderUI.ChangeHandler.stateChanged(ChangeEvent e)
      void | BasicScrollPaneUI.ViewportChangeHandler.stateChanged(ChangeEvent e)
      void | BasicScrollPaneUI.HSBChangeListener.stateChanged(ChangeEvent e)
      void | BasicScrollPaneUI.VSBChangeListener.stateChanged(ChangeEvent e)
      void | BasicScrollBarUI.ModelListener.stateChanged(ChangeEvent e)
      void | BasicProgressBarUI.ChangeHandler.stateChanged(ChangeEvent e)
      void | BasicButtonListener.stateChanged(ChangeEvent e)
      void | BasicMenuUI.ChangeHandler.stateChanged(ChangeEvent e)

    • Uses of ChangeEvent in javax.swing.table

      Fields in javax.swing.table declared as ChangeEvent
      修饰符与类型 字段与描述
      protected ChangeEvent DefaultTableColumnModel.changeEvent
      Change event (only one needed)
      Methods in javax.swing.table with parameters of type ChangeEvent
      修饰符与类型 方法与描述
      void JTableHeader.columnMarginChanged(ChangeEvent e)
      Invoked when a column is moved due to a margin change.

    • Uses of ChangeEvent in javax.swing.text

      Fields in javax.swing.text declared as ChangeEvent
      修饰符与类型 字段与描述
      protected ChangeEvent StyleContext.NamedStyle.changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
      protected ChangeEvent DefaultCaret.changeEvent
      The change event for the model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.event.DocumentEvent.EventType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.DocumentEvent.EventType

  • Packages that use DocumentEvent.EventType
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DocumentEvent.EventType in javax.swing.event

      Fields in javax.swing.event declared as DocumentEvent.EventType
      修饰符与类型 字段与描述
      static DocumentEvent.EventType DocumentEvent.EventType.CHANGE
      Change type.
      static DocumentEvent.EventType DocumentEvent.EventType.INSERT
      Insert type.
      static DocumentEvent.EventType DocumentEvent.EventType.REMOVE
      Remove type.
      Methods in javax.swing.event that return DocumentEvent.EventType
      修饰符与类型 方法与描述
      DocumentEvent.EventType DocumentEvent.getType()
      Gets the type of event.

    • Uses of DocumentEvent.EventType in javax.swing.text

      Methods in javax.swing.text that return DocumentEvent.EventType
      修饰符与类型 方法与描述
      DocumentEvent.EventType AbstractDocument.DefaultDocumentEvent.getType()
      Returns the type of event.
      Constructors in javax.swing.text with parameters of type DocumentEvent.EventType
      构造方法与描述
      AbstractDocument.DefaultDocumentEvent(int offs, int len, DocumentEvent.EventType type)
      Constructs a change record.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atvr="iittttlannol>oaydl/n/


Uses of Class javax.swing.event.EventListenerList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.EventListenerList

  • Packages that use EventListenerList
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of EventListenerList in javax.swing

      Fields in javax.swing declared as EventListenerList
      修饰符与类型 | 字段与描述
      protected EventListenerList AbstractSpinnerModel.listenerList
      The list of ChangeListeners for this model.
      protected EventListenerList DefaultBoundedRangeModel.listenerList
      The listeners waiting for model changes.
      protected EventListenerList | AbstractListModel.listenerList
      protected EventListenerList DefaultSingleSelectionModel.listenerList
      The collection of registered listeners
      protected EventListenerList | DefaultListSelectionModel.listenerList
      protected EventListenerList DefaultButtonModel.listenerList
      Stores the listeners on this model.
      protected EventListenerList | AbstractCellEditor.listenerList
      protected EventListenerList | MenuSelectionManager.listenerList
      protected EventListenerList JComponent.listenerList
      A list of event listeners for this component.
      protected EventListenerList | Timer.listenerList

    • Uses of EventListenerList in javax.swing.colorchooser

      Fields in javax.swing.colorchooser declared as EventListenerList
      修饰符与类型 | 字段与描述
      protected EventListenerList | DefaultColorSelectionModel.listenerList

    • Uses of EventListenerList in javax.swing.table

      Fields in javax.swing.table declared as EventListenerList
      修饰符与类型 字段与描述
      protected EventListenerList DefaultTableColumnModel.listenerList
      List of TableColumnModelListener
      protected EventListenerList AbstractTableModel.listenerList
      List of listeners

    • Uses of EventListenerList in javax.swing.text

      Fields in javax.swing.text declared as EventListenerList
      修饰符与类型 字段与描述
      protected EventListenerList StyleContext.NamedStyle.listenerList
      The change listeners for the model.
      protected EventListenerList AbstractDocument.listenerList
      The event listener list for the document.
      protected EventListenerList DefaultCaret.listenerList
      The event listener list.

    • Uses of EventListenerList in javax.swing.tree

      Fields in javax.swing.tree declared as EventListenerList
      修饰符与类型 字段与描述
      protected EventListenerList DefaultTreeModel.listenerList
      Listeners.
      protected EventListenerList DefaultTreeSelectionModel.listenerList
      Event listener list.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oule/衧ayo A nlmpp


Uses of Class javax.swing.event.HyperlinkEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.HyperlinkEvent

  • Packages that use HyperlinkEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HyperlinkEvent in javax.swing

      Methods in javax.swing with parameters of type HyperlinkEvent
      修饰符与类型 方法与描述
      void JEditorPane.fireHyperlinkUpdate(HyperlinkEvent e)
      Notifies all listeners that have registered interest for notification on this event type.

    • Uses of HyperlinkEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type HyperlinkEvent
      修饰符与类型 方法与描述
      void HyperlinkListener.hyperlinkUpdate(HyperlinkEvent e)
      Called when a hypertext link is updated.

    • Uses of HyperlinkEvent in javax.swing.text.html

      Subclasses of HyperlinkEvent in javax.swing.text.html
      修饰符与类型 类与描述
      class  FormSubmitEvent
      FormSubmitEvent is used to notify interested parties that a form was submited.
      class  HTMLFrameHyperlinkEvent
      HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/wl.../erfffa pp.h/=.//e


Uses of Class javax.swing.event.HyperlinkEvent.EventType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.HyperlinkEvent.EventType

  • Packages that use HyperlinkEvent.EventType
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HyperlinkEvent.EventType in javax.swing.event

      Fields in javax.swing.event declared as HyperlinkEvent.EventType
      修饰符与类型 字段与描述
      static HyperlinkEvent.EventType HyperlinkEvent.EventType.ACTIVATED
      Activated type.
      static HyperlinkEvent.EventType HyperlinkEvent.EventType.ENTERED
      Entered type.
      static HyperlinkEvent.EventType HyperlinkEvent.EventType.EXITED
      Exited type.
      Methods in javax.swing.event that return HyperlinkEvent.EventType
      修饰符与类型 方法与描述
      HyperlinkEvent.EventType HyperlinkEvent.getEventType()
      Gets the type of event.
      Constructors in javax.swing.event with parameters of type HyperlinkEvent.EventType
      构造方法与描述
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)
      Creates a new object representing a hypertext link event.

    • Uses of HyperlinkEvent.EventType in javax.swing.text.html

      Constructors in javax.swing.text.html with parameters of type HyperlinkEvent.EventType
      构造方法与描述
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
      Creates a new object representing a html frame hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
      Creates a new object representing a hypertext link event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne laoSLlr.t/ a etul> eh


Uses of Class javax.swing.event.InternalFrameAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.InternalFrameAdapter

No usage of javax.swing.event.InternalFrameAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slw//..=f"""htrrv.//a


Uses of Class javax.swing.event.InternalFrameEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.InternalFrameEvent

  • Packages that use InternalFrameEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of InternalFrameEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type InternalFrameEvent
      修饰符与类型 方法与描述
      void InternalFrameAdapter.internalFrameActivated(InternalFrameEvent e)
      Invoked when an internal frame is activated.
      void InternalFrameListener.internalFrameActivated(InternalFrameEvent e)
      Invoked when an internal frame is activated.
      void InternalFrameAdapter.internalFrameClosed(InternalFrameEvent e)
      Invoked when an internal frame has been closed.
      void InternalFrameListener.internalFrameClosed(InternalFrameEvent e)
      Invoked when an internal frame has been closed.
      void InternalFrameAdapter.internalFrameClosing(InternalFrameEvent e)
      Invoked when an internal frame is in the process of being closed.
      void InternalFrameListener.internalFrameClosing(InternalFrameEvent e)
      Invoked when an internal frame is in the process of being closed.
      void InternalFrameAdapter.internalFrameDeactivated(InternalFrameEvent e)
      Invoked when an internal frame is de-activated.
      void InternalFrameListener.internalFrameDeactivated(InternalFrameEvent e)
      Invoked when an internal frame is de-activated.
      void InternalFrameAdapter.internalFrameDeiconified(InternalFrameEvent e)
      Invoked when an internal frame is de-iconified.
      void InternalFrameListener.internalFrameDeiconified(InternalFrameEvent e)
      Invoked when an internal frame is de-iconified.
      void InternalFrameAdapter.internalFrameIconified(InternalFrameEvent e)
      Invoked when an internal frame is iconified.
      void InternalFrameListener.internalFrameIconified(InternalFrameEvent e)
      Invoked when an internal frame is iconified.
      void InternalFrameAdapter.internalFrameOpened(InternalFrameEvent e)
      Invoked when an internal frame has been opened.
      void InternalFrameListener.internalFrameOpened(InternalFrameEvent e)
      Invoked when a internal frame has been opened.

    • Uses of InternalFrameEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type InternalFrameEvent
      修饰符与类型 | 方法与描述
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameActivated(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosed(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosing(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeactivated(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeiconified(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameIconified(InternalFrameEvent e)
      void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameOpened(InternalFrameEvent e)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

say/rPl.Cn豯d/oeaa


Uses of Class javax.swing.event.ListDataEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.ListDataEvent

  • Packages that use ListDataEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of ListDataEvent in javax.swing

      Methods in javax.swing with parameters of type ListDataEvent
      修饰符与类型 方法与描述
      void JComboBox.contentsChanged(ListDataEvent e)
      This method is public as an implementation side effect.
      void JList.AccessibleJList.contentsChanged(ListDataEvent e)
      List Data Listener contents changed method.
      void JComboBox.intervalAdded(ListDataEvent e)
      This method is public as an implementation side effect.
      void JList.AccessibleJList.intervalAdded(ListDataEvent e)
      List Data Listener interval added method.
      void JComboBox.intervalRemoved(ListDataEvent e)
      This method is public as an implementation side effect.
      void JList.AccessibleJList.intervalRemoved(ListDataEvent e)
      List Data Listener interval removed method.

    • Uses of ListDataEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type ListDataEvent
      修饰符与类型 方法与描述
      void ListDataListener.contentsChanged(ListDataEvent e)
      Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
      void ListDataListener.intervalAdded(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been inserted in the data model.
      void ListDataListener.intervalRemoved(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been removed from the data model.

    • Uses of ListDataEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ListDataEvent
      修饰符与类型 | 方法与描述
      void | BasicListUI.ListDataHandler.contentsChanged(ListDataEvent e)
      void | BasicComboBoxUI.ListDataHandler.contentsChanged(ListDataEvent e)
      void | BasicComboPopup.ListDataHandler.contentsChanged(ListDataEvent e)
      void | BasicListUI.ListDataHandler.intervalAdded(ListDataEvent e)
      void BasicDirectoryModel.intervalAdded(ListDataEvent e)
      Obsolete - not used.
      void | BasicComboBoxUI.ListDataHandler.intervalAdded(ListDataEvent e)
      void | BasicComboPopup.ListDataHandler.intervalAdded(ListDataEvent e)
      void | BasicListUI.ListDataHandler.intervalRemoved(ListDataEvent e)
      void BasicDirectoryModel.intervalRemoved(ListDataEvent e)
      Obsolete - not used.
      void | BasicComboBoxUI.ListDataHandler.intervalRemoved(ListDataEvent e)
      void | BasicComboPopup.ListDataHandler.intervalRemoved(ListDataEvent e)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et ont ta,eaf腚"�.bo..g�


Uses of Class javax.swing.event.ListSelectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.ListSelectionEvent

  • Packages that use ListSelectionEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of ListSelectionEvent in javax.swing

      Methods in javax.swing with parameters of type ListSelectionEvent
      修饰符与类型 方法与描述
      void JTable.columnSelectionChanged(ListSelectionEvent e)
      Invoked when the selection model of the TableColumnModel is changed.
      void JTable.AccessibleJTable.columnSelectionChanged(ListSelectionEvent e)
      Track that the selection model of the TableColumnModel changed.
      void JTable.valueChanged(ListSelectionEvent e)
      Invoked when the row selection changes -- repaints to show the new selection.
      void JTable.AccessibleJTable.valueChanged(ListSelectionEvent e)
      Track changes to table cell selections
      void JList.AccessibleJList.valueChanged(ListSelectionEvent e)
      List Selection Listener value change method.

    • Uses of ListSelectionEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type ListSelectionEvent
      修饰符与类型 方法与描述
      void TableColumnModelListener.columnSelectionChanged(ListSelectionEvent e)
      Tells listeners that the selection model of the TableColumnModel changed.
      void ListSelectionListener.valueChanged(ListSelectionEvent e)
      Called whenever the value of the selection changes.

    • Uses of ListSelectionEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type ListSelectionEvent
      修饰符与类型 | 方法与描述
      void | BasicListUI.ListSelectionHandler.valueChanged(ListSelectionEvent e)
      void | BasicFileChooserUI.SelectionListener.valueChanged(ListSelectionEvent e)
      void | BasicComboPopup.ListSelectionHandler.valueChanged(ListSelectionEvent e)

    • Uses of ListSelectionEvent in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type ListSelectionEvent
      修饰符与类型 | 方法与描述
      void | MetalFileChooserUI.valueChanged(ListSelectionEvent e)

    • Uses of ListSelectionEvent in javax.swing.table

      Methods in javax.swing.table with parameters of type ListSelectionEvent
      修饰符与类型 方法与描述
      void JTableHeader.columnSelectionChanged(ListSelectionEvent e)
      Invoked when the selection model of the TableColumnModel is changed.
      protected void DefaultTableColumnModel.fireColumnSelectionChanged(ListSelectionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      void DefaultTableColumnModel.valueChanged(ListSelectionEvent e)
      A ListSelectionListener that forwards ListSelectionEvents when there is a column selection change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Jnaltek_niL>aDnnhh�>抖.f


Uses of Class javax.swing.event.MenuDragMouseEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.MenuDragMouseEvent

  • Packages that use MenuDragMouseEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of MenuDragMouseEvent in javax.swing

      Methods in javax.swing with parameters of type MenuDragMouseEvent
      修饰符与类型 方法与描述
      protected void JMenuItem.fireMenuDragMouseDragged(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void JMenuItem.fireMenuDragMouseEntered(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void JMenuItem.fireMenuDragMouseExited(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void JMenuItem.fireMenuDragMouseReleased(MenuDragMouseEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      void JMenuItem.processMenuDragMouseEvent(MenuDragMouseEvent e)
      Handles mouse drag in a menu.

    • Uses of MenuDragMouseEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type MenuDragMouseEvent
      修饰符与类型 方法与描述
      void MenuDragMouseListener.menuDragMouseDragged(MenuDragMouseEvent e)
      Invoked when the mouse is being dragged in a menu component's display area.
      void MenuDragMouseListener.menuDragMouseEntered(MenuDragMouseEvent e)
      Invoked when the dragged mouse has entered a menu component's display area.
      void MenuDragMouseListener.menuDragMouseExited(MenuDragMouseEvent e)
      Invoked when the dragged mouse has left a menu component's display area.
      void MenuDragMouseListener.menuDragMouseReleased(MenuDragMouseEvent e)
      Invoked when a dragged mouse is release in a menu component's display area.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c ooassht >i//Lsewvioe;


Uses of Class javax.swing.event.MenuEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.MenuEvent

  • Packages that use MenuEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of MenuEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type MenuEvent
      修饰符与类型 方法与描述
      void MenuListener.menuCanceled(MenuEvent e)
      Invoked when the menu is canceled.
      void MenuListener.menuDeselected(MenuEvent e)
      Invoked when the menu is deselected.
      void MenuListener.menuSelected(MenuEvent e)
      Invoked when a menu is selected.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lsac> <<>///orMMsnelt ai<


Uses of Class javax.swing.event.MenuKeyEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.MenuKeyEvent

  • Packages that use MenuKeyEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of MenuKeyEvent in javax.swing

      Methods in javax.swing with parameters of type MenuKeyEvent
      修饰符与类型 方法与描述
      protected void JMenuItem.fireMenuKeyPressed(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void JMenuItem.fireMenuKeyReleased(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void JMenuItem.fireMenuKeyTyped(MenuKeyEvent event)
      Notifies all listeners that have registered interest for notification on this event type.
      void JMenuItem.processMenuKeyEvent(MenuKeyEvent e)
      Handles a keystroke in a menu.

    • Uses of MenuKeyEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type MenuKeyEvent
      修饰符与类型 方法与描述
      void MenuKeyListener.menuKeyPressed(MenuKeyEvent e)
      Invoked when a key has been pressed.
      void MenuKeyListener.menuKeyReleased(MenuKeyEvent e)
      Invoked when a key has been released.
      void MenuKeyListener.menuKeyTyped(MenuKeyEvent e)
      Invoked when a key has been typed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aL.cs= ec/./hoiv=cavt.B


Uses of Class javax.swing.event.MouseInputAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.MouseInputAdapter

  • Packages that use MouseInputAdapter
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MouseInputAdapter in javax.swing.plaf.basic

      Subclasses of MouseInputAdapter in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicDesktopIconUI.MouseInputHandler
      Listens for mouse movements and acts on them.
      protected class  BasicInternalFrameUI.BorderListener
      Listens for border adjustments.
      class  BasicSliderUI.TrackListener
      Track mouse movements.
      Fields in javax.swing.plaf.basic declared as MouseInputAdapter
      修饰符与类型 | 字段与描述
      protected MouseInputAdapter | BasicInternalFrameUI.borderListener
      Methods in javax.swing.plaf.basic that return MouseInputAdapter
      修饰符与类型 | 方法与描述
      protected MouseInputAdapter | BasicInternalFrameUI.createBorderListener(JInternalFrame w)

    • Uses of MouseInputAdapter in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return MouseInputAdapter
      修饰符与类型 方法与描述
      protected MouseInputAdapter MetalInternalFrameUI.createBorderListener(JInternalFrame w)
      Returns the MouseInputAdapter that will be installed on the TitlePane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.=.- tet>ddo/oelek a>a eem


Uses of Class javax.swing.event.PopupMenuEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.PopupMenuEvent

  • Packages that use PopupMenuEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of PopupMenuEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type PopupMenuEvent
      修饰符与类型 方法与描述
      void PopupMenuListener.popupMenuCanceled(PopupMenuEvent e)
      This method is called when the popup menu is canceled
      void PopupMenuListener.popupMenuWillBecomeInvisible(PopupMenuEvent e)
      This method is called before the popup menu becomes invisible Note that a JPopupMenu can become invisible any time
      void PopupMenuListener.popupMenuWillBecomeVisible(PopupMenuEvent e)
      This method is called before the popup menu becomes visible
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eodttan>"IIIolcca ct"iia/


Uses of Class javax.swing.event.RowSorterEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.RowSorterEvent

  • Packages that use RowSorterEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of RowSorterEvent in javax.swing

      Methods in javax.swing with parameters of type RowSorterEvent
      修饰符与类型 方法与描述
      void JTable.sorterChanged(RowSorterEvent e)
      RowSorterListener notification that the RowSorter has changed in some way.

    • Uses of RowSorterEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type RowSorterEvent
      修饰符与类型 方法与描述
      void RowSorterListener.sorterChanged(RowSorterEvent e)
      Notification that the RowSorter has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eexexiif-iiid.hha.<> �


Uses of Class javax.swing.event.RowSorterEvent.Type

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.RowSorterEvent.Type

  • Packages that use RowSorterEvent.Type
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of RowSorterEvent.Type in javax.swing.event

      Methods in javax.swing.event that return RowSorterEvent.Type
      修饰符与类型 方法与描述
      RowSorterEvent.Type RowSorterEvent.getType()
      Returns the type of event.
      static RowSorterEvent.Type RowSorterEvent.Type.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static RowSorterEvent.Type[] RowSorterEvent.Type.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.swing.event with parameters of type RowSorterEvent.Type
      构造方法与描述
      RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
      Creates a RowSorterEvent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lst_,otmb_.onsddrt rne.


Uses of Class javax.swing.event.SwingPropertyChangeSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.SwingPropertyChangeSupport

  • Packages that use SwingPropertyChangeSupport
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of SwingPropertyChangeSupport in javax.swing

      Fields in javax.swing declared as SwingPropertyChangeSupport
      修饰符与类型 字段与描述
      protected SwingPropertyChangeSupport AbstractAction.changeSupport
      If any PropertyChangeListeners have been registered, the changeSupport field describes them.

    • Uses of SwingPropertyChangeSupport in javax.swing.tree

      Fields in javax.swing.tree declared as SwingPropertyChangeSupport
      修饰符与类型 字段与描述
      protected SwingPropertyChangeSupport DefaultTreeSelectionModel.changeSupport
      Used to messaged registered listeners.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nd/icvij>is > � dtelFelt


Uses of Class javax.swing.event.TableColumnModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.TableColumnModelEvent

  • Packages that use TableColumnModelEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableColumnModelEvent in javax.swing

      Methods in javax.swing with parameters of type TableColumnModelEvent
      修饰符与类型 方法与描述
      void JTable.columnAdded(TableColumnModelEvent e)
      Invoked when a column is added to the table column model.
      void JTable.AccessibleJTable.columnAdded(TableColumnModelEvent e)
      Track changes to the table contents (column insertions)
      void JTable.columnMoved(TableColumnModelEvent e)
      Invoked when a column is repositioned.
      void JTable.AccessibleJTable.columnMoved(TableColumnModelEvent e)
      Track changes of a column repositioning.
      void JTable.columnRemoved(TableColumnModelEvent e)
      Invoked when a column is removed from the table column model.
      void JTable.AccessibleJTable.columnRemoved(TableColumnModelEvent e)
      Track changes to the table contents (column deletions)

    • Uses of TableColumnModelEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type TableColumnModelEvent
      修饰符与类型 方法与描述
      void TableColumnModelListener.columnAdded(TableColumnModelEvent e)
      Tells listeners that a column was added to the model.
      void TableColumnModelListener.columnMoved(TableColumnModelEvent e)
      Tells listeners that a column was repositioned.
      void TableColumnModelListener.columnRemoved(TableColumnModelEvent e)
      Tells listeners that a column was removed from the model.

    • Uses of TableColumnModelEvent in javax.swing.table

      Methods in javax.swing.table with parameters of type TableColumnModelEvent
      修饰符与类型 方法与描述
      void JTableHeader.columnAdded(TableColumnModelEvent e)
      Invoked when a column is added to the table column model.
      void JTableHeader.columnMoved(TableColumnModelEvent e)
      Invoked when a column is repositioned.
      void JTableHeader.columnRemoved(TableColumnModelEvent e)
      Invoked when a column is removed from the table column model.
      protected void DefaultTableColumnModel.fireColumnAdded(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void DefaultTableColumnModel.fireColumnMoved(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void DefaultTableColumnModel.fireColumnRemoved(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ga> i


Uses of Class javax.swing.event.TableModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.TableModelEvent

  • Packages that use TableModelEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableModelEvent in javax.swing

      Methods in javax.swing with parameters of type TableModelEvent
      修饰符与类型 方法与描述
      void JTable.tableChanged(TableModelEvent e)
      Invoked when this table's TableModel generates a TableModelEvent.
      void JTable.AccessibleJTable.tableChanged(TableModelEvent e)
      Track changes to the table contents
      void JTable.AccessibleJTable.tableRowsDeleted(TableModelEvent e)
      Track changes to the table contents (row deletions)
      void JTable.AccessibleJTable.tableRowsInserted(TableModelEvent e)
      Track changes to the table contents (row insertions)

    • Uses of TableModelEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type TableModelEvent
      修饰符与类型 方法与描述
      void TableModelListener.tableChanged(TableModelEvent e)
      This fine grain notification tells listeners the exact range of cells, rows, or columns that changed.

    • Uses of TableModelEvent in javax.swing.table

      Methods in javax.swing.table with parameters of type TableModelEvent
      修饰符与类型 方法与描述
      void AbstractTableModel.fireTableChanged(TableModelEvent e)
      Forwards the given notification event to all TableModelListeners that registered themselves as listeners for this table model.
      void DefaultTableModel.newDataAvailable(TableModelEvent event)
      Equivalent to fireTableChanged.
      void DefaultTableModel.newRowsAdded(TableModelEvent e)
      Ensures that the new rows have the correct number of columns.
      void DefaultTableModel.rowsRemoved(TableModelEvent event)
      Equivalent to fireTableChanged.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

liutodeulma


Uses of Class javax.swing.event.TreeExpansionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.TreeExpansionEvent

  • Packages that use TreeExpansionEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeExpansionEvent in javax.swing

      Methods in javax.swing with parameters of type TreeExpansionEvent
      修饰符与类型 方法与描述
      void JTree.AccessibleJTree.treeCollapsed(TreeExpansionEvent e)
      Tree Collapsed notification.
      void JTree.AccessibleJTree.treeExpanded(TreeExpansionEvent e)
      Tree Model Expansion notification.

    • Uses of TreeExpansionEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type TreeExpansionEvent
      修饰符与类型 方法与描述
      void TreeExpansionListener.treeCollapsed(TreeExpansionEvent event)
      Called whenever an item in the tree has been collapsed.
      void TreeExpansionListener.treeExpanded(TreeExpansionEvent event)
      Called whenever an item in the tree has been expanded.
      void TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be collapsed.
      void TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be expanded.

    • Uses of TreeExpansionEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type TreeExpansionEvent
      修饰符与类型 方法与描述
      void BasicTreeUI.TreeExpansionHandler.treeCollapsed(TreeExpansionEvent event)
      Called whenever an item in the tree has been collapsed.
      void BasicTreeUI.TreeExpansionHandler.treeExpanded(TreeExpansionEvent event)
      Called whenever an item in the tree has been expanded.

    • Uses of TreeExpansionEvent in javax.swing.tree

      Fields in javax.swing.tree declared as TreeExpansionEvent
      修饰符与类型 字段与描述
      protected TreeExpansionEvent ExpandVetoException.event
      The event that the exception was created for.
      Constructors in javax.swing.tree with parameters of type TreeExpansionEvent
      构造方法与描述
      ExpandVetoException(TreeExpansionEvent event)
      Constructs an ExpandVetoException object with no message.
      ExpandVetoException(TreeExpansionEvent event, String message)
      Constructs an ExpandVetoException object with the specified message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= =Vy>RN V


Uses of Class javax.swing.event.TreeModelEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.TreeModelEvent

  • Packages that use TreeModelEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeModelEvent in javax.swing

      Methods in javax.swing with parameters of type TreeModelEvent
      修饰符与类型 | 方法与描述
      void | JTree.TreeModelHandler.treeNodesChanged(TreeModelEvent e)
      void JTree.AccessibleJTree.treeNodesChanged(TreeModelEvent e)
      Tree Model Node change notification.
      void | JTree.TreeModelHandler.treeNodesInserted(TreeModelEvent e)
      void JTree.AccessibleJTree.treeNodesInserted(TreeModelEvent e)
      Tree Model Node change notification.
      void | JTree.TreeModelHandler.treeNodesRemoved(TreeModelEvent e)
      void JTree.AccessibleJTree.treeNodesRemoved(TreeModelEvent e)
      Tree Model Node change notification.
      void | JTree.TreeModelHandler.treeStructureChanged(TreeModelEvent e)
      void JTree.AccessibleJTree.treeStructureChanged(TreeModelEvent e)
      Tree Model structure change change notification.

    • Uses of TreeModelEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type TreeModelEvent
      修饰符与类型 方法与描述
      void TreeModelListener.treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void TreeModelListener.treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void TreeModelListener.treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void TreeModelListener.treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

    • Uses of TreeModelEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type TreeModelEvent
      修饰符与类型 | 方法与描述
      void | BasicTreeUI.TreeModelHandler.treeNodesChanged(TreeModelEvent e)
      void | BasicTreeUI.TreeModelHandler.treeNodesInserted(TreeModelEvent e)
      void | BasicTreeUI.TreeModelHandler.treeNodesRemoved(TreeModelEvent e)
      void | BasicTreeUI.TreeModelHandler.treeStructureChanged(TreeModelEvent e)

    • Uses of TreeModelEvent in javax.swing.tree

      Methods in javax.swing.tree with parameters of type TreeModelEvent
      修饰符与类型 方法与描述
      void VariableHeightLayoutCache.treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void FixedHeightLayoutCache.treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      abstract void AbstractLayoutCache.treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void VariableHeightLayoutCache.treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void FixedHeightLayoutCache.treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      abstract void AbstractLayoutCache.treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void VariableHeightLayoutCache.treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void FixedHeightLayoutCache.treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      abstract void AbstractLayoutCache.treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void VariableHeightLayoutCache.treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.
      void FixedHeightLayoutCache.treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.
      abstract void AbstractLayoutCache.treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>T"/lndo|k).kenMb


Uses of Class javax.swing.event.TreeSelectionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.TreeSelectionEvent

  • Packages that use TreeSelectionEvent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeSelectionEvent in javax.swing

      Methods in javax.swing with parameters of type TreeSelectionEvent
      修饰符与类型 方法与描述
      protected void JTree.fireValueChanged(TreeSelectionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.TreeSelectionRedirector.valueChanged(TreeSelectionEvent e)
      Invoked by the TreeSelectionModel when the selection changes.
      void JTree.AccessibleJTree.valueChanged(TreeSelectionEvent e)
      Tree Selection Listener value change method.

    • Uses of TreeSelectionEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type TreeSelectionEvent
      修饰符与类型 方法与描述
      void TreeSelectionListener.valueChanged(TreeSelectionEvent e)
      Called whenever the value of the selection changes.

    • Uses of TreeSelectionEvent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type TreeSelectionEvent
      修饰符与类型 方法与描述
      void BasicTreeUI.TreeSelectionHandler.valueChanged(TreeSelectionEvent event)
      Messaged when the selection changes in the tree we're displaying for.

    • Uses of TreeSelectionEvent in javax.swing.tree

      Methods in javax.swing.tree with parameters of type TreeSelectionEvent
      修饰符与类型 方法与描述
      protected void DefaultTreeSelectionModel.fireValueChanged(TreeSelectionEvent e)
      Notifies all listeners that are registered for tree selection events on this object.
      void DefaultTreeCellEditor.valueChanged(TreeSelectionEvent e)
      Resets lastPath.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esro/Trveeeena..r.ormeo>e


Uses of Class javax.swing.event.UndoableEditEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.event.UndoableEditEvent

  • Packages that use UndoableEditEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of UndoableEditEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type UndoableEditEvent
      修饰符与类型 方法与描述
      void UndoableEditListener.undoableEditHappened(UndoableEditEvent e)
      An undoable edit happened

    • Uses of UndoableEditEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type UndoableEditEvent
      修饰符与类型 方法与描述
      protected void AbstractDocument.fireUndoableEditUpdate(UndoableEditEvent e)
      Notifies all listeners that have registered interest for notification on this event type.

    • Uses of UndoableEditEvent in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type UndoableEditEvent
      修饰符与类型 方法与描述
      protected void HTMLDocument.fireUndoableEditUpdate(UndoableEditEvent e)
      Notifies all listeners that have registered interest for notification on this event type.

    • Uses of UndoableEditEvent in javax.swing.undo

      Methods in javax.swing.undo with parameters of type UndoableEditEvent
      修饰符与类型 方法与描述
      void UndoManager.undoableEditHappened(UndoableEditEvent e)
      An UndoableEditListener method.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ao<"mseeh{lgg>aljw


Uses of Interface javax.swing.event.AncestorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.AncestorListener

  • Packages that use AncestorListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of AncestorListener in javax.swing

      Methods in javax.swing that return AncestorListener
      修饰符与类型 方法与描述
      AncestorListener[] JComponent.getAncestorListeners()
      Returns an array of all the ancestor listeners registered on this component.
      Methods in javax.swing with parameters of type AncestorListener
      修饰符与类型 方法与描述
      void JComponent.addAncestorListener(AncestorListener listener)
      Registers listener so that it will receive AncestorEvents when it or any of its ancestors move or are made visible or invisible.
      void JComponent.removeAncestorListener(AncestorListener listener)
      Unregisters listener so that it will no longer receive AncestorEvents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=>vev


Uses of Interface javax.swing.event.CaretListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.CaretListener

  • Packages that use CaretListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of CaretListener in javax.swing

      Classes in javax.swing that implement CaretListener
      修饰符与类型 类与描述
      protected class  JEditorPane.AccessibleJEditorPane
      This class implements accessibility support for the JEditorPane class.
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.
      protected class  JTextArea.AccessibleJTextArea
      This class implements accessibility support for the JTextArea class.
      protected class  JTextField.AccessibleJTextField
      This class implements accessibility support for the JTextField class.

    • Uses of CaretListener in javax.swing.text

      Classes in javax.swing.text that implement CaretListener
      修饰符与类型 类与描述
      class  JTextComponent.AccessibleJTextComponent
      This class implements accessibility support for the JTextComponent class.
      Methods in javax.swing.text that return CaretListener
      修饰符与类型 方法与描述
      CaretListener[] JTextComponent.getCaretListeners()
      Returns an array of all the caret listeners registered on this text component.
      Methods in javax.swing.text with parameters of type CaretListener
      修饰符与类型 方法与描述
      void JTextComponent.addCaretListener(CaretListener listener)
      Adds a caret listener for notification of any changes to the caret.
      void JTextComponent.removeCaretListener(CaretListener listener)
      Removes a caret listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d=


Uses of Interface javax.swing.event.CellEditorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.CellEditorListener

  • Packages that use CellEditorListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of CellEditorListener in javax.swing

      Classes in javax.swing that implement CellEditorListener
      修饰符与类型 类与描述
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.
      Methods in javax.swing that return CellEditorListener
      修饰符与类型 方法与描述
      CellEditorListener[] AbstractCellEditor.getCellEditorListeners()
      Returns an array of all the CellEditorListeners added to this AbstractCellEditor with addCellEditorListener().
      Methods in javax.swing with parameters of type CellEditorListener
      修饰符与类型 方法与描述
      void AbstractCellEditor.addCellEditorListener(CellEditorListener l)
      Adds a CellEditorListener to the listener list.
      void CellEditor.addCellEditorListener(CellEditorListener l)
      Adds a listener to the list that's notified when the editor stops, or cancels editing.
      void AbstractCellEditor.removeCellEditorListener(CellEditorListener l)
      Removes a CellEditorListener from the listener list.
      void CellEditor.removeCellEditorListener(CellEditorListener l)
      Removes a listener from the list that's notified

    • Uses of CellEditorListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement CellEditorListener
      修饰符与类型 类与描述
      class  BasicTreeUI.CellEditorHandler
      Listener responsible for getting cell editing events and updating the tree accordingly.
      Methods in javax.swing.plaf.basic that return CellEditorListener
      修饰符与类型 方法与描述
      protected CellEditorListener BasicTreeUI.createCellEditorListener()
      Creates a listener to handle events from the current editor.

    • Uses of CellEditorListener in javax.swing.tree

      Methods in javax.swing.tree that return CellEditorListener
      修饰符与类型 方法与描述
      CellEditorListener[] DefaultTreeCellEditor.getCellEditorListeners()
      Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().
      Methods in javax.swing.tree with parameters of type CellEditorListener
      修饰符与类型 方法与描述
      void DefaultTreeCellEditor.addCellEditorListener(CellEditorListener l)
      Adds the CellEditorListener.
      void DefaultTreeCellEditor.removeCellEditorListener(CellEditorListener l)
      Removes the previously added CellEditorListener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

viaa1etr-a>rud/sil.he �=�


Uses of Interface javax.swing.event.ChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.ChangeListener

  • Packages that use ChangeListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.colorchooser
    Contains classes and interfaces used by the JColorChooser component.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of ChangeListener in javax.swing

      Classes in javax.swing that implement ChangeListener
      修饰符与类型 类与描述
      protected class  AbstractButton.ButtonChangeListener
      Extends ChangeListener to be serializable.
      protected class  JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
      This class implements accessibility support for the JCheckBoxMenuItem class.
      protected class  JMenu.AccessibleJMenu
      This class implements accessibility support for the JMenu class.
      protected class  JMenuItem.AccessibleJMenuItem
      This class implements accessibility support for the JMenuItem class.
      protected class  JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
      This class implements accessibility support for the JRadioButtonMenuItem class.
      protected class  JScrollPane.AccessibleJScrollPane
      This class implements accessibility support for the JScrollPane class.
      protected class  JSpinner.AccessibleJSpinner
      AccessibleJSpinner implements accessibility support for the JSpinner class.
      static class  JSpinner.DateEditor
      An editor for a JSpinner whose model is a SpinnerDateModel.
      static class  JSpinner.DefaultEditor
      A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
      static class  JSpinner.ListEditor
      An editor for a JSpinner whose model is a SpinnerListModel.
      static class  JSpinner.NumberEditor
      An editor for a JSpinner whose model is a SpinnerNumberModel.
      protected class  JTabbedPane.AccessibleJTabbedPane
      This class implements accessibility support for the JTabbedPane class.
      protected class  JTabbedPane.ModelListener
      We pass ModelChanged events along to the listeners with the tabbedpane (instead of the model itself) as the event source.
      protected class  ProgressMonitor.AccessibleProgressMonitor
      AccessibleProgressMonitor implements accessibility support for the ProgressMonitor class.
      Fields in javax.swing declared as ChangeListener
      修饰符与类型 字段与描述
      protected ChangeListener JProgressBar.changeListener
      Listens for change events sent by the progress bar's model, redispatching them to change-event listeners registered upon this progress bar.
      protected ChangeListener JSlider.changeListener
      The changeListener (no suffix) is the listener we add to the slider's model.
      protected ChangeListener JTabbedPane.changeListener
      The changeListener is the listener we add to the model.
      protected ChangeListener AbstractButton.changeListener
      The button model's changeListener.
      Methods in javax.swing that return ChangeListener
      修饰符与类型 方法与描述
      protected ChangeListener JProgressBar.createChangeListener()
      Subclasses that want to handle change events from the model differently can override this to return an instance of a custom ChangeListener implementation.
      protected ChangeListener JSlider.createChangeListener()
      Subclasses that want to handle ChangeEvents from the model differently can override this to return an instance of a custom ChangeListener implementation.
      protected ChangeListener JTabbedPane.createChangeListener()
      Subclasses that want to handle ChangeEvents differently can override this to return a subclass of ModelListener or another ChangeListener implementation.
      protected ChangeListener AbstractButton.createChangeListener()
      Subclasses that want to handle ChangeEvents differently can override this to return another ChangeListener implementation.
      ChangeListener[] JProgressBar.getChangeListeners()
      Returns an array of all the ChangeListeners added to this progress bar with addChangeListener.
      ChangeListener[] JSlider.getChangeListeners()
      Returns an array of all the ChangeListeners added to this JSlider with addChangeListener().
      ChangeListener[] JSpinner.getChangeListeners()
      Returns an array of all the ChangeListeners added to this JSpinner with addChangeListener().
      ChangeListener[] AbstractSpinnerModel.getChangeListeners()
      Returns an array of all the ChangeListeners added to this AbstractSpinnerModel with addChangeListener().
      ChangeListener[] JTabbedPane.getChangeListeners()
      Returns an array of all the ChangeListeners added to this JTabbedPane with addChangeListener.
      ChangeListener[] DefaultBoundedRangeModel.getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultBoundedRangeModel.
      ChangeListener[] DefaultSingleSelectionModel.getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultSingleSelectionModel.
      ChangeListener[] DefaultButtonModel.getChangeListeners()
      Returns an array of all the change listeners registered on this DefaultButtonModel.
      ChangeListener[] JViewport.getChangeListeners()
      Returns an array of all the ChangeListeners added to this JViewport with addChangeListener().
      ChangeListener[] MenuSelectionManager.getChangeListeners()
      Returns an array of all the ChangeListeners added to this MenuSelectionManager with addChangeListener().
      ChangeListener[] AbstractButton.getChangeListeners()
      Returns an array of all the ChangeListeners added to this AbstractButton with addChangeListener().
      Methods in javax.swing with parameters of type ChangeListener
      修饰符与类型 方法与描述
      void JProgressBar.addChangeListener(ChangeListener l)
      Adds the specified ChangeListener to the progress bar.
      void JSlider.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the slider.
      void JSpinner.addChangeListener(ChangeListener listener)
      Adds a listener to the list that is notified each time a change to the model occurs.
      void SpinnerModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model's listener list.
      void AbstractSpinnerModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model's listener list.
      void JTabbedPane.addChangeListener(ChangeListener l)
      Adds a ChangeListener to this tabbedpane.
      void DefaultBoundedRangeModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener.
      void DefaultSingleSelectionModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      void DefaultButtonModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      void BoundedRangeModel.addChangeListener(ChangeListener x)
      Adds a ChangeListener to the model's listener list.
      void JViewport.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the list that is notified each time the view's size, position, or the viewport's extent size has changed.
      void ButtonModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      void MenuSelectionManager.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      void SingleSelectionModel.addChangeListener(ChangeListener listener)
      Adds listener as a listener to changes in the model.
      void AbstractButton.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the button.
      void JProgressBar.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the progress bar.
      void JSlider.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the slider.
      void JSpinner.removeChangeListener(ChangeListener listener)
      Removes a ChangeListener from this spinner.
      void SpinnerModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model's listener list.
      void AbstractSpinnerModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model's listener list.
      void JTabbedPane.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from this tabbedpane.
      void DefaultBoundedRangeModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener.
      void DefaultSingleSelectionModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.
      void DefaultButtonModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void BoundedRangeModel.removeChangeListener(ChangeListener x)
      Removes a ChangeListener from the model's listener list.
      void JViewport.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the list that's notified each time the views size, position, or the viewports extent size has changed.
      void ButtonModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void MenuSelectionManager.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.
      void SingleSelectionModel.removeChangeListener(ChangeListener listener)
      Removes listener as a listener to changes in the model.
      void AbstractButton.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the button.

    • Uses of ChangeListener in javax.swing.colorchooser

      Methods in javax.swing.colorchooser that return ChangeListener
      修饰符与类型 方法与描述
      ChangeListener[] DefaultColorSelectionModel.getChangeListeners()
      Returns an array of all the ChangeListeners added to this DefaultColorSelectionModel with addChangeListener.
      Methods in javax.swing.colorchooser with parameters of type ChangeListener
      修饰符与类型 方法与描述
      void DefaultColorSelectionModel.addChangeListener(ChangeListener l)
      Adds a ChangeListener to the model.
      void ColorSelectionModel.addChangeListener(ChangeListener listener)
      Adds listener as a listener to changes in the model.
      void DefaultColorSelectionModel.removeChangeListener(ChangeListener l)
      Removes a ChangeListener from the model.
      void ColorSelectionModel.removeChangeListener(ChangeListener listener)
      Removes listener as a listener to changes in the model.

    • Uses of ChangeListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ChangeListener
      修饰符与类型 类与描述
      class  BasicButtonListener
      Button Listener
      class  BasicMenuUI.ChangeHandler
      As of Java 2 platform 1.4, this previously undocumented class is now obsolete.
      class  BasicProgressBarUI.ChangeHandler
      This inner class is marked "public" due to a compiler bug.
      protected class  BasicScrollBarUI.ModelListener
      A listener to listen for model changes.
      class  BasicScrollPaneUI.HSBChangeListener
      Horizontal scrollbar listener.
      class  BasicScrollPaneUI.ViewportChangeHandler
      Listener for viewport events.
      class  BasicScrollPaneUI.VSBChangeListener
      Vertical scrollbar listener.
      class  BasicSliderUI.ChangeHandler
      Data model listener.
      class  BasicTabbedPaneUI.TabSelectionHandler
      This class should be treated as a "protected" inner class.
      Fields in javax.swing.plaf.basic declared as ChangeListener
      修饰符与类型 | 字段与描述
      protected ChangeListener | BasicSliderUI.changeListener
      protected ChangeListener | BasicProgressBarUI.changeListener
      protected ChangeListener | BasicMenuBarUI.changeListener
      protected ChangeListener | BasicMenuUI.changeListener
      protected ChangeListener | BasicScrollPaneUI.hsbChangeListener
      protected ChangeListener | BasicColorChooserUI.previewListener
      protected ChangeListener | BasicTabbedPaneUI.tabChangeListener
      protected ChangeListener | BasicScrollPaneUI.viewportChangeListener
      protected ChangeListener | BasicScrollPaneUI.vsbChangeListener
      Methods in javax.swing.plaf.basic that return ChangeListener
      修饰符与类型 | 方法与描述
      protected ChangeListener | BasicTabbedPaneUI.createChangeListener()
      protected ChangeListener | BasicMenuBarUI.createChangeListener()
      protected ChangeListener | BasicMenuUI.createChangeListener(JComponent c)
      protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
      protected ChangeListener | BasicScrollPaneUI.createHSBChangeListener()
      protected ChangeListener | BasicScrollPaneUI.createViewportChangeListener()
      protected ChangeListener | BasicScrollPaneUI.createVSBChangeListener()

    • Uses of ChangeListener in javax.swing.text

      Methods in javax.swing.text that return ChangeListener
      修饰符与类型 方法与描述
      ChangeListener[] StyleContext.getChangeListeners()
      Returns an array of all the ChangeListeners added to this StyleContext with addChangeListener().
      ChangeListener[] StyleContext.NamedStyle.getChangeListeners()
      Returns an array of all the ChangeListeners added to this NamedStyle with addChangeListener().
      ChangeListener[] DefaultCaret.getChangeListeners()
      Returns an array of all the change listeners registered on this caret.
      Methods in javax.swing.text with parameters of type ChangeListener
      修饰符与类型 方法与描述
      void StyleContext.addChangeListener(ChangeListener l)
      Adds a listener to track when styles are added or removed.
      void StyleContext.NamedStyle.addChangeListener(ChangeListener l)
      Adds a change listener.
      void Style.addChangeListener(ChangeListener l)
      Adds a listener to track whenever an attribute has been changed.
      void DefaultCaret.addChangeListener(ChangeListener l)
      Adds a listener to track whenever the caret position has been changed.
      void Caret.addChangeListener(ChangeListener l)
      Adds a listener to track whenever the caret position has been changed.
      void StyleContext.removeChangeListener(ChangeListener l)
      Removes a listener that was tracking styles being added or removed.
      void StyleContext.NamedStyle.removeChangeListener(ChangeListener l)
      Removes a change listener.
      void Style.removeChangeListener(ChangeListener l)
      Removes a listener that was tracking attribute changes.
      void DefaultCaret.removeChangeListener(ChangeListener l)
      Removes a listener that was tracking caret position changes.
      void Caret.removeChangeListener(ChangeListener l)
      Removes a listener that was tracking caret position changes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.event.DocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.DocumentEvent

  • Packages that use DocumentEvent
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of DocumentEvent in javax.swing.event

      Methods in javax.swing.event with parameters of type DocumentEvent
      修饰符与类型 方法与描述
      void DocumentListener.changedUpdate(DocumentEvent e)
      Gives notification that an attribute or set of attributes changed.
      void DocumentListener.insertUpdate(DocumentEvent e)
      Gives notification that there was an insert into the document.
      void DocumentListener.removeUpdate(DocumentEvent e)
      Gives notification that a portion of the document has been removed.

    • Uses of DocumentEvent in javax.swing.text

      Classes in javax.swing.text that implement DocumentEvent
      修饰符与类型 类与描述
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      Methods in javax.swing.text with parameters of type DocumentEvent
      修饰符与类型 | 方法与描述
      void JTextComponent.AccessibleJTextComponent.changedUpdate(DocumentEvent e)
      Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected void AbstractDocument.fireChangedUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void AbstractDocument.fireInsertUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void AbstractDocument.fireRemoveUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      protected void BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the DocumentEvent to the give child view.
      void JTextComponent.AccessibleJTextComponent.insertUpdate(DocumentEvent e)
      Handles document insert (fire appropriate property change event which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was inserted into the document in a location that the given flow view is responsible for.
      void JTextComponent.AccessibleJTextComponent.removeUpdate(DocumentEvent e)
      Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was removed from the document in a location that the given flow view is responsible for.
      protected boolean ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element.
      protected boolean View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for.
      protected void PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f)
      Repaint the region of change covered by the given document event.
      protected void AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Update the layout in response to receiving notification of change from the model.
      protected void View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Updates the layout in response to receiving notification of change from the model.

    • Uses of DocumentEvent in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type DocumentEvent
      修饰符与类型 | 方法与描述
      void ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Invoked when the Elements attributes have changed.
      void InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      protected void HTMLDocument.fireChangedUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      void InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.event.DocumentEvent.ElementChange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.DocumentEvent.ElementChange

  • Packages that use DocumentEvent.ElementChange
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DocumentEvent.ElementChange in javax.swing.event

      Methods in javax.swing.event that return DocumentEvent.ElementChange
      修饰符与类型 方法与描述
      DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
      Gets the change information for the given element.

    • Uses of DocumentEvent.ElementChange in javax.swing.text

      Classes in javax.swing.text that implement DocumentEvent.ElementChange
      修饰符与类型 类与描述
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      Methods in javax.swing.text that return DocumentEvent.ElementChange
      修饰符与类型 方法与描述
      DocumentEvent.ElementChange AbstractDocument.DefaultDocumentEvent.getChange(Element elem)
      Gets the changes for an element.
      Methods in javax.swing.text with parameters of type DocumentEvent.ElementChange
      修饰符与类型 | 方法与描述
      protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      protected void BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected boolean ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element.
      protected boolean View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for.
      protected void AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Update the layout in response to receiving notification of change from the model.
      protected void View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Updates the layout in response to receiving notification of change from the model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

daCeJSphtiiit eevarLe


Uses of Interface javax.swing.event.DocumentListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.DocumentListener

  • Packages that use DocumentListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DocumentListener in javax.swing

      Classes in javax.swing that implement DocumentListener
      修饰符与类型 类与描述
      protected class  JEditorPane.AccessibleJEditorPane
      This class implements accessibility support for the JEditorPane class.
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.
      protected class  JTextArea.AccessibleJTextArea
      This class implements accessibility support for the JTextArea class.
      protected class  JTextField.AccessibleJTextField
      This class implements accessibility support for the JTextField class.

    • Uses of DocumentListener in javax.swing.text

      Classes in javax.swing.text that implement DocumentListener
      修饰符与类型 类与描述
      class  JTextComponent.AccessibleJTextComponent
      This class implements accessibility support for the JTextComponent class.
      Methods in javax.swing.text that return DocumentListener
      修饰符与类型 方法与描述
      DocumentListener[] AbstractDocument.getDocumentListeners()
      Returns an array of all the document listeners registered on this document.
      Methods in javax.swing.text with parameters of type DocumentListener
      修饰符与类型 方法与描述
      void DefaultStyledDocument.addDocumentListener(DocumentListener listener)
      Adds a document listener for notification of any changes.
      void AbstractDocument.addDocumentListener(DocumentListener listener)
      Adds a document listener for notification of any changes.
      void Document.addDocumentListener(DocumentListener listener)
      Registers the given observer to begin receiving notifications when changes are made to the document.
      void DefaultStyledDocument.removeDocumentListener(DocumentListener listener)
      Removes a document listener.
      void AbstractDocument.removeDocumentListener(DocumentListener listener)
      Removes a document listener.
      void Document.removeDocumentListener(DocumentListener listener)
      Unregisters the given observer from the notification list so it will no longer receive change updates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tneh>finetttt...vw"a=/j>sD


Uses of Interface javax.swing.event.HyperlinkListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.HyperlinkListener

  • Packages that use HyperlinkListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of HyperlinkListener in javax.swing

      Methods in javax.swing that return HyperlinkListener
      修饰符与类型 方法与描述
      HyperlinkListener[] JEditorPane.getHyperlinkListeners()
      Returns an array of all the HyperLinkListeners added to this JEditorPane with addHyperlinkListener().
      Methods in javax.swing with parameters of type HyperlinkListener
      修饰符与类型 方法与描述
      void JEditorPane.addHyperlinkListener(HyperlinkListener listener)
      Adds a hyperlink listener for notification of any changes, for example when a link is selected and entered.
      void JEditorPane.removeHyperlinkListener(HyperlinkListener listener)
      Removes a hyperlink listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"/era/岩构筶l//=e a"rc/


Uses of Interface javax.swing.event.InternalFrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.InternalFrameListener

  • Packages that use InternalFrameListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of InternalFrameListener in javax.swing

      Methods in javax.swing that return InternalFrameListener
      修饰符与类型 方法与描述
      InternalFrameListener[] JInternalFrame.getInternalFrameListeners()
      Returns an array of all the InternalFrameListeners added to this JInternalFrame with addInternalFrameListener.
      Methods in javax.swing with parameters of type InternalFrameListener
      修饰符与类型 方法与描述
      void JInternalFrame.addInternalFrameListener(InternalFrameListener l)
      Adds the specified listener to receive internal frame events from this internal frame.
      void JInternalFrame.removeInternalFrameListener(InternalFrameListener l)
      Removes the specified internal frame listener so that it no longer receives internal frame events from this internal frame.

    • Uses of InternalFrameListener in javax.swing.event

      Classes in javax.swing.event that implement InternalFrameListener
      修饰符与类型 类与描述
      class  InternalFrameAdapter
      An abstract adapter class for receiving internal frame events.

    • Uses of InternalFrameListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement InternalFrameListener
      修饰符与类型 | 类与描述
      protected class  | BasicInternalFrameUI.BasicInternalFrameListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

assivax=e"""nillftkscokcpl


Uses of Interface javax.swing.event.ListDataListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.ListDataListener

  • Packages that use ListDataListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of ListDataListener in javax.swing

      Classes in javax.swing that implement ListDataListener
      修饰符与类型 类与描述
      class  JComboBox
      A component that combines a button or editable field and a drop-down list.
      protected class  JList.AccessibleJList
      This class implements accessibility support for the JList class.
      Methods in javax.swing that return ListDataListener
      修饰符与类型 方法与描述
      ListDataListener[] AbstractListModel.getListDataListeners()
      Returns an array of all the list data listeners registered on this AbstractListModel.
      Methods in javax.swing with parameters of type ListDataListener
      修饰符与类型 方法与描述
      void AbstractListModel.addListDataListener(ListDataListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      void ListModel.addListDataListener(ListDataListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      void AbstractListModel.removeListDataListener(ListDataListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.
      void ListModel.removeListDataListener(ListDataListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.

    • Uses of ListDataListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ListDataListener
      修饰符与类型 类与描述
      class  BasicComboBoxUI.ListDataHandler
      This listener watches for changes in the ComboBoxModel.
      class  BasicComboPopup.ListDataHandler
      As of 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
      class  BasicListUI.ListDataHandler
      The ListDataListener that's added to the JLists model at installUI time, and whenever the JList.model property changes.
      Fields in javax.swing.plaf.basic declared as ListDataListener
      修饰符与类型 | 字段与描述
      protected ListDataListener | BasicListUI.listDataListener
      protected ListDataListener BasicComboBoxUI.listDataListener
      This protected field is implementation specific.
      protected ListDataListener BasicComboPopup.listDataListener
      This protected field is implementation specific.
      Methods in javax.swing.plaf.basic that return ListDataListener
      修饰符与类型 方法与描述
      protected ListDataListener BasicListUI.createListDataListener()
      Creates an instance of ListDataListener that's added to the JLists by model as needed.
      protected ListDataListener BasicComboBoxUI.createListDataListener()
      Creates a list data listener which will be added to the ComboBoxModel.
      protected ListDataListener BasicComboPopup.createListDataListener()
      Creates a list data listener which will be added to the ComboBoxModel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s pyns.s.yeiys {_pbanbatt=


Uses of Interface javax.swing.event.ListSelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.ListSelectionListener

  • Packages that use ListSelectionListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of ListSelectionListener in javax.swing

      Classes in javax.swing that implement ListSelectionListener
      修饰符与类型 类与描述
      protected class  JList.AccessibleJList
      This class implements accessibility support for the JList class.
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.
      Methods in javax.swing that return ListSelectionListener
      修饰符与类型 方法与描述
      ListSelectionListener[] DefaultListSelectionModel.getListSelectionListeners()
      Returns an array of all the list selection listeners registered on this DefaultListSelectionModel.
      ListSelectionListener[] JList.getListSelectionListeners()
      Returns an array of all the ListSelectionListeners added to this JList by way of addListSelectionListener.
      Methods in javax.swing with parameters of type ListSelectionListener
      修饰符与类型 方法与描述
      void DefaultListSelectionModel.addListSelectionListener(ListSelectionListener l)
      Add a listener to the list that's notified each time a change to the selection occurs.
      void ListSelectionModel.addListSelectionListener(ListSelectionListener x)
      Add a listener to the list that's notified each time a change to the selection occurs.
      void JList.addListSelectionListener(ListSelectionListener listener)
      Adds a listener to the list, to be notified each time a change to the selection occurs; the preferred way of listening for selection state changes.
      void DefaultListSelectionModel.removeListSelectionListener(ListSelectionListener l)
      Remove a listener from the list that's notified each time a change to the selection occurs.
      void ListSelectionModel.removeListSelectionListener(ListSelectionListener x)
      Remove a listener from the list that's notified each time a change to the selection occurs.
      void JList.removeListSelectionListener(ListSelectionListener listener)
      Removes a selection listener from the list.

    • Uses of ListSelectionListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ListSelectionListener
      修饰符与类型 | 类与描述
      protected class  BasicComboPopup.ListSelectionHandler
      As of Java 2 platform v 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
      protected class  | BasicFileChooserUI.SelectionListener
      class  BasicListUI.ListSelectionHandler
      The ListSelectionListener that's added to the JLists selection model at installUI time, and whenever the JList.selectionModel property changes.
      Fields in javax.swing.plaf.basic declared as ListSelectionListener
      修饰符与类型 | 字段与描述
      protected ListSelectionListener | BasicListUI.listSelectionListener
      protected ListSelectionListener BasicComboPopup.listSelectionListener
      This protected field is implementation specific.
      Methods in javax.swing.plaf.basic that return ListSelectionListener
      修饰符与类型 | 方法与描述
      protected ListSelectionListener BasicListUI.createListSelectionListener()
      Creates an instance of ListSelectionHandler that's added to the JLists by selectionModel as needed.
      protected ListSelectionListener BasicComboPopup.createListSelectionListener()
      Creates a list selection listener that watches for selection changes in the popup's list.
      ListSelectionListener | BasicFileChooserUI.createListSelectionListener(JFileChooser fc)

    • Uses of ListSelectionListener in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return ListSelectionListener
      修饰符与类型 方法与描述
      ListSelectionListener MetalFileChooserUI.createListSelectionListener(JFileChooser fc)
      Creates a selection listener for the list of files and directories.

    • Uses of ListSelectionListener in javax.swing.table

      Classes in javax.swing.table that implement ListSelectionListener
      修饰符与类型 类与描述
      class  DefaultTableColumnModel
      The standard column-handler for a JTable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>nd>euf=/tyknbAbl svilr


Uses of Interface javax.swing.event.MenuDragMouseListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.MenuDragMouseListener

  • Packages that use MenuDragMouseListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of MenuDragMouseListener in javax.swing

      Methods in javax.swing that return MenuDragMouseListener
      修饰符与类型 方法与描述
      MenuDragMouseListener[] JMenuItem.getMenuDragMouseListeners()
      Returns an array of all the MenuDragMouseListeners added to this JMenuItem with addMenuDragMouseListener().
      Methods in javax.swing with parameters of type MenuDragMouseListener
      修饰符与类型 方法与描述
      void JMenuItem.addMenuDragMouseListener(MenuDragMouseListener l)
      Adds a MenuDragMouseListener to the menu item.
      void JMenuItem.removeMenuDragMouseListener(MenuDragMouseListener l)
      Removes a MenuDragMouseListener from the menu item.

    • Uses of MenuDragMouseListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as MenuDragMouseListener
      修饰符与类型 | 字段与描述
      protected MenuDragMouseListener | BasicMenuItemUI.menuDragMouseListener
      Methods in javax.swing.plaf.basic that return MenuDragMouseListener
      修饰符与类型 | 方法与描述
      protected MenuDragMouseListener | BasicMenuUI.createMenuDragMouseListener(JComponent c)
      protected MenuDragMouseListener | BasicMenuItemUI.createMenuDragMouseListener(JComponent c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/>/te er/>boa创oel- =<<=a


Uses of Interface javax.swing.event.MenuKeyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.MenuKeyListener

  • Packages that use MenuKeyListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of MenuKeyListener in javax.swing

      Methods in javax.swing that return MenuKeyListener
      修饰符与类型 方法与描述
      MenuKeyListener[] JMenuItem.getMenuKeyListeners()
      Returns an array of all the MenuKeyListeners added to this JMenuItem with addMenuKeyListener().
      MenuKeyListener[] JPopupMenu.getMenuKeyListeners()
      Returns an array of all the MenuKeyListeners added to this JPopupMenu with addMenuKeyListener().
      Methods in javax.swing with parameters of type MenuKeyListener
      修饰符与类型 方法与描述
      void JMenuItem.addMenuKeyListener(MenuKeyListener l)
      Adds a MenuKeyListener to the menu item.
      void JPopupMenu.addMenuKeyListener(MenuKeyListener l)
      Adds a MenuKeyListener to the popup menu.
      void JMenuItem.removeMenuKeyListener(MenuKeyListener l)
      Removes a MenuKeyListener from the menu item.
      void JPopupMenu.removeMenuKeyListener(MenuKeyListener l)
      Removes a MenuKeyListener from the popup menu.

    • Uses of MenuKeyListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as MenuKeyListener
      修饰符与类型 | 字段与描述
      protected MenuKeyListener | BasicMenuItemUI.menuKeyListener
      Methods in javax.swing.plaf.basic that return MenuKeyListener
      修饰符与类型 | 方法与描述
      protected MenuKeyListener | BasicMenuUI.createMenuKeyListener(JComponent c)
      protected MenuKeyListener | BasicMenuItemUI.createMenuKeyListener(JComponent c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r cif<"osand


Uses of Interface javax.swing.event.MenuListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.MenuListener

  • Packages that use MenuListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of MenuListener in javax.swing

      Methods in javax.swing that return MenuListener
      修饰符与类型 方法与描述
      MenuListener[] JMenu.getMenuListeners()
      Returns an array of all the MenuListeners added to this JMenu with addMenuListener().
      Methods in javax.swing with parameters of type MenuListener
      修饰符与类型 方法与描述
      void JMenu.addMenuListener(MenuListener l)
      Adds a listener for menu events.
      void JMenu.removeMenuListener(MenuListener l)
      Removes a listener for menu events.

    • Uses of MenuListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as MenuListener
      修饰符与类型 | 字段与描述
      protected MenuListener | BasicMenuUI.menuListener
      Methods in javax.swing.plaf.basic that return MenuListener
      修饰符与类型 | 方法与描述
      protected MenuListener | BasicMenuUI.createMenuListener(JComponent c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"rn"tom"=bbba RR>lvl>bl tA


Uses of Interface javax.swing.event.MouseInputListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.MouseInputListener

  • Packages that use MouseInputListener
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MouseInputListener in javax.swing.event

      Classes in javax.swing.event that implement MouseInputListener
      修饰符与类型 类与描述
      class  MouseInputAdapter
      An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest.

    • Uses of MouseInputListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement MouseInputListener
      修饰符与类型 | 类与描述
      class  BasicDesktopIconUI.MouseInputHandler
      Listens for mouse movements and acts on them.
      protected class  BasicInternalFrameUI.BorderListener
      Listens for border adjustments.
      protected class  | BasicInternalFrameUI.GlassPaneDispatcher
      class  BasicListUI.MouseInputHandler
      Mouse input, and focus handling for JList.
      protected class  | BasicMenuItemUI.MouseInputHandler
      protected class  BasicMenuUI.MouseInputHandler
      Instantiated and used by a menu item to handle the current menu selection from mouse events.
      class  BasicSliderUI.TrackListener
      Track mouse movements.
      class  BasicTableHeaderUI.MouseInputHandler
      This inner class is marked "public" due to a compiler bug.
      class  BasicTableUI.MouseInputHandler
      This inner class is marked "public" due to a compiler bug.
      class  BasicToolBarUI.DockingListener
      This class should be treated as a "protected" inner class.
      class  BasicTreeUI.MouseInputHandler
      MouseInputHandler handles passing all mouse events, including mouse motion events, until the mouse is released to the destination it is constructed with.
      Fields in javax.swing.plaf.basic declared as MouseInputListener
      修饰符与类型 | 字段与描述
      protected MouseInputListener | BasicToolBarUI.dockingListener
      protected MouseInputListener | BasicInternalFrameUI.glassPaneDispatcher
      protected MouseInputListener | BasicTableHeaderUI.mouseInputListener
      protected MouseInputListener | BasicTableUI.mouseInputListener
      protected MouseInputListener | BasicListUI.mouseInputListener
      protected MouseInputListener | BasicMenuItemUI.mouseInputListener
      Methods in javax.swing.plaf.basic that return MouseInputListener
      修饰符与类型 | 方法与描述
      protected MouseInputListener | BasicToolBarUI.createDockingListener()
      protected MouseInputListener | BasicInternalFrameUI.createGlassPaneDispatcher()
      protected MouseInputListener BasicTableHeaderUI.createMouseInputListener()
      Creates the mouse listener for the JTableHeader.
      protected MouseInputListener BasicTableUI.createMouseInputListener()
      Creates the mouse listener for the JTable.
      protected MouseInputListener BasicListUI.createMouseInputListener()
      Creates a delegate that implements MouseInputListener.
      protected MouseInputListener | BasicDesktopIconUI.createMouseInputListener()
      protected MouseInputListener | BasicMenuUI.createMouseInputListener(JComponent c)
      protected MouseInputListener | BasicMenuItemUI.createMouseInputListener(JComponent c)

    • Uses of MouseInputListener in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement MouseInputListener
      修饰符与类型 | 类与描述
      protected class  | MetalToolBarUI.MetalDockingListener
      Methods in javax.swing.plaf.metal that return MouseInputListener
      修饰符与类型 | 方法与描述
      protected MouseInputListener | MetalToolBarUI.createDockingListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> "3 uaEvh/! atl


Uses of Interface javax.swing.event.PopupMenuListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.PopupMenuListener

  • Packages that use PopupMenuListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of PopupMenuListener in javax.swing

      Methods in javax.swing that return PopupMenuListener
      修饰符与类型 方法与描述
      PopupMenuListener[] JComboBox.getPopupMenuListeners()
      Returns an array of all the PopupMenuListeners added to this JComboBox with addPopupMenuListener().
      PopupMenuListener[] JPopupMenu.getPopupMenuListeners()
      Returns an array of all the PopupMenuListeners added to this JMenuItem with addPopupMenuListener().
      Methods in javax.swing with parameters of type PopupMenuListener
      修饰符与类型 方法与描述
      void JComboBox.addPopupMenuListener(PopupMenuListener l)
      Adds a PopupMenu listener which will listen to notification messages from the popup portion of the combo box.
      void JPopupMenu.addPopupMenuListener(PopupMenuListener l)
      Adds a PopupMenu listener.
      void JComboBox.removePopupMenuListener(PopupMenuListener l)
      Removes a PopupMenuListener.
      void JPopupMenu.removePopupMenuListener(PopupMenuListener l)
      Removes a PopupMenu listener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ta>/jfeee


Uses of Interface javax.swing.event.RowSorterListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.RowSorterListener

  • Packages that use RowSorterListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of RowSorterListener in javax.swing

      Classes in javax.swing that implement RowSorterListener
      修饰符与类型 类与描述
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      Methods in javax.swing with parameters of type RowSorterListener
      修饰符与类型 方法与描述
      void RowSorter.addRowSorterListener(RowSorterListener l)
      Adds a RowSorterListener to receive notification about this RowSorter.
      void RowSorter.removeRowSorterListener(RowSorterListener l)
      Removes a RowSorterListener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yu"gslCl"glpgl==b--t


Uses of Interface javax.swing.event.TableColumnModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TableColumnModelListener

  • Packages that use TableColumnModelListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableColumnModelListener in javax.swing

      Classes in javax.swing that implement TableColumnModelListener
      修饰符与类型 类与描述
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.

    • Uses of TableColumnModelListener in javax.swing.table

      Classes in javax.swing.table that implement TableColumnModelListener
      修饰符与类型 类与描述
      class  JTableHeader
      This is the object which manages the header of the JTable.
      Methods in javax.swing.table that return TableColumnModelListener
      修饰符与类型 方法与描述
      TableColumnModelListener[] DefaultTableColumnModel.getColumnModelListeners()
      Returns an array of all the column model listeners registered on this model.
      Methods in javax.swing.table with parameters of type TableColumnModelListener
      修饰符与类型 方法与描述
      void DefaultTableColumnModel.addColumnModelListener(TableColumnModelListener x)
      Adds a listener for table column model events.
      void TableColumnModel.addColumnModelListener(TableColumnModelListener x)
      Adds a listener for table column model events.
      void DefaultTableColumnModel.removeColumnModelListener(TableColumnModelListener x)
      Removes a listener for table column model events.
      void TableColumnModel.removeColumnModelListener(TableColumnModelListener x)
      Removes a listener for table column model events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fviooluballlllaabst>lCt ><


Uses of Interface javax.swing.event.TableModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TableModelListener

  • Packages that use TableModelListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableModelListener in javax.swing

      Classes in javax.swing that implement TableModelListener
      修饰符与类型 类与描述
      class  JTable
      The JTable is used to display and edit regular two-dimensional tables of cells.
      protected class  JTable.AccessibleJTable
      This class implements accessibility support for the JTable class.

    • Uses of TableModelListener in javax.swing.table

      Methods in javax.swing.table that return TableModelListener
      修饰符与类型 方法与描述
      TableModelListener[] AbstractTableModel.getTableModelListeners()
      Returns an array of all the table model listeners registered on this model.
      Methods in javax.swing.table with parameters of type TableModelListener
      修饰符与类型 方法与描述
      void AbstractTableModel.addTableModelListener(TableModelListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      void TableModel.addTableModelListener(TableModelListener l)
      Adds a listener to the list that is notified each time a change to the data model occurs.
      void AbstractTableModel.removeTableModelListener(TableModelListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.
      void TableModel.removeTableModelListener(TableModelListener l)
      Removes a listener from the list that is notified each time a change to the data model occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p/


Uses of Interface javax.swing.event.TreeExpansionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TreeExpansionListener

  • Packages that use TreeExpansionListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of TreeExpansionListener in javax.swing

      Classes in javax.swing that implement TreeExpansionListener
      修饰符与类型 类与描述
      protected class  JTree.AccessibleJTree
      This class implements accessibility support for the JTree class.
      Methods in javax.swing that return TreeExpansionListener
      修饰符与类型 方法与描述
      TreeExpansionListener[] JTree.getTreeExpansionListeners()
      Returns an array of all the TreeExpansionListeners added to this JTree with addTreeExpansionListener().
      Methods in javax.swing with parameters of type TreeExpansionListener
      修饰符与类型 方法与描述
      void JTree.addTreeExpansionListener(TreeExpansionListener tel)
      Adds a listener for TreeExpansion events.
      void JTree.removeTreeExpansionListener(TreeExpansionListener tel)
      Removes a listener for TreeExpansion events.

    • Uses of TreeExpansionListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement TreeExpansionListener
      修饰符与类型 类与描述
      class  BasicTreeUI.TreeExpansionHandler
      Updates the TreeState in response to nodes expanding/collapsing.
      Methods in javax.swing.plaf.basic that return TreeExpansionListener
      修饰符与类型 方法与描述
      protected TreeExpansionListener BasicTreeUI.createTreeExpansionListener()
      Creates and returns the object responsible for updating the treestate when nodes expanded state changes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ree ersarmmm /...tar<=ast/


Uses of Interface javax.swing.event.TreeModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TreeModelListener

  • Packages that use TreeModelListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeModelListener in javax.swing

      Classes in javax.swing that implement TreeModelListener
      修饰符与类型 类与描述
      protected class  JTree.AccessibleJTree
      This class implements accessibility support for the JTree class.
      protected class  JTree.TreeModelHandler
      Listens to the model and updates the expandedState accordingly when nodes are removed, or changed.
      Fields in javax.swing declared as TreeModelListener
      修饰符与类型 字段与描述
      protected TreeModelListener JTree.treeModelListener
      Updates the expandedState.
      Methods in javax.swing that return TreeModelListener
      修饰符与类型 方法与描述
      protected TreeModelListener JTree.createTreeModelListener()
      Creates and returns an instance of TreeModelHandler.

    • Uses of TreeModelListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement TreeModelListener
      修饰符与类型 类与描述
      class  BasicTreeUI.TreeModelHandler
      Forwards all TreeModel events to the TreeState.
      Methods in javax.swing.plaf.basic that return TreeModelListener
      修饰符与类型 方法与描述
      protected TreeModelListener BasicTreeUI.createTreeModelListener()
      Returns a listener that can update the tree when the model changes.

    • Uses of TreeModelListener in javax.swing.tree

      Methods in javax.swing.tree that return TreeModelListener
      修饰符与类型 方法与描述
      TreeModelListener[] DefaultTreeModel.getTreeModelListeners()
      Returns an array of all the tree model listeners registered on this model.
      Methods in javax.swing.tree with parameters of type TreeModelListener
      修饰符与类型 方法与描述
      void DefaultTreeModel.addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      void TreeModel.addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      void DefaultTreeModel.removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener().
      void TreeModel.removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ady>tross===c"aac>s>yv>>gsa


Uses of Interface javax.swing.event.TreeSelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TreeSelectionListener

  • Packages that use TreeSelectionListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeSelectionListener in javax.swing

      Classes in javax.swing that implement TreeSelectionListener
      修饰符与类型 类与描述
      protected class  JTree.AccessibleJTree
      This class implements accessibility support for the JTree class.
      protected class  JTree.TreeSelectionRedirector
      Handles creating a new TreeSelectionEvent with the JTree as the source and passing it off to all the listeners.
      Methods in javax.swing that return TreeSelectionListener
      修饰符与类型 方法与描述
      TreeSelectionListener[] JTree.getTreeSelectionListeners()
      Returns an array of all the TreeSelectionListeners added to this JTree with addTreeSelectionListener().
      Methods in javax.swing with parameters of type TreeSelectionListener
      修饰符与类型 方法与描述
      void JTree.addTreeSelectionListener(TreeSelectionListener tsl)
      Adds a listener for TreeSelection events.
      void JTree.EmptySelectionModel.addTreeSelectionListener(TreeSelectionListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.removeTreeSelectionListener(TreeSelectionListener tsl)
      Removes a TreeSelection listener.
      void JTree.EmptySelectionModel.removeTreeSelectionListener(TreeSelectionListener listener)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.

    • Uses of TreeSelectionListener in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement TreeSelectionListener
      修饰符与类型 类与描述
      class  BasicTreeUI.TreeSelectionHandler
      Listens for changes in the selection model and updates the display accordingly.
      Methods in javax.swing.plaf.basic that return TreeSelectionListener
      修饰符与类型 方法与描述
      protected TreeSelectionListener BasicTreeUI.createTreeSelectionListener()
      Creates the listener that updates the display based on selection change methods.

    • Uses of TreeSelectionListener in javax.swing.tree

      Classes in javax.swing.tree that implement TreeSelectionListener
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor
      A TreeCellEditor.
      Methods in javax.swing.tree that return TreeSelectionListener
      修饰符与类型 方法与描述
      TreeSelectionListener[] DefaultTreeSelectionModel.getTreeSelectionListeners()
      Returns an array of all the tree selection listeners registered on this model.
      Methods in javax.swing.tree with parameters of type TreeSelectionListener
      修饰符与类型 方法与描述
      void DefaultTreeSelectionModel.addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      void TreeSelectionModel.addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      void DefaultTreeSelectionModel.removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
      void TreeSelectionModel.removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>seeNj)>->eennraev


Uses of Interface javax.swing.event.TreeWillExpandListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.TreeWillExpandListener

  • Packages that use TreeWillExpandListener
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of TreeWillExpandListener in javax.swing

      Methods in javax.swing that return TreeWillExpandListener
      修饰符与类型 方法与描述
      TreeWillExpandListener[] JTree.getTreeWillExpandListeners()
      Returns an array of all the TreeWillExpandListeners added to this JTree with addTreeWillExpandListener().
      Methods in javax.swing with parameters of type TreeWillExpandListener
      修饰符与类型 方法与描述
      void JTree.addTreeWillExpandListener(TreeWillExpandListener tel)
      Adds a listener for TreeWillExpand events.
      void JTree.removeTreeWillExpandListener(TreeWillExpandListener tel)
      Removes a listener for TreeWillExpand events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n>= cl ><<


Uses of Interface javax.swing.event.UndoableEditListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.event.UndoableEditListener

  • Packages that use UndoableEditListener
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of UndoableEditListener in javax.swing.text

      Methods in javax.swing.text that return UndoableEditListener
      修饰符与类型 方法与描述
      UndoableEditListener[] AbstractDocument.getUndoableEditListeners()
      Returns an array of all the undoable edit listeners registered on this document.
      Methods in javax.swing.text with parameters of type UndoableEditListener
      修饰符与类型 方法与描述
      void AbstractDocument.addUndoableEditListener(UndoableEditListener listener)
      Adds an undo listener for notification of any changes.
      void Document.addUndoableEditListener(UndoableEditListener listener)
      Registers the given observer to begin receiving notifications when undoable edits are made to the document.
      void AbstractDocument.removeUndoableEditListener(UndoableEditListener listener)
      Removes an undo listener.
      void Document.removeUndoableEditListener(UndoableEditListener listener)
      Unregisters the given observer from the notification list so it will no longer receive updates.

    • Uses of UndoableEditListener in javax.swing.undo

      Classes in javax.swing.undo that implement UndoableEditListener
      修饰符与类型 类与描述
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
      Fields in javax.swing.undo with type parameters of type UndoableEditListener
      修饰符与类型 | 字段与描述
      protected Vector<UndoableEditListener> | UndoableEditSupport.listeners
      Methods in javax.swing.undo that return UndoableEditListener
      修饰符与类型 方法与描述
      UndoableEditListener[] UndoableEditSupport.getUndoableEditListeners()
      Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().
      Methods in javax.swing.undo with parameters of type UndoableEditListener
      修饰符与类型 方法与描述
      void UndoableEditSupport.addUndoableEditListener(UndoableEditListener l)
      Registers an UndoableEditListener.
      void UndoableEditSupport.removeUndoableEditListener(UndoableEditListener l)
      Removes an UndoableEditListener.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ta/t e #eehtraait1=


FileFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.filechooser

类 FileFilter

  • java.lang.Object
    • javax.swing.filechooser.FileFilter
  • 直接已知子类：
    BasicFileChooserUI.AcceptAllFileFilter, FileNameExtensionFilter

    public abstract class FileFilter
extends Object
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user. See FileNameExtensionFilter for an implementation that filters using the file name extension.

    A FileFilter can be set on a JFileChooser to keep unwanted files from appearing in the directory listing. For an example implementation of a simple file filter, see yourJDK/demo/jfc/FileChooserDemo/ExampleFileFilter.java. For more information and examples see How to Use File Choosers, a section in The Java Tutorial.

    另请参见：
    FileNameExtensionFilter, JFileChooser.setFileFilter(javax.swing.filechooser.FileFilter), JFileChooser.addChoosableFileFilter(javax.swing.filechooser.FileFilter)

    • 构造方法摘要

      Constructors
      构造方法与描述
      FileFilter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean accept(File f)
      Whether the given file is accepted by this filter.
      abstract String getDescription()
      The description of this filter.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileFilter

        public FileFilter()

    • 方法详细信息

      • accept

        public abstract boolean accept(File f)
        Whether the given file is accepted by this filter.

      • getDescription

        public abstract String getDescription()
        The description of this filter. For example: "JPG and GIF Images"
        另请参见：
        FileView.getName(java.io.File)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcsn


FileNameExtensionFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.filechooser

类 FileNameExtensionFilter

  • java.lang.Object
    • javax.swing.filechooser.FileFilter
      • javax.swing.filechooser.FileNameExtensionFilter

  • public final class FileNameExtensionFilter
extends FileFilter
    An implementation of FileFilter that filters using a specified set of extensions. The extension for a file is the portion of the file name after the last ".". Files whose name does not contain a "." have no file name extension. File name extension comparisons are case insensitive.

    The following example creates a FileNameExtensionFilter that will show jpg files:

     FileFilter filter = new FileNameExtensionFilter("JPEG file", "jpg", "jpeg");
 JFileChooser fileChooser = ...;
 fileChooser.addChoosableFileFilter(filter);
    从以下版本开始：
    1.6
    另请参见：
    FileFilter,
JFileChooser.setFileFilter(javax.swing.filechooser.FileFilter),
JFileChooser.addChoosableFileFilter(javax.swing.filechooser.FileFilter),
JFileChooser.getFileFilter()

    • 构造方法摘要

      Constructors
      构造方法与描述
      FileNameExtensionFilter(String description, String... extensions)
      Creates a FileNameExtensionFilter with the specified description and file name extensions.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean accept(File f)
      Tests the specified file, returning true if the file is accepted, false otherwise.
      String getDescription()
      The description of this filter.
      String[] getExtensions()
      Returns the set of file name extensions files are tested against.
      String toString()
      Returns a string representation of the FileNameExtensionFilter.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FileNameExtensionFilter

        public FileNameExtensionFilter(String description,
                       String... extensions)
        Creates a FileNameExtensionFilter with the specified description and file name extensions. The returned FileNameExtensionFilter will accept all directories and any file with a file name extension contained in extensions.
        参数：
        描述 - textual description for the filter, may be null
        extensions - the accepted file name extensions
        抛出：
        IllegalArgumentException - if extensions is null, empty, contains null, or contains an empty string
        另请参见：
        accept(java.io.File)

    • 方法详细信息

      • accept

        public boolean accept(File f)
        Tests the specified file, returning true if the file is accepted, false otherwise. True is returned if the extension matches one of the file name extensions of this FileFilter, or the file is a directory.
        指定者：
        accept in class FileFilter
        参数：
        f - the File to test
        返回：
        true if the file is to be accepted, false otherwise

      • getDescription

        public String getDescription()
        The description of this filter. For example: "JPG and GIF Images."
        指定者：
        getDescription in class FileFilter
        返回：
        the description of this filter
        另请参见：
        FileView.getName(java.io.File)

      • getExtensions

        public String[] getExtensions()
        Returns the set of file name extensions files are tested against.
        返回：
        the set of file name extensions files are tested against

      • toString

        public String toString()
        Returns a string representation of the FileNameExtensionFilter. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class Object
        返回：
        a string representation of this FileNameExtensionFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se>=Tp "sn=nrn Ev a�>gg╥n rtoi


FileSystemView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.filechooser

类 FileSystemView

  • java.lang.Object
    • javax.swing.filechooser.FileSystemView

  • public abstract class FileSystemView
extends Object
    FileSystemView is JFileChooser's gateway to the file system. Since the JDK1.1 File API doesn't allow access to such information as root partitions, file type information, or hidden file bits, this class is designed to intuit as much OS-specific file system information as possible.

    Java Licensees may want to provide a different implementation of FileSystemView to better handle a given operating system.

    • 构造方法摘要

      Constructors
      构造方法与描述
      FileSystemView()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      File createFileObject(File dir, String filename)
      Returns a File object constructed in dir from the given filename.
      File createFileObject(String path)
      Returns a File object constructed from the given path string.
      protected File createFileSystemRoot(File f)
      Creates a new File object for f with correct behavior for a file system root directory.
      abstract File createNewFolder(File containingDir)
      Creates a new folder with a default folder name.
      File | getChild(File parent, String fileName)
      File getDefaultDirectory()
      Return the user's default starting directory for the file chooser.
      File[] getFiles(File dir, boolean useFileHiding)
      Gets the list of shown (i.e.
      static FileSystemView | getFileSystemView()
      File getHomeDirectory()
      File getParentDirectory(File dir)
      Returns the parent directory of dir.
      File[] getRoots()
      Returns all root partitions on this system.
      String getSystemDisplayName(File f)
      Name of a file, directory, or folder as it would be displayed in a system file browser.
      Icon getSystemIcon(File f)
      Icon for a file, directory, or folder as it would be displayed in a system file browser.
      String getSystemTypeDescription(File f)
      Type description for a file, directory, or folder as it would be displayed in a system file browser.
      boolean isComputerNode(File dir)
      Used by UI classes to decide whether to display a special icon for a computer node, e.g.
      boolean isDrive(File dir)
      Used by UI classes to decide whether to display a special icon for drives or partitions, e.g.
      boolean isFileSystem(File f)
      Checks if f represents a real directory or file as opposed to a special folder such as "Desktop".
      boolean isFileSystemRoot(File dir)
      Is dir the root of a tree in the file system, such as a drive or partition.
      boolean isFloppyDrive(File dir)
      Used by UI classes to decide whether to display a special icon for a floppy disk.
      boolean isHiddenFile(File f)
      Returns whether a file is hidden or not.
      boolean isParent(File folder, File file)
      On Windows, a file can appear in multiple folders, other than its parent directory in the filesystem.
      boolean isRoot(File f)
      Determines if the given file is a root in the navigatable tree(s).
      Boolean isTraversable(File f)
      Returns true if the file (directory) can be visited.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileSystemView

        public FileSystemView()

    • 方法详细信息

      • getFileSystemView

        public static FileSystemView getFileSystemView()

      • isRoot

        public boolean isRoot(File f)
        Determines if the given file is a root in the navigatable tree(s). Examples: Windows 98 has one root, the Desktop folder. DOS has one root per drive letter, C:\, D:\, etc. Unix has one root, the "/" directory. The default implementation gets information from the ShellFolder class.
        参数：
        f - a File object representing a directory
        返回：
        true if f is a root in the navigatable tree.
        另请参见：
        isFileSystemRoot(java.io.File)

      • isTraversable

        public Boolean isTraversable(File f)
        Returns true if the file (directory) can be visited. Returns false if the directory cannot be traversed.
        参数：
        f - the File
        返回：
        true if the file/directory can be traversed, otherwise false
        从以下版本开始：
        1.4
        另请参见：
        JFileChooser.isTraversable(java.io.File), FileView.isTraversable(java.io.File)

      • getSystemDisplayName

        public String getSystemDisplayName(File f)
        Name of a file, directory, or folder as it would be displayed in a system file browser. Example from Windows: the "M:\" directory displays as "CD-ROM (M:)" The default implementation gets information from the ShellFolder class.
        参数：
        f - a File object
        返回：
        the file name as it would be displayed by a native file chooser
        从以下版本开始：
        1.4
        另请参见：
        JFileChooser.getName(java.io.File)

      • getSystemTypeDescription

        public String getSystemTypeDescription(File f)
        Type description for a file, directory, or folder as it would be displayed in a system file browser. Example from Windows: the "Desktop" folder is desribed as "Desktop". Override for platforms with native ShellFolder implementations.
        参数：
        f - a File object
        返回：
        the file type description as it would be displayed by a native file chooser or null if no native information is available.
        从以下版本开始：
        1.4
        另请参见：
        JFileChooser.getTypeDescription(java.io.File)

      • getSystemIcon

        public Icon getSystemIcon(File f)
        Icon for a file, directory, or folder as it would be displayed in a system file browser. Example from Windows: the "M:\" directory displays a CD-ROM icon. The default implementation gets information from the ShellFolder class.
        参数：
        f - a File object
        返回：
        an icon as it would be displayed by a native file chooser
        从以下版本开始：
        1.4
        另请参见：
        JFileChooser.getIcon(java.io.File)

      • isParent

        public boolean isParent(File folder,
               File file)
        On Windows, a file can appear in multiple folders, other than its parent directory in the filesystem. Folder could for example be the "Desktop" folder which is not the same as file.getParentFile().
        参数：
        folder - a File object repesenting a directory or special folder
        file - a File object
        返回：
        true if folder is a directory or special folder and contains file.
        从以下版本开始：
        1.4

      • getChild

        public File getChild(File parent,
            String fileName)
        参数：
        parent - a File object repesenting a directory or special folder
        fileName - a name of a file or folder which exists in parent
        返回：
        a File object. This is normally constructed with new File(parent, fileName) except when parent and child are both special folders, in which case the File is a wrapper containing a ShellFolder object.
        从以下版本开始：
        1.4

      • isFileSystem

        public boolean isFileSystem(File f)
        Checks if f represents a real directory or file as opposed to a special folder such as "Desktop". Used by UI classes to decide if a folder is selectable when doing directory choosing.
        参数：
        f - a File object
        返回：
        true if f is a real file or directory.
        从以下版本开始：
        1.4

      • createNewFolder

        public abstract File createNewFolder(File containingDir)
                              throws IOException
        Creates a new folder with a default folder name.
        抛出：
        IOException

      • isHiddenFile

        public boolean isHiddenFile(File f)
        Returns whether a file is hidden or not.

      • isFileSystemRoot

        public boolean isFileSystemRoot(File dir)
        Is dir the root of a tree in the file system, such as a drive or partition. Example: Returns true for "C:\" on Windows 98.
        参数：
        dir - a File object representing a directory
        返回：
        true if f is a root of a filesystem
        从以下版本开始：
        1.4
        另请参见：
        isRoot(java.io.File)

      • isDrive

        public boolean isDrive(File dir)
        Used by UI classes to decide whether to display a special icon for drives or partitions, e.g. a "hard disk" icon. The default implementation has no way of knowing, so always returns false.
        参数：
        dir - a directory
        返回：
        false always
        从以下版本开始：
        1.4

      • isFloppyDrive

        public boolean isFloppyDrive(File dir)
        Used by UI classes to decide whether to display a special icon for a floppy disk. Implies isDrive(dir). The default implementation has no way of knowing, so always returns false.
        参数：
        dir - a directory
        返回：
        false always
        从以下版本开始：
        1.4

      • isComputerNode

        public boolean isComputerNode(File dir)
        Used by UI classes to decide whether to display a special icon for a computer node, e.g. "My Computer" or a network server. The default implementation has no way of knowing, so always returns false.
        参数：
        dir - a directory
        返回：
        false always
        从以下版本开始：
        1.4

      • getRoots

        public File[] getRoots()
        Returns all root partitions on this system. For example, on Windows, this would be the "Desktop" folder, while on DOS this would be the A: through Z: drives.

      • getHomeDirectory

        public File getHomeDirectory()

      • getDefaultDirectory

        public File getDefaultDirectory()
        Return the user's default starting directory for the file chooser.
        返回：
        a File object representing the default starting folder
        从以下版本开始：
        1.4

      • createFileObject

        public File createFileObject(File dir,
                    String filename)
        Returns a File object constructed in dir from the given filename.

      • createFileObject

        public File createFileObject(String path)
        Returns a File object constructed from the given path string.

      • getFiles

        public File[] getFiles(File dir,
              boolean useFileHiding)
        Gets the list of shown (i.e. not hidden) files.

      • getParentDirectory

        public File getParentDirectory(File dir)
        Returns the parent directory of dir.
        参数：
        dir - the File being queried
        返回：
        the parent directory of dir, or null if dir is null

      • createFileSystemRoot

        protected File createFileSystemRoot(File f)
        Creates a new File object for f with correct behavior for a file system root directory.
        参数：
        f - a File object representing a file system root directory, for example "/" on Unix or "C:\" on Windows.
        返回：
        a new File object
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FileView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.filechooser

类 FileView

  • java.lang.Object
    • javax.swing.filechooser.FileView
  • 直接已知子类：
    BasicFileChooserUI.BasicFileView

    public abstract class FileView
extends Object
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File. Each L&F JFileChooserUI object implements this class to pass back the correct icons and type descriptions specific to that L&F. For example, the Microsoft Windows L&F returns the generic Windows icons for directories and generic files. Additionally, you may want to provide your own FileView to JFileChooser to return different icons or additional information using JFileChooser.setFileView(javax.swing.filechooser.FileView).

    JFileChooser first looks to see if there is a user defined FileView, if there is, it gets type information from there first. If FileView returns null for any method, JFileChooser then uses the L&F specific view to get the information. So, for example, if you provide a FileView class that returns an Icon for JPG files, and returns null icons for all other files, the UI's FileView will provide default icons for all other files.

    For an example implementation of a simple file view, see yourJDK/demo/jfc/FileChooserDemo/ExampleFileView.java. For more information and examples see How to Use File Choosers, a section in The Java Tutorial.

    另请参见：
    JFileChooser

    • 构造方法摘要

      Constructors
      构造方法与描述
      FileView()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDescription(File f)
      A human readable description of the file.
      Icon getIcon(File f)
      The icon that represents this file in the JFileChooser.
      String getName(File f)
      The name of the file.
      String getTypeDescription(File f)
      A human readable description of the type of the file.
      Boolean isTraversable(File f)
      Whether the directory is traversable or not.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileView

        public FileView()

    • 方法详细信息

      • getName

        public String getName(File f)
        The name of the file. Normally this would be simply f.getName().

      • getDescription

        public String getDescription(File f)
        A human readable description of the file. For example, a file named jag.jpg might have a description that read: "A JPEG image file of James Gosling's face".

      • getTypeDescription

        public String getTypeDescription(File f)
        A human readable description of the type of the file. For example, a jpg file might have a type description of: "A JPEG Compressed Image File"

      • getIcon

        public Icon getIcon(File f)
        The icon that represents this file in the JFileChooser.

      • isTraversable

        public Boolean isTraversable(File f)
        Whether the directory is traversable or not. This might be useful, for example, if you want a directory to represent a compound document and don't want the user to descend into it.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"stoendena<


javax.swing.filechooser

Classes

  • FileFilter
  • FileNameExtensionFilter
  • FileSystemView
  • FileView
�


javax.swing.filechooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.filechooser

Contains classes and interfaces used by the JFileChooser component.

请参见： 描述

  • Class Summary
    类 描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileNameExtensionFilter
    An implementation of FileFilter that filters using a specified set of extensions.
    FileSystemView
    FileSystemView is JFileChooser's gateway to the file system.
    FileView
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.

软件包 javax.swing.filechooser Description

Contains classes and interfaces used by the JFileChooser component.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

This document forms the complete API specification. For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use File Choosers, a section in The Java Tutorial
  • Internationalization Documentation
  • Input Method Framework Documentation
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c


javax.swing.filechooser Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.filechooser

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.filechooser.FileFilter
      • javax.swing.filechooser.FileNameExtensionFilter
    • javax.swing.filechooser.FileSystemView
    • javax.swing.filechooser.FileView
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nvasoitaiiiv"ttc


Uses of Package javax.swing.filechooser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.filechooser

  • Packages that use javax.swing.filechooser
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.filechooser
    Contains classes and interfaces used by the JFileChooser component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
  • Classes in javax.swing.filechooser used by javax.swing
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileSystemView
    FileSystemView is JFileChooser's gateway to the file system.
    FileView
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
  • Classes in javax.swing.filechooser used by javax.swing.filechooser
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileSystemView
    FileSystemView is JFileChooser's gateway to the file system.
  • Classes in javax.swing.filechooser used by javax.swing.plaf
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileView
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
  • Classes in javax.swing.filechooser used by javax.swing.plaf.basic
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileView
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
  • Classes in javax.swing.filechooser used by javax.swing.plaf.metal
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
  • Classes in javax.swing.filechooser used by javax.swing.plaf.multi
    类与描述
    FileFilter
    FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
    FileView
    FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

="/n>imLfkv rS>= av


Uses of Class javax.swing.filechooser.FileFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.filechooser.FileFilter

  • Packages that use FileFilter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.filechooser
    Contains classes and interfaces used by the JFileChooser component.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of FileFilter in javax.swing

      Methods in javax.swing that return FileFilter
      修饰符与类型 方法与描述
      FileFilter JFileChooser.getAcceptAllFileFilter()
      Returns the AcceptAll file filter.
      FileFilter[] JFileChooser.getChoosableFileFilters()
      Gets the list of user choosable file filters.
      FileFilter JFileChooser.getFileFilter()
      Returns the currently selected file filter.
      Methods in javax.swing with parameters of type FileFilter
      修饰符与类型 方法与描述
      void JFileChooser.addChoosableFileFilter(FileFilter filter)
      Adds a filter to the list of user choosable file filters.
      boolean JFileChooser.removeChoosableFileFilter(FileFilter f)
      Removes a filter from the list of user choosable file filters.
      void JFileChooser.setFileFilter(FileFilter filter)
      Sets the current file filter.

    • Uses of FileFilter in javax.swing.filechooser

      Subclasses of FileFilter in javax.swing.filechooser
      修饰符与类型 类与描述
      class  FileNameExtensionFilter
      An implementation of FileFilter that filters using a specified set of extensions.

    • Uses of FileFilter in javax.swing.plaf

      Methods in javax.swing.plaf that return FileFilter
      修饰符与类型 | 方法与描述
      abstract FileFilter | FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)

    • Uses of FileFilter in javax.swing.plaf.basic

      Subclasses of FileFilter in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      protected class  | BasicFileChooserUI.AcceptAllFileFilter
      Methods in javax.swing.plaf.basic that return FileFilter
      修饰符与类型 方法与描述
      FileFilter BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
      Returns the default accept all file filter

    • Uses of FileFilter in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as FileFilter
      修饰符与类型 | 字段与描述
      protected FileFilter[] | MetalFileChooserUI.FilterComboBoxModel.filters

    • Uses of FileFilter in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return FileFilter
      修饰符与类型 方法与描述
      FileFilter MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a)
      Invokes the getAcceptAllFileFilter method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>rs - ns;re/ 糿


Uses of Class javax.swing.filechooser.FileNameExtensionFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.filechooser.FileNameExtensionFilter

No usage of javax.swing.filechooser.FileNameExtensionFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aFv.f=" ahhhnetta np


Uses of Class javax.swing.filechooser.FileSystemView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.filechooser.FileSystemView

  • Packages that use FileSystemView
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.filechooser
    Contains classes and interfaces used by the JFileChooser component.

    • Uses of FileSystemView in javax.swing

      Methods in javax.swing that return FileSystemView
      修饰符与类型 方法与描述
      FileSystemView JFileChooser.getFileSystemView()
      Returns the file system view.
      Methods in javax.swing with parameters of type FileSystemView
      修饰符与类型 方法与描述
      void JFileChooser.setFileSystemView(FileSystemView fsv)
      Sets the file system view that the JFileChooser uses for accessing and creating file system resources, such as finding the floppy drive and getting a list of root drives.
      protected void JFileChooser.setup(FileSystemView view)
      Performs common constructor initialization and setup.
      Constructors in javax.swing with parameters of type FileSystemView
      构造方法与描述
      JFileChooser(File currentDirectory, FileSystemView fsv)
      Constructs a JFileChooser using the given current directory and FileSystemView.
      JFileChooser(FileSystemView fsv)
      Constructs a JFileChooser using the given FileSystemView.
      JFileChooser(String currentDirectoryPath, FileSystemView fsv)
      Constructs a JFileChooser using the given current directory path and FileSystemView.

    • Uses of FileSystemView in javax.swing.filechooser

      Methods in javax.swing.filechooser that return FileSystemView
      修饰符与类型 | 方法与描述
      static FileSystemView | FileSystemView.getFileSystemView()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> &&Clp


Uses of Class javax.swing.filechooser.FileView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.filechooser.FileView

  • Packages that use FileView
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of FileView in javax.swing

      Methods in javax.swing that return FileView
      修饰符与类型 方法与描述
      FileView JFileChooser.getFileView()
      Returns the current file view.
      Methods in javax.swing with parameters of type FileView
      修饰符与类型 方法与描述
      void JFileChooser.setFileView(FileView fileView)
      Sets the file view to used to retrieve UI information, such as the icon that represents a file or the type description of a file.

    • Uses of FileView in javax.swing.plaf

      Methods in javax.swing.plaf that return FileView
      修饰符与类型 | 方法与描述
      abstract FileView | FileChooserUI.getFileView(JFileChooser fc)

    • Uses of FileView in javax.swing.plaf.basic

      Subclasses of FileView in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      protected class  | BasicFileChooserUI.BasicFileView
      Methods in javax.swing.plaf.basic that return FileView
      修饰符与类型 | 方法与描述
      FileView | BasicFileChooserUI.getFileView(JFileChooser fc)

    • Uses of FileView in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return FileView
      修饰符与类型 方法与描述
      FileView MultiFileChooserUI.getFileView(JFileChooser a)
      Invokes the getFileView method on each UI handled by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htaJx c


ActionMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ActionMapUIResource

  • java.lang.Object
    • javax.swing.ActionMap
      • javax.swing.plaf.ActionMapUIResource
  • 所有已实现的接口：
    Serializable, UIResource

    public class ActionMapUIResource
extends ActionMap
implements UIResource
    A subclass of javax.swing.ActionMap that implements UIResource. UI classes which provide an ActionMap should use this class.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      ActionMapUIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.ActionMap

        allKeys, clear, get, getParent, keys, put, remove, setParent, size

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ActionMapUIResource

        public ActionMapUIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iaa/."it.<"e/n.c>a


BorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 BorderUIResource

  • java.lang.Object
    • javax.swing.plaf.BorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource

    public class BorderUIResource
extends Object
implements Border, UIResource, Serializable

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  | BorderUIResource.BevelBorderUIResource
      static class  | BorderUIResource.CompoundBorderUIResource
      static class  | BorderUIResource.EmptyBorderUIResource
      static class  | BorderUIResource.EtchedBorderUIResource
      static class  | BorderUIResource.LineBorderUIResource
      static class  | BorderUIResource.MatteBorderUIResource
      static class  | BorderUIResource.TitledBorderUIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource(Border delegate)
      Creates a UIResource border object which wraps an existing Border instance.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Border | getBlackLineBorderUIResource()
      Insets getBorderInsets(Component c)
      Returns the insets of the border.
      static Border | getEtchedBorderUIResource()
      static Border | getLoweredBevelBorderUIResource()
      static Border | getRaisedBevelBorderUIResource()
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource

        public BorderUIResource(Border delegate)
        Creates a UIResource border object which wraps an existing Border instance.
        参数：
        delegate - the border being wrapped

    • 方法详细信息

      • getEtchedBorderUIResource

        public static Border getEtchedBorderUIResource()

      • getLoweredBevelBorderUIResource

        public static Border getLoweredBevelBorderUIResource()

      • getRaisedBevelBorderUIResource

        public static Border getRaisedBevelBorderUIResource()

      • getBlackLineBorderUIResource

        public static Border getBlackLineBorderUIResource()

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        从接口复制的描述： Border
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c)
        从接口复制的描述： Border
        Returns the insets of the border.
        指定者：
        getBorderInsets in interface Border
        参数：
        c - the component for which this border insets value applies

      • isBorderOpaque

        public boolean isBorderOpaque()
        从接口复制的描述： Border
        Returns whether or not the border is opaque. If the border is opaque, it is responsible for filling in it's own background when painting.
        指定者：
        isBorderOpaque in interface Border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ii Aoxi=ni- ->clj lceb<>i/bpF/Eac p1 /"-a/


BorderUIResource.BevelBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.BevelBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.BevelBorderUIResource
extends BevelBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.BevelBorder

        bevelType, highlightInner, highlightOuter, LOWERED, RAISED, shadowInner, shadowOuter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.BevelBorderUIResource(int bevelType)
      BorderUIResource.BevelBorderUIResource(int bevelType, Color highlight, Color shadow)
      BorderUIResource.BevelBorderUIResource(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.BevelBorder

        getBevelType, getBorderInsets, getHighlightInnerColor, getHighlightInnerColor, getHighlightOuterColor, getHighlightOuterColor, getShadowInnerColor, getShadowInnerColor, getShadowOuterColor, getShadowOuterColor, isBorderOpaque, paintBorder, paintLoweredBevel, paintRaisedBevel

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.BevelBorderUIResource

        public BorderUIResource.BevelBorderUIResource(int bevelType)

      • BorderUIResource.BevelBorderUIResource

        public BorderUIResource.BevelBorderUIResource(int bevelType,
                                      Color highlight,
                                      Color shadow)

      • BorderUIResource.BevelBorderUIResource

        @ConstructorProperties(value={"bevelType","highlightOuterColor","highlightInnerColor","shadowOuterColor","shadowInnerColor"})
public BorderUIResource.BevelBorderUIResource(int bevelType,
                                                                 Color highlightOuter,
                                                                 Color highlightInner,
                                                                 Color shadowOuter,
                                                                 Color shadowInner)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_tn sassshiaec Ih>t>萴./Ra礶ld


BorderUIResource.CompoundBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.CompoundBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.CompoundBorderUIResource
extends CompoundBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.CompoundBorder

        insideBorder, outsideBorder

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.CompoundBorderUIResource(Border outsideBorder, Border insideBorder)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.CompoundBorder

        getBorderInsets, getInsideBorder, getOutsideBorder, isBorderOpaque, paintBorder

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.CompoundBorderUIResource

        @ConstructorProperties(value={"outsideBorder","insideBorder"})
public BorderUIResource.CompoundBorderUIResource(Border outsideBorder,
                                                                    Border insideBorder)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a trherhgtthggi>ww .h< hfs


BorderUIResource.EmptyBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.EmptyBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EmptyBorder
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.EmptyBorderUIResource
extends EmptyBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.EmptyBorder

        bottom, left, right, top

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.EmptyBorderUIResource(Insets insets)
      BorderUIResource.EmptyBorderUIResource(int top, int left, int bottom, int right)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.EmptyBorder

        getBorderInsets, getBorderInsets, isBorderOpaque, paintBorder

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.EmptyBorderUIResource

        public BorderUIResource.EmptyBorderUIResource(int top,
                                      int left,
                                      int bottom,
                                      int right)

      • BorderUIResource.EmptyBorderUIResource

        @ConstructorProperties(value="borderInsets")
public BorderUIResource.EmptyBorderUIResource(Insets insets)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.ws=ct"citttittt/// < .


BorderUIResource.EtchedBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.EtchedBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.EtchedBorderUIResource
extends EtchedBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.EtchedBorder

        etchType, highlight, LOWERED, RAISED, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.EtchedBorderUIResource()
      BorderUIResource.EtchedBorderUIResource(Color highlight, Color shadow)
      BorderUIResource.EtchedBorderUIResource(int etchType)
      BorderUIResource.EtchedBorderUIResource(int etchType, Color highlight, Color shadow)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.EtchedBorder

        getBorderInsets, getEtchType, getHighlightColor, getHighlightColor, getShadowColor, getShadowColor, isBorderOpaque, paintBorder

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.EtchedBorderUIResource

        public BorderUIResource.EtchedBorderUIResource()

      • BorderUIResource.EtchedBorderUIResource

        public BorderUIResource.EtchedBorderUIResource(int etchType)

      • BorderUIResource.EtchedBorderUIResource

        public BorderUIResource.EtchedBorderUIResource(Color highlight,
                                       Color shadow)

      • BorderUIResource.EtchedBorderUIResource

        @ConstructorProperties(value={"etchType","highlightColor","shadowColor"})
public BorderUIResource.EtchedBorderUIResource(int etchType,
                                                                  Color highlight,
                                                                  Color shadow)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s_=lvlblslucasssa> }=s {{_ lel ;ae<


BorderUIResource.LineBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.LineBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.LineBorderUIResource
extends LineBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.LineBorder

        lineColor, roundedCorners, thickness

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.LineBorderUIResource(Color color)
      BorderUIResource.LineBorderUIResource(Color color, int thickness)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.LineBorder

        createBlackLineBorder, createGrayLineBorder, getBorderInsets, getLineColor, getRoundedCorners, getThickness, isBorderOpaque, paintBorder

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.LineBorderUIResource

        public BorderUIResource.LineBorderUIResource(Color color)

      • BorderUIResource.LineBorderUIResource

        @ConstructorProperties(value={"lineColor","thickness"})
public BorderUIResource.LineBorderUIResource(Color color,
                                                                int thickness)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lei4t>k">kcLLkcc=lllluia>=eelmienI tRc


BorderUIResource.MatteBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.MatteBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.EmptyBorder
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.MatteBorderUIResource
extends MatteBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.MatteBorder

        color, tileIcon

      • Fields inherited from class javax.swing.border.EmptyBorder

        bottom, left, right, top

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.MatteBorderUIResource(Icon tileIcon)
      BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Color color)
      BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Icon tileIcon)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.MatteBorder

        getBorderInsets, getBorderInsets, getMatteColor, getTileIcon, isBorderOpaque, paintBorder

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.MatteBorderUIResource

        public BorderUIResource.MatteBorderUIResource(int top,
                                      int left,
                                      int bottom,
                                      int right,
                                      Color color)

      • BorderUIResource.MatteBorderUIResource

        public BorderUIResource.MatteBorderUIResource(int top,
                                      int left,
                                      int bottom,
                                      int right,
                                      Icon tileIcon)

      • BorderUIResource.MatteBorderUIResource

        public BorderUIResource.MatteBorderUIResource(Icon tileIcon)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dspde id apiiapp eoodohc//-< owtcd n


BorderUIResource.TitledBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 BorderUIResource.TitledBorderUIResource

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BorderUIResource

    public static class BorderUIResource.TitledBorderUIResource
extends TitledBorder
implements UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.border.TitledBorder

        ABOVE_BOTTOM, ABOVE_TOP, BELOW_BOTTOM, BELOW_TOP, border, BOTTOM, CENTER, DEFAULT_JUSTIFICATION, DEFAULT_POSITION, EDGE_SPACING, LEADING, LEFT, RIGHT, TEXT_INSET_H, TEXT_SPACING, title, titleColor, titleFont, titleJustification, titlePosition, TOP, TRAILING

    • 构造方法摘要

      Constructors
      构造方法与描述
      BorderUIResource.TitledBorderUIResource(Border border)
      BorderUIResource.TitledBorderUIResource(Border border, String title)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
      BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
      BorderUIResource.TitledBorderUIResource(String title)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.border.TitledBorder

        getBaseline, getBaselineResizeBehavior, getBorder, getBorderInsets, getFont, getMinimumSize, getTitle, getTitleColor, getTitleFont, getTitleJustification, getTitlePosition, isBorderOpaque, paintBorder, setBorder, setTitle, setTitleColor, setTitleFont, setTitleJustification, setTitlePosition

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBorderInsets, getInteriorRectangle, getInteriorRectangle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BorderUIResource.TitledBorderUIResource

        public BorderUIResource.TitledBorderUIResource(String title)

      • BorderUIResource.TitledBorderUIResource

        public BorderUIResource.TitledBorderUIResource(Border border)

      • BorderUIResource.TitledBorderUIResource

        public BorderUIResource.TitledBorderUIResource(Border border,
                                       String title)

      • BorderUIResource.TitledBorderUIResource

        public BorderUIResource.TitledBorderUIResource(Border border,
                                       String title,
                                       int titleJustification,
                                       int titlePosition)

      • BorderUIResource.TitledBorderUIResource

        public BorderUIResource.TitledBorderUIResource(Border border,
                                       String title,
                                       int titleJustification,
                                       int titlePosition,
                                       Font titleFont)

      • BorderUIResource.TitledBorderUIResource

        @ConstructorProperties(value={"border","title","titleJustification","titlePosition","titleFont","titleColor"})
public BorderUIResource.TitledBorderUIResource(Border border,
                                                                  String title,
                                                                  int titleJustification,
                                                                  int titlePosition,
                                                                  Font titleFont,
                                                                  Color titleColor)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

teItr ueemvio<>ll8r


ButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
  • 直接已知子类：
    BasicButtonUI, MenuItemUI, MultiButtonUI

    public abstract class ButtonUI
extends ComponentUI
    Pluggable look and feel interface for JButton.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ButtonUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ButtonUI

        public ButtonUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rldeeorsoreUUree#roo>s<<> .n<>dx


ColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ColorChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ColorChooserUI
  • 直接已知子类：
    BasicColorChooserUI, MultiColorChooserUI

    public abstract class ColorChooserUI
extends ComponentUI
    Pluggable look and feel interface for JColorChooser.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ColorChooserUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ColorChooserUI

        public ColorChooserUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/d/b/>/ resUllrto eUUorsoezl#


ColorUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ColorUIResource

  • java.lang.Object
    • java.awt.Color
      • javax.swing.plaf.ColorUIResource
  • 所有已实现的接口：
    Paint, Transparency, Serializable, UIResource

    public class ColorUIResource
extends Color
implements UIResource

    • 字段摘要

      • Fields inherited from class java.awt.Color

        black, BLACK, blue, BLUE, cyan, CYAN, DARK_GRAY, darkGray, gray, GRAY, green, GREEN, LIGHT_GRAY, lightGray, magenta, MAGENTA, orange, ORANGE, pink, PINK, red, RED, white, WHITE, yellow, YELLOW

      • 字段 - 继承于接口 java.awt.Transparency

        BITMASK, OPAQUE, TRANSLUCENT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ColorUIResource(Color c)
      ColorUIResource(float r, float g, float b)
      ColorUIResource(int rgb)
      ColorUIResource(int r, int g, int b)

    • 方法摘要

      • 方法 - 继承于类 java.awt.Color

        brighter, createContext, darker, decode, equals, getAlpha, getBlue, getColor, getColor, getColor, getColorComponents, getColorComponents, getColorSpace, getComponents, getComponents, getGreen, getHSBColor, getRed, getRGB, getRGBColorComponents, getRGBComponents, getTransparency, hashCode, HSBtoRGB, RGBtoHSB, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ColorUIResource

        @ConstructorProperties(value={"red","green","blue"})
public ColorUIResource(int r,
                                          int g,
                                          int b)

      • ColorUIResource

        public ColorUIResource(int rgb)

      • ColorUIResource

        public ColorUIResource(float r,
               float g,
               float b)

      • ColorUIResource

        public ColorUIResource(Color c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

TnaIodardht4h<<>>driIRReuRredB!(L


ComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 ComboBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ComboBoxUI
  • 直接已知子类：
    BasicComboBoxUI, MultiComboBoxUI

    public abstract class ComboBoxUI
extends ComponentUI
    Pluggable look and feel interface for JComboBox.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComboBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean isFocusTraversable(JComboBox c)
      Determine whether or not the combo box itself is traversable
      abstract boolean isPopupVisible(JComboBox c)
      Determine the visibility of the popup
      abstract void setPopupVisible(JComboBox c, boolean v)
      Set the visiblity of the popup

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComboBoxUI

        public ComboBoxUI()

    • 方法详细信息

      • setPopupVisible

        public abstract void setPopupVisible(JComboBox c,
                   boolean v)
        Set the visiblity of the popup

      • isPopupVisible

        public abstract boolean isPopupVisible(JComboBox c)
        Determine the visibility of the popup

      • isFocusTraversable

        public abstract boolean isFocusTraversable(JComboBox c)
        Determine whether or not the combo box itself is traversable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/rasasCs<>>/聅s//gjiwwag.thoal=Cp


ComponentInputMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ComponentInputMapUIResource

  • java.lang.Object
    • javax.swing.InputMap
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource
  • 所有已实现的接口：
    Serializable, UIResource

    public class ComponentInputMapUIResource
extends ComponentInputMap
implements UIResource
    A subclass of javax.swing.ComponentInputMap that implements UIResource. UI classes which provide a ComponentInputMap should use this class.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComponentInputMapUIResource(JComponent component)

    • 方法摘要

      • 方法 - 继承于类 javax.swing.ComponentInputMap

        clear, getComponent, put, remove, setParent

      • 方法 - 继承于类 javax.swing.InputMap

        allKeys, get, getParent, keys, size

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentInputMapUIResource

        public ComponentInputMapUIResource(JComponent component)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-Usarfaa<>>>


ComponentUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 ComponentUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
  • 直接已知子类：
    ButtonUI, ColorChooserUI, ComboBoxUI, DesktopIconUI, DesktopPaneUI, FileChooserUI, InternalFrameUI, LabelUI, LayerUI, ListUI, MenuBarUI, OptionPaneUI, PanelUI, PopupMenuUI, ProgressBarUI, RootPaneUI, ScrollBarUI, ScrollPaneUI, SeparatorUI, SliderUI, SpinnerUI, SplitPaneUI, TabbedPaneUI, TableHeaderUI, TableUI, TextUI, ToolBarUI, ToolTipUI, TreeUI, ViewportUI

    public abstract class ComponentUI
extends Object
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture. The UI delegate object for a Swing component is responsible for implementing the aspects of the component that depend on the look and feel. The JComponent class invokes methods from this class in order to delegate operations (painting, layout calculations, etc.) that may vary depending on the look and feel installed. Client programs should not invoke methods on this class directly.
    另请参见：
    JComponent, UIManager

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComponentUI()
      Sole constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent c, int x, int y)
      Returns true if the specified x,y location is contained within the look and feel's defined shape of the specified component.
      static ComponentUI createUI(JComponent c)
      Returns an instance of the UI delegate for the specified component.
      Accessible getAccessibleChild(JComponent c, int i)
      Returns the ith Accessible child of the object.
      int getAccessibleChildrenCount(JComponent c)
      Returns the number of accessible children in the object.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of he component changes as the size changes.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate that it is time to paint the specified component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentUI

        public ComponentUI()
        Sole constructor. (For invocation by subclass constructors, typically implicit.)

    • 方法详细信息

      • installUI

        public void installUI(JComponent c)
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        update(java.awt.Graphics, javax.swing.JComponent)

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate that it is time to paint the specified component. This method is invoked by JComponent when the specified component is being painted.

        By default this method fills the specified component with its background color if its opaque property is true, and then immediately calls paint. In general this method need not be overridden by subclasses; all look-and-feel rendering code should reside in the paint method.

        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • contains

        public boolean contains(JComponent c,
               int x,
               int y)
        Returns true if the specified x,y location is contained within the look and feel's defined shape of the specified component. x and y are defined to be relative to the coordinate system of the specified component. Although a component's bounds is constrained to a rectangle, this method provides the means for defining a non-rectangular shape within those bounds for the purpose of hit detection.
        参数：
        c - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        x - the x coordinate of the point
        y - the y coordinate of the point
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • createUI

        public static ComponentUI createUI(JComponent c)
        Returns an instance of the UI delegate for the specified component. Each subclass must provide its own static createUI method that returns an instance of that UI delegate subclass. If the UI delegate subclass is stateless, it may return an instance that is shared by multiple components. If the UI delegate is stateful, then it should return a new instance per component. The default implementation of this method throws an error, as it should never be invoked.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline. The baseline is measured from the top of the component. This method is primarily meant for LayoutManagers to align components along their baseline. A return value less than 0 indicates this component does not have a reasonable baseline and that LayoutManagers should not align this component on its baseline.

        This method returns -1. Subclasses that have a meaningful baseline should override appropriately.

        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int,int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of he component changes as the size changes. This method is primarily meant for layout managers and GUI builders.

        This method returns BaselineResizeBehavior.OTHER. Subclasses that support a baseline should override appropriately.

        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent c)
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, this method should return the number of children of this object. UIs might wish to override this if they present areas on the screen that can be viewed as components, but actual components are not used for presenting those areas. Note: As of v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleChildrenCount() instead of this method.
        返回：
        the number of accessible children in the object
        另请参见：
        getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent c,
                            int i)
        Returns the ith Accessible child of the object. UIs might need to override this if they present areas on the screen that can be viewed as components, but actual components are not used for presenting those areas.

        Note: As of v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleChild() instead of this method.

        参数：
        i - zero-based index of child
        返回：
        the ith Accessible child of the object
        另请参见：
        getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 DesktopIconUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopIconUI
  • 直接已知子类：
    BasicDesktopIconUI, MultiDesktopIconUI

    public abstract class DesktopIconUI
extends ComponentUI
    Pluggable look and feel interface for JDesktopIcon.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DesktopIconUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DesktopIconUI

        public DesktopIconUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etnJoiCoiwnniwwv.<


DesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 DesktopPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopPaneUI
  • 直接已知子类：
    BasicDesktopPaneUI, MultiDesktopPaneUI

    public abstract class DesktopPaneUI
extends ComponentUI
    Pluggable look and feel interface for JDesktopPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DesktopPaneUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DesktopPaneUI

        public DesktopPaneUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tun>""_iu/"=i>lelt>" 溞t箃l:t黶 r


DimensionUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 DimensionUIResource

  • java.lang.Object
    • java.awt.geom.Dimension2D
      • java.awt.Dimension
        • javax.swing.plaf.DimensionUIResource
  • 所有已实现的接口：
    Serializable, Cloneable, UIResource

    public class DimensionUIResource
extends Dimension
implements UIResource

    • 字段摘要

      • Fields inherited from class java.awt.Dimension

        height, width

    • 构造方法摘要

      Constructors
      构造方法与描述
      DimensionUIResource(int width, int height)

    • 方法摘要

      • 方法 - 继承于类 java.awt.Dimension

        equals, getHeight, getSize, getWidth, hashCode, setSize, setSize, setSize, toString

      • 方法 - 继承于类 java.awt.geom.Dimension2D

        clone, setSize

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DimensionUIResource

        public DimensionUIResource(int width,
                   int height)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rc uc3ob rga>d


FileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 FileChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.FileChooserUI
  • 直接已知子类：
    BasicFileChooserUI, MultiFileChooserUI

    public abstract class FileChooserUI
extends ComponentUI
    Pluggable look and feel interface for JFileChooser.

    • 构造方法摘要

      Constructors
      构造方法与描述
      FileChooserUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      abstract void | ensureFileIsVisible(JFileChooser fc, File f)
      abstract FileFilter | getAcceptAllFileFilter(JFileChooser fc)
      abstract String | getApproveButtonText(JFileChooser fc)
      JButton getDefaultButton(JFileChooser fc)
      Returns default button for current LookAndFeel.
      abstract String | getDialogTitle(JFileChooser fc)
      abstract FileView | getFileView(JFileChooser fc)
      abstract void | rescanCurrentDirectory(JFileChooser fc)

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FileChooserUI

        public FileChooserUI()

    • 方法详细信息

      • getAcceptAllFileFilter

        public abstract FileFilter getAcceptAllFileFilter(JFileChooser fc)

      • getFileView

        public abstract FileView getFileView(JFileChooser fc)

      • getApproveButtonText

        public abstract String getApproveButtonText(JFileChooser fc)

      • getDialogTitle

        public abstract String getDialogTitle(JFileChooser fc)

      • rescanCurrentDirectory

        public abstract void rescanCurrentDirectory(JFileChooser fc)

      • ensureFileIsVisible

        public abstract void ensureFileIsVisible(JFileChooser fc,
                       File f)

      • getDefaultButton

        public JButton getDefaultButton(JFileChooser fc)
        Returns default button for current LookAndFeel. JFileChooser will use this button as default button for dialog windows.
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts>g/f"...a o祎avv/pserrJr


FontUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 FontUIResource

  • java.lang.Object
    • java.awt.Font
      • javax.swing.plaf.FontUIResource
  • 所有已实现的接口：
    Serializable, UIResource

    public class FontUIResource
extends Font
implements UIResource
    A subclass of java.awt.Font that implements UIResource. UI classes which set default font properties should use this class.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    UIResource

    • 字段摘要

      • Fields inherited from class java.awt.Font

        BOLD, CENTER_BASELINE, DIALOG, DIALOG_INPUT, HANGING_BASELINE, ITALIC, LAYOUT_LEFT_TO_RIGHT, LAYOUT_NO_LIMIT_CONTEXT, LAYOUT_NO_START_CONTEXT, LAYOUT_RIGHT_TO_LEFT, MONOSPACED, name, PLAIN, pointSize, ROMAN_BASELINE, SANS_SERIF, SERIF, size, style, TRUETYPE_FONT, TYPE1_FONT

    • 构造方法摘要

      Constructors
      构造方法与描述
      FontUIResource(Font font)
      FontUIResource(String name, int style, int size)

    • 方法摘要

      • 方法 - 继承于类 java.awt.Font

        canDisplay, canDisplay, canDisplayUpTo, canDisplayUpTo, canDisplayUpTo, createFont, createFont, createGlyphVector, createGlyphVector, createGlyphVector, createGlyphVector, decode, deriveFont, deriveFont, deriveFont, deriveFont, deriveFont, deriveFont, equals, getAttributes, getAvailableAttributes, getBaselineFor, getFamily, getFamily, getFont, getFont, getFont, getFontName, getFontName, getItalicAngle, getLineMetrics, getLineMetrics, getLineMetrics, getLineMetrics, getMaxCharBounds, getMissingGlyphCode, getName, getNumGlyphs, getPeer, getPSName, getSize, getSize2D, getStringBounds, getStringBounds, getStringBounds, getStringBounds, getStyle, getTransform, hashCode, hasLayoutAttributes, hasUniformLineMetrics, isBold, isItalic, isPlain, isTransformed, layoutGlyphVector, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FontUIResource

        public FontUIResource(String name,
              int style,
              int size)

      • FontUIResource

        public FontUIResource(Font font)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aooo o,orns, dr a忻术孩棍鳏髯础<.<�


IconUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 IconUIResource

  • java.lang.Object
    • javax.swing.plaf.IconUIResource
  • 所有已实现的接口：
    Serializable, Icon, UIResource

    public class IconUIResource
extends Object
implements Icon, UIResource, Serializable
    An Icon wrapper class which implements UIResource. UI classes which set icon properties should use this class to wrap any icons specified as defaults. This class delegates all method invocations to the Icon "delegate" object specified at construction.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      IconUIResource(Icon delegate)
      Creates a UIResource icon object which wraps an existing Icon instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IconUIResource

        public IconUIResource(Icon delegate)
        Creates a UIResource icon object which wraps an existing Icon instance.
        参数：
        delegate - the icon being wrapped

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

em=Ls"c="c llc > rrapt-b__"brmtSiovaaia_i=s


InputMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 InputMapUIResource

  • java.lang.Object
    • javax.swing.InputMap
      • javax.swing.plaf.InputMapUIResource
  • 所有已实现的接口：
    Serializable, UIResource

    public class InputMapUIResource
extends InputMap
implements UIResource
    A subclass of javax.swing.InputMap that implements UIResource. UI classes which provide a InputMap should use this class.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputMapUIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.InputMap

        allKeys, clear, get, getParent, keys, put, remove, setParent, size

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputMapUIResource

        public InputMapUIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(.j#nh/.h/gII/gg/.hhdcrd/<<<


InsetsUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 InsetsUIResource

  • java.lang.Object
    • java.awt.Insets
      • javax.swing.plaf.InsetsUIResource
  • 所有已实现的接口：
    Serializable, Cloneable, UIResource

    public class InsetsUIResource
extends Insets
implements UIResource

    • 字段摘要

      • Fields inherited from class java.awt.Insets

        bottom, left, right, top

    • 构造方法摘要

      Constructors
      构造方法与描述
      InsetsUIResource(int top, int left, int bottom, int right)

    • 方法摘要

      • 方法 - 继承于类 java.awt.Insets

        clone, equals, hashCode, set, toString

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InsetsUIResource

        public InsetsUIResource(int top,
                int left,
                int bottom,
                int right)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a<<>aacscceif<.og


InternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 InternalFrameUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.InternalFrameUI
  • 直接已知子类：
    BasicInternalFrameUI, MultiInternalFrameUI

    public abstract class InternalFrameUI
extends ComponentUI
    Pluggable look and feel interface for JInternalFrame.

    • 构造方法摘要

      Constructors
      构造方法与描述
      InternalFrameUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InternalFrameUI

        public InternalFrameUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=""dd>id>tds>tddny>>/l


javax.swing.plaf

Interfaces

  • UIResource

Classes

  • ActionMapUIResource
  • BorderUIResource
  • BorderUIResource.BevelBorderUIResource
  • BorderUIResource.CompoundBorderUIResource
  • BorderUIResource.EmptyBorderUIResource
  • BorderUIResource.EtchedBorderUIResource
  • BorderUIResource.LineBorderUIResource
  • BorderUIResource.MatteBorderUIResource
  • BorderUIResource.TitledBorderUIResource
  • ButtonUI
  • ColorChooserUI
  • ColorUIResource
  • ComboBoxUI
  • ComponentInputMapUIResource
  • ComponentUI
  • DesktopIconUI
  • DesktopPaneUI
  • DimensionUIResource
  • FileChooserUI
  • FontUIResource
  • IconUIResource
  • InputMapUIResource
  • InsetsUIResource
  • InternalFrameUI
  • LabelUI
  • LayerUI
  • ListUI
  • MenuBarUI
  • MenuItemUI
  • OptionPaneUI
  • PanelUI
  • PopupMenuUI
  • ProgressBarUI
  • RootPaneUI
  • ScrollBarUI
  • ScrollPaneUI
  • SeparatorUI
  • SliderUI
  • SpinnerUI
  • SplitPaneUI
  • TabbedPaneUI
  • TableHeaderUI
  • TableUI
  • TextUI
  • ToolBarUI
  • ToolTipUI
  • TreeUI
  • ViewportUI
=


javax.swing.plaf

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf

Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.

请参见： 描述

  • 接口摘要
    接口 描述
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
  • Class Summary
    类 描述
    ActionMapUIResource
    A subclass of javax.swing.ActionMap that implements UIResource.
    BorderUIResource
    BorderUIResource.BevelBorderUIResource
    BorderUIResource.CompoundBorderUIResource
    BorderUIResource.EmptyBorderUIResource
    BorderUIResource.EtchedBorderUIResource
    BorderUIResource.LineBorderUIResource
    BorderUIResource.MatteBorderUIResource
    BorderUIResource.TitledBorderUIResource
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorChooserUI
    Pluggable look and feel interface for JColorChooser.
    ColorUIResource
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentInputMapUIResource
    A subclass of javax.swing.ComponentInputMap that implements UIResource.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    DesktopPaneUI
    Pluggable look and feel interface for JDesktopPane.
    DimensionUIResource
    FileChooserUI
    Pluggable look and feel interface for JFileChooser.
    FontUIResource
    A subclass of java.awt.Font that implements UIResource.
    IconUIResource
    An Icon wrapper class which implements UIResource.
    InputMapUIResource
    A subclass of javax.swing.InputMap that implements UIResource.
    InsetsUIResource
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    LayerUI<V extends Component>
    The base class for all JLayer's UI delegates.
    ListUI
    The JList pluggable look and feel delegate.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    MenuItemUI
    Pluggable look and feel interface for JMenuItem.
    OptionPaneUI
    Pluggable look and feel interface for JOptionPane.
    PanelUI
    Pluggable look and feel interface for Panel.
    PopupMenuUI
    Pluggable look and feel interface for JPopupMenu.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SpinnerUI
    Pluggable look and feel interface for JSpinner
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TableHeaderUI
    Pluggable look and feel interface for JTableHeader.
    TableUI
    Pluggable look and feel interface for JTable.
    TextUI
    Text editor user interface
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    ViewportUI
    Pluggable look and feel interface for JViewport.

软件包 javax.swing.plaf Description

Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities. Its classes are subclassed and implemented by look and feel UIs such as Basic and the Java look and feel (Metal). This package is only used by developers who cannot create a new look and feel by subclassing existing look-and-feel components (such as those provided by the javax.swing.plaf.basic and javax.swing.plaf.metal packages).

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l s>(nenno,>rrbev


javax.swing.plaf Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.ActionMap (implements java.io.Serializable)
      • javax.swing.plaf.ActionMapUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.BorderUIResource (implements javax.swing.border.Border, java.io.Serializable, javax.swing.plaf.UIResource)
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • javax.swing.plaf.ColorUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
      • javax.swing.plaf.ColorChooserUI
      • javax.swing.plaf.ComboBoxUI
      • javax.swing.plaf.DesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
      • javax.swing.plaf.FileChooserUI
      • javax.swing.plaf.InternalFrameUI
      • javax.swing.plaf.LabelUI
      • javax.swing.plaf.LayerUI<V> (implements java.io.Serializable)
      • javax.swing.plaf.ListUI
      • javax.swing.plaf.MenuBarUI
      • javax.swing.plaf.OptionPaneUI
      • javax.swing.plaf.PanelUI
      • javax.swing.plaf.PopupMenuUI
      • javax.swing.plaf.ProgressBarUI
      • javax.swing.plaf.RootPaneUI
      • javax.swing.plaf.ScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
      • javax.swing.plaf.SeparatorUI
      • javax.swing.plaf.SliderUI
      • javax.swing.plaf.SpinnerUI
      • javax.swing.plaf.SplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
      • javax.swing.plaf.TableUI
      • javax.swing.plaf.TextUI
      • javax.swing.plaf.ToolBarUI
      • javax.swing.plaf.ToolTipUI
      • javax.swing.plaf.TreeUI
      • javax.swing.plaf.ViewportUI
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
        • javax.swing.plaf.DimensionUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.Font (implements java.io.Serializable)
      • javax.swing.plaf.FontUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.IconUIResource (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.InputMapUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.InsetsUIResource (implements javax.swing.plaf.UIResource)

Interface Hierarchy

  • javax.swing.plaf.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

redt .v/BBvse


LabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 LabelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LabelUI
  • 直接已知子类：
    BasicLabelUI, MultiLabelUI

    public abstract class LabelUI
extends ComponentUI
    Pluggable look and feel interface for JLabel.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LabelUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LabelUI

        public LabelUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fs=<<


LayerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 LayerUI<V extends Component>

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LayerUI<V>
  • 类型参数：
    V - one of the super types of JLayer's view component
    所有已实现的接口：
    Serializable

    public class LayerUI<V extends Component>
extends ComponentUI
implements Serializable
    The base class for all JLayer's UI delegates.

    paint(java.awt.Graphics, javax.swing.JComponent) method performs the painting of the JLayer and eventDispatched(AWTEvent, JLayer) method is notified about any AWTEvents which have been generated by a JLayer or any of its subcomponents.

    The LayerUI differs from the UI delegates of the other components, because it is LookAndFeel independent and is not updated by default when the system LookAndFeel is changed.

    The subclasses of LayerUI can either be stateless and shareable by multiple JLayers or not shareable.

    从以下版本开始：
    1.7
    另请参见：
    JLayer.setUI(LayerUI),
JLayer.setView(Component),
JLayer.getView()

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayerUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list for a specific property.
      void applyPropertyChange(PropertyChangeEvent evt, JLayer<? extends V> l)
      Notifies the LayerUI when any of its property are changed and enables updating every JLayer this LayerUI instance is set to.
      void doLayout(JLayer<? extends V> l)
      Causes the passed instance of JLayer to lay out its components.
      void eventDispatched(AWTEvent e, JLayer<? extends V> l)
      Processes AWTEvents for JLayer and all its descendants to this LayerUI instance.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Support for reporting bound property changes for Object properties.
      int getBaseline(JComponent c, int width, int height)
      If the JLayer's view component is not null, this calls the view's getBaseline() method.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getBaselineResizeBehavior() method.
      Dimension getMaximumSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getMaximumSize() method.
      Dimension getMinimumSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getMinimalSize() method.
      Dimension getPreferredSize(JComponent c)
      If the JLayer's view component is not null, this returns the result of the view's getPreferredSize() method.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the property change listeners registered on this component.
      PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
      Returns an array of all the listeners which have been associated with the named property.
      void installUI(JComponent c)
      Configures the JLayer this LayerUI is set to.
      void paint(Graphics g, JComponent c)
      Paints the specified component.
      void paintImmediately(int x, int y, int width, int height, JLayer<? extends V> l)
      Paints the specified region in the JLayer this LayerUI is set to, immediately.
      protected void processComponentEvent(ComponentEvent e, JLayer<? extends V> l)
      Processes component events occurring on the JLayer or any of its subcomponents.
      protected void processFocusEvent(FocusEvent e, JLayer<? extends V> l)
      Processes focus events occurring on the JLayer or any of its subcomponents.
      protected void processHierarchyBoundsEvent(HierarchyEvent e, JLayer<? extends V> l)
      Processes hierarchy bounds event occurring on the JLayer or any of its subcomponents.
      protected void processHierarchyEvent(HierarchyEvent e, JLayer<? extends V> l)
      Processes hierarchy event occurring on the JLayer or any of its subcomponents.
      protected void processInputMethodEvent(InputMethodEvent e, JLayer<? extends V> l)
      Processes input event occurring on the JLayer or any of its subcomponents.
      protected void processKeyEvent(KeyEvent e, JLayer<? extends V> l)
      Processes key events occurring on the JLayer or any of its subcomponents.
      protected void processMouseEvent(MouseEvent e, JLayer<? extends V> l)
      Processes mouse events occurring on the JLayer or any of its subcomponents.
      protected void processMouseMotionEvent(MouseEvent e, JLayer<? extends V> l)
      Processes mouse motion event occurring on the JLayer or any of its subcomponents.
      protected void processMouseWheelEvent(MouseWheelEvent e, JLayer<? extends V> l)
      Processes mouse wheel event occurring on the JLayer or any of its subcomponents.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list for a specific property.
      void uninstallUI(JComponent c)
      Reverses the configuration which was previously set in the installUI(JComponent) method.
      void updateUI(JLayer<? extends V> l)
      Invoked when JLayer.updateUI() is called by the JLayer this LayerUI is set to.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LayerUI

        public LayerUI()

    • 方法详细信息

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component. Subclasses should override this method and use the specified Graphics object to render the content of the component.

        The default implementation paints the passed component as is.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • eventDispatched

        public void eventDispatched(AWTEvent e,
                   JLayer<? extends V> l)
        Processes AWTEvents for JLayer and all its descendants to this LayerUI instance.

        To enable the AWTEvents of a particular type, you call JLayer.setLayerEventMask(long) in installUI(javax.swing.JComponent) and set the layer event mask to 0 in uninstallUI(javax.swing.JComponent) after that. By default this method calls the appropriate process&lt;event&nbsp;type&gt;Event method for the given class of event.

        Note: Events are processed only for displayable JLayers.

        参数：
        e - the event to be dispatched
        l - the layer this LayerUI is set to
        另请参见：
        JLayer.setLayerEventMask(long),
Component.isDisplayable(),
processComponentEvent(java.awt.event.ComponentEvent, javax.swing.JLayer),
processFocusEvent(java.awt.event.FocusEvent, javax.swing.JLayer),
processKeyEvent(java.awt.event.KeyEvent, javax.swing.JLayer),
processMouseEvent(java.awt.event.MouseEvent, javax.swing.JLayer),
processMouseMotionEvent(java.awt.event.MouseEvent, javax.swing.JLayer),
processInputMethodEvent(java.awt.event.InputMethodEvent, javax.swing.JLayer),
processHierarchyEvent(java.awt.event.HierarchyEvent, javax.swing.JLayer),
processMouseWheelEvent(java.awt.event.MouseWheelEvent, javax.swing.JLayer)

      • processComponentEvent

        protected void processComponentEvent(ComponentEvent e,
                         JLayer<? extends V> l)
        Processes component events occurring on the JLayer or any of its subcomponents.

        This method is not called unless component events are enabled for the JLayer objects, this LayerUI is set to. Component events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.COMPONENT_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the ComponentEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processFocusEvent

        protected void processFocusEvent(FocusEvent e,
                     JLayer<? extends V> l)
        Processes focus events occurring on the JLayer or any of its subcomponents.

        This method is not called unless focus events are enabled for the JLayer objects, this LayerUI is set to. Focus events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.FOCUS_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the FocusEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processKeyEvent

        protected void processKeyEvent(KeyEvent e,
                   JLayer<? extends V> l)
        Processes key events occurring on the JLayer or any of its subcomponents.

        This method is not called unless key events are enabled for the JLayer objects, this LayerUI is set to. Key events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.KEY_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the KeyEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processMouseEvent

        protected void processMouseEvent(MouseEvent e,
                     JLayer<? extends V> l)
        Processes mouse events occurring on the JLayer or any of its subcomponents.

        This method is not called unless mouse events are enabled for the JLayer objects, this LayerUI is set to. Mouse events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.MOUSE_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the MouseEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processMouseMotionEvent

        protected void processMouseMotionEvent(MouseEvent e,
                           JLayer<? extends V> l)
        Processes mouse motion event occurring on the JLayer or any of its subcomponents.

        This method is not called unless mouse motion events are enabled for the JLayer objects, this LayerUI is set to. Mouse motion events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.MOUSE_MOTION_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the MouseEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processMouseWheelEvent

        protected void processMouseWheelEvent(MouseWheelEvent e,
                          JLayer<? extends V> l)
        Processes mouse wheel event occurring on the JLayer or any of its subcomponents.

        This method is not called unless mouse wheel events are enabled for the JLayer objects, this LayerUI is set to. Mouse wheel events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.MOUSE_WHEEL_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the MouseEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processInputMethodEvent

        protected void processInputMethodEvent(InputMethodEvent e,
                           JLayer<? extends V> l)
        Processes input event occurring on the JLayer or any of its subcomponents.

        This method is not called unless input events are enabled for the JLayer objects, this LayerUI is set to. Input events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.INPUT_METHOD_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the InputMethodEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processHierarchyEvent

        protected void processHierarchyEvent(HierarchyEvent e,
                         JLayer<? extends V> l)
        Processes hierarchy event occurring on the JLayer or any of its subcomponents.

        This method is not called unless hierarchy events are enabled for the JLayer objects, this LayerUI is set to. Hierarchy events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.HIERARCHY_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the HierarchyEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • processHierarchyBoundsEvent

        protected void processHierarchyBoundsEvent(HierarchyEvent e,
                               JLayer<? extends V> l)
        Processes hierarchy bounds event occurring on the JLayer or any of its subcomponents.

        This method is not called unless hierarchy bounds events are enabled for the JLayer objects, this LayerUI is set to. Hierarchy bounds events are enabled in the overridden installUI(javax.swing.JComponent) method and should be disabled in the uninstallUI(javax.swing.JComponent) method after that.

         public void installUI(JComponent c) {
    super.installUI(c);
    JLayer l = (JLayer) c;
    l.setLayerEventMask(AWTEvent.HIERARCHY_BOUNDS_EVENT_MASK);
 }

 public void uninstallUI(JComponent c) {
     super.uninstallUI(c);
     JLayer l = (JLayer) c;
     l.setLayerEventMask(0);
 }
        参数：
        e - the HierarchyEvent to be processed
        l - the layer this LayerUI instance is set to
        另请参见：
        JLayer.setLayerEventMask(long),
installUI(javax.swing.JComponent),
uninstallUI(javax.swing.JComponent)

      • updateUI

        public void updateUI(JLayer<? extends V> l)
        Invoked when JLayer.updateUI() is called by the JLayer this LayerUI is set to.
        参数：
        l - the JLayer which UI is updated

      • installUI

        public void installUI(JComponent c)
        Configures the JLayer this LayerUI is set to. The default implementation registers the passed JLayer component as a PropertyChangeListener for the property changes of this LayerUI.
        重载：
        installUI in class ComponentUI
        参数：
        c - the JLayer component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Reverses the configuration which was previously set in the installUI(JComponent) method. The default implementation unregisters the passed JLayer component as a PropertyChangeListener for the property changes of this LayerUI.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed.
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all bound properties of this class.

        If listener is null, no exception is thrown and no action is performed.

        参数：
        listener - the property change listener to be added
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(),
addPropertyChangeListener(String, java.beans.PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This method should be used to remove PropertyChangeListeners that were registered for all bound properties of this class.

        If listener is null, no exception is thrown and no action is performed.

        参数：
        listener - the PropertyChangeListener to be removed
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(),
removePropertyChangeListener(String, PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the property change listeners registered on this component.
        返回：
        all of this ui's PropertyChangeListeners or an empty array if no property change listeners are currently registered
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(String)

      • addPropertyChangeListener

        public void addPropertyChangeListener(String propertyName,
                             PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list for a specific property.

        If propertyName or listener is null, no exception is thrown and no action is taken.

        参数：
        propertyName - one of the property names listed above
        listener - the property change listener to be added
        另请参见：
        removePropertyChangeListener(String, PropertyChangeListener), getPropertyChangeListeners(String), addPropertyChangeListener(String, PropertyChangeListener)

      • removePropertyChangeListener

        public void removePropertyChangeListener(String propertyName,
                                PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list for a specific property. This method should be used to remove PropertyChangeListeners that were registered for a specific bound property.

        If propertyName or listener is null, no exception is thrown and no action is taken.

        参数：
        propertyName - a valid property name
        listener - the PropertyChangeListener to be removed
        另请参见：
        addPropertyChangeListener(String, PropertyChangeListener), getPropertyChangeListeners(String), removePropertyChangeListener(PropertyChangeListener)

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
        Returns an array of all the listeners which have been associated with the named property.
        参数：
        propertyName - The name of the property being listened to
        返回：
        all of the PropertyChangeListeners associated with the named property; if no such listeners have been added or if propertyName is null, an empty array is returned
        另请参见：
        addPropertyChangeListener(String, PropertyChangeListener),
removePropertyChangeListener(String, PropertyChangeListener),
getPropertyChangeListeners()

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Support for reporting bound property changes for Object properties. This method can be called when a bound property has changed and it will send the appropriate PropertyChangeEvent to any registered PropertyChangeListeners.
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • applyPropertyChange

        public void applyPropertyChange(PropertyChangeEvent evt,
                       JLayer<? extends V> l)
        Notifies the LayerUI when any of its property are changed and enables updating every JLayer this LayerUI instance is set to.
        参数：
        evt - the PropertyChangeEvent generated by this LayerUI
        l - the JLayer this LayerUI is set to

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        If the JLayer's view component is not null, this calls the view's getBaseline() method. Otherwise, the default implementation is called.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JLayer to return baseline resize behavior for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        另请参见：
        JComponent.getBaseline(int,int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        If the JLayer's view component is not null, this returns the result of the view's getBaselineResizeBehavior() method. Otherwise, the default implementation is called.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JLayer to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        另请参见：
        JComponent.getBaseline(int, int)

      • doLayout

        public void doLayout(JLayer<? extends V> l)
        Causes the passed instance of JLayer to lay out its components.
        参数：
        l - the JLayer component where this UI delegate is being installed

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        If the JLayer's view component is not null, this returns the result of the view's getPreferredSize() method. Otherwise, the default implementation is used.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - JLayer to return preferred size for
        返回：
        preferred size for the passed JLayer
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        If the JLayer's view component is not null, this returns the result of the view's getMinimalSize() method. Otherwise, the default implementation is used.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - JLayer to return preferred size for
        返回：
        minimal size for the passed JLayer
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        If the JLayer's view component is not null, this returns the result of the view's getMaximumSize() method. Otherwise, the default implementation is used.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - JLayer to return preferred size for
        返回：
        maximum size for the passed JLayer
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • paintImmediately

        public void paintImmediately(int x,
                    int y,
                    int width,
                    int height,
                    JLayer<? extends V> l)
        Paints the specified region in the JLayer this LayerUI is set to, immediately.

        This method is to be overridden when the dirty region needs to be changed. The default implementation delegates its functionality to JComponent.paintImmediately(int, int, int, int).

        参数：
        x - the x value of the region to be painted
        y - the y value of the region to be painted
        w - the width of the region to be painted
        h - the height of the region to be painted
        另请参见：
        JComponent.paintImmediately(int, int, int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 ListUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ListUI
  • 直接已知子类：
    BasicListUI, MultiListUI

    public abstract class ListUI
extends ComponentUI
    The JList pluggable look and feel delegate.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ListUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Rectangle getCellBounds(JList list, int index1, int index2)
      Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.
      abstract Point indexToLocation(JList list, int index)
      Returns the origin in the given JList, of the specified item, in the list's coordinate system.
      abstract int locationToIndex(JList list, Point location)
      Returns the cell index in the specified JList closest to the given location in the list's coordinate system.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ListUI

        public ListUI()

    • 方法详细信息

      • locationToIndex

        public abstract int locationToIndex(JList list,
                  Point location)
        Returns the cell index in the specified JList closest to the given location in the list's coordinate system. To determine if the cell actually contains the specified location, compare the point against the cell's bounds, as provided by getCellBounds. This method returns -1 if the list's model is empty.
        参数：
        list - the list
        location - the coordinates of the point
        返回：
        the cell index closest to the given location, or -1
        抛出：
        NullPointerException - if location is null

      • indexToLocation

        public abstract Point indexToLocation(JList list,
                    int index)
        Returns the origin in the given JList, of the specified item, in the list's coordinate system. Returns null if the index isn't valid.
        参数：
        list - the list
        index - the cell index
        返回：
        the origin of the cell, or null

      • getCellBounds

        public abstract Rectangle getCellBounds(JList list,
                      int index1,
                      int index2)
        Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices. The indices can be supplied in any order.

        If the smaller index is outside the list's range of cells, this method returns null. If the smaller index is valid, but the larger index is outside the list's range, the bounds of just the first index is returned. Otherwise, the bounds of the valid range is returned.

        参数：
        list - the list
        index1 - the first index in the range
        index2 - the second index in the range
        返回：
        the bounding rectangle for the range of cells, or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gs"js "s "=cc"==ttnn" tsssa wjt sslpp"s


MenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 MenuBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.MenuBarUI
  • 直接已知子类：
    BasicMenuBarUI, MultiMenuBarUI

    public abstract class MenuBarUI
extends ComponentUI
    Pluggable look and feel interface for JMenuBar.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuBarUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MenuBarUI

        public MenuBarUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1tnoaecaeiddeiipnuunetnnooeiosdet


MenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 MenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
  • 直接已知子类：
    BasicMenuItemUI, MultiMenuItemUI

    public abstract class MenuItemUI
extends ButtonUI
    Pluggable look and feel interface for JMenuItem.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MenuItemUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MenuItemUI

        public MenuItemUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s:ot >se<


OptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 OptionPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.OptionPaneUI
  • 直接已知子类：
    BasicOptionPaneUI, MultiOptionPaneUI

    public abstract class OptionPaneUI
extends ComponentUI
    Pluggable look and feel interface for JOptionPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      OptionPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean containsCustomComponents(JOptionPane op)
      Returns true if the user has supplied instances of Component for either the options or message.
      abstract void selectInitialValue(JOptionPane op)
      Requests the component representing the default value to have focus.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OptionPaneUI

        public OptionPaneUI()

    • 方法详细信息

      • selectInitialValue

        public abstract void selectInitialValue(JOptionPane op)
        Requests the component representing the default value to have focus.

      • containsCustomComponents

        public abstract boolean containsCustomComponents(JOptionPane op)
        Returns true if the user has supplied instances of Component for either the options or message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xs1rt>soeceshi.dl>l/


PanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 PanelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PanelUI
  • 直接已知子类：
    BasicPanelUI, MultiPanelUI

    public abstract class PanelUI
extends ComponentUI
    Pluggable look and feel interface for Panel.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PanelUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PanelUI

        public PanelUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. shBlelBes/ssssfw..eav//>d


PopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 PopupMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PopupMenuUI
  • 直接已知子类：
    BasicPopupMenuUI, MultiPopupMenuUI

    public abstract class PopupMenuUI
extends ComponentUI
    Pluggable look and feel interface for JPopupMenu.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PopupMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Popup getPopup(JPopupMenu popup, int x, int y)
      Returns the Popup that will be responsible for displaying the JPopupMenu.
      boolean | isPopupTrigger(MouseEvent e)

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PopupMenuUI

        public PopupMenuUI()

    • 方法详细信息

      • isPopupTrigger

        public boolean isPopupTrigger(MouseEvent e)
        从以下版本开始：
        1.3

      • getPopup

        public Popup getPopup(JPopupMenu popup,
             int x,
             int y)
        Returns the Popup that will be responsible for displaying the JPopupMenu.
        参数：
        popup - JPopupMenu requesting Popup
        x - Screen x location Popup is to be shown at
        y - Screen y location Popup is to be shown at.
        返回：
        Popup that will show the JPopupMenu
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ie" <#g llblepT/a obxt


ProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ProgressBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ProgressBarUI
  • 直接已知子类：
    BasicProgressBarUI, MultiProgressBarUI

    public abstract class ProgressBarUI
extends ComponentUI
    Pluggable look and feel interface for JProgressBar.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ProgressBarUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProgressBarUI

        public ProgressBarUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=g"ta_nr_n-aan--#a OOBO RR >c s" m


RootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 RootPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.RootPaneUI
  • 直接已知子类：
    BasicRootPaneUI, MultiRootPaneUI

    public abstract class RootPaneUI
extends ComponentUI
    Pluggable look and feel interface for JRootPane.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      RootPaneUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RootPaneUI

        public RootPaneUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nt恬⺪l臊�4AhD 1-� $jaLa脆-"�


ScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ScrollBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollBarUI
  • 直接已知子类：
    BasicScrollBarUI, MultiScrollBarUI

    public abstract class ScrollBarUI
extends ComponentUI
    Pluggable look and feel interface for JScrollBar.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScrollBarUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ScrollBarUI

        public ScrollBarUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pp>/b/a/n/sl><g/ppyohd/npa


ScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ScrollPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollPaneUI
  • 直接已知子类：
    BasicScrollPaneUI, MultiScrollPaneUI

    public abstract class ScrollPaneUI
extends ComponentUI
    Pluggable look and feel interface for JScrollPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ScrollPaneUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ScrollPaneUI

        public ScrollPaneUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llho>o/o


SeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 SeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
  • 直接已知子类：
    BasicSeparatorUI, MultiSeparatorUI, SynthSeparatorUI

    public abstract class SeparatorUI
extends ComponentUI
    Pluggable look and feel interface for JSeparator.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SeparatorUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SeparatorUI

        public SeparatorUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e<>-" t>a"sbrtssmaaa-


SliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 SliderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SliderUI
  • 直接已知子类：
    BasicSliderUI, MultiSliderUI

    public abstract class SliderUI
extends ComponentUI
    Pluggable look and feel interface for JSlider.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SliderUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SliderUI

        public SliderUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shblbmbab<>


SpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 SpinnerUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SpinnerUI
  • 直接已知子类：
    BasicSpinnerUI, MultiSpinnerUI

    public abstract class SpinnerUI
extends ComponentUI
    Pluggable look and feel interface for JSpinner
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      SpinnerUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SpinnerUI

        public SpinnerUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fＣ�> 帽锚辉薄a怂颖权╢<


SplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 SplitPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SplitPaneUI
  • 直接已知子类：
    BasicSplitPaneUI, MultiSplitPaneUI

    public abstract class SplitPaneUI
extends ComponentUI
    Pluggable look and feel interface for JSplitPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SplitPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void finishedPaintingChildren(JSplitPane jc, Graphics g)
      Messaged after the JSplitPane the receiver is providing the look and feel for paints its children.
      abstract int getDividerLocation(JSplitPane jc)
      Returns the location of the divider.
      abstract int getMaximumDividerLocation(JSplitPane jc)
      Returns the maximum possible location of the divider.
      abstract int getMinimumDividerLocation(JSplitPane jc)
      Returns the minimum possible location of the divider.
      abstract void resetToPreferredSizes(JSplitPane jc)
      Messaged to relayout the JSplitPane based on the preferred size of the children components.
      abstract void setDividerLocation(JSplitPane jc, int location)
      Sets the location of the divider to location.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SplitPaneUI

        public SplitPaneUI()

    • 方法详细信息

      • resetToPreferredSizes

        public abstract void resetToPreferredSizes(JSplitPane jc)
        Messaged to relayout the JSplitPane based on the preferred size of the children components.

      • setDividerLocation

        public abstract void setDividerLocation(JSplitPane jc,
                      int location)
        Sets the location of the divider to location.

      • getDividerLocation

        public abstract int getDividerLocation(JSplitPane jc)
        Returns the location of the divider.

      • getMinimumDividerLocation

        public abstract int getMinimumDividerLocation(JSplitPane jc)
        Returns the minimum possible location of the divider.

      • getMaximumDividerLocation

        public abstract int getMaximumDividerLocation(JSplitPane jc)
        Returns the maximum possible location of the divider.

      • finishedPaintingChildren

        public abstract void finishedPaintingChildren(JSplitPane jc,
                            Graphics g)
        Messaged after the JSplitPane the receiver is providing the look and feel for paints its children.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vaf">ole/l .h..eh.edi >w!al/i/a"


TabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 TabbedPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TabbedPaneUI
  • 直接已知子类：
    BasicTabbedPaneUI, MultiTabbedPaneUI

    public abstract class TabbedPaneUI
extends ComponentUI
    Pluggable look and feel interface for JTabbedPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TabbedPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      abstract Rectangle | getTabBounds(JTabbedPane pane, int index)
      abstract int | getTabRunCount(JTabbedPane pane)
      abstract int | tabForCoordinate(JTabbedPane pane, int x, int y)

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TabbedPaneUI

        public TabbedPaneUI()

    • 方法详细信息

      • tabForCoordinate

        public abstract int tabForCoordinate(JTabbedPane pane,
                   int x,
                   int y)

      • getTabBounds

        public abstract Rectangle getTabBounds(JTabbedPane pane,
                     int index)

      • getTabRunCount

        public abstract int getTabRunCount(JTabbedPane pane)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aav.he(re(n<<(nniippsbhc< i>naiiii4h&


TableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 TableHeaderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableHeaderUI
  • 直接已知子类：
    BasicTableHeaderUI, MultiTableHeaderUI

    public abstract class TableHeaderUI
extends ComponentUI
    Pluggable look and feel interface for JTableHeader.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableHeaderUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableHeaderUI

        public TableHeaderUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d i>><< << //< <>))/xe/aPPltcisPne


TableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 TableUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableUI
  • 直接已知子类：
    BasicTableUI, MultiTableUI

    public abstract class TableUI
extends ComponentUI
    Pluggable look and feel interface for JTable.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableUI

        public TableUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ao9 � � 0 >#00a 319b9&,0200cr癮 鬳r


TextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 TextUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
  • 直接已知子类：
    BasicTextUI, MultiTextUI

    public abstract class TextUI
extends ComponentUI
    Text editor user interface

    • 构造方法摘要

      Constructors
      构造方法与描述
      TextUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void damageRange(JTextComponent t, int p0, int p1)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      abstract void damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      abstract EditorKit getEditorKit(JTextComponent t)
      Fetches the binding of services that set a policy for the type of document being edited.
      abstract int getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      abstract View getRootView(JTextComponent t)
      Fetches a View with the allocation of the associated text component (i.e.
      String getToolTipText(JTextComponent t, Point pt)
      Returns the string to be used as the tooltip at the passed in location.
      abstract Rectangle modelToView(JTextComponent t, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      abstract Rectangle modelToView(JTextComponent t, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      abstract int viewToModel(JTextComponent t, Point pt)
      Converts the given place in the view coordinate system to the nearest representative location in the model.
      abstract int viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TextUI

        public TextUI()

    • 方法详细信息

      • modelToView

        public abstract Rectangle modelToView(JTextComponent t,
                    int pos)
                               throws BadLocationException
        Converts the given location in the model to a place in the view coordinate system.
        参数：
        pos - the local location in the model to translate >= 0
        返回：
        the coordinates as a rectangle
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document

      • modelToView

        public abstract Rectangle modelToView(JTextComponent t,
                    int pos,
                    Position.Bias bias)
                               throws BadLocationException
        Converts the given location in the model to a place in the view coordinate system.
        参数：
        pos - the local location in the model to translate >= 0
        返回：
        the coordinates as a rectangle
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document

      • viewToModel

        public abstract int viewToModel(JTextComponent t,
              Point pt)
        Converts the given place in the view coordinate system to the nearest representative location in the model.
        参数：
        pt - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        返回：
        the offset from the start of the document >= 0

      • viewToModel

        public abstract int viewToModel(JTextComponent t,
              Point pt,
              Position.Bias[] biasReturn)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        参数：
        pt - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        biasReturn - filled in by this method to indicate whether the point given is closer to the previous or the next character in the model
        返回：
        the location within the model that best represents the given point in the view >= 0

      • getNextVisualPositionFrom

        public abstract int getNextVisualPositionFrom(JTextComponent t,
                            int pos,
                            Position.Bias b,
                            int direction,
                            Position.Bias[] biasRet)
                                       throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        参数：
        t - the text component for which this UI is installed
        pos - the position to convert >= 0
        b - the bias for the position
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This may be SwingConstants.WEST, SwingConstants.EAST, SwingConstants.NORTH, or SwingConstants.SOUTH
        biasRet - an array to contain the bias for the returned position
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException
        IllegalArgumentException - for an invalid direction

      • damageRange

        public abstract void damageRange(JTextComponent t,
               int p0,
               int p1)
        Causes the portion of the view responsible for the given part of the model to be repainted.
        参数：
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0

      • damageRange

        public abstract void damageRange(JTextComponent t,
               int p0,
               int p1,
               Position.Bias firstBias,
               Position.Bias secondBias)
        Causes the portion of the view responsible for the given part of the model to be repainted.
        参数：
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0

      • getEditorKit

        public abstract EditorKit getEditorKit(JTextComponent t)
        Fetches the binding of services that set a policy for the type of document being edited. This contains things like the commands available, stream readers and writers, etc.
        返回：
        the editor kit binding

      • getRootView

        public abstract View getRootView(JTextComponent t)
        Fetches a View with the allocation of the associated text component (i.e. the root of the hierarchy) that can be traversed to determine how the model is being represented spatially.
        返回：
        the view

      • getToolTipText

        public String getToolTipText(JTextComponent t,
                    Point pt)
        Returns the string to be used as the tooltip at the passed in location.
        从以下版本开始：
        1.4
        另请参见：
        JTextComponent.getToolTipText(java.awt.event.MouseEvent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ttnMpn Crnc竍tonv>fE =l"黣Mgl


ToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ToolBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolBarUI
  • 直接已知子类：
    BasicToolBarUI, MultiToolBarUI

    public abstract class ToolBarUI
extends ComponentUI
    Pluggable look and feel interface for JToolBar.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ToolBarUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ToolBarUI

        public ToolBarUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x.txljM(jMoooMoovUnn/c


ToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ToolTipUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolTipUI
  • 直接已知子类：
    BasicToolTipUI, MultiToolTipUI

    public abstract class ToolTipUI
extends ComponentUI
    Pluggable look and feel interface for JToolTip.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ToolTipUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ToolTipUI

        public ToolTipUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.tdl�@oo@駉� nXM俇tx2 /a衕


TreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf

类 TreeUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TreeUI
  • 直接已知子类：
    BasicTreeUI, MultiTreeUI

    public abstract class TreeUI
extends ComponentUI
    Pluggable look and feel interface for JTree.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TreeUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void cancelEditing(JTree tree)
      Cancels the current editing session.
      abstract TreePath getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      abstract Rectangle getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      abstract TreePath getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      abstract int getRowCount(JTree tree)
      Returns the number of rows that are being displayed.
      abstract int getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract boolean isEditing(JTree tree)
      Returns true if the tree is being edited.
      abstract void startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      abstract boolean stopEditing(JTree tree)
      Stops the current editing session.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TreeUI

        public TreeUI()

    • 方法详细信息

      • getPathBounds

        public abstract Rectangle getPathBounds(JTree tree,
                      TreePath path)
        Returns the Rectangle enclosing the label portion that the last item in path will be drawn into. Will return null if any component in path is currently valid.

      • getPathForRow

        public abstract TreePath getPathForRow(JTree tree,
                     int row)
        Returns the path for passed in row. If row is not visible null is returned.

      • getRowForPath

        public abstract int getRowForPath(JTree tree,
                TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.

      • getRowCount

        public abstract int getRowCount(JTree tree)
        Returns the number of rows that are being displayed.

      • getClosestPathForLocation

        public abstract TreePath getClosestPathForLocation(JTree tree,
                                 int x,
                                 int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.

      • isEditing

        public abstract boolean isEditing(JTree tree)
        Returns true if the tree is being edited. The item that is being edited can be returned by getEditingPath().

      • stopEditing

        public abstract boolean stopEditing(JTree tree)
        Stops the current editing session. This has no effect if the tree isn't being edited. Returns true if the editor allows the editing session to stop.

      • cancelEditing

        public abstract void cancelEditing(JTree tree)
        Cancels the current editing session. This has no effect if the tree isn't being edited. Returns true if the editor allows the editing session to stop.

      • startEditingAtPath

        public abstract void startEditingAtPath(JTree tree,
                      TreePath path)
        Selects the last item in path and tries to edit it. Editing will fail if the CellEditor won't allow it for the selected item.

      • getEditingPath

        public abstract TreePath getEditingPath(JTree tree)
        Returns the path to the element that is being edited.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

levci/tlm""mott=>so r&"h&rsTa.t


UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.plaf

Interface UIResource

  • All Known Implementing Classes:
    ActionMapUIResource, BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.SplitPaneBorder, BasicBorders.ToggleButtonBorder, BasicComboBoxEditor.UIResource, BasicComboBoxRenderer.UIResource, BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter, BorderUIResource, BorderUIResource.BevelBorderUIResource, BorderUIResource.CompoundBorderUIResource, BorderUIResource.EmptyBorderUIResource, BorderUIResource.EtchedBorderUIResource, BorderUIResource.LineBorderUIResource, BorderUIResource.MatteBorderUIResource, BorderUIResource.TitledBorderUIResource, ColorUIResource, ComponentInputMapUIResource, DefaultListCellRenderer.UIResource, DefaultMenuLayout, DefaultTableCellRenderer.UIResource, DimensionUIResource, FontUIResource, IconUIResource, InputMapUIResource, InsetsUIResource, JScrollPane.ScrollBar, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.RolloverButtonBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TextFieldBorder, MetalBorders.ToggleButtonBorder, MetalBorders.ToolBarBorder, MetalCheckBoxIcon, MetalComboBoxEditor.UIResource, MetalIconFactory.PaletteCloseIcon, ScrollPaneLayout.UIResource

    public interface UIResource
    This interface is used to mark objects created by ComponentUI delegates. The ComponentUI.installUI() and ComponentUI.uninstallUI() methods can use this interface to decide if a properties value has been overridden. For example, the JList cellRenderer property is initialized by BasicListUI.installUI(), only if it's initial value is null:
     if (list.getCellRenderer() == null) {
     list.setCellRenderer((ListCellRenderer)(UIManager.get("List.cellRenderer")));
 }
    At uninstallUI() time we reset the property to null if its value is an instance of UIResource:
     if (list.getCellRenderer() instanceof UIResource) {
     list.setCellRenderer(null);
 }
    This pattern applies to all properties except the java.awt.Component properties font, foreground, and background. If one of these properties isn't initialized, or is explicitly set to null, its container provides the value. For this reason the "== null" is unreliable when installUI() is called to dynamically change a components look and feel. So at installUI() time we check to see if the current value is a UIResource:
     if (!(list.getFont() instanceof UIResource)) {
     list.setFont(UIManager.getFont("List.font"));
 }
    另请参见：
    ComponentUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pe;eg>s">s.wws..jlmm"veR/


Uses of Package javax.swing.plaf

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf

  • Packages that use javax.swing.plaf
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
  • Classes in javax.swing.plaf used by javax.swing
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorChooserUI
    Pluggable look and feel interface for JColorChooser.
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    DesktopPaneUI
    Pluggable look and feel interface for JDesktopPane.
    FileChooserUI
    Pluggable look and feel interface for JFileChooser.
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    LayerUI
    The base class for all JLayer's UI delegates.
    ListUI
    The JList pluggable look and feel delegate.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    MenuItemUI
    Pluggable look and feel interface for JMenuItem.
    OptionPaneUI
    Pluggable look and feel interface for JOptionPane.
    PanelUI
    Pluggable look and feel interface for Panel.
    PopupMenuUI
    Pluggable look and feel interface for JPopupMenu.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SpinnerUI
    Pluggable look and feel interface for JSpinner
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TableUI
    Pluggable look and feel interface for JTable.
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
    ViewportUI
    Pluggable look and feel interface for JViewport.
  • Classes in javax.swing.plaf used by javax.swing.plaf
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
  • Classes in javax.swing.plaf used by javax.swing.plaf.basic
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorChooserUI
    Pluggable look and feel interface for JColorChooser.
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    DesktopPaneUI
    Pluggable look and feel interface for JDesktopPane.
    FileChooserUI
    Pluggable look and feel interface for JFileChooser.
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    ListUI
    The JList pluggable look and feel delegate.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    MenuItemUI
    Pluggable look and feel interface for JMenuItem.
    OptionPaneUI
    Pluggable look and feel interface for JOptionPane.
    PanelUI
    Pluggable look and feel interface for Panel.
    PopupMenuUI
    Pluggable look and feel interface for JPopupMenu.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SpinnerUI
    Pluggable look and feel interface for JSpinner
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TableHeaderUI
    Pluggable look and feel interface for JTableHeader.
    TableUI
    Pluggable look and feel interface for JTable.
    TextUI
    Text editor user interface
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
    ViewportUI
    Pluggable look and feel interface for JViewport.
  • Classes in javax.swing.plaf used by javax.swing.plaf.metal
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorUIResource
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    FileChooserUI
    Pluggable look and feel interface for JFileChooser.
    FontUIResource
    A subclass of java.awt.Font that implements UIResource.
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TextUI
    Text editor user interface
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
  • Classes in javax.swing.plaf used by javax.swing.plaf.multi
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorChooserUI
    Pluggable look and feel interface for JColorChooser.
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    DesktopPaneUI
    Pluggable look and feel interface for JDesktopPane.
    FileChooserUI
    Pluggable look and feel interface for JFileChooser.
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    ListUI
    The JList pluggable look and feel delegate.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    MenuItemUI
    Pluggable look and feel interface for JMenuItem.
    OptionPaneUI
    Pluggable look and feel interface for JOptionPane.
    PanelUI
    Pluggable look and feel interface for Panel.
    PopupMenuUI
    Pluggable look and feel interface for JPopupMenu.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SpinnerUI
    Pluggable look and feel interface for JSpinner
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TableHeaderUI
    Pluggable look and feel interface for JTableHeader.
    TableUI
    Pluggable look and feel interface for JTable.
    TextUI
    Text editor user interface
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    ViewportUI
    Pluggable look and feel interface for JViewport.
  • Classes in javax.swing.plaf used by javax.swing.plaf.synth
    类与描述
    ButtonUI
    Pluggable look and feel interface for JButton.
    ColorChooserUI
    Pluggable look and feel interface for JColorChooser.
    ComboBoxUI
    Pluggable look and feel interface for JComboBox.
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    DesktopIconUI
    Pluggable look and feel interface for JDesktopIcon.
    DesktopPaneUI
    Pluggable look and feel interface for JDesktopPane.
    InternalFrameUI
    Pluggable look and feel interface for JInternalFrame.
    LabelUI
    Pluggable look and feel interface for JLabel.
    ListUI
    The JList pluggable look and feel delegate.
    MenuBarUI
    Pluggable look and feel interface for JMenuBar.
    MenuItemUI
    Pluggable look and feel interface for JMenuItem.
    OptionPaneUI
    Pluggable look and feel interface for JOptionPane.
    PanelUI
    Pluggable look and feel interface for Panel.
    PopupMenuUI
    Pluggable look and feel interface for JPopupMenu.
    ProgressBarUI
    Pluggable look and feel interface for JProgressBar.
    RootPaneUI
    Pluggable look and feel interface for JRootPane.
    ScrollBarUI
    Pluggable look and feel interface for JScrollBar.
    ScrollPaneUI
    Pluggable look and feel interface for JScrollPane.
    SeparatorUI
    Pluggable look and feel interface for JSeparator.
    SliderUI
    Pluggable look and feel interface for JSlider.
    SpinnerUI
    Pluggable look and feel interface for JSpinner
    SplitPaneUI
    Pluggable look and feel interface for JSplitPane.
    TabbedPaneUI
    Pluggable look and feel interface for JTabbedPane.
    TableHeaderUI
    Pluggable look and feel interface for JTableHeader.
    TableUI
    Pluggable look and feel interface for JTable.
    TextUI
    Text editor user interface
    ToolBarUI
    Pluggable look and feel interface for JToolBar.
    ToolTipUI
    Pluggable look and feel interface for JToolTip.
    TreeUI
    Pluggable look and feel interface for JTree.
    ViewportUI
    Pluggable look and feel interface for JViewport.
  • Classes in javax.swing.plaf used by javax.swing.table
    类与描述
    TableHeaderUI
    Pluggable look and feel interface for JTableHeader.
    UIResource
    This interface is used to mark objects created by ComponentUI delegates.
  • Classes in javax.swing.plaf used by javax.swing.text
    类与描述
    ComponentUI
    The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
    TextUI
    Text editor user interface
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


ViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf

类 ViewportUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ViewportUI
  • 直接已知子类：
    BasicViewportUI, MultiViewportUI, SynthViewportUI

    public abstract class ViewportUI
extends ComponentUI
    Pluggable look and feel interface for JViewport.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ViewportUI()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ViewportUI

        public ViewportUI()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=o=esn on srr ssrlvvroir'n e t or


BasicArrowButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicArrowButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JButton
              • javax.swing.plaf.basic.BasicArrowButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
    直接已知子类：
    MetalScrollButton

    public class BasicArrowButton
extends JButton
implements SwingConstants
    JButton object that draws a scaled Arrow in one of the cardinal directions.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JButton

        JButton.AccessibleJButton

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int direction
      The direction of the arrow.

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicArrowButton(int direction)
      Creates a BasicArrowButton whose arrow is drawn in the specified direction.
      BasicArrowButton(int direction, Color background, Color shadow, Color darkShadow, Color highlight)
      Creates a BasicArrowButton whose arrow is drawn in the specified direction and with the specified colors.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getDirection()
      Returns the direction of the arrow.
      Dimension getMaximumSize()
      Returns the maximum size of the BasicArrowButton.
      Dimension getMinimumSize()
      Returns the minimum size of the BasicArrowButton.
      Dimension getPreferredSize()
      Returns the preferred size of the BasicArrowButton.
      boolean isFocusTraversable()
      Returns whether the arrow button should get the focus.
      void paint(Graphics g)
      Invoked by Swing to draw components.
      void paintTriangle(Graphics g, int x, int y, int size, int direction, boolean isEnabled)
      Paints a triangle.
      void setDirection(int direction)
      Sets the direction of the arrow.

      • 方法 - 继承于类 javax.swing.JButton

        getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • direction

        protected int direction
        The direction of the arrow. One of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST.

    • 构造方法详细信息

      • BasicArrowButton

        public BasicArrowButton(int direction,
                Color background,
                Color shadow,
                Color darkShadow,
                Color highlight)
        Creates a BasicArrowButton whose arrow is drawn in the specified direction and with the specified colors.
        参数：
        direction - the direction of the arrow; one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
        background - the background color of the button
        shadow - the color of the shadow
        darkShadow - the color of the dark shadow
        highlight - the color of the highlight
        从以下版本开始：
        1.4

      • BasicArrowButton

        public BasicArrowButton(int direction)
        Creates a BasicArrowButton whose arrow is drawn in the specified direction.
        参数：
        direction - the direction of the arrow; one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST

    • 方法详细信息

      • getDirection

        public int getDirection()
        Returns the direction of the arrow.

      • setDirection

        public void setDirection(int direction)
        Sets the direction of the arrow.
        参数：
        direction - the direction of the arrow; one of of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST

      • paint

        public void paint(Graphics g)
        Description copied from class: JComponent
        Invoked by Swing to draw components. Applications should not invoke paint directly, but should instead use the repaint method to schedule the component for redrawing.

        This method actually delegates the work of painting to three protected methods: paintComponent, paintBorder, and paintChildren. They're called in the order listed to ensure that children appear on top of component itself. Generally speaking, the component and its children should not paint in the insets area allocated to the border. Subclasses can just override this method, as always. A subclass that just wants to specialize the UI (look and feel) delegate's paint method should just override paintComponent.

        重载：
        paint in class JComponent
        参数：
        g - the Graphics context in which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size of the BasicArrowButton.
        重载：
        getPreferredSize in class JComponent
        返回：
        the preferred size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • getMinimumSize

        public Dimension getMinimumSize()
        Returns the minimum size of the BasicArrowButton.
        重载：
        getMinimumSize in class JComponent
        返回：
        the minimum size
        另请参见：
        JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

      • getMaximumSize

        public Dimension getMaximumSize()
        Returns the maximum size of the BasicArrowButton.
        重载：
        getMaximumSize in class JComponent
        返回：
        the maximum size
        另请参见：
        JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

      • isFocusTraversable

        public boolean isFocusTraversable()
        Returns whether the arrow button should get the focus. BasicArrowButtons are used as a child component of composite components such as JScrollBar and JComboBox. Since the composite component typically gets the focus, this method is overriden to return false.
        重载：
        isFocusTraversable in class Component
        返回：
        false
        另请参见：
        Component.setFocusable(boolean)

      • paintTriangle

        public void paintTriangle(Graphics g,
                 int x,
                 int y,
                 int size,
                 int direction,
                 boolean isEnabled)
        Paints a triangle.
        参数：
        g - the Graphics to draw to
        x - the x coordinate
        y - the y coordinate
        size - the size of the triangle to draw
        direction - the direction in which to draw the arrow; one of SwingConstants.NORTH, SwingConstants.SOUTH, SwingConstants.EAST or SwingConstants.WEST
        isEnabled - whether or not the arrow is drawn enabled
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicBorders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders

  • java.lang.Object
    • javax.swing.plaf.basic.BasicBorders

  • public class BasicBorders
extends Object
    Factory object that can vend Borders appropriate for the basic L & F.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  | BasicBorders.ButtonBorder
      static class  | BasicBorders.FieldBorder
      static class  | BasicBorders.MarginBorder
      static class  | BasicBorders.MenuBarBorder
      static class  | BasicBorders.RadioButtonBorder
      static class  BasicBorders.RolloverButtonBorder
      Special thin border for rollover toolbar buttons.
      static class  BasicBorders.SplitPaneBorder
      Draws the border around the splitpane.
      static class  | BasicBorders.ToggleButtonBorder

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Border | getButtonBorder()
      static Border | getInternalFrameBorder()
      static Border | getMenuBarBorder()
      static Border | getProgressBarBorder()
      static Border | getRadioButtonBorder()
      static Border | getSplitPaneBorder()
      static Border getSplitPaneDividerBorder()
      Returns a border instance for a JSplitPane divider
      static Border | getTextFieldBorder()
      static Border | getToggleButtonBorder()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders

        public BasicBorders()

    • 方法详细信息

      • getButtonBorder

        public static Border getButtonBorder()

      • getRadioButtonBorder

        public static Border getRadioButtonBorder()

      • getToggleButtonBorder

        public static Border getToggleButtonBorder()

      • getMenuBarBorder

        public static Border getMenuBarBorder()

      • getSplitPaneBorder

        public static Border getSplitPaneBorder()

      • getSplitPaneDividerBorder

        public static Border getSplitPaneDividerBorder()
        Returns a border instance for a JSplitPane divider
        从以下版本开始：
        1.3

      • getTextFieldBorder

        public static Border getTextFieldBorder()

      • getProgressBarBorder

        public static Border getProgressBarBorder()

      • getInternalFrameBorder

        public static Border getInternalFrameBorder()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

clr/"/e/s/taascpatcc"e<.h..flC"lmmarjtpk


BasicBorders.ButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.ButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    直接已知子类：
    BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.ToggleButtonBorder
    封闭类：
    BasicBorders

    public static class BasicBorders.ButtonBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | darkShadow
      protected Color | highlight
      protected Color | lightHighlight
      protected Color | shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.ButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • shadow

        protected Color shadow

      • darkShadow

        protected Color darkShadow

      • highlight

        protected Color highlight

      • lightHighlight

        protected Color lightHighlight

    • 构造方法详细信息

      • BasicBorders.ButtonBorder

        public BasicBorders.ButtonBorder(Color shadow,
                         Color darkShadow,
                         Color highlight,
                         Color lightHighlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"rdv <> <./.>..cBeetr/)


BasicBorders.FieldBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.FieldBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.FieldBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | darkShadow
      protected Color | highlight
      protected Color | lightHighlight
      protected Color | shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.FieldBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • shadow

        protected Color shadow

      • darkShadow

        protected Color darkShadow

      • highlight

        protected Color highlight

      • lightHighlight

        protected Color lightHighlight

    • 构造方法详细信息

      • BasicBorders.FieldBorder

        public BasicBorders.FieldBorder(Color shadow,
                        Color darkShadow,
                        Color highlight,
                        Color lightHighlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

odr e u F >b>Fofh逾鈔t<=lzz>et:tutg=tteb/poptr


BasicBorders.MarginBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.MarginBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.MarginBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.MarginBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.MarginBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque, paintBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders.MarginBorder

        public BasicBorders.MarginBorder()

    • 方法详细信息

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e"stc ic css ccp4tt >->/ ac<<<-


BasicBorders.MenuBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.MenuBarBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.MenuBarBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.MenuBarBorder(Color shadow, Color highlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders.MenuBarBorder

        public BasicBorders.MenuBarBorder(Color shadow,
                          Color highlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m<<<#>at/d(bb otflllf/oSttt&a皏ngp


BasicBorders.RadioButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.RadioButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.RadioButtonBorder
extends BasicBorders.ButtonBorder

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicBorders.ButtonBorder

        darkShadow, highlight, lightHighlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.RadioButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders.RadioButtonBorder

        public BasicBorders.RadioButtonBorder(Color shadow,
                              Color darkShadow,
                              Color highlight,
                              Color lightHighlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class BasicBorders.ButtonBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class BasicBorders.ButtonBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0t0a"a>/xr/)#a0t920&w9v1022,a9 t2r,,,0&a


BasicBorders.RolloverButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.RolloverButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.RolloverButtonBorder
extends BasicBorders.ButtonBorder
    Special thin border for rollover toolbar buttons.
    从以下版本开始：
    1.4

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicBorders.ButtonBorder

        darkShadow, highlight, lightHighlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.RolloverButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicBorders.ButtonBorder

        getBorderInsets

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders.RolloverButtonBorder

        public BasicBorders.RolloverButtonBorder(Color shadow,
                                 Color darkShadow,
                                 Color highlight,
                                 Color lightHighlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class BasicBorders.ButtonBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e tm m mgmun.gel.daa lme>sss lp-sis


BasicBorders.SplitPaneBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.SplitPaneBorder

  • java.lang.Object
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
  • 所有已实现的接口：
    Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.SplitPaneBorder
extends Object
implements Border, UIResource
    Draws the border around the splitpane. To work correctly you shoudl also install a border on the divider (property SplitPaneDivider.border).

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | highlight
      protected Color | shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.SplitPaneBorder(Color highlight, Color shadow)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c)
      Returns the insets of the border.
      boolean isBorderOpaque()
      Returns whether or not the border is opaque.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      Paints the border for the specified component with the specified position and size.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • highlight

        protected Color highlight

      • shadow

        protected Color shadow

    • 构造方法详细信息

      • BasicBorders.SplitPaneBorder

        public BasicBorders.SplitPaneBorder(Color highlight,
                            Color shadow)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        从接口复制的描述： Border
        Paints the border for the specified component with the specified position and size.
        指定者：
        paintBorder in interface Border
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c)
        从接口复制的描述： Border
        Returns the insets of the border.
        指定者：
        getBorderInsets in interface Border
        参数：
        c - the component for which this border insets value applies

      • isBorderOpaque

        public boolean isBorderOpaque()
        从接口复制的描述： Border
        Returns whether or not the border is opaque. If the border is opaque, it is responsible for filling in it's own background when painting.
        指定者：
        isBorderOpaque in interface Border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>> p|pLpips
  • ll&rrl/>l<<<巫謑;< <&ss|


BasicBorders.ToggleButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicBorders.ToggleButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    BasicBorders

    public static class BasicBorders.ToggleButtonBorder
extends BasicBorders.ButtonBorder

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicBorders.ButtonBorder

        darkShadow, highlight, lightHighlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicBorders.ToggleButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int width, int height)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicBorders.ToggleButtonBorder

        public BasicBorders.ToggleButtonBorder(Color shadow,
                               Color darkShadow,
                               Color highlight,
                               Color lightHighlight)

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int width,
               int height)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class BasicBorders.ButtonBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        width - the width of the painted border
        height - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class BasicBorders.ButtonBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

抧[�勿1 �埾�1's 恏/$ 0cV0P}>X�


BasicButtonListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicButtonListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicButtonListener
  • 所有已实现的接口：
    FocusListener, MouseListener, MouseMotionListener, PropertyChangeListener, EventListener, ChangeListener

    public class BasicButtonListener
extends Object
implements MouseListener, MouseMotionListener, FocusListener, ChangeListener, PropertyChangeListener
    Button Listener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicButtonListener(AbstractButton b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | checkOpacity(AbstractButton b)
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.
      void installKeyboardActions(JComponent c)
      Register default key actions: pressing space to "click" a button and registring the keyboard mnemonic (if any).
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.
      void uninstallKeyboardActions(JComponent c)
      Unregister's default key actions

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicButtonListener

        public BasicButtonListener(AbstractButton b)

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • checkOpacity

        protected void checkOpacity(AbstractButton b)

      • installKeyboardActions

        public void installKeyboardActions(JComponent c)
        Register default key actions: pressing space to "click" a button and registring the keyboard mnemonic (if any).

      • uninstallKeyboardActions

        public void uninstallKeyboardActions(JComponent c)
        Unregister's default key actions

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Cc pd.ael 嫉>F


BasicButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
  • 直接已知子类：
    BasicToggleButtonUI, MetalButtonUI, SynthButtonUI

    public class BasicButtonUI
extends ButtonUI
    BasicButton implementation

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | defaultTextIconGap
      protected int | defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | clearTextShiftOffset()
      protected BasicButtonListener | createButtonListener(AbstractButton b)
      static ComponentUI | createUI(JComponent c)
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      int | getDefaultTextIconGap(AbstractButton b)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected String | getPropertyPrefix()
      protected int | getTextShiftOffset()
      protected void | installDefaults(AbstractButton b)
      protected void | installKeyboardActions(AbstractButton b)
      protected void | installListeners(AbstractButton b)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | paintButtonPressed(Graphics g, AbstractButton b)
      protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void | paintIcon(Graphics g, JComponent c, Rectangle iconRect)
      protected void paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
      Method which renders the text of the current button.
      protected void paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      As of Java 2 platform v 1.4 this method should not be used or overriden.
      protected void | setTextShiftOffset()
      protected void | uninstallDefaults(AbstractButton b)
      protected void | uninstallKeyboardActions(AbstractButton b)
      protected void | uninstallListeners(AbstractButton b)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • defaultTextIconGap

        protected int defaultTextIconGap

      • defaultTextShiftOffset

        protected int defaultTextShiftOffset

    • 构造方法详细信息

      • BasicButtonUI

        public BasicButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • getPropertyPrefix

        protected String getPropertyPrefix()

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults(AbstractButton b)

      • installListeners

        protected void installListeners(AbstractButton b)

      • installKeyboardActions

        protected void installKeyboardActions(AbstractButton b)

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions(AbstractButton b)

      • uninstallListeners

        protected void uninstallListeners(AbstractButton b)

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)

      • createButtonListener

        protected BasicButtonListener createButtonListener(AbstractButton b)

      • getDefaultTextIconGap

        public int getDefaultTextIconGap(AbstractButton b)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintIcon

        protected void paintIcon(Graphics g,
             JComponent c,
             Rectangle iconRect)

      • paintText

        protected void paintText(Graphics g,
             JComponent c,
             Rectangle textRect,
             String text)
        As of Java 2 platform v 1.4 this method should not be used or overriden. Use the paintText method which takes the AbstractButton argument.

      • paintText

        protected void paintText(Graphics g,
             AbstractButton b,
             Rectangle textRect,
             String text)
        Method which renders the text of the current button.

        参数：
        g - Graphics context
        b - Current button to render
        textRect - Bounding rectangle to render the text.
        text - String to render
        从以下版本开始：
        1.4

      • paintFocus

        protected void paintFocus(Graphics g,
              AbstractButton b,
              Rectangle viewRect,
              Rectangle textRect,
              Rectangle iconRect)

      • paintButtonPressed

        protected void paintButtonPressed(Graphics g,
                      AbstractButton b)

      • clearTextShiftOffset

        protected void clearTextShiftOffset()

      • setTextShiftOffset

        protected void setTextShiftOffset()

      • getTextShiftOffset

        protected int getTextShiftOffset()

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicCheckBoxMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicCheckBoxMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

  • public class BasicCheckBoxMenuItemUI
extends BasicMenuItemUI
    BasicCheckboxMenuItem implementation

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicCheckBoxMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      protected String | getPropertyPrefix()
      void | processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicCheckBoxMenuItemUI

        public BasicCheckBoxMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicMenuItemUI

      • processMouseEvent

        public void processMouseEvent(JMenuItem item,
                     MouseEvent e,
                     MenuElement[] path,
                     MenuSelectionManager manager)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

el(met/ct/gOO/gga.rr<>air


BasicCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicCheckBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI

  • public class BasicCheckBoxUI
extends BasicRadioButtonUI
    CheckboxUI implementation for BasicCheckboxUI

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicRadioButtonUI

        icon

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicCheckBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      String getPropertyPrefix()

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicRadioButtonUI

        getDefaultIcon, getPreferredSize, installDefaults, paint, paintFocus, uninstallDefaults

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToggleButtonUI

        getTextShiftOffset, paintIcon

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicCheckBoxUI

        public BasicCheckBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • getPropertyPrefix

        public String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicRadioButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k BicisicisCehCCBfaassis>lccnas""s>==raa


BasicColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicColorChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
  • 直接已知子类：
    SynthColorChooserUI

    public class BasicColorChooserUI
extends ColorChooserUI
    Provides the basic look and feel for a JColorChooser.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicColorChooserUI.PropertyHandler
      This inner class is marked "public" due to a compiler bug.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JColorChooser chooser
      JColorChooser this BasicColorChooserUI is installed on.
      protected AbstractColorChooserPanel[] | defaultChoosers
      protected ChangeListener | previewListener
      protected PropertyChangeListener | propertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicColorChooserUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected AbstractColorChooserPanel[] | createDefaultChoosers()
      protected PropertyChangeListener | createPropertyChangeListener()
      static ComponentUI | createUI(JComponent c)
      protected void | installDefaults()
      protected void | installListeners()
      protected void | installPreviewPanel()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallDefaultChoosers()
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      protected void uninstallPreviewPanel()
      Removes installed preview panel from the UI delegate.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • chooser

        protected JColorChooser chooser
        JColorChooser this BasicColorChooserUI is installed on.
        从以下版本开始：
        1.5

      • defaultChoosers

        protected AbstractColorChooserPanel[] defaultChoosers

      • previewListener

        protected ChangeListener previewListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

    • 构造方法详细信息

      • BasicColorChooserUI

        public BasicColorChooserUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • createDefaultChoosers

        protected AbstractColorChooserPanel[] createDefaultChoosers()

      • uninstallDefaultChoosers

        protected void uninstallDefaultChoosers()

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installPreviewPanel

        protected void installPreviewPanel()

      • uninstallPreviewPanel

        protected void uninstallPreviewPanel()
        Removes installed preview panel from the UI delegate.
        从以下版本开始：
        1.7

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installListeners

        protected void installListeners()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • uninstallListeners

        protected void uninstallListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsfica


BasicColorChooserUI.PropertyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicColorChooserUI.PropertyHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicColorChooserUI

    public class BasicColorChooserUI.PropertyHandler
extends Object
implements PropertyChangeListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicColorChooserUI.PropertyHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicColorChooserUI.PropertyHandler

        public BasicColorChooserUI.PropertyHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/"csllra/r/""fwcC/oabblnja/l


BasicComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxEditor

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxEditor
  • 所有已实现的接口：
    FocusListener, EventListener, ComboBoxEditor
    直接已知子类：
    BasicComboBoxEditor.UIResource, MetalComboBoxEditor

    public class BasicComboBoxEditor
extends Object
implements ComboBoxEditor, FocusListener
    The default editor for editable combo boxes. The editor is implemented as a JTextField.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  BasicComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JTextField | editor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxEditor()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionListener(ActionListener l)
      Add an ActionListener.
      protected JTextField createEditorComponent()
      Creates the internal editor component.
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.
      Component getEditorComponent()
      Return the component that should be added to the tree hierarchy for this editor
      Object getItem()
      Return the edited item
      void removeActionListener(ActionListener l)
      Remove an ActionListener
      void selectAll()
      Ask the editor to start editing and to select everything
      void setItem(Object anObject)
      Sets the item that should be edited.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • editor

        protected JTextField editor

    • 构造方法详细信息

      • BasicComboBoxEditor

        public BasicComboBoxEditor()

    • 方法详细信息

      • getEditorComponent

        public Component getEditorComponent()
        从接口复制的描述： ComboBoxEditor
        Return the component that should be added to the tree hierarchy for this editor
        指定者：
        getEditorComponent in interface ComboBoxEditor

      • createEditorComponent

        protected JTextField createEditorComponent()
        Creates the internal editor component. Override this to provide a custom implementation.
        返回：
        a new editor component
        从以下版本开始：
        1.6

      • setItem

        public void setItem(Object anObject)
        Sets the item that should be edited.
        指定者：
        setItem in interface ComboBoxEditor
        参数：
        anObject - the displayed value of the editor

      • getItem

        public Object getItem()
        从接口复制的描述： ComboBoxEditor
        Return the edited item
        指定者：
        getItem in interface ComboBoxEditor

      • selectAll

        public void selectAll()
        从接口复制的描述： ComboBoxEditor
        Ask the editor to start editing and to select everything
        指定者：
        selectAll in interface ComboBoxEditor

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener

      • addActionListener

        public void addActionListener(ActionListener l)
        从接口复制的描述： ComboBoxEditor
        Add an ActionListener. An action event is generated when the edited item changes
        指定者：
        addActionListener in interface ComboBoxEditor

      • removeActionListener

        public void removeActionListener(ActionListener l)
        从接口复制的描述： ComboBoxEditor
        Remove an ActionListener
        指定者：
        removeActionListener in interface ComboBoxEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s tslcl c>a >aa-


BasicComboBoxEditor.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.basic

类 BasicComboBoxEditor.UIResource

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxEditor
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
  • 所有已实现的接口：
    FocusListener, EventListener, ComboBoxEditor, UIResource
    封闭类：
    BasicComboBoxEditor

    public static class BasicComboBoxEditor.UIResource
extends BasicComboBoxEditor
implements UIResource
    A subclass of BasicComboBoxEditor that implements UIResource. BasicComboBoxEditor doesn't implement UIResource directly so that applications can safely override the cellRenderer property with BasicListCellRenderer subclasses.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicComboBoxEditor

        BasicComboBoxEditor.UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxEditor

        editor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxEditor.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxEditor

        addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxEditor.UIResource

        public BasicComboBoxEditor.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/tCa.../../...//feeeopmt)o


BasicComboBoxRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.plaf.basic.BasicComboBoxRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, SwingConstants
    直接已知子类：
    BasicComboBoxRenderer.UIResource

    public class BasicComboBoxRenderer
extends JLabel
implements ListCellRenderer, Serializable
    ComboBox renderer

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static Border noFocusBorder
      An empty Border.

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxRenderer()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Return a component that has been configured to display the specified value.
      Dimension getPreferredSize()
      If the preferredSize has been set to a non-null value just returns it.

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • noFocusBorder

        protected static Border noFocusBorder
        An empty Border. This field might not be used. To change the Border used by this renderer directly set it using the setBorder method.

    • 构造方法详细信息

      • BasicComboBoxRenderer

        public BasicComboBoxRenderer()

    • 方法详细信息

      • getPreferredSize

        public Dimension getPreferredSize()
        Description copied from class: JComponent
        If the preferredSize has been set to a non-null value just returns it. If the UI delegate's getPreferredSize method returns a non null value then return that; otherwise defer to the component's layout manager.
        重载：
        getPreferredSize in class JComponent
        返回：
        the value of the preferredSize property
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • getListCellRendererComponent

        public Component getListCellRendererComponent(JList list,
                                     Object value,
                                     int index,
                                     boolean isSelected,
                                     boolean cellHasFocus)
        从接口复制的描述： ListCellRenderer
        Return a component that has been configured to display the specified value. That component's paint method is then called to "render" the cell. If it is necessary to compute the dimensions of a list because the list cells do not have a fixed size, this method is called to generate a component on which getPreferredSize can be invoked.
        指定者：
        getListCellRendererComponent in interface ListCellRenderer
        参数：
        list - The JList we're painting.
        value - The value returned by list.getModel().getElementAt(index).
        index - The cells index.
        isSelected - True if the specified cell was selected.
        cellHasFocus - True if the specified cell has the focus.
        返回：
        A component whose paint() method will render the specified value.
        另请参见：
        JList, ListSelectionModel, ListModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicComboBoxRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.basic

类 BasicComboBoxRenderer.UIResource

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.plaf.basic.BasicComboBoxRenderer
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, UIResource, SwingConstants
    封闭类：
    BasicComboBoxRenderer

    public static class BasicComboBoxRenderer.UIResource
extends BasicComboBoxRenderer
implements UIResource
    A subclass of BasicComboBoxRenderer that implements UIResource. BasicComboBoxRenderer doesn't implement UIResource directly so that applications can safely override the cellRenderer property with BasicListCellRenderer subclasses.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicComboBoxRenderer

        BasicComboBoxRenderer.UIResource

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxRenderer

        noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxRenderer.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxRenderer

        getListCellRendererComponent, getPreferredSize

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxRenderer.UIResource

        public BasicComboBoxRenderer.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pe;p p/

e <->


BasicComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
  • 直接已知子类：
    MetalComboBoxUI, SynthComboBoxUI

    public class BasicComboBoxUI
extends ComboBoxUI
    Basic UI implementation for JComboBox.

    The combo box is a compound component which means that it is an agregate of many simpler components. This class creates and manages the listeners on the combo box and the combo box model. These listeners update the user interface in response to changes in the properties and state of the combo box.

    All event handling is handled by listener classes created with the createxxxListener() methods and internal classes. You can change the behavior of this class by overriding the createxxxListener() methods and supplying your own event listeners or subclassing from the ones supplied in this class.

    For adding specific actions, overide installKeyboardActions to add actions in response to KeyStroke bindings. See the article Keyboard Bindings in Swing at The Swing Connection.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicComboBoxUI.ComboBoxLayoutManager
      This layout manager handles the 'standard' layout of combo boxes.
      class  BasicComboBoxUI.FocusHandler
      This listener hides the popup when the focus is lost.
      class  BasicComboBoxUI.ItemHandler
      This listener watches for changes to the selection in the combo box.
      class  BasicComboBoxUI.KeyHandler
      This listener checks to see if the key event isn't a navigation key.
      class  BasicComboBoxUI.ListDataHandler
      This listener watches for changes in the ComboBoxModel.
      class  BasicComboBoxUI.PropertyChangeHandler
      This listener watches for bound properties that have changed in the combo box.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JButton | arrowButton
      protected Dimension | cachedMinimumSize
      protected JComboBox | comboBox
      protected CellRendererPane | currentValuePane
      protected Component | editor
      protected FocusListener focusListener
      This protected field is implementation specific.
      protected boolean hasFocus
      This protected field is implementation specific.
      protected boolean | isMinimumSizeDirty
      protected ItemListener itemListener
      This protected field is implementation specific.
      protected KeyListener keyListener
      This protected field is implementation specific.
      protected JList | listBox
      protected ListDataListener listDataListener
      This protected field is implementation specific.
      protected Insets padding
      If specified, these insets act as padding around the cell renderer when laying out and painting the "selected" item in the combo box.
      protected ComboPopup | popup
      protected KeyListener | popupKeyListener
      protected MouseListener | popupMouseListener
      protected MouseMotionListener | popupMouseMotionListener
      protected PropertyChangeListener propertyChangeListener
      This protected field is implementation specific.
      protected boolean squareButton
      Indicates whether or not the combo box button should be square.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addEditor()
      This public method is implementation specific and should be private.
      void configureArrowButton()
      This public method is implementation specific and should be private.
      protected void configureEditor()
      This protected method is implementation specific and should be private.
      protected JButton createArrowButton()
      Creates a button which will be used as the control to show or hide the popup portion of the combo box.
      protected ComboBoxEditor createEditor()
      Creates the default editor that will be used in editable combo boxes.
      protected FocusListener createFocusListener()
      Creates a FocusListener which will be added to the combo box.
      protected ItemListener createItemListener()
      Creates an ItemListener which will be added to the combo box.
      protected KeyListener createKeyListener()
      Creates a KeyListener which will be added to the combo box.
      protected LayoutManager createLayoutManager()
      Creates a layout manager for managing the components which make up the combo box.
      protected ListDataListener createListDataListener()
      Creates a list data listener which will be added to the ComboBoxModel.
      protected ComboPopup createPopup()
      Creates the popup portion of the combo box.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates a PropertyChangeListener which will be added to the combo box.
      protected ListCellRenderer createRenderer()
      Creates the default renderer that will be used in a non-editiable combo box.
      static ComponentUI | createUI(JComponent c)
      Accessible getAccessibleChild(JComponent c, int i)
      Returns the ith Accessible child of the object.
      int getAccessibleChildrenCount(JComponent c)
      Returns the number of accessible children in the object.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected Dimension getDefaultSize()
      Return the default size of an empty display area of the combo box using the current renderer and font.
      protected Dimension getDisplaySize()
      Returns the calculated size of the display area.
      protected Insets getInsets()
      Gets the insets from the JComboBox.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      The minumum size is the size of the display area plus insets plus the button.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected Dimension getSizeForComponent(Component comp)
      Returns the size a component would have if used as a cell renderer.
      protected void installComponents()
      Creates and initializes the components which make up the aggregate combo box.
      protected void installDefaults()
      Installs the default colors, default font, default renderer, and default editor into the JComboBox.
      protected void installKeyboardActions()
      Adds keyboard actions to the JComboBox.
      protected void installListeners()
      Creates and installs listeners for the combo box and its model.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      boolean isFocusTraversable(JComboBox c)
      Determines if the JComboBox is focus traversable.
      protected boolean isNavigationKey(int keyCode)
      Returns whether or not the supplied keyCode maps to a key that is used for navigation.
      boolean isPopupVisible(JComboBox c)
      Tells if the popup is visible or not.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
      Paints the currently selected item.
      void paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
      Paints the background of the currently selected item.
      protected Rectangle rectangleForCurrentValue()
      Returns the area that is reserved for drawing the currently selected item.
      void removeEditor()
      This public method is implementation specific and should be private.
      protected void selectNextPossibleValue()
      Selects the next item in the list.
      protected void selectPreviousPossibleValue()
      Selects the previous item in the list.
      void setPopupVisible(JComboBox c, boolean v)
      Hides the popup.
      protected void toggleOpenClose()
      Hides the popup if it is showing and shows the popup if it is hidden.
      void unconfigureArrowButton()
      This public method is implementation specific and should be private.
      protected void unconfigureEditor()
      This protected method is implementation specific and should be private.
      protected void uninstallComponents()
      The aggregate components which compise the combo box are unregistered and uninitialized.
      protected void uninstallDefaults()
      Uninstalls the default colors, default font, default renderer, and default editor from the combo box.
      protected void uninstallKeyboardActions()
      Removes the focus InputMap and ActionMap.
      protected void uninstallListeners()
      Removes the installed listeners from the combo box and its model.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • comboBox

        protected JComboBox comboBox

      • hasFocus

        protected boolean hasFocus
        This protected field is implementation specific. Do not access directly or override.

      • listBox

        protected JList listBox

      • currentValuePane

        protected CellRendererPane currentValuePane

      • popup

        protected ComboPopup popup

      • editor

        protected Component editor

      • arrowButton

        protected JButton arrowButton

      • keyListener

        protected KeyListener keyListener
        This protected field is implementation specific. Do not access directly or override. Override the listener construction method instead.
        另请参见：
        createKeyListener()

      • focusListener

        protected FocusListener focusListener
        This protected field is implementation specific. Do not access directly or override. Override the listener construction method instead.
        另请参见：
        createFocusListener()

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener
        This protected field is implementation specific. Do not access directly or override. Override the listener construction method instead.
        另请参见：
        createPropertyChangeListener()

      • itemListener

        protected ItemListener itemListener
        This protected field is implementation specific. Do not access directly or override. Override the listener construction method instead.
        另请参见：
        createItemListener()

      • popupMouseListener

        protected MouseListener popupMouseListener

      • popupMouseMotionListener

        protected MouseMotionListener popupMouseMotionListener

      • popupKeyListener

        protected KeyListener popupKeyListener

      • listDataListener

        protected ListDataListener listDataListener
        This protected field is implementation specific. Do not access directly or override. Override the listener construction method instead.
        另请参见：
        createListDataListener()

      • isMinimumSizeDirty

        protected boolean isMinimumSizeDirty

      • cachedMinimumSize

        protected Dimension cachedMinimumSize

      • squareButton

        protected boolean squareButton
        Indicates whether or not the combo box button should be square. If square, then the width and height are equal, and are both set to the height of the combo minus appropriate insets.
        从以下版本开始：
        1.7

      • padding

        protected Insets padding
        If specified, these insets act as padding around the cell renderer when laying out and painting the "selected" item in the combo box. These insets add to those specified by the cell renderer.
        从以下版本开始：
        1.7

    • 构造方法详细信息

      • BasicComboBoxUI

        public BasicComboBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        Installs the default colors, default font, default renderer, and default editor into the JComboBox.

      • installListeners

        protected void installListeners()
        Creates and installs listeners for the combo box and its model. This method is called when the UI is installed.

      • uninstallDefaults

        protected void uninstallDefaults()
        Uninstalls the default colors, default font, default renderer, and default editor from the combo box.

      • uninstallListeners

        protected void uninstallListeners()
        Removes the installed listeners from the combo box and its model. The number and types of listeners removed and in this method should be the same that was added in installListeners

      • createPopup

        protected ComboPopup createPopup()
        Creates the popup portion of the combo box.
        返回：
        an instance of ComboPopup
        另请参见：
        ComboPopup

      • createKeyListener

        protected KeyListener createKeyListener()
        Creates a KeyListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.
        返回：
        an instance KeyListener or null

      • createFocusListener

        protected FocusListener createFocusListener()
        Creates a FocusListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.
        返回：
        an instance of a FocusListener or null

      • createListDataListener

        protected ListDataListener createListDataListener()
        Creates a list data listener which will be added to the ComboBoxModel. If this method returns null then it will not be added to the combo box model.
        返回：
        an instance of a ListDataListener or null

      • createItemListener

        protected ItemListener createItemListener()
        Creates an ItemListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.

        Subclasses may override this method to return instances of their own ItemEvent handlers.

        返回：
        an instance of an ItemListener or null

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates a PropertyChangeListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.
        返回：
        an instance of a PropertyChangeListener or null

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Creates a layout manager for managing the components which make up the combo box.
        返回：
        an instance of a layout manager

      • createRenderer

        protected ListCellRenderer createRenderer()
        Creates the default renderer that will be used in a non-editiable combo box. A default renderer will used only if a renderer has not been explicitly set with setRenderer.
        返回：
        a ListCellRender used for the combo box
        另请参见：
        JComboBox.setRenderer(javax.swing.ListCellRenderer)

      • createEditor

        protected ComboBoxEditor createEditor()
        Creates the default editor that will be used in editable combo boxes. A default editor will be used only if an editor has not been explicitly set with setEditor.
        返回：
        a ComboBoxEditor used for the combo box
        另请参见：
        JComboBox.setEditor(javax.swing.ComboBoxEditor)

      • installComponents

        protected void installComponents()
        Creates and initializes the components which make up the aggregate combo box. This method is called as part of the UI installation process.

      • uninstallComponents

        protected void uninstallComponents()
        The aggregate components which compise the combo box are unregistered and uninitialized. This method is called as part of the UI uninstallation process.

      • addEditor

        public void addEditor()
        This public method is implementation specific and should be private. do not call or override. To implement a specific editor create a custom ComboBoxEditor
        另请参见：
        createEditor(), JComboBox.setEditor(javax.swing.ComboBoxEditor), ComboBoxEditor

      • removeEditor

        public void removeEditor()
        This public method is implementation specific and should be private. do not call or override.
        另请参见：
        addEditor()

      • configureEditor

        protected void configureEditor()
        This protected method is implementation specific and should be private. do not call or override.
        另请参见：
        addEditor()

      • unconfigureEditor

        protected void unconfigureEditor()
        This protected method is implementation specific and should be private. Do not call or override.
        另请参见：
        addEditor()

      • configureArrowButton

        public void configureArrowButton()
        This public method is implementation specific and should be private. Do not call or override.
        另请参见：
        createArrowButton()

      • unconfigureArrowButton

        public void unconfigureArrowButton()
        This public method is implementation specific and should be private. Do not call or override.
        另请参见：
        createArrowButton()

      • createArrowButton

        protected JButton createArrowButton()
        Creates a button which will be used as the control to show or hide the popup portion of the combo box.
        返回：
        a button which represents the popup control

      • isPopupVisible

        public boolean isPopupVisible(JComboBox c)
        Tells if the popup is visible or not.
        指定者：
        isPopupVisible in class ComboBoxUI

      • setPopupVisible

        public void setPopupVisible(JComboBox c,
                   boolean v)
        Hides the popup.
        指定者：
        setPopupVisible in class ComboBoxUI

      • isFocusTraversable

        public boolean isFocusTraversable(JComboBox c)
        Determines if the JComboBox is focus traversable. If the JComboBox is editable this returns false, otherwise it returns true.
        指定者：
        isFocusTraversable in class ComboBoxUI

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        The minumum size is the size of the display area plus insets plus the button.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent c)
        Description copied from class: ComponentUI
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, this method should return the number of children of this object. UIs might wish to override this if they present areas on the screen that can be viewed as components, but actual components are not used for presenting those areas. Note: As of v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleChildrenCount() instead of this method.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the number of accessible children in the object
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent c,
                            int i)
        Description copied from class: ComponentUI
        Returns the ith Accessible child of the object. UIs might need to override this if they present areas on the screen that can be viewed as components, but actual components are not used for presenting those areas.

        Note: As of v1.3, it is recommended that developers call Component.AccessibleAWTComponent.getAccessibleChild() instead of this method.

        重载：
        getAccessibleChild in class ComponentUI
        i - zero-based index of child
        返回：
        the ith Accessible child of the object
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)

      • isNavigationKey

        protected boolean isNavigationKey(int keyCode)
        Returns whether or not the supplied keyCode maps to a key that is used for navigation. This is used for optimizing key input by only passing non- navigation keys to the type-ahead mechanism. Subclasses should override this if they change the navigation keys.

      • selectNextPossibleValue

        protected void selectNextPossibleValue()
        Selects the next item in the list. It won't change the selection if the currently selected item is already the last item.

      • selectPreviousPossibleValue

        protected void selectPreviousPossibleValue()
        Selects the previous item in the list. It won't change the selection if the currently selected item is already the first item.

      • toggleOpenClose

        protected void toggleOpenClose()
        Hides the popup if it is showing and shows the popup if it is hidden.

      • rectangleForCurrentValue

        protected Rectangle rectangleForCurrentValue()
        Returns the area that is reserved for drawing the currently selected item.

      • getInsets

        protected Insets getInsets()
        Gets the insets from the JComboBox.

      • paintCurrentValue

        public void paintCurrentValue(Graphics g,
                     Rectangle bounds,
                     boolean hasFocus)
        Paints the currently selected item.

      • paintCurrentValueBackground

        public void paintCurrentValueBackground(Graphics g,
                               Rectangle bounds,
                               boolean hasFocus)
        Paints the background of the currently selected item.

      • getDefaultSize

        protected Dimension getDefaultSize()
        Return the default size of an empty display area of the combo box using the current renderer and font.
        返回：
        the size of an empty display area
        另请参见：
        getDisplaySize()

      • getDisplaySize

        protected Dimension getDisplaySize()
        Returns the calculated size of the display area. The display area is the portion of the combo box in which the selected item is displayed. This method will use the prototype display value if it has been set.

        For combo boxes with a non trivial number of items, it is recommended to use a prototype display value to significantly speed up the display size calculation.

        返回：
        the size of the display area calculated from the combo box items
        另请参见：
        JComboBox.setPrototypeDisplayValue(java.lang.Object)

      • getSizeForComponent

        protected Dimension getSizeForComponent(Component comp)
        Returns the size a component would have if used as a cell renderer.
        参数：
        comp - a Component to check
        返回：
        size of the component
        从以下版本开始：
        1.7

      • installKeyboardActions

        protected void installKeyboardActions()
        Adds keyboard actions to the JComboBox. Actions on enter and esc are already supplied. Add more actions as you need them.

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        Removes the focus InputMap and ActionMap.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicComboBoxUI.ComboBoxLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.ComboBoxLayoutManager

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
  • 所有已实现的接口：
    LayoutManager
    直接已知子类：
    MetalComboBoxUI.MetalComboBoxLayoutManager
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.ComboBoxLayoutManager
extends Object
implements LayoutManager
    This layout manager handles the 'standard' layout of combo boxes. It puts the arrow button to the right and the editor to the left. If there is no editor it still keeps the arrow button to the right. This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.ComboBoxLayoutManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String name, Component comp)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      void layoutContainer(Container parent)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container parent)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container parent)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component comp)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.ComboBoxLayoutManager

        public BasicComboBoxUI.ComboBoxLayoutManager()

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component comp)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        comp - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component comp)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        comp - the component to be removed

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container parent)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to be laid out
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/LaCigxngxa..xaan"hh ilt rrsferr/e


BasicComboBoxUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.FocusHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.FocusHandler
extends Object
implements FocusListener
    This listener hides the popup when the focus is lost. It also repaints when focus is gained or lost. This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.FocusHandler

        public BasicComboBoxUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iCmasic ic"llc""i.ww


BasicComboBoxUI.ItemHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.ItemHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
  • 所有已实现的接口：
    ItemListener, EventListener
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.ItemHandler
extends Object
implements ItemListener
    This listener watches for changes to the selection in the combo box.

    This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    另请参见：
    BasicComboBoxUI.createItemListener()

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.ItemHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void itemStateChanged(ItemEvent e)
      Invoked when an item has been selected or deselected by the user.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.ItemHandler

        public BasicComboBoxUI.ItemHandler()

    • 方法详细信息

      • itemStateChanged

        public void itemStateChanged(ItemEvent e)
        从接口复制的描述： ItemListener
        Invoked when an item has been selected or deselected by the user. The code written for this method performs the operations that need to occur when an item is selected (or deselected).
        指定者：
        itemStateChanged in interface ItemListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jna/e=af=a< a<


BasicComboBoxUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.KeyHandler

  • java.lang.Object
    • java.awt.event.KeyAdapter
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
  • 所有已实现的接口：
    KeyListener, EventListener
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.KeyHandler
extends KeyAdapter
    This listener checks to see if the key event isn't a navigation key. If it finds a key event that wasn't a navigation key it dispatches it to JComboBox.selectWithKeyChar() so that it can do type-ahead. This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.KeyHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void keyPressed(KeyEvent e)
      Invoked when a key has been pressed.

      • 方法 - 继承于类 java.awt.event.KeyAdapter

        keyReleased, keyTyped

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.KeyHandler

        public BasicComboBoxUI.KeyHandler()

    • 方法详细信息

      • keyPressed

        public void keyPressed(KeyEvent e)
        Description copied from class: KeyAdapter
        Invoked when a key has been pressed.
        指定者：
        keyPressed in interface KeyListener
        重载：
        keyPressed in class KeyAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.s. >J>>>a>/ t> 襬zss i"="a蘬pfsplt.


BasicComboBoxUI.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.ListDataHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
  • 所有已实现的接口：
    EventListener, ListDataListener
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.ListDataHandler
extends Object
implements ListDataListener
    This listener watches for changes in the ComboBoxModel.

    This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    另请参见：
    BasicComboBoxUI.createListDataListener()

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.ListDataHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void contentsChanged(ListDataEvent e)
      Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
      void intervalAdded(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been inserted in the data model.
      void intervalRemoved(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been removed from the data model.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.ListDataHandler

        public BasicComboBoxUI.ListDataHandler()

    • 方法详细信息

      • contentsChanged

        public void contentsChanged(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods. For example, this is sent when an item has been replaced. Index0 and index1 bracket the change.
        指定者：
        contentsChanged in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been inserted in the data model. The new interval includes both index0 and index1.
        指定者：
        intervalAdded in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been removed from the data model. The interval includes both index0 and index1.
        指定者：
        intervalRemoved in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>a"a"eaerranovu:ra<:.t;//hc0/ tw


BasicComboBoxUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboBoxUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    直接已知子类：
    MetalComboBoxUI.MetalPropertyChangeListener
    封闭类：
    BasicComboBoxUI

    public class BasicComboBoxUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    This listener watches for bound properties that have changed in the combo box.

    Subclasses which wish to listen to combo box property changes should call the superclass methods to ensure that the combo box ui correctly handles property changes.

    This public inner class should be treated as protected. Instantiate it only within subclasses of BasicComboBoxUI.

    另请参见：
    BasicComboBoxUI.createPropertyChangeListener()

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboBoxUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboBoxUI.PropertyChangeHandler

        public BasicComboBoxUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Evvea<> <>e >ee<>pp>.aeDttss.>sitsiitc>ceso


BasicComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPopupMenu
            • javax.swing.plaf.basic.BasicComboPopup
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, MenuElement, ComboPopup
    直接已知子类：
    MetalComboBoxUI.MetalComboPopup

    public class BasicComboPopup
extends JPopupMenu
implements ComboPopup
    This is a basic implementation of the ComboPopup interface. This class represents the ui for the popup portion of the combo box.

    All event handling is handled by listener classes created with the createxxxListener() methods and internal classes. You can change the behavior of this class by overriding the createxxxListener() methods and supplying your own event listeners or subclassing from the ones supplied in this class.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicComboPopup.InvocationKeyHandler
      As of Java 2 platform v 1.4, this class is now obsolete and is only included for backwards API compatibility.
      protected class  BasicComboPopup.InvocationMouseHandler
      A listener to be registered upon the combo box (not its popup menu) to handle mouse events that affect the state of the popup menu.
      protected class  BasicComboPopup.InvocationMouseMotionHandler
      This listener watches for dragging and updates the current selection in the list if it is dragging over the list.
      protected class  BasicComboPopup.ItemHandler
      This listener watches for changes to the selection in the combo box.
      class  BasicComboPopup.ListDataHandler
      As of 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
      protected class  BasicComboPopup.ListMouseHandler
      This listener hides the popup when the mouse is released in the list.
      protected class  BasicComboPopup.ListMouseMotionHandler
      This listener changes the selected item as you move the mouse over the list.
      protected class  BasicComboPopup.ListSelectionHandler
      As of Java 2 platform v 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
      protected class  BasicComboPopup.PropertyChangeHandler
      This listener watches for bound properties that have changed in the combo box.

      • Nested classes/interfaces inherited from class javax.swing.JPopupMenu

        JPopupMenu.AccessibleJPopupMenu, JPopupMenu.Separator

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Timer autoscrollTimer
      This protected field is implementation specific.
      protected JComboBox | comboBox
      protected boolean | hasEntered
      protected boolean | isAutoScrolling
      protected ItemListener itemListener
      This protected field is implementation specific.
      protected KeyListener keyListener
      This protected field is implementation specific.
      protected JList list
      This protected field is implementation specific.
      protected ListDataListener listDataListener
      This protected field is implementation specific.
      protected MouseListener listMouseListener
      This protected field is implementation specific.
      protected MouseMotionListener listMouseMotionListener
      This protected field is implementation specific.
      protected ListSelectionListener listSelectionListener
      This protected field is implementation specific.
      protected MouseListener mouseListener
      This protected field is implementation specific.
      protected MouseMotionListener mouseMotionListener
      This protected field is implementation specific.
      protected PropertyChangeListener propertyChangeListener
      This protected field is implementation specific.
      protected static int | SCROLL_DOWN
      protected static int | SCROLL_UP
      protected int | scrollDirection
      protected JScrollPane scroller
      This protected field is implementation specific.
      protected boolean valueIsAdjusting
      As of Java 2 platform v1.4 this previously undocumented field is no longer used.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboPopup(JComboBox combo)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void autoScrollDown()
      This protected method is implementation specific and should be private.
      protected void autoScrollUp()
      This protected method is implementation specific and should be private.
      protected Rectangle computePopupBounds(int px, int py, int pw, int ph)
      Calculate the placement and size of the popup portion of the combo box based on the combo box location and the enclosing screen bounds.
      protected void configureList()
      Configures the list which is used to hold the combo box items in the popup.
      protected void configurePopup()
      Configures the popup portion of the combo box.
      protected void configureScroller()
      Configures the scrollable portion which holds the list within the combo box popup.
      protected MouseEvent | convertMouseEvent(MouseEvent e)
      protected ItemListener createItemListener()
      Creates an ItemListener which will be added to the combo box.
      protected KeyListener createKeyListener()
      Creates the key listener that will be added to the combo box.
      protected JList createList()
      Creates the JList used in the popup to display the items in the combo box model.
      protected ListDataListener createListDataListener()
      Creates a list data listener which will be added to the ComboBoxModel.
      protected MouseListener createListMouseListener()
      Creates a mouse listener that watches for mouse events in the popup's list.
      protected MouseMotionListener createListMouseMotionListener()
      Creates a mouse motion listener that watches for mouse motion events in the popup's list.
      protected ListSelectionListener createListSelectionListener()
      Creates a list selection listener that watches for selection changes in the popup's list.
      protected MouseListener createMouseListener()
      Creates a listener that will watch for mouse-press and release events on the combo box.
      protected MouseMotionListener createMouseMotionListener()
      Creates the mouse motion listener which will be added to the combo box.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates a PropertyChangeListener which will be added to the combo box.
      protected JScrollPane createScroller()
      Creates the scroll pane which houses the scrollable list.
      protected void delegateFocus(MouseEvent e)
      This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up.
      protected void firePopupMenuCanceled()
      Notifies PopupMenuListeners that this popup menu is cancelled.
      protected void firePopupMenuWillBecomeInvisible()
      Notifies PopupMenuListeners that this popup menu will become invisible.
      protected void firePopupMenuWillBecomeVisible()
      Notifies PopupMenuListeners that this popup menu will become visible.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this BasicComboPopup.
      KeyListener getKeyListener()
      Implementation of ComboPopup.getKeyListener().
      JList getList()
      Implementation of ComboPopup.getList().
      MouseListener getMouseListener()
      Implementation of ComboPopup.getMouseListener().
      MouseMotionListener getMouseMotionListener()
      Implementation of ComboPopup.getMouseMotionListener().
      protected int getPopupHeightForRowCount(int maxRowCount)
      Retrieves the height of the popup based on the current ListCellRenderer and the maximum row count.
      void hide()
      Implementation of ComboPopup.hide().
      protected void installComboBoxListeners()
      This method adds the necessary listeners to the JComboBox.
      protected void installComboBoxModelListeners(ComboBoxModel model)
      Installs the listeners on the combo box model.
      protected void | installKeyboardActions()
      protected void installListListeners()
      Adds the listeners to the list control.
      boolean isFocusTraversable()
      Overridden to unconditionally return false.
      void show()
      Implementation of ComboPopup.show().
      protected void startAutoScrolling(int direction)
      This protected method is implementation specific and should be private.
      protected void stopAutoScrolling()
      This protected method is implementation specific and should be private.
      protected void togglePopup()
      Makes the popup visible if it is hidden and makes it hidden if it is visible.
      protected void uninstallComboBoxModelListeners(ComboBoxModel model)
      Removes the listeners from the combo box model
      void uninstallingUI()
      Called when the UI is uninstalling.
      protected void | uninstallKeyboardActions()
      protected void updateListBoxSelectionForEvent(MouseEvent anEvent, boolean shouldScroll)
      A utility method used by the event listeners.

      • 方法 - 继承于类 javax.swing.JPopupMenu

        add, add, add, addMenuKeyListener, addPopupMenuListener, addSeparator, createActionChangeListener, createActionComponent, getComponent, getComponentAtIndex, getComponentIndex, getDefaultLightWeightPopupEnabled, getInvoker, getLabel, getMargin, getMenuKeyListeners, getPopupMenuListeners, getSelectionModel, getSubElements, getUI, getUIClassID, insert, insert, isBorderPainted, isLightWeightPopupEnabled, isPopupTrigger, isVisible, menuSelectionChanged, pack, paintBorder, paramString, processFocusEvent, processKeyEvent, processKeyEvent, processMouseEvent, remove, removeMenuKeyListener, removePopupMenuListener, setBorderPainted, setDefaultLightWeightPopupEnabled, setInvoker, setLabel, setLightWeightPopupEnabled, setLocation, setPopupSize, setPopupSize, setSelected, setSelectionModel, setUI, setVisible, show, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.plaf.basic.ComboPopup

        isVisible

    • 字段详细信息

      • comboBox

        protected JComboBox comboBox

      • list

        protected JList list
        This protected field is implementation specific. Do not access directly or override. Use the accessor methods instead.
        另请参见：
        getList(), createList()

      • scroller

        protected JScrollPane scroller
        This protected field is implementation specific. Do not access directly or override. Use the create method instead
        另请参见：
        createScroller()

      • valueIsAdjusting

        protected boolean valueIsAdjusting
        As of Java 2 platform v1.4 this previously undocumented field is no longer used.

      • mouseMotionListener

        protected MouseMotionListener mouseMotionListener
        This protected field is implementation specific. Do not access directly or override. Use the accessor or create methods instead.
        另请参见：
        getMouseMotionListener(), createMouseMotionListener()

      • mouseListener

        protected MouseListener mouseListener
        This protected field is implementation specific. Do not access directly or override. Use the accessor or create methods instead.
        另请参见：
        getMouseListener(), createMouseListener()

      • keyListener

        protected KeyListener keyListener
        This protected field is implementation specific. Do not access directly or override. Use the accessor or create methods instead.
        另请参见：
        getKeyListener(), createKeyListener()

      • listSelectionListener

        protected ListSelectionListener listSelectionListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead.
        另请参见：
        createListSelectionListener()

      • listMouseListener

        protected MouseListener listMouseListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead.
        另请参见：
        createListMouseListener()

      • listMouseMotionListener

        protected MouseMotionListener listMouseMotionListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead
        另请参见：
        createListMouseMotionListener()

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead
        另请参见：
        createPropertyChangeListener()

      • listDataListener

        protected ListDataListener listDataListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead
        另请参见：
        createListDataListener()

      • itemListener

        protected ItemListener itemListener
        This protected field is implementation specific. Do not access directly or override. Use the create method instead
        另请参见：
        createItemListener()

      • autoscrollTimer

        protected Timer autoscrollTimer
        This protected field is implementation specific. Do not access directly or override.

      • hasEntered

        protected boolean hasEntered

      • isAutoScrolling

        protected boolean isAutoScrolling

      • scrollDirection

        protected int scrollDirection

      • SCROLL_UP

        protected static final int SCROLL_UP
        另请参见：
        Constant Field Values

      • SCROLL_DOWN

        protected static final int SCROLL_DOWN
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BasicComboPopup

        public BasicComboPopup(JComboBox combo)

    • 方法详细信息

      • show

        public void show()
        Implementation of ComboPopup.show().
        指定者：
        show in interface ComboPopup
        重载：
        show in class Component

      • hide

        public void hide()
        Implementation of ComboPopup.hide().
        指定者：
        hide in interface ComboPopup
        重载：
        hide in class Component

      • getList

        public JList getList()
        Implementation of ComboPopup.getList().
        指定者：
        getList in interface ComboPopup

      • getMouseListener

        public MouseListener getMouseListener()
        Implementation of ComboPopup.getMouseListener().
        指定者：
        getMouseListener in interface ComboPopup
        返回：
        a MouseListener or null
        另请参见：
        ComboPopup.getMouseListener()

      • getMouseMotionListener

        public MouseMotionListener getMouseMotionListener()
        Implementation of ComboPopup.getMouseMotionListener().
        指定者：
        getMouseMotionListener in interface ComboPopup
        返回：
        a MouseMotionListener or null
        另请参见：
        ComboPopup.getMouseMotionListener()

      • getKeyListener

        public KeyListener getKeyListener()
        Implementation of ComboPopup.getKeyListener().
        指定者：
        getKeyListener in interface ComboPopup
        返回：
        a KeyListener or null
        另请参见：
        ComboPopup.getKeyListener()

      • uninstallingUI

        public void uninstallingUI()
        Called when the UI is uninstalling. Since this popup isn't in the component tree, it won't get it's uninstallUI() called. It removes the listeners that were added in addComboBoxListeners().
        指定者：
        uninstallingUI in interface ComboPopup

      • uninstallComboBoxModelListeners

        protected void uninstallComboBoxModelListeners(ComboBoxModel model)
        Removes the listeners from the combo box model
        参数：
        model - The combo box model to install listeners
        另请参见：
        installComboBoxModelListeners(javax.swing.ComboBoxModel)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • firePopupMenuWillBecomeVisible

        protected void firePopupMenuWillBecomeVisible()
        Description copied from class: JPopupMenu
        Notifies PopupMenuListeners that this popup menu will become visible.
        重载：
        firePopupMenuWillBecomeVisible in class JPopupMenu

      • firePopupMenuWillBecomeInvisible

        protected void firePopupMenuWillBecomeInvisible()
        Description copied from class: JPopupMenu
        Notifies PopupMenuListeners that this popup menu will become invisible.
        重载：
        firePopupMenuWillBecomeInvisible in class JPopupMenu

      • firePopupMenuCanceled

        protected void firePopupMenuCanceled()
        Description copied from class: JPopupMenu
        Notifies PopupMenuListeners that this popup menu is cancelled.
        重载：
        firePopupMenuCanceled in class JPopupMenu

      • createMouseListener

        protected MouseListener createMouseListener()
        Creates a listener that will watch for mouse-press and release events on the combo box. 警告： When overriding this method, make sure to maintain the existing behavior.
        返回：
        a MouseListener which will be added to the combo box or null

      • createMouseMotionListener

        protected MouseMotionListener createMouseMotionListener()
        Creates the mouse motion listener which will be added to the combo box. 警告： When overriding this method, make sure to maintain the existing behavior.
        返回：
        a MouseMotionListener which will be added to the combo box or null

      • createKeyListener

        protected KeyListener createKeyListener()
        Creates the key listener that will be added to the combo box. If this method returns null then it will not be added to the combo box.
        返回：
        a KeyListener or null

      • createListSelectionListener

        protected ListSelectionListener createListSelectionListener()
        Creates a list selection listener that watches for selection changes in the popup's list. If this method returns null then it will not be added to the popup list.
        返回：
        an instance of a ListSelectionListener or null

      • createListDataListener

        protected ListDataListener createListDataListener()
        Creates a list data listener which will be added to the ComboBoxModel. If this method returns null then it will not be added to the combo box model.
        返回：
        an instance of a ListDataListener or null

      • createListMouseListener

        protected MouseListener createListMouseListener()
        Creates a mouse listener that watches for mouse events in the popup's list. If this method returns null then it will not be added to the combo box.
        返回：
        an instance of a MouseListener or null

      • createListMouseMotionListener

        protected MouseMotionListener createListMouseMotionListener()
        Creates a mouse motion listener that watches for mouse motion events in the popup's list. If this method returns null then it will not be added to the combo box.
        返回：
        an instance of a MouseMotionListener or null

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates a PropertyChangeListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.
        返回：
        an instance of a PropertyChangeListener or null

      • createItemListener

        protected ItemListener createItemListener()
        Creates an ItemListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.

        Subclasses may override this method to return instances of their own ItemEvent handlers.

        返回：
        an instance of an ItemListener or null

      • createList

        protected JList createList()
        Creates the JList used in the popup to display the items in the combo box model. This method is called when the UI class is created.
        返回：
        a JList used to display the combo box items

      • configureList

        protected void configureList()
        Configures the list which is used to hold the combo box items in the popup. This method is called when the UI class is created.
        另请参见：
        createList()

      • installListListeners

        protected void installListListeners()
        Adds the listeners to the list control.

      • createScroller

        protected JScrollPane createScroller()
        Creates the scroll pane which houses the scrollable list.

      • configureScroller

        protected void configureScroller()
        Configures the scrollable portion which holds the list within the combo box popup. This method is called when the UI class is created.

      • configurePopup

        protected void configurePopup()
        Configures the popup portion of the combo box. This method is called when the UI class is created.

      • installComboBoxListeners

        protected void installComboBoxListeners()
        This method adds the necessary listeners to the JComboBox.

      • installComboBoxModelListeners

        protected void installComboBoxModelListeners(ComboBoxModel model)
        Installs the listeners on the combo box model. Any listeners installed on the combo box model should be removed in uninstallComboBoxModelListeners.
        参数：
        model - The combo box model to install listeners
        另请参见：
        uninstallComboBoxModelListeners(javax.swing.ComboBoxModel)

      • installKeyboardActions

        protected void installKeyboardActions()

      • isFocusTraversable

        public boolean isFocusTraversable()
        Overridden to unconditionally return false.
        重载：
        isFocusTraversable in class Component
        返回：
        true if this Component is focusable; false otherwise
        另请参见：
        Component.setFocusable(boolean)

      • startAutoScrolling

        protected void startAutoScrolling(int direction)
        This protected method is implementation specific and should be private. do not call or override.

      • stopAutoScrolling

        protected void stopAutoScrolling()
        This protected method is implementation specific and should be private. do not call or override.

      • autoScrollUp

        protected void autoScrollUp()
        This protected method is implementation specific and should be private. do not call or override.

      • autoScrollDown

        protected void autoScrollDown()
        This protected method is implementation specific and should be private. do not call or override.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this BasicComboPopup. The AccessibleContext will have its parent set to the ComboBox.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JPopupMenu
        返回：
        an AccessibleContext for the BasicComboPopup
        从以下版本开始：
        1.5

      • delegateFocus

        protected void delegateFocus(MouseEvent e)
        This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up. The standard implementation delegates the focus to the editor (if the combo box is editable) or to the JComboBox if it is not editable.

      • togglePopup

        protected void togglePopup()
        Makes the popup visible if it is hidden and makes it hidden if it is visible.

      • convertMouseEvent

        protected MouseEvent convertMouseEvent(MouseEvent e)

      • getPopupHeightForRowCount

        protected int getPopupHeightForRowCount(int maxRowCount)
        Retrieves the height of the popup based on the current ListCellRenderer and the maximum row count.

      • computePopupBounds

        protected Rectangle computePopupBounds(int px,
                           int py,
                           int pw,
                           int ph)
        Calculate the placement and size of the popup portion of the combo box based on the combo box location and the enclosing screen bounds. If no transformations are required, then the returned rectangle will have the same values as the parameters.
        参数：
        px - starting x location
        py - starting y location
        pw - starting width
        ph - starting height
        返回：
        a rectangle which represents the placement and size of the popup

      • updateListBoxSelectionForEvent

        protected void updateListBoxSelectionForEvent(MouseEvent anEvent,
                                  boolean shouldScroll)
        A utility method used by the event listeners. Given a mouse event, it changes the list selection to the list item below the mouse.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicComboPopup.InvocationKeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.InvocationKeyHandler

  • java.lang.Object
    • java.awt.event.KeyAdapter
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
  • 所有已实现的接口：
    KeyListener, EventListener
    封闭类：
    BasicComboPopup

    public class BasicComboPopup.InvocationKeyHandler
extends KeyAdapter
    As of Java 2 platform v 1.4, this class is now obsolete and is only included for backwards API compatibility. Do not instantiate or subclass.

    All the functionality of this class has been included in BasicComboBoxUI ActionMap/InputMap methods.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboPopup.InvocationKeyHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void keyReleased(KeyEvent e)
      Invoked when a key has been released.

      • 方法 - 继承于类 java.awt.event.KeyAdapter

        keyPressed, keyTyped

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.InvocationKeyHandler

        public BasicComboPopup.InvocationKeyHandler()

    • 方法详细信息

      • keyReleased

        public void keyReleased(KeyEvent e)
        Description copied from class: KeyAdapter
        Invoked when a key has been released.
        指定者：
        keyReleased in interface KeyListener
        重载：
        keyReleased in class KeyAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctCapailaiwnniwwvs""//a/j..xlna.=orr>o<"s


BasicComboPopup.InvocationMouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.InvocationMouseHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.InvocationMouseHandler
extends MouseAdapter
    A listener to be registered upon the combo box (not its popup menu) to handle mouse events that affect the state of the popup menu. The main purpose of this listener is to make the popup menu appear and disappear. This listener also helps with click-and-drag scenarios by setting the selection if the mouse was released over the list during a drag.

    警告： We recommend that you not create subclasses of this class. If you absolutely must create a subclass, be sure to invoke the superclass version of each method.

    另请参见：
    BasicComboPopup.createMouseListener()

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.InvocationMouseHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mousePressed(MouseEvent e)
      Responds to mouse-pressed events on the combo box.
      void mouseReleased(MouseEvent e)
      Responds to the user terminating a click or drag that began on the combo box.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.InvocationMouseHandler

        protected BasicComboPopup.InvocationMouseHandler()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Responds to mouse-pressed events on the combo box.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter
        参数：
        e - the mouse-press event to be handled

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Responds to the user terminating a click or drag that began on the combo box.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter
        参数：
        e - the mouse-release event to be handled
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..mopo mxooe/.clv./nnon>xf""t.leiel==q


BasicComboPopup.InvocationMouseMotionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.InvocationMouseMotionHandler

  • java.lang.Object
    • java.awt.event.MouseMotionAdapter
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
  • 所有已实现的接口：
    MouseMotionListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.InvocationMouseMotionHandler
extends MouseMotionAdapter
    This listener watches for dragging and updates the current selection in the list if it is dragging over the list.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.InvocationMouseMotionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.

      • 方法 - 继承于类 java.awt.event.MouseMotionAdapter

        mouseMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.InvocationMouseMotionHandler

        protected BasicComboPopup.InvocationMouseMotionHandler()

    • 方法详细信息

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseMotionAdapter
        Invoked when a mouse button is pressed on a component and then dragged. Mouse drag events will continue to be delivered to the component where the first originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).
        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseMotionAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ai < ai>a/>>a//蕆nn" raaBB1lR


BasicComboPopup.ItemHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.ItemHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler
  • 所有已实现的接口：
    ItemListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.ItemHandler
extends Object
implements ItemListener
    This listener watches for changes to the selection in the combo box.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.ItemHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void itemStateChanged(ItemEvent e)
      Invoked when an item has been selected or deselected by the user.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.ItemHandler

        protected BasicComboPopup.ItemHandler()

    • 方法详细信息

      • itemStateChanged

        public void itemStateChanged(ItemEvent e)
        从接口复制的描述： ItemListener
        Invoked when an item has been selected or deselected by the user. The code written for this method performs the operations that need to occur when an item is selected (or deselected).
        指定者：
        itemStateChanged in interface ItemListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lCcIeIeIlIy(allaanee a />ll>d>p tvvctaraj


BasicComboPopup.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.ListDataHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
  • 所有已实现的接口：
    EventListener, ListDataListener
    封闭类：
    BasicComboPopup

    public class BasicComboPopup.ListDataHandler
extends Object
implements ListDataListener
    As of 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility. Do not call or override.

    The functionality has been migrated into ItemHandler.

    另请参见：
    BasicComboPopup.createItemListener()

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicComboPopup.ListDataHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void contentsChanged(ListDataEvent e)
      Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
      void intervalAdded(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been inserted in the data model.
      void intervalRemoved(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been removed from the data model.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.ListDataHandler

        public BasicComboPopup.ListDataHandler()

    • 方法详细信息

      • contentsChanged

        public void contentsChanged(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods. For example, this is sent when an item has been replaced. Index0 and index1 bracket the change.
        指定者：
        contentsChanged in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been inserted in the data model. The new interval includes both index0 and index1.
        指定者：
        intervalAdded in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been removed from the data model. The interval includes both index0 and index1.
        指定者：
        intervalRemoved in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hh "=""uepaal/k�=t >a;ca/�//. ew


BasicComboPopup.ListMouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.ListMouseHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.ListMouseHandler
extends MouseAdapter
    This listener hides the popup when the mouse is released in the list.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.ListMouseHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent anEvent)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.ListMouseHandler

        protected BasicComboPopup.ListMouseHandler()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseReleased

        public void mouseReleased(MouseEvent anEvent)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>>beeoa<"/lu <<t


BasicComboPopup.ListMouseMotionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.ListMouseMotionHandler

  • java.lang.Object
    • java.awt.event.MouseMotionAdapter
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
  • 所有已实现的接口：
    MouseMotionListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.ListMouseMotionHandler
extends MouseMotionAdapter
    This listener changes the selected item as you move the mouse over the list. The selection change is not committed to the model, this is for user feedback only.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.ListMouseMotionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseMoved(MouseEvent anEvent)
      Invoked when the mouse button has been moved on a component (with no buttons no down).

      • 方法 - 继承于类 java.awt.event.MouseMotionAdapter

        mouseDragged

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.ListMouseMotionHandler

        protected BasicComboPopup.ListMouseMotionHandler()

    • 方法详细信息

      • mouseMoved

        public void mouseMoved(MouseEvent anEvent)
        Description copied from class: MouseMotionAdapter
        Invoked when the mouse button has been moved on a component (with no buttons no down).
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseMotionAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t<< dd/<bbsat;allb;&-


BasicComboPopup.ListSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.ListSelectionHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
  • 所有已实现的接口：
    EventListener, ListSelectionListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.ListSelectionHandler
extends Object
implements ListSelectionListener
    As of Java 2 platform v 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility. Do not call or override.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.ListSelectionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(ListSelectionEvent e)
      Called whenever the value of the selection changes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.ListSelectionHandler

        protected BasicComboPopup.ListSelectionHandler()

    • 方法详细信息

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        从接口复制的描述： ListSelectionListener
        Called whenever the value of the selection changes.
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=t=è�


BasicComboPopup.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicComboPopup.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicComboPopup

    protected class BasicComboPopup.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    This listener watches for bound properties that have changed in the combo box.

    Subclasses which wish to listen to combo box property changes should call the superclass methods to ensure that the combo popup correctly handles property changes.

    另请参见：
    BasicComboPopup.createPropertyChangeListener()

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicComboPopup.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicComboPopup.PropertyChangeHandler

        protected BasicComboPopup.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,_amaca=atgt="l"a""奈rI hht hpn:dtttpvc/蚻r


BasicDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopIconUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
  • 直接已知子类：
    MetalDesktopIconUI, SynthDesktopIconUI

    public class BasicDesktopIconUI
extends DesktopIconUI
    Basic L&F for a minimized window on a desktop.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicDesktopIconUI.MouseInputHandler
      Listens for mouse movements and acts on them.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JInternalFrame.JDesktopIcon | desktopIcon
      protected JInternalFrame | frame
      protected JComponent iconPane
      The title pane component used in the desktop icon.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicDesktopIconUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected MouseInputListener | createMouseInputListener()
      static ComponentUI | createUI(JComponent c)
      void | deiconize()
      Insets | getInsets(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Desktop icons can not be resized.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • desktopIcon

        protected JInternalFrame.JDesktopIcon desktopIcon

      • frame

        protected JInternalFrame frame

      • iconPane

        protected JComponent iconPane
        The title pane component used in the desktop icon.
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • BasicDesktopIconUI

        public BasicDesktopIconUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installComponents

        protected void installComponents()

      • uninstallComponents

        protected void uninstallComponents()

      • installListeners

        protected void installListeners()

      • uninstallListeners

        protected void uninstallListeners()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener()

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Desktop icons can not be resized. Therefore, we should always return the minimum size of the desktop icon.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        getMinimumSize(javax.swing.JComponent)

      • getInsets

        public Insets getInsets(JComponent c)

      • deiconize

        public void deiconize()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


BasicDesktopIconUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopIconUI.MouseInputHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.event.MouseInputAdapter
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
    封闭类：
    BasicDesktopIconUI

    public class BasicDesktopIconUI.MouseInputHandler
extends MouseInputAdapter
    Listens for mouse movements and acts on them. This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicDesktopIconUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.
      void | moveAndRepaint(JComponent f, int newX, int newY, int newWidth, int newHeight)

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseEntered, mouseExited, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.MouseListener

        mouseClicked, mouseEntered, mouseExited

    • 构造方法详细信息

      • BasicDesktopIconUI.MouseInputHandler

        public BasicDesktopIconUI.MouseInputHandler()

    • 方法详细信息

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter

      • mousePressed

        public void mousePressed(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • moveAndRepaint

        public void moveAndRepaint(JComponent f,
                  int newX,
                  int newY,
                  int newWidth,
                  int newHeight)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C>o)ae#te#luu#lltCaatnvt(ttsf<


BasicDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
  • 直接已知子类：
    SynthDesktopPaneUI

    public class BasicDesktopPaneUI
extends DesktopPaneUI
    Basic L&F for a desktop.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  BasicDesktopPaneUI.CloseAction
      Handles closing an internal frame.
      protected class  BasicDesktopPaneUI.MaximizeAction
      Handles maximizing an internal frame.
      protected class  BasicDesktopPaneUI.MinimizeAction
      Handles minimizing an internal frame.
      protected class  BasicDesktopPaneUI.NavigateAction
      Handles navigating to the next internal frame.
      protected class  BasicDesktopPaneUI.OpenAction
      Handles restoring a minimized or maximized internal frame.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected KeyStroke closeKey
      Deprecated.
      As of 1.3.
      protected JDesktopPane | desktop
      protected DesktopManager | desktopManager
      protected KeyStroke maximizeKey
      Deprecated.
      As of 1.3.
      protected KeyStroke minimizeKey
      Deprecated.
      As of 1.3.
      protected KeyStroke navigateKey
      Deprecated.
      As of 1.3.
      protected KeyStroke navigateKey2
      Deprecated.
      As of 1.3.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicDesktopPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected PropertyChangeListener createPropertyChangeListener()
      Returns the PropertyChangeListener to install on the JDesktopPane.
      static ComponentUI | createUI(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults()
      protected void | installDesktopManager()
      protected void | installKeyboardActions()
      protected void installListeners()
      Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | registerKeyboardActions()
      protected void | uninstallDefaults()
      protected void | uninstallDesktopManager()
      protected void | uninstallKeyboardActions()
      protected void uninstallListeners()
      Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      protected void | unregisterKeyboardActions()

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • desktop

        protected JDesktopPane desktop

      • desktopManager

        protected DesktopManager desktopManager

      • minimizeKey

        @Deprecated
protected KeyStroke minimizeKey
        Deprecated. As of 1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • maximizeKey

        @Deprecated
protected KeyStroke maximizeKey
        Deprecated. As of 1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • closeKey

        @Deprecated
protected KeyStroke closeKey
        Deprecated. As of 1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • navigateKey

        @Deprecated
protected KeyStroke navigateKey
        Deprecated. As of 1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • navigateKey2

        @Deprecated
protected KeyStroke navigateKey2
        Deprecated. As of 1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

    • 构造方法详细信息

      • BasicDesktopPaneUI

        public BasicDesktopPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installListeners

        protected void installListeners()
        Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
        从以下版本开始：
        1.5
        另请参见：
        createPropertyChangeListener()

      • uninstallListeners

        protected void uninstallListeners()
        Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
        从以下版本开始：
        1.5
        另请参见：
        createPropertyChangeListener()

      • installDesktopManager

        protected void installDesktopManager()

      • uninstallDesktopManager

        protected void uninstallDesktopManager()

      • installKeyboardActions

        protected void installKeyboardActions()

      • registerKeyboardActions

        protected void registerKeyboardActions()

      • unregisterKeyboardActions

        protected void unregisterKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Returns the PropertyChangeListener to install on the JDesktopPane.
        返回：
        The PropertyChangeListener that will be added to track changes in the desktop pane.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicDesktopPaneUI.CloseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI.CloseAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicDesktopPaneUI

    protected class BasicDesktopPaneUI.CloseAction
extends AbstractAction
    Handles closing an internal frame.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicDesktopPaneUI.CloseAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDesktopPaneUI.CloseAction

        protected BasicDesktopPaneUI.CloseAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gd rn pt pmoopmmhrooepanoann ad paonmmn gEERM>o


BasicDesktopPaneUI.MaximizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI.MaximizeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicDesktopPaneUI

    protected class BasicDesktopPaneUI.MaximizeAction
extends AbstractAction
    Handles maximizing an internal frame.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicDesktopPaneUI.MaximizeAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDesktopPaneUI.MaximizeAction

        protected BasicDesktopPaneUI.MaximizeAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicDesktopPaneUI.MinimizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI.MinimizeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicDesktopPaneUI

    protected class BasicDesktopPaneUI.MinimizeAction
extends AbstractAction
    Handles minimizing an internal frame.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicDesktopPaneUI.MinimizeAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDesktopPaneUI.MinimizeAction

        protected BasicDesktopPaneUI.MinimizeAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

te鑢g俶 Mm 鑢orrl� ne�Cr9 餾n& 0 te


BasicDesktopPaneUI.NavigateAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI.NavigateAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicDesktopPaneUI

    protected class BasicDesktopPaneUI.NavigateAction
extends AbstractAction
    Handles navigating to the next internal frame.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicDesktopPaneUI.NavigateAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDesktopPaneUI.NavigateAction

        protected BasicDesktopPaneUI.NavigateAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

\ \r�訲麯腁�


BasicDesktopPaneUI.OpenAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDesktopPaneUI.OpenAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicDesktopPaneUI

    protected class BasicDesktopPaneUI.OpenAction
extends AbstractAction
    Handles restoring a minimized or maximized internal frame.
    从以下版本开始：
    1.3

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicDesktopPaneUI.OpenAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDesktopPaneUI.OpenAction

        protected BasicDesktopPaneUI.OpenAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llho>o/o焗\rr T枘


BasicDirectoryModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicDirectoryModel

  • java.lang.Object
    • javax.swing.AbstractListModel
      • javax.swing.plaf.basic.BasicDirectoryModel
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, ListModel

    public class BasicDirectoryModel
extends AbstractListModel
implements PropertyChangeListener
    Basic implementation of a file list.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractListModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicDirectoryModel(JFileChooser filechooser)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      boolean | contains(Object o)
      void | fireContentsChanged()
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Support for reporting bound property changes for boolean properties.
      Vector<File> getDirectories()
      Object getElementAt(int index)
      Returns the value at the specified index.
      Vector<File> getFiles()
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the property change listeners registered on this component.
      int getSize()
      Returns the length of the list.
      int | indexOf(Object o)
      void intervalAdded(ListDataEvent e)
      Obsolete - not used.
      void intervalRemoved(ListDataEvent e)
      Obsolete - not used.
      void invalidateFileCache()
      This method is used to interrupt file loading thread.
      protected boolean | lt(File a, File b)
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      boolean renameFile(File oldFile, File newFile)
      Renames a file in the underlying file system.
      protected void | sort(Vector<? extends File> v)
      void | validateFileCache()

      • 方法 - 继承于类 javax.swing.AbstractListModel

        addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicDirectoryModel

        public BasicDirectoryModel(JFileChooser filechooser)

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • invalidateFileCache

        public void invalidateFileCache()
        This method is used to interrupt file loading thread.

      • getDirectories

        public Vector<File> getDirectories()

      • getFiles

        public Vector<File> getFiles()

      • validateFileCache

        public void validateFileCache()

      • renameFile

        public boolean renameFile(File oldFile,
                 File newFile)
        Renames a file in the underlying file system.
        参数：
        oldFile - a File object representing the existing file
        newFile - a File object representing the desired new file name
        返回：
        true if rename succeeded, otherwise false
        从以下版本开始：
        1.4

      • fireContentsChanged

        public void fireContentsChanged()

      • getSize

        public int getSize()
        从接口复制的描述： ListModel
        Returns the length of the list.
        指定者：
        getSize in interface ListModel
        返回：
        the length of the list

      • contains

        public boolean contains(Object o)

      • indexOf

        public int indexOf(Object o)

      • getElementAt

        public Object getElementAt(int index)
        从接口复制的描述： ListModel
        Returns the value at the specified index.
        指定者：
        getElementAt in interface ListModel
        参数：
        index - the requested index
        返回：
        the value at index

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        Obsolete - not used.

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        Obsolete - not used.

      • sort

        protected void sort(Vector<? extends File> v)

      • lt

        protected boolean lt(File a,
         File b)

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all bound properties of this class.

        If listener is null, no exception is thrown and no action is performed.

        参数：
        listener - the property change listener to be added
        从以下版本开始：
        1.6
        另请参见：
        removePropertyChangeListener(java.beans.PropertyChangeListener), getPropertyChangeListeners()

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list.

        If listener is null, no exception is thrown and no action is performed.

        参数：
        listener - the PropertyChangeListener to be removed
        从以下版本开始：
        1.6
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener), getPropertyChangeListeners()

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the property change listeners registered on this component.
        返回：
        all of this component's PropertyChangeListeners or an empty array if no property change listeners are currently registered
        从以下版本开始：
        1.6
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.beans.PropertyChangeListener),
PropertyChangeSupport.getPropertyChangeListeners()

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Support for reporting bound property changes for boolean properties. This method can be called when a bound property has changed and it will send the appropriate PropertyChangeEvent to any registered PropertyChangeListeners.
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b


BasicEditorPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicEditorPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicEditorPaneUI
  • 所有已实现的接口：
    ViewFactory
    直接已知子类：
    BasicTextPaneUI, SynthEditorPaneUI

    public class BasicEditorPaneUI
extends BasicTextUI
    Provides the look and feel for a JEditorPane.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicEditorPaneUI()
      Creates a new BasicEditorPaneUI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for the JTextPane.
      EditorKit getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.
      void installUI(JComponent c)
      Installs the UI for a component.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.
      void uninstallUI(JComponent c)
      Deinstalls the UI for a component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicEditorPaneUI

        public BasicEditorPaneUI()
        Creates a new BasicEditorPaneUI.

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for the JTextPane.
        参数：
        c - the JTextPane component
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        指定者：
        getPropertyPrefix in class BasicTextUI
        返回：
        the name ("EditorPane")

      • installUI

        public void installUI(JComponent c)
        Installs the UI for a component. This does the following things.
        1. Sets the associated component to opaque if the opaque property has not already been set by the client program. This will cause the component's background color to be painted.
        2. Installs the default caret and highlighter into the associated component. These properties are only set if their current value is either null or an instance of UIResource.
        3. Attaches to the editor and model. If there is no model, a default one is created.
        4. Creates the view factory and the view hierarchy used to represent the model.
        重载：
        installUI in class BasicTextUI
        参数：
        c - the editor component
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent)

      • uninstallUI

        public void uninstallUI(JComponent c)
        Deinstalls the UI for a component. This removes the listeners, uninstalls the highlighter, removes views, and nulls out the keymap.
        重载：
        uninstallUI in class BasicTextUI
        参数：
        c - the editor component
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent)

      • getEditorKit

        public EditorKit getEditorKit(JTextComponent tc)
        Fetches the EditorKit for the UI. This is whatever is currently set in the associated JEditorPane.
        重载：
        getEditorKit in class BasicTextUI
        参数：
        tc - the text component for which this UI is installed
        返回：
        the editor capabilities
        另请参见：
        TextUI.getEditorKit(javax.swing.text.JTextComponent)

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to rebuild the ActionMap based upon an EditorKit change.
        重载：
        propertyChange in class BasicTextUI
        参数：
        evt - the property change event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h/a..ejbej(aaj((thaad<=>>par/e.hhw.js=.翰l


BasicFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
  • 直接已知子类：
    MetalFileChooserUI

    public class BasicFileChooserUI
extends FileChooserUI
    Basic L&F implementation of a FileChooser.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | BasicFileChooserUI.AcceptAllFileFilter
      protected class  BasicFileChooserUI.ApproveSelectionAction
      Responds to an Open or Save request
      protected class  | BasicFileChooserUI.BasicFileView
      protected class  BasicFileChooserUI.CancelSelectionAction
      Responds to a cancel request.
      protected class  | BasicFileChooserUI.ChangeToParentDirectoryAction
      protected class  | BasicFileChooserUI.DoubleClickListener
      protected class  BasicFileChooserUI.GoHomeAction
      Acts on the "home" key event or equivalent event.
      protected class  BasicFileChooserUI.NewFolderAction
      Creates a new folder.
      protected class  | BasicFileChooserUI.SelectionListener
      protected class  BasicFileChooserUI.UpdateAction
      Rescans the files in the current directory

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | cancelButtonMnemonic
      protected String | cancelButtonText
      protected String | cancelButtonToolTipText
      protected Icon | computerIcon
      protected Icon | detailsViewIcon
      protected Icon | directoryIcon
      protected int directoryOpenButtonMnemonic
      The mnemonic keycode used for the approve button when a directory is selected and the current selection mode is FILES_ONLY.
      protected String directoryOpenButtonText
      The label text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
      protected String directoryOpenButtonToolTipText
      The tooltip text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
      protected Icon | fileIcon
      protected Icon | floppyDriveIcon
      protected Icon | hardDriveIcon
      protected int | helpButtonMnemonic
      protected String | helpButtonText
      protected String | helpButtonToolTipText
      protected Icon | homeFolderIcon
      protected Icon | listViewIcon
      protected Icon | newFolderIcon
      protected int | openButtonMnemonic
      protected String | openButtonText
      protected String | openButtonToolTipText
      protected int | saveButtonMnemonic
      protected String | saveButtonText
      protected String | saveButtonToolTipText
      protected int | updateButtonMnemonic
      protected String | updateButtonText
      protected String | updateButtonToolTipText
      protected Icon | upFolderIcon
      protected Icon | viewMenuIcon

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicFileChooserUI(JFileChooser b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void | clearIconCache()
      protected MouseListener | createDoubleClickListener(JFileChooser fc, JList list)
      ListSelectionListener | createListSelectionListener(JFileChooser fc)
      protected void | createModel()
      PropertyChangeListener | createPropertyChangeListener(JFileChooser fc)
      static ComponentUI createUI(JComponent c)
      Creates a BasicFileChooserUI implementation for the specified component.
      void | ensureFileIsVisible(JFileChooser fc, File f)
      FileFilter getAcceptAllFileFilter(JFileChooser fc)
      Returns the default accept all file filter
      JPanel getAccessoryPanel()
      protected JButton | getApproveButton(JFileChooser fc)
      int | getApproveButtonMnemonic(JFileChooser fc)
      String | getApproveButtonText(JFileChooser fc)
      String | getApproveButtonToolTipText(JFileChooser fc)
      Action getApproveSelectionAction()
      Action getCancelSelectionAction()
      Action getChangeToParentDirectoryAction()
      JButton getDefaultButton(JFileChooser fc)
      Returns default button for current LookAndFeel.
      String getDialogTitle(JFileChooser fc)
      Returns the title of this dialog
      protected File getDirectory()
      Property to remember the directory that is currently selected in the UI.
      String getDirectoryName()
      JFileChooser getFileChooser()
      String getFileName()
      FileView | getFileView(JFileChooser fc)
      Action getGoHomeAction()
      BasicDirectoryModel getModel()
      Action getNewFolderAction()
      Action getUpdateAction()
      void | installComponents(JFileChooser fc)
      protected void | installDefaults(JFileChooser fc)
      protected void | installIcons(JFileChooser fc)
      protected void | installListeners(JFileChooser fc)
      protected void | installStrings(JFileChooser fc)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected boolean isDirectorySelected()
      Property to remember whether a directory is currently selected in the UI.
      void | rescanCurrentDirectory(JFileChooser fc)
      protected void setDirectory(File f)
      Property to remember the directory that is currently selected in the UI.
      void | setDirectoryName(String dirname)
      protected void setDirectorySelected(boolean b)
      Property to remember whether a directory is currently selected in the UI.
      void | setFileName(String filename)
      void | uninstallComponents(JFileChooser fc)
      protected void | uninstallDefaults(JFileChooser fc)
      protected void | uninstallIcons(JFileChooser fc)
      protected void | uninstallListeners(JFileChooser fc)
      protected void | uninstallStrings(JFileChooser fc)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • directoryIcon

        protected Icon directoryIcon

      • fileIcon

        protected Icon fileIcon

      • computerIcon

        protected Icon computerIcon

      • hardDriveIcon

        protected Icon hardDriveIcon

      • floppyDriveIcon

        protected Icon floppyDriveIcon

      • newFolderIcon

        protected Icon newFolderIcon

      • upFolderIcon

        protected Icon upFolderIcon

      • homeFolderIcon

        protected Icon homeFolderIcon

      • listViewIcon

        protected Icon listViewIcon

      • detailsViewIcon

        protected Icon detailsViewIcon

      • viewMenuIcon

        protected Icon viewMenuIcon

      • saveButtonMnemonic

        protected int saveButtonMnemonic

      • openButtonMnemonic

        protected int openButtonMnemonic

      • cancelButtonMnemonic

        protected int cancelButtonMnemonic

      • updateButtonMnemonic

        protected int updateButtonMnemonic

      • helpButtonMnemonic

        protected int helpButtonMnemonic

      • directoryOpenButtonMnemonic

        protected int directoryOpenButtonMnemonic
        The mnemonic keycode used for the approve button when a directory is selected and the current selection mode is FILES_ONLY.
        从以下版本开始：
        1.4

      • saveButtonText

        protected String saveButtonText

      • openButtonText

        protected String openButtonText

      • cancelButtonText

        protected String cancelButtonText

      • updateButtonText

        protected String updateButtonText

      • helpButtonText

        protected String helpButtonText

      • directoryOpenButtonText

        protected String directoryOpenButtonText
        The label text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
        从以下版本开始：
        1.4

      • saveButtonToolTipText

        protected String saveButtonToolTipText

      • openButtonToolTipText

        protected String openButtonToolTipText

      • cancelButtonToolTipText

        protected String cancelButtonToolTipText

      • updateButtonToolTipText

        protected String updateButtonToolTipText

      • helpButtonToolTipText

        protected String helpButtonToolTipText

      • directoryOpenButtonToolTipText

        protected String directoryOpenButtonToolTipText
        The tooltip text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
        从以下版本开始：
        1.4

    • 构造方法详细信息

      • BasicFileChooserUI

        public BasicFileChooserUI(JFileChooser b)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a BasicFileChooserUI implementation for the specified component. By default the BasicLookAndFeel class uses createUI methods of all basic UIs classes to instantiate UIs.
        参数：
        c - the JFileChooser which needs a UI
        返回：
        the BasicFileChooserUI object
        从以下版本开始：
        1.7
        另请参见：
        UIDefaults.getUI(JComponent)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installComponents

        public void installComponents(JFileChooser fc)

      • uninstallComponents

        public void uninstallComponents(JFileChooser fc)

      • installListeners

        protected void installListeners(JFileChooser fc)

      • uninstallListeners

        protected void uninstallListeners(JFileChooser fc)

      • installDefaults

        protected void installDefaults(JFileChooser fc)

      • installIcons

        protected void installIcons(JFileChooser fc)

      • installStrings

        protected void installStrings(JFileChooser fc)

      • uninstallDefaults

        protected void uninstallDefaults(JFileChooser fc)

      • uninstallIcons

        protected void uninstallIcons(JFileChooser fc)

      • uninstallStrings

        protected void uninstallStrings(JFileChooser fc)

      • createModel

        protected void createModel()

      • getModel

        public BasicDirectoryModel getModel()

      • createPropertyChangeListener

        public PropertyChangeListener createPropertyChangeListener(JFileChooser fc)

      • getFileName

        public String getFileName()

      • getDirectoryName

        public String getDirectoryName()

      • setFileName

        public void setFileName(String filename)

      • setDirectoryName

        public void setDirectoryName(String dirname)

      • rescanCurrentDirectory

        public void rescanCurrentDirectory(JFileChooser fc)
        指定者：
        rescanCurrentDirectory in class FileChooserUI

      • ensureFileIsVisible

        public void ensureFileIsVisible(JFileChooser fc,
                       File f)
        指定者：
        ensureFileIsVisible in class FileChooserUI

      • getFileChooser

        public JFileChooser getFileChooser()

      • getAccessoryPanel

        public JPanel getAccessoryPanel()

      • getApproveButton

        protected JButton getApproveButton(JFileChooser fc)

      • getDefaultButton

        public JButton getDefaultButton(JFileChooser fc)
        Description copied from class: FileChooserUI
        Returns default button for current LookAndFeel. JFileChooser will use this button as default button for dialog windows.
        重载：
        getDefaultButton in class FileChooserUI

      • getApproveButtonToolTipText

        public String getApproveButtonToolTipText(JFileChooser fc)

      • clearIconCache

        public void clearIconCache()

      • createDoubleClickListener

        protected MouseListener createDoubleClickListener(JFileChooser fc,
                                      JList list)

      • createListSelectionListener

        public ListSelectionListener createListSelectionListener(JFileChooser fc)

      • isDirectorySelected

        protected boolean isDirectorySelected()
        Property to remember whether a directory is currently selected in the UI.
        返回：
        true iff a directory is currently selected.
        从以下版本开始：
        1.4

      • setDirectorySelected

        protected void setDirectorySelected(boolean b)
        Property to remember whether a directory is currently selected in the UI. This is normally called by the UI on a selection event.
        参数：
        b - iff a directory is currently selected.
        从以下版本开始：
        1.4

      • getDirectory

        protected File getDirectory()
        Property to remember the directory that is currently selected in the UI.
        返回：
        the value of the directory property
        从以下版本开始：
        1.4
        另请参见：
        setDirectory(java.io.File)

      • setDirectory

        protected void setDirectory(File f)
        Property to remember the directory that is currently selected in the UI. This is normally called by the UI on a selection event.
        参数：
        f - the File object representing the directory that is currently selected
        从以下版本开始：
        1.4

      • getAcceptAllFileFilter

        public FileFilter getAcceptAllFileFilter(JFileChooser fc)
        Returns the default accept all file filter
        指定者：
        getAcceptAllFileFilter in class FileChooserUI

      • getFileView

        public FileView getFileView(JFileChooser fc)
        指定者：
        getFileView in class FileChooserUI

      • getDialogTitle

        public String getDialogTitle(JFileChooser fc)
        Returns the title of this dialog
        指定者：
        getDialogTitle in class FileChooserUI

      • getApproveButtonMnemonic

        public int getApproveButtonMnemonic(JFileChooser fc)

      • getApproveButtonText

        public String getApproveButtonText(JFileChooser fc)
        指定者：
        getApproveButtonText in class FileChooserUI

      • getNewFolderAction

        public Action getNewFolderAction()

      • getGoHomeAction

        public Action getGoHomeAction()

      • getChangeToParentDirectoryAction

        public Action getChangeToParentDirectoryAction()

      • getApproveSelectionAction

        public Action getApproveSelectionAction()

      • getCancelSelectionAction

        public Action getCancelSelectionAction()

      • getUpdateAction

        public Action getUpdateAction()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicFileChooserUI.AcceptAllFileFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.AcceptAllFileFilter

  • java.lang.Object
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
  • 封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.AcceptAllFileFilter
extends FileFilter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicFileChooserUI.AcceptAllFileFilter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean accept(File f)
      Whether the given file is accepted by this filter.
      String getDescription()
      The description of this filter.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.AcceptAllFileFilter

        public BasicFileChooserUI.AcceptAllFileFilter()

    • 方法详细信息

      • accept

        public boolean accept(File f)
        Description copied from class: FileFilter
        Whether the given file is accepted by this filter.
        指定者：
        accept in class FileFilter

      • getDescription

        public String getDescription()
        Description copied from class: FileFilter
        The description of this filter. For example: "JPG and GIF Images"
        指定者：
        getDescription in class FileFilter
        另请参见：
        FileView.getName(java.io.File)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,. talilli>nni>>rl..blietdde..a.v.//.f/I


BasicFileChooserUI.ApproveSelectionAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.ApproveSelectionAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.ApproveSelectionAction
extends AbstractAction
    Responds to an Open or Save request

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.ApproveSelectionAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.ApproveSelectionAction

        protected BasicFileChooserUI.ApproveSelectionAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stehet


BasicFileChooserUI.BasicFileView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.BasicFileView

  • java.lang.Object
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
  • 封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.BasicFileView
extends FileView

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Hashtable<File,Icon> | iconCache

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicFileChooserUI.BasicFileView()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void | cacheIcon(File f, Icon i)
      void | clearIconCache()
      Icon | getCachedIcon(File f)
      String getDescription(File f)
      A human readable description of the file.
      Icon getIcon(File f)
      The icon that represents this file in the JFileChooser.
      String getName(File f)
      The name of the file.
      String getTypeDescription(File f)
      A human readable description of the type of the file.
      Boolean | isHidden(File f)

      • 方法 - 继承于类 javax.swing.filechooser.FileView

        isTraversable

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • iconCache

        protected Hashtable<File,Icon> iconCache

    • 构造方法详细信息

      • BasicFileChooserUI.BasicFileView

        public BasicFileChooserUI.BasicFileView()

    • 方法详细信息

      • clearIconCache

        public void clearIconCache()

      • getName

        public String getName(File f)
        Description copied from class: FileView
        The name of the file. Normally this would be simply f.getName().
        重载：
        getName in class FileView

      • getDescription

        public String getDescription(File f)
        Description copied from class: FileView
        A human readable description of the file. For example, a file named jag.jpg might have a description that read: "A JPEG image file of James Gosling's face".
        重载：
        getDescription in class FileView

      • getTypeDescription

        public String getTypeDescription(File f)
        Description copied from class: FileView
        A human readable description of the type of the file. For example, a jpg file might have a type description of: "A JPEG Compressed Image File"
        重载：
        getTypeDescription in class FileView

      • getCachedIcon

        public Icon getCachedIcon(File f)

      • cacheIcon

        public void cacheIcon(File f,
             Icon i)

      • getIcon

        public Icon getIcon(File f)
        Description copied from class: FileView
        The icon that represents this file in the JFileChooser.
        重载：
        getIcon in class FileView

      • isHidden

        public Boolean isHidden(File f)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sepeogng"=ss"==ct>>hAi d=>oo=/


BasicFileChooserUI.CancelSelectionAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.CancelSelectionAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.CancelSelectionAction
extends AbstractAction
    Responds to a cancel request.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.CancelSelectionAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.CancelSelectionAction

        protected BasicFileChooserUI.CancelSelectionAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"spa&n>&niggnii"a==nor>hn u


BasicFileChooserUI.ChangeToParentDirectoryAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.ChangeToParentDirectoryAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.ChangeToParentDirectoryAction
extends AbstractAction

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.ChangeToParentDirectoryAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.ChangeToParentDirectoryAction

        protected BasicFileChooserUI.ChangeToParentDirectoryAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irv)nsbc/jee


BasicFileChooserUI.DoubleClickListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.DoubleClickListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.DoubleClickListener
extends MouseAdapter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicFileChooserUI.DoubleClickListener(JList list)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseEntered(MouseEvent e)
      The JList used for representing the files is created by subclasses, but the selection is monitored in this class.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseDragged, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.DoubleClickListener

        public BasicFileChooserUI.DoubleClickListener(JList list)

    • 方法详细信息

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        The JList used for representing the files is created by subclasses, but the selection is monitored in this class. The TransferHandler installed in the JFileChooser is also installed in the file list as it is used as the actual transfer source. The list is updated on a mouse enter to reflect the current data transfer state of the file chooser.
        指定者：
        mouseEntered in interface MouseListener
        重载：
        mouseEntered in class MouseAdapter

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener
        重载：
        mouseClicked in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iiv-srt1ed>>edd>eoo/...s.a-sl.fff/ei/o


BasicFileChooserUI.GoHomeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.GoHomeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.GoHomeAction
extends AbstractAction
    Acts on the "home" key event or equivalent event.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.GoHomeAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.GoHomeAction

        protected BasicFileChooserUI.GoHomeAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hureoete es a hft/hh�"u蝡大�<误�/�"韙t縭�>a�


BasicFileChooserUI.NewFolderAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.NewFolderAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.NewFolderAction
extends AbstractAction
    Creates a new folder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.NewFolderAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.NewFolderAction

        protected BasicFileChooserUI.NewFolderAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n gnn="h.f..../vn//>ttss


BasicFileChooserUI.SelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.SelectionListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
  • 所有已实现的接口：
    EventListener, ListSelectionListener
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.SelectionListener
extends Object
implements ListSelectionListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.SelectionListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(ListSelectionEvent e)
      Called whenever the value of the selection changes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.SelectionListener

        protected BasicFileChooserUI.SelectionListener()

    • 方法详细信息

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        从接口复制的描述： ListSelectionListener
        Called whenever the value of the selection changes.
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/ ninionivggivviiaasvoltoov>b>o ___v- -"/t


BasicFileChooserUI.UpdateAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFileChooserUI.UpdateAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicFileChooserUI

    protected class BasicFileChooserUI.UpdateAction
extends AbstractAction
    Rescans the files in the current directory

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicFileChooserUI.UpdateAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFileChooserUI.UpdateAction

        protected BasicFileChooserUI.UpdateAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hlo3sp&kt3Fuw o>/jaas/s lnl


BasicFormattedTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicFormattedTextFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
  • 所有已实现的接口：
    ViewFactory

    public class BasicFormattedTextFieldUI
extends BasicTextFieldUI
    Provides the look and feel implementation for JFormattedTextField.
    从以下版本开始：
    1.4

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicFormattedTextFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        create, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicFormattedTextFieldUI

        public BasicFormattedTextFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JFormattedTextField.
        参数：
        c - the formatted text field
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicTextFieldUI
        返回：
        the name "FormattedTextField"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xNcAe>>rc#n/ruobf>ar


BasicGraphicsUtils

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicGraphicsUtils

  • java.lang.Object
    • javax.swing.plaf.basic.BasicGraphicsUtils

  • public class BasicGraphicsUtils
extends Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicGraphicsUtils()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static void | drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      static void | drawDashedRect(Graphics g, int x, int y, int width, int height)
      static void | drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      static void | drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
      static void | drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
      static void drawString(Graphics g, String text, int underlinedChar, int x, int y)
      Draw a string with the graphics g at location (x,y) just like g.drawString would.
      static void drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
      Draw a string with the graphics g at location (x, y) just like g.drawString would.
      static Insets getEtchedInsets()
      Returns the amount of space taken up by a border drawn by drawEtchedRect()
      static Insets getGrooveInsets()
      Returns the amount of space taken up by a border drawn by drawGroove()
      static Dimension | getPreferredButtonSize(AbstractButton b, int textIconGap)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicGraphicsUtils

        public BasicGraphicsUtils()

    • 方法详细信息

      • drawEtchedRect

        public static void drawEtchedRect(Graphics g,
                  int x,
                  int y,
                  int w,
                  int h,
                  Color shadow,
                  Color darkShadow,
                  Color highlight,
                  Color lightHighlight)

      • getEtchedInsets

        public static Insets getEtchedInsets()
        Returns the amount of space taken up by a border drawn by drawEtchedRect()
        返回：
        the inset of an etched rect

      • drawGroove

        public static void drawGroove(Graphics g,
              int x,
              int y,
              int w,
              int h,
              Color shadow,
              Color highlight)

      • getGrooveInsets

        public static Insets getGrooveInsets()
        Returns the amount of space taken up by a border drawn by drawGroove()
        返回：
        the inset of a groove border

      • drawBezel

        public static void drawBezel(Graphics g,
             int x,
             int y,
             int w,
             int h,
             boolean isPressed,
             boolean isDefault,
             Color shadow,
             Color darkShadow,
             Color highlight,
             Color lightHighlight)

      • drawLoweredBezel

        public static void drawLoweredBezel(Graphics g,
                    int x,
                    int y,
                    int w,
                    int h,
                    Color shadow,
                    Color darkShadow,
                    Color highlight,
                    Color lightHighlight)

      • drawString

        public static void drawString(Graphics g,
              String text,
              int underlinedChar,
              int x,
              int y)
        Draw a string with the graphics g at location (x,y) just like g.drawString would. The first occurrence of underlineChar in text will be underlined. The matching algorithm is not case sensitive.

      • drawStringUnderlineCharAt

        public static void drawStringUnderlineCharAt(Graphics g,
                             String text,
                             int underlinedIndex,
                             int x,
                             int y)
        Draw a string with the graphics g at location (x, y) just like g.drawString would. The character at index underlinedIndex in text will be underlined. If index is beyond the bounds of text (including < 0), nothing will be underlined.
        参数：
        g - Graphics to draw with
        text - String to draw
        underlinedIndex - Index of character in text to underline
        x - x coordinate to draw at
        y - y coordinate to draw at
        从以下版本开始：
        1.4

      • drawDashedRect

        public static void drawDashedRect(Graphics g,
                  int x,
                  int y,
                  int width,
                  int height)

      • getPreferredButtonSize

        public static Dimension getPreferredButtonSize(AbstractButton b,
                               int textIconGap)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

M>> s>">cakgeakkpt/at erNPe譺!m秇hwr-=t


BasicHTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicHTML

  • java.lang.Object
    • javax.swing.plaf.basic.BasicHTML

  • public class BasicHTML
extends Object
    Support for providing html views for the swing components. This translates a simple html string to a javax.swing.text.View implementation that can render the html and provide the necessary layout semantics.
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String documentBaseKey
      Key stored as a client property to indicate the base that relative references are resolved against.
      static String propertyKey
      Key to use for the html renderer when stored as a client property of a JComponent.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicHTML()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static View createHTMLView(JComponent c, String html)
      Create an html renderer for the given component and string of html.
      static int getHTMLBaseline(View view, int w, int h)
      Returns the baseline for the html renderer.
      static boolean isHTMLString(String s)
      Check the given string to see if it should trigger the html rendering logic in a non-text component that supports html rendering.
      static void updateRenderer(JComponent c, String text)
      Stash the HTML render for the given text into the client properties of the given JComponent.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • propertyKey

        public static final String propertyKey
        Key to use for the html renderer when stored as a client property of a JComponent.
        另请参见：
        Constant Field Values

      • documentBaseKey

        public static final String documentBaseKey
        Key stored as a client property to indicate the base that relative references are resolved against. For example, lets say you keep your images in the directory resources relative to the code path, you would use the following the set the base:
           jComponent.putClientProperty(documentBaseKey,
                                xxx.class.getResource("resources/"));
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BasicHTML

        public BasicHTML()

    • 方法详细信息

      • createHTMLView

        public static View createHTMLView(JComponent c,
                  String html)
        Create an html renderer for the given component and string of html.

      • getHTMLBaseline

        public static int getHTMLBaseline(View view,
                  int w,
                  int h)
        Returns the baseline for the html renderer.
        参数：
        view - the View to get the baseline for
        w - the width to get the baseline for
        h - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        FontMetrics, JComponent.getBaseline(int,int)

      • isHTMLString

        public static boolean isHTMLString(String s)
        Check the given string to see if it should trigger the html rendering logic in a non-text component that supports html rendering.

      • updateRenderer

        public static void updateRenderer(JComponent c,
                  String text)
        Stash the HTML render for the given text into the client properties of the given JComponent. If the given text is NOT HTML the property will be cleared of any renderer.

        This method is useful for ComponentUI implementations that are static (i.e. shared) and get their state entirely from the JComponent.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"alr>)e>)t<<)tthloo a


BasicIconFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicIconFactory

  • java.lang.Object
    • javax.swing.plaf.basic.BasicIconFactory
  • 所有已实现的接口：
    Serializable

    public class BasicIconFactory
extends Object
implements Serializable
    Factory object that can vend Icons appropriate for the basic L & F.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicIconFactory()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Icon | createEmptyFrameIcon()
      static Icon | getCheckBoxIcon()
      static Icon | getCheckBoxMenuItemIcon()
      static Icon | getMenuArrowIcon()
      static Icon | getMenuItemArrowIcon()
      static Icon | getMenuItemCheckIcon()
      static Icon | getRadioButtonIcon()
      static Icon | getRadioButtonMenuItemIcon()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicIconFactory

        public BasicIconFactory()

    • 方法详细信息

      • getMenuItemCheckIcon

        public static Icon getMenuItemCheckIcon()

      • getMenuItemArrowIcon

        public static Icon getMenuItemArrowIcon()

      • getMenuArrowIcon

        public static Icon getMenuArrowIcon()

      • getCheckBoxIcon

        public static Icon getCheckBoxIcon()

      • getRadioButtonIcon

        public static Icon getRadioButtonIcon()

      • getCheckBoxMenuItemIcon

        public static Icon getCheckBoxMenuItemIcon()

      • getRadioButtonMenuItemIcon

        public static Icon getRadioButtonMenuItemIcon()

      • createEmptyFrameIcon

        public static Icon createEmptyFrameIcon()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ecia<�><剥剥�"appi"f


BasicInternalFrameTitlePane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable
    直接已知子类：
    MetalInternalFrameTitlePane

    public class BasicInternalFrameTitlePane
extends JComponent
    The class that manages a basic title bar

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicInternalFrameTitlePane.CloseAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.IconifyAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MaximizeAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.MoveAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.PropertyChangeHandler
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.RestoreAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.SizeAction
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.SystemMenuBar
      This class should be treated as a "protected" inner class.
      class  BasicInternalFrameTitlePane.TitlePaneLayout
      This class should be treated as a "protected" inner class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static String | CLOSE_CMD
      protected Action | closeAction
      protected JButton | closeButton
      protected Icon | closeIcon
      protected JInternalFrame | frame
      protected JButton | iconButton
      protected Icon | iconIcon
      protected static String | ICONIFY_CMD
      protected Action | iconifyAction
      protected JButton | maxButton
      protected Icon | maxIcon
      protected static String | MAXIMIZE_CMD
      protected Action | maximizeAction
      protected JMenuBar | menuBar
      protected Icon | minIcon
      protected static String | MOVE_CMD
      protected Action | moveAction
      protected Color | notSelectedTextColor
      protected Color | notSelectedTitleColor
      protected PropertyChangeListener | propertyChangeListener
      protected static String | RESTORE_CMD
      protected Action | restoreAction
      protected Color | selectedTextColor
      protected Color | selectedTitleColor
      protected static String | SIZE_CMD
      protected Action | sizeAction
      protected JMenu | windowMenu

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane(JInternalFrame f)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | addSubComponents()
      protected void | addSystemMenuItems(JMenu systemMenu)
      protected void | assembleSystemMenu()
      protected void | createActions()
      protected void | createButtons()
      protected LayoutManager | createLayout()
      protected PropertyChangeListener | createPropertyChangeListener()
      protected JMenu | createSystemMenu()
      protected JMenuBar | createSystemMenuBar()
      protected void | enableActions()
      protected String | getTitle(String text, FontMetrics fm, int availTextWidth)
      protected void | installDefaults()
      protected void | installListeners()
      protected void | installTitlePane()
      void paintComponent(Graphics g)
      Calls the UI delegate's paint method, if the UI delegate is non-null.
      protected void paintTitleBackground(Graphics g)
      Invoked from paintComponent.
      protected void postClosingEvent(JInternalFrame frame)
      Post a WINDOW_CLOSING-like event to the frame, so that it can be treated like a regular Frame.
      protected void | setButtonIcons()
      protected void | showSystemMenu()
      protected void | uninstallDefaults()
      protected void | uninstallListeners()

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • menuBar

        protected JMenuBar menuBar

      • iconButton

        protected JButton iconButton

      • maxButton

        protected JButton maxButton

      • closeButton

        protected JButton closeButton

      • windowMenu

        protected JMenu windowMenu

      • frame

        protected JInternalFrame frame

      • selectedTitleColor

        protected Color selectedTitleColor

      • selectedTextColor

        protected Color selectedTextColor

      • notSelectedTitleColor

        protected Color notSelectedTitleColor

      • notSelectedTextColor

        protected Color notSelectedTextColor

      • maxIcon

        protected Icon maxIcon

      • minIcon

        protected Icon minIcon

      • iconIcon

        protected Icon iconIcon

      • closeIcon

        protected Icon closeIcon

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

      • closeAction

        protected Action closeAction

      • maximizeAction

        protected Action maximizeAction

      • iconifyAction

        protected Action iconifyAction

      • restoreAction

        protected Action restoreAction

      • moveAction

        protected Action moveAction

      • sizeAction

        protected Action sizeAction

      • CLOSE_CMD

        protected static final String CLOSE_CMD

      • ICONIFY_CMD

        protected static final String ICONIFY_CMD

      • RESTORE_CMD

        protected static final String RESTORE_CMD

      • MAXIMIZE_CMD

        protected static final String MAXIMIZE_CMD

      • MOVE_CMD

        protected static final String MOVE_CMD

      • SIZE_CMD

        protected static final String SIZE_CMD

    • 构造方法详细信息

      • BasicInternalFrameTitlePane

        public BasicInternalFrameTitlePane(JInternalFrame f)

    • 方法详细信息

      • installTitlePane

        protected void installTitlePane()

      • addSubComponents

        protected void addSubComponents()

      • createActions

        protected void createActions()

      • installListeners

        protected void installListeners()

      • uninstallListeners

        protected void uninstallListeners()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • createButtons

        protected void createButtons()

      • setButtonIcons

        protected void setButtonIcons()

      • assembleSystemMenu

        protected void assembleSystemMenu()

      • addSystemMenuItems

        protected void addSystemMenuItems(JMenu systemMenu)

      • createSystemMenu

        protected JMenu createSystemMenu()

      • createSystemMenuBar

        protected JMenuBar createSystemMenuBar()

      • showSystemMenu

        protected void showSystemMenu()

      • paintComponent

        public void paintComponent(Graphics g)
        Description copied from class: JComponent
        Calls the UI delegate's paint method, if the UI delegate is non-null. We pass the delegate a copy of the Graphics object to protect the rest of the paint code from irrevocable changes (for example, Graphics.translate).

        If you override this in a subclass you should not make permanent changes to the passed in Graphics. For example, you should not alter the clip Rectangle or modify the transform. If you need to do these operations you may find it easier to create a new Graphics from the passed in Graphics and manipulate it. Further, if you do not invoker super's implementation you must honor the opaque property, that is if this component is opaque, you must completely fill in the background in a non-opaque color. If you do not honor the opaque property you will likely see visual artifacts.

        The passed in Graphics object might have a transform other than the identify transform installed on it. In this case, you might get unexpected results if you cumulatively apply another transform.

        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics object to protect
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • paintTitleBackground

        protected void paintTitleBackground(Graphics g)
        Invoked from paintComponent. Paints the background of the titlepane. All text and icons will then be rendered on top of this background.
        参数：
        g - the graphics to use to render the background
        从以下版本开始：
        1.4

      • getTitle

        protected String getTitle(String text,
              FontMetrics fm,
              int availTextWidth)

      • postClosingEvent

        protected void postClosingEvent(JInternalFrame frame)
        Post a WINDOW_CLOSING-like event to the frame, so that it can be treated like a regular Frame.

      • enableActions

        protected void enableActions()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • createLayout

        protected LayoutManager createLayout()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicInternalFrameTitlePane.CloseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.CloseAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.CloseAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.CloseAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.CloseAction

        public BasicInternalFrameTitlePane.CloseAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-ste,eeerevoer-rest⒖Sn薐⒃�/蔽菶� 許S�>lga


BasicInternalFrameTitlePane.IconifyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.IconifyAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.IconifyAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.IconifyAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.IconifyAction

        public BasicInternalFrameTitlePane.IconifyAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/<>>cr


BasicInternalFrameTitlePane.MaximizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.MaximizeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.MaximizeAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.MaximizeAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.MaximizeAction

        public BasicInternalFrameTitlePane.MaximizeAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alnurui/uod, a=cn鵯V蜕构隢譴觬霉�/dㄇ迨


BasicInternalFrameTitlePane.MoveAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.MoveAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.MoveAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.MoveAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.MoveAction

        public BasicInternalFrameTitlePane.MoveAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnbbAbDbabn;a-b8t>1s/;>lma/>r/dl�


BasicInternalFrameTitlePane.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.PropertyChangeHandler

        public BasicInternalFrameTitlePane.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicInternalFrameTitlePane.RestoreAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.RestoreAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.RestoreAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.RestoreAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.RestoreAction

        public BasicInternalFrameTitlePane.RestoreAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ll ncM瀒t, ah==l�>e凸� 離t妹霉xd


BasicInternalFrameTitlePane.SizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.SizeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.SizeAction
extends AbstractAction
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.SizeAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.SizeAction

        public BasicInternalFrameTitlePane.SizeAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ffDs癰a瞡&r->paa/38


BasicInternalFrameTitlePane.SystemMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.SystemMenuBar

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JMenuBar
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.SystemMenuBar
extends JMenuBar
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JMenuBar

        JMenuBar.AccessibleJMenuBar

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.SystemMenuBar()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isFocusTraversable()
      Returns whether this Component can become the focus owner.
      boolean isOpaque()
      Returns true if this component is completely opaque.
      void paint(Graphics g)
      Invoked by Swing to draw components.
      void requestFocus()
      Requests that this Component gets the input focus.

      • 方法 - 继承于类 javax.swing.JMenuBar

        add, addNotify, getAccessibleContext, getComponent, getComponentAtIndex, getComponentIndex, getHelpMenu, getMargin, getMenu, getMenuCount, getSelectionModel, getSubElements, getUI, getUIClassID, isBorderPainted, isSelected, menuSelectionChanged, paintBorder, paramString, processKeyBinding, processKeyEvent, processMouseEvent, removeNotify, setBorderPainted, setHelpMenu, setMargin, setSelected, setSelectionModel, setUI, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.SystemMenuBar

        public BasicInternalFrameTitlePane.SystemMenuBar()

    • 方法详细信息

      • isFocusTraversable

        public boolean isFocusTraversable()
        Description copied from class: Component
        Returns whether this Component can become the focus owner.
        重载：
        isFocusTraversable in class Component
        返回：
        true if this Component is focusable; false otherwise
        另请参见：
        Component.setFocusable(boolean)

      • requestFocus

        public void requestFocus()
        Description copied from class: JComponent
        Requests that this Component gets the input focus. Refer to Component.requestFocus() for a complete description of this method.

        Note that the use of this method is discouraged because its behavior is platform dependent. Instead we recommend the use of requestFocusInWindow(). If you would like more information on focus, see How to Use the Focus Subsystem, a section in The Java Tutorial.

        重载：
        requestFocus in class JComponent
        另请参见：
        Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

      • paint

        public void paint(Graphics g)
        Description copied from class: JComponent
        Invoked by Swing to draw components. Applications should not invoke paint directly, but should instead use the repaint method to schedule the component for redrawing.

        This method actually delegates the work of painting to three protected methods: paintComponent, paintBorder, and paintChildren. They're called in the order listed to ensure that children appear on top of component itself. Generally speaking, the component and its children should not paint in the insets area allocated to the border. Subclasses can just override this method, as always. A subclass that just wants to specialize the UI (look and feel) delegate's paint method should just override paintComponent.

        重载：
        paint in class JComponent
        参数：
        g - the Graphics context in which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • isOpaque

        public boolean isOpaque()
        Description copied from class: JComponent
        Returns true if this component is completely opaque.

        An opaque component paints every pixel within its rectangular bounds. A non-opaque component paints only a subset of its pixels or none at all, allowing the pixels underneath it to "show through". Therefore, a component that does not fully paint its pixels provides a degree of transparency.

        Subclasses that guarantee to always completely paint their contents should override this method and return true.

        重载：
        isOpaque in class JComponent
        返回：
        true if this component is completely opaque
        另请参见：
        JComponent.setOpaque(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicInternalFrameTitlePane.TitlePaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameTitlePane.TitlePaneLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    BasicInternalFrameTitlePane

    public class BasicInternalFrameTitlePane.TitlePaneLayout
extends Object
implements LayoutManager
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameTitlePane.TitlePaneLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String name, Component c)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      void layoutContainer(Container c)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container c)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container c)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameTitlePane.TitlePaneLayout

        public BasicInternalFrameTitlePane.TitlePaneLayout()

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component c)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        c - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to be removed

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        c - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        c - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container c)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        c - the container to be laid out
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eaf/tociocissciiGgssoy


BasicInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
  • 直接已知子类：
    MetalInternalFrameUI, SynthInternalFrameUI

    public class BasicInternalFrameUI
extends InternalFrameUI
    A basic L&F implementation of JInternalFrame.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | BasicInternalFrameUI.BasicInternalFrameListener
      protected class  BasicInternalFrameUI.BorderListener
      Listens for border adjustments.
      protected class  | BasicInternalFrameUI.ComponentHandler
      protected class  | BasicInternalFrameUI.GlassPaneDispatcher
      class  | BasicInternalFrameUI.InternalFrameLayout
      class  | BasicInternalFrameUI.InternalFramePropertyChangeListener

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected MouseInputAdapter | borderListener
      protected ComponentListener | componentListener
      protected JComponent | eastPane
      protected JInternalFrame | frame
      protected MouseInputListener | glassPaneDispatcher
      protected LayoutManager | internalFrameLayout
      protected JComponent | northPane
      protected KeyStroke openMenuKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected PropertyChangeListener | propertyChangeListener
      protected JComponent | southPane
      protected BasicInternalFrameTitlePane | titlePane
      protected JComponent | westPane

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameUI(JInternalFrame b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void activateFrame(JInternalFrame f)
      This method is called when the frame becomes selected.
      protected void closeFrame(JInternalFrame f)
      This method is called when the user wants to close the frame.
      protected MouseInputAdapter | createBorderListener(JInternalFrame w)
      protected ComponentListener | createComponentListener()
      protected DesktopManager | createDesktopManager()
      protected JComponent | createEastPane(JInternalFrame w)
      protected MouseInputListener | createGlassPaneDispatcher()
      protected void | createInternalFrameListener()
      protected LayoutManager | createLayoutManager()
      protected JComponent | createNorthPane(JInternalFrame w)
      protected PropertyChangeListener | createPropertyChangeListener()
      protected JComponent | createSouthPane(JInternalFrame w)
      static ComponentUI | createUI(JComponent b)
      protected JComponent | createWestPane(JInternalFrame w)
      protected void deactivateFrame(JInternalFrame f)
      This method is called when the frame is no longer selected.
      protected void deiconifyFrame(JInternalFrame f)
      This method is called when the user wants to deiconify the frame.
      protected void | deinstallMouseHandlers(JComponent c)
      protected DesktopManager getDesktopManager()
      Returns the proper DesktopManager.
      JComponent getEastPane()
      Dimension getMaximumSize(JComponent x)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent x)
      Returns the specified component's minimum size appropriate for the look and feel.
      JComponent getNorthPane()
      Dimension getPreferredSize(JComponent x)
      Returns the specified component's preferred size appropriate for the look and feel.
      JComponent getSouthPane()
      JComponent getWestPane()
      protected void iconifyFrame(JInternalFrame f)
      This method is called when the user wants to iconify the frame.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      protected void | installMouseHandlers(JComponent c)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      boolean | isKeyBindingActive()
      protected boolean | isKeyBindingRegistered()
      protected void maximizeFrame(JInternalFrame f)
      This method is called when the user wants to maximize the frame.
      protected void minimizeFrame(JInternalFrame f)
      This method is called when the user wants to minimize the frame.
      protected void replacePane(JComponent currentPane, JComponent newPane)
      Installs necessary mouse handlers on newPane and adds it to the frame.
      void | setEastPane(JComponent c)
      protected void | setKeyBindingActive(boolean b)
      protected void | setKeyBindingRegistered(boolean b)
      void | setNorthPane(JComponent c)
      void | setSouthPane(JComponent c)
      protected void | setupMenuCloseKey()
      protected void | setupMenuOpenKey()
      void | setWestPane(JComponent c)
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • frame

        protected JInternalFrame frame

      • borderListener

        protected MouseInputAdapter borderListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

      • internalFrameLayout

        protected LayoutManager internalFrameLayout

      • componentListener

        protected ComponentListener componentListener

      • glassPaneDispatcher

        protected MouseInputListener glassPaneDispatcher

      • northPane

        protected JComponent northPane

      • southPane

        protected JComponent southPane

      • westPane

        protected JComponent westPane

      • eastPane

        protected JComponent eastPane

      • titlePane

        protected BasicInternalFrameTitlePane titlePane

      • openMenuKey

        @Deprecated
protected KeyStroke openMenuKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

    • 构造方法详细信息

      • BasicInternalFrameUI

        public BasicInternalFrameUI(JInternalFrame b)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • installKeyboardActions

        protected void installKeyboardActions()

      • installComponents

        protected void installComponents()

      • installListeners

        protected void installListeners()
        从以下版本开始：
        1.3

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallComponents

        protected void uninstallComponents()

      • uninstallListeners

        protected void uninstallListeners()
        从以下版本开始：
        1.3

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • createLayoutManager

        protected LayoutManager createLayoutManager()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • getPreferredSize

        public Dimension getPreferredSize(JComponent x)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        x - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent x)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        x - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent x)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        x - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • replacePane

        protected void replacePane(JComponent currentPane,
               JComponent newPane)
        Installs necessary mouse handlers on newPane and adds it to the frame. Reverse process for the currentPane.

      • deinstallMouseHandlers

        protected void deinstallMouseHandlers(JComponent c)

      • installMouseHandlers

        protected void installMouseHandlers(JComponent c)

      • createNorthPane

        protected JComponent createNorthPane(JInternalFrame w)

      • createSouthPane

        protected JComponent createSouthPane(JInternalFrame w)

      • createWestPane

        protected JComponent createWestPane(JInternalFrame w)

      • createEastPane

        protected JComponent createEastPane(JInternalFrame w)

      • createBorderListener

        protected MouseInputAdapter createBorderListener(JInternalFrame w)

      • createInternalFrameListener

        protected void createInternalFrameListener()

      • isKeyBindingRegistered

        protected final boolean isKeyBindingRegistered()

      • setKeyBindingRegistered

        protected final void setKeyBindingRegistered(boolean b)

      • isKeyBindingActive

        public final boolean isKeyBindingActive()

      • setKeyBindingActive

        protected final void setKeyBindingActive(boolean b)

      • setupMenuOpenKey

        protected void setupMenuOpenKey()

      • setupMenuCloseKey

        protected void setupMenuCloseKey()

      • getNorthPane

        public JComponent getNorthPane()

      • setNorthPane

        public void setNorthPane(JComponent c)

      • getSouthPane

        public JComponent getSouthPane()

      • setSouthPane

        public void setSouthPane(JComponent c)

      • getWestPane

        public JComponent getWestPane()

      • setWestPane

        public void setWestPane(JComponent c)

      • getEastPane

        public JComponent getEastPane()

      • setEastPane

        public void setEastPane(JComponent c)

      • getDesktopManager

        protected DesktopManager getDesktopManager()
        Returns the proper DesktopManager. Calls getDesktopPane() to find the JDesktop component and returns the desktopManager from it. If this fails, it will return a default DesktopManager that should work in arbitrary parents.

      • createDesktopManager

        protected DesktopManager createDesktopManager()

      • closeFrame

        protected void closeFrame(JInternalFrame f)
        This method is called when the user wants to close the frame. The playCloseSound Action is fired. This action is delegated to the desktopManager.

      • maximizeFrame

        protected void maximizeFrame(JInternalFrame f)
        This method is called when the user wants to maximize the frame. The playMaximizeSound Action is fired. This action is delegated to the desktopManager.

      • minimizeFrame

        protected void minimizeFrame(JInternalFrame f)
        This method is called when the user wants to minimize the frame. The playRestoreDownSound Action is fired. This action is delegated to the desktopManager.

      • iconifyFrame

        protected void iconifyFrame(JInternalFrame f)
        This method is called when the user wants to iconify the frame. The playMinimizeSound Action is fired. This action is delegated to the desktopManager.

      • deiconifyFrame

        protected void deiconifyFrame(JInternalFrame f)
        This method is called when the user wants to deiconify the frame. The playRestoreUpSound Action is fired. This action is delegated to the desktopManager.

      • activateFrame

        protected void activateFrame(JInternalFrame f)
        This method is called when the frame becomes selected. This action is delegated to the desktopManager.

      • deactivateFrame

        protected void deactivateFrame(JInternalFrame f)
        This method is called when the frame is no longer selected. This action is delegated to the desktopManager.

      • createComponentListener

        protected ComponentListener createComponentListener()

      • createGlassPaneDispatcher

        protected MouseInputListener createGlassPaneDispatcher()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicInternalFrameUI.BasicInternalFrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.BasicInternalFrameListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
  • 所有已实现的接口：
    EventListener, InternalFrameListener
    封闭类：
    BasicInternalFrameUI

    protected class BasicInternalFrameUI.BasicInternalFrameListener
extends Object
implements InternalFrameListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicInternalFrameUI.BasicInternalFrameListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void internalFrameActivated(InternalFrameEvent e)
      Invoked when an internal frame is activated.
      void internalFrameClosed(InternalFrameEvent e)
      Invoked when an internal frame has been closed.
      void internalFrameClosing(InternalFrameEvent e)
      Invoked when an internal frame is in the process of being closed.
      void internalFrameDeactivated(InternalFrameEvent e)
      Invoked when an internal frame is de-activated.
      void internalFrameDeiconified(InternalFrameEvent e)
      Invoked when an internal frame is de-iconified.
      void internalFrameIconified(InternalFrameEvent e)
      Invoked when an internal frame is iconified.
      void internalFrameOpened(InternalFrameEvent e)
      Invoked when a internal frame has been opened.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameUI.BasicInternalFrameListener

        protected BasicInternalFrameUI.BasicInternalFrameListener()

    • 方法详细信息

      • internalFrameClosing

        public void internalFrameClosing(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame is in the process of being closed. The close operation can be overridden at this point.
        指定者：
        internalFrameClosing in interface InternalFrameListener
        另请参见：
        JInternalFrame.setDefaultCloseOperation(int)

      • internalFrameClosed

        public void internalFrameClosed(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame has been closed.
        指定者：
        internalFrameClosed in interface InternalFrameListener
        另请参见：
        JInternalFrame.setClosed(boolean)

      • internalFrameOpened

        public void internalFrameOpened(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when a internal frame has been opened.
        指定者：
        internalFrameOpened in interface InternalFrameListener
        另请参见：
        JInternalFrame.show()

      • internalFrameIconified

        public void internalFrameIconified(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame is iconified.
        指定者：
        internalFrameIconified in interface InternalFrameListener
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameDeiconified

        public void internalFrameDeiconified(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame is de-iconified.
        指定者：
        internalFrameDeiconified in interface InternalFrameListener
        另请参见：
        JInternalFrame.setIcon(boolean)

      • internalFrameActivated

        public void internalFrameActivated(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame is activated.
        指定者：
        internalFrameActivated in interface InternalFrameListener
        另请参见：
        JInternalFrame.setSelected(boolean)

      • internalFrameDeactivated

        public void internalFrameDeactivated(InternalFrameEvent e)
        从接口复制的描述： InternalFrameListener
        Invoked when an internal frame is de-activated.
        指定者：
        internalFrameDeactivated in interface InternalFrameListener
        另请参见：
        JInternalFrame.setSelected(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ib// <;lMal/ohaa<


BasicInternalFrameUI.BorderListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.BorderListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.event.MouseInputAdapter
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener, SwingConstants
    封闭类：
    BasicInternalFrameUI

    protected class BasicInternalFrameUI.BorderListener
extends MouseInputAdapter
implements SwingConstants
    Listens for border adjustments.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | RESIZE_NONE

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicInternalFrameUI.BorderListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • RESIZE_NONE

        protected final int RESIZE_NONE
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BasicInternalFrameUI.BorderListener

        protected BasicInternalFrameUI.BorderListener()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener
        重载：
        mouseClicked in class MouseAdapter

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter

      • mousePressed

        public void mousePressed(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener
        重载：
        mouseEntered in class MouseAdapter

      • mouseExited

        public void mouseExited(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener
        重载：
        mouseExited in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hAold/dtli>cth


BasicInternalFrameUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.ComponentHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
  • 所有已实现的接口：
    ComponentListener, EventListener
    封闭类：
    BasicInternalFrameUI

    protected class BasicInternalFrameUI.ComponentHandler
extends Object
implements ComponentListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicInternalFrameUI.ComponentHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void componentHidden(ComponentEvent e)
      Invoked when the component has been made invisible.
      void componentMoved(ComponentEvent e)
      Invoked when the component's position changes.
      void componentResized(ComponentEvent e)
      Invoked when a JInternalFrame's parent's size changes.
      void componentShown(ComponentEvent e)
      Invoked when the component has been made visible.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameUI.ComponentHandler

        protected BasicInternalFrameUI.ComponentHandler()

    • 方法详细信息

      • componentResized

        public void componentResized(ComponentEvent e)
        Invoked when a JInternalFrame's parent's size changes.
        指定者：
        componentResized in interface ComponentListener

      • componentMoved

        public void componentMoved(ComponentEvent e)
        从接口复制的描述： ComponentListener
        Invoked when the component's position changes.
        指定者：
        componentMoved in interface ComponentListener

      • componentShown

        public void componentShown(ComponentEvent e)
        从接口复制的描述： ComponentListener
        Invoked when the component has been made visible.
        指定者：
        componentShown in interface ComponentListener

      • componentHidden

        public void componentHidden(ComponentEvent e)
        从接口复制的描述： ComponentListener
        Invoked when the component has been made invisible.
        指定者：
        componentHidden in interface ComponentListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otutaaivai nni rleep>ebi as.a/w..veja/..


BasicInternalFrameUI.GlassPaneDispatcher

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.GlassPaneDispatcher

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicInternalFrameUI

    protected class BasicInternalFrameUI.GlassPaneDispatcher
extends Object
implements MouseInputListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicInternalFrameUI.GlassPaneDispatcher()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameUI.GlassPaneDispatcher

        protected BasicInternalFrameUI.GlassPaneDispatcher()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/iSegg/>


BasicInternalFrameUI.InternalFrameLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.InternalFrameLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    BasicInternalFrameUI

    public class BasicInternalFrameUI.InternalFrameLayout
extends Object
implements LayoutManager

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameUI.InternalFrameLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String name, Component c)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      void layoutContainer(Container c)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container c)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container c)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameUI.InternalFrameLayout

        public BasicInternalFrameUI.InternalFrameLayout()

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component c)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        c - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to be removed

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        c - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        c - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutContainer

        public void layoutContainer(Container c)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        c - the container to be laid out
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>c&/ppbp=tsd=>""/gae(s


BasicInternalFrameUI.InternalFramePropertyChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicInternalFrameUI.InternalFramePropertyChangeListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicInternalFrameUI

    public class BasicInternalFrameUI.InternalFramePropertyChangeListener
extends Object
implements PropertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicInternalFrameUI.InternalFramePropertyChangeListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent evt)
      Detects changes in state from the JInternalFrame and handles actions.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicInternalFrameUI.InternalFramePropertyChangeListener

        public BasicInternalFrameUI.InternalFramePropertyChangeListener()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        Detects changes in state from the JInternalFrame and handles actions.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>&


BasicLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicLabelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    直接已知子类：
    MetalLabelUI, SynthLabelUI

    public class BasicLabelUI
extends LabelUI
implements PropertyChangeListener
    A Windows L&F implementation of LabelUI. This implementation is completely static, i.e. there's only one UIView implementation that's shared by all JLabel objects.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static BasicLabelUI labelUI
      The default BasicLabelUI instance.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicLabelUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installComponents(JLabel c)
      protected void | installDefaults(JLabel c)
      protected void | installKeyboardActions(JLabel l)
      protected void | installListeners(JLabel c)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected String layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
      Forwards the call to SwingUtilities.layoutCompoundLabel().
      void paint(Graphics g, JComponent c)
      Paints the label text with the foreground color, if the label is opaque then paints the entire background with the background color.
      protected void paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Paint clippedText at textX, textY with background.lighter() and then shifted down and to the right by one pixel with background.darker().
      protected void paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Paint clippedText at textX, textY with the labels foreground color.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallComponents(JLabel c)
      protected void | uninstallDefaults(JLabel c)
      protected void | uninstallKeyboardActions(JLabel c)
      protected void | uninstallListeners(JLabel c)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • labelUI

        protected static BasicLabelUI labelUI
        The default BasicLabelUI instance. This field might not be used. To change the default instance use a subclass which overrides the createUI method, and place that class name in defaults table under the key "LabelUI".

    • 构造方法详细信息

      • BasicLabelUI

        public BasicLabelUI()

    • 方法详细信息

      • layoutCL

        protected String layoutCL(JLabel label,
              FontMetrics fontMetrics,
              String text,
              Icon icon,
              Rectangle viewR,
              Rectangle iconR,
              Rectangle textR)
        Forwards the call to SwingUtilities.layoutCompoundLabel(). This method is here so that a subclass could do Label specific layout and to shorten the method name a little.
        另请参见：
        SwingUtilities.layoutCompoundLabel(javax.swing.JComponent, java.awt.FontMetrics, java.lang.String, javax.swing.Icon, int, int, int, int, java.awt.Rectangle, java.awt.Rectangle, java.awt.Rectangle, int)

      • paintEnabledText

        protected void paintEnabledText(JLabel l,
                    Graphics g,
                    String s,
                    int textX,
                    int textY)
        Paint clippedText at textX, textY with the labels foreground color.
        另请参见：
        paint(java.awt.Graphics, javax.swing.JComponent), paintDisabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)

      • paintDisabledText

        protected void paintDisabledText(JLabel l,
                     Graphics g,
                     String s,
                     int textX,
                     int textY)
        Paint clippedText at textX, textY with background.lighter() and then shifted down and to the right by one pixel with background.darker().
        另请参见：
        paint(java.awt.Graphics, javax.swing.JComponent), paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the label text with the foreground color, if the label is opaque then paints the entire background with the background color. The Label text is drawn by paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int) or paintDisabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int). The locations of the label parts are computed by layoutCL(javax.swing.JLabel, java.awt.FontMetrics, java.lang.String, javax.swing.Icon, java.awt.Rectangle, java.awt.Rectangle, java.awt.Rectangle).
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int), paintDisabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int), layoutCL(javax.swing.JLabel, java.awt.FontMetrics, java.lang.String, javax.swing.Icon, java.awt.Rectangle, java.awt.Rectangle, java.awt.Rectangle)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        getPreferredSize(c)
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        getPreferredSize(c)
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JLabel c)

      • installListeners

        protected void installListeners(JLabel c)

      • installComponents

        protected void installComponents(JLabel c)

      • installKeyboardActions

        protected void installKeyboardActions(JLabel l)

      • uninstallDefaults

        protected void uninstallDefaults(JLabel c)

      • uninstallListeners

        protected void uninstallListeners(JLabel c)

      • uninstallComponents

        protected void uninstallComponents(JLabel c)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions(JLabel c)

      • createUI

        public static ComponentUI createUI(JComponent c)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
  • 直接已知子类：
    SynthListUI

    public class BasicListUI
extends ListUI
    An extensible implementation of ListUI.

    BasicListUI instances cannot be shared between multiple lists.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicListUI.FocusHandler
      This inner class is marked "public" due to a compiler bug.
      class  BasicListUI.ListDataHandler
      The ListDataListener that's added to the JLists model at installUI time, and whenever the JList.model property changes.
      class  BasicListUI.ListSelectionHandler
      The ListSelectionListener that's added to the JLists selection model at installUI time, and whenever the JList.selectionModel property changes.
      class  BasicListUI.MouseInputHandler
      Mouse input, and focus handling for JList.
      class  BasicListUI.PropertyChangeHandler
      The PropertyChangeListener that's added to the JList at installUI time.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | cellHeight
      protected int[] | cellHeights
      protected static int | cellRendererChanged
      protected int | cellWidth
      protected static int | fixedCellHeightChanged
      protected static int | fixedCellWidthChanged
      protected FocusListener | focusListener
      protected static int | fontChanged
      protected JList | list
      protected ListDataListener | listDataListener
      protected ListSelectionListener | listSelectionListener
      protected static int | modelChanged
      protected MouseInputListener | mouseInputListener
      protected PropertyChangeListener | propertyChangeListener
      protected static int | prototypeCellValueChanged
      protected CellRendererPane | rendererPane
      protected static int | selectionModelChanged
      protected int | updateLayoutStateNeeded

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected int convertRowToY(int row)
      Return the JList relative Y coordinate of the origin of the specified row or -1 if row isn't valid.
      protected int convertYToRow(int y0)
      Convert the JList relative coordinate to the row that contains it, based on the current layout.
      protected FocusListener | createFocusListener()
      protected ListDataListener createListDataListener()
      Creates an instance of ListDataListener that's added to the JLists by model as needed.
      protected ListSelectionListener createListSelectionListener()
      Creates an instance of ListSelectionHandler that's added to the JLists by selectionModel as needed.
      protected MouseInputListener createMouseInputListener()
      Creates a delegate that implements MouseInputListener.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates an instance of PropertyChangeHandler that's added to the JList by installUI().
      static ComponentUI createUI(JComponent list)
      Returns a new instance of BasicListUI.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Rectangle getCellBounds(JList list, int index1, int index2)
      Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.
      Dimension getPreferredSize(JComponent c)
      The preferredSize of the list depends upon the layout orientation.
      protected int getRowHeight(int row)
      Returns the height of the specified row based on the current layout.
      Point indexToLocation(JList list, int index)
      Returns the origin in the given JList, of the specified item, in the list's coordinate system.
      protected void installDefaults()
      Initializes list properties such as font, foreground, and background, and adds the CellRendererPane.
      protected void installKeyboardActions()
      Registers the keyboard bindings on the JList that the BasicListUI is associated with.
      protected void installListeners()
      Creates and installs the listeners for the JList, its model, and its selectionModel.
      void installUI(JComponent c)
      Initializes this.list by calling installDefaults(), installListeners(), and installKeyboardActions() in order.
      int locationToIndex(JList list, Point location)
      Returns the cell index in the specified JList closest to the given location in the list's coordinate system.
      protected void maybeUpdateLayoutState()
      If updateLayoutStateNeeded is non zero, call updateLayoutState() and reset updateLayoutStateNeeded.
      void paint(Graphics g, JComponent c)
      Paint the rows that intersect the Graphics objects clipRect.
      protected void paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
      Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it.
      protected void selectNextIndex()
      Selected the previous row and force it to be visible.
      protected void selectPreviousIndex()
      Selected the previous row and force it to be visible.
      protected void uninstallDefaults()
      Sets the list properties that have not been explicitly overridden to null.
      protected void uninstallKeyboardActions()
      Unregisters keyboard actions installed from installKeyboardActions.
      protected void uninstallListeners()
      Removes the listeners from the JList, its model, and its selectionModel.
      void uninstallUI(JComponent c)
      Uninitializes this.list by calling uninstallListeners(), uninstallKeyboardActions(), and uninstallDefaults() in order.
      protected void updateLayoutState()
      Recompute the value of cellHeight or cellHeights based and cellWidth, based on the current font and the current values of fixedCellWidth, fixedCellHeight, and prototypeCellValue.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • list

        protected JList list

      • rendererPane

        protected CellRendererPane rendererPane

      • focusListener

        protected FocusListener focusListener

      • mouseInputListener

        protected MouseInputListener mouseInputListener

      • listSelectionListener

        protected ListSelectionListener listSelectionListener

      • listDataListener

        protected ListDataListener listDataListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

      • cellHeights

        protected int[] cellHeights

      • cellHeight

        protected int cellHeight

      • cellWidth

        protected int cellWidth

      • updateLayoutStateNeeded

        protected int updateLayoutStateNeeded

      • modelChanged

        protected static final int modelChanged
        另请参见：
        Constant Field Values

      • selectionModelChanged

        protected static final int selectionModelChanged
        另请参见：
        Constant Field Values

      • fontChanged

        protected static final int fontChanged
        另请参见：
        Constant Field Values

      • fixedCellWidthChanged

        protected static final int fixedCellWidthChanged
        另请参见：
        Constant Field Values

      • fixedCellHeightChanged

        protected static final int fixedCellHeightChanged
        另请参见：
        Constant Field Values

      • prototypeCellValueChanged

        protected static final int prototypeCellValueChanged
        另请参见：
        Constant Field Values

      • cellRendererChanged

        protected static final int cellRendererChanged
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • BasicListUI

        public BasicListUI()

    • 方法详细信息

      • paintCell

        protected void paintCell(Graphics g,
             int row,
             Rectangle rowBounds,
             ListCellRenderer cellRenderer,
             ListModel dataModel,
             ListSelectionModel selModel,
             int leadIndex)
        Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it. Subclasses may want to override this method rather than paint().
        另请参见：
        paint(java.awt.Graphics, javax.swing.JComponent)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paint the rows that intersect the Graphics objects clipRect. This method calls paintCell as necessary. Subclasses may want to override these methods.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        paintCell(java.awt.Graphics, int, java.awt.Rectangle, javax.swing.ListCellRenderer, javax.swing.ListModel, javax.swing.ListSelectionModel, int)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        The preferredSize of the list depends upon the layout orientation.
        Layout Orientation | Preferred Size
        JList.VERTICAL | The preferredSize of the list is total height of the rows and the maximum width of the cells. If JList.fixedCellHeight is specified then the total height of the rows is just (cellVerticalMargins + fixedCellHeight) * model.getSize() where rowVerticalMargins is the space we allocate for drawing the yellow focus outline. Similarly if fixedCellWidth is specified then we just use that.
        JList.VERTICAL_WRAP | If the visible row count is greater than zero, the preferredHeight is the maximum cell height * visibleRowCount. If the visible row count is <= 0, the preferred height is either the current height of the list, or the maximum cell height, whichever is bigger. The preferred width is than the maximum cell width * number of columns needed. Where the number of columns needs is list.height / max cell height. Max cell height is either the fixed cell height, or is determined by iterating through all the cells to find the maximum height from the ListCellRenderer.
        JList.HORIZONTAL_WRAP If the visible row count is greater than zero, the preferredHeight is the maximum cell height * adjustedRowCount. Where visibleRowCount is used to determine the number of columns. Because this lays out horizontally the number of rows is then determined from the column count. For example, lets say you have a model with 10 items and the visible row count is 8. The number of columns needed to display this is 2, but you no longer need 8 rows to display this, you only need 5, thus the adjustedRowCount is 5.

        If the visible row count is <= 0, the preferred height is dictated by the number of columns, which will be as many as can fit in the width of the JList (width / max cell width), with at least one column. The preferred height then becomes the model size / number of columns * maximum cell height. Max cell height is either the fixed cell height, or is determined by iterating through all the cells to find the maximum height from the ListCellRenderer.

        The above specifies the raw preferred width and height. The resulting preferred width is the above width + insets.left + insets.right and the resulting preferred height is the above height + insets.top + insets.bottom. Where the Insets are determined from list.getInsets().
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - The JList component.
        返回：
        The total size of the list.
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • selectPreviousIndex

        protected void selectPreviousIndex()
        Selected the previous row and force it to be visible.
        另请参见：
        JList.ensureIndexIsVisible(int)

      • selectNextIndex

        protected void selectNextIndex()
        Selected the previous row and force it to be visible.
        另请参见：
        JList.ensureIndexIsVisible(int)

      • installKeyboardActions

        protected void installKeyboardActions()
        Registers the keyboard bindings on the JList that the BasicListUI is associated with. This method is called at installUI() time.
        另请参见：
        installUI(javax.swing.JComponent)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        Unregisters keyboard actions installed from installKeyboardActions. This method is called at uninstallUI() time - subclassess should ensure that all of the keyboard actions registered at installUI time are removed here.
        另请参见：
        installUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Creates and installs the listeners for the JList, its model, and its selectionModel. This method is called at installUI() time.
        另请参见：
        installUI(javax.swing.JComponent), uninstallListeners()

      • uninstallListeners

        protected void uninstallListeners()
        Removes the listeners from the JList, its model, and its selectionModel. All of the listener fields, are reset to null here. This method is called at uninstallUI() time, it should be kept in sync with installListeners.
        另请参见：
        uninstallUI(javax.swing.JComponent), installListeners()

      • installDefaults

        protected void installDefaults()
        Initializes list properties such as font, foreground, and background, and adds the CellRendererPane. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        另请参见：
        uninstallDefaults(), installUI(javax.swing.JComponent), CellRendererPane

      • uninstallDefaults

        protected void uninstallDefaults()
        Sets the list properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        另请参见：
        installDefaults(), uninstallUI(javax.swing.JComponent), CellRendererPane

      • installUI

        public void installUI(JComponent c)
        Initializes this.list by calling installDefaults(), installListeners(), and installKeyboardActions() in order.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        installDefaults(),
installListeners(),
installKeyboardActions()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Uninitializes this.list by calling uninstallListeners(), uninstallKeyboardActions(), and uninstallDefaults() in order. Sets this.list to null.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        uninstallListeners(),
uninstallKeyboardActions(),
uninstallDefaults()

      • createUI

        public static ComponentUI createUI(JComponent list)
        Returns a new instance of BasicListUI. BasicListUI delegates are allocated one per JList.
        返回：
        A new ListUI implementation for the Windows look and feel.

      • locationToIndex

        public int locationToIndex(JList list,
                  Point location)
        Returns the cell index in the specified JList closest to the given location in the list's coordinate system. To determine if the cell actually contains the specified location, compare the point against the cell's bounds, as provided by getCellBounds. This method returns -1 if the list's model is empty.
        指定者：
        locationToIndex in class ListUI
        参数：
        list - the list
        location - the coordinates of the point
        返回：
        the cell index closest to the given location, or -1
        抛出：
        NullPointerException - if location is null

      • indexToLocation

        public Point indexToLocation(JList list,
                    int index)
        Returns the origin in the given JList, of the specified item, in the list's coordinate system. Returns null if the index isn't valid.
        指定者：
        indexToLocation in class ListUI
        参数：
        list - the list
        index - the cell index
        返回：
        the origin of the cell, or null

      • getCellBounds

        public Rectangle getCellBounds(JList list,
                      int index1,
                      int index2)
        Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices. The indices can be supplied in any order.

        If the smaller index is outside the list's range of cells, this method returns null. If the smaller index is valid, but the larger index is outside the list's range, the bounds of just the first index is returned. Otherwise, the bounds of the valid range is returned.

        指定者：
        getCellBounds in class ListUI
        参数：
        list - the list
        index1 - the first index in the range
        index2 - the second index in the range
        返回：
        the bounding rectangle for the range of cells, or null

      • getRowHeight

        protected int getRowHeight(int row)
        Returns the height of the specified row based on the current layout.
        返回：
        The specified row height or -1 if row isn't valid.
        另请参见：
        convertYToRow(int), convertRowToY(int), updateLayoutState()

      • convertYToRow

        protected int convertYToRow(int y0)
        Convert the JList relative coordinate to the row that contains it, based on the current layout. If y0 doesn't fall within any row, return -1.
        返回：
        The row that contains y0, or -1.
        另请参见：
        getRowHeight(int), updateLayoutState()

      • convertRowToY

        protected int convertRowToY(int row)
        Return the JList relative Y coordinate of the origin of the specified row or -1 if row isn't valid.
        返回：
        The Y coordinate of the origin of row, or -1.
        另请参见：
        getRowHeight(int), updateLayoutState()

      • maybeUpdateLayoutState

        protected void maybeUpdateLayoutState()
        If updateLayoutStateNeeded is non zero, call updateLayoutState() and reset updateLayoutStateNeeded. This method should be called by methods before doing any computation based on the geometry of the list. For example it's the first call in paint() and getPreferredSize().
        另请参见：
        updateLayoutState()

      • updateLayoutState

        protected void updateLayoutState()
        Recompute the value of cellHeight or cellHeights based and cellWidth, based on the current font and the current values of fixedCellWidth, fixedCellHeight, and prototypeCellValue.
        另请参见：
        maybeUpdateLayoutState()

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener()
        Creates a delegate that implements MouseInputListener. The delegate is added to the corresponding java.awt.Component listener lists at installUI() time. Subclasses can override this method to return a custom MouseInputListener, e.g.
         class MyListUI extends BasicListUI {
    protected MouseInputListener createMouseInputListener() {
        return new MyMouseInputHandler();
    }
    public class MyMouseInputHandler extends MouseInputHandler {
        public void mouseMoved(MouseEvent e) {
            // do some extra work when the mouse moves
            super.mouseMoved(e);
        }
    }
 }
        另请参见：
        BasicListUI.MouseInputHandler, installUI(javax.swing.JComponent)

      • createFocusListener

        protected FocusListener createFocusListener()

      • createListSelectionListener

        protected ListSelectionListener createListSelectionListener()
        Creates an instance of ListSelectionHandler that's added to the JLists by selectionModel as needed. Subclasses can override this method to return a custom ListSelectionListener, e.g.
         class MyListUI extends BasicListUI {
    protected ListSelectionListener createListSelectionListener() {
        return new MySelectionListener();
    }
    public class MySelectionListener extends ListSelectionHandler {
        public void valueChanged(ListSelectionEvent e) {
            // do some extra work when the selection changes
            super.valueChange(e);
        }
    }
 }
        另请参见：
        BasicListUI.ListSelectionHandler, installUI(javax.swing.JComponent)

      • createListDataListener

        protected ListDataListener createListDataListener()
        Creates an instance of ListDataListener that's added to the JLists by model as needed. Subclasses can override this method to return a custom ListDataListener, e.g.
         class MyListUI extends BasicListUI {
    protected ListDataListener createListDataListener() {
        return new MyListDataListener();
    }
    public class MyListDataListener extends ListDataHandler {
        public void contentsChanged(ListDataEvent e) {
            // do some extra work when the models contents change
            super.contentsChange(e);
        }
    }
 }
        另请参见：
        ListDataListener, JList.getModel(), installUI(javax.swing.JComponent)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates an instance of PropertyChangeHandler that's added to the JList by installUI(). Subclasses can override this method to return a custom PropertyChangeListener, e.g.
         class MyListUI extends BasicListUI {
    protected PropertyChangeListener createPropertyChangeListener() {
        return new MyPropertyChangeListener();
    }
    public class MyPropertyChangeListener extends PropertyChangeHandler {
        public void propertyChange(PropertyChangeEvent e) {
            if (e.getPropertyName().equals("model")) {
                // do some extra work when the model changes
            }
            super.propertyChange(e);
        }
    }
 }
        另请参见：
        PropertyChangeListener, installUI(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicListUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI.FocusHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicListUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicListUI

    public class BasicListUI.FocusHandler
extends Object
implements FocusListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTableUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.
      protected void | repaintCellFocus()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicListUI.FocusHandler

        public BasicListUI.FocusHandler()

    • 方法详细信息

      • repaintCellFocus

        protected void repaintCellFocus()

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

igc"v.na.ni niiltttwva.>""l e.f. aa p>a,


BasicListUI.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI.ListDataHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler
  • 所有已实现的接口：
    EventListener, ListDataListener
    封闭类：
    BasicListUI

    public class BasicListUI.ListDataHandler
extends Object
implements ListDataListener
    The ListDataListener that's added to the JLists model at installUI time, and whenever the JList.model property changes.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JList.getModel(),
BasicListUI.maybeUpdateLayoutState(),
BasicListUI.createListDataListener(),
BasicListUI.installUI(javax.swing.JComponent)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI.ListDataHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void contentsChanged(ListDataEvent e)
      Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
      void intervalAdded(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been inserted in the data model.
      void intervalRemoved(ListDataEvent e)
      Sent after the indices in the index0,index1 interval have been removed from the data model.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicListUI.ListDataHandler

        public BasicListUI.ListDataHandler()

    • 方法详细信息

      • intervalAdded

        public void intervalAdded(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been inserted in the data model. The new interval includes both index0 and index1.
        指定者：
        intervalAdded in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • intervalRemoved

        public void intervalRemoved(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent after the indices in the index0,index1 interval have been removed from the data model. The interval includes both index0 and index1.
        指定者：
        intervalRemoved in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information

      • contentsChanged

        public void contentsChanged(ListDataEvent e)
        从接口复制的描述： ListDataListener
        Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods. For example, this is sent when an item has been replaced. Index0 and index1 bracket the change.
        指定者：
        contentsChanged in interface ListDataListener
        参数：
        e - a ListDataEvent encapsulating the event information
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>aFa aejaec ecctiee=a"=rllcloe/..."==trset<


BasicListUI.ListSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI.ListSelectionHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
  • 所有已实现的接口：
    EventListener, ListSelectionListener
    封闭类：
    BasicListUI

    public class BasicListUI.ListSelectionHandler
extends Object
implements ListSelectionListener
    The ListSelectionListener that's added to the JLists selection model at installUI time, and whenever the JList.selectionModel property changes. When the selection changes we repaint the affected rows.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BasicListUI.createListSelectionListener(),
BasicListUI.getCellBounds(javax.swing.JList, int, int),
BasicListUI.installUI(javax.swing.JComponent)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI.ListSelectionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(ListSelectionEvent e)
      Called whenever the value of the selection changes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicListUI.ListSelectionHandler

        public BasicListUI.ListSelectionHandler()

    • 方法详细信息

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        从接口复制的描述： ListSelectionListener
        Called whenever the value of the selection changes.
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"< >/r> aeib rbs p lIeena1a td


BasicListUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicListUI

    public class BasicListUI.MouseInputHandler
extends Object
implements MouseInputListener
    Mouse input, and focus handling for JList. An instance of this class is added to the appropriate java.awt.Component lists at installUI() time. Note keyboard input is handled with JComponent KeyboardActions, see installKeyboardActions().

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BasicListUI.createMouseInputListener(),
BasicListUI.installKeyboardActions(),
BasicListUI.installUI(javax.swing.JComponent)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicListUI.MouseInputHandler

        public BasicListUI.MouseInputHandler()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#lir>=e>)e<&)eineeo=f././o.boe- il I.oAny.


BasicListUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicListUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicListUI

    public class BasicListUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    The PropertyChangeListener that's added to the JList at installUI time. When the value of a JList property that affects layout changes, we set a bit in updateLayoutStateNeeded. If the JLists model changes we additionally remove our listeners from the old model. Likewise for the JList selectionModel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    BasicListUI.maybeUpdateLayoutState(),
BasicListUI.createPropertyChangeListener(),
BasicListUI.installUI(javax.swing.JComponent)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicListUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicListUI.PropertyChangeHandler

        public BasicListUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nstv/......//...=(mm klsc "ci=lto"bbbl>lkhs


BasicLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicLookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    MetalLookAndFeel, SynthLookAndFeel

    public abstract class BasicLookAndFeel
extends LookAndFeel
implements Serializable
    A base class to use in creating a look and feel for Swing.

    Each of the ComponentUIs provided by BasicLookAndFeel derives its behavior from the defaults table. Unless otherwise noted each of the ComponentUI implementations in this package document the set of defaults they use. Unless otherwise noted the defaults are installed at the time installUI is invoked, and follow the recommendations outlined in LookAndFeel for installing defaults.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicLookAndFeel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Action createAudioAction(Object key)
      Creates and returns an Action used to play a sound.
      protected ActionMap getAudioActionMap()
      Returns an ActionMap containing the audio actions for this look and feel.
      UIDefaults getDefaults()
      Returns the look and feel defaults.
      protected void initClassDefaults(UIDefaults table)
      Populates table with mappings from uiClassID to the fully qualified name of the ui class.
      protected void initComponentDefaults(UIDefaults table)
      Populates table with the defaults for the basic look and feel.
      void initialize()
      Initializes the look and feel.
      protected void initSystemColorDefaults(UIDefaults table)
      Populates table with system colors.
      protected void loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative)
      Populates table with the name-color pairs in systemColors.
      protected void playSound(Action audioAction)
      If necessary, invokes actionPerformed on audioAction to play a sound.
      void uninitialize()
      Uninitializes the look and feel.

      • 方法 - 继承于类 javax.swing.LookAndFeel

        getDescription, getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getID, getLayoutStyle, getName, getSupportsWindowDecorations, installBorder, installColors, installColorsAndFont, installProperty, isNativeLookAndFeel, isSupportedLookAndFeel, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninstallBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BasicLookAndFeel

        public BasicLookAndFeel()

    • 方法详细信息

      • getDefaults

        public UIDefaults getDefaults()
        Returns the look and feel defaults. The returned UIDefaults is populated by invoking, in order, initClassDefaults, initSystemColorDefaults and initComponentDefaults.

        While this method is public, it should only be invoked by the UIManager when the look and feel is set as the current look and feel and after initialize has been invoked.

        重载：
        getDefaults in class LookAndFeel
        返回：
        the look and feel defaults
        另请参见：
        initClassDefaults(javax.swing.UIDefaults),
initSystemColorDefaults(javax.swing.UIDefaults),
initComponentDefaults(javax.swing.UIDefaults)

      • initialize

        public void initialize()
        Initializes the look and feel. While this method is public, it should only be invoked by the UIManager when a look and feel is installed as the current look and feel. This method is invoked before the UIManager invokes getDefaults. This method is intended to perform any initialization for the look and feel. Subclasses should do any one-time setup they need here, rather than in a static initializer, because look and feel class objects may be loaded just to discover that isSupportedLookAndFeel() returns false.
        重载：
        initialize in class LookAndFeel
        另请参见：
        LookAndFeel.uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • uninitialize

        public void uninitialize()
        Uninitializes the look and feel. While this method is public, it should only be invoked by the UIManager when the look and feel is uninstalled. For example, UIManager.setLookAndFeel invokes this when the look and feel is changed.

        Subclasses may choose to free up some resources here.

        重载：
        uninitialize in class LookAndFeel
        另请参见：
        LookAndFeel.initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • initClassDefaults

        protected void initClassDefaults(UIDefaults table)
        Populates table with mappings from uiClassID to the fully qualified name of the ui class. The value for a particular uiClassID is "javax.swing.plaf.basic.Basic + uiClassID". For example, the value for the uiClassID TreeUI is "javax.swing.plaf.basic.BasicTreeUI".
        参数：
        table - the UIDefaults instance the entries are added to
        抛出：
        NullPointerException - if table is null
        另请参见：
        LookAndFeel, getDefaults()

      • initSystemColorDefaults

        protected void initSystemColorDefaults(UIDefaults table)
        Populates table with system colors. This creates an array of name-color pairs and invokes loadSystemColors.

        The name is a String that corresponds to the name of one of the static SystemColor fields in the SystemColor class. A name-color pair is created for every such SystemColor field.

        The color corresponds to a hex String as understood by Color.decode. For example, one of the name-color pairs is "desktop"-"#005C5C". This corresponds to the SystemColor field desktop, with a color value of new Color(0x005C5C).

        The following shows two of the name-color pairs:

           String[] nameColorPairs = new String[] {
          "desktop", "#005C5C",
    "activeCaption", "#000080" };
   loadSystemColors(table, nameColorPairs, isNativeLookAndFeel());
        As previously stated, this invokes loadSystemColors with the supplied table and name-color pair array. The last argument to loadSystemColors indicates whether the value of the field in SystemColor should be used. This method passes the value of isNativeLookAndFeel() as the last argument to loadSystemColors.
        参数：
        table - the UIDefaults object the values are added to
        抛出：
        NullPointerException - if table is null
        另请参见：
        SystemColor, getDefaults(), loadSystemColors(javax.swing.UIDefaults, java.lang.String[], boolean)

      • loadSystemColors

        protected void loadSystemColors(UIDefaults table,
                    String[] systemColors,
                    boolean useNative)
        Populates table with the name-color pairs in systemColors. Refer to initSystemColorDefaults(UIDefaults) for details on the format of systemColors.

        An entry is added to table for each of the name-color pairs in systemColors. The entry key is the name of the name-color pair.

        The value of the entry corresponds to the color of the name-color pair. The value of the entry is calculated in one of two ways. With either approach the value is always a ColorUIResource.

        If useNative is false, the color is created by using Color.decode to convert the String into a Color. If decode can not convert the String into a Color (NumberFormatException is thrown) then a ColorUIResource of black is used.

        If useNative is true, the color is the value of the field in SystemColor with the same name as the name of the name-color pair. If the field is not valid, a ColorUIResource of black is used.

        参数：
        table - the UIDefaults object the values are added to
        systemColors - array of name-color pairs as described in initSystemColorDefaults(UIDefaults)
        useNative - whether the color is obtained from SystemColor or Color.decode
        抛出：
        NullPointerException - if systemColors is null; or systemColors is not empty, and table is null; or one of the names of the name-color pairs is null; or useNative is false and one of the colors of the name-color pairs is null
        ArrayIndexOutOfBoundsException - if useNative is false and systemColors.length is odd
        另请参见：
        initSystemColorDefaults(javax.swing.UIDefaults), SystemColor, Color.decode(String)

      • initComponentDefaults

        protected void initComponentDefaults(UIDefaults table)
        Populates table with the defaults for the basic look and feel.
        参数：
        table - the UIDefaults to add the values to
        抛出：
        NullPointerException - if table is null

      • getAudioActionMap

        protected ActionMap getAudioActionMap()
        Returns an ActionMap containing the audio actions for this look and feel.

        The returned ActionMap contains Actions that embody the ability to render an auditory cue. These auditory cues map onto user and system activities that may be useful for an end user to know about (such as a dialog box appearing).

        At the appropriate time, the ComponentUI is responsible for obtaining an Action out of the ActionMap and passing it to playSound.

        This method first looks up the ActionMap from the defaults using the key "AuditoryCues.actionMap".

        If the value is non-null, it is returned. If the value of the default "AuditoryCues.actionMap" is null and the value of the default "AuditoryCues.cueList" is non-null, an ActionMapUIResource is created and populated. Population is done by iterating over each of the elements of the "AuditoryCues.cueList" array, and invoking createAudioAction() to create an Action for each element. The resulting Action is placed in the ActionMapUIResource, using the array element as the key. For example, if the "AuditoryCues.cueList" array contains a single-element, "audioKey", the ActionMapUIResource is created, then populated by way of actionMap.put(cueList[0], createAudioAction(cueList[0])).

        If the value of the default "AuditoryCues.actionMap" is null and the value of the default "AuditoryCues.cueList" is null, an empty ActionMapUIResource is created.

        返回：
        an ActionMap containing Actions responsible for playing auditory cues
        抛出：
        ClassCastException - if the value of the default "AuditoryCues.actionMap" is not an ActionMap, or the value of the default "AuditoryCues.cueList" is not an Object[]
        从以下版本开始：
        1.4
        另请参见：
        createAudioAction(java.lang.Object), playSound(Action)

      • createAudioAction

        protected Action createAudioAction(Object key)
        Creates and returns an Action used to play a sound.

        If key is non-null, an Action is created using the value from the defaults with key key. The value identifies the sound resource to load when actionPerformed is invoked on the Action. The sound resource is loaded into a byte[] by way of getClass().getResourceAsStream().

        参数：
        key - the key identifying the audio action
        返回：
        an Action used to play the source, or null if key is null
        从以下版本开始：
        1.4
        另请参见：
        playSound(Action)

      • playSound

        protected void playSound(Action audioAction)
        If necessary, invokes actionPerformed on audioAction to play a sound. The actionPerformed method is invoked if the value of the "AuditoryCues.playList" default is a non-null Object[] containing a String entry equal to the name of the audioAction.
        参数：
        audioAction - an Action that knows how to render the audio associated with the system or user activity that is occurring; a value of null, is ignored
        抛出：
        ClassCastException - if audioAction is non-null and the value of the default "AuditoryCues.playList" is not an Object[]
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
  • 直接已知子类：
    MetalMenuBarUI, SynthMenuBarUI

    public class BasicMenuBarUI
extends MenuBarUI
    A default L&F implementation of MenuBarUI. This implementation is a "combined" view/controller.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeListener | changeListener
      protected ContainerListener | containerListener
      protected JMenuBar | menuBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicMenuBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected ChangeListener | createChangeListener()
      protected ContainerListener | createContainerListener()
      static ComponentUI | createUI(JComponent x)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • menuBar

        protected JMenuBar menuBar

      • containerListener

        protected ContainerListener containerListener

      • changeListener

        protected ChangeListener changeListener

    • 构造方法详细信息

      • BasicMenuBarUI

        public BasicMenuBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • installListeners

        protected void installListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • createContainerListener

        protected ContainerListener createContainerListener()

      • createChangeListener

        protected ChangeListener createChangeListener()

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

to>ie.rd.rceercc>cnn"dld ii"y.ctuCdu>uu


BasicMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
  • 直接已知子类：
    BasicCheckBoxMenuItemUI, BasicMenuUI, BasicRadioButtonMenuItemUI, SynthMenuItemUI

    public class BasicMenuItemUI
extends MenuItemUI
    BasicMenuItem implementation

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected String acceleratorDelimiter
      Accelerator delimiter string, such as '+' in 'Ctrl+C'.
      protected Font | acceleratorFont
      protected Color | acceleratorForeground
      protected Color | acceleratorSelectionForeground
      protected Icon | arrowIcon
      protected Icon | checkIcon
      protected int | defaultTextIconGap
      protected Color | disabledForeground
      protected MenuDragMouseListener | menuDragMouseListener
      protected JMenuItem | menuItem
      protected MenuKeyListener | menuKeyListener
      protected MouseInputListener | mouseInputListener
      protected boolean | oldBorderPainted
      protected PropertyChangeListener propertyChangeListener
      PropertyChangeListener returned from createPropertyChangeListener.
      protected Color | selectionBackground
      protected Color | selectionForeground

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected MenuDragMouseListener | createMenuDragMouseListener(JComponent c)
      protected MenuKeyListener | createMenuKeyListener(JComponent c)
      protected MouseInputListener | createMouseInputListener(JComponent c)
      protected PropertyChangeListener createPropertyChangeListener(JComponent c)
      Creates a PropertyChangeListener which will be added to the menu item.
      static ComponentUI | createUI(JComponent c)
      protected void doClick(MenuSelectionManager msm)
      Call this method when a menu item is to be activated.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      MenuElement[] getPath()
      protected Dimension | getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected String | getPropertyPrefix()
      protected void | installComponents(JMenuItem menuItem)
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void paintBackground(Graphics g, JMenuItem menuItem, Color bgColor)
      Draws the background of the menu item.
      protected void | paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
      protected void paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
      Renders the text of the current menu item.
      protected void | uninstallComponents(JMenuItem menuItem)
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      We draw the background in paintMenuItem() so override update (which fills the background of opaque components by default) to just call paint().

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • menuItem

        protected JMenuItem menuItem

      • selectionBackground

        protected Color selectionBackground

      • selectionForeground

        protected Color selectionForeground

      • disabledForeground

        protected Color disabledForeground

      • acceleratorForeground

        protected Color acceleratorForeground

      • acceleratorSelectionForeground

        protected Color acceleratorSelectionForeground

      • acceleratorDelimiter

        protected String acceleratorDelimiter
        Accelerator delimiter string, such as '+' in 'Ctrl+C'.
        从以下版本开始：
        1.7

      • defaultTextIconGap

        protected int defaultTextIconGap

      • acceleratorFont

        protected Font acceleratorFont

      • mouseInputListener

        protected MouseInputListener mouseInputListener

      • menuDragMouseListener

        protected MenuDragMouseListener menuDragMouseListener

      • menuKeyListener

        protected MenuKeyListener menuKeyListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener
        PropertyChangeListener returned from createPropertyChangeListener. You should not need to access this field, rather if you want to customize the PropertyChangeListener override createPropertyChangeListener.
        从以下版本开始：
        1.6
        另请参见：
        createPropertyChangeListener(javax.swing.JComponent)

      • arrowIcon

        protected Icon arrowIcon

      • checkIcon

        protected Icon checkIcon

      • oldBorderPainted

        protected boolean oldBorderPainted

    • 构造方法详细信息

      • BasicMenuItemUI

        public BasicMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • installComponents

        protected void installComponents(JMenuItem menuItem)
        从以下版本开始：
        1.3

      • getPropertyPrefix

        protected String getPropertyPrefix()

      • installListeners

        protected void installListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallComponents

        protected void uninstallComponents(JMenuItem menuItem)
        从以下版本开始：
        1.3

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener(JComponent c)

      • createMenuDragMouseListener

        protected MenuDragMouseListener createMenuDragMouseListener(JComponent c)

      • createMenuKeyListener

        protected MenuKeyListener createMenuKeyListener(JComponent c)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener(JComponent c)
        Creates a PropertyChangeListener which will be added to the menu item. If this method returns null then it will not be added to the menu item.
        返回：
        an instance of a PropertyChangeListener or null
        从以下版本开始：
        1.6

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getPreferredMenuItemSize

        protected Dimension getPreferredMenuItemSize(JComponent c,
                                 Icon checkIcon,
                                 Icon arrowIcon,
                                 int defaultTextIconGap)

      • update

        public void update(Graphics g,
          JComponent c)
        We draw the background in paintMenuItem() so override update (which fills the background of opaque components by default) to just call paint().
        重载：
        update in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintMenuItem

        protected void paintMenuItem(Graphics g,
                 JComponent c,
                 Icon checkIcon,
                 Icon arrowIcon,
                 Color background,
                 Color foreground,
                 int defaultTextIconGap)

      • paintBackground

        protected void paintBackground(Graphics g,
                   JMenuItem menuItem,
                   Color bgColor)
        Draws the background of the menu item.
        参数：
        g - the paint graphics
        menuItem - menu item to be painted
        bgColor - selection background color
        从以下版本开始：
        1.4

      • paintText

        protected void paintText(Graphics g,
             JMenuItem menuItem,
             Rectangle textRect,
             String text)
        Renders the text of the current menu item.

        参数：
        g - graphics context
        menuItem - menu item to render
        textRect - bounding rectangle for rendering the text
        text - string to render
        从以下版本开始：
        1.4

      • getPath

        public MenuElement[] getPath()

      • doClick

        protected void doClick(MenuSelectionManager msm)
        Call this method when a menu item is to be activated. This method handles some of the details of menu item activation such as clearing the selected path and messaging the JMenuItem's doClick() method.
        参数：
        msm - A MenuSelectionManager. The visual feedback and internal bookkeeping tasks are delegated to this MenuSelectionManager. If null is passed as this argument, the MenuSelectionManager.defaultManager is used.
        从以下版本开始：
        1.4
        另请参见：
        MenuSelectionManager, AbstractButton.doClick(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicMenuItemUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuItemUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicMenuItemUI

    protected class BasicMenuItemUI.MouseInputHandler
extends Object
implements MouseInputListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicMenuItemUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicMenuItemUI.MouseInputHandler

        protected BasicMenuItemUI.MouseInputHandler()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnddi>ipt


BasicMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
  • 直接已知子类：
    SynthMenuUI

    public class BasicMenuUI
extends BasicMenuItemUI
    A default L&F implementation of MenuUI. This implementation is a "combined" view/controller.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicMenuUI.ChangeHandler
      As of Java 2 platform 1.4, this previously undocumented class is now obsolete.
      protected class  BasicMenuUI.MouseInputHandler
      Instantiated and used by a menu item to handle the current menu selection from mouse events.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeListener | changeListener
      protected MenuListener | menuListener

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected ChangeListener | createChangeListener(JComponent c)
      protected MenuDragMouseListener | createMenuDragMouseListener(JComponent c)
      protected MenuKeyListener | createMenuKeyListener(JComponent c)
      protected MenuListener | createMenuListener(JComponent c)
      protected MouseInputListener | createMouseInputListener(JComponent c)
      protected PropertyChangeListener createPropertyChangeListener(JComponent c)
      Creates a PropertyChangeListener which will be added to the menu item.
      static ComponentUI | createUI(JComponent x)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      protected String | getPropertyPrefix()
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      protected void | setupPostTimer(JMenu menu)
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        doClick, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallUI, update

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • changeListener

        protected ChangeListener changeListener

      • menuListener

        protected MenuListener menuListener

    • 构造方法详细信息

      • BasicMenuUI

        public BasicMenuUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicMenuItemUI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicMenuItemUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicMenuItemUI

      • installKeyboardActions

        protected void installKeyboardActions()
        重载：
        installKeyboardActions in class BasicMenuItemUI

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        重载：
        uninstallKeyboardActions in class BasicMenuItemUI

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener(JComponent c)
        重载：
        createMouseInputListener in class BasicMenuItemUI

      • createMenuListener

        protected MenuListener createMenuListener(JComponent c)

      • createChangeListener

        protected ChangeListener createChangeListener(JComponent c)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener(JComponent c)
        Description copied from class: BasicMenuItemUI
        Creates a PropertyChangeListener which will be added to the menu item. If this method returns null then it will not be added to the menu item.
        重载：
        createPropertyChangeListener in class BasicMenuItemUI
        返回：
        an instance of a PropertyChangeListener or null

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicMenuItemUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicMenuItemUI

      • createMenuDragMouseListener

        protected MenuDragMouseListener createMenuDragMouseListener(JComponent c)
        重载：
        createMenuDragMouseListener in class BasicMenuItemUI

      • createMenuKeyListener

        protected MenuKeyListener createMenuKeyListener(JComponent c)
        重载：
        createMenuKeyListener in class BasicMenuItemUI

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class BasicMenuItemUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • setupPostTimer

        protected void setupPostTimer(JMenu menu)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicMenuUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuUI.ChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicMenuUI

    public class BasicMenuUI.ChangeHandler
extends Object
implements ChangeListener
    As of Java 2 platform 1.4, this previously undocumented class is now obsolete. KeyBindings are now managed by the popup menu.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      boolean | isSelected
      JMenu menu
      BasicMenuUI ui
      Component wasFocused

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • menu

        public JMenu menu

      • ui

        public BasicMenuUI ui

      • isSelected

        public boolean isSelected

      • wasFocused

        public Component wasFocused

    • 构造方法详细信息

      • BasicMenuUI.ChangeHandler

        public BasicMenuUI.ChangeHandler(JMenu m,
                         BasicMenuUI ui)

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t=ettea/eav//avv..ee ioceootcoesse msssnvnt.t


BasicMenuUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicMenuUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicMenuUI

    protected class BasicMenuUI.MouseInputHandler
extends Object
implements MouseInputListener
    Instantiated and used by a menu item to handle the current menu selection from mouse events. A MouseInputHandler processes and forwards all mouse events to a shared instance of the MenuSelectionManager.

    This class is protected so that it can be subclassed by other look and feels to implement their own mouse handling behavior. All overridden methods should call the parent methods so that the menu selection is correct.

    从以下版本开始：
    1.4
    另请参见：
    MenuSelectionManager

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicMenuUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on the menu and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the cursor enters the menu.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when the mouse has been clicked on the menu.
      void mouseReleased(MouseEvent e)
      Invoked when the mouse has been released on the menu.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicMenuUI.MouseInputHandler

        protected BasicMenuUI.MouseInputHandler()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        Invoked when the mouse has been clicked on the menu. This method clears or sets the selection path of the MenuSelectionManager.
        指定者：
        mousePressed in interface MouseListener
        参数：
        e - the mouse event

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Invoked when the mouse has been released on the menu. Delegates the mouse event to the MenuSelectionManager.
        指定者：
        mouseReleased in interface MouseListener
        参数：
        e - the mouse event

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        Invoked when the cursor enters the menu. This method sets the selected path for the MenuSelectionManager and handles the case in which a menu item is used to pop up an additional menu, as in a hierarchical menu system.
        指定者：
        mouseEntered in interface MouseListener
        参数：
        e - the mouse event; not used

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Invoked when a mouse button is pressed on the menu and then dragged. Delegates the mouse event to the MenuSelectionManager.
        指定者：
        mouseDragged in interface MouseMotionListener
        参数：
        e - the mouse event
        另请参见：
        MouseMotionListener.mouseDragged(java.awt.event.MouseEvent)

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hyreah)sh)("")((hhlla.bagllals


BasicOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicOptionPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
  • 直接已知子类：
    SynthOptionPaneUI

    public class BasicOptionPaneUI
extends OptionPaneUI
    Provides the basic look and feel for a JOptionPane. BasicMessagePaneUI provides a means to place an icon, message and buttons into a Container. Generally, the layout will look like:

            ------------------
        | i | message    |
        | c | message    |
        | o | message    |
        | n | message    |
        ------------------
        |     buttons    |
        |________________|
    icon is an instance of Icon that is wrapped inside a JLabel. The message is an opaque object and is tested for the following: if the message is a Component it is added to the Container, if it is an Icon it is wrapped inside a JLabel and added to the Container otherwise it is wrapped inside a JLabel.

    The above layout is used when the option pane's ComponentOrientation property is horizontal, left-to-right. The layout will be adjusted appropriately for other orientations.

    The Container, message, icon, and buttons are all determined from abstract methods.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicOptionPaneUI.ButtonActionListener
      This inner class is marked "public" due to a compiler bug.
      static class  BasicOptionPaneUI.ButtonAreaLayout
      ButtonAreaLayout behaves in a similar manner to FlowLayout.
      class  BasicOptionPaneUI.PropertyChangeHandler
      This inner class is marked "public" due to a compiler bug.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean hasCustomComponents
      This is set to true in validateComponent if a Component is contained in either the message or the buttons.
      protected Component initialFocusComponent
      Component to receive focus when messaged with selectInitialValue.
      protected JComponent inputComponent
      JComponent provide for input if optionPane.getWantsInput() returns true.
      static int | MinimumHeight
      protected Dimension | minimumSize
      static int | MinimumWidth
      protected JOptionPane optionPane
      JOptionPane that the receiver is providing the look and feel for.
      protected PropertyChangeListener | propertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicOptionPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void addButtonComponents(Container container, Object[] buttons, int initialIndex)
      Creates the appropriate object to represent each of the objects in buttons and adds it to container.
      protected void addIcon(Container top)
      Creates and adds a JLabel representing the icon returned from getIcon to top.
      protected void addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
      Creates the appropriate object to represent msg and places it into container.
      protected void burstStringInto(Container c, String d, int maxll)
      Recursively creates new JLabel instances to represent d.
      boolean containsCustomComponents(JOptionPane op)
      Returns true if in the last call to validateComponent the message or buttons contained a subclass of Component.
      protected ActionListener | createButtonActionListener(int buttonIndex)
      protected Container createButtonArea()
      Creates and returns a Container containing the buttons.
      protected LayoutManager | createLayoutManager()
      protected Container createMessageArea()
      Messaged from installComponents to create a Container containing the body of the message.
      protected PropertyChangeListener | createPropertyChangeListener()
      protected Container | createSeparator()
      static ComponentUI createUI(JComponent x)
      Creates a new BasicOptionPaneUI instance.
      protected Object[] getButtons()
      Returns the buttons to display from the JOptionPane the receiver is providing the look and feel for.
      protected Icon getIcon()
      Returns the icon from the JOptionPane the receiver is providing the look and feel for, or the default icon as returned from getDefaultIcon.
      protected Icon getIconForType(int messageType)
      Returns the icon to use for the passed in type.
      protected int getInitialValueIndex()
      Returns the initial index into the buttons to select.
      protected int getMaxCharactersPerLineCount()
      Returns the maximum number of characters to place on a line.
      protected Object getMessage()
      Returns the message to display from the JOptionPane the receiver is providing the look and feel for.
      Dimension getMinimumOptionPaneSize()
      Returns the minimum size the option pane should be.
      Dimension getPreferredSize(JComponent c)
      If c is the JOptionPane the receiver is contained in, the preferred size that is returned is the maximum of the preferred size of the LayoutManager for the JOptionPane, and getMinimumOptionPaneSize.
      protected boolean getSizeButtonsToSameWidth()
      Returns true, basic L&F wants all the buttons to have the same width.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Installs the receiver as the L&F for the passed in JOptionPane.
      protected void resetInputValue()
      Sets the input value in the option pane the receiver is providing the look and feel for based on the value in the inputComponent.
      void selectInitialValue(JOptionPane op)
      If inputComponent is non-null, the focus is requested on that, otherwise request focus on the default value
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Removes the receiver from the L&F controller of the passed in split pane.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • MinimumWidth

        public static final int MinimumWidth
        另请参见：
        Constant Field Values

      • MinimumHeight

        public static final int MinimumHeight
        另请参见：
        Constant Field Values

      • optionPane

        protected JOptionPane optionPane
        JOptionPane that the receiver is providing the look and feel for.

      • minimumSize

        protected Dimension minimumSize

      • inputComponent

        protected JComponent inputComponent
        JComponent provide for input if optionPane.getWantsInput() returns true.

      • initialFocusComponent

        protected Component initialFocusComponent
        Component to receive focus when messaged with selectInitialValue.

      • hasCustomComponents

        protected boolean hasCustomComponents
        This is set to true in validateComponent if a Component is contained in either the message or the buttons.

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

    • 构造方法详细信息

      • BasicOptionPaneUI

        public BasicOptionPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new BasicOptionPaneUI instance.

      • installUI

        public void installUI(JComponent c)
        Installs the receiver as the L&F for the passed in JOptionPane.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Removes the receiver from the L&F controller of the passed in split pane.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installComponents

        protected void installComponents()

      • uninstallComponents

        protected void uninstallComponents()

      • createLayoutManager

        protected LayoutManager createLayoutManager()

      • installListeners

        protected void installListeners()

      • uninstallListeners

        protected void uninstallListeners()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • getMinimumOptionPaneSize

        public Dimension getMinimumOptionPaneSize()
        Returns the minimum size the option pane should be. Primarily provided for subclassers wishing to offer a different minimum size.

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        If c is the JOptionPane the receiver is contained in, the preferred size that is returned is the maximum of the preferred size of the LayoutManager for the JOptionPane, and getMinimumOptionPaneSize.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • createMessageArea

        protected Container createMessageArea()
        Messaged from installComponents to create a Container containing the body of the message. The icon is the created by calling addIcon.

      • addMessageComponents

        protected void addMessageComponents(Container container,
                        GridBagConstraints cons,
                        Object msg,
                        int maxll,
                        boolean internallyCreated)
        Creates the appropriate object to represent msg and places it into container. If msg is an instance of Component, it is added directly, if it is an Icon, a JLabel is created to represent it, otherwise a JLabel is created for the string, if d is an Object[], this method will be recursively invoked for the children. internallyCreated is true if Objc is an instance of Component and was created internally by this method (this is used to correctly set hasCustomComponents only if !internallyCreated).

      • getMessage

        protected Object getMessage()
        Returns the message to display from the JOptionPane the receiver is providing the look and feel for.

      • addIcon

        protected void addIcon(Container top)
        Creates and adds a JLabel representing the icon returned from getIcon to top. This is messaged from createMessageArea

      • getIcon

        protected Icon getIcon()
        Returns the icon from the JOptionPane the receiver is providing the look and feel for, or the default icon as returned from getDefaultIcon.

      • getIconForType

        protected Icon getIconForType(int messageType)
        Returns the icon to use for the passed in type.

      • getMaxCharactersPerLineCount

        protected int getMaxCharactersPerLineCount()
        Returns the maximum number of characters to place on a line.

      • burstStringInto

        protected void burstStringInto(Container c,
                   String d,
                   int maxll)
        Recursively creates new JLabel instances to represent d. Each JLabel instance is added to c.

      • createSeparator

        protected Container createSeparator()

      • createButtonArea

        protected Container createButtonArea()
        Creates and returns a Container containing the buttons. The buttons are created by calling getButtons.

      • addButtonComponents

        protected void addButtonComponents(Container container,
                       Object[] buttons,
                       int initialIndex)
        Creates the appropriate object to represent each of the objects in buttons and adds it to container. This differs from addMessageComponents in that it will recurse on buttons and that if button is not a Component it will create an instance of JButton.

      • createButtonActionListener

        protected ActionListener createButtonActionListener(int buttonIndex)

      • getButtons

        protected Object[] getButtons()
        Returns the buttons to display from the JOptionPane the receiver is providing the look and feel for. If the JOptionPane has options set, they will be provided, otherwise if the optionType is YES_NO_OPTION, yesNoOptions is returned, if the type is YES_NO_CANCEL_OPTION yesNoCancelOptions is returned, otherwise defaultButtons are returned.

      • getSizeButtonsToSameWidth

        protected boolean getSizeButtonsToSameWidth()
        Returns true, basic L&F wants all the buttons to have the same width.

      • getInitialValueIndex

        protected int getInitialValueIndex()
        Returns the initial index into the buttons to select. The index is calculated from the initial value from the JOptionPane and options of the JOptionPane or 0.

      • resetInputValue

        protected void resetInputValue()
        Sets the input value in the option pane the receiver is providing the look and feel for based on the value in the inputComponent.

      • selectInitialValue

        public void selectInitialValue(JOptionPane op)
        If inputComponent is non-null, the focus is requested on that, otherwise request focus on the default value
        指定者：
        selectInitialValue in class OptionPaneUI

      • containsCustomComponents

        public boolean containsCustomComponents(JOptionPane op)
        Returns true if in the last call to validateComponent the message or buttons contained a subclass of Component.
        指定者：
        containsCustomComponents in class OptionPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicOptionPaneUI.ButtonActionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicOptionPaneUI.ButtonActionListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicOptionPaneUI

    public class BasicOptionPaneUI.ButtonActionListener
extends Object
implements ActionListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicOptionPaneUI.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | buttonIndex

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicOptionPaneUI.ButtonActionListener(int buttonIndex)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • buttonIndex

        protected int buttonIndex

    • 构造方法详细信息

      • BasicOptionPaneUI.ButtonActionListener

        public BasicOptionPaneUI.ButtonActionListener(int buttonIndex)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nstv nfinfraafrr""ii>ossnnb/


BasicOptionPaneUI.ButtonAreaLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicOptionPaneUI.ButtonAreaLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    BasicOptionPaneUI

    public static class BasicOptionPaneUI.ButtonAreaLayout
extends Object
implements LayoutManager
    ButtonAreaLayout behaves in a similar manner to FlowLayout. It lays out all components from left to right. If syncAllWidths is true, the widths of each component will be set to the largest preferred size width. This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicOptionPaneUI.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean centersChildren
      If true, children are lumped together in parent.
      protected int | padding
      protected boolean | syncAllWidths

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicOptionPaneUI.ButtonAreaLayout(boolean syncAllWidths, int padding)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addLayoutComponent(String string, Component comp)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      boolean | getCentersChildren()
      int | getPadding()
      boolean | getSyncAllWidths()
      void layoutContainer(Container container)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container c)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container c)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.
      void | setCentersChildren(boolean newValue)
      void | setPadding(int newPadding)
      void | setSyncAllWidths(boolean newValue)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • syncAllWidths

        protected boolean syncAllWidths

      • padding

        protected int padding

      • centersChildren

        protected boolean centersChildren
        If true, children are lumped together in parent.

    • 构造方法详细信息

      • BasicOptionPaneUI.ButtonAreaLayout

        public BasicOptionPaneUI.ButtonAreaLayout(boolean syncAllWidths,
                                  int padding)

    • 方法详细信息

      • setSyncAllWidths

        public void setSyncAllWidths(boolean newValue)

      • getSyncAllWidths

        public boolean getSyncAllWidths()

      • setPadding

        public void setPadding(int newPadding)

      • getPadding

        public int getPadding()

      • setCentersChildren

        public void setCentersChildren(boolean newValue)

      • getCentersChildren

        public boolean getCentersChildren()

      • addLayoutComponent

        public void addLayoutComponent(String string,
                      Component comp)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        string - the string to be associated with the component
        comp - the component to be added

      • layoutContainer

        public void layoutContainer(Container container)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        container - the container to be laid out

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        c - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        c - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to be removed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.nnoxg"ov<.dd >;c�>tLlotn"uL/Jt;u<


BasicOptionPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicOptionPaneUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicOptionPaneUI

    public class BasicOptionPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicOptionPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicOptionPaneUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      If the source of the PropertyChangeEvent e equals the optionPane and is one of the ICON_PROPERTY, MESSAGE_PROPERTY, OPTIONS_PROPERTY or INITIAL_VALUE_PROPERTY, validateComponent is invoked.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicOptionPaneUI.PropertyChangeHandler

        public BasicOptionPaneUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        If the source of the PropertyChangeEvent e equals the optionPane and is one of the ICON_PROPERTY, MESSAGE_PROPERTY, OPTIONS_PROPERTY or INITIAL_VALUE_PROPERTY, validateComponent is invoked.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eh>Ls"c="c llc >ottroirghhyttmeCnaaa//nr


BasicPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicPanelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
  • 直接已知子类：
    SynthPanelUI

    public class BasicPanelUI
extends PanelUI
    BasicPanel implementation

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicPanelUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected void | installDefaults(JPanel p)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallDefaults(JPanel p)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicPanelUI

        public BasicPanelUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JPanel p)

      • uninstallDefaults

        protected void uninstallDefaults(JPanel p)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slO lllsens="enoUuBBe"蝊辝=/isi


BasicPasswordFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicPasswordFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
  • 所有已实现的接口：
    ViewFactory

    public class BasicPasswordFieldUI
extends BasicTextFieldUI
    Provides the Windows look and feel for a password field. The only difference from the standard text field is that the view of the text is simply a string of the echo character as specified in JPasswordField, rather than the real text contained in the field.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicPasswordFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View create(Element elem)
      Creates a view (PasswordView) for an element.
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JPasswordField.
      protected String getPropertyPrefix()
      Fetches the name used as a key to look up properties through the UIManager.
      protected void installDefaults()
      Installs the necessary properties on the JPasswordField.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicPasswordFieldUI

        public BasicPasswordFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JPasswordField.
        参数：
        c - the JPasswordField
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to look up properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicTextFieldUI
        返回：
        the name ("PasswordField")

      • installDefaults

        protected void installDefaults()
        Installs the necessary properties on the JPasswordField.
        重载：
        installDefaults in class BasicTextUI
        从以下版本开始：
        1.6
        另请参见：
        BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

      • create

        public View create(Element elem)
        Creates a view (PasswordView) for an element.
        指定者：
        create in interface ViewFactory
        重载：
        create in class BasicTextFieldUI
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oonedeteiemttiocamn膇cjesn.enlt"a_ allc"薿e


BasicPopupMenuSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicPopupMenuSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

  • public class BasicPopupMenuSeparatorUI
extends BasicSeparatorUI
    A Basic L&F implementation of PopupMenuSeparatorUI. This implementation is a "combined" view/controller.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSeparatorUI

        highlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicPopupMenuSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSeparatorUI

        getMaximumSize, getMinimumSize, installDefaults, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicPopupMenuSeparatorUI

        public BasicPopupMenuSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicSeparatorUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicSeparatorUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ottiwxewxettxeeij..gnxEw.tte)"rae>cceaaoj


BasicPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicPopupMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
  • 直接已知子类：
    SynthPopupMenuUI

    public class BasicPopupMenuUI
extends PopupMenuUI
    A Windows L&F implementation of PopupMenuUI. This implementation is a "combined" view/controller.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JPopupMenu | popupMenu

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicPopupMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent x)
      void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      boolean | isPopupTrigger(MouseEvent e)
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.PopupMenuUI

        getPopup

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • popupMenu

        protected JPopupMenu popupMenu

    • 构造方法详细信息

      • BasicPopupMenuUI

        public BasicPopupMenuUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        public void installDefaults()

      • installListeners

        protected void installListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • isPopupTrigger

        public boolean isPopupTrigger(MouseEvent e)
        重载：
        isPopupTrigger in class PopupMenuUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hr Ti - /-->/- yyiLstass蝛e莣p"lbe_peiLcs


BasicProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicProgressBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
  • 直接已知子类：
    MetalProgressBarUI, SynthProgressBarUI

    public class BasicProgressBarUI
extends ProgressBarUI
    A Basic L&F implementation of ProgressBarUI.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicProgressBarUI.ChangeHandler
      This inner class is marked "public" due to a compiler bug.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Rectangle boxRect
      Used to hold the location and size of the bouncing box (returned by getBox) to be painted.
      protected ChangeListener | changeListener
      protected JProgressBar | progressBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicProgressBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent x)
      protected int getAmountFull(Insets b, int width, int height)
      This determines the amount of the progress bar that should be filled based on the percent done gathered from the model.
      protected int getAnimationIndex()
      Gets the index of the current animation frame.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected Rectangle getBox(Rectangle r)
      Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r.
      protected int getBoxLength(int availableLength, int otherDimension)
      Returns the length of the "bouncing box" to be painted.
      protected int getCellLength()
      Returns the width (if HORIZONTAL) or height (if VERTICAL) of each of the indivdual cells/units to be rendered in the progress bar.
      protected int getCellSpacing()
      Returns the spacing between each of the cells/units in the progress bar.
      protected int getFrameCount()
      Returns the number of frames for the complete animation loop used by an indeterminate JProgessBar.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      The Minimum size for this component is 10.
      protected Dimension | getPreferredInnerHorizontal()
      protected Dimension | getPreferredInnerVertical()
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected Color getSelectionBackground()
      The "selectionBackground" is the color of the text when it is painted over an unfilled area of the progress bar.
      protected Color getSelectionForeground()
      The "selectionForeground" is the color of the text when it is painted over a filled area of the progress bar.
      protected Point getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height)
      Designate the place where the progress string will be painted.
      protected void incrementAnimationIndex()
      Sets the index of the current animation frame, to the next valid value, which results in the progress bar being repainted.
      protected void | installDefaults()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Delegates painting to one of two methods: paintDeterminate or paintIndeterminate.
      protected void paintDeterminate(Graphics g, JComponent c)
      All purpose paint method that should do the right thing for almost all linear, determinate progress bars.
      protected void paintIndeterminate(Graphics g, JComponent c)
      All purpose paint method that should do the right thing for all linear bouncing-box progress bars.
      protected void | paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
      protected void setAnimationIndex(int newValue)
      Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted.
      protected void | setCellLength(int cellLen)
      protected void | setCellSpacing(int cellSpace)
      protected void startAnimationTimer()
      Starts the animation thread, creating and initializing it if necessary.
      protected void stopAnimationTimer()
      Stops the animation thread.
      protected void | uninstallDefaults()
      protected void uninstallListeners()
      Removes all listeners installed by this object.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • progressBar

        protected JProgressBar progressBar

      • changeListener

        protected ChangeListener changeListener

      • boxRect

        protected Rectangle boxRect
        Used to hold the location and size of the bouncing box (returned by getBox) to be painted.
        从以下版本开始：
        1.5

    • 构造方法详细信息

      • BasicProgressBarUI

        public BasicProgressBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installListeners

        protected void installListeners()

      • startAnimationTimer

        protected void startAnimationTimer()
        Starts the animation thread, creating and initializing it if necessary. This method is invoked when an indeterminate progress bar should start animating. Reasons for this may include:
        • The progress bar is determinate and becomes displayable
        • The progress bar is displayable and becomes determinate
        • The progress bar is displayable and determinate and this UI is installed
        If you implement your own animation thread, you must override this method.
        从以下版本开始：
        1.4
        另请参见：
        stopAnimationTimer()

      • stopAnimationTimer

        protected void stopAnimationTimer()
        Stops the animation thread. This method is invoked when the indeterminate animation should be stopped. Reasons for this may include:
        • The progress bar changes to determinate
        • The progress bar is no longer part of a displayable hierarchy
        • This UI in uninstalled
        If you implement your own animation thread, you must override this method.
        从以下版本开始：
        1.4
        另请参见：
        startAnimationTimer()

      • uninstallListeners

        protected void uninstallListeners()
        Removes all listeners installed by this object.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getPreferredInnerHorizontal

        protected Dimension getPreferredInnerHorizontal()

      • getPreferredInnerVertical

        protected Dimension getPreferredInnerVertical()

      • getSelectionForeground

        protected Color getSelectionForeground()
        The "selectionForeground" is the color of the text when it is painted over a filled area of the progress bar.

      • getSelectionBackground

        protected Color getSelectionBackground()
        The "selectionBackground" is the color of the text when it is painted over an unfilled area of the progress bar.

      • getCellLength

        protected int getCellLength()
        Returns the width (if HORIZONTAL) or height (if VERTICAL) of each of the indivdual cells/units to be rendered in the progress bar. However, for text rendering simplification and aesthetic considerations, this function will return 1 when the progress string is being rendered.
        返回：
        the value representing the spacing between cells
        另请参见：
        setCellLength(int), JProgressBar.isStringPainted()

      • setCellLength

        protected void setCellLength(int cellLen)

      • getCellSpacing

        protected int getCellSpacing()
        Returns the spacing between each of the cells/units in the progress bar. However, for text rendering simplification and aesthetic considerations, this function will return 0 when the progress string is being rendered.
        返回：
        the value representing the spacing between cells
        另请参见：
        setCellSpacing(int), JProgressBar.isStringPainted()

      • setCellSpacing

        protected void setCellSpacing(int cellSpace)

      • getAmountFull

        protected int getAmountFull(Insets b,
                int width,
                int height)
        This determines the amount of the progress bar that should be filled based on the percent done gathered from the model. This is a common operation so it was abstracted out. It assumes that your progress bar is linear. That is, if you are making a circular progress indicator, you will want to override this method.

      • paint

        public void paint(Graphics g,
         JComponent c)
        Delegates painting to one of two methods: paintDeterminate or paintIndeterminate.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getBox

        protected Rectangle getBox(Rectangle r)
        Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r. Subclasses that add to the painting performed in this class's implementation of paintIndeterminate -- to draw an outline around the bouncing box, for example -- can use this method to get the location of the bouncing box that was just painted. By overriding this method, you have complete control over the size and position of the bouncing box, without having to reimplement paintIndeterminate.
        参数：
        r - the Rectangle instance to be modified; may be null
        返回：
        null if no box should be drawn; otherwise, returns the passed-in rectangle (if non-null) or a new rectangle
        从以下版本开始：
        1.4
        另请参见：
        setAnimationIndex(int)

      • getBoxLength

        protected int getBoxLength(int availableLength,
               int otherDimension)
        Returns the length of the "bouncing box" to be painted. This method is invoked by the default implementation of paintIndeterminate to get the width (if the progress bar is horizontal) or height (if vertical) of the box. For example:
        boxRect.width = getBoxLength(componentInnards.width,
                             componentInnards.height);
        参数：
        availableLength - the amount of space available for the bouncing box to move in; for a horizontal progress bar, for example, this should be the inside width of the progress bar (the component width minus borders)
        otherDimension - for a horizontal progress bar, this should be the inside height of the progress bar; this value might be used to constrain or determine the return value
        返回：
        the size of the box dimension being determined; must be no larger than availableLength
        从以下版本开始：
        1.5
        另请参见：
        SwingUtilities.calculateInnerArea(javax.swing.JComponent, java.awt.Rectangle)

      • paintIndeterminate

        protected void paintIndeterminate(Graphics g,
                      JComponent c)
        All purpose paint method that should do the right thing for all linear bouncing-box progress bars. Override this if you are making another kind of progress bar.
        从以下版本开始：
        1.4
        另请参见：
        paintDeterminate(java.awt.Graphics, javax.swing.JComponent)

      • paintDeterminate

        protected void paintDeterminate(Graphics g,
                    JComponent c)
        All purpose paint method that should do the right thing for almost all linear, determinate progress bars. By setting a few values in the defaults table, things should work just fine to paint your progress bar. Naturally, override this if you are making a circular or semi-circular progress bar.
        从以下版本开始：
        1.4
        另请参见：
        paintIndeterminate(java.awt.Graphics, javax.swing.JComponent)

      • paintString

        protected void paintString(Graphics g,
               int x,
               int y,
               int width,
               int height,
               int amountFull,
               Insets b)

      • getStringPlacement

        protected Point getStringPlacement(Graphics g,
                       String progressString,
                       int x,
                       int y,
                       int width,
                       int height)
        Designate the place where the progress string will be painted. This implementation places it at the center of the progress bar (in both x and y). Override this if you want to right, left, top, or bottom align the progress string or if you need to nudge it around for any reason.

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        The Minimum size for this component is 10. The rationale here is that there should be at least one pixel per 10 percent.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAnimationIndex

        protected int getAnimationIndex()
        Gets the index of the current animation frame.
        从以下版本开始：
        1.4

      • getFrameCount

        protected final int getFrameCount()
        Returns the number of frames for the complete animation loop used by an indeterminate JProgessBar. The progress chunk will go from one end to the other and back during the entire loop. This visual behavior may be changed by subclasses in other Look and Feels.
        返回：
        the number of frames
        从以下版本开始：
        1.6

      • setAnimationIndex

        protected void setAnimationIndex(int newValue)
        Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted. Subclasses that don't use the default painting code might need to override this method to change the way that the repaint method is invoked.
        参数：
        newValue - the new animation index; no checking is performed on its value
        从以下版本开始：
        1.4
        另请参见：
        incrementAnimationIndex()

      • incrementAnimationIndex

        protected void incrementAnimationIndex()
        Sets the index of the current animation frame, to the next valid value, which results in the progress bar being repainted. The next valid value is, by default, the current animation index plus one. If the new value would be too large, this method sets the index to 0. Subclasses might need to override this method to ensure that the index does not go over the number of frames needed for the particular progress bar instance. This method is invoked by the default animation thread every X milliseconds, where X is specified by the "ProgressBar.repaintInterval" UI default.
        从以下版本开始：
        1.4
        另请参见：
        setAnimationIndex(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicProgressBarUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicProgressBarUI.ChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicProgressBarUI

    public class BasicProgressBarUI.ChangeHandler
extends Object
implements ChangeListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicProgressBarUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicProgressBarUI.ChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicProgressBarUI.ChangeHandler

        public BasicProgressBarUI.ChangeHandler()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_ljfrtiiti_nni__tnoooJum)tte/u lc >><"uu/l


BasicRadioButtonMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicRadioButtonMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

  • public class BasicRadioButtonMenuItemUI
extends BasicMenuItemUI
    BasicRadioButtonMenuItem implementation

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicRadioButtonMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      protected String | getPropertyPrefix()
      void | processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicRadioButtonMenuItemUI

        public BasicRadioButtonMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicMenuItemUI

      • processMouseEvent

        public void processMouseEvent(JMenuItem item,
                     MouseEvent e,
                     MenuElement[] path,
                     MenuSelectionManager manager)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


BasicRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicRadioButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
  • 直接已知子类：
    BasicCheckBoxUI, MetalRadioButtonUI

    public class BasicRadioButtonUI
extends BasicToggleButtonUI
    RadioButtonUI implementation for BasicRadioButtonUI

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Icon | icon

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicRadioButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      Icon getDefaultIcon()
      Dimension getPreferredSize(JComponent c)
      The preferred size of the radio button
      protected String | getPropertyPrefix()
      protected void | installDefaults(AbstractButton b)
      void paint(Graphics g, JComponent c)
      paint the radio button
      protected void | paintFocus(Graphics g, Rectangle textRect, Dimension size)
      protected void | uninstallDefaults(AbstractButton b)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToggleButtonUI

        getTextShiftOffset, paintIcon

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • icon

        protected Icon icon

    • 构造方法详细信息

      • BasicRadioButtonUI

        public BasicRadioButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicToggleButtonUI

      • installDefaults

        protected void installDefaults(AbstractButton b)
        重载：
        installDefaults in class BasicButtonUI

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class BasicButtonUI

      • getDefaultIcon

        public Icon getDefaultIcon()

      • paint

        public void paint(Graphics g,
         JComponent c)
        paint the radio button
        重载：
        paint in class BasicToggleButtonUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintFocus

        protected void paintFocus(Graphics g,
              Rectangle textRect,
              Dimension size)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        The preferred size of the radio button
        重载：
        getPreferredSize in class BasicButtonUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eolfa v xfe" =e ft<;am> a=e Neaca�


BasicRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicRootPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    直接已知子类：
    MetalRootPaneUI, SynthRootPaneUI

    public class BasicRootPaneUI
extends RootPaneUI
implements PropertyChangeListener
    Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicRootPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      protected void | installComponents(JRootPane root)
      protected void | installDefaults(JRootPane c)
      protected void | installKeyboardActions(JRootPane root)
      protected void | installListeners(JRootPane root)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void propertyChange(PropertyChangeEvent e)
      Invoked when a property changes on the root pane.
      protected void | uninstallComponents(JRootPane root)
      protected void | uninstallDefaults(JRootPane root)
      protected void | uninstallKeyboardActions(JRootPane root)
      protected void | uninstallListeners(JRootPane root)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicRootPaneUI

        public BasicRootPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JRootPane c)

      • installComponents

        protected void installComponents(JRootPane root)

      • installListeners

        protected void installListeners(JRootPane root)

      • installKeyboardActions

        protected void installKeyboardActions(JRootPane root)

      • uninstallDefaults

        protected void uninstallDefaults(JRootPane root)

      • uninstallComponents

        protected void uninstallComponents(JRootPane root)

      • uninstallListeners

        protected void uninstallListeners(JRootPane root)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions(JRootPane root)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Invoked when a property changes on the root pane. If the event indicates the defaultButton has changed, this will reinstall the keyboard actions.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/>trt t/tar><


BasicScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI
  • 所有已实现的接口：
    LayoutManager, SwingConstants
    直接已知子类：
    MetalScrollBarUI, SynthScrollBarUI

    public class BasicScrollBarUI
extends ScrollBarUI
implements LayoutManager, SwingConstants
    Implementation of ScrollBarUI for the Basic Look and Feel

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  BasicScrollBarUI.ArrowButtonListener
      Listener for cursor keys.
      protected class  BasicScrollBarUI.ModelListener
      A listener to listen for model changes.
      class  | BasicScrollBarUI.PropertyChangeHandler
      protected class  BasicScrollBarUI.ScrollListener
      Listener for scrolling events initiated in the ScrollPane.
      protected class  BasicScrollBarUI.TrackListener
      Track mouse drags.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected BasicScrollBarUI.ArrowButtonListener | buttonListener
      protected JButton | decrButton
      protected static int | DECREASE_HIGHLIGHT
      protected int decrGap
      Distance between the decrement button and the track.
      protected JButton | incrButton
      protected static int | INCREASE_HIGHLIGHT
      protected int incrGap
      Distance between the increment button and the track.
      protected boolean | isDragging
      protected Dimension | maximumThumbSize
      protected Dimension | minimumThumbSize
      protected BasicScrollBarUI.ModelListener | modelListener
      protected static int | NO_HIGHLIGHT
      protected PropertyChangeListener | propertyChangeListener
      protected JScrollBar | scrollbar
      protected int scrollBarWidth
      Hint as to what width (when vertical) or height (when horizontal) should be.
      protected BasicScrollBarUI.ScrollListener | scrollListener
      protected Timer | scrollTimer
      protected Color | thumbColor
      protected Color | thumbDarkShadowColor
      protected Color | thumbHighlightColor
      protected Color | thumbLightShadowColor
      protected Rectangle | thumbRect
      protected Color | trackColor
      protected int | trackHighlight
      protected Color | trackHighlightColor
      protected BasicScrollBarUI.TrackListener | trackListener
      protected Rectangle | trackRect

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addLayoutComponent(String name, Component child)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      protected void | configureScrollBarColors()
      protected BasicScrollBarUI.ArrowButtonListener | createArrowButtonListener()
      protected JButton | createDecreaseButton(int orientation)
      protected JButton | createIncreaseButton(int orientation)
      protected BasicScrollBarUI.ModelListener | createModelListener()
      protected PropertyChangeListener | createPropertyChangeListener()
      protected BasicScrollBarUI.ScrollListener | createScrollListener()
      protected BasicScrollBarUI.TrackListener | createTrackListener()
      static ComponentUI | createUI(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      protected Dimension getMaximumThumbSize()
      Returns the largest acceptable size for the thumb.
      protected Dimension getMinimumThumbSize()
      Returns the smallest acceptable size for the thumb.
      Dimension getPreferredSize(JComponent c)
      A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.
      boolean getSupportsAbsolutePositioning()
      Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).
      protected Rectangle getThumbBounds()
      Return the current size/location of the thumb.
      protected Rectangle getTrackBounds()
      Returns the current bounds of the track, i.e.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      boolean isThumbRollover()
      Returns true if the mouse is currently over the thumb.
      void layoutContainer(Container scrollbarContainer)
      Lays out the specified container.
      protected void | layoutHScrollbar(JScrollBar sb)
      protected void | layoutVScrollbar(JScrollBar sb)
      Dimension minimumLayoutSize(Container scrollbarContainer)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | paintDecreaseHighlight(Graphics g)
      protected void | paintIncreaseHighlight(Graphics g)
      protected void | paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
      protected void | paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
      Dimension preferredLayoutSize(Container scrollbarContainer)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component child)
      Removes the specified component from the layout.
      protected void | scrollByBlock(int direction)
      protected void | scrollByUnit(int direction)
      protected void setThumbBounds(int x, int y, int width, int height)
      Set the bounds of the thumb and force a repaint that includes the old thumbBounds and the new one.
      protected void setThumbRollover(boolean active)
      Sets whether or not the mouse is currently over the thumb.
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMinimumSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • minimumThumbSize

        protected Dimension minimumThumbSize

      • maximumThumbSize

        protected Dimension maximumThumbSize

      • thumbHighlightColor

        protected Color thumbHighlightColor

      • thumbLightShadowColor

        protected Color thumbLightShadowColor

      • thumbDarkShadowColor

        protected Color thumbDarkShadowColor

      • thumbColor

        protected Color thumbColor

      • trackColor

        protected Color trackColor

      • trackHighlightColor

        protected Color trackHighlightColor

      • scrollbar

        protected JScrollBar scrollbar

      • incrButton

        protected JButton incrButton

      • decrButton

        protected JButton decrButton

      • isDragging

        protected boolean isDragging

      • trackListener

        protected BasicScrollBarUI.TrackListener trackListener

      • buttonListener

        protected BasicScrollBarUI.ArrowButtonListener buttonListener

      • modelListener

        protected BasicScrollBarUI.ModelListener modelListener

      • thumbRect

        protected Rectangle thumbRect

      • trackRect

        protected Rectangle trackRect

      • trackHighlight

        protected int trackHighlight

      • NO_HIGHLIGHT

        protected static final int NO_HIGHLIGHT
        另请参见：
        Constant Field Values

      • DECREASE_HIGHLIGHT

        protected static final int DECREASE_HIGHLIGHT
        另请参见：
        Constant Field Values

      • INCREASE_HIGHLIGHT

        protected static final int INCREASE_HIGHLIGHT
        另请参见：
        Constant Field Values

      • scrollListener

        protected BasicScrollBarUI.ScrollListener scrollListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

      • scrollTimer

        protected Timer scrollTimer

      • scrollBarWidth

        protected int scrollBarWidth
        Hint as to what width (when vertical) or height (when horizontal) should be.
        从以下版本开始：
        1.7

      • incrGap

        protected int incrGap
        Distance between the increment button and the track. This may be a negative number. If negative, then an overlap between the button and track will occur, which is useful for shaped buttons.
        从以下版本开始：
        1.7

      • decrGap

        protected int decrGap
        Distance between the decrement button and the track. This may be a negative number. If negative, then an overlap between the button and track will occur, which is useful for shaped buttons.
        从以下版本开始：
        1.7

    • 构造方法详细信息

      • BasicScrollBarUI

        public BasicScrollBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • configureScrollBarColors

        protected void configureScrollBarColors()

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • installComponents

        protected void installComponents()

      • uninstallComponents

        protected void uninstallComponents()

      • installListeners

        protected void installListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallDefaults

        protected void uninstallDefaults()

      • createTrackListener

        protected BasicScrollBarUI.TrackListener createTrackListener()

      • createArrowButtonListener

        protected BasicScrollBarUI.ArrowButtonListener createArrowButtonListener()

      • createModelListener

        protected BasicScrollBarUI.ModelListener createModelListener()

      • createScrollListener

        protected BasicScrollBarUI.ScrollListener createScrollListener()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • setThumbRollover

        protected void setThumbRollover(boolean active)
        Sets whether or not the mouse is currently over the thumb.
        参数：
        active - True indicates the thumb is currently active.
        从以下版本开始：
        1.5

      • isThumbRollover

        public boolean isThumbRollover()
        Returns true if the mouse is currently over the thumb.
        返回：
        true if the thumb is currently active
        从以下版本开始：
        1.5

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb. The preferred height is the sum of the preferred heights of the same parts. The basis for the preferred size of a horizontal scrollbar is similar.

        The preferredSize is only computed once, subsequent calls to this method just return a cached size.

        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the JScrollBar that's delegating this method to us
        返回：
        the preferred size of a Basic JScrollBar
        另请参见：
        getMaximumSize(javax.swing.JComponent), ComponentUI.getMinimumSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - The JScrollBar that's delegating this method to us.
        返回：
        new Dimension(Integer.MAX_VALUE, Integer.MAX_VALUE);
        另请参见：
        ComponentUI.getMinimumSize(javax.swing.JComponent), getPreferredSize(javax.swing.JComponent)

      • createDecreaseButton

        protected JButton createDecreaseButton(int orientation)

      • createIncreaseButton

        protected JButton createIncreaseButton(int orientation)

      • paintDecreaseHighlight

        protected void paintDecreaseHighlight(Graphics g)

      • paintIncreaseHighlight

        protected void paintIncreaseHighlight(Graphics g)

      • paintTrack

        protected void paintTrack(Graphics g,
              JComponent c,
              Rectangle trackBounds)

      • paintThumb

        protected void paintThumb(Graphics g,
              JComponent c,
              Rectangle thumbBounds)

      • getMinimumThumbSize

        protected Dimension getMinimumThumbSize()
        Returns the smallest acceptable size for the thumb. If the scrollbar becomes so small that this size isn't available, the thumb will be hidden.

        Warning : the value returned by this method should not be be modified, it's a shared static constant.

        返回：
        The smallest acceptable size for the thumb.
        另请参见：
        getMaximumThumbSize()

      • getMaximumThumbSize

        protected Dimension getMaximumThumbSize()
        Returns the largest acceptable size for the thumb. To create a fixed size thumb one make this method and getMinimumThumbSize return the same value.

        Warning : the value returned by this method should not be be modified, it's a shared static constant.

        返回：
        The largest acceptable size for the thumb.
        另请参见：
        getMinimumThumbSize()

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component child)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        child - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component child)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        child - the component to be removed

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container scrollbarContainer)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        scrollbarContainer - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container scrollbarContainer)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        scrollbarContainer - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • layoutVScrollbar

        protected void layoutVScrollbar(JScrollBar sb)

      • layoutHScrollbar

        protected void layoutHScrollbar(JScrollBar sb)

      • layoutContainer

        public void layoutContainer(Container scrollbarContainer)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        scrollbarContainer - the container to be laid out

      • setThumbBounds

        protected void setThumbBounds(int x,
                  int y,
                  int width,
                  int height)
        Set the bounds of the thumb and force a repaint that includes the old thumbBounds and the new one.
        另请参见：
        getThumbBounds()

      • getThumbBounds

        protected Rectangle getThumbBounds()
        Return the current size/location of the thumb.

        Warning : the value returned by this method should not be be modified, it's a reference to the actual rectangle, not a copy.

        返回：
        The current size/location of the thumb.
        另请参见：
        setThumbBounds(int, int, int, int)

      • getTrackBounds

        protected Rectangle getTrackBounds()
        Returns the current bounds of the track, i.e. the space in between the increment and decrement buttons, less the insets. The value returned by this method is updated each time the scrollbar is laid out (validated).

        Warning : the value returned by this method should not be be modified, it's a reference to the actual rectangle, not a copy.

        返回：
        the current bounds of the scrollbar track
        另请参见：
        layoutContainer(java.awt.Container)

      • scrollByBlock

        protected void scrollByBlock(int direction)

      • scrollByUnit

        protected void scrollByUnit(int direction)

      • getSupportsAbsolutePositioning

        public boolean getSupportsAbsolutePositioning()
        Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).
        返回：
        true if a mouse gesture can absolutely position the thumb
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicScrollBarUI.ArrowButtonListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI.ArrowButtonListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicScrollBarUI

    protected class BasicScrollBarUI.ArrowButtonListener
extends MouseAdapter
    Listener for cursor keys.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicScrollBarUI.ArrowButtonListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollBarUI.ArrowButtonListener

        protected BasicScrollBarUI.ArrowButtonListener()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xn.ali.#i.Ihh.IInavv


BasicScrollBarUI.ModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI.ModelListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicScrollBarUI

    protected class BasicScrollBarUI.ModelListener
extends Object
implements ChangeListener
    A listener to listen for model changes.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicScrollBarUI.ModelListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollBarUI.ModelListener

        protected BasicScrollBarUI.ModelListener()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irn..../.."...""hrttctFccssicat"c


BasicScrollBarUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicScrollBarUI

    public class BasicScrollBarUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollBarUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollBarUI.PropertyChangeHandler

        public BasicScrollBarUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aA>IpSiel>E.tH._ nlv><.� tdslcr"


BasicScrollBarUI.ScrollListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI.ScrollListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicScrollBarUI

    protected class BasicScrollBarUI.ScrollListener
extends Object
implements ActionListener
    Listener for scrolling events initiated in the ScrollPane.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollBarUI.ScrollListener()
      BasicScrollBarUI.ScrollListener(int dir, boolean block)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      void | setDirection(int direction)
      void | setScrollByBlock(boolean block)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollBarUI.ScrollListener

        public BasicScrollBarUI.ScrollListener()

      • BasicScrollBarUI.ScrollListener

        public BasicScrollBarUI.ScrollListener(int dir,
                               boolean block)

    • 方法详细信息

      • setDirection

        public void setDirection(int direction)

      • setScrollByBlock

        public void setScrollByBlock(boolean block)

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r< iena;>snos_>


BasicScrollBarUI.TrackListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollBarUI.TrackListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicScrollBarUI

    protected class BasicScrollBarUI.TrackListener
extends MouseAdapter
implements MouseMotionListener
    Track mouse drags.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | currentMouseX
      protected int | currentMouseY
      protected int | offset

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicScrollBarUI.TrackListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseDragged(MouseEvent e)
      Set the models value to the position of the thumb's top of Vertical scrollbar, or the left/right of Horizontal scrollbar in left-to-right/right-to-left scrollbar relative to the origin of the track.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits the scrollbar.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseEntered, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • offset

        protected transient int offset

      • currentMouseX

        protected transient int currentMouseX

      • currentMouseY

        protected transient int currentMouseY

    • 构造方法详细信息

      • BasicScrollBarUI.TrackListener

        protected BasicScrollBarUI.TrackListener()

    • 方法详细信息

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter

      • mousePressed

        public void mousePressed(MouseEvent e)
        If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page. If there is no thumb then page up if the mouse is in the upper half of the track.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Set the models value to the position of the thumb's top of Vertical scrollbar, or the left/right of Horizontal scrollbar in left-to-right/right-to-left scrollbar relative to the origin of the track.
        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter

      • mouseExited

        public void mouseExited(MouseEvent e)
        Invoked when the mouse exits the scrollbar.
        指定者：
        mouseExited in interface MouseListener
        重载：
        mouseExited in class MouseAdapter
        参数：
        e - MouseEvent further describing the event
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tn.m.//paa. u - o"祎/Eopaoog>LVts


BasicScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI
  • 所有已实现的接口：
    ScrollPaneConstants
    直接已知子类：
    MetalScrollPaneUI, SynthScrollPaneUI

    public class BasicScrollPaneUI
extends ScrollPaneUI
implements ScrollPaneConstants
    A default L&F implementation of ScrollPaneUI.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      class  BasicScrollPaneUI.HSBChangeListener
      Horizontal scrollbar listener.
      protected class  BasicScrollPaneUI.MouseWheelHandler
      MouseWheelHandler is an inner class which implements the MouseWheelListener interface.
      class  | BasicScrollPaneUI.PropertyChangeHandler
      class  BasicScrollPaneUI.ViewportChangeHandler
      Listener for viewport events.
      class  BasicScrollPaneUI.VSBChangeListener
      Vertical scrollbar listener.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeListener | hsbChangeListener
      protected JScrollPane | scrollpane
      protected PropertyChangeListener | spPropertyChangeListener
      protected ChangeListener | viewportChangeListener
      protected ChangeListener | vsbChangeListener

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected ChangeListener | createHSBChangeListener()
      protected MouseWheelListener createMouseWheelListener()
      Creates an instance of MouseWheelListener, which is added to the JScrollPane by installUI().
      protected PropertyChangeListener createPropertyChangeListener()
      Creates an instance of PropertyChangeListener that's added to the JScrollPane by installUI().
      static ComponentUI | createUI(JComponent x)
      protected ChangeListener | createViewportChangeListener()
      protected ChangeListener | createVSBChangeListener()
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      protected void | installDefaults(JScrollPane scrollpane)
      protected void | installKeyboardActions(JScrollPane c)
      protected void | installListeners(JScrollPane c)
      void installUI(JComponent x)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | syncScrollPaneWithViewport()
      protected void | uninstallDefaults(JScrollPane c)
      protected void | uninstallKeyboardActions(JScrollPane c)
      protected void | uninstallListeners(JComponent c)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      protected void | updateColumnHeader(PropertyChangeEvent e)
      protected void | updateRowHeader(PropertyChangeEvent e)
      protected void | updateScrollBarDisplayPolicy(PropertyChangeEvent e)
      protected void | updateViewport(PropertyChangeEvent e)

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMinimumSize, getPreferredSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • scrollpane

        protected JScrollPane scrollpane

      • vsbChangeListener

        protected ChangeListener vsbChangeListener

      • hsbChangeListener

        protected ChangeListener hsbChangeListener

      • viewportChangeListener

        protected ChangeListener viewportChangeListener

      • spPropertyChangeListener

        protected PropertyChangeListener spPropertyChangeListener

    • 构造方法详细信息

      • BasicScrollPaneUI

        public BasicScrollPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        new Dimension(Short.MAX_VALUE, Short.MAX_VALUE)
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • installDefaults

        protected void installDefaults(JScrollPane scrollpane)

      • installListeners

        protected void installListeners(JScrollPane c)

      • installKeyboardActions

        protected void installKeyboardActions(JScrollPane c)

      • installUI

        public void installUI(JComponent x)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        x - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults(JScrollPane c)

      • uninstallListeners

        protected void uninstallListeners(JComponent c)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions(JScrollPane c)

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • syncScrollPaneWithViewport

        protected void syncScrollPaneWithViewport()

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • createViewportChangeListener

        protected ChangeListener createViewportChangeListener()

      • createHSBChangeListener

        protected ChangeListener createHSBChangeListener()

      • createVSBChangeListener

        protected ChangeListener createVSBChangeListener()

      • createMouseWheelListener

        protected MouseWheelListener createMouseWheelListener()
        Creates an instance of MouseWheelListener, which is added to the JScrollPane by installUI(). The returned MouseWheelListener is used to handle mouse wheel-driven scrolling.
        返回：
        MouseWheelListener which implements wheel-driven scrolling
        从以下版本开始：
        1.4
        另请参见：
        installUI(javax.swing.JComponent), BasicScrollPaneUI.MouseWheelHandler

      • updateScrollBarDisplayPolicy

        protected void updateScrollBarDisplayPolicy(PropertyChangeEvent e)

      • updateViewport

        protected void updateViewport(PropertyChangeEvent e)

      • updateRowHeader

        protected void updateRowHeader(PropertyChangeEvent e)

      • updateColumnHeader

        protected void updateColumnHeader(PropertyChangeEvent e)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates an instance of PropertyChangeListener that's added to the JScrollPane by installUI(). Subclasses can override this method to return a custom PropertyChangeListener, e.g.
         class MyScrollPaneUI extends BasicScrollPaneUI {
    protected PropertyChangeListener createPropertyChangeListener() {
        return new MyPropertyChangeListener();
    }
    public class MyPropertyChangeListener extends PropertyChangeListener {
        public void propertyChange(PropertyChangeEvent e) {
            if (e.getPropertyName().equals("viewport")) {
                // do some extra work when the viewport changes
            }
            super.propertyChange(e);
        }
    }
 }
        另请参见：
        PropertyChangeListener, installUI(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicScrollPaneUI.HSBChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI.HSBChangeListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicScrollPaneUI

    public class BasicScrollPaneUI.HSBChangeListener
extends Object
implements ChangeListener
    Horizontal scrollbar listener.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollPaneUI.HSBChangeListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollPaneUI.HSBChangeListener

        public BasicScrollPaneUI.HSBChangeListener()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"c " L> LkiiLkk"ldd),/niaa< >><>/> s


BasicScrollPaneUI.MouseWheelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI.MouseWheelHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
  • 所有已实现的接口：
    MouseWheelListener, EventListener
    封闭类：
    BasicScrollPaneUI

    protected class BasicScrollPaneUI.MouseWheelHandler
extends Object
implements MouseWheelListener
    MouseWheelHandler is an inner class which implements the MouseWheelListener interface. MouseWheelHandler responds to MouseWheelEvents by scrolling the JScrollPane appropriately. If the scroll pane's isWheelScrollingEnabled method returns false, no scrolling occurs.
    从以下版本开始：
    1.4
    另请参见：
    JScrollPane.isWheelScrollingEnabled(), BasicScrollPaneUI.createMouseWheelListener(), MouseWheelListener, MouseWheelEvent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicScrollPaneUI.MouseWheelHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseWheelMoved(MouseWheelEvent e)
      Called when the mouse wheel is rotated while over a JScrollPane.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollPaneUI.MouseWheelHandler

        protected BasicScrollPaneUI.MouseWheelHandler()

    • 方法详细信息

      • mouseWheelMoved

        public void mouseWheelMoved(MouseWheelEvent e)
        Called when the mouse wheel is rotated while over a JScrollPane.
        指定者：
        mouseWheelMoved in interface MouseWheelListener
        参数：
        e - MouseWheelEvent to be handled
        从以下版本开始：
        1.4
        另请参见：
        MouseWheelEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>LVBSRCCRCIAACII#nll"D_"CRRSR/..,DABBRL


BasicScrollPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicScrollPaneUI

    public class BasicScrollPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollPaneUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollPaneUI.PropertyChangeHandler

        public BasicScrollPaneUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tl/>hhf>n nssrrtmoaccsunf#r<


BasicScrollPaneUI.ViewportChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI.ViewportChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicScrollPaneUI

    public class BasicScrollPaneUI.ViewportChangeHandler
extends Object
implements ChangeListener
    Listener for viewport events.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollPaneUI.ViewportChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollPaneUI.ViewportChangeHandler

        public BasicScrollPaneUI.ViewportChangeHandler()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>p3pTpApbpsab13/o/8/re/1><<>a>/ c


BasicScrollPaneUI.VSBChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicScrollPaneUI.VSBChangeListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicScrollPaneUI

    public class BasicScrollPaneUI.VSBChangeListener
extends Object
implements ChangeListener
    Vertical scrollbar listener.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicScrollPaneUI.VSBChangeListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicScrollPaneUI.VSBChangeListener

        public BasicScrollPaneUI.VSBChangeListener()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d<鋍,c1c癱ae及篇岜鋖籰卑。Ｓ粲Ｐ 利t f</


BasicSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
  • 直接已知子类：
    BasicPopupMenuSeparatorUI, BasicToolBarSeparatorUI, MetalSeparatorUI

    public class BasicSeparatorUI
extends SeparatorUI
    A Basic L&F implementation of SeparatorUI. This implementation is a "combined" view/controller.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | highlight
      protected Color | shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JSeparator s)
      protected void | installListeners(JSeparator s)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | uninstallDefaults(JSeparator s)
      protected void | uninstallListeners(JSeparator s)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • shadow

        protected Color shadow

      • highlight

        protected Color highlight

    • 构造方法详细信息

      • BasicSeparatorUI

        public BasicSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JSeparator s)

      • uninstallDefaults

        protected void uninstallDefaults(JSeparator s)

      • installListeners

        protected void installListeners(JSeparator s)

      • uninstallListeners

        protected void uninstallListeners(JSeparator s)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
  • 直接已知子类：
    MetalSliderUI, SynthSliderUI

    public class BasicSliderUI
extends SliderUI
    A Basic L&F implementation of SliderUI.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      class  BasicSliderUI.ActionScroller
      As of Java 2 platform v1.3 this undocumented class is no longer used.
      class  BasicSliderUI.ChangeHandler
      Data model listener.
      class  BasicSliderUI.ComponentHandler
      Listener for resizing events.
      class  BasicSliderUI.FocusHandler
      Focus-change listener.
      class  | BasicSliderUI.PropertyChangeHandler
      class  BasicSliderUI.ScrollListener
      Scroll-event listener.
      class  BasicSliderUI.TrackListener
      Track mouse movements.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected ChangeListener | changeListener
      protected ComponentListener | componentListener
      protected Rectangle | contentRect
      protected Insets | focusInsets
      protected FocusListener | focusListener
      protected Rectangle | focusRect
      protected Insets | insetCache
      protected Rectangle | labelRect
      protected boolean | leftToRightCache
      static int | MAX_SCROLL
      static int | MIN_SCROLL
      static int | NEGATIVE_SCROLL
      static int | POSITIVE_SCROLL
      protected PropertyChangeListener | propertyChangeListener
      protected BasicSliderUI.ScrollListener | scrollListener
      protected Timer | scrollTimer
      protected JSlider | slider
      protected Rectangle | thumbRect
      protected Rectangle | tickRect
      protected int | trackBuffer
      protected BasicSliderUI.TrackListener | trackListener
      protected Rectangle | trackRect

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI(JSlider b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | calculateContentRect()
      protected void | calculateFocusRect()
      protected void | calculateGeometry()
      protected void | calculateLabelRect()
      protected void | calculateThumbLocation()
      protected void | calculateThumbSize()
      protected void | calculateTickRect()
      protected void | calculateTrackBuffer()
      protected void | calculateTrackRect()
      protected ChangeListener | createChangeListener(JSlider slider)
      protected ComponentListener | createComponentListener(JSlider slider)
      protected FocusListener | createFocusListener(JSlider slider)
      protected PropertyChangeListener | createPropertyChangeListener(JSlider slider)
      protected BasicSliderUI.ScrollListener | createScrollListener(JSlider slider)
      protected BasicSliderUI.TrackListener | createTrackListener(JSlider slider)
      static ComponentUI | createUI(JComponent b)
      protected boolean | drawInverted()
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected Color | getFocusColor()
      protected int | getHeightOfHighValueLabel()
      protected int | getHeightOfLowValueLabel()
      protected int | getHeightOfTallestLabel()
      protected Integer getHighestValue()
      Returns the biggest value that has an entry in the label table.
      protected Component getHighestValueLabel()
      Returns the label that corresponds to the lowest slider value in the label table.
      protected Color | getHighlightColor()
      protected Integer getLowestValue()
      Returns the smallest value that has an entry in the label table.
      protected Component getLowestValueLabel()
      Returns the label that corresponds to the highest slider value in the label table.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumHorizontalSize()
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getMinimumVerticalSize()
      Dimension getPreferredHorizontalSize()
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      Dimension getPreferredVerticalSize()
      protected Color | getShadowColor()
      protected Dimension | getThumbSize()
      protected int getTickLength()
      Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.
      protected int | getWidthOfHighValueLabel()
      protected int | getWidthOfLowValueLabel()
      protected int | getWidthOfWidestLabel()
      protected void | installDefaults(JSlider slider)
      protected void | installKeyboardActions(JSlider slider)
      protected void | installListeners(JSlider slider)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected boolean isDragging()
      Returns true if the user is dragging the slider.
      protected boolean labelsHaveSameBaselines()
      Returns true if all the labels from the label table have the same baseline.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void | paintFocus(Graphics g)
      protected void paintHorizontalLabel(Graphics g, int value, Component label)
      Called for every label in the label table.
      void | paintLabels(Graphics g)
      protected void | paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
      protected void | paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
      protected void | paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
      protected void | paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
      void | paintThumb(Graphics g)
      void | paintTicks(Graphics g)
      void | paintTrack(Graphics g)
      protected void paintVerticalLabel(Graphics g, int value, Component label)
      Called for every label in the label table.
      protected void | recalculateIfInsetsChanged()
      protected void | recalculateIfOrientationChanged()
      void | scrollByBlock(int direction)
      void | scrollByUnit(int direction)
      protected void scrollDueToClickInTrack(int dir)
      This function is called when a mousePressed was detected in the track, not in the thumb.
      void | setThumbLocation(int x, int y)
      protected void | uninstallDefaults(JSlider slider)
      protected void | uninstallKeyboardActions(JSlider slider)
      protected void | uninstallListeners(JSlider slider)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      int valueForXPosition(int xPos)
      Returns the value at the x position.
      int valueForYPosition(int yPos)
      Returns the value at the y position.
      protected int | xPositionForValue(int value)
      protected int | yPositionForValue(int value)
      protected int yPositionForValue(int value, int trackY, int trackHeight)
      Returns the y location for the specified value.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • POSITIVE_SCROLL

        public static final int POSITIVE_SCROLL
        另请参见：
        Constant Field Values

      • NEGATIVE_SCROLL

        public static final int NEGATIVE_SCROLL
        另请参见：
        Constant Field Values

      • MIN_SCROLL

        public static final int MIN_SCROLL
        另请参见：
        Constant Field Values

      • MAX_SCROLL

        public static final int MAX_SCROLL
        另请参见：
        Constant Field Values

      • scrollTimer

        protected Timer scrollTimer

      • slider

        protected JSlider slider

      • focusInsets

        protected Insets focusInsets

      • insetCache

        protected Insets insetCache

      • leftToRightCache

        protected boolean leftToRightCache

      • focusRect

        protected Rectangle focusRect

      • contentRect

        protected Rectangle contentRect

      • labelRect

        protected Rectangle labelRect

      • tickRect

        protected Rectangle tickRect

      • trackRect

        protected Rectangle trackRect

      • thumbRect

        protected Rectangle thumbRect

      • trackBuffer

        protected int trackBuffer

      • trackListener

        protected BasicSliderUI.TrackListener trackListener

      • changeListener

        protected ChangeListener changeListener

      • componentListener

        protected ComponentListener componentListener

      • focusListener

        protected FocusListener focusListener

      • scrollListener

        protected BasicSliderUI.ScrollListener scrollListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

    • 构造方法详细信息

      • BasicSliderUI

        public BasicSliderUI(JSlider b)

    • 方法详细信息

      • getShadowColor

        protected Color getShadowColor()

      • getHighlightColor

        protected Color getHighlightColor()

      • getFocusColor

        protected Color getFocusColor()

      • isDragging

        protected boolean isDragging()
        Returns true if the user is dragging the slider.
        返回：
        true if the user is dragging the slider
        从以下版本开始：
        1.5

      • createUI

        public static ComponentUI createUI(JComponent b)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JSlider slider)

      • uninstallDefaults

        protected void uninstallDefaults(JSlider slider)

      • createTrackListener

        protected BasicSliderUI.TrackListener createTrackListener(JSlider slider)

      • createChangeListener

        protected ChangeListener createChangeListener(JSlider slider)

      • createComponentListener

        protected ComponentListener createComponentListener(JSlider slider)

      • createFocusListener

        protected FocusListener createFocusListener(JSlider slider)

      • createScrollListener

        protected BasicSliderUI.ScrollListener createScrollListener(JSlider slider)

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener(JSlider slider)

      • installListeners

        protected void installListeners(JSlider slider)

      • uninstallListeners

        protected void uninstallListeners(JSlider slider)

      • installKeyboardActions

        protected void installKeyboardActions(JSlider slider)

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions(JSlider slider)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • labelsHaveSameBaselines

        protected boolean labelsHaveSameBaselines()
        Returns true if all the labels from the label table have the same baseline.
        返回：
        true if all the labels from the label table have the same baseline
        从以下版本开始：
        1.6

      • getPreferredHorizontalSize

        public Dimension getPreferredHorizontalSize()

      • getPreferredVerticalSize

        public Dimension getPreferredVerticalSize()

      • getMinimumHorizontalSize

        public Dimension getMinimumHorizontalSize()

      • getMinimumVerticalSize

        public Dimension getMinimumVerticalSize()

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • calculateGeometry

        protected void calculateGeometry()

      • calculateFocusRect

        protected void calculateFocusRect()

      • calculateThumbSize

        protected void calculateThumbSize()

      • calculateContentRect

        protected void calculateContentRect()

      • calculateThumbLocation

        protected void calculateThumbLocation()

      • calculateTrackBuffer

        protected void calculateTrackBuffer()

      • calculateTrackRect

        protected void calculateTrackRect()

      • getTickLength

        protected int getTickLength()
        Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders. BasicSliderUI uses the returned value to determine the tick area rectangle. If you want to give your ticks some room, make this larger than you need and paint your ticks away from the sides in paintTicks().

      • calculateTickRect

        protected void calculateTickRect()

      • calculateLabelRect

        protected void calculateLabelRect()

      • getThumbSize

        protected Dimension getThumbSize()

      • getWidthOfWidestLabel

        protected int getWidthOfWidestLabel()

      • getHeightOfTallestLabel

        protected int getHeightOfTallestLabel()

      • getWidthOfHighValueLabel

        protected int getWidthOfHighValueLabel()

      • getWidthOfLowValueLabel

        protected int getWidthOfLowValueLabel()

      • getHeightOfHighValueLabel

        protected int getHeightOfHighValueLabel()

      • getHeightOfLowValueLabel

        protected int getHeightOfLowValueLabel()

      • drawInverted

        protected boolean drawInverted()

      • getHighestValue

        protected Integer getHighestValue()
        Returns the biggest value that has an entry in the label table.
        返回：
        biggest value that has an entry in the label table, or null.
        从以下版本开始：
        1.6

      • getLowestValue

        protected Integer getLowestValue()
        Returns the smallest value that has an entry in the label table.
        返回：
        smallest value that has an entry in the label table, or null.
        从以下版本开始：
        1.6

      • getLowestValueLabel

        protected Component getLowestValueLabel()
        Returns the label that corresponds to the highest slider value in the label table.
        另请参见：
        JSlider.setLabelTable(java.util.Dictionary)

      • getHighestValueLabel

        protected Component getHighestValueLabel()
        Returns the label that corresponds to the lowest slider value in the label table.
        另请参见：
        JSlider.setLabelTable(java.util.Dictionary)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • recalculateIfInsetsChanged

        protected void recalculateIfInsetsChanged()

      • recalculateIfOrientationChanged

        protected void recalculateIfOrientationChanged()

      • paintFocus

        public void paintFocus(Graphics g)

      • paintTrack

        public void paintTrack(Graphics g)

      • paintTicks

        public void paintTicks(Graphics g)

      • paintMinorTickForHorizSlider

        protected void paintMinorTickForHorizSlider(Graphics g,
                                Rectangle tickBounds,
                                int x)

      • paintMajorTickForHorizSlider

        protected void paintMajorTickForHorizSlider(Graphics g,
                                Rectangle tickBounds,
                                int x)

      • paintMinorTickForVertSlider

        protected void paintMinorTickForVertSlider(Graphics g,
                               Rectangle tickBounds,
                               int y)

      • paintMajorTickForVertSlider

        protected void paintMajorTickForVertSlider(Graphics g,
                               Rectangle tickBounds,
                               int y)

      • paintLabels

        public void paintLabels(Graphics g)

      • paintHorizontalLabel

        protected void paintHorizontalLabel(Graphics g,
                        int value,
                        Component label)
        Called for every label in the label table. Used to draw the labels for horizontal sliders. The graphics have been translated to labelRect.y already.
        另请参见：
        JSlider.setLabelTable(java.util.Dictionary)

      • paintVerticalLabel

        protected void paintVerticalLabel(Graphics g,
                      int value,
                      Component label)
        Called for every label in the label table. Used to draw the labels for vertical sliders. The graphics have been translated to labelRect.x already.
        另请参见：
        JSlider.setLabelTable(java.util.Dictionary)

      • paintThumb

        public void paintThumb(Graphics g)

      • setThumbLocation

        public void setThumbLocation(int x,
                    int y)

      • scrollByBlock

        public void scrollByBlock(int direction)

      • scrollByUnit

        public void scrollByUnit(int direction)

      • scrollDueToClickInTrack

        protected void scrollDueToClickInTrack(int dir)
        This function is called when a mousePressed was detected in the track, not in the thumb. The default behavior is to scroll by block. You can override this method to stop it from scrolling or to add additional behavior.

      • xPositionForValue

        protected int xPositionForValue(int value)

      • yPositionForValue

        protected int yPositionForValue(int value)

      • yPositionForValue

        protected int yPositionForValue(int value,
                    int trackY,
                    int trackHeight)
        Returns the y location for the specified value. No checking is done on the arguments. In particular if trackHeight is negative undefined results may occur.
        参数：
        value - the slider value to get the location for
        trackY - y-origin of the track
        trackHeight - the height of the track
        从以下版本开始：
        1.6

      • valueForYPosition

        public int valueForYPosition(int yPos)
        Returns the value at the y position. If yPos is beyond the track at the the bottom or the top, this method sets the value to either the minimum or maximum value of the slider, depending on if the slider is inverted or not.

      • valueForXPosition

        public int valueForXPosition(int xPos)
        Returns the value at the x position. If xPos is beyond the track at the left or the right, this method sets the value to either the minimum or maximum value of the slider, depending on if the slider is inverted or not.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicSliderUI.ActionScroller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.ActionScroller

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.ActionScroller
extends AbstractAction
    As of Java 2 platform v1.3 this undocumented class is no longer used. The recommended approach to creating bindings is to use a combination of an ActionMap, to contain the action, and an InputMap to contain the mapping from KeyStroke to action description. The InputMap is is usually described in the LookAndFeel tables.

    Please refer to the key bindings specification for further details.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.ActionScroller(JSlider slider, int dir, boolean block)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.ActionScroller

        public BasicSliderUI.ActionScroller(JSlider slider,
                            int dir,
                            boolean block)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lriaeir/irCeerCC psso cceheetenfs anrfffneCnm r


BasicSliderUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.ChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.ChangeHandler
extends Object
implements ChangeListener
    Data model listener. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.ChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.ChangeHandler

        public BasicSliderUI.ChangeHandler()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Beabpe4re4h>>4hhliSS-)> - a Lti"kcc"lt tB


BasicSliderUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.ComponentHandler

  • java.lang.Object
    • java.awt.event.ComponentAdapter
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
  • 所有已实现的接口：
    ComponentListener, EventListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.ComponentHandler
extends ComponentAdapter
    Listener for resizing events.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.ComponentHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void componentResized(ComponentEvent e)
      Invoked when the component's size changes.

      • 方法 - 继承于类 java.awt.event.ComponentAdapter

        componentHidden, componentMoved, componentShown

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.ComponentHandler

        public BasicSliderUI.ComponentHandler()

    • 方法详细信息

      • componentResized

        public void componentResized(ComponentEvent e)
        Description copied from class: ComponentAdapter
        Invoked when the component's size changes.
        指定者：
        componentResized in interface ComponentListener
        重载：
        componentResized in class ComponentAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tc"= l1cl ><< >>Ln<< a �>iiusunya///ib>/k


BasicSliderUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.FocusHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.FocusHandler
extends Object
implements FocusListener
    Focus-change listener.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.FocusHandler

        public BasicSliderUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rdonrpBipD>-eD>>> dds�4x> Eaublsppjab;nr


BasicSliderUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    直接已知子类：
    MetalSliderUI.MetalPropertyListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.PropertyChangeHandler

        public BasicSliderUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sn=t/3ah3amrrammd< u>busll lu-=MD====!>=-=


BasicSliderUI.ScrollListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.ScrollListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.ScrollListener
extends Object
implements ActionListener
    Scroll-event listener. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.ScrollListener()
      BasicSliderUI.ScrollListener(int dir, boolean block)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      void | setDirection(int direction)
      void | setScrollByBlock(boolean block)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSliderUI.ScrollListener

        public BasicSliderUI.ScrollListener()

      • BasicSliderUI.ScrollListener

        public BasicSliderUI.ScrollListener(int dir,
                            boolean block)

    • 方法详细信息

      • setDirection

        public void setDirection(int direction)

      • setScrollByBlock

        public void setScrollByBlock(boolean block)

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e = -. h aglev/npocs ct l郺#loe萯


BasicSliderUI.TrackListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSliderUI.TrackListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.event.MouseInputAdapter
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
    封闭类：
    BasicSliderUI

    public class BasicSliderUI.TrackListener
extends MouseInputAdapter
    Track mouse movements. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | currentMouseX
      protected int | currentMouseY
      protected int | offset

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSliderUI.TrackListener()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void mouseDragged(MouseEvent e)
      Set the models value to the position of the top/left of the thumb relative to the origin of the track.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.
      boolean | shouldScroll(int direction)

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseEntered, mouseExited, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.MouseListener

        mouseClicked, mouseEntered, mouseExited

    • 字段详细信息

      • offset

        protected transient int offset

      • currentMouseX

        protected transient int currentMouseX

      • currentMouseY

        protected transient int currentMouseY

    • 构造方法详细信息

      • BasicSliderUI.TrackListener

        public BasicSliderUI.TrackListener()

    • 方法详细信息

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter

      • mousePressed

        public void mousePressed(MouseEvent e)
        If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page. If there is no thumb then page up if the mouse is in the upper half of the track.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • shouldScroll

        public boolean shouldScroll(int direction)

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Set the models value to the position of the top/left of the thumb relative to the origin of the track.
        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/cc/t>>o糽l


BasicSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSpinnerUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
  • 直接已知子类：
    SynthSpinnerUI

    public class BasicSpinnerUI
extends SpinnerUI
    The default Spinner UI delegate.
    从以下版本开始：
    1.4

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JSpinner spinner
      The spinner that we're a UI delegate for.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSpinnerUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected JComponent createEditor()
      This method is called by installUI to get the editor component of the JSpinner.
      protected LayoutManager createLayout()
      Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner.
      protected Component createNextButton()
      Creates an increment button, i.e.
      protected Component createPreviousButton()
      Creates a decrement button, i.e.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates a PropertyChangeListener that can be added to the JSpinner itself.
      static ComponentUI createUI(JComponent c)
      Returns a new instance of BasicSpinnerUI.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected void installDefaults()
      Initialize the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
      protected void installKeyboardActions()
      Installs the keyboard Actions onto the JSpinner.
      protected void installListeners()
      Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.
      protected void installNextButtonListeners(Component c)
      Installs the necessary listeners on the next button, c, to update the JSpinner in response to a user gesture.
      protected void installPreviousButtonListeners(Component c)
      Installs the necessary listeners on the previous button, c, to update the JSpinner in response to a user gesture.
      void installUI(JComponent c)
      Calls installDefaults, installListeners, and then adds the components returned by createNextButton, createPreviousButton, and createEditor.
      protected void replaceEditor(JComponent oldEditor, JComponent newEditor)
      Called by the PropertyChangeListener when the JSpinner editor property changes.
      protected void uninstallDefaults()
      Sets the JSpinner's layout manager to null.
      protected void uninstallListeners()
      Removes the PropertyChangeListener added by installListeners.
      void uninstallUI(JComponent c)
      Calls uninstallDefaults, uninstallListeners, and then removes all of the spinners children.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • spinner

        protected JSpinner spinner
        The spinner that we're a UI delegate for. Initialized by the installUI method, and reset to null by uninstallUI.
        另请参见：
        installUI(javax.swing.JComponent), uninstallUI(javax.swing.JComponent)

    • 构造方法详细信息

      • BasicSpinnerUI

        public BasicSpinnerUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Returns a new instance of BasicSpinnerUI. SpinnerListUI delegates are allocated one per JSpinner.
        参数：
        c - the JSpinner (not used)
        返回：
        a new BasicSpinnerUI object
        另请参见：
        ComponentUI.createUI(javax.swing.JComponent)

      • installUI

        public void installUI(JComponent c)
        Calls installDefaults, installListeners, and then adds the components returned by createNextButton, createPreviousButton, and createEditor.
        重载：
        installUI in class ComponentUI
        参数：
        c - the JSpinner
        另请参见：
        installDefaults(),
installListeners(),
createNextButton(),
createPreviousButton(),
createEditor()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Calls uninstallDefaults, uninstallListeners, and then removes all of the spinners children.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the JSpinner (not used)
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installListeners

        protected void installListeners()
        Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.

        This method is called by installUI.

        另请参见：
        replaceEditor(javax.swing.JComponent, javax.swing.JComponent), uninstallListeners()

      • uninstallListeners

        protected void uninstallListeners()
        Removes the PropertyChangeListener added by installListeners.

        This method is called by uninstallUI.

        另请参见：
        installListeners()

      • installDefaults

        protected void installDefaults()
        Initialize the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table. The JSpinners layout is set to the value returned by createLayout. This method is called by installUI.
        另请参见：
        uninstallDefaults(),
installUI(javax.swing.JComponent),
createLayout(),
LookAndFeel.installBorder(javax.swing.JComponent, java.lang.String),
LookAndFeel.installColors(javax.swing.JComponent, java.lang.String, java.lang.String)

      • uninstallDefaults

        protected void uninstallDefaults()
        Sets the JSpinner's layout manager to null. This method is called by uninstallUI.
        另请参见：
        installDefaults(), uninstallUI(javax.swing.JComponent)

      • installNextButtonListeners

        protected void installNextButtonListeners(Component c)
        Installs the necessary listeners on the next button, c, to update the JSpinner in response to a user gesture.
        参数：
        c - Component to install the listeners on
        抛出：
        NullPointerException - if c is null.
        从以下版本开始：
        1.5
        另请参见：
        createNextButton()

      • installPreviousButtonListeners

        protected void installPreviousButtonListeners(Component c)
        Installs the necessary listeners on the previous button, c, to update the JSpinner in response to a user gesture.
        参数：
        c - Component to install the listeners on.
        抛出：
        NullPointerException - if c is null.
        从以下版本开始：
        1.5
        另请参见：
        createPreviousButton()

      • createLayout

        protected LayoutManager createLayout()
        Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner. These three children must be added with a constraint that identifies their role: "Editor", "Next", and "Previous". The default layout manager can handle the absence of any of these children.
        返回：
        a LayoutManager for the editor, next button, and previous button.
        另请参见：
        createNextButton(),
createPreviousButton(),
createEditor()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates a PropertyChangeListener that can be added to the JSpinner itself. Typically, this listener will call replaceEditor when the "editor" property changes, since it's the SpinnerUI's responsibility to add the editor to the JSpinner (and remove the old one). This method is called by installListeners.
        返回：
        A PropertyChangeListener for the JSpinner itself
        另请参见：
        installListeners()

      • createPreviousButton

        protected Component createPreviousButton()
        Creates a decrement button, i.e. component that replaces the spinner value with the object returned by spinner.getPreviousValue. By default the previousButton is a JButton. If the decrement button is not needed this method should return null.
        返回：
        a component that will replace the spinner's value with the previous value in the sequence, or null
        另请参见：
        installUI(javax.swing.JComponent),
createNextButton(),
installPreviousButtonListeners(java.awt.Component)

      • createNextButton

        protected Component createNextButton()
        Creates an increment button, i.e. component that replaces the spinner value with the object returned by spinner.getNextValue. By default the nextButton is a JButton. If the increment button is not needed this method should return null.
        返回：
        a component that will replace the spinner's value with the next value in the sequence, or null
        另请参见：
        installUI(javax.swing.JComponent),
createPreviousButton(),
installNextButtonListeners(java.awt.Component)

      • createEditor

        protected JComponent createEditor()
        This method is called by installUI to get the editor component of the JSpinner. By default it just returns JSpinner.getEditor(). Subclasses can override createEditor to return a component that contains the spinner's editor or null, if they're going to handle adding the editor to the JSpinner in an installUI override.

        Typically this method would be overridden to wrap the editor with a container with a custom border, since one can't assume that the editors border can be set directly.

        The replaceEditor method is called when the spinners editor is changed with JSpinner.setEditor. If you've overriden this method, then you'll probably want to override replaceEditor as well.

        返回：
        the JSpinners editor JComponent, spinner.getEditor() by default
        另请参见：
        installUI(javax.swing.JComponent),
replaceEditor(javax.swing.JComponent, javax.swing.JComponent),
JSpinner.getEditor()

      • replaceEditor

        protected void replaceEditor(JComponent oldEditor,
                 JComponent newEditor)
        Called by the PropertyChangeListener when the JSpinner editor property changes. It's the responsibility of this method to remove the old editor and add the new one. By default this operation is just:
         spinner.remove(oldEditor);
 spinner.add(newEditor, "Editor");
        The implementation of replaceEditor should be coordinated with the createEditor method.
        另请参见：
        createEditor(), createPropertyChangeListener()

      • installKeyboardActions

        protected void installKeyboardActions()
        Installs the keyboard Actions onto the JSpinner.
        从以下版本开始：
        1.5

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

4


BasicSplitPaneDivider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneDivider

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider
  • 所有已实现的接口：
    ImageObserver, MenuContainer, PropertyChangeListener, Serializable, EventListener

    public class BasicSplitPaneDivider
extends Container
implements PropertyChangeListener
    Divider used by BasicSplitPaneUI. Subclassers may wish to override paint to do something more interesting. The border effect is drawn in BasicSplitPaneUI, so if you don't like that border, reset it there. To conditionally drag from certain areas subclass mousePressed and call super when you wish the dragging to begin.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  BasicSplitPaneDivider.DividerLayout
      Used to layout a BasicSplitPaneDivider.
      protected class  BasicSplitPaneDivider.DragController
      Handles the events during a dragging session for a HORIZONTAL_SPLIT oriented split pane.
      protected class  BasicSplitPaneDivider.MouseHandler
      MouseHandler is responsible for converting mouse events (released, dragged...) into the appropriate DragController methods.
      protected class  BasicSplitPaneDivider.VerticalDragController
      Handles the events during a dragging session for a VERTICAL_SPLIT oriented split pane.

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int dividerSize
      Size of the divider.
      protected BasicSplitPaneDivider.DragController dragger
      Handles mouse dragging message to do the actual dragging.
      protected Component hiddenDivider
      Divider that is used for noncontinuous layout mode.
      protected JButton leftButton
      Button for quickly toggling the left component.
      protected BasicSplitPaneDivider.MouseHandler mouseHandler
      Handles mouse events from both this class, and the split pane.
      protected static int | ONE_TOUCH_OFFSET
      protected static int ONE_TOUCH_SIZE
      Width or height of the divider based on orientation BasicSplitPaneUI adds two to this.
      protected int orientation
      Orientation of the JSplitPane.
      protected JButton rightButton
      Button for quickly toggling the right component.
      protected JSplitPane splitPane
      JSplitPane the receiver is contained in.
      protected BasicSplitPaneUI splitPaneUI
      UI this instance was created from.

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneDivider(BasicSplitPaneUI ui)
      Creates an instance of BasicSplitPaneDivider.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected JButton createLeftOneTouchButton()
      Creates and return an instance of JButton that can be used to collapse the left component in the split pane.
      protected JButton createRightOneTouchButton()
      Creates and return an instance of JButton that can be used to collapse the right component in the split pane.
      protected void dragDividerTo(int location)
      Messages the BasicSplitPaneUI with dragDividerTo that this instance is contained in.
      protected void finishDraggingTo(int location)
      Messages the BasicSplitPaneUI with finishDraggingTo that this instance is contained in.
      BasicSplitPaneUI getBasicSplitPaneUI()
      Returns the SplitPaneUI the receiver is currently in.
      Border getBorder()
      Returns the border of this component or null if no border is currently set.
      int getDividerSize()
      Returns the size of the divider, that is the width if the splitpane is HORIZONTAL_SPLIT, or the height of VERTICAL_SPLIT.
      Insets getInsets()
      If a border has been set on this component, returns the border's insets, else calls super.getInsets.
      Dimension getMinimumSize()
      Returns dividerSize x dividerSize
      Dimension getPreferredSize()
      Returns dividerSize x dividerSize
      boolean isMouseOver()
      Returns whether or not the mouse is currently over the divider
      protected void oneTouchExpandableChanged()
      Messaged when the oneTouchExpandable value of the JSplitPane the receiver is contained in changes.
      void paint(Graphics g)
      Paints the divider.
      protected void prepareForDragging()
      Message to prepare for dragging.
      void propertyChange(PropertyChangeEvent e)
      Property change event, presumably from the JSplitPane, will message updateOrientation if necessary.
      void setBasicSplitPaneUI(BasicSplitPaneUI newUI)
      Sets the SplitPaneUI that is using the receiver.
      void setBorder(Border border)
      Sets the border of this component.
      void setDividerSize(int newSize)
      Sets the size of the divider to newSize.
      protected void setMouseOver(boolean mouseOver)
      Sets whether or not the mouse is currently over the divider.

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getListeners, getMaximumSize, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ONE_TOUCH_SIZE

        protected static final int ONE_TOUCH_SIZE
        Width or height of the divider based on orientation BasicSplitPaneUI adds two to this.
        另请参见：
        Constant Field Values

      • ONE_TOUCH_OFFSET

        protected static final int ONE_TOUCH_OFFSET
        另请参见：
        Constant Field Values

      • dragger

        protected BasicSplitPaneDivider.DragController dragger
        Handles mouse dragging message to do the actual dragging.

      • splitPaneUI

        protected BasicSplitPaneUI splitPaneUI
        UI this instance was created from.

      • dividerSize

        protected int dividerSize
        Size of the divider.

      • hiddenDivider

        protected Component hiddenDivider
        Divider that is used for noncontinuous layout mode.

      • splitPane

        protected JSplitPane splitPane
        JSplitPane the receiver is contained in.

      • mouseHandler

        protected BasicSplitPaneDivider.MouseHandler mouseHandler
        Handles mouse events from both this class, and the split pane. Mouse events are handled for the splitpane since you want to be able to drag when clicking on the border of the divider, which is not drawn by the divider.

      • orientation

        protected int orientation
        Orientation of the JSplitPane.

      • leftButton

        protected JButton leftButton
        Button for quickly toggling the left component.

      • rightButton

        protected JButton rightButton
        Button for quickly toggling the right component.

    • 构造方法详细信息

      • BasicSplitPaneDivider

        public BasicSplitPaneDivider(BasicSplitPaneUI ui)
        Creates an instance of BasicSplitPaneDivider. Registers this instance for mouse events and mouse dragged events.

    • 方法详细信息

      • setBasicSplitPaneUI

        public void setBasicSplitPaneUI(BasicSplitPaneUI newUI)
        Sets the SplitPaneUI that is using the receiver.

      • getBasicSplitPaneUI

        public BasicSplitPaneUI getBasicSplitPaneUI()
        Returns the SplitPaneUI the receiver is currently in.

      • setDividerSize

        public void setDividerSize(int newSize)
        Sets the size of the divider to newSize. That is the width if the splitpane is HORIZONTAL_SPLIT, or the height of VERTICAL_SPLIT.

      • getDividerSize

        public int getDividerSize()
        Returns the size of the divider, that is the width if the splitpane is HORIZONTAL_SPLIT, or the height of VERTICAL_SPLIT.

      • setBorder

        public void setBorder(Border border)
        Sets the border of this component.
        从以下版本开始：
        1.3

      • getBorder

        public Border getBorder()
        Returns the border of this component or null if no border is currently set.
        返回：
        the border object for this component
        从以下版本开始：
        1.3
        另请参见：
        setBorder(javax.swing.border.Border)

      • getInsets

        public Insets getInsets()
        If a border has been set on this component, returns the border's insets, else calls super.getInsets.
        重载：
        getInsets in class Container
        返回：
        the value of the insets property.
        另请参见：
        setBorder(javax.swing.border.Border)

      • setMouseOver

        protected void setMouseOver(boolean mouseOver)
        Sets whether or not the mouse is currently over the divider.
        参数：
        mouseOver - whether or not the mouse is currently over the divider
        从以下版本开始：
        1.5

      • isMouseOver

        public boolean isMouseOver()
        Returns whether or not the mouse is currently over the divider
        返回：
        whether or not the mouse is currently over the divider
        从以下版本开始：
        1.5

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns dividerSize x dividerSize
        重载：
        getPreferredSize in class Container
        返回：
        an instance of Dimension that represents the preferred size of this container.
        另请参见：
        Container.getMinimumSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()

      • getMinimumSize

        public Dimension getMinimumSize()
        Returns dividerSize x dividerSize
        重载：
        getMinimumSize in class Container
        返回：
        an instance of Dimension that represents the minimum size of this container.
        另请参见：
        Container.getPreferredSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.minimumLayoutSize(Container),
Component.getMinimumSize()

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Property change event, presumably from the JSplitPane, will message updateOrientation if necessary.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • paint

        public void paint(Graphics g)
        Paints the divider.
        重载：
        paint in class Container
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • oneTouchExpandableChanged

        protected void oneTouchExpandableChanged()
        Messaged when the oneTouchExpandable value of the JSplitPane the receiver is contained in changes. Will create the leftButton and rightButton if they are null. invalidates the receiver as well.

      • createLeftOneTouchButton

        protected JButton createLeftOneTouchButton()
        Creates and return an instance of JButton that can be used to collapse the left component in the split pane.

      • createRightOneTouchButton

        protected JButton createRightOneTouchButton()
        Creates and return an instance of JButton that can be used to collapse the right component in the split pane.

      • prepareForDragging

        protected void prepareForDragging()
        Message to prepare for dragging. This messages the BasicSplitPaneUI with startDragging.

      • dragDividerTo

        protected void dragDividerTo(int location)
        Messages the BasicSplitPaneUI with dragDividerTo that this instance is contained in.

      • finishDraggingTo

        protected void finishDraggingTo(int location)
        Messages the BasicSplitPaneUI with finishDraggingTo that this instance is contained in.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicSplitPaneDivider.DividerLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneDivider.DividerLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    BasicSplitPaneDivider

    protected class BasicSplitPaneDivider.DividerLayout
extends Object
implements LayoutManager
    Used to layout a BasicSplitPaneDivider. Layout for the divider involves appropriately moving the left/right buttons around.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicSplitPaneDivider.DividerLayout()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(String string, Component c)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      void layoutContainer(Container c)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container c)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      Dimension preferredLayoutSize(Container c)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      void removeLayoutComponent(Component c)
      Removes the specified component from the layout.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneDivider.DividerLayout

        protected BasicSplitPaneDivider.DividerLayout()

    • 方法详细信息

      • layoutContainer

        public void layoutContainer(Container c)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        c - the container to be laid out

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        c - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container c)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        c - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • removeLayoutComponent

        public void removeLayoutComponent(Component c)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        c - the component to be removed

      • addLayoutComponent

        public void addLayoutComponent(String string,
                      Component c)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        string - the string to be associated with the component
        c - the component to be added
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>tsic> c>" >""ks eeprl ===---l/nibni


BasicSplitPaneDivider.DragController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneDivider.DragController

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
  • 直接已知子类：
    BasicSplitPaneDivider.VerticalDragController
    封闭类：
    BasicSplitPaneDivider

    protected class BasicSplitPaneDivider.DragController
extends Object
    Handles the events during a dragging session for a HORIZONTAL_SPLIT oriented split pane. This continually messages dragDividerTo and then when done messages finishDraggingTo. When an instance is created it should be messaged with isValid to insure that dragging can happen (dragging won't be allowed if the two views can not be resized).

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicSplitPaneDivider.DragController(MouseEvent e)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | completeDrag(int x, int y)
      protected void completeDrag(MouseEvent e)
      Messages finishDraggingTo with the new location for the mouse event.
      protected void | continueDrag(int newX, int newY)
      protected void continueDrag(MouseEvent e)
      Messages dragDividerTo with the new location for the mouse event.
      protected int getNeededLocation(int x, int y)
      Returns the x argument, since this is used for horizontal splits.
      protected boolean isValid()
      Returns true if the dragging session is valid.
      protected int positionForMouseEvent(MouseEvent e)
      Returns the new position to put the divider at based on the passed in MouseEvent.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneDivider.DragController

        protected BasicSplitPaneDivider.DragController(MouseEvent e)

    • 方法详细信息

      • isValid

        protected boolean isValid()
        Returns true if the dragging session is valid.

      • positionForMouseEvent

        protected int positionForMouseEvent(MouseEvent e)
        Returns the new position to put the divider at based on the passed in MouseEvent.

      • getNeededLocation

        protected int getNeededLocation(int x,
                    int y)
        Returns the x argument, since this is used for horizontal splits.

      • continueDrag

        protected void continueDrag(int newX,
                int newY)

      • continueDrag

        protected void continueDrag(MouseEvent e)
        Messages dragDividerTo with the new location for the mouse event.

      • completeDrag

        protected void completeDrag(int x,
                int y)

      • completeDrag

        protected void completeDrag(MouseEvent e)
        Messages finishDraggingTo with the new location for the mouse event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i"csasluslcaalccrarcekhhl"vse


BasicSplitPaneDivider.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneDivider.MouseHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicSplitPaneDivider

    protected class BasicSplitPaneDivider.MouseHandler
extends MouseAdapter
implements MouseMotionListener
    MouseHandler is responsible for converting mouse events (released, dragged...) into the appropriate DragController methods.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicSplitPaneDivider.MouseHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseDragged(MouseEvent e)
      If dragger is not null it is messaged with continueDrag.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Resets the cursor based on the orientation.
      void mousePressed(MouseEvent e)
      Starts the dragging session by creating the appropriate instance of DragController.
      void mouseReleased(MouseEvent e)
      If dragger is not null it is messaged with completeDrag.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneDivider.MouseHandler

        protected BasicSplitPaneDivider.MouseHandler()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Starts the dragging session by creating the appropriate instance of DragController.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        If dragger is not null it is messaged with completeDrag.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        If dragger is not null it is messaged with continueDrag.
        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Resets the cursor based on the orientation.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener
        重载：
        mouseEntered in class MouseAdapter
        参数：
        e - MouseEvent describing the details of the enter event.
        从以下版本开始：
        1.5

      • mouseExited

        public void mouseExited(MouseEvent e)
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener
        重载：
        mouseExited in class MouseAdapter
        参数：
        e - MouseEvent describing the details of the exit event.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

IfTZsHe Hen ennlf osdo/((e"tihdo e>oS)tz


BasicSplitPaneDivider.VerticalDragController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneDivider.VerticalDragController

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
  • 封闭类：
    BasicSplitPaneDivider

    protected class BasicSplitPaneDivider.VerticalDragController
extends BasicSplitPaneDivider.DragController
    Handles the events during a dragging session for a VERTICAL_SPLIT oriented split pane. This continually messages dragDividerTo and then when done messages finishDraggingTo. When an instance is created it should be messaged with isValid to insure that dragging can happen (dragging won't be allowed if the two views can not be resized).

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicSplitPaneDivider.VerticalDragController(MouseEvent e)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected int getNeededLocation(int x, int y)
      Returns the y argument, since this is used for vertical splits.
      protected int positionForMouseEvent(MouseEvent e)
      Returns the new position to put the divider at based on the passed in MouseEvent.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController

        completeDrag, completeDrag, continueDrag, continueDrag, isValid

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneDivider.VerticalDragController

        protected BasicSplitPaneDivider.VerticalDragController(MouseEvent e)

    • 方法详细信息

      • getNeededLocation

        protected int getNeededLocation(int x,
                    int y)
        Returns the y argument, since this is used for vertical splits.
        重载：
        getNeededLocation in class BasicSplitPaneDivider.DragController

      • positionForMouseEvent

        protected int positionForMouseEvent(MouseEvent e)
        Returns the new position to put the divider at based on the passed in MouseEvent.
        重载：
        positionForMouseEvent in class BasicSplitPaneDivider.DragController
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cais d<.Eeessnpr;esscobc=o


BasicSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
  • 直接已知子类：
    MetalSplitPaneUI, SynthSplitPaneUI

    public class BasicSplitPaneUI
extends SplitPaneUI
    A Basic L&F implementation of the SplitPaneUI.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicSplitPaneUI.BasicHorizontalLayoutManager
      LayoutManager for JSplitPanes that have an orientation of HORIZONTAL_SPLIT.
      class  BasicSplitPaneUI.BasicVerticalLayoutManager
      LayoutManager used for JSplitPanes with an orientation of VERTICAL_SPLIT.
      class  BasicSplitPaneUI.FocusHandler
      Implementation of the FocusListener that the JSplitPane UI uses.
      class  BasicSplitPaneUI.KeyboardDownRightHandler
      Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
      class  BasicSplitPaneUI.KeyboardEndHandler
      Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
      class  BasicSplitPaneUI.KeyboardHomeHandler
      Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
      class  BasicSplitPaneUI.KeyboardResizeToggleHandler
      Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
      class  BasicSplitPaneUI.KeyboardUpLeftHandler
      Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
      class  BasicSplitPaneUI.PropertyHandler
      Implementation of the PropertyChangeListener that the JSplitPane UI uses.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int beginDragDividerLocation
      Location of the divider when the dragging session began.
      protected BasicSplitPaneDivider divider
      Instance of the divider for this JSplitPane.
      protected KeyStroke dividerResizeToggleKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected int dividerSize
      The size of the divider while the dragging session is valid.
      protected KeyStroke downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected boolean draggingHW
      Set to true in startDragging if any of the children (not including the nonContinuousLayoutDivider) are heavy weights.
      protected KeyStroke endKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected FocusListener focusListener
      Instance of the FocusListener for this JSplitPane.
      protected KeyStroke homeKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected static int KEYBOARD_DIVIDER_MOVE_OFFSET
      How far (relative) the divider does move when it is moved around by the cursor keys on the keyboard.
      protected ActionListener keyboardDownRightListener
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener keyboardEndListener
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener keyboardHomeListener
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener keyboardResizeToggleListener
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener keyboardUpLeftListener
      Deprecated.
      As of Java 2 platform v1.3.
      protected BasicSplitPaneUI.BasicHorizontalLayoutManager layoutManager
      LayoutManager that is created and placed into the split pane.
      protected KeyStroke leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected static String NON_CONTINUOUS_DIVIDER
      The divider used for non-continuous layout is added to the split pane with this object.
      protected Component nonContinuousLayoutDivider
      Instance for the shadow of the divider when non continuous layout is being used.
      protected PropertyChangeListener propertyChangeListener
      Instance of the PropertyChangeListener for this JSplitPane.
      protected KeyStroke rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected JSplitPane splitPane
      JSplitPane instance this instance is providing the look and feel for.
      protected KeyStroke upKey
      Deprecated.
      As of Java 2 platform v1.3.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      BasicSplitPaneDivider createDefaultDivider()
      Creates the default divider.
      protected Component createDefaultNonContinuousLayoutDivider()
      Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
      protected FocusListener createFocusListener()
      Creates a FocusListener for the JSplitPane UI.
      protected ActionListener createKeyboardDownRightListener()
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener createKeyboardEndListener()
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener createKeyboardHomeListener()
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener createKeyboardResizeToggleListener()
      Deprecated.
      As of Java 2 platform v1.3.
      protected ActionListener createKeyboardUpLeftListener()
      Deprecated.
      As of Java 2 platform v1.3.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates a PropertyChangeListener for the JSplitPane UI.
      static ComponentUI createUI(JComponent x)
      Creates a new BasicSplitPaneUI instance
      protected void dragDividerTo(int location)
      Messaged during a dragging session to move the divider to the passed in location.
      protected void finishDraggingTo(int location)
      Messaged to finish the dragging session.
      void finishedPaintingChildren(JSplitPane sp, Graphics g)
      Called when the specified split pane has finished painting its children.
      BasicSplitPaneDivider getDivider()
      Returns the divider between the top Components.
      protected int getDividerBorderSize()
      Deprecated.
      As of Java 2 platform v1.3, instead set the border on the divider.
      int getDividerLocation(JSplitPane jc)
      Returns the location of the divider, which may differ from what the splitpane thinks the location of the divider is.
      Insets getInsets(JComponent jc)
      Returns the insets.
      int getLastDragLocation()
      Returns the last drag location of the JSplitPane.
      int getMaximumDividerLocation(JSplitPane jc)
      Gets the maximum location of the divider.
      Dimension getMaximumSize(JComponent jc)
      Returns the maximum size for the passed in component, This is passed off to the current layoutmanager.
      int getMinimumDividerLocation(JSplitPane jc)
      Gets the minimum location of the divider.
      Dimension getMinimumSize(JComponent jc)
      Returns the minimum size for the passed in component, This is passed off to the current layoutmanager.
      Component getNonContinuousLayoutDivider()
      Returns the divider to use when the splitPane is configured to not continuously layout.
      int getOrientation()
      Returns the orientation for the JSplitPane.
      Dimension getPreferredSize(JComponent jc)
      Returns the preferred size for the passed in component, This is passed off to the current layoutmanager.
      JSplitPane getSplitPane()
      Returns the splitpane this instance is currently contained in.
      protected void installDefaults()
      Installs the UI defaults.
      protected void installKeyboardActions()
      Installs the keyboard actions for the UI.
      protected void installListeners()
      Installs the event listeners for the UI.
      void installUI(JComponent c)
      Installs the UI.
      boolean isContinuousLayout()
      Determines wether the JSplitPane is set to use a continuous layout.
      void paint(Graphics g, JComponent jc)
      Paints the specified component appropriately for the look and feel.
      protected void resetLayoutManager()
      Resets the layout manager based on orientation and messages it with invalidateLayout to pull in appropriate Components.
      void resetToPreferredSizes(JSplitPane jc)
      Messaged to reset the preferred sizes.
      void setContinuousLayout(boolean b)
      Turn continuous layout on/off.
      void setDividerLocation(JSplitPane jc, int location)
      Sets the location of the divider to location.
      void setLastDragLocation(int l)
      Set the last drag location of the JSplitPane.
      protected void setNonContinuousLayoutDivider(Component newDivider)
      Sets the divider to use when the splitPane is configured to not continuously layout.
      protected void setNonContinuousLayoutDivider(Component newDivider, boolean rememberSizes)
      Sets the divider to use.
      void setOrientation(int orientation)
      Set the orientation for the JSplitPane.
      protected void startDragging()
      Should be messaged before the dragging session starts, resets lastDragLocation and dividerSize.
      protected void uninstallDefaults()
      Uninstalls the UI defaults.
      protected void uninstallKeyboardActions()
      Uninstalls the keyboard actions for the UI.
      protected void uninstallListeners()
      Uninstalls the event listeners for the UI.
      void uninstallUI(JComponent c)
      Uninstalls the UI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NON_CONTINUOUS_DIVIDER

        protected static final String NON_CONTINUOUS_DIVIDER
        The divider used for non-continuous layout is added to the split pane with this object.
        另请参见：
        Constant Field Values

      • KEYBOARD_DIVIDER_MOVE_OFFSET

        protected static int KEYBOARD_DIVIDER_MOVE_OFFSET
        How far (relative) the divider does move when it is moved around by the cursor keys on the keyboard.

      • splitPane

        protected JSplitPane splitPane
        JSplitPane instance this instance is providing the look and feel for.

      • layoutManager

        protected BasicSplitPaneUI.BasicHorizontalLayoutManager layoutManager
        LayoutManager that is created and placed into the split pane.

      • divider

        protected BasicSplitPaneDivider divider
        Instance of the divider for this JSplitPane.

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener
        Instance of the PropertyChangeListener for this JSplitPane.

      • focusListener

        protected FocusListener focusListener
        Instance of the FocusListener for this JSplitPane.

      • dividerSize

        protected int dividerSize
        The size of the divider while the dragging session is valid.

      • nonContinuousLayoutDivider

        protected Component nonContinuousLayoutDivider
        Instance for the shadow of the divider when non continuous layout is being used.

      • draggingHW

        protected boolean draggingHW
        Set to true in startDragging if any of the children (not including the nonContinuousLayoutDivider) are heavy weights.

      • beginDragDividerLocation

        protected int beginDragDividerLocation
        Location of the divider when the dragging session began.

      • upKey

        @Deprecated
protected KeyStroke upKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • downKey

        @Deprecated
protected KeyStroke downKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • leftKey

        @Deprecated
protected KeyStroke leftKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • rightKey

        @Deprecated
protected KeyStroke rightKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • homeKey

        @Deprecated
protected KeyStroke homeKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • endKey

        @Deprecated
protected KeyStroke endKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • dividerResizeToggleKey

        @Deprecated
protected KeyStroke dividerResizeToggleKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • keyboardUpLeftListener

        @Deprecated
protected ActionListener keyboardUpLeftListener
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • keyboardDownRightListener

        @Deprecated
protected ActionListener keyboardDownRightListener
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • keyboardHomeListener

        @Deprecated
protected ActionListener keyboardHomeListener
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • keyboardEndListener

        @Deprecated
protected ActionListener keyboardEndListener
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • keyboardResizeToggleListener

        @Deprecated
protected ActionListener keyboardResizeToggleListener
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

    • 构造方法详细信息

      • BasicSplitPaneUI

        public BasicSplitPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new BasicSplitPaneUI instance

      • installUI

        public void installUI(JComponent c)
        Installs the UI.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        Installs the UI defaults.

      • installListeners

        protected void installListeners()
        Installs the event listeners for the UI.

      • installKeyboardActions

        protected void installKeyboardActions()
        Installs the keyboard actions for the UI.

      • uninstallUI

        public void uninstallUI(JComponent c)
        Uninstalls the UI.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()
        Uninstalls the UI defaults.

      • uninstallListeners

        protected void uninstallListeners()
        Uninstalls the event listeners for the UI.

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        Uninstalls the keyboard actions for the UI.

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates a PropertyChangeListener for the JSplitPane UI.

      • createFocusListener

        protected FocusListener createFocusListener()
        Creates a FocusListener for the JSplitPane UI.

      • createKeyboardUpLeftListener

        @Deprecated
protected ActionListener createKeyboardUpLeftListener()
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this method is no longer used. Subclassers previously using this method should instead create an Action wrapping the ActionListener, and register that Action by overriding installKeyboardActions and placing the Action in the SplitPane's ActionMap. Please refer to the key bindings specification for further details.

        Creates a ActionListener for the JSplitPane UI that listens for specific key presses.

      • createKeyboardDownRightListener

        @Deprecated
protected ActionListener createKeyboardDownRightListener()
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this method is no longer used. Subclassers previously using this method should instead create an Action wrapping the ActionListener, and register that Action by overriding installKeyboardActions and placing the Action in the SplitPane's ActionMap. Please refer to the key bindings specification for further details.

        Creates a ActionListener for the JSplitPane UI that listens for specific key presses.

      • createKeyboardHomeListener

        @Deprecated
protected ActionListener createKeyboardHomeListener()
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this method is no longer used. Subclassers previously using this method should instead create an Action wrapping the ActionListener, and register that Action by overriding installKeyboardActions and placing the Action in the SplitPane's ActionMap. Please refer to the key bindings specification for further details.

        Creates a ActionListener for the JSplitPane UI that listens for specific key presses.

      • createKeyboardEndListener

        @Deprecated
protected ActionListener createKeyboardEndListener()
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this method is no longer used. Subclassers previously using this method should instead create an Action wrapping the ActionListener, and register that Action by overriding installKeyboardActions and placing the Action in the SplitPane's ActionMap. Please refer to the key bindings specification for further details.

        Creates a ActionListener for the JSplitPane UI that listens for specific key presses.

      • createKeyboardResizeToggleListener

        @Deprecated
protected ActionListener createKeyboardResizeToggleListener()
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this method is no longer used. Subclassers previously using this method should instead create an Action wrapping the ActionListener, and register that Action by overriding installKeyboardActions and placing the Action in the SplitPane's ActionMap. Please refer to the key bindings specification for further details.

        Creates a ActionListener for the JSplitPane UI that listens for specific key presses.

      • getOrientation

        public int getOrientation()
        Returns the orientation for the JSplitPane.

      • setOrientation

        public void setOrientation(int orientation)
        Set the orientation for the JSplitPane.

      • isContinuousLayout

        public boolean isContinuousLayout()
        Determines wether the JSplitPane is set to use a continuous layout.

      • setContinuousLayout

        public void setContinuousLayout(boolean b)
        Turn continuous layout on/off.

      • getLastDragLocation

        public int getLastDragLocation()
        Returns the last drag location of the JSplitPane.

      • setLastDragLocation

        public void setLastDragLocation(int l)
        Set the last drag location of the JSplitPane.

      • getDivider

        public BasicSplitPaneDivider getDivider()
        Returns the divider between the top Components.

      • createDefaultNonContinuousLayoutDivider

        protected Component createDefaultNonContinuousLayoutDivider()
        Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.

      • setNonContinuousLayoutDivider

        protected void setNonContinuousLayoutDivider(Component newDivider)
        Sets the divider to use when the splitPane is configured to not continuously layout. This divider will only be used during a dragging session. It is recommended that the passed in component be a heavy weight.

      • setNonContinuousLayoutDivider

        protected void setNonContinuousLayoutDivider(Component newDivider,
                                 boolean rememberSizes)
        Sets the divider to use.

      • getNonContinuousLayoutDivider

        public Component getNonContinuousLayoutDivider()
        Returns the divider to use when the splitPane is configured to not continuously layout. This divider will only be used during a dragging session.

      • getSplitPane

        public JSplitPane getSplitPane()
        Returns the splitpane this instance is currently contained in.

      • createDefaultDivider

        public BasicSplitPaneDivider createDefaultDivider()
        Creates the default divider.

      • resetToPreferredSizes

        public void resetToPreferredSizes(JSplitPane jc)
        Messaged to reset the preferred sizes.
        指定者：
        resetToPreferredSizes in class SplitPaneUI

      • setDividerLocation

        public void setDividerLocation(JSplitPane jc,
                      int location)
        Sets the location of the divider to location.
        指定者：
        setDividerLocation in class SplitPaneUI

      • getDividerLocation

        public int getDividerLocation(JSplitPane jc)
        Returns the location of the divider, which may differ from what the splitpane thinks the location of the divider is.
        指定者：
        getDividerLocation in class SplitPaneUI

      • getMinimumDividerLocation

        public int getMinimumDividerLocation(JSplitPane jc)
        Gets the minimum location of the divider.
        指定者：
        getMinimumDividerLocation in class SplitPaneUI

      • getMaximumDividerLocation

        public int getMaximumDividerLocation(JSplitPane jc)
        Gets the maximum location of the divider.
        指定者：
        getMaximumDividerLocation in class SplitPaneUI

      • finishedPaintingChildren

        public void finishedPaintingChildren(JSplitPane sp,
                            Graphics g)
        Called when the specified split pane has finished painting its children.
        指定者：
        finishedPaintingChildren in class SplitPaneUI

      • paint

        public void paint(Graphics g,
         JComponent jc)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        jc - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent jc)
        Returns the preferred size for the passed in component, This is passed off to the current layoutmanager.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        jc - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent jc)
        Returns the minimum size for the passed in component, This is passed off to the current layoutmanager.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        jc - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent jc)
        Returns the maximum size for the passed in component, This is passed off to the current layoutmanager.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        jc - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getInsets

        public Insets getInsets(JComponent jc)
        Returns the insets. The insets are returned from the border insets of the current border.

      • resetLayoutManager

        protected void resetLayoutManager()
        Resets the layout manager based on orientation and messages it with invalidateLayout to pull in appropriate Components.

      • startDragging

        protected void startDragging()
        Should be messaged before the dragging session starts, resets lastDragLocation and dividerSize.

      • dragDividerTo

        protected void dragDividerTo(int location)
        Messaged during a dragging session to move the divider to the passed in location. If continuousLayout is true the location is reset and the splitPane validated.

      • finishDraggingTo

        protected void finishDraggingTo(int location)
        Messaged to finish the dragging session. If not continuous display the dividers location will be reset.

      • getDividerBorderSize

        @Deprecated
protected int getDividerBorderSize()
        Deprecated. As of Java 2 platform v1.3, instead set the border on the divider.
        As of Java 2 platform v1.3 this method is no longer used. Instead you should set the border on the divider.

        Returns the width of one side of the divider border.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicSplitPaneUI.BasicHorizontalLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.BasicHorizontalLayoutManager

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
  • 所有已实现的接口：
    LayoutManager, LayoutManager2
    直接已知子类：
    BasicSplitPaneUI.BasicVerticalLayoutManager
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.BasicHorizontalLayoutManager
extends Object
implements LayoutManager2
    LayoutManager for JSplitPanes that have an orientation of HORIZONTAL_SPLIT.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Component[] | components
      protected int[] | sizes

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addLayoutComponent(Component comp, Object constraints)
      Adds the specified component to the layout, using the specified constraint object.
      void addLayoutComponent(String place, Component component)
      Adds the component at place.
      protected int getAvailableSize(Dimension containerSize, Insets insets)
      Returns the available width based on the container size and Insets.
      protected int getInitialLocation(Insets insets)
      Returns the left inset, unless the Insets are null in which case 0 is returned.
      float getLayoutAlignmentX(Container target)
      Returns the alignment along the x axis.
      float getLayoutAlignmentY(Container target)
      Returns the alignment along the y axis.
      protected int getPreferredSizeOfComponent(Component c)
      Returns the width of the passed in Components preferred size.
      protected int getSizeOfComponent(Component c)
      Returns the width of the passed in component.
      protected int[] getSizes()
      Returns the sizes of the components.
      void invalidateLayout(Container c)
      Does nothing.
      void layoutContainer(Container container)
      Does the actual layout.
      Dimension maximumLayoutSize(Container target)
      Returns the maximum layout size, which is Integer.MAX_VALUE in both directions.
      Dimension minimumLayoutSize(Container container)
      Returns the minimum size needed to contain the children.
      Dimension preferredLayoutSize(Container container)
      Returns the preferred size needed to contain the children.
      void removeLayoutComponent(Component component)
      Removes the specified component from our knowledge.
      protected void resetSizeAt(int index)
      Resets the size of the Component at the passed in location.
      void resetToPreferredSizes()
      Marks the receiver so that the next time this instance is laid out it'll ask for the preferred sizes.
      protected void setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize)
      Sets the width of the component c to be size, placing its x location at location, y to the insets.top and height to the containersize.height less the top and bottom insets.
      protected void setSizes(int[] newSizes)
      Sets the sizes to newSizes.
      protected void updateComponents()
      Determines the components.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • sizes

        protected int[] sizes

      • components

        protected Component[] components

    • 方法详细信息

      • layoutContainer

        public void layoutContainer(Container container)
        Does the actual layout.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        container - the container to be laid out

      • addLayoutComponent

        public void addLayoutComponent(String place,
                      Component component)
        Adds the component at place. Place must be one of JSplitPane.LEFT, RIGHT, TOP, BOTTOM, or null (for the divider).
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        place - the string to be associated with the component
        component - the component to be added

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container container)
        Returns the minimum size needed to contain the children. The width is the sum of all the childrens min widths and the height is the largest of the childrens minimum heights.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        container - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container container)
        Returns the preferred size needed to contain the children. The width is the sum of all the childrens preferred widths and the height is the largest of the childrens preferred heights.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        container - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • removeLayoutComponent

        public void removeLayoutComponent(Component component)
        Removes the specified component from our knowledge.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        component - the component to be removed

      • addLayoutComponent

        public void addLayoutComponent(Component comp,
                      Object constraints)
        Adds the specified component to the layout, using the specified constraint object.
        指定者：
        addLayoutComponent in interface LayoutManager2
        参数：
        comp - the component to be added
        constraints - where/how the component is added to the layout.

      • getLayoutAlignmentX

        public float getLayoutAlignmentX(Container target)
        Returns the alignment along the x axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentX in interface LayoutManager2

      • getLayoutAlignmentY

        public float getLayoutAlignmentY(Container target)
        Returns the alignment along the y axis. This specifies how the component would like to be aligned relative to other components. The value should be a number between 0 and 1 where 0 represents alignment along the origin, 1 is aligned the furthest away from the origin, 0.5 is centered, etc.
        指定者：
        getLayoutAlignmentY in interface LayoutManager2

      • invalidateLayout

        public void invalidateLayout(Container c)
        Does nothing. If the developer really wants to change the size of one of the views JSplitPane.resetToPreferredSizes should be messaged.
        指定者：
        invalidateLayout in interface LayoutManager2

      • maximumLayoutSize

        public Dimension maximumLayoutSize(Container target)
        Returns the maximum layout size, which is Integer.MAX_VALUE in both directions.
        指定者：
        maximumLayoutSize in interface LayoutManager2
        另请参见：
        Component.getMaximumSize(), LayoutManager

      • resetToPreferredSizes

        public void resetToPreferredSizes()
        Marks the receiver so that the next time this instance is laid out it'll ask for the preferred sizes.

      • resetSizeAt

        protected void resetSizeAt(int index)
        Resets the size of the Component at the passed in location.

      • setSizes

        protected void setSizes(int[] newSizes)
        Sets the sizes to newSizes.

      • getSizes

        protected int[] getSizes()
        Returns the sizes of the components.

      • getPreferredSizeOfComponent

        protected int getPreferredSizeOfComponent(Component c)
        Returns the width of the passed in Components preferred size.

      • getSizeOfComponent

        protected int getSizeOfComponent(Component c)
        Returns the width of the passed in component.

      • getAvailableSize

        protected int getAvailableSize(Dimension containerSize,
                   Insets insets)
        Returns the available width based on the container size and Insets.

      • getInitialLocation

        protected int getInitialLocation(Insets insets)
        Returns the left inset, unless the Insets are null in which case 0 is returned.

      • setComponentToSize

        protected void setComponentToSize(Component c,
                      int size,
                      int location,
                      Insets insets,
                      Dimension containerSize)
        Sets the width of the component c to be size, placing its x location at location, y to the insets.top and height to the containersize.height less the top and bottom insets.

      • updateComponents

        protected void updateComponents()
        Determines the components. This should be called whenever a new instance of this is installed into an existing SplitPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


BasicSplitPaneUI.BasicVerticalLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.basic

类 BasicSplitPaneUI.BasicVerticalLayoutManager

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
  • 所有已实现的接口：
    LayoutManager, LayoutManager2
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.BasicVerticalLayoutManager
extends BasicSplitPaneUI.BasicHorizontalLayoutManager
    LayoutManager used for JSplitPanes with an orientation of VERTICAL_SPLIT.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

        components, sizes

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.BasicVerticalLayoutManager()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

        addLayoutComponent, addLayoutComponent, getAvailableSize, getInitialLocation, getLayoutAlignmentX, getLayoutAlignmentY, getPreferredSizeOfComponent, getSizeOfComponent, getSizes, invalidateLayout, layoutContainer, maximumLayoutSize, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent, resetSizeAt, resetToPreferredSizes, setComponentToSize, setSizes, updateComponents

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.BasicVerticalLayoutManager

        public BasicSplitPaneUI.BasicVerticalLayoutManager()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttmte he eoo eeeesser#iinttettnse


BasicSplitPaneUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.FocusHandler

  • java.lang.Object
    • java.awt.event.FocusAdapter
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.FocusHandler
extends FocusAdapter
    Implementation of the FocusListener that the JSplitPane UI uses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent ev)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent ev)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.FocusHandler

        public BasicSplitPaneUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent ev)
        Description copied from class: FocusAdapter
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener
        重载：
        focusGained in class FocusAdapter

      • focusLost

        public void focusLost(FocusEvent ev)
        Description copied from class: FocusAdapter
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
        重载：
        focusLost in class FocusAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

di<"n"M"l"rFeldaeatthledittmfm___i__=_etS


BasicSplitPaneUI.KeyboardDownRightHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.KeyboardDownRightHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.KeyboardDownRightHandler
extends Object
implements ActionListener
    Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.KeyboardDownRightHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ev)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.KeyboardDownRightHandler

        public BasicSplitPaneUI.KeyboardDownRightHandler()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent ev)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


BasicSplitPaneUI.KeyboardEndHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.KeyboardEndHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.KeyboardEndHandler
extends Object
implements ActionListener
    Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.KeyboardEndHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ev)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.KeyboardEndHandler

        public BasicSplitPaneUI.KeyboardEndHandler()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent ev)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i 辛斜小杏。/t> rrntn&gnoo輊&s8m


BasicSplitPaneUI.KeyboardHomeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.KeyboardHomeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.KeyboardHomeHandler
extends Object
implements ActionListener
    Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.KeyboardHomeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ev)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.KeyboardHomeHandler

        public BasicSplitPaneUI.KeyboardHomeHandler()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent ev)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/Tn莅竍e3&\;g3rb11r/rsortt>


BasicSplitPaneUI.KeyboardResizeToggleHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.KeyboardResizeToggleHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.KeyboardResizeToggleHandler
extends Object
implements ActionListener
    Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.KeyboardResizeToggleHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ev)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.KeyboardResizeToggleHandler

        public BasicSplitPaneUI.KeyboardResizeToggleHandler()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent ev)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ehCi>lm&i"


BasicSplitPaneUI.KeyboardUpLeftHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicSplitPaneUI.KeyboardUpLeftHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
  • 所有已实现的接口：
    ActionListener, EventListener
    封闭类：
    BasicSplitPaneUI

    public class BasicSplitPaneUI.KeyboardUpLeftHandler
extends Object
implements ActionListener
    Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.

    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicSplitPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicSplitPaneUI.KeyboardUpLeftHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ev)
      Invoked when an action occurs.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicSplitPaneUI.KeyboardUpLeftHandler

        public BasicSplitPaneUI.KeyboardUpLeftHandler()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent ev)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rt� r � e颁联弧裘<奔袅Ａ哩莹/纅热�


BasicTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    MetalTabbedPaneUI, SynthTabbedPaneUI

    public class BasicTabbedPaneUI
extends TabbedPaneUI
implements SwingConstants
    A Basic L&F implementation of TabbedPaneUI.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicTabbedPaneUI.FocusHandler
      This class should be treated as a "protected" inner class.
      class  BasicTabbedPaneUI.MouseHandler
      This class should be treated as a "protected" inner class.
      class  BasicTabbedPaneUI.PropertyChangeHandler
      This class should be treated as a "protected" inner class.
      class  BasicTabbedPaneUI.TabbedPaneLayout
      This class should be treated as a "protected" inner class.
      class  BasicTabbedPaneUI.TabSelectionHandler
      This class should be treated as a "protected" inner class.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Rectangle calcRect
      A rectangle used for general layout calculations in order to avoid constructing many new Rectangles on the fly.
      protected Insets | contentBorderInsets
      protected Color | darkShadow
      protected KeyStroke downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected Color | focus
      protected FocusListener | focusListener
      protected Color | highlight
      protected KeyStroke leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected Color | lightHighlight
      protected int | maxTabHeight
      protected int | maxTabWidth
      protected MouseListener | mouseListener
      protected PropertyChangeListener | propertyChangeListener
      protected Rectangle[] | rects
      protected KeyStroke rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected int | runCount
      protected int | selectedRun
      protected Insets | selectedTabPadInsets
      protected Color | shadow
      protected Insets | tabAreaInsets
      protected ChangeListener | tabChangeListener
      protected Insets | tabInsets
      protected JTabbedPane | tabPane
      protected int | tabRunOverlay
      protected int[] | tabRuns
      protected int | textIconGap
      protected KeyStroke upKey
      Deprecated.
      As of Java 2 platform v1.3.

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | assureRectsCreated(int tabCount)
      protected int | calculateMaxTabHeight(int tabPlacement)
      protected int | calculateMaxTabWidth(int tabPlacement)
      protected int | calculateTabAreaHeight(int tabPlacement, int horizRunCount, int maxTabHeight)
      protected int | calculateTabAreaWidth(int tabPlacement, int vertRunCount, int maxTabWidth)
      protected int | calculateTabHeight(int tabPlacement, int tabIndex, int fontHeight)
      protected int | calculateTabWidth(int tabPlacement, int tabIndex, FontMetrics metrics)
      protected ChangeListener | createChangeListener()
      protected FocusListener | createFocusListener()
      protected LayoutManager createLayoutManager()
      Invoked by installUI to create a layout manager object to manage the JTabbedPane.
      protected MouseListener | createMouseListener()
      protected PropertyChangeListener | createPropertyChangeListener()
      protected JButton createScrollButton(int direction)
      Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
      static ComponentUI | createUI(JComponent c)
      protected void | expandTabRunsArray()
      protected int getBaseline(int tab)
      Returns the baseline for the specified tab.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      protected int getBaselineOffset()
      Returns the amount the baseline is offset by.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected Insets | getContentBorderInsets(int tabPlacement)
      protected int getFocusIndex()
      Returns the index of the tab that has focus.
      protected FontMetrics | getFontMetrics()
      protected Icon | getIconForTab(int tabIndex)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      protected int | getNextTabIndex(int base)
      protected int | getNextTabIndexInRun(int tabCount, int base)
      protected int | getNextTabRun(int baseRun)
      protected int | getPreviousTabIndex(int base)
      protected int | getPreviousTabIndexInRun(int tabCount, int base)
      protected int | getPreviousTabRun(int baseRun)
      protected int getRolloverTab()
      Returns the tab the mouse is currently over, or -1 if the mouse is no longer over any tab.
      protected int | getRunForTab(int tabCount, int tabIndex)
      protected Insets | getSelectedTabPadInsets(int tabPlacement)
      protected Insets | getTabAreaInsets(int tabPlacement)
      protected Rectangle getTabBounds(int tabIndex, Rectangle dest)
      Returns the bounds of the specified tab in the coordinate space of the JTabbedPane component.
      Rectangle getTabBounds(JTabbedPane pane, int i)
      Returns the bounds of the specified tab index.
      protected Insets | getTabInsets(int tabPlacement, int tabIndex)
      protected int | getTabLabelShiftX(int tabPlacement, int tabIndex, boolean isSelected)
      protected int | getTabLabelShiftY(int tabPlacement, int tabIndex, boolean isSelected)
      int | getTabRunCount(JTabbedPane pane)
      protected int | getTabRunIndent(int tabPlacement, int run)
      protected int | getTabRunOffset(int tabPlacement, int tabCount, int tabIndex, boolean forward)
      protected int | getTabRunOverlay(int tabPlacement)
      protected View getTextViewForTab(int tabIndex)
      Returns the text View object required to render stylized text (HTML) for the specified tab or null if no specialized text rendering is needed for this tab.
      protected Component | getVisibleComponent()
      protected void installComponents()
      Creates and installs any required subcomponents for the JTabbedPane.
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected int | lastTabInRun(int tabCount, int run)
      protected void | layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | navigateSelectedTab(int direction)
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | paintContentBorder(Graphics g, int tabPlacement, int selectedIndex)
      protected void | paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
      protected void | paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
      protected void paintTabArea(Graphics g, int tabPlacement, int selectedIndex)
      Paints the tabs in the tab area.
      protected void | paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      protected void paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      this function draws the border around each tab note that this function does now draw the background of the tab.
      protected void | paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
      protected static void | rotateInsets(Insets topInsets, Insets targetInsets, int targetPlacement)
      protected void | selectAdjacentRunTab(int tabPlacement, int tabIndex, int offset)
      protected void | selectNextTab(int current)
      protected void | selectNextTabInRun(int current)
      protected void | selectPreviousTab(int current)
      protected void | selectPreviousTabInRun(int current)
      protected void setRolloverTab(int index)
      Sets the tab the mouse is currently over to index.
      protected void | setVisibleComponent(Component component)
      protected boolean | shouldPadTabRun(int tabPlacement, int run)
      protected boolean | shouldRotateTabRuns(int tabPlacement)
      int tabForCoordinate(JTabbedPane pane, int x, int y)
      Returns the tab index which intersects the specified point in the JTabbedPane's coordinate space.
      protected void uninstallComponents()
      Removes any installed subcomponents from the JTabbedPane.
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getPreferredSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • tabPane

        protected JTabbedPane tabPane

      • highlight

        protected Color highlight

      • lightHighlight

        protected Color lightHighlight

      • shadow

        protected Color shadow

      • darkShadow

        protected Color darkShadow

      • focus

        protected Color focus

      • textIconGap

        protected int textIconGap

      • tabRunOverlay

        protected int tabRunOverlay

      • tabInsets

        protected Insets tabInsets

      • selectedTabPadInsets

        protected Insets selectedTabPadInsets

      • tabAreaInsets

        protected Insets tabAreaInsets

      • contentBorderInsets

        protected Insets contentBorderInsets

      • upKey

        @Deprecated
protected KeyStroke upKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • downKey

        @Deprecated
protected KeyStroke downKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • leftKey

        @Deprecated
protected KeyStroke leftKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • rightKey

        @Deprecated
protected KeyStroke rightKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • tabRuns

        protected int[] tabRuns

      • runCount

        protected int runCount

      • selectedRun

        protected int selectedRun

      • rects

        protected Rectangle[] rects

      • maxTabHeight

        protected int maxTabHeight

      • maxTabWidth

        protected int maxTabWidth

      • tabChangeListener

        protected ChangeListener tabChangeListener

      • propertyChangeListener

        protected PropertyChangeListener propertyChangeListener

      • mouseListener

        protected MouseListener mouseListener

      • focusListener

        protected FocusListener focusListener

      • calcRect

        protected transient Rectangle calcRect
        A rectangle used for general layout calculations in order to avoid constructing many new Rectangles on the fly.

    • 构造方法详细信息

      • BasicTabbedPaneUI

        public BasicTabbedPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Invoked by installUI to create a layout manager object to manage the JTabbedPane.
        返回：
        a layout manager object
        另请参见：
        BasicTabbedPaneUI.TabbedPaneLayout, JTabbedPane.getTabLayoutPolicy()

      • installComponents

        protected void installComponents()
        Creates and installs any required subcomponents for the JTabbedPane. Invoked by installUI.
        从以下版本开始：
        1.4

      • createScrollButton

        protected JButton createScrollButton(int direction)
        Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction. The returned JButton must be instance of UIResource.
        参数：
        direction - One of the SwingConstants constants: SOUTH, NORTH, EAST or WEST
        返回：
        Widget for user to
        抛出：
        IllegalArgumentException - if direction is not one of NORTH, SOUTH, EAST or WEST
        从以下版本开始：
        1.5
        另请参见：
        JTabbedPane.setTabPlacement(int), SwingConstants

      • uninstallComponents

        protected void uninstallComponents()
        Removes any installed subcomponents from the JTabbedPane. Invoked by uninstallUI.
        从以下版本开始：
        1.4

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installListeners

        protected void installListeners()

      • uninstallListeners

        protected void uninstallListeners()

      • createMouseListener

        protected MouseListener createMouseListener()

      • createFocusListener

        protected FocusListener createFocusListener()

      • createChangeListener

        protected ChangeListener createChangeListener()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • setRolloverTab

        protected void setRolloverTab(int index)
        Sets the tab the mouse is currently over to index. index will be -1 if the mouse is no longer over any tab. No checking is done to ensure the passed in index identifies a valid tab.
        参数：
        index - Index of the tab the mouse is over.
        从以下版本开始：
        1.5

      • getRolloverTab

        protected int getRolloverTab()
        Returns the tab the mouse is currently over, or -1 if the mouse is no longer over any tab.
        返回：
        the tab the mouse is currently over, or -1 if the mouse is no longer over any tab
        从以下版本开始：
        1.5

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaseline

        protected int getBaseline(int tab)
        Returns the baseline for the specified tab.
        参数：
        tab - index of tab to get baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        IndexOutOfBoundsException - if index is out of range (index < 0 || index >= tab count)
        从以下版本开始：
        1.6

      • getBaselineOffset

        protected int getBaselineOffset()
        Returns the amount the baseline is offset by. This is typically the same as getTabLabelShiftY.
        返回：
        amount to offset the baseline by
        从以下版本开始：
        1.6

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintTabArea

        protected void paintTabArea(Graphics g,
                int tabPlacement,
                int selectedIndex)
        Paints the tabs in the tab area. Invoked by paint(). The graphics parameter must be a valid Graphics object. Tab placement may be either: JTabbedPane.TOP, JTabbedPane.BOTTOM, JTabbedPane.LEFT, or JTabbedPane.RIGHT. The selected index must be a valid tabbed pane tab index (0 to tab count - 1, inclusive) or -1 if no tab is currently selected. The handling of invalid parameters is unspecified.
        参数：
        g - the graphics object to use for rendering
        tabPlacement - the placement for the tabs within the JTabbedPane
        selectedIndex - the tab index of the selected component
        从以下版本开始：
        1.4

      • paintTab

        protected void paintTab(Graphics g,
            int tabPlacement,
            Rectangle[] rects,
            int tabIndex,
            Rectangle iconRect,
            Rectangle textRect)

      • layoutLabel

        protected void layoutLabel(int tabPlacement,
               FontMetrics metrics,
               int tabIndex,
               String title,
               Icon icon,
               Rectangle tabRect,
               Rectangle iconRect,
               Rectangle textRect,
               boolean isSelected)

      • paintIcon

        protected void paintIcon(Graphics g,
             int tabPlacement,
             int tabIndex,
             Icon icon,
             Rectangle iconRect,
             boolean isSelected)

      • paintText

        protected void paintText(Graphics g,
             int tabPlacement,
             Font font,
             FontMetrics metrics,
             int tabIndex,
             String title,
             Rectangle textRect,
             boolean isSelected)

      • getTabLabelShiftX

        protected int getTabLabelShiftX(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)

      • getTabLabelShiftY

        protected int getTabLabelShiftY(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)

      • paintFocusIndicator

        protected void paintFocusIndicator(Graphics g,
                       int tabPlacement,
                       Rectangle[] rects,
                       int tabIndex,
                       Rectangle iconRect,
                       Rectangle textRect,
                       boolean isSelected)

      • paintTabBorder

        protected void paintTabBorder(Graphics g,
                  int tabPlacement,
                  int tabIndex,
                  int x,
                  int y,
                  int w,
                  int h,
                  boolean isSelected)
        this function draws the border around each tab note that this function does now draw the background of the tab. that is done elsewhere

      • paintTabBackground

        protected void paintTabBackground(Graphics g,
                      int tabPlacement,
                      int tabIndex,
                      int x,
                      int y,
                      int w,
                      int h,
                      boolean isSelected)

      • paintContentBorder

        protected void paintContentBorder(Graphics g,
                      int tabPlacement,
                      int selectedIndex)

      • paintContentBorderTopEdge

        protected void paintContentBorderTopEdge(Graphics g,
                             int tabPlacement,
                             int selectedIndex,
                             int x,
                             int y,
                             int w,
                             int h)

      • paintContentBorderLeftEdge

        protected void paintContentBorderLeftEdge(Graphics g,
                              int tabPlacement,
                              int selectedIndex,
                              int x,
                              int y,
                              int w,
                              int h)

      • paintContentBorderBottomEdge

        protected void paintContentBorderBottomEdge(Graphics g,
                                int tabPlacement,
                                int selectedIndex,
                                int x,
                                int y,
                                int w,
                                int h)

      • paintContentBorderRightEdge

        protected void paintContentBorderRightEdge(Graphics g,
                               int tabPlacement,
                               int selectedIndex,
                               int x,
                               int y,
                               int w,
                               int h)

      • getTabBounds

        public Rectangle getTabBounds(JTabbedPane pane,
                     int i)
        Returns the bounds of the specified tab index. The bounds are with respect to the JTabbedPane's coordinate space.
        指定者：
        getTabBounds in class TabbedPaneUI

      • getTabRunCount

        public int getTabRunCount(JTabbedPane pane)
        指定者：
        getTabRunCount in class TabbedPaneUI

      • tabForCoordinate

        public int tabForCoordinate(JTabbedPane pane,
                   int x,
                   int y)
        Returns the tab index which intersects the specified point in the JTabbedPane's coordinate space.
        指定者：
        tabForCoordinate in class TabbedPaneUI

      • getTabBounds

        protected Rectangle getTabBounds(int tabIndex,
                     Rectangle dest)
        Returns the bounds of the specified tab in the coordinate space of the JTabbedPane component. This is required because the tab rects are by default defined in the coordinate space of the component where they are rendered, which could be the JTabbedPane (for WRAP_TAB_LAYOUT) or a ScrollableTabPanel (SCROLL_TAB_LAYOUT). This method should be used whenever the tab rectangle must be relative to the JTabbedPane itself and the result should be placed in a designated Rectangle object (rather than instantiating and returning a new Rectangle each time). The tab index parameter must be a valid tabbed pane tab index (0 to tab count - 1, inclusive). The destination rectangle parameter must be a valid Rectangle instance. The handling of invalid parameters is unspecified.
        参数：
        tabIndex - the index of the tab
        dest - the rectangle where the result should be placed
        返回：
        the resulting rectangle
        从以下版本开始：
        1.4

      • getVisibleComponent

        protected Component getVisibleComponent()

      • setVisibleComponent

        protected void setVisibleComponent(Component component)

      • assureRectsCreated

        protected void assureRectsCreated(int tabCount)

      • expandTabRunsArray

        protected void expandTabRunsArray()

      • getRunForTab

        protected int getRunForTab(int tabCount,
               int tabIndex)

      • lastTabInRun

        protected int lastTabInRun(int tabCount,
               int run)

      • getTabRunOverlay

        protected int getTabRunOverlay(int tabPlacement)

      • getTabRunIndent

        protected int getTabRunIndent(int tabPlacement,
                  int run)

      • shouldPadTabRun

        protected boolean shouldPadTabRun(int tabPlacement,
                      int run)

      • shouldRotateTabRuns

        protected boolean shouldRotateTabRuns(int tabPlacement)

      • getIconForTab

        protected Icon getIconForTab(int tabIndex)

      • getTextViewForTab

        protected View getTextViewForTab(int tabIndex)
        Returns the text View object required to render stylized text (HTML) for the specified tab or null if no specialized text rendering is needed for this tab. This is provided to support html rendering inside tabs.
        参数：
        tabIndex - the index of the tab
        返回：
        the text view to render the tab's text or null if no specialized rendering is required
        从以下版本开始：
        1.4

      • calculateTabHeight

        protected int calculateTabHeight(int tabPlacement,
                     int tabIndex,
                     int fontHeight)

      • calculateMaxTabHeight

        protected int calculateMaxTabHeight(int tabPlacement)

      • calculateTabWidth

        protected int calculateTabWidth(int tabPlacement,
                    int tabIndex,
                    FontMetrics metrics)

      • calculateMaxTabWidth

        protected int calculateMaxTabWidth(int tabPlacement)

      • calculateTabAreaHeight

        protected int calculateTabAreaHeight(int tabPlacement,
                         int horizRunCount,
                         int maxTabHeight)

      • calculateTabAreaWidth

        protected int calculateTabAreaWidth(int tabPlacement,
                        int vertRunCount,
                        int maxTabWidth)

      • getTabInsets

        protected Insets getTabInsets(int tabPlacement,
                  int tabIndex)

      • getSelectedTabPadInsets

        protected Insets getSelectedTabPadInsets(int tabPlacement)

      • getTabAreaInsets

        protected Insets getTabAreaInsets(int tabPlacement)

      • getContentBorderInsets

        protected Insets getContentBorderInsets(int tabPlacement)

      • getFontMetrics

        protected FontMetrics getFontMetrics()

      • navigateSelectedTab

        protected void navigateSelectedTab(int direction)

      • selectNextTabInRun

        protected void selectNextTabInRun(int current)

      • selectPreviousTabInRun

        protected void selectPreviousTabInRun(int current)

      • selectNextTab

        protected void selectNextTab(int current)

      • selectPreviousTab

        protected void selectPreviousTab(int current)

      • selectAdjacentRunTab

        protected void selectAdjacentRunTab(int tabPlacement,
                        int tabIndex,
                        int offset)

      • getFocusIndex

        protected int getFocusIndex()
        Returns the index of the tab that has focus.
        返回：
        index of tab that has focus
        从以下版本开始：
        1.5

      • getTabRunOffset

        protected int getTabRunOffset(int tabPlacement,
                  int tabCount,
                  int tabIndex,
                  boolean forward)

      • getPreviousTabIndex

        protected int getPreviousTabIndex(int base)

      • getNextTabIndex

        protected int getNextTabIndex(int base)

      • getNextTabIndexInRun

        protected int getNextTabIndexInRun(int tabCount,
                       int base)

      • getPreviousTabIndexInRun

        protected int getPreviousTabIndexInRun(int tabCount,
                           int base)

      • getPreviousTabRun

        protected int getPreviousTabRun(int baseRun)

      • getNextTabRun

        protected int getNextTabRun(int baseRun)

      • rotateInsets

        protected static void rotateInsets(Insets topInsets,
                Insets targetInsets,
                int targetPlacement)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicTabbedPaneUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI.FocusHandler

  • java.lang.Object
    • java.awt.event.FocusAdapter
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicTabbedPaneUI

    public class BasicTabbedPaneUI.FocusHandler
extends FocusAdapter
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTabbedPaneUI.FocusHandler

        public BasicTabbedPaneUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        Description copied from class: FocusAdapter
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener
        重载：
        focusGained in class FocusAdapter

      • focusLost

        public void focusLost(FocusEvent e)
        Description copied from class: FocusAdapter
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
        重载：
        focusLost in class FocusAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/b sa&taftpa< 浠l衋na盟l眑 c （j 塞


BasicTabbedPaneUI.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI.MouseHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicTabbedPaneUI

    public class BasicTabbedPaneUI.MouseHandler
extends MouseAdapter
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI.MouseHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTabbedPaneUI.MouseHandler

        public BasicTabbedPaneUI.MouseHandler()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>spr"oacoalssall


BasicTabbedPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicTabbedPaneUI

    public class BasicTabbedPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTabbedPaneUI.PropertyChangeHandler

        public BasicTabbedPaneUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p llklilsly.ispyi.lln Ecteenen"taeeenbaaep


BasicTabbedPaneUI.TabbedPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI.TabbedPaneLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
  • 所有已实现的接口：
    LayoutManager
    直接已知子类：
    MetalTabbedPaneUI.TabbedPaneLayout
    封闭类：
    BasicTabbedPaneUI

    public class BasicTabbedPaneUI.TabbedPaneLayout
extends Object
implements LayoutManager
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI.TabbedPaneLayout()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addLayoutComponent(String name, Component comp)
      If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
      void | calculateLayoutInfo()
      protected Dimension | calculateSize(boolean minimum)
      protected void | calculateTabRects(int tabPlacement, int tabCount)
      void layoutContainer(Container parent)
      Lays out the specified container.
      Dimension minimumLayoutSize(Container parent)
      Calculates the minimum size dimensions for the specified container, given the components it contains.
      protected void | normalizeTabRuns(int tabPlacement, int tabCount, int start, int max)
      protected void | padSelectedTab(int tabPlacement, int selectedIndex)
      protected void | padTabRun(int tabPlacement, int start, int end, int max)
      Dimension preferredLayoutSize(Container parent)
      Calculates the preferred size dimensions for the specified container, given the components it contains.
      protected int | preferredTabAreaHeight(int tabPlacement, int width)
      protected int | preferredTabAreaWidth(int tabPlacement, int height)
      void removeLayoutComponent(Component comp)
      Removes the specified component from the layout.
      protected void | rotateTabRuns(int tabPlacement, int selectedRun)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTabbedPaneUI.TabbedPaneLayout

        public BasicTabbedPaneUI.TabbedPaneLayout()

    • 方法详细信息

      • addLayoutComponent

        public void addLayoutComponent(String name,
                      Component comp)
        从接口复制的描述： LayoutManager
        If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
        指定者：
        addLayoutComponent in interface LayoutManager
        参数：
        name - the string to be associated with the component
        comp - the component to be added

      • removeLayoutComponent

        public void removeLayoutComponent(Component comp)
        从接口复制的描述： LayoutManager
        Removes the specified component from the layout.
        指定者：
        removeLayoutComponent in interface LayoutManager
        参数：
        comp - the component to be removed

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the preferred size dimensions for the specified container, given the components it contains.
        指定者：
        preferredLayoutSize in interface LayoutManager
        参数：
        parent - the container to be laid out
        另请参见：
        LayoutManager.minimumLayoutSize(java.awt.Container)

      • minimumLayoutSize

        public Dimension minimumLayoutSize(Container parent)
        从接口复制的描述： LayoutManager
        Calculates the minimum size dimensions for the specified container, given the components it contains.
        指定者：
        minimumLayoutSize in interface LayoutManager
        参数：
        parent - the component to be laid out
        另请参见：
        LayoutManager.preferredLayoutSize(java.awt.Container)

      • calculateSize

        protected Dimension calculateSize(boolean minimum)

      • preferredTabAreaHeight

        protected int preferredTabAreaHeight(int tabPlacement,
                         int width)

      • preferredTabAreaWidth

        protected int preferredTabAreaWidth(int tabPlacement,
                        int height)

      • layoutContainer

        public void layoutContainer(Container parent)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        参数：
        parent - the container to be laid out

      • calculateLayoutInfo

        public void calculateLayoutInfo()

      • calculateTabRects

        protected void calculateTabRects(int tabPlacement,
                     int tabCount)

      • rotateTabRuns

        protected void rotateTabRuns(int tabPlacement,
                 int selectedRun)

      • normalizeTabRuns

        protected void normalizeTabRuns(int tabPlacement,
                    int tabCount,
                    int start,
                    int max)

      • padTabRun

        protected void padTabRun(int tabPlacement,
             int start,
             int end,
             int max)

      • padSelectedTab

        protected void padSelectedTab(int tabPlacement,
                  int selectedIndex)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.rap>spo"mlpeso a / >=a-顳


BasicTabbedPaneUI.TabSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTabbedPaneUI.TabSelectionHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
  • 所有已实现的接口：
    EventListener, ChangeListener
    封闭类：
    BasicTabbedPaneUI

    public class BasicTabbedPaneUI.TabSelectionHandler
extends Object
implements ChangeListener
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTabbedPaneUI.TabSelectionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void stateChanged(ChangeEvent e)
      Invoked when the target of the listener has changed its state.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTabbedPaneUI.TabSelectionHandler

        public BasicTabbedPaneUI.TabSelectionHandler()

    • 方法详细信息

      • stateChanged

        public void stateChanged(ChangeEvent e)
        从接口复制的描述： ChangeListener
        Invoked when the target of the listener has changed its state.
        指定者：
        stateChanged in interface ChangeListener
        参数：
        e - a ChangeEvent object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

PsaebdcedciTTciiclaavtct/<<


BasicTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableHeaderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
  • 直接已知子类：
    SynthTableHeaderUI

    public class BasicTableHeaderUI
extends TableHeaderUI
    BasicTableHeaderUI implementation

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicTableHeaderUI.MouseInputHandler
      This inner class is marked "public" due to a compiler bug.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JTableHeader header
      The JTableHeader that is delegating the painting to this UI.
      protected MouseInputListener | mouseInputListener
      protected CellRendererPane | rendererPane

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableHeaderUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected MouseInputListener createMouseInputListener()
      Creates the mouse listener for the JTableHeader.
      static ComponentUI | createUI(JComponent h)
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Dimension getMaximumSize(JComponent c)
      Return the maximum size of the header.
      Dimension getMinimumSize(JComponent c)
      Return the minimum size of the header.
      Dimension getPreferredSize(JComponent c)
      Return the preferred size of the header.
      protected int getRolloverColumn()
      Returns the index of the column header over which the mouse currently is.
      protected void installDefaults()
      Initializes JTableHeader properties such as font, foreground, and background.
      protected void installKeyboardActions()
      Register all keyboard actions on the JTableHeader.
      protected void installListeners()
      Attaches listeners to the JTableHeader.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void rolloverColumnUpdated(int oldColumn, int newColumn)
      This method gets called every time when a rollover column in the table header is updated.
      protected void | uninstallDefaults()
      protected void uninstallKeyboardActions()
      Unregisters default key actions.
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • header

        protected JTableHeader header
        The JTableHeader that is delegating the painting to this UI.

      • rendererPane

        protected CellRendererPane rendererPane

      • mouseInputListener

        protected MouseInputListener mouseInputListener

    • 构造方法详细信息

      • BasicTableHeaderUI

        public BasicTableHeaderUI()

    • 方法详细信息

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener()
        Creates the mouse listener for the JTableHeader.

      • createUI

        public static ComponentUI createUI(JComponent h)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        Initializes JTableHeader properties such as font, foreground, and background. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        另请参见：
        installUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Attaches listeners to the JTableHeader.

      • installKeyboardActions

        protected void installKeyboardActions()
        Register all keyboard actions on the JTableHeader.

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        Unregisters default key actions.

      • getRolloverColumn

        protected int getRolloverColumn()
        Returns the index of the column header over which the mouse currently is. When the mouse is not over the table header, -1 is returned.
        返回：
        the index of the current rollover column
        从以下版本开始：
        1.6
        另请参见：
        rolloverColumnUpdated(int, int)

      • rolloverColumnUpdated

        protected void rolloverColumnUpdated(int oldColumn,
                         int newColumn)
        This method gets called every time when a rollover column in the table header is updated. Every look and feel that supports a rollover effect in a table header should override this method and repaint the header.
        参数：
        oldColumn - the index of the previous rollover column or -1 if the mouse was not over a column
        newColumn - the index of the new rollover column or -1 if the mouse is not over a column
        从以下版本开始：
        1.6
        另请参见：
        getRolloverColumn(), JTableHeader.getHeaderRect(int)

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Return the minimum size of the header. The minimum width is the sum of the minimum widths of each column (plus inter-cell spacing).
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Return the preferred size of the header. The preferred height is the maximum of the preferred heights of all of the components provided by the header renderers. The preferred width is the sum of the preferred widths of each column (plus inter-cell spacing).
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Return the maximum size of the header. The maximum width is the sum of the maximum widths of each column (plus inter-cell spacing).
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicTableHeaderUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableHeaderUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicTableHeaderUI

    public class BasicTableHeaderUI.MouseInputHandler
extends Object
implements MouseInputListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTableUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableHeaderUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTableHeaderUI.MouseInputHandler

        public BasicTableHeaderUI.MouseInputHandler()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vienophmphteehtt.i <:I


BasicTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
  • 直接已知子类：
    SynthTableUI

    public class BasicTableUI
extends TableUI
    BasicTableUI implementation

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicTableUI.FocusHandler
      This inner class is marked "public" due to a compiler bug.
      class  BasicTableUI.KeyHandler
      This inner class is marked "public" due to a compiler bug.
      class  BasicTableUI.MouseInputHandler
      This inner class is marked "public" due to a compiler bug.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected FocusListener | focusListener
      protected KeyListener | keyListener
      protected MouseInputListener | mouseInputListener
      protected CellRendererPane | rendererPane
      protected JTable | table

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected FocusListener createFocusListener()
      Creates the focus listener for handling keyboard navigation in the JTable.
      protected KeyListener createKeyListener()
      Creates the key listener for handling keyboard navigation in the JTable.
      protected MouseInputListener createMouseInputListener()
      Creates the mouse listener for the JTable.
      static ComponentUI | createUI(JComponent c)
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Dimension getMaximumSize(JComponent c)
      Return the maximum size of the table.
      Dimension getMinimumSize(JComponent c)
      Return the minimum size of the table.
      Dimension getPreferredSize(JComponent c)
      Return the preferred size of the table.
      protected void installDefaults()
      Initialize JTable properties, e.g.
      protected void installKeyboardActions()
      Register all keyboard actions on the JTable.
      protected void installListeners()
      Attaches listeners to the JTable.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paint a representation of the table instance that was set in installUI().
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • table

        protected JTable table

      • rendererPane

        protected CellRendererPane rendererPane

      • keyListener

        protected KeyListener keyListener

      • focusListener

        protected FocusListener focusListener

      • mouseInputListener

        protected MouseInputListener mouseInputListener

    • 构造方法详细信息

      • BasicTableUI

        public BasicTableUI()

    • 方法详细信息

      • createKeyListener

        protected KeyListener createKeyListener()
        Creates the key listener for handling keyboard navigation in the JTable.

      • createFocusListener

        protected FocusListener createFocusListener()
        Creates the focus listener for handling keyboard navigation in the JTable.

      • createMouseInputListener

        protected MouseInputListener createMouseInputListener()
        Creates the mouse listener for the JTable.

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        Initialize JTable properties, e.g. font, foreground, and background. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        另请参见：
        installUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Attaches listeners to the JTable.

      • installKeyboardActions

        protected void installKeyboardActions()
        Register all keyboard actions on the JTable.

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Return the minimum size of the table. The minimum height is the row height times the number of rows. The minimum width is the sum of the minimum widths of each column.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Return the preferred size of the table. The preferred height is the row height times the number of rows. The preferred width is the sum of the preferred widths of each column.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Return the maximum size of the table. The maximum height is the row heighttimes the number of rows. The maximum width is the sum of the maximum widths of each column.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paint a representation of the table instance that was set in installUI().
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicTableUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableUI.FocusHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicTableUI

    public class BasicTableUI.FocusHandler
extends Object
implements FocusListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTableUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTableUI.FocusHandler

        public BasicTableUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o>..r=et


BasicTableUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableUI.KeyHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler
  • 所有已实现的接口：
    KeyListener, EventListener
    封闭类：
    BasicTableUI

    public class BasicTableUI.KeyHandler
extends Object
implements KeyListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTableUI.

    As of Java 2 platform v1.3 this class is no longer used. Instead JTable overrides processKeyBinding to dispatch the event to the current TableCellEditor.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableUI.KeyHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void keyPressed(KeyEvent e)
      Invoked when a key has been pressed.
      void keyReleased(KeyEvent e)
      Invoked when a key has been released.
      void keyTyped(KeyEvent e)
      Invoked when a key has been typed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTableUI.KeyHandler

        public BasicTableUI.KeyHandler()

    • 方法详细信息

      • keyPressed

        public void keyPressed(KeyEvent e)
        从接口复制的描述： KeyListener
        Invoked when a key has been pressed. See the class description for KeyEvent for a definition of a key pressed event.
        指定者：
        keyPressed in interface KeyListener

      • keyReleased

        public void keyReleased(KeyEvent e)
        从接口复制的描述： KeyListener
        Invoked when a key has been released. See the class description for KeyEvent for a definition of a key released event.
        指定者：
        keyReleased in interface KeyListener

      • keyTyped

        public void keyTyped(KeyEvent e)
        从接口复制的描述： KeyListener
        Invoked when a key has been typed. See the class description for KeyEvent for a definition of a key typed event.
        指定者：
        keyTyped in interface KeyListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sssdd>


BasicTableUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTableUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicTableUI

    public class BasicTableUI.MouseInputHandler
extends Object
implements MouseInputListener
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicTableUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTableUI.MouseInputHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTableUI.MouseInputHandler

        public BasicTableUI.MouseInputHandler()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a1>薵�>�/栓�>Ia&01>g0<1sd 232/


BasicTextAreaUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTextAreaUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextAreaUI
  • 所有已实现的接口：
    ViewFactory
    直接已知子类：
    SynthTextAreaUI

    public class BasicTextAreaUI
extends BasicTextUI
    Provides the look and feel for a plain text editor. In this implementation the default UI is extended to act as a simple view factory.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextAreaUI()
      Constructs a new BasicTextAreaUI object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View create(Element elem)
      Creates the view for an element.
      static ComponentUI createUI(JComponent ta)
      Creates a UI for a JTextArea.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      Dimension getMinimumSize(JComponent c)
      The method is overridden to take into account caret width.
      Dimension getPreferredSize(JComponent c)
      The method is overridden to take into account caret width.
      protected String getPropertyPrefix()
      Fetches the name used as a key to look up properties through the UIManager.
      protected void installDefaults()
      Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getNextVisualPositionFrom, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTextAreaUI

        public BasicTextAreaUI()
        Constructs a new BasicTextAreaUI object.

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent ta)
        Creates a UI for a JTextArea.
        参数：
        ta - a text area
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to look up properties through the UIManager. This is used as a prefix to all the standard text properties.
        指定者：
        getPropertyPrefix in class BasicTextUI
        返回：
        the name ("TextArea")

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicTextUI
        Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to rebuild the View when the WrapLine or the WrapStyleWord property changes.
        重载：
        propertyChange in class BasicTextUI
        参数：
        evt - the property change event

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        The method is overridden to take into account caret width.
        重载：
        getPreferredSize in class BasicTextUI
        参数：
        c - the editor component
        返回：
        the preferred size
        抛出：
        IllegalArgumentException - if invalid value is passed
        从以下版本开始：
        1.5
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        The method is overridden to take into account caret width.
        重载：
        getMinimumSize in class BasicTextUI
        参数：
        c - the editor component
        返回：
        the minimum size
        抛出：
        IllegalArgumentException - if invalid value is passed
        从以下版本开始：
        1.5
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • create

        public View create(Element elem)
        Creates the view for an element. Returns a WrappedPlainView or PlainView.
        指定者：
        create in interface ViewFactory
        重载：
        create in class BasicTextUI
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

npe


BasicTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTextFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
  • 所有已实现的接口：
    ViewFactory
    直接已知子类：
    BasicFormattedTextFieldUI, BasicPasswordFieldUI, MetalTextFieldUI, SynthTextFieldUI

    public class BasicTextFieldUI
extends BasicTextUI
    Basis of a look and feel for a JTextField.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextFieldUI()
      Creates a new BasicTextFieldUI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View create(Element elem)
      Creates a view (FieldView) based on an element.
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JTextField.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTextFieldUI

        public BasicTextFieldUI()
        Creates a new BasicTextFieldUI.

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JTextField.
        参数：
        c - the text field
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        指定者：
        getPropertyPrefix in class BasicTextUI
        返回：
        the name ("TextField")

      • create

        public View create(Element elem)
        Creates a view (FieldView) based on an element.
        指定者：
        create in interface ViewFactory
        重载：
        create in class BasicTextUI
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

waiiraifai"nni""i.///


BasicTextPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTextPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
  • 所有已实现的接口：
    ViewFactory

    public class BasicTextPaneUI
extends BasicEditorPaneUI
    Provides the look and feel for a styled text editor.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextPaneUI()
      Creates a new BasicTextPaneUI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for the JTextPane.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.
      void installUI(JComponent c)
      Installs the UI for a component.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicEditorPaneUI

        getEditorKit, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTextPaneUI

        public BasicTextPaneUI()
        Creates a new BasicTextPaneUI.

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for the JTextPane.
        参数：
        c - the JTextPane object
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicEditorPaneUI
        返回：
        the name ("TextPane")

      • installUI

        public void installUI(JComponent c)
        Description copied from class: BasicEditorPaneUI
        Installs the UI for a component. This does the following things.
        1. Sets the associated component to opaque if the opaque property has not already been set by the client program. This will cause the component's background color to be painted.
        2. Installs the default caret and highlighter into the associated component. These properties are only set if their current value is either null or an instance of UIResource.
        3. Attaches to the editor and model. If there is no model, a default one is created.
        4. Creates the view factory and the view hierarchy used to represent the model.
        重载：
        installUI in class BasicEditorPaneUI
        参数：
        c - the editor component
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent)

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. If the font, foreground or document has changed, the the appropriate property is set in the default style of the document.
        重载：
        propertyChange in class BasicEditorPaneUI
        参数：
        evt - the property change event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t amamPmSmr<t�/>a << =dm颽<


BasicTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTextUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
  • 所有已实现的接口：
    ViewFactory
    直接已知子类：
    BasicEditorPaneUI, BasicTextAreaUI, BasicTextFieldUI, DefaultTextUI

    public abstract class BasicTextUI
extends TextUI
implements ViewFactory

    Basis of a text components look-and-feel. This provides the basic editor view and controller services that may be useful when creating a look-and-feel for an extension of JTextComponent.

    Most state is held in the associated JTextComponent as bound properties, and the UI installs default values for the various properties. This default will install something for all of the properties. Typically, a LAF implementation will do more however. At a minimum, a LAF would generally install key bindings.

    This class also provides some concurrency support if the Document associated with the JTextComponent is a subclass of AbstractDocument. Access to the View (or View hierarchy) is serialized between any thread mutating the model and the Swing event thread (which is expected to render, do model/view coordinate translation, etc). Any access to the root view should first acquire a read-lock on the AbstractDocument and release that lock in a finally block.

    An important method to define is the getPropertyPrefix() method which is used as the basis of the keys used to fetch defaults from the UIManager. The string should reflect the type of TextUI (eg. TextField, TextArea, etc) without the particular LAF part of the name (eg Metal, Motif, etc).

    To build a view of the model, one of the following strategies can be employed.

    1. One strategy is to simply redefine the ViewFactory interface in the UI. By default, this UI itself acts as the factory for View implementations. This is useful for simple factories. To do this reimplement the create(javax.swing.text.Element) method.
    2. A common strategy for creating more complex types of documents is to have the EditorKit implementation return a factory. Since the EditorKit ties all of the pieces necessary to maintain a type of document, the factory is typically an important part of that and should be produced by the EditorKit implementation.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicCaret
      static class  | BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextUI()
      Creates a new UI.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      View create(Element elem)
      Creates a view for an element.
      View create(Element elem, int p0, int p1)
      Creates a view for an element.
      protected Caret createCaret()
      Creates the object to use for a caret.
      protected Highlighter createHighlighter()
      Creates the object to use for adding highlights.
      protected Keymap createKeymap()
      Creates the keymap to use for the text component, and installs any necessary bindings into it.
      void damageRange(JTextComponent tc, int p0, int p1)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      void damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      protected JTextComponent getComponent()
      Fetches the text component associated with this UI implementation.
      EditorKit getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.
      protected String getKeymapName()
      Fetches the name of the keymap that will be installed/used by default for this UI.
      Dimension getMaximumSize(JComponent c)
      Gets the maximum size for the editor component.
      Dimension getMinimumSize(JComponent c)
      Gets the minimum size for the editor component.
      int getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      Dimension getPreferredSize(JComponent c)
      Gets the preferred size for the editor component.
      protected abstract String getPropertyPrefix()
      Gets the name used as a key to look up properties through the UIManager.
      View getRootView(JTextComponent tc)
      Fetches a View with the allocation of the associated text component (i.e.
      String getToolTipText(JTextComponent t, Point pt)
      Returns the string to be used as the tooltip at the passed in location.
      protected Rectangle getVisibleEditorRect()
      Gets the allocation to give the root View.
      protected void installDefaults()
      Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
      protected void | installKeyboardActions()
      protected void installListeners()
      Installs listeners for the UI.
      void installUI(JComponent c)
      Installs the UI for a component.
      protected void modelChanged()
      Flags model changes.
      Rectangle modelToView(JTextComponent tc, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      Rectangle modelToView(JTextComponent tc, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      void paint(Graphics g, JComponent c)
      Paints the interface.
      protected void paintBackground(Graphics g)
      Paints a background for the view.
      protected void paintSafely(Graphics g)
      Paints the interface safely with a guarantee that the model won't change from the view of this thread.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.
      protected void setView(View v)
      Sets the current root of the view hierarchy and calls invalidate().
      protected void uninstallDefaults()
      Sets the component properties that have not been explicitly overridden to null.
      protected void | uninstallKeyboardActions()
      protected void uninstallListeners()
      Uninstalls listeners for the UI.
      void uninstallUI(JComponent c)
      Deinstalls the UI for a component.
      void update(Graphics g, JComponent c)
      Superclass paints background in an uncontrollable way (i.e.
      int viewToModel(JTextComponent tc, Point pt)
      Converts the given place in the view coordinate system to the nearest representative location in the model.
      int viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn)
      Converts the given place in the view coordinate system to the nearest representative location in the model.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTextUI

        public BasicTextUI()
        Creates a new UI.

    • 方法详细信息

      • createCaret

        protected Caret createCaret()
        Creates the object to use for a caret. By default an instance of BasicCaret is created. This method can be redefined to provide something else that implements the InputPosition interface or a subclass of JCaret.
        返回：
        the caret object

      • createHighlighter

        protected Highlighter createHighlighter()
        Creates the object to use for adding highlights. By default an instance of BasicHighlighter is created. This method can be redefined to provide something else that implements the Highlighter interface or a subclass of DefaultHighlighter.
        返回：
        the highlighter

      • getKeymapName

        protected String getKeymapName()
        Fetches the name of the keymap that will be installed/used by default for this UI. This is implemented to create a name based upon the classname. The name is the the name of the class with the package prefix removed.
        返回：
        the name

      • createKeymap

        protected Keymap createKeymap()
        Creates the keymap to use for the text component, and installs any necessary bindings into it. By default, the keymap is shared between all instances of this type of TextUI. The keymap has the name defined by the getKeymapName method. If the keymap is not found, then DEFAULT_KEYMAP from JTextComponent is used.

        The set of bindings used to create the keymap is fetched from the UIManager using a key formed by combining the getPropertyPrefix() method and the string .keyBindings. The type is expected to be JTextComponent.KeyBinding[].

        返回：
        the keymap
        另请参见：
        getKeymapName(), JTextComponent

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to do nothing (i.e. the response to properties in JTextComponent itself are handled prior to calling this method). This implementation updates the background of the text component if the editable and/or enabled state changes.
        参数：
        evt - the property change event

      • getPropertyPrefix

        protected abstract String getPropertyPrefix()
        Gets the name used as a key to look up properties through the UIManager. This is used as a prefix to all the standard text properties.
        返回：
        the name

      • installDefaults

        protected void installDefaults()
        Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        另请参见：
        uninstallDefaults(), installUI(javax.swing.JComponent)

      • uninstallDefaults

        protected void uninstallDefaults()
        Sets the component properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        另请参见：
        installDefaults(), uninstallUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Installs listeners for the UI.

      • uninstallListeners

        protected void uninstallListeners()
        Uninstalls listeners for the UI.

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • paintBackground

        protected void paintBackground(Graphics g)
        Paints a background for the view. This will only be called if isOpaque() on the associated component is true. The default is to paint the background color of the component.
        参数：
        g - the graphics context

      • getComponent

        protected final JTextComponent getComponent()
        Fetches the text component associated with this UI implementation. This will be null until the ui has been installed.
        返回：
        the editor component

      • modelChanged

        protected void modelChanged()
        Flags model changes. This is called whenever the model has changed. It is implemented to rebuild the view hierarchy to represent the default root element of the associated model.

      • setView

        protected final void setView(View v)
        Sets the current root of the view hierarchy and calls invalidate(). If there were any child components, they will be removed (i.e. there are assumed to have come from components embedded in views).
        参数：
        v - the root view

      • paintSafely

        protected void paintSafely(Graphics g)
        Paints the interface safely with a guarantee that the model won't change from the view of this thread. This does the following things, rendering from back to front.
        1. If the component is marked as opaque, the background is painted in the current background color of the component.
        2. The highlights (if any) are painted.
        3. The view hierarchy is painted.
        4. The caret is painted.
        参数：
        g - the graphics context

      • installUI

        public void installUI(JComponent c)
        Installs the UI for a component. This does the following things.
        1. Sets the associated component to opaque if the opaque property has not already been set by the client program. This will cause the component's background color to be painted.
        2. Installs the default caret and highlighter into the associated component. These properties are only set if their current value is either null or an instance of UIResource.
        3. Attaches to the editor and model. If there is no model, a default one is created.
        4. Creates the view factory and the view hierarchy used to represent the model.
        重载：
        installUI in class ComponentUI
        参数：
        c - the editor component
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent)

      • uninstallUI

        public void uninstallUI(JComponent c)
        Deinstalls the UI for a component. This removes the listeners, uninstalls the highlighter, removes views, and nulls out the keymap.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the editor component
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent)

      • update

        public void update(Graphics g,
          JComponent c)
        Superclass paints background in an uncontrollable way (i.e. one might want an image tiled into the background). To prevent this from happening twice, this method is reimplemented to simply paint.

        NOTE: NOTE: Superclass is also not thread-safe in its rendering of the background, although that is not an issue with the default rendering.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • paint

        public final void paint(Graphics g,
         JComponent c)
        Paints the interface. This is routed to the paintSafely method under the guarantee that the model won't change from the view of this thread while it's rendering (if the associated model is derived from AbstractDocument). This enables the model to potentially be updated asynchronously.
        重载：
        paint in class ComponentUI
        参数：
        g - the graphics context
        c - the editor component
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Gets the preferred size for the editor component. If the component has been given a size prior to receiving this request, it will set the size of the view hierarchy to reflect the size of the component before requesting the preferred size of the view hierarchy. This allows formatted views to format to the current component size before answering the request. Other views don't care about currently formatted size and give the same answer either way.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the editor component
        返回：
        the size
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Gets the minimum size for the editor component.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the editor component
        返回：
        the size
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Gets the maximum size for the editor component.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the editor component
        返回：
        the size
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getVisibleEditorRect

        protected Rectangle getVisibleEditorRect()
        Gets the allocation to give the root View. Due to an unfortunate set of historical events this method is inappropriately named. The Rectangle returned has nothing to do with visibility. The component must have a non-zero positive size for this translation to be computed.
        返回：
        the bounding box for the root view

      • modelToView

        public Rectangle modelToView(JTextComponent tc,
                    int pos)
                      throws BadLocationException
        Converts the given location in the model to a place in the view coordinate system. The component must have a non-zero positive size for this translation to be computed.
        指定者：
        modelToView in class TextUI
        参数：
        tc - the text component for which this UI is installed
        pos - the local location in the model to translate >= 0
        返回：
        the coordinates as a rectangle, null if the model is not painted
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        TextUI.modelToView(javax.swing.text.JTextComponent, int)

      • modelToView

        public Rectangle modelToView(JTextComponent tc,
                    int pos,
                    Position.Bias bias)
                      throws BadLocationException
        Converts the given location in the model to a place in the view coordinate system. The component must have a non-zero positive size for this translation to be computed.
        指定者：
        modelToView in class TextUI
        参数：
        tc - the text component for which this UI is installed
        pos - the local location in the model to translate >= 0
        返回：
        the coordinates as a rectangle, null if the model is not painted
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        TextUI.modelToView(javax.swing.text.JTextComponent, int)

      • viewToModel

        public int viewToModel(JTextComponent tc,
              Point pt)
        Converts the given place in the view coordinate system to the nearest representative location in the model. The component must have a non-zero positive size for this translation to be computed.
        指定者：
        viewToModel in class TextUI
        参数：
        tc - the text component for which this UI is installed
        pt - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        返回：
        the offset from the start of the document >= 0, -1 if not painted
        另请参见：
        TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

      • viewToModel

        public int viewToModel(JTextComponent tc,
              Point pt,
              Position.Bias[] biasReturn)
        Converts the given place in the view coordinate system to the nearest representative location in the model. The component must have a non-zero positive size for this translation to be computed.
        指定者：
        viewToModel in class TextUI
        参数：
        tc - the text component for which this UI is installed
        pt - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        biasReturn - filled in by this method to indicate whether the point given is closer to the previous or the next character in the model
        返回：
        the offset from the start of the document >= 0, -1 if the component doesn't yet have a positive size.
        另请参见：
        TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(JTextComponent t,
                            int pos,
                            Position.Bias b,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        指定者：
        getNextVisualPositionFrom in class TextUI
        参数：
        t - the text component for which this UI is installed
        pos - the position to convert >= 0
        b - the bias for the position
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This may be SwingConstants.WEST, SwingConstants.EAST, SwingConstants.NORTH, or SwingConstants.SOUTH
        biasRet - an array to contain the bias for the returned position
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException

      • damageRange

        public void damageRange(JTextComponent tc,
               int p0,
               int p1)
        Causes the portion of the view responsible for the given part of the model to be repainted. Does nothing if the view is not currently painted.
        指定者：
        damageRange in class TextUI
        参数：
        tc - the text component for which this UI is installed
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0
        另请参见：
        TextUI.damageRange(javax.swing.text.JTextComponent, int, int)

      • damageRange

        public void damageRange(JTextComponent t,
               int p0,
               int p1,
               Position.Bias p0Bias,
               Position.Bias p1Bias)
        Causes the portion of the view responsible for the given part of the model to be repainted.
        指定者：
        damageRange in class TextUI
        参数：
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0

      • getEditorKit

        public EditorKit getEditorKit(JTextComponent tc)
        Fetches the EditorKit for the UI.
        指定者：
        getEditorKit in class TextUI
        参数：
        tc - the text component for which this UI is installed
        返回：
        the editor capabilities
        另请参见：
        TextUI.getEditorKit(javax.swing.text.JTextComponent)

      • getRootView

        public View getRootView(JTextComponent tc)
        Fetches a View with the allocation of the associated text component (i.e. the root of the hierarchy) that can be traversed to determine how the model is being represented spatially.

        NOTE:The View hierarchy can be traversed from the root view, and other things can be done as well. Things done in this way cannot be protected like simple method calls through the TextUI. Therefore, proper operation in the presence of concurrency must be arranged by any logic that calls this method!

        指定者：
        getRootView in class TextUI
        参数：
        tc - the text component for which this UI is installed
        返回：
        the view
        另请参见：
        TextUI.getRootView(javax.swing.text.JTextComponent)

      • getToolTipText

        public String getToolTipText(JTextComponent t,
                    Point pt)
        Returns the string to be used as the tooltip at the passed in location. This forwards the method onto the root View.
        重载：
        getToolTipText in class TextUI
        从以下版本开始：
        1.4
        另请参见：
        JTextComponent.getToolTipText(java.awt.event.MouseEvent), View.getToolTipText(float, float, java.awt.Shape)

      • create

        public View create(Element elem)
        Creates a view for an element. If a subclass wishes to directly implement the factory producing the view(s), it should reimplement this method. By default it simply returns null indicating it is unable to represent the element.
        指定者：
        create in interface ViewFactory
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View

      • create

        public View create(Element elem,
          int p0,
          int p1)
        Creates a view for an element. If a subclass wishes to directly implement the factory producing the view(s), it should reimplement this method. By default it simply returns null indicating it is unable to represent the part of the element.
        参数：
        elem - the element
        p0 - the starting offset >= 0
        p1 - the ending offset >= p0
        返回：
        the view
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicTextUI.BasicCaret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.basic

类 BasicTextUI.BasicCaret

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle
          • javax.swing.text.DefaultCaret
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret
  • 所有已实现的接口：
    FocusListener, MouseListener, MouseMotionListener, Shape, Serializable, Cloneable, EventListener, UIResource, Caret
    封闭类：
    BasicTextUI

    public static class BasicTextUI.BasicCaret
extends DefaultCaret
implements UIResource

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.geom.Rectangle2D

        Rectangle2D.Double, Rectangle2D.Float

    • 字段摘要

      • Fields inherited from class javax.swing.text.DefaultCaret

        ALWAYS_UPDATE, changeEvent, listenerList, NEVER_UPDATE, UPDATE_WHEN_ON_EDT

      • Fields inherited from class java.awt.Rectangle

        height, width, x, y

      • Fields inherited from class java.awt.geom.Rectangle2D

        OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextUI.BasicCaret()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.DefaultCaret

        addChangeListener, adjustVisibility, damage, deinstall, equals, fireStateChanged, focusGained, focusLost, getBlinkRate, getChangeListeners, getComponent, getDot, getDotBias, getListeners, getMagicCaretPosition, getMark, getMarkBias, getSelectionPainter, getUpdatePolicy, install, isActive, isSelectionVisible, isVisible, mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, moveCaret, moveDot, moveDot, paint, positionCaret, removeChangeListener, repaint, setBlinkRate, setDot, setDot, setMagicCaretPosition, setSelectionVisible, setUpdatePolicy, setVisible, toString

      • 方法 - 继承于类 java.awt.Rectangle

        add, add, add, contains, contains, contains, contains, createIntersection, createUnion, getBounds, getBounds2D, getHeight, getLocation, getSize, getWidth, getX, getY, grow, inside, intersection, intersects, isEmpty, move, outcode, reshape, resize, setBounds, setBounds, setLocation, setLocation, setRect, setSize, setSize, translate, union

      • 方法 - 继承于类 java.awt.geom.Rectangle2D

        add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union

      • 方法 - 继承于类 java.awt.geom.RectangularShape

        clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.awt.Shape

        contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

    • 构造方法详细信息

      • BasicTextUI.BasicCaret

        public BasicTextUI.BasicCaret()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>p" -/ " p s/=輑 RRo l�9t豣�.lemv逶"�


BasicTextUI.BasicHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.basic

类 BasicTextUI.BasicHighlighter

  • java.lang.Object
    • javax.swing.text.LayeredHighlighter
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
  • 所有已实现的接口：
    UIResource, Highlighter
    封闭类：
    BasicTextUI

    public static class BasicTextUI.BasicHighlighter
extends DefaultHighlighter
implements UIResource

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultHighlighter

        DefaultHighlighter.DefaultHighlightPainter

      • Nested classes/interfaces inherited from class javax.swing.text.LayeredHighlighter

        LayeredHighlighter.LayerPainter

      • Nested classes/interfaces inherited from interface javax.swing.text.Highlighter

        Highlighter.Highlight, Highlighter.HighlightPainter

    • 字段摘要

      • Fields inherited from class javax.swing.text.DefaultHighlighter

        DefaultPainter

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTextUI.BasicHighlighter()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.DefaultHighlighter

        addHighlight, changeHighlight, deinstall, getDrawsLayeredHighlights, getHighlights, install, paint, paintLayeredHighlights, removeAllHighlights, removeHighlight, setDrawsLayeredHighlights

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTextUI.BasicHighlighter

        public BasicTextUI.BasicHighlighter()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ta../e./erfferr aaanidm dn)/d/ aa.< ,t


BasicToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToggleButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
  • 直接已知子类：
    BasicRadioButtonUI, MetalToggleButtonUI

    public class BasicToggleButtonUI
extends BasicButtonUI
    BasicToggleButton implementation

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicToggleButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      protected String | getPropertyPrefix()
      protected int getTextShiftOffset()
      Overriden so that the text will not be rendered as shifted for Toggle buttons and subclasses.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, installDefaults, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToggleButtonUI

        public BasicToggleButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicButtonUI

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicButtonUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintIcon

        protected void paintIcon(Graphics g,
             AbstractButton b,
             Rectangle iconRect)

      • getTextShiftOffset

        protected int getTextShiftOffset()
        Overriden so that the text will not be rendered as shifted for Toggle buttons and subclasses.
        重载：
        getTextShiftOffset in class BasicButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> t>csCsoc


BasicToolBarSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI

  • public class BasicToolBarSeparatorUI
extends BasicSeparatorUI
    A Basic L&F implementation of ToolBarSeparatorUI. This implementation is a "combined" view/controller.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSeparatorUI

        highlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicToolBarSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JSeparator s)
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSeparatorUI

        getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolBarSeparatorUI

        public BasicToolBarSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        protected void installDefaults(JSeparator s)
        重载：
        installDefaults in class BasicSeparatorUI

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicSeparatorUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicSeparatorUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s<>e>a>>>a/i> <縭r."h.f/..nl?vnagaasntv"


BasicToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    MetalToolBarUI, SynthToolBarUI

    public class BasicToolBarUI
extends ToolBarUI
implements SwingConstants
    A Basic L&F implementation of ToolBarUI. This implementation is a "combined" view/controller.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      class  BasicToolBarUI.DockingListener
      This class should be treated as a "protected" inner class.
      protected class  | BasicToolBarUI.DragWindow
      protected class  | BasicToolBarUI.FrameListener
      protected class  | BasicToolBarUI.PropertyListener
      protected class  | BasicToolBarUI.ToolBarContListener
      protected class  | BasicToolBarUI.ToolBarFocusListener

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected String | constraintBeforeFloating
      protected Color | dockingBorderColor
      protected Color | dockingColor
      protected MouseInputListener | dockingListener
      protected KeyStroke downKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected BasicToolBarUI.DragWindow | dragWindow
      protected Color | floatingBorderColor
      protected Color | floatingColor
      protected int | focusedCompIndex
      protected KeyStroke leftKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected PropertyChangeListener | propertyListener
      protected KeyStroke rightKey
      Deprecated.
      As of Java 2 platform v1.3.
      protected JToolBar | toolBar
      protected ContainerListener | toolBarContListener
      protected FocusListener | toolBarFocusListener
      protected KeyStroke upKey
      Deprecated.
      As of Java 2 platform v1.3.

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicToolBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      boolean | canDock(Component c, Point p)
      protected MouseInputListener | createDockingListener()
      protected BasicToolBarUI.DragWindow | createDragWindow(JToolBar toolbar)
      protected JFrame createFloatingFrame(JToolBar toolbar)
      No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
      protected RootPaneContainer createFloatingWindow(JToolBar toolbar)
      Creates a window which contains the toolbar after it has been dragged out from its container
      protected WindowListener | createFrameListener()
      protected Border createNonRolloverBorder()
      Creates the non rollover border for toolbar components.
      protected PropertyChangeListener | createPropertyListener()
      protected Border createRolloverBorder()
      Creates a rollover border for toolbar components.
      protected ContainerListener | createToolBarContListener()
      protected FocusListener | createToolBarFocusListener()
      static ComponentUI | createUI(JComponent c)
      protected void | dragTo(Point position, Point origin)
      protected void | floatAt(Point position, Point origin)
      Color getDockingColor()
      Gets the color displayed when over a docking area
      Color getFloatingColor()
      Gets the color displayed when over a floating area
      protected Border getNonRolloverBorder(AbstractButton b)
      Returns a non-rollover border for the button.
      protected Border getRolloverBorder(AbstractButton b)
      Returns a rollover border for the button.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      protected void installNonRolloverBorders(JComponent c)
      Installs non-rollover borders on all the child components of the JComponent.
      protected void installNormalBorders(JComponent c)
      Installs normal borders on all the child components of the JComponent.
      protected void installRolloverBorders(JComponent c)
      Installs rollover borders on all the child components of the JComponent.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      boolean | isFloating()
      boolean isRolloverBorders()
      Returns a flag to determine whether rollover button borders are enabled.
      protected void | navigateFocusedComp(int direction)
      protected void paintDragWindow(Graphics g)
      Paints the contents of the window used for dragging.
      protected void setBorderToNonRollover(Component c)
      Sets the border of the component to have a non-rollover border which was created by the createNonRolloverBorder() method.
      protected void setBorderToNormal(Component c)
      Sets the border of the component to have a normal border.
      protected void setBorderToRollover(Component c)
      Sets the border of the component to have a rollover border which was created by the createRolloverBorder() method.
      void setDockingColor(Color c)
      Sets the color displayed when over a docking area
      void | setFloating(boolean b, Point p)
      void setFloatingColor(Color c)
      Sets the color displayed when over a floating area
      void | setFloatingLocation(int x, int y)
      void | setOrientation(int orientation)
      void setRolloverBorders(boolean rollover)
      Sets the flag for enabling rollover borders on the toolbar and it will also install the apropriate border depending on the state of the flag.
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • toolBar

        protected JToolBar toolBar

      • dragWindow

        protected BasicToolBarUI.DragWindow dragWindow

      • focusedCompIndex

        protected int focusedCompIndex

      • dockingColor

        protected Color dockingColor

      • floatingColor

        protected Color floatingColor

      • dockingBorderColor

        protected Color dockingBorderColor

      • floatingBorderColor

        protected Color floatingBorderColor

      • dockingListener

        protected MouseInputListener dockingListener

      • propertyListener

        protected PropertyChangeListener propertyListener

      • toolBarContListener

        protected ContainerListener toolBarContListener

      • toolBarFocusListener

        protected FocusListener toolBarFocusListener

      • constraintBeforeFloating

        protected String constraintBeforeFloating

      • upKey

        @Deprecated
protected KeyStroke upKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • downKey

        @Deprecated
protected KeyStroke downKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • leftKey

        @Deprecated
protected KeyStroke leftKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

      • rightKey

        @Deprecated
protected KeyStroke rightKey
        Deprecated. As of Java 2 platform v1.3.
        As of Java 2 platform v1.3 this previously undocumented field is no longer used. Key bindings are now defined by the LookAndFeel, please refer to the key bindings specification for further details.

    • 构造方法详细信息

      • BasicToolBarUI

        public BasicToolBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()

      • uninstallDefaults

        protected void uninstallDefaults()

      • installComponents

        protected void installComponents()

      • uninstallComponents

        protected void uninstallComponents()

      • installListeners

        protected void installListeners()

      • uninstallListeners

        protected void uninstallListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • navigateFocusedComp

        protected void navigateFocusedComp(int direction)

      • createRolloverBorder

        protected Border createRolloverBorder()
        Creates a rollover border for toolbar components. The rollover border will be installed if rollover borders are enabled.

        Override this method to provide an alternate rollover border.

        从以下版本开始：
        1.4

      • createNonRolloverBorder

        protected Border createNonRolloverBorder()
        Creates the non rollover border for toolbar components. This border will be installed as the border for components added to the toolbar if rollover borders are not enabled.

        Override this method to provide an alternate rollover border.

        从以下版本开始：
        1.4

      • createFloatingFrame

        protected JFrame createFloatingFrame(JToolBar toolbar)
        No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
        另请参见：
        createFloatingWindow(javax.swing.JToolBar)

      • createFloatingWindow

        protected RootPaneContainer createFloatingWindow(JToolBar toolbar)
        Creates a window which contains the toolbar after it has been dragged out from its container
        返回：
        a RootPaneContainer object, containing the toolbar.
        从以下版本开始：
        1.4

      • createDragWindow

        protected BasicToolBarUI.DragWindow createDragWindow(JToolBar toolbar)

      • isRolloverBorders

        public boolean isRolloverBorders()
        Returns a flag to determine whether rollover button borders are enabled.
        返回：
        true if rollover borders are enabled; false otherwise
        从以下版本开始：
        1.4
        另请参见：
        setRolloverBorders(boolean)

      • setRolloverBorders

        public void setRolloverBorders(boolean rollover)
        Sets the flag for enabling rollover borders on the toolbar and it will also install the apropriate border depending on the state of the flag.
        参数：
        rollover - if true, rollover borders are installed. Otherwise non-rollover borders are installed
        从以下版本开始：
        1.4
        另请参见：
        isRolloverBorders()

      • installRolloverBorders

        protected void installRolloverBorders(JComponent c)
        Installs rollover borders on all the child components of the JComponent.

        This is a convenience method to call setBorderToRollover for each child component.

        参数：
        c - container which holds the child components (usally a JToolBar)
        从以下版本开始：
        1.4
        另请参见：
        setBorderToRollover(java.awt.Component)

      • installNonRolloverBorders

        protected void installNonRolloverBorders(JComponent c)
        Installs non-rollover borders on all the child components of the JComponent. A non-rollover border is the border that is installed on the child component while it is in the toolbar.

        This is a convenience method to call setBorderToNonRollover for each child component.

        参数：
        c - container which holds the child components (usally a JToolBar)
        从以下版本开始：
        1.4
        另请参见：
        setBorderToNonRollover(java.awt.Component)

      • installNormalBorders

        protected void installNormalBorders(JComponent c)
        Installs normal borders on all the child components of the JComponent. A normal border is the original border that was installed on the child component before it was added to the toolbar.

        This is a convenience method to call setBorderNormal for each child component.

        参数：
        c - container which holds the child components (usally a JToolBar)
        从以下版本开始：
        1.4
        另请参见：
        setBorderToNonRollover(java.awt.Component)

      • setBorderToRollover

        protected void setBorderToRollover(Component c)
        Sets the border of the component to have a rollover border which was created by the createRolloverBorder() method.
        参数：
        c - component which will have a rollover border installed
        从以下版本开始：
        1.4
        另请参见：
        createRolloverBorder()

      • getRolloverBorder

        protected Border getRolloverBorder(AbstractButton b)
        Returns a rollover border for the button.
        参数：
        b - the button to calculate the rollover border for
        返回：
        the rollover border
        从以下版本开始：
        1.6
        另请参见：
        setBorderToRollover(java.awt.Component)

      • setBorderToNonRollover

        protected void setBorderToNonRollover(Component c)
        Sets the border of the component to have a non-rollover border which was created by the createNonRolloverBorder() method.
        参数：
        c - component which will have a non-rollover border installed
        从以下版本开始：
        1.4
        另请参见：
        createNonRolloverBorder()

      • getNonRolloverBorder

        protected Border getNonRolloverBorder(AbstractButton b)
        Returns a non-rollover border for the button.
        参数：
        b - the button to calculate the non-rollover border for
        返回：
        the non-rollover border
        从以下版本开始：
        1.6
        另请参见：
        setBorderToNonRollover(java.awt.Component)

      • setBorderToNormal

        protected void setBorderToNormal(Component c)
        Sets the border of the component to have a normal border. A normal border is the original border that was installed on the child component before it was added to the toolbar.
        参数：
        c - component which will have a normal border re-installed
        从以下版本开始：
        1.4
        另请参见：
        createNonRolloverBorder()

      • setFloatingLocation

        public void setFloatingLocation(int x,
                       int y)

      • isFloating

        public boolean isFloating()

      • setFloating

        public void setFloating(boolean b,
               Point p)

      • setOrientation

        public void setOrientation(int orientation)

      • getDockingColor

        public Color getDockingColor()
        Gets the color displayed when over a docking area

      • setDockingColor

        public void setDockingColor(Color c)
        Sets the color displayed when over a docking area

      • getFloatingColor

        public Color getFloatingColor()
        Gets the color displayed when over a floating area

      • setFloatingColor

        public void setFloatingColor(Color c)
        Sets the color displayed when over a floating area

      • canDock

        public boolean canDock(Component c,
              Point p)

      • dragTo

        protected void dragTo(Point position,
          Point origin)

      • floatAt

        protected void floatAt(Point position,
           Point origin)

      • createToolBarContListener

        protected ContainerListener createToolBarContListener()

      • createToolBarFocusListener

        protected FocusListener createToolBarFocusListener()

      • createPropertyListener

        protected PropertyChangeListener createPropertyListener()

      • createDockingListener

        protected MouseInputListener createDockingListener()

      • createFrameListener

        protected WindowListener createFrameListener()

      • paintDragWindow

        protected void paintDragWindow(Graphics g)
        Paints the contents of the window used for dragging.
        参数：
        g - Graphics to paint to.
        抛出：
        NullPointerException - is g is null
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicToolBarUI.DockingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.DockingListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    直接已知子类：
    MetalToolBarUI.MetalDockingListener
    封闭类：
    BasicToolBarUI

    public class BasicToolBarUI.DockingListener
extends Object
implements MouseInputListener
    This class should be treated as a "protected" inner class. Instantiate it only within subclasses of BasicToolBarUI.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean | isDragging
      protected Point | origin
      protected JToolBar | toolBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicToolBarUI.DockingListener(JToolBar t)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • toolBar

        protected JToolBar toolBar

      • isDragging

        protected boolean isDragging

      • origin

        protected Point origin

    • 构造方法详细信息

      • BasicToolBarUI.DockingListener

        public BasicToolBarUI.DockingListener(JToolBar t)

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bmoe< ea <>//<>>ige"aa>m"an"docbld=ra


BasicToolBarUI.DragWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.DragWindow

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • java.awt.Window
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible
    封闭类：
    BasicToolBarUI

    protected class BasicToolBarUI.DragWindow
extends Window

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Window

        Window.AccessibleAWTWindow, Window.Type

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Color getBorderColor()
      Insets getInsets()
      Determines the insets of this container, which indicate the size of the container's border.
      Point getOffset()
      int getOrientation()
      Returns the orientation of the toolbar window when the toolbar is floating.
      void paint(Graphics g)
      Paints the container.
      void | setBorderColor(Color c)
      void | setOffset(Point p)
      void | setOrientation(int o)

      • 方法 - 继承于类 java.awt.Window

        addNotify, addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getAccessibleContext, getBackground, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOpacity, getOwnedWindows, getOwner, getOwnerlessWindows, getShape, getToolkit, getType, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isAutoRequestFocus, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isOpaque, isShowing, isValidateRoot, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setAutoRequestFocus, setBackground, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setOpacity, setShape, setSize, setSize, setType, setVisible, show, toBack, toFront

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getOrientation

        public int getOrientation()
        Returns the orientation of the toolbar window when the toolbar is floating. The orientation is either one of JToolBar.HORIZONTAL or JToolBar.VERTICAL.
        返回：
        the orientation of the toolbar window
        从以下版本开始：
        1.6

      • setOrientation

        public void setOrientation(int o)

      • getOffset

        public Point getOffset()

      • setOffset

        public void setOffset(Point p)

      • setBorderColor

        public void setBorderColor(Color c)

      • getBorderColor

        public Color getBorderColor()

      • paint

        public void paint(Graphics g)
        Description copied from class: Window
        Paints the container. This forwards the paint to any lightweight components that are children of this container. If this method is reimplemented, super.paint(g) should be called so that lightweight components are properly rendered. If a child component is entirely clipped by the current clipping setting in g, paint() will not be forwarded to that child.
        重载：
        paint in class Window
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • getInsets

        public Insets getInsets()
        Description copied from class: Container
        Determines the insets of this container, which indicate the size of the container's border.

        A Frame object, for example, has a top inset that corresponds to the height of the frame's title bar.

        重载：
        getInsets in class Container
        返回：
        the insets of this container.
        另请参见：
        Insets, LayoutManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


BasicToolBarUI.FrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.FrameListener

  • java.lang.Object
    • java.awt.event.WindowAdapter
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener
  • 所有已实现的接口：
    WindowFocusListener, WindowListener, WindowStateListener, EventListener
    封闭类：
    BasicToolBarUI

    protected class BasicToolBarUI.FrameListener
extends WindowAdapter

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicToolBarUI.FrameListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void windowClosing(WindowEvent w)
      Invoked when a window is in the process of being closed.

      • 方法 - 继承于类 java.awt.event.WindowAdapter

        windowActivated, windowClosed, windowDeactivated, windowDeiconified, windowGainedFocus, windowIconified, windowLostFocus, windowOpened, windowStateChanged

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolBarUI.FrameListener

        protected BasicToolBarUI.FrameListener()

    • 方法详细信息

      • windowClosing

        public void windowClosing(WindowEvent w)
        Description copied from class: WindowAdapter
        Invoked when a window is in the process of being closed. The close operation can be overridden at this point.
        指定者：
        windowClosing in interface WindowListener
        重载：
        windowClosing in class WindowAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

deegeet((ettoattSSea>((BfgSBt>""guByS/


BasicToolBarUI.PropertyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.PropertyListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    直接已知子类：
    MetalToolBarUI.MetalRolloverListener
    封闭类：
    BasicToolBarUI

    protected class BasicToolBarUI.PropertyListener
extends Object
implements PropertyChangeListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicToolBarUI.PropertyListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolBarUI.PropertyListener

        protected BasicToolBarUI.PropertyListener()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntgos= s= vcc vv>gyyfh.f.../.x///.gnnsdLg>ex


BasicToolBarUI.ToolBarContListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.ToolBarContListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
  • 所有已实现的接口：
    ContainerListener, EventListener
    直接已知子类：
    MetalToolBarUI.MetalContainerListener
    封闭类：
    BasicToolBarUI

    protected class BasicToolBarUI.ToolBarContListener
extends Object
implements ContainerListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicToolBarUI.ToolBarContListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void componentAdded(ContainerEvent e)
      Invoked when a component has been added to the container.
      void componentRemoved(ContainerEvent e)
      Invoked when a component has been removed from the container.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolBarUI.ToolBarContListener

        protected BasicToolBarUI.ToolBarContListener()

    • 方法详细信息

      • componentAdded

        public void componentAdded(ContainerEvent e)
        从接口复制的描述： ContainerListener
        Invoked when a component has been added to the container.
        指定者：
        componentAdded in interface ContainerListener

      • componentRemoved

        public void componentRemoved(ContainerEvent e)
        从接口复制的描述： ContainerListener
        Invoked when a component has been removed from the container.
        指定者：
        componentRemoved in interface ContainerListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Tor;riod ;a>dn, taat;cuoam-鋟 aphsOefla�/


BasicToolBarUI.ToolBarFocusListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolBarUI.ToolBarFocusListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicToolBarUI

    protected class BasicToolBarUI.ToolBarFocusListener
extends Object
implements FocusListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BasicToolBarUI.ToolBarFocusListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when a component gains the keyboard focus.
      void focusLost(FocusEvent e)
      Invoked when a component loses the keyboard focus.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolBarUI.ToolBarFocusListener

        protected BasicToolBarUI.ToolBarFocusListener()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component gains the keyboard focus.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        从接口复制的描述： FocusListener
        Invoked when a component loses the keyboard focus.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>nedereiemttio rg.t.orr津�<鸼忖r�<>>磕


BasicToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicToolTipUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
  • 直接已知子类：
    MetalToolTipUI, SynthToolTipUI

    public class BasicToolTipUI
extends ToolTipUI
    Standard tool tip L&F.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicToolTipUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JComponent c)
      protected void | installListeners(JComponent c)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | uninstallDefaults(JComponent c)
      protected void | uninstallListeners(JComponent c)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicToolTipUI

        public BasicToolTipUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JComponent c)

      • uninstallDefaults

        protected void uninstallDefaults(JComponent c)

      • installListeners

        protected void installListeners(JComponent c)

      • uninstallListeners

        protected void uninstallListeners(JComponent c)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rgero.肔


BasicTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
  • 直接已知子类：
    MetalTreeUI, SynthTreeUI

    public class BasicTreeUI
extends TreeUI
    The basic L&F for a hierarchical data structure.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  BasicTreeUI.CellEditorHandler
      Listener responsible for getting cell editing events and updating the tree accordingly.
      class  BasicTreeUI.ComponentHandler
      Updates the preferred size when scrolling (if necessary).
      class  BasicTreeUI.FocusHandler
      Repaints the lead selection row when focus is lost/gained.
      class  BasicTreeUI.KeyHandler
      This is used to get mutliple key down events to appropriately generate events.
      class  BasicTreeUI.MouseHandler
      TreeMouseListener is responsible for updating the selection based on mouse events.
      class  BasicTreeUI.MouseInputHandler
      MouseInputHandler handles passing all mouse events, including mouse motion events, until the mouse is released to the destination it is constructed with.
      class  BasicTreeUI.NodeDimensionsHandler
      Class responsible for getting size of node, method is forwarded to BasicTreeUI method.
      class  BasicTreeUI.PropertyChangeHandler
      PropertyChangeListener for the tree.
      class  BasicTreeUI.SelectionModelPropertyChangeHandler
      Listener on the TreeSelectionModel, resets the row selection if any of the properties of the model change.
      class  BasicTreeUI.TreeCancelEditingAction
      ActionListener that invokes cancelEditing when action performed.
      class  BasicTreeUI.TreeExpansionHandler
      Updates the TreeState in response to nodes expanding/collapsing.
      class  BasicTreeUI.TreeHomeAction
      TreeHomeAction is used to handle end/home actions.
      class  BasicTreeUI.TreeIncrementAction
      TreeIncrementAction is used to handle up/down actions.
      class  BasicTreeUI.TreeModelHandler
      Forwards all TreeModel events to the TreeState.
      class  BasicTreeUI.TreePageAction
      TreePageAction handles page up and page down events.
      class  BasicTreeUI.TreeSelectionHandler
      Listens for changes in the selection model and updates the display accordingly.
      class  BasicTreeUI.TreeToggleAction
      For the first selected row expandedness will be toggled.
      class  BasicTreeUI.TreeTraverseAction
      TreeTraverseAction is the action used for left/right keys.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected TreeCellEditor cellEditor
      Editor for the tree.
      protected Icon | collapsedIcon
      protected boolean createdCellEditor
      Set to true if editor that is currently in the tree was created by this instance.
      protected boolean createdRenderer
      Set to true if the renderer that is currently in the tree was created by this instance.
      protected TreeCellRenderer currentCellRenderer
      Renderer that is being used to do the actual cell drawing.
      protected int depthOffset
      How much the depth should be offset to properly calculate x locations.
      protected Hashtable<TreePath,Boolean> drawingCache
      Used for minimizing the drawing of vertical lines.
      protected Component editingComponent
      When editing, this will be the Component that is doing the actual editing.
      protected TreePath editingPath
      Path that is being edited.
      protected int editingRow
      Row that is being edited.
      protected boolean editorHasDifferentSize
      Set to true if the editor has a different size than the renderer.
      protected Icon | expandedIcon
      protected boolean largeModel
      True if doing optimizations for a largeModel.
      protected int lastSelectedRow
      Index of the row that was last selected.
      protected int leftChildIndent
      Distance between left margin and where vertical dashes will be drawn.
      protected AbstractLayoutCache.NodeDimensions nodeDimensions
      Reponsible for telling the TreeState the size needed for a node.
      protected Dimension preferredMinSize
      Minimum preferred size.
      protected Dimension preferredSize
      Size needed to completely display all the nodes.
      protected CellRendererPane rendererPane
      Used to paint the TreeCellRenderer.
      protected int rightChildIndent
      Distance to add to leftChildIndent to determine where cell contents will be drawn.
      protected boolean stopEditingInCompleteEditing
      Set to false when editing and shouldSelectCell() returns true meaning the node should be selected before editing, used in completeEditing.
      protected int totalChildIndent
      Total distance that will be indented.
      protected JTree tree
      Component that we're going to be drawing into.
      protected TreeModel treeModel
      Used to determine what to display.
      protected TreeSelectionModel treeSelectionModel
      Model maintaing the selection.
      protected AbstractLayoutCache treeState
      Object responsible for handling sizing and expanded issues.
      protected boolean validCachedPreferredSize
      Is the preferredSize valid?

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void cancelEditing(JTree tree)
      Cancels the current editing session.
      protected void checkForClickInExpandControl(TreePath path, int mouseX, int mouseY)
      If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.
      protected void completeEditing()
      Messages to stop the editing session.
      protected void completeEditing(boolean messageStop, boolean messageCancel, boolean messageTree)
      Stops the editing session.
      protected void completeUIInstall()
      Invoked from installUI after all the defaults/listeners have been installed.
      protected void | completeUIUninstall()
      protected void configureLayoutCache()
      Resets the TreeState instance based on the tree we're providing the look and feel for.
      protected CellEditorListener createCellEditorListener()
      Creates a listener to handle events from the current editor.
      protected CellRendererPane createCellRendererPane()
      Returns the renderer pane that renderer components are placed in.
      protected ComponentListener createComponentListener()
      Creates and returns a new ComponentHandler.
      protected TreeCellEditor createDefaultCellEditor()
      Creates a default cell editor.
      protected TreeCellRenderer createDefaultCellRenderer()
      Returns the default cell renderer that is used to do the stamping of each node.
      protected FocusListener createFocusListener()
      Creates a listener that is responsible for updating the display when focus is lost/gained.
      protected KeyListener createKeyListener()
      Creates the listener reponsible for getting key events from the tree.
      protected AbstractLayoutCache createLayoutCache()
      Creates the object responsible for managing what is expanded, as well as the size of nodes.
      protected MouseListener createMouseListener()
      Creates the listener responsible for updating the selection based on mouse events.
      protected AbstractLayoutCache.NodeDimensions createNodeDimensions()
      Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.
      protected PropertyChangeListener createPropertyChangeListener()
      Creates a listener that is responsible that updates the UI based on how the tree changes.
      protected PropertyChangeListener createSelectionModelPropertyChangeListener()
      Creates the listener responsible for getting property change events from the selection model.
      protected TreeExpansionListener createTreeExpansionListener()
      Creates and returns the object responsible for updating the treestate when nodes expanded state changes.
      protected TreeModelListener createTreeModelListener()
      Returns a listener that can update the tree when the model changes.
      protected TreeSelectionListener createTreeSelectionListener()
      Creates the listener that updates the display based on selection change methods.
      static ComponentUI | createUI(JComponent x)
      protected void | drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
      protected void | drawDashedHorizontalLine(Graphics g, int y, int x1, int x2)
      protected void | drawDashedVerticalLine(Graphics g, int x, int y1, int y2)
      protected void ensureRowsAreVisible(int beginRow, int endRow)
      Ensures that the rows identified by beginRow through endRow are visible.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
      Returns an enum indicating how the baseline of the component changes as the size changes.
      protected TreeCellEditor | getCellEditor()
      protected TreeCellRenderer getCellRenderer()
      Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.
      TreePath getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      Icon getCollapsedIcon()
      protected Rectangle getDropLineRect(JTree.DropLocation loc)
      Returns a ubounding box for the drop line.
      TreePath getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      Icon getExpandedIcon()
      protected Color | getHashColor()
      protected int getHorizontalLegBuffer()
      The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default.
      protected TreePath getLastChildPath(TreePath parent)
      Returns a path to the last child of parent.
      protected int getLeadSelectionRow()
      Returns the lead row of the selection.
      int | getLeftChildIndent()
      Dimension getMaximumSize(JComponent c)
      Returns the maximum size for this component, which will be the preferred size if the instance is currently in a JTree, or 0, 0.
      Dimension getMinimumSize(JComponent c)
      Returns the minimum size for this component.
      protected TreeModel | getModel()
      Rectangle getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      TreePath getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      Dimension getPreferredMinSize()
      Returns the minimum preferred size.
      Dimension getPreferredSize(JComponent c)
      Returns the preferred size to properly display the tree, this is a cover method for getPreferredSize(c, true).
      Dimension getPreferredSize(JComponent c, boolean checkConsistency)
      Returns the preferred size to represent the tree in c.
      int | getRightChildIndent()
      int getRowCount(JTree tree)
      Returns the number of rows that are being displayed.
      int getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      protected int | getRowHeight()
      protected int getRowX(int row, int depth)
      Returns the location, along the x-axis, to render a particular row at.
      protected TreeSelectionModel | getSelectionModel()
      protected boolean | getShowsRootHandles()
      protected int getVerticalLegBuffer()
      The vertical element of legs between nodes starts at the bottom of the parent node by default.
      protected void handleExpandControlClick(TreePath path, int mouseX, int mouseY)
      Messaged when the user clicks the particular row, this invokes toggleExpandState.
      protected void installComponents()
      Intalls the subcomponents of the tree, which is the renderer pane.
      protected void | installDefaults()
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected boolean isDropLine(JTree.DropLocation loc)
      Tells if a DropLocation should be indicated by a line between nodes.
      protected boolean | isEditable()
      boolean isEditing(JTree tree)
      Returns true if the tree is being edited.
      protected boolean | isLargeModel()
      protected boolean | isLeaf(int row)
      protected boolean isLocationInExpandControl(TreePath path, int mouseX, int mouseY)
      Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.
      protected boolean isMultiSelectEvent(MouseEvent event)
      Returning true signifies a mouse event on the node should select from the anchor point.
      protected boolean | isRootVisible()
      protected boolean isToggleEvent(MouseEvent event)
      Returning true indicates the row under the mouse should be toggled based on the event.
      protected boolean isToggleSelectionEvent(MouseEvent event)
      Returning true signifies a mouse event on the node should toggle the selection of only the row under mouse.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void paintDropLine(Graphics g)
      Paints the drop line.
      protected void paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the expand (toggle) part of a row.
      protected void paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
      Paints a horizontal line.
      protected void paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the renderer part of a row.
      protected void paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
      Paints a vertical line.
      protected void paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.
      protected void pathWasCollapsed(TreePath path)
      Messaged from the VisibleTreeNode after it has collapsed.
      protected void pathWasExpanded(TreePath path)
      Messaged from the VisibleTreeNode after it has been expanded.
      protected void prepareForUIInstall()
      Invoked after the tree instance variable has been set, but before any defaults/listeners have been installed.
      protected void | prepareForUIUninstall()
      protected void selectPathForEvent(TreePath path, MouseEvent event)
      Messaged to update the selection based on a MouseEvent over a particular row.
      protected void setCellEditor(TreeCellEditor editor)
      Sets the cell editor.
      protected void setCellRenderer(TreeCellRenderer tcr)
      Sets the TreeCellRenderer to tcr.
      void | setCollapsedIcon(Icon newG)
      protected void setEditable(boolean newValue)
      Configures the receiver to allow, or not allow, editing.
      void | setExpandedIcon(Icon newG)
      protected void | setHashColor(Color color)
      protected void setLargeModel(boolean largeModel)
      Updates the componentListener, if necessary.
      void | setLeftChildIndent(int newAmount)
      protected void setModel(TreeModel model)
      Sets the TreeModel.
      void setPreferredMinSize(Dimension newSize)
      Sets the preferred minimum size.
      void | setRightChildIndent(int newAmount)
      protected void setRootVisible(boolean newValue)
      Sets the root to being visible.
      protected void setRowHeight(int rowHeight)
      Sets the row height, this is forwarded to the treeState.
      protected void setSelectionModel(TreeSelectionModel newLSM)
      Resets the selection model.
      protected void setShowsRootHandles(boolean newValue)
      Determines whether the node handles are to be displayed.
      protected boolean shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Returns true if the expand (toggle) control should be drawn for the specified row.
      protected boolean startEditing(TreePath path, MouseEvent event)
      Will start editing for node if there is a cellEditor and shouldSelectCell returns true.
      void startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      boolean stopEditing(JTree tree)
      Stops the current editing session.
      protected void toggleExpandState(TreePath path)
      Expands path if it is not expanded, or collapses row if it is expanded.
      protected void uninstallComponents()
      Uninstalls the renderer pane.
      protected void | uninstallDefaults()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      protected void updateCachedPreferredSize()
      Updates the preferredSize instance variable, which is returned from getPreferredSize().
      protected void updateCellEditor()
      Updates the cellEditor based on the editability of the JTree that we're contained in.
      protected void updateDepthOffset()
      Updates how much each depth should be offset by.
      protected void updateExpandedDescendants(TreePath path)
      Updates the expanded state of all the descendants of path by getting the expanded descendants from the tree and forwarding to the tree state.
      protected void updateLayoutCacheExpandedNodes()
      Makes all the nodes that are expanded in JTree expanded in LayoutCache.
      protected void updateLeadSelectionRow()
      Updates the lead row of the selection.
      protected void updateRenderer()
      Messaged from the tree we're in when the renderer has changed.
      protected void updateSize()
      Marks the cached size as being invalid, and messages the tree with treeDidChange.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • collapsedIcon

        protected transient Icon collapsedIcon

      • expandedIcon

        protected transient Icon expandedIcon

      • leftChildIndent

        protected int leftChildIndent
        Distance between left margin and where vertical dashes will be drawn.

      • rightChildIndent

        protected int rightChildIndent
        Distance to add to leftChildIndent to determine where cell contents will be drawn.

      • totalChildIndent

        protected int totalChildIndent
        Total distance that will be indented. The sum of leftChildIndent and rightChildIndent.

      • preferredMinSize

        protected Dimension preferredMinSize
        Minimum preferred size.

      • lastSelectedRow

        protected int lastSelectedRow
        Index of the row that was last selected.

      • tree

        protected JTree tree
        Component that we're going to be drawing into.

      • currentCellRenderer

        protected transient TreeCellRenderer currentCellRenderer
        Renderer that is being used to do the actual cell drawing.

      • createdRenderer

        protected boolean createdRenderer
        Set to true if the renderer that is currently in the tree was created by this instance.

      • cellEditor

        protected transient TreeCellEditor cellEditor
        Editor for the tree.

      • createdCellEditor

        protected boolean createdCellEditor
        Set to true if editor that is currently in the tree was created by this instance.

      • stopEditingInCompleteEditing

        protected boolean stopEditingInCompleteEditing
        Set to false when editing and shouldSelectCell() returns true meaning the node should be selected before editing, used in completeEditing.

      • rendererPane

        protected CellRendererPane rendererPane
        Used to paint the TreeCellRenderer.

      • preferredSize

        protected Dimension preferredSize
        Size needed to completely display all the nodes.

      • validCachedPreferredSize

        protected boolean validCachedPreferredSize
        Is the preferredSize valid?

      • treeState

        protected AbstractLayoutCache treeState
        Object responsible for handling sizing and expanded issues.

      • drawingCache

        protected Hashtable<TreePath,Boolean> drawingCache
        Used for minimizing the drawing of vertical lines.

      • largeModel

        protected boolean largeModel
        True if doing optimizations for a largeModel. Subclasses that don't support this may wish to override createLayoutCache to not return a FixedHeightLayoutCache instance.

      • nodeDimensions

        protected AbstractLayoutCache.NodeDimensions nodeDimensions
        Reponsible for telling the TreeState the size needed for a node.

      • treeModel

        protected TreeModel treeModel
        Used to determine what to display.

      • treeSelectionModel

        protected TreeSelectionModel treeSelectionModel
        Model maintaing the selection.

      • depthOffset

        protected int depthOffset
        How much the depth should be offset to properly calculate x locations. This is based on whether or not the root is visible, and if the root handles are visible.

      • editingComponent

        protected Component editingComponent
        When editing, this will be the Component that is doing the actual editing.

      • editingPath

        protected TreePath editingPath
        Path that is being edited.

      • editingRow

        protected int editingRow
        Row that is being edited. Should only be referenced if editingComponent is not null.

      • editorHasDifferentSize

        protected boolean editorHasDifferentSize
        Set to true if the editor has a different size than the renderer.

    • 构造方法详细信息

      • BasicTreeUI

        public BasicTreeUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • getHashColor

        protected Color getHashColor()

      • setHashColor

        protected void setHashColor(Color color)

      • setLeftChildIndent

        public void setLeftChildIndent(int newAmount)

      • getLeftChildIndent

        public int getLeftChildIndent()

      • setRightChildIndent

        public void setRightChildIndent(int newAmount)

      • getRightChildIndent

        public int getRightChildIndent()

      • setExpandedIcon

        public void setExpandedIcon(Icon newG)

      • getExpandedIcon

        public Icon getExpandedIcon()

      • setCollapsedIcon

        public void setCollapsedIcon(Icon newG)

      • getCollapsedIcon

        public Icon getCollapsedIcon()

      • setLargeModel

        protected void setLargeModel(boolean largeModel)
        Updates the componentListener, if necessary.

      • isLargeModel

        protected boolean isLargeModel()

      • setRowHeight

        protected void setRowHeight(int rowHeight)
        Sets the row height, this is forwarded to the treeState.

      • getRowHeight

        protected int getRowHeight()

      • setCellRenderer

        protected void setCellRenderer(TreeCellRenderer tcr)
        Sets the TreeCellRenderer to tcr. This invokes updateRenderer.

      • getCellRenderer

        protected TreeCellRenderer getCellRenderer()
        Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.

      • setModel

        protected void setModel(TreeModel model)
        Sets the TreeModel.

      • getModel

        protected TreeModel getModel()

      • setRootVisible

        protected void setRootVisible(boolean newValue)
        Sets the root to being visible.

      • isRootVisible

        protected boolean isRootVisible()

      • setShowsRootHandles

        protected void setShowsRootHandles(boolean newValue)
        Determines whether the node handles are to be displayed.

      • getShowsRootHandles

        protected boolean getShowsRootHandles()

      • setCellEditor

        protected void setCellEditor(TreeCellEditor editor)
        Sets the cell editor.

      • getCellEditor

        protected TreeCellEditor getCellEditor()

      • setEditable

        protected void setEditable(boolean newValue)
        Configures the receiver to allow, or not allow, editing.

      • isEditable

        protected boolean isEditable()

      • setSelectionModel

        protected void setSelectionModel(TreeSelectionModel newLSM)
        Resets the selection model. The appropriate listener are installed on the model.

      • getSelectionModel

        protected TreeSelectionModel getSelectionModel()

      • getPathBounds

        public Rectangle getPathBounds(JTree tree,
                      TreePath path)
        Returns the Rectangle enclosing the label portion that the last item in path will be drawn into. Will return null if any component in path is currently valid.
        指定者：
        getPathBounds in class TreeUI

      • getPathForRow

        public TreePath getPathForRow(JTree tree,
                     int row)
        Returns the path for passed in row. If row is not visible null is returned.
        指定者：
        getPathForRow in class TreeUI

      • getRowForPath

        public int getRowForPath(JTree tree,
                TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.
        指定者：
        getRowForPath in class TreeUI

      • getRowCount

        public int getRowCount(JTree tree)
        Returns the number of rows that are being displayed.
        指定者：
        getRowCount in class TreeUI

      • getClosestPathForLocation

        public TreePath getClosestPathForLocation(JTree tree,
                                 int x,
                                 int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        指定者：
        getClosestPathForLocation in class TreeUI

      • isEditing

        public boolean isEditing(JTree tree)
        Returns true if the tree is being edited. The item that is being edited can be returned by getEditingPath().
        指定者：
        isEditing in class TreeUI

      • stopEditing

        public boolean stopEditing(JTree tree)
        Stops the current editing session. This has no effect if the tree isn't being edited. Returns true if the editor allows the editing session to stop.
        指定者：
        stopEditing in class TreeUI

      • cancelEditing

        public void cancelEditing(JTree tree)
        Cancels the current editing session.
        指定者：
        cancelEditing in class TreeUI

      • startEditingAtPath

        public void startEditingAtPath(JTree tree,
                      TreePath path)
        Selects the last item in path and tries to edit it. Editing will fail if the CellEditor won't allow it for the selected item.
        指定者：
        startEditingAtPath in class TreeUI

      • getEditingPath

        public TreePath getEditingPath(JTree tree)
        Returns the path to the element that is being edited.
        指定者：
        getEditingPath in class TreeUI

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • prepareForUIInstall

        protected void prepareForUIInstall()
        Invoked after the tree instance variable has been set, but before any defaults/listeners have been installed.

      • completeUIInstall

        protected void completeUIInstall()
        Invoked from installUI after all the defaults/listeners have been installed.

      • installDefaults

        protected void installDefaults()

      • installListeners

        protected void installListeners()

      • installKeyboardActions

        protected void installKeyboardActions()

      • installComponents

        protected void installComponents()
        Intalls the subcomponents of the tree, which is the renderer pane.

      • createNodeDimensions

        protected AbstractLayoutCache.NodeDimensions createNodeDimensions()
        Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        Creates a listener that is responsible that updates the UI based on how the tree changes.

      • createMouseListener

        protected MouseListener createMouseListener()
        Creates the listener responsible for updating the selection based on mouse events.

      • createFocusListener

        protected FocusListener createFocusListener()
        Creates a listener that is responsible for updating the display when focus is lost/gained.

      • createKeyListener

        protected KeyListener createKeyListener()
        Creates the listener reponsible for getting key events from the tree.

      • createSelectionModelPropertyChangeListener

        protected PropertyChangeListener createSelectionModelPropertyChangeListener()
        Creates the listener responsible for getting property change events from the selection model.

      • createTreeSelectionListener

        protected TreeSelectionListener createTreeSelectionListener()
        Creates the listener that updates the display based on selection change methods.

      • createCellEditorListener

        protected CellEditorListener createCellEditorListener()
        Creates a listener to handle events from the current editor.

      • createComponentListener

        protected ComponentListener createComponentListener()
        Creates and returns a new ComponentHandler. This is used for the large model to mark the validCachedPreferredSize as invalid when the component moves.

      • createTreeExpansionListener

        protected TreeExpansionListener createTreeExpansionListener()
        Creates and returns the object responsible for updating the treestate when nodes expanded state changes.

      • createLayoutCache

        protected AbstractLayoutCache createLayoutCache()
        Creates the object responsible for managing what is expanded, as well as the size of nodes.

      • createCellRendererPane

        protected CellRendererPane createCellRendererPane()
        Returns the renderer pane that renderer components are placed in.

      • createDefaultCellEditor

        protected TreeCellEditor createDefaultCellEditor()
        Creates a default cell editor.

      • createDefaultCellRenderer

        protected TreeCellRenderer createDefaultCellRenderer()
        Returns the default cell renderer that is used to do the stamping of each node.

      • createTreeModelListener

        protected TreeModelListener createTreeModelListener()
        Returns a listener that can update the tree when the model changes.

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • prepareForUIUninstall

        protected void prepareForUIUninstall()

      • completeUIUninstall

        protected void completeUIUninstall()

      • uninstallDefaults

        protected void uninstallDefaults()

      • uninstallListeners

        protected void uninstallListeners()

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()

      • uninstallComponents

        protected void uninstallComponents()
        Uninstalls the renderer pane.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class ComponentUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • getBaselineResizeBehavior

        public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
        Returns an enum indicating how the baseline of the component changes as the size changes.
        重载：
        getBaselineResizeBehavior in class ComponentUI
        参数：
        c - JComponent to return baseline resize behavior for
        返回：
        an enum indicating how the baseline changes as the component size changes
        抛出：
        NullPointerException - if c is null
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • isDropLine

        protected boolean isDropLine(JTree.DropLocation loc)
        Tells if a DropLocation should be indicated by a line between nodes. This is meant for javax.swing.DropMode.INSERT and javax.swing.DropMode.ON_OR_INSERT drop modes.
        参数：
        loc - a DropLocation
        返回：
        true if the drop location should be shown as a line
        从以下版本开始：
        1.7

      • paintDropLine

        protected void paintDropLine(Graphics g)
        Paints the drop line.
        参数：
        g - Graphics object to draw on
        从以下版本开始：
        1.7

      • getDropLineRect

        protected Rectangle getDropLineRect(JTree.DropLocation loc)
        Returns a ubounding box for the drop line.
        参数：
        loc - a DropLocation
        返回：
        bounding box for the drop line
        从以下版本开始：
        1.7

      • paintHorizontalPartOfLeg

        protected void paintHorizontalPartOfLeg(Graphics g,
                            Rectangle clipBounds,
                            Insets insets,
                            Rectangle bounds,
                            TreePath path,
                            int row,
                            boolean isExpanded,
                            boolean hasBeenExpanded,
                            boolean isLeaf)
        Paints the horizontal part of the leg. The receiver should NOT modify clipBounds, or insets.

        NOTE: parentRow can be -1 if the root is not visible.

      • paintVerticalPartOfLeg

        protected void paintVerticalPartOfLeg(Graphics g,
                          Rectangle clipBounds,
                          Insets insets,
                          TreePath path)
        Paints the vertical part of the leg. The receiver should NOT modify clipBounds, insets.

      • paintExpandControl

        protected void paintExpandControl(Graphics g,
                      Rectangle clipBounds,
                      Insets insets,
                      Rectangle bounds,
                      TreePath path,
                      int row,
                      boolean isExpanded,
                      boolean hasBeenExpanded,
                      boolean isLeaf)
        Paints the expand (toggle) part of a row. The receiver should NOT modify clipBounds, or insets.

      • paintRow

        protected void paintRow(Graphics g,
            Rectangle clipBounds,
            Insets insets,
            Rectangle bounds,
            TreePath path,
            int row,
            boolean isExpanded,
            boolean hasBeenExpanded,
            boolean isLeaf)
        Paints the renderer part of a row. The receiver should NOT modify clipBounds, or insets.

      • shouldPaintExpandControl

        protected boolean shouldPaintExpandControl(TreePath path,
                               int row,
                               boolean isExpanded,
                               boolean hasBeenExpanded,
                               boolean isLeaf)
        Returns true if the expand (toggle) control should be drawn for the specified row.

      • paintVerticalLine

        protected void paintVerticalLine(Graphics g,
                     JComponent c,
                     int x,
                     int top,
                     int bottom)
        Paints a vertical line.

      • paintHorizontalLine

        protected void paintHorizontalLine(Graphics g,
                       JComponent c,
                       int y,
                       int left,
                       int right)
        Paints a horizontal line.

      • getVerticalLegBuffer

        protected int getVerticalLegBuffer()
        The vertical element of legs between nodes starts at the bottom of the parent node by default. This method makes the leg start below that.

      • getHorizontalLegBuffer

        protected int getHorizontalLegBuffer()
        The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default. This method makes the leg end before that.

      • drawCentered

        protected void drawCentered(Component c,
                Graphics graphics,
                Icon icon,
                int x,
                int y)

      • drawDashedHorizontalLine

        protected void drawDashedHorizontalLine(Graphics g,
                            int y,
                            int x1,
                            int x2)

      • drawDashedVerticalLine

        protected void drawDashedVerticalLine(Graphics g,
                          int x,
                          int y1,
                          int y2)

      • getRowX

        protected int getRowX(int row,
          int depth)
        Returns the location, along the x-axis, to render a particular row at. The return value does not include any Insets specified on the JTree. This does not check for the validity of the row or depth, it is assumed to be correct and will not throw an Exception if the row or depth doesn't match that of the tree.
        参数：
        row - Row to return x location for
        depth - Depth of the row
        返回：
        amount to indent the given row.
        从以下版本开始：
        1.5

      • updateLayoutCacheExpandedNodes

        protected void updateLayoutCacheExpandedNodes()
        Makes all the nodes that are expanded in JTree expanded in LayoutCache. This invokes updateExpandedDescendants with the root path.

      • updateExpandedDescendants

        protected void updateExpandedDescendants(TreePath path)
        Updates the expanded state of all the descendants of path by getting the expanded descendants from the tree and forwarding to the tree state.

      • getLastChildPath

        protected TreePath getLastChildPath(TreePath parent)
        Returns a path to the last child of parent.

      • updateDepthOffset

        protected void updateDepthOffset()
        Updates how much each depth should be offset by.

      • updateCellEditor

        protected void updateCellEditor()
        Updates the cellEditor based on the editability of the JTree that we're contained in. If the tree is editable but doesn't have a cellEditor, a basic one will be used.

      • updateRenderer

        protected void updateRenderer()
        Messaged from the tree we're in when the renderer has changed.

      • configureLayoutCache

        protected void configureLayoutCache()
        Resets the TreeState instance based on the tree we're providing the look and feel for.

      • updateSize

        protected void updateSize()
        Marks the cached size as being invalid, and messages the tree with treeDidChange.

      • updateCachedPreferredSize

        protected void updateCachedPreferredSize()
        Updates the preferredSize instance variable, which is returned from getPreferredSize().

        For left to right orientations, the size is determined from the current AbstractLayoutCache. For RTL orientations, the preferred size becomes the width minus the minimum x position.

      • pathWasExpanded

        protected void pathWasExpanded(TreePath path)
        Messaged from the VisibleTreeNode after it has been expanded.

      • pathWasCollapsed

        protected void pathWasCollapsed(TreePath path)
        Messaged from the VisibleTreeNode after it has collapsed.

      • ensureRowsAreVisible

        protected void ensureRowsAreVisible(int beginRow,
                        int endRow)
        Ensures that the rows identified by beginRow through endRow are visible.

      • setPreferredMinSize

        public void setPreferredMinSize(Dimension newSize)
        Sets the preferred minimum size.

      • getPreferredMinSize

        public Dimension getPreferredMinSize()
        Returns the minimum preferred size.

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Returns the preferred size to properly display the tree, this is a cover method for getPreferredSize(c, true).
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c,
                         boolean checkConsistency)
        Returns the preferred size to represent the tree in c. If checkConsistency is true checkConsistency is messaged first.

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Returns the minimum size for this component. Which will be the min preferred size or 0, 0.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Returns the maximum size for this component, which will be the preferred size if the instance is currently in a JTree, or 0, 0.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • completeEditing

        protected void completeEditing()
        Messages to stop the editing session. If the UI the receiver is providing the look and feel for returns true from getInvokesStopCellEditing, stopCellEditing will invoked on the current editor. Then completeEditing will be messaged with false, true, false to cancel any lingering editing.

      • completeEditing

        protected void completeEditing(boolean messageStop,
                   boolean messageCancel,
                   boolean messageTree)
        Stops the editing session. If messageStop is true the editor is messaged with stopEditing, if messageCancel is true the editor is messaged with cancelEditing. If messageTree is true the treeModel is messaged with valueForPathChanged.

      • startEditing

        protected boolean startEditing(TreePath path,
                   MouseEvent event)
        Will start editing for node if there is a cellEditor and shouldSelectCell returns true.

        This assumes that path is valid and visible.

      • checkForClickInExpandControl

        protected void checkForClickInExpandControl(TreePath path,
                                int mouseX,
                                int mouseY)
        If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.

      • isLocationInExpandControl

        protected boolean isLocationInExpandControl(TreePath path,
                                int mouseX,
                                int mouseY)
        Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.

      • handleExpandControlClick

        protected void handleExpandControlClick(TreePath path,
                            int mouseX,
                            int mouseY)
        Messaged when the user clicks the particular row, this invokes toggleExpandState.

      • toggleExpandState

        protected void toggleExpandState(TreePath path)
        Expands path if it is not expanded, or collapses row if it is expanded. If expanding a path and JTree scrolls on expand, ensureRowsAreVisible is invoked to scroll as many of the children to visible as possible (tries to scroll to last visible descendant of path).

      • isToggleSelectionEvent

        protected boolean isToggleSelectionEvent(MouseEvent event)
        Returning true signifies a mouse event on the node should toggle the selection of only the row under mouse.

      • isMultiSelectEvent

        protected boolean isMultiSelectEvent(MouseEvent event)
        Returning true signifies a mouse event on the node should select from the anchor point.

      • isToggleEvent

        protected boolean isToggleEvent(MouseEvent event)
        Returning true indicates the row under the mouse should be toggled based on the event. This is invoked after checkForClickInExpandControl, implying the location is not in the expand (toggle) control

      • selectPathForEvent

        protected void selectPathForEvent(TreePath path,
                      MouseEvent event)
        Messaged to update the selection based on a MouseEvent over a particular row. If the event is a toggle selection event, the row is either selected, or deselected. If the event identifies a multi selection event, the selection is updated from the anchor point. Otherwise the row is selected, and if the event specified a toggle event the row is expanded/collapsed.

      • isLeaf

        protected boolean isLeaf(int row)
        返回：
        true if the node at row is a leaf.

      • updateLeadSelectionRow

        protected void updateLeadSelectionRow()
        Updates the lead row of the selection.
        从以下版本开始：
        1.7

      • getLeadSelectionRow

        protected int getLeadSelectionRow()
        Returns the lead row of the selection.
        返回：
        selection lead row
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


BasicTreeUI.CellEditorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.CellEditorHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
  • 所有已实现的接口：
    EventListener, CellEditorListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.CellEditorHandler
extends Object
implements CellEditorListener
    Listener responsible for getting cell editing events and updating the tree accordingly.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.CellEditorHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void editingCanceled(ChangeEvent e)
      Messaged when editing has been canceled in the tree.
      void editingStopped(ChangeEvent e)
      Messaged when editing has stopped in the tree.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.CellEditorHandler

        public BasicTreeUI.CellEditorHandler()

    • 方法详细信息

      • editingStopped

        public void editingStopped(ChangeEvent e)
        Messaged when editing has stopped in the tree.
        指定者：
        editingStopped in interface CellEditorListener

      • editingCanceled

        public void editingCanceled(ChangeEvent e)
        Messaged when editing has been canceled in the tree.
        指定者：
        editingCanceled in interface CellEditorListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>ca.//.//.../.."<""Sh(lgnnr>S/ta>""ano/


BasicTreeUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.ComponentHandler

  • java.lang.Object
    • java.awt.event.ComponentAdapter
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
  • 所有已实现的接口：
    ActionListener, ComponentListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.ComponentHandler
extends ComponentAdapter
implements ActionListener
    Updates the preferred size when scrolling (if necessary).

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JScrollBar scrollBar
      ScrollBar that is being adjusted.
      protected Timer timer
      Timer used when inside a scrollpane and the scrollbar is adjusting.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.ComponentHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ae)
      Public as a result of Timer.
      void componentMoved(ComponentEvent e)
      Invoked when the component's position changes.
      protected JScrollPane getScrollPane()
      Returns the JScrollPane housing the JTree, or null if one isn't found.
      protected void startTimer()
      Creates, if necessary, and starts a Timer to check if need to resize the bounds.

      • 方法 - 继承于类 java.awt.event.ComponentAdapter

        componentHidden, componentResized, componentShown

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • timer

        protected Timer timer
        Timer used when inside a scrollpane and the scrollbar is adjusting.

      • scrollBar

        protected JScrollBar scrollBar
        ScrollBar that is being adjusted.

    • 构造方法详细信息

      • BasicTreeUI.ComponentHandler

        public BasicTreeUI.ComponentHandler()

    • 方法详细信息

      • componentMoved

        public void componentMoved(ComponentEvent e)
        Description copied from class: ComponentAdapter
        Invoked when the component's position changes.
        指定者：
        componentMoved in interface ComponentListener
        重载：
        componentMoved in class ComponentAdapter

      • startTimer

        protected void startTimer()
        Creates, if necessary, and starts a Timer to check if need to resize the bounds.

      • getScrollPane

        protected JScrollPane getScrollPane()
        Returns the JScrollPane housing the JTree, or null if one isn't found.

      • actionPerformed

        public void actionPerformed(ActionEvent ae)
        Public as a result of Timer. If the scrollBar is null, or not adjusting, this stops the timer and updates the sizing.
        指定者：
        actionPerformed in interface ActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cd eN oey:a/s " ds=i ssonvS


BasicTreeUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.FocusHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler
  • 所有已实现的接口：
    FocusListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.FocusHandler
extends Object
implements FocusListener
    Repaints the lead selection row when focus is lost/gained.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.FocusHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void focusGained(FocusEvent e)
      Invoked when focus is activated on the tree we're in, redraws the lead row.
      void focusLost(FocusEvent e)
      Invoked when focus is activated on the tree we're in, redraws the lead row.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.FocusHandler

        public BasicTreeUI.FocusHandler()

    • 方法详细信息

      • focusGained

        public void focusGained(FocusEvent e)
        Invoked when focus is activated on the tree we're in, redraws the lead row.
        指定者：
        focusGained in interface FocusListener

      • focusLost

        public void focusLost(FocusEvent e)
        Invoked when focus is activated on the tree we're in, redraws the lead row.
        指定者：
        focusLost in interface FocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j>a/e=af=a< a<nmEtt/pv= "iii<=l:


BasicTreeUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.KeyHandler

  • java.lang.Object
    • java.awt.event.KeyAdapter
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
  • 所有已实现的接口：
    KeyListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.KeyHandler
extends KeyAdapter
    This is used to get mutliple key down events to appropriately generate events.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean isKeyDown
      Set to true while keyPressed is active.
      protected Action repeatKeyAction
      Key code that is being generated for.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.KeyHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void keyPressed(KeyEvent e)
      Invoked when a key has been pressed.
      void keyReleased(KeyEvent e)
      Invoked when a key has been released.
      void keyTyped(KeyEvent e)
      Invoked when a key has been typed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • repeatKeyAction

        protected Action repeatKeyAction
        Key code that is being generated for.

      • isKeyDown

        protected boolean isKeyDown
        Set to true while keyPressed is active.

    • 构造方法详细信息

      • BasicTreeUI.KeyHandler

        public BasicTreeUI.KeyHandler()

    • 方法详细信息

      • keyTyped

        public void keyTyped(KeyEvent e)
        Invoked when a key has been typed. Moves the keyboard focus to the first element whose first letter matches the alphanumeric key pressed by the user. Subsequent same key presses move the keyboard focus to the next object that starts with the same letter.
        指定者：
        keyTyped in interface KeyListener
        重载：
        keyTyped in class KeyAdapter

      • keyPressed

        public void keyPressed(KeyEvent e)
        Description copied from class: KeyAdapter
        Invoked when a key has been pressed.
        指定者：
        keyPressed in interface KeyListener
        重载：
        keyPressed in class KeyAdapter

      • keyReleased

        public void keyReleased(KeyEvent e)
        Description copied from class: KeyAdapter
        Invoked when a key has been released.
        指定者：
        keyReleased in interface KeyListener
        重载：
        keyReleased in class KeyAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gs>/cietiemnnemmIeiiasaecTTiTrigx."ngnntadaa


BasicTreeUI.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.MouseHandler

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.MouseHandler
extends MouseAdapter
implements MouseMotionListener
    TreeMouseListener is responsible for updating the selection based on mouse events.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.MouseHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse button has been moved on a component (with no buttons no down).
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseEntered, mouseExited, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.MouseHandler

        public BasicTreeUI.MouseHandler()

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class MouseAdapter

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Invoked when the mouse button has been moved on a component (with no buttons no down).
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter
        从以下版本开始：
        1.4

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//pahctr


BasicTreeUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.MouseInputHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.MouseInputHandler
extends Object
implements MouseInputListener
    MouseInputHandler handles passing all mouse events, including mouse motion events, until the mouse is released to the destination it is constructed with. It is assumed all the events are currently target at source.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Component destination
      Destination that receives all events.
      protected Component source
      Source that events are coming from.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void mouseClicked(MouseEvent e)
      Invoked when the mouse button has been clicked (pressed and released) on a component.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseEntered(MouseEvent e)
      Invoked when the mouse enters a component.
      void mouseExited(MouseEvent e)
      Invoked when the mouse exits a component.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.
      void mouseReleased(MouseEvent e)
      Invoked when a mouse button has been released on a component.
      protected void | removeFromSource()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • source

        protected Component source
        Source that events are coming from.

      • destination

        protected Component destination
        Destination that receives all events.

    • 构造方法详细信息

      • BasicTreeUI.MouseInputHandler

        public BasicTreeUI.MouseInputHandler(Component source,
                             Component destination,
                             MouseEvent event)

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse button has been clicked (pressed and released) on a component.
        指定者：
        mouseClicked in interface MouseListener

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse enters a component.
        指定者：
        mouseEntered in interface MouseListener

      • mouseExited

        public void mouseExited(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when the mouse exits a component.
        指定者：
        mouseExited in interface MouseListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener

      • removeFromSource

        protected void removeFromSource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"/CtN.sts>o kx<&na a"e "/"/o


BasicTreeUI.NodeDimensionsHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.NodeDimensionsHandler

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
  • 封闭类：
    BasicTreeUI

    public class BasicTreeUI.NodeDimensionsHandler
extends AbstractLayoutCache.NodeDimensions
    Class responsible for getting size of node, method is forwarded to BasicTreeUI method. X location does not include insets, that is handled in getPathBounds.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.NodeDimensionsHandler()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size)
      Responsible for getting the size of a particular node.
      protected int | getRowX(int row, int depth)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.NodeDimensionsHandler

        public BasicTreeUI.NodeDimensionsHandler()

    • 方法详细信息

      • getNodeDimensions

        public Rectangle getNodeDimensions(Object value,
                          int row,
                          int depth,
                          boolean expanded,
                          Rectangle size)
        Responsible for getting the size of a particular node.
        指定者：
        getNodeDimensions in class AbstractLayoutCache.NodeDimensions
        参数：
        value - the value to be represented
        row - row being queried
        depth - the depth of the row
        expanded - true if row is expanded, false otherwise
        size - a Rectangle containing the size needed to represent value
        返回：
        a Rectangle containing the node dimensions, or null if node has no dimension

      • getRowX

        protected int getRowX(int row,
          int depth)
        返回：
        amount to indent the given row.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aamL"lablalssall


BasicTreeUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.PropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener
    PropertyChangeListener for the tree. Updates the appropriate varaible, or TreeState, based on what changes.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.PropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent event)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.PropertyChangeHandler

        public BasicTreeUI.PropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent event)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        event - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ j= =p=t=etxt/vxtii "i=ffrar/e.hh".l..."


BasicTreeUI.SelectionModelPropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.SelectionModelPropertyChangeHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.SelectionModelPropertyChangeHandler
extends Object
implements PropertyChangeListener
    Listener on the TreeSelectionModel, resets the row selection if any of the properties of the model change.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.SelectionModelPropertyChangeHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent event)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.SelectionModelPropertyChangeHandler

        public BasicTreeUI.SelectionModelPropertyChangeHandler()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent event)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        event - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"osc dvc=l s="bs


BasicTreeUI.TreeCancelEditingAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeCancelEditingAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeCancelEditingAction
extends AbstractAction
    ActionListener that invokes cancelEditing when action performed.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeCancelEditingAction(String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.TreeCancelEditingAction

        public BasicTreeUI.TreeCancelEditingAction(String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


BasicTreeUI.TreeExpansionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeExpansionHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
  • 所有已实现的接口：
    EventListener, TreeExpansionListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeExpansionHandler
extends Object
implements TreeExpansionListener
    Updates the TreeState in response to nodes expanding/collapsing.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeExpansionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeCollapsed(TreeExpansionEvent event)
      Called whenever an item in the tree has been collapsed.
      void treeExpanded(TreeExpansionEvent event)
      Called whenever an item in the tree has been expanded.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.TreeExpansionHandler

        public BasicTreeUI.TreeExpansionHandler()

    • 方法详细信息

      • treeExpanded

        public void treeExpanded(TreeExpansionEvent event)
        Called whenever an item in the tree has been expanded.
        指定者：
        treeExpanded in interface TreeExpansionListener

      • treeCollapsed

        public void treeCollapsed(TreeExpansionEvent event)
        Called whenever an item in the tree has been collapsed.
        指定者：
        treeCollapsed in interface TreeExpansionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ehfc d/


BasicTreeUI.TreeHomeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeHomeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeHomeAction
extends AbstractAction
    TreeHomeAction is used to handle end/home actions. Scrolls either the first or last cell to be visible based on direction.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | direction

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeHomeAction(int direction, String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • direction

        protected int direction

    • 构造方法详细信息

      • BasicTreeUI.TreeHomeAction

        public BasicTreeUI.TreeHomeAction(int direction,
                          String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shetmSotoaao, se/"挝/e韔>/osc =ad"兑sp�


BasicTreeUI.TreeIncrementAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeIncrementAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeIncrementAction
extends AbstractAction
    TreeIncrementAction is used to handle up/down actions. Selection is moved up or down based on direction.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int direction
      Specifies the direction to adjust the selection by.

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeIncrementAction(int direction, String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • direction

        protected int direction
        Specifies the direction to adjust the selection by.

    • 构造方法详细信息

      • BasicTreeUI.TreeIncrementAction

        public BasicTreeUI.TreeIncrementAction(int direction,
                               String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9wts t/p rs, r>,wyy鮮� h╨筫se飖ts舒 > 觔莟�"


BasicTreeUI.TreeModelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeModelHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
  • 所有已实现的接口：
    EventListener, TreeModelListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeModelHandler
extends Object
implements TreeModelListener
    Forwards all TreeModel events to the TreeState.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeModelHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.TreeModelHandler

        public BasicTreeUI.TreeModelHandler()

    • 方法详细信息

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        To indicate the root has changed, childIndices and children will be null.

        Use e.getPath() to get the parent of the changed node(s). e.getChildIndices() returns the index(es) of the changed node(s).

        指定者：
        treeNodesChanged in interface TreeModelListener

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after nodes have been inserted into the tree.

        Use e.getPath() to get the parent of the new node(s). e.getChildIndices() returns the index(es) of the new node(s) in ascending order.

        指定者：
        treeNodesInserted in interface TreeModelListener

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        Use e.getPath() to get the former parent of the deleted node(s). e.getChildIndices() returns, in ascending order, the index(es) the node(s) had before being deleted.

        指定者：
        treeNodesRemoved in interface TreeModelListener

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)
        从接口复制的描述： TreeModelListener

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        Use e.getPath() to get the path to the node. e.getChildIndices() returns null.

        指定者：
        treeStructureChanged in interface TreeModelListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

攁l�} m豇豃,蠵 掯 > ><蔵a.. fu


BasicTreeUI.TreePageAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreePageAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreePageAction
extends AbstractAction
    TreePageAction handles page up and page down events.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int direction
      Specifies the direction to adjust the selection by.

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreePageAction(int direction, String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • direction

        protected int direction
        Specifies the direction to adjust the selection by.

    • 构造方法详细信息

      • BasicTreeUI.TreePageAction

        public BasicTreeUI.TreePageAction(int direction,
                          String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mRlpgplptpcrhtm>�/鵵行#�/p.醥


BasicTreeUI.TreeSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeSelectionHandler

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
  • 所有已实现的接口：
    EventListener, TreeSelectionListener
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeSelectionHandler
extends Object
implements TreeSelectionListener
    Listens for changes in the selection model and updates the display accordingly.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeSelectionHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void valueChanged(TreeSelectionEvent event)
      Messaged when the selection changes in the tree we're displaying for.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.TreeSelectionHandler

        public BasicTreeUI.TreeSelectionHandler()

    • 方法详细信息

      • valueChanged

        public void valueChanged(TreeSelectionEvent event)
        Messaged when the selection changes in the tree we're displaying for. Stops editing, messages super and displays the changed paths.
        指定者：
        valueChanged in interface TreeSelectionListener
        参数：
        event - the event that characterizes the change.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rdeoiehreh<44h<>ee3 l a< l a


BasicTreeUI.TreeToggleAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeToggleAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeToggleAction
extends AbstractAction
    For the first selected row expandedness will be toggled.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeToggleAction(String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicTreeUI.TreeToggleAction

        public BasicTreeUI.TreeToggleAction(String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ufmifi.isifl_sua_= lv"/sssabs<&/nl汉pb;ni


BasicTreeUI.TreeTraverseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicTreeUI.TreeTraverseAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    BasicTreeUI

    public class BasicTreeUI.TreeTraverseAction
extends AbstractAction
    TreeTraverseAction is the action used for left/right keys. Will toggle the expandedness of a node, as well as potentially incrementing the selection.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int direction
      Determines direction to traverse, 1 means expand, -1 means collapse.

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicTreeUI.TreeTraverseAction(int direction, String name)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.
      boolean isEnabled()
      Returns true if the action is enabled.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • direction

        protected int direction
        Determines direction to traverse, 1 means expand, -1 means collapse.

    • 构造方法详细信息

      • BasicTreeUI.TreeTraverseAction

        public BasicTreeUI.TreeTraverseAction(int direction,
                              String name)

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.

      • isEnabled

        public boolean isEnabled()
        Description copied from class: AbstractAction
        Returns true if the action is enabled.
        指定者：
        isEnabled in interface Action
        重载：
        isEnabled in class AbstractAction
        返回：
        true if the action is enabled, false otherwise
        另请参见：
        Action.isEnabled()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hhrret|re


BasicViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 BasicViewportUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI

  • public class BasicViewportUI
extends ViewportUI
    BasicViewport implementation

    • 构造方法摘要

      Constructors
      构造方法与描述
      BasicViewportUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      protected void | installDefaults(JComponent c)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallDefaults(JComponent c)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BasicViewportUI

        public BasicViewportUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JComponent c)

      • uninstallDefaults

        protected void uninstallDefaults(JComponent c)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=鎍op.irpp.ril/ppsa_nme>...e.o/lts


ComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.plaf.basic

Interface ComboPopup

  • All Known Implementing Classes:
    BasicComboPopup, MetalComboBoxUI.MetalComboPopup

    public interface ComboPopup
    The interface which defines the methods required for the implementation of the popup portion of a combo box.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      KeyListener getKeyListener()
      Returns a key listener that will be added to the combo box or null.
      JList getList()
      Returns the list that is being used to draw the items in the combo box.
      MouseListener getMouseListener()
      Returns a mouse listener that will be added to the combo box or null.
      MouseMotionListener getMouseMotionListener()
      Returns a mouse motion listener that will be added to the combo box or null.
      void hide()
      Hides the popup
      boolean isVisible()
      Returns true if the popup is visible (currently being displayed).
      void show()
      Shows the popup
      void uninstallingUI()
      Called to inform the ComboPopup that the UI is uninstalling.

    • 方法详细信息

      • show

        void show()
        Shows the popup

      • hide

        void hide()
        Hides the popup

      • isVisible

        boolean isVisible()
        Returns true if the popup is visible (currently being displayed).
        返回：
        true if the component is visible; false otherwise.

      • getList

        JList getList()
        Returns the list that is being used to draw the items in the combo box. This method is highly implementation specific and should not be used for general list manipulation.

      • getMouseListener

        MouseListener getMouseListener()
        Returns a mouse listener that will be added to the combo box or null. If this method returns null then it will not be added to the combo box.
        返回：
        a MouseListener or null

      • getMouseMotionListener

        MouseMotionListener getMouseMotionListener()
        Returns a mouse motion listener that will be added to the combo box or null. If this method returns null then it will not be added to the combo box.
        返回：
        a MouseMotionListener or null

      • getKeyListener

        KeyListener getKeyListener()
        Returns a key listener that will be added to the combo box or null. If this method returns null then it will not be added to the combo box.

      • uninstallingUI

        void uninstallingUI()
        Called to inform the ComboPopup that the UI is uninstalling. If the ComboPopup added any listeners in the component, it should remove them here.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r e sa>ta>e >ee


DefaultMenuLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.basic

类 DefaultMenuLayout

  • java.lang.Object
    • javax.swing.BoxLayout
      • javax.swing.plaf.basic.DefaultMenuLayout
  • 所有已实现的接口：
    LayoutManager, LayoutManager2, Serializable, UIResource

    public class DefaultMenuLayout
extends BoxLayout
implements UIResource
    The default layout manager for Popup menus and menubars. This class is an extension of BoxLayout which adds the UIResource tag so that pluggable L&Fs can distinguish it from user-installed layout managers on menus.

    • 字段摘要

      • Fields inherited from class javax.swing.BoxLayout

        LINE_AXIS, PAGE_AXIS, X_AXIS, Y_AXIS

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultMenuLayout(Container target, int axis)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Dimension preferredLayoutSize(Container target)
      Returns the preferred dimensions for this layout, given the components in the specified target container.

      • 方法 - 继承于类 javax.swing.BoxLayout

        addLayoutComponent, addLayoutComponent, getAxis, getLayoutAlignmentX, getLayoutAlignmentY, getTarget, invalidateLayout, layoutContainer, maximumLayoutSize, minimumLayoutSize, removeLayoutComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultMenuLayout

        public DefaultMenuLayout(Container target,
                 int axis)

    • 方法详细信息

      • preferredLayoutSize

        public Dimension preferredLayoutSize(Container target)
        Description copied from class: BoxLayout
        Returns the preferred dimensions for this layout, given the components in the specified target container.
        指定者：
        preferredLayoutSize in interface LayoutManager
        重载：
        preferredLayoutSize in class BoxLayout
        参数：
        target - the container that needs to be laid out
        返回：
        the dimensions >= 0 && <= Integer.MAX_VALUE
        另请参见：
        Container, BoxLayout.minimumLayoutSize(java.awt.Container), BoxLayout.maximumLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>UeeS>>rl/>hfs oI U.ifhbejtte ej ei


javax.swing.plaf.basic

Interfaces

  • ComboPopup

Classes

  • BasicArrowButton
  • BasicBorders
  • BasicBorders.ButtonBorder
  • BasicBorders.FieldBorder
  • BasicBorders.MarginBorder
  • BasicBorders.MenuBarBorder
  • BasicBorders.RadioButtonBorder
  • BasicBorders.RolloverButtonBorder
  • BasicBorders.SplitPaneBorder
  • BasicBorders.ToggleButtonBorder
  • BasicButtonListener
  • BasicButtonUI
  • BasicCheckBoxMenuItemUI
  • BasicCheckBoxUI
  • BasicColorChooserUI
  • BasicComboBoxEditor
  • BasicComboBoxEditor.UIResource
  • BasicComboBoxRenderer
  • BasicComboBoxRenderer.UIResource
  • BasicComboBoxUI
  • BasicComboPopup
  • BasicDesktopIconUI
  • BasicDesktopPaneUI
  • BasicDirectoryModel
  • BasicEditorPaneUI
  • BasicFileChooserUI
  • BasicFormattedTextFieldUI
  • BasicGraphicsUtils
  • BasicHTML
  • BasicIconFactory
  • BasicInternalFrameTitlePane
  • BasicInternalFrameUI
  • BasicLabelUI
  • BasicListUI
  • BasicLookAndFeel
  • BasicMenuBarUI
  • BasicMenuItemUI
  • BasicMenuUI
  • BasicOptionPaneUI
  • BasicOptionPaneUI.ButtonAreaLayout
  • BasicPanelUI
  • BasicPasswordFieldUI
  • BasicPopupMenuSeparatorUI
  • BasicPopupMenuUI
  • BasicProgressBarUI
  • BasicRadioButtonMenuItemUI
  • BasicRadioButtonUI
  • BasicRootPaneUI
  • BasicScrollBarUI
  • BasicScrollPaneUI
  • BasicSeparatorUI
  • BasicSliderUI
  • BasicSpinnerUI
  • BasicSplitPaneDivider
  • BasicSplitPaneUI
  • BasicTabbedPaneUI
  • BasicTableHeaderUI
  • BasicTableUI
  • BasicTextAreaUI
  • BasicTextFieldUI
  • BasicTextPaneUI
  • BasicTextUI
  • BasicTextUI.BasicCaret
  • BasicTextUI.BasicHighlighter
  • BasicToggleButtonUI
  • BasicToolBarSeparatorUI
  • BasicToolBarUI
  • BasicToolTipUI
  • BasicTreeUI
  • BasicViewportUI
  • DefaultMenuLayout
h


javax.swing.plaf.basic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf.basic

Provides user interface objects built according to the Basic look and feel.

请参见： 描述

  • 接口摘要
    接口 描述
    ComboPopup
    The interface which defines the methods required for the implementation of the popup portion of a combo box.
  • Class Summary
    类 描述
    BasicArrowButton
    JButton object that draws a scaled Arrow in one of the cardinal directions.
    BasicBorders
    Factory object that can vend Borders appropriate for the basic L & F.
    BasicBorders.ButtonBorder
    BasicBorders.FieldBorder
    BasicBorders.MarginBorder
    BasicBorders.MenuBarBorder
    BasicBorders.RadioButtonBorder
    BasicBorders.RolloverButtonBorder
    Special thin border for rollover toolbar buttons.
    BasicBorders.SplitPaneBorder
    Draws the border around the splitpane.
    BasicBorders.ToggleButtonBorder
    BasicButtonListener
    Button Listener
    BasicButtonUI
    BasicButton implementation
    BasicCheckBoxMenuItemUI
    BasicCheckboxMenuItem implementation
    BasicCheckBoxUI
    CheckboxUI implementation for BasicCheckboxUI
    BasicColorChooserUI
    Provides the basic look and feel for a JColorChooser.
    BasicComboBoxEditor
    The default editor for editable combo boxes.
    BasicComboBoxEditor.UIResource
    A subclass of BasicComboBoxEditor that implements UIResource.
    BasicComboBoxRenderer
    ComboBox renderer
    BasicComboBoxRenderer.UIResource
    A subclass of BasicComboBoxRenderer that implements UIResource.
    BasicComboBoxUI
    Basic UI implementation for JComboBox.
    BasicComboPopup
    This is a basic implementation of the ComboPopup interface.
    BasicDesktopIconUI
    Basic L&F for a minimized window on a desktop.
    BasicDesktopPaneUI
    Basic L&F for a desktop.
    BasicDirectoryModel
    Basic implementation of a file list.
    BasicEditorPaneUI
    Provides the look and feel for a JEditorPane.
    BasicFileChooserUI
    Basic L&F implementation of a FileChooser.
    BasicFormattedTextFieldUI
    Provides the look and feel implementation for JFormattedTextField.
    BasicGraphicsUtils
    BasicHTML
    Support for providing html views for the swing components.
    BasicIconFactory
    Factory object that can vend Icons appropriate for the basic L & F.
    BasicInternalFrameTitlePane
    The class that manages a basic title bar
    BasicInternalFrameUI
    A basic L&F implementation of JInternalFrame.
    BasicLabelUI
    A Windows L&F implementation of LabelUI.
    BasicListUI
    An extensible implementation of ListUI.
    BasicLookAndFeel
    A base class to use in creating a look and feel for Swing.
    BasicMenuBarUI
    A default L&F implementation of MenuBarUI.
    BasicMenuItemUI
    BasicMenuItem implementation
    BasicMenuUI
    A default L&F implementation of MenuUI.
    BasicOptionPaneUI
    Provides the basic look and feel for a JOptionPane.
    BasicOptionPaneUI.ButtonAreaLayout
    ButtonAreaLayout behaves in a similar manner to FlowLayout.
    BasicPanelUI
    BasicPanel implementation
    BasicPasswordFieldUI
    Provides the Windows look and feel for a password field.
    BasicPopupMenuSeparatorUI
    A Basic L&F implementation of PopupMenuSeparatorUI.
    BasicPopupMenuUI
    A Windows L&F implementation of PopupMenuUI.
    BasicProgressBarUI
    A Basic L&F implementation of ProgressBarUI.
    BasicRadioButtonMenuItemUI
    BasicRadioButtonMenuItem implementation
    BasicRadioButtonUI
    RadioButtonUI implementation for BasicRadioButtonUI
    BasicRootPaneUI
    Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
    BasicScrollBarUI
    Implementation of ScrollBarUI for the Basic Look and Feel
    BasicScrollPaneUI
    A default L&F implementation of ScrollPaneUI.
    BasicSeparatorUI
    A Basic L&F implementation of SeparatorUI.
    BasicSliderUI
    A Basic L&F implementation of SliderUI.
    BasicSpinnerUI
    The default Spinner UI delegate.
    BasicSplitPaneDivider
    Divider used by BasicSplitPaneUI.
    BasicSplitPaneUI
    A Basic L&F implementation of the SplitPaneUI.
    BasicTabbedPaneUI
    A Basic L&F implementation of TabbedPaneUI.
    BasicTableHeaderUI
    BasicTableHeaderUI implementation
    BasicTableUI
    BasicTableUI implementation
    BasicTextAreaUI
    Provides the look and feel for a plain text editor.
    BasicTextFieldUI
    Basis of a look and feel for a JTextField.
    BasicTextPaneUI
    Provides the look and feel for a styled text editor.
    BasicTextUI
    Basis of a text components look-and-feel.
    BasicTextUI.BasicCaret
    BasicTextUI.BasicHighlighter
    BasicToggleButtonUI
    BasicToggleButton implementation
    BasicToolBarSeparatorUI
    A Basic L&F implementation of ToolBarSeparatorUI.
    BasicToolBarUI
    A Basic L&F implementation of ToolBarUI.
    BasicToolTipUI
    Standard tool tip L&F.
    BasicTreeUI
    The basic L&F for a hierarchical data structure.
    BasicViewportUI
    BasicViewport implementation
    DefaultMenuLayout
    The default layout manager for Popup menus and menubars.

软件包 javax.swing.plaf.basic Description

Provides user interface objects built according to the Basic look and feel. The Basic look and feel provides default behavior used by many look and feel packages. It contains components, layout managers, events, event listeners, and adapters. You can subclass the classes in this package to create your own customized look and feel.

These classes are designed to be used while the corresponding LookAndFeel class has been installed (UIManager.setLookAndFeel(new XXXLookAndFeel())). Using them while a different LookAndFeel is installed may produce unexpected results, including exceptions. Additionally, changing the LookAndFeel maintained by the UIManager without updating the corresponding ComponentUI of any JComponents may also produce unexpected results, such as the wrong colors showing up, and is generally not encouraged.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.swing.plaf.basic Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf.basic

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MarginBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
    • javax.swing.AbstractListModel<E> (implements javax.swing.ListModel<E>, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDirectoryModel (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicBorders
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder (implements javax.swing.border.Border, javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicButtonListener (implements javax.swing.event.ChangeListener, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicGraphicsUtils
    • javax.swing.plaf.basic.BasicHTML
    • javax.swing.plaf.basic.BasicIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener (implements javax.swing.event.InternalFrameListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler (implements java.awt.event.ComponentListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicListUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler (implements java.awt.event.MouseWheelListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager (implements java.awt.LayoutManager2)
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler (implements java.awt.event.KeyListener)
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler (implements javax.swing.event.CellEditorListener)
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler (implements javax.swing.event.TreeExpansionListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler (implements javax.swing.event.TreeSelectionListener)
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
      • javax.swing.plaf.basic.DefaultMenuLayout (implements javax.swing.plaf.UIResource)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider (implements java.beans.PropertyChangeListener)
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.plaf.basic.BasicComboBoxRenderer (implements javax.swing.ListCellRenderer<E>, java.io.Serializable)
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter (implements javax.swing.plaf.UIResource)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener (implements javax.swing.SwingConstants)
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret (implements javax.swing.plaf.UIResource)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener

Interface Hierarchy

  • javax.swing.plaf.basic.ComboPopup
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Package javax.swing.plaf.basic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf.basic

  • Packages that use javax.swing.plaf.basic
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
  • Classes in javax.swing.plaf.basic used by javax.swing.plaf.basic
    类与描述
    BasicBorders.ButtonBorder
    BasicButtonListener
    Button Listener
    BasicButtonUI
    BasicButton implementation
    BasicComboBoxEditor
    The default editor for editable combo boxes.
    BasicComboBoxRenderer
    ComboBox renderer
    BasicDirectoryModel
    Basic implementation of a file list.
    BasicEditorPaneUI
    Provides the look and feel for a JEditorPane.
    BasicInternalFrameTitlePane
    The class that manages a basic title bar
    BasicLabelUI
    A Windows L&F implementation of LabelUI.
    BasicMenuItemUI
    BasicMenuItem implementation
    BasicMenuUI
    A default L&F implementation of MenuUI.
    BasicRadioButtonUI
    RadioButtonUI implementation for BasicRadioButtonUI
    BasicScrollBarUI.ArrowButtonListener
    Listener for cursor keys.
    BasicScrollBarUI.ModelListener
    A listener to listen for model changes.
    BasicScrollBarUI.ScrollListener
    Listener for scrolling events initiated in the ScrollPane.
    BasicScrollBarUI.TrackListener
    Track mouse drags.
    BasicSeparatorUI
    A Basic L&F implementation of SeparatorUI.
    BasicSliderUI.ScrollListener
    Scroll-event listener.
    BasicSliderUI.TrackListener
    Track mouse movements.
    BasicSplitPaneDivider
    Divider used by BasicSplitPaneUI.
    BasicSplitPaneDivider.DragController
    Handles the events during a dragging session for a HORIZONTAL_SPLIT oriented split pane.
    BasicSplitPaneDivider.MouseHandler
    MouseHandler is responsible for converting mouse events (released, dragged...) into the appropriate DragController methods.
    BasicSplitPaneUI
    A Basic L&F implementation of the SplitPaneUI.
    BasicSplitPaneUI.BasicHorizontalLayoutManager
    LayoutManager for JSplitPanes that have an orientation of HORIZONTAL_SPLIT.
    BasicTextFieldUI
    Basis of a look and feel for a JTextField.
    BasicTextUI
    Basis of a text components look-and-feel.
    BasicToggleButtonUI
    BasicToggleButton implementation
    BasicToolBarUI.DragWindow
    ComboPopup
    The interface which defines the methods required for the implementation of the popup portion of a combo box.
  • Classes in javax.swing.plaf.basic used by javax.swing.plaf.metal
    类与描述
    BasicArrowButton
    JButton object that draws a scaled Arrow in one of the cardinal directions.
    BasicButtonListener
    Button Listener
    BasicButtonUI
    BasicButton implementation
    BasicComboBoxEditor
    The default editor for editable combo boxes.
    BasicComboBoxUI
    Basic UI implementation for JComboBox.
    BasicComboBoxUI.ComboBoxLayoutManager
    This layout manager handles the 'standard' layout of combo boxes.
    BasicComboBoxUI.PropertyChangeHandler
    This listener watches for bound properties that have changed in the combo box.
    BasicComboPopup
    This is a basic implementation of the ComboPopup interface.
    BasicDesktopIconUI
    Basic L&F for a minimized window on a desktop.
    BasicFileChooserUI
    Basic L&F implementation of a FileChooser.
    BasicInternalFrameTitlePane
    The class that manages a basic title bar
    BasicInternalFrameUI
    A basic L&F implementation of JInternalFrame.
    BasicLabelUI
    A Windows L&F implementation of LabelUI.
    BasicLookAndFeel
    A base class to use in creating a look and feel for Swing.
    BasicMenuBarUI
    A default L&F implementation of MenuBarUI.
    BasicProgressBarUI
    A Basic L&F implementation of ProgressBarUI.
    BasicRadioButtonUI
    RadioButtonUI implementation for BasicRadioButtonUI
    BasicRootPaneUI
    Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
    BasicScrollBarUI
    Implementation of ScrollBarUI for the Basic Look and Feel
    BasicScrollPaneUI
    A default L&F implementation of ScrollPaneUI.
    BasicSeparatorUI
    A Basic L&F implementation of SeparatorUI.
    BasicSliderUI
    A Basic L&F implementation of SliderUI.
    BasicSliderUI.PropertyChangeHandler
    BasicSplitPaneDivider
    Divider used by BasicSplitPaneUI.
    BasicSplitPaneUI
    A Basic L&F implementation of the SplitPaneUI.
    BasicTabbedPaneUI
    A Basic L&F implementation of TabbedPaneUI.
    BasicTabbedPaneUI.TabbedPaneLayout
    This class should be treated as a "protected" inner class.
    BasicTextFieldUI
    Basis of a look and feel for a JTextField.
    BasicTextUI
    Basis of a text components look-and-feel.
    BasicToggleButtonUI
    BasicToggleButton implementation
    BasicToolBarUI
    A Basic L&F implementation of ToolBarUI.
    BasicToolBarUI.DockingListener
    This class should be treated as a "protected" inner class.
    BasicToolBarUI.PropertyListener
    BasicToolBarUI.ToolBarContListener
    BasicToolTipUI
    Standard tool tip L&F.
    BasicTreeUI
    The basic L&F for a hierarchical data structure.
    ComboPopup
    The interface which defines the methods required for the implementation of the popup portion of a combo box.
  • Classes in javax.swing.plaf.basic used by javax.swing.plaf.nimbus
    类与描述
    BasicLookAndFeel
    A base class to use in creating a look and feel for Swing.
  • Classes in javax.swing.plaf.basic used by javax.swing.plaf.synth
    类与描述
    BasicButtonUI
    BasicButton implementation
    BasicColorChooserUI
    Provides the basic look and feel for a JColorChooser.
    BasicComboBoxUI
    Basic UI implementation for JComboBox.
    BasicDesktopIconUI
    Basic L&F for a minimized window on a desktop.
    BasicDesktopPaneUI
    Basic L&F for a desktop.
    BasicEditorPaneUI
    Provides the look and feel for a JEditorPane.
    BasicInternalFrameUI
    A basic L&F implementation of JInternalFrame.
    BasicLabelUI
    A Windows L&F implementation of LabelUI.
    BasicListUI
    An extensible implementation of ListUI.
    BasicLookAndFeel
    A base class to use in creating a look and feel for Swing.
    BasicMenuBarUI
    A default L&F implementation of MenuBarUI.
    BasicMenuItemUI
    BasicMenuItem implementation
    BasicMenuUI
    A default L&F implementation of MenuUI.
    BasicOptionPaneUI
    Provides the basic look and feel for a JOptionPane.
    BasicPanelUI
    BasicPanel implementation
    BasicPopupMenuUI
    A Windows L&F implementation of PopupMenuUI.
    BasicProgressBarUI
    A Basic L&F implementation of ProgressBarUI.
    BasicRootPaneUI
    Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
    BasicScrollBarUI
    Implementation of ScrollBarUI for the Basic Look and Feel
    BasicScrollPaneUI
    A default L&F implementation of ScrollPaneUI.
    BasicSliderUI
    A Basic L&F implementation of SliderUI.
    BasicSliderUI.TrackListener
    Track mouse movements.
    BasicSpinnerUI
    The default Spinner UI delegate.
    BasicSplitPaneDivider
    Divider used by BasicSplitPaneUI.
    BasicSplitPaneUI
    A Basic L&F implementation of the SplitPaneUI.
    BasicTabbedPaneUI
    A Basic L&F implementation of TabbedPaneUI.
    BasicTableHeaderUI
    BasicTableHeaderUI implementation
    BasicTableUI
    BasicTableUI implementation
    BasicTextAreaUI
    Provides the look and feel for a plain text editor.
    BasicTextFieldUI
    Basis of a look and feel for a JTextField.
    BasicTextUI
    Basis of a text components look-and-feel.
    BasicToolBarUI
    A Basic L&F implementation of ToolBarUI.
    BasicToolTipUI
    Standard tool tip L&F.
    BasicTreeUI
    The basic L&F for a hierarchical data structure.
    ComboPopup
    The interface which defines the methods required for the implementation of the popup portion of a combo box.
  • Classes in javax.swing.plaf.basic used by javax.swing.text
    类与描述
    BasicTextUI
    Basis of a text components look-and-feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lnet>i>>a)))rnee/=..fbU.


Uses of Class javax.swing.plaf.basic.BasicArrowButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicArrowButton

  • Packages that use BasicArrowButton
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicArrowButton in javax.swing.plaf.metal

      Subclasses of BasicArrowButton in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalScrollButton
      JButton object for Metal scrollbar arrows.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lchv�>


Uses of Class javax.swing.plaf.basic.BasicBorders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders

No usage of javax.swing.plaf.basic.BasicBorders
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.swing.plaf.basic.BasicBorders.ButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.ButtonBorder

  • Packages that use BasicBorders.ButtonBorder
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicBorders.ButtonBorder in javax.swing.plaf.basic

      Subclasses of BasicBorders.ButtonBorder in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      static class  | BasicBorders.RadioButtonBorder
      static class  BasicBorders.RolloverButtonBorder
      Special thin border for rollover toolbar buttons.
      static class  | BasicBorders.ToggleButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atosn>=sti)i>ak>n y/


Uses of Class javax.swing.plaf.basic.BasicBorders.FieldBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.FieldBorder

No usage of javax.swing.plaf.basic.BasicBorders.FieldBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctl


Uses of Class javax.swing.plaf.basic.BasicBorders.MarginBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.MarginBorder

No usage of javax.swing.plaf.basic.BasicBorders.MarginBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a S >etcm/a." aJ /


Uses of Class javax.swing.plaf.basic.BasicBorders.MenuBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.MenuBarBorder

No usage of javax.swing.plaf.basic.BasicBorders.MenuBarBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

詃".


Uses of Class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.RadioButtonBorder

No usage of javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< Vsqe>vl ab!>d"<


Uses of Class javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder

No usage of javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e<


Uses of Class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

No usage of javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AP/ab;1;p-1


Uses of Class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder

No usage of javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"os.></iCoi�


Uses of Class javax.swing.plaf.basic.BasicButtonListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicButtonListener

  • Packages that use BasicButtonListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicButtonListener in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return BasicButtonListener
      修饰符与类型 | 方法与描述
      protected BasicButtonListener | BasicButtonUI.createButtonListener(AbstractButton b)

    • Uses of BasicButtonListener in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return BasicButtonListener
      修饰符与类型 | 方法与描述
      protected BasicButtonListener | MetalButtonUI.createButtonListener(AbstractButton b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ievf/trnpn.evveri


Uses of Class javax.swing.plaf.basic.BasicButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicButtonUI

  • Packages that use BasicButtonUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicButtonUI in javax.swing.plaf.basic

      Subclasses of BasicButtonUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicCheckBoxUI
      CheckboxUI implementation for BasicCheckboxUI
      class  BasicRadioButtonUI
      RadioButtonUI implementation for BasicRadioButtonUI
      class  BasicToggleButtonUI
      BasicToggleButton implementation

    • Uses of BasicButtonUI in javax.swing.plaf.metal

      Subclasses of BasicButtonUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalButtonUI
      MetalButtonUI implementation
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
      class  MetalRadioButtonUI
      RadioButtonUI implementation for MetalRadioButtonUI
      class  MetalToggleButtonUI
      MetalToggleButton implementation

    • Uses of BasicButtonUI in javax.swing.plaf.synth

      Subclasses of BasicButtonUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthButtonUI
      Provides the Synth L&F UI delegate for JButton.
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ab;e=wetMyaa紇bif


Uses of Class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

No usage of javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j


Uses of Class javax.swing.plaf.basic.BasicCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicCheckBoxUI

No usage of javax.swing.plaf.basic.BasicCheckBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.tＨ�/�o>


Uses of Class javax.swing.plaf.basic.BasicColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicColorChooserUI

  • Packages that use BasicColorChooserUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicColorChooserUI in javax.swing.plaf.synth

      Subclasses of BasicColorChooserUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthColorChooserUI
      Provides the Synth L&F UI delegate for JColorChooser.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a-cIiiBo(LSlB.s j/./t//&


Uses of Class javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler

No usage of javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.meChooClllsb//a.�"w


Uses of Class javax.swing.plaf.basic.BasicComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxEditor

  • Packages that use BasicComboBoxEditor
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicComboBoxEditor in javax.swing.plaf.basic

      Subclasses of BasicComboBoxEditor in javax.swing.plaf.basic
      修饰符与类型 类与描述
      static class  BasicComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.

    • Uses of BasicComboBoxEditor in javax.swing.plaf.metal

      Subclasses of BasicComboBoxEditor in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxEditor
      The default editor for Metal editable combo boxes
      static class  MetalComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sbo tyn o&>_maM/aikgh


Uses of Class javax.swing.plaf.basic.BasicComboBoxEditor.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxEditor.UIResource

No usage of javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c."..swajvvvi=.. U..t


Uses of Class javax.swing.plaf.basic.BasicComboBoxRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxRenderer

  • Packages that use BasicComboBoxRenderer
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicComboBoxRenderer in javax.swing.plaf.basic

      Subclasses of BasicComboBoxRenderer in javax.swing.plaf.basic
      修饰符与类型 类与描述
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s./tp.bssal a x /ah..p< /


Uses of Class javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource

No usage of javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tglmer.nedddoiaarei//


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI

  • Packages that use BasicComboBoxUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicComboBoxUI in javax.swing.plaf.metal

      Subclasses of BasicComboBoxUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI
      Metal UI for JComboBox

    • Uses of BasicComboBoxUI in javax.swing.plaf.synth

      Subclasses of BasicComboBoxUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthComboBoxUI
      Provides the Synth L&F UI delegate for JComboBox.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eae=m>c>7l<舉 a/ndmi


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager

  • Packages that use BasicComboBoxUI.ComboBoxLayoutManager
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicComboBoxUI.ComboBoxLayoutManager in javax.swing.plaf.metal

      Subclasses of BasicComboBoxUI.ComboBoxLayoutManager in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboBoxLayoutManager
      This inner class is marked "public" due to a compiler bug.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

liet0t>.apt=euo� l a 1r m


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b"oif=" ahhha tt T-=o


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler

No usage of javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

milsckaht///sn..as>b/


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler

No usage of javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>omt>s>lisa/豤a/lnar


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler

No usage of javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kh">=aso.udEAeEr -<


Uses of Class javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler

  • Packages that use BasicComboBoxUI.PropertyChangeHandler
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicComboBoxUI.PropertyChangeHandler in javax.swing.plaf.metal

      Subclasses of BasicComboBoxUI.PropertyChangeHandler in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalPropertyChangeListener
      This inner class is marked "public" due to a compiler bug.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dn.isl/c.ba>Tmoe giies a


Uses of Class javax.swing.plaf.basic.BasicComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup

  • Packages that use BasicComboPopup
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicComboPopup in javax.swing.plaf.metal

      Subclasses of BasicComboPopup in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s, oi a notnoea騮liha_rt�


Uses of Class javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cflalafniggg.iiih


Uses of Class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sell>ra/->or


Uses of Class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n metvdgC/e-ny"-segL


Uses of Class javax.swing.plaf.basic.BasicComboPopup.ItemHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.ItemHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.ItemHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. /."/./.....l.�//..


Uses of Class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.ListDataHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

naE&uacLt �1F/o


Uses of Class javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�.wfH @.ml "k/


Uses of Class javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i>Roat=gs"v t/ ija.


Uses of Class javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.myto


Uses of Class javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ome ﹔/lk"钶


Uses of Class javax.swing.plaf.basic.BasicDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopIconUI

  • Packages that use BasicDesktopIconUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicDesktopIconUI in javax.swing.plaf.metal

      Subclasses of BasicDesktopIconUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalDesktopIconUI
      Metal desktop icon.

    • Uses of BasicDesktopIconUI in javax.swing.plaf.synth

      Subclasses of BasicDesktopIconUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthDesktopIconUI
      Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ab ydtsaaao>fse/t"=罫


Uses of Class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0>"e


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI

  • Packages that use BasicDesktopPaneUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicDesktopPaneUI in javax.swing.plaf.synth

      Subclasses of BasicDesktopPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthDesktopPaneUI
      Provides the Synth L&F UI delegate for JDesktopPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

scc/i/d


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction

No usage of javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>usRo>T>g莞be3&La癰b


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction

No usage of javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

UfIoDesaBsssipjj/r>.v


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction

No usage of javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sta@鬊e�8�l髉rt


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction

No usage of javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r<竛@馚p�8�!�pg


Uses of Class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction

No usage of javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-.motsn>sl>g/s�


Uses of Class javax.swing.plaf.basic.BasicDirectoryModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicDirectoryModel

  • Packages that use BasicDirectoryModel
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicDirectoryModel in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return BasicDirectoryModel
      修饰符与类型 | 方法与描述
      BasicDirectoryModel | BasicFileChooserUI.getModel()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sNheenlOhmt oot/yctpdces


Uses of Class javax.swing.plaf.basic.BasicEditorPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicEditorPaneUI

  • Packages that use BasicEditorPaneUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicEditorPaneUI in javax.swing.plaf.basic

      Subclasses of BasicEditorPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTextPaneUI
      Provides the look and feel for a styled text editor.

    • Uses of BasicEditorPaneUI in javax.swing.plaf.synth

      Subclasses of BasicEditorPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ Mcev3/T>situiMB


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI

  • Packages that use BasicFileChooserUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicFileChooserUI in javax.swing.plaf.metal

      Subclasses of BasicFileChooserUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalFileChooserUI
      Metal L&F implementation of a FileChooser.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ibIav:e


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter

No usage of javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dU lg ssittt,s""lsb3s


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d=.ueca> oi dca//l"s


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

No usage of javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

劏帘冰保了宣/�<◆ �<


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>seh"mPaaetnttueradmN


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

U FcCsbcgso .s "aj"


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener

No usage of javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a —间讳篇嗽冰籶Ｃ粼3


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=nrnr&s徊>皉/


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.llllipjj./slv


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener

No usage of javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

weVsn"/ou nynKpt o.


Uses of Class javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction

No usage of javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ai/ab;1;p-1


Uses of Class javax.swing.plaf.basic.BasicFormattedTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicFormattedTextFieldUI

No usage of javax.swing.plaf.basic.BasicFormattedTextFieldUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>rsRo>T>g莞be3&Ha癰bb


Uses of Class javax.swing.plaf.basic.BasicGraphicsUtils

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicGraphicsUtils

No usage of javax.swing.plaf.basic.BasicGraphicsUtils
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

onrnr&s&�>皉/


Uses of Class javax.swing.plaf.basic.BasicHTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicHTML

No usage of javax.swing.plaf.basic.BasicHTML
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆ �<


Uses of Class javax.swing.plaf.basic.BasicIconFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicIconFactory

No usage of javax.swing.plaf.basic.BasicIconFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

je3<.asr>< sristeaad


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane

  • Packages that use BasicInternalFrameTitlePane
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicInternalFrameTitlePane in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicInternalFrameTitlePane
      修饰符与类型 | 字段与描述
      protected BasicInternalFrameTitlePane | BasicInternalFrameUI.titlePane

    • Uses of BasicInternalFrameTitlePane in javax.swing.plaf.metal

      Subclasses of BasicInternalFrameTitlePane in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalInternalFrameTitlePane
      Class that manages a JLF title bar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"Le/r t" s/ su1t<>


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsmiFrarennnIiii "a-i


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lcdd7shPfml劯|�.


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-.motsn>sl>g/s


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esfbso abash"xvh�>.i


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

srtＨ�/�o>


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nt/>slpla


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aedai sie"�nI發hcogs/


Uses of Class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout

No usage of javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o /otgso"�><.nt==mvr


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI

  • Packages that use BasicInternalFrameUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicInternalFrameUI in javax.swing.plaf.metal

      Subclasses of BasicInternalFrameUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalInternalFrameUI
      Metal implementation of JInternalFrame.

    • Uses of BasicInternalFrameUI in javax.swing.plaf.synth

      Subclasses of BasicInternalFrameUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthInternalFrameUI
      Provides the Synth L&F UI delegate for JInternalFrame.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&"'Ltovaiu/aj薾s※黵;s


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>-rls!n,


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c�//oavo� n>ee敏 r


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i)a>>/"Eae皀v


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et /hm//t


Uses of Class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener

No usage of javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a/ .n<."/t"< b>->


Uses of Class javax.swing.plaf.basic.BasicLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicLabelUI

  • Packages that use BasicLabelUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicLabelUI in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicLabelUI
      修饰符与类型 字段与描述
      protected static BasicLabelUI BasicLabelUI.labelUI
      The default BasicLabelUI instance.

    • Uses of BasicLabelUI in javax.swing.plaf.metal

      Subclasses of BasicLabelUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalLabelUI
      A Windows L&F implementation of LabelUI.

    • Uses of BasicLabelUI in javax.swing.plaf.synth

      Subclasses of BasicLabelUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthLabelUI
      Provides the Synth L&F UI delegate for JLabel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rb-眆er og>>rerdc蟖t/


Uses of Class javax.swing.plaf.basic.BasicListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI

  • Packages that use BasicListUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicListUI in javax.swing.plaf.synth

      Subclasses of BasicListUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthListUI
      Provides the Synth L&F UI delegate for JList.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pC- .t>c hil/8b


Uses of Class javax.swing.plaf.basic.BasicListUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicListUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dii>stra/>>>UI..ho.f.


Uses of Class javax.swing.plaf.basic.BasicListUI.ListDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI.ListDataHandler

No usage of javax.swing.plaf.basic.BasicListUI.ListDataHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/i


Uses of Class javax.swing.plaf.basic.BasicListUI.ListSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI.ListSelectionHandler

No usage of javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.SL >ilm


Uses of Class javax.swing.plaf.basic.BasicListUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicListUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/>slplay/ <


Uses of Class javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bub-/to(/eor"rI<;te


Uses of Class javax.swing.plaf.basic.BasicLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicLookAndFeel

  • Packages that use BasicLookAndFeel
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicLookAndFeel in javax.swing.plaf.metal

      Subclasses of BasicLookAndFeel in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalLookAndFeel
      The Java Look and Feel, otherwise known as Metal.

    • Uses of BasicLookAndFeel in javax.swing.plaf.nimbus

      Subclasses of BasicLookAndFeel in javax.swing.plaf.nimbus
      修饰符与类型 类与描述
      class  NimbusLookAndFeel
      The NimbusLookAndFeel class.

    • Uses of BasicLookAndFeel in javax.swing.plaf.synth

      Subclasses of BasicLookAndFeel in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthLookAndFeel
      SynthLookAndFeel provides the basis for creating a customized look and feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sir "sb>JAbphe>h>ml e


Uses of Class javax.swing.plaf.basic.BasicMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuBarUI

  • Packages that use BasicMenuBarUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicMenuBarUI in javax.swing.plaf.metal

      Subclasses of BasicMenuBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalMenuBarUI
      Metal implementation of MenuBarUI.

    • Uses of BasicMenuBarUI in javax.swing.plaf.synth

      Subclasses of BasicMenuBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthMenuBarUI
      Provides the Synth L&F UI delegate for JMenuBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etmotsooo<;nn&tg&&d


Uses of Class javax.swing.plaf.basic.BasicMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuItemUI

  • Packages that use BasicMenuItemUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicMenuItemUI in javax.swing.plaf.basic

      Subclasses of BasicMenuItemUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicCheckBoxMenuItemUI
      BasicCheckboxMenuItem implementation
      class  BasicMenuUI
      A default L&F implementation of MenuUI.
      class  BasicRadioButtonMenuItemUI
      BasicRadioButtonMenuItem implementation

    • Uses of BasicMenuItemUI in javax.swing.plaf.synth

      Subclasses of BasicMenuItemUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eeg ncd teTs=v�


Uses of Class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lsac> <<>///on<>o


Uses of Class javax.swing.plaf.basic.BasicMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuUI

  • Packages that use BasicMenuUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicMenuUI in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicMenuUI
      修饰符与类型 | 字段与描述
      BasicMenuUI | BasicMenuUI.ChangeHandler.ui
      Constructors in javax.swing.plaf.basic with parameters of type BasicMenuUI
      构造方法与描述
      BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

    • Uses of BasicMenuUI in javax.swing.plaf.synth

      Subclasses of BasicMenuUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tod/>.in/>n/fAasinfsin<


Uses of Class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuUI.ChangeHandler

No usage of javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stＨ�/�o>


Uses of Class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vealtle"l hcffrwoef


Uses of Class javax.swing.plaf.basic.BasicOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicOptionPaneUI

  • Packages that use BasicOptionPaneUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicOptionPaneUI in javax.swing.plaf.synth

      Subclasses of BasicOptionPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthOptionPaneUI
      Provides the Synth L&F UI delegate for JOptionPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C.>li" y ./.x/rs


Uses of Class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener

No usage of javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=da<=pe/".cc=bc=acaa


Uses of Class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

No usage of javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-rmotsn>sl>g/s


Uses of Class javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt1B="nlcaaal>ii/nUo"


Uses of Class javax.swing.plaf.basic.BasicPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicPanelUI

  • Packages that use BasicPanelUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicPanelUI in javax.swing.plaf.synth

      Subclasses of BasicPanelUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthPanelUI
      Provides the Synth L&F UI delegate for JPanel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>�>c:sae觟 �>馈 �/bfee


Uses of Class javax.swing.plaf.basic.BasicPasswordFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicPasswordFieldUI

No usage of javax.swing.plaf.basic.BasicPasswordFieldUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n/./..=f"""h mvl<�


Uses of Class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

No usage of javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sar=u


Uses of Class javax.swing.plaf.basic.BasicPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicPopupMenuUI

  • Packages that use BasicPopupMenuUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicPopupMenuUI in javax.swing.plaf.synth

      Subclasses of BasicPopupMenuUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthPopupMenuUI
      Provides the Synth L&F UI delegate for JPopupMenu.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p t�=<(o/


Uses of Class javax.swing.plaf.basic.BasicProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicProgressBarUI

  • Packages that use BasicProgressBarUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicProgressBarUI in javax.swing.plaf.metal

      Subclasses of BasicProgressBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalProgressBarUI
      The Metal implementation of ProgressBarUI.

    • Uses of BasicProgressBarUI in javax.swing.plaf.synth

      Subclasses of BasicProgressBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthProgressBarUI
      Provides the Synth L&F UI delegate for JProgressBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N {t f胒a


Uses of Class javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler

No usage of javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jTas="cittttlnBB�.


Uses of Class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

No usage of javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rae>baslpaaana==.hivc


Uses of Class javax.swing.plaf.basic.BasicRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicRadioButtonUI

  • Packages that use BasicRadioButtonUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicRadioButtonUI in javax.swing.plaf.basic

      Subclasses of BasicRadioButtonUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicCheckBoxUI
      CheckboxUI implementation for BasicCheckboxUI

    • Uses of BasicRadioButtonUI in javax.swing.plaf.metal

      Subclasses of BasicRadioButtonUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
      class  MetalRadioButtonUI
      RadioButtonUI implementation for MetalRadioButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acb=Vhrla n<<0htm<瞚 x猧


Uses of Class javax.swing.plaf.basic.BasicRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicRootPaneUI

  • Packages that use BasicRootPaneUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicRootPaneUI in javax.swing.plaf.metal

      Subclasses of BasicRootPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalRootPaneUI
      Provides the metal look and feel implementation of RootPaneUI.

    • Uses of BasicRootPaneUI in javax.swing.plaf.synth

      Subclasses of BasicRootPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthRootPaneUI
      Provides the Synth L&F UI delegate for JRootPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t觟de,i,sdfin i.裕髓肌笆b


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI

  • Packages that use BasicScrollBarUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicScrollBarUI in javax.swing.plaf.metal

      Subclasses of BasicScrollBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalScrollBarUI
      Implementation of ScrollBarUI for the Metal Look and Feel

    • Uses of BasicScrollBarUI in javax.swing.plaf.synth

      Subclasses of BasicScrollBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la鹄""c<r靤inlr


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener

  • Packages that use BasicScrollBarUI.ArrowButtonListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicScrollBarUI.ArrowButtonListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicScrollBarUI.ArrowButtonListener
      修饰符与类型 | 字段与描述
      protected BasicScrollBarUI.ArrowButtonListener | BasicScrollBarUI.buttonListener
      Methods in javax.swing.plaf.basic that return BasicScrollBarUI.ArrowButtonListener
      修饰符与类型 | 方法与描述
      protected BasicScrollBarUI.ArrowButtonListener | BasicScrollBarUI.createArrowButtonListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d<鋍,r rOce蔼� /园, a91玲1


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI.ModelListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI.ModelListener

  • Packages that use BasicScrollBarUI.ModelListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicScrollBarUI.ModelListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicScrollBarUI.ModelListener
      修饰符与类型 | 字段与描述
      protected BasicScrollBarUI.ModelListener | BasicScrollBarUI.modelListener
      Methods in javax.swing.plaf.basic that return BasicScrollBarUI.ModelListener
      修饰符与类型 | 方法与描述
      protected BasicScrollBarUI.ModelListener | BasicScrollBarUI.createModelListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>dv ewevve,fiwf锚父命弦摹


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/>L.MoaBrrroBpplsoap


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

  • Packages that use BasicScrollBarUI.ScrollListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicScrollBarUI.ScrollListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicScrollBarUI.ScrollListener
      修饰符与类型 | 字段与描述
      protected BasicScrollBarUI.ScrollListener | BasicScrollBarUI.scrollListener
      Methods in javax.swing.plaf.basic that return BasicScrollBarUI.ScrollListener
      修饰符与类型 | 方法与描述
      protected BasicScrollBarUI.ScrollListener | BasicScrollBarUI.createScrollListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kt>o dnDsgio.w/a e >膐予


Uses of Class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollBarUI.TrackListener

  • Packages that use BasicScrollBarUI.TrackListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicScrollBarUI.TrackListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicScrollBarUI.TrackListener
      修饰符与类型 | 字段与描述
      protected BasicScrollBarUI.TrackListener | BasicScrollBarUI.trackListener
      Methods in javax.swing.plaf.basic that return BasicScrollBarUI.TrackListener
      修饰符与类型 | 方法与描述
      protected BasicScrollBarUI.TrackListener | BasicScrollBarUI.createTrackListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aabd tkynk> >moom


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI

  • Packages that use BasicScrollPaneUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicScrollPaneUI in javax.swing.plaf.metal

      Subclasses of BasicScrollPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalScrollPaneUI
      A Metal L&F implementation of ScrollPaneUI.

    • Uses of BasicScrollPaneUI in javax.swing.plaf.synth

      Subclasses of BasicScrollPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt�vcb/@a瑂nda/n


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener

No usage of javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tBlwinavxxx ctt/.ivt


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler

No usage of javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3n>nlafniggg.l--aS.hu


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/ /dv


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler

No usage of javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hiehl hi鬿o


Uses of Class javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener

No usage of javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-pmotsn>sl>

g/sP


Uses of Class javax.swing.plaf.basic.BasicSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSeparatorUI

  • Packages that use BasicSeparatorUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicSeparatorUI in javax.swing.plaf.basic

      Subclasses of BasicSeparatorUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicPopupMenuSeparatorUI
      A Basic L&F implementation of PopupMenuSeparatorUI.
      class  BasicToolBarSeparatorUI
      A Basic L&F implementation of ToolBarSeparatorUI.

    • Uses of BasicSeparatorUI in javax.swing.plaf.metal

      Subclasses of BasicSeparatorUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalPopupMenuSeparatorUI
      A Metal L&F implementation of PopupMenuSeparatorUI.
      class  MetalSeparatorUI
      A Metal L&F implementation of SeparatorUI.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>i>n.r"slSf>eptjxlra/


Uses of Class javax.swing.plaf.basic.BasicSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI

  • Packages that use BasicSliderUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicSliderUI in javax.swing.plaf.metal

      Subclasses of BasicSliderUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalSliderUI
      A Java L&F implementation of SliderUI.

    • Uses of BasicSliderUI in javax.swing.plaf.synth

      Subclasses of BasicSliderUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSliderUI
      Provides the Synth L&F UI delegate for JSlider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dit


Uses of Class javax.swing.plaf.basic.BasicSliderUI.ActionScroller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.ActionScroller

No usage of javax.swing.plaf.basic.BasicSliderUI.ActionScroller
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c o/I


Uses of Class javax.swing.plaf.basic.BasicSliderUI.ChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.ChangeHandler

No usage of javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r塩t>/>l //oIaooo/s


Uses of Class javax.swing.plaf.basic.BasicSliderUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.ComponentHandler

No usage of javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dd!v<=niorpu ,r/n


Uses of Class javax.swing.plaf.basic.BasicSliderUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicSliderUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-pmotsn>sl>g/s


Uses of Class javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler

  • Packages that use BasicSliderUI.PropertyChangeHandler
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicSliderUI.PropertyChangeHandler in javax.swing.plaf.metal

      Subclasses of BasicSliderUI.PropertyChangeHandler in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalSliderUI.MetalPropertyListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htrll < >l>>><==.x.nmb/xe


Uses of Class javax.swing.plaf.basic.BasicSliderUI.ScrollListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.ScrollListener

  • Packages that use BasicSliderUI.ScrollListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicSliderUI.ScrollListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicSliderUI.ScrollListener
      修饰符与类型 | 字段与描述
      protected BasicSliderUI.ScrollListener | BasicSliderUI.scrollListener
      Methods in javax.swing.plaf.basic that return BasicSliderUI.ScrollListener
      修饰符与类型 | 方法与描述
      protected BasicSliderUI.ScrollListener | BasicSliderUI.createScrollListener(JSlider slider)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i衕"u>mLd辉r鬾� ｄe pd "e


Uses of Class javax.swing.plaf.basic.BasicSliderUI.TrackListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSliderUI.TrackListener

  • Packages that use BasicSliderUI.TrackListener
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicSliderUI.TrackListener in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicSliderUI.TrackListener
      修饰符与类型 | 字段与描述
      protected BasicSliderUI.TrackListener | BasicSliderUI.trackListener
      Methods in javax.swing.plaf.basic that return BasicSliderUI.TrackListener
      修饰符与类型 | 方法与描述
      protected BasicSliderUI.TrackListener | BasicSliderUI.createTrackListener(JSlider slider)

    • Uses of BasicSliderUI.TrackListener in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return BasicSliderUI.TrackListener
      修饰符与类型 | 方法与描述
      protected BasicSliderUI.TrackListener | SynthSliderUI.createTrackListener(JSlider s)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ion->amahJs/i


Uses of Class javax.swing.plaf.basic.BasicSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSpinnerUI

  • Packages that use BasicSpinnerUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicSpinnerUI in javax.swing.plaf.synth

      Subclasses of BasicSpinnerUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSpinnerUI
      Provides the Synth L&F UI delegate for JSpinner.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s


Uses of Class javax.swing.plaf.basic.BasicSplitPaneDivider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneDivider

  • Packages that use BasicSplitPaneDivider
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicSplitPaneDivider in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicSplitPaneDivider
      修饰符与类型 字段与描述
      protected BasicSplitPaneDivider BasicSplitPaneUI.divider
      Instance of the divider for this JSplitPane.
      Methods in javax.swing.plaf.basic that return BasicSplitPaneDivider
      修饰符与类型 方法与描述
      BasicSplitPaneDivider BasicSplitPaneUI.createDefaultDivider()
      Creates the default divider.
      BasicSplitPaneDivider BasicSplitPaneUI.getDivider()
      Returns the divider between the top Components.

    • Uses of BasicSplitPaneDivider in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return BasicSplitPaneDivider
      修饰符与类型 方法与描述
      BasicSplitPaneDivider MetalSplitPaneUI.createDefaultDivider()
      Creates the default divider.

    • Uses of BasicSplitPaneDivider in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return BasicSplitPaneDivider
      修饰符与类型 方法与描述
      BasicSplitPaneDivider SynthSplitPaneUI.createDefaultDivider()
      Creates the default divider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nieaDos(ac\./t靑rfp


Uses of Class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout

No usage of javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneDivider.DragController

  • Packages that use BasicSplitPaneDivider.DragController
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicSplitPaneDivider.DragController in javax.swing.plaf.basic

      Subclasses of BasicSplitPaneDivider.DragController in javax.swing.plaf.basic
      修饰符与类型 类与描述
      protected class  BasicSplitPaneDivider.VerticalDragController
      Handles the events during a dragging session for a VERTICAL_SPLIT oriented split pane.
      Fields in javax.swing.plaf.basic declared as BasicSplitPaneDivider.DragController
      修饰符与类型 字段与描述
      protected BasicSplitPaneDivider.DragController BasicSplitPaneDivider.dragger
      Handles mouse dragging message to do the actual dragging.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lr1Ssv> e"爏.la/l�/


Uses of Class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler

  • Packages that use BasicSplitPaneDivider.MouseHandler
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicSplitPaneDivider.MouseHandler in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicSplitPaneDivider.MouseHandler
      修饰符与类型 字段与描述
      protected BasicSplitPaneDivider.MouseHandler BasicSplitPaneDivider.mouseHandler
      Handles mouse events from both this class, and the split pane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

scinax//.jjj./ ec-permau


Uses of Class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController

No usage of javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/<.ri><>" i"LL"aovL


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI

  • Packages that use BasicSplitPaneUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicSplitPaneUI in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicSplitPaneUI
      修饰符与类型 字段与描述
      protected BasicSplitPaneUI BasicSplitPaneDivider.splitPaneUI
      UI this instance was created from.
      Methods in javax.swing.plaf.basic that return BasicSplitPaneUI
      修饰符与类型 方法与描述
      BasicSplitPaneUI BasicSplitPaneDivider.getBasicSplitPaneUI()
      Returns the SplitPaneUI the receiver is currently in.
      Methods in javax.swing.plaf.basic with parameters of type BasicSplitPaneUI
      修饰符与类型 方法与描述
      void BasicSplitPaneDivider.setBasicSplitPaneUI(BasicSplitPaneUI newUI)
      Sets the SplitPaneUI that is using the receiver.
      Constructors in javax.swing.plaf.basic with parameters of type BasicSplitPaneUI
      构造方法与描述
      BasicSplitPaneDivider(BasicSplitPaneUI ui)
      Creates an instance of BasicSplitPaneDivider.

    • Uses of BasicSplitPaneUI in javax.swing.plaf.metal

      Subclasses of BasicSplitPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalSplitPaneUI
      Metal split pane.

    • Uses of BasicSplitPaneUI in javax.swing.plaf.synth

      Subclasses of BasicSplitPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSplitPaneUI
      Provides the Synth L&F UI delegate for JSplitPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uno


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

  • Packages that use BasicSplitPaneUI.BasicHorizontalLayoutManager
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicSplitPaneUI.BasicHorizontalLayoutManager in javax.swing.plaf.basic

      Subclasses of BasicSplitPaneUI.BasicHorizontalLayoutManager in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicSplitPaneUI.BasicVerticalLayoutManager
      LayoutManager used for JSplitPanes with an orientation of VERTICAL_SPLIT.
      Fields in javax.swing.plaf.basic declared as BasicSplitPaneUI.BasicHorizontalLayoutManager
      修饰符与类型 字段与描述
      protected BasicSplitPaneUI.BasicHorizontalLayoutManager BasicSplitPaneUI.layoutManager
      LayoutManager that is created and placed into the split pane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.S"Eu.ttpeg/cpe


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sUinax//.jjj./ /n.ua


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eslrble ><<b


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&a癰bb


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ieia 眃. �&


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>mgvol "di g evtbov"


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>csRo>T>g莞be3&la癰bo


Uses of Class javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler

No usage of javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>1sRo>T>g莞be3&Ma癰bo


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI

  • Packages that use BasicTabbedPaneUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTabbedPaneUI in javax.swing.plaf.metal

      Subclasses of BasicTabbedPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTabbedPaneUI
      The Metal subclass of BasicTabbedPaneUI.

    • Uses of BasicTabbedPaneUI in javax.swing.plaf.synth

      Subclasses of BasicTabbedPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sa


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st>


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler

No usage of javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/rppswivaaaa./ t.sjr


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

daiC>=mdasdbvrd


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout

  • Packages that use BasicTabbedPaneUI.TabbedPaneLayout
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicTabbedPaneUI.TabbedPaneLayout in javax.swing.plaf.metal

      Subclasses of BasicTabbedPaneUI.TabbedPaneLayout in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTabbedPaneUI.TabbedPaneLayout
      This inner class is marked "public" due to a compiler bug.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


Uses of Class javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler

No usage of javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r." hril>>>>i""a"fot


Uses of Class javax.swing.plaf.basic.BasicTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableHeaderUI

  • Packages that use BasicTableHeaderUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTableHeaderUI in javax.swing.plaf.synth

      Subclasses of BasicTableHeaderUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTableHeaderUI
      Provides the Synth L&F UI delegate for JTableHeader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c iot,t


Uses of Class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mi"itllm""".Hcc"r<>B


Uses of Class javax.swing.plaf.basic.BasicTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableUI

  • Packages that use BasicTableUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTableUI in javax.swing.plaf.synth

      Subclasses of BasicTableUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTableUI
      Provides the Synth L&F UI delegate for JTable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1l/t1�1 �,. l o, e� ts


Uses of Class javax.swing.plaf.basic.BasicTableUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicTableUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


Uses of Class javax.swing.plaf.basic.BasicTableUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableUI.KeyHandler

No usage of javax.swing.plaf.basic.BasicTableUI.KeyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lresic//fbbbpx..h


Uses of Class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTableUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne">a"iv/l1ga>.w".a


Uses of Class javax.swing.plaf.basic.BasicTextAreaUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextAreaUI

  • Packages that use BasicTextAreaUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTextAreaUI in javax.swing.plaf.synth

      Subclasses of BasicTextAreaUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.plaf.basic.BasicTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextFieldUI

  • Packages that use BasicTextFieldUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTextFieldUI in javax.swing.plaf.basic

      Subclasses of BasicTextFieldUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicFormattedTextFieldUI
      Provides the look and feel implementation for JFormattedTextField.
      class  BasicPasswordFieldUI
      Provides the Windows look and feel for a password field.

    • Uses of BasicTextFieldUI in javax.swing.plaf.metal

      Subclasses of BasicTextFieldUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTextFieldUI
      Basis of a look and feel for a JTextField.

    • Uses of BasicTextFieldUI in javax.swing.plaf.synth

      Subclasses of BasicTextFieldUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=hl l<


Uses of Class javax.swing.plaf.basic.BasicTextPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextPaneUI

No usage of javax.swing.plaf.basic.BasicTextPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iccb.plwsiiias /rnai


Uses of Class javax.swing.plaf.basic.BasicTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextUI

  • Packages that use BasicTextUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of BasicTextUI in javax.swing.plaf.basic

      Subclasses of BasicTextUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicEditorPaneUI
      Provides the look and feel for a JEditorPane.
      class  BasicFormattedTextFieldUI
      Provides the look and feel implementation for JFormattedTextField.
      class  BasicPasswordFieldUI
      Provides the Windows look and feel for a password field.
      class  BasicTextAreaUI
      Provides the look and feel for a plain text editor.
      class  BasicTextFieldUI
      Basis of a look and feel for a JTextField.
      class  BasicTextPaneUI
      Provides the look and feel for a styled text editor.

    • Uses of BasicTextUI in javax.swing.plaf.metal

      Subclasses of BasicTextUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTextFieldUI
      Basis of a look and feel for a JTextField.

    • Uses of BasicTextUI in javax.swing.plaf.synth

      Subclasses of BasicTextUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.

    • Uses of BasicTextUI in javax.swing.text

      Subclasses of BasicTextUI in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultTextUI
      Deprecated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tophesv-"er>"d>t�=er


Uses of Class javax.swing.plaf.basic.BasicTextUI.BasicCaret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextUI.BasicCaret

No usage of javax.swing.plaf.basic.BasicTextUI.BasicCaret
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ececm>lnlcde.pgtbt �<


Uses of Class javax.swing.plaf.basic.BasicTextUI.BasicHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTextUI.BasicHighlighter

No usage of javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

->snr>!ttp->t =/ ao


Uses of Class javax.swing.plaf.basic.BasicToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToggleButtonUI

  • Packages that use BasicToggleButtonUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicToggleButtonUI in javax.swing.plaf.basic

      Subclasses of BasicToggleButtonUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicCheckBoxUI
      CheckboxUI implementation for BasicCheckboxUI
      class  BasicRadioButtonUI
      RadioButtonUI implementation for BasicRadioButtonUI

    • Uses of BasicToggleButtonUI in javax.swing.plaf.metal

      Subclasses of BasicToggleButtonUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
      class  MetalRadioButtonUI
      RadioButtonUI implementation for MetalRadioButtonUI
      class  MetalToggleButtonUI
      MetalToggleButton implementation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>hcr"coalsssdlcc. ln./dgr


Uses of Class javax.swing.plaf.basic.BasicToolBarSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarSeparatorUI

No usage of javax.swing.plaf.basic.BasicToolBarSeparatorUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nj= tithmmmUiss" g


Uses of Class javax.swing.plaf.basic.BasicToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI

  • Packages that use BasicToolBarUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicToolBarUI in javax.swing.plaf.metal

      Subclasses of BasicToolBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalToolBarUI
      A Metal Look and Feel implementation of ToolBarUI.

    • Uses of BasicToolBarUI in javax.swing.plaf.synth

      Subclasses of BasicToolBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b!> Jh9dr r u/r kn_�."rv


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.DockingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.DockingListener

  • Packages that use BasicToolBarUI.DockingListener
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicToolBarUI.DockingListener in javax.swing.plaf.metal

      Subclasses of BasicToolBarUI.DockingListener in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalToolBarUI.MetalDockingListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e�=te;t >/l=/ato/a/w><


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.DragWindow

  • Packages that use BasicToolBarUI.DragWindow
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of BasicToolBarUI.DragWindow in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as BasicToolBarUI.DragWindow
      修饰符与类型 | 字段与描述
      protected BasicToolBarUI.DragWindow | BasicToolBarUI.dragWindow
      Methods in javax.swing.plaf.basic that return BasicToolBarUI.DragWindow
      修饰符与类型 | 方法与描述
      protected BasicToolBarUI.DragWindow | BasicToolBarUI.createDragWindow(JToolBar toolbar)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u&>tia>i�


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.FrameListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.FrameListener

No usage of javax.swing.plaf.basic.BasicToolBarUI.FrameListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

UiIsic".fbbbpxllwj/gl


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.PropertyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.PropertyListener

  • Packages that use BasicToolBarUI.PropertyListener
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicToolBarUI.PropertyListener in javax.swing.plaf.metal

      Subclasses of BasicToolBarUI.PropertyListener in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalToolBarUI.MetalRolloverListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eTx...i......"<


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener

  • Packages that use BasicToolBarUI.ToolBarContListener
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of BasicToolBarUI.ToolBarContListener in javax.swing.plaf.metal

      Subclasses of BasicToolBarUI.ToolBarContListener in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      protected class  | MetalToolBarUI.MetalContainerListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

B=ah at萳/Cirp//anubur"sn


Uses of Class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener

No usage of javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a><逝鲻�"avvl


Uses of Class javax.swing.plaf.basic.BasicToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicToolTipUI

  • Packages that use BasicToolTipUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicToolTipUI in javax.swing.plaf.metal

      Subclasses of BasicToolTipUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalToolTipUI
      A Metal L&F extension of BasicToolTipUI.

    • Uses of BasicToolTipUI in javax.swing.plaf.synth

      Subclasses of BasicToolTipUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthToolTipUI
      Provides the Synth L&F UI delegate for JToolTip.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raecp/fi9c諮"jl erxp/


Uses of Class javax.swing.plaf.basic.BasicTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI

  • Packages that use BasicTreeUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of BasicTreeUI in javax.swing.plaf.metal

      Subclasses of BasicTreeUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTreeUI
      The metal look and feel implementation of TreeUI.

    • Uses of BasicTreeUI in javax.swing.plaf.synth

      Subclasses of BasicTreeUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTreeUI
      Provides the Synth L&F UI delegate for JTree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vRos 萻c


Uses of Class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snywavalm""".-yycaiIt


Uses of Class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>rst>w>lnwa"a>"y-a"


Uses of Class javax.swing.plaf.basic.BasicTreeUI.FocusHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.FocusHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.FocusHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-bmotsn>sl>g/s�


Uses of Class javax.swing.plaf.basic.BasicTreeUI.KeyHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.KeyHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.KeyHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a0fx./j./.../faacilt


Uses of Class javax.swing.plaf.basic.BasicTreeUI.MouseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.MouseHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.MouseHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r yeasAefssse/..liy


Uses of Class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x"tli"C<>///olvdr y"l


Uses of Class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Hx/csetlpspnd".aro/a


Uses of Class javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

T=僫�(lp":< d;r�


Uses of Class javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tmknbrytcraa>"xnaww.


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slplasy/ <�


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&渁癰bs


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>l-rd>oln> odsa


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla"y/


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreePageAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreePageAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreePageAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

穖0ommlL


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>g/sS


Uses of Class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction

No usage of javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<TP=-/.o mt


Uses of Class javax.swing.plaf.basic.BasicViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.BasicViewportUI

No usage of javax.swing.plaf.basic.BasicViewportUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA"yachc/y.m谤h<鎟╩�


Uses of Class javax.swing.plaf.basic.DefaultMenuLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.basic.DefaultMenuLayout

No usage of javax.swing.plaf.basic.DefaultMenuLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elmb isT>hhhcaooelgxe


Uses of Interface javax.swing.plaf.basic.ComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.plaf.basic.ComboPopup

  • Packages that use ComboPopup
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ComboPopup in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ComboPopup
      修饰符与类型 类与描述
      class  BasicComboPopup
      This is a basic implementation of the ComboPopup interface.
      Fields in javax.swing.plaf.basic declared as ComboPopup
      修饰符与类型 | 字段与描述
      protected ComboPopup | BasicComboBoxUI.popup
      Methods in javax.swing.plaf.basic that return ComboPopup
      修饰符与类型 方法与描述
      protected ComboPopup BasicComboBoxUI.createPopup()
      Creates the popup portion of the combo box.

    • Uses of ComboPopup in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ComboPopup
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.
      Methods in javax.swing.plaf.metal that return ComboPopup
      修饰符与类型 | 方法与描述
      protected ComboPopup | MetalComboBoxUI.createPopup()

    • Uses of ComboPopup in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return ComboPopup
      修饰符与类型 | 方法与描述
      protected ComboPopup | SynthComboBoxUI.createPopup()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcocil眜=sta=a d=a./


Uses of Class javax.swing.plaf.ActionMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ActionMapUIResource

No usage of javax.swing.plaf.ActionMapUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.r�


Uses of Class javax.swing.plaf.BorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource

No usage of javax.swing.plaf.BorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e9rsiofoisotsrf/澹偶


Uses of Class javax.swing.plaf.BorderUIResource.BevelBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.BevelBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.BevelBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-d/ireLx.depf�


Uses of Class javax.swing.plaf.BorderUIResource.CompoundBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.CompoundBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/em>ratca.yolj/>e<


Uses of Class javax.swing.plaf.BorderUIResource.EmptyBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.EmptyBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slplapy/ <.


Uses of Class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.EtchedBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"黷va


Uses of Class javax.swing.plaf.BorderUIResource.LineBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.LineBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.LineBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l r l/dt 黡a


Uses of Class javax.swing.plaf.BorderUIResource.MatteBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.MatteBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.MatteBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a.8t 3Td


Uses of Class javax.swing.plaf.BorderUIResource.TitledBorderUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.BorderUIResource.TitledBorderUIResource

No usage of javax.swing.plaf.BorderUIResource.TitledBorderUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

黲dd e/i s


Uses of Class javax.swing.plaf.ButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ButtonUI

  • Packages that use ButtonUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ButtonUI in javax.swing

      Methods in javax.swing that return ButtonUI
      修饰符与类型 方法与描述
      ButtonUI AbstractButton.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type ButtonUI
      修饰符与类型 方法与描述
      void AbstractButton.setUI(ButtonUI ui)
      Sets the L&F object that renders this component.

    • Uses of ButtonUI in javax.swing.plaf

      Subclasses of ButtonUI in javax.swing.plaf
      修饰符与类型 类与描述
      class  MenuItemUI
      Pluggable look and feel interface for JMenuItem.

    • Uses of ButtonUI in javax.swing.plaf.basic

      Subclasses of ButtonUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicButtonUI
      BasicButton implementation
      class  BasicCheckBoxMenuItemUI
      BasicCheckboxMenuItem implementation
      class  BasicCheckBoxUI
      CheckboxUI implementation for BasicCheckboxUI
      class  BasicMenuItemUI
      BasicMenuItem implementation
      class  BasicMenuUI
      A default L&F implementation of MenuUI.
      class  BasicRadioButtonMenuItemUI
      BasicRadioButtonMenuItem implementation
      class  BasicRadioButtonUI
      RadioButtonUI implementation for BasicRadioButtonUI
      class  BasicToggleButtonUI
      BasicToggleButton implementation

    • Uses of ButtonUI in javax.swing.plaf.metal

      Subclasses of ButtonUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalButtonUI
      MetalButtonUI implementation
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
      class  MetalRadioButtonUI
      RadioButtonUI implementation for MetalRadioButtonUI
      class  MetalToggleButtonUI
      MetalToggleButton implementation

    • Uses of ButtonUI in javax.swing.plaf.multi

      Subclasses of ButtonUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiButtonUI
      A multiplexing UI used to combine ButtonUIs.
      class  MultiMenuItemUI
      A multiplexing UI used to combine MenuItemUIs.

    • Uses of ButtonUI in javax.swing.plaf.synth

      Subclasses of ButtonUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthButtonUI
      Provides the Synth L&F UI delegate for JButton.
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laeysidvrem>p#>ec;#


Uses of Class javax.swing.plaf.ColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ColorChooserUI

  • Packages that use ColorChooserUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ColorChooserUI in javax.swing

      Methods in javax.swing that return ColorChooserUI
      修饰符与类型 方法与描述
      ColorChooserUI JColorChooser.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type ColorChooserUI
      修饰符与类型 方法与描述
      void JColorChooser.setUI(ColorChooserUI ui)
      Sets the L&F object that renders this component.

    • Uses of ColorChooserUI in javax.swing.plaf.basic

      Subclasses of ColorChooserUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicColorChooserUI
      Provides the basic look and feel for a JColorChooser.

    • Uses of ColorChooserUI in javax.swing.plaf.multi

      Subclasses of ColorChooserUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiColorChooserUI
      A multiplexing UI used to combine ColorChooserUIs.

    • Uses of ColorChooserUI in javax.swing.plaf.synth

      Subclasses of ColorChooserUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthColorChooserUI
      Provides the Synth L&F UI delegate for JColorChooser.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c;kc


Uses of Class javax.swing.plaf.ColorUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ColorUIResource

  • Packages that use ColorUIResource
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of ColorUIResource in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return ColorUIResource
      修饰符与类型 方法与描述
      ColorUIResource MetalTheme.getAcceleratorForeground()
      Returns the accelerator foreground color.
      static ColorUIResource MetalLookAndFeel.getAcceleratorForeground()
      Returns the accelerator foreground color of the current theme.
      ColorUIResource MetalTheme.getAcceleratorSelectedForeground()
      Returns the accelerator selected foreground color.
      static ColorUIResource MetalLookAndFeel.getAcceleratorSelectedForeground()
      Returns the accelerator selected foreground color of the current theme.
      protected ColorUIResource OceanTheme.getBlack()
      Returns the black color.
      protected ColorUIResource MetalTheme.getBlack()
      Returns the black color.
      static ColorUIResource MetalLookAndFeel.getBlack()
      Returns the black color of the current theme.
      ColorUIResource MetalTheme.getControl()
      Returns the control color.
      static ColorUIResource MetalLookAndFeel.getControl()
      Returns the control color of the current theme.
      ColorUIResource MetalTheme.getControlDarkShadow()
      Returns the control dark shadow color.
      static ColorUIResource MetalLookAndFeel.getControlDarkShadow()
      Returns the control dark shadow color of the current theme.
      ColorUIResource MetalTheme.getControlDisabled()
      Returns the control disabled color.
      static ColorUIResource MetalLookAndFeel.getControlDisabled()
      Returns the control disabled color of the current theme.
      ColorUIResource MetalTheme.getControlHighlight()
      Returns the control highlight color.
      static ColorUIResource MetalLookAndFeel.getControlHighlight()
      Returns the control highlight color of the current theme.
      ColorUIResource MetalTheme.getControlInfo()
      Returns the control info color.
      static ColorUIResource MetalLookAndFeel.getControlInfo()
      Returns the control info color of the current theme.
      ColorUIResource MetalTheme.getControlShadow()
      Returns the control shadow color.
      static ColorUIResource MetalLookAndFeel.getControlShadow()
      Returns the control shadow color of the current theme.
      ColorUIResource OceanTheme.getControlTextColor()
      Returns the control text color.
      ColorUIResource MetalTheme.getControlTextColor()
      Returns the control text color.
      static ColorUIResource MetalLookAndFeel.getControlTextColor()
      Returns the control text color of the current theme.
      ColorUIResource OceanTheme.getDesktopColor()
      Returns the desktop color.
      ColorUIResource MetalTheme.getDesktopColor()
      Returns the desktop color.
      static ColorUIResource MetalLookAndFeel.getDesktopColor()
      Returns the desktop color of the current theme.
      ColorUIResource MetalTheme.getFocusColor()
      Returns the focus color.
      static ColorUIResource MetalLookAndFeel.getFocusColor()
      Returns the focus color of the current theme.
      ColorUIResource MetalTheme.getHighlightedTextColor()
      Returns the highlighted text color.
      static ColorUIResource MetalLookAndFeel.getHighlightedTextColor()
      Returns the highlighted text color of the current theme.
      ColorUIResource OceanTheme.getInactiveControlTextColor()
      Returns the inactive control text color.
      ColorUIResource MetalTheme.getInactiveControlTextColor()
      Returns the inactive control text color.
      static ColorUIResource MetalLookAndFeel.getInactiveControlTextColor()
      Returns the inactive control text color of the current theme.
      ColorUIResource MetalTheme.getInactiveSystemTextColor()
      Returns the inactive system text color.
      static ColorUIResource MetalLookAndFeel.getInactiveSystemTextColor()
      Returns the inactive system text color of the current theme.
      ColorUIResource MetalTheme.getMenuBackground()
      Returns the menu background color.
      static ColorUIResource MetalLookAndFeel.getMenuBackground()
      Returns the menu background color of the current theme.
      ColorUIResource OceanTheme.getMenuDisabledForeground()
      Returns the menu disabled foreground color.
      ColorUIResource MetalTheme.getMenuDisabledForeground()
      Returns the menu disabled foreground color.
      static ColorUIResource MetalLookAndFeel.getMenuDisabledForeground()
      Returns the menu disabled foreground color of the current theme.
      ColorUIResource MetalTheme.getMenuForeground()
      Returns the menu foreground color.
      static ColorUIResource MetalLookAndFeel.getMenuForeground()
      Returns the menu foreground color of the current theme.
      ColorUIResource MetalTheme.getMenuSelectedBackground()
      Returns the menu selected background color.
      static ColorUIResource MetalLookAndFeel.getMenuSelectedBackground()
      Returns the menu selected background color of the current theme.
      ColorUIResource MetalTheme.getMenuSelectedForeground()
      Returns the menu selected foreground color.
      static ColorUIResource MetalLookAndFeel.getMenuSelectedForeground()
      Returns the menu selected foreground color of the current theme.
      protected ColorUIResource DefaultMetalTheme.getPrimary1()
      Returns the primary 1 color.
      protected ColorUIResource OceanTheme.getPrimary1()
      Returns the primary 1 color.
      protected abstract ColorUIResource MetalTheme.getPrimary1()
      Returns the primary 1 color.
      protected ColorUIResource DefaultMetalTheme.getPrimary2()
      Returns the primary 2 color.
      protected ColorUIResource OceanTheme.getPrimary2()
      Returns the primary 2 color.
      protected abstract ColorUIResource MetalTheme.getPrimary2()
      Returns the primary 2 color.
      protected ColorUIResource DefaultMetalTheme.getPrimary3()
      Returns the primary 3 color.
      protected ColorUIResource OceanTheme.getPrimary3()
      Returns the primary 3 color.
      protected abstract ColorUIResource MetalTheme.getPrimary3()
      Returns the primary 3 color.
      ColorUIResource MetalTheme.getPrimaryControl()
      Returns the primary control color.
      static ColorUIResource MetalLookAndFeel.getPrimaryControl()
      Returns the primary control color of the current theme.
      ColorUIResource MetalTheme.getPrimaryControlDarkShadow()
      Returns the primary control dark shadow color.
      static ColorUIResource MetalLookAndFeel.getPrimaryControlDarkShadow()
      Returns the primary control dark shadow color of the current theme.
      ColorUIResource MetalTheme.getPrimaryControlHighlight()
      Returns the primary control highlight color.
      static ColorUIResource MetalLookAndFeel.getPrimaryControlHighlight()
      Returns the primary control highlight color of the current theme.
      ColorUIResource MetalTheme.getPrimaryControlInfo()
      Returns the primary control info color.
      static ColorUIResource MetalLookAndFeel.getPrimaryControlInfo()
      Returns the primary control info color of the current theme.
      ColorUIResource MetalTheme.getPrimaryControlShadow()
      Returns the primary control shadow color.
      static ColorUIResource MetalLookAndFeel.getPrimaryControlShadow()
      Returns the primary control shadow color of the current theme.
      protected ColorUIResource DefaultMetalTheme.getSecondary1()
      Returns the secondary 1 color.
      protected ColorUIResource OceanTheme.getSecondary1()
      Returns the secondary 1 color.
      protected abstract ColorUIResource MetalTheme.getSecondary1()
      Returns the secondary 1 color.
      protected ColorUIResource DefaultMetalTheme.getSecondary2()
      Returns the secondary 2 color.
      protected ColorUIResource OceanTheme.getSecondary2()
      Returns the secondary 2 color.
      protected abstract ColorUIResource MetalTheme.getSecondary2()
      Returns the secondary 2 color.
      protected ColorUIResource DefaultMetalTheme.getSecondary3()
      Returns the secondary 3 color.
      protected ColorUIResource OceanTheme.getSecondary3()
      Returns the secondary 3 color.
      protected abstract ColorUIResource MetalTheme.getSecondary3()
      Returns the secondary 3 color.
      ColorUIResource MetalTheme.getSeparatorBackground()
      Returns the separator background color.
      static ColorUIResource MetalLookAndFeel.getSeparatorBackground()
      Returns the separator background color of the current theme.
      ColorUIResource MetalTheme.getSeparatorForeground()
      Returns the separator foreground color.
      static ColorUIResource MetalLookAndFeel.getSeparatorForeground()
      Returns the separator foreground color of the current theme.
      ColorUIResource MetalTheme.getSystemTextColor()
      Returns the system text color.
      static ColorUIResource MetalLookAndFeel.getSystemTextColor()
      Returns the system text color of the current theme.
      ColorUIResource MetalTheme.getTextHighlightColor()
      Returns the text highlight color.
      static ColorUIResource MetalLookAndFeel.getTextHighlightColor()
      Returns the text highlight color of the current theme.
      ColorUIResource MetalTheme.getUserTextColor()
      Returns the user text color.
      static ColorUIResource MetalLookAndFeel.getUserTextColor()
      Returns the user text color of the current theme.
      protected ColorUIResource MetalTheme.getWhite()
      Returns the white color.
      static ColorUIResource MetalLookAndFeel.getWhite()
      Returns the white color of the current theme.
      ColorUIResource MetalTheme.getWindowBackground()
      Returns the window background color.
      static ColorUIResource MetalLookAndFeel.getWindowBackground()
      Returns the window background color of the current theme.
      ColorUIResource MetalTheme.getWindowTitleBackground()
      Returns the window title background color.
      static ColorUIResource MetalLookAndFeel.getWindowTitleBackground()
      Returns the window title background color of the current theme.
      ColorUIResource MetalTheme.getWindowTitleForeground()
      Returns the window title foreground color.
      static ColorUIResource MetalLookAndFeel.getWindowTitleForeground()
      Returns the window title foreground color of the current theme.
      ColorUIResource MetalTheme.getWindowTitleInactiveBackground()
      Returns the window title inactive background color.
      static ColorUIResource MetalLookAndFeel.getWindowTitleInactiveBackground()
      Returns the window title inactive background color of the current theme.
      ColorUIResource MetalTheme.getWindowTitleInactiveForeground()
      Returns the window title inactive foreground color.
      static ColorUIResource MetalLookAndFeel.getWindowTitleInactiveForeground()
      Returns the window title inactive foreground color of the current theme.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.ComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ComboBoxUI

  • Packages that use ComboBoxUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ComboBoxUI in javax.swing

      Methods in javax.swing that return ComboBoxUI
      修饰符与类型 方法与描述
      ComboBoxUI JComboBox.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type ComboBoxUI
      修饰符与类型 方法与描述
      void JComboBox.setUI(ComboBoxUI ui)
      Sets the L&F object that renders this component.

    • Uses of ComboBoxUI in javax.swing.plaf.basic

      Subclasses of ComboBoxUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicComboBoxUI
      Basic UI implementation for JComboBox.

    • Uses of ComboBoxUI in javax.swing.plaf.metal

      Subclasses of ComboBoxUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalComboBoxUI
      Metal UI for JComboBox

    • Uses of ComboBoxUI in javax.swing.plaf.multi

      Subclasses of ComboBoxUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiComboBoxUI
      A multiplexing UI used to combine ComboBoxUIs.

    • Uses of ComboBoxUI in javax.swing.plaf.synth

      Subclasses of ComboBoxUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthComboBoxUI
      Provides the Synth L&F UI delegate for JComboBox.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>o>


Uses of Class javax.swing.plaf.ComponentInputMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ComponentInputMapUIResource

No usage of javax.swing.plaf.ComponentInputMapUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/nlpe= "sssas//snpn�


Uses of Class javax.swing.plaf.ComponentUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ComponentUI

  • Packages that use ComponentUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of ComponentUI in javax.swing

      Fields in javax.swing declared as ComponentUI
      修饰符与类型 字段与描述
      protected ComponentUI JComponent.ui
      The look and feel delegate for this component.
      Methods in javax.swing that return ComponentUI
      修饰符与类型 方法与描述
      static ComponentUI UIManager.getUI(JComponent target)
      Returns the appropriate ComponentUI implementation for target.
      ComponentUI UIDefaults.getUI(JComponent target)
      Creates an ComponentUI implementation for the specified component.
      Methods in javax.swing that return types with arguments of type ComponentUI
      修饰符与类型 方法与描述
      类<? extends ComponentUI> UIDefaults.getUIClass(String uiClassID)
      Returns the L&F class that renders this component.
      类<? extends ComponentUI> UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader)
      The value of get(uidClassID) must be the String name of a class that implements the corresponding ComponentUI class.
      Methods in javax.swing with parameters of type ComponentUI
      修饰符与类型 方法与描述
      protected void JComponent.setUI(ComponentUI newUI)
      Sets the look and feel delegate for this component.

    • Uses of ComponentUI in javax.swing.plaf

      Subclasses of ComponentUI in javax.swing.plaf
      修饰符与类型 类与描述
      class  ButtonUI
      Pluggable look and feel interface for JButton.
      class  ColorChooserUI
      Pluggable look and feel interface for JColorChooser.
      class  ComboBoxUI
      Pluggable look and feel interface for JComboBox.
      class  DesktopIconUI
      Pluggable look and feel interface for JDesktopIcon.
      class  DesktopPaneUI
      Pluggable look and feel interface for JDesktopPane.
      class  FileChooserUI
      Pluggable look and feel interface for JFileChooser.
      class  InternalFrameUI
      Pluggable look and feel interface for JInternalFrame.
      class  LabelUI
      Pluggable look and feel interface for JLabel.
      class  LayerUI<V extends Component>
      The base class for all JLayer's UI delegates.
      class  ListUI
      The JList pluggable look and feel delegate.
      class  MenuBarUI
      Pluggable look and feel interface for JMenuBar.
      class  MenuItemUI
      Pluggable look and feel interface for JMenuItem.
      class  OptionPaneUI
      Pluggable look and feel interface for JOptionPane.
      class  PanelUI
      Pluggable look and feel interface for Panel.
      class  PopupMenuUI
      Pluggable look and feel interface for JPopupMenu.
      class  ProgressBarUI
      Pluggable look and feel interface for JProgressBar.
      class  RootPaneUI
      Pluggable look and feel interface for JRootPane.
      class  ScrollBarUI
      Pluggable look and feel interface for JScrollBar.
      class  ScrollPaneUI
      Pluggable look and feel interface for JScrollPane.
      class  SeparatorUI
      Pluggable look and feel interface for JSeparator.
      class  SliderUI
      Pluggable look and feel interface for JSlider.
      class  SpinnerUI
      Pluggable look and feel interface for JSpinner
      class  SplitPaneUI
      Pluggable look and feel interface for JSplitPane.
      class  TabbedPaneUI
      Pluggable look and feel interface for JTabbedPane.
      class  TableHeaderUI
      Pluggable look and feel interface for JTableHeader.
      class  TableUI
      Pluggable look and feel interface for JTable.
      class  TextUI
      Text editor user interface
      class  ToolBarUI
      Pluggable look and feel interface for JToolBar.
      class  ToolTipUI
      Pluggable look and feel interface for JToolTip.
      class  TreeUI
      Pluggable look and feel interface for JTree.
      class  ViewportUI
      Pluggable look and feel interface for JViewport.
      Methods in javax.swing.plaf that return ComponentUI
      修饰符与类型 方法与描述
      static ComponentUI ComponentUI.createUI(JComponent c)
      Returns an instance of the UI delegate for the specified component.

    • Uses of ComponentUI in javax.swing.plaf.basic

      Subclasses of ComponentUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicButtonUI
      BasicButton implementation
      class  BasicCheckBoxMenuItemUI
      BasicCheckboxMenuItem implementation
      class  BasicCheckBoxUI
      CheckboxUI implementation for BasicCheckboxUI
      class  BasicColorChooserUI
      Provides the basic look and feel for a JColorChooser.
      class  BasicComboBoxUI
      Basic UI implementation for JComboBox.
      class  BasicDesktopIconUI
      Basic L&F for a minimized window on a desktop.
      class  BasicDesktopPaneUI
      Basic L&F for a desktop.
      class  BasicEditorPaneUI
      Provides the look and feel for a JEditorPane.
      class  BasicFileChooserUI
      Basic L&F implementation of a FileChooser.
      class  BasicFormattedTextFieldUI
      Provides the look and feel implementation for JFormattedTextField.
      class  BasicInternalFrameUI
      A basic L&F implementation of JInternalFrame.
      class  BasicLabelUI
      A Windows L&F implementation of LabelUI.
      class  BasicListUI
      An extensible implementation of ListUI.
      class  BasicMenuBarUI
      A default L&F implementation of MenuBarUI.
      class  BasicMenuItemUI
      BasicMenuItem implementation
      class  BasicMenuUI
      A default L&F implementation of MenuUI.
      class  BasicOptionPaneUI
      Provides the basic look and feel for a JOptionPane.
      class  BasicPanelUI
      BasicPanel implementation
      class  BasicPasswordFieldUI
      Provides the Windows look and feel for a password field.
      class  BasicPopupMenuSeparatorUI
      A Basic L&F implementation of PopupMenuSeparatorUI.
      class  BasicPopupMenuUI
      A Windows L&F implementation of PopupMenuUI.
      class  BasicProgressBarUI
      A Basic L&F implementation of ProgressBarUI.
      class  BasicRadioButtonMenuItemUI
      BasicRadioButtonMenuItem implementation
      class  BasicRadioButtonUI
      RadioButtonUI implementation for BasicRadioButtonUI
      class  BasicRootPaneUI
      Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
      class  BasicScrollBarUI
      Implementation of ScrollBarUI for the Basic Look and Feel
      class  BasicScrollPaneUI
      A default L&F implementation of ScrollPaneUI.
      class  BasicSeparatorUI
      A Basic L&F implementation of SeparatorUI.
      class  BasicSliderUI
      A Basic L&F implementation of SliderUI.
      class  BasicSpinnerUI
      The default Spinner UI delegate.
      class  BasicSplitPaneUI
      A Basic L&F implementation of the SplitPaneUI.
      class  BasicTabbedPaneUI
      A Basic L&F implementation of TabbedPaneUI.
      class  BasicTableHeaderUI
      BasicTableHeaderUI implementation
      class  BasicTableUI
      BasicTableUI implementation
      class  BasicTextAreaUI
      Provides the look and feel for a plain text editor.
      class  BasicTextFieldUI
      Basis of a look and feel for a JTextField.
      class  BasicTextPaneUI
      Provides the look and feel for a styled text editor.
      class  BasicTextUI
      Basis of a text components look-and-feel.
      class  BasicToggleButtonUI
      BasicToggleButton implementation
      class  BasicToolBarSeparatorUI
      A Basic L&F implementation of ToolBarSeparatorUI.
      class  BasicToolBarUI
      A Basic L&F implementation of ToolBarUI.
      class  BasicToolTipUI
      Standard tool tip L&F.
      class  BasicTreeUI
      The basic L&F for a hierarchical data structure.
      class  BasicViewportUI
      BasicViewport implementation
      Methods in javax.swing.plaf.basic that return ComponentUI
      修饰符与类型 | 方法与描述
      static ComponentUI | BasicViewportUI.createUI(JComponent c)
      static ComponentUI BasicFormattedTextFieldUI.createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      static ComponentUI | BasicCheckBoxUI.createUI(JComponent b)
      static ComponentUI | BasicToolBarSeparatorUI.createUI(JComponent c)
      static ComponentUI | BasicPopupMenuSeparatorUI.createUI(JComponent c)
      static ComponentUI | BasicSeparatorUI.createUI(JComponent c)
      static ComponentUI BasicPasswordFieldUI.createUI(JComponent c)
      Creates a UI for a JPasswordField.
      static ComponentUI | BasicToggleButtonUI.createUI(JComponent b)
      static ComponentUI | BasicRadioButtonUI.createUI(JComponent b)
      static ComponentUI BasicTextPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI | BasicToolTipUI.createUI(JComponent c)
      static ComponentUI | BasicToolBarUI.createUI(JComponent c)
      static ComponentUI BasicTextAreaUI.createUI(JComponent ta)
      Creates a UI for a JTextArea.
      static ComponentUI | BasicTableHeaderUI.createUI(JComponent h)
      static ComponentUI | BasicTableUI.createUI(JComponent c)
      static ComponentUI | BasicTabbedPaneUI.createUI(JComponent c)
      static ComponentUI BasicSpinnerUI.createUI(JComponent c)
      Returns a new instance of BasicSpinnerUI.
      static ComponentUI | BasicSliderUI.createUI(JComponent b)
      static ComponentUI | BasicScrollPaneUI.createUI(JComponent x)
      static ComponentUI | BasicScrollBarUI.createUI(JComponent c)
      static ComponentUI | BasicProgressBarUI.createUI(JComponent x)
      static ComponentUI BasicOptionPaneUI.createUI(JComponent x)
      Creates a new BasicOptionPaneUI instance.
      static ComponentUI | BasicPanelUI.createUI(JComponent c)
      static ComponentUI BasicListUI.createUI(JComponent list)
      Returns a new instance of BasicListUI.
      static ComponentUI | BasicLabelUI.createUI(JComponent c)
      static ComponentUI | BasicInternalFrameUI.createUI(JComponent b)
      static ComponentUI BasicTextFieldUI.createUI(JComponent c)
      Creates a UI for a JTextField.
      static ComponentUI | BasicDesktopIconUI.createUI(JComponent c)
      static ComponentUI | BasicDesktopPaneUI.createUI(JComponent c)
      static ComponentUI | BasicColorChooserUI.createUI(JComponent c)
      static ComponentUI BasicFileChooserUI.createUI(JComponent c)
      Creates a BasicFileChooserUI implementation for the specified component.
      static ComponentUI BasicEditorPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI | BasicMenuBarUI.createUI(JComponent x)
      static ComponentUI | BasicButtonUI.createUI(JComponent c)
      static ComponentUI | BasicRadioButtonMenuItemUI.createUI(JComponent b)
      static ComponentUI | BasicCheckBoxMenuItemUI.createUI(JComponent c)
      static ComponentUI | BasicMenuUI.createUI(JComponent x)
      static ComponentUI | BasicTreeUI.createUI(JComponent x)
      static ComponentUI | BasicRootPaneUI.createUI(JComponent c)
      static ComponentUI | BasicComboBoxUI.createUI(JComponent c)
      static ComponentUI | BasicMenuItemUI.createUI(JComponent c)
      static ComponentUI BasicSplitPaneUI.createUI(JComponent x)
      Creates a new BasicSplitPaneUI instance
      static ComponentUI | BasicPopupMenuUI.createUI(JComponent x)

    • Uses of ComponentUI in javax.swing.plaf.metal

      Subclasses of ComponentUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalButtonUI
      MetalButtonUI implementation
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
      class  MetalComboBoxUI
      Metal UI for JComboBox
      class  MetalDesktopIconUI
      Metal desktop icon.
      class  MetalFileChooserUI
      Metal L&F implementation of a FileChooser.
      class  MetalInternalFrameUI
      Metal implementation of JInternalFrame.
      class  MetalLabelUI
      A Windows L&F implementation of LabelUI.
      class  MetalMenuBarUI
      Metal implementation of MenuBarUI.
      class  MetalPopupMenuSeparatorUI
      A Metal L&F implementation of PopupMenuSeparatorUI.
      class  MetalProgressBarUI
      The Metal implementation of ProgressBarUI.
      class  MetalRadioButtonUI
      RadioButtonUI implementation for MetalRadioButtonUI
      class  MetalRootPaneUI
      Provides the metal look and feel implementation of RootPaneUI.
      class  MetalScrollBarUI
      Implementation of ScrollBarUI for the Metal Look and Feel
      class  MetalScrollPaneUI
      A Metal L&F implementation of ScrollPaneUI.
      class  MetalSeparatorUI
      A Metal L&F implementation of SeparatorUI.
      class  MetalSliderUI
      A Java L&F implementation of SliderUI.
      class  MetalSplitPaneUI
      Metal split pane.
      class  MetalTabbedPaneUI
      The Metal subclass of BasicTabbedPaneUI.
      class  MetalTextFieldUI
      Basis of a look and feel for a JTextField.
      class  MetalToggleButtonUI
      MetalToggleButton implementation
      class  MetalToolBarUI
      A Metal Look and Feel implementation of ToolBarUI.
      class  MetalToolTipUI
      A Metal L&F extension of BasicToolTipUI.
      class  MetalTreeUI
      The metal look and feel implementation of TreeUI.
      Methods in javax.swing.plaf.metal that return ComponentUI
      修饰符与类型 | 方法与描述
      static ComponentUI | MetalToolTipUI.createUI(JComponent c)
      static ComponentUI | MetalToolBarUI.createUI(JComponent c)
      static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
      static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
      static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
      static ComponentUI MetalSplitPaneUI.createUI(JComponent x)
      Creates a new MetalSplitPaneUI instance
      static ComponentUI | MetalTreeUI.createUI(JComponent x)
      static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
      static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
      static ComponentUI MetalRootPaneUI.createUI(JComponent c)
      Creates a UI for a JRootPane.
      static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
      static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
      static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
      static ComponentUI MetalMenuBarUI.createUI(JComponent x)
      Creates the ComponentUI implementation for the passed in component.
      static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
      static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
      static ComponentUI | MetalSliderUI.createUI(JComponent c)
      static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
      static ComponentUI | MetalLabelUI.createUI(JComponent c)
      static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
      static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
      static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
      static ComponentUI | MetalButtonUI.createUI(JComponent c)

    • Uses of ComponentUI in javax.swing.plaf.multi

      Subclasses of ComponentUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiButtonUI
      A multiplexing UI used to combine ButtonUIs.
      class  MultiColorChooserUI
      A multiplexing UI used to combine ColorChooserUIs.
      class  MultiComboBoxUI
      A multiplexing UI used to combine ComboBoxUIs.
      class  MultiDesktopIconUI
      A multiplexing UI used to combine DesktopIconUIs.
      class  MultiDesktopPaneUI
      A multiplexing UI used to combine DesktopPaneUIs.
      class  MultiFileChooserUI
      A multiplexing UI used to combine FileChooserUIs.
      class  MultiInternalFrameUI
      A multiplexing UI used to combine InternalFrameUIs.
      class  MultiLabelUI
      A multiplexing UI used to combine LabelUIs.
      class  MultiListUI
      A multiplexing UI used to combine ListUIs.
      class  MultiMenuBarUI
      A multiplexing UI used to combine MenuBarUIs.
      class  MultiMenuItemUI
      A multiplexing UI used to combine MenuItemUIs.
      class  MultiOptionPaneUI
      A multiplexing UI used to combine OptionPaneUIs.
      class  MultiPanelUI
      A multiplexing UI used to combine PanelUIs.
      class  MultiPopupMenuUI
      A multiplexing UI used to combine PopupMenuUIs.
      class  MultiProgressBarUI
      A multiplexing UI used to combine ProgressBarUIs.
      class  MultiRootPaneUI
      A multiplexing UI used to combine RootPaneUIs.
      class  MultiScrollBarUI
      A multiplexing UI used to combine ScrollBarUIs.
      class  MultiScrollPaneUI
      A multiplexing UI used to combine ScrollPaneUIs.
      class  MultiSeparatorUI
      A multiplexing UI used to combine SeparatorUIs.
      class  MultiSliderUI
      A multiplexing UI used to combine SliderUIs.
      class  MultiSpinnerUI
      A multiplexing UI used to combine SpinnerUIs.
      class  MultiSplitPaneUI
      A multiplexing UI used to combine SplitPaneUIs.
      class  MultiTabbedPaneUI
      A multiplexing UI used to combine TabbedPaneUIs.
      class  MultiTableHeaderUI
      A multiplexing UI used to combine TableHeaderUIs.
      class  MultiTableUI
      A multiplexing UI used to combine TableUIs.
      class  MultiTextUI
      A multiplexing UI used to combine TextUIs.
      class  MultiToolBarUI
      A multiplexing UI used to combine ToolBarUIs.
      class  MultiToolTipUI
      A multiplexing UI used to combine ToolTipUIs.
      class  MultiTreeUI
      A multiplexing UI used to combine TreeUIs.
      class  MultiViewportUI
      A multiplexing UI used to combine ViewportUIs.
      Methods in javax.swing.plaf.multi that return ComponentUI
      修饰符与类型 方法与描述
      static ComponentUI MultiViewportUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTreeUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiToolTipUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiToolBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTextUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTableUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTableHeaderUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiTabbedPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSplitPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSpinnerUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSliderUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiSeparatorUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiScrollPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiScrollBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiRootPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiProgressBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiPopupMenuUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiPanelUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiOptionPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiMenuItemUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiMenuBarUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiListUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiLabelUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiInternalFrameUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiFileChooserUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiDesktopPaneUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiDesktopIconUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiComboBoxUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiColorChooserUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiButtonUI.createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      static ComponentUI MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target)
      Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.
      ComponentUI[] MultiViewportUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiTreeUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiToolTipUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiToolBarUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiTextUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiTableUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiTableHeaderUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiTabbedPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiSplitPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiSpinnerUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiSliderUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiSeparatorUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiScrollPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiScrollBarUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiRootPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiProgressBarUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiPopupMenuUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiPanelUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiOptionPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiMenuItemUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiMenuBarUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiListUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiLabelUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiInternalFrameUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiFileChooserUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiDesktopPaneUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiDesktopIconUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiComboBoxUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiColorChooserUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      ComponentUI[] MultiButtonUI.getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      protected static ComponentUI[] MultiLookAndFeel.uisToArray(Vector uis)
      Creates an array, populates it with UI objects from the passed-in vector, and returns the array.
      Methods in javax.swing.plaf.multi with parameters of type ComponentUI
      修饰符与类型 方法与描述
      static ComponentUI MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target)
      Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.

    • Uses of ComponentUI in javax.swing.plaf.synth

      Subclasses of ComponentUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthButtonUI
      Provides the Synth L&F UI delegate for JButton.
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthColorChooserUI
      Provides the Synth L&F UI delegate for JColorChooser.
      class  SynthComboBoxUI
      Provides the Synth L&F UI delegate for JComboBox.
      class  SynthDesktopIconUI
      Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
      class  SynthDesktopPaneUI
      Provides the Synth L&F UI delegate for JDesktopPane.
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthInternalFrameUI
      Provides the Synth L&F UI delegate for JInternalFrame.
      class  SynthLabelUI
      Provides the Synth L&F UI delegate for JLabel.
      class  SynthListUI
      Provides the Synth L&F UI delegate for JList.
      class  SynthMenuBarUI
      Provides the Synth L&F UI delegate for JMenuBar.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthOptionPaneUI
      Provides the Synth L&F UI delegate for JOptionPane.
      class  SynthPanelUI
      Provides the Synth L&F UI delegate for JPanel.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthPopupMenuUI
      Provides the Synth L&F UI delegate for JPopupMenu.
      class  SynthProgressBarUI
      Provides the Synth L&F UI delegate for JProgressBar.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthRootPaneUI
      Provides the Synth L&F UI delegate for JRootPane.
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
      class  SynthSeparatorUI
      Provides the Synth L&F UI delegate for JSeparator.
      class  SynthSliderUI
      Provides the Synth L&F UI delegate for JSlider.
      class  SynthSpinnerUI
      Provides the Synth L&F UI delegate for JSpinner.
      class  SynthSplitPaneUI
      Provides the Synth L&F UI delegate for JSplitPane.
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
      class  SynthTableHeaderUI
      Provides the Synth L&F UI delegate for JTableHeader.
      class  SynthTableUI
      Provides the Synth L&F UI delegate for JTable.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.
      class  SynthToolTipUI
      Provides the Synth L&F UI delegate for JToolTip.
      class  SynthTreeUI
      Provides the Synth L&F UI delegate for JTree.
      class  SynthViewportUI
      Provides the Synth L&F UI delegate for JViewport.
      Methods in javax.swing.plaf.synth that return ComponentUI
      修饰符与类型 | 方法与描述
      static ComponentUI SynthViewportUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTreeUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthToolTipUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthToolBarUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTextPaneUI.createUI(JComponent c)
      Creates a UI for the JTextPane.
      static ComponentUI SynthTextAreaUI.createUI(JComponent ta)
      Creates a UI object for a JTextArea.
      static ComponentUI SynthTableHeaderUI.createUI(JComponent h)
      Creates a new UI object for the given component.
      static ComponentUI SynthTableUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthTabbedPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthSplitPaneUI.createUI(JComponent x)
      Creates a new SynthSplitPaneUI instance
      static ComponentUI SynthSpinnerUI.createUI(JComponent c)
      Returns a new instance of SynthSpinnerUI.
      static ComponentUI SynthSliderUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthScrollPaneUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI | SynthScrollBarUI.createUI(JComponent c)
      static ComponentUI SynthRootPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthRadioButtonMenuItemUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthProgressBarUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthPopupMenuUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthPasswordFieldUI.createUI(JComponent c)
      Creates a UI for a JPasswordField.
      static ComponentUI SynthSeparatorUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthPanelUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthOptionPaneUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuBarUI.createUI(JComponent x)
      Creates a new UI object for the given component.
      static ComponentUI SynthListUI.createUI(JComponent list)
      Creates a new UI object for the given component.
      static ComponentUI SynthInternalFrameUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthTextFieldUI.createUI(JComponent c)
      Creates a UI for a JTextField.
      static ComponentUI SynthFormattedTextFieldUI.createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      static ComponentUI SynthEditorPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthDesktopIconUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthDesktopPaneUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthComboBoxUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthLabelUI.createUI(JComponent c)
      Returns the LabelUI implementation used for the skins look and feel.
      static ComponentUI SynthColorChooserUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthMenuItemUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthCheckBoxMenuItemUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthToggleButtonUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthRadioButtonUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthCheckBoxUI.createUI(JComponent b)
      Creates a new UI object for the given component.
      static ComponentUI SynthButtonUI.createUI(JComponent c)
      Creates a new UI object for the given component.
      static ComponentUI SynthLookAndFeel.createUI(JComponent c)
      Creates the Synth look and feel ComponentUI for the passed in JComponent.

    • Uses of ComponentUI in javax.swing.text

      Subclasses of ComponentUI in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultTextUI
      Deprecated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.DesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.DesktopIconUI

  • Packages that use DesktopIconUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of DesktopIconUI in javax.swing

      Methods in javax.swing that return DesktopIconUI
      修饰符与类型 方法与描述
      DesktopIconUI JInternalFrame.JDesktopIcon.getUI()
      Returns the look-and-feel object that renders this component.
      Methods in javax.swing with parameters of type DesktopIconUI
      修饰符与类型 方法与描述
      void JInternalFrame.JDesktopIcon.setUI(DesktopIconUI ui)
      Sets the look-and-feel object that renders this component.

    • Uses of DesktopIconUI in javax.swing.plaf.basic

      Subclasses of DesktopIconUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicDesktopIconUI
      Basic L&F for a minimized window on a desktop.

    • Uses of DesktopIconUI in javax.swing.plaf.metal

      Subclasses of DesktopIconUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalDesktopIconUI
      Metal desktop icon.

    • Uses of DesktopIconUI in javax.swing.plaf.multi

      Subclasses of DesktopIconUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiDesktopIconUI
      A multiplexing UI used to combine DesktopIconUIs.

    • Uses of DesktopIconUI in javax.swing.plaf.synth

      Subclasses of DesktopIconUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthDesktopIconUI
      Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n=afrfai nnneoPPnreatr/lts


Uses of Class javax.swing.plaf.DesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.DesktopPaneUI

  • Packages that use DesktopPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of DesktopPaneUI in javax.swing

      Methods in javax.swing that return DesktopPaneUI
      修饰符与类型 方法与描述
      DesktopPaneUI JDesktopPane.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type DesktopPaneUI
      修饰符与类型 方法与描述
      void JDesktopPane.setUI(DesktopPaneUI ui)
      Sets the L&F object that renders this component.

    • Uses of DesktopPaneUI in javax.swing.plaf.basic

      Subclasses of DesktopPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicDesktopPaneUI
      Basic L&F for a desktop.

    • Uses of DesktopPaneUI in javax.swing.plaf.multi

      Subclasses of DesktopPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiDesktopPaneUI
      A multiplexing UI used to combine DesktopPaneUIs.

    • Uses of DesktopPaneUI in javax.swing.plaf.synth

      Subclasses of DesktopPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthDesktopPaneUI
      Provides the Synth L&F UI delegate for JDesktopPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"pEnp&ps;;;&SPP""i


Uses of Class javax.swing.plaf.DimensionUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.DimensionUIResource

No usage of javax.swing.plaf.DimensionUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

P.afng..xsssaall<>.h"


Uses of Class javax.swing.plaf.FileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.FileChooserUI

  • Packages that use FileChooserUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.

    • Uses of FileChooserUI in javax.swing

      Methods in javax.swing that return FileChooserUI
      修饰符与类型 方法与描述
      FileChooserUI JFileChooser.getUI()
      Gets the UI object which implements the L&F for this component.

    • Uses of FileChooserUI in javax.swing.plaf.basic

      Subclasses of FileChooserUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicFileChooserUI
      Basic L&F implementation of a FileChooser.

    • Uses of FileChooserUI in javax.swing.plaf.metal

      Subclasses of FileChooserUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalFileChooserUI
      Metal L&F implementation of a FileChooser.

    • Uses of FileChooserUI in javax.swing.plaf.multi

      Subclasses of FileChooserUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiFileChooserUI
      A multiplexing UI used to combine FileChooserUIs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uthUs< >lscla"itbb>s nt


Uses of Class javax.swing.plaf.FontUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.FontUIResource

  • Packages that use FontUIResource
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of FontUIResource in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return FontUIResource
      修饰符与类型 方法与描述
      FontUIResource DefaultMetalTheme.getControlTextFont()
      Returns the control text font.
      abstract FontUIResource MetalTheme.getControlTextFont()
      Returns the control text font.
      static FontUIResource MetalLookAndFeel.getControlTextFont()
      Returns the control text font of the current theme.
      FontUIResource DefaultMetalTheme.getMenuTextFont()
      Returns the menu text font.
      abstract FontUIResource MetalTheme.getMenuTextFont()
      Returns the menu text font.
      static FontUIResource MetalLookAndFeel.getMenuTextFont()
      Returns the menu text font of the current theme.
      FontUIResource DefaultMetalTheme.getSubTextFont()
      Returns the sub-text font.
      abstract FontUIResource MetalTheme.getSubTextFont()
      Returns the sub-text font.
      static FontUIResource MetalLookAndFeel.getSubTextFont()
      Returns the sub-text font of the current theme.
      FontUIResource DefaultMetalTheme.getSystemTextFont()
      Returns the system text font.
      abstract FontUIResource MetalTheme.getSystemTextFont()
      Returns the system text font.
      static FontUIResource MetalLookAndFeel.getSystemTextFont()
      Returns the sytem text font of the current theme.
      FontUIResource DefaultMetalTheme.getUserTextFont()
      Returns the user text font.
      abstract FontUIResource MetalTheme.getUserTextFont()
      Returns the user text font.
      static FontUIResource MetalLookAndFeel.getUserTextFont()
      Returns the user text font of the current theme.
      FontUIResource DefaultMetalTheme.getWindowTitleFont()
      Returns the window title font.
      abstract FontUIResource MetalTheme.getWindowTitleFont()
      Returns the window title font.
      static FontUIResource MetalLookAndFeel.getWindowTitleFont()
      Returns the window title font of the current theme.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aMbs ta.c=s jr/ig>ss


Uses of Class javax.swing.plaf.IconUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.IconUIResource

No usage of javax.swing.plaf.IconUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g>/j..//....=>ccl>Lso


Uses of Class javax.swing.plaf.InputMapUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.InputMapUIResource

No usage of javax.swing.plaf.InputMapUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o=.>e


Uses of Class javax.swing.plaf.InsetsUIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.InsetsUIResource

No usage of javax.swing.plaf.InsetsUIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.plaf.InternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.InternalFrameUI

  • Packages that use InternalFrameUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of InternalFrameUI in javax.swing

      Methods in javax.swing that return InternalFrameUI
      修饰符与类型 方法与描述
      InternalFrameUI JInternalFrame.getUI()
      Returns the look-and-feel object that renders this component.
      Methods in javax.swing with parameters of type InternalFrameUI
      修饰符与类型 方法与描述
      void JInternalFrame.setUI(InternalFrameUI ui)
      Sets the UI delegate for this JInternalFrame.

    • Uses of InternalFrameUI in javax.swing.plaf.basic

      Subclasses of InternalFrameUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicInternalFrameUI
      A basic L&F implementation of JInternalFrame.

    • Uses of InternalFrameUI in javax.swing.plaf.metal

      Subclasses of InternalFrameUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalInternalFrameUI
      Metal implementation of JInternalFrame.

    • Uses of InternalFrameUI in javax.swing.plaf.multi

      Subclasses of InternalFrameUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiInternalFrameUI
      A multiplexing UI used to combine InternalFrameUIs.

    • Uses of InternalFrameUI in javax.swing.plaf.synth

      Subclasses of InternalFrameUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthInternalFrameUI
      Provides the Synth L&F UI delegate for JInternalFrame.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tp �=


Uses of Class javax.swing.plaf.LabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.LabelUI

  • Packages that use LabelUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of LabelUI in javax.swing

      Methods in javax.swing that return LabelUI
      修饰符与类型 方法与描述
      LabelUI JLabel.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type LabelUI
      修饰符与类型 方法与描述
      void JLabel.setUI(LabelUI ui)
      Sets the L&F object that renders this component.

    • Uses of LabelUI in javax.swing.plaf.basic

      Subclasses of LabelUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicLabelUI
      A Windows L&F implementation of LabelUI.

    • Uses of LabelUI in javax.swing.plaf.metal

      Subclasses of LabelUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalLabelUI
      A Windows L&F implementation of LabelUI.

    • Uses of LabelUI in javax.swing.plaf.multi

      Subclasses of LabelUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiLabelUI
      A multiplexing UI used to combine LabelUIs.

    • Uses of LabelUI in javax.swing.plaf.synth

      Subclasses of LabelUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthLabelUI
      Provides the Synth L&F UI delegate for JLabel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osa/t:w:p/ol.loo糏<襛�<�>a


Uses of Class javax.swing.plaf.LayerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.LayerUI

  • Packages that use LayerUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of LayerUI in javax.swing

      Methods in javax.swing that return LayerUI
      修饰符与类型 方法与描述
      LayerUI<? super V> JLayer.getUI()
      Returns the LayerUI for this JLayer.
      Methods in javax.swing with parameters of type LayerUI
      修饰符与类型 方法与描述
      void JLayer.setUI(LayerUI<? super V> ui)
      Sets the LayerUI which will perform painting and receive input events for this JLayer.
      Constructors in javax.swing with parameters of type LayerUI
      构造方法与描述
      JLayer(V view, LayerUI<V> ui)
      Creates a new JLayer object with the specified view component and LayerUI object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stsron>acppp>pttrahlpucaln


Uses of Class javax.swing.plaf.ListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ListUI

  • Packages that use ListUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ListUI in javax.swing

      Methods in javax.swing that return ListUI
      修饰符与类型 方法与描述
      ListUI JList.getUI()
      Returns the ListUI, the look and feel object that renders this component.
      Methods in javax.swing with parameters of type ListUI
      修饰符与类型 方法与描述
      void JList.setUI(ListUI ui)
      Sets the ListUI, the look and feel object that renders this component.

    • Uses of ListUI in javax.swing.plaf.basic

      Subclasses of ListUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicListUI
      An extensible implementation of ListUI.

    • Uses of ListUI in javax.swing.plaf.multi

      Subclasses of ListUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiListUI
      A multiplexing UI used to combine ListUIs.

    • Uses of ListUI in javax.swing.plaf.synth

      Subclasses of ListUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthListUI
      Provides the Synth L&F UI delegate for JList.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>= /vdve /g--ppftr>糰b


Uses of Class javax.swing.plaf.MenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.MenuBarUI

  • Packages that use MenuBarUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of MenuBarUI in javax.swing

      Methods in javax.swing that return MenuBarUI
      修饰符与类型 方法与描述
      MenuBarUI JMenuBar.getUI()
      Returns the menubar's current UI.
      Methods in javax.swing with parameters of type MenuBarUI
      修饰符与类型 方法与描述
      void JMenuBar.setUI(MenuBarUI ui)
      Sets the L&F object that renders this component.

    • Uses of MenuBarUI in javax.swing.plaf.basic

      Subclasses of MenuBarUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicMenuBarUI
      A default L&F implementation of MenuBarUI.

    • Uses of MenuBarUI in javax.swing.plaf.metal

      Subclasses of MenuBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalMenuBarUI
      Metal implementation of MenuBarUI.

    • Uses of MenuBarUI in javax.swing.plaf.multi

      Subclasses of MenuBarUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiMenuBarUI
      A multiplexing UI used to combine MenuBarUIs.

    • Uses of MenuBarUI in javax.swing.plaf.synth

      Subclasses of MenuBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthMenuBarUI
      Provides the Synth L&F UI delegate for JMenuBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iwanctL"m


Uses of Class javax.swing.plaf.MenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.MenuItemUI

  • Packages that use MenuItemUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of MenuItemUI in javax.swing

      Methods in javax.swing with parameters of type MenuItemUI
      修饰符与类型 方法与描述
      void JMenuItem.setUI(MenuItemUI ui)
      Sets the look and feel object that renders this component.

    • Uses of MenuItemUI in javax.swing.plaf.basic

      Subclasses of MenuItemUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicCheckBoxMenuItemUI
      BasicCheckboxMenuItem implementation
      class  BasicMenuItemUI
      BasicMenuItem implementation
      class  BasicMenuUI
      A default L&F implementation of MenuUI.
      class  BasicRadioButtonMenuItemUI
      BasicRadioButtonMenuItem implementation

    • Uses of MenuItemUI in javax.swing.plaf.multi

      Subclasses of MenuItemUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiMenuItemUI
      A multiplexing UI used to combine MenuItemUIs.

    • Uses of MenuItemUI in javax.swing.plaf.synth

      Subclasses of MenuItemUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

� �+�jc4� a咳.奔


Uses of Class javax.swing.plaf.OptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.OptionPaneUI

  • Packages that use OptionPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of OptionPaneUI in javax.swing

      Methods in javax.swing that return OptionPaneUI
      修饰符与类型 方法与描述
      OptionPaneUI JOptionPane.getUI()
      Returns the UI object which implements the L&F for this component.
      Methods in javax.swing with parameters of type OptionPaneUI
      修饰符与类型 方法与描述
      void JOptionPane.setUI(OptionPaneUI ui)
      Sets the UI object which implements the L&F for this component.

    • Uses of OptionPaneUI in javax.swing.plaf.basic

      Subclasses of OptionPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicOptionPaneUI
      Provides the basic look and feel for a JOptionPane.

    • Uses of OptionPaneUI in javax.swing.plaf.multi

      Subclasses of OptionPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiOptionPaneUI
      A multiplexing UI used to combine OptionPaneUIs.

    • Uses of OptionPaneUI in javax.swing.plaf.synth

      Subclasses of OptionPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthOptionPaneUI
      Provides the Synth L&F UI delegate for JOptionPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laali///glllij//l>vaa>/ v=


Uses of Class javax.swing.plaf.PanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.PanelUI

  • Packages that use PanelUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of PanelUI in javax.swing

      Methods in javax.swing that return PanelUI
      修饰符与类型 方法与描述
      PanelUI JPanel.getUI()
      Returns the look and feel (L&F) object that renders this component.
      Methods in javax.swing with parameters of type PanelUI
      修饰符与类型 方法与描述
      void JPanel.setUI(PanelUI ui)
      Sets the look and feel (L&F) object that renders this component.

    • Uses of PanelUI in javax.swing.plaf.basic

      Subclasses of PanelUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicPanelUI
      BasicPanel implementation

    • Uses of PanelUI in javax.swing.plaf.multi

      Subclasses of PanelUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiPanelUI
      A multiplexing UI used to combine PanelUIs.

    • Uses of PanelUI in javax.swing.plaf.synth

      Subclasses of PanelUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthPanelUI
      Provides the Synth L&F UI delegate for JPanel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtvactotpa eedo 技纤≡蜃


Uses of Class javax.swing.plaf.PopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.PopupMenuUI

  • Packages that use PopupMenuUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of PopupMenuUI in javax.swing

      Methods in javax.swing that return PopupMenuUI
      修饰符与类型 方法与描述
      PopupMenuUI JPopupMenu.getUI()
      Returns the look and feel (L&F) object that renders this component.
      Methods in javax.swing with parameters of type PopupMenuUI
      修饰符与类型 方法与描述
      void JPopupMenu.setUI(PopupMenuUI ui)
      Sets the L&F object that renders this component.

    • Uses of PopupMenuUI in javax.swing.plaf.basic

      Subclasses of PopupMenuUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicPopupMenuUI
      A Windows L&F implementation of PopupMenuUI.

    • Uses of PopupMenuUI in javax.swing.plaf.multi

      Subclasses of PopupMenuUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiPopupMenuUI
      A multiplexing UI used to combine PopupMenuUIs.

    • Uses of PopupMenuUI in javax.swing.plaf.synth

      Subclasses of PopupMenuUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthPopupMenuUI
      Provides the Synth L&F UI delegate for JPopupMenu.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rrrt>


Uses of Class javax.swing.plaf.ProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ProgressBarUI

  • Packages that use ProgressBarUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ProgressBarUI in javax.swing

      Methods in javax.swing that return ProgressBarUI
      修饰符与类型 方法与描述
      ProgressBarUI JProgressBar.getUI()
      Returns the look-and-feel object that renders this component.
      Methods in javax.swing with parameters of type ProgressBarUI
      修饰符与类型 方法与描述
      void JProgressBar.setUI(ProgressBarUI ui)
      Sets the look-and-feel object that renders this component.

    • Uses of ProgressBarUI in javax.swing.plaf.basic

      Subclasses of ProgressBarUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicProgressBarUI
      A Basic L&F implementation of ProgressBarUI.

    • Uses of ProgressBarUI in javax.swing.plaf.metal

      Subclasses of ProgressBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalProgressBarUI
      The Metal implementation of ProgressBarUI.

    • Uses of ProgressBarUI in javax.swing.plaf.multi

      Subclasses of ProgressBarUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiProgressBarUI
      A multiplexing UI used to combine ProgressBarUIs.

    • Uses of ProgressBarUI in javax.swing.plaf.synth

      Subclasses of ProgressBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthProgressBarUI
      Provides the Synth L&F UI delegate for JProgressBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llexali.�)r<ā/rr衧他n鵪


Uses of Class javax.swing.plaf.RootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.RootPaneUI

  • Packages that use RootPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of RootPaneUI in javax.swing

      Methods in javax.swing that return RootPaneUI
      修饰符与类型 方法与描述
      RootPaneUI JRootPane.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type RootPaneUI
      修饰符与类型 方法与描述
      void JRootPane.setUI(RootPaneUI ui)
      Sets the L&F object that renders this component.

    • Uses of RootPaneUI in javax.swing.plaf.basic

      Subclasses of RootPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicRootPaneUI
      Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.

    • Uses of RootPaneUI in javax.swing.plaf.metal

      Subclasses of RootPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalRootPaneUI
      Provides the metal look and feel implementation of RootPaneUI.

    • Uses of RootPaneUI in javax.swing.plaf.multi

      Subclasses of RootPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiRootPaneUI
      A multiplexing UI used to combine RootPaneUIs.

    • Uses of RootPaneUI in javax.swing.plaf.synth

      Subclasses of RootPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthRootPaneUI
      Provides the Synth L&F UI delegate for JRootPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a 吮冕贬槐Ａ欲眔n<ū樱> �<


Uses of Class javax.swing.plaf.ScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ScrollBarUI

  • Packages that use ScrollBarUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ScrollBarUI in javax.swing

      Methods in javax.swing that return ScrollBarUI
      修饰符与类型 方法与描述
      ScrollBarUI JScrollBar.getUI()
      Returns the delegate that implements the look and feel for this component.
      Methods in javax.swing with parameters of type ScrollBarUI
      修饰符与类型 方法与描述
      void JScrollBar.setUI(ScrollBarUI ui)
      Sets the L&F object that renders this component.

    • Uses of ScrollBarUI in javax.swing.plaf.basic

      Subclasses of ScrollBarUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicScrollBarUI
      Implementation of ScrollBarUI for the Basic Look and Feel

    • Uses of ScrollBarUI in javax.swing.plaf.metal

      Subclasses of ScrollBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalScrollBarUI
      Implementation of ScrollBarUI for the Metal Look and Feel

    • Uses of ScrollBarUI in javax.swing.plaf.multi

      Subclasses of ScrollBarUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiScrollBarUI
      A multiplexing UI used to combine ScrollBarUIs.

    • Uses of ScrollBarUI in javax.swing.plaf.synth

      Subclasses of ScrollBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<<�>tatb<>so瞡t/>t覆s>p�


Uses of Class javax.swing.plaf.ScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ScrollPaneUI

  • Packages that use ScrollPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ScrollPaneUI in javax.swing

      Methods in javax.swing that return ScrollPaneUI
      修饰符与类型 方法与描述
      ScrollPaneUI JScrollPane.getUI()
      Returns the look and feel (L&F) object that renders this component.
      Methods in javax.swing with parameters of type ScrollPaneUI
      修饰符与类型 方法与描述
      void JScrollPane.setUI(ScrollPaneUI ui)
      Sets the ScrollPaneUI object that provides the look and feel (L&F) for this component.

    • Uses of ScrollPaneUI in javax.swing.plaf.basic

      Subclasses of ScrollPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicScrollPaneUI
      A default L&F implementation of ScrollPaneUI.

    • Uses of ScrollPaneUI in javax.swing.plaf.metal

      Subclasses of ScrollPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalScrollPaneUI
      A Metal L&F implementation of ScrollPaneUI.

    • Uses of ScrollPaneUI in javax.swing.plaf.multi

      Subclasses of ScrollPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiScrollPaneUI
      A multiplexing UI used to combine ScrollPaneUIs.

    • Uses of ScrollPaneUI in javax.swing.plaf.synth

      Subclasses of ScrollPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ll< e<�la.) rr<═ar衖�


Uses of Class javax.swing.plaf.SeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.SeparatorUI

  • Packages that use SeparatorUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SeparatorUI in javax.swing

      Methods in javax.swing that return SeparatorUI
      修饰符与类型 方法与描述
      SeparatorUI JSeparator.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type SeparatorUI
      修饰符与类型 方法与描述
      void JSeparator.setUI(SeparatorUI ui)
      Sets the L&F object that renders this component.

    • Uses of SeparatorUI in javax.swing.plaf.basic

      Subclasses of SeparatorUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicPopupMenuSeparatorUI
      A Basic L&F implementation of PopupMenuSeparatorUI.
      class  BasicSeparatorUI
      A Basic L&F implementation of SeparatorUI.
      class  BasicToolBarSeparatorUI
      A Basic L&F implementation of ToolBarSeparatorUI.

    • Uses of SeparatorUI in javax.swing.plaf.metal

      Subclasses of SeparatorUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalPopupMenuSeparatorUI
      A Metal L&F implementation of PopupMenuSeparatorUI.
      class  MetalSeparatorUI
      A Metal L&F implementation of SeparatorUI.

    • Uses of SeparatorUI in javax.swing.plaf.multi

      Subclasses of SeparatorUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiSeparatorUI
      A multiplexing UI used to combine SeparatorUIs.

    • Uses of SeparatorUI in javax.swing.plaf.synth

      Subclasses of SeparatorUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSeparatorUI
      Provides the Synth L&F UI delegate for JSeparator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdoeob oBb=lmpslsra


Uses of Class javax.swing.plaf.SliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.SliderUI

  • Packages that use SliderUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SliderUI in javax.swing

      Methods in javax.swing that return SliderUI
      修饰符与类型 方法与描述
      SliderUI JSlider.getUI()
      Gets the UI object which implements the L&F for this component.
      Methods in javax.swing with parameters of type SliderUI
      修饰符与类型 方法与描述
      void JSlider.setUI(SliderUI ui)
      Sets the UI object which implements the L&F for this component.

    • Uses of SliderUI in javax.swing.plaf.basic

      Subclasses of SliderUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicSliderUI
      A Basic L&F implementation of SliderUI.

    • Uses of SliderUI in javax.swing.plaf.metal

      Subclasses of SliderUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalSliderUI
      A Java L&F implementation of SliderUI.

    • Uses of SliderUI in javax.swing.plaf.multi

      Subclasses of SliderUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiSliderUI
      A multiplexing UI used to combine SliderUIs.

    • Uses of SliderUI in javax.swing.plaf.synth

      Subclasses of SliderUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSliderUI
      Provides the Synth L&F UI delegate for JSlider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>f>>l l<>aa


Uses of Class javax.swing.plaf.SpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.SpinnerUI

  • Packages that use SpinnerUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SpinnerUI in javax.swing

      Methods in javax.swing that return SpinnerUI
      修饰符与类型 方法与描述
      SpinnerUI JSpinner.getUI()
      Returns the look and feel (L&F) object that renders this component.
      Methods in javax.swing with parameters of type SpinnerUI
      修饰符与类型 方法与描述
      void JSpinner.setUI(SpinnerUI ui)
      Sets the look and feel (L&F) object that renders this component.

    • Uses of SpinnerUI in javax.swing.plaf.basic

      Subclasses of SpinnerUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicSpinnerUI
      The default Spinner UI delegate.

    • Uses of SpinnerUI in javax.swing.plaf.multi

      Subclasses of SpinnerUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiSpinnerUI
      A multiplexing UI used to combine SpinnerUIs.

    • Uses of SpinnerUI in javax.swing.plaf.synth

      Subclasses of SpinnerUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSpinnerUI
      Provides the Synth L&F UI delegate for JSpinner.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.av>v<<rss;r


Uses of Class javax.swing.plaf.SplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.SplitPaneUI

  • Packages that use SplitPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SplitPaneUI in javax.swing

      Methods in javax.swing that return SplitPaneUI
      修饰符与类型 方法与描述
      SplitPaneUI JSplitPane.getUI()
      Returns the SplitPaneUI that is providing the current look and feel.
      Methods in javax.swing with parameters of type SplitPaneUI
      修饰符与类型 方法与描述
      void JSplitPane.setUI(SplitPaneUI ui)
      Sets the L&F object that renders this component.

    • Uses of SplitPaneUI in javax.swing.plaf.basic

      Subclasses of SplitPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicSplitPaneUI
      A Basic L&F implementation of the SplitPaneUI.

    • Uses of SplitPaneUI in javax.swing.plaf.metal

      Subclasses of SplitPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalSplitPaneUI
      Metal split pane.

    • Uses of SplitPaneUI in javax.swing.plaf.multi

      Subclasses of SplitPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiSplitPaneUI
      A multiplexing UI used to combine SplitPaneUIs.

    • Uses of SplitPaneUI in javax.swing.plaf.synth

      Subclasses of SplitPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthSplitPaneUI
      Provides the Synth L&F UI delegate for JSplitPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aE


Uses of Class javax.swing.plaf.TabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.TabbedPaneUI

  • Packages that use TabbedPaneUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of TabbedPaneUI in javax.swing

      Methods in javax.swing that return TabbedPaneUI
      修饰符与类型 方法与描述
      TabbedPaneUI JTabbedPane.getUI()
      Returns the UI object which implements the L&F for this component.
      Methods in javax.swing with parameters of type TabbedPaneUI
      修饰符与类型 方法与描述
      void JTabbedPane.setUI(TabbedPaneUI ui)
      Sets the UI object which implements the L&F for this component.

    • Uses of TabbedPaneUI in javax.swing.plaf.basic

      Subclasses of TabbedPaneUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTabbedPaneUI
      A Basic L&F implementation of TabbedPaneUI.

    • Uses of TabbedPaneUI in javax.swing.plaf.metal

      Subclasses of TabbedPaneUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTabbedPaneUI
      The Metal subclass of BasicTabbedPaneUI.

    • Uses of TabbedPaneUI in javax.swing.plaf.multi

      Subclasses of TabbedPaneUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiTabbedPaneUI
      A multiplexing UI used to combine TabbedPaneUIs.

    • Uses of TabbedPaneUI in javax.swing.plaf.synth

      Subclasses of TabbedPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ebcjEkavci=cbiie.dlt .0�


Uses of Class javax.swing.plaf.TableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.TableHeaderUI

  • Packages that use TableHeaderUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableHeaderUI in javax.swing.plaf.basic

      Subclasses of TableHeaderUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTableHeaderUI
      BasicTableHeaderUI implementation

    • Uses of TableHeaderUI in javax.swing.plaf.multi

      Subclasses of TableHeaderUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiTableHeaderUI
      A multiplexing UI used to combine TableHeaderUIs.

    • Uses of TableHeaderUI in javax.swing.plaf.synth

      Subclasses of TableHeaderUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTableHeaderUI
      Provides the Synth L&F UI delegate for JTableHeader.

    • Uses of TableHeaderUI in javax.swing.table

      Methods in javax.swing.table that return TableHeaderUI
      修饰符与类型 方法与描述
      TableHeaderUI JTableHeader.getUI()
      Returns the look and feel (L&F) object that renders this component.
      Methods in javax.swing.table with parameters of type TableHeaderUI
      修饰符与类型 方法与描述
      void JTableHeader.setUI(TableHeaderUI ui)
      Sets the look and feel (L&F) object that renders this component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"<i>v<<bb;;opf>�;r1


Uses of Class javax.swing.plaf.TableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.TableUI

  • Packages that use TableUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of TableUI in javax.swing

      Methods in javax.swing that return TableUI
      修饰符与类型 方法与描述
      TableUI JTable.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type TableUI
      修饰符与类型 方法与描述
      void JTable.setUI(TableUI ui)
      Sets the L&F object that renders this component and repaints.

    • Uses of TableUI in javax.swing.plaf.basic

      Subclasses of TableUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTableUI
      BasicTableUI implementation

    • Uses of TableUI in javax.swing.plaf.multi

      Subclasses of TableUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiTableUI
      A multiplexing UI used to combine TableUIs.

    • Uses of TableUI in javax.swing.plaf.synth

      Subclasses of TableUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTableUI
      Provides the Synth L&F UI delegate for JTable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ddaeeeedal,vee�"tav琣n�


Uses of Class javax.swing.plaf.TextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.TextUI

  • Packages that use TextUI
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TextUI in javax.swing.plaf.basic

      Subclasses of TextUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicEditorPaneUI
      Provides the look and feel for a JEditorPane.
      class  BasicFormattedTextFieldUI
      Provides the look and feel implementation for JFormattedTextField.
      class  BasicPasswordFieldUI
      Provides the Windows look and feel for a password field.
      class  BasicTextAreaUI
      Provides the look and feel for a plain text editor.
      class  BasicTextFieldUI
      Basis of a look and feel for a JTextField.
      class  BasicTextPaneUI
      Provides the look and feel for a styled text editor.
      class  BasicTextUI
      Basis of a text components look-and-feel.

    • Uses of TextUI in javax.swing.plaf.metal

      Subclasses of TextUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTextFieldUI
      Basis of a look and feel for a JTextField.

    • Uses of TextUI in javax.swing.plaf.multi

      Subclasses of TextUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiTextUI
      A multiplexing UI used to combine TextUIs.

    • Uses of TextUI in javax.swing.plaf.synth

      Subclasses of TextUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.

    • Uses of TextUI in javax.swing.text

      Subclasses of TextUI in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultTextUI
      Deprecated.
      Methods in javax.swing.text that return TextUI
      修饰符与类型 方法与描述
      TextUI JTextComponent.getUI()
      Fetches the user-interface factory for this text-oriented editor.
      Methods in javax.swing.text with parameters of type TextUI
      修饰符与类型 方法与描述
      void JTextComponent.setUI(TextUI ui)
      Sets the user-interface factory for this text-oriented editor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.oe纆/iaesns.d薼Cx


Uses of Class javax.swing.plaf.ToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ToolBarUI

  • Packages that use ToolBarUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ToolBarUI in javax.swing

      Methods in javax.swing that return ToolBarUI
      修饰符与类型 方法与描述
      ToolBarUI JToolBar.getUI()
      Returns the tool bar's current UI.
      Methods in javax.swing with parameters of type ToolBarUI
      修饰符与类型 方法与描述
      void JToolBar.setUI(ToolBarUI ui)
      Sets the L&F object that renders this component.

    • Uses of ToolBarUI in javax.swing.plaf.basic

      Subclasses of ToolBarUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicToolBarUI
      A Basic L&F implementation of ToolBarUI.

    • Uses of ToolBarUI in javax.swing.plaf.metal

      Subclasses of ToolBarUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalToolBarUI
      A Metal Look and Feel implementation of ToolBarUI.

    • Uses of ToolBarUI in javax.swing.plaf.multi

      Subclasses of ToolBarUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiToolBarUI
      A multiplexing UI used to combine ToolBarUIs.

    • Uses of ToolBarUI in javax.swing.plaf.synth

      Subclasses of ToolBarUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xs.se="t iiimesscaty teep


Uses of Class javax.swing.plaf.ToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ToolTipUI

  • Packages that use ToolTipUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ToolTipUI in javax.swing

      Methods in javax.swing that return ToolTipUI
      修饰符与类型 方法与描述
      ToolTipUI JToolTip.getUI()
      Returns the L&F object that renders this component.

    • Uses of ToolTipUI in javax.swing.plaf.basic

      Subclasses of ToolTipUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicToolTipUI
      Standard tool tip L&F.

    • Uses of ToolTipUI in javax.swing.plaf.metal

      Subclasses of ToolTipUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalToolTipUI
      A Metal L&F extension of BasicToolTipUI.

    • Uses of ToolTipUI in javax.swing.plaf.multi

      Subclasses of ToolTipUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiToolTipUI
      A multiplexing UI used to combine ToolTipUIs.

    • Uses of ToolTipUI in javax.swing.plaf.synth

      Subclasses of ToolTipUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthToolTipUI
      Provides the Synth L&F UI delegate for JToolTip.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

patvxjcj/vsiv"ssrrs.c-snlc


Uses of Class javax.swing.plaf.TreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.TreeUI

  • Packages that use TreeUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of TreeUI in javax.swing

      Methods in javax.swing that return TreeUI
      修饰符与类型 方法与描述
      TreeUI JTree.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type TreeUI
      修饰符与类型 方法与描述
      void JTree.setUI(TreeUI ui)
      Sets the L&F object that renders this component.

    • Uses of TreeUI in javax.swing.plaf.basic

      Subclasses of TreeUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTreeUI
      The basic L&F for a hierarchical data structure.

    • Uses of TreeUI in javax.swing.plaf.metal

      Subclasses of TreeUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalTreeUI
      The metal look and feel implementation of TreeUI.

    • Uses of TreeUI in javax.swing.plaf.multi

      Subclasses of TreeUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiTreeUI
      A multiplexing UI used to combine TreeUIs.

    • Uses of TreeUI in javax.swing.plaf.synth

      Subclasses of TreeUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTreeUI
      Provides the Synth L&F UI delegate for JTree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cb 1,0O021 a 罯r纈苬 �&思n


Uses of Class javax.swing.plaf.ViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.ViewportUI

  • Packages that use ViewportUI
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ViewportUI in javax.swing

      Methods in javax.swing that return ViewportUI
      修饰符与类型 方法与描述
      ViewportUI JViewport.getUI()
      Returns the L&F object that renders this component.
      Methods in javax.swing with parameters of type ViewportUI
      修饰符与类型 方法与描述
      void JViewport.setUI(ViewportUI ui)
      Sets the L&F object that renders this component.

    • Uses of ViewportUI in javax.swing.plaf.basic

      Subclasses of ViewportUI in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicViewportUI
      BasicViewport implementation

    • Uses of ViewportUI in javax.swing.plaf.multi

      Subclasses of ViewportUI in javax.swing.plaf.multi
      修饰符与类型 类与描述
      class  MultiViewportUI
      A multiplexing UI used to combine ViewportUIs.

    • Uses of ViewportUI in javax.swing.plaf.synth

      Subclasses of ViewportUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthViewportUI
      Provides the Synth L&F UI delegate for JViewport.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>pxff .xgb/vm


Uses of Interface javax.swing.plaf.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.plaf.UIResource

  • Packages that use UIResource
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of UIResource in javax.swing

      Classes in javax.swing that implement UIResource
      修饰符与类型 类与描述
      static class  DefaultListCellRenderer.UIResource
      A subclass of DefaultListCellRenderer that implements UIResource.
      protected class  JScrollPane.ScrollBar
      By default JScrollPane creates scrollbars that are instances of this class.
      static class  ScrollPaneLayout.UIResource
      The UI resource version of ScrollPaneLayout.

    • Uses of UIResource in javax.swing.plaf

      Classes in javax.swing.plaf that implement UIResource
      修饰符与类型 | 类与描述
      class  ActionMapUIResource
      A subclass of javax.swing.ActionMap that implements UIResource.
      class  | BorderUIResource
      static class  | BorderUIResource.BevelBorderUIResource
      static class  | BorderUIResource.CompoundBorderUIResource
      static class  | BorderUIResource.EmptyBorderUIResource
      static class  | BorderUIResource.EtchedBorderUIResource
      static class  | BorderUIResource.LineBorderUIResource
      static class  | BorderUIResource.MatteBorderUIResource
      static class  | BorderUIResource.TitledBorderUIResource
      class  | ColorUIResource
      class  ComponentInputMapUIResource
      A subclass of javax.swing.ComponentInputMap that implements UIResource.
      class  | DimensionUIResource
      class  FontUIResource
      A subclass of java.awt.Font that implements UIResource.
      class  IconUIResource
      An Icon wrapper class which implements UIResource.
      class  InputMapUIResource
      A subclass of javax.swing.InputMap that implements UIResource.
      class  | InsetsUIResource

    • Uses of UIResource in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement UIResource
      修饰符与类型 | 类与描述
      static class  | BasicBorders.ButtonBorder
      static class  | BasicBorders.FieldBorder
      static class  | BasicBorders.MarginBorder
      static class  | BasicBorders.MenuBarBorder
      static class  | BasicBorders.RadioButtonBorder
      static class  BasicBorders.RolloverButtonBorder
      Special thin border for rollover toolbar buttons.
      static class  BasicBorders.SplitPaneBorder
      Draws the border around the splitpane.
      static class  | BasicBorders.ToggleButtonBorder
      static class  BasicComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
      static class  BasicComboBoxRenderer.UIResource
      A subclass of BasicComboBoxRenderer that implements UIResource.
      static class  | BasicTextUI.BasicCaret
      static class  | BasicTextUI.BasicHighlighter
      class  DefaultMenuLayout
      The default layout manager for Popup menus and menubars.

    • Uses of UIResource in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement UIResource
      修饰符与类型 | 类与描述
      static class  | MetalBorders.ButtonBorder
      static class  | MetalBorders.Flush3DBorder
      static class  | MetalBorders.InternalFrameBorder
      static class  | MetalBorders.MenuBarBorder
      static class  | MetalBorders.MenuItemBorder
      static class  | MetalBorders.OptionDialogBorder
      static class  MetalBorders.PaletteBorder
      Border for a Palette.
      static class  | MetalBorders.PopupMenuBorder
      static class  | MetalBorders.RolloverButtonBorder
      static class  | MetalBorders.ScrollPaneBorder
      static class  | MetalBorders.TextFieldBorder
      static class  | MetalBorders.ToggleButtonBorder
      static class  | MetalBorders.ToolBarBorder
      class  MetalCheckBoxIcon
      CheckboxIcon implementation for OrganicCheckBoxUI
      static class  MetalComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
      static class  MetalIconFactory.PaletteCloseIcon
      Defines an icon for Palette close

    • Uses of UIResource in javax.swing.table

      Classes in javax.swing.table that implement UIResource
      修饰符与类型 类与描述
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m_nrba"╝t.>rea.s-riosl


DefaultMetalTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 DefaultMetalTheme

  • java.lang.Object
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
  • 直接已知子类：
    OceanTheme

    public class DefaultMetalTheme
extends MetalTheme
    A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel". Refer to MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme) for details on changing the default theme.

    All colors returned by DefaultMetalTheme are completely opaque.

    Font Style

    DefaultMetalTheme uses bold fonts for many controls. To make all controls (with the exception of the internal frame title bars and client decorated frame title bars) use plain fonts you can do either of the following:
    • Set the system property swing.boldMetal to false. For example, java -Dswing.boldMetal=false MyApp.
    • Set the defaults property swing.boldMetal to Boolean.FALSE. For example: UIManager.put("swing.boldMetal", Boolean.FALSE);
    The defaults property swing.boldMetal, if set, takes precendence over the system property of the same name. After setting this defaults property you need to re-install MetalLookAndFeel, as well as update the UI of any previously created widgets. Otherwise the results are undefined. The following illustrates how to do this:
       // turn off bold fonts
   UIManager.put("swing.boldMetal", Boolean.FALSE);

   // re-install the Metal Look and Feel
   UIManager.setLookAndFeel(new MetalLookAndFeel());

   // Update the ComponentUIs for all Components. This
   // needs to be invoked for all windows.
   SwingUtilities.updateComponentTreeUI(rootComponent);

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    MetalLookAndFeel, MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultMetalTheme()
      Creates and returns an instance of DefaultMetalTheme.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      FontUIResource getControlTextFont()
      Returns the control text font.
      FontUIResource getMenuTextFont()
      Returns the menu text font.
      String getName()
      Returns the name of this theme.
      protected ColorUIResource getPrimary1()
      Returns the primary 1 color.
      protected ColorUIResource getPrimary2()
      Returns the primary 2 color.
      protected ColorUIResource getPrimary3()
      Returns the primary 3 color.
      protected ColorUIResource getSecondary1()
      Returns the secondary 1 color.
      protected ColorUIResource getSecondary2()
      Returns the secondary 2 color.
      protected ColorUIResource getSecondary3()
      Returns the secondary 3 color.
      FontUIResource getSubTextFont()
      Returns the sub-text font.
      FontUIResource getSystemTextFont()
      Returns the system text font.
      FontUIResource getUserTextFont()
      Returns the user text font.
      FontUIResource getWindowTitleFont()
      Returns the window title font.

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalTheme

        addCustomEntriesToTable, getAcceleratorForeground, getAcceleratorSelectedForeground, getBlack, getControl, getControlDarkShadow, getControlDisabled, getControlHighlight, getControlInfo, getControlShadow, getControlTextColor, getDesktopColor, getFocusColor, getHighlightedTextColor, getInactiveControlTextColor, getInactiveSystemTextColor, getMenuBackground, getMenuDisabledForeground, getMenuForeground, getMenuSelectedBackground, getMenuSelectedForeground, getPrimaryControl, getPrimaryControlDarkShadow, getPrimaryControlHighlight, getPrimaryControlInfo, getPrimaryControlShadow, getSeparatorBackground, getSeparatorForeground, getSystemTextColor, getTextHighlightColor, getUserTextColor, getWhite, getWindowBackground, getWindowTitleBackground, getWindowTitleForeground, getWindowTitleInactiveBackground, getWindowTitleInactiveForeground

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultMetalTheme

        public DefaultMetalTheme()
        Creates and returns an instance of DefaultMetalTheme.

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of this theme. This returns "Steel".
        指定者：
        getName in class MetalTheme
        返回：
        the name of this theme.

      • getPrimary1

        protected ColorUIResource getPrimary1()
        Returns the primary 1 color. This returns a color with rgb values of 102, 102, and 153, respectively.
        指定者：
        getPrimary1 in class MetalTheme
        返回：
        the primary 1 color

      • getPrimary2

        protected ColorUIResource getPrimary2()
        Returns the primary 2 color. This returns a color with rgb values of 153, 153, 204, respectively.
        指定者：
        getPrimary2 in class MetalTheme
        返回：
        the primary 2 color

      • getPrimary3

        protected ColorUIResource getPrimary3()
        Returns the primary 3 color. This returns a color with rgb values 204, 204, 255, respectively.
        指定者：
        getPrimary3 in class MetalTheme
        返回：
        the primary 3 color

      • getSecondary1

        protected ColorUIResource getSecondary1()
        Returns the secondary 1 color. This returns a color with rgb values 102, 102, and 102, respectively.
        指定者：
        getSecondary1 in class MetalTheme
        返回：
        the secondary 1 color

      • getSecondary2

        protected ColorUIResource getSecondary2()
        Returns the secondary 2 color. This returns a color with rgb values 153, 153, and 153, respectively.
        指定者：
        getSecondary2 in class MetalTheme
        返回：
        the secondary 2 color

      • getSecondary3

        protected ColorUIResource getSecondary3()
        Returns the secondary 3 color. This returns a color with rgb values 204, 204, and 204, respectively.
        指定者：
        getSecondary3 in class MetalTheme
        返回：
        the secondary 3 color

      • getControlTextFont

        public FontUIResource getControlTextFont()
        Returns the control text font. This returns Dialog, 12pt. If plain fonts have been enabled as described in font style, the font style is plain. Otherwise the font style is bold.
        指定者：
        getControlTextFont in class MetalTheme
        返回：
        the control text font

      • getSystemTextFont

        public FontUIResource getSystemTextFont()
        Returns the system text font. This returns Dialog, 12pt, plain.
        指定者：
        getSystemTextFont in class MetalTheme
        返回：
        the sytem text font

      • getUserTextFont

        public FontUIResource getUserTextFont()
        Returns the user text font. This returns Dialog, 12pt, plain.
        指定者：
        getUserTextFont in class MetalTheme
        返回：
        the user text font

      • getMenuTextFont

        public FontUIResource getMenuTextFont()
        Returns the menu text font. This returns Dialog, 12pt. If plain fonts have been enabled as described in font style, the font style is plain. Otherwise the font style is bold.
        指定者：
        getMenuTextFont in class MetalTheme
        返回：
        the menu text font

      • getWindowTitleFont

        public FontUIResource getWindowTitleFont()
        Returns the window title font. This returns Dialog, 12pt, bold.
        指定者：
        getWindowTitleFont in class MetalTheme
        返回：
        the window title font

      • getSubTextFont

        public FontUIResource getSubTextFont()
        Returns the sub-text font. This returns Dialog, 10pt, plain.
        指定者：
        getSubTextFont in class MetalTheme
        返回：
        the sub-text font
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.swing.plaf.metal

Classes

  • DefaultMetalTheme
  • MetalBorders
  • MetalBorders.ButtonBorder
  • MetalBorders.Flush3DBorder
  • MetalBorders.InternalFrameBorder
  • MetalBorders.MenuBarBorder
  • MetalBorders.MenuItemBorder
  • MetalBorders.OptionDialogBorder
  • MetalBorders.PaletteBorder
  • MetalBorders.PopupMenuBorder
  • MetalBorders.RolloverButtonBorder
  • MetalBorders.ScrollPaneBorder
  • MetalBorders.TableHeaderBorder
  • MetalBorders.TextFieldBorder
  • MetalBorders.ToggleButtonBorder
  • MetalBorders.ToolBarBorder
  • MetalButtonUI
  • MetalCheckBoxIcon
  • MetalCheckBoxUI
  • MetalComboBoxButton
  • MetalComboBoxEditor
  • MetalComboBoxEditor.UIResource
  • MetalComboBoxIcon
  • MetalComboBoxUI
  • MetalDesktopIconUI
  • MetalFileChooserUI
  • MetalIconFactory
  • MetalIconFactory.FileIcon16
  • MetalIconFactory.FolderIcon16
  • MetalIconFactory.PaletteCloseIcon
  • MetalIconFactory.TreeControlIcon
  • MetalIconFactory.TreeFolderIcon
  • MetalIconFactory.TreeLeafIcon
  • MetalInternalFrameTitlePane
  • MetalInternalFrameUI
  • MetalLabelUI
  • MetalLookAndFeel
  • MetalMenuBarUI
  • MetalPopupMenuSeparatorUI
  • MetalProgressBarUI
  • MetalRadioButtonUI
  • MetalRootPaneUI
  • MetalScrollBarUI
  • MetalScrollButton
  • MetalScrollPaneUI
  • MetalSeparatorUI
  • MetalSliderUI
  • MetalSplitPaneUI
  • MetalTabbedPaneUI
  • MetalTextFieldUI
  • MetalTheme
  • MetalToggleButtonUI
  • MetalToolBarUI
  • MetalToolTipUI
  • MetalTreeUI
  • OceanTheme
"


javax.swing.plaf.metal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf.metal

Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

请参见： 描述

  • Class Summary
    类 描述
    DefaultMetalTheme
    A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel".
    MetalBorders
    Factory object that can vend Borders appropriate for the metal L & F.
    MetalBorders.ButtonBorder
    MetalBorders.Flush3DBorder
    MetalBorders.InternalFrameBorder
    MetalBorders.MenuBarBorder
    MetalBorders.MenuItemBorder
    MetalBorders.OptionDialogBorder
    MetalBorders.PaletteBorder
    Border for a Palette.
    MetalBorders.PopupMenuBorder
    MetalBorders.RolloverButtonBorder
    MetalBorders.ScrollPaneBorder
    MetalBorders.TableHeaderBorder
    Border for a Table Header
    MetalBorders.TextFieldBorder
    MetalBorders.ToggleButtonBorder
    MetalBorders.ToolBarBorder
    MetalButtonUI
    MetalButtonUI implementation
    MetalCheckBoxIcon
    CheckboxIcon implementation for OrganicCheckBoxUI
    MetalCheckBoxUI
    CheckboxUI implementation for MetalCheckboxUI
    MetalComboBoxButton
    JButton subclass to help out MetalComboBoxUI
    MetalComboBoxEditor
    The default editor for Metal editable combo boxes
    MetalComboBoxEditor.UIResource
    A subclass of BasicComboBoxEditor that implements UIResource.
    MetalComboBoxIcon
    This utility class draws the horizontal bars which indicate a MetalComboBox
    MetalComboBoxUI
    Metal UI for JComboBox
    MetalDesktopIconUI
    Metal desktop icon.
    MetalFileChooserUI
    Metal L&F implementation of a FileChooser.
    MetalIconFactory
    Factory object that vends Icons for the JavaTM look and feel (Metal).
    MetalIconFactory.FileIcon16
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalIconFactory.FolderIcon16
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalIconFactory.PaletteCloseIcon
    Defines an icon for Palette close
    MetalIconFactory.TreeControlIcon
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalIconFactory.TreeFolderIcon
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalIconFactory.TreeLeafIcon
    MetalInternalFrameTitlePane
    Class that manages a JLF title bar
    MetalInternalFrameUI
    Metal implementation of JInternalFrame.
    MetalLabelUI
    A Windows L&F implementation of LabelUI.
    MetalLookAndFeel
    The Java Look and Feel, otherwise known as Metal.
    MetalMenuBarUI
    Metal implementation of MenuBarUI.
    MetalPopupMenuSeparatorUI
    A Metal L&F implementation of PopupMenuSeparatorUI.
    MetalProgressBarUI
    The Metal implementation of ProgressBarUI.
    MetalRadioButtonUI
    RadioButtonUI implementation for MetalRadioButtonUI
    MetalRootPaneUI
    Provides the metal look and feel implementation of RootPaneUI.
    MetalScrollBarUI
    Implementation of ScrollBarUI for the Metal Look and Feel
    MetalScrollButton
    JButton object for Metal scrollbar arrows.
    MetalScrollPaneUI
    A Metal L&F implementation of ScrollPaneUI.
    MetalSeparatorUI
    A Metal L&F implementation of SeparatorUI.
    MetalSliderUI
    A Java L&F implementation of SliderUI.
    MetalSplitPaneUI
    Metal split pane.
    MetalTabbedPaneUI
    The Metal subclass of BasicTabbedPaneUI.
    MetalTextFieldUI
    Basis of a look and feel for a JTextField.
    MetalTheme
    MetalTheme provides the color palette and fonts used by the Java Look and Feel.
    MetalToggleButtonUI
    MetalToggleButton implementation
    MetalToolBarUI
    A Metal Look and Feel implementation of ToolBarUI.
    MetalToolTipUI
    A Metal L&F extension of BasicToolTipUI.
    MetalTreeUI
    The metal look and feel implementation of TreeUI.
    OceanTheme
    The default theme for the MetalLookAndFeel.

软件包 javax.swing.plaf.metal Description

Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

These classes are designed to be used while the corresponding LookAndFeel class has been installed (UIManager.setLookAndFeel(new XXXLookAndFeel())). Using them while a different LookAndFeel is installed may produce unexpected results, including exceptions. Additionally, changing the LookAndFeel maintained by the UIManager without updating the corresponding ComponentUI of any JComponents may also produce unexpected results, such as the wrong colors showing up, and is generally not encouraged.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t OaT�


javax.swing.plaf.metal Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf.metal

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder (implements javax.swing.SwingConstants, javax.swing.plaf.UIResource)
    • javax.swing.AbstractListModel<E> (implements javax.swing.ListModel<E>, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel (implements javax.swing.ComboBoxModel)
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel (implements javax.swing.ComboBoxModel, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
                • javax.swing.plaf.metal.MetalScrollButton
              • javax.swing.plaf.metal.MetalComboBoxButton
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer<E>, java.io.Serializable)
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI
            • javax.swing.plaf.metal.MetalToggleButtonUI
          • javax.swing.plaf.metal.MetalButtonUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalLabelUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.metal.MetalScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalTabbedPaneUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.metal.MetalLookAndFeel
    • javax.swing.plaf.metal.MetalBorders
    • javax.swing.plaf.metal.MetalCheckBoxIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalComboBoxIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


MetalBorders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders

  • java.lang.Object
    • javax.swing.plaf.metal.MetalBorders

  • public class MetalBorders
extends Object
    Factory object that can vend Borders appropriate for the metal L & F.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  | MetalBorders.ButtonBorder
      static class  | MetalBorders.Flush3DBorder
      static class  | MetalBorders.InternalFrameBorder
      static class  | MetalBorders.MenuBarBorder
      static class  | MetalBorders.MenuItemBorder
      static class  | MetalBorders.OptionDialogBorder
      static class  MetalBorders.PaletteBorder
      Border for a Palette.
      static class  | MetalBorders.PopupMenuBorder
      static class  | MetalBorders.RolloverButtonBorder
      static class  | MetalBorders.ScrollPaneBorder
      static class  MetalBorders.TableHeaderBorder
      Border for a Table Header
      static class  | MetalBorders.TextFieldBorder
      static class  | MetalBorders.ToggleButtonBorder
      static class  | MetalBorders.ToolBarBorder

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Border getButtonBorder()
      Returns a border instance for a JButton
      static Border getDesktopIconBorder()
      Returns a border instance for a Desktop Icon
      static Border getTextBorder()
      Returns a border instance for a text component
      static Border getTextFieldBorder()
      Returns a border instance for a JTextField
      static Border getToggleButtonBorder()
      Returns a border instance for a JToggleButton

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders

        public MetalBorders()

    • 方法详细信息

      • getButtonBorder

        public static Border getButtonBorder()
        Returns a border instance for a JButton
        从以下版本开始：
        1.3

      • getTextBorder

        public static Border getTextBorder()
        Returns a border instance for a text component
        从以下版本开始：
        1.3

      • getTextFieldBorder

        public static Border getTextFieldBorder()
        Returns a border instance for a JTextField
        从以下版本开始：
        1.3

      • getToggleButtonBorder

        public static Border getToggleButtonBorder()
        Returns a border instance for a JToggleButton
        从以下版本开始：
        1.3

      • getDesktopIconBorder

        public static Border getDesktopIconBorder()
        Returns a border instance for a Desktop Icon
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

de eh>"ls=de;teorl|a"�> a�."ssvoij.i


MetalBorders.ButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.ButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    直接已知子类：
    MetalBorders.RolloverButtonBorder, MetalBorders.ToggleButtonBorder
    封闭类：
    MetalBorders

    public static class MetalBorders.ButtonBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Insets | borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.ButtonBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • borderInsets

        protected static Insets borderInsets

    • 构造方法详细信息

      • MetalBorders.ButtonBorder

        public MetalBorders.ButtonBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>lM>- ><>">>j.mml >l/aaca> l><


MetalBorders.Flush3DBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.Flush3DBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    直接已知子类：
    MetalBorders.TextFieldBorder
    封闭类：
    MetalBorders

    public static class MetalBorders.Flush3DBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.Flush3DBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.Flush3DBorder

        public MetalBorders.Flush3DBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hetfefsf.foae.hles..lccnv sr__eebbao=ro-


MetalBorders.InternalFrameBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.InternalFrameBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.InternalFrameBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.InternalFrameBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.InternalFrameBorder

        public MetalBorders.InternalFrameBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>et �


MetalBorders.MenuBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.MenuBarBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.MenuBarBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Insets | borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.MenuBarBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • borderInsets

        protected static Insets borderInsets

    • 构造方法详细信息

      • MetalBorders.MenuBarBorder

        public MetalBorders.MenuBarBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>>Nllbs&"n&;/s缝a�>轨祆mhl�&秚


MetalBorders.MenuItemBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.MenuItemBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.MenuItemBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Insets | borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.MenuItemBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • borderInsets

        protected static Insets borderInsets

    • 构造方法详细信息

      • MetalBorders.MenuItemBorder

        public MetalBorders.MenuItemBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/mlnann;ittlin j= |bbb&p>秈�


MetalBorders.OptionDialogBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.OptionDialogBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.OptionDialogBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.OptionDialogBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.OptionDialogBorder

        public MetalBorders.OptionDialogBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k>.slsasnsssinktiCppnsuLd nllsc_llnsaafaas


MetalBorders.PaletteBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.PaletteBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.PaletteBorder
extends AbstractBorder
implements UIResource
    Border for a Palette.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.PaletteBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.PaletteBorder

        public MetalBorders.PaletteBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cNk=p=i=o= "loc;llkkneatdIIc_"f)(mmw ; n


MetalBorders.PopupMenuBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.PopupMenuBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.PopupMenuBorder
extends AbstractBorder
implements UIResource

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Insets | borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.PopupMenuBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • borderInsets

        protected static Insets borderInsets

    • 构造方法详细信息

      • MetalBorders.PopupMenuBorder

        public MetalBorders.PopupMenuBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;/<|n|_|p|;nsp;lsb y"穜贩u"dtmhm#ttthtrao<


MetalBorders.RolloverButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.RolloverButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.RolloverButtonBorder
extends MetalBorders.ButtonBorder

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.metal.MetalBorders.ButtonBorder

        borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.RolloverButtonBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalBorders.ButtonBorder

        getBorderInsets

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.RolloverButtonBorder

        public MetalBorders.RolloverButtonBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class MetalBorders.ButtonBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w/ia asasaja.xaan"hher>. ...///laalpp/Mormat


MetalBorders.ScrollPaneBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.ScrollPaneBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.ScrollPaneBorder
extends AbstractBorder
implements UIResource

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.ScrollPaneBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.ScrollPaneBorder

        public MetalBorders.ScrollPaneBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

essldllslllssens(tt s>>vvier!i-cc->t al


MetalBorders.TableHeaderBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.TableHeaderBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
  • 所有已实现的接口：
    Serializable, Border
    封闭类：
    MetalBorders

    public static class MetalBorders.TableHeaderBorder
extends AbstractBorder
    Border for a Table Header
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Insets | editorBorderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.TableHeaderBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets insets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • editorBorderInsets

        protected Insets editorBorderInsets

    • 构造方法详细信息

      • MetalBorders.TableHeaderBorder

        public MetalBorders.TableHeaderBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets insets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        insets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

RRy ><>>


MetalBorders.TextFieldBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.TextFieldBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.TextFieldBorder
extends MetalBorders.Flush3DBorder

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.TextFieldBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder

        getBorderInsets

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.TextFieldBorder

        public MetalBorders.TextFieldBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class MetalBorders.Flush3DBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gbe" rihril>>illl蔭alann h>vgim


MetalBorders.ToggleButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.ToggleButtonBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource
    封闭类：
    MetalBorders

    public static class MetalBorders.ToggleButtonBorder
extends MetalBorders.ButtonBorder
    从以下版本开始：
    1.3

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.metal.MetalBorders.ButtonBorder

        borderInsets

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.ToggleButtonBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalBorders.ButtonBorder

        getBorderInsets

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalBorders.ToggleButtonBorder

        public MetalBorders.ToggleButtonBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class MetalBorders.ButtonBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nealm


MetalBorders.ToolBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalBorders.ToolBarBorder

  • java.lang.Object
    • javax.swing.border.AbstractBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder
  • 所有已实现的接口：
    Serializable, Border, UIResource, SwingConstants
    封闭类：
    MetalBorders

    public static class MetalBorders.ToolBarBorder
extends AbstractBorder
implements UIResource, SwingConstants

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected javax.swing.plaf.metal.MetalBumps | bumps

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalBorders.ToolBarBorder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Insets getBorderInsets(Component c, Insets newInsets)
      Reinitializes the insets parameter with this Border's current Insets.
      void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
      This default implementation does no painting.

      • 方法 - 继承于类 javax.swing.border.AbstractBorder

        getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • bumps

        protected javax.swing.plaf.metal.MetalBumps bumps

    • 构造方法详细信息

      • MetalBorders.ToolBarBorder

        public MetalBorders.ToolBarBorder()

    • 方法详细信息

      • paintBorder

        public void paintBorder(Component c,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Description copied from class: AbstractBorder
        This default implementation does no painting.
        指定者：
        paintBorder in interface Border
        重载：
        paintBorder in class AbstractBorder
        参数：
        c - the component for which this border is being painted
        g - the paint graphics
        x - the x position of the painted border
        y - the y position of the painted border
        w - the width of the painted border
        h - the height of the painted border

      • getBorderInsets

        public Insets getBorderInsets(Component c,
                     Insets newInsets)
        Description copied from class: AbstractBorder
        Reinitializes the insets parameter with this Border's current Insets.
        重载：
        getBorderInsets in class AbstractBorder
        参数：
        c - the component for which this border insets value applies
        newInsets - the object to be reinitialized
        返回：
        the insets object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bb.ado"/dtn>tlss<<


MetalButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.metal.MetalButtonUI

  • public class MetalButtonUI
extends BasicButtonUI
    MetalButtonUI implementation

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | disabledTextColor
      protected Color | focusColor
      protected Color | selectColor

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected BasicButtonListener | createButtonListener(AbstractButton b)
      static ComponentUI | createUI(JComponent c)
      protected Color | getDisabledTextColor()
      protected Color | getFocusColor()
      protected Color | getSelectColor()
      void | installDefaults(AbstractButton b)
      protected void | paintButtonPressed(Graphics g, AbstractButton b)
      protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      As of Java 2 platform v 1.4 this method should not be used or overriden.
      void | uninstallDefaults(AbstractButton b)
      void update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, getPropertyPrefix, getTextShiftOffset, installKeyboardActions, installListeners, installUI, paint, paintIcon, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • focusColor

        protected Color focusColor

      • selectColor

        protected Color selectColor

      • disabledTextColor

        protected Color disabledTextColor

    • 构造方法详细信息

      • MetalButtonUI

        public MetalButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        public void installDefaults(AbstractButton b)
        重载：
        installDefaults in class BasicButtonUI

      • uninstallDefaults

        public void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class BasicButtonUI

      • createButtonListener

        protected BasicButtonListener createButtonListener(AbstractButton b)
        重载：
        createButtonListener in class BasicButtonUI

      • getSelectColor

        protected Color getSelectColor()

      • getDisabledTextColor

        protected Color getDisabledTextColor()

      • getFocusColor

        protected Color getFocusColor()

      • update

        public void update(Graphics g,
          JComponent c)
        If necessary paints the background of the component, then invokes paint.
        重载：
        update in class ComponentUI
        参数：
        g - Graphics to paint to
        c - JComponent painting on
        抛出：
        NullPointerException - if g or c is null
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)

      • paintButtonPressed

        protected void paintButtonPressed(Graphics g,
                      AbstractButton b)
        重载：
        paintButtonPressed in class BasicButtonUI

      • paintFocus

        protected void paintFocus(Graphics g,
              AbstractButton b,
              Rectangle viewRect,
              Rectangle textRect,
              Rectangle iconRect)
        重载：
        paintFocus in class BasicButtonUI

      • paintText

        protected void paintText(Graphics g,
             JComponent c,
             Rectangle textRect,
             String text)
        Description copied from class: BasicButtonUI
        As of Java 2 platform v 1.4 this method should not be used or overriden. Use the paintText method which takes the AbstractButton argument.
        重载：
        paintText in class BasicButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.><"


MetalCheckBoxIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalCheckBoxIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalCheckBoxIcon
  • 所有已实现的接口：
    Serializable, Icon, UIResource

    public class MetalCheckBoxIcon
extends Object
implements Icon, UIResource, Serializable
    CheckboxIcon implementation for OrganicCheckBoxUI

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalCheckBoxIcon()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | drawCheck(Component c, Graphics g, int x, int y)
      protected int | getControlSize()
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalCheckBoxIcon

        public MetalCheckBoxIcon()

    • 方法详细信息

      • getControlSize

        protected int getControlSize()

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • drawCheck

        protected void drawCheck(Component c,
             Graphics g,
             int x,
             int y)

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etf/tcpIcp>aap>>gteebpsf/ccslc#cpothhBnas/


MetalCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalCheckBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI

  • public class MetalCheckBoxUI
extends MetalRadioButtonUI
    CheckboxUI implementation for MetalCheckboxUI

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.metal.MetalRadioButtonUI

        disabledTextColor, focusColor, selectColor

      • Fields inherited from class javax.swing.plaf.basic.BasicRadioButtonUI

        icon

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalCheckBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      String getPropertyPrefix()
      void | installDefaults(AbstractButton b)
      protected void | uninstallDefaults(AbstractButton b)

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalRadioButtonUI

        getDisabledTextColor, getFocusColor, getSelectColor, paint, paintFocus

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicRadioButtonUI

        getDefaultIcon, getPreferredSize

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToggleButtonUI

        getTextShiftOffset, paintIcon

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalCheckBoxUI

        public MetalCheckBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • getPropertyPrefix

        public String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicRadioButtonUI

      • installDefaults

        public void installDefaults(AbstractButton b)
        重载：
        installDefaults in class MetalRadioButtonUI

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class MetalRadioButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sclrrTarylraetii"癮cr;y.pcu.maj"tiR


MetalComboBoxButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JButton
              • javax.swing.plaf.metal.MetalComboBoxButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants

    public class MetalComboBoxButton
extends JButton
    JButton subclass to help out MetalComboBoxUI

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    MetalComboBoxButton

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JButton

        JButton.AccessibleJButton

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected JComboBox | comboBox
      protected Icon | comboIcon
      protected boolean | iconOnly
      protected JList | listBox
      protected CellRendererPane | rendererPane

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
      MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      JComboBox getComboBox()
      Icon getComboIcon()
      Dimension getMinimumSize()
      If the minimum size has been set to a non-null value just returns it.
      boolean isFocusTraversable()
      Returns whether this Component can become the focus owner.
      boolean | isIconOnly()
      void paintComponent(Graphics g)
      Calls the UI delegate's paint method, if the UI delegate is non-null.
      void | setComboBox(JComboBox cb)
      void | setComboIcon(Icon i)
      void setEnabled(boolean enabled)
      Enables (or disables) the button.
      void | setIconOnly(boolean isIconOnly)

      • 方法 - 继承于类 javax.swing.JButton

        getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • comboBox

        protected JComboBox comboBox

      • listBox

        protected JList listBox

      • rendererPane

        protected CellRendererPane rendererPane

      • comboIcon

        protected Icon comboIcon

      • iconOnly

        protected boolean iconOnly

    • 构造方法详细信息

      • MetalComboBoxButton

        public MetalComboBoxButton(JComboBox cb,
                   Icon i,
                   CellRendererPane pane,
                   JList list)

      • MetalComboBoxButton

        public MetalComboBoxButton(JComboBox cb,
                   Icon i,
                   boolean onlyIcon,
                   CellRendererPane pane,
                   JList list)

    • 方法详细信息

      • getComboBox

        public final JComboBox getComboBox()

      • setComboBox

        public final void setComboBox(JComboBox cb)

      • getComboIcon

        public final Icon getComboIcon()

      • setComboIcon

        public final void setComboIcon(Icon i)

      • isIconOnly

        public final boolean isIconOnly()

      • setIconOnly

        public final void setIconOnly(boolean isIconOnly)

      • isFocusTraversable

        public boolean isFocusTraversable()
        Description copied from class: Component
        Returns whether this Component can become the focus owner.
        重载：
        isFocusTraversable in class Component
        返回：
        true if this Component is focusable; false otherwise
        另请参见：
        Component.setFocusable(boolean)

      • setEnabled

        public void setEnabled(boolean enabled)
        Description copied from class: AbstractButton
        Enables (or disables) the button.
        重载：
        setEnabled in class AbstractButton
        参数：
        enabled - true to enable the button, otherwise false
        另请参见：
        Component.isEnabled(), Component.isLightweight()

      • paintComponent

        public void paintComponent(Graphics g)
        Description copied from class: JComponent
        Calls the UI delegate's paint method, if the UI delegate is non-null. We pass the delegate a copy of the Graphics object to protect the rest of the paint code from irrevocable changes (for example, Graphics.translate).

        If you override this in a subclass you should not make permanent changes to the passed in Graphics. For example, you should not alter the clip Rectangle or modify the transform. If you need to do these operations you may find it easier to create a new Graphics from the passed in Graphics and manipulate it. Further, if you do not invoker super's implementation you must honor the opaque property, that is if this component is opaque, you must completely fill in the background in a non-opaque color. If you do not honor the opaque property you will likely see visual artifacts.

        The passed in Graphics object might have a transform other than the identify transform installed on it. In this case, you might get unexpected results if you cumulatively apply another transform.

        重载：
        paintComponent in class JComponent
        参数：
        g - the Graphics object to protect
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • getMinimumSize

        public Dimension getMinimumSize()
        Description copied from class: JComponent
        If the minimum size has been set to a non-null value just returns it. If the UI delegate's getMinimumSize method returns a non-null value then return that; otherwise defer to the component's layout manager.
        重载：
        getMinimumSize in class JComponent
        返回：
        the value of the minimumSize property
        另请参见：
        JComponent.setMinimumSize(java.awt.Dimension), ComponentUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalComboBoxEditor

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxEditor
      • javax.swing.plaf.metal.MetalComboBoxEditor
  • 所有已实现的接口：
    FocusListener, EventListener, ComboBoxEditor
    直接已知子类：
    MetalComboBoxEditor.UIResource

    public class MetalComboBoxEditor
extends BasicComboBoxEditor
    The default editor for Metal editable combo boxes

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  MetalComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static Insets editorBorderInsets
      The default editor border Insets.

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxEditor

        editor

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxEditor()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxEditor

        addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • editorBorderInsets

        protected static Insets editorBorderInsets
        The default editor border Insets. This field might not be used.

    • 构造方法详细信息

      • MetalComboBoxEditor

        public MetalComboBoxEditor()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.in"as hthas."


MetalComboBoxEditor.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalComboBoxEditor.UIResource

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxEditor
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
  • 所有已实现的接口：
    FocusListener, EventListener, ComboBoxEditor, UIResource
    封闭类：
    MetalComboBoxEditor

    public static class MetalComboBoxEditor.UIResource
extends MetalComboBoxEditor
implements UIResource
    A subclass of BasicComboBoxEditor that implements UIResource. BasicComboBoxEditor doesn't implement UIResource directly so that applications can safely override the cellRenderer property with BasicListCellRenderer subclasses.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.metal.MetalComboBoxEditor

        MetalComboBoxEditor.UIResource

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.metal.MetalComboBoxEditor

        editorBorderInsets

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxEditor

        editor

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxEditor.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxEditor

        addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalComboBoxEditor.UIResource

        public MetalComboBoxEditor.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ed 2 , l ,rcle蔼� /联胠园辉粜p�>gne1/


MetalComboBoxIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalComboBoxIcon
  • 所有已实现的接口：
    Serializable, Icon

    public class MetalComboBoxIcon
extends Object
implements Icon, Serializable
    This utility class draws the horizontal bars which indicate a MetalComboBox
    另请参见：
    MetalComboBoxUI

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxIcon()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIconHeight()
      Created a stub to satisfy the interface.
      int getIconWidth()
      Created a stub to satisfy the interface.
      void paintIcon(Component c, Graphics g, int x, int y)
      Paints the horizontal bars for the

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalComboBoxIcon

        public MetalComboBoxIcon()

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        Paints the horizontal bars for the
        指定者：
        paintIcon in interface Icon

      • getIconWidth

        public int getIconWidth()
        Created a stub to satisfy the interface.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        Created a stub to satisfy the interface.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rey>>>t>a>iumar&m ssneesy..dsilnadnii ..


MetalComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI

  • public class MetalComboBoxUI
extends BasicComboBoxUI
    Metal UI for JComboBox

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    MetalComboBoxEditor, MetalComboBoxButton

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  MetalComboBoxUI.MetalComboBoxLayoutManager
      This inner class is marked "public" due to a compiler bug.
      class  MetalComboBoxUI.MetalComboPopup
      Deprecated.
      As of Java 2 platform v1.4.
      class  MetalComboBoxUI.MetalPropertyChangeListener
      This inner class is marked "public" due to a compiler bug.

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicComboBoxUI

        BasicComboBoxUI.ComboBoxLayoutManager, BasicComboBoxUI.FocusHandler, BasicComboBoxUI.ItemHandler, BasicComboBoxUI.KeyHandler, BasicComboBoxUI.ListDataHandler, BasicComboBoxUI.PropertyChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxUI

        arrowButton, cachedMinimumSize, comboBox, currentValuePane, editor, focusListener, hasFocus, isMinimumSizeDirty, itemListener, keyListener, listBox, listDataListener, padding, popup, popupKeyListener, popupMouseListener, popupMouseMotionListener, propertyChangeListener, squareButton

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void configureEditor()
      This protected method is implementation specific and should be private.
      protected JButton createArrowButton()
      Creates a button which will be used as the control to show or hide the popup portion of the combo box.
      protected ComboBoxEditor createEditor()
      Creates the default editor that will be used in editable combo boxes.
      protected LayoutManager createLayoutManager()
      Creates a layout manager for managing the components which make up the combo box.
      protected ComboPopup createPopup()
      Creates the popup portion of the combo box.
      PropertyChangeListener createPropertyChangeListener()
      Creates a PropertyChangeListener which will be added to the combo box.
      static ComponentUI | createUI(JComponent c)
      protected void editablePropertyChanged(PropertyChangeEvent e)
      Deprecated.
      As of Java 2 platform v1.4.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      Dimension getMinimumSize(JComponent c)
      The minumum size is the size of the display area plus insets plus the button.
      void | layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
      If necessary paints the currently selected item.
      void paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
      If necessary paints the background of the currently selected item.
      protected void removeListeners()
      Deprecated.
      As of Java 2 platform v1.4.
      void unconfigureEditor()
      This protected method is implementation specific and should be private.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxUI

        addEditor, configureArrowButton, createFocusListener, createItemListener, createKeyListener, createListDataListener, createRenderer, getAccessibleChild, getAccessibleChildrenCount, getBaselineResizeBehavior, getDefaultSize, getDisplaySize, getInsets, getMaximumSize, getPreferredSize, getSizeForComponent, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, isFocusTraversable, isNavigationKey, isPopupVisible, rectangleForCurrentValue, removeEditor, selectNextPossibleValue, selectPreviousPossibleValue, setPopupVisible, toggleOpenClose, unconfigureArrowButton, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalComboBoxUI

        public MetalComboBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicComboBoxUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintCurrentValue

        public void paintCurrentValue(Graphics g,
                     Rectangle bounds,
                     boolean hasFocus)
        If necessary paints the currently selected item.
        重载：
        paintCurrentValue in class BasicComboBoxUI
        参数：
        g - Graphics to paint to
        bounds - Region to paint current value to
        hasFocus - whether or not the JComboBox has focus
        抛出：
        NullPointerException - if any of the arguments are null.
        从以下版本开始：
        1.5

      • paintCurrentValueBackground

        public void paintCurrentValueBackground(Graphics g,
                               Rectangle bounds,
                               boolean hasFocus)
        If necessary paints the background of the currently selected item.
        重载：
        paintCurrentValueBackground in class BasicComboBoxUI
        参数：
        g - Graphics to paint to
        bounds - Region to paint background to
        hasFocus - whether or not the JComboBox has focus
        抛出：
        NullPointerException - if any of the arguments are null.
        从以下版本开始：
        1.5

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Returns the baseline.
        重载：
        getBaseline in class BasicComboBoxUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        抛出：
        NullPointerException - if c is null
        IllegalArgumentException - if width or height is < 0
        从以下版本开始：
        1.6
        另请参见：
        JComponent.getBaseline(int, int)

      • createEditor

        protected ComboBoxEditor createEditor()
        Description copied from class: BasicComboBoxUI
        Creates the default editor that will be used in editable combo boxes. A default editor will be used only if an editor has not been explicitly set with setEditor.
        重载：
        createEditor in class BasicComboBoxUI
        返回：
        a ComboBoxEditor used for the combo box
        另请参见：
        JComboBox.setEditor(javax.swing.ComboBoxEditor)

      • createPopup

        protected ComboPopup createPopup()
        Description copied from class: BasicComboBoxUI
        Creates the popup portion of the combo box.
        重载：
        createPopup in class BasicComboBoxUI
        返回：
        an instance of ComboPopup
        另请参见：
        ComboPopup

      • createArrowButton

        protected JButton createArrowButton()
        Description copied from class: BasicComboBoxUI
        Creates a button which will be used as the control to show or hide the popup portion of the combo box.
        重载：
        createArrowButton in class BasicComboBoxUI
        返回：
        a button which represents the popup control

      • createPropertyChangeListener

        public PropertyChangeListener createPropertyChangeListener()
        Description copied from class: BasicComboBoxUI
        Creates a PropertyChangeListener which will be added to the combo box. If this method returns null then it will not be added to the combo box.
        重载：
        createPropertyChangeListener in class BasicComboBoxUI
        返回：
        an instance of a PropertyChangeListener or null

      • editablePropertyChanged

        @Deprecated
protected void editablePropertyChanged(PropertyChangeEvent e)
        Deprecated. As of Java 2 platform v1.4.
        As of Java 2 platform v1.4 this method is no longer used. Do not call or override. All the functionality of this method is in the MetalPropertyChangeListener.

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Description copied from class: BasicComboBoxUI
        Creates a layout manager for managing the components which make up the combo box.
        重载：
        createLayoutManager in class BasicComboBoxUI
        返回：
        an instance of a layout manager

      • layoutComboBox

        public void layoutComboBox(Container parent,
                  MetalComboBoxUI.MetalComboBoxLayoutManager manager)

      • removeListeners

        @Deprecated
protected void removeListeners()
        Deprecated. As of Java 2 platform v1.4.
        As of Java 2 platform v1.4 this method is no longer used.

      • configureEditor

        public void configureEditor()
        Description copied from class: BasicComboBoxUI
        This protected method is implementation specific and should be private. do not call or override.
        重载：
        configureEditor in class BasicComboBoxUI
        另请参见：
        BasicComboBoxUI.addEditor()

      • unconfigureEditor

        public void unconfigureEditor()
        Description copied from class: BasicComboBoxUI
        This protected method is implementation specific and should be private. Do not call or override.
        重载：
        unconfigureEditor in class BasicComboBoxUI
        另请参见：
        BasicComboBoxUI.addEditor()

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: BasicComboBoxUI
        The minumum size is the size of the display area plus insets plus the button.
        重载：
        getMinimumSize in class BasicComboBoxUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalComboBoxUI.MetalComboBoxLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxUI.MetalComboBoxLayoutManager

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    MetalComboBoxUI

    public class MetalComboBoxUI.MetalComboBoxLayoutManager
extends BasicComboBoxUI.ComboBoxLayoutManager
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxUI.MetalComboBoxLayoutManager()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void layoutContainer(Container parent)
      Lays out the specified container.
      void | superLayout(Container parent)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager

        addLayoutComponent, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalComboBoxUI.MetalComboBoxLayoutManager

        public MetalComboBoxUI.MetalComboBoxLayoutManager()

    • 方法详细信息

      • layoutContainer

        public void layoutContainer(Container parent)
        从接口复制的描述： LayoutManager
        Lays out the specified container.
        指定者：
        layoutContainer in interface LayoutManager
        重载：
        layoutContainer in class BasicComboBoxUI.ComboBoxLayoutManager
        参数：
        parent - the container to be laid out

      • superLayout

        public void superLayout(Container parent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


MetalComboBoxUI.MetalComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxUI.MetalComboPopup

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JPopupMenu
            • javax.swing.plaf.basic.BasicComboPopup
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, MenuElement, ComboPopup
    封闭类：
    MetalComboBoxUI
    Deprecated.
    As of Java 2 platform v1.4.

    @Deprecated
public class MetalComboBoxUI.MetalComboPopup
extends BasicComboPopup
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of . This class is now obsolete and doesn't do anything and is only included for backwards API compatibility. Do not call or override.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicComboPopup

        BasicComboPopup.InvocationKeyHandler, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.InvocationMouseMotionHandler, BasicComboPopup.ItemHandler, BasicComboPopup.ListDataHandler, BasicComboPopup.ListMouseHandler, BasicComboPopup.ListMouseMotionHandler, BasicComboPopup.ListSelectionHandler, BasicComboPopup.PropertyChangeHandler

      • Nested classes/interfaces inherited from class javax.swing.JPopupMenu

        JPopupMenu.AccessibleJPopupMenu, JPopupMenu.Separator

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicComboPopup

        autoscrollTimer, comboBox, hasEntered, isAutoScrolling, itemListener, keyListener, list, listDataListener, listMouseListener, listMouseMotionListener, listSelectionListener, mouseListener, mouseMotionListener, propertyChangeListener, SCROLL_DOWN, SCROLL_UP, scrollDirection, scroller, valueIsAdjusting

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
      Deprecated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void delegateFocus(MouseEvent e)
      Deprecated.
      This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboPopup

        autoScrollDown, autoScrollUp, computePopupBounds, configureList, configurePopup, configureScroller, convertMouseEvent, createItemListener, createKeyListener, createList, createListDataListener, createListMouseListener, createListMouseMotionListener, createListSelectionListener, createMouseListener, createMouseMotionListener, createPropertyChangeListener, createScroller, firePopupMenuCanceled, firePopupMenuWillBecomeInvisible, firePopupMenuWillBecomeVisible, getAccessibleContext, getKeyListener, getList, getMouseListener, getMouseMotionListener, getPopupHeightForRowCount, hide, installComboBoxListeners, installComboBoxModelListeners, installKeyboardActions, installListListeners, isFocusTraversable, show, startAutoScrolling, stopAutoScrolling, togglePopup, uninstallComboBoxModelListeners, uninstallingUI, uninstallKeyboardActions, updateListBoxSelectionForEvent

      • 方法 - 继承于类 javax.swing.JPopupMenu

        add, add, add, addMenuKeyListener, addPopupMenuListener, addSeparator, createActionChangeListener, createActionComponent, getComponent, getComponentAtIndex, getComponentIndex, getDefaultLightWeightPopupEnabled, getInvoker, getLabel, getMargin, getMenuKeyListeners, getPopupMenuListeners, getSelectionModel, getSubElements, getUI, getUIClassID, insert, insert, isBorderPainted, isLightWeightPopupEnabled, isPopupTrigger, isVisible, menuSelectionChanged, pack, paintBorder, paramString, processFocusEvent, processKeyEvent, processKeyEvent, processMouseEvent, remove, removeMenuKeyListener, removePopupMenuListener, setBorderPainted, setDefaultLightWeightPopupEnabled, setInvoker, setLabel, setLightWeightPopupEnabled, setLocation, setPopupSize, setPopupSize, setSelected, setSelectionModel, setUI, setVisible, show, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.plaf.basic.ComboPopup

        isVisible

    • 构造方法详细信息

      • MetalComboBoxUI.MetalComboPopup

        public MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
        Deprecated.

    • 方法详细信息

      • delegateFocus

        public void delegateFocus(MouseEvent e)
        Deprecated.
        Description copied from class: BasicComboPopup
        This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up. The standard implementation delegates the focus to the editor (if the combo box is editable) or to the JComboBox if it is not editable.
        重载：
        delegateFocus in class BasicComboPopup
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalComboBoxUI.MetalPropertyChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalComboBoxUI.MetalPropertyChangeListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    MetalComboBoxUI

    public class MetalComboBoxUI.MetalPropertyChangeListener
extends BasicComboBoxUI.PropertyChangeHandler
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of .

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalComboBoxUI.MetalPropertyChangeListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalComboBoxUI.MetalPropertyChangeListener

        public MetalComboBoxUI.MetalPropertyChangeListener()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        重载：
        propertyChange in class BasicComboBoxUI.PropertyChangeHandler
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"/!n"pt"pmoopmmgvrr /s>a "s ld>dAAu>nIvs/


MetalDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalDesktopIconUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI

  • public class MetalDesktopIconUI
extends BasicDesktopIconUI
    Metal desktop icon.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicDesktopIconUI

        BasicDesktopIconUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicDesktopIconUI

        desktopIcon, frame, iconPane

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalDesktopIconUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getMaximumSize(JComponent c)
      Desktop icons can not be resized.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installListeners()
      protected void | uninstallComponents()
      protected void | uninstallListeners()

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicDesktopIconUI

        createMouseInputListener, deiconize, getInsets, installUI, uninstallDefaults, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalDesktopIconUI

        public MetalDesktopIconUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicDesktopIconUI

      • installComponents

        protected void installComponents()
        重载：
        installComponents in class BasicDesktopIconUI

      • uninstallComponents

        protected void uninstallComponents()
        重载：
        uninstallComponents in class BasicDesktopIconUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicDesktopIconUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicDesktopIconUI

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicDesktopIconUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class BasicDesktopIconUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: BasicDesktopIconUI
        Desktop icons can not be resized. Therefore, we should always return the minimum size of the desktop icon.
        重载：
        getMaximumSize in class BasicDesktopIconUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        BasicDesktopIconUI.getMinimumSize(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

or" d.1 i>�-t縲d


MetalFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalFileChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI

  • public class MetalFileChooserUI
extends BasicFileChooserUI
    Metal L&F implementation of a FileChooser.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  MetalFileChooserUI.DirectoryComboBoxAction
      Acts when DirectoryComboBox has changed the selected item.
      protected class  MetalFileChooserUI.DirectoryComboBoxModel
      Data model for a type-face selection combo-box.
      protected class  | MetalFileChooserUI.FileRenderer
      protected class  MetalFileChooserUI.FilterComboBoxModel
      Data model for a type-face selection combo-box.
      class  MetalFileChooserUI.FilterComboBoxRenderer
      Render different type sizes and styles.
      protected class  | MetalFileChooserUI.SingleClickListener

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicFileChooserUI

        BasicFileChooserUI.AcceptAllFileFilter, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.BasicFileView, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.DoubleClickListener, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.SelectionListener, BasicFileChooserUI.UpdateAction

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicFileChooserUI

        cancelButtonMnemonic, cancelButtonText, cancelButtonToolTipText, computerIcon, detailsViewIcon, directoryIcon, directoryOpenButtonMnemonic, directoryOpenButtonText, directoryOpenButtonToolTipText, fileIcon, floppyDriveIcon, hardDriveIcon, helpButtonMnemonic, helpButtonText, helpButtonToolTipText, homeFolderIcon, listViewIcon, newFolderIcon, openButtonMnemonic, openButtonText, openButtonToolTipText, saveButtonMnemonic, saveButtonText, saveButtonToolTipText, updateButtonMnemonic, updateButtonText, updateButtonToolTipText, upFolderIcon, viewMenuIcon

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalFileChooserUI(JFileChooser filechooser)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | addControlButtons()
      protected ActionMap | createActionMap()
      protected JPanel | createDetailsView(JFileChooser fc)
      protected MetalFileChooserUI.DirectoryComboBoxModel | createDirectoryComboBoxModel(JFileChooser fc)
      protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer | createDirectoryComboBoxRenderer(JFileChooser fc)
      protected MetalFileChooserUI.FilterComboBoxModel | createFilterComboBoxModel()
      protected MetalFileChooserUI.FilterComboBoxRenderer | createFilterComboBoxRenderer()
      protected JPanel | createList(JFileChooser fc)
      ListSelectionListener createListSelectionListener(JFileChooser fc)
      Creates a selection listener for the list of files and directories.
      PropertyChangeListener | createPropertyChangeListener(JFileChooser fc)
      static ComponentUI | createUI(JComponent c)
      void | ensureFileIsVisible(JFileChooser fc, File f)
      protected ActionMap | getActionMap()
      protected JButton | getApproveButton(JFileChooser fc)
      protected JPanel | getBottomPanel()
      protected JPanel | getButtonPanel()
      String getDirectoryName()
      String getFileName()
      Dimension getMaximumSize(JComponent c)
      Returns the maximum size of the JFileChooser.
      Dimension getMinimumSize(JComponent c)
      Returns the minimum size of the JFileChooser.
      Dimension getPreferredSize(JComponent c)
      Returns the preferred size of the specified JFileChooser.
      void | installComponents(JFileChooser fc)
      protected void | installListeners(JFileChooser fc)
      protected void | installStrings(JFileChooser fc)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | removeControlButtons()
      void | rescanCurrentDirectory(JFileChooser fc)
      void | setDirectoryName(String dirname)
      protected void setDirectorySelected(boolean directorySelected)
      Property to remember whether a directory is currently selected in the UI.
      void | setFileName(String filename)
      void | uninstallComponents(JFileChooser fc)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void | valueChanged(ListSelectionEvent e)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicFileChooserUI

        clearIconCache, createDoubleClickListener, createModel, getAcceptAllFileFilter, getAccessoryPanel, getApproveButtonMnemonic, getApproveButtonText, getApproveButtonToolTipText, getApproveSelectionAction, getCancelSelectionAction, getChangeToParentDirectoryAction, getDefaultButton, getDialogTitle, getDirectory, getFileChooser, getFileView, getGoHomeAction, getModel, getNewFolderAction, getUpdateAction, installDefaults, installIcons, isDirectorySelected, setDirectory, uninstallDefaults, uninstallIcons, uninstallListeners, uninstallStrings

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalFileChooserUI

        public MetalFileChooserUI(JFileChooser filechooser)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicFileChooserUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallComponents

        public void uninstallComponents(JFileChooser fc)
        重载：
        uninstallComponents in class BasicFileChooserUI

      • installComponents

        public void installComponents(JFileChooser fc)
        重载：
        installComponents in class BasicFileChooserUI

      • getButtonPanel

        protected JPanel getButtonPanel()

      • getBottomPanel

        protected JPanel getBottomPanel()

      • installStrings

        protected void installStrings(JFileChooser fc)
        重载：
        installStrings in class BasicFileChooserUI

      • installListeners

        protected void installListeners(JFileChooser fc)
        重载：
        installListeners in class BasicFileChooserUI

      • getActionMap

        protected ActionMap getActionMap()

      • createActionMap

        protected ActionMap createActionMap()

      • createList

        protected JPanel createList(JFileChooser fc)

      • createDetailsView

        protected JPanel createDetailsView(JFileChooser fc)

      • createListSelectionListener

        public ListSelectionListener createListSelectionListener(JFileChooser fc)
        Creates a selection listener for the list of files and directories.
        重载：
        createListSelectionListener in class BasicFileChooserUI
        参数：
        fc - a JFileChooser
        返回：
        a ListSelectionListener

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicFileChooserUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Returns the preferred size of the specified JFileChooser. The preferred size is at least as large, in both height and width, as the preferred size recommended by the file chooser's layout manager.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - a JFileChooser
        返回：
        a Dimension specifying the preferred width and height of the file chooser
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Returns the minimum size of the JFileChooser.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - a JFileChooser
        返回：
        a Dimension specifying the minimum width and height of the file chooser
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Returns the maximum size of the JFileChooser.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - a JFileChooser
        返回：
        a Dimension specifying the maximum width and height of the file chooser
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • createPropertyChangeListener

        public PropertyChangeListener createPropertyChangeListener(JFileChooser fc)
        重载：
        createPropertyChangeListener in class BasicFileChooserUI

      • removeControlButtons

        protected void removeControlButtons()

      • addControlButtons

        protected void addControlButtons()

      • ensureFileIsVisible

        public void ensureFileIsVisible(JFileChooser fc,
                       File f)
        重载：
        ensureFileIsVisible in class BasicFileChooserUI

      • rescanCurrentDirectory

        public void rescanCurrentDirectory(JFileChooser fc)
        重载：
        rescanCurrentDirectory in class BasicFileChooserUI

      • getFileName

        public String getFileName()
        重载：
        getFileName in class BasicFileChooserUI

      • setFileName

        public void setFileName(String filename)
        重载：
        setFileName in class BasicFileChooserUI

      • setDirectorySelected

        protected void setDirectorySelected(boolean directorySelected)
        Property to remember whether a directory is currently selected in the UI. This is normally called by the UI on a selection event.
        重载：
        setDirectorySelected in class BasicFileChooserUI
        参数：
        directorySelected - if a directory is currently selected.
        从以下版本开始：
        1.4

      • getDirectoryName

        public String getDirectoryName()
        重载：
        getDirectoryName in class BasicFileChooserUI

      • setDirectoryName

        public void setDirectoryName(String dirname)
        重载：
        setDirectoryName in class BasicFileChooserUI

      • createDirectoryComboBoxRenderer

        protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer createDirectoryComboBoxRenderer(JFileChooser fc)

      • createDirectoryComboBoxModel

        protected MetalFileChooserUI.DirectoryComboBoxModel createDirectoryComboBoxModel(JFileChooser fc)

      • createFilterComboBoxRenderer

        protected MetalFileChooserUI.FilterComboBoxRenderer createFilterComboBoxRenderer()

      • createFilterComboBoxModel

        protected MetalFileChooserUI.FilterComboBoxModel createFilterComboBoxModel()

      • valueChanged

        public void valueChanged(ListSelectionEvent e)

      • getApproveButton

        protected JButton getApproveButton(JFileChooser fc)
        重载：
        getApproveButton in class BasicFileChooserUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalFileChooserUI.DirectoryComboBoxAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalFileChooserUI.DirectoryComboBoxAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    MetalFileChooserUI

    protected class MetalFileChooserUI.DirectoryComboBoxAction
extends AbstractAction
    Acts when DirectoryComboBox has changed the selected item.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalFileChooserUI.DirectoryComboBoxAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Invoked when an action occurs.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalFileChooserUI.DirectoryComboBoxAction

        protected MetalFileChooserUI.DirectoryComboBoxAction()

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        从接口复制的描述： ActionListener
        Invoked when an action occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kvtcfb//b/gpp/gg/.ffffa


MetalFileChooserUI.DirectoryComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalFileChooserUI.DirectoryComboBoxModel

  • java.lang.Object
    • javax.swing.AbstractListModel
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel
  • 所有已实现的接口：
    Serializable, ComboBoxModel, ListModel
    封闭类：
    MetalFileChooserUI

    protected class MetalFileChooserUI.DirectoryComboBoxModel
extends AbstractListModel
implements ComboBoxModel
    Data model for a type-face selection combo-box.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractListModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalFileChooserUI.DirectoryComboBoxModel()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getDepth(int i)
      Object getElementAt(int index)
      Returns the value at the specified index.
      Object getSelectedItem()
      Returns the selected item
      int getSize()
      Returns the length of the list.
      void setSelectedItem(Object selectedDirectory)
      Set the selected item.

      • 方法 - 继承于类 javax.swing.AbstractListModel

        addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.ListModel

        addListDataListener, removeListDataListener

    • 构造方法详细信息

      • MetalFileChooserUI.DirectoryComboBoxModel

        public MetalFileChooserUI.DirectoryComboBoxModel()

    • 方法详细信息

      • getDepth

        public int getDepth(int i)

      • setSelectedItem

        public void setSelectedItem(Object selectedDirectory)
        从接口复制的描述： ComboBoxModel
        Set the selected item. The implementation of this method should notify all registered ListDataListeners that the contents have changed.
        指定者：
        setSelectedItem in interface ComboBoxModel
        参数：
        selectedDirectory - the list object to select or null to clear the selection

      • getSelectedItem

        public Object getSelectedItem()
        从接口复制的描述： ComboBoxModel
        Returns the selected item
        指定者：
        getSelectedItem in interface ComboBoxModel
        返回：
        The selected item or null if there is no selection

      • getSize

        public int getSize()
        从接口复制的描述： ListModel
        Returns the length of the list.
        指定者：
        getSize in interface ListModel
        返回：
        the length of the list

      • getElementAt

        public Object getElementAt(int index)
        从接口复制的描述： ListModel
        Returns the value at the specified index.
        指定者：
        getElementAt in interface ListModel
        参数：
        index - the requested index
        返回：
        the value at index
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/heih.ghubttubb doopph xteponet eehmeupnwed


MetalFileChooserUI.FileRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalFileChooserUI.FileRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.DefaultListCellRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer<Object>, SwingConstants
    封闭类：
    MetalFileChooserUI

    protected class MetalFileChooserUI.FileRenderer
extends DefaultListCellRenderer

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.DefaultListCellRenderer

        DefaultListCellRenderer.UIResource

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.DefaultListCellRenderer

        noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalFileChooserUI.FileRenderer()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.DefaultListCellRenderer

        firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getListCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MetalFileChooserUI.FileRenderer

        protected MetalFileChooserUI.FileRenderer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


MetalFileChooserUI.FilterComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalFileChooserUI.FilterComboBoxModel

  • java.lang.Object
    • javax.swing.AbstractListModel
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, ComboBoxModel, ListModel
    封闭类：
    MetalFileChooserUI

    protected class MetalFileChooserUI.FilterComboBoxModel
extends AbstractListModel
implements ComboBoxModel, PropertyChangeListener
    Data model for a type-face selection combo-box.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected FileFilter[] | filters

      • Fields inherited from class javax.swing.AbstractListModel

        listenerList

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalFileChooserUI.FilterComboBoxModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getElementAt(int index)
      Returns the value at the specified index.
      Object getSelectedItem()
      Returns the selected item
      int getSize()
      Returns the length of the list.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      void setSelectedItem(Object filter)
      Set the selected item.

      • 方法 - 继承于类 javax.swing.AbstractListModel

        addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.ListModel

        addListDataListener, removeListDataListener

    • 字段详细信息

      • filters

        protected FileFilter[] filters

    • 构造方法详细信息

      • MetalFileChooserUI.FilterComboBoxModel

        protected MetalFileChooserUI.FilterComboBoxModel()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • setSelectedItem

        public void setSelectedItem(Object filter)
        从接口复制的描述： ComboBoxModel
        Set the selected item. The implementation of this method should notify all registered ListDataListeners that the contents have changed.
        指定者：
        setSelectedItem in interface ComboBoxModel
        参数：
        filter - the list object to select or null to clear the selection

      • getSelectedItem

        public Object getSelectedItem()
        从接口复制的描述： ComboBoxModel
        Returns the selected item
        指定者：
        getSelectedItem in interface ComboBoxModel
        返回：
        The selected item or null if there is no selection

      • getSize

        public int getSize()
        从接口复制的描述： ListModel
        Returns the length of the list.
        指定者：
        getSize in interface ListModel
        返回：
        the length of the list

      • getElementAt

        public Object getElementAt(int index)
        从接口复制的描述： ListModel
        Returns the value at the specified index.
        指定者：
        getElementAt in interface ListModel
        参数：
        index - the requested index
        返回：
        the value at index
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ommx.j./j./...//.ammaa


MetalFileChooserUI.FilterComboBoxRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalFileChooserUI.FilterComboBoxRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.DefaultListCellRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer<Object>, SwingConstants
    封闭类：
    MetalFileChooserUI

    public class MetalFileChooserUI.FilterComboBoxRenderer
extends DefaultListCellRenderer
    Render different type sizes and styles.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.DefaultListCellRenderer

        DefaultListCellRenderer.UIResource

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.DefaultListCellRenderer

        noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalFileChooserUI.FilterComboBoxRenderer()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
      Return a component that has been configured to display the specified value.

      • 方法 - 继承于类 javax.swing.DefaultListCellRenderer

        firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MetalFileChooserUI.FilterComboBoxRenderer

        public MetalFileChooserUI.FilterComboBoxRenderer()

    • 方法详细信息

      • getListCellRendererComponent

        public Component getListCellRendererComponent(JList list,
                                     Object value,
                                     int index,
                                     boolean isSelected,
                                     boolean cellHasFocus)
        从接口复制的描述： ListCellRenderer
        Return a component that has been configured to display the specified value. That component's paint method is then called to "render" the cell. If it is necessary to compute the dimensions of a list because the list cells do not have a fixed size, this method is called to generate a component on which getPreferredSize can be invoked.
        指定者：
        getListCellRendererComponent in interface ListCellRenderer<Object>
        重载：
        getListCellRendererComponent in class DefaultListCellRenderer
        参数：
        list - The JList we're painting.
        value - The value returned by list.getModel().getElementAt(index).
        index - The cells index.
        isSelected - True if the specified cell was selected.
        cellHasFocus - True if the specified cell has the focus.
        返回：
        A component whose paint() method will render the specified value.
        另请参见：
        JList, ListSelectionModel, ListModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalFileChooserUI.SingleClickListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalFileChooserUI.SingleClickListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    MetalFileChooserUI

    protected class MetalFileChooserUI.SingleClickListener
extends MouseAdapter

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalFileChooserUI.SingleClickListener(JList list)

    • 方法摘要

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalFileChooserUI.SingleClickListener

        public MetalFileChooserUI.SingleClickListener(JList list)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eUl.oeeseelCCellsb//Isnteaa#ahlsavi"


MetalIconFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory
  • 所有已实现的接口：
    Serializable

    public class MetalIconFactory
extends Object
implements Serializable
    Factory object that vends Icons for the JavaTM look and feel (Metal). These icons are used extensively in Metal via the defaults mechanism. While other look and feels often use GIFs for icons, creating icons in code facilitates switching to other themes.

    Each method in this class returns either an Icon or null, where null implies that there is no default icon.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  MetalIconFactory.FileIcon16
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.FolderIcon16
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.PaletteCloseIcon
      Defines an icon for Palette close
      static class  MetalIconFactory.TreeControlIcon
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  MetalIconFactory.TreeFolderIcon
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      static class  | MetalIconFactory.TreeLeafIcon

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static boolean | DARK
      static boolean | LIGHT

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Icon getCheckBoxIcon()
      Returns a checkbox icon.
      static Icon | getCheckBoxMenuItemIcon()
      static Icon | getFileChooserDetailViewIcon()
      static Icon | getFileChooserHomeFolderIcon()
      static Icon | getFileChooserListViewIcon()
      static Icon | getFileChooserNewFolderIcon()
      static Icon | getFileChooserUpFolderIcon()
      static Icon | getHorizontalSliderThumbIcon()
      static Icon | getInternalFrameAltMaximizeIcon(int size)
      static Icon | getInternalFrameCloseIcon(int size)
      static Icon | getInternalFrameDefaultMenuIcon()
      static Icon | getInternalFrameMaximizeIcon(int size)
      static Icon | getInternalFrameMinimizeIcon(int size)
      static Icon | getMenuArrowIcon()
      static Icon | getMenuItemArrowIcon()
      static Icon getMenuItemCheckIcon()
      Returns an icon to be used by JCheckBoxMenuItem.
      static Icon | getRadioButtonIcon()
      static Icon | getRadioButtonMenuItemIcon()
      static Icon | getTreeComputerIcon()
      static Icon | getTreeControlIcon(boolean isCollapsed)
      static Icon | getTreeFloppyDriveIcon()
      static Icon | getTreeFolderIcon()
      static Icon | getTreeHardDriveIcon()
      static Icon | getTreeLeafIcon()
      static Icon | getVerticalSliderThumbIcon()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DARK

        public static final boolean DARK
        另请参见：
        Constant Field Values

      • LIGHT

        public static final boolean LIGHT
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MetalIconFactory

        public MetalIconFactory()

    • 方法详细信息

      • getFileChooserDetailViewIcon

        public static Icon getFileChooserDetailViewIcon()

      • getFileChooserHomeFolderIcon

        public static Icon getFileChooserHomeFolderIcon()

      • getFileChooserListViewIcon

        public static Icon getFileChooserListViewIcon()

      • getFileChooserNewFolderIcon

        public static Icon getFileChooserNewFolderIcon()

      • getFileChooserUpFolderIcon

        public static Icon getFileChooserUpFolderIcon()

      • getInternalFrameAltMaximizeIcon

        public static Icon getInternalFrameAltMaximizeIcon(int size)

      • getInternalFrameCloseIcon

        public static Icon getInternalFrameCloseIcon(int size)

      • getInternalFrameDefaultMenuIcon

        public static Icon getInternalFrameDefaultMenuIcon()

      • getInternalFrameMaximizeIcon

        public static Icon getInternalFrameMaximizeIcon(int size)

      • getInternalFrameMinimizeIcon

        public static Icon getInternalFrameMinimizeIcon(int size)

      • getRadioButtonIcon

        public static Icon getRadioButtonIcon()

      • getCheckBoxIcon

        public static Icon getCheckBoxIcon()
        Returns a checkbox icon.
        从以下版本开始：
        1.3

      • getTreeComputerIcon

        public static Icon getTreeComputerIcon()

      • getTreeFloppyDriveIcon

        public static Icon getTreeFloppyDriveIcon()

      • getTreeFolderIcon

        public static Icon getTreeFolderIcon()

      • getTreeHardDriveIcon

        public static Icon getTreeHardDriveIcon()

      • getTreeLeafIcon

        public static Icon getTreeLeafIcon()

      • getTreeControlIcon

        public static Icon getTreeControlIcon(boolean isCollapsed)

      • getMenuArrowIcon

        public static Icon getMenuArrowIcon()

      • getMenuItemCheckIcon

        public static Icon getMenuItemCheckIcon()
        Returns an icon to be used by JCheckBoxMenuItem.
        返回：
        the default icon for check box menu items, or null if no default exists

      • getMenuItemArrowIcon

        public static Icon getMenuItemArrowIcon()

      • getCheckBoxMenuItemIcon

        public static Icon getCheckBoxMenuItemIcon()

      • getRadioButtonMenuItemIcon

        public static Icon getRadioButtonMenuItemIcon()

      • getHorizontalSliderThumbIcon

        public static Icon getHorizontalSliderThumbIcon()

      • getVerticalSliderThumbIcon

        public static Icon getVerticalSliderThumbIcon()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.


MetalIconFactory.FileIcon16

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.FileIcon16

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16
  • 所有已实现的接口：
    Serializable, Icon
    直接已知子类：
    MetalIconFactory.TreeLeafIcon
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.FileIcon16
extends Object
implements Icon, Serializable

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.FileIcon16()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getAdditionalHeight()
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      int | getShift()
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalIconFactory.FileIcon16

        public MetalIconFactory.FileIcon16()

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • getShift

        public int getShift()

      • getAdditionalHeight

        public int getAdditionalHeight()

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>>aan e<


MetalIconFactory.FolderIcon16

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.FolderIcon16

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
  • 所有已实现的接口：
    Serializable, Icon
    直接已知子类：
    MetalIconFactory.TreeFolderIcon
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.FolderIcon16
extends Object
implements Icon, Serializable

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.FolderIcon16()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getAdditionalHeight()
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      int | getShift()
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalIconFactory.FolderIcon16

        public MetalIconFactory.FolderIcon16()

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • getShift

        public int getShift()

      • getAdditionalHeight

        public int getAdditionalHeight()

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m edh= = n<< tn>m'Igdc/pod=ootilrhttnUwdp


MetalIconFactory.PaletteCloseIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.PaletteCloseIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
  • 所有已实现的接口：
    Serializable, Icon, UIResource
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.PaletteCloseIcon
extends Object
implements Icon, UIResource, Serializable
    Defines an icon for Palette close
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.PaletteCloseIcon()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalIconFactory.PaletteCloseIcon

        public MetalIconFactory.PaletteCloseIcon()

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n>= l cl ><< >> seeiMiioeenl


MetalIconFactory.TreeControlIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.TreeControlIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
  • 所有已实现的接口：
    Serializable, Icon
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.TreeControlIcon
extends Object
implements Icon, Serializable

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean | isLight

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.TreeControlIcon(boolean isCollapsed)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int getIconHeight()
      Returns the icon's height.
      int getIconWidth()
      Returns the icon's width.
      void paintIcon(Component c, Graphics g, int x, int y)
      Draw the icon at the specified location.
      void | paintMe(Component c, Graphics g, int x, int y)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • isLight

        protected boolean isLight

    • 构造方法详细信息

      • MetalIconFactory.TreeControlIcon

        public MetalIconFactory.TreeControlIcon(boolean isCollapsed)

    • 方法详细信息

      • paintIcon

        public void paintIcon(Component c,
             Graphics g,
             int x,
             int y)
        从接口复制的描述： Icon
        Draw the icon at the specified location. Icon implementations may use the Component argument to get properties useful for painting, e.g. the foreground or background color.
        指定者：
        paintIcon in interface Icon

      • paintMe

        public void paintMe(Component c,
           Graphics g,
           int x,
           int y)

      • getIconWidth

        public int getIconWidth()
        从接口复制的描述： Icon
        Returns the icon's width.
        指定者：
        getIconWidth in interface Icon
        返回：
        an int specifying the fixed width of the icon.

      • getIconHeight

        public int getIconHeight()
        从接口复制的描述： Icon
        Returns the icon's height.
        指定者：
        getIconHeight in interface Icon
        返回：
        an int specifying the fixed height of the icon.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>cDk=bn"blctcc4aul


MetalIconFactory.TreeFolderIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.TreeFolderIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
  • 所有已实现的接口：
    Serializable, Icon
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.TreeFolderIcon
extends MetalIconFactory.FolderIcon16

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.TreeFolderIcon()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getAdditionalHeight()
      int | getShift()

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

        getIconHeight, getIconWidth, paintIcon

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalIconFactory.TreeFolderIcon

        public MetalIconFactory.TreeFolderIcon()

    • 方法详细信息

      • getShift

        public int getShift()
        重载：
        getShift in class MetalIconFactory.FolderIcon16

      • getAdditionalHeight

        public int getAdditionalHeight()
        重载：
        getAdditionalHeight in class MetalIconFactory.FolderIcon16
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fs=obpespec::ecct pple;ubnntbe<


MetalIconFactory.TreeLeafIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalIconFactory.TreeLeafIcon

  • java.lang.Object
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
  • 所有已实现的接口：
    Serializable, Icon
    封闭类：
    MetalIconFactory

    public static class MetalIconFactory.TreeLeafIcon
extends MetalIconFactory.FileIcon16

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalIconFactory.TreeLeafIcon()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getAdditionalHeight()
      int | getShift()

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16

        getIconHeight, getIconWidth, paintIcon

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalIconFactory.TreeLeafIcon

        public MetalIconFactory.TreeLeafIcon()

    • 方法详细信息

      • getShift

        public int getShift()
        重载：
        getShift in class MetalIconFactory.FileIcon16

      • getAdditionalHeight

        public int getAdditionalHeight()
        重载：
        getAdditionalHeight in class MetalIconFactory.FileIcon16
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oena"apafaml== o/ <= =vv=T==l


MetalInternalFrameTitlePane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalInternalFrameTitlePane

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable

    public class MetalInternalFrameTitlePane
extends BasicInternalFrameTitlePane
    Class that manages a JLF title bar
    从以下版本开始：
    1.3

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicInternalFrameTitlePane

        BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.PropertyChangeHandler, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicInternalFrameTitlePane.SystemMenuBar, BasicInternalFrameTitlePane.TitlePaneLayout

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected boolean | isPalette
      protected Icon | paletteCloseIcon
      protected int | paletteTitleHeight

      • Fields inherited from class javax.swing.plaf.basic.BasicInternalFrameTitlePane

        CLOSE_CMD, closeAction, closeButton, closeIcon, frame, iconButton, iconIcon, ICONIFY_CMD, iconifyAction, maxButton, maxIcon, MAXIMIZE_CMD, maximizeAction, menuBar, minIcon, MOVE_CMD, moveAction, notSelectedTextColor, notSelectedTitleColor, propertyChangeListener, RESTORE_CMD, restoreAction, selectedTextColor, selectedTitleColor, SIZE_CMD, sizeAction, windowMenu

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalInternalFrameTitlePane(JInternalFrame f)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void addNotify()
      Notifies this component that it now has a parent component.
      protected void addSubComponents()
      Override the parent's method avoid creating a menu bar.
      protected void addSystemMenuItems(JMenu systemMenu)
      Override the parent's method to do nothing.
      protected void assembleSystemMenu()
      Override the parent's method to do nothing.
      protected void | createButtons()
      protected LayoutManager | createLayout()
      protected PropertyChangeListener | createPropertyChangeListener()
      protected void | installDefaults()
      void paintComponent(Graphics g)
      Calls the UI delegate's paint method, if the UI delegate is non-null.
      void | paintPalette(Graphics g)
      void | setPalette(boolean b)
      protected void showSystemMenu()
      Override the parent's method to do nothing.
      protected void | uninstallDefaults()

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicInternalFrameTitlePane

        createActions, createSystemMenu, createSystemMenuBar, enableActions, getTitle, installListeners, installTitlePane, paintTitleBackground, postClosingEvent, setButtonIcons, uninstallListeners

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • isPalette

        protected boolean isPalette

      • paletteCloseIcon

        protected Icon paletteCloseIcon

      • paletteTitleHeight

        protected int paletteTitleHeight

    • 构造方法详细信息

      • MetalInternalFrameTitlePane

        public MetalInternalFrameTitlePane(JInternalFrame f)

    • 方法详细信息

      • addNotify

        public void addNotify()
        Description copied from class: JComponent
        Notifies this component that it now has a parent component. When this method is invoked, the chain of parent components is set up with KeyboardAction event listeners. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        addNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicInternalFrameTitlePane

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicInternalFrameTitlePane

      • createButtons

        protected void createButtons()
        重载：
        createButtons in class BasicInternalFrameTitlePane

      • assembleSystemMenu

        protected void assembleSystemMenu()
        Override the parent's method to do nothing. Metal frames do not have system menus.
        重载：
        assembleSystemMenu in class BasicInternalFrameTitlePane

      • addSystemMenuItems

        protected void addSystemMenuItems(JMenu systemMenu)
        Override the parent's method to do nothing. Metal frames do not have system menus.
        重载：
        addSystemMenuItems in class BasicInternalFrameTitlePane

      • showSystemMenu

        protected void showSystemMenu()
        Override the parent's method to do nothing. Metal frames do not have system menus.
        重载：
        showSystemMenu in class BasicInternalFrameTitlePane

      • addSubComponents

        protected void addSubComponents()
        Override the parent's method avoid creating a menu bar. Metal frames do not have system menus.
        重载：
        addSubComponents in class BasicInternalFrameTitlePane

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        重载：
        createPropertyChangeListener in class BasicInternalFrameTitlePane

      • createLayout

        protected LayoutManager createLayout()
        重载：
        createLayout in class BasicInternalFrameTitlePane

      • paintPalette

        public void paintPalette(Graphics g)

      • paintComponent

        public void paintComponent(Graphics g)
        Description copied from class: JComponent
        Calls the UI delegate's paint method, if the UI delegate is non-null. We pass the delegate a copy of the Graphics object to protect the rest of the paint code from irrevocable changes (for example, Graphics.translate).

        If you override this in a subclass you should not make permanent changes to the passed in Graphics. For example, you should not alter the clip Rectangle or modify the transform. If you need to do these operations you may find it easier to create a new Graphics from the passed in Graphics and manipulate it. Further, if you do not invoker super's implementation you must honor the opaque property, that is if this component is opaque, you must completely fill in the background in a non-opaque color. If you do not honor the opaque property you will likely see visual artifacts.

        The passed in Graphics object might have a transform other than the identify transform installed on it. In this case, you might get unexpected results if you cumulatively apply another transform.

        重载：
        paintComponent in class BasicInternalFrameTitlePane
        参数：
        g - the Graphics object to protect
        另请参见：
        JComponent.paint(java.awt.Graphics), ComponentUI

      • setPalette

        public void setPalette(boolean b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalInternalFrameUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI

  • public class MetalInternalFrameUI
extends BasicInternalFrameUI
    Metal implementation of JInternalFrame.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicInternalFrameUI

        BasicInternalFrameUI.BasicInternalFrameListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.ComponentHandler, BasicInternalFrameUI.GlassPaneDispatcher, BasicInternalFrameUI.InternalFrameLayout, BasicInternalFrameUI.InternalFramePropertyChangeListener

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static String | IS_PALETTE

      • Fields inherited from class javax.swing.plaf.basic.BasicInternalFrameUI

        borderListener, componentListener, eastPane, frame, glassPaneDispatcher, internalFrameLayout, northPane, openMenuKey, propertyChangeListener, southPane, titlePane, westPane

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalInternalFrameUI(JInternalFrame b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected MouseInputAdapter createBorderListener(JInternalFrame w)
      Returns the MouseInputAdapter that will be installed on the TitlePane.
      protected JComponent | createNorthPane(JInternalFrame w)
      static ComponentUI | createUI(JComponent c)
      protected void | installKeyboardActions()
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void | setPalette(boolean isPalette)
      protected void | uninstallComponents()
      protected void | uninstallKeyboardActions()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicInternalFrameUI

        activateFrame, closeFrame, createComponentListener, createDesktopManager, createEastPane, createGlassPaneDispatcher, createInternalFrameListener, createLayoutManager, createPropertyChangeListener, createSouthPane, createWestPane, deactivateFrame, deiconifyFrame, deinstallMouseHandlers, getDesktopManager, getEastPane, getMaximumSize, getMinimumSize, getNorthPane, getPreferredSize, getSouthPane, getWestPane, iconifyFrame, installComponents, installDefaults, installMouseHandlers, isKeyBindingActive, isKeyBindingRegistered, maximizeFrame, minimizeFrame, replacePane, setEastPane, setKeyBindingActive, setKeyBindingRegistered, setNorthPane, setSouthPane, setupMenuCloseKey, setupMenuOpenKey, setWestPane, uninstallDefaults

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IS_PALETTE

        protected static String IS_PALETTE

    • 构造方法详细信息

      • MetalInternalFrameUI

        public MetalInternalFrameUI(JInternalFrame b)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicInternalFrameUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicInternalFrameUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicInternalFrameUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicInternalFrameUI

      • installKeyboardActions

        protected void installKeyboardActions()
        重载：
        installKeyboardActions in class BasicInternalFrameUI

      • uninstallKeyboardActions

        protected void uninstallKeyboardActions()
        重载：
        uninstallKeyboardActions in class BasicInternalFrameUI

      • uninstallComponents

        protected void uninstallComponents()
        重载：
        uninstallComponents in class BasicInternalFrameUI

      • createNorthPane

        protected JComponent createNorthPane(JInternalFrame w)
        重载：
        createNorthPane in class BasicInternalFrameUI

      • setPalette

        public void setPalette(boolean isPalette)

      • createBorderListener

        protected MouseInputAdapter createBorderListener(JInternalFrame w)
        Returns the MouseInputAdapter that will be installed on the TitlePane.
        重载：
        createBorderListener in class BasicInternalFrameUI
        参数：
        w - the JInternalFrame
        返回：
        the MouseInputAdapter that will be installed on the TitlePane.
        从以下版本开始：
        1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hsea(oMboMpeeMppstnnvajgwuwroudr/e.a aaeoe)tlr


MetalLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalLabelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI
          • javax.swing.plaf.metal.MetalLabelUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener

    public class MetalLabelUI
extends BasicLabelUI
    A Windows L&F implementation of LabelUI. This implementation is completely static, i.e. there's only one UIView implementation that's shared by all JLabel objects.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static MetalLabelUI metalLabelUI
      The default MetalLabelUI instance.

      • Fields inherited from class javax.swing.plaf.basic.BasicLabelUI

        labelUI

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalLabelUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      protected void paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
      Just paint the text gray (Label.disabledForeground) rather than in the labels foreground color.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicLabelUI

        getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, layoutCL, paint, paintEnabledText, propertyChange, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • metalLabelUI

        protected static MetalLabelUI metalLabelUI
        The default MetalLabelUI instance. This field might not be used. To change the default instance use a subclass which overrides the createUI method, and place that class name in defaults table under the key "LabelUI".

    • 构造方法详细信息

      • MetalLabelUI

        public MetalLabelUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • paintDisabledText

        protected void paintDisabledText(JLabel l,
                     Graphics g,
                     String s,
                     int textX,
                     int textY)
        Just paint the text gray (Label.disabledForeground) rather than in the labels foreground color.
        重载：
        paintDisabledText in class BasicLabelUI
        另请参见：
        BasicLabelUI.paint(java.awt.Graphics, javax.swing.JComponent), BasicLabelUI.paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.//f< aa a/>>a//P>JJja.w.xxv.awnslwaaxaal n


MetalLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalLookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel
        • javax.swing.plaf.metal.MetalLookAndFeel
  • 所有已实现的接口：
    Serializable

    public class MetalLookAndFeel
extends BasicLookAndFeel
    The Java Look and Feel, otherwise known as Metal.

    Each of the ComponentUIs provided by MetalLookAndFeel derives its behavior from the defaults table. Unless otherwise noted each of the ComponentUI implementations in this package document the set of defaults they use. Unless otherwise noted the defaults are installed at the time installUI is invoked, and follow the recommendations outlined in LookAndFeel for installing defaults.

    MetalLookAndFeel derives it's color palette and fonts from MetalTheme. The default theme is OceanTheme. The theme can be changed using the setCurrentTheme method, refer to it for details on changing the theme. Prior to 1.5 the default theme was DefaultMetalTheme. The system property "swing.metalTheme" can be set to "steel" to indicate the default should be DefaultMetalTheme.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    MetalTheme, DefaultMetalTheme, OceanTheme

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalLookAndFeel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void createDefaultTheme()
      Ensures the current MetalTheme is non-null.
      static ColorUIResource getAcceleratorForeground()
      Returns the accelerator foreground color of the current theme.
      static ColorUIResource getAcceleratorSelectedForeground()
      Returns the accelerator selected foreground color of the current theme.
      static ColorUIResource getBlack()
      Returns the black color of the current theme.
      static ColorUIResource getControl()
      Returns the control color of the current theme.
      static ColorUIResource getControlDarkShadow()
      Returns the control dark shadow color of the current theme.
      static ColorUIResource getControlDisabled()
      Returns the control disabled color of the current theme.
      static ColorUIResource getControlHighlight()
      Returns the control highlight color of the current theme.
      static ColorUIResource getControlInfo()
      Returns the control info color of the current theme.
      static ColorUIResource getControlShadow()
      Returns the control shadow color of the current theme.
      static ColorUIResource getControlTextColor()
      Returns the control text color of the current theme.
      static FontUIResource getControlTextFont()
      Returns the control text font of the current theme.
      static MetalTheme getCurrentTheme()
      Return the theme currently being used by MetalLookAndFeel.
      UIDefaults getDefaults()
      Returns the look and feel defaults.
      String getDescription()
      Returns a short description of this look and feel.
      static ColorUIResource getDesktopColor()
      Returns the desktop color of the current theme.
      Icon getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      Icon getDisabledSelectedIcon(JComponent component, Icon icon)
      Returns an Icon for use by disabled components that are also selected.
      static ColorUIResource getFocusColor()
      Returns the focus color of the current theme.
      static ColorUIResource getHighlightedTextColor()
      Returns the highlighted text color of the current theme.
      String getID()
      Returns an identifier for this look and feel.
      static ColorUIResource getInactiveControlTextColor()
      Returns the inactive control text color of the current theme.
      static ColorUIResource getInactiveSystemTextColor()
      Returns the inactive system text color of the current theme.
      LayoutStyle getLayoutStyle()
      Returns a LayoutStyle implementing the Java look and feel design guidelines as specified at http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html.
      static ColorUIResource getMenuBackground()
      Returns the menu background color of the current theme.
      static ColorUIResource getMenuDisabledForeground()
      Returns the menu disabled foreground color of the current theme.
      static ColorUIResource getMenuForeground()
      Returns the menu foreground color of the current theme.
      static ColorUIResource getMenuSelectedBackground()
      Returns the menu selected background color of the current theme.
      static ColorUIResource getMenuSelectedForeground()
      Returns the menu selected foreground color of the current theme.
      static FontUIResource getMenuTextFont()
      Returns the menu text font of the current theme.
      String getName()
      Returns the name of this look and feel.
      static ColorUIResource getPrimaryControl()
      Returns the primary control color of the current theme.
      static ColorUIResource getPrimaryControlDarkShadow()
      Returns the primary control dark shadow color of the current theme.
      static ColorUIResource getPrimaryControlHighlight()
      Returns the primary control highlight color of the current theme.
      static ColorUIResource getPrimaryControlInfo()
      Returns the primary control info color of the current theme.
      static ColorUIResource getPrimaryControlShadow()
      Returns the primary control shadow color of the current theme.
      static ColorUIResource getSeparatorBackground()
      Returns the separator background color of the current theme.
      static ColorUIResource getSeparatorForeground()
      Returns the separator foreground color of the current theme.
      static FontUIResource getSubTextFont()
      Returns the sub-text font of the current theme.
      boolean getSupportsWindowDecorations()
      Returns true; metal can provide Window decorations.
      static ColorUIResource getSystemTextColor()
      Returns the system text color of the current theme.
      static FontUIResource getSystemTextFont()
      Returns the sytem text font of the current theme.
      static ColorUIResource getTextHighlightColor()
      Returns the text highlight color of the current theme.
      static ColorUIResource getUserTextColor()
      Returns the user text color of the current theme.
      static FontUIResource getUserTextFont()
      Returns the user text font of the current theme.
      static ColorUIResource getWhite()
      Returns the white color of the current theme.
      static ColorUIResource getWindowBackground()
      Returns the window background color of the current theme.
      static ColorUIResource getWindowTitleBackground()
      Returns the window title background color of the current theme.
      static FontUIResource getWindowTitleFont()
      Returns the window title font of the current theme.
      static ColorUIResource getWindowTitleForeground()
      Returns the window title foreground color of the current theme.
      static ColorUIResource getWindowTitleInactiveBackground()
      Returns the window title inactive background color of the current theme.
      static ColorUIResource getWindowTitleInactiveForeground()
      Returns the window title inactive foreground color of the current theme.
      protected void initClassDefaults(UIDefaults table)
      Populates table with mappings from uiClassID to the fully qualified name of the ui class.
      protected void initComponentDefaults(UIDefaults table)
      Populates table with the defaults for metal.
      protected void initSystemColorDefaults(UIDefaults table)
      Populates table with system colors.
      boolean isNativeLookAndFeel()
      Returns false; MetalLookAndFeel is not a native look and feel.
      boolean isSupportedLookAndFeel()
      Returns true; MetalLookAndFeel can be run on any platform.
      void provideErrorFeedback(Component component)
      Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus.
      static void setCurrentTheme(MetalTheme theme)
      Set the theme used by MetalLookAndFeel.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicLookAndFeel

        createAudioAction, getAudioActionMap, initialize, loadSystemColors, playSound, uninitialize

      • 方法 - 继承于类 javax.swing.LookAndFeel

        getDesktopPropertyValue, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, toString, uninstallBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MetalLookAndFeel

        public MetalLookAndFeel()

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of this look and feel. This returns "Metal".
        指定者：
        getName in class LookAndFeel
        返回：
        the name of this look and feel

      • getID

        public String getID()
        Returns an identifier for this look and feel. This returns "Metal".
        指定者：
        getID in class LookAndFeel
        返回：
        the identifier of this look and feel

      • getDescription

        public String getDescription()
        Returns a short description of this look and feel. This returns "The Java(tm) Look and Feel".
        指定者：
        getDescription in class LookAndFeel
        返回：
        a short description for the look and feel

      • isNativeLookAndFeel

        public boolean isNativeLookAndFeel()
        Returns false; MetalLookAndFeel is not a native look and feel.
        指定者：
        isNativeLookAndFeel in class LookAndFeel
        返回：
        false

      • isSupportedLookAndFeel

        public boolean isSupportedLookAndFeel()
        Returns true; MetalLookAndFeel can be run on any platform.
        指定者：
        isSupportedLookAndFeel in class LookAndFeel
        返回：
        true
        另请参见：
        UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • getSupportsWindowDecorations

        public boolean getSupportsWindowDecorations()
        Returns true; metal can provide Window decorations.
        重载：
        getSupportsWindowDecorations in class LookAndFeel
        返回：
        true
        从以下版本开始：
        1.4
        另请参见：
        JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
JRootPane.setWindowDecorationStyle(int)

      • initClassDefaults

        protected void initClassDefaults(UIDefaults table)
        Populates table with mappings from uiClassID to the fully qualified name of the ui class. MetalLookAndFeel registers an entry for each of the classes in the package javax.swing.plaf.metal that are named MetalXXXUI. The string XXX is one of Swing's uiClassIDs. For the uiClassIDs that do not have a class in metal, the corresponding class in javax.swing.plaf.basic is used. For example, metal does not have a class named "MetalColorChooserUI", as such, javax.swing.plaf.basic.BasicColorChooserUI is used.
        重载：
        initClassDefaults in class BasicLookAndFeel
        参数：
        table - the UIDefaults instance the entries are added to
        抛出：
        NullPointerException - if table is null
        另请参见：
        BasicLookAndFeel.initClassDefaults(javax.swing.UIDefaults)

      • initSystemColorDefaults

        protected void initSystemColorDefaults(UIDefaults table)
        Populates table with system colors. The following values are added to table:
        Key | Value
        "desktop" | theme.getDesktopColor()
        "activeCaption" | theme.getWindowTitleBackground()
        "activeCaptionText" | theme.getWindowTitleForeground()
        "activeCaptionBorder" | theme.getPrimaryControlShadow()
        "inactiveCaption" | theme.getWindowTitleInactiveBackground()
        "inactiveCaptionText" | theme.getWindowTitleInactiveForeground()
        "inactiveCaptionBorder" | theme.getControlShadow()
        "window" | theme.getWindowBackground()
        "windowBorder" | theme.getControl()
        "windowText" | theme.getUserTextColor()
        "menu" | theme.getMenuBackground()
        "menuText" | theme.getMenuForeground()
        "text" | theme.getWindowBackground()
        "textText" | theme.getUserTextColor()
        "textHighlight" | theme.getTextHighlightColor()
        "textHighlightText" | theme.getHighlightedTextColor()
        "textInactiveText" | theme.getInactiveSystemTextColor()
        "control" | theme.getControl()
        "controlText" | theme.getControlTextColor()
        "controlHighlight" | theme.getControlHighlight()
        "controlLtHighlight" | theme.getControlHighlight()
        "controlShadow" | theme.getControlShadow()
        "controlDkShadow" | theme.getControlDarkShadow()
        "scrollbar" | theme.getControl()
        "info" | theme.getPrimaryControl()
        "infoText" | theme.getPrimaryControlInfo()
        The value theme corresponds to the current MetalTheme.
        重载：
        initSystemColorDefaults in class BasicLookAndFeel
        参数：
        table - the UIDefaults object the values are added to
        抛出：
        NullPointerException - if table is null
        另请参见：
        SystemColor, BasicLookAndFeel.getDefaults(), BasicLookAndFeel.loadSystemColors(javax.swing.UIDefaults, java.lang.String[], boolean)

      • initComponentDefaults

        protected void initComponentDefaults(UIDefaults table)
        Populates table with the defaults for metal.
        重载：
        initComponentDefaults in class BasicLookAndFeel
        参数：
        table - the UIDefaults to add the values to
        抛出：
        NullPointerException - if table is null

      • createDefaultTheme

        protected void createDefaultTheme()
        Ensures the current MetalTheme is non-null. This is a cover method for getCurrentTheme.
        另请参见：
        getCurrentTheme()

      • getDefaults

        public UIDefaults getDefaults()
        Returns the look and feel defaults. This invokes, in order, createDefaultTheme(), super.getDefaults() and getCurrentTheme().addCustomEntriesToTable(table).

        While this method is public, it should only be invoked by the UIManager when the look and feel is set as the current look and feel and after initialize has been invoked.

        重载：
        getDefaults in class BasicLookAndFeel
        返回：
        the look and feel defaults
        另请参见：
        createDefaultTheme(),
BasicLookAndFeel.getDefaults(),
MetalTheme.addCustomEntriesToTable(UIDefaults)

      • provideErrorFeedback

        public void provideErrorFeedback(Component component)
        Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus. The default implementation beeps. Subclasses that wish different behavior should override this and provide the additional feedback.
        重载：
        provideErrorFeedback in class LookAndFeel
        参数：
        component - the Component the error occurred in, may be null indicating the error condition is not directly associated with a Component
        从以下版本开始：
        1.4

      • setCurrentTheme

        public static void setCurrentTheme(MetalTheme theme)
        Set the theme used by MetalLookAndFeel.

        After the theme is set, MetalLookAndFeel needs to be re-installed and the uis need to be recreated. The following shows how to do this:

           MetalLookAndFeel.setCurrentTheme(theme);

   // re-install the Metal Look and Feel
   UIManager.setLookAndFeel(new MetalLookAndFeel());

   // Update the ComponentUIs for all Components. This
   // needs to be invoked for all windows.
   SwingUtilities.updateComponentTreeUI(rootComponent);
        If this is not done the results are undefined.
        参数：
        theme - the theme to use
        抛出：
        NullPointerException - if theme is null
        另请参见：
        getCurrentTheme()

      • getCurrentTheme

        public static MetalTheme getCurrentTheme()
        Return the theme currently being used by MetalLookAndFeel. If the current theme is null, the default theme is created.
        返回：
        the current theme
        从以下版本开始：
        1.5
        另请参见：
        setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

      • getDisabledIcon

        public Icon getDisabledIcon(JComponent component,
                   Icon icon)
        Returns an Icon with a disabled appearance. This method is used to generate a disabled Icon when one has not been specified. For example, if you create a JButton and only specify an Icon via setIcon this method will be called to generate the disabled Icon. If null is passed as icon this method returns null.

        Some look and feels might not render the disabled Icon, in which case they will ignore this.

        重载：
        getDisabledIcon in class LookAndFeel
        参数：
        component - JComponent that will display the Icon, may be null
        icon - Icon to generate disable icon from.
        返回：
        Disabled icon, or null if a suitable Icon can not be generated.
        从以下版本开始：
        1.5

      • getDisabledSelectedIcon

        public Icon getDisabledSelectedIcon(JComponent component,
                           Icon icon)
        Returns an Icon for use by disabled components that are also selected. This method is used to generate an Icon for components that are in both the disabled and selected states but do not have a specific Icon for this state. For example, if you create a JButton and only specify an Icon via setIcon this method will be called to generate the disabled and selected Icon. If null is passed as icon this method returns null.

        Some look and feels might not render the disabled and selected Icon, in which case they will ignore this.

        重载：
        getDisabledSelectedIcon in class LookAndFeel
        参数：
        component - JComponent that will display the Icon, may be null
        icon - Icon to generate disabled and selected icon from.
        返回：
        Disabled and Selected icon, or null if a suitable Icon can not be generated.
        从以下版本开始：
        1.5

      • getControlTextFont

        public static FontUIResource getControlTextFont()
        Returns the control text font of the current theme. This is a cover method for getCurrentTheme().getControlTextColor().
        返回：
        the control text font
        另请参见：
        MetalTheme

      • getSystemTextFont

        public static FontUIResource getSystemTextFont()
        Returns the sytem text font of the current theme. This is a cover method for getCurrentTheme().getSystemTextFont().
        返回：
        the system text font
        另请参见：
        MetalTheme

      • getUserTextFont

        public static FontUIResource getUserTextFont()
        Returns the user text font of the current theme. This is a cover method for getCurrentTheme().getUserTextFont().
        返回：
        the user text font
        另请参见：
        MetalTheme

      • getMenuTextFont

        public static FontUIResource getMenuTextFont()
        Returns the menu text font of the current theme. This is a cover method for getCurrentTheme().getMenuTextFont().
        返回：
        the menu text font
        另请参见：
        MetalTheme

      • getWindowTitleFont

        public static FontUIResource getWindowTitleFont()
        Returns the window title font of the current theme. This is a cover method for getCurrentTheme().getWindowTitleFont().
        返回：
        the window title font
        另请参见：
        MetalTheme

      • getSubTextFont

        public static FontUIResource getSubTextFont()
        Returns the sub-text font of the current theme. This is a cover method for getCurrentTheme().getSubTextFont().
        返回：
        the sub-text font
        另请参见：
        MetalTheme

      • getDesktopColor

        public static ColorUIResource getDesktopColor()
        Returns the desktop color of the current theme. This is a cover method for getCurrentTheme().getDesktopColor().
        返回：
        the desktop color
        另请参见：
        MetalTheme

      • getFocusColor

        public static ColorUIResource getFocusColor()
        Returns the focus color of the current theme. This is a cover method for getCurrentTheme().getFocusColor().
        返回：
        the focus color
        另请参见：
        MetalTheme

      • getWhite

        public static ColorUIResource getWhite()
        Returns the white color of the current theme. This is a cover method for getCurrentTheme().getWhite().
        返回：
        the white color
        另请参见：
        MetalTheme

      • getBlack

        public static ColorUIResource getBlack()
        Returns the black color of the current theme. This is a cover method for getCurrentTheme().getBlack().
        返回：
        the black color
        另请参见：
        MetalTheme

      • getControl

        public static ColorUIResource getControl()
        Returns the control color of the current theme. This is a cover method for getCurrentTheme().getControl().
        返回：
        the control color
        另请参见：
        MetalTheme

      • getControlShadow

        public static ColorUIResource getControlShadow()
        Returns the control shadow color of the current theme. This is a cover method for getCurrentTheme().getControlShadow().
        返回：
        the control shadow color
        另请参见：
        MetalTheme

      • getControlDarkShadow

        public static ColorUIResource getControlDarkShadow()
        Returns the control dark shadow color of the current theme. This is a cover method for getCurrentTheme().getControlDarkShadow().
        返回：
        the control dark shadow color
        另请参见：
        MetalTheme

      • getControlInfo

        public static ColorUIResource getControlInfo()
        Returns the control info color of the current theme. This is a cover method for getCurrentTheme().getControlInfo().
        返回：
        the control info color
        另请参见：
        MetalTheme

      • getControlHighlight

        public static ColorUIResource getControlHighlight()
        Returns the control highlight color of the current theme. This is a cover method for getCurrentTheme().getControlHighlight().
        返回：
        the control highlight color
        另请参见：
        MetalTheme

      • getControlDisabled

        public static ColorUIResource getControlDisabled()
        Returns the control disabled color of the current theme. This is a cover method for getCurrentTheme().getControlDisabled().
        返回：
        the control disabled color
        另请参见：
        MetalTheme

      • getPrimaryControl

        public static ColorUIResource getPrimaryControl()
        Returns the primary control color of the current theme. This is a cover method for getCurrentTheme().getPrimaryControl().
        返回：
        the primary control color
        另请参见：
        MetalTheme

      • getPrimaryControlShadow

        public static ColorUIResource getPrimaryControlShadow()
        Returns the primary control shadow color of the current theme. This is a cover method for getCurrentTheme().getPrimaryControlShadow().
        返回：
        the primary control shadow color
        另请参见：
        MetalTheme

      • getPrimaryControlDarkShadow

        public static ColorUIResource getPrimaryControlDarkShadow()
        Returns the primary control dark shadow color of the current theme. This is a cover method for getCurrentTheme().getPrimaryControlDarkShadow().
        返回：
        the primary control dark shadow color
        另请参见：
        MetalTheme

      • getPrimaryControlInfo

        public static ColorUIResource getPrimaryControlInfo()
        Returns the primary control info color of the current theme. This is a cover method for getCurrentTheme().getPrimaryControlInfo().
        返回：
        the primary control info color
        另请参见：
        MetalTheme

      • getPrimaryControlHighlight

        public static ColorUIResource getPrimaryControlHighlight()
        Returns the primary control highlight color of the current theme. This is a cover method for getCurrentTheme().getPrimaryControlHighlight().
        返回：
        the primary control highlight color
        另请参见：
        MetalTheme

      • getSystemTextColor

        public static ColorUIResource getSystemTextColor()
        Returns the system text color of the current theme. This is a cover method for getCurrentTheme().getSystemTextColor().
        返回：
        the system text color
        另请参见：
        MetalTheme

      • getControlTextColor

        public static ColorUIResource getControlTextColor()
        Returns the control text color of the current theme. This is a cover method for getCurrentTheme().getControlTextColor().
        返回：
        the control text color
        另请参见：
        MetalTheme

      • getInactiveControlTextColor

        public static ColorUIResource getInactiveControlTextColor()
        Returns the inactive control text color of the current theme. This is a cover method for getCurrentTheme().getInactiveControlTextColor().
        返回：
        the inactive control text color
        另请参见：
        MetalTheme

      • getInactiveSystemTextColor

        public static ColorUIResource getInactiveSystemTextColor()
        Returns the inactive system text color of the current theme. This is a cover method for getCurrentTheme().getInactiveSystemTextColor().
        返回：
        the inactive system text color
        另请参见：
        MetalTheme

      • getUserTextColor

        public static ColorUIResource getUserTextColor()
        Returns the user text color of the current theme. This is a cover method for getCurrentTheme().getUserTextColor().
        返回：
        the user text color
        另请参见：
        MetalTheme

      • getTextHighlightColor

        public static ColorUIResource getTextHighlightColor()
        Returns the text highlight color of the current theme. This is a cover method for getCurrentTheme().getTextHighlightColor().
        返回：
        the text highlight color
        另请参见：
        MetalTheme

      • getHighlightedTextColor

        public static ColorUIResource getHighlightedTextColor()
        Returns the highlighted text color of the current theme. This is a cover method for getCurrentTheme().getHighlightedTextColor().
        返回：
        the highlighted text color
        另请参见：
        MetalTheme

      • getWindowBackground

        public static ColorUIResource getWindowBackground()
        Returns the window background color of the current theme. This is a cover method for getCurrentTheme().getWindowBackground().
        返回：
        the window background color
        另请参见：
        MetalTheme

      • getWindowTitleBackground

        public static ColorUIResource getWindowTitleBackground()
        Returns the window title background color of the current theme. This is a cover method for getCurrentTheme().getWindowTitleBackground().
        返回：
        the window title background color
        另请参见：
        MetalTheme

      • getWindowTitleForeground

        public static ColorUIResource getWindowTitleForeground()
        Returns the window title foreground color of the current theme. This is a cover method for getCurrentTheme().getWindowTitleForeground().
        返回：
        the window title foreground color
        另请参见：
        MetalTheme

      • getWindowTitleInactiveBackground

        public static ColorUIResource getWindowTitleInactiveBackground()
        Returns the window title inactive background color of the current theme. This is a cover method for getCurrentTheme().getWindowTitleInactiveBackground().
        返回：
        the window title inactive background color
        另请参见：
        MetalTheme

      • getWindowTitleInactiveForeground

        public static ColorUIResource getWindowTitleInactiveForeground()
        Returns the window title inactive foreground color of the current theme. This is a cover method for getCurrentTheme().getWindowTitleInactiveForeground().
        返回：
        the window title inactive foreground color
        另请参见：
        MetalTheme

      • getMenuBackground

        public static ColorUIResource getMenuBackground()
        Returns the menu background color of the current theme. This is a cover method for getCurrentTheme().getMenuBackground().
        返回：
        the menu background color
        另请参见：
        MetalTheme

      • getMenuForeground

        public static ColorUIResource getMenuForeground()
        Returns the menu foreground color of the current theme. This is a cover method for getCurrentTheme().getMenuForeground().
        返回：
        the menu foreground color
        另请参见：
        MetalTheme

      • getMenuSelectedBackground

        public static ColorUIResource getMenuSelectedBackground()
        Returns the menu selected background color of the current theme. This is a cover method for getCurrentTheme().getMenuSelectedBackground().
        返回：
        the menu selected background color
        另请参见：
        MetalTheme

      • getMenuSelectedForeground

        public static ColorUIResource getMenuSelectedForeground()
        Returns the menu selected foreground color of the current theme. This is a cover method for getCurrentTheme().getMenuSelectedForeground().
        返回：
        the menu selected foreground color
        另请参见：
        MetalTheme

      • getMenuDisabledForeground

        public static ColorUIResource getMenuDisabledForeground()
        Returns the menu disabled foreground color of the current theme. This is a cover method for getCurrentTheme().getMenuDisabledForeground().
        返回：
        the menu disabled foreground color
        另请参见：
        MetalTheme

      • getSeparatorBackground

        public static ColorUIResource getSeparatorBackground()
        Returns the separator background color of the current theme. This is a cover method for getCurrentTheme().getSeparatorBackground().
        返回：
        the separator background color
        另请参见：
        MetalTheme

      • getSeparatorForeground

        public static ColorUIResource getSeparatorForeground()
        Returns the separator foreground color of the current theme. This is a cover method for getCurrentTheme().getSeparatorForeground().
        返回：
        the separator foreground color
        另请参见：
        MetalTheme

      • getAcceleratorForeground

        public static ColorUIResource getAcceleratorForeground()
        Returns the accelerator foreground color of the current theme. This is a cover method for getCurrentTheme().getAcceleratorForeground().
        返回：
        the separator accelerator foreground color
        另请参见：
        MetalTheme

      • getAcceleratorSelectedForeground

        public static ColorUIResource getAcceleratorSelectedForeground()
        Returns the accelerator selected foreground color of the current theme. This is a cover method for getCurrentTheme().getAcceleratorSelectedForeground().
        返回：
        the accelerator selected foreground color
        另请参见：
        MetalTheme

      • getLayoutStyle

        public LayoutStyle getLayoutStyle()
        Returns a LayoutStyle implementing the Java look and feel design guidelines as specified at http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html.
        重载：
        getLayoutStyle in class LookAndFeel
        返回：
        LayoutStyle implementing the Java look and feel design guidelines
        从以下版本开始：
        1.6
        另请参见：
        LayoutStyle.getInstance()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalMenuBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI

  • public class MetalMenuBarUI
extends BasicMenuBarUI
    Metal implementation of MenuBarUI. This class is responsible for providing the metal look and feel for JMenuBars.
    从以下版本开始：
    1.5
    另请参见：
    MenuBarUI

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuBarUI

        changeListener, containerListener, menuBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalMenuBarUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates the ComponentUI implementation for the passed in component.
      void installUI(JComponent c)
      Configures the specified component appropriate for the metal look and feel.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuBarUI

        createChangeListener, createContainerListener, getMaximumSize, getMinimumSize, installDefaults, installKeyboardActions, installListeners, uninstallDefaults, uninstallKeyboardActions, uninstallListeners

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getPreferredSize, paint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalMenuBarUI

        public MetalMenuBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates the ComponentUI implementation for the passed in component.
        参数：
        x - JComponent to create the ComponentUI implementation for
        返回：
        ComponentUI implementation for x
        抛出：
        NullPointerException - if x is null

      • installUI

        public void installUI(JComponent c)
        Configures the specified component appropriate for the metal look and feel.
        重载：
        installUI in class BasicMenuBarUI
        参数：
        c - the component where this UI delegate is being installed
        抛出：
        NullPointerException - if c is null.
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Reverses configuration which was done on the specified component during installUI.
        重载：
        uninstallUI in class BasicMenuBarUI
        参数：
        c - the component where this UI delegate is being installed
        抛出：
        NullPointerException - if c is null.
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • update

        public void update(Graphics g,
          JComponent c)
        If necessary paints the background of the component, then invokes paint.
        重载：
        update in class ComponentUI
        参数：
        g - Graphics to paint to
        c - JComponent painting on
        抛出：
        NullPointerException - if g or c is null
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d/itcrturt hht oo )nktoettkndao>ndnn(ddotnr


MetalPopupMenuSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalPopupMenuSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

  • public class MetalPopupMenuSeparatorUI
extends MetalSeparatorUI
    A Metal L&F implementation of PopupMenuSeparatorUI. This implementation is a "combined" view/controller.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSeparatorUI

        highlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalPopupMenuSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalSeparatorUI

        installDefaults

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSeparatorUI

        getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalPopupMenuSeparatorUI

        public MetalPopupMenuSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class MetalSeparatorUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class MetalSeparatorUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

erlrMrhf"Meeel苘/....exx.ht?sjwllewtdI


MetalProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalProgressBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI

  • public class MetalProgressBarUI
extends BasicProgressBarUI
    The Metal implementation of ProgressBarUI.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicProgressBarUI

        BasicProgressBarUI.ChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicProgressBarUI

        boxRect, changeListener, progressBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalProgressBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      void paintDeterminate(Graphics g, JComponent c)
      Draws a bit of special highlighting on the progress bar.
      void paintIndeterminate(Graphics g, JComponent c)
      Draws a bit of special highlighting on the progress bar and bouncing box.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicProgressBarUI

        getAmountFull, getAnimationIndex, getBaseline, getBaselineResizeBehavior, getBox, getBoxLength, getCellLength, getCellSpacing, getFrameCount, getMaximumSize, getMinimumSize, getPreferredInnerHorizontal, getPreferredInnerVertical, getPreferredSize, getSelectionBackground, getSelectionForeground, getStringPlacement, incrementAnimationIndex, installDefaults, installListeners, installUI, paint, paintString, setAnimationIndex, setCellLength, setCellSpacing, startAnimationTimer, stopAnimationTimer, uninstallDefaults, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalProgressBarUI

        public MetalProgressBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • paintDeterminate

        public void paintDeterminate(Graphics g,
                    JComponent c)
        Draws a bit of special highlighting on the progress bar. The core painting is deferred to the BasicProgressBar's paintDeterminate method.
        重载：
        paintDeterminate in class BasicProgressBarUI
        从以下版本开始：
        1.4
        另请参见：
        BasicProgressBarUI.paintIndeterminate(java.awt.Graphics, javax.swing.JComponent)

      • paintIndeterminate

        public void paintIndeterminate(Graphics g,
                      JComponent c)
        Draws a bit of special highlighting on the progress bar and bouncing box. The core painting is deferred to the BasicProgressBar's paintIndeterminate method.
        重载：
        paintIndeterminate in class BasicProgressBarUI
        从以下版本开始：
        1.4
        另请参见：
        BasicProgressBarUI.paintDeterminate(java.awt.Graphics, javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>>"te/e /.t=.-/sjw..C "1


MetalRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalRadioButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
  • 直接已知子类：
    MetalCheckBoxUI

    public class MetalRadioButtonUI
extends BasicRadioButtonUI
    RadioButtonUI implementation for MetalRadioButtonUI

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | disabledTextColor
      protected Color | focusColor
      protected Color | selectColor

      • Fields inherited from class javax.swing.plaf.basic.BasicRadioButtonUI

        icon

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalRadioButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      protected Color | getDisabledTextColor()
      protected Color | getFocusColor()
      protected Color | getSelectColor()
      void | installDefaults(AbstractButton b)
      void paint(Graphics g, JComponent c)
      paint the radio button
      protected void | paintFocus(Graphics g, Rectangle t, Dimension d)
      protected void | uninstallDefaults(AbstractButton b)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicRadioButtonUI

        getDefaultIcon, getPreferredSize, getPropertyPrefix

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToggleButtonUI

        getTextShiftOffset, paintIcon

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • focusColor

        protected Color focusColor

      • selectColor

        protected Color selectColor

      • disabledTextColor

        protected Color disabledTextColor

    • 构造方法详细信息

      • MetalRadioButtonUI

        public MetalRadioButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        public void installDefaults(AbstractButton b)
        重载：
        installDefaults in class BasicRadioButtonUI

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class BasicRadioButtonUI

      • getSelectColor

        protected Color getSelectColor()

      • getDisabledTextColor

        protected Color getDisabledTextColor()

      • getFocusColor

        protected Color getFocusColor()

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: BasicRadioButtonUI
        paint the radio button
        重载：
        paint in class BasicRadioButtonUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintFocus

        protected void paintFocus(Graphics g,
              Rectangle t,
              Dimension d)
        重载：
        paintFocus in class BasicRadioButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eo :s>o1/d胷


MetalRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalRootPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI
          • javax.swing.plaf.metal.MetalRootPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener

    public class MetalRootPaneUI
extends BasicRootPaneUI
    Provides the metal look and feel implementation of RootPaneUI.

    MetalRootPaneUI provides support for the windowDecorationStyle property of JRootPane. MetalRootPaneUI does this by way of installing a custom LayoutManager, a private Component to render the appropriate widgets, and a private Border. The LayoutManager is always installed, regardless of the value of the windowDecorationStyle property, but the Border and Component are only installed/added if the windowDecorationStyle is other than JRootPane.NONE.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalRootPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JRootPane.
      void installUI(JComponent c)
      Invokes supers implementation of installUI to install the necessary state onto the passed in JRootPane to render the metal look and feel implementation of RootPaneUI.
      void propertyChange(PropertyChangeEvent e)
      Invoked when a property changes.
      void uninstallUI(JComponent c)
      Invokes supers implementation to uninstall any of its state.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicRootPaneUI

        installComponents, installDefaults, installKeyboardActions, installListeners, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalRootPaneUI

        public MetalRootPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JRootPane.
        参数：
        c - the JRootPane the RootPaneUI will be created for
        返回：
        the RootPaneUI implementation for the passed in JRootPane

      • installUI

        public void installUI(JComponent c)
        Invokes supers implementation of installUI to install the necessary state onto the passed in JRootPane to render the metal look and feel implementation of RootPaneUI. If the windowDecorationStyle property of the JRootPane is other than JRootPane.NONE, this will add a custom Component to render the widgets to JRootPane, as well as installing a custom Border and LayoutManager on the JRootPane.
        重载：
        installUI in class BasicRootPaneUI
        参数：
        c - the JRootPane to install state onto
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Invokes supers implementation to uninstall any of its state. This will also reset the LayoutManager of the JRootPane. If a Component has been added to the JRootPane to render the window decoration style, this method will remove it. Similarly, this will revert the Border and LayoutManager of the JRootPane to what it was before installUI was invoked.
        重载：
        uninstallUI in class BasicRootPaneUI
        参数：
        c - the JRootPane to uninstall state from
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Invoked when a property changes. MetalRootPaneUI is primarily interested in events originating from the JRootPane it has been installed on identifying the property windowDecorationStyle. If the windowDecorationStyle has changed to a value other than JRootPane.NONE, this will add a Component to the JRootPane to render the window decorations, as well as installing a Border on the JRootPane. On the other hand, if the windowDecorationStyle has changed to JRootPane.NONE, this will remove the Component that has been added to the JRootPane as well resetting the Border to what it was before installUI was invoked.
        指定者：
        propertyChange in interface PropertyChangeListener
        重载：
        propertyChange in class BasicRootPaneUI
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./.;dne&netccette/ee-" <- --=i/op


MetalScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalScrollBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI
          • javax.swing.plaf.metal.MetalScrollBarUI
  • 所有已实现的接口：
    LayoutManager, SwingConstants

    public class MetalScrollBarUI
extends BasicScrollBarUI
    Implementation of ScrollBarUI for the Metal Look and Feel

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicScrollBarUI

        BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.ModelListener, BasicScrollBarUI.PropertyChangeHandler, BasicScrollBarUI.ScrollListener, BasicScrollBarUI.TrackListener

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected javax.swing.plaf.metal.MetalBumps | bumps
      protected MetalScrollButton | decreaseButton
      static String | FREE_STANDING_PROP
      protected MetalScrollButton | increaseButton
      protected boolean | isFreeStanding
      protected int | scrollBarWidth

      • Fields inherited from class javax.swing.plaf.basic.BasicScrollBarUI

        buttonListener, decrButton, DECREASE_HIGHLIGHT, decrGap, incrButton, INCREASE_HIGHLIGHT, incrGap, isDragging, maximumThumbSize, minimumThumbSize, modelListener, NO_HIGHLIGHT, propertyChangeListener, scrollbar, scrollListener, scrollTimer, thumbDarkShadowColor, thumbLightShadowColor, thumbRect, trackColor, trackHighlight, trackHighlightColor, trackListener, trackRect

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalScrollBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | configureScrollBarColors()
      protected JButton createDecreaseButton(int orientation)
      Returns the view that represents the decrease view.
      protected JButton createIncreaseButton(int orientation)
      Returns the view that represents the increase view.
      protected PropertyChangeListener | createPropertyChangeListener()
      static ComponentUI | createUI(JComponent c)
      protected Dimension getMinimumThumbSize()
      Returns the smallest acceptable size for the thumb.
      Dimension getPreferredSize(JComponent c)
      A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.
      protected void | installDefaults()
      protected void | installListeners()
      protected void | paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
      protected void | paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
      protected void setThumbBounds(int x, int y, int width, int height)
      This is overridden only to increase the invalid area.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicScrollBarUI

        addLayoutComponent, createArrowButtonListener, createModelListener, createScrollListener, createTrackListener, getMaximumSize, getMaximumThumbSize, getSupportsAbsolutePositioning, getThumbBounds, getTrackBounds, installComponents, installKeyboardActions, installUI, isThumbRollover, layoutContainer, layoutHScrollbar, layoutVScrollbar, minimumLayoutSize, paint, paintDecreaseHighlight, paintIncreaseHighlight, preferredLayoutSize, removeLayoutComponent, scrollByBlock, scrollByUnit, setThumbRollover, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMinimumSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • bumps

        protected javax.swing.plaf.metal.MetalBumps bumps

      • increaseButton

        protected MetalScrollButton increaseButton

      • decreaseButton

        protected MetalScrollButton decreaseButton

      • scrollBarWidth

        protected int scrollBarWidth

      • FREE_STANDING_PROP

        public static final String FREE_STANDING_PROP
        另请参见：
        Constant Field Values

      • isFreeStanding

        protected boolean isFreeStanding

    • 构造方法详细信息

      • MetalScrollBarUI

        public MetalScrollBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicScrollBarUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicScrollBarUI

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener()
        重载：
        createPropertyChangeListener in class BasicScrollBarUI

      • configureScrollBarColors

        protected void configureScrollBarColors()
        重载：
        configureScrollBarColors in class BasicScrollBarUI

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: BasicScrollBarUI
        A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb. The preferred height is the sum of the preferred heights of the same parts. The basis for the preferred size of a horizontal scrollbar is similar.

        The preferredSize is only computed once, subsequent calls to this method just return a cached size.

        重载：
        getPreferredSize in class BasicScrollBarUI
        参数：
        c - the JScrollBar that's delegating this method to us
        返回：
        the preferred size of a Basic JScrollBar
        另请参见：
        BasicScrollBarUI.getMaximumSize(javax.swing.JComponent), ComponentUI.getMinimumSize(javax.swing.JComponent)

      • createDecreaseButton

        protected JButton createDecreaseButton(int orientation)
        Returns the view that represents the decrease view.
        重载：
        createDecreaseButton in class BasicScrollBarUI

      • createIncreaseButton

        protected JButton createIncreaseButton(int orientation)
        Returns the view that represents the increase view.
        重载：
        createIncreaseButton in class BasicScrollBarUI

      • paintTrack

        protected void paintTrack(Graphics g,
              JComponent c,
              Rectangle trackBounds)
        重载：
        paintTrack in class BasicScrollBarUI

      • paintThumb

        protected void paintThumb(Graphics g,
              JComponent c,
              Rectangle thumbBounds)
        重载：
        paintThumb in class BasicScrollBarUI

      • getMinimumThumbSize

        protected Dimension getMinimumThumbSize()
        Description copied from class: BasicScrollBarUI
        Returns the smallest acceptable size for the thumb. If the scrollbar becomes so small that this size isn't available, the thumb will be hidden.

        Warning : the value returned by this method should not be be modified, it's a shared static constant.

        重载：
        getMinimumThumbSize in class BasicScrollBarUI
        返回：
        The smallest acceptable size for the thumb.
        另请参见：
        BasicScrollBarUI.getMaximumThumbSize()

      • setThumbBounds

        protected void setThumbBounds(int x,
                  int y,
                  int width,
                  int height)
        This is overridden only to increase the invalid area. This ensures that the "Shadow" below the thumb is invalidated
        重载：
        setThumbBounds in class BasicScrollBarUI
        另请参见：
        BasicScrollBarUI.getThumbBounds()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalScrollButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalScrollButton

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.AbstractButton
            • javax.swing.JButton
              • javax.swing.plaf.basic.BasicArrowButton
                • javax.swing.plaf.metal.MetalScrollButton
  • 所有已实现的接口：
    ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants

    public class MetalScrollButton
extends BasicArrowButton
    JButton object for Metal scrollbar arrows.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JButton

        JButton.AccessibleJButton

      • Nested classes/interfaces inherited from class javax.swing.AbstractButton

        AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicArrowButton

        direction

      • Fields inherited from class javax.swing.AbstractButton

        actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalScrollButton(int direction, int width, boolean freeStanding)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getButtonWidth()
      Dimension getMaximumSize()
      Returns the maximum size of the BasicArrowButton.
      Dimension getMinimumSize()
      Returns the minimum size of the BasicArrowButton.
      Dimension getPreferredSize()
      Returns the preferred size of the BasicArrowButton.
      void paint(Graphics g)
      Invoked by Swing to draw components.
      void | setFreeStanding(boolean freeStanding)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicArrowButton

        getDirection, isFocusTraversable, paintTriangle, setDirection

      • 方法 - 继承于类 javax.swing.JButton

        getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI

      • 方法 - 继承于类 javax.swing.AbstractButton

        actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MetalScrollButton

        public MetalScrollButton(int direction,
                 int width,
                 boolean freeStanding)

    • 方法详细信息

      • setFreeStanding

        public void setFreeStanding(boolean freeStanding)

      • paint

        public void paint(Graphics g)
        Description copied from class: JComponent
        Invoked by Swing to draw components. Applications should not invoke paint directly, but should instead use the repaint method to schedule the component for redrawing.

        This method actually delegates the work of painting to three protected methods: paintComponent, paintBorder, and paintChildren. They're called in the order listed to ensure that children appear on top of component itself. Generally speaking, the component and its children should not paint in the insets area allocated to the border. Subclasses can just override this method, as always. A subclass that just wants to specialize the UI (look and feel) delegate's paint method should just override paintComponent.

        重载：
        paint in class BasicArrowButton
        参数：
        g - the Graphics context in which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • getPreferredSize

        public Dimension getPreferredSize()
        Description copied from class: BasicArrowButton
        Returns the preferred size of the BasicArrowButton.
        重载：
        getPreferredSize in class BasicArrowButton
        返回：
        the preferred size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • getMinimumSize

        public Dimension getMinimumSize()
        Description copied from class: BasicArrowButton
        Returns the minimum size of the BasicArrowButton.
        重载：
        getMinimumSize in class BasicArrowButton
        返回：
        the minimum size
        另请参见：
        JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

      • getMaximumSize

        public Dimension getMaximumSize()
        Description copied from class: BasicArrowButton
        Returns the maximum size of the BasicArrowButton.
        重载：
        getMaximumSize in class BasicArrowButton
        返回：
        the maximum size
        另请参见：
        JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

      • getButtonWidth

        public int getButtonWidth()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalScrollPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI
          • javax.swing.plaf.metal.MetalScrollPaneUI
  • 所有已实现的接口：
    ScrollPaneConstants

    public class MetalScrollPaneUI
extends BasicScrollPaneUI
    A Metal L&F implementation of ScrollPaneUI.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicScrollPaneUI

        BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.MouseWheelHandler, BasicScrollPaneUI.PropertyChangeHandler, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicScrollPaneUI

        hsbChangeListener, scrollpane, spPropertyChangeListener, viewportChangeListener, vsbChangeListener

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalScrollPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected PropertyChangeListener | createScrollBarSwapListener()
      static ComponentUI | createUI(JComponent x)
      void | installListeners(JScrollPane scrollPane)
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void | uninstallListeners(JComponent c)
      void uninstallListeners(JScrollPane scrollPane)
      Deprecated.
      - Replaced by uninstallListeners(JComponent)
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicScrollPaneUI

        createHSBChangeListener, createMouseWheelListener, createPropertyChangeListener, createViewportChangeListener, createVSBChangeListener, getBaseline, getBaselineResizeBehavior, getMaximumSize, installDefaults, installKeyboardActions, paint, syncScrollPaneWithViewport, uninstallDefaults, uninstallKeyboardActions, updateColumnHeader, updateRowHeader, updateScrollBarDisplayPolicy, updateViewport

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMinimumSize, getPreferredSize, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalScrollPaneUI

        public MetalScrollPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicScrollPaneUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicScrollPaneUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installListeners

        public void installListeners(JScrollPane scrollPane)
        重载：
        installListeners in class BasicScrollPaneUI

      • uninstallListeners

        protected void uninstallListeners(JComponent c)
        重载：
        uninstallListeners in class BasicScrollPaneUI

      • uninstallListeners

        @Deprecated
public void uninstallListeners(JScrollPane scrollPane)
        Deprecated. - Replaced by uninstallListeners(JComponent)

      • createScrollBarSwapListener

        protected PropertyChangeListener createScrollBarSwapListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jca/e=af=a< a<


MetalSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
  • 直接已知子类：
    MetalPopupMenuSeparatorUI

    public class MetalSeparatorUI
extends BasicSeparatorUI
    A Metal L&F implementation of SeparatorUI. This implementation is a "combined" view/controller.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSeparatorUI

        highlight, shadow

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JSeparator s)
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSeparatorUI

        getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalSeparatorUI

        public MetalSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        protected void installDefaults(JSeparator s)
        重载：
        installDefaults in class BasicSeparatorUI

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicSeparatorUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicSeparatorUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssw//.=..=f""=ffa; nnC&pa//p/


MetalSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalSliderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI

  • public class MetalSliderUI
extends BasicSliderUI
    A Java L&F implementation of SliderUI.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | MetalSliderUI.MetalPropertyListener

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicSliderUI

        BasicSliderUI.ActionScroller, BasicSliderUI.ChangeHandler, BasicSliderUI.ComponentHandler, BasicSliderUI.FocusHandler, BasicSliderUI.PropertyChangeHandler, BasicSliderUI.ScrollListener, BasicSliderUI.TrackListener

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Color | darkShadowColor
      protected boolean | filledSlider
      protected static Color | highlightColor
      protected static Icon horizThumbIcon
      A default horizontal thumb Icon.
      protected String | SLIDER_FILL
      protected static Color | thumbColor
      protected int | TICK_BUFFER
      protected static int | tickLength
      protected static int | trackWidth
      protected static Icon vertThumbIcon
      A default vertical thumb Icon.

      • Fields inherited from class javax.swing.plaf.basic.BasicSliderUI

        changeListener, componentListener, contentRect, focusInsets, focusListener, focusRect, insetCache, labelRect, leftToRightCache, MAX_SCROLL, MIN_SCROLL, NEGATIVE_SCROLL, POSITIVE_SCROLL, propertyChangeListener, scrollListener, scrollTimer, slider, thumbRect, tickRect, trackBuffer, trackListener, trackRect

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalSliderUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected PropertyChangeListener | createPropertyChangeListener(JSlider slider)
      static ComponentUI | createUI(JComponent c)
      protected int getThumbOverhang()
      Returns the amount that the thumb goes past the slide bar.
      protected Dimension | getThumbSize()
      int getTickLength()
      Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.
      protected int getTrackLength()
      Returns the longer dimension of the slide bar.
      protected int getTrackWidth()
      Returns the shorter dimension of the track.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void | paintFocus(Graphics g)
      protected void | paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
      protected void | paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
      protected void | paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
      protected void | paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
      void | paintThumb(Graphics g)
      void | paintTrack(Graphics g)
      protected void scrollDueToClickInTrack(int dir)
      This function is called when a mousePressed was detected in the track, not in the thumb.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSliderUI

        calculateContentRect, calculateFocusRect, calculateGeometry, calculateLabelRect, calculateThumbLocation, calculateThumbSize, calculateTickRect, calculateTrackBuffer, calculateTrackRect, createChangeListener, createComponentListener, createFocusListener, createScrollListener, createTrackListener, drawInverted, getBaseline, getBaselineResizeBehavior, getFocusColor, getHeightOfHighValueLabel, getHeightOfLowValueLabel, getHeightOfTallestLabel, getHighestValue, getHighestValueLabel, getHighlightColor, getLowestValue, getLowestValueLabel, getMaximumSize, getMinimumHorizontalSize, getMinimumSize, getMinimumVerticalSize, getPreferredHorizontalSize, getPreferredSize, getPreferredVerticalSize, getShadowColor, getWidthOfHighValueLabel, getWidthOfLowValueLabel, getWidthOfWidestLabel, installDefaults, installKeyboardActions, installListeners, isDragging, labelsHaveSameBaselines, paint, paintHorizontalLabel, paintLabels, paintTicks, paintVerticalLabel, recalculateIfInsetsChanged, recalculateIfOrientationChanged, scrollByBlock, scrollByUnit, setThumbLocation, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, valueForXPosition, valueForYPosition, xPositionForValue, yPositionForValue, yPositionForValue

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • TICK_BUFFER

        protected final int TICK_BUFFER
        另请参见：
        Constant Field Values

      • filledSlider

        protected boolean filledSlider

      • thumbColor

        protected static Color thumbColor

      • highlightColor

        protected static Color highlightColor

      • darkShadowColor

        protected static Color darkShadowColor

      • trackWidth

        protected static int trackWidth

      • tickLength

        protected static int tickLength

      • horizThumbIcon

        protected static Icon horizThumbIcon
        A default horizontal thumb Icon. This field might not be used. To change the Icon used by this delgate directly set it using the Slider.horizontalThumbIcon UIManager property.

      • vertThumbIcon

        protected static Icon vertThumbIcon
        A default vertical thumb Icon. This field might not be used. To change the Icon used by this delgate directly set it using the Slider.verticalThumbIcon UIManager property.

      • SLIDER_FILL

        protected final String SLIDER_FILL
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MetalSliderUI

        public MetalSliderUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicSliderUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • createPropertyChangeListener

        protected PropertyChangeListener createPropertyChangeListener(JSlider slider)
        重载：
        createPropertyChangeListener in class BasicSliderUI

      • paintThumb

        public void paintThumb(Graphics g)
        重载：
        paintThumb in class BasicSliderUI

      • paintTrack

        public void paintTrack(Graphics g)
        重载：
        paintTrack in class BasicSliderUI

      • paintFocus

        public void paintFocus(Graphics g)
        重载：
        paintFocus in class BasicSliderUI

      • getThumbSize

        protected Dimension getThumbSize()
        重载：
        getThumbSize in class BasicSliderUI

      • getTickLength

        public int getTickLength()
        Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders. BasicSliderUI uses the returned value to determine the tick area rectangle.
        重载：
        getTickLength in class BasicSliderUI

      • getTrackWidth

        protected int getTrackWidth()
        Returns the shorter dimension of the track.

      • getTrackLength

        protected int getTrackLength()
        Returns the longer dimension of the slide bar. (The slide bar is only the part that runs directly under the thumb)

      • getThumbOverhang

        protected int getThumbOverhang()
        Returns the amount that the thumb goes past the slide bar.

      • scrollDueToClickInTrack

        protected void scrollDueToClickInTrack(int dir)
        Description copied from class: BasicSliderUI
        This function is called when a mousePressed was detected in the track, not in the thumb. The default behavior is to scroll by block. You can override this method to stop it from scrolling or to add additional behavior.
        重载：
        scrollDueToClickInTrack in class BasicSliderUI

      • paintMinorTickForHorizSlider

        protected void paintMinorTickForHorizSlider(Graphics g,
                                Rectangle tickBounds,
                                int x)
        重载：
        paintMinorTickForHorizSlider in class BasicSliderUI

      • paintMajorTickForHorizSlider

        protected void paintMajorTickForHorizSlider(Graphics g,
                                Rectangle tickBounds,
                                int x)
        重载：
        paintMajorTickForHorizSlider in class BasicSliderUI

      • paintMinorTickForVertSlider

        protected void paintMinorTickForVertSlider(Graphics g,
                               Rectangle tickBounds,
                               int y)
        重载：
        paintMinorTickForVertSlider in class BasicSliderUI

      • paintMajorTickForVertSlider

        protected void paintMajorTickForVertSlider(Graphics g,
                               Rectangle tickBounds,
                               int y)
        重载：
        paintMajorTickForVertSlider in class BasicSliderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalSliderUI.MetalPropertyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalSliderUI.MetalPropertyListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    MetalSliderUI

    protected class MetalSliderUI.MetalPropertyListener
extends BasicSliderUI.PropertyChangeHandler

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalSliderUI.MetalPropertyListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalSliderUI.MetalPropertyListener

        protected MetalSliderUI.MetalPropertyListener()

    • 方法详细信息

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        重载：
        propertyChange in class BasicSliderUI.PropertyChangeHandler
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>hff.tehtedrreddiassiclihUUe#ifisalln/v//xat


MetalSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalSplitPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI

  • public class MetalSplitPaneUI
extends BasicSplitPaneUI
    Metal split pane.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicSplitPaneUI

        BasicSplitPaneUI.BasicHorizontalLayoutManager, BasicSplitPaneUI.BasicVerticalLayoutManager, BasicSplitPaneUI.FocusHandler, BasicSplitPaneUI.KeyboardDownRightHandler, BasicSplitPaneUI.KeyboardEndHandler, BasicSplitPaneUI.KeyboardHomeHandler, BasicSplitPaneUI.KeyboardResizeToggleHandler, BasicSplitPaneUI.KeyboardUpLeftHandler, BasicSplitPaneUI.PropertyHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSplitPaneUI

        beginDragDividerLocation, divider, dividerResizeToggleKey, dividerSize, downKey, draggingHW, endKey, focusListener, homeKey, KEYBOARD_DIVIDER_MOVE_OFFSET, keyboardDownRightListener, keyboardEndListener, keyboardHomeListener, keyboardResizeToggleListener, keyboardUpLeftListener, layoutManager, leftKey, NON_CONTINUOUS_DIVIDER, nonContinuousLayoutDivider, propertyChangeListener, rightKey, splitPane, upKey

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalSplitPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      BasicSplitPaneDivider createDefaultDivider()
      Creates the default divider.
      static ComponentUI createUI(JComponent x)
      Creates a new MetalSplitPaneUI instance

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSplitPaneUI

        createDefaultNonContinuousLayoutDivider, createFocusListener, createKeyboardDownRightListener, createKeyboardEndListener, createKeyboardHomeListener, createKeyboardResizeToggleListener, createKeyboardUpLeftListener, createPropertyChangeListener, dragDividerTo, finishDraggingTo, finishedPaintingChildren, getDivider, getDividerBorderSize, getDividerLocation, getInsets, getLastDragLocation, getMaximumDividerLocation, getMaximumSize, getMinimumDividerLocation, getMinimumSize, getNonContinuousLayoutDivider, getOrientation, getPreferredSize, getSplitPane, installDefaults, installKeyboardActions, installListeners, installUI, isContinuousLayout, paint, resetLayoutManager, resetToPreferredSizes, setContinuousLayout, setDividerLocation, setLastDragLocation, setNonContinuousLayoutDivider, setNonContinuousLayoutDivider, setOrientation, startDragging, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalSplitPaneUI

        public MetalSplitPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new MetalSplitPaneUI instance

      • createDefaultDivider

        public BasicSplitPaneDivider createDefaultDivider()
        Creates the default divider.
        重载：
        createDefaultDivider in class BasicSplitPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"eeU/Utwaiai sg.nn a gt.t


MetalTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalTabbedPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI
          • javax.swing.plaf.metal.MetalTabbedPaneUI
  • 所有已实现的接口：
    SwingConstants

    public class MetalTabbedPaneUI
extends BasicTabbedPaneUI
    The Metal subclass of BasicTabbedPaneUI.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  MetalTabbedPaneUI.TabbedPaneLayout
      This inner class is marked "public" due to a compiler bug.

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTabbedPaneUI

        BasicTabbedPaneUI.FocusHandler, BasicTabbedPaneUI.MouseHandler, BasicTabbedPaneUI.PropertyChangeHandler, BasicTabbedPaneUI.TabSelectionHandler

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected int | minTabWidth
      protected Color | selectColor
      protected Color | selectHighlight
      protected Color | tabAreaBackground

      • Fields inherited from class javax.swing.plaf.basic.BasicTabbedPaneUI

        calcRect, contentBorderInsets, darkShadow, downKey, focus, focusListener, highlight, leftKey, lightHighlight, maxTabHeight, maxTabWidth, mouseListener, propertyChangeListener, rects, rightKey, runCount, selectedRun, selectedTabPadInsets, shadow, tabAreaInsets, tabChangeListener, tabInsets, tabPane, tabRunOverlay, tabRuns, textIconGap, upKey

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalTabbedPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected int | calculateMaxTabHeight(int tabPlacement)
      protected LayoutManager createLayoutManager()
      Invoked by installUI to create a layout manager object to manage the JTabbedPane.
      static ComponentUI | createUI(JComponent x)
      protected int getBaselineOffset()
      Returns the amount the baseline is offset by.
      protected Color | getColorForGap(int currentRun, int x, int y)
      protected int getTabLabelShiftX(int tabPlacement, int tabIndex, boolean isSelected)
      Overridden to do nothing for the Java L&F.
      protected int getTabLabelShiftY(int tabPlacement, int tabIndex, boolean isSelected)
      Overridden to do nothing for the Java L&F.
      protected int | getTabRunOverlay(int tabPlacement)
      protected void | installDefaults()
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void | paintBottomTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      protected void | paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
      protected void | paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
      protected void | paintHighlightBelowTab()
      protected void | paintLeftTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      protected void | paintRightTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      protected void | paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      protected void paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
      this function draws the border around each tab note that this function does now draw the background of the tab.
      protected void | paintTopTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
      protected boolean | shouldFillGap(int currentRun, int tabIndex, int x, int y)
      protected boolean | shouldPadTabRun(int tabPlacement, int run)
      protected boolean | shouldRotateTabRuns(int tabPlacement, int selectedRun)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate that it is time to paint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTabbedPaneUI

        assureRectsCreated, calculateMaxTabWidth, calculateTabAreaHeight, calculateTabAreaWidth, calculateTabHeight, calculateTabWidth, createChangeListener, createFocusListener, createMouseListener, createPropertyChangeListener, createScrollButton, expandTabRunsArray, getBaseline, getBaseline, getBaselineResizeBehavior, getContentBorderInsets, getFocusIndex, getFontMetrics, getIconForTab, getMaximumSize, getMinimumSize, getNextTabIndex, getNextTabIndexInRun, getNextTabRun, getPreviousTabIndex, getPreviousTabIndexInRun, getPreviousTabRun, getRolloverTab, getRunForTab, getSelectedTabPadInsets, getTabAreaInsets, getTabBounds, getTabBounds, getTabInsets, getTabRunCount, getTabRunIndent, getTabRunOffset, getTextViewForTab, getVisibleComponent, installComponents, installKeyboardActions, installListeners, installUI, lastTabInRun, layoutLabel, navigateSelectedTab, paintContentBorder, paintIcon, paintTab, paintTabArea, paintText, rotateInsets, selectAdjacentRunTab, selectNextTab, selectNextTabInRun, selectPreviousTab, selectPreviousTabInRun, setRolloverTab, setVisibleComponent, shouldRotateTabRuns, tabForCoordinate, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • minTabWidth

        protected int minTabWidth

      • tabAreaBackground

        protected Color tabAreaBackground

      • selectColor

        protected Color selectColor

      • selectHighlight

        protected Color selectHighlight

    • 构造方法详细信息

      • MetalTabbedPaneUI

        public MetalTabbedPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Description copied from class: BasicTabbedPaneUI
        Invoked by installUI to create a layout manager object to manage the JTabbedPane.
        重载：
        createLayoutManager in class BasicTabbedPaneUI
        返回：
        a layout manager object
        另请参见：
        BasicTabbedPaneUI.TabbedPaneLayout, JTabbedPane.getTabLayoutPolicy()

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicTabbedPaneUI

      • paintTabBorder

        protected void paintTabBorder(Graphics g,
                  int tabPlacement,
                  int tabIndex,
                  int x,
                  int y,
                  int w,
                  int h,
                  boolean isSelected)
        Description copied from class: BasicTabbedPaneUI
        this function draws the border around each tab note that this function does now draw the background of the tab. that is done elsewhere
        重载：
        paintTabBorder in class BasicTabbedPaneUI

      • paintTopTabBorder

        protected void paintTopTabBorder(int tabIndex,
                     Graphics g,
                     int x,
                     int y,
                     int w,
                     int h,
                     int btm,
                     int rght,
                     boolean isSelected)

      • shouldFillGap

        protected boolean shouldFillGap(int currentRun,
                    int tabIndex,
                    int x,
                    int y)

      • getColorForGap

        protected Color getColorForGap(int currentRun,
                   int x,
                   int y)

      • paintLeftTabBorder

        protected void paintLeftTabBorder(int tabIndex,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h,
                      int btm,
                      int rght,
                      boolean isSelected)

      • paintBottomTabBorder

        protected void paintBottomTabBorder(int tabIndex,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h,
                        int btm,
                        int rght,
                        boolean isSelected)

      • paintRightTabBorder

        protected void paintRightTabBorder(int tabIndex,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h,
                       int btm,
                       int rght,
                       boolean isSelected)

      • update

        public void update(Graphics g,
          JComponent c)
        Description copied from class: ComponentUI
        Notifies this UI delegate that it is time to paint the specified component. This method is invoked by JComponent when the specified component is being painted.

        By default this method fills the specified component with its background color if its opaque property is true, and then immediately calls paint. In general this method need not be overridden by subclasses; all look-and-feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • paintTabBackground

        protected void paintTabBackground(Graphics g,
                      int tabPlacement,
                      int tabIndex,
                      int x,
                      int y,
                      int w,
                      int h,
                      boolean isSelected)
        重载：
        paintTabBackground in class BasicTabbedPaneUI

      • getTabLabelShiftX

        protected int getTabLabelShiftX(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)
        Overridden to do nothing for the Java L&F.
        重载：
        getTabLabelShiftX in class BasicTabbedPaneUI

      • getTabLabelShiftY

        protected int getTabLabelShiftY(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)
        Overridden to do nothing for the Java L&F.
        重载：
        getTabLabelShiftY in class BasicTabbedPaneUI

      • getBaselineOffset

        protected int getBaselineOffset()
        Returns the amount the baseline is offset by. This is typically the same as getTabLabelShiftY.
        重载：
        getBaselineOffset in class BasicTabbedPaneUI
        返回：
        amount to offset the baseline by
        从以下版本开始：
        1.6

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicTabbedPaneUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintHighlightBelowTab

        protected void paintHighlightBelowTab()

      • paintFocusIndicator

        protected void paintFocusIndicator(Graphics g,
                       int tabPlacement,
                       Rectangle[] rects,
                       int tabIndex,
                       Rectangle iconRect,
                       Rectangle textRect,
                       boolean isSelected)
        重载：
        paintFocusIndicator in class BasicTabbedPaneUI

      • paintContentBorderTopEdge

        protected void paintContentBorderTopEdge(Graphics g,
                             int tabPlacement,
                             int selectedIndex,
                             int x,
                             int y,
                             int w,
                             int h)
        重载：
        paintContentBorderTopEdge in class BasicTabbedPaneUI

      • paintContentBorderBottomEdge

        protected void paintContentBorderBottomEdge(Graphics g,
                                int tabPlacement,
                                int selectedIndex,
                                int x,
                                int y,
                                int w,
                                int h)
        重载：
        paintContentBorderBottomEdge in class BasicTabbedPaneUI

      • paintContentBorderLeftEdge

        protected void paintContentBorderLeftEdge(Graphics g,
                              int tabPlacement,
                              int selectedIndex,
                              int x,
                              int y,
                              int w,
                              int h)
        重载：
        paintContentBorderLeftEdge in class BasicTabbedPaneUI

      • paintContentBorderRightEdge

        protected void paintContentBorderRightEdge(Graphics g,
                               int tabPlacement,
                               int selectedIndex,
                               int x,
                               int y,
                               int w,
                               int h)
        重载：
        paintContentBorderRightEdge in class BasicTabbedPaneUI

      • calculateMaxTabHeight

        protected int calculateMaxTabHeight(int tabPlacement)
        重载：
        calculateMaxTabHeight in class BasicTabbedPaneUI

      • getTabRunOverlay

        protected int getTabRunOverlay(int tabPlacement)
        重载：
        getTabRunOverlay in class BasicTabbedPaneUI

      • shouldRotateTabRuns

        protected boolean shouldRotateTabRuns(int tabPlacement,
                          int selectedRun)

      • shouldPadTabRun

        protected boolean shouldPadTabRun(int tabPlacement,
                      int run)
        重载：
        shouldPadTabRun in class BasicTabbedPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalTabbedPaneUI.TabbedPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalTabbedPaneUI.TabbedPaneLayout

  • java.lang.Object
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
  • 所有已实现的接口：
    LayoutManager
    封闭类：
    MetalTabbedPaneUI

    public class MetalTabbedPaneUI.TabbedPaneLayout
extends BasicTabbedPaneUI.TabbedPaneLayout
    This inner class is marked "public" due to a compiler bug. This class should be treated as a "protected" inner class. Instantiate it only within subclasses of MetalTabbedPaneUI.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalTabbedPaneUI.TabbedPaneLayout()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | normalizeTabRuns(int tabPlacement, int tabCount, int start, int max)
      protected void | padSelectedTab(int tabPlacement, int selectedIndex)
      protected void | rotateTabRuns(int tabPlacement, int selectedRun)

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout

        addLayoutComponent, calculateLayoutInfo, calculateSize, calculateTabRects, layoutContainer, minimumLayoutSize, padTabRun, preferredLayoutSize, preferredTabAreaHeight, preferredTabAreaWidth, removeLayoutComponent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalTabbedPaneUI.TabbedPaneLayout

        public MetalTabbedPaneUI.TabbedPaneLayout()

    • 方法详细信息

      • normalizeTabRuns

        protected void normalizeTabRuns(int tabPlacement,
                    int tabCount,
                    int start,
                    int max)
        重载：
        normalizeTabRuns in class BasicTabbedPaneUI.TabbedPaneLayout

      • rotateTabRuns

        protected void rotateTabRuns(int tabPlacement,
                 int selectedRun)
        重载：
        rotateTabRuns in class BasicTabbedPaneUI.TabbedPaneLayout

      • padSelectedTab

        protected void padSelectedTab(int tabPlacement,
                  int selectedIndex)
        重载：
        padSelectedTab in class BasicTabbedPaneUI.TabbedPaneLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mpm"ma"ma"0 "00icppa haMhhoywySr ee< 穊


MetalTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalTextFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
  • 所有已实现的接口：
    ViewFactory

    public class MetalTextFieldUI
extends BasicTextFieldUI
    Basis of a look and feel for a JTextField.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalTextFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        create, getBaseline, getBaselineResizeBehavior, getPropertyPrefix

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalTextFieldUI

        public MetalTextFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses.
        重载：
        propertyChange in class BasicTextUI
        参数：
        evt - the property change event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h/------!laTEODA=TE b/


MetalTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalTheme

  • java.lang.Object
    • javax.swing.plaf.metal.MetalTheme
  • 直接已知子类：
    DefaultMetalTheme

    public abstract class MetalTheme
extends Object
    MetalTheme provides the color palette and fonts used by the Java Look and Feel.

    MetalTheme is abstract, see DefaultMetalTheme and OceanTheme for concrete implementations.

    MetalLookAndFeel maintains the current theme that the the ComponentUI implementations for metal use. Refer to MetalLookAndFeel.setCurrentTheme(MetalTheme) for details on changing the current theme.

    MetalTheme provides a number of public methods for getting colors. These methods are implemented in terms of a handful of protected abstract methods. A subclass need only override the protected abstract methods (getPrimary1, getPrimary2, getPrimary3, getSecondary1, getSecondary2, and getSecondary3); although a subclass may override the other public methods for more control over the set of colors that are used.

    Concrete implementations of MetalTheme must return non-null values from all methods. While the behavior of returning null is not specified, returning null will result in incorrect behavior.

    It is strongly recommended that subclasses return completely opaque colors. To do otherwise may result in rendering problems, such as visual garbage.

    另请参见：
    DefaultMetalTheme, OceanTheme, MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalTheme()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addCustomEntriesToTable(UIDefaults table)
      Adds values specific to this theme to the defaults table.
      ColorUIResource getAcceleratorForeground()
      Returns the accelerator foreground color.
      ColorUIResource getAcceleratorSelectedForeground()
      Returns the accelerator selected foreground color.
      protected ColorUIResource getBlack()
      Returns the black color.
      ColorUIResource getControl()
      Returns the control color.
      ColorUIResource getControlDarkShadow()
      Returns the control dark shadow color.
      ColorUIResource getControlDisabled()
      Returns the control disabled color.
      ColorUIResource getControlHighlight()
      Returns the control highlight color.
      ColorUIResource getControlInfo()
      Returns the control info color.
      ColorUIResource getControlShadow()
      Returns the control shadow color.
      ColorUIResource getControlTextColor()
      Returns the control text color.
      abstract FontUIResource getControlTextFont()
      Returns the control text font.
      ColorUIResource getDesktopColor()
      Returns the desktop color.
      ColorUIResource getFocusColor()
      Returns the focus color.
      ColorUIResource getHighlightedTextColor()
      Returns the highlighted text color.
      ColorUIResource getInactiveControlTextColor()
      Returns the inactive control text color.
      ColorUIResource getInactiveSystemTextColor()
      Returns the inactive system text color.
      ColorUIResource getMenuBackground()
      Returns the menu background color.
      ColorUIResource getMenuDisabledForeground()
      Returns the menu disabled foreground color.
      ColorUIResource getMenuForeground()
      Returns the menu foreground color.
      ColorUIResource getMenuSelectedBackground()
      Returns the menu selected background color.
      ColorUIResource getMenuSelectedForeground()
      Returns the menu selected foreground color.
      abstract FontUIResource getMenuTextFont()
      Returns the menu text font.
      abstract String getName()
      Returns the name of this theme.
      protected abstract ColorUIResource getPrimary1()
      Returns the primary 1 color.
      protected abstract ColorUIResource getPrimary2()
      Returns the primary 2 color.
      protected abstract ColorUIResource getPrimary3()
      Returns the primary 3 color.
      ColorUIResource getPrimaryControl()
      Returns the primary control color.
      ColorUIResource getPrimaryControlDarkShadow()
      Returns the primary control dark shadow color.
      ColorUIResource getPrimaryControlHighlight()
      Returns the primary control highlight color.
      ColorUIResource getPrimaryControlInfo()
      Returns the primary control info color.
      ColorUIResource getPrimaryControlShadow()
      Returns the primary control shadow color.
      protected abstract ColorUIResource getSecondary1()
      Returns the secondary 1 color.
      protected abstract ColorUIResource getSecondary2()
      Returns the secondary 2 color.
      protected abstract ColorUIResource getSecondary3()
      Returns the secondary 3 color.
      ColorUIResource getSeparatorBackground()
      Returns the separator background color.
      ColorUIResource getSeparatorForeground()
      Returns the separator foreground color.
      abstract FontUIResource getSubTextFont()
      Returns the sub-text font.
      ColorUIResource getSystemTextColor()
      Returns the system text color.
      abstract FontUIResource getSystemTextFont()
      Returns the system text font.
      ColorUIResource getTextHighlightColor()
      Returns the text highlight color.
      ColorUIResource getUserTextColor()
      Returns the user text color.
      abstract FontUIResource getUserTextFont()
      Returns the user text font.
      protected ColorUIResource getWhite()
      Returns the white color.
      ColorUIResource getWindowBackground()
      Returns the window background color.
      ColorUIResource getWindowTitleBackground()
      Returns the window title background color.
      abstract FontUIResource getWindowTitleFont()
      Returns the window title font.
      ColorUIResource getWindowTitleForeground()
      Returns the window title foreground color.
      ColorUIResource getWindowTitleInactiveBackground()
      Returns the window title inactive background color.
      ColorUIResource getWindowTitleInactiveForeground()
      Returns the window title inactive foreground color.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalTheme

        public MetalTheme()

    • 方法详细信息

      • getName

        public abstract String getName()
        Returns the name of this theme.
        返回：
        the name of this theme

      • getPrimary1

        protected abstract ColorUIResource getPrimary1()
        Returns the primary 1 color.
        返回：
        the primary 1 color

      • getPrimary2

        protected abstract ColorUIResource getPrimary2()
        Returns the primary 2 color.
        返回：
        the primary 2 color

      • getPrimary3

        protected abstract ColorUIResource getPrimary3()
        Returns the primary 3 color.
        返回：
        the primary 3 color

      • getSecondary1

        protected abstract ColorUIResource getSecondary1()
        Returns the secondary 1 color.
        返回：
        the secondary 1 color

      • getSecondary2

        protected abstract ColorUIResource getSecondary2()
        Returns the secondary 2 color.
        返回：
        the secondary 2 color

      • getSecondary3

        protected abstract ColorUIResource getSecondary3()
        Returns the secondary 3 color.
        返回：
        the secondary 3 color

      • getControlTextFont

        public abstract FontUIResource getControlTextFont()
        Returns the control text font.
        返回：
        the control text font

      • getSystemTextFont

        public abstract FontUIResource getSystemTextFont()
        Returns the system text font.
        返回：
        the system text font

      • getUserTextFont

        public abstract FontUIResource getUserTextFont()
        Returns the user text font.
        返回：
        the user text font

      • getMenuTextFont

        public abstract FontUIResource getMenuTextFont()
        Returns the menu text font.
        返回：
        the menu text font

      • getWindowTitleFont

        public abstract FontUIResource getWindowTitleFont()
        Returns the window title font.
        返回：
        the window title font

      • getSubTextFont

        public abstract FontUIResource getSubTextFont()
        Returns the sub-text font.
        返回：
        the sub-text font

      • getWhite

        protected ColorUIResource getWhite()
        Returns the white color. This returns opaque white (0xFFFFFFFF).
        返回：
        the white color

      • getBlack

        protected ColorUIResource getBlack()
        Returns the black color. This returns opaque black (0xFF000000).
        返回：
        the black color

      • getFocusColor

        public ColorUIResource getFocusColor()
        Returns the focus color. This returns the value of getPrimary2().
        返回：
        the focus color

      • getDesktopColor

        public ColorUIResource getDesktopColor()
        Returns the desktop color. This returns the value of getPrimary2().
        返回：
        the desktop color

      • getControl

        public ColorUIResource getControl()
        Returns the control color. This returns the value of getSecondary3().
        返回：
        the control color

      • getControlShadow

        public ColorUIResource getControlShadow()
        Returns the control shadow color. This returns the value of getSecondary2().
        返回：
        the control shadow color

      • getControlDarkShadow

        public ColorUIResource getControlDarkShadow()
        Returns the control dark shadow color. This returns the value of getSecondary1().
        返回：
        the control dark shadow color

      • getControlInfo

        public ColorUIResource getControlInfo()
        Returns the control info color. This returns the value of getBlack().
        返回：
        the control info color

      • getControlHighlight

        public ColorUIResource getControlHighlight()
        Returns the control highlight color. This returns the value of getWhite().
        返回：
        the control highlight color

      • getControlDisabled

        public ColorUIResource getControlDisabled()
        Returns the control disabled color. This returns the value of getSecondary2().
        返回：
        the control disabled color

      • getPrimaryControl

        public ColorUIResource getPrimaryControl()
        Returns the primary control color. This returns the value of getPrimary3().
        返回：
        the primary control color

      • getPrimaryControlShadow

        public ColorUIResource getPrimaryControlShadow()
        Returns the primary control shadow color. This returns the value of getPrimary2().
        返回：
        the primary control shadow color

      • getPrimaryControlDarkShadow

        public ColorUIResource getPrimaryControlDarkShadow()
        Returns the primary control dark shadow color. This returns the value of getPrimary1().
        返回：
        the primary control dark shadow color

      • getPrimaryControlInfo

        public ColorUIResource getPrimaryControlInfo()
        Returns the primary control info color. This returns the value of getBlack().
        返回：
        the primary control info color

      • getPrimaryControlHighlight

        public ColorUIResource getPrimaryControlHighlight()
        Returns the primary control highlight color. This returns the value of getWhite().
        返回：
        the primary control highlight color

      • getSystemTextColor

        public ColorUIResource getSystemTextColor()
        Returns the system text color. This returns the value of getBlack().
        返回：
        the system text color

      • getControlTextColor

        public ColorUIResource getControlTextColor()
        Returns the control text color. This returns the value of getControlInfo().
        返回：
        the control text color

      • getInactiveControlTextColor

        public ColorUIResource getInactiveControlTextColor()
        Returns the inactive control text color. This returns the value of getControlDisabled().
        返回：
        the inactive control text color

      • getInactiveSystemTextColor

        public ColorUIResource getInactiveSystemTextColor()
        Returns the inactive system text color. This returns the value of getSecondary2().
        返回：
        the inactive system text color

      • getUserTextColor

        public ColorUIResource getUserTextColor()
        Returns the user text color. This returns the value of getBlack().
        返回：
        the user text color

      • getTextHighlightColor

        public ColorUIResource getTextHighlightColor()
        Returns the text highlight color. This returns the value of getPrimary3().
        返回：
        the text highlight color

      • getHighlightedTextColor

        public ColorUIResource getHighlightedTextColor()
        Returns the highlighted text color. This returns the value of getControlTextColor().
        返回：
        the highlighted text color

      • getWindowBackground

        public ColorUIResource getWindowBackground()
        Returns the window background color. This returns the value of getWhite().
        返回：
        the window background color

      • getWindowTitleBackground

        public ColorUIResource getWindowTitleBackground()
        Returns the window title background color. This returns the value of getPrimary3().
        返回：
        the window title background color

      • getWindowTitleForeground

        public ColorUIResource getWindowTitleForeground()
        Returns the window title foreground color. This returns the value of getBlack().
        返回：
        the window title foreground color

      • getWindowTitleInactiveBackground

        public ColorUIResource getWindowTitleInactiveBackground()
        Returns the window title inactive background color. This returns the value of getSecondary3().
        返回：
        the window title inactive background color

      • getWindowTitleInactiveForeground

        public ColorUIResource getWindowTitleInactiveForeground()
        Returns the window title inactive foreground color. This returns the value of getBlack().
        返回：
        the window title inactive foreground color

      • getMenuBackground

        public ColorUIResource getMenuBackground()
        Returns the menu background color. This returns the value of getSecondary3().
        返回：
        the menu background color

      • getMenuForeground

        public ColorUIResource getMenuForeground()
        Returns the menu foreground color. This returns the value of getBlack().
        返回：
        the menu foreground color

      • getMenuSelectedBackground

        public ColorUIResource getMenuSelectedBackground()
        Returns the menu selected background color. This returns the value of getPrimary2().
        返回：
        the menu selected background color

      • getMenuSelectedForeground

        public ColorUIResource getMenuSelectedForeground()
        Returns the menu selected foreground color. This returns the value of getBlack().
        返回：
        the menu selected foreground color

      • getMenuDisabledForeground

        public ColorUIResource getMenuDisabledForeground()
        Returns the menu disabled foreground color. This returns the value of getSecondary2().
        返回：
        the menu disabled foreground color

      • getSeparatorBackground

        public ColorUIResource getSeparatorBackground()
        Returns the separator background color. This returns the value of getWhite().
        返回：
        the separator background color

      • getSeparatorForeground

        public ColorUIResource getSeparatorForeground()
        Returns the separator foreground color. This returns the value of getPrimary1().
        返回：
        the separator foreground color

      • getAcceleratorForeground

        public ColorUIResource getAcceleratorForeground()
        Returns the accelerator foreground color. This returns the value of getPrimary1().
        返回：
        the accelerator foreground color

      • getAcceleratorSelectedForeground

        public ColorUIResource getAcceleratorSelectedForeground()
        Returns the accelerator selected foreground color. This returns the value of getBlack().
        返回：
        the accelerator selected foreground color

      • addCustomEntriesToTable

        public void addCustomEntriesToTable(UIDefaults table)
        Adds values specific to this theme to the defaults table. This method is invoked when the look and feel defaults are obtained from MetalLookAndFeel.

        This implementation does nothing; it is provided for subclasses that wish to customize the defaults table.

        参数：
        table - the UIDefaults to add the values to
        另请参见：
        MetalLookAndFeel.getDefaults()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MetalToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalToggleButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.metal.MetalToggleButtonUI

  • public class MetalToggleButtonUI
extends BasicToggleButtonUI
    MetalToggleButton implementation

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Color | disabledTextColor
      protected Color | focusColor
      protected Color | selectColor

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalToggleButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent b)
      protected Color | getDisabledTextColor()
      protected Color | getFocusColor()
      protected Color | getSelectColor()
      void | installDefaults(AbstractButton b)
      protected void | paintButtonPressed(Graphics g, AbstractButton b)
      protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
      protected void paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
      Paints the appropriate icon of the button b in the space iconRect.
      protected void paintText(Graphics g, JComponent c, Rectangle textRect, String text)
      As of Java 2 platform v 1.4 this method should not be used or overriden.
      protected void | uninstallDefaults(AbstractButton b)
      void update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToggleButtonUI

        getPropertyPrefix, getTextShiftOffset, paint

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, installKeyboardActions, installListeners, installUI, paintIcon, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • focusColor

        protected Color focusColor

      • selectColor

        protected Color selectColor

      • disabledTextColor

        protected Color disabledTextColor

    • 构造方法详细信息

      • MetalToggleButtonUI

        public MetalToggleButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)

      • installDefaults

        public void installDefaults(AbstractButton b)
        重载：
        installDefaults in class BasicButtonUI

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class BasicButtonUI

      • getSelectColor

        protected Color getSelectColor()

      • getDisabledTextColor

        protected Color getDisabledTextColor()

      • getFocusColor

        protected Color getFocusColor()

      • update

        public void update(Graphics g,
          JComponent c)
        If necessary paints the background of the component, then invokes paint.
        重载：
        update in class ComponentUI
        参数：
        g - Graphics to paint to
        c - JComponent painting on
        抛出：
        NullPointerException - if g or c is null
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)

      • paintButtonPressed

        protected void paintButtonPressed(Graphics g,
                      AbstractButton b)
        重载：
        paintButtonPressed in class BasicButtonUI

      • paintText

        protected void paintText(Graphics g,
             JComponent c,
             Rectangle textRect,
             String text)
        Description copied from class: BasicButtonUI
        As of Java 2 platform v 1.4 this method should not be used or overriden. Use the paintText method which takes the AbstractButton argument.
        重载：
        paintText in class BasicButtonUI

      • paintFocus

        protected void paintFocus(Graphics g,
              AbstractButton b,
              Rectangle viewRect,
              Rectangle textRect,
              Rectangle iconRect)
        重载：
        paintFocus in class BasicButtonUI

      • paintIcon

        protected void paintIcon(Graphics g,
             AbstractButton b,
             Rectangle iconRect)
        Paints the appropriate icon of the button b in the space iconRect.
        重载：
        paintIcon in class BasicToggleButtonUI
        参数：
        g - Graphics to paint to
        b - Button to render for
        iconRect - space to render in
        抛出：
        NullPointerException - if any of the arguments are null.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>fxnjs jsasssaaemII<4ae1>>eced>ptre>ppp


MetalToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalToolBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI
          • javax.swing.plaf.metal.MetalToolBarUI
  • 所有已实现的接口：
    SwingConstants

    public class MetalToolBarUI
extends BasicToolBarUI
    A Metal Look and Feel implementation of ToolBarUI. This implementation is a "combined" view/controller.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected class  | MetalToolBarUI.MetalContainerListener
      protected class  | MetalToolBarUI.MetalDockingListener
      protected class  | MetalToolBarUI.MetalRolloverListener

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicToolBarUI

        BasicToolBarUI.DockingListener, BasicToolBarUI.DragWindow, BasicToolBarUI.FrameListener, BasicToolBarUI.PropertyListener, BasicToolBarUI.ToolBarContListener, BasicToolBarUI.ToolBarFocusListener

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ContainerListener contListener
      This protected field is implemenation specific.
      protected PropertyChangeListener rolloverListener
      This protected field is implemenation specific.

      • Fields inherited from class javax.swing.plaf.basic.BasicToolBarUI

        constraintBeforeFloating, dockingBorderColor, dockingColor, dockingListener, downKey, dragWindow, floatingBorderColor, floatingColor, focusedCompIndex, leftKey, propertyListener, rightKey, toolBar, toolBarContListener, toolBarFocusListener, upKey

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalToolBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected ContainerListener createContainerListener()
      Creates a container listener that will be added to the JToolBar.
      protected MouseInputListener | createDockingListener()
      protected Border createNonRolloverBorder()
      Creates the non rollover border for toolbar components.
      protected Border createRolloverBorder()
      Creates a rollover border for toolbar components.
      protected PropertyChangeListener createRolloverListener()
      Creates a property change listener that will be added to the JToolBar.
      static ComponentUI | createUI(JComponent c)
      protected void | installListeners()
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected void setBorderToNonRollover(Component c)
      Sets the border of the component to have a non-rollover border which was created by the BasicToolBarUI.createNonRolloverBorder() method.
      protected void | setDragOffset(Point p)
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      If necessary paints the background of the component, then invokes paint.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolBarUI

        canDock, createDragWindow, createFloatingFrame, createFloatingWindow, createFrameListener, createPropertyListener, createToolBarContListener, createToolBarFocusListener, dragTo, floatAt, getDockingColor, getFloatingColor, getNonRolloverBorder, getRolloverBorder, installComponents, installDefaults, installKeyboardActions, installNonRolloverBorders, installNormalBorders, installRolloverBorders, isFloating, isRolloverBorders, navigateFocusedComp, paintDragWindow, setBorderToNormal, setBorderToRollover, setDockingColor, setFloating, setFloatingColor, setFloatingLocation, setOrientation, setRolloverBorders, uninstallComponents, uninstallDefaults, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • contListener

        protected ContainerListener contListener
        This protected field is implemenation specific. Do not access directly or override. Use the create method instead.
        另请参见：
        createContainerListener()

      • rolloverListener

        protected PropertyChangeListener rolloverListener
        This protected field is implemenation specific. Do not access directly or override. Use the create method instead.
        另请参见：
        createRolloverListener()

    • 构造方法详细信息

      • MetalToolBarUI

        public MetalToolBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicToolBarUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicToolBarUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicToolBarUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicToolBarUI

      • createRolloverBorder

        protected Border createRolloverBorder()
        Description copied from class: BasicToolBarUI
        Creates a rollover border for toolbar components. The rollover border will be installed if rollover borders are enabled.

        Override this method to provide an alternate rollover border.

        重载：
        createRolloverBorder in class BasicToolBarUI

      • createNonRolloverBorder

        protected Border createNonRolloverBorder()
        Description copied from class: BasicToolBarUI
        Creates the non rollover border for toolbar components. This border will be installed as the border for components added to the toolbar if rollover borders are not enabled.

        Override this method to provide an alternate rollover border.

        重载：
        createNonRolloverBorder in class BasicToolBarUI

      • setBorderToNonRollover

        protected void setBorderToNonRollover(Component c)
        Description copied from class: BasicToolBarUI
        Sets the border of the component to have a non-rollover border which was created by the BasicToolBarUI.createNonRolloverBorder() method.
        重载：
        setBorderToNonRollover in class BasicToolBarUI
        参数：
        c - component which will have a non-rollover border installed
        另请参见：
        BasicToolBarUI.createNonRolloverBorder()

      • createContainerListener

        protected ContainerListener createContainerListener()
        Creates a container listener that will be added to the JToolBar. If this method returns null then it will not be added to the toolbar.
        返回：
        an instance of a ContainerListener or null

      • createRolloverListener

        protected PropertyChangeListener createRolloverListener()
        Creates a property change listener that will be added to the JToolBar. If this method returns null then it will not be added to the toolbar.
        返回：
        an instance of a PropertyChangeListener or null

      • createDockingListener

        protected MouseInputListener createDockingListener()
        重载：
        createDockingListener in class BasicToolBarUI

      • setDragOffset

        protected void setDragOffset(Point p)

      • update

        public void update(Graphics g,
          JComponent c)
        If necessary paints the background of the component, then invokes paint.
        重载：
        update in class ComponentUI
        参数：
        g - Graphics to paint to
        c - JComponent painting on
        抛出：
        NullPointerException - if g or c is null
        从以下版本开始：
        1.5
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dp"


MetalToolBarUI.MetalContainerListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalToolBarUI.MetalContainerListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
  • 所有已实现的接口：
    ContainerListener, EventListener
    封闭类：
    MetalToolBarUI

    protected class MetalToolBarUI.MetalContainerListener
extends BasicToolBarUI.ToolBarContListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalToolBarUI.MetalContainerListener()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener

        componentAdded, componentRemoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalToolBarUI.MetalContainerListener

        protected MetalToolBarUI.MetalContainerListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oalUolsolsaiisaas///a/aas//otloaBasp<


MetalToolBarUI.MetalDockingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalToolBarUI.MetalDockingListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, EventListener, MouseInputListener
    封闭类：
    MetalToolBarUI

    protected class MetalToolBarUI.MetalDockingListener
extends BasicToolBarUI.DockingListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicToolBarUI.DockingListener

        isDragging, origin, toolBar

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalToolBarUI.MetalDockingListener(JToolBar t)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mousePressed(MouseEvent e)
      Invoked when a mouse button has been pressed on a component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener

        mouseClicked, mouseEntered, mouseExited, mouseMoved, mouseReleased

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalToolBarUI.MetalDockingListener

        public MetalToolBarUI.MetalDockingListener(JToolBar t)

    • 方法详细信息

      • mousePressed

        public void mousePressed(MouseEvent e)
        从接口复制的描述： MouseListener
        Invoked when a mouse button has been pressed on a component.
        指定者：
        mousePressed in interface MouseListener
        重载：
        mousePressed in class BasicToolBarUI.DockingListener

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        从接口复制的描述： MouseMotionListener
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class BasicToolBarUI.DockingListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ul><<>nadoinl<.a.apd


MetalToolBarUI.MetalRolloverListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.metal

类 MetalToolBarUI.MetalRolloverListener

  • java.lang.Object
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
  • 所有已实现的接口：
    PropertyChangeListener, EventListener
    封闭类：
    MetalToolBarUI

    protected class MetalToolBarUI.MetalRolloverListener
extends BasicToolBarUI.PropertyListener

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | MetalToolBarUI.MetalRolloverListener()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener

        propertyChange

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalToolBarUI.MetalRolloverListener

        protected MetalToolBarUI.MetalRolloverListener()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nr&nra<


MetalToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalToolTipUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI

  • public class MetalToolTipUI
extends BasicToolTipUI
    A Metal L&F extension of BasicToolTipUI.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | padSpaceBetweenStrings

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalToolTipUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent c)
      String getAcceleratorString()
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected boolean | isAcceleratorHidden()
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolTipUI

        getMaximumSize, getMinimumSize, installDefaults, installListeners, uninstallDefaults, uninstallListeners

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • padSpaceBetweenStrings

        public static final int padSpaceBetweenStrings
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • MetalToolTipUI

        public MetalToolTipUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicToolTipUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicToolTipUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicToolTipUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicToolTipUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • isAcceleratorHidden

        protected boolean isAcceleratorHidden()

      • getAcceleratorString

        public String getAcceleratorString()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fh=<; refta�>>/..Dee=h"mi╥ie@Bi


MetalTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 MetalTreeUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI

  • public class MetalTreeUI
extends BasicTreeUI
    The metal look and feel implementation of TreeUI.

    MetalTreeUI allows for configuring how to visually render the spacing and delineation between nodes. The following hints are supported:

    Angled

             A line is drawn connecting the child to the parent. For handling of the root node refer to JTree.setRootVisible(boolean) and JTree.setShowsRootHandles(boolean).

    Horizontal

             A horizontal line is drawn dividing the children of the root node.

    None

             Do not draw any visual indication between nodes.

    As it is typically impratical to obtain the TreeUI from the JTree and cast to an instance of MetalTreeUI you enable this property via the client property JTree.lineStyle. For example, to switch to Horizontal style you would do: tree.putClientProperty("JTree.lineStyle", "Horizontal");

    The default is Angled.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTreeUI

        BasicTreeUI.CellEditorHandler, BasicTreeUI.ComponentHandler, BasicTreeUI.FocusHandler, BasicTreeUI.KeyHandler, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, BasicTreeUI.NodeDimensionsHandler, BasicTreeUI.PropertyChangeHandler, BasicTreeUI.SelectionModelPropertyChangeHandler, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeExpansionHandler, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreeModelHandler, BasicTreeUI.TreePageAction, BasicTreeUI.TreeSelectionHandler, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicTreeUI

        cellEditor, collapsedIcon, createdCellEditor, createdRenderer, currentCellRenderer, depthOffset, drawingCache, editingComponent, editingPath, editingRow, editorHasDifferentSize, expandedIcon, largeModel, lastSelectedRow, leftChildIndent, nodeDimensions, preferredMinSize, preferredSize, rendererPane, rightChildIndent, stopEditingInCompleteEditing, totalChildIndent, tree, treeModel, treeSelectionModel, treeState, validCachedPreferredSize

    • 构造方法摘要

      Constructors
      构造方法与描述
      MetalTreeUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI | createUI(JComponent x)
      protected void decodeLineStyle(Object lineStyleFlag)
      this function converts between the string passed into the client property and the internal representation (currently and int)
      protected int getHorizontalLegBuffer()
      The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      protected boolean | isLocationInExpandControl(int row, int rowLevel, int mouseX, int mouseY)
      void paint(Graphics g, JComponent c)
      Paints the specified component appropriately for the look and feel.
      protected void paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void | paintHorizontalSeparators(Graphics g, JComponent c)
      protected void paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTreeUI

        cancelEditing, checkForClickInExpandControl, completeEditing, completeEditing, completeUIInstall, completeUIUninstall, configureLayoutCache, createCellEditorListener, createCellRendererPane, createComponentListener, createDefaultCellEditor, createDefaultCellRenderer, createFocusListener, createKeyListener, createLayoutCache, createMouseListener, createNodeDimensions, createPropertyChangeListener, createSelectionModelPropertyChangeListener, createTreeExpansionListener, createTreeModelListener, createTreeSelectionListener, drawCentered, drawDashedHorizontalLine, drawDashedVerticalLine, ensureRowsAreVisible, getBaseline, getBaselineResizeBehavior, getCellEditor, getCellRenderer, getClosestPathForLocation, getCollapsedIcon, getDropLineRect, getEditingPath, getExpandedIcon, getHashColor, getLastChildPath, getLeadSelectionRow, getLeftChildIndent, getMaximumSize, getMinimumSize, getModel, getPathBounds, getPathForRow, getPreferredMinSize, getPreferredSize, getPreferredSize, getRightChildIndent, getRowCount, getRowForPath, getRowHeight, getRowX, getSelectionModel, getShowsRootHandles, getVerticalLegBuffer, handleExpandControlClick, installComponents, installDefaults, installKeyboardActions, installListeners, isDropLine, isEditable, isEditing, isLargeModel, isLeaf, isLocationInExpandControl, isMultiSelectEvent, isRootVisible, isToggleEvent, isToggleSelectionEvent, paintDropLine, paintExpandControl, paintHorizontalLine, paintRow, paintVerticalLine, pathWasCollapsed, pathWasExpanded, prepareForUIInstall, prepareForUIUninstall, selectPathForEvent, setCellEditor, setCellRenderer, setCollapsedIcon, setEditable, setExpandedIcon, setHashColor, setLargeModel, setLeftChildIndent, setModel, setPreferredMinSize, setRightChildIndent, setRootVisible, setRowHeight, setSelectionModel, setShowsRootHandles, shouldPaintExpandControl, startEditing, startEditingAtPath, stopEditing, toggleExpandState, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, updateCachedPreferredSize, updateCellEditor, updateDepthOffset, updateExpandedDescendants, updateLayoutCacheExpandedNodes, updateLeadSelectionRow, updateRenderer, updateSize

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, update

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MetalTreeUI

        public MetalTreeUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)

      • getHorizontalLegBuffer

        protected int getHorizontalLegBuffer()
        Description copied from class: BasicTreeUI
        The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default. This method makes the leg end before that.
        重载：
        getHorizontalLegBuffer in class BasicTreeUI

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicTreeUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicTreeUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • decodeLineStyle

        protected void decodeLineStyle(Object lineStyleFlag)
        this function converts between the string passed into the client property and the internal representation (currently and int)

      • isLocationInExpandControl

        protected boolean isLocationInExpandControl(int row,
                                int rowLevel,
                                int mouseX,
                                int mouseY)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Description copied from class: ComponentUI
        Paints the specified component appropriately for the look and feel. This method is invoked from the ComponentUI.update method when the specified component is being painted. Subclasses should override this method and use the specified Graphics object to render the content of the component.
        重载：
        paint in class BasicTreeUI
        参数：
        g - the Graphics context in which to paint
        c - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • paintHorizontalSeparators

        protected void paintHorizontalSeparators(Graphics g,
                             JComponent c)

      • paintVerticalPartOfLeg

        protected void paintVerticalPartOfLeg(Graphics g,
                          Rectangle clipBounds,
                          Insets insets,
                          TreePath path)
        Description copied from class: BasicTreeUI
        Paints the vertical part of the leg. The receiver should NOT modify clipBounds, insets.

        重载：
        paintVerticalPartOfLeg in class BasicTreeUI

      • paintHorizontalPartOfLeg

        protected void paintHorizontalPartOfLeg(Graphics g,
                            Rectangle clipBounds,
                            Insets insets,
                            Rectangle bounds,
                            TreePath path,
                            int row,
                            boolean isExpanded,
                            boolean hasBeenExpanded,
                            boolean isLeaf)
        Description copied from class: BasicTreeUI
        Paints the horizontal part of the leg. The receiver should NOT modify clipBounds, or insets.

        NOTE: parentRow can be -1 if the root is not visible.

        重载：
        paintHorizontalPartOfLeg in class BasicTreeUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


OceanTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.metal

类 OceanTheme

  • java.lang.Object
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme

  • public class OceanTheme
extends DefaultMetalTheme
    The default theme for the MetalLookAndFeel.

    The designers of the Metal Look and Feel strive to keep the default look up to date, possibly through the use of new themes in the future. Therefore, developers should only use this class directly when they wish to customize the "Ocean" look, or force it to be the current theme, regardless of future updates.

    All colors returned by OceanTheme are completely opaque.

    从以下版本开始：
    1.5
    另请参见：
    MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

    • 构造方法摘要

      Constructors
      构造方法与描述
      OceanTheme()
      Creates an instance of OceanTheme

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addCustomEntriesToTable(UIDefaults table)
      Add this theme's custom entries to the defaults table.
      protected ColorUIResource getBlack()
      Returns the black color.
      ColorUIResource getControlTextColor()
      Returns the control text color.
      ColorUIResource getDesktopColor()
      Returns the desktop color.
      ColorUIResource getInactiveControlTextColor()
      Returns the inactive control text color.
      ColorUIResource getMenuDisabledForeground()
      Returns the menu disabled foreground color.
      String getName()
      Return the name of this theme, "Ocean".
      protected ColorUIResource getPrimary1()
      Returns the primary 1 color.
      protected ColorUIResource getPrimary2()
      Returns the primary 2 color.
      protected ColorUIResource getPrimary3()
      Returns the primary 3 color.
      protected ColorUIResource getSecondary1()
      Returns the secondary 1 color.
      protected ColorUIResource getSecondary2()
      Returns the secondary 2 color.
      protected ColorUIResource getSecondary3()
      Returns the secondary 3 color.

      • 方法 - 继承于类 javax.swing.plaf.metal.DefaultMetalTheme

        getControlTextFont, getMenuTextFont, getSubTextFont, getSystemTextFont, getUserTextFont, getWindowTitleFont

      • 方法 - 继承于类 javax.swing.plaf.metal.MetalTheme

        getAcceleratorForeground, getAcceleratorSelectedForeground, getControl, getControlDarkShadow, getControlDisabled, getControlHighlight, getControlInfo, getControlShadow, getFocusColor, getHighlightedTextColor, getInactiveSystemTextColor, getMenuBackground, getMenuForeground, getMenuSelectedBackground, getMenuSelectedForeground, getPrimaryControl, getPrimaryControlDarkShadow, getPrimaryControlHighlight, getPrimaryControlInfo, getPrimaryControlShadow, getSeparatorBackground, getSeparatorForeground, getSystemTextColor, getTextHighlightColor, getUserTextColor, getWhite, getWindowBackground, getWindowTitleBackground, getWindowTitleForeground, getWindowTitleInactiveBackground, getWindowTitleInactiveForeground

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OceanTheme

        public OceanTheme()
        Creates an instance of OceanTheme

    • 方法详细信息

      • addCustomEntriesToTable

        public void addCustomEntriesToTable(UIDefaults table)
        Add this theme's custom entries to the defaults table.
        重载：
        addCustomEntriesToTable in class MetalTheme
        参数：
        table - the defaults table, non-null
        抛出：
        NullPointerException - if table is null
        另请参见：
        MetalLookAndFeel.getDefaults()

      • getName

        public String getName()
        Return the name of this theme, "Ocean".
        重载：
        getName in class DefaultMetalTheme
        返回：
        "Ocean"

      • getPrimary1

        protected ColorUIResource getPrimary1()
        Returns the primary 1 color. This returns a color with an rgb hex value of 0x6382BF.
        重载：
        getPrimary1 in class DefaultMetalTheme
        返回：
        the primary 1 color
        另请参见：
        Color.decode(java.lang.String)

      • getPrimary2

        protected ColorUIResource getPrimary2()
        Returns the primary 2 color. This returns a color with an rgb hex value of 0xA3B8CC.
        重载：
        getPrimary2 in class DefaultMetalTheme
        返回：
        the primary 2 color
        另请参见：
        Color.decode(java.lang.String)

      • getPrimary3

        protected ColorUIResource getPrimary3()
        Returns the primary 3 color. This returns a color with an rgb hex value of 0xB8CFE5.
        重载：
        getPrimary3 in class DefaultMetalTheme
        返回：
        the primary 3 color
        另请参见：
        Color.decode(java.lang.String)

      • getSecondary1

        protected ColorUIResource getSecondary1()
        Returns the secondary 1 color. This returns a color with an rgb hex value of 0x7A8A99.
        重载：
        getSecondary1 in class DefaultMetalTheme
        返回：
        the secondary 1 color
        另请参见：
        Color.decode(java.lang.String)

      • getSecondary2

        protected ColorUIResource getSecondary2()
        Returns the secondary 2 color. This returns a color with an rgb hex value of 0xB8CFE5.
        重载：
        getSecondary2 in class DefaultMetalTheme
        返回：
        the secondary 2 color
        另请参见：
        Color.decode(java.lang.String)

      • getSecondary3

        protected ColorUIResource getSecondary3()
        Returns the secondary 3 color. This returns a color with an rgb hex value of 0xEEEEEE.
        重载：
        getSecondary3 in class DefaultMetalTheme
        返回：
        the secondary 3 color
        另请参见：
        Color.decode(java.lang.String)

      • getBlack

        protected ColorUIResource getBlack()
        Returns the black color. This returns a color with an rgb hex value of 0x333333.
        重载：
        getBlack in class MetalTheme
        返回：
        the black color
        另请参见：
        Color.decode(java.lang.String)

      • getDesktopColor

        public ColorUIResource getDesktopColor()
        Returns the desktop color. This returns a color with an rgb hex value of 0xFFFFFF.
        重载：
        getDesktopColor in class MetalTheme
        返回：
        the desktop color
        另请参见：
        Color.decode(java.lang.String)

      • getInactiveControlTextColor

        public ColorUIResource getInactiveControlTextColor()
        Returns the inactive control text color. This returns a color with an rgb hex value of 0x999999.
        重载：
        getInactiveControlTextColor in class MetalTheme
        返回：
        the inactive control text color

      • getControlTextColor

        public ColorUIResource getControlTextColor()
        Returns the control text color. This returns a color with an rgb hex value of 0x333333.
        重载：
        getControlTextColor in class MetalTheme
        返回：
        the control text color

      • getMenuDisabledForeground

        public ColorUIResource getMenuDisabledForeground()
        Returns the menu disabled foreground color. This returns a color with an rgb hex value of 0x999999.
        重载：
        getMenuDisabledForeground in class MetalTheme
        返回：
        the menu disabled foreground color
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>RredandadttaddmrbbRtdnu))wiR,o ittec>>c.e


Uses of Package javax.swing.plaf.metal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf.metal

  • Packages that use javax.swing.plaf.metal
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
  • Classes in javax.swing.plaf.metal used by javax.swing.plaf.metal
    类与描述
    DefaultMetalTheme
    A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel".
    MetalBorders.ButtonBorder
    MetalBorders.Flush3DBorder
    MetalComboBoxEditor
    The default editor for Metal editable combo boxes
    MetalComboBoxUI.MetalComboBoxLayoutManager
    This inner class is marked "public" due to a compiler bug.
    MetalFileChooserUI.DirectoryComboBoxModel
    Data model for a type-face selection combo-box.
    MetalFileChooserUI.FilterComboBoxModel
    Data model for a type-face selection combo-box.
    MetalFileChooserUI.FilterComboBoxRenderer
    Render different type sizes and styles.
    MetalIconFactory.FileIcon16
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalIconFactory.FolderIcon16
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    MetalLabelUI
    A Windows L&F implementation of LabelUI.
    MetalRadioButtonUI
    RadioButtonUI implementation for MetalRadioButtonUI
    MetalScrollButton
    JButton object for Metal scrollbar arrows.
    MetalSeparatorUI
    A Metal L&F implementation of SeparatorUI.
    MetalTheme
    MetalTheme provides the color palette and fonts used by the Java Look and Feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnooB/Bb/aaal///>>e//tCoi


Uses of Class javax.swing.plaf.metal.DefaultMetalTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.DefaultMetalTheme

  • Packages that use DefaultMetalTheme
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of DefaultMetalTheme in javax.swing.plaf.metal

      Subclasses of DefaultMetalTheme in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  OceanTheme
      The default theme for the MetalLookAndFeel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laS


Uses of Class javax.swing.plaf.metal.MetalBorders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders

No usage of javax.swing.plaf.metal.MetalBorders
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!v-rtom_rbbbvnnn-msrs


Uses of Class javax.swing.plaf.metal.MetalBorders.ButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.ButtonBorder

  • Packages that use MetalBorders.ButtonBorder
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalBorders.ButtonBorder in javax.swing.plaf.metal

      Subclasses of MetalBorders.ButtonBorder in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      static class  | MetalBorders.RolloverButtonBorder
      static class  | MetalBorders.ToggleButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ccaiaooyehsbu=Ccsun/<


Uses of Class javax.swing.plaf.metal.MetalBorders.Flush3DBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.Flush3DBorder

  • Packages that use MetalBorders.Flush3DBorder
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalBorders.Flush3DBorder in javax.swing.plaf.metal

      Subclasses of MetalBorders.Flush3DBorder in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      static class  | MetalBorders.TextFieldBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/,idcicsitnwci歉蔚 瓣�


Uses of Class javax.swing.plaf.metal.MetalBorders.InternalFrameBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.InternalFrameBorder

No usage of javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lLfosn..r/aD>i-鰯r>s


Uses of Class javax.swing.plaf.metal.MetalBorders.MenuBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.MenuBarBorder

No usage of javax.swing.plaf.metal.MetalBorders.MenuBarBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tsRo>T>g莞be3&躠癰bs


Uses of Class javax.swing.plaf.metal.MetalBorders.MenuItemBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.MenuItemBorder

No usage of javax.swing.plaf.metal.MetalBorders.MenuItemBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wlg磎�at 8a


Uses of Class javax.swing.plaf.metal.MetalBorders.OptionDialogBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.OptionDialogBorder

No usage of javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>al e lsy=>bn


Uses of Class javax.swing.plaf.metal.MetalBorders.PaletteBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.PaletteBorder

No usage of javax.swing.plaf.metal.MetalBorders.PaletteBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/ab;1;p-1


Uses of Class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.PopupMenuBorder

No usage of javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn


Uses of Class javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder

No usage of javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>tsenx?iu1i薆ac


Uses of Class javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder

No usage of javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>< >g/s�


Uses of Class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.TableHeaderBorder

No usage of javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

琱eo7cdXor>x0b


Uses of Class javax.swing.plaf.metal.MetalBorders.TextFieldBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.TextFieldBorder

No usage of javax.swing.plaf.metal.MetalBorders.TextFieldBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<=my


Uses of Class javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder

No usage of javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p.lns!"� otbpcl<�


Uses of Class javax.swing.plaf.metal.MetalBorders.ToolBarBorder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalBorders.ToolBarBorder

No usage of javax.swing.plaf.metal.MetalBorders.ToolBarBorder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A>/ab;1;p-1


Uses of Class javax.swing.plaf.metal.MetalButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalButtonUI

No usage of javax.swing.plaf.metal.MetalButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Class javax.swing.plaf.metal.MetalCheckBoxIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalCheckBoxIcon

No usage of javax.swing.plaf.metal.MetalCheckBoxIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.metal.MetalCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalCheckBoxUI

No usage of javax.swing.plaf.metal.MetalCheckBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.plaf.metal.MetalComboBoxButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxButton

No usage of javax.swing.plaf.metal.MetalComboBoxButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oe

plr&/,>t>/


Uses of Class javax.swing.plaf.metal.MetalComboBoxEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxEditor

  • Packages that use MetalComboBoxEditor
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalComboBoxEditor in javax.swing.plaf.metal

      Subclasses of MetalComboBoxEditor in javax.swing.plaf.metal
      修饰符与类型 类与描述
      static class  MetalComboBoxEditor.UIResource
      A subclass of BasicComboBoxEditor that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a tr> >tl1.atdh/shs�


Uses of Class javax.swing.plaf.metal.MetalComboBoxEditor.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxEditor.UIResource

No usage of javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/i./../erfffai眄se<漱


Uses of Class javax.swing.plaf.metal.MetalComboBoxIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxIcon

No usage of javax.swing.plaf.metal.MetalComboBoxIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Class javax.swing.plaf.metal.MetalComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxUI

No usage of javax.swing.plaf.metal.MetalComboBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager

  • Packages that use MetalComboBoxUI.MetalComboBoxLayoutManager
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalComboBoxUI.MetalComboBoxLayoutManager in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type MetalComboBoxUI.MetalComboBoxLayoutManager
      修饰符与类型 | 方法与描述
      void | MetalComboBoxUI.layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>te-p


Uses of Class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup

No usage of javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g


Uses of Class javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener

No usage of javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>b(nl/nBawUona.tb>g


Uses of Class javax.swing.plaf.metal.MetalDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalDesktopIconUI

No usage of javax.swing.plaf.metal.MetalDesktopIconUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sl,eaoio evwdiir娶则�


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI

No usage of javax.swing.plaf.metal.MetalFileChooserUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dieoiltaettt#raarorgl


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction

No usage of javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.d.tf /l


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

  • Packages that use MetalFileChooserUI.DirectoryComboBoxModel
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalFileChooserUI.DirectoryComboBoxModel in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return MetalFileChooserUI.DirectoryComboBoxModel
      修饰符与类型 | 方法与描述
      protected MetalFileChooserUI.DirectoryComboBoxModel | MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wCemsgnnbse/&-P<&a/ a


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer

No usage of javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

idnll" .rhhhoJjjttBya


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

  • Packages that use MetalFileChooserUI.FilterComboBoxModel
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalFileChooserUI.FilterComboBoxModel in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return MetalFileChooserUI.FilterComboBoxModel
      修饰符与类型 | 方法与描述
      protected MetalFileChooserUI.FilterComboBoxModel | MetalFileChooserUI.createFilterComboBoxModel()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer

  • Packages that use MetalFileChooserUI.FilterComboBoxRenderer
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalFileChooserUI.FilterComboBoxRenderer in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal that return MetalFileChooserUI.FilterComboBoxRenderer
      修饰符与类型 | 方法与描述
      protected MetalFileChooserUI.FilterComboBoxRenderer | MetalFileChooserUI.createFilterComboBoxRenderer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/r>a/h7p,ko#a糘a vtn


Uses of Class javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener

No usage of javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

errt.liy"mxfbvo 祎


Uses of Class javax.swing.plaf.metal.MetalIconFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory

No usage of javax.swing.plaf.metal.MetalIconFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aamm"boalsssv AAl><


Uses of Class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.FileIcon16

  • Packages that use MetalIconFactory.FileIcon16
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalIconFactory.FileIcon16 in javax.swing.plaf.metal

      Subclasses of MetalIconFactory.FileIcon16 in javax.swing.plaf.metal
      修饰符与类型 | 类与描述
      static class  | MetalIconFactory.TreeLeafIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alotsavb)srvn 雇滴礸e


Uses of Class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

  • Packages that use MetalIconFactory.FolderIcon16
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalIconFactory.FolderIcon16 in javax.swing.plaf.metal

      Subclasses of MetalIconFactory.FolderIcon16 in javax.swing.plaf.metal
      修饰符与类型 类与描述
      static class  MetalIconFactory.TreeFolderIcon
      警告： Serialized objects of this class will not be compatible with future Swing releases.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

U<<S叔gi.=


Uses of Class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

No usage of javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>PU./ fopne/>sl.


Uses of Class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

No usage of javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a1>t>.>lP. neU


Uses of Class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

No usage of javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>jn>t>>>la>..ti 1.


Uses of Class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

No usage of javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntm


Uses of Class javax.swing.plaf.metal.MetalInternalFrameTitlePane

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalInternalFrameTitlePane

No usage of javax.swing.plaf.metal.MetalInternalFrameTitlePane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.metal.MetalInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalInternalFrameUI

No usage of javax.swing.plaf.metal.MetalInternalFrameUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

enrnr&s/�>皉/


Uses of Class javax.swing.plaf.metal.MetalLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalLabelUI

  • Packages that use MetalLabelUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalLabelUI in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as MetalLabelUI
      修饰符与类型 字段与描述
      protected static MetalLabelUI MetalLabelUI.metalLabelUI
      The default MetalLabelUI instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ut iiuc o >k=cr室n⒁ds


Uses of Class javax.swing.plaf.metal.MetalLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalLookAndFeel

No usage of javax.swing.plaf.metal.MetalLookAndFeel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c


Uses of Class javax.swing.plaf.metal.MetalMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalMenuBarUI

No usage of javax.swing.plaf.metal.MetalMenuBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

No usage of javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s oa>bic


Uses of Class javax.swing.plaf.metal.MetalProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalProgressBarUI

No usage of javax.swing.plaf.metal.MetalProgressBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rnrnr&s�>皉/


Uses of Class javax.swing.plaf.metal.MetalRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalRadioButtonUI

  • Packages that use MetalRadioButtonUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalRadioButtonUI in javax.swing.plaf.metal

      Subclasses of MetalRadioButtonUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalCheckBoxUI
      CheckboxUI implementation for MetalCheckboxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.


Uses of Class javax.swing.plaf.metal.MetalRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalRootPaneUI

No usage of javax.swing.plaf.metal.MetalRootPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"w>miewvoeee..aarm< h


Uses of Class javax.swing.plaf.metal.MetalScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalScrollBarUI

No usage of javax.swing.plaf.metal.MetalScrollBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s'a.�Ba祲-<僼s


Uses of Class javax.swing.plaf.metal.MetalScrollButton

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalScrollButton

  • Packages that use MetalScrollButton
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalScrollButton in javax.swing.plaf.metal

      Fields in javax.swing.plaf.metal declared as MetalScrollButton
      修饰符与类型 | 字段与描述
      protected MetalScrollButton | MetalScrollBarUI.decreaseButton
      protected MetalScrollButton | MetalScrollBarUI.increaseButton
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hdwa nta"gqLoc=/etlesd


Uses of Class javax.swing.plaf.metal.MetalScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalScrollPaneUI

No usage of javax.swing.plaf.metal.MetalScrollPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x//.../"=...ronns


Uses of Class javax.swing.plaf.metal.MetalSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalSeparatorUI

  • Packages that use MetalSeparatorUI
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalSeparatorUI in javax.swing.plaf.metal

      Subclasses of MetalSeparatorUI in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  MetalPopupMenuSeparatorUI
      A Metal L&F implementation of PopupMenuSeparatorUI.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cs


Uses of Class javax.swing.plaf.metal.MetalSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalSliderUI

No usage of javax.swing.plaf.metal.MetalSliderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.o.=".h rrr>olle>r_=


Uses of Class javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener

No usage of javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.=nt


Uses of Class javax.swing.plaf.metal.MetalSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalSplitPaneUI

No usage of javax.swing.plaf.metal.MetalSplitPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r >lem.malsb


Uses of Class javax.swing.plaf.metal.MetalTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalTabbedPaneUI

No usage of javax.swing.plaf.metal.MetalTabbedPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!&bloy� t !h>誽�


Uses of Class javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout

No usage of javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctes/a>m a


Uses of Class javax.swing.plaf.metal.MetalTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalTextFieldUI

No usage of javax.swing.plaf.metal.MetalTextFieldUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s. r


Uses of Class javax.swing.plaf.metal.MetalTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalTheme

  • Packages that use MetalTheme
    软件包 描述
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.

    • Uses of MetalTheme in javax.swing.plaf.metal

      Subclasses of MetalTheme in javax.swing.plaf.metal
      修饰符与类型 类与描述
      class  DefaultMetalTheme
      A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel".
      class  OceanTheme
      The default theme for the MetalLookAndFeel.
      Methods in javax.swing.plaf.metal that return MetalTheme
      修饰符与类型 方法与描述
      static MetalTheme MetalLookAndFeel.getCurrentTheme()
      Return the theme currently being used by MetalLookAndFeel.
      Methods in javax.swing.plaf.metal with parameters of type MetalTheme
      修饰符与类型 方法与描述
      static void MetalLookAndFeel.setCurrentTheme(MetalTheme theme)
      Set the theme used by MetalLookAndFeel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> nm/ec/aiee w纄nai.


Uses of Class javax.swing.plaf.metal.MetalToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToggleButtonUI

No usage of javax.swing.plaf.metal.MetalToggleButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llUmar "sss=lddoF>>n


Uses of Class javax.swing.plaf.metal.MetalToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToolBarUI

No usage of javax.swing.plaf.metal.MetalToolBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ai/ab;1;p-1


Uses of Class javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener

No usage of javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r.;sos�"a/u


Uses of Class javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener

No usage of javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener

No usage of javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

2Ae�sryl/c m ^%


Uses of Class javax.swing.plaf.metal.MetalToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalToolTipUI

No usage of javax.swing.plaf.metal.MetalToolTipUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n1drswrw rau, r.濉⒂.


Uses of Class javax.swing.plaf.metal.MetalTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.MetalTreeUI

No usage of javax.swing.plaf.metal.MetalTreeUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla>y/ <


Uses of Class javax.swing.plaf.metal.OceanTheme

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.metal.OceanTheme

No usage of javax.swing.plaf.metal.OceanTheme
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>nt>>>ln>ppss


javax.swing.plaf.multi

Classes

  • MultiButtonUI
  • MultiColorChooserUI
  • MultiComboBoxUI
  • MultiDesktopIconUI
  • MultiDesktopPaneUI
  • MultiFileChooserUI
  • MultiInternalFrameUI
  • MultiLabelUI
  • MultiListUI
  • MultiLookAndFeel
  • MultiMenuBarUI
  • MultiMenuItemUI
  • MultiOptionPaneUI
  • MultiPanelUI
  • MultiPopupMenuUI
  • MultiProgressBarUI
  • MultiRootPaneUI
  • MultiScrollBarUI
  • MultiScrollPaneUI
  • MultiSeparatorUI
  • MultiSliderUI
  • MultiSpinnerUI
  • MultiSplitPaneUI
  • MultiTabbedPaneUI
  • MultiTableHeaderUI
  • MultiTableUI
  • MultiTextUI
  • MultiToolBarUI
  • MultiToolTipUI
  • MultiTreeUI
  • MultiViewportUI
s


javax.swing.plaf.multi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf.multi

Provides user interface objects that combine two or more look and feels.

请参见： 描述

  • Class Summary
    类 描述
    MultiButtonUI
    A multiplexing UI used to combine ButtonUIs.
    MultiColorChooserUI
    A multiplexing UI used to combine ColorChooserUIs.
    MultiComboBoxUI
    A multiplexing UI used to combine ComboBoxUIs.
    MultiDesktopIconUI
    A multiplexing UI used to combine DesktopIconUIs.
    MultiDesktopPaneUI
    A multiplexing UI used to combine DesktopPaneUIs.
    MultiFileChooserUI
    A multiplexing UI used to combine FileChooserUIs.
    MultiInternalFrameUI
    A multiplexing UI used to combine InternalFrameUIs.
    MultiLabelUI
    A multiplexing UI used to combine LabelUIs.
    MultiListUI
    A multiplexing UI used to combine ListUIs.
    MultiLookAndFeel
    A multiplexing look and feel that allows more than one UI to be associated with a component at the same time.
    MultiMenuBarUI
    A multiplexing UI used to combine MenuBarUIs.
    MultiMenuItemUI
    A multiplexing UI used to combine MenuItemUIs.
    MultiOptionPaneUI
    A multiplexing UI used to combine OptionPaneUIs.
    MultiPanelUI
    A multiplexing UI used to combine PanelUIs.
    MultiPopupMenuUI
    A multiplexing UI used to combine PopupMenuUIs.
    MultiProgressBarUI
    A multiplexing UI used to combine ProgressBarUIs.
    MultiRootPaneUI
    A multiplexing UI used to combine RootPaneUIs.
    MultiScrollBarUI
    A multiplexing UI used to combine ScrollBarUIs.
    MultiScrollPaneUI
    A multiplexing UI used to combine ScrollPaneUIs.
    MultiSeparatorUI
    A multiplexing UI used to combine SeparatorUIs.
    MultiSliderUI
    A multiplexing UI used to combine SliderUIs.
    MultiSpinnerUI
    A multiplexing UI used to combine SpinnerUIs.
    MultiSplitPaneUI
    A multiplexing UI used to combine SplitPaneUIs.
    MultiTabbedPaneUI
    A multiplexing UI used to combine TabbedPaneUIs.
    MultiTableHeaderUI
    A multiplexing UI used to combine TableHeaderUIs.
    MultiTableUI
    A multiplexing UI used to combine TableUIs.
    MultiTextUI
    A multiplexing UI used to combine TextUIs.
    MultiToolBarUI
    A multiplexing UI used to combine ToolBarUIs.
    MultiToolTipUI
    A multiplexing UI used to combine ToolTipUIs.
    MultiTreeUI
    A multiplexing UI used to combine TreeUIs.
    MultiViewportUI
    A multiplexing UI used to combine ViewportUIs.

软件包 javax.swing.plaf.multi Description

Provides user interface objects that combine two or more look and feels. When a component asks for its UI, this look and feel returns a multiplexing UI that handles all communications with both the default look and feel and one or more auxiliary look and feels. For example, if a user combines an auxiliary audio look and feel with the Motif look and feel, the JButton.getUI method would return an instance of MultiButtonUI, which would handle both a MotifButtonUI and an AudioButtonUI.

For more information, see Using the Multiplexing Look and Feel.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b


javax.swing.plaf.multi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf.multi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI
        • javax.swing.plaf.multi.MultiButtonUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.multi.MultiColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.multi.MultiComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.multi.MultiDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.multi.MultiDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.multi.MultiInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.multi.MultiLabelUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.multi.MultiListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.multi.MultiMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.multi.MultiOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.multi.MultiPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.multi.MultiPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.multi.MultiProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.multi.MultiRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.multi.MultiScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.multi.MultiScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.multi.MultiSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.multi.MultiSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.multi.MultiSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.multi.MultiTabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.multi.MultiTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.multi.MultiTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.multi.MultiTextUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.multi.MultiToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.multi.MultiToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.multi.MultiTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.multi.MultiViewportUI
    • javax.swing.LookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/b ahhsolsn


MultiButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.multi.MultiButtonUI

  • public class MultiButtonUI
extends ButtonUI
    A multiplexing UI used to combine ButtonUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiButtonUI

        public MultiButtonUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MultiColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiColorChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.multi.MultiColorChooserUI

  • public class MultiColorChooserUI
extends ColorChooserUI
    A multiplexing UI used to combine ColorChooserUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiColorChooserUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiColorChooserUI

        public MultiColorChooserUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Snbe


MultiComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiComboBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.multi.MultiComboBoxUI

  • public class MultiComboBoxUI
extends ComboBoxUI
    A multiplexing UI used to combine ComboBoxUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiComboBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      boolean isFocusTraversable(JComboBox a)
      Invokes the isFocusTraversable method on each UI handled by this object.
      boolean isPopupVisible(JComboBox a)
      Invokes the isPopupVisible method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void setPopupVisible(JComboBox a, boolean b)
      Invokes the setPopupVisible method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiComboBoxUI

        public MultiComboBoxUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • isFocusTraversable

        public boolean isFocusTraversable(JComboBox a)
        Invokes the isFocusTraversable method on each UI handled by this object.
        指定者：
        isFocusTraversable in class ComboBoxUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • setPopupVisible

        public void setPopupVisible(JComboBox a,
                   boolean b)
        Invokes the setPopupVisible method on each UI handled by this object.
        指定者：
        setPopupVisible in class ComboBoxUI

      • isPopupVisible

        public boolean isPopupVisible(JComboBox a)
        Invokes the isPopupVisible method on each UI handled by this object.
        指定者：
        isPopupVisible in class ComboBoxUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n<-evb


MultiDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiDesktopIconUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.multi.MultiDesktopIconUI

  • public class MultiDesktopIconUI
extends DesktopIconUI
    A multiplexing UI used to combine DesktopIconUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiDesktopIconUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiDesktopIconUI

        public MultiDesktopIconUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ooc >


MultiDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiDesktopPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.multi.MultiDesktopPaneUI

  • public class MultiDesktopPaneUI
extends DesktopPaneUI
    A multiplexing UI used to combine DesktopPaneUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiDesktopPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiDesktopPaneUI

        public MultiDesktopPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t3 ..o"ooel


MultiFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiFileChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI

  • public class MultiFileChooserUI
extends FileChooserUI
    A multiplexing UI used to combine FileChooserUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiFileChooserUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      void ensureFileIsVisible(JFileChooser a, File b)
      Invokes the ensureFileIsVisible method on each UI handled by this object.
      FileFilter getAcceptAllFileFilter(JFileChooser a)
      Invokes the getAcceptAllFileFilter method on each UI handled by this object.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      String getApproveButtonText(JFileChooser a)
      Invokes the getApproveButtonText method on each UI handled by this object.
      String getDialogTitle(JFileChooser a)
      Invokes the getDialogTitle method on each UI handled by this object.
      FileView getFileView(JFileChooser a)
      Invokes the getFileView method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void rescanCurrentDirectory(JFileChooser a)
      Invokes the rescanCurrentDirectory method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.FileChooserUI

        getDefaultButton

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiFileChooserUI

        public MultiFileChooserUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • getAcceptAllFileFilter

        public FileFilter getAcceptAllFileFilter(JFileChooser a)
        Invokes the getAcceptAllFileFilter method on each UI handled by this object.
        指定者：
        getAcceptAllFileFilter in class FileChooserUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getFileView

        public FileView getFileView(JFileChooser a)
        Invokes the getFileView method on each UI handled by this object.
        指定者：
        getFileView in class FileChooserUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getApproveButtonText

        public String getApproveButtonText(JFileChooser a)
        Invokes the getApproveButtonText method on each UI handled by this object.
        指定者：
        getApproveButtonText in class FileChooserUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getDialogTitle

        public String getDialogTitle(JFileChooser a)
        Invokes the getDialogTitle method on each UI handled by this object.
        指定者：
        getDialogTitle in class FileChooserUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • rescanCurrentDirectory

        public void rescanCurrentDirectory(JFileChooser a)
        Invokes the rescanCurrentDirectory method on each UI handled by this object.
        指定者：
        rescanCurrentDirectory in class FileChooserUI

      • ensureFileIsVisible

        public void ensureFileIsVisible(JFileChooser a,
                       File b)
        Invokes the ensureFileIsVisible method on each UI handled by this object.
        指定者：
        ensureFileIsVisible in class FileChooserUI

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MultiInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiInternalFrameUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.multi.MultiInternalFrameUI

  • public class MultiInternalFrameUI
extends InternalFrameUI
    A multiplexing UI used to combine InternalFrameUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiInternalFrameUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiInternalFrameUI

        public MultiInternalFrameUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.tss=ci"citttitttnggdePbba ..;C


MultiLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiLabelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.multi.MultiLabelUI

  • public class MultiLabelUI
extends LabelUI
    A multiplexing UI used to combine LabelUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiLabelUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiLabelUI

        public MultiLabelUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.hnincnino,witcelh�.肝觋媚颡纤蛟⑾稀枋龅�


MultiListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiListUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.multi.MultiListUI

  • public class MultiListUI
extends ListUI
    A multiplexing UI used to combine ListUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiListUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Rectangle getCellBounds(JList a, int b, int c)
      Invokes the getCellBounds method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      Point indexToLocation(JList a, int b)
      Invokes the indexToLocation method on each UI handled by this object.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      int locationToIndex(JList a, Point b)
      Invokes the locationToIndex method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiListUI

        public MultiListUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • locationToIndex

        public int locationToIndex(JList a,
                  Point b)
        Invokes the locationToIndex method on each UI handled by this object.
        指定者：
        locationToIndex in class ListUI
        参数：
        a - the list
        b - the coordinates of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • indexToLocation

        public Point indexToLocation(JList a,
                    int b)
        Invokes the indexToLocation method on each UI handled by this object.
        指定者：
        indexToLocation in class ListUI
        参数：
        a - the list
        b - the cell index
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getCellBounds

        public Rectangle getCellBounds(JList a,
                      int b,
                      int c)
        Invokes the getCellBounds method on each UI handled by this object.
        指定者：
        getCellBounds in class ListUI
        参数：
        a - the list
        b - the first index in the range
        c - the second index in the range
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w


MultiLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiLookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel

  • public class MultiLookAndFeel
extends LookAndFeel

    A multiplexing look and feel that allows more than one UI to be associated with a component at the same time. The primary look and feel is called the default look and feel, and the other look and feels are called auxiliary.

    For further information, see Using the Multiplexing Look and Feel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    UIManager.addAuxiliaryLookAndFeel(javax.swing.LookAndFeel), javax.swing.plaf.multi

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiLookAndFeel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUIs(ComponentUI mui, Vector uis, JComponent target)
      Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.
      UIDefaults getDefaults()
      Creates, initializes, and returns the look and feel specific defaults.
      String getDescription()
      Returns a one-line description of this look and feel.
      String getID()
      Returns a string, suitable for use by applications/services, that identifies this look and feel.
      String getName()
      Returns a string, suitable for use in menus, that identifies this look and feel.
      boolean isNativeLookAndFeel()
      Returns false; this look and feel is not native to any platform.
      boolean isSupportedLookAndFeel()
      Returns true; every platform permits this look and feel.
      protected static ComponentUI[] uisToArray(Vector uis)
      Creates an array, populates it with UI objects from the passed-in vector, and returns the array.

      • 方法 - 继承于类 javax.swing.LookAndFeel

        getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getLayoutStyle, getSupportsWindowDecorations, initialize, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninitialize, uninstallBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MultiLookAndFeel

        public MultiLookAndFeel()

    • 方法详细信息

      • getName

        public String getName()
        Returns a string, suitable for use in menus, that identifies this look and feel.
        指定者：
        getName in class LookAndFeel
        返回：
        a string such as "Multiplexing Look and Feel"

      • getID

        public String getID()
        Returns a string, suitable for use by applications/services, that identifies this look and feel.
        指定者：
        getID in class LookAndFeel
        返回：
        "Multiplex"

      • getDescription

        public String getDescription()
        Returns a one-line description of this look and feel.
        指定者：
        getDescription in class LookAndFeel
        返回：
        a descriptive string such as "Allows multiple UI instances per component instance"

      • isNativeLookAndFeel

        public boolean isNativeLookAndFeel()
        Returns false; this look and feel is not native to any platform.
        指定者：
        isNativeLookAndFeel in class LookAndFeel
        返回：
        false

      • isSupportedLookAndFeel

        public boolean isSupportedLookAndFeel()
        Returns true; every platform permits this look and feel.
        指定者：
        isSupportedLookAndFeel in class LookAndFeel
        返回：
        true
        另请参见：
        UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • getDefaults

        public UIDefaults getDefaults()
        Creates, initializes, and returns the look and feel specific defaults. For this look and feel, the defaults consist solely of mappings of UI class IDs (such as "ButtonUI") to ComponentUI class names (such as "javax.swing.plaf.multi.MultiButtonUI").
        重载：
        getDefaults in class LookAndFeel
        返回：
        an initialized UIDefaults object
        另请参见：
        JComponent.getUIClassID()

      • createUIs

        public static ComponentUI createUIs(ComponentUI mui,
                    Vector uis,
                    JComponent target)
        Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI. This method finds the ComponentUI objects by invoking getDefaults().getUI(target) on each default and auxiliary look and feel currently in use. The first UI object this method adds to the uis vector is for the default look and feel.

        This method is invoked by the createUI method of MultiXxxxUI classes.

        参数：
        mui - the ComponentUI object that represents the complete UI for the target component; this should be an instance of one of the MultiXxxxUI classes
        uis - a Vector; generally this is the uis field of the mui argument
        target - a component whose UI is represented by mui
        返回：
        mui if the component has any auxiliary UI objects; otherwise, returns the UI object for the default look and feel or null if the default UI object couldn't be found
        另请参见：
        UIManager.getAuxiliaryLookAndFeels(), UIDefaults.getUI(javax.swing.JComponent), MultiButtonUI.uis, MultiButtonUI.createUI(javax.swing.JComponent)

      • uisToArray

        protected static ComponentUI[] uisToArray(Vector uis)
        Creates an array, populates it with UI objects from the passed-in vector, and returns the array. If uis is null, this method returns an array with zero elements. If uis is an empty vector, this method returns null. A run-time error occurs if any objects in the uis vector are not of type ComponentUI.
        参数：
        uis - a vector containing ComponentUI objects
        返回：
        an array equivalent to the passed-in vector
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.wttlnmlnettneeos..pe.otnnnoU.nJeggh.


MultiMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiMenuBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.multi.MultiMenuBarUI

  • public class MultiMenuBarUI
extends MenuBarUI
    A multiplexing UI used to combine MenuBarUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiMenuBarUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiMenuBarUI

        public MultiMenuBarUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t <


MultiMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI

  • public class MultiMenuItemUI
extends MenuItemUI
    A multiplexing UI used to combine MenuItemUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiMenuItemUI

        public MultiMenuItemUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a4


MultiOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiOptionPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.multi.MultiOptionPaneUI

  • public class MultiOptionPaneUI
extends OptionPaneUI
    A multiplexing UI used to combine OptionPaneUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiOptionPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      boolean containsCustomComponents(JOptionPane a)
      Invokes the containsCustomComponents method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void selectInitialValue(JOptionPane a)
      Invokes the selectInitialValue method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiOptionPaneUI

        public MultiOptionPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • selectInitialValue

        public void selectInitialValue(JOptionPane a)
        Invokes the selectInitialValue method on each UI handled by this object.
        指定者：
        selectInitialValue in class OptionPaneUI

      • containsCustomComponents

        public boolean containsCustomComponents(JOptionPane a)
        Invokes the containsCustomComponents method on each UI handled by this object.
        指定者：
        containsCustomComponents in class OptionPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hamo>


MultiPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiPanelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.multi.MultiPanelUI

  • public class MultiPanelUI
extends PanelUI
    A multiplexing UI used to combine PanelUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiPanelUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiPanelUI

        public MultiPanelUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w


MultiPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiPopupMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.multi.MultiPopupMenuUI

  • public class MultiPopupMenuUI
extends PopupMenuUI
    A multiplexing UI used to combine PopupMenuUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiPopupMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Popup getPopup(JPopupMenu a, int b, int c)
      Invokes the getPopup method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      boolean isPopupTrigger(MouseEvent a)
      Invokes the isPopupTrigger method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiPopupMenuUI

        public MultiPopupMenuUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • isPopupTrigger

        public boolean isPopupTrigger(MouseEvent a)
        Invokes the isPopupTrigger method on each UI handled by this object.
        重载：
        isPopupTrigger in class PopupMenuUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        从以下版本开始：
        1.3

      • getPopup

        public Popup getPopup(JPopupMenu a,
             int b,
             int c)
        Invokes the getPopup method on each UI handled by this object.
        重载：
        getPopup in class PopupMenuUI
        参数：
        a - JPopupMenu requesting Popup
        b - Screen x location Popup is to be shown at
        c - Screen y location Popup is to be shown at.
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        从以下版本开始：
        1.4

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


MultiProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiProgressBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.multi.MultiProgressBarUI

  • public class MultiProgressBarUI
extends ProgressBarUI
    A multiplexing UI used to combine ProgressBarUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiProgressBarUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiProgressBarUI

        public MultiProgressBarUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#JgeCmlomlpaalppw/""eFLck//o>p>dnp�>d


MultiRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiRootPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.multi.MultiRootPaneUI

  • public class MultiRootPaneUI
extends RootPaneUI
    A multiplexing UI used to combine RootPaneUIs.

    This file was automatically generated by AutoMulti.

    从以下版本开始：
    1.4

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiRootPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiRootPaneUI

        public MultiRootPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

spmgmomodlhp<JJpe罫


MultiScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiScrollBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.multi.MultiScrollBarUI

  • public class MultiScrollBarUI
extends ScrollBarUI
    A multiplexing UI used to combine ScrollBarUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiScrollBarUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiScrollBarUI

        public MultiScrollBarUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r l b>t>gomsglsmmd>lm


MultiScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiScrollPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.multi.MultiScrollPaneUI

  • public class MultiScrollPaneUI
extends ScrollPaneUI
    A multiplexing UI used to combine ScrollPaneUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiScrollPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiScrollPaneUI

        public MultiScrollPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eF .;


MultiSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI

  • public class MultiSeparatorUI
extends SeparatorUI
    A multiplexing UI used to combine SeparatorUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiSeparatorUI

        public MultiSeparatorUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3l>t>/>a>gsall/ lddl<>le>Fhll


MultiSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiSliderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.multi.MultiSliderUI

  • public class MultiSliderUI
extends SliderUI
    A multiplexing UI used to combine SliderUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiSliderUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiSliderUI

        public MultiSliderUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3绷 羖玲龄没嵩ｔ缺<留猫孕嗅鹒n/bfr�//orga<>


MultiSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiSpinnerUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.multi.MultiSpinnerUI

  • public class MultiSpinnerUI
extends SpinnerUI
    A multiplexing UI used to combine SpinnerUIs.

    This file was automatically generated by AutoMulti.

    从以下版本开始：
    1.4

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiSpinnerUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiSpinnerUI

        public MultiSpinnerUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>r/nd en


MultiSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiSplitPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.multi.MultiSplitPaneUI

  • public class MultiSplitPaneUI
extends SplitPaneUI
    A multiplexing UI used to combine SplitPaneUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiSplitPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      void finishedPaintingChildren(JSplitPane a, Graphics b)
      Invokes the finishedPaintingChildren method on each UI handled by this object.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      int getDividerLocation(JSplitPane a)
      Invokes the getDividerLocation method on each UI handled by this object.
      int getMaximumDividerLocation(JSplitPane a)
      Invokes the getMaximumDividerLocation method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      int getMinimumDividerLocation(JSplitPane a)
      Invokes the getMinimumDividerLocation method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void resetToPreferredSizes(JSplitPane a)
      Invokes the resetToPreferredSizes method on each UI handled by this object.
      void setDividerLocation(JSplitPane a, int b)
      Invokes the setDividerLocation method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiSplitPaneUI

        public MultiSplitPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • resetToPreferredSizes

        public void resetToPreferredSizes(JSplitPane a)
        Invokes the resetToPreferredSizes method on each UI handled by this object.
        指定者：
        resetToPreferredSizes in class SplitPaneUI

      • setDividerLocation

        public void setDividerLocation(JSplitPane a,
                      int b)
        Invokes the setDividerLocation method on each UI handled by this object.
        指定者：
        setDividerLocation in class SplitPaneUI

      • getDividerLocation

        public int getDividerLocation(JSplitPane a)
        Invokes the getDividerLocation method on each UI handled by this object.
        指定者：
        getDividerLocation in class SplitPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getMinimumDividerLocation

        public int getMinimumDividerLocation(JSplitPane a)
        Invokes the getMinimumDividerLocation method on each UI handled by this object.
        指定者：
        getMinimumDividerLocation in class SplitPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getMaximumDividerLocation

        public int getMaximumDividerLocation(JSplitPane a)
        Invokes the getMaximumDividerLocation method on each UI handled by this object.
        指定者：
        getMaximumDividerLocation in class SplitPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • finishedPaintingChildren

        public void finishedPaintingChildren(JSplitPane a,
                            Graphics b)
        Invokes the finishedPaintingChildren method on each UI handled by this object.
        指定者：
        finishedPaintingChildren in class SplitPaneUI

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MultiTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiTabbedPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.multi.MultiTabbedPaneUI

  • public class MultiTabbedPaneUI
extends TabbedPaneUI
    A multiplexing UI used to combine TabbedPaneUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiTabbedPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      Rectangle getTabBounds(JTabbedPane a, int b)
      Invokes the getTabBounds method on each UI handled by this object.
      int getTabRunCount(JTabbedPane a)
      Invokes the getTabRunCount method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      int tabForCoordinate(JTabbedPane a, int b, int c)
      Invokes the tabForCoordinate method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiTabbedPaneUI

        public MultiTabbedPaneUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • tabForCoordinate

        public int tabForCoordinate(JTabbedPane a,
                   int b,
                   int c)
        Invokes the tabForCoordinate method on each UI handled by this object.
        指定者：
        tabForCoordinate in class TabbedPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getTabBounds

        public Rectangle getTabBounds(JTabbedPane a,
                     int b)
        Invokes the getTabBounds method on each UI handled by this object.
        指定者：
        getTabBounds in class TabbedPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getTabRunCount

        public int getTabRunCount(JTabbedPane a)
        Invokes the getTabRunCount method on each UI handled by this object.
        指定者：
        getTabRunCount in class TabbedPaneUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h ;,na,n&bbn&&tCvvhCe


MultiTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiTableHeaderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.multi.MultiTableHeaderUI

  • public class MultiTableHeaderUI
extends TableHeaderUI
    A multiplexing UI used to combine TableHeaderUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiTableHeaderUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiTableHeaderUI

        public MultiTableHeaderUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.


MultiTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiTableUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.multi.MultiTableUI

  • public class MultiTableUI
extends TableUI
    A multiplexing UI used to combine TableUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiTableUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiTableUI

        public MultiTableUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csornr r roig ceaso0码牵过b ra" .>aa�/萩/x


MultiTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiTextUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.multi.MultiTextUI

  • public class MultiTextUI
extends TextUI
    A multiplexing UI used to combine TextUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiTextUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      void damageRange(JTextComponent a, int b, int c)
      Invokes the damageRange method on each UI handled by this object.
      void damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e)
      Invokes the damageRange method on each UI handled by this object.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      EditorKit getEditorKit(JTextComponent a)
      Invokes the getEditorKit method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      int getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e)
      Invokes the getNextVisualPositionFrom method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      View getRootView(JTextComponent a)
      Invokes the getRootView method on each UI handled by this object.
      String getToolTipText(JTextComponent a, Point b)
      Invokes the getToolTipText method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      Rectangle modelToView(JTextComponent a, int b)
      Invokes the modelToView method on each UI handled by this object.
      Rectangle modelToView(JTextComponent a, int b, Position.Bias c)
      Invokes the modelToView method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.
      int viewToModel(JTextComponent a, Point b)
      Invokes the viewToModel method on each UI handled by this object.
      int viewToModel(JTextComponent a, Point b, Position.Bias[] c)
      Invokes the viewToModel method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiTextUI

        public MultiTextUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • getToolTipText

        public String getToolTipText(JTextComponent a,
                    Point b)
        Invokes the getToolTipText method on each UI handled by this object.
        重载：
        getToolTipText in class TextUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        从以下版本开始：
        1.4
        另请参见：
        JTextComponent.getToolTipText(java.awt.event.MouseEvent)

      • modelToView

        public Rectangle modelToView(JTextComponent a,
                    int b)
                      throws BadLocationException
        Invokes the modelToView method on each UI handled by this object.
        指定者：
        modelToView in class TextUI
        b - the local location in the model to translate >= 0
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document

      • modelToView

        public Rectangle modelToView(JTextComponent a,
                    int b,
                    Position.Bias c)
                      throws BadLocationException
        Invokes the modelToView method on each UI handled by this object.
        指定者：
        modelToView in class TextUI
        b - the local location in the model to translate >= 0
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document

      • viewToModel

        public int viewToModel(JTextComponent a,
              Point b)
        Invokes the viewToModel method on each UI handled by this object.
        指定者：
        viewToModel in class TextUI
        b - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • viewToModel

        public int viewToModel(JTextComponent a,
              Point b,
              Position.Bias[] c)
        Invokes the viewToModel method on each UI handled by this object.
        指定者：
        viewToModel in class TextUI
        b - the location in the view to translate. This should be in the same coordinate system as the mouse events.
        c - filled in by this method to indicate whether the point given is closer to the previous or the next character in the model
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(JTextComponent a,
                            int b,
                            Position.Bias c,
                            int d,
                            Position.Bias[] e)
                              throws BadLocationException
        Invokes the getNextVisualPositionFrom method on each UI handled by this object.
        指定者：
        getNextVisualPositionFrom in class TextUI
        参数：
        a - the text component for which this UI is installed
        b - the position to convert >= 0
        c - the bias for the position
        d - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This may be SwingConstants.WEST, SwingConstants.EAST, SwingConstants.NORTH, or SwingConstants.SOUTH
        e - an array to contain the bias for the returned position
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        抛出：
        BadLocationException

      • damageRange

        public void damageRange(JTextComponent a,
               int b,
               int c)
        Invokes the damageRange method on each UI handled by this object.
        指定者：
        damageRange in class TextUI
        b - the beginning of the range >= 0
        c - the end of the range >= p0

      • damageRange

        public void damageRange(JTextComponent a,
               int b,
               int c,
               Position.Bias d,
               Position.Bias e)
        Invokes the damageRange method on each UI handled by this object.
        指定者：
        damageRange in class TextUI
        b - the beginning of the range >= 0
        c - the end of the range >= p0

      • getEditorKit

        public EditorKit getEditorKit(JTextComponent a)
        Invokes the getEditorKit method on each UI handled by this object.
        指定者：
        getEditorKit in class TextUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getRootView

        public View getRootView(JTextComponent a)
        Invokes the getRootView method on each UI handled by this object.
        指定者：
        getRootView in class TextUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MultiToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiToolBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.multi.MultiToolBarUI

  • public class MultiToolBarUI
extends ToolBarUI
    A multiplexing UI used to combine ToolBarUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiToolBarUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiToolBarUI

        public MultiToolBarUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oanxigxngxa..xaan"hhsb n,,p ra" . aaf. c e


MultiToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiToolTipUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.multi.MultiToolTipUI

  • public class MultiToolTipUI
extends ToolTipUI
    A multiplexing UI used to combine ToolTipUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiToolTipUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiToolTipUI

        public MultiToolTipUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oiaah"


MultiTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiTreeUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.multi.MultiTreeUI

  • public class MultiTreeUI
extends TreeUI
    A multiplexing UI used to combine TreeUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiTreeUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void cancelEditing(JTree a)
      Invokes the cancelEditing method on each UI handled by this object.
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      TreePath getClosestPathForLocation(JTree a, int b, int c)
      Invokes the getClosestPathForLocation method on each UI handled by this object.
      TreePath getEditingPath(JTree a)
      Invokes the getEditingPath method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Rectangle getPathBounds(JTree a, TreePath b)
      Invokes the getPathBounds method on each UI handled by this object.
      TreePath getPathForRow(JTree a, int b)
      Invokes the getPathForRow method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      int getRowCount(JTree a)
      Invokes the getRowCount method on each UI handled by this object.
      int getRowForPath(JTree a, TreePath b)
      Invokes the getRowForPath method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      boolean isEditing(JTree a)
      Invokes the isEditing method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void startEditingAtPath(JTree a, TreePath b)
      Invokes the startEditingAtPath method on each UI handled by this object.
      boolean stopEditing(JTree a)
      Invokes the stopEditing method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiTreeUI

        public MultiTreeUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • getPathBounds

        public Rectangle getPathBounds(JTree a,
                      TreePath b)
        Invokes the getPathBounds method on each UI handled by this object.
        指定者：
        getPathBounds in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getPathForRow

        public TreePath getPathForRow(JTree a,
                     int b)
        Invokes the getPathForRow method on each UI handled by this object.
        指定者：
        getPathForRow in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getRowForPath

        public int getRowForPath(JTree a,
                TreePath b)
        Invokes the getRowForPath method on each UI handled by this object.
        指定者：
        getRowForPath in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getRowCount

        public int getRowCount(JTree a)
        Invokes the getRowCount method on each UI handled by this object.
        指定者：
        getRowCount in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • getClosestPathForLocation

        public TreePath getClosestPathForLocation(JTree a,
                                 int b,
                                 int c)
        Invokes the getClosestPathForLocation method on each UI handled by this object.
        指定者：
        getClosestPathForLocation in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • isEditing

        public boolean isEditing(JTree a)
        Invokes the isEditing method on each UI handled by this object.
        指定者：
        isEditing in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • stopEditing

        public boolean stopEditing(JTree a)
        Invokes the stopEditing method on each UI handled by this object.
        指定者：
        stopEditing in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • cancelEditing

        public void cancelEditing(JTree a)
        Invokes the cancelEditing method on each UI handled by this object.
        指定者：
        cancelEditing in class TreeUI

      • startEditingAtPath

        public void startEditingAtPath(JTree a,
                      TreePath b)
        Invokes the startEditingAtPath method on each UI handled by this object.
        指定者：
        startEditingAtPath in class TreeUI

      • getEditingPath

        public TreePath getEditingPath(JTree a)
        Invokes the getEditingPath method on each UI handled by this object.
        指定者：
        getEditingPath in class TreeUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


MultiViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.multi

类 MultiViewportUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.multi.MultiViewportUI

  • public class MultiViewportUI
extends ViewportUI
    A multiplexing UI used to combine ViewportUIs.

    This file was automatically generated by AutoMulti.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector uis
      The vector containing the real UIs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultiViewportUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(JComponent a, int b, int c)
      Invokes the contains method on each UI handled by this object.
      static ComponentUI createUI(JComponent a)
      Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
      Accessible getAccessibleChild(JComponent a, int b)
      Invokes the getAccessibleChild method on each UI handled by this object.
      int getAccessibleChildrenCount(JComponent a)
      Invokes the getAccessibleChildrenCount method on each UI handled by this object.
      Dimension getMaximumSize(JComponent a)
      Invokes the getMaximumSize method on each UI handled by this object.
      Dimension getMinimumSize(JComponent a)
      Invokes the getMinimumSize method on each UI handled by this object.
      Dimension getPreferredSize(JComponent a)
      Invokes the getPreferredSize method on each UI handled by this object.
      ComponentUI[] getUIs()
      Returns the list of UIs associated with this multiplexing UI.
      void installUI(JComponent a)
      Invokes the installUI method on each UI handled by this object.
      void paint(Graphics a, JComponent b)
      Invokes the paint method on each UI handled by this object.
      void uninstallUI(JComponent a)
      Invokes the uninstallUI method on each UI handled by this object.
      void update(Graphics a, JComponent b)
      Invokes the update method on each UI handled by this object.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • uis

        protected Vector uis
        The vector containing the real UIs. This is populated in the call to createUI, and can be obtained by calling the getUIs method. The first element is guaranteed to be the real UI obtained from the default look and feel.

    • 构造方法详细信息

      • MultiViewportUI

        public MultiViewportUI()

    • 方法详细信息

      • getUIs

        public ComponentUI[] getUIs()
        Returns the list of UIs associated with this multiplexing UI. This allows processing of the UIs by an application aware of multiplexing UIs on components.

      • contains

        public boolean contains(JComponent a,
               int b,
               int c)
        Invokes the contains method on each UI handled by this object.
        重载：
        contains in class ComponentUI
        参数：
        a - the component where the x,y location is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        b - the x coordinate of the point
        c - the y coordinate of the point
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.contains(int, int), Component.contains(int, int)

      • update

        public void update(Graphics a,
          JComponent b)
        Invokes the update method on each UI handled by this object.
        重载：
        update in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

      • createUI

        public static ComponentUI createUI(JComponent a)
        Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI. Otherwise, just returns the UI object obtained from the default LookAndFeel.

      • installUI

        public void installUI(JComponent a)
        Invokes the installUI method on each UI handled by this object.
        重载：
        installUI in class ComponentUI
        参数：
        a - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent a)
        Invokes the uninstallUI method on each UI handled by this object.
        重载：
        uninstallUI in class ComponentUI
        参数：
        a - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • paint

        public void paint(Graphics a,
         JComponent b)
        Invokes the paint method on each UI handled by this object.
        重载：
        paint in class ComponentUI
        参数：
        a - the Graphics context in which to paint
        b - the component being painted; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent a)
        Invokes the getPreferredSize method on each UI handled by this object.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        a - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent a)
        Invokes the getMinimumSize method on each UI handled by this object.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        a - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent a)
        Invokes the getMaximumSize method on each UI handled by this object.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        a - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount(JComponent a)
        Invokes the getAccessibleChildrenCount method on each UI handled by this object.
        重载：
        getAccessibleChildrenCount in class ComponentUI
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

      • getAccessibleChild

        public Accessible getAccessibleChild(JComponent a,
                            int b)
        Invokes the getAccessibleChild method on each UI handled by this object.
        重载：
        getAccessibleChild in class ComponentUI
        b - zero-based index of child
        返回：
        the value obtained from the first UI, which is the UI obtained from the default LookAndFeel
        另请参见：
        ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>c.(ata(watt.nmv(c


Uses of Package javax.swing.plaf.multi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf.multi

No usage of javax.swing.plaf.multi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h>..//s


Uses of Class javax.swing.plaf.multi.MultiButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiButtonUI

No usage of javax.swing.plaf.multi.MultiButtonUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e aDp癲ph u


Uses of Class javax.swing.plaf.multi.MultiColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiColorChooserUI

No usage of javax.swing.plaf.multi.MultiColorChooserUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cefax-.


Uses of Class javax.swing.plaf.multi.MultiComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiComboBoxUI

No usage of javax.swing.plaf.multi.MultiComboBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>g/s


Uses of Class javax.swing.plaf.multi.MultiDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiDesktopIconUI

No usage of javax.swing.plaf.multi.MultiDesktopIconUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>im">iaa>droyd-u


Uses of Class javax.swing.plaf.multi.MultiDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiDesktopPaneUI

No usage of javax.swing.plaf.multi.MultiDesktopPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>H�


Uses of Class javax.swing.plaf.multi.MultiFileChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiFileChooserUI

No usage of javax.swing.plaf.multi.MultiFileChooserUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>�踥ai�ho礹誹


Uses of Class javax.swing.plaf.multi.MultiInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiInternalFrameUI

No usage of javax.swing.plaf.multi.MultiInternalFrameUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c a.


Uses of Class javax.swing.plaf.multi.MultiLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiLabelUI

No usage of javax.swing.plaf.multi.MultiLabelUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sttＨ�/�o>


Uses of Class javax.swing.plaf.multi.MultiListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiListUI

No usage of javax.swing.plaf.multi.MultiListUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>n_st>�>lt�/<萰ots/�


Uses of Class javax.swing.plaf.multi.MultiLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiLookAndFeel

No usage of javax.swing.plaf.multi.MultiLookAndFeel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eieo


Uses of Class javax.swing.plaf.multi.MultiMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiMenuBarUI

No usage of javax.swing.plaf.multi.MultiMenuBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.multi.MultiMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiMenuItemUI

No usage of javax.swing.plaf.multi.MultiMenuItemUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

 ";爐"dPr<ol =


Uses of Class javax.swing.plaf.multi.MultiOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiOptionPaneUI

No usage of javax.swing.plaf.multi.MultiOptionPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p"yg9Nri- 則a>.p纒9


Uses of Class javax.swing.plaf.multi.MultiPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiPanelUI

No usage of javax.swing.plaf.multi.MultiPanelUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Al/ab;1;p-1


Uses of Class javax.swing.plaf.multi.MultiPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiPopupMenuUI

No usage of javax.swing.plaf.multi.MultiPopupMenuUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r"a-E.s"gr t.ssyal3


Uses of Class javax.swing.plaf.multi.MultiProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiProgressBarUI

No usage of javax.swing.plaf.multi.MultiProgressBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3/"t-b1. h>i糿as


Uses of Class javax.swing.plaf.multi.MultiRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiRootPaneUI

No usage of javax.swing.plaf.multi.MultiRootPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla>y/


Uses of Class javax.swing.plaf.multi.MultiScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiScrollBarUI

No usage of javax.swing.plaf.multi.MultiScrollBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1o,r,竬d


Uses of Class javax.swing.plaf.multi.MultiScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiScrollPaneUI

No usage of javax.swing.plaf.multi.MultiScrollPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ri a�(vca00s�n


Uses of Class javax.swing.plaf.multi.MultiSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiSeparatorUI

No usage of javax.swing.plaf.multi.MultiSeparatorUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a@t>i>lria(svaa�


Uses of Class javax.swing.plaf.multi.MultiSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiSliderUI

No usage of javax.swing.plaf.multi.MultiSliderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla>y/


Uses of Class javax.swing.plaf.multi.MultiSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiSpinnerUI

No usage of javax.swing.plaf.multi.MultiSpinnerUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�>dipu(


Uses of Class javax.swing.plaf.multi.MultiSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiSplitPaneUI

No usage of javax.swing.plaf.multi.MultiSplitPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nr.rl.i pya>簄"s


Uses of Class javax.swing.plaf.multi.MultiTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiTabbedPaneUI

No usage of javax.swing.plaf.multi.MultiTabbedPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nloMu�..lo /猻倢


Uses of Class javax.swing.plaf.multi.MultiTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiTableHeaderUI

No usage of javax.swing.plaf.multi.MultiTableHeaderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

蠺tlDen/s餌rv�e


Uses of Class javax.swing.plaf.multi.MultiTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiTableUI

No usage of javax.swing.plaf.multi.MultiTableUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&襛癰bD


Uses of Class javax.swing.plaf.multi.MultiTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiTextUI

No usage of javax.swing.plaf.multi.MultiTextUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>>t>R>l>RT竜/bs3Ta


Uses of Class javax.swing.plaf.multi.MultiToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiToolBarUI

No usage of javax.swing.plaf.multi.MultiToolBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ ao.lbnrT<"lcg/.�


Uses of Class javax.swing.plaf.multi.MultiToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiToolTipUI

No usage of javax.swing.plaf.multi.MultiToolTipUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0d纁bnH爋A<誫i


Uses of Class javax.swing.plaf.multi.MultiTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiTreeUI

No usage of javax.swing.plaf.multi.MultiTreeUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n />slpla>y/


Uses of Class javax.swing.plaf.multi.MultiViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.multi.MultiViewportUI

No usage of javax.swing.plaf.multi.MultiViewportUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsla"ihc. u. -� /a


 Using the Multiplexing Look and Feel

This document is based on an article originally published in The Swing Connection.

The Multiplexing look and feel lets you supplement an ordinary look and feel (called the default look and feel) with one or more auxiliary look and feels. For example, you could simultaneously provide text-to-speech and Braille outputs, in addition to the ordinary visual output that a Swing-based application generates, by adding two auxiliary look and feels (one for text-to-speech, the other for Braille) to the default look and feel. The default look and feel can be any ordinary look and feel -- the Java or Windows look and feel, for example -- and requires no modifications to work with auxiliary look and feels.

This document has the following sections:

  • ����
  • How to Use Auxiliary Look and Feels
  • Tips for Writing an Auxiliary Look and Feel
    • Dos and Don'ts
    • Extending UIDefaults
    • Examining Other UI Objects
  • How the Multiplexing Look and Feel is Implemented
  • How to Provide a Custom Multiplexing Look and Feel

Before reading further, you should be familiar with the concept of pluggable look and feels. For basic information, see How to Set the Look and Feel, a section in The Java Tutorial. For architectural details, you can read Pluggable look-and-feel architecture, a section within a Swing Connection article.

����

The classes in the javax.swing.plaf.multi package implement a multiplexing look and feel. A multiplexing look and feel transparently creates -- and simultaneously supports -- UI objects from several different look and feels in response to a component requesting its UI object (with the getUI method).

Without a multiplexing look and feel, a developer who wanted to enhance a particular look and feel would need to extend the classes supporting that look and feel. For example, to add text-to-speech support to the Java look and feel without using a multiplexing look and feel, the developer would need to create a group of classes that extend those of the Java look and feel, and add text-to-speech support to the new classes. If the developer also wanted to add text-to-speech support to other look and feels, such as Motif or Windows, the developers would need to create subclasses of those classes as well.

This approach has at least two shortcomings:

  • First, each subclass must use what is essentially a copy of the same code, potentially creating a difficult support situation for the developer.
  • Second, and more significantly for the end user, some application developers might force a particular look and feel to be used. When this approach is used, the end user can't even use the enhanced look and feel.

A multiplexing look and feel both these problems simultaneously because it allows multiple look and feels to be combined. The first problem (having to use what amounts to a second copy of the same code) is solved because the developer can create a specialized look and feel that can then be combined with other look and feels.

The second problem (having to force the use of a particular look and feel) is solved because a specialized look and feel can be used with whatever default look and feel the application may have locked in place.

The default multiplexing look and feel implementation, represented by the MultiLookAndFeel class in the javax.swing.plaf.multi package, is called (unsurprisingly) the Multiplexing look and feel.

How to Use Auxiliary Look and Feels

It's easy to use auxiliary look and feels with Swing. To instruct Swing to use the Multiplexing look and feel, all an application has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.auxiliarylaf property. Swing treats the swing.auxiliarylaf property as a comma-separated list of LookAndFeel subclasses that specify what auxiliary look and feels should be used in addition to the default look and feel. If at least one valid LookAndFeel subclass is specified in the swing.auxiliarylaf property, Swing automatically uses the Multiplexing look and feel to load and support the default and auxiliary look and feels.

For example, let's assume that an application makes use of a look and feel that supports text-to-speech feedback, and also uses an look and feel that adds support for a device that emits perfume. Let's assume that the text-to-speech look and feel is named com.myco.TextTalkerLookAndFeel, and the look and feel that adds support for perfume is named com.smellco.OlfactoryLookAndFeel.

To tell Swing to use both these look and feels -- and to use a default look and feel at the same time -- your application could simply add the following line to the $JDKHOME/lib/swing.properties file:

    swing.auxiliarylaf=com.myco.TextTalkerLookAndFeel,
        com.smellco.OlfactoryLookAndFeel

This statement tells Swing to obtain a component's UI from the Multiplexing look and feel automatically, instead of obtaining it directly from the default look and feel. The resulting multiplexing UI is a small delegate that obtains and maintains UIs from the default and auxiliary look and feels. As a result, when a method is invoked in a multiplexing UI object, the multiplexing UI invokes the same method on each of the UIs obtained from the default and auxiliary look and feels.

Tips for Writing an Auxiliary Look and Feel

An auxiliary look and feel is like any other look and feel, except that it doesn't have to provide the complete support that a default look and feel must. For example, an auxiliary look and feel that supports just text-to-speech feedback doesn't need to provide any code for painting. Also, it might not need to support all components -- JSeparators, for example, might be ignored.

Auxiliary look and feels tend to be simple, so developing one can be easier than developing a visual look and feel. The developer can concentrate solely on providing the specialized functionality.

Because the primary purpose of an auxiliary look and feel is to enhance the default look and feel, auxiliary look and feels tend be nonvisual. Since an auxiliary look and feel is a genuine look and feel, however, there is nothing to prevent it from rendering information on the display.

Just like for any other look and feel, you implement an auxiliary look and feel by writing a subclass of javax.swing.LookAndFeel and creating subclasses of the FooUI classes defined in the javax.swing.plaf package.

Dos and Don'ts

The following paragraphs provide some general recommendations for developing auxiliary look and feels.

Use the installUI method to perform all initialization, and the uninstallUI method to perform all cleanup.

    The installUI and uninstallUI methods are invoked when a component's look and feel is set. The installUI method gives the new UI object a chance to add listeners on the component and its data model. Similarly, the uninstallUI method lets the previous UI object remove its listeners.

Don't extend visual look and feels.

    We recommended that you don't implement UI classes of an auxiliary look and feel as subclasses of the UI classes of a visual look and feel.�Why not? Because they might accidentally inherit code that installs listeners on a component object or renders the component on the display.�As a result, your auxiliary look and feel would compete with the default look and feel rather than cooperating with it.

    Instead, we recommend that the UI classes of an auxiliary look and feel directly extend the abstract UI classes in the javax.swing.plaf package.�By using this strategy, the developer of an auxiliary look and feel can avoid competing with the default look and feel.

Override all UI-specific methods your UI classes inherit.

    We recommend that each UI class of an auxiliary look and feel override the methods defined in the javax.swing.plaf UI classes it descends from The reasons for this recommendation are similar to those for not extending a visual look and feel. For example, the ComponentUI class, from which all UI classes descend, provides a default implementation for the update method. This default implementation paints on the display if the component is opaque. If a UI class from a non-visual auxiliary look and feel does not override this method, all opaque components appear as blank areas on the screen!

Extending UIDefaults

In many cases, you might want an auxiliary look and feel to be "incomplete."�That is, you might not need to support the complete set of components. For example, an auxiliary look and feel might choose to provide a ButtonUI subclass but no LabelUI subclass. This option is allowed, and the multiplexing look and feel gracefully handles such situations.

By default, however, Swing issues an error message when it asks a look and feel for a UI object and the look and feel does not support that UI. This message can be annoying, especially to auxiliary look-and-feel developers who don't want to support a particular component.

Fortunately, you can prevent this error message by creating a subclass of the UIDefaults class and returning an instance of it from the getDefaults method of your LookAndFeel class. For example:

public class MyAuxLookAndFeel
              extends LookAndFeel {
��� ...
��� public UIDefaults getDefaults() {
������� UIDefaults table =
new MyAuxUIDefaults();
������� Object[] uiDefaults = {
��������� "ButtonUI", "MyAuxButtonUI",
��������� ...
������� }
������� table.putDefaults(uiDefaults);
������� return table;
��� }
}

class MyAuxUIDefaults extends UIDefaults {
��� protected void getUIError(String msg) {
������� //System.err.println
//   ("An
              annoying message!");
��� }
}

In the preceding example, an auxiliary look and feel named MyAux creates a UIDefaults subclass that overrides the getUIError method.�The getUIError method is the method that is invoked when Swing cannot find a UI object in a look and feel.�By merely doing nothing in this method, you can avoid the error message.

Examining Other UI Objects

In rare instances, a UI object from an auxiliary look and feel may be interested in the default UI object used by the component.�In these cases, the UI object from auxiliary look and feel can obtain the UI from a component by calling its getUI method.�The returned UI is an instance of one of the multiplexing look and feel UI classes (for example, MultiButtonUI). The UI object from the auxiliary look and feel can call the getUIs method of the returned object to obtain an array containing a complete list of all UI objects handled by the multiplexing UI. The first element is guaranteed to be the UI created from the default look and feel.

How the Multiplexing Look and Feel Is Implemented

The Multiplexing look and feel (represented by javax.swing.plaf.multi.MultiLookAndFeel) is meant to be transparent to all developers and users.�It should "just work" -- and it is used only when the user tells Swing to use an auxiliary look and feel.

When the Multiplexing look and feel is in use, the type of the UI object associated with each component depends on whether any of the auxiliary look and feels currently in use support the component. If so, the component's UI object is an instance of a multiplexing UI. If only the default look and feel supports the component, then the component gets a UI object from the default look and feel, just as if no auxiliary look and feels were installed.

A multiplexing UI object obtains and maintains UI objects from the default and auxiliary look and feels, referring to these UIs in the following manner:

  • The UI object from the default look and feel is always the first to be created. After that, a UI object is created from each auxiliary look and feel in the order they are specified in the swing.auxiliarylaf property.

  • When a method that requests information from a UI object is invoked, the multiplexing UI object invokes the method on all the UI objects, but returns only the results from the UI for the default look and feel. For example, when the getPreferredSize method is invoked on a multiplexing UI, the UI returns only the results of invoking getPreferredSize on the UI obtained from the default look and feel. The getPreferredSize method is also invoked on the UI object for each auxiliary look and feel, but the return values are ignored.

  • When a method that does not request information from the UI object is invoked, the multiplexing UI object invokes that method on all UIs -- on the UI object obtained from the default look and feel and on all the UIs obtained from the auxiliary look and feels, as well. For example, invoking the installUI method on a multiplexing UI causes the multiplexing UI to invoke installUI on the UI obtained from the default look and feel and the UIs obtained from the auxiliary factories.

In all cases, the UI object obtained from the default look and feel is acted upon first, and then the auxiliary look and feels are acted upon in the order they are specified in the swing.auxiliarylaf property.

How to Provide a Custom Multiplexing Look and Feel

While we hope the behavior of the Multiplexing look and feel is flexible enough not to require an alternative multiplexing look and feel, Swing allows the user to specify another multiplexing look and feel to use.

To do that, all the user has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.plaf.multiplexinglaf property.�Swing then treats the swing.plaf.multiplexinglaf property as a LookAndFeel subclass that supports multiplexing.

For example, if a user has a multiplexing look and feel represented by com.myco.SuperMultiLookAndFeel that is a better match for their needs than the Multiplexing look and feel (javax.swing.plaf.multi.MultiLookAndFeel), the user could include the following line in $JDKHOME/lib/swing.properties:

swing.plaf.multiplexinglaf = com.myco.SuperMultiLookAndFeel

This statement instructs Swing to use com.myco.SuperMultiLookAndFeel instead of javax.swing.plaf.multi.MultiLookAndFeel. But if you use this kind of statement, be careful, because the suppliers of auxiliary look and feels will most likely have developed and tested against our Multiplexing look and feel.


AbstractRegionPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.nimbus

类 AbstractRegionPainter

  • java.lang.Object
    • javax.swing.plaf.nimbus.AbstractRegionPainter
  • 所有已实现的接口：
    Painter<JComponent>

    public abstract class AbstractRegionPainter
extends Object
implements Painter<JComponent>
    Convenient base class for defining Painter instances for rendering a region or component in Nimbus.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected static class  AbstractRegionPainter.PaintContext
      A class encapsulating state useful when painting.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected AbstractRegionPainter()
      Create a new AbstractRegionPainter

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void configureGraphics(Graphics2D g)
      Configures the given Graphics2D.
      protected float decodeAnchorX(float x, float dx)
      Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded X value of the control point, and the offset distance to the anchor from that control point.
      protected float decodeAnchorY(float y, float dy)
      Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded Y value of the control point, and the offset distance to the anchor from that control point.
      protected Color decodeColor(Color color1, Color color2, float midPoint)
      Decodes and returns a color, which is derived from a offset between two other colors.
      protected Color decodeColor(String key, float hOffset, float sOffset, float bOffset, int aOffset)
      Decodes and returns a color, which is derived from a base color in UI defaults.
      protected LinearGradientPaint decodeGradient(float x1, float y1, float x2, float y2, float[] midpoints, Color[] colors)
      Given parameters for creating a LinearGradientPaint, this method will create and return a linear gradient paint.
      protected RadialGradientPaint decodeRadialGradient(float x, float y, float r, float[] midpoints, Color[] colors)
      Given parameters for creating a RadialGradientPaint, this method will create and return a radial gradient paint.
      protected float decodeX(float x)
      Decodes and returns a float value representing the actual pixel location for the given encoded X value.
      protected float decodeY(float y)
      Decodes and returns a float value representing the actual pixel location for the given encoded y value.
      protected abstract void doPaint(Graphics2D g, JComponent c, int width, int height, Object[] extendedCacheKeys)
      Actually performs the painting operation.
      protected Color getComponentColor(JComponent c, String property, Color defaultColor, float saturationOffset, float brightnessOffset, int alphaOffset)
      Get a color property from the given JComponent.
      protected Object[] getExtendedCacheKeys(JComponent c)
      Get any extra attributes which the painter implementation would like to include in the image cache lookups.
      protected abstract AbstractRegionPainter.PaintContext getPaintContext()
      Gets the PaintContext for this painting operation.
      void paint(Graphics2D g, JComponent c, int w, int h)
      Renders to the given Graphics2D object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractRegionPainter

        protected AbstractRegionPainter()
        Create a new AbstractRegionPainter

    • 方法详细信息

      • paint

        public final void paint(Graphics2D g,
         JComponent c,
         int w,
         int h)
        从接口复制的描述： Painter

        Renders to the given Graphics2D object. Implementations of this method may modify state on the Graphics2D, and are not required to restore that state upon completion. In most cases, it is recommended that the caller pass in a scratch graphics object. The Graphics2D must never be null.

        State on the graphics object may be honored by the paint method, but may not be. For instance, setting the antialiasing rendering hint on the graphics may or may not be respected by the Painter implementation.

        The supplied object parameter acts as an optional configuration argument. For example, it could be of type Component. A Painter that expected it could then read state from that Component and use the state for painting. For example, an implementation may read the backgroundColor and use that.

        Generally, to enhance reusability, most standard Painters ignore this parameter. They can thus be reused in any context. The object may be null. Implementations must not throw a NullPointerException if the object parameter is null.

        Finally, the width and height arguments specify the width and height that the Painter should paint into. More specifically, the specified width and height instruct the painter that it should paint fully within this width and height. Any specified clip on the g param will further constrain the region.

        For example, suppose I have a Painter implementation that draws a gradient. The gradient goes from white to black. It "stretches" to fill the painted region. Thus, if I use this Painter to paint a 500 x 500 region, the far left would be black, the far right would be white, and a smooth gradient would be painted between. I could then, without modification, reuse the Painter to paint a region that is 20x20 in size. This region would also be black on the left, white on the right, and a smooth gradient painted between.

        指定者：
        paint in interface Painter<JComponent>
        参数：
        g - The Graphics2D to render to. This must not be null.
        c - an optional configuration parameter. This may be null.
        w - width of the area to paint.
        h - height of the area to paint.

      • getExtendedCacheKeys

        protected Object[] getExtendedCacheKeys(JComponent c)
        Get any extra attributes which the painter implementation would like to include in the image cache lookups. This is checked for every call of the paint(g, c, w, h) method.
        参数：
        c - The component on the current paint call
        返回：
        Array of extra objects to be included in the cache key

      • getPaintContext

        protected abstract AbstractRegionPainter.PaintContext getPaintContext()

        Gets the PaintContext for this painting operation. This method is called on every paint, and so should be fast and produce no garbage. The PaintContext contains information such as cache hints. It also contains data necessary for decoding points at runtime, such as the stretching insets, the canvas size at which the encoded points were defined, and whether the stretching insets are inverted.

        This method allows for subclasses to package the painting of different states with possibly different canvas sizes, etc, into one AbstractRegionPainter implementation.

        返回：
        a PaintContext associated with this paint operation.

      • configureGraphics

        protected void configureGraphics(Graphics2D g)

        Configures the given Graphics2D. Often, rendering hints or compositiing rules are applied to a Graphics2D object prior to painting, which should affect all of the subsequent painting operations. This method provides a convenient hook for configuring the Graphics object prior to rendering, regardless of whether the render operation is performed to an intermediate buffer or directly to the display.

        参数：
        g - The Graphics2D object to configure. Will not be null.

      • doPaint

        protected abstract void doPaint(Graphics2D g,
           JComponent c,
           int width,
           int height,
           Object[] extendedCacheKeys)
        Actually performs the painting operation. Subclasses must implement this method. The graphics object passed may represent the actual surface being rendererd to, or it may be an intermediate buffer. It has also been pre-translated. Simply render the component as if it were located at 0, 0 and had a width of width and a height of height. For performance reasons, you may want to read the clip from the Graphics2D object and only render within that space.
        参数：
        g - The Graphics2D surface to paint to
        c - The JComponent related to the drawing event. For example, if the region being rendered is Button, then c will be a JButton. If the region being drawn is ScrollBarSlider, then the component will be JScrollBar. This value may be null.
        width - The width of the region to paint. Note that in the case of painting the foreground, this value may differ from c.getWidth().
        height - The height of the region to paint. Note that in the case of painting the foreground, this value may differ from c.getHeight().
        extendedCacheKeys - The result of the call to getExtendedCacheKeys()

      • decodeX

        protected final float decodeX(float x)
        Decodes and returns a float value representing the actual pixel location for the given encoded X value.
        参数：
        x - an encoded x value (0...1, or 1...2, or 2...3)
        返回：
        the decoded x value
        抛出：
        IllegalArgumentException - if x < 0 or x > 3

      • decodeY

        protected final float decodeY(float y)
        Decodes and returns a float value representing the actual pixel location for the given encoded y value.
        参数：
        y - an encoded y value (0...1, or 1...2, or 2...3)
        返回：
        the decoded y value
        抛出：
        IllegalArgumentException - if y < 0 or y > 3

      • decodeAnchorX

        protected final float decodeAnchorX(float x,
                  float dx)
        Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded X value of the control point, and the offset distance to the anchor from that control point.
        参数：
        x - an encoded x value of the bezier control point (0...1, or 1...2, or 2...3)
        dx - the offset distance to the anchor from the control point x
        返回：
        the decoded x location of the control point
        抛出：
        IllegalArgumentException - if x < 0 or x > 3

      • decodeAnchorY

        protected final float decodeAnchorY(float y,
                  float dy)
        Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded Y value of the control point, and the offset distance to the anchor from that control point.
        参数：
        y - an encoded y value of the bezier control point (0...1, or 1...2, or 2...3)
        dy - the offset distance to the anchor from the control point y
        返回：
        the decoded y position of the control point
        抛出：
        IllegalArgumentException - if y < 0 or y > 3

      • decodeColor

        protected final Color decodeColor(String key,
                float hOffset,
                float sOffset,
                float bOffset,
                int aOffset)
        Decodes and returns a color, which is derived from a base color in UI defaults.
        参数：
        key - A key corrosponding to the value in the UI Defaults table of UIManager where the base color is defined
        hOffset - The hue offset used for derivation.
        sOffset - The saturation offset used for derivation.
        bOffset - The brightness offset used for derivation.
        aOffset - The alpha offset used for derivation. Between 0...255
        返回：
        The derived color, whos color value will change if the parent uiDefault color changes.

      • decodeColor

        protected final Color decodeColor(Color color1,
                Color color2,
                float midPoint)
        Decodes and returns a color, which is derived from a offset between two other colors.
        参数：
        color1 - The first color
        color2 - The second color
        midPoint - The offset between color 1 and color 2, a value of 0.0 is color 1 and 1.0 is color 2;
        返回：
        The derived color

      • decodeGradient

        protected final LinearGradientPaint decodeGradient(float x1,
                                 float y1,
                                 float x2,
                                 float y2,
                                 float[] midpoints,
                                 Color[] colors)
        Given parameters for creating a LinearGradientPaint, this method will create and return a linear gradient paint. One primary purpose for this method is to avoid creating a LinearGradientPaint where the start and end points are equal. In such a case, the end y point is slightly increased to avoid the overlap.
        参数：
        x1 -
        y1 -
        x2 -
        y2 -
        midpoints -
        colors -
        返回：
        a valid LinearGradientPaint. This method never returns null.
        抛出：
        NullPointerException - if midpoints array is null, or colors array is null,
        IllegalArgumentException - if start and end points are the same points, or midpoints.length != colors.length, or colors is less than 2 in size, or a midpoints value is less than 0.0 or greater than 1.0, or the midpoints are not provided in strictly increasing order

      • decodeRadialGradient

        protected final RadialGradientPaint decodeRadialGradient(float x,
                                       float y,
                                       float r,
                                       float[] midpoints,
                                       Color[] colors)
        Given parameters for creating a RadialGradientPaint, this method will create and return a radial gradient paint. One primary purpose for this method is to avoid creating a RadialGradientPaint where the radius is non-positive. In such a case, the radius is just slightly increased to avoid 0.
        参数：
        x -
        y -
        r -
        midpoints -
        colors -
        返回：
        a valid RadialGradientPaint. This method never returns null.
        抛出：
        NullPointerException - if midpoints array is null, or colors array is null
        IllegalArgumentException - if r is non-positive, or midpoints.length != colors.length, or colors is less than 2 in size, or a midpoints value is less than 0.0 or greater than 1.0, or the midpoints are not provided in strictly increasing order

      • getComponentColor

        protected final Color getComponentColor(JComponent c,
                      String property,
                      Color defaultColor,
                      float saturationOffset,
                      float brightnessOffset,
                      int alphaOffset)
        Get a color property from the given JComponent. First checks for a getXXX() method and if that fails checks for a client property with key property. If that still fails to return a Color then defaultColor is returned.
        参数：
        c - The component to get the color property from
        property - The name of a bean style property or client property
        defaultColor - The color to return if no color was obtained from the component.
        返回：
        The color that was obtained from the component or defaultColor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractRegionPainter.PaintContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.plaf.nimbus

类 AbstractRegionPainter.PaintContext

  • java.lang.Object
    • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
  • 封闭类：
    AbstractRegionPainter

    protected static class AbstractRegionPainter.PaintContext
extends Object
    A class encapsulating state useful when painting. Generally, instances of this class are created once, and reused for each paint request without modification. This class contains values useful when hinting the cache engine, and when decoding control points and bezier curve anchors.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      protected static class  | AbstractRegionPainter.PaintContext.CacheMode

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractRegionPainter.PaintContext(Insets insets, Dimension canvasSize, boolean inverted)
      Creates a new PaintContext which does not attempt to cache or scale any cached images.
      AbstractRegionPainter.PaintContext(Insets insets, Dimension canvasSize, boolean inverted, AbstractRegionPainter.PaintContext.CacheMode cacheMode, double maxH, double maxV)
      Creates a new PaintContext.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractRegionPainter.PaintContext

        public AbstractRegionPainter.PaintContext(Insets insets,
                                  Dimension canvasSize,
                                  boolean inverted)
        Creates a new PaintContext which does not attempt to cache or scale any cached images.
        参数：
        insets - The stretching insets. May be null. If null, then assumed to be 0, 0, 0, 0.
        canvasSize - The size of the canvas used when encoding the various x/y values. May be null. If null, then it is assumed that there are no encoded values, and any calls to one of the "decode" methods will return the passed in value.
        inverted - Whether to "invert" the meaning of the 9-square grid and stretching insets

      • AbstractRegionPainter.PaintContext

        public AbstractRegionPainter.PaintContext(Insets insets,
                                  Dimension canvasSize,
                                  boolean inverted,
                                  AbstractRegionPainter.PaintContext.CacheMode cacheMode,
                                  double maxH,
                                  double maxV)
        Creates a new PaintContext.
        参数：
        insets - The stretching insets. May be null. If null, then assumed to be 0, 0, 0, 0.
        canvasSize - The size of the canvas used when encoding the various x/y values. May be null. If null, then it is assumed that there are no encoded values, and any calls to one of the "decode" methods will return the passed in value.
        inverted - Whether to "invert" the meaning of the 9-square grid and stretching insets
        cacheMode - A hint as to which caching mode to use. If null, then set to no caching.
        maxH - The maximium scale in the horizontal direction to use before punting and redrawing from scratch. For example, if maxH is 2, then we will attempt to scale any cached images up to 2x the canvas width before redrawing from scratch. Reasonable maxH values may improve painting performance. If set too high, then you may get poor looking graphics at higher zoom levels. Must be >= 1.
        maxV - The maximium scale in the vertical direction to use before punting and redrawing from scratch. For example, if maxV is 2, then we will attempt to scale any cached images up to 2x the canvas height before redrawing from scratch. Reasonable maxV values may improve painting performance. If set too high, then you may get poor looking graphics at higher zoom levels. Must be >= 1.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pm:faf ftfe"ttp/t ii===O TO=R BNR= -=B>


AbstractRegionPainter.PaintContext.CacheMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing.plaf.nimbus

Enum AbstractRegionPainter.PaintContext.CacheMode

  • java.lang.Object
    • java.lang.Enum<AbstractRegionPainter.PaintContext.CacheMode>
      • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode
  • 所有已实现的接口：
    Serializable, Comparable<AbstractRegionPainter.PaintContext.CacheMode>
    封闭类：
    AbstractRegionPainter.PaintContext

    protected static enum AbstractRegionPainter.PaintContext.CacheMode
extends Enum<AbstractRegionPainter.PaintContext.CacheMode>

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      FIXED_SIZES
      NINE_SQUARE_SCALE
      NO_CACHING

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static AbstractRegionPainter.PaintContext.CacheMode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AbstractRegionPainter.PaintContext.CacheMode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • NO_CACHING

        public static final AbstractRegionPainter.PaintContext.CacheMode NO_CACHING

      • FIXED_SIZES

        public static final AbstractRegionPainter.PaintContext.CacheMode FIXED_SIZES

      • NINE_SQUARE_SCALE

        public static final AbstractRegionPainter.PaintContext.CacheMode NINE_SQUARE_SCALE

    • 方法详细信息

      • values

        public static AbstractRegionPainter.PaintContext.CacheMode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AbstractRegionPainter.PaintContext.CacheMode c : AbstractRegionPainter.PaintContext.CacheMode.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AbstractRegionPainter.PaintContext.CacheMode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

th


javax.swing.plaf.nimbus

Classes

  • AbstractRegionPainter
  • AbstractRegionPainter.PaintContext
  • NimbusLookAndFeel
  • NimbusStyle
  • State

Enums

  • AbstractRegionPainter.PaintContext.CacheMode
i


javax.swing.plaf.nimbus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf.nimbus

Provides user interface objects built according to the cross-platform Nimbus look and feel.

请参见： 描述

  • Class Summary
    类 描述
    AbstractRegionPainter
    Convenient base class for defining Painter instances for rendering a region or component in Nimbus.
    AbstractRegionPainter.PaintContext
    A class encapsulating state useful when painting.
    NimbusLookAndFeel
    The NimbusLookAndFeel class.
    NimbusStyle
    A SynthStyle implementation used by Nimbus.
    State<T extends JComponent>
    Represents a built in, or custom, state in Nimbus.
  • Enum Summary
    Enum 描述
    AbstractRegionPainter.PaintContext.CacheMode

软件包 javax.swing.plaf.nimbus Description

Provides user interface objects built according to the cross-platform Nimbus look and feel.

Nimbus uses instances of the Painter interface to paint components. With each Swing component it associates a foreground and a background Painter, and there may be several painters for different component states.

Nimbus allows customizing many of its properties, including painters, by altering the UIDefaults table. Here's an example:

    UIManager.put("ProgressBar.tileWidth", myTileWidth);
    UIManager.put("ProgressBar[Enabled].backgroundPainter", myBgPainter);
    UIManager.put("ProgressBar[Enabled].foregroundPainter", myFgPainter);

Per-component customization is also possible. When rendering a component, Nimbus checks its client property named "Nimbus.Overrides". The value of this property should be an instance of UIDefaults. Settings from that table override the UIManager settings, but for that particular component instance only. An optional client property, "Nimbus.Overrides.InheritDefaults" of type Boolean, specifies whether the overriding settings should be merged with default ones (true), or replace them (false). By default they are merged:

    JProgressBar bar = new JProgressBar();
    UIDefaults overrides = new UIDefaults();
    overrides.put("ProgressBar.cycleTime", 330);
    ...
    bar.putClientProperty("Nimbus.Overrides", overrides);
    bar.putClientProperty("Nimbus.Overrides.InheritDefaults", false);

Colors in Nimbus are derived from a core set of primary colors. There are also secondary colors, which are derived from primary ones, but serve themselves as base colors for other derived colors. The derivation mechanism allows for runtime customization, i.e. if a primary or secondary color is changed, all colors that are derived from it are automatically updated. The method NimbusLookAndFeel.getDerivedColor(java.lang.String, float, float, float, int, boolean) may be used to create a derived color.

These classes are designed to be used while the corresponding LookAndFeel class has been installed (UIManager.setLookAndFeel(new XXXLookAndFeel())). Using them while a different LookAndFeel is installed may produce unexpected results, including exceptions. Additionally, changing the LookAndFeel maintained by the UIManager without updating the corresponding ComponentUI of any JComponents may also produce unexpected results, such as the wrong colors showing up, and is generally not encouraged.

Note: Most of the Swing API is not thread safe. For details, see Concurrency in Swing, a section in The Java Tutorial.

从以下版本开始：
1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ymg/a//txt


javax.swing.plaf.nimbus Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf.nimbus

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.plaf.nimbus.AbstractRegionPainter (implements javax.swing.Painter<T>)
    • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.synth.SynthLookAndFeel
          • javax.swing.plaf.nimbus.NimbusLookAndFeel
    • javax.swing.plaf.nimbus.State<T>
    • javax.swing.plaf.synth.SynthStyle
      • javax.swing.plaf.nimbus.NimbusStyle

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snp disueeebgssonyaaa


NimbusLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.nimbus

类 NimbusLookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel
        • javax.swing.plaf.synth.SynthLookAndFeel
          • javax.swing.plaf.nimbus.NimbusLookAndFeel
  • 所有已实现的接口：
    Serializable

    public class NimbusLookAndFeel
extends SynthLookAndFeel

    The NimbusLookAndFeel class.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NimbusLookAndFeel()
      Create a new NimbusLookAndFeel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      UIDefaults getDefaults()
      Returns the defaults for this SynthLookAndFeel.
      protected Color getDerivedColor(Color color1, Color color2, float midPoint)
      Decodes and returns a color, which is derived from a offset between two other colors.
      protected Color getDerivedColor(Color color1, Color color2, float midPoint, boolean uiResource)
      Decodes and returns a color, which is derived from an offset between two other colors.
      Color getDerivedColor(String uiDefaultParentName, float hOffset, float sOffset, float bOffset, int aOffset, boolean uiResource)
      Get a derived color, derived colors are shared instances and is color value will change when its parent UIDefault color changes.
      String getDescription()
      Returns a textual description of this look and feel.
      Icon getDisabledIcon(JComponent component, Icon icon)
      Returns an Icon with a disabled appearance.
      String getID()
      Return a string that identifies this look and feel.
      String getName()
      Return a short string that identifies this look and feel.
      static NimbusStyle getStyle(JComponent c, Region r)
      Gets the style associated with the given component and region.
      void initialize()
      Called by UIManager when this look and feel is installed.
      void register(Region region, String prefix)
      Registers a third party component with the NimbusLookAndFeel.
      boolean shouldUpdateStyleOnAncestorChanged()
      Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes.
      protected boolean shouldUpdateStyleOnEvent(PropertyChangeEvent ev)
      Returns whether or not the UIs should update their styles when a particular event occurs.
      void uninitialize()
      Called by UIManager when this look and feel is uninstalled.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthLookAndFeel

        createUI, getRegion, getStyleFactory, isNativeLookAndFeel, isSupportedLookAndFeel, load, load, setStyleFactory, updateStyles

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicLookAndFeel

        createAudioAction, getAudioActionMap, initClassDefaults, initComponentDefaults, initSystemColorDefaults, loadSystemColors, playSound

      • 方法 - 继承于类 javax.swing.LookAndFeel

        getDesktopPropertyValue, getDisabledSelectedIcon, getLayoutStyle, getSupportsWindowDecorations, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninstallBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NimbusLookAndFeel

        public NimbusLookAndFeel()
        Create a new NimbusLookAndFeel.

    • 方法详细信息

      • initialize

        public void initialize()
        Called by UIManager when this look and feel is installed.
        重载：
        initialize in class SynthLookAndFeel
        另请参见：
        LookAndFeel.uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • uninitialize

        public void uninitialize()
        Called by UIManager when this look and feel is uninstalled.
        重载：
        uninitialize in class SynthLookAndFeel
        另请参见：
        LookAndFeel.initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • getDefaults

        public UIDefaults getDefaults()
        Description copied from class: SynthLookAndFeel
        Returns the defaults for this SynthLookAndFeel.
        重载：
        getDefaults in class SynthLookAndFeel
        返回：
        Defaults table.
        另请参见：
        BasicLookAndFeel.initClassDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initSystemColorDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)

      • getStyle

        public static NimbusStyle getStyle(JComponent c,
                   Region r)
        Gets the style associated with the given component and region. This will never return null. If an appropriate component and region cannot be determined, then a default style is returned.
        参数：
        c - a non-null reference to a JComponent
        r - a non-null reference to the region of the component c
        返回：
        a non-null reference to a NimbusStyle.

      • getName

        public String getName()
        Return a short string that identifies this look and feel. This String will be the unquoted String "Nimbus".
        重载：
        getName in class SynthLookAndFeel
        返回：
        a short string identifying this look and feel.

      • getID

        public String getID()
        Return a string that identifies this look and feel. This String will be the unquoted String "Nimbus".
        重载：
        getID in class SynthLookAndFeel
        返回：
        a short string identifying this look and feel.

      • getDescription

        public String getDescription()
        Returns a textual description of this look and feel.
        重载：
        getDescription in class SynthLookAndFeel
        返回：
        textual description of this look and feel.

      • shouldUpdateStyleOnAncestorChanged

        public boolean shouldUpdateStyleOnAncestorChanged()
        Description copied from class: SynthLookAndFeel
        Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes. A subclass that provided a SynthStyleFactory that based the return value from getStyle off the containment hierarchy would override this method to return true.
        重载：
        shouldUpdateStyleOnAncestorChanged in class SynthLookAndFeel
        返回：
        true

      • shouldUpdateStyleOnEvent

        protected boolean shouldUpdateStyleOnEvent(PropertyChangeEvent ev)
        Description copied from class: SynthLookAndFeel
        Returns whether or not the UIs should update their styles when a particular event occurs.
        重载：
        shouldUpdateStyleOnEvent in class SynthLookAndFeel
        参数：
        ev - a PropertyChangeEvent
        返回：
        whether or not the UIs should update their styles
        从以下版本开始：
        1.7

      • register

        public void register(Region region,
            String prefix)

        Registers a third party component with the NimbusLookAndFeel.

        Regions represent Components and areas within Components that act as independent painting areas. Once registered with the NimbusLookAndFeel, NimbusStyles for these Regions can be retrieved via the getStyle method.

        The NimbusLookAndFeel uses a standard naming scheme for entries in the UIDefaults table. The key for each property, state, painter, and other default registered in UIDefaults for a specific Region will begin with the specified prefix

        For example, suppose I had a component named JFoo. Suppose I then registered this component with the NimbusLookAndFeel in this manner:

     laf.register(NimbusFooUI.FOO_REGION, "Foo");

        In this case, I could then register properties for this component with UIDefaults in the following manner:

     UIManager.put("Foo.background", new ColorUIResource(Color.BLACK));
     UIManager.put("Foo.Enabled.backgroundPainter", new FooBackgroundPainter());

        It is also possible to register a named component with Nimbus. For example, suppose you wanted to style the background of a JPanel named "MyPanel" differently from other JPanels. You could accomplish this by doing the following:

     laf.register(Region.PANEL, "\"MyPanel\"");
     UIManager.put("\"MyPanel\".background", new ColorUIResource(Color.RED));
        参数：
        region - The Synth Region that is being registered. Such as Button, or ScrollBarThumb, or NimbusFooUI.FOO_REGION.
        prefix - The UIDefault prefix. For example, could be ComboBox, or if a named components, "MyComboBox", or even something like ToolBar."MyComboBox"."ComboBox.arrowButton"

      • getDisabledIcon

        public Icon getDisabledIcon(JComponent component,
                   Icon icon)
        Description copied from class: LookAndFeel
        Returns an Icon with a disabled appearance. This method is used to generate a disabled Icon when one has not been specified. For example, if you create a JButton and only specify an Icon via setIcon this method will be called to generate the disabled Icon. If null is passed as icon this method returns null.

        Some look and feels might not render the disabled Icon, in which case they will ignore this.

        重载：
        getDisabledIcon in class LookAndFeel
        参数：
        component - JComponent that will display the Icon, may be null
        icon - Icon to generate the disabled icon from
        返回：
        disabled Icon, or null if a suitable Icon can not be generated

      • getDerivedColor

        public Color getDerivedColor(String uiDefaultParentName,
                    float hOffset,
                    float sOffset,
                    float bOffset,
                    int aOffset,
                    boolean uiResource)
        Get a derived color, derived colors are shared instances and is color value will change when its parent UIDefault color changes.
        参数：
        uiDefaultParentName - The parent UIDefault key
        hOffset - The hue offset
        sOffset - The saturation offset
        bOffset - The brightness offset
        aOffset - The alpha offset
        uiResource - True if the derived color should be a UIResource, false if it should not be
        返回：
        The stored derived color

      • getDerivedColor

        protected final Color getDerivedColor(Color color1,
                    Color color2,
                    float midPoint,
                    boolean uiResource)
        Decodes and returns a color, which is derived from an offset between two other colors.
        参数：
        color1 - The first color
        color2 - The second color
        midPoint - The offset between color 1 and color 2, a value of 0.0 is color 1 and 1.0 is color 2;
        uiResource - True if the derived color should be a UIResource
        返回：
        The derived color

      • getDerivedColor

        protected final Color getDerivedColor(Color color1,
                    Color color2,
                    float midPoint)
        Decodes and returns a color, which is derived from a offset between two other colors.
        参数：
        color1 - The first color
        color2 - The second color
        midPoint - The offset between color 1 and color 2, a value of 0.0 is color 1 and 1.0 is color 2;
        返回：
        The derived color, which will be a UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NimbusStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.plaf.nimbus

类 NimbusStyle

  • java.lang.Object
    • javax.swing.plaf.synth.SynthStyle
      • javax.swing.plaf.nimbus.NimbusStyle

  • public final class NimbusStyle
extends SynthStyle

    A SynthStyle implementation used by Nimbus. Each Region that has been registered with the NimbusLookAndFeel will have an associated NimbusStyle. Third party components that are registered with the NimbusLookAndFeel will therefore be handed a NimbusStyle from the look and feel from the #getStyle(JComponent, Region) method.

    This class properly reads and retrieves values placed in the UIDefaults according to the standard Nimbus naming conventions. It will create and retrieve painters, fonts, colors, and other data stored there.

    NimbusStyle also supports the ability to override settings on a per component basis. NimbusStyle checks the component's client property map for "Nimbus.Overrides". If the value associated with this key is an instance of UIDefaults, then the values in that defaults table will override the standard Nimbus defaults in UIManager, but for that component instance only.

    Optionally, you may specify the client property "Nimbus.Overrides.InheritDefaults". If true, this client property indicates that the defaults located in UIManager should first be read, and then replaced with defaults located in the component client properties. If false, then only the defaults located in the component client property map will be used. If not specified, it is assumed to be true.

    You must specify "Nimbus.Overrides" for "Nimbus.Overrides.InheritDefaults" to have any effect. "Nimbus.Overrides" indicates whether there are any overrides, while "Nimbus.Overrides.InheritDefaults" indicates whether those overrides should first be initialized with the defaults from UIManager.

    The NimbusStyle is reloaded whenever a property change event is fired for a component for "Nimbus.Overrides" or "Nimbus.Overrides.InheritDefaults". So for example, setting a new UIDefaults on a component would cause the style to be reloaded.

    The values are only read out of UIManager once, and then cached. If you need to read the values again (for example, if the UI is being reloaded), then discard this NimbusStyle and read a new one from NimbusLookAndFeel using NimbusLookAndFeel.getStyle.

    The primary API of interest in this class for 3rd party component authors are the three methods which retrieve painters: #getBackgroundPainter, #getForegroundPainter, and #getBorderPainter.

    NimbusStyle allows you to specify custom states, or modify the order of states. Synth (and thus Nimbus) has the concept of a "state". For example, a JButton might be in the "MOUSE_OVER" state, or the "ENABLED" state, or the "DISABLED" state. These are all "standard" states which are defined in synth, and which apply to all synth Regions.

    Sometimes, however, you need to have a custom state. For example, you want JButton to render differently if it's parent is a JToolbar. In Nimbus, you specify these custom states by including a special key in UIDefaults. The following UIDefaults entries define three states for this button:

     JButton.States = Enabled, Disabled, Toolbar
     JButton[Enabled].backgroundPainter = somePainter
     JButton[Disabled].background = BLUE
     JButton[Toolbar].backgroundPainter = someOtherPaint

    As you can see, the JButton.States entry lists the states that the JButton style will support. You then specify the settings for each state. If you do not specify the JButton.States entry, then the standard Synth states will be assumed. If you specify the entry but the list of states is empty or null, then the standard synth states will be assumed.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static String | LARGE_KEY
      static double | LARGE_SCALE
      static String | MINI_KEY
      static double | MINI_SCALE
      static String | SMALL_KEY
      static double | SMALL_SCALE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object get(SynthContext ctx, Object key)
      Getter for a region specific style property.
      Painter getBackgroundPainter(SynthContext ctx)
      Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext.
      Painter getBorderPainter(SynthContext ctx)
      Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext.
      protected Color getColorForState(SynthContext ctx, ColorType type)
      Returns the color for the specified state.
      protected Font getFontForState(SynthContext ctx)
      Returns the font for the specified state.
      Painter getForegroundPainter(SynthContext ctx)
      Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext.
      Insets getInsets(SynthContext ctx, Insets in)
      Returns the Insets that are used to calculate sizing information.
      SynthPainter getPainter(SynthContext ctx)
      Returns the SynthPainter that will be used for painting.
      void installDefaults(SynthContext ctx)
      Installs the necessary state from this Style on the JComponent from context.
      boolean isOpaque(SynthContext ctx)
      Returns true if the region is opaque.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthStyle

        getBoolean, getColor, getFont, getGraphicsUtils, getIcon, getInt, getString, uninstallDefaults

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • LARGE_KEY

        public static final String LARGE_KEY
        另请参见：
        Constant Field Values

      • SMALL_KEY

        public static final String SMALL_KEY
        另请参见：
        Constant Field Values

      • MINI_KEY

        public static final String MINI_KEY
        另请参见：
        Constant Field Values

      • LARGE_SCALE

        public static final double LARGE_SCALE
        另请参见：
        Constant Field Values

      • SMALL_SCALE

        public static final double SMALL_SCALE
        另请参见：
        Constant Field Values

      • MINI_SCALE

        public static final double MINI_SCALE
        另请参见：
        Constant Field Values

    • 方法详细信息

      • installDefaults

        public void installDefaults(SynthContext ctx)
        Description copied from class: SynthStyle
        Installs the necessary state from this Style on the JComponent from context.
        重载：
        installDefaults in class SynthStyle
        参数：
        ctx - SynthContext identifying component to install properties to.

      • getInsets

        public Insets getInsets(SynthContext ctx,
               Insets in)
        Description copied from class: SynthStyle
        Returns the Insets that are used to calculate sizing information.
        重载：
        getInsets in class SynthStyle
        参数：
        ctx - SynthContext identifying requester
        in - Insets to place return value in.
        返回：
        Sizing Insets.

      • getColorForState

        protected Color getColorForState(SynthContext ctx,
                     ColorType type)
        Description copied from class: SynthStyle
        Returns the color for the specified state. This should NOT call any methods on the JComponent.
        指定者：
        getColorForState in class SynthStyle
        参数：
        ctx - SynthContext identifying requester
        type - Type of color being requested.
        返回：
        Color to render with

      • getFontForState

        protected Font getFontForState(SynthContext ctx)
        Description copied from class: SynthStyle
        Returns the font for the specified state. This should NOT call any method on the JComponent.
        指定者：
        getFontForState in class SynthStyle
        参数：
        ctx - SynthContext identifying requester
        返回：
        Font to render with

      • getPainter

        public SynthPainter getPainter(SynthContext ctx)
        Description copied from class: SynthStyle
        Returns the SynthPainter that will be used for painting. This may return null.
        重载：
        getPainter in class SynthStyle
        参数：
        ctx - SynthContext identifying requester
        返回：
        SynthPainter to use

      • isOpaque

        public boolean isOpaque(SynthContext ctx)
        Description copied from class: SynthStyle
        Returns true if the region is opaque.
        重载：
        isOpaque in class SynthStyle
        参数：
        ctx - SynthContext identifying requester
        返回：
        true if region is opaque.

      • get

        public Object get(SynthContext ctx,
         Object key)
        Description copied from class: SynthStyle
        Getter for a region specific style property.
        重载：
        get in class SynthStyle
        参数：
        ctx -
        key - must not be null
        返回：
        Value of the named property

      • getBackgroundPainter

        public Painter getBackgroundPainter(SynthContext ctx)
        Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext. This method does appropriate fallback searching, as described in #get.
        参数：
        ctx - The SynthContext. Must not be null.
        返回：
        The background painter associated for the given state, or null if none could be found.

      • getForegroundPainter

        public Painter getForegroundPainter(SynthContext ctx)
        Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext. This method does appropriate fallback searching, as described in #get.
        参数：
        ctx - The SynthContext. Must not be null.
        返回：
        The foreground painter associated for the given state, or null if none could be found.

      • getBorderPainter

        public Painter getBorderPainter(SynthContext ctx)
        Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext. This method does appropriate fallback searching, as described in #get.
        参数：
        ctx - The SynthContext. Must not be null.
        返回：
        The border painter associated for the given state, or null if none could be found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d/tdos rs rcc rr e >p)p<


State

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.nimbus

类 State<T extends JComponent>

  • java.lang.Object
    • javax.swing.plaf.nimbus.State<T>

  • public abstract class State<T extends JComponent>
extends Object

    Represents a built in, or custom, state in Nimbus.

    Synth provides several built in states, which are:

    • Enabled
    • Mouse Over
    • Pressed
    • Disabled
    • Focused
    • Selected
    • Default

    However, there are many more states that could be described in a LookAndFeel, and it would be nice to style components differently based on these different states. For example, a progress bar could be "indeterminate". It would be very convenient to allow this to be defined as a "state".

    This class, State, is intended to be used for such situations. Simply implement the abstract #isInState method. It returns true if the given JComponent is "in this state", false otherwise. This method will be called many times in performance sensitive loops. It must execute very quickly.

    For example, the following might be an implementation of a custom "Indeterminate" state for JProgressBars:

     public final class IndeterminateState extends State<JProgressBar> {
         public IndeterminateState() {
             super("Indeterminate");
         }

         @Override
         protected boolean isInState(JProgressBar c) {
             return c.isIndeterminate();
         }
     }

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected State(String name)
      Create a new custom State.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract boolean isInState(T c)
      Gets whether the specified JComponent is in the custom state represented by this class.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • State

        protected State(String name)

        Create a new custom State. Specify the name for the state. The name should be unique within the states set for any one particular component. The name of the state should coincide with the name used in UIDefaults.

        For example, the following would be correct:

     defaults.put("Button.States", "Enabled, Foo, Disabled");
     defaults.put("Button.Foo", new FooState("Foo"));
        参数：
        name - a simple user friendly name for the state, such as "Indeterminate" or "EmbeddedPanel" or "Blurred". It is customary to use camel case, with the first letter capitalized.

    • 方法详细信息

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • isInState

        protected abstract boolean isInState(T c)

        Gets whether the specified JComponent is in the custom state represented by this class. This is an extremely performance sensitive loop. Please take proper precautions to ensure that it executes quickly.

        Nimbus uses this method to help determine what state a JComponent is in. For example, a custom State could exist for JProgressBar such that it would return true when the progress bar is indeterminate. Such an implementation of this method would simply be:

         return c.isIndeterminate();
        参数：
        c - the JComponent to test. This will never be null.
        返回：
        true if c is in the custom state represented by this State instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nj-i.e&!rkwe<>llsa/t.aoyeinf


Uses of Package javax.swing.plaf.nimbus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf.nimbus

  • Packages that use javax.swing.plaf.nimbus
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
  • Classes in javax.swing.plaf.nimbus used by javax.swing.plaf.nimbus
    类与描述
    AbstractRegionPainter.PaintContext
    A class encapsulating state useful when painting.
    AbstractRegionPainter.PaintContext.CacheMode
    NimbusStyle
    A SynthStyle implementation used by Nimbus.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

../r>ihil<<< /..=lssuas/


Uses of Class javax.swing.plaf.nimbus.AbstractRegionPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.AbstractRegionPainter

No usage of javax.swing.plaf.nimbus.AbstractRegionPainter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=ebrl


Uses of Class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext

  • Packages that use AbstractRegionPainter.PaintContext
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.

    • Uses of AbstractRegionPainter.PaintContext in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return AbstractRegionPainter.PaintContext
      修饰符与类型 方法与描述
      protected abstract AbstractRegionPainter.PaintContext AbstractRegionPainter.getPaintContext()
      Gets the PaintContext for this painting operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>dple&d ooo h ,


Uses of Class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode

  • Packages that use AbstractRegionPainter.PaintContext.CacheMode
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.

    • Uses of AbstractRegionPainter.PaintContext.CacheMode in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return AbstractRegionPainter.PaintContext.CacheMode
      修饰符与类型 方法与描述
      static AbstractRegionPainter.PaintContext.CacheMode AbstractRegionPainter.PaintContext.CacheMode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AbstractRegionPainter.PaintContext.CacheMode[] AbstractRegionPainter.PaintContext.CacheMode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.swing.plaf.nimbus with parameters of type AbstractRegionPainter.PaintContext.CacheMode
      构造方法与描述
      AbstractRegionPainter.PaintContext(Insets insets, Dimension canvasSize, boolean inverted, AbstractRegionPainter.PaintContext.CacheMode cacheMode, double maxH, double maxV)
      Creates a new PaintContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ln?drdp鸻c./i �


Uses of Class javax.swing.plaf.nimbus.NimbusLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.NimbusLookAndFeel

No usage of javax.swing.plaf.nimbus.NimbusLookAndFeel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t=r>.


Uses of Class javax.swing.plaf.nimbus.NimbusStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.NimbusStyle

  • Packages that use NimbusStyle
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.

    • Uses of NimbusStyle in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return NimbusStyle
      修饰符与类型 方法与描述
      static NimbusStyle NimbusLookAndFeel.getStyle(JComponent c, Region r)
      Gets the style associated with the given component and region.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/baj><姘鵹 0s ;at 99tn


Uses of Class javax.swing.plaf.nimbus.State

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.nimbus.State

No usage of javax.swing.plaf.nimbus.State
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h= ce as ttttk livc


Primary Colors

Key Value Preview
control
#d6d9df (214,217,223)
info
#f2f2bd (242,242,189)
nimbusAlertYellow
#ffdc23 (255,220,35)
nimbusBase
#33628c (51,98,140)
nimbusDisabledText
#8e8f91 (142,143,145)
nimbusFocus
#73a4d1 (115,164,209)
nimbusGreen
#b0b332 (176,179,50)
nimbusInfoBlue
#2f5cb4 (47,92,180)
nimbusLightBackground
#ffffff (255,255,255)
nimbusOrange
#bf6204 (191,98,4)
nimbusRed
#a92e22 (169,46,34)
nimbusSelectedText
#ffffff (255,255,255)
nimbusSelectionBackground
#39698a (57,105,138)
text
#000000 (0,0,0)

Secondary Colors

Key Value Preview
activeCaption
#babec6 (186,190,198)
background
#d6d9df (214,217,223)
controlDkShadow
#a4abb8 (164,171,184)
controlHighlight
#e9ecf2 (233,236,242)
controlLHighlight
#f7f8fa (247,248,250)
controlShadow
#ccd3e0 (204,211,224)
controlText
#000000 (0,0,0)
desktop
#3d6079 (61,96,121)
inactiveCaption
#bdc1c8 (189,193,200)
infoText
#000000 (0,0,0)
menu
#edeff2 (237,239,242)
menuText
#000000 (0,0,0)
nimbusBlueGrey
#a9b0be (169,176,190)
nimbusBorder
#9297a1 (146,151,161)
nimbusSelection
#39698a (57,105,138)
scrollbar
#cdd0d5 (205,208,213)
textBackground
#39698a (57,105,138)
textForeground
#000000 (0,0,0)
textHighlight
#39698a (57,105,138)
textHighlightText
#ffffff (255,255,255)
textInactiveText
#8e8f91 (142,143,145)


ColorType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 ColorType

  • java.lang.Object
    • javax.swing.plaf.synth.ColorType

  • public class ColorType
extends Object
    A typesafe enumeration of colors that can be fetched from a style.

    Each SynthStyle has a set of ColorTypes that are accessed by way of the SynthStyle.getColor(SynthContext, ColorType) method. SynthStyle's installDefaults will install the FOREGROUND color as the foreground of the Component, and the BACKGROUND color to the background of the component (assuming that you have not explicitly specified a foreground and background color). Some components support more color based properties, for example JList has the property selectionForeground which will be mapped to FOREGROUND with a component state of SynthConstants.SELECTED.

    The following example shows a custom SynthStyle that returns a red Color for the DISABLED state, otherwise a black color.

     class MyStyle extends SynthStyle {
     private Color disabledColor = new ColorUIResource(Color.RED);
     private Color color = new ColorUIResource(Color.BLACK);
     protected Color getColorForState(SynthContext context, ColorType type){
         if (context.getComponentState() == SynthConstants.DISABLED) {
             return disabledColor;
         }
         return color;
     }
 }
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static ColorType BACKGROUND
      ColorType for the background of a region.
      static ColorType FOCUS
      ColorType for the focus.
      static ColorType FOREGROUND
      ColorType for the foreground of a region.
      static int MAX_COUNT
      Maximum number of ColorTypes.
      static ColorType TEXT_BACKGROUND
      ColorType for the background of a region.
      static ColorType TEXT_FOREGROUND
      ColorType for the foreground of a region.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ColorType(String description)
      Creates a new ColorType with the specified description.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getID()
      Returns a unique id, as an integer, for this ColorType.
      String toString()
      Returns the textual description of this ColorType.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FOREGROUND

        public static final ColorType FOREGROUND
        ColorType for the foreground of a region.

      • BACKGROUND

        public static final ColorType BACKGROUND
        ColorType for the background of a region.

      • TEXT_FOREGROUND

        public static final ColorType TEXT_FOREGROUND
        ColorType for the foreground of a region.

      • TEXT_BACKGROUND

        public static final ColorType TEXT_BACKGROUND
        ColorType for the background of a region.

      • FOCUS

        public static final ColorType FOCUS
        ColorType for the focus.

      • MAX_COUNT

        public static final int MAX_COUNT
        Maximum number of ColorTypes.

    • 构造方法详细信息

      • ColorType

        protected ColorType(String description)
        Creates a new ColorType with the specified description.
        参数：
        描述 - String description of the ColorType.

    • 方法详细信息

      • getID

        public final int getID()
        Returns a unique id, as an integer, for this ColorType.
        返回：
        a unique id, as an integer, for this ColorType.

      • toString

        public String toString()
        Returns the textual description of this ColorType. This is the same value that the ColorType was created with.
        重载：
        toString in class Object
        返回：
        the description of the string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c, a =.<,-sdr錴s


javax.swing.plaf.synth

Interfaces

  • SynthConstants
  • SynthUI

Classes

  • ColorType
  • Region
  • SynthButtonUI
  • SynthCheckBoxMenuItemUI
  • SynthCheckBoxUI
  • SynthColorChooserUI
  • SynthComboBoxUI
  • SynthContext
  • SynthDesktopIconUI
  • SynthDesktopPaneUI
  • SynthEditorPaneUI
  • SynthFormattedTextFieldUI
  • SynthGraphicsUtils
  • SynthInternalFrameUI
  • SynthLabelUI
  • SynthListUI
  • SynthLookAndFeel
  • SynthMenuBarUI
  • SynthMenuItemUI
  • SynthMenuUI
  • SynthOptionPaneUI
  • SynthPainter
  • SynthPanelUI
  • SynthPasswordFieldUI
  • SynthPopupMenuUI
  • SynthProgressBarUI
  • SynthRadioButtonMenuItemUI
  • SynthRadioButtonUI
  • SynthRootPaneUI
  • SynthScrollBarUI
  • SynthScrollPaneUI
  • SynthSeparatorUI
  • SynthSliderUI
  • SynthSpinnerUI
  • SynthSplitPaneUI
  • SynthStyle
  • SynthStyleFactory
  • SynthTabbedPaneUI
  • SynthTableHeaderUI
  • SynthTableUI
  • SynthTextAreaUI
  • SynthTextFieldUI
  • SynthTextPaneUI
  • SynthToggleButtonUI
  • SynthToolBarUI
  • SynthToolTipUI
  • SynthTreeUI
  • SynthViewportUI
>


javax.swing.plaf.synth

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.plaf.synth

Synth is a skinnable look and feel in which all painting is delegated.

请参见： 描述

  • 接口摘要
    接口 描述
    SynthConstants
    Constants used by Synth.
    SynthUI
    SynthUI is used to fetch the SynthContext for a particular Component.
  • Class Summary
    类 描述
    ColorType
    A typesafe enumeration of colors that can be fetched from a style.
    Region
    A distinct rendering area of a Swing component.
    SynthButtonUI
    Provides the Synth L&F UI delegate for JButton.
    SynthCheckBoxMenuItemUI
    Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
    SynthCheckBoxUI
    Provides the Synth L&F UI delegate for JCheckBox.
    SynthColorChooserUI
    Provides the Synth L&F UI delegate for JColorChooser.
    SynthComboBoxUI
    Provides the Synth L&F UI delegate for JComboBox.
    SynthContext
    An immutable transient object containing contextual information about a Region.
    SynthDesktopIconUI
    Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
    SynthDesktopPaneUI
    Provides the Synth L&F UI delegate for JDesktopPane.
    SynthEditorPaneUI
    Provides the Synth L&F UI delegate for JEditorPane.
    SynthFormattedTextFieldUI
    Provides the Synth L&F UI delegate for JFormattedTextField.
    SynthGraphicsUtils
    Wrapper for primitive graphics calls.
    SynthInternalFrameUI
    Provides the Synth L&F UI delegate for JInternalFrame.
    SynthLabelUI
    Provides the Synth L&F UI delegate for JLabel.
    SynthListUI
    Provides the Synth L&F UI delegate for JList.
    SynthLookAndFeel
    SynthLookAndFeel provides the basis for creating a customized look and feel.
    SynthMenuBarUI
    Provides the Synth L&F UI delegate for JMenuBar.
    SynthMenuItemUI
    Provides the Synth L&F UI delegate for JMenuItem.
    SynthMenuUI
    Provides the Synth L&F UI delegate for JMenu.
    SynthOptionPaneUI
    Provides the Synth L&F UI delegate for JOptionPane.
    SynthPainter
    SynthPainter is used for painting portions of JComponents.
    SynthPanelUI
    Provides the Synth L&F UI delegate for JPanel.
    SynthPasswordFieldUI
    Provides the Synth L&F UI delegate for JPasswordField.
    SynthPopupMenuUI
    Provides the Synth L&F UI delegate for JPopupMenu.
    SynthProgressBarUI
    Provides the Synth L&F UI delegate for JProgressBar.
    SynthRadioButtonMenuItemUI
    Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
    SynthRadioButtonUI
    Provides the Synth L&F UI delegate for JRadioButton.
    SynthRootPaneUI
    Provides the Synth L&F UI delegate for JRootPane.
    SynthScrollBarUI
    Provides the Synth L&F UI delegate for JScrollBar.
    SynthScrollPaneUI
    Provides the Synth L&F UI delegate for JScrollPane.
    SynthSeparatorUI
    Provides the Synth L&F UI delegate for JSeparator.
    SynthSliderUI
    Provides the Synth L&F UI delegate for JSlider.
    SynthSpinnerUI
    Provides the Synth L&F UI delegate for JSpinner.
    SynthSplitPaneUI
    Provides the Synth L&F UI delegate for JSplitPane.
    SynthStyle
    SynthStyle is a set of style properties.
    SynthStyleFactory
    Factory used for obtaining SynthStyles.
    SynthTabbedPaneUI
    Provides the Synth L&F UI delegate for JTabbedPane.
    SynthTableHeaderUI
    Provides the Synth L&F UI delegate for JTableHeader.
    SynthTableUI
    Provides the Synth L&F UI delegate for JTable.
    SynthTextAreaUI
    Provides the look and feel for a plain text editor in the Synth look and feel.
    SynthTextFieldUI
    Provides the Synth L&F UI delegate for JTextField.
    SynthTextPaneUI
    Provides the look and feel for a styled text editor in the Synth look and feel.
    SynthToggleButtonUI
    Provides the Synth L&F UI delegate for JToggleButton.
    SynthToolBarUI
    Provides the Synth L&F UI delegate for JToolBar.
    SynthToolTipUI
    Provides the Synth L&F UI delegate for JToolTip.
    SynthTreeUI
    Provides the Synth L&F UI delegate for JTree.
    SynthViewportUI
    Provides the Synth L&F UI delegate for JViewport.

软件包 javax.swing.plaf.synth Description

Synth is a skinnable look and feel in which all painting is delegated. Synth does not provide a default look. In order to use Synth you need to specify a file, or provide a SynthStyleFactory. Both configuration options require an understanding of the synth architecture, which is described below, as well as an understanding of Swing's architecture.

Unless otherwise specified null is not a legal value to any of the methods defined in the synth package and if passed in will result in a NullPointerException.

Synth

Each ComponentUI implementation in Synth associates itself with one SynthStyle per Region, most Components only have one Region and therefor only one SynthStyle. SynthStyle is used to access all style related properties: fonts, colors and other Component properties. In addition SynthStyles are used to obtain SynthPainters for painting the background, border, focus and other portions of a Component. The ComponentUIs obtain SynthStyles from a SynthStyleFactory. A SynthStyleFactory can be provided directly by way of SynthLookAndFeel.setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory), or indirectly by way of SynthLookAndFeel.load(java.io.InputStream, java.lang.Class). The following example uses the SynthLookAndFeel.load() method to configure a SynthLookAndFeel and sets it as the current look and feel:

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(MyClass.class.getResourceAsStream("laf.xml"), MyClass.class);
  UIManager.setLookAndFeel(laf);

Many JComponents are broken down into smaller pieces and identified by the type safe enumeration in Region. For example, a JTabbedPane consists of a Region for the JTabbedPane (Region.TABBED_PANE), the content area (Region.TABBED_PANE_CONTENT), the area behind the tabs (Region.TABBED_PANE_TAB_AREA), and the tabs (Region.TABBED_PANE_TAB). Each Region of each JComponent will have a SynthStyle. This allows you to customize individual pieces of each region of each JComponent.

Many of the Synth methods take a SynthContext. This is used to provide information about the current Component and includes: the SynthStyle associated with the current Region, the state of the Component as a bitmask (refer to SynthConstants for the valid states), and a Region identifying the portion of the Component being painted.

All text rendering by non-JTextComponents is delegated to a SynthGraphicsUtils, which is obtained using the SynthStyle method SynthStyle.getGraphicsUtils(javax.swing.plaf.synth.SynthContext). You can customize text rendering by supplying your own SynthGraphicsUtils.

Notes on specific components

JTree

Synth provides a region for the cells of a tree: Region.TREE_CELL. To specify the colors of the renderer you'll want to provide a style for the TREE_CELL region. The following illustrates this:

  <style id="treeCellStyle">
    <opaque value="TRUE"/>
    <state>
      <color value="WHITE" type="TEXT_FOREGROUND"/>
      <color value="RED" type="TEXT_BACKGROUND"/>
    </state>
    <state value="SELECTED">
      <color value="RED" type="TEXT_FOREGROUND"/>
      <color value="WHITE" type="BACKGROUND"/>
    </state>
  </style>
  <bind style="treeCellStyle" type="region" key="TreeCell"/>

This specifies a color combination of red on white, when selected, and white on red when not selected. To see the background you need to specify that labels are not opaque. The following XML fragment does that:

  <style id="labelStyle">
    <opaque value="FALSE"/>
  </style>
  <bind style="labelStyle" type="region" key="Label"/>

JList and JTable

The colors that the renderers for JList and JTable use are specified by way of the list and table Regions. The following XML fragment illustrates how to specify red on white, when selected, and white on red when not selected:

  <style id="style">
    <opaque value="TRUE"/>
    <state>
      <color value="WHITE" type="TEXT_FOREGROUND"/>
      <color value="RED" type="TEXT_BACKGROUND"/>
      <color value="RED" type="BACKGROUND"/>
    </state>
    <state value="SELECTED">
      <color value="RED" type="TEXT_FOREGROUND"/>
      <color value="WHITE" type="TEXT_BACKGROUND"/>
    </state>
  </style>
  <bind style="style" type="region" key="Table"/>
  <bind style="style" type="region" key="List"/>
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.swing.plaf.synth Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.plaf.synth

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.plaf.synth.ColorType
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.synth.SynthButtonUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
            • javax.swing.plaf.synth.SynthToggleButtonUI
              • javax.swing.plaf.synth.SynthRadioButtonUI
                • javax.swing.plaf.synth.SynthCheckBoxUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
              • javax.swing.plaf.synth.SynthMenuUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
            • javax.swing.plaf.synth.SynthMenuItemUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
              • javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
          • javax.swing.plaf.synth.SynthColorChooserUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.synth.SynthComboBoxUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.synth.SynthDesktopIconUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
          • javax.swing.plaf.synth.SynthDesktopPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.synth.SynthInternalFrameUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.synth.SynthLabelUI (implements javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
          • javax.swing.plaf.synth.SynthListUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.synth.SynthMenuBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
          • javax.swing.plaf.synth.SynthOptionPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
          • javax.swing.plaf.synth.SynthPanelUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
          • javax.swing.plaf.synth.SynthPopupMenuUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.synth.SynthProgressBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.synth.SynthRootPaneUI (implements javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.synth.SynthScrollBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.synth.SynthScrollPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.synth.SynthSeparatorUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.synth.SynthSliderUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
          • javax.swing.plaf.synth.SynthSpinnerUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.synth.SynthSplitPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.synth.SynthTabbedPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
          • javax.swing.plaf.synth.SynthTableHeaderUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
          • javax.swing.plaf.synth.SynthTableUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.synth.SynthEditorPaneUI (implements javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
            • javax.swing.plaf.synth.SynthTextAreaUI (implements javax.swing.plaf.synth.SynthUI)
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.synth.SynthTextFieldUI (implements javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthFormattedTextFieldUI
              • javax.swing.plaf.synth.SynthPasswordFieldUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.synth.SynthToolBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.synth.SynthToolTipUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.synth.SynthTreeUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.synth.SynthViewportUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.synth.SynthLookAndFeel
    • javax.swing.plaf.synth.Region
    • javax.swing.plaf.synth.SynthContext
    • javax.swing.plaf.synth.SynthGraphicsUtils
    • javax.swing.plaf.synth.SynthPainter
    • javax.swing.plaf.synth.SynthStyle
    • javax.swing.plaf.synth.SynthStyleFactory

Interface Hierarchy

  • javax.swing.plaf.synth.SynthConstants
    • javax.swing.plaf.synth.SynthUI
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Region

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 Region

  • java.lang.Object
    • javax.swing.plaf.synth.Region

  • public class Region
extends Object
    A distinct rendering area of a Swing component. A component may support one or more regions. Specific component regions are defined by the typesafe enumeration in this class.

    Regions are typically used as a way to identify the Components and areas a particular style is to apply to. Synth's file format allows you to bind styles based on the name of a Region. The name is derived from the field name of the constant:

    1. Map all characters to lowercase.
    2. Map the first character to uppercase.
    3. Map the first character after underscores to uppercase.
    4. Remove all underscores.
    For example, to identify the SPLIT_PANE Region you would use SplitPane. The following shows a custom SynthStyleFactory that returns a specific style for split panes:
        public SynthStyle getStyle(JComponent c, Region id) {
        if (id == Region.SPLIT_PANE) {
            return splitPaneStyle;
        }
        ...
    }
    The following xml accomplishes the same thing:
     <style id="splitPaneStyle">
   ...
 </style>
 <bind style="splitPaneStyle" type="region" key="SplitPane"/>
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Region ARROW_BUTTON
      ArrowButton's are special types of buttons that also render a directional indicator, typically an arrow.
      static Region BUTTON
      Button region.
      static Region CHECK_BOX
      CheckBox region.
      static Region CHECK_BOX_MENU_ITEM
      CheckBoxMenuItem region.
      static Region COLOR_CHOOSER
      ColorChooser region.
      static Region COMBO_BOX
      ComboBox region.
      static Region DESKTOP_ICON
      DesktopIcon region.
      static Region DESKTOP_PANE
      DesktopPane region.
      static Region EDITOR_PANE
      EditorPane region.
      static Region FILE_CHOOSER
      FileChooser region.
      static Region FORMATTED_TEXT_FIELD
      FormattedTextField region.
      static Region INTERNAL_FRAME
      InternalFrame region.
      static Region INTERNAL_FRAME_TITLE_PANE
      TitlePane of an InternalFrame.
      static Region LABEL
      Label region.
      static Region LIST
      List region.
      static Region MENU
      Menu region.
      static Region MENU_BAR
      MenuBar region.
      static Region MENU_ITEM
      MenuItem region.
      static Region MENU_ITEM_ACCELERATOR
      Accelerator region of a MenuItem.
      static Region OPTION_PANE
      OptionPane region.
      static Region PANEL
      Panel region.
      static Region PASSWORD_FIELD
      PasswordField region.
      static Region POPUP_MENU
      PopupMenu region.
      static Region POPUP_MENU_SEPARATOR
      PopupMenuSeparator region.
      static Region PROGRESS_BAR
      ProgressBar region.
      static Region RADIO_BUTTON
      RadioButton region.
      static Region RADIO_BUTTON_MENU_ITEM
      RegionButtonMenuItem region.
      static Region ROOT_PANE
      RootPane region.
      static Region SCROLL_BAR
      ScrollBar region.
      static Region SCROLL_BAR_THUMB
      Thumb of the ScrollBar.
      static Region SCROLL_BAR_TRACK
      Track of the ScrollBar.
      static Region SCROLL_PANE
      ScrollPane region.
      static Region SEPARATOR
      Separator region.
      static Region SLIDER
      Slider region.
      static Region SLIDER_THUMB
      Thumb of the Slider.
      static Region SLIDER_TRACK
      Track of the Slider.
      static Region SPINNER
      Spinner region.
      static Region SPLIT_PANE
      SplitPane region.
      static Region SPLIT_PANE_DIVIDER
      Divider of the SplitPane.
      static Region TABBED_PANE
      TabbedPane region.
      static Region TABBED_PANE_CONTENT
      Region of a TabbedPane containing the content.
      static Region TABBED_PANE_TAB
      Region of a TabbedPane for one tab.
      static Region TABBED_PANE_TAB_AREA
      Region of a TabbedPane containing the tabs.
      static Region TABLE
      Table region.
      static Region TABLE_HEADER
      TableHeader region.
      static Region TEXT_AREA
      TextArea region.
      static Region TEXT_FIELD
      TextField region.
      static Region TEXT_PANE
      TextPane region.
      static Region TOGGLE_BUTTON
      ToggleButton region.
      static Region TOOL_BAR
      ToolBar region.
      static Region TOOL_BAR_CONTENT
      Region of the ToolBar containing the content.
      static Region TOOL_BAR_DRAG_WINDOW
      Region for the Window containing the ToolBar.
      static Region TOOL_BAR_SEPARATOR
      ToolBar separator region.
      static Region TOOL_TIP
      ToolTip region.
      static Region TREE
      Tree region.
      static Region TREE_CELL
      Region of the Tree for one cell.
      static Region VIEWPORT
      Viewport region.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Region(String name, String ui, boolean subregion)
      Creates a Region with the specified name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Returns the name of the region.
      boolean isSubregion()
      Returns true if the Region is a subregion of a Component, otherwise false.
      String toString()
      Returns the name of the Region.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ARROW_BUTTON

        public static final Region ARROW_BUTTON
        ArrowButton's are special types of buttons that also render a directional indicator, typically an arrow. ArrowButtons are used by composite components, for example ScrollBar's contain ArrowButtons. To bind a style to this Region use the name ArrowButton.

      • BUTTON

        public static final Region BUTTON
        Button region. To bind a style to this Region use the name Button.

      • CHECK_BOX

        public static final Region CHECK_BOX
        CheckBox region. To bind a style to this Region use the name CheckBox.

      • CHECK_BOX_MENU_ITEM

        public static final Region CHECK_BOX_MENU_ITEM
        CheckBoxMenuItem region. To bind a style to this Region use the name CheckBoxMenuItem.

      • COLOR_CHOOSER

        public static final Region COLOR_CHOOSER
        ColorChooser region. To bind a style to this Region use the name ColorChooser.

      • COMBO_BOX

        public static final Region COMBO_BOX
        ComboBox region. To bind a style to this Region use the name ComboBox.

      • DESKTOP_PANE

        public static final Region DESKTOP_PANE
        DesktopPane region. To bind a style to this Region use the name DesktopPane.

      • DESKTOP_ICON

        public static final Region DESKTOP_ICON
        DesktopIcon region. To bind a style to this Region use the name DesktopIcon.

      • EDITOR_PANE

        public static final Region EDITOR_PANE
        EditorPane region. To bind a style to this Region use the name EditorPane.

      • FILE_CHOOSER

        public static final Region FILE_CHOOSER
        FileChooser region. To bind a style to this Region use the name FileChooser.

      • FORMATTED_TEXT_FIELD

        public static final Region FORMATTED_TEXT_FIELD
        FormattedTextField region. To bind a style to this Region use the name FormattedTextField.

      • INTERNAL_FRAME

        public static final Region INTERNAL_FRAME
        InternalFrame region. To bind a style to this Region use the name InternalFrame.

      • INTERNAL_FRAME_TITLE_PANE

        public static final Region INTERNAL_FRAME_TITLE_PANE
        TitlePane of an InternalFrame. The TitlePane typically shows a menu, title, widgets to manipulate the internal frame. To bind a style to this Region use the name InternalFrameTitlePane.

      • LABEL

        public static final Region LABEL
        Label region. To bind a style to this Region use the name Label.

      • LIST

        public static final Region LIST
        List region. To bind a style to this Region use the name List.

      • MENU

        public static final Region MENU
        Menu region. To bind a style to this Region use the name Menu.

      • MENU_BAR

        public static final Region MENU_BAR
        MenuBar region. To bind a style to this Region use the name MenuBar.

      • MENU_ITEM

        public static final Region MENU_ITEM
        MenuItem region. To bind a style to this Region use the name MenuItem.

      • MENU_ITEM_ACCELERATOR

        public static final Region MENU_ITEM_ACCELERATOR
        Accelerator region of a MenuItem. To bind a style to this Region use the name MenuItemAccelerator.

      • OPTION_PANE

        public static final Region OPTION_PANE
        OptionPane region. To bind a style to this Region use the name OptionPane.

      • PANEL

        public static final Region PANEL
        Panel region. To bind a style to this Region use the name Panel.

      • PASSWORD_FIELD

        public static final Region PASSWORD_FIELD
        PasswordField region. To bind a style to this Region use the name PasswordField.

      • POPUP_MENU

        public static final Region POPUP_MENU
        PopupMenu region. To bind a style to this Region use the name PopupMenu.

      • POPUP_MENU_SEPARATOR

        public static final Region POPUP_MENU_SEPARATOR
        PopupMenuSeparator region. To bind a style to this Region use the name PopupMenuSeparator.

      • PROGRESS_BAR

        public static final Region PROGRESS_BAR
        ProgressBar region. To bind a style to this Region use the name ProgressBar.

      • RADIO_BUTTON

        public static final Region RADIO_BUTTON
        RadioButton region. To bind a style to this Region use the name RadioButton.

      • RADIO_BUTTON_MENU_ITEM

        public static final Region RADIO_BUTTON_MENU_ITEM
        RegionButtonMenuItem region. To bind a style to this Region use the name RadioButtonMenuItem.

      • ROOT_PANE

        public static final Region ROOT_PANE
        RootPane region. To bind a style to this Region use the name RootPane.

      • SCROLL_BAR

        public static final Region SCROLL_BAR
        ScrollBar region. To bind a style to this Region use the name ScrollBar.

      • SCROLL_BAR_TRACK

        public static final Region SCROLL_BAR_TRACK
        Track of the ScrollBar. To bind a style to this Region use the name ScrollBarTrack.

      • SCROLL_BAR_THUMB

        public static final Region SCROLL_BAR_THUMB
        Thumb of the ScrollBar. The thumb is the region of the ScrollBar that gives a graphical depiction of what percentage of the View is currently visible. To bind a style to this Region use the name ScrollBarThumb.

      • SCROLL_PANE

        public static final Region SCROLL_PANE
        ScrollPane region. To bind a style to this Region use the name ScrollPane.

      • SEPARATOR

        public static final Region SEPARATOR
        Separator region. To bind a style to this Region use the name Separator.

      • SLIDER

        public static final Region SLIDER
        Slider region. To bind a style to this Region use the name Slider.

      • SLIDER_TRACK

        public static final Region SLIDER_TRACK
        Track of the Slider. To bind a style to this Region use the name SliderTrack.

      • SLIDER_THUMB

        public static final Region SLIDER_THUMB
        Thumb of the Slider. The thumb of the Slider identifies the current value. To bind a style to this Region use the name SliderThumb.

      • SPINNER

        public static final Region SPINNER
        Spinner region. To bind a style to this Region use the name Spinner.

      • SPLIT_PANE

        public static final Region SPLIT_PANE
        SplitPane region. To bind a style to this Region use the name SplitPane.

      • SPLIT_PANE_DIVIDER

        public static final Region SPLIT_PANE_DIVIDER
        Divider of the SplitPane. To bind a style to this Region use the name SplitPaneDivider.

      • TABBED_PANE

        public static final Region TABBED_PANE
        TabbedPane region. To bind a style to this Region use the name TabbedPane.

      • TABBED_PANE_TAB

        public static final Region TABBED_PANE_TAB
        Region of a TabbedPane for one tab. To bind a style to this Region use the name TabbedPaneTab.

      • TABBED_PANE_TAB_AREA

        public static final Region TABBED_PANE_TAB_AREA
        Region of a TabbedPane containing the tabs. To bind a style to this Region use the name TabbedPaneTabArea.

      • TABBED_PANE_CONTENT

        public static final Region TABBED_PANE_CONTENT
        Region of a TabbedPane containing the content. To bind a style to this Region use the name TabbedPaneContent.

      • TABLE

        public static final Region TABLE
        Table region. To bind a style to this Region use the name Table.

      • TABLE_HEADER

        public static final Region TABLE_HEADER
        TableHeader region. To bind a style to this Region use the name TableHeader.

      • TEXT_AREA

        public static final Region TEXT_AREA
        TextArea region. To bind a style to this Region use the name TextArea.

      • TEXT_FIELD

        public static final Region TEXT_FIELD
        TextField region. To bind a style to this Region use the name TextField.

      • TEXT_PANE

        public static final Region TEXT_PANE
        TextPane region. To bind a style to this Region use the name TextPane.

      • TOGGLE_BUTTON

        public static final Region TOGGLE_BUTTON
        ToggleButton region. To bind a style to this Region use the name ToggleButton.

      • TOOL_BAR

        public static final Region TOOL_BAR
        ToolBar region. To bind a style to this Region use the name ToolBar.

      • TOOL_BAR_CONTENT

        public static final Region TOOL_BAR_CONTENT
        Region of the ToolBar containing the content. To bind a style to this Region use the name ToolBarContent.

      • TOOL_BAR_DRAG_WINDOW

        public static final Region TOOL_BAR_DRAG_WINDOW
        Region for the Window containing the ToolBar. To bind a style to this Region use the name ToolBarDragWindow.

      • TOOL_TIP

        public static final Region TOOL_TIP
        ToolTip region. To bind a style to this Region use the name ToolTip.

      • TOOL_BAR_SEPARATOR

        public static final Region TOOL_BAR_SEPARATOR
        ToolBar separator region. To bind a style to this Region use the name ToolBarSeparator.

      • TREE

        public static final Region TREE
        Tree region. To bind a style to this Region use the name Tree.

      • TREE_CELL

        public static final Region TREE_CELL
        Region of the Tree for one cell. To bind a style to this Region use the name TreeCell.

      • VIEWPORT

        public static final Region VIEWPORT
        Viewport region. To bind a style to this Region use the name Viewport.

    • 构造方法详细信息

      • Region

        protected Region(String name,
      String ui,
      boolean subregion)
        Creates a Region with the specified name. This should only be used if you are creating your own JComponent subclass with a custom ComponentUI class.
        参数：
        name - Name of the region
        ui - String that will be returned from component.getUIClassID. This will be null if this is a subregion.
        subregion - Whether or not this is a subregion.

    • 方法详细信息

      • isSubregion

        public boolean isSubregion()
        Returns true if the Region is a subregion of a Component, otherwise false. For example, Region.BUTTON corresponds do a Component so that Region.BUTTON.isSubregion() returns false.
        返回：
        true if the Region is a subregion of a Component.

      • getName

        public String getName()
        Returns the name of the region.
        返回：
        name of the Region.

      • toString

        public String toString()
        Returns the name of the Region.
        重载：
        toString in class Object
        返回：
        name of the Region.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.synth.SynthButtonUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI
    直接已知子类：
    SynthToggleButtonUI

    public class SynthButtonUI
extends BasicButtonUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JButton.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected Icon getDefaultIcon(AbstractButton b)
      Returns the default icon.
      protected Icon getIcon(AbstractButton b)
      Returns the Icon to use for painting the button.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected Icon getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      protected void | installDefaults(AbstractButton b)
      protected void | installListeners(AbstractButton b)
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults(AbstractButton b)
      protected void | uninstallListeners(AbstractButton b)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaselineResizeBehavior, getDefaultTextIconGap, getPropertyPrefix, getTextShiftOffset, installKeyboardActions, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthButtonUI

        public SynthButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults(AbstractButton b)
        重载：
        installDefaults in class BasicButtonUI

      • installListeners

        protected void installListeners(AbstractButton b)
        重载：
        installListeners in class BasicButtonUI

      • uninstallListeners

        protected void uninstallListeners(AbstractButton b)
        重载：
        uninstallListeners in class BasicButtonUI

      • uninstallDefaults

        protected void uninstallDefaults(AbstractButton b)
        重载：
        uninstallDefaults in class BasicButtonUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Description copied from class: BasicButtonUI
        Returns the baseline.
        重载：
        getBaseline in class BasicButtonUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        另请参见：
        JComponent.getBaseline(int, int)

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicButtonUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • getDefaultIcon

        protected Icon getDefaultIcon(AbstractButton b)
        Returns the default icon. This should not callback to the JComponent.
        参数：
        b - button the icon is associated with
        返回：
        default icon

      • getIcon

        protected Icon getIcon(AbstractButton b)
        Returns the Icon to use for painting the button. The icon is chosen with respect to the current state of the button.
        参数：
        b - button the icon is associated with
        返回：
        an icon

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class BasicButtonUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicButtonUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class BasicButtonUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getSizingIcon

        protected Icon getSizingIcon(AbstractButton b)
        Returns the Icon used in calculating the preferred/minimum/maximum size.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthCheckBoxMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthCheckBoxMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.synth.SynthMenuItemUI
              • javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthCheckBoxMenuItemUI
extends SynthMenuItemUI
    Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthCheckBoxMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      protected String | getPropertyPrefix()
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthMenuItemUI

        getContext, getPreferredMenuItemSize, installDefaults, installListeners, paint, paint, propertyChange, uninstallDefaults, uninstallListeners, uninstallUI, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredSize, installComponents, installKeyboardActions, installUI, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthCheckBoxMenuItemUI

        public SynthCheckBoxMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicMenuItemUI

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthMenuItemUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/Bgxsj.sj aaj sttt;b&eiev&nlDau lhaa(lan


SynthCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthCheckBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.synth.SynthButtonUI
            • javax.swing.plaf.synth.SynthToggleButtonUI
              • javax.swing.plaf.synth.SynthRadioButtonUI
                • javax.swing.plaf.synth.SynthCheckBoxUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthCheckBoxUI
extends SynthRadioButtonUI
    Provides the Synth L&F UI delegate for JCheckBox.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthCheckBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent b)
      Creates a new UI object for the given component.
      protected String | getPropertyPrefix()
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthRadioButtonUI

        getSizingIcon

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthButtonUI

        getBaseline, getContext, getDefaultIcon, getIcon, getMaximumSize, getMinimumSize, getPreferredSize, installDefaults, installListeners, paint, paint, propertyChange, uninstallDefaults, uninstallListeners, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaselineResizeBehavior, getDefaultTextIconGap, getTextShiftOffset, installKeyboardActions, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthCheckBoxUI

        public SynthCheckBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)
        Creates a new UI object for the given component.
        参数：
        b - component to create UI object for
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class SynthRadioButtonUI

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthRadioButtonUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

naukhknkekcoMennBn>>//snns//SthcnktByyoeCsM


SynthColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthColorChooserUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
          • javax.swing.plaf.synth.SynthColorChooserUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthColorChooserUI
extends BasicColorChooserUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JColorChooser.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicColorChooserUI

        BasicColorChooserUI.PropertyHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicColorChooserUI

        chooser, defaultChoosers, previewListener, propertyChangeListener

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthColorChooserUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected AbstractColorChooserPanel[] | createDefaultChoosers()
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicColorChooserUI

        createPropertyChangeListener, installPreviewPanel, installUI, uninstallDefaultChoosers, uninstallPreviewPanel, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthColorChooserUI

        public SynthColorChooserUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • createDefaultChoosers

        protected AbstractColorChooserPanel[] createDefaultChoosers()
        重载：
        createDefaultChoosers in class BasicColorChooserUI

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicColorChooserUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicColorChooserUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicColorChooserUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicColorChooserUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does not perform any actions.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthComboBoxUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.synth.SynthComboBoxUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthComboBoxUI
extends BasicComboBoxUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JComboBox.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicComboBoxUI

        BasicComboBoxUI.ComboBoxLayoutManager, BasicComboBoxUI.FocusHandler, BasicComboBoxUI.ItemHandler, BasicComboBoxUI.KeyHandler, BasicComboBoxUI.ListDataHandler, BasicComboBoxUI.PropertyChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicComboBoxUI

        arrowButton, cachedMinimumSize, comboBox, currentValuePane, editor, focusListener, hasFocus, isMinimumSizeDirty, itemListener, keyListener, listBox, listDataListener, padding, popup, popupKeyListener, popupMouseListener, popupMouseMotionListener, propertyChangeListener, squareButton

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthComboBoxUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected JButton createArrowButton()
      Creates a button which will be used as the control to show or hide the popup portion of the combo box.
      protected ComboBoxEditor createEditor()
      Creates the default editor that will be used in editable combo boxes.
      protected ComboPopup createPopup()
      Creates the popup portion of the combo box.
      protected ListCellRenderer createRenderer()
      Creates the default renderer that will be used in a non-editiable combo box.
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected Dimension getDefaultSize()
      Returns the default size of an empty display area of the combo box using the current renderer and font.
      protected void installDefaults()
      Installs the default colors, default font, default renderer, and default editor into the JComboBox.
      protected void installListeners()
      Creates and installs listeners for the combo box and its model.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
      Paints the currently selected item.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void uninstallDefaults()
      Uninstalls the default colors, default font, default renderer, and default editor from the combo box.
      protected void uninstallListeners()
      Removes the installed listeners from the combo box and its model.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicComboBoxUI

        addEditor, configureArrowButton, configureEditor, createFocusListener, createItemListener, createKeyListener, createLayoutManager, createListDataListener, createPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getDisplaySize, getInsets, getMaximumSize, getMinimumSize, getPreferredSize, getSizeForComponent, installComponents, installKeyboardActions, isFocusTraversable, isNavigationKey, isPopupVisible, paintCurrentValueBackground, rectangleForCurrentValue, removeEditor, selectNextPossibleValue, selectPreviousPossibleValue, setPopupVisible, toggleOpenClose, unconfigureArrowButton, unconfigureEditor, uninstallComponents, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthComboBoxUI

        public SynthComboBoxUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicComboBoxUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicComboBoxUI
        Installs the default colors, default font, default renderer, and default editor into the JComboBox.
        重载：
        installDefaults in class BasicComboBoxUI

      • installListeners

        protected void installListeners()
        Description copied from class: BasicComboBoxUI
        Creates and installs listeners for the combo box and its model. This method is called when the UI is installed.
        重载：
        installListeners in class BasicComboBoxUI

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicComboBoxUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()
        Description copied from class: BasicComboBoxUI
        Uninstalls the default colors, default font, default renderer, and default editor from the combo box.
        重载：
        uninstallDefaults in class BasicComboBoxUI

      • uninstallListeners

        protected void uninstallListeners()
        Description copied from class: BasicComboBoxUI
        Removes the installed listeners from the combo box and its model. The number and types of listeners removed and in this method should be the same that was added in installListeners
        重载：
        uninstallListeners in class BasicComboBoxUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • createPopup

        protected ComboPopup createPopup()
        Description copied from class: BasicComboBoxUI
        Creates the popup portion of the combo box.
        重载：
        createPopup in class BasicComboBoxUI
        返回：
        an instance of ComboPopup
        另请参见：
        ComboPopup

      • createRenderer

        protected ListCellRenderer createRenderer()
        Description copied from class: BasicComboBoxUI
        Creates the default renderer that will be used in a non-editiable combo box. A default renderer will used only if a renderer has not been explicitly set with setRenderer.
        重载：
        createRenderer in class BasicComboBoxUI
        返回：
        a ListCellRender used for the combo box
        另请参见：
        JComboBox.setRenderer(javax.swing.ListCellRenderer)

      • createEditor

        protected ComboBoxEditor createEditor()
        Description copied from class: BasicComboBoxUI
        Creates the default editor that will be used in editable combo boxes. A default editor will be used only if an editor has not been explicitly set with setEditor.
        重载：
        createEditor in class BasicComboBoxUI
        返回：
        a ComboBoxEditor used for the combo box
        另请参见：
        JComboBox.setEditor(javax.swing.ComboBoxEditor)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • createArrowButton

        protected JButton createArrowButton()
        Description copied from class: BasicComboBoxUI
        Creates a button which will be used as the control to show or hide the popup portion of the combo box.
        重载：
        createArrowButton in class BasicComboBoxUI
        返回：
        a button which represents the popup control

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicComboBoxUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paintCurrentValue

        public void paintCurrentValue(Graphics g,
                     Rectangle bounds,
                     boolean hasFocus)
        Paints the currently selected item.
        重载：
        paintCurrentValue in class BasicComboBoxUI

      • getDefaultSize

        protected Dimension getDefaultSize()
        Returns the default size of an empty display area of the combo box using the current renderer and font. This method was overridden to use SynthComboBoxRenderer instead of DefaultListCellRenderer as the default renderer when calculating the size of the combo box. This is used in the case of the combo not having any data.
        重载：
        getDefaultSize in class BasicComboBoxUI
        返回：
        the size of an empty display area
        另请参见：
        BasicComboBoxUI.getDisplaySize()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.plaf.synth

Interface SynthConstants

  • All Known Subinterfaces:
    SynthUI
    All Known Implementing Classes:
    SynthButtonUI, SynthCheckBoxMenuItemUI, SynthCheckBoxUI, SynthColorChooserUI, SynthComboBoxUI, SynthDesktopIconUI, SynthDesktopPaneUI, SynthEditorPaneUI, SynthFormattedTextFieldUI, SynthInternalFrameUI, SynthLabelUI, SynthListUI, SynthMenuBarUI, SynthMenuItemUI, SynthMenuUI, SynthOptionPaneUI, SynthPanelUI, SynthPasswordFieldUI, SynthPopupMenuUI, SynthProgressBarUI, SynthRadioButtonMenuItemUI, SynthRadioButtonUI, SynthRootPaneUI, SynthScrollBarUI, SynthScrollPaneUI, SynthSeparatorUI, SynthSliderUI, SynthSpinnerUI, SynthSplitPaneUI, SynthTabbedPaneUI, SynthTableHeaderUI, SynthTableUI, SynthTextAreaUI, SynthTextFieldUI, SynthTextPaneUI, SynthToggleButtonUI, SynthToolBarUI, SynthToolTipUI, SynthTreeUI, SynthViewportUI

    public interface SynthConstants
    Constants used by Synth. Not all Components support all states. A Component will at least be in one of the primary states. That is, the return value from SynthContext.getComponentState() will at least be one of ENABLED, MOUSE_OVER, PRESSED or DISABLED, and may also contain FOCUSED, SELECTED or DEFAULT.
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DEFAULT
      Indicates the region is the default.
      static int DISABLED
      Primary state indicating the region is not enabled.
      static int ENABLED
      Primary state indicating the component is enabled.
      static int FOCUSED
      Indicates the region has focus.
      static int MOUSE_OVER
      Primary state indicating the mouse is over the region.
      static int PRESSED
      Primary state indicating the region is in a pressed state.
      static int SELECTED
      Indicates the region is selected.

    • 字段详细信息

      • ENABLED

        static final int ENABLED
        Primary state indicating the component is enabled.
        另请参见：
        Constant Field Values

      • MOUSE_OVER

        static final int MOUSE_OVER
        Primary state indicating the mouse is over the region.
        另请参见：
        Constant Field Values

      • PRESSED

        static final int PRESSED
        Primary state indicating the region is in a pressed state. Pressed does not necessarily mean the user has pressed the mouse button.
        另请参见：
        Constant Field Values

      • DISABLED

        static final int DISABLED
        Primary state indicating the region is not enabled.
        另请参见：
        Constant Field Values

      • FOCUSED

        static final int FOCUSED
        Indicates the region has focus.
        另请参见：
        Constant Field Values

      • SELECTED

        static final int SELECTED
        Indicates the region is selected.
        另请参见：
        Constant Field Values

      • DEFAULT

        static final int DEFAULT
        Indicates the region is the default. This is typically used for buttons to indicate this button is somehow special.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ga.js "s "=cc"==tt//nni)oro/pasa


SynthContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthContext

  • java.lang.Object
    • javax.swing.plaf.synth.SynthContext

  • public class SynthContext
extends Object
    An immutable transient object containing contextual information about a Region. A SynthContext should only be considered valid for the duration of the method it is passed to. In other words you should not cache a SynthContext that is passed to you and expect it to remain valid.
    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthContext(JComponent component, Region region, SynthStyle style, int state)
      Creates a SynthContext with the specified values.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JComponent getComponent()
      Returns the hosting component containing the region.
      int getComponentState()
      Returns the state of the widget, which is a bitmask of the values defined in SynthConstants.
      Region getRegion()
      Returns the Region identifying this state.
      SynthStyle getStyle()
      Returns the style associated with this Region.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthContext

        public SynthContext(JComponent component,
            Region region,
            SynthStyle style,
            int state)
        Creates a SynthContext with the specified values. This is meant for subclasses and custom UI implementors. You very rarely need to construct a SynthContext, though some methods will take one.
        参数：
        component - JComponent
        region - Identifies the portion of the JComponent
        style - Style associated with the component
        state - State of the component as defined in SynthConstants.
        抛出：
        NullPointerException - if component, region of style is null.

    • 方法详细信息

      • getComponent

        public JComponent getComponent()
        Returns the hosting component containing the region.
        返回：
        Hosting Component

      • getRegion

        public Region getRegion()
        Returns the Region identifying this state.
        返回：
        Region of the hosting component

      • getStyle

        public SynthStyle getStyle()
        Returns the style associated with this Region.
        返回：
        SynthStyle associated with the region.

      • getComponentState

        public int getComponentState()
        Returns the state of the widget, which is a bitmask of the values defined in SynthConstants. A region will at least be in one of ENABLED, MOUSE_OVER, PRESSED or DISABLED.
        返回：
        State of Component
        另请参见：
        SynthConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> ofrtirttootttamss >-" -


SynthDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthDesktopIconUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.synth.SynthDesktopIconUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthDesktopIconUI
extends BasicDesktopIconUI
implements SynthUI, PropertyChangeListener
    Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicDesktopIconUI

        BasicDesktopIconUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicDesktopIconUI

        desktopIcon, frame, iconPane

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthDesktopIconUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicDesktopIconUI

        createMouseInputListener, deiconize, getInsets, getMaximumSize, getMinimumSize, getPreferredSize, installUI, uninstallComponents, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthDesktopIconUI

        public SynthDesktopIconUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installComponents

        protected void installComponents()
        重载：
        installComponents in class BasicDesktopIconUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicDesktopIconUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicDesktopIconUI

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicDesktopIconUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicDesktopIconUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthDesktopPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
          • javax.swing.plaf.synth.SynthDesktopPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthDesktopPaneUI
extends BasicDesktopPaneUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JDesktopPane.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicDesktopPaneUI

        BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicDesktopPaneUI

        closeKey, desktop, desktopManager, maximizeKey, minimizeKey, navigateKey, navigateKey2

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthDesktopPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults()
      protected void | installDesktopManager()
      protected void installListeners()
      Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallDesktopManager()
      protected void uninstallListeners()
      Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicDesktopPaneUI

        createPropertyChangeListener, getMaximumSize, getMinimumSize, getPreferredSize, installKeyboardActions, installUI, registerKeyboardActions, uninstallKeyboardActions, uninstallUI, unregisterKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthDesktopPaneUI

        public SynthDesktopPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installListeners

        protected void installListeners()
        Description copied from class: BasicDesktopPaneUI
        Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
        重载：
        installListeners in class BasicDesktopPaneUI
        另请参见：
        BasicDesktopPaneUI.createPropertyChangeListener()

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicDesktopPaneUI

      • uninstallListeners

        protected void uninstallListeners()
        Description copied from class: BasicDesktopPaneUI
        Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
        重载：
        uninstallListeners in class BasicDesktopPaneUI
        另请参见：
        BasicDesktopPaneUI.createPropertyChangeListener()

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicDesktopPaneUI

      • installDesktopManager

        protected void installDesktopManager()
        重载：
        installDesktopManager in class BasicDesktopPaneUI

      • uninstallDesktopManager

        protected void uninstallDesktopManager()
        重载：
        uninstallDesktopManager in class BasicDesktopPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicDesktopPaneUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

os


SynthEditorPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthEditorPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.synth.SynthEditorPaneUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory
    直接已知子类：
    SynthTextPaneUI

    public class SynthEditorPaneUI
extends BasicEditorPaneUI
implements SynthUI
    Provides the Synth L&F UI delegate for JEditorPane.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthEditorPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void paintBackground(Graphics g)
      Paints a background for the view.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.
      protected void uninstallDefaults()
      Sets the component properties that have not been explicitly overridden to null.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicEditorPaneUI

        getEditorKit, getPropertyPrefix, installUI, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthEditorPaneUI

        public SynthEditorPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicTextUI
        Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

      • uninstallDefaults

        protected void uninstallDefaults()
        Description copied from class: BasicTextUI
        Sets the component properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        重载：
        uninstallDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.installDefaults(), BasicTextUI.uninstallUI(javax.swing.JComponent)

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to rebuild the ActionMap based upon an EditorKit change.
        重载：
        propertyChange in class BasicEditorPaneUI
        参数：
        evt - the property change event

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class BasicTextUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBackground

        protected void paintBackground(Graphics g)
        Description copied from class: BasicTextUI
        Paints a background for the view. This will only be called if isOpaque() on the associated component is true. The default is to paint the background color of the component.
        重载：
        paintBackground in class BasicTextUI
        参数：
        g - the graphics context

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa>psplp/psn<>nn<蓅sySsstDDIhlSypDIechhntnnx


SynthFormattedTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthFormattedTextFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.synth.SynthTextFieldUI
              • javax.swing.plaf.synth.SynthFormattedTextFieldUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory

    public class SynthFormattedTextFieldUI
extends SynthTextFieldUI
    Provides the Synth L&F UI delegate for JFormattedTextField.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthFormattedTextFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JFormattedTextField.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthTextFieldUI

        getContext, installDefaults, paint, paintBackground, propertyChange, uninstallDefaults, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        create, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, uninstallUI, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthFormattedTextFieldUI

        public SynthFormattedTextFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JFormattedTextField.
        参数：
        c - the formatted text field
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicTextFieldUI
        返回：
        the name "FormattedTextField"

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthTextFieldUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ti.yytantalffallij..tsblc<iki4.=cl4


SynthGraphicsUtils

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthGraphicsUtils

  • java.lang.Object
    • javax.swing.plaf.synth.SynthGraphicsUtils

  • public class SynthGraphicsUtils
extends Object
    Wrapper for primitive graphics calls.
    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthGraphicsUtils()
      Creates a SynthGraphicsUtils.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text)
      Returns the size of the passed in string.
      void drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)
      Draws a line between the two end points.
      void drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)
      Draws a line between the two end points.
      int getMaximumCharHeight(SynthContext context)
      Returns the maximum height of the the Font from the passed in SynthContext.
      Dimension getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the maximum size needed to properly render an icon and text.
      Dimension getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the minimum size needed to properly render an icon and text.
      Dimension getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the preferred size needed to properly render an icon and text.
      String layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
      Lays out text and an icon returning, by reference, the location to place the icon and text.
      void paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
      Paints an icon and text.
      void paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)
      Paints text at the specified location.
      void paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
      Paints text at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthGraphicsUtils

        public SynthGraphicsUtils()
        Creates a SynthGraphicsUtils.

    • 方法详细信息

      • drawLine

        public void drawLine(SynthContext context,
            Object paintKey,
            Graphics g,
            int x1,
            int y1,
            int x2,
            int y2)
        Draws a line between the two end points.
        参数：
        context - Identifies hosting region.
        paintKey - Identifies the portion of the component being asked to paint, may be null.
        g - Graphics object to paint to
        x1 - x origin
        y1 - y origin
        x2 - x destination
        y2 - y destination

      • drawLine

        public void drawLine(SynthContext context,
            Object paintKey,
            Graphics g,
            int x1,
            int y1,
            int x2,
            int y2,
            Object styleKey)
        Draws a line between the two end points.

        This implementation supports only one line style key, "dashed". The "dashed" line style is applied only to vertical and horizontal lines.

        Specifying null or any key different from "dashed" will draw solid lines.

        参数：
        context - identifies hosting region
        paintKey - identifies the portion of the component being asked to paint, may be null
        g - Graphics object to paint to
        x1 - x origin
        y1 - y origin
        x2 - x destination
        y2 - y destination
        styleKey - identifies the requested style of the line (e.g. "dashed")
        从以下版本开始：
        1.6

      • layoutText

        public String layoutText(SynthContext ss,
                FontMetrics fm,
                String text,
                Icon icon,
                int hAlign,
                int vAlign,
                int hTextPosition,
                int vTextPosition,
                Rectangle viewR,
                Rectangle iconR,
                Rectangle textR,
                int iconTextGap)
        Lays out text and an icon returning, by reference, the location to place the icon and text.
        参数：
        ss - SynthContext
        fm - FontMetrics for the Font to use, this may be ignored
        text - Text to layout
        icon - Icon to layout
        hAlign - horizontal alignment
        vAlign - vertical alignment
        hTextPosition - horizontal text position
        vTextPosition - vertical text position
        viewR - Rectangle to layout text and icon in.
        iconR - Rectangle to place icon bounds in
        textR - Rectangle to place text in
        iconTextGap - gap between icon and text

      • computeStringWidth

        public int computeStringWidth(SynthContext ss,
                     Font font,
                     FontMetrics metrics,
                     String text)
        Returns the size of the passed in string.
        参数：
        ss - SynthContext
        font - Font to use
        metrics - FontMetrics, may be ignored
        text - Text to get size of.

      • getMinimumSize

        public Dimension getMinimumSize(SynthContext ss,
                       Font font,
                       String text,
                       Icon icon,
                       int hAlign,
                       int vAlign,
                       int hTextPosition,
                       int vTextPosition,
                       int iconTextGap,
                       int mnemonicIndex)
        Returns the minimum size needed to properly render an icon and text.
        参数：
        ss - SynthContext
        font - Font to use
        text - Text to layout
        icon - Icon to layout
        hAlign - horizontal alignment
        vAlign - vertical alignment
        hTextPosition - horizontal text position
        vTextPosition - vertical text position
        iconTextGap - gap between icon and text
        mnemonicIndex - Index into text to render the mnemonic at, -1 indicates no mnemonic.

      • getMaximumSize

        public Dimension getMaximumSize(SynthContext ss,
                       Font font,
                       String text,
                       Icon icon,
                       int hAlign,
                       int vAlign,
                       int hTextPosition,
                       int vTextPosition,
                       int iconTextGap,
                       int mnemonicIndex)
        Returns the maximum size needed to properly render an icon and text.
        参数：
        ss - SynthContext
        font - Font to use
        text - Text to layout
        icon - Icon to layout
        hAlign - horizontal alignment
        vAlign - vertical alignment
        hTextPosition - horizontal text position
        vTextPosition - vertical text position
        iconTextGap - gap between icon and text
        mnemonicIndex - Index into text to render the mnemonic at, -1 indicates no mnemonic.

      • getMaximumCharHeight

        public int getMaximumCharHeight(SynthContext context)
        Returns the maximum height of the the Font from the passed in SynthContext.
        参数：
        context - SynthContext used to determine font.
        返回：
        maximum height of the characters for the font from the passed in context.

      • getPreferredSize

        public Dimension getPreferredSize(SynthContext ss,
                         Font font,
                         String text,
                         Icon icon,
                         int hAlign,
                         int vAlign,
                         int hTextPosition,
                         int vTextPosition,
                         int iconTextGap,
                         int mnemonicIndex)
        Returns the preferred size needed to properly render an icon and text.
        参数：
        ss - SynthContext
        font - Font to use
        text - Text to layout
        icon - Icon to layout
        hAlign - horizontal alignment
        vAlign - vertical alignment
        hTextPosition - horizontal text position
        vTextPosition - vertical text position
        iconTextGap - gap between icon and text
        mnemonicIndex - Index into text to render the mnemonic at, -1 indicates no mnemonic.

      • paintText

        public void paintText(SynthContext ss,
             Graphics g,
             String text,
             Rectangle bounds,
             int mnemonicIndex)
        Paints text at the specified location. This will not attempt to render the text as html nor will it offset by the insets of the component.
        参数：
        ss - SynthContext
        g - Graphics used to render string in.
        text - Text to render
        bounds - Bounds of the text to be drawn.
        mnemonicIndex - Index to draw string at.

      • paintText

        public void paintText(SynthContext ss,
             Graphics g,
             String text,
             int x,
             int y,
             int mnemonicIndex)
        Paints text at the specified location. This will not attempt to render the text as html nor will it offset by the insets of the component.
        参数：
        ss - SynthContext
        g - Graphics used to render string in.
        text - Text to render
        x - X location to draw text at.
        y - Upper left corner to draw text at.
        mnemonicIndex - Index to draw string at.

      • paintText

        public void paintText(SynthContext ss,
             Graphics g,
             String text,
             Icon icon,
             int hAlign,
             int vAlign,
             int hTextPosition,
             int vTextPosition,
             int iconTextGap,
             int mnemonicIndex,
             int textOffset)
        Paints an icon and text. This will render the text as html, if necessary, and offset the location by the insets of the component.
        参数：
        ss - SynthContext
        g - Graphics to render string and icon into
        text - Text to layout
        icon - Icon to layout
        hAlign - horizontal alignment
        vAlign - vertical alignment
        hTextPosition - horizontal text position
        vTextPosition - vertical text position
        iconTextGap - gap between icon and text
        mnemonicIndex - Index into text to render the mnemonic at, -1 indicates no mnemonic.
        textOffset - Amount to offset the text when painting
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthInternalFrameUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.synth.SynthInternalFrameUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthInternalFrameUI
extends BasicInternalFrameUI
implements SynthUI, PropertyChangeListener
    Provides the Synth L&F UI delegate for JInternalFrame.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicInternalFrameUI

        BasicInternalFrameUI.BasicInternalFrameListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.ComponentHandler, BasicInternalFrameUI.GlassPaneDispatcher, BasicInternalFrameUI.InternalFrameLayout, BasicInternalFrameUI.InternalFramePropertyChangeListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicInternalFrameUI

        borderListener, componentListener, eastPane, frame, glassPaneDispatcher, internalFrameLayout, northPane, openMenuKey, propertyChangeListener, southPane, titlePane, westPane

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | SynthInternalFrameUI(JInternalFrame b)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected ComponentListener | createComponentListener()
      protected JComponent | createNorthPane(JInternalFrame w)
      static ComponentUI createUI(JComponent b)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicInternalFrameUI

        activateFrame, closeFrame, createBorderListener, createDesktopManager, createEastPane, createGlassPaneDispatcher, createInternalFrameListener, createLayoutManager, createPropertyChangeListener, createSouthPane, createWestPane, deactivateFrame, deiconifyFrame, deinstallMouseHandlers, getDesktopManager, getEastPane, getMaximumSize, getMinimumSize, getNorthPane, getPreferredSize, getSouthPane, getWestPane, iconifyFrame, installComponents, installKeyboardActions, installMouseHandlers, installUI, isKeyBindingActive, isKeyBindingRegistered, maximizeFrame, minimizeFrame, replacePane, setEastPane, setKeyBindingActive, setKeyBindingRegistered, setNorthPane, setSouthPane, setupMenuCloseKey, setupMenuOpenKey, setWestPane, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthInternalFrameUI

        protected SynthInternalFrameUI(JInternalFrame b)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)
        Creates a new UI object for the given component.
        参数：
        b - component to create UI object for
        返回：
        the UI object

      • installDefaults

        public void installDefaults()
        重载：
        installDefaults in class BasicInternalFrameUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicInternalFrameUI

      • uninstallComponents

        protected void uninstallComponents()
        重载：
        uninstallComponents in class BasicInternalFrameUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicInternalFrameUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicInternalFrameUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • createNorthPane

        protected JComponent createNorthPane(JInternalFrame w)
        重载：
        createNorthPane in class BasicInternalFrameUI

      • createComponentListener

        protected ComponentListener createComponentListener()
        重载：
        createComponentListener in class BasicInternalFrameUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthLabelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI
          • javax.swing.plaf.synth.SynthLabelUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthLabelUI
extends BasicLabelUI
implements SynthUI
    Provides the Synth L&F UI delegate for JLabel.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicLabelUI

        labelUI

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthLabelUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Returns the LabelUI implementation used for the skins look and feel.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JLabel c)
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults(JLabel c)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicLabelUI

        getBaselineResizeBehavior, installComponents, installKeyboardActions, installListeners, installUI, layoutCL, paintDisabledText, paintEnabledText, uninstallComponents, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthLabelUI

        public SynthLabelUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Returns the LabelUI implementation used for the skins look and feel.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults(JLabel c)
        重载：
        installDefaults in class BasicLabelUI

      • uninstallDefaults

        protected void uninstallDefaults(JLabel c)
        重载：
        uninstallDefaults in class BasicLabelUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Description copied from class: BasicLabelUI
        Returns the baseline.
        重载：
        getBaseline in class BasicLabelUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        另请参见：
        JComponent.getBaseline(int, int)

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicLabelUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicLabelUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class BasicLabelUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        getPreferredSize(c)
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class BasicLabelUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        getPreferredSize(c)
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        重载：
        propertyChange in class BasicLabelUI
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ih>/p///l/<>/l//<鄌onntUSebbttl"ltalsiitlag at>p


SynthListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthListUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
          • javax.swing.plaf.synth.SynthListUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthListUI
extends BasicListUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JList.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicListUI

        BasicListUI.FocusHandler, BasicListUI.ListDataHandler, BasicListUI.ListSelectionHandler, BasicListUI.MouseInputHandler, BasicListUI.PropertyChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicListUI

        cellHeight, cellHeights, cellRendererChanged, cellWidth, fixedCellHeightChanged, fixedCellWidthChanged, focusListener, fontChanged, list, listDataListener, listSelectionListener, modelChanged, mouseInputListener, propertyChangeListener, prototypeCellValueChanged, rendererPane, selectionModelChanged, updateLayoutStateNeeded

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthListUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent list)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes list properties such as font, foreground, and background, and adds the CellRendererPane.
      protected void installListeners()
      Creates and installs the listeners for the JList, its model, and its selectionModel.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void uninstallDefaults()
      Sets the list properties that have not been explicitly overridden to null.
      protected void uninstallListeners()
      Removes the listeners from the JList, its model, and its selectionModel.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicListUI

        convertRowToY, convertYToRow, createFocusListener, createListDataListener, createListSelectionListener, createMouseInputListener, createPropertyChangeListener, getBaseline, getBaselineResizeBehavior, getCellBounds, getPreferredSize, getRowHeight, indexToLocation, installKeyboardActions, installUI, locationToIndex, maybeUpdateLayoutState, paint, paintCell, selectNextIndex, selectPreviousIndex, uninstallKeyboardActions, uninstallUI, updateLayoutState

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthListUI

        public SynthListUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent list)
        Creates a new UI object for the given component.
        参数：
        list - component to create UI object for
        返回：
        the UI object

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the BasicListUI.paint(java.awt.Graphics, javax.swing.JComponent) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        BasicListUI.paint(java.awt.Graphics, javax.swing.JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • installListeners

        protected void installListeners()
        Description copied from class: BasicListUI
        Creates and installs the listeners for the JList, its model, and its selectionModel. This method is called at installUI() time.
        重载：
        installListeners in class BasicListUI
        另请参见：
        BasicListUI.installUI(javax.swing.JComponent), BasicListUI.uninstallListeners()

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • uninstallListeners

        protected void uninstallListeners()
        Description copied from class: BasicListUI
        Removes the listeners from the JList, its model, and its selectionModel. All of the listener fields, are reset to null here. This method is called at uninstallUI() time, it should be kept in sync with installListeners.
        重载：
        uninstallListeners in class BasicListUI
        另请参见：
        BasicListUI.uninstallUI(javax.swing.JComponent), BasicListUI.installListeners()

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicListUI
        Initializes list properties such as font, foreground, and background, and adds the CellRendererPane. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicListUI
        另请参见：
        BasicListUI.uninstallDefaults(), BasicListUI.installUI(javax.swing.JComponent), CellRendererPane

      • uninstallDefaults

        protected void uninstallDefaults()
        Description copied from class: BasicListUI
        Sets the list properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        重载：
        uninstallDefaults in class BasicListUI
        另请参见：
        BasicListUI.installDefaults(), BasicListUI.uninstallUI(javax.swing.JComponent), CellRendererPane

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et(pm#rl#re..reeiyeeDnr"cseicnioforpocc. ecas."ie


SynthLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthLookAndFeel

  • java.lang.Object
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel
        • javax.swing.plaf.synth.SynthLookAndFeel
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    NimbusLookAndFeel

    public class SynthLookAndFeel
extends BasicLookAndFeel
    SynthLookAndFeel provides the basis for creating a customized look and feel. SynthLookAndFeel does not directly provide a look, all painting is delegated. You need to either provide a configuration file, by way of the load(java.io.InputStream, java.lang.Class) method, or provide your own SynthStyleFactory to setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory). Refer to the 软件包 summary for an example of loading a file, and SynthStyleFactory for an example of providing your own SynthStyleFactory to setStyleFactory.

    警告： This class implements Serializable as a side effect of it extending BasicLookAndFeel. It is not intended to be serialized. An attempt to serialize it will result in NotSerializableException.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthLookAndFeel()
      Creates a SynthLookAndFeel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates the Synth look and feel ComponentUI for the passed in JComponent.
      UIDefaults getDefaults()
      Returns the defaults for this SynthLookAndFeel.
      String getDescription()
      Returns a textual description of SynthLookAndFeel.
      String getID()
      Return a string that identifies this look and feel.
      String getName()
      Return a short string that identifies this look and feel.
      static Region getRegion(JComponent c)
      Returns the Region for the JComponent c.
      static SynthStyle getStyle(JComponent c, Region region)
      Gets a SynthStyle for the specified region of the specified component.
      static SynthStyleFactory getStyleFactory()
      Returns the current SynthStyleFactory.
      void initialize()
      Called by UIManager when this look and feel is installed.
      boolean isNativeLookAndFeel()
      Returns false, SynthLookAndFeel is not a native look and feel.
      boolean isSupportedLookAndFeel()
      Returns true, SynthLookAndFeel is always supported.
      void load(InputStream input, 类<?> resourceBase)
      Loads the set of SynthStyles that will be used by this SynthLookAndFeel.
      void load(URL url)
      Loads the set of SynthStyles that will be used by this SynthLookAndFeel.
      static void setStyleFactory(SynthStyleFactory cache)
      Sets the SynthStyleFactory that the UI classes provided by synth will use to obtain a SynthStyle.
      boolean shouldUpdateStyleOnAncestorChanged()
      Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes.
      protected boolean shouldUpdateStyleOnEvent(PropertyChangeEvent ev)
      Returns whether or not the UIs should update their styles when a particular event occurs.
      void uninitialize()
      Called by UIManager when this look and feel is uninstalled.
      static void updateStyles(Component c)
      Updates the style associated with c, and all its children.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicLookAndFeel

        createAudioAction, getAudioActionMap, initClassDefaults, initComponentDefaults, initSystemColorDefaults, loadSystemColors, playSound

      • 方法 - 继承于类 javax.swing.LookAndFeel

        getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getLayoutStyle, getSupportsWindowDecorations, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninstallBorder

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SynthLookAndFeel

        public SynthLookAndFeel()
        Creates a SynthLookAndFeel.

        For the returned SynthLookAndFeel to be useful you need to invoke load to specify the set of SynthStyles, or invoke setStyleFactory.

        另请参见：
        load(java.io.InputStream, java.lang.Class), setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory)

    • 方法详细信息

      • setStyleFactory

        public static void setStyleFactory(SynthStyleFactory cache)
        Sets the SynthStyleFactory that the UI classes provided by synth will use to obtain a SynthStyle.
        参数：
        cache - SynthStyleFactory the UIs should use.

      • getStyleFactory

        public static SynthStyleFactory getStyleFactory()
        Returns the current SynthStyleFactory.
        返回：
        SynthStyleFactory

      • getStyle

        public static SynthStyle getStyle(JComponent c,
                  Region region)
        Gets a SynthStyle for the specified region of the specified component. This is not for general consumption, only custom UIs should call this method.
        参数：
        c - JComponent to get the SynthStyle for
        region - Identifies the region of the specified component
        返回：
        SynthStyle to use.

      • updateStyles

        public static void updateStyles(Component c)
        Updates the style associated with c, and all its children. This is a lighter version of SwingUtilities.updateComponentTreeUI.
        参数：
        c - Component to update style for.

      • getRegion

        public static Region getRegion(JComponent c)
        Returns the Region for the JComponent c.
        参数：
        c - JComponent to fetch the Region for
        返回：
        Region corresponding to c

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates the Synth look and feel ComponentUI for the passed in JComponent.
        参数：
        c - JComponent to create the ComponentUI for
        返回：
        ComponentUI to use for c

      • load

        public void load(InputStream input,
        类<?> resourceBase)
          throws ParseException
        Loads the set of SynthStyles that will be used by this SynthLookAndFeel. resourceBase is used to resolve any path based resources, for example an Image would be resolved by resourceBase.getResource(path). Refer to Synth File Format for more information.
        参数：
        input - InputStream to load from
        resourceBase - used to resolve any images or other resources
        抛出：
        ParseException - if there is an error in parsing
        IllegalArgumentException - if input or resourceBase is null

      • load

        public void load(URL url)
          throws ParseException,
                 IOException
        Loads the set of SynthStyles that will be used by this SynthLookAndFeel. Path based resources are resolved relatively to the specified URL of the style. For example an Image would be resolved by new URL(synthFile, path). Refer to Synth File Format for more information.
        参数：
        url - the URL to load the set of SynthStyle from
        抛出：
        ParseException - if there is an error in parsing
        IllegalArgumentException - if synthSet is null
        IOException - if synthSet cannot be opened as an InputStream
        从以下版本开始：
        1.6

      • initialize

        public void initialize()
        Called by UIManager when this look and feel is installed.
        重载：
        initialize in class BasicLookAndFeel
        另请参见：
        LookAndFeel.uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • uninitialize

        public void uninitialize()
        Called by UIManager when this look and feel is uninstalled.
        重载：
        uninitialize in class BasicLookAndFeel
        另请参见：
        LookAndFeel.initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • getDefaults

        public UIDefaults getDefaults()
        Returns the defaults for this SynthLookAndFeel.
        重载：
        getDefaults in class BasicLookAndFeel
        返回：
        Defaults table.
        另请参见：
        BasicLookAndFeel.initClassDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initSystemColorDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)

      • isSupportedLookAndFeel

        public boolean isSupportedLookAndFeel()
        Returns true, SynthLookAndFeel is always supported.
        指定者：
        isSupportedLookAndFeel in class LookAndFeel
        返回：
        true.
        另请参见：
        UIManager.setLookAndFeel(javax.swing.LookAndFeel)

      • isNativeLookAndFeel

        public boolean isNativeLookAndFeel()
        Returns false, SynthLookAndFeel is not a native look and feel.
        指定者：
        isNativeLookAndFeel in class LookAndFeel
        返回：
        false

      • getDescription

        public String getDescription()
        Returns a textual description of SynthLookAndFeel.
        指定者：
        getDescription in class LookAndFeel
        返回：
        textual description of synth.

      • getName

        public String getName()
        Return a short string that identifies this look and feel.
        指定者：
        getName in class LookAndFeel
        返回：
        a short string identifying this look and feel.

      • getID

        public String getID()
        Return a string that identifies this look and feel.
        指定者：
        getID in class LookAndFeel
        返回：
        a short string identifying this look and feel.

      • shouldUpdateStyleOnAncestorChanged

        public boolean shouldUpdateStyleOnAncestorChanged()
        Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes. A subclass that provided a SynthStyleFactory that based the return value from getStyle off the containment hierarchy would override this method to return true.
        返回：
        whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor changed.

      • shouldUpdateStyleOnEvent

        protected boolean shouldUpdateStyleOnEvent(PropertyChangeEvent ev)
        Returns whether or not the UIs should update their styles when a particular event occurs.
        参数：
        ev - a PropertyChangeEvent
        返回：
        whether or not the UIs should update their styles
        从以下版本开始：
        1.7
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r.o


SynthMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthMenuBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.synth.SynthMenuBarUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthMenuBarUI
extends BasicMenuBarUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JMenuBar.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuBarUI

        changeListener, containerListener, menuBar

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthMenuBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuBarUI

        createChangeListener, createContainerListener, getMaximumSize, getMinimumSize, installKeyboardActions, installUI, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthMenuBarUI

        public SynthMenuBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicMenuBarUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicMenuBarUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicMenuBarUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicMenuBarUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lstpa&t>&tlsstllDwsspr4c


SynthMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.synth.SynthMenuItemUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI
    直接已知子类：
    SynthCheckBoxMenuItemUI, SynthRadioButtonMenuItemUI

    public class SynthMenuItemUI
extends BasicMenuItemUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JMenuItem.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected Dimension | getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredSize, getPropertyPrefix, installComponents, installKeyboardActions, installUI, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthMenuItemUI

        public SynthMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicMenuItemUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicMenuItemUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicMenuItemUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicMenuItemUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicMenuItemUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getPreferredMenuItemSize

        protected Dimension getPreferredMenuItemSize(JComponent c,
                                 Icon checkIcon,
                                 Icon arrowIcon,
                                 int defaultTextIconGap)
        重载：
        getPreferredMenuItemSize in class BasicMenuItemUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class BasicMenuItemUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicMenuItemUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;l;


SynthMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
              • javax.swing.plaf.synth.SynthMenuUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthMenuUI
extends BasicMenuUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JMenu.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuUI

        BasicMenuUI.ChangeHandler, BasicMenuUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuUI

        changeListener, menuListener

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected Dimension | getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuUI

        createChangeListener, createMenuDragMouseListener, createMenuKeyListener, createMenuListener, createMouseInputListener, createPropertyChangeListener, getMaximumSize, getPropertyPrefix, installKeyboardActions, setupPostTimer, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        doClick, getMinimumSize, getPath, getPreferredSize, installComponents, installUI, paintBackground, paintMenuItem, paintText, uninstallComponents

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthMenuUI

        public SynthMenuUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicMenuUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicMenuUI

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicMenuItemUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicMenuUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicMenuUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getPreferredMenuItemSize

        protected Dimension getPreferredMenuItemSize(JComponent c,
                                 Icon checkIcon,
                                 Icon arrowIcon,
                                 int defaultTextIconGap)
        重载：
        getPreferredMenuItemSize in class BasicMenuItemUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class BasicMenuItemUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicMenuItemUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthOptionPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
          • javax.swing.plaf.synth.SynthOptionPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthOptionPaneUI
extends BasicOptionPaneUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JOptionPane.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicOptionPaneUI

        BasicOptionPaneUI.ButtonActionListener, BasicOptionPaneUI.ButtonAreaLayout, BasicOptionPaneUI.PropertyChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicOptionPaneUI

        hasCustomComponents, initialFocusComponent, inputComponent, MinimumHeight, minimumSize, MinimumWidth, optionPane, propertyChangeListener

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthOptionPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected Container createMessageArea()
      Called from installComponents() to create a Container containing the body of the message.
      protected Container | createSeparator()
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected boolean getSizeButtonsToSameWidth()
      Returns true, basic L&F wants all the buttons to have the same width.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicOptionPaneUI

        addButtonComponents, addIcon, addMessageComponents, burstStringInto, containsCustomComponents, createButtonActionListener, createButtonArea, createLayoutManager, createPropertyChangeListener, getButtons, getIcon, getIconForType, getInitialValueIndex, getMaxCharactersPerLineCount, getMessage, getMinimumOptionPaneSize, getPreferredSize, installKeyboardActions, installUI, resetInputValue, selectInitialValue, uninstallComponents, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthOptionPaneUI

        public SynthOptionPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicOptionPaneUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicOptionPaneUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicOptionPaneUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicOptionPaneUI

      • installComponents

        protected void installComponents()
        重载：
        installComponents in class BasicOptionPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • getSizeButtonsToSameWidth

        protected boolean getSizeButtonsToSameWidth()
        Description copied from class: BasicOptionPaneUI
        Returns true, basic L&F wants all the buttons to have the same width.
        重载：
        getSizeButtonsToSameWidth in class BasicOptionPaneUI

      • createMessageArea

        protected Container createMessageArea()
        Called from installComponents() to create a Container containing the body of the message. The icon is the created by calling BasicOptionPaneUI.addIcon(java.awt.Container).
        重载：
        createMessageArea in class BasicOptionPaneUI

      • createSeparator

        protected Container createSeparator()
        重载：
        createSeparator in class BasicOptionPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>" vsv=v"vait">ltu<


SynthPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthPainter

  • java.lang.Object
    • javax.swing.plaf.synth.SynthPainter

  • public abstract class SynthPainter
extends Object
    SynthPainter is used for painting portions of JComponents. At a minimum each JComponent has two paint methods: one for the border and one for the background. Some JComponents have more than one Region, and as a consequence more paint methods.

    Instances of SynthPainter are obtained from the SynthStyle.getPainter(javax.swing.plaf.synth.SynthContext) method.

    You typically supply a SynthPainter by way of Synth's file format. The following example registers a painter for all JButtons that will render the image myImage.png:

      <style id="buttonStyle">
    <imagePainter path="myImage.png" sourceInsets="2 2 2 2"
                  paintCenter="true" stretch="true"/>
    <insets top="2" bottom="2" left="2" right="2"/>
  </style>
  <bind style="buttonStyle" type="REGION" key="button"/>

    SynthPainter is abstract in so far as it does no painting, all the methods are empty. While none of these methods are typed to throw an exception, subclasses can assume that valid arguments are passed in, and if not they can throw a NullPointerException or IllegalArgumentException in response to invalid arguments.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthPainter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an arrow button.
      void paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an arrow button.
      void paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction)
      Paints the foreground of an arrow button.
      void paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a button.
      void paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a button.
      void paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a check box.
      void paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a check box.
      void paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a check box menu item.
      void paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a check box menu item.
      void paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a color chooser.
      void paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a color chooser.
      void paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a combo box.
      void paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a combo box.
      void paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop icon.
      void paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a desktop icon.
      void paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop pane.
      void paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop pane.
      void paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an editor pane.
      void paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an editor pane.
      void paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a file chooser.
      void paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a file chooser.
      void paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a formatted text field.
      void paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a formatted text field.
      void paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an internal frame.
      void paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an internal frame.
      void paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an internal frame title pane.
      void paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an internal frame title pane.
      void paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a label.
      void paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a label.
      void paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a list.
      void paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a list.
      void paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu.
      void paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu bar.
      void paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu bar.
      void paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu.
      void paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu item.
      void paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu item.
      void paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an option pane.
      void paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an option pane.
      void paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a panel.
      void paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a panel.
      void paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a password field.
      void paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a password field.
      void paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a popup menu.
      void paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a popup menu.
      void paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a progress bar.
      void paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a progress bar.
      void paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a progress bar.
      void paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a progress bar.
      void paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of a progress bar.
      void paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a radio button.
      void paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a radio button.
      void paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a radio button menu item.
      void paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a radio button menu item.
      void paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a root pane.
      void paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a root pane.
      void paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a scrollbar.
      void paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a scrollbar.
      void paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a scrollbar.
      void paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a scrollbar.
      void paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the thumb of a scrollbar.
      void paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the thumb of a scrollbar.
      void paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the track of a scrollbar.
      void paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the track of a scrollbar.
      void paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the track of a scrollbar.
      void paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the track of a scrollbar.
      void paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a scroll pane.
      void paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a scroll pane.
      void paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a separator.
      void paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a separator.
      void paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a separator.
      void paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a separator.
      void paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of a separator.
      void paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a slider.
      void paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a slider.
      void paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a slider.
      void paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a slider.
      void paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the thumb of a slider.
      void paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the thumb of a slider.
      void paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the track of a slider.
      void paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the track of a slider.
      void paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the track of a slider.
      void paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the track of a slider.
      void paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a spinner.
      void paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a spinner.
      void paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a split pane.
      void paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a split pane.
      void paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the divider of a split pane.
      void paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the divider of a split pane.
      void paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of the divider of a split pane.
      void paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the divider, when the user is dragging the divider, of a split pane.
      void paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tabbed pane.
      void paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tabbed pane.
      void paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the area that contains the content of the selected tab of a tabbed pane.
      void paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the area that contains the content of the selected tab of a tabbed pane.
      void paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the area behind the tabs of a tabbed pane.
      void paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the area behind the tabs of a tabbed pane.
      void paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the area behind the tabs of a tabbed pane.
      void paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the area behind the tabs of a tabbed pane.
      void paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      Paints the background of a tab of a tabbed pane.
      void paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      Paints the background of a tab of a tabbed pane.
      void paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      Paints the border of a tab of a tabbed pane.
      void paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      Paints the border of a tab of a tabbed pane.
      void paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a table.
      void paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a table.
      void paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the header of a table.
      void paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the header of a table.
      void paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text area.
      void paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text area.
      void paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text field.
      void paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text field.
      void paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text pane.
      void paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text pane.
      void paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a toggle button.
      void paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a toggle button.
      void paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tool bar.
      void paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a tool bar.
      void paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tool bar.
      void paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a tool bar.
      void paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the tool bar's content area.
      void paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the tool bar's content area.
      void paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the content area of a tool bar.
      void paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the content area of a tool bar.
      void paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the window containing the tool bar when it has been detached from its primary frame.
      void paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the window containing the tool bar when it has been detached from its primary frame.
      void paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
      void paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
      void paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tool tip.
      void paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tool tip.
      void paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tree.
      void paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tree.
      void paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the row containing a cell in a tree.
      void paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the row containing a cell in a tree.
      void paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the focus indicator for a cell in a tree when it has focus.
      void paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the viewport.
      void paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a viewport.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthPainter

        public SynthPainter()

    • 方法详细信息

      • paintArrowButtonBackground

        public void paintArrowButtonBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of an arrow button. Arrow buttons are created by some components, such as JScrollBar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintArrowButtonBorder

        public void paintArrowButtonBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of an arrow button. Arrow buttons are created by some components, such as JScrollBar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintArrowButtonForeground

        public void paintArrowButtonForeground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int direction)
        Paints the foreground of an arrow button. This method is responsible for drawing a graphical representation of a direction, typically an arrow. Arrow buttons are created by some components, such as JScrollBar
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        direction - One of SwingConstants.NORTH, SwingConstants.SOUTH SwingConstants.EAST or SwingConstants.WEST

      • paintButtonBackground

        public void paintButtonBackground(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the background of a button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintButtonBorder

        public void paintButtonBorder(SynthContext context,
                     Graphics g,
                     int x,
                     int y,
                     int w,
                     int h)
        Paints the border of a button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintCheckBoxMenuItemBackground

        public void paintCheckBoxMenuItemBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
        Paints the background of a check box menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintCheckBoxMenuItemBorder

        public void paintCheckBoxMenuItemBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
        Paints the border of a check box menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintCheckBoxBackground

        public void paintCheckBoxBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a check box.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintCheckBoxBorder

        public void paintCheckBoxBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a check box.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintColorChooserBackground

        public void paintColorChooserBackground(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
        Paints the background of a color chooser.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintColorChooserBorder

        public void paintColorChooserBorder(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the border of a color chooser.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintComboBoxBackground

        public void paintComboBoxBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a combo box.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintComboBoxBorder

        public void paintComboBoxBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a combo box.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintDesktopIconBackground

        public void paintDesktopIconBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of a desktop icon.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintDesktopIconBorder

        public void paintDesktopIconBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of a desktop icon.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintDesktopPaneBackground

        public void paintDesktopPaneBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of a desktop pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintDesktopPaneBorder

        public void paintDesktopPaneBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the background of a desktop pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintEditorPaneBackground

        public void paintEditorPaneBackground(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the background of an editor pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintEditorPaneBorder

        public void paintEditorPaneBorder(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the border of an editor pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintFileChooserBackground

        public void paintFileChooserBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of a file chooser.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintFileChooserBorder

        public void paintFileChooserBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of a file chooser.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintFormattedTextFieldBackground

        public void paintFormattedTextFieldBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
        Paints the background of a formatted text field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintFormattedTextFieldBorder

        public void paintFormattedTextFieldBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
        Paints the border of a formatted text field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintInternalFrameTitlePaneBackground

        public void paintInternalFrameTitlePaneBackground(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
        Paints the background of an internal frame title pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintInternalFrameTitlePaneBorder

        public void paintInternalFrameTitlePaneBorder(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
        Paints the border of an internal frame title pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintInternalFrameBackground

        public void paintInternalFrameBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
        Paints the background of an internal frame.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintInternalFrameBorder

        public void paintInternalFrameBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the border of an internal frame.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintLabelBackground

        public void paintLabelBackground(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the background of a label.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintLabelBorder

        public void paintLabelBorder(SynthContext context,
                    Graphics g,
                    int x,
                    int y,
                    int w,
                    int h)
        Paints the border of a label.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintListBackground

        public void paintListBackground(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the background of a list.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintListBorder

        public void paintListBorder(SynthContext context,
                   Graphics g,
                   int x,
                   int y,
                   int w,
                   int h)
        Paints the border of a list.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuBarBackground

        public void paintMenuBarBackground(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the background of a menu bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuBarBorder

        public void paintMenuBarBorder(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h)
        Paints the border of a menu bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuItemBackground

        public void paintMenuItemBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuItemBorder

        public void paintMenuItemBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuBackground

        public void paintMenuBackground(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the background of a menu.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintMenuBorder

        public void paintMenuBorder(SynthContext context,
                   Graphics g,
                   int x,
                   int y,
                   int w,
                   int h)
        Paints the border of a menu.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintOptionPaneBackground

        public void paintOptionPaneBackground(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the background of an option pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintOptionPaneBorder

        public void paintOptionPaneBorder(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the border of an option pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPanelBackground

        public void paintPanelBackground(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the background of a panel.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPanelBorder

        public void paintPanelBorder(SynthContext context,
                    Graphics g,
                    int x,
                    int y,
                    int w,
                    int h)
        Paints the border of a panel.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPasswordFieldBackground

        public void paintPasswordFieldBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
        Paints the background of a password field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPasswordFieldBorder

        public void paintPasswordFieldBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the border of a password field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPopupMenuBackground

        public void paintPopupMenuBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the background of a popup menu.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintPopupMenuBorder

        public void paintPopupMenuBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the border of a popup menu.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintProgressBarBackground

        public void paintProgressBarBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of a progress bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintProgressBarBackground

        public void paintProgressBarBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int orientation)
        Paints the background of a progress bar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - one of JProgressBar.HORIZONTAL or JProgressBar.VERTICAL
        从以下版本开始：
        1.6

      • paintProgressBarBorder

        public void paintProgressBarBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of a progress bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintProgressBarBorder

        public void paintProgressBarBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h,
                          int orientation)
        Paints the border of a progress bar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - one of JProgressBar.HORIZONTAL or JProgressBar.VERTICAL
        从以下版本开始：
        1.6

      • paintProgressBarForeground

        public void paintProgressBarForeground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int orientation)
        Paints the foreground of a progress bar. is responsible for providing an indication of the progress of the progress bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - one of JProgressBar.HORIZONTAL or JProgressBar.VERTICAL

      • paintRadioButtonMenuItemBackground

        public void paintRadioButtonMenuItemBackground(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
        Paints the background of a radio button menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintRadioButtonMenuItemBorder

        public void paintRadioButtonMenuItemBorder(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
        Paints the border of a radio button menu item.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintRadioButtonBackground

        public void paintRadioButtonBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of a radio button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintRadioButtonBorder

        public void paintRadioButtonBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of a radio button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintRootPaneBackground

        public void paintRootPaneBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a root pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintRootPaneBorder

        public void paintRootPaneBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a root pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollBarBackground

        public void paintScrollBarBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the background of a scrollbar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollBarBackground

        public void paintScrollBarBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h,
                            int orientation)
        Paints the background of a scrollbar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL
        从以下版本开始：
        1.6

      • paintScrollBarBorder

        public void paintScrollBarBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the border of a scrollbar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollBarBorder

        public void paintScrollBarBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h,
                        int orientation)
        Paints the border of a scrollbar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL
        从以下版本开始：
        1.6

      • paintScrollBarThumbBackground

        public void paintScrollBarThumbBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int orientation)
        Paints the background of the thumb of a scrollbar. The thumb provides a graphical indication as to how much of the Component is visible in a JScrollPane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL

      • paintScrollBarThumbBorder

        public void paintScrollBarThumbBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h,
                             int orientation)
        Paints the border of the thumb of a scrollbar. The thumb provides a graphical indication as to how much of the Component is visible in a JScrollPane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL

      • paintScrollBarTrackBackground

        public void paintScrollBarTrackBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
        Paints the background of the track of a scrollbar. The track contains the thumb.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollBarTrackBackground

        public void paintScrollBarTrackBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int orientation)
        Paints the background of the track of a scrollbar. The track contains the thumb. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL
        从以下版本开始：
        1.6

      • paintScrollBarTrackBorder

        public void paintScrollBarTrackBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the border of the track of a scrollbar. The track contains the thumb.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollBarTrackBorder

        public void paintScrollBarTrackBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h,
                             int orientation)
        Paints the border of the track of a scrollbar. The track contains the thumb. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - Orientation of the JScrollBar, one of JScrollBar.HORIZONTAL or JScrollBar.VERTICAL
        从以下版本开始：
        1.6

      • paintScrollPaneBackground

        public void paintScrollPaneBackground(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the background of a scroll pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintScrollPaneBorder

        public void paintScrollPaneBorder(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the border of a scroll pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSeparatorBackground

        public void paintSeparatorBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the background of a separator.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSeparatorBackground

        public void paintSeparatorBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h,
                            int orientation)
        Paints the background of a separator. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSeparator.HORIZONTAL or JSeparator.VERTICAL
        从以下版本开始：
        1.6

      • paintSeparatorBorder

        public void paintSeparatorBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the border of a separator.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSeparatorBorder

        public void paintSeparatorBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h,
                        int orientation)
        Paints the border of a separator. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSeparator.HORIZONTAL or JSeparator.VERTICAL
        从以下版本开始：
        1.6

      • paintSeparatorForeground

        public void paintSeparatorForeground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h,
                            int orientation)
        Paints the foreground of a separator.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSeparator.HORIZONTAL or JSeparator.VERTICAL

      • paintSliderBackground

        public void paintSliderBackground(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the background of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSliderBackground

        public void paintSliderBackground(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h,
                         int orientation)
        Paints the background of a slider. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL
        从以下版本开始：
        1.6

      • paintSliderBorder

        public void paintSliderBorder(SynthContext context,
                     Graphics g,
                     int x,
                     int y,
                     int w,
                     int h)
        Paints the border of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSliderBorder

        public void paintSliderBorder(SynthContext context,
                     Graphics g,
                     int x,
                     int y,
                     int w,
                     int h,
                     int orientation)
        Paints the border of a slider. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL
        从以下版本开始：
        1.6

      • paintSliderThumbBackground

        public void paintSliderThumbBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int orientation)
        Paints the background of the thumb of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL

      • paintSliderThumbBorder

        public void paintSliderThumbBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h,
                          int orientation)
        Paints the border of the thumb of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL

      • paintSliderTrackBackground

        public void paintSliderTrackBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of the track of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSliderTrackBackground

        public void paintSliderTrackBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int orientation)
        Paints the background of the track of a slider. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL
        从以下版本开始：
        1.6

      • paintSliderTrackBorder

        public void paintSliderTrackBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of the track of a slider.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSliderTrackBorder

        public void paintSliderTrackBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h,
                          int orientation)
        Paints the border of the track of a slider. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSlider.HORIZONTAL or JSlider.VERTICAL
        从以下版本开始：
        1.6

      • paintSpinnerBackground

        public void paintSpinnerBackground(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the background of a spinner.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSpinnerBorder

        public void paintSpinnerBorder(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h)
        Paints the border of a spinner.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSplitPaneDividerBackground

        public void paintSplitPaneDividerBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
        Paints the background of the divider of a split pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSplitPaneDividerBackground

        public void paintSplitPaneDividerBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
        Paints the background of the divider of a split pane. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT
        从以下版本开始：
        1.6

      • paintSplitPaneDividerForeground

        public void paintSplitPaneDividerForeground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
        Paints the foreground of the divider of a split pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT

      • paintSplitPaneDragDivider

        public void paintSplitPaneDragDivider(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h,
                             int orientation)
        Paints the divider, when the user is dragging the divider, of a split pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JSplitPane.HORIZONTAL_SPLIT or JSplitPane.VERTICAL_SPLIT

      • paintSplitPaneBackground

        public void paintSplitPaneBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the background of a split pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintSplitPaneBorder

        public void paintSplitPaneBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the border of a split pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneBackground

        public void paintTabbedPaneBackground(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the background of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneBorder

        public void paintTabbedPaneBorder(SynthContext context,
                         Graphics g,
                         int x,
                         int y,
                         int w,
                         int h)
        Paints the border of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneTabAreaBackground

        public void paintTabbedPaneTabAreaBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
        Paints the background of the area behind the tabs of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneTabAreaBackground

        public void paintTabbedPaneTabAreaBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h,
                                    int orientation)
        Paints the background of the area behind the tabs of a tabbed pane. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JTabbedPane.TOP, JTabbedPane.LEFT, JTabbedPane.BOTTOM, or JTabbedPane.RIGHT
        从以下版本开始：
        1.6

      • paintTabbedPaneTabAreaBorder

        public void paintTabbedPaneTabAreaBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
        Paints the border of the area behind the tabs of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneTabAreaBorder

        public void paintTabbedPaneTabAreaBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h,
                                int orientation)
        Paints the border of the area behind the tabs of a tabbed pane. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JTabbedPane.TOP, JTabbedPane.LEFT, JTabbedPane.BOTTOM, or JTabbedPane.RIGHT
        从以下版本开始：
        1.6

      • paintTabbedPaneTabBackground

        public void paintTabbedPaneTabBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h,
                                int tabIndex)
        Paints the background of a tab of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        tabIndex - Index of tab being painted.

      • paintTabbedPaneTabBackground

        public void paintTabbedPaneTabBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h,
                                int tabIndex,
                                int orientation)
        Paints the background of a tab of a tabbed pane. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        tabIndex - Index of tab being painted.
        orientation - One of JTabbedPane.TOP, JTabbedPane.LEFT, JTabbedPane.BOTTOM, or JTabbedPane.RIGHT
        从以下版本开始：
        1.6

      • paintTabbedPaneTabBorder

        public void paintTabbedPaneTabBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h,
                            int tabIndex)
        Paints the border of a tab of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        tabIndex - Index of tab being painted.

      • paintTabbedPaneTabBorder

        public void paintTabbedPaneTabBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h,
                            int tabIndex,
                            int orientation)
        Paints the border of a tab of a tabbed pane. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        tabIndex - Index of tab being painted.
        orientation - One of JTabbedPane.TOP, JTabbedPane.LEFT, JTabbedPane.BOTTOM, or JTabbedPane.RIGHT
        从以下版本开始：
        1.6

      • paintTabbedPaneContentBackground

        public void paintTabbedPaneContentBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
        Paints the background of the area that contains the content of the selected tab of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTabbedPaneContentBorder

        public void paintTabbedPaneContentBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
        Paints the border of the area that contains the content of the selected tab of a tabbed pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTableHeaderBackground

        public void paintTableHeaderBackground(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
        Paints the background of the header of a table.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTableHeaderBorder

        public void paintTableHeaderBorder(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the border of the header of a table.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTableBackground

        public void paintTableBackground(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the background of a table.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTableBorder

        public void paintTableBorder(SynthContext context,
                    Graphics g,
                    int x,
                    int y,
                    int w,
                    int h)
        Paints the border of a table.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextAreaBackground

        public void paintTextAreaBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a text area.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextAreaBorder

        public void paintTextAreaBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a text area.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextPaneBackground

        public void paintTextPaneBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of a text pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextPaneBorder

        public void paintTextPaneBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a text pane.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextFieldBackground

        public void paintTextFieldBackground(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
        Paints the background of a text field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTextFieldBorder

        public void paintTextFieldBorder(SynthContext context,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
        Paints the border of a text field.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToggleButtonBackground

        public void paintToggleButtonBackground(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
        Paints the background of a toggle button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToggleButtonBorder

        public void paintToggleButtonBorder(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the border of a toggle button.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarBackground

        public void paintToolBarBackground(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the background of a tool bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarBackground

        public void paintToolBarBackground(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h,
                          int orientation)
        Paints the background of a tool bar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolBarBorder

        public void paintToolBarBorder(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h)
        Paints the border of a tool bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarBorder

        public void paintToolBarBorder(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h,
                      int orientation)
        Paints the border of a tool bar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolBarContentBackground

        public void paintToolBarContentBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
        Paints the background of the tool bar's content area.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarContentBackground

        public void paintToolBarContentBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int orientation)
        Paints the background of the tool bar's content area. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolBarContentBorder

        public void paintToolBarContentBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
        Paints the border of the content area of a tool bar.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarContentBorder

        public void paintToolBarContentBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h,
                             int orientation)
        Paints the border of the content area of a tool bar. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolBarDragWindowBackground

        public void paintToolBarDragWindowBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
        Paints the background of the window containing the tool bar when it has been detached from its primary frame.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarDragWindowBackground

        public void paintToolBarDragWindowBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h,
                                    int orientation)
        Paints the background of the window containing the tool bar when it has been detached from its primary frame. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolBarDragWindowBorder

        public void paintToolBarDragWindowBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
        Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolBarDragWindowBorder

        public void paintToolBarDragWindowBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h,
                                int orientation)
        Paints the border of the window containing the tool bar when it has been detached from it's primary frame. This implementation invokes the method of the same name without the orientation.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
        orientation - One of JToolBar.HORIZONTAL or JToolBar.VERTICAL
        从以下版本开始：
        1.6

      • paintToolTipBackground

        public void paintToolTipBackground(SynthContext context,
                          Graphics g,
                          int x,
                          int y,
                          int w,
                          int h)
        Paints the background of a tool tip.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintToolTipBorder

        public void paintToolTipBorder(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h)
        Paints the border of a tool tip.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTreeBackground

        public void paintTreeBackground(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the background of a tree.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTreeBorder

        public void paintTreeBorder(SynthContext context,
                   Graphics g,
                   int x,
                   int y,
                   int w,
                   int h)
        Paints the border of a tree.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTreeCellBackground

        public void paintTreeCellBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of the row containing a cell in a tree.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTreeCellBorder

        public void paintTreeCellBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of the row containing a cell in a tree.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintTreeCellFocus

        public void paintTreeCellFocus(SynthContext context,
                      Graphics g,
                      int x,
                      int y,
                      int w,
                      int h)
        Paints the focus indicator for a cell in a tree when it has focus.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintViewportBackground

        public void paintViewportBackground(SynthContext context,
                           Graphics g,
                           int x,
                           int y,
                           int w,
                           int h)
        Paints the background of the viewport.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to

      • paintViewportBorder

        public void paintViewportBorder(SynthContext context,
                       Graphics g,
                       int x,
                       int y,
                       int w,
                       int h)
        Paints the border of a viewport.
        参数：
        context - SynthContext identifying the JComponent and Region to paint to
        g - Graphics to paint to
        x - X coordinate of the area to paint to
        y - Y coordinate of the area to paint to
        w - Width of the area to paint to
        h - Height of the area to paint to
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthPanelUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
          • javax.swing.plaf.synth.SynthPanelUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthPanelUI
extends BasicPanelUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JPanel.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthPanelUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults(JPanel p)
      protected void installListeners(JPanel p)
      Installs listeners into the panel.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent pce)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults(JPanel p)
      protected void uninstallListeners(JPanel p)
      Uninstalls listeners from the panel.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicPanelUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthPanelUI

        public SynthPanelUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class BasicPanelUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class BasicPanelUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installListeners

        protected void installListeners(JPanel p)
        Installs listeners into the panel.
        参数：
        p - the JPanel object

      • uninstallListeners

        protected void uninstallListeners(JPanel p)
        Uninstalls listeners from the panel.
        参数：
        p - the JPanel object

      • installDefaults

        protected void installDefaults(JPanel p)
        重载：
        installDefaults in class BasicPanelUI

      • uninstallDefaults

        protected void uninstallDefaults(JPanel p)
        重载：
        uninstallDefaults in class BasicPanelUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent pce)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        pce - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. .e a syl.


SynthPasswordFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthPasswordFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.synth.SynthTextFieldUI
              • javax.swing.plaf.synth.SynthPasswordFieldUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory

    public class SynthPasswordFieldUI
extends SynthTextFieldUI
    Provides the Synth L&F UI delegate for JPasswordField.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthPasswordFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      View create(Element elem)
      Creates a view (PasswordView) for an element.
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JPasswordField.
      protected String getPropertyPrefix()
      Fetches the name used as a key to look up properties through the UIManager.
      protected void | installKeyboardActions()
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthTextFieldUI

        getContext, installDefaults, paint, paintBackground, propertyChange, uninstallDefaults, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, uninstallUI, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthPasswordFieldUI

        public SynthPasswordFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JPasswordField.
        参数：
        c - the JPasswordField
        返回：
        the UI

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to look up properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicTextFieldUI
        返回：
        the name ("PasswordField")

      • create

        public View create(Element elem)
        Creates a view (PasswordView) for an element.
        指定者：
        create in interface ViewFactory
        重载：
        create in class BasicTextFieldUI
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthTextFieldUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • installKeyboardActions

        protected void installKeyboardActions()
        重载：
        installKeyboardActions in class BasicTextUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e-x(>acpac


SynthPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthPopupMenuUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
          • javax.swing.plaf.synth.SynthPopupMenuUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthPopupMenuUI
extends BasicPopupMenuUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JPopupMenu.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicPopupMenuUI

        popupMenu

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthPopupMenuUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicPopupMenuUI

        installKeyboardActions, installUI, isPopupTrigger, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.PopupMenuUI

        getPopup

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthPopupMenuUI

        public SynthPopupMenuUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installDefaults

        public void installDefaults()
        重载：
        installDefaults in class BasicPopupMenuUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicPopupMenuUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicPopupMenuUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicPopupMenuUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


SynthProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthProgressBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.synth.SynthProgressBarUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthProgressBarUI
extends BasicProgressBarUI
implements SynthUI, PropertyChangeListener
    Provides the Synth L&F UI delegate for JProgressBar.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicProgressBarUI

        BasicProgressBarUI.ChangeHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicProgressBarUI

        boxRect, changeListener, progressBar

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthProgressBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      protected Rectangle getBox(Rectangle r)
      Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void paintText(SynthContext context, Graphics g, String title)
      Paints the component's text.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void setAnimationIndex(int newValue)
      Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted.
      protected void | uninstallDefaults()
      protected void uninstallListeners()
      Removes all listeners installed by this object.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicProgressBarUI

        getAmountFull, getAnimationIndex, getBaselineResizeBehavior, getBoxLength, getCellLength, getCellSpacing, getFrameCount, getMaximumSize, getMinimumSize, getPreferredInnerHorizontal, getPreferredInnerVertical, getSelectionBackground, getSelectionForeground, getStringPlacement, incrementAnimationIndex, installUI, paintDeterminate, paintIndeterminate, paintString, setCellLength, setCellSpacing, startAnimationTimer, stopAnimationTimer, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthProgressBarUI

        public SynthProgressBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicProgressBarUI

      • uninstallListeners

        protected void uninstallListeners()
        Description copied from class: BasicProgressBarUI
        Removes all listeners installed by this object.
        重载：
        uninstallListeners in class BasicProgressBarUI

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicProgressBarUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicProgressBarUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Description copied from class: BasicProgressBarUI
        Returns the baseline.
        重载：
        getBaseline in class BasicProgressBarUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        另请参见：
        JComponent.getBaseline(int, int)

      • getBox

        protected Rectangle getBox(Rectangle r)
        Description copied from class: BasicProgressBarUI
        Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r. Subclasses that add to the painting performed in this class's implementation of paintIndeterminate -- to draw an outline around the bouncing box, for example -- can use this method to get the location of the bouncing box that was just painted. By overriding this method, you have complete control over the size and position of the bouncing box, without having to reimplement paintIndeterminate.
        重载：
        getBox in class BasicProgressBarUI
        参数：
        r - the Rectangle instance to be modified; may be null
        返回：
        null if no box should be drawn; otherwise, returns the passed-in rectangle (if non-null) or a new rectangle
        另请参见：
        BasicProgressBarUI.setAnimationIndex(int)

      • setAnimationIndex

        protected void setAnimationIndex(int newValue)
        Description copied from class: BasicProgressBarUI
        Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted. Subclasses that don't use the default painting code might need to override this method to change the way that the repaint method is invoked.
        重载：
        setAnimationIndex in class BasicProgressBarUI
        参数：
        newValue - the new animation index; no checking is performed on its value
        另请参见：
        BasicProgressBarUI.incrementAnimationIndex()

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicProgressBarUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintText

        protected void paintText(SynthContext context,
             Graphics g,
             String title)
        Paints the component's text.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        title - the text to paint

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicProgressBarUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y


SynthRadioButtonMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthRadioButtonMenuItemUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.synth.SynthMenuItemUI
              • javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthRadioButtonMenuItemUI
extends SynthMenuItemUI
    Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        BasicMenuItemUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicMenuItemUI

        acceleratorDelimiter, acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthRadioButtonMenuItemUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent b)
      Creates a new UI object for the given component.
      protected String | getPropertyPrefix()
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthMenuItemUI

        getContext, getPreferredMenuItemSize, installDefaults, installListeners, paint, paint, propertyChange, uninstallDefaults, uninstallListeners, uninstallUI, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicMenuItemUI

        createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredSize, installComponents, installKeyboardActions, installUI, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallKeyboardActions

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthRadioButtonMenuItemUI

        public SynthRadioButtonMenuItemUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)
        Creates a new UI object for the given component.
        参数：
        b - component to create UI object for
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicMenuItemUI

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthMenuItemUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

usnftlnalnuiinuuhs//iren>>rsv>xsg�"


SynthRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthRadioButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.synth.SynthButtonUI
            • javax.swing.plaf.synth.SynthToggleButtonUI
              • javax.swing.plaf.synth.SynthRadioButtonUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI
    直接已知子类：
    SynthCheckBoxUI

    public class SynthRadioButtonUI
extends SynthToggleButtonUI
    Provides the Synth L&F UI delegate for JRadioButton.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthRadioButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent b)
      Creates a new UI object for the given component.
      protected String | getPropertyPrefix()
      protected Icon getSizingIcon(AbstractButton b)
      Returns the Icon used in calculating the preferred/minimum/maximum size.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthButtonUI

        getBaseline, getContext, getDefaultIcon, getIcon, getMaximumSize, getMinimumSize, getPreferredSize, installDefaults, installListeners, paint, paint, propertyChange, uninstallDefaults, uninstallListeners, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaselineResizeBehavior, getDefaultTextIconGap, getTextShiftOffset, installKeyboardActions, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthRadioButtonUI

        public SynthRadioButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)
        Creates a new UI object for the given component.
        参数：
        b - component to create UI object for
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class SynthToggleButtonUI

      • getSizingIcon

        protected Icon getSizingIcon(AbstractButton b)
        Returns the Icon used in calculating the preferred/minimum/maximum size.
        重载：
        getSizingIcon in class SynthButtonUI

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthToggleButtonUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ilnsnnn;pll>ta<"a//><方i/>a <<b>


SynthRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthRootPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI
          • javax.swing.plaf.synth.SynthRootPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthRootPaneUI
extends BasicRootPaneUI
implements SynthUI
    Provides the Synth L&F UI delegate for JRootPane.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthRootPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults(JRootPane c)
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      Invoked when a property changes on the root pane.
      protected void | uninstallDefaults(JRootPane root)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicRootPaneUI

        installComponents, installKeyboardActions, installListeners, installUI, uninstallComponents, uninstallKeyboardActions, uninstallListeners, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthRootPaneUI

        public SynthRootPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults(JRootPane c)
        重载：
        installDefaults in class BasicRootPaneUI

      • uninstallDefaults

        protected void uninstallDefaults(JRootPane root)
        重载：
        uninstallDefaults in class BasicRootPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        Invoked when a property changes on the root pane. If the event indicates the defaultButton has changed, this will reinstall the keyboard actions.
        指定者：
        propertyChange in interface PropertyChangeListener
        重载：
        propertyChange in class BasicRootPaneUI
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hibL 1nv" oa7fh>m>泛aio/_s給!蝘h及


SynthScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthScrollBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI
          • javax.swing.plaf.synth.SynthScrollBarUI
  • 所有已实现的接口：
    LayoutManager, PropertyChangeListener, EventListener, SynthConstants, SynthUI, SwingConstants

    public class SynthScrollBarUI
extends BasicScrollBarUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JScrollBar.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicScrollBarUI

        BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.ModelListener, BasicScrollBarUI.PropertyChangeHandler, BasicScrollBarUI.ScrollListener, BasicScrollBarUI.TrackListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicScrollBarUI

        buttonListener, decrButton, DECREASE_HIGHLIGHT, decrGap, incrButton, INCREASE_HIGHLIGHT, incrGap, isDragging, maximumThumbSize, minimumThumbSize, modelListener, NO_HIGHLIGHT, propertyChangeListener, scrollbar, scrollBarWidth, scrollListener, scrollTimer, thumbColor, thumbDarkShadowColor, thumbHighlightColor, thumbLightShadowColor, thumbRect, trackColor, trackHighlight, trackHighlightColor, trackListener, trackRect

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthScrollBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | configureScrollBarColors()
      protected JButton | createDecreaseButton(int orientation)
      protected JButton | createIncreaseButton(int orientation)
      static ComponentUI | createUI(JComponent c)
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected Dimension getMinimumThumbSize()
      Returns the smallest acceptable size for the thumb.
      Dimension getPreferredSize(JComponent c)
      A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.
      boolean getSupportsAbsolutePositioning()
      Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void paintThumb(SynthContext context, Graphics g, Rectangle thumbBounds)
      Paints the scrollbar thumb.
      protected void paintTrack(SynthContext context, Graphics g, Rectangle trackBounds)
      Paints the scrollbar track.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void setThumbRollover(boolean active)
      Sets whether or not the mouse is currently over the thumb.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicScrollBarUI

        addLayoutComponent, createArrowButtonListener, createModelListener, createPropertyChangeListener, createScrollListener, createTrackListener, getMaximumSize, getMaximumThumbSize, getThumbBounds, getTrackBounds, installComponents, installKeyboardActions, installUI, isThumbRollover, layoutContainer, layoutHScrollbar, layoutVScrollbar, minimumLayoutSize, paintDecreaseHighlight, paintIncreaseHighlight, paintThumb, paintTrack, preferredLayoutSize, removeLayoutComponent, scrollByBlock, scrollByUnit, setThumbBounds, uninstallComponents, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMinimumSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthScrollBarUI

        public SynthScrollBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicScrollBarUI

      • configureScrollBarColors

        protected void configureScrollBarColors()
        重载：
        configureScrollBarColors in class BasicScrollBarUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicScrollBarUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicScrollBarUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicScrollBarUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • getSupportsAbsolutePositioning

        public boolean getSupportsAbsolutePositioning()
        Description copied from class: BasicScrollBarUI
        Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).
        重载：
        getSupportsAbsolutePositioning in class BasicScrollBarUI
        返回：
        true if a mouse gesture can absolutely position the thumb

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicScrollBarUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paintTrack

        protected void paintTrack(SynthContext context,
              Graphics g,
              Rectangle trackBounds)
        Paints the scrollbar track.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        trackBounds - bounding box for the track

      • paintThumb

        protected void paintThumb(SynthContext context,
              Graphics g,
              Rectangle thumbBounds)
        Paints the scrollbar thumb.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        thumbBounds - bounding box for the thumb

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb. The preferred height is the sum of the preferred heights of the same parts. The basis for the preferred size of a horizontal scrollbar is similar.

        The preferredSize is only computed once, subsequent calls to this method just return a cached size.

        重载：
        getPreferredSize in class BasicScrollBarUI
        参数：
        c - the JScrollBar that's delegating this method to us
        返回：
        the preferred size of a Basic JScrollBar
        另请参见：
        BasicScrollBarUI.getMaximumSize(javax.swing.JComponent), ComponentUI.getMinimumSize(javax.swing.JComponent)

      • getMinimumThumbSize

        protected Dimension getMinimumThumbSize()
        Description copied from class: BasicScrollBarUI
        Returns the smallest acceptable size for the thumb. If the scrollbar becomes so small that this size isn't available, the thumb will be hidden.

        Warning : the value returned by this method should not be be modified, it's a shared static constant.

        重载：
        getMinimumThumbSize in class BasicScrollBarUI
        返回：
        The smallest acceptable size for the thumb.
        另请参见：
        BasicScrollBarUI.getMaximumThumbSize()

      • createDecreaseButton

        protected JButton createDecreaseButton(int orientation)
        重载：
        createDecreaseButton in class BasicScrollBarUI

      • createIncreaseButton

        protected JButton createIncreaseButton(int orientation)
        重载：
        createIncreaseButton in class BasicScrollBarUI

      • setThumbRollover

        protected void setThumbRollover(boolean active)
        Description copied from class: BasicScrollBarUI
        Sets whether or not the mouse is currently over the thumb.
        重载：
        setThumbRollover in class BasicScrollBarUI
        参数：
        active - True indicates the thumb is currently active.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthScrollPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI
          • javax.swing.plaf.synth.SynthScrollPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI, ScrollPaneConstants

    public class SynthScrollPaneUI
extends BasicScrollPaneUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JScrollPane.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicScrollPaneUI

        BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.MouseWheelHandler, BasicScrollPaneUI.PropertyChangeHandler, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicScrollPaneUI

        hsbChangeListener, scrollpane, spPropertyChangeListener, viewportChangeListener, vsbChangeListener

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

      • 字段 - 继承于接口 javax.swing.ScrollPaneConstants

        COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthScrollPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installDefaults(JScrollPane scrollpane)
      protected void | installListeners(JScrollPane c)
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults(JScrollPane c)
      protected void | uninstallListeners(JComponent c)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicScrollPaneUI

        createHSBChangeListener, createMouseWheelListener, createPropertyChangeListener, createViewportChangeListener, createVSBChangeListener, getBaseline, getBaselineResizeBehavior, getMaximumSize, installKeyboardActions, installUI, syncScrollPaneWithViewport, uninstallKeyboardActions, uninstallUI, updateColumnHeader, updateRowHeader, updateScrollBarDisplayPolicy, updateViewport

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthScrollPaneUI

        public SynthScrollPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicScrollPaneUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • installDefaults

        protected void installDefaults(JScrollPane scrollpane)
        重载：
        installDefaults in class BasicScrollPaneUI

      • installListeners

        protected void installListeners(JScrollPane c)
        重载：
        installListeners in class BasicScrollPaneUI

      • uninstallDefaults

        protected void uninstallDefaults(JScrollPane c)
        重载：
        uninstallDefaults in class BasicScrollPaneUI

      • uninstallListeners

        protected void uninstallListeners(JComponent c)
        重载：
        uninstallListeners in class BasicScrollPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p/hoSniynianniaaoivvs/an/pt/ctcraBtamlllax.ra/ahy


SynthSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthSeparatorUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.synth.SynthSeparatorUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthSeparatorUI
extends SeparatorUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JSeparator.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthSeparatorUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension getMaximumSize(JComponent c)
      Returns the specified component's maximum size appropriate for the look and feel.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      void installDefaults(JSeparator c)
      Installs default setting.
      void installListeners(JSeparator c)
      Installs listeners.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      void uninstallDefaults(JSeparator c)
      Uninstalls default setting.
      void uninstallListeners(JSeparator c)
      Uninstalls listeners.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthSeparatorUI

        public SynthSeparatorUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        public void installDefaults(JSeparator c)
        Installs default setting. This method is called when a LookAndFeel is installed.

      • uninstallDefaults

        public void uninstallDefaults(JSeparator c)
        Uninstalls default setting. This method is called when a LookAndFeel is uninstalled.

      • installListeners

        public void installListeners(JSeparator c)
        Installs listeners. This method is called when a LookAndFeel is installed.

      • uninstallListeners

        public void uninstallListeners(JSeparator c)
        Uninstalls listeners. This method is called when a LookAndFeel is uninstalled.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class ComponentUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class ComponentUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • getMaximumSize

        public Dimension getMaximumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's maximum size appropriate for the look and feel. If null is returned, the maximum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMaximumSize in class ComponentUI
        参数：
        c - the component whose maximum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


SynthSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthSliderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.synth.SynthSliderUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthSliderUI
extends BasicSliderUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JSlider.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicSliderUI

        BasicSliderUI.ActionScroller, BasicSliderUI.ChangeHandler, BasicSliderUI.ComponentHandler, BasicSliderUI.FocusHandler, BasicSliderUI.PropertyChangeHandler, BasicSliderUI.ScrollListener, BasicSliderUI.TrackListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSliderUI

        changeListener, componentListener, contentRect, focusInsets, focusListener, focusRect, insetCache, labelRect, leftToRightCache, MAX_SCROLL, MIN_SCROLL, NEGATIVE_SCROLL, POSITIVE_SCROLL, propertyChangeListener, scrollListener, scrollTimer, slider, thumbRect, tickRect, trackBuffer, trackListener, trackRect

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | SynthSliderUI(JSlider c)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void | calculateGeometry()
      protected void | calculateThumbLocation()
      protected BasicSliderUI.TrackListener | createTrackListener(JSlider s)
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      int getBaseline(JComponent c, int width, int height)
      Returns the baseline.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension getMinimumSize(JComponent c)
      Returns the specified component's minimum size appropriate for the look and feel.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected Dimension | getThumbSize()
      protected void | installDefaults(JSlider slider)
      protected void | installListeners(JSlider slider)
      protected void layout()
      Lays out the slider.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void paintThumb(SynthContext context, Graphics g, Rectangle thumbBounds)
      Paints the slider thumb.
      protected void paintTrack(SynthContext context, Graphics g, Rectangle trackBounds)
      Paints the slider track.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | recalculateIfInsetsChanged()
      void | setThumbLocation(int x, int y)
      protected void uninstallDefaults(JSlider slider)
      Uninstalls default setting.
      protected void | uninstallListeners(JSlider slider)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.
      int valueForXPosition(int xPos)
      Returns the value at the x position.
      int valueForYPosition(int yPos)
      Returns the value at the y position.
      protected int | xPositionForValue(int value)
      protected int yPositionForValue(int value, int trackY, int trackHeight)
      Returns the y location for the specified value.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSliderUI

        calculateContentRect, calculateFocusRect, calculateLabelRect, calculateThumbSize, calculateTickRect, calculateTrackBuffer, calculateTrackRect, createChangeListener, createComponentListener, createFocusListener, createPropertyChangeListener, createScrollListener, drawInverted, getBaselineResizeBehavior, getFocusColor, getHeightOfHighValueLabel, getHeightOfLowValueLabel, getHeightOfTallestLabel, getHighestValue, getHighestValueLabel, getHighlightColor, getLowestValue, getLowestValueLabel, getMaximumSize, getMinimumHorizontalSize, getMinimumVerticalSize, getPreferredHorizontalSize, getPreferredVerticalSize, getShadowColor, getTickLength, getWidthOfHighValueLabel, getWidthOfLowValueLabel, getWidthOfWidestLabel, installKeyboardActions, installUI, isDragging, labelsHaveSameBaselines, paintFocus, paintHorizontalLabel, paintLabels, paintMajorTickForHorizSlider, paintMajorTickForVertSlider, paintMinorTickForHorizSlider, paintMinorTickForVertSlider, paintThumb, paintTicks, paintTrack, paintVerticalLabel, recalculateIfOrientationChanged, scrollByBlock, scrollByUnit, scrollDueToClickInTrack, uninstallKeyboardActions, uninstallUI, yPositionForValue

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthSliderUI

        protected SynthSliderUI(JSlider c)

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults(JSlider slider)
        重载：
        installDefaults in class BasicSliderUI

      • uninstallDefaults

        protected void uninstallDefaults(JSlider slider)
        Uninstalls default setting. This method is called when a LookAndFeel is uninstalled.
        重载：
        uninstallDefaults in class BasicSliderUI

      • installListeners

        protected void installListeners(JSlider slider)
        重载：
        installListeners in class BasicSliderUI

      • uninstallListeners

        protected void uninstallListeners(JSlider slider)
        重载：
        uninstallListeners in class BasicSliderUI

      • createTrackListener

        protected BasicSliderUI.TrackListener createTrackListener(JSlider s)
        重载：
        createTrackListener in class BasicSliderUI

      • getBaseline

        public int getBaseline(JComponent c,
              int width,
              int height)
        Description copied from class: BasicSliderUI
        Returns the baseline.
        重载：
        getBaseline in class BasicSliderUI
        参数：
        c - JComponent baseline is being requested for
        width - the width to get the baseline for
        height - the height to get the baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline
        另请参见：
        JComponent.getBaseline(int, int)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicSliderUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • getMinimumSize

        public Dimension getMinimumSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's minimum size appropriate for the look and feel. If null is returned, the minimum size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method invokes getPreferredSize and returns that value.
        重载：
        getMinimumSize in class BasicSliderUI
        参数：
        c - the component whose minimum size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        返回：
        a Dimension object or null
        另请参见：
        JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

      • calculateGeometry

        protected void calculateGeometry()
        重载：
        calculateGeometry in class BasicSliderUI

      • layout

        protected void layout()
        Lays out the slider.

      • calculateThumbLocation

        protected void calculateThumbLocation()
        重载：
        calculateThumbLocation in class BasicSliderUI

      • setThumbLocation

        public void setThumbLocation(int x,
                    int y)
        重载：
        setThumbLocation in class BasicSliderUI

      • xPositionForValue

        protected int xPositionForValue(int value)
        重载：
        xPositionForValue in class BasicSliderUI

      • yPositionForValue

        protected int yPositionForValue(int value,
                    int trackY,
                    int trackHeight)
        Description copied from class: BasicSliderUI
        Returns the y location for the specified value. No checking is done on the arguments. In particular if trackHeight is negative undefined results may occur.
        重载：
        yPositionForValue in class BasicSliderUI
        参数：
        value - the slider value to get the location for
        trackY - y-origin of the track
        trackHeight - the height of the track

      • valueForYPosition

        public int valueForYPosition(int yPos)
        Description copied from class: BasicSliderUI
        Returns the value at the y position. If yPos is beyond the track at the the bottom or the top, this method sets the value to either the minimum or maximum value of the slider, depending on if the slider is inverted or not.
        重载：
        valueForYPosition in class BasicSliderUI

      • valueForXPosition

        public int valueForXPosition(int xPos)
        Description copied from class: BasicSliderUI
        Returns the value at the x position. If xPos is beyond the track at the left or the right, this method sets the value to either the minimum or maximum value of the slider, depending on if the slider is inverted or not.
        重载：
        valueForXPosition in class BasicSliderUI

      • getThumbSize

        protected Dimension getThumbSize()
        重载：
        getThumbSize in class BasicSliderUI

      • recalculateIfInsetsChanged

        protected void recalculateIfInsetsChanged()
        重载：
        recalculateIfInsetsChanged in class BasicSliderUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicSliderUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paintThumb

        protected void paintThumb(SynthContext context,
              Graphics g,
              Rectangle thumbBounds)
        Paints the slider thumb.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        thumbBounds - bounding box for the thumb

      • paintTrack

        protected void paintTrack(SynthContext context,
              Graphics g,
              Rectangle trackBounds)
        Paints the slider track.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        trackBounds - bounding box for the track

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,


SynthSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthSpinnerUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
          • javax.swing.plaf.synth.SynthSpinnerUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthSpinnerUI
extends BasicSpinnerUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JSpinner.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSpinnerUI

        spinner

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthSpinnerUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected JComponent createEditor()
      This method is called by installUI to get the editor component of the JSpinner.
      protected LayoutManager createLayout()
      Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner.
      protected Component createNextButton()
      Creates an increment button, i.e.
      protected Component createPreviousButton()
      Creates a decrement button, i.e.
      static ComponentUI createUI(JComponent c)
      Returns a new instance of SynthSpinnerUI.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
      protected void installListeners()
      Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void replaceEditor(JComponent oldEditor, JComponent newEditor)
      Called by the PropertyChangeListener when the JSpinner editor property changes.
      protected void uninstallDefaults()
      Sets the JSpinner's layout manager to null.
      protected void uninstallListeners()
      Removes the PropertyChangeListener added by installListeners.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSpinnerUI

        createPropertyChangeListener, getBaseline, getBaselineResizeBehavior, installKeyboardActions, installNextButtonListeners, installPreviousButtonListeners, installUI, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthSpinnerUI

        public SynthSpinnerUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Returns a new instance of SynthSpinnerUI.
        参数：
        c - the JSpinner (not used)
        返回：
        a new SynthSpinnerUI object
        另请参见：
        ComponentUI.createUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Description copied from class: BasicSpinnerUI
        Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.

        This method is called by installUI.

        重载：
        installListeners in class BasicSpinnerUI
        另请参见：
        BasicSpinnerUI.replaceEditor(javax.swing.JComponent, javax.swing.JComponent), BasicSpinnerUI.uninstallListeners()

      • uninstallListeners

        protected void uninstallListeners()
        Description copied from class: BasicSpinnerUI
        Removes the PropertyChangeListener added by installListeners.

        This method is called by uninstallUI.

        重载：
        uninstallListeners in class BasicSpinnerUI
        另请参见：
        BasicSpinnerUI.installListeners()

      • installDefaults

        protected void installDefaults()
        Initializes the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table. The JSpinners layout is set to the value returned by createLayout. This method is called by installUI.
        重载：
        installDefaults in class BasicSpinnerUI
        另请参见：
        uninstallDefaults(),
BasicSpinnerUI.installUI(javax.swing.JComponent),
createLayout(),
LookAndFeel.installBorder(javax.swing.JComponent, java.lang.String),
LookAndFeel.installColors(javax.swing.JComponent, java.lang.String, java.lang.String)

      • uninstallDefaults

        protected void uninstallDefaults()
        Sets the JSpinner's layout manager to null. This method is called by uninstallUI.
        重载：
        uninstallDefaults in class BasicSpinnerUI
        另请参见：
        installDefaults(), BasicSpinnerUI.uninstallUI(javax.swing.JComponent)

      • createLayout

        protected LayoutManager createLayout()
        Description copied from class: BasicSpinnerUI
        Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner. These three children must be added with a constraint that identifies their role: "Editor", "Next", and "Previous". The default layout manager can handle the absence of any of these children.
        重载：
        createLayout in class BasicSpinnerUI
        返回：
        a LayoutManager for the editor, next button, and previous button.
        另请参见：
        BasicSpinnerUI.createNextButton(),
BasicSpinnerUI.createPreviousButton(),
BasicSpinnerUI.createEditor()

      • createPreviousButton

        protected Component createPreviousButton()
        Description copied from class: BasicSpinnerUI
        Creates a decrement button, i.e. component that replaces the spinner value with the object returned by spinner.getPreviousValue. By default the previousButton is a JButton. If the decrement button is not needed this method should return null.
        重载：
        createPreviousButton in class BasicSpinnerUI
        返回：
        a component that will replace the spinner's value with the previous value in the sequence, or null
        另请参见：
        BasicSpinnerUI.installUI(javax.swing.JComponent),
BasicSpinnerUI.createNextButton(),
BasicSpinnerUI.installPreviousButtonListeners(java.awt.Component)

      • createNextButton

        protected Component createNextButton()
        Description copied from class: BasicSpinnerUI
        Creates an increment button, i.e. component that replaces the spinner value with the object returned by spinner.getNextValue. By default the nextButton is a JButton. If the increment button is not needed this method should return null.
        重载：
        createNextButton in class BasicSpinnerUI
        返回：
        a component that will replace the spinner's value with the next value in the sequence, or null
        另请参见：
        BasicSpinnerUI.installUI(javax.swing.JComponent),
BasicSpinnerUI.createPreviousButton(),
BasicSpinnerUI.installNextButtonListeners(java.awt.Component)

      • createEditor

        protected JComponent createEditor()
        This method is called by installUI to get the editor component of the JSpinner. By default it just returns JSpinner.getEditor(). Subclasses can override createEditor to return a component that contains the spinner's editor or null, if they're going to handle adding the editor to the JSpinner in an installUI override.

        Typically this method would be overridden to wrap the editor with a container with a custom border, since one can't assume that the editors border can be set directly.

        The replaceEditor method is called when the spinners editor is changed with JSpinner.setEditor. If you've overriden this method, then you'll probably want to override replaceEditor as well.

        重载：
        createEditor in class BasicSpinnerUI
        返回：
        the JSpinners editor JComponent, spinner.getEditor() by default
        另请参见：
        BasicSpinnerUI.installUI(javax.swing.JComponent),
replaceEditor(javax.swing.JComponent, javax.swing.JComponent),
JSpinner.getEditor()

      • replaceEditor

        protected void replaceEditor(JComponent oldEditor,
                 JComponent newEditor)
        Called by the PropertyChangeListener when the JSpinner editor property changes. It's the responsibility of this method to remove the old editor and add the new one. By default this operation is just:
         spinner.remove(oldEditor);
 spinner.add(newEditor, "Editor");
        The implementation of replaceEditor should be coordinated with the createEditor method.
        重载：
        replaceEditor in class BasicSpinnerUI
        另请参见：
        createEditor(), BasicSpinnerUI.createPropertyChangeListener()

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/itbpespetddettr>FF--" <--->-asibslt""s/ i - a


SynthSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthSplitPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.synth.SynthSplitPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthSplitPaneUI
extends BasicSplitPaneUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JSplitPane.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicSplitPaneUI

        BasicSplitPaneUI.BasicHorizontalLayoutManager, BasicSplitPaneUI.BasicVerticalLayoutManager, BasicSplitPaneUI.FocusHandler, BasicSplitPaneUI.KeyboardDownRightHandler, BasicSplitPaneUI.KeyboardEndHandler, BasicSplitPaneUI.KeyboardHomeHandler, BasicSplitPaneUI.KeyboardResizeToggleHandler, BasicSplitPaneUI.KeyboardUpLeftHandler, BasicSplitPaneUI.PropertyHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicSplitPaneUI

        beginDragDividerLocation, divider, dividerResizeToggleKey, dividerSize, downKey, draggingHW, endKey, focusListener, homeKey, KEYBOARD_DIVIDER_MOVE_OFFSET, keyboardDownRightListener, keyboardEndListener, keyboardHomeListener, keyboardResizeToggleListener, keyboardUpLeftListener, layoutManager, leftKey, NON_CONTINUOUS_DIVIDER, nonContinuousLayoutDivider, propertyChangeListener, rightKey, splitPane, upKey

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthSplitPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      BasicSplitPaneDivider createDefaultDivider()
      Creates the default divider.
      protected Component createDefaultNonContinuousLayoutDivider()
      Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
      static ComponentUI createUI(JComponent x)
      Creates a new SynthSplitPaneUI instance
      void finishedPaintingChildren(JSplitPane jc, Graphics g)
      Called when the specified split pane has finished painting its children.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Installs the UI defaults.
      protected void installListeners()
      Installs the event listeners for the UI.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void uninstallDefaults()
      Uninstalls the UI defaults.
      protected void uninstallListeners()
      Uninstalls the event listeners from the UI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicSplitPaneUI

        createFocusListener, createKeyboardDownRightListener, createKeyboardEndListener, createKeyboardHomeListener, createKeyboardResizeToggleListener, createKeyboardUpLeftListener, createPropertyChangeListener, dragDividerTo, finishDraggingTo, getDivider, getDividerBorderSize, getDividerLocation, getInsets, getLastDragLocation, getMaximumDividerLocation, getMaximumSize, getMinimumDividerLocation, getMinimumSize, getNonContinuousLayoutDivider, getOrientation, getPreferredSize, getSplitPane, installKeyboardActions, installUI, isContinuousLayout, resetLayoutManager, resetToPreferredSizes, setContinuousLayout, setDividerLocation, setLastDragLocation, setNonContinuousLayoutDivider, setNonContinuousLayoutDivider, setOrientation, startDragging, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthSplitPaneUI

        public SynthSplitPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new SynthSplitPaneUI instance
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        Installs the UI defaults.
        重载：
        installDefaults in class BasicSplitPaneUI

      • installListeners

        protected void installListeners()
        Installs the event listeners for the UI.
        重载：
        installListeners in class BasicSplitPaneUI

      • uninstallDefaults

        protected void uninstallDefaults()
        Uninstalls the UI defaults.
        重载：
        uninstallDefaults in class BasicSplitPaneUI

      • uninstallListeners

        protected void uninstallListeners()
        Uninstalls the event listeners from the UI.
        重载：
        uninstallListeners in class BasicSplitPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • createDefaultDivider

        public BasicSplitPaneDivider createDefaultDivider()
        Creates the default divider.
        重载：
        createDefaultDivider in class BasicSplitPaneUI

      • createDefaultNonContinuousLayoutDivider

        protected Component createDefaultNonContinuousLayoutDivider()
        Description copied from class: BasicSplitPaneUI
        Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
        重载：
        createDefaultNonContinuousLayoutDivider in class BasicSplitPaneUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicSplitPaneUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • finishedPaintingChildren

        public void finishedPaintingChildren(JSplitPane jc,
                            Graphics g)
        Description copied from class: BasicSplitPaneUI
        Called when the specified split pane has finished painting its children.
        重载：
        finishedPaintingChildren in class BasicSplitPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itvi>iiidid>>vii>e88Psnat;loSdPl>oSrtfft&ro竤&pb;


SynthStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthStyle

  • java.lang.Object
    • javax.swing.plaf.synth.SynthStyle
  • 直接已知子类：
    NimbusStyle

    public abstract class SynthStyle
extends Object
    SynthStyle is a set of style properties. Each SynthUI references at least one SynthStyle that is obtained using a SynthStyleFactory. You typically don't need to interact with this class directly, rather you will load a Synth File Format file into SynthLookAndFeel that will create a set of SynthStyles.
    从以下版本开始：
    1.5
    另请参见：
    SynthLookAndFeel, SynthStyleFactory

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthStyle()
      Constructs a SynthStyle.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object get(SynthContext context, Object key)
      Getter for a region specific style property.
      boolean getBoolean(SynthContext context, Object key, boolean defaultValue)
      Convenience method to get a specific style property whose value is an Boolean.
      Color getColor(SynthContext context, ColorType type)
      Returns the color for the specified state.
      protected abstract Color getColorForState(SynthContext context, ColorType type)
      Returns the color for the specified state.
      Font getFont(SynthContext context)
      Returns the Font for the specified state.
      protected abstract Font getFontForState(SynthContext context)
      Returns the font for the specified state.
      SynthGraphicsUtils getGraphicsUtils(SynthContext context)
      Returns the SynthGraphicUtils for the specified context.
      Icon getIcon(SynthContext context, Object key)
      Convenience method to get a specific style property whose value is an Icon.
      Insets getInsets(SynthContext context, Insets insets)
      Returns the Insets that are used to calculate sizing information.
      int getInt(SynthContext context, Object key, int defaultValue)
      Convenience method to get a specific style property whose value is a Number.
      SynthPainter getPainter(SynthContext context)
      Returns the SynthPainter that will be used for painting.
      String getString(SynthContext context, Object key, String defaultValue)
      Convenience method to get a specific style property whose value is a String.
      void installDefaults(SynthContext context)
      Installs the necessary state from this Style on the JComponent from context.
      boolean isOpaque(SynthContext context)
      Returns true if the region is opaque.
      void uninstallDefaults(SynthContext context)
      Uninstalls any state that this style installed on the JComponent from context.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthStyle

        public SynthStyle()
        Constructs a SynthStyle.

    • 方法详细信息

      • getGraphicsUtils

        public SynthGraphicsUtils getGraphicsUtils(SynthContext context)
        Returns the SynthGraphicUtils for the specified context.
        参数：
        context - SynthContext identifying requester
        返回：
        SynthGraphicsUtils

      • getColor

        public Color getColor(SynthContext context,
             ColorType type)
        Returns the color for the specified state. This gives precedence to foreground and background of the JComponent. If the Color from the JComponent is not appropriate, or not used, this will invoke getColorForState. Subclasses should generally not have to override this, instead override getColorForState(javax.swing.plaf.synth.SynthContext, javax.swing.plaf.synth.ColorType).
        参数：
        context - SynthContext identifying requester
        type - Type of color being requested.
        返回：
        Color

      • getColorForState

        protected abstract Color getColorForState(SynthContext context,
                     ColorType type)
        Returns the color for the specified state. This should NOT call any methods on the JComponent.
        参数：
        context - SynthContext identifying requester
        type - Type of color being requested.
        返回：
        Color to render with

      • getFont

        public Font getFont(SynthContext context)
        Returns the Font for the specified state. This redirects to the JComponent from the context as necessary. If this does not redirect to the JComponent getFontForState(javax.swing.plaf.synth.SynthContext) is invoked.
        参数：
        context - SynthContext identifying requester
        返回：
        Font to render with

      • getFontForState

        protected abstract Font getFontForState(SynthContext context)
        Returns the font for the specified state. This should NOT call any method on the JComponent.
        参数：
        context - SynthContext identifying requester
        返回：
        Font to render with

      • getInsets

        public Insets getInsets(SynthContext context,
               Insets insets)
        Returns the Insets that are used to calculate sizing information.
        参数：
        context - SynthContext identifying requester
        insets - Insets to place return value in.
        返回：
        Sizing Insets.

      • getPainter

        public SynthPainter getPainter(SynthContext context)
        Returns the SynthPainter that will be used for painting. This may return null.
        参数：
        context - SynthContext identifying requester
        返回：
        SynthPainter to use

      • isOpaque

        public boolean isOpaque(SynthContext context)
        Returns true if the region is opaque.
        参数：
        context - SynthContext identifying requester
        返回：
        true if region is opaque.

      • get

        public Object get(SynthContext context,
         Object key)
        Getter for a region specific style property.
        参数：
        context - SynthContext identifying requester
        key - Property being requested.
        返回：
        Value of the named property

      • installDefaults

        public void installDefaults(SynthContext context)
        Installs the necessary state from this Style on the JComponent from context.
        参数：
        context - SynthContext identifying component to install properties to.

      • uninstallDefaults

        public void uninstallDefaults(SynthContext context)
        Uninstalls any state that this style installed on the JComponent from context.

        Styles should NOT depend upon this being called, in certain cases it may never be called.

        参数：
        context - SynthContext identifying component to install properties to.

      • getInt

        public int getInt(SynthContext context,
         Object key,
         int defaultValue)
        Convenience method to get a specific style property whose value is a Number. If the value is a Number, intValue is returned, otherwise defaultValue is returned.
        参数：
        context - SynthContext identifying requester
        key - Property being requested.
        defaultValue - Value to return if the property has not been specified, or is not a Number
        返回：
        Value of the named property

      • getBoolean

        public boolean getBoolean(SynthContext context,
                 Object key,
                 boolean defaultValue)
        Convenience method to get a specific style property whose value is an Boolean.
        参数：
        context - SynthContext identifying requester
        key - Property being requested.
        defaultValue - Value to return if the property has not been specified, or is not a Boolean
        返回：
        Value of the named property

      • getIcon

        public Icon getIcon(SynthContext context,
           Object key)
        Convenience method to get a specific style property whose value is an Icon.
        参数：
        context - SynthContext identifying requester
        key - Property being requested.
        返回：
        Value of the named property, or null if not specified

      • getString

        public String getString(SynthContext context,
               Object key,
               String defaultValue)
        Convenience method to get a specific style property whose value is a String.
        参数：
        context - SynthContext identifying requester
        key - Property being requested.
        defaultValue - Value to return if the property has not been specified, or is not a String
        返回：
        Value of the named property
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acytudkndkcggkcchlootftlonnnnu, irr utonc


SynthStyleFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthStyleFactory

  • java.lang.Object
    • javax.swing.plaf.synth.SynthStyleFactory

  • public abstract class SynthStyleFactory
extends Object
    Factory used for obtaining SynthStyles. Each of the Synth ComponentUIs will call into the current SynthStyleFactory to obtain a SynthStyle for each of the distinct regions they have.

    The following example creates a custom SynthStyleFactory that returns a different style based on the Region:

     class MyStyleFactory extends SynthStyleFactory {
     public SynthStyle getStyle(JComponent c, Region id) {
         if (id == Region.BUTTON) {
             return buttonStyle;
         }
         else if (id == Region.TREE) {
             return treeStyle;
         }
         return defaultStyle;
     }
 }
 SynthLookAndFeel laf = new SynthLookAndFeel();
 UIManager.setLookAndFeel(laf);
 SynthLookAndFeel.setStyleFactory(new MyStyleFactory());
    从以下版本开始：
    1.5
    另请参见：
    SynthStyleFactory, SynthStyle

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthStyleFactory()
      Creates a SynthStyleFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract SynthStyle getStyle(JComponent c, Region id)
      Returns the style for the specified Component.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthStyleFactory

        public SynthStyleFactory()
        Creates a SynthStyleFactory.

    • 方法详细信息

      • getStyle

        public abstract SynthStyle getStyle(JComponent c,
                  Region id)
        Returns the style for the specified Component.
        参数：
        c - Component asking for
        id - Region identifier
        返回：
        SynthStyle for region.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.=hnettetnhhtnntpjjo.,ntxxaOetc)O..ltlxg


SynthTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTabbedPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI
          • javax.swing.plaf.synth.SynthTabbedPaneUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI, SwingConstants

    public class SynthTabbedPaneUI
extends BasicTabbedPaneUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JTabbedPane.

    Looks up the selectedTabPadInsets property from the Style, which represents additional insets for the selected tab.

    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTabbedPaneUI

        BasicTabbedPaneUI.FocusHandler, BasicTabbedPaneUI.MouseHandler, BasicTabbedPaneUI.PropertyChangeHandler, BasicTabbedPaneUI.TabbedPaneLayout, BasicTabbedPaneUI.TabSelectionHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicTabbedPaneUI

        calcRect, contentBorderInsets, darkShadow, downKey, focus, focusListener, highlight, leftKey, lightHighlight, maxTabHeight, maxTabWidth, mouseListener, propertyChangeListener, rects, rightKey, runCount, selectedRun, selectedTabPadInsets, shadow, tabAreaInsets, tabChangeListener, tabInsets, tabPane, tabRunOverlay, tabRuns, textIconGap, upKey

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTabbedPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected int | calculateMaxTabHeight(int tabPlacement)
      protected int | calculateMaxTabWidth(int tabPlacement)
      protected int | calculateTabWidth(int tabPlacement, int tabIndex, FontMetrics metrics)
      protected LayoutManager createLayoutManager()
      Invoked by installUI to create a layout manager object to manage the JTabbedPane.
      protected MouseListener | createMouseListener()
      protected JButton createScrollButton(int direction)
      Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      protected int getBaseline(int tab)
      Returns the baseline for the specified tab.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected FontMetrics | getFontMetrics()
      protected Insets | getTabInsets(int tabPlacement, int tabIndex)
      protected int | getTabLabelShiftX(int tabPlacement, int tabIndex, boolean isSelected)
      protected int | getTabLabelShiftY(int tabPlacement, int tabIndex, boolean isSelected)
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void setRolloverTab(int index)
      Sets the tab the mouse is currently over to index.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTabbedPaneUI

        assureRectsCreated, calculateTabAreaHeight, calculateTabAreaWidth, calculateTabHeight, createChangeListener, createFocusListener, createPropertyChangeListener, expandTabRunsArray, getBaseline, getBaselineOffset, getBaselineResizeBehavior, getContentBorderInsets, getFocusIndex, getIconForTab, getMaximumSize, getMinimumSize, getNextTabIndex, getNextTabIndexInRun, getNextTabRun, getPreviousTabIndex, getPreviousTabIndexInRun, getPreviousTabRun, getRolloverTab, getRunForTab, getSelectedTabPadInsets, getTabAreaInsets, getTabBounds, getTabBounds, getTabRunCount, getTabRunIndent, getTabRunOffset, getTabRunOverlay, getTextViewForTab, getVisibleComponent, installComponents, installKeyboardActions, installUI, lastTabInRun, layoutLabel, navigateSelectedTab, paintContentBorder, paintContentBorderBottomEdge, paintContentBorderLeftEdge, paintContentBorderRightEdge, paintContentBorderTopEdge, paintFocusIndicator, paintIcon, paintTab, paintTabArea, paintTabBackground, paintTabBorder, paintText, rotateInsets, selectAdjacentRunTab, selectNextTab, selectNextTabInRun, selectPreviousTab, selectPreviousTabInRun, setVisibleComponent, shouldPadTabRun, shouldRotateTabRuns, tabForCoordinate, uninstallComponents, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTabbedPaneUI

        public SynthTabbedPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicTabbedPaneUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicTabbedPaneUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicTabbedPaneUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicTabbedPaneUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • createScrollButton

        protected JButton createScrollButton(int direction)
        Description copied from class: BasicTabbedPaneUI
        Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction. The returned JButton must be instance of UIResource.
        重载：
        createScrollButton in class BasicTabbedPaneUI
        参数：
        direction - One of the SwingConstants constants: SOUTH, NORTH, EAST or WEST
        返回：
        Widget for user to
        另请参见：
        JTabbedPane.setTabPlacement(int), SwingConstants

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.

      • createMouseListener

        protected MouseListener createMouseListener()
        重载：
        createMouseListener in class BasicTabbedPaneUI

      • getTabLabelShiftX

        protected int getTabLabelShiftX(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)
        重载：
        getTabLabelShiftX in class BasicTabbedPaneUI

      • getTabLabelShiftY

        protected int getTabLabelShiftY(int tabPlacement,
                    int tabIndex,
                    boolean isSelected)
        重载：
        getTabLabelShiftY in class BasicTabbedPaneUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • getBaseline

        protected int getBaseline(int tab)
        Description copied from class: BasicTabbedPaneUI
        Returns the baseline for the specified tab.
        重载：
        getBaseline in class BasicTabbedPaneUI
        参数：
        tab - index of tab to get baseline for
        返回：
        baseline or a value < 0 indicating there is no reasonable baseline

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicTabbedPaneUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • setRolloverTab

        protected void setRolloverTab(int index)
        Description copied from class: BasicTabbedPaneUI
        Sets the tab the mouse is currently over to index. index will be -1 if the mouse is no longer over any tab. No checking is done to ensure the passed in index identifies a valid tab.
        重载：
        setRolloverTab in class BasicTabbedPaneUI
        参数：
        index - Index of the tab the mouse is over.

      • calculateMaxTabHeight

        protected int calculateMaxTabHeight(int tabPlacement)
        重载：
        calculateMaxTabHeight in class BasicTabbedPaneUI

      • calculateTabWidth

        protected int calculateTabWidth(int tabPlacement,
                    int tabIndex,
                    FontMetrics metrics)
        重载：
        calculateTabWidth in class BasicTabbedPaneUI

      • calculateMaxTabWidth

        protected int calculateMaxTabWidth(int tabPlacement)
        重载：
        calculateMaxTabWidth in class BasicTabbedPaneUI

      • getTabInsets

        protected Insets getTabInsets(int tabPlacement,
                  int tabIndex)
        重载：
        getTabInsets in class BasicTabbedPaneUI

      • getFontMetrics

        protected FontMetrics getFontMetrics()
        重载：
        getFontMetrics in class BasicTabbedPaneUI

      • createLayoutManager

        protected LayoutManager createLayoutManager()
        Description copied from class: BasicTabbedPaneUI
        Invoked by installUI to create a layout manager object to manage the JTabbedPane.
        重载：
        createLayoutManager in class BasicTabbedPaneUI
        返回：
        a layout manager object
        另请参见：
        BasicTabbedPaneUI.TabbedPaneLayout, JTabbedPane.getTabLayoutPolicy()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTableHeaderUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
          • javax.swing.plaf.synth.SynthTableHeaderUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthTableHeaderUI
extends BasicTableHeaderUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JTableHeader.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTableHeaderUI

        BasicTableHeaderUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicTableHeaderUI

        header, mouseInputListener, rendererPane

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTableHeaderUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent h)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes JTableHeader properties such as font, foreground, and background.
      protected void installListeners()
      Attaches listeners to the JTableHeader.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed.
      protected void rolloverColumnUpdated(int oldColumn, int newColumn)
      This method gets called every time when a rollover column in the table header is updated.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTableHeaderUI

        createMouseInputListener, getBaseline, getMaximumSize, getMinimumSize, getPreferredSize, getRolloverColumn, installKeyboardActions, installUI, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTableHeaderUI

        public SynthTableHeaderUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent h)
        Creates a new UI object for the given component.
        参数：
        h - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicTableHeaderUI
        Initializes JTableHeader properties such as font, foreground, and background. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTableHeaderUI
        另请参见：
        BasicTableHeaderUI.installUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Description copied from class: BasicTableHeaderUI
        Attaches listeners to the JTableHeader.
        重载：
        installListeners in class BasicTableHeaderUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicTableHeaderUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicTableHeaderUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicTableHeaderUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • rolloverColumnUpdated

        protected void rolloverColumnUpdated(int oldColumn,
                         int newColumn)
        Description copied from class: BasicTableHeaderUI
        This method gets called every time when a rollover column in the table header is updated. Every look and feel that supports a rollover effect in a table header should override this method and repaint the header.
        重载：
        rolloverColumnUpdated in class BasicTableHeaderUI
        参数：
        oldColumn - the index of the previous rollover column or -1 if the mouse was not over a column
        newColumn - the index of the new rollover column or -1 if the mouse is not over a column
        另请参见：
        BasicTableHeaderUI.getRolloverColumn(), JTableHeader.getHeaderRect(int)

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lioit>k">kcLLkcc=u >/-M 3MD>aiIr(ejccc-aee Lt"o


SynthTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTableUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
          • javax.swing.plaf.synth.SynthTableUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthTableUI
extends BasicTableUI
implements SynthUI, PropertyChangeListener
    Provides the Synth L&F UI delegate for JTable.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTableUI

        BasicTableUI.FocusHandler, BasicTableUI.KeyHandler, BasicTableUI.MouseInputHandler

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicTableUI

        focusListener, keyListener, mouseInputListener, rendererPane, table

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTableUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes JTable properties, such as font, foreground, and background.
      protected void installListeners()
      Attaches listeners to the JTable.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent event)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTableUI

        createFocusListener, createKeyListener, createMouseInputListener, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installKeyboardActions, installUI, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTableUI

        public SynthTableUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        Initializes JTable properties, such as font, foreground, and background. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTableUI
        另请参见：
        BasicTableUI.installUI(javax.swing.JComponent)

      • installListeners

        protected void installListeners()
        Attaches listeners to the JTable.
        重载：
        installListeners in class BasicTableUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicTableUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicTableUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicTableUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • propertyChange

        public void propertyChange(PropertyChangeEvent event)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        event - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e adaIaia/>>a//�1ff/./.e./ee.cah-tlmdd=a"tr/�


SynthTextAreaUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTextAreaUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextAreaUI
            • javax.swing.plaf.synth.SynthTextAreaUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory

    public class SynthTextAreaUI
extends BasicTextAreaUI
implements SynthUI
    Provides the look and feel for a plain text editor in the Synth look and feel. In this implementation the default UI is extended to act as a simple view factory.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTextAreaUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent ta)
      Creates a UI object for a JTextArea.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void paintBackground(Graphics g)
      Paints a background for the view.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.
      protected void uninstallDefaults()
      Sets the component properties that have not been explicitly overridden to null.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextAreaUI

        create, getBaseline, getBaselineResizeBehavior, getMinimumSize, getPreferredSize, getPropertyPrefix

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getNextVisualPositionFrom, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, uninstallUI, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTextAreaUI

        public SynthTextAreaUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent ta)
        Creates a UI object for a JTextArea.
        参数：
        ta - a text area
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicTextUI
        Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTextAreaUI
        另请参见：
        BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

      • uninstallDefaults

        protected void uninstallDefaults()
        Description copied from class: BasicTextUI
        Sets the component properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        重载：
        uninstallDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.installDefaults(), BasicTextUI.uninstallUI(javax.swing.JComponent)

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class BasicTextUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBackground

        protected void paintBackground(Graphics g)
        Description copied from class: BasicTextUI
        Paints a background for the view. This will only be called if isOpaque() on the associated component is true. The default is to paint the background color of the component.
        重载：
        paintBackground in class BasicTextUI
        参数：
        g - the graphics context

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to rebuild the View when the WrapLine or the WrapStyleWord property changes.
        重载：
        propertyChange in class BasicTextAreaUI
        参数：
        evt - the property change event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=p�


SynthTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTextFieldUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.synth.SynthTextFieldUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory
    直接已知子类：
    SynthFormattedTextFieldUI, SynthPasswordFieldUI

    public class SynthTextFieldUI
extends BasicTextFieldUI
implements SynthUI
    Provides the Synth L&F UI delegate for JTextField.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTextFieldUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for a JTextField.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults()
      Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void paintBackground(Graphics g)
      Paints a background for the view.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.
      protected void uninstallDefaults()
      Sets the component properties that have not been explicitly overridden to null.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextFieldUI

        create, getBaseline, getBaselineResizeBehavior, getPropertyPrefix

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, uninstallUI, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTextFieldUI

        public SynthTextFieldUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for a JTextField.
        参数：
        c - the text field
        返回：
        the UI object

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class BasicTextUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.

        This is routed to the BasicTextUI.paintSafely(java.awt.Graphics) method under the guarantee that the model does not change from the view of this thread while it is rendering (if the associated model is derived from AbstractDocument). This enables the model to potentially be updated asynchronously.

        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paintBackground

        protected void paintBackground(Graphics g)
        Description copied from class: BasicTextUI
        Paints a background for the view. This will only be called if isOpaque() on the associated component is true. The default is to paint the background color of the component.
        重载：
        paintBackground in class BasicTextUI
        参数：
        g - the graphics context

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. This is implemented to do nothing (i.e. the response to properties in JTextComponent itself are handled prior to calling this method).
        重载：
        propertyChange in class BasicTextUI
        参数：
        evt - the property change event

      • installDefaults

        protected void installDefaults()
        Description copied from class: BasicTextUI
        Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color. The font, foreground, and background properties are only set if their current value is either null or a UIResource, other properties are set if the current value is null.
        重载：
        installDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

      • uninstallDefaults

        protected void uninstallDefaults()
        Description copied from class: BasicTextUI
        Sets the component properties that have not been explicitly overridden to null. A property is considered overridden if its current value is not a UIResource.
        重载：
        uninstallDefaults in class BasicTextUI
        另请参见：
        BasicTextUI.installDefaults(), BasicTextUI.uninstallUI(javax.swing.JComponent)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>


SynthTextPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTextPaneUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.synth.SynthEditorPaneUI
              • javax.swing.plaf.synth.SynthTextPaneUI
  • 所有已实现的接口：
    SynthConstants, SynthUI, ViewFactory

    public class SynthTextPaneUI
extends SynthEditorPaneUI
    Provides the look and feel for a styled text editor in the Synth look and feel.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTextPaneUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a UI for the JTextPane.
      protected String getPropertyPrefix()
      Fetches the name used as a key to lookup properties through the UIManager.
      void installUI(JComponent c)
      Installs the UI for a component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void propertyChange(PropertyChangeEvent evt)
      This method gets called when a bound property is changed on the associated JTextComponent.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthEditorPaneUI

        getContext, installDefaults, paint, paintBackground, uninstallDefaults, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicEditorPaneUI

        getEditorKit, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintSafely, setView, uninstallKeyboardActions, uninstallListeners, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTextPaneUI

        public SynthTextPaneUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a UI for the JTextPane.
        参数：
        c - the JTextPane object
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        Fetches the name used as a key to lookup properties through the UIManager. This is used as a prefix to all the standard text properties.
        重载：
        getPropertyPrefix in class BasicEditorPaneUI
        返回：
        the name ("TextPane")

      • installUI

        public void installUI(JComponent c)
        Installs the UI for a component. This does the following things.
        1. Sets opaqueness of the associated component according to its style, if the opaque property has not already been set by the client program.
        2. Installs the default caret and highlighter into the associated component. These properties are only set if their current value is either null or an instance of UIResource.
        3. Attaches to the editor and model. If there is no model, a default one is created.
        4. Creates the view factory and the view hierarchy used to represent the model.
        重载：
        installUI in class BasicEditorPaneUI
        参数：
        c - the editor component
        另请参见：
        BasicTextUI.installUI(javax.swing.JComponent), ComponentUI.installUI(javax.swing.JComponent)

      • propertyChange

        protected void propertyChange(PropertyChangeEvent evt)
        This method gets called when a bound property is changed on the associated JTextComponent. This is a hook which UI implementations may change to reflect how the UI displays bound properties of JTextComponent subclasses. If the font, foreground or document has changed, the the appropriate property is set in the default style of the document.
        重载：
        propertyChange in class SynthEditorPaneUI
        参数：
        evt - the property change event

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthEditorPaneUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a Te TennnennCettal bi"">sTthaglel eoolr tlrT


SynthToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthToggleButtonUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.synth.SynthButtonUI
            • javax.swing.plaf.synth.SynthToggleButtonUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI
    直接已知子类：
    SynthRadioButtonUI

    public class SynthToggleButtonUI
extends SynthButtonUI
    Provides the Synth L&F UI delegate for JToggleButton.
    从以下版本开始：
    1.7

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicButtonUI

        defaultTextIconGap, defaultTextShiftOffset

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthToggleButtonUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent b)
      Creates a new UI object for the given component.
      protected String | getPropertyPrefix()
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

      • 方法 - 继承于类 javax.swing.plaf.synth.SynthButtonUI

        getBaseline, getContext, getDefaultIcon, getIcon, getMaximumSize, getMinimumSize, getPreferredSize, getSizingIcon, installDefaults, installListeners, paint, paint, propertyChange, uninstallDefaults, uninstallListeners, update

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicButtonUI

        clearTextShiftOffset, createButtonListener, getBaselineResizeBehavior, getDefaultTextIconGap, getTextShiftOffset, installKeyboardActions, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthToggleButtonUI

        public SynthToggleButtonUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent b)
        Creates a new UI object for the given component.
        参数：
        b - component to create UI object for
        返回：
        the UI object

      • getPropertyPrefix

        protected String getPropertyPrefix()
        重载：
        getPropertyPrefix in class BasicButtonUI

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        重载：
        paintBorder in class SynthButtonUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tplIde deh ehhhryyeh i coo s a cJiTooeccoTae a


SynthToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthToolBarUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI
          • javax.swing.plaf.synth.SynthToolBarUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI, SwingConstants

    public class SynthToolBarUI
extends BasicToolBarUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JToolBar.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicToolBarUI

        BasicToolBarUI.DockingListener, BasicToolBarUI.DragWindow, BasicToolBarUI.FrameListener, BasicToolBarUI.PropertyListener, BasicToolBarUI.ToolBarContListener, BasicToolBarUI.ToolBarFocusListener

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicToolBarUI

        constraintBeforeFloating, dockingBorderColor, dockingColor, dockingListener, downKey, dragWindow, floatingBorderColor, floatingColor, focusedCompIndex, leftKey, propertyListener, rightKey, toolBar, toolBarContListener, toolBarFocusListener, upKey

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthToolBarUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected LayoutManager createLayout()
      Creates a LayoutManager to use with the toolbar.
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void | installComponents()
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the toolbar.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void paintContent(SynthContext context, Graphics g, Rectangle bounds)
      Paints the toolbar content.
      protected void paintDragWindow(Graphics g)
      Paints the contents of the window used for dragging.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void setBorderToNonRollover(Component c)
      This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
      protected void setBorderToNormal(Component c)
      This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
      protected void setBorderToRollover(Component c)
      This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
      protected void | uninstallComponents()
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolBarUI

        canDock, createDockingListener, createDragWindow, createFloatingFrame, createFloatingWindow, createFrameListener, createNonRolloverBorder, createPropertyListener, createRolloverBorder, createToolBarContListener, createToolBarFocusListener, dragTo, floatAt, getDockingColor, getFloatingColor, getNonRolloverBorder, getRolloverBorder, installKeyboardActions, installNonRolloverBorders, installNormalBorders, installRolloverBorders, installUI, isFloating, isRolloverBorders, navigateFocusedComp, setDockingColor, setFloating, setFloatingColor, setFloatingLocation, setOrientation, setRolloverBorders, uninstallKeyboardActions, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthToolBarUI

        public SynthToolBarUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicToolBarUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicToolBarUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicToolBarUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicToolBarUI

      • installComponents

        protected void installComponents()
        重载：
        installComponents in class BasicToolBarUI

      • uninstallComponents

        protected void uninstallComponents()
        重载：
        uninstallComponents in class BasicToolBarUI

      • createLayout

        protected LayoutManager createLayout()
        Creates a LayoutManager to use with the toolbar.
        返回：
        a LayoutManager instance

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • setBorderToNonRollover

        protected void setBorderToNonRollover(Component c)
        This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
        重载：
        setBorderToNonRollover in class BasicToolBarUI
        参数：
        c - component which will have a non-rollover border installed
        另请参见：
        BasicToolBarUI.createNonRolloverBorder()

      • setBorderToRollover

        protected void setBorderToRollover(Component c)
        This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
        重载：
        setBorderToRollover in class BasicToolBarUI
        参数：
        c - component which will have a rollover border installed
        另请参见：
        BasicToolBarUI.createRolloverBorder()

      • setBorderToNormal

        protected void setBorderToNormal(Component c)
        This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.
        重载：
        setBorderToNormal in class BasicToolBarUI
        参数：
        c - component which will have a normal border re-installed
        另请参见：
        BasicToolBarUI.createNonRolloverBorder()

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the toolbar.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintContent

        protected void paintContent(SynthContext context,
                Graphics g,
                Rectangle bounds)
        Paints the toolbar content.
        参数：
        context - context for the component being painted
        g - Graphics object used for painting
        bounds - bounding box for the toolbar

      • paintDragWindow

        protected void paintDragWindow(Graphics g)
        Description copied from class: BasicToolBarUI
        Paints the contents of the window used for dragging.
        重载：
        paintDragWindow in class BasicToolBarUI
        参数：
        g - Graphics to paint to.

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


SynthToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthToolTipUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.synth.SynthToolTipUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthToolTipUI
extends BasicToolTipUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JToolTip.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthToolTipUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Dimension getPreferredSize(JComponent c)
      Returns the specified component's preferred size appropriate for the look and feel.
      protected void | installDefaults(JComponent c)
      protected void | installListeners(JComponent c)
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults(JComponent c)
      protected void | uninstallListeners(JComponent c)
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicToolTipUI

        getMaximumSize, getMinimumSize, installUI, uninstallUI

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthToolTipUI

        public SynthToolTipUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installDefaults

        protected void installDefaults(JComponent c)
        重载：
        installDefaults in class BasicToolTipUI

      • uninstallDefaults

        protected void uninstallDefaults(JComponent c)
        重载：
        uninstallDefaults in class BasicToolTipUI

      • installListeners

        protected void installListeners(JComponent c)
        重载：
        installListeners in class BasicToolTipUI

      • uninstallListeners

        protected void uninstallListeners(JComponent c)
        重载：
        uninstallListeners in class BasicToolTipUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicToolTipUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • getPreferredSize

        public Dimension getPreferredSize(JComponent c)
        Description copied from class: ComponentUI
        Returns the specified component's preferred size appropriate for the look and feel. If null is returned, the preferred size will be calculated by the component's layout manager instead (this is the preferred approach for any component with a specific layout manager installed). The default implementation of this method returns null.
        重载：
        getPreferredSize in class BasicToolTipUI
        参数：
        c - the component whose preferred size is being queried; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r=earaseasbppsbb/M..as.<"ee.r/.aogueyyaprt"/ptt


SynthTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthTreeUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.synth.SynthTreeUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthTreeUI
extends BasicTreeUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JTree.
    从以下版本开始：
    1.7

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTreeUI

        BasicTreeUI.CellEditorHandler, BasicTreeUI.ComponentHandler, BasicTreeUI.FocusHandler, BasicTreeUI.KeyHandler, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, BasicTreeUI.NodeDimensionsHandler, BasicTreeUI.PropertyChangeHandler, BasicTreeUI.SelectionModelPropertyChangeHandler, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeExpansionHandler, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreeModelHandler, BasicTreeUI.TreePageAction, BasicTreeUI.TreeSelectionHandler, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction

    • 字段摘要

      • Fields inherited from class javax.swing.plaf.basic.BasicTreeUI

        cellEditor, collapsedIcon, createdCellEditor, createdRenderer, currentCellRenderer, depthOffset, drawingCache, editingComponent, editingPath, editingRow, editorHasDifferentSize, expandedIcon, largeModel, lastSelectedRow, leftChildIndent, nodeDimensions, preferredMinSize, preferredSize, rendererPane, rightChildIndent, stopEditingInCompleteEditing, totalChildIndent, tree, treeModel, treeSelectionModel, treeState, validCachedPreferredSize

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthTreeUI()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected TreeCellEditor createDefaultCellEditor()
      Creates a default cell editor.
      protected TreeCellRenderer createDefaultCellRenderer()
      Returns the default cell renderer that is used to do the stamping of each node.
      static ComponentUI createUI(JComponent x)
      Creates a new UI object for the given component.
      protected void | drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      Icon getExpandedIcon()
      protected int getRowX(int row, int depth)
      Returns the location, along the x-axis, to render a particular row at.
      protected void | installDefaults()
      protected void | installListeners()
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      protected void paintDropLine(Graphics g)
      Paints the drop line.
      protected void paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the expand (toggle) part of a row.
      protected void paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
      Paints a horizontal line.
      protected void paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
      Paints a vertical line.
      protected void paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.
      void propertyChange(PropertyChangeEvent event)
      This method gets called when a bound property is changed.
      protected void | uninstallDefaults()
      protected void | uninstallListeners()
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTreeUI

        cancelEditing, checkForClickInExpandControl, completeEditing, completeEditing, completeUIInstall, completeUIUninstall, configureLayoutCache, createCellEditorListener, createCellRendererPane, createComponentListener, createFocusListener, createKeyListener, createLayoutCache, createMouseListener, createNodeDimensions, createPropertyChangeListener, createSelectionModelPropertyChangeListener, createTreeExpansionListener, createTreeModelListener, createTreeSelectionListener, drawDashedHorizontalLine, drawDashedVerticalLine, ensureRowsAreVisible, getBaseline, getBaselineResizeBehavior, getCellEditor, getCellRenderer, getClosestPathForLocation, getCollapsedIcon, getDropLineRect, getEditingPath, getHashColor, getHorizontalLegBuffer, getLastChildPath, getLeadSelectionRow, getLeftChildIndent, getMaximumSize, getMinimumSize, getModel, getPathBounds, getPathForRow, getPreferredMinSize, getPreferredSize, getPreferredSize, getRightChildIndent, getRowCount, getRowForPath, getRowHeight, getSelectionModel, getShowsRootHandles, getVerticalLegBuffer, handleExpandControlClick, installComponents, installKeyboardActions, installUI, isDropLine, isEditable, isEditing, isLargeModel, isLeaf, isLocationInExpandControl, isMultiSelectEvent, isRootVisible, isToggleEvent, isToggleSelectionEvent, paintRow, pathWasCollapsed, pathWasExpanded, prepareForUIInstall, prepareForUIUninstall, selectPathForEvent, setCellEditor, setCellRenderer, setCollapsedIcon, setEditable, setExpandedIcon, setHashColor, setLargeModel, setLeftChildIndent, setModel, setPreferredMinSize, setRightChildIndent, setRootVisible, setRowHeight, setSelectionModel, setShowsRootHandles, shouldPaintExpandControl, startEditing, startEditingAtPath, stopEditing, toggleExpandState, uninstallComponents, uninstallKeyboardActions, uninstallUI, updateCachedPreferredSize, updateCellEditor, updateDepthOffset, updateExpandedDescendants, updateLayoutCacheExpandedNodes, updateLeadSelectionRow, updateRenderer, updateSize

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthTreeUI

        public SynthTreeUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent x)
        Creates a new UI object for the given component.
        参数：
        x - component to create UI object for
        返回：
        the UI object

      • getExpandedIcon

        public Icon getExpandedIcon()
        重载：
        getExpandedIcon in class BasicTreeUI

      • installDefaults

        protected void installDefaults()
        重载：
        installDefaults in class BasicTreeUI

      • installListeners

        protected void installListeners()
        重载：
        installListeners in class BasicTreeUI

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • createDefaultCellEditor

        protected TreeCellEditor createDefaultCellEditor()
        Description copied from class: BasicTreeUI
        Creates a default cell editor.
        重载：
        createDefaultCellEditor in class BasicTreeUI

      • createDefaultCellRenderer

        protected TreeCellRenderer createDefaultCellRenderer()
        Description copied from class: BasicTreeUI
        Returns the default cell renderer that is used to do the stamping of each node.
        重载：
        createDefaultCellRenderer in class BasicTreeUI

      • uninstallDefaults

        protected void uninstallDefaults()
        重载：
        uninstallDefaults in class BasicTreeUI

      • uninstallListeners

        protected void uninstallListeners()
        重载：
        uninstallListeners in class BasicTreeUI

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        从接口复制的描述： SynthUI
        Paints the border.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class BasicTreeUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • paintHorizontalPartOfLeg

        protected void paintHorizontalPartOfLeg(Graphics g,
                            Rectangle clipBounds,
                            Insets insets,
                            Rectangle bounds,
                            TreePath path,
                            int row,
                            boolean isExpanded,
                            boolean hasBeenExpanded,
                            boolean isLeaf)
        Description copied from class: BasicTreeUI
        Paints the horizontal part of the leg. The receiver should NOT modify clipBounds, or insets.

        NOTE: parentRow can be -1 if the root is not visible.

        重载：
        paintHorizontalPartOfLeg in class BasicTreeUI

      • paintHorizontalLine

        protected void paintHorizontalLine(Graphics g,
                       JComponent c,
                       int y,
                       int left,
                       int right)
        Description copied from class: BasicTreeUI
        Paints a horizontal line.
        重载：
        paintHorizontalLine in class BasicTreeUI

      • paintVerticalPartOfLeg

        protected void paintVerticalPartOfLeg(Graphics g,
                          Rectangle clipBounds,
                          Insets insets,
                          TreePath path)
        Description copied from class: BasicTreeUI
        Paints the vertical part of the leg. The receiver should NOT modify clipBounds, insets.

        重载：
        paintVerticalPartOfLeg in class BasicTreeUI

      • paintVerticalLine

        protected void paintVerticalLine(Graphics g,
                     JComponent c,
                     int x,
                     int top,
                     int bottom)
        Description copied from class: BasicTreeUI
        Paints a vertical line.
        重载：
        paintVerticalLine in class BasicTreeUI

      • paintExpandControl

        protected void paintExpandControl(Graphics g,
                      Rectangle clipBounds,
                      Insets insets,
                      Rectangle bounds,
                      TreePath path,
                      int row,
                      boolean isExpanded,
                      boolean hasBeenExpanded,
                      boolean isLeaf)
        Description copied from class: BasicTreeUI
        Paints the expand (toggle) part of a row. The receiver should NOT modify clipBounds, or insets.
        重载：
        paintExpandControl in class BasicTreeUI

      • drawCentered

        protected void drawCentered(Component c,
                Graphics graphics,
                Icon icon,
                int x,
                int y)
        重载：
        drawCentered in class BasicTreeUI

      • propertyChange

        public void propertyChange(PropertyChangeEvent event)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        event - A PropertyChangeEvent object describing the event source and the property that has changed.

      • paintDropLine

        protected void paintDropLine(Graphics g)
        Description copied from class: BasicTreeUI
        Paints the drop line.
        重载：
        paintDropLine in class BasicTreeUI
        参数：
        g - Graphics object to draw on

      • getRowX

        protected int getRowX(int row,
          int depth)
        Description copied from class: BasicTreeUI
        Returns the location, along the x-axis, to render a particular row at. The return value does not include any Insets specified on the JTree. This does not check for the validity of the row or depth, it is assumed to be correct and will not throw an Exception if the row or depth doesn't match that of the tree.
        重载：
        getRowX in class BasicTreeUI
        参数：
        row - Row to return x location for
        depth - Depth of the row
        返回：
        amount to indent the given row.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SynthUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.plaf.synth

Interface SynthUI

  • All Superinterfaces:
    SynthConstants
    All Known Implementing Classes:
    SynthButtonUI, SynthCheckBoxMenuItemUI, SynthCheckBoxUI, SynthColorChooserUI, SynthComboBoxUI, SynthDesktopIconUI, SynthDesktopPaneUI, SynthEditorPaneUI, SynthFormattedTextFieldUI, SynthInternalFrameUI, SynthLabelUI, SynthListUI, SynthMenuBarUI, SynthMenuItemUI, SynthMenuUI, SynthOptionPaneUI, SynthPanelUI, SynthPasswordFieldUI, SynthPopupMenuUI, SynthProgressBarUI, SynthRadioButtonMenuItemUI, SynthRadioButtonUI, SynthRootPaneUI, SynthScrollBarUI, SynthScrollPaneUI, SynthSeparatorUI, SynthSliderUI, SynthSpinnerUI, SynthSplitPaneUI, SynthTabbedPaneUI, SynthTableHeaderUI, SynthTableUI, SynthTextAreaUI, SynthTextFieldUI, SynthTextPaneUI, SynthToggleButtonUI, SynthToolBarUI, SynthToolTipUI, SynthTreeUI, SynthViewportUI

    public interface SynthUI
extends SynthConstants
    SynthUI is used to fetch the SynthContext for a particular Component.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.

    • 方法详细信息

      • getContext

        SynthContext getContext(JComponent c)
        Returns the Context for the specified component.
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • paintBorder

        void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Paints the border.
        参数：
        context - a component context
        g - Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>rncnnonniggniiaivvvv.j./p/haee//nt


SynthViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.plaf.synth

类 SynthViewportUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.synth.SynthViewportUI
  • 所有已实现的接口：
    PropertyChangeListener, EventListener, SynthConstants, SynthUI

    public class SynthViewportUI
extends ViewportUI
implements PropertyChangeListener, SynthUI
    Provides the Synth L&F UI delegate for JViewport.
    从以下版本开始：
    1.7

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.plaf.synth.SynthConstants

        DEFAULT, DISABLED, ENABLED, FOCUSED, MOUSE_OVER, PRESSED, SELECTED

    • 构造方法摘要

      Constructors
      构造方法与描述
      SynthViewportUI()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static ComponentUI createUI(JComponent c)
      Creates a new UI object for the given component.
      SynthContext getContext(JComponent c)
      Returns the Context for the specified component.
      protected void installDefaults(JComponent c)
      Installs defaults for a viewport.
      protected void installListeners(JComponent c)
      Installs listeners into the viewport.
      void installUI(JComponent c)
      Configures the specified component appropriately for the look and feel.
      void paint(Graphics g, JComponent c)
      Paints the specified component according to the Look and Feel.
      protected void paint(SynthContext context, Graphics g)
      Paints the specified component.
      void paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void propertyChange(PropertyChangeEvent e)
      This method gets called when a bound property is changed.
      protected void uninstallDefaults(JComponent c)
      Uninstalls defaults from a viewport.
      protected void uninstallListeners(JComponent c)
      Uninstalls listeners from the viewport.
      void uninstallUI(JComponent c)
      Reverses configuration which was done on the specified component during installUI.
      void update(Graphics g, JComponent c)
      Notifies this UI delegate to repaint the specified component.

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SynthViewportUI

        public SynthViewportUI()

    • 方法详细信息

      • createUI

        public static ComponentUI createUI(JComponent c)
        Creates a new UI object for the given component.
        参数：
        c - component to create UI object for
        返回：
        the UI object

      • installUI

        public void installUI(JComponent c)
        Description copied from class: ComponentUI
        Configures the specified component appropriately for the look and feel. This method is invoked when the ComponentUI instance is being installed as the UI delegate on the specified component. This method should completely configure the component for the look and feel, including the following:
        1. Install default property values for color, fonts, borders, icons, opacity, etc. on the component. Whenever possible, property values initialized by the client program should not be overridden.
        2. Install a LayoutManager on the component if necessary.
        3. Create/add any required sub-components to the component.
        4. Create/install event listeners on the component.
        5. Create/install a PropertyChangeListener on the component in order to detect and respond to component property changes appropriately.
        6. Install keyboard UI (mnemonics, traversal, etc.) on the component.
        7. Initialize any appropriate instance data.
        重载：
        installUI in class ComponentUI
        参数：
        c - the component where this UI delegate is being installed
        另请参见：
        ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

      • uninstallUI

        public void uninstallUI(JComponent c)
        Description copied from class: ComponentUI
        Reverses configuration which was done on the specified component during installUI. This method is invoked when this UIComponent instance is being removed as the UI delegate for the specified component. This method should undo the configuration performed in installUI, being careful to leave the JComponent instance in a clean state (no extraneous listeners, look-and-feel-specific property objects, etc.). This should include the following:
        1. Remove any UI-set borders from the component.
        2. Remove any UI-set layout managers on the component.
        3. Remove any UI-added sub-components from the component.
        4. Remove any UI-added event/property listeners from the component.
        5. Remove any UI-installed keyboard UI from the component.
        6. Nullify any allocated instance data objects to allow for GC.
        重载：
        uninstallUI in class ComponentUI
        参数：
        c - the component from which this UI delegate is being removed; this argument is often ignored, but might be used if the UI object is stateless and shared by multiple components
        另请参见：
        ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

      • installDefaults

        protected void installDefaults(JComponent c)
        Installs defaults for a viewport.
        参数：
        c - a JViewport object

      • installListeners

        protected void installListeners(JComponent c)
        Installs listeners into the viewport.
        参数：
        c - a JViewport object

      • uninstallListeners

        protected void uninstallListeners(JComponent c)
        Uninstalls listeners from the viewport.
        参数：
        c - a JViewport object

      • uninstallDefaults

        protected void uninstallDefaults(JComponent c)
        Uninstalls defaults from a viewport.
        参数：
        c - a JViewport object

      • getContext

        public SynthContext getContext(JComponent c)
        从接口复制的描述： SynthUI
        Returns the Context for the specified component.
        指定者：
        getContext in interface SynthUI
        参数：
        c - Component requesting SynthContext.
        返回：
        SynthContext describing component.

      • update

        public void update(Graphics g,
          JComponent c)
        Notifies this UI delegate to repaint the specified component. This method paints the component background, then calls the paint(SynthContext,Graphics) method.

        In general, this method does not need to be overridden by subclasses. All Look and Feel rendering code should reside in the paint method.

        重载：
        update in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paintBorder

        public void paintBorder(SynthContext context,
               Graphics g,
               int x,
               int y,
               int w,
               int h)
        Paints the border. The method is never called, because the JViewport class does not support a border. This implementation does nothing.
        指定者：
        paintBorder in interface SynthUI
        参数：
        context - a component context
        g - the Graphics to paint on
        x - the X coordinate
        y - the Y coordinate
        w - width of the border
        h - height of the border

      • paint

        public void paint(Graphics g,
         JComponent c)
        Paints the specified component according to the Look and Feel.

        This method is not used by Synth Look and Feel. Painting is handled by the paint(SynthContext,Graphics) method.

        重载：
        paint in class ComponentUI
        参数：
        g - the Graphics object used for painting
        c - the component being painted
        另请参见：
        paint(SynthContext,Graphics)

      • paint

        protected void paint(SynthContext context,
         Graphics g)
        Paints the specified component. This implementation does nothing.
        参数：
        context - context for the component being painted
        g - the Graphics object used for painting
        另请参见：
        update(Graphics,JComponent)

      • propertyChange

        public void propertyChange(PropertyChangeEvent e)
        从接口复制的描述： PropertyChangeListener
        This method gets called when a bound property is changed.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        e - A PropertyChangeEvent object describing the event source and the property that has changed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b


Uses of Package javax.swing.plaf.synth

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.plaf.synth

  • Packages that use javax.swing.plaf.synth
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
  • Classes in javax.swing.plaf.synth used by javax.swing.plaf.nimbus
    类与描述
    ColorType
    A typesafe enumeration of colors that can be fetched from a style.
    Region
    A distinct rendering area of a Swing component.
    SynthContext
    An immutable transient object containing contextual information about a Region.
    SynthLookAndFeel
    SynthLookAndFeel provides the basis for creating a customized look and feel.
    SynthPainter
    SynthPainter is used for painting portions of JComponents.
    SynthStyle
    SynthStyle is a set of style properties.
  • Classes in javax.swing.plaf.synth used by javax.swing.plaf.synth
    类与描述
    ColorType
    A typesafe enumeration of colors that can be fetched from a style.
    Region
    A distinct rendering area of a Swing component.
    SynthButtonUI
    Provides the Synth L&F UI delegate for JButton.
    SynthConstants
    Constants used by Synth.
    SynthContext
    An immutable transient object containing contextual information about a Region.
    SynthEditorPaneUI
    Provides the Synth L&F UI delegate for JEditorPane.
    SynthGraphicsUtils
    Wrapper for primitive graphics calls.
    SynthMenuItemUI
    Provides the Synth L&F UI delegate for JMenuItem.
    SynthPainter
    SynthPainter is used for painting portions of JComponents.
    SynthRadioButtonUI
    Provides the Synth L&F UI delegate for JRadioButton.
    SynthStyle
    SynthStyle is a set of style properties.
    SynthStyleFactory
    Factory used for obtaining SynthStyles.
    SynthTextFieldUI
    Provides the Synth L&F UI delegate for JTextField.
    SynthToggleButtonUI
    Provides the Synth L&F UI delegate for JToggleButton.
    SynthUI
    SynthUI is used to fetch the SynthContext for a particular Component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mvlihChpoeee/v//c>nn"jst


Uses of Class javax.swing.plaf.synth.ColorType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.ColorType

  • Packages that use ColorType
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of ColorType in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus with parameters of type ColorType
      修饰符与类型 | 方法与描述
      protected Color | NimbusStyle.getColorForState(SynthContext ctx, ColorType type)

    • Uses of ColorType in javax.swing.plaf.synth

      Fields in javax.swing.plaf.synth declared as ColorType
      修饰符与类型 字段与描述
      static ColorType ColorType.BACKGROUND
      ColorType for the background of a region.
      static ColorType ColorType.FOCUS
      ColorType for the focus.
      static ColorType ColorType.FOREGROUND
      ColorType for the foreground of a region.
      static ColorType ColorType.TEXT_BACKGROUND
      ColorType for the background of a region.
      static ColorType ColorType.TEXT_FOREGROUND
      ColorType for the foreground of a region.
      Methods in javax.swing.plaf.synth with parameters of type ColorType
      修饰符与类型 方法与描述
      Color SynthStyle.getColor(SynthContext context, ColorType type)
      Returns the color for the specified state.
      protected abstract Color SynthStyle.getColorForState(SynthContext context, ColorType type)
      Returns the color for the specified state.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

J oiu


Uses of Class javax.swing.plaf.synth.Region

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.Region

  • Packages that use Region
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of Region in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus with parameters of type Region
      修饰符与类型 方法与描述
      static NimbusStyle NimbusLookAndFeel.getStyle(JComponent c, Region r)
      Gets the style associated with the given component and region.
      void NimbusLookAndFeel.register(Region region, String prefix)
      Registers a third party component with the NimbusLookAndFeel.

    • Uses of Region in javax.swing.plaf.synth

      Fields in javax.swing.plaf.synth declared as Region
      修饰符与类型 字段与描述
      static Region Region.ARROW_BUTTON
      ArrowButton's are special types of buttons that also render a directional indicator, typically an arrow.
      static Region Region.BUTTON
      Button region.
      static Region Region.CHECK_BOX
      CheckBox region.
      static Region Region.CHECK_BOX_MENU_ITEM
      CheckBoxMenuItem region.
      static Region Region.COLOR_CHOOSER
      ColorChooser region.
      static Region Region.COMBO_BOX
      ComboBox region.
      static Region Region.DESKTOP_ICON
      DesktopIcon region.
      static Region Region.DESKTOP_PANE
      DesktopPane region.
      static Region Region.EDITOR_PANE
      EditorPane region.
      static Region Region.FILE_CHOOSER
      FileChooser region.
      static Region Region.FORMATTED_TEXT_FIELD
      FormattedTextField region.
      static Region Region.INTERNAL_FRAME
      InternalFrame region.
      static Region Region.INTERNAL_FRAME_TITLE_PANE
      TitlePane of an InternalFrame.
      static Region Region.LABEL
      Label region.
      static Region Region.LIST
      List region.
      static Region Region.MENU
      Menu region.
      static Region Region.MENU_BAR
      MenuBar region.
      static Region Region.MENU_ITEM
      MenuItem region.
      static Region Region.MENU_ITEM_ACCELERATOR
      Accelerator region of a MenuItem.
      static Region Region.OPTION_PANE
      OptionPane region.
      static Region Region.PANEL
      Panel region.
      static Region Region.PASSWORD_FIELD
      PasswordField region.
      static Region Region.POPUP_MENU
      PopupMenu region.
      static Region Region.POPUP_MENU_SEPARATOR
      PopupMenuSeparator region.
      static Region Region.PROGRESS_BAR
      ProgressBar region.
      static Region Region.RADIO_BUTTON
      RadioButton region.
      static Region Region.RADIO_BUTTON_MENU_ITEM
      RegionButtonMenuItem region.
      static Region Region.ROOT_PANE
      RootPane region.
      static Region Region.SCROLL_BAR
      ScrollBar region.
      static Region Region.SCROLL_BAR_THUMB
      Thumb of the ScrollBar.
      static Region Region.SCROLL_BAR_TRACK
      Track of the ScrollBar.
      static Region Region.SCROLL_PANE
      ScrollPane region.
      static Region Region.SEPARATOR
      Separator region.
      static Region Region.SLIDER
      Slider region.
      static Region Region.SLIDER_THUMB
      Thumb of the Slider.
      static Region Region.SLIDER_TRACK
      Track of the Slider.
      static Region Region.SPINNER
      Spinner region.
      static Region Region.SPLIT_PANE
      SplitPane region.
      static Region Region.SPLIT_PANE_DIVIDER
      Divider of the SplitPane.
      static Region Region.TABBED_PANE
      TabbedPane region.
      static Region Region.TABBED_PANE_CONTENT
      Region of a TabbedPane containing the content.
      static Region Region.TABBED_PANE_TAB
      Region of a TabbedPane for one tab.
      static Region Region.TABBED_PANE_TAB_AREA
      Region of a TabbedPane containing the tabs.
      static Region Region.TABLE
      Table region.
      static Region Region.TABLE_HEADER
      TableHeader region.
      static Region Region.TEXT_AREA
      TextArea region.
      static Region Region.TEXT_FIELD
      TextField region.
      static Region Region.TEXT_PANE
      TextPane region.
      static Region Region.TOGGLE_BUTTON
      ToggleButton region.
      static Region Region.TOOL_BAR
      ToolBar region.
      static Region Region.TOOL_BAR_CONTENT
      Region of the ToolBar containing the content.
      static Region Region.TOOL_BAR_DRAG_WINDOW
      Region for the Window containing the ToolBar.
      static Region Region.TOOL_BAR_SEPARATOR
      ToolBar separator region.
      static Region Region.TOOL_TIP
      ToolTip region.
      static Region Region.TREE
      Tree region.
      static Region Region.TREE_CELL
      Region of the Tree for one cell.
      static Region Region.VIEWPORT
      Viewport region.
      Methods in javax.swing.plaf.synth that return Region
      修饰符与类型 方法与描述
      Region SynthContext.getRegion()
      Returns the Region identifying this state.
      static Region SynthLookAndFeel.getRegion(JComponent c)
      Returns the Region for the JComponent c.
      Methods in javax.swing.plaf.synth with parameters of type Region
      修饰符与类型 方法与描述
      abstract SynthStyle SynthStyleFactory.getStyle(JComponent c, Region id)
      Returns the style for the specified Component.
      static SynthStyle SynthLookAndFeel.getStyle(JComponent c, Region region)
      Gets a SynthStyle for the specified region of the specified component.
      Constructors in javax.swing.plaf.synth with parameters of type Region
      构造方法与描述
      SynthContext(JComponent component, Region region, SynthStyle style, int state)
      Creates a SynthContext with the specified values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.synth.SynthButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthButtonUI

  • Packages that use SynthButtonUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthButtonUI in javax.swing.plaf.synth

      Subclasses of SynthButtonUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tFir"=ccca>sseCb>oC=


Uses of Class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthCheckBoxMenuItemUI

No usage of javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j


Uses of Class javax.swing.plaf.synth.SynthCheckBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthCheckBoxUI

No usage of javax.swing.plaf.synth.SynthCheckBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sstＨ�/�o>


Uses of Class javax.swing.plaf.synth.SynthColorChooserUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthColorChooserUI

No usage of javax.swing.plaf.synth.SynthColorChooserUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s-moitbis=s-&.//>


Uses of Class javax.swing.plaf.synth.SynthComboBoxUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthComboBoxUI

No usage of javax.swing.plaf.synth.SynthComboBoxUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/sd


Uses of Class javax.swing.plaf.synth.SynthContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthContext

  • Packages that use SynthContext
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthContext in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus with parameters of type SynthContext
      修饰符与类型 | 方法与描述
      Object | NimbusStyle.get(SynthContext ctx, Object key)
      Painter NimbusStyle.getBackgroundPainter(SynthContext ctx)
      Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext.
      Painter NimbusStyle.getBorderPainter(SynthContext ctx)
      Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext.
      protected Color | NimbusStyle.getColorForState(SynthContext ctx, ColorType type)
      protected Font | NimbusStyle.getFontForState(SynthContext ctx)
      Painter NimbusStyle.getForegroundPainter(SynthContext ctx)
      Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext.
      Insets | NimbusStyle.getInsets(SynthContext ctx, Insets in)
      SynthPainter | NimbusStyle.getPainter(SynthContext ctx)
      void | NimbusStyle.installDefaults(SynthContext ctx)
      boolean | NimbusStyle.isOpaque(SynthContext ctx)

    • Uses of SynthContext in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return SynthContext
      修饰符与类型 | 方法与描述
      SynthContext | SynthViewportUI.getContext(JComponent c)
      SynthContext | SynthTreeUI.getContext(JComponent c)
      SynthContext | SynthToolTipUI.getContext(JComponent c)
      SynthContext | SynthToolBarUI.getContext(JComponent c)
      SynthContext | SynthTextAreaUI.getContext(JComponent c)
      SynthContext | SynthTableHeaderUI.getContext(JComponent c)
      SynthContext | SynthTableUI.getContext(JComponent c)
      SynthContext | SynthTabbedPaneUI.getContext(JComponent c)
      SynthContext | SynthSplitPaneUI.getContext(JComponent c)
      SynthContext | SynthSpinnerUI.getContext(JComponent c)
      SynthContext | SynthSliderUI.getContext(JComponent c)
      SynthContext | SynthScrollPaneUI.getContext(JComponent c)
      SynthContext | SynthScrollBarUI.getContext(JComponent c)
      SynthContext | SynthRootPaneUI.getContext(JComponent c)
      SynthContext | SynthProgressBarUI.getContext(JComponent c)
      SynthContext | SynthPopupMenuUI.getContext(JComponent c)
      SynthContext | SynthSeparatorUI.getContext(JComponent c)
      SynthContext | SynthPanelUI.getContext(JComponent c)
      SynthContext | SynthOptionPaneUI.getContext(JComponent c)
      SynthContext | SynthMenuUI.getContext(JComponent c)
      SynthContext | SynthMenuBarUI.getContext(JComponent c)
      SynthContext | SynthListUI.getContext(JComponent c)
      SynthContext | SynthInternalFrameUI.getContext(JComponent c)
      SynthContext | SynthTextFieldUI.getContext(JComponent c)
      SynthContext | SynthEditorPaneUI.getContext(JComponent c)
      SynthContext | SynthDesktopIconUI.getContext(JComponent c)
      SynthContext | SynthDesktopPaneUI.getContext(JComponent c)
      SynthContext | SynthComboBoxUI.getContext(JComponent c)
      SynthContext | SynthLabelUI.getContext(JComponent c)
      SynthContext | SynthColorChooserUI.getContext(JComponent c)
      SynthContext | SynthMenuItemUI.getContext(JComponent c)
      SynthContext | SynthButtonUI.getContext(JComponent c)
      SynthContext SynthUI.getContext(JComponent c)
      Returns the Context for the specified component.
      Methods in javax.swing.plaf.synth with parameters of type SynthContext
      修饰符与类型 | 方法与描述
      int SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text)
      Returns the size of the passed in string.
      void SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)
      Draws a line between the two end points.
      void SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)
      Draws a line between the two end points.
      Object SynthStyle.get(SynthContext context, Object key)
      Getter for a region specific style property.
      boolean SynthStyle.getBoolean(SynthContext context, Object key, boolean defaultValue)
      Convenience method to get a specific style property whose value is an Boolean.
      Color SynthStyle.getColor(SynthContext context, ColorType type)
      Returns the color for the specified state.
      protected abstract Color SynthStyle.getColorForState(SynthContext context, ColorType type)
      Returns the color for the specified state.
      Font SynthStyle.getFont(SynthContext context)
      Returns the Font for the specified state.
      protected abstract Font SynthStyle.getFontForState(SynthContext context)
      Returns the font for the specified state.
      SynthGraphicsUtils SynthStyle.getGraphicsUtils(SynthContext context)
      Returns the SynthGraphicUtils for the specified context.
      Icon SynthStyle.getIcon(SynthContext context, Object key)
      Convenience method to get a specific style property whose value is an Icon.
      Insets SynthStyle.getInsets(SynthContext context, Insets insets)
      Returns the Insets that are used to calculate sizing information.
      int SynthStyle.getInt(SynthContext context, Object key, int defaultValue)
      Convenience method to get a specific style property whose value is a Number.
      int SynthGraphicsUtils.getMaximumCharHeight(SynthContext context)
      Returns the maximum height of the the Font from the passed in SynthContext.
      Dimension SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the maximum size needed to properly render an icon and text.
      Dimension SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the minimum size needed to properly render an icon and text.
      SynthPainter SynthStyle.getPainter(SynthContext context)
      Returns the SynthPainter that will be used for painting.
      Dimension SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
      Returns the preferred size needed to properly render an icon and text.
      String SynthStyle.getString(SynthContext context, Object key, String defaultValue)
      Convenience method to get a specific style property whose value is a String.
      void SynthStyle.installDefaults(SynthContext context)
      Installs the necessary state from this Style on the JComponent from context.
      boolean SynthStyle.isOpaque(SynthContext context)
      Returns true if the region is opaque.
      String SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
      Lays out text and an icon returning, by reference, the location to place the icon and text.
      protected void SynthViewportUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthTreeUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthToolTipUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthToolBarUI.paint(SynthContext context, Graphics g)
      Paints the toolbar.
      protected void SynthTextAreaUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthTableHeaderUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthTableUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthTabbedPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthSplitPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthSpinnerUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthSliderUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthScrollPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthScrollBarUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthRootPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthProgressBarUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthPopupMenuUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthSeparatorUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthPanelUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthOptionPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthMenuUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthMenuBarUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthInternalFrameUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthTextFieldUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthEditorPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthDesktopIconUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthDesktopPaneUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthComboBoxUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthLabelUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthColorChooserUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthMenuItemUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      protected void SynthButtonUI.paint(SynthContext context, Graphics g)
      Paints the specified component.
      void SynthPainter.paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an arrow button.
      void SynthPainter.paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an arrow button.
      void SynthPainter.paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction)
      Paints the foreground of an arrow button.
      void SynthViewportUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void | SynthTreeUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthToolTipUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthToolBarUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTextPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTextAreaUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTableHeaderUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTableUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTabbedPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthSplitPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthSpinnerUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthSliderUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthScrollPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthScrollBarUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthRootPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthRadioButtonMenuItemUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthProgressBarUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthPopupMenuUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthPasswordFieldUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthSeparatorUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthPanelUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthOptionPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthMenuUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthMenuBarUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthListUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthInternalFrameUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthTextFieldUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthFormattedTextFieldUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthEditorPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthDesktopIconUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthDesktopPaneUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthComboBoxUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthLabelUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthColorChooserUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthMenuItemUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthCheckBoxMenuItemUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthToggleButtonUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthRadioButtonUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthCheckBoxUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void | SynthButtonUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      void SynthUI.paintBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border.
      void SynthPainter.paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a button.
      void SynthPainter.paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a button.
      void SynthPainter.paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a check box.
      void SynthPainter.paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a check box.
      void SynthPainter.paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a check box menu item.
      void SynthPainter.paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a check box menu item.
      void SynthPainter.paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a color chooser.
      void SynthPainter.paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a color chooser.
      void SynthPainter.paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a combo box.
      void SynthPainter.paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a combo box.
      protected void SynthToolBarUI.paintContent(SynthContext context, Graphics g, Rectangle bounds)
      Paints the toolbar content.
      void SynthPainter.paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop icon.
      void SynthPainter.paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a desktop icon.
      void SynthPainter.paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop pane.
      void SynthPainter.paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a desktop pane.
      void SynthPainter.paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an editor pane.
      void SynthPainter.paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an editor pane.
      void SynthPainter.paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a file chooser.
      void SynthPainter.paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a file chooser.
      void SynthPainter.paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a formatted text field.
      void SynthPainter.paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a formatted text field.
      void SynthPainter.paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an internal frame.
      void SynthPainter.paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an internal frame.
      void SynthPainter.paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an internal frame title pane.
      void SynthPainter.paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an internal frame title pane.
      void SynthPainter.paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a label.
      void SynthPainter.paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a label.
      void SynthPainter.paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a list.
      void SynthPainter.paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a list.
      void SynthPainter.paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu.
      void SynthPainter.paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu bar.
      void SynthPainter.paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu bar.
      void SynthPainter.paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu.
      void SynthPainter.paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a menu item.
      void SynthPainter.paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a menu item.
      void SynthPainter.paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of an option pane.
      void SynthPainter.paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of an option pane.
      void SynthPainter.paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a panel.
      void SynthPainter.paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a panel.
      void SynthPainter.paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a password field.
      void SynthPainter.paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a password field.
      void SynthPainter.paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a popup menu.
      void SynthPainter.paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a popup menu.
      void SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a progress bar.
      void SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a progress bar.
      void SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a progress bar.
      void SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a progress bar.
      void SynthPainter.paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of a progress bar.
      void SynthPainter.paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a radio button.
      void SynthPainter.paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a radio button.
      void SynthPainter.paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a radio button menu item.
      void SynthPainter.paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a radio button menu item.
      void SynthPainter.paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a root pane.
      void SynthPainter.paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a root pane.
      void SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a scrollbar.
      void SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a scrollbar.
      void SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a scrollbar.
      void SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a scrollbar.
      void SynthPainter.paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the thumb of a scrollbar.
      void SynthPainter.paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the thumb of a scrollbar.
      void SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the track of a scrollbar.
      void SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the track of a scrollbar.
      void SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the track of a scrollbar.
      void SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the track of a scrollbar.
      void SynthPainter.paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a scroll pane.
      void SynthPainter.paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a scroll pane.
      void SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a separator.
      void SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a separator.
      void SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a separator.
      void SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a separator.
      void SynthPainter.paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of a separator.
      void SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a slider.
      void SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a slider.
      void SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a slider.
      void SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a slider.
      void SynthPainter.paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the thumb of a slider.
      void SynthPainter.paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the thumb of a slider.
      void SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the track of a slider.
      void SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the track of a slider.
      void SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the track of a slider.
      void SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the track of a slider.
      void SynthPainter.paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a spinner.
      void SynthPainter.paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a spinner.
      void SynthPainter.paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a split pane.
      void SynthPainter.paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a split pane.
      void SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the divider of a split pane.
      void SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the divider of a split pane.
      void SynthPainter.paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the foreground of the divider of a split pane.
      void SynthPainter.paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the divider, when the user is dragging the divider, of a split pane.
      void SynthPainter.paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tabbed pane.
      void SynthPainter.paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tabbed pane.
      void SynthPainter.paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the area that contains the content of the selected tab of a tabbed pane.
      void SynthPainter.paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the area that contains the content of the selected tab of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the area behind the tabs of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the area behind the tabs of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the area behind the tabs of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the area behind the tabs of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      Paints the background of a tab of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      Paints the background of a tab of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex)
      Paints the border of a tab of a tabbed pane.
      void SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation)
      Paints the border of a tab of a tabbed pane.
      void SynthPainter.paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a table.
      void SynthPainter.paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a table.
      void SynthPainter.paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the header of a table.
      void SynthPainter.paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the header of a table.
      protected void SynthProgressBarUI.paintText(SynthContext context, Graphics g, String title)
      Paints the component's text.
      void SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
      Paints an icon and text.
      void SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)
      Paints text at the specified location.
      void SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
      Paints text at the specified location.
      void SynthPainter.paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text area.
      void SynthPainter.paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text area.
      void SynthPainter.paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text field.
      void SynthPainter.paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text field.
      void SynthPainter.paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a text pane.
      void SynthPainter.paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a text pane.
      protected void SynthSliderUI.paintThumb(SynthContext context, Graphics g, Rectangle thumbBounds)
      Paints the slider thumb.
      protected void SynthScrollBarUI.paintThumb(SynthContext context, Graphics g, Rectangle thumbBounds)
      Paints the scrollbar thumb.
      void SynthPainter.paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a toggle button.
      void SynthPainter.paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a toggle button.
      void SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tool bar.
      void SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of a tool bar.
      void SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tool bar.
      void SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of a tool bar.
      void SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the tool bar's content area.
      void SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the tool bar's content area.
      void SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the content area of a tool bar.
      void SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the content area of a tool bar.
      void SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the window containing the tool bar when it has been detached from its primary frame.
      void SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the background of the window containing the tool bar when it has been detached from its primary frame.
      void SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
      void SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation)
      Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
      void SynthPainter.paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tool tip.
      void SynthPainter.paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tool tip.
      protected void SynthSliderUI.paintTrack(SynthContext context, Graphics g, Rectangle trackBounds)
      Paints the slider track.
      protected void SynthScrollBarUI.paintTrack(SynthContext context, Graphics g, Rectangle trackBounds)
      Paints the scrollbar track.
      void SynthPainter.paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of a tree.
      void SynthPainter.paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a tree.
      void SynthPainter.paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the row containing a cell in a tree.
      void SynthPainter.paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of the row containing a cell in a tree.
      void SynthPainter.paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the focus indicator for a cell in a tree when it has focus.
      void SynthPainter.paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the background of the viewport.
      void SynthPainter.paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h)
      Paints the border of a viewport.
      void SynthStyle.uninstallDefaults(SynthContext context)
      Uninstalls any state that this style installed on the JComponent from context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.synth.SynthDesktopIconUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthDesktopIconUI

No usage of javax.swing.plaf.synth.SynthDesktopIconUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/peg">.allljlmmbt ;l


Uses of Class javax.swing.plaf.synth.SynthDesktopPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthDesktopPaneUI

No usage of javax.swing.plaf.synth.SynthDesktopPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ral葊4@mblt


Uses of Class javax.swing.plaf.synth.SynthEditorPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthEditorPaneUI

  • Packages that use SynthEditorPaneUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthEditorPaneUI in javax.swing.plaf.synth

      Subclasses of SynthEditorPaneUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oewiipCdri


Uses of Class javax.swing.plaf.synth.SynthFormattedTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthFormattedTextFieldUI

No usage of javax.swing.plaf.synth.SynthFormattedTextFieldUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lp"UrPadEiiins//a.�"w


Uses of Class javax.swing.plaf.synth.SynthGraphicsUtils

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthGraphicsUtils

  • Packages that use SynthGraphicsUtils
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthGraphicsUtils in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return SynthGraphicsUtils
      修饰符与类型 方法与描述
      SynthGraphicsUtils SynthStyle.getGraphicsUtils(SynthContext context)
      Returns the SynthGraphicUtils for the specified context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.Sfewess irl


Uses of Class javax.swing.plaf.synth.SynthInternalFrameUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthInternalFrameUI

No usage of javax.swing.plaf.synth.SynthInternalFrameUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osmaame<>aaaa" >i


Uses of Class javax.swing.plaf.synth.SynthLabelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthLabelUI

No usage of javax.swing.plaf.synth.SynthLabelUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sstＨ�/�o>


Uses of Class javax.swing.plaf.synth.SynthListUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthListUI

No usage of javax.swing.plaf.synth.SynthListUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>籹t>�>ls�/<热ots/�


Uses of Class javax.swing.plaf.synth.SynthLookAndFeel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthLookAndFeel

  • Packages that use SynthLookAndFeel
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.

    • Uses of SynthLookAndFeel in javax.swing.plaf.nimbus

      Subclasses of SynthLookAndFeel in javax.swing.plaf.nimbus
      修饰符与类型 类与描述
      class  NimbusLookAndFeel
      The NimbusLookAndFeel class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ern ay# o繿 o黣vadlecmi


Uses of Class javax.swing.plaf.synth.SynthMenuBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthMenuBarUI

No usage of javax.swing.plaf.synth.SynthMenuBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/fle软糾tlllyeffrle/"


Uses of Class javax.swing.plaf.synth.SynthMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthMenuItemUI

  • Packages that use SynthMenuItemUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthMenuItemUI in javax.swing.plaf.synth

      Subclasses of SynthMenuItemUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

P&i1wan"eynirlo /t/.


Uses of Class javax.swing.plaf.synth.SynthMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthMenuUI

No usage of javax.swing.plaf.synth.SynthMenuUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atse>


Uses of Class javax.swing.plaf.synth.SynthOptionPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthOptionPaneUI

No usage of javax.swing.plaf.synth.SynthOptionPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>tti >f"s dhnn薎


Uses of Class javax.swing.plaf.synth.SynthPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthPainter

  • Packages that use SynthPainter
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthPainter in javax.swing.plaf.nimbus

      Methods in javax.swing.plaf.nimbus that return SynthPainter
      修饰符与类型 | 方法与描述
      SynthPainter | NimbusStyle.getPainter(SynthContext ctx)

    • Uses of SynthPainter in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return SynthPainter
      修饰符与类型 方法与描述
      SynthPainter SynthStyle.getPainter(SynthContext context)
      Returns the SynthPainter that will be used for painting.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.aakaBi>"e>tgeav/il=b


Uses of Class javax.swing.plaf.synth.SynthPanelUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthPanelUI

No usage of javax.swing.plaf.synth.SynthPanelUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o-ds/a>etxxxChnnp/hfg


Uses of Class javax.swing.plaf.synth.SynthPasswordFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthPasswordFieldUI

No usage of javax.swing.plaf.synth.SynthPasswordFieldUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.nosio<;;cy"a>ptiC


Uses of Class javax.swing.plaf.synth.SynthPopupMenuUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthPopupMenuUI

No usage of javax.swing.plaf.synth.SynthPopupMenuUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-omotsn>sl><<>g/s�


Uses of Class javax.swing.plaf.synth.SynthProgressBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthProgressBarUI

No usage of javax.swing.plaf.synth.SynthProgressBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthRadioButtonMenuItemUI

No usage of javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jC0ss眗cure


Uses of Class javax.swing.plaf.synth.SynthRadioButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthRadioButtonUI

  • Packages that use SynthRadioButtonUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthRadioButtonUI in javax.swing.plaf.synth

      Subclasses of SynthRadioButtonUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

TaoAuaSc.>gdisc"sl<


Uses of Class javax.swing.plaf.synth.SynthRootPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthRootPaneUI

No usage of javax.swing.plaf.synth.SynthRootPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/ ovig=e"""ivuut e<


Uses of Class javax.swing.plaf.synth.SynthScrollBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthScrollBarUI

No usage of javax.swing.plaf.synth.SynthScrollBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bfcl o" >em颿


Uses of Class javax.swing.plaf.synth.SynthScrollPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthScrollPaneUI

No usage of javax.swing.plaf.synth.SynthScrollPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&t=ee>�>i&w#誽�.


Uses of Class javax.swing.plaf.synth.SynthSeparatorUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthSeparatorUI

No usage of javax.swing.plaf.synth.SynthSeparatorUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>D&t>e>lte>=&>e


Uses of Class javax.swing.plaf.synth.SynthSliderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthSliderUI

No usage of javax.swing.plaf.synth.SynthSliderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>/>slpla.y/


Uses of Class javax.swing.plaf.synth.SynthSpinnerUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthSpinnerUI

No usage of javax.swing.plaf.synth.SynthSpinnerUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

衏nia elF腮� �.


Uses of Class javax.swing.plaf.synth.SynthSplitPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthSplitPaneUI

No usage of javax.swing.plaf.synth.SynthSplitPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>i觮c


Uses of Class javax.swing.plaf.synth.SynthStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthStyle

  • Packages that use SynthStyle
    软件包 描述
    javax.swing.plaf.nimbus
    Provides user interface objects built according to the cross-platform Nimbus look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthStyle in javax.swing.plaf.nimbus

      Subclasses of SynthStyle in javax.swing.plaf.nimbus
      修饰符与类型 类与描述
      class  NimbusStyle
      A SynthStyle implementation used by Nimbus.

    • Uses of SynthStyle in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return SynthStyle
      修饰符与类型 方法与描述
      SynthStyle SynthContext.getStyle()
      Returns the style associated with this Region.
      abstract SynthStyle SynthStyleFactory.getStyle(JComponent c, Region id)
      Returns the style for the specified Component.
      static SynthStyle SynthLookAndFeel.getStyle(JComponent c, Region region)
      Gets a SynthStyle for the specified region of the specified component.
      Constructors in javax.swing.plaf.synth with parameters of type SynthStyle
      构造方法与描述
      SynthContext(JComponent component, Region region, SynthStyle style, int state)
      Creates a SynthContext with the specified values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=s>/jsas/dp


Uses of Class javax.swing.plaf.synth.SynthStyleFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthStyleFactory

  • Packages that use SynthStyleFactory
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthStyleFactory in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return SynthStyleFactory
      修饰符与类型 方法与描述
      static SynthStyleFactory SynthLookAndFeel.getStyleFactory()
      Returns the current SynthStyleFactory.
      Methods in javax.swing.plaf.synth with parameters of type SynthStyleFactory
      修饰符与类型 方法与描述
      static void SynthLookAndFeel.setStyleFactory(SynthStyleFactory cache)
      Sets the SynthStyleFactory that the UI classes provided by synth will use to obtain a SynthStyle.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(n<>extChoooy ..Jxiawojn.


Uses of Class javax.swing.plaf.synth.SynthTabbedPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTabbedPaneUI

No usage of javax.swing.plaf.synth.SynthTabbedPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nng//....///.arr-phms


Uses of Class javax.swing.plaf.synth.SynthTableHeaderUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTableHeaderUI

No usage of javax.swing.plaf.synth.SynthTableHeaderUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ts>">>餴|s


Uses of Class javax.swing.plaf.synth.SynthTableUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTableUI

No usage of javax.swing.plaf.synth.SynthTableUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>sRo>T>g莞be3&-a癰b


Uses of Class javax.swing.plaf.synth.SynthTextAreaUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTextAreaUI

No usage of javax.swing.plaf.synth.SynthTextAreaUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"mNstpka>lss"=rlbd


Uses of Class javax.swing.plaf.synth.SynthTextFieldUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTextFieldUI

  • Packages that use SynthTextFieldUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthTextFieldUI in javax.swing.plaf.synth

      Subclasses of SynthTextFieldUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ans"a Tiru.asawts.e╰�


Uses of Class javax.swing.plaf.synth.SynthTextPaneUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTextPaneUI

No usage of javax.swing.plaf.synth.SynthTextPaneUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

UPISs tvoiii>=>> =yp<


Uses of Class javax.swing.plaf.synth.SynthToggleButtonUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthToggleButtonUI

  • Packages that use SynthToggleButtonUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthToggleButtonUI in javax.swing.plaf.synth

      Subclasses of SynthToggleButtonUI in javax.swing.plaf.synth
      修饰符与类型 类与描述
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l;sFdsoi/l"lg粪oae


Uses of Class javax.swing.plaf.synth.SynthToolBarUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthToolBarUI

No usage of javax.swing.plaf.synth.SynthToolBarUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hd srovkc"""b <


Uses of Class javax.swing.plaf.synth.SynthToolTipUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthToolTipUI

No usage of javax.swing.plaf.synth.SynthToolTipUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.钾@"cl鰔�<� 檒t


Uses of Class javax.swing.plaf.synth.SynthTreeUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthTreeUI

No usage of javax.swing.plaf.synth.SynthTreeUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla>y/


Uses of Class javax.swing.plaf.synth.SynthViewportUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.plaf.synth.SynthViewportUI

No usage of javax.swing.plaf.synth.SynthViewportUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

M>e>>


Uses of Interface javax.swing.plaf.synth.SynthConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.plaf.synth.SynthConstants

  • Packages that use SynthConstants
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthConstants in javax.swing.plaf.synth

      Subinterfaces of SynthConstants in javax.swing.plaf.synth
      修饰符与类型 Interface and Description
      interface  SynthUI
      SynthUI is used to fetch the SynthContext for a particular Component.
      Classes in javax.swing.plaf.synth that implement SynthConstants
      修饰符与类型 类与描述
      class  SynthButtonUI
      Provides the Synth L&F UI delegate for JButton.
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthColorChooserUI
      Provides the Synth L&F UI delegate for JColorChooser.
      class  SynthComboBoxUI
      Provides the Synth L&F UI delegate for JComboBox.
      class  SynthDesktopIconUI
      Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
      class  SynthDesktopPaneUI
      Provides the Synth L&F UI delegate for JDesktopPane.
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthInternalFrameUI
      Provides the Synth L&F UI delegate for JInternalFrame.
      class  SynthLabelUI
      Provides the Synth L&F UI delegate for JLabel.
      class  SynthListUI
      Provides the Synth L&F UI delegate for JList.
      class  SynthMenuBarUI
      Provides the Synth L&F UI delegate for JMenuBar.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthOptionPaneUI
      Provides the Synth L&F UI delegate for JOptionPane.
      class  SynthPanelUI
      Provides the Synth L&F UI delegate for JPanel.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthPopupMenuUI
      Provides the Synth L&F UI delegate for JPopupMenu.
      class  SynthProgressBarUI
      Provides the Synth L&F UI delegate for JProgressBar.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthRootPaneUI
      Provides the Synth L&F UI delegate for JRootPane.
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
      class  SynthSeparatorUI
      Provides the Synth L&F UI delegate for JSeparator.
      class  SynthSliderUI
      Provides the Synth L&F UI delegate for JSlider.
      class  SynthSpinnerUI
      Provides the Synth L&F UI delegate for JSpinner.
      class  SynthSplitPaneUI
      Provides the Synth L&F UI delegate for JSplitPane.
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
      class  SynthTableHeaderUI
      Provides the Synth L&F UI delegate for JTableHeader.
      class  SynthTableUI
      Provides the Synth L&F UI delegate for JTable.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.
      class  SynthToolTipUI
      Provides the Synth L&F UI delegate for JToolTip.
      class  SynthTreeUI
      Provides the Synth L&F UI delegate for JTree.
      class  SynthViewportUI
      Provides the Synth L&F UI delegate for JViewport.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ln<..ej.osldb o


Uses of Interface javax.swing.plaf.synth.SynthUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.plaf.synth.SynthUI

  • Packages that use SynthUI
    软件包 描述
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.

    • Uses of SynthUI in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement SynthUI
      修饰符与类型 类与描述
      class  SynthButtonUI
      Provides the Synth L&F UI delegate for JButton.
      class  SynthCheckBoxMenuItemUI
      Provides the Synth L&F UI delegate for JCheckBoxMenuItem.
      class  SynthCheckBoxUI
      Provides the Synth L&F UI delegate for JCheckBox.
      class  SynthColorChooserUI
      Provides the Synth L&F UI delegate for JColorChooser.
      class  SynthComboBoxUI
      Provides the Synth L&F UI delegate for JComboBox.
      class  SynthDesktopIconUI
      Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.
      class  SynthDesktopPaneUI
      Provides the Synth L&F UI delegate for JDesktopPane.
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthInternalFrameUI
      Provides the Synth L&F UI delegate for JInternalFrame.
      class  SynthLabelUI
      Provides the Synth L&F UI delegate for JLabel.
      class  SynthListUI
      Provides the Synth L&F UI delegate for JList.
      class  SynthMenuBarUI
      Provides the Synth L&F UI delegate for JMenuBar.
      class  SynthMenuItemUI
      Provides the Synth L&F UI delegate for JMenuItem.
      class  SynthMenuUI
      Provides the Synth L&F UI delegate for JMenu.
      class  SynthOptionPaneUI
      Provides the Synth L&F UI delegate for JOptionPane.
      class  SynthPanelUI
      Provides the Synth L&F UI delegate for JPanel.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthPopupMenuUI
      Provides the Synth L&F UI delegate for JPopupMenu.
      class  SynthProgressBarUI
      Provides the Synth L&F UI delegate for JProgressBar.
      class  SynthRadioButtonMenuItemUI
      Provides the Synth L&F UI delegate for JRadioButtonMenuItem.
      class  SynthRadioButtonUI
      Provides the Synth L&F UI delegate for JRadioButton.
      class  SynthRootPaneUI
      Provides the Synth L&F UI delegate for JRootPane.
      class  SynthScrollBarUI
      Provides the Synth L&F UI delegate for JScrollBar.
      class  SynthScrollPaneUI
      Provides the Synth L&F UI delegate for JScrollPane.
      class  SynthSeparatorUI
      Provides the Synth L&F UI delegate for JSeparator.
      class  SynthSliderUI
      Provides the Synth L&F UI delegate for JSlider.
      class  SynthSpinnerUI
      Provides the Synth L&F UI delegate for JSpinner.
      class  SynthSplitPaneUI
      Provides the Synth L&F UI delegate for JSplitPane.
      class  SynthTabbedPaneUI
      Provides the Synth L&F UI delegate for JTabbedPane.
      class  SynthTableHeaderUI
      Provides the Synth L&F UI delegate for JTableHeader.
      class  SynthTableUI
      Provides the Synth L&F UI delegate for JTable.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.
      class  SynthToggleButtonUI
      Provides the Synth L&F UI delegate for JToggleButton.
      class  SynthToolBarUI
      Provides the Synth L&F UI delegate for JToolBar.
      class  SynthToolTipUI
      Provides the Synth L&F UI delegate for JToolTip.
      class  SynthTreeUI
      Provides the Synth L&F UI delegate for JTree.
      class  SynthViewportUI
      Provides the Synth L&F UI delegate for JViewport.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

avbis7i"hoLcnd


Component Specific Properties

The look, and to some degree the feel of Synth can be customized by way of component specific properties. These properties are accessed from SynthStyle#get. Refer to synth file format for examples of how to specify these properties in a synth configuration file.

This file specifies the expected class type each of the values are to take. The behavior of supplying the wrong type is unspecified: typically a ClassCastException is thrown, but it is implementation specific.

ArrowButton

ArrowButton is a special type of JButton that renders an arrow. ArrowButton is typically not created directly, rather some of the Components will create it to render a button with an arrow. The components that make use of ArrowButton are: JComboBox, JScrollBar and JSplitPane (for the buttons on the divider). In addition to the Button properties, ArrowButton supports the following propeties:

ArrowButton Specific Properties
Property | Expected Type | Default Value | Description
ArrowButton.size | Integer | 16 | Preferred size of the arrow button.

JButton

JButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JButton supports the following property:

JButton Specific Properties
Property | Expected Type | Default Value | Description
Button.defaultButtonFollowsFocus | Boolean | true | Whether or not the default JButton should change to the button that is receiving focus.

JCheckBox

JCheckBox paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JCheckBox supports the following property:

JCheckBox Specific Properties
Property | Expected Type | Default Value | Description
CheckBox.icon | Icon | null | Icon used to render the check.

JComboBox

JComboBox is a composite component that consists of the following child Components:

Name | Type | Description
ComboBox.arrowButton | SynthArrowButton | Renders the drop down indicator.
ComboBox.list | JList | JList used to render the values.
ComboBox.listRenderer | Component | The renderer used for the JComboBox's JList.
ComboBox.popup | JPopupMenu | JPopupMenu used to show the ComboBox.list of the JComboBox.
ComboBox.renderer | Component | The renderer used for the JComboBox. This is ONLY set if the renderer is a UIResource.
ComboBox.scrollPane | JScrollPane | JScrollPane containing the JList.
ComboBox.textField | JTextField | The editor.

JComboBox Specific Properties
Property | Expected Type | Default Value | Description
ComboBox.showPopupOnNavigation | Boolean | false | Whether or not the JPopupMenu should appear when navigating with the keyboard.

JFileChooser

JFileChooser Specific Properties
Property | Expected Type | Default Value | 描述
FileChooser.cancelIcon | Icon | null | Icon displayed on cancel button of the file chooser.
FileChooser.okIcon | Icon | null | Icon displayed on the ok button of the file chooser.
FileView.directoryIcon | Icon | null | Icon used for directories.
FileView.fileIcon | Icon | null | Icon used for files.
FileView.computerIcon | Icon | null | Icon used for directories that represent the computer. Not all platforms will make use of this icon.
FileView.hardDriveIcon | Icon | null | Icon used to represent the root of a hard drive. For example, on Windows this would be used when viewing the C drive.
FileView.floppyDriveIcon | Icon | null | Icon used to represent a floppy disk.
FileChooser.newFolderIcon | Icon | null | Icon used by the button that creates a new folder.
FileChooser.upFolderIcon | Icon | null | Icon used by the button that navigates to the parent folder.
FileChooser.homeFolderIcon | Icon | null | Icon used by the button that navigates to the current user's home directory.
FileChooser.detailsViewIcon | Icon | null | Icon used by the button that toggles the detailed files list view.
FileChooser.listViewIcon | Icon | null | Icon used by the button that toggles the regular files list view, showing only an icon and the name of each file and directory.
FileChooser.viewMenuIcon | Icon | null | Icon used by the button that shows popup menu for selection of a view mode.

JInternalFrame

JInternalFrame Specific Properties
Property | Expected Type | DefaultValue | Description
InternalFrame.icon | Icon | null | Icon drawn representing the system icon of the internal frame. If pressed the system menu will be shown.

JInternalFrameTitlePane

JInternalFrameTitlePane is the control bar located at the top of the internal frame similar to that found in a frame.

JInternalFrameTitlePane Specific Properties
Property | Expected Type | Default Value | Description
InternalFrameTitlePane.maximizeIcon | Icon | null | Icon drawn to indicate the ability to maximize the internal frame.
InternalFrameTitlePane.minimizeIcon | Icon | null | Icon drawn to indicate the ability to restore the internal frame back to its previous state.
InternalFrameTitlePane.iconifyIcon | Icon | null | Icon drawn to indicate the ability to minimize the internal frame.
InternalFrameTitlePane.closeIcon | Icon | null | Icon drawn to indicate the abililty to close the internal frame.
InternalFrameTitlePane.titleSpacing | Integer | 2 | Space between the buttons on the title pane and the title.
InternalFrameTitlePane.buttonSpacing | Integer | 2 | Space between the buttons on the title pane.
InternalFrameTitlePane.maxFrameIconSize | Dimension | 16x16 | Maximum size of the frame icon that will be rendered on the title pane. If the icon is bigger than this size, it will be scaled down.
InternalFrameTitlePane.titleAlignment | leading|trailing|center | leading | Alignment for the title. With a left to right component orientation leading is left and trailing right. With a right to left component orientation leading is right and trailing left.

JList

JList's sets the name of the renderer to List.renderer. JList supports the following properties:

JList Specific Properties
Property | Expected Type | Default Value | Description
List.rendererUseListColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JList's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
List.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
List.cellHeight | Integer | -1 | Cell height of the JList. Is this is -1, setFixedCellHeight is not invoked.

Menu Properties

The Menu classes (JCheckBoxMenuItem, JMenu, JMenuItem, and JRadioButtonMenuItem) all support the same set of properties and behave similarly. Each component consists of two Regions: the region specific to the component and Region.MENU_ITEM_ACCELERATOR. MENU_ITEM_ACCELERATOR is used for painting the accelerator. Both Regions paint text using the TEXT_FOREGROUND ColorType. The following set of properties are supported:

Property | Expected Type | Default Value | Description
prefix.acceleratorDelimiter | String | + | String separator between the description of the modifiers and the key, for example Ctrl <acceleratorDelimiter> X.
prefix.arrowIcon | Icon | null | Icon drawn to the right of the text (or left when the ComponentOrientation is right to left) of the text. This is typically only defined for JMenu.
prefix.checkIcon | Icon | null | Icon drawn to the left of the text (or right when the ComponentOrientation is right to left) of the text. This is typically only defined for JCheckBoxMenuItem and JRadioButtonMenuItem to provide the check or radio button.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JMenuItem. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textIconGap | Integer | 4 | Padding between the icon and text. Refer to the javadoc for javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.

Prefix is one of: CheckBoxMenuItem, Menu, MenuItem, or RadioButtonMenuItem.

JMenu also supports the following properties:

Property | Expected Type | Default Value | Description
Menu.delay | Integer | 200 | Sets the delay before the menu appears.
Menu.shortcutKeys | int[] | KeyEvent.ALT_MASK | Array of the KeyEvent modifiers to use for shortcut keys.

JOptionPane

JOptionPane is a composite component and may consist of numerous child components, they are: OptionPane.button, OptionPane.label, OptionPane.comboBox, OptionPane.scrollPane, OptionPane.list, OptionPane.textField, OptionPane.iconLabel.

JOptionPane Specific Properties
Property | Expected Type | Default Value | Description
OptionPane.buttonAreaBorder | Border | null | Border around the button area.
OptionPane.buttonClickThreshhold | Integer | 0 | Passed to the created buttons setMultiClickThreshhold.
OptionPane.buttonOrientation | Integer | SwingConstants.CENTER | How the buttons should be layed out, one of SwingConstants.LEFT, SwingConstants.RIGHT or SwingConstants.CENTER (this will be flipped when in a right to left locale).
OptionPane.buttonPadding | Integer | 6 | Amount of space between buttons.
OptionPane.cancelIcon | Icon | null | Icon for the cancel button.
OptionPane.errorIcon | Icon | null | Icon used for ERROR_MESSAGE.
OptionPane.informationIcon | Icon | null | Icon used for INFORMATION_MESSAGE.
OptionPane.isYesLast | Boolean | false | If true the 'yes' button leads other buttons, otherwise it follows the other buttons.
OptionPane.questionIcon | Icon | null | Icon used for error QUESTION_MESSAGE.
OptionPane.minimumSize | Dimension | 262x90 | Minimum size for the JOptionPane.
OptionPane.noIcon | Icon | null | Icon for the no button.
OptionPane.okIcon | Icon | null | Icon for the ok button.
OptionPane.sameSizeButtons | Boolean | true | Whether or not all the buttons should be the same size.
OptionPane.separatorPadding | Integer | 6 | Amount of padding between the message area and separator.
OptionPane.yesIcon | Icon | null | Icon for the yes button.
OptionPane.warningIcon | Icon | null | Icon used for error WARNING_MESSAGE

JProgressBar

JProgressBar Specific Properties
Property | Expected Type | Default Value | 描述
ProgressBar.repaintInterval | Integer | 50 | Number of milliseconds between repaints for indeterminate progress bars.
ProgressBar.cycleTime | Integer | 3000 | Number of milliseconds used to determine how far to move the bouncing box per frame when the progress bar is indeterminate.

JRadioButton

JRadioButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JRadioButton supports the following property:

JRadioButton Specific Properties
Property | Expected Type | Default Value | Description
RadioButton.icon | Icon | null | Icon used to render the radio indicator.

JScrollBar

JScrollBar is a composite component that consists of the following child Components:

Name | Type | Description
ScrollBar.button | SynthArrowButton | Identifies the increment/decrement buttons.

JScrollBar Specific Properties
Property | Expected Type | Default Value | Description
ScrollBar.allowsAbsolutePositioning | Boolean | false | If true, middle mouse click in the track will set the position of the track to where the mouse is.
ScrollBar.maximumThumbSize | Dimension | 4096x4096 | Maximum thumb size.
ScrollBar.minimumThumbSize | Dimension | Derived from ScrollBar.thumbHeight | The minimum thumb size. If this is not specified the minimum thumb size is ScrollBar.thumbHeight plus the insets of the scrollbar along the opposite axis of the scrollbar and 7 along the other axis. For example, if you have not specified Insets for a scrollbar, and the orientation of the scrollbar is vertical, than the minimum thumb size width is ScrollBar.thumbHeight with a height of 7.
ScrollBar.squareButtons | Boolean | false | If true, the width and height of the scrollbar buttons will be made equal.
ScrollBar.thumbHeight | Integer | 14 | The preferred height, when the orientation of the scrollbar is horizontal, or preferred width when the orientation of the scrollbar is vertical.

Separators

All of the separator classes, JSeparator, JPopupMenu.Separator and JToolBar.Separator use the same property:

Property | Expected Type | Default Value | Description
Separator.thickness | Integer | 2 | Preferred width, for vertically aligned separators, or preferred height for horizontally aligned separators. The resulting preferred size will include the Insets.

JToolBar.Separator also supports the following property:

Property | Expected Type | Default Value | Description
ToolBar.separatorSize | Dimension | null | The value of this is passed to the javax.swing.JToolBar$Separator#setSeparatorSize(java.awt.Dimension) method. If unspecified setSeparatorSize is not invoked.

JScrollPane

JScrollPane is unique in that it provides a method for setting the Border around the JViewport with JViewport throwing an IllegalArgumentException from setBorder. To accomodate this a special border is installed on the JScrollPane that uses the insets from the key ScrollPane.viewportBorderInsets. The SynthPainter method paintViewportBorder is called to paint the Viewports border.

JScrollPane Specific Properties
Property | Expected Type | Default Value | Description
ScrollPane.viewportBorderInsets | Insets | null | Insets for the viewport Border.

JSplitPane

JSplitPane is a composite component that will contain a divider and potentially two buttons, if setOneTouchExpandable(true) has been invoked. The two buttons will be named: SplitPaneDivider.leftOneTouchButton and SplitPaneDivider.rightOneTouchButton.

JSplitPane Specific Properties
Property | Expected Type | Default Value | Description
SplitPane.centerOneTouchButtons | Boolean | true | If true, the one touch buttons are centered on the divider.
SplitPane.oneTouchButtonOffset | Integer | 2 | Distance between the one touch buttons.
SplitPane.oneTouchButtonSize | Integer | 6 | Size to make the one touch buttons.
SplitPane.oneTouchExpandable | Boolean | null | If non null, the value of this is passed to setOneTouchExpandable.
SplitPane.size | Integer | 6 | Size of the divider

JSlider

JSlider Specific Properties
Property | Expected Type | Default Value | Description
Slider.thumbWidth | Integer | 30 | Width of the slider thumb
Slider.thumbHeight | Integer | 14 | Height of the slider thumb
Slider.trackBorder | Integer | 1 | Width of the track border
Slider.paintValue | Boolean | true | Whether or not to paint the current value of the slider.

JTabbedPane

JTabbedPane Specific Properties
Property | Expected Type | Default Value | 描述
TabbedPane.tabRunOverlay | Integer | 0 | Number of pixels to overlap tabs when there is more than one row.
TabbedPane.textIconGap | Integer | 0 | Padding added between the icon and text on a tab. If there is no text or icon this value is not used.
TabbedPane.selectedTabPadInsets | Insets | Empty Insets (0, 0, 0, 0) | Extra insets added to the selected tab.
TabbedPane.selectionFollowsFocus | Boolean | true | If true the selection of the tabbed pane changes as the user navigates the tabs with a mouse.

JTable

JTable sets the name of the renderer to Table.cellRenderer. JTable supports the following properties:

JTable Specific Properties
Property | Expected Type | Default Value | Description
Table.gridColor | Color | null | Color used for the grid. If null the foreground from the style is used.
Table.rendererUseTableColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JTable's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
Table.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
Table.rowHeight | Integer | -1 | If not -1 setRowHeight is invoked on the JTable.

JTree

JTree sets the name of the renderer to Tree.renderer, the name of the editor is Tree.cellEditor.

JTree Specific Properties
Property | Expected Type | Default Value | Description
Tree.collapsedIcon | Icon | null | Icon to use when a node is collapsed.
Tree.drawHorizontalLines | Boolean | true | If true nodes have a horizontal connecting them to the leading edge of their parent.
Tree.drawVerticalLines | Boolean | true | If true a vertical line is drawn down from expanded nodes.
Tree.expandedIcon | Icon | null | Icon to use when a node has been expanded.
Tree.leftChildIndent | Integer | 0 | This plus Tree.rightChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rightChildIndent | Integer | 0 | This plus Tree.leftChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rowHeight | Integer | -1 | Row height for the Tree.
Tree.scrollsHorizontallyAndVertically | Boolean | false | If false and scrolling needs to happen to accomodate cells it will only happen along the vertical axis, if true, scrolling may happen along both the horizontal and vertical axis.
Tree.scrollsOnExpand | Boolean | true | Whether or not the JTree should scroll when a node is expanded.
Tree.linesStyle | String |  | The styles of the lines in the tree. Synth supports solid lines (empty value) and dashed lines ("dashed" value). It is possible to add new styles by creating a new SynthGraphicsUtils and binding it to the tree.

JToggleButton

JToggleButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JToggleButton supports the following property:

JToggleButton Specific Properties
Property | Expected Type | Default Value | Description
ToggleButton.icon | Icon | null | Icon used to render the radio indicator.

Button Properties

Each of the Button classes (JButton, JCheckBox, JRadioButton, JToggleButton and SynthArrowButton) support a similar set of properties. These properties are:

Property | Expected Type | Default Value | Description
prefix.contentAreaFilled | Integer | true | Refer to the javadoc of javax.swing.AbstractButton#contentAreaFilled(boolean) for details of how this is used. It is up to the Painter to properly honor this property.
prefix.iconTextGap | Integer | If unspecified, JButton.setIconTextGap is not invoked. | Padding between the icon and text. Refer to the javadoc of javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JButton. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textShiftOffset | Integer | 0 | Amount to shift the text and icon, along the x and y axis, from where it would normally be layed out. This is only used when the button is in a pressed state and does not have a pressed icon.

Prefix is one of: Button, CheckBox, RadioButton or JToggleButton.

Text Properties

Property | Expected Type | Default Value | Description
prefix.caretForeground | Color | #000000 | Color of the caret.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0), EditorPane and TextPane (3, 3, 3, 3) | Margins of the text component.
prefix.caretBlinkRate | Integer | 500 | Number of milliseconds defining the blink rate fo the caret.

Prefix is one of: EditorPane, FormattedTextField, PasswordField, TextArea, TextField or TextPane.


Synth File Format

File Format

Synth's file format (dtd) allows for specifying all the pieces necessary to create your own look and feel. A synth file is loaded by way of the SynthLookAndFeel.load(InputStream, Class) or SynthLookAndFeel.load(URL) methods. The following example uses the load method to configure a SynthLookAndFeel and sets it as the current look and feel:

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(MyClass.class.getResourceAsStream("laf.xml"), MyClass.class);
  UIManager.setLookAndFeel(laf);

This example loads the look and feel from an input stream, using the specified class as the resource base to resolve paths. It is also possible to load a look and feel from an arbitrary URL as in the following example.

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(new URL("file:///C:/java/synth/laf/laf.xml"));
  UIManager.setLookAndFeel(laf);

The method SynthLookAndFeel.load(URL) can be used, for instance, to load a look and feel from any of the following:

  • File, e.g. file:///C:/java/synth/laf/laf.xml
  • Web server, e.g. http://host/laf.xml
  • JAR file, e.g. jar:file:///C:/synth-laf.jar!/laf.xml
  • Remote JAR file, e.g. jar:http://host/synth-laf.jar!/laf.xml

While the DTD for synth is specified, the parser is not validating. Parsing will fail only if a necessary attribute is not specified, or of the wrong type.

The synth element

<!ELEMENT synth ((%beansPersistance;) | style | bind | font | color |
                 imagePainter | imageIcon | defaultsProperty)*>
<!ATTLIST synth
          version              CDATA          #IMPLIED
>

Attribute definitions

version
File format version, should be 1

The synth element contains all the other elements that make up a SynthLookAndFeel definition.

The style element

<!ELEMENT style (property | defaultsProperty | state | font | graphicsUtils |
                 insets | painter | imagePainter | opaque | (%beansPersistance;) |
                 imageIcon)*>
<!ATTLIST style
          id              ID          #IMPLIED
          clone           IDREF       #IMPLIED
>

Attribute definitions

id
Unique identifier for the style.
clone
Identifier of a previously defined style that is copied and used for the new style. This provides a conveniant mechanism for overriding only a portion of an existing style.

A style element corresponds to a SynthStyle, with the child elements specifying properties that apply to all states or state elements which contain properties specific to a particular state. The following example creates an opaque style with the id button, insets of 4, 4, 4, 4 and a font of Dialog 12.

<style id="button">
  <opaque value="true"/>
  <insets top="4" left="4" right="4" bottom="4"/>
  <font name="Dialog" size="12"/>
</style>

The following example creates a new style with an id of clonedButton that is a copy of the style with id button and has a font of Dialog, 14. The resulting style will be opaque, have insets of 4, 4, 4, 4 and a font of Dialog 14.

<style id="clonedButton" clone="button">
  <font name="Dialog" size="14"/>
</style>

The state element

<!ELEMENT state (color | font | painter | imagePainter | (%beansPersistance;) |
                 property |  imageIcon)*>
<!ATTLIST state
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          value           CDATA          #IMPLIED
          idref           IDREF          #IMPLIED
>

Attribute definitions

id
Unique identifier for the state.
clone
Identifier of a previously defined state that is copied and used for the new state.
value
Identifies the state of the Component the properties are to apply to. This is a list of: ENABLED, MOUSE_OVER, PRESSED, DISABLED, FOCUSED, SELECTED or DEFAULT. Multiple states should be separated by 'and.' If you do not specify a value, the contents apply to all states.
idref
Indicates this state should be the same as a previously defined state. This is useful for multiple styles that wish to share the same visual properties for a particular state.

The state element specifies the visual properties that are to be used for a particular state of a component. For example, you could specify the background color when the Component is enabled should look different than the background color when the component is disabled. Not all Components support all states. For example, a Panel only supports the states ENABLED and DISABLED.

The following example creates a state with a red background that will be used when the component is in an a selected and pressed state:

<state value="SELECTED AND PRESSED">
  <color value="RED" type="BACKGROUND"/>
</state>

The state with the most individual matches will be chosen. For example, the following defines two states:

<state value="SELECTED and PRESSED" id="one">
  <color value="RED" type="BACKGROUND"/>
</state>
<state value="SELECTED" id="two">
  <color value="RED" type="BACKGROUND"/>
</state>

State one is used when the Component is SELECTED and PRESSED, and state two when the Component is SELECTED. If the state of the Component contains at least SELECTED and PRESSED, state one will be chosen, otherwise if the state is SELECTED, but not does not contain PRESSED, state two will be used.

The font element

<!ELEMENT font EMPTY>
<!ATTLIST font
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          name            CDATA          #IMPLIED
          style           CDATA          #IMPLIED
          size            CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Font.
idref
Identifier of a previously defined font.
name
Name of the font.
style
Style of the font. This is a list of the styles defined by Font separated by spaces: PLAIN, BOLD or ITALIC. If unspecified PLAIN is used.
size
Size of the font, in pixels

Defines the font for the current state, or style. You must specify either an idref or a name and size.

The following example creates a style with a Font of Dialog 12 Bold.

<style id="test">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>

The following example creates a style with a font of Dialog 12 Bold that will be used if the component is ENABLED, otherwise Dialog 12 Italic will be used.

<style id="test">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <state value="ENABLED">
    <font name="DIALOG" size="12" style="BOLD"/>
  </state>
</style>

While you can supply a different font per state, in general widgets will NOT revalidate when the state changes, so that you may run into sizing problems if you try to use a font with a significantly different size for different states.

The color element

<!ELEMENT color EMPTY>
<!ATTLIST color
          id              ID             #IMPLIED
          idref           IDREF          #IMPLIED
          type            CDATA          #IMPLIED
          value           CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the color.
idref
Identifier of a previously defined color.
type
Describes where this color should be used. This is typically one of the constants defined by ColorType: FOREGROUND, BACKGROUND, TEXT_FOREGROUND, TEXT_BACKGROUND or FOCUS. Alternatively you can specify the complete path to a class and field, for example javax.swing.plaf.synth.ColorType.FOREGROUND, this is useful for subclasses of synth that define additional color types.
value
Value for the color. This accepts the following forms.
  • The name of a constant in the Color class, for example RED.
  • A hex value of the form #RRGGBB where RR gives the red component, GG the green component and BB the blue component. You need not specify all color components. For example, #123 is equivalent to #000123.
  • A hex value of the form #ARRGGBB or #AARRGGBB. This is useful for alpha values other than 0xFF. The form #ARRGGBB is equivalent to #0ARRGGBB.

Color defines a color and what portion of the Component it should be applied to. The following example will use a background color of RED when the component is enabled.

<state value="ENABLED">
  <color value="RED" type="BACKGROUND"/>
</state>

The following example will have a red background when the Component is enabled, otherwise blue.

<style id="test">
  <state value="ENABLED">
    <color value="RED" type="BACKGROUND"/>
  </state>
  <state>
    <color value="#00FF00" type="BACKGROUND"/>
  </state>
</style>

The property element

<!ELEMENT property EMPTY>
<!ATTLIST property
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)          "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

Property elements are used to add key value pairs to a SynthStyle that can be accessed by way of the get method. Many Components use the key value pairs for configuring their visual appearance. Refer to property table for a list of the properties each Component supports. The following creates the properties ScrollBar.allowsAbsolutePositioning, OptionPane.minimumSize, ScrollPane.viewportBorderInsets, Tree.rowHeight and foreground with the values false, a dimensions of 262x90, an insets of 5, 5, 5, 5, the integer 20 and an instance of the class ArrowButtonPainter.

<style id="test">
  <property key="ScrollBar.allowsAbsolutePositioning" type="boolean" value="false"/>
  <property key="OptionPane.minimumSize" type="dimension" value="262 90"/>
  <property key="ScrollPane.viewportBorderInsets" type="insets" value="5 5 5 5"/>
  <property key="Tree.rowHeight" type="integer" value="20"/>
  <object class="ArrowButtonPainter" id="ArrowButtonPainter"/>
  <property key="foreground" type="idref" value="ArrowButtonPainter"/>
</style>

You can also specify properties that are to apply to specific states. Whether or not the property is accessed for each state depends upon how the property is used. For example, the following specifies a default icon and an icon to use while the mouse is over the component.

<style id="test">
  <imageIcon id="defaultIcon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="defaultIcon"/>
  <state value="MOUSE_OVER">
    <imageIcon id="mouseOverIcon" path="resources/myMouseOverImage.png"/>
    <property key="RadioButton.icon" value="mouseOverIcon"/>
  </state>
</style>

<!ELEMENT defaultsProperty EMPTY>
<!ATTLIST defaultsProperty
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)   "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

DefaultsProperty elements are used to define properties that will be placed in the UIDefaults table that SynthLookAndFeel supplies to the UIManager. The following assigns the the Color red to the value Table.focusCellForeground.

<style id="test">
  <object class="javax.swing.plaf.ColorUIResource" id="color">
    <int>255</int>
    <int>0</int>
    <int>0</int>
  </object>
  <defaultsProperty key="Table.focusCellForeground" type="idref" value="color"/>
</style>

This value could then be asked by way of UIManager.get("Table.focusCellForeground").

The graphicsUtils element

<!ELEMENT graphicsUtils EMPTY>
<!ATTLIST graphicsUtils
          idref           IDREF             #REQUIRED
>

Attribute definitions

idref
Identifer of a previously defined SynthGraphicsUtils object that is to be used as the SynthGraphicsUtils for the current style.

GraphicsUtils elements are used to define the SynthGraphicsUtils that the current style will use. The following example creates a style with an instance of CustomGraphicsUtils for the SynthGraphicsUtils.

<style id="test">
  <object class="CustomGraphicsUtils" id="graphics"/>
  <graphicsUtils idref="graphics"/>
</style>

The insets element

<!ELEMENT insets EMPTY>
<!ATTLIST insets
          id           ID             #IMPLIED
          idref        IDREF          #IMPLIED
          top          CDATA          #IMPLIED
          bottom       CDATA          #IMPLIED
          left         CDATA          #IMPLIED
          right        CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Insets.
idref
Identifier of a previously defined Insets.
top
Top component of the Insets.
bottom
Bottom component of the Insets.
left
Left component of the Insets.
right
Right component of the Insets.

Insets elements are used to define the Insets for the current style. The insets will be set on any Components the style is associated with. The following example creates a style with insets of 1, 2, 3, 0.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>

The bind element

<!ELEMENT bind EMPTY>
<!ATTLIST bind
          style        IDREF             #REQUIRED
          type         (name|region)     #REQUIRED
          key          CDATA             #REQUIRED
>

Attribute definitions

style
Unique identifier of a previously defined style.
type
One of name or region. For type name component.getName() is used, otherwise the name of the Region is used.
key
Regular expression applied to the name of the Component, or the name of the Region, depending upon the value of type.

Bind elements specify which Regions a style is to be used for. The following example applies the style test to any Component whose name starts with test.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="test" type="name" key="test.*"/>

Numerous styles may apply to a region, in which case each of the matching styles is merged into a resulting style that is used. Precedence is given to styles defined later in the file. For example, the following defines two styles, a and b. Style a is applied to any component with a name starting with test, and style b is used for button regions.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
</style>

Merging happens for states of a style as well.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
  </state>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
  <state value="ENABLED">
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>

The painter element

<!ELEMENT painter EMPTY>
<!ATTLIST painter
          idref                 IDREF          #IMPLIED
          方法                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
>

Attribute definitions

idref
Identifier of a previously defined SynthPainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this painter is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the painter is used for all directions.

Painter defines a SynthPainter for the current style or the state of the current style. The following example binds an instance of the class MyPainter which must be a SynthPainter to the style test.

<style id="test">
  <object class="MyPainter" id="MyPainter"/>
  <painter idref="MyPainter"/>
</style>

The painter that is used for a particular method and state is determined as follows:

  1. Painter specified for the current state, method and direction.
  2. Painter specified for the current state and method.
  3. Painter specified for the current state.
  4. Painter specified for the style, method and direction.
  5. Painter specified for the style and method.
  6. Painter specified for the style.

Consider the following:

<style id="test">
  <painter idref="fallbackPainter"/>
  <painter idref="styleButtonBackgroundPainter" method="buttonBackground"/>
  <state value="SELECTED">
    <painter idref="stateFallbackPainter"/>
    <painter idref="stateButtonBackgroundPainter" method="buttonBackground"/>
  </state>
</style>

The following outlines which painter will be used for what SynthPainter method:

State | Method | Painter
SELECTED | paintButtonBackground | stateButtonBackgroundPainter
SELECTED | Anything but paintButtonBackground | stateFallbackPainter
Anything but SELECTED | paintButtonBackground | styleButtonBackgroundPainter
Anything but SELECTED | Anything but paintButtonBackground | fallbackPainter

When several identical painters are declared, they are aggregated into a single one. Two painters are identical if their direction and method attributes values are equal. Consider the following:

<style id="panelStyle">
  <imagePainter method="panelBackground" path="red.png" />
  <imagePainter method="panelBackground" path="green.png" />
  <imagePainter method="panelBackground" path="blue.png" />
</style>

These three painters are identical for they use the same method and the same direction (all directions by default). Synth aggregates these painters to create a single one that will paint its children painters in the order of declaration. Hence, Synth will first paint the red picture, then the green one and finally the blue one. Each child painter can be seen as a layer of the aggregate painter.

Painter aggregation, or multi-layering, is very useful to reuse elements. Imagine you want to use an highlight effect on buttons and on selected menu items. With painter aggregation, you just need to create a separate highlighting painter instead of having buttons and menu items painters handle it.

The imagePainter element

<!ELEMENT imagePainter EMPTY>
<!ATTLIST imagePainter
          id                    ID             #IMPLIED
          方法                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
          path                  CDATA          #REQUIRED
          sourceInsets          CDATA          #IMPLIED
          destinationInsets     CDATA          #IMPLIED
          paintCenter           (true|false)   "true"
          stretch               (true|false)   "true"
          center                (true|false)   "false"
>

Attribute definitions

id
Unique identifier for the imagePainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this image is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the image is used for all directions.
path
Path to the image. Path to the image. If SynthLookAndFeel.load is passed a Class this will use the Class method getResource (with with the Class suplied to the load method). If load is passed a URL this will use the URL constructor URL(context, path) to resolve the path.
sourceInsets
Insets on the source image. This is top, left, bottom, right with each component separated by a space.
destinationInsets
Insets of the destination image. This is top, left, bottom, right with each component separated by a space. If not specified the sourceInsets are used.
paintCenter
Whether or not the center of the image should be drawn.
stretch
Whether or not the north, south, east and west components of the resulting image should be scaled or tiled.
center
Whether or not the image is centered.

The ImagePainter element defines a painter for the current style or state that will render using the specified image. ImagePainter offers two distinct rendering modes. The first mode is used to center an image in the space provided. This is commonly used in rendering decorations on top of a widget, for example, to specify an arrow for a scroll button use the center mode. The following example illustrates this:

<style id="test">
  <imagePainter path="resources/myImage.png" center="true"/>
</style>

The second mode is used in scaling an image to fit in the provided space. In this mode sourceInsets is used to specify a border around an image where the north, south, east and west edges of the border are either stretched or tiled (stretch attribute), the four corners of the border drawn in place, and the center is stretched. In this mode you must specify sourceInsets. The following example illustrates an ImagePainter that is using the image MyImage.png and insets of 2 all the way around:

<style id="test">
  <imagePainter path="resources/myImage.png"
                sourceInsets="2 2 2 2"/>
</style>

Refer to the description of the painter element for details as to the precedence in choosing a painter and to understand how identical painters are handled.

The imageIcon element

<!ELEMENT imageIcon EMPTY>
<!ATTLIST imageIcon
          id                    ID             #REQUIRED
          path                  CDATA          #REQUIRED
>

Attribute definitions

id
Unique identifier for the imageIcon.
path
Path to the image. This uses the Class method getResource to resolve the path, with the Class supplied to SynthLookAndFeel.load.

ImageIcon is used to assign an Icon implementation that is wrapping an Image to a unique identifier. This is typically used for properties that take an Icon. The following example binds an ImageIcon to the property RadioButton.icon.

<style id="test">
  <imageIcon id="icon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="icon"/>
</style>

The opaque element

<!ELEMENT opaque EMPTY>
<!ATTLIST opaque
          value              (true|false)   "true"
>

Attribute definitions

id
Whether or not the style should be opaque, if unspecified the style is opaque.

The opaque element indicates whether or not any Components the style is associated with are to be made opaque. The painter will be asked to paint regardless of the opacity of the associated Component. The following example creates a style that is not opaque.

<style id="test">
  <opaque value="FALSE">
  <painter idref="painter"/>
</style>

The beansPersistance entity

Beans persistance can be used to embed any Object. This is typically used for embedding your own Painters, but can be used for other arbritrary objects as well. Refer to http://java.sun.com/products/jfc/tsc/articles/persistence3/ for details on beans persistance.

Backing Style

In creating a Synth file it's good practice to create a backing style that is used by all components. This will make sure that any components that do not match a specific style will have a default font, foreground, background and opacity. The following example illustrates this:

<synth>
  <style id="backingStyle">
    <opaque value="true"/>
    <font name="Dialog" size="12"/>
    <state>
      <color value="BLACK" type="BACKGROUND"/>
      <color value="WHITE" type="FOREGROUND"/>
    </state>
  </style>
  <bind style="backingStyle" type="region" key=".*"/>
</synth>
n


AbstractTableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 AbstractTableModel

  • java.lang.Object
    • javax.swing.table.AbstractTableModel
  • 所有已实现的接口：
    Serializable, TableModel
    直接已知子类：
    DefaultTableModel

    public abstract class AbstractTableModel
extends Object
implements TableModel, Serializable
    This abstract class provides default implementations for most of the methods in the TableModel interface. It takes care of the management of listeners and provides some conveniences for generating TableModelEvents and dispatching them to the listeners. To create a concrete TableModel as a subclass of AbstractTableModel you need only provide implementations for the following three methods:
      public int getRowCount();
  public int getColumnCount();
  public Object getValueAt(int row, int column);

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected EventListenerList listenerList
      List of listeners

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractTableModel()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addTableModelListener(TableModelListener l)
      Adds a listener to the list that's notified each time a change to the data model occurs.
      int findColumn(String columnName)
      Returns a column given its name.
      void fireTableCellUpdated(int row, int column)
      Notifies all listeners that the value of the cell at [row, column] has been updated.
      void fireTableChanged(TableModelEvent e)
      Forwards the given notification event to all TableModelListeners that registered themselves as listeners for this table model.
      void fireTableDataChanged()
      Notifies all listeners that all cell values in the table's rows may have changed.
      void fireTableRowsDeleted(int firstRow, int lastRow)
      Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been deleted.
      void fireTableRowsInserted(int firstRow, int lastRow)
      Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been inserted.
      void fireTableRowsUpdated(int firstRow, int lastRow)
      Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been updated.
      void fireTableStructureChanged()
      Notifies all listeners that the table's structure has changed.
      类<?> getColumnClass(int columnIndex)
      Returns Object.class regardless of columnIndex.
      String getColumnName(int column)
      Returns a default name for the column using spreadsheet conventions: A, B, C, ...
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this AbstractTableModel.
      TableModelListener[] getTableModelListeners()
      Returns an array of all the table model listeners registered on this model.
      boolean isCellEditable(int rowIndex, int columnIndex)
      Returns false.
      void removeTableModelListener(TableModelListener l)
      Removes a listener from the list that's notified each time a change to the data model occurs.
      void setValueAt(Object aValue, int rowIndex, int columnIndex)
      This empty implementation is provided so users don't have to implement this method if their data model is not editable.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.table.TableModel

        getColumnCount, getRowCount, getValueAt

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList
        List of listeners

    • 构造方法详细信息

      • AbstractTableModel

        public AbstractTableModel()

    • 方法详细信息

      • getColumnName

        public String getColumnName(int column)
        Returns a default name for the column using spreadsheet conventions: A, B, C, ... Z, AA, AB, etc. If column cannot be found, returns an empty string.
        指定者：
        getColumnName in interface TableModel
        参数：
        column - the column being queried
        返回：
        a string containing the default name of column

      • findColumn

        public int findColumn(String columnName)
        Returns a column given its name. Implementation is naive so this should be overridden if this method is to be called often. This method is not in the TableModel interface and is not used by the JTable.
        参数：
        columnName - string containing name of column to be located
        返回：
        the column with columnName, or -1 if not found

      • getColumnClass

        public 类<?> getColumnClass(int columnIndex)
        Returns Object.class regardless of columnIndex.
        指定者：
        getColumnClass in interface TableModel
        参数：
        columnIndex - the column being queried
        返回：
        the Object.class

      • isCellEditable

        public boolean isCellEditable(int rowIndex,
                     int columnIndex)
        Returns false. This is the default implementation for all cells.
        指定者：
        isCellEditable in interface TableModel
        参数：
        rowIndex - the row being queried
        columnIndex - the column being queried
        返回：
        false
        另请参见：
        TableModel.setValueAt(java.lang.Object, int, int)

      • setValueAt

        public void setValueAt(Object aValue,
              int rowIndex,
              int columnIndex)
        This empty implementation is provided so users don't have to implement this method if their data model is not editable.
        指定者：
        setValueAt in interface TableModel
        参数：
        aValue - value to assign to cell
        rowIndex - row of cell
        columnIndex - column of cell
        另请参见：
        TableModel.getValueAt(int, int), TableModel.isCellEditable(int, int)

      • addTableModelListener

        public void addTableModelListener(TableModelListener l)
        Adds a listener to the list that's notified each time a change to the data model occurs.
        指定者：
        addTableModelListener in interface TableModel
        参数：
        l - the TableModelListener

      • removeTableModelListener

        public void removeTableModelListener(TableModelListener l)
        Removes a listener from the list that's notified each time a change to the data model occurs.
        指定者：
        removeTableModelListener in interface TableModel
        参数：
        l - the TableModelListener

      • getTableModelListeners

        public TableModelListener[] getTableModelListeners()
        Returns an array of all the table model listeners registered on this model.
        返回：
        all of this model's TableModelListeners or an empty array if no table model listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addTableModelListener(javax.swing.event.TableModelListener), removeTableModelListener(javax.swing.event.TableModelListener)

      • fireTableDataChanged

        public void fireTableDataChanged()
        Notifies all listeners that all cell values in the table's rows may have changed. The number of rows may also have changed and the JTable should redraw the table from scratch. The structure of the table (as in the order of the columns) is assumed to be the same.
        另请参见：
        TableModelEvent, EventListenerList, JTable.tableChanged(TableModelEvent)

      • fireTableStructureChanged

        public void fireTableStructureChanged()
        Notifies all listeners that the table's structure has changed. The number of columns in the table, and the names and types of the new columns may be different from the previous state. If the JTable receives this event and its autoCreateColumnsFromModel flag is set it discards any table columns that it had and reallocates default columns in the order they appear in the model. This is the same as calling setModel(TableModel) on the JTable.
        另请参见：
        TableModelEvent, EventListenerList

      • fireTableRowsInserted

        public void fireTableRowsInserted(int firstRow,
                         int lastRow)
        Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been inserted.
        参数：
        firstRow - the first row
        lastRow - the last row
        另请参见：
        TableModelEvent, EventListenerList

      • fireTableRowsUpdated

        public void fireTableRowsUpdated(int firstRow,
                        int lastRow)
        Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been updated.
        参数：
        firstRow - the first row
        lastRow - the last row
        另请参见：
        TableModelEvent, EventListenerList

      • fireTableRowsDeleted

        public void fireTableRowsDeleted(int firstRow,
                        int lastRow)
        Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been deleted.
        参数：
        firstRow - the first row
        lastRow - the last row
        另请参见：
        TableModelEvent, EventListenerList

      • fireTableCellUpdated

        public void fireTableCellUpdated(int row,
                        int column)
        Notifies all listeners that the value of the cell at [row, column] has been updated.
        参数：
        row - row of cell which has been updated
        column - column of cell which has been updated
        另请参见：
        TableModelEvent, EventListenerList

      • fireTableChanged

        public void fireTableChanged(TableModelEvent e)
        Forwards the given notification event to all TableModelListeners that registered themselves as listeners for this table model.
        参数：
        e - the event to be forwarded
        另请参见：
        addTableModelListener(javax.swing.event.TableModelListener), TableModelEvent, EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this AbstractTableModel. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a model m for its table model listeners with the following code:

        TableModelListener[] tmls = (TableModelListener[])(m.getListeners(TableModelListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getTableModelListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultTableCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 DefaultTableCellRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.table.DefaultTableCellRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants, TableCellRenderer
    直接已知子类：
    DefaultTableCellRenderer.UIResource

    public class DefaultTableCellRenderer
extends JLabel
implements TableCellRenderer, Serializable
    The standard class for rendering (displaying) individual cells in a JTable.

    Implementation Note: This class inherits from JLabel, a standard component class. However JTable employs a unique mechanism for rendering its cells and therefore requires some slightly modified behavior from its cell renderer. The table class defines a single cell renderer and uses it as a as a rubber-stamp for rendering all cells in the table; it renders the first cell, changes the contents of that cell renderer, shifts the origin to the new location, re-draws it, and so on. The standard JLabel component was not designed to be used this way and we want to avoid triggering a revalidate each time the cell is drawn. This would greatly decrease performance because the revalidate message would be passed up the hierarchy of the container to determine whether any other components would be affected. As the renderer is only parented for the lifetime of a painting operation we similarly want to avoid the overhead associated with walking the hierarchy for painting operations. So this class overrides the validate, invalidate, revalidate, repaint, and firePropertyChange methods to be no-ops and override the isOpaque method solely to improve performance. If you write your own renderer, please keep this performance consideration in mind.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTable

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static Border | noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTableCellRenderer()
      Creates a default table cell renderer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
      Overridden for performance reasons.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Overridden for performance reasons.
      Component getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      Returns the default table cell renderer.
      void invalidate()
      Overridden for performance reasons.
      boolean isOpaque()
      Overridden for performance reasons.
      void repaint()
      Overridden for performance reasons.
      void repaint(long tm, int x, int y, int width, int height)
      Overridden for performance reasons.
      void repaint(Rectangle r)
      Overridden for performance reasons.
      void revalidate()
      Overridden for performance reasons.
      void setBackground(Color c)
      Overrides JComponent.setBackground to assign the unselected-background color to the specified color.
      void setForeground(Color c)
      Overrides JComponent.setForeground to assign the unselected-foreground color to the specified color.
      protected void setValue(Object value)
      Sets the String object for the cell being rendered to value.
      void updateUI()
      Notification from the UIManager that the look and feel [L&F] has changed.
      void validate()
      Overridden for performance reasons.

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • noFocusBorder

        protected static Border noFocusBorder

    • 构造方法详细信息

      • DefaultTableCellRenderer

        public DefaultTableCellRenderer()
        Creates a default table cell renderer.

    • 方法详细信息

      • setForeground

        public void setForeground(Color c)
        Overrides JComponent.setForeground to assign the unselected-foreground color to the specified color.
        重载：
        setForeground in class JComponent
        参数：
        c - set the foreground color to this value
        另请参见：
        Component.getForeground()

      • setBackground

        public void setBackground(Color c)
        Overrides JComponent.setBackground to assign the unselected-background color to the specified color.
        重载：
        setBackground in class JComponent
        参数：
        c - set the background color to this value
        另请参见：
        Component.getBackground(), JComponent.setOpaque(boolean)

      • updateUI

        public void updateUI()
        Notification from the UIManager that the look and feel [L&F] has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JLabel
        另请参见：
        JComponent.updateUI()

      • getTableCellRendererComponent

        public Component getTableCellRendererComponent(JTable table,
                                      Object value,
                                      boolean isSelected,
                                      boolean hasFocus,
                                      int row,
                                      int column)
        Returns the default table cell renderer.

        During a printing operation, this method will be called with isSelected and hasFocus values of false to prevent selection and focus from appearing in the printed output. To do other customization based on whether or not the table is being printed, check the return value from JComponent.isPaintingForPrint().

        指定者：
        getTableCellRendererComponent in interface TableCellRenderer
        参数：
        table - the JTable
        value - the value to assign to the cell at [row, column]
        isSelected - true if cell is selected
        hasFocus - true if cell has focus
        row - the row of the cell to render
        column - the column of the cell to render
        返回：
        the default table cell renderer
        另请参见：
        JComponent.isPaintingForPrint()

      • isOpaque

        public boolean isOpaque()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        isOpaque in class JComponent
        返回：
        true if this component is completely opaque
        另请参见：
        JComponent.setOpaque(boolean)

      • invalidate

        public void invalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        invalidate in class Container
        从以下版本开始：
        1.5
        另请参见：
        Container.validate(), Container.layout(), LayoutManager2

      • validate

        public void validate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        validate in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.isValidateRoot(),
JComponent.revalidate(),
Container.validateTree()

      • revalidate

        public void revalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        revalidate in class JComponent
        另请参见：
        Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

      • repaint

        public void repaint(long tm,
           int x,
           int y,
           int width,
           int height)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        tm - this parameter is not used
        x - the x value of the dirty region
        y - the y value of the dirty region
        width - the width of the dirty region
        height - the height of the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint(Rectangle r)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        r - a Rectangle containing the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class Component
        从以下版本开始：
        1.5
        另请参见：
        Component.update(Graphics)

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      boolean oldValue,
                      boolean newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • setValue

        protected void setValue(Object value)
        Sets the String object for the cell being rendered to value.
        参数：
        value - the string value for this cell; if value is null it sets the text value to an empty string
        另请参见：
        JLabel.setText(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultTableCellRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.table

类 DefaultTableCellRenderer.UIResource

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.table.DefaultTableCellRenderer
              • javax.swing.table.DefaultTableCellRenderer.UIResource
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, UIResource, SwingConstants, TableCellRenderer
    封闭类：
    DefaultTableCellRenderer

    public static class DefaultTableCellRenderer.UIResource
extends DefaultTableCellRenderer
implements UIResource
    A subclass of DefaultTableCellRenderer that implements UIResource. DefaultTableCellRenderer doesn't implement UIResource directly so that applications can safely override the cellRenderer property with DefaultTableCellRenderer subclasses.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.table.DefaultTableCellRenderer

        DefaultTableCellRenderer.UIResource

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.table.DefaultTableCellRenderer

        noFocusBorder

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTableCellRenderer.UIResource()

    • 方法摘要

      • 方法 - 继承于类 javax.swing.table.DefaultTableCellRenderer

        firePropertyChange, firePropertyChange, getTableCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, setBackground, setForeground, setValue, updateUI, validate

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DefaultTableCellRenderer.UIResource

        public DefaultTableCellRenderer.UIResource()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

an>el)te)tcaatccwsttni(otn,itsBtjta/oha...


DefaultTableColumnModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 DefaultTableColumnModel

  • java.lang.Object
    • javax.swing.table.DefaultTableColumnModel
  • 所有已实现的接口：
    PropertyChangeListener, Serializable, EventListener, ListSelectionListener, TableColumnModel

    public class DefaultTableColumnModel
extends Object
implements TableColumnModel, PropertyChangeListener, ListSelectionListener, Serializable
    The standard column-handler for a JTable.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTable

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Change event (only one needed)
      protected int columnMargin
      Width margin between each column
      protected boolean columnSelectionAllowed
      Column selection allowed in this column model
      protected EventListenerList listenerList
      List of TableColumnModelListener
      protected ListSelectionModel selectionModel
      Model for keeping track of column selections
      protected Vector<TableColumn> tableColumns
      Array of TableColumn objects in this model
      protected int totalColumnWidth
      A local cache of the combined width of all columns

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTableColumnModel()
      Creates a default table column model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addColumn(TableColumn aColumn)
      Appends aColumn to the end of the tableColumns array.
      void addColumnModelListener(TableColumnModelListener x)
      Adds a listener for table column model events.
      protected ListSelectionModel createSelectionModel()
      Creates a new default list selection model.
      protected void fireColumnAdded(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireColumnMarginChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireColumnMoved(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireColumnRemoved(TableColumnModelEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireColumnSelectionChanged(ListSelectionEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      TableColumn getColumn(int columnIndex)
      Returns the TableColumn object for the column at columnIndex.
      int getColumnCount()
      Returns the number of columns in the tableColumns array.
      int getColumnIndex(Object identifier)
      Returns the index of the first column in the tableColumns array whose identifier is equal to identifier, when compared using equals.
      int getColumnIndexAtX(int x)
      Returns the index of the column that lies at position x, or -1 if no column covers this point.
      int getColumnMargin()
      Returns the width margin for TableColumn.
      TableColumnModelListener[] getColumnModelListeners()
      Returns an array of all the column model listeners registered on this model.
      Enumeration<TableColumn> getColumns()
      Returns an Enumeration of all the columns in the model.
      boolean getColumnSelectionAllowed()
      Returns true if column selection is allowed, otherwise false.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getSelectedColumnCount()
      Returns the number of columns selected.
      int[] getSelectedColumns()
      Returns an array of selected columns.
      ListSelectionModel getSelectionModel()
      Returns the ListSelectionModel that is used to maintain column selection state.
      int getTotalColumnWidth()
      Returns the total combined width of all columns.
      void moveColumn(int columnIndex, int newIndex)
      Moves the column and heading at columnIndex to newIndex.
      void propertyChange(PropertyChangeEvent evt)
      Property Change Listener change method.
      protected void recalcWidthCache()
      Recalculates the total combined width of all columns.
      void removeColumn(TableColumn column)
      Deletes the column from the tableColumns array.
      void removeColumnModelListener(TableColumnModelListener x)
      Removes a listener for table column model events.
      void setColumnMargin(int newMargin)
      Sets the column margin to newMargin.
      void setColumnSelectionAllowed(boolean flag)
      Sets whether column selection is allowed.
      void setSelectionModel(ListSelectionModel newModel)
      Sets the selection model for this TableColumnModel to newModel and registers for listener notifications from the new selection model.
      void valueChanged(ListSelectionEvent e)
      A ListSelectionListener that forwards ListSelectionEvents when there is a column selection change.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • tableColumns

        protected Vector<TableColumn> tableColumns
        Array of TableColumn objects in this model

      • selectionModel

        protected ListSelectionModel selectionModel
        Model for keeping track of column selections

      • columnMargin

        protected int columnMargin
        Width margin between each column

      • listenerList

        protected EventListenerList listenerList
        List of TableColumnModelListener

      • changeEvent

        protected transient ChangeEvent changeEvent
        Change event (only one needed)

      • columnSelectionAllowed

        protected boolean columnSelectionAllowed
        Column selection allowed in this column model

      • totalColumnWidth

        protected int totalColumnWidth
        A local cache of the combined width of all columns

    • 构造方法详细信息

      • DefaultTableColumnModel

        public DefaultTableColumnModel()
        Creates a default table column model.

    • 方法详细信息

      • addColumn

        public void addColumn(TableColumn aColumn)
        Appends aColumn to the end of the tableColumns array. This method also posts the columnAdded event to its listeners.
        指定者：
        addColumn in interface TableColumnModel
        参数：
        aColumn - the TableColumn to be added
        抛出：
        IllegalArgumentException - if aColumn is null
        另请参见：
        removeColumn(javax.swing.table.TableColumn)

      • removeColumn

        public void removeColumn(TableColumn column)
        Deletes the column from the tableColumns array. This method will do nothing if column is not in the table's columns list. tile is called to resize both the header and table views. This method also posts a columnRemoved event to its listeners.
        指定者：
        removeColumn in interface TableColumnModel
        参数：
        column - the TableColumn to be removed
        另请参见：
        addColumn(javax.swing.table.TableColumn)

      • moveColumn

        public void moveColumn(int columnIndex,
              int newIndex)
        Moves the column and heading at columnIndex to newIndex. The old column at columnIndex will now be found at newIndex. The column that used to be at newIndex is shifted left or right to make room. This will not move any columns if columnIndex equals newIndex. This method also posts a columnMoved event to its listeners.
        指定者：
        moveColumn in interface TableColumnModel
        参数：
        columnIndex - the index of column to be moved
        newIndex - new index to move the column
        抛出：
        IllegalArgumentException - if column or newIndex are not in the valid range

      • setColumnMargin

        public void setColumnMargin(int newMargin)
        Sets the column margin to newMargin. This method also posts a columnMarginChanged event to its listeners.
        指定者：
        setColumnMargin in interface TableColumnModel
        参数：
        newMargin - the new margin width, in pixels
        另请参见：
        getColumnMargin(), getTotalColumnWidth()

      • getColumnCount

        public int getColumnCount()
        Returns the number of columns in the tableColumns array.
        指定者：
        getColumnCount in interface TableColumnModel
        返回：
        the number of columns in the tableColumns array
        另请参见：
        getColumns()

      • getColumns

        public Enumeration<TableColumn> getColumns()
        Returns an Enumeration of all the columns in the model.
        指定者：
        getColumns in interface TableColumnModel
        返回：
        an Enumeration of the columns in the model

      • getColumnIndex

        public int getColumnIndex(Object identifier)
        Returns the index of the first column in the tableColumns array whose identifier is equal to identifier, when compared using equals.
        指定者：
        getColumnIndex in interface TableColumnModel
        参数：
        identifier - the identifier object
        返回：
        the index of the first column in the tableColumns array whose identifier is equal to identifier
        抛出：
        IllegalArgumentException - if identifier is null, or if no TableColumn has this identifier
        另请参见：
        getColumn(int)

      • getColumn

        public TableColumn getColumn(int columnIndex)
        Returns the TableColumn object for the column at columnIndex.
        指定者：
        getColumn in interface TableColumnModel
        参数：
        columnIndex - the index of the column desired
        返回：
        the TableColumn object for the column at columnIndex

      • getColumnMargin

        public int getColumnMargin()
        Returns the width margin for TableColumn. The default columnMargin is 1.
        指定者：
        getColumnMargin in interface TableColumnModel
        返回：
        the maximum width for the TableColumn
        另请参见：
        setColumnMargin(int)

      • getColumnIndexAtX

        public int getColumnIndexAtX(int x)
        Returns the index of the column that lies at position x, or -1 if no column covers this point. In keeping with Swing's separable model architecture, a TableColumnModel does not know how the table columns actually appear on screen. The visual presentation of the columns is the responsibility of the view/controller object using this model (typically JTable). The view/controller need not display the columns sequentially from left to right. For example, columns could be displayed from right to left to accomodate a locale preference or some columns might be hidden at the request of the user. Because the model does not know how the columns are laid out on screen, the given xPosition should not be considered to be a coordinate in 2D graphics space. Instead, it should be considered to be a width from the start of the first column in the model. If the column index for a given X coordinate in 2D space is required, JTable.columnAtPoint can be used instead.
        指定者：
        getColumnIndexAtX in interface TableColumnModel
        参数：
        x - the horizontal location of interest
        返回：
        the index of the column or -1 if no column is found
        另请参见：
        JTable.columnAtPoint(java.awt.Point)

      • getTotalColumnWidth

        public int getTotalColumnWidth()
        Returns the total combined width of all columns.
        指定者：
        getTotalColumnWidth in interface TableColumnModel
        返回：
        the totalColumnWidth property

      • setSelectionModel

        public void setSelectionModel(ListSelectionModel newModel)
        Sets the selection model for this TableColumnModel to newModel and registers for listener notifications from the new selection model. If newModel is null, an exception is thrown.
        指定者：
        setSelectionModel in interface TableColumnModel
        参数：
        newModel - the new selection model
        抛出：
        IllegalArgumentException - if newModel is null
        另请参见：
        getSelectionModel()

      • getSelectionModel

        public ListSelectionModel getSelectionModel()
        Returns the ListSelectionModel that is used to maintain column selection state.
        指定者：
        getSelectionModel in interface TableColumnModel
        返回：
        the object that provides column selection state. Or null if row selection is not allowed.
        另请参见：
        setSelectionModel(javax.swing.ListSelectionModel)

      • setColumnSelectionAllowed

        public void setColumnSelectionAllowed(boolean flag)
        Sets whether column selection is allowed. The default is false.
        指定者：
        setColumnSelectionAllowed in interface TableColumnModel
        参数：
        flag - true if column selection will be allowed, false otherwise
        另请参见：
        TableColumnModel.getColumnSelectionAllowed()

      • getColumnSelectionAllowed

        public boolean getColumnSelectionAllowed()
        Returns true if column selection is allowed, otherwise false. The default is false.
        指定者：
        getColumnSelectionAllowed in interface TableColumnModel
        返回：
        the columnSelectionAllowed property
        另请参见：
        TableColumnModel.setColumnSelectionAllowed(boolean)

      • getSelectedColumns

        public int[] getSelectedColumns()
        Returns an array of selected columns. If selectionModel is null, returns an empty array.
        指定者：
        getSelectedColumns in interface TableColumnModel
        返回：
        an array of selected columns or an empty array if nothing is selected or the selectionModel is null

      • getSelectedColumnCount

        public int getSelectedColumnCount()
        Returns the number of columns selected.
        指定者：
        getSelectedColumnCount in interface TableColumnModel
        返回：
        the number of columns selected

      • addColumnModelListener

        public void addColumnModelListener(TableColumnModelListener x)
        Adds a listener for table column model events.
        指定者：
        addColumnModelListener in interface TableColumnModel
        参数：
        x - a TableColumnModelListener object

      • removeColumnModelListener

        public void removeColumnModelListener(TableColumnModelListener x)
        Removes a listener for table column model events.
        指定者：
        removeColumnModelListener in interface TableColumnModel
        参数：
        x - a TableColumnModelListener object

      • getColumnModelListeners

        public TableColumnModelListener[] getColumnModelListeners()
        Returns an array of all the column model listeners registered on this model.
        返回：
        all of this default table column model's ColumnModelListeners or an empty array if no column model listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addColumnModelListener(javax.swing.event.TableColumnModelListener), removeColumnModelListener(javax.swing.event.TableColumnModelListener)

      • fireColumnAdded

        protected void fireColumnAdded(TableColumnModelEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event received
        另请参见：
        EventListenerList

      • fireColumnRemoved

        protected void fireColumnRemoved(TableColumnModelEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event received
        另请参见：
        EventListenerList

      • fireColumnMoved

        protected void fireColumnMoved(TableColumnModelEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event received
        另请参见：
        EventListenerList

      • fireColumnSelectionChanged

        protected void fireColumnSelectionChanged(ListSelectionEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event received
        另请参见：
        EventListenerList

      • fireColumnMarginChanged

        protected void fireColumnMarginChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultTableColumnModel m for its column model listeners with the following code:

        ColumnModelListener[] cmls = (ColumnModelListener[])(m.getListeners(ColumnModelListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this model, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getColumnModelListeners()

      • propertyChange

        public void propertyChange(PropertyChangeEvent evt)
        Property Change Listener change method. Used to track changes to the column width or preferred column width.
        指定者：
        propertyChange in interface PropertyChangeListener
        参数：
        evt - PropertyChangeEvent

      • valueChanged

        public void valueChanged(ListSelectionEvent e)
        A ListSelectionListener that forwards ListSelectionEvents when there is a column selection change.
        指定者：
        valueChanged in interface ListSelectionListener
        参数：
        e - the change event

      • createSelectionModel

        protected ListSelectionModel createSelectionModel()
        Creates a new default list selection model.

      • recalcWidthCache

        protected void recalcWidthCache()
        Recalculates the total combined width of all columns. Updates the totalColumnWidth property.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&asek


DefaultTableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 DefaultTableModel

  • java.lang.Object
    • javax.swing.table.AbstractTableModel
      • javax.swing.table.DefaultTableModel
  • 所有已实现的接口：
    Serializable, TableModel

    public class DefaultTableModel
extends AbstractTableModel
implements Serializable
    This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.

    警告： DefaultTableModel returns a column class of Object. When DefaultTableModel is used with a TableRowSorter this will result in extensive use of toString, which for non-String data types is expensive. If you use DefaultTableModel with a TableRowSorter you are strongly encouraged to override getColumnClass to return the appropriate type.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    TableModel, getDataVector()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector columnIdentifiers
      The Vector of column identifiers.
      protected Vector dataVector
      The Vector of Vectors of Object values.

      • Fields inherited from class javax.swing.table.AbstractTableModel

        listenerList

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTableModel()
      Constructs a default DefaultTableModel which is a table of zero columns and zero rows.
      DefaultTableModel(int rowCount, int columnCount)
      Constructs a DefaultTableModel with rowCount and columnCount of null object values.
      DefaultTableModel(Object[][] data, Object[] columnNames)
      Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
      DefaultTableModel(Object[] columnNames, int rowCount)
      Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
      DefaultTableModel(Vector columnNames, int rowCount)
      Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
      DefaultTableModel(Vector data, Vector columnNames)
      Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addColumn(Object columnName)
      Adds a column to the model.
      void addColumn(Object columnName, Object[] columnData)
      Adds a column to the model.
      void addColumn(Object columnName, Vector columnData)
      Adds a column to the model.
      void addRow(Object[] rowData)
      Adds a row to the end of the model.
      void addRow(Vector rowData)
      Adds a row to the end of the model.
      protected static Vector convertToVector(Object[] anArray)
      Returns a vector that contains the same objects as the array.
      protected static Vector convertToVector(Object[][] anArray)
      Returns a vector of vectors that contains the same objects as the array.
      int getColumnCount()
      Returns the number of columns in this data table.
      String getColumnName(int column)
      Returns the column name.
      Vector getDataVector()
      Returns the Vector of Vectors that contains the table's data values.
      int getRowCount()
      Returns the number of rows in this data table.
      Object getValueAt(int row, int column)
      Returns an attribute value for the cell at row and column.
      void insertRow(int row, Object[] rowData)
      Inserts a row at row in the model.
      void insertRow(int row, Vector rowData)
      Inserts a row at row in the model.
      boolean isCellEditable(int row, int column)
      Returns true regardless of parameter values.
      void moveRow(int start, int end, int to)
      Moves one or more rows from the inclusive range start to end to the to position in the model.
      void newDataAvailable(TableModelEvent event)
      Equivalent to fireTableChanged.
      void newRowsAdded(TableModelEvent e)
      Ensures that the new rows have the correct number of columns.
      void removeRow(int row)
      Removes the row at row from the model.
      void rowsRemoved(TableModelEvent event)
      Equivalent to fireTableChanged.
      void setColumnCount(int columnCount)
      Sets the number of columns in the model.
      void setColumnIdentifiers(Object[] newIdentifiers)
      Replaces the column identifiers in the model.
      void setColumnIdentifiers(Vector columnIdentifiers)
      Replaces the column identifiers in the model.
      void setDataVector(Object[][] dataVector, Object[] columnIdentifiers)
      Replaces the value in the dataVector instance variable with the values in the array dataVector.
      void setDataVector(Vector dataVector, Vector columnIdentifiers)
      Replaces the current dataVector instance variable with the new Vector of rows, dataVector.
      void setNumRows(int rowCount)
      Obsolete as of Java 2 platform v1.3.
      void setRowCount(int rowCount)
      Sets the number of rows in the model.
      void setValueAt(Object aValue, int row, int column)
      Sets the object value for the cell at column and row.

      • 方法 - 继承于类 javax.swing.table.AbstractTableModel

        addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getColumnClass, getListeners, getTableModelListeners, removeTableModelListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • dataVector

        protected Vector dataVector
        The Vector of Vectors of Object values.

      • columnIdentifiers

        protected Vector columnIdentifiers
        The Vector of column identifiers.

    • 构造方法详细信息

      • DefaultTableModel

        public DefaultTableModel()
        Constructs a default DefaultTableModel which is a table of zero columns and zero rows.

      • DefaultTableModel

        public DefaultTableModel(int rowCount,
                 int columnCount)
        Constructs a DefaultTableModel with rowCount and columnCount of null object values.
        参数：
        rowCount - the number of rows the table holds
        columnCount - the number of columns the table holds
        另请参见：
        setValueAt(java.lang.Object, int, int)

      • DefaultTableModel

        public DefaultTableModel(Vector columnNames,
                 int rowCount)
        Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values. Each column's name will be taken from the columnNames vector.
        参数：
        columnNames - vector containing the names of the new columns; if this is null then the model has no columns
        rowCount - the number of rows the table holds
        另请参见：
        setDataVector(java.util.Vector, java.util.Vector), setValueAt(java.lang.Object, int, int)

      • DefaultTableModel

        public DefaultTableModel(Object[] columnNames,
                 int rowCount)
        Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values. Each column's name will be taken from the columnNames array.
        参数：
        columnNames - array containing the names of the new columns; if this is null then the model has no columns
        rowCount - the number of rows the table holds
        另请参见：
        setDataVector(java.util.Vector, java.util.Vector), setValueAt(java.lang.Object, int, int)

      • DefaultTableModel

        public DefaultTableModel(Vector data,
                 Vector columnNames)
        Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
        参数：
        data - the data of the table, a Vector of Vectors of Object values
        columnNames - vector containing the names of the new columns
        另请参见：
        getDataVector(), setDataVector(java.util.Vector, java.util.Vector)

      • DefaultTableModel

        public DefaultTableModel(Object[][] data,
                 Object[] columnNames)
        Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method. The first index in the Object[][] array is the row index and the second is the column index.
        参数：
        data - the data of the table
        columnNames - the names of the columns
        另请参见：
        getDataVector(), setDataVector(java.util.Vector, java.util.Vector)

    • 方法详细信息

      • getDataVector

        public Vector getDataVector()
        Returns the Vector of Vectors that contains the table's data values. The vectors contained in the outer vector are each a single row of values. In other words, to get to the cell at row 1, column 5:

        ((Vector)getDataVector().elementAt(1)).elementAt(5);

        返回：
        the vector of vectors containing the tables data values
        另请参见：
        newDataAvailable(javax.swing.event.TableModelEvent),
newRowsAdded(javax.swing.event.TableModelEvent),
setDataVector(java.util.Vector, java.util.Vector)

      • setDataVector

        public void setDataVector(Vector dataVector,
                 Vector columnIdentifiers)
        Replaces the current dataVector instance variable with the new Vector of rows, dataVector. Each row is represented in dataVector as a Vector of Object values. columnIdentifiers are the names of the new columns. The first name in columnIdentifiers is mapped to column 0 in dataVector. Each row in dataVector is adjusted to match the number of columns in columnIdentifiers either by truncating the Vector if it is too long, or adding null values if it is too short.

        Note that passing in a null value for dataVector results in unspecified behavior, an possibly an exception.

        参数：
        dataVector - the new data vector
        columnIdentifiers - the names of the columns
        另请参见：
        getDataVector()

      • setDataVector

        public void setDataVector(Object[][] dataVector,
                 Object[] columnIdentifiers)
        Replaces the value in the dataVector instance variable with the values in the array dataVector. The first index in the Object[][] array is the row index and the second is the column index. columnIdentifiers are the names of the new columns.
        参数：
        dataVector - the new data vector
        columnIdentifiers - the names of the columns
        另请参见：
        setDataVector(Vector, Vector)

      • newDataAvailable

        public void newDataAvailable(TableModelEvent event)
        Equivalent to fireTableChanged.
        参数：
        event - the change event

      • newRowsAdded

        public void newRowsAdded(TableModelEvent e)
        Ensures that the new rows have the correct number of columns. This is accomplished by using the setSize method in Vector which truncates vectors which are too long, and appends nulls if they are too short. This method also sends out a tableChanged notification message to all the listeners.
        参数：
        e - this TableModelEvent describes where the rows were added. If null it assumes all the rows were newly added
        另请参见：
        getDataVector()

      • rowsRemoved

        public void rowsRemoved(TableModelEvent event)
        Equivalent to fireTableChanged.
        参数：
        event - the change event

      • setNumRows

        public void setNumRows(int rowCount)
        Obsolete as of Java 2 platform v1.3. Please use setRowCount instead.

      • setRowCount

        public void setRowCount(int rowCount)
        Sets the number of rows in the model. If the new size is greater than the current size, new rows are added to the end of the model If the new size is less than the current size, all rows at index rowCount and greater are discarded.

        从以下版本开始：
        1.3
        另请参见：
        setColumnCount(int)

      • addRow

        public void addRow(Vector rowData)
        Adds a row to the end of the model. The new row will contain null values unless rowData is specified. Notification of the row being added will be generated.
        参数：
        rowData - optional data of the row being added

      • addRow

        public void addRow(Object[] rowData)
        Adds a row to the end of the model. The new row will contain null values unless rowData is specified. Notification of the row being added will be generated.
        参数：
        rowData - optional data of the row being added

      • insertRow

        public void insertRow(int row,
             Vector rowData)
        Inserts a row at row in the model. The new row will contain null values unless rowData is specified. Notification of the row being added will be generated.
        参数：
        row - the row index of the row to be inserted
        rowData - optional data of the row being added
        抛出：
        ArrayIndexOutOfBoundsException - if the row was invalid

      • insertRow

        public void insertRow(int row,
             Object[] rowData)
        Inserts a row at row in the model. The new row will contain null values unless rowData is specified. Notification of the row being added will be generated.
        参数：
        row - the row index of the row to be inserted
        rowData - optional data of the row being added
        抛出：
        ArrayIndexOutOfBoundsException - if the row was invalid

      • moveRow

        public void moveRow(int start,
           int end,
           int to)
        Moves one or more rows from the inclusive range start to end to the to position in the model. After the move, the row that was at index start will be at index to. This method will send a tableChanged notification message to all the listeners.

          Examples of moves:

  1. moveRow(1,3,5);
          a|B|C|D|e|f|g|h|i|j|k   - before
          a|e|f|g|h|B|C|D|i|j|k   - after

  2. moveRow(6,7,1);
          a|b|c|d|e|f|G|H|i|j|k   - before
          a|G|H|b|c|d|e|f|i|j|k   - after
        参数：
        start - the starting row index to be moved
        end - the ending row index to be moved
        to - the destination of the rows to be moved
        抛出：
        ArrayIndexOutOfBoundsException - if any of the elements would be moved out of the table's range

      • removeRow

        public void removeRow(int row)
        Removes the row at row from the model. Notification of the row being removed will be sent to all the listeners.
        参数：
        row - the row index of the row to be removed
        抛出：
        ArrayIndexOutOfBoundsException - if the row was invalid

      • setColumnIdentifiers

        public void setColumnIdentifiers(Vector columnIdentifiers)
        Replaces the column identifiers in the model. If the number of newIdentifiers is greater than the current number of columns, new columns are added to the end of each row in the model. If the number of newIdentifiers is less than the current number of columns, all the extra columns at the end of a row are discarded.

        参数：
        columnIdentifiers - vector of column identifiers. If null, set the model to zero columns
        另请参见：
        setNumRows(int)

      • setColumnIdentifiers

        public void setColumnIdentifiers(Object[] newIdentifiers)
        Replaces the column identifiers in the model. If the number of newIdentifiers is greater than the current number of columns, new columns are added to the end of each row in the model. If the number of newIdentifiers is less than the current number of columns, all the extra columns at the end of a row are discarded.

        参数：
        newIdentifiers - array of column identifiers. If null, set the model to zero columns
        另请参见：
        setNumRows(int)

      • setColumnCount

        public void setColumnCount(int columnCount)
        Sets the number of columns in the model. If the new size is greater than the current size, new columns are added to the end of the model with null cell values. If the new size is less than the current size, all columns at index columnCount and greater are discarded.
        参数：
        columnCount - the new number of columns in the model
        从以下版本开始：
        1.3
        另请参见：
        setColumnCount(int)

      • addColumn

        public void addColumn(Object columnName)
        Adds a column to the model. The new column will have the identifier columnName, which may be null. This method will send a tableChanged notification message to all the listeners. This method is a cover for addColumn(Object, Vector) which uses null as the data vector.
        参数：
        columnName - the identifier of the column being added

      • addColumn

        public void addColumn(Object columnName,
             Vector columnData)
        Adds a column to the model. The new column will have the identifier columnName, which may be null. columnData is the optional vector of data for the column. If it is null the column is filled with null values. Otherwise, the new data will be added to model starting with the first element going to row 0, etc. This method will send a tableChanged notification message to all the listeners.
        参数：
        columnName - the identifier of the column being added
        columnData - optional data of the column being added

      • addColumn

        public void addColumn(Object columnName,
             Object[] columnData)
        Adds a column to the model. The new column will have the identifier columnName. columnData is the optional array of data for the column. If it is null the column is filled with null values. Otherwise, the new data will be added to model starting with the first element going to row 0, etc. This method will send a tableChanged notification message to all the listeners.
        另请参见：
        addColumn(Object, Vector)

      • getRowCount

        public int getRowCount()
        Returns the number of rows in this data table.
        指定者：
        getRowCount in interface TableModel
        返回：
        the number of rows in the model
        另请参见：
        TableModel.getColumnCount()

      • getColumnCount

        public int getColumnCount()
        Returns the number of columns in this data table.
        指定者：
        getColumnCount in interface TableModel
        返回：
        the number of columns in the model
        另请参见：
        TableModel.getRowCount()

      • getColumnName

        public String getColumnName(int column)
        Returns the column name.
        指定者：
        getColumnName in interface TableModel
        重载：
        getColumnName in class AbstractTableModel
        参数：
        column - the column being queried
        返回：
        a name for this column using the string value of the appropriate member in columnIdentifiers. If columnIdentifiers does not have an entry for this index, returns the default name provided by the superclass.

      • isCellEditable

        public boolean isCellEditable(int row,
                     int column)
        Returns true regardless of parameter values.
        指定者：
        isCellEditable in interface TableModel
        重载：
        isCellEditable in class AbstractTableModel
        参数：
        row - the row whose value is to be queried
        column - the column whose value is to be queried
        返回：
        true
        另请参见：
        setValueAt(java.lang.Object, int, int)

      • getValueAt

        public Object getValueAt(int row,
                int column)
        Returns an attribute value for the cell at row and column.
        指定者：
        getValueAt in interface TableModel
        参数：
        row - the row whose value is to be queried
        column - the column whose value is to be queried
        返回：
        the value Object at the specified cell
        抛出：
        ArrayIndexOutOfBoundsException - if an invalid row or column was given

      • setValueAt

        public void setValueAt(Object aValue,
              int row,
              int column)
        Sets the object value for the cell at column and row. aValue is the new value. This method will generate a tableChanged notification.
        指定者：
        setValueAt in interface TableModel
        重载：
        setValueAt in class AbstractTableModel
        参数：
        aValue - the new value; this can be null
        row - the row whose value is to be changed
        column - the column whose value is to be changed
        抛出：
        ArrayIndexOutOfBoundsException - if an invalid row or column was given
        另请参见：
        TableModel.getValueAt(int, int), TableModel.isCellEditable(int, int)

      • convertToVector

        protected static Vector convertToVector(Object[] anArray)
        Returns a vector that contains the same objects as the array.
        参数：
        anArray - the array to be converted
        返回：
        the new vector; if anArray is null, returns null

      • convertToVector

        protected static Vector convertToVector(Object[][] anArray)
        Returns a vector of vectors that contains the same objects as the array.
        参数：
        anArray - the double array to be converted
        返回：
        the new vector of vectors; if anArray is null, returns null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.swing.table

Interfaces

  • TableCellEditor
  • TableCellRenderer
  • TableColumnModel
  • TableModel

Classes

  • AbstractTableModel
  • DefaultTableCellRenderer
  • DefaultTableCellRenderer.UIResource
  • DefaultTableColumnModel
  • DefaultTableModel
  • JTableHeader
  • TableColumn
  • TableRowSorter
  • TableStringConverter
e


javax.swing.table

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.table

Provides classes and interfaces for dealing with javax.swing.JTable.

请参见： 描述

  • 接口摘要
    接口 描述
    TableCellEditor
    This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.
    TableCellRenderer
    This interface defines the method required by any object that would like to be a renderer for cells in a JTable.
    TableColumnModel
    Defines the requirements for a table column model object suitable for use with JTable.
    TableModel
    The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.
  • Class Summary
    类 描述
    AbstractTableModel
    This abstract class provides default implementations for most of the methods in the TableModel interface.
    DefaultTableCellRenderer
    The standard class for rendering (displaying) individual cells in a JTable.
    DefaultTableCellRenderer.UIResource
    A subclass of DefaultTableCellRenderer that implements UIResource.
    DefaultTableColumnModel
    The standard column-handler for a JTable.
    DefaultTableModel
    This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.
    JTableHeader
    This is the object which manages the header of the JTable.
    TableColumn
    A TableColumn represents all the attributes of a column in a JTable, such as width, resizibility, minimum and maximum width.
    TableRowSorter<M extends TableModel>
    An implementation of RowSorter that provides sorting and filtering using a TableModel.
    TableStringConverter
    TableStringConverter is used to convert objects from the model into strings.

软件包 javax.swing.table Description

Provides classes and interfaces for dealing with javax.swing.JTable. JTable is Swing's grid or tabular view for constructing user interfaces for tabular data structures inside an application. Use this package if you want control over how tables are constructed, updated, and rendered, as well as how data associated with the tables are viewed and managed.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use Tables, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ucootHttfn<


javax.swing.table Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.table

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • javax.swing.table.DefaultTableModel (implements java.io.Serializable)
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.table.DefaultTableCellRenderer (implements java.io.Serializable, javax.swing.table.TableCellRenderer)
              • javax.swing.table.DefaultTableCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.table.JTableHeader (implements javax.accessibility.Accessible, javax.swing.event.TableColumnModelListener)
    • javax.swing.table.DefaultTableColumnModel (implements javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, java.io.Serializable, javax.swing.table.TableColumnModel)
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
        • javax.swing.table.TableRowSorter<M>
    • javax.swing.table.TableColumn (implements java.io.Serializable)
    • javax.swing.table.TableStringConverter

Interface Hierarchy

  • javax.swing.CellEditor
    • javax.swing.table.TableCellEditor
  • javax.swing.table.TableCellRenderer
  • javax.swing.table.TableColumnModel
  • javax.swing.table.TableModel
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eta_li>t/_


JTableHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 JTableHeader

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.table.JTableHeader
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, EventListener, Accessible, TableColumnModelListener

    public class JTableHeader
extends JComponent
implements TableColumnModelListener, Accessible
    This is the object which manages the header of the JTable.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTable

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTableHeader.AccessibleJTableHeader
      This class implements accessibility support for the JTableHeader class.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected TableColumnModel columnModel
      The TableColumnModel of the table header.
      protected TableColumn draggedColumn
      The index of the column being dragged.
      protected int draggedDistance
      The distance from its original position the column has been dragged.
      protected boolean reorderingAllowed
      If true, reordering of columns are allowed by the user; the default is true.
      protected boolean resizingAllowed
      If true, resizing of columns are allowed by the user; the default is true.
      protected TableColumn resizingColumn
      The index of the column being resized.
      protected JTable table
      The table for which this object is the header; the default is null.
      protected boolean updateTableInRealTime
      Obsolete as of Java 2 platform v1.3.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTableHeader()
      Constructs a JTableHeader with a default TableColumnModel.
      JTableHeader(TableColumnModel cm)
      Constructs a JTableHeader which is initialized with cm as the column model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void columnAdded(TableColumnModelEvent e)
      Invoked when a column is added to the table column model.
      int columnAtPoint(Point point)
      Returns the index of the column that point lies in, or -1 if it lies out of bounds.
      void columnMarginChanged(ChangeEvent e)
      Invoked when a column is moved due to a margin change.
      void columnMoved(TableColumnModelEvent e)
      Invoked when a column is repositioned.
      void columnRemoved(TableColumnModelEvent e)
      Invoked when a column is removed from the table column model.
      void columnSelectionChanged(ListSelectionEvent e)
      Invoked when the selection model of the TableColumnModel is changed.
      protected TableColumnModel createDefaultColumnModel()
      Returns the default column model object which is a DefaultTableColumnModel.
      protected TableCellRenderer createDefaultRenderer()
      Returns a default renderer to be used when no header renderer is defined by a TableColumn.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTableHeader.
      TableColumnModel getColumnModel()
      Returns the TableColumnModel that contains all column information of this table header.
      TableCellRenderer getDefaultRenderer()
      Returns the default renderer used when no headerRenderer is defined by a TableColumn.
      TableColumn getDraggedColumn()
      Returns the the dragged column, if and only if, a drag is in process, otherwise returns null.
      int getDraggedDistance()
      Returns the column's horizontal distance from its original position, if and only if, a drag is in process.
      Rectangle getHeaderRect(int column)
      Returns the rectangle containing the header tile at column.
      boolean getReorderingAllowed()
      Returns true if the user is allowed to rearrange columns by dragging their headers, false otherwise.
      boolean getResizingAllowed()
      Returns true if the user is allowed to resize columns by dragging between their headers, false otherwise.
      TableColumn getResizingColumn()
      Returns the resizing column.
      JTable getTable()
      Returns the table associated with this header.
      String getToolTipText(MouseEvent event)
      Allows the renderer's tips to be used if there is text set.
      TableHeaderUI getUI()
      Returns the look and feel (L&F) object that renders this component.
      String getUIClassID()
      Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.
      boolean getUpdateTableInRealTime()
      Obsolete as of Java 2 platform v1.3.
      protected void initializeLocalVars()
      Initializes the local variables and properties with default values.
      protected String paramString()
      Returns a string representation of this JTableHeader.
      void resizeAndRepaint()
      Sizes the header and marks it as needing display.
      void setColumnModel(TableColumnModel columnModel)
      Sets the column model for this table to newModel and registers for listener notifications from the new column model.
      void setDefaultRenderer(TableCellRenderer defaultRenderer)
      Sets the default renderer to be used when no headerRenderer is defined by a TableColumn.
      void setDraggedColumn(TableColumn aColumn)
      Sets the header's draggedColumn to aColumn.
      void setDraggedDistance(int distance)
      Sets the header's draggedDistance to distance.
      void setReorderingAllowed(boolean reorderingAllowed)
      Sets whether the user can drag column headers to reorder columns.
      void setResizingAllowed(boolean resizingAllowed)
      Sets whether the user can resize columns by dragging between headers.
      void setResizingColumn(TableColumn aColumn)
      Sets the header's resizingColumn to aColumn.
      void setTable(JTable table)
      Sets the table associated with this header.
      void setUI(TableHeaderUI ui)
      Sets the look and feel (L&F) object that renders this component.
      void setUpdateTableInRealTime(boolean flag)
      Obsolete as of Java 2 platform v1.3.
      void updateUI()
      Notification from the UIManager that the look and feel (L&F) has changed.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • table

        protected JTable table
        The table for which this object is the header; the default is null.

      • columnModel

        protected TableColumnModel columnModel
        The TableColumnModel of the table header.

      • reorderingAllowed

        protected boolean reorderingAllowed
        If true, reordering of columns are allowed by the user; the default is true.

      • resizingAllowed

        protected boolean resizingAllowed
        If true, resizing of columns are allowed by the user; the default is true.

      • updateTableInRealTime

        protected boolean updateTableInRealTime
        Obsolete as of Java 2 platform v1.3. Real time repaints, in response to column dragging or resizing, are now unconditional.

      • resizingColumn

        protected transient TableColumn resizingColumn
        The index of the column being resized. null if not resizing.

      • draggedColumn

        protected transient TableColumn draggedColumn
        The index of the column being dragged. null if not dragging.

      • draggedDistance

        protected transient int draggedDistance
        The distance from its original position the column has been dragged.

    • 构造方法详细信息

      • JTableHeader

        public JTableHeader()
        Constructs a JTableHeader with a default TableColumnModel.
        另请参见：
        createDefaultColumnModel()

      • JTableHeader

        public JTableHeader(TableColumnModel cm)
        Constructs a JTableHeader which is initialized with cm as the column model. If cm is null this method will initialize the table header with a default TableColumnModel.
        参数：
        cm - the column model for the table
        另请参见：
        createDefaultColumnModel()

    • 方法详细信息

      • setTable

        public void setTable(JTable table)
        Sets the table associated with this header.
        参数：
        table - the new table

      • getTable

        public JTable getTable()
        Returns the table associated with this header.
        返回：
        the table property

      • setReorderingAllowed

        public void setReorderingAllowed(boolean reorderingAllowed)
        Sets whether the user can drag column headers to reorder columns.
        参数：
        reorderingAllowed - true if the table view should allow reordering; otherwise false
        另请参见：
        getReorderingAllowed()

      • getReorderingAllowed

        public boolean getReorderingAllowed()
        Returns true if the user is allowed to rearrange columns by dragging their headers, false otherwise. The default is true. You can rearrange columns programmatically regardless of this setting.
        返回：
        the reorderingAllowed property
        另请参见：
        setReorderingAllowed(boolean)

      • setResizingAllowed

        public void setResizingAllowed(boolean resizingAllowed)
        Sets whether the user can resize columns by dragging between headers.
        参数：
        resizingAllowed - true if table view should allow resizing
        另请参见：
        getResizingAllowed()

      • getResizingAllowed

        public boolean getResizingAllowed()
        Returns true if the user is allowed to resize columns by dragging between their headers, false otherwise. The default is true. You can resize columns programmatically regardless of this setting.
        返回：
        the resizingAllowed property
        另请参见：
        setResizingAllowed(boolean)

      • getDraggedColumn

        public TableColumn getDraggedColumn()
        Returns the the dragged column, if and only if, a drag is in process, otherwise returns null.
        返回：
        the dragged column, if a drag is in process, otherwise returns null
        另请参见：
        getDraggedDistance()

      • getDraggedDistance

        public int getDraggedDistance()
        Returns the column's horizontal distance from its original position, if and only if, a drag is in process. Otherwise, the the return value is meaningless.
        返回：
        the column's horizontal distance from its original position, if a drag is in process, otherwise the return value is meaningless
        另请参见：
        getDraggedColumn()

      • getResizingColumn

        public TableColumn getResizingColumn()
        Returns the resizing column. If no column is being resized this method returns null.
        返回：
        the resizing column, if a resize is in process, otherwise returns null

      • setUpdateTableInRealTime

        public void setUpdateTableInRealTime(boolean flag)
        Obsolete as of Java 2 platform v1.3. Real time repaints, in response to column dragging or resizing, are now unconditional.

      • getUpdateTableInRealTime

        public boolean getUpdateTableInRealTime()
        Obsolete as of Java 2 platform v1.3. Real time repaints, in response to column dragging or resizing, are now unconditional.

      • setDefaultRenderer

        public void setDefaultRenderer(TableCellRenderer defaultRenderer)
        Sets the default renderer to be used when no headerRenderer is defined by a TableColumn.
        参数：
        defaultRenderer - the default renderer
        从以下版本开始：
        1.3

      • getDefaultRenderer

        public TableCellRenderer getDefaultRenderer()
        Returns the default renderer used when no headerRenderer is defined by a TableColumn.
        返回：
        the default renderer
        从以下版本开始：
        1.3

      • columnAtPoint

        public int columnAtPoint(Point point)
        Returns the index of the column that point lies in, or -1 if it lies out of bounds.
        返回：
        the index of the column that point lies in, or -1 if it lies out of bounds

      • getHeaderRect

        public Rectangle getHeaderRect(int column)
        Returns the rectangle containing the header tile at column. When the column parameter is out of bounds this method uses the same conventions as the JTable method getCellRect.
        返回：
        the rectangle containing the header tile at column
        另请参见：
        JTable.getCellRect(int, int, boolean)

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Allows the renderer's tips to be used if there is text set.
        重载：
        getToolTipText in class JComponent
        参数：
        event - the location of the event identifies the proper renderer and, therefore, the proper tip
        返回：
        the tool tip for this component

      • getUI

        public TableHeaderUI getUI()
        Returns the look and feel (L&F) object that renders this component.
        返回：
        the TableHeaderUI object that renders this component

      • setUI

        public void setUI(TableHeaderUI ui)
        Sets the look and feel (L&F) object that renders this component.
        参数：
        ui - the TableHeaderUI L&F object
        另请参见：
        UIDefaults.getUI(javax.swing.JComponent)

      • updateUI

        public void updateUI()
        Notification from the UIManager that the look and feel (L&F) has changed. Replaces the current UI object with the latest version from the UIManager.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.updateUI()

      • getUIClassID

        public String getUIClassID()
        Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.
        重载：
        getUIClassID in class JComponent
        返回：
        the string "TableHeaderUI"
        另请参见：
        JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

      • setColumnModel

        public void setColumnModel(TableColumnModel columnModel)
        Sets the column model for this table to newModel and registers for listener notifications from the new column model.
        参数：
        columnModel - the new data source for this table
        抛出：
        IllegalArgumentException - if newModel is null
        另请参见：
        getColumnModel()

      • getColumnModel

        public TableColumnModel getColumnModel()
        Returns the TableColumnModel that contains all column information of this table header.
        返回：
        the columnModel property
        另请参见：
        setColumnModel(javax.swing.table.TableColumnModel)

      • columnAdded

        public void columnAdded(TableColumnModelEvent e)
        Invoked when a column is added to the table column model.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnAdded in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnRemoved

        public void columnRemoved(TableColumnModelEvent e)
        Invoked when a column is removed from the table column model.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnRemoved in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnMoved

        public void columnMoved(TableColumnModelEvent e)
        Invoked when a column is repositioned.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnMoved in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnMarginChanged

        public void columnMarginChanged(ChangeEvent e)
        Invoked when a column is moved due to a margin change.

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnMarginChanged in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • columnSelectionChanged

        public void columnSelectionChanged(ListSelectionEvent e)
        Invoked when the selection model of the TableColumnModel is changed. This method currently has no effect (the header is not redrawn).

        Application code will not use these methods explicitly, they are used internally by JTable.

        指定者：
        columnSelectionChanged in interface TableColumnModelListener
        参数：
        e - the event received
        另请参见：
        TableColumnModelListener

      • createDefaultColumnModel

        protected TableColumnModel createDefaultColumnModel()
        Returns the default column model object which is a DefaultTableColumnModel. A subclass can override this method to return a different column model object
        返回：
        the default column model object

      • createDefaultRenderer

        protected TableCellRenderer createDefaultRenderer()
        Returns a default renderer to be used when no header renderer is defined by a TableColumn.
        返回：
        the default table column renderer
        从以下版本开始：
        1.3

      • initializeLocalVars

        protected void initializeLocalVars()
        Initializes the local variables and properties with default values. Used by the constructor methods.

      • resizeAndRepaint

        public void resizeAndRepaint()
        Sizes the header and marks it as needing display. Equivalent to revalidate followed by repaint.

      • setDraggedColumn

        public void setDraggedColumn(TableColumn aColumn)
        Sets the header's draggedColumn to aColumn.

        Application code will not use this method explicitly, it is used internally by the column dragging mechanism.

        参数：
        aColumn - the column being dragged, or null if no column is being dragged

      • setDraggedDistance

        public void setDraggedDistance(int distance)
        Sets the header's draggedDistance to distance.
        参数：
        distance - the distance dragged

      • setResizingColumn

        public void setResizingColumn(TableColumn aColumn)
        Sets the header's resizingColumn to aColumn.

        Application code will not use this method explicitly, it is used internally by the column sizing mechanism.

        参数：
        aColumn - the column being resized, or null if no column is being resized

      • paramString

        protected String paramString()
        Returns a string representation of this JTableHeader. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.

        Overriding paramString to provide information about the specific new aspects of the JFC components.

        重载：
        paramString in class JComponent
        返回：
        a string representation of this JTableHeader

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTableHeader. For JTableHeaders, the AccessibleContext takes the form of an AccessibleJTableHeader. A new AccessibleJTableHeader instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJTableHeader that serves as the AccessibleContext of this JTableHeader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTableHeader.AccessibleJTableHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 JTableHeader.AccessibleJTableHeader

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
  • 所有已实现的接口：
    Serializable, AccessibleComponent, AccessibleExtendedComponent
    封闭类：
    JTableHeader

    protected class JTableHeader.AccessibleJTableHeader
extends JComponent.AccessibleJComponent
    This class implements accessibility support for the JTableHeader class. It provides an implementation of the Java Accessibility API appropriate to table header user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
      This class provides an implementation of the Java Accessibility API appropropriate for JTableHeader entries.

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JTableHeader.AccessibleJTableHeader()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Return the nth Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children in the object.
      AccessibleRole getAccessibleRole()
      Get the role of this object.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTableHeader.AccessibleJTableHeader

        protected JTableHeader.AccessibleJTableHeader()

    • 方法详细信息

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Get the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        重载：
        getAccessibleAt in class Container.AccessibleAWTContainer
        参数：
        p - The point defining the top-left corner of the Accessible, given in the coordinate space of the object's parent.
        返回：
        the Accessible, if it exists, at the specified location; else null

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Returns the number of accessible children in the object. If all of the children of this object implement Accessible, than this method should return the number of children of this object.
        重载：
        getAccessibleChildrenCount in class JComponent.AccessibleJComponent
        返回：
        the number of accessible children in the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Return the nth Accessible child of the object.
        重载：
        getAccessibleChild in class JComponent.AccessibleJComponent
        参数：
        i - zero-based index of child
        返回：
        the nth Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
  • 所有已实现的接口：
    Accessible, AccessibleComponent
    封闭类：
    JTableHeader.AccessibleJTableHeader

    protected class JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
extends AccessibleContext
implements Accessible, AccessibleComponent
    This class provides an implementation of the Java Accessibility API appropropriate for JTableHeader entries.

    • 字段摘要

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
      Constructs an AccessiblJTableHeaaderEntry

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addFocusListener(FocusListener l)
      Adds the specified focus listener to receive focus events from this component.
      void addPropertyChangeListener(PropertyChangeListener l)
      Adds a PropertyChangeListener to the listener list.
      boolean contains(Point p)
      Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
      AccessibleAction getAccessibleAction()
      Gets the AccessibleAction associated with this object that supports one or more actions.
      Accessible getAccessibleAt(Point p)
      Returns the Accessible child, if one exists, contained at the local coordinate Point.
      Accessible getAccessibleChild(int i)
      Returns the specified Accessible child of the object.
      int getAccessibleChildrenCount()
      Returns the number of accessible children of the object.
      AccessibleComponent getAccessibleComponent()
      Get the AccessibleComponent associated with this object.
      AccessibleContext getAccessibleContext()
      Get the AccessibleContext associated with this object.
      String getAccessibleDescription()
      Gets the accessibleDescription property of this object.
      int getAccessibleIndexInParent()
      Gets the 0-based index of this object in its accessible parent.
      String getAccessibleName()
      Gets the accessibleName property of this object.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleSelection getAccessibleSelection()
      Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of this object.
      AccessibleText getAccessibleText()
      Gets the AccessibleText associated with this object presenting text on the display.
      AccessibleValue getAccessibleValue()
      Gets the AccessibleValue associated with this object that supports a Numerical value.
      Color getBackground()
      Gets the background color of this object.
      Rectangle getBounds()
      Gets the bounds of this object in the form of a Rectangle object.
      Cursor getCursor()
      Gets the Cursor of this object.
      Font getFont()
      Gets the Font of this object.
      FontMetrics getFontMetrics(Font f)
      Gets the FontMetrics of this object.
      Color getForeground()
      Gets the foreground color of this object.
      Locale getLocale()
      Gets the locale of the component.
      Point getLocation()
      Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
      Point getLocationOnScreen()
      Returns the location of the object on the screen.
      Dimension getSize()
      Returns the size of this object in the form of a Dimension object.
      boolean isEnabled()
      Determines if the object is enabled.
      boolean isFocusTraversable()
      Returns whether this object can accept focus or not.
      boolean isShowing()
      Determines if the object is showing.
      boolean isVisible()
      Determines if the object is visible.
      void removeFocusListener(FocusListener l)
      Removes the specified focus listener so it no longer receives focus events from this component.
      void removePropertyChangeListener(PropertyChangeListener l)
      Removes a PropertyChangeListener from the listener list.
      void requestFocus()
      Requests focus for this object.
      void setAccessibleDescription(String s)
      Sets the accessible description of this object.
      void setAccessibleName(String s)
      Sets the localized accessible name of this object.
      void setBackground(Color c)
      Sets the background color of this object.
      void setBounds(Rectangle r)
      Sets the bounds of this object in the form of a Rectangle object.
      void setCursor(Cursor c)
      Sets the Cursor of this object.
      void setEnabled(boolean b)
      Sets the enabled state of the object.
      void setFont(Font f)
      Sets the Font of this object.
      void setForeground(Color c)
      Sets the foreground color of this object.
      void setLocation(Point p)
      Sets the location of the object relative to the parent.
      void setSize(Dimension d)
      Resizes this object so that it has width and height.
      void setVisible(boolean b)
      Sets the visible state of the object.

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

        public JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c,
                                                               JTableHeader p,
                                                               JTable t)
        Constructs an AccessiblJTableHeaaderEntry
        从以下版本开始：
        1.4

    • 方法详细信息

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Get the AccessibleContext associated with this object. In the implementation of the Java Accessibility API for this class, returns this object, which serves as its own AccessibleContext.
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        this object

      • getAccessibleName

        public String getAccessibleName()
        Description copied from class: AccessibleContext
        Gets the accessibleName property of this object. The accessibleName property of an object is a localized String that designates the purpose of the object. For example, the accessibleName property of a label or button might be the text of the label or button itself. In the case of an object that doesn't display its name, the accessibleName should still be set. For example, in the case of a text field used to enter the name of a city, the accessibleName for the en_US locale could be 'city.'
        重载：
        getAccessibleName in class AccessibleContext
        返回：
        the localized name of the object; null if this object does not have a name
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String)

      • setAccessibleName

        public void setAccessibleName(String s)
        Description copied from class: AccessibleContext
        Sets the localized accessible name of this object. Changing the name will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_NAME_PROPERTY property.
        重载：
        setAccessibleName in class AccessibleContext
        参数：
        s - the new localized name of the object.
        另请参见：
        AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleDescription

        public String getAccessibleDescription()
        Description copied from class: AccessibleContext
        Gets the accessibleDescription property of this object. The accessibleDescription property of this object is a short localized phrase describing the purpose of the object. For example, in the case of a 'Cancel' button, the accessibleDescription could be 'Ignore changes and close dialog box.'
        重载：
        getAccessibleDescription in class AccessibleContext
        返回：
        the localized description of the object; null if this object does not have a description
        另请参见：
        AccessibleContext.setAccessibleDescription(java.lang.String)

      • setAccessibleDescription

        public void setAccessibleDescription(String s)
        Description copied from class: AccessibleContext
        Sets the accessible description of this object. Changing the name will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_DESCRIPTION_PROPERTY property.
        重载：
        setAccessibleDescription in class AccessibleContext
        参数：
        s - the new localized description of the object
        另请参见：
        AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Description copied from class: AccessibleContext
        Gets the role of this object. The role of the object is the generic purpose or use of the class of this object. For example, the role of a push button is AccessibleRole.PUSH_BUTTON. The roles in AccessibleRole are provided so component developers can pick from a set of predefined roles. This enables assistive technologies to provide a consistent interface to various tweaked subclasses of components (e.g., use AccessibleRole.PUSH_BUTTON for all components that act like a push button) as well as distinguish between sublasses that behave differently (e.g., AccessibleRole.CHECK_BOX for check boxes and AccessibleRole.RADIO_BUTTON for radio buttons).

        Note that the AccessibleRole class is also extensible, so custom component developers can define their own AccessibleRole's if the set of predefined roles is inadequate.

        指定者：
        getAccessibleRole in class AccessibleContext
        返回：
        an instance of AccessibleRole describing the role of the object
        另请参见：
        AccessibleRole

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Description copied from class: AccessibleContext
        Gets the state set of this object. The AccessibleStateSet of an object is composed of a set of unique AccessibleStates. A change in the AccessibleStateSet of an object will cause a PropertyChangeEvent to be fired for the ACCESSIBLE_STATE_PROPERTY property.
        指定者：
        getAccessibleStateSet in class AccessibleContext
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleIndexInParent

        public int getAccessibleIndexInParent()
        Description copied from class: AccessibleContext
        Gets the 0-based index of this object in its accessible parent.
        指定者：
        getAccessibleIndexInParent in class AccessibleContext
        返回：
        the 0-based index of this object in its parent; -1 if this object does not have an accessible parent.
        另请参见：
        AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

      • getAccessibleChildrenCount

        public int getAccessibleChildrenCount()
        Description copied from class: AccessibleContext
        Returns the number of accessible children of the object.
        指定者：
        getAccessibleChildrenCount in class AccessibleContext
        返回：
        the number of accessible children of the object.

      • getAccessibleChild

        public Accessible getAccessibleChild(int i)
        Description copied from class: AccessibleContext
        Returns the specified Accessible child of the object. The Accessible children of an Accessible object are zero-based, so the first child of an Accessible child is at index 0, the second child is at index 1, and so on.
        指定者：
        getAccessibleChild in class AccessibleContext
        参数：
        i - zero-based index of child
        返回：
        the Accessible child of the object
        另请参见：
        AccessibleContext.getAccessibleChildrenCount()

      • getLocale

        public Locale getLocale()
        Description copied from class: AccessibleContext
        Gets the locale of the component. If the component does not have a locale, then the locale of its parent is returned.
        指定者：
        getLocale in class AccessibleContext
        返回：
        this component's locale. If this component does not have a locale, the locale of its parent is returned.

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener l)
        Description copied from class: AccessibleContext
        Adds a PropertyChangeListener to the listener list. The listener is registered for all Accessible properties and will be called when those properties change.
        重载：
        addPropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be added
        另请参见：
        AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener l)
        Description copied from class: AccessibleContext
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        重载：
        removePropertyChangeListener in class AccessibleContext
        参数：
        l - The PropertyChangeListener to be removed

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Description copied from class: AccessibleContext
        Gets the AccessibleAction associated with this object that supports one or more actions.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        AccessibleAction if supported by object; else return null
        另请参见：
        AccessibleAction

      • getAccessibleComponent

        public AccessibleComponent getAccessibleComponent()
        Get the AccessibleComponent associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleComponent interface on behalf of itself.
        重载：
        getAccessibleComponent in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleComponent

      • getAccessibleSelection

        public AccessibleSelection getAccessibleSelection()
        Description copied from class: AccessibleContext
        Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.
        重载：
        getAccessibleSelection in class AccessibleContext
        返回：
        AccessibleSelection if supported by object; else return null
        另请参见：
        AccessibleSelection

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Description copied from class: AccessibleContext
        Gets the AccessibleText associated with this object presenting text on the display.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        AccessibleText if supported by object; else return null
        另请参见：
        AccessibleText

      • getAccessibleValue

        public AccessibleValue getAccessibleValue()
        Description copied from class: AccessibleContext
        Gets the AccessibleValue associated with this object that supports a Numerical value.
        重载：
        getAccessibleValue in class AccessibleContext
        返回：
        AccessibleValue if supported by object; else return null
        另请参见：
        AccessibleValue

      • getBackground

        public Color getBackground()
        从接口复制的描述： AccessibleComponent
        Gets the background color of this object.
        指定者：
        getBackground in interface AccessibleComponent
        返回：
        the background color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • setBackground

        public void setBackground(Color c)
        从接口复制的描述： AccessibleComponent
        Sets the background color of this object.
        指定者：
        setBackground in interface AccessibleComponent
        参数：
        c - the new Color for the background
        另请参见：
        AccessibleComponent.setBackground(java.awt.Color)

      • getForeground

        public Color getForeground()
        从接口复制的描述： AccessibleComponent
        Gets the foreground color of this object.
        指定者：
        getForeground in interface AccessibleComponent
        返回：
        the foreground color, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setForeground(java.awt.Color)

      • setForeground

        public void setForeground(Color c)
        从接口复制的描述： AccessibleComponent
        Sets the foreground color of this object.
        指定者：
        setForeground in interface AccessibleComponent
        参数：
        c - the new Color for the foreground
        另请参见：
        AccessibleComponent.getForeground()

      • getCursor

        public Cursor getCursor()
        从接口复制的描述： AccessibleComponent
        Gets the Cursor of this object.
        指定者：
        getCursor in interface AccessibleComponent
        返回：
        the Cursor, if supported, of the object; otherwise, null
        另请参见：
        AccessibleComponent.setCursor(java.awt.Cursor)

      • setCursor

        public void setCursor(Cursor c)
        从接口复制的描述： AccessibleComponent
        Sets the Cursor of this object.
        指定者：
        setCursor in interface AccessibleComponent
        参数：
        c - the new Cursor for the object
        另请参见：
        AccessibleComponent.getCursor()

      • getFont

        public Font getFont()
        从接口复制的描述： AccessibleComponent
        Gets the Font of this object.
        指定者：
        getFont in interface AccessibleComponent
        返回：
        the Font,if supported, for the object; otherwise, null
        另请参见：
        AccessibleComponent.setFont(java.awt.Font)

      • setFont

        public void setFont(Font f)
        从接口复制的描述： AccessibleComponent
        Sets the Font of this object.
        指定者：
        setFont in interface AccessibleComponent
        参数：
        f - the new Font for the object
        另请参见：
        AccessibleComponent.getFont()

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        从接口复制的描述： AccessibleComponent
        Gets the FontMetrics of this object.
        指定者：
        getFontMetrics in interface AccessibleComponent
        参数：
        f - the Font
        返回：
        the FontMetrics, if supported, the object; otherwise, null
        另请参见：
        AccessibleComponent.getFont()

      • isEnabled

        public boolean isEnabled()
        从接口复制的描述： AccessibleComponent
        Determines if the object is enabled. Objects that are enabled will also have the AccessibleState.ENABLED state set in their AccessibleStateSets.
        指定者：
        isEnabled in interface AccessibleComponent
        返回：
        true if object is enabled; otherwise, false
        另请参见：
        AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

      • setEnabled

        public void setEnabled(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the enabled state of the object.
        指定者：
        setEnabled in interface AccessibleComponent
        参数：
        b - if true, enables this object; otherwise, disables it
        另请参见：
        AccessibleComponent.isEnabled()

      • isVisible

        public boolean isVisible()
        从接口复制的描述： AccessibleComponent
        Determines if the object is visible. Note: this means that the object intends to be visible; however, it may not be showing on the screen because one of the objects that this object is contained by is currently not visible. To determine if an object is showing on the screen, use isShowing().

        Objects that are visible will also have the AccessibleState.VISIBLE state set in their AccessibleStateSets.

        指定者：
        isVisible in interface AccessibleComponent
        返回：
        true if object is visible; otherwise, false
        另请参见：
        AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

      • setVisible

        public void setVisible(boolean b)
        从接口复制的描述： AccessibleComponent
        Sets the visible state of the object.
        指定者：
        setVisible in interface AccessibleComponent
        参数：
        b - if true, shows this object; otherwise, hides it
        另请参见：
        AccessibleComponent.isVisible()

      • isShowing

        public boolean isShowing()
        从接口复制的描述： AccessibleComponent
        Determines if the object is showing. This is determined by checking the visibility of the object and its ancestors. Note: this will return true even if the object is obscured by another (for example, it is underneath a menu that was pulled down).
        指定者：
        isShowing in interface AccessibleComponent
        返回：
        true if object is showing; otherwise, false

      • contains

        public boolean contains(Point p)
        从接口复制的描述： AccessibleComponent
        Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
        指定者：
        contains in interface AccessibleComponent
        参数：
        p - the Point relative to the coordinate system of the object
        返回：
        true if object contains Point; otherwise false
        另请参见：
        AccessibleComponent.getBounds()

      • getLocationOnScreen

        public Point getLocationOnScreen()
        从接口复制的描述： AccessibleComponent
        Returns the location of the object on the screen.
        指定者：
        getLocationOnScreen in interface AccessibleComponent
        返回：
        the location of the object on screen; null if this object is not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

      • getLocation

        public Point getLocation()
        从接口复制的描述： AccessibleComponent
        Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.
        指定者：
        getLocation in interface AccessibleComponent
        返回：
        An instance of Point representing the top-left corner of the object's bounds in the coordinate space of the screen; null if this object or its parent are not on the screen
        另请参见：
        AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

      • setLocation

        public void setLocation(Point p)
        从接口复制的描述： AccessibleComponent
        Sets the location of the object relative to the parent.
        指定者：
        setLocation in interface AccessibleComponent
        参数：
        p - the new position for the top-left corner
        另请参见：
        AccessibleComponent.getLocation()

      • getBounds

        public Rectangle getBounds()
        从接口复制的描述： AccessibleComponent
        Gets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        getBounds in interface AccessibleComponent
        返回：
        A rectangle indicating this component's bounds; null if this object is not on the screen.
        另请参见：
        AccessibleComponent.contains(java.awt.Point)

      • setBounds

        public void setBounds(Rectangle r)
        从接口复制的描述： AccessibleComponent
        Sets the bounds of this object in the form of a Rectangle object. The bounds specify this object's width, height, and location relative to its parent.
        指定者：
        setBounds in interface AccessibleComponent
        参数：
        r - rectangle indicating this component's bounds
        另请参见：
        AccessibleComponent.getBounds()

      • getSize

        public Dimension getSize()
        从接口复制的描述： AccessibleComponent
        Returns the size of this object in the form of a Dimension object. The height field of the Dimension object contains this object's height, and the width field of the Dimension object contains this object's width.
        指定者：
        getSize in interface AccessibleComponent
        返回：
        A Dimension object that indicates the size of this component; null if this object is not on the screen
        另请参见：
        AccessibleComponent.setSize(java.awt.Dimension)

      • setSize

        public void setSize(Dimension d)
        从接口复制的描述： AccessibleComponent
        Resizes this object so that it has width and height.
        指定者：
        setSize in interface AccessibleComponent
        参数：
        d - The dimension specifying the new size of the object.
        另请参见：
        AccessibleComponent.getSize()

      • getAccessibleAt

        public Accessible getAccessibleAt(Point p)
        从接口复制的描述： AccessibleComponent
        Returns the Accessible child, if one exists, contained at the local coordinate Point.
        指定者：
        getAccessibleAt in interface AccessibleComponent
        参数：
        p - The point relative to the coordinate system of this object.
        返回：
        the Accessible, if it exists, at the specified location; otherwise null

      • isFocusTraversable

        public boolean isFocusTraversable()
        从接口复制的描述： AccessibleComponent
        Returns whether this object can accept focus or not. Objects that can accept focus will also have the AccessibleState.FOCUSABLE state set in their AccessibleStateSets.
        指定者：
        isFocusTraversable in interface AccessibleComponent
        返回：
        true if object can accept focus; otherwise false
        另请参见：
        AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

      • requestFocus

        public void requestFocus()
        从接口复制的描述： AccessibleComponent
        Requests focus for this object. If this object cannot accept focus, nothing will happen. Otherwise, the object will attempt to take focus.
        指定者：
        requestFocus in interface AccessibleComponent
        另请参见：
        AccessibleComponent.isFocusTraversable()

      • addFocusListener

        public void addFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Adds the specified focus listener to receive focus events from this component.
        指定者：
        addFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

      • removeFocusListener

        public void removeFocusListener(FocusListener l)
        从接口复制的描述： AccessibleComponent
        Removes the specified focus listener so it no longer receives focus events from this component.
        指定者：
        removeFocusListener in interface AccessibleComponent
        参数：
        l - the focus listener
        另请参见：
        AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


TableCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.table

Interface TableCellEditor

  • All Superinterfaces:
    CellEditor
    All Known Implementing Classes:
    DefaultCellEditor

    public interface TableCellEditor
extends CellEditor
    This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
      Sets an initial value for the editor.

      • 方法 - 继承于接口 javax.swing.CellEditor

        addCellEditorListener, cancelCellEditing, getCellEditorValue, isCellEditable, removeCellEditorListener, shouldSelectCell, stopCellEditing

    • 方法详细信息

      • getTableCellEditorComponent

        Component getTableCellEditorComponent(JTable table,
                                    Object value,
                                    boolean isSelected,
                                    int row,
                                    int column)
        Sets an initial value for the editor. This will cause the editor to stopEditing and lose any partially edited value if the editor is editing when this method is called.

        Returns the component that should be added to the client's Component hierarchy. Once installed in the client's hierarchy this component will then be able to draw and receive user input.

        参数：
        table - the JTable that is asking the editor to edit; can be null
        value - the value of the cell to be edited; it is up to the specific editor to interpret and draw the value. For example, if value is the string "true", it could be rendered as a string or it could be rendered as a check box that is checked. null is a valid value
        isSelected - true if the cell is to be rendered with highlighting
        row - the row of the cell being edited
        column - the column of the cell being edited
        返回：
        the component for editing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpi//l/ai /


TableCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.table

Interface TableCellRenderer

  • All Known Implementing Classes:
    DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource

    public interface TableCellRenderer
    This interface defines the method required by any object that would like to be a renderer for cells in a JTable.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
      Returns the component used for drawing the cell.

    • 方法详细信息

      • getTableCellRendererComponent

        Component getTableCellRendererComponent(JTable table,
                                      Object value,
                                      boolean isSelected,
                                      boolean hasFocus,
                                      int row,
                                      int column)
        Returns the component used for drawing the cell. This method is used to configure the renderer appropriately before drawing.

        The TableCellRenderer is also responsible for rendering the the cell representing the table's current DnD drop location if it has one. If this renderer cares about rendering the DnD drop location, it should query the table directly to see if the given row and column represent the drop location:

             JTable.DropLocation dropLocation = table.getDropLocation();
     if (dropLocation != null
             && !dropLocation.isInsertRow()
             && !dropLocation.isInsertColumn()
             && dropLocation.getRow() == row
             && dropLocation.getColumn() == column) {

         // this cell represents the current drop location
         // so render it specially, perhaps with a different color
     }

        During a printing operation, this method will be called with isSelected and hasFocus values of false to prevent selection and focus from appearing in the printed output. To do other customization based on whether or not the table is being printed, check the return value from JComponent.isPaintingForPrint().

        参数：
        table - the JTable that is asking the renderer to draw; can be null
        value - the value of the cell to be rendered. It is up to the specific renderer to interpret and draw the value. For example, if value is the string "true", it could be rendered as a string or it could be rendered as a check box that is checked. null is a valid value
        isSelected - true if the cell is to be rendered with the selection highlighted; otherwise false
        hasFocus - if true, render cell appropriately. For example, put a special border on the cell, if the cell can be edited, render in the color used to indicate editing
        row - the row index of the cell being drawn. When drawing the header, the value of row is -1
        column - the column index of the cell being drawn
        另请参见：
        JComponent.isPaintingForPrint()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=s"afe""vl s >l>es竤a/


TableColumn

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 TableColumn

  • java.lang.Object
    • javax.swing.table.TableColumn
  • 所有已实现的接口：
    Serializable

    public class TableColumn
extends Object
implements Serializable
    A TableColumn represents all the attributes of a column in a JTable, such as width, resizibility, minimum and maximum width. In addition, the TableColumn provides slots for a renderer and an editor that can be used to display and edit the values in this column.

    It is also possible to specify renderers and editors on a per type basis rather than a per column basis - see the setDefaultRenderer method in the JTable class. This default mechanism is only used when the renderer (or editor) in the TableColumn is null.

    The TableColumn stores the link between the columns in the JTable and the columns in the TableModel. The modelIndex is the column in the TableModel, which will be queried for the data values for the cells in this column. As the column moves around in the view this modelIndex does not change.

    Note: Some implementations may assume that all TableColumnModels are unique, therefore we would recommend that the same TableColumn instance not be added more than once to a TableColumnModel. To show TableColumns with the same column of data from the model, create a new instance with the same modelIndex.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    TableColumnModel,
DefaultTableColumnModel,
JTableHeader.getDefaultRenderer(),
JTable.getDefaultRenderer(Class),
JTable.getDefaultEditor(Class),
JTable.getCellRenderer(int, int),
JTable.getCellEditor(int, int)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CELL_RENDERER_PROPERTY
      Obsolete as of Java 2 platform v1.3.
      protected TableCellEditor cellEditor
      The editor used to edit the data cells of the column.
      protected TableCellRenderer cellRenderer
      The renderer used to draw the data cells of the column.
      static String COLUMN_WIDTH_PROPERTY
      Obsolete as of Java 2 platform v1.3.
      static String HEADER_RENDERER_PROPERTY
      Obsolete as of Java 2 platform v1.3.
      static String HEADER_VALUE_PROPERTY
      Obsolete as of Java 2 platform v1.3.
      protected TableCellRenderer headerRenderer
      The renderer used to draw the header of the column.
      protected Object headerValue
      The header value of the column.
      protected Object identifier
      This object is not used internally by the drawing machinery of the JTable; identifiers may be set in the TableColumn as as an optional way to tag and locate table columns.
      protected boolean isResizable
      If true, the user is allowed to resize the column; the default is true.
      protected int maxWidth
      The maximum width of the column.
      protected int minWidth
      The minimum width of the column.
      protected int modelIndex
      The index of the column in the model which is to be displayed by this TableColumn.
      protected int resizedPostingDisableCount
      Deprecated.
      as of Java 2 platform v1.3
      protected int width
      The width of the column.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableColumn()
      Cover method, using a default model index of 0, default width of 75, a null renderer and a null editor.
      TableColumn(int modelIndex)
      Cover method, using a default width of 75, a null renderer and a null editor.
      TableColumn(int modelIndex, int width)
      Cover method, using a null renderer and a null editor.
      TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
      Creates and initializes an instance of TableColumn with the specified model index, width, cell renderer, and cell editor; all TableColumn constructors delegate to this one.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      protected TableCellRenderer createDefaultHeaderRenderer()
      As of Java 2 platform v1.3, this method is not called by the TableColumn constructor.
      void disableResizedPosting()
      Deprecated.
      as of Java 2 platform v1.3
      void enableResizedPosting()
      Deprecated.
      as of Java 2 platform v1.3
      TableCellEditor getCellEditor()
      Returns the TableCellEditor used by the JTable to edit values for this column.
      TableCellRenderer getCellRenderer()
      Returns the TableCellRenderer used by the JTable to draw values for this column.
      TableCellRenderer getHeaderRenderer()
      Returns the TableCellRenderer used to draw the header of the TableColumn.
      Object getHeaderValue()
      Returns the Object used as the value for the header renderer.
      Object getIdentifier()
      Returns the identifier object for this column.
      int getMaxWidth()
      Returns the maximum width for the TableColumn.
      int getMinWidth()
      Returns the minimum width for the TableColumn.
      int getModelIndex()
      Returns the model index for this column.
      int getPreferredWidth()
      Returns the preferred width of the TableColumn.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the PropertyChangeListeners added to this TableColumn with addPropertyChangeListener().
      boolean getResizable()
      Returns true if the user is allowed to resize the TableColumn's width, false otherwise.
      int getWidth()
      Returns the width of the TableColumn.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void setCellEditor(TableCellEditor cellEditor)
      Sets the editor to used by when a cell in this column is edited.
      void setCellRenderer(TableCellRenderer cellRenderer)
      Sets the TableCellRenderer used by JTable to draw individual values for this column.
      void setHeaderRenderer(TableCellRenderer headerRenderer)
      Sets the TableCellRenderer used to draw the TableColumn's header to headerRenderer.
      void setHeaderValue(Object headerValue)
      Sets the Object whose string representation will be used as the value for the headerRenderer.
      void setIdentifier(Object identifier)
      Sets the TableColumn's identifier to anIdentifier.
      void setMaxWidth(int maxWidth)
      Sets the TableColumn's maximum width to maxWidth or, if maxWidth is less than the minimum width, to the minimum width.
      void setMinWidth(int minWidth)
      Sets the TableColumn's minimum width to minWidth, adjusting the new minimum width if necessary to ensure that 0 <= minWidth <= maxWidth.
      void setModelIndex(int modelIndex)
      Sets the model index for this column.
      void setPreferredWidth(int preferredWidth)
      Sets this column's preferred width to preferredWidth.
      void setResizable(boolean isResizable)
      Sets whether this column can be resized.
      void setWidth(int width)
      This method should not be used to set the widths of columns in the JTable, use setPreferredWidth instead.
      void sizeWidthToFit()
      Resizes the TableColumn to fit the width of its header cell.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • COLUMN_WIDTH_PROPERTY

        public static final String COLUMN_WIDTH_PROPERTY
        Obsolete as of Java 2 platform v1.3. Please use string literals to identify properties.
        另请参见：
        Constant Field Values

      • HEADER_VALUE_PROPERTY

        public static final String HEADER_VALUE_PROPERTY
        Obsolete as of Java 2 platform v1.3. Please use string literals to identify properties.
        另请参见：
        Constant Field Values

      • HEADER_RENDERER_PROPERTY

        public static final String HEADER_RENDERER_PROPERTY
        Obsolete as of Java 2 platform v1.3. Please use string literals to identify properties.
        另请参见：
        Constant Field Values

      • CELL_RENDERER_PROPERTY

        public static final String CELL_RENDERER_PROPERTY
        Obsolete as of Java 2 platform v1.3. Please use string literals to identify properties.
        另请参见：
        Constant Field Values

      • modelIndex

        protected int modelIndex
        The index of the column in the model which is to be displayed by this TableColumn. As columns are moved around in the view modelIndex remains constant.

      • identifier

        protected Object identifier
        This object is not used internally by the drawing machinery of the JTable; identifiers may be set in the TableColumn as as an optional way to tag and locate table columns. The table package does not modify or invoke any methods in these identifier objects other than the equals method which is used in the getColumnIndex() method in the DefaultTableColumnModel.

      • width

        protected int width
        The width of the column.

      • minWidth

        protected int minWidth
        The minimum width of the column.

      • maxWidth

        protected int maxWidth
        The maximum width of the column.

      • headerRenderer

        protected TableCellRenderer headerRenderer
        The renderer used to draw the header of the column.

      • headerValue

        protected Object headerValue
        The header value of the column.

      • cellRenderer

        protected TableCellRenderer cellRenderer
        The renderer used to draw the data cells of the column.

      • cellEditor

        protected TableCellEditor cellEditor
        The editor used to edit the data cells of the column.

      • isResizable

        protected boolean isResizable
        If true, the user is allowed to resize the column; the default is true.

      • resizedPostingDisableCount

        @Deprecated
protected transient int resizedPostingDisableCount
        Deprecated. as of Java 2 platform v1.3
        This field was not used in previous releases and there are currently no plans to support it in the future.

    • 构造方法详细信息

      • TableColumn

        public TableColumn()
        Cover method, using a default model index of 0, default width of 75, a null renderer and a null editor. This method is intended for serialization.
        另请参见：
        TableColumn(int, int, TableCellRenderer, TableCellEditor)

      • TableColumn

        public TableColumn(int modelIndex)
        Cover method, using a default width of 75, a null renderer and a null editor.
        另请参见：
        TableColumn(int, int, TableCellRenderer, TableCellEditor)

      • TableColumn

        public TableColumn(int modelIndex,
           int width)
        Cover method, using a null renderer and a null editor.
        另请参见：
        TableColumn(int, int, TableCellRenderer, TableCellEditor)

      • TableColumn

        public TableColumn(int modelIndex,
           int width,
           TableCellRenderer cellRenderer,
           TableCellEditor cellEditor)
        Creates and initializes an instance of TableColumn with the specified model index, width, cell renderer, and cell editor; all TableColumn constructors delegate to this one. The value of width is used for both the initial and preferred width; if width is negative, they're set to 0. The minimum width is set to 15 unless the initial width is less, in which case the minimum width is set to the initial width.

        When the cellRenderer or cellEditor parameter is null, a default value provided by the JTable getDefaultRenderer or getDefaultEditor method, respectively, is used to provide defaults based on the type of the data in this column. This column-centric rendering strategy can be circumvented by overriding the getCellRenderer methods in JTable.

        参数：
        modelIndex - the index of the column in the model that supplies the data for this column in the table; the model index remains the same even when columns are reordered in the view
        width - this column's preferred width and initial width
        cellRenderer - the object used to render values in this column
        cellEditor - the object used to edit values in this column
        另请参见：
        getMinWidth(),
JTable.getDefaultRenderer(Class),
JTable.getDefaultEditor(Class),
JTable.getCellRenderer(int, int),
JTable.getCellEditor(int, int)

    • 方法详细信息

      • setModelIndex

        public void setModelIndex(int modelIndex)
        Sets the model index for this column. The model index is the index of the column in the model that will be displayed by this TableColumn. As the TableColumn is moved around in the view the model index remains constant.
        参数：
        modelIndex - the new modelIndex

      • getModelIndex

        public int getModelIndex()
        Returns the model index for this column.
        返回：
        the modelIndex property

      • setIdentifier

        public void setIdentifier(Object identifier)
        Sets the TableColumn's identifier to anIdentifier.

        Note: identifiers are not used by the JTable, they are purely a convenience for the external tagging and location of columns.

        参数：
        identifier - an identifier for this column
        另请参见：
        getIdentifier()

      • getIdentifier

        public Object getIdentifier()
        Returns the identifier object for this column. Note identifiers are not used by JTable, they are purely a convenience for external use. If the identifier is null, getIdentifier() returns getHeaderValue as a default.
        返回：
        the identifier property
        另请参见：
        setIdentifier(java.lang.Object)

      • setHeaderValue

        public void setHeaderValue(Object headerValue)
        Sets the Object whose string representation will be used as the value for the headerRenderer. When the TableColumn is created, the default headerValue is null.
        参数：
        headerValue - the new headerValue
        另请参见：
        getHeaderValue()

      • getHeaderValue

        public Object getHeaderValue()
        Returns the Object used as the value for the header renderer.
        返回：
        the headerValue property
        另请参见：
        setHeaderValue(java.lang.Object)

      • setHeaderRenderer

        public void setHeaderRenderer(TableCellRenderer headerRenderer)
        Sets the TableCellRenderer used to draw the TableColumn's header to headerRenderer.

        It is the header renderers responsibility to render the sorting indicator. If you are using sorting and specify a renderer your renderer must render the sorting indication.

        参数：
        headerRenderer - the new headerRenderer
        另请参见：
        getHeaderRenderer()

      • getHeaderRenderer

        public TableCellRenderer getHeaderRenderer()
        Returns the TableCellRenderer used to draw the header of the TableColumn. When the headerRenderer is null, the JTableHeader uses its defaultRenderer. The default value for a headerRenderer is null.
        返回：
        the headerRenderer property
        另请参见：
        setHeaderRenderer(javax.swing.table.TableCellRenderer),
setHeaderValue(java.lang.Object),
JTableHeader.getDefaultRenderer()

      • setCellRenderer

        public void setCellRenderer(TableCellRenderer cellRenderer)
        Sets the TableCellRenderer used by JTable to draw individual values for this column.
        参数：
        cellRenderer - the new cellRenderer
        另请参见：
        getCellRenderer()

      • getCellRenderer

        public TableCellRenderer getCellRenderer()
        Returns the TableCellRenderer used by the JTable to draw values for this column. The cellRenderer of the column not only controls the visual look for the column, but is also used to interpret the value object supplied by the TableModel. When the cellRenderer is null, the JTable uses a default renderer based on the class of the cells in that column. The default value for a cellRenderer is null.
        返回：
        the cellRenderer property
        另请参见：
        setCellRenderer(javax.swing.table.TableCellRenderer), JTable.setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

      • setCellEditor

        public void setCellEditor(TableCellEditor cellEditor)
        Sets the editor to used by when a cell in this column is edited.
        参数：
        cellEditor - the new cellEditor
        另请参见：
        getCellEditor()

      • getCellEditor

        public TableCellEditor getCellEditor()
        Returns the TableCellEditor used by the JTable to edit values for this column. When the cellEditor is null, the JTable uses a default editor based on the class of the cells in that column. The default value for a cellEditor is null.
        返回：
        the cellEditor property
        另请参见：
        setCellEditor(javax.swing.table.TableCellEditor), JTable.setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor)

      • setWidth

        public void setWidth(int width)
        This method should not be used to set the widths of columns in the JTable, use setPreferredWidth instead. Like a layout manager in the AWT, the JTable adjusts a column's width automatically whenever the table itself changes size, or a column's preferred width is changed. Setting widths programmatically therefore has no long term effect.

        This method sets this column's width to width. If width exceeds the minimum or maximum width, it is adjusted to the appropriate limiting value.

        参数：
        width - the new width
        另请参见：
        getWidth(), setMinWidth(int), setMaxWidth(int), setPreferredWidth(int), JTable.doLayout()

      • getWidth

        public int getWidth()
        Returns the width of the TableColumn. The default width is 75.
        返回：
        the width property
        另请参见：
        setWidth(int)

      • setPreferredWidth

        public void setPreferredWidth(int preferredWidth)
        Sets this column's preferred width to preferredWidth. If preferredWidth exceeds the minimum or maximum width, it is adjusted to the appropriate limiting value.

        For details on how the widths of columns in the JTable (and JTableHeader) are calculated from the preferredWidth, see the doLayout method in JTable.

        参数：
        preferredWidth - the new preferred width
        另请参见：
        getPreferredWidth(), JTable.doLayout()

      • getPreferredWidth

        public int getPreferredWidth()
        Returns the preferred width of the TableColumn. The default preferred width is 75.
        返回：
        the preferredWidth property
        另请参见：
        setPreferredWidth(int)

      • setMinWidth

        public void setMinWidth(int minWidth)
        Sets the TableColumn's minimum width to minWidth, adjusting the new minimum width if necessary to ensure that 0 <= minWidth <= maxWidth. For example, if the minWidth argument is negative, this method sets the minWidth property to 0.

        If the value of the width or preferredWidth property is less than the new minimum width, this method sets that property to the new minimum width.

        参数：
        minWidth - the new minimum width
        另请参见：
        getMinWidth(), setPreferredWidth(int), setMaxWidth(int)

      • getMinWidth

        public int getMinWidth()
        Returns the minimum width for the TableColumn. The TableColumn's width can't be made less than this either by the user or programmatically.
        返回：
        the minWidth property
        另请参见：
        setMinWidth(int), TableColumn(int, int, TableCellRenderer, TableCellEditor)

      • setMaxWidth

        public void setMaxWidth(int maxWidth)
        Sets the TableColumn's maximum width to maxWidth or, if maxWidth is less than the minimum width, to the minimum width.

        If the value of the width or preferredWidth property is more than the new maximum width, this method sets that property to the new maximum width.

        参数：
        maxWidth - the new maximum width
        另请参见：
        getMaxWidth(), setPreferredWidth(int), setMinWidth(int)

      • getMaxWidth

        public int getMaxWidth()
        Returns the maximum width for the TableColumn. The TableColumn's width can't be made larger than this either by the user or programmatically. The default maxWidth is Integer.MAX_VALUE.
        返回：
        the maxWidth property
        另请参见：
        setMaxWidth(int)

      • setResizable

        public void setResizable(boolean isResizable)
        Sets whether this column can be resized.
        参数：
        isResizable - if true, resizing is allowed; otherwise false
        另请参见：
        getResizable()

      • getResizable

        public boolean getResizable()
        Returns true if the user is allowed to resize the TableColumn's width, false otherwise. You can change the width programmatically regardless of this setting. The default is true.
        返回：
        the isResizable property
        另请参见：
        setResizable(boolean)

      • sizeWidthToFit

        public void sizeWidthToFit()
        Resizes the TableColumn to fit the width of its header cell. This method does nothing if the header renderer is null (the default case). Otherwise, it sets the minimum, maximum and preferred widths of this column to the widths of the minimum, maximum and preferred sizes of the Component delivered by the header renderer. The transient "width" property of this TableColumn is also set to the preferred width. Note this method is not used internally by the table package.
        另请参见：
        setPreferredWidth(int)

      • disableResizedPosting

        @Deprecated
public void disableResizedPosting()
        Deprecated. as of Java 2 platform v1.3
        This field was not used in previous releases and there are currently no plans to support it in the future.

      • enableResizedPosting

        @Deprecated
public void enableResizedPosting()
        Deprecated. as of Java 2 platform v1.3
        This field was not used in previous releases and there are currently no plans to support it in the future.

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired in response to an explicit call to setFont, setBackground, or setForeground on the current component. Note that if the current component is inheriting its foreground, background, or font from its container, then no event will be fired in response to a change in the inherited property.

        参数：
        listener - the listener to be added

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. The PropertyChangeListener to be removed was registered for all properties.
        参数：
        listener - the listener to be removed

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the PropertyChangeListeners added to this TableColumn with addPropertyChangeListener().
        返回：
        all of the PropertyChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • createDefaultHeaderRenderer

        protected TableCellRenderer createDefaultHeaderRenderer()
        As of Java 2 platform v1.3, this method is not called by the TableColumn constructor. Previously this method was used by the TableColumn to create a default header renderer. As of Java 2 platform v1.3, the default header renderer is null. JTableHeader now provides its own shared default renderer, just as the JTable does for its cell renderers.
        返回：
        the default header renderer
        另请参见：
        JTableHeader.createDefaultRenderer()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableColumnModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.table

Interface TableColumnModel

  • All Known Implementing Classes:
    DefaultTableColumnModel

    public interface TableColumnModel
    Defines the requirements for a table column model object suitable for use with JTable.
    另请参见：
    DefaultTableColumnModel

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addColumn(TableColumn aColumn)
      Appends aColumn to the end of the tableColumns array.
      void addColumnModelListener(TableColumnModelListener x)
      Adds a listener for table column model events.
      TableColumn getColumn(int columnIndex)
      Returns the TableColumn object for the column at columnIndex.
      int getColumnCount()
      Returns the number of columns in the model.
      int getColumnIndex(Object columnIdentifier)
      Returns the index of the first column in the table whose identifier is equal to identifier, when compared using equals.
      int getColumnIndexAtX(int xPosition)
      Returns the index of the column that lies on the horizontal point, xPosition; or -1 if it lies outside the any of the column's bounds.
      int getColumnMargin()
      Returns the width between the cells in each column.
      Enumeration<TableColumn> getColumns()
      Returns an Enumeration of all the columns in the model.
      boolean getColumnSelectionAllowed()
      Returns true if columns may be selected.
      int getSelectedColumnCount()
      Returns the number of selected columns.
      int[] getSelectedColumns()
      Returns an array of indicies of all selected columns.
      ListSelectionModel getSelectionModel()
      Returns the current selection model.
      int getTotalColumnWidth()
      Returns the total width of all the columns.
      void moveColumn(int columnIndex, int newIndex)
      Moves the column and its header at columnIndex to newIndex.
      void removeColumn(TableColumn column)
      Deletes the TableColumn column from the tableColumns array.
      void removeColumnModelListener(TableColumnModelListener x)
      Removes a listener for table column model events.
      void setColumnMargin(int newMargin)
      Sets the TableColumn's column margin to newMargin.
      void setColumnSelectionAllowed(boolean flag)
      Sets whether the columns in this model may be selected.
      void setSelectionModel(ListSelectionModel newModel)
      Sets the selection model.

    • 方法详细信息

      • addColumn

        void addColumn(TableColumn aColumn)
        Appends aColumn to the end of the tableColumns array. This method posts a columnAdded event to its listeners.
        参数：
        aColumn - the TableColumn to be added
        另请参见：
        removeColumn(javax.swing.table.TableColumn)

      • removeColumn

        void removeColumn(TableColumn column)
        Deletes the TableColumn column from the tableColumns array. This method will do nothing if column is not in the table's column list. This method posts a columnRemoved event to its listeners.
        参数：
        column - the TableColumn to be removed
        另请参见：
        addColumn(javax.swing.table.TableColumn)

      • moveColumn

        void moveColumn(int columnIndex,
              int newIndex)
        Moves the column and its header at columnIndex to newIndex. The old column at columnIndex will now be found at newIndex. The column that used to be at newIndex is shifted left or right to make room. This will not move any columns if columnIndex equals newIndex. This method posts a columnMoved event to its listeners.
        参数：
        columnIndex - the index of column to be moved
        newIndex - index of the column's new location
        抛出：
        IllegalArgumentException - if columnIndex or newIndex are not in the valid range

      • setColumnMargin

        void setColumnMargin(int newMargin)
        Sets the TableColumn's column margin to newMargin. This method posts a columnMarginChanged event to its listeners.
        参数：
        newMargin - the width, in pixels, of the new column margins
        另请参见：
        getColumnMargin()

      • getColumnCount

        int getColumnCount()
        Returns the number of columns in the model.
        返回：
        the number of columns in the model

      • getColumns

        Enumeration<TableColumn> getColumns()
        Returns an Enumeration of all the columns in the model.
        返回：
        an Enumeration of all the columns in the model

      • getColumnIndex

        int getColumnIndex(Object columnIdentifier)
        Returns the index of the first column in the table whose identifier is equal to identifier, when compared using equals.
        参数：
        columnIdentifier - the identifier object
        返回：
        the index of the first table column whose identifier is equal to identifier
        抛出：
        IllegalArgumentException - if identifier is null, or no TableColumn has this identifier
        另请参见：
        getColumn(int)

      • getColumn

        TableColumn getColumn(int columnIndex)
        Returns the TableColumn object for the column at columnIndex.
        参数：
        columnIndex - the index of the desired column
        返回：
        the TableColumn object for the column at columnIndex

      • getColumnMargin

        int getColumnMargin()
        Returns the width between the cells in each column.
        返回：
        the margin, in pixels, between the cells

      • getColumnIndexAtX

        int getColumnIndexAtX(int xPosition)
        Returns the index of the column that lies on the horizontal point, xPosition; or -1 if it lies outside the any of the column's bounds. In keeping with Swing's separable model architecture, a TableColumnModel does not know how the table columns actually appear on screen. The visual presentation of the columns is the responsibility of the view/controller object using this model (typically JTable). The view/controller need not display the columns sequentially from left to right. For example, columns could be displayed from right to left to accomodate a locale preference or some columns might be hidden at the request of the user. Because the model does not know how the columns are laid out on screen, the given xPosition should not be considered to be a coordinate in 2D graphics space. Instead, it should be considered to be a width from the start of the first column in the model. If the column index for a given X coordinate in 2D space is required, JTable.columnAtPoint can be used instead.
        返回：
        the index of the column; or -1 if no column is found
        另请参见：
        JTable.columnAtPoint(java.awt.Point)

      • getTotalColumnWidth

        int getTotalColumnWidth()
        Returns the total width of all the columns.
        返回：
        the total computed width of all columns

      • setColumnSelectionAllowed

        void setColumnSelectionAllowed(boolean flag)
        Sets whether the columns in this model may be selected.
        参数：
        flag - true if columns may be selected; otherwise false
        另请参见：
        getColumnSelectionAllowed()

      • getColumnSelectionAllowed

        boolean getColumnSelectionAllowed()
        Returns true if columns may be selected.
        返回：
        true if columns may be selected
        另请参见：
        setColumnSelectionAllowed(boolean)

      • getSelectedColumns

        int[] getSelectedColumns()
        Returns an array of indicies of all selected columns.
        返回：
        an array of integers containing the indicies of all selected columns; or an empty array if nothing is selected

      • getSelectedColumnCount

        int getSelectedColumnCount()
        Returns the number of selected columns.
        返回：
        the number of selected columns; or 0 if no columns are selected

      • setSelectionModel

        void setSelectionModel(ListSelectionModel newModel)
        Sets the selection model.
        参数：
        newModel - a ListSelectionModel object
        另请参见：
        getSelectionModel()

      • getSelectionModel

        ListSelectionModel getSelectionModel()
        Returns the current selection model.
        返回：
        a ListSelectionModel object
        另请参见：
        setSelectionModel(javax.swing.ListSelectionModel)

      • addColumnModelListener

        void addColumnModelListener(TableColumnModelListener x)
        Adds a listener for table column model events.
        参数：
        x - a TableColumnModelListener object

      • removeColumnModelListener

        void removeColumnModelListener(TableColumnModelListener x)
        Removes a listener for table column model events.
        参数：
        x - a TableColumnModelListener object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ka"l


TableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.table

Interface TableModel

  • All Known Implementing Classes:
    AbstractTableModel, DefaultTableModel

    public interface TableModel
    The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.

    The JTable can be set up to display any data model which implements the TableModel interface with a couple of lines of code:

          TableModel myData = new MyTableModel();
      JTable table = new JTable(myData);

    For further documentation, see Creating a Table Model in The Java Tutorial.

    另请参见：
    JTable

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addTableModelListener(TableModelListener l)
      Adds a listener to the list that is notified each time a change to the data model occurs.
      类<?> getColumnClass(int columnIndex)
      Returns the most specific superclass for all the cell values in the column.
      int getColumnCount()
      Returns the number of columns in the model.
      String getColumnName(int columnIndex)
      Returns the name of the column at columnIndex.
      int getRowCount()
      Returns the number of rows in the model.
      Object getValueAt(int rowIndex, int columnIndex)
      Returns the value for the cell at columnIndex and rowIndex.
      boolean isCellEditable(int rowIndex, int columnIndex)
      Returns true if the cell at rowIndex and columnIndex is editable.
      void removeTableModelListener(TableModelListener l)
      Removes a listener from the list that is notified each time a change to the data model occurs.
      void setValueAt(Object aValue, int rowIndex, int columnIndex)
      Sets the value in the cell at columnIndex and rowIndex to aValue.

    • 方法详细信息

      • getRowCount

        int getRowCount()
        Returns the number of rows in the model. A JTable uses this method to determine how many rows it should display. This method should be quick, as it is called frequently during rendering.
        返回：
        the number of rows in the model
        另请参见：
        getColumnCount()

      • getColumnCount

        int getColumnCount()
        Returns the number of columns in the model. A JTable uses this method to determine how many columns it should create and display by default.
        返回：
        the number of columns in the model
        另请参见：
        getRowCount()

      • getColumnName

        String getColumnName(int columnIndex)
        Returns the name of the column at columnIndex. This is used to initialize the table's column header name. Note: this name does not need to be unique; two columns in a table can have the same name.
        参数：
        columnIndex - the index of the column
        返回：
        the name of the column

      • getColumnClass

        类<?> getColumnClass(int columnIndex)
        Returns the most specific superclass for all the cell values in the column. This is used by the JTable to set up a default renderer and editor for the column.
        参数：
        columnIndex - the index of the column
        返回：
        the common ancestor class of the object values in the model.

      • isCellEditable

        boolean isCellEditable(int rowIndex,
                     int columnIndex)
        Returns true if the cell at rowIndex and columnIndex is editable. Otherwise, setValueAt on the cell will not change the value of that cell.
        参数：
        rowIndex - the row whose value to be queried
        columnIndex - the column whose value to be queried
        返回：
        true if the cell is editable
        另请参见：
        setValueAt(java.lang.Object, int, int)

      • getValueAt

        Object getValueAt(int rowIndex,
                int columnIndex)
        Returns the value for the cell at columnIndex and rowIndex.
        参数：
        rowIndex - the row whose value is to be queried
        columnIndex - the column whose value is to be queried
        返回：
        the value Object at the specified cell

      • setValueAt

        void setValueAt(Object aValue,
              int rowIndex,
              int columnIndex)
        Sets the value in the cell at columnIndex and rowIndex to aValue.
        参数：
        aValue - the new value
        rowIndex - the row whose value is to be changed
        columnIndex - the column whose value is to be changed
        另请参见：
        getValueAt(int, int), isCellEditable(int, int)

      • addTableModelListener

        void addTableModelListener(TableModelListener l)
        Adds a listener to the list that is notified each time a change to the data model occurs.
        参数：
        l - the TableModelListener

      • removeTableModelListener

        void removeTableModelListener(TableModelListener l)
        Removes a listener from the list that is notified each time a change to the data model occurs.
        参数：
        l - the TableModelListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ el/>enn>ee IlvI>aeael>>. e


TableRowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 TableRowSorter<M extends TableModel>

  • java.lang.Object
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,Integer>
        • javax.swing.table.TableRowSorter<M>
  • 类型参数：
    M - the type of the model, which must be an implementation of TableModel

    public class TableRowSorter<M extends TableModel>
extends DefaultRowSorter<M,Integer>
    An implementation of RowSorter that provides sorting and filtering using a TableModel. The following example shows adding sorting to a JTable:
       TableModel myModel = createMyTableModel();
   JTable table = new JTable(myModel);
   table.setRowSorter(new TableRowSorter(myModel));
    This will do all the wiring such that when the user does the appropriate gesture, such as clicking on the column header, the table will visually sort.

    JTable's row-based methods and JTable's selection model refer to the view and not the underlying model. Therefore, it is necessary to convert between the two. For example, to get the selection in terms of myModel you need to convert the indices:

       int[] selection = table.getSelectedRows();
   for (int i = 0; i < selection.length; i++) {
     selection[i] = table.convertRowIndexToModel(selection[i]);
   }
    Similarly to select a row in JTable based on a coordinate from the underlying model do the inverse:
       table.setRowSelectionInterval(table.convertRowIndexToView(row),
                                 table.convertRowIndexToView(row));

    The previous example assumes you have not enabled filtering. If you have enabled filtering convertRowIndexToView will return -1 for locations that are not visible in the view.

    TableRowSorter uses Comparators for doing comparisons. The following defines how a Comparator is chosen for a column:

    1. If a Comparator has been specified for the column by the setComparator method, use it.
    2. If the column class as returned by getColumnClass is String, use the Comparator returned by Collator.getInstance().
    3. If the column class implements Comparable, use a Comparator that invokes the compareTo method.
    4. If a TableStringConverter has been specified, use it to convert the values to Strings and then use the Comparator returned by Collator.getInstance().
    5. Otherwise use the Comparator returned by Collator.getInstance() on the results from calling toString on the objects.

    In addition to sorting TableRowSorter provides the ability to filter. A filter is specified using the setFilter method. The following example will only show rows containing the string "foo":

       TableModel myModel = createMyTableModel();
   TableRowSorter sorter = new TableRowSorter(myModel);
   sorter.setRowFilter(RowFilter.regexFilter(".*foo.*"));
   JTable table = new JTable(myModel);
   table.setRowSorter(sorter);

    If the underlying model structure changes (the modelStructureChanged method is invoked) the following are reset to their default values: Comparators by column, current sort order, and whether each column is sortable. The default sort order is natural (the same as the model), and columns are sortable by default.

    TableRowSorter has one formal type parameter: the type of the model. Passing in a type that corresponds exactly to your model allows you to filter based on your model without casting. Refer to the documentation of RowFilter for an example of this.

    警告： DefaultTableModel returns a column class of Object. As such all comparisons will be done using toString. This may be unnecessarily expensive. If the column only contains one type of value, such as an Integer, you should override getColumnClass and return the appropriate 类. This will dramatically increase the performance of this class.

    从以下版本开始：
    1.6
    另请参见：
    JTable, RowFilter, DefaultTableModel, Collator, Comparator

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.DefaultRowSorter

        DefaultRowSorter.ModelWrapper<M,I>

      • Nested classes/interfaces inherited from class javax.swing.RowSorter

        RowSorter.SortKey

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableRowSorter()
      Creates a TableRowSorter with an empty model.
      TableRowSorter(M model)
      Creates a TableRowSorter using model as the underlying TableModel.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Comparator<?> getComparator(int column)
      Returns the Comparator for the specified column.
      TableStringConverter getStringConverter()
      Returns the object responsible for converting values from the model to strings.
      void setModel(M model)
      Sets the TableModel to use as the underlying model for this TableRowSorter.
      void setStringConverter(TableStringConverter stringConverter)
      Sets the object responsible for converting values from the model to strings.
      protected boolean useToString(int column)
      Returns whether or not to convert the value to a string before doing comparisons when sorting.

      • 方法 - 继承于类 javax.swing.DefaultRowSorter

        allRowsChanged, convertRowIndexToModel, convertRowIndexToView, getMaxSortKeys, getModel, getModelRowCount, getModelWrapper, getRowFilter, getSortKeys, getSortsOnUpdates, getViewRowCount, isSortable, modelStructureChanged, rowsDeleted, rowsInserted, rowsUpdated, rowsUpdated, setComparator, setMaxSortKeys, setModelWrapper, setRowFilter, setSortable, setSortKeys, setSortsOnUpdates, sort, toggleSortOrder

      • 方法 - 继承于类 javax.swing.RowSorter

        addRowSorterListener, fireRowSorterChanged, fireSortOrderChanged, removeRowSorterListener

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableRowSorter

        public TableRowSorter()
        Creates a TableRowSorter with an empty model.

      • TableRowSorter

        public TableRowSorter(M model)
        Creates a TableRowSorter using model as the underlying TableModel.
        参数：
        model - the underlying TableModel to use, null is treated as an empty model

    • 方法详细信息

      • setModel

        public void setModel(M model)
        Sets the TableModel to use as the underlying model for this TableRowSorter. A value of null can be used to set an empty model.
        参数：
        model - the underlying model to use, or null

      • setStringConverter

        public void setStringConverter(TableStringConverter stringConverter)
        Sets the object responsible for converting values from the model to strings. If non-null this is used to convert any object values, that do not have a registered Comparator, to strings.
        参数：
        stringConverter - the object responsible for converting values from the model to strings

      • getStringConverter

        public TableStringConverter getStringConverter()
        Returns the object responsible for converting values from the model to strings.
        返回：
        object responsible for converting values to strings.

      • getComparator

        public Comparator<?> getComparator(int column)
        Returns the Comparator for the specified column. If a Comparator has not been specified using the setComparator method a Comparator will be returned based on the column class (TableModel.getColumnClass) of the specified column. If the column class is String, Collator.getInstance is returned. If the column class implements Comparable a private Comparator is returned that invokes the compareTo method. Otherwise Collator.getInstance is returned.
        重载：
        getComparator in class DefaultRowSorter<M extends TableModel,Integer>
        参数：
        column - the column to fetch the Comparator for, in terms of the underlying model
        返回：
        the Comparator for the specified column
        抛出：
        IndexOutOfBoundsException - if column is outside the range of the underlying model

      • useToString

        protected boolean useToString(int column)
        Returns whether or not to convert the value to a string before doing comparisons when sorting. If true ModelWrapper.getStringValueAt will be used, otherwise ModelWrapper.getValueAt will be used. It is up to subclasses, such as TableRowSorter, to honor this value in their ModelWrapper implementation.
        重载：
        useToString in class DefaultRowSorter<M extends TableModel,Integer>
        参数：
        column - the index of the column to test, in terms of the underlying model
        抛出：
        IndexOutOfBoundsException - if column is not valid
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9na<&n&a& xSaef,l 3/t,t;l_cT�7oltu.i.ea


TableStringConverter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.table

类 TableStringConverter

  • java.lang.Object
    • javax.swing.table.TableStringConverter

  • public abstract class TableStringConverter
extends Object
    TableStringConverter is used to convert objects from the model into strings. This is useful in filtering and searching when the model returns objects that do not have meaningful toString implementations.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableStringConverter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String toString(TableModel model, int row, int column)
      Returns the string representation of the value at the specified location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableStringConverter

        public TableStringConverter()

    • 方法详细信息

      • toString

        public abstract String toString(TableModel model,
              int row,
              int column)
        Returns the string representation of the value at the specified location.
        参数：
        model - the TableModel to fetch the value from
        row - the row the string is being requested for
        column - the column the string is being requested for
        返回：
        the string representation. This should never return null.
        抛出：
        NullPointerException - if model is null
        IndexOutOfBoundsException - if the arguments are outside the bounds of the model
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/trwolSolbeelbbdebb.obeallmTwhr/eetwTTnt


Uses of Package javax.swing.table

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.table

  • Packages that use javax.swing.table
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.
  • Classes in javax.swing.table used by javax.swing
    类与描述
    JTableHeader
    This is the object which manages the header of the JTable.
    TableCellEditor
    This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.
    TableCellRenderer
    This interface defines the method required by any object that would like to be a renderer for cells in a JTable.
    TableColumn
    A TableColumn represents all the attributes of a column in a JTable, such as width, resizibility, minimum and maximum width.
    TableColumnModel
    Defines the requirements for a table column model object suitable for use with JTable.
    TableModel
    The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.
  • Classes in javax.swing.table used by javax.swing.event
    类与描述
    TableColumnModel
    Defines the requirements for a table column model object suitable for use with JTable.
    TableModel
    The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.
  • Classes in javax.swing.table used by javax.swing.plaf.basic
    类与描述
    JTableHeader
    This is the object which manages the header of the JTable.
  • Classes in javax.swing.table used by javax.swing.table
    类与描述
    AbstractTableModel
    This abstract class provides default implementations for most of the methods in the TableModel interface.
    DefaultTableCellRenderer
    The standard class for rendering (displaying) individual cells in a JTable.
    JTableHeader
    This is the object which manages the header of the JTable.
    TableCellEditor
    This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.
    TableCellRenderer
    This interface defines the method required by any object that would like to be a renderer for cells in a JTable.
    TableColumn
    A TableColumn represents all the attributes of a column in a JTable, such as width, resizibility, minimum and maximum width.
    TableColumnModel
    Defines the requirements for a table column model object suitable for use with JTable.
    TableModel
    The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.
    TableStringConverter
    TableStringConverter is used to convert objects from the model into strings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iaancs d">-Ir / otu


Uses of Class javax.swing.table.AbstractTableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.AbstractTableModel

  • Packages that use AbstractTableModel
    软件包 描述
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of AbstractTableModel in javax.swing.table

      Subclasses of AbstractTableModel in javax.swing.table
      修饰符与类型 类与描述
      class  DefaultTableModel
      This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ag/on=-a


Uses of Class javax.swing.table.DefaultTableCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.DefaultTableCellRenderer

  • Packages that use DefaultTableCellRenderer
    软件包 描述
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of DefaultTableCellRenderer in javax.swing.table

      Subclasses of DefaultTableCellRenderer in javax.swing.table
      修饰符与类型 类与描述
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

edsu ifa=h rn&i


Uses of Class javax.swing.table.DefaultTableCellRenderer.UIResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.DefaultTableCellRenderer.UIResource

No usage of javax.swing.table.DefaultTableCellRenderer.UIResource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sT =titmtlllrlaatml/l


Uses of Class javax.swing.table.DefaultTableColumnModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.DefaultTableColumnModel

No usage of javax.swing.table.DefaultTableColumnModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.swing.table.DefaultTableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.DefaultTableModel

No usage of javax.swing.table.DefaultTableModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&瞐癰b9


Uses of Class javax.swing.table.JTableHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.JTableHeader

  • Packages that use JTableHeader
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of JTableHeader in javax.swing

      Fields in javax.swing declared as JTableHeader
      修饰符与类型 字段与描述
      protected JTableHeader JTable.tableHeader
      The TableHeader working with the table.
      Methods in javax.swing that return JTableHeader
      修饰符与类型 方法与描述
      protected JTableHeader JTable.createDefaultTableHeader()
      Returns the default table header object, which is a JTableHeader.
      JTableHeader JTable.getTableHeader()
      Returns the tableHeader used by this JTable.
      Methods in javax.swing with parameters of type JTableHeader
      修饰符与类型 方法与描述
      void JTable.setTableHeader(JTableHeader tableHeader)
      Sets the tableHeader working with this JTable to newHeader.

    • Uses of JTableHeader in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as JTableHeader
      修饰符与类型 字段与描述
      protected JTableHeader BasicTableHeaderUI.header
      The JTableHeader that is delegating the painting to this UI.

    • Uses of JTableHeader in javax.swing.table

      Constructors in javax.swing.table with parameters of type JTableHeader
      构造方法与描述
      JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
      Constructs an AccessiblJTableHeaaderEntry
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>dlaiahntu .筧eooeue v


Uses of Class javax.swing.table.JTableHeader.AccessibleJTableHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.JTableHeader.AccessibleJTableHeader

No usage of javax.swing.table.JTableHeader.AccessibleJTableHeader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

secttg grtdein 宓�<艘


Uses of Class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

No usage of javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i


Uses of Class javax.swing.table.TableColumn

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.TableColumn

  • Packages that use TableColumn
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableColumn in javax.swing

      Methods in javax.swing that return TableColumn
      修饰符与类型 方法与描述
      TableColumn JTable.getColumn(Object identifier)
      Returns the TableColumn object for the column in the table whose identifier is equal to identifier, when compared using equals.
      Methods in javax.swing with parameters of type TableColumn
      修饰符与类型 方法与描述
      void JTable.addColumn(TableColumn aColumn)
      Appends aColumn to the end of the array of columns held by this JTable's column model.
      void JTable.removeColumn(TableColumn aColumn)
      Removes aColumn from this JTable's array of columns.

    • Uses of TableColumn in javax.swing.table

      Fields in javax.swing.table declared as TableColumn
      修饰符与类型 字段与描述
      protected TableColumn JTableHeader.draggedColumn
      The index of the column being dragged.
      protected TableColumn JTableHeader.resizingColumn
      The index of the column being resized.
      Fields in javax.swing.table with type parameters of type TableColumn
      修饰符与类型 字段与描述
      protected Vector<TableColumn> DefaultTableColumnModel.tableColumns
      Array of TableColumn objects in this model
      Methods in javax.swing.table that return TableColumn
      修饰符与类型 方法与描述
      TableColumn DefaultTableColumnModel.getColumn(int columnIndex)
      Returns the TableColumn object for the column at columnIndex.
      TableColumn TableColumnModel.getColumn(int columnIndex)
      Returns the TableColumn object for the column at columnIndex.
      TableColumn JTableHeader.getDraggedColumn()
      Returns the the dragged column, if and only if, a drag is in process, otherwise returns null.
      TableColumn JTableHeader.getResizingColumn()
      Returns the resizing column.
      Methods in javax.swing.table that return types with arguments of type TableColumn
      修饰符与类型 方法与描述
      Enumeration<TableColumn> DefaultTableColumnModel.getColumns()
      Returns an Enumeration of all the columns in the model.
      Enumeration<TableColumn> TableColumnModel.getColumns()
      Returns an Enumeration of all the columns in the model.
      Methods in javax.swing.table with parameters of type TableColumn
      修饰符与类型 方法与描述
      void DefaultTableColumnModel.addColumn(TableColumn aColumn)
      Appends aColumn to the end of the tableColumns array.
      void TableColumnModel.addColumn(TableColumn aColumn)
      Appends aColumn to the end of the tableColumns array.
      void DefaultTableColumnModel.removeColumn(TableColumn column)
      Deletes the column from the tableColumns array.
      void TableColumnModel.removeColumn(TableColumn column)
      Deletes the TableColumn column from the tableColumns array.
      void JTableHeader.setDraggedColumn(TableColumn aColumn)
      Sets the header's draggedColumn to aColumn.
      void JTableHeader.setResizingColumn(TableColumn aColumn)
      Sets the header's resizingColumn to aColumn.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tTntiaitn/.acaa.clntdd//�


Uses of Class javax.swing.table.TableRowSorter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.TableRowSorter

No usage of javax.swing.table.TableRowSorter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b l /codoeeelcbbmaddb


Uses of Class javax.swing.table.TableStringConverter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.table.TableStringConverter

  • Packages that use TableStringConverter
    软件包 描述
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableStringConverter in javax.swing.table

      Methods in javax.swing.table that return TableStringConverter
      修饰符与类型 方法与描述
      TableStringConverter TableRowSorter.getStringConverter()
      Returns the object responsible for converting values from the model to strings.
      Methods in javax.swing.table with parameters of type TableStringConverter
      修饰符与类型 方法与描述
      void TableRowSorter.setStringConverter(TableStringConverter stringConverter)
      Sets the object responsible for converting values from the model to strings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ji/pe"TJaa= e=.nsTJ


Uses of Interface javax.swing.table.TableCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.table.TableCellEditor

  • Packages that use TableCellEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableCellEditor in javax.swing

      Classes in javax.swing that implement TableCellEditor
      修饰符与类型 类与描述
      class  DefaultCellEditor
      The default editor for table and tree cells.
      Fields in javax.swing declared as TableCellEditor
      修饰符与类型 字段与描述
      protected TableCellEditor JTable.cellEditor
      The active cell editor object, that overwrites the screen real estate occupied by the current cell and allows the user to change its contents.
      Methods in javax.swing that return TableCellEditor
      修饰符与类型 方法与描述
      TableCellEditor JTable.getCellEditor()
      Returns the active cell editor, which is null if the table is not currently editing.
      TableCellEditor JTable.getCellEditor(int row, int column)
      Returns an appropriate editor for the cell specified by row and column.
      TableCellEditor JTable.getDefaultEditor(类<?> columnClass)
      Returns the editor to be used when no editor has been set in a TableColumn.
      Methods in javax.swing with parameters of type TableCellEditor
      修饰符与类型 方法与描述
      Component JTable.prepareEditor(TableCellEditor editor, int row, int column)
      Prepares the editor by querying the data model for the value and selection state of the cell at row, column.
      void JTable.setCellEditor(TableCellEditor anEditor)
      Sets the active cell editor.
      void JTable.setDefaultEditor(类<?> columnClass, TableCellEditor editor)
      Sets a default cell editor to be used if no editor has been set in a TableColumn.

    • Uses of TableCellEditor in javax.swing.table

      Fields in javax.swing.table declared as TableCellEditor
      修饰符与类型 字段与描述
      protected TableCellEditor TableColumn.cellEditor
      The editor used to edit the data cells of the column.
      Methods in javax.swing.table that return TableCellEditor
      修饰符与类型 方法与描述
      TableCellEditor TableColumn.getCellEditor()
      Returns the TableCellEditor used by the JTable to edit values for this column.
      Methods in javax.swing.table with parameters of type TableCellEditor
      修饰符与类型 方法与描述
      void TableColumn.setCellEditor(TableCellEditor cellEditor)
      Sets the editor to used by when a cell in this column is edited.
      Constructors in javax.swing.table with parameters of type TableCellEditor
      构造方法与描述
      TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
      Creates and initializes an instance of TableColumn with the specified model index, width, cell renderer, and cell editor; all TableColumn constructors delegate to this one.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c躷7o"n胹o<"r ""Jilgm;


Uses of Interface javax.swing.table.TableCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.table.TableCellRenderer

  • Packages that use TableCellRenderer
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableCellRenderer in javax.swing

      Methods in javax.swing that return TableCellRenderer
      修饰符与类型 方法与描述
      TableCellRenderer JTable.getCellRenderer(int row, int column)
      Returns an appropriate renderer for the cell specified by this row and column.
      TableCellRenderer JTable.getDefaultRenderer(类<?> columnClass)
      Returns the cell renderer to be used when no renderer has been set in a TableColumn.
      Methods in javax.swing with parameters of type TableCellRenderer
      修饰符与类型 方法与描述
      Component JTable.prepareRenderer(TableCellRenderer renderer, int row, int column)
      Prepares the renderer by querying the data model for the value and selection state of the cell at row, column.
      void JTable.setDefaultRenderer(类<?> columnClass, TableCellRenderer renderer)
      Sets a default cell renderer to be used if no renderer has been set in a TableColumn.

    • Uses of TableCellRenderer in javax.swing.table

      Classes in javax.swing.table that implement TableCellRenderer
      修饰符与类型 类与描述
      class  DefaultTableCellRenderer
      The standard class for rendering (displaying) individual cells in a JTable.
      static class  DefaultTableCellRenderer.UIResource
      A subclass of DefaultTableCellRenderer that implements UIResource.
      Fields in javax.swing.table declared as TableCellRenderer
      修饰符与类型 字段与描述
      protected TableCellRenderer TableColumn.cellRenderer
      The renderer used to draw the data cells of the column.
      protected TableCellRenderer TableColumn.headerRenderer
      The renderer used to draw the header of the column.
      Methods in javax.swing.table that return TableCellRenderer
      修饰符与类型 方法与描述
      protected TableCellRenderer TableColumn.createDefaultHeaderRenderer()
      As of Java 2 platform v1.3, this method is not called by the TableColumn constructor.
      protected TableCellRenderer JTableHeader.createDefaultRenderer()
      Returns a default renderer to be used when no header renderer is defined by a TableColumn.
      TableCellRenderer TableColumn.getCellRenderer()
      Returns the TableCellRenderer used by the JTable to draw values for this column.
      TableCellRenderer JTableHeader.getDefaultRenderer()
      Returns the default renderer used when no headerRenderer is defined by a TableColumn.
      TableCellRenderer TableColumn.getHeaderRenderer()
      Returns the TableCellRenderer used to draw the header of the TableColumn.
      Methods in javax.swing.table with parameters of type TableCellRenderer
      修饰符与类型 方法与描述
      void TableColumn.setCellRenderer(TableCellRenderer cellRenderer)
      Sets the TableCellRenderer used by JTable to draw individual values for this column.
      void JTableHeader.setDefaultRenderer(TableCellRenderer defaultRenderer)
      Sets the default renderer to be used when no headerRenderer is defined by a TableColumn.
      void TableColumn.setHeaderRenderer(TableCellRenderer headerRenderer)
      Sets the TableCellRenderer used to draw the TableColumn's header to headerRenderer.
      Constructors in javax.swing.table with parameters of type TableCellRenderer
      构造方法与描述
      TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
      Creates and initializes an instance of TableColumn with the specified model index, width, cell renderer, and cell editor; all TableColumn constructors delegate to this one.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nmMua;oino>rehc/rs g orr/薴


Uses of Interface javax.swing.table.TableColumnModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.table.TableColumnModel

  • Packages that use TableColumnModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableColumnModel in javax.swing

      Fields in javax.swing declared as TableColumnModel
      修饰符与类型 字段与描述
      protected TableColumnModel JTable.columnModel
      The TableColumnModel of the table.
      Methods in javax.swing that return TableColumnModel
      修饰符与类型 方法与描述
      protected TableColumnModel JTable.createDefaultColumnModel()
      Returns the default column model object, which is a DefaultTableColumnModel.
      TableColumnModel JTable.getColumnModel()
      Returns the TableColumnModel that contains all column information of this table.
      Methods in javax.swing with parameters of type TableColumnModel
      修饰符与类型 方法与描述
      void JTable.setColumnModel(TableColumnModel columnModel)
      Sets the column model for this table to newModel and registers for listener notifications from the new column model.
      Constructors in javax.swing with parameters of type TableColumnModel
      构造方法与描述
      JTable(TableModel dm, TableColumnModel cm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and a default selection model.
      JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model.

    • Uses of TableColumnModel in javax.swing.event

      Constructors in javax.swing.event with parameters of type TableColumnModel
      构造方法与描述
      TableColumnModelEvent(TableColumnModel source, int from, int to)
      Constructs a TableColumnModelEvent object.

    • Uses of TableColumnModel in javax.swing.table

      Classes in javax.swing.table that implement TableColumnModel
      修饰符与类型 类与描述
      class  DefaultTableColumnModel
      The standard column-handler for a JTable.
      Fields in javax.swing.table declared as TableColumnModel
      修饰符与类型 字段与描述
      protected TableColumnModel JTableHeader.columnModel
      The TableColumnModel of the table header.
      Methods in javax.swing.table that return TableColumnModel
      修饰符与类型 方法与描述
      protected TableColumnModel JTableHeader.createDefaultColumnModel()
      Returns the default column model object which is a DefaultTableColumnModel.
      TableColumnModel JTableHeader.getColumnModel()
      Returns the TableColumnModel that contains all column information of this table header.
      Methods in javax.swing.table with parameters of type TableColumnModel
      修饰符与类型 方法与描述
      void JTableHeader.setColumnModel(TableColumnModel columnModel)
      Sets the column model for this table to newModel and registers for listener notifications from the new column model.
      Constructors in javax.swing.table with parameters of type TableColumnModel
      构造方法与描述
      JTableHeader(TableColumnModel cm)
      Constructs a JTableHeader which is initialized with cm as the column model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/d."hf/fe".././h/t< ÷蛂


Uses of Interface javax.swing.table.TableModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.table.TableModel

  • Packages that use TableModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.table
    Provides classes and interfaces for dealing with javax.swing.JTable.

    • Uses of TableModel in javax.swing

      Fields in javax.swing declared as TableModel
      修饰符与类型 字段与描述
      protected TableModel JTable.dataModel
      The TableModel of the table.
      Methods in javax.swing that return TableModel
      修饰符与类型 方法与描述
      protected TableModel JTable.createDefaultDataModel()
      Returns the default table model object, which is a DefaultTableModel.
      TableModel JTable.getModel()
      Returns the TableModel that provides the data displayed by this JTable.
      Methods in javax.swing that return types with arguments of type TableModel
      修饰符与类型 方法与描述
      RowSorter<? extends TableModel> JTable.getRowSorter()
      Returns the object responsible for sorting.
      Methods in javax.swing with parameters of type TableModel
      修饰符与类型 方法与描述
      void JTable.setModel(TableModel dataModel)
      Sets the data model for this table to newModel and registers with it for listener notifications from the new data model.
      Method parameters in javax.swing with type arguments of type TableModel
      修饰符与类型 方法与描述
      void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
      Sets the RowSorter.
      Constructors in javax.swing with parameters of type TableModel
      构造方法与描述
      JTable(TableModel dm)
      Constructs a JTable that is initialized with dm as the data model, a default column model, and a default selection model.
      JTable(TableModel dm, TableColumnModel cm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and a default selection model.
      JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
      Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model.

    • Uses of TableModel in javax.swing.event

      Constructors in javax.swing.event with parameters of type TableModel
      构造方法与描述
      TableModelEvent(TableModel source)
      All row data in the table has changed, listeners should discard any state that was based on the rows and requery the TableModel to get the new row count and all the appropriate values.
      TableModelEvent(TableModel source, int row)
      This row of data has been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow)
      The data in rows [firstRow, lastRow] have been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow, int column)
      The cells in column column in the range [firstRow, lastRow] have been updated.
      TableModelEvent(TableModel source, int firstRow, int lastRow, int column, int type)
      The cells from (firstRow, column) to (lastRow, column) have been changed.

    • Uses of TableModel in javax.swing.table

      Classes in javax.swing.table with type parameters of type TableModel
      修饰符与类型 类与描述
      class  TableRowSorter<M extends TableModel>
      An implementation of RowSorter that provides sorting and filtering using a TableModel.
      Classes in javax.swing.table that implement TableModel
      修饰符与类型 类与描述
      class  AbstractTableModel
      This abstract class provides default implementations for most of the methods in the TableModel interface.
      class  DefaultTableModel
      This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.
      Methods in javax.swing.table with parameters of type TableModel
      修饰符与类型 方法与描述
      abstract String TableStringConverter.toString(TableModel model, int row, int column)
      Returns the string representation of the value at the specified location.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e ,laa/ m g�-nl"rS. OOfl


AbstractDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument

  • java.lang.Object
    • javax.swing.text.AbstractDocument
  • 所有已实现的接口：
    Serializable, Document
    直接已知子类：
    DefaultStyledDocument, PlainDocument

    public abstract class AbstractDocument
extends Object
implements Document, Serializable
    An implementation of the document interface to serve as a basis for implementing various kinds of documents. At this level there is very little policy, so there is a corresponding increase in difficulty of use.

    This class implements a locking mechanism for the document. It allows multiple readers or one writer, and writers must wait until all observers of the document have been notified of a previous change before beginning another mutation to the document. The read lock is acquired and released using the render method. A write lock is aquired by the methods that mutate the document, and are held for the duration of the method call. Notification is done on the thread that produced the mutation, and the thread has full read access to the document for the duration of the notification, but other readers are kept out until the notification has finished. The notification is a beans event notification which does not allow any further mutations until all listeners have been notified.

    Any models subclassed from this class and used in conjunction with a text component that has a look and feel implementation that is derived from BasicTextUI may be safely updated asynchronously, because all access to the View hierarchy is serialized by BasicTextUI if the document is of type AbstractDocument. The locking assumes that an independent thread will access the View hierarchy only from the DocumentListener methods, and that there will be only one event thread active at a time.

    If concurrency support is desired, there are the following additional implications. The code path for any DocumentListener implementation and any UndoListener implementation must be threadsafe, and not access the component lock if trying to be safe from deadlocks. The repaint and revalidate methods on JComponent are safe.

    AbstractDocument models an implied break at the end of the document. Among other things this allows you to position the caret after the last character. As a result of this, getLength returns one less than the length of the Content. If you create your own Content, be sure and initialize it to have an additional character. Refer to StringContent and GapContent for examples of this. Another implication of this is that Elements that model the implied end character will have an endOffset == (getLength() + 1). For example, in DefaultStyledDocument getParagraphElement(getLength()).getEndOffset() == getLength() + 1 .

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      static interface  AbstractDocument.AttributeContext
      An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      static interface  AbstractDocument.Content
      Interface to describe a sequence of character content that can be edited.
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static String BAD_LOCATION
      Error message to indicate a bad location.
      static String BidiElementName
      Name of elements used to hold a unidirectional run
      static String ContentElementName
      Name of elements used to represent content
      static String ElementNameAttribute
      Name of the attribute used to specify element names.
      protected EventListenerList listenerList
      The event listener list for the document.
      static String ParagraphElementName
      Name of elements used to represent paragraphs
      static String SectionElementName
      Name of elements used to hold sections (lines/paragraphs).

      • 字段 - 继承于接口 javax.swing.text.Document

        StreamDescriptionProperty, TitleProperty

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected AbstractDocument(AbstractDocument.Content data)
      Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
      protected AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
      Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addDocumentListener(DocumentListener listener)
      Adds a document listener for notification of any changes.
      void addUndoableEditListener(UndoableEditListener listener)
      Adds an undo listener for notification of any changes.
      protected Element createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected Element createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element.
      Position createPosition(int offs)
      Returns a position that will track change as the document is altered.
      void dump(PrintStream out)
      Gives a diagnostic dump.
      protected void fireChangedUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireInsertUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireRemoveUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireUndoableEditUpdate(UndoableEditEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      int getAsynchronousLoadPriority()
      Gets the asynchronous loading priority.
      protected AbstractDocument.AttributeContext getAttributeContext()
      Fetches the context for managing attributes.
      Element getBidiRootElement()
      Returns the root element of the bidirectional structure for this document.
      protected AbstractDocument.Content getContent()
      Gets the content for the document.
      protected Thread getCurrentWriter()
      Fetches the current writing thread if there is one.
      abstract Element getDefaultRootElement()
      Returns the root element that views should be based upon unless some other mechanism for assigning views to element structures is provided.
      DocumentFilter getDocumentFilter()
      Returns the DocumentFilter that is responsible for filtering of insertion/removal.
      DocumentListener[] getDocumentListeners()
      Returns an array of all the document listeners registered on this document.
      Dictionary<Object,Object> getDocumentProperties()
      Supports managing a set of properties.
      Position getEndPosition()
      Returns a position that represents the end of the document.
      int getLength()
      Returns the length of the data.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this document.
      abstract Element getParagraphElement(int pos)
      Get the paragraph element containing the given position.
      Object getProperty(Object key)
      A convenience method for looking up a property value.
      Element[] getRootElements()
      Gets all root elements defined.
      Position getStartPosition()
      Returns a position that represents the start of the document.
      String getText(int offset, int length)
      Gets a sequence of text from the document.
      void getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
      UndoableEditListener[] getUndoableEditListeners()
      Returns an array of all the undoable edit listeners registered on this document.
      void insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.
      void putProperty(Object key, Object value)
      A convenience method for storing up a property value.
      void readLock()
      Acquires a lock to begin reading some state from the document.
      void readUnlock()
      Does a read unlock.
      void remove(int offs, int len)
      Removes some content from the document.
      void removeDocumentListener(DocumentListener listener)
      Removes a document listener.
      void removeUndoableEditListener(UndoableEditListener listener)
      Removes an undo listener.
      protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.
      void render(Runnable r)
      This allows the model to be safely rendered in the presence of currency, if the model supports being updated asynchronously.
      void replace(int offset, int length, String text, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.
      void setAsynchronousLoadPriority(int p)
      Sets the asynchronous loading priority.
      void setDocumentFilter(DocumentFilter filter)
      Sets the DocumentFilter.
      void setDocumentProperties(Dictionary<Object,Object> x)
      Replaces the document properties dictionary for this document.
      protected void writeLock()
      Acquires a lock to begin mutating the document this lock protects.
      protected void writeUnlock()
      Releases a write lock previously obtained via writeLock.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList
        The event listener list for the document.

      • BAD_LOCATION

        protected static final String BAD_LOCATION
        Error message to indicate a bad location.
        另请参见：
        Constant Field Values

      • ParagraphElementName

        public static final String ParagraphElementName
        Name of elements used to represent paragraphs
        另请参见：
        Constant Field Values

      • ContentElementName

        public static final String ContentElementName
        Name of elements used to represent content
        另请参见：
        Constant Field Values

      • SectionElementName

        public static final String SectionElementName
        Name of elements used to hold sections (lines/paragraphs).
        另请参见：
        Constant Field Values

      • BidiElementName

        public static final String BidiElementName
        Name of elements used to hold a unidirectional run
        另请参见：
        Constant Field Values

      • ElementNameAttribute

        public static final String ElementNameAttribute
        Name of the attribute used to specify element names.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • AbstractDocument

        protected AbstractDocument(AbstractDocument.Content data)
        Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
        参数：
        data - the content

      • AbstractDocument

        protected AbstractDocument(AbstractDocument.Content data,
                AbstractDocument.AttributeContext context)
        Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
        参数：
        data - the content
        context - the attribute context

    • 方法详细信息

      • getDocumentProperties

        public Dictionary<Object,Object> getDocumentProperties()
        Supports managing a set of properties. Callers can use the documentProperties dictionary to annotate the document with document-wide properties.
        返回：
        a non-null Dictionary
        另请参见：
        setDocumentProperties(java.util.Dictionary)

      • setDocumentProperties

        public void setDocumentProperties(Dictionary<Object,Object> x)
        Replaces the document properties dictionary for this document.
        参数：
        x - the new dictionary
        另请参见：
        getDocumentProperties()

      • fireInsertUpdate

        protected void fireInsertUpdate(DocumentEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • fireChangedUpdate

        protected void fireChangedUpdate(DocumentEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • fireRemoveUpdate

        protected void fireRemoveUpdate(DocumentEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • fireUndoableEditUpdate

        protected void fireUndoableEditUpdate(UndoableEditEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this document. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a document d for its document listeners with the following code:

        DocumentListener[] mls = (DocumentListener[])(d.getListeners(DocumentListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getDocumentListeners(), getUndoableEditListeners()

      • getAsynchronousLoadPriority

        public int getAsynchronousLoadPriority()
        Gets the asynchronous loading priority. If less than zero, the document should not be loaded asynchronously.
        返回：
        the asynchronous loading priority, or -1 if the document should not be loaded asynchronously

      • setAsynchronousLoadPriority

        public void setAsynchronousLoadPriority(int p)
        Sets the asynchronous loading priority.
        参数：
        p - the new asynchronous loading priority; a value less than zero indicates that the document should not be loaded asynchronously

      • setDocumentFilter

        public void setDocumentFilter(DocumentFilter filter)
        Sets the DocumentFilter. The DocumentFilter is passed insert and remove to conditionally allow inserting/deleting of the text. A null value indicates that no filtering will occur.
        参数：
        filter - the DocumentFilter used to constrain text
        从以下版本开始：
        1.4
        另请参见：
        getDocumentFilter()

      • getDocumentFilter

        public DocumentFilter getDocumentFilter()
        Returns the DocumentFilter that is responsible for filtering of insertion/removal. A null return value implies no filtering is to occur.
        返回：
        the DocumentFilter
        从以下版本开始：
        1.4
        另请参见：
        setDocumentFilter(javax.swing.text.DocumentFilter)

      • render

        public void render(Runnable r)
        This allows the model to be safely rendered in the presence of currency, if the model supports being updated asynchronously. The given runnable will be executed in a way that allows it to safely read the model with no changes while the runnable is being executed. The runnable itself may not make any mutations.

        This is implemented to aquire a read lock for the duration of the runnables execution. There may be multiple runnables executing at the same time, and all writers will be blocked while there are active rendering runnables. If the runnable throws an exception, its lock will be safely released. There is no protection against a runnable that never exits, which will effectively leave the document locked for it's lifetime.

        If the given runnable attempts to make any mutations in this implementation, a deadlock will occur. There is no tracking of individual rendering threads to enable detecting this situation, but a subclass could incur the overhead of tracking them and throwing an error.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        render in interface Document
        参数：
        r - the renderer to execute

      • getLength

        public int getLength()
        Returns the length of the data. This is the number of characters of content that represents the users data.
        指定者：
        getLength in interface Document
        返回：
        the length >= 0
        另请参见：
        Document.getLength()

      • addDocumentListener

        public void addDocumentListener(DocumentListener listener)
        Adds a document listener for notification of any changes.
        指定者：
        addDocumentListener in interface Document
        参数：
        listener - the DocumentListener to add
        另请参见：
        Document.addDocumentListener(javax.swing.event.DocumentListener)

      • removeDocumentListener

        public void removeDocumentListener(DocumentListener listener)
        Removes a document listener.
        指定者：
        removeDocumentListener in interface Document
        参数：
        listener - the DocumentListener to remove
        另请参见：
        Document.removeDocumentListener(javax.swing.event.DocumentListener)

      • getDocumentListeners

        public DocumentListener[] getDocumentListeners()
        Returns an array of all the document listeners registered on this document.
        返回：
        all of this document's DocumentListeners or an empty array if no document listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addDocumentListener(javax.swing.event.DocumentListener), removeDocumentListener(javax.swing.event.DocumentListener)

      • addUndoableEditListener

        public void addUndoableEditListener(UndoableEditListener listener)
        Adds an undo listener for notification of any changes. Undo/Redo operations performed on the UndoableEdit will cause the appropriate DocumentEvent to be fired to keep the view(s) in sync with the model.
        指定者：
        addUndoableEditListener in interface Document
        参数：
        listener - the UndoableEditListener to add
        另请参见：
        Document.addUndoableEditListener(javax.swing.event.UndoableEditListener)

      • removeUndoableEditListener

        public void removeUndoableEditListener(UndoableEditListener listener)
        Removes an undo listener.
        指定者：
        removeUndoableEditListener in interface Document
        参数：
        listener - the UndoableEditListener to remove
        另请参见：
        Document.removeDocumentListener(javax.swing.event.DocumentListener)

      • getUndoableEditListeners

        public UndoableEditListener[] getUndoableEditListeners()
        Returns an array of all the undoable edit listeners registered on this document.
        返回：
        all of this document's UndoableEditListeners or an empty array if no undoable edit listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addUndoableEditListener(javax.swing.event.UndoableEditListener), removeUndoableEditListener(javax.swing.event.UndoableEditListener)

      • getProperty

        public final Object getProperty(Object key)
        A convenience method for looking up a property value. It is equivalent to:
         getDocumentProperties().get(key);
        指定者：
        getProperty in interface Document
        参数：
        key - the non-null property key
        返回：
        the value of this property or null
        另请参见：
        getDocumentProperties()

      • putProperty

        public final void putProperty(Object key,
               Object value)
        A convenience method for storing up a property value. It is equivalent to:
         getDocumentProperties().put(key, value);
        If value is null this method will remove the property.
        指定者：
        putProperty in interface Document
        参数：
        key - the non-null key
        value - the property value
        另请参见：
        getDocumentProperties()

      • remove

        public void remove(int offs,
          int len)
            throws BadLocationException
        Removes some content from the document. Removing content causes a write lock to be held while the actual changes are taking place. Observers are notified of the change on the thread that called this method.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        remove in interface Document
        参数：
        offs - the starting offset >= 0
        len - the number of characters to remove >= 0
        抛出：
        BadLocationException - the given remove position is not a valid position within the document
        另请参见：
        Document.remove(int, int)

      • replace

        public void replace(int offset,
           int length,
           String text,
           AttributeSet attrs)
             throws BadLocationException
        Deletes the region of text from offset to offset + length, and replaces it with text. It is up to the implementation as to how this is implemented, some implementations may treat this as two distinct operations: a remove followed by an insert, others may treat the replace as one atomic operation.
        参数：
        offset - index of child element
        length - length of text to delete, may be 0 indicating don't delete anything
        text - text to insert, null indicates no text to insert
        attrs - AttributeSet indicating attributes of inserted text, null is legal, and typically treated as an empty attributeset, but exact interpretation is left to the subclass
        抛出：
        BadLocationException - the given position is not a valid position within the document
        从以下版本开始：
        1.4

      • insertString

        public void insertString(int offs,
                String str,
                AttributeSet a)
                  throws BadLocationException
        Inserts some content into the document. Inserting content causes a write lock to be held while the actual changes are taking place, followed by notification to the observers on the thread that grabbed the write lock.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        insertString in interface Document
        参数：
        offs - the starting offset >= 0
        str - the string to insert; does nothing with null/empty strings
        a - the attributes for the inserted content
        抛出：
        BadLocationException - the given insert position is not a valid position within the document
        另请参见：
        Document.insertString(int, java.lang.String, javax.swing.text.AttributeSet)

      • getText

        public String getText(int offset,
             int length)
               throws BadLocationException
        Gets a sequence of text from the document.
        指定者：
        getText in interface Document
        参数：
        offset - the starting offset >= 0
        length - the number of characters to retrieve >= 0
        返回：
        the text
        抛出：
        BadLocationException - the range given includes a position that is not a valid position within the document
        另请参见：
        Document.getText(int, int)

      • getText

        public void getText(int offset,
           int length,
           Segment txt)
             throws BadLocationException
        Fetches the text contained within the given portion of the document.

        If the partialReturn property on the txt parameter is false, the data returned in the Segment will be the entire length requested and may or may not be a copy depending upon how the data was stored. If the partialReturn property is true, only the amount of text that can be returned without creating a copy is returned. Using partial returns will give better performance for situations where large parts of the document are being scanned. The following is an example of using the partial return to access the entire document:

           int nleft = doc.getDocumentLength();
   Segment text = new Segment();
   int offs = 0;
   text.setPartialReturn(true);
   while (nleft > 0) {
       doc.getText(offs, nleft, text);
       // do something with text
       nleft -= text.count;
       offs += text.count;
   }
        指定者：
        getText in interface Document
        参数：
        offset - the starting offset >= 0
        length - the number of characters to retrieve >= 0
        txt - the Segment object to retrieve the text into
        抛出：
        BadLocationException - the range given includes a position that is not a valid position within the document

      • createPosition

        public Position createPosition(int offs)
                        throws BadLocationException
        Returns a position that will track change as the document is altered.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        createPosition in interface Document
        参数：
        offs - the position in the model >= 0
        返回：
        the position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        Document.createPosition(int)

      • getStartPosition

        public final Position getStartPosition()
        Returns a position that represents the start of the document. The position returned can be counted on to track change and stay located at the beginning of the document.
        指定者：
        getStartPosition in interface Document
        返回：
        the position

      • getEndPosition

        public final Position getEndPosition()
        Returns a position that represents the end of the document. The position returned can be counted on to track change and stay located at the end of the document.
        指定者：
        getEndPosition in interface Document
        返回：
        the position

      • getRootElements

        public Element[] getRootElements()
        Gets all root elements defined. Typically, there will only be one so the default implementation is to return the default root element.
        指定者：
        getRootElements in interface Document
        返回：
        the root element

      • getDefaultRootElement

        public abstract Element getDefaultRootElement()
        Returns the root element that views should be based upon unless some other mechanism for assigning views to element structures is provided.
        指定者：
        getDefaultRootElement in interface Document
        返回：
        the root element
        另请参见：
        Document.getDefaultRootElement()

      • getBidiRootElement

        public Element getBidiRootElement()
        Returns the root element of the bidirectional structure for this document. Its children represent character runs with a given Unicode bidi level.

      • getParagraphElement

        public abstract Element getParagraphElement(int pos)
        Get the paragraph element containing the given position. Sub-classes must define for themselves what exactly constitutes a paragraph. They should keep in mind however that a paragraph should at least be the unit of text over which to run the Unicode bidirectional algorithm.
        参数：
        pos - the starting offset >= 0
        返回：
        the element

      • getAttributeContext

        protected final AbstractDocument.AttributeContext getAttributeContext()
        Fetches the context for managing attributes. This method effectively establishes the strategy used for compressing AttributeSet information.
        返回：
        the context

      • insertUpdate

        protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                AttributeSet attr)
        Updates document structure as a result of text insertion. This will happen within a write lock. If a subclass of this class reimplements this method, it should delegate to the superclass as well.
        参数：
        chng - a description of the change
        attr - the attributes for the change

      • removeUpdate

        protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
        Updates any document structure as a result of text removal. This method is called before the text is actually removed from the Content. This will happen within a write lock. If a subclass of this class reimplements this method, it should delegate to the superclass as well.
        参数：
        chng - a description of the change

      • postRemoveUpdate

        protected void postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng)
        Updates any document structure as a result of text removal. This method is called after the text has been removed from the Content. This will happen within a write lock. If a subclass of this class reimplements this method, it should delegate to the superclass as well.
        参数：
        chng - a description of the change

      • dump

        public void dump(PrintStream out)
        Gives a diagnostic dump.
        参数：
        out - the output stream

      • getContent

        protected final AbstractDocument.Content getContent()
        Gets the content for the document.
        返回：
        the content

      • createLeafElement

        protected Element createLeafElement(Element parent,
                        AttributeSet a,
                        int p0,
                        int p1)
        Creates a document leaf element. Hook through which elements are created to represent the document structure. Because this implementation keeps structure and content separate, elements grow automatically when content is extended so splits of existing elements follow. The document itself gets to decide how to generate elements to give flexibility in the type of elements used.
        参数：
        parent - the parent element
        a - the attributes for the element
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0
        返回：
        the new element

      • createBranchElement

        protected Element createBranchElement(Element parent,
                          AttributeSet a)
        Creates a document branch element, that can contain other elements.
        参数：
        parent - the parent element
        a - the attributes
        返回：
        the element

      • getCurrentWriter

        protected final Thread getCurrentWriter()
        Fetches the current writing thread if there is one. This can be used to distinguish whether a method is being called as part of an existing modification or if a lock needs to be acquired and a new transaction started.
        返回：
        the thread actively modifying the document or null if there are no modifications in progress

      • writeLock

        protected final void writeLock()
        Acquires a lock to begin mutating the document this lock protects. There can be no writing, notification of changes, or reading going on in order to gain the lock. Additionally a thread is allowed to gain more than one writeLock, as long as it doesn't attempt to gain additional writeLocks from within document notification. Attempting to gain a writeLock from within a DocumentListener notification will result in an IllegalStateException. The ability to obtain more than one writeLock per thread allows subclasses to gain a writeLock, perform a number of operations, then release the lock.

        Calls to writeLock must be balanced with calls to writeUnlock, else the Document will be left in a locked state so that no reading or writing can be done.

        抛出：
        IllegalStateException - thrown on illegal lock attempt. If the document is implemented properly, this can only happen if a document listener attempts to mutate the document. This situation violates the bean event model where order of delivery is not guaranteed and all listeners should be notified before further mutations are allowed.

      • writeUnlock

        protected final void writeUnlock()
        Releases a write lock previously obtained via writeLock. After decrementing the lock count if there are no oustanding locks this will allow a new writer, or readers.
        另请参见：
        writeLock()

      • readLock

        public final void readLock()
        Acquires a lock to begin reading some state from the document. There can be multiple readers at the same time. Writing blocks the readers until notification of the change to the listeners has been completed. This method should be used very carefully to avoid unintended compromise of the document. It should always be balanced with a readUnlock.
        另请参见：
        readUnlock()

      • readUnlock

        public final void readUnlock()
        Does a read unlock. This signals that one of the readers is done. If there are no more readers then writing can begin again. This should be balanced with a readLock, and should occur in a finally statement so that the balance is guaranteed. The following is an example.

     readLock();
     try {
         // do something
     } finally {
         readUnlock();
     }
        另请参见：
        readLock()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractDocument.AbstractElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument.AbstractElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    直接已知子类：
    AbstractDocument.BranchElement, AbstractDocument.LeafElement
    封闭类：
    AbstractDocument

    public abstract class AbstractDocument.AbstractElement
extends Object
implements Element, MutableAttributeSet, Serializable, TreeNode
    Implements the abstract part of an element. By default elements support attributes by having a field that represents the immutable part of the current attribute set for the element. The element itself implements MutableAttributeSet which can be used to modify the set by fetching a new immutable set. The immutable sets are provided by the AttributeContext associated with the document.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractDocument.AbstractElement(Element parent, AttributeSet a)
      Creates a new AbstractElement.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(Object name, Object value)
      Adds an attribute to the element.
      void addAttributes(AttributeSet attr)
      Adds a set of attributes to the element.
      abstract Enumeration children()
      Returns the children of the receiver as an Enumeration.
      boolean containsAttribute(Object name, Object value)
      Checks whether a given attribute name/value is defined.
      boolean containsAttributes(AttributeSet attrs)
      Checks whether the element contains all the attributes.
      AttributeSet copyAttributes()
      Copies a set of attributes.
      void dump(PrintStream psOut, int indentAmount)
      Dumps a debugging representation of the element hierarchy.
      abstract boolean getAllowsChildren()
      Returns true if the receiver allows children.
      Object getAttribute(Object attrName)
      Gets the value of an attribute.
      int getAttributeCount()
      Gets the number of attributes that are defined.
      Enumeration<?> getAttributeNames()
      Gets the names of all attributes.
      AttributeSet getAttributes()
      Gets the attributes for the element.
      TreeNode getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      int getChildCount()
      Returns the number of children TreeNode's receiver contains.
      Document getDocument()
      Retrieves the underlying model.
      abstract Element getElement(int index)
      Gets a child element.
      abstract int getElementCount()
      Gets the number of children for the element.
      abstract int getElementIndex(int offset)
      Gets the child element index closest to the given model offset.
      abstract int getEndOffset()
      Gets the ending offset in the model for the element.
      int getIndex(TreeNode node)
      Returns the index of node in the receivers children.
      String getName()
      Gets the name of the element.
      TreeNode getParent()
      Returns the parent TreeNode of the receiver.
      Element getParentElement()
      Gets the parent of the element.
      AttributeSet getResolveParent()
      Gets the resolving parent.
      abstract int getStartOffset()
      Gets the starting offset in the model for the element.
      boolean isDefined(Object attrName)
      Checks whether a given attribute is defined.
      boolean isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      abstract boolean isLeaf()
      Checks whether the element is a leaf.
      void removeAttribute(Object name)
      Removes an attribute from the set.
      void removeAttributes(AttributeSet attrs)
      Removes a set of attributes for the element.
      void removeAttributes(Enumeration<?> names)
      Removes a set of attributes for the element.
      void setResolveParent(AttributeSet parent)
      Sets the resolving parent.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractDocument.AbstractElement

        public AbstractDocument.AbstractElement(Element parent,
                                AttributeSet a)
        Creates a new AbstractElement.
        参数：
        parent - the parent element
        a - the attributes for the element
        从以下版本开始：
        1.4

    • 方法详细信息

      • dump

        public void dump(PrintStream psOut,
        int indentAmount)
        Dumps a debugging representation of the element hierarchy.
        参数：
        psOut - the output stream
        indentAmount - the indentation level >= 0

      • getAttributeCount

        public int getAttributeCount()
        Gets the number of attributes that are defined.
        指定者：
        getAttributeCount in interface AttributeSet
        返回：
        the number of attributes >= 0
        另请参见：
        AttributeSet.getAttributeCount()

      • isDefined

        public boolean isDefined(Object attrName)
        Checks whether a given attribute is defined.
        指定者：
        isDefined in interface AttributeSet
        参数：
        attrName - the non-null attribute name
        返回：
        true if the attribute is defined
        另请参见：
        AttributeSet.isDefined(java.lang.Object)

      • isEqual

        public boolean isEqual(AttributeSet attr)
        Checks whether two attribute sets are equal.
        指定者：
        isEqual in interface AttributeSet
        参数：
        attr - the attribute set to check against
        返回：
        true if the same
        另请参见：
        AttributeSet.isEqual(javax.swing.text.AttributeSet)

      • copyAttributes

        public AttributeSet copyAttributes()
        Copies a set of attributes.
        指定者：
        copyAttributes in interface AttributeSet
        返回：
        the copy
        另请参见：
        AttributeSet.copyAttributes()

      • getAttribute

        public Object getAttribute(Object attrName)
        Gets the value of an attribute.
        指定者：
        getAttribute in interface AttributeSet
        参数：
        attrName - the non-null attribute name
        返回：
        the attribute value
        另请参见：
        AttributeSet.getAttribute(java.lang.Object)

      • getAttributeNames

        public Enumeration<?> getAttributeNames()
        Gets the names of all attributes.
        指定者：
        getAttributeNames in interface AttributeSet
        返回：
        the attribute names as an enumeration
        另请参见：
        AttributeSet.getAttributeNames()

      • containsAttribute

        public boolean containsAttribute(Object name,
                        Object value)
        Checks whether a given attribute name/value is defined.
        指定者：
        containsAttribute in interface AttributeSet
        参数：
        name - the non-null attribute name
        value - the attribute value
        返回：
        true if the name/value is defined
        另请参见：
        AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

      • containsAttributes

        public boolean containsAttributes(AttributeSet attrs)
        Checks whether the element contains all the attributes.
        指定者：
        containsAttributes in interface AttributeSet
        参数：
        attrs - the attributes to check
        返回：
        true if the element contains all the attributes
        另请参见：
        AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

      • getResolveParent

        public AttributeSet getResolveParent()
        Gets the resolving parent. If not overridden, the resolving parent defaults to the parent element.
        指定者：
        getResolveParent in interface AttributeSet
        返回：
        the attributes from the parent, null if none
        另请参见：
        AttributeSet.getResolveParent()

      • addAttribute

        public void addAttribute(Object name,
                Object value)
        Adds an attribute to the element.
        指定者：
        addAttribute in interface MutableAttributeSet
        参数：
        name - the non-null attribute name
        value - the attribute value
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        public void addAttributes(AttributeSet attr)
        Adds a set of attributes to the element.
        指定者：
        addAttributes in interface MutableAttributeSet
        参数：
        attr - the attributes to add
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        public void removeAttribute(Object name)
        Removes an attribute from the set.
        指定者：
        removeAttribute in interface MutableAttributeSet
        参数：
        name - the non-null attribute name
        另请参见：
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        public void removeAttributes(Enumeration<?> names)
        Removes a set of attributes for the element.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        names - the attribute names
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • removeAttributes

        public void removeAttributes(AttributeSet attrs)
        Removes a set of attributes for the element.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        attrs - the attributes
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • setResolveParent

        public void setResolveParent(AttributeSet parent)
        Sets the resolving parent.
        指定者：
        setResolveParent in interface MutableAttributeSet
        参数：
        parent - the parent, null if none
        另请参见：
        MutableAttributeSet.setResolveParent(javax.swing.text.AttributeSet)

      • getDocument

        public Document getDocument()
        Retrieves the underlying model.
        指定者：
        getDocument in interface Element
        返回：
        the model

      • getParentElement

        public Element getParentElement()
        Gets the parent of the element.
        指定者：
        getParentElement in interface Element
        返回：
        the parent

      • getAttributes

        public AttributeSet getAttributes()
        Gets the attributes for the element.
        指定者：
        getAttributes in interface Element
        返回：
        the attribute set

      • getName

        public String getName()
        Gets the name of the element.
        指定者：
        getName in interface Element
        返回：
        the name, null if none

      • getStartOffset

        public abstract int getStartOffset()
        Gets the starting offset in the model for the element.
        指定者：
        getStartOffset in interface Element
        返回：
        the offset >= 0
        另请参见：
        Document, AbstractDocument

      • getEndOffset

        public abstract int getEndOffset()
        Gets the ending offset in the model for the element.
        指定者：
        getEndOffset in interface Element
        返回：
        the offset >= 0
        另请参见：
        Document, AbstractDocument

      • getElement

        public abstract Element getElement(int index)
        Gets a child element.
        指定者：
        getElement in interface Element
        参数：
        index - the child index, >= 0 && < getElementCount()
        返回：
        the child element

      • getElementCount

        public abstract int getElementCount()
        Gets the number of children for the element.
        指定者：
        getElementCount in interface Element
        返回：
        the number of children >= 0

      • getElementIndex

        public abstract int getElementIndex(int offset)
        Gets the child element index closest to the given model offset.
        指定者：
        getElementIndex in interface Element
        参数：
        offset - the offset >= 0
        返回：
        the element index >= 0

      • isLeaf

        public abstract boolean isLeaf()
        Checks whether the element is a leaf.
        指定者：
        isLeaf in interface Element
        指定者：
        isLeaf in interface TreeNode
        返回：
        true if a leaf

      • getChildAt

        public TreeNode getChildAt(int childIndex)
        Returns the child TreeNode at index childIndex.
        指定者：
        getChildAt in interface TreeNode

      • getChildCount

        public int getChildCount()
        Returns the number of children TreeNode's receiver contains.
        指定者：
        getChildCount in interface TreeNode
        返回：
        the number of children TreeNodews's receiver contains

      • getParent

        public TreeNode getParent()
        Returns the parent TreeNode of the receiver.
        指定者：
        getParent in interface TreeNode
        返回：
        the parent TreeNode of the receiver

      • getIndex

        public int getIndex(TreeNode node)
        Returns the index of node in the receivers children. If the receiver does not contain node, -1 will be returned.
        指定者：
        getIndex in interface TreeNode
        参数：
        node - the location of interest
        返回：
        the index of node in the receiver's children, or -1 if absent

      • getAllowsChildren

        public abstract boolean getAllowsChildren()
        Returns true if the receiver allows children.
        指定者：
        getAllowsChildren in interface TreeNode
        返回：
        true if the receiver allows children, otherwise false

      • children

        public abstract Enumeration children()
        Returns the children of the receiver as an Enumeration.
        指定者：
        children in interface TreeNode
        返回：
        the children of the receiver as an Enumeration
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractDocument.AttributeContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface AbstractDocument.AttributeContext

  • All Known Implementing Classes:
    StyleContext, StyleSheet
    封闭类：
    AbstractDocument

    public static interface AbstractDocument.AttributeContext
    An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques. Each mutation of the attribute set can be used to exchange a previous AttributeSet instance with another, preserving the possibility of the AttributeSet remaining immutable. An implementation is provided by the StyleContext class. The Element implementations provided by this class use this interface to provide their MutableAttributeSet implementations, so that different AttributeSet compression techniques can be employed. The method getAttributeContext should be implemented to return the object responsible for implementing the desired compression technique.
    另请参见：
    StyleContext

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AttributeSet addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      AttributeSet getEmptySet()
      Fetches an empty AttributeSet.
      void reclaim(AttributeSet a)
      Reclaims an attribute set.
      AttributeSet removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      AttributeSet removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.

    • 方法详细信息

      • addAttribute

        AttributeSet addAttribute(AttributeSet old,
                        Object name,
                        Object value)
        Adds an attribute to the given set, and returns the new representative set.
        参数：
        old - the old attribute set
        name - the non-null attribute name
        value - the attribute value
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        AttributeSet addAttributes(AttributeSet old,
                         AttributeSet attr)
        Adds a set of attributes to the element.
        参数：
        old - the old attribute set
        attr - the attributes to add
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        AttributeSet removeAttribute(AttributeSet old,
                           Object name)
        Removes an attribute from the set.
        参数：
        old - the old attribute set
        name - the non-null attribute name
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        AttributeSet removeAttributes(AttributeSet old,
                            Enumeration<?> names)
        Removes a set of attributes for the element.
        参数：
        old - the old attribute set
        names - the attribute names
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • removeAttributes

        AttributeSet removeAttributes(AttributeSet old,
                            AttributeSet attrs)
        Removes a set of attributes for the element.
        参数：
        old - the old attribute set
        attrs - the attributes
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • getEmptySet

        AttributeSet getEmptySet()
        Fetches an empty AttributeSet.
        返回：
        the attribute set

      • reclaim

        void reclaim(AttributeSet a)
        Reclaims an attribute set. This is a way for a MutableAttributeSet to mark that it no longer need a particular immutable set. This is only necessary in 1.1 where there are no weak references. A 1.1 implementation would call this in its finalize method.
        参数：
        a - the attribute set to reclaim
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"sl t/


AbstractDocument.BranchElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument.BranchElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
      • javax.swing.text.AbstractDocument.BranchElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    直接已知子类：
    DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement
    封闭类：
    AbstractDocument

    public class AbstractDocument.BranchElement
extends AbstractDocument.AbstractElement
    Implements a composite element that contains other elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractDocument.BranchElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Enumeration children()
      Returns the children of the receiver as an Enumeration.
      boolean getAllowsChildren()
      Returns true if the receiver allows children.
      Element getElement(int index)
      Gets a child element.
      int getElementCount()
      Gets the number of children for the element.
      int getElementIndex(int offset)
      Gets the child element index closest to the given model offset.
      int getEndOffset()
      Gets the ending offset in the model for the element.
      String getName()
      Gets the element name.
      int getStartOffset()
      Gets the starting offset in the model for the element.
      boolean isLeaf()
      Checks whether the element is a leaf.
      Element positionToElement(int pos)
      Gets the child element that contains the given model position.
      void replace(int offset, int length, Element[] elems)
      Replaces content with a new set of elements.
      String toString()
      Converts the element to a string.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.AbstractElement

        addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractDocument.BranchElement

        public AbstractDocument.BranchElement(Element parent,
                              AttributeSet a)
        Constructs a composite element that initially contains no children.
        参数：
        parent - The parent element
        a - the attributes for the element
        从以下版本开始：
        1.4

    • 方法详细信息

      • positionToElement

        public Element positionToElement(int pos)
        Gets the child element that contains the given model position.
        参数：
        pos - the position >= 0
        返回：
        the element, null if none

      • replace

        public void replace(int offset,
           int length,
           Element[] elems)
        Replaces content with a new set of elements.
        参数：
        offset - the starting offset >= 0
        length - the length to replace >= 0
        elems - the new elements

      • toString

        public String toString()
        Converts the element to a string.
        重载：
        toString in class Object
        返回：
        the string

      • getName

        public String getName()
        Gets the element name.
        指定者：
        getName in interface Element
        重载：
        getName in class AbstractDocument.AbstractElement
        返回：
        the element name

      • getStartOffset

        public int getStartOffset()
        Gets the starting offset in the model for the element.
        指定者：
        getStartOffset in interface Element
        指定者：
        getStartOffset in class AbstractDocument.AbstractElement
        返回：
        the offset >= 0
        另请参见：
        Document, AbstractDocument

      • getEndOffset

        public int getEndOffset()
        Gets the ending offset in the model for the element.
        指定者：
        getEndOffset in interface Element
        指定者：
        getEndOffset in class AbstractDocument.AbstractElement
        返回：
        the offset >= 0
        抛出：
        NullPointerException - if this element has no children
        另请参见：
        Document, AbstractDocument

      • getElement

        public Element getElement(int index)
        Gets a child element.
        指定者：
        getElement in interface Element
        指定者：
        getElement in class AbstractDocument.AbstractElement
        参数：
        index - the child index, >= 0 && < getElementCount()
        返回：
        the child element, null if none

      • getElementCount

        public int getElementCount()
        Gets the number of children for the element.
        指定者：
        getElementCount in interface Element
        指定者：
        getElementCount in class AbstractDocument.AbstractElement
        返回：
        the number of children >= 0

      • getElementIndex

        public int getElementIndex(int offset)
        Gets the child element index closest to the given model offset.
        指定者：
        getElementIndex in interface Element
        指定者：
        getElementIndex in class AbstractDocument.AbstractElement
        参数：
        offset - the offset >= 0
        返回：
        the element index >= 0

      • isLeaf

        public boolean isLeaf()
        Checks whether the element is a leaf.
        指定者：
        isLeaf in interface Element
        指定者：
        isLeaf in interface TreeNode
        指定者：
        isLeaf in class AbstractDocument.AbstractElement
        返回：
        true if a leaf

      • getAllowsChildren

        public boolean getAllowsChildren()
        Returns true if the receiver allows children.
        指定者：
        getAllowsChildren in interface TreeNode
        指定者：
        getAllowsChildren in class AbstractDocument.AbstractElement
        返回：
        true if the receiver allows children, otherwise false

      • children

        public Enumeration children()
        Returns the children of the receiver as an Enumeration.
        指定者：
        children in interface TreeNode
        指定者：
        children in class AbstractDocument.AbstractElement
        返回：
        the children of the receiver
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


AbstractDocument.Content

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface AbstractDocument.Content

  • All Known Implementing Classes:
    GapContent, StringContent
    封闭类：
    AbstractDocument

    public static interface AbstractDocument.Content
    Interface to describe a sequence of character content that can be edited. Implementations may or may not support a history mechanism which will be reflected by whether or not mutations return an UndoableEdit implementation.
    另请参见：
    AbstractDocument

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Position createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      void getChars(int where, int len, Segment txt)
      Gets a sequence of characters and copies them into a Segment.
      String getString(int where, int len)
      Fetches a string of characters contained in the sequence.
      UndoableEdit insertString(int where, String str)
      Inserts a string of characters into the sequence.
      int length()
      Current length of the sequence of character content.
      UndoableEdit remove(int where, int nitems)
      Removes some portion of the sequence.

    • 方法详细信息

      • createPosition

        Position createPosition(int offset)
                        throws BadLocationException
        Creates a position within the content that will track change as the content is mutated.
        参数：
        offset - the offset in the content >= 0
        返回：
        a Position
        抛出：
        BadLocationException - for an invalid offset

      • length

        int length()
        Current length of the sequence of character content.
        返回：
        the length >= 0

      • insertString

        UndoableEdit insertString(int where,
                        String str)
                          throws BadLocationException
        Inserts a string of characters into the sequence.
        参数：
        where - offset into the sequence to make the insertion >= 0
        str - string to insert
        返回：
        if the implementation supports a history mechanism, a reference to an Edit implementation will be returned, otherwise returns null
        抛出：
        BadLocationException - thrown if the area covered by the arguments is not contained in the character sequence

      • remove

        UndoableEdit remove(int where,
                  int nitems)
                    throws BadLocationException
        Removes some portion of the sequence.
        参数：
        where - The offset into the sequence to make the insertion >= 0.
        nitems - The number of items in the sequence to remove >= 0.
        返回：
        If the implementation supports a history mechansim, a reference to an Edit implementation will be returned, otherwise null.
        抛出：
        BadLocationException - Thrown if the area covered by the arguments is not contained in the character sequence.

      • getString

        String getString(int where,
               int len)
                 throws BadLocationException
        Fetches a string of characters contained in the sequence.
        参数：
        where - Offset into the sequence to fetch >= 0.
        len - number of characters to copy >= 0.
        返回：
        the string
        抛出：
        BadLocationException - Thrown if the area covered by the arguments is not contained in the character sequence.

      • getChars

        void getChars(int where,
            int len,
            Segment txt)
              throws BadLocationException
        Gets a sequence of characters and copies them into a Segment.
        参数：
        where - the starting offset >= 0
        len - the number of characters >= 0
        txt - the target location to copy into
        抛出：
        BadLocationException - Thrown if the area covered by the arguments is not contained in the character sequence.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

inbret.ct.gOO.ggab## a>/<.nmmttAit.l


AbstractDocument.DefaultDocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument.DefaultDocumentEvent

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent
  • 所有已实现的接口：
    Serializable, DocumentEvent, UndoableEdit
    封闭类：
    AbstractDocument

    public class AbstractDocument.DefaultDocumentEvent
extends CompoundEdit
implements DocumentEvent
    Stores document changes as the document is being modified. Can subsequently be used for change notification when done with the document modification transaction. This is used by the AbstractDocument class and its extensions for broadcasting change information to the document listeners.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.event.DocumentEvent

        DocumentEvent.ElementChange, DocumentEvent.EventType

    • 字段摘要

      • Fields inherited from class javax.swing.undo.CompoundEdit

        edits

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractDocument.DefaultDocumentEvent(int offs, int len, DocumentEvent.EventType type)
      Constructs a change record.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean addEdit(UndoableEdit anEdit)
      Adds a document edit.
      DocumentEvent.ElementChange getChange(Element elem)
      Gets the changes for an element.
      Document getDocument()
      Gets the document that sourced the change event.
      int getLength()
      Returns the length of the change.
      int getOffset()
      Returns the offset within the document of the start of the change.
      String getPresentationName()
      Provides a localized, human readable description of this edit suitable for use in, say, a change log.
      String getRedoPresentationName()
      Provides a localized, human readable description of the redoable form of this edit, e.g.
      DocumentEvent.EventType getType()
      Returns the type of event.
      String getUndoPresentationName()
      Provides a localized, human readable description of the undoable form of this edit, e.g.
      boolean isSignificant()
      DefaultDocument events are significant.
      void redo()
      Redoes a change.
      String toString()
      Returns a string description of the change event.
      void undo()
      Undoes a change.

      • 方法 - 继承于类 javax.swing.undo.CompoundEdit

        canRedo, canUndo, die, end, isInProgress, lastEdit

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        replaceEdit

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractDocument.DefaultDocumentEvent

        public AbstractDocument.DefaultDocumentEvent(int offs,
                                     int len,
                                     DocumentEvent.EventType type)
        Constructs a change record.
        参数：
        offs - the offset into the document of the change >= 0
        len - the length of the change >= 0
        type - the type of event (DocumentEvent.EventType)
        从以下版本开始：
        1.4

    • 方法详细信息

      • toString

        public String toString()
        Returns a string description of the change event.
        重载：
        toString in class CompoundEdit
        返回：
        a string

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        Adds a document edit. If the number of edits crosses a threshold, this switches on a hashtable lookup for ElementChange implementations since access of these needs to be relatively quick.
        指定者：
        addEdit in interface UndoableEdit
        重载：
        addEdit in class CompoundEdit
        参数：
        anEdit - a document edit record
        返回：
        true if the edit was added
        另请参见：
        UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

      • redo

        public void redo()
          throws CannotRedoException
        Redoes a change.
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class CompoundEdit
        抛出：
        CannotRedoException - if the change cannot be redone
        另请参见：
        AbstractUndoableEdit.canRedo()

      • undo

        public void undo()
          throws CannotUndoException
        Undoes a change.
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class CompoundEdit
        抛出：
        CannotUndoException - if the change cannot be undone
        另请参见：
        AbstractUndoableEdit.canUndo()

      • isSignificant

        public boolean isSignificant()
        DefaultDocument events are significant. If you wish to aggregate DefaultDocumentEvents to present them as a single edit to the user place them into a CompoundEdit.
        指定者：
        isSignificant in interface UndoableEdit
        重载：
        isSignificant in class CompoundEdit
        返回：
        whether the event is significant for edit undo purposes
        另请参见：
        UndoableEdit.isSignificant()

      • getPresentationName

        public String getPresentationName()
        Provides a localized, human readable description of this edit suitable for use in, say, a change log.
        指定者：
        getPresentationName in interface UndoableEdit
        重载：
        getPresentationName in class CompoundEdit
        返回：
        the description
        另请参见：
        AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

      • getUndoPresentationName

        public String getUndoPresentationName()
        Provides a localized, human readable description of the undoable form of this edit, e.g. for use as an Undo menu item. Typically derived from getDescription();
        指定者：
        getUndoPresentationName in interface UndoableEdit
        重载：
        getUndoPresentationName in class CompoundEdit
        返回：
        the description
        另请参见：
        AbstractUndoableEdit.getPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Provides a localized, human readable description of the redoable form of this edit, e.g. for use as a Redo menu item. Typically derived from getPresentationName();
        指定者：
        getRedoPresentationName in interface UndoableEdit
        重载：
        getRedoPresentationName in class CompoundEdit
        返回：
        the description
        另请参见：
        AbstractUndoableEdit.getPresentationName()

      • getType

        public DocumentEvent.EventType getType()
        Returns the type of event.
        指定者：
        getType in interface DocumentEvent
        返回：
        the event type as a DocumentEvent.EventType
        另请参见：
        DocumentEvent.getType()

      • getOffset

        public int getOffset()
        Returns the offset within the document of the start of the change.
        指定者：
        getOffset in interface DocumentEvent
        返回：
        the offset >= 0
        另请参见：
        DocumentEvent.getOffset()

      • getLength

        public int getLength()
        Returns the length of the change.
        指定者：
        getLength in interface DocumentEvent
        返回：
        the length >= 0
        另请参见：
        DocumentEvent.getLength()

      • getDocument

        public Document getDocument()
        Gets the document that sourced the change event.
        指定者：
        getDocument in interface DocumentEvent
        返回：
        the document
        另请参见：
        DocumentEvent.getDocument()

      • getChange

        public DocumentEvent.ElementChange getChange(Element elem)
        Gets the changes for an element.
        指定者：
        getChange in interface DocumentEvent
        参数：
        elem - the element
        返回：
        the changes
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractDocument.ElementEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument.ElementEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.text.AbstractDocument.ElementEdit
  • 所有已实现的接口：
    Serializable, DocumentEvent.ElementChange, UndoableEdit
    封闭类：
    AbstractDocument

    public static class AbstractDocument.ElementEdit
extends AbstractUndoableEdit
implements DocumentEvent.ElementChange
    An implementation of ElementChange that can be added to the document event.

    • 字段摘要

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
      Constructs an edit record.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Element[] getChildrenAdded()
      Gets a list of children that were added.
      Element[] getChildrenRemoved()
      Gets a list of children that were removed.
      Element getElement()
      Returns the underlying element.
      int getIndex()
      Returns the index into the list of elements.
      void redo()
      Redoes a change.
      void undo()
      Undoes a change.

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        addEdit, canRedo, canUndo, die, getPresentationName, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractDocument.ElementEdit

        public AbstractDocument.ElementEdit(Element e,
                            int index,
                            Element[] removed,
                            Element[] added)
        Constructs an edit record. This does not modify the element so it can safely be used to catch up a view to the current model state for views that just attached to a model.
        参数：
        e - the element
        index - the index into the model >= 0
        removed - a set of elements that were removed
        added - a set of elements that were added

    • 方法详细信息

      • getElement

        public Element getElement()
        Returns the underlying element.
        指定者：
        getElement in interface DocumentEvent.ElementChange
        返回：
        the element

      • getIndex

        public int getIndex()
        Returns the index into the list of elements.
        指定者：
        getIndex in interface DocumentEvent.ElementChange
        返回：
        the index >= 0

      • getChildrenRemoved

        public Element[] getChildrenRemoved()
        Gets a list of children that were removed.
        指定者：
        getChildrenRemoved in interface DocumentEvent.ElementChange
        返回：
        the list

      • getChildrenAdded

        public Element[] getChildrenAdded()
        Gets a list of children that were added.
        指定者：
        getChildrenAdded in interface DocumentEvent.ElementChange
        返回：
        the list

      • redo

        public void redo()
          throws CannotRedoException
        Redoes a change.
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class AbstractUndoableEdit
        抛出：
        CannotRedoException - if the change cannot be redone
        另请参见：
        AbstractUndoableEdit.canRedo()

      • undo

        public void undo()
          throws CannotUndoException
        Undoes a change.
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class AbstractUndoableEdit
        抛出：
        CannotUndoException - if the change cannot be undone
        另请参见：
        AbstractUndoableEdit.canUndo()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"<.ed<>><>t >ttnwssc=tils aaav.usnxxddjt /not


AbstractDocument.LeafElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractDocument.LeafElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
      • javax.swing.text.AbstractDocument.LeafElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    直接已知子类：
    HTMLDocument.RunElement
    封闭类：
    AbstractDocument

    public class AbstractDocument.LeafElement
extends AbstractDocument.AbstractElement
    Implements an element that directly represents content of some kind.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Element

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Enumeration children()
      Returns the children of the receiver as an Enumeration.
      boolean getAllowsChildren()
      Returns true if the receiver allows children.
      Element getElement(int index)
      Gets a child element.
      int getElementCount()
      Returns the number of child elements.
      int getElementIndex(int pos)
      Gets the child element index closest to the given model offset.
      int getEndOffset()
      Gets the ending offset in the model for the element.
      String getName()
      Gets the element name.
      int getStartOffset()
      Gets the starting offset in the model for the element.
      boolean isLeaf()
      Checks whether the element is a leaf.
      String toString()
      Converts the element to a string.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.AbstractElement

        addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AbstractDocument.LeafElement

        public AbstractDocument.LeafElement(Element parent,
                            AttributeSet a,
                            int offs0,
                            int offs1)
        Constructs an element that represents content within the document (has no children).
        参数：
        parent - The parent element
        a - The element attributes
        offs0 - The start offset >= 0
        offs1 - The end offset >= offs0
        从以下版本开始：
        1.4

    • 方法详细信息

      • toString

        public String toString()
        Converts the element to a string.
        重载：
        toString in class Object
        返回：
        the string

      • getStartOffset

        public int getStartOffset()
        Gets the starting offset in the model for the element.
        指定者：
        getStartOffset in interface Element
        指定者：
        getStartOffset in class AbstractDocument.AbstractElement
        返回：
        the offset >= 0
        另请参见：
        Document, AbstractDocument

      • getEndOffset

        public int getEndOffset()
        Gets the ending offset in the model for the element.
        指定者：
        getEndOffset in interface Element
        指定者：
        getEndOffset in class AbstractDocument.AbstractElement
        返回：
        the offset >= 0
        另请参见：
        Document, AbstractDocument

      • getName

        public String getName()
        Gets the element name.
        指定者：
        getName in interface Element
        重载：
        getName in class AbstractDocument.AbstractElement
        返回：
        the name

      • getElementIndex

        public int getElementIndex(int pos)
        Gets the child element index closest to the given model offset.
        指定者：
        getElementIndex in interface Element
        指定者：
        getElementIndex in class AbstractDocument.AbstractElement
        参数：
        pos - the offset >= 0
        返回：
        the element index >= 0

      • getElement

        public Element getElement(int index)
        Gets a child element.
        指定者：
        getElement in interface Element
        指定者：
        getElement in class AbstractDocument.AbstractElement
        参数：
        index - the child index, >= 0 && < getElementCount()
        返回：
        the child element

      • getElementCount

        public int getElementCount()
        Returns the number of child elements.
        指定者：
        getElementCount in interface Element
        指定者：
        getElementCount in class AbstractDocument.AbstractElement
        返回：
        the number of children >= 0

      • isLeaf

        public boolean isLeaf()
        Checks whether the element is a leaf.
        指定者：
        isLeaf in interface Element
        指定者：
        isLeaf in interface TreeNode
        指定者：
        isLeaf in class AbstractDocument.AbstractElement
        返回：
        true if a leaf

      • getAllowsChildren

        public boolean getAllowsChildren()
        Returns true if the receiver allows children.
        指定者：
        getAllowsChildren in interface TreeNode
        指定者：
        getAllowsChildren in class AbstractDocument.AbstractElement
        返回：
        true if the receiver allows children, otherwise false

      • children

        public Enumeration children()
        Returns the children of the receiver as an Enumeration.
        指定者：
        children in interface TreeNode
        指定者：
        children in class AbstractDocument.AbstractElement
        返回：
        the children of the receiver
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e sitnntnogoroo


AbstractWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AbstractWriter

  • java.lang.Object
    • javax.swing.text.AbstractWriter
  • 直接已知子类：
    HTMLWriter, MinimalHTMLWriter

    public abstract class AbstractWriter
extends Object
    AbstractWriter is an abstract class that actually does the work of writing out the element tree including the attributes. In terms of how much is written out per line, the writer defaults to 100. But this value can be set by subclasses.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static char NEWLINE
      How the text packages models newlines.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected AbstractWriter(Writer w, Document doc)
      Creates a new AbstractWriter.
      protected AbstractWriter(Writer w, Document doc, int pos, int len)
      Creates a new AbstractWriter.
      protected AbstractWriter(Writer w, Element root)
      Creates a new AbstractWriter.
      protected AbstractWriter(Writer w, Element root, int pos, int len)
      Creates a new AbstractWriter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void decrIndent()
      Decrements the indent level.
      protected boolean getCanWrapLines()
      Returns whether or not the lines can be wrapped.
      protected int getCurrentLineLength()
      Returns the current line length.
      protected Document getDocument()
      Fetches the document.
      protected ElementIterator getElementIterator()
      Fetches the ElementIterator.
      int getEndOffset()
      Returns the last offset to be output.
      protected int getIndentLevel()
      Returns the current indentation level.
      protected int getIndentSpace()
      Returns the amount of space to indent.
      protected int getLineLength()
      Returns the maximum line length.
      String getLineSeparator()
      Returns the string used to represent newlines.
      int getStartOffset()
      Returns the first offset to be output.
      protected String getText(Element elem)
      Returns the text associated with the element.
      protected Writer getWriter()
      Returns the Writer that is used to output the content.
      protected void incrIndent()
      Increments the indent level.
      protected void indent()
      Does indentation.
      protected boolean inRange(Element next)
      This method determines whether the current element is in the range specified.
      protected boolean isLineEmpty()
      Returns true if the current line should be considered empty.
      protected void output(char[] content, int start, int length)
      The last stop in writing out content.
      protected void setCanWrapLines(boolean newValue)
      Sets whether or not lines can be wrapped.
      protected void setCurrentLineLength(int length)
      Sets the current line length.
      protected void setIndentSpace(int space)
      Enables subclasses to specify how many spaces an indent maps to.
      protected void setLineLength(int l)
      Enables subclasses to set the number of characters they want written per line.
      void setLineSeparator(String value)
      Sets the String used to reprsent newlines.
      protected void text(Element elem)
      Writes out text.
      protected abstract void write()
      This abstract method needs to be implemented by subclasses.
      protected void write(char ch)
      Writes out a character.
      protected void write(char[] chars, int startIndex, int length)
      All write methods call into this one.
      protected void write(String content)
      Writes out a string.
      protected void writeAttributes(AttributeSet attr)
      Writes out the set of attributes as " =" pairs.
      protected void writeLineSeparator()
      Writes the line separator.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NEWLINE

        protected static final char NEWLINE
        How the text packages models newlines.
        另请参见：
        getLineSeparator(), Constant Field Values

    • 构造方法详细信息

      • AbstractWriter

        protected AbstractWriter(Writer w,
              Document doc)
        Creates a new AbstractWriter. Initializes the ElementIterator with the default root of the document.
        参数：
        w - a Writer.
        doc - a Document

      • AbstractWriter

        protected AbstractWriter(Writer w,
              Document doc,
              int pos,
              int len)
        Creates a new AbstractWriter. Initializes the ElementIterator with the element passed in.
        参数：
        w - a Writer
        doc - an Element
        pos - The location in the document to fetch the content.
        len - The amount to write out.

      • AbstractWriter

        protected AbstractWriter(Writer w,
              Element root)
        Creates a new AbstractWriter. Initializes the ElementIterator with the element passed in.
        参数：
        w - a Writer
        root - an Element

      • AbstractWriter

        protected AbstractWriter(Writer w,
              Element root,
              int pos,
              int len)
        Creates a new AbstractWriter. Initializes the ElementIterator with the element passed in.
        参数：
        w - a Writer
        root - an Element
        pos - The location in the document to fetch the content.
        len - The amount to write out.

    • 方法详细信息

      • getStartOffset

        public int getStartOffset()
        Returns the first offset to be output.
        从以下版本开始：
        1.3

      • getEndOffset

        public int getEndOffset()
        Returns the last offset to be output.
        从以下版本开始：
        1.3

      • getElementIterator

        protected ElementIterator getElementIterator()
        Fetches the ElementIterator.
        返回：
        the ElementIterator.

      • getWriter

        protected Writer getWriter()
        Returns the Writer that is used to output the content.
        从以下版本开始：
        1.3

      • getDocument

        protected Document getDocument()
        Fetches the document.
        返回：
        the Document.

      • inRange

        protected boolean inRange(Element next)
        This method determines whether the current element is in the range specified. When no range is specified, the range is initialized to be the entire document. inRange() returns true if the range specified intersects with the element's range.
        参数：
        下一个 - an Element.
        返回：
        boolean that indicates whether the element is in the range.

      • write

        protected abstract void write()
                       throws IOException,
                              BadLocationException
        This abstract method needs to be implemented by subclasses. Its responsibility is to iterate over the elements and use the write() methods to generate output in the desired format.
        抛出：
        IOException
        BadLocationException

      • getText

        protected String getText(Element elem)
                  throws BadLocationException
        Returns the text associated with the element. The assumption here is that the element is a leaf element. Throws a BadLocationException when encountered.
        参数：
        elem - an Element
        返回：
        the text as a String
        抛出：
        BadLocationException - if pos represents an invalid location within the document

      • text

        protected void text(Element elem)
             throws BadLocationException,
                    IOException
        Writes out text. If a range is specified when the constructor is invoked, then only the appropriate range of text is written out.
        参数：
        elem - an Element.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • setLineLength

        protected void setLineLength(int l)
        Enables subclasses to set the number of characters they want written per line. The default is 100.
        参数：
        l - the maximum line length.

      • getLineLength

        protected int getLineLength()
        Returns the maximum line length.
        从以下版本开始：
        1.3

      • setCurrentLineLength

        protected void setCurrentLineLength(int length)
        Sets the current line length.
        从以下版本开始：
        1.3

      • getCurrentLineLength

        protected int getCurrentLineLength()
        Returns the current line length.
        从以下版本开始：
        1.3

      • isLineEmpty

        protected boolean isLineEmpty()
        Returns true if the current line should be considered empty. This is true when getCurrentLineLength == 0 || indent has been invoked on an empty line.
        从以下版本开始：
        1.3

      • setCanWrapLines

        protected void setCanWrapLines(boolean newValue)
        Sets whether or not lines can be wrapped. This can be toggled during the writing of lines. For example, outputting HTML might set this to false when outputting a quoted string.
        从以下版本开始：
        1.3

      • getCanWrapLines

        protected boolean getCanWrapLines()
        Returns whether or not the lines can be wrapped. If this is false no lineSeparator's will be output.
        从以下版本开始：
        1.3

      • setIndentSpace

        protected void setIndentSpace(int space)
        Enables subclasses to specify how many spaces an indent maps to. When indentation takes place, the indent level is multiplied by this mapping. The default is 2.
        参数：
        space - an int representing the space to indent mapping.

      • getIndentSpace

        protected int getIndentSpace()
        Returns the amount of space to indent.
        从以下版本开始：
        1.3

      • setLineSeparator

        public void setLineSeparator(String value)
        Sets the String used to reprsent newlines. This is initialized in the constructor from either the Document, or the System property line.separator.
        从以下版本开始：
        1.3

      • getLineSeparator

        public String getLineSeparator()
        Returns the string used to represent newlines.
        从以下版本开始：
        1.3

      • incrIndent

        protected void incrIndent()
        Increments the indent level. If indenting would cause getIndentSpace() *getIndentLevel() to be > than getLineLength() this will not cause an indent.

      • decrIndent

        protected void decrIndent()
        Decrements the indent level.

      • getIndentLevel

        protected int getIndentLevel()
        Returns the current indentation level. That is, the number of times incrIndent has been invoked minus the number of times decrIndent has been invoked.
        从以下版本开始：
        1.3

      • indent

        protected void indent()
               throws IOException
        Does indentation. The number of spaces written out is indent level times the space to map mapping. If the current line is empty, this will not make it so that the current line is still considered empty.
        抛出：
        IOException - on any I/O error

      • write

        protected void write(char ch)
              throws IOException
        Writes out a character. This is implemented to invoke the write method that takes a char[].
        参数：
        ch - a char.
        抛出：
        IOException - on any I/O error

      • write

        protected void write(String content)
              throws IOException
        Writes out a string. This is implemented to invoke the write method that takes a char[].
        参数：
        content - a String.
        抛出：
        IOException - on any I/O error

      • writeLineSeparator

        protected void writeLineSeparator()
                           throws IOException
        Writes the line separator. This invokes output directly as well as setting the lineLength to 0.
        抛出：
        IOException
        从以下版本开始：
        1.3

      • write

        protected void write(char[] chars,
         int startIndex,
         int length)
              throws IOException
        All write methods call into this one. If getCanWrapLines() returns false, this will call output with each sequence of chars that doesn't contain a NEWLINE, followed by a call to writeLineSeparator. On the other hand, if getCanWrapLines() returns true, this will split the string, as necessary, so getLineLength is honored. The only exception is if the current string contains no whitespace, and won't fit in which case the line length will exceed getLineLength.
        抛出：
        IOException
        从以下版本开始：
        1.3

      • writeAttributes

        protected void writeAttributes(AttributeSet attr)
                        throws IOException
        Writes out the set of attributes as " =" pairs. It throws an IOException when encountered.
        参数：
        attr - an AttributeSet.
        抛出：
        IOException - on any I/O error

      • output

        protected void output(char[] content,
          int start,
          int length)
               throws IOException
        The last stop in writing out content. All the write methods eventually make it to this method, which invokes write on the Writer.

        This method also updates the line length based on length. If this is invoked to output a newline, the current line length will need to be reset as will no longer be valid. If it is up to the caller to do this. Use writeLineSeparator to write out a newline, which will property update the current line length.

        抛出：
        IOException
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eg


AsyncBoxView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AsyncBoxView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.AsyncBoxView
  • 所有已实现的接口：
    SwingConstants

    public class AsyncBoxView
extends View
    A box that does layout asynchronously. This is useful to keep the GUI event thread moving by not doing any layout on it. The layout is done on a granularity of operations on the child views. After each child view is accessed for some part of layout (a potentially time consuming operation) the remaining tasks can be abandoned or a new higher priority task (i.e. to service a synchronous request or a visible area) can be taken on.

    While the child view is being accessed a read lock is aquired on the associated document so that the model is stable while being accessed.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  AsyncBoxView.ChildLocator
      A class to manage the effective position of the child views in a localized area while changes are being made around the localized area.
      class  AsyncBoxView.ChildState
      A record representing the layout state of a child view.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AsyncBoxView.ChildLocator locator
      Object that manages the offsets of the children.

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      AsyncBoxView(Element elem, int axis)
      Construct a box view that does asynchronous layout.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected AsyncBoxView.ChildState createChildState(View v)
      New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more
      protected void flushRequirementChanges()
      Publish the changes in preferences upward to the parent view.
      float getBottomInset()
      Get the bottom part of the margin around the view.
      Shape getChildAllocation(int index, Shape a)
      Fetches the allocation for the given child view.
      protected AsyncBoxView.ChildState getChildState(int index)
      Fetch the object representing the layout state of of the child at the given index.
      protected boolean getEstimatedMajorSpan()
      Is the major span currently estimated?
      protected float getInsetSpan(int axis)
      Fetch the span along an axis that is taken up by the insets.
      protected LayoutQueue getLayoutQueue()
      Fetch the queue to use for layout.
      float getLeftInset()
      Get the left part of the margin around the view.
      int getMajorAxis()
      Fetch the major axis (the axis the children are tiled along).
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      int getMinorAxis()
      Fetch the minor axis (the axis orthoginal to the tiled axis).
      int getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      float getRightInset()
      Get the right part of the margin around the view.
      float getTopInset()
      Get the top part of the margin around the view.
      View getView(int n)
      Gets the nth child view.
      int getViewCount()
      Returns the number of views in this view.
      int getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      protected int getViewIndexAtPosition(int pos, Position.Bias b)
      Fetches the child view index representing the given position in the model.
      protected void loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      protected void majorRequirementChange(AsyncBoxView.ChildState cs, float delta)
      Requirements changed along the major axis.
      protected void minorRequirementChange(AsyncBoxView.ChildState cs)
      Requirements changed along the minor axis.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape alloc)
      Render the view using the given allocation and rendering surface.
      void preferenceChanged(View child, boolean width, boolean height)
      Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
      void replace(int offset, int length, View[] views)
      Calls the superclass to update the child views, and updates the status records for the children.
      void setBottomInset(float i)
      Set the bottom part of the margin around the view.
      protected void setEstimatedMajorSpan(boolean isEstimated)
      Set the estimatedMajorSpan property that determines if the major span should be treated as being estimated.
      void setLeftInset(float i)
      Set the left part of the margin around the view.
      void setParent(View parent)
      Sets the parent of the view.
      void setRightInset(float i)
      Set the right part of the margin around the view.
      void setSize(float width, float height)
      Sets the size of the view.
      void setTopInset(float i)
      Set the top part of the margin around the view.
      protected void updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Update the layout in response to receiving notification of change from the model.
      int viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getResizeWeight, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, remove, removeAll, removeUpdate, updateChildren, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • locator

        protected AsyncBoxView.ChildLocator locator
        Object that manages the offsets of the children. All locking for management of child locations is on this object.

    • 构造方法详细信息

      • AsyncBoxView

        public AsyncBoxView(Element elem,
            int axis)
        Construct a box view that does asynchronous layout.
        参数：
        elem - the element of the model to represent
        axis - the axis to tile along. This can be either X_AXIS or Y_AXIS.

    • 方法详细信息

      • getMajorAxis

        public int getMajorAxis()
        Fetch the major axis (the axis the children are tiled along). This will have a value of either X_AXIS or Y_AXIS.

      • getMinorAxis

        public int getMinorAxis()
        Fetch the minor axis (the axis orthoginal to the tiled axis). This will have a value of either X_AXIS or Y_AXIS.

      • getTopInset

        public float getTopInset()
        Get the top part of the margin around the view.

      • setTopInset

        public void setTopInset(float i)
        Set the top part of the margin around the view.
        参数：
        i - the value of the inset

      • getBottomInset

        public float getBottomInset()
        Get the bottom part of the margin around the view.

      • setBottomInset

        public void setBottomInset(float i)
        Set the bottom part of the margin around the view.
        参数：
        i - the value of the inset

      • getLeftInset

        public float getLeftInset()
        Get the left part of the margin around the view.

      • setLeftInset

        public void setLeftInset(float i)
        Set the left part of the margin around the view.
        参数：
        i - the value of the inset

      • getRightInset

        public float getRightInset()
        Get the right part of the margin around the view.

      • setRightInset

        public void setRightInset(float i)
        Set the right part of the margin around the view.
        参数：
        i - the value of the inset

      • getInsetSpan

        protected float getInsetSpan(int axis)
        Fetch the span along an axis that is taken up by the insets.
        参数：
        axis - the axis to determine the total insets along, either X_AXIS or Y_AXIS.
        从以下版本开始：
        1.4

      • setEstimatedMajorSpan

        protected void setEstimatedMajorSpan(boolean isEstimated)
        Set the estimatedMajorSpan property that determines if the major span should be treated as being estimated. If this property is true, the value of setSize along the major axis will change the requirements along the major axis and incremental changes will be ignored until all of the children have been updated (which will cause the property to automatically be set to false). If the property is false the value of the majorSpan will be considered to be accurate and incremental changes will be added into the total as they are calculated.
        从以下版本开始：
        1.4

      • getEstimatedMajorSpan

        protected boolean getEstimatedMajorSpan()
        Is the major span currently estimated?
        从以下版本开始：
        1.4

      • getChildState

        protected AsyncBoxView.ChildState getChildState(int index)
        Fetch the object representing the layout state of of the child at the given index.
        参数：
        index - the child index. This should be a value >= 0 and < getViewCount().

      • getLayoutQueue

        protected LayoutQueue getLayoutQueue()
        Fetch the queue to use for layout.

      • createChildState

        protected AsyncBoxView.ChildState createChildState(View v)
        New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more

      • majorRequirementChange

        protected void majorRequirementChange(AsyncBoxView.ChildState cs,
                          float delta)
        Requirements changed along the major axis. This is called by the thread doing layout for the given ChildState object when it has completed fetching the child views new preferences. Typically this would be the layout thread, but might be the event thread if it is trying to update something immediately (such as to perform a model/view translation).

        This is implemented to mark the major axis as having changed so that a future check to see if the requirements need to be published to the parent view will consider the major axis. If the span along the major axis is not estimated, it is updated by the given delta to reflect the incremental change. The delta is ignored if the major span is estimated.

      • minorRequirementChange

        protected void minorRequirementChange(AsyncBoxView.ChildState cs)
        Requirements changed along the minor axis. This is called by the thread doing layout for the given ChildState object when it has completed fetching the child views new preferences. Typically this would be the layout thread, but might be the GUI thread if it is trying to update something immediately (such as to perform a model/view translation).

      • flushRequirementChanges

        protected void flushRequirementChanges()
        Publish the changes in preferences upward to the parent view. This is normally called by the layout thread.

      • replace

        public void replace(int offset,
           int length,
           View[] views)
        Calls the superclass to update the child views, and updates the status records for the children. This is expected to be called while a write lock is held on the model so that interaction with the layout thread will not happen (i.e. the layout thread acquires a read lock before doing anything).
        重载：
        replace in class View
        参数：
        offset - the starting offset into the child views >= 0
        length - the number of existing views to replace >= 0
        views - the child views to insert

      • loadChildren

        protected void loadChildren(ViewFactory f)
        Loads all of the children to initialize the view. This is called by the setParent method. Subclasses can reimplement this to initialize their child views in a different manner. The default implementation creates a child view for each child element.

        Normally a write-lock is held on the Document while the children are being changed, which keeps the rendering and layout threads safe. The exception to this is when the view is initialized to represent an existing element (via this method), so it is synchronized to exclude preferenceChanged while we are initializing.

        参数：
        f - the view factory
        另请参见：
        setParent(javax.swing.text.View)

      • getViewIndexAtPosition

        protected int getViewIndexAtPosition(int pos,
                         Position.Bias b)
        Fetches the child view index representing the given position in the model. This is implemented to fetch the view in the case where there is a child view for each child element.
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position

      • updateLayout

        protected void updateLayout(DocumentEvent.ElementChange ec,
                DocumentEvent e,
                Shape a)
        Update the layout in response to receiving notification of change from the model. This is implemented to note the change on the ChildLocator so that offsets of the children will be correctly computed.
        重载：
        updateLayout in class View
        参数：
        ec - changes to the element this view is responsible for (may be null if there were no changes).
        e - the change information from the associated document
        a - the current allocation of the view
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • setParent

        public void setParent(View parent)
        Sets the parent of the view. This is reimplemented to provide the superclass behavior as well as calling the loadChildren method if this view does not already have children. The children should not be loaded in the constructor because the act of setting the parent may cause them to try to search up the hierarchy (to get the hosting Container for example). If this view has children (the view is being moved from one place in the view hierarchy to another), the loadChildren method will not be called.
        重载：
        setParent in class View
        参数：
        parent - the parent of the view, null if none

      • preferenceChanged

        public void preferenceChanged(View child,
                     boolean width,
                     boolean height)
        Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout. This is reimplemented to queue new work on the layout thread. This method gets messaged from multiple threads via the children.
        重载：
        preferenceChanged in class View
        参数：
        child - the child view
        width - true if the width preference has changed
        height - true if the height preference has changed
        另请参见：
        JComponent.revalidate()

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view if the view caches any layout information.

        Since the major axis is updated asynchronously and should be the sum of the tiled children the call is ignored for the major axis. Since the minor axis is flexible, work is queued to resize the children if the minor span changes.

        重载：
        setSize in class View
        参数：
        width - the width >= 0
        height - the height >= 0

      • paint

        public void paint(Graphics g,
         Shape alloc)
        Render the view using the given allocation and rendering surface.

        This is implemented to determine whether or not the desired region to be rendered (i.e. the unclipped area) is up to date or not. If up-to-date the children are rendered. If not up-to-date, a task to build the desired area is placed on the layout queue as a high priority task. This keeps by event thread moving by rendering if ready, and postponing until a later time if not ready (since paint requests can be rescheduled).

        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        alloc - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis.
        重载：
        getMinimumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis.
        重载：
        getMaximumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getViewCount

        public int getViewCount()
        Returns the number of views in this view. Since the default is to not be a composite view this returns 0.
        重载：
        getViewCount in class View
        返回：
        the number of views >= 0
        另请参见：
        View.getViewCount()

      • getView

        public View getView(int n)
        Gets the nth child view. Since there are no children by default, this returns null.
        重载：
        getView in class View
        参数：
        n - the number of the view to get, >= 0 && < getViewCount()
        返回：
        the view

      • getChildAllocation

        public Shape getChildAllocation(int index,
                       Shape a)
        Fetches the allocation for the given child view. This enables finding out where various views are located, without assuming the views store their location. This returns null since the default is to not have any child views.
        重载：
        getChildAllocation in class View
        参数：
        index - the index of the child, >= 0 && < getViewCount()
        a - the allocation to this view.
        返回：
        the allocation to the child

      • getViewIndex

        public int getViewIndex(int pos,
               Position.Bias b)
        Returns the child view index representing the given position in the model. By default a view has no children so this is implemented to return -1 to indicate there is no valid child index for any position.
        重载：
        getViewIndex in class View
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position
        从以下版本开始：
        1.3

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views.
        返回：
        the bounding box of the given position is returned
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        IllegalArgumentException - for an invalid bias argument
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] biasReturn)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model. The biasReturn argument will be filled in to indicate that the point given is closer to the next character in the model or the previous character in the model.

        This is expected to be called by the GUI thread, holding a read-lock on the associated model. It is implemented to locate the child view and determine it's allocation with a lock on the ChildLocator object, and to call viewToModel on the child view with a lock on the ChildState object to avoid interaction with the layout thread.

        指定者：
        viewToModel in class View
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point in the view >= 0. The biasReturn argument will be filled in to indicate that the point given is closer to the next character in the model or the previous character in the model.

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(int pos,
                            Position.Bias b,
                            Shape a,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        重载：
        getNextVisualPositionFrom in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard; this may be one of the following:
          SwingConstants.WEST SwingConstants.EAST SwingConstants.NORTH SwingConstants.SOUTH
        biasRet - an array contain the bias that was checked
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException
        IllegalArgumentException - if direction is invalid
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AsyncBoxView.ChildLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AsyncBoxView.ChildLocator

  • java.lang.Object
    • javax.swing.text.AsyncBoxView.ChildLocator
  • 封闭类：
    AsyncBoxView

    public class AsyncBoxView.ChildLocator
extends Object
    A class to manage the effective position of the child views in a localized area while changes are being made around the localized area. The AsyncBoxView may be continuously changing, but the visible area needs to remain fairly stable until the layout thread decides to publish an update to the parent.
    从以下版本开始：
    1.3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Rectangle childAlloc
      A shape to use for the child allocation to avoid creating a lot of garbage.
      protected Rectangle lastAlloc
      The last seen allocation (for repainting when changes are flushed upward).
      protected AsyncBoxView.ChildState lastValidOffset
      The location of the last offset calculation that is valid.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AsyncBoxView.ChildLocator()
      construct a child locator.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void childChanged(AsyncBoxView.ChildState cs)
      Notification that a child changed.
      protected Shape getChildAllocation(int index)
      Fetch the allocation to use for a child view.
      Shape getChildAllocation(int index, Shape a)
      Fetch the allocation to use for a child view.
      int getViewIndexAtPoint(float x, float y, Shape a)
      Fetches the child view index at the given point.
      protected int getViewIndexAtVisualOffset(float targetOffset)
      Locate the view responsible for an offset into the box along the major axis.
      void paintChildren(Graphics g)
      Paint the children that intersect the clip area.
      protected void setAllocation(Shape a)
      Copy the currently allocated shape into the Rectangle used to store the current allocation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • lastValidOffset

        protected AsyncBoxView.ChildState lastValidOffset
        The location of the last offset calculation that is valid.

      • lastAlloc

        protected Rectangle lastAlloc
        The last seen allocation (for repainting when changes are flushed upward).

      • childAlloc

        protected Rectangle childAlloc
        A shape to use for the child allocation to avoid creating a lot of garbage.

    • 构造方法详细信息

      • AsyncBoxView.ChildLocator

        public AsyncBoxView.ChildLocator()
        construct a child locator.

    • 方法详细信息

      • childChanged

        public void childChanged(AsyncBoxView.ChildState cs)
        Notification that a child changed. This can effect whether or not new offset calculations are needed. This is called by a ChildState object that has changed it's major span. This can therefore be called by multiple threads.

      • paintChildren

        public void paintChildren(Graphics g)
        Paint the children that intersect the clip area.

      • getChildAllocation

        public Shape getChildAllocation(int index,
                       Shape a)
        Fetch the allocation to use for a child view. This will update the offsets for all children not yet updated before the given index.

      • getViewIndexAtPoint

        public int getViewIndexAtPoint(float x,
                      float y,
                      Shape a)
        Fetches the child view index at the given point. This is called by the various View methods that need to calculate which child to forward a message to. This should be called by a block synchronized on this object, and would typically be followed with one or more calls to getChildAllocation that should also be in the synchronized block.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocation to the View
        返回：
        the nearest child index

      • getChildAllocation

        protected Shape getChildAllocation(int index)
        Fetch the allocation to use for a child view. This does not update the offsets in the ChildState records.

      • setAllocation

        protected void setAllocation(Shape a)
        Copy the currently allocated shape into the Rectangle used to store the current allocation. This would be a floating point rectangle in a Java2D-specific implmentation.

      • getViewIndexAtVisualOffset

        protected int getViewIndexAtVisualOffset(float targetOffset)
        Locate the view responsible for an offset into the box along the major axis. Make sure that offsets are set on the ChildState objects up to the given target span past the desired offset.
        返回：
        index of the view representing the given visual location (targetOffset), or -1 if no view represents that location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

FLi < < !!< ai"" ==D=LL== = =<=====La-=c


AsyncBoxView.ChildState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 AsyncBoxView.ChildState

  • java.lang.Object
    • javax.swing.text.AsyncBoxView.ChildState
  • 所有已实现的接口：
    Runnable
    封闭类：
    AsyncBoxView

    public class AsyncBoxView.ChildState
extends Object
implements Runnable
    A record representing the layout state of a child view. It is runnable as a task on another thread. All access to the child view that is based upon a read-lock on the model should synchronize on this object (i.e. The layout thread and the GUI thread can both have a read lock on the model at the same time and are not protected from each other). Access to a child view hierarchy is serialized via synchronization on the ChildState instance.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      AsyncBoxView.ChildState(View v)
      Construct a child status.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View getChildView()
      Fetch the child view this record represents
      float getMajorOffset()
      Get the offset along the major axis
      float getMajorSpan()
      What is the span along the major axis.
      float getMinorOffset()
      What is the offset along the minor axis
      float getMinorSpan()
      What is the span along the minor axis.
      boolean isLayoutValid()
      Has the child view been laid out.
      void preferenceChanged(boolean width, boolean height)
      Mark preferences changed for this child.
      void run()
      Update the child state.
      void setMajorOffset(float offs)
      This method should only be called by the ChildLocator, it is simply a convenient place to hold the cached location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AsyncBoxView.ChildState

        public AsyncBoxView.ChildState(View v)
        Construct a child status. This needs to start out as fairly large so we don't falsely begin with the idea that all of the children are visible.
        从以下版本开始：
        1.4

    • 方法详细信息

      • getChildView

        public View getChildView()
        Fetch the child view this record represents

      • run

        public void run()
        Update the child state. This should be called by the thread that desires to spend time updating the child state (intended to be the layout thread).

        This aquires a read lock on the associated document for the duration of the update to ensure the model is not changed while it is operating. The first thing to do would be to see if any work actually needs to be done. The following could have conceivably happened while the state was waiting to be updated:

        1. The child may have been removed from the view hierarchy.
        2. The child may have been updated by a higher priority operation (i.e. the child may have become visible).
        指定者：
        run in interface Runnable
        另请参见：
        Thread.run()

      • getMinorSpan

        public float getMinorSpan()
        What is the span along the minor axis.

      • getMinorOffset

        public float getMinorOffset()
        What is the offset along the minor axis

      • getMajorSpan

        public float getMajorSpan()
        What is the span along the major axis.

      • getMajorOffset

        public float getMajorOffset()
        Get the offset along the major axis

      • setMajorOffset

        public void setMajorOffset(float offs)
        This method should only be called by the ChildLocator, it is simply a convenient place to hold the cached location.

      • preferenceChanged

        public void preferenceChanged(boolean width,
                     boolean height)
        Mark preferences changed for this child.
        参数：
        width - true if the width preference has changed
        height - true if the height preference has changed
        另请参见：
        JComponent.revalidate()

      • isLayoutValid

        public boolean isLayoutValid()
        Has the child view been laid out.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a>"cadlad /!<<>v=CALT SC= ===


AttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface AttributeSet

  • All Known Subinterfaces:
    MutableAttributeSet, Style
    All Known Implementing Classes:
    AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, SimpleAttributeSet, StyleContext.NamedStyle, StyleContext.SmallAttributeSet

    public interface AttributeSet
    A collection of unique attributes. This is a read-only, immutable interface. An attribute is basically a key and a value assigned to the key. The collection may represent something like a style run, a logical style, etc. These are generally used to describe features that will contribute to some graphical representation such as a font. The set of possible keys is unbounded and can be anything. Typically View implementations will respond to attribute definitions and render something to represent the attributes.

    Attributes can potentially resolve in a hierarchy. If a key doesn't resolve locally, and a resolving parent exists, the key will be resolved through the parent.

    另请参见：
    MutableAttributeSet

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static interface  AttributeSet.CharacterAttribute
      This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation.
      static interface  AttributeSet.ColorAttribute
      This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
      static interface  AttributeSet.FontAttribute
      This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text.
      static interface  AttributeSet.ParagraphAttribute
      This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Object NameAttribute
      Attribute name used to name the collection of attributes.
      static Object ResolveAttribute
      Attribute name used to identify the resolving parent set of attributes, if one is defined.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containsAttribute(Object name, Object value)
      Returns true if this set defines an attribute with the same name and an equal value.
      boolean containsAttributes(AttributeSet attributes)
      Returns true if this set defines all the attributes from the given set with equal values.
      AttributeSet copyAttributes()
      Returns an attribute set that is guaranteed not to change over time.
      Object getAttribute(Object key)
      Fetches the value of the given attribute.
      int getAttributeCount()
      Returns the number of attributes that are defined locally in this set.
      Enumeration<?> getAttributeNames()
      Returns an enumeration over the names of the attributes that are defined locally in the set.
      AttributeSet getResolveParent()
      Gets the resolving parent.
      boolean isDefined(Object attrName)
      Checks whether the named attribute has a value specified in the set without resolving through another attribute set.
      boolean isEqual(AttributeSet attr)
      Determines if the two attribute sets are equivalent.

    • 字段详细信息

      • NameAttribute

        static final Object NameAttribute
        Attribute name used to name the collection of attributes.

      • ResolveAttribute

        static final Object ResolveAttribute
        Attribute name used to identify the resolving parent set of attributes, if one is defined.

    • 方法详细信息

      • getAttributeCount

        int getAttributeCount()
        Returns the number of attributes that are defined locally in this set. Attributes that are defined in the parent set are not included.
        返回：
        the number of attributes >= 0

      • isDefined

        boolean isDefined(Object attrName)
        Checks whether the named attribute has a value specified in the set without resolving through another attribute set.
        参数：
        attrName - the attribute name
        返回：
        true if the attribute has a value specified

      • isEqual

        boolean isEqual(AttributeSet attr)
        Determines if the two attribute sets are equivalent.
        参数：
        attr - an attribute set
        返回：
        true if the sets are equivalent

      • copyAttributes

        AttributeSet copyAttributes()
        Returns an attribute set that is guaranteed not to change over time.
        返回：
        a copy of the attribute set

      • getAttribute

        Object getAttribute(Object key)
        Fetches the value of the given attribute. If the value is not found locally, the search is continued upward through the resolving parent (if one exists) until the value is either found or there are no more parents. If the value is not found, null is returned.
        参数：
        key - the non-null key of the attribute binding
        返回：
        the value of the attribute, or null if not found

      • getAttributeNames

        Enumeration<?> getAttributeNames()
        Returns an enumeration over the names of the attributes that are defined locally in the set. Names of attributes defined in the resolving parent, if any, are not included. The values of the Enumeration may be anything and are not constrained to a particular Object type.

        This method never returns null. For a set with no attributes, it returns an empty Enumeration.

        返回：
        the names

      • containsAttribute

        boolean containsAttribute(Object name,
                        Object value)
        Returns true if this set defines an attribute with the same name and an equal value. If such an attribute is not found locally, it is searched through in the resolving parent hierarchy.
        参数：
        name - the non-null attribute name
        value - the value
        返回：
        true if the set defines the attribute with an equal value, either locally or through its resolving parent
        抛出：
        NullPointerException - if either name or value is null

      • containsAttributes

        boolean containsAttributes(AttributeSet attributes)
        Returns true if this set defines all the attributes from the given set with equal values. If an attribute is not found locally, it is searched through in the resolving parent hierarchy.
        参数：
        attributes - the set of attributes to check against
        返回：
        true if this set defines all the attributes with equal values, either locally or through its resolving parent
        抛出：
        NullPointerException - if attributes is null

      • getResolveParent

        AttributeSet getResolveParent()
        Gets the resolving parent.
        返回：
        the parent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

larcp;ibl ar/ >V.


AttributeSet.CharacterAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

Interface AttributeSet.CharacterAttribute

  • All Known Implementing Classes:
    StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants
    Enclosing interface:
    AttributeSet

    public static interface AttributeSet.CharacterAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation. This would be any attribute that applies to a so-called run of style.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st=>Cl"ol"=aa"==cttt>lfo�<


AttributeSet.ColorAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

Interface AttributeSet.ColorAttribute

  • All Known Implementing Classes:
    StyleConstants.ColorConstants
    Enclosing interface:
    AttributeSet

    public static interface AttributeSet.ColorAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

SuE>l>_> >"aa SDmtSSph//wa


AttributeSet.FontAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

Interface AttributeSet.FontAttribute

  • All Known Implementing Classes:
    StyleConstants.FontConstants
    Enclosing interface:
    AttributeSet

    public static interface AttributeSet.FontAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text. This is not considered to be a closed set, the definition can change across version of the platform and can be amended by additional user added entries that correspond to logical settings that are specific to some type of content.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,1 =B,,1,3l111╡ al0


AttributeSet.ParagraphAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

Interface AttributeSet.ParagraphAttribute

  • All Known Implementing Classes:
    StyleConstants.ParagraphConstants
    Enclosing interface:
    AttributeSet

    public static interface AttributeSet.ParagraphAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>/n=tl"tlcaalccs


BadLocationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 BadLocationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.swing.text.BadLocationException
  • 所有已实现的接口：
    Serializable

    public class BadLocationException
extends Exception
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BadLocationException(String s, int offs)
      Creates a new BadLocationException object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int offsetRequested()
      Returns the offset into the document that was not legal.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BadLocationException

        public BadLocationException(String s,
                    int offs)
        Creates a new BadLocationException object.
        参数：
        s - a string indicating what was wrong with the arguments
        offs - offset within the document that was requested >= 0

    • 方法详细信息

      • offsetRequested

        public int offsetRequested()
        Returns the offset into the document that was not legal.
        返回：
        the offset >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aast>d>>v >v>. dd>Rus rtlniu mutt"kce


BoxView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 BoxView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    BlockView, FlowView, TableView, TableView.TableCell, TableView.TableRow, WrappedPlainView, ZoneView

    public class BoxView
extends CompositeView
    A view that arranges its children into a box shape by tiling its children along an axis. The box is somewhat like that found in TeX where there is alignment of the children, flexibility of the children is considered, etc. This is a building block that might be useful to represent things like a collection of lines, paragraphs, lists, columns, pages, etc. The axis along which the children are tiled is considered the major axis. The orthoginal axis is the minor axis.

    Layout for each axis is handled separately by the methods layoutMajorAxis and layoutMinorAxis. Subclasses can change the layout algorithm by reimplementing these methods. These methods will be called as necessary depending upon whether or not there is cached layout information and the cache is considered valid. These methods are typically called if the given size along the axis changes, or if layoutChanged is called to force an updated layout. The layoutChanged method invalidates cached layout information, if there is any. The requirements published to the parent view are calculated by the methods calculateMajorAxisRequirements and calculateMinorAxisRequirements. If the layout algorithm is changed, these methods will likely need to be reimplemented.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      BoxView(Element elem, int axis)
      Constructs a BoxView.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void baselineLayout(int targetSpan, int axis, int[] offsets, int[] spans)
      Computes the location and extent of each child view in this BoxView given the targetSpan, which is the width (or height) of the region we have to work with.
      protected SizeRequirements baselineRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for this BoxView by examining the size of each child view.
      protected SizeRequirements calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the major axis axis.
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculates the size requirements for the minor axis axis.
      protected void childAllocation(int index, Rectangle alloc)
      Allocates a region for a child view.
      protected boolean flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      protected void forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      int getAxis()
      Fetches the tile axis property.
      Shape getChildAllocation(int index, Shape a)
      Fetches the allocation for the given child view.
      int getHeight()
      Returns the current height of the box.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      protected int getOffset(int axis, int childIndex)
      Fetches the offset of a particular child's current layout.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      int getResizeWeight(int axis)
      Gets the resize weight.
      protected int getSpan(int axis, int childIndex)
      Fetches the span of a particular childs current layout.
      protected View getViewAtPoint(int x, int y, Rectangle alloc)
      Fetches the child view at the given coordinates.
      int getWidth()
      Returns the current width of the box.
      protected boolean isAfter(int x, int y, Rectangle innerAlloc)
      Determines if a point falls after an allocated region.
      protected boolean isAllocationValid()
      Are the allocations for the children still valid?
      protected boolean isBefore(int x, int y, Rectangle innerAlloc)
      Determines if a point falls before an allocated region.
      protected boolean isLayoutValid(int axis)
      Determines if the layout is valid along the given axis.
      protected void layout(int width, int height)
      Perform layout on the box
      void layoutChanged(int axis)
      Invalidates the layout along an axis.
      protected void layoutMajorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Performs layout for the major axis of the box (i.e.
      protected void layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Performs layout for the minor axis of the box (i.e.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape allocation)
      Renders the BoxView using the given rendering surface and area on that surface.
      protected void paintChild(Graphics g, Rectangle alloc, int index)
      Paints a child.
      void preferenceChanged(View child, boolean width, boolean height)
      This is called by a child to indicate its preferred span has changed.
      void replace(int index, int length, View[] elems)
      Invalidates the layout and resizes the cache of requests/allocations.
      void setAxis(int axis)
      Sets the tile axis property.
      void setSize(float width, float height)
      Sets the size of the view.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BoxView

        public BoxView(Element elem,
       int axis)
        Constructs a BoxView.
        参数：
        elem - the element this view is responsible for
        axis - either View.X_AXIS or View.Y_AXIS

    • 方法详细信息

      • getAxis

        public int getAxis()
        Fetches the tile axis property. This is the axis along which the child views are tiled.
        返回：
        the major axis of the box, either View.X_AXIS or View.Y_AXIS
        从以下版本开始：
        1.3

      • setAxis

        public void setAxis(int axis)
        Sets the tile axis property. This is the axis along which the child views are tiled.
        参数：
        axis - either View.X_AXIS or View.Y_AXIS
        从以下版本开始：
        1.3

      • layoutChanged

        public void layoutChanged(int axis)
        Invalidates the layout along an axis. This happens automatically if the preferences have changed for any of the child views. In some cases the layout may need to be recalculated when the preferences have not changed. The layout can be marked as invalid by calling this method. The layout will be updated the next time the setSize method is called on this view (typically in paint).
        参数：
        axis - either View.X_AXIS or View.Y_AXIS
        从以下版本开始：
        1.3

      • isLayoutValid

        protected boolean isLayoutValid(int axis)
        Determines if the layout is valid along the given axis.
        参数：
        axis - either View.X_AXIS or View.Y_AXIS
        从以下版本开始：
        1.4

      • paintChild

        protected void paintChild(Graphics g,
              Rectangle alloc,
              int index)
        Paints a child. By default that is all it does, but a subclass can use this to paint things relative to the child.
        参数：
        g - the graphics context
        alloc - the allocated region to paint into
        index - the child index, >= 0 && < getViewCount()

      • replace

        public void replace(int index,
           int length,
           View[] elems)
        Invalidates the layout and resizes the cache of requests/allocations. The child allocations can still be accessed for the old layout, but the new children will have an offset and span of 0.
        重载：
        replace in class CompositeView
        参数：
        index - the starting index into the child views to insert the new views; this should be a value >= 0 and <= getViewCount
        length - the number of existing child views to remove; This should be a value >= 0 and <= (getViewCount() - offset)
        elems - the child views to add; this value can be nullto indicate no children are being added (useful to remove)

      • forwardUpdate

        protected void forwardUpdate(DocumentEvent.ElementChange ec,
                 DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Forwards the given DocumentEvent to the child views that need to be notified of the change to the model. If a child changed its requirements and the allocation was valid prior to forwarding the portion of the box from the starting child to the end of the box will be repainted.
        重载：
        forwardUpdate in class View
        参数：
        ec - changes to the element this view is responsible for (may be null if there were no changes)
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        从以下版本开始：
        1.3
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • preferenceChanged

        public void preferenceChanged(View child,
                     boolean width,
                     boolean height)
        This is called by a child to indicate its preferred span has changed. This is implemented to throw away cached layout information so that new calculations will be done the next time the children need an allocation.
        重载：
        preferenceChanged in class View
        参数：
        child - the child view
        width - true if the width preference should change
        height - true if the height preference should change
        另请参见：
        JComponent.revalidate()

      • getResizeWeight

        public int getResizeWeight(int axis)
        Gets the resize weight. A value of 0 or less is not resizable.
        重载：
        getResizeWeight in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the weight
        抛出：
        IllegalArgumentException - for an invalid axis

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view if the view caches any layout information. This is implemented to call the layout method with the sizes inside of the insets.
        重载：
        setSize in class View
        参数：
        width - the width >= 0
        height - the height >= 0

      • paint

        public void paint(Graphics g,
         Shape allocation)
        Renders the BoxView using the given rendering surface and area on that surface. Only the children that intersect the clip bounds of the given Graphics will be rendered.
        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        allocation - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getChildAllocation

        public Shape getChildAllocation(int index,
                       Shape a)
        Fetches the allocation for the given child view. This enables finding out where various views are located. This is implemented to return null if the layout is invalid, otherwise the superclass behavior is executed.
        重载：
        getChildAllocation in class CompositeView
        参数：
        index - the index of the child, >= 0 && < getViewCount()
        a - the allocation to this view
        返回：
        the allocation to the child; or null if a is null; or null if the layout is invalid

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it. This makes sure the allocation is valid before calling the superclass.
        重载：
        modelToView in class CompositeView
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - a bias value of either Position.Bias.Forward or Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        重载：
        viewToModel in class CompositeView
        参数：
        x - x coordinate of the view location to convert >= 0
        y - y coordinate of the view location to convert >= 0
        a - the allocated region to render into
        bias - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        the location within the model that best represents the given point in the view >= 0
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the total alignment needed to position the children with the alignment points lined up along the axis orthoginal to the axis that is being tiled. The axis being tiled will request to be centered (i.e. 0.5f).
        重载：
        getAlignment in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the desired alignment >= 0.0f && <= 1.0f; this should be a value between 0.0 and 1.0 where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin; an alignment of 0.5 would be the center of the view
        抛出：
        IllegalArgumentException - for an invalid axis

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis.
        重载：
        getMinimumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis.
        重载：
        getMaximumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • isAllocationValid

        protected boolean isAllocationValid()
        Are the allocations for the children still valid?
        返回：
        true if allocations still valid

      • isBefore

        protected boolean isBefore(int x,
               int y,
               Rectangle innerAlloc)
        Determines if a point falls before an allocated region.
        指定者：
        isBefore in class CompositeView
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        innerAlloc - the allocated region; this is the area inside of the insets
        返回：
        true if the point lies before the region else false

      • isAfter

        protected boolean isAfter(int x,
              int y,
              Rectangle innerAlloc)
        Determines if a point falls after an allocated region.
        指定者：
        isAfter in class CompositeView
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        innerAlloc - the allocated region; this is the area inside of the insets
        返回：
        true if the point lies after the region else false

      • getViewAtPoint

        protected View getViewAtPoint(int x,
                  int y,
                  Rectangle alloc)
        Fetches the child view at the given coordinates.
        指定者：
        getViewAtPoint in class CompositeView
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        alloc - the parents inner allocation on entry, which should be changed to the childs allocation on exit
        返回：
        the view

      • childAllocation

        protected void childAllocation(int index,
                   Rectangle alloc)
        Allocates a region for a child view.
        指定者：
        childAllocation in class CompositeView
        参数：
        index - the index of the child view to allocate, >= 0 && < getViewCount()
        alloc - the allocated region

      • layout

        protected void layout(int width,
          int height)
        Perform layout on the box
        参数：
        width - the width (inside of the insets) >= 0
        height - the height (inside of the insets) >= 0

      • getWidth

        public int getWidth()
        Returns the current width of the box. This is the width that it was last allocated.
        返回：
        the current width of the box

      • getHeight

        public int getHeight()
        Returns the current height of the box. This is the height that it was last allocated.
        返回：
        the current height of the box

      • layoutMajorAxis

        protected void layoutMajorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Performs layout for the major axis of the box (i.e. the axis that it represents). The results of the layout (the offset and span for each children) are placed in the given arrays which represent the allocations to the children along the major axis.
        参数：
        targetSpan - the total span given to the view, which would be used to layout the children
        axis - the axis being layed out
        offsets - the offsets from the origin of the view for each of the child views; this is a return value and is filled in by the implementation of this method
        spans - the span of each child view; this is a return value and is filled in by the implementation of this method

      • layoutMinorAxis

        protected void layoutMinorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Performs layout for the minor axis of the box (i.e. the axis orthoginal to the axis that it represents). The results of the layout (the offset and span for each children) are placed in the given arrays which represent the allocations to the children along the minor axis.
        参数：
        targetSpan - the total span given to the view, which would be used to layout the children
        axis - the axis being layed out
        offsets - the offsets from the origin of the view for each of the child views; this is a return value and is filled in by the implementation of this method
        spans - the span of each child view; this is a return value and is filled in by the implementation of this method

      • calculateMajorAxisRequirements

        protected SizeRequirements calculateMajorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculates the size requirements for the major axis axis.
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculates the size requirements for the minor axis axis.
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • baselineLayout

        protected void baselineLayout(int targetSpan,
                  int axis,
                  int[] offsets,
                  int[] spans)
        Computes the location and extent of each child view in this BoxView given the targetSpan, which is the width (or height) of the region we have to work with.
        参数：
        targetSpan - the total span given to the view, which would be used to layout the children
        axis - the axis being studied, either View.X_AXIS or View.Y_AXIS
        offsets - an empty array filled by this method with values specifying the location of each child view
        spans - an empty array filled by this method with values specifying the extent of each child view

      • baselineRequirements

        protected SizeRequirements baselineRequirements(int axis,
                                    SizeRequirements r)
        Calculates the size requirements for this BoxView by examining the size of each child view.
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object

      • getOffset

        protected int getOffset(int axis,
            int childIndex)
        Fetches the offset of a particular child's current layout.
        参数：
        axis - the axis being studied
        childIndex - the index of the requested child
        返回：
        the offset (location) for the specified child

      • getSpan

        protected int getSpan(int axis,
          int childIndex)
        Fetches the span of a particular childs current layout.
        参数：
        axis - the axis being studied
        childIndex - the index of the requested child
        返回：
        the span (width or height) of the specified child

      • flipEastAndWestAtEnds

        protected boolean flipEastAndWestAtEnds(int position,
                            Position.Bias bias)
        Determines in which direction the next view lays. Consider the View at index n. Typically the Views are layed out from left to right, so that the View to the EAST will be at index n + 1, and the View to the WEST will be at index n - 1. In certain situations, such as with bidirectional text, it is possible that the View to EAST is not at index n + 1, but rather at index n - 1, or that the View to the WEST is not at index n - 1, but index n + 1. In this case this method would return true, indicating the Views are layed out in descending order. Otherwise the method would return false indicating the Views are layed out in ascending order.

        If the receiver is laying its Views along the Y_AXIS, this will will return the value from invoking the same method on the View responsible for rendering position and bias. Otherwise this will return false.

        重载：
        flipEastAndWestAtEnds in class CompositeView
        参数：
        position - position into the model
        bias - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        true if the Views surrounding the View responding for rendering position and bias are layed out in descending order; otherwise false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Caret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Caret

  • All Known Implementing Classes:
    BasicTextUI.BasicCaret, DefaultCaret

    public interface Caret
    A place within a document view that represents where things can be inserted into the document model. A caret has a position in the document referred to as a dot. The dot is where the caret is currently located in the model. There is a second position maintained by the caret that represents the other end of a selection called mark. If there is no selection the dot and mark will be equal. If a selection exists, the two values will be different.

    The dot can be placed by either calling setDot or moveDot. Setting the dot has the effect of removing any selection that may have previously existed. The dot and mark will be equal. Moving the dot has the effect of creating a selection as the mark is left at whatever position it previously had.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a listener to track whenever the caret position has been changed.
      void deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      int getBlinkRate()
      Gets the blink rate of the caret.
      int getDot()
      Fetches the current position of the caret.
      Point getMagicCaretPosition()
      Gets the current caret visual location.
      int getMark()
      Fetches the current position of the mark.
      void install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      boolean isSelectionVisible()
      Determines if the selection is currently visible.
      boolean isVisible()
      Determines if the caret is currently visible.
      void moveDot(int dot)
      Moves the caret position (dot) to some other position, leaving behind the mark.
      void paint(Graphics g)
      Renders the caret.
      void removeChangeListener(ChangeListener l)
      Removes a listener that was tracking caret position changes.
      void setBlinkRate(int rate)
      Sets the blink rate of the caret.
      void setDot(int dot)
      Sets the caret position to some position.
      void setMagicCaretPosition(Point p)
      Set the current caret visual location.
      void setSelectionVisible(boolean v)
      Sets the visibility of the selection
      void setVisible(boolean v)
      Sets the visibility of the caret.

    • 方法详细信息

      • install

        void install(JTextComponent c)
        Called when the UI is being installed into the interface of a JTextComponent. This can be used to gain access to the model that is being navigated by the implementation of this interface.
        参数：
        c - the JTextComponent

      • deinstall

        void deinstall(JTextComponent c)
        Called when the UI is being removed from the interface of a JTextComponent. This is used to unregister any listeners that were attached.
        参数：
        c - the JTextComponent

      • paint

        void paint(Graphics g)
        Renders the caret. This method is called by UI classes.
        参数：
        g - the graphics context

      • addChangeListener

        void addChangeListener(ChangeListener l)
        Adds a listener to track whenever the caret position has been changed.
        参数：
        l - the change listener

      • removeChangeListener

        void removeChangeListener(ChangeListener l)
        Removes a listener that was tracking caret position changes.
        参数：
        l - the change listener

      • isVisible

        boolean isVisible()
        Determines if the caret is currently visible.
        返回：
        true if the caret is visible else false

      • setVisible

        void setVisible(boolean v)
        Sets the visibility of the caret.
        参数：
        v - true if the caret should be shown, and false if the caret should be hidden

      • isSelectionVisible

        boolean isSelectionVisible()
        Determines if the selection is currently visible.
        返回：
        true if the caret is visible else false

      • setSelectionVisible

        void setSelectionVisible(boolean v)
        Sets the visibility of the selection
        参数：
        v - true if the caret should be shown, and false if the caret should be hidden

      • setMagicCaretPosition

        void setMagicCaretPosition(Point p)
        Set the current caret visual location. This can be used when moving between lines that have uneven end positions (such as when caret up or down actions occur). If text flows left-to-right or right-to-left the x-coordinate will indicate the desired navigation location for vertical movement. If the text flow is top-to-bottom, the y-coordinate will indicate the desired navigation location for horizontal movement.
        参数：
        p - the Point to use for the saved position. This can be null to indicate there is no visual location.

      • getMagicCaretPosition

        Point getMagicCaretPosition()
        Gets the current caret visual location.
        返回：
        the visual position.
        另请参见：
        setMagicCaretPosition(java.awt.Point)

      • setBlinkRate

        void setBlinkRate(int rate)
        Sets the blink rate of the caret. This determines if and how fast the caret blinks, commonly used as one way to attract attention to the caret.
        参数：
        rate - the delay in milliseconds >= 0. If this is zero the caret will not blink.

      • getBlinkRate

        int getBlinkRate()
        Gets the blink rate of the caret. This determines if and how fast the caret blinks, commonly used as one way to attract attention to the caret.
        返回：
        the delay in milliseconds >= 0. If this is zero the caret will not blink.

      • getDot

        int getDot()
        Fetches the current position of the caret.
        返回：
        the position >= 0

      • getMark

        int getMark()
        Fetches the current position of the mark. If there is a selection, the mark will not be the same as the dot.
        返回：
        the position >= 0

      • setDot

        void setDot(int dot)
        Sets the caret position to some position. This causes the mark to become the same as the dot, effectively setting the selection range to zero.

        If the parameter is negative or beyond the length of the document, the caret is placed at the beginning or at the end, respectively.

        参数：
        dot - the new position to set the caret to

      • moveDot

        void moveDot(int dot)
        Moves the caret position (dot) to some other position, leaving behind the mark. This is useful for making selections.
        参数：
        dot - the new position to move the caret to >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nabrattha>>g//n,ii=>.


ChangedCharSetException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 ChangedCharSetException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
  • 所有已实现的接口：
    Serializable

    public class ChangedCharSetException
extends IOException
    ChangedCharSetException as the name indicates is an exception thrown when the charset is changed.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ChangedCharSetException(String charSetSpec, boolean charSetKey)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String getCharSetSpec()
      boolean | keyEqualsCharSet()

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ChangedCharSetException

        public ChangedCharSetException(String charSetSpec,
                       boolean charSetKey)

    • 方法详细信息

      • getCharSetSpec

        public String getCharSetSpec()

      • keyEqualsCharSet

        public boolean keyEqualsCharSet()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>;n.


ComponentView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 ComponentView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.ComponentView
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    FormView, ObjectView

    public class ComponentView
extends View
    Component decorator that implements the view interface. The entire element is used to represent the component. This acts as a gateway from the display-only View implementations to interactive lightweight components (ie it allows components to be embedded into the View hierarchy).

    The component is placed relative to the text baseline according to the value returned by Component.getAlignmentY. For Swing components this value can be conveniently set using the method JComponent.setAlignmentY. For example, setting a value of 0.75 will cause 75 percent of the component to be above the baseline, and 25 percent of the component to be below the baseline.

    This class is implemented to do the extra work necessary to work properly in the presence of multiple threads (i.e. from asynchronous notification of model changes for example) by ensuring that all component access is done on the event thread.

    The component used is determined by the return value of the createComponent method. The default implementation of this method is to return the component held as an attribute of the element (by calling StyleConstants.getComponent). A limitation of this behavior is that the component cannot be used by more than one text component (i.e. with a shared model). Subclasses can remove this constraint by implementing the createComponent to actually create a component based upon some kind of specification contained in the attributes. The ObjectView class in the html package is an example of a ComponentView implementation that supports multiple component views of a shared model.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComponentView(Element elem)
      Creates a new ComponentView object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Component createComponent()
      Create the component that is associated with this view.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      Component getComponent()
      Fetch the component associated with the view.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the coordinate space of the model to that of the view.
      void paint(Graphics g, Shape a)
      The real paint behavior occurs naturally from the association that the component has with its parent container (the same container hosting this view).
      void setParent(View p)
      Sets the parent for a child view.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentView

        public ComponentView(Element elem)
        Creates a new ComponentView object.
        参数：
        elem - the element to decorate

    • 方法详细信息

      • createComponent

        protected Component createComponent()
        Create the component that is associated with this view. This will be called when it has been determined that a new component is needed. This would result from a call to setParent or as a result of being notified that attributes have changed.

      • getComponent

        public final Component getComponent()
        Fetch the component associated with the view.

      • paint

        public void paint(Graphics g,
         Shape a)
        The real paint behavior occurs naturally from the association that the component has with its parent container (the same container hosting this view). This is implemented to do nothing.
        指定者：
        paint in class View
        参数：
        g - the graphics context
        a - the shape
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis. This is implemented to return the value returned by Component.getPreferredSize along the axis of interest.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis. This is implemented to return the value returned by Component.getMinimumSize along the axis of interest.
        重载：
        getMinimumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis. This is implemented to return the value returned by Component.getMaximumSize along the axis of interest.
        重载：
        getMaximumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the alignment of the embedded component.
        重载：
        getAlignment in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the desired alignment. This should be a value between 0.0 and 1.0 where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin. An alignment of 0.5 would be the center of the view.

      • setParent

        public void setParent(View p)
        Sets the parent for a child view. The parent calls this on the child to tell it who its parent is, giving the view access to things like the hosting Container. The superclass behavior is executed, followed by a call to createComponent if the parent view parameter is non-null and a component has not yet been created. The embedded components parent is then set to the value returned by getContainer. If the parent view parameter is null, this view is being cleaned up, thus the component is removed from its parent.

        The changing of the component hierarchy will touch the component lock, which is the one thing that is not safe from the View hierarchy. Therefore, this functionality is executed immediately if on the event thread, or is queued on the event queue if called from another thread (notification of change from an asynchronous update).

        重载：
        setParent in class View
        参数：
        p - the parent

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the coordinate space of the model to that of the view.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position is returned
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point in the view
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CompositeView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 CompositeView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    BoxView

    public abstract class CompositeView
extends View
    CompositeView is an abstract View implementation which manages one or more child views. (Note that CompositeView is intended for managing relatively small numbers of child views.) CompositeView is intended to be used as a starting point for View implementations, such as BoxView, that will contain child Views. Subclasses that wish to manage the collection of child Views should use the replace(int, int, javax.swing.text.View[]) method. As View invokes replace during DocumentListener notification, you normally won't need to directly invoke replace.

    While CompositeView does not impose a layout policy on its child Views, it does allow for inseting the child Views it will contain. The insets can be set by either setInsets(short, short, short, short) or setParagraphInsets(javax.swing.text.AttributeSet).

    In addition to the abstract methods of View, subclasses of CompositeView will need to override:

    • isBefore(int, int, java.awt.Rectangle) - Used to test if a given View location is before the visual space of the CompositeView.
    • isAfter(int, int, java.awt.Rectangle) - Used to test if a given View location is after the visual space of the CompositeView.
    • getViewAtPoint(int, int, java.awt.Rectangle) - Returns the view at a given visual location.
    • childAllocation(int, java.awt.Rectangle) - Returns the bounds of a particular child View. getChildAllocation will invoke childAllocation after offseting the bounds by the Insets of the CompositeView.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompositeView(Element elem)
      Constructs a CompositeView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract void childAllocation(int index, Rectangle a)
      Returns the allocation for a given child.
      protected boolean flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      protected short getBottomInset()
      Gets the bottom inset.
      Shape getChildAllocation(int index, Shape a)
      Fetches the allocation for the given child view to render into.
      protected Rectangle getInsideAllocation(Shape a)
      Translates the immutable allocation given to the view to a mutable allocation that represents the interior allocation (i.e.
      protected short getLeftInset()
      Gets the left inset.
      protected int getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected int getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the north or south direction.
      int getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      protected short getRightInset()
      Gets the right inset.
      protected short getTopInset()
      Gets the top inset.
      View getView(int n)
      Returns the n-th view in this container.
      protected abstract View getViewAtPoint(int x, int y, Rectangle alloc)
      Fetches the child view at the given coordinates.
      protected View getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      int getViewCount()
      Returns the number of child views of this view.
      int getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      protected int getViewIndexAtPosition(int pos)
      Fetches the child view index representing the given position in the model.
      protected abstract boolean isAfter(int x, int y, Rectangle alloc)
      Tests whether a point lies after the rectangle range.
      protected abstract boolean isBefore(int x, int y, Rectangle alloc)
      Tests whether a point lies before the rectangle range.
      protected void loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      Shape modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void replace(int offset, int length, View[] views)
      Replaces child views.
      protected void setInsets(short top, short left, short bottom, short right)
      Sets the insets for the view.
      protected void setParagraphInsets(AttributeSet attr)
      Sets the insets from the paragraph attributes specified in the given attributes.
      void setParent(View parent)
      Sets the parent of the view.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getParent, getPreferredSpan, getResizeWeight, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, paint, preferenceChanged, remove, removeAll, removeUpdate, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CompositeView

        public CompositeView(Element elem)
        Constructs a CompositeView for the given element.
        参数：
        elem - the element this view is responsible for

    • 方法详细信息

      • loadChildren

        protected void loadChildren(ViewFactory f)
        Loads all of the children to initialize the view. This is called by the setParent(javax.swing.text.View) method. Subclasses can reimplement this to initialize their child views in a different manner. The default implementation creates a child view for each child element.
        参数：
        f - the view factory
        另请参见：
        setParent(javax.swing.text.View)

      • setParent

        public void setParent(View parent)
        Sets the parent of the view. This is reimplemented to provide the superclass behavior as well as calling the loadChildren method if this view does not already have children. The children should not be loaded in the constructor because the act of setting the parent may cause them to try to search up the hierarchy (to get the hosting Container for example). If this view has children (the view is being moved from one place in the view hierarchy to another), the loadChildren method will not be called.
        重载：
        setParent in class View
        参数：
        parent - the parent of the view, null if none

      • getViewCount

        public int getViewCount()
        Returns the number of child views of this view.
        重载：
        getViewCount in class View
        返回：
        the number of views >= 0
        另请参见：
        getView(int)

      • getView

        public View getView(int n)
        Returns the n-th view in this container.
        重载：
        getView in class View
        参数：
        n - the number of the desired view, >= 0 && < getViewCount()
        返回：
        the view at index n

      • replace

        public void replace(int offset,
           int length,
           View[] views)
        Replaces child views. If there are no views to remove this acts as an insert. If there are no views to add this acts as a remove. Views being removed will have the parent set to null, and the internal reference to them removed so that they may be garbage collected.
        重载：
        replace in class View
        参数：
        offset - the starting index into the child views to insert the new views; >= 0 and <= getViewCount
        length - the number of existing child views to remove; this should be a value >= 0 and <= (getViewCount() - offset)
        views - the child views to add; this value can be null to indicate no children are being added (useful to remove)

      • getChildAllocation

        public Shape getChildAllocation(int index,
                       Shape a)
        Fetches the allocation for the given child view to render into. This enables finding out where various views are located.
        重载：
        getChildAllocation in class View
        参数：
        index - the index of the child, >= 0 && < getViewCount()
        a - the allocation to this view
        返回：
        the allocation to the child

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - a bias value of either Position.Bias.Forward or Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • modelToView

        public Shape modelToView(int p0,
                Position.Bias b0,
                int p1,
                Position.Bias b1,
                Shape a)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        重载：
        modelToView in class View
        参数：
        p0 - the position to convert >= 0
        b0 - the bias toward the previous character or the next character represented by p0, in case the position is a boundary of two views; either Position.Bias.Forward or Position.Bias.Backward
        p1 - the position to convert >= 0
        b1 - the bias toward the previous character or the next character represented by p1, in case the position is a boundary of two views
        a - the allocated region to render into
        返回：
        the bounding box of the given position is returned
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        IllegalArgumentException - for an invalid bias argument
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        x - x coordinate of the view location to convert >= 0
        y - y coordinate of the view location to convert >= 0
        a - the allocated region to render into
        bias - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        the location within the model that best represents the given point in the view >= 0
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(int pos,
                            Position.Bias b,
                            Shape a,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model. This is a convenience method for getNextNorthSouthVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[]) and getNextEastWestVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[]).
        重载：
        getNextVisualPositionFrom in class View
        参数：
        pos - the position to convert >= 0
        b - a bias value of either Position.Bias.Forward or Position.Bias.Backward
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard; this may be one of the following:
        • SwingConstants.WEST
        • SwingConstants.EAST
        • SwingConstants.NORTH
        • SwingConstants.SOUTH
        biasRet - an array containing the bias that was checked
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException
        IllegalArgumentException - if direction is invalid

      • getViewIndex

        public int getViewIndex(int pos,
               Position.Bias b)
        Returns the child view index representing the given position in the model. This is implemented to call the getViewIndexByPosition method for backward compatibility.
        重载：
        getViewIndex in class View
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position
        从以下版本开始：
        1.3

      • isBefore

        protected abstract boolean isBefore(int x,
               int y,
               Rectangle alloc)
        Tests whether a point lies before the rectangle range.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        alloc - the rectangle
        返回：
        true if the point is before the specified range

      • isAfter

        protected abstract boolean isAfter(int x,
              int y,
              Rectangle alloc)
        Tests whether a point lies after the rectangle range.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        alloc - the rectangle
        返回：
        true if the point is after the specified range

      • getViewAtPoint

        protected abstract View getViewAtPoint(int x,
                  int y,
                  Rectangle alloc)
        Fetches the child view at the given coordinates.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        alloc - the parent's allocation on entry, which should be changed to the child's allocation on exit
        返回：
        the child view

      • childAllocation

        protected abstract void childAllocation(int index,
                   Rectangle a)
        Returns the allocation for a given child.
        参数：
        index - the index of the child, >= 0 && < getViewCount()
        a - the allocation to the interior of the box on entry, and the allocation of the child view at the index on exit.

      • getViewAtPosition

        protected View getViewAtPosition(int pos,
                     Rectangle a)
        Fetches the child view that represents the given position in the model. This is implemented to fetch the view in the case where there is a child view for each child element.
        参数：
        pos - the position >= 0
        a - the allocation to the interior of the box on entry, and the allocation of the view containing the position on exit
        返回：
        the view representing the given position, or null if there isn't one

      • getViewIndexAtPosition

        protected int getViewIndexAtPosition(int pos)
        Fetches the child view index representing the given position in the model. This is implemented to fetch the view in the case where there is a child view for each child element.
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position

      • getInsideAllocation

        protected Rectangle getInsideAllocation(Shape a)
        Translates the immutable allocation given to the view to a mutable allocation that represents the interior allocation (i.e. the bounds of the given allocation with the top, left, bottom, and right insets removed. It is expected that the returned value would be further mutated to represent an allocation to a child view. This is implemented to reuse an instance variable so it avoids creating excessive Rectangles. Typically the result of calling this method would be fed to the childAllocation method.
        参数：
        a - the allocation given to the view
        返回：
        the allocation that represents the inside of the view after the margins have all been removed; if the given allocation was null, the return value is null

      • setParagraphInsets

        protected void setParagraphInsets(AttributeSet attr)
        Sets the insets from the paragraph attributes specified in the given attributes.
        参数：
        attr - the attributes

      • setInsets

        protected void setInsets(short top,
             short left,
             short bottom,
             short right)
        Sets the insets for the view.
        参数：
        top - the top inset >= 0
        left - the left inset >= 0
        bottom - the bottom inset >= 0
        right - the right inset >= 0

      • getLeftInset

        protected short getLeftInset()
        Gets the left inset.
        返回：
        the inset >= 0

      • getRightInset

        protected short getRightInset()
        Gets the right inset.
        返回：
        the inset >= 0

      • getTopInset

        protected short getTopInset()
        Gets the top inset.
        返回：
        the inset >= 0

      • getBottomInset

        protected short getBottomInset()
        Gets the bottom inset.
        返回：
        the inset >= 0

      • getNextNorthSouthVisualPositionFrom

        protected int getNextNorthSouthVisualPositionFrom(int pos,
                                      Position.Bias b,
                                      Shape a,
                                      int direction,
                                      Position.Bias[] biasRet)
                                           throws BadLocationException
        Returns the next visual position for the cursor, in either the north or south direction.
        参数：
        pos - the position to convert >= 0
        b - a bias value of either Position.Bias.Forward or Position.Bias.Backward
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard; this may be one of the following:
        • SwingConstants.NORTH
        • SwingConstants.SOUTH
        biasRet - an array containing the bias that was checked
        返回：
        the location within the model that best represents the next north or south location
        抛出：
        BadLocationException
        IllegalArgumentException - if direction is invalid
        另请参见：
        getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

      • getNextEastWestVisualPositionFrom

        protected int getNextEastWestVisualPositionFrom(int pos,
                                    Position.Bias b,
                                    Shape a,
                                    int direction,
                                    Position.Bias[] biasRet)
                                         throws BadLocationException
        Returns the next visual position for the cursor, in either the east or west direction.
        参数：
        pos - the position to convert >= 0
        b - a bias value of either Position.Bias.Forward or Position.Bias.Backward
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard; this may be one of the following:
        • SwingConstants.WEST
        • SwingConstants.EAST
        biasRet - an array containing the bias that was checked
        返回：
        the location within the model that best represents the next west or east location
        抛出：
        BadLocationException
        IllegalArgumentException - if direction is invalid
        另请参见：
        getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

      • flipEastAndWestAtEnds

        protected boolean flipEastAndWestAtEnds(int position,
                            Position.Bias bias)
        Determines in which direction the next view lays. Consider the View at index n. Typically the Views are layed out from left to right, so that the View to the EAST will be at index n + 1, and the View to the WEST will be at index n - 1. In certain situations, such as with bidirectional text, it is possible that the View to EAST is not at index n + 1, but rather at index n - 1, or that the View to the WEST is not at index n - 1, but index n + 1. In this case this method would return true, indicating the Views are layed out in descending order.

        This unconditionally returns false, subclasses should override this method if there is the possibility for laying Views in descending order.

        参数：
        position - position into the model
        bias - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DateFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DateFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
      • javax.swing.text.DefaultFormatter
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
  • 所有已实现的接口：
    Serializable, Cloneable

    public class DateFormatter
extends InternationalFormatter
    DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    DateFormat

    • 构造方法摘要

      Constructors
      构造方法与描述
      DateFormatter()
      This is shorthand for new DateFormatter(DateFormat.getDateInstance()).
      DateFormatter(DateFormat format)
      Returns a DateFormatter configured with the specified Format instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void setFormat(DateFormat format)
      Sets the format that dictates the legal values that can be edited and displayed.

      • 方法 - 继承于类 javax.swing.text.InternationalFormatter

        clone, getActions, getFields, getFormat, getMaximum, getMinimum, install, setFormat, setMaximum, setMinimum, stringToValue, valueToString

      • 方法 - 继承于类 javax.swing.text.DefaultFormatter

        getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass

      • 方法 - 继承于类 javax.swing.JFormattedTextField.AbstractFormatter

        getFormattedTextField, invalidEdit, setEditValid, uninstall

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DateFormatter

        public DateFormatter()
        This is shorthand for new DateFormatter(DateFormat.getDateInstance()).

      • DateFormatter

        public DateFormatter(DateFormat format)
        Returns a DateFormatter configured with the specified Format instance.
        参数：
        format - Format used to dictate legal values

    • 方法详细信息

      • setFormat

        public void setFormat(DateFormat format)
        Sets the format that dictates the legal values that can be edited and displayed.

        If you have used the nullary constructor the value of this property will be determined for the current locale by way of the Dateformat.getDateInstance() method.

        参数：
        format - DateFormat instance used for converting from/to Strings
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..Btn//g//xss/xx/. t]s>VttPso/nsb,nii/tag


DefaultCaret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultCaret

  • java.lang.Object
    • java.awt.geom.RectangularShape
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle
          • javax.swing.text.DefaultCaret
  • 所有已实现的接口：
    FocusListener, MouseListener, MouseMotionListener, Shape, Serializable, Cloneable, EventListener, Caret
    直接已知子类：
    BasicTextUI.BasicCaret

    public class DefaultCaret
extends Rectangle
implements Caret, FocusListener, MouseListener, MouseMotionListener
    A default implementation of Caret. The caret is rendered as a vertical line in the color specified by the CaretColor property of the associated JTextComponent. It can blink at the rate specified by the BlinkRate property.

    This implementation expects two sources of asynchronous notification. The timer thread fires asynchronously, and causes the caret to simply repaint the most recent bounding box. The caret also tracks change as the document is modified. Typically this will happen on the event dispatch thread as a result of some mouse or keyboard event. The caret behavior on both synchronous and asynchronous documents updates is controlled by UpdatePolicy property. The repaint of the new caret location will occur on the event thread in any case, as calls to modelToView are only safe on the event thread.

    The caret acts as a mouse and focus listener on the text component it has been installed in, and defines the caret semantics based upon those events. The listener methods can be reimplemented to change the semantics. By default, the first mouse button will be used to set focus and caret position. Dragging the mouse pointer with the first mouse button will sweep out a selection that is contiguous in the model. If the associated text component is editable, the caret will become visible when focus is gained, and invisible when focus is lost.

    The Highlighter bound to the associated text component is used to render the selection by default. Selection appearance can be customized by supplying a painter to use for the highlights. By default a painter is used that will render a solid color as specified in the associated text component in the SelectionColor property. This can easily be changed by reimplementing the getSelectionPainter method.

    A customized caret appearance can be achieved by reimplementing the paint method. If the paint method is changed, the damage method should also be reimplemented to cause a repaint for the area needed to render the caret. The caret extends the Rectangle class which is used to hold the bounding box for where the caret was last rendered. This enables the caret to repaint in a thread-safe manner when the caret moves without making a call to modelToView which is unstable between model updates and view repair (i.e. the order of delivery to DocumentListeners is not guaranteed).

    The magic caret position is set to null when the caret position changes. A timer is used to determine the new location (after the caret change). When the timer fires, if the magic caret position is still null it is reset to the current caret position. Any actions that change the caret position and want the magic caret position to remain the same, must remember the magic caret position, change the cursor, and then set the magic caret position to its original value. This has the benefit that only actions that want the magic caret position to persist (such as open/down) need to know about it.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Caret

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.geom.Rectangle2D

        Rectangle2D.Double, Rectangle2D.Float

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ALWAYS_UPDATE
      Indicates that the caret position is to be always updated accordingly to the document changes regardless whether the document updates are performed on the Event Dispatching Thread or not.
      protected ChangeEvent changeEvent
      The change event for the model.
      protected EventListenerList listenerList
      The event listener list.
      static int NEVER_UPDATE
      Indicates that the caret should remain at the same absolute position in the document regardless of any document updates, except when the document length becomes less than the current caret position due to removal.
      static int UPDATE_WHEN_ON_EDT
      Indicates that the caret position is to be updated only when document changes are performed on the Event Dispatching Thread.

      • Fields inherited from class java.awt.Rectangle

        height, width, x, y

      • Fields inherited from class java.awt.geom.Rectangle2D

        OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultCaret()
      Constructs a default caret.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a listener to track whenever the caret position has been changed.
      protected void adjustVisibility(Rectangle nloc)
      Scrolls the associated view (if necessary) to make the caret visible.
      protected void damage(Rectangle r)
      Damages the area surrounding the caret to cause it to be repainted in a new location.
      void deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      boolean equals(Object obj)
      Compares this object to the specified object.
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      void focusGained(FocusEvent e)
      Called when the component containing the caret gains focus.
      void focusLost(FocusEvent e)
      Called when the component containing the caret loses focus.
      int getBlinkRate()
      Gets the caret blink rate.
      ChangeListener[] getChangeListeners()
      Returns an array of all the change listeners registered on this caret.
      protected JTextComponent getComponent()
      Gets the text editor component that this caret is is bound to.
      int getDot()
      Fetches the current position of the caret.
      Position.Bias getDotBias()
      Returns the bias of the caret position.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this caret.
      Point getMagicCaretPosition()
      Gets the saved caret position.
      int getMark()
      Fetches the current position of the mark.
      Position.Bias getMarkBias()
      Returns the bias of the mark.
      protected Highlighter.HighlightPainter getSelectionPainter()
      Gets the painter for the Highlighter.
      int getUpdatePolicy()
      Gets the caret movement policy on document updates.
      void install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      boolean isActive()
      Determines if the caret is currently active.
      boolean isSelectionVisible()
      Checks whether the current selection is visible.
      boolean isVisible()
      Indicates whether or not the caret is currently visible.
      void mouseClicked(MouseEvent e)
      Called when the mouse is clicked.
      void mouseDragged(MouseEvent e)
      Moves the caret position according to the mouse pointer's current location.
      void mouseEntered(MouseEvent e)
      Called when the mouse enters a region.
      void mouseExited(MouseEvent e)
      Called when the mouse exits a region.
      void mouseMoved(MouseEvent e)
      Called when the mouse is moved.
      void mousePressed(MouseEvent e)
      If button 1 is pressed, this is implemented to request focus on the associated text component, and to set the caret position.
      void mouseReleased(MouseEvent e)
      Called when the mouse is released.
      protected void moveCaret(MouseEvent e)
      Tries to move the position of the caret from the coordinates of a mouse event, using viewToModel().
      void moveDot(int dot)
      Moves the caret position to the specified position, with a forward bias.
      void moveDot(int dot, Position.Bias dotBias)
      Moves the caret position to the specified position, with the specified bias.
      void paint(Graphics g)
      Renders the caret as a vertical line.
      protected void positionCaret(MouseEvent e)
      Tries to set the position of the caret from the coordinates of a mouse event, using viewToModel().
      void removeChangeListener(ChangeListener l)
      Removes a listener that was tracking caret position changes.
      protected void repaint()
      Cause the caret to be painted.
      void setBlinkRate(int rate)
      Sets the caret blink rate.
      void setDot(int dot)
      Sets the caret position and mark to the specified position, with a forward bias.
      void setDot(int dot, Position.Bias dotBias)
      Sets the caret position and mark to the specified position, with the specified bias.
      void setMagicCaretPosition(Point p)
      Saves the current caret position.
      void setSelectionVisible(boolean vis)
      Changes the selection visibility.
      void setUpdatePolicy(int policy)
      Sets the caret movement policy on the document updates.
      void setVisible(boolean e)
      Sets the caret visibility, and repaints the caret.
      String toString()
      Returns a String representing this Rectangle and its values.

      • 方法 - 继承于类 java.awt.Rectangle

        add, add, add, contains, contains, contains, contains, createIntersection, createUnion, getBounds, getBounds2D, getHeight, getLocation, getSize, getWidth, getX, getY, grow, inside, intersection, intersects, isEmpty, move, outcode, reshape, resize, setBounds, setBounds, setLocation, setLocation, setRect, setSize, setSize, translate, union

      • 方法 - 继承于类 java.awt.geom.Rectangle2D

        add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union

      • 方法 - 继承于类 java.awt.geom.RectangularShape

        clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 java.awt.Shape

        contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

    • 字段详细信息

      • UPDATE_WHEN_ON_EDT

        public static final int UPDATE_WHEN_ON_EDT
        Indicates that the caret position is to be updated only when document changes are performed on the Event Dispatching Thread.
        从以下版本开始：
        1.5
        另请参见：
        setUpdatePolicy(int), getUpdatePolicy(), Constant Field Values

      • NEVER_UPDATE

        public static final int NEVER_UPDATE
        Indicates that the caret should remain at the same absolute position in the document regardless of any document updates, except when the document length becomes less than the current caret position due to removal. In that case the caret position is adjusted to the end of the document.
        从以下版本开始：
        1.5
        另请参见：
        setUpdatePolicy(int), getUpdatePolicy(), Constant Field Values

      • ALWAYS_UPDATE

        public static final int ALWAYS_UPDATE
        Indicates that the caret position is to be always updated accordingly to the document changes regardless whether the document updates are performed on the Event Dispatching Thread or not.
        从以下版本开始：
        1.5
        另请参见：
        setUpdatePolicy(int), getUpdatePolicy(), Constant Field Values

      • listenerList

        protected EventListenerList listenerList
        The event listener list.

      • changeEvent

        protected transient ChangeEvent changeEvent
        The change event for the model. Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property. The source of events generated here is always "this".

    • 构造方法详细信息

      • DefaultCaret

        public DefaultCaret()
        Constructs a default caret.

    • 方法详细信息

      • setUpdatePolicy

        public void setUpdatePolicy(int policy)
        Sets the caret movement policy on the document updates. Normally the caret updates its absolute position within the document on insertions occurred before or at the caret position and on removals before the caret position. 'Absolute position' means here the position relative to the start of the document. For example if a character is typed within editable text component it is inserted at the caret position and the caret moves to the next absolute position within the document due to insertion and if BACKSPACE is typed then caret decreases its absolute position due to removal of a character before it. Sometimes it may be useful to turn off the caret position updates so that the caret stays at the same absolute position within the document position regardless of any document updates.

        The following update policies are allowed:

        • NEVER_UPDATE: the caret stays at the same absolute position in the document regardless of any document updates, except when document length becomes less than the current caret position due to removal. In that case caret position is adjusted to the end of the document. The caret doesn't try to keep itself visible by scrolling the associated view when using this policy.
        • ALWAYS_UPDATE: the caret always tracks document changes. For regular changes it increases its position if an insertion occurs before or at its current position, and decreases position if a removal occurs before its current position. For undo/redo updates it is always moved to the position where update occurred. The caret also tries to keep itself visible by calling adjustVisibility method.
        • UPDATE_WHEN_ON_EDT: acts like ALWAYS_UPDATE if the document updates are performed on the Event Dispatching Thread and like NEVER_UPDATE if updates are performed on other thread.

        The default property value is UPDATE_WHEN_ON_EDT.

        参数：
        policy - one of the following values : UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE
        抛出：
        IllegalArgumentException - if invalid value is passed
        从以下版本开始：
        1.5
        另请参见：
        getUpdatePolicy(), adjustVisibility(java.awt.Rectangle), UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE

      • getUpdatePolicy

        public int getUpdatePolicy()
        Gets the caret movement policy on document updates.
        返回：
        one of the following values : UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE
        从以下版本开始：
        1.5
        另请参见：
        setUpdatePolicy(int), UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE

      • getComponent

        protected final JTextComponent getComponent()
        Gets the text editor component that this caret is is bound to.
        返回：
        the component

      • repaint

        protected final void repaint()
        Cause the caret to be painted. The repaint area is the bounding box of the caret (i.e. the caret rectangle or this).

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

      • damage

        protected void damage(Rectangle r)
        Damages the area surrounding the caret to cause it to be repainted in a new location. If paint() is reimplemented, this method should also be reimplemented. This method should update the caret bounds (x, y, width, and height).
        参数：
        r - the current location of the caret
        另请参见：
        paint(java.awt.Graphics)

      • adjustVisibility

        protected void adjustVisibility(Rectangle nloc)
        Scrolls the associated view (if necessary) to make the caret visible. Since how this should be done is somewhat of a policy, this method can be reimplemented to change the behavior. By default the scrollRectToVisible method is called on the associated component.
        参数：
        nloc - the new position to scroll to

      • getSelectionPainter

        protected Highlighter.HighlightPainter getSelectionPainter()
        Gets the painter for the Highlighter.
        返回：
        the painter

      • positionCaret

        protected void positionCaret(MouseEvent e)
        Tries to set the position of the caret from the coordinates of a mouse event, using viewToModel().
        参数：
        e - the mouse event

      • moveCaret

        protected void moveCaret(MouseEvent e)
        Tries to move the position of the caret from the coordinates of a mouse event, using viewToModel(). This will cause a selection if the dot and mark are different.
        参数：
        e - the mouse event

      • focusGained

        public void focusGained(FocusEvent e)
        Called when the component containing the caret gains focus. This is implemented to set the caret to visible if the component is editable.
        指定者：
        focusGained in interface FocusListener
        参数：
        e - the focus event
        另请参见：
        FocusListener.focusGained(java.awt.event.FocusEvent)

      • focusLost

        public void focusLost(FocusEvent e)
        Called when the component containing the caret loses focus. This is implemented to set the caret to visibility to false.
        指定者：
        focusLost in interface FocusListener
        参数：
        e - the focus event
        另请参见：
        FocusListener.focusLost(java.awt.event.FocusEvent)

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        Called when the mouse is clicked. If the click was generated from button1, a double click selects a word, and a triple click the current line.
        指定者：
        mouseClicked in interface MouseListener
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mouseClicked(java.awt.event.MouseEvent)

      • mousePressed

        public void mousePressed(MouseEvent e)
        If button 1 is pressed, this is implemented to request focus on the associated text component, and to set the caret position. If the shift key is held down, the caret will be moved, potentially resulting in a selection, otherwise the caret position will be set to the new location. If the component is not enabled, there will be no request for focus.
        指定者：
        mousePressed in interface MouseListener
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mousePressed(java.awt.event.MouseEvent)

      • mouseReleased

        public void mouseReleased(MouseEvent e)
        Called when the mouse is released.
        指定者：
        mouseReleased in interface MouseListener
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mouseReleased(java.awt.event.MouseEvent)

      • mouseEntered

        public void mouseEntered(MouseEvent e)
        Called when the mouse enters a region.
        指定者：
        mouseEntered in interface MouseListener
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mouseEntered(java.awt.event.MouseEvent)

      • mouseExited

        public void mouseExited(MouseEvent e)
        Called when the mouse exits a region.
        指定者：
        mouseExited in interface MouseListener
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mouseExited(java.awt.event.MouseEvent)

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Moves the caret position according to the mouse pointer's current location. This effectively extends the selection. By default, this is only done for mouse button 1.
        指定者：
        mouseDragged in interface MouseMotionListener
        参数：
        e - the mouse event
        另请参见：
        MouseMotionListener.mouseDragged(java.awt.event.MouseEvent)

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Called when the mouse is moved.
        指定者：
        mouseMoved in interface MouseMotionListener
        参数：
        e - the mouse event
        另请参见：
        MouseMotionListener.mouseMoved(java.awt.event.MouseEvent)

      • paint

        public void paint(Graphics g)
        Renders the caret as a vertical line. If this is reimplemented the damage method should also be reimplemented as it assumes the shape of the caret is a vertical line. Sets the caret color to the value returned by getCaretColor().

        If there are multiple text directions present in the associated document, a flag indicating the caret bias will be rendered. This will occur only if the associated document is a subclass of AbstractDocument and there are multiple bidi levels present in the bidi element structure (i.e. the text has multiple directions associated with it).

        指定者：
        paint in interface Caret
        参数：
        g - the graphics context
        另请参见：
        damage(java.awt.Rectangle)

      • install

        public void install(JTextComponent c)
        Called when the UI is being installed into the interface of a JTextComponent. This can be used to gain access to the model that is being navigated by the implementation of this interface. Sets the dot and mark to 0, and establishes document, property change, focus, mouse, and mouse motion listeners.
        指定者：
        install in interface Caret
        参数：
        c - the component
        另请参见：
        Caret.install(javax.swing.text.JTextComponent)

      • deinstall

        public void deinstall(JTextComponent c)
        Called when the UI is being removed from the interface of a JTextComponent. This is used to unregister any listeners that were attached.
        指定者：
        deinstall in interface Caret
        参数：
        c - the component
        另请参见：
        Caret.deinstall(javax.swing.text.JTextComponent)

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a listener to track whenever the caret position has been changed.
        指定者：
        addChangeListener in interface Caret
        参数：
        l - the listener
        另请参见：
        Caret.addChangeListener(javax.swing.event.ChangeListener)

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a listener that was tracking caret position changes.
        指定者：
        removeChangeListener in interface Caret
        参数：
        l - the listener
        另请参见：
        Caret.removeChangeListener(javax.swing.event.ChangeListener)

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the change listeners registered on this caret.
        返回：
        all of this caret's ChangeListeners or an empty array if no change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method. The listener list is processed last to first.
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this caret. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultCaret c for its change listeners with the following code:

        ChangeListener[] cls = (ChangeListener[])(c.getListeners(ChangeListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getChangeListeners()

      • setSelectionVisible

        public void setSelectionVisible(boolean vis)
        Changes the selection visibility.
        指定者：
        setSelectionVisible in interface Caret
        参数：
        vis - the new visibility

      • isSelectionVisible

        public boolean isSelectionVisible()
        Checks whether the current selection is visible.
        指定者：
        isSelectionVisible in interface Caret
        返回：
        true if the selection is visible

      • isActive

        public boolean isActive()
        Determines if the caret is currently active.

        This method returns whether or not the Caret is currently in a blinking state. It does not provide information as to whether it is currently blinked on or off. To determine if the caret is currently painted use the isVisible method.

        返回：
        true if active else false
        从以下版本开始：
        1.5
        另请参见：
        isVisible()

      • isVisible

        public boolean isVisible()
        Indicates whether or not the caret is currently visible. As the caret flashes on and off the return value of this will change between true, when the caret is painted, and false, when the caret is not painted. isActive indicates whether or not the caret is in a blinking state, such that it can be visible, and isVisible indicates whether or not the caret is actually visible.

        Subclasses that wish to render a different flashing caret should override paint and only paint the caret if this method returns true.

        指定者：
        isVisible in interface Caret
        返回：
        true if visible else false
        另请参见：
        Caret.isVisible(), isActive()

      • setVisible

        public void setVisible(boolean e)
        Sets the caret visibility, and repaints the caret. It is important to understand the relationship between this method, isVisible and isActive. Calling this method with a value of true activates the caret blinking. Setting it to false turns it completely off. To determine whether the blinking is active, you should call isActive. In effect, isActive is an appropriate corresponding "getter" method for this one. isVisible can be used to fetch the current visibility status of the caret, meaning whether or not it is currently painted. This status will change as the caret blinks on and off.

        Here's a list showing the potential return values of both isActive and isVisible after calling this method:

        setVisible(true):

        • isActive(): true
        • isVisible(): true or false depending on whether or not the caret is blinked on or off

        setVisible(false):

        • isActive(): false
        • isVisible(): false
        指定者：
        setVisible in interface Caret
        参数：
        e - the visibility specifier
        另请参见：
        isActive(), Caret.setVisible(boolean)

      • setBlinkRate

        public void setBlinkRate(int rate)
        Sets the caret blink rate.
        指定者：
        setBlinkRate in interface Caret
        参数：
        rate - the rate in milliseconds, 0 to stop blinking
        另请参见：
        Caret.setBlinkRate(int)

      • getBlinkRate

        public int getBlinkRate()
        Gets the caret blink rate.
        指定者：
        getBlinkRate in interface Caret
        返回：
        the delay in milliseconds. If this is zero the caret will not blink.
        另请参见：
        Caret.getBlinkRate()

      • getDot

        public int getDot()
        Fetches the current position of the caret.
        指定者：
        getDot in interface Caret
        返回：
        the position >= 0
        另请参见：
        Caret.getDot()

      • getMark

        public int getMark()
        Fetches the current position of the mark. If there is a selection, the dot and mark will not be the same.
        指定者：
        getMark in interface Caret
        返回：
        the position >= 0
        另请参见：
        Caret.getMark()

      • setDot

        public void setDot(int dot)
        Sets the caret position and mark to the specified position, with a forward bias. This implicitly sets the selection range to zero.
        指定者：
        setDot in interface Caret
        参数：
        dot - the position >= 0
        另请参见：
        setDot(int, Position.Bias), Caret.setDot(int)

      • moveDot

        public void moveDot(int dot)
        Moves the caret position to the specified position, with a forward bias.
        指定者：
        moveDot in interface Caret
        参数：
        dot - the position >= 0
        另请参见：
        moveDot(int, javax.swing.text.Position.Bias), Caret.moveDot(int)

      • moveDot

        public void moveDot(int dot,
           Position.Bias dotBias)
        Moves the caret position to the specified position, with the specified bias.
        参数：
        dot - the position >= 0
        dotBias - the bias for this position, not null
        抛出：
        IllegalArgumentException - if the bias is null
        从以下版本开始：
        1.6
        另请参见：
        Caret.moveDot(int)

      • setDot

        public void setDot(int dot,
          Position.Bias dotBias)
        Sets the caret position and mark to the specified position, with the specified bias. This implicitly sets the selection range to zero.
        参数：
        dot - the position >= 0
        dotBias - the bias for this position, not null
        抛出：
        IllegalArgumentException - if the bias is null
        从以下版本开始：
        1.6
        另请参见：
        Caret.setDot(int)

      • getDotBias

        public Position.Bias getDotBias()
        Returns the bias of the caret position.
        返回：
        the bias of the caret position
        从以下版本开始：
        1.6

      • getMarkBias

        public Position.Bias getMarkBias()
        Returns the bias of the mark.
        返回：
        the bias of the mark
        从以下版本开始：
        1.6

      • setMagicCaretPosition

        public void setMagicCaretPosition(Point p)
        Saves the current caret position. This is used when caret up/down actions occur, moving between lines that have uneven end positions.
        指定者：
        setMagicCaretPosition in interface Caret
        参数：
        p - the position
        另请参见：
        getMagicCaretPosition()

      • getMagicCaretPosition

        public Point getMagicCaretPosition()
        Gets the saved caret position.
        指定者：
        getMagicCaretPosition in interface Caret
        返回：
        the position see #setMagicCaretPosition
        另请参见：
        Caret.setMagicCaretPosition(java.awt.Point)

      • equals

        public boolean equals(Object obj)
        Compares this object to the specified object. The superclass behavior of comparing rectangles is not desired, so this is changed to the Object behavior.
        重载：
        equals in class Rectangle
        参数：
        obj - the object to compare this font with
        返回：
        true if the objects are equal; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Description copied from class: Rectangle
        Returns a String representing this Rectangle and its values.
        重载：
        toString in class Rectangle
        返回：
        a String representing this Rectangle object's coordinate and size values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
      • javax.swing.text.DefaultEditorKit
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    StyledEditorKit

    public class DefaultEditorKit
extends EditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document. This implementation provides a default implementation which treats text as plain text and provides a minimal set of actions for a simple editor.

    Newlines
    There are two properties which deal with newlines. The system property, line.separator, is defined to be platform-dependent, either "\n", "\r", or "\r\n". There is also a property defined in DefaultEditorKit, called EndOfLineStringProperty, which is defined automatically when a document is loaded, to be the first occurrence of any of the newline characters. When a document is loaded, EndOfLineStringProperty is set appropriately, and when the document is written back out, the EndOfLineStringProperty is used. But while the document is in memory, the "\n" character is used to define a newline, regardless of how the newline is defined when the document is on disk. Therefore, for searching purposes, "\n" should always be used. When a new document is created, and the EndOfLineStringProperty has not been defined, it will use the System property when writing out the document.

    Note that EndOfLineStringProperty is set on the Document using the get/putProperty methods. Subclasses may override this behavior.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DefaultEditorKit.BeepAction
      Creates a beep.
      static class  DefaultEditorKit.CopyAction
      Copies the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.CutAction
      Cuts the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.DefaultKeyTypedAction
      The action that is executed by default if a key typed event is received and there is no keymap entry.
      static class  DefaultEditorKit.InsertBreakAction
      Places a line/paragraph break into the document.
      static class  DefaultEditorKit.InsertContentAction
      Places content into the associated document.
      static class  DefaultEditorKit.InsertTabAction
      Places a tab character into the document.
      static class  DefaultEditorKit.PasteAction
      Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String backwardAction
      Name of the Action for moving the caret logically backward one position.
      static String beepAction
      Name of the action to create a beep.
      static String beginAction
      Name of the Action for moving the caret to the beginning of the document.
      static String beginLineAction
      Name of the Action for moving the caret to the beginning of a line.
      static String beginParagraphAction
      Name of the Action for moving the caret to the beginning of a paragraph.
      static String beginWordAction
      Name of the Action for moving the caret to the beginning of a word.
      static String copyAction
      Name of the action to copy the selected region and place the contents into the system clipboard.
      static String cutAction
      Name of the action to cut the selected region and place the contents into the system clipboard.
      static String defaultKeyTypedAction
      Name of the action that is executed by default if a key typed event is received and there is no keymap entry.
      static String deleteNextCharAction
      Name of the action to delete the character of content that follows the current caret position.
      static String deleteNextWordAction
      Name of the action to delete the word that follows the beginning of the selection.
      static String deletePrevCharAction
      Name of the action to delete the character of content that precedes the current caret position.
      static String deletePrevWordAction
      Name of the action to delete the word that precedes the beginning of the selection.
      static String downAction
      Name of the Action for moving the caret logically downward one position.
      static String endAction
      Name of the Action for moving the caret to the end of the document.
      static String endLineAction
      Name of the Action for moving the caret to the end of a line.
      static String EndOfLineStringProperty
      When reading a document if a CRLF is encountered a property with this name is added and the value will be "\r\n".
      static String endParagraphAction
      Name of the Action for moving the caret to the end of a paragraph.
      static String endWordAction
      Name of the Action for moving the caret to the end of a word.
      static String forwardAction
      Name of the Action for moving the caret logically forward one position.
      static String insertBreakAction
      Name of the action to place a line/paragraph break into the document.
      static String insertContentAction
      Name of the action to place content into the associated document.
      static String insertTabAction
      Name of the action to place a tab character into the document.
      static String nextWordAction
      Name of the Action for moving the caret to the beginning of the next word.
      static String pageDownAction
      Name of the action to page down vertically.
      static String pageUpAction
      Name of the action to page up vertically.
      static String pasteAction
      Name of the action to paste the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
      static String previousWordAction
      Name of the Action for moving the caret to the beginning of the previous word.
      static String readOnlyAction
      Name of the action to set the editor into read-only mode.
      static String selectAllAction
      Name of the Action for selecting the entire document
      static String selectionBackwardAction
      Name of the Action for extending the selection by moving the caret logically backward one position.
      static String selectionBeginAction
      Name of the Action for moving the caret to the beginning of the document.
      static String selectionBeginLineAction
      Name of the Action for moving the caret to the beginning of a line, extending the selection.
      static String selectionBeginParagraphAction
      Name of the Action for moving the caret to the beginning of a paragraph, extending the selection.
      static String selectionBeginWordAction
      Name of the Action for moving the caret to the beginning of a word, extending the selection.
      static String selectionDownAction
      Name of the Action for moving the caret logically downward one position, extending the selection.
      static String selectionEndAction
      Name of the Action for moving the caret to the end of the document.
      static String selectionEndLineAction
      Name of the Action for moving the caret to the end of a line, extending the selection.
      static String selectionEndParagraphAction
      Name of the Action for moving the caret to the end of a paragraph, extending the selection.
      static String selectionEndWordAction
      Name of the Action for moving the caret to the end of a word, extending the selection.
      static String selectionForwardAction
      Name of the Action for extending the selection by moving the caret logically forward one position.
      static String selectionNextWordAction
      Name of the Action for moving the selection to the beginning of the next word, extending the selection.
      static String selectionPreviousWordAction
      Name of the Action for moving the selection to the beginning of the previous word, extending the selection.
      static String selectionUpAction
      Name of the Action for moving the caret logically upward one position, extending the selection.
      static String selectLineAction
      Name of the Action for selecting a line around the caret.
      static String selectParagraphAction
      Name of the Action for selecting a paragraph around the caret.
      static String selectWordAction
      Name of the Action for selecting a word around the caret.
      static String upAction
      Name of the Action for moving the caret logically upward one position.
      static String writableAction
      Name of the action to set the editor into writeable mode.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit()
      default constructor for DefaultEditorKit

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Caret createCaret()
      Fetches a caret that can navigate through views produced by the associated ViewFactory.
      Document createDefaultDocument()
      Creates an uninitialized text storage model (PlainDocument) that is appropriate for this type of editor.
      Action[] getActions()
      Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
      String getContentType()
      Gets the MIME type of the data that this kit represents support for.
      ViewFactory getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      void read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void read(Reader in, Document doc, int pos)
      Inserts content from the given stream, which will be treated as plain text.
      void write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      void write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream as plain text.

      • 方法 - 继承于类 javax.swing.text.EditorKit

        clone, deinstall, install

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • EndOfLineStringProperty

        public static final String EndOfLineStringProperty
        When reading a document if a CRLF is encountered a property with this name is added and the value will be "\r\n".
        另请参见：
        Constant Field Values

      • insertContentAction

        public static final String insertContentAction
        Name of the action to place content into the associated document. If there is a selection, it is removed before the new content is added.
        另请参见：
        getActions(), Constant Field Values

      • insertBreakAction

        public static final String insertBreakAction
        Name of the action to place a line/paragraph break into the document. If there is a selection, it is removed before the break is added.
        另请参见：
        getActions(), Constant Field Values

      • insertTabAction

        public static final String insertTabAction
        Name of the action to place a tab character into the document. If there is a selection, it is removed before the tab is added.
        另请参见：
        getActions(), Constant Field Values

      • deletePrevCharAction

        public static final String deletePrevCharAction
        Name of the action to delete the character of content that precedes the current caret position.
        另请参见：
        getActions(), Constant Field Values

      • deleteNextCharAction

        public static final String deleteNextCharAction
        Name of the action to delete the character of content that follows the current caret position.
        另请参见：
        getActions(), Constant Field Values

      • deleteNextWordAction

        public static final String deleteNextWordAction
        Name of the action to delete the word that follows the beginning of the selection.
        从以下版本开始：
        1.6
        另请参见：
        getActions(), JTextComponent.getSelectionStart(), Constant Field Values

      • deletePrevWordAction

        public static final String deletePrevWordAction
        Name of the action to delete the word that precedes the beginning of the selection.
        从以下版本开始：
        1.6
        另请参见：
        getActions(), JTextComponent.getSelectionStart(), Constant Field Values

      • readOnlyAction

        public static final String readOnlyAction
        Name of the action to set the editor into read-only mode.
        另请参见：
        getActions(), Constant Field Values

      • writableAction

        public static final String writableAction
        Name of the action to set the editor into writeable mode.
        另请参见：
        getActions(), Constant Field Values

      • cutAction

        public static final String cutAction
        Name of the action to cut the selected region and place the contents into the system clipboard.
        另请参见：
        JTextComponent.cut(), getActions(), Constant Field Values

      • copyAction

        public static final String copyAction
        Name of the action to copy the selected region and place the contents into the system clipboard.
        另请参见：
        JTextComponent.copy(), getActions(), Constant Field Values

      • pasteAction

        public static final String pasteAction
        Name of the action to paste the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
        另请参见：
        JTextComponent.paste(), getActions(), Constant Field Values

      • beepAction

        public static final String beepAction
        Name of the action to create a beep.
        另请参见：
        getActions(), Constant Field Values

      • pageUpAction

        public static final String pageUpAction
        Name of the action to page up vertically.
        另请参见：
        getActions(), Constant Field Values

      • pageDownAction

        public static final String pageDownAction
        Name of the action to page down vertically.
        另请参见：
        getActions(), Constant Field Values

      • forwardAction

        public static final String forwardAction
        Name of the Action for moving the caret logically forward one position.
        另请参见：
        getActions(), Constant Field Values

      • backwardAction

        public static final String backwardAction
        Name of the Action for moving the caret logically backward one position.
        另请参见：
        getActions(), Constant Field Values

      • selectionForwardAction

        public static final String selectionForwardAction
        Name of the Action for extending the selection by moving the caret logically forward one position.
        另请参见：
        getActions(), Constant Field Values

      • selectionBackwardAction

        public static final String selectionBackwardAction
        Name of the Action for extending the selection by moving the caret logically backward one position.
        另请参见：
        getActions(), Constant Field Values

      • upAction

        public static final String upAction
        Name of the Action for moving the caret logically upward one position.
        另请参见：
        getActions(), Constant Field Values

      • downAction

        public static final String downAction
        Name of the Action for moving the caret logically downward one position.
        另请参见：
        getActions(), Constant Field Values

      • selectionUpAction

        public static final String selectionUpAction
        Name of the Action for moving the caret logically upward one position, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • selectionDownAction

        public static final String selectionDownAction
        Name of the Action for moving the caret logically downward one position, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • beginWordAction

        public static final String beginWordAction
        Name of the Action for moving the caret to the beginning of a word.
        另请参见：
        getActions(), Constant Field Values

      • endWordAction

        public static final String endWordAction
        Name of the Action for moving the caret to the end of a word.
        另请参见：
        getActions(), Constant Field Values

      • selectionBeginWordAction

        public static final String selectionBeginWordAction
        Name of the Action for moving the caret to the beginning of a word, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • selectionEndWordAction

        public static final String selectionEndWordAction
        Name of the Action for moving the caret to the end of a word, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • previousWordAction

        public static final String previousWordAction
        Name of the Action for moving the caret to the beginning of the previous word.
        另请参见：
        getActions(), Constant Field Values

      • nextWordAction

        public static final String nextWordAction
        Name of the Action for moving the caret to the beginning of the next word.
        另请参见：
        getActions(), Constant Field Values

      • selectionPreviousWordAction

        public static final String selectionPreviousWordAction
        Name of the Action for moving the selection to the beginning of the previous word, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • selectionNextWordAction

        public static final String selectionNextWordAction
        Name of the Action for moving the selection to the beginning of the next word, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • beginLineAction

        public static final String beginLineAction
        Name of the Action for moving the caret to the beginning of a line.
        另请参见：
        getActions(), Constant Field Values

      • endLineAction

        public static final String endLineAction
        Name of the Action for moving the caret to the end of a line.
        另请参见：
        getActions(), Constant Field Values

      • selectionBeginLineAction

        public static final String selectionBeginLineAction
        Name of the Action for moving the caret to the beginning of a line, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • selectionEndLineAction

        public static final String selectionEndLineAction
        Name of the Action for moving the caret to the end of a line, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • beginParagraphAction

        public static final String beginParagraphAction
        Name of the Action for moving the caret to the beginning of a paragraph.
        另请参见：
        getActions(), Constant Field Values

      • endParagraphAction

        public static final String endParagraphAction
        Name of the Action for moving the caret to the end of a paragraph.
        另请参见：
        getActions(), Constant Field Values

      • selectionBeginParagraphAction

        public static final String selectionBeginParagraphAction
        Name of the Action for moving the caret to the beginning of a paragraph, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • selectionEndParagraphAction

        public static final String selectionEndParagraphAction
        Name of the Action for moving the caret to the end of a paragraph, extending the selection.
        另请参见：
        getActions(), Constant Field Values

      • beginAction

        public static final String beginAction
        Name of the Action for moving the caret to the beginning of the document.
        另请参见：
        getActions(), Constant Field Values

      • endAction

        public static final String endAction
        Name of the Action for moving the caret to the end of the document.
        另请参见：
        getActions(), Constant Field Values

      • selectionBeginAction

        public static final String selectionBeginAction
        Name of the Action for moving the caret to the beginning of the document.
        另请参见：
        getActions(), Constant Field Values

      • selectionEndAction

        public static final String selectionEndAction
        Name of the Action for moving the caret to the end of the document.
        另请参见：
        getActions(), Constant Field Values

      • selectWordAction

        public static final String selectWordAction
        Name of the Action for selecting a word around the caret.
        另请参见：
        getActions(), Constant Field Values

      • selectLineAction

        public static final String selectLineAction
        Name of the Action for selecting a line around the caret.
        另请参见：
        getActions(), Constant Field Values

      • selectParagraphAction

        public static final String selectParagraphAction
        Name of the Action for selecting a paragraph around the caret.
        另请参见：
        getActions(), Constant Field Values

      • selectAllAction

        public static final String selectAllAction
        Name of the Action for selecting the entire document
        另请参见：
        getActions(), Constant Field Values

      • defaultKeyTypedAction

        public static final String defaultKeyTypedAction
        Name of the action that is executed by default if a key typed event is received and there is no keymap entry.
        另请参见：
        getActions(), Constant Field Values

    • 构造方法详细信息

      • DefaultEditorKit

        public DefaultEditorKit()
        default constructor for DefaultEditorKit

    • 方法详细信息

      • getContentType

        public String getContentType()
        Gets the MIME type of the data that this kit represents support for. The default is text/plain.
        指定者：
        getContentType in class EditorKit
        返回：
        the type

      • getViewFactory

        public ViewFactory getViewFactory()
        Fetches a factory that is suitable for producing views of any models that are produced by this kit. The default is to have the UI produce the factory, so this method has no implementation.
        指定者：
        getViewFactory in class EditorKit
        返回：
        the view factory

      • getActions

        public Action[] getActions()
        Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
        指定者：
        getActions in class EditorKit
        返回：
        the command list

      • createCaret

        public Caret createCaret()
        Fetches a caret that can navigate through views produced by the associated ViewFactory.
        指定者：
        createCaret in class EditorKit
        返回：
        the caret

      • createDefaultDocument

        public Document createDefaultDocument()
        Creates an uninitialized text storage model (PlainDocument) that is appropriate for this type of editor.
        指定者：
        createDefaultDocument in class EditorKit
        返回：
        the model

      • read

        public void read(InputStream in,
        Document doc,
        int pos)
          throws IOException,
                 BadLocationException
        Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
        指定者：
        read in class EditorKit
        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(OutputStream out,
         Document doc,
         int pos,
         int len)
           throws IOException,
                  BadLocationException
        Writes content from a document to the given stream in a format appropriate for this kind of content handler.
        指定者：
        write in class EditorKit
        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content >= 0.
        len - The amount to write out >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • read

        public void read(Reader in,
        Document doc,
        int pos)
          throws IOException,
                 BadLocationException
        Inserts content from the given stream, which will be treated as plain text.
        指定者：
        read in class EditorKit
        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(Writer out,
         Document doc,
         int pos,
         int len)
           throws IOException,
                  BadLocationException
        Writes content from a document to the given stream as plain text.
        指定者：
        write in class EditorKit
        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content from >= 0.
        len - The amount to write out >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos is not within 0 and the length of the document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultEditorKit.BeepAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.BeepAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.BeepAction
extends TextAction
    Creates a beep.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.beepAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.BeepAction()
      Create this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.BeepAction

        public DefaultEditorKit.BeepAction()
        Create this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o=nap<&;<&>nn&>>blss lbc,niiscr, ati mmmrcpl


DefaultEditorKit.CopyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.CopyAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.CopyAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.CopyAction
extends TextAction
    Copies the selected region and place its contents into the system clipboard.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.copyAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.CopyAction()
      Create this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.CopyAction

        public DefaultEditorKit.CopyAction()
        Create this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/gon s < dtvep票� rtcnvta..tfrbrueL/.>o"�


DefaultEditorKit.CutAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.CutAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.CutAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.CutAction
extends TextAction
    Cuts the selected region and place its contents into the system clipboard.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.cutAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.CutAction()
      Create this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.CutAction

        public DefaultEditorKit.CutAction()
        Create this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/g5nns� @t�}�9 Te蔱ai.g�C*>� �


DefaultEditorKit.DefaultKeyTypedAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.DefaultKeyTypedAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.DefaultKeyTypedAction
extends TextAction
    The action that is executed by default if a key typed event is received and there is no keymap entry. There is a variation across different VM's in what gets sent as a key typed event, and this action tries to filter out the undesired events. This filters the control characters and those with the ALT modifier. It allows Control-Alt sequences through as these form legitimate unicode characters on some PC keyboards.

    If the event doesn't get filtered, it will try to insert content into the text editor. The content is fetched from the command string of the ActionEvent. The text entry is done through the replaceSelection method on the target text component. This is the action that will be fired for most text entry tasks.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.defaultKeyTypedAction,
DefaultEditorKit.getActions(),
Keymap.setDefaultAction(javax.swing.Action),
Keymap.getDefaultAction()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.DefaultKeyTypedAction()
      Creates this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.DefaultKeyTypedAction

        public DefaultEditorKit.DefaultKeyTypedAction()
        Creates this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

triur>>i>lbo<>b4otiig/ lbRahptN/ef.>


DefaultEditorKit.InsertBreakAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.InsertBreakAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.InsertBreakAction
extends TextAction
    Places a line/paragraph break into the document. If there is a selection, it is removed before the break is added.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.insertBreakAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.InsertBreakAction()
      Creates this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.InsertBreakAction

        public DefaultEditorKit.InsertBreakAction()
        Creates this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>=>Cl"ol"=aa"==ctiiet hlehhatc n ted eefgs


DefaultEditorKit.InsertContentAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.InsertContentAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.InsertContentAction
extends TextAction
    Places content into the associated document. If there is a selection, it is removed before the new content is added.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.insertContentAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.InsertContentAction()
      Creates this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.InsertContentAction

        public DefaultEditorKit.InsertContentAction()
        Creates this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdls.ll/lat ta < >"rcsirru >m">/靉�>栽m3nn.


DefaultEditorKit.InsertTabAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.InsertTabAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.InsertTabAction
extends TextAction
    Places a tab character into the document. If there is a selection, it is removed before the tab is added.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.insertTabAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.InsertTabAction()
      Creates this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.InsertTabAction

        public DefaultEditorKit.InsertTabAction()
        Creates this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

al吮帽帘帘裕Ａ粲�<� ㄈ�/簟<<s�>>ol>�>


DefaultEditorKit.PasteAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultEditorKit.PasteAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.PasteAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    DefaultEditorKit

    public static class DefaultEditorKit.PasteAction
extends TextAction
    Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    DefaultEditorKit.pasteAction, DefaultEditorKit.getActions()

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultEditorKit.PasteAction()
      Create this object with the appropriate identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      The operation to perform when this action is triggered.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultEditorKit.PasteAction

        public DefaultEditorKit.PasteAction()
        Create this object with the appropriate identifier.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        The operation to perform when this action is triggered.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>崞l芶扑瓢撩嘶保俞>保列霍佑Ｐfro>//>orsp


DefaultFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
      • javax.swing.text.DefaultFormatter
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    InternationalFormatter, MaskFormatter

    public class DefaultFormatter
extends JFormattedTextField.AbstractFormatter
implements Cloneable, Serializable
    DefaultFormatter formats aribtrary objects. Formatting is done by invoking the toString method. In order to convert the value back to a String, your class must provide a constructor that takes a String argument. If no single argument constructor that takes a String is found, the returned value will be the String passed into stringToValue.

    Instances of DefaultFormatter can not be used in multiple instances of JFormattedTextField. To obtain a copy of an already configured DefaultFormatter, use the clone method.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    JFormattedTextField.AbstractFormatter

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultFormatter()
      Creates a DefaultFormatter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a copy of the DefaultFormatter.
      boolean getAllowsInvalid()
      Returns whether or not the value being edited is allowed to be invalid for a length of time.
      boolean getCommitsOnValidEdit()
      Returns when edits are published back to the JFormattedTextField.
      protected DocumentFilter getDocumentFilter()
      Returns the DocumentFilter used to restrict the characters that can be input into the JFormattedTextField.
      protected NavigationFilter getNavigationFilter()
      Returns the NavigationFilter used to restrict where the cursor can be placed.
      boolean getOverwriteMode()
      Returns the behavior when inserting characters.
      类<?> getValueClass()
      Returns that class that is used to create new Objects.
      void install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
      void setAllowsInvalid(boolean allowsInvalid)
      Sets whether or not the value being edited is allowed to be invalid for a length of time (that is, stringToValue throws a ParseException).
      void setCommitsOnValidEdit(boolean commit)
      Sets when edits are published back to the JFormattedTextField.
      void setOverwriteMode(boolean overwriteMode)
      Configures the behavior when inserting characters.
      void setValueClass(类<?> valueClass)
      Sets that class that is used to create new Objects.
      Object stringToValue(String string)
      Converts the passed in String into an instance of getValueClass by way of the constructor that takes a String argument.
      String valueToString(Object value)
      Converts the passed in Object into a String by way of the toString method.

      • 方法 - 继承于类 javax.swing.JFormattedTextField.AbstractFormatter

        getActions, getFormattedTextField, invalidEdit, setEditValid, uninstall

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultFormatter

        public DefaultFormatter()
        Creates a DefaultFormatter.

    • 方法详细信息

      • install

        public void install(JFormattedTextField ftf)
        Installs the DefaultFormatter onto a particular JFormattedTextField. This will invoke valueToString to convert the current value from the JFormattedTextField to a String. This will then install the Actions from getActions, the DocumentFilter returned from getDocumentFilter and the NavigationFilter returned from getNavigationFilter onto the JFormattedTextField.

        Subclasses will typically only need to override this if they wish to install additional listeners on the JFormattedTextField.

        If there is a ParseException in converting the current value to a String, this will set the text to an empty String, and mark the JFormattedTextField as being in an invalid state.

        While this is a public method, this is typically only useful for subclassers of JFormattedTextField. JFormattedTextField will invoke this method at the appropriate times when the value changes, or its internal state changes.

        重载：
        install in class JFormattedTextField.AbstractFormatter
        参数：
        ftf - JFormattedTextField to format for, may be null indicating uninstall from current JFormattedTextField.

      • setCommitsOnValidEdit

        public void setCommitsOnValidEdit(boolean commit)
        Sets when edits are published back to the JFormattedTextField. If true, commitEdit is invoked after every valid edit (any time the text is edited). On the other hand, if this is false than the DefaultFormatter does not publish edits back to the JFormattedTextField. As such, the only time the value of the JFormattedTextField will change is when commitEdit is invoked on JFormattedTextField, typically when enter is pressed or focus leaves the JFormattedTextField.
        参数：
        commit - Used to indicate when edits are commited back to the JTextComponent

      • getCommitsOnValidEdit

        public boolean getCommitsOnValidEdit()
        Returns when edits are published back to the JFormattedTextField.
        返回：
        true if edits are commited after evey valid edit

      • setOverwriteMode

        public void setOverwriteMode(boolean overwriteMode)
        Configures the behavior when inserting characters. If overwriteMode is true (the default), new characters overwrite existing characters in the model.
        参数：
        overwriteMode - Indicates if overwrite or overstrike mode is used

      • getOverwriteMode

        public boolean getOverwriteMode()
        Returns the behavior when inserting characters.
        返回：
        true if newly inserted characters overwrite existing characters

      • setAllowsInvalid

        public void setAllowsInvalid(boolean allowsInvalid)
        Sets whether or not the value being edited is allowed to be invalid for a length of time (that is, stringToValue throws a ParseException). It is often convenient to allow the user to temporarily input an invalid value.
        参数：
        allowsInvalid - Used to indicate if the edited value must always be valid

      • getAllowsInvalid

        public boolean getAllowsInvalid()
        Returns whether or not the value being edited is allowed to be invalid for a length of time.
        返回：
        false if the edited value must always be valid

      • setValueClass

        public void setValueClass(类<?> valueClass)
        Sets that class that is used to create new Objects. If the passed in class does not have a single argument constructor that takes a String, String values will be used.
        参数：
        valueClass - Class used to construct return value from stringToValue

      • getValueClass

        public 类<?> getValueClass()
        Returns that class that is used to create new Objects.
        返回：
        Class used to constuct return value from stringToValue

      • stringToValue

        public Object stringToValue(String string)
                     throws ParseException
        Converts the passed in String into an instance of getValueClass by way of the constructor that takes a String argument. If getValueClass returns null, the Class of the current value in the JFormattedTextField will be used. If this is null, a String will be returned. If the constructor thows an exception, a ParseException will be thrown. If there is no single argument String constructor, string will be returned.
        指定者：
        stringToValue in class JFormattedTextField.AbstractFormatter
        参数：
        string - String to convert
        返回：
        Object representation of text
        抛出：
        ParseException - if there is an error in the conversion

      • valueToString

        public String valueToString(Object value)
                     throws ParseException
        Converts the passed in Object into a String by way of the toString method.
        指定者：
        valueToString in class JFormattedTextField.AbstractFormatter
        参数：
        value - Value to convert
        返回：
        String representation of value
        抛出：
        ParseException - if there is an error in the conversion

      • getDocumentFilter

        protected DocumentFilter getDocumentFilter()
        Returns the DocumentFilter used to restrict the characters that can be input into the JFormattedTextField.
        重载：
        getDocumentFilter in class JFormattedTextField.AbstractFormatter
        返回：
        DocumentFilter to restrict edits

      • getNavigationFilter

        protected NavigationFilter getNavigationFilter()
        Returns the NavigationFilter used to restrict where the cursor can be placed.
        重载：
        getNavigationFilter in class JFormattedTextField.AbstractFormatter
        返回：
        NavigationFilter to restrict navigation

      • clone

        public Object clone()
             throws CloneNotSupportedException
        Creates a copy of the DefaultFormatter.
        重载：
        clone in class JFormattedTextField.AbstractFormatter
        返回：
        copy of the DefaultFormatter
        抛出：
        CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ah


DefaultFormatterFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultFormatterFactory

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory
  • 所有已实现的接口：
    Serializable

    public class DefaultFormatterFactory
extends JFormattedTextField.AbstractFormatterFactory
implements Serializable
    An implementation of JFormattedTextField.AbstractFormatterFactory. DefaultFormatterFactory allows specifying a number of different JFormattedTextField.AbstractFormatters that are to be used. The most important one is the default one (setDefaultFormatter). The default formatter will be used if a more specific formatter could not be found. The following process is used to determine the appropriate formatter to use.
    1. Is the passed in value null? Use the null formatter.
    2. Does the JFormattedTextField have focus? Use the edit formatter.
    3. Otherwise, use the display formatter.
    4. If a non-null AbstractFormatter has not been found, use the default formatter.

    The following code shows how to configure a JFormattedTextField with two JFormattedTextField.AbstractFormatters, one for display and one for editing.

     JFormattedTextField.AbstractFormatter editFormatter = ...;
 JFormattedTextField.AbstractFormatter displayFormatter = ...;
 DefaultFormatterFactory factory = new DefaultFormatterFactory(
                 displayFormatter, displayFormatter, editFormatter);
 JFormattedTextField tf = new JFormattedTextField(factory);

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    JFormattedTextField

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultFormatterFactory()
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatter.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
      DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat, JFormattedTextField.AbstractFormatter nullFormat)
      Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      JFormattedTextField.AbstractFormatter getDefaultFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
      JFormattedTextField.AbstractFormatter getDisplayFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      JFormattedTextField.AbstractFormatter getEditFormatter()
      Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField source)
      Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.
      JFormattedTextField.AbstractFormatter getNullFormatter()
      Returns the formatter to use if the value is null.
      void setDefaultFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
      void setDisplayFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      void setEditFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
      void setNullFormatter(JFormattedTextField.AbstractFormatter atf)
      Sets the formatter to use if the value of the JFormattedTextField is null.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultFormatterFactory

        public DefaultFormatterFactory()

      • DefaultFormatterFactory

        public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
        Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatter.
        参数：
        defaultFormat - JFormattedTextField.AbstractFormatter to be used if a more specific JFormattedTextField.AbstractFormatter can not be found.

      • DefaultFormatterFactory

        public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                       JFormattedTextField.AbstractFormatter displayFormat)
        Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
        参数：
        defaultFormat - JFormattedTextField.AbstractFormatter to be used if a more specific JFormattedTextField.AbstractFormatter can not be found.
        displayFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField does not have focus.

      • DefaultFormatterFactory

        public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                       JFormattedTextField.AbstractFormatter displayFormat,
                       JFormattedTextField.AbstractFormatter editFormat)
        Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
        参数：
        defaultFormat - JFormattedTextField.AbstractFormatter to be used if a more specific JFormattedTextField.AbstractFormatter can not be found.
        displayFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField does not have focus.
        editFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField has focus.

      • DefaultFormatterFactory

        public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                       JFormattedTextField.AbstractFormatter displayFormat,
                       JFormattedTextField.AbstractFormatter editFormat,
                       JFormattedTextField.AbstractFormatter nullFormat)
        Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
        参数：
        defaultFormat - JFormattedTextField.AbstractFormatter to be used if a more specific JFormattedTextField.AbstractFormatter can not be found.
        displayFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField does not have focus.
        editFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField has focus.
        nullFormat - JFormattedTextField.AbstractFormatter to be used when the JFormattedTextField has a null value.

    • 方法详细信息

      • setDefaultFormatter

        public void setDefaultFormatter(JFormattedTextField.AbstractFormatter atf)
        Sets the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
        参数：
        atf - JFormattedTextField.AbstractFormatter used if a more specific is not specified

      • getDefaultFormatter

        public JFormattedTextField.AbstractFormatter getDefaultFormatter()
        Returns the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.
        返回：
        JFormattedTextField.AbstractFormatter used if a more specific one is not specified.

      • setDisplayFormatter

        public void setDisplayFormatter(JFormattedTextField.AbstractFormatter atf)
        Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
        参数：
        atf - JFormattedTextField.AbstractFormatter to use when the JFormattedTextField does not have focus

      • getDisplayFormatter

        public JFormattedTextField.AbstractFormatter getDisplayFormatter()
        Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
        返回：
        JFormattedTextField.AbstractFormatter to use when the JFormattedTextField does not have focus

      • setEditFormatter

        public void setEditFormatter(JFormattedTextField.AbstractFormatter atf)
        Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
        参数：
        atf - JFormattedTextField.AbstractFormatter to use when the component has focus

      • getEditFormatter

        public JFormattedTextField.AbstractFormatter getEditFormatter()
        Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.
        返回：
        JFormattedTextField.AbstractFormatter to use when the component has focus

      • setNullFormatter

        public void setNullFormatter(JFormattedTextField.AbstractFormatter atf)
        Sets the formatter to use if the value of the JFormattedTextField is null.
        参数：
        atf - JFormattedTextField.AbstractFormatter to use when the value of the JFormattedTextField is null.

      • getNullFormatter

        public JFormattedTextField.AbstractFormatter getNullFormatter()
        Returns the formatter to use if the value is null.
        返回：
        JFormattedTextField.AbstractFormatter to use when the value is null

      • getFormatter

        public JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField source)
        Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.
        指定者：
        getFormatter in class JFormattedTextField.AbstractFormatterFactory
        参数：
        source - JFormattedTextField requesting JFormattedTextField.AbstractFormatter
        返回：
        JFormattedTextField.AbstractFormatter to handle formatting duties.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-a


DefaultHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultHighlighter

  • java.lang.Object
    • javax.swing.text.LayeredHighlighter
      • javax.swing.text.DefaultHighlighter
  • 所有已实现的接口：
    Highlighter
    直接已知子类：
    BasicTextUI.BasicHighlighter

    public class DefaultHighlighter
extends LayeredHighlighter
    Implements the Highlighter interfaces. Implements a simple highlight painter that renders in a solid color.
    另请参见：
    Highlighter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DefaultHighlighter.DefaultHighlightPainter
      Simple highlight painter that fills a highlighted area with a solid color.

      • Nested classes/interfaces inherited from class javax.swing.text.LayeredHighlighter

        LayeredHighlighter.LayerPainter

      • Nested classes/interfaces inherited from interface javax.swing.text.Highlighter

        Highlighter.Highlight, Highlighter.HighlightPainter

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static LayeredHighlighter.LayerPainter DefaultPainter
      Default implementation of LayeredHighlighter.LayerPainter that can be used for painting highlights.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultHighlighter()
      Creates a new DefaultHighlighther object.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Object addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
      void changeHighlight(Object tag, int p0, int p1)
      Changes a highlight.
      void deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      boolean | getDrawsLayeredHighlights()
      Highlighter.Highlight[] getHighlights()
      Makes a copy of the highlights.
      void install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void paint(Graphics g)
      Renders the highlights.
      void paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.
      void removeAllHighlights()
      Removes all highlights.
      void removeHighlight(Object tag)
      Removes a highlight from the view.
      void setDrawsLayeredHighlights(boolean newValue)
      If true, highlights are drawn as the Views draw the text.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DefaultPainter

        public static final LayeredHighlighter.LayerPainter DefaultPainter
        Default implementation of LayeredHighlighter.LayerPainter that can be used for painting highlights.

        As of 1.4 this field is final.

    • 构造方法详细信息

      • DefaultHighlighter

        public DefaultHighlighter()
        Creates a new DefaultHighlighther object.

    • 方法详细信息

      • paint

        public void paint(Graphics g)
        Renders the highlights.
        参数：
        g - the graphics context

      • install

        public void install(JTextComponent c)
        Called when the UI is being installed into the interface of a JTextComponent. Installs the editor, and removes any existing highlights.
        参数：
        c - the editor component
        另请参见：
        Highlighter.install(javax.swing.text.JTextComponent)

      • deinstall

        public void deinstall(JTextComponent c)
        Called when the UI is being removed from the interface of a JTextComponent.
        参数：
        c - the component
        另请参见：
        Highlighter.deinstall(javax.swing.text.JTextComponent)

      • addHighlight

        public Object addHighlight(int p0,
                  int p1,
                  Highlighter.HighlightPainter p)
                    throws BadLocationException
        Adds a highlight to the view. Returns a tag that can be used to refer to the highlight.
        参数：
        p0 - the start offset of the range to highlight >= 0
        p1 - the end offset of the range to highlight >= p0
        p - the painter to use to actually render the highlight
        返回：
        an object that can be used as a tag to refer to the highlight
        抛出：
        BadLocationException - if the specified location is invalid

      • removeHighlight

        public void removeHighlight(Object tag)
        Removes a highlight from the view.
        参数：
        tag - the reference to the highlight

      • removeAllHighlights

        public void removeAllHighlights()
        Removes all highlights.

      • changeHighlight

        public void changeHighlight(Object tag,
                   int p0,
                   int p1)
                     throws BadLocationException
        Changes a highlight.
        参数：
        tag - the highlight tag
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0
        抛出：
        BadLocationException - if the specified location is invalid

      • getHighlights

        public Highlighter.Highlight[] getHighlights()
        Makes a copy of the highlights. Does not actually clone each highlight, but only makes references to them.
        返回：
        the copy
        另请参见：
        Highlighter.getHighlights()

      • paintLayeredHighlights

        public void paintLayeredHighlights(Graphics g,
                          int p0,
                          int p1,
                          Shape viewBounds,
                          JTextComponent editor,
                          View view)
        When leaf Views (such as LabelView) are rendering they should call into this method. If a highlight is in the given region it will be drawn immediately.
        指定者：
        paintLayeredHighlights in class LayeredHighlighter
        参数：
        g - Graphics used to draw
        p0 - starting offset of view
        p1 - ending offset of view
        viewBounds - Bounds of View
        editor - JTextComponent
        view - View instance being rendered

      • setDrawsLayeredHighlights

        public void setDrawsLayeredHighlights(boolean newValue)
        If true, highlights are drawn as the Views draw the text. That is the Views will call into paintLayeredHighlight which will result in a rectangle being drawn before the text is drawn (if the offsets are in a highlighted region that is). For this to work the painter supplied must be an instance of LayeredHighlightPainter.

      • getDrawsLayeredHighlights

        public boolean getDrawsLayeredHighlights()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.h>tttyta>"oFN< <"tte up>i>atse<|<&eF,|" �.ssl >


DefaultHighlighter.DefaultHighlightPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultHighlighter.DefaultHighlightPainter

  • java.lang.Object
    • javax.swing.text.LayeredHighlighter.LayerPainter
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
  • 所有已实现的接口：
    Highlighter.HighlightPainter
    封闭类：
    DefaultHighlighter

    public static class DefaultHighlighter.DefaultHighlightPainter
extends LayeredHighlighter.LayerPainter
    Simple highlight painter that fills a highlighted area with a solid color.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultHighlighter.DefaultHighlightPainter(Color c)
      Constructs a new highlight painter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Color getColor()
      Returns the color of the highlight.
      void paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c)
      Paints a highlight.
      Shape paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      Paints a portion of a highlight.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultHighlighter.DefaultHighlightPainter

        public DefaultHighlighter.DefaultHighlightPainter(Color c)
        Constructs a new highlight painter. If c is null, the JTextComponent will be queried for its selection color.
        参数：
        c - the color for the highlight

    • 方法详细信息

      • getColor

        public Color getColor()
        Returns the color of the highlight.
        返回：
        the color

      • paint

        public void paint(Graphics g,
         int offs0,
         int offs1,
         Shape bounds,
         JTextComponent c)
        Paints a highlight.
        参数：
        g - the graphics context
        offs0 - the starting model offset >= 0
        offs1 - the ending model offset >= offs1
        bounds - the bounding box for the highlight
        c - the editor

      • paintLayer

        public Shape paintLayer(Graphics g,
               int offs0,
               int offs1,
               Shape bounds,
               JTextComponent c,
               View view)
        Paints a portion of a highlight.
        指定者：
        paintLayer in class LayeredHighlighter.LayerPainter
        参数：
        g - the graphics context
        offs0 - the starting model offset >= 0
        offs1 - the ending model offset >= offs1
        bounds - the bounding box of the view, which is not necessarily the region to paint.
        c - the editor
        view - View painting for
        返回：
        region drawing occured in
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fl >areeblmiat


DefaultStyledDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultStyledDocument

  • java.lang.Object
    • javax.swing.text.AbstractDocument
      • javax.swing.text.DefaultStyledDocument
  • 所有已实现的接口：
    Serializable, Document, StyledDocument
    直接已知子类：
    HTMLDocument

    public class DefaultStyledDocument
extends AbstractDocument
implements StyledDocument
    A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format. The element structure for this document represents style crossings for style runs. These style runs are mapped into a paragraph element structure (which may reside in some other structure). The style runs break at paragraph boundaries since logical styles are assigned to paragraph boundaries.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Document, AbstractDocument

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DefaultStyledDocument.AttributeUndoableEdit
      An UndoableEdit used to remember AttributeSet changes to an Element.
      class  DefaultStyledDocument.ElementBuffer
      Class to manage changes to the element hierarchy.
      static class  DefaultStyledDocument.ElementSpec
      Specification for building elements.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...

      • Nested classes/interfaces inherited from class javax.swing.text.AbstractDocument

        AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected DefaultStyledDocument.ElementBuffer | buffer
      static int BUFFER_SIZE_DEFAULT
      The default size of the initial content buffer.

      • Fields inherited from class javax.swing.text.AbstractDocument

        BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName

      • 字段 - 继承于接口 javax.swing.text.Document

        StreamDescriptionProperty, TitleProperty

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultStyledDocument()
      Constructs a default styled document.
      DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
      Constructs a styled document.
      DefaultStyledDocument(StyleContext styles)
      Constructs a styled document with the default content storage implementation and a shared set of styles.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addDocumentListener(DocumentListener listener)
      Adds a document listener for notification of any changes.
      Style addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      protected void create(DefaultStyledDocument.ElementSpec[] data)
      Initialize the document to reflect the given element structure (i.e.
      protected AbstractDocument.AbstractElement createDefaultRoot()
      Creates the root element to be used to represent the default document structure.
      Color getBackground(AttributeSet attr)
      Gets the background color from an attribute set.
      Element getCharacterElement(int pos)
      Gets a character element based on a position.
      Element getDefaultRootElement()
      Gets the default root element.
      Font getFont(AttributeSet attr)
      Gets the font from an attribute set.
      Color getForeground(AttributeSet attr)
      Gets the foreground color from an attribute set.
      Style getLogicalStyle(int p)
      Fetches the logical style assigned to the paragraph represented by the given position.
      Element getParagraphElement(int pos)
      Gets the paragraph element at the offset pos.
      Style getStyle(String nm)
      Fetches a named style previously added.
      Enumeration<?> getStyleNames()
      Fetches the list of of style names.
      protected void insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
      protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      void removeDocumentListener(DocumentListener listener)
      Removes a document listener.
      void removeElement(Element elem)
      Removes an element from this document.
      void removeStyle(String nm)
      Removes a named style previously added to the document.
      protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates document structure as a result of text removal.
      void setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for some part of the document.
      void setLogicalStyle(int pos, Style s)
      Sets the logical style to use for the paragraph at the given position.
      void setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for a paragraph.
      protected void styleChanged(Style style)
      Called when any of this document's styles have changed.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument

        addUndoableEditListener, createBranchElement, createLeafElement, createPosition, dump, fireChangedUpdate, fireInsertUpdate, fireRemoveUpdate, fireUndoableEditUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, insertString, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.Document

        addUndoableEditListener, createPosition, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeUndoableEditListener, render

    • 字段详细信息

      • BUFFER_SIZE_DEFAULT

        public static final int BUFFER_SIZE_DEFAULT
        The default size of the initial content buffer.
        另请参见：
        Constant Field Values

      • buffer

        protected DefaultStyledDocument.ElementBuffer buffer

    • 构造方法详细信息

      • DefaultStyledDocument

        public DefaultStyledDocument(AbstractDocument.Content c,
                     StyleContext styles)
        Constructs a styled document.
        参数：
        c - the container for the content
        styles - resources and style definitions which may be shared across documents

      • DefaultStyledDocument

        public DefaultStyledDocument(StyleContext styles)
        Constructs a styled document with the default content storage implementation and a shared set of styles.
        参数：
        styles - the styles

      • DefaultStyledDocument

        public DefaultStyledDocument()
        Constructs a default styled document. This buffers input content by a size of BUFFER_SIZE_DEFAULT and has a style context that is scoped by the lifetime of the document and is not shared with other documents.

    • 方法详细信息

      • getDefaultRootElement

        public Element getDefaultRootElement()
        Gets the default root element.
        指定者：
        getDefaultRootElement in interface Document
        指定者：
        getDefaultRootElement in class AbstractDocument
        返回：
        the root
        另请参见：
        Document.getDefaultRootElement()

      • create

        protected void create(DefaultStyledDocument.ElementSpec[] data)
        Initialize the document to reflect the given element structure (i.e. the structure reported by the getDefaultRootElement method. If the document contained any data it will first be removed.

      • insert

        protected void insert(int offset,
          DefaultStyledDocument.ElementSpec[] data)
               throws BadLocationException
        Inserts new elements in bulk. This is useful to allow parsing with the document in an unlocked state and prepare an element structure modification. This method takes an array of tokens that describe how to update an element structure so the time within a write lock can be greatly reduced in an asynchronous update situation.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        参数：
        offset - the starting offset >= 0
        data - the element data
        抛出：
        BadLocationException - for an invalid starting offset

      • removeElement

        public void removeElement(Element elem)
        Removes an element from this document.

        The element is removed from its parent element, as well as the text in the range identified by the element. If the element isn't associated with the document, IllegalArgumentException is thrown.

        As empty branch elements are not allowed in the document, if the element is the sole child, its parent element is removed as well, recursively. This means that when replacing all the children of a particular element, new children should be added before removing old children.

        Element removal results in two events being fired, the DocumentEvent for changes in element structure and UndoableEditEvent for changes in document content.

        If the element contains end-of-content mark (the last "\n" character in document), this character is not removed; instead, preceding leaf element is extended to cover the character. If the last leaf already ends with "\n", it is included in content removal.

        If the element is null, NullPointerException is thrown. If the element structure would become invalid after the removal, for example if the element is the document root element, IllegalArgumentException is thrown. If the current element structure is invalid, IllegalStateException is thrown.

        参数：
        elem - the element to remove
        抛出：
        NullPointerException - if the element is null
        IllegalArgumentException - if the element could not be removed
        IllegalStateException - if the element structure is invalid
        从以下版本开始：
        1.7

      • addStyle

        public Style addStyle(String nm,
             Style parent)
        Adds a new style into the logical style hierarchy. Style attributes resolve from bottom up so an attribute specified in a child will override an attribute specified in the parent.
        指定者：
        addStyle in interface StyledDocument
        参数：
        nm - the name of the style (must be unique within the collection of named styles). The name may be null if the style is unnamed, but the caller is responsible for managing the reference returned as an unnamed style can't be fetched by name. An unnamed style may be useful for things like character attribute overrides such as found in a style run.
        parent - the parent style. This may be null if unspecified attributes need not be resolved in some other style.
        返回：
        the style

      • removeStyle

        public void removeStyle(String nm)
        Removes a named style previously added to the document.
        指定者：
        removeStyle in interface StyledDocument
        参数：
        nm - the name of the style to remove

      • getStyle

        public Style getStyle(String nm)
        Fetches a named style previously added.
        指定者：
        getStyle in interface StyledDocument
        参数：
        nm - the name of the style
        返回：
        the style

      • getStyleNames

        public Enumeration<?> getStyleNames()
        Fetches the list of of style names.
        返回：
        all the style names

      • setLogicalStyle

        public void setLogicalStyle(int pos,
                   Style s)
        Sets the logical style to use for the paragraph at the given position. If attributes aren't explicitly set for character and paragraph attributes they will resolve through the logical style assigned to the paragraph, which in turn may resolve through some hierarchy completely independent of the element hierarchy in the document.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        setLogicalStyle in interface StyledDocument
        参数：
        pos - the offset from the start of the document >= 0
        s - the logical style to assign to the paragraph, null if none

      • getLogicalStyle

        public Style getLogicalStyle(int p)
        Fetches the logical style assigned to the paragraph represented by the given position.
        指定者：
        getLogicalStyle in interface StyledDocument
        参数：
        p - the location to translate to a paragraph and determine the logical style assigned >= 0. This is an offset from the start of the document.
        返回：
        the style, null if none

      • setCharacterAttributes

        public void setCharacterAttributes(int offset,
                          int length,
                          AttributeSet s,
                          boolean replace)
        Sets attributes for some part of the document. A write lock is held by this operation while changes are being made, and a DocumentEvent is sent to the listeners after the change has been successfully completed.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        setCharacterAttributes in interface StyledDocument
        参数：
        offset - the offset in the document >= 0
        length - the length >= 0
        s - the attributes
        replace - true if the previous attributes should be replaced before setting the new attributes

      • setParagraphAttributes

        public void setParagraphAttributes(int offset,
                          int length,
                          AttributeSet s,
                          boolean replace)
        Sets attributes for a paragraph.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        setParagraphAttributes in interface StyledDocument
        参数：
        offset - the offset into the paragraph >= 0
        length - the number of characters affected >= 0
        s - the attributes
        replace - whether to replace existing attributes, or merge them

      • getParagraphElement

        public Element getParagraphElement(int pos)
        Gets the paragraph element at the offset pos. A paragraph consists of at least one child Element, which is usually a leaf.
        指定者：
        getParagraphElement in interface StyledDocument
        指定者：
        getParagraphElement in class AbstractDocument
        参数：
        pos - the starting offset >= 0
        返回：
        the element

      • getCharacterElement

        public Element getCharacterElement(int pos)
        Gets a character element based on a position.
        指定者：
        getCharacterElement in interface StyledDocument
        参数：
        pos - the position in the document >= 0
        返回：
        the element

      • insertUpdate

        protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                AttributeSet attr)
        Updates document structure as a result of text insertion. This will happen within a write lock. This implementation simply parses the inserted content for line breaks and builds up a set of instructions for the element buffer.
        重载：
        insertUpdate in class AbstractDocument
        参数：
        chng - a description of the document change
        attr - the attributes

      • removeUpdate

        protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
        Updates document structure as a result of text removal.
        重载：
        removeUpdate in class AbstractDocument
        参数：
        chng - a description of the document change

      • createDefaultRoot

        protected AbstractDocument.AbstractElement createDefaultRoot()
        Creates the root element to be used to represent the default document structure.
        返回：
        the element base

      • getForeground

        public Color getForeground(AttributeSet attr)
        Gets the foreground color from an attribute set.
        指定者：
        getForeground in interface StyledDocument
        参数：
        attr - the attribute set
        返回：
        the color

      • getBackground

        public Color getBackground(AttributeSet attr)
        Gets the background color from an attribute set.
        指定者：
        getBackground in interface StyledDocument
        参数：
        attr - the attribute set
        返回：
        the color

      • getFont

        public Font getFont(AttributeSet attr)
        Gets the font from an attribute set.
        指定者：
        getFont in interface StyledDocument
        参数：
        attr - the attribute set
        返回：
        the font

      • styleChanged

        protected void styleChanged(Style style)
        Called when any of this document's styles have changed. Subclasses may wish to be intelligent about what gets damaged.
        参数：
        style - The Style that has changed.

      • addDocumentListener

        public void addDocumentListener(DocumentListener listener)
        Adds a document listener for notification of any changes.
        指定者：
        addDocumentListener in interface Document
        重载：
        addDocumentListener in class AbstractDocument
        参数：
        listener - the listener
        另请参见：
        Document.addDocumentListener(javax.swing.event.DocumentListener)

      • removeDocumentListener

        public void removeDocumentListener(DocumentListener listener)
        Removes a document listener.
        指定者：
        removeDocumentListener in interface Document
        重载：
        removeDocumentListener in class AbstractDocument
        参数：
        listener - the listener
        另请参见：
        Document.removeDocumentListener(javax.swing.event.DocumentListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultStyledDocument.AttributeUndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultStyledDocument.AttributeUndoableEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
  • 所有已实现的接口：
    Serializable, UndoableEdit
    封闭类：
    DefaultStyledDocument

    public static class DefaultStyledDocument.AttributeUndoableEdit
extends AbstractUndoableEdit
    An UndoableEdit used to remember AttributeSet changes to an Element.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected AttributeSet | copy
      protected Element | element
      protected boolean | isReplacing
      protected AttributeSet | newAttributes

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void redo()
      Redoes a change.
      void undo()
      Undoes a change.

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        addEdit, canRedo, canUndo, die, getPresentationName, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • newAttributes

        protected AttributeSet newAttributes

      • copy

        protected AttributeSet copy

      • isReplacing

        protected boolean isReplacing

      • element

        protected Element element

    • 构造方法详细信息

      • DefaultStyledDocument.AttributeUndoableEdit

        public DefaultStyledDocument.AttributeUndoableEdit(Element element,
                                           AttributeSet newAttributes,
                                           boolean isReplacing)

    • 方法详细信息

      • redo

        public void redo()
          throws CannotRedoException
        Redoes a change.
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class AbstractUndoableEdit
        抛出：
        CannotRedoException - if the change cannot be redone
        另请参见：
        AbstractUndoableEdit.canRedo()

      • undo

        public void undo()
          throws CannotUndoException
        Undoes a change.
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class AbstractUndoableEdit
        抛出：
        CannotUndoException - if the change cannot be undone
        另请参见：
        AbstractUndoableEdit.canUndo()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hn<ec


DefaultStyledDocument.ElementBuffer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultStyledDocument.ElementBuffer

  • java.lang.Object
    • javax.swing.text.DefaultStyledDocument.ElementBuffer
  • 所有已实现的接口：
    Serializable
    封闭类：
    DefaultStyledDocument

    public class DefaultStyledDocument.ElementBuffer
extends Object
implements Serializable
    Class to manage changes to the element hierarchy.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultStyledDocument.ElementBuffer(Element root)
      Creates a new ElementBuffer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void change(int offset, int length, AbstractDocument.DefaultDocumentEvent de)
      Changes content.
      protected void changeUpdate()
      Updates the element structure in response to a change in the document.
      Element clone(Element parent, Element clonee)
      Creates a copy of this element, with a different parent.
      Element getRootElement()
      Gets the root element.
      void insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de)
      Inserts new content.
      protected void insertUpdate(DefaultStyledDocument.ElementSpec[] data)
      Inserts an update into the document.
      void remove(int offset, int length, AbstractDocument.DefaultDocumentEvent de)
      Removes content.
      protected void removeUpdate()
      Updates the element structure in response to a removal from the associated sequence in the document.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultStyledDocument.ElementBuffer

        public DefaultStyledDocument.ElementBuffer(Element root)
        Creates a new ElementBuffer.
        参数：
        root - the root element
        从以下版本开始：
        1.4

    • 方法详细信息

      • getRootElement

        public Element getRootElement()
        Gets the root element.
        返回：
        the root element

      • insert

        public void insert(int offset,
          int length,
          DefaultStyledDocument.ElementSpec[] data,
          AbstractDocument.DefaultDocumentEvent de)
        Inserts new content.
        参数：
        offset - the starting offset >= 0
        length - the length >= 0
        data - the data to insert
        de - the event capturing this edit

      • remove

        public void remove(int offset,
          int length,
          AbstractDocument.DefaultDocumentEvent de)
        Removes content.
        参数：
        offset - the starting offset >= 0
        length - the length >= 0
        de - the event capturing this edit

      • change

        public void change(int offset,
          int length,
          AbstractDocument.DefaultDocumentEvent de)
        Changes content.
        参数：
        offset - the starting offset >= 0
        length - the length >= 0
        de - the event capturing this edit

      • insertUpdate

        protected void insertUpdate(DefaultStyledDocument.ElementSpec[] data)
        Inserts an update into the document.
        参数：
        data - the elements to insert

      • removeUpdate

        protected void removeUpdate()
        Updates the element structure in response to a removal from the associated sequence in the document. Any elements consumed by the span of the removal are removed.

      • changeUpdate

        protected void changeUpdate()
        Updates the element structure in response to a change in the document.

      • clone

        public Element clone(Element parent,
            Element clonee)
        Creates a copy of this element, with a different parent.
        参数：
        parent - the parent element
        clonee - the element to be cloned
        返回：
        the copy
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h=ltrn_enr eer ->e


DefaultStyledDocument.ElementSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultStyledDocument.ElementSpec

  • java.lang.Object
    • javax.swing.text.DefaultStyledDocument.ElementSpec
  • 封闭类：
    DefaultStyledDocument

    public static class DefaultStyledDocument.ElementSpec
extends Object
    Specification for building elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short ContentType
      A possible value for getType.
      static short EndTagType
      A possible value for getType.
      static short JoinFractureDirection
      A possible value for getDirection.
      static short JoinNextDirection
      A possible value for getDirection.
      static short JoinPreviousDirection
      A possible value for getDirection.
      static short OriginateDirection
      A possible value for getDirection.
      static short StartTagType
      A possible value for getType.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type)
      Constructor useful for markup when the markup will not be stored in the document.
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type, char[] txt, int offs, int len)
      Constructor for creating a spec externally for batch input of content and markup into the document.
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type, int len)
      Constructor for parsing inside the document when the data has already been added, but len information is needed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      char[] getArray()
      Gets the array of characters.
      AttributeSet getAttributes()
      Gets the element attributes.
      short getDirection()
      Gets the direction.
      int getLength()
      Gets the length.
      int getOffset()
      Gets the starting offset.
      short getType()
      Gets the element type.
      void setDirection(short direction)
      Sets the direction.
      void setType(short type)
      Sets the element type.
      String toString()
      Converts the element to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • StartTagType

        public static final short StartTagType
        A possible value for getType. This specifies that this record type is a start tag and represents markup that specifies the start of an element.
        另请参见：
        Constant Field Values

      • EndTagType

        public static final short EndTagType
        A possible value for getType. This specifies that this record type is a end tag and represents markup that specifies the end of an element.
        另请参见：
        Constant Field Values

      • ContentType

        public static final short ContentType
        A possible value for getType. This specifies that this record type represents content.
        另请参见：
        Constant Field Values

      • JoinPreviousDirection

        public static final short JoinPreviousDirection
        A possible value for getDirection. This specifies that the data associated with this record should be joined to what precedes it.
        另请参见：
        Constant Field Values

      • JoinNextDirection

        public static final short JoinNextDirection
        A possible value for getDirection. This specifies that the data associated with this record should be joined to what follows it.
        另请参见：
        Constant Field Values

      • OriginateDirection

        public static final short OriginateDirection
        A possible value for getDirection. This specifies that the data associated with this record should be used to originate a new element. This would be the normal value.
        另请参见：
        Constant Field Values

      • JoinFractureDirection

        public static final short JoinFractureDirection
        A possible value for getDirection. This specifies that the data associated with this record should be joined to the fractured element.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DefaultStyledDocument.ElementSpec

        public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                 short type)
        Constructor useful for markup when the markup will not be stored in the document.
        参数：
        a - the attributes for the element
        type - the type of the element (StartTagType, EndTagType, ContentType)

      • DefaultStyledDocument.ElementSpec

        public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                 short type,
                                 int len)
        Constructor for parsing inside the document when the data has already been added, but len information is needed.
        参数：
        a - the attributes for the element
        type - the type of the element (StartTagType, EndTagType, ContentType)
        len - the length >= 0

      • DefaultStyledDocument.ElementSpec

        public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                 short type,
                                 char[] txt,
                                 int offs,
                                 int len)
        Constructor for creating a spec externally for batch input of content and markup into the document.
        参数：
        a - the attributes for the element
        type - the type of the element (StartTagType, EndTagType, ContentType)
        txt - the text for the element
        offs - the offset into the text >= 0
        len - the length of the text >= 0

    • 方法详细信息

      • setType

        public void setType(short type)
        Sets the element type.
        参数：
        type - the type of the element (StartTagType, EndTagType, ContentType)

      • getType

        public short getType()
        Gets the element type.
        返回：
        the type of the element (StartTagType, EndTagType, ContentType)

      • setDirection

        public void setDirection(short direction)
        Sets the direction.
        参数：
        direction - the direction (JoinPreviousDirection, JoinNextDirection)

      • getDirection

        public short getDirection()
        Gets the direction.
        返回：
        the direction (JoinPreviousDirection, JoinNextDirection)

      • getAttributes

        public AttributeSet getAttributes()
        Gets the element attributes.
        返回：
        the attribute set

      • getArray

        public char[] getArray()
        Gets the array of characters.
        返回：
        the array

      • getOffset

        public int getOffset()
        Gets the starting offset.
        返回：
        the offset >= 0

      • getLength

        public int getLength()
        Gets the length.
        返回：
        the length >= 0

      • toString

        public String toString()
        Converts the element to a string.
        重载：
        toString in class Object
        返回：
        the string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

diei i ioikgcodep/yy,>.a�


DefaultStyledDocument.SectionElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DefaultStyledDocument.SectionElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    封闭类：
    DefaultStyledDocument

    protected class DefaultStyledDocument.SectionElement
extends AbstractDocument.BranchElement
    Default root element for a document... maps out the paragraphs/lines contained.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultStyledDocument.SectionElement()
      Creates a new SectionElement.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Gets the name of the element.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.BranchElement

        children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, positionToElement, replace, toString

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.AbstractElement

        addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DefaultStyledDocument.SectionElement

        public DefaultStyledDocument.SectionElement()
        Creates a new SectionElement.

    • 方法详细信息

      • getName

        public String getName()
        Gets the name of the element.
        指定者：
        getName in interface Element
        重载：
        getName in class AbstractDocument.BranchElement
        返回：
        the name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

su itlomlolrrollw.rr.st. iid/>=sd= " >>lols/>s


DefaultTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.text

类 DefaultTextUI

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI
          • javax.swing.text.DefaultTextUI
  • 所有已实现的接口：
    ViewFactory
    Deprecated.

    @Deprecated
public abstract class DefaultTextUI
extends BasicTextUI

    This class has been deprecated and should no longer be used. The basis of the various TextUI implementations can be found in the javax.swing.plaf.basic package and the class BasicTextUI replaces this class.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.plaf.basic.BasicTextUI

        BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTextUI()
      Deprecated.

    • 方法摘要

      • 方法 - 继承于类 javax.swing.plaf.basic.BasicTextUI

        create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getPropertyPrefix, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel

      • 方法 - 继承于类 javax.swing.plaf.ComponentUI

        contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultTextUI

        public DefaultTextUI()
        Deprecated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

seuce=af=a< a<< /..ll


Document

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Document

  • All Known Subinterfaces:
    StyledDocument
    All Known Implementing Classes:
    AbstractDocument, DefaultStyledDocument, HTMLDocument, PlainDocument

    public interface Document

    The Document is a container for text that serves as the model for swing text components. The goal for this interface is to scale from very simple needs (a plain text textfield) to complex needs (an HTML or XML document, for example).

    Content

    At the simplest level, text can be modeled as a linear sequence of characters. To support internationalization, the Swing text model uses unicode characters. The sequence of characters displayed in a text component is generally referred to as the component's content.

    To refer to locations within the sequence, the coordinates used are the location between two characters. As the diagram below shows, a location in a text document can be referred to as a position, or an offset. This position is zero-based.

    The following text describes this graphic.

    In the example, if the content of a document is the sequence "The quick brown fox," as shown in the preceding diagram, the location just before the word "The" is 0, and the location after the word "The" and before the whitespace that follows it is 3. The entire sequence of characters in the sequence "The" is called a range.

    The following methods give access to the character data that makes up the content.

    • getLength()
    • getText(int, int)
    • getText(int, int, Segment)

    Structure

    Text is rarely represented simply as featureless content. Rather, text typically has some sort of structure associated with it. Exactly what structure is modeled is up to a particular Document implementation. It might be as simple as no structure (i.e. a simple text field), or it might be something like diagram below.

    Diagram shows Book->Chapter->Paragraph

    The unit of structure (i.e. a node of the tree) is referred to by the Element interface. Each Element can be tagged with a set of attributes. These attributes (name/value pairs) are defined by the AttributeSet interface.

    The following methods give access to the document structure.

    • getDefaultRootElement
    • getRootElements

    Mutations

    All documents need to be able to add and remove simple text. Typically, text is inserted and removed via gestures from a keyboard or a mouse. What effect the insertion or removal has upon the document structure is entirely up to the implementation of the document.

    The following methods are related to mutation of the document content:

    • insertString(int, String, AttributeSet)
    • remove(int, int)
    • createPosition(int)

    Notification

    Mutations to the Document must be communicated to interested observers. The notification of change follows the event model guidelines that are specified for JavaBeans. In the JavaBeans event model, once an event notification is dispatched, all listeners must be notified before any further mutations occur to the source of the event. Further, order of delivery is not guaranteed.

    Notification is provided as two separate events, DocumentEvent, and UndoableEditEvent. If a mutation is made to a Document through its api, a DocumentEvent will be sent to all of the registered DocumentListeners. If the Document implementation supports undo/redo capabilities, an UndoableEditEvent will be sent to all of the registered UndoableEditListeners. If an undoable edit is undone, a DocumentEvent should be fired from the Document to indicate it has changed again. In this case however, there should be no UndoableEditEvent generated since that edit is actually the source of the change rather than a mutation to the Document made through its api.

    The preceeding text describes this graphic.

    Referring to the above diagram, suppose that the component shown on the left mutates the document object represented by the blue rectangle. The document responds by dispatching a DocumentEvent to both component views and sends an UndoableEditEvent to the listening logic, which maintains a history buffer.

    Now suppose that the component shown on the right mutates the same document. Again, the document dispatches a DocumentEvent to both component views and sends an UndoableEditEvent to the listening logic that is maintaining the history buffer.

    If the history buffer is then rolled back (i.e. the last UndoableEdit undone), a DocumentEvent is sent to both views, causing both of them to reflect the undone mutation to the document (that is, the removal of the right component's mutation). If the history buffer again rolls back another change, another DocumentEvent is sent to both views, causing them to reflect the undone mutation to the document -- that is, the removal of the left component's mutation.

    The methods related to observing mutations to the document are:

    • addDocumentListener(DocumentListener)
    • removeDocumentListener(DocumentListener)
    • addUndoableEditListener(UndoableEditListener)
    • removeUndoableEditListener(UndoableEditListener)

    Properties

    Document implementations will generally have some set of properties associated with them at runtime. Two well known properties are the StreamDescriptionProperty, which can be used to describe where the Document came from, and the TitleProperty, which can be used to name the Document. The methods related to the properties are:

    • getProperty(Object)
    • putProperty(Object, Object)

    For more information on the Document class, see The Swing Connection and most particularly the article, The Element Interface.

    另请参见：
    DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener, Element, Position, AttributeSet

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String StreamDescriptionProperty
      The property name for the description of the stream used to initialize the document.
      static String TitleProperty
      The property name for the title of the document, if there is one.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addDocumentListener(DocumentListener listener)
      Registers the given observer to begin receiving notifications when changes are made to the document.
      void addUndoableEditListener(UndoableEditListener listener)
      Registers the given observer to begin receiving notifications when undoable edits are made to the document.
      Position createPosition(int offs)
      This method allows an application to mark a place in a sequence of character content.
      Element getDefaultRootElement()
      Returns the root element that views should be based upon, unless some other mechanism for assigning views to element structures is provided.
      Position getEndPosition()
      Returns a position that represents the end of the document.
      int getLength()
      Returns number of characters of content currently in the document.
      Object getProperty(Object key)
      Gets the properties associated with the document.
      Element[] getRootElements()
      Returns all of the root elements that are defined.
      Position getStartPosition()
      Returns a position that represents the start of the document.
      String getText(int offset, int length)
      Fetches the text contained within the given portion of the document.
      void getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
      void insertString(int offset, String str, AttributeSet a)
      Inserts a string of content.
      void putProperty(Object key, Object value)
      Associates a property with the document.
      void remove(int offs, int len)
      Removes a portion of the content of the document.
      void removeDocumentListener(DocumentListener listener)
      Unregisters the given observer from the notification list so it will no longer receive change updates.
      void removeUndoableEditListener(UndoableEditListener listener)
      Unregisters the given observer from the notification list so it will no longer receive updates.
      void render(Runnable r)
      Allows the model to be safely rendered in the presence of concurrency, if the model supports being updated asynchronously.

    • 字段详细信息

      • StreamDescriptionProperty

        static final String StreamDescriptionProperty
        The property name for the description of the stream used to initialize the document. This should be used if the document was initialized from a stream and anything is known about the stream.
        另请参见：
        Constant Field Values

      • TitleProperty

        static final String TitleProperty
        The property name for the title of the document, if there is one.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getLength

        int getLength()
        Returns number of characters of content currently in the document.
        返回：
        number of characters >= 0

      • addDocumentListener

        void addDocumentListener(DocumentListener listener)
        Registers the given observer to begin receiving notifications when changes are made to the document.
        参数：
        listener - the observer to register
        另请参见：
        removeDocumentListener(javax.swing.event.DocumentListener)

      • removeDocumentListener

        void removeDocumentListener(DocumentListener listener)
        Unregisters the given observer from the notification list so it will no longer receive change updates.
        参数：
        listener - the observer to register
        另请参见：
        addDocumentListener(javax.swing.event.DocumentListener)

      • addUndoableEditListener

        void addUndoableEditListener(UndoableEditListener listener)
        Registers the given observer to begin receiving notifications when undoable edits are made to the document.
        参数：
        listener - the observer to register
        另请参见：
        UndoableEditEvent

      • removeUndoableEditListener

        void removeUndoableEditListener(UndoableEditListener listener)
        Unregisters the given observer from the notification list so it will no longer receive updates.
        参数：
        listener - the observer to register
        另请参见：
        UndoableEditEvent

      • getProperty

        Object getProperty(Object key)
        Gets the properties associated with the document.
        参数：
        key - a non-null property key
        返回：
        the properties
        另请参见：
        putProperty(Object, Object)

      • putProperty

        void putProperty(Object key,
               Object value)
        Associates a property with the document. Two standard property keys provided are: StreamDescriptionProperty and TitleProperty. Other properties, such as author, may also be defined.
        参数：
        key - the non-null property key
        value - the property value
        另请参见：
        getProperty(Object)

      • remove

        void remove(int offs,
          int len)
            throws BadLocationException
        Removes a portion of the content of the document. This will cause a DocumentEvent of type DocumentEvent.EventType.REMOVE to be sent to the registered DocumentListeners, unless an exception is thrown. The notification will be sent to the listeners by calling the removeUpdate method on the DocumentListeners.

        To ensure reasonable behavior in the face of concurrency, the event is dispatched after the mutation has occurred. This means that by the time a notification of removal is dispatched, the document has already been updated and any marks created by createPosition have already changed. For a removal, the end of the removal range is collapsed down to the start of the range, and any marks in the removal range are collapsed down to the start of the range.

        Diagram shows removal of 'quick' from 'The quick brown fox.'

        If the Document structure changed as result of the removal, the details of what Elements were inserted and removed in response to the change will also be contained in the generated DocumentEvent. It is up to the implementation of a Document to decide how the structure should change in response to a remove.

        If the Document supports undo/redo, an UndoableEditEvent will also be generated.

        参数：
        offs - the offset from the beginning >= 0
        len - the number of characters to remove >= 0
        抛出：
        BadLocationException - some portion of the removal range was not a valid part of the document. The location in the exception is the first bad position encountered.
        另请参见：
        DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener

      • insertString

        void insertString(int offset,
                String str,
                AttributeSet a)
                  throws BadLocationException
        Inserts a string of content. This will cause a DocumentEvent of type DocumentEvent.EventType.INSERT to be sent to the registered DocumentListers, unless an exception is thrown. The DocumentEvent will be delivered by calling the insertUpdate method on the DocumentListener. The offset and length of the generated DocumentEvent will indicate what change was actually made to the Document.

        Diagram shows insertion of 'quick' in 'The quick brown fox'

        If the Document structure changed as result of the insertion, the details of what Elements were inserted and removed in response to the change will also be contained in the generated DocumentEvent. It is up to the implementation of a Document to decide how the structure should change in response to an insertion.

        If the Document supports undo/redo, an UndoableEditEvent will also be generated.

        参数：
        offset - the offset into the document to insert the content >= 0. All positions that track change at or after the given location will move.
        str - the string to insert
        a - the attributes to associate with the inserted content. This may be null if there are no attributes.
        抛出：
        BadLocationException - the given insert position is not a valid position within the document
        另请参见：
        DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener

      • getText

        String getText(int offset,
             int length)
               throws BadLocationException
        Fetches the text contained within the given portion of the document.
        参数：
        offset - the offset into the document representing the desired start of the text >= 0
        length - the length of the desired string >= 0
        返回：
        the text, in a String of length >= 0
        抛出：
        BadLocationException - some portion of the given range was not a valid part of the document. The location in the exception is the first bad position encountered.

      • getText

        void getText(int offset,
           int length,
           Segment txt)
             throws BadLocationException
        Fetches the text contained within the given portion of the document.

        If the partialReturn property on the txt parameter is false, the data returned in the Segment will be the entire length requested and may or may not be a copy depending upon how the data was stored. If the partialReturn property is true, only the amount of text that can be returned without creating a copy is returned. Using partial returns will give better performance for situations where large parts of the document are being scanned. The following is an example of using the partial return to access the entire document:

   int nleft = doc.getDocumentLength();
   Segment text = new Segment();
   int offs = 0;
   text.setPartialReturn(true);
   while (nleft > 0) {
       doc.getText(offs, nleft, text);
       // do someting with text
       nleft -= text.count;
       offs += text.count;
   }
        参数：
        offset - the offset into the document representing the desired start of the text >= 0
        length - the length of the desired string >= 0
        txt - the Segment object to return the text in
        抛出：
        BadLocationException - Some portion of the given range was not a valid part of the document. The location in the exception is the first bad position encountered.

      • getStartPosition

        Position getStartPosition()
        Returns a position that represents the start of the document. The position returned can be counted on to track change and stay located at the beginning of the document.
        返回：
        the position

      • getEndPosition

        Position getEndPosition()
        Returns a position that represents the end of the document. The position returned can be counted on to track change and stay located at the end of the document.
        返回：
        the position

      • createPosition

        Position createPosition(int offs)
                        throws BadLocationException
        This method allows an application to mark a place in a sequence of character content. This mark can then be used to tracks change as insertions and removals are made in the content. The policy is that insertions always occur prior to the current position (the most common case) unless the insertion location is zero, in which case the insertion is forced to a position that follows the original position.
        参数：
        offs - the offset from the start of the document >= 0
        返回：
        the position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document

      • getRootElements

        Element[] getRootElements()
        Returns all of the root elements that are defined.

        Typically there will be only one document structure, but the interface supports building an arbitrary number of structural projections over the text data. The document can have multiple root elements to support multiple document structures. Some examples might be:

        • Text direction.
        • Lexical token streams.
        • Parse trees.
        • Conversions to formats other than the native format.
        • Modification specifications.
        • Annotations.
        返回：
        the root element

      • getDefaultRootElement

        Element getDefaultRootElement()
        Returns the root element that views should be based upon, unless some other mechanism for assigning views to element structures is provided.
        返回：
        the root element

      • render

        void render(Runnable r)
        Allows the model to be safely rendered in the presence of concurrency, if the model supports being updated asynchronously. The given runnable will be executed in a way that allows it to safely read the model with no changes while the runnable is being executed. The runnable itself may not make any mutations.
        参数：
        r - a Runnable used to render the model
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DocumentFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DocumentFilter

  • java.lang.Object
    • javax.swing.text.DocumentFilter

  • public class DocumentFilter
extends Object
    DocumentFilter, as the name implies, is a filter for the Document mutation methods. When a Document containing a DocumentFilter is modified (either through insert or remove), it forwards the appropriate method invocation to the DocumentFilter. The default implementation allows the modification to occur. Subclasses can filter the modifications by conditionally invoking methods on the superclass, or invoking the necessary methods on the passed in FilterBypass. Subclasses should NOT call back into the Document for the modification instead call into the superclass or the FilterBypass.

    When remove or insertString is invoked on the DocumentFilter, the DocumentFilter may callback into the FilterBypass multiple times, or for different regions, but it should not callback into the FilterBypass after returning from the remove or insertString method.

    By default, text related document mutation methods such as insertString, replace and remove in AbstractDocument use DocumentFilter when available, and Element related mutation methods such as create, insert and removeElement in DefaultStyledDocument do not use DocumentFilter. If a method doesn't follow these defaults, this must be explicitly stated in the method documentation.

    从以下版本开始：
    1.4
    另请参见：
    Document, AbstractDocument, DefaultStyledDocument

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DocumentFilter.FilterBypass
      Used as a way to circumvent calling back into the Document to change it.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocumentFilter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
      Invoked prior to insertion of text into the specified Document.
      void remove(DocumentFilter.FilterBypass fb, int offset, int length)
      Invoked prior to removal of the specified region in the specified Document.
      void replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
      Invoked prior to replacing a region of text in the specified Document.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocumentFilter

        public DocumentFilter()

    • 方法详细信息

      • remove

        public void remove(DocumentFilter.FilterBypass fb,
          int offset,
          int length)
            throws BadLocationException
        Invoked prior to removal of the specified region in the specified Document. Subclasses that want to conditionally allow removal should override this and only call supers implementation as necessary, or call directly into the FilterBypass as necessary.
        参数：
        fb - FilterBypass that can be used to mutate Document
        offset - the offset from the beginning >= 0
        length - the number of characters to remove >= 0
        抛出：
        BadLocationException - some portion of the removal range was not a valid part of the document. The location in the exception is the first bad position encountered.

      • insertString

        public void insertString(DocumentFilter.FilterBypass fb,
                int offset,
                String string,
                AttributeSet attr)
                  throws BadLocationException
        Invoked prior to insertion of text into the specified Document. Subclasses that want to conditionally allow insertion should override this and only call supers implementation as necessary, or call directly into the FilterBypass.
        参数：
        fb - FilterBypass that can be used to mutate Document
        offset - the offset into the document to insert the content >= 0. All positions that track change at or after the given location will move.
        string - the string to insert
        attr - the attributes to associate with the inserted content. This may be null if there are no attributes.
        抛出：
        BadLocationException - the given insert position is not a valid position within the document

      • replace

        public void replace(DocumentFilter.FilterBypass fb,
           int offset,
           int length,
           String text,
           AttributeSet attrs)
             throws BadLocationException
        Invoked prior to replacing a region of text in the specified Document. Subclasses that want to conditionally allow replace should override this and only call supers implementation as necessary, or call directly into the FilterBypass.
        参数：
        fb - FilterBypass that can be used to mutate Document
        offset - Location in Document
        length - Length of text to delete
        text - Text to insert, null indicates no text to insert
        attrs - AttributeSet indicating attributes of inserted text, null is legal.
        抛出：
        BadLocationException - the given insert position is not a valid position within the document
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Srr>.eorwsiiwsiaaiiu.et.pe.e.rh"e. s"i


DocumentFilter.FilterBypass

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 DocumentFilter.FilterBypass

  • java.lang.Object
    • javax.swing.text.DocumentFilter.FilterBypass
  • 封闭类：
    DocumentFilter

    public abstract static class DocumentFilter.FilterBypass
extends Object
    Used as a way to circumvent calling back into the Document to change it. Document implementations that wish to support a DocumentFilter must provide an implementation that will not callback into the DocumentFilter when the following methods are invoked from the DocumentFilter.
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocumentFilter.FilterBypass()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Document getDocument()
      Returns the Document the mutation is occuring on.
      abstract void insertString(int offset, String string, AttributeSet attr)
      Inserts the specified text, bypassing the DocumentFilter.
      abstract void remove(int offset, int length)
      Removes the specified region of text, bypassing the DocumentFilter.
      abstract void replace(int offset, int length, String string, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocumentFilter.FilterBypass

        public DocumentFilter.FilterBypass()

    • 方法详细信息

      • getDocument

        public abstract Document getDocument()
        Returns the Document the mutation is occuring on.
        返回：
        Document that remove/insertString will operate on

      • remove

        public abstract void remove(int offset,
          int length)
                     throws BadLocationException
        Removes the specified region of text, bypassing the DocumentFilter.
        参数：
        offset - the offset from the beginning >= 0
        length - the number of characters to remove >= 0
        抛出：
        BadLocationException - some portion of the removal range was not a valid part of the document. The location in the exception is the first bad position encountered.

      • insertString

        public abstract void insertString(int offset,
                String string,
                AttributeSet attr)
                           throws BadLocationException
        Inserts the specified text, bypassing the DocumentFilter.
        参数：
        offset - the offset into the document to insert the content >= 0. All positions that track change at or after the given location will move.
        string - the string to insert
        attr - the attributes to associate with the inserted content. This may be null if there are no attributes.
        抛出：
        BadLocationException - the given insert position is not a valid position within the document

      • replace

        public abstract void replace(int offset,
           int length,
           String string,
           AttributeSet attrs)
                      throws BadLocationException
        Deletes the region of text from offset to offset + length, and replaces it with text.
        参数：
        offset - Location in Document
        length - Length of text to delete
        string - Text to insert, null indicates no text to insert
        attrs - AttributeSet indicating attributes of inserted text, null is legal.
        抛出：
        BadLocationException - the given insert is not a valid position within the document
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

umrblsiasidvvidddgttavt/t/iutmte/gg/.sx."t


EditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 EditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    DefaultEditorKit

    public abstract class EditorKit
extends Object
implements Cloneable, Serializable
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content. The EditorKit acts as a factory for some kind of policy. For example, an implementation of html and rtf can be provided that is replaceable with other implementations.

    A kit can safely store editing state as an instance of the kit will be dedicated to a text component. New kits will normally be created by cloning a prototype kit. The kit will have it's setComponent method called to establish it's relationship with a JTextComponent.

    • 构造方法摘要

      Constructors
      构造方法与描述
      EditorKit()
      Construct an EditorKit.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a copy of the editor kit.
      abstract Caret createCaret()
      Fetches a caret that can navigate through views produced by the associated ViewFactory.
      abstract Document createDefaultDocument()
      Creates an uninitialized text storage model that is appropriate for this type of editor.
      void deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      abstract Action[] getActions()
      Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
      abstract String getContentType()
      Gets the MIME type of the data that this kit represents support for.
      abstract ViewFactory getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      void install(JEditorPane c)
      Called when the kit is being installed into the a JEditorPane.
      abstract void read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      abstract void read(Reader in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      abstract void write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      abstract void write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EditorKit

        public EditorKit()
        Construct an EditorKit.

    • 方法详细信息

      • clone

        public Object clone()
        Creates a copy of the editor kit. This is implemented to use Object.clone. If the kit cannot be cloned, null is returned.
        重载：
        clone in class Object
        返回：
        the copy
        另请参见：
        Cloneable

      • install

        public void install(JEditorPane c)
        Called when the kit is being installed into the a JEditorPane.
        参数：
        c - the JEditorPane

      • deinstall

        public void deinstall(JEditorPane c)
        Called when the kit is being removed from the JEditorPane. This is used to unregister any listeners that were attached.
        参数：
        c - the JEditorPane

      • getContentType

        public abstract String getContentType()
        Gets the MIME type of the data that this kit represents support for.
        返回：
        the type

      • getViewFactory

        public abstract ViewFactory getViewFactory()
        Fetches a factory that is suitable for producing views of any models that are produced by this kit.
        返回：
        the factory

      • getActions

        public abstract Action[] getActions()
        Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.
        返回：
        the set of actions

      • createCaret

        public abstract Caret createCaret()
        Fetches a caret that can navigate through views produced by the associated ViewFactory.
        返回：
        the caret

      • createDefaultDocument

        public abstract Document createDefaultDocument()
        Creates an uninitialized text storage model that is appropriate for this type of editor.
        返回：
        the model

      • read

        public abstract void read(InputStream in,
        Document doc,
        int pos)
                   throws IOException,
                          BadLocationException
        Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public abstract void write(OutputStream out,
         Document doc,
         int pos,
         int len)
                    throws IOException,
                           BadLocationException
        Writes content from a document to the given stream in a format appropriate for this kind of content handler.
        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content from >= 0.
        len - The amount to write out >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • read

        public abstract void read(Reader in,
        Document doc,
        int pos)
                   throws IOException,
                          BadLocationException
        Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.

        Since actual text editing is unicode based, this would generally be the preferred way to read in the data. Some types of content are stored in an 8-bit form however, and will favor the InputStream.

        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public abstract void write(Writer out,
         Document doc,
         int pos,
         int len)
                    throws IOException,
                           BadLocationException
        Writes content from a document to the given stream in a format appropriate for this kind of content handler.

        Since actual text editing is unicode based, this would generally be the preferred way to write the data. Some types of content are stored in an 8-bit form however, and will favor the OutputStream.

        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content >= 0.
        len - The amount to write out >= 0.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N t t >!- --o-->#e;lfh=oee/dred#k


Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Element

  • All Known Implementing Classes:
    AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement

    public interface Element
    Interface to describe a structural piece of a document. It is intended to capture the spirit of an SGML element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AttributeSet getAttributes()
      Fetches the collection of attributes this element contains.
      Document getDocument()
      Fetches the document associated with this element.
      Element getElement(int index)
      Fetches the child element at the given index.
      int getElementCount()
      Gets the number of child elements contained by this element.
      int getElementIndex(int offset)
      Gets the child element index closest to the given offset.
      int getEndOffset()
      Fetches the offset from the beginning of the document that this element ends at.
      String getName()
      Fetches the name of the element.
      Element getParentElement()
      Fetches the parent element.
      int getStartOffset()
      Fetches the offset from the beginning of the document that this element begins at.
      boolean isLeaf()
      Is this element a leaf element? An element that may have children, even if it currently has no children, would return false.

    • 方法详细信息

      • getDocument

        Document getDocument()
        Fetches the document associated with this element.
        返回：
        the document

      • getParentElement

        Element getParentElement()
        Fetches the parent element. If the element is a root level element returns null.
        返回：
        the parent element

      • getName

        String getName()
        Fetches the name of the element. If the element is used to represent some type of structure, this would be the type name.
        返回：
        the element name

      • getAttributes

        AttributeSet getAttributes()
        Fetches the collection of attributes this element contains.
        返回：
        the attributes for the element

      • getStartOffset

        int getStartOffset()
        Fetches the offset from the beginning of the document that this element begins at. If this element has children, this will be the offset of the first child. As a document position, there is an implied forward bias.
        返回：
        the starting offset >= 0 and < getEndOffset();
        另请参见：
        Document, AbstractDocument

      • getEndOffset

        int getEndOffset()
        Fetches the offset from the beginning of the document that this element ends at. If this element has children, this will be the end offset of the last child. As a document position, there is an implied backward bias.

        All the default Document implementations descend from AbstractDocument. AbstractDocument models an implied break at the end of the document. As a result of this, it is possible for this to return a value greater than the length of the document.

        返回：
        the ending offset > getStartOffset() and <= getDocument().getLength() + 1
        另请参见：
        Document, AbstractDocument

      • getElementIndex

        int getElementIndex(int offset)
        Gets the child element index closest to the given offset. The offset is specified relative to the beginning of the document. Returns -1 if the Element is a leaf, otherwise returns the index of the Element that best represents the given location. Returns 0 if the location is less than the start offset. Returns getElementCount() - 1 if the location is greater than or equal to the end offset.
        参数：
        offset - the specified offset >= 0
        返回：
        the element index >= 0

      • getElementCount

        int getElementCount()
        Gets the number of child elements contained by this element. If this element is a leaf, a count of zero is returned.
        返回：
        the number of child elements >= 0

      • getElement

        Element getElement(int index)
        Fetches the child element at the given index.
        参数：
        index - the specified index >= 0
        返回：
        the child element

      • isLeaf

        boolean isLeaf()
        Is this element a leaf element? An element that may have children, even if it currently has no children, would return false.
        返回：
        true if a leaf element else false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oyctpc&;c&>nn&>>n"xxapssb/xhi.le=&


ElementIterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 ElementIterator

  • java.lang.Object
    • javax.swing.text.ElementIterator
  • 所有已实现的接口：
    Cloneable

    public class ElementIterator
extends Object
implements Cloneable

    ElementIterator, as the name suggests, iteratates over the Element tree. The constructor can be invoked with either Document or an Element as an argument. If the constructor is invoked with a Document as an argument then the root of the iteration is the return value of document.getDefaultRootElement(). The iteration happens in a depth-first manner. In terms of how boundary conditions are handled: a) if next() is called before first() or current(), the root will be returned. b) next() returns null to indicate the end of the list. c) previous() returns null when the current element is the root or next() has returned null. The ElementIterator does no locking of the Element tree. This means that it does not track any changes. It is the responsibility of the user of this class, to ensure that no changes happen during element iteration. Simple usage example: public void iterate() { ElementIterator it = new ElementIterator(root); Element elem; while (true) { if ((elem = next()) != null) { // process element System.out.println("elem: " + elem.getName()); } else { break; } } }

    • 构造方法摘要

      Constructors
      构造方法与描述
      ElementIterator(Document document)
      Creates a new ElementIterator.
      ElementIterator(Element root)
      Creates a new ElementIterator.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Clones the ElementIterator.
      Element current()
      Fetches the current Element.
      int depth()
      Fetches the current depth of element tree.
      Element first()
      Fetches the first element.
      Element 下一个()
      Fetches the next Element.
      Element previous()
      Fetches the previous Element.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ElementIterator

        public ElementIterator(Document document)
        Creates a new ElementIterator. The root element is taken to get the default root element of the document.
        参数：
        document - a Document.

      • ElementIterator

        public ElementIterator(Element root)
        Creates a new ElementIterator.
        参数：
        root - the root Element.

    • 方法详细信息

      • clone

        public Object clone()
        Clones the ElementIterator.
        重载：
        clone in class Object
        返回：
        a cloned ElementIterator Object.
        另请参见：
        Cloneable

      • first

        public Element first()
        Fetches the first element.
        返回：
        an Element.

      • depth

        public int depth()
        Fetches the current depth of element tree.
        返回：
        the depth.

      • current

        public Element current()
        Fetches the current Element.
        返回：
        element on top of the stack or null if the root element is null

      • 下一个

        public Element next()
        Fetches the next Element. The strategy used to locate the next element is a depth-first search.
        返回：
        the next element or null at the end of the list.

      • previous

        public Element previous()
        Fetches the previous Element. If howver the current element is the last element, or the current element is null, then null is returned.
        返回：
        previous Element if available
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tn= h x e "aget_natt吻t�"hfr隺裕袁贩� Ｄ⒑c


FieldView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 FieldView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.PlainView
        • javax.swing.text.FieldView
  • 所有已实现的接口：
    SwingConstants, TabExpander
    直接已知子类：
    PasswordView

    public class FieldView
extends PlainView
    Extends the multi-line plain text view to be suitable for a single-line editor view. If the view is allocated extra space, the field must adjust for it. If the hosting component is a JTextField, this view will manage the ranges of the associated BoundedRangeModel and will adjust the horizontal allocation to match the current visibility settings of the JTextField.
    另请参见：
    View

    • 字段摘要

      • Fields inherited from class javax.swing.text.PlainView

        metrics

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      FieldView(Element elem)
      Constructs a new FieldView wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Shape adjustAllocation(Shape a)
      Adjusts the allocation given to the view to be a suitable allocation for a text field.
      protected FontMetrics getFontMetrics()
      Fetches the font metrics associated with the component hosting this view.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      int getResizeWeight(int axis)
      Determines the resizability of the view along the given axis.
      void insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      void removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      int viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.PlainView

        changedUpdate, damageLineRange, drawLine, drawSelectedText, drawUnselectedText, getLineBuffer, getTabSize, lineToRect, nextTabStop, setSize, updateDamage, updateMetrics

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FieldView

        public FieldView(Element elem)
        Constructs a new FieldView wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • getFontMetrics

        protected FontMetrics getFontMetrics()
        Fetches the font metrics associated with the component hosting this view.
        返回：
        the metrics

      • adjustAllocation

        protected Shape adjustAllocation(Shape a)
        Adjusts the allocation given to the view to be a suitable allocation for a text field. If the view has been allocated more than the preferred span vertically, the allocation is changed to be centered vertically. Horizontally the view is adjusted according to the horizontal alignment property set on the associated JTextField (if that is the type of the hosting component).
        参数：
        a - the allocation given to the view, which may need to be adjusted.
        返回：
        the allocation that the superclass should use.

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders using the given rendering surface and area on that surface. The view may need to do layout and create child views to enable itself to render into the given allocation.
        重载：
        paint in class PlainView
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        重载：
        getPreferredSpan in class PlainView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getPreferredSpan(int)

      • getResizeWeight

        public int getResizeWeight(int axis)
        Determines the resizability of the view along the given axis. A value of 0 or less is not resizable.
        重载：
        getResizeWeight in class View
        参数：
        axis - View.X_AXIS or View.Y_AXIS
        返回：
        the weight -> 1 for View.X_AXIS, else 0

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        重载：
        modelToView in class PlainView
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float fx,
              float fy,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        重载：
        viewToModel in class PlainView
        参数：
        fx - the X coordinate >= 0.0f
        fy - the Y coordinate >= 0.0f
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point in the view
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • insertUpdate

        public void insertUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for.
        重载：
        insertUpdate in class PlainView
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for.
        重载：
        removeUpdate in class PlainView
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FlowView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 FlowView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    ParagraphView

    public abstract class FlowView
extends BoxView
    A View that tries to flow it's children into some partially constrained space. This can be used to build things like paragraphs, pages, etc. The flow is made up of the following pieces of functionality.
    • A logical set of child views, which as used as a layout pool from which a physical view is formed.
    • A strategy for translating the logical view to a physical (flowed) view.
    • Constraints for the strategy to work against.
    • A physical structure, that represents the flow. The children of this view are where the pieces of of the logical views are placed to create the flow.
    从以下版本开始：
    1.3
    另请参见：
    View

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  FlowView.FlowStrategy
      Strategy for maintaining the physical form of the flow.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected View layoutPool
      These are the views that represent the child elements of the element this view represents (The logical view to translate to a physical view).
      protected int layoutSpan
      Default constraint against which the flow is created against.
      protected FlowView.FlowStrategy strategy
      The behavior for keeping the flow updated.

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      FlowView(Element elem, int axis)
      Constructs a FlowView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate equirements along the minor axis.
      void changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected abstract View createRow()
      Create a View that should be used to hold a a rows worth of children in a flow.
      int getFlowAxis()
      Fetches the axis along which views should be flowed.
      int getFlowSpan(int index)
      Fetch the constraining span to flow against for the given child index.
      int getFlowStart(int index)
      Fetch the location along the flow axis that the flow span will start at.
      protected int getViewIndexAtPosition(int pos)
      Fetches the child view index representing the given position in the model.
      void insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      protected void layout(int width, int height)
      Lays out the children.
      protected void loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      void removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void setParent(View parent)
      Sets the parent of the view.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • layoutSpan

        protected int layoutSpan
        Default constraint against which the flow is created against.

      • layoutPool

        protected View layoutPool
        These are the views that represent the child elements of the element this view represents (The logical view to translate to a physical view). These are not directly children of this view. These are either placed into the rows directly or used for the purpose of breaking into smaller chunks, to form the physical view.

      • strategy

        protected FlowView.FlowStrategy strategy
        The behavior for keeping the flow updated. By default this is a singleton shared by all instances of FlowView (FlowStrategy is stateless). Subclasses can create an alternative strategy, which might keep state.

    • 构造方法详细信息

      • FlowView

        public FlowView(Element elem,
        int axis)
        Constructs a FlowView for the given element.
        参数：
        elem - the element that this view is responsible for
        axis - may be either View.X_AXIS or View.Y_AXIS

    • 方法详细信息

      • getFlowAxis

        public int getFlowAxis()
        Fetches the axis along which views should be flowed. By default, this will be the axis orthogonal to the axis along which the flow rows are tiled (the axis of the default flow rows themselves). This is typically used by the FlowStrategy.

      • getFlowSpan

        public int getFlowSpan(int index)
        Fetch the constraining span to flow against for the given child index. This is called by the FlowStrategy while it is updating the flow. A flow can be shaped by providing different values for the row constraints. By default, the entire span inside of the insets along the flow axis is returned.
        参数：
        index - the index of the row being updated. This should be a value >= 0 and < getViewCount().
        另请参见：
        getFlowStart(int)

      • getFlowStart

        public int getFlowStart(int index)
        Fetch the location along the flow axis that the flow span will start at. This is called by the FlowStrategy while it is updating the flow. A flow can be shaped by providing different values for the row constraints.
        参数：
        index - the index of the row being updated. This should be a value >= 0 and < getViewCount().
        另请参见：
        getFlowSpan(int)

      • createRow

        protected abstract View createRow()
        Create a View that should be used to hold a a rows worth of children in a flow. This is called by the FlowStrategy when new children are added or removed (i.e. rows are added or removed) in the process of updating the flow.

      • loadChildren

        protected void loadChildren(ViewFactory f)
        Loads all of the children to initialize the view. This is called by the setParent method. This is reimplemented to not load any children directly (as they are created in the process of formatting). If the layoutPool variable is null, an instance of LogicalView is created to represent the logical view that is used in the process of formatting.
        重载：
        loadChildren in class CompositeView
        参数：
        f - the view factory
        另请参见：
        CompositeView.setParent(javax.swing.text.View)

      • getViewIndexAtPosition

        protected int getViewIndexAtPosition(int pos)
        Fetches the child view index representing the given position in the model.
        重载：
        getViewIndexAtPosition in class CompositeView
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position

      • layout

        protected void layout(int width,
          int height)
        Lays out the children. If the span along the flow axis has changed, layout is marked as invalid which which will cause the superclass behavior to recalculate the layout along the box axis. The FlowStrategy.layout method will be called to rebuild the flow rows as appropriate. If the height of this view changes (determined by the perferred size along the box axis), a preferenceChanged is called. Following all of that, the normal box layout of the superclass is performed.
        重载：
        layout in class BoxView
        参数：
        width - the width to lay out against >= 0. This is the width inside of the inset area.
        height - the height to lay out against >= 0 This is the height inside of the inset area.

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate equirements along the minor axis. This is implemented to forward the request to the logical view by calling getMinimumSpan, getPreferredSpan, and getMaximumSpan on it.
        重载：
        calculateMinorAxisRequirements in class BoxView
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • insertUpdate

        public void insertUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for.
        重载：
        insertUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for.
        重载：
        removeUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent changes,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • setParent

        public void setParent(View parent)
        Sets the parent of the view. This is reimplemented to provide the superclass behavior as well as calling the loadChildren method if this view does not already have children. The children should not be loaded in the constructor because the act of setting the parent may cause them to try to search up the hierarchy (to get the hosting Container for example). If this view has children (the view is being moved from one place in the view hierarchy to another), the loadChildren method will not be called.
        重载：
        setParent in class CompositeView
        参数：
        parent - the parent of the view, null if none
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FlowView.FlowStrategy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 FlowView.FlowStrategy

  • java.lang.Object
    • javax.swing.text.FlowView.FlowStrategy
  • 封闭类：
    FlowView

    public static class FlowView.FlowStrategy
extends Object
    Strategy for maintaining the physical form of the flow. The default implementation is completely stateless, and recalculates the entire flow if the layout is invalid on the given FlowView. Alternative strategies can be implemented by subclassing, and might perform incrementatal repair to the layout or alternative breaking behavior.
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      FlowView.FlowStrategy()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void adjustRow(FlowView fv, int rowIndex, int desiredSpan, int x)
      Adjusts the given row if possible to fit within the layout span.
      void changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected View createView(FlowView fv, int startOffset, int spanLeft, int rowIndex)
      Creates a view that can be used to represent the current piece of the flow.
      protected View getLogicalView(FlowView fv)
      This method gives flow strategies access to the logical view of the FlowView.
      void insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was inserted into the document in a location that the given flow view is responsible for.
      void layout(FlowView fv)
      Update the flow on the given FlowView.
      protected int layoutRow(FlowView fv, int rowIndex, int pos)
      Creates a row of views that will fit within the layout span of the row.
      void removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was removed from the document in a location that the given flow view is responsible for.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FlowView.FlowStrategy

        public FlowView.FlowStrategy()

    • 方法详细信息

      • insertUpdate

        public void insertUpdate(FlowView fv,
                DocumentEvent e,
                Rectangle alloc)
        Gives notification that something was inserted into the document in a location that the given flow view is responsible for. The strategy should update the appropriate changed region (which depends upon the strategy used for repair).
        参数：
        e - the change information from the associated document
        alloc - the current allocation of the view inside of the insets. This value will be null if the view has not yet been displayed.
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(FlowView fv,
                DocumentEvent e,
                Rectangle alloc)
        Gives notification that something was removed from the document in a location that the given flow view is responsible for.
        参数：
        e - the change information from the associated document
        alloc - the current allocation of the view inside of the insets.
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(FlowView fv,
                 DocumentEvent e,
                 Rectangle alloc)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        参数：
        fv - the FlowView containing the changes
        e - the DocumentEvent describing the changes done to the Document
        alloc - Bounds of the View
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • getLogicalView

        protected View getLogicalView(FlowView fv)
        This method gives flow strategies access to the logical view of the FlowView.

      • layout

        public void layout(FlowView fv)
        Update the flow on the given FlowView. By default, this causes all of the rows (child views) to be rebuilt to match the given constraints for each row. This is called by a FlowView.layout to update the child views in the flow.
        参数：
        fv - the view to reflow

      • layoutRow

        protected int layoutRow(FlowView fv,
            int rowIndex,
            int pos)
        Creates a row of views that will fit within the layout span of the row. This is called by the layout method. This is implemented to fill the row by repeatedly calling the createView method until the available span has been exhausted, a forced break was encountered, or the createView method returned null. If the remaining span was exhaused, the adjustRow method will be called to perform adjustments to the row to try and make it fit into the given span.
        参数：
        rowIndex - the index of the row to fill in with views. The row is assumed to be empty on entry.
        pos - The current position in the children of this views element from which to start.
        返回：
        the position to start the next row

      • adjustRow

        protected void adjustRow(FlowView fv,
             int rowIndex,
             int desiredSpan,
             int x)
        Adjusts the given row if possible to fit within the layout span. By default this will try to find the highest break weight possible nearest the end of the row. If a forced break is encountered, the break will be positioned there.
        参数：
        rowIndex - the row to adjust to the current layout span.
        desiredSpan - the current layout span >= 0
        x - the location r starts at.

      • createView

        protected View createView(FlowView fv,
              int startOffset,
              int spanLeft,
              int rowIndex)
        Creates a view that can be used to represent the current piece of the flow. This can be either an entire view from the logical view, or a fragment of the logical view.
        参数：
        fv - the view holding the flow
        startOffset - the start location for the view being created
        spanLeft - the about of span left to fill in the row
        rowIndex - the row the view will be placed into
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t<(nl > ><< >> dhhapr s"":d htenn d/usp<


GapContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 GapContent

  • java.lang.Object
    • javax.swing.text.GapContent
  • 所有已实现的接口：
    Serializable, AbstractDocument.Content

    public class GapContent
extends Object
implements AbstractDocument.Content, Serializable
    An implementation of the AbstractDocument.Content interface implemented using a gapped buffer similar to that used by emacs. The underlying storage is a array of unicode characters with a gap somewhere. The gap is moved to the location of changes to take advantage of common behavior where most changes are in the same location. Changes that occur at a gap boundary are generally cheap and moving the gap is generally cheaper than moving the array contents directly to accomodate the change.

    The positions tracking change are also generally cheap to maintain. The Position implementations (marks) store the array index and can easily calculate the sequential position from the current gap location. Changes only require update to the the marks between the old and new gap boundaries when the gap is moved, so generally updating the marks is pretty cheap. The marks are stored sorted so they can be located quickly with a binary search. This increases the cost of adding a mark, and decreases the cost of keeping the mark updated.

    • 构造方法摘要

      Constructors
      构造方法与描述
      GapContent()
      Creates a new GapContent object.
      GapContent(int initialLength)
      Creates a new GapContent object, with the initial size specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Object allocateArray(int len)
      Allocate an array to store items of the type appropriate (which is determined by the subclass).
      Position createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      protected Object getArray()
      Access to the array.
      protected int getArrayLength()
      Get the length of the allocated array.
      void getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      protected int getGapEnd()
      Access to the end of the gap.
      protected int getGapStart()
      Access to the start of the gap.
      protected Vector getPositionsInRange(Vector v, int offset, int length)
      Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.
      String getString(int where, int len)
      Retrieves a portion of the content.
      UndoableEdit insertString(int where, String str)
      Inserts a string into the content.
      int length()
      Returns the length of the content.
      UndoableEdit remove(int where, int nitems)
      Removes part of the content.
      protected void replace(int position, int rmSize, Object addItems, int addSize)
      Replace the given logical position in the storage with the given new items.
      protected void resetMarksAtZero()
      Resets all the marks that have an offset of 0 to have an index of zero as well.
      protected void shiftEnd(int newSize)
      Make the gap bigger, moving any necessary data and updating the appropriate marks
      protected void shiftGap(int newGapStart)
      Move the start of the gap to a new location, without changing the size of the gap.
      protected void shiftGapEndUp(int newGapEnd)
      Adjust the gap end upward.
      protected void shiftGapStartDown(int newGapStart)
      Adjust the gap end downward.
      protected void updateUndoPositions(Vector positions, int offset, int length)
      Resets the location for all the UndoPosRef instances in positions.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GapContent

        public GapContent()
        Creates a new GapContent object. Initial size defaults to 10.

      • GapContent

        public GapContent(int initialLength)
        Creates a new GapContent object, with the initial size specified. The initial size will not be allowed to go below 2, to give room for the implied break and the gap.
        参数：
        initialLength - the initial size

    • 方法详细信息

      • allocateArray

        protected Object allocateArray(int len)
        Allocate an array to store items of the type appropriate (which is determined by the subclass).

      • getArrayLength

        protected int getArrayLength()
        Get the length of the allocated array.

      • length

        public int length()
        Returns the length of the content.
        指定者：
        length in interface AbstractDocument.Content
        返回：
        the length >= 1
        另请参见：
        AbstractDocument.Content.length()

      • insertString

        public UndoableEdit insertString(int where,
                        String str)
                          throws BadLocationException
        Inserts a string into the content.
        指定者：
        insertString in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0, < length()
        str - the non-null string to insert
        返回：
        an UndoableEdit object for undoing
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.insertString(int, java.lang.String)

      • remove

        public UndoableEdit remove(int where,
                  int nitems)
                    throws BadLocationException
        Removes part of the content.
        指定者：
        remove in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0, where + nitems < length()
        nitems - the number of characters to remove >= 0
        返回：
        an UndoableEdit object for undoing
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.remove(int, int)

      • getString

        public String getString(int where,
               int len)
                 throws BadLocationException
        Retrieves a portion of the content.
        指定者：
        getString in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0
        len - the length to retrieve >= 0
        返回：
        a string representing the content
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.getString(int, int)

      • getChars

        public void getChars(int where,
            int len,
            Segment chars)
              throws BadLocationException
        Retrieves a portion of the content. If the desired content spans the gap, we copy the content. If the desired content does not span the gap, the actual store is returned to avoid the copy since it is contiguous.
        指定者：
        getChars in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0, where + len <= length()
        len - the number of characters to retrieve >= 0
        chars - the Segment object to return the characters in
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.getChars(int, int, javax.swing.text.Segment)

      • createPosition

        public Position createPosition(int offset)
                        throws BadLocationException
        Creates a position within the content that will track change as the content is mutated.
        指定者：
        createPosition in interface AbstractDocument.Content
        参数：
        offset - the offset to track >= 0
        返回：
        the position
        抛出：
        BadLocationException - if the specified position is invalid

      • shiftEnd

        protected void shiftEnd(int newSize)
        Make the gap bigger, moving any necessary data and updating the appropriate marks

      • shiftGap

        protected void shiftGap(int newGapStart)
        Move the start of the gap to a new location, without changing the size of the gap. This moves the data in the array and updates the marks accordingly.

      • resetMarksAtZero

        protected void resetMarksAtZero()
        Resets all the marks that have an offset of 0 to have an index of zero as well.

      • shiftGapStartDown

        protected void shiftGapStartDown(int newGapStart)
        Adjust the gap end downward. This doesn't move any data, but it does update any marks affected by the boundary change. All marks from the old gap start down to the new gap start are squeezed to the end of the gap (their location has been removed).

      • shiftGapEndUp

        protected void shiftGapEndUp(int newGapEnd)
        Adjust the gap end upward. This doesn't move any data, but it does update any marks affected by the boundary change. All marks from the old gap end up to the new gap end are squeezed to the end of the gap (their location has been removed).

      • getPositionsInRange

        protected Vector getPositionsInRange(Vector v,
                         int offset,
                         int length)
        Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length. If v is not null the matching Positions are placed in there. The vector with the resulting Positions are returned.
        参数：
        v - the Vector to use, with a new one created on null
        offset - the starting offset >= 0
        length - the length >= 0
        返回：
        the set of instances

      • updateUndoPositions

        protected void updateUndoPositions(Vector positions,
                       int offset,
                       int length)
        Resets the location for all the UndoPosRef instances in positions.

        This is meant for internal usage, and is generally not of interest to subclasses.

        参数：
        positions - the UndoPosRef instances to reset

      • getArray

        protected final Object getArray()
        Access to the array. The actual type of the array is known only by the subclass.

      • getGapStart

        protected final int getGapStart()
        Access to the start of the gap.

      • getGapEnd

        protected final int getGapEnd()
        Access to the end of the gap.

      • replace

        protected void replace(int position,
           int rmSize,
           Object addItems,
           int addSize)
        Replace the given logical position in the storage with the given new items. This will move the gap to the area being changed if the gap is not currently located at the change location.
        参数：
        position - the location to make the replacement. This is not the location in the underlying storage array, but the location in the contiguous space being modeled.
        rmSize - the number of items to remove
        addItems - the new items to place in storage.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Psoi"gi>gi(nni((idmmt<>t/gg t.i.thssw.tvx.t


GlyphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 GlyphView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.GlyphView
  • 所有已实现的接口：
    Cloneable, SwingConstants, TabableView
    直接已知子类：
    LabelView

    public class GlyphView
extends View
implements TabableView, Cloneable
    A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model. This view is generally responsible for displaying text glyphs using character level attributes in some way. An implementation of the GlyphPainter class is used to do the actual rendering and model/view translations. This separates rendering from layout and management of the association with the model.

    The view supports breaking for the purpose of formatting. The fragments produced by breaking share the view that has primary responsibility for the element (i.e. they are nested classes and carry only a small amount of state of their own) so they can share its resources.

    Since this view represents text that may have tabs embedded in it, it implements the TabableView interface. Tabs will only be expanded if this view is embedded in a container that does tab expansion. ParagraphView is an example of a container that does tab expansion.

    从以下版本开始：
    1.3

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  GlyphView.GlyphPainter
      A class to perform rendering of the glyphs.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      GlyphView(Element elem)
      Constructs a new view wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View breakView(int axis, int p0, float pos, float len)
      Breaks this view on the given axis at the given length.
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected void checkPainter()
      Check to see that a glyph painter exists.
      protected Object clone()
      Creates a shallow copy.
      View createFragment(int p0, int p1)
      Creates a view that represents a portion of the element.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      Color getBackground()
      Fetch the background color to use to render the glyphs.
      int getBreakWeight(int axis, float pos, float len)
      Determines how attractive a break opportunity in this view is.
      int getEndOffset()
      Fetches the portion of the model that this view is responsible for.
      Font getFont()
      Fetch the font that the glyphs should be based upon.
      Color getForeground()
      Fetch the foreground color to use to render the glyphs.
      GlyphView.GlyphPainter getGlyphPainter()
      Fetch the currently installed glyph painter.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      int getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      float getPartialSpan(int p0, int p1)
      Determines the span along the same axis as tab expansion for a portion of the view.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      int getStartOffset()
      Fetches the portion of the model that this view is responsible for.
      float getTabbedSpan(float x, TabExpander e)
      Determines the desired span when using the given tab expansion implementation.
      TabExpander getTabExpander()
      Fetch the TabExpander to use if tabs are present in this view.
      Segment getText(int p0, int p1)
      Fetch a reference to the text that occupies the given range.
      void insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      boolean isStrikeThrough()
      Determine if the glyphs should have a strikethrough line.
      boolean isSubscript()
      Determine if the glyphs should be rendered as superscript.
      boolean isSuperscript()
      Determine if the glyphs should be rendered as subscript.
      boolean isUnderline()
      Determine if the glyphs should be underlined.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape a)
      Renders a portion of a text style run.
      void removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void setGlyphPainter(GlyphView.GlyphPainter p)
      Sets the painter to use for rendering glyphs.
      int viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, forwardUpdate, forwardUpdateToView, getAttributes, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GlyphView

        public GlyphView(Element elem)
        Constructs a new view wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • clone

        protected final Object clone()
        Creates a shallow copy. This is used by the createFragment and breakView methods.
        重载：
        clone in class Object
        返回：
        the copy
        另请参见：
        Cloneable

      • getGlyphPainter

        public GlyphView.GlyphPainter getGlyphPainter()
        Fetch the currently installed glyph painter. If a painter has not yet been installed, and a default was not yet needed, null is returned.

      • setGlyphPainter

        public void setGlyphPainter(GlyphView.GlyphPainter p)
        Sets the painter to use for rendering glyphs.

      • getText

        public Segment getText(int p0,
              int p1)
        Fetch a reference to the text that occupies the given range. This is normally used by the GlyphPainter to determine what characters it should render glyphs for.
        参数：
        p0 - the starting document offset >= 0
        p1 - the ending document offset >= p0
        返回：
        the Segment containing the text

      • getBackground

        public Color getBackground()
        Fetch the background color to use to render the glyphs. If there is no background color, null should be returned. This is implemented to call StyledDocument.getBackground if the associated document is a styled document, otherwise it returns null.

      • getForeground

        public Color getForeground()
        Fetch the foreground color to use to render the glyphs. If there is no foreground color, null should be returned. This is implemented to call StyledDocument.getBackground if the associated document is a StyledDocument. If the associated document is not a StyledDocument, the associated components foreground color is used. If there is no associated component, null is returned.

      • getFont

        public Font getFont()
        Fetch the font that the glyphs should be based upon. This is implemented to call StyledDocument.getFont if the associated document is a StyledDocument. If the associated document is not a StyledDocument, the associated components font is used. If there is no associated component, null is returned.

      • isUnderline

        public boolean isUnderline()
        Determine if the glyphs should be underlined. If true, an underline should be drawn through the baseline.

      • isStrikeThrough

        public boolean isStrikeThrough()
        Determine if the glyphs should have a strikethrough line. If true, a line should be drawn through the center of the glyphs.

      • isSubscript

        public boolean isSubscript()
        Determine if the glyphs should be rendered as superscript.

      • isSuperscript

        public boolean isSuperscript()
        Determine if the glyphs should be rendered as subscript.

      • getTabExpander

        public TabExpander getTabExpander()
        Fetch the TabExpander to use if tabs are present in this view.

      • checkPainter

        protected void checkPainter()
        Check to see that a glyph painter exists. If a painter doesn't exist, a default glyph painter will be installed.

      • getTabbedSpan

        public float getTabbedSpan(float x,
                  TabExpander e)
        Determines the desired span when using the given tab expansion implementation.
        指定者：
        getTabbedSpan in interface TabableView
        参数：
        x - the position the view would be located at for the purpose of tab expansion >= 0.
        e - how to expand the tabs when encountered.
        返回：
        the desired span >= 0
        另请参见：
        TabableView.getTabbedSpan(float, javax.swing.text.TabExpander)

      • getPartialSpan

        public float getPartialSpan(int p0,
                   int p1)
        Determines the span along the same axis as tab expansion for a portion of the view. This is intended for use by the TabExpander for cases where the tab expansion involves aligning the portion of text that doesn't have whitespace relative to the tab stop. There is therefore an assumption that the range given does not contain tabs.

        This method can be called while servicing the getTabbedSpan or getPreferredSize. It has to arrange for its own text buffer to make the measurements.

        指定者：
        getPartialSpan in interface TabableView
        参数：
        p0 - the starting document offset >= 0
        p1 - the ending document offset >= p0
        返回：
        the span >= 0

      • getStartOffset

        public int getStartOffset()
        Fetches the portion of the model that this view is responsible for.
        重载：
        getStartOffset in class View
        返回：
        the starting offset into the model
        另请参见：
        View.getStartOffset()

      • getEndOffset

        public int getEndOffset()
        Fetches the portion of the model that this view is responsible for.
        重载：
        getEndOffset in class View
        返回：
        the ending offset into the model
        另请参见：
        View.getEndOffset()

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders a portion of a text style run.
        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        a - the allocated region to render into

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis.

        This implementation returns the longest non-breakable area within the view as a minimum span for View.X_AXIS.

        重载：
        getMinimumSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the minimum span the view can be rendered into
        抛出：
        IllegalArgumentException - if the axis parameter is invalid
        另请参见：
        View.getMinimumSpan(int)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getPreferredSpan(int)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. For the label, the alignment is along the font baseline for the y axis, and the superclasses alignment along the x axis.
        重载：
        getAlignment in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the desired alignment. This should be a value between 0.0 and 1.0 inclusive, where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin. An alignment of 0.5 would be the center of the view.

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] biasReturn)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region to render into
        biasReturn - either Position.Bias.Forward or Position.Bias.Backward is returned as the zero-th element of this array
        返回：
        the location within the model that best represents the given point of view >= 0
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • getBreakWeight

        public int getBreakWeight(int axis,
                 float pos,
                 float len)
        Determines how attractive a break opportunity in this view is. This can be used for determining which view is the most attractive to call breakView on in the process of formatting. The higher the weight, the more attractive the break. A value equal to or lower than View.BadBreakWeight should not be considered for a break. A value greater than or equal to View.ForcedBreakWeight should be broken.

        This is implemented to forward to the superclass for the Y_AXIS. Along the X_AXIS the following values may be returned.

        View.ExcellentBreakWeight
        if there is whitespace proceeding the desired break location.
        View.BadBreakWeight
        if the desired break location results in a break location of the starting offset.
        View.GoodBreakWeight
        if the other conditions don't occur.
        This will normally result in the behavior of breaking on a whitespace location if one can be found, otherwise breaking between characters.
        重载：
        getBreakWeight in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        pos - the potential location of the start of the broken view >= 0. This may be useful for calculating tab positions.
        len - specifies the relative length from pos where a potential break is desired >= 0.
        返回：
        the weight, which should be a value between View.ForcedBreakWeight and View.BadBreakWeight.
        另请参见：
        LabelView, ParagraphView, View.BadBreakWeight, View.GoodBreakWeight, View.ExcellentBreakWeight, View.ForcedBreakWeight

      • breakView

        public View breakView(int axis,
             int p0,
             float pos,
             float len)
        Breaks this view on the given axis at the given length. This is implemented to attempt to break on a whitespace location, and returns a fragment with the whitespace at the end. If a whitespace location can't be found, the nearest character is used.
        重载：
        breakView in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        p0 - the location in the model where the fragment should start it's representation >= 0.
        pos - the position along the axis that the broken view would occupy >= 0. This may be useful for things like tab calculations.
        len - specifies the distance along the axis where a potential break is desired >= 0.
        返回：
        the fragment of the view that represents the given span, if the view can be broken. If the view doesn't support breaking behavior, the view itself is returned.
        另请参见：
        View.breakView(int, int, float, float)

      • createFragment

        public View createFragment(int p0,
                  int p1)
        Creates a view that represents a portion of the element. This is potentially useful during formatting operations for taking measurements of fragments of the view. If the view doesn't support fragmenting (the default), it should return itself.

        This view does support fragmenting. It is implemented to return a nested class that shares state in this view representing only a portion of the view.

        重载：
        createFragment in class View
        参数：
        p0 - the starting offset >= 0. This should be a value greater or equal to the element starting offset and less than the element ending offset.
        p1 - the ending offset > p0. This should be a value less than or equal to the elements end offset and greater than the elements starting offset.
        返回：
        the view fragment, or itself if the view doesn't support breaking into fragments
        另请参见：
        LabelView

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(int pos,
                            Position.Bias b,
                            Shape a,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        重载：
        getNextVisualPositionFrom in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This may be SwingConstants.WEST, SwingConstants.EAST, SwingConstants.NORTH, or SwingConstants.SOUTH.
        返回：
        the location within the model that best represents the next location visual position.
        抛出：
        BadLocationException
        IllegalArgumentException - for an invalid direction

      • insertUpdate

        public void insertUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. This is implemented to call preferenceChanged along the axis the glyphs are rendered.
        重载：
        insertUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. This is implemented to call preferenceChanged along the axis the glyphs are rendered.
        重载：
        removeUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for. This is implemented to call preferenceChanged along both the horizontal and vertical axis.
        重载：
        changedUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GlyphView.GlyphPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 GlyphView.GlyphPainter

  • java.lang.Object
    • javax.swing.text.GlyphView.GlyphPainter
  • 封闭类：
    GlyphView

    public abstract static class GlyphView.GlyphPainter
extends Object
    A class to perform rendering of the glyphs. This can be implemented to be stateless, or to hold some information as a cache to facilitate faster rendering and model/view translation. At a minimum, the GlyphPainter allows a View implementation to perform its duties independant of a particular version of JVM and selection of capabilities (i.e. shaping for i18n, etc).
    从以下版本开始：
    1.3

    • 构造方法摘要

      Constructors
      构造方法与描述
      GlyphView.GlyphPainter()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      abstract float | getAscent(GlyphView v)
      abstract int getBoundedPosition(GlyphView v, int p0, float x, float len)
      Determines the model location that represents the maximum advance that fits within the given span.
      abstract float | getDescent(GlyphView v)
      abstract float | getHeight(GlyphView v)
      int getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      GlyphView.GlyphPainter getPainter(GlyphView v, int p0, int p1)
      Create a painter to use for the given GlyphView.
      abstract float getSpan(GlyphView v, int p0, int p1, TabExpander e, float x)
      Determine the span the glyphs given a start location (for tab expansion).
      abstract Shape modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      abstract void paint(GlyphView v, Graphics g, Shape a, int p0, int p1)
      Paint the glyphs representing the given range.
      abstract int viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GlyphView.GlyphPainter

        public GlyphView.GlyphPainter()

    • 方法详细信息

      • getSpan

        public abstract float getSpan(GlyphView v,
            int p0,
            int p1,
            TabExpander e,
            float x)
        Determine the span the glyphs given a start location (for tab expansion).

      • getHeight

        public abstract float getHeight(GlyphView v)

      • getAscent

        public abstract float getAscent(GlyphView v)

      • getDescent

        public abstract float getDescent(GlyphView v)

      • paint

        public abstract void paint(GlyphView v,
         Graphics g,
         Shape a,
         int p0,
         int p1)
        Paint the glyphs representing the given range.

      • modelToView

        public abstract Shape modelToView(GlyphView v,
                int pos,
                Position.Bias bias,
                Shape a)
                           throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it. This is shared by the broken views.
        参数：
        v - the GlyphView containing the destination coordinate space
        pos - the position to convert
        bias - either Position.Bias.Forward or Position.Bias.Backward
        a - Bounds of the View
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public abstract int viewToModel(GlyphView v,
              float x,
              float y,
              Shape a,
              Position.Bias[] biasReturn)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        参数：
        v - the GlyphView to provide a mapping for
        x - the X coordinate
        y - the Y coordinate
        a - the allocated region to render into
        biasReturn - either Position.Bias.Forward or Position.Bias.Backward is returned as the zero-th element of this array
        返回：
        the location within the model that best represents the given point of view
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • getBoundedPosition

        public abstract int getBoundedPosition(GlyphView v,
                     int p0,
                     float x,
                     float len)
        Determines the model location that represents the maximum advance that fits within the given span. This could be used to break the given view. The result should be a location just shy of the given advance. This differs from viewToModel which returns the closest position which might be proud of the maximum advance.
        参数：
        v - the view to find the model location to break at.
        p0 - the location in the model where the fragment should start it's representation >= 0.
        x - the graphic location along the axis that the broken view would occupy >= 0. This may be useful for things like tab calculations.
        len - specifies the distance into the view where a potential break is desired >= 0.
        返回：
        the maximum model location possible for a break.
        另请参见：
        View.breakView(int, int, float, float)

      • getPainter

        public GlyphView.GlyphPainter getPainter(GlyphView v,
                                int p0,
                                int p1)
        Create a painter to use for the given GlyphView. If the painter carries state it can create another painter to represent a new GlyphView that is being created. If the painter doesn't hold any significant state, it can return itself. The default behavior is to return itself.
        参数：
        v - the GlyphView to provide a painter for
        p0 - the starting document offset >= 0
        p1 - the ending document offset >= p0

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(GlyphView v,
                            int pos,
                            Position.Bias b,
                            Shape a,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location that one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        参数：
        v - the view to use
        pos - the position to convert >= 0
        b - either Position.Bias.Forward or Position.Bias.Backward
        a - the allocated region to render into
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This may be SwingConstants.WEST, SwingConstants.EAST, SwingConstants.NORTH, or SwingConstants.SOUTH.
        biasRet - either Position.Bias.Forward or Position.Bias.Backward is returned as the zero-th element of this array
        返回：
        the location within the model that best represents the next location visual position.
        抛出：
        BadLocationException
        IllegalArgumentException - for an invalid direction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a.e;an


Highlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Highlighter

  • All Known Implementing Classes:
    BasicTextUI.BasicHighlighter, DefaultHighlighter, LayeredHighlighter

    public interface Highlighter
    An interface for an object that allows one to mark up the background with colored areas.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | Interface and Description
      static interface  | Highlighter.Highlight
      static interface  Highlighter.HighlightPainter
      Highlight renderer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
      void changeHighlight(Object tag, int p0, int p1)
      Changes the given highlight to span a different portion of the document.
      void deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      Highlighter.Highlight[] getHighlights()
      Fetches the current list of highlights.
      void install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void paint(Graphics g)
      Renders the highlights.
      void removeAllHighlights()
      Removes all highlights this highlighter is responsible for.
      void removeHighlight(Object tag)
      Removes a highlight from the view.

    • 方法详细信息

      • install

        void install(JTextComponent c)
        Called when the UI is being installed into the interface of a JTextComponent. This can be used to gain access to the model that is being navigated by the implementation of this interface.
        参数：
        c - the JTextComponent editor

      • deinstall

        void deinstall(JTextComponent c)
        Called when the UI is being removed from the interface of a JTextComponent. This is used to unregister any listeners that were attached.
        参数：
        c - the JTextComponent editor

      • paint

        void paint(Graphics g)
        Renders the highlights.
        参数：
        g - the graphics context.

      • addHighlight

        Object addHighlight(int p0,
                  int p1,
                  Highlighter.HighlightPainter p)
                    throws BadLocationException
        Adds a highlight to the view. Returns a tag that can be used to refer to the highlight.
        参数：
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0
        p - the painter to use for the actual highlighting
        返回：
        an object that refers to the highlight
        抛出：
        BadLocationException - for an invalid range specification

      • removeHighlight

        void removeHighlight(Object tag)
        Removes a highlight from the view.
        参数：
        tag - which highlight to remove

      • removeAllHighlights

        void removeAllHighlights()
        Removes all highlights this highlighter is responsible for.

      • changeHighlight

        void changeHighlight(Object tag,
                   int p0,
                   int p1)
                     throws BadLocationException
        Changes the given highlight to span a different portion of the document. This may be more efficient than a remove/add when a selection is expanding/shrinking (such as a sweep with a mouse) by damaging only what changed.
        参数：
        tag - which highlight to change
        p0 - the beginning of the range >= 0
        p1 - the end of the range >= p0
        抛出：
        BadLocationException - for an invalid range specification

      • getHighlights

        Highlighter.Highlight[] getHighlights()
        Fetches the current list of highlights.
        返回：
        the highlight list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w<>e/tpa=l>p"cgaag>


Highlighter.Highlight

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Highlighter.Highlight

  • Enclosing interface:
    Highlighter

    public static interface Highlighter.Highlight

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getEndOffset()
      Gets the ending model offset for the highlight.
      Highlighter.HighlightPainter getPainter()
      Gets the painter for the highlighter.
      int getStartOffset()
      Gets the starting model offset for the highlight.

    • 方法详细信息

      • getStartOffset

        int getStartOffset()
        Gets the starting model offset for the highlight.
        返回：
        the starting offset >= 0

      • getEndOffset

        int getEndOffset()
        Gets the ending model offset for the highlight.
        返回：
        the ending offset >= 0

      • getPainter

        Highlighter.HighlightPainter getPainter()
        Gets the painter for the highlighter.
        返回：
        the painter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C=owaa.va./...//.aOO<jg/..


Highlighter.HighlightPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Highlighter.HighlightPainter

  • All Known Implementing Classes:
    DefaultHighlighter.DefaultHighlightPainter, LayeredHighlighter.LayerPainter
    Enclosing interface:
    Highlighter

    public static interface Highlighter.HighlightPainter
    Highlight renderer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c)
      Renders the highlight.

    • 方法详细信息

      • paint

        void paint(Graphics g,
         int p0,
         int p1,
         Shape bounds,
         JTextComponent c)
        Renders the highlight.
        参数：
        g - the graphics context
        p0 - the starting offset in the model >= 0
        p1 - the ending offset in the model >= p0
        bounds - the bounding box for the highlight
        c - the editor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etb/�/�/>/<>r瞓/t>tng舶;>>sl


IconView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 IconView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.IconView
  • 所有已实现的接口：
    SwingConstants

    public class IconView
extends View
    Icon decorator that implements the view interface. The entire element is used to represent the icon. This acts as a gateway from the display-only View implementations to interactive lightweight icons (that is, it allows icons to be embedded into the View hierarchy. The parent of the icon is the container that is handed out by the associated view factory.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      IconView(Element elem)
      Creates a new icon view that represents an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape a)
      Paints the icon.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setParent, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IconView

        public IconView(Element elem)
        Creates a new icon view that represents an element.
        参数：
        elem - the element to create a view for

    • 方法详细信息

      • paint

        public void paint(Graphics g,
         Shape a)
        Paints the icon. The real paint behavior occurs naturally from the association that the icon has with its parent container (the same container hosting this view), so this simply allows us to position the icon properly relative to the view. Since the coordinate system for the view is simply the parent containers, positioning the child icon is easy.
        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the alignment to the bottom of the icon along the y axis, and the default along the x axis.
        重载：
        getAlignment in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the desired alignment >= 0.0f && <= 1.0f. This should be a value between 0.0 and 1.0 where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin. An alignment of 0.5 would be the center of the view.

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point of view >= 0
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

// e>e>eaen&n<餬鋏&"abn>;;=yma si


InternationalFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 InternationalFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
      • javax.swing.text.DefaultFormatter
        • javax.swing.text.InternationalFormatter
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    DateFormatter, NumberFormatter

    public class InternationalFormatter
extends DefaultFormatter
    InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.

    If getAllowsInvalid() is false, this will ask the Format to format the current text on every edit.

    You can specify a minimum and maximum value by way of the setMinimum and setMaximum methods. In order for this to work the values returned from stringToValue must be comparable to the min/max values by way of the Comparable interface.

    Be careful how you configure the Format and the InternationalFormatter, as it is possible to create a situation where certain values can not be input. Consider the date format 'M/d/yy', an InternationalFormatter that is always valid (setAllowsInvalid(false)), is in overwrite mode (setOverwriteMode(true)) and the date 7/1/99. In this case the user will not be able to enter a two digit month or day of month. To avoid this, the format should be 'MM/dd/yy'.

    If InternationalFormatter is configured to only allow valid values (setAllowsInvalid(false)), every valid edit will result in the text of the JFormattedTextField being completely reset from the Format. The cursor position will also be adjusted as literal characters are added/removed from the resulting String.

    InternationalFormatter's behavior of stringToValue is slightly different than that of DefaultTextFormatter, it does the following:

    1. parseObject is invoked on the Format specified by setFormat
    2. If a Class has been set for the values (setValueClass), supers implementation is invoked to convert the value returned from parseObject to the appropriate class.
    3. If a ParseException has not been thrown, and the value is outside the min/max a ParseException is thrown.
    4. The value is returned.
    InternationalFormatter implements stringToValue in this manner so that you can specify an alternate Class than Format may return.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4
    另请参见：
    Format, Comparable

    • 构造方法摘要

      Constructors
      构造方法与描述
      InternationalFormatter()
      Creates an InternationalFormatter with no Format specified.
      InternationalFormatter(Format format)
      Creates an InternationalFormatter with the specified Format instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a copy of the DefaultFormatter.
      protected Action[] getActions()
      If getSupportsIncrement returns true, this returns two Actions suitable for incrementing/decrementing the value.
      Format.Field[] getFields(int offset)
      Returns the Format.Field constants associated with the text at offset.
      Format getFormat()
      Returns the format that dictates the legal values that can be edited and displayed.
      Comparable getMaximum()
      Returns the maximum permissible value.
      Comparable getMinimum()
      Returns the minimum permissible value.
      void install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
      void setFormat(Format format)
      Sets the format that dictates the legal values that can be edited and displayed.
      void setMaximum(Comparable max)
      Sets the maximum permissible value.
      void setMinimum(Comparable minimum)
      Sets the minimum permissible value.
      Object stringToValue(String text)
      Returns the Object representation of the String text.
      String valueToString(Object value)
      Returns a String representation of the Object value.

      • 方法 - 继承于类 javax.swing.text.DefaultFormatter

        getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass

      • 方法 - 继承于类 javax.swing.JFormattedTextField.AbstractFormatter

        getFormattedTextField, invalidEdit, setEditValid, uninstall

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InternationalFormatter

        public InternationalFormatter()
        Creates an InternationalFormatter with no Format specified.

      • InternationalFormatter

        public InternationalFormatter(Format format)
        Creates an InternationalFormatter with the specified Format instance.
        参数：
        format - Format instance used for converting from/to Strings

    • 方法详细信息

      • setFormat

        public void setFormat(Format format)
        Sets the format that dictates the legal values that can be edited and displayed.
        参数：
        format - Format instance used for converting from/to Strings

      • getFormat

        public Format getFormat()
        Returns the format that dictates the legal values that can be edited and displayed.
        返回：
        Format instance used for converting from/to Strings

      • setMinimum

        public void setMinimum(Comparable minimum)
        Sets the minimum permissible value. If the valueClass has not been specified, and minimum is non null, the valueClass will be set to that of the class of minimum.
        参数：
        minimum - Minimum legal value that can be input
        另请参见：
        DefaultFormatter.setValueClass(java.lang.Class)

      • getMinimum

        public Comparable getMinimum()
        Returns the minimum permissible value.
        返回：
        Minimum legal value that can be input

      • setMaximum

        public void setMaximum(Comparable max)
        Sets the maximum permissible value. If the valueClass has not been specified, and max is non null, the valueClass will be set to that of the class of max.
        参数：
        max - Maximum legal value that can be input
        另请参见：
        DefaultFormatter.setValueClass(java.lang.Class)

      • getMaximum

        public Comparable getMaximum()
        Returns the maximum permissible value.
        返回：
        Maximum legal value that can be input

      • install

        public void install(JFormattedTextField ftf)
        Installs the DefaultFormatter onto a particular JFormattedTextField. This will invoke valueToString to convert the current value from the JFormattedTextField to a String. This will then install the Actions from getActions, the DocumentFilter returned from getDocumentFilter and the NavigationFilter returned from getNavigationFilter onto the JFormattedTextField.

        Subclasses will typically only need to override this if they wish to install additional listeners on the JFormattedTextField.

        If there is a ParseException in converting the current value to a String, this will set the text to an empty String, and mark the JFormattedTextField as being in an invalid state.

        While this is a public method, this is typically only useful for subclassers of JFormattedTextField. JFormattedTextField will invoke this method at the appropriate times when the value changes, or its internal state changes.

        重载：
        install in class DefaultFormatter
        参数：
        ftf - JFormattedTextField to format for, may be null indicating uninstall from current JFormattedTextField.

      • valueToString

        public String valueToString(Object value)
                     throws ParseException
        Returns a String representation of the Object value. This invokes format on the current Format.
        重载：
        valueToString in class DefaultFormatter
        参数：
        value - Value to convert
        返回：
        String representation of value
        抛出：
        ParseException - if there is an error in the conversion

      • stringToValue

        public Object stringToValue(String text)
                     throws ParseException
        Returns the Object representation of the String text.
        重载：
        stringToValue in class DefaultFormatter
        参数：
        text - String to convert
        返回：
        Object representation of text
        抛出：
        ParseException - if there is an error in the conversion

      • getFields

        public Format.Field[] getFields(int offset)
        Returns the Format.Field constants associated with the text at offset. If offset is not a valid location into the current text, this will return an empty array.
        参数：
        offset - offset into text to be examined
        返回：
        Format.Field constants associated with the text at the given position.

      • clone

        public Object clone()
             throws CloneNotSupportedException
        Creates a copy of the DefaultFormatter.
        重载：
        clone in class DefaultFormatter
        返回：
        copy of the DefaultFormatter
        抛出：
        CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
        另请参见：
        Cloneable

      • getActions

        protected Action[] getActions()
        If getSupportsIncrement returns true, this returns two Actions suitable for incrementing/decrementing the value.
        重载：
        getActions in class JFormattedTextField.AbstractFormatter
        返回：
        Array of Actions to install on JFormattedTextField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h


javax.swing.text

Interfaces

  • AbstractDocument.AttributeContext
  • AbstractDocument.Content
  • AttributeSet
  • AttributeSet.CharacterAttribute
  • AttributeSet.ColorAttribute
  • AttributeSet.FontAttribute
  • AttributeSet.ParagraphAttribute
  • Caret
  • Document
  • Element
  • Highlighter
  • Highlighter.Highlight
  • Highlighter.HighlightPainter
  • Keymap
  • MutableAttributeSet
  • Position
  • Style
  • StyledDocument
  • TabableView
  • TabExpander
  • ViewFactory

Classes

  • AbstractDocument
  • AbstractDocument.ElementEdit
  • AbstractWriter
  • AsyncBoxView
  • BoxView
  • ComponentView
  • CompositeView
  • DateFormatter
  • DefaultCaret
  • DefaultEditorKit
  • DefaultEditorKit.BeepAction
  • DefaultEditorKit.CopyAction
  • DefaultEditorKit.CutAction
  • DefaultEditorKit.DefaultKeyTypedAction
  • DefaultEditorKit.InsertBreakAction
  • DefaultEditorKit.InsertContentAction
  • DefaultEditorKit.InsertTabAction
  • DefaultEditorKit.PasteAction
  • DefaultFormatter
  • DefaultFormatterFactory
  • DefaultHighlighter
  • DefaultHighlighter.DefaultHighlightPainter
  • DefaultStyledDocument
  • DefaultStyledDocument.AttributeUndoableEdit
  • DefaultStyledDocument.ElementSpec
  • DefaultTextUI
  • DocumentFilter
  • DocumentFilter.FilterBypass
  • EditorKit
  • ElementIterator
  • FieldView
  • FlowView
  • FlowView.FlowStrategy
  • GapContent
  • GlyphView
  • GlyphView.GlyphPainter
  • IconView
  • InternationalFormatter
  • JTextComponent
  • JTextComponent.DropLocation
  • JTextComponent.KeyBinding
  • LabelView
  • LayeredHighlighter
  • LayeredHighlighter.LayerPainter
  • LayoutQueue
  • MaskFormatter
  • NavigationFilter
  • NavigationFilter.FilterBypass
  • NumberFormatter
  • ParagraphView
  • PasswordView
  • PlainDocument
  • PlainView
  • Position.Bias
  • Segment
  • SimpleAttributeSet
  • StringContent
  • StyleConstants
  • StyleConstants.CharacterConstants
  • StyleConstants.ColorConstants
  • StyleConstants.FontConstants
  • StyleConstants.ParagraphConstants
  • StyleContext
  • StyledEditorKit
  • StyledEditorKit.AlignmentAction
  • StyledEditorKit.BoldAction
  • StyledEditorKit.FontFamilyAction
  • StyledEditorKit.FontSizeAction
  • StyledEditorKit.ForegroundAction
  • StyledEditorKit.ItalicAction
  • StyledEditorKit.StyledTextAction
  • StyledEditorKit.UnderlineAction
  • TableView
  • TabSet
  • TabStop
  • TextAction
  • Utilities
  • View
  • WrappedPlainView
  • ZoneView

Exceptions

  • BadLocationException
  • ChangedCharSetException
a


javax.swing.text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.text

Provides classes and interfaces that deal with editable and noneditable text components.

请参见： 描述

  • 接口摘要
    接口 描述
    AbstractDocument.AttributeContext
    An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
    AbstractDocument.Content
    Interface to describe a sequence of character content that can be edited.
    AttributeSet
    A collection of unique attributes.
    AttributeSet.CharacterAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation.
    AttributeSet.ColorAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
    AttributeSet.FontAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text.
    AttributeSet.ParagraphAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.
    Caret
    A place within a document view that represents where things can be inserted into the document model.
    Document
    The Document is a container for text that serves as the model for swing text components.
    Element
    Interface to describe a structural piece of a document.
    Highlighter
    An interface for an object that allows one to mark up the background with colored areas.
    Highlighter.Highlight
    Highlighter.HighlightPainter
    Highlight renderer.
    Keymap
    A collection of bindings of KeyStrokes to actions.
    MutableAttributeSet
    A generic interface for a mutable collection of unique attributes.
    Position
    Represents a location within a document.
    Style
    A collection of attributes to associate with an element in a document.
    StyledDocument
    Interface for a generic styled document.
    TabableView
    Interface for Views that have size dependent upon tabs.
    TabExpander
    Simple interface to allow for different types of implementations of tab expansion.
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Class Summary
    类 | 描述
    AbstractDocument
    An implementation of the document interface to serve as a basis for implementing various kinds of documents.
    AbstractDocument.ElementEdit
    An implementation of ElementChange that can be added to the document event.
    AbstractWriter
    AbstractWriter is an abstract class that actually does the work of writing out the element tree including the attributes.
    AsyncBoxView
    A box that does layout asynchronously.
    BoxView
    A view that arranges its children into a box shape by tiling its children along an axis.
    ComponentView
    Component decorator that implements the view interface.
    CompositeView
    CompositeView is an abstract View implementation which manages one or more child views.
    DateFormatter
    DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
    DefaultCaret
    A default implementation of Caret.
    DefaultEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    DefaultEditorKit.BeepAction
    Creates a beep.
    DefaultEditorKit.CopyAction
    Copies the selected region and place its contents into the system clipboard.
    DefaultEditorKit.CutAction
    Cuts the selected region and place its contents into the system clipboard.
    DefaultEditorKit.DefaultKeyTypedAction
    The action that is executed by default if a key typed event is received and there is no keymap entry.
    DefaultEditorKit.InsertBreakAction
    Places a line/paragraph break into the document.
    DefaultEditorKit.InsertContentAction
    Places content into the associated document.
    DefaultEditorKit.InsertTabAction
    Places a tab character into the document.
    DefaultEditorKit.PasteAction
    Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
    DefaultFormatter
    DefaultFormatter formats aribtrary objects.
    DefaultFormatterFactory
    An implementation of JFormattedTextField.AbstractFormatterFactory.
    DefaultHighlighter
    Implements the Highlighter interfaces.
    DefaultHighlighter.DefaultHighlightPainter
    Simple highlight painter that fills a highlighted area with a solid color.
    DefaultStyledDocument
    A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
    DefaultStyledDocument.AttributeUndoableEdit
    An UndoableEdit used to remember AttributeSet changes to an Element.
    DefaultStyledDocument.ElementSpec
    Specification for building elements.
    DefaultTextUI | Deprecated
    DocumentFilter
    DocumentFilter, as the name implies, is a filter for the Document mutation methods.
    DocumentFilter.FilterBypass
    Used as a way to circumvent calling back into the Document to change it.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    ElementIterator
    ElementIterator, as the name suggests, iteratates over the Element tree.
    FieldView
    Extends the multi-line plain text view to be suitable for a single-line editor view.
    FlowView
    A View that tries to flow it's children into some partially constrained space.
    FlowView.FlowStrategy
    Strategy for maintaining the physical form of the flow.
    GapContent
    An implementation of the AbstractDocument.Content interface implemented using a gapped buffer similar to that used by emacs.
    GlyphView
    A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
    GlyphView.GlyphPainter
    A class to perform rendering of the glyphs.
    IconView
    Icon decorator that implements the view interface.
    InternationalFormatter
    InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
    JTextComponent
    JTextComponent is the base class for swing text components.
    JTextComponent.DropLocation
    Represents a drop location for JTextComponents.
    JTextComponent.KeyBinding
    Binding record for creating key bindings.
    LabelView
    A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
    LayeredHighlighter
    LayeredHighlighter.LayerPainter
    Layered highlight renderer.
    LayoutQueue
    A queue of text layout tasks.
    MaskFormatter
    MaskFormatter is used to format and edit strings.
    NavigationFilter
    NavigationFilter can be used to restrict where the cursor can be positioned.
    NavigationFilter.FilterBypass
    Used as a way to circumvent calling back into the caret to position the cursor.
    NumberFormatter
    NumberFormatter subclasses InternationalFormatter adding special behavior for numbers.
    ParagraphView
    View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
    PasswordView
    Implements a View suitable for use in JPasswordField UI implementations.
    PlainDocument
    A plain document that maintains no character attributes.
    PlainView
    Implements View interface for a simple multi-line text view that has text in one font and color.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    Segment
    A segment of a character array representing a fragment of text.
    SimpleAttributeSet
    A straightforward implementation of MutableAttributeSet using a hash table.
    StringContent
    An implementation of the AbstractDocument.Content interface that is a brute force implementation that is useful for relatively small documents and/or debugging.
    StyleConstants
    A collection of well known or common attribute keys and methods to apply to an AttributeSet or MutableAttributeSet to get/set the properties in a typesafe manner.
    StyleConstants.CharacterConstants
    This is a typesafe enumeration of the well-known attributes that contribute to a character style.
    StyleConstants.ColorConstants
    This is a typesafe enumeration of the well-known attributes that contribute to a color.
    StyleConstants.FontConstants
    This is a typesafe enumeration of the well-known attributes that contribute to a font.
    StyleConstants.ParagraphConstants
    This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style.
    StyleContext
    A pool of styles and their associated resources.
    StyledEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    StyledEditorKit.AlignmentAction
    An action to set paragraph alignment.
    StyledEditorKit.BoldAction
    An action to toggle the bold attribute.
    StyledEditorKit.FontFamilyAction
    An action to set the font family in the associated JEditorPane.
    StyledEditorKit.FontSizeAction
    An action to set the font size in the associated JEditorPane.
    StyledEditorKit.ForegroundAction
    An action to set foreground color.
    StyledEditorKit.ItalicAction
    An action to toggle the italic attribute.
    StyledEditorKit.StyledTextAction
    An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
    StyledEditorKit.UnderlineAction
    An action to toggle the underline attribute.
    TableView
    Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
    TabSet
    A TabSet is comprised of many TabStops.
    TabStop
    This class encapsulates a single tab stop (basically as tab stops are thought of by RTF).
    TextAction
    An Action implementation useful for key bindings that are shared across a number of different text components.
    Utilities
    A collection of methods to deal with various text related activities.
    View
    A very important part of the text package is the View class.
    WrappedPlainView
    View of plain text (text with only one font and color) that does line-wrapping.
    ZoneView
    ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.
  • Exception Summary
    Exception 描述
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    ChangedCharSetException
    ChangedCharSetException as the name indicates is an exception thrown when the charset is changed.

软件包 javax.swing.text Description

Provides classes and interfaces that deal with editable and noneditable text components. Examples of text components are text fields and text areas, of which password fields and document editors are special instantiations. Features that are supported by this package include selection/highlighting, editing, style, and key mapping.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Using Text Components, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Frmfn


javax.swing.text Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.text

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
        • javax.swing.text.DefaultEditorKit.CopyAction
        • javax.swing.text.DefaultEditorKit.CutAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
        • javax.swing.text.DefaultEditorKit.PasteAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
          • javax.swing.text.StyledEditorKit.BoldAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
          • javax.swing.text.StyledEditorKit.ItalicAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
      • javax.swing.text.PlainDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
      • javax.swing.text.AbstractDocument.LeafElement
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.text.AbstractDocument.ElementEdit (implements javax.swing.event.DocumentEvent.ElementChange)
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent (implements javax.swing.event.DocumentEvent)
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
    • javax.swing.text.AbstractWriter
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
    • javax.swing.text.AsyncBoxView.ChildLocator
    • javax.swing.text.AsyncBoxView.ChildState (implements java.lang.Runnable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.text.DefaultTextUI
    • javax.swing.text.DefaultStyledDocument.ElementBuffer (implements java.io.Serializable)
    • javax.swing.text.DefaultStyledDocument.ElementSpec
    • javax.swing.text.DocumentFilter
    • javax.swing.text.DocumentFilter.FilterBypass
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
    • javax.swing.text.ElementIterator (implements java.lang.Cloneable)
    • javax.swing.text.FlowView.FlowStrategy
    • javax.swing.text.GapContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • javax.swing.text.GlyphView.GlyphPainter
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
      • javax.swing.text.DefaultFormatter (implements java.lang.Cloneable, java.io.Serializable)
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
          • javax.swing.text.NumberFormatter
        • javax.swing.text.MaskFormatter
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory (implements java.io.Serializable)
    • javax.swing.text.JTextComponent.KeyBinding
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
    • javax.swing.text.LayeredHighlighter.LayerPainter (implements javax.swing.text.Highlighter.HighlightPainter)
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
    • javax.swing.text.LayoutQueue
    • javax.swing.text.NavigationFilter
    • javax.swing.text.NavigationFilter.FilterBypass
    • javax.swing.text.Position.Bias
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • javax.swing.text.Segment (implements java.text.CharacterIterator, java.lang.CharSequence, java.lang.Cloneable)
    • javax.swing.text.SimpleAttributeSet (implements java.lang.Cloneable, javax.swing.text.MutableAttributeSet, java.io.Serializable)
    • javax.swing.text.StringContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants (implements javax.swing.text.AttributeSet.CharacterAttribute)
      • javax.swing.text.StyleConstants.ColorConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.ColorAttribute)
      • javax.swing.text.StyleConstants.FontConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.FontAttribute)
      • javax.swing.text.StyleConstants.ParagraphConstants (implements javax.swing.text.AttributeSet.ParagraphAttribute)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
    • javax.swing.text.StyleContext.NamedStyle (implements java.io.Serializable, javax.swing.text.Style)
    • javax.swing.text.StyleContext.SmallAttributeSet (implements javax.swing.text.AttributeSet)
    • javax.swing.text.TabSet (implements java.io.Serializable)
    • javax.swing.text.TabStop (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.text.BadLocationException
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
    • javax.swing.text.Utilities
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.AsyncBoxView
      • javax.swing.text.ComponentView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
          • javax.swing.text.TableView
          • javax.swing.text.TableView.TableCell
          • javax.swing.text.TableView.TableRow
          • javax.swing.text.WrappedPlainView (implements javax.swing.text.TabExpander)
          • javax.swing.text.ZoneView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
      • javax.swing.text.IconView
      • javax.swing.text.PlainView (implements javax.swing.text.TabExpander)
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView

Interface Hierarchy

  • javax.swing.text.AbstractDocument.AttributeContext
  • javax.swing.text.AbstractDocument.Content
  • javax.swing.text.AttributeSet
    • javax.swing.text.MutableAttributeSet
      • javax.swing.text.Style
  • javax.swing.text.AttributeSet.CharacterAttribute
  • javax.swing.text.AttributeSet.ColorAttribute
  • javax.swing.text.AttributeSet.FontAttribute
  • javax.swing.text.AttributeSet.ParagraphAttribute
  • javax.swing.text.Caret
  • javax.swing.text.Document
    • javax.swing.text.StyledDocument
  • javax.swing.text.Element
  • javax.swing.text.Highlighter
  • javax.swing.text.Highlighter.Highlight
  • javax.swing.text.Highlighter.HighlightPainter
  • javax.swing.text.Keymap
  • javax.swing.text.Position
  • javax.swing.text.TabableView
  • javax.swing.text.TabExpander
  • javax.swing.text.ViewFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


JTextComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 JTextComponent

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
    直接已知子类：
    JEditorPane, JTextArea, JTextField

    public abstract class JTextComponent
extends JComponent
implements Scrollable, Accessible
    JTextComponent is the base class for swing text components. It tries to be compatible with the java.awt.TextComponent class where it can reasonably do so. Also provided are other services for additional flexibility (beyond the pluggable UI and bean support). You can find information on how to use the functionality this class provides in General Rules for Using Text Components, a section in The Java Tutorial.

    Caret Changes
    The caret is a pluggable object in swing text components. Notification of changes to the caret position and the selection are sent to implementations of the CaretListener interface that have been registered with the text component. The UI will install a default caret unless a customized caret has been set.
    By default the caret tracks all the document changes performed on the Event Dispatching Thread and updates it's position accordingly if an insertion occurs before or at the caret position or a removal occurs before the caret position. DefaultCaret tries to make itself visible which may lead to scrolling of a text component within JScrollPane. The default caret behavior can be changed by the DefaultCaret.setUpdatePolicy(int) method.
    Note: Non-editable text components also have a caret though it may not be painted.

    Commands
    Text components provide a number of commands that can be used to manipulate the component. This is essentially the way that the component expresses its capabilities. These are expressed in terms of the swing Action interface, using the TextAction implementation. The set of commands supported by the text component can be found with the getActions() method. These actions can be bound to key events, fired from buttons, etc.

    Text Input
    The text components support flexible and internationalized text input, using keymaps and the input method framework, while maintaining compatibility with the AWT listener model.

    A Keymap lets an application bind key strokes to actions. In order to allow keymaps to be shared across multiple text components, they can use actions that extend TextAction. TextAction can determine which JTextComponent most recently has or had focus and therefore is the subject of the action (In the case that the ActionEvent sent to the action doesn't contain the target text component as its source).

    The input method framework lets text components interact with input methods, separate software components that preprocess events to let users enter thousands of different characters using keyboards with far fewer keys. JTextComponent is an active client of the framework, so it implements the preferred user interface for interacting with input methods. As a consequence, some key events do not reach the text component because they are handled by an input method, and some text input reaches the text component as committed text within an InputMethodEvent instead of as a key event. The complete text input is the combination of the characters in keyTyped key events and committed text in input method events.

    The AWT listener model lets applications attach event listeners to components in order to bind events to actions. Swing encourages the use of keymaps instead of listeners, but maintains compatibility with listeners by giving the listeners a chance to steal an event by consuming it.

    Keyboard event and input method events are handled in the following stages, with each stage capable of consuming the event:

    Stage

    KeyEvent

    InputMethodEvent

    1. | input methods | (generated here)
    2. | focus manager
    3. | registered key listeners | registered input method listeners
    4. | input method handling in JTextComponent
    5. | keymap handling using the current keymap
    6. | keyboard handling in JComponent (e.g. accelerators, component navigation, etc.)

    To maintain compatibility with applications that listen to key events but are not aware of input method events, the input method handling in stage 4 provides a compatibility mode for components that do not process input method events. For these components, the committed text is converted to keyTyped key events and processed in the key event pipeline starting at stage 3 instead of in the input method event pipeline.

    By default the component will create a keymap (named DEFAULT_KEYMAP) that is shared by all JTextComponent instances as the default keymap. Typically a look-and-feel implementation will install a different keymap that resolves to the default keymap for those bindings not found in the different keymap. The minimal bindings include:

    • inserting content into the editor for the printable keys.
    • removing content with the backspace and del keys.
    • caret movement forward and backward

    Model/View Split
    The text components have a model-view split. A text component pulls together the objects used to represent the model, view, and controller. The text document model may be shared by other views which act as observers of the model (e.g. a document may be shared by multiple components).

    Diagram showing interaction between Controller, Document, events, and ViewFactory

    The model is defined by the Document interface. This is intended to provide a flexible text storage mechanism that tracks change during edits and can be extended to more sophisticated models. The model interfaces are meant to capture the capabilities of expression given by SGML, a system used to express a wide variety of content. Each modification to the document causes notification of the details of the change to be sent to all observers in the form of a DocumentEvent which allows the views to stay up to date with the model. This event is sent to observers that have implemented the DocumentListener interface and registered interest with the model being observed.

    Location Information
    The capability of determining the location of text in the view is provided. There are two methods, modelToView(int) and viewToModel(java.awt.Point) for determining this information.

    Undo/Redo support
    Support for an edit history mechanism is provided to allow undo/redo operations. The text component does not itself provide the history buffer by default, but does provide the UndoableEdit records that can be used in conjunction with a history buffer to provide the undo/redo support. The support is provided by the Document model, which allows one to attach UndoableEditListener implementations.

    Thread Safety
    The swing text components provide some support of thread safe operations. Because of the high level of configurability of the text components, it is possible to circumvent the protection provided. The protection primarily comes from the model, so the documentation of AbstractDocument describes the assumptions of the protection provided. The methods that are safe to call asynchronously are marked with comments.

    Newlines
    For a discussion on how newlines are handled, see DefaultEditorKit.

    Printing support
    Several print methods are provided for basic document printing. If more advanced printing is needed, use the getPrintable(java.text.MessageFormat, java.text.MessageFormat) method.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Document, DocumentEvent, DocumentListener, Caret, CaretEvent, CaretListener, TextUI, View, ViewFactory

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  JTextComponent.AccessibleJTextComponent
      This class implements accessibility support for the JTextComponent class.
      static class  JTextComponent.DropLocation
      Represents a drop location for JTextComponents.
      static class  JTextComponent.KeyBinding
      Binding record for creating key bindings.

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_KEYMAP
      The default keymap that will be shared by all JTextComponent instances unless they have had a different keymap set.
      static String FOCUS_ACCELERATOR_KEY
      The bound property name for the focus accelerator.

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextComponent()
      Creates a new JTextComponent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addCaretListener(CaretListener listener)
      Adds a caret listener for notification of any changes to the caret.
      void addInputMethodListener(InputMethodListener l)
      Adds the specified input method listener to receive input method events from this component.
      static Keymap addKeymap(String nm, Keymap parent)
      Adds a new keymap into the keymap hierarchy.
      void copy()
      Transfers the currently selected range in the associated text model to the system clipboard, leaving the contents in the text model.
      void cut()
      Transfers the currently selected range in the associated text model to the system clipboard, removing the contents from the model.
      protected void fireCaretUpdate(CaretEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      AccessibleContext getAccessibleContext()
      Gets the AccessibleContext associated with this JTextComponent.
      Action[] getActions()
      Fetches the command list for the editor.
      Caret getCaret()
      Fetches the caret that allows text-oriented navigation over the view.
      Color getCaretColor()
      Fetches the current color used to render the caret.
      CaretListener[] getCaretListeners()
      Returns an array of all the caret listeners registered on this text component.
      int getCaretPosition()
      Returns the position of the text insertion caret for the text component.
      Color getDisabledTextColor()
      Fetches the current color used to render the disabled text.
      Document getDocument()
      Fetches the model associated with the editor.
      boolean getDragEnabled()
      Returns whether or not automatic drag handling is enabled.
      JTextComponent.DropLocation getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
      DropMode getDropMode()
      Returns the drop mode for this component.
      char getFocusAccelerator()
      Returns the key accelerator that will cause the receiving text component to get the focus.
      Highlighter getHighlighter()
      Fetches the object responsible for making highlights.
      InputMethodRequests getInputMethodRequests()
      Gets the input method request handler which supports requests from input methods for this component.
      Keymap getKeymap()
      Fetches the keymap currently active in this text component.
      static Keymap getKeymap(String nm)
      Fetches a named keymap previously added to the document.
      Insets getMargin()
      Returns the margin between the text component's border and its text.
      NavigationFilter getNavigationFilter()
      Returns the NavigationFilter.
      Dimension getPreferredScrollableViewportSize()
      Returns the preferred size of the viewport for a view component.
      Printable getPrintable(MessageFormat headerFormat, MessageFormat footerFormat)
      Returns a Printable to use for printing the content of this JTextComponent.
      int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
      Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.
      boolean getScrollableTracksViewportHeight()
      Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.
      boolean getScrollableTracksViewportWidth()
      Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.
      int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
      Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.
      String getSelectedText()
      Returns the selected text contained in this TextComponent.
      Color getSelectedTextColor()
      Fetches the current color used to render the selected text.
      Color getSelectionColor()
      Fetches the current color used to render the selection.
      int getSelectionEnd()
      Returns the selected text's end position.
      int getSelectionStart()
      Returns the selected text's start position.
      String getText()
      Returns the text contained in this TextComponent.
      String getText(int offs, int len)
      Fetches a portion of the text represented by the component.
      String getToolTipText(MouseEvent event)
      Returns the string to be used as the tooltip for event.
      TextUI getUI()
      Fetches the user-interface factory for this text-oriented editor.
      boolean isEditable()
      Returns the boolean indicating whether this TextComponent is editable or not.
      static void loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
      Loads a keymap with a bunch of bindings.
      Rectangle modelToView(int pos)
      Converts the given location in the model to a place in the view coordinate system.
      void moveCaretPosition(int pos)
      Moves the caret to a new position, leaving behind a mark defined by the last time setCaretPosition was called.
      protected String paramString()
      Returns a string representation of this JTextComponent.
      void paste()
      Transfers the contents of the system clipboard into the associated text model.
      boolean print()
      A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with no header or footer text.
      boolean print(MessageFormat headerFormat, MessageFormat footerFormat)
      A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with the specified header and footer text.
      boolean print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
      Prints the content of this JTextComponent.
      protected void processInputMethodEvent(InputMethodEvent e)
      Processes input method events occurring on this component by dispatching them to any registered InputMethodListener objects.
      void read(Reader in, Object desc)
      Initializes from a stream.
      void removeCaretListener(CaretListener listener)
      Removes a caret listener.
      static Keymap removeKeymap(String nm)
      Removes a named keymap previously added to the document.
      void removeNotify()
      Notifies this component that it no longer has a parent component.
      void replaceSelection(String content)
      Replaces the currently selected content with new content represented by the given string.
      protected void restoreComposedText()
      Restores composed text previously saved by saveComposedText.
      protected boolean saveComposedText(int pos)
      Saves composed text around the specified position.
      void select(int selectionStart, int selectionEnd)
      Selects the text between the specified start and end positions.
      void selectAll()
      Selects all the text in the TextComponent.
      void setCaret(Caret c)
      Sets the caret to be used.
      void setCaretColor(Color c)
      Sets the current color used to render the caret.
      void setCaretPosition(int position)
      Sets the position of the text insertion caret for the TextComponent.
      void setComponentOrientation(ComponentOrientation o)
      Sets the language-sensitive orientation that is to be used to order the elements or text within this component.
      void setDisabledTextColor(Color c)
      Sets the current color used to render the disabled text.
      void setDocument(Document doc)
      Associates the editor with a text document.
      void setDragEnabled(boolean b)
      Turns on or off automatic drag handling.
      void setDropMode(DropMode dropMode)
      Sets the drop mode for this component.
      void setEditable(boolean b)
      Sets the specified boolean to indicate whether or not this TextComponent should be editable.
      void setFocusAccelerator(char aKey)
      Sets the key accelerator that will cause the receiving text component to get the focus.
      void setHighlighter(Highlighter h)
      Sets the highlighter to be used.
      void setKeymap(Keymap map)
      Sets the keymap to use for binding events to actions.
      void setMargin(Insets m)
      Sets margin space between the text component's border and its text.
      void setNavigationFilter(NavigationFilter filter)
      Sets the NavigationFilter.
      void setSelectedTextColor(Color c)
      Sets the current color used to render the selected text.
      void setSelectionColor(Color c)
      Sets the current color used to render the selection.
      void setSelectionEnd(int selectionEnd)
      Sets the selection end to the specified position.
      void setSelectionStart(int selectionStart)
      Sets the selection start to the specified position.
      void setText(String t)
      Sets the text of this TextComponent to the specified text.
      void setUI(TextUI ui)
      Sets the user-interface factory for this text-oriented editor.
      void updateUI()
      Reloads the pluggable UI.
      int viewToModel(Point pt)
      Converts the given place in the view coordinate system to the nearest representative location in the model.
      void write(Writer out)
      Stores the contents of the model into the given stream.

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • FOCUS_ACCELERATOR_KEY

        public static final String FOCUS_ACCELERATOR_KEY
        The bound property name for the focus accelerator.
        另请参见：
        Constant Field Values

      • DEFAULT_KEYMAP

        public static final String DEFAULT_KEYMAP
        The default keymap that will be shared by all JTextComponent instances unless they have had a different keymap set.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JTextComponent

        public JTextComponent()
        Creates a new JTextComponent. Listeners for caret events are established, and the pluggable UI installed. The component is marked as editable. No layout manager is used, because layout is managed by the view subsystem of text. The document model is set to null.

    • 方法详细信息

      • getUI

        public TextUI getUI()
        Fetches the user-interface factory for this text-oriented editor.
        返回：
        the factory

      • setUI

        public void setUI(TextUI ui)
        Sets the user-interface factory for this text-oriented editor.
        参数：
        ui - the factory

      • updateUI

        public void updateUI()
        Reloads the pluggable UI. The key used to fetch the new interface is getUIClassID(). The type of the UI is TextUI. invalidate is called after setting the UI.
        重载：
        updateUI in class JComponent
        另请参见：
        JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

      • addCaretListener

        public void addCaretListener(CaretListener listener)
        Adds a caret listener for notification of any changes to the caret.
        参数：
        listener - the listener to be added
        另请参见：
        CaretEvent

      • removeCaretListener

        public void removeCaretListener(CaretListener listener)
        Removes a caret listener.
        参数：
        listener - the listener to be removed
        另请参见：
        CaretEvent

      • getCaretListeners

        public CaretListener[] getCaretListeners()
        Returns an array of all the caret listeners registered on this text component.
        返回：
        all of this component's CaretListeners or an empty array if no caret listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addCaretListener(javax.swing.event.CaretListener), removeCaretListener(javax.swing.event.CaretListener)

      • fireCaretUpdate

        protected void fireCaretUpdate(CaretEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method. The listener list is processed in a last-to-first manner.
        参数：
        e - the event
        另请参见：
        EventListenerList

      • setDocument

        public void setDocument(Document doc)
        Associates the editor with a text document. The currently registered factory is used to build a view for the document, which gets displayed by the editor after revalidation. A PropertyChange event ("document") is propagated to each listener.
        参数：
        doc - the document to display/edit
        另请参见：
        getDocument()

      • getDocument

        public Document getDocument()
        Fetches the model associated with the editor. This is primarily for the UI to get at the minimal amount of state required to be a text editor. Subclasses will return the actual type of the model which will typically be something that extends Document.
        返回：
        the model

      • setComponentOrientation

        public void setComponentOrientation(ComponentOrientation o)
        Description copied from class: Component
        Sets the language-sensitive orientation that is to be used to order the elements or text within this component. Language-sensitive LayoutManager and Component subclasses will use this property to determine how to lay out and draw components.

        At construction time, a component's orientation is set to ComponentOrientation.UNKNOWN, indicating that it has not been specified explicitly. The UNKNOWN orientation behaves the same as ComponentOrientation.LEFT_TO_RIGHT.

        To set the orientation of a single component, use this method. To set the orientation of an entire component hierarchy, use applyComponentOrientation.

        This method changes layout-related information, and therefore, invalidates the component hierarchy.

        重载：
        setComponentOrientation in class Component
        另请参见：
        ComponentOrientation, Component.invalidate()

      • getActions

        public Action[] getActions()
        Fetches the command list for the editor. This is the list of commands supported by the plugged-in UI augmented by the collection of commands that the editor itself supports. These are useful for binding to events, such as in a keymap.
        返回：
        the command list

      • setMargin

        public void setMargin(Insets m)
        Sets margin space between the text component's border and its text. The text component's default Border object will use this value to create the proper margin. However, if a non-default border is set on the text component, it is that Border object's responsibility to create the appropriate margin space (else this property will effectively be ignored). This causes a redraw of the component. A PropertyChange event ("margin") is sent to all listeners.
        参数：
        m - the space between the border and the text

      • getMargin

        public Insets getMargin()
        Returns the margin between the text component's border and its text.
        返回：
        the margin

      • setNavigationFilter

        public void setNavigationFilter(NavigationFilter filter)
        Sets the NavigationFilter. NavigationFilter is used by DefaultCaret and the default cursor movement actions as a way to restrict the cursor movement.
        从以下版本开始：
        1.4

      • getNavigationFilter

        public NavigationFilter getNavigationFilter()
        Returns the NavigationFilter. NavigationFilter is used by DefaultCaret and the default cursor movement actions as a way to restrict the cursor movement. A null return value implies the cursor movement and selection should not be restricted.
        返回：
        the NavigationFilter
        从以下版本开始：
        1.4

      • getCaret

        public Caret getCaret()
        Fetches the caret that allows text-oriented navigation over the view.
        返回：
        the caret

      • setCaret

        public void setCaret(Caret c)
        Sets the caret to be used. By default this will be set by the UI that gets installed. This can be changed to a custom caret if desired. Setting the caret results in a PropertyChange event ("caret") being fired.
        参数：
        c - the caret
        另请参见：
        getCaret()

      • getHighlighter

        public Highlighter getHighlighter()
        Fetches the object responsible for making highlights.
        返回：
        the highlighter

      • setHighlighter

        public void setHighlighter(Highlighter h)
        Sets the highlighter to be used. By default this will be set by the UI that gets installed. This can be changed to a custom highlighter if desired. The highlighter can be set to null to disable it. A PropertyChange event ("highlighter") is fired when a new highlighter is installed.
        参数：
        h - the highlighter
        另请参见：
        getHighlighter()

      • setKeymap

        public void setKeymap(Keymap map)
        Sets the keymap to use for binding events to actions. Setting to null effectively disables keyboard input. A PropertyChange event ("keymap") is fired when a new keymap is installed.
        参数：
        map - the keymap
        另请参见：
        getKeymap()

      • setDragEnabled

        public void setDragEnabled(boolean b)
        Turns on or off automatic drag handling. In order to enable automatic drag handling, this property should be set to true, and the component's TransferHandler needs to be non-null. The default value of the dragEnabled property is false.

        The job of honoring this property, and recognizing a user drag gesture, lies with the look and feel implementation, and in particular, the component's TextUI. When automatic drag handling is enabled, most look and feels (including those that subclass BasicLookAndFeel) begin a drag and drop operation whenever the user presses the mouse button over a selection and then moves the mouse a few pixels. Setting this property to true can therefore have a subtle effect on how selections behave.

        If a look and feel is used that ignores this property, you can still begin a drag and drop operation by calling exportAsDrag on the component's TransferHandler.

        参数：
        b - whether or not to enable automatic drag handling
        抛出：
        HeadlessException - if b is true and GraphicsEnvironment.isHeadless() returns true
        从以下版本开始：
        1.4
        另请参见：
        GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDragEnabled

        public boolean getDragEnabled()
        Returns whether or not automatic drag handling is enabled.
        返回：
        the value of the dragEnabled property
        从以下版本开始：
        1.4
        另请参见：
        setDragEnabled(boolean)

      • setDropMode

        public final void setDropMode(DropMode dropMode)
        Sets the drop mode for this component. For backward compatibility, the default for this property is DropMode.USE_SELECTION. Usage of DropMode.INSERT is recommended, however, for an improved user experience. It offers similar behavior of dropping between text locations, but does so without affecting the actual text selection and caret location.

        JTextComponents support the following drop modes:

        • DropMode.USE_SELECTION
        • DropMode.INSERT

        The drop mode is only meaningful if this component has a TransferHandler that accepts drops.

        参数：
        dropMode - the drop mode to use
        抛出：
        IllegalArgumentException - if the drop mode is unsupported or null
        从以下版本开始：
        1.6
        另请参见：
        getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

      • getDropMode

        public final DropMode getDropMode()
        Returns the drop mode for this component.
        返回：
        the drop mode for this component
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode)

      • getDropLocation

        public final JTextComponent.DropLocation getDropLocation()
        Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

        This method is not meant for querying the drop location from a TransferHandler, as the drop location is only set after the TransferHandler's canImport has returned and has allowed for the location to be shown.

        When this property changes, a property change event with name "dropLocation" is fired by the component.

        返回：
        the drop location
        从以下版本开始：
        1.6
        另请参见：
        setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

      • getKeymap

        public Keymap getKeymap()
        Fetches the keymap currently active in this text component.
        返回：
        the keymap

      • addKeymap

        public static Keymap addKeymap(String nm,
               Keymap parent)
        Adds a new keymap into the keymap hierarchy. Keymap bindings resolve from bottom up so an attribute specified in a child will override an attribute specified in the parent.
        参数：
        nm - the name of the keymap (must be unique within the collection of named keymaps in the document); the name may be null if the keymap is unnamed, but the caller is responsible for managing the reference returned as an unnamed keymap can't be fetched by name
        parent - the parent keymap; this may be null if unspecified bindings need not be resolved in some other keymap
        返回：
        the keymap

      • removeKeymap

        public static Keymap removeKeymap(String nm)
        Removes a named keymap previously added to the document. Keymaps with null names may not be removed in this way.
        参数：
        nm - the name of the keymap to remove
        返回：
        the keymap that was removed

      • getKeymap

        public static Keymap getKeymap(String nm)
        Fetches a named keymap previously added to the document. This does not work with null-named keymaps.
        参数：
        nm - the name of the keymap
        返回：
        the keymap

      • loadKeymap

        public static void loadKeymap(Keymap map,
              JTextComponent.KeyBinding[] bindings,
              Action[] actions)

        Loads a keymap with a bunch of bindings. This can be used to take a static table of definitions and load them into some keymap. The following example illustrates an example of binding some keys to the cut, copy, and paste actions associated with a JTextComponent. A code fragment to accomplish this might look as follows:

   static final JTextComponent.KeyBinding[] defaultBindings = {
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_C, InputEvent.CTRL_MASK),
       DefaultEditorKit.copyAction),
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_V, InputEvent.CTRL_MASK),
       DefaultEditorKit.pasteAction),
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_X, InputEvent.CTRL_MASK),
       DefaultEditorKit.cutAction),
   };

   JTextComponent c = new JTextPane();
   Keymap k = c.getKeymap();
   JTextComponent.loadKeymap(k, defaultBindings, c.getActions());
        The sets of bindings and actions may be empty but must be non-null.
        参数：
        map - the keymap
        bindings - the bindings
        actions - the set of actions

      • getCaretColor

        public Color getCaretColor()
        Fetches the current color used to render the caret.
        返回：
        the color

      • setCaretColor

        public void setCaretColor(Color c)
        Sets the current color used to render the caret. Setting to null effectively restores the default color. Setting the color results in a PropertyChange event ("caretColor") being fired.
        参数：
        c - the color
        另请参见：
        getCaretColor()

      • getSelectionColor

        public Color getSelectionColor()
        Fetches the current color used to render the selection.
        返回：
        the color

      • setSelectionColor

        public void setSelectionColor(Color c)
        Sets the current color used to render the selection. Setting the color to null is the same as setting Color.white. Setting the color results in a PropertyChange event ("selectionColor").
        参数：
        c - the color
        另请参见：
        getSelectionColor()

      • getSelectedTextColor

        public Color getSelectedTextColor()
        Fetches the current color used to render the selected text.
        返回：
        the color

      • setSelectedTextColor

        public void setSelectedTextColor(Color c)
        Sets the current color used to render the selected text. Setting the color to null is the same as Color.black. Setting the color results in a PropertyChange event ("selectedTextColor") being fired.
        参数：
        c - the color
        另请参见：
        getSelectedTextColor()

      • getDisabledTextColor

        public Color getDisabledTextColor()
        Fetches the current color used to render the disabled text.
        返回：
        the color

      • setDisabledTextColor

        public void setDisabledTextColor(Color c)
        Sets the current color used to render the disabled text. Setting the color fires off a PropertyChange event ("disabledTextColor").
        参数：
        c - the color
        另请参见：
        getDisabledTextColor()

      • replaceSelection

        public void replaceSelection(String content)
        Replaces the currently selected content with new content represented by the given string. If there is no selection this amounts to an insert of the given text. If there is no replacement text this amounts to a removal of the current selection.

        This is the method that is used by the default implementation of the action for inserting content that gets bound to the keymap actions.

        参数：
        content - the content to replace the selection with

      • getText

        public String getText(int offs,
             int len)
               throws BadLocationException
        Fetches a portion of the text represented by the component. Returns an empty string if length is 0.
        参数：
        offs - the offset >= 0
        len - the length >= 0
        返回：
        the text
        抛出：
        BadLocationException - if the offset or length are invalid

      • modelToView

        public Rectangle modelToView(int pos)
                      throws BadLocationException
        Converts the given location in the model to a place in the view coordinate system. The component must have a positive size for this translation to be computed (i.e. layout cannot be computed until the component has been sized). The component does not have to be visible or painted.
        参数：
        pos - the position >= 0
        返回：
        the coordinates as a rectangle, with (r.x, r.y) as the location in the coordinate system, or null if the component does not yet have a positive size.
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        TextUI.modelToView(javax.swing.text.JTextComponent, int)

      • viewToModel

        public int viewToModel(Point pt)
        Converts the given place in the view coordinate system to the nearest representative location in the model. The component must have a positive size for this translation to be computed (i.e. layout cannot be computed until the component has been sized). The component does not have to be visible or painted.
        参数：
        pt - the location in the view to translate
        返回：
        the offset >= 0 from the start of the document, or -1 if the component does not yet have a positive size.
        另请参见：
        TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

      • cut

        public void cut()
        Transfers the currently selected range in the associated text model to the system clipboard, removing the contents from the model. The current selection is reset. Does nothing for null selections.
        另请参见：
        Toolkit.getSystemClipboard(), Clipboard

      • copy

        public void copy()
        Transfers the currently selected range in the associated text model to the system clipboard, leaving the contents in the text model. The current selection remains intact. Does nothing for null selections.
        另请参见：
        Toolkit.getSystemClipboard(), Clipboard

      • paste

        public void paste()
        Transfers the contents of the system clipboard into the associated text model. If there is a selection in the associated view, it is replaced with the contents of the clipboard. If there is no selection, the clipboard contents are inserted in front of the current insert position in the associated view. If the clipboard is empty, does nothing.
        另请参见：
        replaceSelection(java.lang.String), Toolkit.getSystemClipboard(), Clipboard

      • moveCaretPosition

        public void moveCaretPosition(int pos)
        Moves the caret to a new position, leaving behind a mark defined by the last time setCaretPosition was called. This forms a selection. If the document is null, does nothing. The position must be between 0 and the length of the component's text or else an exception is thrown.
        参数：
        pos - the position
        抛出：
        IllegalArgumentException - if the value supplied for position is less than zero or greater than the component's text length
        另请参见：
        setCaretPosition(int)

      • setFocusAccelerator

        public void setFocusAccelerator(char aKey)
        Sets the key accelerator that will cause the receiving text component to get the focus. The accelerator will be the key combination of the alt key and the character given (converted to upper case). By default, there is no focus accelerator key. Any previous key accelerator setting will be superseded. A '\0' key setting will be registered, and has the effect of turning off the focus accelerator. When the new key is set, a PropertyChange event (FOCUS_ACCELERATOR_KEY) will be fired.
        参数：
        aKey - the key
        另请参见：
        getFocusAccelerator()

      • getFocusAccelerator

        public char getFocusAccelerator()
        Returns the key accelerator that will cause the receiving text component to get the focus. Return '\0' if no focus accelerator has been set.
        返回：
        the key

      • read

        public void read(Reader in,
        Object desc)
          throws IOException
        Initializes from a stream. This creates a model of the type appropriate for the component and initializes the model from the stream. By default this will load the model as plain text. Previous contents of the model are discarded.
        参数：
        in - the stream to read from
        desc - an object describing the stream; this might be a string, a File, a URL, etc. Some kinds of documents (such as html for example) might be able to make use of this information; if non-null, it is added as a property of the document
        抛出：
        IOException - as thrown by the stream being used to initialize
        另请参见：
        EditorKit.createDefaultDocument(), setDocument(javax.swing.text.Document), PlainDocument

      • write

        public void write(Writer out)
           throws IOException
        Stores the contents of the model into the given stream. By default this will store the model as plain text.
        参数：
        out - the output stream
        抛出：
        IOException - on any I/O error

      • removeNotify

        public void removeNotify()
        Description copied from class: JComponent
        Notifies this component that it no longer has a parent component. When this method is invoked, any KeyboardActions set up in the the chain of parent components are removed. This method is called by the toolkit internally and should not be called directly by programs.
        重载：
        removeNotify in class JComponent
        另请参见：
        JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

      • setCaretPosition

        public void setCaretPosition(int position)
        Sets the position of the text insertion caret for the TextComponent. Note that the caret tracks change, so this may move if the underlying text of the component is changed. If the document is null, does nothing. The position must be between 0 and the length of the component's text or else an exception is thrown.
        参数：
        position - the position
        抛出：
        IllegalArgumentException - if the value supplied for position is less than zero or greater than the component's text length

      • getCaretPosition

        public int getCaretPosition()
        Returns the position of the text insertion caret for the text component.
        返回：
        the position of the text insertion caret for the text component >= 0

      • setText

        public void setText(String t)
        Sets the text of this TextComponent to the specified text. If the text is null or empty, has the effect of simply deleting the old text. When text has been inserted, the resulting caret location is determined by the implementation of the caret class.

        Note that text is not a bound property, so no PropertyChangeEvent is fired when it changes. To listen for changes to the text, use DocumentListener.

        参数：
        t - the new text to be set
        另请参见：
        getText(int, int), DefaultCaret

      • getText

        public String getText()
        Returns the text contained in this TextComponent. If the underlying document is null, will give a NullPointerException. Note that text is not a bound property, so no PropertyChangeEvent is fired when it changes. To listen for changes to the text, use DocumentListener.
        返回：
        the text
        抛出：
        NullPointerException - if the document is null
        另请参见：
        setText(java.lang.String)

      • getSelectedText

        public String getSelectedText()
        Returns the selected text contained in this TextComponent. If the selection is null or the document empty, returns null.
        返回：
        the text
        抛出：
        IllegalArgumentException - if the selection doesn't have a valid mapping into the document for some reason
        另请参见：
        setText(java.lang.String)

      • isEditable

        public boolean isEditable()
        Returns the boolean indicating whether this TextComponent is editable or not.
        返回：
        the boolean value
        另请参见：
        setEditable(boolean)

      • setEditable

        public void setEditable(boolean b)
        Sets the specified boolean to indicate whether or not this TextComponent should be editable. A PropertyChange event ("editable") is fired when the state is changed.
        参数：
        b - the boolean to be set
        另请参见：
        isEditable()

      • getSelectionStart

        public int getSelectionStart()
        Returns the selected text's start position. Return 0 for an empty document, or the value of dot if no selection.
        返回：
        the start position >= 0

      • setSelectionStart

        public void setSelectionStart(int selectionStart)
        Sets the selection start to the specified position. The new starting point is constrained to be before or at the current selection end.

        This is available for backward compatibility to code that called this method on java.awt.TextComponent. This is implemented to forward to the Caret implementation which is where the actual selection is maintained.

        参数：
        selectionStart - the start position of the text >= 0

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the selected text's end position. Return 0 if the document is empty, or the value of dot if there is no selection.
        返回：
        the end position >= 0

      • setSelectionEnd

        public void setSelectionEnd(int selectionEnd)
        Sets the selection end to the specified position. The new end point is constrained to be at or after the current selection start.

        This is available for backward compatibility to code that called this method on java.awt.TextComponent. This is implemented to forward to the Caret implementation which is where the actual selection is maintained.

        参数：
        selectionEnd - the end position of the text >= 0

      • select

        public void select(int selectionStart,
          int selectionEnd)
        Selects the text between the specified start and end positions.

        This method sets the start and end positions of the selected text, enforcing the restriction that the start position must be greater than or equal to zero. The end position must be greater than or equal to the start position, and less than or equal to the length of the text component's text.

        If the caller supplies values that are inconsistent or out of bounds, the method enforces these constraints silently, and without failure. Specifically, if the start position or end position is greater than the length of the text, it is reset to equal the text length. If the start position is less than zero, it is reset to zero, and if the end position is less than the start position, it is reset to the start position.

        This call is provided for backward compatibility. It is routed to a call to setCaretPosition followed by a call to moveCaretPosition. The preferred way to manage selection is by calling those methods directly.

        参数：
        selectionStart - the start position of the text
        selectionEnd - the end position of the text
        另请参见：
        setCaretPosition(int), moveCaretPosition(int)

      • selectAll

        public void selectAll()
        Selects all the text in the TextComponent. Does nothing on a null or empty document.

      • getToolTipText

        public String getToolTipText(MouseEvent event)
        Returns the string to be used as the tooltip for event. This will return one of:
        1. If setToolTipText has been invoked with a non-null value, it will be returned, otherwise
        2. The value from invoking getToolTipText on the UI will be returned.
        By default JTextComponent does not register itself with the ToolTipManager. This means that tooltips will NOT be shown from the TextUI unless registerComponent has been invoked on the ToolTipManager.
        重载：
        getToolTipText in class JComponent
        参数：
        event - the event in question
        返回：
        the string to be used as the tooltip for event
        另请参见：
        JComponent.setToolTipText(java.lang.String),
TextUI.getToolTipText(javax.swing.text.JTextComponent, java.awt.Point),
ToolTipManager.registerComponent(javax.swing.JComponent)

      • getPreferredScrollableViewportSize

        public Dimension getPreferredScrollableViewportSize()
        Returns the preferred size of the viewport for a view component. This is implemented to do the default behavior of returning the preferred size of the component.
        指定者：
        getPreferredScrollableViewportSize in interface Scrollable
        返回：
        the preferredSize of a JViewport whose view is this Scrollable
        另请参见：
        JComponent.getPreferredSize()

      • getScrollableUnitIncrement

        public int getScrollableUnitIncrement(Rectangle visibleRect,
                             int orientation,
                             int direction)
        Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation. Ideally, components should handle a partially exposed row or column by returning the distance required to completely expose the item.

        The default implementation of this is to simply return 10% of the visible area. Subclasses are likely to be able to provide a much more reasonable value.

        指定者：
        getScrollableUnitIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        the "unit" increment for scrolling in the specified direction
        抛出：
        IllegalArgumentException - for an invalid orientation
        另请参见：
        JScrollBar.setUnitIncrement(int)

      • getScrollableBlockIncrement

        public int getScrollableBlockIncrement(Rectangle visibleRect,
                              int orientation,
                              int direction)
        Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

        The default implementation of this is to simply return the visible area. Subclasses will likely be able to provide a much more reasonable value.

        指定者：
        getScrollableBlockIncrement in interface Scrollable
        参数：
        visibleRect - the view area visible within the viewport
        orientation - either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL
        direction - less than zero to scroll up/left, greater than zero for down/right
        返回：
        the "block" increment for scrolling in the specified direction
        抛出：
        IllegalArgumentException - for an invalid orientation
        另请参见：
        JScrollBar.setBlockIncrement(int)

      • getScrollableTracksViewportWidth

        public boolean getScrollableTracksViewportWidth()
        Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport. For example a normal text view that supported line wrapping would return true here, since it would be undesirable for wrapped lines to disappear beyond the right edge of the viewport. Note that returning true for a Scrollable whose ancestor is a JScrollPane effectively disables horizontal scrolling.

        Scrolling containers, like JViewport, will use this method each time they are validated.

        指定者：
        getScrollableTracksViewportWidth in interface Scrollable
        返回：
        true if a viewport should force the Scrollables width to match its own

      • getScrollableTracksViewportHeight

        public boolean getScrollableTracksViewportHeight()
        Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport. For example a columnar text view that flowed text in left to right columns could effectively disable vertical scrolling by returning true here.

        Scrolling containers, like JViewport, will use this method each time they are validated.

        指定者：
        getScrollableTracksViewportHeight in interface Scrollable
        返回：
        true if a viewport should force the Scrollables height to match its own

      • print

        public boolean print()
              throws PrinterException
        A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with no header or footer text. Note: this method blocks until printing is done.

        Note: In headless mode, no dialogs will be shown.

        This method calls the full featured print method to perform printing.

        返回：
        true, unless printing is canceled by the user
        抛出：
        PrinterException - if an error in the print system causes the job to be aborted
        SecurityException - if this thread is not allowed to initiate a print job request
        从以下版本开始：
        1.6
        另请参见：
        print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean)

      • print

        public boolean print(MessageFormat headerFormat,
            MessageFormat footerFormat)
              throws PrinterException
        A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with the specified header and footer text. Note: this method blocks until printing is done.

        Note: In headless mode, no dialogs will be shown.

        This method calls the full featured print method to perform printing.

        参数：
        headerFormat - the text, in MessageFormat, to be used as the header, or null for no header
        footerFormat - the text, in MessageFormat, to be used as the footer, or null for no footer
        返回：
        true, unless printing is canceled by the user
        抛出：
        PrinterException - if an error in the print system causes the job to be aborted
        SecurityException - if this thread is not allowed to initiate a print job request
        从以下版本开始：
        1.6
        另请参见：
        print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean), MessageFormat

      • print

        public boolean print(MessageFormat headerFormat,
            MessageFormat footerFormat,
            boolean showPrintDialog,
            PrintService service,
            PrintRequestAttributeSet attributes,
            boolean interactive)
              throws PrinterException
        Prints the content of this JTextComponent. Note: this method blocks until printing is done.

        Page header and footer text can be added to the output by providing MessageFormat arguments. The printing code requests Strings from the formats, providing a single item which may be included in the formatted string: an Integer representing the current page number.

        showPrintDialog boolean parameter allows you to specify whether a print dialog is displayed to the user. When it is, the user may use the dialog to change printing attributes or even cancel the print.

        service allows you to provide the initial PrintService for the print dialog, or to specify PrintService to print to when the dialog is not shown.

        attributes can be used to provide the initial values for the print dialog, or to supply any needed attributes when the dialog is not shown. attributes can be used to control how the job will print, for example duplex or single-sided.

        interactive boolean parameter allows you to specify whether to perform printing in interactive mode. If true, a progress dialog, with an abort option, is displayed for the duration of printing. This dialog is modal when print is invoked on the Event Dispatch Thread and non-modal otherwise. Warning: calling this method on the Event Dispatch Thread with interactive false blocks all events, including repaints, from being processed until printing is complete. It is only recommended when printing from an application with no visible GUI.

        Note: In headless mode, showPrintDialog and interactive parameters are ignored and no dialogs are shown.

        This method ensures the document is not mutated during printing. To indicate it visually, setEnabled(false) is set for the duration of printing.

        This method uses getPrintable(java.text.MessageFormat, java.text.MessageFormat) to render document content.

        This method is thread-safe, although most Swing methods are not. Please see How to Use Threads for more information.

        Sample Usage. This code snippet shows a cross-platform print dialog and then prints the JTextComponent in interactive mode unless the user cancels the dialog:

         textComponent.print(new MessageFormat("My text component header"),
     new MessageFormat("Footer. Page - {0}"), true, null, null, true);

        Executing this code off the Event Dispatch Thread performs printing on the background. The following pattern might be used for background printing:

             FutureTask<Boolean> future =
         new FutureTask<Boolean>(
             new Callable<Boolean>() {
                 public Boolean call() {
                     return textComponent.print(.....);
                 }
             });
     executor.execute(future);
        参数：
        headerFormat - the text, in MessageFormat, to be used as the header, or null for no header
        footerFormat - the text, in MessageFormat, to be used as the footer, or null for no footer
        showPrintDialog - true to display a print dialog, false otherwise
        service - initial PrintService, or null for the default
        attributes - the job attributes to be applied to the print job, or null for none
        interactive - whether to print in an interactive mode
        返回：
        true, unless printing is canceled by the user
        抛出：
        PrinterException - if an error in the print system causes the job to be aborted
        SecurityException - if this thread is not allowed to initiate a print job request
        从以下版本开始：
        1.6
        另请参见：
        getPrintable(java.text.MessageFormat, java.text.MessageFormat), MessageFormat, GraphicsEnvironment.isHeadless(), FutureTask

      • getPrintable

        public Printable getPrintable(MessageFormat headerFormat,
                     MessageFormat footerFormat)
        Returns a Printable to use for printing the content of this JTextComponent. The returned Printable prints the document as it looks on the screen except being reformatted to fit the paper. The returned Printable can be wrapped inside another Printable in order to create complex reports and documents.

        The returned Printable shares the document with this JTextComponent. It is the responsibility of the developer to ensure that the document is not mutated while this Printable is used. Printing behavior is undefined when the document is mutated during printing.

        Page header and footer text can be added to the output by providing MessageFormat arguments. The printing code requests Strings from the formats, providing a single item which may be included in the formatted string: an Integer representing the current page number.

        The returned Printable when printed, formats the document content appropriately for the page size. For correct line wrapping the imageable width of all pages must be the same. See PageFormat.getImageableWidth().

        This method is thread-safe, although most Swing methods are not. Please see How to Use Threads for more information.

        The returned Printable can be printed on any thread.

        This implementation returned Printable performs all painting on the Event Dispatch Thread, regardless of what thread it is used on.

        参数：
        headerFormat - the text, in MessageFormat, to be used as the header, or null for no header
        footerFormat - the text, in MessageFormat, to be used as the footer, or null for no footer
        返回：
        a Printable for use in printing content of this JTextComponent
        从以下版本开始：
        1.6
        另请参见：
        Printable, PageFormat, Document.render(java.lang.Runnable)

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        Gets the AccessibleContext associated with this JTextComponent. For text components, the AccessibleContext takes the form of an AccessibleJTextComponent. A new AccessibleJTextComponent instance is created if necessary.
        指定者：
        getAccessibleContext in interface Accessible
        重载：
        getAccessibleContext in class JComponent
        返回：
        an AccessibleJTextComponent that serves as the AccessibleContext of this JTextComponent

      • paramString

        protected String paramString()
        Returns a string representation of this JTextComponent. This method is intended to be used only for debugging purposes, and the content and format of the returned string may vary between implementations. The returned string may be empty but may not be null.

        Overriding paramString to provide information about the specific new aspects of the JFC components.

        重载：
        paramString in class JComponent
        返回：
        a string representation of this JTextComponent

      • processInputMethodEvent

        protected void processInputMethodEvent(InputMethodEvent e)
        Description copied from class: Component
        Processes input method events occurring on this component by dispatching them to any registered InputMethodListener objects.

        This method is not called unless input method events are enabled for this component. Input method events are enabled when one of the following occurs:

        • An InputMethodListener object is registered via addInputMethodListener.
        • Input method events are enabled via enableEvents.

        Note that if the event parameter is null the behavior is unspecified and may result in an exception.

        重载：
        processInputMethodEvent in class Component
        参数：
        e - the input method event
        另请参见：
        InputMethodEvent, InputMethodListener, Component.addInputMethodListener(java.awt.event.InputMethodListener), Component.enableEvents(long)

      • getInputMethodRequests

        public InputMethodRequests getInputMethodRequests()
        Description copied from class: Component
        Gets the input method request handler which supports requests from input methods for this component. A component that supports on-the-spot text input must override this method to return an InputMethodRequests instance. At the same time, it also has to handle input method events.
        重载：
        getInputMethodRequests in class Component
        返回：
        the input method request handler for this component, null by default
        另请参见：
        Component.addInputMethodListener(java.awt.event.InputMethodListener)

      • addInputMethodListener

        public void addInputMethodListener(InputMethodListener l)
        Description copied from class: Component
        Adds the specified input method listener to receive input method events from this component. A component will only receive input method events from input methods if it also overrides getInputMethodRequests to return an InputMethodRequests instance. If listener l is null, no exception is thrown and no action is performed.

        Refer to AWT Threading Issues for details on AWT's threading model.

        重载：
        addInputMethodListener in class Component
        参数：
        l - the input method listener
        另请参见：
        InputMethodEvent,
InputMethodListener,
Component.removeInputMethodListener(java.awt.event.InputMethodListener),
Component.getInputMethodListeners(),
Component.getInputMethodRequests()

      • saveComposedText

        protected boolean saveComposedText(int pos)
        Saves composed text around the specified position. The composed text (if any) around the specified position is saved in a backing store and removed from the document.
        参数：
        pos - document position to identify the composed text location
        返回：
        true if the composed text exists and is saved, false otherwise
        从以下版本开始：
        1.7
        另请参见：
        restoreComposedText()

      • restoreComposedText

        protected void restoreComposedText()
        Restores composed text previously saved by saveComposedText. The saved composed text is inserted back into the document. This method should be invoked only if saveComposedText returns true.
        从以下版本开始：
        1.7
        另请参见：
        saveComposedText(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTextComponent.AccessibleJTextComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 JTextComponent.AccessibleJTextComponent

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent
            • javax.swing.text.JTextComponent.AccessibleJTextComponent
  • 所有已实现的接口：
    Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
    直接已知子类：
    JEditorPane.AccessibleJEditorPane, JTextArea.AccessibleJTextArea, JTextField.AccessibleJTextField
    封闭类：
    JTextComponent

    public class JTextComponent.AccessibleJTextComponent
extends JComponent.AccessibleJComponent
implements AccessibleText, CaretListener, DocumentListener, AccessibleAction, AccessibleEditableText, AccessibleExtendedText
    This class implements accessibility support for the JTextComponent class. It provides an implementation of the Java Accessibility API appropriate to menu user-interface elements.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JComponent.AccessibleJComponent

        JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler

      • Nested classes/interfaces inherited from class java.awt.Component.AccessibleAWTComponent

        Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

    • 字段摘要

      • Fields inherited from class javax.swing.JComponent.AccessibleJComponent

        accessibleContainerHandler, accessibleFocusHandler

      • Fields inherited from class java.awt.Component.AccessibleAWTComponent

        accessibleAWTComponentHandler, accessibleAWTFocusHandler

      • Fields inherited from class javax.accessibility.AccessibleContext

        ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent

      • 字段 - 继承于接口 javax.accessibility.AccessibleAction

        CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP

      • 字段 - 继承于接口 javax.accessibility.AccessibleText

        CHARACTER, SENTENCE, WORD

      • 字段 - 继承于接口 javax.accessibility.AccessibleExtendedText

        ATTRIBUTE_RUN, LINE

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextComponent.AccessibleJTextComponent()
      Constructs an AccessibleJTextComponent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void caretUpdate(CaretEvent e)
      Handles caret updates (fire appropriate property change event, which are AccessibleContext.ACCESSIBLE_CARET_PROPERTY and AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY).
      void changedUpdate(DocumentEvent e)
      Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void cut(int startIndex, int endIndex)
      Cuts the text between two indices into the system clipboard.
      void delete(int startIndex, int endIndex)
      Deletes the text between two indices
      boolean doAccessibleAction(int i)
      Performs the specified Action on the object
      AccessibleAction getAccessibleAction()
      Gets the AccessibleAction associated with this object that supports one or more actions.
      int getAccessibleActionCount()
      Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.
      String getAccessibleActionDescription(int i)
      Returns a description of the specified action of the object.
      AccessibleEditableText getAccessibleEditableText()
      Returns the AccessibleEditableText interface for this text component.
      AccessibleRole getAccessibleRole()
      Gets the role of this object.
      AccessibleStateSet getAccessibleStateSet()
      Gets the state set of the JTextComponent.
      AccessibleText getAccessibleText()
      Get the AccessibleText associated with this object.
      String getAfterIndex(int part, int index)
      Returns the String after a given index.
      String getAtIndex(int part, int index)
      Returns the String at a given index.
      String getBeforeIndex(int part, int index)
      Returns the String before a given index.
      int getCaretPosition()
      Returns the zero-based offset of the caret.
      AttributeSet getCharacterAttribute(int i)
      Returns the AttributeSet for a given character (at a given index).
      Rectangle getCharacterBounds(int i)
      Determines the bounding box of the character at the given index into the string.
      int getCharCount()
      Returns the number of characters (valid indices)
      int getIndexAtPoint(Point p)
      Given a point in local coordinates, return the zero-based index of the character under that Point.
      String getSelectedText()
      Returns the portion of the text that is selected.
      int getSelectionEnd()
      Returns the end offset within the selected text.
      int getSelectionStart()
      Returns the start offset within the selected text.
      Rectangle getTextBounds(int startIndex, int endIndex)
      Returns the Rectangle enclosing the text between two indicies.
      String getTextRange(int startIndex, int endIndex)
      Returns the text string between two indices.
      AccessibleTextSequence getTextSequenceAfter(int part, int index)
      Returns the AccessibleTextSequence after a given index.
      AccessibleTextSequence getTextSequenceAt(int part, int index)
      Returns the AccessibleTextSequence at a given index.
      AccessibleTextSequence getTextSequenceBefore(int part, int index)
      Returns the AccessibleTextSequence before a given index.
      void insertTextAtIndex(int index, String s)
      Inserts the specified string at the given index
      void insertUpdate(DocumentEvent e)
      Handles document insert (fire appropriate property change event which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void paste(int startIndex)
      Pastes the text from the system clipboard into the text starting at the specified index.
      void removeUpdate(DocumentEvent e)
      Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
      void replaceText(int startIndex, int endIndex, String s)
      Replaces the text between two indices with the specified string.
      void selectText(int startIndex, int endIndex)
      Selects the text between two indices.
      void setAttributes(int startIndex, int endIndex, AttributeSet as)
      Sets attributes for the text between two indices.
      void setTextContents(String s)
      Sets the text contents to the specified string.

      • 方法 - 继承于类 javax.swing.JComponent.AccessibleJComponent

        addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener

      • 方法 - 继承于类 java.awt.Container.AccessibleAWTContainer

        getAccessibleAt

      • 方法 - 继承于类 java.awt.Component.AccessibleAWTComponent

        addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

      • 方法 - 继承于类 javax.accessibility.AccessibleContext

        firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.accessibility.AccessibleComponent

        addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

    • 构造方法详细信息

      • JTextComponent.AccessibleJTextComponent

        public JTextComponent.AccessibleJTextComponent()
        Constructs an AccessibleJTextComponent. Adds a listener to track caret change.

    • 方法详细信息

      • caretUpdate

        public void caretUpdate(CaretEvent e)
        Handles caret updates (fire appropriate property change event, which are AccessibleContext.ACCESSIBLE_CARET_PROPERTY and AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY). This keeps track of the dot position internally. When the caret moves, the internal position is updated after firing the event.
        指定者：
        caretUpdate in interface CaretListener
        参数：
        e - the CaretEvent

      • insertUpdate

        public void insertUpdate(DocumentEvent e)
        Handles document insert (fire appropriate property change event which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY). This tracks the changed offset via the event.
        指定者：
        insertUpdate in interface DocumentListener
        参数：
        e - the DocumentEvent

      • removeUpdate

        public void removeUpdate(DocumentEvent e)
        Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY). This tracks the changed offset via the event.
        指定者：
        removeUpdate in interface DocumentListener
        参数：
        e - the DocumentEvent

      • changedUpdate

        public void changedUpdate(DocumentEvent e)
        Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY). This tracks the changed offset via the event.
        指定者：
        changedUpdate in interface DocumentListener
        参数：
        e - the DocumentEvent

      • getAccessibleStateSet

        public AccessibleStateSet getAccessibleStateSet()
        Gets the state set of the JTextComponent. The AccessibleStateSet of an object is composed of a set of unique AccessibleState's. A change in the AccessibleStateSet of an object will cause a PropertyChangeEvent to be fired for the AccessibleContext.ACCESSIBLE_STATE_PROPERTY property.
        重载：
        getAccessibleStateSet in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleStateSet containing the current state set of the object
        另请参见：
        AccessibleStateSet, AccessibleState, JComponent.AccessibleJComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

      • getAccessibleRole

        public AccessibleRole getAccessibleRole()
        Gets the role of this object.
        重载：
        getAccessibleRole in class JComponent.AccessibleJComponent
        返回：
        an instance of AccessibleRole describing the role of the object (AccessibleRole.TEXT)
        另请参见：
        AccessibleRole

      • getAccessibleText

        public AccessibleText getAccessibleText()
        Get the AccessibleText associated with this object. In the implementation of the Java Accessibility API for this class, return this object, which is responsible for implementing the AccessibleText interface on behalf of itself.
        重载：
        getAccessibleText in class AccessibleContext
        返回：
        this object
        另请参见：
        AccessibleText

      • getIndexAtPoint

        public int getIndexAtPoint(Point p)
        Given a point in local coordinates, return the zero-based index of the character under that Point. If the point is invalid, this method returns -1.
        指定者：
        getIndexAtPoint in interface AccessibleText
        参数：
        p - the Point in local coordinates
        返回：
        the zero-based index of the character under Point p.

      • getCharacterBounds

        public Rectangle getCharacterBounds(int i)
        Determines the bounding box of the character at the given index into the string. The bounds are returned in local coordinates. If the index is invalid a null rectangle is returned. The screen coordinates returned are "unscrolled coordinates" if the JTextComponent is contained in a JScrollPane in which case the resulting rectangle should be composed with the parent coordinates. A good algorithm to use is: Accessible a: AccessibleText at = a.getAccessibleText(); AccessibleComponent ac = a.getAccessibleComponent(); Rectangle r = at.getCharacterBounds(); Point p = ac.getLocation(); r.x += p.x; r.y += p.y; Note: the JTextComponent must have a valid size (e.g. have been added to a parent container whose ancestor container is a valid top-level window) for this method to be able to return a meaningful (non-null) value.
        指定者：
        getCharacterBounds in interface AccessibleText
        参数：
        i - the index into the String >= 0
        返回：
        the screen coordinates of the character's bounding box

      • getCharCount

        public int getCharCount()
        Returns the number of characters (valid indices)
        指定者：
        getCharCount in interface AccessibleText
        返回：
        the number of characters >= 0

      • getCaretPosition

        public int getCaretPosition()
        Returns the zero-based offset of the caret. Note: The character to the right of the caret will have the same index value as the offset (the caret is between two characters).
        指定者：
        getCaretPosition in interface AccessibleText
        返回：
        the zero-based offset of the caret.

      • getCharacterAttribute

        public AttributeSet getCharacterAttribute(int i)
        Returns the AttributeSet for a given character (at a given index).
        指定者：
        getCharacterAttribute in interface AccessibleText
        参数：
        i - the zero-based index into the text
        返回：
        the AttributeSet of the character

      • getSelectionStart

        public int getSelectionStart()
        Returns the start offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same. Return 0 if the text is empty, or the caret position if no selection.
        指定者：
        getSelectionStart in interface AccessibleText
        返回：
        the index into the text of the start of the selection >= 0

      • getSelectionEnd

        public int getSelectionEnd()
        Returns the end offset within the selected text. If there is no selection, but there is a caret, the start and end offsets will be the same. Return 0 if the text is empty, or the caret position if no selection.
        指定者：
        getSelectionEnd in interface AccessibleText
        返回：
        the index into teh text of the end of the selection >= 0

      • getSelectedText

        public String getSelectedText()
        Returns the portion of the text that is selected.
        指定者：
        getSelectedText in interface AccessibleText
        返回：
        the text, null if no selection

      • getAtIndex

        public String getAtIndex(int part,
                int index)
        Returns the String at a given index. Whitespace between words is treated as a word.
        指定者：
        getAtIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence.

      • getAfterIndex

        public String getAfterIndex(int part,
                   int index)
        Returns the String after a given index. Whitespace between words is treated as a word.
        指定者：
        getAfterIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence.

      • getBeforeIndex

        public String getBeforeIndex(int part,
                    int index)
        Returns the String before a given index. Whitespace between words is treated a word.
        指定者：
        getBeforeIndex in interface AccessibleText
        参数：
        part - the CHARACTER, WORD, or SENTENCE to retrieve
        index - an index within the text
        返回：
        the letter, word, or sentence.

      • getAccessibleEditableText

        public AccessibleEditableText getAccessibleEditableText()
        Returns the AccessibleEditableText interface for this text component.
        重载：
        getAccessibleEditableText in class AccessibleContext
        返回：
        the AccessibleEditableText interface
        从以下版本开始：
        1.4
        另请参见：
        AccessibleEditableText

      • setTextContents

        public void setTextContents(String s)
        Sets the text contents to the specified string.
        指定者：
        setTextContents in interface AccessibleEditableText
        参数：
        s - the string to set the text contents
        从以下版本开始：
        1.4

      • insertTextAtIndex

        public void insertTextAtIndex(int index,
                     String s)
        Inserts the specified string at the given index
        指定者：
        insertTextAtIndex in interface AccessibleEditableText
        参数：
        index - the index in the text where the string will be inserted
        s - the string to insert in the text
        从以下版本开始：
        1.4

      • getTextRange

        public String getTextRange(int startIndex,
                  int endIndex)
        Returns the text string between two indices.
        指定者：
        getTextRange in interface AccessibleEditableText
        指定者：
        getTextRange in interface AccessibleExtendedText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        返回：
        the text string between the indices
        从以下版本开始：
        1.4

      • delete

        public void delete(int startIndex,
          int endIndex)
        Deletes the text between two indices
        指定者：
        delete in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        从以下版本开始：
        1.4

      • cut

        public void cut(int startIndex,
       int endIndex)
        Cuts the text between two indices into the system clipboard.
        指定者：
        cut in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        从以下版本开始：
        1.4

      • paste

        public void paste(int startIndex)
        Pastes the text from the system clipboard into the text starting at the specified index.
        指定者：
        paste in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        从以下版本开始：
        1.4

      • replaceText

        public void replaceText(int startIndex,
               int endIndex,
               String s)
        Replaces the text between two indices with the specified string.
        指定者：
        replaceText in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        s - the string to replace the text between two indices
        从以下版本开始：
        1.4

      • selectText

        public void selectText(int startIndex,
              int endIndex)
        Selects the text between two indices.
        指定者：
        selectText in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        从以下版本开始：
        1.4

      • setAttributes

        public void setAttributes(int startIndex,
                 int endIndex,
                 AttributeSet as)
        Sets attributes for the text between two indices.
        指定者：
        setAttributes in interface AccessibleEditableText
        参数：
        startIndex - the starting index in the text
        endIndex - the ending index in the text
        as - the attribute set
        从以下版本开始：
        1.4
        另请参见：
        AttributeSet

      • getTextSequenceAt

        public AccessibleTextSequence getTextSequenceAt(int part,
                                       int index)
        Returns the AccessibleTextSequence at a given index.
        指定者：
        getTextSequenceAt in interface AccessibleExtendedText
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

      • getTextSequenceAfter

        public AccessibleTextSequence getTextSequenceAfter(int part,
                                          int index)
        Returns the AccessibleTextSequence after a given index.
        指定者：
        getTextSequenceAfter in interface AccessibleExtendedText
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

      • getTextSequenceBefore

        public AccessibleTextSequence getTextSequenceBefore(int part,
                                           int index)
        Returns the AccessibleTextSequence before a given index.
        指定者：
        getTextSequenceBefore in interface AccessibleExtendedText
        参数：
        part - the CHARACTER, WORD, SENTENCE, LINE or ATTRIBUTE_RUN to retrieve
        index - an index within the text
        返回：
        an AccessibleTextSequence specifying the text if part and index are valid. Otherwise, null is returned
        从以下版本开始：
        1.6
        另请参见：
        AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

      • getTextBounds

        public Rectangle getTextBounds(int startIndex,
                      int endIndex)
        Returns the Rectangle enclosing the text between two indicies.
        指定者：
        getTextBounds in interface AccessibleExtendedText
        参数：
        startIndex - the start index in the text
        endIndex - the end index in the text
        返回：
        the bounding rectangle of the text if the indices are valid. Otherwise, null is returned
        从以下版本开始：
        1.6

      • getAccessibleAction

        public AccessibleAction getAccessibleAction()
        Description copied from class: AccessibleContext
        Gets the AccessibleAction associated with this object that supports one or more actions.
        重载：
        getAccessibleAction in class AccessibleContext
        返回：
        AccessibleAction if supported by object; else return null
        另请参见：
        AccessibleAction

      • getAccessibleActionCount

        public int getAccessibleActionCount()
        Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.
        指定者：
        getAccessibleActionCount in interface AccessibleAction
        返回：
        the zero-based number of Actions in this object
        从以下版本开始：
        1.4

      • getAccessibleActionDescription

        public String getAccessibleActionDescription(int i)
        Returns a description of the specified action of the object.
        指定者：
        getAccessibleActionDescription in interface AccessibleAction
        参数：
        i - zero-based index of the actions
        返回：
        a String description of the action
        从以下版本开始：
        1.4
        另请参见：
        getAccessibleActionCount()

      • doAccessibleAction

        public boolean doAccessibleAction(int i)
        Performs the specified Action on the object
        指定者：
        doAccessibleAction in interface AccessibleAction
        参数：
        i - zero-based index of actions
        返回：
        true if the action was performed; otherwise false.
        从以下版本开始：
        1.4
        另请参见：
        getAccessibleActionCount()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


JTextComponent.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

类 JTextComponent.DropLocation

  • java.lang.Object
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
  • 封闭类：
    JTextComponent

    public static final class JTextComponent.DropLocation
extends TransferHandler.DropLocation
    Represents a drop location for JTextComponents.
    从以下版本开始：
    1.6
    另请参见：
    JTextComponent.getDropLocation()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Position.Bias getBias()
      Returns the bias for the drop index.
      int getIndex()
      Returns the index where dropped data should be inserted into the associated component.
      String toString()
      Returns a string representation of this drop location.

      • 方法 - 继承于类 javax.swing.TransferHandler.DropLocation

        getDropPoint

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getIndex

        public int getIndex()
        Returns the index where dropped data should be inserted into the associated component. This index represents a position between characters, as would be interpreted by a caret.
        返回：
        the drop index

      • getBias

        public Position.Bias getBias()
        Returns the bias for the drop index.
        返回：
        the drop bias

      • toString

        public String toString()
        Returns a string representation of this drop location. This method is intended to be used for debugging purposes, and the content and format of the returned string may vary between implementations.
        重载：
        toString in class TransferHandler.DropLocation
        返回：
        a string representation of this drop location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oFc " L> LkiiLkk"llloocJbbabelmmltnoba


JTextComponent.KeyBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.text

类 JTextComponent.KeyBinding

  • java.lang.Object
    • javax.swing.text.JTextComponent.KeyBinding
  • 封闭类：
    JTextComponent

    public static class JTextComponent.KeyBinding
extends Object
    Binding record for creating key bindings.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String actionName
      The name of the action for the key.
      KeyStroke key
      The key.

    • 构造方法摘要

      Constructors
      构造方法与描述
      JTextComponent.KeyBinding(KeyStroke key, String actionName)
      Creates a new key binding.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • key

        public KeyStroke key
        The key.

      • actionName

        public String actionName
        The name of the action for the key.

    • 构造方法详细信息

      • JTextComponent.KeyBinding

        public JTextComponent.KeyBinding(KeyStroke key,
                         String actionName)
        Creates a new key binding.
        参数：
        key - the key
        actionName - the name of the action for the key
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tvhndbn bnaddnaaaspppuihuooeunatpiere r o


Keymap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Keymap

  • public interface Keymap
    A collection of bindings of KeyStrokes to actions. The bindings are basically name-value pairs that potentially resolve in a hierarchy.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addActionForKeyStroke(KeyStroke key, Action a)
      Adds a binding to the keymap.
      Action getAction(KeyStroke key)
      Fetches the action appropriate for the given symbolic event sequence.
      Action[] getBoundActions()
      Fetches all of the actions defined in this keymap.
      KeyStroke[] getBoundKeyStrokes()
      Fetches all of the keystrokes in this map that are bound to some action.
      Action getDefaultAction()
      Fetches the default action to fire if a key is typed (i.e.
      KeyStroke[] getKeyStrokesForAction(Action a)
      Fetches the keystrokes that will result in the given action.
      String getName()
      Fetches the name of the set of key-bindings.
      Keymap getResolveParent()
      Fetches the parent keymap used to resolve key-bindings.
      boolean isLocallyDefined(KeyStroke key)
      Determines if the given key sequence is locally defined.
      void removeBindings()
      Removes all bindings from the keymap.
      void removeKeyStrokeBinding(KeyStroke keys)
      Removes a binding from the keymap.
      void setDefaultAction(Action a)
      Set the default action to fire if a key is typed.
      void setResolveParent(Keymap parent)
      Sets the parent keymap, which will be used to resolve key-bindings.

    • 方法详细信息

      • getName

        String getName()
        Fetches the name of the set of key-bindings.
        返回：
        the name

      • getDefaultAction

        Action getDefaultAction()
        Fetches the default action to fire if a key is typed (i.e. a KEY_TYPED KeyEvent is received) and there is no binding for it. Typically this would be some action that inserts text so that the keymap doesn't require an action for each possible key.
        返回：
        the default action

      • setDefaultAction

        void setDefaultAction(Action a)
        Set the default action to fire if a key is typed.
        参数：
        a - the action

      • getAction

        Action getAction(KeyStroke key)
        Fetches the action appropriate for the given symbolic event sequence. This is used by JTextController to determine how to interpret key sequences. If the binding is not resolved locally, an attempt is made to resolve through the parent keymap, if one is set.
        参数：
        key - the key sequence
        返回：
        the action associated with the key sequence if one is defined, otherwise null

      • getBoundKeyStrokes

        KeyStroke[] getBoundKeyStrokes()
        Fetches all of the keystrokes in this map that are bound to some action.
        返回：
        the list of keystrokes

      • getBoundActions

        Action[] getBoundActions()
        Fetches all of the actions defined in this keymap.
        返回：
        the list of actions

      • getKeyStrokesForAction

        KeyStroke[] getKeyStrokesForAction(Action a)
        Fetches the keystrokes that will result in the given action.
        参数：
        a - the action
        返回：
        the list of keystrokes

      • isLocallyDefined

        boolean isLocallyDefined(KeyStroke key)
        Determines if the given key sequence is locally defined.
        参数：
        key - the key sequence
        返回：
        true if the key sequence is locally defined else false

      • addActionForKeyStroke

        void addActionForKeyStroke(KeyStroke key,
                         Action a)
        Adds a binding to the keymap.
        参数：
        key - the key sequence
        a - the action

      • removeKeyStrokeBinding

        void removeKeyStrokeBinding(KeyStroke keys)
        Removes a binding from the keymap.
        参数：
        keys - the key sequence

      • removeBindings

        void removeBindings()
        Removes all bindings from the keymap.

      • getResolveParent

        Keymap getResolveParent()
        Fetches the parent keymap used to resolve key-bindings.
        返回：
        the keymap

      • setResolveParent

        void setResolveParent(Keymap parent)
        Sets the parent keymap, which will be used to resolve key-bindings. The behavior is unspecified if a Keymap has itself as one of its resolve parents.
        参数：
        parent - the parent keymap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

he dd oo dioltoecd n


LabelView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 LabelView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.GlyphView
        • javax.swing.text.LabelView
  • 所有已实现的接口：
    Cloneable, SwingConstants, TabableView
    直接已知子类：
    InlineView

    public class LabelView
extends GlyphView
implements TabableView
    A LabelView is a styled chunk of text that represents a view mapped over an element in the text model. It caches the character level attributes used for rendering.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.GlyphView

        GlyphView.GlyphPainter

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      LabelView(Element elem)
      Constructs a new view wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      Color getBackground()
      Fetches the background color to use to render the glyphs.
      Font getFont()
      Fetches the font that the glyphs should be based upon.
      protected FontMetrics getFontMetrics()
      Deprecated.
      FontMetrics are not used for glyph rendering when running in the JDK.
      Color getForeground()
      Fetches the foreground color to use to render the glyphs.
      boolean isStrikeThrough()
      Determines if the glyphs should have a strikethrough line.
      boolean isSubscript()
      Determines if the glyphs should be rendered as superscript.
      boolean isSuperscript()
      Determines if the glyphs should be rendered as subscript.
      boolean isUnderline()
      Determines if the glyphs should be underlined.
      protected void setBackground(Color bg)
      Sets the background color for the view.
      protected void setPropertiesFromAttributes()
      Sets the cached properties from the attributes.
      protected void setStrikeThrough(boolean s)
      Sets whether or not the view has a strike/line through it.
      protected void setSubscript(boolean s)
      Sets whether or not the view represents a subscript.
      protected void setSuperscript(boolean s)
      Sets whether or not the view represents a superscript.
      protected void setUnderline(boolean u)
      Sets whether or not the view is underlined.

      • 方法 - 继承于类 javax.swing.text.GlyphView

        breakView, checkPainter, clone, createFragment, getAlignment, getBreakWeight, getEndOffset, getGlyphPainter, getMinimumSpan, getNextVisualPositionFrom, getPartialSpan, getPreferredSpan, getStartOffset, getTabbedSpan, getTabExpander, getText, insertUpdate, modelToView, paint, removeUpdate, setGlyphPainter, viewToModel

      • 方法 - 继承于类 javax.swing.text.View

        append, forwardUpdate, forwardUpdateToView, getAttributes, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.TabableView

        getPartialSpan, getTabbedSpan

    • 构造方法详细信息

      • LabelView

        public LabelView(Element elem)
        Constructs a new view wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • setUnderline

        protected void setUnderline(boolean u)
        Sets whether or not the view is underlined. Note that this setter is protected and is really only meant if you need to update some additional state when set.
        参数：
        u - true if the view is underlined, otherwise false
        另请参见：
        isUnderline()

      • setStrikeThrough

        protected void setStrikeThrough(boolean s)
        Sets whether or not the view has a strike/line through it. Note that this setter is protected and is really only meant if you need to update some additional state when set.
        参数：
        s - true if the view has a strike/line through it, otherwise false
        另请参见：
        isStrikeThrough()

      • setSuperscript

        protected void setSuperscript(boolean s)
        Sets whether or not the view represents a superscript. Note that this setter is protected and is really only meant if you need to update some additional state when set.
        参数：
        s - true if the view represents a superscript, otherwise false
        另请参见：
        isSuperscript()

      • setSubscript

        protected void setSubscript(boolean s)
        Sets whether or not the view represents a subscript. Note that this setter is protected and is really only meant if you need to update some additional state when set.
        参数：
        s - true if the view represents a subscript, otherwise false
        另请参见：
        isSubscript()

      • setBackground

        protected void setBackground(Color bg)
        Sets the background color for the view. This method is typically invoked as part of configuring this View. If you need to customize the background color you should override setPropertiesFromAttributes and invoke this method. A value of null indicates no background should be rendered, so that the background of the parent View will show through.
        参数：
        bg - background color, or null
        从以下版本开始：
        1.5
        另请参见：
        setPropertiesFromAttributes()

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Sets the cached properties from the attributes.

      • getFontMetrics

        @Deprecated
protected FontMetrics getFontMetrics()
        Deprecated. FontMetrics are not used for glyph rendering when running in the JDK.
        Fetches the FontMetrics used for this view.

      • getBackground

        public Color getBackground()
        Fetches the background color to use to render the glyphs. This is implemented to return a cached background color, which defaults to null.
        重载：
        getBackground in class GlyphView
        返回：
        the cached background color
        从以下版本开始：
        1.3

      • getForeground

        public Color getForeground()
        Fetches the foreground color to use to render the glyphs. This is implemented to return a cached foreground color, which defaults to null.
        重载：
        getForeground in class GlyphView
        返回：
        the cached foreground color
        从以下版本开始：
        1.3

      • getFont

        public Font getFont()
        Fetches the font that the glyphs should be based upon. This is implemented to return a cached font.
        重载：
        getFont in class GlyphView
        返回：
        the cached font

      • isUnderline

        public boolean isUnderline()
        Determines if the glyphs should be underlined. If true, an underline should be drawn through the baseline. This is implemented to return the cached underline property.

        When you request this property, LabelView re-syncs its state with the properties of the Element's AttributeSet. If Element's AttributeSet does not have this property set, it will revert to false.

        重载：
        isUnderline in class GlyphView
        返回：
        the value of the cached underline property
        从以下版本开始：
        1.3

      • isStrikeThrough

        public boolean isStrikeThrough()
        Determines if the glyphs should have a strikethrough line. If true, a line should be drawn through the center of the glyphs. This is implemented to return the cached strikeThrough property.

        When you request this property, LabelView re-syncs its state with the properties of the Element's AttributeSet. If Element's AttributeSet does not have this property set, it will revert to false.

        重载：
        isStrikeThrough in class GlyphView
        返回：
        the value of the cached strikeThrough property
        从以下版本开始：
        1.3

      • isSubscript

        public boolean isSubscript()
        Determines if the glyphs should be rendered as superscript.
        重载：
        isSubscript in class GlyphView
        返回：
        the value of the cached subscript property

        When you request this property, LabelView re-syncs its state with the properties of the Element's AttributeSet. If Element's AttributeSet does not have this property set, it will revert to false.

        从以下版本开始：
        1.3

      • isSuperscript

        public boolean isSuperscript()
        Determines if the glyphs should be rendered as subscript.

        When you request this property, LabelView re-syncs its state with the properties of the Element's AttributeSet. If Element's AttributeSet does not have this property set, it will revert to false.

        重载：
        isSuperscript in class GlyphView
        返回：
        the value of the cached superscript property
        从以下版本开始：
        1.3

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class GlyphView
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i nc


LayeredHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 LayeredHighlighter

  • java.lang.Object
    • javax.swing.text.LayeredHighlighter
  • 所有已实现的接口：
    Highlighter
    直接已知子类：
    DefaultHighlighter

    public abstract class LayeredHighlighter
extends Object
implements Highlighter
    另请参见：
    Highlighter

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  LayeredHighlighter.LayerPainter
      Layered highlight renderer.

      • Nested classes/interfaces inherited from interface javax.swing.text.Highlighter

        Highlighter.Highlight, Highlighter.HighlightPainter

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayeredHighlighter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.Highlighter

        addHighlight, changeHighlight, deinstall, getHighlights, install, paint, removeAllHighlights, removeHighlight

    • 构造方法详细信息

      • LayeredHighlighter

        public LayeredHighlighter()

    • 方法详细信息

      • paintLayeredHighlights

        public abstract void paintLayeredHighlights(Graphics g,
                          int p0,
                          int p1,
                          Shape viewBounds,
                          JTextComponent editor,
                          View view)
        When leaf Views (such as LabelView) are rendering they should call into this method. If a highlight is in the given region it will be drawn immediately.
        参数：
        g - Graphics used to draw
        p0 - starting offset of view
        p1 - ending offset of view
        viewBounds - Bounds of View
        editor - JTextComponent
        view - View instance being rendered
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

re eok=ck=s""=ss d&&batwtiilsiSb)o"piirh/bgo


LayeredHighlighter.LayerPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 LayeredHighlighter.LayerPainter

  • java.lang.Object
    • javax.swing.text.LayeredHighlighter.LayerPainter
  • 所有已实现的接口：
    Highlighter.HighlightPainter
    直接已知子类：
    DefaultHighlighter.DefaultHighlightPainter
    封闭类：
    LayeredHighlighter

    public abstract static class LayeredHighlighter.LayerPainter
extends Object
implements Highlighter.HighlightPainter
    Layered highlight renderer.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayeredHighlighter.LayerPainter()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      abstract Shape | paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.Highlighter.HighlightPainter

        paint

    • 构造方法详细信息

      • LayeredHighlighter.LayerPainter

        public LayeredHighlighter.LayerPainter()

    • 方法详细信息

      • paintLayer

        public abstract Shape paintLayer(Graphics g,
               int p0,
               int p1,
               Shape viewBounds,
               JTextComponent editor,
               View view)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

riek=keacerfferr>/llsialBnnelle/vlRRarial


LayoutQueue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 LayoutQueue

  • java.lang.Object
    • javax.swing.text.LayoutQueue

  • public class LayoutQueue
extends Object
    A queue of text layout tasks.
    从以下版本开始：
    1.3
    另请参见：
    AsyncBoxView

    • 构造方法摘要

      Constructors
      构造方法与描述
      LayoutQueue()
      Construct a layout queue.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addTask(Runnable task)
      Add a task that is not needed immediately because the results are not believed to be visible.
      static LayoutQueue getDefaultQueue()
      Fetch the default layout queue.
      static void setDefaultQueue(LayoutQueue q)
      Set the default layout queue.
      protected Runnable waitForWork()
      Used by the worker thread to get a new task to execute

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LayoutQueue

        public LayoutQueue()
        Construct a layout queue.

    • 方法详细信息

      • getDefaultQueue

        public static LayoutQueue getDefaultQueue()
        Fetch the default layout queue.

      • setDefaultQueue

        public static void setDefaultQueue(LayoutQueue q)
        Set the default layout queue.
        参数：
        q - the new queue.

      • addTask

        public void addTask(Runnable task)
        Add a task that is not needed immediately because the results are not believed to be visible.

      • waitForWork

        protected Runnable waitForWork()
        Used by the worker thread to get a new task to execute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pc;e&u>�<<.oE


MaskFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 MaskFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
      • javax.swing.text.DefaultFormatter
        • javax.swing.text.MaskFormatter
  • 所有已实现的接口：
    Serializable, Cloneable

    public class MaskFormatter
extends DefaultFormatter
    MaskFormatter is used to format and edit strings. The behavior of a MaskFormatter is controlled by way of a String mask that specifies the valid characters that can be contained at a particular location in the Document model. The following characters can be specified:
    Character

    描述
    # Any valid number, uses Character.isDigit.
    ' Escape character, used to escape any of the special formatting characters.
    U | Any character (Character.isLetter). All lowercase letters are mapped to upper case.
    L | Any character (Character.isLetter). All upper case letters are mapped to lower case.
    A | Any character or number (Character.isLetter or Character.isDigit)
    ? Any character (Character.isLetter).
    * Anything.
    H | Any hex character (0-9, a-f or A-F).

    Typically characters correspond to one char, but in certain languages this is not the case. The mask is on a per character basis, and will thus adjust to fit as many chars as are needed.

    You can further restrict the characters that can be input by the setInvalidCharacters and setValidCharacters methods. setInvalidCharacters allows you to specify which characters are not legal. setValidCharacters allows you to specify which characters are valid. For example, the following code block is equivalent to a mask of '0xHHH' with no invalid/valid characters:

     MaskFormatter formatter = new MaskFormatter("0x***");
 formatter.setValidCharacters("0123456789abcdefABCDEF");

    When initially formatting a value if the length of the string is less than the length of the mask, two things can happen. Either the placeholder string will be used, or the placeholder character will be used. Precedence is given to the placeholder string. For example:

       MaskFormatter formatter = new MaskFormatter("###-####");
   formatter.setPlaceholderCharacter('_');
   formatter.getDisplayValue(tf, "123");

    Would result in the string '123-____'. If setPlaceholder("555-1212") was invoked '123-1212' would result. The placeholder String is only used on the initial format, on subsequent formats only the placeholder character will be used.

    If a MaskFormatter is configured to only allow valid characters (setAllowsInvalid(false)) literal characters will be skipped as necessary when editing. Consider a MaskFormatter with the mask "###-####" and current value "555-1212". Using the right arrow key to navigate through the field will result in (| indicates the position of the caret):

       |555-1212
   5|55-1212
   55|5-1212
   555-|1212
   555-1|212
    The '-' is a literal (non-editable) character, and is skipped.

    Similar behavior will result when editing. Consider inserting the string '123-45' and '12345' into the MaskFormatter in the previous example. Both inserts will result in the same String, '123-45__'. When MaskFormatter is processing the insert at character position 3 (the '-'), two things can happen:

    1. If the inserted character is '-', it is accepted.
    2. If the inserted character matches the mask for the next non-literal character, it is accepted at the new location.
    3. Anything else results in an invalid edit

    By default MaskFormatter will not allow invalid edits, you can change this with the setAllowsInvalid method, and will commit edits on valid edits (use the setCommitsOnValidEdit to change this).

    By default, MaskFormatter is in overwrite mode. That is as characters are typed a new character is not inserted, rather the character at the current location is replaced with the newly typed character. You can change this behavior by way of the method setOverwriteMode.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      MaskFormatter()
      Creates a MaskFormatter with no mask.
      MaskFormatter(String mask)
      Creates a MaskFormatter with the specified mask.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getInvalidCharacters()
      Returns the characters that are not valid for input.
      String getMask()
      Returns the formatting mask.
      String getPlaceholder()
      Returns the String to use if the value does not completely fill in the mask.
      char getPlaceholderCharacter()
      Returns the character to use in place of characters that are not present in the value, ie the user must fill them in.
      String getValidCharacters()
      Returns the valid characters that can be input.
      boolean getValueContainsLiteralCharacters()
      Returns true if stringToValue should return literal characters in the mask.
      void install(JFormattedTextField ftf)
      Installs the DefaultFormatter onto a particular JFormattedTextField.
      void setInvalidCharacters(String invalidCharacters)
      Allows for further restricting of the characters that can be input.
      void setMask(String mask)
      Sets the mask dictating the legal characters.
      void setPlaceholder(String placeholder)
      Sets the string to use if the value does not completely fill in the mask.
      void setPlaceholderCharacter(char placeholder)
      Sets the character to use in place of characters that are not present in the value, ie the user must fill them in.
      void setValidCharacters(String validCharacters)
      Allows for further restricting of the characters that can be input.
      void setValueContainsLiteralCharacters(boolean containsLiteralChars)
      If true, the returned value and set value will also contain the literal characters in mask.
      Object stringToValue(String value)
      Parses the text, returning the appropriate Object representation of the String value.
      String valueToString(Object value)
      Returns a String representation of the Object value based on the mask.

      • 方法 - 继承于类 javax.swing.text.DefaultFormatter

        clone, getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass

      • 方法 - 继承于类 javax.swing.JFormattedTextField.AbstractFormatter

        getActions, getFormattedTextField, invalidEdit, setEditValid, uninstall

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MaskFormatter

        public MaskFormatter()
        Creates a MaskFormatter with no mask.

      • MaskFormatter

        public MaskFormatter(String mask)
              throws ParseException
        Creates a MaskFormatter with the specified mask. A ParseException will be thrown if mask is an invalid mask.
        抛出：
        ParseException - if mask does not contain valid mask characters

    • 方法详细信息

      • setMask

        public void setMask(String mask)
             throws ParseException
        Sets the mask dictating the legal characters. This will throw a ParseException if mask is not valid.
        抛出：
        ParseException - if mask does not contain valid mask characters

      • getMask

        public String getMask()
        Returns the formatting mask.
        返回：
        Mask dictating legal character values.

      • setValidCharacters

        public void setValidCharacters(String validCharacters)
        Allows for further restricting of the characters that can be input. Only characters specified in the mask, not in the invalidCharacters, and in validCharacters will be allowed to be input. Passing in null (the default) implies the valid characters are only bound by the mask and the invalid characters.
        参数：
        validCharacters - If non-null, specifies legal characters.

      • getValidCharacters

        public String getValidCharacters()
        Returns the valid characters that can be input.
        返回：
        Legal characters

      • setInvalidCharacters

        public void setInvalidCharacters(String invalidCharacters)
        Allows for further restricting of the characters that can be input. Only characters specified in the mask, not in the invalidCharacters, and in validCharacters will be allowed to be input. Passing in null (the default) implies the valid characters are only bound by the mask and the valid characters.
        参数：
        invalidCharacters - If non-null, specifies illegal characters.

      • getInvalidCharacters

        public String getInvalidCharacters()
        Returns the characters that are not valid for input.
        返回：
        illegal characters.

      • setPlaceholder

        public void setPlaceholder(String placeholder)
        Sets the string to use if the value does not completely fill in the mask. A null value implies the placeholder char should be used.
        参数：
        placeholder - String used when formatting if the value does not completely fill the mask

      • getPlaceholder

        public String getPlaceholder()
        Returns the String to use if the value does not completely fill in the mask.
        返回：
        String used when formatting if the value does not completely fill the mask

      • setPlaceholderCharacter

        public void setPlaceholderCharacter(char placeholder)
        Sets the character to use in place of characters that are not present in the value, ie the user must fill them in. The default value is a space.

        This is only applicable if the placeholder string has not been specified, or does not completely fill in the mask.

        参数：
        placeholder - Character used when formatting if the value does not completely fill the mask

      • getPlaceholderCharacter

        public char getPlaceholderCharacter()
        Returns the character to use in place of characters that are not present in the value, ie the user must fill them in.
        返回：
        Character used when formatting if the value does not completely fill the mask

      • setValueContainsLiteralCharacters

        public void setValueContainsLiteralCharacters(boolean containsLiteralChars)
        If true, the returned value and set value will also contain the literal characters in mask.

        For example, if the mask is '(###) ###-####', the current value is '(415) 555-1212', and valueContainsLiteralCharacters is true stringToValue will return '(415) 555-1212'. On the other hand, if valueContainsLiteralCharacters is false, stringToValue will return '4155551212'.

        参数：
        containsLiteralChars - Used to indicate if literal characters in mask should be returned in stringToValue

      • getValueContainsLiteralCharacters

        public boolean getValueContainsLiteralCharacters()
        Returns true if stringToValue should return literal characters in the mask.
        返回：
        True if literal characters in mask should be returned in stringToValue

      • stringToValue

        public Object stringToValue(String value)
                     throws ParseException
        Parses the text, returning the appropriate Object representation of the String value. This strips the literal characters as necessary and invokes supers stringToValue, so that if you have specified a value class (setValueClass) an instance of it will be created. This will throw a ParseException if the value does not match the current mask. Refer to setValueContainsLiteralCharacters(boolean) for details on how literals are treated.
        重载：
        stringToValue in class DefaultFormatter
        参数：
        value - String to convert
        返回：
        Object representation of text
        抛出：
        ParseException - if there is an error in the conversion
        另请参见：
        setValueContainsLiteralCharacters(boolean)

      • valueToString

        public String valueToString(Object value)
                     throws ParseException
        Returns a String representation of the Object value based on the mask. Refer to setValueContainsLiteralCharacters(boolean) for details on how literals are treated.
        重载：
        valueToString in class DefaultFormatter
        参数：
        value - Value to convert
        返回：
        String representation of value
        抛出：
        ParseException - if there is an error in the conversion
        另请参见：
        setValueContainsLiteralCharacters(boolean)

      • install

        public void install(JFormattedTextField ftf)
        Installs the DefaultFormatter onto a particular JFormattedTextField. This will invoke valueToString to convert the current value from the JFormattedTextField to a String. This will then install the Actions from getActions, the DocumentFilter returned from getDocumentFilter and the NavigationFilter returned from getNavigationFilter onto the JFormattedTextField.

        Subclasses will typically only need to override this if they wish to install additional listeners on the JFormattedTextField.

        If there is a ParseException in converting the current value to a String, this will set the text to an empty String, and mark the JFormattedTextField as being in an invalid state.

        While this is a public method, this is typically only useful for subclassers of JFormattedTextField. JFormattedTextField will invoke this method at the appropriate times when the value changes, or its internal state changes.

        重载：
        install in class DefaultFormatter
        参数：
        ftf - JFormattedTextField to format for, may be null indicating uninstall from current JFormattedTextField.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

phl


MutableAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface MutableAttributeSet

  • All Superinterfaces:
    AttributeSet
    All Known Subinterfaces:
    Style
    All Known Implementing Classes:
    AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, SimpleAttributeSet, StyleContext.NamedStyle

    public interface MutableAttributeSet
extends AttributeSet
    A generic interface for a mutable collection of unique attributes. Implementations will probably want to provide a constructor of the form: public XXXAttributeSet(ConstAttributeSet source);

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(Object name, Object value)
      Creates a new attribute set similar to this one except that it contains an attribute with the given name and value.
      void addAttributes(AttributeSet attributes)
      Creates a new attribute set similar to this one except that it contains the given attributes and values.
      void removeAttribute(Object name)
      Removes an attribute with the given name.
      void removeAttributes(AttributeSet attributes)
      Removes a set of attributes with the given name.
      void removeAttributes(Enumeration<?> names)
      Removes an attribute set with the given names.
      void setResolveParent(AttributeSet parent)
      Sets the resolving parent.

      • 方法 - 继承于接口 javax.swing.text.AttributeSet

        containsAttribute, containsAttributes, copyAttributes, getAttribute, getAttributeCount, getAttributeNames, getResolveParent, isDefined, isEqual

    • 方法详细信息

      • addAttribute

        void addAttribute(Object name,
                Object value)
        Creates a new attribute set similar to this one except that it contains an attribute with the given name and value. The object must be immutable, or not mutated by any client.
        参数：
        name - the name
        value - the value

      • addAttributes

        void addAttributes(AttributeSet attributes)
        Creates a new attribute set similar to this one except that it contains the given attributes and values.
        参数：
        attributes - the set of attributes

      • removeAttribute

        void removeAttribute(Object name)
        Removes an attribute with the given name.
        参数：
        name - the attribute name

      • removeAttributes

        void removeAttributes(Enumeration<?> names)
        Removes an attribute set with the given names.
        参数：
        names - the set of names

      • removeAttributes

        void removeAttributes(AttributeSet attributes)
        Removes a set of attributes with the given name.
        参数：
        attributes - the set of attributes

      • setResolveParent

        void setResolveParent(AttributeSet parent)
        Sets the resolving parent. This is the set of attributes to resolve through if an attribute isn't defined locally.
        参数：
        parent - the parent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o nlhmttmtteetttF/xx tss.svtu..itr>


NavigationFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 NavigationFilter

  • java.lang.Object
    • javax.swing.text.NavigationFilter

  • public class NavigationFilter
extends Object
    NavigationFilter can be used to restrict where the cursor can be positioned. When the default cursor positioning actions attempt to reposition the cursor they will call into the NavigationFilter, assuming the JTextComponent has a non-null NavigationFilter set. In this manner the NavigationFilter can effectively restrict where the cursor can be positioned. Similarly DefaultCaret will call into the NavigationFilter when the user is changing the selection to further restrict where the cursor can be positioned.

    Subclasses can conditionally call into supers implementation to restrict where the cursor can be placed, or call directly into the FilterBypass.

    从以下版本开始：
    1.4
    另请参见：
    Caret, DefaultCaret, View

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  NavigationFilter.FilterBypass
      Used as a way to circumvent calling back into the caret to position the cursor.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NavigationFilter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
      Returns the next visual position to place the caret at from an existing position.
      void moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret moving the dot.
      void setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret setting the dot.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NavigationFilter

        public NavigationFilter()

    • 方法详细信息

      • setDot

        public void setDot(NavigationFilter.FilterBypass fb,
          int dot,
          Position.Bias bias)
        Invoked prior to the Caret setting the dot. The default implementation calls directly into the FilterBypass with the passed in arguments. Subclasses may wish to conditionally call super with a different location, or invoke the necessary method on the FilterBypass
        参数：
        fb - FilterBypass that can be used to mutate caret position
        dot - the position >= 0
        bias - Bias to place the dot at

      • moveDot

        public void moveDot(NavigationFilter.FilterBypass fb,
           int dot,
           Position.Bias bias)
        Invoked prior to the Caret moving the dot. The default implementation calls directly into the FilterBypass with the passed in arguments. Subclasses may wish to conditionally call super with a different location, or invoke the necessary methods on the FilterBypass.
        参数：
        fb - FilterBypass that can be used to mutate caret position
        dot - the position >= 0
        bias - Bias for new location

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(JTextComponent text,
                            int pos,
                            Position.Bias bias,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Returns the next visual position to place the caret at from an existing position. The default implementation simply forwards the method to the root View. Subclasses may wish to further restrict the location based on additional criteria.
        参数：
        text - JTextComponent containing text
        pos - Position used in determining next position
        bias - Bias used in determining next position
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This will be one of the following values:
        • SwingConstants.WEST
        • SwingConstants.EAST
        • SwingConstants.NORTH
        • SwingConstants.SOUTH
        biasRet - Used to return resulting Bias of next position
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException
        IllegalArgumentException - if direction doesn't have one of the legal values above
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tse>utuadl>bsaseed.ar


NavigationFilter.FilterBypass

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 NavigationFilter.FilterBypass

  • java.lang.Object
    • javax.swing.text.NavigationFilter.FilterBypass
  • 封闭类：
    NavigationFilter

    public abstract static class NavigationFilter.FilterBypass
extends Object
    Used as a way to circumvent calling back into the caret to position the cursor. Caret implementations that wish to support a NavigationFilter must provide an implementation that will not callback into the NavigationFilter.
    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      NavigationFilter.FilterBypass()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Caret getCaret()
      Returns the Caret that is changing.
      abstract void moveDot(int dot, Position.Bias bias)
      Moves the caret location, bypassing the NavigationFilter.
      abstract void setDot(int dot, Position.Bias bias)
      Sets the caret location, bypassing the NavigationFilter.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NavigationFilter.FilterBypass

        public NavigationFilter.FilterBypass()

    • 方法详细信息

      • getCaret

        public abstract Caret getCaret()
        Returns the Caret that is changing.
        返回：
        Caret that is changing

      • setDot

        public abstract void setDot(int dot,
          Position.Bias bias)
        Sets the caret location, bypassing the NavigationFilter.
        参数：
        dot - the position >= 0
        bias - Bias to place the dot at

      • moveDot

        public abstract void moveDot(int dot,
           Position.Bias bias)
        Moves the caret location, bypassing the NavigationFilter.
        参数：
        dot - the position >= 0
        bias - Bias for new location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.>tPrnarnoggnoo=a e e ettxhnncihea <


NumberFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 NumberFormatter

  • java.lang.Object
    • javax.swing.JFormattedTextField.AbstractFormatter
      • javax.swing.text.DefaultFormatter
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.NumberFormatter
  • 所有已实现的接口：
    Serializable, Cloneable

    public class NumberFormatter
extends InternationalFormatter
    NumberFormatter subclasses InternationalFormatter adding special behavior for numbers. Among the specializations are (these are only used if the NumberFormatter does not display invalid nubers, eg setAllowsInvalid(false)):
    • Pressing +/- (- is determined from the DecimalFormatSymbols associated with the DecimalFormat) in any field but the exponent field will attempt to change the sign of the number to positive/negative.
    • Pressing +/- (- is determined from the DecimalFormatSymbols associated with the DecimalFormat) in the exponent field will attemp to change the sign of the exponent to positive/negative.

    If you are displaying scientific numbers, you may wish to turn on overwrite mode, setOverwriteMode(true). For example:

     DecimalFormat decimalFormat = new DecimalFormat("0.000E0");
 NumberFormatter textFormatter = new NumberFormatter(decimalFormat);
 textFormatter.setOverwriteMode(true);
 textFormatter.setAllowsInvalid(false);

    If you are going to allow the user to enter decimal values, you should either force the DecimalFormat to contain at least one decimal (#.0###), or allow the value to be invalid setAllowsInvalid(true). Otherwise users may not be able to input decimal values.

    NumberFormatter provides slightly different behavior to stringToValue than that of its superclass. If you have specified a Class for values, DefaultFormatter.setValueClass(java.lang.Class), that is one of of Integer, Long, Float, Double, Byte or Short and the Format's parseObject returns an instance of Number, the corresponding instance of the value class will be created using the constructor appropriate for the primitive type the value class represents. For example: setValueClass(Integer.class) will cause the resulting value to be created via new Integer(((Number)formatter.parseObject(string)).intValue()). This is typically useful if you wish to set a min/max value as the various Number implementations are generally not comparable to each other. This is also useful if for some reason you need a specific Number implementation for your values.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      NumberFormatter()
      Creates a NumberFormatter with the a default NumberFormat instance obtained from NumberFormat.getNumberInstance().
      NumberFormatter(NumberFormat format)
      Creates a NumberFormatter with the specified Format instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void setFormat(Format format)
      Sets the format that dictates the legal values that can be edited and displayed.

      • 方法 - 继承于类 javax.swing.text.InternationalFormatter

        clone, getActions, getFields, getFormat, getMaximum, getMinimum, install, setMaximum, setMinimum, stringToValue, valueToString

      • 方法 - 继承于类 javax.swing.text.DefaultFormatter

        getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass

      • 方法 - 继承于类 javax.swing.JFormattedTextField.AbstractFormatter

        getFormattedTextField, invalidEdit, setEditValid, uninstall

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NumberFormatter

        public NumberFormatter()
        Creates a NumberFormatter with the a default NumberFormat instance obtained from NumberFormat.getNumberInstance().

      • NumberFormatter

        public NumberFormatter(NumberFormat format)
        Creates a NumberFormatter with the specified Format instance.
        参数：
        format - Format used to dictate legal values

    • 方法详细信息

      • setFormat

        public void setFormat(Format format)
        Sets the format that dictates the legal values that can be edited and displayed.

        If you have used the nullary constructor the value of this property will be determined for the current locale by way of the NumberFormat.getNumberInstance() method.

        重载：
        setFormat in class InternationalFormatter
        参数：
        format - NumberFormat instance used to dictate legal values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

allra st s/elr kyab/u.<� shj r


ParagraphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 ParagraphView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView
  • 所有已实现的接口：
    SwingConstants, TabExpander
    直接已知子类：
    ParagraphView

    public class ParagraphView
extends FlowView
implements TabExpander
    View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc. It is basically a vertical box with a margin around it. The contents of the box are a bunch of rows which are special horizontal boxes. This view creates a collection of views that represent the child elements of the paragraph element. Each of these views are placed into a row directly if they will fit, otherwise the breakView method is called to try and carve the view into pieces that fit.
    另请参见：
    View

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.FlowView

        FlowView.FlowStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected int firstLineIndent
      Indentation for the first line, from the left inset.

      • Fields inherited from class javax.swing.text.FlowView

        layoutPool, layoutSpan, strategy

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParagraphView(Element elem)
      Constructs a ParagraphView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View breakView(int axis, float len, Shape a)
      Breaks this view on the given axis at the given length.
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      void changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected View createRow()
      Create a View that should be used to hold a a row's worth of children in a flow.
      protected int findOffsetToCharactersInString(char[] string, int start)
      Finds the next character in the document with a character in string, starting at offset start.
      protected boolean flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      int getBreakWeight(int axis, float len)
      Gets the break weight for a given location.
      protected int getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      Returns the closest model position to x.
      int getFlowSpan(int index)
      Fetches the constraining span to flow against for the given child index.
      int getFlowStart(int index)
      Fetches the location along the flow axis that the flow span will start at.
      protected View getLayoutView(int index)
      Returns the view at a given index.
      protected int getLayoutViewCount()
      Returns the number of views that this view is responsible for.
      protected int getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected float getPartialSize(int startOffset, int endOffset)
      Returns the size used by the views between startOffset and endOffset.
      protected float getTabBase()
      Returns where the tabs are calculated from.
      protected TabSet getTabSet()
      Gets the Tabset to be used in calculating tabs.
      float nextTabStop(float x, int tabOffset)
      Returns the next tab stop position given a reference position.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      protected void setFirstLineIndent(float fi)
      Sets the indent on the first line.
      protected void setJustification(int j)
      Sets the type of justification.
      protected void setLineSpacing(float ls)
      Sets the line spacing.
      protected void setPropertiesFromAttributes()
      Set the cached properties from the attributes.

      • 方法 - 继承于类 javax.swing.text.FlowView

        getFlowAxis, getViewIndexAtPosition, insertUpdate, layout, loadChildren, removeUpdate, setParent

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, forwardUpdate, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • firstLineIndent

        protected int firstLineIndent
        Indentation for the first line, from the left inset.

    • 构造方法详细信息

      • ParagraphView

        public ParagraphView(Element elem)
        Constructs a ParagraphView for the given element.
        参数：
        elem - the element that this view is responsible for

    • 方法详细信息

      • setJustification

        protected void setJustification(int j)
        Sets the type of justification.
        参数：
        j - one of the following values:
        • StyleConstants.ALIGN_LEFT
        • StyleConstants.ALIGN_CENTER
        • StyleConstants.ALIGN_RIGHT

      • setLineSpacing

        protected void setLineSpacing(float ls)
        Sets the line spacing.
        参数：
        ls - the value is a factor of the line hight

      • setFirstLineIndent

        protected void setFirstLineIndent(float fi)
        Sets the indent on the first line.
        参数：
        fi - the value in points

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Set the cached properties from the attributes.

      • getLayoutViewCount

        protected int getLayoutViewCount()
        Returns the number of views that this view is responsible for. The child views of the paragraph are rows which have been used to arrange pieces of the Views that represent the child elements. This is the number of views that have been tiled in two dimensions, and should be equivalent to the number of child elements to the element this view is responsible for.
        返回：
        the number of views that this ParagraphView is responsible for

      • getLayoutView

        protected View getLayoutView(int index)
        Returns the view at a given index. The child views of the paragraph are rows which have been used to arrange pieces of the Views that represent the child elements. This methods returns the view responsible for the child element index (prior to breaking). These are the Views that were produced from a factory (to represent the child elements) and used for layout.
        参数：
        index - the index of the desired view
        返回：
        the view at index

      • getNextNorthSouthVisualPositionFrom

        protected int getNextNorthSouthVisualPositionFrom(int pos,
                                      Position.Bias b,
                                      Shape a,
                                      int direction,
                                      Position.Bias[] biasRet)
                                           throws BadLocationException
        Returns the next visual position for the cursor, in either the east or west direction. Overridden from CompositeView.
        重载：
        getNextNorthSouthVisualPositionFrom in class CompositeView
        参数：
        pos - position into the model
        b - either Position.Bias.Forward or Position.Bias.Backward
        a - the allocated region to render into
        direction - either SwingConstants.NORTH or SwingConstants.SOUTH
        biasRet - an array containing the bias that were checked in this method
        返回：
        the location in the model that represents the next location visual position
        抛出：
        BadLocationException
        另请参见：
        CompositeView.getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

      • getClosestPositionTo

        protected int getClosestPositionTo(int pos,
                       Position.Bias b,
                       Shape a,
                       int direction,
                       Position.Bias[] biasRet,
                       int rowIndex,
                       int x)
                            throws BadLocationException
        Returns the closest model position to x. rowIndex gives the index of the view that corresponds that should be looked in.
        参数：
        pos - position into the model
        a - the allocated region to render into
        direction - one of the following values:
        • SwingConstants.NORTH
        • SwingConstants.SOUTH
        biasRet - an array containing the bias that were checked in this method
        rowIndex - the index of the view
        x - the x coordinate of interest
        返回：
        the closest model position to x
        抛出：
        BadLocationException

      • flipEastAndWestAtEnds

        protected boolean flipEastAndWestAtEnds(int position,
                            Position.Bias bias)
        Determines in which direction the next view lays. Consider the View at index n. Typically the Views are layed out from left to right, so that the View to the EAST will be at index n + 1, and the View to the WEST will be at index n - 1. In certain situations, such as with bidirectional text, it is possible that the View to EAST is not at index n + 1, but rather at index n - 1, or that the View to the WEST is not at index n - 1, but index n + 1. In this case this method would return true, indicating the Views are layed out in descending order.

        This will return true if the text is layed out right to left at position, otherwise false.

        重载：
        flipEastAndWestAtEnds in class BoxView
        参数：
        position - position into the model
        bias - either Position.Bias.Forward or Position.Bias.Backward
        返回：
        true if the text is layed out right to left at position, otherwise false.

      • getFlowSpan

        public int getFlowSpan(int index)
        Fetches the constraining span to flow against for the given child index.
        重载：
        getFlowSpan in class FlowView
        参数：
        index - the index of the view being queried
        返回：
        the constraining span for the given view at index
        从以下版本开始：
        1.3
        另请参见：
        FlowView.getFlowStart(int)

      • getFlowStart

        public int getFlowStart(int index)
        Fetches the location along the flow axis that the flow span will start at.
        重载：
        getFlowStart in class FlowView
        参数：
        index - the index of the view being queried
        返回：
        the location for the given view at index
        从以下版本开始：
        1.3
        另请参见：
        FlowView.getFlowSpan(int)

      • createRow

        protected View createRow()
        Create a View that should be used to hold a a row's worth of children in a flow.
        指定者：
        createRow in class FlowView
        返回：
        the new View
        从以下版本开始：
        1.3

      • nextTabStop

        public float nextTabStop(float x,
                int tabOffset)
        Returns the next tab stop position given a reference position. This view implements the tab coordinate system, and calls getTabbedSpan on the logical children in the process of layout to determine the desired span of the children. The logical children can delegate their tab expansion upward to the paragraph which knows how to expand tabs. LabelView is an example of a view that delegates its tab expansion needs upward to the paragraph.

        This is implemented to try and locate a TabSet in the paragraph element's attribute set. If one can be found, its settings will be used, otherwise a default expansion will be provided. The base location for for tab expansion is the left inset from the paragraphs most recent allocation (which is what the layout of the children is based upon).

        指定者：
        nextTabStop in interface TabExpander
        参数：
        x - the X reference position
        tabOffset - the position within the text stream that the tab occurred at >= 0
        返回：
        the trailing end of the tab expansion >= 0
        另请参见：
        TabSet, TabStop, LabelView

      • getTabSet

        protected TabSet getTabSet()
        Gets the Tabset to be used in calculating tabs.
        返回：
        the TabSet

      • getPartialSize

        protected float getPartialSize(int startOffset,
                   int endOffset)
        Returns the size used by the views between startOffset and endOffset. This uses getPartialView to calculate the size if the child view implements the TabableView interface. If a size is needed and a View does not implement the TabableView interface, the preferredSpan will be used.
        参数：
        startOffset - the starting document offset >= 0
        endOffset - the ending document offset >= startOffset
        返回：
        the size >= 0

      • findOffsetToCharactersInString

        protected int findOffsetToCharactersInString(char[] string,
                                 int start)
        Finds the next character in the document with a character in string, starting at offset start. If there are no characters found, -1 will be returned.
        参数：
        string - the string of characters
        start - where to start in the model >= 0
        返回：
        the document offset, or -1 if no characters found

      • getTabBase

        protected float getTabBase()
        Returns where the tabs are calculated from.
        返回：
        where tabs are calculated from

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders using the given rendering surface and area on that surface. This is implemented to delgate to the superclass after stashing the base coordinate for tab calculations.
        重载：
        paint in class BoxView
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the alignment to the center of the first row along the y axis, and the default along the x axis.
        重载：
        getAlignment in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the desired alignment. This should be a value between 0.0 and 1.0 inclusive, where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin. An alignment of 0.5 would be the center of the view.

      • breakView

        public View breakView(int axis,
             float len,
             Shape a)
        Breaks this view on the given axis at the given length.

        ParagraphView instances are breakable along the Y_AXIS only, and only if len is after the first line.

        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        len - specifies where a potential break is desired along the given axis >= 0
        a - the current allocation of the view
        返回：
        the fragment of the view that represents the given span, if the view can be broken; if the view doesn't support breaking behavior, the view itself is returned
        另请参见：
        View.breakView(int, int, float, float)

      • getBreakWeight

        public int getBreakWeight(int axis,
                 float len)
        Gets the break weight for a given location.

        ParagraphView instances are breakable along the Y_AXIS only, and only if len is after the first row. If the length is less than one row, a value of BadBreakWeight is returned.

        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        len - specifies where a potential break is desired >= 0
        返回：
        a value indicating the attractiveness of breaking here; either GoodBreakWeight or BadBreakWeight
        另请参见：
        View.getBreakWeight(int, float, float)

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate the needs for the paragraph along the minor axis.

        This uses size requirements of the superclass, modified to take into account the non-breakable areas at the adjacent views edges. The minimal size requirements for such views should be no less than the sum of all adjacent fragments.

        If the axis parameter is neither View.X_AXIS nor View.Y_AXIS, IllegalArgumentException is thrown. If the r parameter is null, a new SizeRequirements object is created, otherwise the supplied SizeRequirements object is returned.

        重载：
        calculateMinorAxisRequirements in class FlowView
        参数：
        axis - the minor axis
        r - the input SizeRequirements object
        返回：
        the new or adjusted SizeRequirements object
        抛出：
        IllegalArgumentException - if the axis parameter is invalid
        另请参见：
        SizeRequirements

      • changedUpdate

        public void changedUpdate(DocumentEvent changes,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class FlowView
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


PasswordView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 PasswordView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.PlainView
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView
  • 所有已实现的接口：
    SwingConstants, TabExpander

    public class PasswordView
extends FieldView
    Implements a View suitable for use in JPasswordField UI implementations. This is basically a field ui that renders its contents as the echo character specified in the associated component (if it can narrow the component to a JPasswordField).
    另请参见：
    View

    • 字段摘要

      • Fields inherited from class javax.swing.text.PlainView

        metrics

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      PasswordView(Element elem)
      Constructs a new view wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected int drawEchoCharacter(Graphics g, int x, int y, char c)
      Renders the echo character, or whatever graphic should be used to display the password characters.
      protected int drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      int viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.FieldView

        adjustAllocation, getFontMetrics, getResizeWeight, insertUpdate, paint, removeUpdate

      • 方法 - 继承于类 javax.swing.text.PlainView

        changedUpdate, damageLineRange, drawLine, getLineBuffer, getTabSize, lineToRect, nextTabStop, setSize, updateDamage, updateMetrics

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PasswordView

        public PasswordView(Element elem)
        Constructs a new view wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • drawUnselectedText

        protected int drawUnselectedText(Graphics g,
                     int x,
                     int y,
                     int p0,
                     int p1)
                          throws BadLocationException
        Renders the given range in the model as normal unselected text. This sets the foreground color and echos the characters using the value returned by getEchoChar().
        重载：
        drawUnselectedText in class PlainView
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the starting offset in the model >= 0
        p1 - the ending offset in the model >= p0
        返回：
        the X location of the end of the range >= 0
        抛出：
        BadLocationException - if p0 or p1 are out of range

      • drawSelectedText

        protected int drawSelectedText(Graphics g,
                   int x,
                   int y,
                   int p0,
                   int p1)
                        throws BadLocationException
        Renders the given range in the model as selected text. This is implemented to render the text in the color specified in the hosting component. It assumes the highlighter will render the selected background. Uses the result of getEchoChar() to display the characters.
        重载：
        drawSelectedText in class PlainView
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the starting offset in the model >= 0
        p1 - the ending offset in the model >= p0
        返回：
        the X location of the end of the range >= 0
        抛出：
        BadLocationException - if p0 or p1 are out of range

      • drawEchoCharacter

        protected int drawEchoCharacter(Graphics g,
                    int x,
                    int y,
                    char c)
        Renders the echo character, or whatever graphic should be used to display the password characters. The color in the Graphics object is set to the appropriate foreground color for selected or unselected text.
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        c - the echo character
        返回：
        the updated X position >= 0

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        重载：
        modelToView in class FieldView
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float fx,
              float fy,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        重载：
        viewToModel in class FieldView
        参数：
        fx - the X coordinate >= 0.0f
        fy - the Y coordinate >= 0.0f
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point in the view
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        重载：
        getPreferredSpan in class FieldView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getPreferredSpan(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cmkc><= <== ====DCC liot ,,thsd>>


PlainDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 PlainDocument

  • java.lang.Object
    • javax.swing.text.AbstractDocument
      • javax.swing.text.PlainDocument
  • 所有已实现的接口：
    Serializable, Document

    public class PlainDocument
extends AbstractDocument
    A plain document that maintains no character attributes. The default element structure for this document is a map of the lines in the text. The Element returned by getDefaultRootElement is a map of the lines, and each child element represents a line. This model does not maintain any character level attributes, but each line can be tagged with an arbitrary set of attributes. Line to offset, and offset to line translations can be quickly performed using the default root element. The structure information of the DocumentEvent's fired by edits will indicate the line structure changes.

    The default content storage management is performed by a gapped buffer implementation (GapContent). It supports editing reasonably large documents with good efficiency when the edits are contiguous or clustered, as is typical.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    Document, AbstractDocument

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.AbstractDocument

        AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String lineLimitAttribute
      Name of the attribute that specifies the maximum length of a line, if there is a maximum length.
      static String tabSizeAttribute
      Name of the attribute that specifies the tab size for tabs contained in the content.

      • Fields inherited from class javax.swing.text.AbstractDocument

        BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName

      • 字段 - 继承于接口 javax.swing.text.Document

        StreamDescriptionProperty, TitleProperty

    • 构造方法摘要

      Constructors
      构造方法与描述
      PlainDocument()
      Constructs a plain text document.
      PlainDocument(AbstractDocument.Content c)
      Constructs a plain text document.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected AbstractDocument.AbstractElement createDefaultRoot()
      Creates the root element to be used to represent the default document structure.
      Element getDefaultRootElement()
      Gets the default root element for the document model.
      Element getParagraphElement(int pos)
      Get the paragraph element containing the given position.
      void insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument

        addDocumentListener, addUndoableEditListener, createBranchElement, createLeafElement, createPosition, dump, fireChangedUpdate, fireInsertUpdate, fireRemoveUpdate, fireUndoableEditUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeDocumentListener, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • tabSizeAttribute

        public static final String tabSizeAttribute
        Name of the attribute that specifies the tab size for tabs contained in the content. The type for the value is Integer.
        另请参见：
        Constant Field Values

      • lineLimitAttribute

        public static final String lineLimitAttribute
        Name of the attribute that specifies the maximum length of a line, if there is a maximum length. The type for the value is Integer.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • PlainDocument

        public PlainDocument()
        Constructs a plain text document. A default model using GapContent is constructed and set.

      • PlainDocument

        public PlainDocument(AbstractDocument.Content c)
        Constructs a plain text document. A default root element is created, and the tab size set to 8.
        参数：
        c - the container for the content

    • 方法详细信息

      • insertString

        public void insertString(int offs,
                String str,
                AttributeSet a)
                  throws BadLocationException
        Inserts some content into the document. Inserting content causes a write lock to be held while the actual changes are taking place, followed by notification to the observers on the thread that grabbed the write lock.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        insertString in interface Document
        重载：
        insertString in class AbstractDocument
        参数：
        offs - the starting offset >= 0
        str - the string to insert; does nothing with null/empty strings
        a - the attributes for the inserted content
        抛出：
        BadLocationException - the given insert position is not a valid position within the document
        另请参见：
        Document.insertString(int, java.lang.String, javax.swing.text.AttributeSet)

      • getDefaultRootElement

        public Element getDefaultRootElement()
        Gets the default root element for the document model.
        指定者：
        getDefaultRootElement in interface Document
        指定者：
        getDefaultRootElement in class AbstractDocument
        返回：
        the root
        另请参见：
        Document.getDefaultRootElement()

      • createDefaultRoot

        protected AbstractDocument.AbstractElement createDefaultRoot()
        Creates the root element to be used to represent the default document structure.
        返回：
        the element base

      • getParagraphElement

        public Element getParagraphElement(int pos)
        Get the paragraph element containing the given position. Since this document only models lines, it returns the line instead.
        指定者：
        getParagraphElement in class AbstractDocument
        参数：
        pos - the starting offset >= 0
        返回：
        the element

      • insertUpdate

        protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                AttributeSet attr)
        Updates document structure as a result of text insertion. This will happen within a write lock. Since this document simply maps out lines, we refresh the line map.
        重载：
        insertUpdate in class AbstractDocument
        参数：
        chng - the change event describing the dit
        attr - the set of attributes for the inserted text

      • removeUpdate

        protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
        Updates any document structure as a result of text removal. This will happen within a write lock. Since the structure represents a line map, this just checks to see if the removal spans lines. If it does, the two lines outside of the removal area are joined together.
        重载：
        removeUpdate in class AbstractDocument
        参数：
        chng - the change event describing the edit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i<


PlainView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 PlainView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.PlainView
  • 所有已实现的接口：
    SwingConstants, TabExpander
    直接已知子类：
    FieldView

    public class PlainView
extends View
implements TabExpander
    Implements View interface for a simple multi-line text view that has text in one font and color. The view represents each child element as a line of text.
    另请参见：
    View

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected FontMetrics metrics
      Font metrics for the current font.

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      PlainView(Element elem)
      Constructs a new PlainView wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected void damageLineRange(int line0, int line1, Shape a, Component host)
      Repaint the given line range.
      protected void drawLine(int lineIndex, Graphics g, int x, int y)
      Renders a line of text, suppressing whitespace at the end and expanding any tabs.
      protected int drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      protected Segment getLineBuffer()
      Gives access to a buffer that can be used to fetch text from the associated document.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      protected int getTabSize()
      Returns the tab size set for the document, defaulting to 8.
      void insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      protected Rectangle lineToRect(Shape a, int line)
      Determine the rectangle that represents the given line.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      float nextTabStop(float x, int tabOffset)
      Returns the next tab stop position after a given reference position.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      void removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void setSize(float width, float height)
      Sets the size of the view.
      protected void updateDamage(DocumentEvent changes, Shape a, ViewFactory f)
      Repaint the region of change covered by the given document event.
      protected void updateMetrics()
      Checks to see if the font metrics and longest line are up-to-date.
      int viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • metrics

        protected FontMetrics metrics
        Font metrics for the current font.

    • 构造方法详细信息

      • PlainView

        public PlainView(Element elem)
        Constructs a new PlainView wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • getTabSize

        protected int getTabSize()
        Returns the tab size set for the document, defaulting to 8.
        返回：
        the tab size

      • drawLine

        protected void drawLine(int lineIndex,
            Graphics g,
            int x,
            int y)
        Renders a line of text, suppressing whitespace at the end and expanding any tabs. This is implemented to make calls to the methods drawUnselectedText and drawSelectedText so that the way selected and unselected text are rendered can be customized.
        参数：
        lineIndex - the line to draw >= 0
        g - the Graphics context
        x - the starting X position >= 0
        y - the starting Y position >= 0
        另请参见：
        drawUnselectedText(java.awt.Graphics, int, int, int, int), drawSelectedText(java.awt.Graphics, int, int, int, int)

      • drawUnselectedText

        protected int drawUnselectedText(Graphics g,
                     int x,
                     int y,
                     int p0,
                     int p1)
                          throws BadLocationException
        Renders the given range in the model as normal unselected text. Uses the foreground or disabled color to render the text.
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the beginning position in the model >= 0
        p1 - the ending position in the model >= 0
        返回：
        the X location of the end of the range >= 0
        抛出：
        BadLocationException - if the range is invalid

      • drawSelectedText

        protected int drawSelectedText(Graphics g,
                   int x,
                   int y,
                   int p0,
                   int p1)
                        throws BadLocationException
        Renders the given range in the model as selected text. This is implemented to render the text in the color specified in the hosting component. It assumes the highlighter will render the selected background.
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the beginning position in the model >= 0
        p1 - the ending position in the model >= 0
        返回：
        the location of the end of the range
        抛出：
        BadLocationException - if the range is invalid

      • getLineBuffer

        protected final Segment getLineBuffer()
        Gives access to a buffer that can be used to fetch text from the associated document.
        返回：
        the buffer

      • updateMetrics

        protected void updateMetrics()
        Checks to see if the font metrics and longest line are up-to-date.
        从以下版本开始：
        1.4

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders using the given rendering surface and area on that surface. The view may need to do layout and create child views to enable itself to render into the given allocation.
        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert >= 0
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float fx,
              float fy,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        fx - the X coordinate >= 0
        fy - the Y coordinate >= 0
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point in the view >= 0
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • insertUpdate

        public void insertUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for.
        重载：
        insertUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for.
        重载：
        removeUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent changes,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view along the given axis, if it has any layout duties.
        重载：
        setSize in class View
        参数：
        width - the width >= 0
        height - the height >= 0

      • nextTabStop

        public float nextTabStop(float x,
                int tabOffset)
        Returns the next tab stop position after a given reference position. This implementation does not support things like centering so it ignores the tabOffset argument.
        指定者：
        nextTabStop in interface TabExpander
        参数：
        x - the current position >= 0
        tabOffset - the position within the text stream that the tab occurred at >= 0.
        返回：
        the tab stop, measured in points >= 0

      • updateDamage

        protected void updateDamage(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Repaint the region of change covered by the given document event. Damages the line that begins the range to cover the case when the insert/remove is only on one line. If lines are added or removed, damages the whole view. The longest line is checked to see if it has changed.
        从以下版本开始：
        1.4

      • damageLineRange

        protected void damageLineRange(int line0,
                   int line1,
                   Shape a,
                   Component host)
        Repaint the given line range.
        参数：
        host - the component hosting the view (used to call repaint)
        a - the region allocated for the view to render into
        line0 - the starting line number to repaint. This must be a valid line number in the model.
        line1 - the ending line number to repaint. This must be a valid line number in the model.
        从以下版本开始：
        1.4

      • lineToRect

        protected Rectangle lineToRect(Shape a,
                   int line)
        Determine the rectangle that represents the given line.
        参数：
        a - the region allocated for the view to render into
        line - the line number to find the region of. This must be a valid line number in the model.
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Position

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Position

  • public interface Position
    Represents a location within a document. It is intended to abstract away implementation details of the document and enable specification of positions within the document that are capable of tracking of change as the document is edited.

    A Position object points at a location between two characters. As the surrounding content is altered, the Position object adjusts its offset automatically to reflect the changes. If content is inserted or removed before the Position object's location, then the Position increments or decrements its offset, respectively, so as to point to the same location. If a portion of the document is removed that contains a Position's offset, then the Position's offset becomes that of the beginning of the removed region. For example, if a Position has an offset of 5 and the region 2-10 is removed, then the Position's offset becomes 2.

    Position with an offset of 0 is a special case. It never changes its offset while document content is altered.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Position.Bias
      A typesafe enumeration to indicate bias to a position in the model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getOffset()
      Fetches the current offset within the document.

    • 方法详细信息

      • getOffset

        int getOffset()
        Fetches the current offset within the document.
        返回：
        the offset >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

al>aea>a/岩构岩襱d..<�


Position.Bias

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

类 Position.Bias

  • java.lang.Object
    • javax.swing.text.Position.Bias
  • Enclosing interface:
    Position

    public static final class Position.Bias
extends Object
    A typesafe enumeration to indicate bias to a position in the model. A position indicates a location between two characters. The bias can be used to indicate an interest toward one of the two sides of the position in boundary conditions where a simple offset is ambiguous.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Position.Bias Backward
      Indicates a bias toward the previous character in the model.
      static Position.Bias Forward
      Indicates to bias toward the next character in the model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      string representation

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • Forward

        public static final Position.Bias Forward
        Indicates to bias toward the next character in the model.

      • Backward

        public static final Position.Bias Backward
        Indicates a bias toward the previous character in the model.

    • 方法详细信息

      • toString

        public String toString()
        string representation
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

occ >


Segment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 Segment

  • java.lang.Object
    • javax.swing.text.Segment
  • 所有已实现的接口：
    CharSequence, Cloneable, CharacterIterator

    public class Segment
extends Object
implements Cloneable, CharacterIterator, CharSequence
    A segment of a character array representing a fragment of text. It should be treated as immutable even though the array is directly accessible. This gives fast access to fragments of text without the overhead of copying around characters. This is effectively an unprotected String.

    The Segment implements the java.text.CharacterIterator interface to support use with the i18n support without copying text into a string.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      char[] array
      This is the array containing the text of interest.
      int count
      This is the number of array elements that make up the text of interest.
      int offset
      This is the offset into the array that the desired text begins.

      • 字段 - 继承于接口 java.text.CharacterIterator

        DONE

    • 构造方法摘要

      Constructors
      构造方法与描述
      Segment()
      Creates a new segment.
      Segment(char[] array, int offset, int count)
      Creates a new segment referring to an existing array.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      char charAt(int index)
      Returns the char value at the specified index.
      Object clone()
      Creates a shallow copy.
      char current()
      Gets the character at the current position (as returned by getIndex()).
      char first()
      Sets the position to getBeginIndex() and returns the character at that position.
      int getBeginIndex()
      Returns the start index of the text.
      int getEndIndex()
      Returns the end index of the text.
      int getIndex()
      Returns the current index.
      boolean isPartialReturn()
      Flag to indicate that partial returns are valid.
      char last()
      Sets the position to getEndIndex()-1 (getEndIndex() if the text is empty) and returns the character at that position.
      int length()
      Returns the length of this character sequence.
      char 下一个()
      Increments the iterator's index by one and returns the character at the new index.
      char previous()
      Decrements the iterator's index by one and returns the character at the new index.
      char setIndex(int position)
      Sets the position to the specified position in the text and returns that character.
      void setPartialReturn(boolean p)
      Flag to indicate that partial returns are valid.
      CharSequence subSequence(int start, int end)
      Returns a new CharSequence that is a subsequence of this sequence.
      String toString()
      Converts a segment into a String.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • array

        public char[] array
        This is the array containing the text of interest. This array should never be modified; it is available only for efficiency.

      • offset

        public int offset
        This is the offset into the array that the desired text begins.

      • count

        public int count
        This is the number of array elements that make up the text of interest.

    • 构造方法详细信息

      • Segment

        public Segment()
        Creates a new segment.

      • Segment

        public Segment(char[] array,
       int offset,
       int count)
        Creates a new segment referring to an existing array.
        参数：
        array - the array to refer to
        offset - the offset into the array
        count - the number of characters

    • 方法详细信息

      • setPartialReturn

        public void setPartialReturn(boolean p)
        Flag to indicate that partial returns are valid. If the flag is true, an implementation of the interface method Document.getText(position,length,Segment) should return as much text as possible without making a copy. The default state of the flag is false which will cause Document.getText(position,length,Segment) to provide the same return behavior it always had, which may or may not make a copy of the text depending upon the request.
        参数：
        p - whether or not partial returns are valid.
        从以下版本开始：
        1.4

      • isPartialReturn

        public boolean isPartialReturn()
        Flag to indicate that partial returns are valid.
        返回：
        whether or not partial returns are valid.
        从以下版本开始：
        1.4

      • toString

        public String toString()
        Converts a segment into a String.
        指定者：
        toString in interface CharSequence
        重载：
        toString in class Object
        返回：
        the string

      • first

        public char first()
        Sets the position to getBeginIndex() and returns the character at that position.
        指定者：
        first in interface CharacterIterator
        返回：
        the first character in the text, or DONE if the text is empty
        从以下版本开始：
        1.3
        另请参见：
        getBeginIndex()

      • last

        public char last()
        Sets the position to getEndIndex()-1 (getEndIndex() if the text is empty) and returns the character at that position.
        指定者：
        last in interface CharacterIterator
        返回：
        the last character in the text, or DONE if the text is empty
        从以下版本开始：
        1.3
        另请参见：
        getEndIndex()

      • current

        public char current()
        Gets the character at the current position (as returned by getIndex()).
        指定者：
        current in interface CharacterIterator
        返回：
        the character at the current position or DONE if the current position is off the end of the text.
        从以下版本开始：
        1.3
        另请参见：
        getIndex()

      • 下一个

        public char next()
        Increments the iterator's index by one and returns the character at the new index. If the resulting index is greater or equal to getEndIndex(), the current index is reset to getEndIndex() and a value of DONE is returned.
        指定者：
        下一个 in interface CharacterIterator
        返回：
        the character at the new position or DONE if the new position is off the end of the text range.
        从以下版本开始：
        1.3

      • previous

        public char previous()
        Decrements the iterator's index by one and returns the character at the new index. If the current index is getBeginIndex(), the index remains at getBeginIndex() and a value of DONE is returned.
        指定者：
        previous in interface CharacterIterator
        返回：
        the character at the new position or DONE if the current position is equal to getBeginIndex().
        从以下版本开始：
        1.3

      • setIndex

        public char setIndex(int position)
        Sets the position to the specified position in the text and returns that character.
        指定者：
        setIndex in interface CharacterIterator
        参数：
        position - the position within the text. Valid values range from getBeginIndex() to getEndIndex(). An IllegalArgumentException is thrown if an invalid value is supplied.
        返回：
        the character at the specified position or DONE if the specified position is equal to getEndIndex()
        从以下版本开始：
        1.3

      • getBeginIndex

        public int getBeginIndex()
        Returns the start index of the text.
        指定者：
        getBeginIndex in interface CharacterIterator
        返回：
        the index at which the text begins.
        从以下版本开始：
        1.3

      • getEndIndex

        public int getEndIndex()
        Returns the end index of the text. This index is the index of the first character following the end of the text.
        指定者：
        getEndIndex in interface CharacterIterator
        返回：
        the index after the last character in the text
        从以下版本开始：
        1.3

      • getIndex

        public int getIndex()
        Returns the current index.
        指定者：
        getIndex in interface CharacterIterator
        返回：
        the current index.
        从以下版本开始：
        1.3

      • charAt

        public char charAt(int index)
        Returns the char value at the specified index. An index ranges from zero to length() - 1. The first char value of the sequence is at index zero, the next at index one, and so on, as for array indexing.

        If the char value specified by the index is a surrogate, the surrogate value is returned.

        指定者：
        charAt in interface CharSequence
        参数：
        index - the index of the char value to be returned
        返回：
        the specified char value
        从以下版本开始：
        1.6

      • length

        public int length()
        Returns the length of this character sequence. The length is the number of 16-bit chars in the sequence.

        指定者：
        length in interface CharSequence
        返回：
        the number of chars in this sequence
        从以下版本开始：
        1.6

      • subSequence

        public CharSequence subSequence(int start,
                       int end)
        Returns a new CharSequence that is a subsequence of this sequence. The subsequence starts with the char value at the specified index and ends with the char value at index end - 1. The length (in chars) of the returned sequence is end - start, so if start == end then an empty sequence is returned.

        指定者：
        subSequence in interface CharSequence
        参数：
        start - the start index, inclusive
        end - the end index, exclusive
        返回：
        the specified subsequence
        从以下版本开始：
        1.6

      • clone

        public Object clone()
        Creates a shallow copy.
        指定者：
        clone in interface CharacterIterator
        重载：
        clone in class Object
        返回：
        the copy
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SimpleAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 SimpleAttributeSet

  • java.lang.Object
    • javax.swing.text.SimpleAttributeSet
  • 所有已实现的接口：
    Serializable, Cloneable, AttributeSet, MutableAttributeSet

    public class SimpleAttributeSet
extends Object
implements MutableAttributeSet, Serializable, Cloneable
    A straightforward implementation of MutableAttributeSet using a hash table.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static AttributeSet EMPTY
      An empty attribute set.

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      SimpleAttributeSet()
      Creates a new attribute set.
      SimpleAttributeSet(AttributeSet source)
      Creates a new attribute set based on a supplied set of attributes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(Object name, Object value)
      Adds an attribute to the list.
      void addAttributes(AttributeSet attributes)
      Adds a set of attributes to the list.
      Object clone()
      Clones a set of attributes.
      boolean containsAttribute(Object name, Object value)
      Checks whether the attribute list contains a specified attribute name/value pair.
      boolean containsAttributes(AttributeSet attributes)
      Checks whether the attribute list contains all the specified name/value pairs.
      AttributeSet copyAttributes()
      Makes a copy of the attributes.
      boolean equals(Object obj)
      Compares this object to the specified object.
      Object getAttribute(Object name)
      Gets the value of an attribute.
      int getAttributeCount()
      Gets a count of the number of attributes.
      Enumeration<?> getAttributeNames()
      Gets the names of the attributes in the set.
      AttributeSet getResolveParent()
      Gets the resolving parent.
      int hashCode()
      Returns a hashcode for this set of attributes.
      boolean isDefined(Object attrName)
      Tells whether a given attribute is defined.
      boolean isEmpty()
      Checks whether the set of attributes is empty.
      boolean isEqual(AttributeSet attr)
      Compares two attribute sets.
      void removeAttribute(Object name)
      Removes an attribute from the list.
      void removeAttributes(AttributeSet attributes)
      Removes a set of attributes from the list.
      void removeAttributes(Enumeration<?> names)
      Removes a set of attributes from the list.
      void setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      String toString()
      Converts the attribute set to a String.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EMPTY

        public static final AttributeSet EMPTY
        An empty attribute set.

    • 构造方法详细信息

      • SimpleAttributeSet

        public SimpleAttributeSet()
        Creates a new attribute set.

      • SimpleAttributeSet

        public SimpleAttributeSet(AttributeSet source)
        Creates a new attribute set based on a supplied set of attributes.
        参数：
        source - the set of attributes

    • 方法详细信息

      • isEmpty

        public boolean isEmpty()
        Checks whether the set of attributes is empty.
        返回：
        true if the set is empty else false

      • getAttributeCount

        public int getAttributeCount()
        Gets a count of the number of attributes.
        指定者：
        getAttributeCount in interface AttributeSet
        返回：
        the count

      • isDefined

        public boolean isDefined(Object attrName)
        Tells whether a given attribute is defined.
        指定者：
        isDefined in interface AttributeSet
        参数：
        attrName - the attribute name
        返回：
        true if the attribute is defined

      • isEqual

        public boolean isEqual(AttributeSet attr)
        Compares two attribute sets.
        指定者：
        isEqual in interface AttributeSet
        参数：
        attr - the second attribute set
        返回：
        true if the sets are equal, false otherwise

      • copyAttributes

        public AttributeSet copyAttributes()
        Makes a copy of the attributes.
        指定者：
        copyAttributes in interface AttributeSet
        返回：
        the copy

      • getAttributeNames

        public Enumeration<?> getAttributeNames()
        Gets the names of the attributes in the set.
        指定者：
        getAttributeNames in interface AttributeSet
        返回：
        the names as an Enumeration

      • getAttribute

        public Object getAttribute(Object name)
        Gets the value of an attribute.
        指定者：
        getAttribute in interface AttributeSet
        参数：
        name - the attribute name
        返回：
        the value

      • containsAttribute

        public boolean containsAttribute(Object name,
                        Object value)
        Checks whether the attribute list contains a specified attribute name/value pair.
        指定者：
        containsAttribute in interface AttributeSet
        参数：
        name - the name
        value - the value
        返回：
        true if the name/value pair is in the list

      • containsAttributes

        public boolean containsAttributes(AttributeSet attributes)
        Checks whether the attribute list contains all the specified name/value pairs.
        指定者：
        containsAttributes in interface AttributeSet
        参数：
        attributes - the attribute list
        返回：
        true if the list contains all the name/value pairs

      • addAttribute

        public void addAttribute(Object name,
                Object value)
        Adds an attribute to the list.
        指定者：
        addAttribute in interface MutableAttributeSet
        参数：
        name - the attribute name
        value - the attribute value

      • addAttributes

        public void addAttributes(AttributeSet attributes)
        Adds a set of attributes to the list.
        指定者：
        addAttributes in interface MutableAttributeSet
        参数：
        attributes - the set of attributes to add

      • removeAttribute

        public void removeAttribute(Object name)
        Removes an attribute from the list.
        指定者：
        removeAttribute in interface MutableAttributeSet
        参数：
        name - the attribute name

      • removeAttributes

        public void removeAttributes(Enumeration<?> names)
        Removes a set of attributes from the list.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        names - the set of names to remove

      • removeAttributes

        public void removeAttributes(AttributeSet attributes)
        Removes a set of attributes from the list.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        attributes - the set of attributes to remove

      • getResolveParent

        public AttributeSet getResolveParent()
        Gets the resolving parent. This is the set of attributes to resolve through if an attribute isn't defined locally. This is null if there are no other sets of attributes to resolve through.
        指定者：
        getResolveParent in interface AttributeSet
        返回：
        the parent

      • setResolveParent

        public void setResolveParent(AttributeSet parent)
        Sets the resolving parent.
        指定者：
        setResolveParent in interface MutableAttributeSet
        参数：
        parent - the parent

      • clone

        public Object clone()
        Clones a set of attributes.
        重载：
        clone in class Object
        返回：
        the new set of attributes
        另请参见：
        Cloneable

      • hashCode

        public int hashCode()
        Returns a hashcode for this set of attributes.
        重载：
        hashCode in class Object
        返回：
        a hashcode value for this set of attributes.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares this object to the specified object. The result is true if the object is an equivalent set of attributes.
        重载：
        equals in class Object
        参数：
        obj - the object to compare this attribute set with
        返回：
        true if the objects are equal; false otherwise
        另请参见：
        Object.hashCode(), HashMap

      • toString

        public String toString()
        Converts the attribute set to a String.
        重载：
        toString in class Object
        返回：
        the string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StringContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StringContent

  • java.lang.Object
    • javax.swing.text.StringContent
  • 所有已实现的接口：
    Serializable, AbstractDocument.Content

    public final class StringContent
extends Object
implements AbstractDocument.Content, Serializable
    An implementation of the AbstractDocument.Content interface that is a brute force implementation that is useful for relatively small documents and/or debugging. It manages the character content as a simple character array. It is also quite inefficient.

    It is generally recommended that the gap buffer or piece table implementations be used instead. This buffer does not scale up to large sizes.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringContent()
      Creates a new StringContent object.
      StringContent(int initialLength)
      Creates a new StringContent object, with the initial size specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Position createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      void getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      protected Vector getPositionsInRange(Vector v, int offset, int length)
      Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.
      String getString(int where, int len)
      Retrieves a portion of the content.
      UndoableEdit insertString(int where, String str)
      Inserts a string into the content.
      int length()
      Returns the length of the content.
      UndoableEdit remove(int where, int nitems)
      Removes part of the content.
      protected void updateUndoPositions(Vector positions)
      Resets the location for all the UndoPosRef instances in positions.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringContent

        public StringContent()
        Creates a new StringContent object. Initial size defaults to 10.

      • StringContent

        public StringContent(int initialLength)
        Creates a new StringContent object, with the initial size specified. If the length is < 1, a size of 1 is used.
        参数：
        initialLength - the initial size

    • 方法详细信息

      • length

        public int length()
        Returns the length of the content.
        指定者：
        length in interface AbstractDocument.Content
        返回：
        the length >= 1
        另请参见：
        AbstractDocument.Content.length()

      • insertString

        public UndoableEdit insertString(int where,
                        String str)
                          throws BadLocationException
        Inserts a string into the content.
        指定者：
        insertString in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0 && < length()
        str - the non-null string to insert
        返回：
        an UndoableEdit object for undoing
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.insertString(int, java.lang.String)

      • remove

        public UndoableEdit remove(int where,
                  int nitems)
                    throws BadLocationException
        Removes part of the content. where + nitems must be < length().
        指定者：
        remove in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0
        nitems - the number of characters to remove >= 0
        返回：
        an UndoableEdit object for undoing
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.remove(int, int)

      • getString

        public String getString(int where,
               int len)
                 throws BadLocationException
        Retrieves a portion of the content. where + len must be <= length().
        指定者：
        getString in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0
        len - the length to retrieve >= 0
        返回：
        a string representing the content; may be empty
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.getString(int, int)

      • getChars

        public void getChars(int where,
            int len,
            Segment chars)
              throws BadLocationException
        Retrieves a portion of the content. where + len must be <= length()
        指定者：
        getChars in interface AbstractDocument.Content
        参数：
        where - the starting position >= 0
        len - the number of characters to retrieve >= 0
        chars - the Segment object to return the characters in
        抛出：
        BadLocationException - if the specified position is invalid
        另请参见：
        AbstractDocument.Content.getChars(int, int, javax.swing.text.Segment)

      • createPosition

        public Position createPosition(int offset)
                        throws BadLocationException
        Creates a position within the content that will track change as the content is mutated.
        指定者：
        createPosition in interface AbstractDocument.Content
        参数：
        offset - the offset to create a position for >= 0
        返回：
        the position
        抛出：
        BadLocationException - if the specified position is invalid

      • getPositionsInRange

        protected Vector getPositionsInRange(Vector v,
                         int offset,
                         int length)
        Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length. If v is not null the matching Positions are placed in there. The vector with the resulting Positions are returned.

        This is meant for internal usage, and is generally not of interest to subclasses.

        参数：
        v - the Vector to use, with a new one created on null
        offset - the starting offset >= 0
        length - the length >= 0
        返回：
        the set of instances

      • updateUndoPositions

        protected void updateUndoPositions(Vector positions)
        Resets the location for all the UndoPosRef instances in positions.

        This is meant for internal usage, and is generally not of interest to subclasses.

        参数：
        positions - the positions of the instances
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>c >gg < h /es= llnn blbv


Style

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface Style

  • All Superinterfaces:
    AttributeSet, MutableAttributeSet
    All Known Implementing Classes:
    StyleContext.NamedStyle

    public interface Style
extends MutableAttributeSet
    A collection of attributes to associate with an element in a document. Since these are typically used to associate character and paragraph styles with the element, operations for this are provided. Other customized attributes that get associated with the element will effectively be name-value pairs that live in a hierarchy and if a name (key) is not found locally, the request is forwarded to the parent. Commonly used attributes are separated out to facilitate alternative implementations that are more efficient.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addChangeListener(ChangeListener l)
      Adds a listener to track whenever an attribute has been changed.
      String getName()
      Fetches the name of the style.
      void removeChangeListener(ChangeListener l)
      Removes a listener that was tracking attribute changes.

      • 方法 - 继承于接口 javax.swing.text.MutableAttributeSet

        addAttribute, addAttributes, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于接口 javax.swing.text.AttributeSet

        containsAttribute, containsAttributes, copyAttributes, getAttribute, getAttributeCount, getAttributeNames, getResolveParent, isDefined, isEqual

    • 方法详细信息

      • getName

        String getName()
        Fetches the name of the style. A style is not required to be named, so null is returned if there is no name associated with the style.
        返回：
        the name

      • addChangeListener

        void addChangeListener(ChangeListener l)
        Adds a listener to track whenever an attribute has been changed.
        参数：
        l - the change listener

      • removeChangeListener

        void removeChangeListener(ChangeListener l)
        Removes a listener that was tracking attribute changes.
        参数：
        l - the change listener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/setCu.Cucmmuccaxvvdd ilt>>arln韆snd


StyleConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

类 StyleConstants

  • java.lang.Object
    • javax.swing.text.StyleConstants
  • 直接已知子类：
    StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants

    public class StyleConstants
extends Object

    A collection of well known or common attribute keys and methods to apply to an AttributeSet or MutableAttributeSet to get/set the properties in a typesafe manner.

    The paragraph attributes form the definition of a paragraph to be rendered. All sizes are specified in points (such as found in postscript), a device independent measure.

    Diagram shows SpaceAbove, FirstLineIndent, LeftIndent, RightIndent, and SpaceBelow a paragraph.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  StyleConstants.CharacterConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a character style.
      static class  StyleConstants.ColorConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a color.
      static class  StyleConstants.FontConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a font.
      static class  StyleConstants.ParagraphConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ALIGN_CENTER
      A possible value for paragraph alignment.
      static int ALIGN_JUSTIFIED
      A possible value for paragraph alignment.
      static int ALIGN_LEFT
      A possible value for paragraph alignment.
      static int ALIGN_RIGHT
      A possible value for paragraph alignment.
      static Object Alignment
      Alignment for the paragraph.
      static Object Background
      Name of the background color attribute.
      static Object BidiLevel
      Bidirectional level of a character as assigned by the Unicode bidi algorithm.
      static Object Bold
      Name of the bold attribute.
      static Object ComponentAttribute
      Name of the component attribute.
      static String ComponentElementName
      Name of elements used to represent components.
      static Object ComposedTextAttribute
      Name of the input method composed text attribute.
      static Object Family
      Name of the font family.
      static Object FirstLineIndent
      The amount of space to indent the first line of the paragraph.
      static Object FontFamily
      Name of the font family.
      static Object FontSize
      Name of the font size.
      static Object Foreground
      Name of the foreground color attribute.
      static Object IconAttribute
      Name of the icon attribute.
      static String IconElementName
      Name of elements used to represent icons.
      static Object Italic
      Name of the italic attribute.
      static Object LeftIndent
      The amount to indent the left side of the paragraph.
      static Object LineSpacing
      The amount of space between lines of the paragraph.
      static Object ModelAttribute
      Attribute used to identify the model for embedded objects that have a model view separation.
      static Object NameAttribute
      Attribute name used to name the collection of attributes.
      static Object Orientation
      Orientation for a paragraph.
      static Object ResolveAttribute
      Attribute name used to identifiy the resolving parent set of attributes, if one is defined.
      static Object RightIndent
      The amount to indent the right side of the paragraph.
      static Object Size
      Name of the font size.
      static Object SpaceAbove
      The amount of space above the paragraph.
      static Object SpaceBelow
      The amount of space below the paragraph.
      static Object StrikeThrough
      Name of the Strikethrough attribute.
      static Object Subscript
      Name of the Subscript attribute.
      static Object Superscript
      Name of the Superscript attribute.
      static Object TabSet
      TabSet for the paragraph, type is a TabSet containing TabStops.
      static Object Underline
      Name of the underline attribute.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static int getAlignment(AttributeSet a)
      Gets the alignment setting.
      static Color getBackground(AttributeSet a)
      Gets the background color setting from the attribute list.
      static int getBidiLevel(AttributeSet a)
      Gets the BidiLevel setting.
      static Component getComponent(AttributeSet a)
      Gets the component setting from the attribute list.
      static float getFirstLineIndent(AttributeSet a)
      Gets the first line indent setting.
      static String getFontFamily(AttributeSet a)
      Gets the font family setting from the attribute list.
      static int getFontSize(AttributeSet a)
      Gets the font size setting from the attribute list.
      static Color getForeground(AttributeSet a)
      Gets the foreground color setting from the attribute list.
      static Icon getIcon(AttributeSet a)
      Gets the icon setting from the attribute list.
      static float getLeftIndent(AttributeSet a)
      Gets the left indent setting.
      static float getLineSpacing(AttributeSet a)
      Gets the line spacing setting.
      static float getRightIndent(AttributeSet a)
      Gets the right indent setting.
      static float getSpaceAbove(AttributeSet a)
      Gets the space above setting.
      static float getSpaceBelow(AttributeSet a)
      Gets the space below setting.
      static TabSet getTabSet(AttributeSet a)
      Gets the TabSet.
      static boolean isBold(AttributeSet a)
      Checks whether the bold attribute is set.
      static boolean isItalic(AttributeSet a)
      Checks whether the italic attribute is set.
      static boolean isStrikeThrough(AttributeSet a)
      Checks whether the strikethrough attribute is set.
      static boolean isSubscript(AttributeSet a)
      Checks whether the subscript attribute is set.
      static boolean isSuperscript(AttributeSet a)
      Checks whether the superscript attribute is set.
      static boolean isUnderline(AttributeSet a)
      Checks whether the underline attribute is set.
      static void setAlignment(MutableAttributeSet a, int align)
      Sets alignment.
      static void setBackground(MutableAttributeSet a, Color fg)
      Sets the background color.
      static void setBidiLevel(MutableAttributeSet a, int o)
      Sets the BidiLevel.
      static void setBold(MutableAttributeSet a, boolean b)
      Sets the bold attribute.
      static void setComponent(MutableAttributeSet a, Component c)
      Sets the component attribute.
      static void setFirstLineIndent(MutableAttributeSet a, float i)
      Sets the first line indent.
      static void setFontFamily(MutableAttributeSet a, String fam)
      Sets the font attribute.
      static void setFontSize(MutableAttributeSet a, int s)
      Sets the font size attribute.
      static void setForeground(MutableAttributeSet a, Color fg)
      Sets the foreground color.
      static void setIcon(MutableAttributeSet a, Icon c)
      Sets the icon attribute.
      static void setItalic(MutableAttributeSet a, boolean b)
      Sets the italic attribute.
      static void setLeftIndent(MutableAttributeSet a, float i)
      Sets left indent.
      static void setLineSpacing(MutableAttributeSet a, float i)
      Sets line spacing.
      static void setRightIndent(MutableAttributeSet a, float i)
      Sets right indent.
      static void setSpaceAbove(MutableAttributeSet a, float i)
      Sets space above.
      static void setSpaceBelow(MutableAttributeSet a, float i)
      Sets space below.
      static void setStrikeThrough(MutableAttributeSet a, boolean b)
      Sets the strikethrough attribute.
      static void setSubscript(MutableAttributeSet a, boolean b)
      Sets the subscript attribute.
      static void setSuperscript(MutableAttributeSet a, boolean b)
      Sets the superscript attribute.
      static void setTabSet(MutableAttributeSet a, TabSet tabs)
      Sets the TabSet.
      static void setUnderline(MutableAttributeSet a, boolean b)
      Sets the underline attribute.
      String toString()
      Returns the string representation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ComponentElementName

        public static final String ComponentElementName
        Name of elements used to represent components.
        另请参见：
        Constant Field Values

      • IconElementName

        public static final String IconElementName
        Name of elements used to represent icons.
        另请参见：
        Constant Field Values

      • NameAttribute

        public static final Object NameAttribute
        Attribute name used to name the collection of attributes.

      • ResolveAttribute

        public static final Object ResolveAttribute
        Attribute name used to identifiy the resolving parent set of attributes, if one is defined.

      • ModelAttribute

        public static final Object ModelAttribute
        Attribute used to identify the model for embedded objects that have a model view separation.

      • BidiLevel

        public static final Object BidiLevel
        Bidirectional level of a character as assigned by the Unicode bidi algorithm.

      • FontFamily

        public static final Object FontFamily
        Name of the font family.

      • Family

        public static final Object Family
        Name of the font family.
        从以下版本开始：
        1.5

      • FontSize

        public static final Object FontSize
        Name of the font size.

      • Size

        public static final Object Size
        Name of the font size.
        从以下版本开始：
        1.5

      • Bold

        public static final Object Bold
        Name of the bold attribute.

      • Italic

        public static final Object Italic
        Name of the italic attribute.

      • Underline

        public static final Object Underline
        Name of the underline attribute.

      • StrikeThrough

        public static final Object StrikeThrough
        Name of the Strikethrough attribute.

      • Superscript

        public static final Object Superscript
        Name of the Superscript attribute.

      • Subscript

        public static final Object Subscript
        Name of the Subscript attribute.

      • Foreground

        public static final Object Foreground
        Name of the foreground color attribute.

      • Background

        public static final Object Background
        Name of the background color attribute.

      • ComponentAttribute

        public static final Object ComponentAttribute
        Name of the component attribute.

      • IconAttribute

        public static final Object IconAttribute
        Name of the icon attribute.

      • ComposedTextAttribute

        public static final Object ComposedTextAttribute
        Name of the input method composed text attribute. The value of this attribute is an instance of AttributedString which represents the composed text.

      • FirstLineIndent

        public static final Object FirstLineIndent
        The amount of space to indent the first line of the paragraph. This value may be negative to offset in the reverse direction. The type is Float and specifies the size of the space in points.

      • LeftIndent

        public static final Object LeftIndent
        The amount to indent the left side of the paragraph. Type is float and specifies the size in points.

      • RightIndent

        public static final Object RightIndent
        The amount to indent the right side of the paragraph. Type is float and specifies the size in points.

      • LineSpacing

        public static final Object LineSpacing
        The amount of space between lines of the paragraph. Type is float and specifies the size as a factor of the line height

      • SpaceAbove

        public static final Object SpaceAbove
        The amount of space above the paragraph. Type is float and specifies the size in points.

      • SpaceBelow

        public static final Object SpaceBelow
        The amount of space below the paragraph. Type is float and specifies the size in points.

      • Alignment

        public static final Object Alignment
        Alignment for the paragraph. The type is Integer. Valid values are:
        • ALIGN_LEFT
        • ALIGN_RIGHT
        • ALIGN_CENTER
        • ALIGN_JUSTIFED

      • TabSet

        public static final Object TabSet
        TabSet for the paragraph, type is a TabSet containing TabStops.

      • Orientation

        public static final Object Orientation
        Orientation for a paragraph.

      • ALIGN_LEFT

        public static final int ALIGN_LEFT
        A possible value for paragraph alignment. This specifies that the text is aligned to the left indent and extra whitespace should be placed on the right.
        另请参见：
        Constant Field Values

      • ALIGN_CENTER

        public static final int ALIGN_CENTER
        A possible value for paragraph alignment. This specifies that the text is aligned to the center and extra whitespace should be placed equally on the left and right.
        另请参见：
        Constant Field Values

      • ALIGN_RIGHT

        public static final int ALIGN_RIGHT
        A possible value for paragraph alignment. This specifies that the text is aligned to the right indent and extra whitespace should be placed on the left.
        另请参见：
        Constant Field Values

      • ALIGN_JUSTIFIED

        public static final int ALIGN_JUSTIFIED
        A possible value for paragraph alignment. This specifies that extra whitespace should be spread out through the rows of the paragraph with the text lined up with the left and right indent except on the last line which should be aligned to the left.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • toString

        public String toString()
        Returns the string representation.
        重载：
        toString in class Object
        返回：
        the string

      • getBidiLevel

        public static int getBidiLevel(AttributeSet a)
        Gets the BidiLevel setting.
        参数：
        a - the attribute set
        返回：
        the value

      • setBidiLevel

        public static void setBidiLevel(MutableAttributeSet a,
                int o)
        Sets the BidiLevel.
        参数：
        a - the attribute set
        o - the bidi level value

      • getComponent

        public static Component getComponent(AttributeSet a)
        Gets the component setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the component, null if none

      • setComponent

        public static void setComponent(MutableAttributeSet a,
                Component c)
        Sets the component attribute.
        参数：
        a - the attribute set
        c - the component

      • getIcon

        public static Icon getIcon(AttributeSet a)
        Gets the icon setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the icon, null if none

      • setIcon

        public static void setIcon(MutableAttributeSet a,
           Icon c)
        Sets the icon attribute.
        参数：
        a - the attribute set
        c - the icon

      • getFontFamily

        public static String getFontFamily(AttributeSet a)
        Gets the font family setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the font family, "Monospaced" as the default

      • setFontFamily

        public static void setFontFamily(MutableAttributeSet a,
                 String fam)
        Sets the font attribute.
        参数：
        a - the attribute set
        fam - the font

      • getFontSize

        public static int getFontSize(AttributeSet a)
        Gets the font size setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the font size, 12 as the default

      • setFontSize

        public static void setFontSize(MutableAttributeSet a,
               int s)
        Sets the font size attribute.
        参数：
        a - the attribute set
        s - the font size

      • isBold

        public static boolean isBold(AttributeSet a)
        Checks whether the bold attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • setBold

        public static void setBold(MutableAttributeSet a,
           boolean b)
        Sets the bold attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • isItalic

        public static boolean isItalic(AttributeSet a)
        Checks whether the italic attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • setItalic

        public static void setItalic(MutableAttributeSet a,
             boolean b)
        Sets the italic attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • isUnderline

        public static boolean isUnderline(AttributeSet a)
        Checks whether the underline attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • isStrikeThrough

        public static boolean isStrikeThrough(AttributeSet a)
        Checks whether the strikethrough attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • isSuperscript

        public static boolean isSuperscript(AttributeSet a)
        Checks whether the superscript attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • isSubscript

        public static boolean isSubscript(AttributeSet a)
        Checks whether the subscript attribute is set.
        参数：
        a - the attribute set
        返回：
        true if set else false

      • setUnderline

        public static void setUnderline(MutableAttributeSet a,
                boolean b)
        Sets the underline attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • setStrikeThrough

        public static void setStrikeThrough(MutableAttributeSet a,
                    boolean b)
        Sets the strikethrough attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • setSuperscript

        public static void setSuperscript(MutableAttributeSet a,
                  boolean b)
        Sets the superscript attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • setSubscript

        public static void setSubscript(MutableAttributeSet a,
                boolean b)
        Sets the subscript attribute.
        参数：
        a - the attribute set
        b - specifies true/false for setting the attribute

      • getForeground

        public static Color getForeground(AttributeSet a)
        Gets the foreground color setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the color, Color.black as the default

      • setForeground

        public static void setForeground(MutableAttributeSet a,
                 Color fg)
        Sets the foreground color.
        参数：
        a - the attribute set
        fg - the color

      • getBackground

        public static Color getBackground(AttributeSet a)
        Gets the background color setting from the attribute list.
        参数：
        a - the attribute set
        返回：
        the color, Color.black as the default

      • setBackground

        public static void setBackground(MutableAttributeSet a,
                 Color fg)
        Sets the background color.
        参数：
        a - the attribute set
        fg - the color

      • getFirstLineIndent

        public static float getFirstLineIndent(AttributeSet a)
        Gets the first line indent setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setFirstLineIndent

        public static void setFirstLineIndent(MutableAttributeSet a,
                      float i)
        Sets the first line indent.
        参数：
        a - the attribute set
        i - the value

      • getRightIndent

        public static float getRightIndent(AttributeSet a)
        Gets the right indent setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setRightIndent

        public static void setRightIndent(MutableAttributeSet a,
                  float i)
        Sets right indent.
        参数：
        a - the attribute set
        i - the value

      • getLeftIndent

        public static float getLeftIndent(AttributeSet a)
        Gets the left indent setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setLeftIndent

        public static void setLeftIndent(MutableAttributeSet a,
                 float i)
        Sets left indent.
        参数：
        a - the attribute set
        i - the value

      • getLineSpacing

        public static float getLineSpacing(AttributeSet a)
        Gets the line spacing setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setLineSpacing

        public static void setLineSpacing(MutableAttributeSet a,
                  float i)
        Sets line spacing.
        参数：
        a - the attribute set
        i - the value

      • getSpaceAbove

        public static float getSpaceAbove(AttributeSet a)
        Gets the space above setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setSpaceAbove

        public static void setSpaceAbove(MutableAttributeSet a,
                 float i)
        Sets space above.
        参数：
        a - the attribute set
        i - the value

      • getSpaceBelow

        public static float getSpaceBelow(AttributeSet a)
        Gets the space below setting.
        参数：
        a - the attribute set
        返回：
        the value, 0 if not set

      • setSpaceBelow

        public static void setSpaceBelow(MutableAttributeSet a,
                 float i)
        Sets space below.
        参数：
        a - the attribute set
        i - the value

      • getAlignment

        public static int getAlignment(AttributeSet a)
        Gets the alignment setting.
        参数：
        a - the attribute set
        返回：
        the value StyleConstants.ALIGN_LEFT if not set

      • setAlignment

        public static void setAlignment(MutableAttributeSet a,
                int align)
        Sets alignment.
        参数：
        a - the attribute set
        align - the alignment value

      • getTabSet

        public static TabSet getTabSet(AttributeSet a)
        Gets the TabSet.
        参数：
        a - the attribute set
        返回：
        the TabSet

      • setTabSet

        public static void setTabSet(MutableAttributeSet a,
             TabSet tabs)
        Sets the TabSet.
        参数：
        a - the attribute set.
        tabs - the TabSet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


StyleConstants.CharacterConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

类 StyleConstants.CharacterConstants

  • java.lang.Object
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants
  • 所有已实现的接口：
    AttributeSet.CharacterAttribute
    封闭类：
    StyleConstants

    public static class StyleConstants.CharacterConstants
extends StyleConstants
implements AttributeSet.CharacterAttribute
    This is a typesafe enumeration of the well-known attributes that contribute to a character style. These are aliased by the outer class for general presentation.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.StyleConstants

        StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants

    • 字段摘要

      • Fields inherited from class javax.swing.text.StyleConstants

        ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.StyleConstants

        getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p-o a- ocddocce


StyleConstants.ColorConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

类 StyleConstants.ColorConstants

  • java.lang.Object
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.ColorConstants
  • 所有已实现的接口：
    AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute
    封闭类：
    StyleConstants

    public static class StyleConstants.ColorConstants
extends StyleConstants
implements AttributeSet.ColorAttribute, AttributeSet.CharacterAttribute
    This is a typesafe enumeration of the well-known attributes that contribute to a color. These are aliased by the outer class for general presentation.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.StyleConstants

        StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants

    • 字段摘要

      • Fields inherited from class javax.swing.text.StyleConstants

        ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.StyleConstants

        getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Bdawaawva./...//.a e� cteh⑻wh"鷛


StyleConstants.FontConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

类 StyleConstants.FontConstants

  • java.lang.Object
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.FontConstants
  • 所有已实现的接口：
    AttributeSet.CharacterAttribute, AttributeSet.FontAttribute
    封闭类：
    StyleConstants

    public static class StyleConstants.FontConstants
extends StyleConstants
implements AttributeSet.FontAttribute, AttributeSet.CharacterAttribute
    This is a typesafe enumeration of the well-known attributes that contribute to a font. These are aliased by the outer class for general presentation.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.StyleConstants

        StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants

    • 字段摘要

      • Fields inherited from class javax.swing.text.StyleConstants

        ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.StyleConstants

        getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//at>tdtBth>Bdaa./wwa.a.a..ea O蟚t


StyleConstants.ParagraphConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text

类 StyleConstants.ParagraphConstants

  • java.lang.Object
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.ParagraphConstants
  • 所有已实现的接口：
    AttributeSet.ParagraphAttribute
    封闭类：
    StyleConstants

    public static class StyleConstants.ParagraphConstants
extends StyleConstants
implements AttributeSet.ParagraphAttribute
    This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style. These are aliased by the outer class for general presentation.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.StyleConstants

        StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants

    • 字段摘要

      • Fields inherited from class javax.swing.text.StyleConstants

        ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline

    • 方法摘要

      • 方法 - 继承于类 javax.swing.text.StyleConstants

        getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n/hn>sg>s


StyleContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyleContext

  • java.lang.Object
    • javax.swing.text.StyleContext
  • 所有已实现的接口：
    Serializable, AbstractDocument.AttributeContext
    直接已知子类：
    StyleSheet

    public class StyleContext
extends Object
implements Serializable, AbstractDocument.AttributeContext
    A pool of styles and their associated resources. This class determines the lifetime of a group of resources by being a container that holds caches for various resources such as font and color that get reused by the various style definitions. This can be shared by multiple documents if desired to maximize the sharing of related resources.

    This class also provides efficient support for small sets of attributes and compresses them by sharing across uses and taking advantage of their immutable nature. Since many styles are replicated, the potential for sharing is significant, and copies can be extremely cheap. Larger sets reduce the possibility of sharing, and therefore revert automatically to a less space-efficient implementation.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  StyleContext.NamedStyle
      A collection of attributes, typically used to represent character and paragraph styles.
      class  StyleContext.SmallAttributeSet
      This class holds a small number of attributes in an array.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_STYLE
      The name given to the default logical style attached to paragraphs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyleContext()
      Creates a new StyleContext object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AttributeSet addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      void addChangeListener(ChangeListener l)
      Adds a listener to track when styles are added or removed.
      Style addStyle(String nm, Style parent)
      Adds a new style into the style hierarchy.
      protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
      Create a large set of attributes that should trade off space for time.
      protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
      Create a compact set of attributes that might be shared.
      Color getBackground(AttributeSet attr)
      Takes a set of attributes and turn it into a background color specification.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this StyleContext with addChangeListener().
      protected int getCompressionThreshold()
      Returns the maximum number of key/value pairs to try and compress into unique/immutable sets.
      static StyleContext getDefaultStyleContext()
      Returns default AttributeContext shared by all documents that don't bother to define/supply their own context.
      AttributeSet getEmptySet()
      Fetches an empty AttributeSet.
      Font getFont(AttributeSet attr)
      Gets the font from an attribute set.
      Font getFont(String family, int style, int size)
      Gets a new font.
      FontMetrics getFontMetrics(Font f)
      Returns font metrics for a font.
      Color getForeground(AttributeSet attr)
      Takes a set of attributes and turn it into a foreground color specification.
      static Object getStaticAttribute(Object key)
      Returns the object previously registered with registerStaticAttributeKey.
      static Object getStaticAttributeKey(Object key)
      Returns the String that key will be registered with
      Style getStyle(String nm)
      Fetches a named style previously added to the document
      Enumeration<?> getStyleNames()
      Fetches the names of the styles defined.
      void readAttributes(ObjectInputStream in, MutableAttributeSet a)
      Context-specific handling of reading in attributes
      static void readAttributeSet(ObjectInputStream in, MutableAttributeSet a)
      Reads a set of attributes from the given object input stream that have been previously written out with writeAttributeSet.
      void reclaim(AttributeSet a)
      Returns a set no longer needed by the MutableAttributeSet implmentation.
      static void registerStaticAttributeKey(Object key)
      Registers an object as a static object that is being used as a key in attribute sets.
      AttributeSet removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      AttributeSet removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      void removeChangeListener(ChangeListener l)
      Removes a listener that was tracking styles being added or removed.
      void removeStyle(String nm)
      Removes a named style previously added to the document.
      String toString()
      Converts a StyleContext to a String.
      void writeAttributes(ObjectOutputStream out, AttributeSet a)
      Context-specific handling of writing out attributes
      static void writeAttributeSet(ObjectOutputStream out, AttributeSet a)
      Writes a set of attributes to the given object stream for the purpose of serialization.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • DEFAULT_STYLE

        public static final String DEFAULT_STYLE
        The name given to the default logical style attached to paragraphs.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StyleContext

        public StyleContext()
        Creates a new StyleContext object.

    • 方法详细信息

      • getDefaultStyleContext

        public static final StyleContext getDefaultStyleContext()
        Returns default AttributeContext shared by all documents that don't bother to define/supply their own context.
        返回：
        the context

      • addStyle

        public Style addStyle(String nm,
             Style parent)
        Adds a new style into the style hierarchy. Style attributes resolve from bottom up so an attribute specified in a child will override an attribute specified in the parent.
        参数：
        nm - the name of the style (must be unique within the collection of named styles in the document). The name may be null if the style is unnamed, but the caller is responsible for managing the reference returned as an unnamed style can't be fetched by name. An unnamed style may be useful for things like character attribute overrides such as found in a style run.
        parent - the parent style. This may be null if unspecified attributes need not be resolved in some other style.
        返回：
        the created style

      • removeStyle

        public void removeStyle(String nm)
        Removes a named style previously added to the document.
        参数：
        nm - the name of the style to remove

      • getStyle

        public Style getStyle(String nm)
        Fetches a named style previously added to the document
        参数：
        nm - the name of the style
        返回：
        the style

      • getStyleNames

        public Enumeration<?> getStyleNames()
        Fetches the names of the styles defined.
        返回：
        the list of names as an enumeration

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a listener to track when styles are added or removed.
        参数：
        l - the change listener

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a listener that was tracking styles being added or removed.
        参数：
        l - the change listener

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this StyleContext with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • getFont

        public Font getFont(AttributeSet attr)
        Gets the font from an attribute set. This is implemented to try and fetch a cached font for the given AttributeSet, and if that fails the font features are resolved and the font is fetched from the low-level font cache.
        参数：
        attr - the attribute set
        返回：
        the font

      • getForeground

        public Color getForeground(AttributeSet attr)
        Takes a set of attributes and turn it into a foreground color specification. This might be used to specify things like brighter, more hue, etc. By default it simply returns the value specified by the StyleConstants.Foreground attribute.
        参数：
        attr - the set of attributes
        返回：
        the color

      • getBackground

        public Color getBackground(AttributeSet attr)
        Takes a set of attributes and turn it into a background color specification. This might be used to specify things like brighter, more hue, etc. By default it simply returns the value specified by the StyleConstants.Background attribute.
        参数：
        attr - the set of attributes
        返回：
        the color

      • getFont

        public Font getFont(String family,
           int style,
           int size)
        Gets a new font. This returns a Font from a cache if a cached font exists. If not, a Font is added to the cache. This is basically a low-level cache for 1.1 font features.
        参数：
        family - the font family (such as "Monospaced")
        style - the style of the font (such as Font.PLAIN)
        size - the point size >= 1
        返回：
        the new font

      • getFontMetrics

        public FontMetrics getFontMetrics(Font f)
        Returns font metrics for a font.
        参数：
        f - the font
        返回：
        the metrics

      • addAttribute

        public AttributeSet addAttribute(AttributeSet old,
                        Object name,
                        Object value)
        Adds an attribute to the given set, and returns the new representative set.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        addAttribute in interface AbstractDocument.AttributeContext
        参数：
        old - the old attribute set
        name - the non-null attribute name
        value - the attribute value
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        public AttributeSet addAttributes(AttributeSet old,
                         AttributeSet attr)
        Adds a set of attributes to the element.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        addAttributes in interface AbstractDocument.AttributeContext
        参数：
        old - the old attribute set
        attr - the attributes to add
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        public AttributeSet removeAttribute(AttributeSet old,
                           Object name)
        Removes an attribute from the set.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        removeAttribute in interface AbstractDocument.AttributeContext
        参数：
        old - the old set of attributes
        name - the non-null attribute name
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                            Enumeration<?> names)
        Removes a set of attributes for the element.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        removeAttributes in interface AbstractDocument.AttributeContext
        参数：
        old - the old attribute set
        names - the attribute names
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                            AttributeSet attrs)
        Removes a set of attributes for the element.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        removeAttributes in interface AbstractDocument.AttributeContext
        参数：
        old - the old attribute set
        attrs - the attributes
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • getEmptySet

        public AttributeSet getEmptySet()
        Fetches an empty AttributeSet.
        指定者：
        getEmptySet in interface AbstractDocument.AttributeContext
        返回：
        the set

      • reclaim

        public void reclaim(AttributeSet a)
        Returns a set no longer needed by the MutableAttributeSet implmentation. This is useful for operation under 1.1 where there are no weak references. This would typically be called by the finalize method of the MutableAttributeSet implementation.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        reclaim in interface AbstractDocument.AttributeContext
        参数：
        a - the set to reclaim

      • getCompressionThreshold

        protected int getCompressionThreshold()
        Returns the maximum number of key/value pairs to try and compress into unique/immutable sets. Any sets above this limit will use hashtables and be a MutableAttributeSet.
        返回：
        the threshold

      • createSmallAttributeSet

        protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
        Create a compact set of attributes that might be shared. This is a hook for subclasses that want to alter the behavior of SmallAttributeSet. This can be reimplemented to return an AttributeSet that provides some sort of attribute conversion.
        参数：
        a - The set of attributes to be represented in the the compact form.

      • createLargeAttributeSet

        protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
        Create a large set of attributes that should trade off space for time. This set will not be shared. This is a hook for subclasses that want to alter the behavior of the larger attribute storage format (which is SimpleAttributeSet by default). This can be reimplemented to return a MutableAttributeSet that provides some sort of attribute conversion.
        参数：
        a - The set of attributes to be represented in the the larger form.

      • toString

        public String toString()
        Converts a StyleContext to a String.
        重载：
        toString in class Object
        返回：
        the string

      • writeAttributes

        public void writeAttributes(ObjectOutputStream out,
                   AttributeSet a)
                     throws IOException
        Context-specific handling of writing out attributes
        抛出：
        IOException

      • readAttributes

        public void readAttributes(ObjectInputStream in,
                  MutableAttributeSet a)
                    throws ClassNotFoundException,
                           IOException
        Context-specific handling of reading in attributes
        抛出：
        ClassNotFoundException
        IOException

      • writeAttributeSet

        public static void writeAttributeSet(ObjectOutputStream out,
                     AttributeSet a)
                              throws IOException
        Writes a set of attributes to the given object stream for the purpose of serialization. This will take special care to deal with static attribute keys that have been registered wit the registerStaticAttributeKey method. Any attribute key not regsitered as a static key will be serialized directly. All values are expected to be serializable.
        参数：
        out - the output stream
        a - the attribute set
        抛出：
        IOException - on any I/O error

      • readAttributeSet

        public static void readAttributeSet(ObjectInputStream in,
                    MutableAttributeSet a)
                             throws ClassNotFoundException,
                                    IOException
        Reads a set of attributes from the given object input stream that have been previously written out with writeAttributeSet. This will try to restore keys that were static objects to the static objects in the current virtual machine considering only those keys that have been registered with the registerStaticAttributeKey method. The attributes retrieved from the stream will be placed into the given mutable set.
        参数：
        in - the object stream to read the attribute data from.
        a - the attribute set to place the attribute definitions in.
        抛出：
        ClassNotFoundException - passed upward if encountered when reading the object stream.
        IOException - passed upward if encountered when reading the object stream.

      • registerStaticAttributeKey

        public static void registerStaticAttributeKey(Object key)
        Registers an object as a static object that is being used as a key in attribute sets. This allows the key to be treated specially for serialization.

        For operation under a 1.1 virtual machine, this uses the value returned by toString concatenated to the classname. The value returned by toString should not have the class reference in it (ie it should be reimplemented from the definition in Object) in order to be the same when recomputed later.

        参数：
        key - the non-null object key

      • getStaticAttribute

        public static Object getStaticAttribute(Object key)
        Returns the object previously registered with registerStaticAttributeKey.

      • getStaticAttributeKey

        public static Object getStaticAttributeKey(Object key)
        Returns the String that key will be registered with
        另请参见：
        getStaticAttribute(java.lang.Object), registerStaticAttributeKey(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

botg


StyleContext.NamedStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyleContext.NamedStyle

  • java.lang.Object
    • javax.swing.text.StyleContext.NamedStyle
  • 所有已实现的接口：
    Serializable, AttributeSet, MutableAttributeSet, Style
    封闭类：
    StyleContext

    public class StyleContext.NamedStyle
extends Object
implements Style, Serializable
    A collection of attributes, typically used to represent character and paragraph styles. This is an implementation of MutableAttributeSet that can be observed if desired. These styles will take advantage of immutability while the sets are small enough, and may be substantially more efficient than something like SimpleAttributeSet.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected ChangeEvent changeEvent
      Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
      protected EventListenerList listenerList
      The change listeners for the model.

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyleContext.NamedStyle()
      Creates a new named style, with a null name and parent.
      StyleContext.NamedStyle(String name, Style parent)
      Creates a new named style.
      StyleContext.NamedStyle(Style parent)
      Creates a new named style.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(Object name, Object value)
      Adds an attribute.
      void addAttributes(AttributeSet attr)
      Adds a set of attributes to the element.
      void addChangeListener(ChangeListener l)
      Adds a change listener.
      boolean containsAttribute(Object name, Object value)
      Checks whether a given attribute name/value is defined.
      boolean containsAttributes(AttributeSet attrs)
      Checks whether the element contains all the attributes.
      AttributeSet copyAttributes()
      Copies a set of attributes.
      protected void fireStateChanged()
      Notifies all listeners that have registered interest for notification on this event type.
      Object getAttribute(Object attrName)
      Gets the value of an attribute.
      int getAttributeCount()
      Gets the number of attributes that are defined.
      Enumeration<?> getAttributeNames()
      Gets the names of all attributes.
      ChangeListener[] getChangeListeners()
      Returns an array of all the ChangeListeners added to this NamedStyle with addChangeListener().
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Return an array of all the listeners of the given type that were added to this model.
      String getName()
      Fetches the name of the style.
      AttributeSet getResolveParent()
      Gets attributes from the parent.
      boolean isDefined(Object attrName)
      Checks whether a given attribute is defined.
      boolean isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      void removeAttribute(Object name)
      Removes an attribute from the set.
      void removeAttributes(AttributeSet attrs)
      Removes a set of attributes for the element.
      void removeAttributes(Enumeration<?> names)
      Removes a set of attributes for the element.
      void removeChangeListener(ChangeListener l)
      Removes a change listener.
      void setName(String name)
      Changes the name of the style.
      void setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      String toString()
      Converts the style to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • listenerList

        protected EventListenerList listenerList
        The change listeners for the model.

      • changeEvent

        protected transient ChangeEvent changeEvent
        Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property. The source of events generated here is always "this".

    • 构造方法详细信息

      • StyleContext.NamedStyle

        public StyleContext.NamedStyle(String name,
                       Style parent)
        Creates a new named style.
        参数：
        name - the style name, null for unnamed
        parent - the parent style, null if none
        从以下版本开始：
        1.4

      • StyleContext.NamedStyle

        public StyleContext.NamedStyle(Style parent)
        Creates a new named style.
        参数：
        parent - the parent style, null if none
        从以下版本开始：
        1.4

      • StyleContext.NamedStyle

        public StyleContext.NamedStyle()
        Creates a new named style, with a null name and parent.

    • 方法详细信息

      • toString

        public String toString()
        Converts the style to a string.
        重载：
        toString in class Object
        返回：
        the string

      • getName

        public String getName()
        Fetches the name of the style. A style is not required to be named, so null is returned if there is no name associated with the style.
        指定者：
        getName in interface Style
        返回：
        the name

      • setName

        public void setName(String name)
        Changes the name of the style. Does nothing with a null name.
        参数：
        name - the new name

      • addChangeListener

        public void addChangeListener(ChangeListener l)
        Adds a change listener.
        指定者：
        addChangeListener in interface Style
        参数：
        l - the change listener

      • removeChangeListener

        public void removeChangeListener(ChangeListener l)
        Removes a change listener.
        指定者：
        removeChangeListener in interface Style
        参数：
        l - the change listener

      • getChangeListeners

        public ChangeListener[] getChangeListeners()
        Returns an array of all the ChangeListeners added to this NamedStyle with addChangeListener().
        返回：
        all of the ChangeListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • fireStateChanged

        protected void fireStateChanged()
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        另请参见：
        EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Return an array of all the listeners of the given type that were added to this model.
        返回：
        all of the objects receiving listenerType notifications from this model
        从以下版本开始：
        1.3

      • getAttributeCount

        public int getAttributeCount()
        Gets the number of attributes that are defined.
        指定者：
        getAttributeCount in interface AttributeSet
        返回：
        the number of attributes >= 0
        另请参见：
        AttributeSet.getAttributeCount()

      • isDefined

        public boolean isDefined(Object attrName)
        Checks whether a given attribute is defined.
        指定者：
        isDefined in interface AttributeSet
        参数：
        attrName - the non-null attribute name
        返回：
        true if the attribute is defined
        另请参见：
        AttributeSet.isDefined(java.lang.Object)

      • isEqual

        public boolean isEqual(AttributeSet attr)
        Checks whether two attribute sets are equal.
        指定者：
        isEqual in interface AttributeSet
        参数：
        attr - the attribute set to check against
        返回：
        true if the same
        另请参见：
        AttributeSet.isEqual(javax.swing.text.AttributeSet)

      • copyAttributes

        public AttributeSet copyAttributes()
        Copies a set of attributes.
        指定者：
        copyAttributes in interface AttributeSet
        返回：
        the copy
        另请参见：
        AttributeSet.copyAttributes()

      • getAttribute

        public Object getAttribute(Object attrName)
        Gets the value of an attribute.
        指定者：
        getAttribute in interface AttributeSet
        参数：
        attrName - the non-null attribute name
        返回：
        the attribute value
        另请参见：
        AttributeSet.getAttribute(java.lang.Object)

      • getAttributeNames

        public Enumeration<?> getAttributeNames()
        Gets the names of all attributes.
        指定者：
        getAttributeNames in interface AttributeSet
        返回：
        the attribute names as an enumeration
        另请参见：
        AttributeSet.getAttributeNames()

      • containsAttribute

        public boolean containsAttribute(Object name,
                        Object value)
        Checks whether a given attribute name/value is defined.
        指定者：
        containsAttribute in interface AttributeSet
        参数：
        name - the non-null attribute name
        value - the attribute value
        返回：
        true if the name/value is defined
        另请参见：
        AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

      • containsAttributes

        public boolean containsAttributes(AttributeSet attrs)
        Checks whether the element contains all the attributes.
        指定者：
        containsAttributes in interface AttributeSet
        参数：
        attrs - the attributes to check
        返回：
        true if the element contains all the attributes
        另请参见：
        AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

      • getResolveParent

        public AttributeSet getResolveParent()
        Gets attributes from the parent. If not overriden, the resolving parent defaults to the parent element.
        指定者：
        getResolveParent in interface AttributeSet
        返回：
        the attributes from the parent
        另请参见：
        AttributeSet.getResolveParent()

      • addAttribute

        public void addAttribute(Object name,
                Object value)
        Adds an attribute.
        指定者：
        addAttribute in interface MutableAttributeSet
        参数：
        name - the non-null attribute name
        value - the attribute value
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        public void addAttributes(AttributeSet attr)
        Adds a set of attributes to the element.
        指定者：
        addAttributes in interface MutableAttributeSet
        参数：
        attr - the attributes to add
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        public void removeAttribute(Object name)
        Removes an attribute from the set.
        指定者：
        removeAttribute in interface MutableAttributeSet
        参数：
        name - the non-null attribute name
        另请参见：
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        public void removeAttributes(Enumeration<?> names)
        Removes a set of attributes for the element.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        names - the attribute names
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • removeAttributes

        public void removeAttributes(AttributeSet attrs)
        Removes a set of attributes for the element.
        指定者：
        removeAttributes in interface MutableAttributeSet
        参数：
        attrs - the attributes
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • setResolveParent

        public void setResolveParent(AttributeSet parent)
        Sets the resolving parent.
        指定者：
        setResolveParent in interface MutableAttributeSet
        参数：
        parent - the parent, null if none
        另请参见：
        MutableAttributeSet.setResolveParent(javax.swing.text.AttributeSet)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcrae" =" ann aau> h


StyleContext.SmallAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyleContext.SmallAttributeSet

  • java.lang.Object
    • javax.swing.text.StyleContext.SmallAttributeSet
  • 所有已实现的接口：
    AttributeSet
    封闭类：
    StyleContext

    public class StyleContext.SmallAttributeSet
extends Object
implements AttributeSet
    This class holds a small number of attributes in an array. The storage format is key, value, key, value, etc. The size of the set is the length of the array divided by two. By default, this is the class that will be used to store attributes when held in the compact sharable form.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyleContext.SmallAttributeSet(AttributeSet attrs)
      StyleContext.SmallAttributeSet(Object[] attributes)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Clones a set of attributes.
      boolean containsAttribute(Object name, Object value)
      Checks whether a given attribute name/value is defined.
      boolean containsAttributes(AttributeSet attrs)
      Checks whether the attribute set contains all of the given attributes.
      AttributeSet copyAttributes()
      Copies a set of attributes.
      boolean equals(Object obj)
      Compares this object to the specifed object.
      Object getAttribute(Object key)
      Gets the value of an attribute.
      int getAttributeCount()
      Gets the number of attributes that are defined.
      Enumeration<?> getAttributeNames()
      Gets the names of all attributes.
      AttributeSet getResolveParent()
      If not overriden, the resolving parent defaults to the parent element.
      int hashCode()
      Returns a hashcode for this set of attributes.
      boolean isDefined(Object key)
      Checks whether a given attribute is defined.
      boolean isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      String toString()
      Returns a string showing the key/value pairs

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StyleContext.SmallAttributeSet

        public StyleContext.SmallAttributeSet(Object[] attributes)

      • StyleContext.SmallAttributeSet

        public StyleContext.SmallAttributeSet(AttributeSet attrs)

    • 方法详细信息

      • toString

        public String toString()
        Returns a string showing the key/value pairs
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • hashCode

        public int hashCode()
        Returns a hashcode for this set of attributes.
        重载：
        hashCode in class Object
        返回：
        a hashcode value for this set of attributes.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares this object to the specifed object. The result is true if the object is an equivalent set of attributes.
        重载：
        equals in class Object
        参数：
        obj - the object to compare with.
        返回：
        true if the objects are equal; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • clone

        public Object clone()
        Clones a set of attributes. Since the set is immutable, a clone is basically the same set.
        重载：
        clone in class Object
        返回：
        the set of attributes
        另请参见：
        Cloneable

      • getAttributeCount

        public int getAttributeCount()
        Gets the number of attributes that are defined.
        指定者：
        getAttributeCount in interface AttributeSet
        返回：
        the number of attributes
        另请参见：
        AttributeSet.getAttributeCount()

      • isDefined

        public boolean isDefined(Object key)
        Checks whether a given attribute is defined.
        指定者：
        isDefined in interface AttributeSet
        参数：
        key - the attribute key
        返回：
        true if the attribute is defined
        另请参见：
        AttributeSet.isDefined(java.lang.Object)

      • isEqual

        public boolean isEqual(AttributeSet attr)
        Checks whether two attribute sets are equal.
        指定者：
        isEqual in interface AttributeSet
        参数：
        attr - the attribute set to check against
        返回：
        true if the same
        另请参见：
        AttributeSet.isEqual(javax.swing.text.AttributeSet)

      • copyAttributes

        public AttributeSet copyAttributes()
        Copies a set of attributes.
        指定者：
        copyAttributes in interface AttributeSet
        返回：
        the copy
        另请参见：
        AttributeSet.copyAttributes()

      • getAttribute

        public Object getAttribute(Object key)
        Gets the value of an attribute.
        指定者：
        getAttribute in interface AttributeSet
        参数：
        key - the attribute name
        返回：
        the attribute value
        另请参见：
        AttributeSet.getAttribute(java.lang.Object)

      • getAttributeNames

        public Enumeration<?> getAttributeNames()
        Gets the names of all attributes.
        指定者：
        getAttributeNames in interface AttributeSet
        返回：
        the attribute names
        另请参见：
        AttributeSet.getAttributeNames()

      • containsAttribute

        public boolean containsAttribute(Object name,
                        Object value)
        Checks whether a given attribute name/value is defined.
        指定者：
        containsAttribute in interface AttributeSet
        参数：
        name - the attribute name
        value - the attribute value
        返回：
        true if the name/value is defined
        另请参见：
        AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

      • containsAttributes

        public boolean containsAttributes(AttributeSet attrs)
        Checks whether the attribute set contains all of the given attributes.
        指定者：
        containsAttributes in interface AttributeSet
        参数：
        attrs - the attributes to check
        返回：
        true if the element contains all the attributes
        另请参见：
        AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

      • getResolveParent

        public AttributeSet getResolveParent()
        If not overriden, the resolving parent defaults to the parent element.
        指定者：
        getResolveParent in interface AttributeSet
        返回：
        the attributes from the parent
        另请参见：
        AttributeSet.getResolveParent()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

obuAm#tl#te..teebxvvd=sn<>daa.rnt/篴pt


StyledDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface StyledDocument

  • All Superinterfaces:
    Document
    All Known Implementing Classes:
    DefaultStyledDocument, HTMLDocument

    public interface StyledDocument
extends Document
    Interface for a generic styled document.

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.Document

        StreamDescriptionProperty, TitleProperty

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Style addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      Color getBackground(AttributeSet attr)
      Takes a set of attributes and turn it into a background color specification.
      Element getCharacterElement(int pos)
      Gets the element that represents the character that is at the given offset within the document.
      Font getFont(AttributeSet attr)
      Takes a set of attributes and turn it into a font specification.
      Color getForeground(AttributeSet attr)
      Takes a set of attributes and turn it into a foreground color specification.
      Style getLogicalStyle(int p)
      Gets a logical style for a given position in a paragraph.
      Element getParagraphElement(int pos)
      Gets the element that represents the paragraph that encloses the given offset within the document.
      Style getStyle(String nm)
      Fetches a named style previously added.
      void removeStyle(String nm)
      Removes a named style previously added to the document.
      void setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace)
      Changes the content element attributes used for the given range of existing content in the document.
      void setLogicalStyle(int pos, Style s)
      Sets the logical style to use for the paragraph at the given position.
      void setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets paragraph attributes.

      • 方法 - 继承于接口 javax.swing.text.Document

        addDocumentListener, addUndoableEditListener, createPosition, getDefaultRootElement, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeDocumentListener, removeUndoableEditListener, render

    • 方法详细信息

      • addStyle

        Style addStyle(String nm,
             Style parent)
        Adds a new style into the logical style hierarchy. Style attributes resolve from bottom up so an attribute specified in a child will override an attribute specified in the parent.
        参数：
        nm - the name of the style (must be unique within the collection of named styles). The name may be null if the style is unnamed, but the caller is responsible for managing the reference returned as an unnamed style can't be fetched by name. An unnamed style may be useful for things like character attribute overrides such as found in a style run.
        parent - the parent style. This may be null if unspecified attributes need not be resolved in some other style.
        返回：
        the style

      • removeStyle

        void removeStyle(String nm)
        Removes a named style previously added to the document.
        参数：
        nm - the name of the style to remove

      • getStyle

        Style getStyle(String nm)
        Fetches a named style previously added.
        参数：
        nm - the name of the style
        返回：
        the style

      • setCharacterAttributes

        void setCharacterAttributes(int offset,
                          int length,
                          AttributeSet s,
                          boolean replace)
        Changes the content element attributes used for the given range of existing content in the document. All of the attributes defined in the given Attributes argument are applied to the given range. This method can be used to completely remove all content level attributes for the given range by giving an Attributes argument that has no attributes defined and setting replace to true.
        参数：
        offset - the start of the change >= 0
        length - the length of the change >= 0
        s - the non-null attributes to change to. Any attributes defined will be applied to the text for the given range.
        replace - indicates whether or not the previous attributes should be cleared before the new attributes as set. If true, the operation will replace the previous attributes entirely. If false, the new attributes will be merged with the previous attributes.

      • setParagraphAttributes

        void setParagraphAttributes(int offset,
                          int length,
                          AttributeSet s,
                          boolean replace)
        Sets paragraph attributes.
        参数：
        offset - the start of the change >= 0
        length - the length of the change >= 0
        s - the non-null attributes to change to. Any attributes defined will be applied to the text for the given range.
        replace - indicates whether or not the previous attributes should be cleared before the new attributes are set. If true, the operation will replace the previous attributes entirely. If false, the new attributes will be merged with the previous attributes.

      • setLogicalStyle

        void setLogicalStyle(int pos,
                   Style s)
        Sets the logical style to use for the paragraph at the given position. If attributes aren't explicitly set for character and paragraph attributes they will resolve through the logical style assigned to the paragraph, which in turn may resolve through some hierarchy completely independent of the element hierarchy in the document.
        参数：
        pos - the starting position >= 0
        s - the style to set

      • getLogicalStyle

        Style getLogicalStyle(int p)
        Gets a logical style for a given position in a paragraph.
        参数：
        p - the position >= 0
        返回：
        the style

      • getParagraphElement

        Element getParagraphElement(int pos)
        Gets the element that represents the paragraph that encloses the given offset within the document.
        参数：
        pos - the offset >= 0
        返回：
        the element

      • getCharacterElement

        Element getCharacterElement(int pos)
        Gets the element that represents the character that is at the given offset within the document.
        参数：
        pos - the offset >= 0
        返回：
        the element

      • getForeground

        Color getForeground(AttributeSet attr)
        Takes a set of attributes and turn it into a foreground color specification. This might be used to specify things like brighter, more hue, etc.
        参数：
        attr - the set of attributes
        返回：
        the color

      • getBackground

        Color getBackground(AttributeSet attr)
        Takes a set of attributes and turn it into a background color specification. This might be used to specify things like brighter, more hue, etc.
        参数：
        attr - the set of attributes
        返回：
        the color

      • getFont

        Font getFont(AttributeSet attr)
        Takes a set of attributes and turn it into a font specification. This can be used to turn things like family, style, size, etc into a font that is available on the system the document is currently being used on.
        参数：
        attr - the set of attributes
        返回：
        the font
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la>.iuabua tta gooo>rv=ih te/


StyledEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
  • 所有已实现的接口：
    Serializable, Cloneable
    直接已知子类：
    HTMLEditorKit, RTFEditorKit

    public class StyledEditorKit
extends DefaultEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document. This implementation provides a default implementation which treats text as styled text and provides a minimal set of actions for editing styled text.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  StyledEditorKit.AlignmentAction
      An action to set paragraph alignment.
      static class  StyledEditorKit.BoldAction
      An action to toggle the bold attribute.
      static class  StyledEditorKit.FontFamilyAction
      An action to set the font family in the associated JEditorPane.
      static class  StyledEditorKit.FontSizeAction
      An action to set the font size in the associated JEditorPane.
      static class  StyledEditorKit.ForegroundAction
      An action to set foreground color.
      static class  StyledEditorKit.ItalicAction
      An action to toggle the italic attribute.
      static class  StyledEditorKit.StyledTextAction
      An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
      static class  StyledEditorKit.UnderlineAction
      An action to toggle the underline attribute.

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultEditorKit

        DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction

    • 字段摘要

      • Fields inherited from class javax.swing.text.DefaultEditorKit

        backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit()
      Creates a new EditorKit used for styled documents.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a copy of the editor kit.
      Document createDefaultDocument()
      Creates an uninitialized text storage model that is appropriate for this type of editor.
      protected void createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      void deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      Action[] getActions()
      Fetches the command list for the editor.
      Element getCharacterAttributeRun()
      Fetches the element representing the current run of character attributes for the caret.
      MutableAttributeSet getInputAttributes()
      Gets the input attributes for the pane.
      ViewFactory getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      void install(JEditorPane c)
      Called when the kit is being installed into a JEditorPane.

      • 方法 - 继承于类 javax.swing.text.DefaultEditorKit

        createCaret, getContentType, read, read, write, write

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit

        public StyledEditorKit()
        Creates a new EditorKit used for styled documents.

    • 方法详细信息

      • getInputAttributes

        public MutableAttributeSet getInputAttributes()
        Gets the input attributes for the pane. When the caret moves and there is no selection, the input attributes are automatically mutated to reflect the character attributes of the current caret location. The styled editing actions use the input attributes to carry out their actions.
        返回：
        the attribute set

      • getCharacterAttributeRun

        public Element getCharacterAttributeRun()
        Fetches the element representing the current run of character attributes for the caret.
        返回：
        the element

      • getActions

        public Action[] getActions()
        Fetches the command list for the editor. This is the list of commands supported by the superclass augmented by the collection of commands defined locally for style operations.
        重载：
        getActions in class DefaultEditorKit
        返回：
        the command list

      • createDefaultDocument

        public Document createDefaultDocument()
        Creates an uninitialized text storage model that is appropriate for this type of editor.
        重载：
        createDefaultDocument in class DefaultEditorKit
        返回：
        the model

      • install

        public void install(JEditorPane c)
        Called when the kit is being installed into a JEditorPane.
        重载：
        install in class EditorKit
        参数：
        c - the JEditorPane

      • deinstall

        public void deinstall(JEditorPane c)
        Called when the kit is being removed from the JEditorPane. This is used to unregister any listeners that were attached.
        重载：
        deinstall in class EditorKit
        参数：
        c - the JEditorPane

      • getViewFactory

        public ViewFactory getViewFactory()
        Fetches a factory that is suitable for producing views of any models that are produced by this kit. This is implemented to return View implementations for the following kinds of elements:
        • AbstractDocument.ContentElementName
        • AbstractDocument.ParagraphElementName
        • AbstractDocument.SectionElementName
        • StyleConstants.ComponentElementName
        • StyleConstants.IconElementName
        重载：
        getViewFactory in class DefaultEditorKit
        返回：
        the factory

      • clone

        public Object clone()
        Creates a copy of the editor kit.
        重载：
        clone in class EditorKit
        返回：
        the copy
        另请参见：
        Cloneable

      • createInputAttributes

        protected void createInputAttributes(Element element,
                         MutableAttributeSet set)
        Copies the key/values in elements AttributeSet into set. This does not copy component, icon, or element names attributes. Subclasses may wish to refine what is and what isn't copied here. But be sure to first remove all the attributes that are in set.

        This is called anytime the caret moves over a different location.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyledEditorKit.AlignmentAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.AlignmentAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.AlignmentAction
extends StyledEditorKit.StyledTextAction
    An action to set paragraph alignment. This sets the StyleConstants.Alignment attribute for the currently selected range of the target JEditorPane. This is done by calling StyledDocument.setParagraphAttributes on the styled document associated with the target JEditorPane.

    If the target text component is specified as the source of the ActionEvent and there is a command string, the command string will be interpreted as an integer that should be one of the legal values for the StyleConstants.Alignment attribute.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.AlignmentAction(String nm, int a)
      Creates a new AlignmentAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Sets the alignment.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.AlignmentAction

        public StyledEditorKit.AlignmentAction(String nm,
                               int a)
        Creates a new AlignmentAction.
        参数：
        nm - the action name
        a - the alignment >= 0

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Sets the alignment.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tt lh l eel -<</t>/>sspdtoodatdd


StyledEditorKit.BoldAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.BoldAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.BoldAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.BoldAction
extends StyledEditorKit.StyledTextAction
    An action to toggle the bold attribute.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.BoldAction()
      Constructs a new BoldAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Toggles the bold attribute.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.BoldAction

        public StyledEditorKit.BoldAction()
        Constructs a new BoldAction.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Toggles the bold attribute.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pl;asaoasa/&bsp&btuuAg.cirtt"Aon>�&秐鬃br;ny


StyledEditorKit.FontFamilyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.FontFamilyAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.FontFamilyAction
extends StyledEditorKit.StyledTextAction
    An action to set the font family in the associated JEditorPane. This will use the family specified as the command string on the ActionEvent if there is one, otherwise the family that was initialized with will be used.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.FontFamilyAction(String nm, String family)
      Creates a new FontFamilyAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Sets the font family.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.FontFamilyAction

        public StyledEditorKit.FontFamilyAction(String nm,
                                String family)
        Creates a new FontFamilyAction.
        参数：
        nm - the action name
        family - the font family

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Sets the font family.
        参数：
        e - the event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fＣ懊t帽锚辉薄ｙ溃b唆=�.欣纅�tnnr so<


StyledEditorKit.FontSizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.FontSizeAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.FontSizeAction
extends StyledEditorKit.StyledTextAction
    An action to set the font size in the associated JEditorPane. This will use the size specified as the command string on the ActionEvent if there is one, otherwise the size that was initialized with will be used.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.FontSizeAction(String nm, int size)
      Creates a new FontSizeAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Sets the font size.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.FontSizeAction

        public StyledEditorKit.FontSizeAction(String nm,
                              int size)
        Creates a new FontSizeAction.
        参数：
        nm - the action name
        size - the font size

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Sets the font size.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cfornr r roig ceaso;满牵咕　<�> .h.r/ .0..a


StyledEditorKit.ForegroundAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.ForegroundAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.ForegroundAction
extends StyledEditorKit.StyledTextAction
    An action to set foreground color. This sets the StyleConstants.Foreground attribute for the currently selected range of the target JEditorPane. This is done by calling StyledDocument.setCharacterAttributes on the styled document associated with the target JEditorPane.

    If the target text component is specified as the source of the ActionEvent and there is a command string, the command string will be interpreted as the foreground color. It will be interpreted by called Color.decode, and should therefore be legal input for that method.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.ForegroundAction(String nm, Color fg)
      Creates a new ForegroundAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Sets the foreground color.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.ForegroundAction

        public StyledEditorKit.ForegroundAction(String nm,
                                Color fg)
        Creates a new ForegroundAction.
        参数：
        nm - the action name
        fg - the foreground color

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Sets the foreground color.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i aenb ner err eed!se rea"pd>P_n 莈�>


StyledEditorKit.ItalicAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.ItalicAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.ItalicAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.ItalicAction
extends StyledEditorKit.StyledTextAction
    An action to toggle the italic attribute.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.ItalicAction()
      Constructs a new ItalicAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Toggles the italic attribute.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.ItalicAction

        public StyledEditorKit.ItalicAction()
        Constructs a new ItalicAction.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Toggles the italic attribute.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htiipripri ssi e ooa/ttnn/tgc(t)r<<>>tmc>


StyledEditorKit.StyledTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.StyledTextAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    直接已知子类：
    HTMLEditorKit.HTMLTextAction, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.UnderlineAction
    封闭类：
    StyledEditorKit

    public abstract static class StyledEditorKit.StyledTextAction
extends TextAction
    An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed. This has some convenience methods for causing character or paragraph level attribute changes. The convenience methods will throw an IllegalArgumentException if the assumption of a StyledDocument, a JEditorPane, or a StyledEditorKit fail to be true.

    The component that gets acted upon by the action will be the source of the ActionEvent if the source can be narrowed to a JEditorPane type. If the source can't be narrowed, the most recently focused text component is changed. If neither of these are the case, the action cannot be performed.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.StyledTextAction(String nm)
      Creates a new StyledTextAction from a string action name.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected JEditorPane getEditor(ActionEvent e)
      Gets the target editor for an action.
      protected StyledDocument getStyledDocument(JEditorPane e)
      Gets the document associated with an editor pane.
      protected StyledEditorKit getStyledEditorKit(JEditorPane e)
      Gets the editor kit associated with an editor pane.
      protected void setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to character content.
      protected void setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to paragraphs.

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.ActionListener

        actionPerformed

    • 构造方法详细信息

      • StyledEditorKit.StyledTextAction

        public StyledEditorKit.StyledTextAction(String nm)
        Creates a new StyledTextAction from a string action name.
        参数：
        nm - the name of the action

    • 方法详细信息

      • getEditor

        protected final JEditorPane getEditor(ActionEvent e)
        Gets the target editor for an action.
        参数：
        e - the action event
        返回：
        the editor

      • getStyledDocument

        protected final StyledDocument getStyledDocument(JEditorPane e)
        Gets the document associated with an editor pane.
        参数：
        e - the editor
        返回：
        the document
        抛出：
        IllegalArgumentException - for the wrong document type

      • getStyledEditorKit

        protected final StyledEditorKit getStyledEditorKit(JEditorPane e)
        Gets the editor kit associated with an editor pane.
        参数：
        e - the editor pane
        返回：
        the kit
        抛出：
        IllegalArgumentException - for the wrong document type

      • setCharacterAttributes

        protected final void setCharacterAttributes(JEditorPane editor,
                          AttributeSet attr,
                          boolean replace)
        Applies the given attributes to character content. If there is a selection, the attributes are applied to the selection range. If there is no selection, the attributes are applied to the input attribute set which defines the attributes for any new text that gets inserted.
        参数：
        editor - the editor
        attr - the attributes
        replace - if true, then replace the existing attributes first

      • setParagraphAttributes

        protected final void setParagraphAttributes(JEditorPane editor,
                          AttributeSet attr,
                          boolean replace)
        Applies the given attributes to paragraphs. If there is a selection, the attributes are applied to the paragraphs that intersect the selection. if there is no selection, the attributes are applied to the paragraph at the current caret position.
        参数：
        editor - the editor
        attr - the attributes
        replace - if true, replace the existing attributes first
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

blsstsrsnsb;&nb;&rii猠;p蕇pL�.萢"胊blln


StyledEditorKit.UnderlineAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 StyledEditorKit.UnderlineAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    StyledEditorKit

    public static class StyledEditorKit.UnderlineAction
extends StyledEditorKit.StyledTextAction
    An action to toggle the underline attribute.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyledEditorKit.UnderlineAction()
      Constructs a new UnderlineAction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent e)
      Toggles the Underline attribute.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StyledEditorKit.UnderlineAction

        public StyledEditorKit.UnderlineAction()
        Constructs a new UnderlineAction.

    • 方法详细信息

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Toggles the Underline attribute.
        参数：
        e - the action event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sdtasic ic"llc""i.// 4op/e>>&pylidti.Edd=dov


TabableView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface TabableView

  • All Known Implementing Classes:
    GlyphView, InlineView, LabelView

    public interface TabableView
    Interface for Views that have size dependent upon tabs.
    另请参见：
    TabExpander, LabelView, ParagraphView

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float getPartialSpan(int p0, int p1)
      Determines the span along the same axis as tab expansion for a portion of the view.
      float getTabbedSpan(float x, TabExpander e)
      Determines the desired span when using the given tab expansion implementation.

    • 方法详细信息

      • getTabbedSpan

        float getTabbedSpan(float x,
                  TabExpander e)
        Determines the desired span when using the given tab expansion implementation. If a container calls this method, it will do so prior to the normal layout which would call getPreferredSpan. A view implementing this should give the same result in any subsequent calls to getPreferredSpan along the axis of tab expansion.
        参数：
        x - the position the view would be located at for the purpose of tab expansion >= 0.
        e - how to expand the tabs when encountered.
        返回：
        the desired span >= 0

      • getPartialSpan

        float getPartialSpan(int p0,
                   int p1)
        Determines the span along the same axis as tab expansion for a portion of the view. This is intended for use by the TabExpander for cases where the tab expansion involves aligning the portion of text that doesn't have whitespace relative to the tab stop. There is therefore an assumption that the range given does not contain tabs.
        参数：
        p0 - the starting location in the text document >= 0
        p1 - the ending location in the text document >= p0
        返回：
        the span >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt"AtT//T/gtt/gg/.hh! x"n->aiss x"


TabExpander

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface TabExpander

  • All Known Implementing Classes:
    FieldView, ParagraphView, ParagraphView, PasswordView, PlainView, WrappedPlainView

    public interface TabExpander
    Simple interface to allow for different types of implementations of tab expansion.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float nextTabStop(float x, int tabOffset)
      Returns the next tab stop position given a reference position.

    • 方法详细信息

      • nextTabStop

        float nextTabStop(float x,
                int tabOffset)
        Returns the next tab stop position given a reference position. Values are expressed in points.
        参数：
        x - the position in points >= 0
        tabOffset - the position within the text stream that the tab occurred at >= 0.
        返回：
        the next tab stop >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lnelnliltlm "llnioo">s"v" avaasg


TableView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TableView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.TableView
  • 所有已实现的接口：
    SwingConstants

    public abstract class TableView
extends BoxView

    Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells. The cell elements can have an arbitrary element structure under them, which will be built with the ViewFactory returned by the getViewFactory method.

    TABLE
      ROW
        CELL
        CELL
      ROW
        CELL
        CELL

    This is implemented as a hierarchy of boxes, the table itself is a vertical box, the rows are horizontal boxes, and the cells are vertical boxes. The cells are allowed to span multiple columns and rows. By default, the table can be thought of as being formed over a grid (i.e. somewhat like one would find in gridbag layout), where table cells can request to span more than one grid cell. The default horizontal span of table cells will be based upon this grid, but can be changed by reimplementing the requested span of the cell (i.e. table cells can have independant spans if desired).

    另请参见：
    View

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  TableView.TableCell
      Deprecated.
      A table cell can now be any View implementation.
      class  TableView.TableRow
      View of a row in a row-centric table.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableView(Element elem)
      Constructs a TableView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements for the minor axis.
      protected TableView.TableCell createTableCell(Element elem)
      Deprecated.
      Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
      protected TableView.TableRow createTableRow(Element elem)
      Creates a new table row.
      protected void forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected View getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      protected void layoutColumns(int targetSpan, int[] offsets, int[] spans, SizeRequirements[] reqs)
      Lays out the columns to fit within the given target span.
      protected void layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Perform layout for the minor axis of the box (i.e.
      void replace(int offset, int length, View[] views)
      Change the child views.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, flipEastAndWestAtEnds, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, paint, paintChild, preferenceChanged, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableView

        public TableView(Element elem)
        Constructs a TableView for the given element.
        参数：
        elem - the element that this view is responsible for

    • 方法详细信息

      • createTableRow

        protected TableView.TableRow createTableRow(Element elem)
        Creates a new table row.
        参数：
        elem - an element
        返回：
        the row

      • createTableCell

        @Deprecated
protected TableView.TableCell createTableCell(Element elem)
        Deprecated. Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
        参数：
        elem - an element
        返回：
        the cell

      • forwardUpdate

        protected void forwardUpdate(DocumentEvent.ElementChange ec,
                 DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Description copied from class: BoxView
        Forwards the given DocumentEvent to the child views that need to be notified of the change to the model. If a child changed its requirements and the allocation was valid prior to forwarding the portion of the box from the starting child to the end of the box will be repainted.
        重载：
        forwardUpdate in class BoxView
        参数：
        ec - changes to the element this view is responsible for (may be null if there were no changes)
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • replace

        public void replace(int offset,
           int length,
           View[] views)
        Change the child views. This is implemented to provide the superclass behavior and invalidate the grid so that rows and columns will be recalculated.
        重载：
        replace in class BoxView
        参数：
        offset - the starting index into the child views to insert the new views; this should be a value >= 0 and <= getViewCount
        length - the number of existing child views to remove; This should be a value >= 0 and <= (getViewCount() - offset)
        views - the child views to add; this value can be nullto indicate no children are being added (useful to remove)

      • layoutColumns

        protected void layoutColumns(int targetSpan,
                 int[] offsets,
                 int[] spans,
                 SizeRequirements[] reqs)
        Lays out the columns to fit within the given target span. Returns the results through offsets and spans.
        参数：
        targetSpan - the given span for total of all the table columns
        reqs - the requirements desired for each column. This is the column maximum of the cells minimum, preferred, and maximum requested span
        spans - the return value of how much to allocated to each column
        offsets - the return value of the offset from the origin for each column

      • layoutMinorAxis

        protected void layoutMinorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Perform layout for the minor axis of the box (i.e. the axis orthoginal to the axis that it represents). The results of the layout should be placed in the given arrays which represent the allocations to the children along the minor axis. This is called by the superclass whenever the layout needs to be updated along the minor axis.

        This is implemented to call the layoutColumns method, and then forward to the superclass to actually carry out the layout of the tables rows.

        重载：
        layoutMinorAxis in class BoxView
        参数：
        targetSpan - the total span given to the view, which whould be used to layout the children.
        axis - the axis being layed out.
        offsets - the offsets from the origin of the view for each of the child views. This is a return value and is filled in by the implementation of this method.
        spans - the span of each child view. This is a return value and is filled in by the implementation of this method.

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate the requirements for the minor axis. This is called by the superclass whenever the requirements need to be updated (i.e. a preferenceChanged was messaged through this view).

        This is implemented to calculate the requirements as the sum of the requirements of the columns.

        重载：
        calculateMinorAxisRequirements in class BoxView
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • getViewAtPosition

        protected View getViewAtPosition(int pos,
                     Rectangle a)
        Fetches the child view that represents the given position in the model. This is implemented to walk through the children looking for a range that contains the given position. In this view the children do not necessarily have a one to one mapping with the child elements.
        重载：
        getViewAtPosition in class CompositeView
        参数：
        pos - the search position >= 0
        a - the allocation to the table on entry, and the allocation of the view containing the position on exit
        返回：
        the view representing the given position, or null if there isn't one
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TableView.TableCell

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TableView.TableCell

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.TableView.TableCell
  • 所有已实现的接口：
    SwingConstants
    封闭类：
    TableView
    Deprecated.
    A table cell can now be any View implementation.

    @Deprecated
public class TableView.TableCell
extends BoxView

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableView.TableCell(Element elem)
      Deprecated.
      Constructs a TableCell for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnCount()
      Deprecated.
      Gets the number of columns this cell spans (e.g.
      int getGridColumn()
      Deprecated.
      Gets the column of the grid location
      int getGridRow()
      Deprecated.
      Gets the row of the grid location
      int getRowCount()
      Deprecated.
      Gets the number of rows this cell spans (that is, the grid height).
      void setGridLocation(int row, int col)
      Deprecated.
      Sets the grid location.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableView.TableCell

        public TableView.TableCell(Element elem)
        Deprecated.
        Constructs a TableCell for the given element.
        参数：
        elem - the element that this view is responsible for
        从以下版本开始：
        1.4

    • 方法详细信息

      • getColumnCount

        public int getColumnCount()
        Deprecated.
        Gets the number of columns this cell spans (e.g. the grid width).
        返回：
        the number of columns

      • getRowCount

        public int getRowCount()
        Deprecated.
        Gets the number of rows this cell spans (that is, the grid height).
        返回：
        the number of rows

      • setGridLocation

        public void setGridLocation(int row,
                   int col)
        Deprecated.
        Sets the grid location.
        参数：
        row - the row >= 0
        col - the column >= 0

      • getGridRow

        public int getGridRow()
        Deprecated.
        Gets the row of the grid location

      • getGridColumn

        public int getGridColumn()
        Deprecated.
        Gets the column of the grid location
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aat u>>l>>i >ii>/<edooa> dmde>ee me t/n


TableView.TableRow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TableView.TableRow

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.TableView.TableRow
  • 所有已实现的接口：
    SwingConstants
    封闭类：
    TableView

    public class TableView.TableRow
extends BoxView
    View of a row in a row-centric table.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      TableView.TableRow(Element elem)
      Constructs a TableView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getResizeWeight(int axis)
      Determines the resizability of the view along the given axis.
      protected View getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      protected void layoutMajorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Perform layout for the major axis of the box (i.e.
      protected void layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Perform layout for the minor axis of the box (i.e.
      void replace(int offset, int length, View[] views)
      Change the child views.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, modelToView, paint, paintChild, preferenceChanged, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TableView.TableRow

        public TableView.TableRow(Element elem)
        Constructs a TableView for the given element.
        参数：
        elem - the element that this view is responsible for
        从以下版本开始：
        1.4

    • 方法详细信息

      • replace

        public void replace(int offset,
           int length,
           View[] views)
        Change the child views. This is implemented to provide the superclass behavior and invalidate the grid so that rows and columns will be recalculated.
        重载：
        replace in class BoxView
        参数：
        offset - the starting index into the child views to insert the new views; this should be a value >= 0 and <= getViewCount
        length - the number of existing child views to remove; This should be a value >= 0 and <= (getViewCount() - offset)
        views - the child views to add; this value can be nullto indicate no children are being added (useful to remove)

      • layoutMajorAxis

        protected void layoutMajorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Perform layout for the major axis of the box (i.e. the axis that it represents). The results of the layout should be placed in the given arrays which represent the allocations to the children along the major axis.

        This is re-implemented to give each child the span of the column width for the table, and to give cells that span multiple columns the multi-column span.

        重载：
        layoutMajorAxis in class BoxView
        参数：
        targetSpan - the total span given to the view, which whould be used to layout the children.
        axis - the axis being layed out.
        offsets - the offsets from the origin of the view for each of the child views. This is a return value and is filled in by the implementation of this method.
        spans - the span of each child view. This is a return value and is filled in by the implementation of this method.

      • layoutMinorAxis

        protected void layoutMinorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Perform layout for the minor axis of the box (i.e. the axis orthoginal to the axis that it represents). The results of the layout should be placed in the given arrays which represent the allocations to the children along the minor axis. This is called by the superclass whenever the layout needs to be updated along the minor axis.

        This is implemented to delegate to the superclass, then adjust the span for any cell that spans multiple rows.

        重载：
        layoutMinorAxis in class BoxView
        参数：
        targetSpan - the total span given to the view, which whould be used to layout the children.
        axis - the axis being layed out.
        offsets - the offsets from the origin of the view for each of the child views. This is a return value and is filled in by the implementation of this method.
        spans - the span of each child view. This is a return value and is filled in by the implementation of this method.

      • getResizeWeight

        public int getResizeWeight(int axis)
        Determines the resizability of the view along the given axis. A value of 0 or less is not resizable.
        重载：
        getResizeWeight in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the resize weight
        抛出：
        IllegalArgumentException - for an invalid axis

      • getViewAtPosition

        protected View getViewAtPosition(int pos,
                     Rectangle a)
        Fetches the child view that represents the given position in the model. This is implemented to walk through the children looking for a range that contains the given position. In this view the children do not necessarily have a one to one mapping with the child elements.
        重载：
        getViewAtPosition in class CompositeView
        参数：
        pos - the search position >= 0
        a - the allocation to the table on entry, and the allocation of the view containing the position on exit
        返回：
        the view representing the given position, or null if there isn't one
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ri


TabSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TabSet

  • java.lang.Object
    • javax.swing.text.TabSet
  • 所有已实现的接口：
    Serializable

    public class TabSet
extends Object
implements Serializable
    A TabSet is comprised of many TabStops. It offers methods for locating the closest TabStop to a given position and finding all the potential TabStops. It is also immutable.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TabSet(TabStop[] tabs)
      Creates and returns an instance of TabSet.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      boolean equals(Object o)
      Indicates whether this TabSet is equal to another one.
      TabStop getTab(int index)
      Returns the TabStop at index index.
      TabStop getTabAfter(float location)
      Returns the Tab instance after location.
      int getTabCount()
      Returns the number of Tab instances the receiver contains.
      int | getTabIndex(TabStop tab)
      int getTabIndexAfter(float location)
      Returns the index of the Tab to be used after location.
      int hashCode()
      Returns a hashcode for this set of TabStops.
      String toString()
      Returns the string representation of the set of tabs.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TabSet

        public TabSet(TabStop[] tabs)
        Creates and returns an instance of TabSet. The array of Tabs passed in must be sorted in ascending order.

    • 方法详细信息

      • getTabCount

        public int getTabCount()
        Returns the number of Tab instances the receiver contains.

      • getTab

        public TabStop getTab(int index)
        Returns the TabStop at index index. This will throw an IllegalArgumentException if index is outside the range of tabs.

      • getTabAfter

        public TabStop getTabAfter(float location)
        Returns the Tab instance after location. This will return null if there are no tabs after location.

      • getTabIndex

        public int getTabIndex(TabStop tab)
        返回：
        the index of the TabStop tab, or -1 if tab is not contained in the receiver.

      • getTabIndexAfter

        public int getTabIndexAfter(float location)
        Returns the index of the Tab to be used after location. This will return -1 if there are no tabs after location.

      • equals

        public boolean equals(Object o)
        Indicates whether this TabSet is equal to another one.
        重载：
        equals in class Object
        参数：
        o - the TabSet instance which this instance should be compared to.
        返回：
        true if o is the instance of TabSet, has the same number of TabStops and they are all equal, false otherwise.
        从以下版本开始：
        1.5
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hashcode for this set of TabStops.
        重载：
        hashCode in class Object
        返回：
        a hashcode value for this set of TabStops.
        从以下版本开始：
        1.5
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Returns the string representation of the set of tabs.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#t


TabStop

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TabStop

  • java.lang.Object
    • javax.swing.text.TabStop
  • 所有已实现的接口：
    Serializable

    public class TabStop
extends Object
implements Serializable
    This class encapsulates a single tab stop (basically as tab stops are thought of by RTF). A tab stop is at a specified distance from the left margin, aligns text in a specified way, and has a specified leader. TabStops are immutable, and usually contained in TabSets.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | ALIGN_BAR
      static int ALIGN_CENTER
      Characters following tab are positioned such that all following characters up to next tab/newline are centered around the tabs location.
      static int ALIGN_DECIMAL
      Characters following tab are aligned such that next decimal/tab/newline is at the tab location, very similar to RIGHT_TAB, just includes decimal as additional character to look for.
      static int ALIGN_LEFT
      Character following tab is positioned at location.
      static int ALIGN_RIGHT
      Characters following tab are positioned such that all following characters up to next tab/newline end at location.
      static int | LEAD_DOTS
      static int | LEAD_EQUALS
      static int | LEAD_HYPHENS
      static int | LEAD_NONE
      static int | LEAD_THICKLINE
      static int | LEAD_UNDERLINE

    • 构造方法摘要

      Constructors
      构造方法与描述
      TabStop(float pos)
      Creates a tab at position pos with a default alignment and default leader.
      TabStop(float pos, int align, int leader)
      Creates a tab with the specified position pos, alignment align and leader leader.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object other)
      Returns true if the tabs are equal.
      int getAlignment()
      Returns the alignment, as an integer, of the tab.
      int getLeader()
      Returns the leader of the tab.
      float getPosition()
      Returns the position, as a float, of the tab.
      int hashCode()
      Returns the hashCode for the object.
      String toString()
      Returns a string representation of the object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • ALIGN_LEFT

        public static final int ALIGN_LEFT
        Character following tab is positioned at location.
        另请参见：
        Constant Field Values

      • ALIGN_RIGHT

        public static final int ALIGN_RIGHT
        Characters following tab are positioned such that all following characters up to next tab/newline end at location.
        另请参见：
        Constant Field Values

      • ALIGN_CENTER

        public static final int ALIGN_CENTER
        Characters following tab are positioned such that all following characters up to next tab/newline are centered around the tabs location.
        另请参见：
        Constant Field Values

      • ALIGN_DECIMAL

        public static final int ALIGN_DECIMAL
        Characters following tab are aligned such that next decimal/tab/newline is at the tab location, very similar to RIGHT_TAB, just includes decimal as additional character to look for.
        另请参见：
        Constant Field Values

      • ALIGN_BAR

        public static final int ALIGN_BAR
        另请参见：
        Constant Field Values

      • LEAD_NONE

        public static final int LEAD_NONE
        另请参见：
        Constant Field Values

      • LEAD_DOTS

        public static final int LEAD_DOTS
        另请参见：
        Constant Field Values

      • LEAD_HYPHENS

        public static final int LEAD_HYPHENS
        另请参见：
        Constant Field Values

      • LEAD_UNDERLINE

        public static final int LEAD_UNDERLINE
        另请参见：
        Constant Field Values

      • LEAD_THICKLINE

        public static final int LEAD_THICKLINE
        另请参见：
        Constant Field Values

      • LEAD_EQUALS

        public static final int LEAD_EQUALS
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • TabStop

        public TabStop(float pos)
        Creates a tab at position pos with a default alignment and default leader.

      • TabStop

        public TabStop(float pos,
       int align,
       int leader)
        Creates a tab with the specified position pos, alignment align and leader leader.

    • 方法详细信息

      • getPosition

        public float getPosition()
        Returns the position, as a float, of the tab.
        返回：
        the position of the tab

      • getAlignment

        public int getAlignment()
        Returns the alignment, as an integer, of the tab.
        返回：
        the alignment of the tab

      • getLeader

        public int getLeader()
        Returns the leader of the tab.
        返回：
        the leader of the tab

      • equals

        public boolean equals(Object other)
        Returns true if the tabs are equal.
        重载：
        equals in class Object
        参数：
        other - the reference object with which to compare.
        返回：
        true if the tabs are equal, otherwise false
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hashCode for the object. This must be defined here to ensure 100% pure.
        重载：
        hashCode in class Object
        返回：
        the hashCode for the object
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n/.e.n....-..l/f>>"o>扛�> :t>


TextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 TextAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    直接已知子类：
    DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, StyledEditorKit.StyledTextAction

    public abstract class TextAction
extends AbstractAction
    An Action implementation useful for key bindings that are shared across a number of different text components. Because the action is shared, it must have a way of getting it's target to act upon. This class provides support to try and find a text component to operate on. The preferred way of getting the component to act upon is through the ActionEvent that is received. If the Object returned by getSource can be narrowed to a text component, it will be used. If the action event is null or can't be narrowed, the last focused text component is tried. This is determined by being used in conjunction with a JTextController which arranges to share that information with a TextAction.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      TextAction(String name)
      Creates a new JTextAction object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Action[] augmentList(Action[] list1, Action[] list2)
      Takes one list of commands and augments it with another list of commands.
      protected JTextComponent getFocusedComponent()
      Fetches the text component that currently has focus.
      protected JTextComponent getTextComponent(ActionEvent e)
      Determines the component to use for the action.

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.ActionListener

        actionPerformed

    • 构造方法详细信息

      • TextAction

        public TextAction(String name)
        Creates a new JTextAction object.
        参数：
        name - the name of the action

    • 方法详细信息

      • getTextComponent

        protected final JTextComponent getTextComponent(ActionEvent e)
        Determines the component to use for the action. This if fetched from the source of the ActionEvent if it's not null and can be narrowed. Otherwise, the last focused component is used.
        参数：
        e - the ActionEvent
        返回：
        the component

      • augmentList

        public static final Action[] augmentList(Action[] list1,
                   Action[] list2)
        Takes one list of commands and augments it with another list of commands. The second list takes precedence over the first list; that is, when both lists contain a command with the same name, the command from the second list is used.
        参数：
        list1 - the first list, may be empty but not null
        list2 - the second list, may be empty but not null
        返回：
        the augmented list

      • getFocusedComponent

        protected final JTextComponent getFocusedComponent()
        Fetches the text component that currently has focus. This allows actions to be shared across text components which is useful for key-bindings where a large set of actions are defined, but generally used the same way across many different components.
        返回：
        the component
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csoa;nninn&bbn&&cdddseeoistt/sinrddd


Uses of Package javax.swing.text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.text

  • Packages that use javax.swing.text
    软件包 描述
    java.awt
    Contains all of the classes for creating user interfaces and for painting graphics and images.
    javax.accessibility
    Defines a contract between user-interface components and an assistive technology that provides access to those components.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
  • Classes in javax.swing.text used by java.awt
    类与描述
    AttributeSet
    A collection of unique attributes.
  • Classes in javax.swing.text used by javax.accessibility
    类与描述
    AttributeSet
    A collection of unique attributes.
  • Classes in javax.swing.text used by javax.swing
    类与描述
    AttributeSet
    A collection of unique attributes.
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    Document
    The Document is a container for text that serves as the model for swing text components.
    DocumentFilter
    DocumentFilter, as the name implies, is a filter for the Document mutation methods.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    Element
    Interface to describe a structural piece of a document.
    JTextComponent
    JTextComponent is the base class for swing text components.
    JTextComponent.AccessibleJTextComponent
    This class implements accessibility support for the JTextComponent class.
    JTextComponent.KeyBinding
    Binding record for creating key bindings.
    MutableAttributeSet
    A generic interface for a mutable collection of unique attributes.
    NavigationFilter
    NavigationFilter can be used to restrict where the cursor can be positioned.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    Style
    A collection of attributes to associate with an element in a document.
    StyledDocument
    Interface for a generic styled document.
    StyledEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
  • Classes in javax.swing.text used by javax.swing.event
    类与描述
    Document
    The Document is a container for text that serves as the model for swing text components.
    Element
    Interface to describe a structural piece of a document.
  • Classes in javax.swing.text used by javax.swing.plaf
    类与描述
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    JTextComponent
    JTextComponent is the base class for swing text components.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    View
    A very important part of the text package is the View class.
  • Classes in javax.swing.text used by javax.swing.plaf.basic
    类与描述
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    Caret
    A place within a document view that represents where things can be inserted into the document model.
    DefaultCaret
    A default implementation of Caret.
    DefaultHighlighter
    Implements the Highlighter interfaces.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    Element
    Interface to describe a structural piece of a document.
    Highlighter
    An interface for an object that allows one to mark up the background with colored areas.
    JTextComponent
    JTextComponent is the base class for swing text components.
    Keymap
    A collection of bindings of KeyStrokes to actions.
    LayeredHighlighter
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    View
    A very important part of the text package is the View class.
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Classes in javax.swing.text used by javax.swing.plaf.metal
    类与描述
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Classes in javax.swing.text used by javax.swing.plaf.multi
    类与描述
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    JTextComponent
    JTextComponent is the base class for swing text components.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    View
    A very important part of the text package is the View class.
  • Classes in javax.swing.text used by javax.swing.plaf.synth
    类与描述
    Element
    Interface to describe a structural piece of a document.
    View
    A very important part of the text package is the View class.
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Classes in javax.swing.text used by javax.swing.text
    类与描述
    AbstractDocument
    An implementation of the document interface to serve as a basis for implementing various kinds of documents.
    AbstractDocument.AbstractElement
    Implements the abstract part of an element.
    AbstractDocument.AttributeContext
    An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
    AbstractDocument.BranchElement
    Implements a composite element that contains other elements.
    AbstractDocument.Content
    Interface to describe a sequence of character content that can be edited.
    AbstractDocument.DefaultDocumentEvent
    Stores document changes as the document is being modified.
    AsyncBoxView.ChildLocator
    A class to manage the effective position of the child views in a localized area while changes are being made around the localized area.
    AsyncBoxView.ChildState
    A record representing the layout state of a child view.
    AttributeSet
    A collection of unique attributes.
    AttributeSet.CharacterAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation.
    AttributeSet.ColorAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
    AttributeSet.FontAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text.
    AttributeSet.ParagraphAttribute
    This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    BoxView
    A view that arranges its children into a box shape by tiling its children along an axis.
    Caret
    A place within a document view that represents where things can be inserted into the document model.
    CompositeView
    CompositeView is an abstract View implementation which manages one or more child views.
    DefaultEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    DefaultFormatter
    DefaultFormatter formats aribtrary objects.
    DefaultStyledDocument.ElementBuffer
    Class to manage changes to the element hierarchy.
    DefaultStyledDocument.ElementSpec
    Specification for building elements.
    Document
    The Document is a container for text that serves as the model for swing text components.
    DocumentFilter
    DocumentFilter, as the name implies, is a filter for the Document mutation methods.
    DocumentFilter.FilterBypass
    Used as a way to circumvent calling back into the Document to change it.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    Element
    Interface to describe a structural piece of a document.
    ElementIterator
    ElementIterator, as the name suggests, iteratates over the Element tree.
    FieldView
    Extends the multi-line plain text view to be suitable for a single-line editor view.
    FlowView
    A View that tries to flow it's children into some partially constrained space.
    FlowView.FlowStrategy
    Strategy for maintaining the physical form of the flow.
    GlyphView
    A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
    GlyphView.GlyphPainter
    A class to perform rendering of the glyphs.
    Highlighter
    An interface for an object that allows one to mark up the background with colored areas.
    Highlighter.Highlight
    Highlighter.HighlightPainter
    Highlight renderer.
    InternationalFormatter
    InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
    JTextComponent
    JTextComponent is the base class for swing text components.
    JTextComponent.DropLocation
    Represents a drop location for JTextComponents.
    JTextComponent.KeyBinding
    Binding record for creating key bindings.
    Keymap
    A collection of bindings of KeyStrokes to actions.
    LayeredHighlighter
    LayeredHighlighter.LayerPainter
    Layered highlight renderer.
    LayoutQueue
    A queue of text layout tasks.
    MutableAttributeSet
    A generic interface for a mutable collection of unique attributes.
    NavigationFilter
    NavigationFilter can be used to restrict where the cursor can be positioned.
    NavigationFilter.FilterBypass
    Used as a way to circumvent calling back into the caret to position the cursor.
    PlainView
    Implements View interface for a simple multi-line text view that has text in one font and color.
    Position
    Represents a location within a document.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    Segment
    A segment of a character array representing a fragment of text.
    Style
    A collection of attributes to associate with an element in a document.
    StyleConstants
    A collection of well known or common attribute keys and methods to apply to an AttributeSet or MutableAttributeSet to get/set the properties in a typesafe manner.
    StyleContext
    A pool of styles and their associated resources.
    StyleContext.SmallAttributeSet
    This class holds a small number of attributes in an array.
    StyledDocument
    Interface for a generic styled document.
    StyledEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    StyledEditorKit.StyledTextAction
    An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
    TabableView
    Interface for Views that have size dependent upon tabs.
    TabExpander
    Simple interface to allow for different types of implementations of tab expansion.
    TableView.TableCell
    Deprecated.
    A table cell can now be any View implementation.
    TableView.TableRow
    View of a row in a row-centric table.
    TabSet
    A TabSet is comprised of many TabStops.
    TabStop
    This class encapsulates a single tab stop (basically as tab stops are thought of by RTF).
    TextAction
    An Action implementation useful for key bindings that are shared across a number of different text components.
    View
    A very important part of the text package is the View class.
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Classes in javax.swing.text used by javax.swing.text.html
    类与描述
    AbstractDocument
    An implementation of the document interface to serve as a basis for implementing various kinds of documents.
    AbstractDocument.AbstractElement
    Implements the abstract part of an element.
    AbstractDocument.AttributeContext
    An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
    AbstractDocument.BranchElement
    Implements a composite element that contains other elements.
    AbstractDocument.Content
    Interface to describe a sequence of character content that can be edited.
    AbstractDocument.DefaultDocumentEvent
    Stores document changes as the document is being modified.
    AbstractDocument.LeafElement
    Implements an element that directly represents content of some kind.
    AbstractWriter
    AbstractWriter is an abstract class that actually does the work of writing out the element tree including the attributes.
    AttributeSet
    A collection of unique attributes.
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    BoxView
    A view that arranges its children into a box shape by tiling its children along an axis.
    ComponentView
    Component decorator that implements the view interface.
    CompositeView
    CompositeView is an abstract View implementation which manages one or more child views.
    DefaultEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    DefaultStyledDocument
    A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
    DefaultStyledDocument.ElementSpec
    Specification for building elements.
    Document
    The Document is a container for text that serves as the model for swing text components.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    Element
    Interface to describe a structural piece of a document.
    GlyphView
    A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
    LabelView
    A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
    MutableAttributeSet
    A generic interface for a mutable collection of unique attributes.
    ParagraphView
    View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
    Position.Bias
    A typesafe enumeration to indicate bias to a position in the model.
    Style
    A collection of attributes to associate with an element in a document.
    StyleContext
    A pool of styles and their associated resources.
    StyleContext.SmallAttributeSet
    This class holds a small number of attributes in an array.
    StyledDocument
    Interface for a generic styled document.
    StyledEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    StyledEditorKit.StyledTextAction
    An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
    TabableView
    Interface for Views that have size dependent upon tabs.
    TextAction
    An Action implementation useful for key bindings that are shared across a number of different text components.
    View
    A very important part of the text package is the View class.
    ViewFactory
    A factory to create a view of some portion of document subject.
  • Classes in javax.swing.text used by javax.swing.text.html.parser
    类与描述
    ChangedCharSetException
    ChangedCharSetException as the name indicates is an exception thrown when the charset is changed.
    SimpleAttributeSet
    A straightforward implementation of MutableAttributeSet using a hash table.
  • Classes in javax.swing.text used by javax.swing.text.rtf
    类与描述
    BadLocationException
    This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
    DefaultEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
    Document
    The Document is a container for text that serves as the model for swing text components.
    EditorKit
    Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
    StyledEditorKit
    This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
  • Classes in javax.swing.text used by javax.swing.tree
    类与描述
    JTextComponent
    JTextComponent is the base class for swing text components.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Utilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 Utilities

  • java.lang.Object
    • javax.swing.text.Utilities

  • public class Utilities
extends Object
    A collection of methods to deal with various text related activities.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Utilities()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
      Draws the given text, expanding any tabs that are contained using the given tab expansion technique.
      static int getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determine where to break the given text to fit within the given span.
      static int getNextWord(JTextComponent c, int offs)
      Determines the start of the next word for the given location.
      static Element getParagraphElement(JTextComponent c, int offs)
      Determines the element to use for a paragraph/line.
      static int getPositionAbove(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row above.
      static int getPositionBelow(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row below.
      static int getPreviousWord(JTextComponent c, int offs)
      Determine the start of the prev word for the given location.
      static int getRowEnd(JTextComponent c, int offs)
      Determines the ending row model position of the row that contains the specified model position.
      static int getRowStart(JTextComponent c, int offs)
      Determines the starting row model position of the row that contains the specified model position.
      static int getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determines the relative offset into the given text that best represents the given span in the view coordinate system.
      static int | getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
      static int getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
      Determines the width of the given segment of text taking tabs into consideration.
      static int getWordEnd(JTextComponent c, int offs)
      Determines the end of a word for the given location.
      static int getWordStart(JTextComponent c, int offs)
      Determines the start of a word for the given model location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Utilities

        public Utilities()

    • 方法详细信息

      • drawTabbedText

        public static final int drawTabbedText(Segment s,
                 int x,
                 int y,
                 Graphics g,
                 TabExpander e,
                 int startOffset)
        Draws the given text, expanding any tabs that are contained using the given tab expansion technique. This particular implementation renders in a 1.1 style coordinate system where ints are used and 72dpi is assumed.
        参数：
        s - the source of the text
        x - the X origin >= 0
        y - the Y origin >= 0
        g - the graphics context
        e - how to expand the tabs. If this value is null, tabs will be expanded as a space character.
        startOffset - starting offset of the text in the document >= 0
        返回：
        the X location at the end of the rendered text

      • getTabbedTextWidth

        public static final int getTabbedTextWidth(Segment s,
                     FontMetrics metrics,
                     int x,
                     TabExpander e,
                     int startOffset)
        Determines the width of the given segment of text taking tabs into consideration. This is implemented in a 1.1 style coordinate system where ints are used and 72dpi is assumed.
        参数：
        s - the source of the text
        metrics - the font metrics to use for the calculation
        x - the X origin >= 0
        e - how to expand the tabs. If this value is null, tabs will be expanded as a space character.
        startOffset - starting offset of the text in the document >= 0
        返回：
        the width of the text

      • getTabbedTextOffset

        public static final int getTabbedTextOffset(Segment s,
                      FontMetrics metrics,
                      int x0,
                      int x,
                      TabExpander e,
                      int startOffset)
        Determines the relative offset into the given text that best represents the given span in the view coordinate system. This is implemented in a 1.1 style coordinate system where ints are used and 72dpi is assumed.
        参数：
        s - the source of the text
        metrics - the font metrics to use for the calculation
        x0 - the starting view location representing the start of the given text >= 0.
        x - the target view location to translate to an offset into the text >= 0.
        e - how to expand the tabs. If this value is null, tabs will be expanded as a space character.
        startOffset - starting offset of the text in the document >= 0
        返回：
        the offset into the text >= 0

      • getTabbedTextOffset

        public static final int getTabbedTextOffset(Segment s,
                      FontMetrics metrics,
                      int x0,
                      int x,
                      TabExpander e,
                      int startOffset,
                      boolean round)

      • getBreakLocation

        public static final int getBreakLocation(Segment s,
                   FontMetrics metrics,
                   int x0,
                   int x,
                   TabExpander e,
                   int startOffset)
        Determine where to break the given text to fit within the given span. This tries to find a word boundary.
        参数：
        s - the source of the text
        metrics - the font metrics to use for the calculation
        x0 - the starting view location representing the start of the given text.
        x - the target view location to translate to an offset into the text.
        e - how to expand the tabs. If this value is null, tabs will be expanded as a space character.
        startOffset - starting offset in the document of the text
        返回：
        the offset into the given text

      • getRowStart

        public static final int getRowStart(JTextComponent c,
              int offs)
                             throws BadLocationException
        Determines the starting row model position of the row that contains the specified model position. The component given must have a size to compute the result. If the component doesn't have a size a value of -1 will be returned.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the position >= 0 if the request can be computed, otherwise a value of -1 will be returned.
        抛出：
        BadLocationException - if the offset is out of range

      • getRowEnd

        public static final int getRowEnd(JTextComponent c,
            int offs)
                           throws BadLocationException
        Determines the ending row model position of the row that contains the specified model position. The component given must have a size to compute the result. If the component doesn't have a size a value of -1 will be returned.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the position >= 0 if the request can be computed, otherwise a value of -1 will be returned.
        抛出：
        BadLocationException - if the offset is out of range

      • getPositionAbove

        public static final int getPositionAbove(JTextComponent c,
                   int offs,
                   int x)
                                  throws BadLocationException
        Determines the position in the model that is closest to the given view location in the row above. The component given must have a size to compute the result. If the component doesn't have a size a value of -1 will be returned.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        x - the X coordinate >= 0
        返回：
        the position >= 0 if the request can be computed, otherwise a value of -1 will be returned.
        抛出：
        BadLocationException - if the offset is out of range

      • getPositionBelow

        public static final int getPositionBelow(JTextComponent c,
                   int offs,
                   int x)
                                  throws BadLocationException
        Determines the position in the model that is closest to the given view location in the row below. The component given must have a size to compute the result. If the component doesn't have a size a value of -1 will be returned.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        x - the X coordinate >= 0
        返回：
        the position >= 0 if the request can be computed, otherwise a value of -1 will be returned.
        抛出：
        BadLocationException - if the offset is out of range

      • getWordStart

        public static final int getWordStart(JTextComponent c,
               int offs)
                              throws BadLocationException
        Determines the start of a word for the given model location. Uses BreakIterator.getWordInstance() to actually get the words.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the location in the model of the word start >= 0
        抛出：
        BadLocationException - if the offset is out of range

      • getWordEnd

        public static final int getWordEnd(JTextComponent c,
             int offs)
                            throws BadLocationException
        Determines the end of a word for the given location. Uses BreakIterator.getWordInstance() to actually get the words.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the location in the model of the word end >= 0
        抛出：
        BadLocationException - if the offset is out of range

      • getNextWord

        public static final int getNextWord(JTextComponent c,
              int offs)
                             throws BadLocationException
        Determines the start of the next word for the given location. Uses BreakIterator.getWordInstance() to actually get the words.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the location in the model of the word start >= 0
        抛出：
        BadLocationException - if the offset is out of range

      • getPreviousWord

        public static final int getPreviousWord(JTextComponent c,
                  int offs)
                                 throws BadLocationException
        Determine the start of the prev word for the given location. Uses BreakIterator.getWordInstance() to actually get the words.
        参数：
        c - the editor
        offs - the offset in the document >= 0
        返回：
        the location in the model of the word start >= 0
        抛出：
        BadLocationException - if the offset is out of range

      • getParagraphElement

        public static final Element getParagraphElement(JTextComponent c,
                          int offs)
        Determines the element to use for a paragraph/line.
        参数：
        c - the editor
        offs - the starting offset in the document >= 0
        返回：
        the element
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


View

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 View

  • java.lang.Object
    • javax.swing.text.View
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    AsyncBoxView, ComponentView, CompositeView, GlyphView, IconView, ImageView, PlainView

    public abstract class View
extends Object
implements SwingConstants

    A very important part of the text package is the View class. As the name suggests it represents a view of the text model, or a piece of the text model. It is this class that is responsible for the look of the text component. The view is not intended to be some completely new thing that one must learn, but rather is much like a lightweight component.

    By default, a view is very light. It contains a reference to the parent view from which it can fetch many things without holding state, and it contains a reference to a portion of the model (Element). A view does not have to exactly represent an element in the model, that is simply a typical and therefore convenient mapping. A view can alternatively maintain a couple of Position objects to maintain its location in the model (i.e. represent a fragment of an element). This is typically the result of formatting where views have been broken down into pieces. The convenience of a substantial relationship to the element makes it easier to build factories to produce the views, and makes it easier to keep track of the view pieces as the model is changed and the view must be changed to reflect the model. Simple views therefore represent an Element directly and complex views do not.

    A view has the following responsibilities:

    Participate in layout.

    The view has a setSize method which is like doLayout and setSize in Component combined. The view has a preferenceChanged method which is like invalidate in Component except that one can invalidate just one axis and the child requesting the change is identified.

    A View expresses the size that it would like to be in terms of three values, a minimum, a preferred, and a maximum span. Layout in a view is can be done independently upon each axis. For a properly functioning View implementation, the minimum span will be <= the preferred span which in turn will be <= the maximum span.

    The above text describes this graphic.

    The minimum set of methods for layout are:

    • getMinimumSpan
    • getPreferredSpan
    • getMaximumSpan
    • getAlignment
    • preferenceChanged
    • setSize

    The setSize method should be prepared to be called a number of times (i.e. It may be called even if the size didn't change). The setSize method is generally called to make sure the View layout is complete prior to trying to perform an operation on it that requires an up-to-date layout. A view's size should always be set to a value within the minimum and maximum span specified by that view. Additionally, the view must always call the preferenceChanged method on the parent if it has changed the values for the layout it would like, and expects the parent to honor. The parent View is not required to recognize a change until the preferenceChanged has been sent. This allows parent View implementations to cache the child requirements if desired. The calling sequence looks something like the following:

    Sample calling sequence between parent view and child view: setSize, getMinimum, getPreferred, getMaximum, getAlignment, setSize

    The exact calling sequence is up to the layout functionality of the parent view (if the view has any children). The view may collect the preferences of the children prior to determining what it will give each child, or it might iteratively update the children one at a time.

    Render a portion of the model.

    This is done in the paint method, which is pretty much like a component paint method. Views are expected to potentially populate a fairly large tree. A View has the following semantics for rendering:

    • The view gets its allocation from the parent at paint time, so it must be prepared to redo layout if the allocated area is different from what it is prepared to deal with.
    • The coordinate system is the same as the hosting Component (i.e. the Component returned by the getContainer method). This means a child view lives in the same coordinate system as the parent view unless the parent has explicitly changed the coordinate system. To schedule itself to be repainted a view can call repaint on the hosting Component.
    • The default is to not clip the children. It is more efficient to allow a view to clip only if it really feels it needs clipping.
    • The Graphics object given is not initialized in any way. A view should set any settings needed.
    • A View is inherently transparent. While a view may render into its entire allocation, typically a view does not. Rendering is performed by tranversing down the tree of View implementations. Each View is responsible for rendering its children. This behavior is depended upon for thread safety. While view implementations do not necessarily have to be implemented with thread safety in mind, other view implementations that do make use of concurrency can depend upon a tree traversal to guarantee thread safety.
    • The order of views relative to the model is up to the implementation. Although child views will typically be arranged in the same order that they occur in the model, they may be visually arranged in an entirely different order. View implementations may have Z-Order associated with them if the children are overlapping.

    The methods for rendering are:

    • paint

    Translate between the model and view coordinate systems.

    Because the view objects are produced from a factory and therefore cannot necessarily be counted upon to be in a particular pattern, one must be able to perform translation to properly locate spatial representation of the model. The methods for doing this are:

    • modelToView
    • viewToModel
    • getDocument
    • getElement
    • getStartOffset
    • getEndOffset

    The layout must be valid prior to attempting to make the translation. The translation is not valid, and must not be attempted while changes are being broadcasted from the model via a DocumentEvent.

    Respond to changes from the model.

    If the overall view is represented by many pieces (which is the best situation if one want to be able to change the view and write the least amount of new code), it would be impractical to have a huge number of DocumentListeners. If each view listened to the model, only a few would actually be interested in the changes broadcasted at any given time. Since the model has no knowledge of views, it has no way to filter the broadcast of change information. The view hierarchy itself is instead responsible for propagating the change information. At any level in the view hierarchy, that view knows enough about its children to best distribute the change information further. Changes are therefore broadcasted starting from the root of the view hierarchy. The methods for doing this are:

    • insertUpdate
    • removeUpdate
    • changedUpdate

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int BadBreakWeight
      The weight to indicate a view is a bad break opportunity for the purpose of formatting.
      static int ExcellentBreakWeight
      The weight to indicate a view supports breaking, and this represents a very attractive place to break.
      static int ForcedBreakWeight
      The weight to indicate a view supports breaking, and must be broken to be represented properly when placed in a view that formats its children by breaking them.
      static int GoodBreakWeight
      The weight to indicate a view supports breaking, but better opportunities probably exist.
      static int X_AXIS
      Axis for format/break operations.
      static int Y_AXIS
      Axis for format/break operations.

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      View(Element elem)
      Creates a new View object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void append(View v)
      Appends a single child view.
      View breakView(int axis, int offset, float pos, float len)
      Tries to break this view on the given axis.
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      View createFragment(int p0, int p1)
      Creates a view that represents a portion of the element.
      protected void forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the DocumentEvent to the give child view.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      int getBreakWeight(int axis, float pos, float len)
      Determines how attractive a break opportunity in this view is.
      Shape getChildAllocation(int index, Shape a)
      Fetches the allocation for the given child view.
      Container getContainer()
      Fetches the container hosting the view.
      Document getDocument()
      Fetches the model associated with the view.
      Element getElement()
      Fetches the structural portion of the subject that this view is mapped to.
      int getEndOffset()
      Fetches the portion of the model for which this view is responsible.
      Graphics getGraphics()
      Fetch a Graphics for rendering.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      int getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location at which one might place a caret.
      View getParent()
      Returns the parent of the view.
      abstract float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      int getResizeWeight(int axis)
      Determines the resizability of the view along the given axis.
      int getStartOffset()
      Fetches the portion of the model for which this view is responsible.
      String getToolTipText(float x, float y, Shape allocation)
      Returns the tooltip text at the specified location.
      View getView(int n)
      Gets the nth child view.
      int getViewCount()
      Returns the number of views in this view.
      ViewFactory getViewFactory()
      Fetches the ViewFactory implementation that is feeding the view hierarchy.
      int getViewIndex(float x, float y, Shape allocation)
      Returns the child view index representing the given position in the view.
      int getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      void insert(int offs, View v)
      Inserts a single child view.
      void insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      boolean isVisible()
      Returns a boolean that indicates whether the view is visible or not.
      Shape modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping, for a given region, from the document model coordinate space to the view coordinate space.
      Shape modelToView(int pos, Shape a)
      Deprecated.
      abstract Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping, for a given character, from the document model coordinate space to the view coordinate space.
      abstract void paint(Graphics g, Shape allocation)
      Renders using the given rendering surface and area on that surface.
      void preferenceChanged(View child, boolean width, boolean height)
      Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
      void remove(int i)
      Removes one of the children at the given position.
      void removeAll()
      Removes all of the children.
      void removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void replace(int offset, int length, View[] views)
      Replaces child views.
      void setParent(View parent)
      Establishes the parent view for this view.
      void setSize(float width, float height)
      Sets the size of the view.
      protected boolean updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for.
      protected void updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a)
      Updates the layout in response to receiving notification of change from the model.
      int viewToModel(float x, float y, Shape a)
      Deprecated.
      abstract int viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • BadBreakWeight

        public static final int BadBreakWeight
        The weight to indicate a view is a bad break opportunity for the purpose of formatting. This value indicates that no attempt should be made to break the view into fragments as the view has not been written to support fragmenting.
        另请参见：
        getBreakWeight(int, float, float), GoodBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, Constant Field Values

      • GoodBreakWeight

        public static final int GoodBreakWeight
        The weight to indicate a view supports breaking, but better opportunities probably exist.
        另请参见：
        getBreakWeight(int, float, float), BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, Constant Field Values

      • ExcellentBreakWeight

        public static final int ExcellentBreakWeight
        The weight to indicate a view supports breaking, and this represents a very attractive place to break.
        另请参见：
        getBreakWeight(int, float, float), BadBreakWeight, GoodBreakWeight, ForcedBreakWeight, Constant Field Values

      • ForcedBreakWeight

        public static final int ForcedBreakWeight
        The weight to indicate a view supports breaking, and must be broken to be represented properly when placed in a view that formats its children by breaking them.
        另请参见：
        getBreakWeight(int, float, float), BadBreakWeight, GoodBreakWeight, ExcellentBreakWeight, Constant Field Values

      • X_AXIS

        public static final int X_AXIS
        Axis for format/break operations.
        另请参见：
        Constant Field Values

      • Y_AXIS

        public static final int Y_AXIS
        Axis for format/break operations.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • View

        public View(Element elem)
        Creates a new View object.
        参数：
        elem - the Element to represent

    • 方法详细信息

      • getParent

        public View getParent()
        Returns the parent of the view.
        返回：
        the parent, or null if none exists

      • isVisible

        public boolean isVisible()
        Returns a boolean that indicates whether the view is visible or not. By default all views are visible.
        返回：
        always returns true

      • getPreferredSpan

        public abstract float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view
        另请参见：
        getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis.
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the minimum span the view can be rendered into
        另请参见：
        getPreferredSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis.
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the maximum span the view can be rendered into
        另请参见：
        getPreferredSpan(int)

      • preferenceChanged

        public void preferenceChanged(View child,
                     boolean width,
                     boolean height)
        Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout. By default this just propagates upward to the next parent. The root view will call revalidate on the associated text component.
        参数：
        child - the child view
        width - true if the width preference has changed
        height - true if the height preference has changed
        另请参见：
        JComponent.revalidate()

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. The desired alignment is returned. This should be a value >= 0.0 and <= 1.0, where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin. An alignment of 0.5 would be the center of the view.
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the value 0.5

      • paint

        public abstract void paint(Graphics g,
         Shape allocation)
        Renders using the given rendering surface and area on that surface. The view may need to do layout and create child views to enable itself to render into the given allocation.
        参数：
        g - the rendering surface to use
        allocation - the allocated region to render into

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. This is guaranteed to be called before any other methods if the parent view is functioning properly. This is also the last method called, since it is called to indicate the view has been removed from the hierarchy as well. When this method is called to set the parent to null, this method does the same for each of its children, propogating the notification that they have been disconnected from the view tree. If this is reimplemented, super.setParent() should be called.
        参数：
        parent - the new parent, or null if the view is being removed from a parent

      • getViewCount

        public int getViewCount()
        Returns the number of views in this view. Since the default is to not be a composite view this returns 0.
        返回：
        the number of views >= 0
        另请参见：
        getViewCount()

      • getView

        public View getView(int n)
        Gets the nth child view. Since there are no children by default, this returns null.
        参数：
        n - the number of the view to get, >= 0 && < getViewCount()
        返回：
        the view

      • removeAll

        public void removeAll()
        Removes all of the children. This is a convenience call to replace.
        从以下版本开始：
        1.3

      • remove

        public void remove(int i)
        Removes one of the children at the given position. This is a convenience call to replace.
        从以下版本开始：
        1.3

      • insert

        public void insert(int offs,
          View v)
        Inserts a single child view. This is a convenience call to replace.
        参数：
        offs - the offset of the view to insert before >= 0
        v - the view
        从以下版本开始：
        1.3
        另请参见：
        replace(int, int, javax.swing.text.View[])

      • append

        public void append(View v)
        Appends a single child view. This is a convenience call to replace.
        参数：
        v - the view
        从以下版本开始：
        1.3
        另请参见：
        replace(int, int, javax.swing.text.View[])

      • replace

        public void replace(int offset,
           int length,
           View[] views)
        Replaces child views. If there are no views to remove this acts as an insert. If there are no views to add this acts as a remove. Views being removed will have the parent set to null, and the internal reference to them removed so that they can be garbage collected. This is implemented to do nothing, because by default a view has no children.
        参数：
        offset - the starting index into the child views to insert the new views. This should be a value >= 0 and <= getViewCount
        length - the number of existing child views to remove This should be a value >= 0 and <= (getViewCount() - offset).
        views - the child views to add. This value can be null to indicate no children are being added (useful to remove).
        从以下版本开始：
        1.3

      • getViewIndex

        public int getViewIndex(int pos,
               Position.Bias b)
        Returns the child view index representing the given position in the model. By default a view has no children so this is implemented to return -1 to indicate there is no valid child index for any position.
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position
        从以下版本开始：
        1.3

      • getChildAllocation

        public Shape getChildAllocation(int index,
                       Shape a)
        Fetches the allocation for the given child view. This enables finding out where various views are located, without assuming how the views store their location. This returns null since the default is to not have any child views.
        参数：
        index - the index of the child, >= 0 && < getViewCount()
        a - the allocation to this view
        返回：
        the allocation to the child

      • getNextVisualPositionFrom

        public int getNextVisualPositionFrom(int pos,
                            Position.Bias b,
                            Shape a,
                            int direction,
                            Position.Bias[] biasRet)
                              throws BadLocationException
        Provides a way to determine the next visually represented model location at which one might place a caret. Some views may not be visible, they might not be in the same order found in the model, or they just might not allow access to some of the locations in the model.
        参数：
        pos - the position to convert >= 0
        a - the allocated region in which to render
        direction - the direction from the current position that can be thought of as the arrow keys typically found on a keyboard. This will be one of the following values:
        • SwingConstants.WEST
        • SwingConstants.EAST
        • SwingConstants.NORTH
        • SwingConstants.SOUTH
        返回：
        the location within the model that best represents the next location visual position
        抛出：
        BadLocationException
        IllegalArgumentException - if direction doesn't have one of the legal values above

      • modelToView

        public abstract Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                           throws BadLocationException
        Provides a mapping, for a given character, from the document model coordinate space to the view coordinate space.
        参数：
        pos - the position of the desired character (>=0)
        a - the area of the view, which encompasses the requested character
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box, in view coordinate space, of the character at the specified position
        抛出：
        BadLocationException - if the specified position does not represent a valid location in the associated document
        IllegalArgumentException - if b is not one of the legal Position.Bias values listed above
        另请参见：
        viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • modelToView

        public Shape modelToView(int p0,
                Position.Bias b0,
                int p1,
                Position.Bias b1,
                Shape a)
                  throws BadLocationException
        Provides a mapping, for a given region, from the document model coordinate space to the view coordinate space. The specified region is created as a union of the first and last character positions.
        参数：
        p0 - the position of the first character (>=0)
        b0 - the bias of the first character position, toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b0 will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        p1 - the position of the last character (>=0)
        b1 - the bias for the second character position, defined one of the legal values shown above
        a - the area of the view, which encompasses the requested region
        返回：
        the bounding box which is a union of the region specified by the first and last character positions
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        IllegalArgumentException - if b0 or b1 are not one of the legal Position.Bias values listed above
        另请参见：
        viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • viewToModel

        public abstract int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] biasReturn)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model. The biasReturn argument will be filled in to indicate that the point given is closer to the next character in the model or the previous character in the model.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region in which to render
        返回：
        the location within the model that best represents the given point in the view >= 0. The biasReturn argument will be filled in to indicate that the point given is closer to the next character in the model or the previous character in the model.

      • insertUpdate

        public void insertUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. To reduce the burden to subclasses, this functionality is spread out into the following calls that subclasses can reimplement:
        1. updateChildren is called if there were any changes to the element this view is responsible for. If this view has child views that are represent the child elements, then this method should do whatever is necessary to make sure the child views correctly represent the model.
        2. forwardUpdate is called to forward the DocumentEvent to the appropriate child views.
        3. updateLayout is called to give the view a chance to either repair its layout, to reschedule layout, or do nothing.
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. To reduce the burden to subclasses, this functionality is spread out into the following calls that subclasses can reimplement:
        1. updateChildren is called if there were any changes to the element this view is responsible for. If this view has child views that are represent the child elements, then this method should do whatever is necessary to make sure the child views correctly represent the model.
        2. forwardUpdate is called to forward the DocumentEvent to the appropriate child views.
        3. updateLayout is called to give the view a chance to either repair its layout, to reschedule layout, or do nothing.
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for. To reduce the burden to subclasses, this functionality is spread out into the following calls that subclasses can reimplement:
        1. updateChildren is called if there were any changes to the element this view is responsible for. If this view has child views that are represent the child elements, then this method should do whatever is necessary to make sure the child views correctly represent the model.
        2. forwardUpdate is called to forward the DocumentEvent to the appropriate child views.
        3. updateLayout is called to give the view a chance to either repair its layout, to reschedule layout, or do nothing.
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • getDocument

        public Document getDocument()
        Fetches the model associated with the view.
        返回：
        the view model, null if none
        另请参见：
        getDocument()

      • getStartOffset

        public int getStartOffset()
        Fetches the portion of the model for which this view is responsible.
        返回：
        the starting offset into the model >= 0
        另请参见：
        getStartOffset()

      • getEndOffset

        public int getEndOffset()
        Fetches the portion of the model for which this view is responsible.
        返回：
        the ending offset into the model >= 0
        另请参见：
        getEndOffset()

      • getElement

        public Element getElement()
        Fetches the structural portion of the subject that this view is mapped to. The view may not be responsible for the entire portion of the element.
        返回：
        the subject
        另请参见：
        getElement()

      • getGraphics

        public Graphics getGraphics()
        Fetch a Graphics for rendering. This can be used to determine font characteristics, and will be different for a print view than a component view.
        返回：
        a Graphics object for rendering
        从以下版本开始：
        1.3

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. By default this simply returns the attributes of the associated element. This method should be used rather than using the element directly to obtain access to the attributes to allow view-specific attributes to be mixed in or to allow the view to have view-specific conversion of attributes by subclasses. Each view should document what attributes it recognizes for the purpose of rendering or layout, and should always access them through the AttributeSet returned by this method.

      • breakView

        public View breakView(int axis,
             int offset,
             float pos,
             float len)
        Tries to break this view on the given axis. This is called by views that try to do formatting of their children. For example, a view of a paragraph will typically try to place its children into row and views representing chunks of text can sometimes be broken down into smaller pieces.

        This is implemented to return the view itself, which represents the default behavior on not being breakable. If the view does support breaking, the starting offset of the view returned should be the given offset, and the end offset should be less than or equal to the end offset of the view being broken.

        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        offset - the location in the document model that a broken fragment would occupy >= 0. This would be the starting offset of the fragment returned
        pos - the position along the axis that the broken view would occupy >= 0. This may be useful for things like tab calculations
        len - specifies the distance along the axis where a potential break is desired >= 0
        返回：
        the fragment of the view that represents the given span, if the view can be broken. If the view doesn't support breaking behavior, the view itself is returned.
        另请参见：
        ParagraphView

      • createFragment

        public View createFragment(int p0,
                  int p1)
        Creates a view that represents a portion of the element. This is potentially useful during formatting operations for taking measurements of fragments of the view. If the view doesn't support fragmenting (the default), it should return itself.
        参数：
        p0 - the starting offset >= 0. This should be a value greater or equal to the element starting offset and less than the element ending offset.
        p1 - the ending offset > p0. This should be a value less than or equal to the elements end offset and greater than the elements starting offset.
        返回：
        the view fragment, or itself if the view doesn't support breaking into fragments
        另请参见：
        LabelView

      • getBreakWeight

        public int getBreakWeight(int axis,
                 float pos,
                 float len)
        Determines how attractive a break opportunity in this view is. This can be used for determining which view is the most attractive to call breakView on in the process of formatting. A view that represents text that has whitespace in it might be more attractive than a view that has no whitespace, for example. The higher the weight, the more attractive the break. A value equal to or lower than BadBreakWeight should not be considered for a break. A value greater than or equal to ForcedBreakWeight should be broken.

        This is implemented to provide the default behavior of returning BadBreakWeight unless the length is greater than the length of the view in which case the entire view represents the fragment. Unless a view has been written to support breaking behavior, it is not attractive to try and break the view. An example of a view that does support breaking is LabelView. An example of a view that uses break weight is ParagraphView.

        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        pos - the potential location of the start of the broken view >= 0. This may be useful for calculating tab positions
        len - specifies the relative length from pos where a potential break is desired >= 0
        返回：
        the weight, which should be a value between ForcedBreakWeight and BadBreakWeight
        另请参见：
        LabelView, ParagraphView, BadBreakWeight, GoodBreakWeight, ExcellentBreakWeight, ForcedBreakWeight

      • getResizeWeight

        public int getResizeWeight(int axis)
        Determines the resizability of the view along the given axis. A value of 0 or less is not resizable.
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the weight

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view along the given axis, if it has any layout duties.
        参数：
        width - the width >= 0
        height - the height >= 0

      • getContainer

        public Container getContainer()
        Fetches the container hosting the view. This is useful for things like scheduling a repaint, finding out the host components font, etc. The default implementation of this is to forward the query to the parent view.
        返回：
        the container, null if none

      • getViewFactory

        public ViewFactory getViewFactory()
        Fetches the ViewFactory implementation that is feeding the view hierarchy. Normally the views are given this as an argument to updates from the model when they are most likely to need the factory, but this method serves to provide it at other times.
        返回：
        the factory, null if none

      • getToolTipText

        public String getToolTipText(float x,
                    float y,
                    Shape allocation)
        Returns the tooltip text at the specified location. The default implementation returns the value from the child View identified by the passed in location.
        从以下版本开始：
        1.4
        另请参见：
        JTextComponent.getToolTipText(java.awt.event.MouseEvent)

      • getViewIndex

        public int getViewIndex(float x,
               float y,
               Shape allocation)
        Returns the child view index representing the given position in the view. This iterates over all the children returning the first with a bounds that contains x, y.
        参数：
        x - the x coordinate
        y - the y coordinate
        allocation - current allocation of the View.
        返回：
        index of the view representing the given location, or -1 if no view represents that position
        从以下版本开始：
        1.4

      • updateChildren

        protected boolean updateChildren(DocumentEvent.ElementChange ec,
                     DocumentEvent e,
                     ViewFactory f)
        Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for. This is implemented to assume the child views are directly responsible for the child elements of the element this view represents. The ViewFactory is used to create child views for each element specified as added in the ElementChange, starting at the index specified in the given ElementChange. The number of child views representing the removed elements specified are removed.
        参数：
        ec - the change information for the element this view is responsible for. This should not be null if this method gets called
        e - the change information from the associated document
        f - the factory to use to build child views
        返回：
        whether or not the child views represent the child elements of the element this view is responsible for. Some views create children that represent a portion of the element they are responsible for, and should return false. This information is used to determine if views in the range of the added elements should be forwarded to or not
        从以下版本开始：
        1.3
        另请参见：
        insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • forwardUpdate

        protected void forwardUpdate(DocumentEvent.ElementChange ec,
                 DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Forwards the given DocumentEvent to the child views that need to be notified of the change to the model. If there were changes to the element this view is responsible for, that should be considered when forwarding (i.e. new child views should not get notified).
        参数：
        ec - changes to the element this view is responsible for (may be null if there were no changes).
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        从以下版本开始：
        1.3
        另请参见：
        insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • forwardUpdateToView

        protected void forwardUpdateToView(View v,
                       DocumentEvent e,
                       Shape a,
                       ViewFactory f)
        Forwards the DocumentEvent to the give child view. This simply messages the view with a call to insertUpdate, removeUpdate, or changedUpdate depending upon the type of the event. This is called by forwardUpdate to forward the event to children that need it.
        参数：
        v - the child view to forward the event to
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        从以下版本开始：
        1.3
        另请参见：
        forwardUpdate(javax.swing.event.DocumentEvent.ElementChange, javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • updateLayout

        protected void updateLayout(DocumentEvent.ElementChange ec,
                DocumentEvent e,
                Shape a)
        Updates the layout in response to receiving notification of change from the model. This is implemented to call preferenceChanged to reschedule a new layout if the ElementChange record is not null.
        参数：
        ec - changes to the element this view is responsible for (may be null if there were no changes)
        e - the change information from the associated document
        a - the current allocation of the view
        从以下版本开始：
        1.3
        另请参见：
        insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • modelToView

        @Deprecated
public Shape modelToView(int pos,
                           Shape a)
                  throws BadLocationException
        Deprecated.
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it. This is implemented to default the bias to Position.Bias.Forward which was previously implied.
        参数：
        pos - the position to convert >= 0
        a - the allocated region in which to render
        返回：
        the bounding box of the given position is returned
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        @Deprecated
public int viewToModel(float x,
                         float y,
                         Shape a)
        Deprecated.
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        参数：
        x - the X coordinate >= 0
        y - the Y coordinate >= 0
        a - the allocated region in which to render
        返回：
        the location within the model that best represents the given point in the view >= 0
        另请参见：
        viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ViewFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text

Interface ViewFactory

  • All Known Implementing Classes:
    BasicEditorPaneUI, BasicFormattedTextFieldUI, BasicPasswordFieldUI, BasicTextAreaUI, BasicTextFieldUI, BasicTextPaneUI, BasicTextUI, DefaultTextUI, HTMLEditorKit.HTMLFactory, MetalTextFieldUI, SynthEditorPaneUI, SynthFormattedTextFieldUI, SynthPasswordFieldUI, SynthTextAreaUI, SynthTextFieldUI, SynthTextPaneUI

    public interface ViewFactory
    A factory to create a view of some portion of document subject. This is intended to enable customization of how views get mapped over a document model.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View create(Element elem)
      Creates a view from the given structural element of a document.

    • 方法详细信息

      • create

        View create(Element elem)
        Creates a view from the given structural element of a document.
        参数：
        elem - the piece of the document to build a view of
        返回：
        the view
        另请参见：
        View
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcl " "g "ggui""mocskh sslo


WrappedPlainView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 WrappedPlainView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.WrappedPlainView
  • 所有已实现的接口：
    SwingConstants, TabExpander

    public class WrappedPlainView
extends BoxView
implements TabExpander
    View of plain text (text with only one font and color) that does line-wrapping. This view expects that its associated element has child elements that represent the lines it should be wrapping. It is implemented as a vertical box that contains logical line views. The logical line views are nested classes that render the logical line as multiple physical line if the logical line is too wide to fit within the allocation. The line views draw upon the outer class for its state to reduce their memory requirements.

    The line views do all of their rendering through the drawLine method which in turn does all of its rendering through the drawSelectedText and drawUnselectedText methods. This enables subclasses to easily specialize the rendering without concern for the layout aspects.

    另请参见：
    View

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrappedPlainView(Element elem)
      Creates a new WrappedPlainView.
      WrappedPlainView(Element elem, boolean wordWrap)
      Creates a new WrappedPlainView.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected int calculateBreakPosition(int p0, int p1)
      This is called by the nested wrapped line views to determine the break location.
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected void drawLine(int p0, int p1, Graphics g, int x, int y)
      Renders a line of text, suppressing whitespace at the end and expanding any tabs.
      protected int drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      protected Segment getLineBuffer()
      Gives access to a buffer that can be used to fetch text from the associated document.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      protected int getTabSize()
      Returns the tab size set for the document, defaulting to 8.
      void insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      protected void loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      float nextTabStop(float x, int tabOffset)
      Returns the next tab stop position after a given reference position.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      void removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void setSize(float width, float height)
      Sets the size of the view.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getOffset, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WrappedPlainView

        public WrappedPlainView(Element elem)
        Creates a new WrappedPlainView. Lines will be wrapped on character boundaries.
        参数：
        elem - the element underlying the view

      • WrappedPlainView

        public WrappedPlainView(Element elem,
                boolean wordWrap)
        Creates a new WrappedPlainView. Lines can be wrapped on either character or word boundaries depending upon the setting of the wordWrap parameter.
        参数：
        elem - the element underlying the view
        wordWrap - should lines be wrapped on word boundaries?

    • 方法详细信息

      • getTabSize

        protected int getTabSize()
        Returns the tab size set for the document, defaulting to 8.
        返回：
        the tab size

      • drawLine

        protected void drawLine(int p0,
            int p1,
            Graphics g,
            int x,
            int y)
        Renders a line of text, suppressing whitespace at the end and expanding any tabs. This is implemented to make calls to the methods drawUnselectedText and drawSelectedText so that the way selected and unselected text are rendered can be customized.
        参数：
        p0 - the starting document location to use >= 0
        p1 - the ending document location to use >= p1
        g - the graphics context
        x - the starting X position >= 0
        y - the starting Y position >= 0
        另请参见：
        drawUnselectedText(java.awt.Graphics, int, int, int, int), drawSelectedText(java.awt.Graphics, int, int, int, int)

      • drawUnselectedText

        protected int drawUnselectedText(Graphics g,
                     int x,
                     int y,
                     int p0,
                     int p1)
                          throws BadLocationException
        Renders the given range in the model as normal unselected text.
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the beginning position in the model >= 0
        p1 - the ending position in the model >= p0
        返回：
        the X location of the end of the range >= 0
        抛出：
        BadLocationException - if the range is invalid

      • drawSelectedText

        protected int drawSelectedText(Graphics g,
                   int x,
                   int y,
                   int p0,
                   int p1)
                        throws BadLocationException
        Renders the given range in the model as selected text. This is implemented to render the text in the color specified in the hosting component. It assumes the highlighter will render the selected background.
        参数：
        g - the graphics context
        x - the starting X coordinate >= 0
        y - the starting Y coordinate >= 0
        p0 - the beginning position in the model >= 0
        p1 - the ending position in the model >= p0
        返回：
        the location of the end of the range.
        抛出：
        BadLocationException - if the range is invalid

      • getLineBuffer

        protected final Segment getLineBuffer()
        Gives access to a buffer that can be used to fetch text from the associated document.
        返回：
        the buffer

      • calculateBreakPosition

        protected int calculateBreakPosition(int p0,
                         int p1)
        This is called by the nested wrapped line views to determine the break location. This can be reimplemented to alter the breaking behavior. It will either break at word or character boundaries depending upon the break argument given at construction.

      • loadChildren

        protected void loadChildren(ViewFactory f)
        Loads all of the children to initialize the view. This is called by the setParent method. Subclasses can reimplement this to initialize their child views in a different manner. The default implementation creates a child view for each child element.
        重载：
        loadChildren in class CompositeView
        参数：
        f - the view factory
        另请参见：
        CompositeView.setParent(javax.swing.text.View)

      • nextTabStop

        public float nextTabStop(float x,
                int tabOffset)
        Returns the next tab stop position after a given reference position. This implementation does not support things like centering so it ignores the tabOffset argument.
        指定者：
        nextTabStop in interface TabExpander
        参数：
        x - the current position >= 0
        tabOffset - the position within the text stream that the tab occurred at >= 0.
        返回：
        the tab stop, measured in points >= 0

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders using the given rendering surface and area on that surface. This is implemented to stash the selection positions, selection colors, and font metrics for the nested lines to use.
        重载：
        paint in class BoxView
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view along the given axis, if it has any layout duties.
        重载：
        setSize in class BoxView
        参数：
        width - the width >= 0
        height - the height >= 0

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis. This is implemented to provide the superclass behavior after first making sure that the current font metrics are cached (for the nested lines which use the metrics to determine the height of the potentially wrapped lines).
        重载：
        getPreferredSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis. This is implemented to provide the superclass behavior after first making sure that the current font metrics are cached (for the nested lines which use the metrics to determine the height of the potentially wrapped lines).
        重载：
        getMinimumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getMinimumSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis. This is implemented to provide the superclass behavior after first making sure that the current font metrics are cached (for the nested lines which use the metrics to determine the height of the potentially wrapped lines).
        重载：
        getMaximumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        另请参见：
        View.getMaximumSpan(int)

      • insertUpdate

        public void insertUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. This is implemented to simply update the children.
        重载：
        insertUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. This is implemented to simply update the children.
        重载：
        removeUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"aatsc hn


ZoneView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text

类 ZoneView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.ZoneView
  • 所有已实现的接口：
    SwingConstants

    public class ZoneView
extends BoxView
    ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations. This enables a substantial reduction in memory consumption for situations where the model being represented is very large, by building view objects only for the region being actively viewed/edited. The size of the children can be estimated in some way, or calculated asynchronously with only the result being saved.

    ZoneView extends BoxView to provide a box that implements zones for its children. The zones are special View implementations (the children of an instance of this class) that represent only a portion of the model that an instance of ZoneView is responsible for. The zones don't create child views until an attempt is made to display them. A box shaped view is well suited to this because:

    • Boxes are a heavily used view, and having a box that provides this behavior gives substantial opportunity to plug the behavior into a view hierarchy from the view factory.
    • Boxes are tiled in one direction, so it is easy to divide them into zones in a reliable way.
    • Boxes typically have a simple relationship to the model (i.e. they create child views that directly represent the child elements).
    • Boxes are easier to estimate the size of than some other shapes.

    The default behavior is controled by two properties, maxZoneSize and maxZonesLoaded. Setting maxZoneSize to Integer.MAX_VALUE would have the effect of causing only one zone to be created. This would effectively turn the view into an implementation of the decorator pattern. Setting maxZonesLoaded to a value of Integer.MAX_VALUE would cause zones to never be unloaded. For simplicity, zones are created on boundaries represented by the child elements of the element the view is responsible for. The zones can be any View implementation, but the default implementation is based upon AsyncBoxView which supports fairly large zones efficiently.

    从以下版本开始：
    1.3
    另请参见：
    View

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ZoneView(Element elem, int axis)
      Constructs a ZoneView.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected View createZone(int p0, int p1)
      Create a view to represent a zone for the given range within the model (which should be within the range of this objects responsibility).
      int getMaximumZoneSize()
      Get the current maximum zone size.
      int getMaxZonesLoaded()
      Get the current setting of the number of zones allowed to be loaded at the same time.
      protected int getViewIndexAtPosition(int pos)
      Returns the child view index representing the given position in the model.
      void insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      protected boolean isZoneLoaded(View zone)
      Determine if a zone is in the loaded state.
      protected void loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      void removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void setMaximumZoneSize(int size)
      Set the desired maximum zone size.
      void setMaxZonesLoaded(int mzl)
      Sets the current setting of the number of zones allowed to be loaded at the same time.
      protected void unloadZone(View zone)
      Unload a zone (Convert the zone to its memory saving state).
      protected boolean updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element.
      protected void zoneWasLoaded(View zone)
      Called by a zone when it gets loaded.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets, setParent

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ZoneView

        public ZoneView(Element elem,
        int axis)
        Constructs a ZoneView.
        参数：
        elem - the element this view is responsible for
        axis - either View.X_AXIS or View.Y_AXIS

    • 方法详细信息

      • getMaximumZoneSize

        public int getMaximumZoneSize()
        Get the current maximum zone size.

      • setMaximumZoneSize

        public void setMaximumZoneSize(int size)
        Set the desired maximum zone size. A zone may get larger than this size if a single child view is larger than this size since zones are formed on child view boundaries.
        参数：
        size - the number of characters the zone may represent before attempting to break the zone into a smaller size.

      • getMaxZonesLoaded

        public int getMaxZonesLoaded()
        Get the current setting of the number of zones allowed to be loaded at the same time.

      • setMaxZonesLoaded

        public void setMaxZonesLoaded(int mzl)
        Sets the current setting of the number of zones allowed to be loaded at the same time. This will throw an IllegalArgumentException if mzl is less than 1.
        参数：
        mzl - the desired maximum number of zones to be actively loaded, must be greater than 0
        抛出：
        IllegalArgumentException - if mzl is < 1

      • zoneWasLoaded

        protected void zoneWasLoaded(View zone)
        Called by a zone when it gets loaded. This happens when an attempt is made to display or perform a model/view translation on a zone that was in an unloaded state. This is imlemented to check if the maximum number of zones was reached and to unload the oldest zone if so.
        参数：
        zone - the child view that was just loaded.

      • unloadZone

        protected void unloadZone(View zone)
        Unload a zone (Convert the zone to its memory saving state). The zones are expected to represent a subset of the child elements of the element this view is responsible for. Therefore, the default implementation is to simple remove all the children.
        参数：
        zone - the child view desired to be set to an unloaded state.

      • isZoneLoaded

        protected boolean isZoneLoaded(View zone)
        Determine if a zone is in the loaded state. The zones are expected to represent a subset of the child elements of the element this view is responsible for. Therefore, the default implementation is to return true if the view has children.

      • createZone

        protected View createZone(int p0,
              int p1)
        Create a view to represent a zone for the given range within the model (which should be within the range of this objects responsibility). This is called by the zone management logic to create new zones. Subclasses can provide a different implementation for a zone by changing this method.
        参数：
        p0 - the start of the desired zone. This should be >= getStartOffset() and < getEndOffset(). This value should also be < p1.
        p1 - the end of the desired zone. This should be > getStartOffset() and <= getEndOffset(). This value should also be > p0.

      • loadChildren

        protected void loadChildren(ViewFactory f)
        Loads all of the children to initialize the view. This is called by the setParent method. This is reimplemented to not load any children directly (as they are created by the zones). This method creates the initial set of zones. Zones don't actually get populated however until an attempt is made to display them or to do model/view coordinate translation.
        重载：
        loadChildren in class CompositeView
        参数：
        f - the view factory
        另请参见：
        CompositeView.setParent(javax.swing.text.View)

      • getViewIndexAtPosition

        protected int getViewIndexAtPosition(int pos)
        Returns the child view index representing the given position in the model.
        重载：
        getViewIndexAtPosition in class CompositeView
        参数：
        pos - the position >= 0
        返回：
        index of the view representing the given position, or -1 if no view represents that position

      • updateChildren

        protected boolean updateChildren(DocumentEvent.ElementChange ec,
                     DocumentEvent e,
                     ViewFactory f)
        The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element. This is reimplemented to do nothing and return false.
        重载：
        updateChildren in class View
        参数：
        ec - the change information for the element this view is responsible for. This should not be null if this method gets called
        e - the change information from the associated document
        f - the factory to use to build child views
        返回：
        whether or not the child views represent the child elements of the element this view is responsible for. Some views create children that represent a portion of the element they are responsible for, and should return false. This information is used to determine if views in the range of the added elements should be forwarded to or not
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • insertUpdate

        public void insertUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. This is largely delegated to the superclass, but is reimplemented to update the relevant zone (i.e. determine if a zone needs to be split into a set of 2 or more zones).
        重载：
        insertUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent changes,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. This is largely delegated to the superclass, but is reimplemented to update the relevant zones (i.e. determine if zones need to be removed or joined with another zone).
        重载：
        removeUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iya nfa famttammi //


Uses of Class javax.swing.text.AbstractDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument

  • Packages that use AbstractDocument
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument in javax.swing.text

      Subclasses of AbstractDocument in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultStyledDocument
      A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
      class  PlainDocument
      A plain document that maintains no character attributes.

    • Uses of AbstractDocument in javax.swing.text.html

      Subclasses of AbstractDocument in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument
      A document that models HTML.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=.m>S/aarson#"Rpeye


Uses of Class javax.swing.text.AbstractDocument.AbstractElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument.AbstractElement

  • Packages that use AbstractDocument.AbstractElement
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.AbstractElement in javax.swing.text

      Subclasses of AbstractDocument.AbstractElement in javax.swing.text
      修饰符与类型 类与描述
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      Methods in javax.swing.text that return AbstractDocument.AbstractElement
      修饰符与类型 方法与描述
      protected AbstractDocument.AbstractElement PlainDocument.createDefaultRoot()
      Creates the root element to be used to represent the default document structure.
      protected AbstractDocument.AbstractElement DefaultStyledDocument.createDefaultRoot()
      Creates the root element to be used to represent the default document structure.

    • Uses of AbstractDocument.AbstractElement in javax.swing.text.html

      Subclasses of AbstractDocument.AbstractElement in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
      Methods in javax.swing.text.html that return AbstractDocument.AbstractElement
      修饰符与类型 方法与描述
      protected AbstractDocument.AbstractElement HTMLDocument.createDefaultRoot()
      Creates the root element to be used to represent the default document structure.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bm.nwp>mt萳"


Uses of Class javax.swing.text.AbstractDocument.BranchElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument.BranchElement

  • Packages that use AbstractDocument.BranchElement
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.BranchElement in javax.swing.text

      Subclasses of AbstractDocument.BranchElement in javax.swing.text
      修饰符与类型 类与描述
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...

    • Uses of AbstractDocument.BranchElement in javax.swing.text.html

      Subclasses of AbstractDocument.BranchElement in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>< <


Uses of Class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument.DefaultDocumentEvent

  • Packages that use AbstractDocument.DefaultDocumentEvent
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.DefaultDocumentEvent in javax.swing.text

      Methods in javax.swing.text with parameters of type AbstractDocument.DefaultDocumentEvent
      修饰符与类型 方法与描述
      void DefaultStyledDocument.ElementBuffer.change(int offset, int length, AbstractDocument.DefaultDocumentEvent de)
      Changes content.
      void DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de)
      Inserts new content.
      protected void PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void AbstractDocument.postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.
      void DefaultStyledDocument.ElementBuffer.remove(int offset, int length, AbstractDocument.DefaultDocumentEvent de)
      Removes content.
      protected void PlainDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.
      protected void DefaultStyledDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates document structure as a result of text removal.
      protected void AbstractDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
      Updates any document structure as a result of text removal.

    • Uses of AbstractDocument.DefaultDocumentEvent in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type AbstractDocument.DefaultDocumentEvent
      修饰符与类型 方法与描述
      protected void HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aciddtaa -�-s!;.r"


Uses of Class javax.swing.text.AbstractDocument.ElementEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument.ElementEdit

No usage of javax.swing.text.AbstractDocument.ElementEdit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

suw//..=f"""h sseun)p


Uses of Class javax.swing.text.AbstractDocument.LeafElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractDocument.LeafElement

  • Packages that use AbstractDocument.LeafElement
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.LeafElement in javax.swing.text.html

      Subclasses of AbstractDocument.LeafElement in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"pEnp&ps;;;&SPPil�/ut=vP


Uses of Class javax.swing.text.AbstractWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AbstractWriter

  • Packages that use AbstractWriter
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractWriter in javax.swing.text.html

      Subclasses of AbstractWriter in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLWriter
      This is a writer for HTMLDocuments.
      class  MinimalHTMLWriter
      MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

axvlu=g a =si


Uses of Class javax.swing.text.AsyncBoxView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AsyncBoxView

No usage of javax.swing.text.AsyncBoxView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/lpsjav/.....eooiatio


Uses of Class javax.swing.text.AsyncBoxView.ChildLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AsyncBoxView.ChildLocator

  • Packages that use AsyncBoxView.ChildLocator
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AsyncBoxView.ChildLocator in javax.swing.text

      Fields in javax.swing.text declared as AsyncBoxView.ChildLocator
      修饰符与类型 字段与描述
      protected AsyncBoxView.ChildLocator AsyncBoxView.locator
      Object that manages the offsets of the children.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&<#腥鵤�/ 0 an0 <>� 3a/


Uses of Class javax.swing.text.AsyncBoxView.ChildState

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.AsyncBoxView.ChildState

  • Packages that use AsyncBoxView.ChildState
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AsyncBoxView.ChildState in javax.swing.text

      Fields in javax.swing.text declared as AsyncBoxView.ChildState
      修饰符与类型 字段与描述
      protected AsyncBoxView.ChildState AsyncBoxView.ChildLocator.lastValidOffset
      The location of the last offset calculation that is valid.
      Methods in javax.swing.text that return AsyncBoxView.ChildState
      修饰符与类型 方法与描述
      protected AsyncBoxView.ChildState AsyncBoxView.createChildState(View v)
      New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more
      protected AsyncBoxView.ChildState AsyncBoxView.getChildState(int index)
      Fetch the object representing the layout state of of the child at the given index.
      Methods in javax.swing.text with parameters of type AsyncBoxView.ChildState
      修饰符与类型 方法与描述
      void AsyncBoxView.ChildLocator.childChanged(AsyncBoxView.ChildState cs)
      Notification that a child changed.
      protected void AsyncBoxView.majorRequirementChange(AsyncBoxView.ChildState cs, float delta)
      Requirements changed along the major axis.
      protected void AsyncBoxView.minorRequirementChange(AsyncBoxView.ChildState cs)
      Requirements changed along the minor axis.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

O csd>otrFreacx.cojt


Uses of Class javax.swing.text.BadLocationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.BadLocationException

  • Packages that use BadLocationException
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

    • Uses of BadLocationException in javax.swing

      Methods in javax.swing that throw BadLocationException
      修饰符与类型 方法与描述
      int JTextArea.getLineEndOffset(int line)
      Determines the offset of the end of the given line.
      int JTextArea.getLineOfOffset(int offset)
      Translates an offset into the components text to a line number.
      int JTextArea.getLineStartOffset(int line)
      Determines the offset of the start of the given line.
      String JPasswordField.getText(int offs, int len)
      Deprecated.
      As of Java 2 platform v1.2, replaced by getPassword.

    • Uses of BadLocationException in javax.swing.plaf

      Methods in javax.swing.plaf that throw BadLocationException
      修饰符与类型 方法与描述
      abstract int TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      abstract Rectangle TextUI.modelToView(JTextComponent t, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      abstract Rectangle TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.

    • Uses of BadLocationException in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that throw BadLocationException
      修饰符与类型 方法与描述
      int BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      Rectangle BasicTextUI.modelToView(JTextComponent tc, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      Rectangle BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.

    • Uses of BadLocationException in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that throw BadLocationException
      修饰符与类型 方法与描述
      int MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e)
      Invokes the getNextVisualPositionFrom method on each UI handled by this object.
      Rectangle MultiTextUI.modelToView(JTextComponent a, int b)
      Invokes the modelToView method on each UI handled by this object.
      Rectangle MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c)
      Invokes the modelToView method on each UI handled by this object.

    • Uses of BadLocationException in javax.swing.text

      Methods in javax.swing.text that throw BadLocationException
      修饰符与类型 方法与描述
      Object DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
      Object Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
      void DefaultHighlighter.changeHighlight(Object tag, int p0, int p1)
      Changes a highlight.
      void Highlighter.changeHighlight(Object tag, int p0, int p1)
      Changes the given highlight to span a different portion of the document.
      Position StringContent.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position GapContent.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position AbstractDocument.createPosition(int offs)
      Returns a position that will track change as the document is altered.
      Position AbstractDocument.Content.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position Document.createPosition(int offs)
      This method allows an application to mark a place in a sequence of character content.
      protected int PasswordView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int PlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int WrappedPlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as selected text.
      protected int PasswordView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      protected int PlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      protected int WrappedPlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
      Renders the given range in the model as normal unselected text.
      void StringContent.getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      void GapContent.getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      void AbstractDocument.Content.getChars(int where, int len, Segment txt)
      Gets a sequence of characters and copies them into a Segment.
      protected int ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      Returns the closest model position to x.
      protected int CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected int CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the north or south direction.
      protected int ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location at which one might place a caret.
      int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
      Returns the next visual position to place the caret at from an existing position.
      static int Utilities.getNextWord(JTextComponent c, int offs)
      Determines the start of the next word for the given location.
      static int Utilities.getPositionAbove(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row above.
      static int Utilities.getPositionBelow(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row below.
      static int Utilities.getPreviousWord(JTextComponent c, int offs)
      Determine the start of the prev word for the given location.
      static int Utilities.getRowEnd(JTextComponent c, int offs)
      Determines the ending row model position of the row that contains the specified model position.
      static int Utilities.getRowStart(JTextComponent c, int offs)
      Determines the starting row model position of the row that contains the specified model position.
      String StringContent.getString(int where, int len)
      Retrieves a portion of the content.
      String GapContent.getString(int where, int len)
      Retrieves a portion of the content.
      String AbstractDocument.Content.getString(int where, int len)
      Fetches a string of characters contained in the sequence.
      protected String AbstractWriter.getText(Element elem)
      Returns the text associated with the element.
      String AbstractDocument.getText(int offset, int length)
      Gets a sequence of text from the document.
      String Document.getText(int offset, int length)
      Fetches the text contained within the given portion of the document.
      String JTextComponent.getText(int offs, int len)
      Fetches a portion of the text represented by the component.
      void AbstractDocument.getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
      void Document.getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
      static int Utilities.getWordEnd(JTextComponent c, int offs)
      Determines the end of a word for the given location.
      static int Utilities.getWordStart(JTextComponent c, int offs)
      Determines the start of a word for the given model location.
      protected void DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
      void DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
      Invoked prior to insertion of text into the specified Document.
      UndoableEdit StringContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit GapContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit AbstractDocument.Content.insertString(int where, String str)
      Inserts a string of characters into the sequence.
      void PlainDocument.insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      abstract void DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
      Inserts the specified text, bypassing the DocumentFilter.
      void AbstractDocument.insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      void Document.insertString(int offset, String str, AttributeSet a)
      Inserts a string of content.
      abstract Shape GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Rectangle JTextComponent.modelToView(int pos)
      Converts the given location in the model to a place in the view coordinate system.
      Shape CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping, for a given region, from the document model coordinate space to the view coordinate space.
      Shape View.modelToView(int pos, Shape a)
      Deprecated.
      Shape PasswordView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape PlainView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape FieldView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape IconView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape ComponentView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the coordinate space of the model to that of the view.
      Shape GlyphView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape CompositeView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape BoxView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      abstract Shape View.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping, for a given character, from the document model coordinate space to the view coordinate space.
      void DefaultEditorKit.read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      abstract void EditorKit.read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void DefaultEditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream, which will be treated as plain text.
      abstract void EditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length)
      Invoked prior to removal of the specified region in the specified Document.
      UndoableEdit StringContent.remove(int where, int nitems)
      Removes part of the content.
      UndoableEdit GapContent.remove(int where, int nitems)
      Removes part of the content.
      abstract void DocumentFilter.FilterBypass.remove(int offset, int length)
      Removes the specified region of text, bypassing the DocumentFilter.
      void AbstractDocument.remove(int offs, int len)
      Removes some content from the document.
      UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
      Removes some portion of the sequence.
      void Document.remove(int offs, int len)
      Removes a portion of the content of the document.
      void DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
      Invoked prior to replacing a region of text in the specified Document.
      abstract void DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.
      void AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.
      protected void AbstractWriter.text(Element elem)
      Writes out text.
      protected abstract void AbstractWriter.write()
      This abstract method needs to be implemented by subclasses.
      void DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      abstract void EditorKit.write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      void DefaultEditorKit.write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream as plain text.
      abstract void EditorKit.write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.

    • Uses of BadLocationException in javax.swing.text.html

      Methods in javax.swing.text.html that throw BadLocationException
      修饰符与类型 | 方法与描述
      protected void HTMLWriter.comment(Element elem)
      Writes out comments.
      protected void HTMLWriter.emptyTag(Element elem)
      Writes out all empty elements (all tags that have no corresponding end tag).
      void | HTMLEditorKit.ParserCallback.flush()
      void HTMLDocument.HTMLReader.flush()
      The last method called on the reader.
      protected void HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
      void HTMLDocument.insertAfterEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string after the the end of the given element.
      void HTMLDocument.insertAfterStart(Element elem, String htmlText)
      Inserts the HTML specified as a string at the start of the element.
      void HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string at the end of the element.
      void HTMLDocument.insertBeforeStart(Element elem, String htmlText)
      Inserts the HTML specified as a string before the start of the given element.
      void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      Shape ImageView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void HTMLEditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream.
      void HTMLDocument.setInnerHTML(Element elem, String htmlText)
      Replaces the children of the given element with the contents specified as an HTML string.
      void HTMLDocument.setOuterHTML(Element elem, String htmlText)
      Replaces the given element in the parent with the contents specified as an HTML string.
      protected void HTMLWriter.startTag(Element elem)
      Writes out a start tag for the element.
      protected void MinimalHTMLWriter.text(Element elem)
      Writes out text.
      protected void HTMLWriter.text(Element elem)
      Writes out text.
      protected void HTMLWriter.textAreaContent(AttributeSet attr)
      Writes out text that is contained in a TEXTAREA form element.
      void MinimalHTMLWriter.write()
      Generates HTML output from a StyledDocument.
      void HTMLWriter.write()
      Iterates over the Element tree and controls the writing out of all the tags and its attributes.
      void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.
      protected void MinimalHTMLWriter.writeBody()
      Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements.
      protected void MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting)
      Writes out the attribute set in an HTML-compliant manner.

    • Uses of BadLocationException in javax.swing.text.rtf

      Methods in javax.swing.text.rtf that throw BadLocationException
      修饰符与类型 方法与描述
      void RTFEditorKit.read(InputStream in, Document doc, int pos)
      Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void RTFEditorKit.read(Reader in, Document doc, int pos)
      Insert content from the given stream, which will be treated as plain text.
      void RTFEditorKit.write(OutputStream out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.
      void RTFEditorKit.write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream as plain text.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/a>;av a


Uses of Class javax.swing.text.BoxView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.BoxView

  • Packages that use BoxView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of BoxView in javax.swing.text

      Subclasses of BoxView in javax.swing.text
      修饰符与类型 类与描述
      class  FlowView
      A View that tries to flow it's children into some partially constrained space.
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      class  TableView
      Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
      class  TableView.TableCell
      Deprecated.
      A table cell can now be any View implementation.
      class  TableView.TableRow
      View of a row in a row-centric table.
      class  WrappedPlainView
      View of plain text (text with only one font and color) that does line-wrapping.
      class  ZoneView
      ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.

    • Uses of BoxView in javax.swing.text.html

      Subclasses of BoxView in javax.swing.text.html
      修饰符与类型 类与描述
      class  BlockView
      A view implementation to display a block (as a box) with CSS specifications.
      class  ListView
      A view implementation to display an html list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a0fx./j./.../hnnp" = "Ect


Uses of Class javax.swing.text.ChangedCharSetException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.ChangedCharSetException

  • Packages that use ChangedCharSetException
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of ChangedCharSetException in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that throw ChangedCharSetException
      修饰符与类型 方法与描述
      protected void Parser.handleEmptyTag(TagElement tag)
      Called when an empty tag is encountered.
      protected void DocumentParser.handleEmptyTag(TagElement tag)
      Handle Empty Tag.
      protected void Parser.startTag(TagElement tag)
      Handle a start tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eNtgx/sj/aaa/.cc<>llar"ln


Uses of Class javax.swing.text.ComponentView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.ComponentView

  • Packages that use ComponentView
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of ComponentView in javax.swing.text.html

      Subclasses of ComponentView in javax.swing.text.html
      修饰符与类型 类与描述
      class  FormView
      Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
      class  ObjectView
      Component decorator that implements the view interface for <object> elements.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atrslsasssnbslee "iptep>k


Uses of Class javax.swing.text.CompositeView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.CompositeView

  • Packages that use CompositeView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of CompositeView in javax.swing.text

      Subclasses of CompositeView in javax.swing.text
      修饰符与类型 类与描述
      class  BoxView
      A view that arranges its children into a box shape by tiling its children along an axis.
      class  FlowView
      A View that tries to flow it's children into some partially constrained space.
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      class  TableView
      Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
      class  TableView.TableCell
      Deprecated.
      A table cell can now be any View implementation.
      class  TableView.TableRow
      View of a row in a row-centric table.
      class  WrappedPlainView
      View of plain text (text with only one font and color) that does line-wrapping.
      class  ZoneView
      ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.

    • Uses of CompositeView in javax.swing.text.html

      Subclasses of CompositeView in javax.swing.text.html
      修饰符与类型 类与描述
      class  BlockView
      A view implementation to display a block (as a box) with CSS specifications.
      class  ListView
      A view implementation to display an html list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gfsllsllses.==abyao/mre


Uses of Class javax.swing.text.DateFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DateFormatter

No usage of javax.swing.text.DateFormatter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i/va<<..=


Uses of Class javax.swing.text.DefaultCaret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultCaret

  • Packages that use DefaultCaret
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of DefaultCaret in javax.swing.plaf.basic

      Subclasses of DefaultCaret in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicCaret
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nml /s/m.


Uses of Class javax.swing.text.DefaultEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit

  • Packages that use DefaultEditorKit
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

    • Uses of DefaultEditorKit in javax.swing.text

      Subclasses of DefaultEditorKit in javax.swing.text
      修饰符与类型 类与描述
      class  StyledEditorKit
      This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.

    • Uses of DefaultEditorKit in javax.swing.text.html

      Subclasses of DefaultEditorKit in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLEditorKit
      The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.

    • Uses of DefaultEditorKit in javax.swing.text.rtf

      Subclasses of DefaultEditorKit in javax.swing.text.rtf
      修饰符与类型 类与描述
      class  RTFEditorKit
      This is the default implementation of RTF editing functionality.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

}i"vss!ua/el;ct�&ocob


Uses of Class javax.swing.text.DefaultEditorKit.BeepAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.BeepAction

No usage of javax.swing.text.DefaultEditorKit.BeepAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"/era/岩构筶l//


Uses of Class javax.swing.text.DefaultEditorKit.CopyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.CopyAction

No usage of javax.swing.text.DefaultEditorKit.CopyAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>羠x 夜q� /+lr


Uses of Class javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction

No usage of javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eSe"&D 爸�-a-t.//nl/


Uses of Class javax.swing.text.DefaultEditorKit.InsertBreakAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.InsertBreakAction

No usage of javax.swing.text.DefaultEditorKit.InsertBreakAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fK < /i


Uses of Class javax.swing.text.DefaultEditorKit.InsertContentAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.InsertContentAction

No usage of javax.swing.text.DefaultEditorKit.InsertContentAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/lmls9t aaC


Uses of Class javax.swing.text.DefaultEditorKit.InsertTabAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.InsertTabAction

No usage of javax.swing.text.DefaultEditorKit.InsertTabAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>g/s


Uses of Class javax.swing.text.DefaultEditorKit.PasteAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultEditorKit.PasteAction

No usage of javax.swing.text.DefaultEditorKit.PasteAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s


Uses of Class javax.swing.text.DefaultFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultFormatter

  • Packages that use DefaultFormatter
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DefaultFormatter in javax.swing.text

      Subclasses of DefaultFormatter in javax.swing.text
      修饰符与类型 类与描述
      class  DateFormatter
      DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
      class  InternationalFormatter
      InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
      class  MaskFormatter
      MaskFormatter is used to format and edit strings.
      class  NumberFormatter
      NumberFormatter subclasses InternationalFormatter adding special behavior for numbers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!=c mim..l/e>蝜lse"eea/


Uses of Class javax.swing.text.DefaultFormatterFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultFormatterFactory

No usage of javax.swing.text.DefaultFormatterFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

".a<n axedr


Uses of Class javax.swing.text.DefaultHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultHighlighter

  • Packages that use DefaultHighlighter
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.

    • Uses of DefaultHighlighter in javax.swing.plaf.basic

      Subclasses of DefaultHighlighter in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicHighlighter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>laofeFm"n uh .h/l==/e


Uses of Class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultHighlighter.DefaultHighlightPainter

No usage of javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dti ora>a Fs./crj/


Uses of Class javax.swing.text.DefaultStyledDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultStyledDocument

  • Packages that use DefaultStyledDocument
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of DefaultStyledDocument in javax.swing.text.html

      Subclasses of DefaultStyledDocument in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument
      A document that models HTML.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l. ng>s/tttaUcceetsae.Be


Uses of Class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit

No usage of javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raeii


Uses of Class javax.swing.text.DefaultStyledDocument.ElementBuffer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultStyledDocument.ElementBuffer

  • Packages that use DefaultStyledDocument.ElementBuffer
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DefaultStyledDocument.ElementBuffer in javax.swing.text

      Fields in javax.swing.text declared as DefaultStyledDocument.ElementBuffer
      修饰符与类型 | 字段与描述
      protected DefaultStyledDocument.ElementBuffer | DefaultStyledDocument.buffer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/p m>dadelo f�/"re /r�


Uses of Class javax.swing.text.DefaultStyledDocument.ElementSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultStyledDocument.ElementSpec

  • Packages that use DefaultStyledDocument.ElementSpec
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of DefaultStyledDocument.ElementSpec in javax.swing.text

      Methods in javax.swing.text with parameters of type DefaultStyledDocument.ElementSpec
      修饰符与类型 方法与描述
      protected void DefaultStyledDocument.create(DefaultStyledDocument.ElementSpec[] data)
      Initialize the document to reflect the given element structure (i.e.
      protected void DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
      void DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de)
      Inserts new content.
      protected void DefaultStyledDocument.ElementBuffer.insertUpdate(DefaultStyledDocument.ElementSpec[] data)
      Inserts an update into the document.

    • Uses of DefaultStyledDocument.ElementSpec in javax.swing.text.html

      Fields in javax.swing.text.html with type parameters of type DefaultStyledDocument.ElementSpec
      修饰符与类型 | 字段与描述
      protected Vector<DefaultStyledDocument.ElementSpec> | HTMLDocument.HTMLReader.parseBuffer
      Methods in javax.swing.text.html with parameters of type DefaultStyledDocument.ElementSpec
      修饰符与类型 方法与描述
      protected void HTMLDocument.create(DefaultStyledDocument.ElementSpec[] data)
      Replaces the contents of the document with the given element specifications.
      protected void HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"l.s>l rsisa0<>/衋/


Uses of Class javax.swing.text.DefaultStyledDocument.SectionElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultStyledDocument.SectionElement

No usage of javax.swing.text.DefaultStyledDocument.SectionElement
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ldi<>树thmmmec ia<


Uses of Class javax.swing.text.DefaultTextUI

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DefaultTextUI

No usage of javax.swing.text.DefaultTextUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e9rsiofoisotsrf/澹偶


Uses of Class javax.swing.text.DocumentFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DocumentFilter

  • Packages that use DocumentFilter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DocumentFilter in javax.swing

      Methods in javax.swing that return DocumentFilter
      修饰符与类型 方法与描述
      protected DocumentFilter JFormattedTextField.AbstractFormatter.getDocumentFilter()
      Subclass and override if you wish to provide a DocumentFilter to restrict what can be input.

    • Uses of DocumentFilter in javax.swing.text

      Methods in javax.swing.text that return DocumentFilter
      修饰符与类型 方法与描述
      protected DocumentFilter DefaultFormatter.getDocumentFilter()
      Returns the DocumentFilter used to restrict the characters that can be input into the JFormattedTextField.
      DocumentFilter AbstractDocument.getDocumentFilter()
      Returns the DocumentFilter that is responsible for filtering of insertion/removal.
      Methods in javax.swing.text with parameters of type DocumentFilter
      修饰符与类型 方法与描述
      void AbstractDocument.setDocumentFilter(DocumentFilter filter)
      Sets the DocumentFilter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r>tvtj,.< ." r


Uses of Class javax.swing.text.DocumentFilter.FilterBypass

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.DocumentFilter.FilterBypass

  • Packages that use DocumentFilter.FilterBypass
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of DocumentFilter.FilterBypass in javax.swing.text

      Methods in javax.swing.text with parameters of type DocumentFilter.FilterBypass
      修饰符与类型 方法与描述
      void DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
      Invoked prior to insertion of text into the specified Document.
      void DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length)
      Invoked prior to removal of the specified region in the specified Document.
      void DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
      Invoked prior to replacing a region of text in the specified Document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cjl<


Uses of Class javax.swing.text.EditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.EditorKit

  • Packages that use EditorKit
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

    • Uses of EditorKit in javax.swing

      Methods in javax.swing that return EditorKit
      修饰符与类型 方法与描述
      protected EditorKit JTextPane.createDefaultEditorKit()
      Creates the EditorKit to use by default.
      protected EditorKit JEditorPane.createDefaultEditorKit()
      Creates the default editor kit (PlainEditorKit) for when the component is first created.
      static EditorKit JEditorPane.createEditorKitForContentType(String type)
      Creates a handler for the given type from the default registry of editor kits.
      EditorKit JEditorPane.getEditorKit()
      Fetches the currently installed kit for handling content.
      EditorKit JEditorPane.getEditorKitForContentType(String type)
      Fetches the editor kit to use for the given type of content.
      Methods in javax.swing with parameters of type EditorKit
      修饰符与类型 方法与描述
      void JTextPane.setEditorKit(EditorKit kit)
      Sets the currently installed kit for handling content.
      void JEditorPane.setEditorKit(EditorKit kit)
      Sets the currently installed kit for handling content.
      void JEditorPane.setEditorKitForContentType(String type, EditorKit k)
      Directly sets the editor kit to use for the given type.

    • Uses of EditorKit in javax.swing.plaf

      Methods in javax.swing.plaf that return EditorKit
      修饰符与类型 方法与描述
      abstract EditorKit TextUI.getEditorKit(JTextComponent t)
      Fetches the binding of services that set a policy for the type of document being edited.

    • Uses of EditorKit in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return EditorKit
      修饰符与类型 方法与描述
      EditorKit BasicEditorPaneUI.getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.
      EditorKit BasicTextUI.getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.

    • Uses of EditorKit in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return EditorKit
      修饰符与类型 方法与描述
      EditorKit MultiTextUI.getEditorKit(JTextComponent a)
      Invokes the getEditorKit method on each UI handled by this object.

    • Uses of EditorKit in javax.swing.text

      Subclasses of EditorKit in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultEditorKit
      This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
      class  StyledEditorKit
      This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.

    • Uses of EditorKit in javax.swing.text.html

      Subclasses of EditorKit in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLEditorKit
      The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.

    • Uses of EditorKit in javax.swing.text.rtf

      Subclasses of EditorKit in javax.swing.text.rtf
      修饰符与类型 类与描述
      class  RTFEditorKit
      This is the default implementation of RTF editing functionality.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pre>eoapalbeix


Uses of Class javax.swing.text.ElementIterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.ElementIterator

  • Packages that use ElementIterator
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of ElementIterator in javax.swing.text

      Methods in javax.swing.text that return ElementIterator
      修饰符与类型 方法与描述
      protected ElementIterator AbstractWriter.getElementIterator()
      Fetches the ElementIterator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i /men teeeriddrl>)e dow


Uses of Class javax.swing.text.FieldView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.FieldView

  • Packages that use FieldView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of FieldView in javax.swing.text

      Subclasses of FieldView in javax.swing.text
      修饰符与类型 类与描述
      class  PasswordView
      Implements a View suitable for use in JPasswordField UI implementations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bArp asaxpe< rs2 .r.//e>a


Uses of Class javax.swing.text.FlowView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.FlowView

  • Packages that use FlowView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of FlowView in javax.swing.text

      Subclasses of FlowView in javax.swing.text
      修饰符与类型 类与描述
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      Methods in javax.swing.text with parameters of type FlowView
      修饰符与类型 方法与描述
      protected void FlowView.FlowStrategy.adjustRow(FlowView fv, int rowIndex, int desiredSpan, int x)
      Adjusts the given row if possible to fit within the layout span.
      void FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected View FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex)
      Creates a view that can be used to represent the current piece of the flow.
      protected View FlowView.FlowStrategy.getLogicalView(FlowView fv)
      This method gives flow strategies access to the logical view of the FlowView.
      void FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was inserted into the document in a location that the given flow view is responsible for.
      void FlowView.FlowStrategy.layout(FlowView fv)
      Update the flow on the given FlowView.
      protected int FlowView.FlowStrategy.layoutRow(FlowView fv, int rowIndex, int pos)
      Creates a row of views that will fit within the layout span of the row.
      void FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc)
      Gives notification that something was removed from the document in a location that the given flow view is responsible for.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ot-g:i.Ei sP/>�


Uses of Class javax.swing.text.FlowView.FlowStrategy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.FlowView.FlowStrategy

  • Packages that use FlowView.FlowStrategy
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of FlowView.FlowStrategy in javax.swing.text

      Fields in javax.swing.text declared as FlowView.FlowStrategy
      修饰符与类型 字段与描述
      protected FlowView.FlowStrategy FlowView.strategy
      The behavior for keeping the flow updated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aw.u"ol.srH�>>vea<※ar


Uses of Class javax.swing.text.GapContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.GapContent

No usage of javax.swing.text.GapContent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/l"olLss===ctrrbE


Uses of Class javax.swing.text.GlyphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.GlyphView

  • Packages that use GlyphView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of GlyphView in javax.swing.text

      Subclasses of GlyphView in javax.swing.text
      修饰符与类型 类与描述
      class  LabelView
      A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
      Methods in javax.swing.text with parameters of type GlyphView
      修饰符与类型 | 方法与描述
      abstract float | GlyphView.GlyphPainter.getAscent(GlyphView v)
      abstract int GlyphView.GlyphPainter.getBoundedPosition(GlyphView v, int p0, float x, float len)
      Determines the model location that represents the maximum advance that fits within the given span.
      abstract float | GlyphView.GlyphPainter.getDescent(GlyphView v)
      abstract float | GlyphView.GlyphPainter.getHeight(GlyphView v)
      int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      GlyphView.GlyphPainter GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1)
      Create a painter to use for the given GlyphView.
      abstract float GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x)
      Determine the span the glyphs given a start location (for tab expansion).
      abstract Shape GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      abstract void GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1)
      Paint the glyphs representing the given range.
      abstract int GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

    • Uses of GlyphView in javax.swing.text.html

      Subclasses of GlyphView in javax.swing.text.html
      修饰符与类型 类与描述
      class  InlineView
      Displays the inline element styles based upon css attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.GlyphView.GlyphPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.GlyphView.GlyphPainter

  • Packages that use GlyphView.GlyphPainter
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of GlyphView.GlyphPainter in javax.swing.text

      Methods in javax.swing.text that return GlyphView.GlyphPainter
      修饰符与类型 方法与描述
      GlyphView.GlyphPainter GlyphView.getGlyphPainter()
      Fetch the currently installed glyph painter.
      GlyphView.GlyphPainter GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1)
      Create a painter to use for the given GlyphView.
      Methods in javax.swing.text with parameters of type GlyphView.GlyphPainter
      修饰符与类型 方法与描述
      void GlyphView.setGlyphPainter(GlyphView.GlyphPainter p)
      Sets the painter to use for rendering glyphs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otly)VV.ilehf<<>< e


Uses of Class javax.swing.text.IconView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.IconView

No usage of javax.swing.text.IconView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

algb/plwsiiia.rria af


Uses of Class javax.swing.text.InternationalFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.InternationalFormatter

  • Packages that use InternationalFormatter
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of InternationalFormatter in javax.swing.text

      Subclasses of InternationalFormatter in javax.swing.text
      修饰符与类型 类与描述
      class  DateFormatter
      DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
      class  NumberFormatter
      NumberFormatter subclasses InternationalFormatter adding special behavior for numbers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ hn"


Uses of Class javax.swing.text.JTextComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.JTextComponent

  • Packages that use JTextComponent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of JTextComponent in javax.swing

      Subclasses of JTextComponent in javax.swing
      修饰符与类型 类与描述
      class  JEditorPane
      A text component to edit various kinds of content.
      class  JFormattedTextField
      JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
      class  JPasswordField
      JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
      class  JTextArea
      A JTextArea is a multi-line area that displays plain text.
      class  JTextField
      JTextField is a lightweight component that allows the editing of a single line of text.
      class  JTextPane
      A text component that can be marked up with attributes that are represented graphically.

    • Uses of JTextComponent in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type JTextComponent
      修饰符与类型 方法与描述
      abstract void TextUI.damageRange(JTextComponent t, int p0, int p1)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      abstract void TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      abstract EditorKit TextUI.getEditorKit(JTextComponent t)
      Fetches the binding of services that set a policy for the type of document being edited.
      abstract int TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      abstract View TextUI.getRootView(JTextComponent t)
      Fetches a View with the allocation of the associated text component (i.e.
      String TextUI.getToolTipText(JTextComponent t, Point pt)
      Returns the string to be used as the tooltip at the passed in location.
      abstract Rectangle TextUI.modelToView(JTextComponent t, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      abstract Rectangle TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      abstract int TextUI.viewToModel(JTextComponent t, Point pt)
      Converts the given place in the view coordinate system to the nearest representative location in the model.
      abstract int TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

    • Uses of JTextComponent in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return JTextComponent
      修饰符与类型 方法与描述
      protected JTextComponent BasicTextUI.getComponent()
      Fetches the text component associated with this UI implementation.
      Methods in javax.swing.plaf.basic with parameters of type JTextComponent
      修饰符与类型 方法与描述
      void BasicTextUI.damageRange(JTextComponent tc, int p0, int p1)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      void BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      EditorKit BasicEditorPaneUI.getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.
      EditorKit BasicTextUI.getEditorKit(JTextComponent tc)
      Fetches the EditorKit for the UI.
      int BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      View BasicTextUI.getRootView(JTextComponent tc)
      Fetches a View with the allocation of the associated text component (i.e.
      String BasicTextUI.getToolTipText(JTextComponent t, Point pt)
      Returns the string to be used as the tooltip at the passed in location.
      Rectangle BasicTextUI.modelToView(JTextComponent tc, int pos)
      Converts the given location in the model to a place in the view coordinate system.
      Rectangle BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      int BasicTextUI.viewToModel(JTextComponent tc, Point pt)
      Converts the given place in the view coordinate system to the nearest representative location in the model.
      int BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn)
      Converts the given place in the view coordinate system to the nearest representative location in the model.

    • Uses of JTextComponent in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type JTextComponent
      修饰符与类型 方法与描述
      void MultiTextUI.damageRange(JTextComponent a, int b, int c)
      Invokes the damageRange method on each UI handled by this object.
      void MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e)
      Invokes the damageRange method on each UI handled by this object.
      EditorKit MultiTextUI.getEditorKit(JTextComponent a)
      Invokes the getEditorKit method on each UI handled by this object.
      int MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e)
      Invokes the getNextVisualPositionFrom method on each UI handled by this object.
      View MultiTextUI.getRootView(JTextComponent a)
      Invokes the getRootView method on each UI handled by this object.
      String MultiTextUI.getToolTipText(JTextComponent a, Point b)
      Invokes the getToolTipText method on each UI handled by this object.
      Rectangle MultiTextUI.modelToView(JTextComponent a, int b)
      Invokes the modelToView method on each UI handled by this object.
      Rectangle MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c)
      Invokes the modelToView method on each UI handled by this object.
      int MultiTextUI.viewToModel(JTextComponent a, Point b)
      Invokes the viewToModel method on each UI handled by this object.
      int MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c)
      Invokes the viewToModel method on each UI handled by this object.

    • Uses of JTextComponent in javax.swing.text

      Methods in javax.swing.text that return JTextComponent
      修饰符与类型 方法与描述
      protected JTextComponent DefaultCaret.getComponent()
      Gets the text editor component that this caret is is bound to.
      protected JTextComponent TextAction.getFocusedComponent()
      Fetches the text component that currently has focus.
      protected JTextComponent TextAction.getTextComponent(ActionEvent e)
      Determines the component to use for the action.
      Methods in javax.swing.text with parameters of type JTextComponent
      修饰符与类型 | 方法与描述
      void DefaultHighlighter.deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      void DefaultCaret.deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      void Highlighter.deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      void Caret.deinstall(JTextComponent c)
      Called when the UI is being removed from the interface of a JTextComponent.
      int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
      Returns the next visual position to place the caret at from an existing position.
      static int Utilities.getNextWord(JTextComponent c, int offs)
      Determines the start of the next word for the given location.
      static Element Utilities.getParagraphElement(JTextComponent c, int offs)
      Determines the element to use for a paragraph/line.
      static int Utilities.getPositionAbove(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row above.
      static int Utilities.getPositionBelow(JTextComponent c, int offs, int x)
      Determines the position in the model that is closest to the given view location in the row below.
      static int Utilities.getPreviousWord(JTextComponent c, int offs)
      Determine the start of the prev word for the given location.
      static int Utilities.getRowEnd(JTextComponent c, int offs)
      Determines the ending row model position of the row that contains the specified model position.
      static int Utilities.getRowStart(JTextComponent c, int offs)
      Determines the starting row model position of the row that contains the specified model position.
      static int Utilities.getWordEnd(JTextComponent c, int offs)
      Determines the end of a word for the given location.
      static int Utilities.getWordStart(JTextComponent c, int offs)
      Determines the start of a word for the given model location.
      void DefaultHighlighter.install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void DefaultCaret.install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void Highlighter.install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void Caret.install(JTextComponent c)
      Called when the UI is being installed into the interface of a JTextComponent.
      void DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c)
      Paints a highlight.
      void Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c)
      Renders the highlight.
      abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      Shape DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      Paints a portion of a highlight.
      abstract void LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.
      void DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.

    • Uses of JTextComponent in javax.swing.tree

      Subclasses of JTextComponent in javax.swing.tree
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.JTextComponent.AccessibleJTextComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.JTextComponent.AccessibleJTextComponent

  • Packages that use JTextComponent.AccessibleJTextComponent
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of JTextComponent.AccessibleJTextComponent in javax.swing

      Subclasses of JTextComponent.AccessibleJTextComponent in javax.swing
      修饰符与类型 类与描述
      protected class  JEditorPane.AccessibleJEditorPane
      This class implements accessibility support for the JEditorPane class.
      protected class  JEditorPane.AccessibleJEditorPaneHTML
      This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
      protected class  JEditorPane.JEditorPaneAccessibleHypertextSupport
      What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
      protected class  JPasswordField.AccessibleJPasswordField
      This class implements accessibility support for the JPasswordField class.
      protected class  JTextArea.AccessibleJTextArea
      This class implements accessibility support for the JTextArea class.
      protected class  JTextField.AccessibleJTextField
      This class implements accessibility support for the JTextField class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Otiaw-F v.vj.!n/vbaohibP


Uses of Class javax.swing.text.JTextComponent.DropLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.JTextComponent.DropLocation

  • Packages that use JTextComponent.DropLocation
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JTextComponent.DropLocation in javax.swing.text

      Methods in javax.swing.text that return JTextComponent.DropLocation
      修饰符与类型 方法与描述
      JTextComponent.DropLocation JTextComponent.getDropLocation()
      Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o<舤mlrayyyue//!"fb_o n


Uses of Class javax.swing.text.JTextComponent.KeyBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.JTextComponent.KeyBinding

  • Packages that use JTextComponent.KeyBinding
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of JTextComponent.KeyBinding in javax.swing

      Methods in javax.swing that return JTextComponent.KeyBinding
      修饰符与类型 方法与描述
      static JTextComponent.KeyBinding[] LookAndFeel.makeKeyBindings(Object[] keyBindingList)
      Convenience method for building an array of KeyBindings.

    • Uses of JTextComponent.KeyBinding in javax.swing.text

      Methods in javax.swing.text with parameters of type JTextComponent.KeyBinding
      修饰符与类型 方法与描述
      static void JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
      Loads a keymap with a bunch of bindings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/intCoJ.TTTe.eeeserT


Uses of Class javax.swing.text.LabelView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.LabelView

  • Packages that use LabelView
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of LabelView in javax.swing.text.html

      Subclasses of LabelView in javax.swing.text.html
      修饰符与类型 类与描述
      class  InlineView
      Displays the inline element styles based upon css attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

en=heymxetttgv//r rd= l"=


Uses of Class javax.swing.text.LayeredHighlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.LayeredHighlighter

  • Packages that use LayeredHighlighter
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of LayeredHighlighter in javax.swing.plaf.basic

      Subclasses of LayeredHighlighter in javax.swing.plaf.basic
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicHighlighter

    • Uses of LayeredHighlighter in javax.swing.text

      Subclasses of LayeredHighlighter in javax.swing.text
      修饰符与类型 类与描述
      class  DefaultHighlighter
      Implements the Highlighter interfaces.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/"3di>lpcptr!etdiS;p


Uses of Class javax.swing.text.LayoutQueue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.LayoutQueue

  • Packages that use LayoutQueue
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of LayoutQueue in javax.swing.text

      Methods in javax.swing.text that return LayoutQueue
      修饰符与类型 方法与描述
      static LayoutQueue LayoutQueue.getDefaultQueue()
      Fetch the default layout queue.
      protected LayoutQueue AsyncBoxView.getLayoutQueue()
      Fetch the queue to use for layout.
      Methods in javax.swing.text with parameters of type LayoutQueue
      修饰符与类型 方法与描述
      static void LayoutQueue.setDefaultQueue(LayoutQueue q)
      Set the default layout queue.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bleibl3s 4 tlnftdi瀋a


Uses of Class javax.swing.text.MaskFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.MaskFormatter

No usage of javax.swing.text.MaskFormatter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rd>


Uses of Class javax.swing.text.NavigationFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.NavigationFilter

  • Packages that use NavigationFilter
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of NavigationFilter in javax.swing

      Methods in javax.swing that return NavigationFilter
      修饰符与类型 方法与描述
      protected NavigationFilter JFormattedTextField.AbstractFormatter.getNavigationFilter()
      Subclass and override if you wish to provide a filter to restrict where the user can navigate to.

    • Uses of NavigationFilter in javax.swing.text

      Methods in javax.swing.text that return NavigationFilter
      修饰符与类型 方法与描述
      protected NavigationFilter DefaultFormatter.getNavigationFilter()
      Returns the NavigationFilter used to restrict where the cursor can be placed.
      NavigationFilter JTextComponent.getNavigationFilter()
      Returns the NavigationFilter.
      Methods in javax.swing.text with parameters of type NavigationFilter
      修饰符与类型 方法与描述
      void JTextComponent.setNavigationFilter(NavigationFilter filter)
      Sets the NavigationFilter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m3>rfk=s.g&l>>jre"nbi


Uses of Class javax.swing.text.NavigationFilter.FilterBypass

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.NavigationFilter.FilterBypass

  • Packages that use NavigationFilter.FilterBypass
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of NavigationFilter.FilterBypass in javax.swing.text

      Methods in javax.swing.text with parameters of type NavigationFilter.FilterBypass
      修饰符与类型 方法与描述
      void NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret moving the dot.
      void NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret setting the dot.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lteD/tewsiiia.rra;acls


Uses of Class javax.swing.text.NumberFormatter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.NumberFormatter

No usage of javax.swing.text.NumberFormatter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d >


Uses of Class javax.swing.text.ParagraphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.ParagraphView

  • Packages that use ParagraphView
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of ParagraphView in javax.swing.text.html

      Subclasses of ParagraphView in javax.swing.text.html
      修饰符与类型 类与描述
      class  ParagraphView
      Displays the a paragraph, and uses css attributes for its configuration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ia=oan nisedh>rlni ncrb


Uses of Class javax.swing.text.PasswordView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.PasswordView

No usage of javax.swing.text.PasswordView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a萮.tttaarr>no.f


Uses of Class javax.swing.text.PlainDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.PlainDocument

No usage of javax.swing.text.PlainDocument
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t� 饎l�r( �|


Uses of Class javax.swing.text.PlainView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.PlainView

  • Packages that use PlainView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of PlainView in javax.swing.text

      Subclasses of PlainView in javax.swing.text
      修饰符与类型 类与描述
      class  FieldView
      Extends the multi-line plain text view to be suitable for a single-line editor view.
      class  PasswordView
      Implements a View suitable for use in JPasswordField UI implementations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gsntewivatan".i .s srat


Uses of Class javax.swing.text.Position.Bias

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.Position.Bias

  • Packages that use Position.Bias
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Position.Bias in javax.swing

      Methods in javax.swing with parameters of type Position.Bias
      修饰符与类型 方法与描述
      TreePath JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias)
      Returns the TreePath to the next tree element that begins with a prefix.
      int JList.getNextMatch(String prefix, int startIndex, Position.Bias bias)
      Returns the next list element whose toString value starts with the given prefix.

    • Uses of Position.Bias in javax.swing.plaf

      Methods in javax.swing.plaf with parameters of type Position.Bias
      修饰符与类型 方法与描述
      abstract void TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      abstract int TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      abstract int TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      abstract Rectangle TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      abstract int TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

    • Uses of Position.Bias in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type Position.Bias
      修饰符与类型 方法与描述
      void BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias)
      Causes the portion of the view responsible for the given part of the model to be repainted.
      int BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      Rectangle BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias)
      Converts the given location in the model to a place in the view coordinate system.
      int BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn)
      Converts the given place in the view coordinate system to the nearest representative location in the model.

    • Uses of Position.Bias in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi with parameters of type Position.Bias
      修饰符与类型 方法与描述
      void MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e)
      Invokes the damageRange method on each UI handled by this object.
      int MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e)
      Invokes the getNextVisualPositionFrom method on each UI handled by this object.
      int MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e)
      Invokes the getNextVisualPositionFrom method on each UI handled by this object.
      Rectangle MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c)
      Invokes the modelToView method on each UI handled by this object.
      int MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c)
      Invokes the viewToModel method on each UI handled by this object.

    • Uses of Position.Bias in javax.swing.text

      Fields in javax.swing.text declared as Position.Bias
      修饰符与类型 字段与描述
      static Position.Bias Position.Bias.Backward
      Indicates a bias toward the previous character in the model.
      static Position.Bias Position.Bias.Forward
      Indicates to bias toward the next character in the model.
      Methods in javax.swing.text that return Position.Bias
      修饰符与类型 方法与描述
      Position.Bias JTextComponent.DropLocation.getBias()
      Returns the bias for the drop index.
      Position.Bias DefaultCaret.getDotBias()
      Returns the bias of the caret position.
      Position.Bias DefaultCaret.getMarkBias()
      Returns the bias of the mark.
      Methods in javax.swing.text with parameters of type Position.Bias
      修饰符与类型 方法与描述
      protected boolean CompositeView.flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      protected boolean BoxView.flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      protected boolean ParagraphView.flipEastAndWestAtEnds(int position, Position.Bias bias)
      Determines in which direction the next view lays.
      protected int ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      Returns the closest model position to x.
      protected int ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
      Returns the closest model position to x.
      protected int CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected int CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected int CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the north or south direction.
      protected int CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the north or south direction.
      protected int ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      protected int ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Returns the next visual position for the cursor, in either the east or west direction.
      int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location that one might place a caret.
      int View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location at which one might place a caret.
      int View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
      Provides a way to determine the next visually represented model location at which one might place a caret.
      int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
      Returns the next visual position to place the caret at from an existing position.
      int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
      Returns the next visual position to place the caret at from an existing position.
      int AsyncBoxView.getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      int CompositeView.getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      int View.getViewIndex(int pos, Position.Bias b)
      Returns the child view index representing the given position in the model.
      protected int AsyncBoxView.getViewIndexAtPosition(int pos, Position.Bias b)
      Fetches the child view index representing the given position in the model.
      abstract Shape GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
      Provides a mapping, for a given region, from the document model coordinate space to the view coordinate space.
      Shape PasswordView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape PlainView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape FieldView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape IconView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape ComponentView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the coordinate space of the model to that of the view.
      Shape GlyphView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape CompositeView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      Shape BoxView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      abstract Shape View.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping, for a given character, from the document model coordinate space to the view coordinate space.
      void DefaultCaret.moveDot(int dot, Position.Bias dotBias)
      Moves the caret position to the specified position, with the specified bias.
      abstract void NavigationFilter.FilterBypass.moveDot(int dot, Position.Bias bias)
      Moves the caret location, bypassing the NavigationFilter.
      void NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret moving the dot.
      void DefaultCaret.setDot(int dot, Position.Bias dotBias)
      Sets the caret position and mark to the specified position, with the specified bias.
      abstract void NavigationFilter.FilterBypass.setDot(int dot, Position.Bias bias)
      Sets the caret location, bypassing the NavigationFilter.
      void NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias)
      Invoked prior to the Caret setting the dot.
      int PasswordView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int PlainView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int FieldView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int AsyncBoxView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int IconView.viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int ComponentView.viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int GlyphView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int CompositeView.viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      int BoxView.viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      abstract int View.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
      abstract int GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

    • Uses of Position.Bias in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Position.Bias
      修饰符与类型 方法与描述
      Shape ImageView.modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      int ImageView.viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.Segment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.Segment

  • Packages that use Segment
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Segment in javax.swing.text

      Methods in javax.swing.text that return Segment
      修饰符与类型 方法与描述
      protected Segment PlainView.getLineBuffer()
      Gives access to a buffer that can be used to fetch text from the associated document.
      protected Segment WrappedPlainView.getLineBuffer()
      Gives access to a buffer that can be used to fetch text from the associated document.
      Segment GlyphView.getText(int p0, int p1)
      Fetch a reference to the text that occupies the given range.
      Methods in javax.swing.text with parameters of type Segment
      修饰符与类型 | 方法与描述
      static int Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
      Draws the given text, expanding any tabs that are contained using the given tab expansion technique.
      static int Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determine where to break the given text to fit within the given span.
      void StringContent.getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      void GapContent.getChars(int where, int len, Segment chars)
      Retrieves a portion of the content.
      void AbstractDocument.Content.getChars(int where, int len, Segment txt)
      Gets a sequence of characters and copies them into a Segment.
      static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determines the relative offset into the given text that best represents the given span in the view coordinate system.
      static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
      static int Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
      Determines the width of the given segment of text taking tabs into consideration.
      void AbstractDocument.getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
      void Document.getText(int offset, int length, Segment txt)
      Fetches the text contained within the given portion of the document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ypcge.si>s .g xb"dpC祍


Uses of Class javax.swing.text.SimpleAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.SimpleAttributeSet

  • Packages that use SimpleAttributeSet
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of SimpleAttributeSet in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return SimpleAttributeSet
      修饰符与类型 | 方法与描述
      protected SimpleAttributeSet | Parser.getAttributes()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= "n>ocei/na"


Uses of Class javax.swing.text.StringContent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StringContent

No usage of javax.swing.text.StringContent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rie>atiaNvvvescc>k" l


Uses of Class javax.swing.text.StyleConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleConstants

  • Packages that use StyleConstants
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of StyleConstants in javax.swing.text

      Subclasses of StyleConstants in javax.swing.text
      修饰符与类型 类与描述
      static class  StyleConstants.CharacterConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a character style.
      static class  StyleConstants.ColorConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a color.
      static class  StyleConstants.FontConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a font.
      static class  StyleConstants.ParagraphConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n g>.htDm,f-/x>rxeyxe>j


Uses of Class javax.swing.text.StyleConstants.CharacterConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleConstants.CharacterConstants

No usage of javax.swing.text.StyleConstants.CharacterConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wa >blosasss d;;ly"tp


Uses of Class javax.swing.text.StyleConstants.ColorConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleConstants.ColorConstants

No usage of javax.swing.text.StyleConstants.ColorConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><=>g/s�


Uses of Class javax.swing.text.StyleConstants.FontConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleConstants.FontConstants

No usage of javax.swing.text.StyleConstants.FontConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>-t>o>l-o>>>n


Uses of Class javax.swing.text.StyleConstants.ParagraphConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleConstants.ParagraphConstants

No usage of javax.swing.text.StyleConstants.ParagraphConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.htas ic"lllltttds/eo


Uses of Class javax.swing.text.StyleContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleContext

  • Packages that use StyleContext
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleContext in javax.swing.text

      Methods in javax.swing.text that return StyleContext
      修饰符与类型 方法与描述
      static StyleContext StyleContext.getDefaultStyleContext()
      Returns default AttributeContext shared by all documents that don't bother to define/supply their own context.
      Constructors in javax.swing.text with parameters of type StyleContext
      构造方法与描述
      DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
      Constructs a styled document.
      DefaultStyledDocument(StyleContext styles)
      Constructs a styled document with the default content storage implementation and a shared set of styles.

    • Uses of StyleContext in javax.swing.text.html

      Subclasses of StyleContext in javax.swing.text.html
      修饰符与类型 类与描述
      class  StyleSheet
      Support for defining the visual characteristics of HTML views being rendered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/eaSlyna /=i=.tlg>蚢o i/m


Uses of Class javax.swing.text.StyleContext.NamedStyle

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleContext.NamedStyle

No usage of javax.swing.text.StyleContext.NamedStyle
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h"rostr>nCCCsaaa"c=un


Uses of Class javax.swing.text.StyleContext.SmallAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyleContext.SmallAttributeSet

  • Packages that use StyleContext.SmallAttributeSet
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleContext.SmallAttributeSet in javax.swing.text

      Methods in javax.swing.text that return StyleContext.SmallAttributeSet
      修饰符与类型 方法与描述
      protected StyleContext.SmallAttributeSet StyleContext.createSmallAttributeSet(AttributeSet a)
      Create a compact set of attributes that might be shared.

    • Uses of StyleContext.SmallAttributeSet in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleContext.SmallAttributeSet
      修饰符与类型 方法与描述
      protected StyleContext.SmallAttributeSet StyleSheet.createSmallAttributeSet(AttributeSet a)
      Creates a compact set of attributes that might be shared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=FisldC/esorssC- i{/p 薼a


Uses of Class javax.swing.text.StyledEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit

  • Packages that use StyledEditorKit
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

    • Uses of StyledEditorKit in javax.swing

      Methods in javax.swing that return StyledEditorKit
      修饰符与类型 方法与描述
      protected StyledEditorKit JTextPane.getStyledEditorKit()
      Gets the editor kit.

    • Uses of StyledEditorKit in javax.swing.text

      Methods in javax.swing.text that return StyledEditorKit
      修饰符与类型 方法与描述
      protected StyledEditorKit StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e)
      Gets the editor kit associated with an editor pane.

    • Uses of StyledEditorKit in javax.swing.text.html

      Subclasses of StyledEditorKit in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLEditorKit
      The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.

    • Uses of StyledEditorKit in javax.swing.text.rtf

      Subclasses of StyledEditorKit in javax.swing.text.rtf
      修饰符与类型 类与描述
      class  RTFEditorKit
      This is the default implementation of RTF editing functionality.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slb jvri&


Uses of Class javax.swing.text.StyledEditorKit.AlignmentAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.AlignmentAction

No usage of javax.swing.text.StyledEditorKit.AlignmentAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r <>eeio"cd


Uses of Class javax.swing.text.StyledEditorKit.BoldAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.BoldAction

No usage of javax.swing.text.StyledEditorKit.BoldAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

At/ab;1;p-1


Uses of Class javax.swing.text.StyledEditorKit.FontFamilyAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.FontFamilyAction

No usage of javax.swing.text.StyledEditorKit.FontFamilyAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bncppa/ou槇>v� 


Uses of Class javax.swing.text.StyledEditorKit.FontSizeAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.FontSizeAction

No usage of javax.swing.text.StyledEditorKit.FontSizeAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.swing.text.StyledEditorKit.ForegroundAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.ForegroundAction

No usage of javax.swing.text.StyledEditorKit.ForegroundAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.eldepbSt aeosno�


Uses of Class javax.swing.text.StyledEditorKit.ItalicAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.ItalicAction

No usage of javax.swing.text.StyledEditorKit.ItalicAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sl=>e>


Uses of Class javax.swing.text.StyledEditorKit.StyledTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.StyledTextAction

  • Packages that use StyledEditorKit.StyledTextAction
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyledEditorKit.StyledTextAction in javax.swing.text

      Subclasses of StyledEditorKit.StyledTextAction in javax.swing.text
      修饰符与类型 类与描述
      static class  StyledEditorKit.AlignmentAction
      An action to set paragraph alignment.
      static class  StyledEditorKit.BoldAction
      An action to toggle the bold attribute.
      static class  StyledEditorKit.FontFamilyAction
      An action to set the font family in the associated JEditorPane.
      static class  StyledEditorKit.FontSizeAction
      An action to set the font size in the associated JEditorPane.
      static class  StyledEditorKit.ForegroundAction
      An action to set foreground color.
      static class  StyledEditorKit.ItalicAction
      An action to toggle the italic attribute.
      static class  StyledEditorKit.UnderlineAction
      An action to toggle the underline attribute.

    • Uses of StyledEditorKit.StyledTextAction in javax.swing.text.html

      Subclasses of StyledEditorKit.StyledTextAction in javax.swing.text.html
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLTextAction
      An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t c/chte.t仕r藻使 竐


Uses of Class javax.swing.text.StyledEditorKit.UnderlineAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.StyledEditorKit.UnderlineAction

No usage of javax.swing.text.StyledEditorKit.UnderlineAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c"trdEdtSyyyxs..n c>/


Uses of Class javax.swing.text.TableView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TableView

No usage of javax.swing.text.TableView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ccaode"t>>>isoocfot"


Uses of Class javax.swing.text.TableView.TableCell

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TableView.TableCell

  • Packages that use TableView.TableCell
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TableView.TableCell in javax.swing.text

      Methods in javax.swing.text that return TableView.TableCell
      修饰符与类型 方法与描述
      protected TableView.TableCell TableView.createTableCell(Element elem)
      Deprecated.
      Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

╝le ojteepm�


Uses of Class javax.swing.text.TableView.TableRow

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TableView.TableRow

  • Packages that use TableView.TableRow
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TableView.TableRow in javax.swing.text

      Methods in javax.swing.text that return TableView.TableRow
      修饰符与类型 方法与描述
      protected TableView.TableRow TableView.createTableRow(Element elem)
      Creates a new table row.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. /.e"."=....l.�.a...gg.1


Uses of Class javax.swing.text.TabSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TabSet

  • Packages that use TabSet
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TabSet in javax.swing.text

      Methods in javax.swing.text that return TabSet
      修饰符与类型 方法与描述
      protected TabSet ParagraphView.getTabSet()
      Gets the Tabset to be used in calculating tabs.
      static TabSet StyleConstants.getTabSet(AttributeSet a)
      Gets the TabSet.
      Methods in javax.swing.text with parameters of type TabSet
      修饰符与类型 方法与描述
      static void StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs)
      Sets the TabSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sl cpoe


Uses of Class javax.swing.text.TabStop

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TabStop

  • Packages that use TabStop
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TabStop in javax.swing.text

      Methods in javax.swing.text that return TabStop
      修饰符与类型 方法与描述
      TabStop TabSet.getTab(int index)
      Returns the TabStop at index index.
      TabStop TabSet.getTabAfter(float location)
      Returns the Tab instance after location.
      Methods in javax.swing.text with parameters of type TabStop
      修饰符与类型 | 方法与描述
      int | TabSet.getTabIndex(TabStop tab)
      Constructors in javax.swing.text with parameters of type TabStop
      构造方法与描述
      TabSet(TabStop[] tabs)
      Creates and returns an instance of TabSet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ognhbieyp


Uses of Class javax.swing.text.TextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.TextAction

  • Packages that use TextAction
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of TextAction in javax.swing.text

      Subclasses of TextAction in javax.swing.text
      修饰符与类型 类与描述
      static class  DefaultEditorKit.BeepAction
      Creates a beep.
      static class  DefaultEditorKit.CopyAction
      Copies the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.CutAction
      Cuts the selected region and place its contents into the system clipboard.
      static class  DefaultEditorKit.DefaultKeyTypedAction
      The action that is executed by default if a key typed event is received and there is no keymap entry.
      static class  DefaultEditorKit.InsertBreakAction
      Places a line/paragraph break into the document.
      static class  DefaultEditorKit.InsertContentAction
      Places content into the associated document.
      static class  DefaultEditorKit.InsertTabAction
      Places a tab character into the document.
      static class  DefaultEditorKit.PasteAction
      Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
      static class  StyledEditorKit.AlignmentAction
      An action to set paragraph alignment.
      static class  StyledEditorKit.BoldAction
      An action to toggle the bold attribute.
      static class  StyledEditorKit.FontFamilyAction
      An action to set the font family in the associated JEditorPane.
      static class  StyledEditorKit.FontSizeAction
      An action to set the font size in the associated JEditorPane.
      static class  StyledEditorKit.ForegroundAction
      An action to set foreground color.
      static class  StyledEditorKit.ItalicAction
      An action to toggle the italic attribute.
      static class  StyledEditorKit.StyledTextAction
      An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.
      static class  StyledEditorKit.UnderlineAction
      An action to toggle the underline attribute.

    • Uses of TextAction in javax.swing.text.html

      Subclasses of TextAction in javax.swing.text.html
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLTextAction
      An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=dcot>"s mLhti癵t/aca


Uses of Class javax.swing.text.Utilities

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.Utilities

No usage of javax.swing.text.Utilities
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.View

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.View

  • Packages that use View
    软件包 描述
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of View in javax.swing.plaf

      Methods in javax.swing.plaf that return View
      修饰符与类型 方法与描述
      abstract View TextUI.getRootView(JTextComponent t)
      Fetches a View with the allocation of the associated text component (i.e.

    • Uses of View in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return View
      修饰符与类型 方法与描述
      View BasicPasswordFieldUI.create(Element elem)
      Creates a view (PasswordView) for an element.
      View BasicTextAreaUI.create(Element elem)
      Creates the view for an element.
      View BasicTextFieldUI.create(Element elem)
      Creates a view (FieldView) based on an element.
      View BasicTextUI.create(Element elem)
      Creates a view for an element.
      View BasicTextUI.create(Element elem, int p0, int p1)
      Creates a view for an element.
      static View BasicHTML.createHTMLView(JComponent c, String html)
      Create an html renderer for the given component and string of html.
      View BasicTextUI.getRootView(JTextComponent tc)
      Fetches a View with the allocation of the associated text component (i.e.
      protected View BasicTabbedPaneUI.getTextViewForTab(int tabIndex)
      Returns the text View object required to render stylized text (HTML) for the specified tab or null if no specialized text rendering is needed for this tab.
      Methods in javax.swing.plaf.basic with parameters of type View
      修饰符与类型 方法与描述
      static int BasicHTML.getHTMLBaseline(View view, int w, int h)
      Returns the baseline for the html renderer.
      protected void BasicTextUI.setView(View v)
      Sets the current root of the view hierarchy and calls invalidate().

    • Uses of View in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return View
      修饰符与类型 方法与描述
      View MultiTextUI.getRootView(JTextComponent a)
      Invokes the getRootView method on each UI handled by this object.

    • Uses of View in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return View
      修饰符与类型 方法与描述
      View SynthPasswordFieldUI.create(Element elem)
      Creates a view (PasswordView) for an element.

    • Uses of View in javax.swing.text

      Subclasses of View in javax.swing.text
      修饰符与类型 类与描述
      class  AsyncBoxView
      A box that does layout asynchronously.
      class  BoxView
      A view that arranges its children into a box shape by tiling its children along an axis.
      class  ComponentView
      Component decorator that implements the view interface.
      class  CompositeView
      CompositeView is an abstract View implementation which manages one or more child views.
      class  FieldView
      Extends the multi-line plain text view to be suitable for a single-line editor view.
      class  FlowView
      A View that tries to flow it's children into some partially constrained space.
      class  GlyphView
      A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
      class  IconView
      Icon decorator that implements the view interface.
      class  LabelView
      A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      class  PasswordView
      Implements a View suitable for use in JPasswordField UI implementations.
      class  PlainView
      Implements View interface for a simple multi-line text view that has text in one font and color.
      class  TableView
      Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
      class  TableView.TableCell
      Deprecated.
      A table cell can now be any View implementation.
      class  TableView.TableRow
      View of a row in a row-centric table.
      class  WrappedPlainView
      View of plain text (text with only one font and color) that does line-wrapping.
      class  ZoneView
      ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.
      Fields in javax.swing.text declared as View
      修饰符与类型 字段与描述
      protected View FlowView.layoutPool
      These are the views that represent the child elements of the element this view represents (The logical view to translate to a physical view).
      Methods in javax.swing.text that return View
      修饰符与类型 方法与描述
      View ParagraphView.breakView(int axis, float len, Shape a)
      Breaks this view on the given axis at the given length.
      View GlyphView.breakView(int axis, int p0, float pos, float len)
      Breaks this view on the given axis at the given length.
      View View.breakView(int axis, int offset, float pos, float len)
      Tries to break this view on the given axis.
      View ViewFactory.create(Element elem)
      Creates a view from the given structural element of a document.
      View GlyphView.createFragment(int p0, int p1)
      Creates a view that represents a portion of the element.
      View View.createFragment(int p0, int p1)
      Creates a view that represents a portion of the element.
      protected abstract View FlowView.createRow()
      Create a View that should be used to hold a a rows worth of children in a flow.
      protected View ParagraphView.createRow()
      Create a View that should be used to hold a a row's worth of children in a flow.
      protected View FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex)
      Creates a view that can be used to represent the current piece of the flow.
      protected View ZoneView.createZone(int p0, int p1)
      Create a view to represent a zone for the given range within the model (which should be within the range of this objects responsibility).
      View AsyncBoxView.ChildState.getChildView()
      Fetch the child view this record represents
      protected View ParagraphView.getLayoutView(int index)
      Returns the view at a given index.
      protected View FlowView.FlowStrategy.getLogicalView(FlowView fv)
      This method gives flow strategies access to the logical view of the FlowView.
      View View.getParent()
      Returns the parent of the view.
      View AsyncBoxView.getView(int n)
      Gets the nth child view.
      View CompositeView.getView(int n)
      Returns the n-th view in this container.
      View View.getView(int n)
      Gets the nth child view.
      protected abstract View CompositeView.getViewAtPoint(int x, int y, Rectangle alloc)
      Fetches the child view at the given coordinates.
      protected View BoxView.getViewAtPoint(int x, int y, Rectangle alloc)
      Fetches the child view at the given coordinates.
      protected View TableView.getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      protected View TableView.TableRow.getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      protected View CompositeView.getViewAtPosition(int pos, Rectangle a)
      Fetches the child view that represents the given position in the model.
      Methods in javax.swing.text with parameters of type View
      修饰符与类型 | 方法与描述
      void View.append(View v)
      Appends a single child view.
      protected AsyncBoxView.ChildState AsyncBoxView.createChildState(View v)
      New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more
      protected void View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the DocumentEvent to the give child view.
      void View.insert(int offs, View v)
      Inserts a single child view.
      protected boolean ZoneView.isZoneLoaded(View zone)
      Determine if a zone is in the loaded state.
      abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      Shape DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view)
      Paints a portion of a highlight.
      abstract void LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.
      void DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
      When leaf Views (such as LabelView) are rendering they should call into this method.
      void AsyncBoxView.preferenceChanged(View child, boolean width, boolean height)
      Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
      void BoxView.preferenceChanged(View child, boolean width, boolean height)
      This is called by a child to indicate its preferred span has changed.
      void View.preferenceChanged(View child, boolean width, boolean height)
      Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
      void TableView.replace(int offset, int length, View[] views)
      Change the child views.
      void TableView.TableRow.replace(int offset, int length, View[] views)
      Change the child views.
      void AsyncBoxView.replace(int offset, int length, View[] views)
      Calls the superclass to update the child views, and updates the status records for the children.
      void CompositeView.replace(int offset, int length, View[] views)
      Replaces child views.
      void BoxView.replace(int index, int length, View[] elems)
      Invalidates the layout and resizes the cache of requests/allocations.
      void View.replace(int offset, int length, View[] views)
      Replaces child views.
      void AsyncBoxView.setParent(View parent)
      Sets the parent of the view.
      void ComponentView.setParent(View p)
      Sets the parent for a child view.
      void CompositeView.setParent(View parent)
      Sets the parent of the view.
      void FlowView.setParent(View parent)
      Sets the parent of the view.
      void View.setParent(View parent)
      Establishes the parent view for this view.
      protected void ZoneView.unloadZone(View zone)
      Unload a zone (Convert the zone to its memory saving state).
      protected void ZoneView.zoneWasLoaded(View zone)
      Called by a zone when it gets loaded.
      Constructors in javax.swing.text with parameters of type View
      构造方法与描述
      AsyncBoxView.ChildState(View v)
      Construct a child status.

    • Uses of View in javax.swing.text.html

      Subclasses of View in javax.swing.text.html
      修饰符与类型 类与描述
      class  BlockView
      A view implementation to display a block (as a box) with CSS specifications.
      class  FormView
      Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
      class  ImageView
      View of an Image, intended to support the HTML <IMG> tag.
      class  InlineView
      Displays the inline element styles based upon css attributes.
      class  ListView
      A view implementation to display an html list
      class  ObjectView
      Component decorator that implements the view interface for <object> elements.
      Methods in javax.swing.text.html that return View
      修饰符与类型 方法与描述
      View InlineView.breakView(int axis, int offset, float pos, float len)
      Tries to break this view on the given axis.
      View HTMLEditorKit.HTMLFactory.create(Element elem)
      Creates a view from an element.
      Methods in javax.swing.text.html with parameters of type View
      修饰符与类型 方法与描述
      float StyleSheet.BoxPainter.getInset(int side, View v)
      Fetches the inset needed on a given side to account for the margin, border, and padding.
      AttributeSet StyleSheet.getViewAttributes(View v)
      Fetches a set of attributes to use in the view for displaying.
      void StyleSheet.BoxPainter.paint(Graphics g, float x, float y, float w, float h, View v)
      Paints the CSS box according to the attributes given.
      void StyleSheet.ListPainter.paint(Graphics g, float x, float y, float w, float h, View v, int item)
      Paints the CSS list decoration according to the attributes given.
      void ImageView.setParent(View parent)
      Establishes the parent view for this view.
      void ParagraphView.setParent(View parent)
      Establishes the parent view for this view.
      void BlockView.setParent(View parent)
      Establishes the parent view for this view.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.WrappedPlainView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.WrappedPlainView

No usage of javax.swing.text.WrappedPlainView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttiewxetttgv//ksaem


Uses of Class javax.swing.text.ZoneView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.ZoneView

No usage of javax.swing.text.ZoneView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s tＨ�/�o>


Uses of Interface javax.swing.text.AbstractDocument.AttributeContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AbstractDocument.AttributeContext

  • Packages that use AbstractDocument.AttributeContext
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.AttributeContext in javax.swing.text

      Classes in javax.swing.text that implement AbstractDocument.AttributeContext
      修饰符与类型 类与描述
      class  StyleContext
      A pool of styles and their associated resources.
      Methods in javax.swing.text that return AbstractDocument.AttributeContext
      修饰符与类型 方法与描述
      protected AbstractDocument.AttributeContext AbstractDocument.getAttributeContext()
      Fetches the context for managing attributes.
      Constructors in javax.swing.text with parameters of type AbstractDocument.AttributeContext
      构造方法与描述
      AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
      Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.

    • Uses of AbstractDocument.AttributeContext in javax.swing.text.html

      Classes in javax.swing.text.html that implement AbstractDocument.AttributeContext
      修饰符与类型 类与描述
      class  StyleSheet
      Support for defining the visual characteristics of HTML views being rendered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

birr7sgs/ttt;Eaaudbc> "


Uses of Interface javax.swing.text.AbstractDocument.Content

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AbstractDocument.Content

  • Packages that use AbstractDocument.Content
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AbstractDocument.Content in javax.swing.text

      Classes in javax.swing.text that implement AbstractDocument.Content
      修饰符与类型 类与描述
      class  GapContent
      An implementation of the AbstractDocument.Content interface implemented using a gapped buffer similar to that used by emacs.
      class  StringContent
      An implementation of the AbstractDocument.Content interface that is a brute force implementation that is useful for relatively small documents and/or debugging.
      Methods in javax.swing.text that return AbstractDocument.Content
      修饰符与类型 方法与描述
      protected AbstractDocument.Content AbstractDocument.getContent()
      Gets the content for the document.
      Constructors in javax.swing.text with parameters of type AbstractDocument.Content
      构造方法与描述
      AbstractDocument(AbstractDocument.Content data)
      Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
      AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
      Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
      DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
      Constructs a styled document.
      PlainDocument(AbstractDocument.Content c)
      Constructs a plain text document.

    • Uses of AbstractDocument.Content in javax.swing.text.html

      Constructors in javax.swing.text.html with parameters of type AbstractDocument.Content
      构造方法与描述
      HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
      Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

- ./>r ad/ajnl/ e"te


Uses of Interface javax.swing.text.AttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AttributeSet

  • Packages that use AttributeSet
    软件包 描述
    java.awt
    Contains all of the classes for creating user interfaces and for painting graphics and images.
    javax.accessibility
    Defines a contract between user-interface components and an assistive technology that provides access to those components.
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of AttributeSet in java.awt

      Methods in java.awt that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet TextComponent.AccessibleAWTTextComponent.getCharacterAttribute(int i)
      Returns the AttributeSet for a given character (at a given index).

    • Uses of AttributeSet in javax.accessibility

      Fields in javax.accessibility declared as AttributeSet
      修饰符与类型 字段与描述
      AttributeSet AccessibleAttributeSequence.attributes
      The text attributes
      Methods in javax.accessibility that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet AccessibleText.getCharacterAttribute(int i)
      Returns the AttributeSet for a given character at a given index
      Methods in javax.accessibility with parameters of type AttributeSet
      修饰符与类型 方法与描述
      void AccessibleEditableText.setAttributes(int startIndex, int endIndex, AttributeSet as)
      Sets attributes for the text between two indices.
      Constructors in javax.accessibility with parameters of type AttributeSet
      构造方法与描述
      AccessibleAttributeSequence(int start, int end, AttributeSet attr)
      Constructs an AccessibleAttributeSequence with the given parameters.

    • Uses of AttributeSet in javax.swing

      Methods in javax.swing that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet ProgressMonitor.AccessibleProgressMonitor.getCharacterAttribute(int i)
      Returns the AttributeSet for a given character at a given index
      AttributeSet JSpinner.AccessibleJSpinner.getCharacterAttribute(int i)
      Returns the AttributeSet for a given character at a given index
      AttributeSet JLabel.AccessibleJLabel.getCharacterAttribute(int i)
      Return the AttributeSet for a given character at a given index
      AttributeSet AbstractButton.AccessibleAbstractButton.getCharacterAttribute(int i)
      Return the AttributeSet for a given character at a given index
      AttributeSet JTextPane.getCharacterAttributes()
      Fetches the character attributes in effect at the current location of the caret, or null.
      AttributeSet JTextPane.getParagraphAttributes()
      Fetches the current paragraph attributes in effect at the location of the caret, or null if none.
      Methods in javax.swing with parameters of type AttributeSet
      修饰符与类型 方法与描述
      void JSpinner.AccessibleJSpinner.setAttributes(int startIndex, int endIndex, AttributeSet as)
      Sets attributes for the text between two indices.
      void JTextPane.setCharacterAttributes(AttributeSet attr, boolean replace)
      Applies the given attributes to character content.
      void JTextPane.setParagraphAttributes(AttributeSet attr, boolean replace)
      Applies the given attributes to paragraphs.

    • Uses of AttributeSet in javax.swing.text

      Subinterfaces of AttributeSet in javax.swing.text
      修饰符与类型 Interface and Description
      interface  MutableAttributeSet
      A generic interface for a mutable collection of unique attributes.
      interface  Style
      A collection of attributes to associate with an element in a document.
      Classes in javax.swing.text that implement AttributeSet
      修饰符与类型 类与描述
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      class  SimpleAttributeSet
      A straightforward implementation of MutableAttributeSet using a hash table.
      class  StyleContext.NamedStyle
      A collection of attributes, typically used to represent character and paragraph styles.
      class  StyleContext.SmallAttributeSet
      This class holds a small number of attributes in an array.
      Fields in javax.swing.text declared as AttributeSet
      修饰符与类型 | 字段与描述
      protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.copy
      static AttributeSet SimpleAttributeSet.EMPTY
      An empty attribute set.
      protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.newAttributes
      Methods in javax.swing.text that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet StyleContext.addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet StyleContext.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      AttributeSet AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      AttributeSet StyleContext.SmallAttributeSet.copyAttributes()
      Copies a set of attributes.
      AttributeSet StyleContext.NamedStyle.copyAttributes()
      Copies a set of attributes.
      AttributeSet AbstractDocument.AbstractElement.copyAttributes()
      Copies a set of attributes.
      AttributeSet SimpleAttributeSet.copyAttributes()
      Makes a copy of the attributes.
      AttributeSet AttributeSet.copyAttributes()
      Returns an attribute set that is guaranteed not to change over time.
      AttributeSet DefaultStyledDocument.ElementSpec.getAttributes()
      Gets the element attributes.
      AttributeSet AbstractDocument.AbstractElement.getAttributes()
      Gets the attributes for the element.
      AttributeSet Element.getAttributes()
      Fetches the collection of attributes this element contains.
      AttributeSet View.getAttributes()
      Fetches the attributes to use when rendering.
      AttributeSet JTextComponent.AccessibleJTextComponent.getCharacterAttribute(int i)
      Returns the AttributeSet for a given character (at a given index).
      AttributeSet StyleContext.getEmptySet()
      Fetches an empty AttributeSet.
      AttributeSet AbstractDocument.AttributeContext.getEmptySet()
      Fetches an empty AttributeSet.
      AttributeSet StyleContext.SmallAttributeSet.getResolveParent()
      If not overriden, the resolving parent defaults to the parent element.
      AttributeSet StyleContext.NamedStyle.getResolveParent()
      Gets attributes from the parent.
      AttributeSet AbstractDocument.AbstractElement.getResolveParent()
      Gets the resolving parent.
      AttributeSet SimpleAttributeSet.getResolveParent()
      Gets the resolving parent.
      AttributeSet AttributeSet.getResolveParent()
      Gets the resolving parent.
      AttributeSet StyleContext.removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      AttributeSet AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      AttributeSet StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      AttributeSet AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      Methods in javax.swing.text with parameters of type AttributeSet
      修饰符与类型 方法与描述
      AttributeSet StyleContext.addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      void StyleContext.NamedStyle.addAttributes(AttributeSet attr)
      Adds a set of attributes to the element.
      void AbstractDocument.AbstractElement.addAttributes(AttributeSet attr)
      Adds a set of attributes to the element.
      void MutableAttributeSet.addAttributes(AttributeSet attributes)
      Creates a new attribute set similar to this one except that it contains the given attributes and values.
      void SimpleAttributeSet.addAttributes(AttributeSet attributes)
      Adds a set of attributes to the list.
      AttributeSet StyleContext.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      AttributeSet AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      boolean StyleContext.SmallAttributeSet.containsAttributes(AttributeSet attrs)
      Checks whether the attribute set contains all of the given attributes.
      boolean StyleContext.NamedStyle.containsAttributes(AttributeSet attrs)
      Checks whether the element contains all the attributes.
      boolean AbstractDocument.AbstractElement.containsAttributes(AttributeSet attrs)
      Checks whether the element contains all the attributes.
      boolean SimpleAttributeSet.containsAttributes(AttributeSet attributes)
      Checks whether the attribute list contains all the specified name/value pairs.
      boolean AttributeSet.containsAttributes(AttributeSet attributes)
      Returns true if this set defines all the attributes from the given set with equal values.
      protected Element AbstractDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected MutableAttributeSet StyleContext.createLargeAttributeSet(AttributeSet a)
      Create a large set of attributes that should trade off space for time.
      protected Element AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element.
      protected StyleContext.SmallAttributeSet StyleContext.createSmallAttributeSet(AttributeSet a)
      Create a compact set of attributes that might be shared.
      static int StyleConstants.getAlignment(AttributeSet a)
      Gets the alignment setting.
      static Color StyleConstants.getBackground(AttributeSet a)
      Gets the background color setting from the attribute list.
      Color DefaultStyledDocument.getBackground(AttributeSet attr)
      Gets the background color from an attribute set.
      Color StyleContext.getBackground(AttributeSet attr)
      Takes a set of attributes and turn it into a background color specification.
      Color StyledDocument.getBackground(AttributeSet attr)
      Takes a set of attributes and turn it into a background color specification.
      static int StyleConstants.getBidiLevel(AttributeSet a)
      Gets the BidiLevel setting.
      static Component StyleConstants.getComponent(AttributeSet a)
      Gets the component setting from the attribute list.
      static float StyleConstants.getFirstLineIndent(AttributeSet a)
      Gets the first line indent setting.
      Font DefaultStyledDocument.getFont(AttributeSet attr)
      Gets the font from an attribute set.
      Font StyleContext.getFont(AttributeSet attr)
      Gets the font from an attribute set.
      Font StyledDocument.getFont(AttributeSet attr)
      Takes a set of attributes and turn it into a font specification.
      static String StyleConstants.getFontFamily(AttributeSet a)
      Gets the font family setting from the attribute list.
      static int StyleConstants.getFontSize(AttributeSet a)
      Gets the font size setting from the attribute list.
      static Color StyleConstants.getForeground(AttributeSet a)
      Gets the foreground color setting from the attribute list.
      Color DefaultStyledDocument.getForeground(AttributeSet attr)
      Gets the foreground color from an attribute set.
      Color StyleContext.getForeground(AttributeSet attr)
      Takes a set of attributes and turn it into a foreground color specification.
      Color StyledDocument.getForeground(AttributeSet attr)
      Takes a set of attributes and turn it into a foreground color specification.
      static Icon StyleConstants.getIcon(AttributeSet a)
      Gets the icon setting from the attribute list.
      static float StyleConstants.getLeftIndent(AttributeSet a)
      Gets the left indent setting.
      static float StyleConstants.getLineSpacing(AttributeSet a)
      Gets the line spacing setting.
      static float StyleConstants.getRightIndent(AttributeSet a)
      Gets the right indent setting.
      static float StyleConstants.getSpaceAbove(AttributeSet a)
      Gets the space above setting.
      static float StyleConstants.getSpaceBelow(AttributeSet a)
      Gets the space below setting.
      static TabSet StyleConstants.getTabSet(AttributeSet a)
      Gets the TabSet.
      void DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
      Invoked prior to insertion of text into the specified Document.
      void PlainDocument.insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      abstract void DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
      Inserts the specified text, bypassing the DocumentFilter.
      void AbstractDocument.insertString(int offs, String str, AttributeSet a)
      Inserts some content into the document.
      void Document.insertString(int offset, String str, AttributeSet a)
      Inserts a string of content.
      protected void PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected void AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      static boolean StyleConstants.isBold(AttributeSet a)
      Checks whether the bold attribute is set.
      boolean StyleContext.SmallAttributeSet.isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      boolean StyleContext.NamedStyle.isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      boolean AbstractDocument.AbstractElement.isEqual(AttributeSet attr)
      Checks whether two attribute sets are equal.
      boolean SimpleAttributeSet.isEqual(AttributeSet attr)
      Compares two attribute sets.
      boolean AttributeSet.isEqual(AttributeSet attr)
      Determines if the two attribute sets are equivalent.
      static boolean StyleConstants.isItalic(AttributeSet a)
      Checks whether the italic attribute is set.
      static boolean StyleConstants.isStrikeThrough(AttributeSet a)
      Checks whether the strikethrough attribute is set.
      static boolean StyleConstants.isSubscript(AttributeSet a)
      Checks whether the subscript attribute is set.
      static boolean StyleConstants.isSuperscript(AttributeSet a)
      Checks whether the superscript attribute is set.
      static boolean StyleConstants.isUnderline(AttributeSet a)
      Checks whether the underline attribute is set.
      void StyleContext.reclaim(AttributeSet a)
      Returns a set no longer needed by the MutableAttributeSet implmentation.
      void AbstractDocument.AttributeContext.reclaim(AttributeSet a)
      Reclaims an attribute set.
      AttributeSet StyleContext.removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      AttributeSet AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name)
      Removes an attribute from the set.
      void StyleContext.NamedStyle.removeAttributes(AttributeSet attrs)
      Removes a set of attributes for the element.
      void AbstractDocument.AbstractElement.removeAttributes(AttributeSet attrs)
      Removes a set of attributes for the element.
      void MutableAttributeSet.removeAttributes(AttributeSet attributes)
      Removes a set of attributes with the given name.
      void SimpleAttributeSet.removeAttributes(AttributeSet attributes)
      Removes a set of attributes from the list.
      AttributeSet StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes for the element.
      AttributeSet StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      AttributeSet AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      void DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
      Invoked prior to replacing a region of text in the specified Document.
      abstract void DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.
      void AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
      Deletes the region of text from offset to offset + length, and replaces it with text.
      void JTextComponent.AccessibleJTextComponent.setAttributes(int startIndex, int endIndex, AttributeSet as)
      Sets attributes for the text between two indices.
      void DefaultStyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for some part of the document.
      void StyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace)
      Changes the content element attributes used for the given range of existing content in the document.
      protected void StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to character content.
      void DefaultStyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for a paragraph.
      void StyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets paragraph attributes.
      protected void StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace)
      Applies the given attributes to paragraphs.
      protected void CompositeView.setParagraphInsets(AttributeSet attr)
      Sets the insets from the paragraph attributes specified in the given attributes.
      void StyleContext.NamedStyle.setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      void AbstractDocument.AbstractElement.setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      void MutableAttributeSet.setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      void SimpleAttributeSet.setResolveParent(AttributeSet parent)
      Sets the resolving parent.
      protected void AbstractWriter.writeAttributes(AttributeSet attr)
      Writes out the set of attributes as " =" pairs.
      void StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a)
      Context-specific handling of writing out attributes
      static void StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a)
      Writes a set of attributes to the given object stream for the purpose of serialization.
      Constructors in javax.swing.text with parameters of type AttributeSet
      构造方法与描述
      AbstractDocument.AbstractElement(Element parent, AttributeSet a)
      Creates a new AbstractElement.
      AbstractDocument.BranchElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.
      AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).
      DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type)
      Constructor useful for markup when the markup will not be stored in the document.
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type, char[] txt, int offs, int len)
      Constructor for creating a spec externally for batch input of content and markup into the document.
      DefaultStyledDocument.ElementSpec(AttributeSet a, short type, int len)
      Constructor for parsing inside the document when the data has already been added, but len information is needed.
      SimpleAttributeSet(AttributeSet source)
      Creates a new attribute set based on a supplied set of attributes.
      StyleContext.SmallAttributeSet(AttributeSet attrs)

    • Uses of AttributeSet in javax.swing.text.html

      Classes in javax.swing.text.html that implement AttributeSet
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
      Methods in javax.swing.text.html that return AttributeSet
      修饰符与类型 方法与描述
      AttributeSet StyleSheet.addAttribute(AttributeSet old, Object key, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet StyleSheet.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      AttributeSet ImageView.getAttributes()
      Fetches the attributes to use when rendering.
      AttributeSet ParagraphView.getAttributes()
      Fetches the attributes to use when rendering.
      AttributeSet InlineView.getAttributes()
      Fetches the attributes to use when rendering.
      AttributeSet BlockView.getAttributes()
      Fetches the attributes to use when rendering.
      AttributeSet Option.getAttributes()
      Fetch the attributes associated with this option.
      abstract AttributeSet HTMLDocument.Iterator.getAttributes()
      Return the attributes for this tag.
      AttributeSet StyleSheet.getDeclaration(String decl)
      Translates a CSS declaration to an AttributeSet that represents the CSS declaration.
      AttributeSet HTMLDocument.RunElement.getResolveParent()
      Gets the resolving parent.
      AttributeSet HTMLDocument.BlockElement.getResolveParent()
      Gets the resolving parent.
      AttributeSet StyleSheet.getViewAttributes(View v)
      Fetches a set of attributes to use in the view for displaying.
      AttributeSet StyleSheet.removeAttribute(AttributeSet old, Object key)
      Removes an attribute from the set.
      AttributeSet StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes.
      AttributeSet StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      AttributeSet StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet)
      Converts a set of HTML attributes to an equivalent set of CSS attributes.
      Methods in javax.swing.text.html with parameters of type AttributeSet
      修饰符与类型 方法与描述
      AttributeSet StyleSheet.addAttribute(AttributeSet old, Object key, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet StyleSheet.addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      protected void HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet attr)
      Searches the attribute set and for each tag that is stored in the tag vector.
      protected Element HTMLDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected MutableAttributeSet StyleSheet.createLargeAttributeSet(AttributeSet a)
      Creates a large set of attributes that should trade off space for time.
      protected Element HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element that directly represents text (doesn't have any children).
      protected StyleContext.SmallAttributeSet StyleSheet.createSmallAttributeSet(AttributeSet a)
      Creates a compact set of attributes that might be shared.
      Color StyleSheet.getBackground(AttributeSet a)
      Takes a set of attributes and turn it into a background color specification.
      StyleSheet.BoxPainter StyleSheet.getBoxPainter(AttributeSet a)
      Fetches the box formatter to use for the given set of CSS attributes.
      Font StyleSheet.getFont(AttributeSet a)
      Fetches the font to use for the given set of attributes.
      Color StyleSheet.getForeground(AttributeSet a)
      Takes a set of attributes and turn it into a foreground color specification.
      static int HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
      Fetches an integer attribute value.
      StyleSheet.ListPainter StyleSheet.getListPainter(AttributeSet a)
      Fetches the list formatter to use for the given set of CSS attributes.
      protected void HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      protected boolean HTMLWriter.isBlockTag(AttributeSet attr)
      Determines if the HTML.Tag associated with the element is a block tag.
      protected boolean HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag)
      Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
      AttributeSet StyleSheet.removeAttribute(AttributeSet old, Object key)
      Removes an attribute from the set.
      AttributeSet StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes.
      AttributeSet StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      protected void HTMLWriter.selectContent(AttributeSet attr)
      Writes out the content of the SELECT form element.
      void HTMLDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for a paragraph.
      protected void HTMLWriter.textAreaContent(AttributeSet attr)
      Writes out text that is contained in a TEXTAREA form element.
      AttributeSet StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet)
      Converts a set of HTML attributes to an equivalent set of CSS attributes.
      protected void MinimalHTMLWriter.writeAttributes(AttributeSet attr)
      Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants.
      protected void HTMLWriter.writeAttributes(AttributeSet attr)
      Writes out the attribute set.
      protected void HTMLWriter.writeEmbeddedTags(AttributeSet attr)
      Searches for embedded tags in the AttributeSet and writes them out.
      protected void MinimalHTMLWriter.writeHTMLTags(AttributeSet attr)
      Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
      protected void MinimalHTMLWriter.writeNonHTMLAttributes(AttributeSet attr)
      Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way.
      Constructors in javax.swing.text.html with parameters of type AttributeSet
      构造方法与描述
      HTMLDocument.BlockElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.
      HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).
      Option(AttributeSet attr)
      Creates a new Option object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.text.AttributeSet.CharacterAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AttributeSet.CharacterAttribute

  • Packages that use AttributeSet.CharacterAttribute
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AttributeSet.CharacterAttribute in javax.swing.text

      Classes in javax.swing.text that implement AttributeSet.CharacterAttribute
      修饰符与类型 类与描述
      static class  StyleConstants.CharacterConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a character style.
      static class  StyleConstants.ColorConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a color.
      static class  StyleConstants.FontConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a font.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l;e=e >.aea"tstc"ij


Uses of Interface javax.swing.text.AttributeSet.ColorAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AttributeSet.ColorAttribute

  • Packages that use AttributeSet.ColorAttribute
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AttributeSet.ColorAttribute in javax.swing.text

      Classes in javax.swing.text that implement AttributeSet.ColorAttribute
      修饰符与类型 类与描述
      static class  StyleConstants.ColorConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a color.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o pdfi=iwdwtd rritjr!l-i"


Uses of Interface javax.swing.text.AttributeSet.FontAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AttributeSet.FontAttribute

  • Packages that use AttributeSet.FontAttribute
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AttributeSet.FontAttribute in javax.swing.text

      Classes in javax.swing.text that implement AttributeSet.FontAttribute
      修饰符与类型 类与描述
      static class  StyleConstants.FontConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a font.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>b t>y/t>pimmpft wrdpi


Uses of Interface javax.swing.text.AttributeSet.ParagraphAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.AttributeSet.ParagraphAttribute

  • Packages that use AttributeSet.ParagraphAttribute
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of AttributeSet.ParagraphAttribute in javax.swing.text

      Classes in javax.swing.text that implement AttributeSet.ParagraphAttribute
      修饰符与类型 类与描述
      static class  StyleConstants.ParagraphConstants
      This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ste/g/ts/wwwv.hhimmtvmukn


Uses of Interface javax.swing.text.Caret

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Caret

  • Packages that use Caret
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Caret in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Caret
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicCaret
      Methods in javax.swing.plaf.basic that return Caret
      修饰符与类型 方法与描述
      protected Caret BasicTextUI.createCaret()
      Creates the object to use for a caret.

    • Uses of Caret in javax.swing.text

      Classes in javax.swing.text that implement Caret
      修饰符与类型 类与描述
      class  DefaultCaret
      A default implementation of Caret.
      Methods in javax.swing.text that return Caret
      修饰符与类型 方法与描述
      Caret DefaultEditorKit.createCaret()
      Fetches a caret that can navigate through views produced by the associated ViewFactory.
      abstract Caret EditorKit.createCaret()
      Fetches a caret that can navigate through views produced by the associated ViewFactory.
      abstract Caret NavigationFilter.FilterBypass.getCaret()
      Returns the Caret that is changing.
      Caret JTextComponent.getCaret()
      Fetches the caret that allows text-oriented navigation over the view.
      Methods in javax.swing.text with parameters of type Caret
      修饰符与类型 方法与描述
      void JTextComponent.setCaret(Caret c)
      Sets the caret to be used.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i;a cdnastusnx.a�"


Uses of Interface javax.swing.text.Document

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Document

  • Packages that use Document
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.rtf
    Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

    • Uses of Document in javax.swing

      Methods in javax.swing that return Document
      修饰符与类型 方法与描述
      protected Document JTextArea.createDefaultModel()
      Creates the default implementation of the model to be used at construction if one isn't explicitly given.
      protected Document JTextField.createDefaultModel()
      Creates the default implementation of the model to be used at construction if one isn't explicitly given.
      Methods in javax.swing with parameters of type Document
      修饰符与类型 方法与描述
      void JFormattedTextField.setDocument(Document doc)
      Associates the editor with a text document.
      void JTextPane.setDocument(Document doc)
      Associates the editor with a text document.
      void JTextField.setDocument(Document doc)
      Associates the editor with a text document.
      Constructors in javax.swing with parameters of type Document
      构造方法与描述
      JPasswordField(Document doc, String txt, int columns)
      Constructs a new JPasswordField that uses the given text storage model and the given number of columns.
      JTextArea(Document doc)
      Constructs a new JTextArea with the given document model, and defaults for all of the other arguments (null, 0, 0).
      JTextArea(Document doc, String text, int rows, int columns)
      Constructs a new JTextArea with the specified number of rows and columns, and the given model.
      JTextField(Document doc, String text, int columns)
      Constructs a new JTextField that uses the given text storage model and the given number of columns.

    • Uses of Document in javax.swing.event

      Methods in javax.swing.event that return Document
      修饰符与类型 方法与描述
      Document DocumentEvent.getDocument()
      Gets the document that sourced the change event.

    • Uses of Document in javax.swing.text

      Subinterfaces of Document in javax.swing.text
      修饰符与类型 Interface and Description
      interface  StyledDocument
      Interface for a generic styled document.
      Classes in javax.swing.text that implement Document
      修饰符与类型 类与描述
      class  AbstractDocument
      An implementation of the document interface to serve as a basis for implementing various kinds of documents.
      class  DefaultStyledDocument
      A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
      class  PlainDocument
      A plain document that maintains no character attributes.
      Methods in javax.swing.text that return Document
      修饰符与类型 方法与描述
      Document StyledEditorKit.createDefaultDocument()
      Creates an uninitialized text storage model that is appropriate for this type of editor.
      Document DefaultEditorKit.createDefaultDocument()
      Creates an uninitialized text storage model (PlainDocument) that is appropriate for this type of editor.
      abstract Document EditorKit.createDefaultDocument()
      Creates an uninitialized text storage model that is appropriate for this type of editor.
      protected Document AbstractWriter.getDocument()
      Fetches the document.
      abstract Document DocumentFilter.FilterBypass.getDocument()
      Returns the Document the mutation is occuring on.
      Document AbstractDocument.AbstractElement.getDocument()
      Retrieves the underlying model.
      Document AbstractDocument.DefaultDocumentEvent.getDocument()
      Gets the document that sourced the change event.
      Document Element.getDocument()
      Fetches the document associated with this element.
      Document View.getDocument()
      Fetches the model associated with the view.
      Document JTextComponent.getDocument()
      Fetches the model associated with the editor.
      Methods in javax.swing.text with parameters of type Document
      修饰符与类型 方法与描述
      void DefaultEditorKit.read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      abstract void EditorKit.read(InputStream in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void DefaultEditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream, which will be treated as plain text.
      abstract void EditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void JTextComponent.setDocument(Document doc)
      Associates the editor with a text document.
      void DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      abstract void EditorKit.write(OutputStream out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      void DefaultEditorKit.write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream as plain text.
      abstract void EditorKit.write(Writer out, Document doc, int pos, int len)
      Writes content from a document to the given stream in a format appropriate for this kind of content handler.
      Constructors in javax.swing.text with parameters of type Document
      构造方法与描述
      AbstractWriter(Writer w, Document doc)
      Creates a new AbstractWriter.
      AbstractWriter(Writer w, Document doc, int pos, int len)
      Creates a new AbstractWriter.
      ElementIterator(Document document)
      Creates a new ElementIterator.

    • Uses of Document in javax.swing.text.html

      Classes in javax.swing.text.html that implement Document
      修饰符与类型 类与描述
      class  HTMLDocument
      A document that models HTML.
      Methods in javax.swing.text.html that return Document
      修饰符与类型 方法与描述
      Document HTMLEditorKit.createDefaultDocument()
      Create an uninitialized text storage model that is appropriate for this type of editor.
      Methods in javax.swing.text.html with parameters of type Document
      修饰符与类型 方法与描述
      void HTMLEditorKit.read(Reader in, Document doc, int pos)
      Inserts content from the given stream.
      void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.

    • Uses of Document in javax.swing.text.rtf

      Methods in javax.swing.text.rtf with parameters of type Document
      修饰符与类型 方法与描述
      void RTFEditorKit.read(InputStream in, Document doc, int pos)
      Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void RTFEditorKit.read(Reader in, Document doc, int pos)
      Insert content from the given stream, which will be treated as plain text.
      void RTFEditorKit.write(OutputStream out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.
      void RTFEditorKit.write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream as plain text.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.text.Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Element

  • Packages that use Element
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Element in javax.swing

      Constructors in javax.swing with parameters of type Element
      构造方法与描述
      JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)

    • Uses of Element in javax.swing.event

      Methods in javax.swing.event that return Element
      修饰符与类型 方法与描述
      Element[] DocumentEvent.ElementChange.getChildrenAdded()
      Gets the child elements that were added to the given parent element.
      Element[] DocumentEvent.ElementChange.getChildrenRemoved()
      Gets the child elements that were removed from the given parent element.
      Element DocumentEvent.ElementChange.getElement()
      Returns the element represented.
      Element HyperlinkEvent.getSourceElement()
      Returns the Element that corresponds to the source of the event.
      Methods in javax.swing.event with parameters of type Element
      修饰符与类型 方法与描述
      DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
      Gets the change information for the given element.
      Constructors in javax.swing.event with parameters of type Element
      构造方法与描述
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
      Creates a new object representing a hypertext link event.
      HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement, InputEvent inputEvent)
      Creates a new object representing a hypertext link event.

    • Uses of Element in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic with parameters of type Element
      修饰符与类型 方法与描述
      View BasicPasswordFieldUI.create(Element elem)
      Creates a view (PasswordView) for an element.
      View BasicTextAreaUI.create(Element elem)
      Creates the view for an element.
      View BasicTextFieldUI.create(Element elem)
      Creates a view (FieldView) based on an element.
      View BasicTextUI.create(Element elem)
      Creates a view for an element.
      View BasicTextUI.create(Element elem, int p0, int p1)
      Creates a view for an element.

    • Uses of Element in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type Element
      修饰符与类型 方法与描述
      View SynthPasswordFieldUI.create(Element elem)
      Creates a view (PasswordView) for an element.

    • Uses of Element in javax.swing.text

      Classes in javax.swing.text that implement Element
      修饰符与类型 类与描述
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      Fields in javax.swing.text declared as Element
      修饰符与类型 | 字段与描述
      protected Element | DefaultStyledDocument.AttributeUndoableEdit.element
      Methods in javax.swing.text that return Element
      修饰符与类型 方法与描述
      Element DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee)
      Creates a copy of this element, with a different parent.
      protected Element AbstractDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected Element AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element.
      Element ElementIterator.current()
      Fetches the current Element.
      Element ElementIterator.first()
      Fetches the first element.
      Element AbstractDocument.getBidiRootElement()
      Returns the root element of the bidirectional structure for this document.
      Element StyledEditorKit.getCharacterAttributeRun()
      Fetches the element representing the current run of character attributes for the caret.
      Element DefaultStyledDocument.getCharacterElement(int pos)
      Gets a character element based on a position.
      Element StyledDocument.getCharacterElement(int pos)
      Gets the element that represents the character that is at the given offset within the document.
      Element[] AbstractDocument.ElementEdit.getChildrenAdded()
      Gets a list of children that were added.
      Element[] AbstractDocument.ElementEdit.getChildrenRemoved()
      Gets a list of children that were removed.
      Element PlainDocument.getDefaultRootElement()
      Gets the default root element for the document model.
      Element DefaultStyledDocument.getDefaultRootElement()
      Gets the default root element.
      abstract Element AbstractDocument.getDefaultRootElement()
      Returns the root element that views should be based upon unless some other mechanism for assigning views to element structures is provided.
      Element Document.getDefaultRootElement()
      Returns the root element that views should be based upon, unless some other mechanism for assigning views to element structures is provided.
      Element AbstractDocument.ElementEdit.getElement()
      Returns the underlying element.
      Element View.getElement()
      Fetches the structural portion of the subject that this view is mapped to.
      abstract Element AbstractDocument.AbstractElement.getElement(int index)
      Gets a child element.
      Element AbstractDocument.BranchElement.getElement(int index)
      Gets a child element.
      Element AbstractDocument.LeafElement.getElement(int index)
      Gets a child element.
      Element Element.getElement(int index)
      Fetches the child element at the given index.
      Element PlainDocument.getParagraphElement(int pos)
      Get the paragraph element containing the given position.
      Element DefaultStyledDocument.getParagraphElement(int pos)
      Gets the paragraph element at the offset pos.
      abstract Element AbstractDocument.getParagraphElement(int pos)
      Get the paragraph element containing the given position.
      Element StyledDocument.getParagraphElement(int pos)
      Gets the element that represents the paragraph that encloses the given offset within the document.
      static Element Utilities.getParagraphElement(JTextComponent c, int offs)
      Determines the element to use for a paragraph/line.
      Element AbstractDocument.AbstractElement.getParentElement()
      Gets the parent of the element.
      Element Element.getParentElement()
      Fetches the parent element.
      Element DefaultStyledDocument.ElementBuffer.getRootElement()
      Gets the root element.
      Element[] AbstractDocument.getRootElements()
      Gets all root elements defined.
      Element[] Document.getRootElements()
      Returns all of the root elements that are defined.
      Element ElementIterator.下一个()
      Fetches the next Element.
      Element AbstractDocument.BranchElement.positionToElement(int pos)
      Gets the child element that contains the given model position.
      Element ElementIterator.previous()
      Fetches the previous Element.
      Methods in javax.swing.text with parameters of type Element
      修饰符与类型 方法与描述
      Element DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee)
      Creates a copy of this element, with a different parent.
      View ViewFactory.create(Element elem)
      Creates a view from the given structural element of a document.
      protected Element AbstractDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected void StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      protected Element AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element.
      protected TableView.TableCell TableView.createTableCell(Element elem)
      Deprecated.
      Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
      protected TableView.TableRow TableView.createTableRow(Element elem)
      Creates a new table row.
      DocumentEvent.ElementChange AbstractDocument.DefaultDocumentEvent.getChange(Element elem)
      Gets the changes for an element.
      protected String AbstractWriter.getText(Element elem)
      Returns the text associated with the element.
      protected boolean AbstractWriter.inRange(Element next)
      This method determines whether the current element is in the range specified.
      void DefaultStyledDocument.removeElement(Element elem)
      Removes an element from this document.
      void AbstractDocument.BranchElement.replace(int offset, int length, Element[] elems)
      Replaces content with a new set of elements.
      protected void AbstractWriter.text(Element elem)
      Writes out text.
      Constructors in javax.swing.text with parameters of type Element
      构造方法与描述
      AbstractDocument.AbstractElement(Element parent, AttributeSet a)
      Creates a new AbstractElement.
      AbstractDocument.BranchElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.
      AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
      Constructs an edit record.
      AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
      Constructs an edit record.
      AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
      Constructs an edit record.
      AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).
      AbstractWriter(Writer w, Element root)
      Creates a new AbstractWriter.
      AbstractWriter(Writer w, Element root, int pos, int len)
      Creates a new AbstractWriter.
      AsyncBoxView(Element elem, int axis)
      Construct a box view that does asynchronous layout.
      BoxView(Element elem, int axis)
      Constructs a BoxView.
      ComponentView(Element elem)
      Creates a new ComponentView object.
      CompositeView(Element elem)
      Constructs a CompositeView for the given element.
      DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
      DefaultStyledDocument.ElementBuffer(Element root)
      Creates a new ElementBuffer.
      ElementIterator(Element root)
      Creates a new ElementIterator.
      FieldView(Element elem)
      Constructs a new FieldView wrapped on an element.
      FlowView(Element elem, int axis)
      Constructs a FlowView for the given element.
      GlyphView(Element elem)
      Constructs a new view wrapped on an element.
      IconView(Element elem)
      Creates a new icon view that represents an element.
      LabelView(Element elem)
      Constructs a new view wrapped on an element.
      ParagraphView(Element elem)
      Constructs a ParagraphView for the given element.
      PasswordView(Element elem)
      Constructs a new view wrapped on an element.
      PlainView(Element elem)
      Constructs a new PlainView wrapped on an element.
      TableView.TableCell(Element elem)
      Deprecated.
      Constructs a TableCell for the given element.
      TableView.TableRow(Element elem)
      Constructs a TableView for the given element.
      TableView(Element elem)
      Constructs a TableView for the given element.
      View(Element elem)
      Creates a new View object.
      WrappedPlainView(Element elem)
      Creates a new WrappedPlainView.
      WrappedPlainView(Element elem, boolean wordWrap)
      Creates a new WrappedPlainView.
      ZoneView(Element elem, int axis)
      Constructs a ZoneView.

    • Uses of Element in javax.swing.text.html

      Classes in javax.swing.text.html that implement Element
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
      Methods in javax.swing.text.html that return Element
      修饰符与类型 方法与描述
      protected Element HTMLDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected Element HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element that directly represents text (doesn't have any children).
      protected Element HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      Element HTMLDocument.getElement(Element e, Object attribute, Object value)
      Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found.
      Element HTMLDocument.getElement(String id)
      Returns the element that has the given id Attribute.
      protected Element[] HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset)
      Returns an array of the Elements that contain offset.
      Methods in javax.swing.text.html with parameters of type Element
      修饰符与类型 方法与描述
      protected void HTMLWriter.comment(Element elem)
      Writes out comments.
      View HTMLEditorKit.HTMLFactory.create(Element elem)
      Creates a view from an element.
      protected Element HTMLDocument.createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected void HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      protected Element HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element that directly represents text (doesn't have any children).
      protected void HTMLWriter.emptyTag(Element elem)
      Writes out all empty elements (all tags that have no corresponding end tag).
      protected void HTMLWriter.endTag(Element elem)
      Writes out an end tag for the element.
      Element HTMLDocument.getElement(Element e, Object attribute, Object value)
      Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found.
      Style StyleSheet.getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      void HTMLDocument.insertAfterEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string after the the end of the given element.
      void HTMLDocument.insertAfterStart(Element elem, String htmlText)
      Inserts the HTML specified as a string at the start of the element.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      void HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string at the end of the element.
      void HTMLDocument.insertBeforeStart(Element elem, String htmlText)
      Inserts the HTML specified as a string before the start of the given element.
      protected boolean MinimalHTMLWriter.isText(Element elem)
      Returns true if the element is a text element.
      void HTMLDocument.setInnerHTML(Element elem, String htmlText)
      Replaces the children of the given element with the contents specified as an HTML string.
      void HTMLDocument.setOuterHTML(Element elem, String htmlText)
      Replaces the given element in the parent with the contents specified as an HTML string.
      protected void HTMLWriter.startTag(Element elem)
      Writes out a start tag for the element.
      protected boolean HTMLWriter.synthesizedElement(Element elem)
      Returns true if the element is a synthesized element.
      protected void MinimalHTMLWriter.text(Element elem)
      Writes out text.
      protected void HTMLWriter.text(Element elem)
      Writes out text.
      protected void MinimalHTMLWriter.writeComponent(Element elem)
      Responsible for handling Component Elements; deliberately unimplemented.
      protected void MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting)
      Writes out the attribute set in an HTML-compliant manner.
      protected void MinimalHTMLWriter.writeImage(Element elem)
      Responsible for handling Icon Elements; deliberately unimplemented.
      protected void MinimalHTMLWriter.writeLeaf(Element elem)
      Responsible for writing out other non-text leaf elements.
      protected void MinimalHTMLWriter.writeStartParagraph(Element elem)
      Emits the start tag for a paragraph.
      Constructors in javax.swing.text.html with parameters of type Element
      构造方法与描述
      BlockView(Element elem, int axis)
      Creates a new view that represents an html box.
      FormView(Element elem)
      Creates a new FormView object.
      HTMLDocument.BlockElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.
      HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      ImageView(Element elem)
      Creates a new view that represents an IMG element.
      InlineView(Element elem)
      Constructs a new view wrapped on an element.
      ListView(Element elem)
      Creates a new view that represents a list element.
      ObjectView(Element elem)
      Creates a new ObjectView object.
      ParagraphView(Element elem)
      Constructs a ParagraphView for the given element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.text.Highlighter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Highlighter

  • Packages that use Highlighter
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Highlighter in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement Highlighter
      修饰符与类型 | 类与描述
      static class  | BasicTextUI.BasicHighlighter
      Methods in javax.swing.plaf.basic that return Highlighter
      修饰符与类型 方法与描述
      protected Highlighter BasicTextUI.createHighlighter()
      Creates the object to use for adding highlights.

    • Uses of Highlighter in javax.swing.text

      Classes in javax.swing.text that implement Highlighter
      修饰符与类型 | 类与描述
      class  DefaultHighlighter
      Implements the Highlighter interfaces.
      class  | LayeredHighlighter
      Methods in javax.swing.text that return Highlighter
      修饰符与类型 方法与描述
      Highlighter JTextComponent.getHighlighter()
      Fetches the object responsible for making highlights.
      Methods in javax.swing.text with parameters of type Highlighter
      修饰符与类型 方法与描述
      void JTextComponent.setHighlighter(Highlighter h)
      Sets the highlighter to be used.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ctot


Uses of Interface javax.swing.text.Highlighter.Highlight

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Highlighter.Highlight

  • Packages that use Highlighter.Highlight
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Highlighter.Highlight in javax.swing.text

      Methods in javax.swing.text that return Highlighter.Highlight
      修饰符与类型 方法与描述
      Highlighter.Highlight[] DefaultHighlighter.getHighlights()
      Makes a copy of the highlights.
      Highlighter.Highlight[] Highlighter.getHighlights()
      Fetches the current list of highlights.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r era>>i,ittawj)


Uses of Interface javax.swing.text.Highlighter.HighlightPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Highlighter.HighlightPainter

  • Packages that use Highlighter.HighlightPainter
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Highlighter.HighlightPainter in javax.swing.text

      Classes in javax.swing.text that implement Highlighter.HighlightPainter
      修饰符与类型 类与描述
      static class  DefaultHighlighter.DefaultHighlightPainter
      Simple highlight painter that fills a highlighted area with a solid color.
      static class  LayeredHighlighter.LayerPainter
      Layered highlight renderer.
      Methods in javax.swing.text that return Highlighter.HighlightPainter
      修饰符与类型 方法与描述
      Highlighter.HighlightPainter Highlighter.Highlight.getPainter()
      Gets the painter for the highlighter.
      protected Highlighter.HighlightPainter DefaultCaret.getSelectionPainter()
      Gets the painter for the Highlighter.
      Methods in javax.swing.text with parameters of type Highlighter.HighlightPainter
      修饰符与类型 方法与描述
      Object DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
      Object Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
      Adds a highlight to the view.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ai.pah.viaaa,ls/./>enrr7h


Uses of Interface javax.swing.text.Keymap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Keymap

  • Packages that use Keymap
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Keymap in javax.swing.plaf.basic

      Methods in javax.swing.plaf.basic that return Keymap
      修饰符与类型 方法与描述
      protected Keymap BasicTextUI.createKeymap()
      Creates the keymap to use for the text component, and installs any necessary bindings into it.

    • Uses of Keymap in javax.swing.text

      Methods in javax.swing.text that return Keymap
      修饰符与类型 方法与描述
      static Keymap JTextComponent.addKeymap(String nm, Keymap parent)
      Adds a new keymap into the keymap hierarchy.
      Keymap JTextComponent.getKeymap()
      Fetches the keymap currently active in this text component.
      static Keymap JTextComponent.getKeymap(String nm)
      Fetches a named keymap previously added to the document.
      Keymap Keymap.getResolveParent()
      Fetches the parent keymap used to resolve key-bindings.
      static Keymap JTextComponent.removeKeymap(String nm)
      Removes a named keymap previously added to the document.
      Methods in javax.swing.text with parameters of type Keymap
      修饰符与类型 方法与描述
      static Keymap JTextComponent.addKeymap(String nm, Keymap parent)
      Adds a new keymap into the keymap hierarchy.
      static void JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
      Loads a keymap with a bunch of bindings.
      void JTextComponent.setKeymap(Keymap map)
      Sets the keymap to use for binding events to actions.
      void Keymap.setResolveParent(Keymap parent)
      Sets the parent keymap, which will be used to resolve key-bindings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yo " t .gtaaa, >c>"l


Uses of Interface javax.swing.text.MutableAttributeSet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.MutableAttributeSet

  • Packages that use MutableAttributeSet
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of MutableAttributeSet in javax.swing

      Methods in javax.swing that return MutableAttributeSet
      修饰符与类型 方法与描述
      MutableAttributeSet JTextPane.getInputAttributes()
      Gets the input attributes for the pane.

    • Uses of MutableAttributeSet in javax.swing.text

      Subinterfaces of MutableAttributeSet in javax.swing.text
      修饰符与类型 Interface and Description
      interface  Style
      A collection of attributes to associate with an element in a document.
      Classes in javax.swing.text that implement MutableAttributeSet
      修饰符与类型 类与描述
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      class  SimpleAttributeSet
      A straightforward implementation of MutableAttributeSet using a hash table.
      class  StyleContext.NamedStyle
      A collection of attributes, typically used to represent character and paragraph styles.
      Methods in javax.swing.text that return MutableAttributeSet
      修饰符与类型 方法与描述
      protected MutableAttributeSet StyleContext.createLargeAttributeSet(AttributeSet a)
      Create a large set of attributes that should trade off space for time.
      MutableAttributeSet StyledEditorKit.getInputAttributes()
      Gets the input attributes for the pane.
      Methods in javax.swing.text with parameters of type MutableAttributeSet
      修饰符与类型 方法与描述
      protected void StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      void StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a)
      Context-specific handling of reading in attributes
      static void StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a)
      Reads a set of attributes from the given object input stream that have been previously written out with writeAttributeSet.
      static void StyleConstants.setAlignment(MutableAttributeSet a, int align)
      Sets alignment.
      static void StyleConstants.setBackground(MutableAttributeSet a, Color fg)
      Sets the background color.
      static void StyleConstants.setBidiLevel(MutableAttributeSet a, int o)
      Sets the BidiLevel.
      static void StyleConstants.setBold(MutableAttributeSet a, boolean b)
      Sets the bold attribute.
      static void StyleConstants.setComponent(MutableAttributeSet a, Component c)
      Sets the component attribute.
      static void StyleConstants.setFirstLineIndent(MutableAttributeSet a, float i)
      Sets the first line indent.
      static void StyleConstants.setFontFamily(MutableAttributeSet a, String fam)
      Sets the font attribute.
      static void StyleConstants.setFontSize(MutableAttributeSet a, int s)
      Sets the font size attribute.
      static void StyleConstants.setForeground(MutableAttributeSet a, Color fg)
      Sets the foreground color.
      static void StyleConstants.setIcon(MutableAttributeSet a, Icon c)
      Sets the icon attribute.
      static void StyleConstants.setItalic(MutableAttributeSet a, boolean b)
      Sets the italic attribute.
      static void StyleConstants.setLeftIndent(MutableAttributeSet a, float i)
      Sets left indent.
      static void StyleConstants.setLineSpacing(MutableAttributeSet a, float i)
      Sets line spacing.
      static void StyleConstants.setRightIndent(MutableAttributeSet a, float i)
      Sets right indent.
      static void StyleConstants.setSpaceAbove(MutableAttributeSet a, float i)
      Sets space above.
      static void StyleConstants.setSpaceBelow(MutableAttributeSet a, float i)
      Sets space below.
      static void StyleConstants.setStrikeThrough(MutableAttributeSet a, boolean b)
      Sets the strikethrough attribute.
      static void StyleConstants.setSubscript(MutableAttributeSet a, boolean b)
      Sets the subscript attribute.
      static void StyleConstants.setSuperscript(MutableAttributeSet a, boolean b)
      Sets the superscript attribute.
      static void StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs)
      Sets the TabSet.
      static void StyleConstants.setUnderline(MutableAttributeSet a, boolean b)
      Sets the underline attribute.

    • Uses of MutableAttributeSet in javax.swing.text.html

      Classes in javax.swing.text.html that implement MutableAttributeSet
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
      Fields in javax.swing.text.html declared as MutableAttributeSet
      修饰符与类型 | 字段与描述
      protected MutableAttributeSet | HTMLDocument.HTMLReader.charAttr
      Methods in javax.swing.text.html that return MutableAttributeSet
      修饰符与类型 方法与描述
      protected MutableAttributeSet StyleSheet.createLargeAttributeSet(AttributeSet a)
      Creates a large set of attributes that should trade off space for time.
      MutableAttributeSet HTMLEditorKit.getInputAttributes()
      Gets the input attributes used for the styled editing actions.
      Methods in javax.swing.text.html with parameters of type MutableAttributeSet
      修饰符与类型 | 方法与描述
      void StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      boolean StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      protected void HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a)
      Adds content that is basically specified entirely in the attribute set.
      protected void HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr)
      Adds an instruction to the parse buffer to create a block element with the given attributes.
      protected void HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.
      void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.text.Position

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Position

  • Packages that use Position
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of Position in javax.swing.text

      Methods in javax.swing.text that return Position
      修饰符与类型 方法与描述
      Position StringContent.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position GapContent.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position AbstractDocument.createPosition(int offs)
      Returns a position that will track change as the document is altered.
      Position AbstractDocument.Content.createPosition(int offset)
      Creates a position within the content that will track change as the content is mutated.
      Position Document.createPosition(int offs)
      This method allows an application to mark a place in a sequence of character content.
      Position AbstractDocument.getEndPosition()
      Returns a position that represents the end of the document.
      Position Document.getEndPosition()
      Returns a position that represents the end of the document.
      Position AbstractDocument.getStartPosition()
      Returns a position that represents the start of the document.
      Position Document.getStartPosition()
      Returns a position that represents the start of the document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ogdgRecwatttvs""i a>>ctdt


Uses of Interface javax.swing.text.Style

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.Style

  • Packages that use Style
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Style in javax.swing

      Methods in javax.swing that return Style
      修饰符与类型 方法与描述
      Style JTextPane.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      Style JTextPane.getLogicalStyle()
      Fetches the logical style assigned to the paragraph represented by the current position of the caret, or null.
      Style JTextPane.getStyle(String nm)
      Fetches a named non-null style previously added.
      Methods in javax.swing with parameters of type Style
      修饰符与类型 方法与描述
      Style JTextPane.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      void JTextPane.setLogicalStyle(Style s)
      Sets the logical style to use for the paragraph at the current caret position.

    • Uses of Style in javax.swing.text

      Classes in javax.swing.text that implement Style
      修饰符与类型 类与描述
      class  StyleContext.NamedStyle
      A collection of attributes, typically used to represent character and paragraph styles.
      Methods in javax.swing.text that return Style
      修饰符与类型 方法与描述
      Style DefaultStyledDocument.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      Style StyleContext.addStyle(String nm, Style parent)
      Adds a new style into the style hierarchy.
      Style StyledDocument.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      Style DefaultStyledDocument.getLogicalStyle(int p)
      Fetches the logical style assigned to the paragraph represented by the given position.
      Style StyledDocument.getLogicalStyle(int p)
      Gets a logical style for a given position in a paragraph.
      Style DefaultStyledDocument.getStyle(String nm)
      Fetches a named style previously added.
      Style StyleContext.getStyle(String nm)
      Fetches a named style previously added to the document
      Style StyledDocument.getStyle(String nm)
      Fetches a named style previously added.
      Methods in javax.swing.text with parameters of type Style
      修饰符与类型 方法与描述
      Style DefaultStyledDocument.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      Style StyleContext.addStyle(String nm, Style parent)
      Adds a new style into the style hierarchy.
      Style StyledDocument.addStyle(String nm, Style parent)
      Adds a new style into the logical style hierarchy.
      void DefaultStyledDocument.setLogicalStyle(int pos, Style s)
      Sets the logical style to use for the paragraph at the given position.
      void StyledDocument.setLogicalStyle(int pos, Style s)
      Sets the logical style to use for the paragraph at the given position.
      protected void DefaultStyledDocument.styleChanged(Style style)
      Called when any of this document's styles have changed.
      Constructors in javax.swing.text with parameters of type Style
      构造方法与描述
      StyleContext.NamedStyle(String name, Style parent)
      Creates a new named style.
      StyleContext.NamedStyle(Style parent)
      Creates a new named style.

    • Uses of Style in javax.swing.text.html

      Methods in javax.swing.text.html that return Style
      修饰符与类型 方法与描述
      Style StyleSheet.getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      Style StyleSheet.getRule(String selector)
      Fetches the rule that best matches the selector given in string form.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rn�=d


Uses of Interface javax.swing.text.StyledDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.StyledDocument

  • Packages that use StyledDocument
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyledDocument in javax.swing

      Methods in javax.swing that return StyledDocument
      修饰符与类型 方法与描述
      StyledDocument JTextPane.getStyledDocument()
      Fetches the model associated with the editor.
      Methods in javax.swing with parameters of type StyledDocument
      修饰符与类型 方法与描述
      void JTextPane.setStyledDocument(StyledDocument doc)
      Associates the editor with a text document.
      Constructors in javax.swing with parameters of type StyledDocument
      构造方法与描述
      JTextPane(StyledDocument doc)
      Creates a new JTextPane, with a specified document model.

    • Uses of StyledDocument in javax.swing.text

      Classes in javax.swing.text that implement StyledDocument
      修饰符与类型 类与描述
      class  DefaultStyledDocument
      A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
      Methods in javax.swing.text that return StyledDocument
      修饰符与类型 方法与描述
      protected StyledDocument StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e)
      Gets the document associated with an editor pane.

    • Uses of StyledDocument in javax.swing.text.html

      Classes in javax.swing.text.html that implement StyledDocument
      修饰符与类型 类与描述
      class  HTMLDocument
      A document that models HTML.
      Constructors in javax.swing.text.html with parameters of type StyledDocument
      构造方法与描述
      MinimalHTMLWriter(Writer w, StyledDocument doc)
      Creates a new MinimalHTMLWriter.
      MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
      Creates a new MinimalHTMLWriter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Leo<


Uses of Interface javax.swing.text.TabableView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.TabableView

  • Packages that use TabableView
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of TabableView in javax.swing.text

      Classes in javax.swing.text that implement TabableView
      修饰符与类型 类与描述
      class  GlyphView
      A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.
      class  LabelView
      A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.

    • Uses of TabableView in javax.swing.text.html

      Classes in javax.swing.text.html that implement TabableView
      修饰符与类型 类与描述
      class  InlineView
      Displays the inline element styles based upon css attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&rLso"oMnsdeoatnit.


Uses of Interface javax.swing.text.TabExpander

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.TabExpander

  • Packages that use TabExpander
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.

    • Uses of TabExpander in javax.swing.text

      Classes in javax.swing.text that implement TabExpander
      修饰符与类型 类与描述
      class  FieldView
      Extends the multi-line plain text view to be suitable for a single-line editor view.
      class  ParagraphView
      View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
      class  PasswordView
      Implements a View suitable for use in JPasswordField UI implementations.
      class  PlainView
      Implements View interface for a simple multi-line text view that has text in one font and color.
      class  WrappedPlainView
      View of plain text (text with only one font and color) that does line-wrapping.
      Methods in javax.swing.text that return TabExpander
      修饰符与类型 方法与描述
      TabExpander GlyphView.getTabExpander()
      Fetch the TabExpander to use if tabs are present in this view.
      Methods in javax.swing.text with parameters of type TabExpander
      修饰符与类型 | 方法与描述
      static int Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
      Draws the given text, expanding any tabs that are contained using the given tab expansion technique.
      static int Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determine where to break the given text to fit within the given span.
      abstract float GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x)
      Determine the span the glyphs given a start location (for tab expansion).
      float TabableView.getTabbedSpan(float x, TabExpander e)
      Determines the desired span when using the given tab expansion implementation.
      float GlyphView.getTabbedSpan(float x, TabExpander e)
      Determines the desired span when using the given tab expansion implementation.
      static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
      Determines the relative offset into the given text that best represents the given span in the view coordinate system.
      static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
      static int Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
      Determines the width of the given segment of text taking tabs into consideration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

An;9.e>/nasdax


Uses of Interface javax.swing.text.ViewFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.ViewFactory

  • Packages that use ViewFactory
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of ViewFactory in javax.swing.plaf.basic

      Classes in javax.swing.plaf.basic that implement ViewFactory
      修饰符与类型 类与描述
      class  BasicEditorPaneUI
      Provides the look and feel for a JEditorPane.
      class  BasicFormattedTextFieldUI
      Provides the look and feel implementation for JFormattedTextField.
      class  BasicPasswordFieldUI
      Provides the Windows look and feel for a password field.
      class  BasicTextAreaUI
      Provides the look and feel for a plain text editor.
      class  BasicTextFieldUI
      Basis of a look and feel for a JTextField.
      class  BasicTextPaneUI
      Provides the look and feel for a styled text editor.
      class  BasicTextUI
      Basis of a text components look-and-feel.

    • Uses of ViewFactory in javax.swing.plaf.metal

      Classes in javax.swing.plaf.metal that implement ViewFactory
      修饰符与类型 类与描述
      class  MetalTextFieldUI
      Basis of a look and feel for a JTextField.

    • Uses of ViewFactory in javax.swing.plaf.synth

      Classes in javax.swing.plaf.synth that implement ViewFactory
      修饰符与类型 类与描述
      class  SynthEditorPaneUI
      Provides the Synth L&F UI delegate for JEditorPane.
      class  SynthFormattedTextFieldUI
      Provides the Synth L&F UI delegate for JFormattedTextField.
      class  SynthPasswordFieldUI
      Provides the Synth L&F UI delegate for JPasswordField.
      class  SynthTextAreaUI
      Provides the look and feel for a plain text editor in the Synth look and feel.
      class  SynthTextFieldUI
      Provides the Synth L&F UI delegate for JTextField.
      class  SynthTextPaneUI
      Provides the look and feel for a styled text editor in the Synth look and feel.

    • Uses of ViewFactory in javax.swing.text

      Classes in javax.swing.text that implement ViewFactory
      修饰符与类型 类与描述
      class  DefaultTextUI
      Deprecated.
      Methods in javax.swing.text that return ViewFactory
      修饰符与类型 方法与描述
      ViewFactory StyledEditorKit.getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      ViewFactory DefaultEditorKit.getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      ViewFactory View.getViewFactory()
      Fetches the ViewFactory implementation that is feeding the view hierarchy.
      abstract ViewFactory EditorKit.getViewFactory()
      Fetches a factory that is suitable for producing views of any models that are produced by this kit.
      Methods in javax.swing.text with parameters of type ViewFactory
      修饰符与类型 | 方法与描述
      void PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      protected void BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
      protected void View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f)
      Forwards the DocumentEvent to the give child view.
      void ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      protected void ZoneView.loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      protected void AsyncBoxView.loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      protected void WrappedPlainView.loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      protected void CompositeView.loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      protected void FlowView.loadChildren(ViewFactory f)
      Loads all of the children to initialize the view.
      void ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      void View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      protected boolean ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element.
      protected boolean View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f)
      Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for.
      protected void PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f)
      Repaint the region of change covered by the given document event.

    • Uses of ViewFactory in javax.swing.text.html

      Classes in javax.swing.text.html that implement ViewFactory
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLFactory
      A factory to build views for HTML.
      Methods in javax.swing.text.html that return ViewFactory
      修饰符与类型 方法与描述
      ViewFactory HTMLEditorKit.getViewFactory()
      Fetch a factory that is suitable for producing views of any models that are produced by this kit.
      Methods in javax.swing.text.html with parameters of type ViewFactory
      修饰符与类型 | 方法与描述
      void ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Invoked when the Elements attributes have changed.
      void InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      void InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a. /a>iVeeetwssn ihtcn t


BlockView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 BlockView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
  • 所有已实现的接口：
    SwingConstants
    直接已知子类：
    ListView

    public class BlockView
extends BoxView
    A view implementation to display a block (as a box) with CSS specifications.

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      BlockView(Element elem, int axis)
      Creates a new view that represents an html box.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected SizeRequirements calculateMajorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the major axis (i.e.
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the requirements of the block along the minor axis (i.e.
      void changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      float getAlignment(int axis)
      Gets the alignment.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      int getResizeWeight(int axis)
      Gets the resize weight.
      protected StyleSheet | getStyleSheet()
      protected void layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans)
      Performs layout for the minor axis of the box (i.e.
      void paint(Graphics g, Shape allocation)
      Renders using the given rendering surface and area on that surface.
      void setParent(View parent)
      Establishes the parent view for this view.
      protected void setPropertiesFromAttributes()
      Update any cached values that come from attributes.

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BlockView

        public BlockView(Element elem,
         int axis)
        Creates a new view that represents an html box. This can be used for a number of elements.
        参数：
        elem - the element to create a view for
        axis - either View.X_AXIS or View.Y_AXIS

    • 方法详细信息

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. This is guaranteed to be called before any other methods if the parent view is functioning properly.

        This is implemented to forward to the superclass as well as call the setPropertiesFromAttributes() method to set the paragraph properties from the css attributes. The call is made at this time to ensure the ability to resolve upward through the parents view attributes.

        重载：
        setParent in class CompositeView
        参数：
        parent - the new parent, or null if the view is being removed from a parent it was previously added to

      • calculateMajorAxisRequirements

        protected SizeRequirements calculateMajorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate the requirements of the block along the major axis (i.e. the axis along with it tiles). This is implemented to provide the superclass behavior and then adjust it if the CSS width or height attribute is specified and applicable to the axis.
        重载：
        calculateMajorAxisRequirements in class BoxView
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate the requirements of the block along the minor axis (i.e. the axis orthoginal to the axis along with it tiles). This is implemented to provide the superclass behavior and then adjust it if the CSS width or height attribute is specified and applicable to the axis.
        重载：
        calculateMinorAxisRequirements in class BoxView
        参数：
        axis - the axis being studied
        r - the SizeRequirements object; if null one will be created
        返回：
        the newly initialized SizeRequirements object
        另请参见：
        SizeRequirements

      • layoutMinorAxis

        protected void layoutMinorAxis(int targetSpan,
                   int axis,
                   int[] offsets,
                   int[] spans)
        Performs layout for the minor axis of the box (i.e. the axis orthoginal to the axis that it represents). The results of the layout (the offset and span for each children) are placed in the given arrays which represent the allocations to the children along the minor axis.
        重载：
        layoutMinorAxis in class BoxView
        参数：
        targetSpan - the total span given to the view, which whould be used to layout the childre.
        axis - the axis being layed out
        offsets - the offsets from the origin of the view for each of the child views; this is a return value and is filled in by the implementation of this method
        spans - the span of each child view; this is a return value and is filled in by the implementation of this method

      • paint

        public void paint(Graphics g,
         Shape allocation)
        Renders using the given rendering surface and area on that surface. This is implemented to delegate to the css box painter to paint the border and background prior to the interior.
        重载：
        paint in class BoxView
        参数：
        g - the rendering surface to use
        allocation - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        重载：
        getAttributes in class View

      • getResizeWeight

        public int getResizeWeight(int axis)
        Gets the resize weight.
        重载：
        getResizeWeight in class BoxView
        参数：
        axis - may be either X_AXIS or Y_AXIS
        返回：
        the weight
        抛出：
        IllegalArgumentException - for an invalid axis

      • getAlignment

        public float getAlignment(int axis)
        Gets the alignment.
        重载：
        getAlignment in class BoxView
        参数：
        axis - may be either X_AXIS or Y_AXIS
        返回：
        the alignment

      • changedUpdate

        public void changedUpdate(DocumentEvent changes,
                 Shape a,
                 ViewFactory f)
        Description copied from class: View
        Gives notification from the document that attributes were changed in a location that this view is responsible for. To reduce the burden to subclasses, this functionality is spread out into the following calls that subclasses can reimplement:
        1. updateChildren is called if there were any changes to the element this view is responsible for. If this view has child views that are represent the child elements, then this method should do whatever is necessary to make sure the child views correctly represent the model.
        2. forwardUpdate is called to forward the DocumentEvent to the appropriate child views.
        3. updateLayout is called to give the view a chance to either repair its layout, to reschedule layout, or do nothing.
        重载：
        changedUpdate in class View
        参数：
        changes - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        重载：
        getPreferredSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis.
        重载：
        getMinimumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis.
        重载：
        getMaximumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        抛出：
        IllegalArgumentException - for an invalid axis type
        另请参见：
        View.getPreferredSpan(int)

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Update any cached values that come from attributes.

      • getStyleSheet

        protected StyleSheet getStyleSheet()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CSS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 CSS

  • java.lang.Object
    • javax.swing.text.html.CSS
  • 所有已实现的接口：
    Serializable

    public class CSS
extends Object
implements Serializable
    Defines a set of CSS attributes as a typesafe enumeration. The HTML View implementations use CSS attributes to determine how they will render. This also defines methods to map between CSS/HTML/StyleConstants. Any shorthand properties, such as font, are mapped to the intrinsic properties.

    The following describes the CSS properties that are suppored by the rendering engine:

    • font-family
    • font-style
    • font-size (supports relative units)
    • font-weight
    • font
    • color
    • background-color (with the exception of transparent)
    • background-image
    • background-repeat
    • background-position
    • background
    • background-repeat
    • text-decoration (with the exception of blink and overline)
    • vertical-align (only sup and super)
    • text-align (justify is treated as center)
    • margin-top
    • margin-right
    • margin-bottom
    • margin-left
    • margin
    • padding-top
    • padding-right
    • padding-bottom
    • padding-left
    • border-style (only supports inset, outset and none)
    • list-style-type
    • list-style-position
    The following are modeled, but currently not rendered.
    • font-variant
    • background-attachment (background always treated as scroll)
    • word-spacing
    • letter-spacing
    • text-indent
    • text-transform
    • line-height
    • border-top-width (this is used to indicate if a border should be used)
    • border-right-width
    • border-bottom-width
    • border-left-width
    • border-width
    • border-top
    • border-right
    • border-bottom
    • border-left
    • border
    • width
    • height
    • float
    • clear
    • display
    • white-space
    • list-style

    Note: for the time being we do not fully support relative units, unless noted, so that p { margin-top: 10% } will be treated as if no margin-top was specified.

    另请参见：
    StyleSheet

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  CSS.Attribute
      Definitions to be used as a key on AttributeSet's that might hold CSS attributes.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CSS()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static CSS.Attribute[] getAllAttributeKeys()
      Return the set of all possible CSS attribute keys.
      static CSS.Attribute getAttribute(String name)
      Translates a string to a CSS.Attribute object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CSS

        public CSS()

    • 方法详细信息

      • getAllAttributeKeys

        public static CSS.Attribute[] getAllAttributeKeys()
        Return the set of all possible CSS attribute keys.

      • getAttribute

        public static final CSS.Attribute getAttribute(String name)
        Translates a string to a CSS.Attribute object. This will return null if there is no attribute by the given name.
        参数：
        name - the name of the CSS attribute to fetch the typesafe enumeration for
        返回：
        the CSS.Attribute object, or null if the string doesn't represent a valid attribute key
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsgcatcstc"ooc""ldaaSlmuCrbr/t.rhtajj/.= st


CSS.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html

类 CSS.Attribute

  • java.lang.Object
    • javax.swing.text.html.CSS.Attribute
  • 封闭类：
    CSS

    public static final class CSS.Attribute
extends Object
    Definitions to be used as a key on AttributeSet's that might hold CSS attributes. Since this is a closed set (i.e. defined exactly by the specification), it is final and cannot be extended.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static CSS.Attribute | BACKGROUND
      static CSS.Attribute | BACKGROUND_ATTACHMENT
      static CSS.Attribute | BACKGROUND_COLOR
      static CSS.Attribute | BACKGROUND_IMAGE
      static CSS.Attribute | BACKGROUND_POSITION
      static CSS.Attribute | BACKGROUND_REPEAT
      static CSS.Attribute | BORDER
      static CSS.Attribute | BORDER_BOTTOM
      static CSS.Attribute | BORDER_BOTTOM_COLOR
      static CSS.Attribute | BORDER_BOTTOM_STYLE
      static CSS.Attribute | BORDER_BOTTOM_WIDTH
      static CSS.Attribute | BORDER_COLOR
      static CSS.Attribute | BORDER_LEFT
      static CSS.Attribute | BORDER_LEFT_COLOR
      static CSS.Attribute | BORDER_LEFT_STYLE
      static CSS.Attribute | BORDER_LEFT_WIDTH
      static CSS.Attribute | BORDER_RIGHT
      static CSS.Attribute | BORDER_RIGHT_COLOR
      static CSS.Attribute | BORDER_RIGHT_STYLE
      static CSS.Attribute | BORDER_RIGHT_WIDTH
      static CSS.Attribute | BORDER_STYLE
      static CSS.Attribute | BORDER_TOP
      static CSS.Attribute | BORDER_TOP_COLOR
      static CSS.Attribute | BORDER_TOP_STYLE
      static CSS.Attribute | BORDER_TOP_WIDTH
      static CSS.Attribute | BORDER_WIDTH
      static CSS.Attribute | CLEAR
      static CSS.Attribute | COLOR
      static CSS.Attribute | DISPLAY
      static CSS.Attribute | FLOAT
      static CSS.Attribute | FONT
      static CSS.Attribute | FONT_FAMILY
      static CSS.Attribute | FONT_SIZE
      static CSS.Attribute | FONT_STYLE
      static CSS.Attribute | FONT_VARIANT
      static CSS.Attribute | FONT_WEIGHT
      static CSS.Attribute | HEIGHT
      static CSS.Attribute | LETTER_SPACING
      static CSS.Attribute | LINE_HEIGHT
      static CSS.Attribute | LIST_STYLE
      static CSS.Attribute | LIST_STYLE_IMAGE
      static CSS.Attribute | LIST_STYLE_POSITION
      static CSS.Attribute | LIST_STYLE_TYPE
      static CSS.Attribute | MARGIN
      static CSS.Attribute | MARGIN_BOTTOM
      static CSS.Attribute | MARGIN_LEFT
      static CSS.Attribute | MARGIN_RIGHT
      static CSS.Attribute | MARGIN_TOP
      static CSS.Attribute | PADDING
      static CSS.Attribute | PADDING_BOTTOM
      static CSS.Attribute | PADDING_LEFT
      static CSS.Attribute | PADDING_RIGHT
      static CSS.Attribute | PADDING_TOP
      static CSS.Attribute | TEXT_ALIGN
      static CSS.Attribute | TEXT_DECORATION
      static CSS.Attribute | TEXT_INDENT
      static CSS.Attribute | TEXT_TRANSFORM
      static CSS.Attribute | VERTICAL_ALIGN
      static CSS.Attribute | WHITE_SPACE
      static CSS.Attribute | WIDTH
      static CSS.Attribute | WORD_SPACING

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDefaultValue()
      Fetch the default value for the attribute.
      boolean isInherited()
      Indicates if the attribute should be inherited from the parent or not.
      String toString()
      The string representation of the attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BACKGROUND

        public static final CSS.Attribute BACKGROUND

      • BACKGROUND_ATTACHMENT

        public static final CSS.Attribute BACKGROUND_ATTACHMENT

      • BACKGROUND_COLOR

        public static final CSS.Attribute BACKGROUND_COLOR

      • BACKGROUND_IMAGE

        public static final CSS.Attribute BACKGROUND_IMAGE

      • BACKGROUND_POSITION

        public static final CSS.Attribute BACKGROUND_POSITION

      • BACKGROUND_REPEAT

        public static final CSS.Attribute BACKGROUND_REPEAT

      • BORDER

        public static final CSS.Attribute BORDER

      • BORDER_BOTTOM

        public static final CSS.Attribute BORDER_BOTTOM

      • BORDER_BOTTOM_COLOR

        public static final CSS.Attribute BORDER_BOTTOM_COLOR

      • BORDER_BOTTOM_STYLE

        public static final CSS.Attribute BORDER_BOTTOM_STYLE

      • BORDER_BOTTOM_WIDTH

        public static final CSS.Attribute BORDER_BOTTOM_WIDTH

      • BORDER_COLOR

        public static final CSS.Attribute BORDER_COLOR

      • BORDER_LEFT

        public static final CSS.Attribute BORDER_LEFT

      • BORDER_LEFT_COLOR

        public static final CSS.Attribute BORDER_LEFT_COLOR

      • BORDER_LEFT_STYLE

        public static final CSS.Attribute BORDER_LEFT_STYLE

      • BORDER_LEFT_WIDTH

        public static final CSS.Attribute BORDER_LEFT_WIDTH

      • BORDER_RIGHT

        public static final CSS.Attribute BORDER_RIGHT

      • BORDER_RIGHT_COLOR

        public static final CSS.Attribute BORDER_RIGHT_COLOR

      • BORDER_RIGHT_STYLE

        public static final CSS.Attribute BORDER_RIGHT_STYLE

      • BORDER_RIGHT_WIDTH

        public static final CSS.Attribute BORDER_RIGHT_WIDTH

      • BORDER_STYLE

        public static final CSS.Attribute BORDER_STYLE

      • BORDER_TOP

        public static final CSS.Attribute BORDER_TOP

      • BORDER_TOP_COLOR

        public static final CSS.Attribute BORDER_TOP_COLOR

      • BORDER_TOP_STYLE

        public static final CSS.Attribute BORDER_TOP_STYLE

      • BORDER_TOP_WIDTH

        public static final CSS.Attribute BORDER_TOP_WIDTH

      • BORDER_WIDTH

        public static final CSS.Attribute BORDER_WIDTH

      • CLEAR

        public static final CSS.Attribute CLEAR

      • COLOR

        public static final CSS.Attribute COLOR

      • DISPLAY

        public static final CSS.Attribute DISPLAY

      • FLOAT

        public static final CSS.Attribute FLOAT

      • FONT

        public static final CSS.Attribute FONT

      • FONT_FAMILY

        public static final CSS.Attribute FONT_FAMILY

      • FONT_SIZE

        public static final CSS.Attribute FONT_SIZE

      • FONT_STYLE

        public static final CSS.Attribute FONT_STYLE

      • FONT_VARIANT

        public static final CSS.Attribute FONT_VARIANT

      • FONT_WEIGHT

        public static final CSS.Attribute FONT_WEIGHT

      • HEIGHT

        public static final CSS.Attribute HEIGHT

      • LETTER_SPACING

        public static final CSS.Attribute LETTER_SPACING

      • LINE_HEIGHT

        public static final CSS.Attribute LINE_HEIGHT

      • LIST_STYLE

        public static final CSS.Attribute LIST_STYLE

      • LIST_STYLE_IMAGE

        public static final CSS.Attribute LIST_STYLE_IMAGE

      • LIST_STYLE_POSITION

        public static final CSS.Attribute LIST_STYLE_POSITION

      • LIST_STYLE_TYPE

        public static final CSS.Attribute LIST_STYLE_TYPE

      • MARGIN

        public static final CSS.Attribute MARGIN

      • MARGIN_BOTTOM

        public static final CSS.Attribute MARGIN_BOTTOM

      • MARGIN_LEFT

        public static final CSS.Attribute MARGIN_LEFT

      • MARGIN_RIGHT

        public static final CSS.Attribute MARGIN_RIGHT

      • MARGIN_TOP

        public static final CSS.Attribute MARGIN_TOP

      • PADDING

        public static final CSS.Attribute PADDING

      • PADDING_BOTTOM

        public static final CSS.Attribute PADDING_BOTTOM

      • PADDING_LEFT

        public static final CSS.Attribute PADDING_LEFT

      • PADDING_RIGHT

        public static final CSS.Attribute PADDING_RIGHT

      • PADDING_TOP

        public static final CSS.Attribute PADDING_TOP

      • TEXT_ALIGN

        public static final CSS.Attribute TEXT_ALIGN

      • TEXT_DECORATION

        public static final CSS.Attribute TEXT_DECORATION

      • TEXT_INDENT

        public static final CSS.Attribute TEXT_INDENT

      • TEXT_TRANSFORM

        public static final CSS.Attribute TEXT_TRANSFORM

      • VERTICAL_ALIGN

        public static final CSS.Attribute VERTICAL_ALIGN

      • WORD_SPACING

        public static final CSS.Attribute WORD_SPACING

      • WHITE_SPACE

        public static final CSS.Attribute WHITE_SPACE

      • WIDTH

        public static final CSS.Attribute WIDTH

    • 方法详细信息

      • toString

        public String toString()
        The string representation of the attribute. This should exactly match the string specified in the CSS specification.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • getDefaultValue

        public String getDefaultValue()
        Fetch the default value for the attribute. If there is no default value (such as for composite attributes), null will be returned.

      • isInherited

        public boolean isInherited()
        Indicates if the attribute should be inherited from the parent or not.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n


FormSubmitEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html

类 FormSubmitEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
  • 所有已实现的接口：
    Serializable

    public class FormSubmitEvent
extends HTMLFrameHyperlinkEvent
    FormSubmitEvent is used to notify interested parties that a form was submited.
    从以下版本开始：
    1.5

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  FormSubmitEvent.MethodType
      Represents an HTML form method type.

      • Nested classes/interfaces inherited from class javax.swing.event.HyperlinkEvent

        HyperlinkEvent.EventType

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getData()
      Gets the form submission data.
      FormSubmitEvent.MethodType getMethod()
      Gets the form method type.

      • 方法 - 继承于类 javax.swing.text.html.HTMLFrameHyperlinkEvent

        getTarget

      • 方法 - 继承于类 javax.swing.event.HyperlinkEvent

        getDescription, getEventType, getInputEvent, getSourceElement, getURL

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • getMethod

        public FormSubmitEvent.MethodType getMethod()
        Gets the form method type.
        返回：
        the form method type, either Method.GET or Method.POST.

      • getData

        public String getData()
        Gets the form submission data.
        返回：
        the string representing the form submission data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i觧srsvsfsw efitstn/述媚帽囊宾叔⒁镫试芫


FormSubmitEvent.MethodType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.swing.text.html

Enum FormSubmitEvent.MethodType

  • java.lang.Object
    • java.lang.Enum<FormSubmitEvent.MethodType>
      • javax.swing.text.html.FormSubmitEvent.MethodType
  • 所有已实现的接口：
    Serializable, Comparable<FormSubmitEvent.MethodType>
    封闭类：
    FormSubmitEvent

    public static enum FormSubmitEvent.MethodType
extends Enum<FormSubmitEvent.MethodType>
    Represents an HTML form method type.
    • GET corresponds to the GET form method
    • POST corresponds to the POST from method
    从以下版本开始：
    1.5

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      GET
      POST

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static FormSubmitEvent.MethodType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FormSubmitEvent.MethodType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • GET

        public static final FormSubmitEvent.MethodType GET

      • POST

        public static final FormSubmitEvent.MethodType POST

    • 方法详细信息

      • values

        public static FormSubmitEvent.MethodType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (FormSubmitEvent.MethodType c : FormSubmitEvent.MethodType.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static FormSubmitEvent.MethodType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h�/ g=Rr>oJe纈o=l 9//ep n//}>l


FormView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 FormView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView
  • 所有已实现的接口：
    ActionListener, EventListener, SwingConstants

    public class FormView
extends ComponentView
implements ActionListener
    Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>. The model for the component is stored as an attribute of the the element (using StyleConstants.ModelAttribute), and is used to build the component of the view. The type of the model is assumed to of the type that would be set by HTMLDocument.HTMLReader.FormAction. If there are multiple views mapped over the document, they will share the embedded component models.

    The following table shows what components get built by this view.

    Element Type | Component built
    input, type button | JButton
    input, type checkbox | JCheckBox
    input, type image | JButton
    input, type password | JPasswordField
    input, type radio | JRadioButton
    input, type reset | JButton
    input, type submit | JButton
    input, type text | JTextField
    select, size > 1 or multiple attribute defined | JList in a JScrollPane
    select, size unspecified or 1 | JComboBox
    textarea | JTextArea in a JScrollPane
    input, type file | JTextField

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      protected class  FormView.MouseEventListener
      MouseEventListener class to handle form submissions when an input with type equal to image is clicked on.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String RESET
      Deprecated.
      As of 1.3, value comes from UIManager UIManager property FormView.resetButtonText
      static String SUBMIT
      Deprecated.
      As of 1.3, value now comes from UIManager property FormView.submitButtonText

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      FormView(Element elem)
      Creates a new FormView object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent evt)
      Responsible for processeing the ActionEvent.
      protected Component createComponent()
      Create the component.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      protected void imageSubmit(String imageData)
      This method is called to submit a form in response to a click on an image -- an <INPUT> form element of type "image".
      protected void submitData(String data)
      This method is responsible for submitting the form data.

      • 方法 - 继承于类 javax.swing.text.ComponentView

        getAlignment, getComponent, getMinimumSpan, getPreferredSpan, modelToView, paint, setParent, viewToModel

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • SUBMIT

        @Deprecated
public static final String SUBMIT
        Deprecated. As of 1.3, value now comes from UIManager property FormView.submitButtonText
        If a value attribute is not specified for a FORM input element of type "submit", then this default string is used.

      • RESET

        @Deprecated
public static final String RESET
        Deprecated. As of 1.3, value comes from UIManager UIManager property FormView.resetButtonText
        If a value attribute is not specified for a FORM input element of type "reset", then this default string is used.

    • 构造方法详细信息

      • FormView

        public FormView(Element elem)
        Creates a new FormView object.
        参数：
        elem - the element to decorate

    • 方法详细信息

      • createComponent

        protected Component createComponent()
        Create the component. This is basically a big switch statement based upon the tag type and html attributes of the associated element.
        重载：
        createComponent in class ComponentView

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis. For certain components, the maximum and preferred span are the same. For others this will return the value returned by Component.getMaximumSize along the axis of interest.
        重载：
        getMaximumSpan in class ComponentView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into >= 0. Typically the view is told to render into the span that is returned, although there is no guarantee. The parent may choose to resize or break the view.
        抛出：
        IllegalArgumentException - for an invalid axis
        另请参见：
        View.getPreferredSpan(int)

      • actionPerformed

        public void actionPerformed(ActionEvent evt)
        Responsible for processeing the ActionEvent. If the element associated with the FormView, has a type of "submit", "reset", "text" or "password" then the action is processed. In the case of a "submit" the form is submitted. In the case of a "reset" the form is reset to its original state. In the case of "text" or "password", if the element is the last one of type "text" or "password", the form is submitted. Otherwise, focus is transferred to the next component in the form.
        指定者：
        actionPerformed in interface ActionListener
        参数：
        evt - the ActionEvent.

      • submitData

        protected void submitData(String data)
        This method is responsible for submitting the form data. A thread is forked to undertake the submission.

      • imageSubmit

        protected void imageSubmit(String imageData)
        This method is called to submit a form in response to a click on an image -- an <INPUT> form element of type "image".
        参数：
        imageData - the mouse click coordinates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


FormView.MouseEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 FormView.MouseEventListener

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.text.html.FormView.MouseEventListener
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, EventListener
    封闭类：
    FormView

    protected class FormView.MouseEventListener
extends MouseAdapter
    MouseEventListener class to handle form submissions when an input with type equal to image is clicked on. A MouseListener is necessary since along with the image data the coordinates associated with the mouse click need to be submitted.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | FormView.MouseEventListener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void mouseReleased(MouseEvent evt)
      Invoked when a mouse button has been released on a component.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FormView.MouseEventListener

        protected FormView.MouseEventListener()

    • 方法详细信息

      • mouseReleased

        public void mouseReleased(MouseEvent evt)
        Description copied from class: MouseAdapter
        Invoked when a mouse button has been released on a component.
        指定者：
        mouseReleased in interface MouseListener
        重载：
        mouseReleased in class MouseAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

meusem>rm>"DD>""b <aaamuMto


HTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTML

  • java.lang.Object
    • javax.swing.text.html.HTML

  • public class HTML
extends Object
    Constants used in the HTMLDocument. These are basically tag and attribute definitions.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      static class  HTML.Attribute
      Typesafe enumeration representing an HTML attribute.
      static class  HTML.Tag
      Typesafe enumeration for an HTML tag.
      static class  | HTML.UnknownTag

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static String | NULL_ATTRIBUTE_VALUE

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTML()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static HTML.Attribute[] getAllAttributeKeys()
      Returns the set of HTML attributes recognized.
      static HTML.Tag[] getAllTags()
      Returns the set of actual HTML tags that are recognized by the default HTML reader.
      static HTML.Attribute getAttributeKey(String attName)
      Fetches an attribute constant for a well-known attribute name (i.e.
      static int getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
      Fetches an integer attribute value.
      static HTML.Tag getTag(String tagName)
      Fetches a tag constant for a well-known tag name (i.e.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NULL_ATTRIBUTE_VALUE

        public static final String NULL_ATTRIBUTE_VALUE
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • HTML

        public HTML()

    • 方法详细信息

      • getAllTags

        public static HTML.Tag[] getAllTags()
        Returns the set of actual HTML tags that are recognized by the default HTML reader. This set does not include tags that are manufactured by the reader.

      • getTag

        public static HTML.Tag getTag(String tagName)
        Fetches a tag constant for a well-known tag name (i.e. one of the tags in the set {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR}. If the given name does not represent one of the well-known tags, then null will be returned.
        参数：
        tagName - the String name requested
        返回：
        a tag constant corresponding to the tagName, or null if not found

      • getIntegerAttributeValue

        public static int getIntegerAttributeValue(AttributeSet attr,
                           HTML.Attribute key,
                           int def)
        Fetches an integer attribute value. Attribute values are stored as a string, and this is a convenience method to convert to an actual integer.
        参数：
        attr - the set of attributes to use to try to fetch a value
        key - the key to use to fetch the value
        def - the default value to use if the attribute isn't defined or there is an error converting to an integer

      • getAllAttributeKeys

        public static HTML.Attribute[] getAllAttributeKeys()
        Returns the set of HTML attributes recognized.
        返回：
        the set of HTML attributes recognized

      • getAttributeKey

        public static HTML.Attribute getAttributeKey(String attName)
        Fetches an attribute constant for a well-known attribute name (i.e. one of the attributes in the set {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG}). If the given name does not represent one of the well-known attributes, then null will be returned.
        参数：
        attName - the String requested
        返回：
        the Attribute corresponding to attName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= " // >>/bTmgl


HTML.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html

类 HTML.Attribute

  • java.lang.Object
    • javax.swing.text.html.HTML.Attribute
  • 封闭类：
    HTML

    public static final class HTML.Attribute
extends Object
    Typesafe enumeration representing an HTML attribute.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static HTML.Attribute | ACTION
      static HTML.Attribute | ALIGN
      static HTML.Attribute | ALINK
      static HTML.Attribute | ALT
      static HTML.Attribute | ARCHIVE
      static HTML.Attribute | BACKGROUND
      static HTML.Attribute | BGCOLOR
      static HTML.Attribute | BORDER
      static HTML.Attribute | CELLPADDING
      static HTML.Attribute | CELLSPACING
      static HTML.Attribute | CHECKED
      static HTML.Attribute | 类
      static HTML.Attribute | CLASSID
      static HTML.Attribute | CLEAR
      static HTML.Attribute | CODE
      static HTML.Attribute | CODEBASE
      static HTML.Attribute | CODETYPE
      static HTML.Attribute | COLOR
      static HTML.Attribute | COLS
      static HTML.Attribute | COLSPAN
      static HTML.Attribute | COMMENT
      static HTML.Attribute | COMPACT
      static HTML.Attribute | CONTENT
      static HTML.Attribute | COORDS
      static HTML.Attribute | DATA
      static HTML.Attribute | DECLARE
      static HTML.Attribute | DIR
      static HTML.Attribute | DUMMY
      static HTML.Attribute | ENCTYPE
      static HTML.Attribute | ENDTAG
      static HTML.Attribute | FACE
      static HTML.Attribute | FRAMEBORDER
      static HTML.Attribute | HALIGN
      static HTML.Attribute | HEIGHT
      static HTML.Attribute | HREF
      static HTML.Attribute | HSPACE
      static HTML.Attribute | HTTPEQUIV
      static HTML.Attribute | ID
      static HTML.Attribute | ISMAP
      static HTML.Attribute | LANG
      static HTML.Attribute | LANGUAGE
      static HTML.Attribute | LINK
      static HTML.Attribute | LOWSRC
      static HTML.Attribute | MARGINHEIGHT
      static HTML.Attribute | MARGINWIDTH
      static HTML.Attribute | MAXLENGTH
      static HTML.Attribute | 方法
      static HTML.Attribute | MULTIPLE
      static HTML.Attribute | N
      static HTML.Attribute | NAME
      static HTML.Attribute | NOHREF
      static HTML.Attribute | NORESIZE
      static HTML.Attribute | NOSHADE
      static HTML.Attribute | NOWRAP
      static HTML.Attribute | PROMPT
      static HTML.Attribute | REL
      static HTML.Attribute | REV
      static HTML.Attribute | ROWS
      static HTML.Attribute | ROWSPAN
      static HTML.Attribute | SCROLLING
      static HTML.Attribute | SELECTED
      static HTML.Attribute | SHAPE
      static HTML.Attribute | SHAPES
      static HTML.Attribute | SIZE
      static HTML.Attribute | SRC
      static HTML.Attribute | STANDBY
      static HTML.Attribute | START
      static HTML.Attribute | STYLE
      static HTML.Attribute | TARGET
      static HTML.Attribute | TEXT
      static HTML.Attribute | TITLE
      static HTML.Attribute | TYPE
      static HTML.Attribute | USEMAP
      static HTML.Attribute | VALIGN
      static HTML.Attribute | VALUE
      static HTML.Attribute | VALUETYPE
      static HTML.Attribute | VERSION
      static HTML.Attribute | VLINK
      static HTML.Attribute | VSPACE
      static HTML.Attribute | WIDTH

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Returns the string representation of this attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SIZE

        public static final HTML.Attribute SIZE

      • COLOR

        public static final HTML.Attribute COLOR

      • CLEAR

        public static final HTML.Attribute CLEAR

      • BACKGROUND

        public static final HTML.Attribute BACKGROUND

      • BGCOLOR

        public static final HTML.Attribute BGCOLOR

      • TEXT

        public static final HTML.Attribute TEXT

      • LINK

        public static final HTML.Attribute LINK

      • VLINK

        public static final HTML.Attribute VLINK

      • ALINK

        public static final HTML.Attribute ALINK

      • WIDTH

        public static final HTML.Attribute WIDTH

      • HEIGHT

        public static final HTML.Attribute HEIGHT

      • ALIGN

        public static final HTML.Attribute ALIGN

      • NAME

        public static final HTML.Attribute NAME

      • HREF

        public static final HTML.Attribute HREF

      • REL

        public static final HTML.Attribute REL

      • REV

        public static final HTML.Attribute REV

      • TITLE

        public static final HTML.Attribute TITLE

      • TARGET

        public static final HTML.Attribute TARGET

      • SHAPE

        public static final HTML.Attribute SHAPE

      • COORDS

        public static final HTML.Attribute COORDS

      • ISMAP

        public static final HTML.Attribute ISMAP

      • NOHREF

        public static final HTML.Attribute NOHREF

      • ALT

        public static final HTML.Attribute ALT

      • ID

        public static final HTML.Attribute ID

      • SRC

        public static final HTML.Attribute SRC

      • HSPACE

        public static final HTML.Attribute HSPACE

      • VSPACE

        public static final HTML.Attribute VSPACE

      • USEMAP

        public static final HTML.Attribute USEMAP

      • LOWSRC

        public static final HTML.Attribute LOWSRC

      • CODEBASE

        public static final HTML.Attribute CODEBASE

      • CODE

        public static final HTML.Attribute CODE

      • ARCHIVE

        public static final HTML.Attribute ARCHIVE

      • VALUE

        public static final HTML.Attribute VALUE

      • VALUETYPE

        public static final HTML.Attribute VALUETYPE

      • TYPE

        public static final HTML.Attribute TYPE

      • 类

        public static final HTML.Attribute CLASS

      • STYLE

        public static final HTML.Attribute STYLE

      • LANG

        public static final HTML.Attribute LANG

      • FACE

        public static final HTML.Attribute FACE

      • DIR

        public static final HTML.Attribute DIR

      • DECLARE

        public static final HTML.Attribute DECLARE

      • CLASSID

        public static final HTML.Attribute CLASSID

      • DATA

        public static final HTML.Attribute DATA

      • CODETYPE

        public static final HTML.Attribute CODETYPE

      • STANDBY

        public static final HTML.Attribute STANDBY

      • BORDER

        public static final HTML.Attribute BORDER

      • SHAPES

        public static final HTML.Attribute SHAPES

      • NOSHADE

        public static final HTML.Attribute NOSHADE

      • COMPACT

        public static final HTML.Attribute COMPACT

      • START

        public static final HTML.Attribute START

      • ACTION

        public static final HTML.Attribute ACTION

      • METHOD

        public static final HTML.Attribute METHOD

      • ENCTYPE

        public static final HTML.Attribute ENCTYPE

      • CHECKED

        public static final HTML.Attribute CHECKED

      • MAXLENGTH

        public static final HTML.Attribute MAXLENGTH

      • MULTIPLE

        public static final HTML.Attribute MULTIPLE

      • SELECTED

        public static final HTML.Attribute SELECTED

      • ROWS

        public static final HTML.Attribute ROWS

      • COLS

        public static final HTML.Attribute COLS

      • DUMMY

        public static final HTML.Attribute DUMMY

      • CELLSPACING

        public static final HTML.Attribute CELLSPACING

      • CELLPADDING

        public static final HTML.Attribute CELLPADDING

      • VALIGN

        public static final HTML.Attribute VALIGN

      • HALIGN

        public static final HTML.Attribute HALIGN

      • NOWRAP

        public static final HTML.Attribute NOWRAP

      • ROWSPAN

        public static final HTML.Attribute ROWSPAN

      • COLSPAN

        public static final HTML.Attribute COLSPAN

      • PROMPT

        public static final HTML.Attribute PROMPT

      • HTTPEQUIV

        public static final HTML.Attribute HTTPEQUIV

      • CONTENT

        public static final HTML.Attribute CONTENT

      • LANGUAGE

        public static final HTML.Attribute LANGUAGE

      • VERSION

        public static final HTML.Attribute VERSION

      • N

        public static final HTML.Attribute N

      • FRAMEBORDER

        public static final HTML.Attribute FRAMEBORDER

      • MARGINWIDTH

        public static final HTML.Attribute MARGINWIDTH

      • MARGINHEIGHT

        public static final HTML.Attribute MARGINHEIGHT

      • SCROLLING

        public static final HTML.Attribute SCROLLING

      • NORESIZE

        public static final HTML.Attribute NORESIZE

      • ENDTAG

        public static final HTML.Attribute ENDTAG

      • COMMENT

        public static final HTML.Attribute COMMENT

    • 方法详细信息

      • toString

        public String toString()
        Returns the string representation of this attribute.
        重载：
        toString in class Object
        返回：
        the string representation of this attribute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


HTML.Tag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTML.Tag

  • java.lang.Object
    • javax.swing.text.html.HTML.Tag
  • 直接已知子类：
    HTML.UnknownTag
    封闭类：
    HTML

    public static class HTML.Tag
extends Object
    Typesafe enumeration for an HTML tag. Although the set of HTML tags is a closed set, we have left the set open so that people can add their own tag types to their custom parser and still communicate to the reader.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static HTML.Tag | A
      static HTML.Tag | ADDRESS
      static HTML.Tag | APPLET
      static HTML.Tag | AREA
      static HTML.Tag | B
      static HTML.Tag | BASE
      static HTML.Tag | BASEFONT
      static HTML.Tag | BIG
      static HTML.Tag | BLOCKQUOTE
      static HTML.Tag | BODY
      static HTML.Tag | BR
      static HTML.Tag | CAPTION
      static HTML.Tag | CENTER
      static HTML.Tag | CITE
      static HTML.Tag | CODE
      static HTML.Tag COMMENT
      All comments are labeled with this tag.
      static HTML.Tag CONTENT
      All text content is labeled with this tag.
      static HTML.Tag | DD
      static HTML.Tag | DFN
      static HTML.Tag | DIR
      static HTML.Tag | DIV
      static HTML.Tag | DL
      static HTML.Tag | DT
      static HTML.Tag | EM
      static HTML.Tag | FONT
      static HTML.Tag | FORM
      static HTML.Tag | FRAME
      static HTML.Tag | FRAMESET
      static HTML.Tag | H1
      static HTML.Tag | H2
      static HTML.Tag | H3
      static HTML.Tag | H4
      static HTML.Tag | H5
      static HTML.Tag | H6
      static HTML.Tag | HEAD
      static HTML.Tag | HR
      static HTML.Tag | HTML
      static HTML.Tag | I
      static HTML.Tag | IMG
      static HTML.Tag IMPLIED
      All text content must be in a paragraph element.
      static HTML.Tag | INPUT
      static HTML.Tag | ISINDEX
      static HTML.Tag | KBD
      static HTML.Tag | LI
      static HTML.Tag | LINK
      static HTML.Tag | MAP
      static HTML.Tag | MENU
      static HTML.Tag | META
      static HTML.Tag | NOFRAMES
      static HTML.Tag | OBJECT
      static HTML.Tag | OL
      static HTML.Tag | OPTION
      static HTML.Tag | P
      static HTML.Tag | PARAM
      static HTML.Tag | PRE
      static HTML.Tag | S
      static HTML.Tag | SAMP
      static HTML.Tag | SCRIPT
      static HTML.Tag | SELECT
      static HTML.Tag | SMALL
      static HTML.Tag | SPAN
      static HTML.Tag | STRIKE
      static HTML.Tag | STRONG
      static HTML.Tag | STYLE
      static HTML.Tag | SUB
      static HTML.Tag | SUP
      static HTML.Tag | TABLE
      static HTML.Tag | TD
      static HTML.Tag | TEXTAREA
      static HTML.Tag | TH
      static HTML.Tag | TITLE
      static HTML.Tag | TR
      static HTML.Tag | TT
      static HTML.Tag | U
      static HTML.Tag | UL
      static HTML.Tag | VAR

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
        HTML.Tag()
      protected HTML.Tag(String id)
      Creates a new Tag with the specified id, and with causesBreak and isBlock set to false.
      protected HTML.Tag(String id, boolean causesBreak, boolean isBlock)
      Creates a new Tag with the specified id; causesBreak and isBlock are defined by the user.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean breaksFlow()
      Returns true if this tag causes a line break to the flow of data, otherwise returns false.
      boolean isBlock()
      Returns true if this tag is a block tag, which is a tag used to add structure to a document.
      boolean isPreformatted()
      Returns true if this tag is pre-formatted, which is true if the tag is either PRE or TEXTAREA.
      String toString()
      Returns the string representation of the tag.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • A

        public static final HTML.Tag A

      • ADDRESS

        public static final HTML.Tag ADDRESS

      • APPLET

        public static final HTML.Tag APPLET

      • AREA

        public static final HTML.Tag AREA

      • B

        public static final HTML.Tag B

      • BASE

        public static final HTML.Tag BASE

      • BASEFONT

        public static final HTML.Tag BASEFONT

      • BIG

        public static final HTML.Tag BIG

      • BLOCKQUOTE

        public static final HTML.Tag BLOCKQUOTE

      • BODY

        public static final HTML.Tag BODY

      • BR

        public static final HTML.Tag BR

      • CAPTION

        public static final HTML.Tag CAPTION

      • CENTER

        public static final HTML.Tag CENTER

      • CITE

        public static final HTML.Tag CITE

      • CODE

        public static final HTML.Tag CODE

      • DD

        public static final HTML.Tag DD

      • DFN

        public static final HTML.Tag DFN

      • DIR

        public static final HTML.Tag DIR

      • DIV

        public static final HTML.Tag DIV

      • DL

        public static final HTML.Tag DL

      • DT

        public static final HTML.Tag DT

      • EM

        public static final HTML.Tag EM

      • FONT

        public static final HTML.Tag FONT

      • FORM

        public static final HTML.Tag FORM

      • FRAME

        public static final HTML.Tag FRAME

      • FRAMESET

        public static final HTML.Tag FRAMESET

      • H1

        public static final HTML.Tag H1

      • H2

        public static final HTML.Tag H2

      • H3

        public static final HTML.Tag H3

      • H4

        public static final HTML.Tag H4

      • H5

        public static final HTML.Tag H5

      • H6

        public static final HTML.Tag H6

      • HEAD

        public static final HTML.Tag HEAD

      • HR

        public static final HTML.Tag HR

      • HTML

        public static final HTML.Tag HTML

      • I

        public static final HTML.Tag I

      • IMG

        public static final HTML.Tag IMG

      • INPUT

        public static final HTML.Tag INPUT

      • ISINDEX

        public static final HTML.Tag ISINDEX

      • KBD

        public static final HTML.Tag KBD

      • LI

        public static final HTML.Tag LI

      • LINK

        public static final HTML.Tag LINK

      • MAP

        public static final HTML.Tag MAP

      • MENU

        public static final HTML.Tag MENU

      • META

        public static final HTML.Tag META

      • NOFRAMES

        public static final HTML.Tag NOFRAMES

      • OBJECT

        public static final HTML.Tag OBJECT

      • OL

        public static final HTML.Tag OL

      • OPTION

        public static final HTML.Tag OPTION

      • P

        public static final HTML.Tag P

      • PARAM

        public static final HTML.Tag PARAM

      • PRE

        public static final HTML.Tag PRE

      • SAMP

        public static final HTML.Tag SAMP

      • SCRIPT

        public static final HTML.Tag SCRIPT

      • SELECT

        public static final HTML.Tag SELECT

      • SMALL

        public static final HTML.Tag SMALL

      • SPAN

        public static final HTML.Tag SPAN

      • STRIKE

        public static final HTML.Tag STRIKE

      • S

        public static final HTML.Tag S

      • STRONG

        public static final HTML.Tag STRONG

      • STYLE

        public static final HTML.Tag STYLE

      • SUB

        public static final HTML.Tag SUB

      • SUP

        public static final HTML.Tag SUP

      • TABLE

        public static final HTML.Tag TABLE

      • TD

        public static final HTML.Tag TD

      • TEXTAREA

        public static final HTML.Tag TEXTAREA

      • TH

        public static final HTML.Tag TH

      • TITLE

        public static final HTML.Tag TITLE

      • TR

        public static final HTML.Tag TR

      • TT

        public static final HTML.Tag TT

      • U

        public static final HTML.Tag U

      • UL

        public static final HTML.Tag UL

      • VAR

        public static final HTML.Tag VAR

      • IMPLIED

        public static final HTML.Tag IMPLIED
        All text content must be in a paragraph element. If a paragraph didn't exist when content was encountered, a paragraph is manufactured.

        This is a tag synthesized by the HTML reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

      • CONTENT

        public static final HTML.Tag CONTENT
        All text content is labeled with this tag.

        This is a tag synthesized by the HTML reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

      • COMMENT

        public static final HTML.Tag COMMENT
        All comments are labeled with this tag.

        This is a tag synthesized by the HTML reader. Since elements are identified by their tag type, we create a some fake tag types to mark the elements that were manufactured.

    • 构造方法详细信息

      • HTML.Tag

        public HTML.Tag()
        从以下版本开始：
        1.3

      • HTML.Tag

        protected HTML.Tag(String id)
        Creates a new Tag with the specified id, and with causesBreak and isBlock set to false.
        参数：
        id - the id of the new tag

      • HTML.Tag

        protected HTML.Tag(String id,
        boolean causesBreak,
        boolean isBlock)
        Creates a new Tag with the specified id; causesBreak and isBlock are defined by the user.
        参数：
        id - the id of the new tag
        causesBreak - true if this tag causes a break to the flow of data
        isBlock - true if the tag is used to add structure to a document

    • 方法详细信息

      • isBlock

        public boolean isBlock()
        Returns true if this tag is a block tag, which is a tag used to add structure to a document.
        返回：
        true if this tag is a block tag, otherwise returns false

      • breaksFlow

        public boolean breaksFlow()
        Returns true if this tag causes a line break to the flow of data, otherwise returns false.
        返回：
        true if this tag causes a line break to the flow of data, otherwise returns false

      • isPreformatted

        public boolean isPreformatted()
        Returns true if this tag is pre-formatted, which is true if the tag is either PRE or TEXTAREA.
        返回：
        true if this tag is pre-formatted, otherwise returns false

      • toString

        public String toString()
        Returns the string representation of the tag.
        重载：
        toString in class Object
        返回：
        the String representation of the tag
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTML.UnknownTag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTML.UnknownTag

  • java.lang.Object
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag
  • 所有已实现的接口：
    Serializable
    封闭类：
    HTML

    public static class HTML.UnknownTag
extends HTML.Tag
implements Serializable

    • 字段摘要

      • Fields inherited from class javax.swing.text.html.HTML.Tag

        A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, COMMENT, CONTENT, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, IMPLIED, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, S, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTML.UnknownTag(String id)
      Creates a new UnknownTag with the specified id.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares this object to the specifed object.
      int hashCode()
      Returns the hash code which corresponds to the string for this tag.

      • 方法 - 继承于类 javax.swing.text.html.HTML.Tag

        breaksFlow, isBlock, isPreformatted, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HTML.UnknownTag

        public HTML.UnknownTag(String id)
        Creates a new UnknownTag with the specified id.
        参数：
        id - the id of the new tag

    • 方法详细信息

      • hashCode

        public int hashCode()
        Returns the hash code which corresponds to the string for this tag.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares this object to the specifed object. The result is true if and only if the argument is not null and is an UnknownTag object with the same name.
        重载：
        equals in class Object
        参数：
        obj - the object to compare this tag with
        返回：
        true if the objects are equal; false otherwise
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dx Cs"c="c llc >too"= .e.../.jaiv/frtt>s=


HTMLDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument

  • java.lang.Object
    • javax.swing.text.AbstractDocument
      • javax.swing.text.DefaultStyledDocument
        • javax.swing.text.html.HTMLDocument
  • 所有已实现的接口：
    Serializable, Document, StyledDocument

    public class HTMLDocument
extends DefaultStyledDocument
    A document that models HTML. The purpose of this model is to support both browsing and editing. As a result, the structure described by an HTML document is not exactly replicated by default. The element structure that is modeled by default, is built by the class HTMLDocument.HTMLReader, which implements the HTMLEditorKit.ParserCallback protocol that the parser expects. To change the structure one can subclass HTMLReader, and reimplement the method getReader(int) to return the new reader implementation. The documentation for HTMLReader should be consulted for the details of the default structure created. The intent is that the document be non-lossy (although reproducing the HTML format may result in a different format).

    The document models only HTML, and makes no attempt to store view attributes in it. The elements are identified by the StyleContext.NameAttribute attribute, which should always have a value of type HTML.Tag that identifies the kind of element. Some of the elements (such as comments) are synthesized. The HTMLFactory uses this attribute to determine what kind of view to build.

    This document supports incremental loading. The TokenThreshold property controls how much of the parse is buffered before trying to update the element structure of the document. This property is set by the EditorKit so that subclasses can disable it.

    The Base property determines the URL against which relative URLs are resolved. By default, this will be the Document.StreamDescriptionProperty if the value of the property is a URL. If a <BASE> tag is encountered, the base will become the URL specified by that tag. Because the base URL is a property, it can of course be set directly.

    The default content storage mechanism for this document is a gap buffer (GapContent). Alternatives can be supplied by using the constructor that takes a Content implementation.

    Modifying HTMLDocument

    In addition to the methods provided by Document and StyledDocument for mutating an HTMLDocument, HTMLDocument provides a number of convenience methods. The following methods can be used to insert HTML content into an existing document.

    • setInnerHTML(Element, String)
    • setOuterHTML(Element, String)
    • insertBeforeStart(Element, String)
    • insertAfterStart(Element, String)
    • insertBeforeEnd(Element, String)
    • insertAfterEnd(Element, String)

    The following examples illustrate using these methods. Each example assumes the HTML document is initialized in the following way:

     JEditorPane p = new JEditorPane();
 p.setContentType("text/html");
 p.setText("..."); // Document text is provided below.
 HTMLDocument d = (HTMLDocument) p.getDocument();

    With the following HTML content:

     <html>
   <head>
     <title>An example HTMLDocument</title>
     <style type="text/css">
       div { background-color: silver; }
       ul { color: red; }
     </style>
   </head>
   <body>
     <div id="BOX">
       <p>Paragraph 1</p>
       <p>Paragraph 2</p>
     </div>
   </body>
 </html>

    All the methods for modifying an HTML document require an Element. Elements can be obtained from an HTML document by using the method getElement(Element e, Object attribute, Object value). It returns the first descendant element that contains the specified attribute with the given value, in depth-first order. For example, d.getElement(d.getDefaultRootElement(), StyleConstants.NameAttribute, HTML.Tag.P) returns the first paragraph element.

    A convenient shortcut for locating elements is the method getElement(String); returns an element whose ID attribute matches the specified value. For example, d.getElement("BOX") returns the DIV element.

    The getIterator(HTML.Tag t) method can also be used for finding all occurrences of the specified HTML tag in the document.

    Inserting elements

    Elements can be inserted before or after the existing children of any non-leaf element by using the methods insertAfterStart and insertBeforeEnd. For example, if e is the DIV element, d.insertAfterStart(e, "<ul><li>List Item</li></ul>") inserts the list before the first paragraph, and d.insertBeforeEnd(e, "<ul><li>List Item</li></ul>") inserts the list after the last paragraph. The DIV block becomes the parent of the newly inserted elements.

    Sibling elements can be inserted before or after any element by using the methods insertBeforeStart and insertAfterEnd. For example, if e is the DIV element, d.insertBeforeStart(e, "<ul><li>List Item</li></ul>") inserts the list before the DIV element, and d.insertAfterEnd(e, "<ul><li>List Item</li></ul>") inserts the list after the DIV element. The newly inserted elements become siblings of the DIV element.

    Replacing elements

    Elements and all their descendants can be replaced by using the methods setInnerHTML and setOuterHTML. For example, if e is the DIV element, d.setInnerHTML(e, "<ul><li>List Item</li></ul>") replaces all children paragraphs with the list, and d.setOuterHTML(e, "<ul><li>List Item</li></ul>") replaces the DIV element itself. In latter case the parent of the list is the BODY element.

    Summary

    The following table shows the example document and the results of various methods described above.

    Example insertAfterStart insertBeforeEnd insertBeforeStart insertAfterEnd setInnerHTML setOuterHTML

    Paragraph 1

    Paragraph 2
    • List Item

    Paragraph 1

    Paragraph 2

    Paragraph 1

    Paragraph 2

    • List Item
    • List Item

    Paragraph 1

    Paragraph 2

    Paragraph 1

    Paragraph 2

    • List Item
    • List Item
    • List Item

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.HTMLReader
      An HTML reader to load an HTML document with an HTML element structure.
      static class  HTMLDocument.Iterator
      An iterator to iterate over a particular type of tag.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultStyledDocument

        DefaultStyledDocument.AttributeUndoableEdit, DefaultStyledDocument.ElementBuffer, DefaultStyledDocument.ElementSpec, DefaultStyledDocument.SectionElement

      • Nested classes/interfaces inherited from class javax.swing.text.AbstractDocument

        AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String AdditionalComments
      Document property key value.

      • Fields inherited from class javax.swing.text.DefaultStyledDocument

        buffer, BUFFER_SIZE_DEFAULT

      • Fields inherited from class javax.swing.text.AbstractDocument

        BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName

      • 字段 - 继承于接口 javax.swing.text.Document

        StreamDescriptionProperty, TitleProperty

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument()
      Constructs an HTML document using the default buffer size and a default StyleSheet.
      HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
      Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
      HTMLDocument(StyleSheet styles)
      Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void create(DefaultStyledDocument.ElementSpec[] data)
      Replaces the contents of the document with the given element specifications.
      protected Element createBranchElement(Element parent, AttributeSet a)
      Creates a document branch element, that can contain other elements.
      protected AbstractDocument.AbstractElement createDefaultRoot()
      Creates the root element to be used to represent the default document structure.
      protected Element createLeafElement(Element parent, AttributeSet a, int p0, int p1)
      Creates a document leaf element that directly represents text (doesn't have any children).
      protected void fireChangedUpdate(DocumentEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireUndoableEditUpdate(UndoableEditEvent e)
      Notifies all listeners that have registered interest for notification on this event type.
      URL getBase()
      Returns the location to resolve relative URLs against.
      Element getElement(Element e, Object attribute, Object value)
      Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found.
      Element getElement(String id)
      Returns the element that has the given id Attribute.
      HTMLDocument.Iterator getIterator(HTML.Tag t)
      Fetches an iterator for the specified HTML tag.
      HTMLEditorKit.Parser getParser()
      Returns the parser that is used when inserting HTML into the existing document.
      boolean getPreservesUnknownTags()
      Returns the behavior the parser observes when encountering unknown tags.
      HTMLEditorKit.ParserCallback getReader(int pos)
      Fetches the reader for the parser to use when loading the document with HTML.
      HTMLEditorKit.ParserCallback getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag)
      Returns the reader for the parser to use to load the document with HTML.
      StyleSheet getStyleSheet()
      Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.
      int getTokenThreshold()
      Gets the number of tokens to buffer before trying to update the documents element structure.
      protected void insert(int offset, DefaultStyledDocument.ElementSpec[] data)
      Inserts new elements in bulk.
      void insertAfterEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string after the the end of the given element.
      void insertAfterStart(Element elem, String htmlText)
      Inserts the HTML specified as a string at the start of the element.
      void insertBeforeEnd(Element elem, String htmlText)
      Inserts the HTML specified as a string at the end of the element.
      void insertBeforeStart(Element elem, String htmlText)
      Inserts the HTML specified as a string before the start of the given element.
      protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
      Updates document structure as a result of text insertion.
      void processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
      Processes HyperlinkEvents that are generated by documents in an HTML frame.
      void setBase(URL u)
      Sets the location to resolve relative URLs against.
      void setInnerHTML(Element elem, String htmlText)
      Replaces the children of the given element with the contents specified as an HTML string.
      void setOuterHTML(Element elem, String htmlText)
      Replaces the given element in the parent with the contents specified as an HTML string.
      void setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace)
      Sets attributes for a paragraph.
      void setParser(HTMLEditorKit.Parser parser)
      Sets the parser that is used by the methods that insert html into the existing document, such as setInnerHTML, and setOuterHTML.
      void setPreservesUnknownTags(boolean preservesTags)
      Determines how unknown tags are handled by the parser.
      void setTokenThreshold(int n)
      Sets the number of tokens to buffer before trying to update the documents element structure.

      • 方法 - 继承于类 javax.swing.text.DefaultStyledDocument

        addDocumentListener, addStyle, getBackground, getCharacterElement, getDefaultRootElement, getFont, getForeground, getLogicalStyle, getParagraphElement, getStyle, getStyleNames, removeDocumentListener, removeElement, removeStyle, removeUpdate, setCharacterAttributes, setLogicalStyle, styleChanged

      • 方法 - 继承于类 javax.swing.text.AbstractDocument

        addUndoableEditListener, createPosition, dump, fireInsertUpdate, fireRemoveUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, insertString, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.Document

        addUndoableEditListener, createPosition, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeUndoableEditListener, render

    • 字段详细信息

      • AdditionalComments

        public static final String AdditionalComments
        Document property key value. The value for the key will be a Vector of Strings that are comments not found in the body.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • HTMLDocument

        public HTMLDocument()
        Constructs an HTML document using the default buffer size and a default StyleSheet. This is a convenience method for the constructor HTMLDocument(Content, StyleSheet).

      • HTMLDocument

        public HTMLDocument(StyleSheet styles)
        Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism. This is a convenience method for the constructor HTMLDocument(Content, StyleSheet).
        参数：
        styles - the styles

      • HTMLDocument

        public HTMLDocument(AbstractDocument.Content c,
            StyleSheet styles)
        Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
        参数：
        c - the container for the content
        styles - the styles

    • 方法详细信息

      • getReader

        public HTMLEditorKit.ParserCallback getReader(int pos)
        Fetches the reader for the parser to use when loading the document with HTML. This is implemented to return an instance of HTMLDocument.HTMLReader. Subclasses can reimplement this method to change how the document gets structured if desired. (For example, to handle custom tags, or structurally represent character style elements.)
        参数：
        pos - the starting position
        返回：
        the reader used by the parser to load the document

      • getReader

        public HTMLEditorKit.ParserCallback getReader(int pos,
                                     int popDepth,
                                     int pushDepth,
                                     HTML.Tag insertTag)
        Returns the reader for the parser to use to load the document with HTML. This is implemented to return an instance of HTMLDocument.HTMLReader. Subclasses can reimplement this method to change how the document gets structured if desired. (For example, to handle custom tags, or structurally represent character style elements.)

        This is a convenience method for getReader(int, int, int, HTML.Tag, TRUE).

        参数：
        popDepth - the number of ElementSpec.EndTagTypes to generate before inserting
        pushDepth - the number of ElementSpec.StartTagTypes with a direction of ElementSpec.JoinNextDirection that should be generated before inserting, but after the end tags have been generated
        insertTag - the first tag to start inserting into document
        返回：
        the reader used by the parser to load the document

      • getBase

        public URL getBase()
        Returns the location to resolve relative URLs against. By default this will be the document's URL if the document was loaded from a URL. If a base tag is found and can be parsed, it will be used as the base location.
        返回：
        the base location

      • setBase

        public void setBase(URL u)
        Sets the location to resolve relative URLs against. By default this will be the document's URL if the document was loaded from a URL. If a base tag is found and can be parsed, it will be used as the base location.

        This also sets the base of the StyleSheet to be u as well as the base of the document.

        参数：
        u - the desired base URL

      • insert

        protected void insert(int offset,
          DefaultStyledDocument.ElementSpec[] data)
               throws BadLocationException
        Inserts new elements in bulk. This is how elements get created in the document. The parsing determines what structure is needed and creates the specification as a set of tokens that describe the edit while leaving the document free of a write-lock. This method can then be called in bursts by the reader to acquire a write-lock for a shorter duration (i.e. while the document is actually being altered).
        重载：
        insert in class DefaultStyledDocument
        参数：
        offset - the starting offset
        data - the element data
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document.

      • insertUpdate

        protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                AttributeSet attr)
        Updates document structure as a result of text insertion. This will happen within a write lock. This implementation simply parses the inserted content for line breaks and builds up a set of instructions for the element buffer.
        重载：
        insertUpdate in class DefaultStyledDocument
        参数：
        chng - a description of the document change
        attr - the attributes

      • create

        protected void create(DefaultStyledDocument.ElementSpec[] data)
        Replaces the contents of the document with the given element specifications. This is called before insert if the loading is done in bursts. This is the only method called if loading the document entirely in one burst.
        重载：
        create in class DefaultStyledDocument
        参数：
        data - the new contents of the document

      • setParagraphAttributes

        public void setParagraphAttributes(int offset,
                          int length,
                          AttributeSet s,
                          boolean replace)
        Sets attributes for a paragraph.

        This method is thread safe, although most Swing methods are not. Please see How to Use Threads for more information.

        指定者：
        setParagraphAttributes in interface StyledDocument
        重载：
        setParagraphAttributes in class DefaultStyledDocument
        参数：
        offset - the offset into the paragraph (must be at least 0)
        length - the number of characters affected (must be at least 0)
        s - the attributes
        replace - whether to replace existing attributes, or merge them

      • getStyleSheet

        public StyleSheet getStyleSheet()
        Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.
        返回：
        the StyleSheet

      • getIterator

        public HTMLDocument.Iterator getIterator(HTML.Tag t)
        Fetches an iterator for the specified HTML tag. This can be used for things like iterating over the set of anchors contained, or iterating over the input elements.
        参数：
        t - the requested HTML.Tag
        返回：
        the Iterator for the given HTML tag
        另请参见：
        HTML.Tag

      • createLeafElement

        protected Element createLeafElement(Element parent,
                        AttributeSet a,
                        int p0,
                        int p1)
        Creates a document leaf element that directly represents text (doesn't have any children). This is implemented to return an element of type HTMLDocument.RunElement.
        重载：
        createLeafElement in class AbstractDocument
        参数：
        parent - the parent element
        a - the attributes for the element
        p0 - the beginning of the range (must be at least 0)
        p1 - the end of the range (must be at least p0)
        返回：
        the new element

      • createBranchElement

        protected Element createBranchElement(Element parent,
                          AttributeSet a)
        Creates a document branch element, that can contain other elements. This is implemented to return an element of type HTMLDocument.BlockElement.
        重载：
        createBranchElement in class AbstractDocument
        参数：
        parent - the parent element
        a - the attributes
        返回：
        the element

      • createDefaultRoot

        protected AbstractDocument.AbstractElement createDefaultRoot()
        Creates the root element to be used to represent the default document structure.
        重载：
        createDefaultRoot in class DefaultStyledDocument
        返回：
        the element base

      • setTokenThreshold

        public void setTokenThreshold(int n)
        Sets the number of tokens to buffer before trying to update the documents element structure.
        参数：
        n - the number of tokens to buffer

      • getTokenThreshold

        public int getTokenThreshold()
        Gets the number of tokens to buffer before trying to update the documents element structure. The default value is Integer.MAX_VALUE.
        返回：
        the number of tokens to buffer

      • setPreservesUnknownTags

        public void setPreservesUnknownTags(boolean preservesTags)
        Determines how unknown tags are handled by the parser. If set to true, unknown tags are put in the model, otherwise they are dropped.
        参数：
        preservesTags - true if unknown tags should be saved in the model, otherwise tags are dropped
        另请参见：
        HTML.Tag

      • getPreservesUnknownTags

        public boolean getPreservesUnknownTags()
        Returns the behavior the parser observes when encountering unknown tags.
        返回：
        true if unknown tags are to be preserved when parsing
        另请参见：
        HTML.Tag

      • processHTMLFrameHyperlinkEvent

        public void processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
        Processes HyperlinkEvents that are generated by documents in an HTML frame. The HyperlinkEvent type, as the parameter suggests, is HTMLFrameHyperlinkEvent. In addition to the typical information contained in a HyperlinkEvent, this event contains the element that corresponds to the frame in which the click happened (the source element) and the target name. The target name has 4 possible values:
        • _self
        • _parent
        • _top
        • a named frame
        If target is _self, the action is to change the value of the HTML.Attribute.SRC attribute and fires a ChangedUpdate event.

        If the target is _parent, then it deletes the parent element, which is a <FRAMESET> element, and inserts a new <FRAME> element, and sets its HTML.Attribute.SRC attribute to have a value equal to the destination URL and fire a RemovedUpdate and InsertUpdate.

        If the target is _top, this method does nothing. In the implementation of the view for a frame, namely the FrameView, the processing of _top is handled. Given that _top implies replacing the entire document, it made sense to handle this outside of the document that it will replace.

        If the target is a named frame, then the element hierarchy is searched for an element with a name equal to the target, its HTML.Attribute.SRC attribute is updated and a ChangedUpdate event is fired.

        参数：
        e - the event

      • setParser

        public void setParser(HTMLEditorKit.Parser parser)
        Sets the parser that is used by the methods that insert html into the existing document, such as setInnerHTML, and setOuterHTML.

        HTMLEditorKit.createDefaultDocument will set the parser for you. If you create an HTMLDocument by hand, be sure and set the parser accordingly.

        参数：
        parser - the parser to be used for text insertion
        从以下版本开始：
        1.3

      • getParser

        public HTMLEditorKit.Parser getParser()
        Returns the parser that is used when inserting HTML into the existing document.
        返回：
        the parser used for text insertion
        从以下版本开始：
        1.3

      • setInnerHTML

        public void setInnerHTML(Element elem,
                String htmlText)
                  throws BadLocationException,
                         IOException
        Replaces the children of the given element with the contents specified as an HTML string.

        This will be seen as at least two events, n inserts followed by a remove.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking setInnerHTML(elem, "<ul><li>") results in the following structure (new elements are in red).

             <body>
       |
     <div>
         \
         <ul>
           \
           <li>

        Parameter elem must not be a leaf element, otherwise an IllegalArgumentException is thrown. If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the branch element whose children will be replaced
        htmlText - the string to be parsed and assigned to elem
        抛出：
        IllegalArgumentException - if elem is a leaf
        IllegalStateException - if an HTMLEditorKit.Parser has not been defined
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • setOuterHTML

        public void setOuterHTML(Element elem,
                String htmlText)
                  throws BadLocationException,
                         IOException
        Replaces the given element in the parent with the contents specified as an HTML string.

        This will be seen as at least two events, n inserts followed by a remove.

        When replacing a leaf this will attempt to make sure there is a newline present if one is needed. This may result in an additional element being inserted. Consider, if you were to replace a character element that contained a newline with <img> this would create two elements, one for the image, ane one for the newline.

        If you try to replace the element at length you will most likely end up with two elements, eg setOuterHTML(getCharacterElement (getLength()), "blah") will result in two leaf elements at the end, one representing 'blah', and the other representing the end element.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking setOuterHTML(elem, "<ul><li>") results in the following structure (new elements are in red).

            <body>
      |
     <ul>
       \
       <li>

        If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the element to replace
        htmlText - the string to be parsed and inserted in place of elem
        抛出：
        IllegalStateException - if an HTMLEditorKit.Parser has not been set
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • insertAfterStart

        public void insertAfterStart(Element elem,
                    String htmlText)
                      throws BadLocationException,
                             IOException
        Inserts the HTML specified as a string at the start of the element.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking insertAfterStart(elem, "<ul><li>") results in the following structure (new elements are in red).

                <body>
          |
        <div>
       /  |  \
    <ul> <p> <p>
     /
  <li>

        Unlike the insertBeforeStart method, new elements become children of the specified element, not siblings.

        Parameter elem must not be a leaf element, otherwise an IllegalArgumentException is thrown. If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the branch element to be the root for the new text
        htmlText - the string to be parsed and assigned to elem
        抛出：
        IllegalArgumentException - if elem is a leaf
        IllegalStateException - if an HTMLEditorKit.Parser has not been set on the document
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • insertBeforeEnd

        public void insertBeforeEnd(Element elem,
                   String htmlText)
                     throws BadLocationException,
                            IOException
        Inserts the HTML specified as a string at the end of the element.

        If elem's children are leaves, and the character at a elem.getEndOffset() - 1 is a newline, this will insert before the newline so that there isn't text after the newline.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking insertBeforeEnd(elem, "<ul><li>") results in the following structure (new elements are in red).

                <body>
          |
        <div>
       /  |  \
     <p> <p> <ul>
               \
               <li>

        Unlike the insertAfterEnd method, new elements become children of the specified element, not siblings.

        Parameter elem must not be a leaf element, otherwise an IllegalArgumentException is thrown. If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the element to be the root for the new text
        htmlText - the string to be parsed and assigned to elem
        抛出：
        IllegalArgumentException - if elem is a leaf
        IllegalStateException - if an HTMLEditorKit.Parser has not been set on the document
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • insertBeforeStart

        public void insertBeforeStart(Element elem,
                     String htmlText)
                       throws BadLocationException,
                              IOException
        Inserts the HTML specified as a string before the start of the given element.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking insertBeforeStart(elem, "<ul><li>") results in the following structure (new elements are in red).

                <body>
         /  \
      <ul> <div>
       /    /  \
     <li> <p>  <p>

        Unlike the insertAfterStart method, new elements become siblings of the specified element, not children.

        If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the element the content is inserted before
        htmlText - the string to be parsed and inserted before elem
        抛出：
        IllegalStateException - if an HTMLEditorKit.Parser has not been set on the document
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • insertAfterEnd

        public void insertAfterEnd(Element elem,
                  String htmlText)
                    throws BadLocationException,
                           IOException
        Inserts the HTML specified as a string after the the end of the given element.

        Consider the following structure (the elem parameter is in bold).

             <body>
       |
     <div>
      /  \
    <p>   <p>

        Invoking insertAfterEnd(elem, "<ul><li>") results in the following structure (new elements are in red).

                <body>
         /  \
      <div> <ul>
       / \    \
     <p> <p>  <li>

        Unlike the insertBeforeEnd method, new elements become siblings of the specified element, not children.

        If either elem or htmlText parameter is null, no changes are made to the document.

        For this to work correcty, the document must have an HTMLEditorKit.Parser set. This will be the case if the document was created from an HTMLEditorKit via the createDefaultDocument method.

        参数：
        elem - the element the content is inserted after
        htmlText - the string to be parsed and inserted after elem
        抛出：
        IllegalStateException - if an HTMLEditorKit.Parser has not been set on the document
        BadLocationException
        IOException
        从以下版本开始：
        1.3

      • getElement

        public Element getElement(String id)
        Returns the element that has the given id Attribute. If the element can't be found, null is returned. Note that this method works on an Attribute, not a character tag. In the following HTML snippet: <a id="HelloThere"> the attribute is 'id' and the character tag is 'a'. This is a convenience method for getElement(RootElement, HTML.Attribute.id, id). This is not thread-safe.
        参数：
        id - the string representing the desired Attribute
        返回：
        the element with the specified Attribute or null if it can't be found, or null if id is null
        从以下版本开始：
        1.3
        另请参见：
        HTML.Attribute

      • getElement

        public Element getElement(Element e,
                 Object attribute,
                 Object value)
        Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found. This is not thread-safe.
        参数：
        e - the root element where the search begins
        attribute - the desired Attribute
        value - the values for the specified Attribute
        返回：
        the element with the specified Attribute and the specified value, or null if it can't be found
        从以下版本开始：
        1.3
        另请参见：
        HTML.Attribute

      • fireChangedUpdate

        protected void fireChangedUpdate(DocumentEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        重载：
        fireChangedUpdate in class AbstractDocument
        参数：
        e - the event
        另请参见：
        EventListenerList

      • fireUndoableEditUpdate

        protected void fireUndoableEditUpdate(UndoableEditEvent e)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        重载：
        fireUndoableEditUpdate in class AbstractDocument
        参数：
        e - the event
        另请参见：
        EventListenerList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTMLDocument.BlockElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.BlockElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.html.HTMLDocument.BlockElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    封闭类：
    HTMLDocument

    public class HTMLDocument.BlockElement
extends AbstractDocument.BranchElement
    An element that represents a structural block of HTML.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.BlockElement(Element parent, AttributeSet a)
      Constructs a composite element that initially contains no children.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Gets the name of the element.
      AttributeSet getResolveParent()
      Gets the resolving parent.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.BranchElement

        children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, positionToElement, replace, toString

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.AbstractElement

        addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.BlockElement

        public HTMLDocument.BlockElement(Element parent,
                         AttributeSet a)
        Constructs a composite element that initially contains no children.
        参数：
        parent - the parent element
        a - the attributes for the element
        从以下版本开始：
        1.4

    • 方法详细信息

      • getName

        public String getName()
        Gets the name of the element.
        指定者：
        getName in interface Element
        重载：
        getName in class AbstractDocument.BranchElement
        返回：
        the name, null if none

      • getResolveParent

        public AttributeSet getResolveParent()
        Gets the resolving parent. HTML attributes are not inherited at the model level so we override this to return null.
        指定者：
        getResolveParent in interface AttributeSet
        重载：
        getResolveParent in class AbstractDocument.AbstractElement
        返回：
        null, there are none
        另请参见：
        AttributeSet.getResolveParent()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oosncli n. pssLn.)/r=tvs>/tto贬/La


HTMLDocument.HTMLReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
  • 封闭类：
    HTMLDocument

    public class HTMLDocument.HTMLReader
extends HTMLEditorKit.ParserCallback
    An HTML reader to load an HTML document with an HTML element structure. This is a set of callbacks from the parser, implemented to create a set of elements tagged with attributes. The parse builds up tokens (ElementSpec) that describe the element subtree desired, and burst it into the document under the protection of a write lock using the insert method on the document outer class.

    The reader can be configured by registering actions (of type HTMLDocument.HTMLReader.TagAction) that describe how to handle the action. The idea behind the actions provided is that the most natural text editing operations can be provided if the element structure boils down to paragraphs with runs of some kind of style in them. Some things are more naturally specified structurally, so arbitrary structure should be allowed above the paragraphs, but will need to be edited with structural actions. The implication of this is that some of the HTML elements specified in the stream being parsed will be collapsed into attributes, and in some cases paragraphs will be synthesized. When HTML elements have been converted to attributes, the attribute key will be of type HTML.Tag, and the value will be of type AttributeSet so that no information is lost. This enables many of the existing actions to work so that the user can type input, hit the return key, backspace, delete, etc and have a reasonable result. Selections can be created, and attributes applied or removed, etc. With this in mind, the work done by the reader can be categorized into the following kinds of tasks:

    Block
    Build the structure like it's specified in the stream. This produces elements that contain other elements.
    Paragraph
    Like block except that it's expected that the element will be used with a paragraph view so a paragraph element won't need to be synthesized.
    Character
    Contribute the element as an attribute that will start and stop at arbitrary text locations. This will ultimately be mixed into a run of text, with all of the currently flattened HTML character elements.
    Special
    Produce an embedded graphical element.
    Form
    Produce an element that is like the embedded graphical element, except that it also has a component model associated with it.
    Hidden
    Create an element that is hidden from view when the document is being viewed read-only, and visible when the document is being edited. This is useful to keep the model from losing information, and used to store things like comments and unrecognized tags.

    Currently, <APPLET>, <PARAM>, <MAP>, <AREA>, <LINK>, <SCRIPT> and <STYLE> are unsupported.

    The assignment of the actions described is shown in the following table for the tags defined in HTML.Tag.

    Tag | Action
    HTML.Tag.A | CharacterAction
    HTML.Tag.ADDRESS | CharacterAction
    HTML.Tag.APPLET | HiddenAction
    HTML.Tag.AREA | AreaAction
    HTML.Tag.B | CharacterAction
    HTML.Tag.BASE | BaseAction
    HTML.Tag.BASEFONT | CharacterAction
    HTML.Tag.BIG | CharacterAction
    HTML.Tag.BLOCKQUOTE | BlockAction
    HTML.Tag.BODY | BlockAction
    HTML.Tag.BR | SpecialAction
    HTML.Tag.CAPTION | BlockAction
    HTML.Tag.CENTER | BlockAction
    HTML.Tag.CITE | CharacterAction
    HTML.Tag.CODE | CharacterAction
    HTML.Tag.DD | BlockAction
    HTML.Tag.DFN | CharacterAction
    HTML.Tag.DIR | BlockAction
    HTML.Tag.DIV | BlockAction
    HTML.Tag.DL | BlockAction
    HTML.Tag.DT | ParagraphAction
    HTML.Tag.EM | CharacterAction
    HTML.Tag.FONT | CharacterAction
    HTML.Tag.FORM | As of 1.4 a BlockAction
    HTML.Tag.FRAME | SpecialAction
    HTML.Tag.FRAMESET | BlockAction
    HTML.Tag.H1 | ParagraphAction
    HTML.Tag.H2 | ParagraphAction
    HTML.Tag.H3 | ParagraphAction
    HTML.Tag.H4 | ParagraphAction
    HTML.Tag.H5 | ParagraphAction
    HTML.Tag.H6 | ParagraphAction
    HTML.Tag.HEAD | HeadAction
    HTML.Tag.HR | SpecialAction
    HTML.Tag.HTML | BlockAction
    HTML.Tag.I | CharacterAction
    HTML.Tag.IMG | SpecialAction
    HTML.Tag.INPUT | FormAction
    HTML.Tag.ISINDEX | IsndexAction
    HTML.Tag.KBD | CharacterAction
    HTML.Tag.LI | BlockAction
    HTML.Tag.LINK | LinkAction
    HTML.Tag.MAP | MapAction
    HTML.Tag.MENU | BlockAction
    HTML.Tag.META | MetaAction
    HTML.Tag.NOFRAMES | BlockAction
    HTML.Tag.OBJECT | SpecialAction
    HTML.Tag.OL | BlockAction
    HTML.Tag.OPTION | FormAction
    HTML.Tag.P | ParagraphAction
    HTML.Tag.PARAM | HiddenAction
    HTML.Tag.PRE | PreAction
    HTML.Tag.SAMP | CharacterAction
    HTML.Tag.SCRIPT | HiddenAction
    HTML.Tag.SELECT | FormAction
    HTML.Tag.SMALL | CharacterAction
    HTML.Tag.STRIKE | CharacterAction
    HTML.Tag.S | CharacterAction
    HTML.Tag.STRONG | CharacterAction
    HTML.Tag.STYLE | StyleAction
    HTML.Tag.SUB | CharacterAction
    HTML.Tag.SUP | CharacterAction
    HTML.Tag.TABLE | BlockAction
    HTML.Tag.TD | BlockAction
    HTML.Tag.TEXTAREA | FormAction
    HTML.Tag.TH | BlockAction
    HTML.Tag.TITLE | TitleAction
    HTML.Tag.TR | BlockAction
    HTML.Tag.TT | CharacterAction
    HTML.Tag.U | CharacterAction
    HTML.Tag.UL | BlockAction
    HTML.Tag.VAR | CharacterAction

    Once </html> is encountered, the Actions are no longer notified.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 | 类与描述
      class  | HTMLDocument.HTMLReader.BlockAction
      class  | HTMLDocument.HTMLReader.CharacterAction
      class  HTMLDocument.HTMLReader.FormAction
      Action to support forms by building all of the elements used to represent form controls.
      class  | HTMLDocument.HTMLReader.HiddenAction
      class  | HTMLDocument.HTMLReader.IsindexAction
      class  | HTMLDocument.HTMLReader.ParagraphAction
      class  | HTMLDocument.HTMLReader.PreAction
      class  | HTMLDocument.HTMLReader.SpecialAction
      class  HTMLDocument.HTMLReader.TagAction
      An action to be performed in response to parsing a tag.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected MutableAttributeSet | charAttr
      protected Vector<DefaultStyledDocument.ElementSpec> | parseBuffer

      • Fields inherited from class javax.swing.text.html.HTMLEditorKit.ParserCallback

        IMPLIED

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader(int offset)
      HTMLDocument.HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void addContent(char[] data, int offs, int length)
      Adds some text with the current character attributes.
      protected void addContent(char[] data, int offs, int length, boolean generateImpliedPIfNecessary)
      Adds some text with the current character attributes.
      protected void addSpecialElement(HTML.Tag t, MutableAttributeSet a)
      Adds content that is basically specified entirely in the attribute set.
      protected void blockClose(HTML.Tag t)
      Adds an instruction to the parse buffer to close out a block element of the given type.
      protected void blockOpen(HTML.Tag t, MutableAttributeSet attr)
      Adds an instruction to the parse buffer to create a block element with the given attributes.
      void flush()
      The last method called on the reader.
      void | handleComment(char[] data, int pos)
      void handleEndOfLineString(String eol)
      This is invoked after the stream has been parsed, but before flush.
      void handleEndTag(HTML.Tag t, int pos)
      Callback from the parser.
      void handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void handleText(char[] data, int pos)
      Called by the parser to indicate a block of text was encountered.
      protected void popCharacterStyle()
      Pops a previously pushed character style off the stack to return to a previous style.
      protected void preContent(char[] data)
      Adds the given content that was encountered in a PRE element.
      protected void pushCharacterStyle()
      Pushes the current character style on a stack in preparation for forming a new nested character style.
      protected void registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
      Registers a handler for the given tag.
      protected void textAreaContent(char[] data)
      Adds the given content to the textarea document.

      • 方法 - 继承于类 javax.swing.text.html.HTMLEditorKit.ParserCallback

        handleError

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • parseBuffer

        protected Vector<DefaultStyledDocument.ElementSpec> parseBuffer

      • charAttr

        protected MutableAttributeSet charAttr

    • 构造方法详细信息

      • HTMLDocument.HTMLReader

        public HTMLDocument.HTMLReader(int offset)

      • HTMLDocument.HTMLReader

        public HTMLDocument.HTMLReader(int offset,
                       int popDepth,
                       int pushDepth,
                       HTML.Tag insertTag)

    • 方法详细信息

      • flush

        public void flush()
           throws BadLocationException
        The last method called on the reader. It allows any pending changes to be flushed into the document. Since this is currently loading synchronously, the entire set of changes are pushed in at this point.
        重载：
        flush in class HTMLEditorKit.ParserCallback
        抛出：
        BadLocationException

      • handleText

        public void handleText(char[] data,
              int pos)
        Called by the parser to indicate a block of text was encountered.
        重载：
        handleText in class HTMLEditorKit.ParserCallback

      • handleStartTag

        public void handleStartTag(HTML.Tag t,
                  MutableAttributeSet a,
                  int pos)
        Callback from the parser. Route to the appropriate handler for the tag.
        重载：
        handleStartTag in class HTMLEditorKit.ParserCallback

      • handleComment

        public void handleComment(char[] data,
                 int pos)
        重载：
        handleComment in class HTMLEditorKit.ParserCallback

      • handleEndTag

        public void handleEndTag(HTML.Tag t,
                int pos)
        Callback from the parser. Route to the appropriate handler for the tag.
        重载：
        handleEndTag in class HTMLEditorKit.ParserCallback

      • handleSimpleTag

        public void handleSimpleTag(HTML.Tag t,
                   MutableAttributeSet a,
                   int pos)
        Callback from the parser. Route to the appropriate handler for the tag.
        重载：
        handleSimpleTag in class HTMLEditorKit.ParserCallback

      • handleEndOfLineString

        public void handleEndOfLineString(String eol)
        This is invoked after the stream has been parsed, but before flush. eol will be one of \n, \r or \r\n, which ever is encountered the most in parsing the stream.
        重载：
        handleEndOfLineString in class HTMLEditorKit.ParserCallback
        从以下版本开始：
        1.3

      • registerTag

        protected void registerTag(HTML.Tag t,
               HTMLDocument.HTMLReader.TagAction a)
        Registers a handler for the given tag. By default all of the well-known tags will have been registered. This can be used to change the handling of a particular tag or to add support for custom tags.

      • pushCharacterStyle

        protected void pushCharacterStyle()
        Pushes the current character style on a stack in preparation for forming a new nested character style.

      • popCharacterStyle

        protected void popCharacterStyle()
        Pops a previously pushed character style off the stack to return to a previous style.

      • textAreaContent

        protected void textAreaContent(char[] data)
        Adds the given content to the textarea document. This method gets called when we are in a textarea context. Therefore all text that is seen belongs to the text area and is hence added to the TextAreaDocument associated with the text area.

      • preContent

        protected void preContent(char[] data)
        Adds the given content that was encountered in a PRE element. This synthesizes lines to hold the runs of text, and makes calls to addContent to actually add the text.

      • blockOpen

        protected void blockOpen(HTML.Tag t,
             MutableAttributeSet attr)
        Adds an instruction to the parse buffer to create a block element with the given attributes.

      • blockClose

        protected void blockClose(HTML.Tag t)
        Adds an instruction to the parse buffer to close out a block element of the given type.

      • addContent

        protected void addContent(char[] data,
              int offs,
              int length)
        Adds some text with the current character attributes.
        参数：
        data - the content to add
        offs - the initial offset
        length - the length

      • addContent

        protected void addContent(char[] data,
              int offs,
              int length,
              boolean generateImpliedPIfNecessary)
        Adds some text with the current character attributes.
        参数：
        data - the content to add
        offs - the initial offset
        length - the length
        generateImpliedPIfNecessary - whether to generate implied paragraphs

      • addSpecialElement

        protected void addSpecialElement(HTML.Tag t,
                     MutableAttributeSet a)
        Adds content that is basically specified entirely in the attribute set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x


HTMLDocument.HTMLReader.BlockAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.BlockAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
  • 直接已知子类：
    HTMLDocument.HTMLReader.ParagraphAction, HTMLDocument.HTMLReader.PreAction
    封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.BlockAction
extends HTMLDocument.HTMLReader.TagAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.BlockAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet attr)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.BlockAction

        public HTMLDocument.HTMLReader.BlockAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet attr)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.TagAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i v wa=ra=p""=ppn ffhr h // 1aP roccgyi


HTMLDocument.HTMLReader.CharacterAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.CharacterAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.CharacterAction
extends HTMLDocument.HTMLReader.TagAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.CharacterAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet attr)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.CharacterAction

        public HTMLDocument.HTMLReader.CharacterAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet attr)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.TagAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nlciniiioiwhconplrc狸微澳　泵澡寄脑逶祝


HTMLDocument.HTMLReader.FormAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.FormAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.FormAction
extends HTMLDocument.HTMLReader.SpecialAction
    Action to support forms by building all of the elements used to represent form controls. This will process the <INPUT>, <TEXTAREA>, <SELECT>, and <OPTION> tags. The element created by this action is expected to have the attribute StyleConstants.ModelAttribute set to the model that holds the state for the form control. This enables multiple views, and allows document to be iterated over picking up the data of the form. The following are the model assignments for the various type of form elements.
    Element Type | Model Type
    input, type button | DefaultButtonModel
    input, type checkbox | JToggleButton.ToggleButtonModel
    input, type image | DefaultButtonModel
    input, type password | PlainDocument
    input, type radio | JToggleButton.ToggleButtonModel
    input, type reset | DefaultButtonModel
    input, type submit | DefaultButtonModel
    input, type text or type is null. | PlainDocument
    select | DefaultComboBoxModel or an DefaultListModel, with an item type of Option
    textarea | PlainDocument

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.FormAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet attr)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.FormAction

        public HTMLDocument.HTMLReader.FormAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet attr)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.SpecialAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

spxfa=he=vnete".nieDdi;to.xjR..cpnn


HTMLDocument.HTMLReader.HiddenAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.HiddenAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.HiddenAction
extends HTMLDocument.HTMLReader.TagAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.HiddenAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.HiddenAction

        public HTMLDocument.HTMLReader.HiddenAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet a)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.TagAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mdma=ph"ph rrh l>tt" saiLLttNia NteNi


HTMLDocument.HTMLReader.IsindexAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.IsindexAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.IsindexAction
extends HTMLDocument.HTMLReader.TagAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.IsindexAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

        end

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.IsindexAction

        public HTMLDocument.HTMLReader.IsindexAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet a)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

enamMD"LD"l>>"lltwssv/tvnssn//"h<>>o<


HTMLDocument.HTMLReader.ParagraphAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.ParagraphAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.ParagraphAction
extends HTMLDocument.HTMLReader.BlockAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.ParagraphAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.ParagraphAction

        public HTMLDocument.HTMLReader.ParagraphAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet a)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.BlockAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.BlockAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

avamr"d<>".n<.r�.vb


HTMLDocument.HTMLReader.PreAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.PreAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
  • 封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.PreAction
extends HTMLDocument.HTMLReader.BlockAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.PreAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet attr)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.PreAction

        public HTMLDocument.HTMLReader.PreAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet attr)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.BlockAction

      • end

        public void end(HTML.Tag t)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        end in class HTMLDocument.HTMLReader.BlockAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ff彼扑妓∷冕薄Ａ欲眔ɡ溃/bfr<


HTMLDocument.HTMLReader.SpecialAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.SpecialAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
  • 直接已知子类：
    HTMLDocument.HTMLReader.FormAction
    封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.SpecialAction
extends HTMLDocument.HTMLReader.TagAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.SpecialAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

        end

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.SpecialAction

        public HTMLDocument.HTMLReader.SpecialAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet a)
        Description copied from class: HTMLDocument.HTMLReader.TagAction
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
        重载：
        start in class HTMLDocument.HTMLReader.TagAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=c" > i s llss=us << ;{ eel e l s lo


HTMLDocument.HTMLReader.TagAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.HTMLReader.TagAction

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
  • 直接已知子类：
    HTMLDocument.HTMLReader.BlockAction, HTMLDocument.HTMLReader.CharacterAction, HTMLDocument.HTMLReader.HiddenAction, HTMLDocument.HTMLReader.IsindexAction, HTMLDocument.HTMLReader.SpecialAction
    封闭类：
    HTMLDocument.HTMLReader

    public class HTMLDocument.HTMLReader.TagAction
extends Object
    An action to be performed in response to parsing a tag. This allows customization of how each tag is handled and avoids a large switch statement.

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.HTMLReader.TagAction()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.HTMLReader.TagAction

        public HTMLDocument.HTMLReader.TagAction()

    • 方法详细信息

      • start

        public void start(HTML.Tag t,
         MutableAttributeSet a)
        Called when a start tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.

      • end

        public void end(HTML.Tag t)
        Called when an end tag is seen for the type of tag this action was registered to. The tag argument indicates the actual tag for those actions that are shared across many tags. By default this does nothing and completely ignores the tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&N|e&s;|&s;e<<>.g&ryylsm|m穖m<


HTMLDocument.Iterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.Iterator

  • java.lang.Object
    • javax.swing.text.html.HTMLDocument.Iterator
  • 封闭类：
    HTMLDocument

    public abstract static class HTMLDocument.Iterator
extends Object
    An iterator to iterate over a particular type of tag. The iterator is not thread safe. If reliable access to the document is not already ensured by the context under which the iterator is being used, its use should be performed under the protection of Document.render.

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.Iterator()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract AttributeSet getAttributes()
      Return the attributes for this tag.
      abstract int getEndOffset()
      Returns the end of the range for which the current occurrence of the tag is defined and has the same attributes.
      abstract int getStartOffset()
      Returns the start of the range for which the current occurrence of the tag is defined and has the same attributes.
      abstract HTML.Tag getTag()
      Type of tag this iterator represents.
      abstract boolean isValid()
      Indicates if the iterator is currently representing an occurrence of a tag.
      abstract void 下一个()
      Move the iterator forward to the next occurrence of the tag it represents.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.Iterator

        public HTMLDocument.Iterator()

    • 方法详细信息

      • getAttributes

        public abstract AttributeSet getAttributes()
        Return the attributes for this tag.
        返回：
        the AttributeSet for this tag, or null if none can be found

      • getStartOffset

        public abstract int getStartOffset()
        Returns the start of the range for which the current occurrence of the tag is defined and has the same attributes.
        返回：
        the start of the range, or -1 if it can't be found

      • getEndOffset

        public abstract int getEndOffset()
        Returns the end of the range for which the current occurrence of the tag is defined and has the same attributes.
        返回：
        the end of the range

      • 下一个

        public abstract void next()
        Move the iterator forward to the next occurrence of the tag it represents.

      • isValid

        public abstract boolean isValid()
        Indicates if the iterator is currently representing an occurrence of a tag. If false there are no more tags for this iterator.
        返回：
        true if the iterator is currently representing an occurrence of a tag, otherwise returns false

      • getTag

        public abstract HTML.Tag getTag()
        Type of tag this iterator represents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g."x


HTMLDocument.RunElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLDocument.RunElement

  • java.lang.Object
    • javax.swing.text.AbstractDocument.AbstractElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
  • 所有已实现的接口：
    Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
    封闭类：
    HTMLDocument

    public class HTMLDocument.RunElement
extends AbstractDocument.LeafElement
    An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.swing.text.AttributeSet

        AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute

    • 字段摘要

      • 字段 - 继承于接口 javax.swing.text.AttributeSet

        NameAttribute, ResolveAttribute

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
      Constructs an element that represents content within the document (has no children).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Gets the name of the element.
      AttributeSet getResolveParent()
      Gets the resolving parent.

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.LeafElement

        children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, toString

      • 方法 - 继承于类 javax.swing.text.AbstractDocument.AbstractElement

        addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HTMLDocument.RunElement

        public HTMLDocument.RunElement(Element parent,
                       AttributeSet a,
                       int offs0,
                       int offs1)
        Constructs an element that represents content within the document (has no children).
        参数：
        parent - the parent element
        a - the element attributes
        offs0 - the start offset (must be at least 0)
        offs1 - the end offset (must be at least offs0)
        从以下版本开始：
        1.4

    • 方法详细信息

      • getName

        public String getName()
        Gets the name of the element.
        指定者：
        getName in interface Element
        重载：
        getName in class AbstractDocument.LeafElement
        返回：
        the name, null if none

      • getResolveParent

        public AttributeSet getResolveParent()
        Gets the resolving parent. HTML attributes are not inherited at the model level so we override this to return null.
        指定者：
        getResolveParent in interface AttributeSet
        重载：
        getResolveParent in class AbstractDocument.AbstractElement
        返回：
        null, there are none
        另请参见：
        AttributeSet.getResolveParent()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pa =err.a


HTMLEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit
  • 所有已实现的接口：
    Serializable, Cloneable, Accessible

    public class HTMLEditorKit
extends StyledEditorKit
implements Accessible
    The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit. Because HTML is a very popular format of content, some support is provided by default. The default support is provided by this class, which supports HTML version 3.2 (with some extensions), and is migrating toward version 4.0. The <applet> tag is not supported, but some support is provided for the <object> tag.

    There are several goals of the HTML EditorKit provided, that have an effect upon the way that HTML is modeled. These have influenced its design in a substantial way.

    Support editing
    It might seem fairly obvious that a plug-in for JEditorPane should provide editing support, but that fact has several design considerations. There are a substantial number of HTML documents that don't properly conform to an HTML specification. These must be normalized somewhat into a correct form if one is to edit them. Additionally, users don't like to be presented with an excessive amount of structure editing, so using traditional text editing gestures is preferred over using the HTML structure exactly as defined in the HTML document.

    The modeling of HTML is provided by the class HTMLDocument. Its documention describes the details of how the HTML is modeled. The editing support leverages heavily off of the text package.

    Extendable/Scalable
    To maximize the usefulness of this kit, a great deal of effort has gone into making it extendable. These are some of the features.
    1. The parser is replacable. The default parser is the Hot Java parser which is DTD based. A different DTD can be used, or an entirely different parser can be used. To change the parser, reimplement the getParser method. The default parser is dynamically loaded when first asked for, so the class files will never be loaded if an alternative parser is used. The default parser is in a separate package called parser below this package.
    2. The parser drives the ParserCallback, which is provided by HTMLDocument. To change the callback, subclass HTMLDocument and reimplement the createDefaultDocument method to return document that produces a different reader. The reader controls how the document is structured. Although the Document provides HTML support by default, there is nothing preventing support of non-HTML tags that result in alternative element structures.
    3. The default view of the models are provided as a hierarchy of View implementations, so one can easily customize how a particular element is displayed or add capabilities for new kinds of elements by providing new View implementations. The default set of views are provided by the HTMLFactory class. This can be easily changed by subclassing or replacing the HTMLFactory and reimplementing the getViewFactory method to return the alternative factory.
    4. The View implementations work primarily off of CSS attributes, which are kept in the views. This makes it possible to have multiple views mapped over the same model that appear substantially different. This can be especially useful for printing. For most HTML attributes, the HTML attributes are converted to CSS attributes for display. This helps make the View implementations more general purpose

    Asynchronous Loading
    Larger documents involve a lot of parsing and take some time to load. By default, this kit produces documents that will be loaded asynchronously if loaded using JEditorPane.setPage. This is controlled by a property on the document. The method createDefaultDocument can be overriden to change this. The batching of work is done by the HTMLDocument.HTMLReader class. The actual work is done by the DefaultStyledDocument and AbstractDocument classes in the text package.

    Customization from current LAF
    HTML provides a well known set of features without exactly specifying the display characteristics. Swing has a theme mechanism for its look-and-feel implementations. It is desirable for the look-and-feel to feed display characteristics into the HTML views. An user with poor vision for example would want high contrast and larger than typical fonts.

    The support for this is provided by the StyleSheet class. The presentation of the HTML can be heavily influenced by the setting of the StyleSheet property on the EditorKit.

    Not lossy
    An EditorKit has the ability to be read and save documents. It is generally the most pleasing to users if there is no loss of data between the two operation. The policy of the HTMLEditorKit will be to store things not recognized or not necessarily visible so they can be subsequently written out. The model of the HTML document should therefore contain all information discovered while reading the document. This is constrained in some ways by the need to support editing (i.e. incorrect documents sometimes must be normalized). The guiding principle is that information shouldn't be lost, but some might be synthesized to produce a more correct model or it might be rearranged.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  HTMLEditorKit.HTMLFactory
      A factory to build views for HTML.
      static class  HTMLEditorKit.HTMLTextAction
      An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
      static class  HTMLEditorKit.LinkController
      Class to watch the associated component and fire hyperlink events on it when appropriate.
      static class  HTMLEditorKit.Parser
      Interface to be supported by the parser.
      static class  HTMLEditorKit.ParserCallback
      The result of parsing drives these callback methods.

      • Nested classes/interfaces inherited from class javax.swing.text.StyledEditorKit

        StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultEditorKit

        DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String BOLD_ACTION
      The bold action identifier
      static String COLOR_ACTION
      The Color choice action identifier The color is passed as an argument
      static String DEFAULT_CSS
      Default Cascading Style Sheet file that sets up the tag views.
      static String FONT_CHANGE_BIGGER
      The font size increase to next value action identifier
      static String FONT_CHANGE_SMALLER
      The font size decrease to next value action identifier
      static String IMG_ALIGN_BOTTOM
      Align images at the bottom.
      static String IMG_ALIGN_MIDDLE
      Align images in the middle.
      static String IMG_ALIGN_TOP
      Align images at the top.
      static String IMG_BORDER
      Align images at the border.
      static String ITALIC_ACTION
      The italic action identifier
      static String LOGICAL_STYLE_ACTION
      The logical style choice action identifier The logical style is passed in as an argument
      static String PARA_INDENT_LEFT
      The paragraph left indent action identifier
      static String PARA_INDENT_RIGHT
      The paragraph right indent action identifier

      • Fields inherited from class javax.swing.text.DefaultEditorKit

        backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit()
      Constructs an HTMLEditorKit, creates a StyleContext, and loads the style sheet.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object clone()
      Creates a copy of the editor kit.
      Document createDefaultDocument()
      Create an uninitialized text storage model that is appropriate for this type of editor.
      protected void createInputAttributes(Element element, MutableAttributeSet set)
      Copies the key/values in elements AttributeSet into set.
      void deinstall(JEditorPane c)
      Called when the kit is being removed from the JEditorPane.
      AccessibleContext getAccessibleContext()
      returns the AccessibleContext associated with this editor kit
      Action[] getActions()
      Fetches the command list for the editor.
      String getContentType()
      Get the MIME type of the data that this kit represents support for.
      Cursor getDefaultCursor()
      Returns the default cursor.
      MutableAttributeSet getInputAttributes()
      Gets the input attributes used for the styled editing actions.
      Cursor getLinkCursor()
      Returns the cursor to use over hyper links.
      protected HTMLEditorKit.Parser getParser()
      Fetch the parser to use for reading HTML streams.
      StyleSheet getStyleSheet()
      Get the set of styles currently being used to render the HTML elements.
      ViewFactory getViewFactory()
      Fetch a factory that is suitable for producing views of any models that are produced by this kit.
      void insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      void install(JEditorPane c)
      Called when the kit is being installed into the a JEditorPane.
      boolean isAutoFormSubmission()
      Indicates whether an html form submission is processed automatically or only FormSubmitEvent is fired.
      void read(Reader in, Document doc, int pos)
      Inserts content from the given stream.
      void setAutoFormSubmission(boolean isAuto)
      Specifies if an html form submission is processed automatically or only FormSubmitEvent is fired.
      void setDefaultCursor(Cursor cursor)
      Sets the default cursor.
      void setLinkCursor(Cursor cursor)
      Sets the cursor to use over links.
      void setStyleSheet(StyleSheet s)
      Set the set of styles to be used to render the various HTML elements.
      void write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit

        getCharacterAttributeRun

      • 方法 - 继承于类 javax.swing.text.DefaultEditorKit

        createCaret, read, write

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_CSS

        public static final String DEFAULT_CSS
        Default Cascading Style Sheet file that sets up the tag views.
        另请参见：
        Constant Field Values

      • BOLD_ACTION

        public static final String BOLD_ACTION
        The bold action identifier
        另请参见：
        Constant Field Values

      • ITALIC_ACTION

        public static final String ITALIC_ACTION
        The italic action identifier
        另请参见：
        Constant Field Values

      • PARA_INDENT_LEFT

        public static final String PARA_INDENT_LEFT
        The paragraph left indent action identifier
        另请参见：
        Constant Field Values

      • PARA_INDENT_RIGHT

        public static final String PARA_INDENT_RIGHT
        The paragraph right indent action identifier
        另请参见：
        Constant Field Values

      • FONT_CHANGE_BIGGER

        public static final String FONT_CHANGE_BIGGER
        The font size increase to next value action identifier
        另请参见：
        Constant Field Values

      • FONT_CHANGE_SMALLER

        public static final String FONT_CHANGE_SMALLER
        The font size decrease to next value action identifier
        另请参见：
        Constant Field Values

      • COLOR_ACTION

        public static final String COLOR_ACTION
        The Color choice action identifier The color is passed as an argument
        另请参见：
        Constant Field Values

      • LOGICAL_STYLE_ACTION

        public static final String LOGICAL_STYLE_ACTION
        The logical style choice action identifier The logical style is passed in as an argument
        另请参见：
        Constant Field Values

      • IMG_ALIGN_TOP

        public static final String IMG_ALIGN_TOP
        Align images at the top.
        另请参见：
        Constant Field Values

      • IMG_ALIGN_MIDDLE

        public static final String IMG_ALIGN_MIDDLE
        Align images in the middle.
        另请参见：
        Constant Field Values

      • IMG_ALIGN_BOTTOM

        public static final String IMG_ALIGN_BOTTOM
        Align images at the bottom.
        另请参见：
        Constant Field Values

      • IMG_BORDER

        public static final String IMG_BORDER
        Align images at the border.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • HTMLEditorKit

        public HTMLEditorKit()
        Constructs an HTMLEditorKit, creates a StyleContext, and loads the style sheet.

    • 方法详细信息

      • getContentType

        public String getContentType()
        Get the MIME type of the data that this kit represents support for. This kit supports the type text/html.
        重载：
        getContentType in class DefaultEditorKit
        返回：
        the type

      • getViewFactory

        public ViewFactory getViewFactory()
        Fetch a factory that is suitable for producing views of any models that are produced by this kit.
        重载：
        getViewFactory in class StyledEditorKit
        返回：
        the factory

      • createDefaultDocument

        public Document createDefaultDocument()
        Create an uninitialized text storage model that is appropriate for this type of editor.
        重载：
        createDefaultDocument in class StyledEditorKit
        返回：
        the model

      • read

        public void read(Reader in,
        Document doc,
        int pos)
          throws IOException,
                 BadLocationException
        Inserts content from the given stream. If doc is an instance of HTMLDocument, this will read HTML 3.2 text. Inserting HTML into a non-empty document must be inside the body Element, if you do not insert into the body an exception will be thrown. When inserting into a non-empty document all tags outside of the body (head, title) will be dropped.
        重载：
        read in class DefaultEditorKit
        参数：
        in - the stream to read from
        doc - the destination for the insertion
        pos - the location in the document to place the content
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document
        RuntimeException - (will eventually be a BadLocationException) if pos is invalid

      • insertHTML

        public void insertHTML(HTMLDocument doc,
              int offset,
              String html,
              int popDepth,
              int pushDepth,
              HTML.Tag insertTag)
                throws BadLocationException,
                       IOException
        Inserts HTML into an existing document.
        参数：
        doc - the document to insert into
        offset - the offset to insert HTML at
        popDepth - the number of ElementSpec.EndTagTypes to generate before inserting
        pushDepth - the number of ElementSpec.StartTagTypes with a direction of ElementSpec.JoinNextDirection that should be generated before inserting, but after the end tags have been generated
        insertTag - the first tag to start inserting into document
        抛出：
        RuntimeException - (will eventually be a BadLocationException) if pos is invalid
        BadLocationException
        IOException

      • write

        public void write(Writer out,
         Document doc,
         int pos,
         int len)
           throws IOException,
                  BadLocationException
        Write content from a document to the given stream in a format appropriate for this kind of content handler.
        重载：
        write in class DefaultEditorKit
        参数：
        out - the stream to write to
        doc - the source for the write
        pos - the location in the document to fetch the content
        len - the amount to write out
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document

      • install

        public void install(JEditorPane c)
        Called when the kit is being installed into the a JEditorPane.
        重载：
        install in class StyledEditorKit
        参数：
        c - the JEditorPane

      • deinstall

        public void deinstall(JEditorPane c)
        Called when the kit is being removed from the JEditorPane. This is used to unregister any listeners that were attached.
        重载：
        deinstall in class StyledEditorKit
        参数：
        c - the JEditorPane

      • setStyleSheet

        public void setStyleSheet(StyleSheet s)
        Set the set of styles to be used to render the various HTML elements. These styles are specified in terms of CSS specifications. Each document produced by the kit will have a copy of the sheet which it can add the document specific styles to. By default, the StyleSheet specified is shared by all HTMLEditorKit instances. This should be reimplemented to provide a finer granularity if desired.

      • getStyleSheet

        public StyleSheet getStyleSheet()
        Get the set of styles currently being used to render the HTML elements. By default the resource specified by DEFAULT_CSS gets loaded, and is shared by all HTMLEditorKit instances.

      • getActions

        public Action[] getActions()
        Fetches the command list for the editor. This is the list of commands supported by the superclass augmented by the collection of commands defined locally for style operations.
        重载：
        getActions in class StyledEditorKit
        返回：
        the command list

      • createInputAttributes

        protected void createInputAttributes(Element element,
                         MutableAttributeSet set)
        Copies the key/values in elements AttributeSet into set. This does not copy component, icon, or element names attributes. Subclasses may wish to refine what is and what isn't copied here. But be sure to first remove all the attributes that are in set.

        This is called anytime the caret moves over a different location.

        重载：
        createInputAttributes in class StyledEditorKit

      • getInputAttributes

        public MutableAttributeSet getInputAttributes()
        Gets the input attributes used for the styled editing actions.
        重载：
        getInputAttributes in class StyledEditorKit
        返回：
        the attribute set

      • setDefaultCursor

        public void setDefaultCursor(Cursor cursor)
        Sets the default cursor.
        从以下版本开始：
        1.3

      • getDefaultCursor

        public Cursor getDefaultCursor()
        Returns the default cursor.
        从以下版本开始：
        1.3

      • setLinkCursor

        public void setLinkCursor(Cursor cursor)
        Sets the cursor to use over links.
        从以下版本开始：
        1.3

      • getLinkCursor

        public Cursor getLinkCursor()
        Returns the cursor to use over hyper links.
        从以下版本开始：
        1.3

      • isAutoFormSubmission

        public boolean isAutoFormSubmission()
        Indicates whether an html form submission is processed automatically or only FormSubmitEvent is fired.
        返回：
        true if html form submission is processed automatically, false otherwise.
        从以下版本开始：
        1.5
        另请参见：
        setAutoFormSubmission(boolean)

      • setAutoFormSubmission

        public void setAutoFormSubmission(boolean isAuto)
        Specifies if an html form submission is processed automatically or only FormSubmitEvent is fired. By default it is set to true.
        从以下版本开始：
        1.5
        另请参见：
        isAutoFormSubmission(), FormSubmitEvent

      • clone

        public Object clone()
        Creates a copy of the editor kit.
        重载：
        clone in class StyledEditorKit
        返回：
        the copy
        另请参见：
        Cloneable

      • getParser

        protected HTMLEditorKit.Parser getParser()
        Fetch the parser to use for reading HTML streams. This can be reimplemented to provide a different parser. The default implementation is loaded dynamically to avoid the overhead of loading the default parser if it's not used. The default parser is the HotJava parser using an HTML 3.2 DTD.

      • getAccessibleContext

        public AccessibleContext getAccessibleContext()
        returns the AccessibleContext associated with this editor kit
        指定者：
        getAccessibleContext in interface Accessible
        返回：
        the AccessibleContext associated with this editor kit
        从以下版本开始：
        1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTMLEditorKit.HTMLFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.HTMLFactory

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory
  • 所有已实现的接口：
    ViewFactory
    封闭类：
    HTMLEditorKit

    public static class HTMLEditorKit.HTMLFactory
extends Object
implements ViewFactory
    A factory to build views for HTML. The following table describes what this factory will build by default.
    Tag | View created
    HTML.Tag.CONTENT | InlineView
    HTML.Tag.IMPLIED | javax.swing.text.html.ParagraphView
    HTML.Tag.P | javax.swing.text.html.ParagraphView
    HTML.Tag.H1 | javax.swing.text.html.ParagraphView
    HTML.Tag.H2 | javax.swing.text.html.ParagraphView
    HTML.Tag.H3 | javax.swing.text.html.ParagraphView
    HTML.Tag.H4 | javax.swing.text.html.ParagraphView
    HTML.Tag.H5 | javax.swing.text.html.ParagraphView
    HTML.Tag.H6 | javax.swing.text.html.ParagraphView
    HTML.Tag.DT | javax.swing.text.html.ParagraphView
    HTML.Tag.MENU | ListView
    HTML.Tag.DIR | ListView
    HTML.Tag.UL | ListView
    HTML.Tag.OL | ListView
    HTML.Tag.LI | BlockView
    HTML.Tag.DL | BlockView
    HTML.Tag.DD | BlockView
    HTML.Tag.BODY | BlockView
    HTML.Tag.HTML | BlockView
    HTML.Tag.CENTER | BlockView
    HTML.Tag.DIV | BlockView
    HTML.Tag.BLOCKQUOTE | BlockView
    HTML.Tag.PRE | BlockView
    HTML.Tag.BLOCKQUOTE | BlockView
    HTML.Tag.PRE | BlockView
    HTML.Tag.IMG | ImageView
    HTML.Tag.HR | HRuleView
    HTML.Tag.BR | BRView
    HTML.Tag.TABLE | javax.swing.text.html.TableView
    HTML.Tag.INPUT | FormView
    HTML.Tag.SELECT | FormView
    HTML.Tag.TEXTAREA | FormView
    HTML.Tag.OBJECT | ObjectView
    HTML.Tag.FRAMESET | FrameSetView
    HTML.Tag.FRAME | FrameView

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.HTMLFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      View create(Element elem)
      Creates a view from an element.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLEditorKit.HTMLFactory

        public HTMLEditorKit.HTMLFactory()

    • 方法详细信息

      • create

        public View create(Element elem)
        Creates a view from an element.
        指定者：
        create in interface ViewFactory
        参数：
        elem - the element
        返回：
        the view
        另请参见：
        View
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vna.=.h".h rrh ndccroar <


HTMLEditorKit.HTMLTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.HTMLTextAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    直接已知子类：
    HTMLEditorKit.InsertHTMLTextAction
    封闭类：
    HTMLEditorKit

    public abstract static class HTMLEditorKit.HTMLTextAction
extends StyledEditorKit.StyledTextAction
    An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.

    NOTE: None of the convenience methods obtain a lock on the document. If you have another thread modifying the text these methods may have inconsistent behavior, or return the wrong thing.

    • 字段摘要

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.HTMLTextAction(String name)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected int elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
      protected Element findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      protected Element[] getElementsAt(HTMLDocument doc, int offset)
      Returns an array of the Elements that contain offset.
      protected HTMLDocument | getHTMLDocument(JEditorPane e)
      protected HTMLEditorKit | getHTMLEditorKit(JEditorPane e)

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 java.awt.event.ActionListener

        actionPerformed

    • 构造方法详细信息

      • HTMLEditorKit.HTMLTextAction

        public HTMLEditorKit.HTMLTextAction(String name)

    • 方法详细信息

      • getHTMLDocument

        protected HTMLDocument getHTMLDocument(JEditorPane e)
        返回：
        HTMLDocument of e.

      • getHTMLEditorKit

        protected HTMLEditorKit getHTMLEditorKit(JEditorPane e)
        返回：
        HTMLEditorKit for e.

      • getElementsAt

        protected Element[] getElementsAt(HTMLDocument doc,
                      int offset)
        Returns an array of the Elements that contain offset. The first elements corresponds to the root.

      • elementCountToTag

        protected int elementCountToTag(HTMLDocument doc,
                    int offset,
                    HTML.Tag tag)
        Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag. This will return -1 if no elements is found representing tag, or 0 if the parent of the leaf at offset represents tag.

      • findElementMatchingTag

        protected Element findElementMatchingTag(HTMLDocument doc,
                             int offset,
                             HTML.Tag tag)
        Returns the deepest element at offset matching tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sMPna ttmdbn"jenrn. iI"< .nj<


HTMLEditorKit.InsertHTMLTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.InsertHTMLTextAction

  • java.lang.Object
    • javax.swing.AbstractAction
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
  • 所有已实现的接口：
    ActionListener, Serializable, Cloneable, EventListener, Action
    封闭类：
    HTMLEditorKit

    public static class HTMLEditorKit.InsertHTMLTextAction
extends HTMLEditorKit.HTMLTextAction
    InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document. At least two HTML.Tags need to be supplied. The first Tag, parentTag, identifies the parent in the document to add the elements to. The second tag, addTag, identifies the first tag that should be added to the document as seen in the HTML string. One important thing to remember, is that the parser is going to generate all the appropriate tags, even if they aren't in the HTML string passed in.

    For example, lets say you wanted to create an action to insert a table into the body. The parentTag would be HTML.Tag.BODY, addTag would be HTML.Tag.TABLE, and the string could be something like <table><tr><td></td></tr></table>.

    There is also an option to supply an alternate parentTag and addTag. These will be checked for if there is no parentTag at offset.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected HTML.Tag addTag
      Tag in HTML to start adding tags from.
      protected HTML.Tag alternateAddTag
      Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.
      protected HTML.Tag alternateParentTag
      Alternate Tag to check for in the document if parentTag is not found.
      protected String html
      HTML to insert.
      protected HTML.Tag parentTag
      Tag to check for in the document.

      • Fields inherited from class javax.swing.AbstractAction

        changeSupport, enabled

      • 字段 - 继承于接口 javax.swing.Action

        ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
      HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void actionPerformed(ActionEvent ae)
      Inserts the HTML into the document.
      protected void insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      protected void insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.

      • 方法 - 继承于类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction

        elementCountToTag, findElementMatchingTag, getElementsAt, getHTMLDocument, getHTMLEditorKit

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit.StyledTextAction

        getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes

      • 方法 - 继承于类 javax.swing.text.TextAction

        augmentList, getFocusedComponent, getTextComponent

      • 方法 - 继承于类 javax.swing.AbstractAction

        addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • html

        protected String html
        HTML to insert.

      • parentTag

        protected HTML.Tag parentTag
        Tag to check for in the document.

      • addTag

        protected HTML.Tag addTag
        Tag in HTML to start adding tags from.

      • alternateParentTag

        protected HTML.Tag alternateParentTag
        Alternate Tag to check for in the document if parentTag is not found.

      • alternateAddTag

        protected HTML.Tag alternateAddTag
        Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.

    • 构造方法详细信息

      • HTMLEditorKit.InsertHTMLTextAction

        public HTMLEditorKit.InsertHTMLTextAction(String name,
                                  String html,
                                  HTML.Tag parentTag,
                                  HTML.Tag addTag)

      • HTMLEditorKit.InsertHTMLTextAction

        public HTMLEditorKit.InsertHTMLTextAction(String name,
                                  String html,
                                  HTML.Tag parentTag,
                                  HTML.Tag addTag,
                                  HTML.Tag alternateParentTag,
                                  HTML.Tag alternateAddTag)

    • 方法详细信息

      • insertHTML

        protected void insertHTML(JEditorPane editor,
              HTMLDocument doc,
              int offset,
              String html,
              int popDepth,
              int pushDepth,
              HTML.Tag addTag)
        A cover for HTMLEditorKit.insertHTML. If an exception it thrown it is wrapped in a RuntimeException and thrown.

      • insertAtBoundary

        protected void insertAtBoundary(JEditorPane editor,
                    HTMLDocument doc,
                    int offset,
                    Element insertElement,
                    String html,
                    HTML.Tag parentTag,
                    HTML.Tag addTag)
        This is invoked when inserting at a boundary. It determines the number of pops, and then the number of pushes that need to be performed, and then invokes insertHTML.
        从以下版本开始：
        1.3

      • insertAtBoundry

        @Deprecated
protected void insertAtBoundry(JEditorPane editor,
                              HTMLDocument doc,
                              int offset,
                              Element insertElement,
                              String html,
                              HTML.Tag parentTag,
                              HTML.Tag addTag)
        Deprecated. As of Java 2 platform v1.3, use insertAtBoundary
        This is invoked when inserting at a boundary. It determines the number of pops, and then the number of pushes that need to be performed, and then invokes insertHTML.

      • actionPerformed

        public void actionPerformed(ActionEvent ae)
        Inserts the HTML into the document.
        参数：
        ae - the event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HTMLEditorKit.LinkController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.LinkController

  • java.lang.Object
    • java.awt.event.MouseAdapter
      • javax.swing.text.html.HTMLEditorKit.LinkController
  • 所有已实现的接口：
    MouseListener, MouseMotionListener, MouseWheelListener, Serializable, EventListener
    封闭类：
    HTMLEditorKit

    public static class HTMLEditorKit.LinkController
extends MouseAdapter
implements MouseMotionListener, Serializable
    Class to watch the associated component and fire hyperlink events on it when appropriate.

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.LinkController()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void activateLink(int pos, JEditorPane editor)
      Calls linkActivated on the associated JEditorPane if the given position represents a link.
      void mouseClicked(MouseEvent e)
      Called for a mouse click event.
      void mouseDragged(MouseEvent e)
      Invoked when a mouse button is pressed on a component and then dragged.
      void mouseMoved(MouseEvent e)
      Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.

      • 方法 - 继承于类 java.awt.event.MouseAdapter

        mouseEntered, mouseExited, mousePressed, mouseReleased, mouseWheelMoved

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLEditorKit.LinkController

        public HTMLEditorKit.LinkController()

    • 方法详细信息

      • mouseClicked

        public void mouseClicked(MouseEvent e)
        Called for a mouse click event. If the component is read-only (ie a browser) then the clicked event is used to drive an attempt to follow the reference specified by a link.
        指定者：
        mouseClicked in interface MouseListener
        重载：
        mouseClicked in class MouseAdapter
        参数：
        e - the mouse event
        另请参见：
        MouseListener.mouseClicked(java.awt.event.MouseEvent)

      • mouseDragged

        public void mouseDragged(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when a mouse button is pressed on a component and then dragged. MOUSE_DRAGGED events will continue to be delivered to the component where the drag originated until the mouse button is released (regardless of whether the mouse position is within the bounds of the component).

        Due to platform-dependent Drag&Drop implementations, MOUSE_DRAGGED events may not be delivered during a native Drag&Drop operation.

        指定者：
        mouseDragged in interface MouseMotionListener
        重载：
        mouseDragged in class MouseAdapter

      • mouseMoved

        public void mouseMoved(MouseEvent e)
        Description copied from class: MouseAdapter
        Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
        指定者：
        mouseMoved in interface MouseMotionListener
        重载：
        mouseMoved in class MouseAdapter

      • activateLink

        protected void activateLink(int pos,
                JEditorPane editor)
        Calls linkActivated on the associated JEditorPane if the given position represents a link.

        This is implemented to forward to the method with the same name, but with the following args both == -1.

        参数：
        pos - the position
        editor - the editor pane
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e. a,a>,aTggaTTceTTgtaij((sgtvnag ,,m.tT(a


HTMLEditorKit.Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.Parser

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.Parser
  • 直接已知子类：
    ParserDelegator
    封闭类：
    HTMLEditorKit

    public abstract static class HTMLEditorKit.Parser
extends Object
    Interface to be supported by the parser. This enables providing a different parser while reusing some of the implementation provided by this editor kit.

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.Parser()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLEditorKit.Parser

        public HTMLEditorKit.Parser()

    • 方法详细信息

      • parse

        public abstract void parse(Reader r,
         HTMLEditorKit.ParserCallback cb,
         boolean ignoreCharSet)
                    throws IOException
        Parse the given stream and drive the given callback with the results of the parse. This method should be implemented to be thread-safe.
        抛出：
        IOException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

saevMueouevnnevvaellre/<<>>>>v//l


HTMLEditorKit.ParserCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLEditorKit.ParserCallback

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
  • 直接已知子类：
    HTMLDocument.HTMLReader
    封闭类：
    HTMLEditorKit

    public static class HTMLEditorKit.ParserCallback
extends Object
    The result of parsing drives these callback methods. The open and close actions should be balanced. The flush method will be the last method called, to give the receiver a chance to flush any pending data into the document.

    Refer to DocumentParser, the default parser used, for further information on the contents of the AttributeSets, the positions, and other info.

    另请参见：
    DocumentParser

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Object IMPLIED
      This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLEditorKit.ParserCallback()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void | flush()
      void | handleComment(char[] data, int pos)
      void handleEndOfLineString(String eol)
      This is invoked after the stream has been parsed, but before flush.
      void | handleEndTag(HTML.Tag t, int pos)
      void | handleError(String errorMsg, int pos)
      void | handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void | handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void | handleText(char[] data, int pos)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IMPLIED

        public static final Object IMPLIED
        This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.
        从以下版本开始：
        1.3

    • 构造方法详细信息

      • HTMLEditorKit.ParserCallback

        public HTMLEditorKit.ParserCallback()

    • 方法详细信息

      • flush

        public void flush()
           throws BadLocationException
        抛出：
        BadLocationException

      • handleText

        public void handleText(char[] data,
              int pos)

      • handleComment

        public void handleComment(char[] data,
                 int pos)

      • handleStartTag

        public void handleStartTag(HTML.Tag t,
                  MutableAttributeSet a,
                  int pos)

      • handleEndTag

        public void handleEndTag(HTML.Tag t,
                int pos)

      • handleSimpleTag

        public void handleSimpleTag(HTML.Tag t,
                   MutableAttributeSet a,
                   int pos)

      • handleError

        public void handleError(String errorMsg,
               int pos)

      • handleEndOfLineString

        public void handleEndOfLineString(String eol)
        This is invoked after the stream has been parsed, but before flush. eol will be one of \n, \r or \r\n, which ever is encountered the most in parsing the stream.
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tw&ert> trpeerpphd->..n)s)Pa />l a>>r/t=


HTMLFrameHyperlinkEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLFrameHyperlinkEvent

  • java.lang.Object
    • java.util.EventObject
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    FormSubmitEvent

    public class HTMLFrameHyperlinkEvent
extends HyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.event.HyperlinkEvent

        HyperlinkEvent.EventType

    • 字段摘要

      • Fields inherited from class java.util.EventObject

        source

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
      Creates a new object representing a html frame hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, InputEvent inputEvent, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
      Creates a new object representing a hypertext link event.
      HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
      Creates a new object representing a hypertext link event.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getTarget()
      returns the target for the link.

      • 方法 - 继承于类 javax.swing.event.HyperlinkEvent

        getDescription, getEventType, getInputEvent, getSourceElement, getURL

      • 方法 - 继承于类 java.util.EventObject

        getSource, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                       HyperlinkEvent.EventType type,
                       URL targetURL,
                       String targetFrame)
        Creates a new object representing a html frame hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                       HyperlinkEvent.EventType type,
                       URL targetURL,
                       String desc,
                       String targetFrame)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a description
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                       HyperlinkEvent.EventType type,
                       URL targetURL,
                       Element sourceElement,
                       String targetFrame)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        sourceElement - the element that corresponds to the source of the event
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                       HyperlinkEvent.EventType type,
                       URL targetURL,
                       String desc,
                       Element sourceElement,
                       String targetFrame)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a desription
        sourceElement - the element that corresponds to the source of the event
        targetFrame - the Frame to display the document in

      • HTMLFrameHyperlinkEvent

        public HTMLFrameHyperlinkEvent(Object source,
                       HyperlinkEvent.EventType type,
                       URL targetURL,
                       String desc,
                       Element sourceElement,
                       InputEvent inputEvent,
                       String targetFrame)
        Creates a new object representing a hypertext link event.
        参数：
        source - the object responsible for the event
        type - the event type
        targetURL - the affected URL
        desc - a desription
        sourceElement - the element that corresponds to the source of the event
        inputEvent - InputEvent that triggered the hyperlink event
        targetFrame - the Frame to display the document in
        从以下版本开始：
        1.7

    • 方法详细信息

      • getTarget

        public String getTarget()
        returns the target for the link.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i>oN n"N=mnped no v><;rNl>hci tr�


HTMLWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 HTMLWriter

  • java.lang.Object
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter

  • public class HTMLWriter
extends AbstractWriter
    This is a writer for HTMLDocuments.

    • 字段摘要

      • Fields inherited from class javax.swing.text.AbstractWriter

        NEWLINE

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTMLWriter(Writer w, HTMLDocument doc)
      Creates a new HTMLWriter.
      HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
      Creates a new HTMLWriter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void closeOutUnwantedEmbeddedTags(AttributeSet attr)
      Searches the attribute set and for each tag that is stored in the tag vector.
      protected void comment(Element elem)
      Writes out comments.
      protected void emptyTag(Element elem)
      Writes out all empty elements (all tags that have no corresponding end tag).
      protected void endTag(Element elem)
      Writes out an end tag for the element.
      protected boolean isBlockTag(AttributeSet attr)
      Determines if the HTML.Tag associated with the element is a block tag.
      protected boolean matchNameAttribute(AttributeSet attr, HTML.Tag tag)
      Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
      protected void output(char[] chars, int start, int length)
      This method is overriden to map any character entities, such as < to &lt;.
      protected void selectContent(AttributeSet attr)
      Writes out the content of the SELECT form element.
      protected void startTag(Element elem)
      Writes out a start tag for the element.
      protected boolean synthesizedElement(Element elem)
      Returns true if the element is a synthesized element.
      protected void text(Element elem)
      Writes out text.
      protected void textAreaContent(AttributeSet attr)
      Writes out text that is contained in a TEXTAREA form element.
      void write()
      Iterates over the Element tree and controls the writing out of all the tags and its attributes.
      protected void writeAttributes(AttributeSet attr)
      Writes out the attribute set.
      protected void writeEmbeddedTags(AttributeSet attr)
      Searches for embedded tags in the AttributeSet and writes them out.
      protected void writeLineSeparator()
      Writes the line separator.
      protected void writeOption(Option option)
      Writes out the content of the Option form element.

      • 方法 - 继承于类 javax.swing.text.AbstractWriter

        decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HTMLWriter

        public HTMLWriter(Writer w,
          HTMLDocument doc)
        Creates a new HTMLWriter.
        参数：
        w - a Writer
        doc - an HTMLDocument

      • HTMLWriter

        public HTMLWriter(Writer w,
          HTMLDocument doc,
          int pos,
          int len)
        Creates a new HTMLWriter.
        参数：
        w - a Writer
        doc - an HTMLDocument
        pos - the document location from which to fetch the content
        len - the amount to write out

    • 方法详细信息

      • write

        public void write()
           throws IOException,
                  BadLocationException
        Iterates over the Element tree and controls the writing out of all the tags and its attributes.
        指定者：
        write in class AbstractWriter
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeAttributes

        protected void writeAttributes(AttributeSet attr)
                        throws IOException
        Writes out the attribute set. Ignores all attributes with a key of type HTML.Tag, attributes with a key of type StyleConstants, and attributes with a key of type HTML.Attribute.ENDTAG.
        重载：
        writeAttributes in class AbstractWriter
        参数：
        attr - an AttributeSet
        抛出：
        IOException - on any I/O error

      • emptyTag

        protected void emptyTag(Element elem)
                 throws BadLocationException,
                        IOException
        Writes out all empty elements (all tags that have no corresponding end tag).
        参数：
        elem - an Element
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • isBlockTag

        protected boolean isBlockTag(AttributeSet attr)
        Determines if the HTML.Tag associated with the element is a block tag.
        参数：
        attr - an AttributeSet
        返回：
        true if tag is block tag, false otherwise.

      • startTag

        protected void startTag(Element elem)
                 throws IOException,
                        BadLocationException
        Writes out a start tag for the element. Ignores all synthesized elements.
        参数：
        elem - an Element
        抛出：
        IOException - on any I/O error
        BadLocationException

      • textAreaContent

        protected void textAreaContent(AttributeSet attr)
                        throws BadLocationException,
                               IOException
        Writes out text that is contained in a TEXTAREA form element.
        参数：
        attr - an AttributeSet
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • text

        protected void text(Element elem)
             throws BadLocationException,
                    IOException
        Writes out text. If a range is specified when the constructor is invoked, then only the appropriate range of text is written out.
        重载：
        text in class AbstractWriter
        参数：
        elem - an Element
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • selectContent

        protected void selectContent(AttributeSet attr)
                      throws IOException
        Writes out the content of the SELECT form element.
        参数：
        attr - the AttributeSet associated with the form element
        抛出：
        IOException - on any I/O error

      • writeOption

        protected void writeOption(Option option)
                    throws IOException
        Writes out the content of the Option form element.
        参数：
        option - an Option
        抛出：
        IOException - on any I/O error

      • endTag

        protected void endTag(Element elem)
               throws IOException
        Writes out an end tag for the element.
        参数：
        elem - an Element
        抛出：
        IOException - on any I/O error

      • comment

        protected void comment(Element elem)
                throws BadLocationException,
                       IOException
        Writes out comments.
        参数：
        elem - an Element
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • synthesizedElement

        protected boolean synthesizedElement(Element elem)
        Returns true if the element is a synthesized element. Currently we are only testing for the p-implied tag.

      • matchNameAttribute

        protected boolean matchNameAttribute(AttributeSet attr,
                         HTML.Tag tag)
        Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.

      • writeEmbeddedTags

        protected void writeEmbeddedTags(AttributeSet attr)
                          throws IOException
        Searches for embedded tags in the AttributeSet and writes them out. It also stores these tags in a vector so that when appropriate the corresponding end tags can be written out.
        抛出：
        IOException - on any I/O error

      • closeOutUnwantedEmbeddedTags

        protected void closeOutUnwantedEmbeddedTags(AttributeSet attr)
                                     throws IOException
        Searches the attribute set and for each tag that is stored in the tag vector. If the tag isnt found, then the tag is removed from the vector and a corresponding end tag is written out.
        抛出：
        IOException - on any I/O error

      • writeLineSeparator

        protected void writeLineSeparator()
                           throws IOException
        Writes the line separator. This is overriden to make sure we don't replace the newline content in case it is outside normal ascii.
        重载：
        writeLineSeparator in class AbstractWriter
        抛出：
        IOException
        从以下版本开始：
        1.3

      • output

        protected void output(char[] chars,
          int start,
          int length)
               throws IOException
        This method is overriden to map any character entities, such as < to &lt;. super.output will be invoked to write the content.
        重载：
        output in class AbstractWriter
        抛出：
        IOException
        从以下版本开始：
        1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ImageView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 ImageView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.html.ImageView
  • 所有已实现的接口：
    SwingConstants

    public class ImageView
extends View
    View of an Image, intended to support the HTML <IMG> tag. Supports scaling via the HEIGHT and WIDTH attributes of the tag. If the image is unable to be loaded any text specified via the ALT attribute will be rendered.

    While this class has been part of swing for a while now, it is public as of 1.4.

    从以下版本开始：
    1.4
    另请参见：
    IconView

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ImageView(Element elem)
      Creates a new view that represents an IMG element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Invoked when the Elements attributes have changed.
      float getAlignment(int axis)
      Determines the desired alignment for this view along an axis.
      String getAltText()
      Returns the text to display if the image can't be loaded.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      Image getImage()
      Returns the image to render.
      URL getImageURL()
      Return a URL for the image source, or null if it could not be determined.
      Icon getLoadingImageIcon()
      Returns the icon to use while in the process of loading the image.
      boolean getLoadsSynchronously()
      Returns true if the image should be loaded when first asked for.
      Icon getNoImageIcon()
      Returns the icon to use if the image couldn't be found.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view along an axis.
      protected StyleSheet getStyleSheet()
      Convenience method to get the StyleSheet.
      String getToolTipText(float x, float y, Shape allocation)
      For images the tooltip text comes from text specified with the ALT attribute.
      Shape modelToView(int pos, Shape a, Position.Bias b)
      Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
      void paint(Graphics g, Shape a)
      Paints the View.
      void setLoadsSynchronously(boolean newValue)
      Sets how the image is loaded.
      void setParent(View parent)
      Establishes the parent view for this view.
      protected void setPropertiesFromAttributes()
      Update any cached values that come from attributes.
      void setSize(float width, float height)
      Sets the size of the view.
      int viewToModel(float x, float y, Shape a, Position.Bias[] bias)
      Provides a mapping from the view coordinate space to the logical coordinate space of the model.

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ImageView

        public ImageView(Element elem)
        Creates a new view that represents an IMG element.
        参数：
        elem - the element to create a view for

    • 方法详细信息

      • getAltText

        public String getAltText()
        Returns the text to display if the image can't be loaded. This is obtained from the Elements attribute set with the attribute name HTML.Attribute.ALT.

      • getImageURL

        public URL getImageURL()
        Return a URL for the image source, or null if it could not be determined.

      • getNoImageIcon

        public Icon getNoImageIcon()
        Returns the icon to use if the image couldn't be found.

      • getLoadingImageIcon

        public Icon getLoadingImageIcon()
        Returns the icon to use while in the process of loading the image.

      • getImage

        public Image getImage()
        Returns the image to render.

      • setLoadsSynchronously

        public void setLoadsSynchronously(boolean newValue)
        Sets how the image is loaded. If newValue is true, the image we be loaded when first asked for, otherwise it will be loaded asynchronously. The default is to not load synchronously, that is to load the image asynchronously.

      • getLoadsSynchronously

        public boolean getLoadsSynchronously()
        Returns true if the image should be loaded when first asked for.

      • getStyleSheet

        protected StyleSheet getStyleSheet()
        Convenience method to get the StyleSheet.

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        重载：
        getAttributes in class View

      • getToolTipText

        public String getToolTipText(float x,
                    float y,
                    Shape allocation)
        For images the tooltip text comes from text specified with the ALT attribute. This is overriden to return getAltText.
        重载：
        getToolTipText in class View
        另请参见：
        JTextComponent.getToolTipText(java.awt.event.MouseEvent)

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Update any cached values that come from attributes.

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. Seize this moment to cache the AWT Container I'm in.
        重载：
        setParent in class View
        参数：
        parent - the new parent, or null if the view is being removed from a parent

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Invoked when the Elements attributes have changed. Recreates the image.
        重载：
        changedUpdate in class View
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • paint

        public void paint(Graphics g,
         Shape a)
        Paints the View.
        指定者：
        paint in class View
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view along an axis.
        指定者：
        getPreferredSpan in class View
        参数：
        axis - may be either X_AXIS or Y_AXIS
        返回：
        the span the view would like to be rendered into; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        另请参见：
        View.getPreferredSpan(int)

      • getAlignment

        public float getAlignment(int axis)
        Determines the desired alignment for this view along an axis. This is implemented to give the alignment to the bottom of the icon along the y axis, and the default along the x axis.
        重载：
        getAlignment in class View
        参数：
        axis - may be either X_AXIS or Y_AXIS
        返回：
        the desired alignment; this should be a value between 0.0 and 1.0 where 0 indicates alignment at the origin and 1.0 indicates alignment to the full span away from the origin; an alignment of 0.5 would be the center of the view

      • modelToView

        public Shape modelToView(int pos,
                Shape a,
                Position.Bias b)
                  throws BadLocationException
        Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
        指定者：
        modelToView in class View
        参数：
        pos - the position to convert
        a - the allocated region to render into
        b - the bias toward the previous character or the next character represented by the offset, in case the position is a boundary of two views; b will have one of these values:
        • Position.Bias.Forward
        • Position.Bias.Backward
        返回：
        the bounding box of the given position
        抛出：
        BadLocationException - if the given position does not represent a valid location in the associated document
        另请参见：
        View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

      • viewToModel

        public int viewToModel(float x,
              float y,
              Shape a,
              Position.Bias[] bias)
        Provides a mapping from the view coordinate space to the logical coordinate space of the model.
        指定者：
        viewToModel in class View
        参数：
        x - the X coordinate
        y - the Y coordinate
        a - the allocated region to render into
        返回：
        the location within the model that best represents the given point of view
        另请参见：
        View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

      • setSize

        public void setSize(float width,
           float height)
        Sets the size of the view. This should cause layout of the view if it has any layout duties.
        重载：
        setSize in class View
        参数：
        width - the width >= 0
        height - the height >= 0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InlineView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 InlineView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.GlyphView
        • javax.swing.text.LabelView
          • javax.swing.text.html.InlineView
  • 所有已实现的接口：
    Cloneable, SwingConstants, TabableView

    public class InlineView
extends LabelView
    Displays the inline element styles based upon css attributes.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.GlyphView

        GlyphView.GlyphPainter

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      InlineView(Element elem)
      Constructs a new view wrapped on an element.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      View breakView(int axis, int offset, float pos, float len)
      Tries to break this view on the given axis.
      void changedUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification from the document that attributes were changed in a location that this view is responsible for.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      int getBreakWeight(int axis, float pos, float len)
      Determines how attractive a break opportunity in this view is.
      protected StyleSheet | getStyleSheet()
      void insertUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was inserted into the document in a location that this view is responsible for.
      void removeUpdate(DocumentEvent e, Shape a, ViewFactory f)
      Gives notification that something was removed from the document in a location that this view is responsible for.
      protected void setPropertiesFromAttributes()
      Set the cached properties from the attributes.

      • 方法 - 继承于类 javax.swing.text.LabelView

        getBackground, getFont, getFontMetrics, getForeground, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setBackground, setStrikeThrough, setSubscript, setSuperscript, setUnderline

      • 方法 - 继承于类 javax.swing.text.GlyphView

        checkPainter, clone, createFragment, getAlignment, getEndOffset, getGlyphPainter, getMinimumSpan, getNextVisualPositionFrom, getPartialSpan, getPreferredSpan, getStartOffset, getTabbedSpan, getTabExpander, getText, modelToView, paint, setGlyphPainter, viewToModel

      • 方法 - 继承于类 javax.swing.text.View

        append, forwardUpdate, forwardUpdateToView, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.swing.text.TabableView

        getPartialSpan, getTabbedSpan

    • 构造方法详细信息

      • InlineView

        public InlineView(Element elem)
        Constructs a new view wrapped on an element.
        参数：
        elem - the element

    • 方法详细信息

      • insertUpdate

        public void insertUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was inserted into the document in a location that this view is responsible for. If either parameter is null, behavior of this method is implementation dependent.
        重载：
        insertUpdate in class GlyphView
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        从以下版本开始：
        1.5
        另请参见：
        View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • removeUpdate

        public void removeUpdate(DocumentEvent e,
                Shape a,
                ViewFactory f)
        Gives notification that something was removed from the document in a location that this view is responsible for. If either parameter is null, behavior of this method is implementation dependent.
        重载：
        removeUpdate in class GlyphView
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        从以下版本开始：
        1.5
        另请参见：
        View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • changedUpdate

        public void changedUpdate(DocumentEvent e,
                 Shape a,
                 ViewFactory f)
        Gives notification from the document that attributes were changed in a location that this view is responsible for.
        重载：
        changedUpdate in class LabelView
        参数：
        e - the change information from the associated document
        a - the current allocation of the view
        f - the factory to use to rebuild if the view has children
        另请参见：
        View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        重载：
        getAttributes in class View

      • getBreakWeight

        public int getBreakWeight(int axis,
                 float pos,
                 float len)
        Determines how attractive a break opportunity in this view is. This can be used for determining which view is the most attractive to call breakView on in the process of formatting. A view that represents text that has whitespace in it might be more attractive than a view that has no whitespace, for example. The higher the weight, the more attractive the break. A value equal to or lower than BadBreakWeight should not be considered for a break. A value greater than or equal to ForcedBreakWeight should be broken.

        This is implemented to provide the default behavior of returning BadBreakWeight unless the length is greater than the length of the view in which case the entire view represents the fragment. Unless a view has been written to support breaking behavior, it is not attractive to try and break the view. An example of a view that does support breaking is LabelView. An example of a view that uses break weight is ParagraphView.

        重载：
        getBreakWeight in class GlyphView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        pos - the potential location of the start of the broken view >= 0. This may be useful for calculating tab positions.
        len - specifies the relative length from pos where a potential break is desired >= 0.
        返回：
        the weight, which should be a value between ForcedBreakWeight and BadBreakWeight.
        另请参见：
        LabelView, ParagraphView, View.BadBreakWeight, View.GoodBreakWeight, View.ExcellentBreakWeight, View.ForcedBreakWeight

      • breakView

        public View breakView(int axis,
             int offset,
             float pos,
             float len)
        Tries to break this view on the given axis. Refer to View.breakView(int, int, float, float) for a complete description of this method.

        Behavior of this method is unspecified in case axis is neither View.X_AXIS nor View.Y_AXIS, and in case offset, pos, or len is null.

        重载：
        breakView in class GlyphView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        offset - the location in the document model that a broken fragment would occupy >= 0. This would be the starting offset of the fragment returned
        pos - the position along the axis that the broken view would occupy >= 0. This may be useful for things like tab calculations
        len - specifies the distance along the axis where a potential break is desired >= 0
        返回：
        the fragment of the view that represents the given span.
        从以下版本开始：
        1.5
        另请参见：
        View.breakView(int, int, float, float)

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Set the cached properties from the attributes.
        重载：
        setPropertiesFromAttributes in class LabelView

      • getStyleSheet

        protected StyleSheet getStyleSheet()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

neg >ske b tfs it alh the e


javax.swing.text.html

Classes

  • BlockView
  • CSS
  • CSS.Attribute
  • FormSubmitEvent
  • FormView
  • HTML
  • HTML.Attribute
  • HTML.Tag
  • HTML.UnknownTag
  • HTMLDocument
  • HTMLDocument.Iterator
  • HTMLEditorKit
  • HTMLEditorKit.HTMLFactory
  • HTMLEditorKit.HTMLTextAction
  • HTMLEditorKit.InsertHTMLTextAction
  • HTMLEditorKit.LinkController
  • HTMLEditorKit.Parser
  • HTMLEditorKit.ParserCallback
  • HTMLFrameHyperlinkEvent
  • HTMLWriter
  • ImageView
  • InlineView
  • ListView
  • MinimalHTMLWriter
  • ObjectView
  • Option
  • ParagraphView
  • StyleSheet
  • StyleSheet.BoxPainter
  • StyleSheet.ListPainter

Enums

  • FormSubmitEvent.MethodType
<


javax.swing.text.html

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.text.html

Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

请参见： 描述

  • Class Summary
    类 描述
    BlockView
    A view implementation to display a block (as a box) with CSS specifications.
    CSS
    Defines a set of CSS attributes as a typesafe enumeration.
    CSS.Attribute
    Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
    FormSubmitEvent
    FormSubmitEvent is used to notify interested parties that a form was submited.
    FormView
    Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
    HTML
    Constants used in the HTMLDocument.
    HTML.Attribute
    Typesafe enumeration representing an HTML attribute.
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTML.UnknownTag
    HTMLDocument
    A document that models HTML.
    HTMLDocument.Iterator
    An iterator to iterate over a particular type of tag.
    HTMLEditorKit
    The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
    HTMLEditorKit.HTMLFactory
    A factory to build views for HTML.
    HTMLEditorKit.HTMLTextAction
    An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
    HTMLEditorKit.InsertHTMLTextAction
    InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
    HTMLEditorKit.LinkController
    Class to watch the associated component and fire hyperlink events on it when appropriate.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
    HTMLFrameHyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
    HTMLWriter
    This is a writer for HTMLDocuments.
    ImageView
    View of an Image, intended to support the HTML <IMG> tag.
    InlineView
    Displays the inline element styles based upon css attributes.
    ListView
    A view implementation to display an html list
    MinimalHTMLWriter
    MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit.
    ObjectView
    Component decorator that implements the view interface for <object> elements.
    Option
    Value for the ListModel used to represent <option> elements.
    ParagraphView
    Displays the a paragraph, and uses css attributes for its configuration.
    StyleSheet
    Support for defining the visual characteristics of HTML views being rendered.
    StyleSheet.BoxPainter
    Class to carry out some of the duties of CSS formatting.
    StyleSheet.ListPainter
    Class to carry out some of the duties of CSS list formatting.
  • Enum Summary
    Enum 描述
    FormSubmitEvent.MethodType
    Represents an HTML form method type.

软件包 javax.swing.text.html Description

Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Package Specification

  • HTML 3.2 Reference Specification - The HTML specification on which HTMLEditorKit is based.
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ra0r,sadako rgew< �


javax.swing.text.html Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.text.html

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.html.ImageView

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.text.html.FormSubmitEvent.MethodType
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vvr/u


ListView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 ListView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
  • 所有已实现的接口：
    SwingConstants

    public class ListView
extends BlockView
    A view implementation to display an html list

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ListView(Element elem)
      Creates a new view that represents a list element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float getAlignment(int axis)
      Calculates the desired shape of the list.
      void paint(Graphics g, Shape allocation)
      Renders using the given rendering surface and area on that surface.
      protected void paintChild(Graphics g, Rectangle alloc, int index)
      Paints one of the children; called by paint().
      protected void setPropertiesFromAttributes()
      Update any cached values that come from attributes.

      • 方法 - 继承于类 javax.swing.text.html.BlockView

        calculateMajorAxisRequirements, calculateMinorAxisRequirements, changedUpdate, getAttributes, getMaximumSpan, getMinimumSpan, getPreferredSpan, getResizeWeight, getStyleSheet, layoutMinorAxis, setParent

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ListView

        public ListView(Element elem)
        Creates a new view that represents a list element.
        参数：
        elem - the element to create a view for

    • 方法详细信息

      • getAlignment

        public float getAlignment(int axis)
        Calculates the desired shape of the list.
        重载：
        getAlignment in class BlockView
        参数：
        axis - may be either X_AXIS or Y_AXIS
        返回：
        the desired span
        另请参见：
        View.getPreferredSpan(int)

      • paint

        public void paint(Graphics g,
         Shape allocation)
        Renders using the given rendering surface and area on that surface.
        重载：
        paint in class BlockView
        参数：
        g - the rendering surface to use
        allocation - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • paintChild

        protected void paintChild(Graphics g,
              Rectangle alloc,
              int index)
        Paints one of the children; called by paint(). By default that is all it does, but a subclass can use this to paint things relative to the child.
        重载：
        paintChild in class BoxView
        参数：
        g - the graphics context
        alloc - the allocated region to render the child into
        index - the index of the child

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Description copied from class: BlockView
        Update any cached values that come from attributes.
        重载：
        setPropertiesFromAttributes in class BlockView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wki../"./"=.."== < aa./aniitxtetVmil//uVtta/a


MinimalHTMLWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 MinimalHTMLWriter

  • java.lang.Object
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.MinimalHTMLWriter

  • public class MinimalHTMLWriter
extends AbstractWriter
    MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit. The format for the document is:
     <html>
   <head>
     <style>
        <!-- list of named styles
         p.normal {
            font-family: SansSerif;
            margin-height: 0;
            font-size: 14
         }
        -->
      </style>
   </head>
   <body>
    <p style=normal>
        Bold, italic, and underline attributes
        of the run are emitted as HTML tags.
        The remaining attributes are emitted as
        part of the style attribute of a <span> tag.
        The syntax is similar to inline styles.
    </p>
   </body>
 </html>

    • 字段摘要

      • Fields inherited from class javax.swing.text.AbstractWriter

        NEWLINE

    • 构造方法摘要

      Constructors
      构造方法与描述
      MinimalHTMLWriter(Writer w, StyledDocument doc)
      Creates a new MinimalHTMLWriter.
      MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
      Creates a new MinimalHTMLWriter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected void endFontTag()
      This is no longer used, instead <span> will be written out.
      protected boolean inFontTag()
      Returns true if we are currently in a <font> tag.
      protected boolean isText(Element elem)
      Returns true if the element is a text element.
      protected void startFontTag(String style)
      This is no longer used, instead <span> will be written out.
      protected void text(Element elem)
      Writes out text.
      void write()
      Generates HTML output from a StyledDocument.
      protected void writeAttributes(AttributeSet attr)
      Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants.
      protected void writeBody()
      Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements.
      protected void writeComponent(Element elem)
      Responsible for handling Component Elements; deliberately unimplemented.
      protected void writeContent(Element elem, boolean needsIndenting)
      Writes out the attribute set in an HTML-compliant manner.
      protected void writeEndParagraph()
      Emits an end tag for a <p> tag.
      protected void writeEndTag(String endTag)
      Writes out an end tag appropriately indented.
      protected void writeHeader()
      Writes out the <head> and <style> tags, and then invokes writeStyles() to write out all the named styles as the content of the <style> tag.
      protected void writeHTMLTags(AttributeSet attr)
      Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
      protected void writeImage(Element elem)
      Responsible for handling Icon Elements; deliberately unimplemented.
      protected void writeLeaf(Element elem)
      Responsible for writing out other non-text leaf elements.
      protected void writeNonHTMLAttributes(AttributeSet attr)
      Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way.
      protected void writeStartParagraph(Element elem)
      Emits the start tag for a paragraph.
      protected void writeStartTag(String tag)
      Writes out a start tag appropriately indented.
      protected void writeStyles()
      Writes out all the named styles as the content of the <style> tag.

      • 方法 - 继承于类 javax.swing.text.AbstractWriter

        decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, output, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write, writeLineSeparator

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MinimalHTMLWriter

        public MinimalHTMLWriter(Writer w,
                 StyledDocument doc)
        Creates a new MinimalHTMLWriter.
        参数：
        w - Writer
        doc - StyledDocument

      • MinimalHTMLWriter

        public MinimalHTMLWriter(Writer w,
                 StyledDocument doc,
                 int pos,
                 int len)
        Creates a new MinimalHTMLWriter.
        参数：
        w - Writer
        doc - StyledDocument
        pos - The location in the document to fetch the content.
        len - The amount to write out.

    • 方法详细信息

      • write

        public void write()
           throws IOException,
                  BadLocationException
        Generates HTML output from a StyledDocument.
        指定者：
        write in class AbstractWriter
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeAttributes

        protected void writeAttributes(AttributeSet attr)
                        throws IOException
        Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants. The attribute name and value are separated by a colon. Each pair is separated by a semicolon.
        重载：
        writeAttributes in class AbstractWriter
        参数：
        attr - an AttributeSet.
        抛出：
        IOException - on any I/O error

      • text

        protected void text(Element elem)
             throws IOException,
                    BadLocationException
        Writes out text.
        重载：
        text in class AbstractWriter
        参数：
        elem - an Element.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeStartTag

        protected void writeStartTag(String tag)
                      throws IOException
        Writes out a start tag appropriately indented. Also increments the indent level.
        抛出：
        IOException - on any I/O error

      • writeEndTag

        protected void writeEndTag(String endTag)
                    throws IOException
        Writes out an end tag appropriately indented. Also decrements the indent level.
        抛出：
        IOException - on any I/O error

      • writeHeader

        protected void writeHeader()
                    throws IOException
        Writes out the <head> and <style> tags, and then invokes writeStyles() to write out all the named styles as the content of the <style> tag. The content is surrounded by valid HTML comment markers to ensure that the document is viewable in applications/browsers that do not support the tag.
        抛出：
        IOException - on any I/O error

      • writeStyles

        protected void writeStyles()
                    throws IOException
        Writes out all the named styles as the content of the <style> tag.
        抛出：
        IOException - on any I/O error

      • writeBody

        protected void writeBody()
                  throws IOException,
                         BadLocationException
        Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements. This method specially handles leaf elements that are text.
        抛出：
        IOException - on any I/O error
        BadLocationException

      • writeEndParagraph

        protected void writeEndParagraph()
                          throws IOException
        Emits an end tag for a <p> tag. Before writing out the tag, this method ensures that all other tags that have been opened are appropriately closed off.
        抛出：
        IOException - on any I/O error

      • writeStartParagraph

        protected void writeStartParagraph(Element elem)
                            throws IOException
        Emits the start tag for a paragraph. If the paragraph has a named style associated with it, then this method also generates a class attribute for the <p> tag and sets its value to be the name of the style.
        抛出：
        IOException - on any I/O error

      • writeLeaf

        protected void writeLeaf(Element elem)
                  throws IOException
        Responsible for writing out other non-text leaf elements.
        抛出：
        IOException - on any I/O error

      • writeImage

        protected void writeImage(Element elem)
                   throws IOException
        Responsible for handling Icon Elements; deliberately unimplemented. How to implement this method is an issue of policy. For example, if you're generating an <img> tag, how should you represent the src attribute (the location of the image)? In certain cases it could be a URL, in others it could be read from a stream.
        参数：
        elem - element of type StyleConstants.IconElementName
        抛出：
        IOException

      • writeComponent

        protected void writeComponent(Element elem)
                       throws IOException
        Responsible for handling Component Elements; deliberately unimplemented. How this method is implemented is a matter of policy.
        抛出：
        IOException

      • isText

        protected boolean isText(Element elem)
        Returns true if the element is a text element.

      • writeContent

        protected void writeContent(Element elem,
                boolean needsIndenting)
                     throws IOException,
                            BadLocationException
        Writes out the attribute set in an HTML-compliant manner.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • writeHTMLTags

        protected void writeHTMLTags(AttributeSet attr)
                      throws IOException
        Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
        抛出：
        IOException - on any I/O error

      • writeNonHTMLAttributes

        protected void writeNonHTMLAttributes(AttributeSet attr)
                               throws IOException
        Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way. Given that attributes such as font family and font size have no direct mapping to HTML tags, a <span> tag is generated and its style attribute is set to contain the list of remaining attributes just like inline styles.
        抛出：
        IOException - on any I/O error

      • inFontTag

        protected boolean inFontTag()
        Returns true if we are currently in a <font> tag.

      • endFontTag

        protected void endFontTag()
                   throws IOException
        This is no longer used, instead <span> will be written out.

        Writes out an end tag for the <font> tag.

        抛出：
        IOException - on any I/O error

      • startFontTag

        protected void startFontTag(String style)
                     throws IOException
        This is no longer used, instead <span> will be written out.

        Writes out a start tag for the <font> tag. Because font tags cannot be nested, this method closes out any enclosing font tag before writing out a new start tag.

        抛出：
        IOException - on any I/O error
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


ObjectView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 ObjectView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.ComponentView
        • javax.swing.text.html.ObjectView
  • 所有已实现的接口：
    SwingConstants

    public class ObjectView
extends ComponentView
    Component decorator that implements the view interface for <object> elements.

    This view will try to load the class specified by the classid attribute. If possible, the Classloader used to load the associated Document is used. This would typically be the same as the ClassLoader used to load the EditorKit. If the document's ClassLoader is null, Class.forName is used.

    If the class can successfully be loaded, an attempt will be made to create an instance of it by calling Class.newInstance. An attempt will be made to narrow the instance to type java.awt.Component to display the object.

    This view can also manage a set of parameters with limitations. The parameters to the <object> element are expected to be present on the associated elements attribute set as simple strings. Each bean property will be queried as a key on the AttributeSet, with the expectation that a non-null value (of type String) will be present if there was a parameter specification for the property. Reflection is used to set the parameter. Currently, this is limited to a very simple single parameter of type String.

    A simple example HTML invocation is:

          <object classid="javax.swing.JLabel">
      <param name="text" value="sample text">
      </object>

    • 字段摘要

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectView(Element elem)
      Creates a new ObjectView object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected Component createComponent()
      Create the component.

      • 方法 - 继承于类 javax.swing.text.ComponentView

        getAlignment, getComponent, getMaximumSpan, getMinimumSpan, getPreferredSpan, modelToView, paint, setParent, viewToModel

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectView

        public ObjectView(Element elem)
        Creates a new ObjectView object.
        参数：
        elem - the element to decorate

    • 方法详细信息

      • createComponent

        protected Component createComponent()
        Create the component. The classid is used as a specification of the classname, which we try to load.
        重载：
        createComponent in class ComponentView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olncdd<>>>eii"xnetyllt">ewxits..aDten


Option

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 Option

  • java.lang.Object
    • javax.swing.text.html.Option
  • 所有已实现的接口：
    Serializable

    public class Option
extends Object
implements Serializable
    Value for the ListModel used to represent <option> elements. This is the object installed as items of the DefaultComboBoxModel used to represent the <select> element.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Option(AttributeSet attr)
      Creates a new Option object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AttributeSet getAttributes()
      Fetch the attributes associated with this option.
      String getLabel()
      Fetch the label associated with the option.
      String getValue()
      Convenience method to return the string associated with the value attribute.
      boolean isSelected()
      Fetches the selection state associated with this option.
      void setLabel(String label)
      Sets the label to be used for the option.
      protected void setSelection(boolean state)
      Sets the selected state.
      String toString()
      String representation is the label.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Option

        public Option(AttributeSet attr)
        Creates a new Option object.
        参数：
        attr - the attributes associated with the option element. The attributes are copied to ensure they won't change.

    • 方法详细信息

      • setLabel

        public void setLabel(String label)
        Sets the label to be used for the option.

      • getLabel

        public String getLabel()
        Fetch the label associated with the option.

      • getAttributes

        public AttributeSet getAttributes()
        Fetch the attributes associated with this option.

      • toString

        public String toString()
        String representation is the label.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • setSelection

        protected void setSelection(boolean state)
        Sets the selected state.

      • isSelected

        public boolean isSelected()
        Fetches the selection state associated with this option.

      • getValue

        public String getValue()
        Convenience method to return the string associated with the value attribute. If the value has not been specified, the label will be returned.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea


ParagraphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 ParagraphView

  • java.lang.Object
    • javax.swing.text.View
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView
              • javax.swing.text.html.ParagraphView
  • 所有已实现的接口：
    SwingConstants, TabExpander

    public class ParagraphView
extends ParagraphView
    Displays the a paragraph, and uses css attributes for its configuration.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.FlowView

        FlowView.FlowStrategy

    • 字段摘要

      • Fields inherited from class javax.swing.text.ParagraphView

        firstLineIndent

      • Fields inherited from class javax.swing.text.FlowView

        layoutPool, layoutSpan, strategy

      • Fields inherited from class javax.swing.text.View

        BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParagraphView(Element elem)
      Constructs a ParagraphView for the given element.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected SizeRequirements calculateMinorAxisRequirements(int axis, SizeRequirements r)
      Calculate the needs for the paragraph along the minor axis.
      AttributeSet getAttributes()
      Fetches the attributes to use when rendering.
      float getMaximumSpan(int axis)
      Determines the maximum span for this view along an axis.
      float getMinimumSpan(int axis)
      Determines the minimum span for this view along an axis.
      float getPreferredSpan(int axis)
      Determines the preferred span for this view.
      protected StyleSheet | getStyleSheet()
      boolean isVisible()
      Indicates whether or not this view should be displayed.
      void paint(Graphics g, Shape a)
      Renders using the given rendering surface and area on that surface.
      void setParent(View parent)
      Establishes the parent view for this view.
      protected void setPropertiesFromAttributes()
      Sets up the paragraph from css attributes instead of the values found in StyleConstants (i.e.

      • 方法 - 继承于类 javax.swing.text.ParagraphView

        breakView, changedUpdate, createRow, findOffsetToCharactersInString, flipEastAndWestAtEnds, getAlignment, getBreakWeight, getClosestPositionTo, getFlowSpan, getFlowStart, getLayoutView, getLayoutViewCount, getNextNorthSouthVisualPositionFrom, getPartialSize, getTabBase, getTabSet, nextTabStop, setFirstLineIndent, setJustification, setLineSpacing

      • 方法 - 继承于类 javax.swing.text.FlowView

        getFlowAxis, getViewIndexAtPosition, insertUpdate, layout, loadChildren, removeUpdate

      • 方法 - 继承于类 javax.swing.text.BoxView

        baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel

      • 方法 - 继承于类 javax.swing.text.CompositeView

        getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets

      • 方法 - 继承于类 javax.swing.text.View

        append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ParagraphView

        public ParagraphView(Element elem)
        Constructs a ParagraphView for the given element.
        参数：
        elem - the element that this view is responsible for

    • 方法详细信息

      • setParent

        public void setParent(View parent)
        Establishes the parent view for this view. This is guaranteed to be called before any other methods if the parent view is functioning properly.

        This is implemented to forward to the superclass as well as call the setPropertiesFromAttributes method to set the paragraph properties from the css attributes. The call is made at this time to ensure the ability to resolve upward through the parents view attributes.

        重载：
        setParent in class FlowView
        参数：
        parent - the new parent, or null if the view is being removed from a parent it was previously added to

      • getAttributes

        public AttributeSet getAttributes()
        Fetches the attributes to use when rendering. This is implemented to multiplex the attributes specified in the model with a StyleSheet.
        重载：
        getAttributes in class View

      • setPropertiesFromAttributes

        protected void setPropertiesFromAttributes()
        Sets up the paragraph from css attributes instead of the values found in StyleConstants (i.e. which are used by the superclass). Since
        重载：
        setPropertiesFromAttributes in class ParagraphView

      • getStyleSheet

        protected StyleSheet getStyleSheet()

      • calculateMinorAxisRequirements

        protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                              SizeRequirements r)
        Calculate the needs for the paragraph along the minor axis.

        If size requirements are explicitly specified for the paragraph, use that requirements. Otherwise, use the requirements of the superclass ParagraphView.

        If the axis parameter is neither View.X_AXIS nor View.Y_AXIS, IllegalArgumentException is thrown. If the r parameter is null, a new SizeRequirements object is created, otherwise the supplied SizeRequirements object is returned.

        重载：
        calculateMinorAxisRequirements in class ParagraphView
        参数：
        axis - the minor axis
        r - the input SizeRequirements object
        返回：
        the new or adjusted SizeRequirements object
        抛出：
        IllegalArgumentException - if the axis parameter is invalid
        另请参见：
        SizeRequirements

      • isVisible

        public boolean isVisible()
        Indicates whether or not this view should be displayed. If none of the children wish to be displayed and the only visible child is the break that ends the paragraph, the paragraph will not be considered visible. Otherwise, it will be considered visible and return true.
        重载：
        isVisible in class View
        返回：
        true if the paragraph should be displayed

      • paint

        public void paint(Graphics g,
         Shape a)
        Renders using the given rendering surface and area on that surface. This is implemented to delgate to the superclass after stashing the base coordinate for tab calculations.
        重载：
        paint in class ParagraphView
        参数：
        g - the rendering surface to use
        a - the allocated region to render into
        另请参见：
        View.paint(java.awt.Graphics, java.awt.Shape)

      • getPreferredSpan

        public float getPreferredSpan(int axis)
        Determines the preferred span for this view. Returns 0 if the view is not visible, otherwise it calls the superclass method to get the preferred span. axis.
        重载：
        getPreferredSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the span the view would like to be rendered into; typically the view is told to render into the span that is returned, although there is no guarantee; the parent may choose to resize or break the view
        另请参见：
        BoxView.getPreferredSpan(int)

      • getMinimumSpan

        public float getMinimumSpan(int axis)
        Determines the minimum span for this view along an axis. Returns 0 if the view is not visible, otherwise it calls the superclass method to get the minimum span.
        重载：
        getMinimumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the minimum span the view can be rendered into
        另请参见：
        BoxView.getMinimumSpan(int)

      • getMaximumSpan

        public float getMaximumSpan(int axis)
        Determines the maximum span for this view along an axis. Returns 0 if the view is not visible, otherwise it calls the superclass method ot get the maximum span.
        重载：
        getMaximumSpan in class BoxView
        参数：
        axis - may be either View.X_AXIS or View.Y_AXIS
        返回：
        the maximum span the view can be rendered into
        另请参见：
        BoxView.getMaximumSpan(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleSheet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html

类 StyleSheet

  • java.lang.Object
    • javax.swing.text.StyleContext
      • javax.swing.text.html.StyleSheet
  • 所有已实现的接口：
    Serializable, AbstractDocument.AttributeContext

    public class StyleSheet
extends StyleContext
    Support for defining the visual characteristics of HTML views being rendered. The StyleSheet is used to translate the HTML model into visual characteristics. This enables views to be customized by a look-and-feel, multiple views over the same model can be rendered differently, etc. This can be thought of as a CSS rule repository. The key for CSS attributes is an object of type CSS.Attribute. The type of the value is up to the StyleSheet implementation, but the toString method is required to return a string representation of CSS value.

    The primary entry point for HTML View implementations to get their attributes is the getViewAttributes method. This should be implemented to establish the desired policy used to associate attributes with the view. Each HTMLEditorKit (i.e. and therefore each associated JEditorPane) can have its own StyleSheet, but by default one sheet will be shared by all of the HTMLEditorKit instances. HTMLDocument instance can also have a StyleSheet, which holds the document-specific CSS specifications.

    In order for Views to store less state and therefore be more lightweight, the StyleSheet can act as a factory for painters that handle some of the rendering tasks. This allows implementations to determine what they want to cache and have the sharing potentially at the level that a selector is common to multiple views. Since the StyleSheet may be used by views over multiple documents and typically the HTML attributes don't effect the selector being used, the potential for sharing is significant.

    The rules are stored as named styles, and other information is stored to translate the context of an element to a rule quickly. The following code fragment will display the named styles, and therefore the CSS rules contained.

   import java.util.*;
   import javax.swing.text.*;
   import javax.swing.text.html.*;

   public class ShowStyles {

       public static void main(String[] args) {
         HTMLEditorKit kit = new HTMLEditorKit();
         HTMLDocument doc = (HTMLDocument) kit.createDefaultDocument();
         StyleSheet styles = doc.getStyleSheet();

         Enumeration rules = styles.getStyleNames();
         while (rules.hasMoreElements()) {
             String name = (String) rules.nextElement();
             Style rule = styles.getStyle(name);
             System.out.println(rule.toString());
         }
         System.exit(0);
       }
   }

    The semantics for when a CSS style should overide visual attributes defined by an element are not well defined. For example, the html <body bgcolor=red> makes the body have a red background. But if the html file also contains the CSS rule body { background: blue } it becomes less clear as to what color the background of the body should be. The current implemention gives visual attributes defined in the element the highest precedence, that is they are always checked before any styles. Therefore, in the previous example the background would have a red color as the body element defines the background color to be red.

    As already mentioned this supports CSS. We don't support the full CSS spec. Refer to the javadoc of the CSS class to see what properties we support. The two major CSS parsing related concepts we do not currently support are pseudo selectors, such as A:link { color: red }, and the important modifier.

    Note: This implementation is currently incomplete. It can be replaced with alternative implementations that are complete. Future versions of this class will provide better CSS support.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  StyleSheet.BoxPainter
      Class to carry out some of the duties of CSS formatting.
      static class  StyleSheet.ListPainter
      Class to carry out some of the duties of CSS list formatting.

      • Nested classes/interfaces inherited from class javax.swing.text.StyleContext

        StyleContext.NamedStyle, StyleContext.SmallAttributeSet

    • 字段摘要

      • Fields inherited from class javax.swing.text.StyleContext

        DEFAULT_STYLE

    • 构造方法摘要

      Constructors
      构造方法与描述
      StyleSheet()
      Construct a StyleSheet

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      AttributeSet addAttribute(AttributeSet old, Object key, Object value)
      Adds an attribute to the given set, and returns the new representative set.
      AttributeSet addAttributes(AttributeSet old, AttributeSet attr)
      Adds a set of attributes to the element.
      void addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      boolean addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      void addRule(String rule)
      Adds a set of rules to the sheet.
      void addStyleSheet(StyleSheet ss)
      Adds the rules from the StyleSheet ss to those of the receiver.
      protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
      Creates a large set of attributes that should trade off space for time.
      protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
      Creates a compact set of attributes that might be shared.
      Color getBackground(AttributeSet a)
      Takes a set of attributes and turn it into a background color specification.
      URL getBase()
      Returns the base.
      StyleSheet.BoxPainter getBoxPainter(AttributeSet a)
      Fetches the box formatter to use for the given set of CSS attributes.
      AttributeSet getDeclaration(String decl)
      Translates a CSS declaration to an AttributeSet that represents the CSS declaration.
      Font getFont(AttributeSet a)
      Fetches the font to use for the given set of attributes.
      Color getForeground(AttributeSet a)
      Takes a set of attributes and turn it into a foreground color specification.
      static int | getIndexOfSize(float pt)
      StyleSheet.ListPainter getListPainter(AttributeSet a)
      Fetches the list formatter to use for the given set of CSS attributes.
      float getPointSize(int index)
      Returns the point size, given a size index.
      float getPointSize(String size)
      Given a string such as "+2", "-2", or "2", returns a point size value.
      Style getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      Style getRule(String selector)
      Fetches the rule that best matches the selector given in string form.
      StyleSheet[] getStyleSheets()
      Returns an array of the linked StyleSheets.
      AttributeSet getViewAttributes(View v)
      Fetches a set of attributes to use in the view for displaying.
      void importStyleSheet(URL url)
      Imports a style sheet from url.
      void loadRules(Reader in, URL ref)
      Loads a set of rules that have been specified in terms of CSS1 grammar.
      AttributeSet removeAttribute(AttributeSet old, Object key)
      Removes an attribute from the set.
      AttributeSet removeAttributes(AttributeSet old, AttributeSet attrs)
      Removes a set of attributes.
      AttributeSet removeAttributes(AttributeSet old, Enumeration<?> names)
      Removes a set of attributes for the element.
      void removeStyle(String nm)
      Removes a named style previously added to the document.
      void removeStyleSheet(StyleSheet ss)
      Removes the StyleSheet ss from those of the receiver.
      void setBase(URL base)
      Sets the base.
      void setBaseFontSize(int sz)
      Sets the base font size, with valid values between 1 and 7.
      void setBaseFontSize(String size)
      Sets the base font size from the passed in String.
      Color stringToColor(String string)
      Converts a color string such as "RED" or "#NNNNNN" to a Color.
      AttributeSet translateHTMLToCSS(AttributeSet htmlAttrSet)
      Converts a set of HTML attributes to an equivalent set of CSS attributes.

      • 方法 - 继承于类 javax.swing.text.StyleContext

        addChangeListener, addStyle, getChangeListeners, getCompressionThreshold, getDefaultStyleContext, getEmptySet, getFont, getFontMetrics, getStaticAttribute, getStaticAttributeKey, getStyle, getStyleNames, readAttributes, readAttributeSet, reclaim, registerStaticAttributeKey, removeChangeListener, toString, writeAttributes, writeAttributeSet

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • StyleSheet

        public StyleSheet()
        Construct a StyleSheet

    • 方法详细信息

      • getRule

        public Style getRule(HTML.Tag t,
            Element e)
        Fetches the style to use to render the given type of HTML tag. The element given is representing the tag and can be used to determine the nesting for situations where the attributes will differ if nesting inside of elements.
        参数：
        t - the type to translate to visual attributes
        e - the element representing the tag; the element can be used to determine the nesting for situations where the attributes will differ if nested inside of other elements
        返回：
        the set of CSS attributes to use to render the tag

      • getRule

        public Style getRule(String selector)
        Fetches the rule that best matches the selector given in string form. Where selector is a space separated String of the element names. For example, selector might be 'html body tr td''

        The attributes of the returned Style will change as rules are added and removed. That is if you to ask for a rule with a selector "table p" and a new rule was added with a selector of "p" the returned Style would include the new attributes from the rule "p".

      • addRule

        public void addRule(String rule)
        Adds a set of rules to the sheet. The rules are expected to be in valid CSS format. Typically this would be called as a result of parsing a <style> tag.

      • getDeclaration

        public AttributeSet getDeclaration(String decl)
        Translates a CSS declaration to an AttributeSet that represents the CSS declaration. Typically this would be called as a result of encountering an HTML style attribute.

      • loadRules

        public void loadRules(Reader in,
             URL ref)
               throws IOException
        Loads a set of rules that have been specified in terms of CSS1 grammar. If there are collisions with existing rules, the newly specified rule will win.
        参数：
        in - the stream to read the CSS grammar from
        ref - the reference URL. This value represents the location of the stream and may be null. All relative URLs specified in the stream will be based upon this parameter.
        抛出：
        IOException

      • getViewAttributes

        public AttributeSet getViewAttributes(View v)
        Fetches a set of attributes to use in the view for displaying. This is basically a set of attributes that can be used for View.getAttributes.

      • removeStyle

        public void removeStyle(String nm)
        Removes a named style previously added to the document.
        重载：
        removeStyle in class StyleContext
        参数：
        nm - the name of the style to remove

      • addStyleSheet

        public void addStyleSheet(StyleSheet ss)
        Adds the rules from the StyleSheet ss to those of the receiver. ss's rules will override the rules of any previously added style sheets. An added StyleSheet will never override the rules of the receiving style sheet.
        从以下版本开始：
        1.3

      • removeStyleSheet

        public void removeStyleSheet(StyleSheet ss)
        Removes the StyleSheet ss from those of the receiver.
        从以下版本开始：
        1.3

      • getStyleSheets

        public StyleSheet[] getStyleSheets()
        Returns an array of the linked StyleSheets. Will return null if there are no linked StyleSheets.
        从以下版本开始：
        1.3

      • importStyleSheet

        public void importStyleSheet(URL url)
        Imports a style sheet from url. The resulting rules are directly added to the receiver. If you do not want the rules to become part of the receiver, create a new StyleSheet and use addStyleSheet to link it in.
        从以下版本开始：
        1.3

      • setBase

        public void setBase(URL base)
        Sets the base. All import statements that are relative, will be relative to base.
        从以下版本开始：
        1.3

      • getBase

        public URL getBase()
        Returns the base.
        从以下版本开始：
        1.3

      • addCSSAttribute

        public void addCSSAttribute(MutableAttributeSet attr,
                   CSS.Attribute key,
                   String value)
        Adds a CSS attribute to the given set.
        从以下版本开始：
        1.3

      • addCSSAttributeFromHTML

        public boolean addCSSAttributeFromHTML(MutableAttributeSet attr,
                              CSS.Attribute key,
                              String value)
        Adds a CSS attribute to the given set.
        从以下版本开始：
        1.3

      • translateHTMLToCSS

        public AttributeSet translateHTMLToCSS(AttributeSet htmlAttrSet)
        Converts a set of HTML attributes to an equivalent set of CSS attributes.
        参数：
        htmlAttrSet - AttributeSet containing the HTML attributes.

      • addAttribute

        public AttributeSet addAttribute(AttributeSet old,
                        Object key,
                        Object value)
        Adds an attribute to the given set, and returns the new representative set. This is reimplemented to convert StyleConstant attributes to CSS prior to forwarding to the superclass behavior. The StyleConstants attribute has no corresponding CSS entry, the StyleConstants attribute is stored (but will likely be unused).
        指定者：
        addAttribute in interface AbstractDocument.AttributeContext
        重载：
        addAttribute in class StyleContext
        参数：
        old - the old attribute set
        key - the non-null attribute key
        value - the attribute value
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • addAttributes

        public AttributeSet addAttributes(AttributeSet old,
                         AttributeSet attr)
        Adds a set of attributes to the element. If any of these attributes are StyleConstants attributes, they will be converted to CSS prior to forwarding to the superclass behavior.
        指定者：
        addAttributes in interface AbstractDocument.AttributeContext
        重载：
        addAttributes in class StyleContext
        参数：
        old - the old attribute set
        attr - the attributes to add
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

      • removeAttribute

        public AttributeSet removeAttribute(AttributeSet old,
                           Object key)
        Removes an attribute from the set. If the attribute is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        指定者：
        removeAttribute in interface AbstractDocument.AttributeContext
        重载：
        removeAttribute in class StyleContext
        参数：
        old - the old set of attributes
        key - the non-null attribute name
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttribute(java.lang.Object)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                            Enumeration<?> names)
        Removes a set of attributes for the element. If any of the attributes is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        指定者：
        removeAttributes in interface AbstractDocument.AttributeContext
        重载：
        removeAttributes in class StyleContext
        参数：
        old - the old attribute set
        names - the attribute names
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • removeAttributes

        public AttributeSet removeAttributes(AttributeSet old,
                            AttributeSet attrs)
        Removes a set of attributes. If any of the attributes is a StyleConstants attribute, the request will be converted to a CSS attribute prior to forwarding to the superclass behavior.
        指定者：
        removeAttributes in interface AbstractDocument.AttributeContext
        重载：
        removeAttributes in class StyleContext
        参数：
        old - the old attribute set
        attrs - the attributes
        返回：
        the updated attribute set
        另请参见：
        MutableAttributeSet.removeAttributes(java.util.Enumeration)

      • createSmallAttributeSet

        protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
        Creates a compact set of attributes that might be shared. This is a hook for subclasses that want to alter the behavior of SmallAttributeSet. This can be reimplemented to return an AttributeSet that provides some sort of attribute conversion.
        重载：
        createSmallAttributeSet in class StyleContext
        参数：
        a - The set of attributes to be represented in the the compact form.

      • createLargeAttributeSet

        protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
        Creates a large set of attributes that should trade off space for time. This set will not be shared. This is a hook for subclasses that want to alter the behavior of the larger attribute storage format (which is SimpleAttributeSet by default). This can be reimplemented to return a MutableAttributeSet that provides some sort of attribute conversion.
        重载：
        createLargeAttributeSet in class StyleContext
        参数：
        a - The set of attributes to be represented in the the larger form.

      • getFont

        public Font getFont(AttributeSet a)
        Fetches the font to use for the given set of attributes.
        重载：
        getFont in class StyleContext
        参数：
        a - the attribute set
        返回：
        the font

      • getForeground

        public Color getForeground(AttributeSet a)
        Takes a set of attributes and turn it into a foreground color specification. This might be used to specify things like brighter, more hue, etc.
        重载：
        getForeground in class StyleContext
        参数：
        a - the set of attributes
        返回：
        the color

      • getBackground

        public Color getBackground(AttributeSet a)
        Takes a set of attributes and turn it into a background color specification. This might be used to specify things like brighter, more hue, etc.
        重载：
        getBackground in class StyleContext
        参数：
        a - the set of attributes
        返回：
        the color

      • getBoxPainter

        public StyleSheet.BoxPainter getBoxPainter(AttributeSet a)
        Fetches the box formatter to use for the given set of CSS attributes.

      • getListPainter

        public StyleSheet.ListPainter getListPainter(AttributeSet a)
        Fetches the list formatter to use for the given set of CSS attributes.

      • setBaseFontSize

        public void setBaseFontSize(int sz)
        Sets the base font size, with valid values between 1 and 7.

      • setBaseFontSize

        public void setBaseFontSize(String size)
        Sets the base font size from the passed in String. The string can either identify a specific font size, with legal values between 1 and 7, or identifiy a relative font size such as +1 or -2.

      • getIndexOfSize

        public static int getIndexOfSize(float pt)

      • getPointSize

        public float getPointSize(int index)
        Returns the point size, given a size index.

      • getPointSize

        public float getPointSize(String size)
        Given a string such as "+2", "-2", or "2", returns a point size value.

      • stringToColor

        public Color stringToColor(String string)
        Converts a color string such as "RED" or "#NNNNNN" to a Color. Note: This will only convert the HTML3.2 color strings or a string of length 7; otherwise, it will return null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StyleSheet.BoxPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html

类 StyleSheet.BoxPainter

  • java.lang.Object
    • javax.swing.text.html.StyleSheet.BoxPainter
  • 所有已实现的接口：
    Serializable
    封闭类：
    StyleSheet

    public static class StyleSheet.BoxPainter
extends Object
implements Serializable
    Class to carry out some of the duties of CSS formatting. Implementations of this class enable views to present the CSS formatting while not knowing anything about how the CSS values are being cached.

    As a delegate of Views, this object is responsible for the insets of a View and making sure the background is maintained according to the CSS attributes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      float getInset(int side, View v)
      Fetches the inset needed on a given side to account for the margin, border, and padding.
      void paint(Graphics g, float x, float y, float w, float h, View v)
      Paints the CSS box according to the attributes given.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getInset

        public float getInset(int side,
             View v)
        Fetches the inset needed on a given side to account for the margin, border, and padding.
        参数：
        side - The size of the box to fetch the inset for. This can be View.TOP, View.LEFT, View.BOTTOM, or View.RIGHT.
        v - the view making the request. This is used to get the AttributeSet, and may be used to resolve percentage arguments.
        抛出：
        IllegalArgumentException - for an invalid direction

      • paint

        public void paint(Graphics g,
         float x,
         float y,
         float w,
         float h,
         View v)
        Paints the CSS box according to the attributes given. This should paint the border, padding, and background.
        参数：
        g - the rendering surface.
        x - the x coordinate of the allocated area to render into.
        y - the y coordinate of the allocated area to render into.
        w - the width of the allocated area to render into.
        h - the height of the allocated area to render into.
        v - the view making the request. This is used to get the AttributeSet, and may be used to resolve percentage arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/).rg


StyleSheet.ListPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html

类 StyleSheet.ListPainter

  • java.lang.Object
    • javax.swing.text.html.StyleSheet.ListPainter
  • 所有已实现的接口：
    Serializable
    封闭类：
    StyleSheet

    public static class StyleSheet.ListPainter
extends Object
implements Serializable
    Class to carry out some of the duties of CSS list formatting. Implementations of this class enable views to present the CSS formatting while not knowing anything about how the CSS values are being cached.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void paint(Graphics g, float x, float y, float w, float h, View v, int item)
      Paints the CSS list decoration according to the attributes given.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • paint

        public void paint(Graphics g,
         float x,
         float y,
         float w,
         float h,
         View v,
         int item)
        Paints the CSS list decoration according to the attributes given.
        参数：
        g - the rendering surface.
        x - the x coordinate of the list item allocation
        y - the y coordinate of the list item allocation
        w - the width of the list item allocation
        h - the height of the list item allocation
        v - the allocated area to paint into.
        item - which list item is being painted. This is a number greater than or equal to 0.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcitsPttPte..teelh//<caL


Uses of Package javax.swing.text.html

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.text.html

  • Packages that use javax.swing.text.html
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.
  • Classes in javax.swing.text.html used by javax.swing.text.html
    类与描述
    BlockView
    A view implementation to display a block (as a box) with CSS specifications.
    CSS.Attribute
    Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
    FormSubmitEvent.MethodType
    Represents an HTML form method type.
    HTML.Attribute
    Typesafe enumeration representing an HTML attribute.
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTMLDocument
    A document that models HTML.
    HTMLDocument.HTMLReader.BlockAction
    HTMLDocument.HTMLReader.SpecialAction
    HTMLDocument.HTMLReader.TagAction
    An action to be performed in response to parsing a tag.
    HTMLDocument.Iterator
    An iterator to iterate over a particular type of tag.
    HTMLEditorKit
    The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
    HTMLEditorKit.HTMLTextAction
    An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
    HTMLFrameHyperlinkEvent
    HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
    Option
    Value for the ListModel used to represent <option> elements.
    StyleSheet
    Support for defining the visual characteristics of HTML views being rendered.
    StyleSheet.BoxPainter
    Class to carry out some of the duties of CSS formatting.
    StyleSheet.ListPainter
    Class to carry out some of the duties of CSS list formatting.
  • Classes in javax.swing.text.html used by javax.swing.text.html.parser
    类与描述
    HTML.Tag
    Typesafe enumeration for an HTML tag.
    HTMLEditorKit.Parser
    Interface to be supported by the parser.
    HTMLEditorKit.ParserCallback
    The result of parsing drives these callback methods.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

MmLxiwivaaaa./..eTaaH"cs


Uses of Class javax.swing.text.html.BlockView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.BlockView

  • Packages that use BlockView
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of BlockView in javax.swing.text.html

      Subclasses of BlockView in javax.swing.text.html
      修饰符与类型 类与描述
      class  ListView
      A view implementation to display an html list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

鹢/gttSa./


Uses of Class javax.swing.text.html.CSS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.CSS

No usage of javax.swing.text.html.CSS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.b./ef=a< ndeedoa


Uses of Class javax.swing.text.html.CSS.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.CSS.Attribute

  • Packages that use CSS.Attribute
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of CSS.Attribute in javax.swing.text.html

      Fields in javax.swing.text.html declared as CSS.Attribute
      修饰符与类型 | 字段与描述
      static CSS.Attribute | CSS.Attribute.BACKGROUND
      static CSS.Attribute | CSS.Attribute.BACKGROUND_ATTACHMENT
      static CSS.Attribute | CSS.Attribute.BACKGROUND_COLOR
      static CSS.Attribute | CSS.Attribute.BACKGROUND_IMAGE
      static CSS.Attribute | CSS.Attribute.BACKGROUND_POSITION
      static CSS.Attribute | CSS.Attribute.BACKGROUND_REPEAT
      static CSS.Attribute | CSS.Attribute.BORDER
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_LEFT_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_TOP
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_COLOR
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_STYLE
      static CSS.Attribute | CSS.Attribute.BORDER_TOP_WIDTH
      static CSS.Attribute | CSS.Attribute.BORDER_WIDTH
      static CSS.Attribute | CSS.Attribute.CLEAR
      static CSS.Attribute | CSS.Attribute.COLOR
      static CSS.Attribute | CSS.Attribute.DISPLAY
      static CSS.Attribute | CSS.Attribute.FLOAT
      static CSS.Attribute | CSS.Attribute.FONT
      static CSS.Attribute | CSS.Attribute.FONT_FAMILY
      static CSS.Attribute | CSS.Attribute.FONT_SIZE
      static CSS.Attribute | CSS.Attribute.FONT_STYLE
      static CSS.Attribute | CSS.Attribute.FONT_VARIANT
      static CSS.Attribute | CSS.Attribute.FONT_WEIGHT
      static CSS.Attribute | CSS.Attribute.HEIGHT
      static CSS.Attribute | CSS.Attribute.LETTER_SPACING
      static CSS.Attribute | CSS.Attribute.LINE_HEIGHT
      static CSS.Attribute | CSS.Attribute.LIST_STYLE
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_IMAGE
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_POSITION
      static CSS.Attribute | CSS.Attribute.LIST_STYLE_TYPE
      static CSS.Attribute | CSS.Attribute.MARGIN
      static CSS.Attribute | CSS.Attribute.MARGIN_BOTTOM
      static CSS.Attribute | CSS.Attribute.MARGIN_LEFT
      static CSS.Attribute | CSS.Attribute.MARGIN_RIGHT
      static CSS.Attribute | CSS.Attribute.MARGIN_TOP
      static CSS.Attribute | CSS.Attribute.PADDING
      static CSS.Attribute | CSS.Attribute.PADDING_BOTTOM
      static CSS.Attribute | CSS.Attribute.PADDING_LEFT
      static CSS.Attribute | CSS.Attribute.PADDING_RIGHT
      static CSS.Attribute | CSS.Attribute.PADDING_TOP
      static CSS.Attribute | CSS.Attribute.TEXT_ALIGN
      static CSS.Attribute | CSS.Attribute.TEXT_DECORATION
      static CSS.Attribute | CSS.Attribute.TEXT_INDENT
      static CSS.Attribute | CSS.Attribute.TEXT_TRANSFORM
      static CSS.Attribute | CSS.Attribute.VERTICAL_ALIGN
      static CSS.Attribute | CSS.Attribute.WHITE_SPACE
      static CSS.Attribute | CSS.Attribute.WIDTH
      static CSS.Attribute | CSS.Attribute.WORD_SPACING
      Methods in javax.swing.text.html that return CSS.Attribute
      修饰符与类型 方法与描述
      static CSS.Attribute[] CSS.getAllAttributeKeys()
      Return the set of all possible CSS attribute keys.
      static CSS.Attribute CSS.getAttribute(String name)
      Translates a string to a CSS.Attribute object.
      Methods in javax.swing.text.html with parameters of type CSS.Attribute
      修饰符与类型 方法与描述
      void StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
      boolean StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
      Adds a CSS attribute to the given set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


Uses of Class javax.swing.text.html.FormSubmitEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.FormSubmitEvent

No usage of javax.swing.text.html.FormSubmitEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bri,.aanhil


Uses of Class javax.swing.text.html.FormSubmitEvent.MethodType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.FormSubmitEvent.MethodType

  • Packages that use FormSubmitEvent.MethodType
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of FormSubmitEvent.MethodType in javax.swing.text.html

      Methods in javax.swing.text.html that return FormSubmitEvent.MethodType
      修饰符与类型 方法与描述
      FormSubmitEvent.MethodType FormSubmitEvent.getMethod()
      Gets the form method type.
      static FormSubmitEvent.MethodType FormSubmitEvent.MethodType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static FormSubmitEvent.MethodType[] FormSubmitEvent.MethodType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iU.a==on"


Uses of Class javax.swing.text.html.FormView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.FormView

No usage of javax.swing.text.html.FormView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>mxingxa///j.rrl>Cse


Uses of Class javax.swing.text.html.FormView.MouseEventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.FormView.MouseEventListener

No usage of javax.swing.text.html.FormView.MouseEventListener
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fc.g!=toesd npur


Uses of Class javax.swing.text.html.HTML

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTML

No usage of javax.swing.text.html.HTML
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/C..ref<>aaaoottdoa


Uses of Class javax.swing.text.html.HTML.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTML.Attribute

  • Packages that use HTML.Attribute
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTML.Attribute in javax.swing.text.html

      Fields in javax.swing.text.html declared as HTML.Attribute
      修饰符与类型 | 字段与描述
      static HTML.Attribute | HTML.Attribute.ACTION
      static HTML.Attribute | HTML.Attribute.ALIGN
      static HTML.Attribute | HTML.Attribute.ALINK
      static HTML.Attribute | HTML.Attribute.ALT
      static HTML.Attribute | HTML.Attribute.ARCHIVE
      static HTML.Attribute | HTML.Attribute.BACKGROUND
      static HTML.Attribute | HTML.Attribute.BGCOLOR
      static HTML.Attribute | HTML.Attribute.BORDER
      static HTML.Attribute | HTML.Attribute.CELLPADDING
      static HTML.Attribute | HTML.Attribute.CELLSPACING
      static HTML.Attribute | HTML.Attribute.CHECKED
      static HTML.Attribute | HTML.Attribute.类
      static HTML.Attribute | HTML.Attribute.CLASSID
      static HTML.Attribute | HTML.Attribute.CLEAR
      static HTML.Attribute | HTML.Attribute.CODE
      static HTML.Attribute | HTML.Attribute.CODEBASE
      static HTML.Attribute | HTML.Attribute.CODETYPE
      static HTML.Attribute | HTML.Attribute.COLOR
      static HTML.Attribute | HTML.Attribute.COLS
      static HTML.Attribute | HTML.Attribute.COLSPAN
      static HTML.Attribute | HTML.Attribute.COMMENT
      static HTML.Attribute | HTML.Attribute.COMPACT
      static HTML.Attribute | HTML.Attribute.CONTENT
      static HTML.Attribute | HTML.Attribute.COORDS
      static HTML.Attribute | HTML.Attribute.DATA
      static HTML.Attribute | HTML.Attribute.DECLARE
      static HTML.Attribute | HTML.Attribute.DIR
      static HTML.Attribute | HTML.Attribute.DUMMY
      static HTML.Attribute | HTML.Attribute.ENCTYPE
      static HTML.Attribute | HTML.Attribute.ENDTAG
      static HTML.Attribute | HTML.Attribute.FACE
      static HTML.Attribute | HTML.Attribute.FRAMEBORDER
      static HTML.Attribute | HTML.Attribute.HALIGN
      static HTML.Attribute | HTML.Attribute.HEIGHT
      static HTML.Attribute | HTML.Attribute.HREF
      static HTML.Attribute | HTML.Attribute.HSPACE
      static HTML.Attribute | HTML.Attribute.HTTPEQUIV
      static HTML.Attribute | HTML.Attribute.ID
      static HTML.Attribute | HTML.Attribute.ISMAP
      static HTML.Attribute | HTML.Attribute.LANG
      static HTML.Attribute | HTML.Attribute.LANGUAGE
      static HTML.Attribute | HTML.Attribute.LINK
      static HTML.Attribute | HTML.Attribute.LOWSRC
      static HTML.Attribute | HTML.Attribute.MARGINHEIGHT
      static HTML.Attribute | HTML.Attribute.MARGINWIDTH
      static HTML.Attribute | HTML.Attribute.MAXLENGTH
      static HTML.Attribute | HTML.Attribute.方法
      static HTML.Attribute | HTML.Attribute.MULTIPLE
      static HTML.Attribute | HTML.Attribute.N
      static HTML.Attribute | HTML.Attribute.NAME
      static HTML.Attribute | HTML.Attribute.NOHREF
      static HTML.Attribute | HTML.Attribute.NORESIZE
      static HTML.Attribute | HTML.Attribute.NOSHADE
      static HTML.Attribute | HTML.Attribute.NOWRAP
      static HTML.Attribute | HTML.Attribute.PROMPT
      static HTML.Attribute | HTML.Attribute.REL
      static HTML.Attribute | HTML.Attribute.REV
      static HTML.Attribute | HTML.Attribute.ROWS
      static HTML.Attribute | HTML.Attribute.ROWSPAN
      static HTML.Attribute | HTML.Attribute.SCROLLING
      static HTML.Attribute | HTML.Attribute.SELECTED
      static HTML.Attribute | HTML.Attribute.SHAPE
      static HTML.Attribute | HTML.Attribute.SHAPES
      static HTML.Attribute | HTML.Attribute.SIZE
      static HTML.Attribute | HTML.Attribute.SRC
      static HTML.Attribute | HTML.Attribute.STANDBY
      static HTML.Attribute | HTML.Attribute.START
      static HTML.Attribute | HTML.Attribute.STYLE
      static HTML.Attribute | HTML.Attribute.TARGET
      static HTML.Attribute | HTML.Attribute.TEXT
      static HTML.Attribute | HTML.Attribute.TITLE
      static HTML.Attribute | HTML.Attribute.TYPE
      static HTML.Attribute | HTML.Attribute.USEMAP
      static HTML.Attribute | HTML.Attribute.VALIGN
      static HTML.Attribute | HTML.Attribute.VALUE
      static HTML.Attribute | HTML.Attribute.VALUETYPE
      static HTML.Attribute | HTML.Attribute.VERSION
      static HTML.Attribute | HTML.Attribute.VLINK
      static HTML.Attribute | HTML.Attribute.VSPACE
      static HTML.Attribute | HTML.Attribute.WIDTH
      Methods in javax.swing.text.html that return HTML.Attribute
      修饰符与类型 方法与描述
      static HTML.Attribute[] HTML.getAllAttributeKeys()
      Returns the set of HTML attributes recognized.
      static HTML.Attribute HTML.getAttributeKey(String attName)
      Fetches an attribute constant for a well-known attribute name (i.e.
      Methods in javax.swing.text.html with parameters of type HTML.Attribute
      修饰符与类型 方法与描述
      static int HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
      Fetches an integer attribute value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.html.HTML.Tag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTML.Tag

  • Packages that use HTML.Tag
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTML.Tag in javax.swing.text.html

      Subclasses of HTML.Tag in javax.swing.text.html
      修饰符与类型 | 类与描述
      static class  | HTML.UnknownTag
      Fields in javax.swing.text.html declared as HTML.Tag
      修饰符与类型 | 字段与描述
      static HTML.Tag | HTML.Tag.A
      static HTML.Tag | HTML.Tag.ADDRESS
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.addTag
      Tag in HTML to start adding tags from.
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.alternateAddTag
      Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.alternateParentTag
      Alternate Tag to check for in the document if parentTag is not found.
      static HTML.Tag | HTML.Tag.APPLET
      static HTML.Tag | HTML.Tag.AREA
      static HTML.Tag | HTML.Tag.B
      static HTML.Tag | HTML.Tag.BASE
      static HTML.Tag | HTML.Tag.BASEFONT
      static HTML.Tag | HTML.Tag.BIG
      static HTML.Tag | HTML.Tag.BLOCKQUOTE
      static HTML.Tag | HTML.Tag.BODY
      static HTML.Tag | HTML.Tag.BR
      static HTML.Tag | HTML.Tag.CAPTION
      static HTML.Tag | HTML.Tag.CENTER
      static HTML.Tag | HTML.Tag.CITE
      static HTML.Tag | HTML.Tag.CODE
      static HTML.Tag HTML.Tag.COMMENT
      All comments are labeled with this tag.
      static HTML.Tag HTML.Tag.CONTENT
      All text content is labeled with this tag.
      static HTML.Tag | HTML.Tag.DD
      static HTML.Tag | HTML.Tag.DFN
      static HTML.Tag | HTML.Tag.DIR
      static HTML.Tag | HTML.Tag.DIV
      static HTML.Tag | HTML.Tag.DL
      static HTML.Tag | HTML.Tag.DT
      static HTML.Tag | HTML.Tag.EM
      static HTML.Tag | HTML.Tag.FONT
      static HTML.Tag | HTML.Tag.FORM
      static HTML.Tag | HTML.Tag.FRAME
      static HTML.Tag | HTML.Tag.FRAMESET
      static HTML.Tag | HTML.Tag.H1
      static HTML.Tag | HTML.Tag.H2
      static HTML.Tag | HTML.Tag.H3
      static HTML.Tag | HTML.Tag.H4
      static HTML.Tag | HTML.Tag.H5
      static HTML.Tag | HTML.Tag.H6
      static HTML.Tag | HTML.Tag.HEAD
      static HTML.Tag | HTML.Tag.HR
      static HTML.Tag | HTML.Tag.HTML
      static HTML.Tag | HTML.Tag.I
      static HTML.Tag | HTML.Tag.IMG
      static HTML.Tag HTML.Tag.IMPLIED
      All text content must be in a paragraph element.
      static HTML.Tag | HTML.Tag.INPUT
      static HTML.Tag | HTML.Tag.ISINDEX
      static HTML.Tag | HTML.Tag.KBD
      static HTML.Tag | HTML.Tag.LI
      static HTML.Tag | HTML.Tag.LINK
      static HTML.Tag | HTML.Tag.MAP
      static HTML.Tag | HTML.Tag.MENU
      static HTML.Tag | HTML.Tag.META
      static HTML.Tag | HTML.Tag.NOFRAMES
      static HTML.Tag | HTML.Tag.OBJECT
      static HTML.Tag | HTML.Tag.OL
      static HTML.Tag | HTML.Tag.OPTION
      static HTML.Tag | HTML.Tag.P
      static HTML.Tag | HTML.Tag.PARAM
      protected HTML.Tag HTMLEditorKit.InsertHTMLTextAction.parentTag
      Tag to check for in the document.
      static HTML.Tag | HTML.Tag.PRE
      static HTML.Tag | HTML.Tag.S
      static HTML.Tag | HTML.Tag.SAMP
      static HTML.Tag | HTML.Tag.SCRIPT
      static HTML.Tag | HTML.Tag.SELECT
      static HTML.Tag | HTML.Tag.SMALL
      static HTML.Tag | HTML.Tag.SPAN
      static HTML.Tag | HTML.Tag.STRIKE
      static HTML.Tag | HTML.Tag.STRONG
      static HTML.Tag | HTML.Tag.STYLE
      static HTML.Tag | HTML.Tag.SUB
      static HTML.Tag | HTML.Tag.SUP
      static HTML.Tag | HTML.Tag.TABLE
      static HTML.Tag | HTML.Tag.TD
      static HTML.Tag | HTML.Tag.TEXTAREA
      static HTML.Tag | HTML.Tag.TH
      static HTML.Tag | HTML.Tag.TITLE
      static HTML.Tag | HTML.Tag.TR
      static HTML.Tag | HTML.Tag.TT
      static HTML.Tag | HTML.Tag.U
      static HTML.Tag | HTML.Tag.UL
      static HTML.Tag | HTML.Tag.VAR
      Methods in javax.swing.text.html that return HTML.Tag
      修饰符与类型 方法与描述
      static HTML.Tag[] HTML.getAllTags()
      Returns the set of actual HTML tags that are recognized by the default HTML reader.
      abstract HTML.Tag HTMLDocument.Iterator.getTag()
      Type of tag this iterator represents.
      static HTML.Tag HTML.getTag(String tagName)
      Fetches a tag constant for a well-known tag name (i.e.
      Methods in javax.swing.text.html with parameters of type HTML.Tag
      修饰符与类型 | 方法与描述
      protected void HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a)
      Adds content that is basically specified entirely in the attribute set.
      protected void HTMLDocument.HTMLReader.blockClose(HTML.Tag t)
      Adds an instruction to the parse buffer to close out a block element of the given type.
      protected void HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr)
      Adds an instruction to the parse buffer to create a block element with the given attributes.
      protected int HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
      void HTMLDocument.HTMLReader.TagAction.end(HTML.Tag t)
      Called when an end tag is seen for the type of tag this action was registered to.
      void | HTMLDocument.HTMLReader.BlockAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.ParagraphAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.HiddenAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.PreAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.CharacterAction.end(HTML.Tag t)
      void | HTMLDocument.HTMLReader.FormAction.end(HTML.Tag t)
      protected Element HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
      Fetches an iterator for the specified HTML tag.
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag)
      Returns the reader for the parser to use to load the document with HTML.
      Style StyleSheet.getRule(HTML.Tag t, Element e)
      Fetches the style to use to render the given type of HTML tag.
      void | HTMLEditorKit.ParserCallback.handleEndTag(HTML.Tag t, int pos)
      void HTMLDocument.HTMLReader.handleEndTag(HTML.Tag t, int pos)
      Callback from the parser.
      void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      void HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
      Callback from the parser.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.
      protected boolean HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag)
      Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
      protected void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
      Registers a handler for the given tag.
      void HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a)
      Called when a start tag is seen for the type of tag this action was registered to.
      void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
      void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
      void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)
      Constructors in javax.swing.text.html with parameters of type HTML.Tag
      构造方法与描述
      HTMLDocument.HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)
      HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
      HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

    • Uses of HTML.Tag in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return HTML.Tag
      修饰符与类型 | 方法与描述
      HTML.Tag | TagElement.getHTMLTag()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.html.HTML.UnknownTag

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTML.UnknownTag

No usage of javax.swing.text.html.HTML.UnknownTag
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gp


Uses of Class javax.swing.text.html.HTMLDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument

  • Packages that use HTMLDocument
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLDocument
      修饰符与类型 | 方法与描述
      protected HTMLDocument | HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)
      Methods in javax.swing.text.html with parameters of type HTMLDocument
      修饰符与类型 方法与描述
      protected int HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
      protected Element HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag)
      Returns the deepest element at offset matching tag.
      protected Element[] HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset)
      Returns an array of the Elements that contain offset.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      This is invoked when inserting at a boundary.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
      Deprecated.
      As of Java 2 platform v1.3, use insertAtBoundary
      void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
      Inserts HTML into an existing document.
      protected void HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
      A cover for HTMLEditorKit.insertHTML.
      Constructors in javax.swing.text.html with parameters of type HTMLDocument
      构造方法与描述
      HTMLWriter(Writer w, HTMLDocument doc)
      Creates a new HTMLWriter.
      HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
      Creates a new HTMLWriter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a="tv >io=tb e a/


Uses of Class javax.swing.text.html.HTMLDocument.BlockElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.BlockElement

No usage of javax.swing.text.html.HTMLDocument.BlockElement
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

To


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader

No usage of javax.swing.text.html.HTMLDocument.HTMLReader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction

  • Packages that use HTMLDocument.HTMLReader.BlockAction
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.BlockAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.BlockAction in javax.swing.text.html
      修饰符与类型 | 类与描述
      class  | HTMLDocument.HTMLReader.ParagraphAction
      class  | HTMLDocument.HTMLReader.PreAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eHtswivaaaan"hhr/..//" e


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-"nra><>- "aaS= Nb


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.FormAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A /ab;1;p-1


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne/>Slplac< vo


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

匰 "/��2rlsri ^


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.PreAction

No usage of javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&Ta癰bb


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction

  • Packages that use HTMLDocument.HTMLReader.SpecialAction
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.SpecialAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.SpecialAction in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument.HTMLReader.FormAction
      Action to support forms by building all of the elements used to represent form controls.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tCrbi/l/g.r飅J>hi.靶鎛


Uses of Class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

  • Packages that use HTMLDocument.HTMLReader.TagAction
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.HTMLReader.TagAction in javax.swing.text.html

      Subclasses of HTMLDocument.HTMLReader.TagAction in javax.swing.text.html
      修饰符与类型 | 类与描述
      class  | HTMLDocument.HTMLReader.BlockAction
      class  | HTMLDocument.HTMLReader.CharacterAction
      class  HTMLDocument.HTMLReader.FormAction
      Action to support forms by building all of the elements used to represent form controls.
      class  | HTMLDocument.HTMLReader.HiddenAction
      class  | HTMLDocument.HTMLReader.IsindexAction
      class  | HTMLDocument.HTMLReader.ParagraphAction
      class  | HTMLDocument.HTMLReader.PreAction
      class  | HTMLDocument.HTMLReader.SpecialAction
      Methods in javax.swing.text.html with parameters of type HTMLDocument.HTMLReader.TagAction
      修饰符与类型 方法与描述
      protected void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
      Registers a handler for the given tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

is.y/a uom=ai.wllea//is


Uses of Class javax.swing.text.html.HTMLDocument.Iterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.Iterator

  • Packages that use HTMLDocument.Iterator
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLDocument.Iterator in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLDocument.Iterator
      修饰符与类型 方法与描述
      HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
      Fetches an iterator for the specified HTML tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea=hctiT.aaad.HHw/xwel >a


Uses of Class javax.swing.text.html.HTMLDocument.RunElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLDocument.RunElement

No usage of javax.swing.text.html.HTMLDocument.RunElement
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

isp


Uses of Class javax.swing.text.html.HTMLEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit

  • Packages that use HTMLEditorKit
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLEditorKit in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLEditorKit
      修饰符与类型 | 方法与描述
      protected HTMLEditorKit | HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bte ../..g/> >ner


Uses of Class javax.swing.text.html.HTMLEditorKit.HTMLFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.HTMLFactory

No usage of javax.swing.text.html.HTMLEditorKit.HTMLFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.u//....///.attrm-"i


Uses of Class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.HTMLTextAction

  • Packages that use HTMLEditorKit.HTMLTextAction
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLEditorKit.HTMLTextAction in javax.swing.text.html

      Subclasses of HTMLEditorKit.HTMLTextAction in javax.swing.text.html
      修饰符与类型 类与描述
      static class  HTMLEditorKit.InsertHTMLTextAction
      InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e""oy<"tbaolsg;pen


Uses of Class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction

No usage of javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eHf>i> >a<<<鰐ees


Uses of Class javax.swing.text.html.HTMLEditorKit.LinkController

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.LinkController

No usage of javax.swing.text.html.HTMLEditorKit.LinkController
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>=sRo>T>g莞be3& a癰bi


Uses of Class javax.swing.text.html.HTMLEditorKit.Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.Parser

  • Packages that use HTMLEditorKit.Parser
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTMLEditorKit.Parser in javax.swing.text.html

      Methods in javax.swing.text.html that return HTMLEditorKit.Parser
      修饰符与类型 方法与描述
      protected HTMLEditorKit.Parser HTMLEditorKit.getParser()
      Fetch the parser to use for reading HTML streams.
      HTMLEditorKit.Parser HTMLDocument.getParser()
      Returns the parser that is used when inserting HTML into the existing document.
      Methods in javax.swing.text.html with parameters of type HTMLEditorKit.Parser
      修饰符与类型 方法与描述
      void HTMLDocument.setParser(HTMLEditorKit.Parser parser)
      Sets the parser that is used by the methods that insert html into the existing document, such as setInnerHTML, and setOuterHTML.

    • Uses of HTMLEditorKit.Parser in javax.swing.text.html.parser

      Subclasses of HTMLEditorKit.Parser in javax.swing.text.html.parser
      修饰符与类型 类与描述
      class  ParserDelegator
      Responsible for starting up a new DocumentParser each time its parse method is invoked.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d鎟,>nteim/df.trjad絙=


Uses of Class javax.swing.text.html.HTMLEditorKit.ParserCallback

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLEditorKit.ParserCallback

  • Packages that use HTMLEditorKit.ParserCallback
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of HTMLEditorKit.ParserCallback in javax.swing.text.html

      Subclasses of HTMLEditorKit.ParserCallback in javax.swing.text.html
      修饰符与类型 类与描述
      class  HTMLDocument.HTMLReader
      An HTML reader to load an HTML document with an HTML element structure.
      Methods in javax.swing.text.html that return HTMLEditorKit.ParserCallback
      修饰符与类型 方法与描述
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos)
      Fetches the reader for the parser to use when loading the document with HTML.
      HTMLEditorKit.ParserCallback HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag)
      Returns the reader for the parser to use to load the document with HTML.
      Methods in javax.swing.text.html with parameters of type HTMLEditorKit.ParserCallback
      修饰符与类型 方法与描述
      abstract void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.

    • Uses of HTMLEditorKit.ParserCallback in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser with parameters of type HTMLEditorKit.ParserCallback
      修饰符与类型 | 方法与描述
      void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnlv"e"fa=tt,坟蟬


Uses of Class javax.swing.text.html.HTMLFrameHyperlinkEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLFrameHyperlinkEvent

  • Packages that use HTMLFrameHyperlinkEvent
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of HTMLFrameHyperlinkEvent in javax.swing.text.html

      Subclasses of HTMLFrameHyperlinkEvent in javax.swing.text.html
      修饰符与类型 类与描述
      class  FormSubmitEvent
      FormSubmitEvent is used to notify interested parties that a form was submited.
      Methods in javax.swing.text.html with parameters of type HTMLFrameHyperlinkEvent
      修饰符与类型 方法与描述
      void HTMLDocument.processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
      Processes HyperlinkEvents that are generated by documents in an HTML frame.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r/.hre f<<


Uses of Class javax.swing.text.html.HTMLWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.HTMLWriter

No usage of javax.swing.text.html.HTMLWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nop wi


Uses of Class javax.swing.text.html.ImageView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.ImageView

No usage of javax.swing.text.html.ImageView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>< t>p>lnpi/ t/oni�


Uses of Class javax.swing.text.html.InlineView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.InlineView

No usage of javax.swing.text.html.InlineView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ro rr歰 >#y_@�


Uses of Class javax.swing.text.html.ListView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.ListView

No usage of javax.swing.text.html.ListView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<>my


Uses of Class javax.swing.text.html.MinimalHTMLWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.MinimalHTMLWriter

No usage of javax.swing.text.html.MinimalHTMLWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o lpivd ett>x"j/a


Uses of Class javax.swing.text.html.ObjectView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.ObjectView

No usage of javax.swing.text.html.ObjectView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dnrnr&sj�>皉/


Uses of Class javax.swing.text.html.Option

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.Option

  • Packages that use Option
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of Option in javax.swing.text.html

      Methods in javax.swing.text.html with parameters of type Option
      修饰符与类型 方法与描述
      protected void HTMLWriter.writeOption(Option option)
      Writes out the content of the Option form element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vl// / >vhsd<>==ttbsi竧l


Uses of Class javax.swing.text.html.ParagraphView

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.ParagraphView

No usage of javax.swing.text.html.ParagraphView
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etwmarys-uuui...>-su.


Uses of Class javax.swing.text.html.StyleSheet

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.StyleSheet

  • Packages that use StyleSheet
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet
      修饰符与类型 | 方法与描述
      protected StyleSheet ImageView.getStyleSheet()
      Convenience method to get the StyleSheet.
      protected StyleSheet | ParagraphView.getStyleSheet()
      protected StyleSheet | InlineView.getStyleSheet()
      protected StyleSheet | BlockView.getStyleSheet()
      StyleSheet HTMLEditorKit.getStyleSheet()
      Get the set of styles currently being used to render the HTML elements.
      StyleSheet HTMLDocument.getStyleSheet()
      Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.
      StyleSheet[] StyleSheet.getStyleSheets()
      Returns an array of the linked StyleSheets.
      Methods in javax.swing.text.html with parameters of type StyleSheet
      修饰符与类型 方法与描述
      void StyleSheet.addStyleSheet(StyleSheet ss)
      Adds the rules from the StyleSheet ss to those of the receiver.
      void StyleSheet.removeStyleSheet(StyleSheet ss)
      Removes the StyleSheet ss from those of the receiver.
      void HTMLEditorKit.setStyleSheet(StyleSheet s)
      Set the set of styles to be used to render the various HTML elements.
      Constructors in javax.swing.text.html with parameters of type StyleSheet
      构造方法与描述
      HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
      Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
      HTMLDocument(StyleSheet styles)
      Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

asni .lc"ea .rhme s>>m


Uses of Class javax.swing.text.html.StyleSheet.BoxPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.StyleSheet.BoxPainter

  • Packages that use StyleSheet.BoxPainter
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet.BoxPainter in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet.BoxPainter
      修饰符与类型 方法与描述
      StyleSheet.BoxPainter StyleSheet.getBoxPainter(AttributeSet a)
      Fetches the box formatter to use for the given set of CSS attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&ic Vg//e>i/u= me.p


Uses of Class javax.swing.text.html.StyleSheet.ListPainter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.StyleSheet.ListPainter

  • Packages that use StyleSheet.ListPainter
    软件包 描述
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.

    • Uses of StyleSheet.ListPainter in javax.swing.text.html

      Methods in javax.swing.text.html that return StyleSheet.ListPainter
      修饰符与类型 方法与描述
      StyleSheet.ListPainter StyleSheet.getListPainter(AttributeSet a)
      Fetches the list formatter to use for the given set of CSS attributes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/v.../erfffaonn=m=sgu"ix


AttributeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 AttributeList

  • java.lang.Object
    • javax.swing.text.html.parser.AttributeList
  • 所有已实现的接口：
    Serializable, DTDConstants

    public final class AttributeList
extends Object
implements DTDConstants, Serializable
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct. An AttributeList can be obtained from the Element class using the getAttributes() method.

    It is actually an element in a linked list. Use the getNext() method repeatedly to enumerate all the attributes of an element.

    另请参见：
    Element

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      int | 修饰符
      String name
      AttributeList 下一个
      int | type
      String value
      Vector<?> values

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttributeList(String name)
      Create an attribute list element.
      AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
      Create an attribute list element.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      int | getModifier()
      String getName()
      AttributeList getNext()
      int | getType()
      String getValue()
      Enumeration<?> getValues()
      static int | name2type(String nm)
      String toString()
      Returns a string representation of the object.
      static String | type2name(int tp)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • name

        public String name

      • type

        public int type

      • values

        public Vector<?> values

      • 修饰符

        public int modifier

      • value

        public String value

      • 下一个

        public AttributeList next

    • 构造方法详细信息

      • AttributeList

        public AttributeList(String name)
        Create an attribute list element.

      • AttributeList

        public AttributeList(String name,
             int type,
             int modifier,
             String value,
             Vector<?> values,
             AttributeList next)
        Create an attribute list element.

    • 方法详细信息

      • getName

        public String getName()
        返回：
        attribute name

      • getType

        public int getType()
        返回：
        attribute type
        另请参见：
        DTDConstants

      • getModifier

        public int getModifier()
        返回：
        attribute modifier
        另请参见：
        DTDConstants

      • getValues

        public Enumeration<?> getValues()
        返回：
        possible attribute values

      • getValue

        public String getValue()
        返回：
        default attribute value

      • getNext

        public AttributeList getNext()
        返回：
        the next attribute in the list

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        string representation

      • name2type

        public static int name2type(String nm)

      • type2name

        public static String type2name(int tp)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ii=//>as


ContentModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 ContentModel

  • java.lang.Object
    • javax.swing.text.html.parser.ContentModel
  • 所有已实现的接口：
    Serializable

    public final class ContentModel
extends Object
implements Serializable
    A representation of a content model. A content model is basically a restricted BNF expression. It is restricted in the sense that it must be deterministic. This means that you don't have to represent it as a finite state automata.

    See Annex H on page 556 of the SGML handbook for more information.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object content
      The content.
      ContentModel 下一个
      The next content model (in a ',', '|' or '&' expression).
      int type
      Type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ContentModel()
      ContentModel(Element content)
      Create a content model for an element.
      ContentModel(int type, ContentModel content)
      Create a content model of a particular type.
      ContentModel(int type, Object content, ContentModel next)
      Create a content model of a particular type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean empty()
      Return true if the content model could match an empty input stream.
      Element first()
      Return the element that must be next.
      boolean first(Object token)
      Return true if the token could potentially be the first token in the input stream.
      void getElements(Vector<Element> elemVec)
      Update elemVec with the list of elements that are part of the this contentModel.
      String toString()
      Convert to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • type

        public int type
        Type. Either '*', '?', '+', ',', '|', '&'.

      • content

        public Object content
        The content. Either an Element or a ContentModel.

      • 下一个

        public ContentModel next
        The next content model (in a ',', '|' or '&' expression).

    • 构造方法详细信息

      • ContentModel

        public ContentModel()

      • ContentModel

        public ContentModel(Element content)
        Create a content model for an element.

      • ContentModel

        public ContentModel(int type,
            ContentModel content)
        Create a content model of a particular type.

      • ContentModel

        public ContentModel(int type,
            Object content,
            ContentModel next)
        Create a content model of a particular type.

    • 方法详细信息

      • empty

        public boolean empty()
        Return true if the content model could match an empty input stream.

      • getElements

        public void getElements(Vector<Element> elemVec)
        Update elemVec with the list of elements that are part of the this contentModel.

      • first

        public boolean first(Object token)
        Return true if the token could potentially be the first token in the input stream.

      • first

        public Element first()
        Return the element that must be next.

      • toString

        public String toString()
        Convert to a string.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bhlu


DocumentParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 DocumentParser

  • java.lang.Object
    • javax.swing.text.html.parser.Parser
      • javax.swing.text.html.parser.DocumentParser
  • 所有已实现的接口：
    DTDConstants

    public class DocumentParser
extends Parser
    A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing). Reads an InputStream of HTML and invokes the appropriate methods in the ParserCallback class. This is the default parser used by HTMLEditorKit to parse HTML url's.

    This will message the callback for all valid tags, as well as tags that are implied but not explicitly specified. For example, the html string (<p>blah) only has a p tag defined. The callback will see the following methods:

    1. handleStartTag(html, ...)
    2. handleStartTag(head, ...)
    3. handleEndTag(head)
    4. handleStartTag(body, ...)
    5. handleStartTag(p, ...)
    6. handleText(...)
    7. handleEndTag(p)
    8. handleEndTag(body)
    9. handleEndTag(html)
    The items in italic are implied, that is, although they were not explicitly specified, to be correct html they should have been present (head isn't necessary, but it is still generated). For tags that are implied, the AttributeSet argument will have a value of Boolean.TRUE for the key HTMLEditorKit.ParserCallback.IMPLIED.

    HTML.Attributes defines a type safe enumeration of html attributes. If an attribute key of a tag is defined in HTML.Attribute, the HTML.Attribute will be used as the key, otherwise a String will be used. For example <p foo=bar class=neat> has two attributes. foo is not defined in HTML.Attribute, where as class is, therefore the AttributeSet will have two values in it, HTML.Attribute.CLASS with a String value of 'neat' and the String key 'foo' with a String value of 'bar'.

    The position argument will indicate the start of the tag, comment or text. Similiar to arrays, the first character in the stream has a position of 0. For tags that are implied the position will indicate the location of the next encountered tag. In the first example, the implied start body and html tags will have the same position as the p tag, and the implied end p, html and body tags will all have the same position.

    As html skips whitespace the position for text will be the position of the first valid character, eg in the string '\n\n\nblah' the text 'blah' will have a position of 3, the newlines are skipped.

    For attributes that do not have a value, eg in the html string <foo blah> the attribute blah does not have a value, there are two possible values that will be placed in the AttributeSet's value:

    • If the DTD does not contain an definition for the element, or the definition does not have an explicit value then the value in the AttributeSet will be HTML.NULL_ATTRIBUTE_VALUE.
    • If the DTD contains an explicit value, as in: <!ATTLIST OPTION selected (selected) #IMPLIED> this value from the dtd (in this case selected) will be used.

    Once the stream has been parsed, the callback is notified of the most likely end of line string. The end of line string will be one of \n, \r or \r\n, which ever is encountered the most in parsing the stream.

    • 字段摘要

      • Fields inherited from class javax.swing.text.html.parser.Parser

        dtd, strict

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 构造方法摘要

      Constructors
      构造方法与描述
      DocumentParser(DTD dtd)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void handleComment(char[] text)
      Called when an HTML comment is encountered.
      protected void handleEmptyTag(TagElement tag)
      Handle Empty Tag.
      protected void handleEndTag(TagElement tag)
      Handle End Tag.
      protected void handleError(int ln, String errorMsg)
      An error has occurred.
      protected void handleStartTag(TagElement tag)
      Handle Start Tag.
      protected void handleText(char[] data)
      Handle Text.
      void | parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)

      • 方法 - 继承于类 javax.swing.text.html.parser.Parser

        endTag, error, error, error, error, flushAttributes, getAttributes, getCurrentLine, getCurrentPos, handleEOFInComment, handleTitle, makeTag, makeTag, markFirstTime, parse, parseDTDMarkup, parseMarkupDeclarations, startTag

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocumentParser

        public DocumentParser(DTD dtd)

    • 方法详细信息

      • parse

        public void parse(Reader in,
         HTMLEditorKit.ParserCallback callback,
         boolean ignoreCharSet)
           throws IOException
        抛出：
        IOException

      • handleStartTag

        protected void handleStartTag(TagElement tag)
        Handle Start Tag.
        重载：
        handleStartTag in class Parser

      • handleComment

        protected void handleComment(char[] text)
        Description copied from class: Parser
        Called when an HTML comment is encountered.
        重载：
        handleComment in class Parser

      • handleEmptyTag

        protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
        Handle Empty Tag.
        重载：
        handleEmptyTag in class Parser
        抛出：
        ChangedCharSetException

      • handleEndTag

        protected void handleEndTag(TagElement tag)
        Handle End Tag.
        重载：
        handleEndTag in class Parser

      • handleText

        protected void handleText(char[] data)
        Handle Text.
        重载：
        handleText in class Parser

      • handleError

        protected void handleError(int ln,
               String errorMsg)
        Description copied from class: Parser
        An error has occurred.
        重载：
        handleError in class Parser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l<...>././/./a竧e鵦/smxrtt萳n�/╝骀�


DTD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 DTD

  • java.lang.Object
    • javax.swing.text.html.parser.DTD
  • 所有已实现的接口：
    DTDConstants

    public class DTD
extends Object
implements DTDConstants
    The representation of an SGML DTD. DTD describes a document syntax and is used in parsing of HTML documents. It contains a list of elements and their attributes as well as a list of entities defined in the DTD.
    另请参见：
    Element, AttributeList, ContentModel, Parser

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      Element applet
      Element base
      Element body
      Hashtable<String,Element> elementHash
      Vector<Element> elements
      Hashtable<Object,Entity> entityHash
      static int | FILE_VERSION
      Element head
      Element html
      Element isindex
      Element meta
      String name
      Element p
      Element param
      Element pcdata
      Element title

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DTD(String name)
      Creates a new DTD with the specified name.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected AttributeList defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      protected ContentModel defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      protected Element defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Entity defEntity(String name, int type, int ch)
      Creates and returns a character Entity.
      protected Entity defEntity(String name, int type, String str)
      Creates and returns an Entity.
      void defineAttributes(String name, AttributeList atts)
      Defines attributes for an Element.
      Element defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Entity defineEntity(String name, int type, char[] data)
      Defines an entity.
      static DTD getDTD(String name)
      Returns a DTD with the specified name.
      Element getElement(int index)
      Gets an element by index.
      Element getElement(String name)
      Gets an element by name.
      Entity getEntity(int ch)
      Gets a character entity.
      Entity getEntity(String name)
      Gets an entity by name.
      String getName()
      Gets the name of the DTD.
      static void | putDTDHash(String name, DTD dtd)
      void read(DataInputStream in)
      Recreates a DTD from an archived format.
      String toString()
      Returns a string representation of this DTD.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • name

        public String name

      • elements

        public Vector<Element> elements

      • elementHash

        public Hashtable<String,Element> elementHash

      • entityHash

        public Hashtable<Object,Entity> entityHash

      • pcdata

        public final Element pcdata

      • html

        public final Element html

      • meta

        public final Element meta

      • base

        public final Element base

      • isindex

        public final Element isindex

      • head

        public final Element head

      • body

        public final Element body

      • applet

        public final Element applet

      • param

        public final Element param

      • p

        public final Element p

      • title

        public final Element title

      • FILE_VERSION

        public static final int FILE_VERSION
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DTD

        protected DTD(String name)
        Creates a new DTD with the specified name.
        参数：
        name - the name, as a String of the new DTD

    • 方法详细信息

      • getName

        public String getName()
        Gets the name of the DTD.
        返回：
        the name of the DTD

      • getEntity

        public Entity getEntity(String name)
        Gets an entity by name.
        返回：
        the Entity corresponding to the name String

      • getEntity

        public Entity getEntity(int ch)
        Gets a character entity.
        返回：
        the Entity corresponding to the ch character

      • getElement

        public Element getElement(String name)
        Gets an element by name. A new element is created if the element doesn't exist.
        参数：
        name - the requested String
        返回：
        the Element corresponding to name, which may be newly created

      • getElement

        public Element getElement(int index)
        Gets an element by index.
        参数：
        index - the requested index
        返回：
        the Element corresponding to index

      • defineEntity

        public Entity defineEntity(String name,
                  int type,
                  char[] data)
        Defines an entity. If the Entity specified by name, type, and data exists, it is returned; otherwise a new Entity is created and is returned.
        参数：
        name - the name of the Entity as a String
        type - the type of the Entity
        data - the Entity's data
        返回：
        the Entity requested or a new Entity if not found

      • defineElement

        public Element defineElement(String name,
                    int type,
                    boolean omitStart,
                    boolean omitEnd,
                    ContentModel content,
                    BitSet exclusions,
                    BitSet inclusions,
                    AttributeList atts)
        Returns the Element which matches the specified parameters. If one doesn't exist, a new one is created and returned.
        参数：
        name - the name of the Element
        type - the type of the Element
        omitStart - true if start should be omitted
        omitEnd - true if end should be omitted
        content - the ContentModel
        atts - the AttributeList specifying the Element
        返回：
        the Element specified

      • defineAttributes

        public void defineAttributes(String name,
                    AttributeList atts)
        Defines attributes for an Element.
        参数：
        name - the name of the Element
        atts - the AttributeList specifying the Element

      • defEntity

        public Entity defEntity(String name,
               int type,
               int ch)
        Creates and returns a character Entity.
        参数：
        name - the entity's name
        返回：
        the new character Entity

      • defEntity

        protected Entity defEntity(String name,
               int type,
               String str)
        Creates and returns an Entity.
        参数：
        name - the entity's name
        返回：
        the new Entity

      • defElement

        protected Element defElement(String name,
                 int type,
                 boolean omitStart,
                 boolean omitEnd,
                 ContentModel content,
                 String[] exclusions,
                 String[] inclusions,
                 AttributeList atts)
        Creates and returns an Element.
        参数：
        name - the element's name
        返回：
        the new Element

      • defAttributeList

        protected AttributeList defAttributeList(String name,
                             int type,
                             int modifier,
                             String value,
                             String values,
                             AttributeList atts)
        Creates and returns an AttributeList.
        参数：
        name - the attribute list's name
        返回：
        the new AttributeList

      • defContentModel

        protected ContentModel defContentModel(int type,
                           Object obj,
                           ContentModel next)
        Creates and returns a new content model.
        参数：
        type - the type of the new content model
        返回：
        the new ContentModel

      • toString

        public String toString()
        Returns a string representation of this DTD.
        重载：
        toString in class Object
        返回：
        the string representation of this DTD

      • putDTDHash

        public static void putDTDHash(String name,
              DTD dtd)

      • getDTD

        public static DTD getDTD(String name)
                  throws IOException
        Returns a DTD with the specified name. If a DTD with that name doesn't exist, one is created and returned. Any uppercase characters in the name are converted to lowercase.
        参数：
        name - the name of the DTD
        返回：
        the DTD which corresponds to name
        抛出：
        IOException

      • read

        public void read(DataInputStream in)
          throws IOException
        Recreates a DTD from an archived format.
        参数：
        in - the DataInputStream to read from
        抛出：
        IOException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DTDConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.swing.text.html.parser

Interface DTDConstants

  • All Known Implementing Classes:
    AttributeList, DocumentParser, DTD, Element, Entity, Parser

    public interface DTDConstants
    SGML constants used in a DTD. The names of the constants correspond the the equivalent SGML constructs as described in "The SGML Handbook" by Charles F. Goldfarb.
    另请参见：
    DTD, Element

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | ANY
      static int | CDATA
      static int | CONREF
      static int | CURRENT
      static int | DEFAULT
      static int | EMPTY
      static int | ENDTAG
      static int | ENTITIES
      static int | ENTITY
      static int | FIXED
      static int | GENERAL
      static int | ID
      static int | IDREF
      static int | IDREFS
      static int | IMPLIED
      static int | MD
      static int | MODEL
      static int | MS
      static int | NAME
      static int | NAMES
      static int | NMTOKEN
      static int | NMTOKENS
      static int | NOTATION
      static int | NUMBER
      static int | NUMBERS
      static int | NUTOKEN
      static int | NUTOKENS
      static int | PARAMETER
      static int | PI
      static int | PUBLIC
      static int | RCDATA
      static int | REQUIRED
      static int | SDATA
      static int | STARTTAG
      static int | SYSTEM

    • 字段详细信息

      • CDATA

        static final int CDATA
        另请参见：
        Constant Field Values

      • ENTITY

        static final int ENTITY
        另请参见：
        Constant Field Values

      • ENTITIES

        static final int ENTITIES
        另请参见：
        Constant Field Values

      • ID

        static final int ID
        另请参见：
        Constant Field Values

      • IDREF

        static final int IDREF
        另请参见：
        Constant Field Values

      • IDREFS

        static final int IDREFS
        另请参见：
        Constant Field Values

      • NAME

        static final int NAME
        另请参见：
        Constant Field Values

      • NAMES

        static final int NAMES
        另请参见：
        Constant Field Values

      • NMTOKEN

        static final int NMTOKEN
        另请参见：
        Constant Field Values

      • NMTOKENS

        static final int NMTOKENS
        另请参见：
        Constant Field Values

      • NOTATION

        static final int NOTATION
        另请参见：
        Constant Field Values

      • NUMBER

        static final int NUMBER
        另请参见：
        Constant Field Values

      • NUMBERS

        static final int NUMBERS
        另请参见：
        Constant Field Values

      • NUTOKEN

        static final int NUTOKEN
        另请参见：
        Constant Field Values

      • NUTOKENS

        static final int NUTOKENS
        另请参见：
        Constant Field Values

      • RCDATA

        static final int RCDATA
        另请参见：
        Constant Field Values

      • EMPTY

        static final int EMPTY
        另请参见：
        Constant Field Values

      • MODEL

        static final int MODEL
        另请参见：
        Constant Field Values

      • ANY

        static final int ANY
        另请参见：
        Constant Field Values

      • FIXED

        static final int FIXED
        另请参见：
        Constant Field Values

      • REQUIRED

        static final int REQUIRED
        另请参见：
        Constant Field Values

      • CURRENT

        static final int CURRENT
        另请参见：
        Constant Field Values

      • CONREF

        static final int CONREF
        另请参见：
        Constant Field Values

      • IMPLIED

        static final int IMPLIED
        另请参见：
        Constant Field Values

      • PUBLIC

        static final int PUBLIC
        另请参见：
        Constant Field Values

      • SDATA

        static final int SDATA
        另请参见：
        Constant Field Values

      • PI

        static final int PI
        另请参见：
        Constant Field Values

      • STARTTAG

        static final int STARTTAG
        另请参见：
        Constant Field Values

      • ENDTAG

        static final int ENDTAG
        另请参见：
        Constant Field Values

      • MS

        static final int MS
        另请参见：
        Constant Field Values

      • MD

        static final int MD
        另请参见：
        Constant Field Values

      • SYSTEM

        static final int SYSTEM
        另请参见：
        Constant Field Values

      • GENERAL

        static final int GENERAL
        另请参见：
        Constant Field Values

      • DEFAULT

        static final int DEFAULT
        另请参见：
        Constant Field Values

      • PARAMETER

        static final int PARAMETER
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lld s"ct"cokkcoos


Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.text.html.parser

类 Element

  • java.lang.Object
    • javax.swing.text.html.parser.Element
  • 所有已实现的接口：
    Serializable, DTDConstants

    public final class Element
extends Object
implements DTDConstants, Serializable
    An element as described in a DTD using the ELEMENT construct. This is essentiall the description of a tag. It describes the type, content model, attributes, attribute types etc. It is used to correctly parse a document by the Parser.
    另请参见：
    DTD, AttributeList

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      AttributeList atts
      ContentModel content
      Object data
      A field to store user data.
      BitSet exclusions
      BitSet inclusions
      int | index
      String name
      boolean | oEnd
      boolean | oStart
      int | type

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      AttributeList getAttribute(String name)
      Get an attribute by name.
      AttributeList getAttributeByValue(String name)
      Get an attribute by value.
      AttributeList getAttributes()
      Get the attributes.
      ContentModel getContent()
      Get content model
      int getIndex()
      Get index.
      String getName()
      Get the name of the element.
      int getType()
      Get type.
      boolean isEmpty()
      Check if empty
      static int | name2type(String nm)
      boolean omitEnd()
      Return true if the end tag can be omitted.
      boolean omitStart()
      Return true if the start tag can be omitted.
      String toString()
      Convert to a string.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • index

        public int index

      • name

        public String name

      • oStart

        public boolean oStart

      • oEnd

        public boolean oEnd

      • inclusions

        public BitSet inclusions

      • exclusions

        public BitSet exclusions

      • type

        public int type

      • content

        public ContentModel content

      • atts

        public AttributeList atts

      • data

        public Object data
        A field to store user data. Mostly used to store style sheets.

    • 方法详细信息

      • getName

        public String getName()
        Get the name of the element.

      • omitStart

        public boolean omitStart()
        Return true if the start tag can be omitted.

      • omitEnd

        public boolean omitEnd()
        Return true if the end tag can be omitted.

      • getType

        public int getType()
        Get type.

      • getContent

        public ContentModel getContent()
        Get content model

      • getAttributes

        public AttributeList getAttributes()
        Get the attributes.

      • getIndex

        public int getIndex()
        Get index.

      • isEmpty

        public boolean isEmpty()
        Check if empty

      • toString

        public String toString()
        Convert to a string.
        重载：
        toString in class Object
        返回：
        a string representation of the object.

      • getAttribute

        public AttributeList getAttribute(String name)
        Get an attribute by name.

      • getAttributeByValue

        public AttributeList getAttributeByValue(String name)
        Get an attribute by value.

      • name2type

        public static int name2type(String nm)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h ttDtDt.tsns.sssrttlu>


Entity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 Entity

  • java.lang.Object
    • javax.swing.text.html.parser.Entity
  • 所有已实现的接口：
    DTDConstants

    public final class Entity
extends Object
implements DTDConstants
    An entity is described in a DTD using the ENTITY construct. It defines the type and value of the the entity.
    另请参见：
    DTD

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      char[] | data
      String name
      int | type

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 构造方法摘要

      Constructors
      构造方法与描述
      Entity(String name, int type, char[] data)
      Creates an entity.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      char[] getData()
      Returns the data.
      String getName()
      Gets the name of the entity.
      String getString()
      Returns the data as a String.
      int getType()
      Gets the type of the entity.
      boolean isGeneral()
      Returns true if it is a general entity.
      boolean isParameter()
      Returns true if it is a parameter entity.
      static int name2type(String nm)
      Converts nm string to the corresponding entity type.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        public String name

      • type

        public int type

      • data

        public char[] data

    • 构造方法详细信息

      • Entity

        public Entity(String name,
      int type,
      char[] data)
        Creates an entity.
        参数：
        name - the name of the entity
        type - the type of the entity
        data - the char array of data

    • 方法详细信息

      • getName

        public String getName()
        Gets the name of the entity.
        返回：
        the name of the entity, as a String

      • getType

        public int getType()
        Gets the type of the entity.
        返回：
        the type of the entity

      • isParameter

        public boolean isParameter()
        Returns true if it is a parameter entity.
        返回：
        true if it is a parameter entity

      • isGeneral

        public boolean isGeneral()
        Returns true if it is a general entity.
        返回：
        true if it is a general entity

      • getData

        public char[] getData()
        Returns the data.
        返回：
        the data

      • getString

        public String getString()
        Returns the data as a String.
        返回：
        the data as a String

      • name2type

        public static int name2type(String nm)
        Converts nm string to the corresponding entity type. If the string does not have a corresponding entity type, returns the type corresponding to "CDATA". Valid entity types are: "PUBLIC", "CDATA", "SDATA", "PI", "STARTTAG", "ENDTAG", "MS", "MD", "SYSTEM".
        参数：
        nm - the string to be converted
        返回：
        the corresponding entity type, or the type corresponding to "CDATA", if none exists
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nutpa&e>&edlleddeexx/xaxxeel/treoh//tavvv//"C


javax.swing.text.html.parser

Interfaces

  • DTDConstants

Classes

  • AttributeList
  • ContentModel
  • DocumentParser
  • DTD
  • Element
  • Entity
  • Parser
  • ParserDelegator
  • TagElement
s


javax.swing.text.html.parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.text.html.parser

Provides the default HTML parser, along with support classes.

请参见： 描述

  • 接口摘要
    接口 描述
    DTDConstants
    SGML constants used in a DTD.
  • Class Summary
    类 描述
    AttributeList
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
    ContentModel
    A representation of a content model.
    DocumentParser
    A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
    DTD
    The representation of an SGML DTD.
    Element
    An element as described in a DTD using the ELEMENT construct.
    Entity
    An entity is described in a DTD using the ENTITY construct.
    Parser
    A simple DTD-driven HTML parser.
    ParserDelegator
    Responsible for starting up a new DocumentParser each time its parse method is invoked.
    TagElement
    A generic HTML TagElement class.

软件包 javax.swing.text.html.parser Description

Provides the default HTML parser, along with support classes. As the stream is parsed, the parser notifies a delegate, which must implement the HTMLEditorKit.ParserCallback interface.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
另请参见：
HTMLEditorKit.ParserCallback
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,sh,onnsnignnneSSdotsun3e


javax.swing.text.html.parser Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.text.html.parser

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • javax.swing.text.html.parser.TagElement

Interface Hierarchy

  • javax.swing.text.html.parser.DTDConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ilpa"atxjvcje i"//o


Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 Parser

  • java.lang.Object
    • javax.swing.text.html.parser.Parser
  • 所有已实现的接口：
    DTDConstants
    直接已知子类：
    DocumentParser

    public class Parser
extends Object
implements DTDConstants
    A simple DTD-driven HTML parser. The parser reads an HTML file from an InputStream and calls various methods (which should be overridden in a subclass) when tags and data are encountered.

    Unfortunately there are many badly implemented HTML parsers out there, and as a result there are many badly formatted HTML files. This parser attempts to parse most HTML files. This means that the implementation sometimes deviates from the SGML specification in favor of HTML.

    The parser treats \r and \r\n as \n. Newlines after starttags and before end tags are ignored just as specified in the SGML/HTML specification.

    The html spec does not specify how spaces are to be coalesced very well. Specifically, the following scenarios are not discussed (note that a space should be used here, but I am using &nbsp to force the space to be displayed):

    '<b>blah <i> <strike> foo' which can be treated as: '<b>blah <i><strike>foo'

    as well as: '<p><a href="xx"> <em>Using</em></a></p>' which appears to be treated as: '<p><a href="xx"><em>Using</em></a></p>'

    If strict is false, when a tag that breaks flow, (TagElement.breaksFlows) or trailing whitespace is encountered, all whitespace will be ignored until a non whitespace character is encountered. This appears to give behavior closer to the popular browsers.

    另请参见：
    DTD, TagElement, SimpleAttributeSet

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected DTD | dtd
      protected boolean strict
      This flag determines whether or not the Parser will be strict in enforcing SGML compatibility.

      • 字段 - 继承于接口 javax.swing.text.html.parser.DTDConstants

        ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM

    • 构造方法摘要

      Constructors
      构造方法与描述
      Parser(DTD dtd)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void endTag(boolean omitted)
      Handle an end tag.
      protected void | error(String err)
      protected void | error(String err, String arg1)
      protected void | error(String err, String arg1, String arg2)
      protected void error(String err, String arg1, String arg2, String arg3)
      Invoke the error handler.
      protected void | flushAttributes()
      protected SimpleAttributeSet | getAttributes()
      protected int | getCurrentLine()
      protected int | getCurrentPos()
      protected void handleComment(char[] text)
      Called when an HTML comment is encountered.
      protected void handleEmptyTag(TagElement tag)
      Called when an empty tag is encountered.
      protected void handleEndTag(TagElement tag)
      Called when an end tag is encountered.
      protected void | handleEOFInComment()
      protected void handleError(int ln, String msg)
      An error has occurred.
      protected void handleStartTag(TagElement tag)
      Called when a start tag is encountered.
      protected void handleText(char[] text)
      Called when PCDATA is encountered.
      protected void handleTitle(char[] text)
      Called when an HTML title tag is encountered.
      protected TagElement | makeTag(Element elem)
      protected TagElement makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      protected void markFirstTime(Element elem)
      Marks the first time a tag has been seen in a document
      void parse(Reader in)
      Parse an HTML stream, given a DTD.
      String parseDTDMarkup()
      Parses th Document Declaration Type markup declaration.
      protected boolean parseMarkupDeclarations(StringBuffer strBuff)
      Parse markup declarations.
      protected void startTag(TagElement tag)
      Handle a start tag.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • dtd

        protected DTD dtd

      • strict

        protected boolean strict
        This flag determines whether or not the Parser will be strict in enforcing SGML compatibility. If false, it will be lenient with certain common classes of erroneous HTML constructs. Strict or not, in either case an error will be recorded.

    • 构造方法详细信息

      • Parser

        public Parser(DTD dtd)

    • 方法详细信息

      • getCurrentLine

        protected int getCurrentLine()
        返回：
        the line number of the line currently being parsed

      • makeTag

        protected TagElement makeTag(Element elem,
                 boolean fictional)
        Makes a TagElement.

      • makeTag

        protected TagElement makeTag(Element elem)

      • getAttributes

        protected SimpleAttributeSet getAttributes()

      • flushAttributes

        protected void flushAttributes()

      • handleText

        protected void handleText(char[] text)
        Called when PCDATA is encountered.

      • handleTitle

        protected void handleTitle(char[] text)
        Called when an HTML title tag is encountered.

      • handleComment

        protected void handleComment(char[] text)
        Called when an HTML comment is encountered.

      • handleEOFInComment

        protected void handleEOFInComment()

      • handleEmptyTag

        protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
        Called when an empty tag is encountered.
        抛出：
        ChangedCharSetException

      • handleStartTag

        protected void handleStartTag(TagElement tag)
        Called when a start tag is encountered.

      • handleEndTag

        protected void handleEndTag(TagElement tag)
        Called when an end tag is encountered.

      • handleError

        protected void handleError(int ln,
               String msg)
        An error has occurred.

      • error

        protected void error(String err,
         String arg1,
         String arg2,
         String arg3)
        Invoke the error handler.

      • error

        protected void error(String err,
         String arg1,
         String arg2)

      • error

        protected void error(String err,
         String arg1)

      • error

        protected void error(String err)

      • startTag

        protected void startTag(TagElement tag)
                 throws ChangedCharSetException
        Handle a start tag. The new tag is pushed onto the tag stack. The attribute list is checked for required attributes.
        抛出：
        ChangedCharSetException

      • endTag

        protected void endTag(boolean omitted)
        Handle an end tag. The end tag is popped from the tag stack.

      • markFirstTime

        protected void markFirstTime(Element elem)
        Marks the first time a tag has been seen in a document

      • parseDTDMarkup

        public String parseDTDMarkup()
                      throws IOException
        Parses th Document Declaration Type markup declaration. Currently ignores it.
        抛出：
        IOException

      • parseMarkupDeclarations

        protected boolean parseMarkupDeclarations(StringBuffer strBuff)
                                   throws IOException
        Parse markup declarations. Currently only handles the Document Type Declaration markup. Returns true if it is a markup declaration false otherwise.
        抛出：
        IOException

      • parse

        public void parse(Reader in)
           throws IOException
        Parse an HTML stream, given a DTD.
        抛出：
        IOException

      • getCurrentPos

        protected int getCurrentPos()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParserDelegator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 ParserDelegator

  • java.lang.Object
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator
  • 所有已实现的接口：
    Serializable

    public class ParserDelegator
extends HTMLEditorKit.Parser
implements Serializable
    Responsible for starting up a new DocumentParser each time its parse method is invoked. Stores a reference to the dtd.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParserDelegator()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected static DTD | createDTD(DTD dtd, String name)
      void parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
      Parse the given stream and drive the given callback with the results of the parse.
      protected static void | setDefaultDTD()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ParserDelegator

        public ParserDelegator()

    • 方法详细信息

      • setDefaultDTD

        protected static void setDefaultDTD()

      • createDTD

        protected static DTD createDTD(DTD dtd,
            String name)

      • parse

        public void parse(Reader r,
         HTMLEditorKit.ParserCallback cb,
         boolean ignoreCharSet)
           throws IOException
        Description copied from class: HTMLEditorKit.Parser
        Parse the given stream and drive the given callback with the results of the parse. This method should be implemented to be thread-safe.
        指定者：
        parse in class HTMLEditorKit.Parser
        抛出：
        IOException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j>a/".r..rheerhhgeooo"tw>""c>


TagElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.html.parser

类 TagElement

  • java.lang.Object
    • javax.swing.text.html.parser.TagElement

  • public class TagElement
extends Object
    A generic HTML TagElement class. The methods define how white space is interpreted around the tag.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TagElement(Element elem)
      TagElement(Element elem, boolean fictional)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      boolean | breaksFlow()
      boolean | fictional()
      Element getElement()
      HTML.Tag getHTMLTag()
      boolean | isPreformatted()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TagElement

        public TagElement(Element elem)

      • TagElement

        public TagElement(Element elem,
          boolean fictional)

    • 方法详细信息

      • breaksFlow

        public boolean breaksFlow()

      • isPreformatted

        public boolean isPreformatted()

      • getElement

        public Element getElement()

      • getHTMLTag

        public HTML.Tag getHTMLTag()

      • fictional

        public boolean fictional()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/; l s e =nne" na.. pl{Cll.ypllttc=y


Uses of Package javax.swing.text.html.parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.text.html.parser

  • Packages that use javax.swing.text.html.parser
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.
  • Classes in javax.swing.text.html.parser used by javax.swing.text.html.parser
    类与描述
    AttributeList
    This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
    ContentModel
    A representation of a content model.
    DTD
    The representation of an SGML DTD.
    DTDConstants
    SGML constants used in a DTD.
    Element
    An element as described in a DTD using the ELEMENT construct.
    Entity
    An entity is described in a DTD using the ENTITY construct.
    Parser
    A simple DTD-driven HTML parser.
    TagElement
    A generic HTML TagElement class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.html.parser.AttributeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.AttributeList

  • Packages that use AttributeList
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of AttributeList in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as AttributeList
      修饰符与类型 | 字段与描述
      AttributeList | Element.atts
      AttributeList | AttributeList.下一个
      Methods in javax.swing.text.html.parser that return AttributeList
      修饰符与类型 | 方法与描述
      protected AttributeList DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      AttributeList Element.getAttribute(String name)
      Get an attribute by name.
      AttributeList Element.getAttributeByValue(String name)
      Get an attribute by value.
      AttributeList Element.getAttributes()
      Get the attributes.
      AttributeList | AttributeList.getNext()
      Methods in javax.swing.text.html.parser with parameters of type AttributeList
      修饰符与类型 方法与描述
      protected AttributeList DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
      Creates and returns an AttributeList.
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      void DTD.defineAttributes(String name, AttributeList atts)
      Defines attributes for an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Constructors in javax.swing.text.html.parser with parameters of type AttributeList
      构造方法与描述
      AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
      Create an attribute list element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.text.html.parser.ContentModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.ContentModel

  • Packages that use ContentModel
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of ContentModel in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as ContentModel
      修饰符与类型 | 字段与描述
      ContentModel | Element.content
      ContentModel ContentModel.下一个
      The next content model (in a ',', '|' or '&' expression).
      Methods in javax.swing.text.html.parser that return ContentModel
      修饰符与类型 方法与描述
      protected ContentModel DTD.defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      ContentModel Element.getContent()
      Get content model
      Methods in javax.swing.text.html.parser with parameters of type ContentModel
      修饰符与类型 方法与描述
      protected ContentModel DTD.defContentModel(int type, Object obj, ContentModel next)
      Creates and returns a new content model.
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Constructors in javax.swing.text.html.parser with parameters of type ContentModel
      构造方法与描述
      ContentModel(int type, ContentModel content)
      Create a content model of a particular type.
      ContentModel(int type, Object content, ContentModel next)
      Create a content model of a particular type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l "tttresrrrpxvv&t&l/"<;&o/


Uses of Class javax.swing.text.html.parser.DocumentParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.DocumentParser

No usage of javax.swing.text.html.parser.DocumentParser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cdo>blosasss d//s/tn>


Uses of Class javax.swing.text.html.parser.DTD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.DTD

  • Packages that use DTD
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of DTD in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as DTD
      修饰符与类型 | 字段与描述
      protected DTD | Parser.dtd
      Methods in javax.swing.text.html.parser that return DTD
      修饰符与类型 | 方法与描述
      protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
      static DTD DTD.getDTD(String name)
      Returns a DTD with the specified name.
      Methods in javax.swing.text.html.parser with parameters of type DTD
      修饰符与类型 | 方法与描述
      protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
      static void | DTD.putDTDHash(String name, DTD dtd)
      Constructors in javax.swing.text.html.parser with parameters of type DTD
      构造方法与描述
      DocumentParser(DTD dtd)
      Parser(DTD dtd)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

avdtn#lCCChnpdsv


Uses of Class javax.swing.text.html.parser.Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.Element

  • Packages that use Element
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Element in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser declared as Element
      修饰符与类型 | 字段与描述
      Element | DTD.applet
      Element | DTD.base
      Element | DTD.body
      Element | DTD.head
      Element | DTD.html
      Element | DTD.isindex
      Element | DTD.meta
      Element | DTD.p
      Element | DTD.param
      Element | DTD.pcdata
      Element | DTD.title
      Fields in javax.swing.text.html.parser with type parameters of type Element
      修饰符与类型 | 字段与描述
      Hashtable<String,Element> | DTD.elementHash
      Vector<Element> | DTD.elements
      Methods in javax.swing.text.html.parser that return Element
      修饰符与类型 | 方法与描述
      protected Element DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
      Creates and returns an Element.
      Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
      Returns the Element which matches the specified parameters.
      Element ContentModel.first()
      Return the element that must be next.
      Element | TagElement.getElement()
      Element DTD.getElement(int index)
      Gets an element by index.
      Element DTD.getElement(String name)
      Gets an element by name.
      Methods in javax.swing.text.html.parser with parameters of type Element
      修饰符与类型 | 方法与描述
      protected TagElement | Parser.makeTag(Element elem)
      protected TagElement Parser.makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      protected void Parser.markFirstTime(Element elem)
      Marks the first time a tag has been seen in a document
      Method parameters in javax.swing.text.html.parser with type arguments of type Element
      修饰符与类型 方法与描述
      void ContentModel.getElements(Vector<Element> elemVec)
      Update elemVec with the list of elements that are part of the this contentModel.
      Constructors in javax.swing.text.html.parser with parameters of type Element
      构造方法与描述
      ContentModel(Element content)
      Create a content model for an element.
      TagElement(Element elem)
      TagElement(Element elem, boolean fictional)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=p"


Uses of Class javax.swing.text.html.parser.Entity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.Entity

  • Packages that use Entity
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Entity in javax.swing.text.html.parser

      Fields in javax.swing.text.html.parser with type parameters of type Entity
      修饰符与类型 | 字段与描述
      Hashtable<Object,Entity> | DTD.entityHash
      Methods in javax.swing.text.html.parser that return Entity
      修饰符与类型 方法与描述
      Entity DTD.defEntity(String name, int type, int ch)
      Creates and returns a character Entity.
      protected Entity DTD.defEntity(String name, int type, String str)
      Creates and returns an Entity.
      Entity DTD.defineEntity(String name, int type, char[] data)
      Defines an entity.
      Entity DTD.getEntity(int ch)
      Gets a character entity.
      Entity DTD.getEntity(String name)
      Gets an entity by name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eh<


Uses of Class javax.swing.text.html.parser.Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.Parser

  • Packages that use Parser
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of Parser in javax.swing.text.html.parser

      Subclasses of Parser in javax.swing.text.html.parser
      修饰符与类型 类与描述
      class  DocumentParser
      A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"p.>stra/>>>tf iTaDlT/t


Uses of Class javax.swing.text.html.parser.ParserDelegator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.ParserDelegator

No usage of javax.swing.text.html.parser.ParserDelegator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.s.hi><>i <糰a..lry


Uses of Class javax.swing.text.html.parser.TagElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.html.parser.TagElement

  • Packages that use TagElement
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of TagElement in javax.swing.text.html.parser

      Methods in javax.swing.text.html.parser that return TagElement
      修饰符与类型 | 方法与描述
      protected TagElement | Parser.makeTag(Element elem)
      protected TagElement Parser.makeTag(Element elem, boolean fictional)
      Makes a TagElement.
      Methods in javax.swing.text.html.parser with parameters of type TagElement
      修饰符与类型 方法与描述
      protected void Parser.handleEmptyTag(TagElement tag)
      Called when an empty tag is encountered.
      protected void DocumentParser.handleEmptyTag(TagElement tag)
      Handle Empty Tag.
      protected void Parser.handleEndTag(TagElement tag)
      Called when an end tag is encountered.
      protected void DocumentParser.handleEndTag(TagElement tag)
      Handle End Tag.
      protected void Parser.handleStartTag(TagElement tag)
      Called when a start tag is encountered.
      protected void DocumentParser.handleStartTag(TagElement tag)
      Handle Start Tag.
      protected void Parser.startTag(TagElement tag)
      Handle a start tag.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sbaicr>dlt=. .cit="tcp


Uses of Interface javax.swing.text.html.parser.DTDConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.text.html.parser.DTDConstants

  • Packages that use DTDConstants
    软件包 描述
    javax.swing.text.html.parser
    Provides the default HTML parser, along with support classes.

    • Uses of DTDConstants in javax.swing.text.html.parser

      Classes in javax.swing.text.html.parser that implement DTDConstants
      修饰符与类型 类与描述
      class  AttributeList
      This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
      class  DocumentParser
      A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
      class  DTD
      The representation of an SGML DTD.
      class  Element
      An element as described in a DTD using the ELEMENT construct.
      class  Entity
      An entity is described in a DTD using the ENTITY construct.
      class  Parser
      A simple DTD-driven HTML parser.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gs>/arsemnnno...lasvnaaun


javax.swing.text.rtf

Classes

  • RTFEditorKit


javax.swing.text.rtf

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.text.rtf

Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

请参见： 描述

  • Class Summary
    类 描述
    RTFEditorKit
    This is the default implementation of RTF editing functionality.

软件包 javax.swing.text.rtf Description

Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jo#


javax.swing.text.rtf Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.text.rtf

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.rtf.RTFEditorKit
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

utma/ .htoei 祃.c/o�


RTFEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.text.rtf

类 RTFEditorKit

  • java.lang.Object
    • javax.swing.text.EditorKit
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.rtf.RTFEditorKit
  • 所有已实现的接口：
    Serializable, Cloneable

    public class RTFEditorKit
extends StyledEditorKit
    This is the default implementation of RTF editing functionality. The RTF support was not written by the Swing team. In the future we hope to improve the support provided.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.text.StyledEditorKit

        StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction

      • Nested classes/interfaces inherited from class javax.swing.text.DefaultEditorKit

        DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction

    • 字段摘要

      • Fields inherited from class javax.swing.text.DefaultEditorKit

        backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction

    • 构造方法摘要

      Constructors
      构造方法与描述
      RTFEditorKit()
      Constructs an RTFEditorKit.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getContentType()
      Get the MIME type of the data that this kit represents support for.
      void read(InputStream in, Document doc, int pos)
      Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
      void read(Reader in, Document doc, int pos)
      Insert content from the given stream, which will be treated as plain text.
      void write(OutputStream out, Document doc, int pos, int len)
      Write content from a document to the given stream in a format appropriate for this kind of content handler.
      void write(Writer out, Document doc, int pos, int len)
      Write content from a document to the given stream as plain text.

      • 方法 - 继承于类 javax.swing.text.StyledEditorKit

        clone, createDefaultDocument, createInputAttributes, deinstall, getActions, getCharacterAttributeRun, getInputAttributes, getViewFactory, install

      • 方法 - 继承于类 javax.swing.text.DefaultEditorKit

        createCaret

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RTFEditorKit

        public RTFEditorKit()
        Constructs an RTFEditorKit.

    • 方法详细信息

      • getContentType

        public String getContentType()
        Get the MIME type of the data that this kit represents support for. This kit supports the type text/rtf.
        重载：
        getContentType in class DefaultEditorKit
        返回：
        the type

      • read

        public void read(InputStream in,
        Document doc,
        int pos)
          throws IOException,
                 BadLocationException
        Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
        重载：
        read in class DefaultEditorKit
        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(OutputStream out,
         Document doc,
         int pos,
         int len)
           throws IOException,
                  BadLocationException
        Write content from a document to the given stream in a format appropriate for this kind of content handler.
        重载：
        write in class DefaultEditorKit
        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content.
        len - The amount to write out.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • read

        public void read(Reader in,
        Document doc,
        int pos)
          throws IOException,
                 BadLocationException
        Insert content from the given stream, which will be treated as plain text.
        重载：
        read in class DefaultEditorKit
        参数：
        in - The stream to read from
        doc - The destination for the insertion.
        pos - The location in the document to place the content.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.

      • write

        public void write(Writer out,
         Document doc,
         int pos,
         int len)
           throws IOException,
                  BadLocationException
        Write content from a document to the given stream as plain text.
        重载：
        write in class DefaultEditorKit
        参数：
        out - The stream to write to
        doc - The source for the write.
        pos - The location in the document to fetch the content.
        len - The amount to write out.
        抛出：
        IOException - on any I/O error
        BadLocationException - if pos represents an invalid location within the document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/0no


Uses of Package javax.swing.text.rtf

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.text.rtf

No usage of javax.swing.text.rtf
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/thg/xnxasssa/ r1>/a


Uses of Class javax.swing.text.rtf.RTFEditorKit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.text.rtf.RTFEditorKit

No usage of javax.swing.text.rtf.RTFEditorKit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/g


AbstractLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 AbstractLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
  • 所有已实现的接口：
    RowMapper
    直接已知子类：
    FixedHeightLayoutCache, VariableHeightLayoutCache

    public abstract class AbstractLayoutCache
extends Object
implements RowMapper
    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  AbstractLayoutCache.NodeDimensions
      Used by AbstractLayoutCache to determine the size and x origin of a particular node.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected AbstractLayoutCache.NodeDimensions nodeDimensions
      Object responsible for getting the size of a node.
      protected boolean rootVisible
      True if the root node is displayed, false if its children are the highest visible nodes.
      protected int rowHeight
      Height to use for each row.
      protected TreeModel treeModel
      Model providing information.
      protected TreeSelectionModel treeSelectionModel
      Selection model.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractLayoutCache()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      abstract boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreeModel getModel()
      Returns the TreeModel that is providing the data.
      AbstractLayoutCache.NodeDimensions getNodeDimensions()
      Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
      protected Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
      Returns, by reference in placeIn, the size needed to represent value.
      abstract TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath getPathForRow(int row)
      Returns the path for passed in row.
      int getPreferredHeight()
      Returns the preferred height.
      int getPreferredWidth(Rectangle bounds)
      Returns the preferred width for the passed in region.
      abstract int getRowCount()
      Number of rows being displayed.
      abstract int getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int getRowHeight()
      Returns the height of each row.
      int[] getRowsForPaths(TreePath[] paths)
      Returns the rows that the TreePath instances in path are being displayed at.
      TreeSelectionModel getSelectionModel()
      Returns the model used to maintain the selection.
      abstract int getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      abstract Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract void invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      abstract void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      abstract boolean isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      protected boolean isFixedRowHeight()
      Returns true if the height of each row is a fixed size.
      boolean isRootVisible()
      Returns true if the root node of the tree is displayed.
      abstract void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree and which is threfore responsible for calculating the dimensions of individual nodes.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void setSelectionModel(TreeSelectionModel newLSM)
      Sets the TreeSelectionModel used to manage the selection to new LSM.
      abstract void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      abstract void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      abstract void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      abstract void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • nodeDimensions

        protected AbstractLayoutCache.NodeDimensions nodeDimensions
        Object responsible for getting the size of a node.

      • treeModel

        protected TreeModel treeModel
        Model providing information.

      • treeSelectionModel

        protected TreeSelectionModel treeSelectionModel
        Selection model.

      • rootVisible

        protected boolean rootVisible
        True if the root node is displayed, false if its children are the highest visible nodes.

      • rowHeight

        protected int rowHeight
        Height to use for each row. If this is <= 0 the renderer will be used to determine the height for each row.

    • 构造方法详细信息

      • AbstractLayoutCache

        public AbstractLayoutCache()

    • 方法详细信息

      • setNodeDimensions

        public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
        Sets the renderer that is responsible for drawing nodes in the tree and which is threfore responsible for calculating the dimensions of individual nodes.
        参数：
        nd - a NodeDimensions object

      • getNodeDimensions

        public AbstractLayoutCache.NodeDimensions getNodeDimensions()
        Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
        返回：
        the NodeDimensions object

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        参数：
        newModel - the TreeModel that is to provide the data

      • getModel

        public TreeModel getModel()
        Returns the TreeModel that is providing the data.
        返回：
        the TreeModel that is providing the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        参数：
        rootVisible - true if the root node of the tree is to be displayed
        另请参见：
        rootVisible

      • isRootVisible

        public boolean isRootVisible()
        Returns true if the root node of the tree is displayed.
        返回：
        true if the root node of the tree is displayed
        另请参见：
        rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If the specified value is less than or equal to zero the current cell renderer is queried for each row's height.
        参数：
        rowHeight - the height of each cell, in pixels

      • getRowHeight

        public int getRowHeight()
        Returns the height of each row. If the returned value is less than or equal to 0 the height for each row is determined by the renderer.

      • setSelectionModel

        public void setSelectionModel(TreeSelectionModel newLSM)
        Sets the TreeSelectionModel used to manage the selection to new LSM.
        参数：
        newLSM - the new TreeSelectionModel

      • getSelectionModel

        public TreeSelectionModel getSelectionModel()
        Returns the model used to maintain the selection.
        返回：
        the treeSelectionModel

      • getPreferredHeight

        public int getPreferredHeight()
        Returns the preferred height.
        返回：
        the preferred height

      • getPreferredWidth

        public int getPreferredWidth(Rectangle bounds)
        Returns the preferred width for the passed in region. The region is defined by the path closest to (bounds.x, bounds.y) and ends at bounds.height + bounds.y. If bounds is null, the preferred width for all the nodes will be returned (and this may be a VERY expensive computation).
        参数：
        bounds - the region being queried
        返回：
        the preferred width for the passed in region

      • isExpanded

        public abstract boolean isExpanded(TreePath path)
        Returns true if the value identified by row is currently expanded.

      • getBounds

        public abstract Rectangle getBounds(TreePath path,
                  Rectangle placeIn)
        Returns a rectangle giving the bounds needed to draw path.
        参数：
        path - a TreePath specifying a node
        placeIn - a Rectangle object giving the available space
        返回：
        a Rectangle object specifying the space to be used

      • getPathForRow

        public abstract TreePath getPathForRow(int row)
        Returns the path for passed in row. If row is not visible null is returned.
        参数：
        row - the row being queried
        返回：
        the TreePath for the given row

      • getRowForPath

        public abstract int getRowForPath(TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.
        参数：
        path - the TreePath being queried
        返回：
        the row where the last item in path is visible or -1 if any elements in path aren't currently visible

      • getPathClosestTo

        public abstract TreePath getPathClosestTo(int x,
                        int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        参数：
        x - the horizontal component of the desired location
        y - the vertical component of the desired location
        返回：
        the TreePath closest to the specified point

      • getVisiblePathsFrom

        public abstract Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed. The first element of the returned enumeration will be path, unless it isn't visible, in which case null will be returned.
        参数：
        path - the starting location for the enumeration
        返回：
        the Enumerator starting at the desired location

      • getVisibleChildCount

        public abstract int getVisibleChildCount(TreePath path)
        Returns the number of visible children for row.
        参数：
        path - the path being queried
        返回：
        the number of visible children for the specified path

      • setExpandedState

        public abstract void setExpandedState(TreePath path,
                    boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        参数：
        path - the path being expanded or collapsed
        isExpanded - true if the path should be expanded, false otherwise

      • getExpandedState

        public abstract boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        参数：
        path - the path being queried
        返回：
        true if the path is expanded and visible, false otherwise

      • getRowCount

        public abstract int getRowCount()
        Number of rows being displayed.
        返回：
        the number of rows being displayed

      • invalidateSizes

        public abstract void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.

      • invalidatePathBounds

        public abstract void invalidatePathBounds(TreePath path)
        Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
        参数：
        path - the path being updated

      • treeNodesChanged

        public abstract void treeNodesChanged(TreeModelEvent e)

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path() returns the path the parent of the changed node(s).

        e.childIndices() returns the index(es) of the changed node(s).

        参数：
        e - the TreeModelEvent

      • treeNodesInserted

        public abstract void treeNodesInserted(TreeModelEvent e)

        Invoked after nodes have been inserted into the tree.

        e.path() returns the parent of the new nodes

        e.childIndices() returns the indices of the new nodes in ascending order.

        参数：
        e - the TreeModelEvent

      • treeNodesRemoved

        public abstract void treeNodesRemoved(TreeModelEvent e)

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path() returns the former parent of the deleted nodes.

        e.childIndices() returns the indices the nodes had before they were deleted in ascending order.

        参数：
        e - the TreeModelEvent

      • treeStructureChanged

        public abstract void treeStructureChanged(TreeModelEvent e)

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path() holds the path to the node.

        e.childIndices() returns null.

        参数：
        e - the TreeModelEvent

      • getRowsForPaths

        public int[] getRowsForPaths(TreePath[] paths)
        Returns the rows that the TreePath instances in path are being displayed at. This method should return an array of the same length as that passed in, and if one of the TreePaths in path is not valid its entry in the array should be set to -1.
        指定者：
        getRowsForPaths in interface RowMapper
        参数：
        paths - the array of TreePaths being queried
        返回：
        an array of the same length that is passed in containing the rows that each corresponding where each TreePath is displayed; if paths is null, null is returned

      • getNodeDimensions

        protected Rectangle getNodeDimensions(Object value,
                          int row,
                          int depth,
                          boolean expanded,
                          Rectangle placeIn)
        Returns, by reference in placeIn, the size needed to represent value. If inPlace is null, a newly created Rectangle should be returned, otherwise the value should be placed in inPlace and returned. This will return null if there is no renderer.
        参数：
        value - the value to be represented
        row - row being queried
        depth - the depth of the row
        expanded - true if row is expanded, false otherwise
        placeIn - a Rectangle containing the size needed to represent value
        返回：
        a Rectangle containing the node dimensions, or null if node has no dimension

      • isFixedRowHeight

        protected boolean isFixedRowHeight()
        Returns true if the height of each row is a fixed size.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractLayoutCache.NodeDimensions

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 AbstractLayoutCache.NodeDimensions

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
  • 直接已知子类：
    BasicTreeUI.NodeDimensionsHandler
    封闭类：
    AbstractLayoutCache

    public abstract static class AbstractLayoutCache.NodeDimensions
extends Object
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractLayoutCache.NodeDimensions()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds)
      Returns, by reference in bounds, the size and x origin to place value at.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AbstractLayoutCache.NodeDimensions

        public AbstractLayoutCache.NodeDimensions()

    • 方法详细信息

      • getNodeDimensions

        public abstract Rectangle getNodeDimensions(Object value,
                          int row,
                          int depth,
                          boolean expanded,
                          Rectangle bounds)
        Returns, by reference in bounds, the size and x origin to place value at. The calling method is responsible for determining the Y location. If bounds is null, a newly created Rectangle should be returned, otherwise the value should be placed in bounds and returned.
        参数：
        value - the value to be represented
        row - row being queried
        depth - the depth of the row
        expanded - true if row is expanded, false otherwise
        bounds - a Rectangle containing the size needed to represent value
        返回：
        a Rectangle containing the node dimensions, or null if node has no dimension
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts"st dd dt>t/ttd


DefaultMutableTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultMutableTreeNode

  • java.lang.Object
    • javax.swing.tree.DefaultMutableTreeNode
  • 所有已实现的接口：
    Serializable, Cloneable, MutableTreeNode, TreeNode
    直接已知子类：
    JTree.DynamicUtilTreeNode

    public class DefaultMutableTreeNode
extends Object
implements Cloneable, MutableTreeNode, Serializable
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure. For examples of using default mutable tree nodes, see How to Use Trees in The Java Tutorial.

    A tree node may have at most one parent and 0 or more children. DefaultMutableTreeNode provides operations for examining and modifying a node's parent and children and also operations for examining the tree that the node is a part of. A node's tree is the set of all nodes that can be reached by starting at the node and following all the possible links to parents and children. A node with no parent is the root of its tree; a node with no children is a leaf. A tree may consist of many subtrees, each node acting as the root for its own subtree.

    This class provides enumerations for efficiently traversing a tree or subtree in various orders or for following the path between two nodes. A DefaultMutableTreeNode may also hold a reference to a user object, the use of which is left to the user. Asking a DefaultMutableTreeNode for its string representation with toString() returns the string representation of its user object.

    This is not a thread safe class.If you intend to use a DefaultMutableTreeNode (or a tree of TreeNodes) in more than one thread, you need to do your own synchronizing. A good convention to adopt is synchronizing on the root node of a tree.

    While DefaultMutableTreeNode implements the MutableTreeNode interface and will allow you to add in any implementation of MutableTreeNode not all of the methods in DefaultMutableTreeNode will be applicable to all MutableTreeNodes implementations. Especially with some of the enumerations that are provided, using some of these methods assumes the DefaultMutableTreeNode contains only DefaultMutableNode instances. All of the TreeNode/MutableTreeNode methods will behave as defined no matter what implementations are added.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    MutableTreeNode

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean allowsChildren
      true if the node is able to have children
      protected Vector children
      array of children, may be null if this node has no children
      static Enumeration<TreeNode> EMPTY_ENUMERATION
      An enumeration that is always empty.
      protected MutableTreeNode parent
      this node's parent, or null if this node has no parent
      protected Object userObject
      optional user object

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultMutableTreeNode()
      Creates a tree node that has no parent and no children, but which allows children.
      DefaultMutableTreeNode(Object userObject)
      Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
      DefaultMutableTreeNode(Object userObject, boolean allowsChildren)
      Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(MutableTreeNode newChild)
      Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
      Enumeration breadthFirstEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order.
      Enumeration children()
      Creates and returns a forward-order enumeration of this node's children.
      Object clone()
      Overridden to make clone public.
      Enumeration depthFirstEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order.
      boolean getAllowsChildren()
      Returns true if this node is allowed to have children.
      TreeNode getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode getChildAt(int index)
      Returns the child at the specified index in this node's child array.
      TreeNode getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      int getChildCount()
      Returns the number of children of this node.
      int getDepth()
      Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf.
      TreeNode getFirstChild()
      Returns this node's first child.
      DefaultMutableTreeNode getFirstLeaf()
      Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.
      int getIndex(TreeNode aChild)
      Returns the index of the specified child in this node's child array.
      TreeNode getLastChild()
      Returns this node's last child.
      DefaultMutableTreeNode getLastLeaf()
      Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.
      int getLeafCount()
      Returns the total number of leaves that are descendants of this node.
      int getLevel()
      Returns the number of levels above this node -- the distance from the root to this node.
      DefaultMutableTreeNode getNextLeaf()
      Returns the leaf after this node or null if this node is the last leaf in the tree.
      DefaultMutableTreeNode getNextNode()
      Returns the node that follows this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode getNextSibling()
      Returns the next sibling of this node in the parent's children array.
      TreeNode getParent()
      Returns this node's parent or null if this node has no parent.
      TreeNode[] getPath()
      Returns the path from the root, to get to this node.
      protected TreeNode[] getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      DefaultMutableTreeNode getPreviousLeaf()
      Returns the leaf before this node or null if this node is the first leaf in the tree.
      DefaultMutableTreeNode getPreviousNode()
      Returns the node that precedes this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode getPreviousSibling()
      Returns the previous sibling of this node in the parent's children array.
      TreeNode getRoot()
      Returns the root of the tree that contains this node.
      TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      int getSiblingCount()
      Returns the number of siblings of this node.
      Object getUserObject()
      Returns this node's user object.
      Object[] getUserObjectPath()
      Returns the user object path, from the root, to get to this node.
      void insert(MutableTreeNode newChild, int childIndex)
      Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
      boolean isLeaf()
      Returns true if this node has no children.
      boolean isNodeAncestor(TreeNode anotherNode)
      Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
      boolean isNodeChild(TreeNode aNode)
      Returns true if aNode is a child of this node.
      boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
      Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
      boolean isNodeRelated(DefaultMutableTreeNode aNode)
      Returns true if and only if aNode is in the same tree as this node.
      boolean isNodeSibling(TreeNode anotherNode)
      Returns true if anotherNode is a sibling of (has the same parent as) this node.
      boolean isRoot()
      Returns true if this node is the root of the tree.
      Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
      Creates and returns an enumeration that follows the path from ancestor to this node.
      Enumeration postorderEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in postorder.
      Enumeration preorderEnumeration()
      Creates and returns an enumeration that traverses the subtree rooted at this node in preorder.
      void remove(int childIndex)
      Removes the child at the specified index from this node's children and sets that node's parent to null.
      void remove(MutableTreeNode aChild)
      Removes aChild from this node's child array, giving it a null parent.
      void removeAllChildren()
      Removes all of this node's children, setting their parents to null.
      void removeFromParent()
      Removes the subtree rooted at this node from the tree, giving this node a null parent.
      void setAllowsChildren(boolean allows)
      Determines whether or not this node is allowed to have children.
      void setParent(MutableTreeNode newParent)
      Sets this node's parent to newParent but does not change the parent's child array.
      void setUserObject(Object userObject)
      Sets the user object for this node to userObject.
      String toString()
      Returns the result of sending toString() to this node's user object, or the empty string if the node has no user object.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • EMPTY_ENUMERATION

        public static final Enumeration<TreeNode> EMPTY_ENUMERATION
        An enumeration that is always empty. This is used when an enumeration of a leaf node's children is requested.

      • parent

        protected MutableTreeNode parent
        this node's parent, or null if this node has no parent

      • children

        protected Vector children
        array of children, may be null if this node has no children

      • userObject

        protected transient Object userObject
        optional user object

      • allowsChildren

        protected boolean allowsChildren
        true if the node is able to have children

    • 构造方法详细信息

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode()
        Creates a tree node that has no parent and no children, but which allows children.

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode(Object userObject)
        Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
        参数：
        userObject - an Object provided by the user that constitutes the node's data

      • DefaultMutableTreeNode

        public DefaultMutableTreeNode(Object userObject,
                      boolean allowsChildren)
        Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.
        参数：
        userObject - an Object provided by the user that constitutes the node's data
        allowsChildren - if true, the node is allowed to have child nodes -- otherwise, it is always a leaf node

    • 方法详细信息

      • insert

        public void insert(MutableTreeNode newChild,
          int childIndex)
        Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex. newChild must not be null and must not be an ancestor of this node.
        指定者：
        insert in interface MutableTreeNode
        参数：
        newChild - the MutableTreeNode to insert under this node
        childIndex - the index in this node's child array where this node is to be inserted
        抛出：
        ArrayIndexOutOfBoundsException - if childIndex is out of bounds
        IllegalArgumentException - if newChild is null or is an ancestor of this node
        IllegalStateException - if this node does not allow children
        另请参见：
        isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • remove

        public void remove(int childIndex)
        Removes the child at the specified index from this node's children and sets that node's parent to null. The child node to remove must be a MutableTreeNode.
        指定者：
        remove in interface MutableTreeNode
        参数：
        childIndex - the index in this node's child array of the child to remove
        抛出：
        ArrayIndexOutOfBoundsException - if childIndex is out of bounds

      • setParent

        public void setParent(MutableTreeNode newParent)
        Sets this node's parent to newParent but does not change the parent's child array. This method is called from insert() and remove() to reassign a child's parent, it should not be messaged from anywhere else.
        指定者：
        setParent in interface MutableTreeNode
        参数：
        newParent - this node's new parent

      • getParent

        public TreeNode getParent()
        Returns this node's parent or null if this node has no parent.
        指定者：
        getParent in interface TreeNode
        返回：
        this node's parent TreeNode, or null if this node has no parent

      • getChildAt

        public TreeNode getChildAt(int index)
        Returns the child at the specified index in this node's child array.
        指定者：
        getChildAt in interface TreeNode
        参数：
        index - an index into this node's child array
        返回：
        the TreeNode in this node's child array at the specified index
        抛出：
        ArrayIndexOutOfBoundsException - if index is out of bounds

      • getChildCount

        public int getChildCount()
        Returns the number of children of this node.
        指定者：
        getChildCount in interface TreeNode
        返回：
        an int giving the number of children of this node

      • getIndex

        public int getIndex(TreeNode aChild)
        Returns the index of the specified child in this node's child array. If the specified node is not a child of this node, returns -1. This method performs a linear search and is O(n) where n is the number of children.
        指定者：
        getIndex in interface TreeNode
        参数：
        aChild - the TreeNode to search for among this node's children
        返回：
        an int giving the index of the node in this node's child array, or -1 if the specified node is a not a child of this node
        抛出：
        IllegalArgumentException - if aChild is null

      • children

        public Enumeration children()
        Creates and returns a forward-order enumeration of this node's children. Modifying this node's child array invalidates any child enumerations created before the modification.
        指定者：
        children in interface TreeNode
        返回：
        an Enumeration of this node's children

      • setAllowsChildren

        public void setAllowsChildren(boolean allows)
        Determines whether or not this node is allowed to have children. If allows is false, all of this node's children are removed.

        Note: By default, a node allows children.

        参数：
        allows - true if this node is allowed to have children

      • getAllowsChildren

        public boolean getAllowsChildren()
        Returns true if this node is allowed to have children.
        指定者：
        getAllowsChildren in interface TreeNode
        返回：
        true if this node allows children, else false

      • setUserObject

        public void setUserObject(Object userObject)
        Sets the user object for this node to userObject.
        指定者：
        setUserObject in interface MutableTreeNode
        参数：
        userObject - the Object that constitutes this node's user-specified data
        另请参见：
        getUserObject(), toString()

      • getUserObject

        public Object getUserObject()
        Returns this node's user object.
        返回：
        the Object stored at this node by the user
        另请参见：
        setUserObject(java.lang.Object), toString()

      • removeFromParent

        public void removeFromParent()
        Removes the subtree rooted at this node from the tree, giving this node a null parent. Does nothing if this node is the root of its tree.
        指定者：
        removeFromParent in interface MutableTreeNode

      • remove

        public void remove(MutableTreeNode aChild)
        Removes aChild from this node's child array, giving it a null parent.
        指定者：
        remove in interface MutableTreeNode
        参数：
        aChild - a child of this node to remove
        抛出：
        IllegalArgumentException - if aChild is null or is not a child of this node

      • removeAllChildren

        public void removeAllChildren()
        Removes all of this node's children, setting their parents to null. If this node has no children, this method does nothing.

      • add

        public void add(MutableTreeNode newChild)
        Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
        参数：
        newChild - node to add as a child of this node
        抛出：
        IllegalArgumentException - if newChild is null
        IllegalStateException - if this node does not allow children
        另请参见：
        insert(javax.swing.tree.MutableTreeNode, int)

      • isNodeAncestor

        public boolean isNodeAncestor(TreeNode anotherNode)
        Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent. (Note that a node is considered an ancestor of itself.) If anotherNode is null, this method returns false. This operation is at worst O(h) where h is the distance from the root to this node.
        参数：
        anotherNode - node to test as an ancestor of this node
        返回：
        true if this node is a descendant of anotherNode
        另请参见：
        isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeDescendant

        public boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
        Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children. Note that a node is considered a descendant of itself. If anotherNode is null, returns false. This operation is at worst O(h) where h is the distance from the root to anotherNode.
        参数：
        anotherNode - node to test as descendant of this node
        返回：
        true if this node is an ancestor of anotherNode
        另请参见：
        isNodeAncestor(javax.swing.tree.TreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

      • getSharedAncestor

        public TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
        Returns the nearest common ancestor to this node and aNode. Returns null, if no such ancestor exists -- if this node and aNode are in different trees or if aNode is null. A node is considered an ancestor of itself.
        参数：
        aNode - node to find common ancestor with
        返回：
        nearest ancestor common to this node and aNode, or null if none
        另请参见：
        isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeRelated

        public boolean isNodeRelated(DefaultMutableTreeNode aNode)
        Returns true if and only if aNode is in the same tree as this node. Returns false if aNode is null.
        返回：
        true if aNode is in the same tree as this node; false if aNode is null
        另请参见：
        getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode), getRoot()

      • getDepth

        public int getDepth()
        Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf. If this node has no children, returns 0. This operation is much more expensive than getLevel() because it must effectively traverse the entire tree rooted at this node.
        返回：
        the depth of the tree whose root is this node
        另请参见：
        getLevel()

      • getLevel

        public int getLevel()
        Returns the number of levels above this node -- the distance from the root to this node. If this node is the root, returns 0.
        返回：
        the number of levels above this node
        另请参见：
        getDepth()

      • getPath

        public TreeNode[] getPath()
        Returns the path from the root, to get to this node. The last element in the path is this node.
        返回：
        an array of TreeNode objects giving the path, where the first element in the path is the root and the last element is this node.

      • getPathToRoot

        protected TreeNode[] getPathToRoot(TreeNode aNode,
                       int depth)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        参数：
        aNode - the TreeNode to get the path for
        depth - an int giving the number of steps already taken towards the root (on recursive calls), used to size the returned array
        返回：
        an array of TreeNodes giving the path from the root to the specified node

      • getUserObjectPath

        public Object[] getUserObjectPath()
        Returns the user object path, from the root, to get to this node. If some of the TreeNodes in the path have null user objects, the returned path will contain nulls.

      • getRoot

        public TreeNode getRoot()
        Returns the root of the tree that contains this node. The root is the ancestor with a null parent.
        返回：
        the root of the tree that contains this node
        另请参见：
        isNodeAncestor(javax.swing.tree.TreeNode)

      • isRoot

        public boolean isRoot()
        Returns true if this node is the root of the tree. The root is the only node in the tree with a null parent; every tree has exactly one root.
        返回：
        true if this node is the root of its tree

      • getNextNode

        public DefaultMutableTreeNode getNextNode()
        Returns the node that follows this node in a preorder traversal of this node's tree. Returns null if this node is the last node of the traversal. This is an inefficient way to traverse the entire tree; use an enumeration, instead.
        返回：
        the node that follows this node in a preorder traversal, or null if this node is last
        另请参见：
        preorderEnumeration()

      • getPreviousNode

        public DefaultMutableTreeNode getPreviousNode()
        Returns the node that precedes this node in a preorder traversal of this node's tree. Returns null if this node is the first node of the traversal -- the root of the tree. This is an inefficient way to traverse the entire tree; use an enumeration, instead.
        返回：
        the node that precedes this node in a preorder traversal, or null if this node is the first
        另请参见：
        preorderEnumeration()

      • preorderEnumeration

        public Enumeration preorderEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in preorder. The first node returned by the enumeration's nextElement() method is this node.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        返回：
        an enumeration for traversing the tree in preorder
        另请参见：
        postorderEnumeration()

      • postorderEnumeration

        public Enumeration postorderEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in postorder. The first node returned by the enumeration's nextElement() method is the leftmost leaf. This is the same as a depth-first traversal.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        返回：
        an enumeration for traversing the tree in postorder
        另请参见：
        depthFirstEnumeration(), preorderEnumeration()

      • breadthFirstEnumeration

        public Enumeration breadthFirstEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order. The first node returned by the enumeration's nextElement() method is this node.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        返回：
        an enumeration for traversing the tree in breadth-first order
        另请参见：
        depthFirstEnumeration()

      • depthFirstEnumeration

        public Enumeration depthFirstEnumeration()
        Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order. The first node returned by the enumeration's nextElement() method is the leftmost leaf. This is the same as a postorder traversal.

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        返回：
        an enumeration for traversing the tree in depth-first order
        另请参见：
        breadthFirstEnumeration(), postorderEnumeration()

      • pathFromAncestorEnumeration

        public Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
        Creates and returns an enumeration that follows the path from ancestor to this node. The enumeration's nextElement() method first returns ancestor, then the child of ancestor that is an ancestor of this node, and so on, and finally returns this node. Creation of the enumeration is O(m) where m is the number of nodes between this node and ancestor, inclusive. Each nextElement() message is O(1).

        Modifying the tree by inserting, removing, or moving a node invalidates any enumerations created before the modification.

        返回：
        an enumeration for following the path from an ancestor of this node to this one
        抛出：
        IllegalArgumentException - if ancestor is not an ancestor of this node
        另请参见：
        isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • isNodeChild

        public boolean isNodeChild(TreeNode aNode)
        Returns true if aNode is a child of this node. If aNode is null, this method returns false.
        返回：
        true if aNode is a child of this node; false if aNode is null

      • getFirstChild

        public TreeNode getFirstChild()
        Returns this node's first child. If this node has no children, throws NoSuchElementException.
        返回：
        the first child of this node
        抛出：
        NoSuchElementException - if this node has no children

      • getLastChild

        public TreeNode getLastChild()
        Returns this node's last child. If this node has no children, throws NoSuchElementException.
        返回：
        the last child of this node
        抛出：
        NoSuchElementException - if this node has no children

      • getChildAfter

        public TreeNode getChildAfter(TreeNode aChild)
        Returns the child in this node's child array that immediately follows aChild, which must be a child of this node. If aChild is the last child, returns null. This method performs a linear search of this node's children for aChild and is O(n) where n is the number of children; to traverse the entire array of children, use an enumeration instead.
        返回：
        the child of this node that immediately follows aChild
        抛出：
        IllegalArgumentException - if aChild is null or is not a child of this node
        另请参见：
        children

      • getChildBefore

        public TreeNode getChildBefore(TreeNode aChild)
        Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node. If aChild is the first child, returns null. This method performs a linear search of this node's children for aChild and is O(n) where n is the number of children.
        返回：
        the child of this node that immediately precedes aChild
        抛出：
        IllegalArgumentException - if aChild is null or is not a child of this node

      • isNodeSibling

        public boolean isNodeSibling(TreeNode anotherNode)
        Returns true if anotherNode is a sibling of (has the same parent as) this node. A node is its own sibling. If anotherNode is null, returns false.
        参数：
        anotherNode - node to test as sibling of this node
        返回：
        true if anotherNode is a sibling of this node

      • getSiblingCount

        public int getSiblingCount()
        Returns the number of siblings of this node. A node is its own sibling (if it has no parent or no siblings, this method returns 1).
        返回：
        the number of siblings of this node

      • getNextSibling

        public DefaultMutableTreeNode getNextSibling()
        Returns the next sibling of this node in the parent's children array. Returns null if this node has no parent or is the parent's last child. This method performs a linear search that is O(n) where n is the number of children; to traverse the entire array, use the parent's child enumeration instead.
        返回：
        the sibling of this node that immediately follows this node
        另请参见：
        children

      • getPreviousSibling

        public DefaultMutableTreeNode getPreviousSibling()
        Returns the previous sibling of this node in the parent's children array. Returns null if this node has no parent or is the parent's first child. This method performs a linear search that is O(n) where n is the number of children.
        返回：
        the sibling of this node that immediately precedes this node

      • isLeaf

        public boolean isLeaf()
        Returns true if this node has no children. To distinguish between nodes that have no children and nodes that cannot have children (e.g. to distinguish files from empty directories), use this method in conjunction with getAllowsChildren
        指定者：
        isLeaf in interface TreeNode
        返回：
        true if this node has no children
        另请参见：
        getAllowsChildren()

      • getFirstLeaf

        public DefaultMutableTreeNode getFirstLeaf()
        Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf. Returns this node if it is a leaf.
        返回：
        the first leaf in the subtree rooted at this node
        另请参见：
        isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • getLastLeaf

        public DefaultMutableTreeNode getLastLeaf()
        Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf. Returns this node if it is a leaf.
        返回：
        the last leaf in the subtree rooted at this node
        另请参见：
        isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

      • getNextLeaf

        public DefaultMutableTreeNode getNextLeaf()
        Returns the leaf after this node or null if this node is the last leaf in the tree.

        In this implementation of the MutableNode interface, this operation is very inefficient. In order to determine the next node, this method first performs a linear search in the parent's child-list in order to find the current node.

        That implementation makes the operation suitable for short traversals from a known position. But to traverse all of the leaves in the tree, you should use depthFirstEnumeration to enumerate the nodes in the tree and use isLeaf on each node to determine which are leaves.

        返回：
        returns the next leaf past this node
        另请参见：
        depthFirstEnumeration(), isLeaf()

      • getPreviousLeaf

        public DefaultMutableTreeNode getPreviousLeaf()
        Returns the leaf before this node or null if this node is the first leaf in the tree.

        In this implementation of the MutableNode interface, this operation is very inefficient. In order to determine the previous node, this method first performs a linear search in the parent's child-list in order to find the current node.

        That implementation makes the operation suitable for short traversals from a known position. But to traverse all of the leaves in the tree, you should use depthFirstEnumeration to enumerate the nodes in the tree and use isLeaf on each node to determine which are leaves.

        返回：
        returns the leaf before this node
        另请参见：
        depthFirstEnumeration(), isLeaf()

      • getLeafCount

        public int getLeafCount()
        Returns the total number of leaves that are descendants of this node. If this node is a leaf, returns 1. This method is O(n) where n is the number of descendants of this node.
        返回：
        the number of leaves beneath this node
        另请参见：
        isNodeAncestor(javax.swing.tree.TreeNode)

      • toString

        public String toString()
        Returns the result of sending toString() to this node's user object, or the empty string if the node has no user object.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
        另请参见：
        getUserObject()

      • clone

        public Object clone()
        Overridden to make clone public. Returns a shallow copy of this node; the new node has no parent or children and has a reference to the same user object, if any.
        重载：
        clone in class Object
        返回：
        a copy of this node
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultTreeCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeCellEditor

  • java.lang.Object
    • javax.swing.tree.DefaultTreeCellEditor
  • 所有已实现的接口：
    ActionListener, EventListener, CellEditor, TreeSelectionListener, TreeCellEditor

    public class DefaultTreeCellEditor
extends Object
implements ActionListener, TreeCellEditor, TreeSelectionListener
    A TreeCellEditor. You need to supply an instance of DefaultTreeCellRenderer so that the icons can be obtained. You can optionally supply a TreeCellEditor that will be layed out according to the icon in the DefaultTreeCellRenderer. If you do not supply a TreeCellEditor, a TextField will be used. Editing is started on a triple mouse click, or after a click, pause, click and a delay of 1200 miliseconds.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTree

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor.DefaultTextField
      TextField used when no editor is supplied.
      class  DefaultTreeCellEditor.EditorContainer
      Container responsible for placing the editingComponent.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Color borderSelectionColor
      True if the border selection color should be drawn.
      protected boolean canEdit
      As of Java 2 platform v1.4 this field should no longer be used.
      protected Component editingComponent
      Component used in editing, obtained from the editingContainer.
      protected Container editingContainer
      Editing container, will contain the editorComponent.
      protected Icon editingIcon
      Icon to use when editing.
      protected Font font
      Font to paint with, null indicates font of renderer is to be used.
      protected TreePath lastPath
      Last path that was selected.
      protected int lastRow
      Row that was last passed into getTreeCellEditorComponent.
      protected int offset
      Used in editing.
      protected TreeCellEditor realEditor
      Editor handling the editing.
      protected DefaultTreeCellRenderer renderer
      Renderer, used to get border and offsets from.
      protected Timer timer
      Used before starting the editing session.
      protected JTree tree
      JTree instance listening too.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void actionPerformed(ActionEvent e)
      Messaged when the timer fires, this will start the editing session.
      void addCellEditorListener(CellEditorListener l)
      Adds the CellEditorListener.
      void cancelCellEditing()
      Messages cancelCellEditing to the realEditor and removes it from this instance.
      protected boolean canEditImmediately(EventObject event)
      Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
      protected Container createContainer()
      Creates the container to manage placement of editingComponent.
      protected TreeCellEditor createTreeCellEditor()
      This is invoked if a TreeCellEditor is not supplied in the constructor.
      protected void | determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Color getBorderSelectionColor()
      Returns the color the border is drawn.
      CellEditorListener[] getCellEditorListeners()
      Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().
      Object getCellEditorValue()
      Returns the value currently being edited.
      Font getFont()
      Gets the font used for editing.
      Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Configures the editor.
      protected boolean inHitRegion(int x, int y)
      Returns true if the passed in location is a valid mouse location to start editing from.
      boolean isCellEditable(EventObject event)
      If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
      protected void prepareForEditing()
      Invoked just before editing is to start.
      void removeCellEditorListener(CellEditorListener l)
      Removes the previously added CellEditorListener.
      void setBorderSelectionColor(Color newColor)
      Sets the color to use for the border.
      void setFont(Font font)
      Sets the font to edit with.
      protected void setTree(JTree newTree)
      Sets the tree currently editing for.
      boolean shouldSelectCell(EventObject event)
      Messages the realEditor for the return value.
      protected boolean shouldStartEditingTimer(EventObject event)
      Returns true if event is a MouseEvent and the click count is 1.
      protected void startEditingTimer()
      Starts the editing timer.
      boolean stopCellEditing()
      If the realEditor will allow editing to stop, the realEditor is removed and true is returned, otherwise false is returned.
      void valueChanged(TreeSelectionEvent e)
      Resets lastPath.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • realEditor

        protected TreeCellEditor realEditor
        Editor handling the editing.

      • renderer

        protected DefaultTreeCellRenderer renderer
        Renderer, used to get border and offsets from.

      • editingContainer

        protected Container editingContainer
        Editing container, will contain the editorComponent.

      • editingComponent

        protected transient Component editingComponent
        Component used in editing, obtained from the editingContainer.

      • canEdit

        protected boolean canEdit
        As of Java 2 platform v1.4 this field should no longer be used. If you wish to provide similar behavior you should directly override isCellEditable.

      • offset

        protected transient int offset
        Used in editing. Indicates x position to place editingComponent.

      • tree

        protected transient JTree tree
        JTree instance listening too.

      • lastPath

        protected transient TreePath lastPath
        Last path that was selected.

      • timer

        protected transient Timer timer
        Used before starting the editing session.

      • lastRow

        protected transient int lastRow
        Row that was last passed into getTreeCellEditorComponent.

      • borderSelectionColor

        protected Color borderSelectionColor
        True if the border selection color should be drawn.

      • editingIcon

        protected transient Icon editingIcon
        Icon to use when editing.

      • font

        protected Font font
        Font to paint with, null indicates font of renderer is to be used.

    • 构造方法详细信息

      • DefaultTreeCellEditor

        public DefaultTreeCellEditor(JTree tree,
                     DefaultTreeCellRenderer renderer)
        Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor. (Use this constructor for normal editing.)
        参数：
        tree - a JTree object
        renderer - a DefaultTreeCellRenderer object

      • DefaultTreeCellEditor

        public DefaultTreeCellEditor(JTree tree,
                     DefaultTreeCellRenderer renderer,
                     TreeCellEditor editor)
        Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor. (Use this constructor for specialized editing.)
        参数：
        tree - a JTree object
        renderer - a DefaultTreeCellRenderer object
        editor - a TreeCellEditor object

    • 方法详细信息

      • setBorderSelectionColor

        public void setBorderSelectionColor(Color newColor)
        Sets the color to use for the border.
        参数：
        newColor - the new border color

      • getBorderSelectionColor

        public Color getBorderSelectionColor()
        Returns the color the border is drawn.
        返回：
        the border selection color

      • setFont

        public void setFont(Font font)
        Sets the font to edit with. null indicates the renderers font should be used. This will NOT override any font you have set in the editor the receiver was instantied with. If null for an editor was passed in a default editor will be created that will pick up this font.
        参数：
        font - the editing Font
        另请参见：
        getFont()

      • getFont

        public Font getFont()
        Gets the font used for editing.
        返回：
        the editing Font
        另请参见：
        setFont(java.awt.Font)

      • getTreeCellEditorComponent

        public Component getTreeCellEditorComponent(JTree tree,
                                   Object value,
                                   boolean isSelected,
                                   boolean expanded,
                                   boolean leaf,
                                   int row)
        Configures the editor. Passed onto the realEditor.
        指定者：
        getTreeCellEditorComponent in interface TreeCellEditor
        参数：
        tree - the JTree that is asking the editor to edit; this parameter can be null
        value - the value of the cell to be edited
        isSelected - true if the cell is to be rendered with selection highlighting
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - the row index of the node being edited
        返回：
        the component for editing

      • getCellEditorValue

        public Object getCellEditorValue()
        Returns the value currently being edited.
        指定者：
        getCellEditorValue in interface CellEditor
        返回：
        the value currently being edited

      • isCellEditable

        public boolean isCellEditable(EventObject event)
        If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
        指定者：
        isCellEditable in interface CellEditor
        参数：
        event - the event the editor should use to consider whether to begin editing or not
        返回：
        true if editing can be started
        另请参见：
        CellEditor.shouldSelectCell(java.util.EventObject)

      • shouldSelectCell

        public boolean shouldSelectCell(EventObject event)
        Messages the realEditor for the return value.
        指定者：
        shouldSelectCell in interface CellEditor
        参数：
        event - the event the editor should use to start editing
        返回：
        true if the editor would like the editing cell to be selected; otherwise returns false
        另请参见：
        CellEditor.isCellEditable(java.util.EventObject)

      • stopCellEditing

        public boolean stopCellEditing()
        If the realEditor will allow editing to stop, the realEditor is removed and true is returned, otherwise false is returned.
        指定者：
        stopCellEditing in interface CellEditor
        返回：
        true if editing was stopped; false otherwise

      • cancelCellEditing

        public void cancelCellEditing()
        Messages cancelCellEditing to the realEditor and removes it from this instance.
        指定者：
        cancelCellEditing in interface CellEditor

      • addCellEditorListener

        public void addCellEditorListener(CellEditorListener l)
        Adds the CellEditorListener.
        指定者：
        addCellEditorListener in interface CellEditor
        参数：
        l - the listener to be added

      • removeCellEditorListener

        public void removeCellEditorListener(CellEditorListener l)
        Removes the previously added CellEditorListener.
        指定者：
        removeCellEditorListener in interface CellEditor
        参数：
        l - the listener to be removed

      • getCellEditorListeners

        public CellEditorListener[] getCellEditorListeners()
        Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().
        返回：
        all of the CellEditorListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • valueChanged

        public void valueChanged(TreeSelectionEvent e)
        Resets lastPath.
        指定者：
        valueChanged in interface TreeSelectionListener
        参数：
        e - the event that characterizes the change.

      • actionPerformed

        public void actionPerformed(ActionEvent e)
        Messaged when the timer fires, this will start the editing session.
        指定者：
        actionPerformed in interface ActionListener

      • setTree

        protected void setTree(JTree newTree)
        Sets the tree currently editing for. This is needed to add a selection listener.
        参数：
        newTree - the new tree to be edited

      • shouldStartEditingTimer

        protected boolean shouldStartEditingTimer(EventObject event)
        Returns true if event is a MouseEvent and the click count is 1.
        参数：
        event - the event being studied

      • startEditingTimer

        protected void startEditingTimer()
        Starts the editing timer.

      • canEditImmediately

        protected boolean canEditImmediately(EventObject event)
        Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
        参数：
        event - the event being studied

      • inHitRegion

        protected boolean inHitRegion(int x,
                  int y)
        Returns true if the passed in location is a valid mouse location to start editing from. This is implemented to return false if x is <= the width of the icon and icon gap displayed by the renderer. In other words this returns true if the user clicks over the text part displayed by the renderer, and false otherwise.
        参数：
        x - the x-coordinate of the point
        y - the y-coordinate of the point
        返回：
        true if the passed in location is a valid mouse location

      • determineOffset

        protected void determineOffset(JTree tree,
                   Object value,
                   boolean isSelected,
                   boolean expanded,
                   boolean leaf,
                   int row)

      • prepareForEditing

        protected void prepareForEditing()
        Invoked just before editing is to start. Will add the editingComponent to the editingContainer.

      • createContainer

        protected Container createContainer()
        Creates the container to manage placement of editingComponent.

      • createTreeCellEditor

        protected TreeCellEditor createTreeCellEditor()
        This is invoked if a TreeCellEditor is not supplied in the constructor. It returns a TextField editor.
        返回：
        a new TextField editor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sv


DefaultTreeCellEditor.DefaultTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeCellEditor.DefaultTextField

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.text.JTextComponent
            • javax.swing.JTextField
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
    封闭类：
    DefaultTreeCellEditor

    public class DefaultTreeCellEditor.DefaultTextField
extends JTextField
    TextField used when no editor is supplied. This textfield locks into the border it is constructed with. It also prefers its parents font over its font. And if the renderer is not null and no font has been specified the preferred height is that of the renderer.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JTextField

        JTextField.AccessibleJTextField

      • Nested classes/interfaces inherited from class javax.swing.text.JTextComponent

        JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Border border
      Border to use.

      • Fields inherited from class javax.swing.JTextField

        notifyAction

      • Fields inherited from class javax.swing.text.JTextComponent

        DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeCellEditor.DefaultTextField(Border border)
      Constructs a DefaultTreeCellEditor.DefaultTextField object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Border getBorder()
      Overrides JComponent.getBorder to returns the current border.
      Font getFont()
      Gets the font of this component.
      Dimension getPreferredSize()
      Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.
      void setBorder(Border border)
      Sets the border of this component.

      • 方法 - 继承于类 javax.swing.JTextField

        actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAccessibleContext, getAction, getActionListeners, getActions, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getScrollOffset, getUIClassID, isValidateRoot, paramString, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setDocument, setFont, setHorizontalAlignment, setScrollOffset

      • 方法 - 继承于类 javax.swing.text.JTextComponent

        addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, restoreComposedText, saveComposedText, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • border

        protected Border border
        Border to use.

    • 构造方法详细信息

      • DefaultTreeCellEditor.DefaultTextField

        public DefaultTreeCellEditor.DefaultTextField(Border border)
        Constructs a DefaultTreeCellEditor.DefaultTextField object.
        参数：
        border - a Border object
        从以下版本开始：
        1.4

    • 方法详细信息

      • setBorder

        public void setBorder(Border border)
        Sets the border of this component.

        This is a bound property.

        重载：
        setBorder in class JComponent
        参数：
        border - the border to be rendered for this component
        另请参见：
        Border, CompoundBorder

      • getBorder

        public Border getBorder()
        Overrides JComponent.getBorder to returns the current border.
        重载：
        getBorder in class JComponent
        返回：
        the border object for this component
        另请参见：
        JComponent.setBorder(javax.swing.border.Border)

      • getFont

        public Font getFont()
        Description copied from class: Component
        Gets the font of this component.
        指定者：
        getFont in interface MenuContainer
        重载：
        getFont in class Component
        返回：
        this component's font; if a font has not been set for this component, the font of its parent is returned
        另请参见：
        Component.setFont(java.awt.Font)

      • getPreferredSize

        public Dimension getPreferredSize()
        Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.
        重载：
        getPreferredSize in class JTextField
        返回：
        a Dimension object containing the preferred size
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnht htthtaiitaanrttmE>artt>u/s;nalv"naabe fhser t


DefaultTreeCellEditor.EditorContainer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeCellEditor.EditorContainer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable
    封闭类：
    DefaultTreeCellEditor

    public class DefaultTreeCellEditor.EditorContainer
extends Container
    Container responsible for placing the editingComponent.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeCellEditor.EditorContainer()
      Constructs an EditorContainer object.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void doLayout()
      Lays out this Container.
      void | EditorContainer()
      Dimension getPreferredSize()
      Returns the preferred size for the Container.
      void paint(Graphics g)
      Overrides Container.paint to paint the node's icon and use the selection color for the background.

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, isValidateRoot, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusDownCycle, update, validate, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DefaultTreeCellEditor.EditorContainer

        public DefaultTreeCellEditor.EditorContainer()
        Constructs an EditorContainer object.

    • 方法详细信息

      • EditorContainer

        public void EditorContainer()

      • paint

        public void paint(Graphics g)
        Overrides Container.paint to paint the node's icon and use the selection color for the background.
        重载：
        paint in class Container
        参数：
        g - the specified Graphics window
        另请参见：
        Component.update(Graphics)

      • doLayout

        public void doLayout()
        Lays out this Container. If editing, the editor will be placed at offset in the x direction and 0 for y.
        重载：
        doLayout in class Container
        另请参见：
        LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

      • getPreferredSize

        public Dimension getPreferredSize()
        Returns the preferred size for the Container. This will be at least preferred size of the editor plus offset.
        重载：
        getPreferredSize in class Container
        返回：
        a Dimension containing the preferred size for the Container; if editingComponent is null the Dimension returned is 0, 0
        另请参见：
        Container.getMinimumSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"..,o


DefaultTreeCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeCellRenderer

  • java.lang.Object
    • java.awt.Component
      • java.awt.Container
        • javax.swing.JComponent
          • javax.swing.JLabel
            • javax.swing.tree.DefaultTreeCellRenderer
  • 所有已实现的接口：
    ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants, TreeCellRenderer

    public class DefaultTreeCellRenderer
extends JLabel
implements TreeCellRenderer
    Displays an entry in a tree. DefaultTreeCellRenderer is not opaque and unless you subclass paint you should not change this. See How to Use Trees in The Java Tutorial for examples of customizing node display using this class.

    The set of icons and colors used by DefaultTreeCellRenderer can be configured using the various setter methods. The value for each property is initialized from the defaults table. When the look and feel changes (updateUI is invoked), any properties that have a value of type UIResource are refreshed from the defaults table. The following table lists the mapping between DefaultTreeCellRenderer property and defaults table key:

    Property: Key:
    "leafIcon" | "Tree.leafIcon"
    "closedIcon" | "Tree.closedIcon"
    "openIcon" | "Tree.openIcon"
    "textSelectionColor" | "Tree.selectionForeground"
    "textNonSelectionColor" | "Tree.textForeground"
    "backgroundSelectionColor" | "Tree.selectionBackground"
    "backgroundNonSelectionColor" | "Tree.textBackground"
    "borderSelectionColor" | "Tree.selectionBorderColor"

    Implementation Note: This class overrides invalidate, validate, revalidate, repaint, and firePropertyChange solely to improve performance. If not overridden, these frequently called methods would execute code paths that are unnecessary for the default tree cell renderer. If you write your own renderer, take care to weigh the benefits and drawbacks of overriding these methods.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.JLabel

        JLabel.AccessibleJLabel

      • Nested classes/interfaces inherited from class javax.swing.JComponent

        JComponent.AccessibleJComponent

      • Nested classes/interfaces inherited from class java.awt.Container

        Container.AccessibleAWTContainer

      • Nested classes/interfaces inherited from class java.awt.Component

        Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Color backgroundNonSelectionColor
      Color to use for the background when the node isn't selected.
      protected Color backgroundSelectionColor
      Color to use for the background when a node is selected.
      protected Color borderSelectionColor
      Color to use for the focus indicator when the node has focus.
      protected Icon closedIcon
      Icon used to show non-leaf nodes that aren't expanded.
      protected boolean hasFocus
      True if has focus.
      protected Icon leafIcon
      Icon used to show leaf nodes.
      protected Icon openIcon
      Icon used to show non-leaf nodes that are expanded.
      protected boolean selected
      Is the value currently selected.
      protected Color textNonSelectionColor
      Color to use for the foreground for non-selected nodes.
      protected Color textSelectionColor
      Color to use for the foreground for selected nodes.

      • Fields inherited from class javax.swing.JLabel

        labelFor

      • Fields inherited from class javax.swing.JComponent

        accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW

      • Fields inherited from class java.awt.Component

        BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT

      • 字段 - 继承于接口 javax.swing.SwingConstants

        BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, 下一个, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST

      • 字段 - 继承于接口 java.awt.image.ImageObserver

        ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeCellRenderer()
      Creates a DefaultTreeCellRenderer.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, byte oldValue, byte newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, char oldValue, char newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, double oldValue, double newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, float oldValue, float newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, int oldValue, int newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, long oldValue, long newValue)
      Overridden for performance reasons.
      protected void firePropertyChange(String propertyName, Object oldValue, Object newValue)
      Overridden for performance reasons.
      void firePropertyChange(String propertyName, short oldValue, short newValue)
      Overridden for performance reasons.
      Color getBackgroundNonSelectionColor()
      Returns the background color to be used for non selected nodes.
      Color getBackgroundSelectionColor()
      Returns the color to use for the background if node is selected.
      Color getBorderSelectionColor()
      Returns the color the border is drawn.
      Icon getClosedIcon()
      Returns the icon used to represent non-leaf nodes that are not expanded.
      Icon getDefaultClosedIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.
      Icon getDefaultLeafIcon()
      Returns the default icon, for the current laf, that is used to represent leaf nodes.
      Icon getDefaultOpenIcon()
      Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.
      Font getFont()
      Gets the font of this component.
      Icon getLeafIcon()
      Returns the icon used to represent leaf nodes.
      Icon getOpenIcon()
      Returns the icon used to represent non-leaf nodes that are expanded.
      Dimension getPreferredSize()
      Overrides JComponent.getPreferredSize to return slightly wider preferred size value.
      Color getTextNonSelectionColor()
      Returns the color the text is drawn with when the node isn't selected.
      Color getTextSelectionColor()
      Returns the color the text is drawn with when the node is selected.
      Component getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Configures the renderer based on the passed in components.
      void invalidate()
      Overridden for performance reasons.
      void paint(Graphics g)
      Paints the value.
      void repaint()
      Overridden for performance reasons.
      void repaint(long tm, int x, int y, int width, int height)
      Overridden for performance reasons.
      void repaint(Rectangle r)
      Overridden for performance reasons.
      void revalidate()
      Overridden for performance reasons.
      void setBackground(Color color)
      Subclassed to map ColorUIResources to null.
      void setBackgroundNonSelectionColor(Color newColor)
      Sets the background color to be used for non selected nodes.
      void setBackgroundSelectionColor(Color newColor)
      Sets the color to use for the background if node is selected.
      void setBorderSelectionColor(Color newColor)
      Sets the color to use for the border.
      void setClosedIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are not expanded.
      void setFont(Font font)
      Subclassed to map FontUIResources to null.
      void setLeafIcon(Icon newIcon)
      Sets the icon used to represent leaf nodes.
      void setOpenIcon(Icon newIcon)
      Sets the icon used to represent non-leaf nodes that are expanded.
      void setTextNonSelectionColor(Color newColor)
      Sets the color the text is drawn with when the node isn't selected.
      void setTextSelectionColor(Color newColor)
      Sets the color the text is drawn with when the node is selected.
      void updateUI()
      Resets the UI property to a value from the current look and feel.
      void validate()
      Overridden for performance reasons.

      • 方法 - 继承于类 javax.swing.JLabel

        checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition

      • 方法 - 继承于类 javax.swing.JComponent

        addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingOrigin, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update

      • 方法 - 继承于类 java.awt.Container

        add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusDownCycle, validateTree

      • 方法 - 继承于类 java.awt.Component

        action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • selected

        protected boolean selected
        Is the value currently selected.

      • hasFocus

        protected boolean hasFocus
        True if has focus.

      • closedIcon

        protected transient Icon closedIcon
        Icon used to show non-leaf nodes that aren't expanded.

      • leafIcon

        protected transient Icon leafIcon
        Icon used to show leaf nodes.

      • openIcon

        protected transient Icon openIcon
        Icon used to show non-leaf nodes that are expanded.

      • textSelectionColor

        protected Color textSelectionColor
        Color to use for the foreground for selected nodes.

      • textNonSelectionColor

        protected Color textNonSelectionColor
        Color to use for the foreground for non-selected nodes.

      • backgroundSelectionColor

        protected Color backgroundSelectionColor
        Color to use for the background when a node is selected.

      • backgroundNonSelectionColor

        protected Color backgroundNonSelectionColor
        Color to use for the background when the node isn't selected.

      • borderSelectionColor

        protected Color borderSelectionColor
        Color to use for the focus indicator when the node has focus.

    • 构造方法详细信息

      • DefaultTreeCellRenderer

        public DefaultTreeCellRenderer()
        Creates a DefaultTreeCellRenderer. Icons and text color are determined from the UIManager.

    • 方法详细信息

      • updateUI

        public void updateUI()
        Resets the UI property to a value from the current look and feel.
        重载：
        updateUI in class JLabel
        从以下版本开始：
        1.7
        另请参见：
        JComponent.updateUI()

      • getDefaultOpenIcon

        public Icon getDefaultOpenIcon()
        Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.

      • getDefaultClosedIcon

        public Icon getDefaultClosedIcon()
        Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.

      • getDefaultLeafIcon

        public Icon getDefaultLeafIcon()
        Returns the default icon, for the current laf, that is used to represent leaf nodes.

      • setOpenIcon

        public void setOpenIcon(Icon newIcon)
        Sets the icon used to represent non-leaf nodes that are expanded.

      • getOpenIcon

        public Icon getOpenIcon()
        Returns the icon used to represent non-leaf nodes that are expanded.

      • setClosedIcon

        public void setClosedIcon(Icon newIcon)
        Sets the icon used to represent non-leaf nodes that are not expanded.

      • getClosedIcon

        public Icon getClosedIcon()
        Returns the icon used to represent non-leaf nodes that are not expanded.

      • setLeafIcon

        public void setLeafIcon(Icon newIcon)
        Sets the icon used to represent leaf nodes.

      • getLeafIcon

        public Icon getLeafIcon()
        Returns the icon used to represent leaf nodes.

      • setTextSelectionColor

        public void setTextSelectionColor(Color newColor)
        Sets the color the text is drawn with when the node is selected.

      • getTextSelectionColor

        public Color getTextSelectionColor()
        Returns the color the text is drawn with when the node is selected.

      • setTextNonSelectionColor

        public void setTextNonSelectionColor(Color newColor)
        Sets the color the text is drawn with when the node isn't selected.

      • getTextNonSelectionColor

        public Color getTextNonSelectionColor()
        Returns the color the text is drawn with when the node isn't selected.

      • setBackgroundSelectionColor

        public void setBackgroundSelectionColor(Color newColor)
        Sets the color to use for the background if node is selected.

      • getBackgroundSelectionColor

        public Color getBackgroundSelectionColor()
        Returns the color to use for the background if node is selected.

      • setBackgroundNonSelectionColor

        public void setBackgroundNonSelectionColor(Color newColor)
        Sets the background color to be used for non selected nodes.

      • getBackgroundNonSelectionColor

        public Color getBackgroundNonSelectionColor()
        Returns the background color to be used for non selected nodes.

      • setBorderSelectionColor

        public void setBorderSelectionColor(Color newColor)
        Sets the color to use for the border.

      • getBorderSelectionColor

        public Color getBorderSelectionColor()
        Returns the color the border is drawn.

      • setFont

        public void setFont(Font font)
        Subclassed to map FontUIResources to null. If font is null, or a FontUIResource, this has the effect of letting the font of the JTree show through. On the other hand, if font is non-null, and not a FontUIResource, the font becomes font.
        重载：
        setFont in class JComponent
        参数：
        font - the desired Font for this component
        另请参见：
        Component.getFont()

      • getFont

        public Font getFont()
        Gets the font of this component.
        指定者：
        getFont in interface MenuContainer
        重载：
        getFont in class Component
        返回：
        this component's font; if a font has not been set for this component, the font of its parent is returned
        另请参见：
        Component.setFont(java.awt.Font)

      • setBackground

        public void setBackground(Color color)
        Subclassed to map ColorUIResources to null. If color is null, or a ColorUIResource, this has the effect of letting the background color of the JTree show through. On the other hand, if color is non-null, and not a ColorUIResource, the background becomes color.
        重载：
        setBackground in class JComponent
        参数：
        color - the desired background Color
        另请参见：
        Component.getBackground(), JComponent.setOpaque(boolean)

      • getTreeCellRendererComponent

        public Component getTreeCellRendererComponent(JTree tree,
                                     Object value,
                                     boolean sel,
                                     boolean expanded,
                                     boolean leaf,
                                     int row,
                                     boolean hasFocus)
        Configures the renderer based on the passed in components. The value is set from messaging the tree with convertValueToText, which ultimately invokes toString on value. The foreground color is set based on the selection and the icon is set based on the leaf and expanded parameters.
        指定者：
        getTreeCellRendererComponent in interface TreeCellRenderer
        返回：
        the Component that the renderer uses to draw the value

      • paint

        public void paint(Graphics g)
        Paints the value. The background is filled based on selected.
        重载：
        paint in class JComponent
        参数：
        g - the Graphics context in which to paint
        另请参见：
        JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

      • getPreferredSize

        public Dimension getPreferredSize()
        Overrides JComponent.getPreferredSize to return slightly wider preferred size value.
        重载：
        getPreferredSize in class JComponent
        返回：
        the value of the preferredSize property
        另请参见：
        JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

      • validate

        public void validate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        validate in class Container
        另请参见：
        Container.add(java.awt.Component),
Container.invalidate(),
Container.isValidateRoot(),
JComponent.revalidate(),
Container.validateTree()

      • invalidate

        public void invalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        invalidate in class Container
        从以下版本开始：
        1.5
        另请参见：
        Container.validate(), Container.layout(), LayoutManager2

      • revalidate

        public void revalidate()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        revalidate in class JComponent
        另请参见：
        Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

      • repaint

        public void repaint(long tm,
           int x,
           int y,
           int width,
           int height)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        tm - this parameter is not used
        x - the x value of the dirty region
        y - the y value of the dirty region
        width - the width of the dirty region
        height - the height of the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint(Rectangle r)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class JComponent
        参数：
        r - a Rectangle containing the dirty region
        另请参见：
        JComponent.isPaintingOrigin(),
Component.isShowing(),
RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

      • repaint

        public void repaint()
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        repaint in class Component
        从以下版本开始：
        1.5
        另请参见：
        Component.update(Graphics)

      • firePropertyChange

        protected void firePropertyChange(String propertyName,
                      Object oldValue,
                      Object newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      byte oldValue,
                      byte newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a byte)
        newValue - the new value of the property (as a byte)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      char oldValue,
                      char newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a char)
        newValue - the new value of the property (as a char)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      short oldValue,
                      short newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a short)
        newValue - the old value of the property (as a short)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      int oldValue,
                      int newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      long oldValue,
                      long newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a long)
        newValue - the new value of the property (as a long)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      float oldValue,
                      float newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a float)
        newValue - the new value of the property (as a float)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      double oldValue,
                      double newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class Component
        参数：
        propertyName - the programmatic name of the property that was changed
        oldValue - the old value of the property (as a double)
        newValue - the new value of the property (as a double)
        另请参见：
        Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

      • firePropertyChange

        public void firePropertyChange(String propertyName,
                      boolean oldValue,
                      boolean newValue)
        Overridden for performance reasons. See the Implementation Note for more information.
        重载：
        firePropertyChange in class JComponent
        参数：
        propertyName - the property whose value has changed
        oldValue - the property's previous value
        newValue - the property's new value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultTreeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeModel

  • java.lang.Object
    • javax.swing.tree.DefaultTreeModel
  • 所有已实现的接口：
    Serializable, TreeModel

    public class DefaultTreeModel
extends Object
implements Serializable, TreeModel
    A simple tree data model that uses TreeNodes. For further information and examples that use DefaultTreeModel, see How to Use Trees in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean asksAllowsChildren
      Determines how the isLeaf method figures out if a node is a leaf node.
      protected EventListenerList listenerList
      Listeners.
      protected TreeNode root
      Root of the tree.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeModel(TreeNode root)
      Creates a tree in which any node can have children.
      DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
      Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      boolean asksAllowsChildren()
      Tells how leaf nodes are determined.
      protected void fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      protected void fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
      Notifies all listeners that have registered interest for notification on this event type.
      Object getChild(Object parent, int index)
      Returns the child of parent at index index in the parent's child array.
      int getChildCount(Object parent)
      Returns the number of children of parent.
      int getIndexOfChild(Object parent, Object child)
      Returns the index of child in parent.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      TreeNode[] getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      Object getRoot()
      Returns the root of the tree.
      TreeModelListener[] getTreeModelListeners()
      Returns an array of all the tree model listeners registered on this model.
      void insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index)
      Invoked this to insert newChild at location index in parents children.
      boolean isLeaf(Object node)
      Returns whether the specified node is a leaf node.
      void nodeChanged(TreeNode node)
      Invoke this method after you've changed how node is to be represented in the tree.
      void nodesChanged(TreeNode node, int[] childIndices)
      Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.
      void nodeStructureChanged(TreeNode node)
      Invoke this method if you've totally changed the children of node and its childrens children...
      void nodesWereInserted(TreeNode node, int[] childIndices)
      Invoke this method after you've inserted some TreeNodes into node.
      void nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
      Invoke this method after you've removed some TreeNodes from node.
      void reload()
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void reload(TreeNode node)
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void removeNodeFromParent(MutableTreeNode node)
      Message this to remove node from its parent.
      void removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener().
      void setAsksAllowsChildren(boolean newValue)
      Sets whether or not to test leafness by asking getAllowsChildren() or isLeaf() to the TreeNodes.
      void setRoot(TreeNode root)
      Sets the root to root.
      void valueForPathChanged(TreePath path, Object newValue)
      This sets the user object of the TreeNode identified by path and posts a node changed.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • root

        protected TreeNode root
        Root of the tree.

      • listenerList

        protected EventListenerList listenerList
        Listeners.

      • asksAllowsChildren

        protected boolean asksAllowsChildren
        Determines how the isLeaf method figures out if a node is a leaf node. If true, a node is a leaf node if it does not allow children. (If it allows children, it is not a leaf node, even if no children are present.) That lets you distinguish between folder nodes and file nodes in a file system, for example.

        If this value is false, then any node which has no children is a leaf node, and any node may acquire children.

        另请参见：
        TreeNode.getAllowsChildren(),
TreeModel.isLeaf(java.lang.Object),
setAsksAllowsChildren(boolean)

    • 构造方法详细信息

      • DefaultTreeModel

        @ConstructorProperties(value="root")
public DefaultTreeModel(TreeNode root)
        Creates a tree in which any node can have children.
        参数：
        root - a TreeNode object that is the root of the tree
        另请参见：
        DefaultTreeModel(TreeNode, boolean)

      • DefaultTreeModel

        public DefaultTreeModel(TreeNode root,
                boolean asksAllowsChildren)
        Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
        参数：
        root - a TreeNode object that is the root of the tree
        asksAllowsChildren - a boolean, false if any node can have children, true if each node is asked to see if it can have children
        另请参见：
        asksAllowsChildren

    • 方法详细信息

      • setAsksAllowsChildren

        public void setAsksAllowsChildren(boolean newValue)
        Sets whether or not to test leafness by asking getAllowsChildren() or isLeaf() to the TreeNodes. If newvalue is true, getAllowsChildren() is messaged, otherwise isLeaf() is messaged.

      • asksAllowsChildren

        public boolean asksAllowsChildren()
        Tells how leaf nodes are determined.
        返回：
        true if only nodes which do not allow children are leaf nodes, false if nodes which have no children (even if allowed) are leaf nodes
        另请参见：
        asksAllowsChildren

      • setRoot

        public void setRoot(TreeNode root)
        Sets the root to root. A null root implies the tree is to display nothing, and is legal.

      • getRoot

        public Object getRoot()
        Returns the root of the tree. Returns null only if the tree has no nodes.
        指定者：
        getRoot in interface TreeModel
        返回：
        the root of the tree

      • getIndexOfChild

        public int getIndexOfChild(Object parent,
                  Object child)
        Returns the index of child in parent. If either the parent or child is null, returns -1.
        指定者：
        getIndexOfChild in interface TreeModel
        参数：
        parent - a note in the tree, obtained from this data source
        child - the node we are interested in
        返回：
        the index of the child in the parent, or -1 if either the parent or the child is null

      • getChild

        public Object getChild(Object parent,
              int index)
        Returns the child of parent at index index in the parent's child array. parent must be a node previously obtained from this data source. This should not return null if index is a valid index for parent (that is index >= 0 && index < getChildCount(parent)).
        指定者：
        getChild in interface TreeModel
        参数：
        parent - a node in the tree, obtained from this data source
        返回：
        the child of parent at index index

      • getChildCount

        public int getChildCount(Object parent)
        Returns the number of children of parent. Returns 0 if the node is a leaf or if it has no children. parent must be a node previously obtained from this data source.
        指定者：
        getChildCount in interface TreeModel
        参数：
        parent - a node in the tree, obtained from this data source
        返回：
        the number of children of the node parent

      • isLeaf

        public boolean isLeaf(Object node)
        Returns whether the specified node is a leaf node. The way the test is performed depends on the askAllowsChildren setting.
        指定者：
        isLeaf in interface TreeModel
        参数：
        node - the node to check
        返回：
        true if the node is a leaf node
        另请参见：
        asksAllowsChildren, TreeModel.isLeaf(java.lang.Object)

      • reload

        public void reload()
        Invoke this method if you've modified the TreeNodes upon which this model depends. The model will notify all of its listeners that the model has changed.

      • valueForPathChanged

        public void valueForPathChanged(TreePath path,
                       Object newValue)
        This sets the user object of the TreeNode identified by path and posts a node changed. If you use custom user objects in the TreeModel you're going to need to subclass this and set the user object of the changed node to something meaningful.
        指定者：
        valueForPathChanged in interface TreeModel
        参数：
        path - path to the node that the user has altered
        newValue - the new value from the TreeCellEditor

      • insertNodeInto

        public void insertNodeInto(MutableTreeNode newChild,
                  MutableTreeNode parent,
                  int index)
        Invoked this to insert newChild at location index in parents children. This will then message nodesWereInserted to create the appropriate event. This is the preferred way to add children as it will create the appropriate event.

      • removeNodeFromParent

        public void removeNodeFromParent(MutableTreeNode node)
        Message this to remove node from its parent. This will message nodesWereRemoved to create the appropriate event. This is the preferred way to remove a node as it handles the event creation for you.

      • nodeChanged

        public void nodeChanged(TreeNode node)
        Invoke this method after you've changed how node is to be represented in the tree.

      • reload

        public void reload(TreeNode node)
        Invoke this method if you've modified the TreeNodes upon which this model depends. The model will notify all of its listeners that the model has changed below the given node.
        参数：
        node - the node below which the model has changed

      • nodesWereInserted

        public void nodesWereInserted(TreeNode node,
                     int[] childIndices)
        Invoke this method after you've inserted some TreeNodes into node. childIndices should be the index of the new elements and must be sorted in ascending order.

      • nodesWereRemoved

        public void nodesWereRemoved(TreeNode node,
                    int[] childIndices,
                    Object[] removedChildren)
        Invoke this method after you've removed some TreeNodes from node. childIndices should be the index of the removed elements and must be sorted in ascending order. And removedChildren should be the array of the children objects that were removed.

      • nodesChanged

        public void nodesChanged(TreeNode node,
                int[] childIndices)
        Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.

      • nodeStructureChanged

        public void nodeStructureChanged(TreeNode node)
        Invoke this method if you've totally changed the children of node and its childrens children... This will post a treeStructureChanged event.

      • getPathToRoot

        public TreeNode[] getPathToRoot(TreeNode aNode)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        参数：
        aNode - the TreeNode to get the path for

      • getPathToRoot

        protected TreeNode[] getPathToRoot(TreeNode aNode,
                       int depth)
        Builds the parents of node up to and including the root node, where the original node is the last element in the returned array. The length of the returned array gives the node's depth in the tree.
        参数：
        aNode - the TreeNode to get the path for
        depth - an int giving the number of steps already taken towards the root (on recursive calls), used to size the returned array
        返回：
        an array of TreeNodes giving the path from the root to the specified node

      • addTreeModelListener

        public void addTreeModelListener(TreeModelListener l)
        Adds a listener for the TreeModelEvent posted after the tree changes.
        指定者：
        addTreeModelListener in interface TreeModel
        参数：
        l - the listener to add
        另请参见：
        removeTreeModelListener(javax.swing.event.TreeModelListener)

      • removeTreeModelListener

        public void removeTreeModelListener(TreeModelListener l)
        Removes a listener previously added with addTreeModelListener().
        指定者：
        removeTreeModelListener in interface TreeModel
        参数：
        l - the listener to remove
        另请参见：
        addTreeModelListener(javax.swing.event.TreeModelListener)

      • getTreeModelListeners

        public TreeModelListener[] getTreeModelListeners()
        Returns an array of all the tree model listeners registered on this model.
        返回：
        all of this model's TreeModelListeners or an empty array if no tree model listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addTreeModelListener(javax.swing.event.TreeModelListener), removeTreeModelListener(javax.swing.event.TreeModelListener)

      • fireTreeNodesChanged

        protected void fireTreeNodesChanged(Object source,
                        Object[] path,
                        int[] childIndices,
                        Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent of the nodes that changed; use null to identify the root has changed
        childIndices - the indices of the changed elements
        children - the changed elements

      • fireTreeNodesInserted

        protected void fireTreeNodesInserted(Object source,
                         Object[] path,
                         int[] childIndices,
                         Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent the nodes were added to
        childIndices - the indices of the new elements
        children - the new elements

      • fireTreeNodesRemoved

        protected void fireTreeNodesRemoved(Object source,
                        Object[] path,
                        int[] childIndices,
                        Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent the nodes were removed from
        childIndices - the indices of the removed elements
        children - the removed elements

      • fireTreeStructureChanged

        protected void fireTreeStructureChanged(Object source,
                            Object[] path,
                            int[] childIndices,
                            Object[] children)
        Notifies all listeners that have registered interest for notification on this event type. The event instance is lazily created using the parameters passed into the fire method.
        参数：
        source - the source of the TreeModelEvent; typically this
        path - the path to the parent of the structure that has changed; use null to identify the root has changed
        childIndices - the indices of the affected elements
        children - the affected elements

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultTreeModel m for its tree model listeners with the following code:

        TreeModelListener[] tmls = (TreeModelListener[])(m.getListeners(TreeModelListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getTreeModelListeners()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uvstlcaicasllassrittdeyio))c")rlc.../f=ffe/i tnis


DefaultTreeSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 DefaultTreeSelectionModel

  • java.lang.Object
    • javax.swing.tree.DefaultTreeSelectionModel
  • 所有已实现的接口：
    Serializable, Cloneable, TreeSelectionModel
    直接已知子类：
    JTree.EmptySelectionModel

    public class DefaultTreeSelectionModel
extends Object
implements Cloneable, Serializable, TreeSelectionModel
    Default implementation of TreeSelectionModel. Listeners are notified whenever the paths in the selection change, not the rows. In order to be able to track row changes you may wish to become a listener for expansion events on the tree and test for changes from there.

    resetRowSelection is called from any of the methods that update the selected paths. If you subclass any of these methods to filter what is allowed to be selected, be sure and message resetRowSelection if you do not message super. 警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    另请参见：
    JTree

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected SwingPropertyChangeSupport changeSupport
      Used to messaged registered listeners.
      protected int leadIndex
      Index of the lead path in selection.
      protected TreePath leadPath
      Last path that was added.
      protected int leadRow
      Lead row.
      protected EventListenerList listenerList
      Event listener list.
      protected DefaultListSelectionModel listSelectionModel
      Handles maintaining the list selection model.
      protected RowMapper rowMapper
      Provides a row for a given path.
      protected TreePath[] selection
      Paths that are currently selected.
      static String SELECTION_MODE_PROPERTY
      Property name for selectionMode.
      protected int selectionMode
      Mode for the selection, will be either SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • 字段 - 继承于接口 javax.swing.tree.TreeSelectionModel

        CONTIGUOUS_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION, SINGLE_TREE_SELECTION

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultTreeSelectionModel()
      Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addSelectionPath(TreePath path)
      Adds path to the current selection.
      void addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      protected boolean arePathsContiguous(TreePath[] paths)
      Returns true if the paths are contiguous, or this object has no RowMapper.
      protected boolean canPathsBeAdded(TreePath[] paths)
      Used to test if a particular set of TreePaths can be added.
      protected boolean canPathsBeRemoved(TreePath[] paths)
      Returns true if the paths can be removed without breaking the continuity of the model.
      void clearSelection()
      Empties the current selection.
      Object clone()
      Returns a clone of this object with the same selection.
      protected void fireValueChanged(TreeSelectionEvent e)
      Notifies all listeners that are registered for tree selection events on this object.
      TreePath getLeadSelectionPath()
      Returns the last path that was added.
      int getLeadSelectionRow()
      Returns the lead selection index.
      <T extends EventListener>
      T[]             		getListeners(类<T> listenerType)
      Returns an array of all the objects currently registered as FooListeners upon this model.
      int getMaxSelectionRow()
      Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.
      int getMinSelectionRow()
      Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.
      PropertyChangeListener[] getPropertyChangeListeners()
      Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.
      RowMapper getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      int getSelectionCount()
      Returns the number of paths that are selected.
      int getSelectionMode()
      Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.
      TreePath getSelectionPath()
      Returns the first path in the selection.
      TreePath[] getSelectionPaths()
      Returns the selection.
      int[] getSelectionRows()
      Returns the selection in terms of rows.
      TreeSelectionListener[] getTreeSelectionListeners()
      Returns an array of all the tree selection listeners registered on this model.
      protected void insureRowContinuity()
      Makes sure the currently selected TreePaths are valid for the current selection mode.
      protected void insureUniqueness()
      This method is obsolete and its implementation is now a noop.
      boolean isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean isRowSelected(int row)
      Returns true if the row identified by row is selected.
      boolean isSelectionEmpty()
      Returns true if the selection is currently empty.
      protected void notifyPathChange(Vector changedPaths, TreePath oldLeadSelection)
      Deprecated.
      As of JDK version 1.7
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removeSelectionPath(TreePath path)
      Removes path from the selection.
      void removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
      void resetRowSelection()
      Updates this object's mapping from TreePath to rows.
      void setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void setSelectionMode(int mode)
      Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      void setSelectionPath(TreePath path)
      Sets the selection to path.
      void setSelectionPaths(TreePath[] pPaths)
      Sets the selection.
      String toString()
      Returns a string that displays and identifies this object's properties.
      protected void updateLeadIndex()
      Updates the leadIndex instance variable.

      • 方法 - 继承于类 java.lang.Object

        equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SELECTION_MODE_PROPERTY

        public static final String SELECTION_MODE_PROPERTY
        Property name for selectionMode.
        另请参见：
        Constant Field Values

      • changeSupport

        protected SwingPropertyChangeSupport changeSupport
        Used to messaged registered listeners.

      • selection

        protected TreePath[] selection
        Paths that are currently selected. Will be null if nothing is currently selected.

      • listenerList

        protected EventListenerList listenerList
        Event listener list.

      • rowMapper

        protected transient RowMapper rowMapper
        Provides a row for a given path.

      • listSelectionModel

        protected DefaultListSelectionModel listSelectionModel
        Handles maintaining the list selection model. The RowMapper is used to map from a TreePath to a row, and the value is then placed here.

      • selectionMode

        protected int selectionMode
        Mode for the selection, will be either SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • leadPath

        protected TreePath leadPath
        Last path that was added.

      • leadIndex

        protected int leadIndex
        Index of the lead path in selection.

      • leadRow

        protected int leadRow
        Lead row.

    • 构造方法详细信息

      • DefaultTreeSelectionModel

        public DefaultTreeSelectionModel()
        Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.

    • 方法详细信息

      • setRowMapper

        public void setRowMapper(RowMapper newMapper)
        Sets the RowMapper instance. This instance is used to determine the row for a particular TreePath.
        指定者：
        setRowMapper in interface TreeSelectionModel

      • getRowMapper

        public RowMapper getRowMapper()
        Returns the RowMapper instance that is able to map a TreePath to a row.
        指定者：
        getRowMapper in interface TreeSelectionModel

      • setSelectionMode

        public void setSelectionMode(int mode)
        Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION. If mode is not one of the defined value, DISCONTIGUOUS_TREE_SELECTION is assumed.

        This may change the selection if the current selection is not valid for the new mode. For example, if three TreePaths are selected when the mode is changed to SINGLE_TREE_SELECTION, only one TreePath will remain selected. It is up to the particular implementation to decide what TreePath remains selected.

        Setting the mode to something other than the defined types will result in the mode becoming DISCONTIGUOUS_TREE_SELECTION.

        指定者：
        setSelectionMode in interface TreeSelectionModel

      • getSelectionMode

        public int getSelectionMode()
        Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.
        指定者：
        getSelectionMode in interface TreeSelectionModel

      • setSelectionPath

        public void setSelectionPath(TreePath path)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If path is null, this has the same effect as invoking clearSelection.
        指定者：
        setSelectionPath in interface TreeSelectionModel
        参数：
        path - new path to select

      • setSelectionPaths

        public void setSelectionPaths(TreePath[] pPaths)
        Sets the selection. Whether the supplied paths are taken as the new selection depends upon the selection mode. If the supplied array is null, or empty, the selection is cleared. If the selection mode is SINGLE_TREE_SELECTION, only the first path in pPaths is used. If the selection mode is CONTIGUOUS_TREE_SELECTION and the supplied paths are not contiguous, then only the first path in pPaths is used. If the selection mode is DISCONTIGUOUS_TREE_SELECTION, then all paths are used.

        All null paths in pPaths are ignored.

        If this represents a change, all registered TreeSelectionListeners are notified.

        The lead path is set to the last unique path.

        The paths returned from getSelectionPaths are in the same order as those supplied to this method.

        指定者：
        setSelectionPaths in interface TreeSelectionModel
        参数：
        pPaths - the new selection

      • addSelectionPath

        public void addSelectionPath(TreePath path)
        Adds path to the current selection. If path is not currently in the selection the TreeSelectionListeners are notified. This has no effect if path is null.
        指定者：
        addSelectionPath in interface TreeSelectionModel
        参数：
        path - the new path to add to the current selection

      • addSelectionPaths

        public void addSelectionPaths(TreePath[] paths)
        Adds paths to the current selection. If any of the paths in paths are not currently in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.

        The lead path is set to the last element in paths.

        If the selection mode is CONTIGUOUS_TREE_SELECTION, and adding the new paths would make the selection discontiguous. Then two things can result: if the TreePaths in paths are contiguous, then the selection becomes these TreePaths, otherwise the TreePaths aren't contiguous and the selection becomes the first TreePath in paths.

        指定者：
        addSelectionPaths in interface TreeSelectionModel
        参数：
        paths - the new path to add to the current selection

      • removeSelectionPath

        public void removeSelectionPath(TreePath path)
        Removes path from the selection. If path is in the selection The TreeSelectionListeners are notified. This has no effect if path is null.
        指定者：
        removeSelectionPath in interface TreeSelectionModel
        参数：
        path - the path to remove from the selection

      • removeSelectionPaths

        public void removeSelectionPaths(TreePath[] paths)
        Removes paths from the selection. If any of the paths in paths are in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.
        指定者：
        removeSelectionPaths in interface TreeSelectionModel
        参数：
        paths - the paths to remove from the selection

      • getSelectionPath

        public TreePath getSelectionPath()
        Returns the first path in the selection. This is useful if there if only one item currently selected.
        指定者：
        getSelectionPath in interface TreeSelectionModel

      • getSelectionPaths

        public TreePath[] getSelectionPaths()
        Returns the selection.
        指定者：
        getSelectionPaths in interface TreeSelectionModel
        返回：
        the selection

      • getSelectionCount

        public int getSelectionCount()
        Returns the number of paths that are selected.
        指定者：
        getSelectionCount in interface TreeSelectionModel

      • isPathSelected

        public boolean isPathSelected(TreePath path)
        Returns true if the path, path, is in the current selection.
        指定者：
        isPathSelected in interface TreeSelectionModel

      • isSelectionEmpty

        public boolean isSelectionEmpty()
        Returns true if the selection is currently empty.
        指定者：
        isSelectionEmpty in interface TreeSelectionModel

      • clearSelection

        public void clearSelection()
        Empties the current selection. If this represents a change in the current selection, the selection listeners are notified.
        指定者：
        clearSelection in interface TreeSelectionModel

      • addTreeSelectionListener

        public void addTreeSelectionListener(TreeSelectionListener x)
        Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
        指定者：
        addTreeSelectionListener in interface TreeSelectionModel
        参数：
        x - the new listener to be added

      • removeTreeSelectionListener

        public void removeTreeSelectionListener(TreeSelectionListener x)
        Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
        指定者：
        removeTreeSelectionListener in interface TreeSelectionModel
        参数：
        x - the listener to remove

      • getTreeSelectionListeners

        public TreeSelectionListener[] getTreeSelectionListeners()
        Returns an array of all the tree selection listeners registered on this model.
        返回：
        all of this model's TreeSelectionListeners or an empty array if no tree selection listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addTreeSelectionListener(javax.swing.event.TreeSelectionListener), removeTreeSelectionListener(javax.swing.event.TreeSelectionListener)

      • fireValueChanged

        protected void fireValueChanged(TreeSelectionEvent e)
        Notifies all listeners that are registered for tree selection events on this object.
        另请参见：
        addTreeSelectionListener(javax.swing.event.TreeSelectionListener), EventListenerList

      • getListeners

        public <T extends EventListener> T[] getListeners(类<T> listenerType)
        Returns an array of all the objects currently registered as FooListeners upon this model. FooListeners are registered using the addFooListener method.

        You can specify the listenerType argument with a class literal, such as FooListener.class. For example, you can query a DefaultTreeSelectionModel m for its tree selection listeners with the following code:

        TreeSelectionListener[] tsls = (TreeSelectionListener[])(m.getListeners(TreeSelectionListener.class));
        If no such listeners exist, this method returns an empty array.
        参数：
        listenerType - the type of listeners requested; this parameter should specify an interface that descends from java.util.EventListener
        返回：
        an array of all objects registered as FooListeners on this component, or an empty array if no such listeners have been added
        抛出：
        ClassCastException - if listenerType doesn't specify a class or interface that implements java.util.EventListener
        从以下版本开始：
        1.3
        另请参见：
        getTreeSelectionListeners(), getPropertyChangeListeners()

      • getSelectionRows

        public int[] getSelectionRows()
        Returns the selection in terms of rows. There is not necessarily a one-to-one mapping between the TreePaths returned from getSelectionPaths and this method. In particular, if a TreePath is not viewable (the RowMapper returns -1 for the row corresponding to the TreePath), then the corresponding row is not included in the returned array. For example, if the selection consists of two paths, A and B, with A at row 10, and B not currently viewable, then this method returns an array with the single entry 10.
        指定者：
        getSelectionRows in interface TreeSelectionModel
        返回：
        the selection in terms of rows

      • getMinSelectionRow

        public int getMinSelectionRow()
        Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.
        指定者：
        getMinSelectionRow in interface TreeSelectionModel

      • getMaxSelectionRow

        public int getMaxSelectionRow()
        Returns the largest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.
        指定者：
        getMaxSelectionRow in interface TreeSelectionModel

      • isRowSelected

        public boolean isRowSelected(int row)
        Returns true if the row identified by row is selected.
        指定者：
        isRowSelected in interface TreeSelectionModel

      • resetRowSelection

        public void resetRowSelection()
        Updates this object's mapping from TreePath to rows. This should be invoked when the mapping from TreePaths to integers has changed (for example, a node has been expanded).

        You do not normally have to call this, JTree and its associated Listeners will invoke this for you. If you are implementing your own View class, then you will have to invoke this.

        This will invoke insureRowContinuity to make sure the currently selected TreePaths are still valid based on the selection mode.

        指定者：
        resetRowSelection in interface TreeSelectionModel

      • getLeadSelectionRow

        public int getLeadSelectionRow()
        Returns the lead selection index. That is the last index that was added.
        指定者：
        getLeadSelectionRow in interface TreeSelectionModel

      • getLeadSelectionPath

        public TreePath getLeadSelectionPath()
        Returns the last path that was added. This may differ from the leadSelectionPath property maintained by the JTree.
        指定者：
        getLeadSelectionPath in interface TreeSelectionModel

      • addPropertyChangeListener

        public void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired when the selection mode changes.

        指定者：
        addPropertyChangeListener in interface TreeSelectionModel
        参数：
        listener - the PropertyChangeListener to be added

      • removePropertyChangeListener

        public void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        指定者：
        removePropertyChangeListener in interface TreeSelectionModel
        参数：
        listener - the PropertyChangeListener to be removed

      • getPropertyChangeListeners

        public PropertyChangeListener[] getPropertyChangeListeners()
        Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.
        返回：
        all of this model's PropertyChangeListeners or an empty array if no property change listeners are currently registered
        从以下版本开始：
        1.4
        另请参见：
        addPropertyChangeListener(java.beans.PropertyChangeListener), removePropertyChangeListener(java.beans.PropertyChangeListener)

      • insureRowContinuity

        protected void insureRowContinuity()
        Makes sure the currently selected TreePaths are valid for the current selection mode. If the selection mode is CONTIGUOUS_TREE_SELECTION and a RowMapper exists, this will make sure all the rows are contiguous, that is, when sorted all the rows are in order with no gaps. If the selection isn't contiguous, the selection is reset to contain the first set, when sorted, of contiguous rows.

        If the selection mode is SINGLE_TREE_SELECTION and more than one TreePath is selected, the selection is reset to contain the first path currently selected.

      • arePathsContiguous

        protected boolean arePathsContiguous(TreePath[] paths)
        Returns true if the paths are contiguous, or this object has no RowMapper.

      • canPathsBeAdded

        protected boolean canPathsBeAdded(TreePath[] paths)
        Used to test if a particular set of TreePaths can be added. This will return true if paths is null (or empty), or this object has no RowMapper, or nothing is currently selected, or the selection mode is DISCONTIGUOUS_TREE_SELECTION, or adding the paths to the current selection still results in a contiguous set of TreePaths.

      • canPathsBeRemoved

        protected boolean canPathsBeRemoved(TreePath[] paths)
        Returns true if the paths can be removed without breaking the continuity of the model. This is rather expensive.

      • notifyPathChange

        @Deprecated
protected void notifyPathChange(Vector changedPaths,
                               TreePath oldLeadSelection)
        Deprecated. As of JDK version 1.7
        Notifies listeners of a change in path. changePaths should contain instances of PathPlaceHolder.

      • updateLeadIndex

        protected void updateLeadIndex()
        Updates the leadIndex instance variable.

      • insureUniqueness

        protected void insureUniqueness()
        This method is obsolete and its implementation is now a noop. It's still called by setSelectionPaths and addSelectionPaths, but only for backwards compatability.

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object

      • clone

        public Object clone()
             throws CloneNotSupportedException
        Returns a clone of this object with the same selection. This method does not duplicate selection listeners and property listeners.
        重载：
        clone in class Object
        返回：
        a clone of this instance.
        抛出：
        CloneNotSupportedException - never thrown by instances of this class
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ExpandVetoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.tree

类 ExpandVetoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.swing.tree.ExpandVetoException
  • 所有已实现的接口：
    Serializable

    public class ExpandVetoException
extends Exception
    Exception used to stop and expand/collapse from happening. See How to Write a Tree-Will-Expand Listener in The Java Tutorial for further information and examples.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected TreeExpansionEvent event
      The event that the exception was created for.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ExpandVetoException(TreeExpansionEvent event)
      Constructs an ExpandVetoException object with no message.
      ExpandVetoException(TreeExpansionEvent event, String message)
      Constructs an ExpandVetoException object with the specified message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • event

        protected TreeExpansionEvent event
        The event that the exception was created for.

    • 构造方法详细信息

      • ExpandVetoException

        public ExpandVetoException(TreeExpansionEvent event)
        Constructs an ExpandVetoException object with no message.
        参数：
        event - a TreeExpansionEvent object

      • ExpandVetoException

        public ExpandVetoException(TreeExpansionEvent event,
                   String message)
        Constructs an ExpandVetoException object with the specified message.
        参数：
        event - a TreeExpansionEvent object
        message - a String containing the message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cTdo"el"ep==epp"c it"stnnd>


FixedHeightLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 FixedHeightLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
      • javax.swing.tree.FixedHeightLayoutCache
  • 所有已实现的接口：
    RowMapper

    public class FixedHeightLayoutCache
extends AbstractLayoutCache
    NOTE: This will become more open in a future release.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.tree.AbstractLayoutCache

        AbstractLayoutCache.NodeDimensions

    • 字段摘要

      • Fields inherited from class javax.swing.tree.AbstractLayoutCache

        nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel

    • 构造方法摘要

      Constructors
      构造方法与描述
      FixedHeightLayoutCache()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath getPathForRow(int row)
      Returns the path for passed in row.
      int getRowCount()
      Returns the number of visible rows.
      int getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void invalidatePathBounds(TreePath path)
      Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
      void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      boolean isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • 方法 - 继承于类 javax.swing.tree.AbstractLayoutCache

        getModel, getNodeDimensions, getNodeDimensions, getPreferredHeight, getPreferredWidth, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setNodeDimensions, setSelectionModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FixedHeightLayoutCache

        public FixedHeightLayoutCache()

    • 方法详细信息

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        重载：
        setModel in class AbstractLayoutCache
        参数：
        newModel - the TreeModel that is to provide the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        重载：
        setRootVisible in class AbstractLayoutCache
        参数：
        rootVisible - true if the root node of the tree is to be displayed
        另请参见：
        AbstractLayoutCache.rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If rowHeight is less than or equal to 0 this will throw an IllegalArgumentException.
        重载：
        setRowHeight in class AbstractLayoutCache
        参数：
        rowHeight - the height of each cell, in pixels

      • getRowCount

        public int getRowCount()
        Returns the number of visible rows.
        指定者：
        getRowCount in class AbstractLayoutCache
        返回：
        the number of rows being displayed

      • invalidatePathBounds

        public void invalidatePathBounds(TreePath path)
        Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
        指定者：
        invalidatePathBounds in class AbstractLayoutCache
        参数：
        path - the path being updated

      • invalidateSizes

        public void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.
        指定者：
        invalidateSizes in class AbstractLayoutCache

      • isExpanded

        public boolean isExpanded(TreePath path)
        Returns true if the value identified by row is currently expanded.
        指定者：
        isExpanded in class AbstractLayoutCache

      • getBounds

        public Rectangle getBounds(TreePath path,
                  Rectangle placeIn)
        Returns a rectangle giving the bounds needed to draw path.
        指定者：
        getBounds in class AbstractLayoutCache
        参数：
        path - a TreePath specifying a node
        placeIn - a Rectangle object giving the available space
        返回：
        a Rectangle object specifying the space to be used

      • getPathForRow

        public TreePath getPathForRow(int row)
        Returns the path for passed in row. If row is not visible null is returned.
        指定者：
        getPathForRow in class AbstractLayoutCache
        参数：
        row - the row being queried
        返回：
        the TreePath for the given row

      • getRowForPath

        public int getRowForPath(TreePath path)
        Returns the row that the last item identified in path is visible at. Will return -1 if any of the elements in path are not currently visible.
        指定者：
        getRowForPath in class AbstractLayoutCache
        参数：
        path - the TreePath being queried
        返回：
        the row where the last item in path is visible or -1 if any elements in path aren't currently visible

      • getPathClosestTo

        public TreePath getPathClosestTo(int x,
                        int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it'll always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        指定者：
        getPathClosestTo in class AbstractLayoutCache
        参数：
        x - the horizontal component of the desired location
        y - the vertical component of the desired location
        返回：
        the TreePath closest to the specified point

      • getVisibleChildCount

        public int getVisibleChildCount(TreePath path)
        Returns the number of visible children for row.
        指定者：
        getVisibleChildCount in class AbstractLayoutCache
        参数：
        path - the path being queried
        返回：
        the number of visible children for the specified path

      • getVisiblePathsFrom

        public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed.
        指定者：
        getVisiblePathsFrom in class AbstractLayoutCache
        参数：
        path - the starting location for the enumeration
        返回：
        the Enumerator starting at the desired location

      • setExpandedState

        public void setExpandedState(TreePath path,
                    boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        指定者：
        setExpandedState in class AbstractLayoutCache
        参数：
        path - the path being expanded or collapsed
        isExpanded - true if the path should be expanded, false otherwise

      • getExpandedState

        public boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        指定者：
        getExpandedState in class AbstractLayoutCache
        参数：
        path - the path being queried
        返回：
        true if the path is expanded and visible, false otherwise

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)

        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path() returns the path the parent of the changed node(s).

        e.childIndices() returns the index(es) of the changed node(s).

        指定者：
        treeNodesChanged in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)

        Invoked after nodes have been inserted into the tree.

        e.path() returns the parent of the new nodes

        e.childIndices() returns the indices of the new nodes in ascending order.

        指定者：
        treeNodesInserted in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)

        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path() returns the former parent of the deleted nodes.

        e.childIndices() returns the indices the nodes had before they were deleted in ascending order.

        指定者：
        treeNodesRemoved in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)

        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath() is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path() holds the path to the node.

        e.childIndices() returns null.

        指定者：
        treeStructureChanged in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tiast


javax.swing.tree

Interfaces

  • MutableTreeNode
  • RowMapper
  • TreeCellEditor
  • TreeCellRenderer
  • TreeModel
  • TreeNode
  • TreeSelectionModel

Classes

  • AbstractLayoutCache
  • AbstractLayoutCache.NodeDimensions
  • DefaultMutableTreeNode
  • DefaultTreeCellEditor
  • DefaultTreeCellRenderer
  • DefaultTreeModel
  • DefaultTreeSelectionModel
  • FixedHeightLayoutCache
  • TreePath
  • VariableHeightLayoutCache

Exceptions

  • ExpandVetoException
i


javax.swing.tree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.tree

Provides classes and interfaces for dealing with javax.swing.JTree.

请参见： 描述

  • 接口摘要
    接口 描述
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Class Summary
    类 描述
    AbstractLayoutCache
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeCellEditor
    A TreeCellEditor.
    DefaultTreeCellRenderer
    Displays an entry in a tree.
    DefaultTreeModel
    A simple tree data model that uses TreeNodes.
    DefaultTreeSelectionModel
    Default implementation of TreeSelectionModel.
    FixedHeightLayoutCache
    NOTE: This will become more open in a future release.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    VariableHeightLayoutCache
    NOTE: This will become more open in a future release.
  • Exception Summary
    Exception 描述
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.

软件包 javax.swing.tree Description

Provides classes and interfaces for dealing with javax.swing.JTree. You use these classes and interfaces if you want control over how trees are constructed, updated, and rendered, as well as how data associated with the tree nodes are viewed and managed.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • How to Use Trees, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yf:S>ysyr&>ll&<< /"lt /v


javax.swing.tree Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.tree

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.tree.ExpandVetoException
    • javax.swing.tree.TreePath (implements java.io.Serializable)

Interface Hierarchy

  • javax.swing.CellEditor
    • javax.swing.tree.TreeCellEditor
  • javax.swing.tree.RowMapper
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cioroj.eo7oi.77rrl m


MutableTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface MutableTreeNode

  • All Superinterfaces:
    TreeNode
    All Known Implementing Classes:
    DefaultMutableTreeNode, JTree.DynamicUtilTreeNode

    public interface MutableTreeNode
extends TreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    另请参见：
    DefaultMutableTreeNode, JTree

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void insert(MutableTreeNode child, int index)
      Adds child to the receiver at index.
      void remove(int index)
      Removes the child at index from the receiver.
      void remove(MutableTreeNode node)
      Removes node from the receiver.
      void removeFromParent()
      Removes the receiver from its parent.
      void setParent(MutableTreeNode newParent)
      Sets the parent of the receiver to newParent.
      void setUserObject(Object object)
      Resets the user object of the receiver to object.

      • 方法 - 继承于接口 javax.swing.tree.TreeNode

        children, getAllowsChildren, getChildAt, getChildCount, getIndex, getParent, isLeaf

    • 方法详细信息

      • insert

        void insert(MutableTreeNode child,
          int index)
        Adds child to the receiver at index. child will be messaged with setParent.

      • remove

        void remove(int index)
        Removes the child at index from the receiver.

      • remove

        void remove(MutableTreeNode node)
        Removes node from the receiver. setParent will be messaged on node.

      • setUserObject

        void setUserObject(Object object)
        Resets the user object of the receiver to object.

      • removeFromParent

        void removeFromParent()
        Removes the receiver from its parent.

      • setParent

        void setParent(MutableTreeNode newParent)
        Sets the parent of the receiver to newParent.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lc tfiifi ddi v RRssia"ar;/nne


RowMapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface RowMapper

  • All Known Implementing Classes:
    AbstractLayoutCache, FixedHeightLayoutCache, VariableHeightLayoutCache

    public interface RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int[] getRowsForPaths(TreePath[] path)
      Returns the rows that the TreePath instances in path are being displayed at.

    • 方法详细信息

      • getRowsForPaths

        int[] getRowsForPaths(TreePath[] path)
        Returns the rows that the TreePath instances in path are being displayed at. The receiver should return an array of the same length as that passed in, and if one of the TreePaths in path is not valid its entry in the array should be set to -1.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t>"c > c>i i< ao>>erarrces"of


TreeCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface TreeCellEditor

  • All Superinterfaces:
    CellEditor
    All Known Implementing Classes:
    DefaultCellEditor, DefaultTreeCellEditor

    public interface TreeCellEditor
extends CellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    另请参见：
    JTree

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
      Sets an initial value for the editor.

      • 方法 - 继承于接口 javax.swing.CellEditor

        addCellEditorListener, cancelCellEditing, getCellEditorValue, isCellEditable, removeCellEditorListener, shouldSelectCell, stopCellEditing

    • 方法详细信息

      • getTreeCellEditorComponent

        Component getTreeCellEditorComponent(JTree tree,
                                   Object value,
                                   boolean isSelected,
                                   boolean expanded,
                                   boolean leaf,
                                   int row)
        Sets an initial value for the editor. This will cause the editor to stopEditing and lose any partially edited value if the editor is editing when this method is called.

        Returns the component that should be added to the client's Component hierarchy. Once installed in the client's hierarchy this component will then be able to draw and receive user input.

        参数：
        tree - the JTree that is asking the editor to edit; this parameter can be null
        value - the value of the cell to be edited
        isSelected - true if the cell is to be rendered with selection highlighting
        expanded - true if the node is expanded
        leaf - true if the node is a leaf node
        row - the row index of the node being edited
        返回：
        the component for editing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Uih/)/{


TreeCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface TreeCellRenderer

  • All Known Implementing Classes:
    DefaultTreeCellRenderer

    public interface TreeCellRenderer
    Defines the requirements for an object that displays a tree node. See How to Use Trees in The Java Tutorial for an example of implementing a tree cell renderer that displays custom icons.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Component getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
      Sets the value of the current tree cell to value.

    • 方法详细信息

      • getTreeCellRendererComponent

        Component getTreeCellRendererComponent(JTree tree,
                                     Object value,
                                     boolean selected,
                                     boolean expanded,
                                     boolean leaf,
                                     int row,
                                     boolean hasFocus)
        Sets the value of the current tree cell to value. If selected is true, the cell will be drawn as if selected. If expanded is true the node is currently expanded and if leaf is true the node represents a leaf and if hasFocus is true the node currently has focus. tree is the JTree the receiver is being configured for. Returns the Component that the renderer uses to draw the value.

        The TreeCellRenderer is also responsible for rendering the the cell representing the tree's current DnD drop location if it has one. If this renderer cares about rendering the DnD drop location, it should query the tree directly to see if the given row represents the drop location:

             JTree.DropLocation dropLocation = tree.getDropLocation();
     if (dropLocation != null
             && dropLocation.getChildIndex() == -1
             && tree.getRowForPath(dropLocation.getPath()) == row) {

         // this row represents the current drop location
         // so render it specially, perhaps with a different color
     }
        返回：
        the Component that the renderer uses to draw the value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&lnee:eDal:&sllbb

mi


TreeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface TreeModel

  • All Known Implementing Classes:
    DefaultTreeModel

    public interface TreeModel
    The model used by JTree.

    JTree and its related classes make extensive use of TreePaths for indentifying nodes in the TreeModel. If a TreeModel returns the same object, as compared by equals, at two different indices under the same parent than the resulting TreePath objects will be considered equal as well. Some implementations may assume that if two TreePaths are equal, they identify the same node. If this condition is not met, painting problems and other oddities may result. In other words, if getChild for a given parent returns the same Object (as determined by equals) problems may result, and it is recommended you avoid doing this.

    Similarly JTree and its related classes place TreePaths in Maps. As such if a node is requested twice, the return values must be equal (using the equals method) and have the same hashCode.

    For further information on tree models, including an example of a custom implementation, see How to Use Trees in The Java Tutorial.

    另请参见：
    TreePath

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addTreeModelListener(TreeModelListener l)
      Adds a listener for the TreeModelEvent posted after the tree changes.
      Object getChild(Object parent, int index)
      Returns the child of parent at index index in the parent's child array.
      int getChildCount(Object parent)
      Returns the number of children of parent.
      int getIndexOfChild(Object parent, Object child)
      Returns the index of child in parent.
      Object getRoot()
      Returns the root of the tree.
      boolean isLeaf(Object node)
      Returns true if node is a leaf.
      void removeTreeModelListener(TreeModelListener l)
      Removes a listener previously added with addTreeModelListener.
      void valueForPathChanged(TreePath path, Object newValue)
      Messaged when the user has altered the value for the item identified by path to newValue.

    • 方法详细信息

      • getRoot

        Object getRoot()
        Returns the root of the tree. Returns null only if the tree has no nodes.
        返回：
        the root of the tree

      • getChild

        Object getChild(Object parent,
              int index)
        Returns the child of parent at index index in the parent's child array. parent must be a node previously obtained from this data source. This should not return null if index is a valid index for parent (that is index >= 0 && index < getChildCount(parent)).
        参数：
        parent - a node in the tree, obtained from this data source
        返回：
        the child of parent at index index

      • getChildCount

        int getChildCount(Object parent)
        Returns the number of children of parent. Returns 0 if the node is a leaf or if it has no children. parent must be a node previously obtained from this data source.
        参数：
        parent - a node in the tree, obtained from this data source
        返回：
        the number of children of the node parent

      • isLeaf

        boolean isLeaf(Object node)
        Returns true if node is a leaf. It is possible for this method to return false even if node has no children. A directory in a filesystem, for example, may contain no files; the node representing the directory is not a leaf, but it also has no children.
        参数：
        node - a node in the tree, obtained from this data source
        返回：
        true if node is a leaf

      • valueForPathChanged

        void valueForPathChanged(TreePath path,
                       Object newValue)
        Messaged when the user has altered the value for the item identified by path to newValue. If newValue signifies a truly new value the model should post a treeNodesChanged event.
        参数：
        path - path to the node that the user has altered
        newValue - the new value from the TreeCellEditor

      • getIndexOfChild

        int getIndexOfChild(Object parent,
                  Object child)
        Returns the index of child in parent. If either parent or child is null, returns -1. If either parent or child don't belong to this tree model, returns -1.
        参数：
        parent - a node in the tree, obtained from this data source
        child - the node we are interested in
        返回：
        the index of the child in the parent, or -1 if either child or parent are null or don't belong to this tree model

      • addTreeModelListener

        void addTreeModelListener(TreeModelListener l)
        Adds a listener for the TreeModelEvent posted after the tree changes.
        参数：
        l - the listener to add
        另请参见：
        removeTreeModelListener(javax.swing.event.TreeModelListener)

      • removeTreeModelListener

        void removeTreeModelListener(TreeModelListener l)
        Removes a listener previously added with addTreeModelListener.
        参数：
        l - the listener to remove
        另请参见：
        addTreeModelListener(javax.swing.event.TreeModelListener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>jnr ndrnigsr -c cedeacb鑣.i


TreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface TreeNode

  • All Known Subinterfaces:
    MutableTreeNode
    All Known Implementing Classes:
    AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultMutableTreeNode, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, JTree.DynamicUtilTreeNode

    public interface TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.

    Implementations of TreeNode that override equals will typically need to override hashCode as well. Refer to TreeModel for more information. For further information and examples of using tree nodes, see How to Use Tree Nodes in The Java Tutorial.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Enumeration children()
      Returns the children of the receiver as an Enumeration.
      boolean getAllowsChildren()
      Returns true if the receiver allows children.
      TreeNode getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      int getChildCount()
      Returns the number of children TreeNodes the receiver contains.
      int getIndex(TreeNode node)
      Returns the index of node in the receivers children.
      TreeNode getParent()
      Returns the parent TreeNode of the receiver.
      boolean isLeaf()
      Returns true if the receiver is a leaf.

    • 方法详细信息

      • getChildAt

        TreeNode getChildAt(int childIndex)
        Returns the child TreeNode at index childIndex.

      • getChildCount

        int getChildCount()
        Returns the number of children TreeNodes the receiver contains.

      • getParent

        TreeNode getParent()
        Returns the parent TreeNode of the receiver.

      • getIndex

        int getIndex(TreeNode node)
        Returns the index of node in the receivers children. If the receiver does not contain node, -1 will be returned.

      • getAllowsChildren

        boolean getAllowsChildren()
        Returns true if the receiver allows children.

      • isLeaf

        boolean isLeaf()
        Returns true if the receiver is a leaf.

      • children

        Enumeration children()
        Returns the children of the receiver as an Enumeration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h iensibsi>nni>> iggec.ejet-jst


TreePath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 TreePath

  • java.lang.Object
    • javax.swing.tree.TreePath
  • 所有已实现的接口：
    Serializable

    public class TreePath
extends Object
implements Serializable
    TreePath represents an array of objects that uniquely identify the path to a node in a tree. The elements of the array are ordered with the root as the first element of the array. For example, a file on the file system is uniquely identified based on the array of parent directories and the name of the file. The path /tmp/foo/bar could be represented by a TreePath as new TreePath(new Object[] {"tmp", "foo", "bar"}).

    TreePath is used extensively by JTree and related classes. For example, JTree represents the selection as an array of TreePaths. When used with JTree, the elements of the path are the objects returned from the TreeModel. When JTree is paired with DefaultTreeModel, the elements of the path are TreeNodes. The following example illustrates extracting the user object from the selection of a JTree:

       DefaultMutableTreeNode root = ...;
   DefaultTreeModel model = new DefaultTreeModel(root);
   JTree tree = new JTree(model);
   ...
   TreePath selectedPath = tree.getSelectionPath();
   DefaultMutableTreeNode selectedNode =
       ((DefaultMutableTreeNode)selectedPath.getLastPathComponent()).
       getUserObject();
    Subclasses typically need override only getLastPathComponent, and getParentPath. As JTree internally creates TreePaths at various points, it's generally not useful to subclass TreePath and use with JTree.

    While TreePath is serializable, a NotSerializableException is thrown if any elements of the path are not serializable.

    For further information and examples of using tree paths, see How to Use Trees in The Java Tutorial.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TreePath()
      Creates an empty TreePath.
        TreePath(Object lastPathComponent)
      Creates a TreePath containing a single element.
        TreePath(Object[] path)
      Creates a TreePath from an array.
      protected TreePath(Object[] path, int length)
      Creates a TreePath from an array.
      protected TreePath(TreePath parent, Object lastPathComponent)
      Creates a TreePath with the specified parent and element.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object o)
      Compares this TreePath to the specified object.
      Object getLastPathComponent()
      Returns the last element of this path.
      TreePath getParentPath()
      Returns the TreePath of the parent.
      Object[] getPath()
      Returns an ordered array of the elements of this TreePath.
      Object getPathComponent(int index)
      Returns the path element at the specified index.
      int getPathCount()
      Returns the number of elements in the path.
      int hashCode()
      Returns the hash code of this TreePath.
      boolean isDescendant(TreePath aTreePath)
      Returns true if aTreePath is a descendant of this TreePath.
      TreePath pathByAddingChild(Object child)
      Returns a new path containing all the elements of this path plus child.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TreePath

        @ConstructorProperties(value="path")
public TreePath(Object[] path)
        Creates a TreePath from an array. The array uniquely identifies the path to a node.
        参数：
        path - an array of objects representing the path to a node
        抛出：
        IllegalArgumentException - if path is null, empty, or contains a null value

      • TreePath

        public TreePath(Object lastPathComponent)
        Creates a TreePath containing a single element. This is used to construct a TreePath identifying the root.
        参数：
        lastPathComponent - the root
        抛出：
        IllegalArgumentException - if lastPathComponent is null
        另请参见：
        TreePath(Object[])

      • TreePath

        protected TreePath(TreePath parent,
        Object lastPathComponent)
        Creates a TreePath with the specified parent and element.
        参数：
        parent - the path to the parent, or null to indicate the root
        lastPathComponent - the last path element
        抛出：
        IllegalArgumentException - if lastPathComponent is null

      • TreePath

        protected TreePath(Object[] path,
        int length)
        Creates a TreePath from an array. The returned TreePath represents the elements of the array from 0 to length - 1.

        This constructor is used internally, and generally not useful outside of subclasses.

        参数：
        path - the array to create the TreePath from
        length - identifies the number of elements in path to create the TreePath from
        抛出：
        NullPointerException - if path is null
        ArrayIndexOutOfBoundsException - if length - 1 is outside the range of the array
        IllegalArgumentException - if any of the elements from 0 to length - 1 are null

      • TreePath

        protected TreePath()
        Creates an empty TreePath. This is provided for subclasses that represent paths in a different manner. Subclasses that use this constructor must override getLastPathComponent, and getParentPath.

    • 方法详细信息

      • getPath

        public Object[] getPath()
        Returns an ordered array of the elements of this TreePath. The first element is the root.
        返回：
        an array of the elements in this TreePath

      • getLastPathComponent

        public Object getLastPathComponent()
        Returns the last element of this path.
        返回：
        the last element in the path

      • getPathCount

        public int getPathCount()
        Returns the number of elements in the path.
        返回：
        the number of elements in the path

      • getPathComponent

        public Object getPathComponent(int index)
        Returns the path element at the specified index.
        参数：
        index - the index of the element requested
        返回：
        the element at the specified index
        抛出：
        IllegalArgumentException - if the index is outside the range of this path

      • equals

        public boolean equals(Object o)
        Compares this TreePath to the specified object. This returns true if o is a TreePath with the exact same elements (as determined by using equals on each element of the path).
        重载：
        equals in class Object
        参数：
        o - the object to compare
        返回：
        true if this object is the same as the obj argument; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns the hash code of this TreePath. The hash code of a TreePath is the hash code of the last element in the path.
        重载：
        hashCode in class Object
        返回：
        the hashCode for the object
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • isDescendant

        public boolean isDescendant(TreePath aTreePath)
        Returns true if aTreePath is a descendant of this TreePath. A TreePath P1 is a descendant of a TreePath P2 if P1 contains all of the elements that make up P2's path. For example, if this object has the path [a, b], and aTreePath has the path [a, b, c], then aTreePath is a descendant of this object. However, if aTreePath has the path [a], then it is not a descendant of this object. By this definition a TreePath is always considered a descendant of itself. That is, aTreePath.isDescendant(aTreePath) returns true.
        参数：
        aTreePath - the TreePath to check
        返回：
        true if aTreePath is a descendant of this path

      • pathByAddingChild

        public TreePath pathByAddingChild(Object child)
        Returns a new path containing all the elements of this path plus child. child is the last element of the newly created TreePath.
        参数：
        child - the path element to add
        抛出：
        NullPointerException - if child is null

      • getParentPath

        public TreePath getParentPath()
        Returns the TreePath of the parent. A return value of null indicates this is the root node.
        返回：
        the parent path

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

emtCpnn<%i/pl鰕.烫╝ai絅= i i>olw


TreeSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.tree

Interface TreeSelectionModel

  • All Known Implementing Classes:
    DefaultTreeSelectionModel, JTree.EmptySelectionModel

    public interface TreeSelectionModel
    This interface represents the current state of the selection for the tree component. For information and examples of using tree selection models, see How to Use Trees in The Java Tutorial.

    The state of the tree selection is characterized by a set of TreePaths, and optionally a set of integers. The mapping from TreePath to integer is done by way of an instance of RowMapper. It is not necessary for a TreeSelectionModel to have a RowMapper to correctly operate, but without a RowMapper getSelectionRows will return null.

    A TreeSelectionModel can be configured to allow only one path (SINGLE_TREE_SELECTION) a number of continguous paths (CONTIGUOUS_TREE_SELECTION) or a number of discontiguous paths (DISCONTIGUOUS_TREE_SELECTION). A RowMapper is used to determine if TreePaths are contiguous. In the absence of a RowMapper CONTIGUOUS_TREE_SELECTION and DISCONTIGUOUS_TREE_SELECTION behave the same, that is they allow any number of paths to be contained in the TreeSelectionModel.

    For a selection model of CONTIGUOUS_TREE_SELECTION any time the paths are changed (setSelectionPath, addSelectionPath ...) the TreePaths are again checked to make they are contiguous. A check of the TreePaths can also be forced by invoking resetRowSelection. How a set of discontiguous TreePaths is mapped to a contiguous set is left to implementors of this interface to enforce a particular policy.

    Implementations should combine duplicate TreePaths that are added to the selection. For example, the following code

       TreePath[] paths = new TreePath[] { treePath, treePath };
   treeSelectionModel.setSelectionPaths(paths);
    should result in only one path being selected: treePath, and not two copies of treePath.

    The lead TreePath is the last path that was added (or set). The lead row is then the row that corresponds to the TreePath as determined from the RowMapper.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int CONTIGUOUS_TREE_SELECTION
      Selection can only be contiguous.
      static int DISCONTIGUOUS_TREE_SELECTION
      Selection can contain any number of items that are not necessarily contiguous.
      static int SINGLE_TREE_SELECTION
      Selection can only contain one path at a time.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPropertyChangeListener(PropertyChangeListener listener)
      Adds a PropertyChangeListener to the listener list.
      void addSelectionPath(TreePath path)
      Adds path to the current selection.
      void addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void addTreeSelectionListener(TreeSelectionListener x)
      Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
      void clearSelection()
      Empties the current selection.
      TreePath getLeadSelectionPath()
      Returns the last path that was added.
      int getLeadSelectionRow()
      Returns the lead selection index.
      int getMaxSelectionRow()
      Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.
      int getMinSelectionRow()
      Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.
      RowMapper getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      int getSelectionCount()
      Returns the number of paths that are selected.
      int getSelectionMode()
      Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      TreePath getSelectionPath()
      Returns the first path in the selection.
      TreePath[] getSelectionPaths()
      Returns the paths in the selection.
      int[] getSelectionRows()
      Returns all of the currently selected rows.
      boolean isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean isRowSelected(int row)
      Returns true if the row identified by row is selected.
      boolean isSelectionEmpty()
      Returns true if the selection is currently empty.
      void removePropertyChangeListener(PropertyChangeListener listener)
      Removes a PropertyChangeListener from the listener list.
      void removeSelectionPath(TreePath path)
      Removes path from the selection.
      void removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void removeTreeSelectionListener(TreeSelectionListener x)
      Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
      void resetRowSelection()
      Updates this object's mapping from TreePaths to rows.
      void setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void setSelectionMode(int mode)
      Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.
      void setSelectionPath(TreePath path)
      Sets the selection to path.
      void setSelectionPaths(TreePath[] paths)
      Sets the selection to path.

    • 字段详细信息

      • SINGLE_TREE_SELECTION

        static final int SINGLE_TREE_SELECTION
        Selection can only contain one path at a time.
        另请参见：
        Constant Field Values

      • CONTIGUOUS_TREE_SELECTION

        static final int CONTIGUOUS_TREE_SELECTION
        Selection can only be contiguous. This will only be enforced if a RowMapper instance is provided. That is, if no RowMapper is set this behaves the same as DISCONTIGUOUS_TREE_SELECTION.
        另请参见：
        Constant Field Values

      • DISCONTIGUOUS_TREE_SELECTION

        static final int DISCONTIGUOUS_TREE_SELECTION
        Selection can contain any number of items that are not necessarily contiguous.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • setSelectionMode

        void setSelectionMode(int mode)
        Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

        This may change the selection if the current selection is not valid for the new mode. For example, if three TreePaths are selected when the mode is changed to SINGLE_TREE_SELECTION, only one TreePath will remain selected. It is up to the particular implementation to decide what TreePath remains selected.

      • getSelectionMode

        int getSelectionMode()
        Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

      • setSelectionPath

        void setSelectionPath(TreePath path)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If path is null, this has the same effect as invoking clearSelection.
        参数：
        path - new path to select

      • setSelectionPaths

        void setSelectionPaths(TreePath[] paths)
        Sets the selection to path. If this represents a change, then the TreeSelectionListeners are notified. If paths is null, this has the same effect as invoking clearSelection.
        参数：
        paths - new selection

      • addSelectionPath

        void addSelectionPath(TreePath path)
        Adds path to the current selection. If path is not currently in the selection the TreeSelectionListeners are notified. This has no effect if path is null.
        参数：
        path - the new path to add to the current selection

      • addSelectionPaths

        void addSelectionPaths(TreePath[] paths)
        Adds paths to the current selection. If any of the paths in paths are not currently in the selection the TreeSelectionListeners are notified. This has no effect if paths is null.
        参数：
        paths - the new paths to add to the current selection

      • removeSelectionPath

        void removeSelectionPath(TreePath path)
        Removes path from the selection. If path is in the selection The TreeSelectionListeners are notified. This has no effect if path is null.
        参数：
        path - the path to remove from the selection

      • removeSelectionPaths

        void removeSelectionPaths(TreePath[] paths)
        Removes paths from the selection. If any of the paths in paths are in the selection, the TreeSelectionListeners are notified. This method has no effect if paths is null.
        参数：
        paths - the path to remove from the selection

      • getSelectionPath

        TreePath getSelectionPath()
        Returns the first path in the selection. How first is defined is up to implementors, and may not necessarily be the TreePath with the smallest integer value as determined from the RowMapper.

      • getSelectionPaths

        TreePath[] getSelectionPaths()
        Returns the paths in the selection. This will return null (or an empty array) if nothing is currently selected.

      • getSelectionCount

        int getSelectionCount()
        Returns the number of paths that are selected.

      • isPathSelected

        boolean isPathSelected(TreePath path)
        Returns true if the path, path, is in the current selection.

      • isSelectionEmpty

        boolean isSelectionEmpty()
        Returns true if the selection is currently empty.

      • clearSelection

        void clearSelection()
        Empties the current selection. If this represents a change in the current selection, the selection listeners are notified.

      • setRowMapper

        void setRowMapper(RowMapper newMapper)
        Sets the RowMapper instance. This instance is used to determine the row for a particular TreePath.

      • getRowMapper

        RowMapper getRowMapper()
        Returns the RowMapper instance that is able to map a TreePath to a row.

      • getSelectionRows

        int[] getSelectionRows()
        Returns all of the currently selected rows. This will return null (or an empty array) if there are no selected TreePaths or a RowMapper has not been set.

      • getMinSelectionRow

        int getMinSelectionRow()
        Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.

      • getMaxSelectionRow

        int getMaxSelectionRow()
        Returns the largest value obtained from the RowMapper for the current set of selected TreePaths. If nothing is selected, or there is no RowMapper, this will return -1.

      • isRowSelected

        boolean isRowSelected(int row)
        Returns true if the row identified by row is selected.

      • resetRowSelection

        void resetRowSelection()
        Updates this object's mapping from TreePaths to rows. This should be invoked when the mapping from TreePaths to integers has changed (for example, a node has been expanded).

        You do not normally have to call this; JTree and its associated listeners will invoke this for you. If you are implementing your own view class, then you will have to invoke this.

      • getLeadSelectionRow

        int getLeadSelectionRow()
        Returns the lead selection index. That is the last index that was added.

      • getLeadSelectionPath

        TreePath getLeadSelectionPath()
        Returns the last path that was added. This may differ from the leadSelectionPath property maintained by the JTree.

      • addPropertyChangeListener

        void addPropertyChangeListener(PropertyChangeListener listener)
        Adds a PropertyChangeListener to the listener list. The listener is registered for all properties.

        A PropertyChangeEvent will get fired when the selection mode changes.

        参数：
        listener - the PropertyChangeListener to be added

      • removePropertyChangeListener

        void removePropertyChangeListener(PropertyChangeListener listener)
        Removes a PropertyChangeListener from the listener list. This removes a PropertyChangeListener that was registered for all properties.
        参数：
        listener - the PropertyChangeListener to be removed

      • addTreeSelectionListener

        void addTreeSelectionListener(TreeSelectionListener x)
        Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
        参数：
        x - the new listener to be added

      • removeTreeSelectionListener

        void removeTreeSelectionListener(TreeSelectionListener x)
        Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
        参数：
        x - the listener to remove
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Uses of Package javax.swing.tree

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.tree

  • Packages that use javax.swing.tree
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.
  • Classes in javax.swing.tree used by javax.swing
    类与描述
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeSelectionModel
    Default implementation of TreeSelectionModel.
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Classes in javax.swing.tree used by javax.swing.event
    类与描述
    ExpandVetoException
    Exception used to stop and expand/collapse from happening.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf
    类与描述
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.basic
    类与描述
    AbstractLayoutCache
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • Classes in javax.swing.tree used by javax.swing.plaf.metal
    类与描述
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.multi
    类与描述
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.plaf.synth
    类与描述
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
  • Classes in javax.swing.tree used by javax.swing.text
    类与描述
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
  • Classes in javax.swing.tree used by javax.swing.text.html
    类与描述
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
  • Classes in javax.swing.tree used by javax.swing.tree
    类与描述
    AbstractLayoutCache
    警告： Serialized objects of this class will not be compatible with future Swing releases.
    AbstractLayoutCache.NodeDimensions
    Used by AbstractLayoutCache to determine the size and x origin of a particular node.
    DefaultMutableTreeNode
    A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
    DefaultTreeCellRenderer
    Displays an entry in a tree.
    MutableTreeNode
    Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
    RowMapper
    Defines the requirements for an object that translates paths in the tree into display rows.
    TreeCellEditor
    Adds to CellEditor the extensions necessary to configure an editor in a tree.
    TreeCellRenderer
    Defines the requirements for an object that displays a tree node.
    TreeModel
    The model used by JTree.
    TreeNode
    Defines the requirements for an object that can be used as a tree node in a JTree.
    TreePath
    TreePath represents an array of objects that uniquely identify the path to a node in a tree.
    TreeSelectionModel
    This interface represents the current state of the selection for the tree component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mp 1enpcpv"iS


VariableHeightLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.tree

类 VariableHeightLayoutCache

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
  • 所有已实现的接口：
    RowMapper

    public class VariableHeightLayoutCache
extends AbstractLayoutCache
    NOTE: This will become more open in a future release.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 嵌套类摘要

      • Nested classes/interfaces inherited from class javax.swing.tree.AbstractLayoutCache

        AbstractLayoutCache.NodeDimensions

    • 字段摘要

      • Fields inherited from class javax.swing.tree.AbstractLayoutCache

        nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel

    • 构造方法摘要

      Constructors
      构造方法与描述
      VariableHeightLayoutCache()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Rectangle getBounds(TreePath path, Rectangle placeIn)
      Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
      boolean getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      TreePath getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath getPathForRow(int row)
      Returns the path for row.
      int getPreferredHeight()
      Returns the preferred height.
      int getPreferredWidth(Rectangle bounds)
      Returns the preferred width and height for the region in visibleRegion.
      int getRowCount()
      Returns the number of visible rows.
      int getRowForPath(TreePath path)
      Returns the row where the last item identified in path is visible.
      int getVisibleChildCount(TreePath path)
      Returns the number of visible children for path.
      Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      void invalidateSizes()
      Informs the TreeState that it needs to recalculate all the sizes it is referencing.
      boolean isExpanded(TreePath path)
      Returns true if the value identified by path is currently expanded.
      void setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree.
      void setRootVisible(boolean rootVisible)
      Determines whether or not the root node from the TreeModel is visible.
      void setRowHeight(int rowHeight)
      Sets the height of each cell.
      void treeNodesChanged(TreeModelEvent e)
      Invoked after a node (or a set of siblings) has changed in some way.
      void treeNodesInserted(TreeModelEvent e)
      Invoked after nodes have been inserted into the tree.
      void treeNodesRemoved(TreeModelEvent e)
      Invoked after nodes have been removed from the tree.
      void treeStructureChanged(TreeModelEvent e)
      Invoked after the tree has drastically changed structure from a given node down.

      • 方法 - 继承于类 javax.swing.tree.AbstractLayoutCache

        getModel, getNodeDimensions, getNodeDimensions, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setSelectionModel

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VariableHeightLayoutCache

        public VariableHeightLayoutCache()

    • 方法详细信息

      • setModel

        public void setModel(TreeModel newModel)
        Sets the TreeModel that will provide the data.
        重载：
        setModel in class AbstractLayoutCache
        参数：
        newModel - the TreeModel that is to provide the data

      • setRootVisible

        public void setRootVisible(boolean rootVisible)
        Determines whether or not the root node from the TreeModel is visible.
        重载：
        setRootVisible in class AbstractLayoutCache
        参数：
        rootVisible - true if the root node of the tree is to be displayed
        另请参见：
        AbstractLayoutCache.rootVisible

      • setRowHeight

        public void setRowHeight(int rowHeight)
        Sets the height of each cell. If the specified value is less than or equal to zero the current cell renderer is queried for each row's height.
        重载：
        setRowHeight in class AbstractLayoutCache
        参数：
        rowHeight - the height of each cell, in pixels

      • setNodeDimensions

        public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
        Sets the renderer that is responsible for drawing nodes in the tree.
        重载：
        setNodeDimensions in class AbstractLayoutCache
        参数：
        nd - the renderer

      • setExpandedState

        public void setExpandedState(TreePath path,
                    boolean isExpanded)
        Marks the path path expanded state to isExpanded.
        指定者：
        setExpandedState in class AbstractLayoutCache
        参数：
        path - the TreePath of interest
        isExpanded - true if the path should be expanded, otherwise false

      • getExpandedState

        public boolean getExpandedState(TreePath path)
        Returns true if the path is expanded, and visible.
        指定者：
        getExpandedState in class AbstractLayoutCache
        参数：
        path - the path being queried
        返回：
        true if the path is expanded and visible, otherwise false

      • getBounds

        public Rectangle getBounds(TreePath path,
                  Rectangle placeIn)
        Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
        指定者：
        getBounds in class AbstractLayoutCache
        参数：
        path - the path to be drawn
        placeIn - the bounds of the enclosing rectangle
        返回：
        the bounds of the enclosing rectangle or null if the node could not be ascertained

      • getPathForRow

        public TreePath getPathForRow(int row)
        Returns the path for row. If row is not visible, null is returned.
        指定者：
        getPathForRow in class AbstractLayoutCache
        参数：
        row - the location of interest
        返回：
        the path for row, or null if row is not visible

      • getRowForPath

        public int getRowForPath(TreePath path)
        Returns the row where the last item identified in path is visible. Will return -1 if any of the elements in path are not currently visible.
        指定者：
        getRowForPath in class AbstractLayoutCache
        参数：
        path - the TreePath of interest
        返回：
        the row where the last item in path is visible

      • getRowCount

        public int getRowCount()
        Returns the number of visible rows.
        指定者：
        getRowCount in class AbstractLayoutCache
        返回：
        the number of visible rows

      • invalidatePathBounds

        public void invalidatePathBounds(TreePath path)
        Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
        指定者：
        invalidatePathBounds in class AbstractLayoutCache
        参数：
        path - the TreePath which is now invalid

      • getPreferredHeight

        public int getPreferredHeight()
        Returns the preferred height.
        重载：
        getPreferredHeight in class AbstractLayoutCache
        返回：
        the preferred height

      • getPreferredWidth

        public int getPreferredWidth(Rectangle bounds)
        Returns the preferred width and height for the region in visibleRegion.
        重载：
        getPreferredWidth in class AbstractLayoutCache
        参数：
        bounds - the region being queried
        返回：
        the preferred width for the passed in region

      • getPathClosestTo

        public TreePath getPathClosestTo(int x,
                        int y)
        Returns the path to the node that is closest to x,y. If there is nothing currently visible this will return null, otherwise it will always return a valid path. If you need to test if the returned object is exactly at x, y you should get the bounds for the returned path and test x, y against that.
        指定者：
        getPathClosestTo in class AbstractLayoutCache
        参数：
        x - the x-coordinate
        y - the y-coordinate
        返回：
        the path to the node that is closest to x, y

      • getVisiblePathsFrom

        public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
        Returns an Enumerator that increments over the visible paths starting at the passed in location. The ordering of the enumeration is based on how the paths are displayed.
        指定者：
        getVisiblePathsFrom in class AbstractLayoutCache
        参数：
        path - the location in the TreePath to start
        返回：
        an Enumerator that increments over the visible paths

      • getVisibleChildCount

        public int getVisibleChildCount(TreePath path)
        Returns the number of visible children for path.
        指定者：
        getVisibleChildCount in class AbstractLayoutCache
        参数：
        path - the path being queried
        返回：
        the number of visible children for path

      • invalidateSizes

        public void invalidateSizes()
        Informs the TreeState that it needs to recalculate all the sizes it is referencing.
        指定者：
        invalidateSizes in class AbstractLayoutCache

      • isExpanded

        public boolean isExpanded(TreePath path)
        Returns true if the value identified by path is currently expanded.
        指定者：
        isExpanded in class AbstractLayoutCache
        返回：
        true if the value identified by path is currently expanded

      • treeNodesChanged

        public void treeNodesChanged(TreeModelEvent e)
        Invoked after a node (or a set of siblings) has changed in some way. The node(s) have not changed locations in the tree or altered their children arrays, but other attributes have changed and may affect presentation. Example: the name of a file has changed, but it is in the same location in the file system.

        e.path returns the path the parent of the changed node(s).

        e.childIndices returns the index(es) of the changed node(s).

        指定者：
        treeNodesChanged in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent of interest

      • treeNodesInserted

        public void treeNodesInserted(TreeModelEvent e)
        Invoked after nodes have been inserted into the tree.

        e.path returns the parent of the new nodes.

        e.childIndices returns the indices of the new nodes in ascending order.

        指定者：
        treeNodesInserted in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent of interest

      • treeNodesRemoved

        public void treeNodesRemoved(TreeModelEvent e)
        Invoked after nodes have been removed from the tree. Note that if a subtree is removed from the tree, this method may only be invoked once for the root of the removed subtree, not once for each individual set of siblings removed.

        e.path returns the former parent of the deleted nodes.

        e.childIndices returns the indices the nodes had before they were deleted in ascending order.

        指定者：
        treeNodesRemoved in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent of interest

      • treeStructureChanged

        public void treeStructureChanged(TreeModelEvent e)
        Invoked after the tree has drastically changed structure from a given node down. If the path returned by e.getPath is of length one and the first element does not identify the current root node the first element should become the new root of the tree.

        e.path holds the path to the node.

        e.childIndices returns null.

        指定者：
        treeStructureChanged in class AbstractLayoutCache
        参数：
        e - the TreeModelEvent of interest
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.swing.tree.AbstractLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.AbstractLayoutCache

  • Packages that use AbstractLayoutCache
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of AbstractLayoutCache in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as AbstractLayoutCache
      修饰符与类型 字段与描述
      protected AbstractLayoutCache BasicTreeUI.treeState
      Object responsible for handling sizing and expanded issues.
      Methods in javax.swing.plaf.basic that return AbstractLayoutCache
      修饰符与类型 方法与描述
      protected AbstractLayoutCache BasicTreeUI.createLayoutCache()
      Creates the object responsible for managing what is expanded, as well as the size of nodes.

    • Uses of AbstractLayoutCache in javax.swing.tree

      Subclasses of AbstractLayoutCache in javax.swing.tree
      修饰符与类型 类与描述
      class  FixedHeightLayoutCache
      NOTE: This will become more open in a future release.
      class  VariableHeightLayoutCache
      NOTE: This will become more open in a future release.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

te/齮


Uses of Class javax.swing.tree.AbstractLayoutCache.NodeDimensions

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.AbstractLayoutCache.NodeDimensions

  • Packages that use AbstractLayoutCache.NodeDimensions
    软件包 描述
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of AbstractLayoutCache.NodeDimensions in javax.swing.plaf.basic

      Subclasses of AbstractLayoutCache.NodeDimensions in javax.swing.plaf.basic
      修饰符与类型 类与描述
      class  BasicTreeUI.NodeDimensionsHandler
      Class responsible for getting size of node, method is forwarded to BasicTreeUI method.
      Fields in javax.swing.plaf.basic declared as AbstractLayoutCache.NodeDimensions
      修饰符与类型 字段与描述
      protected AbstractLayoutCache.NodeDimensions BasicTreeUI.nodeDimensions
      Reponsible for telling the TreeState the size needed for a node.
      Methods in javax.swing.plaf.basic that return AbstractLayoutCache.NodeDimensions
      修饰符与类型 方法与描述
      protected AbstractLayoutCache.NodeDimensions BasicTreeUI.createNodeDimensions()
      Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.

    • Uses of AbstractLayoutCache.NodeDimensions in javax.swing.tree

      Fields in javax.swing.tree declared as AbstractLayoutCache.NodeDimensions
      修饰符与类型 字段与描述
      protected AbstractLayoutCache.NodeDimensions AbstractLayoutCache.nodeDimensions
      Object responsible for getting the size of a node.
      Methods in javax.swing.tree that return AbstractLayoutCache.NodeDimensions
      修饰符与类型 方法与描述
      AbstractLayoutCache.NodeDimensions AbstractLayoutCache.getNodeDimensions()
      Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.
      Methods in javax.swing.tree with parameters of type AbstractLayoutCache.NodeDimensions
      修饰符与类型 方法与描述
      void VariableHeightLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree.
      void AbstractLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
      Sets the renderer that is responsible for drawing nodes in the tree and which is threfore responsible for calculating the dimensions of individual nodes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>re>╮-aet>//b/�j


Uses of Class javax.swing.tree.DefaultMutableTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultMutableTreeNode

  • Packages that use DefaultMutableTreeNode
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of DefaultMutableTreeNode in javax.swing

      Subclasses of DefaultMutableTreeNode in javax.swing
      修饰符与类型 类与描述
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
      Methods in javax.swing with parameters of type DefaultMutableTreeNode
      修饰符与类型 方法与描述
      static void JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
      Adds to parent all the children in children.

    • Uses of DefaultMutableTreeNode in javax.swing.tree

      Methods in javax.swing.tree that return DefaultMutableTreeNode
      修饰符与类型 方法与描述
      DefaultMutableTreeNode DefaultMutableTreeNode.getFirstLeaf()
      Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.
      DefaultMutableTreeNode DefaultMutableTreeNode.getLastLeaf()
      Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextLeaf()
      Returns the leaf after this node or null if this node is the last leaf in the tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextNode()
      Returns the node that follows this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getNextSibling()
      Returns the next sibling of this node in the parent's children array.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousLeaf()
      Returns the leaf before this node or null if this node is the first leaf in the tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousNode()
      Returns the node that precedes this node in a preorder traversal of this node's tree.
      DefaultMutableTreeNode DefaultMutableTreeNode.getPreviousSibling()
      Returns the previous sibling of this node in the parent's children array.
      Methods in javax.swing.tree with parameters of type DefaultMutableTreeNode
      修饰符与类型 方法与描述
      TreeNode DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      boolean DefaultMutableTreeNode.isNodeDescendant(DefaultMutableTreeNode anotherNode)
      Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
      boolean DefaultMutableTreeNode.isNodeRelated(DefaultMutableTreeNode aNode)
      Returns true if and only if aNode is in the same tree as this node.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.<>bc"M;OL.d==> 慹leae


Uses of Class javax.swing.tree.DefaultTreeCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeCellEditor

No usage of javax.swing.tree.DefaultTreeCellEditor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>l...l.../gchl藀.rgl


Uses of Class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

No usage of javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"o ebleMtuuuatjjhuwgv


Uses of Class javax.swing.tree.DefaultTreeCellEditor.EditorContainer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeCellEditor.EditorContainer

No usage of javax.swing.tree.DefaultTreeCellEditor.EditorContainer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>-"t>e>loeeubbu teu


Uses of Class javax.swing.tree.DefaultTreeCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeCellRenderer

  • Packages that use DefaultTreeCellRenderer
    软件包 描述
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of DefaultTreeCellRenderer in javax.swing.tree

      Fields in javax.swing.tree declared as DefaultTreeCellRenderer
      修饰符与类型 字段与描述
      protected DefaultTreeCellRenderer DefaultTreeCellEditor.renderer
      Renderer, used to get border and offsets from.
      Constructors in javax.swing.tree with parameters of type DefaultTreeCellRenderer
      构造方法与描述
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fel dft> />.s


Uses of Class javax.swing.tree.DefaultTreeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeModel

No usage of javax.swing.tree.DefaultTreeModel
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n. f tresssmigg/=v/g


Uses of Class javax.swing.tree.DefaultTreeSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.DefaultTreeSelectionModel

  • Packages that use DefaultTreeSelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.

    • Uses of DefaultTreeSelectionModel in javax.swing

      Subclasses of DefaultTreeSelectionModel in javax.swing
      修饰符与类型 类与描述
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ad >>rteaeo "tnc/


Uses of Class javax.swing.tree.ExpandVetoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.ExpandVetoException

  • Packages that use ExpandVetoException
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.

    • Uses of ExpandVetoException in javax.swing

      Methods in javax.swing that throw ExpandVetoException
      修饰符与类型 方法与描述
      void JTree.fireTreeWillCollapse(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillExpand(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.

    • Uses of ExpandVetoException in javax.swing.event

      Methods in javax.swing.event that throw ExpandVetoException
      修饰符与类型 方法与描述
      void TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be collapsed.
      void TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event)
      Invoked whenever a node in the tree is about to be expanded.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssieng>.>>laaclr.eoee.-t


Uses of Class javax.swing.tree.FixedHeightLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.FixedHeightLayoutCache

No usage of javax.swing.tree.FixedHeightLayoutCache
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sEtae.TTTnstta i="


Uses of Class javax.swing.tree.TreePath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.TreePath

  • Packages that use TreePath
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.plaf
    Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.metal
    Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
    javax.swing.plaf.multi
    Provides user interface objects that combine two or more look and feels.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreePath in javax.swing

      Methods in javax.swing that return TreePath
      修饰符与类型 方法与描述
      TreePath JTree.getAnchorSelectionPath()
      Returns the path identified as the anchor.
      TreePath JTree.getClosestPathForLocation(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath JTree.getEditingPath()
      Returns the path to the element that is currently being edited.
      TreePath JTree.getLeadSelectionPath()
      Returns the path identified as the lead.
      TreePath JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias)
      Returns the TreePath to the next tree element that begins with a prefix.
      TreePath JTree.DropLocation.getPath()
      Returns the path where dropped data should be placed in the tree.
      protected TreePath[] JTree.getPathBetweenRows(int index0, int index1)
      Returns the paths (inclusive) between the specified rows.
      TreePath JTree.getPathForLocation(int x, int y)
      Returns the path for the node at the specified location.
      TreePath JTree.getPathForRow(int row)
      Returns the path for the specified row.
      TreePath JTree.getSelectionPath()
      Returns the path to the first selected node.
      TreePath[] JTree.getSelectionPaths()
      Returns the paths of all selected values.
      Methods in javax.swing that return types with arguments of type TreePath
      修饰符与类型 方法与描述
      protected Enumeration<TreePath> JTree.getDescendantToggledPaths(TreePath parent)
      Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.
      Enumeration<TreePath> JTree.getExpandedDescendants(TreePath parent)
      Returns an Enumeration of the descendants of the path parent that are currently expanded.
      Methods in javax.swing with parameters of type TreePath
      修饰符与类型 方法与描述
      void JTree.addSelectionPath(TreePath path)
      Adds the node identified by the specified TreePath to the current selection.
      void JTree.addSelectionPaths(TreePath[] paths)
      Adds each path in the array of paths to the current selection.
      void JTree.EmptySelectionModel.addSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.collapsePath(TreePath path)
      Ensures that the node identified by the specified path is collapsed and viewable.
      void JTree.expandPath(TreePath path)
      Ensures that the node identified by the specified path is expanded and viewable.
      void JTree.fireTreeCollapsed(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeExpanded(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillCollapse(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      void JTree.fireTreeWillExpand(TreePath path)
      Notifies all listeners that have registered interest for notification on this event type.
      protected Enumeration<TreePath> JTree.getDescendantToggledPaths(TreePath parent)
      Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.
      Enumeration<TreePath> JTree.getExpandedDescendants(TreePath parent)
      Returns an Enumeration of the descendants of the path parent that are currently expanded.
      Rectangle JTree.getPathBounds(TreePath path)
      Returns the Rectangle that the specified node will be drawn into.
      int JTree.getRowForPath(TreePath path)
      Returns the row that displays the node identified by the specified path.
      boolean JTree.hasBeenExpanded(TreePath path)
      Returns true if the node identified by the path has ever been expanded.
      boolean JTree.isCollapsed(TreePath path)
      Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
      boolean JTree.isExpanded(TreePath path)
      Returns true if the node identified by the path is currently expanded,
      boolean JTree.isPathEditable(TreePath path)
      Returns isEditable.
      boolean JTree.isPathSelected(TreePath path)
      Returns true if the item identified by the path is currently selected.
      boolean JTree.isVisible(TreePath path)
      Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded.
      void JTree.makeVisible(TreePath path)
      Ensures that the node identified by path is currently viewable.
      protected boolean JTree.removeDescendantSelectedPaths(TreePath path, boolean includePath)
      Removes any paths in the selection that are descendants of path.
      void JTree.removeSelectionPath(TreePath path)
      Removes the node identified by the specified path from the current selection.
      void JTree.removeSelectionPaths(TreePath[] paths)
      Removes the nodes identified by the specified paths from the current selection.
      void JTree.EmptySelectionModel.removeSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.scrollPathToVisible(TreePath path)
      Makes sure all the path components in path are expanded (except for the last path component) and scrolls so that the node identified by the path is displayed.
      void JTree.setAnchorSelectionPath(TreePath newPath)
      Sets the path identified as the anchor.
      protected void JTree.setExpandedState(TreePath path, boolean state)
      Sets the expanded state of this JTree.
      void JTree.setLeadSelectionPath(TreePath newPath)
      Sets the path identifies as the lead.
      void JTree.setSelectionPath(TreePath path)
      Selects the node identified by the specified path.
      void JTree.setSelectionPaths(TreePath[] paths)
      Selects the nodes identified by the specified array of paths.
      void JTree.EmptySelectionModel.setSelectionPaths(TreePath[] paths)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.
      void JTree.startEditingAtPath(TreePath path)
      Selects the node identified by the specified path and initiates editing.
      Method parameters in javax.swing with type arguments of type TreePath
      修饰符与类型 方法与描述
      protected void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
      Removes any descendants of the TreePaths in toRemove that have been expanded.
      Constructors in javax.swing with parameters of type TreePath
      构造方法与描述
      JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
      Constructs an AccessibleJTreeNode

    • Uses of TreePath in javax.swing.event

      Fields in javax.swing.event declared as TreePath
      修饰符与类型 字段与描述
      protected TreePath TreeSelectionEvent.newLeadSelectionPath
      leadSelectionPath after the paths changed, may be null.
      protected TreePath TreeSelectionEvent.oldLeadSelectionPath
      leadSelectionPath before the paths changed, may be null.
      protected TreePath TreeExpansionEvent.path
      Path to the value this event represents.
      protected TreePath TreeModelEvent.path
      Path to the parent of the nodes that have changed.
      protected TreePath[] TreeSelectionEvent.paths
      Paths this event represents.
      Methods in javax.swing.event that return TreePath
      修饰符与类型 方法与描述
      TreePath TreeSelectionEvent.getNewLeadSelectionPath()
      Returns the current lead path.
      TreePath TreeSelectionEvent.getOldLeadSelectionPath()
      Returns the path that was previously the lead path.
      TreePath TreeExpansionEvent.getPath()
      Returns the path to the value that has been expanded/collapsed.
      TreePath TreeSelectionEvent.getPath()
      Returns the first path element.
      TreePath[] TreeSelectionEvent.getPaths()
      Returns the paths that have been added or removed from the selection.
      TreePath TreeModelEvent.getTreePath()
      For all events, except treeStructureChanged, returns the parent of the changed nodes.
      Methods in javax.swing.event with parameters of type TreePath
      修饰符与类型 方法与描述
      boolean TreeSelectionEvent.isAddedPath(TreePath path)
      Returns whether the specified path was added to the selection.
      Constructors in javax.swing.event with parameters of type TreePath
      构造方法与描述
      TreeExpansionEvent(Object source, TreePath path)
      Constructs a TreeExpansionEvent object.
      TreeModelEvent(Object source, TreePath path)
      Used to create an event when the node structure has changed in some way, identifying the path to the root of the modified subtree as a TreePath object.
      TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
      Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as a TreePath object.
      TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.
      TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.
      TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
      Represents a change in the selection of a TreeSelectionModel.

    • Uses of TreePath in javax.swing.plaf

      Methods in javax.swing.plaf that return TreePath
      修饰符与类型 方法与描述
      abstract TreePath TreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath TreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      abstract TreePath TreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      Methods in javax.swing.plaf with parameters of type TreePath
      修饰符与类型 方法与描述
      abstract Rectangle TreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      abstract int TreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract void TreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.

    • Uses of TreePath in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreePath
      修饰符与类型 字段与描述
      protected TreePath BasicTreeUI.editingPath
      Path that is being edited.
      Fields in javax.swing.plaf.basic with type parameters of type TreePath
      修饰符与类型 字段与描述
      protected Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
      Used for minimizing the drawing of vertical lines.
      Methods in javax.swing.plaf.basic that return TreePath
      修饰符与类型 方法与描述
      TreePath BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath BasicTreeUI.getEditingPath(JTree tree)
      Returns the path to the element that is being edited.
      protected TreePath BasicTreeUI.getLastChildPath(TreePath parent)
      Returns a path to the last child of parent.
      TreePath BasicTreeUI.getPathForRow(JTree tree, int row)
      Returns the path for passed in row.
      Methods in javax.swing.plaf.basic with parameters of type TreePath
      修饰符与类型 方法与描述
      protected void BasicTreeUI.checkForClickInExpandControl(TreePath path, int mouseX, int mouseY)
      If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.
      protected TreePath BasicTreeUI.getLastChildPath(TreePath parent)
      Returns a path to the last child of parent.
      Rectangle BasicTreeUI.getPathBounds(JTree tree, TreePath path)
      Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.
      int BasicTreeUI.getRowForPath(JTree tree, TreePath path)
      Returns the row that the last item identified in path is visible at.
      protected void BasicTreeUI.handleExpandControlClick(TreePath path, int mouseX, int mouseY)
      Messaged when the user clicks the particular row, this invokes toggleExpandState.
      protected boolean BasicTreeUI.isLocationInExpandControl(TreePath path, int mouseX, int mouseY)
      Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.
      protected void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the expand (toggle) part of a row.
      protected void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the horizontal part of the leg.
      protected void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Paints the renderer part of a row.
      protected void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
      Paints the vertical part of the leg.
      protected void BasicTreeUI.pathWasCollapsed(TreePath path)
      Messaged from the VisibleTreeNode after it has collapsed.
      protected void BasicTreeUI.pathWasExpanded(TreePath path)
      Messaged from the VisibleTreeNode after it has been expanded.
      protected void BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event)
      Messaged to update the selection based on a MouseEvent over a particular row.
      protected boolean BasicTreeUI.shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      Returns true if the expand (toggle) control should be drawn for the specified row.
      protected boolean BasicTreeUI.startEditing(TreePath path, MouseEvent event)
      Will start editing for node if there is a cellEditor and shouldSelectCell returns true.
      void BasicTreeUI.startEditingAtPath(JTree tree, TreePath path)
      Selects the last item in path and tries to edit it.
      protected void BasicTreeUI.toggleExpandState(TreePath path)
      Expands path if it is not expanded, or collapses row if it is expanded.
      protected void BasicTreeUI.updateExpandedDescendants(TreePath path)
      Updates the expanded state of all the descendants of path by getting the expanded descendants from the tree and forwarding to the tree state.

    • Uses of TreePath in javax.swing.plaf.metal

      Methods in javax.swing.plaf.metal with parameters of type TreePath
      修饰符与类型 | 方法与描述
      protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

    • Uses of TreePath in javax.swing.plaf.multi

      Methods in javax.swing.plaf.multi that return TreePath
      修饰符与类型 方法与描述
      TreePath MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c)
      Invokes the getClosestPathForLocation method on each UI handled by this object.
      TreePath MultiTreeUI.getEditingPath(JTree a)
      Invokes the getEditingPath method on each UI handled by this object.
      TreePath MultiTreeUI.getPathForRow(JTree a, int b)
      Invokes the getPathForRow method on each UI handled by this object.
      Methods in javax.swing.plaf.multi with parameters of type TreePath
      修饰符与类型 方法与描述
      Rectangle MultiTreeUI.getPathBounds(JTree a, TreePath b)
      Invokes the getPathBounds method on each UI handled by this object.
      int MultiTreeUI.getRowForPath(JTree a, TreePath b)
      Invokes the getRowForPath method on each UI handled by this object.
      void MultiTreeUI.startEditingAtPath(JTree a, TreePath b)
      Invokes the startEditingAtPath method on each UI handled by this object.

    • Uses of TreePath in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth with parameters of type TreePath
      修饰符与类型 | 方法与描述
      protected void | SynthTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void | SynthTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
      protected void | SynthTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

    • Uses of TreePath in javax.swing.tree

      Fields in javax.swing.tree declared as TreePath
      修饰符与类型 字段与描述
      protected TreePath DefaultTreeCellEditor.lastPath
      Last path that was selected.
      protected TreePath DefaultTreeSelectionModel.leadPath
      Last path that was added.
      protected TreePath[] DefaultTreeSelectionModel.selection
      Paths that are currently selected.
      Methods in javax.swing.tree that return TreePath
      修饰符与类型 方法与描述
      TreePath DefaultTreeSelectionModel.getLeadSelectionPath()
      Returns the last path that was added.
      TreePath TreeSelectionModel.getLeadSelectionPath()
      Returns the last path that was added.
      TreePath TreePath.getParentPath()
      Returns the TreePath of the parent.
      TreePath VariableHeightLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath FixedHeightLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      abstract TreePath AbstractLayoutCache.getPathClosestTo(int x, int y)
      Returns the path to the node that is closest to x,y.
      TreePath VariableHeightLayoutCache.getPathForRow(int row)
      Returns the path for row.
      TreePath FixedHeightLayoutCache.getPathForRow(int row)
      Returns the path for passed in row.
      abstract TreePath AbstractLayoutCache.getPathForRow(int row)
      Returns the path for passed in row.
      TreePath DefaultTreeSelectionModel.getSelectionPath()
      Returns the first path in the selection.
      TreePath TreeSelectionModel.getSelectionPath()
      Returns the first path in the selection.
      TreePath[] DefaultTreeSelectionModel.getSelectionPaths()
      Returns the selection.
      TreePath[] TreeSelectionModel.getSelectionPaths()
      Returns the paths in the selection.
      TreePath TreePath.pathByAddingChild(Object child)
      Returns a new path containing all the elements of this path plus child.
      Methods in javax.swing.tree that return types with arguments of type TreePath
      修饰符与类型 方法与描述
      Enumeration<TreePath> VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Enumeration<TreePath> FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract Enumeration<TreePath> AbstractLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Methods in javax.swing.tree with parameters of type TreePath
      修饰符与类型 方法与描述
      void DefaultTreeSelectionModel.addSelectionPath(TreePath path)
      Adds path to the current selection.
      void TreeSelectionModel.addSelectionPath(TreePath path)
      Adds path to the current selection.
      void DefaultTreeSelectionModel.addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      void TreeSelectionModel.addSelectionPaths(TreePath[] paths)
      Adds paths to the current selection.
      protected boolean DefaultTreeSelectionModel.arePathsContiguous(TreePath[] paths)
      Returns true if the paths are contiguous, or this object has no RowMapper.
      protected boolean DefaultTreeSelectionModel.canPathsBeAdded(TreePath[] paths)
      Used to test if a particular set of TreePaths can be added.
      protected boolean DefaultTreeSelectionModel.canPathsBeRemoved(TreePath[] paths)
      Returns true if the paths can be removed without breaking the continuity of the model.
      Rectangle VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.
      Rectangle FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      abstract Rectangle AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn)
      Returns a rectangle giving the bounds needed to draw path.
      boolean VariableHeightLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      boolean FixedHeightLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      abstract boolean AbstractLayoutCache.getExpandedState(TreePath path)
      Returns true if the path is expanded, and visible.
      int VariableHeightLayoutCache.getRowForPath(TreePath path)
      Returns the row where the last item identified in path is visible.
      int FixedHeightLayoutCache.getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      abstract int AbstractLayoutCache.getRowForPath(TreePath path)
      Returns the row that the last item identified in path is visible at.
      int[] AbstractLayoutCache.getRowsForPaths(TreePath[] paths)
      Returns the rows that the TreePath instances in path are being displayed at.
      int[] RowMapper.getRowsForPaths(TreePath[] path)
      Returns the rows that the TreePath instances in path are being displayed at.
      int VariableHeightLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for path.
      int FixedHeightLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      abstract int AbstractLayoutCache.getVisibleChildCount(TreePath path)
      Returns the number of visible children for row.
      Enumeration<TreePath> VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      Enumeration<TreePath> FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      abstract Enumeration<TreePath> AbstractLayoutCache.getVisiblePathsFrom(TreePath path)
      Returns an Enumerator that increments over the visible paths starting at the passed in location.
      void VariableHeightLayoutCache.invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      void FixedHeightLayoutCache.invalidatePathBounds(TreePath path)
      Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
      abstract void AbstractLayoutCache.invalidatePathBounds(TreePath path)
      Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
      boolean TreePath.isDescendant(TreePath aTreePath)
      Returns true if aTreePath is a descendant of this TreePath.
      boolean VariableHeightLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by path is currently expanded.
      boolean FixedHeightLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      abstract boolean AbstractLayoutCache.isExpanded(TreePath path)
      Returns true if the value identified by row is currently expanded.
      boolean DefaultTreeSelectionModel.isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      boolean TreeSelectionModel.isPathSelected(TreePath path)
      Returns true if the path, path, is in the current selection.
      protected void DefaultTreeSelectionModel.notifyPathChange(Vector changedPaths, TreePath oldLeadSelection)
      Deprecated.
      As of JDK version 1.7
      void DefaultTreeSelectionModel.removeSelectionPath(TreePath path)
      Removes path from the selection.
      void TreeSelectionModel.removeSelectionPath(TreePath path)
      Removes path from the selection.
      void DefaultTreeSelectionModel.removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void TreeSelectionModel.removeSelectionPaths(TreePath[] paths)
      Removes paths from the selection.
      void VariableHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void FixedHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      abstract void AbstractLayoutCache.setExpandedState(TreePath path, boolean isExpanded)
      Marks the path path expanded state to isExpanded.
      void DefaultTreeSelectionModel.setSelectionPath(TreePath path)
      Sets the selection to path.
      void TreeSelectionModel.setSelectionPath(TreePath path)
      Sets the selection to path.
      void DefaultTreeSelectionModel.setSelectionPaths(TreePath[] pPaths)
      Sets the selection.
      void TreeSelectionModel.setSelectionPaths(TreePath[] paths)
      Sets the selection to path.
      void DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue)
      This sets the user object of the TreeNode identified by path and posts a node changed.
      void TreeModel.valueForPathChanged(TreePath path, Object newValue)
      Messaged when the user has altered the value for the item identified by path to newValue.
      Constructors in javax.swing.tree with parameters of type TreePath
      构造方法与描述
      TreePath(TreePath parent, Object lastPathComponent)
      Creates a TreePath with the specified parent and element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.swing.tree.VariableHeightLayoutCache

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.tree.VariableHeightLayoutCache

No usage of javax.swing.tree.VariableHeightLayoutCache
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=oothaed>>>/o>>oo""r


Uses of Interface javax.swing.tree.MutableTreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.MutableTreeNode

  • Packages that use MutableTreeNode
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of MutableTreeNode in javax.swing

      Classes in javax.swing that implement MutableTreeNode
      修饰符与类型 类与描述
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.

    • Uses of MutableTreeNode in javax.swing.tree

      Classes in javax.swing.tree that implement MutableTreeNode
      修饰符与类型 类与描述
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
      Fields in javax.swing.tree declared as MutableTreeNode
      修饰符与类型 字段与描述
      protected MutableTreeNode DefaultMutableTreeNode.parent
      this node's parent, or null if this node has no parent
      Methods in javax.swing.tree with parameters of type MutableTreeNode
      修饰符与类型 方法与描述
      void DefaultMutableTreeNode.add(MutableTreeNode newChild)
      Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
      void MutableTreeNode.insert(MutableTreeNode child, int index)
      Adds child to the receiver at index.
      void DefaultMutableTreeNode.insert(MutableTreeNode newChild, int childIndex)
      Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
      void DefaultTreeModel.insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index)
      Invoked this to insert newChild at location index in parents children.
      void MutableTreeNode.remove(MutableTreeNode node)
      Removes node from the receiver.
      void DefaultMutableTreeNode.remove(MutableTreeNode aChild)
      Removes aChild from this node's child array, giving it a null parent.
      void DefaultTreeModel.removeNodeFromParent(MutableTreeNode node)
      Message this to remove node from its parent.
      void MutableTreeNode.setParent(MutableTreeNode newParent)
      Sets the parent of the receiver to newParent.
      void DefaultMutableTreeNode.setParent(MutableTreeNode newParent)
      Sets this node's parent to newParent but does not change the parent's child array.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>it - a lfi te nbP=eEL


Uses of Interface javax.swing.tree.RowMapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.RowMapper

  • Packages that use RowMapper
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of RowMapper in javax.swing

      Methods in javax.swing with parameters of type RowMapper
      修饰符与类型 方法与描述
      void JTree.EmptySelectionModel.setRowMapper(RowMapper mapper)
      This is overriden to do nothing; EmptySelectionModel does not allow a selection.

    • Uses of RowMapper in javax.swing.tree

      Classes in javax.swing.tree that implement RowMapper
      修饰符与类型 类与描述
      class  AbstractLayoutCache
      警告： Serialized objects of this class will not be compatible with future Swing releases.
      class  FixedHeightLayoutCache
      NOTE: This will become more open in a future release.
      class  VariableHeightLayoutCache
      NOTE: This will become more open in a future release.
      Fields in javax.swing.tree declared as RowMapper
      修饰符与类型 字段与描述
      protected RowMapper DefaultTreeSelectionModel.rowMapper
      Provides a row for a given path.
      Methods in javax.swing.tree that return RowMapper
      修饰符与类型 方法与描述
      RowMapper DefaultTreeSelectionModel.getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      RowMapper TreeSelectionModel.getRowMapper()
      Returns the RowMapper instance that is able to map a TreePath to a row.
      Methods in javax.swing.tree with parameters of type RowMapper
      修饰符与类型 方法与描述
      void DefaultTreeSelectionModel.setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
      void TreeSelectionModel.setRowMapper(RowMapper newMapper)
      Sets the RowMapper instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fi=<> <<>///


Uses of Interface javax.swing.tree.TreeCellEditor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.TreeCellEditor

  • Packages that use TreeCellEditor
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeCellEditor in javax.swing

      Classes in javax.swing that implement TreeCellEditor
      修饰符与类型 类与描述
      class  DefaultCellEditor
      The default editor for table and tree cells.
      Fields in javax.swing declared as TreeCellEditor
      修饰符与类型 字段与描述
      protected TreeCellEditor JTree.cellEditor
      Editor for the entries.
      Methods in javax.swing that return TreeCellEditor
      修饰符与类型 方法与描述
      TreeCellEditor JTree.getCellEditor()
      Returns the editor used to edit entries in the tree.
      Methods in javax.swing with parameters of type TreeCellEditor
      修饰符与类型 方法与描述
      void JTree.setCellEditor(TreeCellEditor cellEditor)
      Sets the cell editor.

    • Uses of TreeCellEditor in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeCellEditor
      修饰符与类型 字段与描述
      protected TreeCellEditor BasicTreeUI.cellEditor
      Editor for the tree.
      Methods in javax.swing.plaf.basic that return TreeCellEditor
      修饰符与类型 | 方法与描述
      protected TreeCellEditor BasicTreeUI.createDefaultCellEditor()
      Creates a default cell editor.
      protected TreeCellEditor | BasicTreeUI.getCellEditor()
      Methods in javax.swing.plaf.basic with parameters of type TreeCellEditor
      修饰符与类型 方法与描述
      protected void BasicTreeUI.setCellEditor(TreeCellEditor editor)
      Sets the cell editor.

    • Uses of TreeCellEditor in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return TreeCellEditor
      修饰符与类型 | 方法与描述
      protected TreeCellEditor | SynthTreeUI.createDefaultCellEditor()

    • Uses of TreeCellEditor in javax.swing.tree

      Classes in javax.swing.tree that implement TreeCellEditor
      修饰符与类型 类与描述
      class  DefaultTreeCellEditor
      A TreeCellEditor.
      Fields in javax.swing.tree declared as TreeCellEditor
      修饰符与类型 字段与描述
      protected TreeCellEditor DefaultTreeCellEditor.realEditor
      Editor handling the editing.
      Methods in javax.swing.tree that return TreeCellEditor
      修饰符与类型 方法与描述
      protected TreeCellEditor DefaultTreeCellEditor.createTreeCellEditor()
      This is invoked if a TreeCellEditor is not supplied in the constructor.
      Constructors in javax.swing.tree with parameters of type TreeCellEditor
      构造方法与描述
      DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
      Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/h)trdw elsa[i".ks=mat i =<


Uses of Interface javax.swing.tree.TreeCellRenderer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.TreeCellRenderer

  • Packages that use TreeCellRenderer
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.plaf.synth
    Synth is a skinnable look and feel in which all painting is delegated.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeCellRenderer in javax.swing

      Fields in javax.swing declared as TreeCellRenderer
      修饰符与类型 字段与描述
      protected TreeCellRenderer JTree.cellRenderer
      The cell used to draw nodes.
      Methods in javax.swing that return TreeCellRenderer
      修饰符与类型 方法与描述
      TreeCellRenderer JTree.getCellRenderer()
      Returns the current TreeCellRenderer that is rendering each cell.
      Methods in javax.swing with parameters of type TreeCellRenderer
      修饰符与类型 方法与描述
      void JTree.setCellRenderer(TreeCellRenderer x)
      Sets the TreeCellRenderer that will be used to draw each cell.

    • Uses of TreeCellRenderer in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeCellRenderer
      修饰符与类型 字段与描述
      protected TreeCellRenderer BasicTreeUI.currentCellRenderer
      Renderer that is being used to do the actual cell drawing.
      Methods in javax.swing.plaf.basic that return TreeCellRenderer
      修饰符与类型 方法与描述
      protected TreeCellRenderer BasicTreeUI.createDefaultCellRenderer()
      Returns the default cell renderer that is used to do the stamping of each node.
      protected TreeCellRenderer BasicTreeUI.getCellRenderer()
      Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.
      Methods in javax.swing.plaf.basic with parameters of type TreeCellRenderer
      修饰符与类型 方法与描述
      protected void BasicTreeUI.setCellRenderer(TreeCellRenderer tcr)
      Sets the TreeCellRenderer to tcr.

    • Uses of TreeCellRenderer in javax.swing.plaf.synth

      Methods in javax.swing.plaf.synth that return TreeCellRenderer
      修饰符与类型 | 方法与描述
      protected TreeCellRenderer | SynthTreeUI.createDefaultCellRenderer()

    • Uses of TreeCellRenderer in javax.swing.tree

      Classes in javax.swing.tree that implement TreeCellRenderer
      修饰符与类型 类与描述
      class  DefaultTreeCellRenderer
      Displays an entry in a tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/strtruc oootl eoo ofdoEeo


Uses of Interface javax.swing.tree.TreeModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.TreeModel

  • Packages that use TreeModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeModel in javax.swing

      Fields in javax.swing declared as TreeModel
      修饰符与类型 字段与描述
      protected TreeModel JTree.treeModel
      The model that defines the tree displayed by this object.
      Methods in javax.swing that return TreeModel
      修饰符与类型 方法与描述
      protected static TreeModel JTree.createTreeModel(Object value)
      Returns a TreeModel wrapping the specified object.
      protected static TreeModel JTree.getDefaultTreeModel()
      Creates and returns a sample TreeModel.
      TreeModel JTree.getModel()
      Returns the TreeModel that is providing the data.
      Methods in javax.swing with parameters of type TreeModel
      修饰符与类型 方法与描述
      void JTree.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      Constructors in javax.swing with parameters of type TreeModel
      构造方法与描述
      JTree(TreeModel newModel)
      Returns an instance of JTree which displays the root node -- the tree is created using the specified data model.

    • Uses of TreeModel in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeModel
      修饰符与类型 字段与描述
      protected TreeModel BasicTreeUI.treeModel
      Used to determine what to display.
      Methods in javax.swing.plaf.basic that return TreeModel
      修饰符与类型 | 方法与描述
      protected TreeModel | BasicTreeUI.getModel()
      Methods in javax.swing.plaf.basic with parameters of type TreeModel
      修饰符与类型 方法与描述
      protected void BasicTreeUI.setModel(TreeModel model)
      Sets the TreeModel.

    • Uses of TreeModel in javax.swing.tree

      Classes in javax.swing.tree that implement TreeModel
      修饰符与类型 类与描述
      class  DefaultTreeModel
      A simple tree data model that uses TreeNodes.
      Fields in javax.swing.tree declared as TreeModel
      修饰符与类型 字段与描述
      protected TreeModel AbstractLayoutCache.treeModel
      Model providing information.
      Methods in javax.swing.tree that return TreeModel
      修饰符与类型 方法与描述
      TreeModel AbstractLayoutCache.getModel()
      Returns the TreeModel that is providing the data.
      Methods in javax.swing.tree with parameters of type TreeModel
      修饰符与类型 方法与描述
      void VariableHeightLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void FixedHeightLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
      void AbstractLayoutCache.setModel(TreeModel newModel)
      Sets the TreeModel that will provide the data.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cneeA r Ieena级厄peA/prp/n


Uses of Interface javax.swing.tree.TreeNode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.TreeNode

  • Packages that use TreeNode
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.text.html
    Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeNode in javax.swing

      Classes in javax.swing that implement TreeNode
      修饰符与类型 类与描述
      static class  JTree.DynamicUtilTreeNode
      DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
      Methods in javax.swing that return TreeNode
      修饰符与类型 方法与描述
      TreeNode JTree.DynamicUtilTreeNode.getChildAt(int index)
      Subclassed to load the children, if necessary.
      Constructors in javax.swing with parameters of type TreeNode
      构造方法与描述
      JTree(TreeNode root)
      Returns a JTree with the specified TreeNode as its root, which displays the root node.
      JTree(TreeNode root, boolean asksAllowsChildren)
      Returns a JTree with the specified TreeNode as its root, which displays the root node and which decides whether a node is a leaf node in the specified manner.

    • Uses of TreeNode in javax.swing.text

      Classes in javax.swing.text that implement TreeNode
      修饰符与类型 类与描述
      class  AbstractDocument.AbstractElement
      Implements the abstract part of an element.
      class  AbstractDocument.BranchElement
      Implements a composite element that contains other elements.
      class  AbstractDocument.LeafElement
      Implements an element that directly represents content of some kind.
      protected class  DefaultStyledDocument.SectionElement
      Default root element for a document...
      Methods in javax.swing.text that return TreeNode
      修饰符与类型 方法与描述
      TreeNode AbstractDocument.AbstractElement.getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      TreeNode AbstractDocument.AbstractElement.getParent()
      Returns the parent TreeNode of the receiver.
      Methods in javax.swing.text with parameters of type TreeNode
      修饰符与类型 方法与描述
      int AbstractDocument.AbstractElement.getIndex(TreeNode node)
      Returns the index of node in the receivers children.

    • Uses of TreeNode in javax.swing.text.html

      Classes in javax.swing.text.html that implement TreeNode
      修饰符与类型 类与描述
      class  HTMLDocument.BlockElement
      An element that represents a structural block of HTML.
      class  HTMLDocument.RunElement
      An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.

    • Uses of TreeNode in javax.swing.tree

      Subinterfaces of TreeNode in javax.swing.tree
      修饰符与类型 Interface and Description
      interface  MutableTreeNode
      Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
      Classes in javax.swing.tree that implement TreeNode
      修饰符与类型 类与描述
      class  DefaultMutableTreeNode
      A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
      Fields in javax.swing.tree declared as TreeNode
      修饰符与类型 字段与描述
      protected TreeNode DefaultTreeModel.root
      Root of the tree.
      Fields in javax.swing.tree with type parameters of type TreeNode
      修饰符与类型 字段与描述
      static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
      An enumeration that is always empty.
      Methods in javax.swing.tree that return TreeNode
      修饰符与类型 方法与描述
      TreeNode DefaultMutableTreeNode.getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getChildAt(int index)
      Returns the child at the specified index in this node's child array.
      TreeNode TreeNode.getChildAt(int childIndex)
      Returns the child TreeNode at index childIndex.
      TreeNode DefaultMutableTreeNode.getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getFirstChild()
      Returns this node's first child.
      TreeNode DefaultMutableTreeNode.getLastChild()
      Returns this node's last child.
      TreeNode DefaultMutableTreeNode.getParent()
      Returns this node's parent or null if this node has no parent.
      TreeNode TreeNode.getParent()
      Returns the parent TreeNode of the receiver.
      TreeNode[] DefaultMutableTreeNode.getPath()
      Returns the path from the root, to get to this node.
      TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      TreeNode DefaultMutableTreeNode.getRoot()
      Returns the root of the tree that contains this node.
      TreeNode DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode)
      Returns the nearest common ancestor to this node and aNode.
      Methods in javax.swing.tree with parameters of type TreeNode
      修饰符与类型 方法与描述
      TreeNode DefaultMutableTreeNode.getChildAfter(TreeNode aChild)
      Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.
      TreeNode DefaultMutableTreeNode.getChildBefore(TreeNode aChild)
      Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.
      int DefaultMutableTreeNode.getIndex(TreeNode aChild)
      Returns the index of the specified child in this node's child array.
      int TreeNode.getIndex(TreeNode node)
      Returns the index of node in the receivers children.
      TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      protected TreeNode[] DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth)
      Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.
      boolean DefaultMutableTreeNode.isNodeAncestor(TreeNode anotherNode)
      Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
      boolean DefaultMutableTreeNode.isNodeChild(TreeNode aNode)
      Returns true if aNode is a child of this node.
      boolean DefaultMutableTreeNode.isNodeSibling(TreeNode anotherNode)
      Returns true if anotherNode is a sibling of (has the same parent as) this node.
      void DefaultTreeModel.nodeChanged(TreeNode node)
      Invoke this method after you've changed how node is to be represented in the tree.
      void DefaultTreeModel.nodesChanged(TreeNode node, int[] childIndices)
      Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.
      void DefaultTreeModel.nodeStructureChanged(TreeNode node)
      Invoke this method if you've totally changed the children of node and its childrens children...
      void DefaultTreeModel.nodesWereInserted(TreeNode node, int[] childIndices)
      Invoke this method after you've inserted some TreeNodes into node.
      void DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
      Invoke this method after you've removed some TreeNodes from node.
      Enumeration DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor)
      Creates and returns an enumeration that follows the path from ancestor to this node.
      void DefaultTreeModel.reload(TreeNode node)
      Invoke this method if you've modified the TreeNodes upon which this model depends.
      void DefaultTreeModel.setRoot(TreeNode root)
      Sets the root to root.
      Constructors in javax.swing.tree with parameters of type TreeNode
      构造方法与描述
      DefaultTreeModel(TreeNode root)
      Creates a tree in which any node can have children.
      DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
      Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.swing.tree.TreeSelectionModel

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.tree.TreeSelectionModel

  • Packages that use TreeSelectionModel
    软件包 描述
    javax.swing
    Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
    javax.swing.plaf.basic
    Provides user interface objects built according to the Basic look and feel.
    javax.swing.tree
    Provides classes and interfaces for dealing with javax.swing.JTree.

    • Uses of TreeSelectionModel in javax.swing

      Classes in javax.swing that implement TreeSelectionModel
      修饰符与类型 类与描述
      protected static class  JTree.EmptySelectionModel
      EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
      Fields in javax.swing declared as TreeSelectionModel
      修饰符与类型 字段与描述
      protected TreeSelectionModel JTree.selectionModel
      Models the set of selected nodes in this tree.
      Methods in javax.swing that return TreeSelectionModel
      修饰符与类型 方法与描述
      TreeSelectionModel JTree.getSelectionModel()
      Returns the model for selections.
      Methods in javax.swing with parameters of type TreeSelectionModel
      修饰符与类型 方法与描述
      void JTree.setSelectionModel(TreeSelectionModel selectionModel)
      Sets the tree's selection model.

    • Uses of TreeSelectionModel in javax.swing.plaf.basic

      Fields in javax.swing.plaf.basic declared as TreeSelectionModel
      修饰符与类型 字段与描述
      protected TreeSelectionModel BasicTreeUI.treeSelectionModel
      Model maintaing the selection.
      Methods in javax.swing.plaf.basic that return TreeSelectionModel
      修饰符与类型 | 方法与描述
      protected TreeSelectionModel | BasicTreeUI.getSelectionModel()
      Methods in javax.swing.plaf.basic with parameters of type TreeSelectionModel
      修饰符与类型 方法与描述
      protected void BasicTreeUI.setSelectionModel(TreeSelectionModel newLSM)
      Resets the selection model.

    • Uses of TreeSelectionModel in javax.swing.tree

      Classes in javax.swing.tree that implement TreeSelectionModel
      修饰符与类型 类与描述
      class  DefaultTreeSelectionModel
      Default implementation of TreeSelectionModel.
      Fields in javax.swing.tree declared as TreeSelectionModel
      修饰符与类型 字段与描述
      protected TreeSelectionModel AbstractLayoutCache.treeSelectionModel
      Selection model.
      Methods in javax.swing.tree that return TreeSelectionModel
      修饰符与类型 方法与描述
      TreeSelectionModel AbstractLayoutCache.getSelectionModel()
      Returns the model used to maintain the selection.
      Methods in javax.swing.tree with parameters of type TreeSelectionModel
      修饰符与类型 方法与描述
      void AbstractLayoutCache.setSelectionModel(TreeSelectionModel newLSM)
      Sets the TreeSelectionModel used to manage the selection to new LSM.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>itml"ht...etjjrf.t<


AbstractUndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.undo

类 AbstractUndoableEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
  • 所有已实现的接口：
    Serializable, UndoableEdit
    直接已知子类：
    AbstractDocument.ElementEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit

    public class AbstractUndoableEdit
extends Object
implements UndoableEdit, Serializable
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected static String RedoName
      String returned by getRedoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.
      protected static String UndoName
      String returned by getUndoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractUndoableEdit()
      Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean addEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean canRedo()
      Returns true if this edit is alive and hasBeenDone is false.
      boolean canUndo()
      Returns true if this edit is alive and hasBeenDone is true.
      void die()
      Sets alive to false.
      String getPresentationName()
      This default implementation returns "".
      String getRedoPresentationName()
      Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName.
      String getUndoPresentationName()
      Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName.
      boolean isSignificant()
      This default implementation returns true.
      void redo()
      Throws CannotRedoException if canRedo returns false.
      boolean replaceEdit(UndoableEdit anEdit)
      This default implementation returns false.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void undo()
      Throws CannotUndoException if canUndo returns false.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • UndoName

        protected static final String UndoName
        String returned by getUndoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used. This value is now localized and comes from the defaults table with key AbstractUndoableEdit.undoText.
        另请参见：
        UIDefaults, Constant Field Values

      • RedoName

        protected static final String RedoName
        String returned by getRedoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used. This value is now localized and comes from the defaults table with key AbstractUndoableEdit.redoText.
        另请参见：
        UIDefaults, Constant Field Values

    • 构造方法详细信息

      • AbstractUndoableEdit

        public AbstractUndoableEdit()
        Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.

    • 方法详细信息

      • die

        public void die()
        Sets alive to false. Note that this is a one way operation; dead edits cannot be resurrected. Sending undo or redo to a dead edit results in an exception being thrown.

        Typically an edit is killed when it is consolidated by another edit's addEdit or replaceEdit method, or when it is dequeued from an UndoManager.

        指定者：
        die in interface UndoableEdit
        另请参见：
        CompoundEdit.die()

      • undo

        public void undo()
          throws CannotUndoException
        Throws CannotUndoException if canUndo returns false. Sets hasBeenDone to false. Subclasses should override to undo the operation represented by this edit. Override should begin with a call to super.
        指定者：
        undo in interface UndoableEdit
        抛出：
        CannotUndoException - if canUndo returns false
        另请参见：
        canUndo()

      • canUndo

        public boolean canUndo()
        Returns true if this edit is alive and hasBeenDone is true.
        指定者：
        canUndo in interface UndoableEdit
        返回：
        true if this edit is alive and hasBeenDone is true
        另请参见：
        die(),
undo(),
redo()

      • redo

        public void redo()
          throws CannotRedoException
        Throws CannotRedoException if canRedo returns false. Sets hasBeenDone to true. Subclasses should override to redo the operation represented by this edit. Override should begin with a call to super.
        指定者：
        redo in interface UndoableEdit
        抛出：
        CannotRedoException - if canRedo returns false
        另请参见：
        canRedo()

      • canRedo

        public boolean canRedo()
        Returns true if this edit is alive and hasBeenDone is false.
        指定者：
        canRedo in interface UndoableEdit
        返回：
        true if this edit is alive and hasBeenDone is false
        另请参见：
        die(),
undo(),
redo()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        This default implementation returns false.
        指定者：
        addEdit in interface UndoableEdit
        参数：
        anEdit - the edit to be added
        返回：
        false
        另请参见：
        UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

      • replaceEdit

        public boolean replaceEdit(UndoableEdit anEdit)
        This default implementation returns false.
        指定者：
        replaceEdit in interface UndoableEdit
        参数：
        anEdit - the edit to replace
        返回：
        false
        另请参见：
        UndoableEdit.replaceEdit(javax.swing.undo.UndoableEdit)

      • isSignificant

        public boolean isSignificant()
        This default implementation returns true.
        指定者：
        isSignificant in interface UndoableEdit
        返回：
        true
        另请参见：
        UndoableEdit.isSignificant()

      • getPresentationName

        public String getPresentationName()
        This default implementation returns "". Used by getUndoPresentationName and getRedoPresentationName to construct the strings they return. Subclasses should override to return an appropriate description of the operation this edit represents.
        指定者：
        getPresentationName in interface UndoableEdit
        返回：
        the empty string ""
        另请参见：
        getUndoPresentationName(), getRedoPresentationName()

      • getUndoPresentationName

        public String getUndoPresentationName()
        Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName. If getPresentationName returns "", then the defaults value is returned alone.
        指定者：
        getUndoPresentationName in interface UndoableEdit
        返回：
        the value from the defaults table with key AbstractUndoableEdit.undoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        另请参见：
        getPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName. If getPresentationName returns "", then the defaults value is returned alone.
        指定者：
        getRedoPresentationName in interface UndoableEdit
        返回：
        the value from the defaults table with key AbstractUndoableEdit.redoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        另请参见：
        getPresentationName()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


CannotRedoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.undo

类 CannotRedoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotRedoException
  • 所有已实现的接口：
    Serializable

    public class CannotRedoException
extends RuntimeException
    Thrown when an UndoableEdit is told to redo() and can't.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotRedoException()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CannotRedoException

        public CannotRedoException()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"u/neeReed>doddf/dddmd(odd/tkw"swdp


CannotUndoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.swing.undo

类 CannotUndoException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotUndoException
  • 所有已实现的接口：
    Serializable

    public class CannotUndoException
extends RuntimeException
    Thrown when an UndoableEdit is told to undo() and can't.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotUndoException()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CannotUndoException

        public CannotUndoException()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/aut>tdttth>t"ueed/eeld"dooddd/mdfo>


CompoundEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.undo

类 CompoundEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.CompoundEdit
  • 所有已实现的接口：
    Serializable, UndoableEdit
    直接已知子类：
    AbstractDocument.DefaultDocumentEvent, UndoManager

    public class CompoundEdit
extends AbstractUndoableEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected Vector<UndoableEdit> edits
      The collection of UndoableEdits undone/redone en masse by this CompoundEdit.

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompoundEdit()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean addEdit(UndoableEdit anEdit)
      If this edit is inProgress, accepts anEdit and returns true.
      boolean canRedo()
      Returns false if isInProgress or if super returns false.
      boolean canUndo()
      Returns false if isInProgress or if super returns false.
      void die()
      Sends die to each subedit, in the reverse of the order that they were added.
      void end()
      Sets inProgress to false.
      String getPresentationName()
      Returns getPresentationName from the last UndoableEdit added to edits.
      String getRedoPresentationName()
      Returns getRedoPresentationName from the last UndoableEdit added to edits.
      String getUndoPresentationName()
      Returns getUndoPresentationName from the last UndoableEdit added to edits.
      boolean isInProgress()
      Returns true if this edit is in progress--that is, it has not received end.
      boolean isSignificant()
      Returns true if any of the UndoableEdits in edits do.
      protected UndoableEdit lastEdit()
      Returns the last UndoableEdit in edits, or null if edits is empty.
      void redo()
      Sends redo to all contained UndoableEdits in the order in which they were added.
      String toString()
      Returns a string that displays and identifies this object's properties.
      void undo()
      Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        replaceEdit

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • edits

        protected Vector<UndoableEdit> edits
        The collection of UndoableEdits undone/redone en masse by this CompoundEdit.

    • 构造方法详细信息

      • CompoundEdit

        public CompoundEdit()

    • 方法详细信息

      • undo

        public void undo()
          throws CannotUndoException
        Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class AbstractUndoableEdit
        抛出：
        CannotUndoException - if canUndo returns false
        另请参见：
        AbstractUndoableEdit.canUndo()

      • redo

        public void redo()
          throws CannotRedoException
        Sends redo to all contained UndoableEdits in the order in which they were added.
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class AbstractUndoableEdit
        抛出：
        CannotRedoException - if canRedo returns false
        另请参见：
        AbstractUndoableEdit.canRedo()

      • lastEdit

        protected UndoableEdit lastEdit()
        Returns the last UndoableEdit in edits, or null if edits is empty.

      • die

        public void die()
        Sends die to each subedit, in the reverse of the order that they were added.
        指定者：
        die in interface UndoableEdit
        重载：
        die in class AbstractUndoableEdit
        另请参见：
        die()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        If this edit is inProgress, accepts anEdit and returns true.

        The last edit added to this CompoundEdit is given a chance to addEdit(anEdit). If it refuses (returns false), anEdit is given a chance to replaceEdit the last edit. If anEdit returns false here, it is added to edits.

        指定者：
        addEdit in interface UndoableEdit
        重载：
        addEdit in class AbstractUndoableEdit
        参数：
        anEdit - the edit to be added
        返回：
        true if the edit is inProgress; otherwise returns false
        另请参见：
        UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

      • end

        public void end()
        Sets inProgress to false.
        另请参见：
        canUndo(), canRedo()

      • canUndo

        public boolean canUndo()
        Returns false if isInProgress or if super returns false.
        指定者：
        canUndo in interface UndoableEdit
        重载：
        canUndo in class AbstractUndoableEdit
        返回：
        true if this edit is alive and hasBeenDone is true
        另请参见：
        isInProgress()

      • canRedo

        public boolean canRedo()
        Returns false if isInProgress or if super returns false.
        指定者：
        canRedo in interface UndoableEdit
        重载：
        canRedo in class AbstractUndoableEdit
        返回：
        true if this edit is alive and hasBeenDone is false
        另请参见：
        isInProgress()

      • isInProgress

        public boolean isInProgress()
        Returns true if this edit is in progress--that is, it has not received end. This generally means that edits are still being added to it.
        另请参见：
        end()

      • isSignificant

        public boolean isSignificant()
        Returns true if any of the UndoableEdits in edits do. Returns false if they all return false.
        指定者：
        isSignificant in interface UndoableEdit
        重载：
        isSignificant in class AbstractUndoableEdit
        返回：
        true
        另请参见：
        UndoableEdit.isSignificant()

      • getPresentationName

        public String getPresentationName()
        Returns getPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        指定者：
        getPresentationName in interface UndoableEdit
        重载：
        getPresentationName in class AbstractUndoableEdit
        返回：
        the empty string ""
        另请参见：
        AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

      • getUndoPresentationName

        public String getUndoPresentationName()
        Returns getUndoPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        指定者：
        getUndoPresentationName in interface UndoableEdit
        重载：
        getUndoPresentationName in class AbstractUndoableEdit
        返回：
        the value from the defaults table with key AbstractUndoableEdit.undoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        另请参见：
        AbstractUndoableEdit.getPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Returns getRedoPresentationName from the last UndoableEdit added to edits. If edits is empty, calls super.
        指定者：
        getRedoPresentationName in interface UndoableEdit
        重载：
        getRedoPresentationName in class AbstractUndoableEdit
        返回：
        the value from the defaults table with key AbstractUndoableEdit.redoText, followed by a space, followed by getPresentationName unless getPresentationName is "" in which case, the defaults value is returned alone.
        另请参见：
        AbstractUndoableEdit.getPresentationName()

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class AbstractUndoableEdit
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.swing.undo

Interfaces

  • StateEditable
  • UndoableEdit

Classes

  • AbstractUndoableEdit
  • CompoundEdit
  • StateEdit
  • UndoableEditSupport
  • UndoManager

Exceptions

  • CannotRedoException
  • CannotUndoException


javax.swing.undo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.swing.undo

Allows developers to provide support for undo/redo in applications such as text editors.

请参见： 描述

  • 接口摘要
    接口 描述
    StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    UndoableEdit
    An UndoableEdit represents an edit.
  • Class Summary
    类 描述
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    StateEdit
    StateEdit is a general edit for objects that change state.
    UndoableEditSupport
    A support class used for managing UndoableEdit listeners.
    UndoManager
    UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
  • Exception Summary
    Exception 描述
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.

软件包 javax.swing.undo Description

Allows developers to provide support for undo/redo in applications such as text editors.

Note: Most of the Swing API is not thread safe. For details, see Threads and Swing, a section in The Java Tutorial.

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • Implementing Undo and Redo, a section in The Java Tutorial
从以下版本开始：
1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

onC


javax.swing.undo Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.swing.undo

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.undo.CompoundEdit
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.undo.StateEdit
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
    • javax.swing.undo.UndoableEditSupport

Interface Hierarchy

  • javax.swing.undo.StateEditable
  • javax.swing.undo.UndoableEdit
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.


StateEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.undo

类 StateEdit

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.StateEdit
  • 所有已实现的接口：
    Serializable, UndoableEdit

    public class StateEdit
extends AbstractUndoableEdit

    StateEdit is a general edit for objects that change state. Objects being edited must conform to the StateEditable interface.

    This edit class works by asking an object to store it's state in Hashtables before and after editing occurs. Upon undo or redo the object is told to restore it's state from these Hashtables.

    A state edit is used as follows:
          // Create the edit during the "before" state of the object
      StateEdit newEdit = new StateEdit(myObject);
      // Modify the object
      myObject.someStateModifyingMethod();
      // "end" the edit when you are done modifying the object
      newEdit.end();

    Note that when a StateEdit ends, it removes redundant state from the Hashtables - A state Hashtable is not guaranteed to contain all keys/values placed into it when the state is stored!

    另请参见：
    StateEditable

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected StateEditable object
      The object being edited
      protected Hashtable<Object,Object> postState
      The state information after the edit
      protected Hashtable<Object,Object> preState
      The state information prior to the edit
      protected static String | RCSID
      protected String undoRedoName
      The undo/redo presentation name

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      StateEdit(StateEditable anObject)
      Create and return a new StateEdit.
      StateEdit(StateEditable anObject, String name)
      Create and return a new StateEdit with a presentation name.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      void end()
      Gets the post-edit state of the StateEditable object and ends the edit.
      String getPresentationName()
      Gets the presentation name for this edit
      protected void | init(StateEditable anObject, String name)
      void redo()
      Tells the edited object to apply the state after the edit
      protected void removeRedundantState()
      Remove redundant key/values in state hashtables.
      void undo()
      Tells the edited object to apply the state prior to the edit

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        addEdit, canRedo, canUndo, die, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • RCSID

        protected static final String RCSID
        另请参见：
        Constant Field Values

      • object

        protected StateEditable object
        The object being edited

      • preState

        protected Hashtable<Object,Object> preState
        The state information prior to the edit

      • postState

        protected Hashtable<Object,Object> postState
        The state information after the edit

      • undoRedoName

        protected String undoRedoName
        The undo/redo presentation name

    • 构造方法详细信息

      • StateEdit

        public StateEdit(StateEditable anObject)
        Create and return a new StateEdit.
        参数：
        anObject - The object to watch for changing state
        另请参见：
        StateEdit

      • StateEdit

        public StateEdit(StateEditable anObject,
         String name)
        Create and return a new StateEdit with a presentation name.
        参数：
        anObject - The object to watch for changing state
        name - The presentation name to be used for this edit
        另请参见：
        StateEdit

    • 方法详细信息

      • init

        protected void init(StateEditable anObject,
        String name)

      • end

        public void end()
        Gets the post-edit state of the StateEditable object and ends the edit.

      • undo

        public void undo()
        Tells the edited object to apply the state prior to the edit
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class AbstractUndoableEdit
        另请参见：
        AbstractUndoableEdit.canUndo()

      • redo

        public void redo()
        Tells the edited object to apply the state after the edit
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class AbstractUndoableEdit
        另请参见：
        AbstractUndoableEdit.canRedo()

      • getPresentationName

        public String getPresentationName()
        Gets the presentation name for this edit
        指定者：
        getPresentationName in interface UndoableEdit
        重载：
        getPresentationName in class AbstractUndoableEdit
        返回：
        the empty string ""
        另请参见：
        AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

      • removeRedundantState

        protected void removeRedundantState()
        Remove redundant key/values in state hashtables.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

na/vhrntp e>tmow ">


StateEditable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.undo

Interface StateEditable

  • public interface StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    另请参见：
    StateEdit

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String RCSID
      Resource ID for this class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void restoreState(Hashtable<?,?> state)
      Upon receiving this message the receiver should extract any relevant state out of state.
      void storeState(Hashtable<Object,Object> state)
      Upon receiving this message the receiver should place any relevant state into state.

    • 字段详细信息

      • RCSID

        static final String RCSID
        Resource ID for this class.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • storeState

        void storeState(Hashtable<Object,Object> state)
        Upon receiving this message the receiver should place any relevant state into state.

      • restoreState

        void restoreState(Hashtable<?,?> state)
        Upon receiving this message the receiver should extract any relevant state out of state.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aln "ltcltilltiimt// >/t


UndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.swing.undo

Interface UndoableEdit

  • All Known Implementing Classes:
    AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractUndoableEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit, UndoManager

    public interface UndoableEdit
    An UndoableEdit represents an edit. The edit may be undone, or if already undone the edit may be redone.

    UndoableEdit is designed to be used with the UndoManager. As UndoableEdits are generated by an UndoableEditListener they are typically added to the UndoManager. When an UndoableEdit is added to an UndoManager the following occurs (assuming end has not been called on the UndoManager):

    1. If the UndoManager contains edits it will call addEdit on the current edit passing in the new edit as the argument. If addEdit returns true the new edit is assumed to have been incorporated into the current edit and the new edit will not be added to the list of current edits. Edits can use addEdit as a way for smaller edits to be incorporated into a larger edit and treated as a single edit.
    2. If addEdit returns false replaceEdit is called on the new edit with the current edit passed in as the argument. This is the inverse of addEdit — if the new edit returns true from replaceEdit, the new edit replaces the current edit.
    The UndoManager makes use of isSignificant to determine how many edits should be undone or redone. The UndoManager will undo or redo all insignificant edits (isSignificant returns false) between the current edit and the last or next significant edit. addEdit and replaceEdit can be used to treat multiple edits as a single edit, returning false from isSignificant allows for treating can be used to have many smaller edits undone or redone at once. Similar functionality can also be done using the addEdit method.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoableEdit.
      boolean canRedo()
      Returns true if this edit may be redone.
      boolean canUndo()
      Returns true if this edit may be undone.
      void die()
      Informs the edit that it should no longer be used.
      String getPresentationName()
      Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.
      String getRedoPresentationName()
      Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example.
      String getUndoPresentationName()
      Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example.
      boolean isSignificant()
      Returns true if this edit is considered significant.
      void redo()
      Re-applies the edit.
      boolean replaceEdit(UndoableEdit anEdit)
      Returns true if this UndoableEdit should replace anEdit.
      void undo()
      Undo the edit.

    • 方法详细信息

      • undo

        void undo()
          throws CannotUndoException
        Undo the edit.
        抛出：
        CannotUndoException - if this edit can not be undone

      • canUndo

        boolean canUndo()
        Returns true if this edit may be undone.
        返回：
        true if this edit may be undone

      • redo

        void redo()
          throws CannotRedoException
        Re-applies the edit.
        抛出：
        CannotRedoException - if this edit can not be redone

      • canRedo

        boolean canRedo()
        Returns true if this edit may be redone.
        返回：
        true if this edit may be redone

      • die

        void die()
        Informs the edit that it should no longer be used. Once an UndoableEdit has been marked as dead it can no longer be undone or redone.

        This is a useful hook for cleaning up state no longer needed once undoing or redoing is impossible--for example, deleting file resources used by objects that can no longer be undeleted. UndoManager calls this before it dequeues edits.

        Note that this is a one-way operation. There is no "un-die" method.

        另请参见：
        CompoundEdit.die()

      • addEdit

        boolean addEdit(UndoableEdit anEdit)
        Adds an UndoableEdit to this UndoableEdit. This method can be used to coalesce smaller edits into a larger compound edit. For example, text editors typically allow undo operations to apply to words or sentences. The text editor may choose to generate edits on each key event, but allow those edits to be coalesced into a more user-friendly unit, such as a word. In this case, the UndoableEdit would override addEdit to return true when the edits may be coalesced.

        A return value of true indicates anEdit was incorporated into this edit. A return value of false indicates anEdit may not be incorporated into this edit.

        Typically the receiver is already in the queue of a UndoManager (or other UndoableEditListener), and is being given a chance to incorporate anEdit rather than letting it be added to the queue in turn.

        If true is returned, from now on anEdit must return false from canUndo and canRedo, and must throw the appropriate exception on undo or redo.

        参数：
        anEdit - the edit to be added
        返回：
        true if anEdit may be incorporated into this edit

      • replaceEdit

        boolean replaceEdit(UndoableEdit anEdit)
        Returns true if this UndoableEdit should replace anEdit. This method is used by CompoundEdit and the UndoManager; it is called if anEdit could not be added to the current edit (addEdit returns false).

        This method provides a way for an edit to replace an existing edit.

        This message is the opposite of addEdit--anEdit has typically already been queued in an UndoManager (or other UndoableEditListener), and the receiver is being given a chance to take its place.

        If true is returned, from now on anEdit must return false from canUndo() and canRedo(), and must throw the appropriate exception on undo() or redo().

        参数：
        anEdit - the edit that replaces the current edit
        返回：
        true if this edit should replace anEdit

      • isSignificant

        boolean isSignificant()
        Returns true if this edit is considered significant. A significant edit is typically an edit that should be presented to the user, perhaps on a menu item or tooltip. The UndoManager will undo, or redo, all insignificant edits to the next significant edit.
        返回：
        true if this edit is significant

      • getPresentationName

        String getPresentationName()
        Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.
        返回：
        description of this edit

      • getUndoPresentationName

        String getUndoPresentationName()
        Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example. This is typically derived from getPresentationName.
        返回：
        a description of the undoable form of this edit

      • getRedoPresentationName

        String getRedoPresentationName()
        Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example. This is typically derived from getPresentationName.
        返回：
        a description of the redoable form of this edit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dit/ieldevOeevOOr <<


UndoableEditSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.undo

类 UndoableEditSupport

  • java.lang.Object
    • javax.swing.undo.UndoableEditSupport

  • public class UndoableEditSupport
extends Object
    A support class used for managing UndoableEdit listeners.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected CompoundEdit | compoundEdit
      protected Vector<UndoableEditListener> | listeners
      protected Object | realSource
      protected int | updateLevel

    • 构造方法摘要

      Constructors
      构造方法与描述
      UndoableEditSupport()
      Constructs an UndoableEditSupport object.
      UndoableEditSupport(Object r)
      Constructs an UndoableEditSupport object.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      protected void _postEdit(UndoableEdit e)
      Called only from postEdit and endUpdate.
      void addUndoableEditListener(UndoableEditListener l)
      Registers an UndoableEditListener.
      void | beginUpdate()
      protected CompoundEdit createCompoundEdit()
      Called only from beginUpdate.
      void endUpdate()
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      UndoableEditListener[] getUndoableEditListeners()
      Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().
      int getUpdateLevel()
      Returns the update level value.
      void postEdit(UndoableEdit e)
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      void removeUndoableEditListener(UndoableEditListener l)
      Removes an UndoableEditListener.
      String toString()
      Returns a string that displays and identifies this object's properties.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • updateLevel

        protected int updateLevel

      • compoundEdit

        protected CompoundEdit compoundEdit

      • listeners

        protected Vector<UndoableEditListener> listeners

      • realSource

        protected Object realSource

    • 构造方法详细信息

      • UndoableEditSupport

        public UndoableEditSupport()
        Constructs an UndoableEditSupport object.

      • UndoableEditSupport

        public UndoableEditSupport(Object r)
        Constructs an UndoableEditSupport object.
        参数：
        r - an Object

    • 方法详细信息

      • addUndoableEditListener

        public void addUndoableEditListener(UndoableEditListener l)
        Registers an UndoableEditListener. The listener is notified whenever an edit occurs which can be undone.
        参数：
        l - an UndoableEditListener object
        另请参见：
        removeUndoableEditListener(javax.swing.event.UndoableEditListener)

      • removeUndoableEditListener

        public void removeUndoableEditListener(UndoableEditListener l)
        Removes an UndoableEditListener.
        参数：
        l - the UndoableEditListener object to be removed
        另请参见：
        addUndoableEditListener(javax.swing.event.UndoableEditListener)

      • getUndoableEditListeners

        public UndoableEditListener[] getUndoableEditListeners()
        Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().
        返回：
        all of the UndoableEditListeners added or an empty array if no listeners have been added
        从以下版本开始：
        1.4

      • _postEdit

        protected void _postEdit(UndoableEdit e)
        Called only from postEdit and endUpdate. Calls undoableEditHappened in all listeners. No synchronization is performed here, since the two calling methods are synchronized.

      • postEdit

        public void postEdit(UndoableEdit e)
        DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners. It is unwise to call this method from one of its listeners.

      • getUpdateLevel

        public int getUpdateLevel()
        Returns the update level value.
        返回：
        an integer representing the update level

      • beginUpdate

        public void beginUpdate()

      • createCompoundEdit

        protected CompoundEdit createCompoundEdit()
        Called only from beginUpdate. Exposed here for subclasses' use.

      • endUpdate

        public void endUpdate()
        DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners. It is unwise to call this method from one of its listeners.

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class Object
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/S.e/ll-dp.tt>�


UndoManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.swing.undo

类 UndoManager

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit
      • javax.swing.undo.CompoundEdit
        • javax.swing.undo.UndoManager
  • 所有已实现的接口：
    Serializable, EventListener, UndoableEditListener, UndoableEdit

    public class UndoManager
extends CompoundEdit
implements UndoableEditListener
    UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits. There are two ways to add edits to an UndoManager. Add the edit directly using the addEdit method, or add the UndoManager to a bean that supports UndoableEditListener. The following examples creates an UndoManager and adds it as an UndoableEditListener to a JTextField:
       UndoManager undoManager = new UndoManager();
   JTextField tf = ...;
   tf.getDocument().addUndoableEditListener(undoManager);

    UndoManager maintains an ordered list of edits and the index of the next edit in that list. The index of the next edit is either the size of the current list of edits, or if undo has been invoked it corresponds to the index of the last significant edit that was undone. When undo is invoked all edits from the index of the next edit to the last significant edit are undone, in reverse order. For example, consider an UndoManager consisting of the following edits: A b c D. Edits with a upper-case letter in bold are significant, those in lower-case and italicized are insignificant.

    Figure 1

    As shown in figure 1, if D was just added, the index of the next edit will be 4. Invoking undo results in invoking undo on D and setting the index of the next edit to 3 (edit c), as shown in the following figure.

    Figure 2

    The last significant edit is A, so that invoking undo again invokes undo on c, b, and A, in that order, setting the index of the next edit to 0, as shown in the following figure.

    Figure 3

    Invoking redo results in invoking redo on all edits between the index of the next edit and the next significant edit (or the end of the list). Continuing with the previous example if redo were invoked, redo would in turn be invoked on A, b and c. In addition the index of the next edit is set to 3 (as shown in figure 2).

    Adding an edit to an UndoManager results in removing all edits from the index of the next edit to the end of the list. Continuing with the previous example, if a new edit, e, is added the edit D is removed from the list (after having die invoked on it). If c is not incorporated by the next edit (c.addEdit(e) returns true), or replaced by it (e.replaceEdit(c) returns true), the new edit is added after c, as shown in the following figure.

    Figure 4

    Once end has been invoked on an UndoManager the superclass behavior is used for all UndoableEdit methods. Refer to CompoundEdit for more details on its behavior.

    Unlike the rest of Swing, this class is thread safe.

    警告： Serialized objects of this class will not be compatible with future Swing releases. The current serialization support is appropriate for short term storage or RMI between applications running the same version of Swing. As of 1.4, support for long term storage of all JavaBeansTM has been added to the java.beans package. Please see XMLEncoder.

    • 字段摘要

      • Fields inherited from class javax.swing.undo.CompoundEdit

        edits

      • Fields inherited from class javax.swing.undo.AbstractUndoableEdit

        RedoName, UndoName

    • 构造方法摘要

      Constructors
      构造方法与描述
      UndoManager()
      Creates a new UndoManager.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoManager, if it's possible.
      boolean canRedo()
      Returns true if edits may be redone.
      boolean canUndo()
      Returns true if edits may be undone.
      boolean canUndoOrRedo()
      Returns true if it is possible to invoke undo or redo.
      void discardAllEdits()
      Empties the undo manager sending each edit a die message in the process.
      protected UndoableEdit editToBeRedone()
      Returns the the next significant edit to be redone if redo is invoked.
      protected UndoableEdit editToBeUndone()
      Returns the the next significant edit to be undone if undo is invoked.
      void end()
      Turns this UndoManager into a normal CompoundEdit.
      int getLimit()
      Returns the maximum number of edits this UndoManager holds.
      String getRedoPresentationName()
      Returns a description of the redoable form of this edit.
      String getUndoOrRedoPresentationName()
      Convenience method that returns either getUndoPresentationName or getRedoPresentationName.
      String getUndoPresentationName()
      Returns a description of the undoable form of this edit.
      void redo()
      Redoes the appropriate edits.
      protected void redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      void setLimit(int l)
      Sets the maximum number of edits this UndoManager holds.
      String toString()
      Returns a string that displays and identifies this object's properties.
      protected void trimEdits(int from, int to)
      Removes edits in the specified range.
      protected void trimForLimit()
      Reduces the number of queued edits to a range of size limit, centered on the index of the next edit.
      void undo()
      Undoes the appropriate edits.
      void undoableEditHappened(UndoableEditEvent e)
      An UndoableEditListener method.
      void undoOrRedo()
      Convenience method that invokes one of undo or redo.
      protected void undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.

      • 方法 - 继承于类 javax.swing.undo.CompoundEdit

        die, getPresentationName, isInProgress, isSignificant, lastEdit

      • 方法 - 继承于类 javax.swing.undo.AbstractUndoableEdit

        replaceEdit

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UndoManager

        public UndoManager()
        Creates a new UndoManager.

    • 方法详细信息

      • getLimit

        public int getLimit()
        Returns the maximum number of edits this UndoManager holds. A value less than 0 indicates the number of edits is not limited.
        返回：
        the maximum number of edits this UndoManager holds
        另请参见：
        addEdit(javax.swing.undo.UndoableEdit), setLimit(int)

      • discardAllEdits

        public void discardAllEdits()
        Empties the undo manager sending each edit a die message in the process.
        另请参见：
        AbstractUndoableEdit.die()

      • trimForLimit

        protected void trimForLimit()
        Reduces the number of queued edits to a range of size limit, centered on the index of the next edit.

      • trimEdits

        protected void trimEdits(int from,
             int to)
        Removes edits in the specified range. All edits in the given range (inclusive, and in reverse order) will have die invoked on them and are removed from the list of edits. This has no effect if from > to.
        参数：
        from - the minimum index to remove
        to - the maximum index to remove

      • setLimit

        public void setLimit(int l)
        Sets the maximum number of edits this UndoManager holds. A value less than 0 indicates the number of edits is not limited. If edits need to be discarded to shrink the limit, die will be invoked on them in the reverse order they were added. The default is 100.
        参数：
        l - the new limit
        抛出：
        RuntimeException - if this UndoManager is not in progress (end has been invoked)
        另请参见：
        CompoundEdit.isInProgress(),
end(),
addEdit(javax.swing.undo.UndoableEdit),
getLimit()

      • editToBeUndone

        protected UndoableEdit editToBeUndone()
        Returns the the next significant edit to be undone if undo is invoked. This returns null if there are no edits to be undone.
        返回：
        the next significant edit to be undone

      • editToBeRedone

        protected UndoableEdit editToBeRedone()
        Returns the the next significant edit to be redone if redo is invoked. This returns null if there are no edits to be redone.
        返回：
        the next significant edit to be redone

      • undoTo

        protected void undoTo(UndoableEdit edit)
               throws CannotUndoException
        Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
        抛出：
        CannotUndoException - if one of the edits throws CannotUndoException

      • redoTo

        protected void redoTo(UndoableEdit edit)
               throws CannotRedoException
        Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
        抛出：
        CannotRedoException - if one of the edits throws CannotRedoException

      • undoOrRedo

        public void undoOrRedo()
                throws CannotRedoException,
                       CannotUndoException
        Convenience method that invokes one of undo or redo. If any edits have been undone (the index of the next edit is less than the length of the edits list) this invokes redo, otherwise it invokes undo.
        抛出：
        CannotUndoException - if one of the edits throws CannotUndoException
        CannotRedoException - if one of the edits throws CannotRedoException
        另请参见：
        canUndoOrRedo(), getUndoOrRedoPresentationName()

      • canUndoOrRedo

        public boolean canUndoOrRedo()
        Returns true if it is possible to invoke undo or redo.
        返回：
        true if invoking canUndoOrRedo is valid
        另请参见：
        undoOrRedo()

      • undo

        public void undo()
          throws CannotUndoException
        Undoes the appropriate edits. If end has been invoked this calls through to the superclass, otherwise this invokes undo on all edits between the index of the next edit and the last significant edit, updating the index of the next edit appropriately.
        指定者：
        undo in interface UndoableEdit
        重载：
        undo in class CompoundEdit
        抛出：
        CannotUndoException - if one of the edits throws CannotUndoException or there are no edits to be undone
        另请参见：
        CompoundEdit.end(),
canUndo(),
editToBeUndone()

      • canUndo

        public boolean canUndo()
        Returns true if edits may be undone. If end has been invoked, this returns the value from super. Otherwise this returns true if there are any edits to be undone (editToBeUndone returns non-null).
        指定者：
        canUndo in interface UndoableEdit
        重载：
        canUndo in class CompoundEdit
        返回：
        true if there are edits to be undone
        另请参见：
        CompoundEdit.canUndo(), editToBeUndone()

      • redo

        public void redo()
          throws CannotRedoException
        Redoes the appropriate edits. If end has been invoked this calls through to the superclass. Otherwise this invokes redo on all edits between the index of the next edit and the next significant edit, updating the index of the next edit appropriately.
        指定者：
        redo in interface UndoableEdit
        重载：
        redo in class CompoundEdit
        抛出：
        CannotRedoException - if one of the edits throws CannotRedoException or there are no edits to be redone
        另请参见：
        CompoundEdit.end(),
canRedo(),
editToBeRedone()

      • canRedo

        public boolean canRedo()
        Returns true if edits may be redone. If end has been invoked, this returns the value from super. Otherwise, this returns true if there are any edits to be redone (editToBeRedone returns non-null).
        指定者：
        canRedo in interface UndoableEdit
        重载：
        canRedo in class CompoundEdit
        返回：
        true if there are edits to be redone
        另请参见：
        CompoundEdit.canRedo(), editToBeRedone()

      • addEdit

        public boolean addEdit(UndoableEdit anEdit)
        Adds an UndoableEdit to this UndoManager, if it's possible. This removes all edits from the index of the next edit to the end of the edits list. If end has been invoked the edit is not added and false is returned. If end hasn't been invoked this returns true.
        指定者：
        addEdit in interface UndoableEdit
        重载：
        addEdit in class CompoundEdit
        参数：
        anEdit - the edit to be added
        返回：
        true if anEdit can be incorporated into this edit
        另请参见：
        CompoundEdit.end(), CompoundEdit.addEdit(javax.swing.undo.UndoableEdit)

      • end

        public void end()
        Turns this UndoManager into a normal CompoundEdit. This removes all edits that have been undone.
        重载：
        end in class CompoundEdit
        另请参见：
        CompoundEdit.end()

      • getUndoOrRedoPresentationName

        public String getUndoOrRedoPresentationName()
        Convenience method that returns either getUndoPresentationName or getRedoPresentationName. If the index of the next edit equals the size of the edits list, getUndoPresentationName is returned, otherwise getRedoPresentationName is returned.
        返回：
        undo or redo name

      • getUndoPresentationName

        public String getUndoPresentationName()
        Returns a description of the undoable form of this edit. If end has been invoked this calls into super. Otherwise if there are edits to be undone, this returns the value from the next significant edit that will be undone. If there are no edits to be undone and end has not been invoked this returns the value from the UIManager property "AbstractUndoableEdit.undoText".
        指定者：
        getUndoPresentationName in interface UndoableEdit
        重载：
        getUndoPresentationName in class CompoundEdit
        返回：
        a description of the undoable form of this edit
        另请参见：
        undo(), CompoundEdit.getUndoPresentationName()

      • getRedoPresentationName

        public String getRedoPresentationName()
        Returns a description of the redoable form of this edit. If end has been invoked this calls into super. Otherwise if there are edits to be redone, this returns the value from the next significant edit that will be redone. If there are no edits to be redone and end has not been invoked this returns the value from the UIManager property "AbstractUndoableEdit.redoText".
        指定者：
        getRedoPresentationName in interface UndoableEdit
        重载：
        getRedoPresentationName in class CompoundEdit
        返回：
        a description of the redoable form of this edit
        另请参见：
        redo(), CompoundEdit.getRedoPresentationName()

      • undoableEditHappened

        public void undoableEditHappened(UndoableEditEvent e)
        An UndoableEditListener method. This invokes addEdit with e.getEdit().
        指定者：
        undoableEditHappened in interface UndoableEditListener
        参数：
        e - the UndoableEditEvent the UndoableEditEvent will be added from
        另请参见：
        addEdit(javax.swing.undo.UndoableEdit)

      • toString

        public String toString()
        Returns a string that displays and identifies this object's properties.
        重载：
        toString in class CompoundEdit
        返回：
        a String representation of this object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.swing.undo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.swing.undo

  • Packages that use javax.swing.undo
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.
  • Classes in javax.swing.undo used by javax.swing.event
    类与描述
    UndoableEdit
    An UndoableEdit represents an edit.
  • Classes in javax.swing.undo used by javax.swing.text
    类与描述
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    UndoableEdit
    An UndoableEdit represents an edit.
  • Classes in javax.swing.undo used by javax.swing.undo
    类与描述
    AbstractUndoableEdit
    An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
    CannotRedoException
    Thrown when an UndoableEdit is told to redo() and can't.
    CannotUndoException
    Thrown when an UndoableEdit is told to undo() and can't.
    CompoundEdit
    A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
    StateEditable
    StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.
    UndoableEdit
    An UndoableEdit represents an edit.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

de=xliasonaa e>/c>av>a


Uses of Class javax.swing.undo.AbstractUndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.AbstractUndoableEdit

  • Packages that use AbstractUndoableEdit
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of AbstractUndoableEdit in javax.swing.text

      Subclasses of AbstractUndoableEdit in javax.swing.text
      修饰符与类型 类与描述
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      static class  DefaultStyledDocument.AttributeUndoableEdit
      An UndoableEdit used to remember AttributeSet changes to an Element.

    • Uses of AbstractUndoableEdit in javax.swing.undo

      Subclasses of AbstractUndoableEdit in javax.swing.undo
      修饰符与类型 类与描述
      class  CompoundEdit
      A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
      class  StateEdit
      StateEdit is a general edit for objects that change state.
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:ot daa


Uses of Class javax.swing.undo.CannotRedoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.CannotRedoException

  • Packages that use CannotRedoException
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CannotRedoException in javax.swing.text

      Methods in javax.swing.text that throw CannotRedoException
      修饰符与类型 方法与描述
      void DefaultStyledDocument.AttributeUndoableEdit.redo()
      Redoes a change.
      void AbstractDocument.DefaultDocumentEvent.redo()
      Redoes a change.
      void AbstractDocument.ElementEdit.redo()
      Redoes a change.

    • Uses of CannotRedoException in javax.swing.undo

      Methods in javax.swing.undo that throw CannotRedoException
      修饰符与类型 方法与描述
      void UndoManager.redo()
      Redoes the appropriate edits.
      void AbstractUndoableEdit.redo()
      Throws CannotRedoException if canRedo returns false.
      void CompoundEdit.redo()
      Sends redo to all contained UndoableEdits in the order in which they were added.
      void UndoableEdit.redo()
      Re-applies the edit.
      protected void UndoManager.redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      void UndoManager.undoOrRedo()
      Convenience method that invokes one of undo or redo.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rgv,a =0dh/3s(i >�


Uses of Class javax.swing.undo.CannotUndoException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.CannotUndoException

  • Packages that use CannotUndoException
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CannotUndoException in javax.swing.text

      Methods in javax.swing.text that throw CannotUndoException
      修饰符与类型 方法与描述
      void DefaultStyledDocument.AttributeUndoableEdit.undo()
      Undoes a change.
      void AbstractDocument.DefaultDocumentEvent.undo()
      Undoes a change.
      void AbstractDocument.ElementEdit.undo()
      Undoes a change.

    • Uses of CannotUndoException in javax.swing.undo

      Methods in javax.swing.undo that throw CannotUndoException
      修饰符与类型 方法与描述
      void UndoManager.undo()
      Undoes the appropriate edits.
      void AbstractUndoableEdit.undo()
      Throws CannotUndoException if canUndo returns false.
      void CompoundEdit.undo()
      Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.
      void UndoableEdit.undo()
      Undo the edit.
      void UndoManager.undoOrRedo()
      Convenience method that invokes one of undo or redo.
      protected void UndoManager.undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssldtf


Uses of Class javax.swing.undo.CompoundEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.CompoundEdit

  • Packages that use CompoundEdit
    软件包 描述
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of CompoundEdit in javax.swing.text

      Subclasses of CompoundEdit in javax.swing.text
      修饰符与类型 类与描述
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.

    • Uses of CompoundEdit in javax.swing.undo

      Subclasses of CompoundEdit in javax.swing.undo
      修饰符与类型 类与描述
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
      Fields in javax.swing.undo declared as CompoundEdit
      修饰符与类型 | 字段与描述
      protected CompoundEdit | UndoableEditSupport.compoundEdit
      Methods in javax.swing.undo that return CompoundEdit
      修饰符与类型 方法与描述
      protected CompoundEdit UndoableEditSupport.createCompoundEdit()
      Called only from beginUpdate.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t<-- < - a-


Uses of Class javax.swing.undo.StateEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.StateEdit

No usage of javax.swing.undo.StateEdit
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.3uas ic"lllltmm!nsho


Uses of Class javax.swing.undo.UndoableEditSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.UndoableEditSupport

No usage of javax.swing.undo.UndoableEditSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

anbttr>>d <.eed)s<


Uses of Class javax.swing.undo.UndoManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.swing.undo.UndoManager

No usage of javax.swing.undo.UndoManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

svtＨ�/�o>


Uses of Interface javax.swing.undo.StateEditable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.undo.StateEditable

  • Packages that use StateEditable
    软件包 描述
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of StateEditable in javax.swing.undo

      Fields in javax.swing.undo declared as StateEditable
      修饰符与类型 字段与描述
      protected StateEditable StateEdit.object
      The object being edited
      Methods in javax.swing.undo with parameters of type StateEditable
      修饰符与类型 | 方法与描述
      protected void | StateEdit.init(StateEditable anObject, String name)
      Constructors in javax.swing.undo with parameters of type StateEditable
      构造方法与描述
      StateEdit(StateEditable anObject)
      Create and return a new StateEdit.
      StateEdit(StateEditable anObject, String name)
      Create and return a new StateEdit with a presentation name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.asc xemap_ -eLaa) .r>


Uses of Interface javax.swing.undo.UndoableEdit

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.swing.undo.UndoableEdit

  • Packages that use UndoableEdit
    软件包 描述
    javax.swing.event
    Provides for events fired by Swing components.
    javax.swing.text
    Provides classes and interfaces that deal with editable and noneditable text components.
    javax.swing.undo
    Allows developers to provide support for undo/redo in applications such as text editors.

    • Uses of UndoableEdit in javax.swing.event

      Methods in javax.swing.event that return UndoableEdit
      修饰符与类型 方法与描述
      UndoableEdit UndoableEditEvent.getEdit()
      Returns the edit value.
      Constructors in javax.swing.event with parameters of type UndoableEdit
      构造方法与描述
      UndoableEditEvent(Object source, UndoableEdit edit)
      Constructs an UndoableEditEvent object.

    • Uses of UndoableEdit in javax.swing.text

      Classes in javax.swing.text that implement UndoableEdit
      修饰符与类型 类与描述
      class  AbstractDocument.DefaultDocumentEvent
      Stores document changes as the document is being modified.
      static class  AbstractDocument.ElementEdit
      An implementation of ElementChange that can be added to the document event.
      static class  DefaultStyledDocument.AttributeUndoableEdit
      An UndoableEdit used to remember AttributeSet changes to an Element.
      Methods in javax.swing.text that return UndoableEdit
      修饰符与类型 方法与描述
      UndoableEdit StringContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit GapContent.insertString(int where, String str)
      Inserts a string into the content.
      UndoableEdit AbstractDocument.Content.insertString(int where, String str)
      Inserts a string of characters into the sequence.
      UndoableEdit StringContent.remove(int where, int nitems)
      Removes part of the content.
      UndoableEdit GapContent.remove(int where, int nitems)
      Removes part of the content.
      UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
      Removes some portion of the sequence.
      Methods in javax.swing.text with parameters of type UndoableEdit
      修饰符与类型 方法与描述
      boolean AbstractDocument.DefaultDocumentEvent.addEdit(UndoableEdit anEdit)
      Adds a document edit.

    • Uses of UndoableEdit in javax.swing.undo

      Classes in javax.swing.undo that implement UndoableEdit
      修饰符与类型 类与描述
      class  AbstractUndoableEdit
      An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
      class  CompoundEdit
      A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
      class  StateEdit
      StateEdit is a general edit for objects that change state.
      class  UndoManager
      UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
      Fields in javax.swing.undo with type parameters of type UndoableEdit
      修饰符与类型 字段与描述
      protected Vector<UndoableEdit> CompoundEdit.edits
      The collection of UndoableEdits undone/redone en masse by this CompoundEdit.
      Methods in javax.swing.undo that return UndoableEdit
      修饰符与类型 方法与描述
      protected UndoableEdit UndoManager.editToBeRedone()
      Returns the the next significant edit to be redone if redo is invoked.
      protected UndoableEdit UndoManager.editToBeUndone()
      Returns the the next significant edit to be undone if undo is invoked.
      protected UndoableEdit CompoundEdit.lastEdit()
      Returns the last UndoableEdit in edits, or null if edits is empty.
      Methods in javax.swing.undo with parameters of type UndoableEdit
      修饰符与类型 方法与描述
      protected void UndoableEditSupport._postEdit(UndoableEdit e)
      Called only from postEdit and endUpdate.
      boolean UndoManager.addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoManager, if it's possible.
      boolean AbstractUndoableEdit.addEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean CompoundEdit.addEdit(UndoableEdit anEdit)
      If this edit is inProgress, accepts anEdit and returns true.
      boolean UndoableEdit.addEdit(UndoableEdit anEdit)
      Adds an UndoableEdit to this UndoableEdit.
      void UndoableEditSupport.postEdit(UndoableEdit e)
      DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
      protected void UndoManager.redoTo(UndoableEdit edit)
      Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
      boolean AbstractUndoableEdit.replaceEdit(UndoableEdit anEdit)
      This default implementation returns false.
      boolean UndoableEdit.replaceEdit(UndoableEdit anEdit)
      Returns true if this UndoableEdit should replace anEdit.
      protected void UndoManager.undoTo(UndoableEdit edit)
      Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>lp>dh>


Diagnostic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface Diagnostic<S>

  • 类型参数：
    S - the type of source object used by this diagnostic

    public interface Diagnostic<S>
    Interface for diagnostics from tools. A diagnostic usually reports a problem at a specific position in a source file. However, not all diagnostics are associated with a position or a file.

    A position is a zero-based character offset from the beginning of a file. Negative values (except NOPOS) are not valid positions.

    Line and column numbers begin at 1. Negative values (except NOPOS) and 0 are not valid line or column numbers.

    从以下版本开始：
    1.6

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Diagnostic.Kind
      Kinds of diagnostics, for example, error or warning.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static long NOPOS
      Used to signal that no position is available.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getCode()
      Gets a diagnostic code indicating the type of diagnostic.
      long getColumnNumber()
      Gets the column number of the character offset returned by getPosition().
      long getEndPosition()
      Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.
      Diagnostic.Kind getKind()
      Gets the kind of this diagnostic, for example, error or warning.
      long getLineNumber()
      Gets the line number of the character offset returned by getPosition().
      String getMessage(Locale locale)
      Gets a localized message for the given locale.
      long getPosition()
      Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem.
      S getSource()
      Gets the source object associated with this diagnostic.
      long getStartPosition()
      Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.

    • 字段详细信息

      • NOPOS

        static final long NOPOS
        Used to signal that no position is available.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getKind

        Diagnostic.Kind getKind()
        Gets the kind of this diagnostic, for example, error or warning.
        返回：
        the kind of this diagnostic

      • getSource

        S getSource()
        Gets the source object associated with this diagnostic.
        返回：
        the source object associated with this diagnostic. null if no source object is associated with the diagnostic.

      • getPosition

        long getPosition()
        Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem. In addition, the following must be true:

        getStartPostion() <= getPosition()

        getPosition() <= getEndPosition()

        返回：
        character offset from beginning of source; NOPOS if getSource() would return null or if no location is suitable

      • getStartPosition

        long getStartPosition()
        Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.
        返回：
        offset from beginning of file; NOPOS if and only if getPosition() returns NOPOS

      • getEndPosition

        long getEndPosition()
        Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.
        返回：
        offset from beginning of file; NOPOS if and only if getPosition() returns NOPOS

      • getLineNumber

        long getLineNumber()
        Gets the line number of the character offset returned by getPosition().
        返回：
        a line number or NOPOS if and only if getPosition() returns NOPOS

      • getColumnNumber

        long getColumnNumber()
        Gets the column number of the character offset returned by getPosition().
        返回：
        a column number or NOPOS if and only if getPosition() returns NOPOS

      • getCode

        String getCode()
        Gets a diagnostic code indicating the type of diagnostic. The code is implementation-dependent and might be null.
        返回：
        a diagnostic code

      • getMessage

        String getMessage(Locale locale)
        Gets a localized message for the given locale. The actual message is implementation-dependent. If the locale is null use the default locale.
        参数：
        locale - a locale; might be null
        返回：
        a localized message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atfhHdru>


Diagnostic.Kind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.tools

Enum Diagnostic.Kind

  • java.lang.Object
    • java.lang.Enum<Diagnostic.Kind>
      • javax.tools.Diagnostic.Kind
  • 所有已实现的接口：
    Serializable, Comparable<Diagnostic.Kind>
    Enclosing interface:
    Diagnostic<S>

    public static enum Diagnostic.Kind
extends Enum<Diagnostic.Kind>
    Kinds of diagnostics, for example, error or warning.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ERROR
      Problem which prevents the tool's normal completion.
      MANDATORY_WARNING
      Problem similar to a warning, but is mandated by the tool's specification.
      NOTE
      Informative message from the tool.
      OTHER
      Diagnostic which does not fit within the other kinds.
      WARNING
      Problem which does not usually prevent the tool from completing normally.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Diagnostic.Kind valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Diagnostic.Kind[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ERROR

        public static final Diagnostic.Kind ERROR
        Problem which prevents the tool's normal completion.

      • WARNING

        public static final Diagnostic.Kind WARNING
        Problem which does not usually prevent the tool from completing normally.

      • MANDATORY_WARNING

        public static final Diagnostic.Kind MANDATORY_WARNING
        Problem similar to a warning, but is mandated by the tool's specification. For example, the Java™ Language Specification, 3rd Ed. mandates warnings on certain unchecked operations and the use of deprecated methods.

      • NOTE

        public static final Diagnostic.Kind NOTE
        Informative message from the tool.

      • OTHER

        public static final Diagnostic.Kind OTHER
        Diagnostic which does not fit within the other kinds.

    • 方法详细信息

      • values

        public static Diagnostic.Kind[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Diagnostic.Kind c : Diagnostic.Kind.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Diagnostic.Kind valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vobaNvtavtotoboos< = ===NA=SA>==NT


DiagnosticCollector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.tools

类 DiagnosticCollector<S>

  • java.lang.Object
    • javax.tools.DiagnosticCollector<S>
  • 类型参数：
    S - the type of source objects used by diagnostics received by this object
    所有已实现的接口：
    DiagnosticListener<S>

    public final class DiagnosticCollector<S>
extends Object
implements DiagnosticListener<S>
    Provides an easy way to collect diagnostics in a list.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      DiagnosticCollector()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List<Diagnostic<? extends S>> getDiagnostics()
      Gets a list view of diagnostics collected by this object.
      void report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DiagnosticCollector

        public DiagnosticCollector()

    • 方法详细信息

      • report

        public void report(Diagnostic<? extends S> diagnostic)
        从接口复制的描述： DiagnosticListener
        Invoked when a problem is found.
        指定者：
        report in interface DiagnosticListener<S>
        参数：
        diagnostic - a diagnostic representing the problem that was found

      • getDiagnostics

        public List<Diagnostic<? extends S>> getDiagnostics()
        Gets a list view of diagnostics collected by this object.
        返回：
        a list view of diagnostics
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itfhn nt nossnoond//tootc nscn athhmet doond


DiagnosticListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface DiagnosticListener<S>

  • 类型参数：
    S - the type of source objects used by diagnostics received by this listener
    All Known Implementing Classes:
    DiagnosticCollector

    public interface DiagnosticListener<S>
    Interface for receiving diagnostics from tools.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.

    • 方法详细信息

      • report

        void report(Diagnostic<? extends S> diagnostic)
        Invoked when a problem is found.
        参数：
        diagnostic - a diagnostic representing the problem that was found
        抛出：
        NullPointerException - if the diagnostic argument is null and the implementation cannot handle null arguments
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.<>./o


FileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface FileObject

  • All Known Subinterfaces:
    JavaFileObject
    All Known Implementing Classes:
    ForwardingFileObject, ForwardingJavaFileObject, SimpleJavaFileObject

    public interface FileObject
    File abstraction for tools. In this context, file means an abstraction of regular files and other sources of data. For example, a file object can be used to represent regular files, memory cache, or data in databases.

    All methods in this interface might throw a SecurityException if a security exception occurs.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean delete()
      Deletes this file object.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      Gets the character content of this file object, if available.
      long getLastModified()
      Gets the time this file object was last modified.
      String getName()
      Gets a user-friendly name for this file object.
      InputStream openInputStream()
      Gets an InputStream for this file object.
      OutputStream openOutputStream()
      Gets an OutputStream for this file object.
      Reader openReader(boolean ignoreEncodingErrors)
      Gets a reader for this object.
      Writer openWriter()
      Gets a Writer for this file object.
      URI toUri()
      Returns a URI identifying this file object.

    • 方法详细信息

      • toUri

        URI toUri()
        Returns a URI identifying this file object.
        返回：
        a URI

      • getName

        String getName()
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        返回：
        a user-friendly name

      • openInputStream

        InputStream openInputStream()
                            throws IOException
        Gets an InputStream for this file object.
        返回：
        an InputStream
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openOutputStream

        OutputStream openOutputStream()
                              throws IOException
        Gets an OutputStream for this file object.
        返回：
        an OutputStream
        抛出：
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openReader

        Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
        Gets a reader for this object. The returned reader will replace bytes that cannot be decoded with the default translation character. In addition, the reader may report a diagnostic unless ignoreEncodingErrors is true.
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a Reader
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
        Gets the character content of this file object, if available. Any byte that cannot be decoded will be replaced by the default translation character. In addition, a diagnostic may be reported unless ignoreEncodingErrors is true.
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a CharSequence if available; null otherwise
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • openWriter

        Writer openWriter()
                  throws IOException
        Gets a Writer for this file object.
        返回：
        a Writer
        抛出：
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        long getLastModified()
        Gets the time this file object was last modified. The time is measured in milliseconds since the epoch (00:00:00 GMT, January 1, 1970).
        返回：
        the time this file object was last modified; or 0 if the file object does not exist, if an I/O error occurred, or if the operation is not supported

      • delete

        boolean delete()
        Deletes this file object. In case of errors, returns false.
        返回：
        true if and only if this file object is successfully deleted; false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oocs =all rxsbw


ForwardingFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.tools

类 ForwardingFileObject<F extends FileObject>

  • java.lang.Object
    • javax.tools.ForwardingFileObject<F>
  • 类型参数：
    F - the kind of file object forwarded to by this object
    所有已实现的接口：
    FileObject
    直接已知子类：
    ForwardingJavaFileObject

    public class ForwardingFileObject<F extends FileObject>
extends Object
implements FileObject
    Forwards calls to a given file object. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected F fileObject
      The file object which all methods are delegated to.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ForwardingFileObject(F fileObject)
      Creates a new instance of ForwardingFileObject.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean delete()
      Deletes this file object.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      Gets the character content of this file object, if available.
      long getLastModified()
      Gets the time this file object was last modified.
      String getName()
      Gets a user-friendly name for this file object.
      InputStream openInputStream()
      Gets an InputStream for this file object.
      OutputStream openOutputStream()
      Gets an OutputStream for this file object.
      Reader openReader(boolean ignoreEncodingErrors)
      Gets a reader for this object.
      Writer openWriter()
      Gets a Writer for this file object.
      URI toUri()
      Returns a URI identifying this file object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • fileObject

        protected final F extends FileObject fileObject
        The file object which all methods are delegated to.

    • 构造方法详细信息

      • ForwardingFileObject

        protected ForwardingFileObject(F fileObject)
        Creates a new instance of ForwardingFileObject.
        参数：
        fileObject - delegate to this file object

    • 方法详细信息

      • toUri

        public URI toUri()
        从接口复制的描述： FileObject
        Returns a URI identifying this file object.
        指定者：
        toUri in interface FileObject
        返回：
        a URI

      • getName

        public String getName()
        从接口复制的描述： FileObject
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        指定者：
        getName in interface FileObject
        返回：
        a user-friendly name

      • openInputStream

        public InputStream openInputStream()
                            throws IOException
        从接口复制的描述： FileObject
        Gets an InputStream for this file object.
        指定者：
        openInputStream in interface FileObject
        返回：
        an InputStream
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openOutputStream

        public OutputStream openOutputStream()
                              throws IOException
        从接口复制的描述： FileObject
        Gets an OutputStream for this file object.
        指定者：
        openOutputStream in interface FileObject
        返回：
        an OutputStream
        抛出：
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support byte access
        IOException - if an I/O error occurred

      • openReader

        public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
        从接口复制的描述： FileObject
        Gets a reader for this object. The returned reader will replace bytes that cannot be decoded with the default translation character. In addition, the reader may report a diagnostic unless ignoreEncodingErrors is true.
        指定者：
        openReader in interface FileObject
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a Reader
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
        从接口复制的描述： FileObject
        Gets the character content of this file object, if available. Any byte that cannot be decoded will be replaced by the default translation character. In addition, a diagnostic may be reported unless ignoreEncodingErrors is true.
        指定者：
        getCharContent in interface FileObject
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a CharSequence if available; null otherwise
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • openWriter

        public Writer openWriter()
                  throws IOException
        从接口复制的描述： FileObject
        Gets a Writer for this file object.
        指定者：
        openWriter in interface FileObject
        返回：
        a Writer
        抛出：
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        public long getLastModified()
        从接口复制的描述： FileObject
        Gets the time this file object was last modified. The time is measured in milliseconds since the epoch (00:00:00 GMT, January 1, 1970).
        指定者：
        getLastModified in interface FileObject
        返回：
        the time this file object was last modified; or 0 if the file object does not exist, if an I/O error occurred, or if the operation is not supported

      • delete

        public boolean delete()
        从接口复制的描述： FileObject
        Deletes this file object. In case of errors, returns false.
        指定者：
        delete in interface FileObject
        返回：
        true if and only if this file object is successfully deleted; false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/sha>cmc pes/=.l"maaa.>aa__ifhdh"=a>l


ForwardingJavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.tools

类 ForwardingJavaFileManager<M extends JavaFileManager>

  • java.lang.Object
    • javax.tools.ForwardingJavaFileManager<M>
  • 类型参数：
    M - the kind of file manager forwarded to by this object
    所有已实现的接口：
    Closeable, Flushable, AutoCloseable, JavaFileManager, OptionChecker

    public class ForwardingJavaFileManager<M extends JavaFileManager>
extends Object
implements JavaFileManager
    Forwards calls to a given file manager. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileManager

        JavaFileManager.Location

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected M fileManager
      The file manager which all methods are delegated to.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ForwardingJavaFileManager(M fileManager)
      Creates a new instance of ForwardingJavaFileManager.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Releases any resources opened by this file manager directly or indirectly.
      void flush()
      Flushes any resources opened for output by this file manager directly or indirectly.
      ClassLoader getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      FileObject getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      JavaFileObject getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      boolean handleOption(String current, Iterator<String> remaining)
      Handles one option.
      boolean hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      String inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      int isSupportedOption(String option)
      Determines if the given option is supported and if so, the number of arguments the option takes.
      Iterable<JavaFileObject> list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • fileManager

        protected final M extends JavaFileManager fileManager
        The file manager which all methods are delegated to.

    • 构造方法详细信息

      • ForwardingJavaFileManager

        protected ForwardingJavaFileManager(M fileManager)
        Creates a new instance of ForwardingJavaFileManager.
        参数：
        fileManager - delegate to this file manager

    • 方法详细信息

      • getClassLoader

        public ClassLoader getClassLoader(JavaFileManager.Location location)
        从接口复制的描述： JavaFileManager
        Gets a class loader for loading plug-ins from the given location. For example, to load annotation processors, a compiler will request a class loader for the ANNOTATION_PROCESSOR_PATH location.
        指定者：
        getClassLoader in interface JavaFileManager
        参数：
        location - a location
        返回：
        a class loader for the given location; or null if loading plug-ins from the given location is disabled or if the location is not known
        抛出：
        SecurityException - if a class loader can not be created in the current security context
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • list

        public Iterable<JavaFileObject> list(JavaFileManager.Location location,
                            String packageName,
                            Set<JavaFileObject.Kind> kinds,
                            boolean recurse)
                              throws IOException
        从接口复制的描述： JavaFileManager
        Lists all file objects matching the given criteria in the given location. List file objects in "subpackages" if recurse is true.

        Note: even if the given location is unknown to this file manager, it may not return null. Also, an unknown location may not cause an exception.

        指定者：
        list in interface JavaFileManager
        参数：
        location - a location
        packageName - a package name
        kinds - return objects only of these kinds
        recurse - if true include "subpackages"
        返回：
        an Iterable of file objects matching the given criteria
        抛出：
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • inferBinaryName

        public String inferBinaryName(JavaFileManager.Location location,
                     JavaFileObject file)
        从接口复制的描述： JavaFileManager
        Infers a binary name of a file object based on a location. The binary name returned might not be a valid JLS binary name.
        指定者：
        inferBinaryName in interface JavaFileManager
        参数：
        location - a location
        file - a file object
        返回：
        a binary name or null the file object is not found in the given location
        抛出：
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • isSameFile

        public boolean isSameFile(FileObject a,
                 FileObject b)
        从接口复制的描述： JavaFileManager
        Compares two file objects and return true if they represent the same underlying object.
        指定者：
        isSameFile in interface JavaFileManager
        参数：
        a - a file object
        b - a file object
        返回：
        true if the given file objects represent the same underlying object
        抛出：
        IllegalArgumentException - if either of the arguments were created with another file manager and this file manager does not support foreign file objects

      • handleOption

        public boolean handleOption(String current,
                   Iterator<String> remaining)
        从接口复制的描述： JavaFileManager
        Handles one option. If current is an option to this file manager it will consume any arguments to that option from remaining and return true, otherwise return false.
        指定者：
        handleOption in interface JavaFileManager
        参数：
        current - current option
        remaining - remaining options
        返回：
        true if this option was handled by this file manager, false otherwise
        抛出：
        IllegalArgumentException - if this option to this file manager is used incorrectly
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened

      • hasLocation

        public boolean hasLocation(JavaFileManager.Location location)
        从接口复制的描述： JavaFileManager
        Determines if a location is known to this file manager.
        指定者：
        hasLocation in interface JavaFileManager
        参数：
        location - a location
        返回：
        true if the location is known

      • isSupportedOption

        public int isSupportedOption(String option)
        从接口复制的描述： OptionChecker
        Determines if the given option is supported and if so, the number of arguments the option takes.
        指定者：
        isSupportedOption in interface OptionChecker
        参数：
        option - an option
        返回：
        the number of arguments the given option takes or -1 if the option is not supported

      • getJavaFileForInput

        public JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                 String className,
                                 JavaFileObject.Kind kind)
                                   throws IOException
        从接口复制的描述： JavaFileManager
        Gets a file object for input representing the specified class of the specified kind in the given location.
        指定者：
        getJavaFileForInput in interface JavaFileManager
        参数：
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or 类
        返回：
        a file object, might return null if the file does not exist
        抛出：
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getJavaFileForOutput

        public JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                  String className,
                                  JavaFileObject.Kind kind,
                                  FileObject sibling)
                                    throws IOException
        从接口复制的描述： JavaFileManager
        Gets a file object for output representing the specified class of the specified kind in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        指定者：
        getJavaFileForOutput in interface JavaFileManager
        参数：
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or 类
        sibling - a file object to be used as hint for placement; might be null
        返回：
        a file object for output
        抛出：
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IllegalStateException - JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getFileForInput

        public FileObject getFileForInput(JavaFileManager.Location location,
                         String packageName,
                         String relativeName)
                           throws IOException
        从接口复制的描述： JavaFileManager
        Gets a file object for input representing the specified relative name in the specified package in the given location.

        If the returned object represents a source or 类 file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name. For example, to locate the properties file "resources/compiler.properties" in the package "com.sun.tools.javac" in the SOURCE_PATH location, this method might be called like so:

        getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

        If the call was executed on Windows, with SOURCE_PATH set to "C:\Documents and Settings\UncleBob\src\share\classes", a valid result would be a file object representing the file "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties".

        指定者：
        getFileForInput in interface JavaFileManager
        参数：
        location - a location
        packageName - a package name
        relativeName - a relative name
        返回：
        a file object, might return null if the file does not exist
        抛出：
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • getFileForOutput

        public FileObject getFileForOutput(JavaFileManager.Location location,
                          String packageName,
                          String relativeName,
                          FileObject sibling)
                            throws IOException
        从接口复制的描述： JavaFileManager
        Gets a file object for output representing the specified relative name in the specified package in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        If the returned object represents a source or 类 file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name or next to the sibling argument. See getFileForInput for an example.

        指定者：
        getFileForOutput in interface JavaFileManager
        参数：
        location - a location
        packageName - a package name
        relativeName - a relative name
        sibling - a file object to be used as hint for placement; might be null
        返回：
        a file object
        抛出：
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IllegalStateException - if JavaFileManager.close() has been called and this file manager cannot be reopened
        IOException - if an I/O error occurred, or if JavaFileManager.close() has been called and this file manager cannot be reopened

      • flush

        public void flush()
           throws IOException
        从接口复制的描述： JavaFileManager
        Flushes any resources opened for output by this file manager directly or indirectly. Flushing a closed file manager has no effect.
        指定者：
        flush in interface Flushable
        指定者：
        flush in interface JavaFileManager
        抛出：
        IOException - if an I/O error occurred
        另请参见：
        JavaFileManager.close()

      • close

        public void close()
           throws IOException
        从接口复制的描述： JavaFileManager
        Releases any resources opened by this file manager directly or indirectly. This might render this file manager useless and the effect of subsequent calls to methods on this object or any objects obtained through this object is undefined unless explicitly allowed. However, closing a file manager which has already been closed has no effect.
        指定者：
        close in interface Closeable
        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface JavaFileManager
        抛出：
        IOException - if an I/O error occurred
        另请参见：
        JavaFileManager.flush()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ForwardingJavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.tools

类 ForwardingJavaFileObject<F extends JavaFileObject>

  • java.lang.Object
    • javax.tools.ForwardingFileObject<F>
      • javax.tools.ForwardingJavaFileObject<F>
  • 类型参数：
    F - the kind of file object forwarded to by this object
    所有已实现的接口：
    FileObject, JavaFileObject

    public class ForwardingJavaFileObject<F extends JavaFileObject>
extends ForwardingFileObject<F>
implements JavaFileObject
    Forwards calls to a given file object. Subclasses of this class might override some of these methods and might also provide additional fields and methods.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileObject

        JavaFileObject.Kind

    • 字段摘要

      • Fields inherited from class javax.tools.ForwardingFileObject

        fileObject

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ForwardingJavaFileObject(F fileObject)
      Creates a new instance of ForwardingJavaFileObject.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      修饰符 getAccessLevel()
      Provides a hint about the access level of the class represented by this file object.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      NestingKind getNestingKind()
      Provides a hint about the nesting level of the class represented by this file object.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.

      • 方法 - 继承于类 javax.tools.ForwardingFileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.tools.FileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

    • 构造方法详细信息

      • ForwardingJavaFileObject

        protected ForwardingJavaFileObject(F fileObject)
        Creates a new instance of ForwardingJavaFileObject.
        参数：
        fileObject - delegate to this file object

    • 方法详细信息

      • getKind

        public JavaFileObject.Kind getKind()
        从接口复制的描述： JavaFileObject
        Gets the kind of this file object.
        指定者：
        getKind in interface JavaFileObject
        返回：
        the kind

      • isNameCompatible

        public boolean isNameCompatible(String simpleName,
                       JavaFileObject.Kind kind)
        从接口复制的描述： JavaFileObject
        Checks if this file object is compatible with the specified simple name and kind. A simple name is a single identifier (not qualified) as defined in the Java Language Specification 3rd ed., section 6.2 "Names and Identifiers".
        指定者：
        isNameCompatible in interface JavaFileObject
        参数：
        simpleName - a simple name of a class
        kind - a kind
        返回：
        true if this file object is compatible; false otherwise

      • getNestingKind

        public NestingKind getNestingKind()
        从接口复制的描述： JavaFileObject
        Provides a hint about the nesting level of the class represented by this file object. This method may return NestingKind.MEMBER to mean NestingKind.LOCAL or NestingKind.ANONYMOUS. If the nesting level is not known or this file object does not represent a class file this method returns null.
        指定者：
        getNestingKind in interface JavaFileObject
        返回：
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        public 修饰符 getAccessLevel()
        从接口复制的描述： JavaFileObject
        Provides a hint about the access level of the class represented by this file object. If the access level is not known or if this file object does not represent a class file this method returns null.
        指定者：
        getAccessLevel in interface JavaFileObject
        返回：
        the access level
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ollrsoCLoCtllCttmnsstddn trre>fn>g oo/nrti╠li></


JavaCompiler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface JavaCompiler

  • All Superinterfaces:
    OptionChecker, Tool

    public interface JavaCompiler
extends Tool, OptionChecker
    Interface to invoke Java™ programming language compilers from programs.

    The compiler might generate diagnostics during compilation (for example, error messages). If a diagnostic listener is provided, the diagnostics will be supplied to the listener. If no listener is provided, the diagnostics will be formatted in an unspecified format and written to the default output, which is System.err unless otherwise specified. Even if a diagnostic listener is supplied, some diagnostics might not fit in a Diagnostic and will be written to the default output.

    A compiler tool has an associated standard file manager, which is the file manager that is native to the tool (or built-in). The standard file manager can be obtained by calling getStandardFileManager.

    A compiler tool must function with any file manager as long as any additional requirements as detailed in the methods below are met. If no file manager is provided, the compiler tool will use a standard file manager such as the one returned by getStandardFileManager.

    An instance implementing this interface must conform to the Java Language Specification and generate class files conforming to the Java Virtual Machine specification. The versions of these specifications are defined in the Tool interface. Additionally, an instance of this interface supporting SourceVersion.RELEASE_6 or higher must also support annotation processing.

    The compiler relies on two services: diagnostic listener and file manager. Although most classes and interfaces in this package defines an API for compilers (and tools in general) the interfaces DiagnosticListener, JavaFileManager, FileObject, and JavaFileObject are not intended to be used in applications. Instead these interfaces are intended to be implemented and used to provide customized services for a compiler and thus defines an SPI for compilers.

    There are a number of classes and interfaces in this package which are designed to ease the implementation of the SPI to customize the behavior of a compiler:

    StandardJavaFileManager
    Every compiler which implements this interface provides a standard file manager for operating on regular files. The StandardJavaFileManager interface defines additional methods for creating file objects from regular files.

    The standard file manager serves two purposes:

    • basic building block for customizing how a compiler reads and writes files
    • sharing between multiple compilation tasks

    Reusing a file manager can potentially reduce overhead of scanning the file system and reading jar files. Although there might be no reduction in overhead, a standard file manager must work with multiple sequential compilations making the following example a recommended coding pattern:

           Files[] files1 = ... ; // input for first compilation task
       Files[] files2 = ... ; // input for second compilation task

       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
       StandardJavaFileManager fileManager = compiler.getStandardFileManager(null, null, null);

       Iterable<? extends JavaFileObject> compilationUnits1 =
           fileManager.getJavaFileObjectsFromFiles(Arrays.asList(files1));
       compiler.getTask(null, fileManager, null, null, null, compilationUnits1).call();

       Iterable<? extends JavaFileObject> compilationUnits2 =
           fileManager.getJavaFileObjects(files2); // use alternative method
       // reuse the same file manager to allow caching of jar files
       compiler.getTask(null, fileManager, null, null, null, compilationUnits2).call();

       fileManager.close();
    DiagnosticCollector
    Used to collect diagnostics in a list, for example:
           Iterable<? extends JavaFileObject> compilationUnits = ...;
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
       DiagnosticCollector<JavaFileObject> diagnostics = new DiagnosticCollector<JavaFileObject>();
       StandardJavaFileManager fileManager = compiler.getStandardFileManager(diagnostics, null, null);
       compiler.getTask(null, fileManager, diagnostics, null, null, compilationUnits).call();

       for (Diagnostic diagnostic : diagnostics.getDiagnostics())
           System.out.format("Error on line %d in %s%n",
                             diagnostic.getLineNumber(),
                             diagnostic.getSource().toUri());

       fileManager.close();
    ForwardingJavaFileManager, ForwardingFileObject, and ForwardingJavaFileObject
    Subclassing is not available for overriding the behavior of a standard file manager as it is created by calling a method on a compiler, not by invoking a constructor. Instead forwarding (or delegation) should be used. These classes makes it easy to forward most calls to a given file manager or file object while allowing customizing behavior. For example, consider how to log all calls to JavaFileManager.flush():
           final Logger logger = ...;
       Iterable<? extends JavaFileObject> compilationUnits = ...;
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
       StandardJavaFileManager stdFileManager = compiler.getStandardFileManager(null, null, null);
       JavaFileManager fileManager = new ForwardingJavaFileManager(stdFileManager) {
           public void flush() {
               logger.entering(StandardJavaFileManager.class.getName(), "flush");
               super.flush();
               logger.exiting(StandardJavaFileManager.class.getName(), "flush");
           }
       };
       compiler.getTask(null, fileManager, null, null, null, compilationUnits).call();
    SimpleJavaFileObject
    This class provides a basic file object implementation which can be used as building block for creating file objects. For example, here is how to define a file object which represent source code stored in a string:
           /**
        * A file object used to represent source coming from a string.
        */
       public class JavaSourceFromString extends SimpleJavaFileObject {
           /**
            * The source code of this "file".
            */
           final String code;

           /**
            * Constructs a new JavaSourceFromString.
            * @param name the name of the compilation unit represented by this file object
            * @param code the source code for the compilation unit represented by this file object
            */
           JavaSourceFromString(String name, String code) {
               super(URI.create("string:///" + name.replace('.','/') + Kind.SOURCE.extension),
                     Kind.SOURCE);
               this.code = code;
           }

           @Override
           public CharSequence getCharContent(boolean ignoreEncodingErrors) {
               return code;
           }
       }
    从以下版本开始：
    1.6
    另请参见：
    DiagnosticListener, Diagnostic, JavaFileManager

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static interface  JavaCompiler.CompilationTask
      Interface representing a future for a compilation task.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      JavaCompiler.CompilationTask getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.

      • 方法 - 继承于接口 javax.tools.Tool

        getSourceVersions, run

      • 方法 - 继承于接口 javax.tools.OptionChecker

        isSupportedOption

    • 方法详细信息

      • getTask

        JavaCompiler.CompilationTask getTask(Writer out,
                                   JavaFileManager fileManager,
                                   DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                   Iterable<String> options,
                                   Iterable<String> classes,
                                   Iterable<? extends JavaFileObject> compilationUnits)
        Creates a future for a compilation task with the given components and arguments. The compilation might not have completed as described in the CompilationTask interface.

        If a file manager is provided, it must be able to handle all locations defined in StandardLocation.

        Note that annotation processing can process both the compilation units of source code to be compiled, passed with the compilationUnits parameter, as well as class files, whose names are passed with the classes parameter.

        参数：
        out - a Writer for additional output from the compiler; use System.err if null
        fileManager - a file manager; if null use the compiler's standard filemanager
        diagnosticListener - a diagnostic listener; if null use the compiler's default method for reporting diagnostics
        options - compiler options, null means no options
        classes - names of classes to be processed by annotation processing, null means no class names
        compilationUnits - the compilation units to compile, null means no compilation units
        返回：
        an object representing the compilation
        抛出：
        RuntimeException - if an unrecoverable error occurred in a user supplied component. The cause will be the error in user code.
        IllegalArgumentException - if any of the given compilation units are of other kind than source

      • getStandardFileManager

        StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                             Locale locale,
                                             Charset charset)
        Gets a new instance of the standard file manager implementation for this tool. The file manager will use the given diagnostic listener for producing any non-fatal diagnostics. Fatal errors will be signalled with the appropriate exceptions.

        The standard file manager will be automatically reopened if it is accessed after calls to flush or close. The standard file manager must be usable with other tools.

        参数：
        diagnosticListener - a diagnostic listener for non-fatal diagnostics; if null use the compiler's default method for reporting diagnostics
        locale - the locale to apply when formatting diagnostics; null means the default locale.
        charset - the character set used for decoding bytes; if null use the platform default
        返回：
        the standard file manager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oLrs"s>stsnrtosc#ll|ebedsp s


JavaCompiler.CompilationTask

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface JavaCompiler.CompilationTask

  • All Superinterfaces:
    Callable<Boolean>
    Enclosing interface:
    JavaCompiler

    public static interface JavaCompiler.CompilationTask
extends Callable<Boolean>
    Interface representing a future for a compilation task. The compilation task has not yet started. To start the task, call the call method.

    Before calling the call method, additional aspects of the task can be configured, for example, by calling the setProcessors method.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Boolean call()
      Performs this compilation task.
      void setLocale(Locale locale)
      Set the locale to be applied when formatting diagnostics and other localized data.
      void setProcessors(Iterable<? extends Processor> processors)
      Sets processors (for annotation processing).

    • 方法详细信息

      • setProcessors

        void setProcessors(Iterable<? extends Processor> processors)
        Sets processors (for annotation processing). This will bypass the normal discovery mechanism.
        参数：
        processors - processors (for annotation processing)
        抛出：
        IllegalStateException - if the task has started

      • setLocale

        void setLocale(Locale locale)
        Set the locale to be applied when formatting diagnostics and other localized data.
        参数：
        locale - the locale to apply; null means apply no locale
        抛出：
        IllegalStateException - if the task has started

      • call

        Boolean call()
        Performs this compilation task. The compilation may only be performed once. Subsequent calls to this method throw IllegalStateException.
        指定者：
        call in interface Callable<Boolean>
        返回：
        true if and only all the files compiled without errors; false otherwise
        抛出：
        RuntimeException - if an unrecoverable error occurred in a user-supplied component. The cause will be the error in user code.
        IllegalStateException - if called more than once
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/pjr,<< <t)(


JavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface JavaFileManager

  • All Superinterfaces:
    AutoCloseable, Closeable, Flushable, OptionChecker
    All Known Subinterfaces:
    StandardJavaFileManager
    All Known Implementing Classes:
    ForwardingJavaFileManager

    public interface JavaFileManager
extends Closeable, Flushable, OptionChecker
    File manager for tools operating on Java™ programming language source and class files. In this context, file means an abstraction of regular files and other sources of data.

    When constructing new JavaFileObjects, the file manager must determine where to create them. For example, if a file manager manages regular files on a file system, it would most likely have a current/working directory to use as default location when creating or finding files. A number of hints can be provided to a file manager as to where to create files. Any file manager might choose to ignore these hints.

    Some methods in this interface use class names. Such class names must be given in the Java Virtual Machine internal form of fully qualified class and interface names. For convenience '.' and '/' are interchangeable. The internal form is defined in chapter four of the Java Virtual Machine Specification.

    Discussion: this means that the names "java/lang.package-info", "java/lang/package-info", "java.lang.package-info", are valid and equivalent. Compare to binary name as defined in the Java Language Specification (JLS) section 13.1 "The Form of a Binary".

    The case of names is significant. All names should be treated as case-sensitive. For example, some file systems have case-insensitive, case-aware file names. File objects representing such files should take care to preserve case by using File.getCanonicalFile() or similar means. If the system is not case-aware, file objects must use other means to preserve case.

    Relative names: some methods in this interface use relative names. A relative name is a non-null, non-empty sequence of path segments separated by '/'. '.' or '..' are invalid path segments. A valid relative name must match the "path-rootless" rule of RFC 3986, section 3.3. Informally, this should be true:

      URI.create(relativeName).normalize().getPath().equals(relativeName)

    All methods in this interface might throw a SecurityException.

    An object of this interface is not required to support multi-threaded access, that is, be synchronized. However, it must support concurrent access to different file objects created by this object.

    Implementation note: a consequence of this requirement is that a trivial implementation of output to a JarOutputStream is not a sufficient implementation. That is, rather than creating a JavaFileObject that returns the JarOutputStream directly, the contents must be cached until closed and then written to the JarOutputStream.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    从以下版本开始：
    1.6
    另请参见：
    JavaFileObject, FileObject

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static interface  JavaFileManager.Location
      Interface for locations of file objects.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Releases any resources opened by this file manager directly or indirectly.
      void flush()
      Flushes any resources opened for output by this file manager directly or indirectly.
      ClassLoader getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      FileObject getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      JavaFileObject getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      boolean handleOption(String current, Iterator<String> remaining)
      Handles one option.
      boolean hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      String inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      Iterable<JavaFileObject> list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.

      • 方法 - 继承于接口 javax.tools.OptionChecker

        isSupportedOption

    • 方法详细信息

      • getClassLoader

        ClassLoader getClassLoader(JavaFileManager.Location location)
        Gets a class loader for loading plug-ins from the given location. For example, to load annotation processors, a compiler will request a class loader for the ANNOTATION_PROCESSOR_PATH location.
        参数：
        location - a location
        返回：
        a class loader for the given location; or null if loading plug-ins from the given location is disabled or if the location is not known
        抛出：
        SecurityException - if a class loader can not be created in the current security context
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • list

        Iterable<JavaFileObject> list(JavaFileManager.Location location,
                            String packageName,
                            Set<JavaFileObject.Kind> kinds,
                            boolean recurse)
                              throws IOException
        Lists all file objects matching the given criteria in the given location. List file objects in "subpackages" if recurse is true.

        Note: even if the given location is unknown to this file manager, it may not return null. Also, an unknown location may not cause an exception.

        参数：
        location - a location
        packageName - a package name
        kinds - return objects only of these kinds
        recurse - if true include "subpackages"
        返回：
        an Iterable of file objects matching the given criteria
        抛出：
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • inferBinaryName

        String inferBinaryName(JavaFileManager.Location location,
                     JavaFileObject file)
        Infers a binary name of a file object based on a location. The binary name returned might not be a valid JLS binary name.
        参数：
        location - a location
        file - a file object
        返回：
        a binary name or null the file object is not found in the given location
        抛出：
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • isSameFile

        boolean isSameFile(FileObject a,
                 FileObject b)
        Compares two file objects and return true if they represent the same underlying object.
        参数：
        a - a file object
        b - a file object
        返回：
        true if the given file objects represent the same underlying object
        抛出：
        IllegalArgumentException - if either of the arguments were created with another file manager and this file manager does not support foreign file objects

      • handleOption

        boolean handleOption(String current,
                   Iterator<String> remaining)
        Handles one option. If current is an option to this file manager it will consume any arguments to that option from remaining and return true, otherwise return false.
        参数：
        current - current option
        remaining - remaining options
        返回：
        true if this option was handled by this file manager, false otherwise
        抛出：
        IllegalArgumentException - if this option to this file manager is used incorrectly
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • hasLocation

        boolean hasLocation(JavaFileManager.Location location)
        Determines if a location is known to this file manager.
        参数：
        location - a location
        返回：
        true if the location is known

      • getJavaFileForInput

        JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                 String className,
                                 JavaFileObject.Kind kind)
                                   throws IOException
        Gets a file object for input representing the specified class of the specified kind in the given location.
        参数：
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or 类
        返回：
        a file object, might return null if the file does not exist
        抛出：
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • getJavaFileForOutput

        JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                  String className,
                                  JavaFileObject.Kind kind,
                                  FileObject sibling)
                                    throws IOException
        Gets a file object for output representing the specified class of the specified kind in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        参数：
        location - a location
        className - the name of a class
        kind - the kind of file, must be one of SOURCE or 类
        sibling - a file object to be used as hint for placement; might be null
        返回：
        a file object for output
        抛出：
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if the kind is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - close() has been called and this file manager cannot be reopened

      • getFileForInput

        FileObject getFileForInput(JavaFileManager.Location location,
                         String packageName,
                         String relativeName)
                           throws IOException
        Gets a file object for input representing the specified relative name in the specified package in the given location.

        If the returned object represents a source or 类 file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name. For example, to locate the properties file "resources/compiler.properties" in the package "com.sun.tools.javac" in the SOURCE_PATH location, this method might be called like so:

        getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

        If the call was executed on Windows, with SOURCE_PATH set to "C:\Documents and Settings\UncleBob\src\share\classes", a valid result would be a file object representing the file "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties".

        参数：
        location - a location
        packageName - a package name
        relativeName - a relative name
        返回：
        a file object, might return null if the file does not exist
        抛出：
        IllegalArgumentException - if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • getFileForOutput

        FileObject getFileForOutput(JavaFileManager.Location location,
                          String packageName,
                          String relativeName,
                          FileObject sibling)
                            throws IOException
        Gets a file object for output representing the specified relative name in the specified package in the given location.

        Optionally, this file manager might consider the sibling as a hint for where to place the output. The exact semantics of this hint is unspecified. The JDK compiler, javac, for example, will place class files in the same directories as originating source files unless a class file output directory is provided. To facilitate this behavior, javac might provide the originating source file as sibling when calling this method.

        If the returned object represents a source or 类 file, it must be an instance of JavaFileObject.

        Informally, the file object returned by this method is located in the concatenation of the location, package name, and relative name or next to the sibling argument. See getFileForInput for an example.

        参数：
        location - a location
        packageName - a package name
        relativeName - a relative name
        sibling - a file object to be used as hint for placement; might be null
        返回：
        a file object
        抛出：
        IllegalArgumentException - if sibling is not known to this file manager, or if the location is not known to this file manager and the file manager does not support unknown locations, or if relativeName is not valid
        IOException - if an I/O error occurred, or if close() has been called and this file manager cannot be reopened
        IllegalStateException - if close() has been called and this file manager cannot be reopened

      • flush

        void flush()
           throws IOException
        Flushes any resources opened for output by this file manager directly or indirectly. Flushing a closed file manager has no effect.
        指定者：
        flush in interface Flushable
        抛出：
        IOException - if an I/O error occurred
        另请参见：
        close()

      • close

        void close()
           throws IOException
        Releases any resources opened by this file manager directly or indirectly. This might render this file manager useless and the effect of subsequent calls to methods on this object or any objects obtained through this object is undefined unless explicitly allowed. However, closing a file manager which has already been closed has no effect.
        指定者：
        close in interface AutoCloseable
        指定者：
        close in interface Closeable
        抛出：
        IOException - if an I/O error occurred
        另请参见：
        flush()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x


JavaFileManager.Location

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface JavaFileManager.Location

  • All Known Implementing Classes:
    StandardLocation
    Enclosing interface:
    JavaFileManager

    public static interface JavaFileManager.Location
    Interface for locations of file objects. Used by file managers to determine where to place or search for file objects.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Gets the name of this location.
      boolean isOutputLocation()
      Determines if this is an output location.

    • 方法详细信息

      • getName

        String getName()
        Gets the name of this location.
        返回：
        a name

      • isOutputLocation

        boolean isOutputLocation()
        Determines if this is an output location. An output location is a location that is conventionally used for output.
        返回：
        true if this is an output location, false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iton nsansseesssdnttbdmr aSr hn


JavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface JavaFileObject

  • All Superinterfaces:
    FileObject
    All Known Implementing Classes:
    ForwardingJavaFileObject, SimpleJavaFileObject

    public interface JavaFileObject
extends FileObject
    File abstraction for tools operating on Java™ programming language source and class files.

    All methods in this interface might throw a SecurityException if a security exception occurs.

    Unless explicitly allowed, all methods in this interface might throw a NullPointerException if given a null argument.

    从以下版本开始：
    1.6
    另请参见：
    JavaFileManager

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  JavaFileObject.Kind
      Kinds of JavaFileObjects.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      修饰符 getAccessLevel()
      Provides a hint about the access level of the class represented by this file object.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      NestingKind getNestingKind()
      Provides a hint about the nesting level of the class represented by this file object.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.

      • 方法 - 继承于接口 javax.tools.FileObject

        delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

    • 方法详细信息

      • getKind

        JavaFileObject.Kind getKind()
        Gets the kind of this file object.
        返回：
        the kind

      • isNameCompatible

        boolean isNameCompatible(String simpleName,
                       JavaFileObject.Kind kind)
        Checks if this file object is compatible with the specified simple name and kind. A simple name is a single identifier (not qualified) as defined in the Java Language Specification 3rd ed., section 6.2 "Names and Identifiers".
        参数：
        simpleName - a simple name of a class
        kind - a kind
        返回：
        true if this file object is compatible; false otherwise

      • getNestingKind

        NestingKind getNestingKind()
        Provides a hint about the nesting level of the class represented by this file object. This method may return NestingKind.MEMBER to mean NestingKind.LOCAL or NestingKind.ANONYMOUS. If the nesting level is not known or this file object does not represent a class file this method returns null.
        返回：
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        修饰符 getAccessLevel()
        Provides a hint about the access level of the class represented by this file object. If the access level is not known or if this file object does not represent a class file this method returns null.
        返回：
        the access level
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ecenardeirei /l,oo.to ">M/Fs


JavaFileObject.Kind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.tools

Enum JavaFileObject.Kind

  • java.lang.Object
    • java.lang.Enum<JavaFileObject.Kind>
      • javax.tools.JavaFileObject.Kind
  • 所有已实现的接口：
    Serializable, Comparable<JavaFileObject.Kind>
    Enclosing interface:
    JavaFileObject

    public static enum JavaFileObject.Kind
extends Enum<JavaFileObject.Kind>
    Kinds of JavaFileObjects.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      类
      Class files for the Java Virtual Machine.
      HTML
      HTML files.
      OTHER
      Any other kind.
      SOURCE
      Source files written in the Java programming language.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String extension
      The extension which (by convention) is normally used for this kind of file object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static JavaFileObject.Kind valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JavaFileObject.Kind[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • SOURCE

        public static final JavaFileObject.Kind SOURCE
        Source files written in the Java programming language. For example, regular files ending with .java.

      • 类

        public static final JavaFileObject.Kind CLASS
        Class files for the Java Virtual Machine. For example, regular files ending with .class.

      • HTML

        public static final JavaFileObject.Kind HTML
        HTML files. For example, regular files ending with .html.

      • OTHER

        public static final JavaFileObject.Kind OTHER
        Any other kind.

    • 字段详细信息

      • extension

        public final String extension
        The extension which (by convention) is normally used for this kind of file object. If no convention exists, the empty string ("") is used.

    • 方法详细信息

      • values

        public static JavaFileObject.Kind[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (JavaFileObject.Kind c : JavaFileObject.Kind.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static JavaFileObject.Kind valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x&t/rfIab>"II>"> ec/l/<.


javax.tools

Interfaces

  • Diagnostic
  • DiagnosticListener
  • FileObject
  • JavaCompiler
  • JavaCompiler.CompilationTask
  • JavaFileManager
  • JavaFileManager.Location
  • JavaFileObject
  • OptionChecker
  • StandardJavaFileManager
  • Tool

Classes

  • DiagnosticCollector
  • ForwardingFileObject
  • ForwardingJavaFileManager
  • ForwardingJavaFileObject
  • SimpleJavaFileObject
  • ToolProvider

Enums

  • Diagnostic.Kind
  • JavaFileObject.Kind
  • StandardLocation
=


javax.tools

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.tools

Provides interfaces for tools which can be invoked from a program, for example, compilers.

请参见： 描述

  • 接口摘要
    接口 描述
    Diagnostic<S>
    Interface for diagnostics from tools.
    DiagnosticListener<S>
    Interface for receiving diagnostics from tools.
    FileObject
    File abstraction for tools.
    JavaCompiler
    Interface to invoke Java™ programming language compilers from programs.
    JavaCompiler.CompilationTask
    Interface representing a future for a compilation task.
    JavaFileManager
    File manager for tools operating on Java™ programming language source and class files.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
    OptionChecker
    Interface for recognizing options.
    StandardJavaFileManager
    File manager based on java.io.File.
    Tool
    Common interface for tools that can be invoked from a program.
  • Class Summary
    类 描述
    DiagnosticCollector<S>
    Provides an easy way to collect diagnostics in a list.
    ForwardingFileObject<F extends FileObject>
    Forwards calls to a given file object.
    ForwardingJavaFileManager<M extends JavaFileManager>
    Forwards calls to a given file manager.
    ForwardingJavaFileObject<F extends JavaFileObject>
    Forwards calls to a given file object.
    SimpleJavaFileObject
    Provides simple implementations for most methods in JavaFileObject.
    ToolProvider
    Provides methods for locating tool providers, for example, providers of compilers.
  • Enum Summary
    Enum 描述
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    JavaFileObject.Kind
    Kinds of JavaFileObjects.
    StandardLocation
    Standard locations of file objects.

软件包 javax.tools Description

Provides interfaces for tools which can be invoked from a program, for example, compilers.

These interfaces and classes are required as part of the Java™ Platform, Standard Edition (Java SE), but there is no requirement to provide any tools implementing them.

Unless explicitly allowed, all methods in this package might throw a NullPointerException if given a null argument or if given a list or collection containing null elements. Similarly, no method may return null unless explicitly allowed.

This package is the home of the Java programming language compiler framework. This framework allows clients of the framework to locate and run compilers from programs. The framework also provides Service Provider Interfaces (SPI) for structured access to diagnostics (DiagnosticListener) as well as a file abstraction for overriding file access (JavaFileManager and JavaFileObject). See JavaCompiler for more details on using the SPI.

There is no requirement for a compiler at runtime. However, if a default compiler is provided, it can be located using the ToolProvider, for example:

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();

It is possible to provide alternative compilers or tools through the service provider mechanism.

For example, if com.vendor.VendorJavaCompiler is a provider of the JavaCompiler tool then its jar file would contain the file META-INF/services/javax.tools.JavaCompiler. This file would contain the single line:

com.vendor.VendorJavaCompiler

If the jar file is on the class path, VendorJavaCompiler can be located using code like this:

JavaCompiler compiler = ServiceLoader.load(JavaCompiler.class).iterator().next();

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tatrnsam>tii"_anovbs<-


javax.tools Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.tools

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.tools.ToolProvider

Interface Hierarchy

  • java.lang.AutoCloseable
    • java.io.Closeable
      • javax.tools.JavaFileManager (also extends java.io.Flushable, javax.tools.OptionChecker)
        • javax.tools.StandardJavaFileManager
  • java.util.concurrent.Callable<V>
    • javax.tools.JavaCompiler.CompilationTask
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • java.io.Flushable
    • javax.tools.JavaFileManager (also extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
  • javax.tools.JavaFileManager.Location
  • javax.tools.OptionChecker
    • javax.tools.JavaCompiler (also extends javax.tools.Tool)
    • javax.tools.JavaFileManager (also extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
  • javax.tools.Tool
    • javax.tools.JavaCompiler (also extends javax.tools.OptionChecker)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.JavaFileObject.Kind
      • javax.tools.Diagnostic.Kind
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_B= =-!--->l>>x(sst<


OptionChecker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface OptionChecker

  • All Known Subinterfaces:
    JavaCompiler, JavaFileManager, StandardJavaFileManager
    All Known Implementing Classes:
    ForwardingJavaFileManager

    public interface OptionChecker
    Interface for recognizing options.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int isSupportedOption(String option)
      Determines if the given option is supported and if so, the number of arguments the option takes.

    • 方法详细信息

      • isSupportedOption

        int isSupportedOption(String option)
        Determines if the given option is supported and if so, the number of arguments the option takes.
        参数：
        option - an option
        返回：
        the number of arguments the given option takes or -1 if the option is not supported
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fO=aln)on)("")((cujjEmaE/aauvvni )


SimpleJavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.tools

类 SimpleJavaFileObject

  • java.lang.Object
    • javax.tools.SimpleJavaFileObject
  • 所有已实现的接口：
    FileObject, JavaFileObject

    public class SimpleJavaFileObject
extends Object
implements JavaFileObject
    Provides simple implementations for most methods in JavaFileObject. This class is designed to be subclassed and used as a basis for JavaFileObject implementations. Subclasses can override the implementation and specification of any method of this class as long as the general contract of JavaFileObject is obeyed.
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileObject

        JavaFileObject.Kind

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected JavaFileObject.Kind kind
      The kind of this file object.
      protected URI uri
      A URI for this file object.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
      Construct a SimpleJavaFileObject of the given kind and with the given URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean delete()
      This implementation does nothing.
      修饰符 getAccessLevel()
      This implementation returns null.
      CharSequence getCharContent(boolean ignoreEncodingErrors)
      This implementation always throws UnsupportedOperationException.
      JavaFileObject.Kind getKind()
      Gets the kind of this file object.
      long getLastModified()
      This implementation returns 0L.
      String getName()
      Gets a user-friendly name for this file object.
      NestingKind getNestingKind()
      This implementation returns null.
      boolean isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      This implementation compares the path of its URI to the given simple name.
      InputStream openInputStream()
      This implementation always throws UnsupportedOperationException.
      OutputStream openOutputStream()
      This implementation always throws UnsupportedOperationException.
      Reader openReader(boolean ignoreEncodingErrors)
      Wraps the result of getCharContent(boolean) in a Reader.
      Writer openWriter()
      Wraps the result of openOutputStream in a Writer.
      String toString()
      Returns a string representation of the object.
      URI toUri()
      Returns a URI identifying this file object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • uri

        protected final URI uri
        A URI for this file object.

      • kind

        protected final JavaFileObject.Kind kind
        The kind of this file object.

    • 构造方法详细信息

      • SimpleJavaFileObject

        protected SimpleJavaFileObject(URI uri,
                    JavaFileObject.Kind kind)
        Construct a SimpleJavaFileObject of the given kind and with the given URI.
        参数：
        uri - the URI for this file object
        kind - the kind of this file object

    • 方法详细信息

      • toUri

        public URI toUri()
        从接口复制的描述： FileObject
        Returns a URI identifying this file object.
        指定者：
        toUri in interface FileObject
        返回：
        a URI

      • getName

        public String getName()
        从接口复制的描述： FileObject
        Gets a user-friendly name for this file object. The exact value returned is not specified but implementations should take care to preserve names as given by the user. For example, if the user writes the filename "BobsApp\Test.java" on the command line, this method should return "BobsApp\Test.java" whereas the toUri method might return file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java.
        指定者：
        getName in interface FileObject
        返回：
        a user-friendly name

      • openInputStream

        public InputStream openInputStream()
                            throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        openInputStream in interface FileObject
        返回：
        an InputStream
        抛出：
        IOException - if an I/O error occurred

      • openOutputStream

        public OutputStream openOutputStream()
                              throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        openOutputStream in interface FileObject
        返回：
        an OutputStream
        抛出：
        IOException - if an I/O error occurred

      • openReader

        public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
        Wraps the result of getCharContent(boolean) in a Reader. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        openReader in interface FileObject
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a Reader wrapping the result of getCharContent
        抛出：
        IllegalStateException - if this file object was opened for writing and does not support reading
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getCharContent

        public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
        This implementation always throws UnsupportedOperationException. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        getCharContent in interface FileObject
        参数：
        ignoreEncodingErrors - ignore encoding errors if true
        返回：
        a CharSequence if available; null otherwise
        抛出：
        IOException - if an I/O error occurred

      • openWriter

        public Writer openWriter()
                  throws IOException
        Wraps the result of openOutputStream in a Writer. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        openWriter in interface FileObject
        返回：
        a Writer wrapping the result of openOutputStream
        抛出：
        IllegalStateException - if this file object was opened for reading and does not support writing
        UnsupportedOperationException - if this kind of file object does not support character access
        IOException - if an I/O error occurred

      • getLastModified

        public long getLastModified()
        This implementation returns 0L. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        getLastModified in interface FileObject
        返回：
        0L

      • delete

        public boolean delete()
        This implementation does nothing. Subclasses can change this behavior as long as the contract of FileObject is obeyed.
        指定者：
        delete in interface FileObject
        返回：
        false

      • getKind

        public JavaFileObject.Kind getKind()
        从接口复制的描述： JavaFileObject
        Gets the kind of this file object.
        指定者：
        getKind in interface JavaFileObject
        返回：
        this.kind

      • isNameCompatible

        public boolean isNameCompatible(String simpleName,
                       JavaFileObject.Kind kind)
        This implementation compares the path of its URI to the given simple name. This method returns true if the given kind is equal to the kind of this object, and if the path is equal to simpleName + kind.extension or if it ends with "/" + simpleName + kind.extension.

        This method calls getKind() and toUri() and does not access the fields uri and kind directly.

        Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.

        指定者：
        isNameCompatible in interface JavaFileObject
        参数：
        simpleName - a simple name of a class
        kind - a kind
        返回：
        true if this file object is compatible; false otherwise

      • getNestingKind

        public NestingKind getNestingKind()
        This implementation returns null. Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.
        指定者：
        getNestingKind in interface JavaFileObject
        返回：
        the nesting kind, or null if the nesting kind is not known

      • getAccessLevel

        public 修饰符 getAccessLevel()
        This implementation returns null. Subclasses can change this behavior as long as the contract of JavaFileObject is obeyed.
        指定者：
        getAccessLevel in interface JavaFileObject
        返回：
        the access level

      • toString

        public String toString()
        Description copied from class: Object
        Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

        The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character `@', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

         getClass().getName() + '@' + Integer.toHexString(hashCode())
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


StandardJavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface StandardJavaFileManager

  • All Superinterfaces:
    AutoCloseable, Closeable, Flushable, JavaFileManager, OptionChecker

    public interface StandardJavaFileManager
extends JavaFileManager
    File manager based on java.io.File. A common way to obtain an instance of this class is using getStandardFileManager, for example:
       JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
   DiagnosticCollector<JavaFileObject> diagnostics =
       new DiagnosticCollector<JavaFileObject>();
   StandardJavaFileManager fm = compiler.getStandardFileManager(diagnostics, null, null);
    This file manager creates file objects representing regular files, zip file entries, or entries in similar file system based containers. Any file object returned from a file manager implementing this interface must observe the following behavior:
    • File names need not be canonical.
    • For file objects representing regular files
      • the method FileObject.delete() is equivalent to File.delete(),
      • the method FileObject.getLastModified() is equivalent to File.lastModified(),
      • the methods FileObject.getCharContent(boolean), FileObject.openInputStream(), and FileObject.openReader(boolean) must succeed if the following would succeed (ignoring encoding issues):
        new FileInputStream(new File(fileObject.toUri()))
      • and the methods FileObject.openOutputStream(), and FileObject.openWriter() must succeed if the following would succeed (ignoring encoding issues):
        new FileOutputStream(new File(fileObject.toUri()))
    • The URI returned from FileObject.toUri()
      • must be absolute (have a schema), and
      • must have a normalized path component which can be resolved without any process-specific context such as the current directory (file names must be absolute).
    According to these rules, the following URIs, for example, are allowed:
    • file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java
    • jar:///C:/Documents%20and%20Settings/UncleBob/lib/vendorA.jar!com/vendora/LibraryClass.class
    Whereas these are not (reason in parentheses):
    • file:BobsApp/Test.java (the file name is relative and depend on the current directory)
    • jar:lib/vendorA.jar!com/vendora/LibraryClass.class (the first half of the path depends on the current directory, whereas the component after ! is legal)
    • Test.java (this URI depends on the current directory and does not have a schema)
    • jar:///C:/Documents%20and%20Settings/UncleBob/BobsApp/../lib/vendorA.jar!com/vendora/LibraryClass.class (the path is not normalized)
    从以下版本开始：
    1.6

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.tools.JavaFileManager

        JavaFileManager.Location

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Iterable<? extends JavaFileObject> getJavaFileObjects(File... files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> getJavaFileObjects(String... names)
      Gets file objects representing the given file names.
      Iterable<? extends JavaFileObject> getJavaFileObjectsFromFiles(Iterable<? extends File> files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> getJavaFileObjectsFromStrings(Iterable<String> names)
      Gets file objects representing the given file names.
      Iterable<? extends File> getLocation(JavaFileManager.Location location)
      Gets the path associated with the given location.
      boolean isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
      void setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
      Associates the given path with the given location.

      • 方法 - 继承于接口 javax.tools.JavaFileManager

        close, flush, getClassLoader, getFileForInput, getFileForOutput, getJavaFileForInput, getJavaFileForOutput, handleOption, hasLocation, inferBinaryName, list

      • 方法 - 继承于接口 javax.tools.OptionChecker

        isSupportedOption

    • 方法详细信息

      • isSameFile

        boolean isSameFile(FileObject a,
                 FileObject b)
        Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
        指定者：
        isSameFile in interface JavaFileManager
        参数：
        a - a file object
        b - a file object
        返回：
        true if the given file objects represent the same canonical file or zip file entry; false otherwise
        抛出：
        IllegalArgumentException - if either of the arguments were created with another file manager implementation

      • getJavaFileObjectsFromFiles

        Iterable<? extends JavaFileObject> getJavaFileObjectsFromFiles(Iterable<? extends File> files)
        Gets file objects representing the given files.
        参数：
        files - a list of files
        返回：
        a list of file objects
        抛出：
        IllegalArgumentException - if the list of files includes a directory

      • getJavaFileObjects

        Iterable<? extends JavaFileObject> getJavaFileObjects(File... files)
        Gets file objects representing the given files. Convenience method equivalent to:
             getJavaFileObjectsFromFiles(Arrays.asList(files))
        参数：
        files - an array of files
        返回：
        a list of file objects
        抛出：
        IllegalArgumentException - if the array of files includes a directory
        NullPointerException - if the given array contains null elements

      • getJavaFileObjectsFromStrings

        Iterable<? extends JavaFileObject> getJavaFileObjectsFromStrings(Iterable<String> names)
        Gets file objects representing the given file names.
        参数：
        names - a list of file names
        返回：
        a list of file objects
        抛出：
        IllegalArgumentException - if the list of file names includes a directory

      • getJavaFileObjects

        Iterable<? extends JavaFileObject> getJavaFileObjects(String... names)
        Gets file objects representing the given file names. Convenience method equivalent to:
             getJavaFileObjectsFromStrings(Arrays.asList(names))
        参数：
        names - a list of file names
        返回：
        a list of file objects
        抛出：
        IllegalArgumentException - if the array of file names includes a directory
        NullPointerException - if the given array contains null elements

      • setLocation

        void setLocation(JavaFileManager.Location location,
               Iterable<? extends File> path)
                 throws IOException
        Associates the given path with the given location. Any previous value will be discarded.
        参数：
        location - a location
        path - a list of files, if null use the default path for this location
        抛出：
        IllegalArgumentException - if location is an output location and path does not contain exactly one element
        IOException - if location is an output location and path does not represent an existing directory
        另请参见：
        getLocation(javax.tools.JavaFileManager.Location)

      • getLocation

        Iterable<? extends File> getLocation(JavaFileManager.Location location)
        Gets the path associated with the given location.
        参数：
        location - a location
        返回：
        a list of files or null if this location has no associated path
        另请参见：
        setLocation(javax.tools.JavaFileManager.Location, java.lang.Iterable)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"he oqtoqeuuqee vuuertmoh ssvah t ge


StandardLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.tools

Enum StandardLocation

  • java.lang.Object
    • java.lang.Enum<StandardLocation>
      • javax.tools.StandardLocation
  • 所有已实现的接口：
    Serializable, Comparable<StandardLocation>, JavaFileManager.Location

    public enum StandardLocation
extends Enum<StandardLocation>
implements JavaFileManager.Location
    Standard locations of file objects.
    从以下版本开始：
    1.6

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ANNOTATION_PROCESSOR_PATH
      Location to search for annotation processors.
      CLASS_OUTPUT
      Location of new class files.
      CLASS_PATH
      Location to search for user class files.
      PLATFORM_CLASS_PATH
      Location to search for platform classes.
      SOURCE_OUTPUT
      Location of new source files.
      SOURCE_PATH
      Location to search for existing source files.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Gets the name of this location.
      boolean isOutputLocation()
      Determines if this is an output location.
      static JavaFileManager.Location locationFor(String name)
      Gets a location object with the given name.
      static StandardLocation valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static StandardLocation[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • CLASS_OUTPUT

        public static final StandardLocation CLASS_OUTPUT
        Location of new class files.

      • SOURCE_OUTPUT

        public static final StandardLocation SOURCE_OUTPUT
        Location of new source files.

      • CLASS_PATH

        public static final StandardLocation CLASS_PATH
        Location to search for user class files.

      • SOURCE_PATH

        public static final StandardLocation SOURCE_PATH
        Location to search for existing source files.

      • ANNOTATION_PROCESSOR_PATH

        public static final StandardLocation ANNOTATION_PROCESSOR_PATH
        Location to search for annotation processors.

      • PLATFORM_CLASS_PATH

        public static final StandardLocation PLATFORM_CLASS_PATH
        Location to search for platform classes. Sometimes called the boot class path.

    • 方法详细信息

      • values

        public static StandardLocation[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (StandardLocation c : StandardLocation.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static StandardLocation valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null

      • locationFor

        public static JavaFileManager.Location locationFor(String name)
        Gets a location object with the given name. The following property must hold: locationFor(x) == locationFor(y) if and only if x.equals(y). The returned location will be an output location if and only if name ends with "_OUTPUT".
        参数：
        name - a name
        返回：
        a location

      • getName

        public String getName()
        从接口复制的描述： JavaFileManager.Location
        Gets the name of this location.
        指定者：
        getName in interface JavaFileManager.Location
        返回：
        a name

      • isOutputLocation

        public boolean isOutputLocation()
        从接口复制的描述： JavaFileManager.Location
        Determines if this is an output location. An output location is a location that is conventionally used for output.
        指定者：
        isOutputLocation in interface JavaFileManager.Location
        返回：
        true if this is an output location, false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< del fe fo fooltssoddocd>dete><齮toir


Tool

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

Interface Tool

  • All Known Subinterfaces:
    JavaCompiler

    public interface Tool
    Common interface for tools that can be invoked from a program. A tool is traditionally a command line program such as a compiler. The set of tools available with a platform is defined by the vendor.

    Tools can be located using ServiceLoader.load(Class).

    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Set<SourceVersion> getSourceVersions()
      Gets the source versions of the Java™ programming language supported by this tool.
      int run(InputStream in, OutputStream out, OutputStream err, String... arguments)
      Run the tool with the given I/O channels and arguments.

    • 方法详细信息

      • run

        int run(InputStream in,
      OutputStream out,
      OutputStream err,
      String... arguments)
        Run the tool with the given I/O channels and arguments. By convention a tool returns 0 for success and nonzero for errors. Any diagnostics generated will be written to either out or err in some unspecified format.
        参数：
        in - "standard" input; use System.in if null
        out - "standard" output; use System.out if null
        err - "standard" error; use System.err if null
        arguments - arguments to pass to the tool
        返回：
        0 for success; nonzero otherwise
        抛出：
        NullPointerException - if the array of arguments contains any null elements.

      • getSourceVersions

        Set<SourceVersion> getSourceVersions()
        Gets the source versions of the Java™ programming language supported by this tool.
        返回：
        a set of supported source versions
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v>a=ah> h>a,,>aaaabba/.avetnbbn.l>c


ToolProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.tools

类 ToolProvider

  • java.lang.Object
    • javax.tools.ToolProvider

  • public class ToolProvider
extends Object
    Provides methods for locating tool providers, for example, providers of compilers. This class complements the functionality of ServiceLoader.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static JavaCompiler getSystemJavaCompiler()
      Gets the Java™ programming language compiler provided with this platform.
      static ClassLoader getSystemToolClassLoader()
      Returns the class loader for tools provided with this platform.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • getSystemJavaCompiler

        public static JavaCompiler getSystemJavaCompiler()
        Gets the Java™ programming language compiler provided with this platform.
        返回：
        the compiler provided with this platform or null if no compiler is provided

      • getSystemToolClassLoader

        public static ClassLoader getSystemToolClassLoader()
        Returns the class loader for tools provided with this platform. This does not include user-installed tools. Use the service provider mechanism for locating user installed tools.
        返回：
        the class loader for tools provided with this platform or null if no tools are provided
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e ddmdsdld tile erd襛Jg">n>a�" lEJ�


Uses of Package javax.tools

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.tools

  • Packages that use javax.tools
    软件包 描述
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.
  • Classes in javax.tools used by javax.annotation.processing
    类与描述
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    FileObject
    File abstraction for tools.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
  • Classes in javax.tools used by javax.tools
    类与描述
    Diagnostic
    Interface for diagnostics from tools.
    Diagnostic.Kind
    Kinds of diagnostics, for example, error or warning.
    DiagnosticListener
    Interface for receiving diagnostics from tools.
    FileObject
    File abstraction for tools.
    ForwardingFileObject
    Forwards calls to a given file object.
    JavaCompiler
    Interface to invoke Java™ programming language compilers from programs.
    JavaCompiler.CompilationTask
    Interface representing a future for a compilation task.
    JavaFileManager
    File manager for tools operating on Java™ programming language source and class files.
    JavaFileManager.Location
    Interface for locations of file objects.
    JavaFileObject
    File abstraction for tools operating on Java™ programming language source and class files.
    JavaFileObject.Kind
    Kinds of JavaFileObjects.
    OptionChecker
    Interface for recognizing options.
    StandardJavaFileManager
    File manager based on java.io.File.
    StandardLocation
    Standard locations of file objects.
    Tool
    Common interface for tools that can be invoked from a program.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ot/."."=...elvvs


Uses of Class javax.tools.Diagnostic.Kind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.Diagnostic.Kind

  • Packages that use Diagnostic.Kind
    软件包 描述
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Diagnostic.Kind in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type Diagnostic.Kind
      修饰符与类型 方法与描述
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg)
      Prints a message of the specified kind.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e)
      Prints a message of the specified kind at the location of the element.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a)
      Prints a message of the specified kind at the location of the annotation mirror of the annotated element.
      void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
      Prints a message of the specified kind at the location of the annotation value inside the annotation mirror of the annotated element.

    • Uses of Diagnostic.Kind in javax.tools

      Methods in javax.tools that return Diagnostic.Kind
      修饰符与类型 方法与描述
      Diagnostic.Kind Diagnostic.getKind()
      Gets the kind of this diagnostic, for example, error or warning.
      static Diagnostic.Kind Diagnostic.Kind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Diagnostic.Kind[] Diagnostic.Kind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

inaO">Aenia a d.穕t罚au


Uses of Class javax.tools.DiagnosticCollector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.DiagnosticCollector

No usage of javax.tools.DiagnosticCollector
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h


Uses of Class javax.tools.ForwardingFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.ForwardingFileObject

  • Packages that use ForwardingFileObject
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of ForwardingFileObject in javax.tools

      Subclasses of ForwardingFileObject in javax.tools
      修饰符与类型 类与描述
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vsa.ref< aaayetth/=.v/e j


Uses of Class javax.tools.ForwardingJavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.ForwardingJavaFileManager

No usage of javax.tools.ForwardingJavaFileManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

F.ia/Footoooa.aaa>.rh


Uses of Class javax.tools.ForwardingJavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.ForwardingJavaFileObject

No usage of javax.tools.ForwardingJavaFileObject
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ra>l.aoo/鋙i.om


Uses of Class javax.tools.JavaFileObject.Kind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.JavaFileObject.Kind

  • Packages that use JavaFileObject.Kind
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileObject.Kind in javax.tools

      Fields in javax.tools declared as JavaFileObject.Kind
      修饰符与类型 字段与描述
      protected JavaFileObject.Kind SimpleJavaFileObject.kind
      The kind of this file object.
      Methods in javax.tools that return JavaFileObject.Kind
      修饰符与类型 | 方法与描述
      JavaFileObject.Kind | SimpleJavaFileObject.getKind()
      JavaFileObject.Kind JavaFileObject.getKind()
      Gets the kind of this file object.
      JavaFileObject.Kind | ForwardingJavaFileObject.getKind()
      static JavaFileObject.Kind JavaFileObject.Kind.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static JavaFileObject.Kind[] JavaFileObject.Kind.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.tools with parameters of type JavaFileObject.Kind
      修饰符与类型 | 方法与描述
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      boolean SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      This implementation compares the path of its URI to the given simple name.
      boolean JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Checks if this file object is compatible with the specified simple name and kind.
      boolean | ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
      Method parameters in javax.tools with type arguments of type JavaFileObject.Kind
      修饰符与类型 | 方法与描述
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Constructors in javax.tools with parameters of type JavaFileObject.Kind
      构造方法与描述
      SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
      Construct a SimpleJavaFileObject of the given kind and with the given URI.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lks//..=f"""h ,,sriF="erao


Uses of Class javax.tools.SimpleJavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.SimpleJavaFileObject

No usage of javax.tools.SimpleJavaFileObject
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"i>ae irefffi aaLsdtr


Uses of Class javax.tools.StandardLocation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.StandardLocation

  • Packages that use StandardLocation
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of StandardLocation in javax.tools

      Methods in javax.tools that return StandardLocation
      修饰符与类型 方法与描述
      static StandardLocation StandardLocation.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static StandardLocation[] StandardLocation.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shbl. .sb>ae. ce." e..e;


Uses of Class javax.tools.ToolProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.tools.ToolProvider

No usage of javax.tools.ToolProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eT.-trkcaaa/h//f=aee


Uses of Interface javax.tools.Diagnostic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.Diagnostic

  • Packages that use Diagnostic
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Diagnostic in javax.tools

      Methods in javax.tools that return types with arguments of type Diagnostic
      修饰符与类型 方法与描述
      List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
      Gets a list view of diagnostics collected by this object.
      Methods in javax.tools with parameters of type Diagnostic
      修饰符与类型 | 方法与描述
      void DiagnosticListener.report(Diagnostic<? extends S> diagnostic)
      Invoked when a problem is found.
      void | DiagnosticCollector.report(Diagnostic<? extends S> diagnostic)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gaeb sable


Uses of Interface javax.tools.DiagnosticListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.DiagnosticListener

  • Packages that use DiagnosticListener
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of DiagnosticListener in javax.tools

      Classes in javax.tools that implement DiagnosticListener
      修饰符与类型 类与描述
      class  DiagnosticCollector<S>
      Provides an easy way to collect diagnostics in a list.
      Methods in javax.tools with parameters of type DiagnosticListener
      修饰符与类型 方法与描述
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tAlatsnibena>oactocc


Uses of Interface javax.tools.FileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.FileObject

  • Packages that use FileObject
    软件包 描述
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of FileObject in javax.annotation.processing

      Methods in javax.annotation.processing that return FileObject
      修饰符与类型 方法与描述
      FileObject Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements)
      Creates a new auxiliary resource file for writing and returns a file object for it.
      FileObject Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName)
      Returns an object for reading an existing resource.

    • Uses of FileObject in javax.tools

      Classes in javax.tools with type parameters of type FileObject
      修饰符与类型 类与描述
      class  ForwardingFileObject<F extends FileObject>
      Forwards calls to a given file object.
      Subinterfaces of FileObject in javax.tools
      修饰符与类型 Interface and Description
      interface  JavaFileObject
      File abstraction for tools operating on Java™ programming language source and class files.
      Classes in javax.tools that implement FileObject
      修饰符与类型 类与描述
      class  ForwardingFileObject<F extends FileObject>
      Forwards calls to a given file object.
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      class  SimpleJavaFileObject
      Provides simple implementations for most methods in JavaFileObject.
      Fields in javax.tools declared as FileObject
      修饰符与类型 字段与描述
      protected F ForwardingFileObject.fileObject
      The file object which all methods are delegated to.
      Methods in javax.tools that return FileObject
      修饰符与类型 | 方法与描述
      FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Methods in javax.tools with parameters of type FileObject
      修饰符与类型 | 方法与描述
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      boolean StandardJavaFileManager.isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
      boolean JavaFileManager.isSameFile(FileObject a, FileObject b)
      Compares two file objects and return true if they represent the same underlying object.
      boolean | ForwardingJavaFileManager.isSameFile(FileObject a, FileObject b)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

po"s"neecppurgeed=;aEc/


Uses of Interface javax.tools.JavaCompiler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.JavaCompiler

  • Packages that use JavaCompiler
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaCompiler in javax.tools

      Methods in javax.tools that return JavaCompiler
      修饰符与类型 方法与描述
      static JavaCompiler ToolProvider.getSystemJavaCompiler()
      Gets the Java™ programming language compiler provided with this platform.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

& n>tnAnogggsnnntetsuaauS


Uses of Interface javax.tools.JavaCompiler.CompilationTask

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.JavaCompiler.CompilationTask

  • Packages that use JavaCompiler.CompilationTask
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaCompiler.CompilationTask in javax.tools

      Methods in javax.tools that return JavaCompiler.CompilationTask
      修饰符与类型 方法与描述
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(


Uses of Interface javax.tools.JavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.JavaFileManager

  • Packages that use JavaFileManager
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileManager in javax.tools

      Classes in javax.tools with type parameters of type JavaFileManager
      修饰符与类型 类与描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
      Subinterfaces of JavaFileManager in javax.tools
      修饰符与类型 Interface and Description
      interface  StandardJavaFileManager
      File manager based on java.io.File.
      Classes in javax.tools that implement JavaFileManager
      修饰符与类型 类与描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
      Fields in javax.tools declared as JavaFileManager
      修饰符与类型 字段与描述
      protected M ForwardingJavaFileManager.fileManager
      The file manager which all methods are delegated to.
      Methods in javax.tools with parameters of type JavaFileManager
      修饰符与类型 方法与描述
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.p./d t=� .l .ro./ld


Uses of Interface javax.tools.JavaFileManager.Location

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.JavaFileManager.Location

  • Packages that use JavaFileManager.Location
    软件包 描述
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileManager.Location in javax.annotation.processing

      Methods in javax.annotation.processing with parameters of type JavaFileManager.Location
      修饰符与类型 方法与描述
      FileObject Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements)
      Creates a new auxiliary resource file for writing and returns a file object for it.
      FileObject Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName)
      Returns an object for reading an existing resource.

    • Uses of JavaFileManager.Location in javax.tools

      Classes in javax.tools that implement JavaFileManager.Location
      修饰符与类型 类与描述
      class  StandardLocation
      Standard locations of file objects.
      Methods in javax.tools that return JavaFileManager.Location
      修饰符与类型 方法与描述
      static JavaFileManager.Location StandardLocation.locationFor(String name)
      Gets a location object with the given name.
      Methods in javax.tools with parameters of type JavaFileManager.Location
      修饰符与类型 | 方法与描述
      ClassLoader JavaFileManager.getClassLoader(JavaFileManager.Location location)
      Gets a class loader for loading plug-ins from the given location.
      ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
      FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      Gets a file object for input representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
      FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      Gets a file object for output representing the specified relative name in the specified package in the given location.
      FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Iterable<? extends File> StandardJavaFileManager.getLocation(JavaFileManager.Location location)
      Gets the path associated with the given location.
      boolean JavaFileManager.hasLocation(JavaFileManager.Location location)
      Determines if a location is known to this file manager.
      boolean | ForwardingJavaFileManager.hasLocation(JavaFileManager.Location location)
      String JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      void StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
      Associates the given path with the given location.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a=aoia>M>萢mtf.


Uses of Interface javax.tools.JavaFileObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.JavaFileObject

  • Packages that use JavaFileObject
    软件包 描述
    javax.annotation.processing
    Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of JavaFileObject in javax.annotation.processing

      Methods in javax.annotation.processing that return JavaFileObject
      修饰符与类型 方法与描述
      JavaFileObject Filer.createClassFile(CharSequence name, Element... originatingElements)
      Creates a new class file, and returns an object to allow writing to it.
      JavaFileObject Filer.createSourceFile(CharSequence name, Element... originatingElements)
      Creates a new source file and returns an object to allow writing to it.

    • Uses of JavaFileObject in javax.tools

      Classes in javax.tools with type parameters of type JavaFileObject
      修饰符与类型 类与描述
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      Classes in javax.tools that implement JavaFileObject
      修饰符与类型 类与描述
      class  ForwardingJavaFileObject<F extends JavaFileObject>
      Forwards calls to a given file object.
      class  SimpleJavaFileObject
      Provides simple implementations for most methods in JavaFileObject.
      Methods in javax.tools that return JavaFileObject
      修饰符与类型 | 方法与描述
      JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      Gets a file object for input representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
      JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Gets a file object for output representing the specified class of the specified kind in the given location.
      JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
      Methods in javax.tools that return types with arguments of type JavaFileObject
      修饰符与类型 | 方法与描述
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(File... files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(String... names)
      Gets file objects representing the given file names.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files)
      Gets file objects representing the given files.
      Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names)
      Gets file objects representing the given file names.
      Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Lists all file objects matching the given criteria in the given location.
      Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
      Methods in javax.tools with parameters of type JavaFileObject
      修饰符与类型 | 方法与描述
      String JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Infers a binary name of a file object based on a location.
      String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
      Method parameters in javax.tools with type arguments of type JavaFileObject
      修饰符与类型 方法与描述
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
      JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
      Creates a future for a compilation task with the given components and arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xpo禵_>_ro>"ooas//�/.鈔td<


Uses of Interface javax.tools.OptionChecker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.OptionChecker

  • Packages that use OptionChecker
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of OptionChecker in javax.tools

      Subinterfaces of OptionChecker in javax.tools
      修饰符与类型 Interface and Description
      interface  JavaCompiler
      Interface to invoke Java™ programming language compilers from programs.
      interface  JavaFileManager
      File manager for tools operating on Java™ programming language source and class files.
      interface  StandardJavaFileManager
      File manager based on java.io.File.
      Classes in javax.tools that implement OptionChecker
      修饰符与类型 类与描述
      class  ForwardingJavaFileManager<M extends JavaFileManager>
      Forwards calls to a given file manager.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xl/.f=" ahhh een.ia>.s=


Uses of Interface javax.tools.StandardJavaFileManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.StandardJavaFileManager

  • Packages that use StandardJavaFileManager
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of StandardJavaFileManager in javax.tools

      Methods in javax.tools that return StandardJavaFileManager
      修饰符与类型 方法与描述
      StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
      Gets a new instance of the standard file manager implementation for this tool.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

}. ahoftlakdrrc"nee(錗<


Uses of Interface javax.tools.Tool

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.tools.Tool

  • Packages that use Tool
    软件包 描述
    javax.tools
    Provides interfaces for tools which can be invoked from a program, for example, compilers.

    • Uses of Tool in javax.tools

      Subinterfaces of Tool in javax.tools
      修饰符与类型 Interface and Description
      interface  JavaCompiler
      Interface to invoke Java™ programming language compilers from programs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lal l e a bbb o)(()a


InvalidTransactionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.transaction

类 InvalidTransactionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
  • 所有已实现的接口：
    Serializable

    public class InvalidTransactionException
extends RemoteException
    This exception indicates that the request carried an invalid transaction context. For example, this exception could be raised if an error occured when trying to register a resource.
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidTransactionException()
      InvalidTransactionException(String msg)

    • 方法摘要

      • 方法 - 继承于类 java.rmi.RemoteException

        getCause, getMessage

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidTransactionException

        public InvalidTransactionException()

      • InvalidTransactionException

        public InvalidTransactionException(String msg)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.arnsts d /(es/v.ralj/an


javax.transaction

Exceptions

  • InvalidTransactionException
  • TransactionRequiredException
  • TransactionRolledbackException
s


javax.transaction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.transaction

Contains three exceptions thrown by the ORB machinery during unmarshalling.

请参见： 描述

  • Exception Summary
    Exception 描述
    InvalidTransactionException
    This exception indicates that the request carried an invalid transaction context.
    TransactionRequiredException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    TransactionRolledbackException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

软件包 javax.transaction Description

Contains three exceptions thrown by the ORB machinery during unmarshalling.

从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

epttea//r/.j///faadp嗬� � ;


javax.transaction Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.transaction

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nil:f/thp/oor//�><<


TransactionRequiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.transaction

类 TransactionRequiredException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRequiredException
  • 所有已实现的接口：
    Serializable

    public class TransactionRequiredException
extends RemoteException
    This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransactionRequiredException()
      TransactionRequiredException(String msg)

    • 方法摘要

      • 方法 - 继承于类 java.rmi.RemoteException

        getCause, getMessage

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransactionRequiredException

        public TransactionRequiredException()

      • TransactionRequiredException

        public TransactionRequiredException(String msg)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e.etixl oa-/t>Aex"rcn"iC<"efsoA<


TransactionRolledbackException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.transaction

类 TransactionRolledbackException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.TransactionRolledbackException
  • 所有已实现的接口：
    Serializable

    public class TransactionRolledbackException
extends RemoteException
    This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless
    另请参见：
    Serialized Form

    • 字段摘要

      • Fields inherited from class java.rmi.RemoteException

        detail

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransactionRolledbackException()
      TransactionRolledbackException(String msg)

    • 方法摘要

      • 方法 - 继承于类 java.rmi.RemoteException

        getCause, getMessage

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransactionRolledbackException

        public TransactionRolledbackException()

      • TransactionRolledbackException

        public TransactionRolledbackException(String msg)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gg1sFsRs-sbe-b1gl <


Uses of Package javax.transaction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.transaction

No usage of javax.transaction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>acD>襤.tttie==Ci� T


Uses of Class javax.transaction.InvalidTransactionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.transaction.InvalidTransactionException

No usage of javax.transaction.InvalidTransactionException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dsfele"


Uses of Class javax.transaction.TransactionRequiredException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.transaction.TransactionRequiredException

No usage of javax.transaction.TransactionRequiredException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alp<�-u >�/


Uses of Class javax.transaction.TransactionRolledbackException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.transaction.TransactionRolledbackException

No usage of javax.transaction.TransactionRolledbackException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tes < cr&�"etB"mt "


javax.transaction.xa

Interfaces

  • XAResource
  • Xid

Exceptions

  • XAException


javax.transaction.xa

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

请参见： 描述

  • 接口摘要
    接口 描述
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • Exception Summary
    Exception 描述
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

软件包 javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/nxdllt.da =l.>e/�


javax.transaction.xa Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.transaction.xa

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.xa.XAException

Interface Hierarchy

  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ma>n8>tsooo<;nneg&&m�


Uses of Package javax.transaction.xa

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.transaction.xa

  • Packages that use javax.transaction.xa
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
  • Classes in javax.transaction.xa used by javax.sql
    类与描述
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
  • Classes in javax.transaction.xa used by javax.transaction.xa
    类与描述
    XAException
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    XAResource
    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
    Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"Inr衝&Jeieb>x/as奏f


XAException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.transaction.xa

类 XAException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.transaction.xa.XAException
  • 所有已实现的接口：
    Serializable

    public class XAException
extends Exception
    The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      int errorCode
      The error code with which to create the SystemException.
      static int XA_HEURCOM
      The transaction branch has been heuristically committed.
      static int XA_HEURHAZ
      The transaction branch may have been heuristically completed.
      static int XA_HEURMIX
      The transaction branch has been heuristically committed and rolled back.
      static int XA_HEURRB
      The transaction branch has been heuristically rolled back.
      static int XA_NOMIGRATE
      Resumption must occur where the suspension occurred.
      static int XA_RBBASE
      The inclusive lower bound of the rollback codes.
      static int XA_RBCOMMFAIL
      Indicates that the rollback was caused by a communication failure.
      static int XA_RBDEADLOCK
      A deadlock was detected.
      static int XA_RBEND
      The inclusive upper bound of the rollback error code.
      static int XA_RBINTEGRITY
      A condition that violates the integrity of the resource was detected.
      static int XA_RBOTHER
      The resource manager rolled back the transaction branch for a reason not on this list.
      static int XA_RBPROTO
      A protocol error occurred in the resource manager.
      static int XA_RBROLLBACK
      Indicates that the rollback was caused by an unspecified reason.
      static int XA_RBTIMEOUT
      A transaction branch took too long.
      static int XA_RBTRANSIENT
      May retry the transaction branch.
      static int XA_RDONLY
      The transaction branch was read-only and has been committed.
      static int XA_RETRY
      Routine returned with no effect and may be reissued.
      static int XAER_ASYNC
      There is an asynchronous operation already outstanding.
      static int XAER_DUPID
      The XID already exists.
      static int XAER_INVAL
      Invalid arguments were given.
      static int XAER_NOTA
      The XID is not valid.
      static int XAER_OUTSIDE
      The resource manager is doing work outside a global transaction.
      static int XAER_PROTO
      Routine was invoked in an inproper context.
      static int XAER_RMERR
      A resource manager error has occurred in the transaction branch.
      static int XAER_RMFAIL
      Resource manager is unavailable.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XAException()
      Create an XAException.
      XAException(int errcode)
      Create an XAException with a given error code.
      XAException(String s)
      Create an XAException with a given string.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • errorCode

        public int errorCode
        The error code with which to create the SystemException.

      • XA_RBBASE

        public static final int XA_RBBASE
        The inclusive lower bound of the rollback codes.
        另请参见：
        Constant Field Values

      • XA_RBROLLBACK

        public static final int XA_RBROLLBACK
        Indicates that the rollback was caused by an unspecified reason.
        另请参见：
        Constant Field Values

      • XA_RBCOMMFAIL

        public static final int XA_RBCOMMFAIL
        Indicates that the rollback was caused by a communication failure.
        另请参见：
        Constant Field Values

      • XA_RBDEADLOCK

        public static final int XA_RBDEADLOCK
        A deadlock was detected.
        另请参见：
        Constant Field Values

      • XA_RBINTEGRITY

        public static final int XA_RBINTEGRITY
        A condition that violates the integrity of the resource was detected.
        另请参见：
        Constant Field Values

      • XA_RBOTHER

        public static final int XA_RBOTHER
        The resource manager rolled back the transaction branch for a reason not on this list.
        另请参见：
        Constant Field Values

      • XA_RBPROTO

        public static final int XA_RBPROTO
        A protocol error occurred in the resource manager.
        另请参见：
        Constant Field Values

      • XA_RBTIMEOUT

        public static final int XA_RBTIMEOUT
        A transaction branch took too long.
        另请参见：
        Constant Field Values

      • XA_RBTRANSIENT

        public static final int XA_RBTRANSIENT
        May retry the transaction branch.
        另请参见：
        Constant Field Values

      • XA_RBEND

        public static final int XA_RBEND
        The inclusive upper bound of the rollback error code.
        另请参见：
        Constant Field Values

      • XA_NOMIGRATE

        public static final int XA_NOMIGRATE
        Resumption must occur where the suspension occurred.
        另请参见：
        Constant Field Values

      • XA_HEURHAZ

        public static final int XA_HEURHAZ
        The transaction branch may have been heuristically completed.
        另请参见：
        Constant Field Values

      • XA_HEURCOM

        public static final int XA_HEURCOM
        The transaction branch has been heuristically committed.
        另请参见：
        Constant Field Values

      • XA_HEURRB

        public static final int XA_HEURRB
        The transaction branch has been heuristically rolled back.
        另请参见：
        Constant Field Values

      • XA_HEURMIX

        public static final int XA_HEURMIX
        The transaction branch has been heuristically committed and rolled back.
        另请参见：
        Constant Field Values

      • XA_RETRY

        public static final int XA_RETRY
        Routine returned with no effect and may be reissued.
        另请参见：
        Constant Field Values

      • XA_RDONLY

        public static final int XA_RDONLY
        The transaction branch was read-only and has been committed.
        另请参见：
        Constant Field Values

      • XAER_ASYNC

        public static final int XAER_ASYNC
        There is an asynchronous operation already outstanding.
        另请参见：
        Constant Field Values

      • XAER_RMERR

        public static final int XAER_RMERR
        A resource manager error has occurred in the transaction branch.
        另请参见：
        Constant Field Values

      • XAER_NOTA

        public static final int XAER_NOTA
        The XID is not valid.
        另请参见：
        Constant Field Values

      • XAER_INVAL

        public static final int XAER_INVAL
        Invalid arguments were given.
        另请参见：
        Constant Field Values

      • XAER_PROTO

        public static final int XAER_PROTO
        Routine was invoked in an inproper context.
        另请参见：
        Constant Field Values

      • XAER_RMFAIL

        public static final int XAER_RMFAIL
        Resource manager is unavailable.
        另请参见：
        Constant Field Values

      • XAER_DUPID

        public static final int XAER_DUPID
        The XID already exists.
        另请参见：
        Constant Field Values

      • XAER_OUTSIDE

        public static final int XAER_OUTSIDE
        The resource manager is doing work outside a global transaction.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • XAException

        public XAException()
        Create an XAException.

      • XAException

        public XAException(String s)
        Create an XAException with a given string.
        参数：
        s - The String object containing the exception message.

      • XAException

        public XAException(int errcode)
        Create an XAException with a given error code.
        参数：
        errcode - The error code identifying the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


XAResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.transaction.xa

Interface XAResource

  • public interface XAResource

    The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

    The XA interface defines the contract between a Resource Manager and a Transaction Manager in a distributed transaction processing (DTP) environment. A JDBC driver or a JMS provider implements this interface to support the association between a global transaction and a database or message service connection.

    The XAResource interface can be supported by any transactional resource that is intended to be used by application programs in an environment where transactions are controlled by an external transaction manager. An example of such a resource is a database management system. An application may access data through multiple database connections. Each database connection is enlisted with the transaction manager as a transactional resource. The transaction manager obtains an XAResource for each connection participating in a global transaction. The transaction manager uses the start method to associate the global transaction with the resource, and it uses the end method to disassociate the transaction from the resource. The resource manager is responsible for associating the global transaction to all work performed on its data between the start and end method invocations.

    At transaction commit time, the resource managers are informed by the transaction manager to prepare, commit, or rollback a transaction according to the two-phase commit protocol.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int TMENDRSCAN
      Ends a recovery scan.
      static int TMFAIL
      Disassociates the caller and marks the transaction branch rollback-only.
      static int TMJOIN
      Caller is joining existing transaction branch.
      static int TMNOFLAGS
      Use TMNOFLAGS to indicate no flags value is selected.
      static int TMONEPHASE
      Caller is using one-phase optimization.
      static int TMRESUME
      Caller is resuming association with a suspended transaction branch.
      static int TMSTARTRSCAN
      Starts a recovery scan.
      static int TMSUCCESS
      Disassociates caller from a transaction branch.
      static int TMSUSPEND
      Caller is suspending (not ending) its association with a transaction branch.
      static int XA_OK
      The transaction work has been prepared normally.
      static int XA_RDONLY
      The transaction branch has been read-only and has been committed.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.

    • 字段详细信息

      • TMENDRSCAN

        static final int TMENDRSCAN
        Ends a recovery scan.
        另请参见：
        Constant Field Values

      • TMFAIL

        static final int TMFAIL
        Disassociates the caller and marks the transaction branch rollback-only.
        另请参见：
        Constant Field Values

      • TMJOIN

        static final int TMJOIN
        Caller is joining existing transaction branch.
        另请参见：
        Constant Field Values

      • TMNOFLAGS

        static final int TMNOFLAGS
        Use TMNOFLAGS to indicate no flags value is selected.
        另请参见：
        Constant Field Values

      • TMONEPHASE

        static final int TMONEPHASE
        Caller is using one-phase optimization.
        另请参见：
        Constant Field Values

      • TMRESUME

        static final int TMRESUME
        Caller is resuming association with a suspended transaction branch.
        另请参见：
        Constant Field Values

      • TMSTARTRSCAN

        static final int TMSTARTRSCAN
        Starts a recovery scan.
        另请参见：
        Constant Field Values

      • TMSUCCESS

        static final int TMSUCCESS
        Disassociates caller from a transaction branch.
        另请参见：
        Constant Field Values

      • TMSUSPEND

        static final int TMSUSPEND
        Caller is suspending (not ending) its association with a transaction branch.
        另请参见：
        Constant Field Values

      • XA_RDONLY

        static final int XA_RDONLY
        The transaction branch has been read-only and has been committed.
        另请参见：
        Constant Field Values

      • XA_OK

        static final int XA_OK
        The transaction work has been prepared normally.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • commit

        void commit(Xid xid,
          boolean onePhase)
            throws XAException
        Commits the global transaction specified by xid.
        参数：
        xid - A global transaction identifier
        onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
        抛出：
        XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

        If the resource manager did not commit the transaction and the paramether onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

      • end

        void end(Xid xid,
       int flags)
         throws XAException
        Ends the work performed on behalf of a transaction branch. The resource manager disassociates the XA resource from the transaction branch specified and lets the transaction complete.

        If TMSUSPEND is specified in the flags, the transaction branch is temporarily suspended in an incomplete state. The transaction context is in a suspended state and must be resumed via the start method with TMRESUME specified.

        If TMFAIL is specified, the portion of work has failed. The resource manager may mark the transaction as rollback-only

        If TMSUCCESS is specified, the portion of work has completed successfully.

        参数：
        xid - A global transaction identifier that is the same as the identifier used previously in the start method.
        flags - One of TMSUCCESS, TMFAIL, or TMSUSPEND.
        抛出：
        XAException - An error has occurred. Possible XAException values are XAER_RMERR, XAER_RMFAILED, XAER_NOTA, XAER_INVAL, XAER_PROTO, or XA_RB*.

      • forget

        void forget(Xid xid)
            throws XAException
        Tells the resource manager to forget about a heuristically completed transaction branch.
        参数：
        xid - A global transaction identifier.
        抛出：
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • getTransactionTimeout

        int getTransactionTimeout()
                          throws XAException
        Obtains the current transaction timeout value set for this XAResource instance. If XAResource.setTransactionTimeout was not used prior to invoking this method, the return value is the default timeout set for the resource manager; otherwise, the value used in the previous setTransactionTimeout call is returned.
        返回：
        the transaction timeout value in seconds.
        抛出：
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • isSameRM

        boolean isSameRM(XAResource xares)
                 throws XAException
        This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
        参数：
        xares - An XAResource object whose resource manager instance is to be compared with the resource manager instance of the target object.
        返回：
        true if it's the same RM instance; otherwise false.
        抛出：
        XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

      • prepare

        int prepare(Xid xid)
            throws XAException
        Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
        参数：
        xid - A global transaction identifier.
        返回：
        A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
        抛出：
        XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

      • recover

        Xid[] recover(int flag)
              throws XAException
        Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.
        参数：
        flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter.
        返回：
        The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
        抛出：
        XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

      • rollback

        void rollback(Xid xid)
              throws XAException
        Informs the resource manager to roll back work done on behalf of a transaction branch.
        参数：
        xid - A global transaction identifier.
        抛出：
        XAException - An error has occurred.

      • setTransactionTimeout

        boolean setTransactionTimeout(int seconds)
                              throws XAException

        Sets the current transaction timeout value for this XAResource instance. Once set, this timeout value is effective until setTransactionTimeout is invoked again with a different value. To reset the timeout value to the default value used by the resource manager, set the value to zero. If the timeout operation is performed successfully, the method returns true; otherwise false. If a resource manager does not support explicitly setting the transaction timeout value, this method returns false.

        参数：
        seconds - The transaction timeout value in seconds.
        返回：
        true if the transaction timeout value is set successfully; otherwise false.
        抛出：
        XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, or XAER_INVAL.

      • start

        void start(Xid xid,
         int flags)
           throws XAException
        Starts work on behalf of a transaction branch specified in xid. If TMJOIN is specified, the start applies to joining a transaction previously seen by the resource manager. If TMRESUME is specified, the start applies to resuming a suspended transaction specified in the parameter xid. If neither TMJOIN nor TMRESUME is specified and the transaction specified by xid has previously been seen by the resource manager, the resource manager throws the XAException exception with XAER_DUPID error code.
        参数：
        xid - A global transaction identifier to be associated with the resource.
        flags - One of TMNOFLAGS, TMJOIN, or TMRESUME.
        抛出：
        XAException - An error has occurred. Possible exceptions are XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_DUPID, XAER_OUTSIDE, XAER_NOTA, XAER_INVAL, or XAER_PROTO.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t#


Xid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.transaction.xa

Interface Xid

  • public interface Xid
    The Xid interface is a Java mapping of the X/Open transaction identifier XID structure. This interface specifies three accessor methods to retrieve a global transaction format ID, global transaction ID, and branch qualifier. The Xid interface is used by the transaction manager and the resource managers. This interface is not visible to the application programs.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int MAXBQUALSIZE
      Maximum number of bytes returned by getBqual.
      static int MAXGTRIDSIZE
      Maximum number of bytes returned by getGtrid.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getBranchQualifier()
      Obtain the transaction branch identifier part of XID as an array of bytes.
      int getFormatId()
      Obtain the format identifier part of the XID.
      byte[] getGlobalTransactionId()
      Obtain the global transaction identifier part of XID as an array of bytes.

    • 字段详细信息

      • MAXGTRIDSIZE

        static final int MAXGTRIDSIZE
        Maximum number of bytes returned by getGtrid.
        另请参见：
        Constant Field Values

      • MAXBQUALSIZE

        static final int MAXBQUALSIZE
        Maximum number of bytes returned by getBqual.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getFormatId

        int getFormatId()
        Obtain the format identifier part of the XID.
        返回：
        Format identifier. O means the OSI CCR format.

      • getGlobalTransactionId

        byte[] getGlobalTransactionId()
        Obtain the global transaction identifier part of XID as an array of bytes.
        返回：
        Global transaction identifier.

      • getBranchQualifier

        byte[] getBranchQualifier()
        Obtain the transaction branch identifier part of XID as an array of bytes.
        返回：
        Global transaction identifier.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=/"n>sc n>ddr /rd>>tl


Uses of Class javax.transaction.xa.XAException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.transaction.xa.XAException

  • Packages that use XAException
    软件包 描述
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAException in javax.transaction.xa

      Methods in javax.transaction.xa that throw XAException
      修饰符与类型 方法与描述
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.getTransactionTimeout()
      Obtains the current transaction timeout value set for this XAResource instance.
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      boolean XAResource.setTransactionTimeout(int seconds)
      Sets the current transaction timeout value for this XAResource instance.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h"cl vvi


Uses of Interface javax.transaction.xa.XAResource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.transaction.xa.XAResource

  • Packages that use XAResource
    软件包 描述
    javax.sql
    Provides the API for server side data source access and processing from the JavaTM programming language.
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of XAResource in javax.sql

      Methods in javax.sql that return XAResource
      修饰符与类型 方法与描述
      XAResource XAConnection.getXAResource()
      Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.

    • Uses of XAResource in javax.transaction.xa

      Methods in javax.transaction.xa with parameters of type XAResource
      修饰符与类型 方法与描述
      boolean XAResource.isSameRM(XAResource xares)
      This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x ioinnnaarrtnn.it",/


Uses of Interface javax.transaction.xa.Xid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.transaction.xa.Xid

  • Packages that use Xid
    软件包 描述
    javax.transaction.xa
    Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

    • Uses of Xid in javax.transaction.xa

      Methods in javax.transaction.xa that return Xid
      修饰符与类型 方法与描述
      Xid[] XAResource.recover(int flag)
      Obtains a list of prepared transaction branches from a resource manager.
      Methods in javax.transaction.xa with parameters of type Xid
      修饰符与类型 方法与描述
      void XAResource.commit(Xid xid, boolean onePhase)
      Commits the global transaction specified by xid.
      void XAResource.end(Xid xid, int flags)
      Ends the work performed on behalf of a transaction branch.
      void XAResource.forget(Xid xid)
      Tells the resource manager to forget about a heuristically completed transaction branch.
      int XAResource.prepare(Xid xid)
      Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
      void XAResource.rollback(Xid xid)
      Informs the resource manager to roll back work done on behalf of a transaction branch.
      void XAResource.start(Xid xid, int flags)
      Starts work on behalf of a transaction branch specified in xid.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dloiielsns C""eta.."">d


javax.xml

Classes

  • XMLConstants
3


javax.xml

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml

  • Class Summary
    类 描述
    XMLConstants
    Utility class to contain basic XML values as constants.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ph=erd/rj


javax.xml Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.XMLConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i"p aeteddct,e�<毕�


Uses of Package javax.xml

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml

No usage of javax.xml
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" >znoioftsetagg/->-=


XMLConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml

类 XMLConstants

  • java.lang.Object
    • javax.xml.XMLConstants

  • public final class XMLConstants
extends Object

    Utility class to contain basic XML values as constants.

    从以下版本开始：
    1.5
    另请参见：
    Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition), XML 1.0 Second Edition Specification Errata, Namespaces in XML 1.1, Namespaces in XML, Namespaces in XML Errata, XML Schema Part 1: Structures

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_NS_PREFIX
      Prefix to use to represent the default XML Namespace.
      static String FEATURE_SECURE_PROCESSING
      Feature for secure processing.
      static String NULL_NS_URI
      Namespace URI to use to represent that there is no Namespace.
      static String RELAXNG_NS_URI
      RELAX NG Namespace URI.
      static String W3C_XML_SCHEMA_INSTANCE_NS_URI
      W3C XML Schema Instance Namespace URI.
      static String W3C_XML_SCHEMA_NS_URI
      W3C XML Schema Namespace URI.
      static String W3C_XPATH_DATATYPE_NS_URI
      W3C XPath Datatype Namespace URI.
      static String XML_DTD_NS_URI
      XML Document Type Declaration Namespace URI as an arbitrary value.
      static String XML_NS_PREFIX
      The official XML Namespace prefix.
      static String XML_NS_URI
      The official XML Namespace name URI.
      static String XMLNS_ATTRIBUTE
      The official XML attribute used for specifying XML Namespace declarations.
      static String XMLNS_ATTRIBUTE_NS_URI
      The official XML attribute used for specifying XML Namespace declarations, XMLConstants.XMLNS_ATTRIBUTE, Namespace name URI.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NULL_NS_URI

        public static final String NULL_NS_URI

        Namespace URI to use to represent that there is no Namespace.

        Defined by the Namespace specification to be "".

        另请参见：
        Namespaces in XML, 5.2 Namespace Defaulting, Constant Field Values

      • DEFAULT_NS_PREFIX

        public static final String DEFAULT_NS_PREFIX

        Prefix to use to represent the default XML Namespace.

        Defined by the XML specification to be "".

        另请参见：
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • XML_NS_URI

        public static final String XML_NS_URI

        The official XML Namespace name URI.

        Defined by the XML specification to be "http://www.w3.org/XML/1998/namespace".

        另请参见：
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • XML_NS_PREFIX

        public static final String XML_NS_PREFIX

        The official XML Namespace prefix.

        Defined by the XML specification to be "xml".

        另请参见：
        Namespaces in XML, 3. Qualified Names<, Constant Field Values

      • XMLNS_ATTRIBUTE_NS_URI

        public static final String XMLNS_ATTRIBUTE_NS_URI

        The official XML attribute used for specifying XML Namespace declarations, XMLConstants.XMLNS_ATTRIBUTE, Namespace name URI.

        Defined by the XML specification to be "http://www.w3.org/2000/xmlns/".

        另请参见：
        Namespaces in XML, 3. Qualified Names, Namespaces in XML Errata, Constant Field Values

      • XMLNS_ATTRIBUTE

        public static final String XMLNS_ATTRIBUTE

        The official XML attribute used for specifying XML Namespace declarations.

        It is NOT valid to use as a prefix. Defined by the XML specification to be "xmlns".

        另请参见：
        Namespaces in XML, 3. Qualified Names, Constant Field Values

      • W3C_XML_SCHEMA_NS_URI

        public static final String W3C_XML_SCHEMA_NS_URI

        W3C XML Schema Namespace URI.

        Defined to be "http://www.w3.org/2001/XMLSchema".

        另请参见：
        XML Schema Part 1: Structures, 2.6 Schema-Related Markup in Documents Being Validated, Constant Field Values

      • W3C_XML_SCHEMA_INSTANCE_NS_URI

        public static final String W3C_XML_SCHEMA_INSTANCE_NS_URI

        W3C XML Schema Instance Namespace URI.

        Defined to be "http://www.w3.org/2001/XMLSchema-instance".

        另请参见：
        XML Schema Part 1: Structures, 2.6 Schema-Related Markup in Documents Being Validated, Constant Field Values

      • W3C_XPATH_DATATYPE_NS_URI

        public static final String W3C_XPATH_DATATYPE_NS_URI

        W3C XPath Datatype Namespace URI.

        Defined to be "http://www.w3.org/2003/11/xpath-datatypes".

        另请参见：
        XQuery 1.0 and XPath 2.0 Data Model, Constant Field Values

      • XML_DTD_NS_URI

        public static final String XML_DTD_NS_URI

        XML Document Type Declaration Namespace URI as an arbitrary value.

        Since not formally defined by any existing standard, arbitrarily define to be "http://www.w3.org/TR/REC-xml".

        另请参见：
        Constant Field Values

      • RELAXNG_NS_URI

        public static final String RELAXNG_NS_URI

        RELAX NG Namespace URI.

        Defined to be "http://relaxng.org/ns/structure/1.0".

        另请参见：
        RELAX NG Specification, Constant Field Values

      • FEATURE_SECURE_PROCESSING

        public static final String FEATURE_SECURE_PROCESSING

        Feature for secure processing.

        • true instructs the implementation to process XML securely. This may set limits on XML constructs to avoid conditions such as denial of service attacks.
        • false instructs the implementation to process XML acording the letter of the XML specifications ingoring security issues such as limits on XML constructs to avoid conditions such as denial of service attacks.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gti l >eft lsa!j絤nN;ln" a


Binder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 Binder<XmlNode>

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>

  • public abstract class Binder<XmlNode>
extends Object
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.

    An instance of this class maintains the association between XML nodes of an infoset preserving view and a JAXB representation of an XML document. Navigation between the two views is provided by the methods getXMLNode(Object) and getJAXBNode(Object).

    Modifications can be made to either the infoset preserving view or the JAXB representation of the document while the other view remains unmodified. The binder is able to synchronize the changes made in the modified view back into the other view using the appropriate Binder update methods, updateXML(Object, Object) or updateJAXB(Object).

    A typical usage scenario is the following:

    • load XML document into an XML infoset representation
    • unmarshal(Object) XML infoset view to JAXB view. (Note to conserve resources, it is possible to only unmarshal a subtree of the XML infoset view to the JAXB view.)
    • application access/updates JAXB view of XML document.
    • updateXML(Object) synchronizes modifications to JAXB view back into the XML infoset view. Update operation preserves as much of original XML infoset as possible (i.e. comments, PI, ...)

    A Binder instance is created using the factory method JAXBContext.createBinder() or JAXBContext.createBinder(Class).

    The template parameter, XmlNode, is the root interface/class for the XML infoset preserving representation. A Binder implementation is required to minimally support an XmlNode value of org.w3c.dom.Node.class. A Binder implementation can support alternative XML infoset preserving representations.

    从以下版本开始：
    JAXB 2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      Binder()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract Object getJAXBNode(XmlNode xmlNode)
      Gets the JAXB object associated with the given XML element.
      abstract Object getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      abstract Schema getSchema()
      Gets the last Schema object (including null) set by the setSchema(Schema) method.
      abstract XmlNode getXMLNode(Object jaxbObject)
      Gets the XML element associated with the given JAXB object.
      abstract void marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      abstract void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      abstract void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.
      abstract void setSchema(Schema schema)
      Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
      abstract Object unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode, 类<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      abstract Object updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Binder

        public Binder()

    • 方法详细信息

      • unmarshal

        public abstract Object unmarshal(XmlNode xmlNode)
                          throws JAXBException
        Unmarshal XML infoset view to a JAXB object tree.

        This method is similar to Unmarshaller.unmarshal(Node) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        This method throws UnmarshalException when the Binder's JAXBContext does not have a mapping for the XML element name or the type, specifiable via @xsi:type, of xmlNode to a JAXB mapped class. The method unmarshal(Object, Class) enables an application to specify the JAXB mapped class that the xmlNode should be mapped to.

        参数：
        xmlNode - the document/element to unmarshal XML data from.
        返回：
        the newly created root object of the JAXB object tree.
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If the node parameter is null

      • unmarshal

        public abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode,
                           类<T> declaredType)
                                  throws JAXBException
        Unmarshal XML root element by provided declaredType to a JAXB object tree.

        Implements Unmarshal by Declared Type

        This method is similar to Unmarshaller.unmarshal(Node, Class) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

        参数：
        xmlNode - the document/element to unmarshal XML data from.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        返回：
        JAXB Element representation of node
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
        IllegalArgumentException - If any of the input parameters are null
        从以下版本开始：
        JAXB2.0

      • marshal

        public abstract void marshal(Object jaxbObject,
           XmlNode xmlNode)
                      throws JAXBException
        Marshal a JAXB object tree to a new XML document.

        This method is similar to Marshaller.marshal(Object, Node) with the addition of maintaining the association between JAXB objects and the produced XML nodes, enabling future update operations such as updateXML(Object, Object) or updateJAXB(Object).

        When getSchema() is non-null, the marshalled xml content is validated during this operation.

        参数：
        jaxbObject - The content tree to be marshalled.
        xmlNode - The parameter must be a Node that accepts children.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to marshal jaxbObject (or any object reachable from jaxbObject).
        IllegalArgumentException - If any of the method parameters are null

      • getXMLNode

        public abstract XmlNode getXMLNode(Object jaxbObject)
        Gets the XML element associated with the given JAXB object.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the bind methods and the update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        参数：
        jaxbObject - An instance that is reachable from a prior call to a bind or update method that returned a JAXB object tree.
        返回：
        null if the specified JAXB object is not known to this Binder, or if it is not associated with an XML element.
        抛出：
        IllegalArgumentException - If the jaxbObject parameter is null

      • getJAXBNode

        public abstract Object getJAXBNode(XmlNode xmlNode)
        Gets the JAXB object associated with the given XML element.

        Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

        An association between an XML element and a JAXB object is established by the unmarshal, marshal and update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

        返回：
        null if the specified XML node is not known to this Binder, or if it is not associated with a JAXB object.
        抛出：
        IllegalArgumentException - If the node parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject)
                           throws JAXBException
        Takes an JAXB object and updates its associated XML node and its descendants.

        This is a convenience method of:

         updateXML( jaxbObject, getXMLNode(jaxbObject));
        抛出：
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If the jaxbObject parameter is null

      • updateXML

        public abstract XmlNode updateXML(Object jaxbObject,
                XmlNode xmlNode)
                           throws JAXBException
        Changes in JAXB object tree are updated in its associated XML parse tree.

        This operation can be thought of as an "in-place" marshalling. The difference is that instead of creating a whole new XML tree, this operation updates an existing tree while trying to preserve the XML as much as possible.

        For example, unknown elements/attributes in XML that were not bound to JAXB will be left untouched (whereas a marshalling operation would create a new tree that doesn't contain any of those.)

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        参数：
        jaxbObject - root of potentially modified JAXB object tree
        xmlNode - root of update target XML parse tree
        返回：
        Returns the updated XML node. Typically, this is the same node you passed in as xmlNode, but it maybe a different object, for example when the tag name of the object has changed.
        抛出：
        JAXBException - If any unexpected problem occurs updating corresponding XML content.
        IllegalArgumentException - If any of the input parameters are null

      • updateJAXB

        public abstract Object updateJAXB(XmlNode xmlNode)
                           throws JAXBException
        Takes an XML node and updates its associated JAXB object and its descendants.

        This operation can be thought of as an "in-place" unmarshalling. The difference is that instead of creating a whole new JAXB tree, this operation updates an existing tree, reusing as much JAXB objects as possible.

        As a side-effect, this operation updates the association between XML nodes and JAXB objects.

        返回：
        Returns the updated JAXB object. Typically, this is the same object that was returned from earlier marshal(Object,Object) or updateJAXB(Object) method invocation, but it maybe a different object, for example when the name of the XML element has changed.
        抛出：
        JAXBException - If any unexpected problem occurs updating corresponding JAXB mapped content.
        IllegalArgumentException - If node parameter is null

      • setSchema

        public abstract void setSchema(Schema schema)
        Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
        参数：
        schema - set to null to disable validation.
        另请参见：
        Unmarshaller.setSchema(Schema)

      • getSchema

        public abstract Schema getSchema()
        Gets the last Schema object (including null) set by the setSchema(Schema) method.
        返回：
        the Schema object for validation or null if not present

      • setEventHandler

        public abstract void setEventHandler(ValidationEventHandler handler)
                              throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the Binder unmarshal, marshal and update methods.

        Calling this method with a null parameter will cause the Binder to revert back to the default default event handler.

        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        public abstract ValidationEventHandler getEventHandler()
                                                throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        public abstract void setProperty(String name,
               Object value)
                          throws PropertyException
        Set the particular property in the underlying implementation of Binder. This method can only be used to set one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        public abstract Object getProperty(String name)
                            throws PropertyException
        Get the particular property in the underlying implementation of Binder. This method can only be used to get one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DataBindingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 DataBindingException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
  • 所有已实现的接口：
    Serializable

    public class DataBindingException
extends RuntimeException
    Exception that represents a failure in a JAXB operation.

    This exception differs from JAXBException in that this is an unchecked exception, while JAXBException is a checked exception.

    从以下版本开始：
    JAXB2.1
    另请参见：
    JAXB, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DataBindingException(String message, Throwable cause)
      DataBindingException(Throwable cause)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DataBindingException

        public DataBindingException(String message,
                    Throwable cause)

      • DataBindingException

        public DataBindingException(Throwable cause)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

coox&b


DatatypeConverter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

类 DatatypeConverter

  • java.lang.Object
    • javax.xml.bind.DatatypeConverter

  • public final class DatatypeConverter
extends Object

    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype. Customizations can involve writing a parse and print method for parsing and printing lexical representations of a XML schema datatype respectively. However, writing parse and print methods requires knowledge of the lexical representations ( XML Schema Part2: Datatypes specification ) and hence may be difficult to write.

    This class makes it easier to write parse and print methods. It defines static parse and print methods that provide access to a JAXB provider's implementation of parse and print methods. These methods are invoked by custom parse and print methods. For example, the binding of xsd:dateTime to a long can be customized using parse and print methods as follows:

        // Customized parse method
    public long myParseCal( String dateTimeString ) {
        java.util.Calendar cal = DatatypeConverter.parseDateTime(dateTimeString);
        long longval = convert_calendar_to_long(cal); //application specific
        return longval;
    }

    // Customized print method
    public String myPrintCal( Long longval ) {
        java.util.Calendar cal = convert_long_to_calendar(longval) ; //application specific
        String dateTimeString = DatatypeConverter.printDateTime(cal);
        return dateTimeString;
    }

    There is a static parse and print method corresponding to each parse and print method respectively in the DatatypeConverterInterface.

    The static methods defined in the class can also be used to specify a parse or a print method in a javaType binding declaration.

    JAXB Providers are required to call the setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    从以下版本开始：
    JAXB1.0
    另请参见：
    DatatypeConverterInterface, ParseConversionEvent, PrintConversionEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      static byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      static boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      static byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      static Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      static Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      static BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      static double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      static float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      static byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      static int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      static BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      static long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      static QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      static short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      static String parseString(String lexicalXSDString)
      Convert the lexical XSD string argument into a String value.
      static Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      static long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      static int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      static String printAnySimpleType(String val)
      Converts a string value into a string.
      static String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      static String printBoolean(boolean val)
      Converts a boolean value into a string.
      static String printByte(byte val)
      Converts a byte value into a string.
      static String printDate(Calendar val)
      Converts a Calendar value into a string.
      static String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      static String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      static String printDouble(double val)
      Converts a double value into a string.
      static String printFloat(float val)
      Converts a float value into a string.
      static String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      static String printInt(int val)
      Converts an int value into a string.
      static String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      static String printLong(long val)
      Converts A long value into a string.
      static String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String printShort(short val)
      Converts a short value into a string.
      static String printString(String val)
      Converts the string argument into a string.
      static String printTime(Calendar val)
      Converts a Calendar value into a string.
      static String printUnsignedInt(long val)
      Converts a long value into a string.
      static String printUnsignedShort(int val)
      Converts an int value into a string.
      static void setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • setDatatypeConverter

        public static void setDatatypeConverter(DatatypeConverterInterface converter)
        This method is for JAXB provider use only.

        JAXB Providers are required to call this method at some point before allowing any of the JAXB client marshal or unmarshal operations to occur. This is necessary to configure the datatype converter that should be used to perform the print and parse conversions.

        Calling this api repeatedly will have no effect - the DatatypeConverterInterface instance passed into the first invocation is the one that will be used from then on.

        参数：
        converter - an instance of a class that implements the DatatypeConverterInterface class - this parameter must not be null.
        抛出：
        IllegalArgumentException - if the parameter is null
        SecurityException - If the SecurityManager in charge denies the access to set the datatype converter.
        另请参见：
        JAXBPermission

      • parseString

        public static String parseString(String lexicalXSDString)

        Convert the lexical XSD string argument into a String value.

        参数：
        lexicalXSDString - A string containing a lexical representation of xsd:string.
        返回：
        A String value represented by the string argument.

      • parseInteger

        public static BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        参数：
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        返回：
        A BigInteger value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        public static int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        参数：
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        返回：
        A int value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        public static long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        参数：
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        返回：
        A long value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        public static short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        参数：
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        返回：
        A short value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        public static BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        参数：
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        返回：
        A BigDecimal value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        public static float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        参数：
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        返回：
        A float value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        public static double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        参数：
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        返回：
        A double value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        public static boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        参数：
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        返回：
        A boolean value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        public static byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        参数：
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        返回：
        A byte value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        public static QName parseQName(String lexicalXSDQName,
               NamespaceContext nsc)

        Converts the string argument into a byte value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        参数：
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        返回：
        A QName value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        public static Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        返回：
        A Calendar object represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        public static byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        参数：
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        返回：
        An array of bytes represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        public static byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        参数：
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        返回：
        An array of bytes represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        public static long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        参数：
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        返回：
        A long value represented by the string argument.
        抛出：
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        public static int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        参数：
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        返回：
        An int value represented by the string argument.
        抛出：
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        public static Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDTime - A string containing lexical representation of xsd:time.
        返回：
        A Calendar value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        public static Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        返回：
        A Calendar value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        public static String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        参数：
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        返回：
        A string containing the lexical representation of the simple type.

      • printString

        public static String printString(String val)

        Converts the string argument into a string.

        参数：
        val - A string value.
        返回：
        A string containing a lexical representation of xsd:string.

      • printInteger

        public static String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        参数：
        val - A BigInteger value
        返回：
        A string containing a lexical representation of xsd:integer
        抛出：
        IllegalArgumentException - val is null.

      • printInt

        public static String printInt(int val)

        Converts an int value into a string.

        参数：
        val - An int value
        返回：
        A string containing a lexical representation of xsd:int

      • printLong

        public static String printLong(long val)

        Converts A long value into a string.

        参数：
        val - A long value
        返回：
        A string containing a lexical representation of xsd:long

      • printShort

        public static String printShort(short val)

        Converts a short value into a string.

        参数：
        val - A short value
        返回：
        A string containing a lexical representation of xsd:short

      • printDecimal

        public static String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        参数：
        val - A BigDecimal value
        返回：
        A string containing a lexical representation of xsd:decimal
        抛出：
        IllegalArgumentException - val is null.

      • printFloat

        public static String printFloat(float val)

        Converts a float value into a string.

        参数：
        val - A float value
        返回：
        A string containing a lexical representation of xsd:float

      • printDouble

        public static String printDouble(double val)

        Converts a double value into a string.

        参数：
        val - A double value
        返回：
        A string containing a lexical representation of xsd:double

      • printBoolean

        public static String printBoolean(boolean val)

        Converts a boolean value into a string.

        参数：
        val - A boolean value
        返回：
        A string containing a lexical representation of xsd:boolean

      • printByte

        public static String printByte(byte val)

        Converts a byte value into a string.

        参数：
        val - A byte value
        返回：
        A string containing a lexical representation of xsd:byte

      • printQName

        public static String printQName(QName val,
                NamespaceContext nsc)

        Converts a QName instance into a string.

        参数：
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        返回：
        A string containing a lexical representation of QName
        抛出：
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        public static String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:dateTime
        抛出：
        IllegalArgumentException - if val is null.

      • printBase64Binary

        public static String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        参数：
        val - An array of bytes
        返回：
        A string containing a lexical representation of xsd:base64Binary
        抛出：
        IllegalArgumentException - if val is null.

      • printHexBinary

        public static String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        参数：
        val - An array of bytes
        返回：
        A string containing a lexical representation of xsd:hexBinary
        抛出：
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        public static String printUnsignedInt(long val)

        Converts a long value into a string.

        参数：
        val - A long value
        返回：
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        public static String printUnsignedShort(int val)

        Converts an int value into a string.

        参数：
        val - An int value
        返回：
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        public static String printTime(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:time
        抛出：
        IllegalArgumentException - if val is null.

      • printDate

        public static String printDate(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:date
        抛出：
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        public static String printAnySimpleType(String val)

        Converts a string value into a string.

        参数：
        val - A string value
        返回：
        A string containing a lexical representation of xsd:AnySimpleType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DatatypeConverterInterface

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface DatatypeConverterInterface

  • public interface DatatypeConverterInterface

    The DatatypeConverterInterface is for JAXB provider use only. A JAXB provider must supply a class that implements this interface. JAXB Providers are required to call the DatatypeConverter.setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality. Calling this api repeatedly will have no effect - the DatatypeConverter instance passed into the first invocation is the one that will be used from then on.

    This interface defines the parse and print methods. There is one parse and print method for each XML schema datatype specified in the the default binding Table 5-1 in the JAXB specification.

    The parse and print methods defined here are invoked by the static parse and print methods defined in the DatatypeConverter class.

    A parse method for a XML schema datatype must be capable of converting any lexical representation of the XML schema datatype ( specified by the XML Schema Part2: Datatypes specification into a value in the value space of the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException or a subclass of IllegalArgumentException must be thrown by the method.

    A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

    The prefix xsd: is used to refer to XML schema datatypes XML Schema Part2: Datatypes specification.

    从以下版本开始：
    JAXB1.0
    另请参见：
    DatatypeConverter, ParseConversionEvent, PrintConversionEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String parseAnySimpleType(String lexicalXSDAnySimpleType)
      Return a string containing the lexical representation of the simple type.
      byte[] parseBase64Binary(String lexicalXSDBase64Binary)
      Converts the string argument into an array of bytes.
      boolean parseBoolean(String lexicalXSDBoolean)
      Converts the string argument into a boolean value.
      byte parseByte(String lexicalXSDByte)
      Converts the string argument into a byte value.
      Calendar parseDate(String lexicalXSDDate)
      Converts the string argument into a Calendar value.
      Calendar parseDateTime(String lexicalXSDDateTime)
      Converts the string argument into a Calendar value.
      BigDecimal parseDecimal(String lexicalXSDDecimal)
      Converts the string argument into a BigDecimal value.
      double parseDouble(String lexicalXSDDouble)
      Converts the string argument into a double value.
      float parseFloat(String lexicalXSDFloat)
      Converts the string argument into a float value.
      byte[] parseHexBinary(String lexicalXSDHexBinary)
      Converts the string argument into an array of bytes.
      int parseInt(String lexicalXSDInt)
      Convert the string argument into an int value.
      BigInteger parseInteger(String lexicalXSDInteger)
      Convert the string argument into a BigInteger value.
      long parseLong(String lexicalXSDLong)
      Converts the string argument into a long value.
      QName parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      short parseShort(String lexicalXSDShort)
      Converts the string argument into a short value.
      String parseString(String lexicalXSDString)
      Convert the string argument into a string.
      Calendar parseTime(String lexicalXSDTime)
      Converts the string argument into a Calendar value.
      long parseUnsignedInt(String lexicalXSDUnsignedInt)
      Converts the string argument into a long value.
      int parseUnsignedShort(String lexicalXSDUnsignedShort)
      Converts the string argument into an int value.
      String printAnySimpleType(String val)
      Converts a string value into a string.
      String printBase64Binary(byte[] val)
      Converts an array of bytes into a string.
      String printBoolean(boolean val)
      Converts a boolean value into a string.
      String printByte(byte val)
      Converts a byte value into a string.
      String printDate(Calendar val)
      Converts a Calendar value into a string.
      String printDateTime(Calendar val)
      Converts a Calendar value into a string.
      String printDecimal(BigDecimal val)
      Converts a BigDecimal value into a string.
      String printDouble(double val)
      Converts a double value into a string.
      String printFloat(float val)
      Converts a float value into a string.
      String printHexBinary(byte[] val)
      Converts an array of bytes into a string.
      String printInt(int val)
      Converts an int value into a string.
      String printInteger(BigInteger val)
      Converts a BigInteger value into a string.
      String printLong(long val)
      Converts a long value into a string.
      String printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      String printShort(short val)
      Converts a short value into a string.
      String printString(String val)
      Converts the string argument into a string.
      String printTime(Calendar val)
      Converts a Calendar value into a string.
      String printUnsignedInt(long val)
      Converts a long value into a string.
      String printUnsignedShort(int val)
      Converts an int value into a string.

    • 方法详细信息

      • parseString

        String parseString(String lexicalXSDString)

        Convert the string argument into a string.

        参数：
        lexicalXSDString - A lexical representation of the XML Schema datatype xsd:string
        返回：
        A string that is the same as the input string.

      • parseInteger

        BigInteger parseInteger(String lexicalXSDInteger)

        Convert the string argument into a BigInteger value.

        参数：
        lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
        返回：
        A BigInteger value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

      • parseInt

        int parseInt(String lexicalXSDInt)

        Convert the string argument into an int value.

        参数：
        lexicalXSDInt - A string containing a lexical representation of xsd:int.
        返回：
        An int value represented byte the string argument.
        抛出：
        NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

      • parseLong

        long parseLong(String lexicalXSDLong)

        Converts the string argument into a long value.

        参数：
        lexicalXSDLong - A string containing lexical representation of xsd:long.
        返回：
        A long value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

      • parseShort

        short parseShort(String lexicalXSDShort)

        Converts the string argument into a short value.

        参数：
        lexicalXSDShort - A string containing lexical representation of xsd:short.
        返回：
        A short value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

      • parseDecimal

        BigDecimal parseDecimal(String lexicalXSDDecimal)

        Converts the string argument into a BigDecimal value.

        参数：
        lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
        返回：
        A BigDecimal value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

      • parseFloat

        float parseFloat(String lexicalXSDFloat)

        Converts the string argument into a float value.

        参数：
        lexicalXSDFloat - A string containing lexical representation of xsd:float.
        返回：
        A float value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

      • parseDouble

        double parseDouble(String lexicalXSDDouble)

        Converts the string argument into a double value.

        参数：
        lexicalXSDDouble - A string containing lexical representation of xsd:double.
        返回：
        A double value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

      • parseBoolean

        boolean parseBoolean(String lexicalXSDBoolean)

        Converts the string argument into a boolean value.

        参数：
        lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
        返回：
        A boolean value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

      • parseByte

        byte parseByte(String lexicalXSDByte)

        Converts the string argument into a byte value.

        参数：
        lexicalXSDByte - A string containing lexical representation of xsd:byte.
        返回：
        A byte value represented by the string argument.
        抛出：
        NumberFormatException - lexicalXSDByte does not contain a parseable byte.
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

      • parseQName

        QName parseQName(String lexicalXSDQName,
               NamespaceContext nsc)

        Converts the string argument into a QName value.

        String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

        参数：
        lexicalXSDQName - A string containing lexical representation of xsd:QName.
        nsc - A namespace context for interpreting a prefix within a QName.
        返回：
        A QName value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

      • parseDateTime

        Calendar parseDateTime(String lexicalXSDDateTime)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
        返回：
        A Calendar object represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

      • parseBase64Binary

        byte[] parseBase64Binary(String lexicalXSDBase64Binary)

        Converts the string argument into an array of bytes.

        参数：
        lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
        返回：
        An array of bytes represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

      • parseHexBinary

        byte[] parseHexBinary(String lexicalXSDHexBinary)

        Converts the string argument into an array of bytes.

        参数：
        lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
        返回：
        An array of bytes represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

      • parseUnsignedInt

        long parseUnsignedInt(String lexicalXSDUnsignedInt)

        Converts the string argument into a long value.

        参数：
        lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
        返回：
        A long value represented by the string argument.
        抛出：
        NumberFormatException - if string parameter can not be parsed into a long value.

      • parseUnsignedShort

        int parseUnsignedShort(String lexicalXSDUnsignedShort)

        Converts the string argument into an int value.

        参数：
        lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
        返回：
        An int value represented by the string argument.
        抛出：
        NumberFormatException - if string parameter can not be parsed into an int value.

      • parseTime

        Calendar parseTime(String lexicalXSDTime)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDTime - A string containing lexical representation of xsd:Time.
        返回：
        A Calendar value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

      • parseDate

        Calendar parseDate(String lexicalXSDDate)

        Converts the string argument into a Calendar value.

        参数：
        lexicalXSDDate - A string containing lexical representation of xsd:Date.
        返回：
        A Calendar value represented by the string argument.
        抛出：
        IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

      • parseAnySimpleType

        String parseAnySimpleType(String lexicalXSDAnySimpleType)

        Return a string containing the lexical representation of the simple type.

        参数：
        lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
        返回：
        A string containing the lexical representation of the simple type.

      • printString

        String printString(String val)

        Converts the string argument into a string.

        参数：
        val - A string value.
        返回：
        A string containing a lexical representation of xsd:string

      • printInteger

        String printInteger(BigInteger val)

        Converts a BigInteger value into a string.

        参数：
        val - A BigInteger value
        返回：
        A string containing a lexical representation of xsd:integer
        抛出：
        IllegalArgumentException - val is null.

      • printInt

        String printInt(int val)

        Converts an int value into a string.

        参数：
        val - An int value
        返回：
        A string containing a lexical representation of xsd:int

      • printLong

        String printLong(long val)

        Converts a long value into a string.

        参数：
        val - A long value
        返回：
        A string containing a lexical representation of xsd:long

      • printShort

        String printShort(short val)

        Converts a short value into a string.

        参数：
        val - A short value
        返回：
        A string containing a lexical representation of xsd:short

      • printDecimal

        String printDecimal(BigDecimal val)

        Converts a BigDecimal value into a string.

        参数：
        val - A BigDecimal value
        返回：
        A string containing a lexical representation of xsd:decimal
        抛出：
        IllegalArgumentException - val is null.

      • printFloat

        String printFloat(float val)

        Converts a float value into a string.

        参数：
        val - A float value
        返回：
        A string containing a lexical representation of xsd:float

      • printDouble

        String printDouble(double val)

        Converts a double value into a string.

        参数：
        val - A double value
        返回：
        A string containing a lexical representation of xsd:double

      • printBoolean

        String printBoolean(boolean val)

        Converts a boolean value into a string.

        参数：
        val - A boolean value
        返回：
        A string containing a lexical representation of xsd:boolean

      • printByte

        String printByte(byte val)

        Converts a byte value into a string.

        参数：
        val - A byte value
        返回：
        A string containing a lexical representation of xsd:byte

      • printQName

        String printQName(QName val,
                NamespaceContext nsc)

        Converts a QName instance into a string.

        参数：
        val - A QName value
        nsc - A namespace context for interpreting a prefix within a QName.
        返回：
        A string containing a lexical representation of QName
        抛出：
        IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

      • printDateTime

        String printDateTime(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:dateTime
        抛出：
        IllegalArgumentException - if val is null.

      • printBase64Binary

        String printBase64Binary(byte[] val)

        Converts an array of bytes into a string.

        参数：
        val - an array of bytes
        返回：
        A string containing a lexical representation of xsd:base64Binary
        抛出：
        IllegalArgumentException - if val is null.

      • printHexBinary

        String printHexBinary(byte[] val)

        Converts an array of bytes into a string.

        参数：
        val - an array of bytes
        返回：
        A string containing a lexical representation of xsd:hexBinary
        抛出：
        IllegalArgumentException - if val is null.

      • printUnsignedInt

        String printUnsignedInt(long val)

        Converts a long value into a string.

        参数：
        val - A long value
        返回：
        A string containing a lexical representation of xsd:unsignedInt

      • printUnsignedShort

        String printUnsignedShort(int val)

        Converts an int value into a string.

        参数：
        val - An int value
        返回：
        A string containing a lexical representation of xsd:unsignedShort

      • printTime

        String printTime(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:time
        抛出：
        IllegalArgumentException - if val is null.

      • printDate

        String printDate(Calendar val)

        Converts a Calendar value into a string.

        参数：
        val - A Calendar value
        返回：
        A string containing a lexical representation of xsd:date
        抛出：
        IllegalArgumentException - if val is null.

      • printAnySimpleType

        String printAnySimpleType(String val)

        Converts a string value into a string.

        参数：
        val - A string value
        返回：
        A string containing a lexical representation of xsd:AnySimpleType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a >xuelmelaAAlaaIacc><<>dfor=s.=.


Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.bind

Interface Element

  • public interface Element
    This is an element marker interface. Under certain circumstances, it is necessary for the binding compiler to generate derived java content classes that implement this interface. In those cases, client applications must supply element instances rather than types of elements. For more detail, see section 5.7 "Element Declaration" and 5.7.1 "Bind to Java Element Interface" of the specification.
    从以下版本开始：
    JAXB1.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lryigvngvneevnnocyytedo


javax.xml.bind

Interfaces

  • DatatypeConverterInterface
  • Element
  • Marshaller
  • NotIdentifiableEvent
  • ParseConversionEvent
  • PrintConversionEvent
  • Unmarshaller
  • UnmarshallerHandler
  • ValidationEvent
  • ValidationEventHandler
  • ValidationEventLocator
  • Validator

Classes

  • Binder
  • DatatypeConverter
  • JAXB
  • JAXBContext
  • JAXBElement
  • JAXBElement.GlobalScope
  • JAXBIntrospector
  • JAXBPermission
  • Marshaller.Listener
  • SchemaOutputResolver
  • Unmarshaller.Listener

Exceptions

  • DataBindingException
  • JAXBException
  • MarshalException
  • PropertyException
  • TypeConstraintException
  • UnmarshalException
  • ValidationException
d


javax.xml.bind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

请参见： 描述

  • 接口摘要
    接口 描述
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    Element
    This is an element marker interface.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator Deprecated
    since JAXB 2.0
  • Class Summary
    类 描述
    Binder<XmlNode>
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverter
    The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
    JAXB
    Class that defines convenience methods for common, simple use of JAXB.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement<T>
    JAXB representation of an Xml Element.
    JAXBElement.GlobalScope
    Designates global scope for an xml element.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    JAXBPermission
    This class is for JAXB permissions.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
  • Exception Summary
    Exception 描述
    DataBindingException
    Exception that represents a failure in a JAXB operation.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    MarshalException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    TypeConstraintException
    This exception indicates that a violation of a dynamically checked type constraint was detected.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    ValidationException
    This exception indicates that an error has occurred while performing a validate operation.

软件包 javax.xml.bind Description

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

JAXBContext is the client-entry point to the runtime binding framework.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s aka


javax.xml.bind Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>
    • javax.xml.bind.DatatypeConverter
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.xml.bind.Marshaller.Listener
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.bind.JAXBPermission
    • javax.xml.bind.SchemaOutputResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • java.lang.RuntimeException
          • javax.xml.bind.DataBindingException
          • javax.xml.bind.TypeConstraintException
    • javax.xml.bind.Unmarshaller.Listener

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.xml.bind.DatatypeConverterInterface
  • javax.xml.bind.Element
  • javax.xml.bind.Marshaller
  • javax.xml.bind.Unmarshaller
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


JAXB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

类 JAXB

  • java.lang.Object
    • javax.xml.bind.JAXB

  • public final class JAXB
extends Object
    Class that defines convenience methods for common, simple use of JAXB.

    Methods defined in this class are convenience methods that combine several basic operations in the JAXBContext, Unmarshaller, and Marshaller. They are designed to be the prefered methods for developers new to JAXB. They have the following characterstics:

    1. Generally speaking, the performance is not necessarily optimal. It is expected that people who need to write performance critical code will use the rest of the JAXB API directly.
    2. Errors that happen during the processing is wrapped into DataBindingException (which will have JAXBException as its cause. It is expected that people who prefer the checked exception would use the rest of the JAXB API directly.

    In addition, the unmarshal methods have the following characteristic:

    1. Schema validation is not performed on the input XML. The processing will try to continue even if there are errors in the XML, as much as possible. Only as the last resort, this method fails with DataBindingException.

    Similarly, the marshal methods have the following characteristic:

    1. The processing will try to continue even if the Java object tree does not meet the validity requirement. Only as the last resort, this method fails with DataBindingException.

    All the methods on this class require non-null arguments to all parameters. The unmarshal methods either fail with an exception or return a non-null value.

    从以下版本开始：
    2.1

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static void marshal(Object jaxbObject, File xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, OutputStream xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Result xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, String xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URI xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, URL xml)
      Writes a Java object tree to XML and store it to the specified location.
      static void marshal(Object jaxbObject, Writer xml)
      Writes a Java object tree to XML and store it to the specified location.
      static <T> T unmarshal(File xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(InputStream xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Reader xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(Source xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(String xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URI xml, 类<T> type)
      Reads in a Java object tree from the given XML input.
      static <T> T unmarshal(URL xml, 类<T> type)
      Reads in a Java object tree from the given XML input.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • unmarshal

        public static <T> T unmarshal(File xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - Reads the entire file as XML.

      • unmarshal

        public static <T> T unmarshal(URL xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The resource pointed by the URL is read in its entirety.

      • unmarshal

        public static <T> T unmarshal(URI xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The URI is turned into URL and then follows the handling of URL.

      • unmarshal

        public static <T> T unmarshal(String xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File

      • unmarshal

        public static <T> T unmarshal(InputStream xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The entire stream is read as an XML infoset. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Reader xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The character stream is read as an XML infoset. The encoding declaration in the XML will be ignored. Upon a successful completion, the stream will be closed by this method.

      • unmarshal

        public static <T> T unmarshal(Source xml,
              类<T> type)
        Reads in a Java object tree from the given XML input.
        参数：
        xml - The XML infoset that the Source represents is read.

      • marshal

        public static void marshal(Object jaxbObject,
           File xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - XML will be written to this file. If it already exists, it will be overwritten.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           URL xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the resource pointed by this URL. Note that not all URLs support such operation, and exact semantics depends on the URL implementations. In case of HTTP URLs, this will perform HTTP POST.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           URI xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The URI is turned into URL and then follows the handling of URL. See above.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           String xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The string is first interpreted as an absolute URI. If it's not a valid absolute URI, then it's interpreted as a File
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           OutputStream xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the given OutputStream. Upon a successful completion, the stream will be closed by this method.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           Writer xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent as a character stream to the given Writer. Upon a successful completion, the stream will be closed by this method.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.

      • marshal

        public static void marshal(Object jaxbObject,
           Result xml)
        Writes a Java object tree to XML and store it to the specified location.
        参数：
        jaxbObject - The Java object to be marshalled into XML. If this object is a JAXBElement, it will provide the root tag name and the body. If this object has XmlRootElement on its class definition, that will be used as the root tag name and the given object will provide the body. Otherwise, the root tag name is infered from the short class name. This parameter must not be null.
        xml - The XML will be sent to the Result object.
        抛出：
        DataBindingException - If the operation fails, such as due to I/O error, unbindable classes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xalf


JAXBContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 JAXBContext

  • java.lang.Object
    • javax.xml.bind.JAXBContext

  • public abstract class JAXBContext
extends Object

    The JAXBContext class provides the client's entry point to the JAXB API. It provides an abstraction for managing the XML/Java binding information necessary to implement the JAXB binding framework operations: unmarshal, marshal and validate.

    A client application normally obtains new instances of this class using one of these two styles for newInstance methods, although there are other specialized forms of the method available:

    • JAXBContext.newInstance( "com.acme.foo:com.acme.bar" )
      The JAXBContext instance is initialized from a list of colon separated Java package names. Each java package contains JAXB mapped classes, schema-derived classes and/or user annotated classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS 3rd Edition, Section 7.4.1. Package Annotations).
    • JAXBContext.newInstance( com.acme.foo.Foo.class )
      The JAXBContext instance is intialized with class(es) passed as parameter(s) and classes that are statically reachable from these class(es). See newInstance(Class...) for details.

    SPEC REQUIREMENT: the provider must supply an implementation class containing the following method signatures:

     public static JAXBContext createContext( String contextPath, ClassLoader classLoader, Map properties ) throws JAXBException
 public static JAXBContext createContext( Class[] classes, Map properties ) throws JAXBException

    The following JAXB 1.0 requirement is only required for schema to java interface/implementation binding. It does not apply to JAXB annotated classes. JAXB Providers must generate a jaxb.properties file in each package containing schema derived classes. The property file must contain a property named javax.xml.bind.context.factory whose value is the name of the class that implements the createContext APIs.

    The class supplied by the provider does not have to be assignable to javax.xml.bind.JAXBContext, it simply has to provide a class that implements the createContext APIs.

    In addition, the provider must call the DatatypeConverter.setDatatypeConverter api prior to any client invocations of the marshal and unmarshal methods. This is necessary to configure the datatype converter that will be used during these operations.

    Unmarshalling

    The Unmarshaller class provides the client application the ability to convert XML data into a tree of Java content objects. The unmarshal method allows for any global XML element declared in the schema to be unmarshalled as the root of an instance document. Additionally, the unmarshal method allows for an unrecognized root element that has an xsi:type attribute's value that references a type definition declared in the schema to be unmarshalled as the root of an instance document. The JAXBContext object allows the merging of global elements and type definitions across a set of schemas (listed in the contextPath). Since each schema in the schema set can belong to distinct namespaces, the unification of schemas to an unmarshalling context should be namespace independent. This means that a client application is able to unmarshal XML documents that are instances of any of the schemas listed in the contextPath. For example:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo:com.acme.bar" );
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) ); // ok
        BarObject barObj = (BarObject)u.unmarshal( new File( "bar.xml" ) ); // ok
        BazObject bazObj = (BazObject)u.unmarshal( new File( "baz.xml" ) ); // error, "com.acme.baz" not in contextPath

    The client application may also generate Java content trees explicitly rather than unmarshalling existing XML data. For all JAXB-annotated value classes, an application can create content using constructors. For schema-derived interface/implementation classes and for the creation of elements that are not bound to a JAXB-annotated class, an application needs to have access and knowledge about each of the schema derived ObjectFactory classes that exist in each of java packages contained in the contextPath. For each schema derived java class, there is a static factory method that produces objects of that type. For example, assume that after compiling a schema, you have a package com.acme.foo that contains a schema derived interface named PurchaseOrder. In order to create objects of that type, the client application would use the factory method like this:

           com.acme.foo.PurchaseOrder po =
           com.acme.foo.ObjectFactory.createPurchaseOrder();

    Once the client application has an instance of the the schema derived object, it can use the mutator methods to set content on it.

    For more information on the generated ObjectFactory classes, see Section 4.2 Java Package of the specification.

    SPEC REQUIREMENT: the provider must generate a class in each package that contains all of the necessary object factory methods for that package named ObjectFactory as well as the static newInstance( javaContentInterface ) method

    Marshalling

    The Marshaller class provides the client application the ability to convert a Java content tree back into XML data. There is no difference between marshalling a content tree that is created manually using the factory methods and marshalling a content tree that is the result an unmarshal operation. Clients can marshal a java content tree back to XML data to a java.io.OutputStream or a java.io.Writer. The marshalling process can alternatively produce SAX2 event streams to a registered ContentHandler or produce a DOM Node object. Client applications have control over the output encoding as well as whether or not to marshal the XML data as a complete document or as a fragment.

    Here is a simple example that unmarshals an XML document and then marshals it back out:

            JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );

        // unmarshal from foo.xml
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) );

        // marshal to System.out
        Marshaller m = jc.createMarshaller();
        m.marshal( fooObj, System.out );

    Validation

    Validation has been changed significantly since JAXB 1.0. The Validator class has been deprecated and made optional. This means that you are advised not to use this class and, in fact, it may not even be available depending on your JAXB provider. JAXB 1.0 client applications that rely on Validator will still work properly when deployed with the JAXB 1.0 runtime system. In JAXB 2.0, the Unmarshaller has included convenince methods that expose the JAXP 1.3 javax.xml.validation framework. Please refer to the Unmarshaller.setSchema(javax.xml.validation.Schema) API for more information.

    JAXB Runtime Binding Framework Compatibility

    The following JAXB 1.0 restriction only applies to binding schema to interfaces/implementation classes. Since this binding does not require a common runtime system, a JAXB client application must not attempt to mix runtime objects (JAXBContext, Marshaller, etc. ) from different providers. This does not mean that the client application isn't portable, it simply means that a client has to use a runtime system provided by the same provider that was used to compile the schema.

    Discovery of JAXB implementation

    When one of the newInstance methods is called, a JAXB implementation is discovered by the following steps.

    1. For each package/class explicitly passed in to the newInstance(java.lang.String) method, in the order they are specified, jaxb.properties file is looked up in its package, by using the associated classloader — this is the owner class loader for a 类 argument, and for a package the speified ClassLoader.

      If such a file is discovered, it is loaded as a property file, and the value of the JAXB_CONTEXT_FACTORY key will be assumed to be the provider factory class. This class is then loaded by the associated classloader discussed above.

      This phase of the look up allows some packages to force the use of a certain JAXB implementation. (For example, perhaps the schema compiler has generated some vendor extension in the code.)

    2. If the system property JAXB_CONTEXT_FACTORY exists, then its value is assumed to be the provider factory class. This phase of the look up enables per-JVM override of the JAXB implementation.
    3. Look for /META-INF/services/javax.xml.bind.JAXBContext file in the associated classloader. This file follows the standard service descriptor convention, and if such a file exists, its content is assumed to be the provider factory class. This phase of the look up is for automatic discovery. It allows users to just put a JAXB implementation in a classpath and use it without any furhter configuration.
    4. Finally, if all the steps above fail, then the rest of the look up is unspecified. That said, the recommended behavior is to simply look for some hard-coded platform default JAXB implementation. This phase of the look up is so that JavaSE can have its own JAXB implementation as the last resort.

    Once the provider factory class is discovered, its public static JAXBContext createContext(String,ClassLoader,Map) method (see newInstance(String, ClassLoader, Map) for the parameter semantics.) or public static JAXBContext createContet(Class[],Map) method (see newInstance(Class[], Map) for the parameter semantics) are invoked to create a JAXBContext.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Marshaller, Unmarshaller, S 7.4.1.1 "Package Annotations" in Java Language Specification, 3rd Edition

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String JAXB_CONTEXT_FACTORY
      The name of the property that contains the name of the class capable of creating new JAXBContext objects.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | JAXBContext()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Binder<Node> createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> createBinder(类<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
      JAXBIntrospector createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
      abstract Marshaller createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator createValidator()
      Deprecated.
      since JAXB2.0
      void generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
      static JAXBContext newInstance(类... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(类[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JAXB_CONTEXT_FACTORY

        public static final String JAXB_CONTEXT_FACTORY
        The name of the property that contains the name of the class capable of creating new JAXBContext objects.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • JAXBContext

        protected JAXBContext()

    • 方法详细信息

      • newInstance

        public static JAXBContext newInstance(String contextPath)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is a convenience method to invoke the newInstance(String,ClassLoader) method with the context class loader of the current thread.

        抛出：
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                      ClassLoader classLoader)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a context path which is a list of colon (':', \u003A) separated java package names that contain schema-derived classes and/or fully qualified JAXB-annotated classes. Schema-derived code is registered with the JAXBContext by the ObjectFactory.class generated per package. Alternatively than being listed in the context path, programmer annotated JAXB mapped classes can be listed in a jaxb.index resource file, format described below. Note that a java package can contain both schema-derived classes and user annotated JAXB classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS 3rd Edition, Section 7.4.1. "Package Annotations").

        Every package listed on the contextPath must meet one or both of the following conditions otherwise a JAXBException will be thrown:

        1. it must contain ObjectFactory.class
        2. it must contain jaxb.index

        Format for jaxb.index

        The file contains a newline-separated list of class names. Space and tab characters, as well as blank lines, are ignored. The comment character is '#' (0x23); on each line all characters following the first comment character are ignored. The file must be encoded in UTF-8. Classes that are reachable, as defined in newInstance(Class...), from the listed classes are also registered with JAXBContext.

        Constraints on class name occuring in a jaxb.index file are:

        • Must not end with ".class".
        • Class names are resolved relative to package containing jaxb.index file. Only classes occuring directly in package containing jaxb.index file are allowed.
        • Fully qualified class names are not allowed. A qualified class name,relative to current package, is only allowed to specify a nested or inner class.

        To maintain compatibility with JAXB 1.0 schema to java interface/implementation binding, enabled by schema customization , the JAXB provider will ensure that each package on the context path has a jaxb.properties file which contains a value for the javax.xml.bind.context.factory property and that all values resolve to the same provider. This requirement does not apply to JAXB annotated classes.

        If there are any global XML element name collisions across the various packages listed on the contextPath, a JAXBException will be thrown.

        Mixing generated interface/impl bindings from multiple JAXB Providers in the same context path may result in a JAXBException being thrown.

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        参数：
        contextPath - list of java package names that contain schema derived class and/or java to schema (JAXB-annotated) mapped classes
        classLoader - This class loader will be used to locate the implementation classes.
        返回：
        a new instance of a JAXBContext
        抛出：
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath

      • newInstance

        public static JAXBContext newInstance(String contextPath,
                      ClassLoader classLoader,
                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        This is mostly the same as newInstance(String, ClassLoader), but this version allows you to pass in provider-specific properties to configure the instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        参数：
        contextPath - list of java package names that contain schema derived classes
        classLoader - This class loader will be used to locate the implementation classes.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        返回：
        a new instance of a JAXBContext
        抛出：
        JAXBException - if an error was encountered while creating the JAXBContext such as
        1. failure to locate either ObjectFactory.class or jaxb.index in the packages
        2. an ambiguity among global elements contained in the contextPath
        3. failure to locate a value for the context factory provider property
        4. mixing schema derived packages from different providers on the same contextPath
        从以下版本开始：
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(类... classesToBeBound)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        The client application must supply a list of classes that the new context object needs to recognize. Not only the new context will recognize all the classes specified, but it will also recognize any classes that are directly/indirectly referenced statically from the specified classes. Subclasses of referenced classes nor @XmlTransient referenced classes are not registered with JAXBContext. For example, in the following Java code, if you do newInstance(Foo.class), the newly created JAXBContext will recognize both Foo and Bar, but not Zot or FooBar:

         class Foo {
      @XmlTransient FooBar c;
      Bar b;
 }
 class Bar { int x; }
 class Zot extends Bar { int y; }
 class FooBar { }
        Therefore, a typical client application only needs to specify the top-level classes, but it needs to be careful.

        Note that for each java package registered with JAXBContext, when the optional package annotations exist, they must be processed. (see JLS 3rd Edition, Section 7.4.1. "Package Annotations").

        The steps involved in discovering the JAXB implementation is discussed in the class javadoc.

        参数：
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        返回：
        A new instance of a JAXBContext. Always non-null valid object.
        抛出：
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null);)
        从以下版本开始：
        JAXB2.0

      • newInstance

        public static JAXBContext newInstance(类[] classesToBeBound,
                      Map<String,?> properties)
                               throws JAXBException

        Obtain a new instance of a JAXBContext class.

        An overloading of newInstance(Class...) to configure 'properties' for this instantiation of JAXBContext.

        The interpretation of properties is up to implementations. Implementations should throw JAXBException if it finds properties that it doesn't understand.

        参数：
        classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
        properties - provider-specific properties. Can be null, which means the same thing as passing in an empty map.
        返回：
        A new instance of a JAXBContext. Always non-null valid object.
        抛出：
        JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
        1. No JAXB implementation was discovered
        2. Classes use JAXB annotations incorrectly
        3. Classes have colliding annotations (i.e., two classes with the same type name)
        4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
        IllegalArgumentException - if the parameter contains null (i.e., newInstance(null,someMap);)
        从以下版本开始：
        JAXB2.0

      • createUnmarshaller

        public abstract Unmarshaller createUnmarshaller()
                                         throws JAXBException
        Create an Unmarshaller object that can be used to convert XML data into a java content tree.
        返回：
        an Unmarshaller object
        抛出：
        JAXBException - if an error was encountered while creating the Unmarshaller object

      • createMarshaller

        public abstract Marshaller createMarshaller()
                                     throws JAXBException
        Create a Marshaller object that can be used to convert a java content tree into XML data.
        返回：
        a Marshaller object
        抛出：
        JAXBException - if an error was encountered while creating the Marshaller object

      • createValidator

        public abstract Validator createValidator()
                                   throws JAXBException
        Deprecated. since JAXB2.0
        Validator has been made optional and deprecated in JAXB 2.0. Please refer to the javadoc for Validator for more detail.

        Create a Validator object that can be used to validate a java content tree against its source schema.

        返回：
        a Validator object
        抛出：
        JAXBException - if an error was encountered while creating the Validator object

      • createBinder

        public <T> Binder<T> createBinder(类<T> domType)
        Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
        参数：
        domType - select the DOM API to use by passing in its DOM Node class.
        返回：
        always a new valid Binder object.
        抛出：
        UnsupportedOperationException - if DOM API corresponding to domType is not supported by the implementation.
        从以下版本开始：
        JAXB2.0

      • createBinder

        public Binder<Node> createBinder()
        Creates a Binder for W3C DOM.
        返回：
        always a new valid Binder object.
        从以下版本开始：
        JAXB2.0

      • createJAXBIntrospector

        public JAXBIntrospector createJAXBIntrospector()
        Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
        返回：
        always return a non-null valid JAXBIntrospector object.
        抛出：
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        从以下版本开始：
        JAXB2.0

      • generateSchema

        public void generateSchema(SchemaOutputResolver outputResolver)
                    throws IOException
        Generates the schema documents for this context.
        参数：
        outputResolver - this object controls the output to which schemas will be sent.
        抛出：
        IOException - if SchemaOutputResolver throws an IOException.
        UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
        从以下版本开始：
        JAXB 2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v


JAXBElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 JAXBElement<T>

  • java.lang.Object
    • javax.xml.bind.JAXBElement<T>
  • 所有已实现的接口：
    Serializable

    public class JAXBElement<T>
extends Object
implements Serializable

    JAXB representation of an Xml Element.

    This class represents information about an Xml Element from both the element declaration within a schema and the element instance value within an xml document with the following properties

    • element's xml tag name
    • value represents the element instance's atttribute(s) and content model
    • element declaration's declaredType (xs:element @type attribute)
    • scope of element declaration
    • boolean nil property. (element instance's xsi:nil attribute)

    The declaredType and scope property are the JAXB class binding for the xml type definition.

    Scope is either JAXBElement.GlobalScope or the Java class representing the complex type definition containing the schema element declaration.

    There is a property constraint that if value is null, then nil must be true. The converse is not true to enable representing a nil element with attribute(s). If nil is true, it is possible that value is non-null so it can hold the value of the attributes associated with a nil element.

    从以下版本开始：
    JAXB 2.0
    另请参见：
    Serialized Form

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  JAXBElement.GlobalScope
      Designates global scope for an xml element.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected 类<T> declaredType
      Java datatype binding for xml element declaration's type.
      protected QName name
      xml element tag name
      protected boolean nil
      true iff the xml element instance has xsi:nil="true".
      protected 类 scope
      Scope of xml element declaration representing this xml element instance.
      protected T value
      xml element value.

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBElement(QName name, 类<T> declaredType, 类 scope, T value)
      Construct an xml element instance.
      JAXBElement(QName name, 类<T> declaredType, T value)
      Construct an xml element instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      类<T> getDeclaredType()
      Returns the Java binding of the xml element declaration's type attribute.
      QName getName()
      Returns the xml element tag name.
      类 getScope()
      Returns scope of xml element declaration.
      T getValue()
      Return the content model and attribute values for this element.
      boolean isGlobalScope()
      Returns true iff this xml element declaration is global.
      boolean isNil()
      Returns true iff this element instance content model is nil.
      boolean isTypeSubstituted()
      Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
      void setNil(boolean value)
      Set whether this element has nil content.
      void setValue(T t)
      Set the content model and attributes of this xml element.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        protected final QName name
        xml element tag name

      • declaredType

        protected final 类<T> declaredType
        Java datatype binding for xml element declaration's type.

      • scope

        protected final 类 scope
        Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

      • value

        protected T value
        xml element value. Represents content model and attributes of an xml element instance.

      • nil

        protected boolean nil
        true iff the xml element instance has xsi:nil="true".

    • 构造方法详细信息

      • JAXBElement

        public JAXBElement(QName name,
           类<T> declaredType,
           类 scope,
           T value)

        Construct an xml element instance.

        参数：
        name - Java binding of xml element tag name
        declaredType - Java binding of xml element declaration's type
        scope - Java binding of scope of xml element declaration. Passing null is the same as passing GlobalScope.class
        value - Java instance representing xml element's value.
        另请参见：
        getScope(), isTypeSubstituted()

      • JAXBElement

        public JAXBElement(QName name,
           类<T> declaredType,
           T value)
        Construct an xml element instance. This is just a convenience method for new JAXBElement(name,declaredType,GlobalScope.class,value)

    • 方法详细信息

      • getDeclaredType

        public 类<T> getDeclaredType()
        Returns the Java binding of the xml element declaration's type attribute.

      • getName

        public QName getName()
        Returns the xml element tag name.

      • setValue

        public void setValue(T t)

        Set the content model and attributes of this xml element.

        When this property is set to null, isNil() must by true. Details of constraint are described at isNil().

        另请参见：
        isTypeSubstituted()

      • getValue

        public T getValue()

        Return the content model and attribute values for this element.

        See isNil() for a description of a property constraint when this value is null

      • getScope

        public 类 getScope()
        Returns scope of xml element declaration.
        返回：
        GlobalScope.class if this element is of global scope.
        另请参见：
        isGlobalScope()

      • isNil

        public boolean isNil()

        Returns true iff this element instance content model is nil.

        This property always returns true when getValue() is null. Note that the converse is not true, when this property is true, getValue() can contain a non-null value for attribute(s). It is valid for a nil xml element to have attribute(s).

      • setNil

        public void setNil(boolean value)

        Set whether this element has nil content.

        另请参见：
        isNil()

      • isGlobalScope

        public boolean isGlobalScope()
        Returns true iff this xml element declaration is global.

      • isTypeSubstituted

        public boolean isTypeSubstituted()
        Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Aol n>ethssutoh.


JAXBElement.GlobalScope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 JAXBElement.GlobalScope

  • java.lang.Object
    • javax.xml.bind.JAXBElement.GlobalScope
  • 封闭类：
    JAXBElement<T>

    public static final class JAXBElement.GlobalScope
extends Object
    Designates global scope for an xml element.

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBElement.GlobalScope()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JAXBElement.GlobalScope

        public JAXBElement.GlobalScope()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dj aapeppeinneiih ee c ei e ic tft


JAXBException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 JAXBException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    MarshalException, PropertyException, UnmarshalException, ValidationException

    public class JAXBException
extends Exception
    This is the root exception class for all JAXB exceptions.
    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBContext, Marshaller, Unmarshaller, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBException(String message)
      Construct a JAXBException with the specified detail message.
      JAXBException(String message, String errorCode)
      Construct a JAXBException with the specified detail message and vendor specific errorCode.
      JAXBException(String message, String errorCode, Throwable exception)
      Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
      JAXBException(String message, Throwable exception)
      Construct a JAXBException with the specified detail message and linkedException.
      JAXBException(Throwable exception)
      Construct a JAXBException with a linkedException.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void printStackTrace(PrintWriter s)
      Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this JAXBException.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JAXBException

        public JAXBException(String message)
        Construct a JAXBException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • JAXBException

        public JAXBException(String message,
             String errorCode)
        Construct a JAXBException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • JAXBException

        public JAXBException(Throwable exception)
        Construct a JAXBException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
             Throwable exception)
        Construct a JAXBException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • JAXBException

        public JAXBException(String message,
             String errorCode,
             Throwable exception)
        Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • 方法详细信息

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        返回：
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        返回：
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        参数：
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this JAXBException.
        重载：
        toString in class Throwable
        返回：
        a string representation of this throwable.

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output

      • getCause

        public Throwable getCause()
        Description copied from class: Throwable
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

        This implementation returns the cause that was supplied via one of the constructors requiring a Throwable, or that was set after creation with the Throwable.initCause(Throwable) method. While it is typically unnecessary to override this method, a subclass can override it to return a cause set by some other means. This is appropriate for a "legacy chained throwable" that predates the addition of chained exceptions to Throwable. Note that it is not necessary to override any of the PrintStackTrace methods, all of which invoke the getCause method to determine the cause of a throwable.

        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pnt < > i >sriptrd//_b<_"ttltsl/a.l...sscd >


JAXBIntrospector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 JAXBIntrospector

  • java.lang.Object
    • javax.xml.bind.JAXBIntrospector

  • public abstract class JAXBIntrospector
extends Object
    Provide access to JAXB xml binding data for a JAXB object.

    Intially, the intent of this class is to just conceptualize how a JAXB application developer can access xml binding information, independent if binding model is java to schema or schema to java. Since accessing the XML element name related to a JAXB element is a highly requested feature, demonstrate access to this binding information. The factory method to get a JAXBIntrospector instance is JAXBContext.createJAXBIntrospector().

    从以下版本开始：
    JAXB2.0
    另请参见：
    JAXBContext.createJAXBIntrospector()

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBIntrospector()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract QName getElementName(Object jaxbElement)
      Get xml element qname for jaxbElement.
      static Object getValue(Object jaxbElement)
      Get the element value of a JAXB element.
      abstract boolean isElement(Object object)
      Return true iff object represents a JAXB element.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JAXBIntrospector

        public JAXBIntrospector()

    • 方法详细信息

      • isElement

        public abstract boolean isElement(Object object)

        Return true iff object represents a JAXB element.

        Parameter object is a JAXB element for following cases:

        1. It is an instance of javax.xml.bind.JAXBElement.
        2. The class of object is annotated with @XmlRootElement.
        另请参见：
        getElementName(Object)

      • getElementName

        public abstract QName getElementName(Object jaxbElement)

        Get xml element qname for jaxbElement.

        参数：
        jaxbElement - is an object that isElement(Object) returned true.
        返回：
        xml element qname associated with jaxbElement; null if jaxbElement is not a JAXB Element.

      • getValue

        public static Object getValue(Object jaxbElement)

        Get the element value of a JAXB element.

        Convenience method to abstract whether working with either a javax.xml.bind.JAXBElement instance or an instance of @XmlRootElement annotated Java class.

        参数：
        jaxbElement - object that #isElement(Object) returns true.
        返回：
        The element value of the jaxbElement.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bllls"ct"cokkcoos< 3snn< mBeEann<靦J<


JAXBPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 JAXBPermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.bind.JAXBPermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class JAXBPermission
extends BasicPermission
    This class is for JAXB permissions. A JAXBPermission contains a name (also referred to as a "target name") but no actions list; you either have the named permission or you don't.

    The target name is the name of the JAXB permission (see below).

    The following table lists all the possible JAXBPermission target names, and for each provides a description of what the permission allows and a discussion of the risks of granting code the permission.

    Permission Target Name | What the Permission Allows | Risks of Allowing this Permission
    setDatatypeConverter | Allows the code to set VM-wide DatatypeConverterInterface via the setDatatypeConverter method that all the methods on DatatypeConverter uses. | Malicious code can set DatatypeConverterInterface, which has VM-wide singleton semantics, before a genuine JAXB implementation sets one. This allows malicious code to gain access to objects that it may otherwise not have access to, such as Frame.getFrames() that belongs to another application running in the same JVM.
    从以下版本开始：
    JAXB 2.2
    另请参见：
    BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBPermission(String name)
      Creates a new JAXBPermission with the specified name.

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • JAXBPermission

        public JAXBPermission(String name)
        Creates a new JAXBPermission with the specified name.
        参数：
        name - The name of the JAXBPermission. As of 2.2 only "setDatatypeConverter" is defined.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orm.e.g.c.tu.cob.phhVF= ==== =p lll<-1


MarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
  • 所有已实现的接口：
    Serializable

    public class MarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.

    The ValidationEventHandler can cause this exception to be thrown during the marshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBException, Marshaller, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MarshalException(String message)
      Construct a MarshalException with the specified detail message.
      MarshalException(String message, String errorCode)
      Construct a MarshalException with the specified detail message and vendor specific errorCode.
      MarshalException(String message, String errorCode, Throwable exception)
      Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      MarshalException(String message, Throwable exception)
      Construct a MarshalException with the specified detail message and linkedException.
      MarshalException(Throwable exception)
      Construct a MarshalException with a linkedException.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MarshalException

        public MarshalException(String message)
        Construct a MarshalException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • MarshalException

        public MarshalException(String message,
                String errorCode)
        Construct a MarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • MarshalException

        public MarshalException(Throwable exception)
        Construct a MarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                Throwable exception)
        Construct a MarshalException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • MarshalException

        public MarshalException(String message,
                String errorCode,
                Throwable exception)
        Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<=/naavai nni c SSii44rarienvlpg


Marshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface Marshaller

  • All Known Implementing Classes:
    AbstractMarshallerImpl

    public interface Marshaller

    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data. It provides the basic marshalling methods:

    Assume the following setup code for all following code fragments:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object element = u.unmarshal( new File( "foo.xml" ) );
       Marshaller m = jc.createMarshaller();

    Marshalling to a File:

           OutputStream os = new FileOutputStream( "nosferatu.xml" );
       m.marshal( element, os );

    Marshalling to a SAX ContentHandler:

           // assume MyContentHandler instanceof ContentHandler
       m.marshal( element, new MyContentHandler() );

    Marshalling to a DOM Node:

           DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.newDocument();

       m.marshal( element, doc );

    Marshalling to a java.io.OutputStream:

           m.marshal( element, System.out );

    Marshalling to a java.io.Writer:

           m.marshal( element, new PrintWriter( System.out ) );

    Marshalling to a javax.xml.transform.SAXResult:

           // assume MyContentHandler instanceof ContentHandler
       SAXResult result = new SAXResult( new MyContentHandler() );

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.DOMResult:

           DOMResult result = new DOMResult();

       m.marshal( element, result );

    Marshalling to a javax.xml.transform.StreamResult:

           StreamResult result = new StreamResult( System.out );

       m.marshal( element, result );

    Marshalling to a javax.xml.stream.XMLStreamWriter:

           XMLStreamWriter xmlStreamWriter =
           XMLOutputFactory.newInstance().createXMLStreamWriter( ... );

       m.marshal( element, xmlStreamWriter );

    Marshalling to a javax.xml.stream.XMLEventWriter:

           XMLEventWriter xmlEventWriter =
           XMLOutputFactory.newInstance().createXMLEventWriter( ... );

       m.marshal( element, xmlEventWriter );

    Marshalling content tree rooted by a JAXB element

    The first parameter of the overloaded Marshaller.marshal(java.lang.Object, ...) methods must be a JAXB element as computed by JAXBIntrospector.isElement(java.lang.Object); otherwise, a Marshaller.marshal method must throw a MarshalException. There exist two mechanisms to enable marshalling an instance that is not a JAXB element. One method is to wrap the instance as a value of a JAXBElement, and pass the wrapper element as the first parameter to a Marshaller.marshal method. For java to schema binding, it is also possible to simply annotate the instance's class with @XmlRootElement.

    Encoding

    By default, the Marshaller will use UTF-8 encoding when generating XML data to a java.io.OutputStream, or a java.io.Writer. Use the setProperty API to change the output encoding used during these marshal operations. Client applications are expected to supply a valid character encoding name as defined in the W3C XML 1.0 Recommendation and supported by your Java Platform.

    Validation and Well-Formedness

    Client applications are not required to validate the Java content tree prior to calling any of the marshal API's. Furthermore, there is no requirement that the Java content tree be valid with respect to its original schema in order to marshal it back into XML data. Different JAXB Providers will support marshalling invalid Java content trees at varying levels, however all JAXB Providers must be able to marshal a valid content tree back to XML data. A JAXB Provider must throw a MarshalException when it is unable to complete the marshal operation due to invalid content. Some JAXB Providers will fully allow marshalling invalid content, others will fail on the first validation error.

    Even when schema validation is not explictly enabled for the marshal operation, it is possible that certain types of validation events will be detected during the operation. Validation events will be reported to the registered event handler. If the client application has not registered an event handler prior to invoking one of the marshal API's, then events will be delivered to a default event handler which will terminate the marshal operation after encountering the first error or fatal error. Note that for JAXB 2.0 and later versions, DefaultValidationEventHandler is no longer used.

    Supported Properties

    All JAXB Providers are required to support the following set of properties. Some providers may support additional properties.

    jaxb.encoding - value must be a java.lang.String
    The output encoding to use when marshalling the XML data. The Marshaller will use "UTF-8" by default if this property is not specified.
    jaxb.formatted.output - value must be a java.lang.Boolean
    This property controls whether or not the Marshaller will format the resulting XML data with line breaks and indentation. A true value for this property indicates human readable indented xml data, while a false value indicates unformatted xml data. The Marshaller will default to false (unformatted) if this property is not specified.
    jaxb.schemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:schemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.noNamespaceSchemaLocation - value must be a java.lang.String
    This property allows the client application to specify an xsi:noNamespaceSchemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
    jaxb.fragment - value must be a java.lang.Boolean
    This property determines whether or not document level events will be generated by the Marshaller. If the property is not specified, the default is false. This property has different implications depending on which marshal api you are using - when this property is set to true:
    • marshal(Object,ContentHandler) - the Marshaller won't
             invoke ContentHandler.startDocument() and
             ContentHandler.endDocument().
    • marshal(Object,Node) - the property has no effect on this API.
    • marshal(Object,OutputStream) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Writer) - the Marshaller won't generate an xml declaration.
    • marshal(Object,Result) - depends on the kind of Result object, see semantics for Node, ContentHandler, and Stream APIs
    • marshal(Object,XMLEventWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.
    • marshal(Object,XMLStreamWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.

    Marshal Event Callbacks

    "The Marshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during marshalling. 'External listeners' allow for centralized processing of marshal events in one callback method rather than by type event callbacks.

    Class defined event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signatures:

       // Invoked by Marshaller after it has created an instance of this object.
   boolean beforeMarshal(Marshaller);

   // Invoked by Marshaller after it has marshalled all properties of this object.
   void afterMmarshal(Marshaller);
    The class defined event callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Marshaller.Listener instance with a setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Marshaller.Listener.beforeMarshal(Object) and Marshaller.Listener.afterMarshal(Object).

    An event callback method throwing an exception terminates the current marshal process.

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBContext, Validator, Unmarshaller

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Marshaller.Listener

      Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String JAXB_ENCODING
      The name of the property used to specify the output encoding in the marshalled XML data.
      static String JAXB_FORMATTED_OUTPUT
      The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
      static String JAXB_FRAGMENT
      The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
      static String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
      The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
      static String JAXB_SCHEMA_LOCATION
      The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <A extends XmlAdapter>
      A             		getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      void marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

    • 字段详细信息

      • JAXB_ENCODING

        static final String JAXB_ENCODING
        The name of the property used to specify the output encoding in the marshalled XML data.
        另请参见：
        Constant Field Values

      • JAXB_FORMATTED_OUTPUT

        static final String JAXB_FORMATTED_OUTPUT
        The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
        另请参见：
        Constant Field Values

      • JAXB_SCHEMA_LOCATION

        static final String JAXB_SCHEMA_LOCATION
        The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.
        另请参见：
        Constant Field Values

      • JAXB_NO_NAMESPACE_SCHEMA_LOCATION

        static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
        The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
        另请参见：
        Constant Field Values

      • JAXB_FRAGMENT

        static final String JAXB_FRAGMENT
        The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
        另请参见：
        Constant Field Values

    • 方法详细信息

      • marshal

        void marshal(Object jaxbElement,
           Result result)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.

        All JAXB Providers must at least support DOMResult, SAXResult, and StreamResult. It can support other derived classes of Result as well.

        参数：
        jaxbElement - The root of content tree to be marshalled.
        result - XML will be sent to this Result
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           OutputStream os)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into an output stream.
        参数：
        jaxbElement - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           File output)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a file.
        参数：
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        从以下版本开始：
        JAXB2.1

      • marshal

        void marshal(Object jaxbElement,
           Writer writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a Writer.
        参数：
        jaxbElement - The root of content tree to be marshalled.
        writer - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           ContentHandler handler)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        参数：
        jaxbElement - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           Node node)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        参数：
        jaxbElement - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null

      • marshal

        void marshal(Object jaxbElement,
           XMLStreamWriter writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        参数：
        jaxbElement - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        从以下版本开始：
        JAXB 2.0

      • marshal

        void marshal(Object jaxbElement,
           XMLEventWriter writer)
             throws JAXBException
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        参数：
        jaxbElement - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
        IllegalArgumentException - If any of the method parameters are null
        从以下版本开始：
        JAXB 2.0

      • getNode

        Node getNode(Object contentTree)
             throws JAXBException
        Get a DOM tree view of the content tree(Optional). If the returned DOM tree is updated, these changes are also visible in the content tree. Use marshal(Object, org.w3c.dom.Node) to force a deep copy of the content tree to a DOM representation.
        参数：
        contentTree - - JAXB Java representation of XML content
        返回：
        the DOM tree view of the contentTree
        抛出：
        UnsupportedOperationException - If the JAXB provider implementation does not support a DOM view of the content tree
        IllegalArgumentException - If any of the method parameters are null
        JAXBException - If any unexpected problem occurs

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Set the particular property in the underlying implementation of Marshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Get the particular property in the underlying implementation of Marshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        抛出：
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB 2.0
        另请参见：
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(类<A> type,
                                     A adapter)
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<类,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        参数：
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        抛出：
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB 2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(类<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        抛出：
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB 2.0

      • setAttachmentMarshaller

        void setAttachmentMarshaller(AttachmentMarshaller am)

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        抛出：
        IllegalStateException - if attempt to concurrently call this method during a marshal operation.

      • getAttachmentMarshaller

        AttachmentMarshaller getAttachmentMarshaller()

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        参数：
        schema - Schema object to validate marshal operations against or null to disable validation
        抛出：
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        从以下版本开始：
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        返回：
        the Schema object being used to perform marshal-time validation or null if not present.
        抛出：
        UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        从以下版本开始：
        JAXB2.0

      • setListener

        void setListener(Marshaller.Listener listener)

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        参数：
        listener - an instance of a class that implements Marshaller.Listener
        从以下版本开始：
        JAXB2.0

      • getListener

        Marshaller.Listener getListener()

        Return Marshaller.Listener registered with this Marshaller.

        返回：
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
        从以下版本开始：
        JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Marshaller.Listener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 Marshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Marshaller.Listener
  • Enclosing interface:
    Marshaller

    public abstract static class Marshaller.Listener
extends Object

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

    This class enables pre and post processing of each marshalled object. The event callbacks are called when marshalling from an instance that maps to an xml element or complex type definition. The event callbacks are not called when marshalling from an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining marshal event callbacks. See Marshal Event Callbacks for an overview.

    从以下版本开始：
    JAXB2.0
    另请参见：
    Marshaller.setListener(Listener), Marshaller.getListener()

    • 构造方法摘要

      Constructors
      构造方法与描述
      Marshaller.Listener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void afterMarshal(Object source)

      Callback method invoked after marshalling source to XML.
      void beforeMarshal(Object source)

      Callback method invoked before marshalling from source to XML.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Marshaller.Listener

        public Marshaller.Listener()

    • 方法详细信息

      • beforeMarshal

        public void beforeMarshal(Object source)

        Callback method invoked before marshalling from source to XML.

        This method is invoked just before marshalling process starts to marshal source. Note that if the class of source defines its own beforeMarshal method, the class specific callback method is invoked just before this method is invoked.

        参数：
        source - instance of JAXB mapped class prior to marshalling from it.

      • afterMarshal

        public void afterMarshal(Object source)

        Callback method invoked after marshalling source to XML.

        This method is invoked after source and all its descendants have been marshalled. Note that if the class of source defines its own afterMarshal method, the class specific callback method is invoked just before this method is invoked.

        参数：
        source - instance of JAXB mapped class after marshalling it.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aex//.=..=f""=ffai ><(dhaeoe


NotIdentifiableEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.bind

Interface NotIdentifiableEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl

    public interface NotIdentifiableEvent
extends ValidationEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEventHandler

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b


ParseConversionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.bind

Interface ParseConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    ParseConversionEventImpl

    public interface ParseConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    从以下版本开始：
    JAXB1.0
    另请参见：
    ValidationEvent, ValidationEventHandler, Unmarshaller

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.viraiarihlhrooroffaLdt aMenonf


PrintConversionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.bind

Interface PrintConversionEvent

  • All Superinterfaces:
    ValidationEvent
    All Known Implementing Classes:
    PrintConversionEventImpl

    public interface PrintConversionEvent
extends ValidationEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    从以下版本开始：
    JAXB1.0
    另请参见：
    ValidationEvent, ValidationEventHandler, Marshaller

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Utd dpd/do /ht>vamm.


PropertyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 PropertyException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.PropertyException
  • 所有已实现的接口：
    Serializable

    public class PropertyException
extends JAXBException
    This exception indicates that an error was encountered while getting or setting a property.
    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBContext, Validator, Unmarshaller, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      PropertyException(String message)
      Construct a PropertyException with the specified detail message.
      PropertyException(String name, Object value)
      Construct a PropertyException whose message field is set based on the name of the property and value.toString().
      PropertyException(String message, String errorCode)
      Construct a PropertyException with the specified detail message and vendor specific errorCode.
      PropertyException(String message, String errorCode, Throwable exception)
      Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
      PropertyException(String message, Throwable exception)
      Construct a PropertyException with the specified detail message and linkedException.
      PropertyException(Throwable exception)
      Construct a PropertyException with a linkedException.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PropertyException

        public PropertyException(String message)
        Construct a PropertyException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • PropertyException

        public PropertyException(String message,
                 String errorCode)
        Construct a PropertyException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • PropertyException

        public PropertyException(Throwable exception)
        Construct a PropertyException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                 Throwable exception)
        Construct a PropertyException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • PropertyException

        public PropertyException(String message,
                 String errorCode,
                 Throwable exception)
        Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

      • PropertyException

        public PropertyException(String name,
                 Object value)
        Construct a PropertyException whose message field is set based on the name of the property and value.toString().
        参数：
        name - the name of the property related to this exception
        value - the value of the property related to this exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

JAtyr"rys' 'eiihottwmh.la.xjoJ/nxs"


SchemaOutputResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 SchemaOutputResolver

  • java.lang.Object
    • javax.xml.bind.SchemaOutputResolver

  • public abstract class SchemaOutputResolver
extends Object
    Controls where a JAXB implementation puts the generates schema files.

    An implementation of this abstract class has to be provided by the calling application to generate schemas.

    This is a class, not an interface so as to allow future versions to evolve without breaking the compatibility.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SchemaOutputResolver()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Result createOutput(String namespaceUri, String suggestedFileName)
      Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SchemaOutputResolver

        public SchemaOutputResolver()

    • 方法详细信息

      • createOutput

        public abstract Result createOutput(String namespaceUri,
                  String suggestedFileName)
                             throws IOException
        Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

        This method is called only once for any given namespace. IOW, all the components in one namespace is always written into the same schema document.

        参数：
        namespaceUri - The namespace URI that the schema declares. Can be the empty string, but never be null.
        suggestedFileName - A JAXB implementation generates an unique file name (like "schema1.xsd") for the convenience of the callee. This name can be used for the file name of the schema, or the callee can just ignore this name and come up with its own name. This is just a hint.
        返回：
        a Result object that encapsulates the actual destination of the schema. If the Result object has a system ID, it must be an absolute system ID. Those system IDs are relativized by the caller and used for <xs:import> statements. If the Result object does not have a system ID, a schema for the namespace URI is generated but it won't be explicitly <xs:import>ed from other schemas. If null is returned, the schema generation for this namespace URI will be skipped.
        抛出：
        IOException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"s/ -----!---!!)h((n troocircev ergdde


TypeConstraintException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 TypeConstraintException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.bind.TypeConstraintException
  • 所有已实现的接口：
    Serializable

    public class TypeConstraintException
extends RuntimeException
    This exception indicates that a violation of a dynamically checked type constraint was detected.

    This exception can be thrown by the generated setter methods of the schema derived Java content classes. However, since fail-fast validation is an optional feature for JAXB Providers to support, not all setter methods will throw this exception when a type constraint is violated.

    If this exception is throw while invoking a fail-fast setter, the value of the property is guaranteed to remain unchanged, as if the setter were never called.

    从以下版本开始：
    JAXB1.0
    另请参见：
    ValidationEvent, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeConstraintException(String message)
      Construct a TypeConstraintException with the specified detail message.
      TypeConstraintException(String message, String errorCode)
      Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.
      TypeConstraintException(String message, String errorCode, Throwable exception)
      Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
      TypeConstraintException(String message, Throwable exception)
      Construct a TypeConstraintException with the specified detail message and linkedException.
      TypeConstraintException(Throwable exception)
      Construct a TypeConstraintException with a linkedException.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getErrorCode()
      Get the vendor specific error code
      Throwable getLinkedException()
      Get the linked exception
      void printStackTrace()
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
      void printStackTrace(PrintStream s)
      Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
      void setLinkedException(Throwable exception)
      Add a linked Exception.
      String toString()
      Returns a short description of this TypeConstraintException.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TypeConstraintException

        public TypeConstraintException(String message)
        Construct a TypeConstraintException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       String errorCode)
        Construct a TypeConstraintException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • TypeConstraintException

        public TypeConstraintException(Throwable exception)
        Construct a TypeConstraintException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       Throwable exception)
        Construct a TypeConstraintException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • TypeConstraintException

        public TypeConstraintException(String message,
                       String errorCode,
                       Throwable exception)
        Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception

    • 方法详细信息

      • getErrorCode

        public String getErrorCode()
        Get the vendor specific error code
        返回：
        a string specifying the vendor specific error code

      • getLinkedException

        public Throwable getLinkedException()
        Get the linked exception
        返回：
        the linked Exception, null if none exists

      • setLinkedException

        public void setLinkedException(Throwable exception)
        Add a linked Exception.
        参数：
        exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

      • toString

        public String toString()
        Returns a short description of this TypeConstraintException.
        重载：
        toString in class Throwable
        返回：
        a string representation of this throwable.

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace()
        Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
        重载：
        printStackTrace in class Throwable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ipapkki=lk>s


UnmarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 UnmarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.UnmarshalException
  • 所有已实现的接口：
    Serializable

    public class UnmarshalException
extends JAXBException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.

    The ValidationEventHandler can cause this exception to be thrown during the unmarshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBException, Unmarshaller, ValidationEventHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnmarshalException(String message)
      Construct an UnmarshalException with the specified detail message.
      UnmarshalException(String message, String errorCode)
      Construct an UnmarshalException with the specified detail message and vendor specific errorCode.
      UnmarshalException(String message, String errorCode, Throwable exception)
      Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
      UnmarshalException(String message, Throwable exception)
      Construct an UnmarshalException with the specified detail message and linkedException.
      UnmarshalException(Throwable exception)
      Construct an UnmarshalException with a linkedException.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnmarshalException

        public UnmarshalException(String message)
        Construct an UnmarshalException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • UnmarshalException

        public UnmarshalException(String message,
                  String errorCode)
        Construct an UnmarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • UnmarshalException

        public UnmarshalException(Throwable exception)
        Construct an UnmarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                  Throwable exception)
        Construct an UnmarshalException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • UnmarshalException

        public UnmarshalException(String message,
                  String errorCode,
                  Throwable exception)
        Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v


Unmarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface Unmarshaller

  • All Known Implementing Classes:
    AbstractUnmarshallerImpl

    public interface Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled. It provides an overloading of unmarshal methods for many different input kinds.

    Unmarshalling from a File:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( new File( "nosferatu.xml" ) );

    Unmarshalling from an InputStream:

           InputStream is = new FileInputStream( "nosferatu.xml" );
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( is );

    Unmarshalling from a URL:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       URL url = new URL( "http://beaker.east/nosferatu.xml" );
       Object o = u.unmarshal( url );

    Unmarshalling from a StringBuffer using a javax.xml.transform.stream.StreamSource:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       StringBuffer xmlStr = new StringBuffer( "<?xml version="1.0"?>..." );
       Object o = u.unmarshal( new StreamSource( new StringReader( xmlStr.toString() ) ) );

    Unmarshalling from a org.w3c.dom.Node:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));

       Object o = u.unmarshal( doc );

    Unmarshalling from a javax.xml.transform.sax.SAXSource using a client specified validating SAX2.0 parser:

           // configure a validating SAX2.0 parser (Xerces2)
       static final String JAXP_SCHEMA_LANGUAGE =
           "http://java.sun.com/xml/jaxp/properties/schemaLanguage";
       static final String JAXP_SCHEMA_LOCATION =
           "http://java.sun.com/xml/jaxp/properties/schemaSource";
       static final String W3C_XML_SCHEMA =
           "http://www.w3.org/2001/XMLSchema";

       System.setProperty( "javax.xml.parsers.SAXParserFactory",
                           "org.apache.xerces.jaxp.SAXParserFactoryImpl" );

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware(true);
       spf.setValidating(true);
       SAXParser saxParser = spf.newSAXParser();

       try {
           saxParser.setProperty(JAXP_SCHEMA_LANGUAGE, W3C_XML_SCHEMA);
           saxParser.setProperty(JAXP_SCHEMA_LOCATION, "http://....");
       } catch (SAXNotRecognizedException x) {
           // exception handling omitted
       }

       XMLReader xmlReader = saxParser.getXMLReader();
       SAXSource source =
           new SAXSource( xmlReader, new InputSource( "http://..." ) );

       // Setup JAXB to unmarshal
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       ValidationEventCollector vec = new ValidationEventCollector();
       u.setEventHandler( vec );

       // turn off the JAXB provider's default validation mechanism to
       // avoid duplicate validation
       u.setValidating( false )

       // unmarshal
       Object o = u.unmarshal( source );

       // check for events
       if( vec.hasEvents() ) {
          // iterate over events
       }

    Unmarshalling from a StAX XMLStreamReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLStreamReader xmlStreamReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLStreamReader( ... );

       Object o = u.unmarshal( xmlStreamReader );

    Unmarshalling from a StAX XMLEventReader:

           JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLEventReader xmlEventReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLEventReader( ... );

       Object o = u.unmarshal( xmlEventReader );

    Unmarshalling XML Data

    Unmarshalling can deserialize XML data that represents either an entire XML document or a subtree of an XML document. Typically, it is sufficient to use the unmarshalling methods described by Unmarshal root element that is declared globally. These unmarshal methods utilize JAXBContext's mapping of global XML element declarations and type definitions to JAXB mapped classes to initiate the unmarshalling of the root element of XML data. When the JAXBContext's mappings are not sufficient to unmarshal the root element of XML data, the application can assist the unmarshalling process by using the unmarshal by declaredType methods. These methods are useful for unmarshalling XML data where the root element corresponds to a local element declaration in the schema.
    An unmarshal method never returns null. If the unmarshal process is unable to unmarshal the root of XML content to a JAXB mapped object, a fatal error is reported that terminates processing by throwing JAXBException.

    Unmarshal a root element that is globally declared

    The unmarshal methods that do not have an declaredType parameter use JAXBContext to unmarshal the root element of an XML data. The JAXBContext instance is the one that was used to create this Unmarshaller. The JAXBContext instance maintains a mapping of globally declared XML element and type definition names to JAXB mapped classes. The unmarshal method checks if JAXBContext has a mapping from the root element's XML name and/or @xsi:type to a JAXB mapped class. If it does, it umarshalls the XML data using the appropriate JAXB mapped class. Note that when the root element name is unknown and the root element has an @xsi:type, the XML data is unmarshalled using that JAXB mapped class as the value of a JAXBElement. When the JAXBContext object does not have a mapping for the root element's name nor its @xsi:type, if it exists, then the unmarshal operation will abort immediately by throwing a UnmarshalException. This exception scenario can be worked around by using the unmarshal by declaredType methods described in the next subsection.

    Unmarshal by Declared Type

    The unmarshal methods with a declaredType parameter enable an application to deserialize a root element of XML data, even when there is no mapping in JAXBContext of the root element's XML name. The unmarshaller unmarshals the root element using the application provided mapping specified as the declaredType parameter. Note that even when the root element's element name is mapped by JAXBContext, the declaredType parameter overrides that mapping for deserializing the root element when using these unmarshal methods. Additionally, when the root element of XML data has an xsi:type attribute and that attribute's value references a type definition that is mapped to a JAXB mapped class by JAXBContext, that the root element's xsi:type attribute takes precedence over the unmarshal methods declaredType parameter. These methods always return a JAXBElement<declaredType> instance. The table below shows how the properties of the returned JAXBElement instance are set.

    Unmarshal By Declared Type returned JAXBElement
    JAXBElement Property | Value
    name | xml element name
    value | instanceof declaredType
    declaredType | unmarshal method declaredType parameter
    scope | null (actual scope is unknown)

    The following is an example of unmarshal by declaredType method.

    Unmarshal by declaredType from a org.w3c.dom.Node:

           Schema fragment for example
       <xs:schema>
          <xs:complexType name="FooType">...<\xs:complexType>
          <!-- global element declaration "PurchaseOrder" -->
          <xs:element name="PurchaseOrder">
              <xs:complexType>
                 <xs:sequence>
                    <!-- local element declaration "foo" -->
                    <xs:element name="foo" type="FooType"/>
                    ...
                 </xs:sequence>
              </xs:complexType>
          </xs:element>
       </xs:schema>

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));
       Element  fooSubtree = ...; // traverse DOM till reach xml element foo, constrained by a
                                  // local element declaration in schema.

       // FooType is the JAXB mapping of the type of local element declaration foo.
       JAXBElement<FooType> foo = u.unmarshal( fooSubtree, FooType.class);

    Support for SAX2.0 Compliant Parsers

    A client application has the ability to select the SAX2.0 compliant parser of their choice. If a SAX parser is not selected, then the JAXB Provider's default parser will be used. Even though the JAXB Provider's default parser is not required to be SAX2.0 compliant, all providers are required to allow a client application to specify their own SAX2.0 parser. Some providers may require the client application to specify the SAX2.0 parser at schema compile time. See unmarshal(Source) for more detail.

    Validation and Well-Formedness

    A client application can enable or disable JAXP 1.3 validation mechanism via the setSchema(javax.xml.validation.Schema) API. Sophisticated clients can specify their own validating SAX 2.0 compliant parser and bypass the JAXP 1.3 validation mechanism using the unmarshal(Source) API.

    Since unmarshalling invalid XML content is defined in JAXB 2.0, the Unmarshaller default validation event handler was made more lenient than in JAXB 1.0. When schema-derived code generated by JAXB 1.0 binding compiler is registered with JAXBContext, the default unmarshal validation handler is DefaultValidationEventHandler and it terminates the marshal operation after encountering either a fatal error or an error. For a JAXB 2.0 client application, there is no explicitly defined default validation handler and the default event handling only terminates the marshal operation after encountering a fatal error.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Unmarshaller. However, some providers may support their own set of provider specific properties.

    Unmarshal Event Callbacks

    The Unmarshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during unmarshalling. 'External listeners' allow for centralized processing of unmarshal events in one callback method rather than by type event callbacks.

    'Class defined' event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signature:

       // This method is called immediately after the object is created and before the unmarshalling of this
   // object begins. The callback provides an opportunity to initialize JavaBean properties prior to unmarshalling.
   void beforeUnmarshal(Unmarshaller, Object parent);

   //This method is called after all the properties (except IDREF) are unmarshalled for this object,
   //but before this object is set to the parent object.
   void afterUnmarshal(Unmarshaller, Object parent);
    The class defined callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

    The external listener callback mechanism enables the registration of a Unmarshaller.Listener instance with an setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods. The external listener receives events when unmarshalling proces is marshalling to a JAXB element or to JAXB mapped class.

    The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Unmarshaller.Listener.beforeUnmarshal(Object, Object) and Unmarshaller.Listener.afterUnmarshal(Object, Object).

    An event callback method throwing an exception terminates the current unmarshal process.

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBContext, Marshaller, Validator

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  Unmarshaller.Listener

      Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <A extends XmlAdapter>
      A             		getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      UnmarshallerHandler getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
      boolean isValidating()
      Deprecated.
      since JAXB2.0, please see getSchema()
      <A extends XmlAdapter>
      void             		setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, 类<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, 类<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • 方法详细信息

      • unmarshal

        Object unmarshal(File f)
                 throws JAXBException
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        参数：
        f - the file to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the file parameter is null

      • unmarshal

        Object unmarshal(InputStream is)
                 throws JAXBException
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        参数：
        is - the InputStream to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null

      • unmarshal

        Object unmarshal(Reader reader)
                 throws JAXBException
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        参数：
        reader - the Reader to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputStream parameter is null
        从以下版本开始：
        JAXB2.0

      • unmarshal

        Object unmarshal(URL url)
                 throws JAXBException
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        参数：
        url - the url to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the URL parameter is null

      • unmarshal

        Object unmarshal(InputSource source)
                 throws JAXBException
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        参数：
        source - the input source to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the InputSource parameter is null

      • unmarshal

        Object unmarshal(Node node)
                 throws JAXBException
        Unmarshal global XML data from the specified DOM tree and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        参数：
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Node parameter is null
        另请参见：
        unmarshal(org.w3c.dom.Node, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Node node,
                           类<T> declaredType)
                         throws JAXBException
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        参数：
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        declaredType - appropriate JAXB mapped class to hold node's XML data.
        返回：
        JAXB Element representation of node
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        从以下版本开始：
        JAXB2.0

      • unmarshal

        Object unmarshal(Source source)
                 throws JAXBException
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        参数：
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the Source parameter is null
        另请参见：
        unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(Source source,
                           类<T> declaredType)
                         throws JAXBException
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        参数：
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        declaredType - appropriate JAXB mapped class to hold source's xml root element
        返回：
        Java content rooted by JAXB Element
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        从以下版本开始：
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        参数：
        reader - The parser to be read.
        返回：
        the newly created root object of the java content tree.
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        从以下版本开始：
        JAXB2.0
        另请参见：
        unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                           类<T> declaredType)
                         throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        参数：
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        返回：
        content tree rooted by JAXB Element representation
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        从以下版本开始：
        JAXB2.0

      • unmarshal

        Object unmarshal(XMLEventReader reader)
                 throws JAXBException
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        参数：
        reader - The parser to be read.
        返回：
        the newly created root object of the java content tree.
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If the reader parameter is null
        IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
        从以下版本开始：
        JAXB2.0
        另请参见：
        unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                           类<T> declaredType)
                         throws JAXBException
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        参数：
        reader - The parser to be read.
        declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        返回：
        content tree rooted by JAXB Element representation
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        IllegalArgumentException - If any parameter is null
        从以下版本开始：
        JAXB2.0

      • getUnmarshallerHandler

        UnmarshallerHandler getUnmarshallerHandler()
        Get an unmarshaller handler object that can be used as a component in an XML pipeline.

        The JAXB Provider can return the same handler object for multiple invocations of this method. In other words, this method does not necessarily create a new instance of UnmarshallerHandler. If the application needs to use more than one UnmarshallerHandler, it should create more than one Unmarshaller.

        返回：
        the unmarshaller handler object
        另请参见：
        UnmarshallerHandler

      • setValidating

        void setValidating(boolean validating)
                   throws JAXBException
        Deprecated. since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
        Specifies whether or not the default validation mechanism of the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        This method only controls the JAXB Provider's default unmarshal-time validation mechanism - it has no impact on clients that specify their own validating SAX 2.0 compliant parser. Clients that specify their own unmarshal-time validation mechanism may wish to turn off the JAXB Provider's default validation mechanism via this API to avoid "double validation".

        This method is deprecated as of JAXB 2.0 - please use the new setSchema(javax.xml.validation.Schema) API.

        参数：
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        抛出：
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • isValidating

        boolean isValidating()
                     throws JAXBException
        Deprecated. since JAXB2.0, please see getSchema()
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        This API returns the state of the JAXB Provider's default unmarshal-time validation mechanism.

        This method is deprecated as of JAXB 2.0 - please use the new getSchema() API.

        返回：
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        抛出：
        JAXBException - if an error occurs while retrieving the validating flag
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a ValidationEventHandler.

        The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a ValidationEventHandler before invoking the unmarshal methods, then ValidationEvents will be handled by the default event handler which will terminate the unmarshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Unmarshaller to revert back to the default event handler.

        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Set the particular property in the underlying implementation of Unmarshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Get the particular property in the underlying implementation of Unmarshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null

      • setSchema

        void setSchema(Schema schema)
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        参数：
        schema - Schema object to validate unmarshal operations against or null to disable validation
        抛出：
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        从以下版本开始：
        JAXB2.0

      • getSchema

        Schema getSchema()
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        返回：
        the Schema object being used to perform unmarshal-time validation or null if not present
        抛出：
        UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
        从以下版本开始：
        JAXB2.0

      • setAdapter

        void setAdapter(XmlAdapter adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        抛出：
        IllegalArgumentException - if the adapter parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB2.0
        另请参见：
        setAdapter(Class,XmlAdapter)

      • setAdapter

        <A extends XmlAdapter> void setAdapter(类<A> type,
                                     A adapter)
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<类,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        参数：
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
        抛出：
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB2.0

      • getAdapter

        <A extends XmlAdapter> A getAdapter(类<A> type)
        Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        抛出：
        IllegalArgumentException - if the type parameter is null.
        UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
        从以下版本开始：
        JAXB2.0

      • setAttachmentUnmarshaller

        void setAttachmentUnmarshaller(AttachmentUnmarshaller au)

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        抛出：
        IllegalStateException - if attempt to concurrently call this method during a unmarshal operation.

      • getAttachmentUnmarshaller

        AttachmentUnmarshaller getAttachmentUnmarshaller()

      • setListener

        void setListener(Unmarshaller.Listener listener)

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        参数：
        listener - provides unmarshal event callbacks for this Unmarshaller
        从以下版本开始：
        JAXB2.0

      • getListener

        Unmarshaller.Listener getListener()

        Return Unmarshaller.Listener registered with this Unmarshaller.

        返回：
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
        从以下版本开始：
        JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Unmarshaller.Listener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind

类 Unmarshaller.Listener

  • java.lang.Object
    • javax.xml.bind.Unmarshaller.Listener
  • Enclosing interface:
    Unmarshaller

    public abstract static class Unmarshaller.Listener
extends Object

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

    This class enables pre and post processing of an instance of a JAXB mapped class as XML data is unmarshalled into it. The event callbacks are called when unmarshalling XML content into a JAXBElement instance or a JAXB mapped class that represents a complex type definition. The event callbacks are not called when unmarshalling to an instance of a Java datatype that represents a simple type definition.

    External listener is one of two different mechanisms for defining unmarshal event callbacks. See Unmarshal Event Callbacks for an overview.

    (@link #setListener(Listener)} (@link #getListener()}

    从以下版本开始：
    JAXB2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      Unmarshaller.Listener()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void afterUnmarshal(Object target, Object parent)

      Callback method invoked after unmarshalling XML data into target.
      void beforeUnmarshal(Object target, Object parent)

      Callback method invoked before unmarshalling into target.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Unmarshaller.Listener

        public Unmarshaller.Listener()

    • 方法详细信息

      • beforeUnmarshal

        public void beforeUnmarshal(Object target,
                   Object parent)

        Callback method invoked before unmarshalling into target.

        This method is invoked immediately after target was created and before the unmarshalling of this object begins. Note that if the class of target defines its own beforeUnmarshal method, the class specific callback method is invoked before this method is invoked.

        参数：
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will eventually reference target. null when target is root element.

      • afterUnmarshal

        public void afterUnmarshal(Object target,
                  Object parent)

        Callback method invoked after unmarshalling XML data into target.

        This method is invoked after all the properties (except IDREF) are unmarshalled into target, but before target is set into its parent object. Note that if the class of target defines its own afterUnmarshal method, the class specific callback method is invoked before this method is invoked.

        参数：
        target - non-null instance of JAXB mapped class prior to unmarshalling into it.
        parent - instance of JAXB mapped class that will reference target. null when target is root element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>lt > >d >ddpc d o>< / >>


UnmarshallerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface UnmarshallerHandler

  • All Superinterfaces:
    ContentHandler

    public interface UnmarshallerHandler
extends ContentHandler
    Unmarshaller implemented as SAX ContentHandler.

    Applications can use this interface to use their JAXB provider as a component in an XML pipeline. For example:

           JAXBContext context = JAXBContext.newInstance( "org.acme.foo" );

       Unmarshaller unmarshaller = context.createUnmarshaller();

       UnmarshallerHandler unmarshallerHandler = unmarshaller.getUnmarshallerHandler();

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware( true );

       XMLReader xmlReader = spf.newSAXParser().getXMLReader();
       xmlReader.setContentHandler( unmarshallerHandler );
       xmlReader.parse(new InputSource( new FileInputStream( XML_FILE ) ) );

       MyObject myObject= (MyObject)unmarshallerHandler.getResult();

    This interface is reusable: even if the user fails to unmarshal an object, s/he can still start a new round of unmarshalling.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Unmarshaller.getUnmarshallerHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getResult()
      Obtains the unmarshalled result.

      • 方法 - 继承于接口 org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • 方法详细信息

      • getResult

        Object getResult()
                 throws JAXBException,
                        IllegalStateException
        Obtains the unmarshalled result. This method can be called only after this handler receives the endDocument SAX event.
        返回：
        always return a non-null valid object which was unmarshalled.
        抛出：
        IllegalStateException - if this method is called before this handler receives the endDocument event.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ldlmsmunmu-ssu--ca噜 >>illrt糷�.發<<


Uses of Package javax.xml.bind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind

  • Packages that use javax.xml.bind
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.bind used by javax.xml.bind
    类与描述
    Binder
    Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
    DatatypeConverterInterface
    The DatatypeConverterInterface is for JAXB provider use only.
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    JAXBIntrospector
    Provide access to JAXB xml binding data for a JAXB object.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    SchemaOutputResolver
    Controls where a JAXB implementation puts the generates schema files.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    UnmarshallerHandler
    Unmarshaller implemented as SAX ContentHandler.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
    Validator
    Deprecated.
    since JAXB 2.0
  • Classes in javax.xml.bind used by javax.xml.bind.annotation
    类与描述
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.bind.helpers
    类与描述
    JAXBElement
    JAXB representation of an Xml Element.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Marshaller.Listener

    Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
    NotIdentifiableEvent
    This event indicates that a problem was encountered resolving an ID/IDREF.
    ParseConversionEvent
    This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
    PrintConversionEvent
    This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
    PropertyException
    This exception indicates that an error was encountered while getting or setting a property.
    UnmarshalException
    This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    Unmarshaller.Listener

    Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
    ValidationEventLocator
    Encapsulate the location of a ValidationEvent.
  • Classes in javax.xml.bind used by javax.xml.bind.util
    类与描述
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
    JAXBException
    This is the root exception class for all JAXB exceptions.
    Marshaller
    The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
    Unmarshaller
    The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
    ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    ValidationEventHandler
    A basic event handler interface for validation errors.
  • Classes in javax.xml.bind used by javax.xml.ws
    类与描述
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.handler.soap
    类与描述
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • Classes in javax.xml.bind used by javax.xml.ws.spi
    类与描述
    JAXBContext
    The JAXBContext class provides the client's entry point to the JAXB API.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/gl/ < .< &- C


ValidationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface ValidationEvent

  • All Known Subinterfaces:
    NotIdentifiableEvent, ParseConversionEvent, PrintConversionEvent
    All Known Implementing Classes:
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl, ValidationEventImpl

    public interface ValidationEvent
    This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEventHandler

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ERROR
      Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int FATAL_ERROR
      Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
      static int WARNING
      Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.

    • 字段详细信息

      • WARNING

        static final int WARNING
        Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation
        另请参见：
        Constant Field Values

      • ERROR

        static final int ERROR
        Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
        另请参见：
        Constant Field Values

      • FATAL_ERROR

        static final int FATAL_ERROR
        Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getSeverity

        int getSeverity()
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        返回：
        the severity code for this warning/error

      • getMessage

        String getMessage()
        Retrieve the text message for this warning/error.
        返回：
        the text message for this warning/error or null if one wasn't set

      • getLinkedException

        Throwable getLinkedException()
        Retrieve the linked exception for this warning/error.
        返回：
        the linked exception for this warning/error or null if one wasn't set

      • getLocator

        ValidationEventLocator getLocator()
        Retrieve the locator for this warning/error.
        返回：
        the locator that indicates where the warning/error occurred
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.g/f�> e>>lstsS.rttiol(da/=dp


ValidationEventHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface ValidationEventHandler

  • All Known Implementing Classes:
    DefaultValidationEventHandler, ValidationEventCollector

    public interface ValidationEventHandler
    A basic event handler interface for validation errors.

    If an application needs to implement customized event handling, it must implement this interface and then register it with either the Unmarshaller, the Validator, or the Marshaller. The JAXB Provider will then report validation errors and warnings encountered during the unmarshal, marshal, and validate operations to these event handlers.

    If the handleEvent method throws an unchecked runtime exception, the JAXB Provider must treat that as if the method returned false, effectively terminating whatever operation was in progress at the time (unmarshal, validate, or marshal).

    Modifying the Java content tree within your event handler is undefined by the specification and may result in unexpected behaviour.

    Failing to return false from the handleEvent method after encountering a fatal error is undefined by the specification and may result in unexpected behavior.

    Default Event Handler

    See: Validator javadocs
    从以下版本开始：
    JAXB1.0
    另请参见：
    Unmarshaller, Validator, Marshaller, ValidationEvent, ValidationEventCollector

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • 方法详细信息

      • handleEvent

        boolean handleEvent(ValidationEvent event)
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        参数：
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        返回：
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
        抛出：
        IllegalArgumentException - if the event object is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/pRrn=on=s""=ss d<< i) >(stt>>>a>te


ValidationEventLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface ValidationEventLocator

  • All Known Implementing Classes:
    ValidationEventLocatorImpl

    public interface ValidationEventLocator
    Encapsulate the location of a ValidationEvent.

    The ValidationEventLocator indicates where the ValidationEvent occurred. Different fields will be set depending on the type of validation that was being performed when the error or warning was detected. For example, on-demand validation would produce locators that contained references to objects in the Java content tree while unmarshal-time validation would produce locators containing information appropriate to the source of the XML data (file, url, Node, etc).

    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEvent

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available

    • 方法详细信息

      • getURL

        URL getURL()
        Return the name of the XML source as a URL if available
        返回：
        the name of the XML source as a URL or null if unavailable

      • getOffset

        int getOffset()
        Return the byte offset if available
        返回：
        the byte offset into the input source or -1 if unavailable

      • getLineNumber

        int getLineNumber()
        Return the line number if available
        返回：
        the line number or -1 if unavailable

      • getColumnNumber

        int getColumnNumber()
        Return the column number if available
        返回：
        the column number or -1 if unavailable

      • getObject

        Object getObject()
        Return a reference to the object in the Java content tree if available
        返回：
        a reference to the object in the Java content tree or null if unavailable

      • getNode

        Node getNode()
        Return a reference to the DOM Node if available
        返回：
        a reference to the DOM Node or null if unavailable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sc=>>./> - -a>ibthxnh 蘨ttrtoh


ValidationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind

类 ValidationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.ValidationException
  • 所有已实现的接口：
    Serializable

    public class ValidationException
extends JAXBException
    This exception indicates that an error has occurred while performing a validate operation.

    The ValidationEventHandler can cause this exception to be thrown during the validate operations. See ValidationEventHandler.handleEvent(ValidationEvent).

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBException, Validator, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValidationException(String message)
      Construct an ValidationException with the specified detail message.
      ValidationException(String message, String errorCode)
      Construct an ValidationException with the specified detail message and vendor specific errorCode.
      ValidationException(String message, String errorCode, Throwable exception)
      Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
      ValidationException(String message, Throwable exception)
      Construct an ValidationException with the specified detail message and linkedException.
      ValidationException(Throwable exception)
      Construct an ValidationException with a linkedException.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.JAXBException

        getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ValidationException

        public ValidationException(String message)
        Construct an ValidationException with the specified detail message. The errorCode and linkedException will default to null.
        参数：
        message - a description of the exception

      • ValidationException

        public ValidationException(String message,
                   String errorCode)
        Construct an ValidationException with the specified detail message and vendor specific errorCode. The linkedException will default to null.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code

      • ValidationException

        public ValidationException(Throwable exception)
        Construct an ValidationException with a linkedException. The detail message and vendor specific errorCode will default to null.
        参数：
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                   Throwable exception)
        Construct an ValidationException with the specified detail message and linkedException. The errorCode will default to null.
        参数：
        message - a description of the exception
        exception - the linked exception

      • ValidationException

        public ValidationException(String message,
                   String errorCode,
                   Throwable exception)
        Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
        参数：
        message - a description of the exception
        errorCode - a string specifying the vendor specific error code
        exception - the linked exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

8&aae�>p�< a xi9&ta/.1r9<1cr2e<


Validator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind

Interface Validator

  • Deprecated.
    since JAXB 2.0

    public interface Validator
    As of JAXB 2.0, this class is deprecated and optional.

    The Validator class is responsible for controlling the validation of content trees during runtime.

    Three Forms of Validation

    Unmarshal-Time Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected while unmarshalling XML data into a Java content tree and is completely orthogonal to the other types of validation. To enable or disable it, see the javadoc for Unmarshaller.setValidating. All JAXB 1.0 Providers are required to support this operation.
    On-Demand Validation
    This form of validation enables a client application to receive information about validation errors and warnings detected in the Java content tree. At any point, client applications can call the Validator.validate method on the Java content tree (or any sub-tree of it). All JAXB 1.0 Providers are required to support this operation.
    Fail-Fast Validation
    This form of validation enables a client application to receive immediate feedback about modifications to the Java content tree that violate type constraints on Java Properties as defined in the specification. JAXB Providers are not required support this type of validation. Of the JAXB Providers that do support this type of validation, some may require you to decide at schema compile time whether or not a client application will be allowed to request fail-fast validation at runtime.

    The Validator class is responsible for managing On-Demand Validation. The Unmarshaller class is responsible for managing Unmarshal-Time Validation during the unmarshal operations. Although there is no formal method of enabling validation during the marshal operations, the Marshaller may detect errors, which will be reported to the ValidationEventHandler registered on it.

    Using the Default EventHandler

    If the client application does not set an event handler on their Validator, Unmarshaller, or Marshaller prior to calling the validate, unmarshal, or marshal methods, then a default event handler will receive notification of any errors or warnings encountered. The default event handler will cause the current operation to halt after encountering the first error or fatal error (but will attempt to continue after receiving warnings).

    Handling Validation Events

    There are three ways to handle events encountered during the unmarshal, validate, and marshal operations:
    Use the default event handler
    The default event handler will be used if you do not specify one via the setEventHandler API's on Validator, Unmarshaller, or Marshaller.
    Implement and register a custom event handler
    Client applications that require sophisticated event processing can implement the ValidationEventHandler interface and register it with the Unmarshaller and/or Validator.
    Use the ValidationEventCollector utility
    For convenience, a specialized event handler is provided that simply collects any ValidationEvent objects created during the unmarshal, validate, and marshal operations and returns them to the client application as a java.util.Collection.

    Validation and Well-Formedness

    Validation events are handled differently depending on how the client application is configured to process them as described in the previous section. However, there are certain cases where a JAXB Provider indicates that it is no longer able to reliably detect and report errors. In these cases, the JAXB Provider will set the severity of the ValidationEvent to FATAL_ERROR to indicate that the unmarshal, validate, or marshal operations should be terminated. The default event handler and ValidationEventCollector utility class must terminate processing after being notified of a fatal error. Client applications that supply their own ValidationEventHandler should also terminate processing after being notified of a fatal error. If not, unexpected behaviour may occur.

    Supported Properties

    There currently are not any properties required to be supported by all JAXB Providers on Validator. However, some providers may support their own set of provider specific properties.

    从以下版本开始：
    JAXB1.0
    另请参见：
    JAXBContext, Unmarshaller, ValidationEventHandler, ValidationEvent, ValidationEventCollector

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ValidationEventHandler getEventHandler()
      Deprecated.
      since JAXB2.0
      Object getProperty(String name)
      Deprecated.
      since JAXB2.0
      void setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      boolean validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • 方法详细信息

      • setEventHandler

        void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Deprecated. since JAXB2.0
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to validate. If the client application does not register a validation event handler before invoking the validate method, then validation events will be handled by the default event handler which will terminate the validate operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Validator to revert back to the default default event handler.

        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler

      • getEventHandler

        ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Deprecated. since JAXB2.0
        Return the current event handler or the default event handler if one hasn't been set.
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler

      • validate

        boolean validate(Object subrootObj)
                 throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree starting at subrootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method can be used to validate any arbitrary subtree of the Java content tree. Global constraint checking will not be performed as part of this operation (i.e. ID/IDREF constraints).

        参数：
        subrootObj - the obj to begin validation at
        返回：
        true if the subtree rooted at subrootObj is valid, false otherwise
        抛出：
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at subrootObj
        IllegalArgumentException - If the subrootObj parameter is null

      • validateRoot

        boolean validateRoot(Object rootObj)
                     throws JAXBException
        Deprecated. since JAXB2.0
        Validate the Java content tree rooted at rootObj.

        Client applications can use this method to validate Java content trees on-demand at runtime. This method is used to validate an entire Java content tree. Global constraint checking will be performed as part of this operation (i.e. ID/IDREF constraints).

        参数：
        rootObj - the root obj to begin validation at
        返回：
        true if the tree rooted at rootObj is valid, false otherwise
        抛出：
        JAXBException - if any unexpected problem occurs during validation
        ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at rootObj
        IllegalArgumentException - If the rootObj parameter is null

      • setProperty

        void setProperty(String name,
               Object value)
                 throws PropertyException
        Deprecated. since JAXB2.0
        Set the particular property in the underlying implementation of Validator. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value
        IllegalArgumentException - If the name parameter is null

      • getProperty

        Object getProperty(String name)
                   throws PropertyException
        Deprecated. since JAXB2.0
        Get the particular property in the underlying implementation of Validator. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name
        IllegalArgumentException - If the name parameter is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>;/efypb.s|>s<>&iias>_>i>"la.seap


DomHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.bind.annotation

Interface DomHandler<ElementT,ResultT extends Result>

  • All Known Implementing Classes:
    W3CDomHandler

    public interface DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.

    Implementations of this interface will be used in conjunction with XmlAnyElement annotation to map an element of XML into a representation of infoset such as W3C DOM.

    Implementations hide how a portion of XML is converted into/from such DOM-like representation, allowing JAXB providers to work with arbitrary such library.

    This interface is intended to be implemented by library writers and consumed by JAXB providers. None of those methods are intended to be called from applications.

    从以下版本开始：
    JAXB2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ResultT createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      ElementT getElement(ResultT rt)
      Once the portion is sent to the Result.
      Source marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.

    • 方法详细信息

      • createUnmarshaller

        ResultT createUnmarshaller(ValidationEventHandler errorHandler)
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        参数：
        errorHandler - if any error happens between the invocation of this method and the invocation of getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        返回：
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        ElementT getElement(ResultT rt)
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        参数：
        rt - The Result object created by createUnmarshaller(ValidationEventHandler).
        返回：
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        Source marshal(ElementT n,
             ValidationEventHandler errorHandler)
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        参数：
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        返回：
        null if there was an error. The error should have been reported to the handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aglFt.i="&t


javax.xml.bind.annotation

Interfaces

  • DomHandler

Classes

  • W3CDomHandler
  • XmlElement.DEFAULT
  • XmlElementDecl.GLOBAL
  • XmlElementRef.DEFAULT
  • XmlSchemaType.DEFAULT
  • XmlType.DEFAULT

Enums

  • XmlAccessOrder
  • XmlAccessType
  • XmlNsForm

Annotation Types

  • XmlAccessorOrder
  • XmlAccessorType
  • XmlAnyAttribute
  • XmlAnyElement
  • XmlAttachmentRef
  • XmlAttribute
  • XmlElement
  • XmlElementDecl
  • XmlElementRef
  • XmlElementRefs
  • XmlElements
  • XmlElementWrapper
  • XmlEnum
  • XmlEnumValue
  • XmlID
  • XmlIDREF
  • XmlInlineBinaryData
  • XmlList
  • XmlMimeType
  • XmlMixed
  • XmlNs
  • XmlRegistry
  • XmlRootElement
  • XmlSchema
  • XmlSchemaType
  • XmlSchemaTypes
  • XmlSeeAlso
  • XmlTransient
  • XmlType
  • XmlValue
i


javax.xml.bind.annotation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind.annotation

Defines annotations for customizing Java program elements to XML Schema mapping.

请参见： 描述

  • 接口摘要
    接口 描述
    DomHandler<ElementT,ResultT extends Result>
    Converts an element (and its descendants) from/to DOM (or similar) representation.
  • Class Summary
    类 描述
    W3CDomHandler
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    XmlElement.DEFAULT
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.
    XmlElementDecl.GLOBAL
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.
    XmlElementRef.DEFAULT
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.
    XmlSchemaType.DEFAULT
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.
    XmlType.DEFAULT
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.
  • Enum Summary
    Enum 描述
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Annotation Types Summary
    Annotation Type 描述
    XmlAccessorOrder
    Controls the ordering of fields and properties in a class.
    XmlAccessorType
    Controls whether fields or Javabean properties are serialized by default.
    XmlAnyAttribute
    Maps a JavaBean property to a map of wildcard attributes.
    XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.
    XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content.
    XmlAttribute
    Maps a JavaBean property to a XML attribute.
    XmlElement
    Maps a JavaBean property to a XML element derived from property name.
    XmlElementDecl
    Maps a factory method to a XML element.
    XmlElementRef
    Maps a JavaBean property to a XML element derived from property's type.
    XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.
    XmlElements
    A container for multiple @XmlElement annotations.
    XmlElementWrapper
    Generates a wrapper element around XML representation.
    XmlEnum
    Maps an enum type Enum to XML representation.
    XmlEnumValue
    Maps an enum constant in Enum type to XML representation.
    XmlID
    Maps a JavaBean property to XML ID.
    XmlIDREF
    Maps a JavaBean property to XML IDREF.
    XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.
    XmlList
    Used to map a property to a list simple type.
    XmlMimeType
    Associates the MIME type that controls the XML representation of the property.
    XmlMixed
    Annotate a JavaBean multi-valued property to support mixed content.
    XmlNs
    Associates a namespace prefix with a XML namespace URI.
    XmlRegistry
    Marks a class that has XmlElementDecls.
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlSchema
    Maps a package name to a XML namespace.
    XmlSchemaType
    Maps a Java type to a simple schema built-in type.
    XmlSchemaTypes
    A container for multiple @XmlSchemaType annotations.
    XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
    XmlType
    Maps a class or an enum type to a XML Schema type.
    XmlValue
    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

软件包 javax.xml.bind.annotation Description

Defines annotations for customizing Java program elements to XML Schema mapping.

Package Specification

The following table shows the JAXB mapping annotations that can be associated with each program element.

Program Element JAXB annotation
软件包
XmlAccessorOrder
XmlAccessorType
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlJavaTypeAdapter
XmlJavaTypeAdapters
类
XmlAccessorOrder
XmlAccessorType
XmlInlineBinaryData
XmlRootElement
XmlType
XmlJavaTypeAdapter
Enum type
XmlEnum
XmlEnumValue (enum constant only)
XmlRootElement
XmlType
XmlJavaTypeAdapter
JavaBean Property/field
XmlElement
XmlElements
XmlElementRef
XmlElementRefs
XmlElementWrapper
XmlAnyElement
XmlAttribute
XmlAnyAttribute
XmlTransient
XmlValue
XmlID
XmlIDREF
XmlList
XmlMixed
XmlMimeType
XmlAttachmentRef
XmlInlineBinaryData
XmlElementDecl (only on method)
XmlJavaTypeAdapter
Parameter
XmlList
XmlAttachmentRef
XmlMimeType
XmlJavaTypeAdapter

Terminology

JavaBean property and field: For the purposes of mapping, there is no semantic difference between a field and a JavaBean property. Thus, an annotation that can be applied to a JavaBean property can always be applied to a field. Hence in the Javadoc documentation, for brevity, the term JavaBean property or property is used to mean either JavaBean property or a field. Where required, both are explicitly mentioned.

top level class: For the purpose of mapping, there is no semantic difference between a top level class and a static nested class. Thus, an annotation that can be applied to a top level class, can always be applied to a nested static class. Hence in the Javadoc documentation, for brevity, the term "top level class" or just class is used to mean either a top level class or a nested static class.

mapping annotation:A JAXB 2.0 defined program annotation based on the JSR 175 programming annotation facility.

Common Usage Constraints

The following usage constraints are defined here since they apply to more than annotation:

  • For a property, a given annotation can be applied to either read or write property but not both.
  • A property name must be different from any other property name in any of the super classes of the class being mapped.
  • A mapped field name or the decapitalized name of a mapped property must be unique within a class.

Notations

Namespace prefixes

The following namespace prefixes are used in the XML Schema fragments in this package.

Prefix | Namespace | Notes
xs | http://www.w3.org/2001/XMLSchema | Namespace of XML Schema namespace
ref | http://ws-i.org/profiles/basic/1.1/xsd | Namespace for swaref schema component
xsi | http://www.w3.org/2001/XMLSchema-instance | XML Schema namespace for instances
从以下版本开始：
JAXB 2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.xml.bind.annotation Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind.annotation

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.bind.annotation.XmlType.DEFAULT

Interface Hierarchy

  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>

Annotation Type Hierarchy

  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlAccessOrder
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt/.....///Fb t g.


Uses of Package javax.xml.bind.annotation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind.annotation

  • Packages that use javax.xml.bind.annotation
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.bind.annotation used by javax.xml.bind.annotation
    类与描述
    DomHandler
    Converts an element (and its descendants) from/to DOM (or similar) representation.
    XmlAccessOrder
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    XmlAccessType
    Used by XmlAccessorType to control serialization of fields or properties.
    XmlNsForm
    Enumeration of XML Schema namespace qualifications.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws
    类与描述
    XmlTransient
    Prevents the mapping of a JavaBean property/type to XML representation.
  • Classes in javax.xml.bind.annotation used by javax.xml.ws.wsaddressing
    类与描述
    XmlRootElement
    Maps a class or an enum type to an XML element.
    XmlType
    Maps a class or an enum type to a XML Schema type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/<.atata.nnnia""t.""n..=


W3CDomHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.annotation

类 W3CDomHandler

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler
  • 所有已实现的接口：
    DomHandler<Element,DOMResult>

    public class W3CDomHandler
extends Object
implements DomHandler<Element,DOMResult>
    DomHandler implementation for W3C DOM (org.w3c.dom package.)
    从以下版本开始：
    JAXB2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      W3CDomHandler()
      Default constructor.
      W3CDomHandler(DocumentBuilder builder)
      Constructor that allows applications to specify which DOM implementation to be used.

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      DocumentBuilder getBuilder()
      Element getElement(DOMResult r)
      Once the portion is sent to the Result.
      Source marshal(Element element, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      void | setBuilder(DocumentBuilder builder)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • W3CDomHandler

        public W3CDomHandler()
        Default constructor. It is up to a JAXB provider to decide which DOM implementation to use or how that is configured.

      • W3CDomHandler

        public W3CDomHandler(DocumentBuilder builder)
        Constructor that allows applications to specify which DOM implementation to be used.
        参数：
        builder - must not be null. JAXB uses this DocumentBuilder to create a new element.

    • 方法详细信息

      • getBuilder

        public DocumentBuilder getBuilder()

      • setBuilder

        public void setBuilder(DocumentBuilder builder)

      • createUnmarshaller

        public DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
        从接口复制的描述： DomHandler
        When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

        A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

        指定者：
        createUnmarshaller in interface DomHandler<Element,DOMResult>
        参数：
        errorHandler - if any error happens between the invocation of this method and the invocation of DomHandler.getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
        返回：
        null if the operation fails. The error must have been reported to the error handler.

      • getElement

        public Element getElement(DOMResult r)
        从接口复制的描述： DomHandler
        Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

        Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

        指定者：
        getElement in interface DomHandler<Element,DOMResult>
        参数：
        r - The Result object created by DomHandler.createUnmarshaller(ValidationEventHandler).
        返回：
        null if the operation fails. The error must have been reported to the error handler.

      • marshal

        public Source marshal(Element element,
             ValidationEventHandler errorHandler)
        从接口复制的描述： DomHandler
        This method is called when a JAXB provider needs to marshal an element to XML.

        If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

        指定者：
        marshal in interface DomHandler<Element,DOMResult>
        errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
        返回：
        null if there was an error. The error should have been reported to the handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hr /s "i.ip i>tattoa/a.R v =-"


XmlAccessOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.bind.annotation

Enum XmlAccessOrder

  • java.lang.Object
    • java.lang.Enum<XmlAccessOrder>
      • javax.xml.bind.annotation.XmlAccessOrder
  • 所有已实现的接口：
    Serializable, Comparable<XmlAccessOrder>

    public enum XmlAccessOrder
extends Enum<XmlAccessOrder>
    Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlAccessorOrder

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALPHABETICAL
      The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).
      UNDEFINED
      The ordering of fields and properties in a class is undefined.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static XmlAccessOrder valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNDEFINED

        public static final XmlAccessOrder UNDEFINED
        The ordering of fields and properties in a class is undefined.

      • ALPHABETICAL

        public static final XmlAccessOrder ALPHABETICAL
        The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).

    • 方法详细信息

      • values

        public static XmlAccessOrder[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessOrder c : XmlAccessOrder.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessOrder valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e tloHomHoinnoiin/..>ccolrote inrit;do


XmlAccessorOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorOrder

  • @Inherited
@Retention(value=RUNTIME)
@Target(value={软件包,TYPE})
public @interface XmlAccessorOrder

    Controls the ordering of fields and properties in a class.

    Usage

    @XmlAccessorOrder annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind package javadoc for additional common information.

    The effective XmlAccessOrder on a class is determined as follows:

    • If there is a @XmlAccessorOrder on a class, then it is used.
    • Otherwise, if a @XmlAccessorOrder exists on one of its super classes, then it is inherited (by the virtue of Inherited)
    • Otherwise, the @XmlAccessorOrder on the package of the class is used, if it's there.
    • Otherwise XmlAccessOrder.UNDEFINED.

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlAccessOrder

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      XmlAccessOrder value

    • Element Detail

      • value

        public abstract XmlAccessOrder value
        Default:
        javax.xml.bind.annotation.XmlAccessOrder.UNDEFINED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bj.rf>- =Lthe/


XmlAccessorType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAccessorType

  • @Inherited
@Retention(value=RUNTIME)
@Target(value={软件包,TYPE})
public @interface XmlAccessorType

    Controls whether fields or Javabean properties are serialized by default.

    Usage

    @XmlAccessorType annotation can be used with the following program elements:

    • package
    • a top level class

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation provides control over the default serialization of properties and fields in a class.

    The annotation @XmlAccessorType on a package applies to all classes in the package. The following inheritance semantics apply:

    • If there is a @XmlAccessorType on a class, then it is used.
    • Otherwise, if a @XmlAccessorType exists on one of its super classes, then it is inherited.
    • Otherwise, the @XmlAccessorType on a package is inherited.

    Defaulting Rules:

    By default, if @XmlAccessorType on a package is absent, then the following package level annotation is assumed.

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    By default, if @XmlAccessorType on a class is absent, and none of its super classes is annotated with @XmlAccessorType, then the following default on the class is assumed:

       @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

    This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorOrder, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlAccessType

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      XmlAccessType value
      Specifies whether fields or properties are serialized.

    • Element Detail

      • value

        public abstract XmlAccessType value
        Specifies whether fields or properties are serialized.
        另请参见：
        XmlAccessType
        Default:
        javax.xml.bind.annotation.XmlAccessType.PUBLIC_MEMBER
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>si.trCureb ebb c


XmlAccessType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.bind.annotation

Enum XmlAccessType

  • java.lang.Object
    • java.lang.Enum<XmlAccessType>
      • javax.xml.bind.annotation.XmlAccessType
  • 所有已实现的接口：
    Serializable, Comparable<XmlAccessType>

    public enum XmlAccessType
extends Enum<XmlAccessType>
    Used by XmlAccessorType to control serialization of fields or properties.
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlAccessorType

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      字段
      Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      NONE
      None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.
      PROPERTY
      Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
      PUBLIC_MEMBER
      Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static XmlAccessType valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • PROPERTY

        public static final XmlAccessType PROPERTY
        Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Fields are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • FIELD

        public static final XmlAccessType FIELD
        Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Getter/setter pairs are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

      • PUBLIC_MEMBER

        public static final XmlAccessType PUBLIC_MEMBER
        Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient. Fields or getter/setter pairs that are private, protected, or defaulted to package-only access are bound to XML only when they are explicitly annotated by the appropriate JAXB annotations.

      • NONE

        public static final XmlAccessType NONE
        None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.

    • 方法详细信息

      • values

        public static XmlAccessType[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlAccessType c : XmlAccessType.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlAccessType valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r mmaaa a./...//.ree;JJ aojsalh vn m


XmlAnyAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyAttribute

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlAnyAttribute

    Maps a JavaBean property to a map of wildcard attributes.

    Usage

    The @XmlAnyAttribute annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlAnyAttribute.
    • The type of the property or the field must java.util.Map

    While processing attributes to be unmarshalled into a value class, each attribute that is not statically associated with another JavaBean property, via XmlAttribute, is entered into the wildcard attribute map represented by Map<QName,Object>. The attribute QName is the map's key. The key's value is the String value of the attribute.

    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/rcb


XmlAnyElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAnyElement

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlAnyElement
    Maps a JavaBean property to XML infoset representation and/or JAXB element.

    This annotation serves as a "catch-all" property while unmarshalling xml content into a instance of a JAXB annotated class. It typically annotates a multi-valued JavaBean property, but it can occur on single value JavaBean property. During unmarshalling, each xml element that does not match a static @XmlElement or @XmlElementRef annotation for the other JavaBean properties on the class, is added to this "catch-all" property.

    Usages:

     @XmlAnyElement
 public Element[] others;

 // Collection of Element or JAXB elements.
 @XmlAnyElement(lax="true")
 public Object[] others;

 @XmlAnyElement
 private List<Element> nodes;

 @XmlAnyElement
 private Element node;

    Restriction usage constraints

    This annotation is mutually exclusive with XmlElement, XmlAttribute, XmlValue, XmlElements, XmlID, and XmlIDREF.

    There can be only one XmlAnyElement annotated JavaBean property in a class and its super classes.

    Relationship to other annotations

    This annotation can be used with XmlJavaTypeAdapter, so that users can map their own data structure to DOM, which in turn can be composed into XML.

    This annotation can be used with XmlMixed like this:

     // List of java.lang.String or DOM nodes.
 @XmlAnyElement @XmlMixed
 List<Object> others;

    Schema To Java example

    The following schema would produce the following Java class:

 <xs:complexType name="foo">
   <xs:sequence>
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

     class Foo {
   int a;
   int b;
   @XmlAnyElement
   List<Element> any;
 }
    It can unmarshal instances like

 <foo xmlns:e="extra">
   <a>1</a>
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
   <c>5</c>     // this will be bound to DOM, because the annotation doesn't remember namespaces.
 </foo>
    The following schema would produce the following Java class:

 <xs:complexType name="bar">
   <xs:complexContent>
   <xs:extension base="foo">
     <xs:sequence>
       <xs:element name="c" type="xs:int" />
       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
     </xs:sequence>
   </xs:extension>
 </xs:complexType>

 class Bar extends Foo {
   int c;
   // Foo.getAny() also represents wildcard content for type definition bar.
 }
    It can unmarshal instances like

 <bar xmlns:e="extra">
   <a>1</a>
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
   <c>5</c>     // this now goes to Bar.c
   <e:other />  // this will go to Foo.any
 </bar>

    Using XmlAnyElement with XmlElementRef

    The XmlAnyElement annotation can be used with XmlElementRefs to designate additional elements that can participate in the content tree.

    The following schema would produce the following Java class:

 <xs:complexType name="foo">
   <xs:choice maxOccurs="unbounded" minOccurs="0">
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" />
   </xs:choice>
 </xs:complexType>

     class Foo {
   @XmlAnyElement(lax="true")
   @XmlElementRefs({
     @XmlElementRef(name="a", type="JAXBElement.class")
     @XmlElementRef(name="b", type="JAXBElement.class")
   })
   List<Object> others;
 }

 @XmlRegistry
 class ObjectFactory {
   ...
   @XmlElementDecl(name = "a", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooA( Integer i ) { ... }

   @XmlElementDecl(name = "b", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooB( Integer i ) { ... }
    It can unmarshal instances like

 <foo xmlns:e="extra">
   <a>1</a>     // this will unmarshal to a <a href="../../../../javax/xml/bind/JAXBElement.html" title="class in javax.xml.bind"><code>JAXBElement</code></a> instance whose value is 1.
   <e:other />  // this will unmarshal to a DOM <a href="../../../../org/w3c/dom/Element.html" title="interface in org.w3c.dom"><code>Element</code></a>.
   <b>3</b>     // this will unmarshal to a <a href="../../../../javax/xml/bind/JAXBElement.html" title="class in javax.xml.bind"><code>JAXBElement</code></a> instance whose value is 1.
 </foo>

    W3C XML Schema "lax" wildcard emulation

    The lax element of the annotation enables the emulation of the "lax" wildcard semantics. For example, when the Java source code is annotated like this:
     @XmlRootElement
 class Foo {
   @XmlAnyElement(lax=true)
   public Object[] others;
 }
    then the following document will unmarshal like this:

 <foo>
   <unknown />
   <foo />
 </foo>

 Foo foo = unmarshal();
 // 1 for 'unknown', another for 'foo'
 assert foo.others.length==2;
 // 'unknown' unmarshals to a DOM element
 assert foo.others[0] instanceof Element;
 // because of lax=true, the 'foo' element eagerly
 // unmarshals to a Foo object.
 assert foo.others[1] instanceof Foo;
    从以下版本开始：
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      boolean lax
      Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.
      类<? extends DomHandler> value
      Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.

    • Element Detail

      • lax

        public abstract boolean lax
        Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.

        When false

        If false, all the elements that match the property will be unmarshalled to DOM, and the property will only contain DOM elements.

        When true

        If true, when an element matches a property marked with XmlAnyElement is known to JAXBContext (for example, there's a class with XmlRootElement that has the same tag name, or there's XmlElementDecl that has the same tag name), the unmarshaller will eagerly unmarshal this element to the JAXB object, instead of unmarshalling it to DOM. Additionally, if the element is unknown but it has a known xsi:type, the unmarshaller eagerly unmarshals the element to a JAXBElement, with the unknown element name and the JAXBElement value is set to an instance of the JAXB mapping of the known xsi:type.

        As a result, after the unmarshalling, the property can become heterogeneous; it can have both DOM nodes and some JAXB objects at the same time.

        This can be used to emulate the "lax" wildcard semantics of the W3C XML Schema.

        Default:
        false

      • value

        public abstract 类<? extends DomHandler> value
        Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.
        Default:
        javax.xml.bind.annotation.W3CDomHandler.class
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.=".>l"ltn ""/mnn蕇assrl


XmlAttachmentRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttachmentRef

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,PARAMETER})
public @interface XmlAttachmentRef
    Marks a field/property that its XML form is a uri reference to mime content. The mime content is optimally stored out-of-line as an attachment. A field/property must always map to the DataHandler class.

    Usage

     @XmlRootElement
 class Foo {
   @XmlAttachmentRef
   @XmlAttribute
   DataHandler data;

   @XmlAttachmentRef
   @XmlElement
   DataHandler body;
 }
    The above code maps to the following XML:

 <xs:element name="foo" xmlns:ref="http://ws-i.org/profiles/basic/1.1/xsd">
   <xs:complexType>
     <xs:sequence>
       <xs:element name="body" type="ref:swaRef" minOccurs="0" />
     </xs:sequence>
     <xs:attribute name="data" type="ref:swaRef" use="optional" />
   </xs:complexType>
 </xs:element>

    The above binding supports WS-I AP 1.0 WS-I Attachments Profile Version 1.0.

    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m=lnidmndmxllmxxa/ ete:/lh


XmlAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlAttribute

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlAttribute

    Maps a JavaBean property to a XML attribute.

    Usage

    The @XmlAttribute annotation can be used with the following program elements:

    • JavaBean property
    • field

    A static final field is mapped to a XML fixed attribute.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • If type of the field or the property is a collection type, then the collection item type must be mapped to schema simple type.
           // Examples
     @XmlAttribute List<Integer> items; //legal
     @XmlAttribute List<Bar> foo; // illegal if Bar does not map to a schema simple type
    • If the type of the field or the property is a non collection type, then the type of the property or field must map to a simple schema type.
           // Examples
     @XmlAttribute int foo; // legal
     @XmlAttribute Foo foo; // illegal if Foo does not map to a schema simple type
    • This annotation can be used with the following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlJavaTypeAdapter
      • .

    Example 1: Map a JavaBean property to an XML attribute.

         //Example: Code fragment
     public class USPrice {
         @XmlAttribute
         public java.math.BigDecimal getPrice() {...} ;
         public void setPrice(java.math.BigDecimal ) {...};
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="USPrice">
       <xs:sequence>
       </xs:sequence>
       <xs:attribute name="price" type="xs:decimal"/>
     </xs:complexType>

    Example 2: Map a JavaBean property to an XML attribute with anonymous type.

    See Example 7 in @XmlType.

    Example 3: Map a JavaBean collection property to an XML attribute.

         // Example: Code fragment
     class Foo {
         ...
         @XmlAttribute List<Integer> items;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="foo">
       ...
       <xs:attribute name="items">
         <xs:simpleType>
           <xs:list itemType="xs:int"/>
         </xs:simpleType>
     </xs:complexType>
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlType

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      Name of the XML Schema attribute.
      String namespace
      Specifies the XML target namespace of the XML Schema attribute.
      boolean required
      Specifies if the XML Schema attribute is optional or required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema attribute. By default, the XML Schema attribute name is derived from the JavaBean property name.
        Default:
        "##default"

      • required

        public abstract boolean required
        Specifies if the XML Schema attribute is optional or required. If true, then the JavaBean property is mapped to a XML Schema attribute that is required. Otherwise it is mapped to a XML Schema attribute that is optional.
        Default:
        false

      • namespace

        public abstract String namespace
        Specifies the XML target namespace of the XML Schema attribute.
        Default:
        "##default"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bmjcee etrrettnmoe"n"ll>>n


XmlElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElement

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,PARAMETER})
public @interface XmlElement
    Maps a JavaBean property to a XML element derived from property name.

    Usage

    @XmlElement annotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    • within XmlElements

    The usage is subject to the following constraints:
    • This annotation can be used with following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlElementWrapper, XmlJavaTypeAdapter
    • if the type of JavaBean property is a collection type of array, an indexed property, or a parameterized list, and this annotation is used with XmlElements then, @XmlElement.type() must be DEFAULT.class since the collection item type is already known.

    A JavaBean property, when annotated with @XmlElement annotation is mapped to a local element in the XML Schema complex type to which the containing class is mapped.

    Example 1: Map a public non static non final field to local element

         //Example: Code fragment
     public class USPrice {
         @XmlElement(name="itemprice")
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="itemprice" type="xs:decimal" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 2: Map a field to a nillable element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="0"/>
       </sequence>
     </xs:complexType>

    Example 3: Map a field to a nillable, required element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true, required=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="1"/>
       </sequence>
     </xs:complexType>

    Example 4: Map a JavaBean property to an XML element with anonymous type.

    See Example 6 in @XmlType.

    从以下版本开始：
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String defaultValue
      Default value of this element.
      String name
      Name of the XML Schema element.
      String namespace
      XML target namespace of the XML Schema element.
      boolean nillable
      Customize the element declaration to be nillable.
      boolean required
      Customize the element declaration to be required.
      类 type
      The Java class being referenced.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema element.

        If the value is "##default", then element name is derived from the JavaBean property name.

        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        Customize the element declaration to be nillable.

        If nillable() is true, then the JavaBean property is mapped to a XML Schema nillable element declaration.

        Default:
        false

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        Default:
        false

      • namespace

        public abstract String namespace
        XML target namespace of the XML Schema element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise "" (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The '' value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.

        Default:
        "\u0000"

      • type

        public abstract 类 type
        The Java class being referenced.
        Default:
        javax.xml.bind.annotation.XmlElement.DEFAULT.class
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= VTML


XmlElement.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation

类 XmlElement.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElement.DEFAULT
  • 封闭类：
    XmlElement

    public static final class XmlElement.DEFAULT
extends Object
    Used in XmlElement.type() to signal that the type be inferred from the signature of the property.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlElement.DEFAULT()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlElement.DEFAULT

        public XmlElement.DEFAULT()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=>">gnn/rrrnrf<=rahn>L


XmlElementDecl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementDecl

  • @Retention(value=RUNTIME)
@Target(value=方法)
public @interface XmlElementDecl
    Maps a factory method to a XML element.

    Usage

    The annotation creates a mapping between an XML schema element declaration and a element factory method that returns a JAXBElement instance representing the element declaration. Typically, the element factory method is generated (and annotated) from a schema into the ObjectFactory class in a Java package that represents the binding of the element declaration's target namespace. Thus, while the annotation syntax allows @XmlElementDecl to be used on any method, semantically its use is restricted to annotation of element factory method. The usage is subject to the following constraints:
    • The class containing the element factory method annotated with @XmlElementDecl must be marked with XmlRegistry.
    • The element factory method must take one parameter assignable to Object.

    Example 1: Annotation on a factory method

         // Example: code fragment
     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="foo")
         JAXBElement<String> createFoo(String s) { ... }
     }

     <!-- XML input -->
       <foo>string</foo>

     // Example: code fragment corresponding to XML input
     JAXBElement<String> o =
     (JAXBElement<String>)unmarshaller.unmarshal(aboveDocument);
     // print JAXBElement instance to show values
     System.out.println(o.getName());   // prints  "{}foo"
     System.out.println(o.getValue());  // prints  "string"
     System.out.println(o.getValue().getClass()); // prints "java.lang.String"

     <!-- Example: XML schema definition -->
     <xs:element name="foo" type="xs:string"/>

    Example 2: Element declaration with non local scope

    The following example illustrates the use of scope annotation parameter in binding of element declaration in schema derived code.

    The following example may be replaced in a future revision of this javadoc.

     <!-- Example: XML schema definition -->
     <xs:schema>
       <xs:complexType name="pea">
         <xs:choice maxOccurs="unbounded">
           <xs:element name="foo" type="xs:string"/>
           <xs:element name="bar" type="xs:string"/>
         </xs:choice>
       </xs:complexType>
       <xs:element name="foo" type="xs:int"/>
     </xs:schema>

         // Example: expected default binding
     class Pea {
         @XmlElementRefs({
             @XmlElementRef(name="foo",type=JAXBElement.class)
             @XmlElementRef(name="bar",type=JAXBElement.class)
         })
         List<JAXBElement<String>> fooOrBar;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(scope=Pea.class,name="foo")
         JAXBElement createPeaFoo(String s);

         @XmlElementDecl(scope=Pea.class,name="bar")
         JAXBElement createPeaBar(String s);

         @XmlElementDecl(name="foo")
         JAXBElement createFoo(Integer i);
     }
    Without scope createFoo and createPeaFoo would become ambiguous since both of them map to a XML schema element with the same local name "foo".
    从以下版本开始：
    JAXB 2.0
    另请参见：
    XmlRegistry

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      String name
      local name of the XML element.

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String defaultValue
      Default value of this element.
      String namespace
      namespace name of the XML element.
      类 scope
      scope of the mapping.
      String substitutionHeadName
      XML local name of a substitution group's head element.
      String substitutionHeadNamespace
      namespace name of a substitution group's head XML element.

    • Element Detail

      • name

        public abstract String name
        local name of the XML element.

        Note to reviewers: There is no default name; since the annotation is on a factory method, it is not clear that the method name can be derived from the factory method name.

        另请参见：
        namespace()

      • scope

        public abstract 类 scope
        scope of the mapping.

        If this is not XmlElementDecl.GLOBAL, then this element declaration mapping is only active within the specified class.

        Default:
        javax.xml.bind.annotation.XmlElementDecl.GLOBAL.class

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the value is the namespace name for the package of the class containing this factory method.

        另请参见：
        name()
        Default:
        "##default"

      • substitutionHeadNamespace

        public abstract String substitutionHeadNamespace
        namespace name of a substitution group's head XML element.

        This specifies the namespace name of the XML element whose local name is specified by substitutionHeadName().

        If susbtitutionHeadName() is "", then this value can only be "##default". But the value is ignored since since this element is not part of susbtitution group when the value of susbstitutionHeadName() is "".

        If susbtitutionHeadName() is not "" and the value is "##default", then the namespace name is the namespace name to which the package of the containing class, marked with XmlRegistry, is mapped.

        If susbtitutionHeadName() is not "" and the value is not "##default", then the value is the namespace name.

        另请参见：
        substitutionHeadName()
        Default:
        "##default"

      • substitutionHeadName

        public abstract String substitutionHeadName
        XML local name of a substitution group's head element.

        If the value is "", then this element is not part of any substitution group.

        另请参见：
        substitutionHeadNamespace()
        Default:
        ""

      • defaultValue

        public abstract String defaultValue
        Default value of this element.

        The '' value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.

        Default:
        "\u0000"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hinioinitn nnll.eaa/ lii


XmlElementDecl.GLOBAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation

类 XmlElementDecl.GLOBAL

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
  • 封闭类：
    XmlElementDecl

    public static final class XmlElementDecl.GLOBAL
extends Object
    Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlElementDecl.GLOBAL()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlElementDecl.GLOBAL

        public XmlElementDecl.GLOBAL()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c>ot/ddtddoeedooaS lccro>s>Fd"s


XmlElementRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRef

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlElementRef

    Maps a JavaBean property to a XML element derived from property's type.

    Usage

    @XmlElementRef annotation can be used with a JavaBean property or from within XmlElementRefs

    This annotation dynamically associates an XML element name with the JavaBean property. When a JavaBean property is annotated with XmlElement, the XML element name is statically derived from the JavaBean property name. However, when this annotation is used, the XML element name is derived from the instance of the type of the JavaBean property at runtime.

    XML Schema substitution group support

    XML Schema allows a XML document author to use XML element names that were not statically specified in the content model of a schema using substitution groups. Schema derived code provides support for substitution groups using an element property, (section 5.5.5, "Element Property" of JAXB 2.0 specification). An element property method signature is of the form:

     public void setTerm(JAXBElement<? extends Operator>);
     public JAXBElement<? extends Operator> getTerm();

    An element factory method annotated with XmlElementDecl is used to create a JAXBElement instance, containing an XML element name. The presence of @XmlElementRef annotation on an element property indicates that the element name from JAXBElement instance be used instead of deriving an XML element name from the JavaBean property name.

    The usage is subject to the following constraints:

    • If the collection item type (for collection property) or property type (for single valued property) is JAXBElement, then @XmlElementRef}.name() and @XmlElementRef.namespace() must point an element factory method with an @XmlElementDecl annotation in a class annotated with @XmlRegistry (usually ObjectFactory class generated by the schema compiler) :
      • @XmlElementDecl.name() must equal @XmlElementRef.name()
      • @XmlElementDecl.namespace() must equal @XmlElementRef.namespace().
    • If the collection item type (for collection property) or property type (for single valued property) is not JAXBElement, then the type referenced by the property or field must be annotated with XmlRootElement.
    • This annotation can be used with the following annotations: XmlElementWrapper, XmlJavaTypeAdapter.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Ant Task Example

    The following Java class hierarchy models an Ant build script. An Ant task corresponds to a class in the class hierarchy. The XML element name of an Ant task is indicated by the @XmlRootElement annotation on its corresponding class.
         @XmlRootElement(name="target")
     class Target {
         // The presence of @XmlElementRef indicates that the XML
         // element name will be derived from the @XmlRootElement
         // annotation on the type (for e.g. "jar" for JarTask).
         @XmlElementRef
         List<Task> tasks;
     }

     abstract class Task {
     }

     @XmlRootElement(name="jar")
     class JarTask extends Task {
         ...
     }

     @XmlRootElement(name="javac")
     class JavacTask extends Task {
         ...
     }

     <!-- XML Schema fragment -->
     <xs:element name="target" type="Target">
     <xs:complexType name="Target">
       <xs:sequence>
         <xs:choice maxOccurs="unbounded">
           <xs:element ref="jar">
           <xs:element ref="javac">
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Thus the following code fragment:

         Target target = new Target();
     target.tasks.add(new JarTask());
     target.tasks.add(new JavacTask());
     marshal(target);
    will produce the following XML output:

     <target>
       <jar>
         ....
       </jar>
       <javac>
         ....
       </javac>
     </target>

    It is not an error to have a class that extends Task that doesn't have XmlRootElement. But they can't show up in an XML instance (because they don't have XML element names).

    Example 2: XML Schema Susbstitution group support

    The following example shows the annotations for XML Schema substitution groups. The annotations and the ObjectFactory are derived from the schema.

         @XmlElement
     class Math {
         //  The value of type()is
         //  JAXBElement.class , which indicates the XML
         //  element name ObjectFactory - in general a class marked
         //  with @XmlRegistry. (See ObjectFactory below)
         //
         //  The name() is "operator", a pointer to a
         // factory method annotated with a
         //  XmlElementDecl with the name "operator". Since
         //  "operator" is the head of a substitution group that
         //  contains elements "add" and "sub" elements, "operator"
         //  element can be substituted in an instance document by
         //  elements "add" or "sub". At runtime, JAXBElement
         //  instance contains the element name that has been
         //  substituted in the XML document.
         //
         @XmlElementRef(type=JAXBElement.class,name="operator")
         JAXBElement<? extends Operator> term;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="operator")
         JAXBElement<Operator> createOperator(Operator o) {...}
         @XmlElementDecl(name="add",substitutionHeadName="operator")
         JAXBElement<Operator> createAdd(Operator o) {...}
         @XmlElementDecl(name="sub",substitutionHeadName="operator")
         JAXBElement<Operator> createSub(Operator o) {...}
     }

     class Operator {
         ...
     }

    Thus, the following code fragment

         Math m = new Math();
     m.term = new ObjectFactory().createAdd(new Operator());
     marshal(m);
    will produce the following XML output:
         <math>
       <add>...</add>
     </math>
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlElementRefs

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      String namespace
      This parameter and name() are used to determine the XML element for the JavaBean property.
      boolean required
      Customize the element declaration to be required.
      类 type
      The Java type being referenced.

    • Element Detail

      • type

        public abstract 类 type
        The Java type being referenced.

        If the value is DEFAULT.class, the type is inferred from the the type of the JavaBean property.

        Default:
        javax.xml.bind.annotation.XmlElementRef.DEFAULT.class

      • namespace

        public abstract String namespace
        This parameter and name() are used to determine the XML element for the JavaBean property.

        If type() is JAXBElement.class , then namespace() and name() point to a factory method with XmlElementDecl. The XML element name is the element name from the factory method's XmlElementDecl annotation or if an element from its substitution group (of which it is a head element) has been substituted in the XML document, then the element name is from the XmlElementDecl on the substituted element.

        If type() is not JAXBElement.class, then the XML element name is the XML element name statically associated with the type using the annotation XmlRootElement on the type. If the type is not annotated with an XmlElementDecl, then it is an error.

        If type() is not JAXBElement.class, then this value must be "".

        Default:
        ""

      • name

        public abstract String name
        另请参见：
        namespace()
        Default:
        "##default"

      • required

        public abstract boolean required
        Customize the element declaration to be required.

        If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

        For compatibility with JAXB 2.1, this property defaults to true, despite the fact that XmlElement.required() defaults to false.

        从以下版本开始：
        2.2
        Default:
        true
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slct=/csatxjasi�"s//. i


XmlElementRef.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation

类 XmlElementRef.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
  • 封闭类：
    XmlElementRef

    public static final class XmlElementRef.DEFAULT
extends Object
    Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlElementRef.DEFAULT()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlElementRef.DEFAULT

        public XmlElementRef.DEFAULT()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aivcilltllm""lmmna..d<


XmlElementRefs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementRefs

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlElementRefs
    Marks a property that refers to classes with XmlElement or JAXBElement.

    Compared to an element property (property with XmlElement annotation), a reference property has a different substitution semantics. When a sub-class is assigned to a property, an element property produces the same tag name with @xsi:type, whereas a reference property produces a different tag name (the tag name that's on the the sub-class.)

    This annotation can be used with the following annotations: XmlJavaTypeAdapter, XmlElementWrapper.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlElementWrapper, XmlElementRef

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      XmlElementRef[] value

    • Element Detail

      • value

        public abstract XmlElementRef[] value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.dcrlgalg eeg ttt l


XmlElements

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElements

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlElements

    A container for multiple @XmlElement annotations. Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlElements as follows:

     @XmlElements({ @XmlElement(...),@XmlElement(...) })

    The @XmlElements annnotation can be used with the following program elements:

    • a JavaBean property
    • non static, non transient field
    This annotation is intended for annotation a JavaBean collection property (e.g. List).

    Usage

    The usage is subject to the following constraints:

    • This annotation can be used with the following annotations: @XmlIDREF, @XmlElementWrapper.
    • If @XmlIDREF is also specified on the JavaBean property, then each @XmlElement.type() must contain a JavaBean property annotated with @XmlID.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example 1: Map to a list of elements

    // Mapped code fragment
    public class Foo {
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
         }
         public List items;
    }

    <!-- XML Representation for a List of {1,2.5}
            XML output is not wrapped using another element -->
    ...
     1
     2.5
    ...

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:element name="A" type="xs:int"/>
          <xs:element name="B" type="xs:float"/>
        <xs:choice>
      </xs:sequence>
    </xs:complexType>

    Example 2: Map to a list of elements wrapped with another element

    // Mapped code fragment
    public class Foo {
        @XmlElementWrapper(name="bar")
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
        }
        public List items;
    }

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="xs:int"/>
              <xs:element name="B" type="xs:float"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

    Example 3: Change element name based on type using an adapter.

        class Foo {
       @XmlJavaTypeAdapter(QtoPAdapter.class)
       @XmlElements({
           @XmlElement(name="A",type=PX.class),
           @XmlElement(name="B",type=PY.class)
       })
       Q bar;
    }

    @XmlType abstract class P {...}
    @XmlType(name="PX") class PX extends P {...}
    @XmlType(name="PY") class PY extends P {...}

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="PX"/>
              <xs:element name="B" type="PY"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlElement, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      XmlElement[] value
      Collection of @XmlElement annotations

    • Element Detail

      • value

        public abstract XmlElement[] value
        Collection of @XmlElement annotations
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/oj.rfs&<>aa_>.t


XmlElementWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlElementWrapper

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlElementWrapper
    Generates a wrapper element around XML representation. This is primarily intended to be used to produce a wrapper XML element around collections. The annotation therefore supports two forms of serialization shown below.
        //Example: code fragment
      int[] names;

    // XML Serialization Form 1 (Unwrapped collection)
    <names> ... </names>
    <names> ... </names>

    // XML Serialization Form 2 ( Wrapped collection )
    <wrapperElement>
       <names> value-of-item </names>
       <names> value-of-item </names>
       ....
    </wrapperElement>

    The two serialized XML forms allow a null collection to be represented either by absence or presence of an element with a nillable attribute.

    Usage

    The @XmlElementWrapper annotation can be used with the following program elements:

    • JavaBean property
    • non static, non transient field

    The usage is subject to the following constraints:

    • The property must be a collection property
    • This annotation can be used with the following annotations: XmlElement, XmlElements, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter
      • .

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlElement, XmlElements, XmlElementRef, XmlElementRefs

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      Name of the XML wrapper element.
      String namespace
      XML target namespace of the XML wrapper element.
      boolean nillable
      If true, the absence of the collection is represented by using xsi:nil='true'.
      boolean required
      Customize the wrapper element declaration to be required.

    • Element Detail

      • name

        public abstract String name
        Name of the XML wrapper element. By default, the XML wrapper element name is derived from the JavaBean property name.
        Default:
        "##default"

      • namespace

        public abstract String namespace
        XML target namespace of the XML wrapper element.

        If the value is "##default", then the namespace is determined as follows:

        1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
        2. Otherwise "" (which produces unqualified element in the default namespace.
        Default:
        "##default"

      • nillable

        public abstract boolean nillable
        If true, the absence of the collection is represented by using xsi:nil='true'. Otherwise, it is represented by the absence of the element.
        Default:
        false

      • required

        public abstract boolean required
        Customize the wrapper element declaration to be required.

        If required() is true, then the corresponding generated XML schema element declaration will have minOccurs="1", to indicate that the wrapper element is always expected.

        Note that this only affects the schema generation, and not the unmarshalling or marshalling capability. This is simply a mechanism to let users express their application constraints better.

        从以下版本开始：
        JAXB 2.1
        Default:
        false
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t&"alRh> njjcniaill " se


XmlEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnum

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlEnum

    Maps an enum type Enum to XML representation.

    This annotation, together with XmlEnumValue provides a mapping of enum type to XML representation.

    Usage

    The @XmlEnum annotation can be used with the following program elements:

    • enum type

    The usage is subject to the following constraints:

    • This annotation can be used the following other annotations: XmlType, XmlRootElement

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type to which @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value() .

    Examples: See examples in XmlEnumValue

    从以下版本开始：
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      类<?> value
      Java type that is mapped to a XML simple type.

    • Element Detail

      • value

        public abstract 类<?> value
        Java type that is mapped to a XML simple type.
        Default:
        java.lang.String.class
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e)>ceX<>X<>cc<>>tdaa../f/.l


XmlEnumValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlEnumValue

  • @Retention(value=RUNTIME)
@Target(value=字段)
public @interface XmlEnumValue
    Maps an enum constant in Enum type to XML representation.

    Usage

    The @XmlEnumValue annotation can be used with the following program elements:

    • enum constant

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    This annotation, together with XmlEnum provides a mapping of enum type to XML representation.

    An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type specified in @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value()

    In the absence of this annotation, Enum.name() is used as the XML representation.

    Example 1: Map enum constant name -> enumeration facet

         //Example: Code fragment
     @XmlEnum(String.class)
     public enum Card { CLUBS, DIAMONDS, HEARTS, SPADES }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Card">
       <xs:restriction base="xs:string"/>
         <xs:enumeration value="CLUBS"/>
         <xs:enumeration value="DIAMONDS"/>
         <xs:enumeration value="HEARTS"/>
         <xs:enumeration value="SPADES"/>
     </xs:simpleType>

    Example 2: Map enum constant name(value) -> enumeration facet

         //Example: code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Coin {
         @XmlEnumValue("1") PENNY(1),
         @XmlEnumValue("5") NICKEL(5),
         @XmlEnumValue("10") DIME(10),
         @XmlEnumValue("25") QUARTER(25) }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Coin">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="5"/>
         <xs:enumeration value="10"/>
         <xs:enumeration value="25"/>
       </xs:restriction>
     </xs:simpleType>

    Example 3: Map enum constant name -> enumeration facet

         //Code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Code {
         @XmlEnumValue("1") ONE,
         @XmlEnumValue("2") TWO;
     }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Code">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="2"/>
       </xs:restriction>
     </xs:simpleType>
    从以下版本开始：
    JAXB 2.0

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      String value

    • Element Detail

      • value

        public abstract String value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nlg, httht hhm sl


XmlID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlID

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlID

    Maps a JavaBean property to XML ID.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlID annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:
    • At most one field or property in a class can be annotated with @XmlID.
    • The JavaBean property's type must be java.lang.String.
    • The only other mapping annotations that can be used with @XmlID are:@XmlElement and @XmlAttribute.

    Example: Map a JavaBean property's type to xs:ID

        // Example: code fragment
    public class Customer {
        @XmlAttribute
        @XmlID
        public String getCustomerID();
        public void setCustomerID(String id);
        .... other properties not shown
    }

    <!-- Example: XML Schema fragment -->
    <xs:complexType name="Customer">
      <xs:complexContent>
        <xs:sequence>
          ....
        </xs:sequence>
        <xs:attribute name="customerID" type="xs:ID"/>
      </xs:complexContent>
    </xs:complexType>
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlIDREF
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s-taook##ei#oa


XmlIDREF

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlIDREF

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlIDREF

    Maps a JavaBean property to XML IDREF.

    To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

    Usage

    The @XmlIDREF annotation can be used with the following program elements:
    • a JavaBean property
    • non static, non transient field

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following constraints:

    • If the type of the field or property is a collection type, then the collection item type must contain a property or field annotated with @XmlID.
    • If the field or property is single valued, then the type of the property or field must contain a property or field annotated with @XmlID.

      Note: If the collection item type or the type of the property (for non collection type) is java.lang.Object, then the instance must contain a property/field annotated with @XmlID attribute.

    • This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlList, and XmlElements.

    Example: Map a JavaBean property to xs:IDREF (i.e. by reference rather than by containment)

   //EXAMPLE: Code fragment
   public class Shipping {
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
       ....
    }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

    Example 2: The following is a complete example of containment versus reference.

        // By default, Customer maps to complex type xs:Customer
    public class Customer {

        // map JavaBean property type to xs:ID
        @XmlID public String getCustomerID();
        public void setCustomerID(String id);

        // .... other properties not shown
    }

   // By default, Invoice maps to a complex type xs:Invoice
   public class Invoice {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);

      // .... other properties not shown here
   }

   // By default, Shipping maps to complex type xs:Shipping
   public class Shipping {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
   }

   // at least one class must reference Customer by containment;
   // Customer instances won't be marshalled.
   @XmlElement(name="CustomerData")
   public class CustomerData {
       // map reference to Customer by containment by default.
       public Customer getCustomer();

       // maps reference to Shipping by containment by default.
       public Shipping getShipping();

       // maps reference to Invoice by containment by default.
       public Invoice getInvoice();
   }

   <!-- XML Schema mapping for above code frament -->

   <xs:complexType name="Invoice">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Customer">
     <xs:complexContent>
       <xs:sequence>
         ....
       </xs:sequence>
       <xs:attribute name="CustomerID" type="xs:ID"/>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="CustomerData">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:Customer"/>
         <xs:element name="shipping" type="xs:Shipping"/>
         <xs:element name="invoice"  type="xs:Invoice"/>
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:element name"customerData" type="xs:CustomerData"/>

   <!-- Instance document conforming to the above XML Schema -->
    <customerData>
       <customer customerID="Alice">
           ....
       </customer>

       <shipping customer="Alice">
           ....
       </shipping>

       <invoice customer="Alice">
           ....
       </invoice>
   </customerData>

    Example 3: Mapping List to repeating element of type IDREF

         // Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElement(name="Alice")
             public List customers;
     }

     <!-- XML schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

    Example 4: Mapping a List to a list of elements of type IDREF.

         //Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElements(
             @XmlElement(name="Alice", type="Customer.class")
              @XmlElement(name="John", type="InternationalCustomer.class")
         public List customers;
     }

     <!-- XML Schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
           <xs:element name="John" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtepa//can_lirltt"isiJ漳s


XmlInlineBinaryData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlInlineBinaryData

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,TYPE})
public @interface XmlInlineBinaryData
    Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.

    When XOP encoding is enabled as described in AttachmentMarshaller.isXOPPackage(), this annotation disables datatypes such as Image or Source or byte[] that are bound to base64-encoded binary from being considered for XOP encoding. If a JAXB property is annotated with this annotation or if the JAXB property's base type is annotated with this annotation, neither AttachmentMarshaller.addMtomAttachment(DataHandler, String, String) nor AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String) is ever called for the property. The binary data will always be inlined.

    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=o"e;s xs && e e&Te


XmlList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlList

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,PARAMETER})
public @interface XmlList
    Used to map a property to a list simple type.

    Usage

    The @XmlList annotation can be used with the following program elements:

    • JavaBean property
    • field

    When a collection property is annotated just with @XmlElement, each item in the collection will be wrapped by an element. For example,

     @XmlRootElement
 class Foo {
     @XmlElement
     List<String> data;
 }
    would produce XML like this:

 <foo>
   <data>abc</data>
   <data>def</data>
 </foo>
    @XmlList annotation, on the other hand, allows multiple values to be represented as whitespace-separated tokens in a single element. For example,
     @XmlRootElement
 class Foo {
     @XmlElement
     @XmlList
     List<String> data;
 }
    the above code will produce XML like this:

 <foo>
   <data>abc def</data>
 </foo>

    This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlValue, XmlIDREF.

    • The use of @XmlList with XmlValue while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlValue would.
    • The use of @XmlList with XmlAttribute while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlAttribute would.
    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l mreaucssucNL "


XmlMimeType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlMimeType

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,PARAMETER})
public @interface XmlMimeType
    Associates the MIME type that controls the XML representation of the property.

    This annotation is used in conjunction with datatypes such as Image or Source that are bound to base64-encoded binary in XML.

    If a property that has this annotation has a sibling property bound to the xmime:contentType attribute, and if in the instance the property has a value, the value of the attribute takes precedence and that will control the marshalling.

    从以下版本开始：
    JAXB2.0

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      String value
      The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.

    • Element Detail

      • value

        public abstract String value
        The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

╯薼rlpl萳m>嫒ㄓax�>/�/�/t �


XmlMixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlMixed

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlMixed

    Annotate a JavaBean multi-valued property to support mixed content.

    The usage is subject to the following constraints:

    • can be used with @XmlElementRef, @XmlElementRefs or @XmlAnyElement

    The following can be inserted into @XmlMixed annotated multi-valued property

    • XML text information items are added as values of java.lang.String.
    • Children element information items are added as instances of JAXBElement or instances with a class that is annotated with @XmlRootElement.
    • Unknown content that is not be bound to a JAXB mapped class is inserted as Element. (Assumes property annotated with @XmlAnyElement)
    Below is an example of binding and creation of mixed content.

  <!-- schema fragment having  mixed content -->
  <xs:complexType name="letterBody" mixed="true">
    <xs:sequence>
      <xs:element name="name" type="xs:string"/>
      <xs:element name="quantity" type="xs:positiveInteger"/>
      <xs:element name="productName" type="xs:string"/>
      <!-- etc. -->
    </xs:sequence>
  </xs:complexType>
  <xs:element name="letterBody" type="letterBody"/>

 // Schema-derived Java code:
 // (Only annotations relevant to mixed content are shown below,
 //  others are ommitted.)
 import java.math.BigInteger;
 public class ObjectFactory {
      // element instance factories
      JAXBElement<LetterBody> createLetterBody(LetterBody value);
      JAXBElement<String>     createLetterBodyName(String value);
      JAXBElement<BigInteger> createLetterBodyQuantity(BigInteger value);
      JAXBElement<String>     createLetterBodyProductName(String value);
      // type instance factory
      LetterBody> createLetterBody();
 }

     public class LetterBody {
      // Mixed content can contain instances of Element classes
      // Name, Quantity and ProductName. Text data is represented as
      // java.util.String for text.
      @XmlMixed
      @XmlElementRefs({
              @XmlElementRef(name="productName", type=JAXBElement.class),
              @XmlElementRef(name="quantity", type=JAXBElement.class),
              @XmlElementRef(name="name", type=JAXBElement.class)})
      List getContent(){...}
 }
    The following is an XML instance document with mixed content

 <letterBody>
 Dear Mr.<name>Robert Smith</name>
 Your order of <quantity>1</quantity> <productName>Baby
 Monitor</productName> shipped from our warehouse. ....
 </letterBody>
    that can be constructed using following JAXB API calls.

 LetterBody lb = ObjectFactory.createLetterBody();
 JAXBElement<LetterBody> lbe = ObjectFactory.createLetterBody(lb);
 List gcl = lb.getContent();  //add mixed content to general content property.
 gcl.add("Dear Mr.");  // add text information item as a String.

 // add child element information item
 gcl.add(ObjectFactory.createLetterBodyName("Robert Smith"));
 gcl.add("Your order of "); // add text information item as a String

 // add children element information items
 gcl.add(ObjectFactory.
                      createLetterBodyQuantity(new BigInteger("1")));
 gcl.add(ObjectFactory.createLetterBodyProductName("Baby Monitor"));
 gcl.add("shipped from our warehouse");  // add text information item

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

natM "h-!---ac tmlaim=o


XmlNs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlNs

  • @Retention(value=RUNTIME)
@Target(value={})
public @interface XmlNs

    Associates a namespace prefix with a XML namespace URI.

    Usage

    @XmlNs annotation is intended for use from other program annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example:See XmlSchema annotation type for an example.

    从以下版本开始：
    JAXB2.0

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      String namespaceURI
      Namespace URI
      String prefix
      Namespace prefix

    • Element Detail

      • prefix

        public abstract String prefix
        Namespace prefix

      • namespaceURI

        public abstract String namespaceURI
        Namespace URI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/LC C CeClasesns ==ean =b


XmlNsForm

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.bind.annotation

Enum XmlNsForm

  • java.lang.Object
    • java.lang.Enum<XmlNsForm>
      • javax.xml.bind.annotation.XmlNsForm
  • 所有已实现的接口：
    Serializable, Comparable<XmlNsForm>

    public enum XmlNsForm
extends Enum<XmlNsForm>
    Enumeration of XML Schema namespace qualifications.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Usage

    The namespace qualification values are used in the annotations defined in this packge. The enumeration values are mapped as follows:

    Enum Value | XML Schema Value
    UNQUALIFIED | unqualified
    QUALIFIED | qualified
    UNSET | namespace qualification attribute is absent from the XML Schema fragment
    从以下版本开始：
    JAXB2.0

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      QUALIFIED
      UNQUALIFIED
      UNSET

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static XmlNsForm valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • UNQUALIFIED

        public static final XmlNsForm UNQUALIFIED

      • QUALIFIED

        public static final XmlNsForm QUALIFIED

      • UNSET

        public static final XmlNsForm UNSET

    • 方法详细信息

      • values

        public static XmlNsForm[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (XmlNsForm c : XmlNsForm.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static XmlNsForm valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e aoemeeebeh,XXnp


XmlRegistry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlRegistry

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRegistry
    Marks a class that has XmlElementDecls.
    从以下版本开始：
    JAXB 2.0
    另请参见：
    XmlElementDecl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=i" e/


XmlRootElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlRootElement

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRootElement
    Maps a class or an enum type to an XML element.

    Usage

    The @XmlRootElement annotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    When a top level class or an enum type is annotated with the @XmlRootElement annotation, then its value is represented as XML element in an XML document.

    This annotation can be used with the following annotations: XmlType, XmlEnum, XmlAccessorType, XmlAccessorOrder.

    Example 1: Associate an element with XML Schema type

         // Example: Code fragment
     @XmlRootElement
     class Point {
        int x;
        int y;
        Point(int _x,int _y) {x=_x;y=_y;}
     }

         //Example: Code fragment corresponding to XML output
     marshal( new Point(3,5), System.out);

     <!-- Example: XML output -->
     <point>
       <x> 3 </x>
       <y> 5 </y>
     </point>
    The annotation causes an global element declaration to be produced in the schema. The global element declaration is associated with the XML schema type to which the class is mapped.

     <!-- Example: XML schema definition -->
     <xs:element name="point" type="point"/>
     <xs:complexType name="point">
       <xs:sequence>
         <xs:element name="x" type="xs:int"/>
         <xs:element name="y" type="xs:int"/>
       </xs:sequence>
     </xs:complexType>

    Example 2: Orthogonality to type inheritance

    An element declaration annotated on a type is not inherited by its derived types. The following example shows this.

         // Example: Code fragment
     @XmlRootElement
     class Point3D extends Point {
         int z;
         Point3D(int _x,int _y,int _z) {super(_x,_y);z=_z;}
     }

     //Example: Code fragment corresponding to XML output *
     marshal( new Point3D(3,5,0), System.out );

     <!-- Example: XML output -->
     <!-- The element name is point3D not point -->
     <point3D>
       <x>3</x>
       <y>5</y>
       <z>0</z>
     </point3D>

     <!-- Example: XML schema definition -->
     <xs:element name="point3D" type="point3D"/>
     <xs:complexType name="point3D">
       <xs:complexContent>
         <xs:extension base="point">
           <xs:sequence>
             <xs:element name="z" type="xs:int"/>
           </xs:sequence>
         </xs:extension>
       </xs:complexContent>
     </xs:complexType>
    Example 3: Associate a global element with XML Schema type to which the class is mapped.
         //Example: Code fragment
     @XmlRootElement(name="PriceElement")
     public class USPrice {
         @XmlElement
         public java.math.BigDecimal price;
     }

     <!-- Example: XML schema definition -->
     <xs:element name="PriceElement" type="USPrice"/>
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal"/>
       </sequence>
     </xs:complexType>
    从以下版本开始：
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      local name of the XML element.
      String namespace
      namespace name of the XML element.

    • Element Detail

      • namespace

        public abstract String namespace
        namespace name of the XML element.

        If the value is "##default", then the XML namespace name is derived from the package of the class ( XmlSchema ). If the package is unnamed, then the XML namespace is the default empty namespace.

        Default:
        "##default"

      • name

        public abstract String name
        local name of the XML element.

        If the value is "##default", then the name is derived from the class name.

        Default:
        "##default"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

apei<<>iiiaangps


XmlSchema

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchema

  • @Retention(value=RUNTIME)
@Target(value=软件包)
public @interface XmlSchema

    Maps a package name to a XML namespace.

    Usage

    The XmlSchema annotation can be used with the following program elements:

    • 软件包

    This is a package level annotation and follows the recommendations and restrictions contained in JSR 175, section III, "Annotations". Thus the usage is subject to the following constraints and recommendations.

    • There can only be one package declaration as noted in JSR 175, section III, "Annotations".
    • JSR 175 recommends package-info.java for package level annotations. JAXB Providers that follow this recommendation will allow the package level annotations to be defined in package-info.java.

    Example 1: Customize name of XML namespace to which package is mapped.

        @javax.xml.bind.annotation.XmlSchema (
      namespace = "http://www.example.com/MYPO1"
    )

    <!-- XML Schema fragment -->
    <schema
      xmlns=...
      xmlns:po=....
      targetNamespace="http://www.example.com/MYPO1"
    >
    <!-- prefixes generated by default are implementation
            depedenent -->

    Example 2: Customize namespace prefix, namespace URI mapping

        // Package level annotation
    @javax.xml.bind.annotation.XmlSchema (
      xmlns = {
        @javax.xml.bind.annotation.XmlNs(prefix = "po",
                   namespaceURI="http://www.example.com/myPO1"),

        @javax.xml.bind.annotation.XmlNs(prefix="xs",
                   namespaceURI="http://www.w3.org/2001/XMLSchema")
      )
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns:xs="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        targetNamespace="http://www.example.com/PO1">

    Example 3: Customize elementFormDefault

        @javax.xml.bind.annotation.XmlSchema (
      elementFormDefault=XmlNsForm.UNQUALIFIED
      ...
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        elementFormDefault="unqualified">
    从以下版本开始：
    JAXB2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      XmlNsForm attributeFormDefault
      Namespace qualification for attributes.
      XmlNsForm elementFormDefault
      Namespace qualification for elements.
      String location
      Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.
      String namespace
      Name of the XML namespace.
      XmlNs[] xmlns
      Customize the namespace URI, prefix associations.

    • Element Detail

      • xmlns

        public abstract XmlNs[] xmlns
        Customize the namespace URI, prefix associations. By default, the namespace prefixes for a XML namespace are generated by a JAXB Provider in an implementation dependent way.
        Default:
        {}

      • namespace

        public abstract String namespace
        Name of the XML namespace.
        Default:
        ""

      • elementFormDefault

        public abstract XmlNsForm elementFormDefault
        Namespace qualification for elements. By default, element default attribute will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • attributeFormDefault

        public abstract XmlNsForm attributeFormDefault
        Namespace qualification for attributes. By default, attributesFormDefault will be absent from the XML Schema fragment.
        Default:
        javax.xml.bind.annotation.XmlNsForm.UNSET

      • location

        public abstract String location
        Indicates that this namespace (specified by namespace()) has a schema already available exeternally, available at this location.

        This instructs the JAXB schema generators to simply refer to the pointed schema, as opposed to generating components into the schema. This schema is assumed to match what would be otherwise produced by the schema generator (same element names, same type names...)

        This feature is intended to be used when a set of the Java classes is originally generated from an existing schema, hand-written to match externally defined schema, or the generated schema is modified manually.

        Value could be any absolute URI, like http://example.org/some.xsd. It is also possible to specify the empty string, to indicate that the schema is externally available but the location is unspecified (and thus it's the responsibility of the reader of the generate schema to locate it.) Finally, the default value of this property "##generate" indicates that the schema generator is going to generate components for this namespace (as it did in JAXB 2.0.)

        Multiple XmlSchema annotations on multiple packages are allowed to govern the same namespace(). In such case, all of them must have the same location() values.

        Note to implementor

        More precisely, the value must be either "", "##generate", or a valid lexical representation of xs:anyURI that begins with <scheme>:.

        A schema generator is expected to generate a corresponding <xs:import namespace="..." schemaLocation="..."/> (or no schemaLocation attribute at all if the empty string is specified.) However, the schema generator is allowed to use a different value in the schemaLocation attribute (including not generating such attribute), for example so that the user can specify a local copy of the resource through the command line interface.

        从以下版本开始：
        JAXB2.1
        Default:
        "##generate"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>< "b sscumssltba sssalC


XmlSchemaType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaType

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,软件包})
public @interface XmlSchemaType
    Maps a Java type to a simple schema built-in type.

    Usage

    @XmlSchemaType annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • package

    @XmlSchemaType annotation defined for Java type applies to all references to the Java type from a property/field. A @XmlSchemaType annotation specified on the property/field overrides the @XmlSchemaType annotation specified at the package level.

    This annotation can be used with the following annotations: XmlElement, XmlAttribute.

    Example 1: Customize mapping of XMLGregorianCalendar on the field.

         //Example: Code fragment
     public class USPrice {
         @XmlElement
         @XmlSchemaType(name="date")
         public XMLGregorianCalendar date;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="date" type="xs:date"/>
       </sequence>
     </xs:complexType>

    Example 2: Customize mapping of XMLGregorianCalendar at package level

         package foo;
     @javax.xml.bind.annotation.XmlSchemaType(
          name="date", type=javax.xml.datatype.XMLGregorianCalendar.class)
     }
    从以下版本开始：
    JAXB2.0

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      String name

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String namespace
      类 type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • name

        public abstract String name

      • namespace

        public abstract String namespace
        Default:
        "http://www.w3.org/2001/XMLSchema"

      • type

        public abstract 类 type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.XmlSchemaType.DEFAULT.class
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ocfhyoU oibll>bbp nn =eoa t


XmlSchemaType.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation

类 XmlSchemaType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
  • 封闭类：
    XmlSchemaType

    public static final class XmlSchemaType.DEFAULT
extends Object
    Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlSchemaType.DEFAULT()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlSchemaType.DEFAULT

        public XmlSchemaType.DEFAULT()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ecs u>>l>>i >ii>dddX vXirBrJr m fB


XmlSchemaTypes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlSchemaTypes

  • @Retention(value=RUNTIME)
@Target(value=软件包)
public @interface XmlSchemaTypes

    A container for multiple @XmlSchemaType annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlSchemaType annotations as follows:

     @XmlSchemaTypes({ @XmlSchemaType(...), @XmlSchemaType(...) })

    The @XmlSchemaTypes annnotation can be used to define XmlSchemaType for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlSchemaType

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      XmlSchemaType[] value
      Collection of @XmlSchemaType annotations

    • Element Detail

      • value

        public abstract XmlSchemaType[] value
        Collection of @XmlSchemaType annotations
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h.t-c-pgep"aap""h 构a "RsRem


XmlSeeAlso

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlSeeAlso

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface XmlSeeAlso
    Instructs JAXB to also bind other classes when binding this class.

    Java makes it impractical/impossible to list all sub-classes of a given class. This often gets in a way of JAXB users, as it JAXB cannot automatically list up the classes that need to be known to JAXBContext.

    For example, with the following class definitions:

     class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    The user would be required to create JAXBContext as JAXBContext.newInstance(Dog.class,Cat.class) (Animal will be automatically picked up since Dog and Cat refers to it.)

    XmlSeeAlso annotation would allow you to write:

     @XmlSeeAlso({Dog.class,Cat.class})
 class Animal {}
 class Dog extends Animal {}
 class Cat extends Animal {}

    This would allow you to do JAXBContext.newInstance(Animal.class). By the help of this annotation, JAXB implementations will be able to correctly bind Dog and Cat.

    从以下版本开始：
    JAXB2.1

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      类[] value

    • Element Detail

      • value

        public abstract 类[] value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csornr r roig ceaso0律始r


XmlTransient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlTransient

  • @Retention(value=RUNTIME)
@Target(value={字段,方法,TYPE})
public @interface XmlTransient

    Prevents the mapping of a JavaBean property/type to XML representation.

    The @XmlTransient annotation is useful for resolving name collisions between a JavaBean property name and a field name or preventing the mapping of a field/property. A name collision can occur when the decapitalized JavaBean property name and a field name are the same. If the JavaBean property refers to the field, then the name collision can be resolved by preventing the mapping of either the field or the JavaBean property using the @XmlTransient annotation.

    When placed on a class, it indicates that the class shouldn't be mapped to XML by itself. Properties on such class will be mapped to XML along with its derived classes, as if the class is inlined.

    Usage

    The @XmlTransient annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • class

    @XmlTransientis mutually exclusive with all other JAXB defined annotations.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Example: Resolve name collision between JavaBean property and field name

       // Example: Code fragment
   public class USAddress {

       // The field name "name" collides with the property name
       // obtained by bean decapitalization of getName() below
       @XmlTransient public String name;

       String getName() {..};
       String setName() {..};
   }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="name" type="xs:string"/>
     </xs:sequence>
   </xs:complexType>
    从以下版本开始：
    JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=s slsts sily =byesst..mn(


XmlType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlType

  • @Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlType

    Maps a class or an enum type to a XML Schema type.

    Usage

    The @XmlType annnotation can be used with the following program elements:

    • a top level class
    • an enum type

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    Mapping a Class

    A class maps to a XML Schema type. A class is a data container for values represented by properties and fields. A schema type is a data container for values represented by schema components within a schema type's content model (e.g. model groups, attributes etc).

    To be mapped, a class must either have a public no-arg constructor or a static no-arg factory method. The static factory method can be specified in factoryMethod() and factoryClass() annotation elements. The static factory method or the no-arg constructor is used during unmarshalling to create an instance of this class. If both are present, the static factory method overrides the no-arg constructor.

    A class maps to either a XML Schema complex type or a XML Schema simple type. The XML Schema type is derived based on the mapping of JavaBean properties and fields contained within the class. The schema type to which the class is mapped can either be named or anonymous. A class can be mapped to an anonymous schema type by annotating the class with @XmlType(name="").

    Either a global element, local element or a local attribute can be associated with an anonymous type as follows:

    • global element: A global element of an anonymous type can be derived by annotating the class with @XmlRootElement. See Example 3 below.
    • local element: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the element associated with the anonymous type. See Example 4 below.
    • attribute: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the attribute associated with the anonymous type. See Example 5 below.
    Mapping to XML Schema Complex Type
    • If class is annotated with @XmlType(name="") , it is mapped to an anonymous type otherwise, the class name maps to a complex type name. The XmlName() annotation element can be used to customize the name.
    • Properties and fields that are mapped to elements are mapped to a content model within a complex type. The annotation element propOrder() can be used to customize the content model to be xs:all or xs:sequence. It is used for specifying the order of XML elements in xs:sequence.
    • Properties and fields can be mapped to attributes within the complex type.
    • The targetnamespace of the XML Schema type can be customized using the annotation element namespace().

    Mapping class to XML Schema simple type

    A class can be mapped to a XML Schema simple type using the @XmlValue annotation. For additional details and examples, see @XmlValue annotation type.

    The following table shows the mapping of the class to a XML Schema complex type or simple type. The notational symbols used in the table are:

    • -> : represents a mapping
    • [x]+ : one or more occurances of x
    • [ @XmlValue property ]: JavaBean property annotated with @XmlValue
    • X : don't care
    Target propOrder ClassBody ComplexType SimpleType
    类 {} [property]+ -> elements complexcontent
    xs:all
    类 non empty [property]+ -> elements complexcontent
    xs:sequence
    类 X no property -> element complexcontent
    empty sequence
    类 X 1 [ @XmlValue property] &&
    [property]+ ->attributes     		simplecontent
    类 X 1 [ @XmlValue property ]&&
    no properties -> attribute     		simpletype

    Mapping an enum type

    An enum type maps to a XML schema simple type with enumeration facets. The following annotation elements are ignored since they are not meaningful: propOrder() , factoryMethod() , factoryClass() .

    Usage with other annotations

    This annotation can be used with the following annotations: XmlRootElement, XmlAccessorOrder, XmlAccessorType, XmlEnum. However, XmlAccessorOrder and XmlAccessorType are ignored when this annotation is used on an enum type.

    Example 1: Map a class to a complex type with xs:sequence with a customized ordering of JavaBean properties.

       @XmlType(propOrder={"street", "city" , "state", "zip", "name" })
   public class USAddress {
     String getName() {..};
     void setName(String) {..};

     String getStreet() {..};
     void setStreet(String) {..};

     String getCity() {..};
     void setCity(String) {..};

     String getState() {..};
     void setState(String) {..};

     java.math.BigDecimal getZip() {..};
     void setZip(java.math.BigDecimal) {..};
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="street" type="xs:string"/>
       <xs:element name="city" type="xs:string"/>
       <xs:element name="state" type="xs:string"/>
       <xs:element name="zip" type="xs:decimal"/>
       <xs:element name="name" type="xs:string"/>
     </xs:all>
   </xs:complexType>

    Example 2: Map a class to a complex type with xs:all

     @XmlType(propOrder={})
 public class USAddress { ...}

 <!-- XML Schema mapping for USAddress -->
 <xs:complexType name="USAddress">
   <xs:all>
     <xs:element name="name" type="xs:string"/>
     <xs:element name="street" type="xs:string"/>
     <xs:element name="city" type="xs:string"/>
     <xs:element name="state" type="xs:string"/>
     <xs:element name="zip" type="xs:decimal"/>
   </xs:sequence>
 </xs:complexType>

    Example 3: Map a class to a global element with an anonymous type.

       @XmlRootElement
   @XmlType(name="")
   public class USAddress { ...}

   <!-- XML Schema mapping for USAddress -->
   <xs:element name="USAddress">
     <xs:complexType>
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:element name="street" type="xs:string"/>
         <xs:element name="city" type="xs:string"/>
         <xs:element name="state" type="xs:string"/>
         <xs:element name="zip" type="xs:decimal"/>
       </xs:sequence>
     </xs:complexType>
   </xs:element>

    Example 4: Map a property to a local element with anonmyous type.

       //Example: Code fragment
   public class Invoice {
       USAddress addr;
           ...
       }

   @XmlType(name="")
   public class USAddress { ... }
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="Invoice">
     <xs:sequence>
       <xs:element name="addr">
         <xs:complexType>
           <xs:element name="name", type="xs:string"/>
           <xs:element name="city", type="xs:string"/>
           <xs:element name="city" type="xs:string"/>
           <xs:element name="state" type="xs:string"/>
           <xs:element name="zip" type="xs:decimal"/>
         </xs:complexType>
       ...
     </xs:sequence>
   </xs:complexType>

    Example 5: Map a property to an attribute with anonymous type.

     //Example: Code fragment
     public class Item {
         public String name;
         @XmlAttribute
         public USPrice price;
     }

     // map class to anonymous simple type.
     @XmlType(name="")
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="Item">
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:attribute name="price">
           <xs:simpleType>
             <xs:restriction base="xs:decimal"/>
           </xs:simpleType>
         </xs:attribute>
       </xs:sequence>
     </xs:complexType>

    Example 6: Define a factoryClass and factoryMethod

          @XmlType(name="USAddressType", factoryClass=USAddressFactory.class,
      factoryMethod="getUSAddress")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

      public USAddress(String name, String street, String city,
          String state, int zip) {
          this.name = name;
          this.street = street;
          this.city = city;
          this.state = state;
          this.zip = zip;
      }
  }

  public class USAddressFactory {
      public static USAddress getUSAddress(){
       return new USAddress("Mark Baker", "23 Elm St",
          "Dayton", "OH", 90952);
  }

    Example 7: Define factoryMethod and use the default factoryClass

          @XmlType(name="USAddressType", factoryMethod="getNewInstance")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

          private USAddress() {}

          public static USAddress getNewInstance(){
              return new USAddress();
          }
      }
    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlElement, XmlAttribute, XmlValue, XmlSchema

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      类 factoryClass
      Class containing a no-arg factory method for creating an instance of this class.
      String factoryMethod
      Name of a no-arg factory method in the class specified in factoryClass factoryClass().
      String name
      Name of the XML Schema type which the class is mapped.
      String namespace
      Name of the target namespace of the XML Schema type.
      String[] propOrder
      Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

    • Element Detail

      • name

        public abstract String name
        Name of the XML Schema type which the class is mapped.
        Default:
        "##default"

      • propOrder

        public abstract String[] propOrder
        Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

        Refer to the table for how the propOrder affects the mapping of class

        The propOrder is a list of names of JavaBean properties in the class. Each name in the list is the name of a Java identifier of the JavaBean property. The order in which JavaBean properties are listed is the order of XML Schema elements to which the JavaBean properties are mapped.

        All of the JavaBean properties being mapped to XML Schema elements must be listed.

        A JavaBean property or field listed in propOrder must not be transient or annotated with @XmlTransient.

        The default ordering of JavaBean properties is determined by @XmlAccessorOrder.

        Default:
        ""

      • namespace

        public abstract String namespace
        Name of the target namespace of the XML Schema type. By default, this is the target namespace to which the package containing the class is mapped.
        Default:
        "##default"

      • factoryClass

        public abstract 类 factoryClass
        Class containing a no-arg factory method for creating an instance of this class. The default is this class.

        If factoryClass is DEFAULT.class and factoryMethod is "", then there is no static factory method.

        If factoryClass is DEFAULT.class and factoryMethod is not "", then factoryMethod is the name of a static factory method in this class.

        If factoryClass is not DEFAULT.class, then factoryMethod must not be "" and must be the name of a static factory method specified in factoryClass.

        Default:
        javax.xml.bind.annotation.XmlType.DEFAULT.class

      • factoryMethod

        public abstract String factoryMethod
        Name of a no-arg factory method in the class specified in factoryClass factoryClass().
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>=acbtrbc>d


XmlType.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation

类 XmlType.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.XmlType.DEFAULT
  • 封闭类：
    XmlType

    public static final class XmlType.DEFAULT
extends Object
    Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlType.DEFAULT()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlType.DEFAULT

        public XmlType.DEFAULT()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>l/./r/./...i/=chl�/g-rca///f.蔯


XmlValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation

Annotation Type XmlValue

  • @Retention(value=RUNTIME)
@Target(value={字段,方法})
public @interface XmlValue

    Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

    Usage:

    The @XmlValue annotation can be used with the following program elements:

    • a JavaBean property.
    • non static, non transient field.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    The usage is subject to the following usage constraints:
    • At most one field or property can be annotated with the @XmlValue annotation.
    • @XmlValue can be used with the following annotations: XmlList. However this is redundant since XmlList maps a type to a simple schema type that derives by list just as XmlValue would.
    • If the type of the field or property is a collection type, then the collection item type must map to a simple schema type.
    • If the type of the field or property is not a collection type, then the type must map to a XML Schema simple type.

    If the annotated JavaBean property is the sole class member being mapped to XML Schema construct, then the class is mapped to a simple type. If there are additional JavaBean properties (other than the JavaBean property annotated with @XmlValue annotation) that are mapped to XML attributes, then the class is mapped to a complex type with simpleContent.

    Example 1: Map a class to XML Schema simpleType

     // Example 1: Code fragment
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example 1: XML Schema fragment -->
     <xs:simpleType name="USPrice">
       <xs:restriction base="xs:decimal"/>
     </xs:simpleType>

    Example 2: Map a class to XML Schema complexType with with simpleContent.

   // Example 2: Code fragment
   public class InternationalPrice {
       @XmlValue
       public java.math.BigDecimal price;

       @XmlAttribute
       public String currency;
   }

   <!-- Example 2: XML Schema fragment -->
   <xs:complexType name="InternationalPrice">
     <xs:simpleContent>
       <xs:extension base="xs:decimal">
         <xs:attribute name="currency" type="xs:string"/>
       </xs:extension>
     </xs:simpleContent>
   </xs:complexType>

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>fnoa ta gaa ggl bbt<


CollapsedStringAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.annotation.adapters

类 CollapsedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter

  • public class CollapsedStringAdapter
extends XmlAdapter<String,String>
    Built-in XmlAdapter to handle xs:token and its derived types.

    This adapter removes leading and trailing whitespaces, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

    从以下版本开始：
    JAXB 2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      CollapsedStringAdapter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected static boolean isWhiteSpace(char ch)
      returns true if the specified char is a white space character.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CollapsedStringAdapter

        public CollapsedStringAdapter()

    • 方法详细信息

      • unmarshal

        public String unmarshal(String text)
        Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.
        指定者：
        unmarshal in class XmlAdapter<String,String>
        参数：
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        指定者：
        marshal in class XmlAdapter<String,String>
        参数：
        s - The value to be convereted. Can be null.

      • isWhiteSpace

        protected static boolean isWhiteSpace(char ch)
        returns true if the specified char is a white space character.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

E/ >-鵨emgm_l"Ols


HexBinaryAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.annotation.adapters

类 HexBinaryAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,byte[]>
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter

  • public final class HexBinaryAdapter
extends XmlAdapter<String,byte[]>
    XmlAdapter for xs:hexBinary.

    This XmlAdapter binds byte[] to the hexBinary representation in XML.

    从以下版本开始：
    JAXB 2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      HexBinaryAdapter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String marshal(byte[] bytes)
      Convert a bound type to a value type.
      byte[] unmarshal(String s)
      Convert a value type to a bound type.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HexBinaryAdapter

        public HexBinaryAdapter()

    • 方法详细信息

      • unmarshal

        public byte[] unmarshal(String s)
        Description copied from class: XmlAdapter
        Convert a value type to a bound type.
        指定者：
        unmarshal in class XmlAdapter<String,byte[]>
        参数：
        s - The value to be converted. Can be null.

      • marshal

        public String marshal(byte[] bytes)
        Description copied from class: XmlAdapter
        Convert a bound type to a value type.
        指定者：
        marshal in class XmlAdapter<String,byte[]>
        参数：
        bytes - The value to be convereted. Can be null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

it>slsaslsb;spi>>mi


javax.xml.bind.annotation.adapters

Classes

  • CollapsedStringAdapter
  • HexBinaryAdapter
  • NormalizedStringAdapter
  • XmlAdapter
  • XmlJavaTypeAdapter.DEFAULT

Annotation Types

  • XmlJavaTypeAdapter
  • XmlJavaTypeAdapters
1


javax.xml.bind.annotation.adapters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind.annotation.adapters

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

请参见： 描述

  • Class Summary
    类 描述
    CollapsedStringAdapter
    Built-in XmlAdapter to handle xs:token and its derived types.
    HexBinaryAdapter
    XmlAdapter for xs:hexBinary.
    NormalizedStringAdapter
    XmlAdapter to handle xs:normalizedString.
    XmlAdapter<ValueType,BoundType>
    Adapts a Java type for custom marshaling.
    XmlJavaTypeAdapter.DEFAULT
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.
  • Annotation Types Summary
    Annotation Type 描述
    XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.
    XmlJavaTypeAdapters
    A container for multiple @XmlJavaTypeAdapter annotations.

软件包 javax.xml.bind.annotation.adapters Description

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntagn.rxmajvxxaalllreotans


javax.xml.bind.annotation.adapters Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind.annotation.adapters

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

Annotation Type Hierarchy

  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

as-susbbb essnat.oi


NormalizedStringAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.annotation.adapters

类 NormalizedStringAdapter

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter

  • public final class NormalizedStringAdapter
extends XmlAdapter<String,String>
    XmlAdapter to handle xs:normalizedString.

    This adapter removes leading and trailing whitespaces, then replace any tab, CR, and LF by a whitespace character ' '.

    从以下版本开始：
    JAXB 2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      NormalizedStringAdapter()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected static boolean isWhiteSpaceExceptSpace(char ch)
      Returns true if the specified char is a white space character but not 0x20.
      String marshal(String s)
      No-op.
      String unmarshal(String text)
      Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NormalizedStringAdapter

        public NormalizedStringAdapter()

    • 方法详细信息

      • unmarshal

        public String unmarshal(String text)
        Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'
        指定者：
        unmarshal in class XmlAdapter<String,String>
        参数：
        text - The value to be converted. Can be null.

      • marshal

        public String marshal(String s)
        No-op. Just return the same string given as the parameter.
        指定者：
        marshal in class XmlAdapter<String,String>
        参数：
        s - The value to be convereted. Can be null.

      • isWhiteSpaceExceptSpace

        protected static boolean isWhiteSpaceExceptSpace(char ch)
        Returns true if the specified char is a white space character but not 0x20.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mcr dFdatraro dane� e<比r雹宵>a/i /


Uses of Package javax.xml.bind.annotation.adapters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind.annotation.adapters

  • Packages that use javax.xml.bind.annotation.adapters
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind
    类与描述
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.annotation.adapters
    类与描述
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • Classes in javax.xml.bind.annotation.adapters used by javax.xml.bind.helpers
    类与描述
    XmlAdapter
    Adapts a Java type for custom marshaling.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.>/bdM.cnb/>t


XmlAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.annotation.adapters

类 XmlAdapter<ValueType,BoundType>

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
  • 类型参数：
    BoundType - The type that JAXB doesn't know how to handle. An adapter is written to allow this type to be used as an in-memory representation through the ValueType.
    ValueType - The type that JAXB knows how to handle out of the box.
    直接已知子类：
    CollapsedStringAdapter, HexBinaryAdapter, NormalizedStringAdapter

    public abstract class XmlAdapter<ValueType,BoundType>
extends Object
    Adapts a Java type for custom marshaling.

    Usage:

    Some Java types do not map naturally to a XML representation, for example HashMap or other non JavaBean classes. Conversely, a XML repsentation may map to a Java type but an application may choose to accesss the XML representation using another Java type. For example, the schema to Java binding rules bind xs:DateTime by default to XmlGregorianCalendar. But an application may desire to bind xs:DateTime to a custom type, MyXmlGregorianCalendar, for example. In both cases, there is a mismatch between bound type , used by an application to access XML content and the value type, that is mapped to an XML representation.

    This abstract class defines methods for adapting a bound type to a value type or vice versa. The methods are invoked by the JAXB binding framework during marshaling and unmarshalling:

    • XmlAdapter.marshal(...): During marshalling, JAXB binding framework invokes XmlAdapter.marshal(..) to adapt a bound type to value type, which is then marshaled to XML representation.
    • XmlAdapter.unmarshal(...): During unmarshalling, JAXB binding framework first unmarshals XML representation to a value type and then invokes XmlAdapter.unmarshal(..) to adapt the value type to a bound type.
    Writing an adapter therefore involves the following steps:
    • Write an adapter that implements this abstract class.
    • Install the adapter using the annotation XmlJavaTypeAdapter

    Example: Customized mapping of HashMap

    The following example illustrates the use of @XmlAdapter and @XmlJavaTypeAdapter to customize the mapping of a HashMap.

    Step 1: Determine the desired XML representation for HashMap.

         <hashmap>
         <entry key="id123">this is a value</entry>
         <entry key="id312">this is another value</entry>
         ...
       </hashmap>

    Step 2: Determine the schema definition that the desired XML representation shown above should follow.

     <xs:complexType name="myHashMapType">
       <xs:sequence>
         <xs:element name="entry" type="myHashMapEntryType"
                        minOccurs = "0" maxOccurs="unbounded"/>
       </xs:sequence>
     </xs:complexType>

     <xs:complexType name="myHashMapEntryType">
       <xs:simpleContent>
         <xs:extension base="xs:string">
           <xs:attribute name="key" type="xs:int"/>
         </xs:extension>
       </xs:simpleContent>
     </xs:complexType>

    Step 3: Write value types that can generate the above schema definition.

         public class MyHashMapType {
         List<MyHashMapEntryType> entry;
     }

     public class MyHashMapEntryType {
         @XmlAttribute
         public Integer key;

         @XmlValue
         public String value;
     }

    Step 4: Write the adapter that adapts the value type, MyHashMapType to a bound type, HashMap, used by the application.

         public final class MyHashMapAdapter extends
                        XmlAdapter<MyHashMapType,HashMap> { ... }

    Step 5: Use the adapter.

         public class Foo {
         @XmlJavaTypeAdapter(MyHashMapAdapter.class)
         HashMap hashmap;
         ...
     }
    The above code fragment will map to the following schema:
         <xs:complexType name="Foo">
       <xs:sequence>
         <xs:element name="hashmap" type="myHashMapType"
       </xs:sequence>
     </xs:complexType>
    从以下版本开始：
    JAXB 2.0
    另请参见：
    XmlJavaTypeAdapter

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected XmlAdapter()
      Do-nothing constructor for the derived classes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract ValueType marshal(BoundType v)
      Convert a bound type to a value type.
      abstract BoundType unmarshal(ValueType v)
      Convert a value type to a bound type.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlAdapter

        protected XmlAdapter()
        Do-nothing constructor for the derived classes.

    • 方法详细信息

      • unmarshal

        public abstract BoundType unmarshal(ValueType v)
                             throws Exception
        Convert a value type to a bound type.
        参数：
        v - The value to be converted. Can be null.
        抛出：
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.

      • marshal

        public abstract ValueType marshal(BoundType v)
                           throws Exception
        Convert a bound type to a value type.
        参数：
        v - The value to be convereted. Can be null.
        抛出：
        Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ol t np� jI s


XmlJavaTypeAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapter

  • @Retention(value=RUNTIME)
@Target(value={软件包,字段,方法,TYPE,PARAMETER})
public @interface XmlJavaTypeAdapter
    Use an adapter that implements XmlAdapter for custom marshaling.

    Usage:

    The @XmlJavaTypeAdapter annotation can be used with the following program elements:

    • a JavaBean property
    • field
    • parameter
    • package
    • from within XmlJavaTypeAdapters

    When @XmlJavaTypeAdapter annotation is defined on a class, it applies to all references to the class.

    When @XmlJavaTypeAdapter annotation is defined at the package level it applies to all references from within the package to @XmlJavaTypeAdapter.type().

    When @XmlJavaTypeAdapter annotation is defined on the field, property or parameter, then the annotation applies to the field, property or the parameter only.

    A @XmlJavaTypeAdapter annotation on a field, property or parameter overrides the @XmlJavaTypeAdapter annotation associated with the class being referenced by the field, property or parameter.

    A @XmlJavaTypeAdapter annotation on a class overrides the @XmlJavaTypeAdapter annotation specified at the package level for that class.

    This annotation can be used with the following other annotations: XmlElement, XmlAttribute, XmlElementRef, XmlElementRefs, XmlAnyElement. This can also be used at the package level with the following annotations: XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes.

    Example: See example in XmlAdapter

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlAdapter

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      类<? extends XmlAdapter> value
      Points to the clsss that converts a value type to a bound type or vice versa.

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      类 type
      If this annotation is used at the package level, then value of the type() must be specified.

    • Element Detail

      • value

        public abstract 类<? extends XmlAdapter> value
        Points to the clsss that converts a value type to a bound type or vice versa. See XmlAdapter for more details.

      • type

        public abstract 类 type
        If this annotation is used at the package level, then value of the type() must be specified.
        Default:
        javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT.class
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=> >� oopii7.tdta>


XmlJavaTypeAdapter.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.annotation.adapters

类 XmlJavaTypeAdapter.DEFAULT

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
  • 封闭类：
    XmlJavaTypeAdapter

    public static final class XmlJavaTypeAdapter.DEFAULT
extends Object
    Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XmlJavaTypeAdapter.DEFAULT()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XmlJavaTypeAdapter.DEFAULT

        public XmlJavaTypeAdapter.DEFAULT()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

luics"c="c llc >=MMcesc/<


XmlJavaTypeAdapters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.bind.annotation.adapters

Annotation Type XmlJavaTypeAdapters

  • @Retention(value=RUNTIME)
@Target(value=软件包)
public @interface XmlJavaTypeAdapters

    A container for multiple @XmlJavaTypeAdapter annotations.

    Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlJavaTypeAdapter as follows:

     @XmlJavaTypeAdapters ({ @XmlJavaTypeAdapter(...),@XmlJavaTypeAdapter(...) })

    The @XmlJavaTypeAdapters annnotation is useful for defining XmlJavaTypeAdapter annotations for different types at the package level.

    See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

    从以下版本开始：
    JAXB2.0
    另请参见：
    XmlJavaTypeAdapter

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      XmlJavaTypeAdapter[] value
      Collection of @XmlJavaTypeAdapter annotations

    • Element Detail

      • value

        public abstract XmlJavaTypeAdapter[] value
        Collection of @XmlJavaTypeAdapter annotations
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v">iess ssuttsuue eeecbse


Uses of Class javax.xml.bind.annotation.adapters.CollapsedStringAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.CollapsedStringAdapter

No usage of javax.xml.bind.annotation.adapters.CollapsedStringAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.bind.annotation.adapters.HexBinaryAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.HexBinaryAdapter

No usage of javax.xml.bind.annotation.adapters.HexBinaryAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&\a癰bl


Uses of Class javax.xml.bind.annotation.adapters.NormalizedStringAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.NormalizedStringAdapter

No usage of javax.xml.bind.annotation.adapters.NormalizedStringAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" .=sdLCilon>talt


Uses of Class javax.xml.bind.annotation.adapters.XmlAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.XmlAdapter

  • Packages that use XmlAdapter
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation.adapters
    XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of XmlAdapter in javax.xml.bind

      Methods in javax.xml.bind with type parameters of type XmlAdapter
      修饰符与类型 方法与描述
      <A extends XmlAdapter>
      A             		Unmarshaller.getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      A             		Marshaller.getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      <A extends XmlAdapter>
      void             		Unmarshaller.setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      <A extends XmlAdapter>
      void             		Marshaller.setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      Methods in javax.xml.bind with parameters of type XmlAdapter
      修饰符与类型 方法与描述
      void Unmarshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void Marshaller.setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.

    • Uses of XmlAdapter in javax.xml.bind.annotation.adapters

      Subclasses of XmlAdapter in javax.xml.bind.annotation.adapters
      修饰符与类型 类与描述
      class  CollapsedStringAdapter
      Built-in XmlAdapter to handle xs:token and its derived types.
      class  HexBinaryAdapter
      XmlAdapter for xs:hexBinary.
      class  NormalizedStringAdapter
      XmlAdapter to handle xs:normalizedString.

    • Uses of XmlAdapter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with type parameters of type XmlAdapter
      修饰符与类型 方法与描述
      <A extends XmlAdapter>
      A             		AbstractUnmarshallerImpl.getAdapter(类<A> type)
      <A extends XmlAdapter>
      A             		AbstractMarshallerImpl.getAdapter(类<A> type)
      <A extends XmlAdapter>
      void             		AbstractUnmarshallerImpl.setAdapter(类<A> type, A adapter)
      <A extends XmlAdapter>
      void             		AbstractMarshallerImpl.setAdapter(类<A> type, A adapter)
      Methods in javax.xml.bind.helpers with parameters of type XmlAdapter
      修饰符与类型 | 方法与描述
      void | AbstractUnmarshallerImpl.setAdapter(XmlAdapter adapter)
      void | AbstractMarshallerImpl.setAdapter(XmlAdapter adapter)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snh "mam/ >(荅sct=.糹


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..obo><>tb>tg�r輙<


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tea.ax. njjjslee."..r


Uses of Class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters

No usage of javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!a\4.d ca:?<�nv


Uses of Class javax.xml.bind.annotation.W3CDomHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.W3CDomHandler

No usage of javax.xml.bind.annotation.W3CDomHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> > ove


Uses of Class javax.xml.bind.annotation.XmlAccessOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAccessOrder

  • Packages that use XmlAccessOrder
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessOrder in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessOrder
      修饰符与类型 方法与描述
      static XmlAccessOrder XmlAccessOrder.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessOrder[] XmlAccessOrder.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s-e/bsrkj."=e/t/-lO-tba-i


Uses of Class javax.xml.bind.annotation.XmlAccessorOrder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAccessorOrder

No usage of javax.xml.bind.annotation.XmlAccessorOrder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/xt[er


Uses of Class javax.xml.bind.annotation.XmlAccessorType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAccessorType

No usage of javax.xml.bind.annotation.XmlAccessorType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>s�/t>[>lx[


Uses of Class javax.xml.bind.annotation.XmlAccessType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAccessType

  • Packages that use XmlAccessType
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlAccessType in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlAccessType
      修饰符与类型 方法与描述
      static XmlAccessType XmlAccessType.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlAccessType[] XmlAccessType.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/jl /e>..n.e ls lb>l/


Uses of Class javax.xml.bind.annotation.XmlAnyAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAnyAttribute

No usage of javax.xml.bind.annotation.XmlAnyAttribute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dc>>>pAoonnsmt


Uses of Class javax.xml.bind.annotation.XmlAnyElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAnyElement

No usage of javax.xml.bind.annotation.XmlAnyElement
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Class javax.xml.bind.annotation.XmlAttachmentRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAttachmentRef

No usage of javax.xml.bind.annotation.XmlAttachmentRef
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>su>2uixXt Ftnfl<


Uses of Class javax.xml.bind.annotation.XmlAttribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlAttribute

No usage of javax.xml.bind.annotation.XmlAttribute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-"motsn>sl><<>g/s


Uses of Class javax.xml.bind.annotation.XmlElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElement

No usage of javax.xml.bind.annotation.XmlElement
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>obo><>tb>tg�< >r輙<


Uses of Class javax.xml.bind.annotation.XmlElement.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElement.DEFAULT

No usage of javax.xml.bind.annotation.XmlElement.DEFAULT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i//. sh� *ho


Uses of Class javax.xml.bind.annotation.XmlElementDecl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementDecl

No usage of javax.xml.bind.annotation.XmlElementDecl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rnbDrgFgn舶n;1�e�-n-


Uses of Class javax.xml.bind.annotation.XmlElementDecl.GLOBAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementDecl.GLOBAL

No usage of javax.xml.bind.annotation.XmlElementDecl.GLOBAL
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lm>-ertn>./1" apbvis


Uses of Class javax.xml.bind.annotation.XmlElementRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementRef

No usage of javax.xml.bind.annotation.XmlElementRef
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

."obo><>tb>tg�<>r輙<


Uses of Class javax.xml.bind.annotation.XmlElementRef.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementRef.DEFAULT

No usage of javax.xml.bind.annotation.XmlElementRef.DEFAULT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ole SchTc0a>o.ah=bn


Uses of Class javax.xml.bind.annotation.XmlElementRefs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementRefs

No usage of javax.xml.bind.annotation.XmlElementRefs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>淪&d1/e �ao


Uses of Class javax.xml.bind.annotation.XmlElements

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElements

No usage of javax.xml.bind.annotation.XmlElements
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ni/>slplaty/


Uses of Class javax.xml.bind.annotation.XmlElementWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlElementWrapper

No usage of javax.xml.bind.annotation.XmlElementWrapper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s "


Uses of Class javax.xml.bind.annotation.XmlEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlEnum

No usage of javax.xml.bind.annotation.XmlEnum
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a —间讳篇嗽冰籶Ｃ粼3


Uses of Class javax.xml.bind.annotation.XmlEnumValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlEnumValue

No usage of javax.xml.bind.annotation.XmlEnumValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i;-anosNm/h齞t


Uses of Class javax.xml.bind.annotation.XmlID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlID

No usage of javax.xml.bind.annotation.XmlID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nrnr&sN�>皉/


Uses of Class javax.xml.bind.annotation.XmlIDREF

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlIDREF

No usage of javax.xml.bind.annotation.XmlIDREF
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eg>=il>y�.<.-/<


Uses of Class javax.xml.bind.annotation.XmlInlineBinaryData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlInlineBinaryData

No usage of javax.xml.bind.annotation.XmlInlineBinaryData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


Uses of Class javax.xml.bind.annotation.XmlList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlList

No usage of javax.xml.bind.annotation.XmlList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1991 1 9,0 l 1O3a0s


Uses of Class javax.xml.bind.annotation.XmlMimeType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlMimeType

No usage of javax.xml.bind.annotation.XmlMimeType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>at._o.ln&�


Uses of Class javax.xml.bind.annotation.XmlMixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlMixed

No usage of javax.xml.bind.annotation.XmlMixed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

na/>slplay/


Uses of Class javax.xml.bind.annotation.XmlNs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlNs

No usage of javax.xml.bind.annotation.XmlNs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n//>slpla3y/ <�


Uses of Class javax.xml.bind.annotation.XmlNsForm

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlNsForm

  • Packages that use XmlNsForm
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of XmlNsForm in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return XmlNsForm
      修饰符与类型 方法与描述
      static XmlNsForm XmlNsForm.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static XmlNsForm[] XmlNsForm.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.tse a=aoit p.e


Uses of Class javax.xml.bind.annotation.XmlRegistry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlRegistry

No usage of javax.xml.bind.annotation.XmlRegistry
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r"o >


Uses of Class javax.xml.bind.annotation.XmlRootElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlRootElement

  • Packages that use XmlRootElement
    软件包 描述
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlRootElement in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlRootElement
      修饰符与类型 类与描述
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ax t ..mca iuo"s:rse/c#


Uses of Class javax.xml.bind.annotation.XmlSchema

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlSchema

No usage of javax.xml.bind.annotation.XmlSchema
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tut" naa/>>>"okkva--p


Uses of Class javax.xml.bind.annotation.XmlSchemaType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlSchemaType

No usage of javax.xml.bind.annotation.XmlSchemaType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.iobo><>tb>tg�r輙<


Uses of Class javax.xml.bind.annotation.XmlSchemaType.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlSchemaType.DEFAULT

No usage of javax.xml.bind.annotation.XmlSchemaType.DEFAULT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>dRera//.t� so n


Uses of Class javax.xml.bind.annotation.XmlSchemaTypes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlSchemaTypes

No usage of javax.xml.bind.annotation.XmlSchemaTypes
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ai9�-E<n ri�s


Uses of Class javax.xml.bind.annotation.XmlSeeAlso

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlSeeAlso

No usage of javax.xml.bind.annotation.XmlSeeAlso
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-hmotsn>sl><<>g/s|


Uses of Class javax.xml.bind.annotation.XmlTransient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlTransient

  • Packages that use XmlTransient
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of XmlTransient in javax.xml.ws

      Classes in javax.xml.ws with annotations of type XmlTransient
      修饰符与类型 类与描述
      class  EndpointReference
      This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ie


Uses of Class javax.xml.bind.annotation.XmlType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlType

  • Packages that use XmlType
    软件包 描述
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of XmlType in javax.xml.ws.wsaddressing

      Classes in javax.xml.ws.wsaddressing with annotations of type XmlType
      修饰符与类型 类与描述
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e�=c s1&mat/lxn.薬t


Uses of Class javax.xml.bind.annotation.XmlType.DEFAULT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlType.DEFAULT

No usage of javax.xml.bind.annotation.XmlType.DEFAULT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"aattmlnetttnnnnma/�/


Uses of Class javax.xml.bind.annotation.XmlValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.annotation.XmlValue

No usage of javax.xml.bind.annotation.XmlValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ratiaNvvvesccnvnna


Uses of Interface javax.xml.bind.annotation.DomHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.annotation.DomHandler

  • Packages that use DomHandler
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.

    • Uses of DomHandler in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation that implement DomHandler
      修饰符与类型 类与描述
      class  W3CDomHandler
      DomHandler implementation for W3C DOM (org.w3c.dom package.)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rr apiar.i"r


AttachmentMarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.attachment

类 AttachmentMarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller

  • public abstract class AttachmentMarshaller
extends Object

    Enable JAXB marshalling to optimize storage of binary data.

    This API enables an efficient cooperative creation of optimized binary data formats between a JAXB marshalling process and a MIME-based package processor. A JAXB implementation marshals the root body of a MIME-based package, delegating the creation of referenceable MIME parts to the MIME-based package processor that implements this abstraction.

    XOP processing is enabled when isXOPPackage() is true. See addMtomAttachment(DataHandler, String, String) for details.

    WS-I Attachment Profile 1.0 is supported by addSwaRefAttachment(DataHandler) being called by the marshaller for each JAXB property related to {http://ws-i.org/profiles/basic/1.1/xsd}swaRef.

    从以下版本开始：
    JAXB 2.0
    另请参见：
    Marshaller.setAttachmentMarshaller(AttachmentMarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttachmentMarshaller()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
      Consider binary data for optimized binary storage as an attachment.
      abstract String addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
      Consider MIME content data for optimized binary storage as an attachment.
      abstract String addSwaRefAttachment(DataHandler data)
      Add MIME data as an attachment and return attachment's content-id, cid.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB marshaller should enable XOP creation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttachmentMarshaller

        public AttachmentMarshaller()

    • 方法详细信息

      • addMtomAttachment

        public abstract String addMtomAttachment(DataHandler data,
                       String elementNamespace,
                       String elementLocalName)

        Consider MIME content data for optimized binary storage as an attachment.

        This method is called by JAXB marshal process when isXOPPackage() is true, for each element whose datatype is "base64Binary", as described in Step 3 in Creating XOP Packages.

        The method implementor determines whether data shall be attached separately or inlined as base64Binary data. If the implementation chooses to optimize the storage of the binary data as a MIME part, it is responsible for attaching data to the MIME-based package, and then assigning an unique content-id, cid, that identifies the MIME part within the MIME message. This method returns the cid, which enables the JAXB marshaller to marshal a XOP element that refers to that cid in place of marshalling the binary data. When the method returns null, the JAXB marshaller inlines data as base64binary data.

        The caller of this method is required to meet the following constraint. If the element infoset item containing data has the attribute xmime:contentType or if the JAXB property/field representing datais annotated with a known MIME type, data.getContentType() should be set to that MIME type.

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        参数：
        data - represents the data to be attached. Must be non-null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        返回：
        a valid content-id URI (see RFC 2387) that identifies the attachment containing data. Otherwise, null if the attachment was not added and should instead be inlined in the message.
        另请参见：
        XML-binary Optimized Packaging, Describing Media Content of Binary Data in XML

      • addMtomAttachment

        public abstract String addMtomAttachment(byte[] data,
                       int offset,
                       int length,
                       String mimeType,
                       String elementNamespace,
                       String elementLocalName)

        Consider binary data for optimized binary storage as an attachment.

        Since content type is not known, the attachment's MIME content type must be set to "application/octet-stream".

        The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

        参数：
        data - represents the data to be attached. Must be non-null. The actual data region is specified by (data,offset,length) tuple.
        offset - The offset within the array of the first byte to be read; must be non-negative and no larger than array.length
        length - The number of bytes to be read from the given array; must be non-negative and no larger than array.length
        mimeType - If the data has an associated MIME type known to JAXB, that is passed as this parameter. If none is known, "application/octet-stream". This parameter may never be null.
        elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
        elementLocalName - The local name of the element. Always a non-null valid string.
        返回：
        content-id URI, cid, to the attachment containing data or null if data should be inlined.
        另请参见：
        addMtomAttachment(DataHandler, String, String)

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB marshaller should enable XOP creation.

        This value must not change during the marshalling process. When this value is true, the addMtomAttachment(...) method is invoked when the appropriate binary datatypes are encountered by the marshal process.

        Marshaller.marshal() must throw IllegalStateException if this value is true and the XML content to be marshalled violates Step 1 in Creating XOP Pacakges http://www.w3.org/TR/2005/REC-xop10-20050125/#creating_xop_packages. "Ensure the Original XML Infoset contains no element information item with a [namespace name] of "http://www.w3.org/2004/08/xop/include" and a [local name] of Include"

        When this method returns true and during the marshal process at least one call to addMtomAttachment(...) returns a content-id, the MIME-based package processor must label the root part with the application/xop+xml media type as described in Step 5 of Creating XOP Pacakges.

        返回：
        true when MIME context is a XOP Package.

      • addSwaRefAttachment

        public abstract String addSwaRefAttachment(DataHandler data)

        Add MIME data as an attachment and return attachment's content-id, cid.

        This method is called by JAXB marshal process for each element/attribute typed as {http://ws-i.org/profiles/basic/1.1/xsd}swaRef. The MIME-based package processor implementing this method is responsible for attaching the specified data to a MIME attachment, and generating a content-id, cid, that uniquely identifies the attachment within the MIME-based package.

        Caller inserts the returned content-id, cid, into the XML content being marshalled.

        参数：
        data - represents the data to be attached. Must be non-null.
        返回：
        must be a valid URI used as cid. Must satisfy Conformance Requirement R2928 from WS-I Attachments Profile Version 1.0.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ae=/rlaf


AttachmentUnmarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.attachment

类 AttachmentUnmarshaller

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentUnmarshaller

  • public abstract class AttachmentUnmarshaller
extends Object

    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

    This API enables an efficient cooperative processing of optimized binary data formats between a JAXB 2.0 implementation and MIME-based package processor (MTOM/XOP and WS-I AP 1.0). JAXB unmarshals the body of a package, delegating the understanding of the packaging format being used to a MIME-based package processor that implements this abstract class.

    This abstract class identifies if a package requires XOP processing, isXOPPackage() and provides retrieval of binary content stored as attachments by content-id.

    Identifying the content-id, cid, to pass to getAttachment*(String cid)

    • For XOP processing, the infoset representation of the cid is described in step 2a in Section 3.2 Interpreting XOP Packages
    • For WS-I AP 1.0, the cid is identified as an element or attribute of type ref:swaRef specified in Section 4.4 Referencing Attachments from the SOAP Envelope
    从以下版本开始：
    JAXB 2.0
    另请参见：
    Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0., Describing Media Content of Binary Data in XML

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttachmentUnmarshaller()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract byte[] getAttachmentAsByteArray(String cid)
      Retrieve the attachment identified by content-id, cid, as a byte[]
      abstract DataHandler getAttachmentAsDataHandler(String cid)
      Lookup MIME content by content-id, cid, and return as a DataHandler.
      boolean isXOPPackage()
      Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttachmentUnmarshaller

        public AttachmentUnmarshaller()

    • 方法详细信息

      • getAttachmentAsDataHandler

        public abstract DataHandler getAttachmentAsDataHandler(String cid)

        Lookup MIME content by content-id, cid, and return as a DataHandler.

        The returned DataHandler instance must be configured to meet the following required mapping constaint.

        Required Mappings between MIME and Java Types
        MIME Type | Java Type
        DataHandler.getContentType() | instanceof DataHandler.getContent()
        image/gif | java.awt.Image
        image/jpeg | java.awt.Image
        text/xml or application/xml | javax.xml.transform.Source
        Note that it is allowable to support additional mappings.

        参数：
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        返回：
        a DataHandler that represents the MIME attachment.
        抛出：
        IllegalArgumentException - if the attachment for the given cid is not found.

      • getAttachmentAsByteArray

        public abstract byte[] getAttachmentAsByteArray(String cid)

        Retrieve the attachment identified by content-id, cid, as a byte[]

        .
        参数：
        cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
        返回：
        byte[] representation of attachment identified by cid.
        抛出：
        IllegalArgumentException - if the attachment for the given cid is not found.

      • isXOPPackage

        public boolean isXOPPackage()

        Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

        This method returns true when the constraints specified in Identifying XOP Documents are met. This value must not change during the unmarshalling process.

        返回：
        true when MIME context is a XOP Document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n nsa ha eme eennmm riu eesiJrAs h nJlB


javax.xml.bind.attachment

Classes

  • AttachmentMarshaller
  • AttachmentUnmarshaller
e


javax.xml.bind.attachment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind.attachment

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

请参见： 描述

  • Class Summary
    类 描述
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.

软件包 javax.xml.bind.attachment Description

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

Soap MTOM[1], XOP([2][3]) and WS-I AP[4] standardize approaches to optimized transmission of binary datatypes as an attachment. To optimally support these standards within a message passing environment, this package enables an integrated solution between a MIME-based package processor and JAXB unmarshall/marshal processes.

Package Specification

  • JAXB Specification

Related Standards

  • [1]SOAP Message Transmission Optimization Mechanism
  • [2]XML-binary Optimized Packaging
  • [3]WS-I Attachments Profile Version 1.0.
  • [4]Describing Media Content of Binary Data in XML
从以下版本开始：
JAXB 2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aajcat.aHAtsaaAtrrbtcand/x


javax.xml.bind.attachment Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind.attachment

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.bind.attachment.AttachmentUnmarshaller
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Naasdc ><<< RBB觧嚎�-


Uses of Package javax.xml.bind.attachment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind.attachment

  • Packages that use javax.xml.bind.attachment
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind
    类与描述
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
  • Classes in javax.xml.bind.attachment used by javax.xml.bind.helpers
    类与描述
    AttachmentMarshaller
    Enable JAXB marshalling to optimize storage of binary data.
    AttachmentUnmarshaller
    Enables JAXB unmarshalling of a root document containing optimized binary data formats.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aam-3sdct/rrrrt/rn�


Uses of Class javax.xml.bind.attachment.AttachmentMarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.attachment.AttachmentMarshaller

  • Packages that use AttachmentMarshaller
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentMarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentMarshaller
      修饰符与类型 | 方法与描述
      AttachmentMarshaller | Marshaller.getAttachmentMarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentMarshaller
      修饰符与类型 方法与描述
      void Marshaller.setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.

    • Uses of AttachmentMarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentMarshaller
      修饰符与类型 | 方法与描述
      AttachmentMarshaller | AbstractMarshallerImpl.getAttachmentMarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentMarshaller
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.setAttachmentMarshaller(AttachmentMarshaller am)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>ex l_ol"


Uses of Class javax.xml.bind.attachment.AttachmentUnmarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.attachment.AttachmentUnmarshaller

  • Packages that use AttachmentUnmarshaller
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of AttachmentUnmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return AttachmentUnmarshaller
      修饰符与类型 | 方法与描述
      AttachmentUnmarshaller | Unmarshaller.getAttachmentUnmarshaller()
      Methods in javax.xml.bind with parameters of type AttachmentUnmarshaller
      修饰符与类型 方法与描述
      void Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

    • Uses of AttachmentUnmarshaller in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return AttachmentUnmarshaller
      修饰符与类型 | 方法与描述
      AttachmentUnmarshaller | AbstractUnmarshallerImpl.getAttachmentUnmarshaller()
      Methods in javax.xml.bind.helpers with parameters of type AttachmentUnmarshaller
      修饰符与类型 | 方法与描述
      void | AbstractUnmarshallerImpl.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eice k/a .n(.


Uses of Class javax.xml.bind.Binder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.Binder

  • Packages that use Binder
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Binder in javax.xml.bind

      Methods in javax.xml.bind that return Binder
      修饰符与类型 方法与描述
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      <T> Binder<T> JAXBContext.createBinder(类<T> domType)
      Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/Td.haso


Uses of Class javax.xml.bind.DataBindingException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.DataBindingException

No usage of javax.xml.bind.DataBindingException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

clod&nb&Tggglaaae>/"v


Uses of Class javax.xml.bind.DatatypeConverter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.DatatypeConverter

No usage of javax.xml.bind.DatatypeConverter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/>slplaby/


Uses of Class javax.xml.bind.JAXB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXB

No usage of javax.xml.bind.JAXB
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dn8;&s-sbe-3sgb tao3X


Uses of Class javax.xml.bind.JAXBContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBContext

  • Packages that use JAXBContext
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of JAXBContext in javax.xml.bind

      Methods in javax.xml.bind that return JAXBContext
      修饰符与类型 方法与描述
      static JAXBContext JAXBContext.newInstance(类... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(类[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.

    • Uses of JAXBContext in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type JAXBContext
      构造方法与描述
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.

    • Uses of JAXBContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type JAXBContext
      修饰符与类型 方法与描述
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Object LogicalMessage.getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void LogicalMessage.setPayload(Object payload, JAXBContext context)
      Sets the message payload

    • Uses of JAXBContext in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap with parameters of type JAXBContext
      修饰符与类型 方法与描述
      Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.

    • Uses of JAXBContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type JAXBContext
      修饰符与类型 方法与描述
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eSra->laiatti" cedr<�


Uses of Class javax.xml.bind.JAXBElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBElement

  • Packages that use JAXBElement
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of JAXBElement in javax.xml.bind

      Methods in javax.xml.bind that return JAXBElement
      修饰符与类型 方法与描述
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, 类<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, 类<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, 类<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of JAXBElement in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return JAXBElement
      修饰符与类型 | 方法与描述
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, 类<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, 类<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, 类<T> expectedType)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, 类<T> expectedType)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.emeptakWvv/re.xm


Uses of Class javax.xml.bind.JAXBElement.GlobalScope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBElement.GlobalScope

No usage of javax.xml.bind.JAXBElement.GlobalScope
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oitml"tx...ndaatl"cv


Uses of Class javax.xml.bind.JAXBException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBException

  • Packages that use JAXBException
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of JAXBException in javax.xml.bind

      Subclasses of JAXBException in javax.xml.bind
      修饰符与类型 类与描述
      class  MarshalException
      This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
      class  PropertyException
      This exception indicates that an error was encountered while getting or setting a property.
      class  UnmarshalException
      This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
      class  ValidationException
      This exception indicates that an error has occurred while performing a validate operation.
      Methods in javax.xml.bind that throw JAXBException
      修饰符与类型 方法与描述
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Object UnmarshallerHandler.getResult()
      Obtains the unmarshalled result.
      boolean Unmarshaller.isValidating()
      Deprecated.
      since JAXB2.0, please see Unmarshaller.getSchema()
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void Marshaller.marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void Marshaller.marshal(Object jaxbElement, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void Marshaller.marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      void Marshaller.marshal(Object jaxbElement, Writer writer)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      abstract void Binder.marshal(Object jaxbObject, XmlNode xmlNode)
      Marshal a JAXB object tree to a new XML document.
      void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      static JAXBContext JAXBContext.newInstance(类... classesToBeBound)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(类[] classesToBeBound, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
      Obtain a new instance of a JAXBContext class.
      static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
      Obtain a new instance of a JAXBContext class.
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Unmarshaller.setValidating(boolean validating)
      Deprecated.
      since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
      Object Unmarshaller.unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object Unmarshaller.unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, 类<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object Unmarshaller.unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, 类<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object Unmarshaller.unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object Unmarshaller.unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.unmarshal(XmlNode xmlNode)
      Unmarshal XML infoset view to a JAXB object tree.
      abstract <T> JAXBElement<T> Binder.unmarshal(XmlNode xmlNode, 类<T> declaredType)
      Unmarshal XML root element by provided declaredType to a JAXB object tree.
      Object Unmarshaller.unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      abstract Object Binder.updateJAXB(XmlNode xmlNode)
      Takes an XML node and updates its associated JAXB object and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject)
      Takes an JAXB object and updates its associated XML node and its descendants.
      abstract XmlNode Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
      Changes in JAXB object tree are updated in its associated XML parse tree.
      boolean Validator.validate(Object subrootObj)
      Deprecated.
      since JAXB2.0
      boolean Validator.validateRoot(Object rootObj)
      Deprecated.
      since JAXB2.0

    • Uses of JAXBException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw JAXBException
      修饰符与类型 | 方法与描述
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      boolean AbstractUnmarshallerImpl.isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)
      void | AbstractMarshallerImpl.marshal(Object jaxbElement, File output)
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void | AbstractMarshallerImpl.marshal(Object obj, OutputStream os)
      void | AbstractMarshallerImpl.marshal(Object obj, Writer w)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)
      void | AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
      void AbstractUnmarshallerImpl.setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object | AbstractUnmarshallerImpl.unmarshal(File f)
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      Object | AbstractUnmarshallerImpl.unmarshal(InputStream is)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, 类<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(Reader reader)
      Object | AbstractUnmarshallerImpl.unmarshal(Source source)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, 类<T> expectedType)
      Object | AbstractUnmarshallerImpl.unmarshal(URL url)
      Object | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, 类<T> expectedType)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, 类<T> expectedType)

    • Uses of JAXBException in javax.xml.bind.util

      Methods in javax.xml.bind.util that throw JAXBException
      修饰符与类型 方法与描述
      Object JAXBResult.getResult()
      Gets the unmarshalled object created by the transformation.
      Constructors in javax.xml.bind.util that throw JAXBException
      构造方法与描述
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.bind.JAXBIntrospector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBIntrospector

  • Packages that use JAXBIntrospector
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of JAXBIntrospector in javax.xml.bind

      Methods in javax.xml.bind that return JAXBIntrospector
      修饰符与类型 方法与描述
      JAXBIntrospector JAXBContext.createJAXBIntrospector()
      Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.bind.JAXBPermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.JAXBPermission

No usage of javax.xml.bind.JAXBPermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

><


Uses of Class javax.xml.bind.MarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.MarshalException

No usage of javax.xml.bind.MarshalException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sirususbcnrito>(8lfr


Uses of Class javax.xml.bind.Marshaller.Listener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.Marshaller.Listener

  • Packages that use Marshaller.Listener
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Marshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller.Listener
      修饰符与类型 方法与描述
      Marshaller.Listener Marshaller.getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Methods in javax.xml.bind with parameters of type Marshaller.Listener
      修饰符与类型 方法与描述
      void Marshaller.setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.

    • Uses of Marshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Marshaller.Listener
      修饰符与类型 | 方法与描述
      Marshaller.Listener | AbstractMarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Marshaller.Listener
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.setListener(Marshaller.Listener listener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hh"tb v vidnt.I.alitm膙


Uses of Class javax.xml.bind.PropertyException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.PropertyException

  • Packages that use PropertyException
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PropertyException in javax.xml.bind

      Methods in javax.xml.bind that throw PropertyException
      修饰符与类型 方法与描述
      Object Unmarshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Unmarshaller.
      Object Validator.getProperty(String name)
      Deprecated.
      since JAXB2.0
      Object Marshaller.getProperty(String name)
      Get the particular property in the underlying implementation of Marshaller.
      abstract Object Binder.getProperty(String name)
      Get the particular property in the underlying implementation of Binder.
      void Unmarshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Unmarshaller.
      void Validator.setProperty(String name, Object value)
      Deprecated.
      since JAXB2.0
      void Marshaller.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Marshaller.
      abstract void Binder.setProperty(String name, Object value)
      Set the particular property in the underlying implementation of Binder.

    • Uses of PropertyException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that throw PropertyException
      修饰符与类型 方法与描述
      Object AbstractUnmarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      Object AbstractMarshallerImpl.getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      void AbstractUnmarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
      void AbstractMarshallerImpl.setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ie/c=9vt#fgiolSm>//_B=


Uses of Class javax.xml.bind.SchemaOutputResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.SchemaOutputResolver

  • Packages that use SchemaOutputResolver
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of SchemaOutputResolver in javax.xml.bind

      Methods in javax.xml.bind with parameters of type SchemaOutputResolver
      修饰符与类型 方法与描述
      void JAXBContext.generateSchema(SchemaOutputResolver outputResolver)
      Generates the schema documents for this context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elt= cl< ddddl<<=.=


Uses of Class javax.xml.bind.TypeConstraintException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.TypeConstraintException

No usage of javax.xml.bind.TypeConstraintException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lmevss= lccc -ookia w


Uses of Class javax.xml.bind.UnmarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.UnmarshalException

  • Packages that use UnmarshalException
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of UnmarshalException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return UnmarshalException
      修饰符与类型 方法与描述
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"o ">wgaolltidd


Uses of Class javax.xml.bind.Unmarshaller.Listener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.Unmarshaller.Listener

  • Packages that use Unmarshaller.Listener
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of Unmarshaller.Listener in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller.Listener
      修饰符与类型 方法与描述
      Unmarshaller.Listener Unmarshaller.getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Methods in javax.xml.bind with parameters of type Unmarshaller.Listener
      修饰符与类型 方法与描述
      void Unmarshaller.setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

    • Uses of Unmarshaller.Listener in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Unmarshaller.Listener
      修饰符与类型 | 方法与描述
      Unmarshaller.Listener | AbstractUnmarshallerImpl.getListener()
      Methods in javax.xml.bind.helpers with parameters of type Unmarshaller.Listener
      修饰符与类型 | 方法与描述
      void | AbstractUnmarshallerImpl.setListener(Unmarshaller.Listener listener)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<> //= v a//i<觭o_ao"r <


Uses of Class javax.xml.bind.ValidationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.ValidationException

No usage of javax.xml.bind.ValidationException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cmae>Reolccc=i((iiet)


Uses of Interface javax.xml.bind.DatatypeConverterInterface

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.DatatypeConverterInterface

  • Packages that use DatatypeConverterInterface
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of DatatypeConverterInterface in javax.xml.bind

      Methods in javax.xml.bind with parameters of type DatatypeConverterInterface
      修饰符与类型 方法与描述
      static void DatatypeConverter.setDatatypeConverter(DatatypeConverterInterface converter)
      This method is for JAXB provider use only.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lsyrv<


Uses of Interface javax.xml.bind.Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.Element

No usage of javax.xml.bind.Element
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>l /onlu sssdXoo/ec&d


Uses of Interface javax.xml.bind.Marshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.Marshaller

  • Packages that use Marshaller
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Marshaller in javax.xml.bind

      Methods in javax.xml.bind that return Marshaller
      修饰符与类型 方法与描述
      abstract Marshaller JAXBContext.createMarshaller()
      Create a Marshaller object that can be used to convert a java content tree into XML data.

    • Uses of Marshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Marshaller
      修饰符与类型 类与描述
      class  AbstractMarshallerImpl
      Partial default Marshaller implementation.

    • Uses of Marshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Marshaller
      构造方法与描述
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/g"y aopsa g=e


Uses of Interface javax.xml.bind.NotIdentifiableEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.NotIdentifiableEvent

  • Packages that use NotIdentifiableEvent
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of NotIdentifiableEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement NotIdentifiableEvent
      修饰符与类型 类与描述
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


Uses of Interface javax.xml.bind.ParseConversionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.ParseConversionEvent

  • Packages that use ParseConversionEvent
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ParseConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ParseConversionEvent
      修饰符与类型 类与描述
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<lrPg豴iU�/�l.


Uses of Interface javax.xml.bind.PrintConversionEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.PrintConversionEvent

  • Packages that use PrintConversionEvent
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of PrintConversionEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement PrintConversionEvent
      修饰符与类型 类与描述
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c�tlr�g攸tU�.


Uses of Interface javax.xml.bind.Unmarshaller

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.Unmarshaller

  • Packages that use Unmarshaller
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of Unmarshaller in javax.xml.bind

      Methods in javax.xml.bind that return Unmarshaller
      修饰符与类型 方法与描述
      abstract Unmarshaller JAXBContext.createUnmarshaller()
      Create an Unmarshaller object that can be used to convert XML data into a java content tree.

    • Uses of Unmarshaller in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement Unmarshaller
      修饰符与类型 类与描述
      class  AbstractUnmarshallerImpl
      Partial default Unmarshaller implementation.

    • Uses of Unmarshaller in javax.xml.bind.util

      Constructors in javax.xml.bind.util with parameters of type Unmarshaller
      构造方法与描述
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b.


Uses of Interface javax.xml.bind.UnmarshallerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.UnmarshallerHandler

  • Packages that use UnmarshallerHandler
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of UnmarshallerHandler in javax.xml.bind

      Methods in javax.xml.bind that return UnmarshallerHandler
      修饰符与类型 方法与描述
      UnmarshallerHandler Unmarshaller.getUnmarshallerHandler()
      Get an unmarshaller handler object that can be used as a component in an XML pipeline.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irteLislleeesnjjthmjxdbx.


Uses of Interface javax.xml.bind.ValidationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.ValidationEvent

  • Packages that use ValidationEvent
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEvent in javax.xml.bind

      Subinterfaces of ValidationEvent in javax.xml.bind
      修饰符与类型 Interface and Description
      interface  NotIdentifiableEvent
      This event indicates that a problem was encountered resolving an ID/IDREF.
      interface  ParseConversionEvent
      This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
      interface  PrintConversionEvent
      This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
      Methods in javax.xml.bind with parameters of type ValidationEvent
      修饰符与类型 方法与描述
      boolean ValidationEventHandler.handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

    • Uses of ValidationEvent in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEvent
      修饰符与类型 类与描述
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
      class  ValidationEventImpl
      Default implementation of the ValidationEvent interface.
      Methods in javax.xml.bind.helpers with parameters of type ValidationEvent
      修饰符与类型 | 方法与描述
      boolean | DefaultValidationEventHandler.handleEvent(ValidationEvent event)

    • Uses of ValidationEvent in javax.xml.bind.util

      Methods in javax.xml.bind.util that return ValidationEvent
      修饰符与类型 方法与描述
      ValidationEvent[] ValidationEventCollector.getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      Methods in javax.xml.bind.util with parameters of type ValidationEvent
      修饰符与类型 | 方法与描述
      boolean | ValidationEventCollector.handleEvent(ValidationEvent event)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/t"" . sel.. >"c舉l


Uses of Interface javax.xml.bind.ValidationEventHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.ValidationEventHandler

  • Packages that use ValidationEventHandler
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of ValidationEventHandler in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventHandler
      修饰符与类型 方法与描述
      ValidationEventHandler Unmarshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler Validator.getEventHandler()
      Deprecated.
      since JAXB2.0
      ValidationEventHandler Marshaller.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      abstract ValidationEventHandler Binder.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Methods in javax.xml.bind with parameters of type ValidationEventHandler
      修饰符与类型 方法与描述
      void Unmarshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.
      void Validator.setEventHandler(ValidationEventHandler handler)
      Deprecated.
      since JAXB2.0
      void Marshaller.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      abstract void Binder.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a ValidationEventHandler.

    • Uses of ValidationEventHandler in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation with parameters of type ValidationEventHandler
      修饰符与类型 | 方法与描述
      DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      ResultT DomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
      Source DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of ValidationEventHandler in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventHandler
      修饰符与类型 类与描述
      class  DefaultValidationEventHandler
      JAXB 1.0 only default validation event handler.
      Methods in javax.xml.bind.helpers that return ValidationEventHandler
      修饰符与类型 | 方法与描述
      ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventHandler
      修饰符与类型 | 方法与描述
      void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)

    • Uses of ValidationEventHandler in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement ValidationEventHandler
      修饰符与类型 类与描述
      class  ValidationEventCollector
      ValidationEventHandler implementation that collects all events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i ll.o;.nd"oe. <="rvn


Uses of Interface javax.xml.bind.ValidationEventLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.ValidationEventLocator

  • Packages that use ValidationEventLocator
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventLocator in javax.xml.bind

      Methods in javax.xml.bind that return ValidationEventLocator
      修饰符与类型 方法与描述
      ValidationEventLocator ValidationEvent.getLocator()
      Retrieve the locator for this warning/error.

    • Uses of ValidationEventLocator in javax.xml.bind.helpers

      Classes in javax.xml.bind.helpers that implement ValidationEventLocator
      修饰符与类型 类与描述
      class  ValidationEventLocatorImpl
      Default implementation of the ValidationEventLocator interface.
      Methods in javax.xml.bind.helpers that return ValidationEventLocator
      修饰符与类型 | 方法与描述
      ValidationEventLocator | ValidationEventImpl.getLocator()
      Methods in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      修饰符与类型 方法与描述
      void ValidationEventImpl.setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      Constructors in javax.xml.bind.helpers with parameters of type ValidationEventLocator
      构造方法与描述
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>pmava./.../fttot.sc""an=n


Uses of Interface javax.xml.bind.Validator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.bind.Validator

  • Packages that use Validator
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

    • Uses of Validator in javax.xml.bind

      Methods in javax.xml.bind that return Validator
      修饰符与类型 方法与描述
      abstract Validator JAXBContext.createValidator()
      Deprecated.
      since JAXB2.0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eL nisattL>dt."tcdlo


AbstractMarshallerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.helpers

类 AbstractMarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl
  • 所有已实现的接口：
    Marshaller

    public abstract class AbstractMarshallerImpl
extends Object
implements Marshaller
    Partial default Marshaller implementation.

    This class provides a partial default implementation for the Marshaller interface.

    The only methods that a JAXB Provider has to implement are
marshal(Object, javax.xml.transform.Result),
marshal(Object, javax.xml.stream.XMLStreamWriter), and
marshal(Object, javax.xml.stream.XMLEventWriter).

    从以下版本开始：
    JAXB1.0
    另请参见：
    Marshaller

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.xml.bind.Marshaller

        Marshaller.Listener

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.Marshaller

        JAXB_ENCODING, JAXB_FORMATTED_OUTPUT, JAXB_FRAGMENT, JAXB_NO_NAMESPACE_SCHEMA_LOCATION, JAXB_SCHEMA_LOCATION

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractMarshallerImpl()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <A extends XmlAdapter>
      A             		getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      AttachmentMarshaller getAttachmentMarshaller()
      protected String getEncoding()
      Convenience method for getting the current output encoding.
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      protected String getJavaEncoding(String encoding)
      Gets the corresponding Java encoding name from an IANA name.
      Marshaller.Listener getListener()
      Return Marshaller.Listener registered with this Marshaller.
      Node getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      protected String getNoNSSchemaLocation()
      Convenience method for getting the current noNamespaceSchemaLocation.
      Object getProperty(String name)
      Default implementation of the getProperty method handles the four defined properties in Marshaller.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      protected String getSchemaLocation()
      Convenience method for getting the current schemaLocation.
      protected boolean isFormattedOutput()
      Convenience method for getting the formatted output flag.
      protected boolean isFragment()
      Convenience method for getting the fragment flag.
      void marshal(Object obj, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.
      void marshal(Object jaxbElement, File output)
      Marshal the content tree rooted at jaxbElement into a file.
      void marshal(Object obj, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      void marshal(Object obj, OutputStream os)
      Marshal the content tree rooted at jaxbElement into an output stream.
      void marshal(Object obj, Writer w)
      Marshal the content tree rooted at jaxbElement into a Writer.
      void marshal(Object obj, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
      void marshal(Object obj, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
      <A extends XmlAdapter>
      void             		setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this marshaller.
      void setAttachmentMarshaller(AttachmentMarshaller am)
      Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
      protected void setEncoding(String encoding)
      Convenience method for setting the output encoding.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      protected void setFormattedOutput(boolean v)
      Convenience method for setting the formatted output flag.
      protected void setFragment(boolean v)
      Convenience method for setting the fragment flag.
      void setListener(Marshaller.Listener listener)
      Register marshal event callback Marshaller.Listener with this Marshaller.
      protected void setNoNSSchemaLocation(String location)
      Convenience method for setting the noNamespaceSchemaLocation.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method handles the four defined properties in Marshaller.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
      protected void setSchemaLocation(String location)
      Convenience method for setting the schemaLocation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.bind.Marshaller

        marshal

    • 构造方法详细信息

      • AbstractMarshallerImpl

        public AbstractMarshallerImpl()

    • 方法详细信息

      • marshal

        public final void marshal(Object obj,
           OutputStream os)
                   throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into an output stream.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The root of content tree to be marshalled.
        os - XML will be added to this stream.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object jaxbElement,
           File output)
             throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into a file.
        指定者：
        marshal in interface Marshaller
        参数：
        jaxbElement - The root of content tree to be marshalled.
        output - File to be written. If this file already exists, it will be overwritten.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           Writer w)
                   throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into a Writer.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The root of content tree to be marshalled.
        w - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           ContentHandler handler)
                   throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into SAX2 events.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The root of content tree to be marshalled.
        handler - XML will be sent to this handler as SAX2 events.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public final void marshal(Object obj,
           Node node)
                   throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into a DOM tree.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The content tree to be marshalled.
        node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.

      • getNode

        public Node getNode(Object obj)
             throws JAXBException
        By default, the getNode method is unsupported and throw an UnsupportedOperationException. Implementations that choose to support this method must override this method.
        指定者：
        getNode in interface Marshaller
        参数：
        obj - - JAXB Java representation of XML content
        返回：
        the DOM tree view of the contentTree
        抛出：
        JAXBException - If any unexpected problem occurs

      • getEncoding

        protected String getEncoding()
        Convenience method for getting the current output encoding.
        返回：
        the current encoding or "UTF-8" if it hasn't been set.

      • setEncoding

        protected void setEncoding(String encoding)
        Convenience method for setting the output encoding.
        参数：
        encoding - a valid encoding as specified in the Marshaller class documentation

      • getSchemaLocation

        protected String getSchemaLocation()
        Convenience method for getting the current schemaLocation.
        返回：
        the current schemaLocation or null if it hasn't been set

      • setSchemaLocation

        protected void setSchemaLocation(String location)
        Convenience method for setting the schemaLocation.
        参数：
        location - the schemaLocation value

      • getNoNSSchemaLocation

        protected String getNoNSSchemaLocation()
        Convenience method for getting the current noNamespaceSchemaLocation.
        返回：
        the current noNamespaceSchemaLocation or null if it hasn't been set

      • setNoNSSchemaLocation

        protected void setNoNSSchemaLocation(String location)
        Convenience method for setting the noNamespaceSchemaLocation.
        参数：
        location - the noNamespaceSchemaLocation value

      • isFormattedOutput

        protected boolean isFormattedOutput()
        Convenience method for getting the formatted output flag.
        返回：
        the current value of the formatted output flag or false if it hasn't been set.

      • setFormattedOutput

        protected void setFormattedOutput(boolean v)
        Convenience method for setting the formatted output flag.
        参数：
        v - value of the formatted output flag.

      • isFragment

        protected boolean isFragment()
        Convenience method for getting the fragment flag.
        返回：
        the current value of the fragment flag or false if it hasn't been set.

      • setFragment

        protected void setFragment(boolean v)
        Convenience method for setting the fragment flag.
        参数：
        v - value of the fragment flag.

      • getJavaEncoding

        protected String getJavaEncoding(String encoding)
                          throws UnsupportedEncodingException
        Gets the corresponding Java encoding name from an IANA name. This method is a helper method for the derived class to convert encoding names.
        抛出：
        UnsupportedEncodingException - If this implementation couldn't find the Java encoding name.

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws PropertyException
        Default implementation of the setProperty method handles the four defined properties in Marshaller. If a provider needs to handle additional properties, it should override this method in a derived class.
        指定者：
        setProperty in interface Marshaller
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method handles the four defined properties in Marshaller. If a provider needs to support additional provider specific properties, it should override this method in a derived class.
        指定者：
        getProperty in interface Marshaller
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        从接口复制的描述： Marshaller
        Return the current event handler or the default event handler if one hasn't been set.
        指定者：
        getEventHandler in interface Marshaller
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler
        另请参见：
        Marshaller.getEventHandler()

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        从接口复制的描述： Marshaller
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

        Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

        指定者：
        setEventHandler in interface Marshaller
        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler
        另请参见：
        Marshaller.setEventHandler(ValidationEventHandler)

      • marshal

        public void marshal(Object obj,
           XMLEventWriter writer)
             throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The content tree rooted at jaxbElement to be marshalled.
        writer - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • marshal

        public void marshal(Object obj,
           XMLStreamWriter writer)
             throws JAXBException
        从接口复制的描述： Marshaller
        Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
        指定者：
        marshal in interface Marshaller
        参数：
        obj - The content tree to be marshalled.
        writer - XML will be sent to this writer.
        抛出：
        JAXBException - If any unexpected problem occurs during the marshalling.
        MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

      • setSchema

        public void setSchema(Schema schema)
        从接口复制的描述： Marshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

        This method allows the caller to validate the marshalled XML as it's marshalled.

        Initially this property is set to null.

        指定者：
        setSchema in interface Marshaller
        参数：
        schema - Schema object to validate marshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        从接口复制的描述： Marshaller
        Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.
        指定者：
        getSchema in interface Marshaller
        返回：
        the Schema object being used to perform marshal-time validation or null if not present.

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        从接口复制的描述： Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        指定者：
        setAdapter in interface Marshaller
        另请参见：
        Marshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(类<A> type,
                                     A adapter)
        从接口复制的描述： Marshaller
        Associates a configured instance of XmlAdapter with this marshaller.

        Every marshaller internally maintains a Map<类,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

        指定者：
        setAdapter in interface Marshaller
        参数：
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(类<A> type)
        从接口复制的描述： Marshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        指定者：
        getAdapter in interface Marshaller

      • setAttachmentMarshaller

        public void setAttachmentMarshaller(AttachmentMarshaller am)
        从接口复制的描述： Marshaller

        Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

        指定者：
        setAttachmentMarshaller in interface Marshaller

      • getAttachmentMarshaller

        public AttachmentMarshaller getAttachmentMarshaller()
        指定者：
        getAttachmentMarshaller in interface Marshaller

      • setListener

        public void setListener(Marshaller.Listener listener)
        从接口复制的描述： Marshaller

        Register marshal event callback Marshaller.Listener with this Marshaller.

        There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        指定者：
        setListener in interface Marshaller
        参数：
        listener - an instance of a class that implements Marshaller.Listener

      • getListener

        public Marshaller.Listener getListener()
        从接口复制的描述： Marshaller

        Return Marshaller.Listener registered with this Marshaller.

        指定者：
        getListener in interface Marshaller
        返回：
        registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AbstractUnmarshallerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.helpers

类 AbstractUnmarshallerImpl

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl
  • 所有已实现的接口：
    Unmarshaller

    public abstract class AbstractUnmarshallerImpl
extends Object
implements Unmarshaller
    Partial default Unmarshaller implementation.

    This class provides a partial default implementation for the Unmarshallerinterface.

    A JAXB Provider has to implement five methods (getUnmarshallerHandler, unmarshal(Node), unmarshal(XMLReader,InputSource), unmarshal(XMLStreamReader), and unmarshal(XMLEventReader).

    从以下版本开始：
    JAXB1.0
    另请参见：
    Unmarshaller

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.xml.bind.Unmarshaller

        Unmarshaller.Listener

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean validating
      whether or not the unmarshaller will validate

    • 构造方法摘要

      Constructors
      构造方法与描述
      AbstractUnmarshallerImpl()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected UnmarshalException createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.
      <A extends XmlAdapter>
      A             		getAdapter(类<A> type)
      Gets the adapter associated with the specified type.
      AttachmentUnmarshaller getAttachmentUnmarshaller()
      ValidationEventHandler getEventHandler()
      Return the current event handler or the default event handler if one hasn't been set.
      Unmarshaller.Listener getListener()
      Return Unmarshaller.Listener registered with this Unmarshaller.
      Object getProperty(String name)
      Default implementation of the getProperty method always throws PropertyException since there are no required properties.
      Schema getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      protected XMLReader getXMLReader()
      Obtains a configured XMLReader.
      boolean isValidating()
      Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
      <A extends XmlAdapter>
      void             		setAdapter(类<A> type, A adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAdapter(XmlAdapter adapter)
      Associates a configured instance of XmlAdapter with this unmarshaller.
      void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
      Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
      void setEventHandler(ValidationEventHandler handler)
      Allow an application to register a validation event handler.
      void setListener(Unmarshaller.Listener listener)
      Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
      void setProperty(String name, Object value)
      Default implementation of the setProperty method always throws PropertyException since there are no required properties.
      void setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void setValidating(boolean validating)
      Specifies whether or not the Unmarshaller should validate during unmarshal operations.
      Object unmarshal(File f)
      Unmarshal XML data from the specified file and return the resulting content tree.
      Object unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
      Object unmarshal(InputStream is)
      Unmarshal XML data from the specified InputStream and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Node node, 类<T> expectedType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
      Object unmarshal(Reader reader)
      Unmarshal XML data from the specified Reader and return the resulting content tree.
      Object unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(Source source, 类<T> expectedType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      Object unmarshal(URL url)
      Unmarshal XML data from the specified URL and return the resulting content tree.
      Object unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLEventReader reader, 类<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
      protected abstract Object unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.
      Object unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> unmarshal(XMLStreamReader reader, 类<T> expectedType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.bind.Unmarshaller

        getUnmarshallerHandler, unmarshal

    • 字段详细信息

      • validating

        protected boolean validating
        whether or not the unmarshaller will validate

    • 构造方法详细信息

      • AbstractUnmarshallerImpl

        public AbstractUnmarshallerImpl()

    • 方法详细信息

      • getXMLReader

        protected XMLReader getXMLReader()
                          throws JAXBException
        Obtains a configured XMLReader. This method is used when the client-specified SAXSource object doesn't have XMLReader. Unmarshaller is not re-entrant, so we will only use one instance of XMLReader.
        抛出：
        JAXBException

      • unmarshal

        public Object unmarshal(Source source)
                 throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified XML Source and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        SAX 2.0 Parser Pluggability

        A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

        This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

        The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        另请参见：
        Unmarshaller.unmarshal(javax.xml.transform.Source, Class)

      • unmarshal

        protected abstract Object unmarshal(XMLReader reader,
               InputSource source)
                             throws JAXBException
        Unmarshals an object by using the specified XMLReader and the InputSource. The callee should call the setErrorHandler method of the XMLReader so that errors are passed to the client-specified ValidationEventHandler.
        抛出：
        JAXBException

      • unmarshal

        public final Object unmarshal(InputSource source)
                       throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        source - the input source to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(URL url)
                       throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified URL and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        url - the url to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(File f)
                       throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified file and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        f - the file to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(InputStream is)
                       throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

        Implements Unmarshal Global Root Element.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        is - the InputStream to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public final Object unmarshal(Reader reader)
                       throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

        Implements Unmarshal Global Root Element.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        reader - the Reader to unmarshal XML data from
        返回：
        the newly created root object of the java content tree
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • isValidating

        public boolean isValidating()
                     throws JAXBException
        Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

        Note: I named this method isValidating() to stay in-line with JAXP, as opposed to naming it getValidating().

        指定者：
        isValidating in interface Unmarshaller
        返回：
        true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
        抛出：
        JAXBException - if an error occurs while retrieving the validating flag

      • setEventHandler

        public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
        Allow an application to register a validation event handler.

        The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a validation event handler before invoking the unmarshal methods, then all validation events will be silently ignored and may result in unexpected behaviour.

        指定者：
        setEventHandler in interface Unmarshaller
        参数：
        handler - the validation event handler
        抛出：
        JAXBException - if an error was encountered while setting the event handler

      • setValidating

        public void setValidating(boolean validating)
                   throws JAXBException
        Specifies whether or not the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

        This method may only be invoked before or after calling one of the unmarshal methods.

        指定者：
        setValidating in interface Unmarshaller
        参数：
        validating - true if the Unmarshaller should validate during unmarshal, false otherwise
        抛出：
        JAXBException - if an error occurred while enabling or disabling validation at unmarshal time

      • getEventHandler

        public ValidationEventHandler getEventHandler()
                                       throws JAXBException
        Return the current event handler or the default event handler if one hasn't been set.
        指定者：
        getEventHandler in interface Unmarshaller
        返回：
        the current ValidationEventHandler or the default event handler if it hasn't been set
        抛出：
        JAXBException - if an error was encountered while getting the current event handler

      • createUnmarshalException

        protected UnmarshalException createUnmarshalException(SAXException e)
        Creates an UnmarshalException from a SAXException. This is an utility method provided for the derived classes.

        When a provider-implemented ContentHandler wants to throw a JAXBException, it needs to wrap the exception by a SAXException. If the unmarshaller implementation blindly wrap SAXException by JAXBException, such an exception will be a JAXBException wrapped by a SAXException wrapped by another JAXBException. This is silly.

        This method checks the nested exception of SAXException and reduce those excessive wrapping.

        返回：
        the resulting UnmarshalException

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws PropertyException
        Default implementation of the setProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        指定者：
        setProperty in interface Unmarshaller
        参数：
        name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
        value - the value of the property to be set
        抛出：
        PropertyException - when there is an error processing the given property or value

      • getProperty

        public Object getProperty(String name)
                   throws PropertyException
        Default implementation of the getProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.
        指定者：
        getProperty in interface Unmarshaller
        参数：
        name - the name of the property to retrieve
        返回：
        the value of the requested property
        抛出：
        PropertyException - when there is an error retrieving the given property or value property name

      • unmarshal

        public Object unmarshal(XMLEventReader reader)
                 throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        This method is an Unmarshal Global Root method.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        reader - The parser to be read.
        返回：
        the newly created root object of the java content tree.
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        另请参见：
        Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, Class)

      • unmarshal

        public Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified pull parser and return the resulting content tree.

        Implements Unmarshal Global Root Element.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        reader - The parser to be read.
        返回：
        the newly created root object of the java content tree.
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
        另请参见：
        Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, Class)

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Node node,
                           类<T> expectedType)
                         throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
        expectedType - appropriate JAXB mapped class to hold node's XML data.
        返回：
        JAXB Element representation of node
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(Source source,
                           类<T> expectedType)
                         throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

        Implements Unmarshal by Declared Type

        See SAX 2.0 Parser Pluggability

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
        expectedType - appropriate JAXB mapped class to hold source's xml root element
        返回：
        Java content rooted by JAXB Element
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                           类<T> expectedType)
                         throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        返回：
        content tree rooted by JAXB Element representation
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • unmarshal

        public <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                           类<T> expectedType)
                         throws JAXBException
        从接口复制的描述： Unmarshaller
        Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

        This method implements unmarshal by declaredType.

        This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

        指定者：
        unmarshal in interface Unmarshaller
        参数：
        reader - The parser to be read.
        expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
        返回：
        content tree rooted by JAXB Element representation
        抛出：
        JAXBException - If any unexpected errors occur while unmarshalling
        UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

      • setSchema

        public void setSchema(Schema schema)
        从接口复制的描述： Unmarshaller
        Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

        This method replaces the deprecated setValidating(boolean) API.

        Initially this property is set to null.

        指定者：
        setSchema in interface Unmarshaller
        参数：
        schema - Schema object to validate unmarshal operations against or null to disable validation

      • getSchema

        public Schema getSchema()
        从接口复制的描述： Unmarshaller
        Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

        This method provides replacement functionality for the deprecated Unmarshaller.isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

        boolean isValidating = u.getSchema()!=null;

        指定者：
        getSchema in interface Unmarshaller
        返回：
        the Schema object being used to perform unmarshal-time validation or null if not present

      • setAdapter

        public void setAdapter(XmlAdapter adapter)
        从接口复制的描述： Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

        指定者：
        setAdapter in interface Unmarshaller
        另请参见：
        Unmarshaller.setAdapter(Class,XmlAdapter)

      • setAdapter

        public <A extends XmlAdapter> void setAdapter(类<A> type,
                                     A adapter)
        从接口复制的描述： Unmarshaller
        Associates a configured instance of XmlAdapter with this unmarshaller.

        Every unmarshaller internally maintains a Map<类,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

        This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

        指定者：
        setAdapter in interface Unmarshaller
        参数：
        type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
        adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

      • getAdapter

        public <A extends XmlAdapter> A getAdapter(类<A> type)
        从接口复制的描述： Unmarshaller
        Gets the adapter associated with the specified type. This is the reverse operation of the Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.
        指定者：
        getAdapter in interface Unmarshaller

      • setAttachmentUnmarshaller

        public void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
        从接口复制的描述： Unmarshaller

        Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

        Unmarshal time validation, enabled via Unmarshaller.setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

        指定者：
        setAttachmentUnmarshaller in interface Unmarshaller

      • getAttachmentUnmarshaller

        public AttachmentUnmarshaller getAttachmentUnmarshaller()
        指定者：
        getAttachmentUnmarshaller in interface Unmarshaller

      • setListener

        public void setListener(Unmarshaller.Listener listener)
        从接口复制的描述： Unmarshaller

        Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

        There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

        指定者：
        setListener in interface Unmarshaller
        参数：
        listener - provides unmarshal event callbacks for this Unmarshaller

      • getListener

        public Unmarshaller.Listener getListener()
        从接口复制的描述： Unmarshaller

        Return Unmarshaller.Listener registered with this Unmarshaller.

        指定者：
        getListener in interface Unmarshaller
        返回：
        registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefaultValidationEventHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.helpers

类 DefaultValidationEventHandler

  • java.lang.Object
    • javax.xml.bind.helpers.DefaultValidationEventHandler
  • 所有已实现的接口：
    ValidationEventHandler

    public class DefaultValidationEventHandler
extends Object
implements ValidationEventHandler

    JAXB 1.0 only default validation event handler. This is the default handler for all objects created from a JAXBContext that is managing schema-derived code generated by a JAXB 1.0 binding compiler.

    This handler causes the unmarshal and validate operations to fail on the first error or fatal error.

    This handler is not the default handler for JAXB mapped classes following JAXB 2.0 or later versions. Default validation event handling has changed and is specified in Unmarshaller and Marshaller.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Unmarshaller, Validator, ValidationEventHandler

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultValidationEventHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultValidationEventHandler

        public DefaultValidationEventHandler()

    • 方法详细信息

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        从接口复制的描述： ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        指定者：
        handleEvent in interface ValidationEventHandler
        参数：
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        返回：
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


javax.xml.bind.helpers

Classes

  • AbstractMarshallerImpl
  • AbstractUnmarshallerImpl
  • DefaultValidationEventHandler
  • NotIdentifiableEventImpl
  • ParseConversionEventImpl
  • PrintConversionEventImpl
  • ValidationEventImpl
  • ValidationEventLocatorImpl
P


javax.xml.bind.helpers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind.helpers

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

请参见： 描述

  • Class Summary
    类 描述
    AbstractMarshallerImpl
    Partial default Marshaller implementation.
    AbstractUnmarshallerImpl
    Partial default Unmarshaller implementation.
    DefaultValidationEventHandler
    JAXB 1.0 only default validation event handler.
    NotIdentifiableEventImpl
    Default implementation of the NotIdentifiableEvent interface.
    ParseConversionEventImpl
    Default implementation of the ParseConversionEvent interface.
    PrintConversionEventImpl
    Default implementation of the PrintConversionEvent interface.
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
    ValidationEventLocatorImpl
    Default implementation of the ValidationEventLocator interface.

软件包 javax.xml.bind.helpers Description

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

JAXB Providers can extend these classes and implement the abstract methods.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mEtvVialepraaei//"" >,ia


javax.xml.bind.helpers Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind.helpers

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)a;oatrabtmb_((yipaiI


NotIdentifiableEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.helpers

类 NotIdentifiableEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.NotIdentifiableEventImpl
  • 所有已实现的接口：
    NotIdentifiableEvent, ValidationEvent

    public class NotIdentifiableEventImpl
extends ValidationEventImpl
implements NotIdentifiableEvent
    Default implementation of the NotIdentifiableEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    从以下版本开始：
    JAXB1.0
    另请参见：
    NotIdentifiableEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new NotIdentifiableEventImpl.
      NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new NotIdentifiableEventImpl.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • 构造方法详细信息

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new NotIdentifiableEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

      • NotIdentifiableEventImpl

        public NotIdentifiableEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new NotIdentifiableEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=lhe>el.ltttpastb//.s .-r s<


ParseConversionEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.helpers

类 ParseConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.ParseConversionEventImpl
  • 所有已实现的接口：
    ParseConversionEvent, ValidationEvent

    public class ParseConversionEventImpl
extends ValidationEventImpl
implements ParseConversionEvent
    Default implementation of the ParseConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    从以下版本开始：
    JAXB1.0
    另请参见：
    ParseConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ParseConversionEventImpl.
      ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ParseConversionEventImpl.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • 构造方法详细信息

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new ParseConversionEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

      • ParseConversionEventImpl

        public ParseConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new ParseConversionEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Xllmsel>elp.tetp//Est/rts@


PrintConversionEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.helpers

类 PrintConversionEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
      • javax.xml.bind.helpers.PrintConversionEventImpl
  • 所有已实现的接口：
    PrintConversionEvent, ValidationEvent

    public class PrintConversionEventImpl
extends ValidationEventImpl
implements PrintConversionEvent
    Default implementation of the PrintConversionEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    从以下版本开始：
    JAXB1.0
    另请参见：
    PrintConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new PrintConversionEventImpl.
      PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new PrintConversionEventImpl.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.bind.helpers.ValidationEventImpl

        getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.bind.ValidationEvent

        getLinkedException, getLocator, getMessage, getSeverity

    • 构造方法详细信息

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator)
        Create a new PrintConversionEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

      • PrintConversionEventImpl

        public PrintConversionEventImpl(int _severity,
                        String _message,
                        ValidationEventLocator _locator,
                        Throwable _linkedException)
        Create a new PrintConversionEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mhm mse>lslllps..p�/rp/ts


Uses of Package javax.xml.bind.helpers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind.helpers

  • Packages that use javax.xml.bind.helpers
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
  • Classes in javax.xml.bind.helpers used by javax.xml.bind.helpers
    类与描述
    ValidationEventImpl
    Default implementation of the ValidationEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

epc".t.de---c.ff>lll/糾s


ValidationEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.helpers

类 ValidationEventImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventImpl
  • 所有已实现的接口：
    ValidationEvent
    直接已知子类：
    NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl

    public class ValidationEventImpl
extends Object
implements ValidationEvent
    Default implementation of the ValidationEvent interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.bind.ValidationEvent

        ERROR, FATAL_ERROR, WARNING

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
      Create a new ValidationEventImpl.
      ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
      Create a new ValidationEventImpl.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getLinkedException()
      Retrieve the linked exception for this warning/error.
      ValidationEventLocator getLocator()
      Retrieve the locator for this warning/error.
      String getMessage()
      Retrieve the text message for this warning/error.
      int getSeverity()
      Retrieve the severity code for this warning/error.
      void setLinkedException(Throwable _linkedException)
      Set the linked exception field of this event.
      void setLocator(ValidationEventLocator _locator)
      Set the locator object for this event.
      void setMessage(String _message)
      Set the message field of this event.
      void setSeverity(int _severity)
      Set the severity field of this event.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                   String _message,
                   ValidationEventLocator _locator)
        Create a new ValidationEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

      • ValidationEventImpl

        public ValidationEventImpl(int _severity,
                   String _message,
                   ValidationEventLocator _locator,
                   Throwable _linkedException)
        Create a new ValidationEventImpl.
        参数：
        _severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
        _message - The text message for this event - may be null.
        _locator - The locator object for this event - may be null.
        _linkedException - An optional linked exception that may provide additional information about the event - may be null.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

    • 方法详细信息

      • getSeverity

        public int getSeverity()
        从接口复制的描述： ValidationEvent
        Retrieve the severity code for this warning/error.

        Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

        指定者：
        getSeverity in interface ValidationEvent
        返回：
        the severity code for this warning/error

      • setSeverity

        public void setSeverity(int _severity)
        Set the severity field of this event.
        参数：
        _severity - Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR.
        抛出：
        IllegalArgumentException - if an illegal severity field is supplied

      • getMessage

        public String getMessage()
        从接口复制的描述： ValidationEvent
        Retrieve the text message for this warning/error.
        指定者：
        getMessage in interface ValidationEvent
        返回：
        the text message for this warning/error or null if one wasn't set

      • setMessage

        public void setMessage(String _message)
        Set the message field of this event.
        参数：
        _message - String message - may be null.

      • getLinkedException

        public Throwable getLinkedException()
        从接口复制的描述： ValidationEvent
        Retrieve the linked exception for this warning/error.
        指定者：
        getLinkedException in interface ValidationEvent
        返回：
        the linked exception for this warning/error or null if one wasn't set

      • setLinkedException

        public void setLinkedException(Throwable _linkedException)
        Set the linked exception field of this event.
        参数：
        _linkedException - Optional linked exception - may be null.

      • getLocator

        public ValidationEventLocator getLocator()
        从接口复制的描述： ValidationEvent
        Retrieve the locator for this warning/error.
        指定者：
        getLocator in interface ValidationEvent
        返回：
        the locator that indicates where the warning/error occurred

      • setLocator

        public void setLocator(ValidationEventLocator _locator)
        Set the locator object for this event.
        参数：
        _locator - The locator - may be null.

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
        另请参见：
        Object.equals(Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>rtilellb;=ucn1 usdsd�-do.>rl ear=


ValidationEventLocatorImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.helpers

类 ValidationEventLocatorImpl

  • java.lang.Object
    • javax.xml.bind.helpers.ValidationEventLocatorImpl
  • 所有已实现的接口：
    ValidationEventLocator

    public class ValidationEventLocatorImpl
extends Object
implements ValidationEventLocator
    Default implementation of the ValidationEventLocator interface.

    JAXB providers are allowed to use whatever class that implements the ValidationEventLocator interface. This class is just provided for a convenience.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValidationEventLocatorImpl()
      Creates an object with all fields unavailable.
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.
      ValidationEventLocatorImpl(Object _object)
      Constructs an object that points to a JAXB content object.
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Return the column number if available
      int getLineNumber()
      Return the line number if available
      Node getNode()
      Return a reference to the DOM Node if available
      Object getObject()
      Return a reference to the object in the Java content tree if available
      int getOffset()
      Return the byte offset if available
      URL getURL()
      Return the name of the XML source as a URL if available
      void setColumnNumber(int _columnNumber)
      Set the columnNumber field on this event locator.
      void setLineNumber(int _lineNumber)
      Set the lineNumber field on this event locator.
      void setNode(Node _node)
      Set the Node field on this event locator.
      void setObject(Object _object)
      Set the Object field on this event locator.
      void setOffset(int _offset)
      Set the offset field on this event locator.
      void setURL(URL _url)
      Set the URL field on this event locator.
      String toString()
      Returns a string representation of this object in a format helpful to debugging.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl()
        Creates an object with all fields unavailable.

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Locator loc)
        Constructs an object from an org.xml.sax.Locator. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        参数：
        loc - the SAX Locator object that will be used to populate this event locator.
        抛出：
        IllegalArgumentException - if the Locator is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(SAXParseException e)
        Constructs an object from the location information of a SAXParseException. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.
        参数：
        e - the SAXParseException object that will be used to populate this event locator.
        抛出：
        IllegalArgumentException - if the SAXParseException is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Node _node)
        Constructs an object that points to a DOM Node. The object's Node becomes available. ColumnNumber, LineNumber, Object, Offset, and URL are not available.
        参数：
        _node - the DOM Node object that will be used to populate this event locator.
        抛出：
        IllegalArgumentException - if the Node is null

      • ValidationEventLocatorImpl

        public ValidationEventLocatorImpl(Object _object)
        Constructs an object that points to a JAXB content object. The object's Object becomes available. ColumnNumber, LineNumber, Node, Offset, and URL are not available.
        参数：
        _object - the Object that will be used to populate this event locator.
        抛出：
        IllegalArgumentException - if the Object is null

    • 方法详细信息

      • getURL

        public URL getURL()
        从接口复制的描述： ValidationEventLocator
        Return the name of the XML source as a URL if available
        指定者：
        getURL in interface ValidationEventLocator
        返回：
        the name of the XML source as a URL or null if unavailable
        另请参见：
        ValidationEventLocator.getURL()

      • setURL

        public void setURL(URL _url)
        Set the URL field on this event locator. Null values are allowed.
        参数：
        _url - the url

      • getOffset

        public int getOffset()
        从接口复制的描述： ValidationEventLocator
        Return the byte offset if available
        指定者：
        getOffset in interface ValidationEventLocator
        返回：
        the byte offset into the input source or -1 if unavailable
        另请参见：
        ValidationEventLocator.getOffset()

      • setOffset

        public void setOffset(int _offset)
        Set the offset field on this event locator.
        参数：
        _offset - the offset

      • getLineNumber

        public int getLineNumber()
        从接口复制的描述： ValidationEventLocator
        Return the line number if available
        指定者：
        getLineNumber in interface ValidationEventLocator
        返回：
        the line number or -1 if unavailable
        另请参见：
        ValidationEventLocator.getLineNumber()

      • setLineNumber

        public void setLineNumber(int _lineNumber)
        Set the lineNumber field on this event locator.
        参数：
        _lineNumber - the line number

      • getColumnNumber

        public int getColumnNumber()
        从接口复制的描述： ValidationEventLocator
        Return the column number if available
        指定者：
        getColumnNumber in interface ValidationEventLocator
        返回：
        the column number or -1 if unavailable
        另请参见：
        ValidationEventLocator.getColumnNumber()

      • setColumnNumber

        public void setColumnNumber(int _columnNumber)
        Set the columnNumber field on this event locator.
        参数：
        _columnNumber - the column number

      • getObject

        public Object getObject()
        从接口复制的描述： ValidationEventLocator
        Return a reference to the object in the Java content tree if available
        指定者：
        getObject in interface ValidationEventLocator
        返回：
        a reference to the object in the Java content tree or null if unavailable
        另请参见：
        ValidationEventLocator.getObject()

      • setObject

        public void setObject(Object _object)
        Set the Object field on this event locator. Null values are allowed.
        参数：
        _object - the java content object

      • getNode

        public Node getNode()
        从接口复制的描述： ValidationEventLocator
        Return a reference to the DOM Node if available
        指定者：
        getNode in interface ValidationEventLocator
        返回：
        a reference to the DOM Node or null if unavailable
        另请参见：
        ValidationEventLocator.getNode()

      • setNode

        public void setNode(Node _node)
        Set the Node field on this event locator. Null values are allowed.
        参数：
        _node - the Node

      • toString

        public String toString()
        Returns a string representation of this object in a format helpful to debugging.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
        另请参见：
        Object.equals(Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

../tefc


Uses of Class javax.xml.bind.helpers.AbstractMarshallerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.AbstractMarshallerImpl

No usage of javax.xml.bind.helpers.AbstractMarshallerImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.


Uses of Class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.AbstractUnmarshallerImpl

No usage of javax.xml.bind.helpers.AbstractUnmarshallerImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t f/h nRs


Uses of Class javax.xml.bind.helpers.DefaultValidationEventHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.DefaultValidationEventHandler

No usage of javax.xml.bind.helpers.DefaultValidationEventHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se.<=O/Ie/ lv=T"u"�


Uses of Class javax.xml.bind.helpers.NotIdentifiableEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.NotIdentifiableEventImpl

No usage of javax.xml.bind.helpers.NotIdentifiableEventImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/ab;1;p-1


Uses of Class javax.xml.bind.helpers.ParseConversionEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.ParseConversionEventImpl

No usage of javax.xml.bind.helpers.ParseConversionEventImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

As屏 pP�3o<b=


Uses of Class javax.xml.bind.helpers.PrintConversionEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.PrintConversionEventImpl

No usage of javax.xml.bind.helpers.PrintConversionEventImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rk3 豴��3o<


Uses of Class javax.xml.bind.helpers.ValidationEventImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.ValidationEventImpl

  • Packages that use ValidationEventImpl
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

    • Uses of ValidationEventImpl in javax.xml.bind.helpers

      Subclasses of ValidationEventImpl in javax.xml.bind.helpers
      修饰符与类型 类与描述
      class  NotIdentifiableEventImpl
      Default implementation of the NotIdentifiableEvent interface.
      class  ParseConversionEventImpl
      Default implementation of the ParseConversionEvent interface.
      class  PrintConversionEventImpl
      Default implementation of the PrintConversionEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

brv>e/ad/ta f.


Uses of Class javax.xml.bind.helpers.ValidationEventLocatorImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.helpers.ValidationEventLocatorImpl

No usage of javax.xml.bind.helpers.ValidationEventLocatorImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.tpss&>eccccFddnPetc


javax.xml.bind.util

Classes

  • JAXBResult
  • JAXBSource
  • ValidationEventCollector


javax.xml.bind.util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.bind.util

Useful client utility classes.

请参见： 描述

  • Class Summary
    类 描述
    JAXBResult
    JAXP Result implementation that unmarshals a JAXB object.
    JAXBSource
    JAXP Source implementation that marshals a JAXB-generated object.
    ValidationEventCollector
    ValidationEventHandler implementation that collects all events.

软件包 javax.xml.bind.util Description

Useful client utility classes.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c<


javax.xml.bind.util Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.bind.util

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pslli.s.yeiys ed(td


JAXBResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.util

类 JAXBResult

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult
      • javax.xml.bind.util.JAXBResult
  • 所有已实现的接口：
    Result

    public class JAXBResult
extends SAXResult
    JAXP Result implementation that unmarshals a JAXB object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to unmarshal a document resulting from an XSLT transformation.

           JAXBResult result = new JAXBResult(
         JAXBContext.newInstance("org.acme.foo") );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(new StreamSource("document.xml"),result);

       // obtain the unmarshalled content tree
       Object o = result.getResult();

    The fact that JAXBResult derives from SAXResult is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXResult.

    In particular it shall never attempt to call the setHandler, setLexicalHandler, and setSystemId methods.

    • 字段摘要

      • Fields inherited from class javax.xml.transform.sax.SAXResult

        FEATURE

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBResult(JAXBContext context)
      Creates a new instance that uses the specified JAXBContext to unmarshal.
      JAXBResult(Unmarshaller _unmarshaller)
      Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object getResult()
      Gets the unmarshalled object created by the transformation.

      • 方法 - 继承于类 javax.xml.transform.sax.SAXResult

        getHandler, getLexicalHandler, getSystemId, setHandler, setLexicalHandler, setSystemId

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JAXBResult

        public JAXBResult(JAXBContext context)
           throws JAXBException
        Creates a new instance that uses the specified JAXBContext to unmarshal.
        参数：
        context - The JAXBContext that will be used to create the necessary Unmarshaller. This parameter must not be null.
        抛出：
        JAXBException - if an error is encountered while creating the JAXBResult or if the context parameter is null.

      • JAXBResult

        public JAXBResult(Unmarshaller _unmarshaller)
           throws JAXBException
        Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

        This JAXBResult object will use the specified Unmarshaller instance. It is the caller's responsibility not to use the same Unmarshaller for other purposes while it is being used by this object.

        The primary purpose of this method is to allow the client to configure Unmarshaller. Unless you know what you are doing, it's easier and safer to pass a JAXBContext.

        参数：
        _unmarshaller - the unmarshaller. This parameter must not be null.
        抛出：
        JAXBException - if an error is encountered while creating the JAXBResult or the Unmarshaller parameter is null.

    • 方法详细信息

      • getResult

        public Object getResult()
                 throws JAXBException
        Gets the unmarshalled object created by the transformation.
        返回：
        Always return a non-null object.
        抛出：
        IllegalStateException - if this method is called before an object is unmarshalled.
        JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ber=sinbaa/art>>ra>gy/rol->


JAXBSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.bind.util

类 JAXBSource

  • java.lang.Object
    • javax.xml.transform.sax.SAXSource
      • javax.xml.bind.util.JAXBSource
  • 所有已实现的接口：
    Source

    public class JAXBSource
extends SAXSource
    JAXP Source implementation that marshals a JAXB-generated object.

    This utility class is useful to combine JAXB with other Java/XML technologies.

    The following example shows how to use JAXB to marshal a document for transformation by XSLT.

           MyObject o = // get JAXB content tree

       // jaxbContext is a JAXBContext object from which 'o' is created.
       JAXBSource source = new JAXBSource( jaxbContext, o );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(source,new StreamResult(System.out));

    The fact that JAXBSource derives from SAXSource is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXSource. In particular, the setXMLReader and setInputSource methods shall never be called. The XMLReader object obtained by the getXMLReader method shall be used only for parsing the InputSource object returned by the getInputSource method.

    Similarly the InputSource object obtained by the getInputSource method shall be used only for being parsed by the XMLReader object returned by the getXMLReader.

    • 字段摘要

      • Fields inherited from class javax.xml.transform.sax.SAXSource

        FEATURE

    • 构造方法摘要

      Constructors
      构造方法与描述
      JAXBSource(JAXBContext context, Object contentObject)
      Creates a new Source for the given content object.
      JAXBSource(Marshaller marshaller, Object contentObject)
      Creates a new Source for the given content object.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.transform.sax.SAXSource

        getInputSource, getSystemId, getXMLReader, setInputSource, setSystemId, setXMLReader, sourceToInputSource

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • JAXBSource

        public JAXBSource(JAXBContext context,
          Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        参数：
        context - JAXBContext that was used to create contentObject. This context is used to create a new instance of marshaller and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        抛出：
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.

      • JAXBSource

        public JAXBSource(Marshaller marshaller,
          Object contentObject)
           throws JAXBException
        Creates a new Source for the given content object.
        参数：
        marshaller - A marshaller instance that will be used to marshal contentObject into XML. This must be created from a JAXBContext that was used to build contentObject and must not be null.
        contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
        抛出：
        JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:e/= =<=p=fh=":bthzz==-F=FOOAMp= e


Uses of Package javax.xml.bind.util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.bind.util

No usage of javax.xml.bind.util
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

al >>1vllrle><


ValidationEventCollector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.bind.util

类 ValidationEventCollector

  • java.lang.Object
    • javax.xml.bind.util.ValidationEventCollector
  • 所有已实现的接口：
    ValidationEventHandler

    public class ValidationEventCollector
extends Object
implements ValidationEventHandler
    ValidationEventHandler implementation that collects all events.

    To use this class, create a new instance and pass it to the setEventHandler method of the Validator, Unmarshaller, Marshaller class. After the call to validate or unmarshal completes, call the getEvents method to retrieve all the reported errors and warnings.

    从以下版本开始：
    JAXB1.0
    另请参见：
    Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValidationEventCollector()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ValidationEvent[] getEvents()
      Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
      boolean handleEvent(ValidationEvent event)
      Receive notification of a validation warning or error.
      boolean hasEvents()
      Returns true if this event collector contains at least one ValidationEvent.
      void reset()
      Clear all collected errors and warnings.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ValidationEventCollector

        public ValidationEventCollector()

    • 方法详细信息

      • getEvents

        public ValidationEvent[] getEvents()
        Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
        返回：
        a copy of all the collected errors and warnings or an empty array if there weren't any

      • reset

        public void reset()
        Clear all collected errors and warnings.

      • hasEvents

        public boolean hasEvents()
        Returns true if this event collector contains at least one ValidationEvent.
        返回：
        true if this event collector contains at least one ValidationEvent, false otherwise

      • handleEvent

        public boolean handleEvent(ValidationEvent event)
        从接口复制的描述： ValidationEventHandler
        Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

        If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

        指定者：
        handleEvent in interface ValidationEventHandler
        参数：
        event - the encapsulated validation event information. It is a provider error if this parameter is null.
        返回：
        true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttit


Uses of Class javax.xml.bind.util.JAXBResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.util.JAXBResult

No usage of javax.xml.bind.util.JAXBResult
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

onete".b


Uses of Class javax.xml.bind.util.JAXBSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.util.JAXBSource

No usage of javax.xml.bind.util.JAXBSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lnPce4�.n


Uses of Class javax.xml.bind.util.ValidationEventCollector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.bind.util.ValidationEventCollector

No usage of javax.xml.bind.util.ValidationEventCollector
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>/de#dceic


Uses of Class javax.xml.XMLConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.XMLConstants

No usage of javax.xml.XMLConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.ns sc.o #s>


AlgorithmMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface AlgorithmMethod

  • All Known Subinterfaces:
    CanonicalizationMethod, DigestMethod, SignatureMethod, Transform
    All Known Implementing Classes:
    TransformService

    public interface AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications. Subclasses represent specific types of XML security algorithms, such as a Transform.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAlgorithm()
      Returns the algorithm URI of this AlgorithmMethod.
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm parameters of this AlgorithmMethod.

    • 方法详细信息

      • getAlgorithm

        String getAlgorithm()
        Returns the algorithm URI of this AlgorithmMethod.
        返回：
        the algorithm URI of this AlgorithmMethod

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm parameters of this AlgorithmMethod.
        返回：
        the algorithm parameters of this AlgorithmMethod. Returns null if this AlgorithmMethod does not require parameters and they are not specified.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>8/7eaeltt</


Data

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto

Interface Data

  • All Known Subinterfaces:
    NodeSetData
    All Known Implementing Classes:
    OctetStreamData

    public interface Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms. The primary purpose of this interface is to group and provide type safety for all Data subtypes.
    从以下版本开始：
    1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v<>ctohhohtmtittl tt;sar


javax.xml.crypto

Interfaces

  • AlgorithmMethod
  • Data
  • KeySelectorResult
  • NodeSetData
  • URIDereferencer
  • URIReference
  • XMLCryptoContext
  • XMLStructure

Classes

  • KeySelector
  • KeySelector.Purpose
  • OctetStreamData

Exceptions

  • KeySelectorException
  • MarshalException
  • NoSuchMechanismException
  • URIReferenceException
h


javax.xml.crypto

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto

Common classes for XML cryptography.

请参见： 描述

  • 接口摘要
    接口 描述
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    NodeSetData
    An abstract representation of a Data type containing a node-set.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Class Summary
    类 描述
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    KeySelector.Purpose
    The purpose of the key that is to be selected.
    OctetStreamData
    A representation of a Data type containing an octet stream.
  • Exception Summary
    Exception 描述
    KeySelectorException
    Indicates an exceptional condition thrown by a KeySelector.
    MarshalException
    Indicates an exceptional condition that occured during the XML marshalling or unmarshalling process.
    NoSuchMechanismException
    This exception is thrown when a particular XML mechanism is requested but is not available in the environment.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.

软件包 javax.xml.crypto Description

Common classes for XML cryptography. This package includes common classes that are used to perform XML cryptographic operations, such as generating an XML signature or encrypting XML data.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l//=lio> ><>> iddi


javax.xml.crypto Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.KeySelectorException
        • javax.xml.crypto.MarshalException
        • java.lang.RuntimeException
          • javax.xml.crypto.NoSuchMechanismException
        • javax.xml.crypto.URIReferenceException

Interface Hierarchy

  • javax.xml.crypto.AlgorithmMethod
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.xml.crypto.KeySelectorResult
  • javax.xml.crypto.URIDereferencer
  • javax.xml.crypto.URIReference
  • javax.xml.crypto.XMLCryptoContext
  • javax.xml.crypto.XMLStructure
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

asstn>itooochoomvee E


KeySelector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 KeySelector

  • java.lang.Object
    • javax.xml.crypto.KeySelector

  • public abstract class KeySelector
extends Object
    A selector that finds and returns a key using the data contained in a KeyInfo object. An example of an implementation of this class is one that searchs a KeyStore for trusted keys that match information contained in a KeyInfo.

    Whether or not the returned key is trusted and the mechanisms used to determine that is implementation-specific.

    从以下版本开始：
    1.6

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  KeySelector.Purpose
      The purpose of the key that is to be selected.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected KeySelector()
      Default no-args constructor; intended for invocation by subclasses only.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract KeySelectorResult select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
      static KeySelector singletonKeySelector(Key key)
      Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeySelector

        protected KeySelector()
        Default no-args constructor; intended for invocation by subclasses only.

    • 方法详细信息

      • select

        public abstract KeySelectorResult select(KeyInfo keyInfo,
                       KeySelector.Purpose purpose,
                       AlgorithmMethod method,
                       XMLCryptoContext context)
                                  throws KeySelectorException
        Attempts to find a key that satisfies the specified constraints.
        参数：
        keyInfo - a KeyInfo (may be null)
        purpose - the key's purpose (KeySelector.Purpose.SIGN, KeySelector.Purpose.VERIFY, KeySelector.Purpose.ENCRYPT, or KeySelector.Purpose.DECRYPT)
        method - the algorithm method that this key is to be used for. Only keys that are compatible with the algorithm and meet the constraints of the specified algorithm should be returned.
        context - an XMLCryptoContext that may contain useful information for finding an appropriate key. If this key selector supports resolving RetrievalMethod types, the context's baseURI and dereferencer parameters (if specified) should be used by the selector to resolve and dereference the URI.
        返回：
        the result of the key selector
        抛出：
        KeySelectorException - if an exceptional condition occurs while attempting to find a key. Note that an inability to find a key is not considered an exception (null should be returned in that case). However, an error condition (ex: network communications failure) that prevented the KeySelector from finding a potential key should be considered an exception.
        ClassCastException - if the data type of method is not supported by this key selector

      • singletonKeySelector

        public static KeySelector singletonKeySelector(Key key)
        Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.
        参数：
        key - the sole key to be stored in the key selector
        返回：
        a key selector that always selects the specified key
        抛出：
        NullPointerException - if key is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nepii sned#/avtnaoe n ec/I,n


KeySelector.Purpose

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

类 KeySelector.Purpose

  • java.lang.Object
    • javax.xml.crypto.KeySelector.Purpose
  • 封闭类：
    KeySelector

    public static class KeySelector.Purpose
extends Object
    The purpose of the key that is to be selected.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static KeySelector.Purpose DECRYPT
      A key for decrypting.
      static KeySelector.Purpose ENCRYPT
      A key for encrypting.
      static KeySelector.Purpose SIGN
      A key for signing.
      static KeySelector.Purpose VERIFY
      A key for verifying.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Returns a string representation of this purpose ("sign", "verify", "encrypt", or "decrypt").

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • SIGN

        public static final KeySelector.Purpose SIGN
        A key for signing.

      • VERIFY

        public static final KeySelector.Purpose VERIFY
        A key for verifying.

      • ENCRYPT

        public static final KeySelector.Purpose ENCRYPT
        A key for encrypting.

      • DECRYPT

        public static final KeySelector.Purpose DECRYPT
        A key for decrypting.

    • 方法详细信息

      • toString

        public String toString()
        Returns a string representation of this purpose ("sign", "verify", "encrypt", or "decrypt").
        重载：
        toString in class Object
        返回：
        a string representation of this purpose
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ccleehKKeec< c< t o


KeySelectorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 KeySelectorException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.KeySelectorException
  • 所有已实现的接口：
    Serializable

    public class KeySelectorException
extends Exception
    Indicates an exceptional condition thrown by a KeySelector.

    A KeySelectorException can contain a cause: another throwable that caused this KeySelectorException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      KeySelectorException()
      Constructs a new KeySelectorException with null as its detail message.
      KeySelectorException(String message)
      Constructs a new KeySelectorException with the specified detail message.
      KeySelectorException(String message, Throwable cause)
      Constructs a new KeySelectorException with the specified detail message and cause.
      KeySelectorException(Throwable cause)
      Constructs a new KeySelectorException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • KeySelectorException

        public KeySelectorException()
        Constructs a new KeySelectorException with null as its detail message.

      • KeySelectorException

        public KeySelectorException(String message)
        Constructs a new KeySelectorException with the specified detail message.
        参数：
        message - the detail message

      • KeySelectorException

        public KeySelectorException(String message,
                    Throwable cause)
        Constructs a new KeySelectorException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • KeySelectorException

        public KeySelectorException(Throwable cause)
        Constructs a new KeySelectorException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this KeySelectorException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this KeySelectorException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA>nl h"slo/=)li"aoa1 hna =/<


KeySelectorResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface KeySelectorResult

  • public interface KeySelectorResult
    The result returned by the KeySelector.select method.

    At a minimum, a KeySelectorResult contains the Key selected by the KeySelector. Implementations of this interface may add methods to return implementation or algorithm specific information, such as a chain of certificates or debugging information.

    从以下版本开始：
    1.6
    另请参见：
    KeySelector

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Key getKey()
      Returns the selected key.

    • 方法详细信息

      • getKey

        Key getKey()
        Returns the selected key.
        返回：
        the selected key, or null if none can be found
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ksT>raneanittniiicrrd<">"<>ac//fvt


MarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 MarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.MarshalException
  • 所有已实现的接口：
    Serializable

    public class MarshalException
extends Exception
    Indicates an exceptional condition that occured during the XML marshalling or unmarshalling process.

    A MarshalException can contain a cause: another throwable that caused this MarshalException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    XMLSignature.sign(XMLSignContext), XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      MarshalException()
      Constructs a new MarshalException with null as its detail message.
      MarshalException(String message)
      Constructs a new MarshalException with the specified detail message.
      MarshalException(String message, Throwable cause)
      Constructs a new MarshalException with the specified detail message and cause.
      MarshalException(Throwable cause)
      Constructs a new MarshalException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this MarshalException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this MarshalException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this MarshalException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this MarshalException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MarshalException

        public MarshalException()
        Constructs a new MarshalException with null as its detail message.

      • MarshalException

        public MarshalException(String message)
        Constructs a new MarshalException with the specified detail message.
        参数：
        message - the detail message

      • MarshalException

        public MarshalException(String message,
                Throwable cause)
        Constructs a new MarshalException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • MarshalException

        public MarshalException(Throwable cause)
        Constructs a new MarshalException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Returns the cause of this MarshalException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this MarshalException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this MarshalException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this MarshalException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this MarshalException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this MarshalException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tf/no;m/v


NodeSetData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface NodeSetData

  • All Superinterfaces:
    Data

    public interface NodeSetData
extends Data
    An abstract representation of a Data type containing a node-set. The type (class) and ordering of the nodes contained in the set are not defined by this class; instead that behavior should be defined by NodeSetData subclasses.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Iterator iterator()
      Returns a read-only iterator over the nodes contained in this NodeSetData in document order.

    • 方法详细信息

      • iterator

        Iterator iterator()
        Returns a read-only iterator over the nodes contained in this NodeSetData in document order. Attempts to modify the returned iterator via the remove method throw UnsupportedOperationException.
        返回：
        an Iterator over the nodes in this NodeSetData in document order
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fk=n


NoSuchMechanismException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 NoSuchMechanismException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.crypto.NoSuchMechanismException
  • 所有已实现的接口：
    Serializable

    public class NoSuchMechanismException
extends RuntimeException
    This exception is thrown when a particular XML mechanism is requested but is not available in the environment.

    A NoSuchMechanismException can contain a cause: another throwable that caused this NoSuchMechanismException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.getInstance, KeyInfoFactory.getInstance, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoSuchMechanismException()
      Constructs a new NoSuchMechanismException with null as its detail message.
      NoSuchMechanismException(String message)
      Constructs a new NoSuchMechanismException with the specified detail message.
      NoSuchMechanismException(String message, Throwable cause)
      Constructs a new NoSuchMechanismException with the specified detail message and cause.
      NoSuchMechanismException(Throwable cause)
      Constructs a new NoSuchMechanismException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoSuchMechanismException

        public NoSuchMechanismException()
        Constructs a new NoSuchMechanismException with null as its detail message.

      • NoSuchMechanismException

        public NoSuchMechanismException(String message)
        Constructs a new NoSuchMechanismException with the specified detail message.
        参数：
        message - the detail message

      • NoSuchMechanismException

        public NoSuchMechanismException(String message,
                        Throwable cause)
        Constructs a new NoSuchMechanismException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • NoSuchMechanismException

        public NoSuchMechanismException(Throwable cause)
        Constructs a new NoSuchMechanismException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this NoSuchMechanismException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

afha罯t a&aeRl>ico=拥ehiL/l.snnklpsj/


OctetStreamData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 OctetStreamData

  • java.lang.Object
    • javax.xml.crypto.OctetStreamData
  • 所有已实现的接口：
    Data

    public class OctetStreamData
extends Object
implements Data
    A representation of a Data type containing an octet stream.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      OctetStreamData(InputStream octetStream)
      Creates a new OctetStreamData.
      OctetStreamData(InputStream octetStream, String uri, String mimeType)
      Creates a new OctetStreamData.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getMimeType()
      Returns the MIME type associated with the data object represented by this OctetStreamData.
      InputStream getOctetStream()
      Returns the input stream of this OctetStreamData.
      String getURI()
      Returns the URI String identifying the data object represented by this OctetStreamData.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OctetStreamData

        public OctetStreamData(InputStream octetStream)
        Creates a new OctetStreamData.
        参数：
        octetStream - the input stream containing the octets
        抛出：
        NullPointerException - if octetStream is null

      • OctetStreamData

        public OctetStreamData(InputStream octetStream,
               String uri,
               String mimeType)
        Creates a new OctetStreamData.
        参数：
        octetStream - the input stream containing the octets
        uri - the URI String identifying the data object (may be null)
        mimeType - the MIME type associated with the data object (may be null)
        抛出：
        NullPointerException - if octetStream is null

    • 方法详细信息

      • getOctetStream

        public InputStream getOctetStream()
        Returns the input stream of this OctetStreamData.
        返回：
        the input stream of this OctetStreamData.

      • getURI

        public String getURI()
        Returns the URI String identifying the data object represented by this OctetStreamData.
        返回：
        the URI String or null if not applicable

      • getMimeType

        public String getMimeType()
        Returns the MIME type associated with the data object represented by this OctetStreamData.
        返回：
        the MIME type or null if not applicable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)e<;>ne&nel<bslpuurn4l.=l


URIDereferencer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface URIDereferencer

  • public interface URIDereferencer
    A dereferencer of URIReferences.

    The result of dereferencing a URIReference is either an instance of OctetStreamData or NodeSetData. Unless the URIReference is a same-document reference as defined in section 4.2 of the W3C Recommendation for XML-Signature Syntax and Processing, the result of dereferencing the URIReference MUST be an OctetStreamData.

    从以下版本开始：
    1.6
    另请参见：
    XMLCryptoContext.setURIDereferencer(URIDereferencer), XMLCryptoContext.getURIDereferencer()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Data dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • 方法详细信息

      • dereference

        Data dereference(URIReference uriReference,
               XMLCryptoContext context)
                 throws URIReferenceException
        Dereferences the specified URIReference and returns the dereferenced data.
        参数：
        uriReference - the URIReference
        context - an XMLCryptoContext that may contain additional useful information for dereferencing the URI. This implementation should dereference the specified URIReference against the context's baseURI parameter, if specified.
        返回：
        the dereferenced data
        抛出：
        NullPointerException - if uriReference or context are null
        URIReferenceException - if an exception occurs while dereferencing the specified uriReference
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s >"C"c""co<


URIReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface URIReference

  • All Known Subinterfaces:
    DOMURIReference, Reference, RetrievalMethod

    public interface URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.

    Note that some subclasses may not have a type attribute and for objects of those types, the getType() method always returns null.

    从以下版本开始：
    1.6
    另请参见：
    URIDereferencer

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getType()
      Returns the type of data referenced by this URI.
      String getURI()
      Returns the URI of the referenced data object.

    • 方法详细信息

      • getURI

        String getURI()
        Returns the URI of the referenced data object.
        返回：
        the URI of the data object in RFC 2396 format (may be null if not specified)

      • getType

        String getType()
        Returns the type of data referenced by this URI.
        返回：
        the type (a URI) of the data object (may be null if not specified)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vl>>c>/>i>t


URIReferenceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto

类 URIReferenceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.URIReferenceException
  • 所有已实现的接口：
    Serializable

    public class URIReferenceException
extends Exception
    Indicates an exceptional condition thrown while dereferencing a URIReference.

    A URIReferenceException can contain a cause: another throwable that caused this URIReferenceException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    URIDereferencer.dereference(URIReference, XMLCryptoContext), RetrievalMethod.dereference(XMLCryptoContext), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      URIReferenceException()
      Constructs a new URIReferenceException with null as its detail message.
      URIReferenceException(String message)
      Constructs a new URIReferenceException with the specified detail message.
      URIReferenceException(String message, Throwable cause)
      Constructs a new URIReferenceException with the specified detail message and cause.
      URIReferenceException(String message, Throwable cause, URIReference uriReference)
      Constructs a new URIReferenceException with the specified detail message, cause and URIReference.
      URIReferenceException(Throwable cause)
      Constructs a new URIReferenceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown.
      URIReference getURIReference()
      Returns the URIReference that was being dereferenced when the exception was thrown.
      void printStackTrace()
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • URIReferenceException

        public URIReferenceException()
        Constructs a new URIReferenceException with null as its detail message.

      • URIReferenceException

        public URIReferenceException(String message)
        Constructs a new URIReferenceException with the specified detail message.
        参数：
        message - the detail message

      • URIReferenceException

        public URIReferenceException(String message,
                     Throwable cause)
        Constructs a new URIReferenceException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • URIReferenceException

        public URIReferenceException(String message,
                     Throwable cause,
                     URIReference uriReference)
        Constructs a new URIReferenceException with the specified detail message, cause and URIReference.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        uriReference - the URIReference that was being dereferenced when the error was encountered
        抛出：
        NullPointerException - if uriReference is null

      • URIReferenceException

        public URIReferenceException(Throwable cause)
        Constructs a new URIReferenceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getURIReference

        public URIReference getURIReference()
        Returns the URIReference that was being dereferenced when the exception was thrown.
        返回：
        the URIReference that was being dereferenced when the exception was thrown, or null if not specified

      • getCause

        public Throwable getCause()
        Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this URIReferenceException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this URIReferenceException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/tm/f/=d./.>.


Uses of Package javax.xml.crypto

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto

  • Packages that use javax.xml.crypto
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.
  • Classes in javax.xml.crypto used by javax.xml.crypto
    类与描述
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    KeySelector.Purpose
    The purpose of the key that is to be selected.
    KeySelectorException
    Indicates an exceptional condition thrown by a KeySelector.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dom
    类与描述
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig
    类与描述
    AlgorithmMethod
    An abstract representation of an algorithm defined in the XML Security specifications.
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    KeySelectorResult
    The result returned by the KeySelector.select method.
    MarshalException
    Indicates an exceptional condition that occured during the XML marshalling or unmarshalling process.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.dom
    类与描述
    KeySelector
    A selector that finds and returns a key using the data contained in a KeyInfo object.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.keyinfo
    类与描述
    Data
    An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
    MarshalException
    Indicates an exceptional condition that occured during the XML marshalling or unmarshalling process.
    URIDereferencer
    A dereferencer of URIReferences.
    URIReference
    Identifies a data object via a URI-Reference, as specified by RFC 2396.
    URIReferenceException
    Indicates an exceptional condition thrown while dereferencing a URIReference.
    XMLCryptoContext
    Contains common context information for XML cryptographic operations.
    XMLStructure
    A representation of an XML structure from any namespace.
  • Classes in javax.xml.crypto used by javax.xml.crypto.dsig.spec
    类与描述
    XMLStructure
    A representation of an XML structure from any namespace.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bsr


XMLCryptoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface XMLCryptoContext

  • All Known Subinterfaces:
    XMLSignContext, XMLValidateContext
    All Known Implementing Classes:
    DOMCryptoContext, DOMSignContext, DOMValidateContext

    public interface XMLCryptoContext
    Contains common context information for XML cryptographic operations.

    This interface contains methods for setting and retrieving properties that affect the processing of XML signatures or XML encrypted structures.

    Note that XMLCryptoContext instances can contain information and state specific to the XML cryptographic structure it is used with. The results are unpredictable if an XMLCryptoContext is used with multiple structures (for example, you should not use the same XMLValidateContext instance to validate two different XMLSignature objects).

    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object get(Object key)
      Returns the value to which this context maps the specified key.
      String getBaseURI()
      Returns the base URI.
      String getDefaultNamespacePrefix()
      Returns the default namespace prefix.
      KeySelector getKeySelector()
      Returns the key selector for finding a key.
      String getNamespacePrefix(String namespaceURI, String defaultPrefix)
      Returns the namespace prefix that the specified namespace URI is associated with.
      Object getProperty(String name)
      Returns the value of the specified property.
      URIDereferencer getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Object put(Object key, Object value)
      Associates the specified value with the specified key in this context.
      String putNamespacePrefix(String namespaceURI, String prefix)
      Maps the specified namespace URI to the specified prefix.
      void setBaseURI(String baseURI)
      Sets the base URI.
      void setDefaultNamespacePrefix(String defaultPrefix)
      Sets the default namespace prefix.
      void setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.
      Object setProperty(String name, Object value)
      Sets the specified property.
      void setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

    • 方法详细信息

      • getBaseURI

        String getBaseURI()
        Returns the base URI.
        返回：
        the base URI, or null if not specified
        另请参见：
        setBaseURI(String)

      • setBaseURI

        void setBaseURI(String baseURI)
        Sets the base URI.
        参数：
        baseURI - the base URI, or null to remove current value
        抛出：
        IllegalArgumentException - if baseURI is not RFC 2396 compliant
        另请参见：
        getBaseURI()

      • getKeySelector

        KeySelector getKeySelector()
        Returns the key selector for finding a key.
        返回：
        the key selector, or null if not specified
        另请参见：
        setKeySelector(KeySelector)

      • setKeySelector

        void setKeySelector(KeySelector ks)
        Sets the key selector for finding a key.
        参数：
        ks - the key selector, or null to remove the current setting
        另请参见：
        getKeySelector()

      • getURIDereferencer

        URIDereferencer getURIDereferencer()
        Returns a URIDereferencer that is used to dereference URIReferences.
        返回：
        the URIDereferencer, or null if not specified
        另请参见：
        setURIDereferencer(URIDereferencer)

      • setURIDereferencer

        void setURIDereferencer(URIDereferencer dereferencer)
        Sets a URIDereferencer that is used to dereference URIReferences. The specified URIDereferencer is used in place of an implementation's default URIDereferencer.
        参数：
        dereferencer - the URIDereferencer, or null to remove any current setting
        另请参见：
        getURIDereferencer()

      • getNamespacePrefix

        String getNamespacePrefix(String namespaceURI,
                        String defaultPrefix)
        Returns the namespace prefix that the specified namespace URI is associated with. Returns the specified default prefix if the specified namespace URI has not been bound to a prefix. To bind a namespace URI to a prefix, call the putNamespacePrefix method.
        参数：
        namespaceURI - a namespace URI
        defaultPrefix - the prefix to be returned in the event that the the specified namespace URI has not been bound to a prefix.
        返回：
        the prefix that is associated with the specified namespace URI, or defaultPrefix if the URI is not registered. If the namespace URI is registered but has no prefix, an empty string ("") is returned.
        抛出：
        NullPointerException - if namespaceURI is null
        另请参见：
        putNamespacePrefix(String, String)

      • putNamespacePrefix

        String putNamespacePrefix(String namespaceURI,
                        String prefix)
        Maps the specified namespace URI to the specified prefix. If there is already a prefix associated with the specified namespace URI, the old prefix is replaced by the specified prefix.
        参数：
        namespaceURI - a namespace URI
        prefix - a namespace prefix (or null to remove any existing mapping). Specifying the empty string ("") binds no prefix to the namespace URI.
        返回：
        the previous prefix associated with the specified namespace URI, or null if there was none
        抛出：
        NullPointerException - if namespaceURI is null
        另请参见：
        getNamespacePrefix(String, String)

      • getDefaultNamespacePrefix

        String getDefaultNamespacePrefix()
        Returns the default namespace prefix. The default namespace prefix is the prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        返回：
        the default namespace prefix, or null if none has been set.
        另请参见：
        setDefaultNamespacePrefix(String)

      • setDefaultNamespacePrefix

        void setDefaultNamespacePrefix(String defaultPrefix)
        Sets the default namespace prefix. This sets the namespace prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        参数：
        defaultPrefix - the default namespace prefix, or null to remove the current setting. Specify the empty string ("") to bind no prefix.
        另请参见：
        getDefaultNamespacePrefix()

      • setProperty

        Object setProperty(String name,
                 Object value)
        Sets the specified property.
        参数：
        name - the name of the property
        value - the value of the property to be set
        返回：
        the previous value of the specified property, or null if it did not have a value
        抛出：
        NullPointerException - if name is null
        另请参见：
        getProperty(String)

      • getProperty

        Object getProperty(String name)
        Returns the value of the specified property.
        参数：
        name - the name of the property
        返回：
        the current value of the specified property, or null if it does not have a value
        抛出：
        NullPointerException - if name is null
        另请参见：
        setProperty(String, Object)

      • get

        Object get(Object key)
        Returns the value to which this context maps the specified key.

        More formally, if this context contains a mapping from a key k to a value v such that (key==null ? k==null : key.equals(k)), then this method returns v; otherwise it returns null. (There can be at most one such mapping.)

        This method is useful for retrieving arbitrary information that is specific to the cryptographic operation that this context is used for.

        参数：
        key - the key whose associated value is to be returned
        返回：
        the value to which this context maps the specified key, or null if there is no mapping for the key
        另请参见：
        put(Object, Object)

      • put

        Object put(Object key,
         Object value)
        Associates the specified value with the specified key in this context. If the context previously contained a mapping for this key, the old value is replaced by the specified value.

        This method is useful for storing arbitrary information that is specific to the cryptographic operation that this context is used for.

        参数：
        key - key with which the specified value is to be associated with
        value - value to be associated with the specified key
        返回：
        the previous value associated with the key, or null if there was no mapping for the key
        抛出：
        IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this context
        另请参见：
        get(Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn.g>鹵eg


XMLStructure

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto

Interface XMLStructure

  • All Known Subinterfaces:
    CanonicalizationMethod, DigestMethod, KeyInfo, KeyName, KeyValue, Manifest, PGPData, Reference, RetrievalMethod, SignatureMethod, SignatureProperties, SignatureProperty, SignedInfo, Transform, X509Data, X509IssuerSerial, XMLObject, XMLSignature, XMLSignature.SignatureValue
    All Known Implementing Classes:
    DOMStructure, TransformService

    public interface XMLStructure
    A representation of an XML structure from any namespace. The purpose of this interface is to group (and provide type safety for) all representations of XML structures.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.

    • 方法详细信息

      • isFeatureSupported

        boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        参数：
        feature - the feature name (as an absolute URI)
        返回：
        true if the specified feature is supported, false otherwise
        抛出：
        NullPointerException - if feature is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cilals="lli)ic<


Uses of Class javax.xml.crypto.KeySelector

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.KeySelector

  • Packages that use KeySelector
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of KeySelector in javax.xml.crypto

      Methods in javax.xml.crypto that return KeySelector
      修饰符与类型 方法与描述
      KeySelector XMLCryptoContext.getKeySelector()
      Returns the key selector for finding a key.
      static KeySelector KeySelector.singletonKeySelector(Key key)
      Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.
      Methods in javax.xml.crypto with parameters of type KeySelector
      修饰符与类型 方法与描述
      void XMLCryptoContext.setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.

    • Uses of KeySelector in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return KeySelector
      修饰符与类型 | 方法与描述
      KeySelector | DOMCryptoContext.getKeySelector()
      Methods in javax.xml.crypto.dom with parameters of type KeySelector
      修饰符与类型 | 方法与描述
      void | DOMCryptoContext.setKeySelector(KeySelector ks)

    • Uses of KeySelector in javax.xml.crypto.dsig.dom

      Constructors in javax.xml.crypto.dsig.dom with parameters of type KeySelector
      构造方法与描述
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/ldell0""""eb//cp-/=.//ax


Uses of Class javax.xml.crypto.KeySelector.Purpose

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.KeySelector.Purpose

  • Packages that use KeySelector.Purpose
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.

    • Uses of KeySelector.Purpose in javax.xml.crypto

      Fields in javax.xml.crypto declared as KeySelector.Purpose
      修饰符与类型 字段与描述
      static KeySelector.Purpose KeySelector.Purpose.DECRYPT
      A key for decrypting.
      static KeySelector.Purpose KeySelector.Purpose.ENCRYPT
      A key for encrypting.
      static KeySelector.Purpose KeySelector.Purpose.SIGN
      A key for signing.
      static KeySelector.Purpose KeySelector.Purpose.VERIFY
      A key for verifying.
      Methods in javax.xml.crypto with parameters of type KeySelector.Purpose
      修饰符与类型 方法与描述
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h,rt/a>etxxxC>cctCeolteeya


Uses of Class javax.xml.crypto.KeySelectorException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.KeySelectorException

  • Packages that use KeySelectorException
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.

    • Uses of KeySelectorException in javax.xml.crypto

      Methods in javax.xml.crypto that throw KeySelectorException
      修饰符与类型 方法与描述
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p=-h/a>-->>> mnnTAT TV Bm


Uses of Class javax.xml.crypto.MarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.MarshalException

  • Packages that use MarshalException
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of MarshalException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw MarshalException
      修饰符与类型 方法与描述
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.

    • Uses of MarshalException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw MarshalException
      修饰符与类型 方法与描述
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l".!im


Uses of Class javax.xml.crypto.NoSuchMechanismException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.NoSuchMechanismException

No usage of javax.xml.crypto.NoSuchMechanismException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t d/i�,$&r


Uses of Class javax.xml.crypto.OctetStreamData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.OctetStreamData

No usage of javax.xml.crypto.OctetStreamData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆ �<


Uses of Class javax.xml.crypto.URIReferenceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.URIReferenceException

  • Packages that use URIReferenceException
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIReferenceException in javax.xml.crypto

      Methods in javax.xml.crypto that throw URIReferenceException
      修饰符与类型 方法与描述
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • Uses of URIReferenceException in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that throw URIReferenceException
      修饰符与类型 方法与描述
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e >rRIRdoeee>.ii/ea.jmx.e


Uses of Interface javax.xml.crypto.AlgorithmMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.AlgorithmMethod

  • Packages that use AlgorithmMethod
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of AlgorithmMethod in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type AlgorithmMethod
      修饰符与类型 方法与描述
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of AlgorithmMethod in javax.xml.crypto.dsig

      Subinterfaces of AlgorithmMethod in javax.xml.crypto.dsig
      修饰符与类型 Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  DigestMethod
      A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureMethod
      A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Transform
      A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement AlgorithmMethod
      修饰符与类型 类与描述
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt羖< <>


Uses of Interface javax.xml.crypto.Data

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.Data

  • Packages that use Data
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of Data in javax.xml.crypto

      Subinterfaces of Data in javax.xml.crypto
      修饰符与类型 Interface and Description
      interface  NodeSetData
      An abstract representation of a Data type containing a node-set.
      Classes in javax.xml.crypto that implement Data
      修饰符与类型 类与描述
      class  OctetStreamData
      A representation of a Data type containing an octet stream.
      Methods in javax.xml.crypto that return Data
      修饰符与类型 方法与描述
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.

    • Uses of Data in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Data
      修饰符与类型 方法与描述
      Data Reference.getDereferencedData()
      Returns the dereferenced data, if reference caching is enabled.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.
      Methods in javax.xml.crypto.dsig with parameters of type Data
      修饰符与类型 方法与描述
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

    • Uses of Data in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return Data
      修饰符与类型 方法与描述
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

meebcees"cc=Lll--/="!bi-


Uses of Interface javax.xml.crypto.KeySelectorResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.KeySelectorResult

  • Packages that use KeySelectorResult
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of KeySelectorResult in javax.xml.crypto

      Methods in javax.xml.crypto that return KeySelectorResult
      修饰符与类型 方法与描述
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of KeySelectorResult in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeySelectorResult
      修饰符与类型 方法与描述
      KeySelectorResult XMLSignature.getKeySelectorResult()
      Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=flon le">


Uses of Interface javax.xml.crypto.NodeSetData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.NodeSetData

No usage of javax.xml.crypto.NodeSetData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..xeter=e"""i.XXass


Uses of Interface javax.xml.crypto.URIDereferencer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.URIDereferencer

  • Packages that use URIDereferencer
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIDereferencer in javax.xml.crypto

      Methods in javax.xml.crypto that return URIDereferencer
      修饰符与类型 方法与描述
      URIDereferencer XMLCryptoContext.getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Methods in javax.xml.crypto with parameters of type URIDereferencer
      修饰符与类型 方法与描述
      void XMLCryptoContext.setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

    • Uses of URIDereferencer in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return URIDereferencer
      修饰符与类型 | 方法与描述
      URIDereferencer | DOMCryptoContext.getURIDereferencer()
      Methods in javax.xml.crypto.dom with parameters of type URIDereferencer
      修饰符与类型 | 方法与描述
      void | DOMCryptoContext.setURIDereferencer(URIDereferencer dereferencer)

    • Uses of URIDereferencer in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return URIDereferencer
      修饰符与类型 方法与描述
      abstract URIDereferencer XMLSignatureFactory.getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.

    • Uses of URIDereferencer in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return URIDereferencer
      修饰符与类型 方法与描述
      abstract URIDereferencer KeyInfoFactory.getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/wav猘asrie.<<>>C�.


Uses of Interface javax.xml.crypto.URIReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.URIReference

  • Packages that use URIReference
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of URIReference in javax.xml.crypto

      Methods in javax.xml.crypto that return URIReference
      修饰符与类型 方法与描述
      URIReference URIReferenceException.getURIReference()
      Returns the URIReference that was being dereferenced when the exception was thrown.
      Methods in javax.xml.crypto with parameters of type URIReference
      修饰符与类型 方法与描述
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.
      Constructors in javax.xml.crypto with parameters of type URIReference
      构造方法与描述
      URIReferenceException(String message, Throwable cause, URIReference uriReference)
      Constructs a new URIReferenceException with the specified detail message, cause and URIReference.

    • Uses of URIReference in javax.xml.crypto.dom

      Subinterfaces of URIReference in javax.xml.crypto.dom
      修饰符与类型 Interface and Description
      interface  DOMURIReference
      A DOM-specific URIReference.

    • Uses of URIReference in javax.xml.crypto.dsig

      Subinterfaces of URIReference in javax.xml.crypto.dsig
      修饰符与类型 Interface and Description
      interface  Reference
      A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

    • Uses of URIReference in javax.xml.crypto.dsig.keyinfo

      Subinterfaces of URIReference in javax.xml.crypto.dsig.keyinfo
      修饰符与类型 Interface and Description
      interface  RetrievalMethod
      A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;g #/ 0 >#09920&�9r◆�//╯


Uses of Interface javax.xml.crypto.XMLCryptoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.XMLCryptoContext

  • Packages that use XMLCryptoContext
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of XMLCryptoContext in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type XMLCryptoContext
      修饰符与类型 方法与描述
      Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
      Dereferences the specified URIReference and returns the dereferenced data.
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of XMLCryptoContext in javax.xml.crypto.dom

      Classes in javax.xml.crypto.dom that implement XMLCryptoContext
      修饰符与类型 类与描述
      class  DOMCryptoContext
      This class provides a DOM-specific implementation of the XMLCryptoContext interface.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig

      Subinterfaces of XMLCryptoContext in javax.xml.crypto.dsig
      修饰符与类型 Interface and Description
      interface  XMLSignContext
      Contains context information for generating XML Signatures.
      interface  XMLValidateContext
      Contains context information for validating XML Signatures.
      Methods in javax.xml.crypto.dsig with parameters of type XMLCryptoContext
      修饰符与类型 方法与描述
      abstract void TransformService.init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLCryptoContext
      修饰符与类型 类与描述
      class  DOMSignContext
      A DOM-specific XMLSignContext.
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.

    • Uses of XMLCryptoContext in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type XMLCryptoContext
      修饰符与类型 方法与描述
      Data RetrievalMethod.dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sac.al/.>aitrg


Uses of Interface javax.xml.crypto.XMLStructure

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.XMLStructure

  • Packages that use XMLStructure
    软件包 描述
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of XMLStructure in javax.xml.crypto.dom

      Classes in javax.xml.crypto.dom that implement XMLStructure
      修饰符与类型 类与描述
      class  DOMStructure
      A DOM-specific XMLStructure.

    • Uses of XMLStructure in javax.xml.crypto.dsig

      Subinterfaces of XMLStructure in javax.xml.crypto.dsig
      修饰符与类型 Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  DigestMethod
      A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Manifest
      A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Reference
      A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureMethod
      A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureProperties
      A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignatureProperty
      A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  SignedInfo
      An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  Transform
      A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  XMLObject
      A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  XMLSignature
      A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      static interface  XMLSignature.SignatureValue
      A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement XMLStructure
      修饰符与类型 类与描述
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
      Methods in javax.xml.crypto.dsig with parameters of type XMLStructure
      修饰符与类型 方法与描述
      abstract void TransformService.init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.

    • Uses of XMLStructure in javax.xml.crypto.dsig.keyinfo

      Subinterfaces of XMLStructure in javax.xml.crypto.dsig.keyinfo
      修饰符与类型 Interface and Description
      interface  KeyInfo
      A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  KeyName
      A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  KeyValue
      A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  PGPData
      A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  RetrievalMethod
      A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  X509Data
      A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      interface  X509IssuerSerial
      A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Methods in javax.xml.crypto.dsig.keyinfo with parameters of type XMLStructure
      修饰符与类型 方法与描述
      void KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.

    • Uses of XMLStructure in javax.xml.crypto.dsig.spec

      Methods in javax.xml.crypto.dsig.spec that return XMLStructure
      修饰符与类型 方法与描述
      XMLStructure XSLTTransformParameterSpec.getStylesheet()
      Returns the stylesheet.
      Constructors in javax.xml.crypto.dsig.spec with parameters of type XMLStructure
      构造方法与描述
      XSLTTransformParameterSpec(XMLStructure stylesheet)
      Creates an XSLTTransformParameterSpec with the specified stylesheet.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/I鹐 "idex/餽鰋讼aDf汝詓<


DOMCryptoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dom

类 DOMCryptoContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
  • 所有已实现的接口：
    XMLCryptoContext
    直接已知子类：
    DOMSignContext, DOMValidateContext

    public class DOMCryptoContext
extends Object
implements XMLCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface. It also includes additional methods that are specific to a DOM-based implementation for registering and retrieving elements that contain attributes of type ID.
    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DOMCryptoContext()
      Default constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object get(Object key)
      This implementation uses an internal HashMap to get the object that the specified key maps to.
      String getBaseURI()
      Returns the base URI.
      String getDefaultNamespacePrefix()
      Returns the default namespace prefix.
      Element getElementById(String idValue)
      Returns the Element with the specified ID attribute value.
      KeySelector getKeySelector()
      Returns the key selector for finding a key.
      String getNamespacePrefix(String namespaceURI, String defaultPrefix)
      This implementation uses an internal HashMap to get the prefix that the specified URI maps to.
      Object getProperty(String name)
      This implementation uses an internal HashMap to get the object that the specified name maps to.
      URIDereferencer getURIDereferencer()
      Returns a URIDereferencer that is used to dereference URIReferences.
      Iterator iterator()
      Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext.
      Object put(Object key, Object value)
      This implementation uses an internal HashMap to map the key to the specified object.
      String putNamespacePrefix(String namespaceURI, String prefix)
      This implementation uses an internal HashMap to map the URI to the specified prefix.
      void setBaseURI(String baseURI)
      Sets the base URI.
      void setDefaultNamespacePrefix(String defaultPrefix)
      Sets the default namespace prefix.
      void setIdAttributeNS(Element element, String namespaceURI, String localName)
      Registers the element's attribute specified by the namespace URI and local name to be of type ID.
      void setKeySelector(KeySelector ks)
      Sets the key selector for finding a key.
      Object setProperty(String name, Object value)
      This implementation uses an internal HashMap to map the name to the specified object.
      void setURIDereferencer(URIDereferencer dereferencer)
      Sets a URIDereferencer that is used to dereference URIReferences.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DOMCryptoContext

        protected DOMCryptoContext()
        Default constructor. (For invocation by subclass constructors).

    • 方法详细信息

      • getNamespacePrefix

        public String getNamespacePrefix(String namespaceURI,
                        String defaultPrefix)
        This implementation uses an internal HashMap to get the prefix that the specified URI maps to. It returns the defaultPrefix if it maps to null.
        指定者：
        getNamespacePrefix in interface XMLCryptoContext
        参数：
        namespaceURI - a namespace URI
        defaultPrefix - the prefix to be returned in the event that the the specified namespace URI has not been bound to a prefix.
        返回：
        the prefix that is associated with the specified namespace URI, or defaultPrefix if the URI is not registered. If the namespace URI is registered but has no prefix, an empty string ("") is returned.
        抛出：
        NullPointerException - if namespaceURI is null
        另请参见：
        XMLCryptoContext.putNamespacePrefix(String, String)

      • putNamespacePrefix

        public String putNamespacePrefix(String namespaceURI,
                        String prefix)
        This implementation uses an internal HashMap to map the URI to the specified prefix.
        指定者：
        putNamespacePrefix in interface XMLCryptoContext
        参数：
        namespaceURI - a namespace URI
        prefix - a namespace prefix (or null to remove any existing mapping). Specifying the empty string ("") binds no prefix to the namespace URI.
        返回：
        the previous prefix associated with the specified namespace URI, or null if there was none
        抛出：
        NullPointerException - if namespaceURI is null
        另请参见：
        XMLCryptoContext.getNamespacePrefix(String, String)

      • getDefaultNamespacePrefix

        public String getDefaultNamespacePrefix()
        从接口复制的描述： XMLCryptoContext
        Returns the default namespace prefix. The default namespace prefix is the prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        指定者：
        getDefaultNamespacePrefix in interface XMLCryptoContext
        返回：
        the default namespace prefix, or null if none has been set.
        另请参见：
        XMLCryptoContext.setDefaultNamespacePrefix(String)

      • setDefaultNamespacePrefix

        public void setDefaultNamespacePrefix(String defaultPrefix)
        从接口复制的描述： XMLCryptoContext
        Sets the default namespace prefix. This sets the namespace prefix for all namespace URIs not explicitly set by the putNamespacePrefix method.
        指定者：
        setDefaultNamespacePrefix in interface XMLCryptoContext
        参数：
        defaultPrefix - the default namespace prefix, or null to remove the current setting. Specify the empty string ("") to bind no prefix.
        另请参见：
        XMLCryptoContext.getDefaultNamespacePrefix()

      • getBaseURI

        public String getBaseURI()
        从接口复制的描述： XMLCryptoContext
        Returns the base URI.
        指定者：
        getBaseURI in interface XMLCryptoContext
        返回：
        the base URI, or null if not specified
        另请参见：
        XMLCryptoContext.setBaseURI(String)

      • setBaseURI

        public void setBaseURI(String baseURI)
        从接口复制的描述： XMLCryptoContext
        Sets the base URI.
        指定者：
        setBaseURI in interface XMLCryptoContext
        参数：
        baseURI - the base URI, or null to remove current value
        抛出：
        IllegalArgumentException - if baseURI is not RFC 2396 compliant
        另请参见：
        XMLCryptoContext.getBaseURI()

      • getURIDereferencer

        public URIDereferencer getURIDereferencer()
        从接口复制的描述： XMLCryptoContext
        Returns a URIDereferencer that is used to dereference URIReferences.
        指定者：
        getURIDereferencer in interface XMLCryptoContext
        返回：
        the URIDereferencer, or null if not specified
        另请参见：
        XMLCryptoContext.setURIDereferencer(URIDereferencer)

      • setURIDereferencer

        public void setURIDereferencer(URIDereferencer dereferencer)
        从接口复制的描述： XMLCryptoContext
        Sets a URIDereferencer that is used to dereference URIReferences. The specified URIDereferencer is used in place of an implementation's default URIDereferencer.
        指定者：
        setURIDereferencer in interface XMLCryptoContext
        参数：
        dereferencer - the URIDereferencer, or null to remove any current setting
        另请参见：
        XMLCryptoContext.getURIDereferencer()

      • getProperty

        public Object getProperty(String name)
        This implementation uses an internal HashMap to get the object that the specified name maps to.
        指定者：
        getProperty in interface XMLCryptoContext
        参数：
        name - the name of the property
        返回：
        the current value of the specified property, or null if it does not have a value
        抛出：
        NullPointerException - if name is null
        另请参见：
        XMLCryptoContext.setProperty(String, Object)

      • setProperty

        public Object setProperty(String name,
                 Object value)
        This implementation uses an internal HashMap to map the name to the specified object.
        指定者：
        setProperty in interface XMLCryptoContext
        参数：
        name - the name of the property
        value - the value of the property to be set
        返回：
        the previous value of the specified property, or null if it did not have a value
        抛出：
        NullPointerException - if name is null
        另请参见：
        XMLCryptoContext.getProperty(String)

      • getKeySelector

        public KeySelector getKeySelector()
        从接口复制的描述： XMLCryptoContext
        Returns the key selector for finding a key.
        指定者：
        getKeySelector in interface XMLCryptoContext
        返回：
        the key selector, or null if not specified
        另请参见：
        XMLCryptoContext.setKeySelector(KeySelector)

      • setKeySelector

        public void setKeySelector(KeySelector ks)
        从接口复制的描述： XMLCryptoContext
        Sets the key selector for finding a key.
        指定者：
        setKeySelector in interface XMLCryptoContext
        参数：
        ks - the key selector, or null to remove the current setting
        另请参见：
        XMLCryptoContext.getKeySelector()

      • getElementById

        public Element getElementById(String idValue)
        Returns the Element with the specified ID attribute value.

        This implementation uses an internal HashMap to get the element that the specified attribute value maps to.

        参数：
        idValue - the value of the ID
        返回：
        the Element with the specified ID attribute value, or null if none.
        抛出：
        NullPointerException - if idValue is null
        另请参见：
        setIdAttributeNS(org.w3c.dom.Element, java.lang.String, java.lang.String)

      • setIdAttributeNS

        public void setIdAttributeNS(Element element,
                    String namespaceURI,
                    String localName)
        Registers the element's attribute specified by the namespace URI and local name to be of type ID. The attribute must have a non-empty value.

        This implementation uses an internal HashMap to map the attribute's value to the specified element.

        参数：
        element - the element
        namespaceURI - the namespace URI of the attribute (specify null if not applicable)
        localName - the local name of the attribute
        抛出：
        IllegalArgumentException - if localName is not an attribute of the specified element or it does not contain a specific value
        NullPointerException - if element or localName is null
        另请参见：
        getElementById(java.lang.String)

      • iterator

        public Iterator iterator()
        Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext. Attempts to modify the set via the Iterator.remove() method throw an UnsupportedOperationException. The mappings are returned in no particular order. Each element in the iteration is represented as a Map.Entry. If the DOMCryptoContext is modified while an iteration is in progress, the results of the iteration are undefined.
        返回：
        a read-only iterator over the set of mappings

      • get

        public Object get(Object key)
        This implementation uses an internal HashMap to get the object that the specified key maps to.
        指定者：
        get in interface XMLCryptoContext
        参数：
        key - the key whose associated value is to be returned
        返回：
        the value to which this context maps the specified key, or null if there is no mapping for the key
        另请参见：
        XMLCryptoContext.put(Object, Object)

      • put

        public Object put(Object key,
         Object value)
        This implementation uses an internal HashMap to map the key to the specified object.
        指定者：
        put in interface XMLCryptoContext
        参数：
        key - key with which the specified value is to be associated with
        value - value to be associated with the specified key
        返回：
        the previous value associated with the key, or null if there was no mapping for the key
        抛出：
        IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this context
        另请参见：
        XMLCryptoContext.get(Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DOMStructure

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dom

类 DOMStructure

  • java.lang.Object
    • javax.xml.crypto.dom.DOMStructure
  • 所有已实现的接口：
    XMLStructure

    public class DOMStructure
extends Object
implements XMLStructure
    A DOM-specific XMLStructure. The purpose of this class is to allow a DOM node to be used to represent extensible content (any elements or mixed content) in XML Signature structures.

    If a sequence of nodes is needed, the node contained in the DOMStructure is the first node of the sequence and successive nodes can be accessed by invoking Node.getNextSibling().

    If the owner document of the DOMStructure is different than the target document of an XMLSignature, the XMLSignature.sign(XMLSignContext) method imports the node into the target document before generating the signature.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMStructure(Node node)
      Creates a DOMStructure containing the specified node.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getNode()
      Returns the node contained in this DOMStructure.
      boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DOMStructure

        public DOMStructure(Node node)
        Creates a DOMStructure containing the specified node.
        参数：
        node - the node
        抛出：
        NullPointerException - if node is null

    • 方法详细信息

      • getNode

        public Node getNode()
        Returns the node contained in this DOMStructure.
        返回：
        the node

      • isFeatureSupported

        public boolean isFeatureSupported(String feature)
        从接口复制的描述： XMLStructure
        Indicates whether a specified feature is supported.
        指定者：
        isFeatureSupported in interface XMLStructure
        参数：
        feature - the feature name (as an absolute URI)
        返回：
        true if the specified feature is supported, false otherwise
        抛出：
        NullPointerException - if feature is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lr"S/ajlaj/a/.//.= ttint "ijnagi l /lmSna


DOMURIReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dom

Interface DOMURIReference

  • All Superinterfaces:
    URIReference

    public interface DOMURIReference
extends URIReference
    A DOM-specific URIReference. The purpose of this class is to provide additional context necessary for resolving XPointer URIs or same-document references.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getHere()
      Returns the here node.

      • 方法 - 继承于接口 javax.xml.crypto.URIReference

        getType, getURI

    • 方法详细信息

      • getHere

        Node getHere()
        Returns the here node.
        返回：
        the attribute or processing instruction node or the parent element of the text node that directly contains the URI
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oSM>SrOObaSd


javax.xml.crypto.dom

Interfaces

  • DOMURIReference

Classes

  • DOMCryptoContext
  • DOMStructure
s


javax.xml.crypto.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto.dom

DOM-specific classes for the javax.xml.crypto package.

请参见： 描述

  • 接口摘要
    接口 描述
    DOMURIReference
    A DOM-specific URIReference.
  • Class Summary
    类 描述
    DOMCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface.
    DOMStructure
    A DOM-specific XMLStructure.

软件包 javax.xml.crypto.dom Description

DOM-specific classes for the javax.xml.crypto package. Only users who are using a DOM-based XML cryptographic implementations (ex: XMLSignatureFactory or KeyInfoFactory) should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<= u<<> >!=E=!<oski �


javax.xml.crypto.dom Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto.dom

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)

Interface Hierarchy

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.//rl < llll�-->erruh


Uses of Package javax.xml.crypto.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto.dom

  • Packages that use javax.xml.crypto.dom
    软件包 描述
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
  • Classes in javax.xml.crypto.dom used by javax.xml.crypto.dsig.dom
    类与描述
    DOMCryptoContext
    This class provides a DOM-specific implementation of the XMLCryptoContext interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>teea(slsex/eata


Uses of Class javax.xml.crypto.dom.DOMCryptoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dom.DOMCryptoContext

  • Packages that use DOMCryptoContext
    软件包 描述
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of DOMCryptoContext in javax.xml.crypto.dsig.dom

      Subclasses of DOMCryptoContext in javax.xml.crypto.dsig.dom
      修饰符与类型 类与描述
      class  DOMSignContext
      A DOM-specific XMLSignContext.
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v/#evdir/a礽m


Uses of Class javax.xml.crypto.dom.DOMStructure

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dom.DOMStructure

No usage of javax.xml.crypto.dom.DOMStructure
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dloyxmlvaaaan"hh rj.m


Uses of Interface javax.xml.crypto.dom.DOMURIReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dom.DOMURIReference

No usage of javax.xml.crypto.dom.DOMURIReference
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

MoaR> f d�/turalMs薳


CanonicalizationMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface CanonicalizationMethod

  • All Superinterfaces:
    AlgorithmMethod, Transform, XMLStructure

    public interface CanonicalizationMethod
extends Transform
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>
     <complexType name="CanonicalizationMethodType" mixed="true">
       <sequence>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A CanonicalizationMethod instance may be created by invoking the newCanonicalizationMethod method of the XMLSignatureFactory class.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newCanonicalizationMethod(String, C14NMethodParameterSpec)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String EXCLUSIVE
      The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
      static String EXCLUSIVE_WITH_COMMENTS
      The Exclusive Canonical XML with comments canonicalization method algorithm URI.
      static String INCLUSIVE
      The Canonical XML (without comments) canonicalization method algorithm URI.
      static String INCLUSIVE_WITH_COMMENTS
      The Canonical XML with comments canonicalization method algorithm URI.

      • 字段 - 继承于接口 javax.xml.crypto.dsig.Transform

        BASE64, ENVELOPED, XPATH, XPATH2, XSLT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

      • 方法 - 继承于接口 javax.xml.crypto.dsig.Transform

        transform, transform

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

      • 方法 - 继承于接口 javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • 字段详细信息

      • INCLUSIVE

        static final String INCLUSIVE
        The Canonical XML (without comments) canonicalization method algorithm URI.
        另请参见：
        Constant Field Values

      • INCLUSIVE_WITH_COMMENTS

        static final String INCLUSIVE_WITH_COMMENTS
        The Canonical XML with comments canonicalization method algorithm URI.
        另请参见：
        Constant Field Values

      • EXCLUSIVE

        static final String EXCLUSIVE
        The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
        另请参见：
        Constant Field Values

      • EXCLUSIVE_WITH_COMMENTS

        static final String EXCLUSIVE_WITH_COMMENTS
        The Exclusive Canonical XML with comments canonicalization method algorithm URI.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

        The returned parameters can be typecast to a C14NMethodParameterSpec object.

        指定者：
        getParameterSpec in interface AlgorithmMethod
        指定者：
        getParameterSpec in interface Transform
        返回：
        the algorithm-specific input parameters (may be null if not specified)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esbodo


DigestMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface DigestMethod

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure

    public interface DigestMethod
extends XMLStructure, AlgorithmMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="DigestMethod" type="ds:DigestMethodType"/>
     <complexType name="DigestMethodType" mixed="true">
       <sequence>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A DigestMethod instance may be created by invoking the newDigestMethod method of the XMLSignatureFactory class.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newDigestMethod(String, DigestMethodParameterSpec)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String RIPEMD160
      The RIPEMD-160 digest method algorithm URI.
      static String SHA1
      The SHA1 digest method algorithm URI.
      static String SHA256
      The SHA256 digest method algorithm URI.
      static String SHA512
      The SHA512 digest method algorithm URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this DigestMethod.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

      • 方法 - 继承于接口 javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • 字段详细信息

      • SHA1

        static final String SHA1
        The SHA1 digest method algorithm URI.
        另请参见：
        Constant Field Values

      • SHA256

        static final String SHA256
        The SHA256 digest method algorithm URI.
        另请参见：
        Constant Field Values

      • SHA512

        static final String SHA512
        The SHA512 digest method algorithm URI.
        另请参见：
        Constant Field Values

      • RIPEMD160

        static final String RIPEMD160
        The RIPEMD-160 digest method algorithm URI.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this DigestMethod.

        The returned parameters can be typecast to a DigestMethodParameterSpec object.

        指定者：
        getParameterSpec in interface AlgorithmMethod
        返回：
        the algorithm-specific parameters (may be null if not specified)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.ea"afckfe=eree續/l


javax.xml.crypto.dsig

Interfaces

  • CanonicalizationMethod
  • DigestMethod
  • Manifest
  • Reference
  • SignatureMethod
  • SignatureProperties
  • SignatureProperty
  • SignedInfo
  • Transform
  • XMLObject
  • XMLSignature
  • XMLSignature.SignatureValue
  • XMLSignContext
  • XMLValidateContext

Classes

  • TransformService
  • XMLSignatureFactory

Exceptions

  • TransformException
  • XMLSignatureException
�


javax.xml.crypto.dsig

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto.dsig

Classes for generating and validating XML digital signatures.

请参见： 描述

  • 接口摘要
    接口 描述
    CanonicalizationMethod
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    DigestMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Manifest
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Reference
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperties
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperty
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignedInfo
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Transform
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLObject
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature.SignatureValue
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • Class Summary
    类 描述
    TransformService
    A Service Provider Interface for transform and canonicalization algorithms.
    XMLSignatureFactory
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
  • Exception Summary
    Exception 描述
    TransformException
    Indicates an exceptional condition that occured while executing a transform algorithm.
    XMLSignatureException
    Indicates an exceptional condition that occured during the XML signature generation or validation process.

软件包 javax.xml.crypto.dsig Description

Classes for generating and validating XML digital signatures. This package includes classes that represent the core elements defined in the W3C XML digital signature specification: XMLSignature, SignedInfo, CanonicalizationMethod, SignatureMethod, Reference, DigestMethod, XMLObject, Manifest, SignatureProperties, and SignatureProperty. KeyInfo types are defined in the javax.xml.crypto.dsig.keyinfo subpackage. XMLSignatureFactory is an abstract factory that creates XMLSignature objects from scratch or from a pre-existing XML representation, such as a DOM node. TransformService is a service provider interface for creating and plugging in implementations of transform and canonicalization algorithms.

Of primary significance in this package is the XMLSignature class, which allows you to sign and validate an XML digital signature.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iadgi<


javax.xml.crypto.dsig Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto.dsig

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.dsig.TransformException
        • javax.xml.crypto.dsig.XMLSignatureException
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • javax.xml.crypto.dsig.XMLSignatureFactory

Interface Hierarchy

  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>eOoX<>cccir fappbs


Manifest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface Manifest

  • All Superinterfaces:
    XMLStructure

    public interface Manifest
extends XMLStructure
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

 <element name="Manifest" type="ds:ManifestType"/>
   <complexType name="ManifestType">
     <sequence>
       <element ref="ds:Reference" maxOccurs="unbounded"/>
     </sequence>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A Manifest instance may be created by invoking one of the newManifest methods of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   List references = Collections.singletonList(factory.newReference
       ("#reference-1", DigestMethod.SHA1));
   Manifest manifest = factory.newManifest(references, "manifest-1");
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newManifest(List), XMLSignatureFactory.newManifest(List, String)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String TYPE
      URI that identifies the Manifest element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getId()
      Returns the Id of this Manifest.
      List getReferences()
      Returns an unmodifiable list of one or more References that are contained in this Manifest.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • TYPE

        static final String TYPE
        URI that identifies the Manifest element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getId

        String getId()
        Returns the Id of this Manifest.
        返回：
        the Id of this Manifest (or null if not specified)

      • getReferences

        List getReferences()
        Returns an unmodifiable list of one or more References that are contained in this Manifest.
        返回：
        an unmodifiable list of one or more References
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raeiii/


Reference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface Reference

  • All Superinterfaces:
    URIReference, XMLStructure

    public interface Reference
extends URIReference, XMLStructure
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML schema is defined as:
     <element name="Reference" type="ds:ReferenceType"/>
 <complexType name="ReferenceType">
   <sequence>
     <element ref="ds:Transforms" minOccurs="0"/>
     <element ref="ds:DigestMethod"/>
     <element ref="ds:DigestValue"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
   <attribute name="URI" type="anyURI" use="optional"/>
   <attribute name="Type" type="anyURI" use="optional"/>
 </complexType>

 <element name="DigestValue" type="ds:DigestValueType"/>
 <simpleType name="DigestValueType">
   <restriction base="base64Binary"/>
 </simpleType>

    A Reference instance may be created by invoking one of the newReference methods of the XMLSignatureFactory class; for example:

       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   Reference ref = factory.newReference
     ("http://www.ietf.org/rfc/rfc3275.txt",
      factory.newDigestMethod(DigestMethod.SHA1, null));
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newReference(String, DigestMethod), XMLSignatureFactory.newReference(String, DigestMethod, List, String, String)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] getCalculatedDigestValue()
      Returns the calculated digest value of this Reference after a validation operation.
      Data getDereferencedData()
      Returns the dereferenced data, if reference caching is enabled.
      InputStream getDigestInputStream()
      Returns the pre-digested input stream, if reference caching is enabled.
      DigestMethod getDigestMethod()
      Returns the digest method of this Reference.
      byte[] getDigestValue()
      Returns the digest value of this Reference.
      String getId()
      Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.
      List getTransforms()
      Returns an unmodifiable list of Transforms that are contained in this Reference.
      boolean validate(XMLValidateContext validateContext)
      Validates this reference.

      • 方法 - 继承于接口 javax.xml.crypto.URIReference

        getType, getURI

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getTransforms

        List getTransforms()
        Returns an unmodifiable list of Transforms that are contained in this Reference.
        返回：
        an unmodifiable list of Transforms (may be empty but never null)

      • getDigestMethod

        DigestMethod getDigestMethod()
        Returns the digest method of this Reference.
        返回：
        the digest method

      • getId

        String getId()
        Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.
        返回：
        the Id attribute (may be null if not specified)

      • getDigestValue

        byte[] getDigestValue()
        Returns the digest value of this Reference.
        返回：
        the raw digest value, or null if this reference has not been digested yet. Each invocation of this method returns a new clone to protect against subsequent modification.

      • getCalculatedDigestValue

        byte[] getCalculatedDigestValue()
        Returns the calculated digest value of this Reference after a validation operation. This method is useful for debugging if the reference fails to validate.
        返回：
        the calculated digest value, or null if this reference has not been validated yet. Each invocation of this method returns a new clone to protect against subsequent modification.

      • validate

        boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
        Validates this reference. This method verifies the digest of this reference.

        This method only validates the reference the first time it is invoked. On subsequent invocations, it returns a cached result.

        参数：
        validateContext - the validating context
        返回：
        true if this reference was validated successfully; false otherwise
        抛出：
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected exception occurs while validating the reference

      • getDereferencedData

        Data getDereferencedData()
        Returns the dereferenced data, if reference caching is enabled. This is the result of dereferencing the URI of this reference during a validation or generation operation.
        返回：
        the dereferenced data, or null if reference caching is not enabled or this reference has not been generated or validated

      • getDigestInputStream

        InputStream getDigestInputStream()
        Returns the pre-digested input stream, if reference caching is enabled. This is the input to the digest operation during a validation or signing operation.
        返回：
        an input stream containing the pre-digested input, or null if reference caching is not enabled or this reference has not been generated or validated
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

df.C33C"/a/orslan:e t nvt/ee


SignatureMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface SignatureMethod

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure

    public interface SignatureMethod
extends XMLStructure, AlgorithmMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="SignatureMethod" type="ds:SignatureMethodType"/>
     <complexType name="SignatureMethodType" mixed="true">
       <sequence>
         <element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
         <any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
           <!-- (0,unbounded) elements from (1,1) namespace -->
       </sequence>
       <attribute name="Algorithm" type="anyURI" use="required"/>
     </complexType>
    A SignatureMethod instance may be created by invoking the newSignatureMethod method of the XMLSignatureFactory class.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newSignatureMethod(String, SignatureMethodParameterSpec)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DSA_SHA1
      The DSAwithSHA1 (DSS) signature method algorithm URI.
      static String HMAC_SHA1
      The HMAC-SHA1 MAC signature method algorithm URI
      static String RSA_SHA1
      The RSAwithSHA1 (PKCS #1) signature method algorithm URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters of this SignatureMethod.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

      • 方法 - 继承于接口 javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • 字段详细信息

      • DSA_SHA1

        static final String DSA_SHA1
        The DSAwithSHA1 (DSS) signature method algorithm URI.
        另请参见：
        Constant Field Values

      • RSA_SHA1

        static final String RSA_SHA1
        The RSAwithSHA1 (PKCS #1) signature method algorithm URI.
        另请参见：
        Constant Field Values

      • HMAC_SHA1

        static final String HMAC_SHA1
        The HMAC-SHA1 MAC signature method algorithm URI
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters of this SignatureMethod.

        The returned parameters can be typecast to a SignatureMethodParameterSpec object.

        指定者：
        getParameterSpec in interface AlgorithmMethod
        返回：
        the algorithm-specific input parameters of this SignatureMethod (may be null if not specified)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nctv


SignatureProperties

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface SignatureProperties

  • All Superinterfaces:
    XMLStructure

    public interface SignatureProperties
extends XMLStructure
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

<element name="SignatureProperties" type="ds:SignaturePropertiesType"/>
   <complexType name="SignaturePropertiesType">
     <sequence>
       <element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
     </sequence>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A SignatureProperties instance may be created by invoking the newSignatureProperties method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   SignatureProperties properties =
      factory.newSignatureProperties(props, "signature-properties-1");
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newSignatureProperties(List, String), SignatureProperty

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String TYPE
      URI that identifies the SignatureProperties element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getId()
      Returns the Id of this SignatureProperties.
      List getProperties()
      Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • TYPE

        static final String TYPE
        URI that identifies the SignatureProperties element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getId

        String getId()
        Returns the Id of this SignatureProperties.
        返回：
        the Id of this SignatureProperties (or null if not specified)

      • getProperties

        List getProperties()
        Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.
        返回：
        an unmodifiable list of one or more SignaturePropertys
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lsl L a a "d"all"i llhea"l>figdu


SignatureProperty

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface SignatureProperty

  • All Superinterfaces:
    XMLStructure

    public interface SignatureProperty
extends XMLStructure
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

<element name="SignatureProperty" type="ds:SignaturePropertyType"/>
   <complexType name="SignaturePropertyType" mixed="true">
     <choice maxOccurs="unbounded">
       <any namespace="##other" processContents="lax"/>
       <!-- (1,1) elements from (1, unbounded) namespaces -->
     </choice>
     <attribute name="Target" type="anyURI" use="required"/>
     <attribute name="Id" type="ID" use="optional"/>
   </complexType>
    A SignatureProperty instance may be created by invoking the newSignatureProperty method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
   SignatureProperty property = factory.newSignatureProperty
      (Collections.singletonList(content), "#Signature-1", "TimeStamp");
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newSignatureProperty(List, String, String), SignatureProperties

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getContent()
      Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty.
      String getId()
      Returns the Id of this SignatureProperty.
      String getTarget()
      Returns the target URI of this SignatureProperty.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getTarget

        String getTarget()
        Returns the target URI of this SignatureProperty.
        返回：
        the target URI of this SignatureProperty (never null)

      • getId

        String getId()
        Returns the Id of this SignatureProperty.
        返回：
        the Id of this SignatureProperty (or null if not specified)

      • getContent

        List getContent()
        Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty. These represent additional information items concerning the generation of the XMLSignature (i.e. date/time stamp or serial numbers of cryptographic hardware used in signature generation).
        返回：
        an unmodifiable list of one or more XMLStructures
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ie>slsaslsb;/li>>hiy絫><�


SignedInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface SignedInfo

  • All Superinterfaces:
    XMLStructure

    public interface SignedInfo
extends XMLStructure
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

 <element name="SignedInfo" type="ds:SignedInfoType"/>
 <complexType name="SignedInfoType">
   <sequence>
     <element ref="ds:CanonicalizationMethod"/>
     <element ref="ds:SignatureMethod"/>
     <element ref="ds:Reference" maxOccurs="unbounded"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
 </complexType>
    A SignedInfo instance may be created by invoking one of the newSignedInfo methods of the XMLSignatureFactory class.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List), XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      CanonicalizationMethod getCanonicalizationMethod()
      Returns the canonicalization method of this SignedInfo.
      InputStream getCanonicalizedData()
      Returns the canonicalized signed info bytes after a signing or validation operation.
      String getId()
      Returns the optional Id attribute of this SignedInfo.
      List getReferences()
      Returns an unmodifiable list of one or more References.
      SignatureMethod getSignatureMethod()
      Returns the signature method of this SignedInfo.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getCanonicalizationMethod

        CanonicalizationMethod getCanonicalizationMethod()
        Returns the canonicalization method of this SignedInfo.
        返回：
        the canonicalization method

      • getSignatureMethod

        SignatureMethod getSignatureMethod()
        Returns the signature method of this SignedInfo.
        返回：
        the signature method

      • getReferences

        List getReferences()
        Returns an unmodifiable list of one or more References.
        返回：
        an unmodifiable list of one or more References

      • getId

        String getId()
        Returns the optional Id attribute of this SignedInfo.
        返回：
        the id (may be null if not specified)

      • getCanonicalizedData

        InputStream getCanonicalizedData()
        Returns the canonicalized signed info bytes after a signing or validation operation. This method is useful for debugging.
        返回：
        an InputStream containing the canonicalized bytes, or null if this SignedInfo has not been signed or validated yet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

celt=st- -- p csp=NNsafpl a- =-<


Transform

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface Transform

  • All Superinterfaces:
    AlgorithmMethod, XMLStructure
    All Known Subinterfaces:
    CanonicalizationMethod
    All Known Implementing Classes:
    TransformService

    public interface Transform
extends XMLStructure, AlgorithmMethod
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:
     <element name="Transform" type="ds:TransformType"/>
   <complexType name="TransformType" mixed="true">
     <choice minOccurs="0" maxOccurs="unbounded">
       <any namespace="##other" processContents="lax"/>
       <!-- (1,1) elements from (0,unbounded) namespaces -->
       <element name="XPath" type="string"/>
     </choice>
     <attribute name="Algorithm" type="anyURI" use="required"/>
   </complexType>
    A Transform instance may be created by invoking the newTransform method of the XMLSignatureFactory class.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newTransform(String, TransformParameterSpec)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String BASE64
      The Base64 transform algorithm URI.
      static String ENVELOPED
      The Enveloped Signature transform algorithm URI.
      static String XPATH
      The XPath transform algorithm URI.
      static String XPATH2
      The XPath Filter 2 transform algorithm URI.
      static String XSLT
      The XSLT transform algorithm URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      AlgorithmParameterSpec getParameterSpec()
      Returns the algorithm-specific input parameters associated with this Transform.
      Data transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

      • 方法 - 继承于接口 javax.xml.crypto.AlgorithmMethod

        getAlgorithm

    • 字段详细信息

      • BASE64

        static final String BASE64
        The Base64 transform algorithm URI.
        另请参见：
        Constant Field Values

      • ENVELOPED

        static final String ENVELOPED
        The Enveloped Signature transform algorithm URI.
        另请参见：
        Constant Field Values

      • XPATH

        static final String XPATH
        The XPath transform algorithm URI.
        另请参见：
        Constant Field Values

      • XPATH2

        static final String XPATH2
        The XPath Filter 2 transform algorithm URI.
        另请参见：
        Constant Field Values

      • XSLT

        static final String XSLT
        The XSLT transform algorithm URI.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getParameterSpec

        AlgorithmParameterSpec getParameterSpec()
        Returns the algorithm-specific input parameters associated with this Transform.

        The returned parameters can be typecast to a TransformParameterSpec object.

        指定者：
        getParameterSpec in interface AlgorithmMethod
        返回：
        the algorithm-specific input parameters (may be null if not specified)

      • transform

        Data transform(Data data,
             XMLCryptoContext context)
               throws TransformException
        Transforms the specified data using the underlying transform algorithm.
        参数：
        data - the data to be transformed
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        返回：
        the transformed data
        抛出：
        NullPointerException - if data is null
        TransformException - if an error occurs while executing the transform

      • transform

        Data transform(Data data,
             XMLCryptoContext context,
             OutputStream os)
               throws TransformException
        Transforms the specified data using the underlying transform algorithm. If the output of this transform is an OctetStreamData, then this method returns null and the bytes are written to the specified OutputStream. Otherwise, the OutputStream is ignored and the method behaves as if transform(Data, XMLCryptoContext) were invoked.
        参数：
        data - the data to be transformed
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        os - the OutputStream that should be used to write the transformed data to
        返回：
        the transformed data (or null if the data was written to the OutputStream parameter)
        抛出：
        NullPointerException - if data or os is null
        TransformException - if an error occurs while executing the transform
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hard/h/tpp/v/blr gc.siicx瑀>f


TransformException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig

类 TransformException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.dsig.TransformException
  • 所有已实现的接口：
    Serializable

    public class TransformException
extends Exception
    Indicates an exceptional condition that occured while executing a transform algorithm.

    A TransformException can contain a cause: another throwable that caused this TransformException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    Transform.transform(javax.xml.crypto.Data, javax.xml.crypto.XMLCryptoContext), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransformException()
      Constructs a new TransformException with null as its detail message.
      TransformException(String message)
      Constructs a new TransformException with the specified detail message.
      TransformException(String message, Throwable cause)
      Constructs a new TransformException with the specified detail message and cause.
      TransformException(Throwable cause)
      Constructs a new TransformException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this TransformException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this TransformException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this TransformException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this TransformException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransformException

        public TransformException()
        Constructs a new TransformException with null as its detail message.

      • TransformException

        public TransformException(String message)
        Constructs a new TransformException with the specified detail message.
        参数：
        message - the detail message

      • TransformException

        public TransformException(String message,
                  Throwable cause)
        Constructs a new TransformException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • TransformException

        public TransformException(Throwable cause)
        Constructs a new TransformException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Returns the cause of this TransformException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this TransformException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this TransformException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this TransformException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this TransformException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this TransformException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u"t.-m齦-"nnls/i.-f


TransformService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig

类 TransformService

  • java.lang.Object
    • javax.xml.crypto.dsig.TransformService
  • 所有已实现的接口：
    AlgorithmMethod, Transform, XMLStructure

    public abstract class TransformService
extends Object
implements Transform
    A Service Provider Interface for transform and canonicalization algorithms.

    Each instance of TransformService supports a specific transform or canonicalization algorithm and XML mechanism type. To create a TransformService, call one of the static getInstance methods, passing in the algorithm URI and XML mechanism type desired, for example:

    TransformService ts = TransformService.getInstance(Transform.XPATH2, "DOM");

    TransformService implementations are registered and loaded using the Provider mechanism. Each TransformService service provider implementation should include a MechanismType service attribute that identifies the XML mechanism type that it supports. If the attribute is not specified, "DOM" is assumed. For example, a service provider that supports the XPath Filter 2 Transform and DOM mechanism would be specified in the Provider subclass as:

         put("TransformService." + Transform.XPATH2,
         "org.example.XPath2TransformService");
     put("TransformService." + Transform.XPATH2 + " MechanismType", "DOM");
    TransformService implementations that support the DOM mechanism type must abide by the DOM interoperability requirements defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    Once a TransformService has been created, it can be used to process Transform or CanonicalizationMethod objects. If the Transform or CanonicalizationMethod exists in XML form (for example, when validating an existing XMLSignature), the init(XMLStructure, XMLCryptoContext) method must be first called to initialize the transform and provide document context (even if there are no parameters). Alternatively, if the Transform or CanonicalizationMethod is being created from scratch, the init(TransformParameterSpec) method is called to initialize the transform with parameters and the marshalParams method is called to marshal the parameters to XML and provide the transform with document context. Finally, the transform method is called to perform the transformation.

    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single TransformService instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different TransformService instance need not synchronize.

    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.crypto.dsig.Transform

        BASE64, ENVELOPED, XPATH, XPATH2, XSLT

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TransformService()
      Default constructor, for invocation by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAlgorithm()
      Returns the URI of the algorithm supported by this TransformService.
      static TransformService getInstance(String algorithm, String mechanismType)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).
      static TransformService getInstance(String algorithm, String mechanismType, Provider provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      static TransformService getInstance(String algorithm, String mechanismType, String provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      String getMechanismType()
      Returns the mechanism type supported by this TransformService.
      Provider getProvider()
      Returns the provider of this TransformService.
      abstract void init(TransformParameterSpec params)
      Initializes this TransformService with the specified parameters.
      abstract void init(XMLStructure parent, XMLCryptoContext context)
      Initializes this TransformService with the specified parameters and document context.
      abstract void marshalParams(XMLStructure parent, XMLCryptoContext context)
      Marshals the algorithm-specific parameters.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.crypto.dsig.Transform

        getParameterSpec, transform, transform

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 构造方法详细信息

      • TransformService

        protected TransformService()
        Default constructor, for invocation by subclasses.

    • 方法详细信息

      • getInstance

        public static TransformService getInstance(String algorithm,
                           String mechanismType)
                                    throws NoSuchAlgorithmException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a TransformService implementation of the desired algorithm and MechanismType service attribute. It traverses the list of registered security Providers, starting with the most preferred Provider. A new TransformService object from the first Provider that supports the specified algorithm and mechanism type is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        返回：
        a new TransformService
        抛出：
        NullPointerException - if algorithm or mechanismType is null
        NoSuchAlgorithmException - if no Provider supports a TransformService implementation for the specified algorithm and mechanism type
        另请参见：
        Provider

      • getInstance

        public static TransformService getInstance(String algorithm,
                           String mechanismType,
                           Provider provider)
                                    throws NoSuchAlgorithmException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        参数：
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        provider - the Provider object
        返回：
        a new TransformService
        抛出：
        NullPointerException - if provider, algorithm, or mechanismType is null
        NoSuchAlgorithmException - if a TransformService implementation for the specified algorithm and mechanism type is not available from the specified Provider object
        另请参见：
        Provider

      • getInstance

        public static TransformService getInstance(String algorithm,
                           String mechanismType,
                           String provider)
                                    throws NoSuchAlgorithmException,
                                           NoSuchProviderException
        Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        algorithm - the URI of the algorithm
        mechanismType - the type of the XML processing mechanism and representation
        provider - the string name of the provider
        返回：
        a new TransformService
        抛出：
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if provider, mechanismType, or algorithm is null
        NoSuchAlgorithmException - if a TransformService implementation for the specified algorithm and mechanism type is not available from the specified provider
        另请参见：
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the mechanism type supported by this TransformService.
        返回：
        the mechanism type

      • getAlgorithm

        public final String getAlgorithm()
        Returns the URI of the algorithm supported by this TransformService.
        指定者：
        getAlgorithm in interface AlgorithmMethod
        返回：
        the algorithm URI

      • getProvider

        public final Provider getProvider()
        Returns the provider of this TransformService.
        返回：
        the provider

      • init

        public abstract void init(TransformParameterSpec params)
                   throws InvalidAlgorithmParameterException
        Initializes this TransformService with the specified parameters.

        If the parameters exist in XML form, the init(XMLStructure, XMLCryptoContext) method should be used to initialize the TransformService.

        参数：
        params - the algorithm parameters (may be null if not required or optional)
        抛出：
        InvalidAlgorithmParameterException - if the specified parameters are invalid for this algorithm

      • marshalParams

        public abstract void marshalParams(XMLStructure parent,
                 XMLCryptoContext context)
                            throws MarshalException
        Marshals the algorithm-specific parameters. If there are no parameters to be marshalled, this method returns without throwing an exception.
        参数：
        parent - a mechanism-specific structure containing the parent node that the marshalled parameters should be appended to
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        抛出：
        ClassCastException - if the type of parent or context is not compatible with this TransformService
        NullPointerException - if parent is null
        MarshalException - if the parameters cannot be marshalled

      • init

        public abstract void init(XMLStructure parent,
        XMLCryptoContext context)
                   throws InvalidAlgorithmParameterException
        Initializes this TransformService with the specified parameters and document context.
        参数：
        parent - a mechanism-specific structure containing the parent structure
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        抛出：
        ClassCastException - if the type of parent or context is not compatible with this TransformService
        NullPointerException - if parent is null
        InvalidAlgorithmParameterException - if the specified parameters are invalid for this algorithm
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.xml.crypto.dsig

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto.dsig

  • Packages that use javax.xml.crypto.dsig
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
  • Classes in javax.xml.crypto.dsig used by javax.xml.crypto.dsig
    类与描述
    CanonicalizationMethod
    A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    DigestMethod
    A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Manifest
    A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Reference
    A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureMethod
    A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperties
    A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignatureProperty
    A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    SignedInfo
    An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    Transform
    A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    TransformException
    Indicates an exceptional condition that occured while executing a transform algorithm.
    TransformService
    A Service Provider Interface for transform and canonicalization algorithms.
    XMLObject
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignature.SignatureValue
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    XMLSignatureException
    Indicates an exceptional condition that occured during the XML signature generation or validation process.
    XMLSignatureFactory
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • Classes in javax.xml.crypto.dsig used by javax.xml.crypto.dsig.dom
    类与描述
    XMLSignContext
    Contains context information for generating XML Signatures.
    XMLValidateContext
    Contains context information for validating XML Signatures.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aoc>ypmxllla.rriao zzi


XMLObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface XMLObject

  • All Superinterfaces:
    XMLStructure

    public interface XMLObject
extends XMLStructure
    A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An XMLObject may contain any data and may include optional MIME type, ID, and encoding attributes. The XML Schema Definition is defined as:

 <element name="Object" type="ds:ObjectType"/>
 <complexType name="ObjectType" mixed="true">
   <sequence minOccurs="0" maxOccurs="unbounded">
     <any namespace="##any" processContents="lax"/>
   </sequence>
   <attribute name="Id" type="ID" use="optional"/>
   <attribute name="MimeType" type="string" use="optional"/>
   <attribute name="Encoding" type="anyURI" use="optional"/>
 </complexType>
    A XMLObject instance may be created by invoking the newXMLObject method of the XMLSignatureFactory class; for example:
       XMLSignatureFactory fac = XMLSignatureFactory.getInstance("DOM");
   List content = Collections.singletonList(fac.newManifest(references)));
   XMLObject object = factory.newXMLObject(content, "object-1", null, null);

    Note that this class is named XMLObject rather than Object to avoid naming clashes with the existing java.lang.Object class.

    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newXMLObject(List, String, String, String)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String TYPE
      URI that identifies the Object element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getContent()
      Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.
      String getEncoding()
      Returns the encoding URI of this XMLObject.
      String getId()
      Returns the Id of this XMLObject.
      String getMimeType()
      Returns the mime type of this XMLObject.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • TYPE

        static final String TYPE
        URI that identifies the Object element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getContent

        List getContent()
        Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.

        If there is a public subclass representing the type of XMLStructure, it is returned as an instance of that class (ex: a SignatureProperties element would be returned as an instance of SignatureProperties).

        返回：
        an unmodifiable list of XMLStructures (may be empty but never null)

      • getId

        String getId()
        Returns the Id of this XMLObject.
        返回：
        the Id (or null if not specified)

      • getMimeType

        String getMimeType()
        Returns the mime type of this XMLObject. The mime type is an optional attribute which describes the data within this XMLObject (independent of its encoding).
        返回：
        the mime type (or null if not specified)

      • getEncoding

        String getEncoding()
        Returns the encoding URI of this XMLObject. The encoding URI identifies the method by which the object is encoded.
        返回：
        the encoding URI (or null if not specified)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nabcMSoLSot""ott.attt


XMLSignature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface XMLSignature

  • All Superinterfaces:
    XMLStructure

    public interface XMLSignature
extends XMLStructure
    A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. This class contains methods for signing and validating XML signatures with behavior as defined by the W3C specification. The XML Schema Definition is defined as:

 <element name="Signature" type="ds:SignatureType"/>
 <complexType name="SignatureType">
    <sequence>
      <element ref="ds:SignedInfo"/>
      <element ref="ds:SignatureValue"/>
      <element ref="ds:KeyInfo" minOccurs="0"/>
      <element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
    </sequence>
    <attribute name="Id" type="ID" use="optional"/>
 </complexType>

    An XMLSignature instance may be created by invoking one of the newXMLSignature methods of the XMLSignatureFactory class.

    If the contents of the underlying document containing the XMLSignature are subsequently modified, the behavior is undefined.

    Note that this class is named XMLSignature rather than Signature to avoid naming clashes with the existing java.security.Signature class.

    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo), XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo, List, String, String)

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static interface  XMLSignature.SignatureValue
      A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String XMLNS
      The XML Namespace URI of the W3C Recommendation for XML-Signature Syntax and Processing.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getId()
      Returns the optional Id of this XMLSignature.
      KeyInfo getKeyInfo()
      Returns the key info of this XMLSignature.
      KeySelectorResult getKeySelectorResult()
      Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
      List getObjects()
      Returns an unmodifiable list of XMLObjects contained in this XMLSignature.
      XMLSignature.SignatureValue getSignatureValue()
      Returns the signature value of this XMLSignature.
      SignedInfo getSignedInfo()
      Returns the signed info of this XMLSignature.
      void sign(XMLSignContext signContext)
      Signs this XMLSignature.
      boolean validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • XMLNS

        static final String XMLNS
        The XML Namespace URI of the W3C Recommendation for XML-Signature Syntax and Processing.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • validate

        boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
        Validates the signature according to the core validation processing rules. This method validates the signature using the existing state, it does not unmarshal and reinitialize the contents of the XMLSignature using the location information specified in the context.

        This method only validates the signature the first time it is invoked. On subsequent invocations, it returns a cached result.

        参数：
        validateContext - the validating context
        返回：
        true if the signature passed core validation, otherwise false
        抛出：
        ClassCastException - if the type of validateContext is not compatible with this XMLSignature
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected error occurs during validation that prevented the validation operation from completing

      • getKeyInfo

        KeyInfo getKeyInfo()
        Returns the key info of this XMLSignature.
        返回：
        the key info (may be null if not specified)

      • getSignedInfo

        SignedInfo getSignedInfo()
        Returns the signed info of this XMLSignature.
        返回：
        the signed info (never null)

      • getObjects

        List getObjects()
        Returns an unmodifiable list of XMLObjects contained in this XMLSignature.
        返回：
        an unmodifiable list of XMLObjects (may be empty but never null)

      • getId

        String getId()
        Returns the optional Id of this XMLSignature.
        返回：
        the Id (may be null if not specified)

      • getSignatureValue

        XMLSignature.SignatureValue getSignatureValue()
        Returns the signature value of this XMLSignature.
        返回：
        the signature value

      • sign

        void sign(XMLSignContext signContext)
          throws MarshalException,
                 XMLSignatureException
        Signs this XMLSignature.

        If this method throws an exception, this XMLSignature and the signContext parameter will be left in the state that it was in prior to the invocation.

        参数：
        signContext - the signing context
        抛出：
        ClassCastException - if the type of signContext is not compatible with this XMLSignature
        NullPointerException - if signContext is null
        MarshalException - if an exception occurs while marshalling
        XMLSignatureException - if an unexpected exception occurs while generating the signature

      • getKeySelectorResult

        KeySelectorResult getKeySelectorResult()
        Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.
        返回：
        the key selector result, or null if a key selector has not been specified or this XMLSignature has not been signed or validated
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/m


XMLSignature.SignatureValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig

Interface XMLSignature.SignatureValue

  • All Superinterfaces:
    XMLStructure
    Enclosing interface:
    XMLSignature

    public static interface XMLSignature.SignatureValue
extends XMLStructure
    A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. The XML Schema Definition is defined as:

       <element name="SignatureValue" type="ds:SignatureValueType"/>
     <complexType name="SignatureValueType">
       <simpleContent>
         <extension base="base64Binary">
           <attribute name="Id" type="ID" use="optional"/>
         </extension>
       </simpleContent>
     </complexType>

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getId()
      Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.
      byte[] getValue()
      Returns the signature value of this SignatureValue.
      boolean validate(XMLValidateContext validateContext)
      Validates the signature value.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getId

        String getId()
        Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.
        返回：
        the Id attribute (may be null if not specified)

      • getValue

        byte[] getValue()
        Returns the signature value of this SignatureValue.
        返回：
        the signature value (may be null if the XMLSignature has not been signed yet). Each invocation of this method returns a new clone of the array to prevent subsequent modification.

      • validate

        boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
        Validates the signature value. This method performs a cryptographic validation of the signature calculated over the SignedInfo of the XMLSignature.

        This method only validates the signature the first time it is invoked. On subsequent invocations, it returns a cached result.

        参数：
        validateContext - the validating context
        返回：
        true if the signature was validated successfully; false otherwise
        抛出：
        NullPointerException - if validateContext is null
        XMLSignatureException - if an unexpected exception occurs while validating the signature
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gk-/w.w3.w/www//t gglesda/llii>eebs


XMLSignatureException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig

类 XMLSignatureException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.crypto.dsig.XMLSignatureException
  • 所有已实现的接口：
    Serializable

    public class XMLSignatureException
extends Exception
    Indicates an exceptional condition that occured during the XML signature generation or validation process.

    An XMLSignatureException can contain a cause: another throwable that caused this XMLSignatureException to get thrown.

    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLSignatureException()
      Constructs a new XMLSignatureException with null as its detail message.
      XMLSignatureException(String message)
      Constructs a new XMLSignatureException with the specified detail message.
      XMLSignatureException(String message, Throwable cause)
      Constructs a new XMLSignatureException with the specified detail message and cause.
      XMLSignatureException(Throwable cause)
      Constructs a new XMLSignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.
      void printStackTrace()
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the standard error stream.
      void printStackTrace(PrintStream s)
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print stream.
      void printStackTrace(PrintWriter s)
      Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print writer.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XMLSignatureException

        public XMLSignatureException()
        Constructs a new XMLSignatureException with null as its detail message.

      • XMLSignatureException

        public XMLSignatureException(String message)
        Constructs a new XMLSignatureException with the specified detail message.
        参数：
        message - the detail message

      • XMLSignatureException

        public XMLSignatureException(String message,
                     Throwable cause)
        Constructs a new XMLSignatureException with the specified detail message and cause.

        Note that the detail message associated with cause is not automatically incorporated in this exception's detail message.

        参数：
        message - the detail message
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • XMLSignatureException

        public XMLSignatureException(Throwable cause)
        Constructs a new XMLSignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - the cause (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

    • 方法详细信息

      • getCause

        public Throwable getCause()
        Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this XMLSignatureException to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.

      • printStackTrace

        public void printStackTrace()
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the standard error stream.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print stream.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintStream to use for output

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print writer.
        重载：
        printStackTrace in class Throwable
        参数：
        s - PrintWriter to use for output
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

brscoltoSyeeSyyomeere. ..=r.//j../"r


XMLSignatureFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig

类 XMLSignatureFactory

  • java.lang.Object
    • javax.xml.crypto.dsig.XMLSignatureFactory

  • public abstract class XMLSignatureFactory
extends Object
    A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.

    XMLSignatureFactory Type

    Each instance of XMLSignatureFactory supports a specific XML mechanism type. To create an XMLSignatureFactory, call one of the static getInstance methods, passing in the XML mechanism type desired, for example:

    XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");

    The objects that this factory produces will be based on DOM and abide by the DOM interoperability requirements as defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    XMLSignatureFactory implementations are registered and loaded using the Provider mechanism. For example, a service provider that supports the DOM mechanism would be specified in the Provider subclass as:

         put("XMLSignatureFactory.DOM", "org.example.DOMXMLSignatureFactory");

    An implementation MUST minimally support the default mechanism type: DOM.

    Note that a caller must use the same XMLSignatureFactory instance to create the XMLStructures of a particular XMLSignature that is to be generated. The behavior is undefined if XMLStructures from different providers or different mechanism types are used together.

    Also, the XMLStructures that are created by this factory may contain state specific to the XMLSignature and are not intended to be reusable.

    Creating XMLSignatures from scratch

    Once the XMLSignatureFactory has been created, objects can be instantiated by calling the appropriate method. For example, a Reference instance may be created by invoking one of the newReference methods.

    Unmarshalling XMLSignatures from XML

    Alternatively, an XMLSignature may be created from an existing XML representation by invoking the unmarshalXMLSignature method and passing it a mechanism-specific XMLValidateContext instance containing the XML content:

     DOMValidateContext context = new DOMValidateContext(key, signatureElement);
 XMLSignature signature = factory.unmarshalXMLSignature(context);
    Each XMLSignatureFactory must support the required XMLValidateContext types for that factory type, but may support others. A DOM XMLSignatureFactory must support DOMValidateContext objects.

    Signing and marshalling XMLSignatures to XML

    Each XMLSignature created by the factory can also be marshalled to an XML representation and signed, by invoking the sign method of the XMLSignature object and passing it a mechanism-specific XMLSignContext object containing the signing key and marshalling parameters (see DOMSignContext). For example:
        DOMSignContext context = new DOMSignContext(privateKey, document);
    signature.sign(context);
    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single XMLSignatureFactory instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different XMLSignatureFactory instance need not synchronize.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected XMLSignatureFactory()
      Default constructor, for invocation by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static XMLSignatureFactory getInstance()
      Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").
      static XMLSignatureFactory getInstance(String mechanismType)
      Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static XMLSignatureFactory getInstance(String mechanismType, Provider provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static XMLSignatureFactory getInstance(String mechanismType, String provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      KeyInfoFactory getKeyInfoFactory()
      Returns a KeyInfoFactory that creates KeyInfo objects.
      String getMechanismType()
      Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").
      Provider getProvider()
      Returns the provider of this XMLSignatureFactory.
      abstract URIDereferencer getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.
      abstract boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.
      abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract DigestMethod newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
      abstract Manifest newManifest(List references)
      Creates a Manifest containing the specified list of References.
      abstract Manifest newManifest(List references, String id)
      Creates a Manifest containing the specified list of References and optional id.
      abstract Reference newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
      abstract SignatureMethod newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.
      abstract SignatureProperties newSignatureProperties(List properties, String id)
      Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
      abstract SignatureProperty newSignatureProperty(List content, String target, String id)
      Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
      abstract SignedInfo newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
      abstract Transform newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract Transform newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract XMLObject newXMLObject(List content, String id, String mimeType, String encoding)
      Creates an XMLObject from the specified parameters.
      abstract XMLSignature newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
      abstract XMLSignature unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLSignatureFactory

        protected XMLSignatureFactory()
        Default constructor, for invocation by subclasses.

    • 方法详细信息

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType)
        Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate an XMLSignatureFactory implementation of the desired mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new XMLSignatureFactory object from the first Provider that supports the specified mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        返回：
        a new XMLSignatureFactory
        抛出：
        NullPointerException - if mechanismType is null
        NoSuchMechanismException - if no Provider supports an XMLSignatureFactory implementation for the specified mechanism
        另请参见：
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType,
                              Provider provider)
        Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the Provider object
        返回：
        a new XMLSignatureFactory
        抛出：
        NullPointerException - if provider or mechanismType is null
        NoSuchMechanismException - if an XMLSignatureFactory implementation for the specified mechanism is not available from the specified Provider object
        另请参见：
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance(String mechanismType,
                              String provider)
                                       throws NoSuchProviderException
        Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the string name of the provider
        返回：
        a new XMLSignatureFactory
        抛出：
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if provider or mechanismType is null
        NoSuchMechanismException - if an XMLSignatureFactory implementation for the specified mechanism is not available from the specified provider
        另请参见：
        Provider

      • getInstance

        public static XMLSignatureFactory getInstance()
        Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate an XMLSignatureFactory implementation of the default mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new XMLSignatureFactory object from the first Provider that supports the DOM mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        返回：
        a new XMLSignatureFactory
        抛出：
        NoSuchMechanismException - if no Provider supports an XMLSignatureFactory implementation for the DOM mechanism
        另请参见：
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").
        返回：
        the XML processing mechanism type supported by this XMLSignatureFactory

      • getProvider

        public final Provider getProvider()
        Returns the provider of this XMLSignatureFactory.
        返回：
        the provider of this XMLSignatureFactory

      • newXMLSignature

        public abstract XMLSignature newXMLSignature(SignedInfo si,
                           KeyInfo ki)
        Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
        参数：
        si - the signed info
        ki - the key info (may be null)
        返回：
        an XMLSignature
        抛出：
        NullPointerException - if si is null

      • newXMLSignature

        public abstract XMLSignature newXMLSignature(SignedInfo si,
                           KeyInfo ki,
                           List objects,
                           String id,
                           String signatureValueId)
        Creates an XMLSignature and initializes it with the specified parameters.
        参数：
        si - the signed info
        ki - the key info (may be null)
        objects - a list of XMLObjects (may be empty or null)
        id - the Id (may be null)
        signatureValueId - the SignatureValue Id (may be null)
        返回：
        an XMLSignature
        抛出：
        NullPointerException - if si is null
        ClassCastException - if any of the objects are not of type XMLObject

      • newReference

        public abstract Reference newReference(String uri,
                     DigestMethod dm)
        Creates a Reference with the specified URI and digest method.
        参数：
        uri - the reference URI (may be null)
        dm - the digest method
        返回：
        a Reference
        抛出：
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm is null

      • newReference

        public abstract Reference newReference(String uri,
                     DigestMethod dm,
                     List transforms,
                     String type,
                     String id)
        Creates a Reference with the specified parameters.
        参数：
        uri - the reference URI (may be null)
        dm - the digest method
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        返回：
        a Reference
        抛出：
        ClassCastException - if any of the transforms are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm is null

      • newReference

        public abstract Reference newReference(String uri,
                     DigestMethod dm,
                     List transforms,
                     String type,
                     String id,
                     byte[] digestValue)
        Creates a Reference with the specified parameters and pre-calculated digest value.

        This method is useful when the digest value of a Reference has been previously computed. See for example, the OASIS-DSS (Digital Signature Services) specification.

        参数：
        uri - the reference URI (may be null)
        dm - the digest method
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        digestValue - the digest value. The array is cloned to protect against subsequent modification.
        返回：
        a Reference
        抛出：
        ClassCastException - if any of the transforms are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant
        NullPointerException - if dm or digestValue is null

      • newReference

        public abstract Reference newReference(String uri,
                     DigestMethod dm,
                     List appliedTransforms,
                     Data result,
                     List transforms,
                     String type,
                     String id)
        Creates a Reference with the specified parameters.

        This method is useful when a list of transforms have already been applied to the Reference. See for example, the OASIS-DSS (Digital Signature Services) specification.

        When an XMLSignature containing this reference is generated, the specified transforms (if non-null) are applied to the specified result. The Transforms element of the resulting Reference element is set to the concatenation of the appliedTransforms and transforms.

        参数：
        uri - the reference URI (may be null)
        dm - the digest method
        appliedTransforms - a list of Transforms that have already been applied. The list is defensively copied to protect against subsequent modification. The list must contain at least one entry.
        result - the result of processing the sequence of appliedTransforms
        transforms - a list of Transforms that are to be applied when generating the signature. The list is defensively copied to protect against subsequent modification. May be null or empty.
        type - the reference type, as a URI (may be null)
        id - the reference ID (may be null)
        返回：
        a Reference
        抛出：
        ClassCastException - if any of the transforms (in either list) are not of type Transform
        IllegalArgumentException - if uri is not RFC 2396 compliant or appliedTransforms is empty
        NullPointerException - if dm, appliedTransforms or result is null

      • newSignedInfo

        public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                       SignatureMethod sm,
                       List references)
        Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
        参数：
        cm - the canonicalization method
        sm - the signature method
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        返回：
        a SignedInfo
        抛出：
        ClassCastException - if any of the references are not of type Reference
        IllegalArgumentException - if references is empty
        NullPointerException - if any of the parameters are null

      • newSignedInfo

        public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                       SignatureMethod sm,
                       List references,
                       String id)
        Creates a SignedInfo with the specified parameters.
        参数：
        cm - the canonicalization method
        sm - the signature method
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        返回：
        a SignedInfo
        抛出：
        ClassCastException - if any of the references are not of type Reference
        IllegalArgumentException - if references is empty
        NullPointerException - if cm, sm, or references are null

      • newXMLObject

        public abstract XMLObject newXMLObject(List content,
                     String id,
                     String mimeType,
                     String encoding)
        Creates an XMLObject from the specified parameters.
        参数：
        content - a list of XMLStructures. The list is defensively copied to protect against subsequent modification. May be null or empty.
        id - the Id (may be null)
        mimeType - the mime type (may be null)
        encoding - the encoding (may be null)
        返回：
        an XMLObject
        抛出：
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newManifest

        public abstract Manifest newManifest(List references)
        Creates a Manifest containing the specified list of References.
        参数：
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        返回：
        a Manifest
        抛出：
        NullPointerException - if references is null
        IllegalArgumentException - if references is empty
        ClassCastException - if references contains any entries that are not of type Reference

      • newManifest

        public abstract Manifest newManifest(List references,
                   String id)
        Creates a Manifest containing the specified list of References and optional id.
        参数：
        references - a list of one or more References. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        返回：
        a Manifest
        抛出：
        NullPointerException - if references is null
        IllegalArgumentException - if references is empty
        ClassCastException - if references contains any entries that are not of type Reference

      • newSignatureProperty

        public abstract SignatureProperty newSignatureProperty(List content,
                                     String target,
                                     String id)
        Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
        参数：
        content - a list of one or more XMLStructures. The list is defensively copied to protect against subsequent modification.
        target - the target URI of the Signature that this property applies to
        id - the id (may be null)
        返回：
        a SignatureProperty
        抛出：
        NullPointerException - if content or target is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newSignatureProperties

        public abstract SignatureProperties newSignatureProperties(List properties,
                                         String id)
        Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
        参数：
        properties - a list of one or more SignaturePropertys. The list is defensively copied to protect against subsequent modification.
        id - the id (may be null)
        返回：
        a SignatureProperties
        抛出：
        NullPointerException - if properties is null
        IllegalArgumentException - if properties is empty
        ClassCastException - if properties contains any entries that are not of type SignatureProperty

      • newDigestMethod

        public abstract DigestMethod newDigestMethod(String algorithm,
                           DigestMethodParameterSpec params)
                                      throws NoSuchAlgorithmException,
                                             InvalidAlgorithmParameterException
        Creates a DigestMethod for the specified algorithm URI and parameters.
        参数：
        algorithm - the URI identifying the digest algorithm
        params - algorithm-specific digest parameters (may be null)
        返回：
        the DigestMethod
        抛出：
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newSignatureMethod

        public abstract SignatureMethod newSignatureMethod(String algorithm,
                                 SignatureMethodParameterSpec params)
                                            throws NoSuchAlgorithmException,
                                                   InvalidAlgorithmParameterException
        Creates a SignatureMethod for the specified algorithm URI and parameters.
        参数：
        algorithm - the URI identifying the signature algorithm
        params - algorithm-specific signature parameters (may be null)
        返回：
        the SignatureMethod
        抛出：
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newTransform

        public abstract Transform newTransform(String algorithm,
                     TransformParameterSpec params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
        Creates a Transform for the specified algorithm URI and parameters.
        参数：
        algorithm - the URI identifying the transform algorithm
        params - algorithm-specific transform parameters (may be null)
        返回：
        the Transform
        抛出：
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newTransform

        public abstract Transform newTransform(String algorithm,
                     XMLStructure params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
        Creates a Transform for the specified algorithm URI and parameters. The parameters are specified as a mechanism-specific XMLStructure (ex: DOMStructure). This method is useful when the parameters are in XML form or there is no standard class for specifying the parameters.
        参数：
        algorithm - the URI identifying the transform algorithm
        params - a mechanism-specific XML structure from which to unmarshal the parameters from (may be null if not required or optional)
        返回：
        the Transform
        抛出：
        ClassCastException - if the type of params is inappropriate for this XMLSignatureFactory
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newCanonicalizationMethod

        public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                               C14NMethodParameterSpec params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
        Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
        参数：
        algorithm - the URI identifying the canonicalization algorithm
        params - algorithm-specific canonicalization parameters (may be null)
        返回：
        the CanonicalizationMethod
        抛出：
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • newCanonicalizationMethod

        public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                               XMLStructure params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
        Creates a CanonicalizationMethod for the specified algorithm URI and parameters. The parameters are specified as a mechanism-specific XMLStructure (ex: DOMStructure). This method is useful when the parameters are in XML form or there is no standard class for specifying the parameters.
        参数：
        algorithm - the URI identifying the canonicalization algorithm
        params - a mechanism-specific XML structure from which to unmarshal the parameters from (may be null if not required or optional)
        返回：
        the CanonicalizationMethod
        抛出：
        ClassCastException - if the type of params is inappropriate for this XMLSignatureFactory
        InvalidAlgorithmParameterException - if the specified parameters are inappropriate for the requested algorithm
        NoSuchAlgorithmException - if an implementation of the specified algorithm cannot be found
        NullPointerException - if algorithm is null

      • getKeyInfoFactory

        public final KeyInfoFactory getKeyInfoFactory()
        Returns a KeyInfoFactory that creates KeyInfo objects. The returned KeyInfoFactory has the same mechanism type and provider as this XMLSignatureFactory.
        返回：
        a KeyInfoFactory
        抛出：
        NoSuchMechanismException - if a KeyFactory implementation with the same mechanism type and provider is not available

      • unmarshalXMLSignature

        public abstract XMLSignature unmarshalXMLSignature(XMLValidateContext context)
                                            throws MarshalException
        Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
        参数：
        context - a mechanism-specific context from which to unmarshal the signature from
        返回：
        the XMLSignature
        抛出：
        NullPointerException - if context is null
        ClassCastException - if the type of context is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling

      • unmarshalXMLSignature

        public abstract XMLSignature unmarshalXMLSignature(XMLStructure xmlStructure)
                                            throws MarshalException
        Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance. This method is useful if you only want to unmarshal (and not validate) an XMLSignature.
        参数：
        xmlStructure - a mechanism-specific XML structure from which to unmarshal the signature from
        返回：
        the XMLSignature
        抛出：
        NullPointerException - if xmlStructure is null
        ClassCastException - if the type of xmlStructure is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling

      • isFeatureSupported

        public abstract boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        参数：
        feature - the feature name (as an absolute URI)
        返回：
        true if the specified feature is supported, false otherwise
        抛出：
        NullPointerException - if feature is null

      • getURIDereferencer

        public abstract URIDereferencer getURIDereferencer()
        Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.
        返回：
        a reference to the default URIDereferencer (never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XMLSignContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig

Interface XMLSignContext

  • All Superinterfaces:
    XMLCryptoContext
    All Known Implementing Classes:
    DOMSignContext

    public interface XMLSignContext
extends XMLCryptoContext
    Contains context information for generating XML Signatures. This interface is primarily intended for type-safety.

    Note that XMLSignContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if an XMLSignContext is used with different signature structures (for example, you should not use the same XMLSignContext instance to sign two different XMLSignature objects).

    Supported Properties

    The following properties can be set using the setProperty method.

    • javax.xml.crypto.dsig.cacheReference: value must be a Boolean. This property controls whether or not the digested Reference objects will cache the dereferenced content and pre-digested input for subsequent retrieval via the Reference.getDereferencedData and Reference.getDigestInputStream methods. The default value if not specified is Boolean.FALSE.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignature.sign(XMLSignContext)

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stsdd>< //< eocc>=noo胏穋l


XMLValidateContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig

Interface XMLValidateContext

  • All Superinterfaces:
    XMLCryptoContext
    All Known Implementing Classes:
    DOMValidateContext

    public interface XMLValidateContext
extends XMLCryptoContext
    Contains context information for validating XML Signatures. This interface is primarily intended for type-safety.

    Note that XMLValidateContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if an XMLValidateContext is used with different signature structures (for example, you should not use the same XMLValidateContext instance to validate two different XMLSignature objects).

    Supported Properties

    The following properties can be set by an application using the setProperty method.

    • javax.xml.crypto.dsig.cacheReference: value must be a Boolean. This property controls whether or not the Reference.validate method will cache the dereferenced content and pre-digested input for subsequent retrieval via the Reference.getDereferencedData and Reference.getDigestInputStream methods. The default value if not specified is Boolean.FALSE.
    从以下版本开始：
    1.6
    另请参见：
    XMLSignature.validate(XMLValidateContext), Reference.validate(XMLValidateContext)

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>>/> >d>ltdd>>/o


Uses of Class javax.xml.crypto.dsig.TransformException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.TransformException

  • Packages that use TransformException
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of TransformException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw TransformException
      修饰符与类型 方法与描述
      Data Transform.transform(Data data, XMLCryptoContext context)
      Transforms the specified data using the underlying transform algorithm.
      Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
      Transforms the specified data using the underlying transform algorithm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/.vin afccctiff/>/�


Uses of Class javax.xml.crypto.dsig.TransformService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.TransformService

  • Packages that use TransformService
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of TransformService in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return TransformService
      修饰符与类型 方法与描述
      static TransformService TransformService.getInstance(String algorithm, String mechanismType)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).
      static TransformService TransformService.getInstance(String algorithm, String mechanismType, Provider provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
      static TransformService TransformService.getInstance(String algorithm, String mechanismType, String provider)
      Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rttF r rbFrs屑/>nae.e鸼


Uses of Class javax.xml.crypto.dsig.XMLSignatureException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.XMLSignatureException

  • Packages that use XMLSignatureException
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignatureException in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that throw XMLSignatureException
      修饰符与类型 方法与描述
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.
      boolean XMLSignature.validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.
      boolean XMLSignature.SignatureValue.validate(XMLValidateContext validateContext)
      Validates the signature value.
      boolean Reference.validate(XMLValidateContext validateContext)
      Validates this reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v/l /mivA i g


Uses of Class javax.xml.crypto.dsig.XMLSignatureFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.XMLSignatureFactory

  • Packages that use XMLSignatureFactory
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignatureFactory in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignatureFactory
      修饰符与类型 方法与描述
      static XMLSignatureFactory XMLSignatureFactory.getInstance()
      Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType)
      Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType, Provider provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static XMLSignatureFactory XMLSignatureFactory.getInstance(String mechanismType, String provider)
      Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lena"b>s>aoit\c fga縠


Uses of Interface javax.xml.crypto.dsig.CanonicalizationMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.CanonicalizationMethod

  • Packages that use CanonicalizationMethod
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of CanonicalizationMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return CanonicalizationMethod
      修饰符与类型 方法与描述
      CanonicalizationMethod SignedInfo.getCanonicalizationMethod()
      Returns the canonicalization method of this SignedInfo.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type CanonicalizationMethod
      修饰符与类型 方法与描述
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Xshm/l)aa/


Uses of Interface javax.xml.crypto.dsig.DigestMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.DigestMethod

  • Packages that use DigestMethod
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of DigestMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return DigestMethod
      修饰符与类型 方法与描述
      DigestMethod Reference.getDigestMethod()
      Returns the digest method of this Reference.
      abstract DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type DigestMethod
      修饰符与类型 方法与描述
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

og>ljacoi nas>Jlmv


Uses of Interface javax.xml.crypto.dsig.Manifest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.Manifest

  • Packages that use Manifest
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Manifest in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Manifest
      修饰符与类型 方法与描述
      abstract Manifest XMLSignatureFactory.newManifest(List references)
      Creates a Manifest containing the specified list of References.
      abstract Manifest XMLSignatureFactory.newManifest(List references, String id)
      Creates a Manifest containing the specified list of References and optional id.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ae///..=f"""h yyv nnilhtp


Uses of Interface javax.xml.crypto.dsig.Reference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.Reference

  • Packages that use Reference
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Reference in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return Reference
      修饰符与类型 方法与描述
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm)
      Creates a Reference with the specified URI and digest method.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
      Creates a Reference with the specified parameters.
      abstract Reference XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
      Creates a Reference with the specified parameters and pre-calculated digest value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aBx.././.a "竌//t�


Uses of Interface javax.xml.crypto.dsig.SignatureMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.SignatureMethod

  • Packages that use SignatureMethod
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureMethod in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureMethod
      修饰符与类型 方法与描述
      SignatureMethod SignedInfo.getSignatureMethod()
      Returns the signature method of this SignedInfo.
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.
      Methods in javax.xml.crypto.dsig with parameters of type SignatureMethod
      修饰符与类型 方法与描述
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e noamatn reem萾gsadddd<


Uses of Interface javax.xml.crypto.dsig.SignatureProperties

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.SignatureProperties

  • Packages that use SignatureProperties
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureProperties in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureProperties
      修饰符与类型 方法与描述
      abstract SignatureProperties XMLSignatureFactory.newSignatureProperties(List properties, String id)
      Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y.pvod,MneeetnttctXo/nSir


Uses of Interface javax.xml.crypto.dsig.SignatureProperty

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.SignatureProperty

  • Packages that use SignatureProperty
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignatureProperty in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignatureProperty
      修饰符与类型 方法与描述
      abstract SignatureProperty XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
      Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

smtIaig=.nnnaL x.ehv i


Uses of Interface javax.xml.crypto.dsig.SignedInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.SignedInfo

  • Packages that use SignedInfo
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of SignedInfo in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return SignedInfo
      修饰符与类型 方法与描述
      SignedInfo XMLSignature.getSignedInfo()
      Returns the signed info of this XMLSignature.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references)
      Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
      abstract SignedInfo XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
      Creates a SignedInfo with the specified parameters.
      Methods in javax.xml.crypto.dsig with parameters of type SignedInfo
      修饰符与类型 方法与描述
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_ nla= nl alisl/t"ib<


Uses of Interface javax.xml.crypto.dsig.Transform

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.Transform

  • Packages that use Transform
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of Transform in javax.xml.crypto.dsig

      Subinterfaces of Transform in javax.xml.crypto.dsig
      修饰符与类型 Interface and Description
      interface  CanonicalizationMethod
      A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
      Classes in javax.xml.crypto.dsig that implement Transform
      修饰符与类型 类与描述
      class  TransformService
      A Service Provider Interface for transform and canonicalization algorithms.
      Methods in javax.xml.crypto.dsig that return Transform
      修饰符与类型 方法与描述
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
      Creates a Transform for the specified algorithm URI and parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d sev"lelllas//d"nSImngtl


Uses of Interface javax.xml.crypto.dsig.XMLObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.XMLObject

  • Packages that use XMLObject
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLObject in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLObject
      修饰符与类型 方法与描述
      abstract XMLObject XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
      Creates an XMLObject from the specified parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Interface javax.xml.crypto.dsig.XMLSignature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.XMLSignature

  • Packages that use XMLSignature
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignature in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignature
      修饰符与类型 方法与描述
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/elttmi"sfegd.kafanpms/


Uses of Interface javax.xml.crypto.dsig.XMLSignature.SignatureValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.XMLSignature.SignatureValue

  • Packages that use XMLSignature.SignatureValue
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of XMLSignature.SignatureValue in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return XMLSignature.SignatureValue
      修饰符与类型 方法与描述
      XMLSignature.SignatureValue XMLSignature.getSignatureValue()
      Returns the signature value of this XMLSignature.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cSti">Xrtooo=accaaa"f ed


Uses of Interface javax.xml.crypto.dsig.XMLSignContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.XMLSignContext

  • Packages that use XMLSignContext
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of XMLSignContext in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type XMLSignContext
      修饰符与类型 方法与描述
      void XMLSignature.sign(XMLSignContext signContext)
      Signs this XMLSignature.

    • Uses of XMLSignContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLSignContext
      修饰符与类型 类与描述
      class  DOMSignContext
      A DOM-specific XMLSignContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea.keitiLkslka du=sncksan


Uses of Interface javax.xml.crypto.dsig.XMLValidateContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.XMLValidateContext

  • Packages that use XMLValidateContext
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.

    • Uses of XMLValidateContext in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type XMLValidateContext
      修饰符与类型 方法与描述
      abstract XMLSignature XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context)
      Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
      boolean XMLSignature.validate(XMLValidateContext validateContext)
      Validates the signature according to the core validation processing rules.
      boolean XMLSignature.SignatureValue.validate(XMLValidateContext validateContext)
      Validates the signature value.
      boolean Reference.validate(XMLValidateContext validateContext)
      Validates this reference.

    • Uses of XMLValidateContext in javax.xml.crypto.dsig.dom

      Classes in javax.xml.crypto.dsig.dom that implement XMLValidateContext
      修饰符与类型 类与描述
      class  DOMValidateContext
      A DOM-specific XMLValidateContext.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.tdS>fnadP>hl.as�=�"g


DOMSignContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.dom

类 DOMSignContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
      • javax.xml.crypto.dsig.dom.DOMSignContext
  • 所有已实现的接口：
    XMLSignContext, XMLCryptoContext

    public class DOMSignContext
extends DOMCryptoContext
implements XMLSignContext
    A DOM-specific XMLSignContext. This class contains additional methods to specify the location in a DOM tree where an XMLSignature object is to be marshalled when generating the signature.

    Note that DOMSignContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if a DOMSignContext is used with different signature structures (for example, you should not use the same DOMSignContext instance to sign two different XMLSignature objects).

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMSignContext(Key signingKey, Node parent)
      Creates a DOMSignContext with the specified signing key and parent node.
      DOMSignContext(Key signingKey, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getNextSibling()
      Returns the nextSibling node.
      Node getParent()
      Returns the parent node.
      void setNextSibling(Node nextSibling)
      Sets the next sibling node.
      void setParent(Node parent)
      Sets the parent node.

      • 方法 - 继承于类 javax.xml.crypto.dom.DOMCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

    • 构造方法详细信息

      • DOMSignContext

        public DOMSignContext(Key signingKey,
              Node parent)
        Creates a DOMSignContext with the specified signing key and parent node. The signing key is stored in a singleton KeySelector that is returned by the getKeySelector method. The marshalled XMLSignature will be added as the last child element of the specified parent node unless a next sibling node is specified by invoking the setNextSibling method.
        参数：
        signingKey - the signing key
        parent - the parent node
        抛出：
        NullPointerException - if signingKey or parent is null

      • DOMSignContext

        public DOMSignContext(Key signingKey,
              Node parent,
              Node nextSibling)
        Creates a DOMSignContext with the specified signing key, parent and next sibling nodes. The signing key is stored in a singleton KeySelector that is returned by the getKeySelector method. The marshalled XMLSignature will be inserted as a child element of the specified parent node and immediately before the specified next sibling node.
        参数：
        signingKey - the signing key
        parent - the parent node
        nextSibling - the next sibling node
        抛出：
        NullPointerException - if signingKey, parent or nextSibling is null

      • DOMSignContext

        public DOMSignContext(KeySelector ks,
              Node parent)
        Creates a DOMSignContext with the specified key selector and parent node. The marshalled XMLSignature will be added as the last child element of the specified parent node unless a next sibling node is specified by invoking the setNextSibling method.
        参数：
        ks - the key selector
        parent - the parent node
        抛出：
        NullPointerException - if ks or parent is null

      • DOMSignContext

        public DOMSignContext(KeySelector ks,
              Node parent,
              Node nextSibling)
        Creates a DOMSignContext with the specified key selector, parent and next sibling nodes. The marshalled XMLSignature will be inserted as a child element of the specified parent node and immediately before the specified next sibling node.
        参数：
        ks - the key selector
        parent - the parent node
        nextSibling - the next sibling node
        抛出：
        NullPointerException - if ks, parent or nextSibling is null

    • 方法详细信息

      • setParent

        public void setParent(Node parent)
        Sets the parent node.
        参数：
        parent - the parent node. The marshalled XMLSignature will be added as a child element of this node.
        抛出：
        NullPointerException - if parent is null
        另请参见：
        getParent()

      • setNextSibling

        public void setNextSibling(Node nextSibling)
        Sets the next sibling node.
        参数：
        nextSibling - the next sibling node. The marshalled XMLSignature will be inserted immediately before this node. Specify null to remove the current setting.
        另请参见：
        getNextSibling()

      • getParent

        public Node getParent()
        Returns the parent node.
        返回：
        the parent node (never null)
        另请参见：
        setParent(Node)

      • getNextSibling

        public Node getNextSibling()
        Returns the nextSibling node.
        返回：
        the nextSibling node, or null if not specified.
        另请参见：
        setNextSibling(Node)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/>gyt蝣比�.家<"


DOMValidateContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.dom

类 DOMValidateContext

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext
      • javax.xml.crypto.dsig.dom.DOMValidateContext
  • 所有已实现的接口：
    XMLValidateContext, XMLCryptoContext

    public class DOMValidateContext
extends DOMCryptoContext
implements XMLValidateContext
    A DOM-specific XMLValidateContext. This class contains additional methods to specify the location in a DOM tree where an XMLSignature is to be unmarshalled and validated from.

    Note that the behavior of an unmarshalled XMLSignature is undefined if the contents of the underlying DOM tree are modified by the caller after the XMLSignature is created.

    Also, note that DOMValidateContext instances can contain information and state specific to the XML signature structure it is used with. The results are unpredictable if a DOMValidateContext is used with different signature structures (for example, you should not use the same DOMValidateContext instance to validate two different XMLSignature objects).

    从以下版本开始：
    1.6
    另请参见：
    XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext)

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMValidateContext(Key validatingKey, Node node)
      Creates a DOMValidateContext containing the specified key and node.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getNode()
      Returns the node.
      void setNode(Node node)
      Sets the node.

      • 方法 - 继承于类 javax.xml.crypto.dom.DOMCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 javax.xml.crypto.XMLCryptoContext

        get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

    • 构造方法详细信息

      • DOMValidateContext

        public DOMValidateContext(KeySelector ks,
                  Node node)
        Creates a DOMValidateContext containing the specified key selector and node.
        参数：
        ks - a key selector for finding a validation key
        node - the node
        抛出：
        NullPointerException - if ks or node is null

      • DOMValidateContext

        public DOMValidateContext(Key validatingKey,
                  Node node)
        Creates a DOMValidateContext containing the specified key and node. The validating key will be stored in a singleton KeySelector that is returned when the getKeySelector method is called.
        参数：
        validatingKey - the validating key
        node - the node
        抛出：
        NullPointerException - if validatingKey or node is null

    • 方法详细信息

      • setNode

        public void setNode(Node node)
        Sets the node.
        参数：
        node - the node
        抛出：
        NullPointerException - if node is null
        另请参见：
        getNode()

      • getNode

        public Node getNode()
        Returns the node.
        返回：
        the node (never null)
        另请参见：
        setNode(Node)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et = ittithmhthhNw..f=nni .ew.oddc3>ceo,b>"


javax.xml.crypto.dsig.dom

Classes

  • DOMSignContext
  • DOMValidateContext
H


javax.xml.crypto.dsig.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto.dsig.dom

DOM-specific classes for the javax.xml.crypto.dsig package.

请参见： 描述

  • Class Summary
    类 描述
    DOMSignContext
    A DOM-specific XMLSignContext.
    DOMValidateContext
    A DOM-specific XMLValidateContext.

软件包 javax.xml.crypto.dsig.dom Description

DOM-specific classes for the javax.xml.crypto.dsig package. Only users who are using a DOM-based XMLSignatureFactory or KeyInfoFactory should need to make direct use of this package.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pesepomdemo"ddmgeef/./. =


javax.xml.crypto.dsig.dom Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto.dsig.dom

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ae>a"e orm<�"ttmihm.c


Uses of Package javax.xml.crypto.dsig.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto.dsig.dom

No usage of javax.xml.crypto.dsig.dom
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nhgv


Uses of Class javax.xml.crypto.dsig.dom.DOMSignContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.dom.DOMSignContext

No usage of javax.xml.crypto.dsig.dom.DOMSignContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

blvmsc/#st/


Uses of Class javax.xml.crypto.dsig.dom.DOMValidateContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.dom.DOMValidateContext

No usage of javax.xml.crypto.dsig.dom.DOMValidateContext
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

">j"did >dvbgsak/p�


javax.xml.crypto.dsig.keyinfo

Interfaces

  • KeyInfo
  • KeyName
  • KeyValue
  • PGPData
  • RetrievalMethod
  • X509Data
  • X509IssuerSerial

Classes

  • KeyInfoFactory
"


javax.xml.crypto.dsig.keyinfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto.dsig.keyinfo

Classes for parsing and processing KeyInfo elements and structures.

请参见： 描述

  • 接口摘要
    接口 描述
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyName
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyValue
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    PGPData
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    RetrievalMethod
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509Data
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509IssuerSerial
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • Class Summary
    类 描述
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.

软件包 javax.xml.crypto.dsig.keyinfo Description

Classes for parsing and processing KeyInfo elements and structures. KeyInfo is an optional element that enables the recipient(s) to obtain the key needed to validate an XMLSignature. KeyInfo may contain keys, names, certificates and other public key management information, such as in-band key distribution or key agreement data. This package contains classes representing types defined in the W3C specification for XML Signatures, such as KeyName, KeyValue, RetrievalMethod, X509Data, X509IssuerSerial, and PGPData. KeyInfoFactory is an abstract factory that creates KeyInfo objects from scratch.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tevi/nf/gknn/paae.ee


javax.xml.crypto.dsig.keyinfo Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto.dsig.keyinfo

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Interface Hierarchy

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lkh etsssi, ocaa/,


KeyInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface KeyInfo

  • All Superinterfaces:
    XMLStructure

    public interface KeyInfo
extends XMLStructure
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyInfo contains a list of XMLStructures, each of which contain information that enables the recipient(s) to obtain the key needed to validate an XML signature. The XML Schema Definition is defined as:
     <element name="KeyInfo" type="ds:KeyInfoType"/>
 <complexType name="KeyInfoType" mixed="true">
   <choice maxOccurs="unbounded">
     <element ref="ds:KeyName"/>
     <element ref="ds:KeyValue"/>
     <element ref="ds:RetrievalMethod"/>
     <element ref="ds:X509Data"/>
     <element ref="ds:PGPData"/>
     <element ref="ds:SPKIData"/>
     <element ref="ds:MgmtData"/>
     <any processContents="lax" namespace="##other"/>
     <!-- (1,1) elements from (0,unbounded) namespaces -->
   </choice>
   <attribute name="Id" type="ID" use="optional"/>
 </complexType>
    A KeyInfo instance may be created by invoking one of the newKeyInfo methods of the KeyInfoFactory class, and passing it a list of one or more XMLStructures and an optional id parameter; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   KeyInfo keyInfo = factory.newKeyInfo
      (Collections.singletonList(factory.newKeyName("Alice"), "keyinfo-1"));

    KeyInfo objects can also be marshalled to XML by invoking the marshal method.

    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newKeyInfo(List), KeyInfoFactory.newKeyInfo(List, String)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getContent()
      Returns an unmodifiable list containing the key information.
      String getId()
      Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.
      void marshal(XMLStructure parent, XMLCryptoContext context)
      Marshals the key info to XML.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getContent

        List getContent()
        Returns an unmodifiable list containing the key information. Each entry of the list is an XMLStructure.

        If there is a public subclass representing the type of XMLStructure, it is returned as an instance of that class (ex: an X509Data element would be returned as an instance of X509Data).

        返回：
        an unmodifiable list of one or more XMLStructures in this KeyInfo. Never returns null or an empty list.

      • getId

        String getId()
        Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.
        返回：
        the Id attribute of this KeyInfo (may be null if not specified)

      • marshal

        void marshal(XMLStructure parent,
           XMLCryptoContext context)
             throws MarshalException
        Marshals the key info to XML.
        参数：
        parent - a mechanism-specific structure containing the parent node that the marshalled key info will be appended to
        context - the XMLCryptoContext containing additional context (may be null if not applicable)
        抛出：
        ClassCastException - if the type of parent or context is not compatible with this key info
        MarshalException - if the key info cannot be marshalled
        NullPointerException - if parent is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtrs <;>s"/."krcoeeCt


KeyInfoFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.keyinfo

类 KeyInfoFactory

  • java.lang.Object
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

  • public abstract class KeyInfoFactory
extends Object
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.

    Each instance of KeyInfoFactory supports a specific XML mechanism type. To create a KeyInfoFactory, call one of the static getInstance methods, passing in the XML mechanism type desired, for example:

    KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");

    The objects that this factory produces will be based on DOM and abide by the DOM interoperability requirements as defined in the DOM Mechanism Requirements section of the API overview. See the Service Providers section of the API overview for a list of standard mechanism types.

    KeyInfoFactory implementations are registered and loaded using the Provider mechanism. For example, a service provider that supports the DOM mechanism would be specified in the Provider subclass as:

         put("KeyInfoFactory.DOM", "org.example.DOMKeyInfoFactory");

    Also, the XMLStructures that are created by this factory may contain state specific to the KeyInfo and are not intended to be reusable.

    An implementation MUST minimally support the default mechanism type: DOM.

    Note that a caller must use the same KeyInfoFactory instance to create the XMLStructures of a particular KeyInfo object. The behavior is undefined if XMLStructures from different providers or different mechanism types are used together.

    Concurrent Access

    The static methods of this class are guaranteed to be thread-safe. Multiple threads may concurrently invoke the static methods defined in this class with no ill effects.

    However, this is not true for the non-static methods defined by this class. Unless otherwise documented by a specific provider, threads that need to access a single KeyInfoFactory instance concurrently should synchronize amongst themselves and provide the necessary locking. Multiple threads each manipulating a different KeyInfoFactory instance need not synchronize.

    从以下版本开始：
    1.6

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected KeyInfoFactory()
      Default constructor, for invocation by subclasses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static KeyInfoFactory getInstance()
      Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").
      static KeyInfoFactory getInstance(String mechanismType)
      Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static KeyInfoFactory getInstance(String mechanismType, Provider provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static KeyInfoFactory getInstance(String mechanismType, String provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      String getMechanismType()
      Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")
      Provider getProvider()
      Returns the provider of this KeyInfoFactory.
      abstract URIDereferencer getURIDereferencer()
      Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
      abstract boolean isFeatureSupported(String feature)
      Indicates whether a specified feature is supported.
      abstract KeyInfo newKeyInfo(List content)
      Creates a KeyInfo containing the specified list of key information types.
      abstract KeyInfo newKeyInfo(List content, String id)
      Creates a KeyInfo containing the specified list of key information types and optional id.
      abstract KeyName newKeyName(String name)
      Creates a KeyName from the specified name.
      abstract KeyValue newKeyValue(PublicKey key)
      Creates a KeyValue from the specified public key.
      abstract PGPData newPGPData(byte[] keyId)
      Creates a PGPData from the specified PGP public key identifier.
      abstract PGPData newPGPData(byte[] keyId, byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
      abstract PGPData newPGPData(byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP key material packet and optional list of external elements.
      abstract RetrievalMethod newRetrievalMethod(String uri)
      Creates a RetrievalMethod from the specified URI.
      abstract RetrievalMethod newRetrievalMethod(String uri, String type, List transforms)
      Creates a RetrievalMethod from the specified parameters.
      abstract X509Data newX509Data(List content)
      Creates a X509Data containing the specified list of X.509 content.
      abstract X509IssuerSerial newX509IssuerSerial(String issuerName, BigInteger serialNumber)
      Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
      abstract KeyInfo unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • KeyInfoFactory

        protected KeyInfoFactory()
        Default constructor, for invocation by subclasses.

    • 方法详细信息

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType)
        Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a KeyInfoFactory implementation of the desired mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new KeyInfoFactory object from the first Provider that supports the specified mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        返回：
        a new KeyInfoFactory
        抛出：
        NullPointerException - if mechanismType is null
        NoSuchMechanismException - if no Provider supports a KeyInfoFactory implementation for the specified mechanism
        另请参见：
        Provider

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType,
                         Provider provider)
        Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. Note that the specified Provider object does not have to be registered in the provider list.
        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the Provider object
        返回：
        a new KeyInfoFactory
        抛出：
        NullPointerException - if mechanismType or provider are null
        NoSuchMechanismException - if a KeyInfoFactory implementation for the specified mechanism is not available from the specified Provider object
        另请参见：
        Provider

      • getInstance

        public static KeyInfoFactory getInstance(String mechanismType,
                         String provider)
                                  throws NoSuchProviderException
        Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider. The specified provider must be registered in the security provider list.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        参数：
        mechanismType - the type of the XML processing mechanism and representation. See the Service Providers section of the API overview for a list of standard mechanism types.
        provider - the string name of the provider
        返回：
        a new KeyInfoFactory
        抛出：
        NoSuchProviderException - if the specified provider is not registered in the security provider list
        NullPointerException - if mechanismType or provider are null
        NoSuchMechanismException - if a KeyInfoFactory implementation for the specified mechanism is not available from the specified provider
        另请参见：
        Provider

      • getInstance

        public static KeyInfoFactory getInstance()
        Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").

        This method uses the standard JCA provider lookup mechanism to locate and instantiate a KeyInfoFactory implementation of the default mechanism type. It traverses the list of registered security Providers, starting with the most preferred Provider. A new KeyInfoFactory object from the first Provider that supports the DOM mechanism is returned.

        Note that the list of registered providers may be retrieved via the Security.getProviders() method.

        返回：
        a new KeyInfoFactory
        抛出：
        NoSuchMechanismException - if no Provider supports a KeyInfoFactory implementation for the DOM mechanism
        另请参见：
        Provider

      • getMechanismType

        public final String getMechanismType()
        Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")
        返回：
        the XML processing mechanism type supported by this KeyInfoFactory

      • getProvider

        public final Provider getProvider()
        Returns the provider of this KeyInfoFactory.
        返回：
        the provider of this KeyInfoFactory

      • newKeyInfo

        public abstract KeyInfo newKeyInfo(List content)
        Creates a KeyInfo containing the specified list of key information types.
        参数：
        content - a list of one or more XMLStructures representing key information types. The list is defensively copied to protect against subsequent modification.
        返回：
        a KeyInfo
        抛出：
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newKeyInfo

        public abstract KeyInfo newKeyInfo(List content,
                 String id)
        Creates a KeyInfo containing the specified list of key information types and optional id. The id parameter represents the value of an XML ID attribute and is useful for referencing the KeyInfo from other XML structures.
        参数：
        content - a list of one or more XMLStructures representing key information types. The list is defensively copied to protect against subsequent modification.
        id - the value of an XML ID (may be null)
        返回：
        a KeyInfo
        抛出：
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty
        ClassCastException - if content contains any entries that are not of type XMLStructure

      • newKeyName

        public abstract KeyName newKeyName(String name)
        Creates a KeyName from the specified name.
        参数：
        name - the name that identifies the key
        返回：
        a KeyName
        抛出：
        NullPointerException - if name is null

      • newKeyValue

        public abstract KeyValue newKeyValue(PublicKey key)
                              throws KeyException
        Creates a KeyValue from the specified public key.
        参数：
        key - the public key
        返回：
        a KeyValue
        抛出：
        KeyException - if the key's algorithm is not recognized or supported by this KeyInfoFactory
        NullPointerException - if key is null

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyId)
        Creates a PGPData from the specified PGP public key identifier.
        参数：
        keyId - a PGP public key identifier as defined in RFC 2440, section 11.2. The array is cloned to protect against subsequent modification.
        返回：
        a PGPData
        抛出：
        NullPointerException - if keyId is null
        IllegalArgumentException - if the key id is not in the correct format

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyId,
                 byte[] keyPacket,
                 List other)
        Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
        参数：
        keyId - a PGP public key identifier as defined in RFC 2440, section 11.2. The array is cloned to protect against subsequent modification.
        keyPacket - a PGP key material packet as defined in RFC 2440, section 5.5. The array is cloned to protect against subsequent modification. May be null.
        other - a list of XMLStructures representing elements from an external namespace. The list is defensively copied to protect against subsequent modification. May be null or empty.
        返回：
        a PGPData
        抛出：
        NullPointerException - if keyId is null
        IllegalArgumentException - if the keyId or keyPacket is not in the correct format. For keyPacket, the format of the packet header is checked and the tag is verified that it is of type key material. The contents and format of the packet body are not checked.
        ClassCastException - if other contains any entries that are not of type XMLStructure

      • newPGPData

        public abstract PGPData newPGPData(byte[] keyPacket,
                 List other)
        Creates a PGPData from the specified PGP key material packet and optional list of external elements.
        参数：
        keyPacket - a PGP key material packet as defined in RFC 2440, section 5.5. The array is cloned to protect against subsequent modification.
        other - a list of XMLStructures representing elements from an external namespace. The list is defensively copied to protect against subsequent modification. May be null or empty.
        返回：
        a PGPData
        抛出：
        NullPointerException - if keyPacket is null
        IllegalArgumentException - if keyPacket is not in the correct format. For keyPacket, the format of the packet header is checked and the tag is verified that it is of type key material. The contents and format of the packet body are not checked.
        ClassCastException - if other contains any entries that are not of type XMLStructure

      • newRetrievalMethod

        public abstract RetrievalMethod newRetrievalMethod(String uri)
        Creates a RetrievalMethod from the specified URI.
        参数：
        uri - the URI that identifies the KeyInfo information to be retrieved
        返回：
        a RetrievalMethod
        抛出：
        NullPointerException - if uri is null
        IllegalArgumentException - if uri is not RFC 2396 compliant

      • newRetrievalMethod

        public abstract RetrievalMethod newRetrievalMethod(String uri,
                                 String type,
                                 List transforms)
        Creates a RetrievalMethod from the specified parameters.
        参数：
        uri - the URI that identifies the KeyInfo information to be retrieved
        type - a URI that identifies the type of KeyInfo information to be retrieved (may be null)
        transforms - a list of Transforms. The list is defensively copied to protect against subsequent modification. May be null or empty.
        返回：
        a RetrievalMethod
        抛出：
        NullPointerException - if uri is null
        IllegalArgumentException - if uri is not RFC 2396 compliant
        ClassCastException - if transforms contains any entries that are not of type Transform

      • newX509Data

        public abstract X509Data newX509Data(List content)
        Creates a X509Data containing the specified list of X.509 content.
        参数：
        content - a list of one or more X.509 content types. Valid types are String (subject names), byte[] (subject key ids), X509Certificate, X509CRL, or XMLStructure (X509IssuerSerial objects or elements from an external namespace). Subject names are distinguished names in RFC 2253 String format. Implementations MUST support the attribute type keywords defined in RFC 2253 (CN, L, ST, O, OU, C, STREET, DC and UID). Implementations MAY support additional keywords. The list is defensively copied to protect against subsequent modification.
        返回：
        a X509Data
        抛出：
        NullPointerException - if content is null
        IllegalArgumentException - if content is empty, or if a subject name is not RFC 2253 compliant or one of the attribute type keywords is not recognized.
        ClassCastException - if content contains any entries that are not of one of the valid types mentioned above

      • newX509IssuerSerial

        public abstract X509IssuerSerial newX509IssuerSerial(String issuerName,
                                   BigInteger serialNumber)
        Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
        参数：
        issuerName - the issuer's distinguished name in RFC 2253 String format. Implementations MUST support the attribute type keywords defined in RFC 2253 (CN, L, ST, O, OU, C, STREET, DC and UID). Implementations MAY support additional keywords.
        serialNumber - the serial number
        返回：
        an X509IssuerSerial
        抛出：
        NullPointerException - if issuerName or serialNumber are null
        IllegalArgumentException - if the issuer name is not RFC 2253 compliant or one of the attribute type keywords is not recognized.

      • isFeatureSupported

        public abstract boolean isFeatureSupported(String feature)
        Indicates whether a specified feature is supported.
        参数：
        feature - the feature name (as an absolute URI)
        返回：
        true if the specified feature is supported, false otherwise
        抛出：
        NullPointerException - if feature is null

      • getURIDereferencer

        public abstract URIDereferencer getURIDereferencer()
        Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.
        返回：
        a reference to the default URIDereferencer

      • unmarshalKeyInfo

        public abstract KeyInfo unmarshalKeyInfo(XMLStructure xmlStructure)
                                  throws MarshalException
        Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
        参数：
        xmlStructure - a mechanism-specific XML structure from which to unmarshal the keyinfo from
        返回：
        the KeyInfo
        抛出：
        NullPointerException - if xmlStructure is null
        ClassCastException - if the type of xmlStructure is inappropriate for this factory
        MarshalException - if an unrecoverable exception occurs during unmarshalling
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


KeyName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface KeyName

  • All Superinterfaces:
    XMLStructure

    public interface KeyName
extends XMLStructure
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyName object contains a string value which may be used by the signer to communicate a key identifier to the recipient. The XML Schema Definition is defined as:
     <element name="KeyName" type="string"/>
    A KeyName instance may be created by invoking the newKeyName method of the KeyInfoFactory class, and passing it a String representing the name of the key; for example:
     KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 KeyName keyName = factory.newKeyName("Alice");
    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newKeyName(String)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Returns the name of this KeyName.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getName

        String getName()
        Returns the name of this KeyName.
        返回：
        the name of this KeyName (never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"ooeoaa.."/..//oddxdxt


KeyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface KeyValue

  • All Superinterfaces:
    XMLStructure

    public interface KeyValue
extends XMLStructure
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A KeyValue object contains a single public key that may be useful in validating the signature. The XML schema definition is defined as:
        <element name="KeyValue" type="ds:KeyValueType"/>
    <complexType name="KeyValueType" mixed="true">
      <choice>
        <element ref="ds:DSAKeyValue"/>
        <element ref="ds:RSAKeyValue"/>
        <any namespace="##other" processContents="lax"/>
      </choice>
    </complexType>

    <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>
    <complexType name="DSAKeyValueType">
      <sequence>
        <sequence minOccurs="0">
          <element name="P" type="ds:CryptoBinary"/>
          <element name="Q" type="ds:CryptoBinary"/>
        </sequence>
        <element name="G" type="ds:CryptoBinary" minOccurs="0"/>
        <element name="Y" type="ds:CryptoBinary"/>
        <element name="J" type="ds:CryptoBinary" minOccurs="0"/>
        <sequence minOccurs="0">
          <element name="Seed" type="ds:CryptoBinary"/>
          <element name="PgenCounter" type="ds:CryptoBinary"/>
        </sequence>
      </sequence>
    </complexType>

    <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>
    <complexType name="RSAKeyValueType">
      <sequence>
        <element name="Modulus" type="ds:CryptoBinary"/>
        <element name="Exponent" type="ds:CryptoBinary"/>
      </sequence>
    </complexType>
    A KeyValue instance may be created by invoking the newKeyValue method of the KeyInfoFactory class, and passing it a PublicKey representing the value of the public key. Here is an example of creating a KeyValue from a DSAPublicKey of a Certificate stored in a KeyStore:
     KeyStore keyStore = KeyStore.getInstance(KeyStore.getDefaultType());
 PublicKey dsaPublicKey = keyStore.getCertificate("myDSASigningCert").getPublicKey();
 KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 KeyValue keyValue = factory.newKeyValue(dsaPublicKey);
    This class returns the DSAKeyValue and RSAKeyValue elements as objects of type DSAPublicKey and RSAPublicKey, respectively. Note that not all of the fields in the schema are accessible as parameters of these types.
    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newKeyValue(PublicKey)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DSA_TYPE
      URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue.
      static String RSA_TYPE
      URI identifying the RSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#RSAKeyValue.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      PublicKey getPublicKey()
      Returns the public key of this KeyValue.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • DSA_TYPE

        static final String DSA_TYPE
        URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote DSAKeyValue structure.
        另请参见：
        Constant Field Values

      • RSA_TYPE

        static final String RSA_TYPE
        URI identifying the RSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#RSAKeyValue. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote RSAKeyValue structure.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getPublicKey

        PublicKey getPublicKey()
                       throws KeyException
        Returns the public key of this KeyValue.
        返回：
        the public key of this KeyValue
        抛出：
        KeyException - if this KeyValue cannot be converted to a PublicKey
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ _shkf>u>kajgsegc-pcfs


PGPData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface PGPData

  • All Superinterfaces:
    XMLStructure

    public interface PGPData
extends XMLStructure
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A PGPData object is used to convey information related to PGP public key pairs and signatures on such keys. The XML Schema Definition is defined as:
        <element name="PGPData" type="ds:PGPDataType"/>
    <complexType name="PGPDataType">
      <choice>
        <sequence>
          <element name="PGPKeyID" type="base64Binary"/>
          <element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
        <sequence>
          <element name="PGPKeyPacket" type="base64Binary"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
      </choice>
    </complexType>
    A PGPData instance may be created by invoking one of the newPGPData methods of the KeyInfoFactory class, and passing it byte arrays representing the contents of the PGP public key identifier and/or PGP key material packet, and an optional list of elements from an external namespace.
    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newPGPData(byte[]),
KeyInfoFactory.newPGPData(byte[], byte[], List),
KeyInfoFactory.newPGPData(byte[], List)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String TYPE
      URI identifying the PGPData KeyInfo type: http://www.w3.org/2000/09/xmldsig#PGPData.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getExternalElements()
      Returns an unmodifiable list of XMLStructures representing elements from an external namespace.
      byte[] getKeyId()
      Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.
      byte[] getKeyPacket()
      Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • TYPE

        static final String TYPE
        URI identifying the PGPData KeyInfo type: http://www.w3.org/2000/09/xmldsig#PGPData. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote PGPData structure.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getKeyId

        byte[] getKeyId()
        Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.
        返回：
        the PGP public key identifier (may be null if not specified). Each invocation of this method returns a new clone to protect against subsequent modification.

      • getKeyPacket

        byte[] getKeyPacket()
        Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.
        返回：
        the PGP key material packet (may be null if not specified). Each invocation of this method returns a new clone to protect against subsequent modification.

      • getExternalElements

        List getExternalElements()
        Returns an unmodifiable list of XMLStructures representing elements from an external namespace.
        返回：
        an unmodifiable list of XMLStructures (may be empty, but never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e. >t>>->" -- ett> <>bl/>e=hm>ahd<<


RetrievalMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface RetrievalMethod

  • All Superinterfaces:
    URIReference, XMLStructure

    public interface RetrievalMethod
extends URIReference, XMLStructure
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. A RetrievalMethod object is used to convey a reference to KeyInfo information that is stored at another location. The XML schema definition is defined as:
       <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>
   <complexType name="RetrievalMethodType">
     <sequence>
       <element name="Transforms" type="ds:TransformsType" minOccurs="0"/>
     </sequence>
     <attribute name="URI" type="anyURI"/>
     <attribute name="Type" type="anyURI" use="optional"/>
   </complexType>
    A RetrievalMethod instance may be created by invoking one of the newRetrievalMethod methods of the KeyInfoFactory class, and passing it the URI identifying the location of the KeyInfo, an optional type URI identifying the type of KeyInfo, and an optional list of Transforms; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   RetrievalMethod rm = factory.newRetrievalMethod
      ("#KeyValue-1", KeyValue.DSA_TYPE, Collections.singletonList(Transform.BASE64));
    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newRetrievalMethod(String), KeyInfoFactory.newRetrievalMethod(String, String, List)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Data dereference(XMLCryptoContext context)
      Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
      List getTransforms()
      Returns an unmodifiable list of Transforms of this RetrievalMethod.
      String getURI()
      Returns the URI of the referenced KeyInfo information.

      • 方法 - 继承于接口 javax.xml.crypto.URIReference

        getType

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getTransforms

        List getTransforms()
        Returns an unmodifiable list of Transforms of this RetrievalMethod.
        返回：
        an unmodifiable list of Transform objects (may be empty but never null).

      • getURI

        String getURI()
        Returns the URI of the referenced KeyInfo information.
        指定者：
        getURI in interface URIReference
        返回：
        the URI of the referenced KeyInfo information in RFC 2396 format (never null)

      • dereference

        Data dereference(XMLCryptoContext context)
                 throws URIReferenceException
        Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
        参数：
        context - an XMLCryptoContext that may contain additional useful information for dereferencing the URI. The context's baseURI and dereferencer parameters (if specified) are used to resolve and dereference this RetrievalMethod
        返回：
        a Data object representing the raw contents of the KeyInfo information referenced by this RetrievalMethod. It is the caller's responsibility to convert the returned data to an appropriate KeyInfo object.
        抛出：
        NullPointerException - if context is null
        URIReferenceException - if there is an error while dereferencing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toJbebb"b_lkb>v/u9l


Uses of Package javax.xml.crypto.dsig.keyinfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto.dsig.keyinfo

  • Packages that use javax.xml.crypto.dsig.keyinfo
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto
    类与描述
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto.dsig
    类与描述
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.
  • Classes in javax.xml.crypto.dsig.keyinfo used by javax.xml.crypto.dsig.keyinfo
    类与描述
    KeyInfo
    A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyInfoFactory
    A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.
    KeyName
    A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    KeyValue
    A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    PGPData
    A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    RetrievalMethod
    A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509Data
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
    X509IssuerSerial
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ec


X509Data

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface X509Data

  • All Superinterfaces:
    XMLStructure

    public interface X509Data
extends XMLStructure
    A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An X509Data object contains one or more identifers of keys or X.509 certificates (or certificates' identifiers or a revocation list). The XML Schema Definition is defined as:
        <element name="X509Data" type="ds:X509DataType"/>
    <complexType name="X509DataType">
        <sequence maxOccurs="unbounded">
          <choice>
            <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
            <element name="X509SKI" type="base64Binary"/>
            <element name="X509SubjectName" type="string"/>
            <element name="X509Certificate" type="base64Binary"/>
            <element name="X509CRL" type="base64Binary"/>
            <any namespace="##other" processContents="lax"/>
          </choice>
        </sequence>
    </complexType>

    <complexType name="X509IssuerSerialType">
      <sequence>
        <element name="X509IssuerName" type="string"/>
        <element name="X509SerialNumber" type="integer"/>
      </sequence>
    </complexType>
    An X509Data instance may be created by invoking the newX509Data methods of the KeyInfoFactory class and passing it a list of one or more XMLStructures representing X.509 content; for example:
       KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
   X509Data x509Data = factory.newX509Data
       (Collections.singletonList("cn=Alice"));
    从以下版本开始：
    1.6
    另请参见：
    KeyInfoFactory.newX509Data(List)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String RAW_X509_CERTIFICATE_TYPE
      URI identifying the binary (ASN.1 DER) X.509 Certificate KeyInfo type: http://www.w3.org/2000/09/xmldsig#rawX509Certificate.
      static String TYPE
      URI identifying the X509Data KeyInfo type: http://www.w3.org/2000/09/xmldsig#X509Data.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getContent()
      Returns an unmodifiable list of the content in this X509Data.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 字段详细信息

      • TYPE

        static final String TYPE
        URI identifying the X509Data KeyInfo type: http://www.w3.org/2000/09/xmldsig#X509Data. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote X509Data structure.
        另请参见：
        Constant Field Values

      • RAW_X509_CERTIFICATE_TYPE

        static final String RAW_X509_CERTIFICATE_TYPE
        URI identifying the binary (ASN.1 DER) X.509 Certificate KeyInfo type: http://www.w3.org/2000/09/xmldsig#rawX509Certificate. This can be specified as the value of the type parameter of the RetrievalMethod class to describe a remote X509 Certificate.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getContent

        List getContent()
        Returns an unmodifiable list of the content in this X509Data. Valid types are String (subject names), byte[] (subject key ids), X509Certificate, X509CRL, or XMLStructure (X509IssuerSerial objects or elements from an external namespace).
        返回：
        an unmodifiable list of the content in this X509Data (never null or empty)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

doe t o soe dadve胻r"hbtblale.tat傅�


X509IssuerSerial

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.keyinfo

Interface X509IssuerSerial

  • All Superinterfaces:
    XMLStructure

    public interface X509IssuerSerial
extends XMLStructure
    A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing. An X509IssuerSerial object contains an X.509 issuer distinguished name (DN) and serial number pair. The XML schema definition is defined as:
       <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
   <complexType name="X509IssuerSerialType">
     <sequence>
       <element name="X509IssuerName" type="string"/>
       <element name="X509SerialNumber" type="integer"/>
     </sequence>
   </complexType>
    An X509IssuerSerial instance may be created by invoking the newX509IssuerSerial method of the KeyInfoFactory class, and passing it a String and BigInteger representing the X.500 DN and serial number. Here is an example of creating an X509IssuerSerial from the issuer DN and serial number of an existing X509Certificate:
     KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
 X509IssuerSerial issuer = factory.newX509IssuerSerial
     (cert.getIssuerX500Principal().getName(), cert.getSerialNumber());
    从以下版本开始：
    1.6
    另请参见：
    X509Data.getContent(), KeyInfoFactory.newX509IssuerSerial(String, BigInteger)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getIssuerName()
      Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.
      BigInteger getSerialNumber()
      Returns the serial number of this X509IssuerSerial.

      • 方法 - 继承于接口 javax.xml.crypto.XMLStructure

        isFeatureSupported

    • 方法详细信息

      • getIssuerName

        String getIssuerName()
        Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.
        返回：
        the X.500 distinguished name in RFC 2253 String format (never null)

      • getSerialNumber

        BigInteger getSerialNumber()
        Returns the serial number of this X509IssuerSerial.
        返回：
        the serial number (never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ivftt/cy/ceuuceea/ee/dS/m


Uses of Class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

  • Packages that use KeyInfoFactory
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyInfoFactory in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeyInfoFactory
      修饰符与类型 方法与描述
      KeyInfoFactory XMLSignatureFactory.getKeyInfoFactory()
      Returns a KeyInfoFactory that creates KeyInfo objects.

    • Uses of KeyInfoFactory in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyInfoFactory
      修饰符与类型 方法与描述
      static KeyInfoFactory KeyInfoFactory.getInstance()
      Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType)
      Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, Provider provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
      static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, String provider)
      Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elt ai


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyInfo

  • Packages that use KeyInfo
    软件包 描述
    javax.xml.crypto
    Common classes for XML cryptography.
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyInfo in javax.xml.crypto

      Methods in javax.xml.crypto with parameters of type KeyInfo
      修饰符与类型 方法与描述
      abstract KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
      Attempts to find a key that satisfies the specified constraints.

    • Uses of KeyInfo in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig that return KeyInfo
      修饰符与类型 方法与描述
      KeyInfo XMLSignature.getKeyInfo()
      Returns the key info of this XMLSignature.
      Methods in javax.xml.crypto.dsig with parameters of type KeyInfo
      修饰符与类型 方法与描述
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki)
      Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
      abstract XMLSignature XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
      Creates an XMLSignature and initializes it with the specified parameters.

    • Uses of KeyInfo in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyInfo
      修饰符与类型 方法与描述
      abstract KeyInfo KeyInfoFactory.newKeyInfo(List content)
      Creates a KeyInfo containing the specified list of key information types.
      abstract KeyInfo KeyInfoFactory.newKeyInfo(List content, String id)
      Creates a KeyInfo containing the specified list of key information types and optional id.
      abstract KeyInfo KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure)
      Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>-slj鎝a2t


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyName

  • Packages that use KeyName
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyName in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyName
      修饰符与类型 方法与描述
      abstract KeyName KeyInfoFactory.newKeyName(String name)
      Creates a KeyName from the specified name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e"ie>s<>cccs=""s"pty:( l


Uses of Interface javax.xml.crypto.dsig.keyinfo.KeyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.KeyValue

  • Packages that use KeyValue
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of KeyValue in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return KeyValue
      修饰符与类型 方法与描述
      abstract KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
      Creates a KeyValue from the specified public key.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eoy/o皀rcyyem///p or�> �/


Uses of Interface javax.xml.crypto.dsig.keyinfo.PGPData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.PGPData

  • Packages that use PGPData
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of PGPData in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return PGPData
      修饰符与类型 方法与描述
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyId)
      Creates a PGPData from the specified PGP public key identifier.
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
      abstract PGPData KeyInfoFactory.newPGPData(byte[] keyPacket, List other)
      Creates a PGPData from the specified PGP key material packet and optional list of external elements.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a v...o"=..nr yy=ltnraj╯


Uses of Interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.RetrievalMethod

  • Packages that use RetrievalMethod
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of RetrievalMethod in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return RetrievalMethod
      修饰符与类型 方法与描述
      abstract RetrievalMethod KeyInfoFactory.newRetrievalMethod(String uri)
      Creates a RetrievalMethod from the specified URI.
      abstract RetrievalMethod KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms)
      Creates a RetrievalMethod from the specified parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>trepaportgdca史邓 纺姆�


Uses of Interface javax.xml.crypto.dsig.keyinfo.X509Data

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.X509Data

  • Packages that use X509Data
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of X509Data in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return X509Data
      修饰符与类型 方法与描述
      abstract X509Data KeyInfoFactory.newX509Data(List content)
      Creates a X509Data containing the specified list of X.509 content.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cll".mlmt"A "acci"iaa a.


Uses of Interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

  • Packages that use X509IssuerSerial
    软件包 描述
    javax.xml.crypto.dsig.keyinfo
    Classes for parsing and processing KeyInfo elements and structures.

    • Uses of X509IssuerSerial in javax.xml.crypto.dsig.keyinfo

      Methods in javax.xml.crypto.dsig.keyinfo that return X509IssuerSerial
      修饰符与类型 方法与描述
      abstract X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
      Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Em=-====== << T/}n /s t


C14NMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig.spec

Interface C14NMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec, TransformParameterSpec
    All Known Implementing Classes:
    ExcC14NParameterSpec

    public interface C14NMethodParameterSpec
extends TransformParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm. The purpose of this interface is to group (and provide type safety for) all canonicalization (C14N) parameter specifications. All canonicalization parameter specifications must implement this interface.
    从以下版本开始：
    1.6
    另请参见：
    CanonicalizationMethod
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dvsc/ars


DigestMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig.spec

Interface DigestMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec

    public interface DigestMethodParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm. The purpose of this interface is to group (and provide type safety for) all digest method parameter specifications. All digest method parameter specifications must implement this interface.
    从以下版本开始：
    1.6
    另请参见：
    DigestMethod
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iX粼湓Ｔ帷员六� �>龋利校//


ExcC14NParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 ExcC14NParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
  • 所有已实现的接口：
    AlgorithmParameterSpec, C14NMethodParameterSpec, TransformParameterSpec

    public final class ExcC14NParameterSpec
extends Object
implements C14NMethodParameterSpec
    Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm. The parameters include an optional inclusive namespace prefix list. The XML Schema Definition of the Exclusive XML Canonicalization parameters is defined as:

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:ec="http://www.w3.org/2001/10/xml-exc-c14n#"
         targetNamespace="http://www.w3.org/2001/10/xml-exc-c14n#"
         version="0.1" elementFormDefault="qualified">

 <element name="InclusiveNamespaces" type="ec:InclusiveNamespaces"/>
 <complexType name="InclusiveNamespaces">
   <attribute name="PrefixList" type="xsd:string"/>
 </complexType>
 </schema>
    从以下版本开始：
    1.6
    另请参见：
    CanonicalizationMethod

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT
      Indicates the default namespace ("#default").

    • 构造方法摘要

      Constructors
      构造方法与描述
      ExcC14NParameterSpec()
      Creates a ExcC14NParameterSpec with an empty prefix list.
      ExcC14NParameterSpec(List prefixList)
      Creates a ExcC14NParameterSpec with the specified list of prefixes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getPrefixList()
      Returns the inclusive namespace prefix list.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT

        public static final String DEFAULT
        Indicates the default namespace ("#default").
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • ExcC14NParameterSpec

        public ExcC14NParameterSpec()
        Creates a ExcC14NParameterSpec with an empty prefix list.

      • ExcC14NParameterSpec

        public ExcC14NParameterSpec(List prefixList)
        Creates a ExcC14NParameterSpec with the specified list of prefixes. The list is copied to protect against subsequent modification.
        参数：
        prefixList - the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.
        抛出：
        NullPointerException - if prefixList is null
        ClassCastException - if any of the entries in the list are not of type String

    • 方法详细信息

      • getPrefixList

        public List getPrefixList()
        Returns the inclusive namespace prefix list. Each entry in the list is a String that represents a namespace prefix.

        This implementation returns an unmodifiable list.

        返回：
        the inclusive namespace prefix list (may be empty but never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h . dadv∏jx


HMACParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 HMACParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.HMACParameterSpec
  • 所有已实现的接口：
    AlgorithmParameterSpec, SignatureMethodParameterSpec

    public final class HMACParameterSpec
extends Object
implements SignatureMethodParameterSpec
    Parameters for the XML Signature HMAC Algorithm. The parameters include an optional output length which specifies the MAC truncation length in bits. The resulting HMAC will be truncated to the specified number of bits. If the parameter is not specified, then this implies that all the bits of the hash are to be output. The XML Schema Definition of the HMACOutputLength element is defined as:

 <element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
 <simpleType name="HMACOutputLengthType">
   <restriction base="integer"/>
 </simpleType>
    从以下版本开始：
    1.6
    另请参见：
    SignatureMethod, RFC 2104

    • 构造方法摘要

      Constructors
      构造方法与描述
      HMACParameterSpec(int outputLength)
      Creates an HMACParameterSpec with the specified truncation length.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getOutputLength()
      Returns the truncation length.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HMACParameterSpec

        public HMACParameterSpec(int outputLength)
        Creates an HMACParameterSpec with the specified truncation length.
        参数：
        outputLength - the truncation length in number of bits

    • 方法详细信息

      • getOutputLength

        public int getOutputLength()
        Returns the truncation length.
        返回：
        the truncation length in number of bits
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hitu/a.ja..//....ecc"lsskccablk L


javax.xml.crypto.dsig.spec

Interfaces

  • C14NMethodParameterSpec
  • DigestMethodParameterSpec
  • SignatureMethodParameterSpec
  • TransformParameterSpec

Classes

  • ExcC14NParameterSpec
  • HMACParameterSpec
  • XPathFilter2ParameterSpec
  • XPathFilterParameterSpec
  • XPathType
  • XPathType.Filter
  • XSLTTransformParameterSpec
>


javax.xml.crypto.dsig.spec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.crypto.dsig.spec

Parameter classes for XML digital signatures.

请参见： 描述

  • 接口摘要
    接口 描述
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    DigestMethodParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
  • Class Summary
    类 描述
    ExcC14NParameterSpec
    Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
    HMACParameterSpec
    Parameters for the XML Signature HMAC Algorithm.
    XPathFilter2ParameterSpec
    Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
    XPathFilterParameterSpec
    Parameters for the XPath Filtering Transform Algorithm.
    XPathType
    The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:
    XPathType.Filter
    Represents the filter set operation.
    XSLTTransformParameterSpec
    Parameters for the XSLT Transform Algorithm.

软件包 javax.xml.crypto.dsig.spec Description

Parameter classes for XML digital signatures. This package contains interfaces and classes representing input parameters for the digest, signature, transform, or canonicalization algorithms used in the processing of XML signatures.

Package Specification

  • XML-Signature Syntax and Processing: W3C Recommendation
  • RFC 3275: XML-Signature Syntax and Processing
  • Exclusive XML Canonicalization algorithm: W3C Recommendation
  • XPath Filter 2.0 Transform Algorithm: W3C Recommendation

从以下版本开始：
1.6
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-s-e-} -/-/>>/p>;;e> "np.n


javax.xml.crypto.dsig.spec Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.crypto.dsig.spec

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)

Interface Hierarchy

  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atrna>


SignatureMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig.spec

Interface SignatureMethodParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec
    All Known Implementing Classes:
    HMACParameterSpec

    public interface SignatureMethodParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm. The purpose of this interface is to group (and provide type safety for) all signature method parameter specifications. All signature method parameter specifications must implement this interface.
    从以下版本开始：
    1.6
    另请参见：
    SignatureMethod
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

RaT=< /


TransformParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.crypto.dsig.spec

Interface TransformParameterSpec

  • All Superinterfaces:
    AlgorithmParameterSpec
    All Known Subinterfaces:
    C14NMethodParameterSpec
    All Known Implementing Classes:
    ExcC14NParameterSpec, XPathFilter2ParameterSpec, XPathFilterParameterSpec, XSLTTransformParameterSpec

    public interface TransformParameterSpec
extends AlgorithmParameterSpec
    A specification of algorithm parameters for a Transform algorithm. The purpose of this interface is to group (and provide type safety for) all transform parameter specifications. All transform parameter specifications must implement this interface.
    从以下版本开始：
    1.6
    另请参见：
    Transform
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a<>edlx<"".r/ao=.of


Uses of Package javax.xml.crypto.dsig.spec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.crypto.dsig.spec

  • Packages that use javax.xml.crypto.dsig.spec
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.
  • Classes in javax.xml.crypto.dsig.spec used by javax.xml.crypto.dsig
    类与描述
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    DigestMethodParameterSpec
    A specification of algorithm parameters for a DigestMethod algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
  • Classes in javax.xml.crypto.dsig.spec used by javax.xml.crypto.dsig.spec
    类与描述
    C14NMethodParameterSpec
    A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
    SignatureMethodParameterSpec
    A specification of algorithm parameters for an XML SignatureMethod algorithm.
    TransformParameterSpec
    A specification of algorithm parameters for a Transform algorithm.
    XPathType.Filter
    Represents the filter set operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mcmapekepppptx>.ta/pyllg


XPathFilter2ParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 XPathFilter2ParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
  • 所有已实现的接口：
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XPathFilter2ParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm. The parameters include a list of one or more XPathType objects.
    从以下版本开始：
    1.6
    另请参见：
    Transform, XPathFilterParameterSpec

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathFilter2ParameterSpec(List xPathList)
      Creates an XPathFilter2ParameterSpec.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List getXPathList()
      Returns a list of one or more XPathType objects.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XPathFilter2ParameterSpec

        public XPathFilter2ParameterSpec(List xPathList)
        Creates an XPathFilter2ParameterSpec.
        参数：
        xPathList - a list of one or more XPathType objects. The list is defensively copied to protect against subsequent modification.
        抛出：
        ClassCastException - if xPathList contains any entries that are not of type XPathType
        IllegalArgumentException - if xPathList is empty
        NullPointerException - if xPathList is null

    • 方法详细信息

      • getXPathList

        public List getXPathList()
        Returns a list of one or more XPathType objects.

        This implementation returns an unmodifiable list.

        返回：
        a List of XPathType objects (never null or empty)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.c..s.B.//3..c=n t>sb�;;8sn <<>>i/rds>�


XPathFilterParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 XPathFilterParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
  • 所有已实现的接口：
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XPathFilterParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the XPath Filtering Transform Algorithm. The parameters include the XPath expression and an optional Map of additional namespace prefix mappings. The XML Schema Definition of the XPath Filtering transform parameters is defined as:

 <element name="XPath" type="string"/>
    从以下版本开始：
    1.6
    另请参见：
    Transform

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathFilterParameterSpec(String xPath)
      Creates an XPathFilterParameterSpec with the specified XPath expression.
      XPathFilterParameterSpec(String xPath, Map namespaceMap)
      Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Map getNamespaceMap()
      Returns a map of namespace prefixes.
      String getXPath()
      Returns the XPath expression to be evaluated.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XPathFilterParameterSpec

        public XPathFilterParameterSpec(String xPath)
        Creates an XPathFilterParameterSpec with the specified XPath expression.
        参数：
        xPath - the XPath expression to be evaluated
        抛出：
        NullPointerException - if xPath is null

      • XPathFilterParameterSpec

        public XPathFilterParameterSpec(String xPath,
                        Map namespaceMap)
        Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map. The map is copied to protect against subsequent modification.
        参数：
        xPath - the XPath expression to be evaluated
        namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
        抛出：
        NullPointerException - if xPath or namespaceMap are null
        ClassCastException - if any of the map's keys or entries are not of type String

    • 方法详细信息

      • getXPath

        public String getXPath()
        Returns the XPath expression to be evaluated.
        返回：
        the XPath expression to be evaluated

      • getNamespaceMap

        public Map getNamespaceMap()
        Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

        This implementation returns an unmodifiable map.

        返回：
        a Map of namespace prefixes to namespace URIs (may be empty, but never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c.d p m ,ia cluxod/m媸档� 宰鲕“笆砸√>


XPathType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 XPathType

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathType

  • public class XPathType
extends Object
    The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:xf="http://www.w3.org/2002/06/xmldsig-filter2"
         targetNamespace="http://www.w3.org/2002/06/xmldsig-filter2"
         version="0.1" elementFormDefault="qualified">

 <element name="XPath"
          type="xf:XPathType"/>

 <complexType name="XPathType">
   <simpleContent>
     <extension base="string">
       <attribute name="Filter">
         <simpleType>
           <restriction base="string">
             <enumeration value="intersect"/>
             <enumeration value="subtract"/>
             <enumeration value="union"/>
           </restriction>
         </simpleType>
       </attribute>
     </extension>
   </simpleContent>
 </complexType>
    从以下版本开始：
    1.6
    另请参见：
    XPathFilter2ParameterSpec

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  XPathType.Filter
      Represents the filter set operation.

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathType(String expression, XPathType.Filter filter)
      Creates an XPathType instance with the specified XPath expression and filter.
      XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
      Creates an XPathType instance with the specified XPath expression, filter, and namespace map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getExpression()
      Returns the XPath expression to be evaluated.
      XPathType.Filter getFilter()
      Returns the filter operation.
      Map getNamespaceMap()
      Returns a map of namespace prefixes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XPathType

        public XPathType(String expression,
         XPathType.Filter filter)
        Creates an XPathType instance with the specified XPath expression and filter.
        参数：
        expression - the XPath expression to be evaluated
        filter - the filter operation (XPathType.Filter.INTERSECT, XPathType.Filter.SUBTRACT, or XPathType.Filter.UNION)
        抛出：
        NullPointerException - if expression or filter is null

      • XPathType

        public XPathType(String expression,
         XPathType.Filter filter,
         Map namespaceMap)
        Creates an XPathType instance with the specified XPath expression, filter, and namespace map. The map is copied to protect against subsequent modification.
        参数：
        expression - the XPath expression to be evaluated
        filter - the filter operation (XPathType.Filter.INTERSECT, XPathType.Filter.SUBTRACT, or XPathType.Filter.UNION)
        namespaceMap - the map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.
        抛出：
        NullPointerException - if expression, filter or namespaceMap are null
        ClassCastException - if any of the map's keys or entries are not of type String

    • 方法详细信息

      • getExpression

        public String getExpression()
        Returns the XPath expression to be evaluated.
        返回：
        the XPath expression to be evaluated

      • getFilter

        public XPathType.Filter getFilter()
        Returns the filter operation.
        返回：
        the filter operation

      • getNamespaceMap

        public Map getNamespaceMap()
        Returns a map of namespace prefixes. Each key is a namespace prefix String that maps to a corresponding namespace URI String.

        This implementation returns an unmodifiable map.

        返回：
        a Map of namespace prefixes to namespace URIs (may be empty, but never null)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/R=e.e/a M"h


XPathType.Filter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.crypto.dsig.spec

类 XPathType.Filter

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XPathType.Filter
  • 封闭类：
    XPathType

    public static class XPathType.Filter
extends Object
    Represents the filter set operation.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static XPathType.Filter INTERSECT
      The intersect filter operation.
      static XPathType.Filter SUBTRACT
      The subtract filter operation.
      static XPathType.Filter UNION
      The union filter operation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Returns the string form of the operation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • INTERSECT

        public static final XPathType.Filter INTERSECT
        The intersect filter operation.

      • SUBTRACT

        public static final XPathType.Filter SUBTRACT
        The subtract filter operation.

      • UNION

        public static final XPathType.Filter UNION
        The union filter operation.

    • 方法详细信息

      • toString

        public String toString()
        Returns the string form of the operation.
        重载：
        toString in class Object
        返回：
        the string form of the operation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o npe"t="t iit tarr== T== -Rv= vmsNs


XSLTTransformParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.crypto.dsig.spec

类 XSLTTransformParameterSpec

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
  • 所有已实现的接口：
    AlgorithmParameterSpec, TransformParameterSpec

    public final class XSLTTransformParameterSpec
extends Object
implements TransformParameterSpec
    Parameters for the XSLT Transform Algorithm. The parameters include a namespace-qualified stylesheet element.

    An XSLTTransformParameterSpec is instantiated with a mechanism-dependent (ex: DOM) stylesheet element. For example:

       DOMStructure stylesheet = new DOMStructure(element)
   XSLTTransformParameterSpec spec = new XSLTransformParameterSpec(stylesheet);
    where element is an Element containing the namespace-qualified stylesheet element.
    从以下版本开始：
    1.6
    另请参见：
    Transform

    • 构造方法摘要

      Constructors
      构造方法与描述
      XSLTTransformParameterSpec(XMLStructure stylesheet)
      Creates an XSLTTransformParameterSpec with the specified stylesheet.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XMLStructure getStylesheet()
      Returns the stylesheet.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XSLTTransformParameterSpec

        public XSLTTransformParameterSpec(XMLStructure stylesheet)
        Creates an XSLTTransformParameterSpec with the specified stylesheet.
        参数：
        stylesheet - the XSLT stylesheet to be used
        抛出：
        NullPointerException - if stylesheet is null

    • 方法详细信息

      • getStylesheet

        public XMLStructure getStylesheet()
        Returns the stylesheet.
        返回：
        the stylesheet
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

) s/>ta>tleetllp>oola/xoyycap/pdeotiox/ags


Uses of Class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.ExcC14NParameterSpec

No usage of javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.gxeter=e"""i.aa.e..r


Uses of Class javax.xml.crypto.dsig.spec.HMACParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.HMACParameterSpec

No usage of javax.xml.crypto.dsig.spec.HMACParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nj/>slplaay/


Uses of Class javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec

No usage of javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)adv


Uses of Class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

No usage of javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>�a>lxadceitc/ d


Uses of Class javax.xml.crypto.dsig.spec.XPathType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.XPathType

No usage of javax.xml.crypto.dsig.spec.XPathType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

XtP= cls


Uses of Class javax.xml.crypto.dsig.spec.XPathType.Filter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.XPathType.Filter

  • Packages that use XPathType.Filter
    软件包 描述
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of XPathType.Filter in javax.xml.crypto.dsig.spec

      Fields in javax.xml.crypto.dsig.spec declared as XPathType.Filter
      修饰符与类型 字段与描述
      static XPathType.Filter XPathType.Filter.INTERSECT
      The intersect filter operation.
      static XPathType.Filter XPathType.Filter.SUBTRACT
      The subtract filter operation.
      static XPathType.Filter XPathType.Filter.UNION
      The union filter operation.
      Methods in javax.xml.crypto.dsig.spec that return XPathType.Filter
      修饰符与类型 方法与描述
      XPathType.Filter XPathType.getFilter()
      Returns the filter operation.
      Constructors in javax.xml.crypto.dsig.spec with parameters of type XPathType.Filter
      构造方法与描述
      XPathType(String expression, XPathType.Filter filter)
      Creates an XPathType instance with the specified XPath expression and filter.
      XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
      Creates an XPathType instance with the specified XPath expression, filter, and namespace map.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

arpearsvbyl>"<


Uses of Class javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec

No usage of javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/cu>c" sce��>a薿ho<


Uses of Interface javax.xml.crypto.dsig.spec.C14NMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.spec.C14NMethodParameterSpec

  • Packages that use C14NMethodParameterSpec
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of C14NMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type C14NMethodParameterSpec
      修饰符与类型 方法与描述
      abstract CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
      Creates a CanonicalizationMethod for the specified algorithm URI and parameters.

    • Uses of C14NMethodParameterSpec in javax.xml.crypto.dsig.spec

      Classes in javax.xml.crypto.dsig.spec that implement C14NMethodParameterSpec
      修饰符与类型 类与描述
      class  ExcC14NParameterSpec
      Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ctnclI輔yp


Uses of Interface javax.xml.crypto.dsig.spec.DigestMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.spec.DigestMethodParameterSpec

  • Packages that use DigestMethodParameterSpec
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.

    • Uses of DigestMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type DigestMethodParameterSpec
      修饰符与类型 方法与描述
      abstract DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
      Creates a DigestMethod for the specified algorithm URI and parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>/."/./....=>//iai.e/


Uses of Interface javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec

  • Packages that use SignatureMethodParameterSpec
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of SignatureMethodParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type SignatureMethodParameterSpec
      修饰符与类型 方法与描述
      abstract SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
      Creates a SignatureMethod for the specified algorithm URI and parameters.

    • Uses of SignatureMethodParameterSpec in javax.xml.crypto.dsig.spec

      Classes in javax.xml.crypto.dsig.spec that implement SignatureMethodParameterSpec
      修饰符与类型 类与描述
      class  HMACParameterSpec
      Parameters for the XML Signature HMAC Algorithm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>w/a3vc > d"s�>=/n>m-


Uses of Interface javax.xml.crypto.dsig.spec.TransformParameterSpec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.crypto.dsig.spec.TransformParameterSpec

  • Packages that use TransformParameterSpec
    软件包 描述
    javax.xml.crypto.dsig
    Classes for generating and validating XML digital signatures.
    javax.xml.crypto.dsig.spec
    Parameter classes for XML digital signatures.

    • Uses of TransformParameterSpec in javax.xml.crypto.dsig

      Methods in javax.xml.crypto.dsig with parameters of type TransformParameterSpec
      修饰符与类型 方法与描述
      abstract void TransformService.init(TransformParameterSpec params)
      Initializes this TransformService with the specified parameters.
      abstract Transform XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
      Creates a Transform for the specified algorithm URI and parameters.

    • Uses of TransformParameterSpec in javax.xml.crypto.dsig.spec

      Subinterfaces of TransformParameterSpec in javax.xml.crypto.dsig.spec
      修饰符与类型 Interface and Description
      interface  C14NMethodParameterSpec
      A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
      Classes in javax.xml.crypto.dsig.spec that implement TransformParameterSpec
      修饰符与类型 类与描述
      class  ExcC14NParameterSpec
      Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
      class  XPathFilter2ParameterSpec
      Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
      class  XPathFilterParameterSpec
      Parameters for the XPath Filtering Transform Algorithm.
      class  XSLTTransformParameterSpec
      Parameters for the XSLT Transform Algorithm.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=np<.aeghlh/..ufnzBcad


DatatypeConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.datatype

类 DatatypeConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.datatype.DatatypeConfigurationException
  • 所有已实现的接口：
    Serializable

    public class DatatypeConfigurationException
extends Exception

    Indicates a serious configuration error.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      DatatypeConfigurationException()
      Create a new DatatypeConfigurationException with no specified detail mesage and cause.
      DatatypeConfigurationException(String message)
      Create a new DatatypeConfigurationException with the specified detail message.
      DatatypeConfigurationException(String message, Throwable cause)
      Create a new DatatypeConfigurationException with the specified detail message and cause.
      DatatypeConfigurationException(Throwable cause)
      Create a new DatatypeConfigurationException with the specified cause.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DatatypeConfigurationException

        public DatatypeConfigurationException()

        Create a new DatatypeConfigurationException with no specified detail mesage and cause.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(String message)

        Create a new DatatypeConfigurationException with the specified detail message.

        参数：
        message - The detail message.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(String message,
                              Throwable cause)

        Create a new DatatypeConfigurationException with the specified detail message and cause.

        参数：
        message - The detail message.
        cause - The cause. A null value is permitted, and indicates that the cause is nonexistent or unknown.

      • DatatypeConfigurationException

        public DatatypeConfigurationException(Throwable cause)

        Create a new DatatypeConfigurationException with the specified cause.

        参数：
        cause - The cause. A null value is permitted, and indicates that the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cfr">DteEeraslh>n


DatatypeConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.datatype

类 DatatypeConstants

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants

  • public final class DatatypeConstants
extends Object

    Utility class to contain basic Datatype values as constants.

    从以下版本开始：
    1.5

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  DatatypeConstants.Field
      Type-safe enum class that represents six fields of the Duration class.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int APRIL
      Value for fourth month of year.
      static int AUGUST
      Value for eighth month of year.
      static QName DATE
      Fully qualified name for W3C XML Schema 1.0 datatype date.
      static QName DATETIME
      Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
      static DatatypeConstants.Field DAYS
      A constant that represents the days field.
      static int DECEMBER
      Value for twelve month of year.
      static QName DURATION
      Fully qualified name for W3C XML Schema datatype duration.
      static QName DURATION_DAYTIME
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
      static QName DURATION_YEARMONTH
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
      static int EQUAL
      Comparison result.
      static int FEBRUARY
      Value for second month of year.
      static int FIELD_UNDEFINED
      Designation that an "int" field is not set.
      static QName GDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gDay.
      static QName GMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gMonth.
      static QName GMONTHDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.
      static int GREATER
      Comparison result.
      static QName GYEAR
      Fully qualified name for W3C XML Schema 1.0 datatype gYear.
      static QName GYEARMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.
      static DatatypeConstants.Field HOURS
      A constant that represents the hours field.
      static int INDETERMINATE
      Comparison result.
      static int JANUARY
      Value for first month of year.
      static int JULY
      Value for seventh month of year.
      static int JUNE
      Value for sixth month of year.
      static int LESSER
      Comparison result.
      static int MARCH
      Value for third month of year.
      static int MAX_TIMEZONE_OFFSET
      W3C XML Schema max timezone offset is -14:00.
      static int MAY
      Value for fifth month of year.
      static int MIN_TIMEZONE_OFFSET
      W3C XML Schema min timezone offset is +14:00.
      static DatatypeConstants.Field MINUTES
      A constant that represents the minutes field.
      static DatatypeConstants.Field MONTHS
      A constant that represents the months field.
      static int NOVEMBER
      Value for eleven month of year.
      static int OCTOBER
      Value for tenth month of year.
      static DatatypeConstants.Field SECONDS
      A constant that represents the seconds field.
      static int SEPTEMBER
      Value for ninth month of year.
      static QName TIME
      Fully qualified name for W3C XML Schema 1.0 datatype time.
      static DatatypeConstants.Field YEARS
      A constant that represents the years field.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JANUARY

        public static final int JANUARY
        Value for first month of year.
        另请参见：
        Constant Field Values

      • FEBRUARY

        public static final int FEBRUARY
        Value for second month of year.
        另请参见：
        Constant Field Values

      • MARCH

        public static final int MARCH
        Value for third month of year.
        另请参见：
        Constant Field Values

      • APRIL

        public static final int APRIL
        Value for fourth month of year.
        另请参见：
        Constant Field Values

      • MAY

        public static final int MAY
        Value for fifth month of year.
        另请参见：
        Constant Field Values

      • JUNE

        public static final int JUNE
        Value for sixth month of year.
        另请参见：
        Constant Field Values

      • JULY

        public static final int JULY
        Value for seventh month of year.
        另请参见：
        Constant Field Values

      • AUGUST

        public static final int AUGUST
        Value for eighth month of year.
        另请参见：
        Constant Field Values

      • SEPTEMBER

        public static final int SEPTEMBER
        Value for ninth month of year.
        另请参见：
        Constant Field Values

      • OCTOBER

        public static final int OCTOBER
        Value for tenth month of year.
        另请参见：
        Constant Field Values

      • NOVEMBER

        public static final int NOVEMBER
        Value for eleven month of year.
        另请参见：
        Constant Field Values

      • DECEMBER

        public static final int DECEMBER
        Value for twelve month of year.
        另请参见：
        Constant Field Values

      • LESSER

        public static final int LESSER

        Comparison result.

        另请参见：
        Constant Field Values

      • EQUAL

        public static final int EQUAL

        Comparison result.

        另请参见：
        Constant Field Values

      • GREATER

        public static final int GREATER

        Comparison result.

        另请参见：
        Constant Field Values

      • INDETERMINATE

        public static final int INDETERMINATE

        Comparison result.

        另请参见：
        Constant Field Values

      • FIELD_UNDEFINED

        public static final int FIELD_UNDEFINED
        Designation that an "int" field is not set.
        另请参见：
        Constant Field Values

      • YEARS

        public static final DatatypeConstants.Field YEARS

        A constant that represents the years field.

      • MONTHS

        public static final DatatypeConstants.Field MONTHS

        A constant that represents the months field.

      • DAYS

        public static final DatatypeConstants.Field DAYS

        A constant that represents the days field.

      • HOURS

        public static final DatatypeConstants.Field HOURS

        A constant that represents the hours field.

      • MINUTES

        public static final DatatypeConstants.Field MINUTES

        A constant that represents the minutes field.

      • SECONDS

        public static final DatatypeConstants.Field SECONDS

        A constant that represents the seconds field.

      • DATETIME

        public static final QName DATETIME

        Fully qualified name for W3C XML Schema 1.0 datatype dateTime.

      • TIME

        public static final QName TIME

        Fully qualified name for W3C XML Schema 1.0 datatype time.

      • DATE

        public static final QName DATE

        Fully qualified name for W3C XML Schema 1.0 datatype date.

      • GYEARMONTH

        public static final QName GYEARMONTH

        Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.

      • GMONTHDAY

        public static final QName GMONTHDAY

        Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.

      • GYEAR

        public static final QName GYEAR

        Fully qualified name for W3C XML Schema 1.0 datatype gYear.

      • GMONTH

        public static final QName GMONTH

        Fully qualified name for W3C XML Schema 1.0 datatype gMonth.

      • GDAY

        public static final QName GDAY

        Fully qualified name for W3C XML Schema 1.0 datatype gDay.

      • DURATION

        public static final QName DURATION

        Fully qualified name for W3C XML Schema datatype duration.

      • DURATION_DAYTIME

        public static final QName DURATION_DAYTIME

        Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.

      • DURATION_YEARMONTH

        public static final QName DURATION_YEARMONTH

        Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.

      • MAX_TIMEZONE_OFFSET

        public static final int MAX_TIMEZONE_OFFSET
        W3C XML Schema max timezone offset is -14:00. Zone offset is in minutes.
        另请参见：
        Constant Field Values

      • MIN_TIMEZONE_OFFSET

        public static final int MIN_TIMEZONE_OFFSET
        W3C XML Schema min timezone offset is +14:00. Zone offset is in minutes.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method


DatatypeConstants.Field

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.datatype

类 DatatypeConstants.Field

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants.Field
  • 封闭类：
    DatatypeConstants

    public static final class DatatypeConstants.Field
extends Object
    Type-safe enum class that represents six fields of the Duration class.
    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getId()
      Get id of this Field.
      String toString()
      Returns a field name in English.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 方法详细信息

      • toString

        public String toString()
        Returns a field name in English. This method is intended to be used for debugging/diagnosis and not for display to end-users.
        重载：
        toString in class Object
        返回：
        a non-null valid String constant.

      • getId

        public int getId()

        Get id of this Field.

        返回：
        Id of field.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ae.tlnaanajvj(jjtippeo/c<mdei a


DatatypeFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.datatype

类 DatatypeFactory

  • java.lang.Object
    • javax.xml.datatype.DatatypeFactory

  • public abstract class DatatypeFactory
extends Object

    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.

    newInstance() is used to create a new DatatypeFactory. The following implementation resolution mechanisms are used in the following order:

    1. If the system property specified by DATATYPEFACTORY_PROPERTY, "javax.xml.datatype.DatatypeFactory", exists, a class with the name of the property's value is instantiated. Any Exception thrown during the instantiation process is wrapped as a DatatypeConfigurationException.
    2. If the file ${JAVA_HOME}/lib/jaxp.properties exists, it is loaded in a Properties Object. The Properties Object is then queried for the property as documented in the prior step and processed as documented in the prior step.
    3. The services resolution mechanism is used, e.g. META-INF/services/java.xml.datatype.DatatypeFactory. Any Exception thrown during the instantiation process is wrapped as a DatatypeConfigurationException.
    4. The final mechanism is to attempt to instantiate the 类 specified by DATATYPEFACTORY_IMPLEMENTATION_CLASS. Any Exception thrown during the instantiation process is wrapped as a DatatypeConfigurationException.
    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DATATYPEFACTORY_IMPLEMENTATION_CLASS
      Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
      static String DATATYPEFACTORY_PROPERTY
      Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DatatypeFactory()
      Protected constructor to prevent instaniation outside of package.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Duration newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      Duration newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      abstract Duration newDuration(long durationInMilliSeconds)
      Obtain a new instance of a Duration specifying the Duration as milliseconds.
      abstract Duration newDuration(String lexicalRepresentation)
      Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.
      Duration newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(long durationInMilliseconds)
      Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationDayTime(String lexicalRepresentation)
      Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(boolean isPositive, int year, int month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(long durationInMilliseconds)
      Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration newDurationYearMonth(String lexicalRepresentation)
      Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      static DatatypeFactory newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
      abstract XMLGregorianCalendar newXMLGregorianCalendar()
      Create a new instance of an XMLGregorianCalendar.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(GregorianCalendar cal)
      Create an XMLGregorianCalendar from a GregorianCalendar.
      XMLGregorianCalendar newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone)
      Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.
      abstract XMLGregorianCalendar newXMLGregorianCalendar(String lexicalRepresentation)
      Create a new XMLGregorianCalendar by parsing the String as a lexical representation.
      XMLGregorianCalendar newXMLGregorianCalendarDate(int year, int month, int day, int timezone)
      Create a Java representation of XML Schema builtin datatype date or g*.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DATATYPEFACTORY_PROPERTY

        public static final String DATATYPEFACTORY_PROPERTY

        Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

        Default value is javax.xml.datatype.DatatypeFactory.

        另请参见：
        Constant Field Values

      • DATATYPEFACTORY_IMPLEMENTATION_CLASS

        public static final String DATATYPEFACTORY_IMPLEMENTATION_CLASS

        Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.

        Implementers should specify the name of an appropriate class to be instantiated if no other implementation resolution mechanism succeeds.

        Users should not refer to this field; it is intended only to document a factory implementation detail.

    • 构造方法详细信息

      • DatatypeFactory

        protected DatatypeFactory()

        Protected constructor to prevent instaniation outside of package.

        Use newInstance() to create a DatatypeFactory.

    • 方法详细信息

      • newInstance

        public static DatatypeFactory newInstance()
                                   throws DatatypeConfigurationException

        Obtain a new instance of a DatatypeFactory.

        The implementation resolution mechanisms are defined in this 类's documentation.

        返回：
        New instance of a DatatypeFactory
        抛出：
        DatatypeConfigurationException - If the implementation is not available or cannot be instantiated.
        另请参见：
        newInstance(String factoryClassName, ClassLoader classLoader)

      • newInstance

        public static DatatypeFactory newInstance(String factoryClassName,
                          ClassLoader classLoader)
                                   throws DatatypeConfigurationException

        Obtain a new instance of a DatatypeFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a DatatypeFactory it can use the factory to configure and obtain datatype instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.datatype.DatatypeFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a DatatypeFactory
        抛出：
        DatatypeConfigurationException - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        从以下版本开始：
        1.6
        另请参见：
        newInstance()

      • newDuration

        public abstract Duration newDuration(String lexicalRepresentation)

        Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.

        XML Schema Part 2: Datatypes, 3.2.6 duration, defines duration as:

        duration represents a duration of time. The value space of duration is a six-dimensional space where the coordinates designate the Gregorian year, month, day, hour, minute, and second components defined in Section 5.5.3.2 of [ISO 8601], respectively. These components are ordered in their significance by their order of appearance i.e. as year, month, day, hour, minute, and second.

        All six values are set and availabe from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        参数：
        lexicalRepresentation - String representation of a Duration.
        返回：
        New Duration created from parsing the lexicalRepresentation.
        抛出：
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - if lexicalRepresentation is null.

      • newDuration

        public abstract Duration newDuration(long durationInMilliSeconds)

        Obtain a new instance of a Duration specifying the Duration as milliseconds.

        XML Schema Part 2: Datatypes, 3.2.6 duration, defines duration as:

        duration represents a duration of time. The value space of duration is a six-dimensional space where the coordinates designate the Gregorian year, month, day, hour, minute, and second components defined in Section 5.5.3.2 of [ISO 8601], respectively. These components are ordered in their significance by their order of appearance i.e. as year, month, day, hour, minute, and second.

        All six values are set by computing their values from the specified milliseconds and are availabe using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getMonths() and Duration.getDays() can be influenced.

        参数：
        durationInMilliSeconds - Duration in milliseconds to create.
        返回：
        New Duration representing durationInMilliSeconds.

      • newDuration

        public abstract Duration newDuration(boolean isPositive,
                   BigInteger years,
                   BigInteger months,
                   BigInteger days,
                   BigInteger hours,
                   BigInteger minutes,
                   BigDecimal seconds)

        Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        years - of this Duration
        months - of this Duration
        days - of this Duration
        hours - of this Duration
        minutes - of this Duration
        seconds - of this Duration
        返回：
        New Duration created from the specified values.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all the fields (years, months, ...) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDuration

        public Duration newDuration(boolean isPositive,
                   int years,
                   int months,
                   int days,
                   int hours,
                   int minutes,
                   int seconds)

        Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        years - of this Duration
        months - of this Duration
        days - of this Duration
        hours - of this Duration
        minutes - of this Duration
        seconds - of this Duration
        返回：
        New Duration created from the specified values.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields is negative.
        另请参见：
        newDuration( boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)

      • newDurationDayTime

        public Duration newDurationDayTime(String lexicalRepresentation)

        Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        All four values are set and availabe from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        参数：
        lexicalRepresentation - Lexical representation of a duration.
        返回：
        New Duration created using the specified lexicalRepresentation.
        抛出：
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration expressed only in terms of days and time.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - If lexicalRepresentation is null.

      • newDurationDayTime

        public Duration newDurationDayTime(long durationInMilliseconds)

        Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        All four values are set by computing their values from the specified milliseconds and are availabe using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getDays() can be influenced.

        Any remaining milliseconds after determining the day, hour, minute and second are discarded.

        参数：
        durationInMilliseconds - Milliseconds of Duration to create.
        返回：
        New Duration created with the specified durationInMilliseconds.
        另请参见：
        XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration

      • newDurationDayTime

        public Duration newDurationDayTime(boolean isPositive,
                          BigInteger day,
                          BigInteger hour,
                          BigInteger minute,
                          BigInteger second)

        Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        day - Day of Duration.
        hour - Hour of Duration.
        minute - Minute of Duration.
        second - Second of Duration.
        返回：
        New Duration created with the specified day, hour, minute and second.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all the fields (day, hour, ...) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDurationDayTime

        public Duration newDurationDayTime(boolean isPositive,
                          int day,
                          int hour,
                          int minute,
                          int second)

        Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.

        The datatype xdt:dayTimeDuration is a subtype of xs:duration whose lexical representation contains only day, hour, minute, and second components. This datatype resides in the namespace http://www.w3.org/2003/11/xpath-datatypes.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        day - Day of Duration.
        hour - Hour of Duration.
        minute - Minute of Duration.
        second - Second of Duration.
        返回：
        New Duration created with the specified day, hour, minute and second.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields (day, hour, ...) is negative.

      • newDurationYearMonth

        public Duration newDurationYearMonth(String lexicalRepresentation)

        Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The datatype xdt:yearMonthDuration is a subtype of xs:duration whose lexical representation contains only year and month components. This datatype resides in the namespace XMLConstants.W3C_XPATH_DATATYPE_NS_URI.

        Both values are set and availabe from the created Duration

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        参数：
        lexicalRepresentation - Lexical representation of a duration.
        返回：
        New Duration created using the specified lexicalRepresentation.
        抛出：
        IllegalArgumentException - If lexicalRepresentation is not a valid representation of a Duration expressed only in terms of years and months.
        UnsupportedOperationException - If implementation cannot support requested values.
        NullPointerException - If lexicalRepresentation is null.

      • newDurationYearMonth

        public Duration newDurationYearMonth(long durationInMilliseconds)

        Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The datatype xdt:yearMonthDuration is a subtype of xs:duration whose lexical representation contains only year and month components. This datatype resides in the namespace XMLConstants.W3C_XPATH_DATATYPE_NS_URI.

        Both values are set by computing their values from the specified milliseconds and are availabe using the get methods of the created Duration. The values conform to and are defined by:

        • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
        • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
        • XMLGregorianCalendar Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation

        The default start instance is defined by GregorianCalendar's use of the start of the epoch: i.e., Calendar.YEAR = 1970, Calendar.MONTH = Calendar.JANUARY, Calendar.DATE = 1, etc. This is important as there are variations in the Gregorian Calendar, e.g. leap years have different days in the month = Calendar.FEBRUARY so the result of Duration.getMonths() can be influenced.

        Any remaining milliseconds after determining the year and month are discarded.

        参数：
        durationInMilliseconds - Milliseconds of Duration to create.
        返回：
        New Duration created using the specified durationInMilliseconds.

      • newDurationYearMonth

        public Duration newDurationYearMonth(boolean isPositive,
                            BigInteger year,
                            BigInteger month)

        Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        The XML Schema specification states that values can be of an arbitrary size. Implementations may chose not to or be incapable of supporting arbitrarily large and/or small values. An UnsupportedOperationException will be thrown with a message indicating implementation limits if implementation capacities are exceeded.

        A null value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        year - Year of Duration.
        month - Month of Duration.
        返回：
        New Duration created using the specified year and month.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if all of the fields (year, month) are null or if any of the fields is negative.
        UnsupportedOperationException - If implementation cannot support requested values.

      • newDurationYearMonth

        public Duration newDurationYearMonth(boolean isPositive,
                            int year,
                            int month)

        Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        isPositive - Set to false to create a negative duration. When the length of the duration is zero, this parameter will be ignored.
        year - Year of Duration.
        month - Month of Duration.
        返回：
        New Duration created using the specified year and month.
        抛出：
        IllegalArgumentException - If the values are not a valid representation of a Duration: if any of the fields (year, month) is negative.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar()

        Create a new instance of an XMLGregorianCalendar.

        All date/time datatype fields set to DatatypeConstants.FIELD_UNDEFINED or null.

        返回：
        New XMLGregorianCalendar with all date/time datatype fields set to DatatypeConstants.FIELD_UNDEFINED or null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(String lexicalRepresentation)

        Create a new XMLGregorianCalendar by parsing the String as a lexical representation.

        Parsing the lexical string representation is defined in XML Schema 1.0 Part 2, Section 3.2.[7-14].1, Lexical Representation.

        The string representation may not have any leading and trailing whitespaces.

        The parsing is done field by field so that the following holds for any lexically correct String x:

         newXMLGregorianCalendar(x).toXMLFormat().equals(x)

        Except for the noted lexical/canonical representation mismatches listed in XML Schema 1.0 errata, Section 3.2.7.2.

        参数：
        lexicalRepresentation - Lexical representation of one the eight XML Schema date/time datatypes.
        返回：
        XMLGregorianCalendar created from the lexicalRepresentation.
        抛出：
        IllegalArgumentException - If the lexicalRepresentation is not a valid XMLGregorianCalendar.
        NullPointerException - If lexicalRepresentation is null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(GregorianCalendar cal)

        Create an XMLGregorianCalendar from a GregorianCalendar.

        Field by Field Conversion from GregorianCalendar to an XMLGregorianCalendar
        java.util.GregorianCalendar field | javax.xml.datatype.XMLGregorianCalendar field
        ERA == GregorianCalendar.BC ? -YEAR : YEAR | XMLGregorianCalendar.setYear(int year)
        MONTH + 1 | XMLGregorianCalendar.setMonth(int month)
        DAY_OF_MONTH | XMLGregorianCalendar.setDay(int day)
        HOUR_OF_DAY, MINUTE, SECOND, MILLISECOND | XMLGregorianCalendar.setTime(int hour, int minute, int second, BigDecimal fractional)
        (ZONE_OFFSET + DST_OFFSET) / (60*1000)
        (in minutes)         		XMLGregorianCalendar.setTimezone(int offset) *

        *conversion loss of information. It is not possible to represent a java.util.GregorianCalendar daylight savings timezone id in the XML Schema 1.0 date/time datatype representation.

        To compute the return value's TimeZone field,

        • when this.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using the this.getTimezone().
        • else use the GregorianCalendar default timezone value for the host is defined as specified by java.util.TimeZone.getDefault().

        参数：
        cal - java.util.GregorianCalendar used to create XMLGregorianCalendar
        返回：
        XMLGregorianCalendar created from java.util.GregorianCalendar
        抛出：
        NullPointerException - If cal is null.

      • newXMLGregorianCalendar

        public abstract XMLGregorianCalendar newXMLGregorianCalendar(BigInteger year,
                                           int month,
                                           int day,
                                           int hour,
                                           int minute,
                                           int second,
                                           BigDecimal fractionalSecond,
                                           int timezone)

        Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes. Note that year parameter supports arbitrarily large numbers and fractionalSecond has infinite precision.

        A null value indicates that field is not set.

        参数：
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        hour - of XMLGregorianCalendar to be created.
        minute - of XMLGregorianCalendar to be created.
        second - of XMLGregorianCalendar to be created.
        fractionalSecond - of XMLGregorianCalendar to be created.
        timezone - of XMLGregorianCalendar to be created.
        返回：
        XMLGregorianCalendar created from specified values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().

      • newXMLGregorianCalendar

        public XMLGregorianCalendar newXMLGregorianCalendar(int year,
                                           int month,
                                           int day,
                                           int hour,
                                           int minute,
                                           int second,
                                           int millisecond,
                                           int timezone)

        Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.

        XMLGregorianCalendar eon and fractionalSecond are set to null

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        hour - of XMLGregorianCalendar to be created.
        minute - of XMLGregorianCalendar to be created.
        second - of XMLGregorianCalendar to be created.
        millisecond - of XMLGregorianCalendar to be created.
        timezone - of XMLGregorianCalendar to be created.
        返回：
        XMLGregorianCalendar created from specified values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().

      • newXMLGregorianCalendarDate

        public XMLGregorianCalendar newXMLGregorianCalendarDate(int year,
                                               int month,
                                               int day,
                                               int timezone)

        Create a Java representation of XML Schema builtin datatype date or g*.

        For example, an instance of gYear can be created invoking this factory with month and day parameters set to DatatypeConstants.FIELD_UNDEFINED.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        year - of XMLGregorianCalendar to be created.
        month - of XMLGregorianCalendar to be created.
        day - of XMLGregorianCalendar to be created.
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        返回：
        XMLGregorianCalendar created from parameter values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        另请参见：
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                               int minutes,
                                               int seconds,
                                               int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        返回：
        XMLGregorianCalendar created from parameter values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        另请参见：
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                               int minutes,
                                               int seconds,
                                               BigDecimal fractionalSecond,
                                               int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A null value indicates that field is not set.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        fractionalSecond - value of null indicates that this optional field is not set.
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        返回：
        XMLGregorianCalendar created from parameter values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        另请参见：
        DatatypeConstants.FIELD_UNDEFINED

      • newXMLGregorianCalendarTime

        public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                               int minutes,
                                               int seconds,
                                               int milliseconds,
                                               int timezone)

        Create a Java instance of XML Schema builtin datatype time.

        A DatatypeConstants.FIELD_UNDEFINED value indicates that field is not set.

        参数：
        hours - number of hours
        minutes - number of minutes
        seconds - number of seconds
        milliseconds - number of milliseconds
        timezone - offset in minutes. DatatypeConstants.FIELD_UNDEFINED indicates optional field is not set.
        返回：
        XMLGregorianCalendar created from parameter values.
        抛出：
        IllegalArgumentException - If any individual parameter's value is outside the maximum value constraint for the field as determined by the Date/Time Data Mapping table in XMLGregorianCalendar or if the composite values constitute an invalid XMLGregorianCalendar instance as determined by XMLGregorianCalendar.isValid().
        另请参见：
        DatatypeConstants.FIELD_UNDEFINED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Duration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.datatype

类 Duration

  • java.lang.Object
    • javax.xml.datatype.Duration

  • public abstract class Duration
extends Object

    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.

    A Duration object represents a period of Gregorian time, which consists of six fields (years, months, days, hours, minutes, and seconds) plus a sign (+/-) field.

    The first five fields have non-negative (>=0) integers or null (which represents that the field is not set), and the seconds field has a non-negative decimal or null. A negative sign indicates a negative duration.

    This class provides a number of methods that make it easy to use for the duration datatype of XML Schema 1.0 with the errata.

    Order relationship

    Duration objects only have partial order, where two values A and B maybe either:

    1. A<B (A is shorter than B)
    2. A>B (A is longer than B)
    3. A==B (A and B are of the same duration)
    4. A<>B (Comparison between A and B is indeterminate)

    For example, 30 days cannot be meaningfully compared to one month. The compare(Duration duration) method implements this relationship.

    See the isLongerThan(Duration) method for details about the order relationship among Duration objects.

    Operations over Duration

    This class provides a set of basic arithmetic operations, such as addition, subtraction and multiplication. Because durations don't have total order, an operation could fail for some combinations of operations. For example, you cannot subtract 15 days from 1 month. See the javadoc of those methods for detailed conditions where this could happen.

    Also, division of a duration by a number is not provided because the Duration class can only deal with finite precision decimal numbers. For example, one cannot represent 1 sec divided by 3.

    However, you could substitute a division by 3 with multiplying by numbers such as 0.3 or 0.333.

    Range of allowed values

    Because some operations of Duration rely on Calendar even though Duration can hold very large or very small values, some of the methods may not work correctly on such Durations. The impacted methods document their dependency on Calendar.

    从以下版本开始：
    1.5
    另请参见：
    XMLGregorianCalendar.add(Duration)

    • 构造方法摘要

      Constructors
      构造方法与描述
      Duration()
      Default no-arg constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Duration add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract void addTo(Calendar calendar)
      Adds this duration to a Calendar object.
      void addTo(Date date)
      Adds this duration to a Date object.
      abstract int compare(Duration duration)
      Partial order relation comparison with this Duration instance.
      boolean equals(Object duration)
      Checks if this duration object has the same duration as another Duration object.
      int getDays()
      Obtains the value of the DAYS field as an integer value, or 0 if not present.
      abstract Number getField(DatatypeConstants.Field field)
      Gets the value of a field.
      int getHours()
      Obtains the value of the HOURS field as an integer value, or 0 if not present.
      int getMinutes()
      Obtains the value of the MINUTES field as an integer value, or 0 if not present.
      int getMonths()
      Obtains the value of the MONTHS field as an integer value, or 0 if not present.
      int getSeconds()
      Obtains the value of the SECONDS field as an integer value, or 0 if not present.
      abstract int getSign()
      Returns the sign of this duration in -1,0, or 1.
      long getTimeInMillis(Calendar startInstant)
      Returns the length of the duration in milli-seconds.
      long getTimeInMillis(Date startInstant)
      Returns the length of the duration in milli-seconds.
      QName getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      int getYears()
      Get the years value of this Duration as an int or 0 if not present.
      abstract int hashCode()
      Returns a hash code consistent with the definition of the equals method.
      boolean isLongerThan(Duration duration)
      Checks if this duration object is strictly longer than another Duration object.
      abstract boolean isSet(DatatypeConstants.Field field)
      Checks if a field is set.
      boolean isShorterThan(Duration duration)
      Checks if this duration object is strictly shorter than another Duration object.
      abstract Duration multiply(BigDecimal factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      Duration multiply(int factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      abstract Duration negate()
      Returns a new Duration object whose value is -this.
      abstract Duration normalizeWith(Calendar startTimeInstant)
      Converts the years and months fields into the days field by using a specific time instant as the reference point.
      Duration subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
      String toString()
      Returns a String representation of this Duration Object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Duration

        public Duration()
        Default no-arg constructor.

        Note: Always use the DatatypeFactory to construct an instance of Duration. The constructor on this class cannot be guaranteed to produce an object with a consistent state and may be removed in the future.

    • 方法详细信息

      • getXMLSchemaType

        public QName getXMLSchemaType()

        Return the name of the XML Schema date/time type that this instance maps to. Type is computed based on fields that are set, i.e. isSet(DatatypeConstants.Field field) == true.

        Required fields for XML Schema 1.0 Date/Time Datatypes.
        (timezone is optional for all date/time datatypes)
        Datatype | year | month | day | hour | minute | second
        DatatypeConstants.DURATION | X | X | X | X | X | X
        DatatypeConstants.DURATION_DAYTIME | X | X | X | X
        DatatypeConstants.DURATION_YEARMONTH | X | X
        返回：
        one of the following constants: DatatypeConstants.DURATION, DatatypeConstants.DURATION_DAYTIME or DatatypeConstants.DURATION_YEARMONTH.
        抛出：
        IllegalStateException - If the combination of set fields does not match one of the XML Schema date/time datatypes.

      • getSign

        public abstract int getSign()
        Returns the sign of this duration in -1,0, or 1.
        返回：
        -1 if this duration is negative, 0 if the duration is zero, and 1 if the duration is positive.

      • getYears

        public int getYears()

        Get the years value of this Duration as an int or 0 if not present.

        getYears() is a convenience method for getField(DatatypeConstants.YEARS).

        As the return value is an int, an incorrect value will be returned for Durations with years that go beyond the range of an int. Use getField(DatatypeConstants.YEARS) to avoid possible loss of precision.

        返回：
        If the years field is present, return its value as an int, else return 0.

      • getMonths

        public int getMonths()
        Obtains the value of the MONTHS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the MONTHS field.
        返回：
        Months of this Duration.

      • getDays

        public int getDays()
        Obtains the value of the DAYS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the DAYS field.
        返回：
        Days of this Duration.

      • getHours

        public int getHours()
        Obtains the value of the HOURS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the HOURS field.
        返回：
        Hours of this Duration.

      • getMinutes

        public int getMinutes()
        Obtains the value of the MINUTES field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the MINUTES field.
        返回：
        Minutes of this Duration.

      • getSeconds

        public int getSeconds()
        Obtains the value of the SECONDS field as an integer value, or 0 if not present. This method works just like getYears() except that this method works on the SECONDS field.
        返回：
        seconds in the integer value. The fraction of seconds will be discarded (for example, if the actual value is 2.5, this method returns 2)

      • getTimeInMillis

        public long getTimeInMillis(Calendar startInstant)

        Returns the length of the duration in milli-seconds.

        If the seconds field carries more digits than milli-second order, those will be simply discarded (or in other words, rounded to zero.) For example, for any Calendar value x,

         new Duration("PT10.00099S").getTimeInMills(x) == 10000.
 new Duration("-PT10.00099S").getTimeInMills(x) == -10000.

        Note that this method uses the addTo(Calendar) method, which may work incorrectly with Duration objects with very large values in its fields. See the addTo(Calendar) method for details.

        参数：
        startInstant - The length of a month/year varies. The startInstant is used to disambiguate this variance. Specifically, this method returns the difference between startInstant and startInstant+duration
        返回：
        milliseconds between startInstant and startInstant plus this Duration
        抛出：
        NullPointerException - if startInstant parameter is null.

      • getTimeInMillis

        public long getTimeInMillis(Date startInstant)

        Returns the length of the duration in milli-seconds.

        If the seconds field carries more digits than milli-second order, those will be simply discarded (or in other words, rounded to zero.) For example, for any Date value x,

         new Duration("PT10.00099S").getTimeInMills(x) == 10000.
 new Duration("-PT10.00099S").getTimeInMills(x) == -10000.

        Note that this method uses the addTo(Date) method, which may work incorrectly with Duration objects with very large values in its fields. See the addTo(Date) method for details.

        参数：
        startInstant - The length of a month/year varies. The startInstant is used to disambiguate this variance. Specifically, this method returns the difference between startInstant and startInstant+duration.
        返回：
        milliseconds between startInstant and startInstant plus this Duration
        抛出：
        NullPointerException - If the startInstant parameter is null.
        另请参见：
        getTimeInMillis(Calendar)

      • getField

        public abstract Number getField(DatatypeConstants.Field field)
        Gets the value of a field. Fields of a duration object may contain arbitrary large value. Therefore this method is designed to return a Number object. In case of YEARS, MONTHS, DAYS, HOURS, and MINUTES, the returned number will be a non-negative integer. In case of seconds, the returned number may be a non-negative decimal value.
        参数：
        field - one of the six Field constants (YEARS,MONTHS,DAYS,HOURS, MINUTES, or SECONDS.)
        返回：
        If the specified field is present, this method returns a non-null non-negative Number object that represents its value. If it is not present, return null. For YEARS, MONTHS, DAYS, HOURS, and MINUTES, this method returns a BigInteger object. For SECONDS, this method returns a BigDecimal.
        抛出：
        NullPointerException - If the field is null.

      • isSet

        public abstract boolean isSet(DatatypeConstants.Field field)
        Checks if a field is set. A field of a duration object may or may not be present. This method can be used to test if a field is present.
        参数：
        field - one of the six Field constants (YEARS,MONTHS,DAYS,HOURS, MINUTES, or SECONDS.)
        返回：
        true if the field is present. false if not.
        抛出：
        NullPointerException - If the field parameter is null.

      • add

        public abstract Duration add(Duration rhs)

        Computes a new duration whose value is this+rhs.

        For example,

         "1 day" + "-3 days" = "-2 days"
 "1 year" + "1 day" = "1 year and 1 day"
 "-(1 hour,50 minutes)" + "-20 minutes" = "-(1 hours,70 minutes)"
 "15 hours" + "-3 days" = "-(2 days,9 hours)"
 "1 year" + "-1 day" = IllegalStateException

        Since there's no way to meaningfully subtract 1 day from 1 month, there are cases where the operation fails in IllegalStateException.

        Formally, the computation is defined as follows.

        Firstly, we can assume that two Durations to be added are both positive without losing generality (i.e., (-X)+Y=Y-X, X+(-Y)=X-Y, (-X)+(-Y)=-(X+Y))

        Addition of two positive Durations are simply defined as field by field addition where missing fields are treated as 0.

        A field of the resulting Duration will be unset if and only if respective fields of two input Durations are unset.

        Note that lhs.add(rhs) will be always successful if lhs.signum()*rhs.signum()!=-1 or both of them are normalized.

        参数：
        rhs - Duration to add to this Duration
        返回：
        non-null valid Duration object.
        抛出：
        NullPointerException - If the rhs parameter is null.
        IllegalStateException - If two durations cannot be meaningfully added. For example, adding negative one day to one month causes this exception.
        另请参见：
        subtract(Duration)

      • addTo

        public abstract void addTo(Calendar calendar)
        Adds this duration to a Calendar object.

        Calls Calendar.add(int,int) in the order of YEARS, MONTHS, DAYS, HOURS, MINUTES, SECONDS, and MILLISECONDS if those fields are present. Because the Calendar class uses int to hold values, there are cases where this method won't work correctly (for example if values of fields exceed the range of int.)

        Also, since this duration class is a Gregorian duration, this method will not work correctly if the given Calendar object is based on some other calendar systems.

        Any fractional parts of this Duration object beyond milliseconds will be simply ignored. For example, if this duration is "P1.23456S", then 1 is added to SECONDS, 234 is added to MILLISECONDS, and the rest will be unused.

        Note that because Calendar.add(int, int) is using int, Duration with values beyond the range of int in its fields will cause overflow/underflow to the given Calendar. XMLGregorianCalendar.add(Duration) provides the same basic operation as this method while avoiding the overflow/underflow issues.

        参数：
        calendar - A calendar object whose value will be modified.
        抛出：
        NullPointerException - if the calendar parameter is null.

      • addTo

        public void addTo(Date date)
        Adds this duration to a Date object.

        The given date is first converted into a GregorianCalendar, then the duration is added exactly like the addTo(Calendar) method.

        The updated time instant is then converted back into a Date object and used to update the given Date object.

        This somewhat redundant computation is necessary to unambiguously determine the duration of months and years.

        参数：
        date - A date object whose value will be modified.
        抛出：
        NullPointerException - if the date parameter is null.

      • subtract

        public Duration subtract(Duration rhs)

        Computes a new duration whose value is this-rhs.

        For example:

         "1 day" - "-3 days" = "4 days"
 "1 year" - "1 day" = IllegalStateException
 "-(1 hour,50 minutes)" - "-20 minutes" = "-(1hours,30 minutes)"
 "15 hours" - "-3 days" = "3 days and 15 hours"
 "1 year" - "-1 day" = "1 year and 1 day"

        Since there's no way to meaningfully subtract 1 day from 1 month, there are cases where the operation fails in IllegalStateException.

        Formally the computation is defined as follows. First, we can assume that two Durations are both positive without losing generality. (i.e., (-X)-Y=-(X+Y), X-(-Y)=X+Y, (-X)-(-Y)=-(X-Y))

        Then two durations are subtracted field by field. If the sign of any non-zero field F is different from the sign of the most significant field, 1 (if F is negative) or -1 (otherwise) will be borrowed from the next bigger unit of F.

        This process is repeated until all the non-zero fields have the same sign.

        If a borrow occurs in the days field (in other words, if the computation needs to borrow 1 or -1 month to compensate days), then the computation fails by throwing an IllegalStateException.

        参数：
        rhs - Duration to subtract from this Duration.
        返回：
        New Duration created from subtracting rhs from this Duration.
        抛出：
        IllegalStateException - If two durations cannot be meaningfully subtracted. For example, subtracting one day from one month causes this exception.
        NullPointerException - If the rhs parameter is null.
        另请参见：
        add(Duration)

      • multiply

        public Duration multiply(int factor)

        Computes a new duration whose value is factor times longer than the value of this duration.

        This method is provided for the convenience. It is functionally equivalent to the following code:

         multiply(new BigDecimal(String.valueOf(factor)))
        参数：
        factor - Factor times longer of new Duration to create.
        返回：
        New Duration that is factortimes longer than this Duration.
        另请参见：
        multiply(BigDecimal)

      • multiply

        public abstract Duration multiply(BigDecimal factor)
        Computes a new duration whose value is factor times longer than the value of this duration.

        For example,

         "P1M" (1 month) * "12" = "P12M" (12 months)
 "PT1M" (1 min) * "0.3" = "PT18S" (18 seconds)
 "P1M" (1 month) * "1.5" = IllegalStateException

        Since the Duration class is immutable, this method doesn't change the value of this object. It simply computes a new Duration object and returns it.

        The operation will be performed field by field with the precision of BigDecimal. Since all the fields except seconds are restricted to hold integers, any fraction produced by the computation will be carried down toward the next lower unit. For example, if you multiply "P1D" (1 day) with "0.5", then it will be 0.5 day, which will be carried down to "PT12H" (12 hours). When fractions of month cannot be meaningfully carried down to days, or year to months, this will cause an IllegalStateException to be thrown. For example if you multiple one month by 0.5.

        To avoid IllegalStateException, use the normalizeWith(Calendar) method to remove the years and months fields.

        参数：
        factor - to multiply by
        返回：
        returns a non-null valid Duration object
        抛出：
        IllegalStateException - if operation produces fraction in the months field.
        NullPointerException - if the factor parameter is null.

      • negate

        public abstract Duration negate()
        Returns a new Duration object whose value is -this.

        Since the Duration class is immutable, this method doesn't change the value of this object. It simply computes a new Duration object and returns it.

        返回：
        always return a non-null valid Duration object.

      • normalizeWith

        public abstract Duration normalizeWith(Calendar startTimeInstant)

        Converts the years and months fields into the days field by using a specific time instant as the reference point.

        For example, duration of one month normalizes to 31 days given the start time instance "July 8th 2003, 17:40:32".

        Formally, the computation is done as follows:

        1. the given Calendar object is cloned
        2. the years, months and days fields will be added to the Calendar object by using the Calendar.add(int,int) method
        3. the difference between the two Calendars in computed in milliseconds and converted to days, if a remainder occurs due to Daylight Savings Time, it is discarded
        4. the computed days, along with the hours, minutes and seconds fields of this duration object is used to construct a new Duration object.

        Note that since the Calendar class uses int to hold the value of year and month, this method may produce an unexpected result if this duration object holds a very large value in the years or months fields.

        参数：
        startTimeInstant - Calendar reference point.
        返回：
        Duration of years and months of this Duration as days.
        抛出：
        NullPointerException - If the startTimeInstant parameter is null.

      • compare

        public abstract int compare(Duration duration)

        Partial order relation comparison with this Duration instance.

        Comparison result must be in accordance with W3C XML Schema 1.0 Part 2, Section 3.2.7.6.2, Order relation on duration.

        Return:

        • DatatypeConstants.LESSER if this Duration is shorter than duration parameter
        • DatatypeConstants.EQUAL if this Duration is equal to duration parameter
        • DatatypeConstants.GREATER if this Duration is longer than duration parameter
        • DatatypeConstants.INDETERMINATE if a conclusive partial order relation cannot be determined
        参数：
        duration - to compare
        返回：
        the relationship between this Durationand duration parameter as DatatypeConstants.LESSER, DatatypeConstants.EQUAL, DatatypeConstants.GREATER or DatatypeConstants.INDETERMINATE.
        抛出：
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - if duration is null.
        另请参见：
        isShorterThan(Duration), isLongerThan(Duration)

      • isLongerThan

        public boolean isLongerThan(Duration duration)

        Checks if this duration object is strictly longer than another Duration object.

        Duration X is "longer" than Y if and only if X>Y as defined in the section 3.2.6.2 of the XML Schema 1.0 specification.

        For example, "P1D" (one day) > "PT12H" (12 hours) and "P2Y" (two years) > "P23M" (23 months).

        参数：
        duration - Duration to test this Duration against.
        返回：
        true if the duration represented by this object is longer than the given duration. false otherwise.
        抛出：
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - If duration is null.
        另请参见：
        isShorterThan(Duration), compare(Duration duration)

      • isShorterThan

        public boolean isShorterThan(Duration duration)

        Checks if this duration object is strictly shorter than another Duration object.

        参数：
        duration - Duration to test this Duration against.
        返回：
        true if duration parameter is shorter than this Duration, else false.
        抛出：
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        NullPointerException - if duration is null.
        另请参见：
        isLongerThan(Duration duration), compare(Duration duration)

      • equals

        public boolean equals(Object duration)

        Checks if this duration object has the same duration as another Duration object.

        For example, "P1D" (1 day) is equal to "PT24H" (24 hours).

        Duration X is equal to Y if and only if time instant t+X and t+Y are the same for all the test time instants specified in the section 3.2.6.2 of the XML Schema 1.0 specification.

        Note that there are cases where two Durations are "incomparable" to each other, like one month and 30 days. For example,

         !new Duration("P1M").isShorterThan(new Duration("P30D"))
 !new Duration("P1M").isLongerThan(new Duration("P30D"))
 !new Duration("P1M").equals(new Duration("P30D"))
        重载：
        equals in class Object
        参数：
        duration - The object to compare this Duration against.
        返回：
        true if this duration is the same length as duration. false if duration is null, is not a Duration object, or its length is different from this duration.
        抛出：
        UnsupportedOperationException - If the underlying implementation cannot reasonably process the request, e.g. W3C XML Schema allows for arbitrarily large/small/precise values, the request may be beyond the implementations capability.
        另请参见：
        compare(Duration duration)

      • hashCode

        public abstract int hashCode()
        Returns a hash code consistent with the definition of the equals method.
        重载：
        hashCode in class Object
        返回：
        a hash code value for this object.
        另请参见：
        Object.hashCode()

      • toString

        public String toString()

        Returns a String representation of this Duration Object.

        The result is formatted according to the XML Schema 1.0 spec and can be always parsed back later into the equivalent Duration Object by DatatypeFactory.newDuration(String lexicalRepresentation).

        Formally, the following holds for any Duration Object x:

         new Duration(x.toString()).equals(x)
        重载：
        toString in class Object
        返回：
        A non-null valid String representation of this Duration.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u ra.maxmajvvajjslooai/Ytnnnc=/".ffnj>MeD>r


javax.xml.datatype

Classes

  • DatatypeConstants
  • DatatypeConstants.Field
  • DatatypeFactory
  • Duration
  • XMLGregorianCalendar

Exceptions

  • DatatypeConfigurationException
c


javax.xml.datatype

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.datatype

XML/Java Type Mappings.

请参见： 描述

  • Class Summary
    类 描述
    DatatypeConstants
    Utility class to contain basic Datatype values as constants.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
  • Exception Summary
    Exception 描述
    DatatypeConfigurationException
    Indicates a serious configuration error.

软件包 javax.xml.datatype Description

XML/Java Type Mappings.

javax.xml.datatypeAPI provides XML/Java type mappings.

The following XML standards apply:

  • W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
W3C XML Schema Data Type | Java Data Type
xs:date | XMLGregorianCalendar
xs:dateTime | XMLGregorianCalendar
xs:duration | Duration
xs:gDay | XMLGregorianCalendar
xs:gMonth | XMLGregorianCalendar
xs:gMonthDay | XMLGregorianCalendar
xs:gYear | XMLGregorianCalendar
xs:gYearMonth | XMLGregorianCalendar
xs:time | XMLGregorianCalendar
XQuery 1.0 and XPath 2.0 Data Model | Java Data Type
xdt:dayTimeDuration | Duration
xdt:yearMonthDuration | Duration

W3C XML Schema data types that have a "natural" mapping to Java types are defined by JSR 31: Java™ Architecture for XML Binding (JAXB) Specification, Binding XML Schema to Java Representations. JAXB defined mappings for XML Schema built-in data types include:

  • xs:anySimpleType
  • xs:base64Binary
  • xs:boolean
  • xs:byte
  • xs:decimal
  • xs:double
  • xs:float
  • xs:hexBinary
  • xs:int
  • xs:integer
  • xs:long
  • xs:QName
  • xs:short
  • xs:string
  • xs:unsignedByte
  • xs:unsignedInt
  • xs:unsignedShort
  • Author Jeff Suttor
  • See W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • See XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
  • Since 1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acililet


javax.xml.datatype Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.datatype

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.datatype.DatatypeFactory
    • javax.xml.datatype.Duration
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.datatype.DatatypeConfigurationException
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a <


Uses of Package javax.xml.datatype

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.datatype

  • Packages that use javax.xml.datatype
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.
  • Classes in javax.xml.datatype used by javax.xml.datatype
    类与描述
    DatatypeConfigurationException
    Indicates a serious configuration error.
    DatatypeConstants.Field
    Type-safe enum class that represents six fields of the Duration class.
    DatatypeFactory
    Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
    Duration
    Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
    XMLGregorianCalendar
    Representation for W3C XML Schema 1.0 date/time datatypes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nodt<-ru>a"aer


XMLGregorianCalendar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.datatype

类 XMLGregorianCalendar

  • java.lang.Object
    • javax.xml.datatype.XMLGregorianCalendar
  • 所有已实现的接口：
    Cloneable

    public abstract class XMLGregorianCalendar
extends Object
implements Cloneable

    Representation for W3C XML Schema 1.0 date/time datatypes. Specifically, these date/time datatypes are DatatypeConstants.DATETIME, DatatypeConstants.TIME, DatatypeConstants.DATE, DatatypeConstants.GYEARMONTH, DatatypeConstants.GMONTHDAY, DatatypeConstants.GYEAR, DatatypeConstants.GMONTH, and DatatypeConstants.GDAY defined in the XML Namespace "http://www.w3.org/2001/XMLSchema". These datatypes are normatively defined in W3C XML Schema 1.0 Part 2, Section 3.2.7-14.

    The table below defines the mapping between XML Schema 1.0 date/time datatype fields and this class' fields. It also summarizes the value constraints for the date and time fields defined in W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats.

    Date/Time Datatype Field Mapping Between XML Schema 1.0 and Java Representation
    XML Schema 1.0
    datatype
    field     		Related
    XMLGregorianCalendar
    Accessor(s)     		Value Range
    year getYear() + getEon() or
    getEonAndYear()     		getYear() is a value between -(10^9-1) to (10^9)-1 or DatatypeConstants.FIELD_UNDEFINED.
    getEon() is high order year value in billion of years.
    getEon() has values greater than or equal to (10^9) or less than or equal to -(10^9). A value of null indicates field is undefined.
    Given that XML Schema 1.0 errata states that the year zero will be a valid lexical value in a future version of XML Schema, this class allows the year field to be set to zero. Otherwise, the year field value is handled exactly as described in the errata and [ISO-8601-1988]. Note that W3C XML Schema 1.0 validation does not allow for the year field to have a value of zero.
    month | getMonth() | 1 to 12 or DatatypeConstants.FIELD_UNDEFINED
    day getDay() Independent of month, max range is 1 to 31 or DatatypeConstants.FIELD_UNDEFINED.
    The normative value constraint stated relative to month field's value is in W3C XML Schema 1.0 Part 2, Appendix D.
    hour | getHour() | 0 to 23 or DatatypeConstants.FIELD_UNDEFINED. An hour value of 24 is allowed to be set in the lexical space provided the minute and second field values are zero. However, an hour value of 24 is not allowed in value space and will be transformed to represent the value of the first instance of the following day as per XML Schema Part 2: Datatypes Second Edition, 3.2 Primitive datatypes.
    minute | getMinute() | 0 to 59 or DatatypeConstants.FIELD_UNDEFINED
    second getSecond() + getMillisecond()/1000 or
    getSecond() + getFractionalSecond()     		getSecond() from 0 to 60 or DatatypeConstants.FIELD_UNDEFINED.
    (Note: 60 only allowable for leap second.)
    getFractionalSecond() allows for infinite precision over the range from 0.0 to 1.0 when the getSecond() is defined.
    FractionalSecond is optional and has a value of null when it is undefined.
    getMillisecond() is the convenience millisecond precision of value of getFractionalSecond().
    timezone | getTimezone() | Number of minutes or DatatypeConstants.FIELD_UNDEFINED. Value range from -14 hours (-14 * 60 minutes) to 14 hours (14 * 60 minutes).

    All maximum value space constraints listed for the fields in the table above are checked by factory methods, @{link DatatypeFactory}, setter methods and parse methods of this class. IllegalArgumentException is thrown when a parameter's value is outside the value constraint for the field or if the composite values constitute an invalid XMLGregorianCalendar instance (for example, if the 31st of June is specified).

    The following operations are defined for this class:

    • accessors/mutators for independent date/time fields
    • conversion between this class and W3C XML Schema 1.0 lexical representation, toString(), DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
    • conversion between this class and GregorianCalendar, toGregorianCalendar(java.util.TimeZone timezone, java.util.Locale aLocale, XMLGregorianCalendar defaults), DatatypeFactory
    • partial order relation comparator method, compare(XMLGregorianCalendar xmlGregorianCalendar)
    • equals(Object) defined relative to compare(XMLGregorianCalendar xmlGregorianCalendar).
    • addition operation with Duration instance as defined in W3C XML Schema 1.0 Part 2, Appendix E, Adding durations to dateTimes.

    从以下版本开始：
    1.5
    另请参见：
    Duration, DatatypeFactory

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLGregorianCalendar()
      Default no-arg constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void add(Duration duration)
      Add duration to this instance.
      abstract void clear()
      Unset all fields to undefined.
      abstract Object clone()
      Creates and returns a copy of this object.
      abstract int compare(XMLGregorianCalendar xmlGregorianCalendar)
      Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
      boolean equals(Object obj)
      Compares this calendar to the specified object.
      abstract int getDay()
      Return day in month or DatatypeConstants.FIELD_UNDEFINED.
      abstract BigInteger getEon()
      Return high order component for XML Schema 1.0 dateTime datatype field for year.
      abstract BigInteger getEonAndYear()
      Return XML Schema 1.0 dateTime datatype field for year.
      abstract BigDecimal getFractionalSecond()
      Return fractional seconds.
      abstract int getHour()
      Return hours or DatatypeConstants.FIELD_UNDEFINED.
      int getMillisecond()
      Return millisecond precision of getFractionalSecond().
      abstract int getMinute()
      Return minutes or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getMonth()
      Return number of month or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getSecond()
      Return seconds or DatatypeConstants.FIELD_UNDEFINED.
      abstract int getTimezone()
      Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.
      abstract TimeZone getTimeZone(int defaultZoneoffset)
      Returns a java.util.TimeZone for this class.
      abstract QName getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      abstract int getYear()
      Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.
      int hashCode()
      Returns a hash code consistent with the definition of the equals method.
      abstract boolean isValid()
      Validate instance by getXMLSchemaType() constraints.
      abstract XMLGregorianCalendar normalize()
      Normalize this instance to UTC.
      abstract void reset()
      Reset this XMLGregorianCalendar to its original values.
      abstract void setDay(int day)
      Set days in month.
      abstract void setFractionalSecond(BigDecimal fractional)
      Set fractional seconds.
      abstract void setHour(int hour)
      Set hours.
      abstract void setMillisecond(int millisecond)
      Set milliseconds.
      abstract void setMinute(int minute)
      Set minutes.
      abstract void setMonth(int month)
      Set month.
      abstract void setSecond(int second)
      Set seconds.
      void setTime(int hour, int minute, int second)
      Set time as one unit.
      void setTime(int hour, int minute, int second, BigDecimal fractional)
      Set time as one unit, including the optional infinite precision fractional seconds.
      void setTime(int hour, int minute, int second, int millisecond)
      Set time as one unit, including optional milliseconds.
      abstract void setTimezone(int offset)
      Set the number of minutes in the timezone offset.
      abstract void setYear(BigInteger year)
      Set low and high order component of XSD dateTime year field.
      abstract void setYear(int year)
      Set year of XSD dateTime year field.
      abstract GregorianCalendar toGregorianCalendar()
      Convert this XMLGregorianCalendar to a GregorianCalendar.
      abstract GregorianCalendar toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.
      String toString()
      Returns a String representation of this XMLGregorianCalendar Object.
      abstract String toXMLFormat()
      Return the lexical representation of this instance.

      • 方法 - 继承于类 java.lang.Object

        finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XMLGregorianCalendar

        public XMLGregorianCalendar()
        Default no-arg constructor.

        Note: Always use the DatatypeFactory to construct an instance of XMLGregorianCalendar. The constructor on this class cannot be guaranteed to produce an object with a consistent state and may be removed in the future.

    • 方法详细信息

      • clear

        public abstract void clear()

        Unset all fields to undefined.

        Set all int fields to DatatypeConstants.FIELD_UNDEFINED and reference fields to null.

      • reset

        public abstract void reset()

        Reset this XMLGregorianCalendar to its original values.

        XMLGregorianCalendar is reset to the same values as when it was created with DatatypeFactory.newXMLGregorianCalendar(), DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation), DatatypeFactory.newXMLGregorianCalendar( BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone), DatatypeFactory.newXMLGregorianCalendar( int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone), DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal), DatatypeFactory.newXMLGregorianCalendarDate( int year, int month, int day, int timezone), DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int timezone), DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) or DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int milliseconds, int timezone).

        reset() is designed to allow the reuse of existing XMLGregorianCalendars thus saving resources associated with the creation of new XMLGregorianCalendars.

      • setYear

        public abstract void setYear(BigInteger year)

        Set low and high order component of XSD dateTime year field.

        Unset this field by invoking the setter with a parameter value of null.

        参数：
        year - value constraints summarized in year field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if year parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setYear

        public abstract void setYear(int year)

        Set year of XSD dateTime year field.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        Note: if the absolute value of the year parameter is less than 10^9, the eon component of the XSD year field is set to null by this method.

        参数：
        year - value constraints are summarized in year field of date/time field mapping table. If year is DatatypeConstants.FIELD_UNDEFINED, then eon is set to null.

      • setMonth

        public abstract void setMonth(int month)

        Set month.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        month - value constraints summarized in month field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if month parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setDay

        public abstract void setDay(int day)

        Set days in month.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        day - value constraints summarized in day field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if day parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTimezone

        public abstract void setTimezone(int offset)

        Set the number of minutes in the timezone offset.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        offset - value constraints summarized in timezone field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if offset parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
           int minute,
           int second)

        Set time as one unit.

        参数：
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.
        另请参见：
        setTime(int, int, int, BigDecimal)

      • setHour

        public abstract void setHour(int hour)

        Set hours.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        hour - value constraints summarized in hour field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if hour parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setMinute

        public abstract void setMinute(int minute)

        Set minutes.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        minute - value constraints summarized in minute field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if minute parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setSecond

        public abstract void setSecond(int second)

        Set seconds.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        second - value constraints summarized in second field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if second parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setMillisecond

        public abstract void setMillisecond(int millisecond)

        Set milliseconds.

        Unset this field by invoking the setter with a parameter value of DatatypeConstants.FIELD_UNDEFINED.

        参数：
        millisecond - value constraints summarized in second field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if millisecond parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setFractionalSecond

        public abstract void setFractionalSecond(BigDecimal fractional)

        Set fractional seconds.

        Unset this field by invoking the setter with a parameter value of null.

        参数：
        fractional - value constraints summarized in second field of date/time field mapping table.
        抛出：
        IllegalArgumentException - if fractional parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
           int minute,
           int second,
           BigDecimal fractional)

        Set time as one unit, including the optional infinite precision fractional seconds.

        参数：
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        fractional - value of null indicates this optional field is not set.
        抛出：
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.

      • setTime

        public void setTime(int hour,
           int minute,
           int second,
           int millisecond)

        Set time as one unit, including optional milliseconds.

        参数：
        hour - value constraints are summarized in hour field of date/time field mapping table.
        minute - value constraints are summarized in minute field of date/time field mapping table.
        second - value constraints are summarized in second field of date/time field mapping table.
        millisecond - value of DatatypeConstants.FIELD_UNDEFINED indicates this optional field is not set.
        抛出：
        IllegalArgumentException - if any parameter is outside value constraints for the field as specified in date/time field mapping table.

      • getEon

        public abstract BigInteger getEon()

        Return high order component for XML Schema 1.0 dateTime datatype field for year. null if this optional part of the year field is not defined.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        返回：
        eon of this XMLGregorianCalendar. The value returned is an integer multiple of 10^9.
        另请参见：
        getYear(), getEonAndYear()

      • getYear

        public abstract int getYear()

        Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        返回：
        year of this XMLGregorianCalendar.
        另请参见：
        getEon(), getEonAndYear()

      • getEonAndYear

        public abstract BigInteger getEonAndYear()

        Return XML Schema 1.0 dateTime datatype field for year.

        Value constraints for this value are summarized in year field of date/time field mapping table.

        返回：
        sum of eon and BigInteger.valueOf(year) when both fields are defined. When only year is defined, return it. When both eon and year are not defined, return null.
        另请参见：
        getEon(), getYear()

      • getMonth

        public abstract int getMonth()

        Return number of month or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in month field of date/time field mapping table.

        返回：
        year of this XMLGregorianCalendar.

      • getDay

        public abstract int getDay()
        Return day in month or DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in day field of date/time field mapping table.

        另请参见：
        setDay(int)

      • getTimezone

        public abstract int getTimezone()
        Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.

        Value constraints for this value are summarized in timezone field of date/time field mapping table.

        另请参见：
        setTimezone(int)

      • getHour

        public abstract int getHour()
        Return hours or DatatypeConstants.FIELD_UNDEFINED. Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined.

        Value constraints for this value are summarized in hour field of date/time field mapping table.

        另请参见：
        setTime(int, int, int)

      • getMinute

        public abstract int getMinute()
        Return minutes or DatatypeConstants.FIELD_UNDEFINED.

        Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined.

        Value constraints for this value are summarized in minute field of date/time field mapping table.

        另请参见：
        setTime(int, int, int)

      • getSecond

        public abstract int getSecond()

        Return seconds or DatatypeConstants.FIELD_UNDEFINED.

        Returns DatatypeConstants.FIELD_UNDEFINED if this field is not defined. When this field is not defined, the optional xs:dateTime fractional seconds field, represented by getFractionalSecond() and getMillisecond(), must not be defined.

        Value constraints for this value are summarized in second field of date/time field mapping table.

        返回：
        Second of this XMLGregorianCalendar.
        另请参见：
        getFractionalSecond(),
getMillisecond(),
setTime(int, int, int)

      • getMillisecond

        public int getMillisecond()

        Return millisecond precision of getFractionalSecond().

        This method represents a convenience accessor to infinite precision fractional second value returned by getFractionalSecond(). The returned value is the rounded down to milliseconds value of getFractionalSecond(). When getFractionalSecond() returns null, this method must return DatatypeConstants.FIELD_UNDEFINED.

        Value constraints for this value are summarized in second field of date/time field mapping table.

        返回：
        Millisecond of this XMLGregorianCalendar.
        另请参见：
        getFractionalSecond(), setTime(int, int, int)

      • getFractionalSecond

        public abstract BigDecimal getFractionalSecond()

        Return fractional seconds.

        null is returned when this optional field is not defined.

        Value constraints are detailed in second field of date/time field mapping table.

        This optional field can only have a defined value when the xs:dateTime second field, represented by getSecond(), does not return DatatypeConstants.FIELD_UNDEFINED.

        返回：
        fractional seconds of this XMLGregorianCalendar.
        另请参见：
        getSecond(), setTime(int, int, int, BigDecimal)

      • compare

        public abstract int compare(XMLGregorianCalendar xmlGregorianCalendar)

        Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.

        xsd:dateTime datatype field mapping to accessors of this class are defined in date/time field mapping table.

        参数：
        xmlGregorianCalendar - Instance of XMLGregorianCalendar to compare
        返回：
        The relationship between this XMLGregorianCalendar and the specified xmlGregorianCalendar as DatatypeConstants.LESSER, DatatypeConstants.EQUAL, DatatypeConstants.GREATER or DatatypeConstants.INDETERMINATE.
        抛出：
        NullPointerException - if xmlGregorianCalendar is null.

      • normalize

        public abstract XMLGregorianCalendar normalize()

        Normalize this instance to UTC.

        2000-03-04T23:00:00+03:00 normalizes to 2000-03-04T20:00:00Z

        Implements W3C XML Schema Part 2, Section 3.2.7.3 (A).

        返回：
        this XMLGregorianCalendar normalized to UTC.

      • equals

        public boolean equals(Object obj)

        Compares this calendar to the specified object. The result is true if and only if the argument is not null and is an XMLGregorianCalendar object that represents the same instant in time as this object.

        重载：
        equals in class Object
        参数：
        obj - to compare.
        返回：
        true when obj is an instance of XMLGregorianCalendar and compare(XMLGregorianCalendar obj) returns DatatypeConstants.EQUAL, otherwise false.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()

        Returns a hash code consistent with the definition of the equals method.

        重载：
        hashCode in class Object
        返回：
        hash code of this object.
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toXMLFormat

        public abstract String toXMLFormat()

        Return the lexical representation of this instance. The format is specified in XML Schema 1.0 Part 2, Section 3.2.[7-14].1, Lexical Representation".

        Specific target lexical representation format is determined by getXMLSchemaType().

        返回：
        XML, as String, representation of this XMLGregorianCalendar
        抛出：
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.

      • getXMLSchemaType

        public abstract QName getXMLSchemaType()

        Return the name of the XML Schema date/time type that this instance maps to. Type is computed based on fields that are set.

        Required fields for XML Schema 1.0 Date/Time Datatypes.
        (timezone is optional for all date/time datatypes)
        Datatype | year | month | day | hour | minute | second
        DatatypeConstants.DATETIME | X | X | X | X | X | X
        DatatypeConstants.DATE | X | X | X
        DatatypeConstants.TIME | X | X | X
        DatatypeConstants.GYEARMONTH | X | X
        DatatypeConstants.GMONTHDAY | X | X
        DatatypeConstants.GYEAR | X
        DatatypeConstants.GMONTH | X
        DatatypeConstants.GDAY | X
        返回：
        One of the following class constants: DatatypeConstants.DATETIME, DatatypeConstants.TIME, DatatypeConstants.DATE, DatatypeConstants.GYEARMONTH, DatatypeConstants.GMONTHDAY, DatatypeConstants.GYEAR, DatatypeConstants.GMONTH or DatatypeConstants.GDAY.
        抛出：
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.

      • toString

        public String toString()

        Returns a String representation of this XMLGregorianCalendar Object.

        The result is a lexical representation generated by toXMLFormat().

        重载：
        toString in class Object
        返回：
        A non-null valid String representation of this XMLGregorianCalendar.
        抛出：
        IllegalStateException - if the combination of set fields does not match one of the eight defined XML Schema builtin date/time datatypes.
        另请参见：
        toXMLFormat()

      • isValid

        public abstract boolean isValid()
        Validate instance by getXMLSchemaType() constraints.
        返回：
        true if data values are valid.

      • add

        public abstract void add(Duration duration)

        Add duration to this instance.

        The computation is specified in XML Schema 1.0 Part 2, Appendix E, Adding durations to dateTimes>. date/time field mapping table defines the mapping from XML Schema 1.0 dateTime fields to this class' representation of those fields.

        参数：
        duration - Duration to add to this XMLGregorianCalendar.
        抛出：
        NullPointerException - when duration parameter is null.

      • toGregorianCalendar

        public abstract GregorianCalendar toGregorianCalendar()

        Convert this XMLGregorianCalendar to a GregorianCalendar.

        When this instance has an undefined field, this conversion relies on the java.util.GregorianCalendar default for its corresponding field. A notable difference between XML Schema 1.0 date/time datatypes and java.util.GregorianCalendar is that Timezone value is optional for date/time datatypes and it is a required field for java.util.GregorianCalendar. See javadoc for java.util.TimeZone.getDefault() on how the default is determined. To explicitly specify the TimeZone instance, see toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar).

        Field by Field Conversion from this class to java.util.GregorianCalendar
        java.util.GregorianCalendar field | javax.xml.datatype.XMLGregorianCalendar field
        ERA | getEonAndYear() .signum() < 0 ? GregorianCalendar.BC : GregorianCalendar.AD
        YEAR | getEonAndYear() .abs().intValue()*
        MONTH | getMonth() - DatatypeConstants.JANUARY + Calendar.JANUARY
        DAY_OF_MONTH | getDay()
        HOUR_OF_DAY | getHour()
        MINUTE | getMinute()
        SECOND | getSecond()
        MILLISECOND | get millisecond order from getFractionalSecond() *
        GregorianCalendar.setTimeZone(TimeZone) | getTimezone() formatted into Custom timezone id
        * designates possible loss of precision during the conversion due to source datatype having higher precision than target datatype.

        To ensure consistency in conversion implementations, the new GregorianCalendar should be instantiated in following manner.

        • Using timeZone value as defined above, create a new java.util.GregorianCalendar(timeZone,Locale.getDefault()).
        • Initialize all GregorianCalendar fields by calling Calendar.clear().
        • Obtain a pure Gregorian Calendar by invoking GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)).
        • Its fields ERA, YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, MINUTE, SECOND and MILLISECOND are set using the method Calendar.set(int,int)

        另请参见：
        toGregorianCalendar(java.util.TimeZone, java.util.Locale, XMLGregorianCalendar)

      • toGregorianCalendar

        public abstract GregorianCalendar toGregorianCalendar(TimeZone timezone,
                                    Locale aLocale,
                                    XMLGregorianCalendar defaults)

        Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.

        Since XML Schema 1.0 date/time datetypes has no concept of timezone ids or daylight savings timezone ids, this conversion operation allows the user to explicitly specify one with timezone parameter.

        To compute the return value's TimeZone field,

        • when parameter timeZone is non-null, it is the timezone field.
        • else when this.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using the this.getTimezone().
        • else when defaults.getTimezone() != FIELD_UNDEFINED, create a java.util.TimeZone with a custom timezone id using defaults.getTimezone().
        • else use the GregorianCalendar default timezone value for the host is defined as specified by java.util.TimeZone.getDefault().

          • To ensure consistency in conversion implementations, the new GregorianCalendar should be instantiated in following manner.

          • Create a new java.util.GregorianCalendar(TimeZone, Locale) with TimeZone set as specified above and the Locale parameter.
          • Initialize all GregorianCalendar fields by calling Calendar.clear()
          • Obtain a pure Gregorian Calendar by invoking GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)).
          • Its fields ERA, YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, MINUTE, SECOND and MILLISECOND are set using the method Calendar.set(int,int)
        参数：
        timezone - provide Timezone. null is a legal value.
        aLocale - provide explicit Locale. Use default GregorianCalendar locale if value is null.
        defaults - provide default field values to use when corresponding field for this instance is FIELD_UNDEFINED or null. If defaultsis null or a field within the specified defaults is undefined, just use java.util.GregorianCalendar defaults.
        返回：
        a java.util.GregorianCalendar conversion of this instance.

      • getTimeZone

        public abstract TimeZone getTimeZone(int defaultZoneoffset)

        Returns a java.util.TimeZone for this class.

        If timezone field is defined for this instance, returns TimeZone initialized with custom timezone id of zoneoffset. If timezone field is undefined, try the defaultZoneoffset that was passed in. If defaultZoneoffset is FIELD_UNDEFINED, return default timezone for this host. (Same default as java.util.GregorianCalendar).

        参数：
        defaultZoneoffset - default zoneoffset if this zoneoffset is DatatypeConstants.FIELD_UNDEFINED.
        返回：
        TimeZone for this.

      • clone

        public abstract Object clone()

        Creates and returns a copy of this object.

        重载：
        clone in class Object
        返回：
        copy of this Object
        另请参见：
        Cloneable
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.xml.datatype.DatatypeConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.DatatypeConfigurationException

  • Packages that use DatatypeConfigurationException
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeConfigurationException in javax.xml.datatype

      Methods in javax.xml.datatype that throw DatatypeConfigurationException
      修饰符与类型 方法与描述
      static DatatypeFactory DatatypeFactory.newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/


Uses of Class javax.xml.datatype.DatatypeConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.DatatypeConstants

No usage of javax.xml.datatype.DatatypeConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l<#sypeaDtttpl//Dtoa/


Uses of Class javax.xml.datatype.DatatypeConstants.Field

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.DatatypeConstants.Field

  • Packages that use DatatypeConstants.Field
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeConstants.Field in javax.xml.datatype

      Fields in javax.xml.datatype declared as DatatypeConstants.Field
      修饰符与类型 字段与描述
      static DatatypeConstants.Field DatatypeConstants.DAYS
      A constant that represents the days field.
      static DatatypeConstants.Field DatatypeConstants.HOURS
      A constant that represents the hours field.
      static DatatypeConstants.Field DatatypeConstants.MINUTES
      A constant that represents the minutes field.
      static DatatypeConstants.Field DatatypeConstants.MONTHS
      A constant that represents the months field.
      static DatatypeConstants.Field DatatypeConstants.SECONDS
      A constant that represents the seconds field.
      static DatatypeConstants.Field DatatypeConstants.YEARS
      A constant that represents the years field.
      Methods in javax.xml.datatype with parameters of type DatatypeConstants.Field
      修饰符与类型 方法与描述
      abstract Number Duration.getField(DatatypeConstants.Field field)
      Gets the value of a field.
      abstract boolean Duration.isSet(DatatypeConstants.Field field)
      Checks if a field is set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#n>leUUaeMh#sXArc 1na


Uses of Class javax.xml.datatype.DatatypeFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.DatatypeFactory

  • Packages that use DatatypeFactory
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of DatatypeFactory in javax.xml.datatype

      Methods in javax.xml.datatype that return DatatypeFactory
      修饰符与类型 方法与描述
      static DatatypeFactory DatatypeFactory.newInstance()
      Obtain a new instance of a DatatypeFactory.
      static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DatatypeFactory from class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Dsn cg>srs/g觮/t>ge"tm


Uses of Class javax.xml.datatype.Duration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.Duration

  • Packages that use Duration
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of Duration in javax.xml.datatype

      Methods in javax.xml.datatype that return Duration
      修饰符与类型 方法与描述
      abstract Duration Duration.add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract Duration Duration.multiply(BigDecimal factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      Duration Duration.multiply(int factor)
      Computes a new duration whose value is factor times longer than the value of this duration.
      abstract Duration Duration.negate()
      Returns a new Duration object whose value is -this.
      abstract Duration DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      Duration DatatypeFactory.newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds)
      Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
      abstract Duration DatatypeFactory.newDuration(long durationInMilliSeconds)
      Obtain a new instance of a Duration specifying the Duration as milliseconds.
      abstract Duration DatatypeFactory.newDuration(String lexicalRepresentation)
      Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.
      Duration DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second)
      Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(long durationInMilliseconds)
      Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationDayTime(String lexicalRepresentation)
      Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
      Duration DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(boolean isPositive, int year, int month)
      Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(long durationInMilliseconds)
      Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      Duration DatatypeFactory.newDurationYearMonth(String lexicalRepresentation)
      Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
      abstract Duration Duration.normalizeWith(Calendar startTimeInstant)
      Converts the years and months fields into the days field by using a specific time instant as the reference point.
      Duration Duration.subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
      Methods in javax.xml.datatype with parameters of type Duration
      修饰符与类型 方法与描述
      abstract void XMLGregorianCalendar.add(Duration duration)
      Add duration to this instance.
      abstract Duration Duration.add(Duration rhs)
      Computes a new duration whose value is this+rhs.
      abstract int Duration.compare(Duration duration)
      Partial order relation comparison with this Duration instance.
      boolean Duration.isLongerThan(Duration duration)
      Checks if this duration object is strictly longer than another Duration object.
      boolean Duration.isShorterThan(Duration duration)
      Checks if this duration object is strictly shorter than another Duration object.
      Duration Duration.subtract(Duration rhs)
      Computes a new duration whose value is this-rhs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/x>.// "d"<|�:t.=u�


Uses of Class javax.xml.datatype.XMLGregorianCalendar

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.datatype.XMLGregorianCalendar

  • Packages that use XMLGregorianCalendar
    软件包 描述
    javax.xml.datatype
    XML/Java Type Mappings.

    • Uses of XMLGregorianCalendar in javax.xml.datatype

      Methods in javax.xml.datatype that return XMLGregorianCalendar
      修饰符与类型 方法与描述
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar()
      Create a new instance of an XMLGregorianCalendar.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)
      Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal)
      Create an XMLGregorianCalendar from a GregorianCalendar.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone)
      Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.
      abstract XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
      Create a new XMLGregorianCalendar by parsing the String as a lexical representation.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarDate(int year, int month, int day, int timezone)
      Create a Java representation of XML Schema builtin datatype date or g*.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone)
      Create a Java instance of XML Schema builtin datatype time.
      abstract XMLGregorianCalendar XMLGregorianCalendar.normalize()
      Normalize this instance to UTC.
      Methods in javax.xml.datatype with parameters of type XMLGregorianCalendar
      修饰符与类型 方法与描述
      abstract int XMLGregorianCalendar.compare(XMLGregorianCalendar xmlGregorianCalendar)
      Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
      abstract GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
      Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

, irgg e dtuci


javax.xml.namespace

Interfaces

  • NamespaceContext

Classes

  • QName
f


javax.xml.namespace

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.namespace

XML Namespace processing.

请参见： 描述

  • 接口摘要
    接口 描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
  • Class Summary
    类 描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

软件包 javax.xml.namespace Description

XML Namespace processing.

The following XML standards apply:

  • XML Schema Part2: Datatypes specification
  • Namespaces in XML
  • Namespaces in XML Errata
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f/e=fo


javax.xml.namespace Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.namespace

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.namespace.QName (implements java.io.Serializable)

Interface Hierarchy

  • javax.xml.namespace.NamespaceContext
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r">o;gs/ttt;Eaa> ggnn


NamespaceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.namespace

Interface NamespaceContext

  • public interface NamespaceContext

    Interface for read only XML Namespace context processing.

    An XML Namespace has the properties:

    • Namespace URI: Namespace name expressed as a URI to which the prefix is bound
    • prefix: syntactically, this is the part of the attribute name following the XMLConstants.XMLNS_ATTRIBUTE ("xmlns") in the Namespace declaration

    example: <element xmlns:prefix="http://Namespace-name-URI">

    All get*(*) methods operate in the current scope for Namespace URI and prefix resolution.

    Note that a Namespace URI can be bound to multiple prefixes in the current scope. This can occur when multiple XMLConstants.XMLNS_ATTRIBUTE ("xmlns") Namespace declarations occur in the same Start-Tag and refer to the same Namespace URI. e.g.

     <element xmlns:prefix1="http://Namespace-name-URI"
          xmlns:prefix2="http://Namespace-name-URI">
    This can also occur when the same Namespace URI is used in multiple XMLConstants.XMLNS_ATTRIBUTE ("xmlns") Namespace declarations in the logical parent element hierarchy. e.g.
     <parent xmlns:prefix1="http://Namespace-name-URI">
   <child xmlns:prefix2="http://Namespace-name-URI">
     ...
   </child>
 </parent>

    A prefix can only be bound to a single Namespace URI in the current scope.

    从以下版本开始：
    1.5
    另请参见：
    javax.xml.XMLConstants for declarations of common XML values, XML Schema Part2: Datatypes, Namespaces in XML, Namespaces in XML Errata

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getNamespaceURI(String prefix)
      Get Namespace URI bound to a prefix in the current scope.
      String getPrefix(String namespaceURI)
      Get prefix bound to Namespace URI in the current scope.
      Iterator getPrefixes(String namespaceURI)
      Get all prefixes bound to a Namespace URI in the current scope.

    • 方法详细信息

      • getNamespaceURI

        String getNamespaceURI(String prefix)

        Get Namespace URI bound to a prefix in the current scope.

        When requesting a Namespace URI by prefix, the following table describes the returned Namespace URI value for all possible prefix values:

        getNamespaceURI(prefix) return value for specified prefixes
        prefix parameter | Namespace URI return value
        DEFAULT_NS_PREFIX ("") | default Namespace URI in the current scope or XMLConstants.NULL_NS_URI("") when there is no default Namespace URI in the current scope
        bound prefix | Namespace URI bound to prefix in current scope
        unbound prefix | XMLConstants.NULL_NS_URI("")
        XMLConstants.XML_NS_PREFIX ("xml") | XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace")
        XMLConstants.XMLNS_ATTRIBUTE ("xmlns") | XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/")
        null | IllegalArgumentException is thrown
        参数：
        prefix - prefix to look up
        返回：
        Namespace URI bound to prefix in the current scope
        抛出：
        IllegalArgumentException - When prefix is null

      • getPrefix

        String getPrefix(String namespaceURI)

        Get prefix bound to Namespace URI in the current scope.

        To get all prefixes bound to a Namespace URI in the current scope, use getPrefixes(String namespaceURI).

        When requesting a prefix by Namespace URI, the following table describes the returned prefix value for all Namespace URI values:

        getPrefix(namespaceURI) return value for specified Namespace URIs
        Namespace URI parameter | prefix value returned
        <default Namespace URI> | XMLConstants.DEFAULT_NS_PREFIX ("")
        bound Namespace URI | prefix bound to Namespace URI in the current scope, if multiple prefixes are bound to the Namespace URI in the current scope, a single arbitrary prefix, whose choice is implementation dependent, is returned
        unbound Namespace URI | null
        XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | XMLConstants.XML_NS_PREFIX ("xml")
        XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | XMLConstants.XMLNS_ATTRIBUTE ("xmlns")
        null | IllegalArgumentException is thrown
        参数：
        namespaceURI - URI of Namespace to lookup
        返回：
        prefix bound to Namespace URI in current context
        抛出：
        IllegalArgumentException - When namespaceURI is null

      • getPrefixes

        Iterator getPrefixes(String namespaceURI)

        Get all prefixes bound to a Namespace URI in the current scope.

        An Iterator over String elements is returned in an arbitrary, implementation dependent, order.

        The Iterator is not modifiable. e.g. the remove() method will throw UnsupportedOperationException.

        When requesting prefixes by Namespace URI, the following table describes the returned prefixes value for all Namespace URI values:

        getPrefixes(namespaceURI) return value for specified Namespace URIs
        Namespace URI parameter | prefixes value returned
        bound Namespace URI, including the <default Namespace URI> | Iterator over prefixes bound to Namespace URI in the current scope in an arbitrary, implementation dependent, order
        unbound Namespace URI | empty Iterator
        XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | Iterator with one element set to XMLConstants.XML_NS_PREFIX ("xml")
        XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | Iterator with one element set to XMLConstants.XMLNS_ATTRIBUTE ("xmlns")
        null | IllegalArgumentException is thrown
        参数：
        namespaceURI - URI of Namespace to lookup
        返回：
        Iterator for all prefixes bound to the Namespace URI in the current scope
        抛出：
        IllegalArgumentException - When namespaceURI is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/d=/


QName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.namespace

类 QName

  • java.lang.Object
    • javax.xml.namespace.QName
  • 所有已实现的接口：
    Serializable

    public class QName
extends Object
implements Serializable

    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

    The value of a QName contains a Namespace URI, local part and prefix.

    The prefix is included in QName to retain lexical information when present in an XML input source. The prefix is NOT used in QName.equals(Object) or to compute the QName.hashCode(). Equality and the hash code are defined using only the Namespace URI and local part.

    If not specified, the Namespace URI is set to XMLConstants.NULL_NS_URI. If not specified, the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

    QName is immutable.

    从以下版本开始：
    1.5
    另请参见：
    XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      QName(String localPart)
      QName constructor specifying the local part.
      QName(String namespaceURI, String localPart)
      QName constructor specifying the Namespace URI and local part.
      QName(String namespaceURI, String localPart, String prefix)
      QName constructor specifying the Namespace URI, local part and prefix.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object objectToTest)
      Test this QName for equality with another Object.
      String getLocalPart()
      Get the local part of this QName.
      String getNamespaceURI()
      Get the Namespace URI of this QName.
      String getPrefix()
      Get the prefix of this QName.
      int hashCode()
      Generate the hash code for this QName.
      String toString()
      String representation of this QName.
      static QName valueOf(String qNameAsString)
      QName derived from parsing the formatted String.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • QName

        public QName(String namespaceURI,
     String localPart)

        QName constructor specifying the Namespace URI and local part.

        If the Namespace URI is null, it is set to XMLConstants.NULL_NS_URI. This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0. Explicitly providing the XMLConstants.NULL_NS_URI value is the preferred coding style.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        When using this constructor, the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

        The Namespace URI is not validated as a URI reference. The local part is not validated as a NCName as specified in Namespaces in XML.

        参数：
        namespaceURI - Namespace URI of the QName
        localPart - local part of the QName
        抛出：
        IllegalArgumentException - When localPart is null
        另请参见：
        QName(String namespaceURI, String localPart, String prefix)

      • QName

        public QName(String namespaceURI,
     String localPart,
     String prefix)

        QName constructor specifying the Namespace URI, local part and prefix.

        If the Namespace URI is null, it is set to XMLConstants.NULL_NS_URI. This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0. Explicitly providing the XMLConstants.NULL_NS_URI value is the preferred coding style.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        If the prefix is null, an IllegalArgumentException is thrown. Use XMLConstants.DEFAULT_NS_PREFIX to explicitly indicate that no prefix is present or the prefix is not relevant.

        The Namespace URI is not validated as a URI reference. The local part and prefix are not validated as a NCName as specified in Namespaces in XML.

        参数：
        namespaceURI - Namespace URI of the QName
        localPart - local part of the QName
        prefix - prefix of the QName
        抛出：
        IllegalArgumentException - When localPart or prefix is null

      • QName

        public QName(String localPart)

        QName constructor specifying the local part.

        If the local part is null an IllegalArgumentException is thrown. A local part of "" is allowed to preserve compatible behavior with QName 1.0.

        When using this constructor, the Namespace URI is set to XMLConstants.NULL_NS_URI and the prefix is set to XMLConstants.DEFAULT_NS_PREFIX.

        In an XML context, all Element and Attribute names exist in the context of a Namespace. Making this explicit during the construction of a QName helps prevent hard to diagnosis XML validity errors. The constructors QName(String namespaceURI, String localPart) and QName(String namespaceURI, String localPart, String prefix) are preferred.

        The local part is not validated as a NCName as specified in Namespaces in XML.

        参数：
        localPart - local part of the QName
        抛出：
        IllegalArgumentException - When localPart is null
        另请参见：
        QName(String namespaceURI, String localPart), QName(String namespaceURI, String localPart, String prefix)

    • 方法详细信息

      • getNamespaceURI

        public String getNamespaceURI()

        Get the Namespace URI of this QName.

        返回：
        Namespace URI of this QName

      • getLocalPart

        public String getLocalPart()

        Get the local part of this QName.

        返回：
        local part of this QName

      • getPrefix

        public String getPrefix()

        Get the prefix of this QName.

        The prefix assigned to a QName might NOT be valid in a different context. For example, a QName may be assigned a prefix in the context of parsing a document but that prefix may be invalid in the context of a different document.

        返回：
        prefix of this QName

      • equals

        public final boolean equals(Object objectToTest)

        Test this QName for equality with another Object.

        If the Object to be tested is not a QName or is null, then this method returns false.

        Two QNames are considered equal if and only if both the Namespace URI and local part are equal. This method uses String.equals() to check equality of the Namespace URI and local part. The prefix is NOT used to determine equality.

        This method satisfies the general contract of Object.equals(Object)

        重载：
        equals in class Object
        参数：
        objectToTest - the Object to test for equality with this QName
        返回：
        true if the given Object is equal to this QName else false
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public final int hashCode()

        Generate the hash code for this QName.

        The hash code is calculated using both the Namespace URI and the local part of the QName. The prefix is NOT used to calculate the hash code.

        This method satisfies the general contract of Object.hashCode().

        重载：
        hashCode in class Object
        返回：
        hash code for this QName Object
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • toString

        public String toString()

        String representation of this QName.

        The commonly accepted way of representing a QName as a String was defined by James Clark. Although this is not a standard specification, it is in common use, e.g. Transformer.setParameter(String name, Object value). This implementation represents a QName as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(XMLConstants.NULL_NS_URI), only the local part is returned. An appropriate use of this method is for debugging or logging for human consumption.

        Note the prefix value is NOT returned as part of the String representation.

        This method satisfies the general contract of Object.toString().

        重载：
        toString in class Object
        返回：
        String representation of this QName

      • valueOf

        public static QName valueOf(String qNameAsString)

        QName derived from parsing the formatted String.

        If the String is null or does not conform to QName.toString() formatting, an IllegalArgumentException is thrown.

        The String MUST be in the form returned by QName.toString().

        The commonly accepted way of representing a QName as a String was defined by James Clark. Although this is not a standard specification, it is in common use, e.g. Transformer.setParameter(String name, Object value). This implementation parses a String formatted as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(XMLConstants.NULL_NS_URI), only the local part should be provided.

        The prefix value CANNOT be represented in the String and will be set to XMLConstants.DEFAULT_NS_PREFIX.

        This method does not do full validation of the resulting QName.

        The Namespace URI is not validated as a URI reference. The local part is not validated as a NCName as specified in Namespaces in XML.

        参数：
        qNameAsString - String representation of the QName
        返回：
        QName corresponding to the given String
        抛出：
        IllegalArgumentException - When qNameAsString is null or malformed
        另请参见：
        QName.toString()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pt>I}.yP


Uses of Package javax.xml.namespace

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.namespace

  • Packages that use javax.xml.namespace
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.datatype
    XML/Java Type Mappings.
    javax.xml.namespace
    XML Namespace processing.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
  • Classes in javax.xml.namespace used by javax.xml.bind
    类与描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.datatype
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.namespace
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.soap
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream
    类与描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream.events
    类与描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.stream.util
    类与描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.handler
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.handler.soap
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.spi
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.ws.wsaddressing
    类与描述
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • Classes in javax.xml.namespace used by javax.xml.xpath
    类与描述
    NamespaceContext
    Interface for read only XML Namespace context processing.
    QName
    QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> >fudu/av>l.s.//mou


Uses of Class javax.xml.namespace.QName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.namespace.QName

  • Packages that use QName
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.datatype
    XML/Java Type Mappings.
    javax.xml.namespace
    XML Namespace processing.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of QName in javax.xml.bind

      Fields in javax.xml.bind declared as QName
      修饰符与类型 字段与描述
      protected QName JAXBElement.name
      xml element tag name
      Methods in javax.xml.bind that return QName
      修饰符与类型 方法与描述
      abstract QName JAXBIntrospector.getElementName(Object jaxbElement)
      Get xml element qname for jaxbElement.
      QName JAXBElement.getName()
      Returns the xml element tag name.
      QName DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      static QName DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      Methods in javax.xml.bind with parameters of type QName
      修饰符与类型 方法与描述
      String DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String DatatypeConverter.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      Constructors in javax.xml.bind with parameters of type QName
      构造方法与描述
      JAXBElement(QName name, 类<T> declaredType, 类 scope, T value)
      Construct an xml element instance.
      JAXBElement(QName name, 类<T> declaredType, T value)
      Construct an xml element instance.

    • Uses of QName in javax.xml.datatype

      Fields in javax.xml.datatype declared as QName
      修饰符与类型 字段与描述
      static QName DatatypeConstants.DATE
      Fully qualified name for W3C XML Schema 1.0 datatype date.
      static QName DatatypeConstants.DATETIME
      Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
      static QName DatatypeConstants.DURATION
      Fully qualified name for W3C XML Schema datatype duration.
      static QName DatatypeConstants.DURATION_DAYTIME
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
      static QName DatatypeConstants.DURATION_YEARMONTH
      Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
      static QName DatatypeConstants.GDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gDay.
      static QName DatatypeConstants.GMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gMonth.
      static QName DatatypeConstants.GMONTHDAY
      Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.
      static QName DatatypeConstants.GYEAR
      Fully qualified name for W3C XML Schema 1.0 datatype gYear.
      static QName DatatypeConstants.GYEARMONTH
      Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.
      static QName DatatypeConstants.TIME
      Fully qualified name for W3C XML Schema 1.0 datatype time.
      Methods in javax.xml.datatype that return QName
      修饰符与类型 方法与描述
      abstract QName XMLGregorianCalendar.getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.
      QName Duration.getXMLSchemaType()
      Return the name of the XML Schema date/time type that this instance maps to.

    • Uses of QName in javax.xml.namespace

      Methods in javax.xml.namespace that return QName
      修饰符与类型 方法与描述
      static QName QName.valueOf(String qNameAsString)
      QName derived from parsing the formatted String.

    • Uses of QName in javax.xml.soap

      Fields in javax.xml.soap declared as QName
      修饰符与类型 字段与描述
      static QName SOAPConstants.SOAP_DATAENCODINGUNKNOWN_FAULT
      SOAP 1.2 DataEncodingUnknown Fault
      static QName SOAPConstants.SOAP_MUSTUNDERSTAND_FAULT
      SOAP 1.2 MustUnderstand Fault
      static QName SOAPConstants.SOAP_RECEIVER_FAULT
      SOAP 1.2 Receiver Fault
      static QName SOAPConstants.SOAP_SENDER_FAULT
      SOAP 1.2 Sender Fault
      static QName SOAPConstants.SOAP_VERSIONMISMATCH_FAULT
      SOAP 1.2 VersionMismatch Fault
      Methods in javax.xml.soap that return QName
      修饰符与类型 方法与描述
      QName SOAPElement.createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      QName SOAPElement.getElementQName()
      Returns the qname of this SOAPElement object.
      QName SOAPFault.getFaultCodeAsQName()
      Gets the fault code for this SOAPFault object as a QName object.
      Methods in javax.xml.soap with parameters of type QName
      修饰符与类型 方法与描述
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      void SOAPFault.appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      String SOAPElement.getAttributeValue(QName qname)
      Returns the value of the attribute with the specified qname.
      Iterator SOAPElement.getChildElements(QName qname)
      Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
      boolean SOAPElement.removeAttribute(QName qname)
      Removes the attribute with the specified qname.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void SOAPFault.setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.

    • Uses of QName in javax.xml.stream

      Methods in javax.xml.stream that return QName
      修饰符与类型 方法与描述
      QName XMLStreamReader.getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      QName XMLStreamReader.getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      Methods in javax.xml.stream with parameters of type QName
      修饰符与类型 方法与描述
      abstract Attribute XMLEventFactory.createAttribute(QName name, String value)
      Create a new Attribute
      abstract EndElement XMLEventFactory.createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract StartElement XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.

    • Uses of QName in javax.xml.stream.events

      Methods in javax.xml.stream.events that return QName
      修饰符与类型 方法与描述
      QName StartElement.getName()
      Get the name of this event
      QName EndElement.getName()
      Get the name of this event
      QName Attribute.getName()
      Returns the QName for this attribute
      QName XMLEvent.getSchemaType()
      This method is provided for implementations to provide optional type information about the associated event.
      Methods in javax.xml.stream.events with parameters of type QName
      修饰符与类型 方法与描述
      Attribute StartElement.getAttributeByName(QName name)
      Returns the attribute referred to by this name

    • Uses of QName in javax.xml.stream.util

      Methods in javax.xml.stream.util that return QName
      修饰符与类型 | 方法与描述
      QName | StreamReaderDelegate.getAttributeName(int index)
      QName | StreamReaderDelegate.getName()

    • Uses of QName in javax.xml.ws

      Methods in javax.xml.ws that return QName
      修饰符与类型 方法与描述
      QName Service.getServiceName()
      Gets the name of this service.
      Methods in javax.xml.ws that return types with arguments of type QName
      修饰符与类型 方法与描述
      Iterator<QName> Service.getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      Methods in javax.xml.ws with parameters of type QName
      修饰符与类型 方法与描述
      void Service.addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      static Service Service.create(QName serviceName)
      Creates a Service instance.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(QName portName, 类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T Service.getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Constructors in javax.xml.ws with parameters of type QName
      构造方法与描述
      Service(URL wsdlDocumentLocation, QName serviceName)
      Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Uses of QName in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return QName
      修饰符与类型 方法与描述
      QName PortInfo.getPortName()
      Gets the qualified name of the WSDL port being accessed.
      QName PortInfo.getServiceName()
      Gets the qualified name of the WSDL service name containing the port being accessed.

    • Uses of QName in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return types with arguments of type QName
      修饰符与类型 方法与描述
      Set<QName> SOAPHandler.getHeaders()
      Gets the header blocks that can be processed by this Handler instance.
      Methods in javax.xml.ws.handler.soap with parameters of type QName
      修饰符与类型 方法与描述
      Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.

    • Uses of QName in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return QName
      修饰符与类型 方法与描述
      abstract QName ServiceDelegate.getServiceName()
      Gets the name of this service.
      Methods in javax.xml.ws.spi that return types with arguments of type QName
      修饰符与类型 方法与描述
      abstract Iterator<QName> ServiceDelegate.getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      Methods in javax.xml.ws.spi with parameters of type QName
      修饰符与类型 方法与描述
      abstract void ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      abstract <T> T ServiceDelegate.getPort(QName portName, 类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Method parameters in javax.xml.ws.spi with type arguments of type QName
      修饰符与类型 方法与描述
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of QName in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type QName
      修饰符与类型 方法与描述
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.

    • Uses of QName in javax.xml.xpath

      Fields in javax.xml.xpath declared as QName
      修饰符与类型 字段与描述
      static QName XPathConstants.BOOLEAN
      The XPath 1.0 boolean data type.
      static QName XPathConstants.NODE
      The XPath 1.0 NodeSet data type.
      static QName XPathConstants.NODESET
      The XPath 1.0 NodeSet data type.
      static QName XPathConstants.NUMBER
      The XPath 1.0 number data type.
      static QName XPathConstants.STRING
      The XPath 1.0 string data type.
      Methods in javax.xml.xpath with parameters of type QName
      修饰符与类型 方法与描述
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      Object XPathExpression.evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      Object XPath.evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
      XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.
      Object XPathVariableResolver.resolveVariable(QName variableName)
      Find a variable in the set of available variables.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.xml.namespace.NamespaceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.namespace.NamespaceContext

  • Packages that use NamespaceContext
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of NamespaceContext in javax.xml.bind

      Methods in javax.xml.bind with parameters of type NamespaceContext
      修饰符与类型 方法与描述
      QName DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a QName value.
      static QName DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
      Converts the string argument into a byte value.
      String DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.
      static String DatatypeConverter.printQName(QName val, NamespaceContext nsc)
      Converts a QName instance into a string.

    • Uses of NamespaceContext in javax.xml.stream

      Methods in javax.xml.stream that return NamespaceContext
      修饰符与类型 方法与描述
      NamespaceContext XMLStreamWriter.getNamespaceContext()
      Returns the current namespace context.
      NamespaceContext XMLStreamReader.getNamespaceContext()
      Returns a read only namespace context for the current position.
      NamespaceContext XMLEventWriter.getNamespaceContext()
      Returns the current namespace context.
      Methods in javax.xml.stream with parameters of type NamespaceContext
      修饰符与类型 方法与描述
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.
      void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLEventWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.

    • Uses of NamespaceContext in javax.xml.stream.events

      Methods in javax.xml.stream.events that return NamespaceContext
      修饰符与类型 方法与描述
      NamespaceContext StartElement.getNamespaceContext()
      Gets a read-only namespace context.

    • Uses of NamespaceContext in javax.xml.stream.util

      Methods in javax.xml.stream.util that return NamespaceContext
      修饰符与类型 | 方法与描述
      NamespaceContext | StreamReaderDelegate.getNamespaceContext()

    • Uses of NamespaceContext in javax.xml.xpath

      Methods in javax.xml.xpath that return NamespaceContext
      修饰符与类型 方法与描述
      NamespaceContext XPath.getNamespaceContext()
      Return the current namespace context.
      Methods in javax.xml.xpath with parameters of type NamespaceContext
      修饰符与类型 方法与描述
      void XPath.setNamespaceContext(NamespaceContext nsContext)
      Establish a namespace context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ra=!ivv i<<纓w>e


DocumentBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.parsers

类 DocumentBuilder

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilder

  • public abstract class DocumentBuilder
extends Object
    Defines the API to obtain DOM Document instances from an XML document. Using this class, an application programmer can obtain a Document from XML.

    An instance of this class can be obtained from the DocumentBuilderFactory.newDocumentBuilder() method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

    Note that this class reuses several classes from the SAX API. This does not require that the implementor of the underlying DOM implementation use a SAX parser to parse XML document into a Document. It merely requires that the implementation communicate with the application using these existing APIs.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DocumentBuilder()
      Protected constructor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract DOMImplementation getDOMImplementation()
      Obtain an instance of a DOMImplementation object.
      Schema getSchema()
      Get a reference to the the Schema being used by the XML processor.
      abstract boolean isNamespaceAware()
      Indicates whether or not this parser is configured to understand namespaces.
      abstract boolean isValidating()
      Indicates whether or not this parser is configured to validate XML documents.
      boolean isXIncludeAware()
      Get the XInclude processing mode for this parser.
      abstract Document newDocument()
      Obtain a new instance of a DOM Document object to build a DOM tree with.
      Document parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      abstract Document parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      Document parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.
      void reset()
      Reset this DocumentBuilder to its original configuration.
      abstract void setEntityResolver(EntityResolver er)
      Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.
      abstract void setErrorHandler(ErrorHandler eh)
      Specify the ErrorHandler to be used by the parser.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocumentBuilder

        protected DocumentBuilder()
        Protected constructor

    • 方法详细信息

      • reset

        public void reset()

        Reset this DocumentBuilder to its original configuration.

        DocumentBuilder is reset to the same state as when it was created with DocumentBuilderFactory.newDocumentBuilder(). reset() is designed to allow the reuse of existing DocumentBuilders thus saving resources associated with the creation of new DocumentBuilders.

        The reset DocumentBuilder is not guaranteed to have the same EntityResolver or ErrorHandler Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal EntityResolver and ErrorHandler.

        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5

      • parse

        public Document parse(InputStream is)
               throws SAXException,
                      IOException
        Parse the content of the given InputStream as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputStream is null.
        参数：
        is - InputStream containing the content to be parsed.
        返回：
        Document result of parsing the InputStream
        抛出：
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        另请参见：
        DocumentHandler

      • parse

        public Document parse(InputStream is,
             String systemId)
               throws SAXException,
                      IOException
        Parse the content of the given InputStream as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputStream is null.
        参数：
        is - InputStream containing the content to be parsed.
        systemId - Provide a base for resolving relative URIs.
        返回：
        A new DOM Document object.
        抛出：
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        另请参见：
        DocumentHandler

      • parse

        public Document parse(String uri)
               throws SAXException,
                      IOException
        Parse the content of the given URI as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the URI is null null.
        参数：
        uri - The location of the content to be parsed.
        返回：
        A new DOM Document object.
        抛出：
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When uri is null
        另请参见：
        DocumentHandler

      • parse

        public Document parse(File f)
               throws SAXException,
                      IOException
        Parse the content of the given file as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the File is null null.
        参数：
        f - The file containing the XML to parse.
        返回：
        A new DOM Document object.
        抛出：
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When f is null
        另请参见：
        DocumentHandler

      • parse

        public abstract Document parse(InputSource is)
                        throws SAXException,
                               IOException
        Parse the content of the given input source as an XML document and return a new DOM Document object. An IllegalArgumentException is thrown if the InputSource is null null.
        参数：
        is - InputSource containing the content to be parsed.
        返回：
        A new DOM Document object.
        抛出：
        IOException - If any IO errors occur.
        SAXException - If any parse errors occur.
        IllegalArgumentException - When is is null
        另请参见：
        DocumentHandler

      • isNamespaceAware

        public abstract boolean isNamespaceAware()
        Indicates whether or not this parser is configured to understand namespaces.
        返回：
        true if this parser is configured to understand namespaces; false otherwise.

      • isValidating

        public abstract boolean isValidating()
        Indicates whether or not this parser is configured to validate XML documents.
        返回：
        true if this parser is configured to validate XML documents; false otherwise.

      • setEntityResolver

        public abstract void setEntityResolver(EntityResolver er)
        Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.
        参数：
        er - The EntityResolver to be used to resolve entities present in the XML document to be parsed.

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler eh)
        Specify the ErrorHandler to be used by the parser. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.
        参数：
        eh - The ErrorHandler to be used by the parser.

      • newDocument

        public abstract Document newDocument()
        Obtain a new instance of a DOM Document object to build a DOM tree with.
        返回：
        A new instance of a DOM Document object.

      • getDOMImplementation

        public abstract DOMImplementation getDOMImplementation()
        Obtain an instance of a DOMImplementation object.
        返回：
        A new instance of a DOMImplementation.

      • getSchema

        public Schema getSchema()

        Get a reference to the the Schema being used by the XML processor.

        If no schema is being used, null is returned.

        返回：
        Schema being used or null if none in use
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get the XInclude processing mode for this parser.

        返回：
        the return value of the DocumentBuilderFactory.isXIncludeAware() when this parser was created from factory.
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5
        另请参见：
        DocumentBuilderFactory.setXIncludeAware(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DocumentBuilderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.parsers

类 DocumentBuilderFactory

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilderFactory

  • public abstract class DocumentBuilderFactory
extends Object
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DocumentBuilderFactory()
      Protected constructor to prevent instantiation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Object getAttribute(String name)
      Allows the user to retrieve specific attributes on the underlying implementation.
      abstract boolean getFeature(String name)
      Get the state of the named feature.
      Schema getSchema()
      Gets the Schema object specified through the setSchema(Schema schema) method.
      boolean isCoalescing()
      Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
      boolean isExpandEntityReferences()
      Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
      boolean isIgnoringComments()
      Indicates whether or not the factory is configured to produce parsers which ignores comments.
      boolean isIgnoringElementContentWhitespace()
      Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
      boolean isNamespaceAware()
      Indicates whether or not the factory is configured to produce parsers which are namespace aware.
      boolean isValidating()
      Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
      boolean isXIncludeAware()
      Get state of XInclude processing.
      abstract DocumentBuilder newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
      static DocumentBuilderFactory newInstance()
      Obtain a new instance of a DocumentBuilderFactory.
      static DocumentBuilderFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DocumentBuilderFactory from class name.
      abstract void setAttribute(String name, Object value)
      Allows the user to set specific attributes on the underlying implementation.
      void setCoalescing(boolean coalescing)
      Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node.
      void setExpandEntityReferences(boolean expandEntityRef)
      Specifies that the parser produced by this code will expand entity reference nodes.
      abstract void setFeature(String name, boolean value)
      Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.
      void setIgnoringComments(boolean ignoreComments)
      Specifies that the parser produced by this code will ignore comments.
      void setIgnoringElementContentWhitespace(boolean whitespace)
      Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10).
      void setNamespaceAware(boolean awareness)
      Specifies that the parser produced by this code will provide support for XML namespaces.
      void setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void setValidating(boolean validating)
      Specifies that the parser produced by this code will validate documents as they are parsed.
      void setXIncludeAware(boolean state)
      Set state of XInclude processing.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DocumentBuilderFactory

        protected DocumentBuilderFactory()

        Protected constructor to prevent instantiation. Use newInstance().

    • 方法详细信息

      • newInstance

        public static DocumentBuilderFactory newInstance()
        Obtain a new instance of a DocumentBuilderFactory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the DocumentBuilderFactory implementation class to load:
        • Use the javax.xml.parsers.DocumentBuilderFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.parsers.DocumentBuilderFactory in jars available to the runtime.
        • Platform default DocumentBuilderFactory instance.
        Once an application has obtained a reference to a DocumentBuilderFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems loading DocumentBuilders, try:

         java -Djaxp.debug=1 YourProgram ....
        返回：
        New instance of a DocumentBuilderFactory
        抛出：
        FactoryConfigurationError - if the implementation is not available or cannot be instantiated.

      • newInstance

        public static DocumentBuilderFactory newInstance(String factoryClassName,
                                 ClassLoader classLoader)

        Obtain a new instance of a DocumentBuilderFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a DocumentBuilderFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.parsers.DocumentBuilderFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a DocumentBuilderFactory
        抛出：
        FactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        从以下版本开始：
        1.6
        另请参见：
        newInstance()

      • newDocumentBuilder

        public abstract DocumentBuilder newDocumentBuilder()
                                            throws ParserConfigurationException
        Creates a new instance of a DocumentBuilder using the currently configured parameters.
        返回：
        A new instance of a DocumentBuilder.
        抛出：
        ParserConfigurationException - if a DocumentBuilder cannot be created which satisfies the configuration requested.

      • setNamespaceAware

        public void setNamespaceAware(boolean awareness)
        Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false
        参数：
        awareness - true if the parser produced will provide support for XML namespaces; false otherwise.

      • setValidating

        public void setValidating(boolean validating)
        Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

        Note that "the validation" here means a validating parser as defined in the XML recommendation. In other words, it essentially just controls the DTD validation. (except the legacy two properties defined in JAXP 1.2.)

        To use modern schema languages such as W3C XML Schema or RELAX NG instead of DTD, you can configure your parser to be a non-validating parser by leaving the setValidating(boolean) method false, then use the setSchema(Schema) method to associate a schema to a parser.

        参数：
        validating - true if the parser produced will validate documents as they are parsed; false otherwise.

      • setIgnoringElementContentWhitespace

        public void setIgnoringElementContentWhitespace(boolean whitespace)
        Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10). Note that only whitespace which is directly contained within element content that has an element only content model (see XML Rec 3.2.1) will be eliminated. Due to reliance on the content model this setting requires the parser to be in validating mode. By default the value of this is set to false.
        参数：
        whitespace - true if the parser created must eliminate whitespace in the element content when parsing XML documents; false otherwise.

      • setExpandEntityReferences

        public void setExpandEntityReferences(boolean expandEntityRef)
        Specifies that the parser produced by this code will expand entity reference nodes. By default the value of this is set to true
        参数：
        expandEntityRef - true if the parser produced will expand entity reference nodes; false otherwise.

      • setIgnoringComments

        public void setIgnoringComments(boolean ignoreComments)

        Specifies that the parser produced by this code will ignore comments. By default the value of this is set to false .

        参数：
        ignoreComments - boolean value to ignore comments during processing

      • setCoalescing

        public void setCoalescing(boolean coalescing)
        Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node. By default the value of this is set to false
        参数：
        coalescing - true if the parser produced will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node; false otherwise.

      • isNamespaceAware

        public boolean isNamespaceAware()
        Indicates whether or not the factory is configured to produce parsers which are namespace aware.
        返回：
        true if the factory is configured to produce parsers which are namespace aware; false otherwise.

      • isValidating

        public boolean isValidating()
        Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
        返回：
        true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

      • isIgnoringElementContentWhitespace

        public boolean isIgnoringElementContentWhitespace()
        Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
        返回：
        true if the factory is configured to produce parsers which ignore ignorable whitespace in element content; false otherwise.

      • isExpandEntityReferences

        public boolean isExpandEntityReferences()
        Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
        返回：
        true if the factory is configured to produce parsers which expand entity reference nodes; false otherwise.

      • isIgnoringComments

        public boolean isIgnoringComments()
        Indicates whether or not the factory is configured to produce parsers which ignores comments.
        返回：
        true if the factory is configured to produce parsers which ignores comments; false otherwise.

      • isCoalescing

        public boolean isCoalescing()
        Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
        返回：
        true if the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node; false otherwise.

      • setAttribute

        public abstract void setAttribute(String name,
                Object value)
                           throws IllegalArgumentException
        Allows the user to set specific attributes on the underlying implementation.
        参数：
        name - The name of the attribute.
        value - The value of the attribute.
        抛出：
        IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

      • getAttribute

        public abstract Object getAttribute(String name)
                             throws IllegalArgumentException
        Allows the user to retrieve specific attributes on the underlying implementation.
        参数：
        name - The name of the attribute.
        返回：
        value The value of the attribute.
        抛出：
        IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

      • setFeature

        public abstract void setFeature(String name,
              boolean value)
                         throws ParserConfigurationException

        Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. A ParserConfigurationException is thrown if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support the feature. It is possible for a DocumentBuilderFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See DocumentBuilder.setErrorHandler(org.xml.sax.ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        参数：
        name - Feature name.
        value - Is feature state true or false.
        抛出：
        ParserConfigurationException - if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support this feature.
        NullPointerException - If the name parameter is null.

      • getFeature

        public abstract boolean getFeature(String name)
                            throws ParserConfigurationException

        Get the state of the named feature.

        Feature names are fully qualified URIs. Implementations may define their own features. An ParserConfigurationException is thrown if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support the feature. It is possible for an DocumentBuilderFactory to expose a feature value but be unable to change its state.

        参数：
        name - Feature name.
        返回：
        State of the named feature.
        抛出：
        ParserConfigurationException - if this DocumentBuilderFactory or the DocumentBuilders it creates cannot support this feature.

      • getSchema

        public Schema getSchema()
        Gets the Schema object specified through the setSchema(Schema schema) method.
        返回：
        the Schema object that was last set through the setSchema(Schema) method, or null if the method was not invoked since a DocumentBuilderFactory is created.
        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5

      • setSchema

        public void setSchema(Schema schema)

        Set the Schema to be used by parsers created from this factory.

        When a Schema is non-null, a parser will use a validator created from it to validate documents before it passes information down to the application.

        When errors are found by the validator, the parser is responsible to report them to the user-specified ErrorHandler (or if the error handler is not set, ignore them or throw them), just like any other errors found by the parser itself. In other words, if the user-specified ErrorHandler is set, it must receive those errors, and if not, they must be treated according to the implementation specific default error handling rules.

        A validator may modify the outcome of a parse (for example by adding default values that were missing in documents), and a parser is responsible to make sure that the application will receive modified DOM trees.

        Initialy, null is set as the Schema.

        This processing will take effect even if the isValidating() method returns false.

        It is an error to use the http://java.sun.com/xml/jaxp/properties/schemaSource property and/or the http://java.sun.com/xml/jaxp/properties/schemaLanguage property in conjunction with a Schema object. Such configuration will cause a ParserConfigurationException exception when the newDocumentBuilder() is invoked.

        Note for implmentors

        A parser must be able to work with any Schema implementation. However, parsers and schemas are allowed to use implementation-specific custom mechanisms as long as they yield the result described in the specification.

        参数：
        schema - Schema to use or null to remove a schema.
        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5

      • setXIncludeAware

        public void setXIncludeAware(boolean state)

        Set state of XInclude processing.

        If XInclude markup is found in the document instance, should it be processed as specified in XML Inclusions (XInclude) Version 1.0.

        XInclude processing defaults to false.

        参数：
        state - Set XInclude processing to true or false
        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get state of XInclude processing.

        返回：
        current state of XInclude processing
        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.parsers

类 FactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.parsers.FactoryConfigurationError
  • 所有已实现的接口：
    Serializable

    public class FactoryConfigurationError
extends Error
    Thrown when a problem with configuration with the Parser Factories exists. This error will typically be thrown when the class of a parser factory specified in the system properties cannot be found or instantiated.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      FactoryConfigurationError()
      Create a new FactoryConfigurationError with no detail mesage.
      FactoryConfigurationError(Exception e)
      Create a new FactoryConfigurationError with a given Exception base cause of the error.
      FactoryConfigurationError(Exception e, String msg)
      Create a new FactoryConfigurationError with the given Exception base cause and detail message.
      FactoryConfigurationError(String msg)
      Create a new FactoryConfigurationError with the String specified as an error message.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the actual exception (if any) that caused this exception to be raised.
      String getMessage()
      Return the message (if any) for this error .

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FactoryConfigurationError

        public FactoryConfigurationError()
        Create a new FactoryConfigurationError with no detail mesage.

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg)
        Create a new FactoryConfigurationError with the String specified as an error message.
        参数：
        msg - The error message for the exception.

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e)
        Create a new FactoryConfigurationError with a given Exception base cause of the error.
        参数：
        e - The exception to be encapsulated in a FactoryConfigurationError.

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e,
                         String msg)
        Create a new FactoryConfigurationError with the given Exception base cause and detail message.
        参数：
        e - The exception to be encapsulated in a FactoryConfigurationError
        msg - The detail message.

    • 方法详细信息

      • getMessage

        public String getMessage()
        Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception, if it exists will be returned. Else the name of the encapsulated exception will be returned.
        重载：
        getMessage in class Throwable
        返回：
        The error message.

      • getException

        public Exception getException()
        Return the actual exception (if any) that caused this exception to be raised.
        返回：
        The encapsulated exception, or null if there is none.

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ptaj./"./"=.."== &uu<>a/lccl ucbll < nk


javax.xml.parsers

Classes

  • DocumentBuilder
  • DocumentBuilderFactory
  • SAXParser
  • SAXParserFactory

Exceptions

  • ParserConfigurationException

Errors

  • FactoryConfigurationError
i


javax.xml.parsers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.parsers

Provides classes allowing the processing of XML documents.

请参见： 描述

  • Class Summary
    类 描述
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
  • Exception Summary
    Exception 描述
    ParserConfigurationException
    Indicates a serious configuration error.
  • Error Summary
    Error 描述
    FactoryConfigurationError
    Thrown when a problem with configuration with the Parser Factories exists.

软件包 javax.xml.parsers Description

Provides classes allowing the processing of XML documents. Two types of plugable parsers are supported:

  • SAX (Simple API for XML)
  • DOM (Document Object Model)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

au/...jm/.//.r<


javax.xml.parsers Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.parsers

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.parsers.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.parsers.ParserConfigurationException
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<蜒裮-..a筫eet


ParserConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.parsers

类 ParserConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.parsers.ParserConfigurationException
  • 所有已实现的接口：
    Serializable

    public class ParserConfigurationException
extends Exception
    Indicates a serious configuration error.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParserConfigurationException()
      Create a new ParserConfigurationException with no detail mesage.
      ParserConfigurationException(String msg)
      Create a new ParserConfigurationException with the String specified as an error message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ParserConfigurationException

        public ParserConfigurationException()
        Create a new ParserConfigurationException with no detail mesage.

      • ParserConfigurationException

        public ParserConfigurationException(String msg)
        Create a new ParserConfigurationException with the String specified as an error message.
        参数：
        msg - The error message for the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=t/rlmalre m>rnen>eerofiiEr n<


SAXParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.parsers

类 SAXParser

  • java.lang.Object
    • javax.xml.parsers.SAXParser

  • public abstract class SAXParser
extends Object
    Defines the API that wraps an XMLReader implementation class. In JAXP 1.0, this class wrapped the Parser interface, however this interface was replaced by the XMLReader. For ease of transition, this class continues to support the same name and interface as well as supporting new methods. An instance of this class can be obtained from the SAXParserFactory.newSAXParser() method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

    This static method creates a new factory instance based on a system property setting or uses the platform default if no property has been defined.

    The system property that controls which Factory implementation to create is named "javax.xml.parsers.SAXParserFactory". This property names a class that is a concrete subclass of this abstract class. If no property is defined, a platform default will be used.

    As the content is parsed by the underlying parser, methods of the given HandlerBase or the DefaultHandler are called.

    Implementors of this class which wrap an underlaying implementation can consider using the ParserAdapter class to initially adapt their SAX1 implementation to work under this revised class.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SAXParser()
      Protected constructor to prevent instaniation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Parser getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.
      abstract Object getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      Schema getSchema()
      Get a reference to the the Schema being used by the XML processor.
      abstract XMLReader getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.
      abstract boolean isNamespaceAware()
      Indicates whether or not this parser is configured to understand namespaces.
      abstract boolean isValidating()
      Indicates whether or not this parser is configured to validate XML documents.
      boolean isXIncludeAware()
      Get the XInclude processing mode for this parser.
      void parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      void parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      void parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
      void parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
      void reset()
      Reset this SAXParser to its original configuration.
      abstract void setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SAXParser

        protected SAXParser()

        Protected constructor to prevent instaniation. Use SAXParserFactory.newSAXParser().

    • 方法详细信息

      • reset

        public void reset()

        Reset this SAXParser to its original configuration.

        SAXParser is reset to the same state as when it was created with SAXParserFactory.newSAXParser(). reset() is designed to allow the reuse of existing SAXParsers thus saving resources associated with the creation of new SAXParsers.

        The reset SAXParser is not guaranteed to have the same Schema Object, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal Schema.

        抛出：
        UnsupportedOperationException - When Implementations do not override this method
        从以下版本开始：
        1.5

      • parse

        public void parse(InputStream is,
         HandlerBase hb)
           throws SAXException,
                  IOException

        Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0.

        参数：
        is - InputStream containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        抛出：
        IllegalArgumentException - If the given InputStream is null.
        SAXException - If parse produces a SAX error.
        IOException - If an IO error occurs interacting with the InputStream.
        另请参见：
        DocumentHandler

      • parse

        public void parse(InputStream is,
         HandlerBase hb,
         String systemId)
           throws SAXException,
                  IOException

        Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0.

        参数：
        is - InputStream containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        systemId - The systemId which is needed for resolving relative URIs.
        抛出：
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO error occurs interacting with the InputStream.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        version of this method instead.

      • parse

        public void parse(InputStream is,
         DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
        参数：
        is - InputStream containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        抛出：
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(InputStream is,
         DefaultHandler dh,
         String systemId)
           throws SAXException,
                  IOException
        Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
        参数：
        is - InputStream containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        systemId - The systemId which is needed for resolving relative URIs.
        抛出：
        IllegalArgumentException - If the given InputStream is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        version of this method instead.

      • parse

        public void parse(String uri,
         HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        参数：
        uri - The location of the content to be parsed.
        hb - The SAX HandlerBase to use.
        抛出：
        IllegalArgumentException - If the uri is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(String uri,
         DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
        参数：
        uri - The location of the content to be parsed.
        dh - The SAX DefaultHandler to use.
        抛出：
        IllegalArgumentException - If the uri is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(File f,
         HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content of the file specified as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        参数：
        f - The file containing the XML to parse
        hb - The SAX HandlerBase to use.
        抛出：
        IllegalArgumentException - If the File object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(File f,
         DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content of the file specified as XML using the specified DefaultHandler.
        参数：
        f - The file containing the XML to parse
        dh - The SAX DefaultHandler to use.
        抛出：
        IllegalArgumentException - If the File object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(InputSource is,
         HandlerBase hb)
           throws SAXException,
                  IOException
        Parse the content given InputSource as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0
        参数：
        is - The InputSource containing the content to be parsed.
        hb - The SAX HandlerBase to use.
        抛出：
        IllegalArgumentException - If the InputSource object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • parse

        public void parse(InputSource is,
         DefaultHandler dh)
           throws SAXException,
                  IOException
        Parse the content given InputSource as XML using the specified DefaultHandler.
        参数：
        is - The InputSource containing the content to be parsed.
        dh - The SAX DefaultHandler to use.
        抛出：
        IllegalArgumentException - If the InputSource object is null.
        IOException - If any IO errors occur.
        SAXException - If any SAX errors occur during processing.
        另请参见：
        DocumentHandler

      • getParser

        public abstract Parser getParser()
                          throws SAXException
        Returns the SAX parser that is encapsultated by the implementation of this class.
        返回：
        The SAX parser that is encapsultated by the implementation of this class.
        抛出：
        SAXException - If any SAX errors occur during processing.

      • getXMLReader

        public abstract XMLReader getXMLReader()
                                throws SAXException
        Returns the XMLReader that is encapsulated by the implementation of this class.
        返回：
        The XMLReader that is encapsulated by the implementation of this class.
        抛出：
        SAXException - If any SAX errors occur during processing.

      • isNamespaceAware

        public abstract boolean isNamespaceAware()
        Indicates whether or not this parser is configured to understand namespaces.
        返回：
        true if this parser is configured to understand namespaces; false otherwise.

      • isValidating

        public abstract boolean isValidating()
        Indicates whether or not this parser is configured to validate XML documents.
        返回：
        true if this parser is configured to validate XML documents; false otherwise.

      • setProperty

        public abstract void setProperty(String name,
               Object value)
                          throws SAXNotRecognizedException,
                                 SAXNotSupportedException

        Sets the particular property in the underlying implementation of XMLReader. A list of the core features and properties can be found at http://sax.sourceforge.net/?selected=get-set.

        参数：
        name - The name of the property to be set.
        value - The value of the property to be set.
        抛出：
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        另请参见：
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • getProperty

        public abstract Object getProperty(String name)
                            throws SAXNotRecognizedException,
                                   SAXNotSupportedException

        Returns the particular property requested for in the underlying implementation of XMLReader.

        参数：
        name - The name of the property to be retrieved.
        返回：
        Value of the requested property.
        抛出：
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        另请参见：
        XMLReader.getProperty(java.lang.String)

      • getSchema

        public Schema getSchema()

        Get a reference to the the Schema being used by the XML processor.

        If no schema is being used, null is returned.

        返回：
        Schema being used or null if none in use
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get the XInclude processing mode for this parser.

        返回：
        the return value of the SAXParserFactory.isXIncludeAware() when this parser was created from factory.
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5
        另请参见：
        SAXParserFactory.setXIncludeAware(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SAXParserFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.parsers

类 SAXParserFactory

  • java.lang.Object
    • javax.xml.parsers.SAXParserFactory

  • public abstract class SAXParserFactory
extends Object
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SAXParserFactory()
      Protected constructor to force use of newInstance().

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      Schema getSchema()
      Gets the Schema object specified through the setSchema(Schema schema) method.
      boolean isNamespaceAware()
      Indicates whether or not the factory is configured to produce parsers which are namespace aware.
      boolean isValidating()
      Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
      boolean isXIncludeAware()
      Get state of XInclude processing.
      static SAXParserFactory newInstance()
      Obtain a new instance of a SAXParserFactory.
      static SAXParserFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SAXParserFactory from class name.
      abstract SAXParser newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      abstract void setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      void setNamespaceAware(boolean awareness)
      Specifies that the parser produced by this code will provide support for XML namespaces.
      void setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void setValidating(boolean validating)
      Specifies that the parser produced by this code will validate documents as they are parsed.
      void setXIncludeAware(boolean state)
      Set state of XInclude processing.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SAXParserFactory

        protected SAXParserFactory()

        Protected constructor to force use of newInstance().

    • 方法详细信息

      • newInstance

        public static SAXParserFactory newInstance()
        Obtain a new instance of a SAXParserFactory. This static method creates a new factory instance This method uses the following ordered lookup procedure to determine the SAXParserFactory implementation class to load:
        • Use the javax.xml.parsers.SAXParserFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.parsers.SAXParserFactory in jars available to the runtime.
        • Platform default SAXParserFactory instance.
        Once an application has obtained a reference to a SAXParserFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems loading DocumentBuilders, try:

         java -Djaxp.debug=1 YourProgram ....
        返回：
        A new instance of a SAXParserFactory.
        抛出：
        FactoryConfigurationError - if the implementation is not available or cannot be instantiated.

      • newInstance

        public static SAXParserFactory newInstance(String factoryClassName,
                           ClassLoader classLoader)

        Obtain a new instance of a SAXParserFactory from class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a SAXParserFactory it can use the factory to configure and obtain parser instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems, try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.parsers.SAXParserFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a SAXParserFactory
        抛出：
        FactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        从以下版本开始：
        1.6
        另请参见：
        newInstance()

      • newSAXParser

        public abstract SAXParser newSAXParser()
                                throws ParserConfigurationException,
                                       SAXException

        Creates a new instance of a SAXParser using the currently configured factory parameters.

        返回：
        A new instance of a SAXParser.
        抛出：
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXException - for SAX errors.

      • setNamespaceAware

        public void setNamespaceAware(boolean awareness)
        Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false.
        参数：
        awareness - true if the parser produced by this code will provide support for XML namespaces; false otherwise.

      • setValidating

        public void setValidating(boolean validating)
        Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

        Note that "the validation" here means a validating parser as defined in the XML recommendation. In other words, it essentially just controls the DTD validation. (except the legacy two properties defined in JAXP 1.2.)

        To use modern schema languages such as W3C XML Schema or RELAX NG instead of DTD, you can configure your parser to be a non-validating parser by leaving the setValidating(boolean) method false, then use the setSchema(Schema) method to associate a schema to a parser.

        参数：
        validating - true if the parser produced by this code will validate documents as they are parsed; false otherwise.

      • isNamespaceAware

        public boolean isNamespaceAware()
        Indicates whether or not the factory is configured to produce parsers which are namespace aware.
        返回：
        true if the factory is configured to produce parsers which are namespace aware; false otherwise.

      • isValidating

        public boolean isValidating()
        Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
        返回：
        true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

      • setFeature

        public abstract void setFeature(String name,
              boolean value)
                         throws ParserConfigurationException,
                                SAXNotRecognizedException,
                                SAXNotSupportedException

        Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader. A list of the core features and properties can be found at http://www.saxproject.org/

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See SAXParser parse methods for handler specification.
        • When the feature is false, the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        参数：
        name - The name of the feature to be set.
        value - The value of the feature to be set.
        抛出：
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        NullPointerException - If the name parameter is null.
        另请参见：
        XMLReader.setFeature(java.lang.String, boolean)

      • getFeature

        public abstract boolean getFeature(String name)
                            throws ParserConfigurationException,
                                   SAXNotRecognizedException,
                                   SAXNotSupportedException

        Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.

        参数：
        name - The name of the property to be retrieved.
        返回：
        Value of the requested property.
        抛出：
        ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
        SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
        SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
        另请参见：
        XMLReader.getProperty(java.lang.String)

      • getSchema

        public Schema getSchema()
        Gets the Schema object specified through the setSchema(Schema schema) method.
        返回：
        the Schema object that was last set through the setSchema(Schema) method, or null if the method was not invoked since a SAXParserFactory is created.
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5

      • setSchema

        public void setSchema(Schema schema)

        Set the Schema to be used by parsers created from this factory.

        When a Schema is non-null, a parser will use a validator created from it to validate documents before it passes information down to the application.

        When warnings/errors/fatal errors are found by the validator, the parser must handle them as if those errors were found by the parser itself. In other words, if the user-specified ErrorHandler is set, it must receive those errors, and if not, they must be treated according to the implementation specific default error handling rules.

        A validator may modify the SAX event stream (for example by adding default values that were missing in documents), and a parser is responsible to make sure that the application will receive those modified event stream.

        Initialy, null is set as the Schema.

        This processing will take effect even if the isValidating() method returns false.

        It is an error to use the http://java.sun.com/xml/jaxp/properties/schemaSource property and/or the http://java.sun.com/xml/jaxp/properties/schemaLanguage property in conjunction with a non-null Schema object. Such configuration will cause a SAXException exception when those properties are set on a SAXParser.

        Note for implmentors

        A parser must be able to work with any Schema implementation. However, parsers and schemas are allowed to use implementation-specific custom mechanisms as long as they yield the result described in the specification.

        参数：
        schema - Schema to use, null to remove a schema.
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5

      • setXIncludeAware

        public void setXIncludeAware(boolean state)

        Set state of XInclude processing.

        If XInclude markup is found in the document instance, should it be processed as specified in XML Inclusions (XInclude) Version 1.0.

        XInclude processing defaults to false.

        参数：
        state - Set XInclude processing to true or false
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5

      • isXIncludeAware

        public boolean isXIncludeAware()

        Get state of XInclude processing.

        返回：
        current state of XInclude processing
        抛出：
        UnsupportedOperationException - When implementation does not override this method
        从以下版本开始：
        1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c=kc>


Uses of Package javax.xml.parsers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.parsers

  • Packages that use javax.xml.parsers
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
  • Classes in javax.xml.parsers used by javax.xml.bind.annotation
    类与描述
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
  • Classes in javax.xml.parsers used by javax.xml.parsers
    类与描述
    DocumentBuilder
    Defines the API to obtain DOM Document instances from an XML document.
    DocumentBuilderFactory
    Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
    ParserConfigurationException
    Indicates a serious configuration error.
    SAXParser
    Defines the API that wraps an XMLReader implementation class.
    SAXParserFactory
    Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/=tba>alp"v詃enI


Uses of Class javax.xml.parsers.DocumentBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.DocumentBuilder

  • Packages that use DocumentBuilder
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of DocumentBuilder in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return DocumentBuilder
      修饰符与类型 | 方法与描述
      DocumentBuilder | W3CDomHandler.getBuilder()
      Methods in javax.xml.bind.annotation with parameters of type DocumentBuilder
      修饰符与类型 | 方法与描述
      void | W3CDomHandler.setBuilder(DocumentBuilder builder)
      Constructors in javax.xml.bind.annotation with parameters of type DocumentBuilder
      构造方法与描述
      W3CDomHandler(DocumentBuilder builder)
      Constructor that allows applications to specify which DOM implementation to be used.

    • Uses of DocumentBuilder in javax.xml.parsers

      Methods in javax.xml.parsers that return DocumentBuilder
      修饰符与类型 方法与描述
      abstract DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.parsers.DocumentBuilderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.DocumentBuilderFactory

  • Packages that use DocumentBuilderFactory
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of DocumentBuilderFactory in javax.xml.parsers

      Methods in javax.xml.parsers that return DocumentBuilderFactory
      修饰符与类型 方法与描述
      static DocumentBuilderFactory DocumentBuilderFactory.newInstance()
      Obtain a new instance of a DocumentBuilderFactory.
      static DocumentBuilderFactory DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a DocumentBuilderFactory from class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.<. ong<>ssso/dd>gsasoslr


Uses of Class javax.xml.parsers.FactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.FactoryConfigurationError

No usage of javax.xml.parsers.FactoryConfigurationError
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

IinyFaclidddt///FB/tx


Uses of Class javax.xml.parsers.ParserConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.ParserConfigurationException

  • Packages that use ParserConfigurationException
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of ParserConfigurationException in javax.xml.parsers

      Methods in javax.xml.parsers that throw ParserConfigurationException
      修饰符与类型 方法与描述
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract boolean DocumentBuilderFactory.getFeature(String name)
      Get the state of the named feature.
      abstract DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
      Creates a new instance of a DocumentBuilder using the currently configured parameters.
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void DocumentBuilderFactory.setFeature(String name, boolean value)
      Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpda>s.eec-t oat祅<


Uses of Class javax.xml.parsers.SAXParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.SAXParser

  • Packages that use SAXParser
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of SAXParser in javax.xml.parsers

      Methods in javax.xml.parsers that return SAXParser
      修饰符与类型 方法与描述
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

CBoc> << ///t/..hch>ttpst


Uses of Class javax.xml.parsers.SAXParserFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.parsers.SAXParserFactory

  • Packages that use SAXParserFactory
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of SAXParserFactory in javax.xml.parsers

      Methods in javax.xml.parsers that return SAXParserFactory
      修饰符与类型 方法与描述
      static SAXParserFactory SAXParserFactory.newInstance()
      Obtain a new instance of a SAXParserFactory.
      static SAXParserFactory SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SAXParserFactory from class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne>< o-.e-- "fvnep ark�.n


AttachmentPart

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 AttachmentPart

  • java.lang.Object
    • javax.xml.soap.AttachmentPart

  • public abstract class AttachmentPart
extends Object
    A single attachment to a SOAPMessage object. A SOAPMessage object may contain zero, one, or many AttachmentPart objects. Each AttachmentPart object consists of two parts, application-specific content and associated MIME headers. The MIME headers consists of name/value pairs that can be used to identify and describe the content.

    An AttachmentPart object must conform to certain standards.

    1. It must conform to MIME [RFC2045] standards
    2. It MUST contain content
    3. The header portion MUST include the following header:
      • Content-Type
        This header identifies the type of data in the content of an AttachmentPart object and MUST conform to [RFC2045]. The following is an example of a Content-Type header:
               Content-Type:  application/xml
        The following line of code, in which ap is an AttachmentPart object, sets the header shown in the previous example.
               ap.setMimeHeader("Content-Type", "application/xml");

    There are no restrictions on the content portion of an AttachmentPart object. The content may be anything from a simple plain text object to a complex XML document or image file.

    An AttachmentPart object is created with the method SOAPMessage.createAttachmentPart. After setting its MIME headers, the AttachmentPart object is added to the message that created it with the method SOAPMessage.addAttachmentPart.

    The following code fragment, in which m is a SOAPMessage object and contentStringl is a String, creates an instance of AttachmentPart, sets the AttachmentPart object with some content and header information, and adds the AttachmentPart object to the SOAPMessage object.

         AttachmentPart ap1 = m.createAttachmentPart();
     ap1.setContent(contentString1, "text/plain");
     m.addAttachmentPart(ap1);

    The following code fragment creates and adds a second AttachmentPart instance to the same message. jpegData is a binary byte buffer representing the jpeg file.

         AttachmentPart ap2 = m.createAttachmentPart();
     byte[] jpegData =  ...;
     ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
     m.addAttachmentPart(ap2);

    The getContent method retrieves the contents and header from an AttachmentPart object. Depending on the DataContentHandler objects present, the returned Object can either be a typed Java object corresponding to the MIME type or an InputStream object that contains the content as bytes.

         String content1 = ap1.getContent();
     java.io.InputStream content2 = ap2.getContent();
    The method clearContent removes all the content from an AttachmentPart object but does not affect its header information.
         ap1.clearContent();

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttachmentPart()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addMimeHeader(String name, String value)
      Adds a MIME header with the specified name and value to this AttachmentPart object.
      abstract void clearContent()
      Clears out the content of this AttachmentPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
      abstract InputStream getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      abstract Object getContent()
      Gets the content of this AttachmentPart object as a Java object.
      String getContentId()
      Gets the value of the MIME header whose name is "Content-ID".
      String getContentLocation()
      Gets the value of the MIME header whose name is "Content-Location".
      String getContentType()
      Gets the value of the MIME header whose name is "Content-Type".
      abstract DataHandler getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the header identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract InputStream getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int getSize()
      Returns the number of bytes in this AttachmentPart object.
      abstract void removeAllMimeHeaders()
      Removes all the MIME header entries.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void setContent(Object object, String contentType)
      Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.
      void setContentId(String contentId)
      Sets the MIME header whose name is "Content-ID" with the given value.
      void setContentLocation(String contentLocation)
      Sets the MIME header whose name is "Content-Location" with the given value.
      void setContentType(String contentType)
      Sets the MIME header whose name is "Content-Type" with the given value.
      abstract void setDataHandler(DataHandler dataHandler)
      Sets the given DataHandler object as the data handler for this AttachmentPart object.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.
      abstract void setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttachmentPart

        public AttachmentPart()

    • 方法详细信息

      • getSize

        public abstract int getSize()
                     throws SOAPException
        Returns the number of bytes in this AttachmentPart object.
        返回：
        the size of this AttachmentPart object in bytes or -1 if the size cannot be determined
        抛出：
        SOAPException - if the content of this attachment is corrupted of if there was an exception while trying to determine the size.

      • clearContent

        public abstract void clearContent()
        Clears out the content of this AttachmentPart object. The MIME header portion is left untouched.

      • getContent

        public abstract Object getContent()
                           throws SOAPException
        Gets the content of this AttachmentPart object as a Java object. The type of the returned Java object depends on (1) the DataContentHandler object that is used to interpret the bytes and (2) the Content-Type given in the header.

        For the MIME content types "text/plain", "text/html" and "text/xml", the DataContentHandler object does the conversions to and from the Java types corresponding to the MIME types. For other MIME types,the DataContentHandler object can return an InputStream object that contains the content data as raw bytes.

        A SAAJ-compliant implementation must, as a minimum, return a java.lang.String object corresponding to any content stream with a Content-Type value of text/plain, a javax.xml.transform.stream.StreamSource object corresponding to a content stream with a Content-Type value of text/xml, a java.awt.Image object corresponding to a content stream with a Content-Type value of image/gif or image/jpeg. For those content types that an installed DataContentHandler object does not understand, the DataContentHandler object is required to return a java.io.InputStream object with the raw bytes.

        返回：
        a Java object with the content of this AttachmentPart object
        抛出：
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error

      • getRawContent

        public abstract InputStream getRawContent()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

        Note that reading from the returned InputStream would result in consuming the data in the stream. It is the responsibility of the caller to reset the InputStream appropriately before calling a Subsequent API. If a copy of the raw attachment content is required then the getRawContentBytes() API should be used instead.

        返回：
        an InputStream from which the raw data contained by the AttachmentPart can be accessed.
        抛出：
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getRawContentBytes()

      • getRawContentBytes

        public abstract byte[] getRawContentBytes()
                                   throws SOAPException
        Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
        返回：
        a byte[] array containing the raw data of the AttachmentPart.
        抛出：
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        从以下版本开始：
        SAAJ 1.3

      • getBase64Content

        public abstract InputStream getBase64Content()
                                      throws SOAPException
        Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
        返回：
        an InputStream from which the Base64 encoded AttachmentPart can be read.
        抛出：
        SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
        从以下版本开始：
        SAAJ 1.3

      • setContent

        public abstract void setContent(Object object,
              String contentType)
        Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type. The type of the Object should correspond to the value given for the Content-Type. This depends on the particular set of DataContentHandler objects in use.
        参数：
        object - the Java object that makes up the content for this attachment part
        contentType - the MIME string that specifies the type of the content
        抛出：
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for this content object
        另请参见：
        getContent()

      • setRawContent

        public abstract void setRawContent(InputStream content,
                 String contentType)
                            throws SOAPException
        Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

        A subsequent call to getSize() may not be an exact measure of the content size.

        参数：
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        抛出：
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        从以下版本开始：
        SAAJ 1.3

      • setRawContentBytes

        public abstract void setRawContentBytes(byte[] content,
                      int offset,
                      int len,
                      String contentType)
                                 throws SOAPException
        Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
        参数：
        content - the raw data to add to the attachment part
        contentType - the value to set into the Content-Type header
        offset - the offset in the byte array of the content
        len - the number of bytes that form the content
        抛出：
        SOAPException - if an there is an error in setting the content or content is null
        从以下版本开始：
        SAAJ 1.3

      • setBase64Content

        public abstract void setBase64Content(InputStream content,
                    String contentType)
                               throws SOAPException
        Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

        A subsequent call to getSize() may not be an exact measure of the content size.

        参数：
        content - the base64 encoded data to add to the attachment part
        contentType - the value to set into the Content-Type header
        抛出：
        SOAPException - if an there is an error in setting the content
        NullPointerException - if content is null
        从以下版本开始：
        SAAJ 1.3

      • getDataHandler

        public abstract DataHandler getDataHandler()
                                    throws SOAPException
        Gets the DataHandler object for this AttachmentPart object.
        返回：
        the DataHandler object associated with this AttachmentPart object
        抛出：
        SOAPException - if there is no data in this AttachmentPart object

      • setDataHandler

        public abstract void setDataHandler(DataHandler dataHandler)
        Sets the given DataHandler object as the data handler for this AttachmentPart object. Typically, on an incoming message, the data handler is automatically set. When a message is being created and populated with content, the setDataHandler method can be used to get data from various data sources into the message.
        参数：
        dataHandler - the DataHandler object to be set
        抛出：
        IllegalArgumentException - if there was a problem with the specified DataHandler object

      • getContentId

        public String getContentId()
        Gets the value of the MIME header whose name is "Content-ID".
        返回：
        a String giving the value of the "Content-ID" header or null if there is none
        另请参见：
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Gets the value of the MIME header whose name is "Content-Location".
        返回：
        a String giving the value of the "Content-Location" header or null if there is none

      • getContentType

        public String getContentType()
        Gets the value of the MIME header whose name is "Content-Type".
        返回：
        a String giving the value of the "Content-Type" header or null if there is none

      • setContentId

        public void setContentId(String contentId)
        Sets the MIME header whose name is "Content-ID" with the given value.
        参数：
        contentId - a String giving the value of the "Content-ID" header
        抛出：
        IllegalArgumentException - if there was a problem with the specified contentId value
        另请参见：
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the MIME header whose name is "Content-Location" with the given value.
        参数：
        contentLocation - a String giving the value of the "Content-Location" header
        抛出：
        IllegalArgumentException - if there was a problem with the specified content location

      • setContentType

        public void setContentType(String contentType)
        Sets the MIME header whose name is "Content-Type" with the given value.
        参数：
        contentType - a String giving the value of the "Content-Type" header
        抛出：
        IllegalArgumentException - if there was a problem with the specified content type

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        参数：
        header - the string name of the MIME header/s to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MIME header entries.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the header identified by the given String.
        参数：
        name - the name of the header; example: "Content-Type"
        返回：
        a String array giving the value for the specified header
        另请参见：
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                 String value)
        Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches. This method also removes all matching headers but the first.

        Note that RFC822 headers can only contain US-ASCII characters.

        参数：
        name - a String giving the name of the header for which to search
        value - a String giving the value to be set for the header whose name matches the given name
        抛出：
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                 String value)
        Adds a MIME header with the specified name and value to this AttachmentPart object.

        Note that RFC822 headers can contain only US-ASCII characters.

        参数：
        name - a String giving the name of the header to be added
        value - a String giving the value of the header to be added
        抛出：
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
        返回：
        an Iterator object with all of the Mime headers for this AttachmentPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        参数：
        names - a String array with the name(s) of the MIME headers to be returned
        返回：
        all of the MIME headers that match one of the names in the given array as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        参数：
        names - a String array with the name(s) of the MIME headers not to be returned
        返回：
        all of the MIME headers in this AttachmentPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Detail

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface Detail

  • All Superinterfaces:
    Element, Node, SOAPElement, SOAPFaultElement

    public interface Detail
extends SOAPFaultElement
    A container for DetailEntry objects. DetailEntry objects give detailed error information that is application-specific and related to the SOAPBody object that contains it.

    A Detail object, which is part of a SOAPFault object, can be retrieved using the method SOAPFault.getDetail. The Detail interface provides two methods. One creates a new DetailEntry object and also automatically adds it to the Detail object. The second method gets a list of the DetailEntry objects contained in a Detail object.

    The following code fragment, in which sf is a SOAPFault object, gets its Detail object (d), adds a new DetailEntry object to d, and then gets a list of all the DetailEntry objects in d. The code also creates a Name object to pass to the method addDetailEntry. The variable se, used to create the Name object, is a SOAPEnvelope object.

        Detail d = sf.getDetail();
    Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    d.addDetailEntry(name);
    Iterator it = d.getDetailEntries();

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DetailEntry addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      Iterator getDetailEntries()
      Gets an Iterator over all of the DetailEntrys in this Detail object.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • addDetailEntry

        DetailEntry addDetailEntry(Name name)
                           throws SOAPException
        Creates a new DetailEntry object with the given name and adds it to this Detail object.
        参数：
        name - a Name object identifying the new DetailEntry object
        抛出：
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        另请参见：
        addDetailEntry(QName qname)

      • addDetailEntry

        DetailEntry addDetailEntry(QName qname)
                           throws SOAPException
        Creates a new DetailEntry object with the given QName and adds it to this Detail object. This method is the preferred over the one using Name.
        参数：
        qname - a QName object identifying the new DetailEntry object
        抛出：
        SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        addDetailEntry(Name name)

      • getDetailEntries

        Iterator getDetailEntries()
        Gets an Iterator over all of the DetailEntrys in this Detail object.
        返回：
        an Iterator object over the DetailEntry objects in this Detail object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r t ta tn nenncittoteaDDaCDncaaoCej r


DetailEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.soap

Interface DetailEntry

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface DetailEntry
extends SOAPElement
    The content for a Detail object, giving details for a SOAPFault object. A DetailEntry object, which carries information about errors related to the SOAPBody object that contains it, is application-specific.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ed../e./erfferr i))/./gwmNCee


javax.xml.soap

Interfaces

  • Detail
  • DetailEntry
  • Name
  • Node
  • SOAPBody
  • SOAPBodyElement
  • SOAPConstants
  • SOAPElement
  • SOAPEnvelope
  • SOAPFault
  • SOAPFaultElement
  • SOAPHeader
  • SOAPHeaderElement
  • Text

Classes

  • AttachmentPart
  • MessageFactory
  • MimeHeader
  • MimeHeaders
  • SAAJMetaFactory
  • SAAJResult
  • SOAPConnection
  • SOAPConnectionFactory
  • SOAPElementFactory
  • SOAPFactory
  • SOAPMessage
  • SOAPPart

Exceptions

  • SOAPException
o


javax.xml.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.soap

Provides the API for creating and building SOAP messages.

请参见： 描述

  • 接口摘要
    接口 描述
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConstants
    The definition of constants pertaining to the SOAP protocol.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    Text
    A representation of a node whose value is text.
  • Class Summary
    类 描述
    AttachmentPart
    A single attachment to a SOAPMessage object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeader
    An object that stores a MIME header name and its value.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    SAAJMetaFactory
    The access point for the implementation classes of the factories defined in the SAAJ API.
    SAAJResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElementFactory Deprecated
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Exception Summary
    Exception 描述
    SOAPException
    An exception that signals that a SOAP exception has occurred.

软件包 javax.xml.soap Description

Provides the API for creating and building SOAP messages. This package is defined in the SOAP with Attachments API for JavaTM (SAAJ) 1.3 specification.

The API in the javax.xml.soap package allows you to do the following:

  • create a point-to-point connection to a specified endpoint
  • create a SOAP message
  • create an XML fragment
  • add content to the header of a SOAP message
  • add content to the body of a SOAP message
  • create attachment parts and add content to them
  • access/add/modify parts of a SOAP message
  • create/add/modify SOAP fault information
  • extract content from a SOAP message
  • send a SOAP request-response message

In addition the APIs in the javax.xml.soap package extend their counterparts in the org.w3c.dom package. This means that the SOAPPart of a SOAPMessage is also a DOM Level 2 Document, and can be manipulated as such by applications, tools and libraries that use DOM (see http://www.w3.org/DOM/ for more information). It is important to note that, while it is possible to use DOM APIs to add ordinary DOM nodes to a SAAJ tree, the SAAJ APIs are still required to return SAAJ types when examining or manipulating the tree. In order to accomplish this the SAAJ APIs (specifically SOAPElement.getChildElements()) are allowed to silently replace objects that are incorrectly typed relative to SAAJ requirements with equivalent objects of the required type. These replacements must never cause the logical structure of the tree to change, so from the perspective of the DOM APIs the tree will remain unchanged. However, the physical composition of the tree will have changed so that references to the nodes that were replaced will refer to nodes that are no longer a part of the tree. The SAAJ APIs are not allowed to make these replacements if they are not required so the replacement objects will never subsequently be silently replaced by future calls to the SAAJ API.

What this means in practical terms is that an application that starts to use SAAJ APIs on a tree after manipulating it using DOM APIs must assume that the tree has been translated into an all SAAJ tree and that any references to objects within the tree that were obtained using DOM APIs are no longer valid. Switching from SAAJ APIs to DOM APIs is not allowed to cause invalid references and neither is using SAAJ APIs exclusively. It is only switching from using DOM APIs on a particular SAAJ tree to using SAAJ APIs that causes the risk of invalid references.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rrdo sclsoam


javax.xml.soap Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.soap

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.soap.AttachmentPart
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.soap.MessageFactory
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.soap.SOAPException

Interface Hierarchy

  • javax.xml.soap.Name
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • javax.xml.soap.SOAPConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sA inm eiiimOwwduooa


MessageFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 MessageFactory

  • java.lang.Object
    • javax.xml.soap.MessageFactory

  • public abstract class MessageFactory
extends Object
    A factory for creating SOAPMessage objects.

    A SAAJ client can create a MessageFactory object using the method newInstance, as shown in the following lines of code.

           MessageFactory mf = MessageFactory.newInstance();
       MessageFactory mf12 = MessageFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);

    All MessageFactory objects, regardless of how they are created, will produce SOAPMessage objects that have the following elements by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    In some cases, specialized MessageFactory objects may be obtained that produce messages prepopulated with additional entries in the SOAPHeader object and the SOAPBody object. The content of a new SOAPMessage object depends on which of the two MessageFactory methods is used to create it.
    • createMessage()
      This is the method clients would normally use to create a request message.
    • createMessage(MimeHeaders, java.io.InputStream) -- message has content from the InputStream object and headers from the MimeHeaders object
      This method can be used internally by a service implementation to create a message that is a response to a request.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MessageFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract SOAPMessage createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      static MessageFactory newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MessageFactory

        public MessageFactory()

    • 方法详细信息

      • newInstance

        public static MessageFactory newInstance()
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load:
        • Use the javax.xml.soap.MessageFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.MessageFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the MessageFactory implementation class.
        返回：
        a new instance of a MessageFactory
        抛出：
        SOAPException - if there was an error in creating the default implementation of the MessageFactory.
        另请参见：
        SAAJMetaFactory

      • newInstance

        public static MessageFactory newInstance(String protocol)
                                  throws SOAPException
        Creates a new MessageFactory object that is an instance of the specified implementation. May be a dynamic message factory, a SOAP 1.1 message factory, or a SOAP 1.2 message factory. A dynamic message factory creates messages based on the MIME headers specified as arguments to the createMessage method. This method uses the SAAJMetaFactory to locate the implementation class and create the MessageFactory instance.
        参数：
        protocol - a string constant representing the class of the specified message factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        返回：
        a new instance of a MessageFactory
        抛出：
        SOAPException - if there was an error in creating the specified implementation of MessageFactory.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        SAAJMetaFactory

      • createMessage

        public abstract SOAPMessage createMessage()
                                   throws SOAPException
        Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects. Profile-specific message factories can choose to prepopulate the SOAPMessage object with profile-specific headers.

        Content can be added to this message's SOAPPart object, and the message can be sent "as is" when a message containing only a SOAP part is sufficient. Otherwise, the SOAPMessage object needs to create one or more AttachmentPart objects and add them to itself. Any content that is not in XML format must be in an AttachmentPart object.

        返回：
        a new SOAPMessage object
        抛出：
        SOAPException - if a SOAP error occurs
        UnsupportedOperationException - if the protocol of this MessageFactory instance is DYNAMIC_SOAP_PROTOCOL

      • createMessage

        public abstract SOAPMessage createMessage(MimeHeaders headers,
                        InputStream in)
                                   throws IOException,
                                          SOAPException
        Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
        参数：
        in - the InputStream object that contains the data for a message
        headers - the transport-specific headers passed to the message in a transport-independent fashion for creation of the message
        返回：
        a new SOAPMessage object containing the data from the given InputStream object
        抛出：
        IOException - if there is a problem in reading data from the input stream
        SOAPException - may be thrown if the message is invalid
        IllegalArgumentException - if the MessageFactory requires one or more MIME headers to be present in the headers parameter and they are missing. MessageFactory implementations for SOAP_1_1_PROTOCOL or SOAP_1_2_PROTOCOL must not throw IllegalArgumentException for this reason.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s s l ie )>>xas=em/x/lmceeee/vsas


MimeHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 MimeHeader

  • java.lang.Object
    • javax.xml.soap.MimeHeader

  • public class MimeHeader
extends Object
    An object that stores a MIME header name and its value. One or more MimeHeader objects may be contained in a MimeHeaders object.
    另请参见：
    MimeHeaders

    • 构造方法摘要

      Constructors
      构造方法与描述
      MimeHeader(String name, String value)
      Constructs a MimeHeader object initialized with the given name and value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Returns the name of this MimeHeader object.
      String getValue()
      Returns the value of this MimeHeader object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MimeHeader

        public MimeHeader(String name,
          String value)
        Constructs a MimeHeader object initialized with the given name and value.
        参数：
        name - a String giving the name of the header
        value - a String giving the value of the header

    • 方法详细信息

      • getName

        public String getName()
        Returns the name of this MimeHeader object.
        返回：
        the name of the header as a String

      • getValue

        public String getValue()
        Returns the value of this MimeHeader object.
        返回：
        the value of the header as a String
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m fto toinnoiiet "mEsPAASei


MimeHeaders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 MimeHeaders

  • java.lang.Object
    • javax.xml.soap.MimeHeaders

  • public class MimeHeaders
extends Object
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

    This class is used primarily when an application wants to retrieve specific attachments based on certain MIME headers and values. This class will most likely be used by implementations of AttachmentPart and other MIME dependent parts of the SAAJ API.

    另请参见：
    SOAPMessage.getAttachments(), AttachmentPart

    • 构造方法摘要

      Constructors
      构造方法与描述
      MimeHeaders()
      Constructs a default MimeHeaders object initialized with an empty Vector object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addHeader(String name, String value)
      Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
      Iterator getAllHeaders()
      Returns all the MimeHeaders in this MimeHeaders object.
      String[] getHeader(String name)
      Returns all of the values for the specified header as an array of String objects.
      Iterator getMatchingHeaders(String[] names)
      Returns all the MimeHeader objects whose name matches a name in the given array of names.
      Iterator getNonMatchingHeaders(String[] names)
      Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
      void removeAllHeaders()
      Removes all the header entries from this MimeHeaders object.
      void removeHeader(String name)
      Remove all MimeHeader objects whose name matches the given name.
      void setHeader(String name, String value)
      Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MimeHeaders

        public MimeHeaders()
        Constructs a default MimeHeaders object initialized with an empty Vector object.

    • 方法详细信息

      • getHeader

        public String[] getHeader(String name)
        Returns all of the values for the specified header as an array of String objects.
        参数：
        name - the name of the header for which values will be returned
        返回：
        a String array with all of the values for the specified header
        另请参见：
        setHeader(java.lang.String, java.lang.String)

      • setHeader

        public void setHeader(String name,
             String value)
        Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches. This method also removes all matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        参数：
        name - a String with the name of the header for which to search
        value - a String with the value that will replace the current value of the specified header
        抛出：
        IllegalArgumentException - if there was a problem in the mime header name or the value being set
        另请参见：
        getHeader(java.lang.String)

      • addHeader

        public void addHeader(String name,
             String value)
        Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

        Note that RFC822 headers can contain only US-ASCII characters.

        参数：
        name - a String with the name of the header to be added
        value - a String with the value of the header to be added
        抛出：
        IllegalArgumentException - if there was a problem in the mime header name or value being added

      • removeHeader

        public void removeHeader(String name)
        Remove all MimeHeader objects whose name matches the given name.
        参数：
        name - a String with the name of the header for which to search

      • removeAllHeaders

        public void removeAllHeaders()
        Removes all the header entries from this MimeHeaders object.

      • getAllHeaders

        public Iterator getAllHeaders()
        Returns all the MimeHeaders in this MimeHeaders object.
        返回：
        an Iterator object over this MimeHeaders object's list of MimeHeader objects

      • getMatchingHeaders

        public Iterator getMatchingHeaders(String[] names)
        Returns all the MimeHeader objects whose name matches a name in the given array of names.
        参数：
        names - an array of String objects with the names for which to search
        返回：
        an Iterator object over the MimeHeader objects whose name matches one of the names in the given list

      • getNonMatchingHeaders

        public Iterator getNonMatchingHeaders(String[] names)
        Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
        参数：
        names - an array of String objects with the names for which to search
        返回：
        an Iterator object over the MimeHeader objects whose name does not match one of the names in the given list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.arlnl-lepr-tgdca湿e眛嗽�"礱腸s//捣k a�


Name

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface Name

  • public interface Name
    A representation of an XML name. This interface provides methods for getting the local and namespace-qualified names and also for getting the prefix associated with the namespace for the name. It is also possible to get the URI of the namespace.

    The following is an example of a namespace declaration in an element.

       <wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
    ("xmlns" stands for "XML namespace".) The following shows what the methods in the Name interface will return.
    • getQualifiedName will return "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
    • getURI will return "http://www.wombat.org/trader"
    • getLocalName will return "GetLastTracePrice"
    • getPrefix will return "WOMBAT"

    XML namespaces are used to disambiguate SOAP identifiers from application-specific identifiers.

    Name objects are created using the method SOAPEnvelope.createName, which has two versions. One method creates Name objects with a local name, a namespace prefix, and a namespace URI. and the second creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    The following line of code gives an example of how a Name object can be used. The variable element is a SOAPElement object. This code creates a new SOAPElement object with the given name and adds it to element.
         element.addChildElement(name);

    The Name interface may be deprecated in a future release of SAAJ in favor of javax.xml.namespace.QName

    另请参见：
    SOAPEnvelope.createName, SOAPFactory.createName

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getLocalName()
      Gets the local name part of the XML name that this Name object represents.
      String getPrefix()
      Returns the prefix that was specified when this Name object was initialized.
      String getQualifiedName()
      Gets the namespace-qualified name of the XML name that this Name object represents.
      String getURI()
      Returns the URI of the namespace for the XML name that this Name object represents.

    • 方法详细信息

      • getLocalName

        String getLocalName()
        Gets the local name part of the XML name that this Name object represents.
        返回：
        a string giving the local name

      • getQualifiedName

        String getQualifiedName()
        Gets the namespace-qualified name of the XML name that this Name object represents.
        返回：
        the namespace-qualified name as a string

      • getPrefix

        String getPrefix()
        Returns the prefix that was specified when this Name object was initialized. This prefix is associated with the namespace for the XML name that this Name object represents.
        返回：
        the prefix as a string

      • getURI

        String getURI()
        Returns the URI of the namespace for the XML name that this Name object represents.
        返回：
        the URI as a string
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ee,>ig>ng>"SS>"". ttprep<>pse;dea


Node

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface Node

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text

    public interface Node
extends Node
    A representation of a node (element) in an XML document. This interface extnends the standard DOM Node interface with methods for getting and setting the value of a node, for getting and setting the parent of a node, and for removing a node.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void detachNode()
      Removes this Node object from the tree.
      SOAPElement getParentElement()
      Returns the parent element of this Node object.
      String getValue()
      Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
      void recycleNode()
      Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
      void setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void setValue(String value)
      If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getValue

        String getValue()
        Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise. If there is an immediate child of this Node that it is a Text node then it's value will be returned. If there is more than one Text node then the value of the first Text Node will be returned. Otherwise null is returned.
        返回：
        a String with the text of this node if this is a Text node or the text contained by the first immediate child of this Node object that is a Text object if such a child exists; null otherwise.

      • setValue

        void setValue(String value)
        If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node. The value of the immediate child of this node can be set only if, there is one child node and that node is a Text node, or if there are no children in which case a child Text node will be created.
        抛出：
        IllegalStateException - if the node is not a Text node and either has more than one child node or has a child node that is not a Text node.
        从以下版本开始：
        SAAJ 1.2

      • setParentElement

        void setParentElement(SOAPElement parent)
                      throws SOAPException
        Sets the parent of this Node object to the given SOAPElement object.
        参数：
        parent - the SOAPElement object to be set as the parent of this Node object
        抛出：
        SOAPException - if there is a problem in setting the parent to the given element
        另请参见：
        getParentElement()

      • getParentElement

        SOAPElement getParentElement()
        Returns the parent element of this Node object. This method can throw an UnsupportedOperationException if the tree is not kept in memory.
        返回：
        the SOAPElement object that is the parent of this Node object or null if this Node object is root
        抛出：
        UnsupportedOperationException - if the whole tree is not kept in memory
        另请参见：
        setParentElement(javax.xml.soap.SOAPElement)

      • detachNode

        void detachNode()
        Removes this Node object from the tree.

      • recycleNode

        void recycleNode()
        Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

        Calling the method recycleNode implies that the method detachNode has been called previously.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e dl it itahlieehbaa"lliant rtcrN tis


SAAJMetaFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SAAJMetaFactory

  • java.lang.Object
    • javax.xml.soap.SAAJMetaFactory

  • public abstract class SAAJMetaFactory
extends Object
    The access point for the implementation classes of the factories defined in the SAAJ API. All of the newInstance methods defined on factories in SAAJ 1.3 defer to instances of this class to do the actual object creation. The implementations of newInstance() methods (in SOAPFactory and MessageFactory) that existed in SAAJ 1.2 have been updated to also delegate to the SAAJMetaFactory when the SAAJ 1.2 defined lookup fails to locate the Factory implementation class name.

    SAAJMetaFactory is a service provider interface. There are no public methods on this class.

    从以下版本开始：
    SAAJ 1.3

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | SAAJMetaFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      protected abstract MessageFactory newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SAAJMetaFactory

        protected SAAJMetaFactory()

    • 方法详细信息

      • newMessageFactory

        protected abstract MessageFactory newMessageFactory(String protocol)
                                             throws SOAPException
        Creates a MessageFactory object for the given String protocol.
        参数：
        protocol - a String indicating the protocol
        抛出：
        SOAPException - if there is an error in creating the MessageFactory
        另请参见：
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL

      • newSOAPFactory

        protected abstract SOAPFactory newSOAPFactory(String protocol)
                                       throws SOAPException
        Creates a SOAPFactory object for the given String protocol.
        参数：
        protocol - a String indicating the protocol
        抛出：
        SOAPException - if there is an error in creating the SOAPFactory
        另请参见：
        SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hhstpa ha dsdna/v/ tPePM hDtvhrhcc ahto


SAAJResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SAAJResult

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult
      • javax.xml.soap.SAAJResult
  • 所有已实现的接口：
    Result

    public class SAAJResult
extends DOMResult
    Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree. These results should be accessed by using the getResult() method. The DOMResult.getNode() method should be avoided in almost all cases.
    从以下版本开始：
    SAAJ 1.3

    • 字段摘要

      • Fields inherited from class javax.xml.transform.dom.DOMResult

        FEATURE

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getResult()

      • 方法 - 继承于类 javax.xml.transform.dom.DOMResult

        getNextSibling, getNode, getSystemId, setNextSibling, setNode, setSystemId

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SAAJResult

        public SAAJResult()
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation, the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        抛出：
        SOAPException - if there is a problem creating a SOAPMessage
        从以下版本开始：
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(String protocol)
           throws SOAPException
        Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol. The DYNAMIC_SOAP_PROTOCOL is ambiguous in this context and will cause this constructor to throw an UnsupportedOperationException.

        This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

        参数：
        protocol - - the name of the SOAP protocol that the resulting SAAJ tree should support
        抛出：
        SOAPException - if a SOAPMessage supporting the specified protocol cannot be created
        从以下版本开始：
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPMessage message)
        Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage. In the normal case these results will be written using DOM APIs and, as a result, the finished SOAPPart will not be guaranteed to be well-formed unless the data used to create it is also well formed. When used in a transformation the validity of the SOAPMessage after the transformation can be guaranteed only by means outside SAAJ specification.
        参数：
        message - - the message whose SOAPPart will be populated as a result of some transformation or marshalling operation
        从以下版本开始：
        SAAJ 1.3

      • SAAJResult

        public SAAJResult(SOAPElement rootNode)
        Creates a SAAJResult that will write the results as a child node of the SOAPElement specified. In the normal case these results will be written using DOM APIs and as a result may invalidate the structure of the SAAJ tree. This kind of SAAJResult should only be used when the validity of the incoming data can be guaranteed by means outside of the SAAJ specification.
        参数：
        rootNode - - the root to which the results will be appended
        从以下版本开始：
        SAAJ 1.3

    • 方法详细信息

      • getResult

        public Node getResult()
        返回：
        the resulting Tree that was created under the specified root Node.
        从以下版本开始：
        SAAJ 1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ili.bl"ll/att蕂lmtd


SOAPBody

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPBody

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPBody
extends SOAPElement
    An object that represents the contents of the SOAP body element in a SOAP message. A SOAP body element consists of XML data that affects the way the application-specific content is processed.

    A SOAPBody object contains SOAPBodyElement objects, which have the content for the SOAP body. A SOAPFault object, which carries status and/or error information, is an example of a SOAPBodyElement object.

    另请参见：
    SOAPFault

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPBodyElement addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      Document extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPFault getFault()
      Returns the SOAPFault object in this SOAPBody object.
      boolean hasFault()
      Indicates whether a SOAPFault object exists in this SOAPBody object.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • addFault

        SOAPFault addFault()
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have default values set for the mandatory child elements. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        A SOAPBody may contain at most one SOAPFault child element.

        返回：
        the new SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error

      • addFault

        SOAPFault addFault(Name faultCode,
                 String faultString,
                 Locale locale)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        参数：
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the Version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        返回：
        the new SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                 String faultString,
                 Locale locale)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        A SOAPBody may contain at most one SOAPFault child element.

        参数：
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use.
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        返回：
        the new SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString, Locale locale)

      • addFault

        SOAPFault addFault(Name faultCode,
                 String faultString)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element.

        参数：
        faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        返回：
        the new SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

      • addFault

        SOAPFault addFault(QName faultCode,
                 String faultString)
                   throws SOAPException
        Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

        For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

        In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

        A SOAPBody may contain at most one SOAPFault child element

        参数：
        faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
        faultString - a String giving an explanation of the fault
        返回：
        the new SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString)

      • hasFault

        boolean hasFault()
        Indicates whether a SOAPFault object exists in this SOAPBody object.
        返回：
        true if a SOAPFault object exists in this SOAPBody object; false otherwise

      • getFault

        SOAPFault getFault()
        Returns the SOAPFault object in this SOAPBody object.
        返回：
        the SOAPFault object in this SOAPBody object if present, null otherwise.

      • addBodyElement

        SOAPBodyElement addBodyElement(Name name)
                               throws SOAPException
        Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
        参数：
        name - a Name object with the name for the new SOAPBodyElement object
        返回：
        the new SOAPBodyElement object
        抛出：
        SOAPException - if a SOAP error occurs
        另请参见：
        addBodyElement(javax.xml.namespace.QName)

      • addBodyElement

        SOAPBodyElement addBodyElement(QName qname)
                               throws SOAPException
        Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
        参数：
        qname - a QName object with the qname for the new SOAPBodyElement object
        返回：
        the new SOAPBodyElement object
        抛出：
        SOAPException - if a SOAP error occurs
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        addBodyElement(Name)

      • addDocument

        SOAPBodyElement addDocument(Document document)
                            throws SOAPException
        Adds the root node of the DOM Document to this SOAPBody object.

        Calling this method invalidates the document parameter. The client application should discard all references to this Document and its contents upon calling addDocument. The behavior of an application that continues to use such references is undefined.

        参数：
        document - the Document object whose root node will be added to this SOAPBody.
        返回：
        the SOAPBodyElement that represents the root node that was added.
        抛出：
        SOAPException - if the Document cannot be added
        从以下版本开始：
        SAAJ 1.2

      • extractContentAsDocument

        Document extractContentAsDocument()
                                  throws SOAPException
        Creates a new DOM Document and sets the first child of this SOAPBody as it's document element. The child SOAPElement is removed as part of the process.
        返回：
        the Document representation of the SOAPBody content.
        抛出：
        SOAPException - if there is not exactly one child SOAPElement of the SOAPBody.
        从以下版本开始：
        SAAJ 1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SOAPBodyElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPBodyElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    SOAPFault

    public interface SOAPBodyElement
extends SOAPElement
    A SOAPBodyElement object represents the contents in a SOAPBody object. The SOAPFault interface is a SOAPBodyElement object that has been defined.

    A new SOAPBodyElement object can be created and added to a SOAPBody object with the SOAPBody method addBodyElement. In the following line of code, sb is a SOAPBody object, and myName is a Name object.

        SOAPBodyElement sbe = sb.addBodyElement(myName);

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t>.r.dg.doeedoobsllitvav"S/a/


SOAPConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPConnection

  • java.lang.Object
    • javax.xml.soap.SOAPConnection

  • public abstract class SOAPConnection
extends Object
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

    The SOAPConnection class is optional. Some implementations may not implement this interface in which case the call to SOAPConnectionFactory.newInstance() (see below) will throw an UnsupportedOperationException.

    A client can obtain a SOAPConnection object using a SOAPConnectionFactory object as in the following example:

          SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
      SOAPConnection con = factory.createConnection();
    A SOAPConnection object can be used to send messages directly to a URL following the request/response paradigm. That is, messages are sent using the method call, which sends the message and then waits until it gets a reply.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPConnection()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract SOAPMessage call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void close()
      Closes this SOAPConnection object.
      SOAPMessage get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SOAPConnection

        public SOAPConnection()

    • 方法详细信息

      • call

        public abstract SOAPMessage call(SOAPMessage request,
               Object to)
                          throws SOAPException
        Sends the given message to the specified endpoint and blocks until it has returned the response.
        参数：
        request - the SOAPMessage object to be sent
        to - an Object that identifies where the message should be sent. It is required to support Objects of type java.lang.String, java.net.URL, and when JAXM is present javax.xml.messaging.URLEndpoint
        返回：
        the SOAPMessage object that is the response to the message that was sent
        抛出：
        SOAPException - if there is a SOAP error

      • get

        public SOAPMessage get(Object to)
                throws SOAPException
        Gets a message from a specific endpoint and blocks until it receives,
        参数：
        to - an Object that identifies where the request should be sent. Objects of type java.lang.String and java.net.URL must be supported.
        返回：
        the SOAPMessage object that is the response to the get message request
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.3

      • close

        public abstract void close()
                    throws SOAPException
        Closes this SOAPConnection object.
        抛出：
        SOAPException - if there is a SOAP error
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

doew.o./o./...//f,UUa,=>fe e..h,Ctt)nxT.a


SOAPConnectionFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPConnectionFactory

  • java.lang.Object
    • javax.xml.soap.SOAPConnectionFactory

  • public abstract class SOAPConnectionFactory
extends Object
    A factory for creating SOAPConnection objects. Implementation of this class is optional. If SOAPConnectionFactory.newInstance() throws an UnsupportedOperationException then the implementation does not support the SAAJ communication infrastructure. Otherwise SOAPConnection objects can be created by calling createConnection() on the newly created SOAPConnectionFactory object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPConnectionFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract SOAPConnection createConnection()
      Create a new SOAPConnection.
      static SOAPConnectionFactory newInstance()
      Creates an instance of the default SOAPConnectionFactory object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SOAPConnectionFactory

        public SOAPConnectionFactory()

    • 方法详细信息

      • newInstance

        public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
        Creates an instance of the default SOAPConnectionFactory object.
        返回：
        a new instance of a default SOAPConnectionFactory object
        抛出：
        SOAPException - if there was an error creating the SOAPConnectionFactory
        UnsupportedOperationException - if newInstance is not supported.

      • createConnection

        public abstract SOAPConnection createConnection()
                                         throws SOAPException
        Create a new SOAPConnection.
        返回：
        the new SOAPConnection object.
        抛出：
        SOAPException - if there was an exception creating the SOAPConnection object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g8uosoaonobuuobbs<<i襪


SOAPConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPConstants

  • public interface SOAPConstants
    The definition of constants pertaining to the SOAP protocol.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_SOAP_PROTOCOL
      The default protocol: SOAP 1.1 for backwards compatibility.
      static String DYNAMIC_SOAP_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
      static String SOAP_1_1_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.1.
      static String SOAP_1_1_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
      static String SOAP_1_2_CONTENT_TYPE
      The media type of the Content-Type MIME header in SOAP 1.2.
      static String SOAP_1_2_PROTOCOL
      Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
      static QName SOAP_DATAENCODINGUNKNOWN_FAULT
      SOAP 1.2 DataEncodingUnknown Fault
      static String SOAP_ENV_PREFIX
      The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
      static QName SOAP_MUSTUNDERSTAND_FAULT
      SOAP 1.2 MustUnderstand Fault
      static QName SOAP_RECEIVER_FAULT
      SOAP 1.2 Receiver Fault
      static QName SOAP_SENDER_FAULT
      SOAP 1.2 Sender Fault
      static QName SOAP_VERSIONMISMATCH_FAULT
      SOAP 1.2 VersionMismatch Fault
      static String URI_NS_SOAP_1_1_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope.
      static String URI_NS_SOAP_1_2_ENCODING
      The namespace identifier for the SOAP 1.2 encoding.
      static String URI_NS_SOAP_1_2_ENVELOPE
      The namespace identifier for the SOAP 1.2 envelope.
      static String URI_NS_SOAP_ENCODING
      The namespace identifier for the SOAP 1.1 encoding.
      static String URI_NS_SOAP_ENVELOPE
      The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
      static String URI_SOAP_1_2_ROLE_NEXT
      The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
      static String URI_SOAP_1_2_ROLE_NONE
      The URI specifying the role None in SOAP 1.2.
      static String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
      The URI identifying the ultimate receiver of the SOAP 1.2 message.
      static String URI_SOAP_ACTOR_NEXT
      The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

    • 字段详细信息

      • DYNAMIC_SOAP_PROTOCOL

        static final String DYNAMIC_SOAP_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method. If no Content-Type header is passed then the createMessage may throw an IllegalArgumentException or, in the case of the no argument version of createMessage, an UnsupportedOperationException.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_1_1_PROTOCOL

        static final String SOAP_1_1_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_1_2_PROTOCOL

        static final String SOAP_1_2_PROTOCOL
        Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • DEFAULT_SOAP_PROTOCOL

        static final String DEFAULT_SOAP_PROTOCOL
        The default protocol: SOAP 1.1 for backwards compatibility.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_NS_SOAP_1_1_ENVELOPE

        static final String URI_NS_SOAP_1_1_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_NS_SOAP_1_2_ENVELOPE

        static final String URI_NS_SOAP_1_2_ENVELOPE
        The namespace identifier for the SOAP 1.2 envelope.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_NS_SOAP_ENVELOPE

        static final String URI_NS_SOAP_ENVELOPE
        The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
        另请参见：
        Constant Field Values

      • URI_NS_SOAP_ENCODING

        static final String URI_NS_SOAP_ENCODING
        The namespace identifier for the SOAP 1.1 encoding. An attribute named encodingStyle in the URI_NS_SOAP_ENVELOPE namespace and set to the value URI_NS_SOAP_ENCODING can be added to an element to indicate that it is encoded using the rules in section 5 of the SOAP 1.1 specification.
        另请参见：
        Constant Field Values

      • URI_NS_SOAP_1_2_ENCODING

        static final String URI_NS_SOAP_1_2_ENCODING
        The namespace identifier for the SOAP 1.2 encoding.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_1_1_CONTENT_TYPE

        static final String SOAP_1_1_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.1.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_1_2_CONTENT_TYPE

        static final String SOAP_1_2_CONTENT_TYPE
        The media type of the Content-Type MIME header in SOAP 1.2.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_SOAP_ACTOR_NEXT

        static final String URI_SOAP_ACTOR_NEXT
        The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

        This value can be passed to
SOAPHeader.examineMustUnderstandHeaderElements(String),
SOAPHeader.examineHeaderElements(String) and
SOAPHeader.extractHeaderElements(String)

        另请参见：
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NEXT

        static final String URI_SOAP_1_2_ROLE_NEXT
        The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_SOAP_1_2_ROLE_NONE

        static final String URI_SOAP_1_2_ROLE_NONE
        The URI specifying the role None in SOAP 1.2.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

        static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
        The URI identifying the ultimate receiver of the SOAP 1.2 message.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_ENV_PREFIX

        static final String SOAP_ENV_PREFIX
        The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        Constant Field Values

      • SOAP_VERSIONMISMATCH_FAULT

        static final QName SOAP_VERSIONMISMATCH_FAULT
        SOAP 1.2 VersionMismatch Fault
        从以下版本开始：
        SAAJ 1.3

      • SOAP_MUSTUNDERSTAND_FAULT

        static final QName SOAP_MUSTUNDERSTAND_FAULT
        SOAP 1.2 MustUnderstand Fault
        从以下版本开始：
        SAAJ 1.3

      • SOAP_DATAENCODINGUNKNOWN_FAULT

        static final QName SOAP_DATAENCODINGUNKNOWN_FAULT
        SOAP 1.2 DataEncodingUnknown Fault
        从以下版本开始：
        SAAJ 1.3

      • SOAP_SENDER_FAULT

        static final QName SOAP_SENDER_FAULT
        SOAP 1.2 Sender Fault
        从以下版本开始：
        SAAJ 1.3

      • SOAP_RECEIVER_FAULT

        static final QName SOAP_RECEIVER_FAULT
        SOAP 1.2 Receiver Fault
        从以下版本开始：
        SAAJ 1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osr=e"">tcfT1,p�>/吹N


SOAPElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPElement

  • All Superinterfaces:
    Element, Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement

    public interface SOAPElement
extends Node, Element
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification. This interface serves as the base interface for those objects that are specifically prescribed by a SOAP specification.

    Methods in this interface that are required to return SAAJ specific objects may "silently" replace nodes in the tree as required to successfully return objects of the correct type. See getChildElements() and javax.xml.soap for details.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPElement addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      QName createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Iterator getAllAttributes()
      Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
      Iterator getAllAttributesAsQNames()
      Returns an Iterator over all of the attributes in this SOAPElement as QName objects.
      String getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      String getAttributeValue(QName qname)
      Returns the value of the attribute with the specified qname.
      Iterator getChildElements()
      Returns an Iterator over all the immediate child Nodes of this element.
      Iterator getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      Iterator getChildElements(QName qname)
      Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
      Name getElementName()
      Returns the name of this SOAPElement object.
      QName getElementQName()
      Returns the qname of this SOAPElement object.
      String getEncodingStyle()
      Returns the encoding style for this SOAPElement object.
      Iterator getNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings declared by this element.
      String getNamespaceURI(String prefix)
      Returns the URI of the namespace that has the given prefix.
      Iterator getVisibleNamespacePrefixes()
      Returns an Iterator over the namespace prefix Strings visible to this element.
      boolean removeAttribute(Name name)
      Removes the attribute with the specified name.
      boolean removeAttribute(QName qname)
      Removes the attribute with the specified qname.
      void removeContents()
      Detaches all children of this SOAPElement.
      boolean removeNamespaceDeclaration(String prefix)
      Removes the namespace declaration corresponding to the given prefix.
      SOAPElement setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • addChildElement

        SOAPElement addChildElement(Name name)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

        This method may be deprecated in a future release of SAAJ in favor of addChildElement(javax.xml.namespace.QName)

        参数：
        name - a Name object with the XML name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        另请参见：
        addChildElement(javax.xml.namespace.QName)

      • addChildElement

        SOAPElement addChildElement(QName qname)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object. The namespace, localname and prefix of the new SOAPElement are all taken from the qname argument.
        参数：
        qname - a QName object with the XML name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        addChildElement(Name)

      • addChildElement

        SOAPElement addChildElement(String localName)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object. The new SOAPElement inherits any in-scope default namespace.
        参数：
        localName - a String giving the local name for the element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                          String prefix)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
        参数：
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if the prefix is not valid in the context of this SOAPElement or if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(String localName,
                          String prefix,
                          String uri)
                            throws SOAPException
        Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
        参数：
        localName - a String giving the local name for the new element
        prefix - a String giving the namespace prefix for the new element
        uri - a String giving the URI of the namespace to which the new element belongs
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object

      • addChildElement

        SOAPElement addChildElement(SOAPElement element)
                            throws SOAPException
        Add a SOAPElement as a child of this SOAPElement instance. The SOAPElement is expected to be created by a SOAPFactory. Callers should not rely on the element instance being added as is into the XML tree. Implementations could end up copying the content of the SOAPElement passed into an instance of a different SOAPElement implementation. For instance if addChildElement() is called on a SOAPHeader, element will be copied into an instance of a SOAPHeaderElement.

        The fragment rooted in element is either added as a whole or not at all, if there was an error.

        The fragment rooted in element cannot contain elements named "Envelope", "Header" or "Body" and in the SOAP namespace. Any namespace prefixes present in the fragment should be fully resolved using appropriate namespace declarations within the fragment itself.

        参数：
        element - the SOAPElement to be added as a new child
        返回：
        an instance representing the new SOAP element that was actually added to the tree.
        抛出：
        SOAPException - if there was an error in adding this element as a child

      • removeContents

        void removeContents()
        Detaches all children of this SOAPElement.

        This method is useful for rolling back the construction of partially completed SOAPHeaders and SOAPBodys in preparation for sending a fault when an error condition is detected. It is also useful for recycling portions of a document within a SOAP message.

        从以下版本开始：
        SAAJ 1.2

      • addTextNode

        SOAPElement addTextNode(String text)
                        throws SOAPException
        Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
        参数：
        text - a String object with the textual content to be added
        返回：
        the SOAPElement object into which the new Text object was inserted
        抛出：
        SOAPException - if there is an error in creating the new Text object or if it is not legal to attach it as a child to this SOAPElement

      • addAttribute

        SOAPElement addAttribute(Name name,
                       String value)
                         throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        参数：
        name - a Name object with the name of the attribute
        value - a String giving the value of the attribute
        返回：
        the SOAPElement object into which the attribute was inserted
        抛出：
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with Name name on this SOAPElement.
        另请参见：
        addAttribute(javax.xml.namespace.QName, String)

      • addAttribute

        SOAPElement addAttribute(QName qname,
                       String value)
                         throws SOAPException
        Adds an attribute with the specified name and value to this SOAPElement object.
        参数：
        qname - a QName object with the name of the attribute
        value - a String giving the value of the attribute
        返回：
        the SOAPElement object into which the attribute was inserted
        抛出：
        SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with QName qname on this SOAPElement.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        addAttribute(Name, String)

      • addNamespaceDeclaration

        SOAPElement addNamespaceDeclaration(String prefix,
                                  String uri)
                                    throws SOAPException
        Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
        参数：
        prefix - a String giving the prefix of the namespace
        uri - a String giving the uri of the namespace
        返回：
        the SOAPElement object into which this namespace declaration was inserted.
        抛出：
        SOAPException - if there is an error in creating the namespace

      • getAttributeValue

        String getAttributeValue(Name name)
        Returns the value of the attribute with the specified name.
        参数：
        name - a Name object with the name of the attribute
        返回：
        a String giving the value of the specified attribute, Null if there is no such attribute
        另请参见：
        getAttributeValue(javax.xml.namespace.QName)

      • getAttributeValue

        String getAttributeValue(QName qname)
        Returns the value of the attribute with the specified qname.
        参数：
        qname - a QName object with the qname of the attribute
        返回：
        a String giving the value of the specified attribute, Null if there is no such attribute
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getAttributeValue(Name)

      • getAllAttributes

        Iterator getAllAttributes()
        Returns an Iterator over all of the attribute Name objects in this SOAPElement object. The iterator can be used to get the attribute names, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        返回：
        an iterator over the names of the attributes
        另请参见：
        getAllAttributesAsQNames()

      • getAllAttributesAsQNames

        Iterator getAllAttributesAsQNames()
        Returns an Iterator over all of the attributes in this SOAPElement as QName objects. The iterator can be used to get the attribute QName, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.
        返回：
        an iterator over the QNames of the attributes
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getAllAttributes()

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Returns the URI of the namespace that has the given prefix.
        参数：
        prefix - a String giving the prefix of the namespace for which to search
        返回：
        a String with the uri of the namespace that has the given prefix

      • getNamespacePrefixes

        Iterator getNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings declared by this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        返回：
        an iterator over the namespace prefixes in this SOAPElement object

      • getVisibleNamespacePrefixes

        Iterator getVisibleNamespacePrefixes()
        Returns an Iterator over the namespace prefix Strings visible to this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.
        返回：
        an iterator over the namespace prefixes are within scope of this SOAPElement object
        从以下版本开始：
        SAAJ 1.2

      • createQName

        QName createQName(String localName,
                String prefix)
                  throws SOAPException
        Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement. The remaining elements of the new QName are taken directly from the parameters, localName and prefix.
        参数：
        localName - a String containing the local part of the name.
        prefix - a String containing the prefix for the name.
        返回：
        a QName with the specified localName and prefix, and with a namespace that is associated with the prefix in the context of this SOAPElement. This namespace will be the same as the one that would be returned by getNamespaceURI(String) if it were given prefix as it's parameter.
        抛出：
        SOAPException - if the QName cannot be created.
        从以下版本开始：
        SAAJ 1.3

      • getElementName

        Name getElementName()
        Returns the name of this SOAPElement object.
        返回：
        a Name object with the name of this SOAPElement object

      • getElementQName

        QName getElementQName()
        Returns the qname of this SOAPElement object.
        返回：
        a QName object with the qname of this SOAPElement object
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getElementName()

      • setElementQName

        SOAPElement setElementQName(QName newName)
                            throws SOAPException
        Changes the name of this Element to newName if possible. SOAP Defined elements such as SOAPEnvelope, SOAPHeader, SOAPBody etc. cannot have their names changed using this method. Any attempt to do so will result in a SOAPException being thrown.

        Callers should not rely on the element instance being renamed as is. Implementations could end up copying the content of the SOAPElement to a renamed instance.

        参数：
        newName - the new name for the Element.
        返回：
        The renamed Node
        抛出：
        SOAPException - if changing the name of this Element is not allowed.
        从以下版本开始：
        SAAJ 1.3

      • removeAttribute

        boolean removeAttribute(Name name)
        Removes the attribute with the specified name.
        参数：
        name - the Name object with the name of the attribute to be removed
        返回：
        true if the attribute was removed successfully; false if it was not
        另请参见：
        removeAttribute(javax.xml.namespace.QName)

      • removeAttribute

        boolean removeAttribute(QName qname)
        Removes the attribute with the specified qname.
        参数：
        qname - the QName object with the qname of the attribute to be removed
        返回：
        true if the attribute was removed successfully; false if it was not
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        removeAttribute(Name)

      • removeNamespaceDeclaration

        boolean removeNamespaceDeclaration(String prefix)
        Removes the namespace declaration corresponding to the given prefix.
        参数：
        prefix - a String giving the prefix for which to search
        返回：
        true if the namespace declaration was removed successfully; false if it was not

      • getChildElements

        Iterator getChildElements()
        Returns an Iterator over all the immediate child Nodes of this element. This includes javax.xml.soap.Text objects as well as SOAPElement objects.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        返回：
        an iterator with the content of this SOAPElement object

      • getChildElements

        Iterator getChildElements(Name name)
        Returns an Iterator over all the immediate child Nodes of this element with the specified name. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        参数：
        name - a Name object with the name of the child elements to be returned
        返回：
        an Iterator object over all the elements in this SOAPElement object with the specified name
        另请参见：
        getChildElements(javax.xml.namespace.QName)

      • getChildElements

        Iterator getChildElements(QName qname)
        Returns an Iterator over all the immediate child Nodes of this element with the specified qname. All of these children will be SOAPElement nodes.

        Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

        参数：
        qname - a QName object with the qname of the child elements to be returned
        返回：
        an Iterator object over all the elements in this SOAPElement object with the specified qname
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getChildElements(Name)

      • setEncodingStyle

        void setEncodingStyle(String encodingStyle)
                      throws SOAPException
        Sets the encoding style for this SOAPElement object to one specified.
        参数：
        encodingStyle - a String giving the encoding style
        抛出：
        IllegalArgumentException - if there was a problem in the encoding style being set.
        SOAPException - if setting the encodingStyle is invalid for this SOAPElement.
        另请参见：
        getEncodingStyle()

      • getEncodingStyle

        String getEncodingStyle()
        Returns the encoding style for this SOAPElement object.
        返回：
        a String giving the encoding style
        另请参见：
        setEncodingStyle(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SOAPElementFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

类 SOAPElementFactory

  • java.lang.Object
    • javax.xml.soap.SOAPElementFactory
  • Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.

    public class SOAPElementFactory
extends Object
    SOAPElementFactory is a factory for XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeader or SOAPBody or SOAPEnvelope.

    Elements created using this factory do not have the properties of an element that lives inside a SOAP header document. These elements are copied into the XML document tree when they are inserted.

    另请参见：
    SOAPFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPElement create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      static SOAPElementFactory newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • create

        public SOAPElement create(Name name)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
        Create a SOAPElement object initialized with the given Name object.
        参数：
        name - a Name object with the XML name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        另请参见：
        SOAPFactory.createElement(javax.xml.soap.Name), SOAPFactory.createElement(javax.xml.namespace.QName)

      • create

        public SOAPElement create(String localName)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
        Create a SOAPElement object initialized with the given local name.
        参数：
        localName - a String giving the local name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        另请参见：
        SOAPFactory.createElement(java.lang.String)

      • create

        public SOAPElement create(String localName,
                 String prefix,
                 String uri)
                   throws SOAPException
        Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
        Create a new SOAPElement object with the given local name, prefix and uri.
        参数：
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        另请参见：
        SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

      • newInstance

        public static SOAPElementFactory newInstance()
                                      throws SOAPException
        Deprecated.
        Creates a new instance of SOAPElementFactory.
        返回：
        a new instance of a SOAPElementFactory
        抛出：
        SOAPException - if there was an error creating the default SOAPElementFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mxl/al//l/.jj/../httpeipsh n> <


SOAPEnvelope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPEnvelope

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPEnvelope
extends SOAPElement
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object. By default, a SOAPMessage object is created with a SOAPPart object that has a SOAPEnvelope object. The SOAPEnvelope object by default has an empty SOAPBody object and an empty SOAPHeader object. The SOAPBody object is required, and the SOAPHeader object, though optional, is used in the majority of cases. If the SOAPHeader object is not needed, it can be deleted, which is shown later.

    A client can access the SOAPHeader and SOAPBody objects by calling the methods SOAPEnvelope.getHeader and SOAPEnvelope.getBody. The following lines of code use these two methods after starting with the SOAPMessage object message to get the SOAPPart object sp, which is then used to get the SOAPEnvelope object se.

         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPHeader sh = se.getHeader();
     SOAPBody sb = se.getBody();

    It is possible to change the body or header of a SOAPEnvelope object by retrieving the current one, deleting it, and then adding a new body or header. The javax.xml.soap.Node method deleteNode deletes the XML element (node) on which it is called. For example, the following line of code deletes the SOAPBody object that is retrieved by the method getBody.

          se.getBody().detachNode();
    To create a SOAPHeader object to replace the one that was removed, a client uses the method SOAPEnvelope.addHeader, which creates a new header and adds it to the SOAPEnvelope object. Similarly, the method addBody creates a new SOAPBody object and adds it to the SOAPEnvelope object. The following code fragment retrieves the current header, removes it, and adds a new one. Then it retrieves the current body, removes it, and adds a new one.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     se.getHeader().detachNode();
     SOAPHeader sh = se.addHeader();
     se.getBody().detachNode();
     SOAPBody sb = se.addBody();
    It is an error to add a SOAPBody or SOAPHeader object if one already exists.

    The SOAPEnvelope interface provides three methods for creating Name objects. One method creates Name objects with a local name, a namespace prefix, and a namesapce URI. The second method creates Name objects with a local name and a namespace prefix, and the third creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

         Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPBody addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPHeader addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      SOAPBody getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPHeader getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • createName

        Name createName(String localName,
              String prefix,
              String uri)
                throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in the SOAP/XML document.

        参数：
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        返回：
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        抛出：
        SOAPException - if there is a SOAP error

      • createName

        Name createName(String localName)
                throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in the SOAP/XML document.

        参数：
        localName - a String giving the local name
        返回：
        a Name object initialized with the given local name
        抛出：
        SOAPException - if there is a SOAP error

      • getHeader

        SOAPHeader getHeader()
                     throws SOAPException
        Returns the SOAPHeader object for this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPHeader object. As a result, the method getHeader will always return a SOAPHeader object unless the header has been removed and a new one has not been added.

        返回：
        the SOAPHeader object or null if there is none
        抛出：
        SOAPException - if there is a problem obtaining the SOAPHeader object

      • getBody

        SOAPBody getBody()
                 throws SOAPException
        Returns the SOAPBody object associated with this SOAPEnvelope object.

        A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPBody object. As a result, the method getBody will always return a SOAPBody object unless the body has been removed and a new one has not been added.

        返回：
        the SOAPBody object for this SOAPEnvelope object or null if there is none
        抛出：
        SOAPException - if there is a problem obtaining the SOAPBody object

      • addHeader

        SOAPHeader addHeader()
                     throws SOAPException
        Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

        It is illegal to add a header when the envelope already contains a header. Therefore, this method should be called only after the existing header has been removed.

        返回：
        the new SOAPHeader object
        抛出：
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPHeader object

      • addBody

        SOAPBody addBody()
                 throws SOAPException
        Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

        It is illegal to add a body when the envelope already contains a body. Therefore, this method should be called only after the existing body has been removed.

        返回：
        the new SOAPBody object
        抛出：
        SOAPException - if this SOAPEnvelope object already contains a valid SOAPBody object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ev


SOAPException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.soap.SOAPException
  • 所有已实现的接口：
    Serializable

    public class SOAPException
extends Exception
    An exception that signals that a SOAP exception has occurred. A SOAPException object may contain a String that gives the reason for the exception, an embedded Throwable object, or both. This class provides methods for retrieving reason messages and for retrieving the embedded Throwable object.

    Typical reasons for throwing a SOAPException object are problems such as difficulty setting a header, not being able to send a message, and not being able to get a connection with the provider. Reasons for embedding a Throwable object include problems such as input/output errors or a parsing problem, such as an error in parsing a header.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPException()
      Constructs a SOAPException object with no reason or embedded Throwable object.
      SOAPException(String reason)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown.
      SOAPException(String reason, Throwable cause)
      Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
      SOAPException(Throwable cause)
      Constructs a SOAPException object initialized with the given Throwable object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the Throwable object embedded in this SOAPException if there is one.
      String getMessage()
      Returns the detail message for this SOAPException object.
      Throwable initCause(Throwable cause)
      Initializes the cause field of this SOAPException object with the given Throwable object.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SOAPException

        public SOAPException()
        Constructs a SOAPException object with no reason or embedded Throwable object.

      • SOAPException

        public SOAPException(String reason)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown.
        参数：
        reason - a description of what caused the exception

      • SOAPException

        public SOAPException(String reason,
             Throwable cause)
        Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
        参数：
        reason - a description of what caused the exception
        cause - a Throwable object that is to be embedded in this SOAPException object

      • SOAPException

        public SOAPException(Throwable cause)
        Constructs a SOAPException object initialized with the given Throwable object.

    • 方法详细信息

      • getMessage

        public String getMessage()
        Returns the detail message for this SOAPException object.

        If there is an embedded Throwable object, and if the SOAPException object has no detail message of its own, this method will return the detail message from the embedded Throwable object.

        重载：
        getMessage in class Throwable
        返回：
        the error or warning message for this SOAPException or, if it has none, the message of the embedded Throwable object, if there is one

      • getCause

        public Throwable getCause()
        Returns the Throwable object embedded in this SOAPException if there is one. Otherwise, this method returns null.
        重载：
        getCause in class Throwable
        返回：
        the embedded Throwable object or null if there is none

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause field of this SOAPException object with the given Throwable object.

        This method can be called at most once. It is generally called from within the constructor or immediately after the constructor has returned a new SOAPException object. If this SOAPException object was created with the constructor SOAPException(Throwable) or SOAPException(String,Throwable), meaning that its cause field already has a value, this method cannot be called even once.

        重载：
        initCause in class Throwable
        参数：
        cause - the Throwable object that caused this SOAPException object to be thrown. The value of this parameter is saved for later retrieval by the getCause() method. A null value is permitted and indicates that the cause is nonexistent or unknown.
        返回：
        a reference to this SOAPException instance
        抛出：
        IllegalArgumentException - if cause is this Throwable object. (A Throwable object cannot be its own cause.)
        IllegalStateException - if the cause for this SOAPException object has already been initialized
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/,Seieviegttegggummd/tdegmho#(Pmreddo.. g/


SOAPFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPFactory

  • java.lang.Object
    • javax.xml.soap.SOAPFactory

  • public abstract class SOAPFactory
extends Object
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree. SOAPFactory can be used to create XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeaderElement or SOAPBodyElement or SOAPEnvelope or other SOAPElement objects. SOAPFactory also has methods to create javax.xml.soap.Detail objects as well as java.xml.soap.Name objects.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Detail createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract Name createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      static SOAPFactory newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SOAPFactory

        public SOAPFactory()

    • 方法详细信息

      • createElement

        public SOAPElement createElement(Element domElement)
                          throws SOAPException
        Creates a SOAPElement object from an existing DOM Element. If the DOM Element that is passed in as an argument is already a SOAPElement then this method must return it unmodified without any further work. Otherwise, a new SOAPElement is created and a deep copy is made of the domElement argument. The concrete type of the return value will depend on the name of the domElement argument. If any part of the tree rooted in domElement violates SOAP rules, a SOAPException will be thrown.
        参数：
        domElement - - the Element to be copied.
        返回：
        a new SOAPElement that is a copy of domElement.
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        从以下版本开始：
        SAAJ 1.3

      • createElement

        public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given Name object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        参数：
        name - a Name object with the XML name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        另请参见：
        createElement(javax.xml.namespace.QName)

      • createElement

        public SOAPElement createElement(QName qname)
                          throws SOAPException
        Creates a SOAPElement object initialized with the given QName object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        参数：
        qname - a QName object with the XML name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        createElement(Name)

      • createElement

        public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
        Creates a SOAPElement object initialized with the given local name.
        参数：
        localName - a String giving the local name for the new element
        返回：
        the new SOAPElement object that was created
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object

      • createElement

        public abstract SOAPElement createElement(String localName,
                        String prefix,
                        String uri)
                                   throws SOAPException
        Creates a new SOAPElement object with the given local name, prefix and uri. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.
        参数：
        localName - a String giving the local name for the new element
        prefix - the prefix for this SOAPElement
        uri - a String giving the URI of the namespace to which the new element belongs
        抛出：
        SOAPException - if there is an error in creating the SOAPElement object

      • createDetail

        public abstract Detail createDetail()
                             throws SOAPException
        Creates a new Detail object which serves as a container for DetailEntry objects.

        This factory method creates Detail objects for use in situations where it is not practical to use the SOAPFault abstraction.

        返回：
        a Detail object
        抛出：
        SOAPException - if there is a SOAP error
        UnsupportedOperationException - if the protocol specified for the SOAPFactory was DYNAMIC_SOAP_PROTOCOL

      • createFault

        public abstract SOAPFault createFault(String reasonText,
                    QName faultCode)
                               throws SOAPException
        Creates a new SOAPFault object initialized with the given reasonText and faultCode
        参数：
        reasonText - the ReasonText/FaultString for the fault
        faultCode - the FaultCode for the fault
        返回：
        a SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.3

      • createFault

        public abstract SOAPFault createFault()
                               throws SOAPException
        Creates a new default SOAPFault object
        返回：
        a SOAPFault object
        抛出：
        SOAPException - if there is a SOAP error
        从以下版本开始：
        SAAJ 1.3

      • createName

        public abstract Name createName(String localName,
              String prefix,
              String uri)
                         throws SOAPException
        Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        参数：
        localName - a String giving the local name
        prefix - a String giving the prefix of the namespace
        uri - a String giving the URI of the namespace
        返回：
        a Name object initialized with the given local name, namespace prefix, and namespace URI
        抛出：
        SOAPException - if there is a SOAP error

      • createName

        public abstract Name createName(String localName)
                         throws SOAPException
        Creates a new Name object initialized with the given local name.

        This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

        参数：
        localName - a String giving the local name
        返回：
        a Name object initialized with the given local name
        抛出：
        SOAPException - if there is a SOAP error

      • newInstance

        public static SOAPFactory newInstance()
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load:
        • Use the javax.xml.soap.SOAPFactory system property.
        • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.SOAPFactory in jars available to the runtime.
        • Use the SAAJMetaFactory instance to locate the SOAPFactory implementation class.
        返回：
        a new instance of a SOAPFactory
        抛出：
        SOAPException - if there was an error creating the default SOAPFactory
        另请参见：
        SAAJMetaFactory

      • newInstance

        public static SOAPFactory newInstance(String protocol)
                               throws SOAPException
        Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
        参数：
        protocol - a string constant representing the protocol of the specified SOAP factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
        返回：
        a new instance of a SOAPFactory
        抛出：
        SOAPException - if there was an error creating the specified SOAPFactory
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        SAAJMetaFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SOAPFault

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPFault

  • All Superinterfaces:
    Element, Node, SOAPBodyElement, SOAPElement

    public interface SOAPFault
extends SOAPBodyElement
    An element in the SOAPBody object that contains error and/or status information. This information may relate to errors in the SOAPMessage object or to problems that are not related to the content in the message itself. Problems not related to the message itself are generally errors in processing, such as the inability to communicate with an upstream server.

    Depending on the protocol specified while creating the MessageFactory instance, a SOAPFault has sub-elements as defined in the SOAP 1.1/SOAP 1.2 specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Detail addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      void addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      void appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      Detail getDetail()
      Returns the optional detail element for this SOAPFault object.
      String getFaultActor()
      Gets the fault actor for this SOAPFault object.
      String getFaultCode()
      Gets the fault code for this SOAPFault object.
      Name getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      QName getFaultCodeAsQName()
      Gets the fault code for this SOAPFault object as a QName object.
      String getFaultNode()
      Returns the optional Node element value for this SOAPFault object.
      Iterator getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      String getFaultRole()
      Returns the optional Role element value for this SOAPFault object.
      String getFaultString()
      Gets the fault string for this SOAPFault object.
      Locale getFaultStringLocale()
      Gets the locale of the fault string for this SOAPFault object.
      Iterator getFaultSubcodes()
      Gets the Subcodes for this SOAPFault as an iterator over QNames.
      boolean hasDetail()
      Returns true if this SOAPFault has a Detail subelement and false otherwise.
      void removeAllFaultSubcodes()
      Removes any Subcodes that may be contained by this SOAPFault.
      void setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • setFaultCode

        void setFaultCode(Name faultCodeQName)
                  throws SOAPException
        Sets this SOAPFault object with the given fault code.

        Fault codes, which give information about the fault, are defined in the SOAP 1.1 specification. A fault code is mandatory and must be of type Name. This method provides a convenient way to set a fault code. For example,

         SOAPEnvelope se = ...;
 // Create a qualified name in the SOAP namespace with a localName
 // of "Client". Note that prefix parameter is optional and is null
 // here which causes the implementation to use an appropriate prefix.
 Name qname = se.createName("Client", null,
                            SOAPConstants.URI_NS_SOAP_ENVELOPE);
 SOAPFault fault = ...;
 fault.setFaultCode(qname);
        It is preferable to use this method over setFaultCode(String).
        参数：
        faultCodeQName - a Name object giving the fault code to be set. It must be namespace qualified.
        抛出：
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        getFaultCodeAsName()

      • setFaultCode

        void setFaultCode(QName faultCodeQName)
                  throws SOAPException
        Sets this SOAPFault object with the given fault code. It is preferable to use this method over setFaultCode(Name).
        参数：
        faultCodeQName - a QName object giving the fault code to be set. It must be namespace qualified.
        抛出：
        SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getFaultCodeAsQName(), setFaultCode(Name), getFaultCodeAsQName()

      • setFaultCode

        void setFaultCode(String faultCode)
                  throws SOAPException
        Sets this SOAPFault object with the give fault code.

        Fault codes, which given information about the fault, are defined in the SOAP 1.1 specification. This element is mandatory in SOAP 1.1. Because the fault code is required to be a QName it is preferable to use the setFaultCode(Name) form of this method.

        参数：
        faultCode - a String giving the fault code to be set. It must be of the form "prefix:localName" where the prefix has been defined in a namespace declaration.
        抛出：
        SOAPException - if there was an error in adding the faultCode to the underlying XML tree.
        另请参见：
        setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

      • getFaultCodeAsName

        Name getFaultCodeAsName()
        Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object. The SOAP 1.1 specification requires the value of the "faultcode" element to be of type QName. This method returns the content of the element as a QName in the form of a SAAJ Name object. This method should be used instead of the getFaultCode method since it allows applications to easily access the namespace name without additional parsing.
        返回：
        a Name representing the faultcode
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        setFaultCode(Name)

      • getFaultCodeAsQName

        QName getFaultCodeAsQName()
        Gets the fault code for this SOAPFault object as a QName object.
        返回：
        a QName representing the faultcode
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        setFaultCode(QName)

      • getFaultSubcodes

        Iterator getFaultSubcodes()
        Gets the Subcodes for this SOAPFault as an iterator over QNames.
        返回：
        an Iterator that accesses a sequence of QNames. This Iterator should not support the optional remove method. The order in which the Subcodes are returned reflects the hierarchy of Subcodes present in the fault from top to bottom.
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        从以下版本开始：
        SAAJ 1.3

      • removeAllFaultSubcodes

        void removeAllFaultSubcodes()
        Removes any Subcodes that may be contained by this SOAPFault. Subsequent calls to getFaultSubcodes will return an empty iterator until a call to appendFaultSubcode is made.
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        从以下版本开始：
        SAAJ 1.3

      • appendFaultSubcode

        void appendFaultSubcode(QName subcode)
                        throws SOAPException
        Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault. Subcodes, which were introduced in SOAP 1.2, are represented by a recursive sequence of subelements rooted in the mandatory Code subelement of a SOAP Fault.
        参数：
        subcode - a QName containing the Value of the Subcode.
        抛出：
        SOAPException - if there was an error in setting the Subcode
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
        从以下版本开始：
        SAAJ 1.3

      • getFaultCode

        String getFaultCode()
        Gets the fault code for this SOAPFault object.
        返回：
        a String with the fault code
        另请参见：
        getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

      • setFaultActor

        void setFaultActor(String faultActor)
                   throws SOAPException
        Sets this SOAPFault object with the given fault actor.

        The fault actor is the recipient in the message path who caused the fault to happen.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to setFaultRole(String)

        参数：
        faultActor - a String identifying the actor that caused this SOAPFault object
        抛出：
        SOAPException - if there was an error in adding the faultActor to the underlying XML tree.
        另请参见：
        getFaultActor()

      • getFaultActor

        String getFaultActor()
        Gets the fault actor for this SOAPFault object.

        If this SOAPFault supports SOAP 1.2 then this call is equivalent to getFaultRole()

        返回：
        a String giving the actor in the message path that caused this SOAPFault object
        另请参见：
        setFaultActor(java.lang.String)

      • setFaultString

        void setFaultString(String faultString)
                    throws SOAPException
        Sets the fault string for this SOAPFault object to the given string.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, Locale.getDefault());
        参数：
        faultString - a String giving an explanation of the fault
        抛出：
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        另请参见：
        getFaultString()

      • setFaultString

        void setFaultString(String faultString,
                  Locale locale)
                    throws SOAPException
        Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

              addFaultReasonText(faultString, locale);
        参数：
        faultString - a String giving an explanation of the fault
        locale - a Locale object indicating the native language of the faultString
        抛出：
        SOAPException - if there was an error in adding the faultString to the underlying XML tree.
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        getFaultString()

      • getFaultString

        String getFaultString()
        Gets the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            String reason = null;
    try {
        reason = (String) getFaultReasonTexts().next();
    } catch (SOAPException e) {}
    return reason;
        返回：
        a String giving an explanation of the fault
        另请参见：
        setFaultString(String), setFaultString(String, Locale)

      • getFaultStringLocale

        Locale getFaultStringLocale()
        Gets the locale of the fault string for this SOAPFault object.

        If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

            Locale locale = null;
    try {
        locale = (Locale) getFaultReasonLocales().next();
    } catch (SOAPException e) {}
    return locale;
        返回：
        a Locale object indicating the native language of the fault string or null if no locale was specified
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        setFaultString(String, Locale)

      • hasDetail

        boolean hasDetail()
        Returns true if this SOAPFault has a Detail subelement and false otherwise. Equivalent to (getDetail()!=null).
        返回：
        true if this SOAPFault has a Detail subelement and false otherwise.
        从以下版本开始：
        SAAJ 1.3

      • getDetail

        Detail getDetail()
        Returns the optional detail element for this SOAPFault object.

        A Detail object carries application-specific error information, the scope of the error information is restricted to faults in the SOAPBodyElement objects if this is a SOAP 1.1 Fault.

        返回：
        a Detail object with application-specific error information if present, null otherwise

      • addDetail

        Detail addDetail()
                 throws SOAPException
        Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

        It is illegal to add a detail when the fault already contains a detail. Therefore, this method should be called only after the existing detail has been removed.

        返回：
        the new Detail object
        抛出：
        SOAPException - if this SOAPFault object already contains a valid Detail object

      • getFaultReasonLocales

        Iterator getFaultReasonLocales()
                               throws SOAPException
        Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items. Any of these Locales can be used in a call to getFaultReasonText in order to obtain a localized version of the Reason Text string.
        返回：
        an Iterator over a sequence of Locale objects for which there are associated Reason Text items.
        抛出：
        SOAPException - if there was an error in retrieving the fault Reason locales.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        从以下版本开始：
        SAAJ 1.3

      • getFaultReasonTexts

        Iterator getFaultReasonTexts()
                             throws SOAPException
        Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
        返回：
        an Iterator over env:Fault/env:Reason/env:Text items.
        抛出：
        SOAPException - if there was an error in retrieving the fault Reason texts.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        从以下版本开始：
        SAAJ 1.3

      • getFaultReasonText

        String getFaultReasonText(Locale locale)
                          throws SOAPException
        Returns the Reason Text associated with the given Locale. If more than one such Reason Text exists the first matching Text is returned
        参数：
        locale - -- the Locale for which a localized Reason Text is desired
        返回：
        the Reason Text associated with locale
        抛出：
        SOAPException - if there was an error in retrieving the fault Reason text for the specified locale .
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getFaultString()

      • addFaultReasonText

        void addFaultReasonText(String text,
                      Locale locale)
                        throws SOAPException
        Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale. If a Reason Text item with this xml:lang already exists its text value will be replaced with text. The locale parameter should not be null

        Code sample:

         SOAPFault fault = ...;
 fault.addFaultReasonText("Version Mismatch", Locale.ENGLISH);
        参数：
        text - -- reason message string
        locale - -- Locale object representing the locale of the message
        抛出：
        SOAPException - if there was an error in adding the Reason text or the locale passed was null.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
        从以下版本开始：
        SAAJ 1.3

      • getFaultNode

        String getFaultNode()
        Returns the optional Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        返回：
        Content of the env:Fault/env:Node element as a String or null if none
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        从以下版本开始：
        SAAJ 1.3

      • setFaultNode

        void setFaultNode(String uri)
                  throws SOAPException
        Creates or replaces any existing Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.
        抛出：
        SOAPException - if there was an error in setting the Node for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
        从以下版本开始：
        SAAJ 1.3

      • getFaultRole

        String getFaultRole()
        Returns the optional Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        返回：
        Content of the env:Fault/env:Role element as a String or null if none
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        从以下版本开始：
        SAAJ 1.3

      • setFaultRole

        void setFaultRole(String uri)
                  throws SOAPException
        Creates or replaces any existing Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.
        参数：
        uri - - the URI of the Role
        抛出：
        SOAPException - if there was an error in setting the Role for this SOAPFault object.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        从以下版本开始：
        SAAJ 1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dp


SOAPFaultElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.soap

Interface SOAPFaultElement

  • All Superinterfaces:
    Element, Node, SOAPElement
    All Known Subinterfaces:
    Detail

    public interface SOAPFaultElement
extends SOAPElement
    A representation of the contents in a SOAPFault object. The Detail interface is a SOAPFaultElement.

    Content is added to a SOAPFaultElement using the SOAPElement method addTextNode.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;mjrmi i dff ddeh<


SOAPHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPHeader

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeader
extends SOAPElement
    A representation of the SOAP header element. A SOAP header element consists of XML data that affects the way the application-specific content is processed by the message provider. For example, transaction semantics, authentication information, and so on, can be specified as the content of a SOAPHeader object.

    A SOAPEnvelope object contains an empty SOAPHeader object by default. If the SOAPHeader object, which is optional, is not needed, it can be retrieved and deleted with the following line of code. The variable se is a SOAPEnvelope object.

          se.getHeader().detachNode();
    A SOAPHeader object is created with the SOAPEnvelope method addHeader. This method, which creates a new header and adds it to the envelope, may be called only after the existing header has been removed.
          se.getHeader().detachNode();
      SOAPHeader sh = se.addHeader();

    A SOAPHeader object can have only SOAPHeaderElement objects as its immediate children. The method addHeaderElement creates a new HeaderElement object and adds it to the SOAPHeader object. In the following line of code, the argument to the method addHeaderElement is a Name object that is the name for the new HeaderElement object.

          SOAPHeaderElement shElement = sh.addHeaderElement(name);
    另请参见：
    SOAPHeaderElement

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPHeaderElement addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      Iterator examineAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
      Iterator examineHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
      Iterator examineMustUnderstandHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
      Iterator extractAllHeaderElements()
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
      Iterator extractHeaderElements(String actor)
      Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(Name name)
                                   throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
        参数：
        name - a Name object with the name of the new SOAPHeaderElement object
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs
        另请参见：
        addHeaderElement(javax.xml.namespace.QName)

      • addHeaderElement

        SOAPHeaderElement addHeaderElement(QName qname)
                                   throws SOAPException
        Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
        参数：
        qname - a QName object with the qname of the new SOAPHeaderElement object
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        addHeaderElement(Name)

      • examineMustUnderstandHeaderElements

        Iterator examineMustUnderstandHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        参数：
        actor - a String giving the URI of the actor / role for which to search
        返回：
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role and are marked as MustUnderstand
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • examineHeaderElements

        Iterator examineHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor. An actor is a global attribute that indicates the intermediate parties that should process a message before it reaches its ultimate receiver. An actor receives the message and processes it before sending it on to the next actor. The default actor is the ultimate intended recipient for the message, so if no actor attribute is included in a SOAPHeader object, it is sent to the ultimate receiver along with the message body.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        参数：
        actor - a String giving the URI of the actor / role for which to search
        返回：
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        另请参见：
        extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • extractHeaderElements

        Iterator extractHeaderElements(String actor)
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

        This method allows an actor to process the parts of the SOAPHeader object that apply to it and to remove them before passing the message on to the next actor.

        In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

        参数：
        actor - a String giving the URI of the actor / role for which to search
        返回：
        an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
        另请参见：
        examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

      • addNotUnderstoodHeaderElement

        SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
                                                throws SOAPException
        Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object. This operation is supported only by SOAP 1.2.
        参数：
        name - a QName object with the name of the SOAPHeaderElement object that was not understood.
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs.
        UnsupportedOperationException - if this is a SOAP 1.1 Header.
        从以下版本开始：
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        参数：
        supportedSOAPURIs - an Iterator object with the URIs of SOAP versions supported.
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs.
        从以下版本开始：
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        参数：
        supportedSoapUris - an array of the URIs of SOAP versions supported.
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs.
        从以下版本开始：
        SAAJ 1.3

      • addUpgradeHeaderElement

        SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
                                          throws SOAPException
        Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.
        参数：
        supportedSoapUri - the URI of SOAP the version that is supported.
        返回：
        the new SOAPHeaderElement object that was inserted into this SOAPHeader object
        抛出：
        SOAPException - if a SOAP error occurs.
        从以下版本开始：
        SAAJ 1.3

      • examineAllHeaderElements

        Iterator examineAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
        返回：
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        extractAllHeaderElements()

      • extractAllHeaderElements

        Iterator extractAllHeaderElements()
        Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
        返回：
        an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        examineAllHeaderElements()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


SOAPHeaderElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface SOAPHeaderElement

  • All Superinterfaces:
    Element, Node, SOAPElement

    public interface SOAPHeaderElement
extends SOAPElement
    An object representing the contents in the SOAP header part of the SOAP envelope. The immediate children of a SOAPHeader object can be represented only as SOAPHeaderElement objects.

    A SOAPHeaderElement object can have other SOAPElement objects as its children.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getActor()
      Returns the uri of the actor attribute of this SOAPHeaderElement.
      boolean getMustUnderstand()
      Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
      boolean getRelay()
      Returns the boolean value of the relay attribute for this SOAPHeaderElement
      String getRole()
      Returns the value of the Role attribute of this SOAPHeaderElement.
      void setActor(String actorURI)
      Sets the actor associated with this SOAPHeaderElement object to the specified actor.
      void setMustUnderstand(boolean mustUnderstand)
      Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.
      void setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.

      • 方法 - 继承于接口 javax.xml.soap.SOAPElement

        addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Element

        getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • setActor

        void setActor(String actorURI)
        Sets the actor associated with this SOAPHeaderElement object to the specified actor. The default value of an actor is: SOAPConstants.URI_SOAP_ACTOR_NEXT

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to setRole(String)

        参数：
        actorURI - a String giving the URI of the actor to set
        抛出：
        IllegalArgumentException - if there is a problem in setting the actor.
        另请参见：
        getActor()

      • setRole

        void setRole(String uri)
             throws SOAPException
        Sets the Role associated with this SOAPHeaderElement object to the specified Role.
        参数：
        uri - - the URI of the Role
        抛出：
        SOAPException - if there is an error in setting the role
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        从以下版本开始：
        SAAJ 1.3

      • getActor

        String getActor()
        Returns the uri of the actor attribute of this SOAPHeaderElement.

        If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to getRole()

        返回：
        a String giving the URI of the actor
        另请参见：
        setActor(java.lang.String)

      • getRole

        String getRole()
        Returns the value of the Role attribute of this SOAPHeaderElement.
        返回：
        a String giving the URI of the Role
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
        从以下版本开始：
        SAAJ 1.3

      • setMustUnderstand

        void setMustUnderstand(boolean mustUnderstand)
        Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

        If the mustUnderstand attribute is on, the actor who receives the SOAPHeaderElement must process it correctly. This ensures, for example, that if the SOAPHeaderElement object modifies the message, that the message is being modified correctly.

        参数：
        mustUnderstand - true to set the mustUnderstand attribute to true; false to set it to false
        抛出：
        IllegalArgumentException - if there is a problem in setting the mustUnderstand attribute
        另请参见：
        getMustUnderstand(), setRelay(boolean)

      • getMustUnderstand

        boolean getMustUnderstand()
        Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
        返回：
        true if the mustUnderstand attribute of this SOAPHeaderElement object is turned on; false otherwise

      • setRelay

        void setRelay(boolean relay)
              throws SOAPException
        Sets the relay attribute for this SOAPHeaderElement to be either true or false.

        The SOAP relay attribute is set to true to indicate that the SOAP header block must be relayed by any node that is targeted by the header block but not actually process it. This attribute is ignored on header blocks whose mustUnderstand attribute is set to true or that are targeted at the ultimate reciever (which is the default). The default value of this attribute is false.

        参数：
        relay - the new value of the relay attribute
        抛出：
        SOAPException - if there is a problem in setting the relay attribute.
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        setMustUnderstand(boolean), getRelay()

      • getRelay

        boolean getRelay()
        Returns the boolean value of the relay attribute for this SOAPHeaderElement
        返回：
        true if the relay attribute is turned on; false otherwise
        抛出：
        UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
        从以下版本开始：
        SAAJ 1.3
        另请参见：
        getMustUnderstand(), setRelay(boolean)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"lspoodcc


SOAPMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPMessage

  • java.lang.Object
    • javax.xml.soap.SOAPMessage

  • public abstract class SOAPMessage
extends Object
    The root class for all SOAP messages. As transmitted on the "wire", a SOAP message is an XML document or a MIME message whose first body part is an XML/SOAP document.

    A SOAPMessage object consists of a SOAP part and optionally one or more attachment parts. The SOAP part for a SOAPMessage object is a SOAPPart object, which contains information used for message routing and identification, and which can contain application-specific content. All data in the SOAP Part of a message must be in XML format.

    A new SOAPMessage object contains the following by default:

    • A SOAPPart object
    • A SOAPEnvelope object
    • A SOAPBody object
    • A SOAPHeader object
    The SOAP part of a message can be retrieved by calling the method SOAPMessage.getSOAPPart(). The SOAPEnvelope object is retrieved from the SOAPPart object, and the SOAPEnvelope object is used to retrieve the SOAPBody and SOAPHeader objects.
         SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPBody sb = se.getBody();
     SOAPHeader sh = se.getHeader();

    In addition to the mandatory SOAPPart object, a SOAPMessage object may contain zero or more AttachmentPart objects, each of which contains application-specific data. The SOAPMessage interface provides methods for creating AttachmentPart objects and also for adding them to a SOAPMessage object. A party that has received a SOAPMessage object can examine its contents by retrieving individual attachment parts.

    Unlike the rest of a SOAP message, an attachment is not required to be in XML format and can therefore be anything from simple text to an image file. Consequently, any message content that is not in XML format must be in an AttachmentPart object.

    A MessageFactory object may create SOAPMessage objects with behavior that is specialized to a particular implementation or application of SAAJ. For instance, a MessageFactory object may produce SOAPMessage objects that conform to a particular Profile such as ebXML. In this case a MessageFactory object might produce SOAPMessage objects that are initialized with ebXML headers.

    In order to ensure backward source compatibility, methods that are added to this class after version 1.1 of the SAAJ specification are all concrete instead of abstract and they all have default implementations. Unless otherwise noted in the JavaDocs for those methods the default implementations simply throw an UnsupportedOperationException and the SAAJ implementation code must override them with methods that provide the specified behavior. Legacy client code does not have this restriction, however, so long as there is no claim made that it conforms to some later version of the specification than it was originally written for. A legacy class that extends the SOAPMessage class can be compiled and/or run against succeeding versions of the SAAJ API without modification. If such a class was correctly implemented then it will continue to behave correctly relative to the version of the specification against which it was written.

    另请参见：
    MessageFactory, AttachmentPart

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CHARACTER_SET_ENCODING
      Specifies the character type encoding for the SOAP Message.
      static String WRITE_XML_DECLARATION
      Specifies whether the SOAP Message will contain an XML declaration when it is sent.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPMessage()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
      abstract int countAttachments()
      Gets a count of the number of attachments in this message.
      abstract AttachmentPart createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract Iterator getAttachments()
      Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
      abstract Iterator getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract String getContentDescription()
      Retrieves a description of this SOAPMessage object's content.
      abstract MimeHeaders getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Object getProperty(String property)
      Retrieves value of the specified property.
      SOAPBody getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      abstract SOAPPart getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
      abstract void removeAllAttachments()
      Removes all AttachmentPart objects that have been added to this SOAPMessage object.
      abstract void removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract boolean saveRequired()
      Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
      abstract void setContentDescription(String description)
      Sets the description of this SOAPMessage object's content with the given description.
      void setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • CHARACTER_SET_ENCODING

        public static final String CHARACTER_SET_ENCODING
        Specifies the character type encoding for the SOAP Message. Valid values include "utf-8" and "utf-16". See vendor documentation for additional supported values. The default is "utf-8".
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        SOAPMessage.setProperty, Constant Field Values

      • WRITE_XML_DECLARATION

        public static final String WRITE_XML_DECLARATION
        Specifies whether the SOAP Message will contain an XML declaration when it is sent. The only valid values are "true" and "false". The default is "false".
        从以下版本开始：
        SAAJ 1.2
        另请参见：
        SOAPMessage.setProperty, Constant Field Values

    • 构造方法详细信息

      • SOAPMessage

        public SOAPMessage()

    • 方法详细信息

      • setContentDescription

        public abstract void setContentDescription(String description)
        Sets the description of this SOAPMessage object's content with the given description.
        参数：
        描述 - a String describing the content of this message
        另请参见：
        getContentDescription()

      • getContentDescription

        public abstract String getContentDescription()
        Retrieves a description of this SOAPMessage object's content.
        返回：
        a String describing the content of this message or null if no description has been set
        另请参见：
        setContentDescription(java.lang.String)

      • getSOAPPart

        public abstract SOAPPart getSOAPPart()
        Gets the SOAP part of this SOAPMessage object.

        SOAPMessage object contains one or more attachments, the SOAP Part must be the first MIME body part in the message.

        返回：
        the SOAPPart object for this SOAPMessage object

      • getSOAPBody

        public SOAPBody getSOAPBody()
                     throws SOAPException
        Gets the SOAP Body contained in this SOAPMessage object.

        返回：
        the SOAPBody object contained by this SOAPMessage object
        抛出：
        SOAPException - if the SOAP Body does not exist or cannot be retrieved
        从以下版本开始：
        SAAJ 1.2

      • getSOAPHeader

        public SOAPHeader getSOAPHeader()
                         throws SOAPException
        Gets the SOAP Header contained in this SOAPMessage object.

        返回：
        the SOAPHeader object contained by this SOAPMessage object
        抛出：
        SOAPException - if the SOAP Header does not exist or cannot be retrieved
        从以下版本开始：
        SAAJ 1.2

      • removeAllAttachments

        public abstract void removeAllAttachments()
        Removes all AttachmentPart objects that have been added to this SOAPMessage object.

        This method does not touch the SOAP part.

      • countAttachments

        public abstract int countAttachments()
        Gets a count of the number of attachments in this message. This count does not include the SOAP part.
        返回：
        the number of AttachmentPart objects that are part of this SOAPMessage object

      • getAttachments

        public abstract Iterator getAttachments()
        Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
        返回：
        an iterator over all the attachments in this message

      • getAttachments

        public abstract Iterator getAttachments(MimeHeaders headers)
        Retrieves all the AttachmentPart objects that have header entries that match the specified headers. Note that a returned attachment could have headers in addition to those specified.
        参数：
        headers - a MimeHeaders object containing the MIME headers for which to search
        返回：
        an iterator over all attachments that have a header that matches one of the given headers

      • removeAttachments

        public abstract void removeAttachments(MimeHeaders headers)
        Removes all the AttachmentPart objects that have header entries that match the specified headers. Note that the removed attachment could have headers in addition to those specified.
        参数：
        headers - a MimeHeaders object containing the MIME headers for which to search
        从以下版本开始：
        SAAJ 1.3

      • getAttachment

        public abstract AttachmentPart getAttachment(SOAPElement element)
                                      throws SOAPException
        Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists. References can be made via an href attribute as described in SOAP Messages with Attachments, or via a single Text child node containing a URI as described in the WS-I Attachments Profile 1.0 for elements of schema type ref:swaRef(ref:swaRef). These two mechanisms must be supported. The support for references via href attribute also implies that this method should also be supported on an element that is an xop:Include element ( XOP). other reference mechanisms may be supported by individual implementations of this standard. Contact your vendor for details.
        参数：
        element - The SOAPElement containing the reference to an Attachment
        返回：
        the referenced AttachmentPart or null if no such AttachmentPart exists or no reference can be found in this SOAPElement.
        抛出：
        SOAPException - if there is an error in the attempt to access the attachment
        从以下版本开始：
        SAAJ 1.3

      • addAttachmentPart

        public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
        Adds the given AttachmentPart object to this SOAPMessage object. An AttachmentPart object must be created before it can be added to a message.
        参数：
        AttachmentPart - an AttachmentPart object that is to become part of this SOAPMessage object
        抛出：
        IllegalArgumentException

      • createAttachmentPart

        public abstract AttachmentPart createAttachmentPart()
        Creates a new empty AttachmentPart object. Note that the method addAttachmentPart must be called with this new AttachmentPart object as the parameter in order for it to become an attachment to this SOAPMessage object.
        返回：
        a new AttachmentPart object that can be populated and added to this SOAPMessage object

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(DataHandler dataHandler)
        Creates an AttachmentPart object and populates it using the given DataHandler object.
        参数：
        dataHandler - the javax.activation.DataHandler object that will generate the content for this SOAPMessage object
        返回：
        a new AttachmentPart object that contains data generated by the given DataHandler object
        抛出：
        IllegalArgumentException - if there was a problem with the specified DataHandler object
        另请参见：
        DataHandler, DataContentHandler

      • getMimeHeaders

        public abstract MimeHeaders getMimeHeaders()
        Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
        返回：
        a MimeHeaders object containing the MimeHeader objects

      • createAttachmentPart

        public AttachmentPart createAttachmentPart(Object content,
                                  String contentType)
        Creates an AttachmentPart object and populates it with the specified data of the specified content type. The type of the Object should correspond to the value given for the Content-Type.
        参数：
        content - an Object containing the content for the AttachmentPart object to be created
        contentType - a String object giving the type of content; examples are "text/xml", "text/plain", and "image/jpeg"
        返回：
        a new AttachmentPart object that contains the given data
        抛出：
        IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for the given content object
        另请参见：
        DataHandler, DataContentHandler

      • saveChanges

        public abstract void saveChanges()
                          throws SOAPException
        Updates this SOAPMessage object with all the changes that have been made to it. This method is called automatically when writeTo(OutputStream) is called. However, if changes are made to a message that was received or to one that has already been sent, the method saveChanges needs to be called explicitly in order to save the changes. The method saveChanges also generates any changes that can be read back (for example, a MessageId in profiles that support a message id). All MIME headers in a message that is created for sending purposes are guaranteed to have valid values only after saveChanges has been called.

        In addition, this method marks the point at which the data from all constituent AttachmentPart objects are pulled into the message.

        抛出：
        SOAPException - if there was a problem saving changes to this message.
        SOAPException

      • saveRequired

        public abstract boolean saveRequired()
        Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
        返回：
        true if saveChanges needs to be called; false otherwise.

      • writeTo

        public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
        Writes this SOAPMessage object to the given output stream. The externalization format is as defined by the SOAP 1.1 with Attachments specification.

        If there are no attachments, just an XML stream is written out. For those messages that have attachments, writeTo writes a MIME-encoded byte stream.

        Note that this method does not write the transport-specific MIME Headers of the Message

        参数：
        out - the OutputStream object to which this SOAPMessage object will be written
        抛出：
        IOException - if an I/O error occurs
        SOAPException - if there was a problem in externalizing this SOAP message

      • setProperty

        public void setProperty(String property,
               Object value)
                 throws SOAPException
        Associates the specified value with the specified property. If there was already a value associated with this property, the old value is replaced.

        The valid property names include WRITE_XML_DECLARATION and CHARACTER_SET_ENCODING. All of these standard SAAJ properties are prefixed by "javax.xml.soap". Vendors may also add implementation specific properties. These properties must be prefixed with package names that are unique to the vendor.

        Setting the property WRITE_XML_DECLARATION to "true" will cause an XML Declaration to be written out at the start of the SOAP message. The default value of "false" suppresses this declaration.

        The property CHARACTER_SET_ENCODING defaults to the value "utf-8" which causes the SOAP message to be encoded using UTF-8. Setting CHARACTER_SET_ENCODING to "utf-16" causes the SOAP message to be encoded using UTF-16.

        Some implementations may allow encodings in addition to UTF-8 and UTF-16. Refer to your vendor's documentation for details.

        参数：
        property - the property with which the specified value is to be associated.
        value - the value to be associated with the specified property
        抛出：
        SOAPException - if the property name is not recognized.
        从以下版本开始：
        SAAJ 1.2

      • getProperty

        public Object getProperty(String property)
                   throws SOAPException
        Retrieves value of the specified property.
        参数：
        property - the name of the property to retrieve
        返回：
        the value associated with the named property or null if no such property exists.
        抛出：
        SOAPException - if the property name is not recognized.
        从以下版本开始：
        SAAJ 1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SOAPPart

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.soap

类 SOAPPart

  • java.lang.Object
    • javax.xml.soap.SOAPPart
  • 所有已实现的接口：
    Document, Node

    public abstract class SOAPPart
extends Object
implements Document, Node
    The container for the SOAP-specific portion of a SOAPMessage object. All messages are required to have a SOAP part, so when a SOAPMessage object is created, it will automatically have a SOAPPart object.

    A SOAPPart object is a MIME part and has the MIME headers Content-Id, Content-Location, and Content-Type. Because the value of Content-Type must be "text/xml", a SOAPPart object automatically has a MIME header of Content-Type with its value set to "text/xml". The value must be "text/xml" because content in the SOAP part of a message must be in XML format. Content that is not of type "text/xml" must be in an AttachmentPart object rather than in the SOAPPart object.

    When a message is sent, its SOAP part must have the MIME header Content-Type set to "text/xml". Or, from the other perspective, the SOAP part of any message that is received must have the MIME header Content-Type with a value of "text/xml".

    A client can access the SOAPPart object of a SOAPMessage object by calling the method SOAPMessage.getSOAPPart. The following line of code, in which message is a SOAPMessage object, retrieves the SOAP part of a message.

       SOAPPart soapPart = message.getSOAPPart();

    A SOAPPart object contains a SOAPEnvelope object, which in turn contains a SOAPBody object and a SOAPHeader object. The SOAPPart method getEnvelope can be used to retrieve the SOAPEnvelope object.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPPart()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addMimeHeader(String name, String value)
      Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
      abstract Iterator getAllMimeHeaders()
      Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
      abstract Source getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      String getContentId()
      Retrieves the value of the MIME header whose name is "Content-Id".
      String getContentLocation()
      Retrieves the value of the MIME header whose name is "Content-Location".
      abstract SOAPEnvelope getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      abstract Iterator getMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects that match a name in the given array.
      abstract String[] getMimeHeader(String name)
      Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
      abstract Iterator getNonMatchingMimeHeaders(String[] names)
      Retrieves all MimeHeader objects whose name does not match a name in the given array.
      abstract void removeAllMimeHeaders()
      Removes all the MimeHeader objects for this SOAPEnvelope object.
      abstract void removeMimeHeader(String header)
      Removes all MIME headers that match the given name.
      abstract void setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      void setContentId(String contentId)
      Sets the value of the MIME header named "Content-Id" to the given String.
      void setContentLocation(String contentLocation)
      Sets the value of the MIME header "Content-Location" to the given String.
      abstract void setMimeHeader(String name, String value)
      Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.w3c.dom.Document

        adoptNode, createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getDocumentURI, getDomConfig, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, getInputEncoding, getStrictErrorChecking, getXmlEncoding, getXmlStandalone, getXmlVersion, importNode, normalizeDocument, renameNode, setDocumentURI, setStrictErrorChecking, setXmlStandalone, setXmlVersion

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 构造方法详细信息

      • SOAPPart

        public SOAPPart()

    • 方法详细信息

      • getEnvelope

        public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
        Gets the SOAPEnvelope object associated with this SOAPPart object. Once the SOAP envelope is obtained, it can be used to get its contents.
        返回：
        the SOAPEnvelope object for this SOAPPart object
        抛出：
        SOAPException - if there is a SOAP error

      • getContentId

        public String getContentId()
        Retrieves the value of the MIME header whose name is "Content-Id".
        返回：
        a String giving the value of the MIME header named "Content-Id"
        另请参见：
        setContentId(java.lang.String)

      • getContentLocation

        public String getContentLocation()
        Retrieves the value of the MIME header whose name is "Content-Location".
        返回：
        a String giving the value of the MIME header whose name is "Content-Location"
        另请参见：
        setContentLocation(java.lang.String)

      • setContentId

        public void setContentId(String contentId)
        Sets the value of the MIME header named "Content-Id" to the given String.
        参数：
        contentId - a String giving the value of the MIME header "Content-Id"
        抛出：
        IllegalArgumentException - if there is a problem in setting the content id
        另请参见：
        getContentId()

      • setContentLocation

        public void setContentLocation(String contentLocation)
        Sets the value of the MIME header "Content-Location" to the given String.
        参数：
        contentLocation - a String giving the value of the MIME header "Content-Location"
        抛出：
        IllegalArgumentException - if there is a problem in setting the content location.
        另请参见：
        getContentLocation()

      • removeMimeHeader

        public abstract void removeMimeHeader(String header)
        Removes all MIME headers that match the given name.
        参数：
        header - a String giving the name of the MIME header(s) to be removed

      • removeAllMimeHeaders

        public abstract void removeAllMimeHeaders()
        Removes all the MimeHeader objects for this SOAPEnvelope object.

      • getMimeHeader

        public abstract String[] getMimeHeader(String name)
        Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
        参数：
        name - the name of the header; example: "Content-Type"
        返回：
        a String array giving all the values for the specified header
        另请参见：
        setMimeHeader(java.lang.String, java.lang.String)

      • setMimeHeader

        public abstract void setMimeHeader(String name,
                 String value)
        Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match. If there is a match, this method clears all existing values for the first header that matches and sets the given value instead. If more than one header has the given name, this method removes all of the matching headers after the first one.

        Note that RFC822 headers can contain only US-ASCII characters.

        参数：
        name - a String giving the header name for which to search
        value - a String giving the value to be set. This value will be substituted for the current value(s) of the first header that is a match if there is one. If there is no match, this value will be the value for a new MimeHeader object.
        抛出：
        IllegalArgumentException - if there was a problem with the specified mime header name or value
        另请参见：
        getMimeHeader(java.lang.String)

      • addMimeHeader

        public abstract void addMimeHeader(String name,
                 String value)
        Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object. If a MimeHeader with the specified name already exists, this method adds the specified value to the already existing value(s).

        Note that RFC822 headers can contain only US-ASCII characters.

        参数：
        name - a String giving the header name
        value - a String giving the value to be set or added
        抛出：
        IllegalArgumentException - if there was a problem with the specified mime header name or value

      • getAllMimeHeaders

        public abstract Iterator getAllMimeHeaders()
        Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
        返回：
        an Iterator object with all of the Mime headers for this SOAPPart object

      • getMatchingMimeHeaders

        public abstract Iterator getMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects that match a name in the given array.
        参数：
        names - a String array with the name(s) of the MIME headers to be returned
        返回：
        all of the MIME headers that match one of the names in the given array, returned as an Iterator object

      • getNonMatchingMimeHeaders

        public abstract Iterator getNonMatchingMimeHeaders(String[] names)
        Retrieves all MimeHeader objects whose name does not match a name in the given array.
        参数：
        names - a String array with the name(s) of the MIME headers not to be returned
        返回：
        all of the MIME headers in this SOAPPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.

      • setContent

        public abstract void setContent(Source source)
                         throws SOAPException
        Sets the content of the SOAPEnvelope object with the data from the given Source object. This Source must contain a valid SOAP document.
        参数：
        source - the javax.xml.transform.Source object with the data to be set
        抛出：
        SOAPException - if there is a problem in setting the source
        另请参见：
        getContent()

      • getContent

        public abstract Source getContent()
                           throws SOAPException
        Returns the content of the SOAPEnvelope as a JAXP Source object.
        返回：
        the content as a javax.xml.transform.Source object
        抛出：
        SOAPException - if the implementation cannot convert the specified Source object
        另请参见：
        setContent(javax.xml.transform.Source)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d<>rroe oe rre n>ooe<.h...=df.a.v/a..lin�"e�


Text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.soap

Interface Text

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface Text
extends Node, Text
    A representation of a node whose value is text. A Text object may represent text that is content or text that is a comment.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isComment()
      Retrieves whether this Text object represents a comment.

      • 方法 - 继承于接口 javax.xml.soap.Node

        detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue

      • 方法 - 继承于接口 org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • 方法 - 继承于接口 org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • isComment

        boolean isComment()
        Retrieves whether this Text object represents a comment.
        返回：
        true if this Text object is a comment; false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nibtagvngvaaavaa eggtgnnaetct<>>att


Uses of Package javax.xml.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.soap

  • Packages that use javax.xml.soap
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.soap used by javax.xml.soap
    类与描述
    AttachmentPart
    A single attachment to a SOAPMessage object.
    Detail
    A container for DetailEntry objects.
    DetailEntry
    The content for a Detail object, giving details for a SOAPFault object.
    MessageFactory
    A factory for creating SOAPMessage objects.
    MimeHeaders
    A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
    Name
    A representation of an XML name.
    Node
    A representation of a node (element) in an XML document.
    SOAPBody
    An object that represents the contents of the SOAP body element in a SOAP message.
    SOAPBodyElement
    A SOAPBodyElement object represents the contents in a SOAPBody object.
    SOAPConnection
    A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
    SOAPConnectionFactory
    A factory for creating SOAPConnection objects.
    SOAPElement
    An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
    SOAPElementFactory
    Deprecated.
    - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
    SOAPEnvelope
    The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
    SOAPException
    An exception that signals that a SOAP exception has occurred.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
    SOAPFaultElement
    A representation of the contents in a SOAPFault object.
    SOAPHeader
    A representation of the SOAP header element.
    SOAPHeaderElement
    An object representing the contents in the SOAP header part of the SOAP envelope.
    SOAPMessage
    The root class for all SOAP messages.
    SOAPPart
    The container for the SOAP-specific portion of a SOAPMessage object.
  • Classes in javax.xml.soap used by javax.xml.ws.handler.soap
    类与描述
    SOAPMessage
    The root class for all SOAP messages.
  • Classes in javax.xml.soap used by javax.xml.ws.soap
    类与描述
    MessageFactory
    A factory for creating SOAPMessage objects.
    SOAPFactory
    SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
    SOAPFault
    An element in the SOAPBody object that contains error and/or status information.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ya.dIIsODMMMsb w:. rMMr


Uses of Class javax.xml.soap.AttachmentPart

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.AttachmentPart

  • Packages that use AttachmentPart
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of AttachmentPart in javax.xml.soap

      Methods in javax.xml.soap that return AttachmentPart
      修饰符与类型 方法与描述
      abstract AttachmentPart SOAPMessage.createAttachmentPart()
      Creates a new empty AttachmentPart object.
      AttachmentPart SOAPMessage.createAttachmentPart(DataHandler dataHandler)
      Creates an AttachmentPart object and populates it using the given DataHandler object.
      AttachmentPart SOAPMessage.createAttachmentPart(Object content, String contentType)
      Creates an AttachmentPart object and populates it with the specified data of the specified content type.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      Methods in javax.xml.soap with parameters of type AttachmentPart
      修饰符与类型 方法与描述
      abstract void SOAPMessage.addAttachmentPart(AttachmentPart AttachmentPart)
      Adds the given AttachmentPart object to this SOAPMessage object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eF"jcn/


Uses of Class javax.xml.soap.MessageFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.MessageFactory

  • Packages that use MessageFactory
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of MessageFactory in javax.xml.soap

      Methods in javax.xml.soap that return MessageFactory
      修饰符与类型 方法与描述
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.

    • Uses of MessageFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return MessageFactory
      修饰符与类型 方法与描述
      MessageFactory SOAPBinding.getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eg.e,ioi h"efl誓蹈a>a


Uses of Class javax.xml.soap.MimeHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.MimeHeader

No usage of javax.xml.soap.MimeHeader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>xs aodddo pprnp l


Uses of Class javax.xml.soap.MimeHeaders

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.MimeHeaders

  • Packages that use MimeHeaders
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of MimeHeaders in javax.xml.soap

      Methods in javax.xml.soap that return MimeHeaders
      修饰符与类型 方法与描述
      abstract MimeHeaders SOAPMessage.getMimeHeaders()
      Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
      Methods in javax.xml.soap with parameters of type MimeHeaders
      修饰符与类型 方法与描述
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      abstract Iterator SOAPMessage.getAttachments(MimeHeaders headers)
      Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
      abstract void SOAPMessage.removeAttachments(MimeHeaders headers)
      Removes all the AttachmentPart objects that have header entries that match the specified headers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

as jrat=


Uses of Class javax.xml.soap.SAAJMetaFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SAAJMetaFactory

No usage of javax.xml.soap.SAAJMetaFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mde e Sfo teeepxdSj


Uses of Class javax.xml.soap.SAAJResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SAAJResult

No usage of javax.xml.soap.SAAJResult
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A /ab;1;p-1


Uses of Class javax.xml.soap.SOAPConnection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPConnection

  • Packages that use SOAPConnection
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnection in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnection
      修饰符与类型 方法与描述
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e!>>e


Uses of Class javax.xml.soap.SOAPConnectionFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPConnectionFactory

  • Packages that use SOAPConnectionFactory
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPConnectionFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPConnectionFactory
      修饰符与类型 方法与描述
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsBOb &OO_>>ct/b<


Uses of Class javax.xml.soap.SOAPElementFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPElementFactory

  • Packages that use SOAPElementFactory
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElementFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPElementFactory
      修饰符与类型 方法与描述
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

doepml.avxxx r d>cc"tLsx


Uses of Class javax.xml.soap.SOAPException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPException

  • Packages that use SOAPException
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPException in javax.xml.soap

      Methods in javax.xml.soap that throw SOAPException
      修饰符与类型 方法与描述
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      void SOAPFault.addFaultReasonText(String text, Locale locale)
      Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
      void SOAPFault.appendFaultSubcode(QName subcode)
      Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract void SOAPConnection.close()
      Closes this SOAPConnection object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      abstract SOAPConnection SOAPConnectionFactory.createConnection()
      Create a new SOAPConnection.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      QName SOAPElement.createQName(String localName, String prefix)
      Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      abstract InputStream AttachmentPart.getBase64Content()
      Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      abstract Source SOAPPart.getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      abstract Object AttachmentPart.getContent()
      Gets the content of this AttachmentPart object as a Java object.
      abstract DataHandler AttachmentPart.getDataHandler()
      Gets the DataHandler object for this AttachmentPart object.
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
      Iterator SOAPFault.getFaultReasonLocales()
      Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
      String SOAPFault.getFaultReasonText(Locale locale)
      Returns the Reason Text associated with the given Locale.
      Iterator SOAPFault.getFaultReasonTexts()
      Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      Object SOAPMessage.getProperty(String property)
      Retrieves value of the specified property.
      abstract InputStream AttachmentPart.getRawContent()
      Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract byte[] AttachmentPart.getRawContentBytes()
      Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
      abstract int AttachmentPart.getSize()
      Returns the number of bytes in this AttachmentPart object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPElementFactory SOAPElementFactory.newInstance()
      Deprecated.
      Creates a new instance of SOAPElementFactory.
      static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
      Creates an instance of the default SOAPConnectionFactory object.
      static MessageFactory MessageFactory.newInstance()
      Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      static MessageFactory MessageFactory.newInstance(String protocol)
      Creates a new MessageFactory object that is an instance of the specified implementation.
      protected abstract MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
      Creates a MessageFactory object for the given String protocol.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.
      abstract void SOAPMessage.saveChanges()
      Updates this SOAPMessage object with all the changes that have been made to it.
      abstract void AttachmentPart.setBase64Content(InputStream content, String contentType)
      Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
      abstract void SOAPPart.setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      void SOAPElement.setEncodingStyle(String encodingStyle)
      Sets the encoding style for this SOAPElement object to one specified.
      void SOAPFault.setFaultActor(String faultActor)
      Sets this SOAPFault object with the given fault actor.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(QName faultCodeQName)
      Sets this SOAPFault object with the given fault code.
      void SOAPFault.setFaultCode(String faultCode)
      Sets this SOAPFault object with the give fault code.
      void SOAPFault.setFaultNode(String uri)
      Creates or replaces any existing Node element value for this SOAPFault object.
      void SOAPFault.setFaultRole(String uri)
      Creates or replaces any existing Role element value for this SOAPFault object.
      void SOAPFault.setFaultString(String faultString)
      Sets the fault string for this SOAPFault object to the given string.
      void SOAPFault.setFaultString(String faultString, Locale locale)
      Sets the fault string for this SOAPFault object to the given string and localized to the given locale.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      void SOAPMessage.setProperty(String property, Object value)
      Associates the specified value with the specified property.
      abstract void AttachmentPart.setRawContent(InputStream content, String contentType)
      Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
      abstract void AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
      Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
      void SOAPHeaderElement.setRelay(boolean relay)
      Sets the relay attribute for this SOAPHeaderElement to be either true or false.
      void SOAPHeaderElement.setRole(String uri)
      Sets the Role associated with this SOAPHeaderElement object to the specified Role.
      abstract void SOAPMessage.writeTo(OutputStream out)
      Writes this SOAPMessage object to the given output stream.
      Constructors in javax.xml.soap that throw SOAPException
      构造方法与描述
      SAAJResult()
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
      SAAJResult(String protocol)
      Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.soap.SOAPFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPFactory

  • Packages that use SOAPFactory
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFactory in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFactory
      修饰符与类型 方法与描述
      static SOAPFactory SOAPFactory.newInstance()
      Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
      static SOAPFactory SOAPFactory.newInstance(String protocol)
      Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
      protected abstract SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
      Creates a SOAPFactory object for the given String protocol.

    • Uses of SOAPFactory in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFactory
      修饰符与类型 方法与描述
      SOAPFactory SOAPBinding.getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eane ew ad


Uses of Class javax.xml.soap.SOAPMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPMessage

  • Packages that use SOAPMessage
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessage in javax.xml.soap

      Methods in javax.xml.soap that return SOAPMessage
      修饰符与类型 方法与描述
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      abstract SOAPMessage MessageFactory.createMessage()
      Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
      abstract SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
      Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
      SOAPMessage SOAPConnection.get(Object to)
      Gets a message from a specific endpoint and blocks until it receives,
      Methods in javax.xml.soap with parameters of type SOAPMessage
      修饰符与类型 方法与描述
      abstract SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
      Sends the given message to the specified endpoint and blocks until it has returned the response.
      Constructors in javax.xml.soap with parameters of type SOAPMessage
      构造方法与描述
      SAAJResult(SOAPMessage message)
      Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.

    • Uses of SOAPMessage in javax.xml.ws.handler.soap

      Methods in javax.xml.ws.handler.soap that return SOAPMessage
      修饰符与类型 方法与描述
      SOAPMessage SOAPMessageContext.getMessage()
      Gets the SOAPMessage from this message context.
      Methods in javax.xml.ws.handler.soap with parameters of type SOAPMessage
      修饰符与类型 方法与描述
      void SOAPMessageContext.setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A� p羣b擞ǎo衕oLtr癮/


Uses of Class javax.xml.soap.SOAPPart

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.soap.SOAPPart

  • Packages that use SOAPPart
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPPart in javax.xml.soap

      Methods in javax.xml.soap that return SOAPPart
      修饰符与类型 方法与描述
      abstract SOAPPart SOAPMessage.getSOAPPart()
      Gets the SOAP part of this SOAPMessage object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vy /p;t&>nnn<"ii/o/)


Uses of Interface javax.xml.soap.Detail

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.Detail

  • Packages that use Detail
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Detail in javax.xml.soap

      Methods in javax.xml.soap that return Detail
      修饰符与类型 方法与描述
      Detail SOAPFault.addDetail()
      Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
      abstract Detail SOAPFactory.createDetail()
      Creates a new Detail object which serves as a container for DetailEntry objects.
      Detail SOAPFault.getDetail()
      Returns the optional detail element for this SOAPFault object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bue


Uses of Interface javax.xml.soap.DetailEntry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.DetailEntry

  • Packages that use DetailEntry
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of DetailEntry in javax.xml.soap

      Methods in javax.xml.soap that return DetailEntry
      修饰符与类型 方法与描述
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      DetailEntry Detail.addDetailEntry(QName qname)
      Creates a new DetailEntry object with the given QName and adds it to this Detail object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ii；涿泵裕羧�<酐颖衾吏o


Uses of Interface javax.xml.soap.Name

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.Name

  • Packages that use Name
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Name in javax.xml.soap

      Methods in javax.xml.soap that return Name
      修饰符与类型 方法与描述
      abstract Name SOAPFactory.createName(String localName)
      Creates a new Name object initialized with the given local name.
      Name SOAPEnvelope.createName(String localName)
      Creates a new Name object initialized with the given local name.
      abstract Name SOAPFactory.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPEnvelope.createName(String localName, String prefix, String uri)
      Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
      Name SOAPElement.getElementName()
      Returns the name of this SOAPElement object.
      Name SOAPFault.getFaultCodeAsName()
      Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
      Methods in javax.xml.soap with parameters of type Name
      修饰符与类型 方法与描述
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      DetailEntry Detail.addDetailEntry(Name name)
      Creates a new DetailEntry object with the given name and adds it to this Detail object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      String SOAPElement.getAttributeValue(Name name)
      Returns the value of the attribute with the specified name.
      Iterator SOAPElement.getChildElements(Name name)
      Returns an Iterator over all the immediate child Nodes of this element with the specified name.
      boolean SOAPElement.removeAttribute(Name name)
      Removes the attribute with the specified name.
      void SOAPFault.setFaultCode(Name faultCodeQName)
      Sets this SOAPFault object with the given fault code.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ihl=>iaMPp!L/蔱uud


Uses of Interface javax.xml.soap.Node

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.Node

  • Packages that use Node
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      interface  Text
      A representation of a node whose value is text.
      Methods in javax.xml.soap that return Node
      修饰符与类型 | 方法与描述
      Node | SAAJResult.getResult()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<./>tross===c"aalnelt ai>


Uses of Interface javax.xml.soap.SOAPBody

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPBody

  • Packages that use SOAPBody
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBody in javax.xml.soap

      Methods in javax.xml.soap that return SOAPBody
      修饰符与类型 方法与描述
      SOAPBody SOAPEnvelope.addBody()
      Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
      SOAPBody SOAPEnvelope.getBody()
      Returns the SOAPBody object associated with this SOAPEnvelope object.
      SOAPBody SOAPMessage.getSOAPBody()
      Gets the SOAP Body contained in this SOAPMessage object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

arevttcsut co/ma莖caha


Uses of Interface javax.xml.soap.SOAPBodyElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPBodyElement

  • Packages that use SOAPBodyElement
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPBodyElement in javax.xml.soap

      Subinterfaces of SOAPBodyElement in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      Methods in javax.xml.soap that return SOAPBodyElement
      修饰符与类型 方法与描述
      SOAPBodyElement SOAPBody.addBodyElement(Name name)
      Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addBodyElement(QName qname)
      Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sgle ax


Uses of Interface javax.xml.soap.SOAPConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPConstants

No usage of javax.xml.soap.SOAPConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vti vLi=s"""la!!vSla-


Uses of Interface javax.xml.soap.SOAPElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPElement

  • Packages that use SOAPElement
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPElement in javax.xml.soap

      Subinterfaces of SOAPElement in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap that return SOAPElement
      修饰符与类型 方法与描述
      SOAPElement SOAPElement.addAttribute(Name name, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addAttribute(QName qname, String value)
      Adds an attribute with the specified name and value to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(Name name)
      Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(QName qname)
      Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      SOAPElement SOAPElement.addChildElement(String localName)
      Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix)
      Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
      SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
      Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
      SOAPElement SOAPElement.addTextNode(String text)
      Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
      SOAPElement SOAPElementFactory.create(Name name)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
      SOAPElement SOAPElementFactory.create(String localName)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
      SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
      Deprecated.
      Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.
      abstract SOAPElement SOAPFactory.createElement(Name name)
      Creates a SOAPElement object initialized with the given Name object.
      SOAPElement SOAPFactory.createElement(QName qname)
      Creates a SOAPElement object initialized with the given QName object.
      abstract SOAPElement SOAPFactory.createElement(String localName)
      Creates a SOAPElement object initialized with the given local name.
      abstract SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
      Creates a new SOAPElement object with the given local name, prefix and uri.
      SOAPElement Node.getParentElement()
      Returns the parent element of this Node object.
      SOAPElement SOAPElement.setElementQName(QName newName)
      Changes the name of this Element to newName if possible.
      Methods in javax.xml.soap with parameters of type SOAPElement
      修饰符与类型 方法与描述
      SOAPElement SOAPElement.addChildElement(SOAPElement element)
      Add a SOAPElement as a child of this SOAPElement instance.
      abstract AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
      Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
      void Node.setParentElement(SOAPElement parent)
      Sets the parent of this Node object to the given SOAPElement object.
      Constructors in javax.xml.soap with parameters of type SOAPElement
      构造方法与描述
      SAAJResult(SOAPElement rootNode)
      Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"/


Uses of Interface javax.xml.soap.SOAPEnvelope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPEnvelope

  • Packages that use SOAPEnvelope
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPEnvelope in javax.xml.soap

      Methods in javax.xml.soap that return SOAPEnvelope
      修饰符与类型 方法与描述
      abstract SOAPEnvelope SOAPPart.getEnvelope()
      Gets the SOAPEnvelope object associated with this SOAPPart object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d绷 扑瓢撩幔怂/Ｐ了Ｓ樱/


Uses of Interface javax.xml.soap.SOAPFault

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPFault

  • Packages that use SOAPFault
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of SOAPFault in javax.xml.soap

      Methods in javax.xml.soap that return SOAPFault
      修饰符与类型 方法与描述
      SOAPFault SOAPBody.addFault()
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
      Creates a new SOAPFault object and adds it to this SOAPBody object.
      abstract SOAPFault SOAPFactory.createFault()
      Creates a new default SOAPFault object
      abstract SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
      Creates a new SOAPFault object initialized with the given reasonText and faultCode
      SOAPFault SOAPBody.getFault()
      Returns the SOAPFault object in this SOAPBody object.

    • Uses of SOAPFault in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return SOAPFault
      修饰符与类型 方法与描述
      SOAPFault SOAPFaultException.getFault()
      Gets the embedded SOAPFault instance.
      Constructors in javax.xml.ws.soap with parameters of type SOAPFault
      构造方法与描述
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oc kh


Uses of Interface javax.xml.soap.SOAPFaultElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPFaultElement

  • Packages that use SOAPFaultElement
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPFaultElement in javax.xml.soap

      Subinterfaces of SOAPFaultElement in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Detail
      A container for DetailEntry objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e a"clad


Uses of Interface javax.xml.soap.SOAPHeader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPHeader

  • Packages that use SOAPHeader
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeader in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeader
      修饰符与类型 方法与描述
      SOAPHeader SOAPEnvelope.addHeader()
      Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPEnvelope.getHeader()
      Returns the SOAPHeader object for this SOAPEnvelope object.
      SOAPHeader SOAPMessage.getSOAPHeader()
      Gets the SOAP Header contained in this SOAPMessage object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ra


Uses of Interface javax.xml.soap.SOAPHeaderElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.SOAPHeaderElement

  • Packages that use SOAPHeaderElement
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of SOAPHeaderElement in javax.xml.soap

      Methods in javax.xml.soap that return SOAPHeaderElement
      修饰符与类型 方法与描述
      SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
      Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
      Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
      Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
      SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
      Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lteih b=///t/>>=l薳 "ro


Uses of Interface javax.xml.soap.Text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.soap.Text

No usage of javax.xml.soap.Text
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=i/


EventFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface EventFilter

  • public interface EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean accept(XMLEvent event)
      Tests whether this event is part of this stream.

    • 方法详细信息

      • accept

        boolean accept(XMLEvent event)
        Tests whether this event is part of this stream. This method will return true if this filter accepts this event and false otherwise.
        参数：
        event - the event to test
        返回：
        true if this filter accepts this event, false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ludeat給sna


FactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream

类 FactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
  • 所有已实现的接口：
    Serializable

    public class FactoryConfigurationError
extends Error
    An error class for reporting factory configuration errors.
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      FactoryConfigurationError()
      Default constructor
      FactoryConfigurationError(Exception e)
      Construct an exception with a nested inner exception
      FactoryConfigurationError(Exception e, String msg)
      Construct an exception with a nested inner exception and a message
      FactoryConfigurationError(String msg)
      Construct an exception with associated message
      FactoryConfigurationError(String msg, Exception e)
      Construct an exception with a nested inner exception and a message

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the nested exception (if any)
      String getMessage()
      Report the message associated with this error

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FactoryConfigurationError

        public FactoryConfigurationError()
        Default constructor

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e)
        Construct an exception with a nested inner exception
        参数：
        e - the exception to nest

      • FactoryConfigurationError

        public FactoryConfigurationError(Exception e,
                         String msg)
        Construct an exception with a nested inner exception and a message
        参数：
        e - the exception to nest
        msg - the message to report

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg,
                         Exception e)
        Construct an exception with a nested inner exception and a message
        参数：
        msg - the message to report
        e - the exception to nest

      • FactoryConfigurationError

        public FactoryConfigurationError(String msg)
        Construct an exception with associated message
        参数：
        msg - the message to report

    • 方法详细信息

      • getException

        public Exception getException()
        Return the nested exception (if any)
        返回：
        the nested exception or null

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.

      • getMessage

        public String getMessage()
        Report the message associated with this error
        重载：
        getMessage in class Throwable
        返回：
        the string value of the message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"<< d siooC""Tcts


javax.xml.stream

Interfaces

  • EventFilter
  • Location
  • StreamFilter
  • XMLEventReader
  • XMLEventWriter
  • XMLReporter
  • XMLResolver
  • XMLStreamConstants
  • XMLStreamReader
  • XMLStreamWriter

Classes

  • XMLEventFactory
  • XMLInputFactory
  • XMLOutputFactory

Exceptions

  • XMLStreamException

Errors

  • FactoryConfigurationError
s


javax.xml.stream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.stream

  • 接口摘要
    接口 描述
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Class Summary
    类 描述
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
  • Exception Summary
    Exception 描述
    XMLStreamException
    The base exception for unexpected processing errors.
  • Error Summary
    Error 描述
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pm:fepupt/tuo/ oelVBAd


javax.xml.stream Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.stream

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
    • javax.xml.stream.XMLEventFactory
    • javax.xml.stream.XMLInputFactory
    • javax.xml.stream.XMLOutputFactory

Interface Hierarchy

  • javax.xml.stream.EventFilter
  • java.util.Iterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.xml.stream.Location
  • javax.xml.stream.StreamFilter
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eT.gtcakkk=>//lB>>c-


Location

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface Location

  • public interface Location
    Provides information on the location of an event. All the information provided by a Location is optional. For example an application may only report line numbers.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getCharacterOffset()
      Return the byte or character offset into the input source this location is pointing to.
      int getColumnNumber()
      Return the column number where the current event ends, returns -1 if none is available.
      int getLineNumber()
      Return the line number where the current event ends, returns -1 if none is available.
      String getPublicId()
      Returns the public ID of the XML
      String getSystemId()
      Returns the system ID of the XML

    • 方法详细信息

      • getLineNumber

        int getLineNumber()
        Return the line number where the current event ends, returns -1 if none is available.
        返回：
        the current line number

      • getColumnNumber

        int getColumnNumber()
        Return the column number where the current event ends, returns -1 if none is available.
        返回：
        the current column number

      • getCharacterOffset

        int getCharacterOffset()
        Return the byte or character offset into the input source this location is pointing to. If the input source is a file or a byte stream then this is the byte offset into that stream, but if the input source is a character media then the offset is the character offset. Returns -1 if there is no offset available.
        返回：
        the current offset

      • getPublicId

        String getPublicId()
        Returns the public ID of the XML
        返回：
        the public ID, or null if not available

      • getSystemId

        String getSystemId()
        Returns the system ID of the XML
        返回：
        the system ID, or null if not available
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r


StreamFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface StreamFilter

  • public interface StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean accept(XMLStreamReader reader)
      Tests whether the current state is part of this stream.

    • 方法详细信息

      • accept

        boolean accept(XMLStreamReader reader)
        Tests whether the current state is part of this stream. This method will return true if this filter accepts this event and false otherwise. The method should not change the state of the reader when accepting a state.
        参数：
        reader - the event to test
        返回：
        true if this filter accepts this event, false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tOe s r sraeaeddfissatxtl/a/hh>".l


Uses of Package javax.xml.stream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.stream

  • Packages that use javax.xml.stream
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
  • Classes in javax.xml.stream used by javax.xml.bind
    类与描述
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.bind.helpers
    类与描述
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.stream
    类与描述
    EventFilter
    This interface declares a simple filter interface that one can create to filter XMLEventReaders
    FactoryConfigurationError
    An error class for reporting factory configuration errors.
    Location
    Provides information on the location of an event.
    StreamFilter
    This interface declares a simple filter interface that one can create to filter XMLStreamReaders
    XMLEventFactory
    This interface defines a utility class for creating instances of XMLEvents
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLInputFactory
    Defines an abstract implementation of a factory for getting streams.
    XMLOutputFactory
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
    XMLReporter
    This interface is used to report non-fatal errors.
    XMLResolver
    This interface is used to resolve resources during an XML parse.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • Classes in javax.xml.stream used by javax.xml.stream.events
    类与描述
    Location
    Provides information on the location of an event.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
  • Classes in javax.xml.stream used by javax.xml.stream.util
    类与描述
    Location
    Provides information on the location of an event.
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLStreamConstants
    This interface declares the constants used in this API.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
  • Classes in javax.xml.stream used by javax.xml.transform.stax
    类与描述
    XMLEventReader
    This is the top level interface for parsing XML Events.
    XMLEventWriter
    This is the top level interface for writing XML documents.
    XMLStreamException
    The base exception for unexpected processing errors.
    XMLStreamReader
    The XMLStreamReader interface allows forward, read-only access to XML.
    XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>el= = ==-s"l-BB<vs


XMLEventFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream

类 XMLEventFactory

  • java.lang.Object
    • javax.xml.stream.XMLEventFactory

  • public abstract class XMLEventFactory
extends Object
    This interface defines a utility class for creating instances of XMLEvents
    从以下版本开始：
    1.6
    另请参见：
    StartElement, EndElement, ProcessingInstruction, Comment, Characters, StartDocument, EndDocument, DTD

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | XMLEventFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Attribute createAttribute(QName name, String value)
      Create a new Attribute
      abstract Attribute createAttribute(String localName, String value)
      Create a new Attribute
      abstract Attribute createAttribute(String prefix, String namespaceURI, String localName, String value)
      Create a new Attribute
      abstract Characters createCData(String content)
      Create a Characters event with the CData flag set to true
      abstract Characters createCharacters(String content)
      Create a Characters event, this method does not check if the content is all whitespace.
      abstract Comment createComment(String text)
      Create a comment
      abstract DTD createDTD(String dtd)
      Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
      abstract EndDocument createEndDocument()
      Creates a new instance of an EndDocument event
      abstract EndElement createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract EndElement createEndElement(String prefix, String namespaceUri, String localName)
      Create a new EndElement
      abstract EndElement createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
      Create a new EndElement
      abstract EntityReference createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event
      abstract Characters createIgnorableSpace(String content)
      Create an ignorable space
      abstract Namespace createNamespace(String namespaceURI)
      Create a new default Namespace
      abstract Namespace createNamespace(String prefix, String namespaceUri)
      Create a new Namespace
      abstract ProcessingInstruction createProcessingInstruction(String target, String data)
      Create a processing instruction
      abstract Characters createSpace(String content)
      Create a Characters event with the isSpace flag set to true
      abstract StartDocument createStartDocument()
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding)
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding, String version)
      Creates a new instance of a StartDocument event
      abstract StartDocument createStartDocument(String encoding, String version, boolean standalone)
      Creates a new instance of a StartDocument event
      abstract StartElement createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.
      static XMLEventFactory newFactory()
      Create a new instance of the factory.
      static XMLEventFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory newInstance()
      Create a new instance of the factory
      static XMLEventFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      abstract void setLocation(Location location)
      This method allows setting of the Location on each event that is created by this factory.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLEventFactory

        protected XMLEventFactory()

    • 方法详细信息

      • newInstance

        public static XMLEventFactory newInstance()
                                   throws FactoryConfigurationError
        Create a new instance of the factory
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLEventFactory newFactory()
                                  throws FactoryConfigurationError
        Create a new instance of the factory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLEventFactory implementation class to load: Use the javax.xml.stream.XMLEventFactory system property. Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.stream.XMLEventFactory in jars available to the runtime. Platform default XMLEventFactory instance. Once an application has obtained a reference to a XMLEventFactory it can use the factory to configure and obtain stream instances. Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newInstance

        public static XMLEventFactory newInstance(String factoryId,
                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
        Create a new instance of the factory
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLEventFactory newFactory(String factoryId,
                         ClassLoader classLoader)
                                  throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used. Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • setLocation

        public abstract void setLocation(Location location)
        This method allows setting of the Location on each event that is created by this factory. The values are copied by value into the events created by this factory. To reset the location information set the location to null.
        参数：
        location - the location to set on each event created

      • createAttribute

        public abstract Attribute createAttribute(String prefix,
                        String namespaceURI,
                        String localName,
                        String value)
        Create a new Attribute
        参数：
        prefix - the prefix of this attribute, may not be null
        namespaceURI - the attribute value is set to this value, may not be null
        localName - the local name of the XML name of the attribute, localName cannot be null
        value - the attribute value to set, may not be null
        返回：
        the Attribute with specified values

      • createAttribute

        public abstract Attribute createAttribute(String localName,
                        String value)
        Create a new Attribute
        参数：
        localName - the local name of the XML name of the attribute, localName cannot be null
        value - the attribute value to set, may not be null
        返回：
        the Attribute with specified values

      • createAttribute

        public abstract Attribute createAttribute(QName name,
                        String value)
        Create a new Attribute
        参数：
        name - the qualified name of the attribute, may not be null
        value - the attribute value to set, may not be null
        返回：
        the Attribute with specified values

      • createNamespace

        public abstract Namespace createNamespace(String namespaceURI)
        Create a new default Namespace
        参数：
        namespaceURI - the default namespace uri
        返回：
        the Namespace with the specified value

      • createNamespace

        public abstract Namespace createNamespace(String prefix,
                        String namespaceUri)
        Create a new Namespace
        参数：
        prefix - the prefix of this namespace, may not be null
        namespaceUri - the attribute value is set to this value, may not be null
        返回：
        the Namespace with the specified values

      • createStartElement

        public abstract StartElement createStartElement(QName name,
                              Iterator attributes,
                              Iterator namespaces)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        参数：
        name - the qualified name of the attribute, may not be null
        attributes - an optional unordered set of objects that implement Attribute to add to the new StartElement, may be null
        namespaces - an optional unordered set of objects that implement Namespace to add to the new StartElement, may be null
        返回：
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                              String namespaceUri,
                              String localName)
        Create a new StartElement. This defaults the NamespaceContext to an empty NamespaceContext. Querying this event for its namespaces or attributes will result in an empty iterator being returned.
        参数：
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        返回：
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                              String namespaceUri,
                              String localName,
                              Iterator attributes,
                              Iterator namespaces)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        参数：
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        attributes - an unordered set of objects that implement Attribute to add to the new StartElement
        namespaces - an unordered set of objects that implement Namespace to add to the new StartElement
        返回：
        an instance of the requested StartElement

      • createStartElement

        public abstract StartElement createStartElement(String prefix,
                              String namespaceUri,
                              String localName,
                              Iterator attributes,
                              Iterator namespaces,
                              NamespaceContext context)
        Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.
        参数：
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        attributes - an unordered set of objects that implement Attribute to add to the new StartElement, may be null
        namespaces - an unordered set of objects that implement Namespace to add to the new StartElement, may be null
        context - the namespace context of this element
        返回：
        an instance of the requested StartElement

      • createEndElement

        public abstract EndElement createEndElement(QName name,
                          Iterator namespaces)
        Create a new EndElement
        参数：
        name - the qualified name of the EndElement
        namespaces - an optional unordered set of objects that implement Namespace that have gone out of scope, may be null
        返回：
        an instance of the requested EndElement

      • createEndElement

        public abstract EndElement createEndElement(String prefix,
                          String namespaceUri,
                          String localName)
        Create a new EndElement
        参数：
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        返回：
        an instance of the requested EndElement

      • createEndElement

        public abstract EndElement createEndElement(String prefix,
                          String namespaceUri,
                          String localName,
                          Iterator namespaces)
        Create a new EndElement
        参数：
        namespaceUri - the uri of the QName of the new StartElement
        localName - the local name of the QName of the new StartElement
        prefix - the prefix of the QName of the new StartElement
        namespaces - an unordered set of objects that implement Namespace that have gone out of scope, may be null
        返回：
        an instance of the requested EndElement

      • createCharacters

        public abstract Characters createCharacters(String content)
        Create a Characters event, this method does not check if the content is all whitespace. To create a space event use #createSpace(String)
        参数：
        content - the string to create
        返回：
        a Characters event

      • createCData

        public abstract Characters createCData(String content)
        Create a Characters event with the CData flag set to true
        参数：
        content - the string to create
        返回：
        a Characters event

      • createSpace

        public abstract Characters createSpace(String content)
        Create a Characters event with the isSpace flag set to true
        参数：
        content - the content of the space to create
        返回：
        a Characters event

      • createIgnorableSpace

        public abstract Characters createIgnorableSpace(String content)
        Create an ignorable space
        参数：
        content - the space to create
        返回：
        a Characters event

      • createStartDocument

        public abstract StartDocument createStartDocument()
        Creates a new instance of a StartDocument event
        返回：
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding,
                                String version,
                                boolean standalone)
        Creates a new instance of a StartDocument event
        参数：
        encoding - the encoding style
        version - the XML version
        standalone - the status of standalone may be set to "true" or "false"
        返回：
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding,
                                String version)
        Creates a new instance of a StartDocument event
        参数：
        encoding - the encoding style
        version - the XML version
        返回：
        a StartDocument event

      • createStartDocument

        public abstract StartDocument createStartDocument(String encoding)
        Creates a new instance of a StartDocument event
        参数：
        encoding - the encoding style
        返回：
        a StartDocument event

      • createEndDocument

        public abstract EndDocument createEndDocument()
        Creates a new instance of an EndDocument event
        返回：
        an EndDocument event

      • createEntityReference

        public abstract EntityReference createEntityReference(String name,
                                    EntityDeclaration declaration)
        Creates a new instance of a EntityReference event
        参数：
        name - The name of the reference
        declaration - the declaration for the event
        返回：
        an EntityReference event

      • createComment

        public abstract Comment createComment(String text)
        Create a comment
        参数：
        text - The text of the comment a Comment event

      • createProcessingInstruction

        public abstract ProcessingInstruction createProcessingInstruction(String target,
                                                String data)
        Create a processing instruction
        参数：
        target - The target of the processing instruction
        data - The text of the processing instruction
        返回：
        a ProcessingInstruction event

      • createDTD

        public abstract DTD createDTD(String dtd)
        Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
        参数：
        dtd - the text of the document type definition
        返回：
        a DTD event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XMLEventReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLEventReader

  • All Superinterfaces:
    Iterator
    All Known Implementing Classes:
    EventReaderDelegate

    public interface XMLEventReader
extends Iterator
    This is the top level interface for parsing XML Events. It provides the ability to peek at the next event and returns configuration information through the property interface.
    从以下版本开始：
    1.6
    另请参见：
    XMLInputFactory, XMLEventWriter

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Frees any resources associated with this Reader.
      String getElementText()
      Reads the content of a text-only element.
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      boolean hasNext()
      Check if there are more events.
      XMLEvent nextEvent()
      Get the next XMLEvent
      XMLEvent nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent peek()
      Check the next XMLEvent without reading it from the stream.

      • 方法 - 继承于接口 java.util.Iterator

        下一个, remove

    • 方法详细信息

      • nextEvent

        XMLEvent nextEvent()
                   throws XMLStreamException
        Get the next XMLEvent
        抛出：
        XMLStreamException - if there is an error with the underlying XML.
        NoSuchElementException - iteration has no more elements.
        另请参见：
        XMLEvent

      • hasNext

        boolean hasNext()
        Check if there are more events. Returns true if there are more events and false otherwise.
        指定者：
        hasNext in interface Iterator
        返回：
        true if the event reader has more events, false otherwise

      • peek

        XMLEvent peek()
              throws XMLStreamException
        Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().
        抛出：
        XMLStreamException
        另请参见：
        XMLEvent

      • getElementText

        String getElementText()
                      throws XMLStreamException
        Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.
        抛出：
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        XMLEvent nextTag()
                 throws XMLStreamException
        Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.
        抛出：
        XMLStreamException - if anything other than space characters are encountered

      • getProperty

        Object getProperty(String name)
                   throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        参数：
        name - The name of the property
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • close

        void close()
           throws XMLStreamException
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        抛出：
        XMLStreamException - if there are errors freeing associated resources
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

F.ic>t">aav ;e<&gc


XMLEventWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLEventWriter

  • All Superinterfaces:
    XMLEventConsumer

    public interface XMLEventWriter
extends XMLEventConsumer
    This is the top level interface for writing XML documents. Instances of this interface are not required to validate the form of the XML.
    从以下版本开始：
    1.6
    另请参见：
    XMLEventReader, XMLEvent, Characters, ProcessingInstruction, StartElement, EndElement

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
      void add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      void close()
      Frees any resources associated with this stream
      void flush()
      Writes any cached events to the underlying output mechanism
      NamespaceContext getNamespaceContext()
      Returns the current namespace context.
      String getPrefix(String uri)
      Gets the prefix the uri is bound to
      void setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.

    • 方法详细信息

      • flush

        void flush()
           throws XMLStreamException
        Writes any cached events to the underlying output mechanism
        抛出：
        XMLStreamException

      • close

        void close()
           throws XMLStreamException
        Frees any resources associated with this stream
        抛出：
        XMLStreamException

      • add

        void add(XMLEvent event)
         throws XMLStreamException
        Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
        Required and optional fields for events added to the writer
        Event Type | Required Fields | Optional Fields | Required Behavior
        START_ELEMENT | QName name | namespaces , attributes | A START_ELEMENT will be written by writing the name, namespaces, and attributes of the event in XML 1.0 valid syntax for START_ELEMENTs. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. Each attribute (if any) is written using the behavior specified in the attribute section of this table. Each namespace (if any) is written using the behavior specified in the namespace section of this table.
        END_ELEMENT | Qname name | None | A well formed END_ELEMENT tag is written. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. If the END_ELEMENT name does not match the START_ELEMENT name an XMLStreamException is thrown.
        ATTRIBUTE | QName name , String value | QName type | An attribute is written using the same algorithm to find the lexical form as used in START_ELEMENT. The default is to use double quotes to wrap attribute values and to escape any double quotes found in the value. The type value is ignored.
        NAMESPACE | String prefix, String namespaceURI, boolean isDefaultNamespaceDeclaration | None | A namespace declaration is written. If the namespace is a default namespace declaration (isDefault is true) then xmlns="$namespaceURI" is written and the prefix is optional. If isDefault is false, the prefix must be declared and the writer must prepend xmlns to the prefix and write out a standard prefix declaration.
        PROCESSING_INSTRUCTION | None | String target, String data | The data does not need to be present and may be null. Target is required and many not be null. The writer will write data section directly after the target, enclosed in appropriate XML 1.0 syntax
        COMMENT | None | String comment | If the comment is present (not null) it is written, otherwise an an empty comment is written
        START_DOCUMENT | None | String encoding , boolean standalone, String version | A START_DOCUMENT event is not required to be written to the stream. If present the attributes are written inside the appropriate XML declaration syntax
        END_DOCUMENT | None | None | Nothing is written to the output
        DTD | String DocumentTypeDefinition | None | The DocumentTypeDefinition is written to the output
        指定者：
        add in interface XMLEventConsumer
        参数：
        event - the event to be added
        抛出：
        XMLStreamException

      • add

        void add(XMLEventReader reader)
         throws XMLStreamException
        Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
        参数：
        reader - the event stream to add to the output
        抛出：
        XMLStreamException

      • getPrefix

        String getPrefix(String uri)
                 throws XMLStreamException
        Gets the prefix the uri is bound to
        参数：
        uri - the uri to look up
        抛出：
        XMLStreamException

      • setPrefix

        void setPrefix(String prefix,
             String uri)
               throws XMLStreamException
        Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.
        参数：
        prefix - the prefix to bind to the uri
        uri - the uri to bind to the prefix
        抛出：
        XMLStreamException

      • setDefaultNamespace

        void setDefaultNamespace(String uri)
                         throws XMLStreamException
        Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.
        参数：
        uri - the uri to bind to the default namespace
        抛出：
        XMLStreamException

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
        Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces.
        参数：
        context - the namespace context to use for this writer
        抛出：
        XMLStreamException

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns the current namespace context.
        返回：
        the current namespace context
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mxeh< e.Faai�>sLltupl>ec.


XMLInputFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream

类 XMLInputFactory

  • java.lang.Object
    • javax.xml.stream.XMLInputFactory

  • public abstract class XMLInputFactory
extends Object
    Defines an abstract implementation of a factory for getting streams. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
    Configuration parameters
    Property Name | Behavior | Return type | Default Value | Required
    javax.xml.stream.isValidating | Turns on/off implementation specific DTD validation | Boolean | False | No
    javax.xml.stream.isNamespaceAware | Turns on/off namespace processing for XML 1.0 support | Boolean | True | True (required) / False (optional)
    javax.xml.stream.isCoalescing | Requires the processor to coalesce adjacent character data | Boolean | False | Yes
    javax.xml.stream.isReplacingEntityReferences | replace internal entity references with their replacement text and report them as characters | Boolean | True | Yes
    javax.xml.stream.isSupportingExternalEntities | Resolve external parsed entities | Boolean | Unspecified | Yes
    javax.xml.stream.supportDTD | Use this property to request processors that do not support DTDs | Boolean | True | Yes
    javax.xml.stream.reporter | sets/gets the impl of the XMLReporter | javax.xml.stream.XMLReporter | Null | Yes
    javax.xml.stream.resolver | sets/gets the impl of the XMLResolver interface | javax.xml.stream.XMLResolver | Null | Yes
    javax.xml.stream.allocator | sets/gets the impl of the XMLEventAllocator interface | javax.xml.stream.util.XMLEventAllocator | Null | Yes
    从以下版本开始：
    1.6
    另请参见：
    XMLOutputFactory, XMLEventReader, XMLStreamReader, EventFilter, XMLReporter, XMLResolver, XMLEventAllocator

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ALLOCATOR
      The property used to set/get the implementation of the allocator
      static String IS_COALESCING
      The property that requires the parser to coalesce adjacent character data sections
      static String IS_NAMESPACE_AWARE
      The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
      static String IS_REPLACING_ENTITY_REFERENCES
      Requires the parser to replace internal entity references with their replacement text and report them as characters
      static String IS_SUPPORTING_EXTERNAL_ENTITIES
      The property that requires the parser to resolve external parsed entities
      static String IS_VALIDATING
      The property used to turn on/off implementation specific validation
      static String REPORTER
      The property used to set/get the implementation of the XMLReporter interface
      static String RESOLVER
      The property used to set/get the implementation of the XMLResolver
      static String SUPPORT_DTD
      The property that requires the parser to support DTDs

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | XMLInputFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract XMLEventReader createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLStreamReader createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      abstract XMLStreamReader createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLEventAllocator getEventAllocator()
      Gets the allocator used by streams created with this factory
      abstract Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      abstract XMLReporter getXMLReporter()
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract XMLResolver getXMLResolver()
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract boolean isPropertySupported(String name)
      Query the set of properties that this factory supports.
      static XMLInputFactory newFactory()
      Create a new instance of the factory.
      static XMLInputFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory newInstance()
      Create a new instance of the factory.
      static XMLInputFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      abstract void setEventAllocator(XMLEventAllocator allocator)
      Set a user defined event allocator for events
      abstract void setProperty(String name, Object value)
      Allows the user to set specific feature/property on the underlying implementation.
      abstract void setXMLReporter(XMLReporter reporter)
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      abstract void setXMLResolver(XMLResolver resolver)
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IS_NAMESPACE_AWARE

        public static final String IS_NAMESPACE_AWARE
        The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
        另请参见：
        Constant Field Values

      • IS_VALIDATING

        public static final String IS_VALIDATING
        The property used to turn on/off implementation specific validation
        另请参见：
        Constant Field Values

      • IS_COALESCING

        public static final String IS_COALESCING
        The property that requires the parser to coalesce adjacent character data sections
        另请参见：
        Constant Field Values

      • IS_REPLACING_ENTITY_REFERENCES

        public static final String IS_REPLACING_ENTITY_REFERENCES
        Requires the parser to replace internal entity references with their replacement text and report them as characters
        另请参见：
        Constant Field Values

      • IS_SUPPORTING_EXTERNAL_ENTITIES

        public static final String IS_SUPPORTING_EXTERNAL_ENTITIES
        The property that requires the parser to resolve external parsed entities
        另请参见：
        Constant Field Values

      • SUPPORT_DTD

        public static final String SUPPORT_DTD
        The property that requires the parser to support DTDs
        另请参见：
        Constant Field Values

      • REPORTER

        public static final String REPORTER
        The property used to set/get the implementation of the XMLReporter interface
        另请参见：
        Constant Field Values

      • RESOLVER

        public static final String RESOLVER
        The property used to set/get the implementation of the XMLResolver
        另请参见：
        Constant Field Values

      • ALLOCATOR

        public static final String ALLOCATOR
        The property used to set/get the implementation of the allocator
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • XMLInputFactory

        protected XMLInputFactory()

    • 方法详细信息

      • newInstance

        public static XMLInputFactory newInstance()
                                   throws FactoryConfigurationError
        Create a new instance of the factory.
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLInputFactory newFactory()
                                  throws FactoryConfigurationError
        Create a new instance of the factory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLInputFactory implementation class to load: Use the javax.xml.stream.XMLInputFactory system property. Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.stream.XMLInputFactory in jars available to the runtime. Platform default XMLInputFactory instance. Once an application has obtained a reference to a XMLInputFactory it can use the factory to configure and obtain stream instances. Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newInstance

        public static XMLInputFactory newInstance(String factoryId,
                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
        Create a new instance of the factory
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLInputFactory newFactory(String factoryId,
                         ClassLoader classLoader)
                                  throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used. Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(Reader reader)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a reader
        参数：
        reader - the XML data to read from
        抛出：
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(Source source)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a JAXP source. This method is optional.
        参数：
        source - the source to read from
        抛出：
        UnsupportedOperationException - if this method is not supported by this XMLInputFactory
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(InputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        参数：
        stream - the InputStream to read from
        抛出：
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(InputStream stream,
                                    String encoding)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        参数：
        stream - the InputStream to read from
        encoding - the character encoding of the stream
        抛出：
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                    InputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        参数：
        systemId - the system ID of the stream
        stream - the InputStream to read from
        抛出：
        XMLStreamException

      • createXMLStreamReader

        public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                    Reader reader)
                                               throws XMLStreamException
        Create a new XMLStreamReader from a java.io.InputStream
        参数：
        systemId - the system ID of the stream
        reader - the InputStream to read from
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(Reader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from a reader
        参数：
        reader - the XML data to read from
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(String systemId,
                                  Reader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from a reader
        参数：
        systemId - the system ID of the input
        reader - the XML data to read from
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
                                             throws XMLStreamException
        Create a new XMLEventReader from an XMLStreamReader. After being used to construct the XMLEventReader instance returned from this method the XMLStreamReader must not be used.
        参数：
        reader - the XMLStreamReader to read from (may not be modified)
        返回：
        a new XMLEventReader
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(Source source)
                                             throws XMLStreamException
        Create a new XMLEventReader from a JAXP source. Support of this method is optional.
        参数：
        source - the source to read from
        抛出：
        UnsupportedOperationException - if this method is not supported by this XMLInputFactory
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(InputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        参数：
        stream - the InputStream to read from
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(InputStream stream,
                                  String encoding)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        参数：
        stream - the InputStream to read from
        encoding - the character encoding of the stream
        抛出：
        XMLStreamException

      • createXMLEventReader

        public abstract XMLEventReader createXMLEventReader(String systemId,
                                  InputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventReader from a java.io.InputStream
        参数：
        systemId - the system ID of the stream
        stream - the InputStream to read from
        抛出：
        XMLStreamException

      • createFilteredReader

        public abstract XMLStreamReader createFilteredReader(XMLStreamReader reader,
                                   StreamFilter filter)
                                              throws XMLStreamException
        Create a filtered reader that wraps the filter around the reader
        参数：
        reader - the reader to filter
        filter - the filter to apply to the reader
        抛出：
        XMLStreamException

      • createFilteredReader

        public abstract XMLEventReader createFilteredReader(XMLEventReader reader,
                                  EventFilter filter)
                                             throws XMLStreamException
        Create a filtered event reader that wraps the filter around the event reader
        参数：
        reader - the event reader to wrap
        filter - the filter to apply to the event reader
        抛出：
        XMLStreamException

      • getXMLResolver

        public abstract XMLResolver getXMLResolver()
        The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • setXMLResolver

        public abstract void setXMLResolver(XMLResolver resolver)
        The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
        参数：
        resolver - the resolver to use to resolve references

      • getXMLReporter

        public abstract XMLReporter getXMLReporter()
        The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

      • setXMLReporter

        public abstract void setXMLReporter(XMLReporter reporter)
        The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
        参数：
        reporter - the resolver to use to report non fatal errors

      • setProperty

        public abstract void setProperty(String name,
               Object value)
                          throws IllegalArgumentException
        Allows the user to set specific feature/property on the underlying implementation. The underlying implementation is not required to support every setting of every property in the specification and may use IllegalArgumentException to signal that an unsupported property may not be set with the specified value.
        参数：
        name - The name of the property (may not be null)
        value - The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • getProperty

        public abstract Object getProperty(String name)
                            throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        参数：
        name - The name of the property (may not be null)
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • isPropertySupported

        public abstract boolean isPropertySupported(String name)
        Query the set of properties that this factory supports.
        参数：
        name - The name of the property (may not be null)
        返回：
        true if the property is supported and false otherwise

      • setEventAllocator

        public abstract void setEventAllocator(XMLEventAllocator allocator)
        Set a user defined event allocator for events
        参数：
        allocator - the user defined allocator

      • getEventAllocator

        public abstract XMLEventAllocator getEventAllocator()
        Gets the allocator used by streams created with this factory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XMLOutputFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream

类 XMLOutputFactory

  • java.lang.Object
    • javax.xml.stream.XMLOutputFactory

  • public abstract class XMLOutputFactory
extends Object
    Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
    Configuration parameters
    Property Name | Behavior | Return type | Default Value | Required
    javax.xml.stream.isRepairingNamespaces | defaults prefixes on the output side | Boolean | False | Yes

    The following paragraphs describe the namespace and prefix repair algorithm:

    The property can be set with the following code line: setProperty("javax.xml.stream.isRepairingNamespaces",new Boolean(true|false));

    This property specifies that the writer default namespace prefix declarations. The default value is false.

    If a writer isRepairingNamespaces it will create a namespace declaration on the current StartElement for any attribute that does not currently have a namespace declaration in scope. If the StartElement has a uri but no prefix specified a prefix will be assigned, if the prefix has not been declared in a parent of the current StartElement it will be declared on the current StartElement. If the defaultNamespace is bound and in scope and the default namespace matches the URI of the attribute or StartElement QName no prefix will be assigned.

    If an element or attribute name has a prefix, but is not bound to any namespace URI, then the prefix will be removed during serialization.

    If element and/or attribute names in the same start or empty-element tag are bound to different namespace URIs and are using the same prefix then the element or the first occurring attribute retains the original prefix and the following attributes have their prefixes replaced with a new prefix that is bound to the namespace URIs of those attributes.

    If an element or attribute name uses a prefix that is bound to a different URI than that inherited from the namespace context of the parent of that element and there is no namespace declaration in the context of the current element then such a namespace declaration is added.

    If an element or attribute name is bound to a prefix and there is a namespace declaration that binds that prefix to a different URI then that namespace declaration is either removed if the correct mapping is inherited from the parent context of that element, or changed to the namespace URI of the element or attribute using that prefix.

    从以下版本开始：
    1.6
    另请参见：
    XMLInputFactory, XMLEventWriter, XMLStreamWriter

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String IS_REPAIRING_NAMESPACES
      Property used to set prefix defaulting on the output side

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | XMLOutputFactory()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer
      abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer
      abstract Object getProperty(String name)
      Get a feature/property on the underlying implementation
      abstract boolean isPropertySupported(String name)
      Query the set of properties that this factory supports.
      static XMLOutputFactory newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory newInstance()
      Create a new instance of the factory.
      static XMLInputFactory newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method newFactory(java.lang.String, java.lang.ClassLoader) instead.
      abstract void setProperty(String name, Object value)
      Allows the user to set specific features/properties on the underlying implementation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • IS_REPAIRING_NAMESPACES

        public static final String IS_REPAIRING_NAMESPACES
        Property used to set prefix defaulting on the output side
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • XMLOutputFactory

        protected XMLOutputFactory()

    • 方法详细信息

      • newInstance

        public static XMLOutputFactory newInstance()
                                    throws FactoryConfigurationError
        Create a new instance of the factory.
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLOutputFactory newFactory()
                                   throws FactoryConfigurationError
        Create a new instance of the factory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLOutputFactory implementation class to load: Use the javax.xml.stream.XMLOutputFactory system property. Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.stream.XMLOutputFactory in jars available to the runtime. Platform default XMLOutputFactory instance. Once an application has obtained a reference to a XMLOutputFactory it can use the factory to configure and obtain stream instances. Note that this is a new method that replaces the deprecated newInstance() method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newInstance

        public static XMLInputFactory newInstance(String factoryId,
                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Deprecated. This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method newFactory(java.lang.String, java.lang.ClassLoader) instead.
        Create a new instance of the factory.
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • newFactory

        public static XMLOutputFactory newFactory(String factoryId,
                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
        Create a new instance of the factory. If the classLoader argument is null, then the ContextClassLoader is used. Note that this is a new method that replaces the deprecated newInstance(String factoryId, ClassLoader classLoader) method. No changes in behavior are defined by this replacement method relative to the deprecated method.
        参数：
        factoryId - Name of the factory to find, same as a property name
        classLoader - classLoader to use
        返回：
        the factory implementation
        抛出：
        FactoryConfigurationError - if an instance of this factory cannot be loaded

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a writer
        参数：
        stream - the writer to write to
        抛出：
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a stream
        参数：
        stream - the stream to write to
        抛出：
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream,
                                    String encoding)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a stream
        参数：
        stream - the stream to write to
        encoding - the encoding to use
        抛出：
        XMLStreamException

      • createXMLStreamWriter

        public abstract XMLStreamWriter createXMLStreamWriter(Result result)
                                               throws XMLStreamException
        Create a new XMLStreamWriter that writes to a JAXP result. This method is optional.
        参数：
        result - the result to write to
        抛出：
        UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(Result result)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a JAXP result. This method is optional.
        参数：
        result - the result to write to
        抛出：
        UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a stream
        参数：
        stream - the stream to write to
        抛出：
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(OutputStream stream,
                                  String encoding)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a stream
        参数：
        stream - the stream to write to
        encoding - the encoding to use
        抛出：
        XMLStreamException

      • createXMLEventWriter

        public abstract XMLEventWriter createXMLEventWriter(Writer stream)
                                             throws XMLStreamException
        Create a new XMLEventWriter that writes to a writer
        参数：
        stream - the stream to write to
        抛出：
        XMLStreamException

      • setProperty

        public abstract void setProperty(String name,
               Object value)
                          throws IllegalArgumentException
        Allows the user to set specific features/properties on the underlying implementation.
        参数：
        name - The name of the property
        value - The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • getProperty

        public abstract Object getProperty(String name)
                            throws IllegalArgumentException
        Get a feature/property on the underlying implementation
        参数：
        name - The name of the property
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • isPropertySupported

        public abstract boolean isPropertySupported(String name)
        Query the set of properties that this factory supports.
        参数：
        name - The name of the property (may not be null)
        返回：
        true if the property is supported and false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m.///a.ja..//...=; c /= ss/c"l=L"ia==ctcgg(o-


XMLReporter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLReporter

  • public interface XMLReporter
    This interface is used to report non-fatal errors. Only warnings should be echoed through this interface.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.

    • 方法详细信息

      • report

        void report(String message,
          String errorType,
          Object relatedInformation,
          Location location)
            throws XMLStreamException
        Report the desired message in an application specific format. Only warnings and non-fatal errors should be reported through this interface. Fatal errors should be thrown as XMLStreamException.
        参数：
        message - the error message
        errorType - an implementation defined error type
        relatedInformation - information related to the error, if available
        location - the location of the error, if available
        抛出：
        XMLStreamException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s3l""d0"dreedrryella


XMLResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLResolver

  • public interface XMLResolver
    This interface is used to resolve resources during an XML parse. If an application wishes to perform custom entity resolution it must register an instance of this interface with the XMLInputFactory using the setXMLResolver method.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object resolveEntity(String publicID, String systemID, String baseURI, String namespace)
      Retrieves a resource.

    • 方法详细信息

      • resolveEntity

        Object resolveEntity(String publicID,
                   String systemID,
                   String baseURI,
                   String namespace)
                     throws XMLStreamException
        Retrieves a resource. This resource can be of the following three return types: (1) java.io.InputStream (2) javax.xml.stream.XMLStreamReader (3) java.xml.stream.XMLEventReader. If this method returns null the processor will attempt to resolve the entity using its default mechanism.
        参数：
        publicID - The public identifier of the external entity being referenced, or null if none was supplied.
        systemID - The system identifier of the external entity being referenced.
        baseURI - Absolute base URI associated with systemId.
        namespace - The namespace of the entity to resolve.
        返回：
        The resource requested or null.
        抛出：
        XMLStreamException - if there was a failure attempting to resolve the resource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=a


XMLStreamConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.stream

Interface XMLStreamConstants

  • All Known Subinterfaces:
    Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement, XMLEvent, XMLStreamReader
    All Known Implementing Classes:
    StreamReaderDelegate

    public interface XMLStreamConstants
    This interface declares the constants used in this API. Numbers in the range 0 to 256 are reserved for the specification, user defined events must use event codes outside that range.
    从以下版本开始：
    1.6

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ATTRIBUTE
      Indicates an event is an attribute
      static int CDATA
      Indicates an event is a CDATA section
      static int CHARACTERS
      Indicates an event is characters
      static int COMMENT
      Indicates an event is a comment
      static int DTD
      Indicates an event is a DTD
      static int END_DOCUMENT
      Indicates an event is an end document
      static int END_ELEMENT
      Indicates an event is an end element
      static int ENTITY_DECLARATION
      Indicates a Entity Declaration
      static int ENTITY_REFERENCE
      Indicates an event is an entity reference
      static int NAMESPACE
      Indicates the event is a namespace declaration
      static int NOTATION_DECLARATION
      Indicates a Notation
      static int PROCESSING_INSTRUCTION
      Indicates an event is a processing instruction
      static int SPACE
      The characters are white space (see [XML], 2.10 "White Space Handling").
      static int START_DOCUMENT
      Indicates an event is a start document
      static int START_ELEMENT
      Indicates an event is a start element

    • 字段详细信息

      • START_ELEMENT

        static final int START_ELEMENT
        Indicates an event is a start element
        另请参见：
        StartElement, Constant Field Values

      • END_ELEMENT

        static final int END_ELEMENT
        Indicates an event is an end element
        另请参见：
        EndElement, Constant Field Values

      • PROCESSING_INSTRUCTION

        static final int PROCESSING_INSTRUCTION
        Indicates an event is a processing instruction
        另请参见：
        ProcessingInstruction, Constant Field Values

      • CHARACTERS

        static final int CHARACTERS
        Indicates an event is characters
        另请参见：
        Characters, Constant Field Values

      • COMMENT

        static final int COMMENT
        Indicates an event is a comment
        另请参见：
        Comment, Constant Field Values

      • SPACE

        static final int SPACE
        The characters are white space (see [XML], 2.10 "White Space Handling"). Events are only reported as SPACE if they are ignorable white space. Otherwise they are reported as CHARACTERS.
        另请参见：
        Characters, Constant Field Values

      • START_DOCUMENT

        static final int START_DOCUMENT
        Indicates an event is a start document
        另请参见：
        StartDocument, Constant Field Values

      • END_DOCUMENT

        static final int END_DOCUMENT
        Indicates an event is an end document
        另请参见：
        EndDocument, Constant Field Values

      • ENTITY_REFERENCE

        static final int ENTITY_REFERENCE
        Indicates an event is an entity reference
        另请参见：
        EntityReference, Constant Field Values

      • ATTRIBUTE

        static final int ATTRIBUTE
        Indicates an event is an attribute
        另请参见：
        Attribute, Constant Field Values

      • DTD

        static final int DTD
        Indicates an event is a DTD
        另请参见：
        DTD, Constant Field Values

      • CDATA

        static final int CDATA
        Indicates an event is a CDATA section
        另请参见：
        Characters, Constant Field Values

      • NAMESPACE

        static final int NAMESPACE
        Indicates the event is a namespace declaration
        另请参见：
        Namespace, Constant Field Values

      • NOTATION_DECLARATION

        static final int NOTATION_DECLARATION
        Indicates a Notation
        另请参见：
        NotationDeclaration, Constant Field Values

      • ENTITY_DECLARATION

        static final int ENTITY_DECLARATION
        Indicates a Entity Declaration
        另请参见：
        NotationDeclaration, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtiEeETEs sR


XMLStreamException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream

类 XMLStreamException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
  • 所有已实现的接口：
    Serializable

    public class XMLStreamException
extends Exception
    The base exception for unexpected processing errors. This Exception class is used to report well-formedness errors as well as unexpected processing conditions.
    从以下版本开始：
    1.6
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected Location | location
      protected Throwable | 嵌套

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLStreamException()
      Default constructor
      XMLStreamException(String msg)
      Construct an exception with the assocated message.
      XMLStreamException(String msg, Location location)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Location location, Throwable th)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Throwable th)
      Construct an exception with the assocated message and exception
      XMLStreamException(Throwable th)
      Construct an exception with the assocated exception

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Location getLocation()
      Gets the location of the exception
      Throwable getNestedException()
      Gets the nested exception.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • nested

        protected Throwable nested

      • location

        protected Location location

    • 构造方法详细信息

      • XMLStreamException

        public XMLStreamException()
        Default constructor

      • XMLStreamException

        public XMLStreamException(String msg)
        Construct an exception with the assocated message.
        参数：
        msg - the message to report

      • XMLStreamException

        public XMLStreamException(Throwable th)
        Construct an exception with the assocated exception
        参数：
        th - a nested exception

      • XMLStreamException

        public XMLStreamException(String msg,
                  Throwable th)
        Construct an exception with the assocated message and exception
        参数：
        th - a nested exception
        msg - the message to report

      • XMLStreamException

        public XMLStreamException(String msg,
                  Location location,
                  Throwable th)
        Construct an exception with the assocated message, exception and location.
        参数：
        th - a nested exception
        msg - the message to report
        location - the location of the error

      • XMLStreamException

        public XMLStreamException(String msg,
                  Location location)
        Construct an exception with the assocated message, exception and location.
        参数：
        msg - the message to report
        location - the location of the error

    • 方法详细信息

      • getNestedException

        public Throwable getNestedException()
        Gets the nested exception.
        返回：
        Nested exception

      • getLocation

        public Location getLocation()
        Gets the location of the exception
        返回：
        the location of the exception, may be null if none is available
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m.eNtN"NaN> ram<�"tttonmsattn/rem/?./


XMLStreamReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLStreamReader

  • All Superinterfaces:
    XMLStreamConstants
    All Known Implementing Classes:
    StreamReaderDelegate

    public interface XMLStreamReader
extends XMLStreamConstants
    The XMLStreamReader interface allows forward, read-only access to XML. It is designed to be the lowest level and most efficient way to read XML data.

    The XMLStreamReader is designed to iterate over XML using next() and hasNext(). The data can be accessed using methods such as getEventType(), getNamespaceURI(), getLocalName() and getText();

    The next() method causes the reader to read the next parse event. The next() method returns an integer which identifies the type of event just read.

    The event type can be determined using getEventType().

    Parsing events are defined as the XML Declaration, a DTD, start tag, character data, white space, end tag, comment, or processing instruction. An attribute or namespace event may be encountered at the root level of a document as the result of a query operation.

    For XML 1.0 compliance an XML processor must pass the identifiers of declared unparsed entities, notation declarations and their associated identifiers to the application. This information is provided through the property API on this interface. The following two properties allow access to this information: javax.xml.stream.notations and javax.xml.stream.entities. When the current event is a DTD the following call will return a list of Notations List l = (List) getProperty("javax.xml.stream.notations"); The following call will return a list of entity declarations: List l = (List) getProperty("javax.xml.stream.entities"); These properties can only be accessed during a DTD event and are defined to return null if the information is not available.

    The following table describes which methods are valid in what state. If a method is called in an invalid state the method will throw a java.lang.IllegalStateException.

    Valid methods for each state
    Event Type | Valid Methods
    All States | getProperty(), hasNext(), require(), close(), getNamespaceURI(), isStartElement(), isEndElement(), isCharacters(), isWhiteSpace(), getNamespaceContext(), getEventType(),getLocation(), hasText(), hasName()
    START_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getAttributeXXX(), isAttributeSpecified(), getNamespaceXXX(), getElementText(), nextTag()
    ATTRIBUTE | next(), nextTag() getAttributeXXX(), isAttributeSpecified(),
    NAMESPACE | next(), nextTag() getNamespaceXXX()
    END_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getNamespaceXXX(), nextTag()
    CHARACTERS | next(), getTextXXX(), nextTag()
    CDATA | next(), getTextXXX(), nextTag()
    COMMENT | next(), getTextXXX(), nextTag()
    SPACE | next(), getTextXXX(), nextTag()
    START_DOCUMENT | next(), getEncoding(), getVersion(), isStandalone(), standaloneSet(), getCharacterEncodingScheme(), nextTag()
    END_DOCUMENT | close()
    PROCESSING_INSTRUCTION | next(), getPITarget(), getPIData(), nextTag()
    ENTITY_REFERENCE | next(), getLocalName(), getText(), nextTag()
    DTD | next(), getText(), nextTag()
    从以下版本开始：
    1.6
    另请参见：
    XMLEvent, XMLInputFactory, XMLStreamWriter

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Frees any resources associated with this Reader.
      int getAttributeCount()
      Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
      String getAttributeLocalName(int index)
      Returns the localName of the attribute at the provided index
      QName getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      String getAttributeNamespace(int index)
      Returns the namespace of the attribute at the provided index
      String getAttributePrefix(int index)
      Returns the prefix of this attribute at the provided index
      String getAttributeType(int index)
      Returns the XML type of the attribute at the provided index
      String getAttributeValue(int index)
      Returns the value of the attribute at the index
      String getAttributeValue(String namespaceURI, String localName)
      Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
      String getCharacterEncodingScheme()
      Returns the character encoding declared on the xml declaration Returns null if none was declared
      String getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String getEncoding()
      Return input encoding if known or null if unknown.
      int getEventType()
      Returns an integer code that indicates the type of the event the cursor is pointing to.
      String getLocalName()
      Returns the (local) name of the current event.
      Location getLocation()
      Return the current location of the processor.
      QName getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      NamespaceContext getNamespaceContext()
      Returns a read only namespace context for the current position.
      int getNamespaceCount()
      Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
      String getNamespacePrefix(int index)
      Returns the prefix for the namespace declared at the index.
      String getNamespaceURI()
      If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
      String getNamespaceURI(int index)
      Returns the uri for the namespace declared at the index.
      String getNamespaceURI(String prefix)
      Return the uri for the given prefix.
      String getPIData()
      Get the data section of a processing instruction
      String getPITarget()
      Get the target of a processing instruction
      String getPrefix()
      Returns the prefix of the current event or null if the event does not have a prefix
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      String getText()
      Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
      char[] getTextCharacters()
      Returns an array which contains the characters from this event.
      int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      int getTextLength()
      Returns the length of the sequence of characters for this Text event within the text character array.
      int getTextStart()
      Returns the offset into the text character array where the first character (of this text event) is stored.
      String getVersion()
      Get the xml version declared on the xml declaration Returns null if none was declared
      boolean hasName()
      returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
      boolean hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      boolean hasText()
      Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
      boolean isAttributeSpecified(int index)
      Returns a boolean which indicates if this attribute was created by default
      boolean isCharacters()
      Returns true if the cursor points to a character data event
      boolean isEndElement()
      Returns true if the cursor points to an end tag (otherwise false)
      boolean isStandalone()
      Get the standalone declaration from the xml declaration
      boolean isStartElement()
      Returns true if the cursor points to a start tag (otherwise false)
      boolean isWhiteSpace()
      Returns true if the cursor points to a character data event that consists of all whitespace
      int 下一个()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      int nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      void require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      boolean standaloneSet()
      Checks if standalone was set in the document

    • 方法详细信息

      • getProperty

        Object getProperty(String name)
                   throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        参数：
        name - The name of the property, may not be null
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if name is null

      • 下一个

        int next()
         throws XMLStreamException
        Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

        Given the following XML:
        <foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
        The behavior of calling next() when being on foo will be:
        1- the comment (COMMENT)
        2- then the characters section (CHARACTERS)
        3- then the CDATA section (another CHARACTERS)
        4- then the next characters section (another CHARACTERS)
        5- then the END_ELEMENT

        NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

        返回：
        the integer code corresponding to the current parse event
        抛出：
        NoSuchElementException - if this is called when hasNext() returns false
        XMLStreamException - if there is an error processing the underlying XML source
        另请参见：
        XMLEvent

      • require

        void require(int type,
           String namespaceURI,
           String localName)
             throws XMLStreamException
        Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.
        参数：
        type - the event type
        namespaceURI - the uri of the event, may be null
        localName - the localName of the event, may be null
        抛出：
        XMLStreamException - if the required values are not matched.

      • getElementText

        String getElementText()
                      throws XMLStreamException
        Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
        Precondition: the current event is START_ELEMENT.
        Postcondition: the current event is the corresponding END_ELEMENT.
        The method does the following (implementations are free to optimized but must do equivalent processing):
         if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();
        抛出：
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        int nextTag()
            throws XMLStreamException
        Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
        Precondition: none
        Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
        Essentially it does the following (implementations are free to optimized but must do equivalent processing):
         int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;
        返回：
        the event type of the element read (START_ELEMENT or END_ELEMENT)
        抛出：
        XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT
        NoSuchElementException - if this is called when hasNext() returns false

      • hasNext

        boolean hasNext()
                throws XMLStreamException
        Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT
        返回：
        true if there are more events, false otherwise
        抛出：
        XMLStreamException - if there is a fatal error detecting the next state

      • close

        void close()
           throws XMLStreamException
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        抛出：
        XMLStreamException - if there are errors freeing associated resources

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Return the uri for the given prefix. The uri returned depends on the current state of the processor.

        NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

        NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

        参数：
        prefix - The prefix to lookup, may not be null
        返回：
        the uri bound to the given prefix or null if it is not bound
        抛出：
        IllegalArgumentException - if the prefix is null

      • isStartElement

        boolean isStartElement()
        Returns true if the cursor points to a start tag (otherwise false)
        返回：
        true if the cursor points to a start tag, false otherwise

      • isEndElement

        boolean isEndElement()
        Returns true if the cursor points to an end tag (otherwise false)
        返回：
        true if the cursor points to an end tag, false otherwise

      • isCharacters

        boolean isCharacters()
        Returns true if the cursor points to a character data event
        返回：
        true if the cursor points to character data, false otherwise

      • isWhiteSpace

        boolean isWhiteSpace()
        Returns true if the cursor points to a character data event that consists of all whitespace
        返回：
        true if the cursor points to all whitespace, false otherwise

      • getAttributeValue

        String getAttributeValue(String namespaceURI,
                       String localName)
        Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
        参数：
        namespaceURI - the namespace of the attribute
        localName - the local name of the attribute, cannot be null
        返回：
        returns the value of the attribute , returns null if not found
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeCount

        int getAttributeCount()
        Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.
        返回：
        returns the number of attributes
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeName

        QName getAttributeName(int index)
        Returns the qname of the attribute at the provided index
        参数：
        index - the position of the attribute
        返回：
        the QName of the attribute
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeNamespace

        String getAttributeNamespace(int index)
        Returns the namespace of the attribute at the provided index
        参数：
        index - the position of the attribute
        返回：
        the namespace URI (can be null)
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeLocalName

        String getAttributeLocalName(int index)
        Returns the localName of the attribute at the provided index
        参数：
        index - the position of the attribute
        返回：
        the localName of the attribute
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributePrefix

        String getAttributePrefix(int index)
        Returns the prefix of this attribute at the provided index
        参数：
        index - the position of the attribute
        返回：
        the prefix of the attribute
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeType

        String getAttributeType(int index)
        Returns the XML type of the attribute at the provided index
        参数：
        index - the position of the attribute
        返回：
        the XML type of the attribute
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getAttributeValue

        String getAttributeValue(int index)
        Returns the value of the attribute at the index
        参数：
        index - the position of the attribute
        返回：
        the attribute value
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • isAttributeSpecified

        boolean isAttributeSpecified(int index)
        Returns a boolean which indicates if this attribute was created by default
        参数：
        index - the position of the attribute
        返回：
        true if this is a default attribute
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

      • getNamespaceCount

        int getNamespaceCount()
        Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.
        返回：
        returns the number of namespace declarations on this specific element
        抛出：
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespacePrefix

        String getNamespacePrefix(int index)
        Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration
        参数：
        index - the position of the namespace declaration
        返回：
        returns the namespace prefix
        抛出：
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespaceURI

        String getNamespaceURI(int index)
        Returns the uri for the namespace declared at the index.
        参数：
        index - the position of the namespace declaration
        返回：
        returns the namespace uri
        抛出：
        IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.
        返回：
        return a namespace context

      • getEventType

        int getEventType()
        Returns an integer code that indicates the type of the event the cursor is pointing to.

      • getText

        String getText()
        Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.
        返回：
        the current text or null
        抛出：
        IllegalStateException - if this state is not a valid text state.

      • getTextCharacters

        char[] getTextCharacters()
        Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.
        返回：
        the current text or an empty array
        抛出：
        IllegalStateException - if this state is not a valid text state.

      • getTextCharacters

        int getTextCharacters(int sourceStart,
                    char[] target,
                    int targetStart,
                    int length)
                      throws XMLStreamException
        Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example: int length = 1024; char[] myBuffer = new char[ length ]; for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length ); if (nCopied < length) break; } XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".
        参数：
        sourceStart - the index of the first character in the source array to copy
        target - the destination array
        targetStart - the start offset in the target array
        length - the number of characters to copy
        返回：
        the number of characters actually copied
        抛出：
        XMLStreamException - if the underlying XML source is not well-formed
        IndexOutOfBoundsException - if targetStart < 0 or > than the length of target
        IndexOutOfBoundsException - if length < 0 or targetStart + length > length of target
        UnsupportedOperationException - if this method is not supported
        NullPointerException - is if target is null

      • getTextStart

        int getTextStart()
        Returns the offset into the text character array where the first character (of this text event) is stored.
        抛出：
        IllegalStateException - if this state is not a valid text state.

      • getTextLength

        int getTextLength()
        Returns the length of the sequence of characters for this Text event within the text character array.
        抛出：
        IllegalStateException - if this state is not a valid text state.

      • getEncoding

        String getEncoding()
        Return input encoding if known or null if unknown.
        返回：
        the encoding of this instance or null

      • hasText

        boolean hasText()
        Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE

      • getLocation

        Location getLocation()
        Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.

      • getName

        QName getName()
        Returns a QName for the current START_ELEMENT or END_ELEMENT event
        返回：
        the QName for the current START_ELEMENT or END_ELEMENT event
        抛出：
        IllegalStateException - if this is not a START_ELEMENT or END_ELEMENT

      • getLocalName

        String getLocalName()
        Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE
        返回：
        the localName
        抛出：
        IllegalStateException - if this not a START_ELEMENT, END_ELEMENT or ENTITY_REFERENCE

      • hasName

        boolean hasName()
        returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise

      • getNamespaceURI

        String getNamespaceURI()
        If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.
        返回：
        the URI bound to this elements prefix, the default namespace, or null

      • getPrefix

        String getPrefix()
        Returns the prefix of the current event or null if the event does not have a prefix
        返回：
        the prefix or null

      • getVersion

        String getVersion()
        Get the xml version declared on the xml declaration Returns null if none was declared
        返回：
        the XML version or null

      • isStandalone

        boolean isStandalone()
        Get the standalone declaration from the xml declaration
        返回：
        true if this is standalone, or false otherwise

      • standaloneSet

        boolean standaloneSet()
        Checks if standalone was set in the document
        返回：
        true if standalone was set in the document, or false otherwise

      • getCharacterEncodingScheme

        String getCharacterEncodingScheme()
        Returns the character encoding declared on the xml declaration Returns null if none was declared
        返回：
        the encoding declared in the document or null

      • getPITarget

        String getPITarget()
        Get the target of a processing instruction
        返回：
        the target or null

      • getPIData

        String getPIData()
        Get the data section of a processing instruction
        返回：
        the data or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


XMLStreamWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream

Interface XMLStreamWriter

  • public interface XMLStreamWriter
    The XMLStreamWriter interface specifies how to write XML. The XMLStreamWriter does not perform well formedness checking on its input. However the writeCharacters method is required to escape & , < and > For attribute values the writeAttribute method will escape the above characters plus " to ensure that all character content and attribute values are well formed. Each NAMESPACE and ATTRIBUTE must be individually written.
    XML Namespaces, javax.xml.stream.isRepairingNamespaces and write method behaviour
    Method | isRepairingNamespaces == true | isRepairingNamespaces == false
    namespaceURI bound | namespaceURI unbound | namespaceURI bound | namespaceURI unbound
    writeAttribute(namespaceURI, localName, value) | prefix:localName="value" [1] | xmlns:{generated}="namespaceURI" {generated}:localName="value" | prefix:localName="value" [1] | XMLStreamException
    writeAttribute(prefix, namespaceURI, localName, value) bound to same prefix:
    prefix:localName="value" [1]

    bound to different prefix:
    xmlns:{generated}="namespaceURI" {generated}:localName="value"     		xmlns:prefix="namespaceURI" prefix:localName="value" [3] bound to same prefix:
    prefix:localName="value" [1][2]

    bound to different prefix:
    XMLStreamException[2]     		xmlns:prefix="namespaceURI" prefix:localName="value" [2][5]
    writeStartElement(namespaceURI, localName)

    writeEmptyElement(namespaceURI, localName)     		<prefix:localName> [1] <{generated}:localName xmlns:{generated}="namespaceURI"> <prefix:localName> [1] XMLStreamException
    writeStartElement(prefix, localName, namespaceURI)

    writeEmptyElement(prefix, localName, namespaceURI)     		bound to same prefix:
    <prefix:localName> [1]

    bound to different prefix:
    <{generated}:localName xmlns:{generated}="namespaceURI">     		<prefix:localName xmlns:prefix="namespaceURI"> [4] bound to same prefix:
    <prefix:localName> [1]

    bound to different prefix:
    XMLStreamException     		<prefix:localName>
    Notes:
    • [1] if namespaceURI == default Namespace URI, then no prefix is written
    • [2] if prefix == "" || null && namespaceURI == "", then no prefix or Namespace declaration is generated or written
    • [3] if prefix == "" || null, then a prefix is randomly generated
    • [4] if prefix == "" || null, then it is treated as the default Namespace and no prefix is generated or written, an xmlns declaration is generated and written if the namespaceURI is unbound
    • [5] if prefix == "" || null, then it is treated as an invalid attempt to define the default Namespace and an XMLStreamException is thrown
    从以下版本开始：
    1.6
    另请参见：
    XMLOutputFactory, XMLStreamReader

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Close this writer and free any resources associated with the writer.
      void flush()
      Write any cached data to the underlying output mechanism.
      NamespaceContext getNamespaceContext()
      Returns the current namespace context.
      String getPrefix(String uri)
      Gets the prefix the uri is bound to
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      void setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void writeAttribute(String localName, String value)
      Writes an attribute to the output stream without a prefix.
      void writeAttribute(String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void writeAttribute(String prefix, String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void writeCData(String data)
      Writes a CData section
      void writeCharacters(char[] text, int start, int len)
      Write text to the output
      void writeCharacters(String text)
      Write text to the output
      void writeComment(String data)
      Writes an xml comment with the data enclosed
      void writeDefaultNamespace(String namespaceURI)
      Writes the default namespace to the stream
      void writeDTD(String dtd)
      Write a DTD section.
      void writeEmptyElement(String localName)
      Writes an empty element tag to the output
      void writeEmptyElement(String namespaceURI, String localName)
      Writes an empty element tag to the output
      void writeEmptyElement(String prefix, String localName, String namespaceURI)
      Writes an empty element tag to the output
      void writeEndDocument()
      Closes any start tags and writes corresponding end tags.
      void writeEndElement()
      Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
      void writeEntityRef(String name)
      Writes an entity reference
      void writeNamespace(String prefix, String namespaceURI)
      Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
      void writeProcessingInstruction(String target)
      Writes a processing instruction
      void writeProcessingInstruction(String target, String data)
      Writes a processing instruction
      void writeStartDocument()
      Write the XML Declaration.
      void writeStartDocument(String version)
      Write the XML Declaration.
      void writeStartDocument(String encoding, String version)
      Write the XML Declaration.
      void writeStartElement(String localName)
      Writes a start tag to the output.
      void writeStartElement(String namespaceURI, String localName)
      Writes a start tag to the output
      void writeStartElement(String prefix, String localName, String namespaceURI)
      Writes a start tag to the output

    • 方法详细信息

      • writeStartElement

        void writeStartElement(String localName)
                       throws XMLStreamException
        Writes a start tag to the output. All writeStartElement methods open a new scope in the internal namespace context. Writing the corresponding EndElement causes the scope to be closed.
        参数：
        localName - local name of the tag, may not be null
        抛出：
        XMLStreamException

      • writeStartElement

        void writeStartElement(String namespaceURI,
                     String localName)
                       throws XMLStreamException
        Writes a start tag to the output
        参数：
        namespaceURI - the namespaceURI of the prefix to use, may not be null
        localName - local name of the tag, may not be null
        抛出：
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeStartElement

        void writeStartElement(String prefix,
                     String localName,
                     String namespaceURI)
                       throws XMLStreamException
        Writes a start tag to the output
        参数：
        localName - local name of the tag, may not be null
        prefix - the prefix of the tag, may not be null
        namespaceURI - the uri to bind the prefix to, may not be null
        抛出：
        XMLStreamException

      • writeEmptyElement

        void writeEmptyElement(String namespaceURI,
                     String localName)
                       throws XMLStreamException
        Writes an empty element tag to the output
        参数：
        namespaceURI - the uri to bind the tag to, may not be null
        localName - local name of the tag, may not be null
        抛出：
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeEmptyElement

        void writeEmptyElement(String prefix,
                     String localName,
                     String namespaceURI)
                       throws XMLStreamException
        Writes an empty element tag to the output
        参数：
        prefix - the prefix of the tag, may not be null
        localName - local name of the tag, may not be null
        namespaceURI - the uri to bind the tag to, may not be null
        抛出：
        XMLStreamException

      • writeEmptyElement

        void writeEmptyElement(String localName)
                       throws XMLStreamException
        Writes an empty element tag to the output
        参数：
        localName - local name of the tag, may not be null
        抛出：
        XMLStreamException

      • writeEndElement

        void writeEndElement()
                     throws XMLStreamException
        Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
        抛出：
        XMLStreamException

      • writeEndDocument

        void writeEndDocument()
                      throws XMLStreamException
        Closes any start tags and writes corresponding end tags.
        抛出：
        XMLStreamException

      • close

        void close()
           throws XMLStreamException
        Close this writer and free any resources associated with the writer. This must not close the underlying output stream.
        抛出：
        XMLStreamException

      • flush

        void flush()
           throws XMLStreamException
        Write any cached data to the underlying output mechanism.
        抛出：
        XMLStreamException

      • writeAttribute

        void writeAttribute(String localName,
                  String value)
                    throws XMLStreamException
        Writes an attribute to the output stream without a prefix.
        参数：
        localName - the local name of the attribute
        value - the value of the attribute
        抛出：
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException

      • writeAttribute

        void writeAttribute(String prefix,
                  String namespaceURI,
                  String localName,
                  String value)
                    throws XMLStreamException
        Writes an attribute to the output stream
        参数：
        prefix - the prefix for this attribute
        namespaceURI - the uri of the prefix for this attribute
        localName - the local name of the attribute
        value - the value of the attribute
        抛出：
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeAttribute

        void writeAttribute(String namespaceURI,
                  String localName,
                  String value)
                    throws XMLStreamException
        Writes an attribute to the output stream
        参数：
        namespaceURI - the uri of the prefix for this attribute
        localName - the local name of the attribute
        value - the value of the attribute
        抛出：
        IllegalStateException - if the current state does not allow Attribute writing
        XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isRepairingNamespaces has not been set to true

      • writeNamespace

        void writeNamespace(String prefix,
                  String namespaceURI)
                    throws XMLStreamException
        Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
        参数：
        prefix - the prefix to bind this namespace to
        namespaceURI - the uri to bind the prefix to
        抛出：
        IllegalStateException - if the current state does not allow Namespace writing
        XMLStreamException

      • writeDefaultNamespace

        void writeDefaultNamespace(String namespaceURI)
                           throws XMLStreamException
        Writes the default namespace to the stream
        参数：
        namespaceURI - the uri to bind the default namespace to
        抛出：
        IllegalStateException - if the current state does not allow Namespace writing
        XMLStreamException

      • writeComment

        void writeComment(String data)
                  throws XMLStreamException
        Writes an xml comment with the data enclosed
        参数：
        data - the data contained in the comment, may be null
        抛出：
        XMLStreamException

      • writeProcessingInstruction

        void writeProcessingInstruction(String target)
                                throws XMLStreamException
        Writes a processing instruction
        参数：
        target - the target of the processing instruction, may not be null
        抛出：
        XMLStreamException

      • writeProcessingInstruction

        void writeProcessingInstruction(String target,
                              String data)
                                throws XMLStreamException
        Writes a processing instruction
        参数：
        target - the target of the processing instruction, may not be null
        data - the data contained in the processing instruction, may not be null
        抛出：
        XMLStreamException

      • writeCData

        void writeCData(String data)
                throws XMLStreamException
        Writes a CData section
        参数：
        data - the data contained in the CData Section, may not be null
        抛出：
        XMLStreamException

      • writeDTD

        void writeDTD(String dtd)
              throws XMLStreamException
        Write a DTD section. This string represents the entire doctypedecl production from the XML 1.0 specification.
        参数：
        dtd - the DTD to be written
        抛出：
        XMLStreamException

      • writeEntityRef

        void writeEntityRef(String name)
                    throws XMLStreamException
        Writes an entity reference
        参数：
        name - the name of the entity
        抛出：
        XMLStreamException

      • writeStartDocument

        void writeStartDocument()
                        throws XMLStreamException
        Write the XML Declaration. Defaults the XML version to 1.0, and the encoding to utf-8
        抛出：
        XMLStreamException

      • writeStartDocument

        void writeStartDocument(String version)
                        throws XMLStreamException
        Write the XML Declaration. Defaults the XML version to 1.0
        参数：
        version - version of the xml document
        抛出：
        XMLStreamException

      • writeStartDocument

        void writeStartDocument(String encoding,
                      String version)
                        throws XMLStreamException
        Write the XML Declaration. Note that the encoding parameter does not set the actual encoding of the underlying output. That must be set when the instance of the XMLStreamWriter is created using the XMLOutputFactory
        参数：
        encoding - encoding of the xml declaration
        version - version of the xml document
        抛出：
        XMLStreamException - If given encoding does not match encoding of the underlying stream

      • writeCharacters

        void writeCharacters(String text)
                     throws XMLStreamException
        Write text to the output
        参数：
        text - the value to write
        抛出：
        XMLStreamException

      • writeCharacters

        void writeCharacters(char[] text,
                   int start,
                   int len)
                     throws XMLStreamException
        Write text to the output
        参数：
        text - the value to write
        start - the starting position in the array
        len - the number of characters to write
        抛出：
        XMLStreamException

      • getPrefix

        String getPrefix(String uri)
                 throws XMLStreamException
        Gets the prefix the uri is bound to
        返回：
        the prefix or null
        抛出：
        XMLStreamException

      • setPrefix

        void setPrefix(String prefix,
             String uri)
               throws XMLStreamException
        Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.
        参数：
        prefix - the prefix to bind to the uri, may not be null
        uri - the uri to bind to the prefix, may be null
        抛出：
        XMLStreamException

      • setDefaultNamespace

        void setDefaultNamespace(String uri)
                         throws XMLStreamException
        Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.
        参数：
        uri - the uri to bind to the default namespace, may be null
        抛出：
        XMLStreamException

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
        Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces. This method may only be called once at the start of the document. It does not cause the namespaces to be declared. If a namespace URI to prefix mapping is found in the namespace context it is treated as declared and the prefix may be used by the StreamWriter.
        参数：
        context - the namespace context to use for this writer, may not be null
        抛出：
        XMLStreamException

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Returns the current namespace context.
        返回：
        the current NamespaceContext

      • getProperty

        Object getProperty(String name)
                   throws IllegalArgumentException
        Get the value of a feature/property from the underlying implementation
        参数：
        name - The name of the property, may not be null
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported
        NullPointerException - if the name is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ca/tdan eta >a


Uses of Class javax.xml.stream.FactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.FactoryConfigurationError

  • Packages that use FactoryConfigurationError
    软件包 描述
    javax.xml.stream

    • Uses of FactoryConfigurationError in javax.xml.stream

      Methods in javax.xml.stream that throw FactoryConfigurationError
      修饰符与类型 方法与描述
      static XMLOutputFactory XMLOutputFactory.newFactory()
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newFactory()
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newInstance()
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newInstance()
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newInstance()
      Create a new instance of the factory
      static XMLInputFactory XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) instead.
      static XMLInputFactory XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
      static XMLEventFactory XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r.s"so.-s"s=a euaka.t


Uses of Class javax.xml.stream.XMLEventFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.XMLEventFactory

  • Packages that use XMLEventFactory
    软件包 描述
    javax.xml.stream

    • Uses of XMLEventFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventFactory
      修饰符与类型 方法与描述
      static XMLEventFactory XMLEventFactory.newFactory()
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLEventFactory XMLEventFactory.newInstance()
      Create a new instance of the factory
      static XMLEventFactory XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dai/o.(ecpppmitena/脁黮mt


Uses of Class javax.xml.stream.XMLInputFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.XMLInputFactory

  • Packages that use XMLInputFactory
    软件包 描述
    javax.xml.stream

    • Uses of XMLInputFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLInputFactory
      修饰符与类型 方法与描述
      static XMLInputFactory XMLInputFactory.newFactory()
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLInputFactory XMLInputFactory.newInstance()
      Create a new instance of the factory.
      static XMLInputFactory XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) instead.
      static XMLInputFactory XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
      Deprecated.
      This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e.(tro>a<<>/Er.cMtlt


Uses of Class javax.xml.stream.XMLOutputFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.XMLOutputFactory

  • Packages that use XMLOutputFactory
    软件包 描述
    javax.xml.stream

    • Uses of XMLOutputFactory in javax.xml.stream

      Methods in javax.xml.stream that return XMLOutputFactory
      修饰符与类型 方法与描述
      static XMLOutputFactory XMLOutputFactory.newFactory()
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newFactory(String factoryId, ClassLoader classLoader)
      Create a new instance of the factory.
      static XMLOutputFactory XMLOutputFactory.newInstance()
      Create a new instance of the factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otmaskife=== >""BABA TO


Uses of Class javax.xml.stream.XMLStreamException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.XMLStreamException

  • Packages that use XMLStreamException
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamException in javax.xml.stream

      Methods in javax.xml.stream that throw XMLStreamException
      修饰符与类型 方法与描述
      void XMLEventWriter.add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
      void XMLEventWriter.add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      void XMLStreamWriter.close()
      Close this writer and free any resources associated with the writer.
      void XMLStreamReader.close()
      Frees any resources associated with this Reader.
      void XMLEventWriter.close()
      Frees any resources associated with this stream
      void XMLEventReader.close()
      Frees any resources associated with this Reader.
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer
      void XMLStreamWriter.flush()
      Write any cached data to the underlying output mechanism.
      void XMLEventWriter.flush()
      Writes any cached events to the underlying output mechanism
      String XMLStreamReader.getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String XMLEventReader.getElementText()
      Reads the content of a text-only element.
      String XMLStreamWriter.getPrefix(String uri)
      Gets the prefix the uri is bound to
      String XMLEventWriter.getPrefix(String uri)
      Gets the prefix the uri is bound to
      int XMLStreamReader.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      boolean XMLStreamReader.hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      int XMLStreamReader.下一个()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      XMLEvent XMLEventReader.nextEvent()
      Get the next XMLEvent
      int XMLStreamReader.nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent XMLEventReader.nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent XMLEventReader.peek()
      Check the next XMLEvent without reading it from the stream.
      void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.
      void XMLStreamReader.require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      Object XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
      Retrieves a resource.
      void XMLStreamWriter.setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void XMLEventWriter.setDefaultNamespace(String uri)
      Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
      void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLEventWriter.setNamespaceContext(NamespaceContext context)
      Sets the current namespace context for prefix and uri bindings.
      void XMLStreamWriter.setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void XMLEventWriter.setPrefix(String prefix, String uri)
      Sets the prefix the uri is bound to.
      void XMLStreamWriter.writeAttribute(String localName, String value)
      Writes an attribute to the output stream without a prefix.
      void XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
      Writes an attribute to the output stream
      void XMLStreamWriter.writeCData(String data)
      Writes a CData section
      void XMLStreamWriter.writeCharacters(char[] text, int start, int len)
      Write text to the output
      void XMLStreamWriter.writeCharacters(String text)
      Write text to the output
      void XMLStreamWriter.writeComment(String data)
      Writes an xml comment with the data enclosed
      void XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
      Writes the default namespace to the stream
      void XMLStreamWriter.writeDTD(String dtd)
      Write a DTD section.
      void XMLStreamWriter.writeEmptyElement(String localName)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
      Writes an empty element tag to the output
      void XMLStreamWriter.writeEndDocument()
      Closes any start tags and writes corresponding end tags.
      void XMLStreamWriter.writeEndElement()
      Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
      void XMLStreamWriter.writeEntityRef(String name)
      Writes an entity reference
      void XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
      Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
      void XMLStreamWriter.writeProcessingInstruction(String target)
      Writes a processing instruction
      void XMLStreamWriter.writeProcessingInstruction(String target, String data)
      Writes a processing instruction
      void XMLStreamWriter.writeStartDocument()
      Write the XML Declaration.
      void XMLStreamWriter.writeStartDocument(String version)
      Write the XML Declaration.
      void XMLStreamWriter.writeStartDocument(String encoding, String version)
      Write the XML Declaration.
      void XMLStreamWriter.writeStartElement(String localName)
      Writes a start tag to the output.
      void XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
      Writes a start tag to the output
      void XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
      Writes a start tag to the output

    • Uses of XMLStreamException in javax.xml.stream.events

      Methods in javax.xml.stream.events that throw XMLStreamException
      修饰符与类型 方法与描述
      void XMLEvent.writeAsEncodedUnicode(Writer writer)
      This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.

    • Uses of XMLStreamException in javax.xml.stream.util

      Methods in javax.xml.stream.util that throw XMLStreamException
      修饰符与类型 | 方法与描述
      void XMLEventConsumer.add(XMLEvent event)
      This method adds an event to the consumer.
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      void | StreamReaderDelegate.close()
      void | EventReaderDelegate.close()
      String | StreamReaderDelegate.getElementText()
      String | EventReaderDelegate.getElementText()
      int | StreamReaderDelegate.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      boolean | StreamReaderDelegate.hasNext()
      int | StreamReaderDelegate.下一个()
      XMLEvent | EventReaderDelegate.nextEvent()
      int | StreamReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.peek()
      void | StreamReaderDelegate.require(int type, String namespaceURI, String localName)

    • Uses of XMLStreamException in javax.xml.transform.stax

      Constructors in javax.xml.transform.stax that throw XMLStreamException
      构造方法与描述
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.xml.stream.EventFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.EventFilter

  • Packages that use EventFilter
    软件包 描述
    javax.xml.stream

    • Uses of EventFilter in javax.xml.stream

      Methods in javax.xml.stream with parameters of type EventFilter
      修饰符与类型 方法与描述
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aas?


Uses of Interface javax.xml.stream.Location

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.Location

  • Packages that use Location
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of Location in javax.xml.stream

      Fields in javax.xml.stream declared as Location
      修饰符与类型 | 字段与描述
      protected Location | XMLStreamException.location
      Methods in javax.xml.stream that return Location
      修饰符与类型 方法与描述
      Location XMLStreamReader.getLocation()
      Return the current location of the processor.
      Location XMLStreamException.getLocation()
      Gets the location of the exception
      Methods in javax.xml.stream with parameters of type Location
      修饰符与类型 方法与描述
      void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
      Report the desired message in an application specific format.
      abstract void XMLEventFactory.setLocation(Location location)
      This method allows setting of the Location on each event that is created by this factory.
      Constructors in javax.xml.stream with parameters of type Location
      构造方法与描述
      XMLStreamException(String msg, Location location)
      Construct an exception with the assocated message, exception and location.
      XMLStreamException(String msg, Location location, Throwable th)
      Construct an exception with the assocated message, exception and location.

    • Uses of Location in javax.xml.stream.events

      Methods in javax.xml.stream.events that return Location
      修饰符与类型 方法与描述
      Location XMLEvent.getLocation()
      Return the location of this event.

    • Uses of Location in javax.xml.stream.util

      Methods in javax.xml.stream.util that return Location
      修饰符与类型 | 方法与描述
      Location | StreamReaderDelegate.getLocation()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.v.far.rhf"/./.�.拦鼓吭鲻跃


Uses of Interface javax.xml.stream.StreamFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.StreamFilter

  • Packages that use StreamFilter
    软件包 描述
    javax.xml.stream

    • Uses of StreamFilter in javax.xml.stream

      Methods in javax.xml.stream with parameters of type StreamFilter
      修饰符与类型 方法与描述
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aixaintlteee ottph t a ,n


Uses of Interface javax.xml.stream.XMLEventReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLEventReader

  • Packages that use XMLEventReader
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLEventReader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLEventReader
      修饰符与类型 方法与描述
      Object Unmarshaller.unmarshal(XMLEventReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLEventReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of XMLEventReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLEventReader
      修饰符与类型 | 方法与描述
      Object | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, 类<T> expectedType)

    • Uses of XMLEventReader in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventReader
      修饰符与类型 方法与描述
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
      Create a new XMLEventReader from a java.io.InputStream
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
      Create a new XMLEventReader from a reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.
      Methods in javax.xml.stream with parameters of type XMLEventReader
      修饰符与类型 方法与描述
      void XMLEventWriter.add(XMLEventReader reader)
      Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
      abstract XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
      Create a filtered event reader that wraps the filter around the event reader

    • Uses of XMLEventReader in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLEventReader
      修饰符与类型 类与描述
      class  EventReaderDelegate
      This is the base class for deriving an XMLEventReader filter.
      Methods in javax.xml.stream.util that return XMLEventReader
      修饰符与类型 方法与描述
      XMLEventReader EventReaderDelegate.getParent()
      Get the parent of this instance.
      Methods in javax.xml.stream.util with parameters of type XMLEventReader
      修饰符与类型 方法与描述
      void EventReaderDelegate.setParent(XMLEventReader reader)
      Set the parent of this instance.
      Constructors in javax.xml.stream.util with parameters of type XMLEventReader
      构造方法与描述
      EventReaderDelegate(XMLEventReader reader)
      Construct an filter with the specified parent.

    • Uses of XMLEventReader in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLEventReader
      修饰符与类型 方法与描述
      XMLEventReader StAXSource.getXMLEventReader()
      Get the XMLEventReader used by this StAXSource.
      Constructors in javax.xml.transform.stax with parameters of type XMLEventReader
      构造方法与描述
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"l.S" pr>opp.lnbv>


Uses of Interface javax.xml.stream.XMLEventWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLEventWriter

  • Packages that use XMLEventWriter
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLEventWriter in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLEventWriter
      修饰符与类型 方法与描述
      void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLEventWriter.

    • Uses of XMLEventWriter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLEventWriter
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

    • Uses of XMLEventWriter in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventWriter
      修饰符与类型 方法与描述
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
      Create a new XMLEventWriter that writes to a stream
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
      Create a new XMLEventWriter that writes to a writer

    • Uses of XMLEventWriter in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLEventWriter
      修饰符与类型 方法与描述
      XMLEventWriter StAXResult.getXMLEventWriter()
      Get the XMLEventWriter used by this StAXResult.
      Constructors in javax.xml.transform.stax with parameters of type XMLEventWriter
      构造方法与描述
      StAXResult(XMLEventWriter xmlEventWriter)
      Creates a new instance of a StAXResult by supplying an XMLEventWriter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sachl">=e"""clttr/haslan=F


Uses of Interface javax.xml.stream.XMLReporter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLReporter

  • Packages that use XMLReporter
    软件包 描述
    javax.xml.stream

    • Uses of XMLReporter in javax.xml.stream

      Methods in javax.xml.stream that return XMLReporter
      修饰符与类型 方法与描述
      abstract XMLReporter XMLInputFactory.getXMLReporter()
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      Methods in javax.xml.stream with parameters of type XMLReporter
      修饰符与类型 方法与描述
      abstract void XMLInputFactory.setXMLReporter(XMLReporter reporter)
      The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mm�>tssaf=f==Bm/ ii m


Uses of Interface javax.xml.stream.XMLResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLResolver

  • Packages that use XMLResolver
    软件包 描述
    javax.xml.stream

    • Uses of XMLResolver in javax.xml.stream

      Methods in javax.xml.stream that return XMLResolver
      修饰符与类型 方法与描述
      abstract XMLResolver XMLInputFactory.getXMLResolver()
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
      Methods in javax.xml.stream with parameters of type XMLResolver
      修饰符与类型 方法与描述
      abstract void XMLInputFactory.setXMLResolver(XMLResolver resolver)
      The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mo \s餫%=�=


Uses of Interface javax.xml.stream.XMLStreamConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLStreamConstants

  • Packages that use XMLStreamConstants
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of XMLStreamConstants in javax.xml.stream

      Subinterfaces of XMLStreamConstants in javax.xml.stream
      修饰符与类型 Interface and Description
      interface  XMLStreamReader
      The XMLStreamReader interface allows forward, read-only access to XML.

    • Uses of XMLStreamConstants in javax.xml.stream.events

      Subinterfaces of XMLStreamConstants in javax.xml.stream.events
      修饰符与类型 Interface and Description
      interface  Attribute
      An interface that contains information about an attribute.
      interface  Characters
      This describes the interface to Characters events.
      interface  Comment
      An interface for comment events
      interface  DTD
      This is the top level interface for events dealing with DTDs
      interface  EndDocument
      A marker interface for the end of the document
      interface  EndElement
      An interface for the end element event.
      interface  EntityDeclaration
      An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
      interface  EntityReference
      An interface for handling Entity events.
      interface  Namespace
      An interface that contains information about a namespace.
      interface  NotationDeclaration
      An interface for handling Notation Declarations Receive notification of a notation declaration event.
      interface  ProcessingInstruction
      An interface that describes the data found in processing instructions
      interface  StartDocument
      An interface for the start document event
      interface  StartElement
      The StartElement interface provides access to information about start elements.
      interface  XMLEvent
      This is the base event interface for handling markup events.

    • Uses of XMLStreamConstants in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLStreamConstants
      修饰符与类型 类与描述
      class  StreamReaderDelegate
      This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> p>u"o>lllr税l."eot


Uses of Interface javax.xml.stream.XMLStreamReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLStreamReader

  • Packages that use XMLStreamReader
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.stream.util
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamReader in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLStreamReader
      修饰符与类型 方法与描述
      Object Unmarshaller.unmarshal(XMLStreamReader reader)
      Unmarshal XML data from the specified pull parser and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(XMLStreamReader reader, 类<T> declaredType)
      Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

    • Uses of XMLStreamReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLStreamReader
      修饰符与类型 | 方法与描述
      Object | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, 类<T> expectedType)

    • Uses of XMLStreamReader in javax.xml.stream

      Methods in javax.xml.stream that return XMLStreamReader
      修饰符与类型 方法与描述
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
      Create a new XMLStreamReader from a reader
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
      Create a new XMLStreamReader from a java.io.InputStream
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
      Create a new XMLStreamReader from a java.io.InputStream
      Methods in javax.xml.stream with parameters of type XMLStreamReader
      修饰符与类型 方法与描述
      boolean StreamFilter.accept(XMLStreamReader reader)
      Tests whether the current state is part of this stream.
      abstract XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
      Create a filtered reader that wraps the filter around the reader
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
      Create a new XMLEventReader from an XMLStreamReader.

    • Uses of XMLStreamReader in javax.xml.stream.util

      Classes in javax.xml.stream.util that implement XMLStreamReader
      修饰符与类型 类与描述
      class  StreamReaderDelegate
      This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
      Methods in javax.xml.stream.util that return XMLStreamReader
      修饰符与类型 方法与描述
      XMLStreamReader StreamReaderDelegate.getParent()
      Get the parent of this instance.
      Methods in javax.xml.stream.util with parameters of type XMLStreamReader
      修饰符与类型 方法与描述
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      void StreamReaderDelegate.setParent(XMLStreamReader reader)
      Set the parent of this instance.
      Constructors in javax.xml.stream.util with parameters of type XMLStreamReader
      构造方法与描述
      StreamReaderDelegate(XMLStreamReader reader)
      Construct an filter with the specified parent.

    • Uses of XMLStreamReader in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLStreamReader
      修饰符与类型 方法与描述
      XMLStreamReader StAXSource.getXMLStreamReader()
      Get the XMLStreamReader used by this StAXSource.
      Constructors in javax.xml.transform.stax with parameters of type XMLStreamReader
      构造方法与描述
      StAXSource(XMLStreamReader xmlStreamReader)
      Creates a new instance of a StAXSource by supplying an XMLStreamReader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ex>tMLEst"""vsnn"rlCNTNRS,o


Uses of Interface javax.xml.stream.XMLStreamWriter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.XMLStreamWriter

  • Packages that use XMLStreamWriter
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.stream
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.

    • Uses of XMLStreamWriter in javax.xml.bind

      Methods in javax.xml.bind with parameters of type XMLStreamWriter
      修饰符与类型 方法与描述
      void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
      Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.

    • Uses of XMLStreamWriter in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type XMLStreamWriter
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

    • Uses of XMLStreamWriter in javax.xml.stream

      Methods in javax.xml.stream that return XMLStreamWriter
      修饰符与类型 方法与描述
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
      Create a new XMLStreamWriter that writes to a stream
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
      Create a new XMLStreamWriter that writes to a writer

    • Uses of XMLStreamWriter in javax.xml.transform.stax

      Methods in javax.xml.transform.stax that return XMLStreamWriter
      修饰符与类型 方法与描述
      XMLStreamWriter StAXResult.getXMLStreamWriter()
      Get the XMLStreamWriter used by this StAXResult.
      Constructors in javax.xml.transform.stax with parameters of type XMLStreamWriter
      构造方法与描述
      StAXResult(XMLStreamWriter xmlStreamWriter)
      Creates a new instance of a StAXResult by supplying an XMLStreamWriter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htteXMLeraaa/a..wmv>//>


Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface Attribute

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants
    All Known Subinterfaces:
    Namespace

    public interface Attribute
extends XMLEvent
    An interface that contains information about an attribute. Attributes are reported as a set of events accessible from a StartElement. Other applications may report Attributes as first-order events, for example as the results of an XPath expression.
    从以下版本开始：
    1.6
    另请参见：
    StartElement

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDTDType()
      Gets the type of this attribute, default is the String "CDATA"
      QName getName()
      Returns the QName for this attribute
      String getValue()
      Gets the normalized value of this attribute
      boolean isSpecified()
      A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getName

        QName getName()
        Returns the QName for this attribute

      • getValue

        String getValue()
        Gets the normalized value of this attribute

      • getDTDType

        String getDTDType()
        Gets the type of this attribute, default is the String "CDATA"
        返回：
        the type as a String, default is "CDATA"

      • isSpecified

        boolean isSpecified()
        A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
        返回：
        returns true if this was specified in the start element
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ee/<..ouljelot/o膕 /


Characters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface Characters

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface Characters
extends XMLEvent
    This describes the interface to Characters events. All text events get reported as Characters events. Content, CData and whitespace are all reported as Characters events. IgnorableWhitespace, in most cases, will be set to false unless an element declaration of element content is present for the current element.
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getData()
      Get the character data of this event
      boolean isCData()
      Returns true if this is a CData section.
      boolean isIgnorableWhiteSpace()
      Return true if this is ignorableWhiteSpace.
      boolean isWhiteSpace()
      Returns true if this set of Characters is all whitespace.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getData

        String getData()
        Get the character data of this event

      • isWhiteSpace

        boolean isWhiteSpace()
        Returns true if this set of Characters is all whitespace. Whitespace inside a document is reported as CHARACTERS. This method allows checking of CHARACTERS events to see if they are composed of only whitespace characters

      • isCData

        boolean isCData()
        Returns true if this is a CData section. If this event is CData its event type will be CDATA If javax.xml.stream.isCoalescing is set to true CDATA Sections that are surrounded by non CDATA characters will be reported as a single Characters event. This method will return false in this case.

      • isIgnorableWhiteSpace

        boolean isIgnorableWhiteSpace()
        Return true if this is ignorableWhiteSpace. If this event is ignorableWhiteSpace its event type will be SPACE.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ai


Comment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface Comment

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface Comment
extends XMLEvent
    An interface for comment events
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getText()
      Return the string data of the comment, returns empty string if it does not exist

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getText

        String getText()
        Return the string data of the comment, returns empty string if it does not exist
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.h�>lu �"


DTD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface DTD

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface DTD
extends XMLEvent
    This is the top level interface for events dealing with DTDs
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getDocumentTypeDeclaration()
      Returns the entire Document Type Declaration as a string, including the internal DTD subset.
      List getEntities()
      Return a List containing the general entities, both external and internal, declared in the DTD.
      List getNotations()
      Return a List containing the notations declared in the DTD.
      Object getProcessedDTD()
      Returns an implementation defined representation of the DTD.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getDocumentTypeDeclaration

        String getDocumentTypeDeclaration()
        Returns the entire Document Type Declaration as a string, including the internal DTD subset. This may be null if there is not an internal subset. If it is not null it must return the entire Document Type Declaration which matches the doctypedecl production in the XML 1.0 specification

      • getProcessedDTD

        Object getProcessedDTD()
        Returns an implementation defined representation of the DTD. This method may return null if no representation is available.

      • getNotations

        List getNotations()
        Return a List containing the notations declared in the DTD. This list must contain NotationDeclaration events.
        返回：
        an unordered list of NotationDeclaration events
        另请参见：
        NotationDeclaration

      • getEntities

        List getEntities()
        Return a List containing the general entities, both external and internal, declared in the DTD. This list must contain EntityDeclaration events.
        返回：
        an unordered list of EntityDeclaration events
        另请参见：
        EntityDeclaration
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

enaitr


EndDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.stream.events

Interface EndDocument

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EndDocument
extends XMLEvent
    A marker interface for the end of the document
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tco rn raaaraa enn ii sa a st


EndElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface EndElement

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EndElement
extends XMLEvent
    An interface for the end element event. An EndElement is reported for each End Tag in the document.
    从以下版本开始：
    1.6
    另请参见：
    XMLEvent

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      QName getName()
      Get the name of this event
      Iterator getNamespaces()
      Returns an Iterator of namespaces that have gone out of scope.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getName

        QName getName()
        Get the name of this event
        返回：
        the qualified name of this event

      • getNamespaces

        Iterator getNamespaces()
        Returns an Iterator of namespaces that have gone out of scope. Returns an empty iterator if no namespaces have gone out of scope.
        返回：
        an Iterator over Namespace interfaces, or an empty iterator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nsbpdpdp&ps;;pssrrpp镏c/.t助 a �>./r


EntityDeclaration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface EntityDeclaration

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EntityDeclaration
extends XMLEvent
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getBaseURI()
      Get the base URI for this reference or null if this information is not available
      String getName()
      The entity's name
      String getNotationName()
      The name of the associated notation.
      String getPublicId()
      The entity's public identifier, or null if none was given
      String getReplacementText()
      The replacement text of the entity.
      String getSystemId()
      The entity's system identifier.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getPublicId

        String getPublicId()
        The entity's public identifier, or null if none was given
        返回：
        the public ID for this declaration or null

      • getSystemId

        String getSystemId()
        The entity's system identifier.
        返回：
        the system ID for this declaration or null

      • getName

        String getName()
        The entity's name
        返回：
        the name, may not be null

      • getNotationName

        String getNotationName()
        The name of the associated notation.
        返回：
        the notation name

      • getReplacementText

        String getReplacementText()
        The replacement text of the entity. This method will only return non-null if this is an internal entity.
        返回：
        null or the replacment text

      • getBaseURI

        String getBaseURI()
        Get the base URI for this reference or null if this information is not available
        返回：
        the base URI or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iXenl/etXS>l la ie("Oitl_hX>;�>e


EntityReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface EntityReference

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface EntityReference
extends XMLEvent
    An interface for handling Entity events. This event reports entities that have not been resolved and reports their replacement text unprocessed (if available). This event will be reported if javax.xml.stream.isReplacingEntityReferences is set to false. If javax.xml.stream.isReplacingEntityReferences is set to true entity references will be resolved transparently. Entities are handled in two possible ways: (1) If javax.xml.stream.isReplacingEntityReferences is set to true all entity references are resolved and reported as markup transparently. (2) If javax.xml.stream.isReplacingEntityReferences is set to false Entity references are reported as an EntityReference Event.
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      EntityDeclaration getDeclaration()
      Return the declaration of this entity.
      String getName()
      The name of the entity

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getDeclaration

        EntityDeclaration getDeclaration()
        Return the declaration of this entity.

      • getName

        String getName()
        The name of the entity
        返回：
        the entity's name, may not be null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--m_ovbovabbvaamvssATFADTA===A- =<>


javax.xml.stream.events

Interfaces

  • Attribute
  • Characters
  • Comment
  • DTD
  • EndDocument
  • EndElement
  • EntityDeclaration
  • EntityReference
  • Namespace
  • NotationDeclaration
  • ProcessingInstruction
  • StartDocument
  • StartElement
  • XMLEvent
r


javax.xml.stream.events

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.stream.events

  • 接口摘要
    接口 描述
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    NotationDeclaration
    An interface for handling Notation Declarations Receive notification of a notation declaration event.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa amcemaeccm(##eaeml/xj


javax.xml.stream.events Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.stream.events

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r.f>"h eeeL..j�


Namespace

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface Namespace

  • All Superinterfaces:
    Attribute, XMLEvent, XMLStreamConstants

    public interface Namespace
extends Attribute
    An interface that contains information about a namespace. Namespaces are accessed from a StartElement.
    从以下版本开始：
    1.6
    另请参见：
    StartElement

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getNamespaceURI()
      Gets the uri bound to the prefix of this namespace
      String getPrefix()
      Gets the prefix, returns "" if this is a default namespace declaration.
      boolean isDefaultNamespaceDeclaration()
      returns true if this attribute declares the default namespace

      • 方法 - 继承于接口 javax.xml.stream.events.Attribute

        getDTDType, getName, getValue, isSpecified

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getPrefix

        String getPrefix()
        Gets the prefix, returns "" if this is a default namespace declaration.

      • getNamespaceURI

        String getNamespaceURI()
        Gets the uri bound to the prefix of this namespace

      • isDefaultNamespaceDeclaration

        boolean isDefaultNamespaceDeclaration()
        returns true if this attribute declares the default namespace
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x mj.j:j


NotationDeclaration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface NotationDeclaration

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface NotationDeclaration
extends XMLEvent
    An interface for handling Notation Declarations Receive notification of a notation declaration event. It is up to the application to record the notation for later reference, At least one of publicId and systemId must be non-null. There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      The notation name.
      String getPublicId()
      The notation's public identifier, or null if none was given.
      String getSystemId()
      The notation's system identifier, or null if none was given.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getName

        String getName()
        The notation name.

      • getPublicId

        String getPublicId()
        The notation's public identifier, or null if none was given.

      • getSystemId

        String getSystemId()
        The notation's system identifier, or null if none was given.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e ->-m---- -->/- bbl穇


ProcessingInstruction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface ProcessingInstruction

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface ProcessingInstruction
extends XMLEvent
    An interface that describes the data found in processing instructions
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getData()
      The data section of the processing instruction
      String getTarget()
      The target section of the processing instruction

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getTarget

        String getTarget()
        The target section of the processing instruction
        返回：
        the String value of the PI or null

      • getData

        String getData()
        The data section of the processing instruction
        返回：
        the String value of the PI's data or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<=>MtMeMa>aod<.on# in ;�;>>bni


StartDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface StartDocument

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface StartDocument
extends XMLEvent
    An interface for the start document event
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean encodingSet()
      Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
      String getCharacterEncodingScheme()
      Returns the encoding style of the XML data
      String getSystemId()
      Returns the system ID of the XML data
      String getVersion()
      Returns the version of XML of this XML stream
      boolean isStandalone()
      Returns if this XML is standalone
      boolean standaloneSet()
      Returns true if the standalone attribute was set in the encoding declaration of the document.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getSystemId

        String getSystemId()
        Returns the system ID of the XML data
        返回：
        the system ID, defaults to ""

      • getCharacterEncodingScheme

        String getCharacterEncodingScheme()
        Returns the encoding style of the XML data
        返回：
        the character encoding, defaults to "UTF-8"

      • encodingSet

        boolean encodingSet()
        Returns true if CharacterEncodingScheme was set in the encoding declaration of the document

      • isStandalone

        boolean isStandalone()
        Returns if this XML is standalone
        返回：
        the standalone state of XML, defaults to "no"

      • standaloneSet

        boolean standaloneSet()
        Returns true if the standalone attribute was set in the encoding declaration of the document.

      • getVersion

        String getVersion()
        Returns the version of XML of this XML stream
        返回：
        the version of XML, defaults to "1.0"
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a;b/bbdeu <蝖mcset"Cg衞盯lm=s


StartElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface StartElement

  • All Superinterfaces:
    XMLEvent, XMLStreamConstants

    public interface StartElement
extends XMLEvent
    The StartElement interface provides access to information about start elements. A StartElement is reported for each Start Tag in the document.
    从以下版本开始：
    1.6

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Attribute getAttributeByName(QName name)
      Returns the attribute referred to by this name
      Iterator getAttributes()
      Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.
      QName getName()
      Get the name of this event
      NamespaceContext getNamespaceContext()
      Gets a read-only namespace context.
      Iterator getNamespaces()
      Returns an Iterator of namespaces declared on this element.
      String getNamespaceURI(String prefix)
      Gets the value that the prefix is bound to in the context of this element.

      • 方法 - 继承于接口 javax.xml.stream.events.XMLEvent

        asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

    • 方法详细信息

      • getName

        QName getName()
        Get the name of this event
        返回：
        the qualified name of this event

      • getAttributes

        Iterator getAttributes()
        Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes. The iterator must contain only implementations of the javax.xml.stream.Attribute interface. Attributes are fundamentally unordered and may not be reported in any order.
        返回：
        a readonly Iterator over Attribute interfaces, or an empty iterator

      • getNamespaces

        Iterator getNamespaces()
        Returns an Iterator of namespaces declared on this element. This Iterator does not contain previously declared namespaces unless they appear on the current START_ELEMENT. Therefore this list may contain redeclared namespaces and duplicate namespace declarations. Use the getNamespaceContext() method to get the current context of namespace declarations.

        The iterator must contain only implementations of the javax.xml.stream.Namespace interface.

        A Namespace isA Attribute. One can iterate over a list of namespaces as a list of attributes. However this method returns only the list of namespaces declared on this START_ELEMENT and does not include the attributes declared on this START_ELEMENT. Returns an empty iterator if there are no namespaces.

        返回：
        a readonly Iterator over Namespace interfaces, or an empty iterator

      • getAttributeByName

        Attribute getAttributeByName(QName name)
        Returns the attribute referred to by this name
        参数：
        name - the qname of the desired name
        返回：
        the attribute corresponding to the name value or null

      • getNamespaceContext

        NamespaceContext getNamespaceContext()
        Gets a read-only namespace context. If no context is available this method will return an empty namespace context. The NamespaceContext contains information about all namespaces in scope for this StartElement.
        返回：
        the current namespace context

      • getNamespaceURI

        String getNamespaceURI(String prefix)
        Gets the value that the prefix is bound to in the context of this element. Returns null if the prefix is not bound in this context
        参数：
        prefix - the prefix to lookup
        返回：
        the uri bound to the prefix or null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>m aaki=-soi/rehc ca.t.LB<&ch>Di,s


Uses of Package javax.xml.stream.events

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.stream.events

  • Packages that use javax.xml.stream.events
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util
  • Classes in javax.xml.stream.events used by javax.xml.stream
    类与描述
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    Comment
    An interface for comment events
    DTD
    This is the top level interface for events dealing with DTDs
    EndDocument
    A marker interface for the end of the document
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    EntityReference
    An interface for handling Entity events.
    Namespace
    An interface that contains information about a namespace.
    ProcessingInstruction
    An interface that describes the data found in processing instructions
    StartDocument
    An interface for the start document event
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
  • Classes in javax.xml.stream.events used by javax.xml.stream.events
    类与描述
    Attribute
    An interface that contains information about an attribute.
    Characters
    This describes the interface to Characters events.
    EndElement
    An interface for the end element event.
    EntityDeclaration
    An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
    StartElement
    The StartElement interface provides access to information about start elements.
    XMLEvent
    This is the base event interface for handling markup events.
  • Classes in javax.xml.stream.events used by javax.xml.stream.util
    类与描述
    XMLEvent
    This is the base event interface for handling markup events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.�.ltr h


XMLEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.events

Interface XMLEvent

  • All Superinterfaces:
    XMLStreamConstants
    All Known Subinterfaces:
    Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement

    public interface XMLEvent
extends XMLStreamConstants
    This is the base event interface for handling markup events. Events are value objects that are used to communicate the XML 1.0 InfoSet to the Application. Events may be cached and referenced after the parse has completed.
    从以下版本开始：
    1.6
    另请参见：
    XMLEventReader, Characters, ProcessingInstruction, StartElement, EndElement, StartDocument, EndDocument, EntityReference, EntityDeclaration, NotationDeclaration

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Characters asCharacters()
      Returns this event as Characters, may result in a class cast exception if this event is not Characters.
      EndElement asEndElement()
      Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
      StartElement asStartElement()
      Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
      int getEventType()
      Returns an integer code for this event.
      Location getLocation()
      Return the location of this event.
      QName getSchemaType()
      This method is provided for implementations to provide optional type information about the associated event.
      boolean isAttribute()
      A utility function to check if this event is an Attribute.
      boolean isCharacters()
      A utility function to check if this event is Characters.
      boolean isEndDocument()
      A utility function to check if this event is an EndDocument.
      boolean isEndElement()
      A utility function to check if this event is a EndElement.
      boolean isEntityReference()
      A utility function to check if this event is an EntityReference.
      boolean isNamespace()
      A utility function to check if this event is a Namespace.
      boolean isProcessingInstruction()
      A utility function to check if this event is a ProcessingInstruction.
      boolean isStartDocument()
      A utility function to check if this event is a StartDocument.
      boolean isStartElement()
      A utility function to check if this event is a StartElement.
      void writeAsEncodedUnicode(Writer writer)
      This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.

    • 方法详细信息

      • getEventType

        int getEventType()
        Returns an integer code for this event.
        另请参见：
        XMLStreamConstants.START_ELEMENT, XMLStreamConstants.END_ELEMENT, XMLStreamConstants.CHARACTERS, XMLStreamConstants.ATTRIBUTE, XMLStreamConstants.NAMESPACE, XMLStreamConstants.PROCESSING_INSTRUCTION, XMLStreamConstants.COMMENT, XMLStreamConstants.START_DOCUMENT, XMLStreamConstants.END_DOCUMENT, XMLStreamConstants.DTD

      • getLocation

        Location getLocation()
        Return the location of this event. The Location returned from this method is non-volatile and will retain its information.
        另请参见：
        Location

      • isStartElement

        boolean isStartElement()
        A utility function to check if this event is a StartElement.
        另请参见：
        StartElement

      • isAttribute

        boolean isAttribute()
        A utility function to check if this event is an Attribute.
        另请参见：
        Attribute

      • isNamespace

        boolean isNamespace()
        A utility function to check if this event is a Namespace.
        另请参见：
        Namespace

      • isEndElement

        boolean isEndElement()
        A utility function to check if this event is a EndElement.
        另请参见：
        EndElement

      • isEntityReference

        boolean isEntityReference()
        A utility function to check if this event is an EntityReference.
        另请参见：
        EntityReference

      • isProcessingInstruction

        boolean isProcessingInstruction()
        A utility function to check if this event is a ProcessingInstruction.
        另请参见：
        ProcessingInstruction

      • isCharacters

        boolean isCharacters()
        A utility function to check if this event is Characters.
        另请参见：
        Characters

      • isStartDocument

        boolean isStartDocument()
        A utility function to check if this event is a StartDocument.
        另请参见：
        StartDocument

      • isEndDocument

        boolean isEndDocument()
        A utility function to check if this event is an EndDocument.
        另请参见：
        EndDocument

      • asStartElement

        StartElement asStartElement()
        Returns this event as a start element event, may result in a class cast exception if this event is not a start element.

      • asEndElement

        EndElement asEndElement()
        Returns this event as an end element event, may result in a class cast exception if this event is not a end element.

      • asCharacters

        Characters asCharacters()
        Returns this event as Characters, may result in a class cast exception if this event is not Characters.

      • getSchemaType

        QName getSchemaType()
        This method is provided for implementations to provide optional type information about the associated event. It is optional and will return null if no information is available.

      • writeAsEncodedUnicode

        void writeAsEncodedUnicode(Writer writer)
                           throws XMLStreamException
        This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters. No indentation or whitespace should be outputted. Any user defined event type SHALL have this method called when being written to on an output stream. Built in Event types MUST implement this method, but implementations MAY choose not call these methods for optimizations reasons when writing out built in Events to an output stream. The output generated MUST be equivalent in terms of the infoset expressed.
        参数：
        writer - The writer that will output the data
        抛出：
        XMLStreamException - if there is a fatal error writing the event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eg> tlFiscar>ans<.>残.-黺<1/


Uses of Interface javax.xml.stream.events.Attribute

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.Attribute

  • Packages that use Attribute
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events

    • Uses of Attribute in javax.xml.stream

      Methods in javax.xml.stream that return Attribute
      修饰符与类型 方法与描述
      abstract Attribute XMLEventFactory.createAttribute(QName name, String value)
      Create a new Attribute
      abstract Attribute XMLEventFactory.createAttribute(String localName, String value)
      Create a new Attribute
      abstract Attribute XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value)
      Create a new Attribute

    • Uses of Attribute in javax.xml.stream.events

      Subinterfaces of Attribute in javax.xml.stream.events
      修饰符与类型 Interface and Description
      interface  Namespace
      An interface that contains information about a namespace.
      Methods in javax.xml.stream.events that return Attribute
      修饰符与类型 方法与描述
      Attribute StartElement.getAttributeByName(QName name)
      Returns the attribute referred to by this name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e t."y"",oy"


Uses of Interface javax.xml.stream.events.Characters

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.Characters

  • Packages that use Characters
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events

    • Uses of Characters in javax.xml.stream

      Methods in javax.xml.stream that return Characters
      修饰符与类型 方法与描述
      abstract Characters XMLEventFactory.createCData(String content)
      Create a Characters event with the CData flag set to true
      abstract Characters XMLEventFactory.createCharacters(String content)
      Create a Characters event, this method does not check if the content is all whitespace.
      abstract Characters XMLEventFactory.createIgnorableSpace(String content)
      Create an ignorable space
      abstract Characters XMLEventFactory.createSpace(String content)
      Create a Characters event with the isSpace flag set to true

    • Uses of Characters in javax.xml.stream.events

      Methods in javax.xml.stream.events that return Characters
      修饰符与类型 方法与描述
      Characters XMLEvent.asCharacters()
      Returns this event as Characters, may result in a class cast exception if this event is not Characters.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Cel >-a-! l peef e/aooar


Uses of Interface javax.xml.stream.events.Comment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.Comment

  • Packages that use Comment
    软件包 描述
    javax.xml.stream

    • Uses of Comment in javax.xml.stream

      Methods in javax.xml.stream that return Comment
      修饰符与类型 方法与描述
      abstract Comment XMLEventFactory.createComment(String text)
      Create a comment
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

belr su=g"""c lleye/gaukt


Uses of Interface javax.xml.stream.events.DTD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.DTD

  • Packages that use DTD
    软件包 描述
    javax.xml.stream

    • Uses of DTD in javax.xml.stream

      Methods in javax.xml.stream that return DTD
      修饰符与类型 方法与描述
      abstract DTD XMLEventFactory.createDTD(String dtd)
      Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tthnca/a.>>ehlpp>e">d/rcd


Uses of Interface javax.xml.stream.events.EndDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.EndDocument

  • Packages that use EndDocument
    软件包 描述
    javax.xml.stream

    • Uses of EndDocument in javax.xml.stream

      Methods in javax.xml.stream that return EndDocument
      修饰符与类型 方法与描述
      abstract EndDocument XMLEventFactory.createEndDocument()
      Creates a new instance of an EndDocument event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnbbA&;&Ts;-8re=8gse8nn8p


Uses of Interface javax.xml.stream.events.EndElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.EndElement

  • Packages that use EndElement
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events

    • Uses of EndElement in javax.xml.stream

      Methods in javax.xml.stream that return EndElement
      修饰符与类型 方法与描述
      abstract EndElement XMLEventFactory.createEndElement(QName name, Iterator namespaces)
      Create a new EndElement
      abstract EndElement XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName)
      Create a new EndElement
      abstract EndElement XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
      Create a new EndElement

    • Uses of EndElement in javax.xml.stream.events

      Methods in javax.xml.stream.events that return EndElement
      修饰符与类型 方法与描述
      EndElement XMLEvent.asEndElement()
      Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oTryjl= ay=鹡i.ot�< nu.=


Uses of Interface javax.xml.stream.events.EntityDeclaration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.EntityDeclaration

  • Packages that use EntityDeclaration
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events

    • Uses of EntityDeclaration in javax.xml.stream

      Methods in javax.xml.stream with parameters of type EntityDeclaration
      修饰符与类型 方法与描述
      abstract EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event

    • Uses of EntityDeclaration in javax.xml.stream.events

      Methods in javax.xml.stream.events that return EntityDeclaration
      修饰符与类型 方法与描述
      EntityDeclaration EntityReference.getDeclaration()
      Return the declaration of this entity.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cE.e//-/.hhh./>> /l<


Uses of Interface javax.xml.stream.events.EntityReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.EntityReference

  • Packages that use EntityReference
    软件包 描述
    javax.xml.stream

    • Uses of EntityReference in javax.xml.stream

      Methods in javax.xml.stream that return EntityReference
      修饰符与类型 方法与描述
      abstract EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
      Creates a new instance of a EntityReference event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g8uosaLa"bbbs<<<� >/i<


Uses of Interface javax.xml.stream.events.Namespace

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.Namespace

  • Packages that use Namespace
    软件包 描述
    javax.xml.stream

    • Uses of Namespace in javax.xml.stream

      Methods in javax.xml.stream that return Namespace
      修饰符与类型 方法与描述
      abstract Namespace XMLEventFactory.createNamespace(String namespaceURI)
      Create a new default Namespace
      abstract Namespace XMLEventFactory.createNamespace(String prefix, String namespaceUri)
      Create a new Namespace
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

F" _=pn>___rae/-tda/heha


Uses of Interface javax.xml.stream.events.NotationDeclaration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.NotationDeclaration

No usage of javax.xml.stream.events.NotationDeclaration
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sl itmlnigggSv//nj)S.


Uses of Interface javax.xml.stream.events.ProcessingInstruction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.ProcessingInstruction

  • Packages that use ProcessingInstruction
    软件包 描述
    javax.xml.stream

    • Uses of ProcessingInstruction in javax.xml.stream

      Methods in javax.xml.stream that return ProcessingInstruction
      修饰符与类型 方法与描述
      abstract ProcessingInstruction XMLEventFactory.createProcessingInstruction(String target, String data)
      Create a processing instruction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

is/U(e&Aocrme�>S薬rS萺t


Uses of Interface javax.xml.stream.events.StartDocument

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.StartDocument

  • Packages that use StartDocument
    软件包 描述
    javax.xml.stream

    • Uses of StartDocument in javax.xml.stream

      Methods in javax.xml.stream that return StartDocument
      修饰符与类型 方法与描述
      abstract StartDocument XMLEventFactory.createStartDocument()
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding)
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding, String version)
      Creates a new instance of a StartDocument event
      abstract StartDocument XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone)
      Creates a new instance of a StartDocument event
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l /dateest>>A .紅ssi


Uses of Interface javax.xml.stream.events.StartElement

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.StartElement

  • Packages that use StartElement
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events

    • Uses of StartElement in javax.xml.stream

      Methods in javax.xml.stream that return StartElement
      修饰符与类型 方法与描述
      abstract StartElement XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
      Create a new StartElement.
      abstract StartElement XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
      Create a new StartElement.

    • Uses of StartElement in javax.xml.stream.events

      Methods in javax.xml.stream.events that return StartElement
      修饰符与类型 方法与描述
      StartElement XMLEvent.asStartElement()
      Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_"sr>l鵤_� amaml


Uses of Interface javax.xml.stream.events.XMLEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.events.XMLEvent

  • Packages that use XMLEvent
    软件包 描述
    javax.xml.stream
    javax.xml.stream.events
    javax.xml.stream.util

    • Uses of XMLEvent in javax.xml.stream

      Methods in javax.xml.stream that return XMLEvent
      修饰符与类型 方法与描述
      XMLEvent XMLEventReader.nextEvent()
      Get the next XMLEvent
      XMLEvent XMLEventReader.nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent XMLEventReader.peek()
      Check the next XMLEvent without reading it from the stream.
      Methods in javax.xml.stream with parameters of type XMLEvent
      修饰符与类型 方法与描述
      boolean EventFilter.accept(XMLEvent event)
      Tests whether this event is part of this stream.
      void XMLEventWriter.add(XMLEvent event)
      Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.

    • Uses of XMLEvent in javax.xml.stream.events

      Subinterfaces of XMLEvent in javax.xml.stream.events
      修饰符与类型 Interface and Description
      interface  Attribute
      An interface that contains information about an attribute.
      interface  Characters
      This describes the interface to Characters events.
      interface  Comment
      An interface for comment events
      interface  DTD
      This is the top level interface for events dealing with DTDs
      interface  EndDocument
      A marker interface for the end of the document
      interface  EndElement
      An interface for the end element event.
      interface  EntityDeclaration
      An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
      interface  EntityReference
      An interface for handling Entity events.
      interface  Namespace
      An interface that contains information about a namespace.
      interface  NotationDeclaration
      An interface for handling Notation Declarations Receive notification of a notation declaration event.
      interface  ProcessingInstruction
      An interface that describes the data found in processing instructions
      interface  StartDocument
      An interface for the start document event
      interface  StartElement
      The StartElement interface provides access to information about start elements.

    • Uses of XMLEvent in javax.xml.stream.util

      Methods in javax.xml.stream.util that return XMLEvent
      修饰符与类型 | 方法与描述
      XMLEvent XMLEventAllocator.allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      XMLEvent | EventReaderDelegate.nextEvent()
      XMLEvent | EventReaderDelegate.nextTag()
      XMLEvent | EventReaderDelegate.peek()
      Methods in javax.xml.stream.util with parameters of type XMLEvent
      修饰符与类型 方法与描述
      void XMLEventConsumer.add(XMLEvent event)
      This method adds an event to the consumer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.stt/ssd"le. a"tn胦o=p


EventReaderDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream.util

类 EventReaderDelegate

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate
  • 所有已实现的接口：
    Iterator, XMLEventReader

    public class EventReaderDelegate
extends Object
implements XMLEventReader
    This is the base class for deriving an XMLEventReader filter. This class is designed to sit between an XMLEventReader and an application's XMLEventReader. By default each method does nothing but call the corresponding method on the parent interface.
    从以下版本开始：
    1.6
    另请参见：
    XMLEventReader, StreamReaderDelegate

    • 构造方法摘要

      Constructors
      构造方法与描述
      EventReaderDelegate()
      Construct an empty filter with no parent.
      EventReaderDelegate(XMLEventReader reader)
      Construct an filter with the specified parent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Frees any resources associated with this Reader.
      String getElementText()
      Reads the content of a text-only element.
      XMLEventReader getParent()
      Get the parent of this instance.
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      boolean hasNext()
      Check if there are more events.
      Object 下一个()
      Returns the next element in the iteration.
      XMLEvent nextEvent()
      Get the next XMLEvent
      XMLEvent nextTag()
      Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
      XMLEvent peek()
      Check the next XMLEvent without reading it from the stream.
      void remove()
      Removes from the underlying collection the last element returned by this iterator (optional operation).
      void setParent(XMLEventReader reader)
      Set the parent of this instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EventReaderDelegate

        public EventReaderDelegate()
        Construct an empty filter with no parent.

      • EventReaderDelegate

        public EventReaderDelegate(XMLEventReader reader)
        Construct an filter with the specified parent.
        参数：
        reader - the parent

    • 方法详细信息

      • setParent

        public void setParent(XMLEventReader reader)
        Set the parent of this instance.
        参数：
        reader - the new parent

      • getParent

        public XMLEventReader getParent()
        Get the parent of this instance.
        返回：
        the parent or null if none is set

      • nextEvent

        public XMLEvent nextEvent()
                   throws XMLStreamException
        从接口复制的描述： XMLEventReader
        Get the next XMLEvent
        指定者：
        nextEvent in interface XMLEventReader
        抛出：
        XMLStreamException - if there is an error with the underlying XML.
        另请参见：
        XMLEvent

      • 下一个

        public Object next()
        从接口复制的描述： Iterator
        Returns the next element in the iteration.
        指定者：
        下一个 in interface Iterator
        返回：
        the next element in the iteration

      • hasNext

        public boolean hasNext()
        从接口复制的描述： XMLEventReader
        Check if there are more events. Returns true if there are more events and false otherwise.
        指定者：
        hasNext in interface Iterator
        指定者：
        hasNext in interface XMLEventReader
        返回：
        true if the event reader has more events, false otherwise

      • peek

        public XMLEvent peek()
              throws XMLStreamException
        从接口复制的描述： XMLEventReader
        Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().
        指定者：
        peek in interface XMLEventReader
        抛出：
        XMLStreamException
        另请参见：
        XMLEvent

      • close

        public void close()
           throws XMLStreamException
        从接口复制的描述： XMLEventReader
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        指定者：
        close in interface XMLEventReader
        抛出：
        XMLStreamException - if there are errors freeing associated resources

      • getElementText

        public String getElementText()
                      throws XMLStreamException
        从接口复制的描述： XMLEventReader
        Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.
        指定者：
        getElementText in interface XMLEventReader
        抛出：
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • nextTag

        public XMLEvent nextTag()
                 throws XMLStreamException
        从接口复制的描述： XMLEventReader
        Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.
        指定者：
        nextTag in interface XMLEventReader
        抛出：
        XMLStreamException - if anything other than space characters are encountered

      • getProperty

        public Object getProperty(String name)
                   throws IllegalArgumentException
        从接口复制的描述： XMLEventReader
        Get the value of a feature/property from the underlying implementation
        指定者：
        getProperty in interface XMLEventReader
        参数：
        name - The name of the property
        返回：
        The value of the property
        抛出：
        IllegalArgumentException - if the property is not supported

      • remove

        public void remove()
        从接口复制的描述： Iterator
        Removes from the underlying collection the last element returned by this iterator (optional operation). This method can be called only once per call to Iterator.next(). The behavior of an iterator is unspecified if the underlying collection is modified while the iteration is in progress in any way other than by calling this method.
        指定者：
        remove in interface Iterator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

agsspmol.>"aA/i縟<";i.d


javax.xml.stream.util

Interfaces

  • XMLEventAllocator
  • XMLEventConsumer

Classes

  • EventReaderDelegate
  • StreamReaderDelegate
x


javax.xml.stream.util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.stream.util

  • 接口摘要
    接口 描述
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Class Summary
    类 描述
    EventReaderDelegate
    This is the base class for deriving an XMLEventReader filter.
    StreamReaderDelegate
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

D evenitleeit//red"oc<


javax.xml.stream.util Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.stream.util

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)

Interface Hierarchy

  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ep=<< vi aa >--c CCsv


StreamReaderDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.stream.util

类 StreamReaderDelegate

  • java.lang.Object
    • javax.xml.stream.util.StreamReaderDelegate
  • 所有已实现的接口：
    XMLStreamConstants, XMLStreamReader

    public class StreamReaderDelegate
extends Object
implements XMLStreamReader
    This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader. By default each method does nothing but call the corresponding method on the parent interface.
    从以下版本开始：
    1.6
    另请参见：
    XMLStreamReader, EventReaderDelegate

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.stream.XMLStreamConstants

        ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT

    • 构造方法摘要

      Constructors
      构造方法与描述
      StreamReaderDelegate()
      Construct an empty filter with no parent.
      StreamReaderDelegate(XMLStreamReader reader)
      Construct an filter with the specified parent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close()
      Frees any resources associated with this Reader.
      int getAttributeCount()
      Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
      String getAttributeLocalName(int index)
      Returns the localName of the attribute at the provided index
      QName getAttributeName(int index)
      Returns the qname of the attribute at the provided index
      String getAttributeNamespace(int index)
      Returns the namespace of the attribute at the provided index
      String getAttributePrefix(int index)
      Returns the prefix of this attribute at the provided index
      String getAttributeType(int index)
      Returns the XML type of the attribute at the provided index
      String getAttributeValue(int index)
      Returns the value of the attribute at the index
      String getAttributeValue(String namespaceUri, String localName)
      Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
      String getCharacterEncodingScheme()
      Returns the character encoding declared on the xml declaration Returns null if none was declared
      String getElementText()
      Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
      String getEncoding()
      Return input encoding if known or null if unknown.
      int getEventType()
      Returns an integer code that indicates the type of the event the cursor is pointing to.
      String getLocalName()
      Returns the (local) name of the current event.
      Location getLocation()
      Return the current location of the processor.
      QName getName()
      Returns a QName for the current START_ELEMENT or END_ELEMENT event
      NamespaceContext getNamespaceContext()
      Returns a read only namespace context for the current position.
      int getNamespaceCount()
      Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
      String getNamespacePrefix(int index)
      Returns the prefix for the namespace declared at the index.
      String getNamespaceURI()
      If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
      String getNamespaceURI(int index)
      Returns the uri for the namespace declared at the index.
      String getNamespaceURI(String prefix)
      Return the uri for the given prefix.
      XMLStreamReader getParent()
      Get the parent of this instance.
      String getPIData()
      Get the data section of a processing instruction
      String getPITarget()
      Get the target of a processing instruction
      String getPrefix()
      Returns the prefix of the current event or null if the event does not have a prefix
      Object getProperty(String name)
      Get the value of a feature/property from the underlying implementation
      String getText()
      Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
      char[] getTextCharacters()
      Returns an array which contains the characters from this event.
      int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
      Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
      int getTextLength()
      Returns the length of the sequence of characters for this Text event within the text character array.
      int getTextStart()
      Returns the offset into the text character array where the first character (of this text event) is stored.
      String getVersion()
      Get the xml version declared on the xml declaration Returns null if none was declared
      boolean hasName()
      returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
      boolean hasNext()
      Returns true if there are more parsing events and false if there are no more events.
      boolean hasText()
      Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
      boolean isAttributeSpecified(int index)
      Returns a boolean which indicates if this attribute was created by default
      boolean isCharacters()
      Returns true if the cursor points to a character data event
      boolean isEndElement()
      Returns true if the cursor points to an end tag (otherwise false)
      boolean isStandalone()
      Get the standalone declaration from the xml declaration
      boolean isStartElement()
      Returns true if the cursor points to a start tag (otherwise false)
      boolean isWhiteSpace()
      Returns true if the cursor points to a character data event that consists of all whitespace
      int 下一个()
      Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
      int nextTag()
      Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
      void require(int type, String namespaceURI, String localName)
      Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
      void setParent(XMLStreamReader reader)
      Set the parent of this instance.
      boolean standaloneSet()
      Checks if standalone was set in the document

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StreamReaderDelegate

        public StreamReaderDelegate()
        Construct an empty filter with no parent.

      • StreamReaderDelegate

        public StreamReaderDelegate(XMLStreamReader reader)
        Construct an filter with the specified parent.
        参数：
        reader - the parent

    • 方法详细信息

      • setParent

        public void setParent(XMLStreamReader reader)
        Set the parent of this instance.
        参数：
        reader - the new parent

      • getParent

        public XMLStreamReader getParent()
        Get the parent of this instance.
        返回：
        the parent or null if none is set

      • 下一个

        public int next()
         throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

        Given the following XML:
        <foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
        The behavior of calling next() when being on foo will be:
        1- the comment (COMMENT)
        2- then the characters section (CHARACTERS)
        3- then the CDATA section (another CHARACTERS)
        4- then the next characters section (another CHARACTERS)
        5- then the END_ELEMENT

        NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

        指定者：
        下一个 in interface XMLStreamReader
        返回：
        the integer code corresponding to the current parse event
        抛出：
        XMLStreamException - if there is an error processing the underlying XML source
        另请参见：
        XMLEvent

      • nextTag

        public int nextTag()
            throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
        Precondition: none
        Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
        Essentially it does the following (implementations are free to optimized but must do equivalent processing):
         int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;
        指定者：
        nextTag in interface XMLStreamReader
        返回：
        the event type of the element read (START_ELEMENT or END_ELEMENT)
        抛出：
        XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT

      • getElementText

        public String getElementText()
                      throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
        Precondition: the current event is START_ELEMENT.
        Postcondition: the current event is the corresponding END_ELEMENT.
        The method does the following (implementations are free to optimized but must do equivalent processing):
         if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();
        指定者：
        getElementText in interface XMLStreamReader
        抛出：
        XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

      • require

        public void require(int type,
           String namespaceURI,
           String localName)
             throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.
        指定者：
        require in interface XMLStreamReader
        参数：
        type - the event type
        namespaceURI - the uri of the event, may be null
        localName - the localName of the event, may be null
        抛出：
        XMLStreamException - if the required values are not matched.

      • hasNext

        public boolean hasNext()
                throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT
        指定者：
        hasNext in interface XMLStreamReader
        返回：
        true if there are more events, false otherwise
        抛出：
        XMLStreamException - if there is a fatal error detecting the next state

      • close

        public void close()
           throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Frees any resources associated with this Reader. This method does not close the underlying input source.
        指定者：
        close in interface XMLStreamReader
        抛出：
        XMLStreamException - if there are errors freeing associated resources

      • getNamespaceURI

        public String getNamespaceURI(String prefix)
        从接口复制的描述： XMLStreamReader
        Return the uri for the given prefix. The uri returned depends on the current state of the processor.

        NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

        NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

        指定者：
        getNamespaceURI in interface XMLStreamReader
        参数：
        prefix - The prefix to lookup, may not be null
        返回：
        the uri bound to the given prefix or null if it is not bound

      • getNamespaceContext

        public NamespaceContext getNamespaceContext()
        从接口复制的描述： XMLStreamReader
        Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.
        指定者：
        getNamespaceContext in interface XMLStreamReader
        返回：
        return a namespace context

      • isStartElement

        public boolean isStartElement()
        从接口复制的描述： XMLStreamReader
        Returns true if the cursor points to a start tag (otherwise false)
        指定者：
        isStartElement in interface XMLStreamReader
        返回：
        true if the cursor points to a start tag, false otherwise

      • isEndElement

        public boolean isEndElement()
        从接口复制的描述： XMLStreamReader
        Returns true if the cursor points to an end tag (otherwise false)
        指定者：
        isEndElement in interface XMLStreamReader
        返回：
        true if the cursor points to an end tag, false otherwise

      • isCharacters

        public boolean isCharacters()
        从接口复制的描述： XMLStreamReader
        Returns true if the cursor points to a character data event
        指定者：
        isCharacters in interface XMLStreamReader
        返回：
        true if the cursor points to character data, false otherwise

      • isWhiteSpace

        public boolean isWhiteSpace()
        从接口复制的描述： XMLStreamReader
        Returns true if the cursor points to a character data event that consists of all whitespace
        指定者：
        isWhiteSpace in interface XMLStreamReader
        返回：
        true if the cursor points to all whitespace, false otherwise

      • getAttributeValue

        public String getAttributeValue(String namespaceUri,
                       String localName)
        从接口复制的描述： XMLStreamReader
        Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
        指定者：
        getAttributeValue in interface XMLStreamReader
        参数：
        namespaceUri - the namespace of the attribute
        localName - the local name of the attribute, cannot be null
        返回：
        returns the value of the attribute , returns null if not found

      • getAttributeCount

        public int getAttributeCount()
        从接口复制的描述： XMLStreamReader
        Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.
        指定者：
        getAttributeCount in interface XMLStreamReader
        返回：
        returns the number of attributes

      • getAttributeName

        public QName getAttributeName(int index)
        从接口复制的描述： XMLStreamReader
        Returns the qname of the attribute at the provided index
        指定者：
        getAttributeName in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the QName of the attribute

      • getAttributePrefix

        public String getAttributePrefix(int index)
        从接口复制的描述： XMLStreamReader
        Returns the prefix of this attribute at the provided index
        指定者：
        getAttributePrefix in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the prefix of the attribute

      • getAttributeNamespace

        public String getAttributeNamespace(int index)
        从接口复制的描述： XMLStreamReader
        Returns the namespace of the attribute at the provided index
        指定者：
        getAttributeNamespace in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the namespace URI (can be null)

      • getAttributeLocalName

        public String getAttributeLocalName(int index)
        从接口复制的描述： XMLStreamReader
        Returns the localName of the attribute at the provided index
        指定者：
        getAttributeLocalName in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the localName of the attribute

      • getAttributeType

        public String getAttributeType(int index)
        从接口复制的描述： XMLStreamReader
        Returns the XML type of the attribute at the provided index
        指定者：
        getAttributeType in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the XML type of the attribute

      • getAttributeValue

        public String getAttributeValue(int index)
        从接口复制的描述： XMLStreamReader
        Returns the value of the attribute at the index
        指定者：
        getAttributeValue in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        the attribute value

      • isAttributeSpecified

        public boolean isAttributeSpecified(int index)
        从接口复制的描述： XMLStreamReader
        Returns a boolean which indicates if this attribute was created by default
        指定者：
        isAttributeSpecified in interface XMLStreamReader
        参数：
        index - the position of the attribute
        返回：
        true if this is a default attribute

      • getNamespaceCount

        public int getNamespaceCount()
        从接口复制的描述： XMLStreamReader
        Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.
        指定者：
        getNamespaceCount in interface XMLStreamReader
        返回：
        returns the number of namespace declarations on this specific element

      • getNamespacePrefix

        public String getNamespacePrefix(int index)
        从接口复制的描述： XMLStreamReader
        Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration
        指定者：
        getNamespacePrefix in interface XMLStreamReader
        参数：
        index - the position of the namespace declaration
        返回：
        returns the namespace prefix

      • getNamespaceURI

        public String getNamespaceURI(int index)
        从接口复制的描述： XMLStreamReader
        Returns the uri for the namespace declared at the index.
        指定者：
        getNamespaceURI in interface XMLStreamReader
        参数：
        index - the position of the namespace declaration
        返回：
        returns the namespace uri

      • getEventType

        public int getEventType()
        从接口复制的描述： XMLStreamReader
        Returns an integer code that indicates the type of the event the cursor is pointing to.
        指定者：
        getEventType in interface XMLStreamReader

      • getText

        public String getText()
        从接口复制的描述： XMLStreamReader
        Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.
        指定者：
        getText in interface XMLStreamReader
        返回：
        the current text or null

      • getTextCharacters

        public int getTextCharacters(int sourceStart,
                    char[] target,
                    int targetStart,
                    int length)
                      throws XMLStreamException
        从接口复制的描述： XMLStreamReader
        Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example: int length = 1024; char[] myBuffer = new char[ length ]; for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length ); if (nCopied < length) break; } XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".
        指定者：
        getTextCharacters in interface XMLStreamReader
        参数：
        sourceStart - the index of the first character in the source array to copy
        target - the destination array
        targetStart - the start offset in the target array
        length - the number of characters to copy
        返回：
        the number of characters actually copied
        抛出：
        XMLStreamException - if the underlying XML source is not well-formed

      • getTextCharacters

        public char[] getTextCharacters()
        从接口复制的描述： XMLStreamReader
        Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.
        指定者：
        getTextCharacters in interface XMLStreamReader
        返回：
        the current text or an empty array

      • getTextStart

        public int getTextStart()
        从接口复制的描述： XMLStreamReader
        Returns the offset into the text character array where the first character (of this text event) is stored.
        指定者：
        getTextStart in interface XMLStreamReader

      • getTextLength

        public int getTextLength()
        从接口复制的描述： XMLStreamReader
        Returns the length of the sequence of characters for this Text event within the text character array.
        指定者：
        getTextLength in interface XMLStreamReader

      • getEncoding

        public String getEncoding()
        从接口复制的描述： XMLStreamReader
        Return input encoding if known or null if unknown.
        指定者：
        getEncoding in interface XMLStreamReader
        返回：
        the encoding of this instance or null

      • hasText

        public boolean hasText()
        从接口复制的描述： XMLStreamReader
        Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
        指定者：
        hasText in interface XMLStreamReader

      • getLocation

        public Location getLocation()
        从接口复制的描述： XMLStreamReader
        Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.
        指定者：
        getLocation in interface XMLStreamReader

      • getName

        public QName getName()
        从接口复制的描述： XMLStreamReader
        Returns a QName for the current START_ELEMENT or END_ELEMENT event
        指定者：
        getName in interface XMLStreamReader
        返回：
        the QName for the current START_ELEMENT or END_ELEMENT event

      • getLocalName

        public String getLocalName()
        从接口复制的描述： XMLStreamReader
        Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE
        指定者：
        getLocalName in interface XMLStreamReader
        返回：
        the localName

      • hasName

        public boolean hasName()
        从接口复制的描述： XMLStreamReader
        returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
        指定者：
        hasName in interface XMLStreamReader

      • getNamespaceURI

        public String getNamespaceURI()
        从接口复制的描述： XMLStreamReader
        If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.
        指定者：
        getNamespaceURI in interface XMLStreamReader
        返回：
        the URI bound to this elements prefix, the default namespace, or null

      • getPrefix

        public String getPrefix()
        从接口复制的描述： XMLStreamReader
        Returns the prefix of the current event or null if the event does not have a prefix
        指定者：
        getPrefix in interface XMLStreamReader
        返回：
        the prefix or null

      • getVersion

        public String getVersion()
        从接口复制的描述： XMLStreamReader
        Get the xml version declared on the xml declaration Returns null if none was declared
        指定者：
        getVersion in interface XMLStreamReader
        返回：
        the XML version or null

      • isStandalone

        public boolean isStandalone()
        从接口复制的描述： XMLStreamReader
        Get the standalone declaration from the xml declaration
        指定者：
        isStandalone in interface XMLStreamReader
        返回：
        true if this is standalone, or false otherwise

      • standaloneSet

        public boolean standaloneSet()
        从接口复制的描述： XMLStreamReader
        Checks if standalone was set in the document
        指定者：
        standaloneSet in interface XMLStreamReader
        返回：
        true if standalone was set in the document, or false otherwise

      • getCharacterEncodingScheme

        public String getCharacterEncodingScheme()
        从接口复制的描述： XMLStreamReader
        Returns the character encoding declared on the xml declaration Returns null if none was declared
        指定者：
        getCharacterEncodingScheme in interface XMLStreamReader
        返回：
        the encoding declared in the document or null

      • getPITarget

        public String getPITarget()
        从接口复制的描述： XMLStreamReader
        Get the target of a processing instruction
        指定者：
        getPITarget in interface XMLStreamReader
        返回：
        the target or null

      • getPIData

        public String getPIData()
        从接口复制的描述： XMLStreamReader
        Get the data section of a processing instruction
        指定者：
        getPIData in interface XMLStreamReader
        返回：
        the data or null

      • getProperty

        public Object getProperty(String name)
        从接口复制的描述： XMLStreamReader
        Get the value of a feature/property from the underlying implementation
        指定者：
        getProperty in interface XMLStreamReader
        参数：
        name - The name of the property, may not be null
        返回：
        The value of the property
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.xml.stream.util

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.stream.util

  • Packages that use javax.xml.stream.util
    软件包 描述
    javax.xml.stream
    javax.xml.stream.util
  • Classes in javax.xml.stream.util used by javax.xml.stream
    类与描述
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • Classes in javax.xml.stream.util used by javax.xml.stream.util
    类与描述
    XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
    XMLEventConsumer
    This interface defines an event consumer interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p f


XMLEventAllocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.util

Interface XMLEventAllocator

  • public interface XMLEventAllocator
    This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader. An implementation is not required to use the XMLEventFactory implementation but this is recommended. The XMLEventAllocator can be set on an XMLInputFactory using the property "javax.xml.stream.allocator"
    从以下版本开始：
    1.6
    另请参见：
    XMLInputFactory, XMLEventFactory

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XMLEvent allocate(XMLStreamReader reader)
      This method allocates an event given the current state of the XMLStreamReader.
      void allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
      XMLEventAllocator newInstance()
      This method creates an instance of the XMLEventAllocator.

    • 方法详细信息

      • newInstance

        XMLEventAllocator newInstance()
        This method creates an instance of the XMLEventAllocator. This allows the XMLInputFactory to allocate a new instance per reader.

      • allocate

        XMLEvent allocate(XMLStreamReader reader)
                  throws XMLStreamException
        This method allocates an event given the current state of the XMLStreamReader. If this XMLEventAllocator does not have a one-to-one mapping between reader states and events this method will return null. This method must not modify the state of the XMLStreamReader.
        参数：
        reader - The XMLStreamReader to allocate from
        返回：
        the event corresponding to the current reader state
        抛出：
        XMLStreamException

      • allocate

        void allocate(XMLStreamReader reader,
            XMLEventConsumer consumer)
              throws XMLStreamException
        This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in. This method can be used to expand or contract reader states into event states. This method may modify the state of the XMLStreamReader.
        参数：
        reader - The XMLStreamReader to allocate from
        consumer - The XMLEventConsumer to add to.
        抛出：
        XMLStreamException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uu/x//xrrPibb#l#e>


XMLEventConsumer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.stream.util

Interface XMLEventConsumer

  • All Known Subinterfaces:
    XMLEventWriter

    public interface XMLEventConsumer
    This interface defines an event consumer interface. The contract of the of a consumer is to accept the event. This interface can be used to mark an object as able to receive events. Add may be called several times in immediate succession so a consumer must be able to cache events it hasn't processed yet.
    从以下版本开始：
    1.6

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(XMLEvent event)
      This method adds an event to the consumer.

    • 方法详细信息

      • add

        void add(XMLEvent event)
         throws XMLStreamException
        This method adds an event to the consumer. Calling this method invalidates the event parameter. The client application should discard all references to this event upon calling add. The behavior of an application that continues to use such references is undefined.
        参数：
        event - the event to add, may not be null
        抛出：
        XMLStreamException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" ecnbonbnssbnn


Uses of Class javax.xml.stream.util.EventReaderDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.util.EventReaderDelegate

No usage of javax.xml.stream.util.EventReaderDelegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

emh


Uses of Class javax.xml.stream.util.StreamReaderDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.stream.util.StreamReaderDelegate

No usage of javax.xml.stream.util.StreamReaderDelegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itTPe -ale. C1


Uses of Interface javax.xml.stream.util.XMLEventAllocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.util.XMLEventAllocator

  • Packages that use XMLEventAllocator
    软件包 描述
    javax.xml.stream
    javax.xml.stream.util

    • Uses of XMLEventAllocator in javax.xml.stream

      Methods in javax.xml.stream that return XMLEventAllocator
      修饰符与类型 方法与描述
      abstract XMLEventAllocator XMLInputFactory.getEventAllocator()
      Gets the allocator used by streams created with this factory
      Methods in javax.xml.stream with parameters of type XMLEventAllocator
      修饰符与类型 方法与描述
      abstract void XMLInputFactory.setEventAllocator(XMLEventAllocator allocator)
      Set a user defined event allocator for events

    • Uses of XMLEventAllocator in javax.xml.stream.util

      Methods in javax.xml.stream.util that return XMLEventAllocator
      修饰符与类型 方法与描述
      XMLEventAllocator XMLEventAllocator.newInstance()
      This method creates an instance of the XMLEventAllocator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gS>"e>.�/alsd遥 .xCu./m


Uses of Interface javax.xml.stream.util.XMLEventConsumer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.stream.util.XMLEventConsumer

  • Packages that use XMLEventConsumer
    软件包 描述
    javax.xml.stream
    javax.xml.stream.util

    • Uses of XMLEventConsumer in javax.xml.stream

      Subinterfaces of XMLEventConsumer in javax.xml.stream
      修饰符与类型 Interface and Description
      interface  XMLEventWriter
      This is the top level interface for writing XML documents.

    • Uses of XMLEventConsumer in javax.xml.stream.util

      Methods in javax.xml.stream.util with parameters of type XMLEventConsumer
      修饰符与类型 方法与描述
      void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
      This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. gc ded cmtci si uirrii


ErrorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface ErrorListener

  • public interface ErrorListener

    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer. The Transformer then reports all errors and warnings through this interface.

    If an application does not register its own custom ErrorListener, the default ErrorListener is used which reports all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

    For transformation errors, a Transformer must use this interface instead of throwing an Exception: it is up to the application to decide whether to throw an Exception for different types of errors and warnings. Note however that the Transformer is not required to continue with the transformation after a call to fatalError(TransformerException exception).

    Transformers may use this mechanism to report XML parsing errors as well as transformation errors.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void error(TransformerException exception)
      Receive notification of a recoverable error.
      void fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      void warning(TransformerException exception)
      Receive notification of a warning.

    • 方法详细信息

      • warning

        void warning(TransformerException exception)
             throws TransformerException
        Receive notification of a warning.

        Transformer can use this method to report conditions that are not errors or fatal errors. The default behaviour is to take no action.

        After invoking this method, the Transformer must continue with the transformation. It should still be possible for the application to process the document through to the end.

        参数：
        exception - The warning information encapsulated in a transformer exception.
        抛出：
        TransformerException - if the application chooses to discontinue the transformation.
        另请参见：
        TransformerException

      • error

        void error(TransformerException exception)
           throws TransformerException
        Receive notification of a recoverable error.

        The transformer must continue to try and provide normal transformation after invoking this method. It should still be possible for the application to process the document through to the end if no other errors are encountered.

        参数：
        exception - The error information encapsulated in a transformer exception.
        抛出：
        TransformerException - if the application chooses to discontinue the transformation.
        另请参见：
        TransformerException

      • fatalError

        void fatalError(TransformerException exception)
                throws TransformerException

        Receive notification of a non-recoverable error.

        The processor may choose to continue, but will not normally proceed to a successful completion.

        The method should throw an exception if it is unable to process the error, or if it wishes execution to terminate immediately. The processor will not necessarily honor this request.

        参数：
        exception - The error information encapsulated in a TransformerException.
        抛出：
        TransformerException - if the application chooses to discontinue the transformation.
        另请参见：
        TransformerException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eev/a>"i_ㄔ


javax.xml.transform

Interfaces

  • ErrorListener
  • Result
  • Source
  • SourceLocator
  • Templates
  • URIResolver

Classes

  • OutputKeys
  • Transformer
  • TransformerFactory

Exceptions

  • TransformerConfigurationException
  • TransformerException

Errors

  • TransformerFactoryConfigurationError
x


javax.xml.transform

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.transform

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

请参见： 描述

  • 接口摘要
    接口 描述
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Class Summary
    类 描述
    OutputKeys
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Exception Summary
    Exception 描述
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
  • Error Summary
    Error 描述
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.

软件包 javax.xml.transform Description

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result. These interfaces have no dependencies on SAX or the DOM standard, and try to make as few assumptions as possible about the details of the source and result of a transformation. It achieves this by defining Source and Result interfaces.

To define concrete classes for the user, the API defines specializations of the interfaces found at the root level. These interfaces are found in javax.xml.transform.sax, javax.xml.transform.dom, and javax.xml.transform.stream.

Creating Objects

The API allows a concrete TransformerFactory object to be created from the static function TransformerFactory.newInstance().

Specification of Inputs and Outputs

This API defines two interface objects called Source and Result. In order to pass Source and Result objects to the interfaces, concrete classes must be used. Three concrete representations are defined for each of these objects: StreamSource and StreamResult, SAXSource and SAXResult, and DOMSource and DOMResult. Each of these objects defines a FEATURE string (which is i the form of a URL), which can be passed into TransformerFactory.getFeature(java.lang.String) to see if the given type of Source or Result object is supported. For instance, to test if a DOMSource and a StreamResult is supported, you can apply the following test.

TransformerFactory tfactory = TransformerFactory.newInstance();
if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE)) {
...
}

Qualified Name Representation

Namespaces present something of a problem area when dealing with XML objects. Qualified Names appear in XML markup as prefixed names. But the prefixes themselves do not hold identity. Rather, it is the URIs that they contextually map to that hold the identity. Therefore, when passing a Qualified Name like "xyz:foo" among Java programs, one must provide a means to map "xyz" to a namespace.

One solution has been to create a "QName" object that holds the namespace URI, as well as the prefix and local name, but this is not always an optimal solution, as when, for example, you want to use unique strings as keys in a dictionary object. Not having a string representation also makes it difficult to specify a namespaced identity outside the context of an XML document.

In order to pass namespaced values to transformations, for instance when setting a property or a parameter on a Transformer object, this specification defines that a String "qname" object parameter be passed as two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the qname has a null URI, then the String object only contains the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the Qualified Name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that the prefix is lost.

Result Tree Serialization

Serialization of the result tree to a stream can be controlled with the Transformer.setOutputProperties(java.util.Properties) and the Transformer.setOutputProperty(java.lang.String, java.lang.String) methods. These properties only apply to stream results, they have no effect when the result is a DOM tree or SAX event stream.

Strings that match the XSLT specification for xsl:output attributes can be referenced from the OutputKeys class. Other strings can be specified as well. If the transformer does not recognize an output key, a IllegalArgumentException is thrown, unless the key name is namespace qualified. Output key names that are namespace qualified are always allowed, although they may be ignored by some implementations.

If all that is desired is the simple identity transformation of a source to a result, then TransformerFactory provides a TransformerFactory.newTransformer() method with no arguments. This method creates a Transformer that effectively copies the source to the result. This method may be used to create a DOM from SAX events or to create an XML or HTML stream from a DOM or SAX events.

Exceptions and Error Reporting

The transformation API throw three types of specialized exceptions. A TransformerFactoryConfigurationError is parallel to the FactoryConfigurationError, and is thrown when a configuration problem with the TransformerFactory exists. This error will typically be thrown when the transformation factory class specified with the "javax.xml.transform.TransformerFactory" system property cannot be found or instantiated.

A TransformerConfigurationException may be thrown if for any reason a Transformer can not be created. A TransformerConfigurationException may be thrown if there is a syntax error in the transformation instructions, for example when TransformerFactory.newTransformer(javax.xml.transform.Source) is called.

TransformerException is a general exception that occurs during the course of a transformation. A transformer exception may wrap another exception, and if any of the TransformerException.printStackTrace() methods are called on it, it will produce a list of stack dumps, starting from the most recent. The transformer exception also provides a SourceLocator object which indicates where in the source tree or transformation instructions the error occurred. TransformerException.getMessageAndLocation() may be called to get an error message with location info, and TransformerException.getLocationAsString() may be called to get just the location string.

Transformation warnings and errors are sent to an ErrorListener, at which point the application may decide to report the error or warning, and may decide to throw an Exception for a non-fatal error. The ErrorListener may be set via TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener) for reporting errors that have to do with syntax errors in the transformation instructions, or via Transformer.setErrorListener(javax.xml.transform.ErrorListener) to report errors that occur during the transformation. The ErrorListener on both objects will always be valid and non-null, whether set by the application or a default implementation provided by the processor. The default implementation provided by the processor will report all warnings and errors to System.err and does not throw any Exceptions. Applications are strongly encouraged to register and use ErrorListeners that insure proper behavior for warnings and errors.

Resolution of URIs within a transformation

The API provides a way for URIs referenced from within the stylesheet instructions or within the transformation to be resolved by the calling application. This can be done by creating a class that implements the URIResolver interface, with its one method, URIResolver.resolve(java.lang.String, java.lang.String), and use this class to set the URI resolution for the transformation instructions or transformation with TransformerFactory.setURIResolver(javax.xml.transform.URIResolver) or Transformer.setURIResolver(javax.xml.transform.URIResolver). The URIResolver.resolve method takes two String arguments, the URI found in the stylesheet instructions or built as part of the transformation process, and the base URI against which the first argument will be made absolute if the absolute URI is required. The returned Source object must be usable by the transformer, as specified in its implemented features.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpmRlpcm鎚t"<>x;/o� 20 0/�


javax.xml.transform Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.transform

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.OutputKeys
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.transform.TransformerFactoryConfigurationError
      • java.lang.Exception
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory

Interface Hierarchy

  • javax.xml.transform.ErrorListener
  • javax.xml.transform.Result
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
  • javax.xml.transform.Templates
  • javax.xml.transform.URIResolver
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s =>e/balll


OutputKeys

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.transform

类 OutputKeys

  • java.lang.Object
    • javax.xml.transform.OutputKeys

  • public class OutputKeys
extends Object
    Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.

    All the fields in this class are read-only.

    另请参见：
    section 16 of the XSL Transformations (XSLT) W3C Recommendation

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String CDATA_SECTION_ELEMENTS
      cdata-section-elements = expanded names.
      static String DOCTYPE_PUBLIC
      doctype-public = string.
      static String DOCTYPE_SYSTEM
      doctype-system = string.
      static String ENCODING
      encoding = string.
      static String INDENT
      indent = "yes" | "no".
      static String MEDIA_TYPE
      media-type = string.
      static String 方法
      method = "xml" | "html" | "text" | expanded name.
      static String OMIT_XML_DECLARATION
      omit-xml-declaration = "yes" | "no".
      static String STANDALONE
      standalone = "yes" | "no".
      static String VERSION
      version = nmtoken.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • METHOD

        public static final String METHOD
        method = "xml" | "html" | "text" | expanded name.

        The value of the method property identifies the overall method that should be used for outputting the result tree. Other non-namespaced values may be used, such as "xhtml", but, if accepted, the handling of such values is implementation defined. If any of the method values are not accepted and are not namespace qualified, then Transformer.setOutputProperty(java.lang.String, java.lang.String) or Transformer.setOutputProperties(java.util.Properties) will throw a IllegalArgumentException.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • VERSION

        public static final String VERSION
        version = nmtoken.

        version specifies the version of the output method.

        When the output method is "xml", the version value specifies the version of XML to be used for outputting the result tree. The default value for the xml output method is 1.0. When the output method is "html", the version value indicates the version of the HTML. The default value for the xml output method is 4.0, which specifies that the result should be output as HTML conforming to the HTML 4.0 Recommendation [HTML]. If the output method is "text", the version property is ignored.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • ENCODING

        public static final String ENCODING
        encoding = string.

        encoding specifies the preferred character encoding that the Transformer should use to encode sequences of characters as sequences of bytes. The value of the encoding property should be treated case-insensitively. The value must only contain characters in the range #x21 to #x7E (i.e., printable ASCII characters). The value should either be a charset registered with the Internet Assigned Numbers Authority [IANA], [RFC2278] or start with X-.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • OMIT_XML_DECLARATION

        public static final String OMIT_XML_DECLARATION
        omit-xml-declaration = "yes" | "no".

        omit-xml-declaration specifies whether the XSLT processor should output an XML declaration; the value must be yes or no.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • STANDALONE

        public static final String STANDALONE
        standalone = "yes" | "no".

        standalone specifies whether the Transformer should output a standalone document declaration; the value must be yes or no.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • DOCTYPE_PUBLIC

        public static final String DOCTYPE_PUBLIC
        doctype-public = string.

        See the documentation for the DOCTYPE_SYSTEM property for a description of what the value of the key should be.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • DOCTYPE_SYSTEM

        public static final String DOCTYPE_SYSTEM
        doctype-system = string.

        doctype-system specifies the system identifier to be used in the document type declaration.

        If the doctype-system property is specified, the xml output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be the name of the first element. If doctype-public property is also specified, then the xml output method should output PUBLIC followed by the public identifier and then the system identifier; otherwise, it should output SYSTEM followed by the system identifier. The internal subset should be empty. The value of the doctype-public property should be ignored unless the doctype-system property is specified.

        If the doctype-public or doctype-system properties are specified, then the html output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be HTML or html. If the doctype-public property is specified, then the output method should output PUBLIC followed by the specified public identifier; if the doctype-system property is also specified, it should also output the specified system identifier following the public identifier. If the doctype-system property is specified but the doctype-public property is not specified, then the output method should output SYSTEM followed by the specified system identifier.

        doctype-system specifies the system identifier to be used in the document type declaration.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • CDATA_SECTION_ELEMENTS

        public static final String CDATA_SECTION_ELEMENTS
        cdata-section-elements = expanded names.

        cdata-section-elements specifies a whitespace delimited list of the names of elements whose text node children should be output using CDATA sections. Note that these names must use the format described in the section Qualfied Name Representation in javax.xml.transform.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation., Constant Field Values

      • INDENT

        public static final String INDENT
        indent = "yes" | "no".

        indent specifies whether the Transformer may add additional whitespace when outputting the result tree; the value must be yes or no.

        另请参见：
        section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

      • MEDIA_TYPE

        public static final String MEDIA_TYPE
        media-type = string.

        media-type specifies the media type (MIME content type) of the data that results from outputting the result tree. The charset parameter should not be specified explicitly; instead, when the top-level media type is text, a charset parameter should be added according to the character encoding actually used by the output method.

        另请参见：
        s ection 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sve=;nC.&b&>ytm).n= .tx< n


Result

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface Result

  • All Known Implementing Classes:
    DOMResult, JAXBResult, SAAJResult, SAXResult, StAXResult, StreamResult

    public interface Result

    An object that implements this interface contains the information needed to build a transformation result tree.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String PI_DISABLE_OUTPUT_ESCAPING
      The name of the processing instruction that is sent if the result tree disables output escaping.
      static String PI_ENABLE_OUTPUT_ESCAPING
      The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setSystemId(String systemId)
      Set the system identifier for this Result.

    • 字段详细信息

      • PI_DISABLE_OUTPUT_ESCAPING

        static final String PI_DISABLE_OUTPUT_ESCAPING
        The name of the processing instruction that is sent if the result tree disables output escaping.

        Normally, result tree serialization escapes & and < (and possibly other characters) when outputting text nodes. This ensures that the output is well-formed XML. However, it is sometimes convenient to be able to produce output that is almost, but not quite well-formed XML; for example, the output may include ill-formed sections that will be transformed into well-formed XML by a subsequent non-XML aware process. If a processing instruction is sent with this name, serialization should be output without any escaping.

        Result DOM trees may also have PI_DISABLE_OUTPUT_ESCAPING and PI_ENABLE_OUTPUT_ESCAPING inserted into the tree.

        另请参见：
        disable-output-escaping in XSLT Specification, Constant Field Values

      • PI_ENABLE_OUTPUT_ESCAPING

        static final String PI_ENABLE_OUTPUT_ESCAPING
        The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.
        另请参见：
        disable-output-escaping in XSLT Specification, Constant Field Values

    • 方法详细信息

      • setSystemId

        void setSystemId(String systemId)
        Set the system identifier for this Result.

        If the Result is not to be written to a file, the system identifier is optional. The application may still want to provide one, however, for use in error messages and warnings, or to resolve relative output identifiers.

        参数：
        systemId - The system identifier as a URI string.

      • getSystemId

        String getSystemId()
        Get the system identifier that was set with setSystemId.
        返回：
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

melmrusursueusaar/..


Source

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface Source

  • All Known Implementing Classes:
    DOMSource, JAXBSource, SAXSource, StAXSource, StreamSource

    public interface Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setSystemId(String systemId)
      Set the system identifier for this Source.

    • 方法详细信息

      • setSystemId

        void setSystemId(String systemId)
        Set the system identifier for this Source.

        The system identifier is optional if the source does not get its data from a URL, but it may still be useful to provide one. The application can use a system identifier, for example, to resolve relative URIs and to include in error messages and warnings.

        参数：
        systemId - The system identifier as a URL string.

      • getSystemId

        String getSystemId()
        Get the system identifier that was set with setSystemId.
        返回：
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tne


SourceLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface SourceLocator

  • All Known Subinterfaces:
    DOMLocator

    public interface SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Return the character position where the current document event ends.
      int getLineNumber()
      Return the line number where the current document event ends.
      String getPublicId()
      Return the public identifier for the current document event.
      String getSystemId()
      Return the system identifier for the current document event.

    • 方法详细信息

      • getPublicId

        String getPublicId()
        Return the public identifier for the current document event.

        The return value is the public identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

        返回：
        A string containing the public identifier, or null if none is available.
        另请参见：
        getSystemId()

      • getSystemId

        String getSystemId()
        Return the system identifier for the current document event.

        The return value is the system identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        返回：
        A string containing the system identifier, or null if none is available.
        另请参见：
        getPublicId()

      • getLineNumber

        int getLineNumber()
        Return the line number where the current document event ends.

        警告： The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

        The return value is an approximation of the line number in the document entity or external parsed entity where the markup that triggered the event appears.

        返回：
        The line number, or -1 if none is available.
        另请参见：
        getColumnNumber()

      • getColumnNumber

        int getColumnNumber()
        Return the character position where the current document event ends.

        警告： The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

        The return value is an approximation of the column number in the document entity or external parsed entity where the markup that triggered the event appears.

        返回：
        The column number, or -1 if none is available.
        另请参见：
        getLineNumber()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lleoctdtEengtEle.teeae>helllv�


Templates

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface Templates

  • public interface Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.

    Templates must be threadsafe for a given instance over multiple threads running concurrently, and may be used multiple times in a given session.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Properties getOutputProperties()
      Get the properties corresponding to the effective xsl:output element.
      Transformer newTransformer()
      Create a new transformation context for this Templates object.

    • 方法详细信息

      • newTransformer

        Transformer newTransformer()
                           throws TransformerConfigurationException
        Create a new transformation context for this Templates object.
        返回：
        A valid non-null instance of a Transformer.
        抛出：
        TransformerConfigurationException - if a Transformer can not be created.

      • getOutputProperties

        Properties getOutputProperties()
        Get the properties corresponding to the effective xsl:output element. The object returned will be a clone of the internal values. Accordingly, it can be mutated without mutating the Templates object, and then handed in to Transformer.setOutputProperties(java.util.Properties).

        The properties returned should contain properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be in the "default" Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set in the stylesheet.

        For XSLT, Attribute Value Templates attribute values will be returned unexpanded (since there is no context at this point). The namespace prefixes inside Attribute Value Templates will be unexpanded, so that they remain valid XPath values.

        返回：
        A Properties object, never null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.t.c.L.".rtl" hLhhvaxvaa/avtmt�


Transformer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform

类 Transformer

  • java.lang.Object
    • javax.xml.transform.Transformer

  • public abstract class Transformer
extends Object
    An instance of this abstract class can transform a source tree into a result tree.

    An instance of this class can be obtained with the TransformerFactory.newTransformer method. This instance may then be used to process XML from a variety of sources and write the transformation output to a variety of sinks.

    An object of this class may not be used in multiple threads running concurrently. Different Transformers may be used concurrently by different threads.

    A Transformer may be used multiple times. Parameters and output properties are preserved across transformations.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Transformer()
      Default constructor is protected on purpose.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void clearParameters()
      Clear all parameters set with setParameter.
      abstract ErrorListener getErrorListener()
      Get the error event handler in effect for the transformation.
      abstract Properties getOutputProperties()
      Get a copy of the output properties for the transformation.
      abstract String getOutputProperty(String name)
      Get an output property that is in effect for the transformer.
      abstract Object getParameter(String name)
      Get a parameter that was explicitly set with setParameter.
      abstract URIResolver getURIResolver()
      Get an object that will be used to resolve URIs used in document().
      void reset()
      Reset this Transformer to its original configuration.
      abstract void setErrorListener(ErrorListener listener)
      Set the error event listener in effect for the transformation.
      abstract void setOutputProperties(Properties oformat)
      Set the output properties for the transformation.
      abstract void setOutputProperty(String name, String value)
      Set an output property that will be in effect for the transformation.
      abstract void setParameter(String name, Object value)
      Add a parameter for the transformation.
      abstract void setURIResolver(URIResolver resolver)
      Set an object that will be used to resolve URIs used in document().
      abstract void transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Transformer

        protected Transformer()
        Default constructor is protected on purpose.

    • 方法详细信息

      • reset

        public void reset()

        Reset this Transformer to its original configuration.

        Transformer is reset to the same state as when it was created with TransformerFactory.newTransformer(), TransformerFactory.newTransformer(Source source) or Templates.newTransformer(). reset() is designed to allow the reuse of existing Transformers thus saving resources associated with the creation of new Transformers.

        The reset Transformer is not guaranteed to have the same URIResolver or ErrorListener Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal URIResolver and ErrorListener.

        抛出：
        UnsupportedOperationException - When implementation does not override this method.
        从以下版本开始：
        1.5

      • transform

        public abstract void transform(Source xmlSource,
             Result outputTarget)
                        throws TransformerException

        Transform the XML Source to a Result. Specific transformation behavior is determined by the settings of the TransformerFactory in effect when the Transformer was instantiated and any modifications made to the Transformer instance.

        An empty Source is represented as an empty document as constructed by DocumentBuilder.newDocument(). The result of transforming an empty Source depends on the transformation behavior; it is not always an empty Result.

        参数：
        xmlSource - The XML input to transform.
        outputTarget - The Result of transforming the xmlSource.
        抛出：
        TransformerException - If an unrecoverable error occurs during the course of the transformation.

      • setParameter

        public abstract void setParameter(String name,
                Object value)
        Add a parameter for the transformation.

        Pass a qualified name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        参数：
        name - The name of the parameter, which may begin with a namespace URI in curly braces ({}).
        value - The value object. This can be any valid Java object. It is up to the processor to provide the proper object coersion or to simply pass the object on for use in an extension.
        抛出：
        NullPointerException - If value is null.

      • getParameter

        public abstract Object getParameter(String name)
        Get a parameter that was explicitly set with setParameter.

        This method does not return a default parameter value, which cannot be determined until the node context is evaluated during the transformation process.

        参数：
        name - of Object to get
        返回：
        A parameter that has been set with setParameter.

      • clearParameters

        public abstract void clearParameters()
        Clear all parameters set with setParameter.

      • setURIResolver

        public abstract void setURIResolver(URIResolver resolver)
        Set an object that will be used to resolve URIs used in document().

        If the resolver argument is null, the URIResolver value will be cleared and the transformer will no longer have a resolver.

        参数：
        resolver - An object that implements the URIResolver interface, or null.

      • getURIResolver

        public abstract URIResolver getURIResolver()
        Get an object that will be used to resolve URIs used in document().
        返回：
        An object that implements the URIResolver interface, or null.

      • setOutputProperties

        public abstract void setOutputProperties(Properties oformat)
        Set the output properties for the transformation. These properties will override properties set in the Templates with xsl:output.

        If argument to this function is null, any properties previously set are removed, and the value will revert to the value defined in the templates object.

        Pass a qualified property key name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        An IllegalArgumentException is thrown if any of the argument keys are not recognized and are not namespace qualified.
        参数：
        oformat - A set of output properties that will be used to override any of the same properties in affect for the transformation.
        抛出：
        IllegalArgumentException - When keys are not recognized and are not namespace qualified.
        另请参见：
        OutputKeys, Properties

      • getOutputProperties

        public abstract Properties getOutputProperties()

        Get a copy of the output properties for the transformation.

        The properties returned should contain properties set by the user, and properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the user or the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be the default Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), in the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), or in the stylesheet.

        Note that mutation of the Properties object returned will not effect the properties that the transformer contains.

        If any of the argument keys are not recognized and are not namespace qualified, the property will be ignored and not returned. In other words the behaviour is not orthogonal with setOutputProperties.

        返回：
        A copy of the set of output properties in effect for the next transformation.
        另请参见：
        OutputKeys, Properties, XSL Transformations (XSLT) Version 1.0

      • setOutputProperty

        public abstract void setOutputProperty(String name,
                     String value)
                                throws IllegalArgumentException
        Set an output property that will be in effect for the transformation.

        Pass a qualified property name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

        For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

        The Properties object that was passed to setOutputProperties(java.util.Properties) won't be effected by calling this method.

        参数：
        name - A non-null String that specifies an output property name, which may be namespace qualified.
        value - The non-null string value of the output property.
        抛出：
        IllegalArgumentException - If the property is not supported, and is not qualified with a namespace.
        另请参见：
        OutputKeys

      • getOutputProperty

        public abstract String getOutputProperty(String name)
                                  throws IllegalArgumentException

        Get an output property that is in effect for the transformer.

        If a property has been set using setOutputProperty(java.lang.String, java.lang.String), that value will be returned. Otherwise, if a property is explicitly specified in the stylesheet, that value will be returned. If the value of the property has been defaulted, that is, if no value has been set explicitly either with setOutputProperty(java.lang.String, java.lang.String) or in the stylesheet, the result may vary depending on implementation and input stylesheet.

        参数：
        name - A non-null String that specifies an output property name, which may be namespace qualified.
        返回：
        The string value of the output property, or null if no property was found.
        抛出：
        IllegalArgumentException - If the property is not supported.
        另请参见：
        OutputKeys

      • setErrorListener

        public abstract void setErrorListener(ErrorListener listener)
                               throws IllegalArgumentException
        Set the error event listener in effect for the transformation.
        参数：
        listener - The new error listener.
        抛出：
        IllegalArgumentException - if listener is null.

      • getErrorListener

        public abstract ErrorListener getErrorListener()
        Get the error event handler in effect for the transformation. Implementations must provide a default error listener.
        返回：
        The current error handler, which should never be null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TransformerConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.transform

类 TransformerConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
  • 所有已实现的接口：
    Serializable

    public class TransformerConfigurationException
extends TransformerException
    Indicates a serious configuration error.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransformerConfigurationException()
      Create a new TransformerConfigurationException with no detail mesage.
      TransformerConfigurationException(String msg)
      Create a new TransformerConfigurationException with the String specified as an error message.
      TransformerConfigurationException(String message, SourceLocator locator)
      Create a new TransformerConfigurationException from a message and a Locator.
      TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerConfigurationException.
      TransformerConfigurationException(String msg, Throwable e)
      Create a new TransformerConfigurationException with the given Exception base cause and detail message.
      TransformerConfigurationException(Throwable e)
      Create a new TransformerConfigurationException with a given Exception base cause of the error.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.transform.TransformerException

        getCause, getException, getLocationAsString, getLocator, getMessageAndLocation, initCause, printStackTrace, printStackTrace, printStackTrace, setLocator

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransformerConfigurationException

        public TransformerConfigurationException()
        Create a new TransformerConfigurationException with no detail mesage.

      • TransformerConfigurationException

        public TransformerConfigurationException(String msg)
        Create a new TransformerConfigurationException with the String specified as an error message.
        参数：
        msg - The error message for the exception.

      • TransformerConfigurationException

        public TransformerConfigurationException(Throwable e)
        Create a new TransformerConfigurationException with a given Exception base cause of the error.
        参数：
        e - The exception to be encapsulated in a TransformerConfigurationException.

      • TransformerConfigurationException

        public TransformerConfigurationException(String msg,
                                 Throwable e)
        Create a new TransformerConfigurationException with the given Exception base cause and detail message.
        参数：
        e - The exception to be encapsulated in a TransformerConfigurationException
        msg - The detail message.

      • TransformerConfigurationException

        public TransformerConfigurationException(String message,
                                 SourceLocator locator)
        Create a new TransformerConfigurationException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

        参数：
        message - The error or warning message.
        locator - The locator object for the error or warning.

      • TransformerConfigurationException

        public TransformerConfigurationException(String message,
                                 SourceLocator locator,
                                 Throwable e)
        Wrap an existing exception in a TransformerConfigurationException.
        参数：
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning.
        e - Any exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"esp


TransformerException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform

类 TransformerException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.transform.TransformerException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    TransformerConfigurationException

    public class TransformerException
extends Exception
    This class specifies an exceptional condition that occured during the transformation process.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransformerException(String message)
      Create a new TransformerException.
      TransformerException(String message, SourceLocator locator)
      Create a new TransformerException from a message and a Locator.
      TransformerException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerException.
      TransformerException(String message, Throwable e)
      Wrap an existing exception in a TransformerException.
      TransformerException(Throwable e)
      Create a new TransformerException wrapping an existing exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Returns the cause of this throwable or null if the cause is nonexistent or unknown.
      Throwable getException()
      This method retrieves an exception that this exception wraps.
      String getLocationAsString()
      Get the location information as a string.
      SourceLocator getLocator()
      Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
      String getMessageAndLocation()
      Get the error message with location information appended.
      Throwable initCause(Throwable cause)
      Initializes the cause of this throwable to the specified value.
      void printStackTrace()
      Print the the trace of methods from where the error originated.
      void printStackTrace(PrintStream s)
      Print the the trace of methods from where the error originated.
      void printStackTrace(PrintWriter s)
      Print the the trace of methods from where the error originated.
      void setLocator(SourceLocator location)
      Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransformerException

        public TransformerException(String message)
        Create a new TransformerException.
        参数：
        message - The error or warning message.

      • TransformerException

        public TransformerException(Throwable e)
        Create a new TransformerException wrapping an existing exception.
        参数：
        e - The exception to be wrapped.

      • TransformerException

        public TransformerException(String message,
                    Throwable e)
        Wrap an existing exception in a TransformerException.

        This is used for throwing processor exceptions before the processing has started.

        参数：
        message - The error or warning message, or null to use the message from the embedded exception.
        e - Any exception

      • TransformerException

        public TransformerException(String message,
                    SourceLocator locator)
        Create a new TransformerException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

        参数：
        message - The error or warning message.
        locator - The locator object for the error or warning.

      • TransformerException

        public TransformerException(String message,
                    SourceLocator locator,
                    Throwable e)
        Wrap an existing exception in a TransformerException.
        参数：
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning.
        e - Any exception

    • 方法详细信息

      • getLocator

        public SourceLocator getLocator()
        Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
        返回：
        A SourceLocator object, or null if none was specified.

      • setLocator

        public void setLocator(SourceLocator location)
        Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.
        参数：
        location - A SourceLocator object, or null to clear the location.

      • getException

        public Throwable getException()
        This method retrieves an exception that this exception wraps.
        返回：
        An Throwable object, or null.
        另请参见：
        getCause()

      • getCause

        public Throwable getCause()
        Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)
        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.

      • initCause

        public Throwable initCause(Throwable cause)
        Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

        This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), this method cannot be called even once.

        重载：
        initCause in class Throwable
        参数：
        cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
        返回：
        a reference to this Throwable instance.
        抛出：
        IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
        IllegalStateException - if this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), or this method has already been called on this throwable.

      • getMessageAndLocation

        public String getMessageAndLocation()
        Get the error message with location information appended.
        返回：
        A String representing the error message with location information appended.

      • getLocationAsString

        public String getLocationAsString()
        Get the location information as a string.
        返回：
        A string with location info, or null if there is no location information.

      • printStackTrace

        public void printStackTrace()
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintStream s)
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        重载：
        printStackTrace in class Throwable
        参数：
        s - The stream where the dump will be sent to.

      • printStackTrace

        public void printStackTrace(PrintWriter s)
        Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.
        重载：
        printStackTrace in class Throwable
        参数：
        s - The writer where the dump will be sent to.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c >"uJvJtac"�> =rctc;e妨� �>/d<


TransformerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform

类 TransformerFactory

  • java.lang.Object
    • javax.xml.transform.TransformerFactory
  • 直接已知子类：
    SAXTransformerFactory

    public abstract class TransformerFactory
extends Object

    A TransformerFactory instance can be used to create Transformer and Templates objects.

    The system property that determines which Factory implementation to create is named "javax.xml.transform.TransformerFactory". This property names a concrete subclass of the TransformerFactory abstract class. If the property is not defined, a platform default is be used.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TransformerFactory()
      Default constructor is protected on purpose.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Source getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Object getAttribute(String name)
      Allows the user to retrieve specific attributes on the underlying implementation.
      abstract ErrorListener getErrorListener()
      Get the error event handler for the TransformerFactory.
      abstract boolean getFeature(String name)
      Look up the value of a feature.
      abstract URIResolver getURIResolver()
      Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      static TransformerFactory newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.
      abstract Templates newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      abstract Transformer newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void setAttribute(String name, Object value)
      Allows the user to set specific attributes on the underlying implementation.
      abstract void setErrorListener(ErrorListener listener)
      Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.
      abstract void setFeature(String name, boolean value)
      Set a feature for this TransformerFactory and Transformers or Templates created by this factory.
      abstract void setURIResolver(URIResolver resolver)
      Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TransformerFactory

        protected TransformerFactory()
        Default constructor is protected on purpose.

    • 方法详细信息

      • newInstance

        public static TransformerFactory newInstance()
                                      throws TransformerFactoryConfigurationError

        Obtain a new instance of a TransformerFactory. This static method creates a new factory instance This method uses the following ordered lookup procedure to determine the TransformerFactory implementation class to load:

        • Use the javax.xml.transform.TransformerFactory system property.
        • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. The jaxp.properties file is read only once by the JAXP implementation and it's values are then cached for future use. If the file does not exist when the first attempt is made to read from it, no further attempts are made to check for its existence. It is not possible to change the value of any property in jaxp.properties after it has been read for the first time.
        • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.transform.TransformerFactory in jars available to the runtime.
        • Platform default TransformerFactory instance.

        Once an application has obtained a reference to a TransformerFactory it can use the factory to configure and obtain transformer instances.

        返回：
        new TransformerFactory instance, never null.
        抛出：
        TransformerFactoryConfigurationError - Thrown if the implementation is not available or cannot be instantiated.

      • newInstance

        public static TransformerFactory newInstance(String factoryClassName,
                             ClassLoader classLoader)
                                      throws TransformerFactoryConfigurationError

        Obtain a new instance of a TransformerFactory from factory class name. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Once an application has obtained a reference to a TransformerFactory it can use the factory to configure and obtain transformer instances.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.transform.TransformerFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        new TransformerFactory instance, never null.
        抛出：
        TransformerFactoryConfigurationError - if factoryClassName is null, or the factory class cannot be loaded, instantiated.
        从以下版本开始：
        1.6
        另请参见：
        newInstance()

      • newTransformer

        public abstract Transformer newTransformer(Source source)
                                    throws TransformerConfigurationException

        Process the Source into a Transformer Object. The Source is an XSLT document that conforms to XSL Transformations (XSLT) Version 1.0. Care must be taken not to use this Transformer in multiple Threads running concurrently. Different TransformerFactories can be used concurrently by different Threads.

        参数：
        source - Source of XSLT document used to create Transformer. Examples of XML Sources include DOMSource, SAXSource, and StreamSource.
        返回：
        A Transformer object that may be used to perform a transformation in a single Thread, never null.
        抛出：
        TransformerConfigurationException - Thrown if there are errors when parsing the Source or it is not possible to create a Transformer instance.
        另请参见：
        XSL Transformations (XSLT) Version 1.0

      • newTransformer

        public abstract Transformer newTransformer()
                                    throws TransformerConfigurationException

        Create a new Transformer that performs a copy of the Source to the Result. i.e. the "identity transform".

        返回：
        A Transformer object that may be used to perform a transformation in a single thread, never null.
        抛出：
        TransformerConfigurationException - When it is not possible to create a Transformer instance.

      • newTemplates

        public abstract Templates newTemplates(Source source)
                                throws TransformerConfigurationException
        Process the Source into a Templates object, which is a a compiled representation of the source. This Templates object may then be used concurrently across multiple threads. Creating a Templates object allows the TransformerFactory to do detailed performance optimization of transformation instructions, without penalizing runtime transformation.
        参数：
        source - An object that holds a URL, input stream, etc.
        返回：
        A Templates object capable of being used for transformation purposes, never null.
        抛出：
        TransformerConfigurationException - When parsing to construct the Templates object fails.

      • getAssociatedStylesheet

        public abstract Source getAssociatedStylesheet(Source source,
                             String media,
                             String title,
                             String charset)
                                        throws TransformerConfigurationException

        Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria. Note that it is possible to return several stylesheets, in which case they are applied as if they were a list of imports or cascades in a single stylesheet.

        参数：
        source - The XML source document.
        media - The media attribute to be matched. May be null, in which case the prefered templates will be used (i.e. alternate = no).
        title - The value of the title attribute to match. May be null.
        charset - The value of the charset attribute to match. May be null.
        返回：
        A Source Object suitable for passing to the TransformerFactory.
        抛出：
        TransformerConfigurationException - An Exception is thrown if an error occurings during parsing of the source.
        另请参见：
        Associating Style Sheets with XML documents Version 1.0

      • setURIResolver

        public abstract void setURIResolver(URIResolver resolver)
        Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
        参数：
        resolver - An object that implements the URIResolver interface, or null.

      • getURIResolver

        public abstract URIResolver getURIResolver()
        Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
        返回：
        The URIResolver that was set with setURIResolver.

      • setFeature

        public abstract void setFeature(String name,
              boolean value)
                         throws TransformerConfigurationException

        Set a feature for this TransformerFactory and Transformers or Templates created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. An TransformerConfigurationException is thrown if this TransformerFactory or the Transformers or Templates it creates cannot support the feature. It is possible for an TransformerFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits and behave in a secure fashion as defined by the implementation. Examples include resolving user defined style sheets and functions. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorListener.fatalError(TransformerException exception). See setErrorListener(ErrorListener listener).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        参数：
        name - Feature name.
        value - Is feature state true or false.
        抛出：
        TransformerConfigurationException - if this TransformerFactory or the Transformers or Templates it creates cannot support this feature.
        NullPointerException - If the name parameter is null.

      • getFeature

        public abstract boolean getFeature(String name)
        Look up the value of a feature.

        Feature names are fully qualified URIs. Implementations may define their own features. false is returned if this TransformerFactory or the Transformers or Templates it creates cannot support the feature. It is possible for an TransformerFactory to expose a feature value but be unable to change its state.

        参数：
        name - Feature name.
        返回：
        The current state of the feature, true or false.
        抛出：
        NullPointerException - If the name parameter is null.

      • setAttribute

        public abstract void setAttribute(String name,
                Object value)
        Allows the user to set specific attributes on the underlying implementation. An attribute in this context is defined to be an option that the implementation provides. An IllegalArgumentException is thrown if the underlying implementation doesn't recognize the attribute.
        参数：
        name - The name of the attribute.
        value - The value of the attribute.
        抛出：
        IllegalArgumentException - When implementation does not recognize the attribute.

      • getAttribute

        public abstract Object getAttribute(String name)
        Allows the user to retrieve specific attributes on the underlying implementation. An IllegalArgumentException is thrown if the underlying implementation doesn't recognize the attribute.
        参数：
        name - The name of the attribute.
        返回：
        value The value of the attribute.
        抛出：
        IllegalArgumentException - When implementation does not recognize the attribute.

      • setErrorListener

        public abstract void setErrorListener(ErrorListener listener)
        Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself. An IllegalArgumentException is thrown if the ErrorListener listener is null.
        参数：
        listener - The new error listener.
        抛出：
        IllegalArgumentException - When listener is null

      • getErrorListener

        public abstract ErrorListener getErrorListener()
        Get the error event handler for the TransformerFactory.
        返回：
        The current error handler, which should never be null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c


TransformerFactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform

类 TransformerFactoryConfigurationError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Error
        • javax.xml.transform.TransformerFactoryConfigurationError
  • 所有已实现的接口：
    Serializable

    public class TransformerFactoryConfigurationError
extends Error
    Thrown when a problem with configuration with the Transformer Factories exists. This error will typically be thrown when the class of a transformation factory specified in the system properties cannot be found or instantiated.
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      TransformerFactoryConfigurationError()
      Create a new TransformerFactoryConfigurationError with no detail mesage.
      TransformerFactoryConfigurationError(Exception e)
      Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
      TransformerFactoryConfigurationError(Exception e, String msg)
      Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
      TransformerFactoryConfigurationError(String msg)
      Create a new TransformerFactoryConfigurationError with the String specified as an error message.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      use the exception chaining mechanism of JDK1.4
      Exception getException()
      Return the actual exception (if any) that caused this exception to be raised.
      String getMessage()
      Return the message (if any) for this error .

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError()
        Create a new TransformerFactoryConfigurationError with no detail mesage.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(String msg)
        Create a new TransformerFactoryConfigurationError with the String specified as an error message.
        参数：
        msg - The error message for the exception.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(Exception e)
        Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
        参数：
        e - The exception to be encapsulated in a TransformerFactoryConfigurationError.

      • TransformerFactoryConfigurationError

        public TransformerFactoryConfigurationError(Exception e,
                                    String msg)
        Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
        参数：
        e - The exception to be encapsulated in a TransformerFactoryConfigurationError
        msg - The detail message.

    • 方法详细信息

      • getMessage

        public String getMessage()
        Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception will be returned.
        重载：
        getMessage in class Throwable
        返回：
        The error message.

      • getException

        public Exception getException()
        Return the actual exception (if any) that caused this exception to be raised.
        返回：
        The encapsulated exception, or null if there is none.

      • getCause

        public Throwable getCause()
        use the exception chaining mechanism of JDK1.4
        重载：
        getCause in class Throwable
        返回：
        the cause of this throwable or null if the cause is nonexistent or unknown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sys>drserssLLsss"a== < yf


URIResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform

Interface URIResolver

  • public interface URIResolver

    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Source resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.

    • 方法详细信息

      • resolve

        Source resolve(String href,
             String base)
               throws TransformerException
        Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
        参数：
        href - An href attribute, which may be relative or absolute.
        base - The base URI against which the first argument will be made absolute if the absolute URI is required.
        返回：
        A Source object, or null if the href cannot be resolved, and the processor should try to resolve the URI itself.
        抛出：
        TransformerException - if an error occurs when trying to resolve the URI.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l- //rdtrdt>>dttvoffaegMt/ "<n


Uses of Package javax.xml.transform

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.transform

  • Packages that use javax.xml.transform
    软件包 描述
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.transform used by java.sql
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.annotation
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.helpers
    类与描述
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.bind.util
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.soap
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.stream
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.transform
    类与描述
    ErrorListener
    To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerException
    This class specifies an exceptional condition that occured during the transformation process.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
    TransformerFactoryConfigurationError
    Thrown when a problem with configuration with the Transformer Factories exists.
    URIResolver
    An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
  • Classes in javax.xml.transform used by javax.xml.transform.dom
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    SourceLocator
    This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
  • Classes in javax.xml.transform used by javax.xml.transform.sax
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
    Templates
    An object that implements this interface is the runtime representation of processed transformation instructions.
    Transformer
    An instance of this abstract class can transform a source tree into a result tree.
    TransformerConfigurationException
    Indicates a serious configuration error.
    TransformerFactory
    A TransformerFactory instance can be used to create Transformer and Templates objects.
  • Classes in javax.xml.transform used by javax.xml.transform.stax
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.transform.stream
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.validation
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws.spi
    类与描述
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • Classes in javax.xml.transform used by javax.xml.ws.wsaddressing
    类与描述
    Result
    An object that implements this interface contains the information needed to build a transformation result tree.
    Source
    An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�"ig.s叔


Uses of Class javax.xml.transform.OutputKeys

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.OutputKeys

No usage of javax.xml.transform.OutputKeys
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

th"std dt>>>>aooer"rr


Uses of Class javax.xml.transform.Transformer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.Transformer

  • Packages that use Transformer
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of Transformer in javax.xml.transform

      Methods in javax.xml.transform that return Transformer
      修饰符与类型 方法与描述
      abstract Transformer TransformerFactory.newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      Transformer Templates.newTransformer()
      Create a new transformation context for this Templates object.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.

    • Uses of Transformer in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return Transformer
      修饰符与类型 方法与描述
      Transformer TransformerHandler.getTransformer()
      Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ou/<>>>a/i


Uses of Class javax.xml.transform.TransformerConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.TransformerConfigurationException

  • Packages that use TransformerConfigurationException
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerConfigurationException in javax.xml.transform

      Methods in javax.xml.transform that throw TransformerConfigurationException
      修饰符与类型 方法与描述
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer TransformerFactory.newTransformer()
      Create a new Transformer that performs a copy of the Source to the Result.
      Transformer Templates.newTransformer()
      Create a new transformation context for this Templates object.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void TransformerFactory.setFeature(String name, boolean value)
      Set a feature for this TransformerFactory and Transformers or Templates created by this factory.

    • Uses of TransformerConfigurationException in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that throw TransformerConfigurationException
      修饰符与类型 方法与描述
      abstract TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

attc


Uses of Class javax.xml.transform.TransformerException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.TransformerException

  • Packages that use TransformerException
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of TransformerException in javax.xml.transform

      Subclasses of TransformerException in javax.xml.transform
      修饰符与类型 类与描述
      class  TransformerConfigurationException
      Indicates a serious configuration error.
      Methods in javax.xml.transform with parameters of type TransformerException
      修饰符与类型 方法与描述
      void ErrorListener.error(TransformerException exception)
      Receive notification of a recoverable error.
      void ErrorListener.fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      void ErrorListener.warning(TransformerException exception)
      Receive notification of a warning.
      Methods in javax.xml.transform that throw TransformerException
      修饰符与类型 方法与描述
      void ErrorListener.error(TransformerException exception)
      Receive notification of a recoverable error.
      void ErrorListener.fatalError(TransformerException exception)
      Receive notification of a non-recoverable error.
      Source URIResolver.resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.
      void ErrorListener.warning(TransformerException exception)
      Receive notification of a warning.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

asv.f=" ahhhge..ds>


Uses of Class javax.xml.transform.TransformerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.TransformerFactory

  • Packages that use TransformerFactory
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerFactory in javax.xml.transform

      Methods in javax.xml.transform that return TransformerFactory
      修饰符与类型 方法与描述
      static TransformerFactory TransformerFactory.newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.

    • Uses of TransformerFactory in javax.xml.transform.sax

      Subclasses of TransformerFactory in javax.xml.transform.sax
      修饰符与类型 类与描述
      class  SAXTransformerFactory
      This class extends TransformerFactory to provide SAX-specific factory methods.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> op;x&>nnn<"mmjfmjxnSr/.


Uses of Class javax.xml.transform.TransformerFactoryConfigurationError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.TransformerFactoryConfigurationError

  • Packages that use TransformerFactoryConfigurationError
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of TransformerFactoryConfigurationError in javax.xml.transform

      Methods in javax.xml.transform that throw TransformerFactoryConfigurationError
      修饰符与类型 方法与描述
      static TransformerFactory TransformerFactory.newInstance()
      Obtain a new instance of a TransformerFactory.
      static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a TransformerFactory from factory class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f


Uses of Interface javax.xml.transform.ErrorListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.ErrorListener

  • Packages that use ErrorListener
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of ErrorListener in javax.xml.transform

      Methods in javax.xml.transform that return ErrorListener
      修饰符与类型 方法与描述
      abstract ErrorListener TransformerFactory.getErrorListener()
      Get the error event handler for the TransformerFactory.
      abstract ErrorListener Transformer.getErrorListener()
      Get the error event handler in effect for the transformation.
      Methods in javax.xml.transform with parameters of type ErrorListener
      修饰符与类型 方法与描述
      abstract void TransformerFactory.setErrorListener(ErrorListener listener)
      Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.
      abstract void Transformer.setErrorListener(ErrorListener listener)
      Set the error event listener in effect for the transformation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sdEdpa mSbwa


Uses of Interface javax.xml.transform.Result

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.Result

  • Packages that use Result
    软件包 描述
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of Result in java.sql

      Methods in java.sql with type parameters of type Result
      修饰符与类型 方法与描述
      <T extends Result>
      T             		SQLXML.setResult(类<T> resultClass)
      Returns a Result for setting the XML value designated by this SQLXML instance.

    • Uses of Result in javax.xml.bind

      Methods in javax.xml.bind that return Result
      修饰符与类型 方法与描述
      abstract Result SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
      Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
      Methods in javax.xml.bind with parameters of type Result
      修饰符与类型 方法与描述
      void Marshaller.marshal(Object jaxbElement, Result result)
      Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
      static void JAXB.marshal(Object jaxbObject, Result xml)
      Writes a Java object tree to XML and store it to the specified location.

    • Uses of Result in javax.xml.bind.annotation

      Classes in javax.xml.bind.annotation with type parameters of type Result
      修饰符与类型 Interface and Description
      interface  DomHandler<ElementT,ResultT extends Result>
      Converts an element (and its descendants) from/to DOM (or similar) representation.

    • Uses of Result in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement Result
      修饰符与类型 类与描述
      class  JAXBResult
      JAXP Result implementation that unmarshals a JAXB object.

    • Uses of Result in javax.xml.soap

      Classes in javax.xml.soap that implement Result
      修饰符与类型 类与描述
      class  SAAJResult
      Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.

    • Uses of Result in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Result
      修饰符与类型 方法与描述
      abstract XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
      Create a new XMLEventWriter that writes to a JAXP result.
      abstract XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
      Create a new XMLStreamWriter that writes to a JAXP result.

    • Uses of Result in javax.xml.transform

      Methods in javax.xml.transform with parameters of type Result
      修饰符与类型 方法与描述
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

    • Uses of Result in javax.xml.transform.dom

      Classes in javax.xml.transform.dom that implement Result
      修饰符与类型 类与描述
      class  DOMResult
      Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.

    • Uses of Result in javax.xml.transform.sax

      Classes in javax.xml.transform.sax that implement Result
      修饰符与类型 类与描述
      class  SAXResult
      Acts as an holder for a transformation Result.
      Methods in javax.xml.transform.sax with parameters of type Result
      修饰符与类型 方法与描述
      void TransformerHandler.setResult(Result result)
      Set the Result associated with this TransformerHandler to be used for the transformation.

    • Uses of Result in javax.xml.transform.stax

      Classes in javax.xml.transform.stax that implement Result
      修饰符与类型 类与描述
      class  StAXResult
      Acts as a holder for an XML Result in the form of a StAX writer,i.e.

    • Uses of Result in javax.xml.transform.stream

      Classes in javax.xml.transform.stream that implement Result
      修饰符与类型 类与描述
      class  StreamResult
      Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

    • Uses of Result in javax.xml.validation

      Methods in javax.xml.validation with parameters of type Result
      修饰符与类型 方法与描述
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of Result in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Result
      修饰符与类型 方法与描述
      abstract void EndpointReference.writeTo(Result result)
      write this EndpointReference to the specified infoset format

    • Uses of Result in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type Result
      修饰符与类型 方法与描述
      void W3CEndpointReference.writeTo(Result result)
      write this EndpointReference to the specified infoset format
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u/ brsr


Uses of Interface javax.xml.transform.Source

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.Source

  • Packages that use Source
    软件包 描述
    java.sql
    Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.stream
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.transform.stax
    Provides for StAX-specific transformation APIs.
    javax.xml.transform.stream
    This package implements stream- and URI- specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of Source in java.sql

      Methods in java.sql with type parameters of type Source
      修饰符与类型 方法与描述
      <T extends Source>
      T             		SQLXML.getSource(类<T> sourceClass)
      Returns a Source for reading the XML value designated by this SQLXML instance.

    • Uses of Source in javax.xml.bind

      Methods in javax.xml.bind with parameters of type Source
      修饰符与类型 方法与描述
      Object Unmarshaller.unmarshal(Source source)
      Unmarshal XML data from the specified XML Source and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Source source, 类<T> declaredType)
      Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
      static <T> T JAXB.unmarshal(Source xml, 类<T> type)
      Reads in a Java object tree from the given XML input.

    • Uses of Source in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return Source
      修饰符与类型 | 方法与描述
      Source DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler)
      This method is called when a JAXB provider needs to marshal an element to XML.
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of Source in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type Source
      修饰符与类型 | 方法与描述
      Object | AbstractUnmarshallerImpl.unmarshal(Source source)
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Source source, 类<T> expectedType)

    • Uses of Source in javax.xml.bind.util

      Classes in javax.xml.bind.util that implement Source
      修饰符与类型 类与描述
      class  JAXBSource
      JAXP Source implementation that marshals a JAXB-generated object.

    • Uses of Source in javax.xml.soap

      Methods in javax.xml.soap that return Source
      修饰符与类型 方法与描述
      abstract Source SOAPPart.getContent()
      Returns the content of the SOAPEnvelope as a JAXP Source object.
      Methods in javax.xml.soap with parameters of type Source
      修饰符与类型 方法与描述
      abstract void SOAPPart.setContent(Source source)
      Sets the content of the SOAPEnvelope object with the data from the given Source object.

    • Uses of Source in javax.xml.stream

      Methods in javax.xml.stream with parameters of type Source
      修饰符与类型 方法与描述
      abstract XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
      Create a new XMLEventReader from a JAXP source.
      abstract XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
      Create a new XMLStreamReader from a JAXP source.

    • Uses of Source in javax.xml.transform

      Methods in javax.xml.transform that return Source
      修饰符与类型 方法与描述
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      Source URIResolver.resolve(String href, String base)
      Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
      Methods in javax.xml.transform with parameters of type Source
      修饰符与类型 方法与描述
      abstract Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
      Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.
      abstract Transformer TransformerFactory.newTransformer(Source source)
      Process the Source into a Transformer Object.
      abstract void Transformer.transform(Source xmlSource, Result outputTarget)
      Transform the XML Source to a Result.

    • Uses of Source in javax.xml.transform.dom

      Classes in javax.xml.transform.dom that implement Source
      修饰符与类型 类与描述
      class  DOMSource
      Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

    • Uses of Source in javax.xml.transform.sax

      Classes in javax.xml.transform.sax that implement Source
      修饰符与类型 类与描述
      class  SAXSource
      Acts as an holder for SAX-style Source.
      Methods in javax.xml.transform.sax with parameters of type Source
      修饰符与类型 方法与描述
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      static InputSource SAXSource.sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.

    • Uses of Source in javax.xml.transform.stax

      Classes in javax.xml.transform.stax that implement Source
      修饰符与类型 类与描述
      class  StAXSource
      Acts as a holder for an XML Source in the form of a StAX reader,i.e.

    • Uses of Source in javax.xml.transform.stream

      Classes in javax.xml.transform.stream that implement Source
      修饰符与类型 类与描述
      class  StreamSource
      Acts as an holder for a transformation Source in the form of a stream of XML markup.

    • Uses of Source in javax.xml.validation

      Methods in javax.xml.validation with parameters of type Source
      修饰符与类型 方法与描述
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      void Validator.validate(Source source)
      Validates the specified input.
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of Source in javax.xml.ws

      Methods in javax.xml.ws that return Source
      修饰符与类型 方法与描述
      Source LogicalMessage.getPayload()
      Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
      Methods in javax.xml.ws that return types with arguments of type Source
      修饰符与类型 方法与描述
      abstract List<Source> Endpoint.getMetadata()
      Returns a list of metadata documents for the service.
      Methods in javax.xml.ws with parameters of type Source
      修饰符与类型 方法与描述
      static EndpointReference EndpointReference.readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      void LogicalMessage.setPayload(Source payload)
      Sets the message payload
      Method parameters in javax.xml.ws with type arguments of type Source
      修饰符与类型 方法与描述
      abstract void Endpoint.setMetadata(List<Source> metadata)
      Sets the metadata for this endpoint.

    • Uses of Source in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Source
      修饰符与类型 方法与描述
      abstract EndpointReference Provider.readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.

    • Uses of Source in javax.xml.ws.wsaddressing

      Constructors in javax.xml.ws.wsaddressing with parameters of type Source
      构造方法与描述
      W3CEndpointReference(Source source)
      Creates an EPR from infoset representation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.xml.transform.SourceLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.SourceLocator

  • Packages that use SourceLocator
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.

    • Uses of SourceLocator in javax.xml.transform

      Methods in javax.xml.transform that return SourceLocator
      修饰符与类型 方法与描述
      SourceLocator TransformerException.getLocator()
      Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
      Methods in javax.xml.transform with parameters of type SourceLocator
      修饰符与类型 方法与描述
      void TransformerException.setLocator(SourceLocator location)
      Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.
      Constructors in javax.xml.transform with parameters of type SourceLocator
      构造方法与描述
      TransformerConfigurationException(String message, SourceLocator locator)
      Create a new TransformerConfigurationException from a message and a Locator.
      TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerConfigurationException.
      TransformerException(String message, SourceLocator locator)
      Create a new TransformerException from a message and a Locator.
      TransformerException(String message, SourceLocator locator, Throwable e)
      Wrap an existing exception in a TransformerException.

    • Uses of SourceLocator in javax.xml.transform.dom

      Subinterfaces of SourceLocator in javax.xml.transform.dom
      修饰符与类型 Interface and Description
      interface  DOMLocator
      Indicates the position of a node in a source DOM, intended primarily for error reporting.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oxm//....///f><


Uses of Interface javax.xml.transform.Templates

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.Templates

  • Packages that use Templates
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of Templates in javax.xml.transform

      Methods in javax.xml.transform that return Templates
      修饰符与类型 方法与描述
      abstract Templates TransformerFactory.newTemplates(Source source)
      Process the Source into a Templates object, which is a a compiled representation of the source.

    • Uses of Templates in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return Templates
      修饰符与类型 方法与描述
      Templates TemplatesHandler.getTemplates()
      When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
      Methods in javax.xml.transform.sax with parameters of type Templates
      修饰符与类型 方法与描述
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e"/nksno aimm= "tvaaN"


Uses of Interface javax.xml.transform.URIResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.URIResolver

  • Packages that use URIResolver
    软件包 描述
    javax.xml.transform
    This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

    • Uses of URIResolver in javax.xml.transform

      Methods in javax.xml.transform that return URIResolver
      修饰符与类型 方法与描述
      abstract URIResolver TransformerFactory.getURIResolver()
      Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      abstract URIResolver Transformer.getURIResolver()
      Get an object that will be used to resolve URIs used in document().
      Methods in javax.xml.transform with parameters of type URIResolver
      修饰符与类型 方法与描述
      abstract void TransformerFactory.setURIResolver(URIResolver resolver)
      Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
      abstract void Transformer.setURIResolver(URIResolver resolver)
      Set an object that will be used to resolve URIs used in document().
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e隺；ds>＃iＡy�=�,贼/ls


DOMLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform.dom

Interface DOMLocator

  • All Superinterfaces:
    SourceLocator

    public interface DOMLocator
extends SourceLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting. To use a DOMLocator, the receiver of an error must downcast the SourceLocator object returned by an exception. A Transformer may use this object for purposes other than error reporting, for instance, to indicate the source node that originated a result node.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getOriginatingNode()
      Return the node where the event occurred.

      • 方法 - 继承于接口 javax.xml.transform.SourceLocator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • 方法详细信息

      • getOriginatingNode

        Node getOriginatingNode()
        Return the node where the event occurred.
        返回：
        The node that is the location for the event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

moaa:neaEaj<


DOMResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.dom

类 DOMResult

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult
  • 所有已实现的接口：
    Result
    直接已知子类：
    SAAJResult

    public class DOMResult
extends Object
implements Result

    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.

    If no output DOM source is set, the transformation will create a Document node as the holder for the result of the transformation, which may be retrieved with getNode().

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMResult()
      Zero-argument default constructor.
      DOMResult(Node node)
      Use a DOM node to create a new output target.
      DOMResult(Node node, Node nextSibling)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
      DOMResult(Node node, Node nextSibling, String systemId)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
      DOMResult(Node node, String systemId)
      Use a DOM node to create a new output target with the specified System ID.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getNextSibling()
      Get the child node before which the result nodes will be inserted.
      Node getNode()
      Get the node that will contain the result DOM tree.
      String getSystemId()
      Get the System Identifier.
      void setNextSibling(Node nextSibling)
      Set the child node before which the result nodes will be inserted.
      void setNode(Node node)
      Set the node that will contain the result DOM tree.
      void setSystemId(String systemId)
      Set the systemId that may be used in association with the node.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE

        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DOMResult

        public DOMResult()

        Zero-argument default constructor.

        node, siblingNode and systemId will be set to null.

      • DOMResult

        public DOMResult(Node node)

        Use a DOM node to create a new output target.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        siblingNode and systemId will be set to null.

        参数：
        node - The DOM node that will contain the result tree.

      • DOMResult

        public DOMResult(Node node,
         String systemId)

        Use a DOM node to create a new output target with the specified System ID.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        siblingNode will be set to null.

        参数：
        node - The DOM node that will contain the result tree.
        systemId - The system identifier which may be used in association with this node.

      • DOMResult

        public DOMResult(Node node,
         Node nextSibling)

        Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.

        In practice, node and nextSibling should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        Use nextSibling to specify the child node where the result nodes should be inserted before. If nextSibling is not a sibling of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalArgumentException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node), i.e. append the result nodes as the last child of the specified node.

        systemId will be set to null.

        参数：
        node - The DOM node that will contain the result tree.
        nextSibling - The child node where the result nodes should be inserted before.
        抛出：
        IllegalArgumentException - If nextSibling is not a sibling of node or node is null and nextSibling is not null.
        从以下版本开始：
        1.5

      • DOMResult

        public DOMResult(Node node,
         Node nextSibling,
         String systemId)

        Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.

        In practice, node and nextSibling should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        Use nextSibling to specify the child node where the result nodes should be inserted before. If nextSibling is not a sibling of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalArgumentException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node, String systemId), i.e. append the result nodes as the last child of the specified node and use the specified System ID.

        参数：
        node - The DOM node that will contain the result tree.
        nextSibling - The child node where the result nodes should be inserted before.
        systemId - The system identifier which may be used in association with this node.
        抛出：
        IllegalArgumentException - If nextSibling is not a sibling of node or node is null and nextSibling is not null.
        从以下版本开始：
        1.5

    • 方法详细信息

      • setNode

        public void setNode(Node node)

        Set the node that will contain the result DOM tree.

        In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

        An IllegalStateException is thrown if nextSibling is not null and node is not a parent of nextSibling. An IllegalStateException is thrown if node is null and nextSibling is not null.

        参数：
        node - The node to which the transformation will be appended.
        抛出：
        IllegalStateException - If nextSibling is not null and nextSibling is not a child of node or node is null and nextSibling is not null.

      • getNode

        public Node getNode()

        Get the node that will contain the result DOM tree.

        If no node was set via DOMResult(Node node), DOMResult(Node node, String systeId), DOMResult(Node node, Node nextSibling), DOMResult(Node node, Node nextSibling, String systemId) or setNode(Node node), then the node will be set by the transformation, and may be obtained from this method once the transformation is complete. Calling this method before the transformation will return null.

        返回：
        The node to which the transformation will be appended.

      • setNextSibling

        public void setNextSibling(Node nextSibling)

        Set the child node before which the result nodes will be inserted.

        Use nextSibling to specify the child node before which the result nodes should be inserted. If nextSibling is not a descendant of node, then an IllegalArgumentException is thrown. If node is null and nextSibling is not null, then an IllegalStateException is thrown. If nextSibling is null, then the behavior is the same as calling DOMResult(Node node), i.e. append the result nodes as the last child of the specified node.

        参数：
        nextSibling - The child node before which the result nodes will be inserted.
        抛出：
        IllegalArgumentException - If nextSibling is not a descendant of node.
        IllegalStateException - If node is null and nextSibling is not null.
        从以下版本开始：
        1.5

      • getNextSibling

        public Node getNextSibling()

        Get the child node before which the result nodes will be inserted.

        If no node was set via DOMResult(Node node, Node nextSibling), DOMResult(Node node, Node nextSibling, String systemId) or setNextSibling(Node nextSibling), then null will be returned.

        返回：
        The child node before which the result nodes will be inserted.
        从以下版本开始：
        1.5

      • setSystemId

        public void setSystemId(String systemId)

        Set the systemId that may be used in association with the node.

        指定者：
        setSystemId in interface Result
        参数：
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()

        Get the System Identifier.

        If no System ID was set via DOMResult(Node node, String systemId), DOMResult(Node node, Node nextSibling, String systemId) or setSystemId(String systemId), then null will be returned.

        指定者：
        getSystemId in interface Result
        返回：
        The system identifier.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DOMSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.dom

类 DOMSource

  • java.lang.Object
    • javax.xml.transform.dom.DOMSource
  • 所有已实现的接口：
    Source

    public class DOMSource
extends Object
implements Source

    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

    Note that XSLT requires namespace support. Attempting to transform a DOM that was not contructed with a namespace-aware parser may result in errors. Parsers can be made namespace aware by calling DocumentBuilderFactory.setNamespaceAware(boolean awareness).

    另请参见：
    Document Object Model (DOM) Level 2 Specification

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMSource()
      Zero-argument default constructor.
      DOMSource(Node n)
      Create a new input source with a DOM node.
      DOMSource(Node node, String systemID)
      Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node getNode()
      Get the node that represents a Source DOM tree.
      String getSystemId()
      Get the base ID (URL or system ID) from where URLs will be resolved.
      void setNode(Node node)
      Set the node that will represents a Source DOM tree.
      void setSystemId(String systemID)
      Set the base ID (URL or system ID) from where URLs will be resolved.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DOMSource

        public DOMSource()

        Zero-argument default constructor. If this constructor is used, and no DOM source is set using setNode(Node node) , then the Transformer will create an empty source Document using DocumentBuilder.newDocument().

        另请参见：
        Transformer.transform(Source xmlSource, Result outputTarget)

      • DOMSource

        public DOMSource(Node n)
        Create a new input source with a DOM node. The operation will be applied to the subtree rooted at this node. In XSLT, a "/" pattern still means the root of the tree (not the subtree), and the evaluation of global variables and parameters is done from the root node also.
        参数：
        n - The DOM node that will contain the Source tree.

      • DOMSource

        public DOMSource(Node node,
         String systemID)
        Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
        参数：
        node - The DOM node that will contain the Source tree.
        systemID - Specifies the base URI associated with node.

    • 方法详细信息

      • setNode

        public void setNode(Node node)
        Set the node that will represents a Source DOM tree.
        参数：
        node - The node that is to be transformed.

      • getNode

        public Node getNode()
        Get the node that represents a Source DOM tree.
        返回：
        The node that is to be transformed.

      • setSystemId

        public void setSystemId(String systemID)
        Set the base ID (URL or system ID) from where URLs will be resolved.
        指定者：
        setSystemId in interface Source
        参数：
        systemID - Base URL for this DOM tree.

      • getSystemId

        public String getSystemId()
        Get the base ID (URL or system ID) from where URLs will be resolved.
        指定者：
        getSystemId in interface Source
        返回：
        Base URL for this DOM tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.a< -! -!<--!<>aet3(cstlNRna/.


javax.xml.transform.dom

Interfaces

  • DOMLocator

Classes

  • DOMResult
  • DOMSource


javax.xml.transform.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.transform.dom

This package implements DOM-specific transformation APIs.

请参见： 描述

  • 接口摘要
    接口 描述
    DOMLocator
    Indicates the position of a node in a source DOM, intended primarily for error reporting.
  • Class Summary
    类 描述
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
    DOMSource
    Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

软件包 javax.xml.transform.dom Description

This package implements DOM-specific transformation APIs.

The DOMSource class allows the client of the implementation of this API to specify a DOM Node as the source of the input tree. The model of how the Transformer deals with the DOM tree in terms of mismatches with the XSLT data model or other data models is beyond the scope of this document. Any of the nodes derived from Node are legal input.

The DOMResult class allows a Node to be specified to which result DOM nodes will be appended. If an output node is not specified, the transformer will use DocumentBuilder.newDocument() to create an output Document node. If a node is specified, it should be one of the following: Document, Element, or DocumentFragment. Specification of any other node type is implementation dependent and undefined by this API. If the result is a Document, the output of the transformation must have a single element root to set as the document element.

The DOMLocator node may be passed to TransformerException objects, and retrieved by trying to cast the result of the TransformerException.getLocator() method. The implementation has no responsibility to use a DOMLocator instead of a SourceLocator (though line numbers and the like do not make much sense for a DOM), so the result of getLocator must always be tested with an instanceof.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aajsa/=..=f"..= >>fleq.


javax.xml.transform.dom Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.transform.dom

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)

Interface Hierarchy

  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orm f etrrr""EEr uu/"


Uses of Package javax.xml.transform.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.transform.dom

  • Packages that use javax.xml.transform.dom
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
  • Classes in javax.xml.transform.dom used by javax.xml.bind.annotation
    类与描述
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
  • Classes in javax.xml.transform.dom used by javax.xml.soap
    类与描述
    DOMResult
    Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/mcU/i.icccmoeh ..orm


Uses of Class javax.xml.transform.dom.DOMResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.dom.DOMResult

  • Packages that use DOMResult
    软件包 描述
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.

    • Uses of DOMResult in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return DOMResult
      修饰符与类型 | 方法与描述
      DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
      Methods in javax.xml.bind.annotation with parameters of type DOMResult
      修饰符与类型 | 方法与描述
      Element | W3CDomHandler.getElement(DOMResult r)

    • Uses of DOMResult in javax.xml.soap

      Subclasses of DOMResult in javax.xml.soap
      修饰符与类型 类与描述
      class  SAAJResult
      Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s.eTi


Uses of Class javax.xml.transform.dom.DOMSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.dom.DOMSource

No usage of javax.xml.transform.dom.DOMSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a&&&rnaavdetl


Uses of Interface javax.xml.transform.dom.DOMLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.dom.DOMLocator

No usage of javax.xml.transform.dom.DOMLocator
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tev> et_.m舤


javax.xml.transform.sax

Interfaces

  • TemplatesHandler
  • TransformerHandler

Classes

  • SAXResult
  • SAXSource
  • SAXTransformerFactory


javax.xml.transform.sax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.transform.sax

This package implements SAX2-specific transformation APIs.

请参见： 描述

  • 接口摘要
    接口 描述
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
  • Class Summary
    类 描述
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
    SAXTransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods.

软件包 javax.xml.transform.sax Description

This package implements SAX2-specific transformation APIs. It provides classes which allow input from ContentHandler events, and also classes that produce org.xml.sax.ContentHandler events. It also provides methods to set the input source as an XMLReader, or to use a InputSource as the source. It also allows the creation of a XMLFilter, which enables transformations to "pull" from other transformations, and lets the transformer to be used polymorphically as an XMLReader.

The SAXSource class allows the setting of an XMLReader to be used for "pulling" parse events, and an InputSource that may be used to specify the SAX source.

The SAXResult class allows the setting of a ContentHandler to be the receiver of SAX2 events from the transformation.

The SAXTransformerFactory extends TransformerFactory to provide factory methods for creating TemplatesHandler, TransformerHandler, and XMLReader instances.

To obtain a SAXTransformerFactory, the caller must cast the TransformerFactory instance returned from TransformerFactory.newInstance().

The TransformerHandler interface allows a transformation to be created from SAX2 parse events, which is a "push" model rather than the "pull" model that normally occurs for a transformation. Normal parse events are received through the ContentHandler interface, lexical events such as startCDATA and endCDATA are received through the LexicalHandler interface, and events that signal the start or end of disabling output escaping are received via ContentHandler.processingInstruction(java.lang.String, java.lang.String), with the target parameter being Result.PI_DISABLE_OUTPUT_ESCAPING and Result.PI_ENABLE_OUTPUT_ESCAPING. If parameters, output properties, or other features need to be set on the Transformer handler, a Transformer reference will need to be obtained from TransformerHandler.getTransformer(), and the methods invoked from that reference.

The TemplatesHandler interface allows the creation of Templates objects from SAX2 parse events. Once the ContentHandler events are complete, the Templates object may be obtained from TemplatesHandler.getTemplates(). Note that TemplatesHandler.setSystemId(java.lang.String) should normally be called in order to establish a base system ID from which relative URLs may be resolved.

The SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) method allows the creation of a XMLFilter, which encapsulates the SAX2 notion of a "pull" transformation. The following illustrates several transformations chained together. Each filter points to a parent XMLReader, and the final transformation is caused by invoking XMLReader.parse(org.xml.sax.InputSource) on the final reader in the chain.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/nr邪)iN /.a=>


javax.xml.transform.sax Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.transform.sax

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mv.la. njjjeitt<>//xi


SAXResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.sax

类 SAXResult

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult
  • 所有已实现的接口：
    Result
    直接已知子类：
    JAXBResult

    public class SAXResult
extends Object
implements Result

    Acts as an holder for a transformation Result.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXResult()
      Zero-argument default constructor.
      SAXResult(ContentHandler handler)
      Create a SAXResult that targets a SAX2 ContentHandler.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ContentHandler getHandler()
      Get the ContentHandler that is the Result.
      LexicalHandler getLexicalHandler()
      Get a SAX2 LexicalHandler for the output.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setHandler(ContentHandler handler)
      Set the target to be a SAX2 ContentHandler.
      void setLexicalHandler(LexicalHandler handler)
      Set the SAX2 LexicalHandler for the output.
      void setSystemId(String systemId)
      Method setSystemId Set the systemID that may be used in association with the ContentHandler.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SAXResult

        public SAXResult()
        Zero-argument default constructor.

      • SAXResult

        public SAXResult(ContentHandler handler)
        Create a SAXResult that targets a SAX2 ContentHandler.
        参数：
        handler - Must be a non-null ContentHandler reference.

    • 方法详细信息

      • setHandler

        public void setHandler(ContentHandler handler)
        Set the target to be a SAX2 ContentHandler.
        参数：
        handler - Must be a non-null ContentHandler reference.

      • getHandler

        public ContentHandler getHandler()
        Get the ContentHandler that is the Result.
        返回：
        The ContentHandler that is to be transformation output.

      • setLexicalHandler

        public void setLexicalHandler(LexicalHandler handler)
        Set the SAX2 LexicalHandler for the output.

        This is needed to handle XML comments and the like. If the lexical handler is not set, an attempt should be made by the transformer to cast the ContentHandler to a LexicalHandler.

        参数：
        handler - A non-null LexicalHandler for handling lexical parse events.

      • getLexicalHandler

        public LexicalHandler getLexicalHandler()
        Get a SAX2 LexicalHandler for the output.
        返回：
        A LexicalHandler, or null.

      • setSystemId

        public void setSystemId(String systemId)
        Method setSystemId Set the systemID that may be used in association with the ContentHandler.
        指定者：
        setSystemId in interface Result
        参数：
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        指定者：
        getSystemId in interface Result
        返回：
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

loit au " dl>aagl�>"ela"r�/1d"rL


SAXSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.sax

类 SAXSource

  • java.lang.Object
    • javax.xml.transform.sax.SAXSource
  • 所有已实现的接口：
    Source
    直接已知子类：
    JAXBSource

    public class SAXSource
extends Object
implements Source

    Acts as an holder for SAX-style Source.

    Note that XSLT requires namespace support. Attempting to transform an input source that is not generated with a namespace-aware parser may result in errors. Parsers can be made namespace aware by calling the SAXParserFactory.setNamespaceAware(boolean awareness) method.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXSource()
      Zero-argument default constructor.
      SAXSource(InputSource inputSource)
      Create a SAXSource, using a SAX InputSource.
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InputSource getInputSource()
      Get the SAX InputSource to be used for the Source.
      String getSystemId()
      Get the base ID (URI or system ID) from where URIs will be resolved.
      XMLReader getXMLReader()
      Get the XMLReader to be used for the Source.
      void setInputSource(InputSource inputSource)
      Set the SAX InputSource to be used for the Source.
      void setSystemId(String systemId)
      Set the system identifier for this Source.
      void setXMLReader(XMLReader reader)
      Set the XMLReader to be used for the Source.
      static InputSource sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SAXSource

        public SAXSource()

        Zero-argument default constructor. If this constructor is used, and no SAX source is set using setInputSource(InputSource inputSource) , then the Transformer will create an empty source InputSource using new InputSource().

        另请参见：
        Transformer.transform(Source xmlSource, Result outputTarget)

      • SAXSource

        public SAXSource(XMLReader reader,
         InputSource inputSource)
        Create a SAXSource, using an XMLReader and a SAX InputSource. The Transformer or SAXTransformerFactory will set itself to be the reader's ContentHandler, and then will call reader.parse(inputSource).
        参数：
        reader - An XMLReader to be used for the parse.
        inputSource - A SAX input source reference that must be non-null and that will be passed to the reader parse method.

      • SAXSource

        public SAXSource(InputSource inputSource)
        Create a SAXSource, using a SAX InputSource. The Transformer or SAXTransformerFactory creates a reader via XMLReaderFactory (if setXMLReader is not used), sets itself as the reader's ContentHandler, and calls reader.parse(inputSource).
        参数：
        inputSource - An input source reference that must be non-null and that will be passed to the parse method of the reader.

    • 方法详细信息

      • setXMLReader

        public void setXMLReader(XMLReader reader)
        Set the XMLReader to be used for the Source.
        参数：
        reader - A valid XMLReader or XMLFilter reference.

      • getXMLReader

        public XMLReader getXMLReader()
        Get the XMLReader to be used for the Source.
        返回：
        A valid XMLReader or XMLFilter reference, or null.

      • setInputSource

        public void setInputSource(InputSource inputSource)
        Set the SAX InputSource to be used for the Source.
        参数：
        inputSource - A valid InputSource reference.

      • getInputSource

        public InputSource getInputSource()
        Get the SAX InputSource to be used for the Source.
        返回：
        A valid InputSource reference, or null.

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this Source. If an input source has already been set, it will set the system ID or that input source, otherwise it will create a new input source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if no byte stream or character stream is specified).

        指定者：
        setSystemId in interface Source
        参数：
        systemId - The system identifier as a URI string.

      • getSystemId

        public String getSystemId()

        Get the base ID (URI or system ID) from where URIs will be resolved.

        指定者：
        getSystemId in interface Source
        返回：
        Base URL for the Source, or null.

      • sourceToInputSource

        public static InputSource sourceToInputSource(Source source)
        Attempt to obtain a SAX InputSource object from a Source object.
        参数：
        source - Must be a non-null Source reference.
        返回：
        An InputSource, or null if Source can not be converted.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gilys">-tofea fcm<.1toedlrs


SAXTransformerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.sax

类 SAXTransformerFactory

  • java.lang.Object
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory

  • public abstract class SAXTransformerFactory
extends TransformerFactory
    This class extends TransformerFactory to provide SAX-specific factory methods. It provides two types of ContentHandlers, one for creating Transformers, the other for creating Templates objects.

    If an application wants to set the ErrorHandler or EntityResolver for an XMLReader used during a transformation, it should use a URIResolver to return the SAXSource which provides (with getXMLReader) a reference to the XMLReader.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
      static String FEATURE_XMLFILTER
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SAXTransformerFactory()
      The default constructor is protected on purpose.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract TemplatesHandler newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
      abstract TransformerHandler newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
      abstract XMLFilter newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..

      • 方法 - 继承于类 javax.xml.transform.TransformerFactory

        getAssociatedStylesheet, getAttribute, getErrorListener, getFeature, getURIResolver, newInstance, newInstance, newTemplates, newTransformer, newTransformer, setAttribute, setErrorListener, setFeature, setURIResolver

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
        另请参见：
        Constant Field Values

      • FEATURE_XMLFILTER

        public static final String FEATURE_XMLFILTER
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • SAXTransformerFactory

        protected SAXTransformerFactory()
        The default constructor is protected on purpose.

    • 方法详细信息

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler(Source src)
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
        参数：
        src - The Source of the transformation instructions.
        返回：
        TransformerHandler ready to transform SAX events.
        抛出：
        TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler(Templates templates)
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
        参数：
        templates - The compiled transformation instructions.
        返回：
        TransformerHandler ready to transform SAX events.
        抛出：
        TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

      • newTransformerHandler

        public abstract TransformerHandler newTransformerHandler()
                                                  throws TransformerConfigurationException
        Get a TransformerHandler object that can process SAX ContentHandler events into a Result. The transformation is defined as an identity (or copy) transformation, for example to copy a series of SAX parse events into a DOM tree.
        返回：
        A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
        抛出：
        TransformerConfigurationException - If for some reason the TransformerHandler cannot be created.

      • newTemplatesHandler

        public abstract TemplatesHandler newTemplatesHandler()
                                              throws TransformerConfigurationException
        Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
        返回：
        A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
        抛出：
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

      • newXMLFilter

        public abstract XMLFilter newXMLFilter(Source src)
                                throws TransformerConfigurationException
        Create an XMLFilter that uses the given Source as the transformation instructions.
        参数：
        src - The Source of the transformation instructions.
        返回：
        An XMLFilter object, or null if this feature is not supported.
        抛出：
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

      • newXMLFilter

        public abstract XMLFilter newXMLFilter(Templates templates)
                                throws TransformerConfigurationException
        Create an XMLFilter, based on the Templates argument..
        参数：
        templates - The compiled transformation instructions.
        返回：
        An XMLFilter object, or null if this feature is not supported.
        抛出：
        TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..netrnenartsw"eje/vx�


TemplatesHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform.sax

Interface TemplatesHandler

  • All Superinterfaces:
    ContentHandler

    public interface TemplatesHandler
extends ContentHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.

    Note that TemplatesHandler does not need to implement LexicalHandler.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      Get the base ID (URI or system ID) from where relative URLs will be resolved.
      Templates getTemplates()
      When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
      void setSystemId(String systemID)
      Set the base ID (URI or system ID) for the Templates object created by this builder.

      • 方法 - 继承于接口 org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • 方法详细信息

      • getTemplates

        Templates getTemplates()
        When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
        返回：
        The Templates object that was created during the SAX event process, or null if no Templates object has been created.

      • setSystemId

        void setSystemId(String systemID)
        Set the base ID (URI or system ID) for the Templates object created by this builder. This must be set in order to resolve relative URIs in the stylesheet. This must be called before the startDocument event.
        参数：
        systemID - Base URI for this stylesheet.

      • getSystemId

        String getSystemId()
        Get the base ID (URI or system ID) from where relative URLs will be resolved.
        返回：
        The systemID that was set with setSystemId(java.lang.String).
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/..r,<< <.sFTToof"


TransformerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.transform.sax

Interface TransformerHandler

  • All Superinterfaces:
    ContentHandler, DTDHandler, LexicalHandler

    public interface TransformerHandler
extends ContentHandler, LexicalHandler, DTDHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      Get the base ID (URI or system ID) from where relative URLs will be resolved.
      Transformer getTransformer()
      Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
      void setResult(Result result)
      Set the Result associated with this TransformerHandler to be used for the transformation.
      void setSystemId(String systemID)
      Set the base ID (URI or system ID) from where relative URLs will be resolved.

      • 方法 - 继承于接口 org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

      • 方法 - 继承于接口 org.xml.sax.ext.LexicalHandler

        comment, endCDATA, endDTD, endEntity, startCDATA, startDTD, startEntity

      • 方法 - 继承于接口 org.xml.sax.DTDHandler

        notationDecl, unparsedEntityDecl

    • 方法详细信息

      • setResult

        void setResult(Result result)
               throws IllegalArgumentException

        Set the Result associated with this TransformerHandler to be used for the transformation.

        参数：
        result - A Result instance, should not be null.
        抛出：
        IllegalArgumentException - if result is invalid for some reason.

      • setSystemId

        void setSystemId(String systemID)
        Set the base ID (URI or system ID) from where relative URLs will be resolved.
        参数：
        systemID - Base URI for the source tree.

      • getSystemId

        String getSystemId()
        Get the base ID (URI or system ID) from where relative URLs will be resolved.
        返回：
        The systemID that was set with setSystemId(java.lang.String).

      • getTransformer

        Transformer getTransformer()

        Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.

        返回：
        Transformer associated with this TransformerHandler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xam//.p..=f""=ffacvvl/.ejg"gll aahT


Uses of Package javax.xml.transform.sax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.transform.sax

  • Packages that use javax.xml.transform.sax
    软件包 描述
    javax.xml.bind.util
    Useful client utility classes.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
  • Classes in javax.xml.transform.sax used by javax.xml.bind.util
    类与描述
    SAXResult
    Acts as an holder for a transformation Result.
    SAXSource
    Acts as an holder for SAX-style Source.
  • Classes in javax.xml.transform.sax used by javax.xml.transform.sax
    类与描述
    TemplatesHandler
    A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
    TransformerHandler
    A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alvsan"n m=kmvss b"""nal


Uses of Class javax.xml.transform.sax.SAXResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.sax.SAXResult

  • Packages that use SAXResult
    软件包 描述
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of SAXResult in javax.xml.bind.util

      Subclasses of SAXResult in javax.xml.bind.util
      修饰符与类型 类与描述
      class  JAXBResult
      JAXP Result implementation that unmarshals a JAXB object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>tn� bla."


Uses of Class javax.xml.transform.sax.SAXSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.sax.SAXSource

  • Packages that use SAXSource
    软件包 描述
    javax.xml.bind.util
    Useful client utility classes.

    • Uses of SAXSource in javax.xml.bind.util

      Subclasses of SAXSource in javax.xml.bind.util
      修饰符与类型 类与描述
      class  JAXBSource
      JAXP Source implementation that marshals a JAXB-generated object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

 yXwP蹯ad slc�<"x]>


Uses of Class javax.xml.transform.sax.SAXTransformerFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.sax.SAXTransformerFactory

No usage of javax.xml.transform.sax.SAXTransformerFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l=asforrtaaam ll


Uses of Interface javax.xml.transform.sax.TemplatesHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.sax.TemplatesHandler

  • Packages that use TemplatesHandler
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TemplatesHandler in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return TemplatesHandler
      修饰符与类型 方法与描述
      abstract TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
      Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ fd /.nw/衧 rXvll


Uses of Interface javax.xml.transform.sax.TransformerHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.transform.sax.TransformerHandler

  • Packages that use TransformerHandler
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.

    • Uses of TransformerHandler in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return TransformerHandler
      修饰符与类型 方法与描述
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler()
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Source src)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
      abstract TransformerHandler SAXTransformerFactory.newTransformerHandler(Templates templates)
      Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o.i>F&ticct=rs� e<-o"a


javax.xml.transform.stax

Classes

  • StAXResult
  • StAXSource


javax.xml.transform.stax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.transform.stax

Provides for StAX-specific transformation APIs.

请参见： 描述

  • Class Summary
    类 描述
    StAXResult
    Acts as a holder for an XML Result in the form of a StAX writer,i.e.
    StAXSource
    Acts as a holder for an XML Source in the form of a StAX reader,i.e.

软件包 javax.xml.transform.stax Description

Provides for StAX-specific transformation APIs. TODO: better description(s).

Package Specification

  • JSR 173: Streaming API for XML

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:

  • TODO: Refer to non-spec documentation
  • @see XMLStreamReader
  • @see XMLEventReader

从以下版本开始：
1.6

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htnimeuneo>rgsllt=


javax.xml.transform.stax Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.transform.stax

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


StAXResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.stax

类 StAXResult

  • java.lang.Object
    • javax.xml.transform.stax.StAXResult
  • 所有已实现的接口：
    Result

    public class StAXResult
extends Object
implements Result

    Acts as a holder for an XML Result in the form of a StAX writer,i.e. XMLStreamWriter or XMLEventWriter. StAXResult can be used in all cases that accept a Result, e.g. Transformer, Validator which accept Result as input.

    从以下版本开始：
    1.6
    另请参见：
    JSR 173: Streaming API for XML, XMLStreamWriter, XMLEventWriter

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      StAXResult(XMLEventWriter xmlEventWriter)
      Creates a new instance of a StAXResult by supplying an XMLEventWriter.
      StAXResult(XMLStreamWriter xmlStreamWriter)
      Creates a new instance of a StAXResult by supplying an XMLStreamWriter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      The returned system identifier is always null.
      XMLEventWriter getXMLEventWriter()
      Get the XMLEventWriter used by this StAXResult.
      XMLStreamWriter getXMLStreamWriter()
      Get the XMLStreamWriter used by this StAXResult.
      void setSystemId(String systemId)
      In the context of a StAXResult, it is not appropriate to explicitly set the system identifier.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StAXResult

        public StAXResult(XMLEventWriter xmlEventWriter)

        Creates a new instance of a StAXResult by supplying an XMLEventWriter.

        XMLEventWriter must be a non-null reference.

        参数：
        xmlEventWriter - XMLEventWriter used to create this StAXResult.
        抛出：
        IllegalArgumentException - If xmlEventWriter == null.

      • StAXResult

        public StAXResult(XMLStreamWriter xmlStreamWriter)

        Creates a new instance of a StAXResult by supplying an XMLStreamWriter.

        XMLStreamWriter must be a non-null reference.

        参数：
        xmlStreamWriter - XMLStreamWriter used to create this StAXResult.
        抛出：
        IllegalArgumentException - If xmlStreamWriter == null.

    • 方法详细信息

      • getXMLEventWriter

        public XMLEventWriter getXMLEventWriter()

        Get the XMLEventWriter used by this StAXResult.

        XMLEventWriter will be null if this StAXResult was created with a XMLStreamWriter.

        返回：
        XMLEventWriter used by this StAXResult.

      • getXMLStreamWriter

        public XMLStreamWriter getXMLStreamWriter()

        Get the XMLStreamWriter used by this StAXResult.

        XMLStreamWriter will be null if this StAXResult was created with a XMLEventWriter.

        返回：
        XMLStreamWriter used by this StAXResult.

      • setSystemId

        public void setSystemId(String systemId)

        In the context of a StAXResult, it is not appropriate to explicitly set the system identifier. The XMLEventWriter or XMLStreamWriter used to construct this StAXResult determines the system identifier of the XML result.

        An UnsupportedOperationException is always thrown by this method.

        指定者：
        setSystemId in interface Result
        参数：
        systemId - Ignored.
        抛出：
        UnsupportedOperationException - Is always thrown by this method.

      • getSystemId

        public String getSystemId()

        The returned system identifier is always null.

        指定者：
        getSystemId in interface Result
        返回：
        The returned system identifier is always null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s


StAXSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.stax

类 StAXSource

  • java.lang.Object
    • javax.xml.transform.stax.StAXSource
  • 所有已实现的接口：
    Source

    public class StAXSource
extends Object
implements Source

    Acts as a holder for an XML Source in the form of a StAX reader,i.e. XMLStreamReader or XMLEventReader. StAXSource can be used in all cases that accept a Source, e.g. Transformer, Validator which accept Source as input.

    StAXSources are consumed during processing and are not reusable.

    从以下版本开始：
    1.6
    另请参见：
    JSR 173: Streaming API for XML, XMLStreamReader, XMLEventReader

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StAXSource(XMLEventReader xmlEventReader)
      Creates a new instance of a StAXSource by supplying an XMLEventReader.
      StAXSource(XMLStreamReader xmlStreamReader)
      Creates a new instance of a StAXSource by supplying an XMLStreamReader.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getSystemId()
      Get the system identifier used by this StAXSource.
      XMLEventReader getXMLEventReader()
      Get the XMLEventReader used by this StAXSource.
      XMLStreamReader getXMLStreamReader()
      Get the XMLStreamReader used by this StAXSource.
      void setSystemId(String systemId)
      In the context of a StAXSource, it is not appropriate to explicitly set the system identifier.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StAXSource

        public StAXSource(XMLEventReader xmlEventReader)
           throws XMLStreamException

        Creates a new instance of a StAXSource by supplying an XMLEventReader.

        XMLEventReader must be a non-null reference.

        XMLEventReader must be in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

        参数：
        xmlEventReader - XMLEventReader used to create this StAXSource.
        抛出：
        XMLStreamException - If xmlEventReader access throws an Exception.
        IllegalArgumentException - If xmlEventReader == null.
        IllegalStateException - If xmlEventReader is not in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

      • StAXSource

        public StAXSource(XMLStreamReader xmlStreamReader)

        Creates a new instance of a StAXSource by supplying an XMLStreamReader.

        XMLStreamReader must be a non-null reference.

        XMLStreamReader must be in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

        参数：
        xmlStreamReader - XMLStreamReader used to create this StAXSource.
        抛出：
        IllegalArgumentException - If xmlStreamReader == null.
        IllegalStateException - If xmlStreamReader is not in XMLStreamConstants.START_DOCUMENT or XMLStreamConstants.START_ELEMENT state.

    • 方法详细信息

      • getXMLEventReader

        public XMLEventReader getXMLEventReader()

        Get the XMLEventReader used by this StAXSource.

        XMLEventReader will be null. if this StAXSource was created with a XMLStreamReader.

        返回：
        XMLEventReader used by this StAXSource.

      • getXMLStreamReader

        public XMLStreamReader getXMLStreamReader()

        Get the XMLStreamReader used by this StAXSource.

        XMLStreamReader will be null if this StAXSource was created with a XMLEventReader.

        返回：
        XMLStreamReader used by this StAXSource.

      • setSystemId

        public void setSystemId(String systemId)

        In the context of a StAXSource, it is not appropriate to explicitly set the system identifier. The XMLStreamReader or XMLEventReader used to construct this StAXSource determines the system identifier of the XML source.

        An UnsupportedOperationException is always thrown by this method.

        指定者：
        setSystemId in interface Source
        参数：
        systemId - Ignored.
        抛出：
        UnsupportedOperationException - Is always thrown by this method.

      • getSystemId

        public String getSystemId()

        Get the system identifier used by this StAXSource.

        The XMLStreamReader or XMLEventReader used to construct this StAXSource is queried to determine the system identifier of the XML source.

        The system identifier may be null or an empty "" String.

        指定者：
        getSystemId in interface Source
        返回：
        System identifier used by this StAXSource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"wl.d -./<=i.iLl snDgrBsl"a/iri=u竘n &


Uses of Package javax.xml.transform.stax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.transform.stax

No usage of javax.xml.transform.stax
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

maeNt_>_"o""" ee/ttsl


Uses of Class javax.xml.transform.stax.StAXResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.stax.StAXResult

No usage of javax.xml.transform.stax.StAXResult
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>acislrF


Uses of Class javax.xml.transform.stax.StAXSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.stax.StAXSource

No usage of javax.xml.transform.stax.StAXSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/x(Pi鋖a <


javax.xml.transform.stream

Classes

  • StreamResult
  • StreamSource


javax.xml.transform.stream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.transform.stream

This package implements stream- and URI- specific transformation APIs.

请参见： 描述

  • Class Summary
    类 描述
    StreamResult
    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.
    StreamSource
    Acts as an holder for a transformation Source in the form of a stream of XML markup.

软件包 javax.xml.transform.stream Description

This package implements stream- and URI- specific transformation APIs.

The StreamSource class provides methods for specifying InputStream input, Reader input, and URL input in the form of strings. Even if an input stream or reader is specified as the source, StreamSource.setSystemId(java.lang.String) should still be called, so that the transformer can know from where it should resolve relative URIs. The public identifier is always optional: if the application writer includes one, it will be provided as part of the SourceLocator information.

The StreamResult class provides methods for specifying OutputStream, Writer, or an output system ID, as the output of the transformation result.

Normally streams should be used rather than readers or writers, for both the Source and Result, since readers and writers already have the encoding established to and from the internal Unicode format. However, there are times when it is useful to write to a character stream, such as when using a StringWriter in order to write to a String, or in the case of reading source XML from a StringReader.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iTp<"r>/tml


javax.xml.transform.stream Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.transform.stream

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

H oe canllltmdd s ass


StreamResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.stream

类 StreamResult

  • java.lang.Object
    • javax.xml.transform.stream.StreamResult
  • 所有已实现的接口：
    Result

    public class StreamResult
extends Object
implements Result

    Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

      • 字段 - 继承于接口 javax.xml.transform.Result

        PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING

    • 构造方法摘要

      Constructors
      构造方法与描述
      StreamResult()
      Zero-argument default constructor.
      StreamResult(File f)
      Construct a StreamResult from a File.
      StreamResult(OutputStream outputStream)
      Construct a StreamResult from a byte stream.
      StreamResult(String systemId)
      Construct a StreamResult from a URL.
      StreamResult(Writer writer)
      Construct a StreamResult from a character stream.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      OutputStream getOutputStream()
      Get the byte stream that was set with setOutputStream.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      Writer getWriter()
      Get the character stream that was set with setWriter.
      void setOutputStream(OutputStream outputStream)
      Set the ByteStream that is to be written to.
      void setSystemId(File f)
      Set the system ID from a File reference.
      void setSystemId(String systemId)
      Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).
      void setWriter(Writer writer)
      Set the writer that is to receive the result.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StreamResult

        public StreamResult()
        Zero-argument default constructor.

      • StreamResult

        public StreamResult(OutputStream outputStream)
        Construct a StreamResult from a byte stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.
        参数：
        outputStream - A valid OutputStream reference.

      • StreamResult

        public StreamResult(Writer writer)
        Construct a StreamResult from a character stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a character stream, such as when using a StringWriter.
        参数：
        writer - A valid Writer reference.

      • StreamResult

        public StreamResult(String systemId)
        Construct a StreamResult from a URL.
        参数：
        systemId - Must be a String that conforms to the URI syntax.

      • StreamResult

        public StreamResult(File f)
        Construct a StreamResult from a File.
        参数：
        f - Must a non-null File reference.

    • 方法详细信息

      • setOutputStream

        public void setOutputStream(OutputStream outputStream)
        Set the ByteStream that is to be written to. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.
        参数：
        outputStream - A valid OutputStream reference.

      • getOutputStream

        public OutputStream getOutputStream()
        Get the byte stream that was set with setOutputStream.
        返回：
        The byte stream that was set with setOutputStream, or null if setOutputStream or the ByteStream constructor was not called.

      • setWriter

        public void setWriter(Writer writer)
        Set the writer that is to receive the result. Normally, a stream should be used rather than a writer, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a writer, such as when using a StringWriter.
        参数：
        writer - A valid Writer reference.

      • getWriter

        public Writer getWriter()
        Get the character stream that was set with setWriter.
        返回：
        The character stream that was set with setWriter, or null if setWriter or the Writer constructor was not called.

      • setSystemId

        public void setSystemId(String systemId)
        Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).
        指定者：
        setSystemId in interface Result
        参数：
        systemId - The system identifier as a URI string.

      • setSystemId

        public void setSystemId(File f)

        Set the system ID from a File reference.

        参数：
        f - Must a non-null File reference.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        指定者：
        getSystemId in interface Result
        返回：
        The system identifier that was set with setSystemId, or null if setSystemId was not called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lettn>i:rsc>nlpnxlL i/s;smcl


StreamSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.transform.stream

类 StreamSource

  • java.lang.Object
    • javax.xml.transform.stream.StreamSource
  • 所有已实现的接口：
    Source

    public class StreamSource
extends Object
implements Source

    Acts as an holder for a transformation Source in the form of a stream of XML markup.

    Note: Due to their internal use of either a Reader or InputStream instance, StreamSource instances may only be used once.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String FEATURE
      If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StreamSource()
      Zero-argument default constructor.
      StreamSource(File f)
      Construct a StreamSource from a File.
      StreamSource(InputStream inputStream)
      Construct a StreamSource from a byte stream.
      StreamSource(InputStream inputStream, String systemId)
      Construct a StreamSource from a byte stream.
      StreamSource(Reader reader)
      Construct a StreamSource from a character reader.
      StreamSource(Reader reader, String systemId)
      Construct a StreamSource from a character reader.
      StreamSource(String systemId)
      Construct a StreamSource from a URL.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InputStream getInputStream()
      Get the byte stream that was set with setByteStream.
      String getPublicId()
      Get the public identifier that was set with setPublicId.
      Reader getReader()
      Get the character stream that was set with setReader.
      String getSystemId()
      Get the system identifier that was set with setSystemId.
      void setInputStream(InputStream inputStream)
      Set the byte stream to be used as input.
      void setPublicId(String publicId)
      Set the public identifier for this Source.
      void setReader(Reader reader)
      Set the input to be a character reader.
      void setSystemId(File f)
      Set the system ID from a File reference.
      void setSystemId(String systemId)
      Set the system identifier for this Source.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • FEATURE

        public static final String FEATURE
        If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • StreamSource

        public StreamSource()

        Zero-argument default constructor. If this constructor is used, and no Stream source is set using setInputStream(java.io.InputStream inputStream) or setReader(java.io.Reader reader), then the Transformer will create an empty source InputStream using new InputStream().

        另请参见：
        Transformer.transform(Source xmlSource, Result outputTarget)

      • StreamSource

        public StreamSource(InputStream inputStream)
        Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so the XML parser can resolve character encoding specified by the XML declaration.

        If this constructor is used to process a stylesheet, normally setSystemId should also be called, so that relative URI references can be resolved.

        参数：
        inputStream - A valid InputStream reference to an XML stream.

      • StreamSource

        public StreamSource(InputStream inputStream,
            String systemId)
        Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

        This constructor allows the systemID to be set in addition to the input stream, which allows relative URIs to be processed.

        参数：
        inputStream - A valid InputStream reference to an XML stream.
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(Reader reader)
        Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        参数：
        reader - A valid Reader reference to an XML character stream.

      • StreamSource

        public StreamSource(Reader reader,
            String systemId)
        Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser may resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        参数：
        reader - A valid Reader reference to an XML character stream.
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(String systemId)
        Construct a StreamSource from a URL.
        参数：
        systemId - Must be a String that conforms to the URI syntax.

      • StreamSource

        public StreamSource(File f)
        Construct a StreamSource from a File.
        参数：
        f - Must a non-null File reference.

    • 方法详细信息

      • setInputStream

        public void setInputStream(InputStream inputStream)
        Set the byte stream to be used as input. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

        If this Source object is used to process a stylesheet, normally setSystemId should also be called, so that relative URL references can be resolved.

        参数：
        inputStream - A valid InputStream reference to an XML stream.

      • getInputStream

        public InputStream getInputStream()
        Get the byte stream that was set with setByteStream.
        返回：
        The byte stream that was set with setByteStream, or null if setByteStream or the ByteStream constructor was not called.

      • setReader

        public void setReader(Reader reader)
        Set the input to be a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.
        参数：
        reader - A valid Reader reference to an XML CharacterStream.

      • getReader

        public Reader getReader()
        Get the character stream that was set with setReader.
        返回：
        The character stream that was set with setReader, or null if setReader or the Reader constructor was not called.

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this Source.

        The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

        参数：
        publicId - The public identifier as a string.

      • getPublicId

        public String getPublicId()
        Get the public identifier that was set with setPublicId.
        返回：
        The public identifier that was set with setPublicId, or null if setPublicId was not called.

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this Source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

        指定者：
        setSystemId in interface Source
        参数：
        systemId - The system identifier as a URL string.

      • getSystemId

        public String getSystemId()
        Get the system identifier that was set with setSystemId.
        指定者：
        getSystemId in interface Source
        返回：
        The system identifier that was set with setSystemId, or null if setSystemId was not called.

      • setSystemId

        public void setSystemId(File f)
        Set the system ID from a File reference.
        参数：
        f - Must a non-null File reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A1r/rapr,tx籰c.lot1譾s/"eo�> >


Uses of Package javax.xml.transform.stream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.transform.stream

No usage of javax.xml.transform.stream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Nso_gr"rae==a.ppfxrt<


Uses of Class javax.xml.transform.stream.StreamResult

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.stream.StreamResult

No usage of javax.xml.transform.stream.StreamResult
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lrrosel


Uses of Class javax.xml.transform.stream.StreamSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.transform.stream.StreamSource

No usage of javax.xml.transform.stream.StreamSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ro蒶r榬蘤o�


javax.xml.validation

Classes

  • Schema
  • SchemaFactory
  • SchemaFactoryLoader
  • TypeInfoProvider
  • Validator
  • ValidatorHandler


javax.xml.validation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.validation

This package provides an API for validation of XML documents.

请参见： 描述

  • Class Summary
    类 描述
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    SchemaFactoryLoader
    Factory that creates SchemaFactory.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.

软件包 javax.xml.validation Description

This package provides an API for validation of XML documents. Validation is the process of verifying that an XML document is an instance of a specified XML schema. An XML schema defines the content model (also called a grammar or vocabulary) that its instance documents will represent.

There are a number of popular technologies available for creating an XML schema. Some of the most popular include:

  • Document Type Definition (DTD) - XML's built-in schema language.
  • W3C XML Schema (WXS) - an object-oriented XML schema language. WXS also provides a type system for constraining the character data of an XML document. WXS is maintained by the World Wide Web Consortium (W3C) and is a W3C Recommendation (that is, a ratified W3C standard specification).
  • RELAX NG (RNG) - a pattern-based, user-friendly XML schema language. RNG schemas may also use types to constrain XML character data. RNG is maintained by the Organization for the Advancement of Structured Information Standards (OASIS) and is both an OASIS and an ISO (International Organization for Standardization) standard.
  • Schematron - a rules-based XML schema language. Whereas DTD, WXS, and RNG are designed to express the structure of a content model, Schematron is designed to enforce individual rules that are difficult or impossible to express with other schema languages. Schematron is intended to supplement a schema written in structural schema language such as the aforementioned. Schematron is in the process of becoming an ISO standard.

Previous versions of JAXP supported validation as a feature of an XML parser, represented by either a SAXParser or DocumentBuilder instance.

The JAXP validation API decouples the validation of an instance document from the parsing of an XML document. This is advantageous for several reasons, some of which are:

  • Support for additional schema langauges. As of JDK 1.5, the two most popular JAXP parser implementations, Crimson and Xerces, only support a subset of the available XML schema languages. The Validation API provides a standard mechanism through which applications may take of advantage of specialization validation libraries which support additional schema languages.
  • Easy runtime coupling of an XML instance and schema. Specifying the location of a schema to use for validation with JAXP parsers can be confusing. The Validation API makes this process simple (see example below).

Usage example. The following example demonstrates validating an XML document with the Validation API (for readability, some exception handling is not shown):

    // parse an XML document into a DOM tree
    DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
    Document document = parser.parse(new File("instance.xml"));

    // create a SchemaFactory capable of understanding WXS schemas
    SchemaFactory factory = SchemaFactory.newInstance(XMLConstants.W3C_XML_SCHEMA_NS_URI);

    // load a WXS schema, represented by a Schema instance
    Source schemaFile = new StreamSource(new File("mySchema.xsd"));
    Schema schema = factory.newSchema(schemaFile);

    // create a Validator instance, which can be used to validate an instance document
    Validator validator = schema.newValidator();

    // validate the DOM tree
    try {
        validator.validate(new DOMSource(document));
    } catch (SAXException e) {
        // instance document is invalid!
    }

The JAXP parsing API has been integrated with the Validation API. Applications may create a Schema with the validation API and associate it with a DocumentBuilderFactory or a SAXParserFactory instance by using the DocumentBuilderFactory.setSchema(Schema) and SAXParserFactory.setSchema(Schema) methods. You should not both set a schema and call setValidating(true) on a parser factory. The former technique will cause parsers to use the new validation API; the latter will cause parsers to use their own internal validation facilities. Turning on both of these options simultaneously will cause either redundant behavior or error conditions.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uekrt = t>/nel


javax.xml.validation Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.validation

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • javax.xml.validation.TypeInfoProvider
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

arnrhc eccc ttter h


Schema

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 Schema

  • java.lang.Object
    • javax.xml.validation.Schema

  • public abstract class Schema
extends Object
    Immutable in-memory representation of grammar.

    This object represents a set of constraints that can be checked/ enforced against an XML document.

    A Schema object is thread safe and applications are encouraged to share it across many parsers in many threads.

    A Schema object is immutable in the sense that it shouldn't change the set of constraints once it is created. In other words, if an application validates the same document twice against the same Schema, it must always produce the same result.

    A Schema object is usually created from SchemaFactory.

    Two kinds of validators can be created from a Schema object. One is Validator, which provides highly-level validation operations that cover typical use cases. The other is ValidatorHandler, which works on top of SAX for better modularity.

    This specification does not refine the Object.equals(java.lang.Object) method. In other words, if you parse the same schema twice, you may still get !schemaA.equals(schemaB).

    从以下版本开始：
    1.5
    另请参见：
    XML Schema Part 1: Structures, Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition)

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Schema()
      Constructor for the derived class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Validator newValidator()
      Creates a new Validator for this Schema.
      abstract ValidatorHandler newValidatorHandler()
      Creates a new ValidatorHandler for this Schema.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Schema

        protected Schema()
        Constructor for the derived class.

        The constructor does nothing.

    • 方法详细信息

      • newValidator

        public abstract Validator newValidator()
        Creates a new Validator for this Schema.

        A validator enforces/checks the set of constraints this object represents.

        Implementors should assure that the properties set on the SchemaFactory that created this Schema are also set on the Validator constructed.

        返回：
        Always return a non-null valid object.

      • newValidatorHandler

        public abstract ValidatorHandler newValidatorHandler()
        Creates a new ValidatorHandler for this Schema.

        Implementors should assure that the properties set on the SchemaFactory that created this Schema are also set on the ValidatorHandler constructed.

        返回：
        Always return a non-null valid object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nTou!o=-f>


SchemaFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 SchemaFactory

  • java.lang.Object
    • javax.xml.validation.SchemaFactory

  • public abstract class SchemaFactory
extends Object
    Factory that creates Schema objects. Entry-point to the validation API.

    SchemaFactory is a schema compiler. It reads external representations of schemas and prepares them for validation.

    The SchemaFactory class is not thread-safe. In other words, it is the application's responsibility to ensure that at most one thread is using a SchemaFactory object at any given moment. Implementations are encouraged to mark methods as synchronized to protect themselves from broken clients.

    SchemaFactory is not re-entrant. While one of the newSchema methods is being invoked, applications may not attempt to recursively invoke the newSchema method, even from the same thread.

    Schema Language

    This spec uses a namespace URI to designate a schema language. The following table shows the values defined by this specification.

    To be compliant with the spec, the implementation is only required to support W3C XML Schema 1.0. However, if it chooses to support other schema languages listed here, it must conform to the relevant behaviors described in this spec.

    Schema languages not listed here are expected to introduce their own URIs to represent themselves. The SchemaFactory class is capable of locating other implementations for other schema languages at run-time.

    Note that because the XML DTD is strongly tied to the parsing process and has a significant effect on the parsing process, it is impossible to define the DTD validation as a process independent from parsing. For this reason, this specification does not define the semantics for the XML DTD. This doesn't prohibit implentors from implementing it in a way they see fit, but users are warned that any DTD validation implemented on this interface necessarily deviate from the XML DTD semantics as defined in the XML 1.0.

    value | language
    XMLConstants.W3C_XML_SCHEMA_NS_URI ("http://www.w3.org/2001/XMLSchema") | W3C XML Schema 1.0
    XMLConstants.RELAXNG_NS_URI ("http://relaxng.org/ns/structure/1.0") | RELAX NG 1.0
    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SchemaFactory()
      Constructor for derived classes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this SchemaFactory.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this SchemaFactory.
      abstract boolean isSchemaLanguageSupported(String schemaLanguage)
      Is specified schema supported by this SchemaFactory?
      static SchemaFactory newInstance(String schemaLanguage)
      Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.
      static SchemaFactory newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SchemaFactory from class name.
      abstract Schema newSchema()
      Creates a special Schema object.
      Schema newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.
      void setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution when parsing schemas.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SchemaFactory

        protected SchemaFactory()

        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create SchemaFactory objects that have null ErrorHandler and null LSResourceResolver.

    • 方法详细信息

      • newInstance

        public static final SchemaFactory newInstance(String schemaLanguage)

        Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.

        To find a SchemaFactory object for a given schema language, this method looks the following places in the following order where "the class loader" refers to the context class loader:

        1. If the system property "javax.xml.validation.SchemaFactory:schemaLanguage" is present (where schemaLanguage is the parameter to this method), then its value is read as a class name. The method will try to create a new instance of this class by using the class loader, and returns it if it is successfully created.
        2. $java.home/lib/jaxp.properties is read and the value associated with the key being the system property above is looked for. If present, the value is processed just like above.

        3. The class loader is asked for service provider provider-configuration files matching javax.xml.validation.SchemaFactory in the resource directory META-INF/services. See the JAR File Specification for file format and parsing rules. Each potential service provider is required to implement the method:

                  isSchemaLanguageSupported(String schemaLanguage)
          The first service provider found in class loader order that supports the specified schema language is returned.
        4. Platform default SchemaFactory is located in a implementation specific way. There must be a platform default SchemaFactory for W3C XML Schema.

        If everything fails, IllegalArgumentException will be thrown.

        Tip for Trouble-shooting:

        See Properties.load(java.io.InputStream) for exactly how a property file is parsed. In particular, colons ':' need to be escaped in a property file, so make sure schema language URIs are properly escaped in it. For example:

         http\://www.w3.org/2001/XMLSchema=org.acme.foo.XSSchemaFactory
        参数：
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. See the list of available schema languages for the possible values.
        返回：
        New instance of a SchemaFactory
        抛出：
        IllegalArgumentException - If no implementation of the schema language is available.
        NullPointerException - If the schemaLanguage parameter is null.
        另请参见：
        newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)

      • newInstance

        public static SchemaFactory newInstance(String schemaLanguage,
                        String factoryClassName,
                        ClassLoader classLoader)

        Obtain a new instance of a SchemaFactory from class name. SchemaFactory is returned if specified factory class name supports the specified schema language. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. See the list of available schema languages for the possible values.
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.validation.SchemaFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a SchemaFactory
        抛出：
        IllegalArgumentException - if factoryClassName is null, or the factory class cannot be loaded, instantiated or doesn't support the schema language specified in schemLanguage parameter.
        NullPointerException - If the schemaLanguage parameter is null.
        从以下版本开始：
        1.6
        另请参见：
        newInstance(String schemaLanguage)

      • isSchemaLanguageSupported

        public abstract boolean isSchemaLanguageSupported(String schemaLanguage)

        Is specified schema supported by this SchemaFactory?

        参数：
        schemaLanguage - Specifies the schema language which the returned SchemaFactory will understand. schemaLanguage must specify a valid schema language.
        返回：
        true if SchemaFactory supports schemaLanguage, else false.
        抛出：
        NullPointerException - If schemaLanguage is null.
        IllegalArgumentException - If schemaLanguage.length() == 0 or schemaLanguage does not specify a valid schema language.

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a feature name but temporarily be unable to return its value.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        返回：
        The current value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the feature name but cannot determine its value at this time.
        NullPointerException - If name is null.
        另请参见：
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

        Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.

        Implementors and developers should pay particular attention to how the special Schema object returned by newSchema() is processed. In some cases, for example, when the SchemaFactory and the class actually loading the schema come from different implementations, it may not be possible for SchemaFactory features to be inherited automatically. Developers should make sure that features, such as secure processing, are explicitly set in both places.

        The feature name is any fully-qualified URI. It is possible for a SchemaFactory to expose a feature value but to be unable to change the current value.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See setErrorHandler(ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the feature name but cannot set the requested value.
        NullPointerException - If name is null.
        另请参见：
        getFeature(String)

      • setProperty

        public void setProperty(String name,
               Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a property name but to be unable to change the current value.

        SchemaFactorys are not required to recognize setting any specific property names.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the SchemaFactory recognizes the property name but cannot set the requested value.
        NullPointerException - If name is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a SchemaFactory to recognize a property name but temporarily be unable to return its value.

        SchemaFactorys are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        返回：
        The current value of the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - If name is null.
        另请参见：
        setProperty(String, Object)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.

        Error handler can be used to customize the error handling process during schema parsing. When an ErrorHandler is set, errors found during the parsing of schemas will be first sent to the ErrorHandler.

        The error handler can abort the parsing of a schema immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the processing by returning normally from the ErrorHandler

        If any Throwable (or instances of its derived classes) is thrown from an ErrorHandler, the caller of the newSchema method will be thrown the same Throwable object.

        SchemaFactory is not allowed to throw SAXException without first reporting it to ErrorHandler.

        Applications can call this method even during a Schema is being parsed.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new SchemaFactory object is created, initially this field is set to null. This field will NOT be inherited to Schemas, Validators, or ValidatorHandlers that are created from this SchemaFactory.

        参数：
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this SchemaFactory.
        返回：
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this SchemaFactory has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution when parsing schemas.

        SchemaFactory uses a LSResourceResolver when it needs to locate external resources while parsing schemas, although exactly what constitutes "locating external resources" is up to each schema language. For example, for W3C XML Schema, this includes files <include>d or <import>ed, and DTD referenced from schema files, etc.

        Applications can call this method even during a Schema is being parsed.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbDOMResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the SchemaFactory will abort the parsing and the caller of the newSchema method will receive the same RuntimeException.

        When a new SchemaFactory object is created, initially this field is set to null. This field will NOT be inherited to Schemas, Validators, or ValidatorHandlers that are created from this SchemaFactory.

        参数：
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this SchemaFactory.
        返回：
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this SchemaFactory has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • newSchema

        public Schema newSchema(Source schema)
                 throws SAXException

        Parses the specified source as a schema and returns it as a schema.

        This is a convenience method for newSchema(Source[] schemas).

        参数：
        schema - Source that represents a schema.
        返回：
        New Schema from parsing schema.
        抛出：
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public Schema newSchema(File schema)
                 throws SAXException

        Parses the specified File as a schema and returns it as a Schema.

        This is a convenience method for newSchema(Source schema).

        参数：
        schema - File that represents a schema.
        返回：
        New Schema from parsing schema.
        抛出：
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public Schema newSchema(URL schema)
                 throws SAXException

        Parses the specified URL as a schema and returns it as a Schema.

        This is a convenience method for newSchema(Source schema).

        参数：
        schema - URL that represents a schema.
        返回：
        New Schema from parsing schema.
        抛出：
        SAXException - If a SAX error occurs during parsing.
        NullPointerException - if schema is null.

      • newSchema

        public abstract Schema newSchema(Source[] schemas)
                          throws SAXException
        Parses the specified source(s) as a schema and returns it as a schema.

        The callee will read all the Sources and combine them into a single schema. The exact semantics of the combination depends on the schema language that this SchemaFactory object is created for.

        When an ErrorHandler is set, the callee will report all the errors found in sources to the handler. If the handler throws an exception, it will abort the schema compilation and the same exception will be thrown from this method. Also, after an error is reported to a handler, the callee is allowed to abort the further processing by throwing it. If an error handler is not set, the callee will throw the first error it finds in the sources.

        W3C XML Schema 1.0

        The resulting schema contains components from the specified sources. The same result would be achieved if all these sources were imported, using appropriate values for schemaLocation and namespace, into a single schema document with a different targetNamespace and no components of its own, if the import elements were given in the same order as the sources. Section 4.2.3 of the XML Schema recommendation describes the options processors have in this regard. While a processor should be consistent in its treatment of JAXP schema sources and XML Schema imports, the behaviour between JAXP-compliant parsers may vary; in particular, parsers may choose to ignore all but the first <import> for a given namespace, regardless of information provided in schemaLocation.

        If the parsed set of schemas includes error(s) as specified in the section 5.1 of the XML Schema spec, then the error must be reported to the ErrorHandler.

        RELAX NG

        For RELAX NG, this method must throw UnsupportedOperationException if schemas.length!=1.

        参数：
        schemas - inputs to be parsed. SchemaFactory is required to recognize SAXSource, StreamSource, StAXSource, and DOMSource. Input schemas must be XML documents or XML elements and must not be null. For backwards compatibility, the results of passing anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or thrown an IllegalArgumentException.
        返回：
        Always return a non-null valid Schema object. Note that when an error has been reported, there is no guarantee that the returned Schema object is meaningful.
        抛出：
        SAXException - If an error is found during processing the specified inputs. When an ErrorHandler is set, errors are reported to there first. See setErrorHandler(ErrorHandler).
        NullPointerException - If the schemas parameter itself is null or any item in the array is null.
        IllegalArgumentException - If any item in the array is not recognized by this method.
        UnsupportedOperationException - If the schema language doesn't support this operation.

      • newSchema

        public abstract Schema newSchema()
                          throws SAXException
        Creates a special Schema object.

        The exact semantics of the returned Schema object depend on the schema language for which this SchemaFactory is created.

        Also, implementations are allowed to use implementation-specific property/feature to alter the semantics of this method.

        Implementors and developers should pay particular attention to how the features set on this SchemaFactory are processed by this special Schema. In some cases, for example, when the SchemaFactory and the class actually loading the schema come from different implementations, it may not be possible for SchemaFactory features to be inherited automatically. Developers should make sure that features, such as secure processing, are explicitly set in both places.

        W3C XML Schema 1.0

        For XML Schema, this method creates a Schema object that performs validation by using location hints specified in documents.

        The returned Schema object assumes that if documents refer to the same URL in the schema location hints, they will always resolve to the same schema document. This asusmption allows implementations to reuse parsed results of schema documents so that multiple validations against the same schema will run faster.

        Note that the use of schema location hints introduces a vulnerability to denial-of-service attacks.

        RELAX NG

        RELAX NG does not support this operation.

        返回：
        Always return non-null valid Schema object.
        抛出：
        UnsupportedOperationException - If this operation is not supported by the callee.
        SAXException - If this operation is supported but failed for some reason.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


SchemaFactoryLoader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 SchemaFactoryLoader

  • java.lang.Object
    • javax.xml.validation.SchemaFactoryLoader

  • public abstract class SchemaFactoryLoader
extends Object

    Factory that creates SchemaFactory.

    DO NOT USE THIS CLASS

    This class was introduced as a part of an early proposal during the JSR-206 standardization process. The proposal was eventually abandoned but this class accidentally remained in the source tree, and made its way into the final version.

    This class does not participate in any JAXP 1.3 or JAXP 1.4 processing. It must not be used by users or JAXP implementations.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SchemaFactoryLoader()
      A do-nothing constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract SchemaFactory newFactory(String schemaLanguage)
      Creates a new SchemaFactory object for the specified schema language.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SchemaFactoryLoader

        protected SchemaFactoryLoader()
        A do-nothing constructor.

    • 方法详细信息

      • newFactory

        public abstract SchemaFactory newFactory(String schemaLanguage)
        Creates a new SchemaFactory object for the specified schema language.
        参数：
        schemaLanguage - See the list of available schema languages.
        返回：
        null if the callee fails to create one.
        抛出：
        NullPointerException - If the schemaLanguage parameter is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sn=>e


TypeInfoProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 TypeInfoProvider

  • java.lang.Object
    • javax.xml.validation.TypeInfoProvider

  • public abstract class TypeInfoProvider
extends Object
    This class provides access to the type information determined by ValidatorHandler.

    Some schema languages, such as W3C XML Schema, encourages a validator to report the "type" it assigns to each attribute/element. Those applications who wish to access this type information can invoke methods defined on this "interface" to access such type information.

    Implementation of this "interface" can be obtained through the ValidatorHandler.getTypeInfoProvider() method.

    从以下版本开始：
    1.5
    另请参见：
    TypeInfo

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TypeInfoProvider()
      Constructor for the derived class.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract TypeInfo getAttributeTypeInfo(int index)
      Returns the immutable TypeInfo object for the specified attribute of the current element.
      abstract TypeInfo getElementTypeInfo()
      Returns the immutable TypeInfo object for the current element.
      abstract boolean isIdAttribute(int index)
      Returns true if the specified attribute is determined to be ID.
      abstract boolean isSpecified(int index)
      Returns false if the attribute was added by the validator.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TypeInfoProvider

        protected TypeInfoProvider()
        Constructor for the derived class.

        The constructor does nothing.

    • 方法详细信息

      • getElementTypeInfo

        public abstract TypeInfo getElementTypeInfo()

        Returns the immutable TypeInfo object for the current element.

        The method may only be called by the startElement event or the endElement event of the ContentHandler that the application sets to the ValidatorHandler.

        When W3C XML Schema validation is being performed, in the case where an element has a union type, the TypeInfo returned by a call to getElementTypeInfo() from the startElement event will be the union type. The TypeInfo returned by a call from the endElement event will be the actual member type used to validate the element.

        返回：
        An immutable TypeInfo object that represents the type of the current element. Note that the caller can keep references to the obtained TypeInfo longer than the callback scope. Otherwise, this method returns null if the validator is unable to determine the type of the current element for some reason (for example, if the validator is recovering from an earlier error.)
        抛出：
        IllegalStateException - If this method is called from other ContentHandler methods.

      • getAttributeTypeInfo

        public abstract TypeInfo getAttributeTypeInfo(int index)
        Returns the immutable TypeInfo object for the specified attribute of the current element.

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        参数：
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        返回：
        An immutable TypeInfo object that represents the type of the specified attribute. Note that the caller can keep references to the obtained TypeInfo longer than the callback scope. Otherwise, this method returns null if the validator is unable to determine the type.
        抛出：
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.

      • isIdAttribute

        public abstract boolean isIdAttribute(int index)
        Returns true if the specified attribute is determined to be ID.

        Exacly how an attribute is "determined to be ID" is up to the schema language. In case of W3C XML Schema, this means that the actual type of the attribute is the built-in ID type or its derived type.

        A DocumentBuilder uses this information to properly implement Attr.isId().

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        参数：
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        返回：
        true if the type of the specified attribute is ID.
        抛出：
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.

      • isSpecified

        public abstract boolean isSpecified(int index)
        Returns false if the attribute was added by the validator.

        This method provides information necessary for a DocumentBuilder to determine what the DOM tree should return from the Attr.getSpecified() method.

        The method may only be called by the startElement event of the ContentHandler that the application sets to the ValidatorHandler.

        A general guideline for validators is to return true if the attribute was originally present in the pipeline, and false if it was added by the validator.

        参数：
        index - The index of the attribute. The same index for the Attributes object passed to the startElement callback.
        返回：
        true if the attribute was present before the validator processes input. false if the attribute was added by the validator.
        抛出：
        IndexOutOfBoundsException - If the index is invalid.
        IllegalStateException - If this method is called from other ContentHandler methods.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iclgd.<. nrmc/a= e舗Ftehpeso" l�


Uses of Package javax.xml.validation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.validation

  • Packages that use javax.xml.validation
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
  • Classes in javax.xml.validation used by javax.xml.bind
    类与描述
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.bind.helpers
    类与描述
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.parsers
    类与描述
    Schema
    Immutable in-memory representation of grammar.
  • Classes in javax.xml.validation used by javax.xml.validation
    类与描述
    Schema
    Immutable in-memory representation of grammar.
    SchemaFactory
    Factory that creates Schema objects. Entry-point to the validation API.
    TypeInfoProvider
    This class provides access to the type information determined by ValidatorHandler.
    Validator
    A processor that checks an XML document against Schema.
    ValidatorHandler
    Streaming validator that works on SAX stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

it a/ htAtXav=


Validator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 Validator

  • java.lang.Object
    • javax.xml.validation.Validator

  • public abstract class Validator
extends Object

    A processor that checks an XML document against Schema.

    A validator object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one Validator object is not used from more than one thread at any given time, and while the validate method is invoked, applications may not recursively call the validate method.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Validator()
      Constructor for derived classes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this Validator.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this Validator.
      abstract void reset()
      Reset this Validator to its original configuration.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validate method invocation.
      void setFeature(String name, boolean value)
      Set the value of a feature flag.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      void validate(Source source)
      Validates the specified input.
      abstract void validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Validator

        protected Validator()
        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create Validator objects that have null ErrorHandler and null LSResourceResolver.

    • 方法详细信息

      • reset

        public abstract void reset()

        Reset this Validator to its original configuration.

        Validator is reset to the same state as when it was created with Schema.newValidator(). reset() is designed to allow the reuse of existing Validators thus saving resources associated with the creation of new Validators.

        The reset Validator is not guaranteed to have the same LSResourceResolver or ErrorHandler Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal LSResourceResolver and ErrorHandler.

      • validate

        public void validate(Source source)
              throws SAXException,
                     IOException
        Validates the specified input.

        This is just a convenience method for validate(Source source, Result result) with result of null.

        参数：
        source - XML to be validated. Must be an XML document or XML element and must not be null. For backwards compatibility, the results of attempting to validate anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or throw an IllegalArgumentException.
        抛出：
        IllegalArgumentException - If the Source is an XML artifact that the implementation cannot validate (for example, a processing instruction).
        SAXException - If the ErrorHandler throws a SAXException or if a fatal error is found and the ErrorHandler returns normally.
        IOException - If the validator is processing a SAXSource and the underlying XMLReader throws an IOException.
        NullPointerException - If source is null.
        另请参见：
        validate(Source source, Result result)

      • validate

        public abstract void validate(Source source,
            Result result)
                       throws SAXException,
                              IOException

        Validates the specified input and send the augmented validation result to the specified output.

        This method places the following restrictions on the types of the Source/Result accepted.

        Source / Result Accepted
        StreamSource SAXSource DOMSource StAXSource
        null | OK | OK | OK | OK
        StreamResult | OK | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException
        SAXResult | IllegalArgumentException | OK | IllegalArgumentException | IllegalArgumentException
        DOMResult | IllegalArgumentException | IllegalArgumentException | OK | IllegalArgumentException
        StAXResult | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException | OK

        To validate one Source into another kind of Result, use the identity transformer (see TransformerFactory.newTransformer()).

        Errors found during the validation is sent to the specified ErrorHandler.

        If a document is valid, or if a document contains some errors but none of them were fatal and the ErrorHandler didn't throw any exception, then the method returns normally.

        参数：
        source - XML to be validated. Must be an XML document or XML element and must not be null. For backwards compatibility, the results of attempting to validate anything other than a document or element are implementation-dependent. Implementations must either recognize and process the input or throw an IllegalArgumentException.
        result - The Result object that receives (possibly augmented) XML. This parameter can be null if the caller is not interested in it. Note that when a DOMResult is used, a validator might just pass the same DOM node from DOMSource to DOMResult (in which case source.getNode()==result.getNode()), it might copy the entire DOM tree, or it might alter the node given by the source.
        抛出：
        IllegalArgumentException - If the Result type doesn't match the Source type of if the Source is an XML artifact that the implementation cannot validate (for example, a processing instruction).
        SAXException - If the ErrorHandler throws a SAXException or if a fatal error is found and the ErrorHandler returns normally.
        IOException - If the validator is processing a SAXSource and the underlying XMLReader throws an IOException.
        NullPointerException - If the source parameter is null.
        另请参见：
        validate(Source source)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the validate method invocation.

        Error handler can be used to customize the error handling process during a validation. When an ErrorHandler is set, errors found during the validation will be first sent to the ErrorHandler.

        The error handler can abort further validation immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the validation by returning normally from the ErrorHandler

        If any Throwable is thrown from an ErrorHandler, the caller of the validate method will be thrown the same Throwable object.

        Validator is not allowed to throw SAXException without first reporting it to ErrorHandler.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new Validator object is created, initially this field is set to null.

        参数：
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this Validator.
        返回：
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this Validator has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution while in a validation episode.

        Validator uses a LSResourceResolver when it needs to locate external resources while a validation, although exactly what constitutes "locating external resources" is up to each schema language.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the Validator will abort the parsing and the caller of the validate method will receive the same RuntimeException.

        When a new Validator object is created, initially this field is set to null.

        参数：
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this Validator.
        返回：
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this Validator has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a Validator to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a validation.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        返回：
        The current value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the feature name but cannot determine its value at this time.
        NullPointerException - When the name parameter is null.
        另请参见：
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature flag.

        Feature can be used to control the way a Validator parses schemas, although Validators are not required to recognize any specific feature names.

        The feature name is any fully-qualified URI. It is possible for a Validator to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the feature name but cannot set the requested value.
        NullPointerException - When the name parameter is null.
        另请参见：
        getFeature(String)

      • setProperty

        public void setProperty(String name,
               Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a Validator to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        Validators are not required to recognize setting any specific property names.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the Validator recognizes the property name but cannot set the requested value.
        NullPointerException - When the name parameter is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a Validator to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a validation.

        Validators are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        返回：
        The current value of the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - When the name parameter is null.
        另请参见：
        setProperty(String, Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ValidatorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.validation

类 ValidatorHandler

  • java.lang.Object
    • javax.xml.validation.ValidatorHandler
  • 所有已实现的接口：
    ContentHandler

    public abstract class ValidatorHandler
extends Object
implements ContentHandler
    Streaming validator that works on SAX stream.

    A ValidatorHandler object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one ValidatorHandler object is not used from more than one thread at any given time.

    ValidatorHandler checks if the SAX events follow the set of constraints described in the associated Schema, and additionally it may modify the SAX events (for example by adding default values, etc.)

    ValidatorHandler extends from ContentHandler, but it refines the underlying ContentHandler in the following way:

    1. startElement/endElement events must receive non-null String for uri, localName, and qname, even though SAX allows some of them to be null. Similarly, the user-specified ContentHandler will receive non-null Strings for all three parameters.
    2. Applications must ensure that ValidatorHandler's ContentHandler.startPrefixMapping(String,String) and ContentHandler.endPrefixMapping(String) are invoked properly. Similarly, the user-specified ContentHandler will receive startPrefixMapping/endPrefixMapping events. If the ValidatorHandler introduces additional namespace bindings, the user-specified ContentHandler will receive additional startPrefixMapping/endPrefixMapping events.
    3. Attributes for the ContentHandler.startElement(String,String,String,Attributes) method may or may not include xmlns* attributes.

    A ValidatorHandler is automatically reset every time the startDocument method is invoked.

    Recognized Properties and Features

    This spec defines the following feature that must be recognized by all ValidatorHandler implementations.

    http://xml.org/sax/features/namespace-prefixes

    This feature controls how a ValidatorHandler introduces namespace bindings that were not present in the original SAX event stream. When this feature is set to true, it must make sure that the user's ContentHandler will see the corresponding xmlns* attribute in the Attributes object of the ContentHandler.startElement(String,String,String,Attributes) callback. Otherwise, xmlns* attributes must not be added to Attributes that's passed to the user-specified ContentHandler.

    (Note that regardless of this switch, namespace bindings are always notified to applications through ContentHandler.startPrefixMapping(String,String) and ContentHandler.endPrefixMapping(String) methods of the ContentHandler specified by the user.)

    Note that this feature does NOT affect the way a ValidatorHandler receives SAX events. It merely changes the way it augments SAX events.

    This feature is set to false by default.

    从以下版本开始：
    1.5

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected ValidatorHandler()
      Constructor for derived classes.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract ContentHandler getContentHandler()
      Gets the ContentHandler which receives the augmented validation result.
      abstract ErrorHandler getErrorHandler()
      Gets the current ErrorHandler set to this ValidatorHandler.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      abstract LSResourceResolver getResourceResolver()
      Gets the current LSResourceResolver set to this ValidatorHandler.
      abstract TypeInfoProvider getTypeInfoProvider()
      Obtains the TypeInfoProvider implementation of this ValidatorHandler.
      abstract void setContentHandler(ContentHandler receiver)
      Sets the ContentHandler which receives the augmented validation result.
      abstract void setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validation.
      void setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void setProperty(String name, Object object)
      Set the value of a property.
      abstract void setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.xml.sax.ContentHandler

        characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

    • 构造方法详细信息

      • ValidatorHandler

        protected ValidatorHandler()

        Constructor for derived classes.

        The constructor does nothing.

        Derived classes must create ValidatorHandler objects that have null ErrorHandler and null LSResourceResolver.

    • 方法详细信息

      • setContentHandler

        public abstract void setContentHandler(ContentHandler receiver)
        Sets the ContentHandler which receives the augmented validation result.

        When a ContentHandler is specified, a ValidatorHandler will work as a filter and basically copy the incoming events to the specified ContentHandler.

        In doing so, a ValidatorHandler may modify the events, for example by adding defaulted attributes.

        A ValidatorHandler may buffer events to certain extent, but to allow ValidatorHandler to be used by a parser, the following requirement has to be met.

        1. When ContentHandler.startElement(String, String, String, Attributes), ContentHandler.endElement(String, String, String), ContentHandler.startDocument(), or ContentHandler.endDocument() are invoked on a ValidatorHandler, the same method on the user-specified ContentHandler must be invoked for the same event before the callback returns.
        2. ValidatorHandler may not introduce new elements that were not present in the input.
        3. ValidatorHandler may not remove attributes that were present in the input.

        When a callback method on the specified ContentHandler throws an exception, the same exception object must be thrown from the ValidatorHandler. The ErrorHandler should not be notified of such an exception.

        This method can be called even during a middle of a validation.

        参数：
        receiver - A ContentHandler or a null value.

      • getContentHandler

        public abstract ContentHandler getContentHandler()
        Gets the ContentHandler which receives the augmented validation result.
        返回：
        This method returns the object that was last set through the getContentHandler() method, or null if that method has never been called since this ValidatorHandler has created.
        另请参见：
        setContentHandler(ContentHandler)

      • setErrorHandler

        public abstract void setErrorHandler(ErrorHandler errorHandler)
        Sets the ErrorHandler to receive errors encountered during the validation.

        Error handler can be used to customize the error handling process during a validation. When an ErrorHandler is set, errors found during the validation will be first sent to the ErrorHandler.

        The error handler can abort further validation immediately by throwing SAXException from the handler. Or for example it can print an error to the screen and try to continue the validation by returning normally from the ErrorHandler

        If any Throwable is thrown from an ErrorHandler, the same Throwable object will be thrown toward the root of the call stack.

        ValidatorHandler is not allowed to throw SAXException without first reporting it to ErrorHandler.

        When the ErrorHandler is null, the implementation will behave as if the following ErrorHandler is set:

         class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

        When a new ValidatorHandler object is created, initially this field is set to null.

        参数：
        errorHandler - A new error handler to be set. This parameter can be null.

      • getErrorHandler

        public abstract ErrorHandler getErrorHandler()
        Gets the current ErrorHandler set to this ValidatorHandler.
        返回：
        This method returns the object that was last set through the setErrorHandler(ErrorHandler) method, or null if that method has never been called since this ValidatorHandler has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • setResourceResolver

        public abstract void setResourceResolver(LSResourceResolver resourceResolver)
        Sets the LSResourceResolver to customize resource resolution while in a validation episode.

        ValidatorHandler uses a LSResourceResolver when it needs to locate external resources while a validation, although exactly what constitutes "locating external resources" is up to each schema language.

        When the LSResourceResolver is null, the implementation will behave as if the following LSResourceResolver is set:

         class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

        If a LSResourceResolver throws a RuntimeException (or instances of its derived classes), then the ValidatorHandler will abort the parsing and the caller of the validate method will receive the same RuntimeException.

        When a new ValidatorHandler object is created, initially this field is set to null.

        参数：
        resourceResolver - A new resource resolver to be set. This parameter can be null.

      • getResourceResolver

        public abstract LSResourceResolver getResourceResolver()
        Gets the current LSResourceResolver set to this ValidatorHandler.
        返回：
        This method returns the object that was last set through the setResourceResolver(LSResourceResolver) method, or null if that method has never been called since this ValidatorHandler has created.
        另请参见：
        setErrorHandler(ErrorHandler)

      • getTypeInfoProvider

        public abstract TypeInfoProvider getTypeInfoProvider()
        Obtains the TypeInfoProvider implementation of this ValidatorHandler.

        The obtained TypeInfoProvider can be queried during a parse to access the type information determined by the validator.

        Some schema languages do not define the notion of type, for those languages, this method may not be supported. However, to be compliant with this specification, implementations for W3C XML Schema 1.0 must support this operation.

        返回：
        null if the validator / schema language does not support the notion of TypeInfo. Otherwise a non-null valid TypeInfoProvider.

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a validation.

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        返回：
        The current value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the feature name but cannot determine its value at this time.
        NullPointerException - When name is null.
        另请参见：
        setFeature(String, boolean)

      • setFeature

        public void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

        Set a feature for this ValidatorHandler.

        Feature can be used to control the way a ValidatorHandler parses schemas. The feature name is any fully-qualified URI. It is possible for a SchemaFactory to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is:

        • true: the implementation will limit XML processing to conform to implementation limits. Examples include enity expansion limits and XML Schema constructs that would consume large amounts of resources. If XML processing is limited for security reasons, it will be reported via a call to the registered ErrorHandler.fatalError(SAXParseException exception). See setErrorHandler(ErrorHandler errorHandler).
        • false: the implementation will processing XML according to the XML specifications without regard to possible implementation limits.
        参数：
        name - The feature name, which is a non-null fully-qualified URI.
        value - The requested value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the feature name but cannot set the requested value.
        NullPointerException - When name is null.
        另请参见：
        getFeature(String)

      • setProperty

        public void setProperty(String name,
               Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a validation.

        ValidatorHandlers are not required to recognize setting any specific property names.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        object - The requested value for the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the ValidatorHandler recognizes the property name but cannot set the requested value.
        NullPointerException - When name is null.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for a ValidatorHandler to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a validation.

        ValidatorHandlers are not required to recognize any specific property names.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        参数：
        name - The property name, which is a non-null fully-qualified URI.
        返回：
        The current value of the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        NullPointerException - When name is null.
        另请参见：
        setProperty(String, Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.xml.validation.Schema

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.Schema

  • Packages that use Schema
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of Schema in javax.xml.bind

      Methods in javax.xml.bind that return Schema
      修饰符与类型 方法与描述
      Schema Unmarshaller.getSchema()
      Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
      Schema Marshaller.getSchema()
      Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
      abstract Schema Binder.getSchema()
      Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.
      Methods in javax.xml.bind with parameters of type Schema
      修饰符与类型 方法与描述
      void Unmarshaller.setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
      void Marshaller.setSchema(Schema schema)
      Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
      abstract void Binder.setSchema(Schema schema)
      Specifies whether marshal, unmarshal and update methods performs validation on their XML content.

    • Uses of Schema in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Schema
      修饰符与类型 | 方法与描述
      Schema | AbstractUnmarshallerImpl.getSchema()
      Schema | AbstractMarshallerImpl.getSchema()
      Methods in javax.xml.bind.helpers with parameters of type Schema
      修饰符与类型 | 方法与描述
      void | AbstractUnmarshallerImpl.setSchema(Schema schema)
      void | AbstractMarshallerImpl.setSchema(Schema schema)

    • Uses of Schema in javax.xml.parsers

      Methods in javax.xml.parsers that return Schema
      修饰符与类型 方法与描述
      Schema SAXParserFactory.getSchema()
      Gets the Schema object specified through the SAXParserFactory.setSchema(Schema schema) method.
      Schema SAXParser.getSchema()
      Get a reference to the the Schema being used by the XML processor.
      Schema DocumentBuilderFactory.getSchema()
      Gets the Schema object specified through the DocumentBuilderFactory.setSchema(Schema schema) method.
      Schema DocumentBuilder.getSchema()
      Get a reference to the the Schema being used by the XML processor.
      Methods in javax.xml.parsers with parameters of type Schema
      修饰符与类型 方法与描述
      void SAXParserFactory.setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.
      void DocumentBuilderFactory.setSchema(Schema schema)
      Set the Schema to be used by parsers created from this factory.

    • Uses of Schema in javax.xml.validation

      Methods in javax.xml.validation that return Schema
      修饰符与类型 方法与描述
      abstract Schema SchemaFactory.newSchema()
      Creates a special Schema object.
      Schema SchemaFactory.newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema SchemaFactory.newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raj


Uses of Class javax.xml.validation.SchemaFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.SchemaFactory

  • Packages that use SchemaFactory
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of SchemaFactory in javax.xml.validation

      Methods in javax.xml.validation that return SchemaFactory
      修饰符与类型 方法与描述
      abstract SchemaFactory SchemaFactoryLoader.newFactory(String schemaLanguage)
      Creates a new SchemaFactory object for the specified schema language.
      static SchemaFactory SchemaFactory.newInstance(String schemaLanguage)
      Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.
      static SchemaFactory SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a SchemaFactory from class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtliclalteee miic>c)S/mev


Uses of Class javax.xml.validation.SchemaFactoryLoader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.SchemaFactoryLoader

No usage of javax.xml.validation.SchemaFactoryLoader
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aslas ic"llllteeds sm


Uses of Class javax.xml.validation.TypeInfoProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.TypeInfoProvider

  • Packages that use TypeInfoProvider
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of TypeInfoProvider in javax.xml.validation

      Methods in javax.xml.validation that return TypeInfoProvider
      修饰符与类型 方法与描述
      abstract TypeInfoProvider ValidatorHandler.getTypeInfoProvider()
      Obtains the TypeInfoProvider implementation of this ValidatorHandler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uox>nm


Uses of Class javax.xml.validation.Validator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.Validator

  • Packages that use Validator
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of Validator in javax.xml.validation

      Methods in javax.xml.validation that return Validator
      修饰符与类型 方法与描述
      abstract Validator Schema.newValidator()
      Creates a new Validator for this Schema.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bArp asaxpe< rs2 = � ff >


Uses of Class javax.xml.validation.ValidatorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.validation.ValidatorHandler

  • Packages that use ValidatorHandler
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of ValidatorHandler in javax.xml.validation

      Methods in javax.xml.validation that return ValidatorHandler
      修饰符与类型 方法与描述
      abstract ValidatorHandler Schema.newValidatorHandler()
      Creates a new ValidatorHandler for this Schema.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Tvneng8e1-sas"alaontn&


Action

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type Action

  • @Documented
@Retention(value=RUNTIME)
@Target(value=方法)
public @interface Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.

    This annotation can be specified on each method of a service endpoint interface. For such a method, the mapped operation in the generated WSDL's wsam:Action attribute on the WSDL input, output and fault messages of the WSDL operation is based upon which attributes of the Action annotation have been specified. For the exact computation of wsam:Action values for the messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for input and output messages.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         input="http://example.com/inputAction",
         output="http://example.com/outputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction"/>
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/outputAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Specify explicit value for Action message addressing property for only the input message. The wsam:Action values for the WSDL output message are computed using the algorithm in the JAX-WS specification.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(input="http://example.com/inputAction")
     public int addNumbers(int number1, int number2) {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         <input message="tns:AddNumbersInput" name="foo"
           wsam:Action="http://example.com/inputAction" />
         <output message="tns:AddNumbersOutput" name="bar"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbersResponse"/>
       </operation>
     </portType>
     ...
   </definitions>
    It is legitimate to specify an explicit value for Action message addressing property for output message only. In this case, wsam:Action value for the WSDL input message is computed using the algorithm in the JAX-WS specification.

    Example 3: See FaultAction annotation for an example of how to specify an explicit value for Action message addressing property for the fault message.

    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    FaultAction

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      FaultAction[] fault
      Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation.
      String input
      Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
      String output
      Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.

    • Element Detail

      • input

        public abstract String input
        Explicit value of the WS-Addressing Action message addressing property for the input message of the operation.
        Default:
        ""

      • output

        public abstract String output
        Explicit value of the WS-Addressing Action message addressing property for the output message of the operation.
        Default:
        ""

      • fault

        public abstract FaultAction[] fault
        Explicit value of the WS-Addressing Action message addressing property for the fault message(s) of the operation. Each exception that is mapped to a fault and requires an explicit WS-Addressing Action message addressing property, needs to be specified as a value in this property using FaultAction annotation.
        Default:
        {}
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i_mn botafteh<


AsyncHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface AsyncHandler<T>

  • public interface AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.

    • 方法详细信息

      • handleResponse

        void handleResponse(Response<T> res)
        Called when the response to an asynchronous operation is available.
        参数：
        res - The response to the operation invocation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e.>f/>>l>


Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface Binding

  • All Known Subinterfaces:
    HTTPBinding, SOAPBinding

    public interface Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getBindingID()
      Get the URI for this binding instance.
      List<Handler> getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      void setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • 方法详细信息

      • getHandlerChain

        List<Handler> getHandlerChain()
        Gets a copy of the handler chain for a protocol binding instance. If the returned chain is modified a call to setHandlerChain is required to configure the binding instance with the new chain.
        返回：
        java.util.List<Handler> Handler chain

      • setHandlerChain

        void setHandlerChain(List<Handler> chain)
        Sets the handler chain for the protocol binding instance.
        参数：
        chain - A List of handler configuration entries
        抛出：
        WebServiceException - On an error in the configuration of the handler chain
        UnsupportedOperationException - If this operation is not supported. This may be done to avoid any overriding of a pre-configured handler chain.

      • getBindingID

        String getBindingID()
        Get the URI for this binding instance.
        返回：
        String The binding identifier for the port. Never returns null
        从以下版本开始：
        JAX-WS 2.1
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c>tow"xr


BindingProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface BindingProvider

  • All Known Subinterfaces:
    Dispatch<T>

    public interface BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Binding

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ENDPOINT_ADDRESS_PROPERTY
      Standard property: Target service endpoint address.
      static String PASSWORD_PROPERTY
      Standard property: Password for authentication.
      static String SESSION_MAINTAIN_PROPERTY
      Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
      static String SOAPACTION_URI_PROPERTY
      Standard property for SOAPAction.
      static String SOAPACTION_USE_PROPERTY
      Standard property for SOAPAction.
      static String USERNAME_PROPERTY
      Standard property: User name for authentication.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Binding getBinding()
      Get the Binding for this binding provider.
      EndpointReference getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		getEndpointReference(类<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      Map<String,Object> getRequestContext()
      Get the context that is used to initialize the message context for request messages.
      Map<String,Object> getResponseContext()
      Get the context that resulted from processing a response message.

    • 字段详细信息

      • USERNAME_PROPERTY

        static final String USERNAME_PROPERTY
        Standard property: User name for authentication.

        Type: java.lang.String

        另请参见：
        Constant Field Values

      • PASSWORD_PROPERTY

        static final String PASSWORD_PROPERTY
        Standard property: Password for authentication.

        Type: java.lang.String

        另请参见：
        Constant Field Values

      • ENDPOINT_ADDRESS_PROPERTY

        static final String ENDPOINT_ADDRESS_PROPERTY
        Standard property: Target service endpoint address. The URI scheme for the endpoint address specification MUST correspond to the protocol/transport binding for the binding in use.

        Type: java.lang.String

        另请参见：
        Constant Field Values

      • SESSION_MAINTAIN_PROPERTY

        static final String SESSION_MAINTAIN_PROPERTY
        Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

        Type: java.lang.Boolean

        另请参见：
        Constant Field Values

      • SOAPACTION_USE_PROPERTY

        static final String SOAPACTION_USE_PROPERTY
        Standard property for SOAPAction. This boolean property indicates whether or not the value of the javax.xml.ws.soap.http.soapaction.uri property is used for the value of the SOAPAction. The default value of this property is false indicating that the javax.xml.ws.soap.http.soapaction.uri property is not used for the value of the SOAPAction, however, if WS-Addressing is enabled, the default value is true.

        Type: java.lang.Boolean

        另请参见：
        Constant Field Values

      • SOAPACTION_URI_PROPERTY

        static final String SOAPACTION_URI_PROPERTY
        Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.ws.soap.http.soapaction.use property is set to true. If WS-Addressing is enabled, this value will also be used for the value of the WS-Addressing Action header. If this property is not set, the default SOAPAction and WS-Addressing Action will be sent.

        Type: java.lang.String

        另请参见：
        Constant Field Values

    • 方法详细信息

      • getRequestContext

        Map<String,Object> getRequestContext()
        Get the context that is used to initialize the message context for request messages. Modifications to the request context do not affect the message context of either synchronous or asynchronous operations that have already been started.
        返回：
        The context that is used in processing request messages.

      • getResponseContext

        Map<String,Object> getResponseContext()
        Get the context that resulted from processing a response message. The returned context is for the most recently completed synchronous operation. Subsequent synchronous operation invocations overwrite the response context. Asynchronous operations return their response context via the Response interface.
        返回：
        The context that resulted from processing the latest response messages.

      • getBinding

        Binding getBinding()
        Get the Binding for this binding provider.
        返回：
        The Binding for this binding provider.

      • getEndpointReference

        EndpointReference getEndpointReference()
        Returns the EndpointReference associated with this BindingProvider instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        返回：
        EndpointReference of the target endpoint associated with this BindingProvider instance.
        抛出：
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(类<T> clazz)
        Returns the EndpointReference associated with this BindingProvider instance. The instance returned will be of type clazz.
        参数：
        clazz - Specifies the type of EndpointReference that MUST be returned.
        返回：
        EndpointReference of the target endpoint associated with this BindingProvider instance. MUST be of type clazz.
        抛出：
        WebServiceException - If the Class clazz is not supported by this implementation.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        从以下版本开始：
        JAX-WS 2.1
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-v>-<.鵧/ e>jP/薾t#i..穉.xcs.r


BindingType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type BindingType

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.

    This annotation may be overriden programmatically or via deployment descriptors, depending on the platform in use.

    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String value
      A binding identifier (a URI).

    • Element Detail

      • value

        public abstract String value
        A binding identifier (a URI). If not specified, the default is the SOAP 1.1 / HTTP binding.

        See the SOAPBinding and HTTPBinding for the definition of the standard binding identifiers.

        另请参见：
        Binding, SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/=>Cl"ol"=rr"==ctiicc> n/w


Dispatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface Dispatch<T>

  • All Superinterfaces:
    BindingProvider

    public interface Dispatch<T>
extends BindingProvider
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations. The javax.xml.ws.Service class acts as a factory for the creation of Dispatch instances.
    从以下版本开始：
    JAX-WS 2.0

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.ws.BindingProvider

        ENDPOINT_ADDRESS_PROPERTY, PASSWORD_PROPERTY, SESSION_MAINTAIN_PROPERTY, SOAPACTION_URI_PROPERTY, SOAPACTION_USE_PROPERTY, USERNAME_PROPERTY

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      T invoke(T msg)
      Invoke a service operation synchronously.
      Response<T> invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Future<?> invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
      void invokeOneWay(T msg)
      Invokes a service operation using the one-way interaction mode.

      • 方法 - 继承于接口 javax.xml.ws.BindingProvider

        getBinding, getEndpointReference, getEndpointReference, getRequestContext, getResponseContext

    • 方法详细信息

      • invoke

        T invoke(T msg)
        Invoke a service operation synchronously. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.
        参数：
        msg - An object that will form the message or payload of the message used to invoke the operation.
        返回：
        The response message or message payload to the operation invocation.
        抛出：
        WebServiceException - If a fault occurs during communication with the service
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Response<T> invokeAsync(T msg)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are obtained by polling the returned Response.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        参数：
        msg - An object that will form the message or payload of the message used to invoke the operation.
        返回：
        The response message or message payload to the operation invocation.
        抛出：
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeAsync

        Future<?> invokeAsync(T msg,
                    AsyncHandler<T> handler)
        Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are communicated to the client via the passed in handler.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        参数：
        msg - An object that will form the message or payload of the message used to invoke the operation.
        handler - The handler object that will receive the response to the operation invocation.
        返回：
        A Future object that may be used to check the status of the operation invocation. This object MUST NOT be used to try to obtain the results of the operation - the object returned from Future<?>.get() is implementation dependent and any use of it will result in non-portable behaviour.
        抛出：
        WebServiceException - If there is any error in the configuration of the Dispatch instance

      • invokeOneWay

        void invokeOneWay(T msg)
        Invokes a service operation using the one-way interaction mode. The operation invocation is logically non-blocking, subject to the capabilities of the underlying protocol, no results are returned. When the protocol in use is SOAP/HTTP, this method MUST block until an HTTP response code has been received or an error occurs.

        The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

        参数：
        msg - An object that will form the message or payload of the message used to invoke the operation.
        抛出：
        WebServiceException - If there is any error in the configuration of the Dispatch instance or if an error occurs during the invocation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

itn . tOtnatt>eiioto>"b>s>scci>pfc


Endpoint

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 Endpoint

  • java.lang.Object
    • javax.xml.ws.Endpoint

  • public abstract class Endpoint
extends Object
    A Web service endpoint.

    Endpoints are created using the static methods defined in this class. An endpoint is always tied to one Binding and one implementor, both set at endpoint creation time.

    An endpoint is either in a published or an unpublished state. The publish methods can be used to start publishing an endpoint, at which point it starts accepting incoming requests. Conversely, the stop method can be used to stop accepting incoming requests and take the endpoint down. Once stopped, an endpoint cannot be published again.

    An Executor may be set on the endpoint in order to gain better control over the threads used to dispatch incoming requests. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the endpoint.

    Handler chains can be set using the contained Binding.

    An endpoint may have a list of metadata documents, such as WSDL and XMLSchema documents, bound to it. At publishing time, the JAX-WS implementation will try to reuse as much of that metadata as possible instead of generating new ones based on the annotations present on the implementor.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Binding, BindingType, SOAPBinding, Executor

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Endpoint()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Endpoint create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      abstract Binding getBinding()
      Returns the binding for this endpoint.
      abstract <T extends EndpointReference>
      T             		getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      abstract Executor getExecutor()
      Returns the executor for this Endpointinstance.
      abstract Object getImplementor()
      Returns the implementation object for this endpoint.
      abstract List<Source> getMetadata()
      Returns a list of metadata documents for the service.
      abstract Map<String,Object> getProperties()
      Returns the property bag for this Endpoint instance.
      abstract boolean isPublished()
      Returns true if the endpoint is in the published state.
      void publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(Object serverContext)
      Publishes this endpoint at the provided server context.
      abstract void publish(String address)
      Publishes this endpoint at the given address.
      static Endpoint publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      void setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Endpoint instance.
      abstract void setMetadata(List<Source> metadata)
      Sets the metadata for this endpoint.
      abstract void setProperties(Map<String,Object> properties)
      Sets the property bag for this Endpoint instance.
      abstract void stop()
      Stops publishing this endpoint.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • WSDL_SERVICE

        public static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

      • WSDL_PORT

        public static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Endpoint

        public Endpoint()

    • 方法详细信息

      • create

        public static Endpoint create(Object implementor)
        Creates an endpoint with the specified implementor object. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        参数：
        implementor - The endpoint implementor.
        返回：
        The newly created endpoint.

      • create

        public static Endpoint create(Object implementor,
              WebServiceFeature... features)
        Creates an endpoint with the specified implementor object and web service features. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        参数：
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        从以下版本开始：
        JAX-WS 2.2

      • create

        public static Endpoint create(String bindingId,
              Object implementor)
        Creates an endpoint with the specified binding type and implementor object.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        参数：
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        返回：
        The newly created endpoint.

      • create

        public static Endpoint create(String bindingId,
              Object implementor,
              WebServiceFeature... features)
        Creates an endpoint with the specified binding type, implementor object, and web service features.

        The newly created endpoint may be published by calling one of the publish(String) and publish(Object) methods.

        参数：
        bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        从以下版本开始：
        JAX-WS 2.2

      • getBinding

        public abstract Binding getBinding()
        Returns the binding for this endpoint.
        返回：
        The binding for this endpoint

      • getImplementor

        public abstract Object getImplementor()
        Returns the implementation object for this endpoint.
        返回：
        The implementor for this endpoint

      • publish

        public abstract void publish(String address)
        Publishes this endpoint at the given address. The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the publish(Object) method instead.
        参数：
        address - A URI specifying the address to use. The address MUST be compatible with the binding specified at the time the endpoint was created.
        抛出：
        IllegalArgumentException - If the provided address URI is not usable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
               Object implementor)
        Creates and publishes an endpoint for the specified implementor object at the given address.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        参数：
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        返回：
        The newly created endpoint.
        抛出：
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public static Endpoint publish(String address,
               Object implementor,
               WebServiceFeature... features)
        Creates and publishes an endpoint for the specified implementor object at the given address. The created endpoint is configured with the web service features.

        The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the create(String,Object) and publish(Object) methods instead.

        参数：
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - The endpoint implementor.
        features - A list of WebServiceFeature to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        抛出：
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        从以下版本开始：
        JAX-WS 2.2

      • publish

        public abstract void publish(Object serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.
        参数：
        serverContext - An object representing a server context to be used for publishing the endpoint.
        抛出：
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.

      • publish

        public void publish(HttpContext serverContext)
        Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it MUST be compatible with the endpoint's binding.

        This is meant for container developers to publish the the endpoints portably and not intended for the end developers.

        参数：
        serverContext - An object representing a server context to be used for publishing the endpoint.
        抛出：
        IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        SecurityException - If a java.lang.SecurityManger is being used and the application doesn't have the WebServicePermission("publishEndpoint") permission.
        从以下版本开始：
        JAX-WS 2.2

      • stop

        public abstract void stop()
        Stops publishing this endpoint. If the endpoint is not in a published state, this method has no effect.

      • isPublished

        public abstract boolean isPublished()
        Returns true if the endpoint is in the published state.
        返回：
        true if the endpoint is in the published state.

      • getMetadata

        public abstract List<Source> getMetadata()
        Returns a list of metadata documents for the service.
        返回：
        List<javax.xml.transform.Source> A list of metadata documents for the service

      • setMetadata

        public abstract void setMetadata(List<Source> metadata)
        Sets the metadata for this endpoint.
        参数：
        metadata - A list of XML document sources containing metadata information for the endpoint (e.g. WSDL or XML Schema documents)
        抛出：
        IllegalStateException - If the endpoint has already been published.

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Endpointinstance. The executor is used to dispatch an incoming request to the implementor object.
        返回：
        The java.util.concurrent.Executor to be used to dispatch a request.
        另请参见：
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Endpoint instance. The executor is used to dispatch an incoming request to the implementor object. If this Endpoint is published using the publish(Object) method and the specified server context defines its own threading behavior, the executor may be ignored.
        参数：
        executor - The java.util.concurrent.Executor to be used to dispatch a request.
        抛出：
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        另请参见：
        Executor

      • getProperties

        public abstract Map<String,Object> getProperties()
        Returns the property bag for this Endpoint instance.
        返回：
        Map<String,Object> The property bag associated with this instance.

      • setProperties

        public abstract void setProperties(Map<String,Object> properties)
        Sets the property bag for this Endpoint instance.
        参数：
        properties - The property bag associated with this instance.

      • getEndpointReference

        public abstract EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        参数：
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        返回：
        EndpointReference of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        抛出：
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        W3CEndpointReference

      • getEndpointReference

        public abstract <T extends EndpointReference> T getEndpointReference(类<T> clazz,
                                                   Element... referenceParameters)
        Returns the EndpointReference associated with this Endpoint instance.
        参数：
        clazz - Specifies the type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        返回：
        EndpointReference of type clazz of this Endpoint instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        抛出：
        WebServiceException - If any error in the creation of the EndpointReference or if the Endpoint is not in the published state or if the clazz is not a supported EndpointReference type.
        UnsupportedOperationException - If this BindingProvider uses the XML/HTTP binding.
        从以下版本开始：
        JAX-WS 2.1

      • setEndpointContext

        public void setEndpointContext(EndpointContext ctxt)
        By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application. If multiple endpoints share different ports of a WSDL, then the multiple port addresses are patched when the WSDL is accessed.

        This needs to be set before publishing the endpoints.

        参数：
        ctxt - that is shared for multiple endpoints
        抛出：
        IllegalStateException - If the endpoint has been published already or it has been stopped.
        从以下版本开始：
        JAX-WS 2.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EndpointContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 EndpointContext

  • java.lang.Object
    • javax.xml.ws.EndpointContext

  • public abstract class EndpointContext
extends Object
    EndpointContext allows multiple endpoints in an application to share any information. For example, servlet application's war may contain multiple endpoints and these endpoints can get addresses of each other by sharing this context. If multiple endpoints share different ports of a WSDL, then the multiple port addresses can be patched when the WSDL is accessed. It also allows all endpoints to share any other runtime information.

    This needs to be set by using Endpoint.setEndpointContext(javax.xml.ws.EndpointContext) before Endpoint.publish(java.lang.String) methods.

    从以下版本开始：
    JAX-WS 2.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      EndpointContext()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Set<Endpoint> getEndpoints()
      This gives list of endpoints in an application.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • EndpointContext

        public EndpointContext()

    • 方法详细信息

      • getEndpoints

        public abstract Set<Endpoint> getEndpoints()
        This gives list of endpoints in an application. For e.g in servlet container, a war file may contain multiple endpoints. In case of http, these endpoints are hosted on the same http server.
        返回：
        list of all endpoints in an application
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

idnsRtcetcokkcoosd>>"h.f...xtg.eopp/pm/


EndpointReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 EndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
  • 直接已知子类：
    W3CEndpointReference

    public abstract class EndpointReference
extends Object
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint. See Web Services Addressing 1.0 - Core for more information on WS-Addressing EndpointReferences.

    This class is immutable as the typical web service developer need not be concerned with its contents. The web service developer should use this class strictly as a mechanism to reference a remote web service endpoint. See the Service APIs that clients can use to that utilize an EndpointReference. See the Endpoint, and BindingProvider APIs on how EndpointReferences can be created for published endpoints.

    Concrete implementations of this class will represent an EndpointReference for a particular version of Addressing. For example the W3CEndpointReference is for use with W3C Web Services Addressing 1.0 - Core Recommendation. If JAX-WS implementors need to support different versions of addressing, they should write their own EndpointReference subclass for that version. This will allow a JAX-WS implementation to create a vendor specific EndpointReferences that the vendor can use to flag a different version of addressing.

    Web service developers that wish to pass or return EndpointReference in Java methods in an SEI should use concrete instances of an EndpointReference such as the W3CEndpointReference. This way the schema mapped from the SEI will be more descriptive of the type of endpoint reference being passed.

    JAX-WS implementors are expected to extract the XML infoset from an EndpointReferece using the writeTo(javax.xml.transform.Result) method.

    JAXB will bind this class to xs:anyType. If a better binding is desired, web services developers should use a concrete subclass such as W3CEndpointReference.

    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    W3CEndpointReference, Service

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | EndpointReference()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <T> T getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static EndpointReference readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      String toString()
      Displays EPR infoset for debugging convenience.
      abstract void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • EndpointReference

        protected EndpointReference()

    • 方法详细信息

      • readFrom

        public static EndpointReference readFrom(Source eprInfoset)
        Factory method to read an EndpointReference from the infoset contained in eprInfoset. This method delegates to the vendor specific implementation of the Provider.readEndpointReference(javax.xml.transform.Source) method.
        参数：
        eprInfoset - The EndpointReference infoset to be unmarshalled
        返回：
        the EndpointReference unmarshalled from eprInfoset never null
        抛出：
        WebServiceException - if an error occurs while creating the EndpointReference from the eprInfoset
        IllegalArgumentException - if the null eprInfoset value is given.

      • writeTo

        public abstract void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        参数：
        result - for writing infoset
        抛出：
        WebServiceException - if there is an error writing the EndpointReference to the specified result.
        IllegalArgumentException - If the null result value is given.

      • getPort

        public <T> T getPort(类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the EndpointReference instance, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The EndpointReference instance specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL Metadata from this EndpointReference or from annotations on the serviceEndpointInterface. For this method to successfully return a proxy, WSDL metadata MUST be available and the EndpointReference instance MUST contain an implementation understood serviceName metadata.

        Because this port is not created from a Service object, handlers will not automatically be configured, and the HandlerResolver and Executor cannot be get or set for this port. The BindingProvider().getBinding().setHandlerChain() method can be used to manually configure handlers for this port.

        参数：
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If this endpointReference is invalid
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        另请参见：
        Proxy, WebServiceFeature

      • toString

        public String toString()
        Displays EPR infoset for debugging convenience.
        重载：
        toString in class Object
        返回：
        a string representation of the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

./.e.a..l ">ssn=>vva lgc"


FaultAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type FaultAction

  • @Documented
@Retention(value=RUNTIME)
@Target(value=方法)
public @interface FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.

    The wsam:Action attribute value in the fault message in the generated WSDL operation mapped for className class is equal to the corresponding value in the FaultAction. For the exact computation of wsam:Action values for the fault messages, refer to the algorithm in the JAX-WS specification.

    Example 1: Specify explicit values for Action message addressing property for the input, output and fault message if the Java method throws only one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/faultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:AddNumbersException" name="AddNumbersException"
           wsam:Action="http://example.com/faultAction"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 2: Here is an example that shows if the explicit value for Action message addressing property for the service specific exception is not present.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     public int addNumbers(int number1, int number2)
         throws AddNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="InvalidNumbers"
           wsam:Action="http://example.com/numbers/AddNumbersPortType/AddNumbers/Fault/AddNumbersException"/>
       </operation>
     </portType>
     ...
   </definitions>

    Example 3: Here is an example that shows how to specify explicit values for Action message addressing property if the Java method throws more than one service specific exception.

     @WebService(targetNamespace="http://example.com/numbers")
 public class AddNumbersImpl {
     @Action(
         fault = {
             @FaultAction(className=AddNumbersException.class, value="http://example.com/addFaultAction"),
             @FaultAction(className=TooBigNumbersException.class, value="http://example.com/toobigFaultAction")
         })
     public int addNumbers(int number1, int number2)
         throws AddNumbersException, TooBigNumbersException {
         return number1 + number2;
     }
 }
    The generated WSDL looks like:
       <definitions targetNamespace="http://example.com/numbers" ...>
     ...
     <portType name="AddNumbersPortType">
       <operation name="AddNumbers">
         ...
         <fault message="tns:addNumbersFault" name="AddNumbersException"
           wsam:Action="http://example.com/addFaultAction"/>
         <fault message="tns:tooBigNumbersFault" name="TooBigNumbersException"
           wsam:Action="http://example.com/toobigFaultAction"/>
       </operation>
     </portType>
     ...
   </definitions>
    从以下版本开始：
    JAX-WS 2.1

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      类<? extends Exception> className
      Name of the exception class

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String value
      Value of WS-Addressing Action message addressing property for the exception

    • Element Detail

      • className

        public abstract 类<? extends Exception> className
        Name of the exception class

      • value

        public abstract String value
        Value of WS-Addressing Action message addressing property for the exception
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x m "ltcltilltiimpbb=ana.eeb


Holder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.ws

类 Holder<T>

  • java.lang.Object
    • javax.xml.ws.Holder<T>
  • 所有已实现的接口：
    Serializable

    public final class Holder<T>
extends Object
implements Serializable
    Holds a value of type T.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      T value
      The value contained in the holder.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Holder()
      Creates a new holder with a null value.
      Holder(T value)
      Create a new holder with the specified value.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public T value
        The value contained in the holder.

    • 构造方法详细信息

      • Holder

        public Holder()
        Creates a new holder with a null value.

      • Holder

        public Holder(T value)
        Create a new holder with the specified value.
        参数：
        value - The value to be stored in the holder.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ed/afaelaerfferr>/eel>lre...a.h


javax.xml.ws

Interfaces

  • AsyncHandler
  • Binding
  • BindingProvider
  • Dispatch
  • LogicalMessage
  • Provider
  • Response
  • WebServiceContext

Classes

  • Endpoint
  • EndpointContext
  • EndpointReference
  • Holder
  • RespectBindingFeature
  • Service
  • WebServiceFeature
  • WebServicePermission

Enums

  • Service.Mode

Exceptions

  • ProtocolException
  • WebServiceException

Annotation Types

  • Action
  • BindingType
  • FaultAction
  • RequestWrapper
  • RespectBinding
  • ResponseWrapper
  • ServiceMode
  • WebEndpoint
  • WebFault
  • WebServiceClient
  • WebServiceProvider
  • WebServiceRef
  • WebServiceRefs
/


javax.xml.ws

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws

This package contains the core JAX-WS APIs.

请参见： 描述

  • 接口摘要
    接口 描述
    AsyncHandler<T>
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch<T>
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    Provider<T>
    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.
    Response<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
  • Class Summary
    类 描述
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Holder<T>
    Holds a value of type T.
    RespectBindingFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    Service
    Service objects provide the client view of a Web service.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
    WebServicePermission
    This class defines web service permissions.
  • Enum Summary
    Enum 描述
    Service.Mode
    The orientation of a dynamic client or service.
  • Exception Summary
    Exception 描述
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Annotation Types Summary
    Annotation Type 描述
    Action
    The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.
    BindingType
    The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
    FaultAction
    The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.
    RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.
    RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
    ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.
    ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.
    WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    WebServiceClient
    Used to annotate a generated service interface.
    WebServiceProvider
    Used to annotate a Provider implementation class.
    WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.
    WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

软件包 javax.xml.ws Description

This package contains the core JAX-WS APIs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eSc/ laj/allj.dd/fe>�>o/


javax.xml.ws Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointContext
    • javax.xml.ws.EndpointReference
    • javax.xml.ws.Holder<T> (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
    • javax.xml.ws.Service
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

Interface Hierarchy

  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.xml.ws.LogicalMessage
  • javax.xml.ws.Provider<T>
  • javax.xml.ws.WebServiceContext

Annotation Type Hierarchy

  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.Service.Mode
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> =da< tttte>>."eens


LogicalMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface LogicalMessage

  • public interface LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Source getPayload()
      Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
      Object getPayload(JAXBContext context)
      Gets the message payload as a JAXB object.
      void setPayload(Object payload, JAXBContext context)
      Sets the message payload
      void setPayload(Source payload)
      Sets the message payload

    • 方法详细信息

      • getPayload

        Source getPayload()
        Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

        If the returned Source is an instance of DOMSource, then modifications to the encapsulated DOM tree change the message payload in-place, there is no need to susequently call setPayload. Other types of Source provide only read access to the message payload.

        返回：
        The contained message payload; returns null if no payload is present in this message.

      • setPayload

        void setPayload(Source payload)
        Sets the message payload
        参数：
        payload - message payload
        抛出：
        WebServiceException - If any error during the setting of the payload in this message
        UnsupportedOperationException - If this operation is not supported

      • getPayload

        Object getPayload(JAXBContext context)
        Gets the message payload as a JAXB object. Note that there is no connection between the returned object and the message payload, changes to the payload require calling setPayload.
        参数：
        context - The JAXBContext that should be used to unmarshall the message payload
        返回：
        The contained message payload; returns null if no payload is present in this message
        抛出：
        WebServiceException - If an error occurs when using a supplied JAXBContext to unmarshall the payload. The cause of the WebServiceException is the original JAXBException.

      • setPayload

        void setPayload(Object payload,
              JAXBContext context)
        Sets the message payload
        参数：
        payload - message payload
        context - The JAXBContext that should be used to marshall the payload
        抛出：
        UnsupportedOperationException - If this operation is not supported
        WebServiceException - If an error occurs when using the supplied JAXBContext to marshall the payload. The cause of the WebServiceException is the original JAXBException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uamevedecep ocuai嗡薾u/pg.pbeezs="


ProtocolException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.ws

类 ProtocolException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    HTTPException, SOAPFaultException

    public class ProtocolException
extends WebServiceException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding. Subclasses are used to communicate protocol level fault information to clients and may be used on the server to control the protocol specific fault representation.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      ProtocolException()
      Constructs a new protocol exception with null as its detail message.
      ProtocolException(String message)
      Constructs a new protocol exception with the specified detail message.
      ProtocolException(String message, Throwable cause)
      Constructs a new runtime exception with the specified detail message and cause.
      ProtocolException(Throwable cause)
      Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ProtocolException

        public ProtocolException()
        Constructs a new protocol exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

      • ProtocolException

        public ProtocolException(String message)
        Constructs a new protocol exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).
        参数：
        message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

      • ProtocolException

        public ProtocolException(String message,
                 Throwable cause)
        Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.
        参数：
        message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

      • ProtocolException

        public ProtocolException(Throwable cause)
        Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.
        参数：
        cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/s === < =- ==-=VOOd a>m vp- nyanslN


Provider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface Provider<T>

  • public interface Provider<T>

    Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.

    Implementations are required to support Provider<Source>, Provider<SOAPMessage> and Provider<DataSource>, depending on the binding in use and the service mode.

    The ServiceMode annotation can be used to control whether the Provider instance will receive entire protocol messages or just message payloads.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Source, SOAPMessage, ServiceMode

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      T invoke(T request)
      Invokes an operation occording to the contents of the request message.

    • 方法详细信息

      • invoke

        T invoke(T request)
        Invokes an operation occording to the contents of the request message.
        参数：
        request - The request message or message payload.
        返回：
        The response message or message payload. May be null if there is no response.
        抛出：
        WebServiceException - If there is an error processing request. The cause of the WebServiceException may be set to a subclass of ProtocolException to control the protocol level representation of the exception.
        另请参见：
        MessageContext, ProtocolException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e">t)> "> ,ii ,,(taa.",=fa/)(ttbjbaa


RequestWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type RequestWrapper

  • @Target(value=方法)
@Retention(value=RUNTIME)
@Documented
public @interface RequestWrapper
    Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime. The default value of the localName is the operationName, as defined in WebMethod annotation and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String className
      Request wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Request wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        从以下版本开始：
        JAX-WS 2.2
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hthn d


RespectBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type RespectBinding

  • @Target(value={TYPE,方法,字段})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="javax.xml.ws.RespectBindingFeature",
                             bean=RespectBindingFeature.class)
public @interface RespectBinding
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the RespectBinding annotation.

    This annotation's behaviour is defined by the corresponding feature RespectBindingFeature.

    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    RespectBindingFeature

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l i/b/&/


RespectBindingFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 RespectBindingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.RespectBindingFeature

  • public final class RespectBindingFeature
extends WebServiceFeature
    This feature clarifies the use of the wsdl:binding in a JAX-WS runtime. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    This feature is only useful with web services that have an associated WSDL. Enabling this feature requires that a JAX-WS implementation inspect the wsdl:binding for an endpoint at runtime to make sure that all wsdl:extensions that have the required attribute set to true are understood and are being used.

    The following describes the affects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, a JAX-WS runtime MUST assure that all required wsdl:binding extensions(including policies) are either understood and used by the runtime, or explicitly disabled by the web service application. A web service can disable a particular extension if there is a corresponding WebServiceFeature or annotation. Similarly, a web service client can disable particular extension using the corresponding WebServiceFeature while creating a proxy or Dispatch instance. The runtime MUST also make sure that binding of SEI parameters/return values respect the wsdl:binding. With this feature enabled, if a required (wsdl:required="true") wsdl:binding extension is in the WSDL and it is not supported by a JAX-WS runtime and it has not been explicitly turned off by the web service developer, then that JAX-WS runtime MUST behave appropriately based on whether it is on the client or server:
      • Client: runtime MUST throw a WebServiceException no sooner than when one of the methods above is invoked but no later than the first invocation of an endpoint operation.
      • Server: throw a WebServiceException and the endpoint MUST fail to deploy
    • DISABLED: In this Mode, an implementation may choose whether to inspect the wsdl:binding or not and to what degree the wsdl:binding will be inspected. For example, one implementation may choose to behave as if this feature is enabled, another implementation may only choose to verify the SEI's parameter/return type bindings.
    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    AddressingFeature

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ID
      Constant value identifying the RespectBindingFeature

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • 构造方法摘要

      Constructors
      构造方法与描述
      RespectBindingFeature()
      Creates an RespectBindingFeature.
      RespectBindingFeature(boolean enabled)
      Creates an RespectBindingFeature

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getID()
      Get the unique identifier for this WebServiceFeature.

      • 方法 - 继承于类 javax.xml.ws.WebServiceFeature

        isEnabled

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ID

        public static final String ID
        Constant value identifying the RespectBindingFeature
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • RespectBindingFeature

        public RespectBindingFeature()
        Creates an RespectBindingFeature. The instance created will be enabled.

      • RespectBindingFeature

        public RespectBindingFeature(boolean enabled)
        Creates an RespectBindingFeature
        参数：
        enabled - specifies whether this feature should be enabled or not.

    • 方法详细信息

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        指定者：
        getID in class WebServiceFeature
        返回：
        the unique identifier for this feature.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s3ftidisiniifltkn/髓辱祄乃酶档藇avv"lo a�


Response

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface Response<T>

  • All Superinterfaces:
    Future<T>

    public interface Response<T>
extends Future<T>
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.

    For asynchronous operation invocations it provides additional methods to check the status of the request. The get(...) methods may throw the standard set of exceptions and their cause may be a RemoteException or a WebServiceException that represents the error that occured during the asynchronous method invocation.

    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Map<String,Object> getContext()
      Gets the contained response context.

      • 方法 - 继承于接口 java.util.concurrent.Future

        cancel, get, get, isCancelled, isDone

    • 方法详细信息

      • getContext

        Map<String,Object> getContext()
        Gets the contained response context.
        返回：
        The contained response context. May be null if a response is not yet available.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>cbmrwarweSSweevc//"= alcmdnncnc<


ResponseWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type ResponseWrapper

  • @Target(value=方法)
@Retention(value=RUNTIME)
@Documented
public @interface ResponseWrapper
    Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime. The default value of the localName is the operationName as defined in WebMethod annotation appended with Response and the targetNamespace is the target namespace of the SEI.

    When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String className
      Response wrapper bean name.
      String localName
      Element's local name.
      String partName
      wsdl:part name for the wrapper part
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • localName

        public abstract String localName
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • className

        public abstract String className
        Response wrapper bean name.
        Default:
        ""

      • partName

        public abstract String partName
        wsdl:part name for the wrapper part
        从以下版本开始：
        JAX-WS 2.2
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>n jhOecgn..gnnvcee>ilov�


Service

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 Service

  • java.lang.Object
    • javax.xml.ws.Service

  • public class Service
extends Object
    Service objects provide the client view of a Web service.

    Service acts as a factory of the following:

    • Proxies for a target service endpoint.
    • Instances of Dispatch for dynamic message-oriented invocation of a remote operation.

    The ports available on a service can be enumerated using the getPorts method. Alternatively, you can pass a service endpoint interface to the unary getPort method and let the runtime select a compatible port.

    Handler chains for all the objects created by a Service can be set by means of a HandlerResolver.

    An Executor may be set on the service in order to gain better control over the threads used to dispatch asynchronous callbacks. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the service.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Provider, HandlerResolver, Executor

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  Service.Mode
      The orientation of a dynamic client or service.

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | Service(URL wsdlDocumentLocation, QName serviceName)
      protected | Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      static Service create(QName serviceName)
      Creates a Service instance.
      static Service create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Executor getExecutor()
      Returns the executor for this Serviceinstance.
      HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      <T> T getPort(类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, 类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      <T> T getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      QName getServiceName()
      Gets the name of this service.
      URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Service

        protected Service(URL wsdlDocumentLocation,
       QName serviceName)

      • Service

        protected Service(URL wsdlDocumentLocation,
       QName serviceName,
       WebServiceFeature... features)

    • 方法详细信息

      • getPort

        public <T> T getPort(QName portName,
            类<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        参数：
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        返回：
        Object Proxy instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        另请参见：
        Proxy, InvocationHandler

      • getPort

        public <T> T getPort(QName portName,
            类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        参数：
        portName - Qualified name of the service endpoint in the WSDL service description.
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy instance.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface or portName is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public <T> T getPort(类<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        参数：
        serviceEndpointInterface - Service endpoint interface.
        返回：
        Object instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.

      • getPort

        public <T> T getPort(类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        参数：
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If an illegal serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        WebServiceFeature

      • getPort

        public <T> T getPort(EndpointReference endpointReference,
            类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1

      • addPort

        public void addPort(QName portName,
           String bindingId,
           String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        参数：
        portName - Qualified name for the target service endpoint.
        bindingId - A String identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI.
        抛出：
        WebServiceException - If any error in the creation of the port.
        另请参见：
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                             类<T> type,
                             Service.Mode mode)
        Creates a Dispatch instance for use with objects of the client's choosing.
        参数：
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source, javax.xml.soap.SOAPMessage and javax.activation.DataSource, depending on the binding in use.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        返回：
        Dispatch instance.
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object.
        另请参见：
        Source, SOAPMessage

      • createDispatch

        public <T> Dispatch<T> createDispatch(QName portName,
                             类<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing.
        参数：
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance.
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                             类<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the client's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        参数：
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        返回：
        Dispatch instance.
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object.
        另请参见：
        JAXBContext

      • createDispatch

        public Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        参数：
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance.
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        JAXBContext, WebServiceFeature

      • createDispatch

        public Dispatch<Object> createDispatch(EndpointReference endpointReference,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the client will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the client will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        JAXBContext, WebServiceFeature

      • getServiceName

        public QName getServiceName()
        Gets the name of this service.
        返回：
        Qualified name of this service

      • getPorts

        public Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        返回：
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName.
        抛出：
        WebServiceException - If this Service class does not have access to the required WSDL metadata.

      • getWSDLDocumentLocation

        public URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        返回：
        URL for the location of the WSDL document for this service.

      • getHandlerResolver

        public HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        返回：
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        参数：
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        另请参见：
        HandlerResolver

      • getExecutor

        public Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        返回：
        The java.util.concurrent.Executor to be used to invoke a callback.
        另请参见：
        Executor

      • setExecutor

        public void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        参数：
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        抛出：
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        另请参见：
        Executor

      • create

        public static Service create(URL wsdlDocumentLocation,
             QName serviceName)
        Creates a Service instance. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        参数：
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        抛出：
        WebServiceException - If any error in creation of the specified service.

      • create

        public static Service create(URL wsdlDocumentLocation,
             QName serviceName,
             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features. The specified WSDL document location and service qualified name MUST uniquely identify a wsdl:service element.
        参数：
        wsdlDocumentLocation - URL for the WSDL document location for the service
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        抛出：
        WebServiceException - If any error in creation of the specified service.
        从以下版本开始：
        JAX-WS 2.2

      • create

        public static Service create(QName serviceName)
        Creates a Service instance.
        参数：
        serviceName - QName for the service
        抛出：
        WebServiceException - If any error in creation of the specified service

      • create

        public static Service create(QName serviceName,
             WebServiceFeature... features)
        Creates a Service instance. The created instance is configured with the web service features.
        参数：
        serviceName - QName for the service
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        抛出：
        WebServiceException - If any error in creation of the specified service
        从以下版本开始：
        JAX-WS 2.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Service.Mode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.ws

Enum Service.Mode

  • java.lang.Object
    • java.lang.Enum<Service.Mode>
      • javax.xml.ws.Service.Mode
  • 所有已实现的接口：
    Serializable, Comparable<Service.Mode>
    封闭类：
    Service

    public static enum Service.Mode
extends Enum<Service.Mode>
    The orientation of a dynamic client or service. MESSAGE provides access to entire protocol message, PAYLOAD to protocol message payload only.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      MESSAGE
      PAYLOAD

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Service.Mode valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • MESSAGE

        public static final Service.Mode MESSAGE

      • PAYLOAD

        public static final Service.Mode PAYLOAD

    • 方法详细信息

      • values

        public static Service.Mode[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (Service.Mode c : Service.Mode.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static Service.Mode valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.ma.../.."...""hottn.(l..xageeQmmcam


ServiceMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type ServiceMode

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Inherited
@Documented
public @interface ServiceMode
    Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      Service.Mode value
      Service mode.

    • Element Detail

      • value

        public abstract Service.Mode value
        Service mode. PAYLOAD indicates that the Provider implementation wishes to work with protocol message payloads only. MESSAGE indicates that the Provider implementation wishes to work with entire protocol messages.
        Default:
        javax.xml.ws.Service.Mode.PAYLOAD
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r>e& iafiatttattl


Uses of Package javax.xml.ws

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws

  • Packages that use javax.xml.ws
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws used by javax.xml.ws
    类与描述
    AsyncHandler
    The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    BindingProvider
    The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointContext
    EndpointContext allows multiple endpoints in an application to share any information.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Response
    The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.handler
    类与描述
    LogicalMessage
    The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
  • Classes in javax.xml.ws used by javax.xml.ws.http
    类与描述
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
  • Classes in javax.xml.ws used by javax.xml.ws.soap
    类与描述
    Binding
    The Binding interface is the base interface for JAX-WS protocol bindings.
    ProtocolException
    The ProtocolException class is a base class for exceptions related to a specific protocol binding.
    WebServiceException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.spi
    类与描述
    Dispatch
    The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
    Endpoint
    A Web service endpoint.
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
    Service
    Service objects provide the client view of a Web service.
    Service.Mode
    The orientation of a dynamic client or service.
    WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
    WebServiceFeature
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
  • Classes in javax.xml.ws used by javax.xml.ws.wsaddressing
    类与描述
    EndpointReference
    This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AiRMF O FOT OE--srovtti


WebEndpoint

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebEndpoint

  • @Target(value=方法)
@Retention(value=RUNTIME)
@Documented
public @interface WebEndpoint
    Used to annotate the getPortName() methods of a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:port element inside a wsdl:service. The latter is determined based on the value of the WebServiceClient annotation on the generated service interface itself.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    WebServiceClient

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      The local name of the endpoint.

    • Element Detail

      • name

        public abstract String name
        The local name of the endpoint.
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nno3e3p3t31/tro>m/>l//.


WebFault

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebFault

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebFault
    Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String faultBean
      Fault bean name.
      String messageName
      wsdl:Message's name.
      String name
      Element's local name.
      String targetNamespace
      Element's namespace name.

    • Element Detail

      • name

        public abstract String name
        Element's local name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Element's namespace name.
        Default:
        ""

      • faultBean

        public abstract String faultBean
        Fault bean name.
        Default:
        ""

      • messageName

        public abstract String messageName
        wsdl:Message's name. Default name is the exception's class name.
        从以下版本开始：
        JAX-WS 2.2
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"rr>slxmvedrnnn( /<


WebServiceClient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebServiceClient

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceClient
    Used to annotate a generated service interface.

    The information specified in this annotation is sufficient to uniquely identify a wsdl:service element inside a WSDL document. This wsdl:service element represents the Web service for which the generated service interface provides a client view.

    从以下版本开始：
    JAX-WS 2.0

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String name
      The local name of the Web service.
      String targetNamespace
      The namespace for the Web service.
      String wsdlLocation
      The location of the WSDL document for the service (a URL).

    • Element Detail

      • name

        public abstract String name
        The local name of the Web service.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        The namespace for the Web service.
        Default:
        ""

      • wsdlLocation

        public abstract String wsdlLocation
        The location of the WSDL document for the service (a URL).
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rdeicinioiasmordi e眗.t7"�


WebServiceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws

Interface WebServiceContext

  • public interface WebServiceContext
    A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served. Typically a WebServiceContext is injected into an endpoint implementation class using the Resource annotation.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Resource

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      <T extends EndpointReference>
      T             		getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      EndpointReference getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      MessageContext getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.
      Principal getUserPrincipal()
      Returns the Principal that identifies the sender of the request currently being serviced.
      boolean isUserInRole(String role)
      Returns a boolean indicating whether the authenticated user is included in the specified logical role.

    • 方法详细信息

      • getMessageContext

        MessageContext getMessageContext()
        Returns the MessageContext for the request being served at the time this method is called. Only properties with APPLICATION scope will be visible to the application.
        返回：
        MessageContext The message context.
        抛出：
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        另请参见：
        MessageContext, MessageContext.Scope, IllegalStateException

      • getUserPrincipal

        Principal getUserPrincipal()
        Returns the Principal that identifies the sender of the request currently being serviced. If the sender has not been authenticated, the method returns null.
        返回：
        Principal The principal object.
        抛出：
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        另请参见：
        Principal, IllegalStateException

      • isUserInRole

        boolean isUserInRole(String role)
        Returns a boolean indicating whether the authenticated user is included in the specified logical role. If the user has not been authenticated, the method returns false.
        参数：
        role - A String specifying the name of the role
        返回：
        a boolean indicating whether the sender of the request belongs to a given role
        抛出：
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.

      • getEndpointReference

        EndpointReference getEndpointReference(Element... referenceParameters)
        Returns the EndpointReference for this endpoint.

        If the Binding for this bindingProvider is either SOAP1.1/HTTP or SOAP1.2/HTTP, then a W3CEndpointReference MUST be returned.

        参数：
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        返回：
        EndpointReference of the endpoint associated with this WebServiceContext. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        抛出：
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        W3CEndpointReference

      • getEndpointReference

        <T extends EndpointReference> T getEndpointReference(类<T> clazz,
                                                   Element... referenceParameters)
        Returns the EndpointReference associated with this endpoint.
        参数：
        clazz - The type of EndpointReference that MUST be returned.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        返回：
        EndpointReference of type clazz of the endpoint associated with this WebServiceContext instance. If the returned EndpointReference is of type W3CEndpointReference then it MUST contain the the specified referenceParameters.
        抛出：
        IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
        WebServiceException - If the clazz type of EndpointReference is not supported.
        从以下版本开始：
        JAX-WS 2.1
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s=sOc/n


WebServiceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.ws

类 WebServiceException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    ProtocolException

    public class WebServiceException
extends RuntimeException
    The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      WebServiceException()
      Constructs a new exception with null as its detail message.
      WebServiceException(String message)
      Constructs a new exception with the specified detail message.
      WebServiceException(String message, Throwable cause)
      Constructs a new exception with the specified detail message and cause.
      WebServiceException(Throwable cause)
      Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WebServiceException

        public WebServiceException()
        Constructs a new exception with null as its detail message. The cause is not initialized.

      • WebServiceException

        public WebServiceException(String message)
        Constructs a new exception with the specified detail message. The cause is not initialized.
        参数：
        message - The detail message which is later retrieved using the getMessage method

      • WebServiceException

        public WebServiceException(String message,
                   Throwable cause)
        Constructs a new exception with the specified detail message and cause.
        参数：
        message - The detail message which is later retrieved using the getMessage method
        cause - The cause which is saved for the later retrieval throw by the getCause method

      • WebServiceException

        public WebServiceException(Throwable cause)
        Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
        参数：
        cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laiseeh >l>h箃tmie.-r


WebServiceFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws

类 WebServiceFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
  • 直接已知子类：
    AddressingFeature, MTOMFeature, RespectBindingFeature

    public abstract class WebServiceFeature
extends Object
    A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.

    The JAX-WS specification will define some standard features and JAX-WS implementors are free to define additional features if necessary. Vendor specific features may not be portable so caution should be used when using them. Each Feature definition MUST define a public static final String ID that can be used in the Feature annotation to refer to the feature. This ID MUST be unique across all features of all vendors. When defining a vendor specific feature ID, use a vendor specific namespace in the ID string.

    从以下版本开始：
    2.1
    另请参见：
    RespectBindingFeature, AddressingFeature, MTOMFeature

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      protected boolean enabled
      Specifies if the feature is enabled or disabled

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | WebServiceFeature()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String getID()
      Get the unique identifier for this WebServiceFeature.
      boolean isEnabled()
      Returns true if this feature is enabled.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • enabled

        protected boolean enabled
        Specifies if the feature is enabled or disabled

    • 构造方法详细信息

      • WebServiceFeature

        protected WebServiceFeature()

    • 方法详细信息

      • getID

        public abstract String getID()
        Get the unique identifier for this WebServiceFeature.
        返回：
        the unique identifier for this feature.

      • isEnabled

        public boolean isEnabled()
        Returns true if this feature is enabled.
        返回：
        true if and only if the feature is enabled .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-i-papap!pi"l


WebServicePermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.ws

类 WebServicePermission

  • java.lang.Object
    • java.security.Permission
      • java.security.BasicPermission
        • javax.xml.ws.WebServicePermission
  • 所有已实现的接口：
    Serializable, Guard

    public final class WebServicePermission
extends BasicPermission
    This class defines web service permissions.

    Web service Permissions are identified by name (also referred to as a "target name") alone. There are no actions associated with them.

    The following permission target name is defined:

    publishEndpoint

    The publishEndpoint permission allows publishing a web service endpoint using the publish methods defined by the javax.xml.ws.Endpoint class.

    另请参见：
    Endpoint, BasicPermission, Permission, Permissions, SecurityManager, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      WebServicePermission(String name)
      Creates a new permission with the specified name.
      WebServicePermission(String name, String actions)
      Creates a new permission with the specified name and actions.

    • 方法摘要

      • 方法 - 继承于类 java.security.BasicPermission

        equals, getActions, hashCode, implies, newPermissionCollection

      • 方法 - 继承于类 java.security.Permission

        checkGuard, getName, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WebServicePermission

        public WebServicePermission(String name)
        Creates a new permission with the specified name.
        参数：
        name - the name of the WebServicePermission

      • WebServicePermission

        public WebServicePermission(String name,
                    String actions)
        Creates a new permission with the specified name and actions. The actions parameter is currently unused and it should be null.
        参数：
        name - the name of the WebServicePermission
        actions - should be null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i癳 p c v lvrvisetee⒚鋈枋拭枨魃侣刺<


WebServiceProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebServiceProvider

  • @Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceProvider
    Used to annotate a Provider implementation class.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Provider

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String portName
      Port name.
      String serviceName
      Service name.
      String targetNamespace
      Target namespace for the service
      String wsdlLocation
      Location of the WSDL description for the service.

    • Element Detail

      • wsdlLocation

        public abstract String wsdlLocation
        Location of the WSDL description for the service.
        Default:
        ""

      • serviceName

        public abstract String serviceName
        Service name.
        Default:
        ""

      • targetNamespace

        public abstract String targetNamespace
        Target namespace for the service
        Default:
        ""

      • portName

        public abstract String portName
        Port name.
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

><< >> lll/m>coiC


WebServiceRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebServiceRef

  • @Target(value={TYPE,方法,字段})
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceRef
    The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it. It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techinques can be used to support multiple threads.

    Web service references are resources in the Java EE 5 sense. The annotations (for example, Addressing) annotated with meta-annotation WebServiceFeatureAnnotation can be used in conjunction with WebServiceRef. The created reference MUST be configured with annotation's web service feature.

    For example, in the code below, the injected StockQuoteProvider proxy MUST have WS-Addressing enabled as specifed by the Addressing annotation.

        public class MyClient {
       @Addressing
       @WebServiceRef(StockQuoteService.class)
       private StockQuoteProvider stockQuoteProvider;
       ...
    }

    If a JAX-WS implementation encounters an unsupported or unrecognized annotation annotated with the WebServiceFeatureAnnotation that is specified with WebServiceRef, an ERROR MUST be given.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Resource, WebServiceFeatureAnnotation

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      String lookup
      A portable JNDI lookup name that resolves to the target web service reference.
      String mappedName
      A product specific name that this resource should be mapped to.
      String name
      The JNDI name of the resource.
      类<?> type
      The Java type of the resource.
      类<? extends Service> value
      The service class, alwiays a type extending javax.xml.ws.Service.
      String wsdlLocation
      A URL pointing to the WSDL document for the web service.

    • Element Detail

      • name

        public abstract String name
        The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this MUST be specified. The JNDI name can be absolute(with any logical namespace) or relative to JNDI java:comp/env namespace.
        Default:
        ""

      • type

        public abstract 类<?> type
        The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this MUST be specified.
        Default:
        java.lang.Object.class

      • mappedName

        public abstract String mappedName
        A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (When a relative JNDI name is specified, then it's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

        Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

        Default:
        ""

      • value

        public abstract 类<? extends Service> value
        The service class, alwiays a type extending javax.xml.ws.Service. This element MUST be specified whenever the type of the reference is a service endpoint interface.
        Default:
        javax.xml.ws.Service.class

      • wsdlLocation

        public abstract String wsdlLocation
        A URL pointing to the WSDL document for the web service. If not specified, the WSDL location specified by annotations on the resource type is used instead.
        Default:
        ""

      • lookup

        public abstract String lookup
        A portable JNDI lookup name that resolves to the target web service reference.
        从以下版本开始：
        JAX-WS 2.2
        Default:
        ""
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

isoErEsEtEefpecci/jj.Lwenc


WebServiceRefs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws

Annotation Type WebServiceRefs

  • @Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebServiceRefs
    The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

    It can be used to inject both service and proxy instances. These injected references are not thread safe. If the references are accessed by multiple threads, usual synchronization techinques can be used to support multiple threads.

    There is no way to associate web service features with the injected instances. If an instance needs to be configured with web service features, use @WebServiceRef to inject the resource along with its features.

    Example: The StockQuoteProvider proxy instance, and the StockQuoteService service instance are injected using @WebServiceRefs.

        @WebServiceRefs({@WebServiceRef(name="service/stockquoteservice", value=StockQuoteService.class),
                     @WebServiceRef(name="service/stockquoteprovider", type=StockQuoteProvider.class, value=StockQuoteService.class})
    public class MyClient {
        void init() {
            Context ic = new InitialContext();
            StockQuoteService service = (StockQuoteService) ic.lookup("java:comp/env/service/stockquoteservice");
            StockQuoteProvider port = (StockQuoteProvider) ic.lookup("java:comp/env/service/stockquoteprovider");
            ...
       }
       ...
    }
    从以下版本开始：
    2.0
    另请参见：
    WebServiceRef

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      WebServiceRef[] value
      Array used for multiple web service reference declarations.

    • Element Detail

      • value

        public abstract WebServiceRef[] value
        Array used for multiple web service reference declarations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

naancmaomajvvajjco sbc a


Uses of Class javax.xml.ws.Action

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.Action

No usage of javax.xml.ws.Action
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_i


Uses of Class javax.xml.ws.BindingType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.BindingType

No usage of javax.xml.ws.BindingType
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/R./f=" ahhhi<""e/ysu


Uses of Class javax.xml.ws.Endpoint

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.Endpoint

  • Packages that use Endpoint
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Endpoint in javax.xml.ws

      Methods in javax.xml.ws that return Endpoint
      修饰符与类型 方法与描述
      static Endpoint Endpoint.create(Object implementor)
      Creates an endpoint with the specified implementor object.
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Endpoint Endpoint.create(String bindingId, Object implementor)
      Creates an endpoint with the specified binding type and implementor object.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Endpoint Endpoint.publish(String address, Object implementor)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Methods in javax.xml.ws that return types with arguments of type Endpoint
      修饰符与类型 方法与描述
      abstract Set<Endpoint> EndpointContext.getEndpoints()
      This gives list of endpoints in an application.

    • Uses of Endpoint in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Endpoint
      修饰符与类型 方法与描述
      abstract Endpoint Provider.createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint Provider.createEndpoint(String bindingId, 类<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint Provider.createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dxeg"stalsssnscc.l."/jta>


Uses of Class javax.xml.ws.EndpointContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.EndpointContext

  • Packages that use EndpointContext
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of EndpointContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type EndpointContext
      修饰符与类型 方法与描述
      void Endpoint.setEndpointContext(EndpointContext ctxt)
      By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtl.../"=...rttteee cuev>


Uses of Class javax.xml.ws.EndpointReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.EndpointReference

  • Packages that use EndpointReference
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of EndpointReference in javax.xml.ws

      Methods in javax.xml.ws with type parameters of type EndpointReference
      修饰符与类型 方法与描述
      <T extends EndpointReference>
      T             		BindingProvider.getEndpointReference(类<T> clazz)
      Returns the EndpointReference associated with this BindingProvider instance.
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      Methods in javax.xml.ws that return EndpointReference
      修饰符与类型 方法与描述
      EndpointReference BindingProvider.getEndpointReference()
      Returns the EndpointReference associated with this BindingProvider instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      static EndpointReference EndpointReference.readFrom(Source eprInfoset)
      Factory method to read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws with parameters of type EndpointReference
      修饰符与类型 方法与描述
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return EndpointReference
      修饰符与类型 方法与描述
      abstract EndpointReference Provider.readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.
      Methods in javax.xml.ws.spi with parameters of type EndpointReference
      修饰符与类型 方法与描述
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.

    • Uses of EndpointReference in javax.xml.ws.wsaddressing

      Subclasses of EndpointReference in javax.xml.ws.wsaddressing
      修饰符与类型 类与描述
      class  W3CEndpointReference
      This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etccseerul募e猉vi"/a<


Uses of Class javax.xml.ws.FaultAction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.FaultAction

No usage of javax.xml.ws.FaultAction
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/l.aong/


Uses of Class javax.xml.ws.Holder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.Holder

No usage of javax.xml.ws.Holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< pAnD&D>�&sa8n�-�1sn


Uses of Class javax.xml.ws.ProtocolException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.ProtocolException

  • Packages that use ProtocolException
    软件包 描述
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of ProtocolException in javax.xml.ws.http

      Subclasses of ProtocolException in javax.xml.ws.http
      修饰符与类型 类与描述
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of ProtocolException in javax.xml.ws.soap

      Subclasses of ProtocolException in javax.xml.ws.soap
      修饰符与类型 类与描述
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;seeo.a


Uses of Class javax.xml.ws.RequestWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.RequestWrapper

No usage of javax.xml.ws.RequestWrapper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

on _t纓>/tpgpxol>>


Uses of Class javax.xml.ws.RespectBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.RespectBinding

No usage of javax.xml.ws.RespectBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p烊t>/$)0a-p岅J


Uses of Class javax.xml.ws.RespectBindingFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.RespectBindingFeature

No usage of javax.xml.ws.RespectBindingFeature
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>."Toa/╝ t2 l > cs


Uses of Class javax.xml.ws.ResponseWrapper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.ResponseWrapper

No usage of javax.xml.ws.ResponseWrapper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sep"tabsasss aoosxeen


Uses of Class javax.xml.ws.Service

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.Service

  • Packages that use Service
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service in javax.xml.ws

      Methods in javax.xml.ws that return Service
      修饰符与类型 方法与描述
      static Service Service.create(QName serviceName)
      Creates a Service instance.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
      Creates a Service instance.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.

    • Uses of Service in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Service
      修饰符与类型 方法与描述
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aeao;n藊a>xtt


Uses of Class javax.xml.ws.Service.Mode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.Service.Mode

  • Packages that use Service.Mode
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Service.Mode in javax.xml.ws

      Methods in javax.xml.ws that return Service.Mode
      修饰符与类型 方法与描述
      static Service.Mode Service.Mode.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static Service.Mode[] Service.Mode.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws with parameters of type Service.Mode
      修饰符与类型 方法与描述
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Service.Mode in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Service.Mode
      修饰符与类型 方法与描述
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"iaslat苨_alh str" e鰂


Uses of Class javax.xml.ws.ServiceMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.ServiceMode

No usage of javax.xml.ws.ServiceMode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s#tavv/vc/i


Uses of Class javax.xml.ws.WebEndpoint

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebEndpoint

No usage of javax.xml.ws.WebEndpoint
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a""�/d� /\>Xvs


Uses of Class javax.xml.ws.WebFault

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebFault

No usage of javax.xml.ws.WebFault
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ni/>slpla y/ <


Uses of Class javax.xml.ws.WebServiceClient

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceClient

No usage of javax.xml.ws.WebServiceClient
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r li.c>>eca"t /紅ms


Uses of Class javax.xml.ws.WebServiceException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceException

  • Packages that use WebServiceException
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceException in javax.xml.ws

      Subclasses of WebServiceException in javax.xml.ws
      修饰符与类型 类与描述
      class  ProtocolException
      The ProtocolException class is a base class for exceptions related to a specific protocol binding.

    • Uses of WebServiceException in javax.xml.ws.http

      Subclasses of WebServiceException in javax.xml.ws.http
      修饰符与类型 类与描述
      class  HTTPException
      The HTTPException exception represents a XML/HTTP fault.

    • Uses of WebServiceException in javax.xml.ws.soap

      Subclasses of WebServiceException in javax.xml.ws.soap
      修饰符与类型 类与描述
      class  SOAPFaultException
      The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

am>7a< et tl3ac/


Uses of Class javax.xml.ws.WebServiceFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceFeature

  • Packages that use WebServiceFeature
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceFeature in javax.xml.ws

      Subclasses of WebServiceFeature in javax.xml.ws
      修饰符与类型 类与描述
      class  RespectBindingFeature
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
      Methods in javax.xml.ws with parameters of type WebServiceFeature
      修饰符与类型 方法与描述
      static Endpoint Endpoint.create(Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified implementor object and web service features.
      static Service Service.create(QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      static Endpoint Endpoint.create(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint with the specified binding type, implementor object, and web service features.
      static Service Service.create(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)
      Creates a Service instance.
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> T Service.getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T EndpointReference.getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      <T> T Service.getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Endpoint Endpoint.publish(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint for the specified implementor object at the given address.
      Constructors in javax.xml.ws with parameters of type WebServiceFeature
      构造方法与描述
      Service(URL wsdlDocumentLocation, QName serviceName, WebServiceFeature... features)

    • Uses of WebServiceFeature in javax.xml.ws.soap

      Subclasses of WebServiceFeature in javax.xml.ws.soap
      修饰符与类型 类与描述
      class  AddressingFeature
      AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      class  MTOMFeature
      This feature represents the use of MTOM with a web service.

    • Uses of WebServiceFeature in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceFeature
      修饰符与类型 方法与描述
      Endpoint Provider.createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      Endpoint Provider.createEndpoint(String bindingId, 类<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      Endpoint Provider.createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract <T> T ServiceDelegate.getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T Provider.getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T ServiceDelegate.getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.ws.WebServicePermission

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServicePermission

No usage of javax.xml.ws.WebServicePermission
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vba.=".h rrr tii"p, n


Uses of Class javax.xml.ws.WebServiceProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceProvider

No usage of javax.xml.ws.WebServiceProvider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y. hlalmva"r."rb "b


Uses of Class javax.xml.ws.WebServiceRef

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceRef

No usage of javax.xml.ws.WebServiceRef
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A/ab;1;p-1


Uses of Class javax.xml.ws.WebServiceRefs

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.WebServiceRefs

No usage of javax.xml.ws.WebServiceRefs
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cbalil;�


Uses of Interface javax.xml.ws.AsyncHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.AsyncHandler

  • Packages that use AsyncHandler
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of AsyncHandler in javax.xml.ws

      Methods in javax.xml.ws with parameters of type AsyncHandler
      修饰符与类型 方法与描述
      Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
      Invoke a service operation asynchronously.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r=noo>_omlcTtAe/otm l�


Uses of Interface javax.xml.ws.Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.Binding

  • Packages that use Binding
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.http
    This package defines APIs specific to the HTTP binding.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of Binding in javax.xml.ws

      Methods in javax.xml.ws that return Binding
      修饰符与类型 方法与描述
      abstract Binding Endpoint.getBinding()
      Returns the binding for this endpoint.
      Binding BindingProvider.getBinding()
      Get the Binding for this binding provider.

    • Uses of Binding in javax.xml.ws.http

      Subinterfaces of Binding in javax.xml.ws.http
      修饰符与类型 Interface and Description
      interface  HTTPBinding
      The HTTPBinding interface is an abstraction for the XML/HTTP binding.

    • Uses of Binding in javax.xml.ws.soap

      Subinterfaces of Binding in javax.xml.ws.soap
      修饰符与类型 Interface and Description
      interface  SOAPBinding
      The SOAPBinding interface is an abstraction for the SOAP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tas e"akx./Mto./


Uses of Interface javax.xml.ws.BindingProvider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.BindingProvider

  • Packages that use BindingProvider
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of BindingProvider in javax.xml.ws

      Subinterfaces of BindingProvider in javax.xml.ws
      修饰符与类型 Interface and Description
      interface  Dispatch<T>
      The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ascll" .ghhhdl//nopic>a.


Uses of Interface javax.xml.ws.Dispatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.Dispatch

  • Packages that use Dispatch
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Dispatch in javax.xml.ws

      Methods in javax.xml.ws that return Dispatch
      修饰符与类型 方法与描述
      <T> Dispatch<T> Service.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the client's choosing.
      <T> Dispatch<T> Service.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the client's choosing.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.

    • Uses of Dispatch in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Dispatch
      修饰符与类型 方法与描述
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> ServiceDelegate.createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ect=


Uses of Interface javax.xml.ws.LogicalMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.LogicalMessage

  • Packages that use LogicalMessage
    软件包 描述
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessage in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return LogicalMessage
      修饰符与类型 方法与描述
      LogicalMessage LogicalMessageContext.getMessage()
      Gets the message from this message context
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.nt


Uses of Interface javax.xml.ws.Provider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.Provider

No usage of javax.xml.ws.Provider
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/p.=a hi nnn/c""..lrP


Uses of Interface javax.xml.ws.Response

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.Response

  • Packages that use Response
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.

    • Uses of Response in javax.xml.ws

      Methods in javax.xml.ws that return Response
      修饰符与类型 方法与描述
      Response<T> Dispatch.invokeAsync(T msg)
      Invoke a service operation asynchronously.
      Methods in javax.xml.ws with parameters of type Response
      修饰符与类型 方法与描述
      void AsyncHandler.handleResponse(Response<T> res)
      Called when the response to an asynchronous operation is available.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vf/se;e# st/-.ya.d>esld


Uses of Interface javax.xml.ws.WebServiceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.WebServiceContext

  • Packages that use WebServiceContext
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of WebServiceContext in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type WebServiceContext
      修饰符与类型 方法与描述
      abstract void Invoker.inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l/ab-dSteo t謗al\.ae/


Handler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler

Interface Handler<C extends MessageContext>

  • All Known Subinterfaces:
    LogicalHandler<C>, SOAPHandler<T>

    public interface Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.
      boolean handleFault(C context)
      The handleFault method is invoked for fault message processing.
      boolean handleMessage(C context)
      The handleMessage method is invoked for normal processing of inbound and outbound messages.

    • 方法详细信息

      • handleMessage

        boolean handleMessage(C context)
        The handleMessage method is invoked for normal processing of inbound and outbound messages. Refer to the description of the handler framework in the JAX-WS specification for full details.
        参数：
        context - the message context.
        返回：
        An indication of whether handler processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        抛出：
        RuntimeException - Causes the JAX-WS runtime to cease handler processing and generate a fault.
        ProtocolException - Causes the JAX-WS runtime to switch to fault message processing.

      • handleFault

        boolean handleFault(C context)
        The handleFault method is invoked for fault message processing. Refer to the description of the handler framework in the JAX-WS specification for full details.
        参数：
        context - the message context
        返回：
        An indication of whether handler fault processing should continue for the current message
        • Return true to continue processing.
        • Return false to block processing.
        抛出：
        RuntimeException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.
        ProtocolException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.

      • close

        void close(MessageContext context)
        Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception. Refer to the description of the handler framework in the JAX-WS specification for full details.
        参数：
        context - the message context
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cebemL= / .r rc.o iv


HandlerResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler

Interface HandlerResolver

  • public interface HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.

    A HandlerResolver may be set on a Service using the setHandlerResolver method.

    When the runtime invokes a HandlerResolver, it will pass it a PortInfo object containing information about the port that the proxy/dispatch object will be accessing.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      List<Handler> getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • 方法详细信息

      • getHandlerChain

        List<Handler> getHandlerChain(PortInfo portInfo)
        Gets the handler chain for the specified port.
        参数：
        portInfo - Contains information about the port being accessed.
        返回：
        java.util.List<Handler> chain
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eCxede/le/shswssx.==LabLtLt>lslla"o


javax.xml.ws.handler

Interfaces

  • Handler
  • HandlerResolver
  • LogicalHandler
  • LogicalMessageContext
  • MessageContext
  • PortInfo

Enums

  • MessageContext.Scope
h


javax.xml.ws.handler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.handler

This package defines APIs for message handlers.

请参见： 描述

  • 接口摘要
    接口 描述
    Handler<C extends MessageContext>
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    LogicalHandler<C extends LogicalMessageContext>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Enum Summary
    Enum 描述
    MessageContext.Scope
    Property scope.

软件包 javax.xml.ws.handler Description

This package defines APIs for message handlers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.e/ reu,


javax.xml.ws.handler Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.handler

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
  • javax.xml.ws.handler.HandlerResolver
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
  • javax.xml.ws.handler.PortInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.handler.MessageContext.Scope
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tmr


LogicalHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.ws.handler

Interface LogicalHandler<C extends LogicalMessageContext>

  • All Superinterfaces:
    Handler<C>

    public interface LogicalHandler<C extends LogicalMessageContext>
extends Handler<C>
    The LogicalHandler extends Handler to provide typesafety for the message context parameter.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.ws.handler.Handler

        close, handleFault, handleMessage
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

veatdtitathljajjh.===sgn�<<


LogicalMessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler

Interface LogicalMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface LogicalMessageContext
extends MessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    从以下版本开始：
    JAX-WS 2.0

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LogicalMessage getMessage()
      Gets the message from this message context

      • 方法 - 继承于接口 javax.xml.ws.handler.MessageContext

        getScope, setScope

      • 方法 - 继承于接口 java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • 方法详细信息

      • getMessage

        LogicalMessage getMessage()
        Gets the message from this message context
        返回：
        The contained message; returns null if no message is present in this message context
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v de>or.lowe>�


MessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler

Interface MessageContext

  • All Superinterfaces:
    Map<String,Object>
    All Known Subinterfaces:
    LogicalMessageContext, SOAPMessageContext

    public interface MessageContext
extends Map<String,Object>
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

    The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

    从以下版本开始：
    JAX-WS 2.0

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 Interface and Description
      static class  MessageContext.Scope
      Property scope.

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String HTTP_REQUEST_HEADERS
      Standard property: HTTP request headers.
      static String HTTP_REQUEST_METHOD
      Standard property: HTTP request method.
      static String HTTP_RESPONSE_CODE
      Standard property: HTTP response status code.
      static String HTTP_RESPONSE_HEADERS
      Standard property: HTTP response headers.
      static String INBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
      static String MESSAGE_OUTBOUND_PROPERTY
      Standard property: message direction, true for outbound messages, false for inbound.
      static String OUTBOUND_MESSAGE_ATTACHMENTS
      Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.
      static String PATH_INFO
      Standard property: Request Path Info
      static String QUERY_STRING
      Standard property: Query string for request.
      static String REFERENCE_PARAMETERS
      Standard property: WS Addressing Reference Parameters.
      static String SERVLET_CONTEXT
      Standard property: servlet context object.
      static String SERVLET_REQUEST
      Standard property: servlet request object.
      static String SERVLET_RESPONSE
      Standard property: servlet response object.
      static String WSDL_DESCRIPTION
      Standard property: input source for WSDL document.
      static String WSDL_INTERFACE
      Standard property: name of wsdl interface (2.0) or port type (1.1).
      static String WSDL_OPERATION
      Standard property: name of WSDL operation.
      static String WSDL_PORT
      Standard property: name of WSDL port.
      static String WSDL_SERVICE
      Standard property: name of WSDL service.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MessageContext.Scope getScope(String name)
      Gets the scope of a property.
      void setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.

      • 方法 - 继承于接口 java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • 字段详细信息

      • MESSAGE_OUTBOUND_PROPERTY

        static final String MESSAGE_OUTBOUND_PROPERTY
        Standard property: message direction, true for outbound messages, false for inbound.

        Type: boolean

        另请参见：
        Constant Field Values

      • INBOUND_MESSAGE_ATTACHMENTS

        static final String INBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map

        另请参见：
        Constant Field Values

      • OUTBOUND_MESSAGE_ATTACHMENTS

        static final String OUTBOUND_MESSAGE_ATTACHMENTS
        Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.

        Type: java.util.Map

        另请参见：
        Constant Field Values

      • WSDL_DESCRIPTION

        static final String WSDL_DESCRIPTION
        Standard property: input source for WSDL document.

        Type: org.xml.sax.InputSource

        另请参见：
        Constant Field Values

      • WSDL_SERVICE

        static final String WSDL_SERVICE
        Standard property: name of WSDL service.

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

      • WSDL_PORT

        static final String WSDL_PORT
        Standard property: name of WSDL port.

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

      • WSDL_INTERFACE

        static final String WSDL_INTERFACE
        Standard property: name of wsdl interface (2.0) or port type (1.1).

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

      • WSDL_OPERATION

        static final String WSDL_OPERATION
        Standard property: name of WSDL operation.

        Type: javax.xml.namespace.QName

        另请参见：
        Constant Field Values

      • HTTP_RESPONSE_CODE

        static final String HTTP_RESPONSE_CODE
        Standard property: HTTP response status code.

        Type: java.lang.Integer

        另请参见：
        Constant Field Values

      • HTTP_REQUEST_HEADERS

        static final String HTTP_REQUEST_HEADERS
        Standard property: HTTP request headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        另请参见：
        Constant Field Values

      • HTTP_RESPONSE_HEADERS

        static final String HTTP_RESPONSE_HEADERS
        Standard property: HTTP response headers.

        Type: java.util.Map<java.lang.String, java.util.List<java.lang.String>>

        另请参见：
        Constant Field Values

      • HTTP_REQUEST_METHOD

        static final String HTTP_REQUEST_METHOD
        Standard property: HTTP request method.

        Type: java.lang.String

        另请参见：
        Constant Field Values

      • SERVLET_REQUEST

        static final String SERVLET_REQUEST
        Standard property: servlet request object.

        Type: javax.servlet.http.HttpServletRequest

        另请参见：
        Constant Field Values

      • SERVLET_RESPONSE

        static final String SERVLET_RESPONSE
        Standard property: servlet response object.

        Type: javax.servlet.http.HttpServletResponse

        另请参见：
        Constant Field Values

      • SERVLET_CONTEXT

        static final String SERVLET_CONTEXT
        Standard property: servlet context object.

        Type: javax.servlet.ServletContext

        另请参见：
        Constant Field Values

      • QUERY_STRING

        static final String QUERY_STRING
        Standard property: Query string for request.

        Type: String

        另请参见：
        Constant Field Values

      • PATH_INFO

        static final String PATH_INFO
        Standard property: Request Path Info

        Type: String

        另请参见：
        Constant Field Values

      • REFERENCE_PARAMETERS

        static final String REFERENCE_PARAMETERS
        Standard property: WS Addressing Reference Parameters. The list MUST include all SOAP headers marked with the wsa:IsReferenceParameter="true" attribute.

        Type: List

        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Constant Field Values

    • 方法详细信息

      • setScope

        void setScope(String name,
            MessageContext.Scope scope)
        Sets the scope of a property.
        参数：
        name - Name of the property associated with the MessageContext
        scope - Desired scope of the property
        抛出：
        IllegalArgumentException - if an illegal property name is specified

      • getScope

        MessageContext.Scope getScope(String name)
        Gets the scope of a property.
        参数：
        name - Name of the property
        返回：
        Scope of the property
        抛出：
        IllegalArgumentException - if a non-existant property name is specified
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


MessageContext.Scope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.ws.handler

Enum MessageContext.Scope

  • java.lang.Object
    • java.lang.Enum<MessageContext.Scope>
      • javax.xml.ws.handler.MessageContext.Scope
  • 所有已实现的接口：
    Serializable, Comparable<MessageContext.Scope>
    Enclosing interface:
    MessageContext

    public static enum MessageContext.Scope
extends Enum<MessageContext.Scope>
    Property scope. Properties scoped as APPLICATION are visible to handlers, client applications and service endpoints; properties scoped as HANDLER are only normally visible to handlers.

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      APPLICATION
      HANDLER

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static MessageContext.Scope valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • APPLICATION

        public static final MessageContext.Scope APPLICATION

      • HANDLER

        public static final MessageContext.Scope HANDLER

    • 方法详细信息

      • values

        public static MessageContext.Scope[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (MessageContext.Scope c : MessageContext.Scope.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static MessageContext.Scope valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i<


PortInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler

Interface PortInfo

  • public interface PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

    This interface is never implemented by an application, only by a JAX-WS implementation.

    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getBindingID()
      Gets the URI identifying the binding used by the port being accessed.
      QName getPortName()
      Gets the qualified name of the WSDL port being accessed.
      QName getServiceName()
      Gets the qualified name of the WSDL service name containing the port being accessed.

    • 方法详细信息

      • getServiceName

        QName getServiceName()
        Gets the qualified name of the WSDL service name containing the port being accessed.
        返回：
        javax.xml.namespace.QName The qualified name of the WSDL service.

      • getPortName

        QName getPortName()
        Gets the qualified name of the WSDL port being accessed.
        返回：
        javax.xml.namespace.QName The qualified name of the WSDL port.

      • getBindingID

        String getBindingID()
        Gets the URI identifying the binding used by the port being accessed.
        返回：
        String The binding identifier for the port.
        另请参见：
        Binding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>lNierve/vP>>>n r>/>osr


Uses of Package javax.xml.ws.handler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.handler

  • Packages that use javax.xml.ws.handler
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.handler used by javax.xml.ws
    类与描述
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler
    类与描述
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    LogicalMessageContext
    The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
    MessageContext.Scope
    Property scope.
    PortInfo
    The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.handler.soap
    类与描述
    Handler
    The Handler interface is the base interface for JAX-WS handlers.
    MessageContext
    The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
  • Classes in javax.xml.ws.handler used by javax.xml.ws.spi
    类与描述
    HandlerResolver
    HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>t/ syiilt/<;lne


Uses of Class javax.xml.ws.handler.MessageContext.Scope

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.handler.MessageContext.Scope

  • Packages that use MessageContext.Scope
    软件包 描述
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of MessageContext.Scope in javax.xml.ws.handler

      Methods in javax.xml.ws.handler that return MessageContext.Scope
      修饰符与类型 方法与描述
      MessageContext.Scope MessageContext.getScope(String name)
      Gets the scope of a property.
      static MessageContext.Scope MessageContext.Scope.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static MessageContext.Scope[] MessageContext.Scope.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Methods in javax.xml.ws.handler with parameters of type MessageContext.Scope
      修饰符与类型 方法与描述
      void MessageContext.setScope(String name, MessageContext.Scope scope)
      Sets the scope of a property.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface javax.xml.ws.handler.Handler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.Handler

  • Packages that use Handler
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of Handler in javax.xml.ws

      Methods in javax.xml.ws that return types with arguments of type Handler
      修饰符与类型 方法与描述
      List<Handler> Binding.getHandlerChain()
      Gets a copy of the handler chain for a protocol binding instance.
      Method parameters in javax.xml.ws with type arguments of type Handler
      修饰符与类型 方法与描述
      void Binding.setHandlerChain(List<Handler> chain)
      Sets the handler chain for the protocol binding instance.

    • Uses of Handler in javax.xml.ws.handler

      Subinterfaces of Handler in javax.xml.ws.handler
      修饰符与类型 Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
      Methods in javax.xml.ws.handler that return types with arguments of type Handler
      修饰符与类型 方法与描述
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.

    • Uses of Handler in javax.xml.ws.handler.soap

      Subinterfaces of Handler in javax.xml.ws.handler.soap
      修饰符与类型 Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/Lf. wm�


Uses of Interface javax.xml.ws.handler.HandlerResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.HandlerResolver

  • Packages that use HandlerResolver
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of HandlerResolver in javax.xml.ws

      Methods in javax.xml.ws that return HandlerResolver
      修饰符与类型 方法与描述
      HandlerResolver Service.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws with parameters of type HandlerResolver
      修饰符与类型 方法与描述
      void Service.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

    • Uses of HandlerResolver in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return HandlerResolver
      修饰符与类型 方法与描述
      abstract HandlerResolver ServiceDelegate.getHandlerResolver()
      Returns the configured handler resolver.
      Methods in javax.xml.ws.spi with parameters of type HandlerResolver
      修饰符与类型 方法与描述
      abstract void ServiceDelegate.setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lm"r-sukcaaa/h//f/lstv"ti


Uses of Interface javax.xml.ws.handler.LogicalHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.LogicalHandler

No usage of javax.xml.ws.handler.LogicalHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sh > wsw<<uuts


Uses of Interface javax.xml.ws.handler.LogicalMessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.LogicalMessageContext

  • Packages that use LogicalMessageContext
    软件包 描述
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of LogicalMessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type LogicalMessageContext
      修饰符与类型 Interface and Description
      interface  LogicalHandler<C extends LogicalMessageContext>
      The LogicalHandler extends Handler to provide typesafety for the message context parameter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/hel/at>/=


Uses of Interface javax.xml.ws.handler.MessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.MessageContext

  • Packages that use MessageContext
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.handler
    This package defines APIs for message handlers.
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of MessageContext in javax.xml.ws

      Methods in javax.xml.ws that return MessageContext
      修饰符与类型 方法与描述
      MessageContext WebServiceContext.getMessageContext()
      Returns the MessageContext for the request being served at the time this method is called.

    • Uses of MessageContext in javax.xml.ws.handler

      Classes in javax.xml.ws.handler with type parameters of type MessageContext
      修饰符与类型 Interface and Description
      interface  Handler<C extends MessageContext>
      The Handler interface is the base interface for JAX-WS handlers.
      Subinterfaces of MessageContext in javax.xml.ws.handler
      修饰符与类型 Interface and Description
      interface  LogicalMessageContext
      The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
      Methods in javax.xml.ws.handler with parameters of type MessageContext
      修饰符与类型 方法与描述
      void Handler.close(MessageContext context)
      Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.

    • Uses of MessageContext in javax.xml.ws.handler.soap

      Subinterfaces of MessageContext in javax.xml.ws.handler.soap
      修饰符与类型 Interface and Description
      interface  SOAPMessageContext
      The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

do; r-m>"hua.p=�<..s>


Uses of Interface javax.xml.ws.handler.PortInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.PortInfo

  • Packages that use PortInfo
    软件包 描述
    javax.xml.ws.handler
    This package defines APIs for message handlers.

    • Uses of PortInfo in javax.xml.ws.handler

      Methods in javax.xml.ws.handler with parameters of type PortInfo
      修饰符与类型 方法与描述
      List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
      Gets the handler chain for the specified port.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ro_a">


javax.xml.ws.handler.soap

Interfaces

  • SOAPHandler
  • SOAPMessageContext
i


javax.xml.ws.handler.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.handler.soap

This package defines APIs for SOAP message handlers.

请参见： 描述

  • 接口摘要
    接口 描述
    SOAPHandler<T extends SOAPMessageContext>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

软件包 javax.xml.ws.handler.soap Description

This package defines APIs for SOAP message handlers.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o蔲lvi=.otd


javax.xml.ws.handler.soap Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.handler.soap

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-h-!t->"<-


SOAPHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler.soap

Interface SOAPHandler<T extends SOAPMessageContext>

  • All Superinterfaces:
    Handler<T>

    public interface SOAPHandler<T extends SOAPMessageContext>
extends Handler<T>
    The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
    从以下版本开始：
    JAX-WS 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Set<QName> getHeaders()
      Gets the header blocks that can be processed by this Handler instance.

      • 方法 - 继承于接口 javax.xml.ws.handler.Handler

        close, handleFault, handleMessage

    • 方法详细信息

      • getHeaders

        Set<QName> getHeaders()
        Gets the header blocks that can be processed by this Handler instance.
        返回：
        Set of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntlgm iM.ti�../h"ldh ao


SOAPMessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.handler.soap

Interface SOAPMessageContext

  • All Superinterfaces:
    Map<String,Object>, MessageContext

    public interface SOAPMessageContext
extends MessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.
    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    SOAPMessage

    • 嵌套类摘要

      • Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext

        MessageContext.Scope

      • Nested classes/interfaces inherited from interface java.util.Map

        Map.Entry<K,V>

    • 字段摘要

      • 字段 - 继承于接口 javax.xml.ws.handler.MessageContext

        HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, REFERENCE_PARAMETERS, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object[] getHeaders(QName header, JAXBContext context, boolean allRoles)
      Gets headers that have a particular qualified name from the message in the message context.
      SOAPMessage getMessage()
      Gets the SOAPMessage from this message context.
      Set<String> getRoles()
      Gets the SOAP actor roles associated with an execution of the handler chain.
      void setMessage(SOAPMessage message)
      Sets the SOAPMessage in this message context

      • 方法 - 继承于接口 javax.xml.ws.handler.MessageContext

        getScope, setScope

      • 方法 - 继承于接口 java.util.Map

        clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

    • 方法详细信息

      • getMessage

        SOAPMessage getMessage()
        Gets the SOAPMessage from this message context. Modifications to the returned SOAPMessage change the message in-place, there is no need to susequently call setMessage.
        返回：
        Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

      • setMessage

        void setMessage(SOAPMessage message)
        Sets the SOAPMessage in this message context
        参数：
        message - SOAP message
        抛出：
        WebServiceException - If any error during the setting of the SOAPMessage in this message context
        UnsupportedOperationException - If this operation is not supported

      • getHeaders

        Object[] getHeaders(QName header,
                  JAXBContext context,
                  boolean allRoles)
        Gets headers that have a particular qualified name from the message in the message context. Note that a SOAP message can contain multiple headers with the same qualified name.
        参数：
        header - The XML qualified name of the SOAP header(s).
        context - The JAXBContext that should be used to unmarshall the header
        allRoles - If true then returns headers for all SOAP roles, if false then only returns headers targetted at the roles currently being played by this SOAP node, see getRoles.
        返回：
        An array of unmarshalled headers; returns an empty array if no message is present in this message context or no headers match the supplied qualified name.
        抛出：
        WebServiceException - If an error occurs when using the supplied JAXBContext to unmarshall. The cause of the WebServiceException is the original JAXBException.

      • getRoles

        Set<String> getRoles()
        Gets the SOAP actor roles associated with an execution of the handler chain. Note that SOAP actor roles apply to the SOAP node and are managed using SOAPBinding.setRoles(java.util.Set) and SOAPBinding.getRoles(). Handler instances in the handler chain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the handler chain.
        返回：
        Array of String for SOAP actor roles
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_- op<"/-g> l="_t>n /r >"ts 胻=


Uses of Package javax.xml.ws.handler.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.handler.soap

  • Packages that use javax.xml.ws.handler.soap
    软件包 描述
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.
  • Classes in javax.xml.ws.handler.soap used by javax.xml.ws.handler.soap
    类与描述
    SOAPMessageContext
    The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l o fnn-ota e縡I "/obntc


Uses of Interface javax.xml.ws.handler.soap.SOAPHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.soap.SOAPHandler

No usage of javax.xml.ws.handler.soap.SOAPHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>rd<


Uses of Interface javax.xml.ws.handler.soap.SOAPMessageContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.handler.soap.SOAPMessageContext

  • Packages that use SOAPMessageContext
    软件包 描述
    javax.xml.ws.handler.soap
    This package defines APIs for SOAP message handlers.

    • Uses of SOAPMessageContext in javax.xml.ws.handler.soap

      Classes in javax.xml.ws.handler.soap with type parameters of type SOAPMessageContext
      修饰符与类型 Interface and Description
      interface  SOAPHandler<T extends SOAPMessageContext>
      The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m d>sa- /b."t w裧r


HTTPBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.ws.http

Interface HTTPBinding

  • All Superinterfaces:
    Binding

    public interface HTTPBinding
extends Binding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
    从以下版本开始：
    JAX-WS 2.0

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String HTTP_BINDING
      A constant representing the identity of the XML/HTTP binding.

    • 方法摘要

      • 方法 - 继承于接口 javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • 字段详细信息

      • HTTP_BINDING

        static final String HTTP_BINDING
        A constant representing the identity of the XML/HTTP binding.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hl>ent/ }lm4c>b


HTTPException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.http

类 HTTPException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
  • 所有已实现的接口：
    Serializable

    public class HTTPException
extends ProtocolException
    The HTTPException exception represents a XML/HTTP fault.

    Since there is no standard format for faults or exceptions in XML/HTTP messaging, only the HTTP status code is captured.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      HTTPException(int statusCode)
      Constructor for the HTTPException

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getStatusCode()
      Gets the HTTP status code.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • HTTPException

        public HTTPException(int statusCode)
        Constructor for the HTTPException
        参数：
        statusCode - int for the HTTP status code

    • 方法详细信息

      • getStatusCode

        public int getStatusCode()
        Gets the HTTP status code.
        返回：
        HTTP status code
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

claareA="l;dcT r�


javax.xml.ws.http

Interfaces

  • HTTPBinding

Exceptions

  • HTTPException
�


javax.xml.ws.http

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.http

This package defines APIs specific to the HTTP binding.

请参见： 描述

  • 接口摘要
    接口 描述
    HTTPBinding
    The HTTPBinding interface is an abstraction for the XML/HTTP binding.
  • Exception Summary
    Exception 描述
    HTTPException
    The HTTPException exception represents a XML/HTTP fault.

软件包 javax.xml.ws.http Description

This package defines APIs specific to the HTTP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l


javax.xml.ws.http Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.http

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/Prb�vava斬nov.s"s


Uses of Package javax.xml.ws.http

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.http

No usage of javax.xml.ws.http
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>ig=e= "tttis<


Uses of Class javax.xml.ws.http.HTTPException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.http.HTTPException

No usage of javax.xml.ws.http.HTTPException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<塇RHt/e鍄rr>m


Uses of Interface javax.xml.ws.http.HTTPBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.http.HTTPBinding

No usage of javax.xml.ws.http.HTTPBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ht>&mL


Addressing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws.soap

Annotation Type Addressing

  • @Target(value={TYPE,方法,字段})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="http://www.w3.org/2005/08/addressing/module",
                             bean=AddressingFeature.class)
public @interface Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this annotation with any other binding is undefined.

    This annotation MUST only be used in conjunction with the WebService, WebServiceProvider, and WebServiceRef annotations. When used with a javax.jws.WebService annotation, this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the Addressing annotation.

    This annotation's behaviour is defined by the corresponding feature AddressingFeature.

    从以下版本开始：
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
      AddressingFeature.Responses responses
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled. If enabled, it means the endpoint supports WS-Addressing but does not require its use. Corresponding 3.1.1 Addressing Assertion must be generated in the generated WSDL.
        Default:
        true

      • required

        public abstract boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, the endpoint requires WS-Addressing and WS-Addressing headers MUST be present on incoming messages. A corresponding 3.1.1 Addressing Assertion must be generated in the WSDL.
        Default:
        false

      • responses

        public abstract AddressingFeature.Responses responses
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all.

        AddressingFeature.Responses.ALL supports all response types and this is the default value.

        AddressingFeature.Responses.ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

        AddressingFeature.Responses.NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

        从以下版本开始：
        JAX-WS 2.2
        Default:
        javax.xml.ws.soap.AddressingFeature.Responses.ALL
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rh>ao.gia


AddressingFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.soap

类 AddressingFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature

  • public final class AddressingFeature
extends WebServiceFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding. Using this feature with any other binding is undefined.

    This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the effects of this feature with respect to be enabled or disabled:

    • ENABLED: In this Mode, WS-Addressing will be enabled. It means the endpoint supports WS-Addressing but does not require its use. A sender could send messages with WS-Addressing headers or without WS-Addressing headers. But a receiver MUST consume both types of messages.
    • DISABLED: In this Mode, WS-Addressing will be disabled. At runtime, WS-Addressing headers MUST NOT be used by a sender or receiver.

    If the feature is enabled, the required property determines whether the endpoint requires WS-Addressing. If it is set true, WS-Addressing headers MUST be present on incoming and outgoing messages. By default the required property is false.

    If the web service developer has not explicitly enabled this feature, WSDL's wsam:Addressing policy assertion is used to find the use of WS-Addressing. By using the feature explicitly, an application overrides WSDL's indication of the use of WS-Addressing. In some cases, this is really required. For example, if an application has implemented WS-Addressing itself, it can use this feature to disable addressing. That means a JAX-WS implementation doesn't consume or produce WS-Addressing headers.

    If addressing is enabled, a corresponding wsam:Addressing policy assertion must be generated in the WSDL as per 3.1 WS-Policy Assertions

    Example 1: Possible Policy Assertion in the generated WSDL for @Addressing

       <wsam:Addressing wsp:Optional="true">
     <wsp:Policy/>
   </wsam:Addressing>

    Example 2: Possible Policy Assertion in the generated WSDL for @Addressing(required=true)

       <wsam:Addressing>
     <wsp:Policy/>
   </wsam:Addressing>

    Example 3: Possible Policy Assertion in the generated WSDL for @Addressing(required=true, responses=Responses.ANONYMOUS)

       <wsam:Addressing>
      <wsp:Policy>
        <wsam:AnonymousResponses/>
      </wsp:Policy>
   </wsam:Addressing>

    See Web Services Addressing - Core, Web Services Addressing 1.0 - SOAP Binding, and Web Services Addressing 1.0 - Metadata for more information on WS-Addressing.

    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    Addressing

    • 嵌套类摘要

      Nested Classes
      修饰符与类型 类与描述
      static class  AddressingFeature.Responses
      If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ID
      Constant value identifying the AddressingFeature
      protected boolean required
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • 构造方法摘要

      Constructors
      构造方法与描述
      AddressingFeature()
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required)
      Creates and configures an AddressingFeature with the use of addressing requirements.
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getID()
      Get the unique identifier for this WebServiceFeature.
      AddressingFeature.Responses getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      boolean isRequired()
      If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.

      • 方法 - 继承于类 javax.xml.ws.WebServiceFeature

        isEnabled

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ID

        public static final String ID
        Constant value identifying the AddressingFeature
        另请参见：
        Constant Field Values

      • required

        protected boolean required
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.

    • 构造方法详细信息

      • AddressingFeature

        public AddressingFeature()
        Creates and configures an AddressingFeature with the use of addressing requirements. The created feature enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It is also configured to accept all the response types.

      • AddressingFeature

        public AddressingFeature(boolean enabled)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled is true, it enables ws-addressing i.e. supports ws-addressing but doesn't require its use. It also configures to accept all the response types.
        参数：
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                 boolean required)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. It also configures to accept all the response types.
        参数：
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .

      • AddressingFeature

        public AddressingFeature(boolean enabled,
                 boolean required,
                 AddressingFeature.Responses responses)
        Creates and configures an AddressingFeature with the use of addressing requirements. If enabled and required are true, it enables ws-addressing and requires its use. Also, the response types can be configured using responses parameter.
        参数：
        enabled - true enables ws-addressing i.e.ws-addressing is supported but doesn't require its use
        required - true means requires the use of ws-addressing .
        responses - specifies what type of responses are required
        从以下版本开始：
        JAX-WS 2.2

    • 方法详细信息

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        指定者：
        getID in class WebServiceFeature
        返回：
        the unique identifier for this feature.

      • isRequired

        public boolean isRequired()
        If addressing is enabled, this property determines whether the endpoint requires WS-Addressing. If required is true, WS-Addressing headers MUST be present on incoming and outgoing messages.
        返回：
        the current required value

      • getResponses

        public AddressingFeature.Responses getResponses()
        If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

        返回：
        AddressingFeature.Responses.ALL when endpoint supports all types of responses, AddressingFeature.Responses.ANONYMOUS when endpoint requires the use of only anonymous responses, AddressingFeature.Responses.NON_ANONYMOUS when endpoint requires the use of only non-anonymous responses
        从以下版本开始：
        JAX-WS 2.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a<<>ra o".sl=_r>!bt.=a=茫kC譨v�>/tyste


AddressingFeature.Responses

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法
javax.xml.ws.soap

Enum AddressingFeature.Responses

  • java.lang.Object
    • java.lang.Enum<AddressingFeature.Responses>
      • javax.xml.ws.soap.AddressingFeature.Responses
  • 所有已实现的接口：
    Serializable, Comparable<AddressingFeature.Responses>
    封闭类：
    AddressingFeature

    public static enum AddressingFeature.Responses
extends Enum<AddressingFeature.Responses>
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.

    ALL supports all response types and this is the default value.

    ANONYMOUS requires the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

    NON_ANONYMOUS requires the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

    从以下版本开始：
    JAX-WS 2.2

    • Enum Constant Summary

      Enum Constants
      Enum Constant and Description
      ALL
      Supports all response types and this is the default
      ANONYMOUS
      Specifies the use of only anonymous responses.
      NON_ANONYMOUS
      Specifies the use of only non-anonymous responses.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static AddressingFeature.Responses valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] values()
      Returns an array containing the constants of this enum type, in the order they are declared.

      • 方法 - 继承于类 java.lang.Enum

        clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

      • 方法 - 继承于类 java.lang.Object

        getClass, notify, notifyAll, wait, wait, wait

    • Enum Constant Detail

      • ANONYMOUS

        public static final AddressingFeature.Responses ANONYMOUS
        Specifies the use of only anonymous responses. It will result into wsam:AnonymousResponses nested assertion as specified in 3.1.2 AnonymousResponses Assertion in the generated WSDL.

      • NON_ANONYMOUS

        public static final AddressingFeature.Responses NON_ANONYMOUS
        Specifies the use of only non-anonymous responses. It will result into wsam:NonAnonymousResponses nested assertion as specified in 3.1.3 NonAnonymousResponses Assertion in the generated WSDL.

      • ALL

        public static final AddressingFeature.Responses ALL
        Supports all response types and this is the default

    • 方法详细信息

      • values

        public static AddressingFeature.Responses[] values()
        Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
        for (AddressingFeature.Responses c : AddressingFeature.Responses.values())
    System.out.println(c);
        返回：
        an array containing the constants of this enum type, in the order they are declared

      • valueOf

        public static AddressingFeature.Responses valueOf(String name)
        Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)
        参数：
        name - the name of the enum constant to be returned.
        返回：
        the enum constant with the specified name
        抛出：
        IllegalArgumentException - if this enum type has no constant with the specified name
        NullPointerException - if the argument is null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • Enum Constants |
  • 字段 |
  • 方法
  • 详细信息：
  • Enum Constants |
  • 字段 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bhondepreps;;pssipaa )-<< cbii>st


javax.xml.ws.soap

Interfaces

  • SOAPBinding

Classes

  • AddressingFeature
  • MTOMFeature

Enums

  • AddressingFeature.Responses

Exceptions

  • SOAPFaultException

Annotation Types

  • Addressing
  • MTOM
/


javax.xml.ws.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.soap

This package defines APIs specific to the SOAP binding.

请参见： 描述

  • 接口摘要
    接口 描述
    SOAPBinding
    The SOAPBinding interface is an abstraction for the SOAP binding.
  • Class Summary
    类 描述
    AddressingFeature
    AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOMFeature
    This feature represents the use of MTOM with a web service.
  • Enum Summary
    Enum 描述
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
  • Exception Summary
    Exception 描述
    SOAPFaultException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.
  • Annotation Types Summary
    Annotation Type 描述
    Addressing
    This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
    MTOM
    This feature represents the use of MTOM with a web service.

软件包 javax.xml.ws.soap Description

This package defines APIs specific to the SOAP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ddtgdte<


javax.xml.ws.soap Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.soap

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.soap.SOAPBinding

Annotation Type Hierarchy

  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.soap.AddressingFeature.Responses
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=n= v=!<-==-d n=ppoT


MTOM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws.soap

Annotation Type MTOM

  • @Target(value={TYPE,方法,字段})
@Retention(value=RUNTIME)
@Documented
@WebServiceFeatureAnnotation(id="http://www.w3.org/2004/08/soap/features/http-optimization",
                             bean=MTOMFeature.class)
public @interface MTOM
    This feature represents the use of MTOM with a web service.

    This annotation MUST only be used in conjunction the javax.jws.WebService, WebServiceProvider, WebServiceRef annotations. When used with the javax.jws.WebService annotation this annotation MUST only be used on the service endpoint implementation class. When used with a WebServiceRef annotation, this annotation MUST only be used when a proxy instance is created. The injected SEI proxy, and endpoint MUST honor the values of the MTOM annotation.

    This annotation's behaviour is defined by the corresponding feature MTOMFeature.

    从以下版本开始：
    JAX-WS 2.1

    • Optional Element Summary

      Optional Elements
      修饰符与类型 Optional Element and Description
      boolean enabled
      Specifies if this feature is enabled or disabled.
      int threshold
      Property for MTOM threshold value.

    • Element Detail

      • enabled

        public abstract boolean enabled
        Specifies if this feature is enabled or disabled.
        Default:
        true

      • threshold

        public abstract int threshold
        Property for MTOM threshold value. When MTOM is enabled, binary data above this size in bytes will be XOP encoded or sent as attachment. The value of this property MUST always be >= 0. Default value is 0.
        Default:
        0
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

smtsic> c>" >""kslli>t>l/=s


MTOMFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.soap

类 MTOMFeature

  • java.lang.Object
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.MTOMFeature

  • public final class MTOMFeature
extends WebServiceFeature
    This feature represents the use of MTOM with a web service. This feature can be used during the creation of SEI proxy, and Dispatch instances on the client side and Endpoint instances on the server side. This feature cannot be used for Service instance creation on the client side.

    The following describes the affects of this feature with respect to being enabled or disabled:

    • ENABLED: In this Mode, MTOM will be enabled. A receiver MUST accept both a non-optimized and an optimized message, and a sender MAY send an optimized message, or a non-optimized message. The heuristics used by a sender to determine whether to use optimization or not are implementation-specific.
    • DISABLED: In this Mode, MTOM will be disabled

    The threshold property can be used to set the threshold value used to determine when binary data should be XOP encoded.

    从以下版本开始：
    JAX-WS 2.1

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String ID
      Constant value identifying the MTOMFeature
      protected int threshold
      Property for MTOM threshold value.

      • Fields inherited from class javax.xml.ws.WebServiceFeature

        enabled

    • 构造方法摘要

      Constructors
      构造方法与描述
      MTOMFeature()
      Create an MTOMFeature.
      MTOMFeature(boolean enabled)
      Creates an MTOMFeature.
      MTOMFeature(boolean enabled, int threshold)
      Creates an MTOMFeature.
      MTOMFeature(int threshold)
      Creates an MTOMFeature.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getID()
      Get the unique identifier for this WebServiceFeature.
      int getThreshold()
      Gets the threshold value used to determine when binary data should be sent as an attachment.

      • 方法 - 继承于类 javax.xml.ws.WebServiceFeature

        isEnabled

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • ID

        public static final String ID
        Constant value identifying the MTOMFeature
        另请参见：
        Constant Field Values

      • threshold

        protected int threshold
        Property for MTOM threshold value. This property serves as a hint when MTOM is enabled, binary data above this size in bytes SHOULD be sent as attachment. The value of this property MUST always be >= 0. Default value is 0.

    • 构造方法详细信息

      • MTOMFeature

        public MTOMFeature()
        Create an MTOMFeature. The instance created will be enabled.

      • MTOMFeature

        public MTOMFeature(boolean enabled)
        Creates an MTOMFeature.
        参数：
        enabled - specifies if this feature should be enabled or not

      • MTOMFeature

        public MTOMFeature(int threshold)
        Creates an MTOMFeature. The instance created will be enabled.
        参数：
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        抛出：
        WebServiceException - if threshold is < 0

      • MTOMFeature

        public MTOMFeature(boolean enabled,
           int threshold)
        Creates an MTOMFeature.
        参数：
        enabled - specifies if this feature should be enabled or not
        threshold - the size in bytes that binary data SHOULD be before being sent as an attachment.
        抛出：
        WebServiceException - if threshold is < 0

    • 方法详细信息

      • getID

        public String getID()
        Get the unique identifier for this WebServiceFeature.
        指定者：
        getID in class WebServiceFeature
        返回：
        the unique identifier for this feature.

      • getThreshold

        public int getThreshold()
        Gets the threshold value used to determine when binary data should be sent as an attachment.
        返回：
        the current threshold size in bytes
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/s


SOAPBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.ws.soap

Interface SOAPBinding

  • All Superinterfaces:
    Binding

    public interface SOAPBinding
extends Binding
    The SOAPBinding interface is an abstraction for the SOAP binding.
    从以下版本开始：
    JAX-WS 2.0

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String SOAP11HTTP_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding.
      static String SOAP11HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
      static String SOAP12HTTP_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding.
      static String SOAP12HTTP_MTOM_BINDING
      A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      MessageFactory getMessageFactory()
      Gets the SAAJ MessageFactory instance used by this SOAP binding.
      Set<String> getRoles()
      Gets the roles played by the SOAP binding instance.
      SOAPFactory getSOAPFactory()
      Gets the SAAJ SOAPFactory instance used by this SOAP binding.
      boolean isMTOMEnabled()
      Returns true if the use of MTOM is enabled.
      void setMTOMEnabled(boolean flag)
      Enables or disables use of MTOM.
      void setRoles(Set<String> roles)
      Sets the roles played by the SOAP binding instance.

      • 方法 - 继承于接口 javax.xml.ws.Binding

        getBindingID, getHandlerChain, setHandlerChain

    • 字段详细信息

      • SOAP11HTTP_BINDING

        static final String SOAP11HTTP_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding.
        另请参见：
        Constant Field Values

      • SOAP12HTTP_BINDING

        static final String SOAP12HTTP_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding.
        另请参见：
        Constant Field Values

      • SOAP11HTTP_MTOM_BINDING

        static final String SOAP11HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
        另请参见：
        Constant Field Values

      • SOAP12HTTP_MTOM_BINDING

        static final String SOAP12HTTP_MTOM_BINDING
        A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getRoles

        Set<String> getRoles()
        Gets the roles played by the SOAP binding instance.
        返回：
        Set The set of roles played by the binding instance.

      • setRoles

        void setRoles(Set<String> roles)
        Sets the roles played by the SOAP binding instance.
        参数：
        roles - The set of roles played by the binding instance.
        抛出：
        WebServiceException - On an error in the configuration of the list of roles.

      • isMTOMEnabled

        boolean isMTOMEnabled()
        Returns true if the use of MTOM is enabled.
        返回：
        true if and only if the use of MTOM is enabled.

      • setMTOMEnabled

        void setMTOMEnabled(boolean flag)
        Enables or disables use of MTOM.
        参数：
        flag - A boolean specifying whether the use of MTOM should be enabled or disabled.
        抛出：
        WebServiceException - If the specified setting is not supported by this binding instance.

      • getSOAPFactory

        SOAPFactory getSOAPFactory()
        Gets the SAAJ SOAPFactory instance used by this SOAP binding.
        返回：
        SOAPFactory instance used by this SOAP binding.

      • getMessageFactory

        MessageFactory getMessageFactory()
        Gets the SAAJ MessageFactory instance used by this SOAP binding.
        返回：
        MessageFactory instance used by this SOAP binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rHnsi.eidixddlase/nv>h-.ts/e


SOAPFaultException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.soap

类 SOAPFaultException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException
  • 所有已实现的接口：
    Serializable

    public class SOAPFaultException
extends ProtocolException
    The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

    A SOAPFaultException wraps a SAAJ SOAPFault that manages the SOAP-specific representation of faults. The createFault method of javax.xml.soap.SOAPFactory may be used to create an instance of javax.xml.soap.SOAPFault for use with the constructor. SOAPBinding contains an accessor for the SOAPFactory used by the binding instance.

    Note that the value of getFault is the only part of the exception used when searializing a SOAP fault.

    Refer to the SOAP specification for a complete description of SOAP faults.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    SOAPFault, SOAPBinding.getSOAPFactory(), ProtocolException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SOAPFaultException(SOAPFault fault)
      Constructor for SOAPFaultException

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      SOAPFault getFault()
      Gets the embedded SOAPFault instance.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SOAPFaultException

        public SOAPFaultException(SOAPFault fault)
        Constructor for SOAPFaultException
        参数：
        fault - SOAPFault representing the fault
        另请参见：
        SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)

    • 方法详细信息

      • getFault

        public SOAPFault getFault()
        Gets the embedded SOAPFault instance.
        返回：
        javax.xml.soap.SOAPFault SOAP fault element
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cs I >f >e >ee> d.rlbi eldedd eeddd�


Uses of Package javax.xml.ws.soap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.soap

  • Packages that use javax.xml.ws.soap
    软件包 描述
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
  • Classes in javax.xml.ws.soap used by javax.xml.ws.soap
    类与描述
    AddressingFeature.Responses
    If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/fithtazbbba/..="lllr/r


Uses of Class javax.xml.ws.soap.Addressing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.Addressing

No usage of javax.xml.ws.soap.Addressing
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.ws.soap.AddressingFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.AddressingFeature

No usage of javax.xml.ws.soap.AddressingFeature
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ly=sr ae


Uses of Class javax.xml.ws.soap.AddressingFeature.Responses

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.AddressingFeature.Responses

  • Packages that use AddressingFeature.Responses
    软件包 描述
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of AddressingFeature.Responses in javax.xml.ws.soap

      Methods in javax.xml.ws.soap that return AddressingFeature.Responses
      修饰符与类型 方法与描述
      AddressingFeature.Responses AddressingFeature.getResponses()
      If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.
      static AddressingFeature.Responses AddressingFeature.Responses.valueOf(String name)
      Returns the enum constant of this type with the specified name.
      static AddressingFeature.Responses[] AddressingFeature.Responses.values()
      Returns an array containing the constants of this enum type, in the order they are declared.
      Constructors in javax.xml.ws.soap with parameters of type AddressingFeature.Responses
      构造方法与描述
      AddressingFeature(boolean enabled, boolean required, AddressingFeature.Responses responses)
      Creates and configures an AddressingFeature with the use of addressing requirements.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sas>este.;fa�=h


Uses of Class javax.xml.ws.soap.MTOM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.MTOM

No usage of javax.xml.ws.soap.MTOM
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ss=>> << ///inooe yfr


Uses of Class javax.xml.ws.soap.MTOMFeature

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.MTOMFeature

No usage of javax.xml.ws.soap.MTOMFeature
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

,n.Mnbe>ona


Uses of Class javax.xml.ws.soap.SOAPFaultException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.soap.SOAPFaultException

No usage of javax.xml.ws.soap.SOAPFaultException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

or htm wiaSrv


Uses of Interface javax.xml.ws.soap.SOAPBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.ws.soap.SOAPBinding

No usage of javax.xml.ws.soap.SOAPBinding
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wapdi�/


Invoker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi

类 Invoker

  • java.lang.Object
    • javax.xml.ws.spi.Invoker

  • public abstract class Invoker
extends Object
    Invoker hides the detail of calling into application endpoint implementation. Container hands over an implementation of Invoker to JAX-WS runtime, and jax-ws runtime calls invoke(java.lang.reflect.Method, java.lang.Object...) for a web service invocation. Finally, Invoker does the actual invocation of web service on endpoint instance. Container also injects the provided WebServiceContext and takes care of invoking javax.annotation.PostConstruct methods, if present, on the endpoint implementation.
    从以下版本开始：
    JAX-WS 2.2
    另请参见：
    Provider.createEndpoint(String, Class, Invoker, WebServiceFeature...)

    • 构造方法摘要

      Constructors
      构造方法与描述
      Invoker()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void inject(WebServiceContext webServiceContext)
      JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
      abstract Object invoke(方法 m, Object... args)
      JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Invoker

        public Invoker()

    • 方法详细信息

      • inject

        public abstract void inject(WebServiceContext webServiceContext)
                     throws IllegalAccessException,
                            IllegalArgumentException,
                            InvocationTargetException
        JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance. The WebServiceContext object uses thread-local information to return the correct information during the actual endpoint invocation regardless of how many threads are concurrently being used to serve requests.
        参数：
        webServiceContext - a holder for MessageContext
        抛出：
        IllegalAccessException - if the injection done by reflection API throws this exception
        IllegalArgumentException - if the injection done by reflection API throws this exception
        InvocationTargetException - if the injection done by reflection API throws this exception

      • invoke

        public abstract Object invoke(方法 m,
            Object... args)
                       throws IllegalAccessException,
                              IllegalArgumentException,
                              InvocationTargetException
        JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance. The injected WebServiceContext.getMessageContext() gives the correct information for this invocation.
        参数：
        m - Method to be invoked on the service
        args - Method arguments
        返回：
        return value of the method
        抛出：
        IllegalAccessException - if the invocation done by reflection API throws this exception
        IllegalArgumentException - if the invocation done by reflection API throws this exception
        InvocationTargetException - if the invocation done by reflection API throws this exception
        另请参见：
        Method.invoke(java.lang.Object, java.lang.Object...)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sst襱yo�"aRin �


javax.xml.ws.spi

Classes

  • Invoker
  • Provider
  • ServiceDelegate

Annotation Types

  • WebServiceFeatureAnnotation
n


javax.xml.ws.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.spi

This package defines SPIs for JAX-WS.

请参见： 描述

  • Class Summary
    类 描述
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
  • Annotation Types Summary
    Annotation Type 描述
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

软件包 javax.xml.ws.spi Description

This package defines SPIs for JAX-WS.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


javax.xml.ws.spi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.spi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.Invoker
    • javax.xml.ws.spi.Provider
    • javax.xml.ws.spi.ServiceDelegate

Annotation Type Hierarchy

  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. hucmegsssk/jj/k"l=v


Provider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi

类 Provider

  • java.lang.Object
    • javax.xml.ws.spi.Provider

  • public abstract class Provider
extends Object
    Service provider for ServiceDelegate and Endpoint objects.

    从以下版本开始：
    JAX-WS 2.0

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String JAXWSPROVIDER_PROPERTY
      A constant representing the property used to lookup the name of a Provider implementation class.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected Provider()
      Creates a new instance of Provider

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Endpoint createAndPublishEndpoint(String address, Object implementor)
      Creates and publishes an endpoint object with the specified address and implementation object.
      Endpoint createAndPublishEndpoint(String address, Object implementor, WebServiceFeature... features)
      Creates and publishes an endpoint object with the specified address, implementation object and web service features.
      Endpoint createEndpoint(String bindingId, 类<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
      abstract Endpoint createEndpoint(String bindingId, Object implementor)
      Creates an endpoint object with the provided binding and implementation object.
      Endpoint createEndpoint(String bindingId, Object implementor, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation object and web service features.
      abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
      abstract W3CEndpointReference createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      abstract <T> T getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      static Provider provider()
      Creates a new provider object.
      abstract EndpointReference readEndpointReference(Source eprInfoset)
      read an EndpointReference from the infoset contained in eprInfoset.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • JAXWSPROVIDER_PROPERTY

        public static final String JAXWSPROVIDER_PROPERTY
        A constant representing the property used to lookup the name of a Provider implementation class.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • Provider

        protected Provider()
        Creates a new instance of Provider

    • 方法详细信息

      • provider

        public static Provider provider()
        Creates a new provider object.

        The algorithm used to locate the provider subclass to use consists of the following steps:

        • If a resource with the name of META-INF/services/javax.xml.ws.spi.Provider exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
        • If the $java.home/lib/jaxws.properties file exists and it is readable by the java.util.Properties.load(InputStream) method and it contains an entry whose key is javax.xml.ws.spi.Provider, then the value of that entry is used as the name of the implementation class.
        • If a system property with the name javax.xml.ws.spi.Provider is defined, then its value is used as the name of the implementation class.
        • Finally, a default implementation class name is used.

      • createServiceDelegate

        public abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    类<? extends Service> serviceClass)
        Creates a service delegate object.

        参数：
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        返回：
        The newly created service delegate.

      • createServiceDelegate

        public ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    类<? extends Service> serviceClass,
                                    WebServiceFeature... features)
        Creates a service delegate object.

        参数：
        wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
        serviceName - The qualified name of the service.
        serviceClass - The service class, which MUST be either javax.xml.ws.Service or a subclass thereof.
        features - Web Service features that must be configured on the service. If the provider doesn't understand a feature, it must throw a WebServiceException.
        返回：
        The newly created service delegate.
        从以下版本开始：
        JAX-WS 2.2

      • createEndpoint

        public abstract Endpoint createEndpoint(String bindingId,
                      Object implementor)
        Creates an endpoint object with the provided binding and implementation object.
        参数：
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        返回：
        The newly created endpoint.

      • createAndPublishEndpoint

        public abstract Endpoint createAndPublishEndpoint(String address,
                                Object implementor)
        Creates and publishes an endpoint object with the specified address and implementation object.
        参数：
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        返回：
        The newly created endpoint.

      • readEndpointReference

        public abstract EndpointReference readEndpointReference(Source eprInfoset)
        read an EndpointReference from the infoset contained in eprInfoset.
        参数：
        eprInfoset - infoset for EndpointReference
        返回：
        the EndpointReference unmarshalled from eprInfoset. This method never returns null.
        抛出：
        WebServiceException - If there is an error creating the EndpointReference from the specified eprInfoset.
        NullPointerException - If the null eprInfoset value is given.
        从以下版本开始：
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
            类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL metadata of the serviceEndpointInterface and the EndpointReference. For this method to successfully return a proxy, WSDL metadata MUST be available and the endpointReference MUST contain an implementation understood serviceName metadata.
        参数：
        endpointReference - the EndpointReference that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method}
        • If this endpointReference is illegal
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        WebServiceFeature

      • createW3CEndpointReference

        public abstract W3CEndpointReference createW3CEndpointReference(String address,
                                              QName serviceName,
                                              QName portName,
                                              List<Element> metadata,
                                              String wsdlDocumentLocation,
                                              List<Element> referenceParameters)
        Factory method to create a W3CEndpointReference.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        参数：
        address - Specifies the address of the target endpoint
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        返回：
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        抛出：
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName> is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        从以下版本开始：
        JAX-WS 2.1

      • createW3CEndpointReference

        public W3CEndpointReference createW3CEndpointReference(String address,
                                              QName interfaceName,
                                              QName serviceName,
                                              QName portName,
                                              List<Element> metadata,
                                              String wsdlDocumentLocation,
                                              List<Element> referenceParameters,
                                              List<Element> elements,
                                              Map<QName,String> attributes)
        Factory method to create a W3CEndpointReference. Using this method, a W3CEndpointReference instance can be created with extension elements, and attributes. Provider implementations must override the default implementation.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. To do so the address property can be provided or this method can automatically determine the address of an endpoint that is published by the same Java EE application and is identified by the serviceName and portName propeties. If the address is null and the serviceName and portName do not identify an endpoint published by the same Java EE application, a javax.lang.IllegalStateException MUST be thrown.

        参数：
        address - Specifies the address of the target endpoint
        interfaceName - the wsam:InterfaceName element in the wsa:Metadata element.
        serviceName - Qualified name of the service in the WSDL.
        portName - Qualified name of the endpoint in the WSDL.
        metadata - A list of elements that should be added to the W3CEndpointReference instances wsa:metadata element.
        wsdlDocumentLocation - URL for the WSDL document location for the service.
        referenceParameters - Reference parameters to be associated with the returned EndpointReference instance.
        elements - extension elements to be associated with the returned EndpointReference instance.
        attributes - extension attributes to be associated with the returned EndpointReference instance.
        返回：
        the W3CEndpointReference created from serviceName, portName, metadata, wsdlDocumentLocation and referenceParameters. This method never returns null.
        抛出：
        IllegalStateException -
        • If the address, serviceName and portName are all null.
        • If the serviceName service is null and the portName> is NOT null.
        • If the address property is null and the serviceName and portName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceNameis NOT null and is not present in the specified WSDL.
        • If the portName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        • If the wsdlDocumentLocation is NOT null but wsdli:wsdlLocation's namespace name cannot be got from the available metadata.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
        从以下版本开始：
        JAX-WS 2.2

      • createAndPublishEndpoint

        public Endpoint createAndPublishEndpoint(String address,
                                Object implementor,
                                WebServiceFeature... features)
        Creates and publishes an endpoint object with the specified address, implementation object and web service features. Provider implementations must override the default implementation.
        参数：
        address - A URI specifying the address and transport/protocol to use. A http: URI MUST result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        从以下版本开始：
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                      Object implementor,
                      WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation object and web service features. Provider implementations must override the default implementation.
        参数：
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
        implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class MUST be annotated with all the necessary Web service annotations.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        从以下版本开始：
        JAX-WS 2.2

      • createEndpoint

        public Endpoint createEndpoint(String bindingId,
                      类<?> implementorClass,
                      Invoker invoker,
                      WebServiceFeature... features)
        Creates an endpoint object with the provided binding, implementation class, invoker and web service features. Containers typically use this to create Endpoint objects. Provider implementations must override the default implementation.
        参数：
        bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP). Can be null.
        implementorClass - A service implementation class that MUST be annotated with all the necessary Web service annotations.
        invoker - that does the actual invocation on the service instance.
        features - A list of WebServiceFeatures to configure on the endpoint. Supported features not in the features parameter will have their default values.
        返回：
        The newly created endpoint.
        从以下版本开始：
        JAX-WS 2.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServiceDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi

类 ServiceDelegate

  • java.lang.Object
    • javax.xml.ws.spi.ServiceDelegate

  • public abstract class ServiceDelegate
extends Object
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

    Every Service object has its own delegate, created using the Provider.createServiceDelegate(java.net.URL, javax.xml.namespace.QName, java.lang.Class) method. A Service object delegates all of its instance methods to its delegate.

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Service, Provider

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ServiceDelegate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addPort(QName portName, String bindingId, String endpointAddress)
      Creates a new port for the service.
      abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(EndpointReference endpointReference, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract <T> Dispatch<T> createDispatch(QName portName, 类<T> type, Service.Mode mode)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract <T> Dispatch<T> createDispatch(QName portName, 类<T> type, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with objects of the user's choosing.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode, WebServiceFeature... features)
      Creates a Dispatch instance for use with JAXB generated objects.
      abstract Executor getExecutor()
      Returns the executor for this Serviceinstance.
      abstract HandlerResolver getHandlerResolver()
      Returns the configured handler resolver.
      abstract <T> T getPort(类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(EndpointReference endpointReference, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, 类<T> serviceEndpointInterface)
      The getPort method returns a proxy.
      abstract <T> T getPort(QName portName, 类<T> serviceEndpointInterface, WebServiceFeature... features)
      The getPort method returns a proxy.
      abstract Iterator<QName> getPorts()
      Returns an Iterator for the list of QNames of service endpoints grouped by this service
      abstract QName getServiceName()
      Gets the name of this service.
      abstract URL getWSDLDocumentLocation()
      Gets the location of the WSDL document for this Service.
      abstract void setExecutor(Executor executor)
      Sets the executor for this Service instance.
      abstract void setHandlerResolver(HandlerResolver handlerResolver)
      Sets the HandlerResolver for this Service instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceDelegate

        protected ServiceDelegate()

    • 方法详细信息

      • getPort

        public abstract <T> T getPort(QName portName,
            类<T> serviceEndpointInterface)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        参数：
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy
        返回：
        Object Proxy instance that supports the specified service endpoint interface
        抛出：
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        另请参见：
        Proxy, InvocationHandler

      • getPort

        public abstract <T> T getPort(QName portName,
            类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. A service client uses this proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy instance.
        参数：
        portName - Qualified name of the service endpoint in the WSDL service description
        serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or instance
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface
        抛出：
        WebServiceException - This exception is thrown in the following cases:
        • If there is an error in creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface or portName is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Proxy, InvocationHandler, WebServiceFeature

      • getPort

        public abstract <T> T getPort(EndpointReference endpointReference,
            类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter endpointReference specifies the endpoint that will be invoked by the returned proxy. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference metadata also has a WSDL, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. The returned proxy should not be reconfigured by the client. If this Service instance has a known proxy port that matches the information contained in the WSDL, then that proxy is returned, otherwise a WebServiceException is thrown.

        Calling this method has the same behavior as the following

         port = service.getPort(portName, serviceEndpointInterface);
        where the portName is retrieved from the metadata of the endpointReference or from the serviceEndpointInterface and the WSDL associated with this Service instance.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned proxy.
        serviceEndpointInterface - Service endpoint interface.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object Proxy instance that supports the specified service endpoint interface.
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy.
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName of this Service instance.
        • If a portName cannot be extracted from the WSDL or endpointReference metadata.
        • If an invalid endpointReference is specified.
        • If an invalid serviceEndpointInterface is specified.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1

      • getPort

        public abstract <T> T getPort(类<T> serviceEndpointInterface)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        参数：
        serviceEndpointInterface - Service endpoint interface
        返回：
        Object instance that supports the specified service endpoint interface
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified

      • getPort

        public abstract <T> T getPort(类<T> serviceEndpointInterface,
            WebServiceFeature... features)
        The getPort method returns a proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.
        参数：
        serviceEndpointInterface - Service endpoint interface
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Object instance that supports the specified service endpoint interface
        抛出：
        WebServiceException -
        • If there is an error during creation of the proxy
        • If there is any missing WSDL metadata as required by this method
        • If an illegal serviceEndpointInterface is specified
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        WebServiceFeature

      • addPort

        public abstract void addPort(QName portName,
           String bindingId,
           String endpointAddress)
        Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.
        参数：
        portName - Qualified name for the target service endpoint
        bindingId - A URI identifier of a binding.
        endpointAddress - Address of the target service endpoint as a URI
        抛出：
        WebServiceException - If any error in the creation of the port
        另请参见：
        SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                             类<T> type,
                             Service.Mode mode)
        Creates a Dispatch instance for use with objects of the user's choosing.
        参数：
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        返回：
        Dispatch instance
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object
        另请参见：
        Source, SOAPMessage

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(QName portName,
                             类<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing.
        参数：
        portName - Qualified name for the target service endpoint
        type - The class of object used for messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract <T> Dispatch<T> createDispatch(EndpointReference endpointReference,
                             类<T> type,
                             Service.Mode mode,
                             WebServiceFeature... features)
        Creates a Dispatch instance for use with objects of the user's choosing. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behaves the same as calling

         dispatch = service.createDispatch(portName, type, mode, features);
        where the portName is retrieved from the WSDL or EndpointReference metadata.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode MUST be MESSAGE when type is SOAPMessage.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • If a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        Source, SOAPMessage, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode)
        Creates a Dispatch instance for use with JAXB generated objects.
        参数：
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        返回：
        Dispatch instance
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object
        另请参见：
        JAXBContext

      • createDispatch

        public abstract Dispatch<Object> createDispatch(QName portName,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects.
        参数：
        portName - Qualified name for the target service endpoint
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - A list of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException - If any error in the creation of the Dispatch object or if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        JAXBContext, WebServiceFeature

      • createDispatch

        public abstract Dispatch<Object> createDispatch(EndpointReference endpointReference,
                              JAXBContext context,
                              Service.Mode mode,
                              WebServiceFeature... features)
        Creates a Dispatch instance for use with JAXB generated objects. If there are any reference parameters in the endpointReference, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint. The endpointReference's address MUST be used for invocations on the endpoint. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the dispatch accordingly from the WSDL associated with this Service instance or from the metadata from the endpointReference. If this Service instance has a WSDL and the endpointReference also has a WSDL in its metadata, then the WSDL from this instance MUST be used. If this Service instance does not have a WSDL and the endpointReference does have a WSDL, then the WSDL from the endpointReference MAY be used. An implementation MUST be able to retrieve the portName from the endpointReference metadata.

        This method behavies the same as calling

         dispatch = service.createDispatch(portName, context, mode, features);
        where the portName is retrieved from the WSDL or endpointReference metadata.
        参数：
        endpointReference - The EndpointReference for the target service endpoint that will be invoked by the returned Dispatch object.
        context - The JAXB context used to marshall and unmarshall messages or message payloads.
        mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
        features - An array of WebServiceFeatures to configure on the proxy. Supported features not in the features parameter will have their default values.
        返回：
        Dispatch instance
        抛出：
        WebServiceException -
        • If there is any missing WSDL metadata as required by this method.
        • If the endpointReference metadata does not match the serviceName or portName of a WSDL associated with this Service instance.
        • If the portName cannot be determined from the EndpointReference metadata.
        • If any error in the creation of the Dispatch object.
        • if a feature is enabled that is not compatible with this port or is unsupported.
        从以下版本开始：
        JAX-WS 2.1
        另请参见：
        JAXBContext, WebServiceFeature

      • getServiceName

        public abstract QName getServiceName()
        Gets the name of this service.
        返回：
        Qualified name of this service

      • getPorts

        public abstract Iterator<QName> getPorts()
        Returns an Iterator for the list of QNames of service endpoints grouped by this service
        返回：
        Returns java.util.Iterator with elements of type javax.xml.namespace.QName
        抛出：
        WebServiceException - If this Service class does not have access to the required WSDL metadata

      • getWSDLDocumentLocation

        public abstract URL getWSDLDocumentLocation()
        Gets the location of the WSDL document for this Service.
        返回：
        URL for the location of the WSDL document for this service

      • getHandlerResolver

        public abstract HandlerResolver getHandlerResolver()
        Returns the configured handler resolver.
        返回：
        HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

      • setHandlerResolver

        public abstract void setHandlerResolver(HandlerResolver handlerResolver)
        Sets the HandlerResolver for this Service instance.

        The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

        参数：
        handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
        另请参见：
        HandlerResolver

      • getExecutor

        public abstract Executor getExecutor()
        Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.
        返回：
        The java.util.concurrent.Executor to be used to invoke a callback.
        另请参见：
        Executor

      • setExecutor

        public abstract void setExecutor(Executor executor)
        Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.
        参数：
        executor - The java.util.concurrent.Executor to be used to invoke a callback.
        抛出：
        SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
        另请参见：
        Executor
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Package javax.xml.ws.spi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.spi

  • Packages that use javax.xml.ws.spi
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
  • Classes in javax.xml.ws.spi used by javax.xml.ws
    类与描述
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.soap
    类与描述
    WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.
  • Classes in javax.xml.ws.spi used by javax.xml.ws.spi
    类与描述
    Invoker
    Invoker hides the detail of calling into application endpoint implementation.
    Provider
    Service provider for ServiceDelegate and Endpoint objects.
    ServiceDelegate
    Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"l>-x;t n= nehals ====


WebServiceFeatureAnnotation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element
javax.xml.ws.spi

Annotation Type WebServiceFeatureAnnotation

  • @Target(value=ANNOTATION_TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceFeatureAnnotation
    Annotation used to identify other annotations as a WebServiceFeature.

    Each WebServiceFeature annotation annotated with this annotation MUST contain an enabled property of type boolean with a default value of true.

    JAX-WS defines the following WebServiceFeature annotations (Addressing, MTOM, RespectBinding), however, an implementation may define vendors specific annotations for other features.

    Annotations annotated with WebServiceFeatureAnnotation MUST have the same @Target of WebServiceRef annotation, so that the resulting feature annotation can be used in conjunction with the WebServiceRef annotation if necessary.

    If a JAX-WS implementation encounters an annotation annotated with the WebServiceFeatureAnnotation that it does not recognize/support an error MUST be given.

    从以下版本开始：
    JAX-WS 2.1
    另请参见：
    Addressing, MTOM, RespectBinding

    • Required Element Summary

      Required Elements
      修饰符与类型 Required Element and Description
      类<? extends WebServiceFeature> bean
      The WebServiceFeature bean that is associated with the WebServiceFeature annotation
      String id
      Unique identifier for the WebServiceFeature.

    • Element Detail

      • id

        public abstract String id
        Unique identifier for the WebServiceFeature. This identifier MUST be unique across all implementations of JAX-WS.

      • bean

        public abstract 类<? extends WebServiceFeature> bean
        The WebServiceFeature bean that is associated with the WebServiceFeature annotation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • Required |
  • Optional
  • 详细信息：
  • Element

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uhr&/>ua>utrruttcWvvh ./ill/


Uses of Class javax.xml.ws.spi.Invoker

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.Invoker

  • Packages that use Invoker
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Invoker in javax.xml.ws.spi

      Methods in javax.xml.ws.spi with parameters of type Invoker
      修饰符与类型 方法与描述
      Endpoint Provider.createEndpoint(String bindingId, 类<?> implementorClass, Invoker invoker, WebServiceFeature... features)
      Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l"/. ci


Uses of Class javax.xml.ws.spi.Provider

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.Provider

  • Packages that use Provider
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of Provider in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return Provider
      修饰符与类型 方法与描述
      static Provider Provider.provider()
      Creates a new provider object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

= = AA=AB == MEEia tine <


Uses of Class javax.xml.ws.spi.ServiceDelegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.ServiceDelegate

  • Packages that use ServiceDelegate
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.

    • Uses of ServiceDelegate in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return ServiceDelegate
      修饰符与类型 方法与描述
      abstract ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass)
      Creates a service delegate object.
      ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, 类<? extends Service> serviceClass, WebServiceFeature... features)
      Creates a service delegate object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C/.usl iodxu"t


Uses of Class javax.xml.ws.spi.WebServiceFeatureAnnotation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.WebServiceFeatureAnnotation

  • Packages that use WebServiceFeatureAnnotation
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.soap
    This package defines APIs specific to the SOAP binding.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws

      Classes in javax.xml.ws with annotations of type WebServiceFeatureAnnotation
      修饰符与类型 类与描述
      interface  RespectBinding
      This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.

    • Uses of WebServiceFeatureAnnotation in javax.xml.ws.soap

      Classes in javax.xml.ws.soap with annotations of type WebServiceFeatureAnnotation
      修饰符与类型 类与描述
      interface  Addressing
      This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
      interface  MTOM
      This feature represents the use of MTOM with a web service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mse /g>dcaias;>i萢lan=


HttpContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi.http

类 HttpContext

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext

  • public abstract class HttpContext
extends Object
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.

    Container provides the implementation for this and it matches web service requests to corresponding HttpContext objects.

    从以下版本开始：
    JAX-WS 2.2

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected HttpHandler | handler

    • 构造方法摘要

      Constructors
      构造方法与描述
      HttpContext()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Object getAttribute(String name)
      Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
      abstract Set<String> getAttributeNames()
      Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
      abstract String getPath()
      Returns the path for this context.
      void setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • handler

        protected HttpHandler handler

    • 构造方法详细信息

      • HttpContext

        public HttpContext()

    • 方法详细信息

      • setHandler

        public void setHandler(HttpHandler handler)
        JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context. Container or its extensions use this handler to process the requests.
        参数：
        handler - the handler to set for this context

      • getPath

        public abstract String getPath()
        Returns the path for this context. This path uniquely identifies an endpoint inside an application and the path is relative to application's context path. Container should give this path based on how it matches request URIs to this HttpContext object.

        For servlet container, this is typically a url-pattern for an endpoint.

        Endpoint's address for this context can be computed as follows:

          HttpExchange exch = ...;
  String endpointAddress =
      exch.getScheme() + "://"
      + exch.getLocalAddress().getHostName()
      + ":" + exch.getLocalAddress().getPort()
      + exch.getContextPath() + getPath();
        返回：
        this context's path

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.
        参数：
        name - attribute name
        返回：
        attribute value

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.
        返回：
        set of all attribute names
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0u.eageh�=vlhr>薼e


HttpExchange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi.http

类 HttpExchange

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpExchange

  • public abstract class HttpExchange
extends Object
    This class encapsulates a HTTP request received and a response to be generated in one exchange. It provides methods for examining the request from the client, and for building and sending the response.

    A HttpExchange must be closed to free or reuse underlying resources. The effect of failing to close an exchange is undefined.

    从以下版本开始：
    JAX-WS 2.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String REQUEST_CIPHER_SUITE
      Standard property: cipher suite value when the request is received over HTTPS
      static String REQUEST_KEY_SIZE
      Standard property: bit size of the algorithm when the request is received over HTTPS
      static String REQUEST_X509CERTIFICATE
      Standard property: A SSL certificate, if any, associated with the request

    • 构造方法摘要

      Constructors
      构造方法与描述
      HttpExchange()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addResponseHeader(String name, String value)
      Adds a response header with the given name and value.
      abstract void close()
      This must be called to end an exchange.
      abstract Object getAttribute(String name)
      Returns an attribute that is associated with this HttpExchange.
      abstract Set<String> getAttributeNames()
      Gives all the attribute names that are associated with this HttpExchange.
      abstract String getContextPath()
      Returns the context path of all the endpoints in an application.
      abstract HttpContext getHttpContext()
      Returns a HttpContext for this exchange.
      abstract InetSocketAddress getLocalAddress()
      Returns the unresolved local address on which the request was received.
      abstract String getPathInfo()
      Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.
      abstract String getProtocol()
      Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.
      abstract String getQueryString()
      Returns the query string that is contained in the request URI after the path.
      abstract InetSocketAddress getRemoteAddress()
      Returns the unresolved address of the remote entity invoking this request.
      abstract InputStream getRequestBody()
      Returns a stream from which the request body can be read.
      abstract String getRequestHeader(String name)
      Returns the value of the specified request header.
      abstract Map<String,List<String>> getRequestHeaders()
      Returns an immutable Map containing the HTTP headers that were included with this request.
      abstract String getRequestMethod()
      Get the HTTP request method
      abstract String getRequestURI()
      Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.
      abstract OutputStream getResponseBody()
      Returns a stream to which the response body must be written.
      abstract Map<String,List<String>> getResponseHeaders()
      Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.
      abstract String getScheme()
      Returns the name of the scheme used to make this request, for example: http, or https.
      abstract Principal getUserPrincipal()
      Returns the Principal that represents the authenticated user for this HttpExchange.
      abstract boolean isUserInRole(String role)
      Indicates whether an authenticated user is included in the specified logical "role".
      abstract void setStatus(int status)
      Sets the HTTP status code for the response.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • REQUEST_CIPHER_SUITE

        public static final String REQUEST_CIPHER_SUITE
        Standard property: cipher suite value when the request is received over HTTPS

        Type: String

        另请参见：
        Constant Field Values

      • REQUEST_KEY_SIZE

        public static final String REQUEST_KEY_SIZE
        Standard property: bit size of the algorithm when the request is received over HTTPS

        Type: Integer

        另请参见：
        Constant Field Values

      • REQUEST_X509CERTIFICATE

        public static final String REQUEST_X509CERTIFICATE
        Standard property: A SSL certificate, if any, associated with the request

        Type: java.security.cert.X509Certificate[] The order of this array is defined as being in ascending order of trust. The first certificate in the chain is the one set by the client, the next is the one used to authenticate the first, and so on.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • HttpExchange

        public HttpExchange()

    • 方法详细信息

      • getRequestHeaders

        public abstract Map<String,List<String>> getRequestHeaders()
        Returns an immutable Map containing the HTTP headers that were included with this request. The keys in this Map will be the header names, while the values will be a List of Strings containing each value that was included (either for a header that was listed several times, or one that accepts a comma-delimited list of values on a single line). In either of these cases, the values for the header name will be presented in the order that they were included in the request.

        The keys in Map are case-insensitive.

        返回：
        an immutable Map which can be used to access request headers

      • getRequestHeader

        public abstract String getRequestHeader(String name)
        Returns the value of the specified request header. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first header in the request. The header name is case-insensitive. This is a convienence method to get a header (instead of using the getRequestHeaders()).
        参数：
        name - the name of the request header
        返回：
        returns the value of the requested header, or null if the request does not have a header of that name

      • getResponseHeaders

        public abstract Map<String,List<String>> getResponseHeaders()
        Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response. The keys in the Map will be the header names, while the values must be a List of Strings containing each value that should be included multiple times (in the order that they should be included).

        The keys in Map are case-insensitive.

        返回：
        a mutable Map which can be used to set response headers.

      • addResponseHeader

        public abstract void addResponseHeader(String name,
                     String value)
        Adds a response header with the given name and value. This method allows a response header to have multiple values. This is a convenience method to add a response header(instead of using the getResponseHeaders()).
        参数：
        name - the name of the header
        value - the additional header value. If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
        另请参见：
        getResponseHeaders()

      • getRequestURI

        public abstract String getRequestURI()
        Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request. Container doesn't decode this string.
        返回：
        the request URI

      • getContextPath

        public abstract String getContextPath()
        Returns the context path of all the endpoints in an application. This path is the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. If this method returns "", the request is for default context. The container does not decode this string.

        Context path is used in computing the endpoint address. See HttpContext.getPath()

        返回：
        context path of all the endpoints in an application
        另请参见：
        HttpContext.getPath()

      • getRequestMethod

        public abstract String getRequestMethod()
        Get the HTTP request method
        返回：
        the request method

      • getHttpContext

        public abstract HttpContext getHttpContext()
        Returns a HttpContext for this exchange. Container matches the request with the associated Endpoint's HttpContext
        返回：
        the HttpContext for this exchange

      • close

        public abstract void close()
                    throws IOException
        This must be called to end an exchange. Container takes care of closing request and response streams. This must be called so that the container can free or reuse underlying resources.
        抛出：
        IOException - if any i/o error

      • getRequestBody

        public abstract InputStream getRequestBody()
                                    throws IOException
        Returns a stream from which the request body can be read. Multiple calls to this method will return the same stream.
        返回：
        the stream from which the request body can be read.
        抛出：
        IOException - if any i/o error during request processing

      • getResponseBody

        public abstract OutputStream getResponseBody()
                                      throws IOException
        Returns a stream to which the response body must be written. setStatus(int)) must be called prior to calling this method. Multiple calls to this method (for the same exchange) will return the same stream.
        返回：
        the stream to which the response body is written
        抛出：
        IOException - if any i/o error during response processing

      • setStatus

        public abstract void setStatus(int status)
        Sets the HTTP status code for the response.

        This method must be called prior to calling getResponseBody().

        参数：
        status - the response code to send
        另请参见：
        getResponseBody()

      • getRemoteAddress

        public abstract InetSocketAddress getRemoteAddress()
        Returns the unresolved address of the remote entity invoking this request.
        返回：
        the InetSocketAddress of the caller

      • getLocalAddress

        public abstract InetSocketAddress getLocalAddress()
        Returns the unresolved local address on which the request was received.
        返回：
        the InetSocketAddress of the local interface

      • getProtocol

        public abstract String getProtocol()
        Returns the protocol string from the request in the form protocol/majorVersion.minorVersion. For example, "HTTP/1.1"
        返回：
        the protocol string from the request

      • getScheme

        public abstract String getScheme()
        Returns the name of the scheme used to make this request, for example: http, or https.
        返回：
        name of the scheme used to make this request

      • getPathInfo

        public abstract String getPathInfo()
        Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

        This can be used for MessageContext.PATH_INFO

        返回：
        decoded extra path information of web service. It is the path that comes after the web service path but before the query string in the request URI null if there is no extra path in the request URI

      • getQueryString

        public abstract String getQueryString()
        Returns the query string that is contained in the request URI after the path.

        This can be used for MessageContext.QUERY_STRING

        返回：
        undecoded query string of request URI, or null if the request URI doesn't have one

      • getAttribute

        public abstract Object getAttribute(String name)
        Returns an attribute that is associated with this HttpExchange. JAX-WS handlers and endpoints may then access the attribute via MessageContext.

        Servlet containers must expose MessageContext.SERVLET_CONTEXT, MessageContext.SERVLET_REQUEST, and MessageContext.SERVLET_RESPONSE as attributes.

        If the request has been received by the container using HTTPS, the following information must be exposed as attributes. These attributes are REQUEST_CIPHER_SUITE, and REQUEST_KEY_SIZE. If there is a SSL certificate associated with the request, it must be exposed using REQUEST_X509CERTIFICATE

        参数：
        name - attribute name
        返回：
        the attribute value, or null if the attribute doesn't exist

      • getAttributeNames

        public abstract Set<String> getAttributeNames()
        Gives all the attribute names that are associated with this HttpExchange.
        返回：
        set of all attribute names
        另请参见：
        getAttribute(String)

      • getUserPrincipal

        public abstract Principal getUserPrincipal()
        Returns the Principal that represents the authenticated user for this HttpExchange.
        返回：
        Principal for an authenticated user, or null if not authenticated

      • isUserInRole

        public abstract boolean isUserInRole(String role)
        Indicates whether an authenticated user is included in the specified logical "role".
        参数：
        role - specifies the name of the role
        返回：
        true if the user making this request belongs to a given role
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


HttpHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.spi.http

类 HttpHandler

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpHandler

  • public abstract class HttpHandler
extends Object
    A handler which is invoked to process HTTP requests.

    JAX-WS runtime provides the implementation for this and sets it using HttpContext.setHandler(HttpHandler) during Endpoint.publish(HttpContext)

    从以下版本开始：
    JAX-WS 2.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      HttpHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HttpHandler

        public HttpHandler()

    • 方法详细信息

      • handle

        public abstract void handle(HttpExchange exchange)
                     throws IOException
        Handles a given request and generates an appropriate response. See HttpExchange for a description of the steps involved in handling an exchange. Container invokes this method when it receives an incoming request.
        参数：
        exchange - the exchange containing the request from the client and used to send the response
        抛出：
        IOException - when an I/O error happens during request handling
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dri)rn//<>>sceehg/a"==/whstmxx.aa.#


javax.xml.ws.spi.http

Classes

  • HttpContext
  • HttpExchange
  • HttpHandler
�


javax.xml.ws.spi.http

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.spi.http

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

请参见： 描述

  • Class Summary
    类 描述
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.

软件包 javax.xml.ws.spi.http Description

Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g. servlet containers). This SPI is not for end developers but provides a way for the container developers to deploy JAX-WS services portably.

The portable deployment is done as below:

  1. Container creates Endpoint objects for an application. The necessary information to create Endpoint objects may be got from web service deployment descriptor files.
  2. Container needs to create HttpContext objects for the deployment. For example, a HttpContext could be created using servlet configuration(for e.g url-pattern) for the web service in servlet container case.
  3. Then publishes all the endpoints using Endpoint.publish(HttpContext). During publish(), JAX-WS runtime registers a HttpHandler callback to handle incoming requests or HttpExchange objects. The HttpExchange object encapsulates a HTTP request and a response.
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates Invoker1, ... InvokerN
  2. Provider.createEndpoint(...)     --> 3. creates Endpoint1
     configures Endpoint1
     ...
  4. Provider.createEndpoint(...)     --> 5. creates EndpointN
     configures EndpointN
  6. Creates ApplicationContext
  7. creates HttpContext1, ... HttpContextN
  8. Endpoint1.publish(HttpContext1)  --> 9. creates HttpHandler1
                                          HttpContext1.setHandler(HttpHandler1)
     ...
 10. EndpointN.publish(HttpContextN)  --> 11. creates HttpHandlerN
                                         HttpContextN.setHandler(HttpHandlerN)
The request processing is done as below(for every request):
  Container                               JAX-WS runtime
  ---------                               --------------
  1. Creates a HttpExchange
  2. Gets handler from HttpContext
  3. HttpHandler.handle(HttpExchange) --> 4. reads request from HttpExchange
                                      <-- 5. Calls Invoker
  6. Invokes the actual instance
                                          7. Writes the response to HttpExchange

The portable undeployment is done as below:

  Container
  ---------
  1. @preDestroy on instances
  2. Endpoint1.stop()
  ...
  3. EndpointN.stop()
从以下版本开始：
JAX-WS 2.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

reeslr.rhf//.aLL繪=l .


javax.xml.ws.spi.http Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.spi.http

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.http.HttpContext
    • javax.xml.ws.spi.http.HttpExchange
    • javax.xml.ws.spi.http.HttpHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laec l >


Uses of Package javax.xml.ws.spi.http

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.spi.http

  • Packages that use javax.xml.ws.spi.http
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws
    类与描述
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
  • Classes in javax.xml.ws.spi.http used by javax.xml.ws.spi.http
    类与描述
    HttpContext
    HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
    HttpExchange
    This class encapsulates a HTTP request received and a response to be generated in one exchange.
    HttpHandler
    A handler which is invoked to process HTTP requests.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>p>loep l�/t".�i


Uses of Class javax.xml.ws.spi.http.HttpContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.http.HttpContext

  • Packages that use HttpContext
    软件包 描述
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpContext in javax.xml.ws

      Methods in javax.xml.ws with parameters of type HttpContext
      修饰符与类型 方法与描述
      void Endpoint.publish(HttpContext serverContext)
      Publishes this endpoint at the provided server context.

    • Uses of HttpContext in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http that return HttpContext
      修饰符与类型 方法与描述
      abstract HttpContext HttpExchange.getHttpContext()
      Returns a HttpContext for this exchange.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ealaie.ia la


Uses of Class javax.xml.ws.spi.http.HttpExchange

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.http.HttpExchange

  • Packages that use HttpExchange
    软件包 描述
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpExchange in javax.xml.ws.spi.http

      Methods in javax.xml.ws.spi.http with parameters of type HttpExchange
      修饰符与类型 方法与描述
      abstract void HttpHandler.handle(HttpExchange exchange)
      Handles a given request and generates an appropriate response.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class javax.xml.ws.spi.http.HttpHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.spi.http.HttpHandler

  • Packages that use HttpHandler
    软件包 描述
    javax.xml.ws.spi.http
    Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.

    • Uses of HttpHandler in javax.xml.ws.spi.http

      Fields in javax.xml.ws.spi.http declared as HttpHandler
      修饰符与类型 | 字段与描述
      protected HttpHandler | HttpContext.handler
      Methods in javax.xml.ws.spi.http with parameters of type HttpHandler
      修饰符与类型 方法与描述
      void HttpContext.setHandler(HttpHandler handler)
      JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pe./n,gs ae瑈oip髇ps挝>o


javax.xml.ws.wsaddressing

Classes

  • W3CEndpointReference
  • W3CEndpointReferenceBuilder


javax.xml.ws.wsaddressing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.ws.wsaddressing

This package defines APIs related to WS-Addressing.

请参见： 描述

  • Class Summary
    类 描述
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.

软件包 javax.xml.ws.wsaddressing Description

This package defines APIs related to WS-Addressing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>elvteEe


javax.xml.ws.wsaddressing Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.ws.wsaddressing

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< >b


Uses of Package javax.xml.ws.wsaddressing

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.ws.wsaddressing

  • Packages that use javax.xml.ws.wsaddressing
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.spi
    类与描述
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
  • Classes in javax.xml.ws.wsaddressing used by javax.xml.ws.wsaddressing
    类与描述
    W3CEndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
    W3CEndpointReferenceBuilder
    This class is used to build W3CEndpointReference instances.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/sung=yk"nop)1h/>muht


W3CEndpointReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.wsaddressing

类 W3CEndpointReference

  • java.lang.Object
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference

  • public final class W3CEndpointReference
extends EndpointReference
    This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.

    Developers should use this class in their SEIs if they want to pass/return endpoint references that represent the W3C WS-Addressing recommendation.

    JAXB will use the JAXB annotations and bind this class to XML infoset that is consistent with that defined by WS-Addressing. See WS-Addressing for more information on WS-Addressing EndpointReferences.

    从以下版本开始：
    JAX-WS 2.1

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      protected static String | NS

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | W3CEndpointReference()
        W3CEndpointReference(Source source)
      Creates an EPR from infoset representation

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void writeTo(Result result)
      write this EndpointReference to the specified infoset format

      • 方法 - 继承于类 javax.xml.ws.EndpointReference

        getPort, readFrom, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • NS

        protected static final String NS
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • W3CEndpointReference

        protected W3CEndpointReference()

      • W3CEndpointReference

        public W3CEndpointReference(Source source)
        Creates an EPR from infoset representation
        参数：
        source - A source object containing valid XmlInfoset instance consistent with the W3C WS-Addressing Core recommendation.
        抛出：
        WebServiceException - If the source does NOT contain a valid W3C WS-Addressing EndpointReference.
        NullPointerException - If the null source value is given

    • 方法详细信息

      • writeTo

        public void writeTo(Result result)
        write this EndpointReference to the specified infoset format
        指定者：
        writeTo in class EndpointReference
        参数：
        result - for writing infoset
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>v tra#;dbv>= vs-<� /xr琧e�


W3CEndpointReferenceBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.ws.wsaddressing

类 W3CEndpointReferenceBuilder

  • java.lang.Object
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • public final class W3CEndpointReferenceBuilder
extends Object
    This class is used to build W3CEndpointReference instances. The intended use of this clsss is for an application component, for example a factory component, to create an W3CEndpointReference for a web service endpoint published by the same Java EE application. It can also be used to create W3CEndpointReferences for an Java SE based endpoint by providing the address property.

    When creating a W3CEndpointReference for an endpoint that is not published by the same Java EE application, the address property MUST be specified.

    When creating a W3CEndpointReference for an endpoint published by the same Java EE application, the address property MAY be null but then the serviceName and endpointName MUST specify an endpoint published by the same Java EE application.

    When the wsdlDocumentLocation is specified it MUST refer to a valid WSDL document and the serviceName and endpointName (if specified) MUST match a service and port in the WSDL document.

    从以下版本开始：
    JAX-WS 2.1

    • 构造方法摘要

      Constructors
      构造方法与描述
      W3CEndpointReferenceBuilder()
      Creates a new W3CEndpointReferenceBuilder instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      W3CEndpointReferenceBuilder address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReference build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
      W3CEndpointReferenceBuilder element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • W3CEndpointReferenceBuilder

        public W3CEndpointReferenceBuilder()
        Creates a new W3CEndpointReferenceBuilder instance.

    • 方法详细信息

      • address

        public W3CEndpointReferenceBuilder address(String address)
        Sets the address to the W3CEndpointReference instance's wsa:Address.

        The address MUST be set to a non-null value when building a W3CEndpointReference for a web service endpoint that is not published by the same Java EE application or when running on Java SE.

        参数：
        address - The address of the endpoint to be targeted by the returned W3CEndpointReference.
        返回：
        A W3CEndpointReferenceBuilder instance with the address set to the wsa:Address.

      • interfaceName

        public W3CEndpointReferenceBuilder interfaceName(QName interfaceName)
        Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        参数：
        interfaceName - The port type name of the endpoint to be targeted by the returned W3CEndpointReference.
        返回：
        A W3CEndpointReferenceBuilder instance with the interfaceName as wsam:InterfaceName element added to the wsa:Metadata element

      • serviceName

        public W3CEndpointReferenceBuilder serviceName(QName serviceName)
        Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element. See 2.1 Referencing WSDL Metadata from an EPR for more details.
        参数：
        serviceName - The service name of the endpoint to be targeted by the returned W3CEndpointReference. This property may also be used with the endpointName (portName) property to lookup the address of a web service endpoint that is published by the same Java EE application.
        返回：
        A W3CEndpointReferenceBuilder instance with the serviceName as wsam:ServiceName element added to the wsa:Metadata element

      • endpointName

        public W3CEndpointReferenceBuilder endpointName(QName endpointName)
        Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element. This method can only be called after the serviceName method has been called.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        参数：
        endpointName - The name of the endpoint to be targeted by the returned W3CEndpointReference. The endpointName (portName) property may also be used with the serviceName property to lookup the address of a web service endpoint published by the same Java EE application.
        返回：
        A W3CEndpointReferenceBuilder instance with the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
        抛出：
        IllegalStateException, - if the serviceName has not been set.
        IllegalArgumentException, - if the endpointName's Namespace URI doesn't match serviceName's Namespace URI

      • wsdlDocumentLocation

        public W3CEndpointReferenceBuilder wsdlDocumentLocation(String wsdlDocumentLocation)
        Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation. The namespace name for the wsdli:wsdlLocation's value can be taken from the WSDL itself.

        See 2.1 Referencing WSDL Metadata from an EPR for more details.

        参数：
        wsdlDocumentLocation - The location of the WSDL document to be referenced in the wsa:Metadata of the W3CEndpointReference.
        返回：
        A W3CEndpointReferenceBuilder instance with the wsdlDocumentLocation that is to be referenced.

      • referenceParameter

        public W3CEndpointReferenceBuilder referenceParameter(Element referenceParameter)
        Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
        参数：
        referenceParameter - The element to be added to the wsa:ReferenceParameters element.
        返回：
        A W3CEndpointReferenceBuilder instance with the referenceParameter added to the wsa:ReferenceParameters element.
        抛出：
        IllegalArgumentException - if referenceParameter is null.

      • metadata

        public W3CEndpointReferenceBuilder metadata(Element metadataElement)
        Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
        参数：
        metadataElement - The element to be added to the wsa:Metadata element.
        返回：
        A W3CEndpointReferenceBuilder instance with the metadataElement added to the wsa:Metadata element.
        抛出：
        IllegalArgumentException - if metadataElement is null.

      • element

        public W3CEndpointReferenceBuilder element(Element element)
        Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
        参数：
        element - The extension element to be added to the W3CEndpointReference
        返回：
        A W3CEndpointReferenceBuilder instance with the extension element added to the W3CEndpointReference instance.
        抛出：
        IllegalArgumentException - if element is null.
        从以下版本开始：
        JAX-WS 2.2

      • attribute

        public W3CEndpointReferenceBuilder attribute(QName name,
                                    String value)
        Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
        参数：
        name - The name of the extension attribute to be added to the W3CEndpointReference
        value - extension attribute value
        返回：
        A W3CEndpointReferenceBuilder instance with the extension attribute added to the W3CEndpointReference instance.
        抛出：
        IllegalArgumentException - if name or value is null.
        从以下版本开始：
        JAX-WS 2.2

      • build

        public W3CEndpointReference build()
        Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.

        This method can be used to create a W3CEndpointReference for any endpoint by specifying the address property along with any other desired properties. This method can also be used to create a W3CEndpointReference for an endpoint that is published by the same Java EE application. This method can automatically determine the address of an endpoint published by the same Java EE application that is identified by the serviceName and endpointName properties. If the address is null and the serviceName and endpointName do not identify an endpoint published by the same Java EE application, a java.lang.IllegalStateException MUST be thrown.

        返回：
        W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance. This method never returns null.
        抛出：
        IllegalStateException -
        • If the address, serviceName and endpointName are all null.
        • If the serviceName service is null and the endpointName is NOT null.
        • If the address property is null and the serviceName and endpointName do not specify a valid endpoint published by the same Java EE application.
        • If the serviceName is NOT null and is not present in the specified WSDL.
        • If the endpointName port is not null and it is not present in serviceName service in the WSDL.
        • If the wsdlDocumentLocation is NOT null and does not represent a valid WSDL.
        WebServiceException - If an error occurs while creating the W3CEndpointReference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReference

  • Packages that use W3CEndpointReference
    软件包 描述
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReference in javax.xml.ws.spi

      Methods in javax.xml.ws.spi that return W3CEndpointReference
      修饰符与类型 方法与描述
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of W3CEndpointReference in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReference
      修饰符与类型 方法与描述
      W3CEndpointReference W3CEndpointReferenceBuilder.build()
      Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/li


Uses of Class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

  • Packages that use W3CEndpointReferenceBuilder
    软件包 描述
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.

    • Uses of W3CEndpointReferenceBuilder in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing that return W3CEndpointReferenceBuilder
      修饰符与类型 方法与描述
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.address(String address)
      Sets the address to the W3CEndpointReference instance's wsa:Address.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.attribute(QName name, String value)
      Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.endpointName(QName endpointName)
      Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.interfaceName(QName interfaceName)
      Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.serviceName(QName serviceName)
      Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.wsdlDocumentLocation(String wsdlDocumentLocation)
      Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/l


javax.xml.xpath

Interfaces

  • XPath
  • XPathExpression
  • XPathFunction
  • XPathFunctionResolver
  • XPathVariableResolver

Classes

  • XPathConstants
  • XPathFactory

Exceptions

  • XPathException
  • XPathExpressionException
  • XPathFactoryConfigurationException
  • XPathFunctionException


javax.xml.xpath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package javax.xml.xpath

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

请参见： 描述

  • 接口摘要
    接口 描述
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
  • Class Summary
    类 描述
    XPathConstants
    XPath constants.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
  • Exception Summary
    Exception 描述
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.

软件包 javax.xml.xpath Description

This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

The following XML standards apply:

  • XML Path Language (XPath) Version 1.0

XPath Overview

The XPath language provides a simple, concise syntax for selecting nodes from an XML document. XPath also provides rules for converting a node in an XML document object model (DOM) tree to a boolean, double, or string value. XPath is a W3C-defined language and an official W3C recommendation; the W3C hosts the XML Path Language (XPath) Version 1.0 specification.

XPath started in life in 1999 as a supplement to the XSLT and XPointer languages, but has more recently become popular as a stand-alone language, as a single XPath expression can be used to replace many lines of DOM API code.

XPath Expressions

An XPath expression is composed of a location path and one or more optional predicates. Expressions may also include XPath variables.

The following is an example of a simple XPath expression:

/foo/bar

This example would select the <bar> element in an XML document such as the following:

<foo>
<bar/>
</foo>

The expression /foo/bar is an example of a location path. While XPath location paths resemble Unix-style file system paths, an important distinction is that XPath expressions return all nodes that match the expression. Thus, all three <bar> elements in the following document would be selected by the /foo/bar expression:

<foo>
<bar/>
<bar/>
<bar/>
</foo>

A special location path operator, //, selects nodes at any depth in an XML document. The following example selects all <bar> elements regardless of their location in a document:

//bar

A wildcard operator, *, causes all element nodes to be selected. The following example selects all children elements of a <foo> element:

/foo/*

In addition to element nodes, XPath location paths may also address attribute nodes, text nodes, comment nodes, and processing instruction nodes. The following table gives examples of location paths for each of these node types:

Location Path | 描述
/foo/bar/@id | Selects the attribute id of the <bar> element
/foo/bar/text() | Selects the text nodes of the <bar> element. No distinction is made between escaped and non-escaped character data.
/foo/bar/comment() | Selects all comment nodes contained in the <bar> element.
/foo/bar/processing-instruction() | Selects all processing-instruction nodes contained in the <bar> element.

Predicates allow for refining the nodes selected by an XPath location path. Predicates are of the form [expression]. The following example selects all <foo> elements that contain an include attribute with the value of true:

//foo[@include='true']

Predicates may be appended to each other to further refine an expression, such as:

//foo[@include='true'][@mode='bar']

Using the XPath API

The following example demonstrates using the XPath API to select one or more nodes from an XML document:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
InputSource inputSource = new InputSource("widgets.xml");
NodeList nodes = (NodeList) xpath.evaluate(expression, inputSource, XPathConstants.NODESET);

XPath Expressions and Types

While XPath expressions select nodes in the XML document, the XPath API allows the selected nodes to be coalesced into one of the following other data types:

  • Boolean
  • Number
  • String

The desired return type is specified by a QName parameter in method call used to evaluate the expression, which is either a call to XPathExpression.evalute(...) or to one of the XPath.evaluate(...) convenience methods. The allowed QName values are specified as constants in the XPathConstants class; they are:

  • XPathConstants.NODESET
  • XPathConstants.NODE
  • XPathConstants.STRING
  • XPathConstants.BOOLEAN
  • XPathConstants.NUMBER

When a Boolean return type is requested, Boolean.TRUE is returned if one or more nodes were selected; otherwise, Boolean.FALSE is returned.

The String return type is a convenience for retrieving the character data from a text node, attribute node, comment node, or processing-instruction node. When used on an element node, the value of the child text nodes is returned.

The Number return type attempts to coalesce the text of a node to a double data type.

XPath Context

XPath location paths may be relative to a particular node in the document, known as the context. Consider the following XML document:

<widgets>
<widget>
<manufacturer/>
<dimensions/>
</widget>
</widgets>

The <widget> element can be selected with the following XPath API code:

// parse the XML as a W3C Document
DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document document = builder.parse(new File("/widgets.xml"));

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
Node widgetNode = (Node) xpath.evaluate(expression, document, XPathConstants.NODE);

With a reference to the <widget> element, a relative XPath expression can now written to select the <manufacturer> child element:

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "manufacturer";
Node manufacturerNode = (Node) xpath.evaluate(expression, widgetNode, XPathConstants.NODE);
  • Author Ben Galbraith
  • Author Norman Walsh
  • Author Jeff Suttor
  • See XML Path Language (XPath) Version 1.0
  • Since 1.5
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

do/dtblmlksy！h趋�.


javax.xml.xpath Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package javax.xml.xpath

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory

Interface Hierarchy

  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ieot Xoinnnuteedhccsl


Uses of Package javax.xml.xpath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
javax.xml.xpath

  • Packages that use javax.xml.xpath
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
  • Classes in javax.xml.xpath used by javax.xml.xpath
    类与描述
    XPath
    XPath provides access to the XPath evaluation environment and expressions.
    XPathException
    XPathException represents a generic XPath exception.
    XPathExpression
    XPathExpression provides access to compiled XPath expressions.
    XPathExpressionException
    XPathExpressionException represents an error in an XPath expression.
    XPathFactory
    An XPathFactory instance can be used to create XPath objects.
    XPathFactoryConfigurationException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
    XPathFunction
    XPathFunction provides access to XPath functions.
    XPathFunctionException
    XPathFunctionException represents an error with an XPath function.
    XPathFunctionResolver
    XPathFunctionResolver provides access to the set of user defined XPathFunctions.
    XPathVariableResolver
    XPathVariableResolver provides access to the set of user defined XPath variables.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o pe


XPath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.xpath

Interface XPath

  • public interface XPath

    XPath provides access to the XPath evaluation environment and expressions.

    Evaluation of XPath Expressions.
    context | If a request is made to evaluate the expression in the absence of a context item, an empty document node will be used for the context. For the purposes of evaluating XPath expressions, a DocumentFragment is treated like a Document node.
    variables If the expression contains a variable reference, its value will be found through the XPathVariableResolver set with setXPathVariableResolver(XPathVariableResolver resolver). An XPathExpressionException is raised if the variable resolver is undefined or the resolver returns null for the variable. The value of a variable must be immutable through the course of any single evaluation.
    functions If the expression contains a function reference, the function will be found through the XPathFunctionResolver set with setXPathFunctionResolver(XPathFunctionResolver resolver). An XPathExpressionException is raised if the function resolver is undefined or the function resolver returns null for the function.
    QNames | QNames in the expression are resolved against the XPath namespace context set with setNamespaceContext(NamespaceContext nsContext).
    result This result of evaluating an expression is converted to an instance of the desired return type. Valid return types are defined in XPathConstants. Conversion to the return type follows XPath conversion rules.

    An XPath object is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one XPath object is not used from more than one thread at any given time, and while the evaluate method is invoked, applications may not recursively call the evaluate method.

    从以下版本开始：
    1.5
    另请参见：
    XML Path Language (XPath) Version 1.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XPathExpression compile(String expression)
      Compile an XPath expression for later evaluation.
      String evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      String evaluate(String expression, Object item)
      Evaluate an XPath expression in the specified context and return the result as a String.
      Object evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
      NamespaceContext getNamespaceContext()
      Return the current namespace context.
      XPathFunctionResolver getXPathFunctionResolver()
      Return the current function resolver.
      XPathVariableResolver getXPathVariableResolver()
      Return the current variable resolver.
      void reset()
      Reset this XPath to its original configuration.
      void setNamespaceContext(NamespaceContext nsContext)
      Establish a namespace context.
      void setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a function resolver.
      void setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a variable resolver.

    • 方法详细信息

      • reset

        void reset()

        Reset this XPath to its original configuration.

        XPath is reset to the same state as when it was created with XPathFactory.newXPath(). reset() is designed to allow the reuse of existing XPaths thus saving resources associated with the creation of new XPaths.

        The reset XPath is not guaranteed to have the same XPathFunctionResolver, XPathVariableResolver or NamespaceContext Objects, e.g. Object.equals(Object obj). It is guaranteed to have a functionally equal XPathFunctionResolver, XPathVariableResolver and NamespaceContext.

      • setXPathVariableResolver

        void setXPathVariableResolver(XPathVariableResolver resolver)

        Establish a variable resolver.

        A NullPointerException is thrown if resolver is null.

        参数：
        resolver - Variable resolver.
        抛出：
        NullPointerException - If resolver is null.

      • getXPathVariableResolver

        XPathVariableResolver getXPathVariableResolver()

        Return the current variable resolver.

        null is returned in no variable resolver is in effect.

        返回：
        Current variable resolver.

      • setXPathFunctionResolver

        void setXPathFunctionResolver(XPathFunctionResolver resolver)

        Establish a function resolver.

        A NullPointerException is thrown if resolver is null.

        参数：
        resolver - XPath function resolver.
        抛出：
        NullPointerException - If resolver is null.

      • getXPathFunctionResolver

        XPathFunctionResolver getXPathFunctionResolver()

        Return the current function resolver.

        null is returned in no function resolver is in effect.

        返回：
        Current function resolver.

      • setNamespaceContext

        void setNamespaceContext(NamespaceContext nsContext)

        Establish a namespace context.

        A NullPointerException is thrown if nsContext is null.

        参数：
        nsContext - Namespace context to use.
        抛出：
        NullPointerException - If nsContext is null.

      • getNamespaceContext

        NamespaceContext getNamespaceContext()

        Return the current namespace context.

        null is returned in no namespace context is in effect.

        返回：
        Current Namespace context.

      • compile

        XPathExpression compile(String expression)
                        throws XPathExpressionException

        Compile an XPath expression for later evaluation.

        If expression contains any XPathFunctions, they must be available via the XPathFunctionResolver. An XPathExpressionException will be thrown if the XPathFunction cannot be resovled with the XPathFunctionResolver.

        If expression contains any variables, the XPathVariableResolver in effect at compile time will be used to resolve them.

        If expression is null, a NullPointerException is thrown.

        参数：
        expression - The XPath expression.
        返回：
        Compiled XPath expression.
        抛出：
        XPathExpressionException - If expression cannot be compiled.
        NullPointerException - If expression is null.

      • evaluate

        Object evaluate(String expression,
              Object item,
              QName returnType)
                throws XPathExpressionException

        Evaluate an XPath expression in the specified context and return the result as the specified type.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants ( NUMBER, STRING, BOOLEAN, NODE or NODESET) then an IllegalArgumentException is thrown.

        If a null value is provided for item, an empty document will be used for the context. If expression or returnType is null, then a NullPointerException is thrown.

        参数：
        expression - The XPath expression.
        item - The starting context (a node, for example).
        returnType - The desired return type.
        返回：
        Result of evaluating an XPath expression as an Object of returnType.
        抛出：
        XPathExpressionException - If expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If expression or returnType is null.

      • evaluate

        String evaluate(String expression,
              Object item)
                throws XPathExpressionException

        Evaluate an XPath expression in the specified context and return the result as a String.

        This method calls evaluate(String expression, Object item, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If a null value is provided for item, an empty document will be used for the context. If expression is null, then a NullPointerException is thrown.

        参数：
        expression - The XPath expression.
        item - The starting context (a node, for example).
        返回：
        The String that is the result of evaluating the expression and converting the result to a String.
        抛出：
        XPathExpressionException - If expression cannot be evaluated.
        NullPointerException - If expression is null.

      • evaluate

        Object evaluate(String expression,
              InputSource source,
              QName returnType)
                throws XPathExpressionException

        Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.

        This method builds a data model for the InputSource and calls evaluate(String expression, Object item, QName returnType) on the resulting document object.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If expression, source or returnType is null, then a NullPointerException is thrown.

        参数：
        expression - The XPath expression.
        source - The input source of the document to evaluate over.
        returnType - The desired return type.
        返回：
        The Object that encapsulates the result of evaluating the expression.
        抛出：
        XPathExpressionException - If expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If expression, source or returnType is null.

      • evaluate

        String evaluate(String expression,
              InputSource source)
                throws XPathExpressionException

        Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.

        This method calls evaluate(String expression, InputSource source, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If expression or source is null, then a NullPointerException is thrown.

        参数：
        expression - The XPath expression.
        source - The InputSource of the document to evaluate over.
        返回：
        The String that is the result of evaluating the expression and converting the result to a String.
        抛出：
        XPathExpressionException - If expression cannot be evaluated.
        NullPointerException - If expression or source is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


XPathConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
javax.xml.xpath

类 XPathConstants

  • java.lang.Object
    • javax.xml.xpath.XPathConstants

  • public class XPathConstants
extends Object

    XPath constants.

    从以下版本开始：
    1.5
    另请参见：
    XML Path Language (XPath) Version 1.0

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static QName BOOLEAN
      The XPath 1.0 boolean data type.
      static String DOM_OBJECT_MODEL
      The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".
      static QName NODE
      The XPath 1.0 NodeSet data type.
      static QName NODESET
      The XPath 1.0 NodeSet data type.
      static QName NUMBER
      The XPath 1.0 number data type.
      static QName STRING
      The XPath 1.0 string data type.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • NUMBER

        public static final QName NUMBER

        The XPath 1.0 number data type.

        Maps to Java Double.

      • STRING

        public static final QName STRING

        The XPath 1.0 string data type.

        Maps to Java String.

      • BOOLEAN

        public static final QName BOOLEAN

        The XPath 1.0 boolean data type.

        Maps to Java Boolean.

      • NODESET

        public static final QName NODESET

        The XPath 1.0 NodeSet data type.

        Maps to Java NodeList.

      • NODE

        public static final QName NODE

        The XPath 1.0 NodeSet data type.

        Maps to Java Node.

      • DOM_OBJECT_MODEL

        public static final String DOM_OBJECT_MODEL

        The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e s/ovelvelRlblla"aa...r......e.h/eo


XPathException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.xpath

类 XPathException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    XPathExpressionException, XPathFactoryConfigurationException

    public class XPathException
extends Exception
    XPathException represents a generic XPath exception.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathException(String message)
      Constructs a new XPathException with the specified detail message.
      XPathException(Throwable cause)
      Constructs a new XPathException with the specified cause.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Get the cause of this XPathException.
      void printStackTrace()
      Print stack trace to System.err.
      void printStackTrace(PrintStream s)
      Print stack trace to specified PrintStream.
      void printStackTrace(PrintWriter s)
      Print stack trace to specified PrintWriter.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XPathException

        public XPathException(String message)

        Constructs a new XPathException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        参数：
        message - The detail message.
        抛出：
        NullPointerException - When message is null.

      • XPathException

        public XPathException(Throwable cause)

        Constructs a new XPathException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        参数：
        cause - The cause.
        抛出：
        NullPointerException - if cause is null.

    • 方法详细信息

      • getCause

        public Throwable getCause()

        Get the cause of this XPathException.

        重载：
        getCause in class Throwable
        返回：
        Cause of this XPathException.

      • printStackTrace

        public void printStackTrace(PrintStream s)

        Print stack trace to specified PrintStream.

        重载：
        printStackTrace in class Throwable
        参数：
        s - Print stack trace to this PrintStream.

      • printStackTrace

        public void printStackTrace()

        Print stack trace to System.err.

        重载：
        printStackTrace in class Throwable

      • printStackTrace

        public void printStackTrace(PrintWriter s)

        Print stack trace to specified PrintWriter.

        重载：
        printStackTrace in class Throwable
        参数：
        s - Print stack trace to this PrintWriter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

SoA; citnci/=,edcD.>t/dto fc>>/f<>"


XPathExpression

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.xpath

Interface XPathExpression

  • public interface XPathExpression

    XPathExpression provides access to compiled XPath expressions.

    Evaluation of XPath Expressions.
    context | If a request is made to evaluate the expression in the absence of a context item, an empty document node will be used for the context. For the purposes of evaluating XPath expressions, a DocumentFragment is treated like a Document node.
    variables If the expression contains a variable reference, its value will be found through the XPathVariableResolver. An XPathExpressionException is raised if the variable resolver is undefined or the resolver returns null for the variable. The value of a variable must be immutable through the course of any single evaluation.
    functions If the expression contains a function reference, the function will be found through the XPathFunctionResolver. An XPathExpressionException is raised if the function resolver is undefined or the function resolver returns null for the function.
    QNames | QNames in the expression are resolved against the XPath namespace context.
    result This result of evaluating an expression is converted to an instance of the desired return type. Valid return types are defined in XPathConstants. Conversion to the return type follows XPath conversion rules.

    An XPath expression is not thread-safe and not reentrant. In other words, it is the application's responsibility to make sure that one XPathExpression object is not used from more than one thread at any given time, and while the evaluate method is invoked, applications may not recursively call the evaluate method.

    从以下版本开始：
    1.5
    另请参见：
    XML Path Language (XPath) Version 1.0, Expressions

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String evaluate(Object item)
      Evaluate the compiled XPath expression in the specified context and return the result as a String.
      Object evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.

    • 方法详细信息

      • evaluate

        Object evaluate(Object item,
              QName returnType)
                throws XPathExpressionException

        Evaluate the compiled XPath expression in the specified context and return the result as the specified type.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If a null value is provided for item, an empty document will be used for the context. If returnType is null, then a NullPointerException is thrown.

        参数：
        item - The starting context (a node, for example).
        returnType - The desired return type.
        返回：
        The Object that is the result of evaluating the expression and converting the result to returnType.
        抛出：
        XPathExpressionException - If the expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If returnType is null.

      • evaluate

        String evaluate(Object item)
                throws XPathExpressionException

        Evaluate the compiled XPath expression in the specified context and return the result as a String.

        This method calls evaluate(Object item, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If a null value is provided for item, an empty document will be used for the context.

        参数：
        item - The starting context (a node, for example).
        返回：
        The String that is the result of evaluating the expression and converting the result to a String.
        抛出：
        XPathExpressionException - If the expression cannot be evaluated.

      • evaluate

        Object evaluate(InputSource source,
              QName returnType)
                throws XPathExpressionException

        Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.

        This method builds a data model for the InputSource and calls evaluate(Object item, QName returnType) on the resulting document object.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If returnType is not one of the types defined in XPathConstants, then an IllegalArgumentException is thrown.

        If source or returnType is null, then a NullPointerException is thrown.

        参数：
        source - The InputSource of the document to evaluate over.
        returnType - The desired return type.
        返回：
        The Object that is the result of evaluating the expression and converting the result to returnType.
        抛出：
        XPathExpressionException - If the expression cannot be evaluated.
        IllegalArgumentException - If returnType is not one of the types defined in XPathConstants.
        NullPointerException - If source or returnType is null.

      • evaluate

        String evaluate(InputSource source)
                throws XPathExpressionException

        Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.

        This method calls evaluate(InputSource source, QName returnType) with a returnType of XPathConstants.STRING.

        See Evaluation of XPath Expressions for context item evaluation, variable, function and QName resolution and return type conversion.

        If source is null, then a NullPointerException is thrown.

        参数：
        source - The InputSource of the document to evaluate over.
        返回：
        The String that is the result of evaluating the expression and converting the result to a String.
        抛出：
        XPathExpressionException - If the expression cannot be evaluated.
        NullPointerException - If source is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t eCd<-sh/nnoebpfl./ofif_okl l ixl


XPathExpressionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.xpath

类 XPathExpressionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    XPathFunctionException

    public class XPathExpressionException
extends XPathException
    XPathExpressionException represents an error in an XPath expression.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathExpressionException(String message)
      Constructs a new XPathExpressionException with the specified detail message.
      XPathExpressionException(Throwable cause)
      Constructs a new XPathExpressionException with the specified cause.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XPathExpressionException

        public XPathExpressionException(String message)

        Constructs a new XPathExpressionException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        参数：
        message - The detail message.
        抛出：
        NullPointerException - When message is null.

      • XPathExpressionException

        public XPathExpressionException(Throwable cause)

        Constructs a new XPathExpressionException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        参数：
        cause - The cause.
        抛出：
        NullPointerException - if cause is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

litm"tl"tc..tcc/a== - c luab


XPathFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
javax.xml.xpath

类 XPathFactory

  • java.lang.Object
    • javax.xml.xpath.XPathFactory

  • public abstract class XPathFactory
extends Object

    An XPathFactory instance can be used to create XPath objects.

    See newInstance(String uri) for lookup mechanism.

    The XPathFactory class is not thread-safe. In other words, it is the application's responsibility to ensure that at most one thread is using a XPathFactory object at any given moment. Implementations are encouraged to mark methods as synchronized to protect themselves from broken clients.

    XPathFactory is not re-entrant. While one of the newInstance methods is being invoked, applications may not attempt to recursively invoke a newInstance method, even from the same thread.

    从以下版本开始：
    1.5

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String DEFAULT_OBJECT_MODEL_URI
      Default Object Model URI.
      static String DEFAULT_PROPERTY_NAME
      The default property name according to the JAXP spec.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected XPathFactory()
      Protected constructor as newInstance() or newInstance(String uri) or newInstance(String uri, String factoryClassName, ClassLoader classLoader) should be used to create a new instance of an XPathFactory.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract boolean getFeature(String name)
      Get the state of the named feature.
      abstract boolean isObjectModelSupported(String objectModel)
      Is specified object model supported by this XPathFactory?
      static XPathFactory newInstance()
      Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.
      static XPathFactory newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
      abstract XPath newXPath()
      Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.
      abstract void setFeature(String name, boolean value)
      Set a feature for this XPathFactory and XPaths created by this factory.
      abstract void setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a default function resolver.
      abstract void setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a default variable resolver.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • DEFAULT_PROPERTY_NAME

        public static final String DEFAULT_PROPERTY_NAME

        The default property name according to the JAXP spec.

        另请参见：
        Constant Field Values

      • DEFAULT_OBJECT_MODEL_URI

        public static final String DEFAULT_OBJECT_MODEL_URI

        Default Object Model URI.

        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • XPathFactory

        protected XPathFactory()

        Protected constructor as newInstance() or newInstance(String uri) or newInstance(String uri, String factoryClassName, ClassLoader classLoader) should be used to create a new instance of an XPathFactory.

    • 方法详细信息

      • newInstance

        public static final XPathFactory newInstance()

        Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.

        This method is functionally equivalent to:

           newInstance(DEFAULT_OBJECT_MODEL_URI)

        Since the implementation for the W3C DOM is always available, this method will never fail.

        返回：
        Instance of an XPathFactory.
        抛出：
        RuntimeException - When there is a failure in creating an XPathFactory for the default object model.

      • newInstance

        public static final XPathFactory newInstance(String uri)
                                      throws XPathFactoryConfigurationException

        Get a new XPathFactory instance using the specified object model.

        To find a XPathFactory object, this method looks the following places in the following order where "the class loader" refers to the context class loader:

        1. If the system property DEFAULT_PROPERTY_NAME + ":uri" is present, where uri is the parameter to this method, then its value is read as a class name. The method will try to create a new instance of this class by using the class loader, and returns it if it is successfully created.
        2. ${java.home}/lib/jaxp.properties is read and the value associated with the key being the system property above is looked for. If present, the value is processed just like above.
        3. The class loader is asked for service provider provider-configuration files matching javax.xml.xpath.XPathFactory in the resource directory META-INF/services. See the JAR File Specification for file format and parsing rules. Each potential service provider is required to implement the method:
                 isObjectModelSupported(String objectModel)
          The first service provider found in class loader order that supports the specified object model is returned.
        4. Platform default XPathFactory is located in a platform specific way. There must be a platform default XPathFactory for the W3C DOM, i.e. DEFAULT_OBJECT_MODEL_URI.

        If everything fails, an XPathFactoryConfigurationException will be thrown.

        Tip for Trouble-shooting:

        See Properties.load(java.io.InputStream) for exactly how a property file is parsed. In particular, colons ':' need to be escaped in a property file, so make sure the URIs are properly escaped in it. For example:

           http\://java.sun.com/jaxp/xpath/dom=org.acme.DomXPathFactory
        参数：
        uri - Identifies the underlying object model. The specification only defines the URI DEFAULT_OBJECT_MODEL_URI, http://java.sun.com/jaxp/xpath/dom for the W3C DOM, the org.w3c.dom package, and implementations are free to introduce other URIs for other object models.
        返回：
        Instance of an XPathFactory.
        抛出：
        XPathFactoryConfigurationException - If the specified object model is unavailable.
        NullPointerException - If uri is null.
        IllegalArgumentException - If uri is null or uri.length() == 0.

      • newInstance

        public static XPathFactory newInstance(String uri,
                       String factoryClassName,
                       ClassLoader classLoader)
                                throws XPathFactoryConfigurationException

        Obtain a new instance of a XPathFactory from a factory class name. XPathFactory is returned if specified factory class supports the specified object model. This function is useful when there are multiple providers in the classpath. It gives more control to the application as it can specify which provider should be loaded.

        Tip for Trouble-shooting

        Setting the jaxp.debug system property will cause this method to print a lot of debug messages to System.err about what it is doing and where it is looking at.

        If you have problems try:

         java -Djaxp.debug=1 YourProgram ....
        参数：
        uri - Identifies the underlying object model. The specification only defines the URI DEFAULT_OBJECT_MODEL_URI,http://java.sun.com/jaxp/xpath/dom for the W3C DOM, the org.w3c.dom package, and implementations are free to introduce other URIs for other object models.
        factoryClassName - fully qualified factory class name that provides implementation of javax.xml.xpath.XPathFactory.
        classLoader - ClassLoader used to load the factory class. If null current Thread's context classLoader is used to load the factory class.
        返回：
        New instance of a XPathFactory
        抛出：
        XPathFactoryConfigurationException - if factoryClassName is null, or the factory class cannot be loaded, instantiated or the factory class does not support the object model specified in the uri parameter.
        NullPointerException - If uri is null.
        IllegalArgumentException - If uri is null or uri.length() == 0.
        从以下版本开始：
        1.6
        另请参见：
        newInstance(), newInstance(String uri)

      • isObjectModelSupported

        public abstract boolean isObjectModelSupported(String objectModel)

        Is specified object model supported by this XPathFactory?

        参数：
        objectModel - Specifies the object model which the returned XPathFactory will understand.
        返回：
        true if XPathFactory supports objectModel, else false.
        抛出：
        NullPointerException - If objectModel is null.
        IllegalArgumentException - If objectModel.length() == 0.

      • setFeature

        public abstract void setFeature(String name,
              boolean value)
                         throws XPathFactoryConfigurationException

        Set a feature for this XPathFactory and XPaths created by this factory.

        Feature names are fully qualified URIs. Implementations may define their own features. An XPathFactoryConfigurationException is thrown if this XPathFactory or the XPaths it creates cannot support the feature. It is possible for an XPathFactory to expose a feature value but be unable to change its state.

        All implementations are required to support the XMLConstants.FEATURE_SECURE_PROCESSING feature. When the feature is true, any reference to an external function is an error. Under these conditions, the implementation must not call the XPathFunctionResolver and must throw an XPathFunctionException.

        参数：
        name - Feature name.
        value - Is feature state true or false.
        抛出：
        XPathFactoryConfigurationException - if this XPathFactory or the XPaths it creates cannot support this feature.
        NullPointerException - if name is null.

      • getFeature

        public abstract boolean getFeature(String name)
                            throws XPathFactoryConfigurationException

        Get the state of the named feature.

        Feature names are fully qualified URIs. Implementations may define their own features. An XPathFactoryConfigurationException is thrown if this XPathFactory or the XPaths it creates cannot support the feature. It is possible for an XPathFactory to expose a feature value but be unable to change its state.

        参数：
        name - Feature name.
        返回：
        State of the named feature.
        抛出：
        XPathFactoryConfigurationException - if this XPathFactory or the XPaths it creates cannot support this feature.
        NullPointerException - if name is null.

      • setXPathVariableResolver

        public abstract void setXPathVariableResolver(XPathVariableResolver resolver)

        Establish a default variable resolver.

        Any XPath objects constructed from this factory will use the specified resolver by default.

        A NullPointerException is thrown if resolver is null.

        参数：
        resolver - Variable resolver.
        抛出：
        NullPointerException - If resolver is null.

      • setXPathFunctionResolver

        public abstract void setXPathFunctionResolver(XPathFunctionResolver resolver)

        Establish a default function resolver.

        Any XPath objects constructed from this factory will use the specified resolver by default.

        A NullPointerException is thrown if resolver is null.

        参数：
        resolver - XPath function resolver.
        抛出：
        NullPointerException - If resolver is null.

      • newXPath

        public abstract XPath newXPath()

        Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.

        返回：
        New instance of an XPath.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XPathFactoryConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.xpath

类 XPathFactoryConfigurationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathFactoryConfigurationException
  • 所有已实现的接口：
    Serializable

    public class XPathFactoryConfigurationException
extends XPathException
    XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathFactoryConfigurationException(String message)
      Constructs a new XPathFactoryConfigurationException with the specified detail message.
      XPathFactoryConfigurationException(Throwable cause)
      Constructs a new XPathFactoryConfigurationException with the specified cause.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XPathFactoryConfigurationException

        public XPathFactoryConfigurationException(String message)

        Constructs a new XPathFactoryConfigurationException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        参数：
        message - The detail message.
        抛出：
        NullPointerException - When message is null.

      • XPathFactoryConfigurationException

        public XPathFactoryConfigurationException(Throwable cause)

        Constructs a new XPathFactoryConfigurationException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        参数：
        cause - The cause.
        抛出：
        NullPointerException - if cause is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tEa3/>-a>-->>----aeeEE=A==== bslts " =b


XPathFunction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.xpath

Interface XPathFunction

  • public interface XPathFunction

    XPathFunction provides access to XPath functions.

    Functions are identified by QName and arity in XPath.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object evaluate(List args)
      Evaluate the function with the specified arguments.

    • 方法详细信息

      • evaluate

        Object evaluate(List args)
                throws XPathFunctionException

        Evaluate the function with the specified arguments.

        To the greatest extent possible, side-effects should be avoided in the definition of extension functions. The implementation evaluating an XPath expression is under no obligation to call extension functions in any particular order or any particular number of times.

        参数：
        args - The arguments, null is a valid value.
        返回：
        The result of evaluating the XPath function as an Object.
        抛出：
        XPathFunctionException - If args cannot be evaluated with this XPath function.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i=t,tl#(l#lww#lltn.. >)a/hnv..e


XPathFunctionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
javax.xml.xpath

类 XPathFunctionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
  • 所有已实现的接口：
    Serializable

    public class XPathFunctionException
extends XPathExpressionException
    XPathFunctionException represents an error with an XPath function.

    从以下版本开始：
    1.5
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      XPathFunctionException(String message)
      Constructs a new XPathFunctionException with the specified detail message.
      XPathFunctionException(Throwable cause)
      Constructs a new XPathFunctionException with the specified cause.

    • 方法摘要

      • 方法 - 继承于类 javax.xml.xpath.XPathException

        getCause, printStackTrace, printStackTrace, printStackTrace

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • XPathFunctionException

        public XPathFunctionException(String message)

        Constructs a new XPathFunctionException with the specified detail message.

        The cause is not initialized.

        If message is null, then a NullPointerException is thrown.

        参数：
        message - The detail message.
        抛出：
        NullPointerException - When message is null.

      • XPathFunctionException

        public XPathFunctionException(Throwable cause)

        Constructs a new XPathFunctionException with the specified cause.

        If cause is null, then a NullPointerException is thrown.

        参数：
        cause - The cause.
        抛出：
        NullPointerException - if cause is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tDcecl>c/y.ht"刃mm.p/郭佑&�&;#>;�;�


XPathFunctionResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.xpath

Interface XPathFunctionResolver

  • public interface XPathFunctionResolver

    XPathFunctionResolver provides access to the set of user defined XPathFunctions.

    XPath functions are resolved by name and arity. The resolver is not needed for XPath built-in functions and the resolver cannot be used to override those functions.

    In particular, the resolver is only called for functions in an another namespace (functions with an explicit prefix). This means that you cannot use the XPathFunctionResolver to implement specifications like XML-Signature Syntax and Processing which extend the function library of XPath 1.0 in the same namespace. This is a consequence of the design of the resolver.

    If you wish to implement additional built-in functions, you will have to extend the underlying implementation directly.

    从以下版本开始：
    1.5
    另请参见：
    XML Path Language (XPath) Version 1.0, Core Function Library

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XPathFunction resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.

    • 方法详细信息

      • resolveFunction

        XPathFunction resolveFunction(QName functionName,
                            int arity)

        Find a function in the set of available functions.

        If functionName or arity is null, then a NullPointerException is thrown.

        参数：
        functionName - The function name.
        arity - The number of arguments that the returned function must accept.
        返回：
        The function or null if no function named functionName with arity arguments exists.
        抛出：
        NullPointerException - If functionName or arity is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> Njs "s "=cc"==tnnnsatlctotno/wt�/c


XPathVariableResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
javax.xml.xpath

Interface XPathVariableResolver

  • public interface XPathVariableResolver

    XPathVariableResolver provides access to the set of user defined XPath variables.

    The XPathVariableResolver and the XPath evaluator must adhere to a contract that cannot be directly enforced by the API. Although variables may be mutable, that is, an application may wish to evaluate the same XPath expression more than once with different variable values, in the course of evaluating any single XPath expression, a variable's value must not change.

    从以下版本开始：
    1.5

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object resolveVariable(QName variableName)
      Find a variable in the set of available variables.

    • 方法详细信息

      • resolveVariable

        Object resolveVariable(QName variableName)

        Find a variable in the set of available variables.

        If variableName is null, then a NullPointerException is thrown.

        参数：
        variableName - The QName of the variable name.
        返回：
        The variables value, or null if no variable named variableName exists. The value returned must be of a type appropriate for the underlying object model.
        抛出：
        NullPointerException - If variableName is null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;i|rCrirprtnsp;nso;;livl&<�>v�&�


Uses of Class javax.xml.xpath.XPathConstants

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathConstants

No usage of javax.xml.xpath.XPathConstants
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wt


Uses of Class javax.xml.xpath.XPathException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathException

  • Packages that use XPathException
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathException in javax.xml.xpath

      Subclasses of XPathException in javax.xml.xpath
      修饰符与类型 类与描述
      class  XPathExpressionException
      XPathExpressionException represents an error in an XPath expression.
      class  XPathFactoryConfigurationException
      XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
      class  XPathFunctionException
      XPathFunctionException represents an error with an XPath function.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ec/gd.setg s襯m0t(sTWeve


Uses of Class javax.xml.xpath.XPathExpressionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathExpressionException

  • Packages that use XPathExpressionException
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathExpressionException in javax.xml.xpath

      Subclasses of XPathExpressionException in javax.xml.xpath
      修饰符与类型 类与描述
      class  XPathFunctionException
      XPathFunctionException represents an error with an XPath function.
      Methods in javax.xml.xpath that throw XPathExpressionException
      修饰符与类型 方法与描述
      XPathExpression XPath.compile(String expression)
      Compile an XPath expression for later evaluation.
      String XPathExpression.evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPathExpression.evaluate(Object item)
      Evaluate the compiled XPath expression in the specified context and return the result as a String.
      Object XPathExpression.evaluate(Object item, QName returnType)
      Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
      String XPath.evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPath.evaluate(String expression, Object item)
      Evaluate an XPath expression in the specified context and return the result as a String.
      Object XPath.evaluate(String expression, Object item, QName returnType)
      Evaluate an XPath expression in the specified context and return the result as the specified type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

na Pa.a;/鈎/鯽drs.e


Uses of Class javax.xml.xpath.XPathFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathFactory

  • Packages that use XPathFactory
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFactory in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFactory
      修饰符与类型 方法与描述
      static XPathFactory XPathFactory.newInstance()
      Get a new XPathFactory instance using the default object model, DEFAULT_OBJECT_MODEL_URI, the W3C DOM.
      static XPathFactory XPathFactory.newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a.vcitllm""".g//t=t<


Uses of Class javax.xml.xpath.XPathFactoryConfigurationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathFactoryConfigurationException

  • Packages that use XPathFactoryConfigurationException
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFactoryConfigurationException in javax.xml.xpath

      Methods in javax.xml.xpath that throw XPathFactoryConfigurationException
      修饰符与类型 方法与描述
      abstract boolean XPathFactory.getFeature(String name)
      Get the state of the named feature.
      static XPathFactory XPathFactory.newInstance(String uri)
      Get a new XPathFactory instance using the specified object model.
      static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
      Obtain a new instance of a XPathFactory from a factory class name.
      abstract void XPathFactory.setFeature(String name, boolean value)
      Set a feature for this XPathFactory and XPaths created by this factory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tflt/Obs/aot//v<>Mv>>re


Uses of Class javax.xml.xpath.XPathFunctionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
javax.xml.xpath.XPathFunctionException

  • Packages that use XPathFunctionException
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunctionException in javax.xml.xpath

      Methods in javax.xml.xpath that throw XPathFunctionException
      修饰符与类型 方法与描述
      Object XPathFunction.evaluate(List args)
      Evaluate the function with the specified arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lg/bpmllmd


Uses of Interface javax.xml.xpath.XPath

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.xpath.XPath

  • Packages that use XPath
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPath in javax.xml.xpath

      Methods in javax.xml.xpath that return XPath
      修饰符与类型 方法与描述
      abstract XPath XPathFactory.newXPath()
      Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> tne=t"rit<


Uses of Interface javax.xml.xpath.XPathExpression

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.xpath.XPathExpression

  • Packages that use XPathExpression
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathExpression in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathExpression
      修饰符与类型 方法与描述
      XPathExpression XPath.compile(String expression)
      Compile an XPath expression for later evaluation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orm.ernro.uc.uee TO=NO=Ns


Uses of Interface javax.xml.xpath.XPathFunction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.xpath.XPathFunction

  • Packages that use XPathFunction
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunction in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFunction
      修饰符与类型 方法与描述
      XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
      Find a function in the set of available functions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

knalry.usmmmg.lltlt"a nit


Uses of Interface javax.xml.xpath.XPathFunctionResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.xpath.XPathFunctionResolver

  • Packages that use XPathFunctionResolver
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathFunctionResolver in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathFunctionResolver
      修饰符与类型 方法与描述
      XPathFunctionResolver XPath.getXPathFunctionResolver()
      Return the current function resolver.
      Methods in javax.xml.xpath with parameters of type XPathFunctionResolver
      修饰符与类型 方法与描述
      abstract void XPathFactory.setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a default function resolver.
      void XPath.setXPathFunctionResolver(XPathFunctionResolver resolver)
      Establish a function resolver.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/tk:1oa


Uses of Interface javax.xml.xpath.XPathVariableResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
javax.xml.xpath.XPathVariableResolver

  • Packages that use XPathVariableResolver
    软件包 描述
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.

    • Uses of XPathVariableResolver in javax.xml.xpath

      Methods in javax.xml.xpath that return XPathVariableResolver
      修饰符与类型 方法与描述
      XPathVariableResolver XPath.getXPathVariableResolver()
      Return the current variable resolver.
      Methods in javax.xml.xpath with parameters of type XPathVariableResolver
      修饰符与类型 方法与描述
      abstract void XPathFactory.setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a default variable resolver.
      void XPath.setXPathVariableResolver(XPathVariableResolver resolver)
      Establish a variable resolver.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/. r@e eP n,:TtT�


ChannelBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.ietf.jgss

类 ChannelBinding

  • java.lang.Object
    • org.ietf.jgss.ChannelBinding

  • public class ChannelBinding
extends Object
    This class encapsulates the concept of caller-provided channel binding information. Channel bindings are used to strengthen the quality with which peer entity authentication is provided during context establishment. They enable the GSS-API callers to bind the establishment of the security context to relevant characteristics like addresses or to application specific data.

    The caller initiating the security context must determine the appropriate channel binding values to set in the GSSContext object. The acceptor must provide an identical binding in order to validate that received tokens possess correct channel-related characteristics.

    Use of channel bindings is optional in GSS-API. ChannelBinding can be set for the GSSContext using the setChannelBinding method before the first call to initSecContext or acceptSecContext has been performed. Unless the setChannelBinding method has been used to set the ChannelBinding for a GSSContext object, null ChannelBinding will be assumed.

    Conceptually, the GSS-API concatenates the initiator and acceptor address information, and the application supplied byte array to form an octet string. The mechanism calculates a MIC over this octet string and binds the MIC to the context establishment token emitted by initSecContext method of the GSSContext interface. The same bindings are set by the context acceptor for its GSSContext object and during processing of the acceptSecContext method a MIC is calculated in the same way. The calculated MIC is compared with that found in the token, and if the MICs differ, accept will throw a GSSException with the major code set to BAD_BINDINGS, and the context will not be established. Some mechanisms may include the actual channel binding data in the token (rather than just a MIC); applications should therefore not use confidential data as channel-binding components.

    Individual mechanisms may impose additional constraints on addresses that may appear in channel bindings. For example, a mechanism may verify that the initiator address field of the channel binding contains the correct network address of the host system. Portable applications should therefore ensure that they either provide correct information for the address fields, or omit setting of the addressing information.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      ChannelBinding(byte[] appData)
      Creates a ChannelBinding object without any addressing information.
      ChannelBinding(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
      Create a ChannelBinding object with user supplied address information and data.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean equals(Object obj)
      Compares two instances of ChannelBinding.
      InetAddress getAcceptorAddress()
      Get the acceptor's address for this channel binding.
      byte[] getApplicationData()
      Get the application specified data for this channel binding.
      InetAddress getInitiatorAddress()
      Get the initiator's address for this channel binding.
      int hashCode()
      Returns a hashcode value for this ChannelBinding object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ChannelBinding

        public ChannelBinding(InetAddress initAddr,
              InetAddress acceptAddr,
              byte[] appData)
        Create a ChannelBinding object with user supplied address information and data. null values can be used for any fields which the application does not want to specify.
        参数：
        initAddr - the address of the context initiator. null value can be supplied to indicate that the application does not want to set this value.
        acceptAddr - the address of the context acceptor. null value can be supplied to indicate that the application does not want to set this value.
        appData - application supplied data to be used as part of the channel bindings. null value can be supplied to indicate that the application does not want to set this value.

      • ChannelBinding

        public ChannelBinding(byte[] appData)
        Creates a ChannelBinding object without any addressing information.
        参数：
        appData - application supplied data to be used as part of the channel bindings.

    • 方法详细信息

      • getInitiatorAddress

        public InetAddress getInitiatorAddress()
        Get the initiator's address for this channel binding.
        返回：
        the initiator's address. null is returned if the address has not been set.

      • getAcceptorAddress

        public InetAddress getAcceptorAddress()
        Get the acceptor's address for this channel binding.
        返回：
        the acceptor's address. null is returned if the address has not been set.

      • getApplicationData

        public byte[] getApplicationData()
        Get the application specified data for this channel binding.
        返回：
        the application data being used as part of the ChannelBinding. null is returned if no application data has been specified for the channel binding.

      • equals

        public boolean equals(Object obj)
        Compares two instances of ChannelBinding.
        重载：
        equals in class Object
        参数：
        obj - another ChannelBinding to compare this one with
        返回：
        true if the two ChannelBinding's contain the same values for the initiator and acceptor addresses and the application data.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        public int hashCode()
        Returns a hashcode value for this ChannelBinding object.
        重载：
        hashCode in class Object
        返回：
        a hashCode value
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

csrfoniie ov/at dn aho/L


GSSContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.ietf.jgss

Interface GSSContext

  • public interface GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context. Security contexts are established between peers using locally acquired credentials. Multiple contexts may exist simultaneously between a pair of peers, using the same or different set of credentials. GSS-API functions in a manner independent of the underlying transport protocol and depends on its calling application to transport the tokens that are generated by the security context between the peers.

    If the caller instantiates the context using the default GSSManager instance, then the Kerberos v5 GSS-API mechanism is guaranteed to be available for context establishment. This mechanism is identified by the Oid "1.2.840.113554.1.2.2" and is defined in RFC 1964.

    Before the context establishment phase is initiated, the context initiator may request specific characteristics desired of the established context. Not all underlying mechanisms support all characteristics that a caller might desire. After the context is established, the caller can check the actual characteristics and services offered by that context by means of various query methods. When using the Kerberos v5 GSS-API mechanism offered by the default GSSManager instance, all optional services will be available locally. They are mutual authentication, credential delegation, confidentiality and integrity protection, and per-message replay detection and sequencing. Note that in the GSS-API, message integrity is a prerequisite for message confidentiality.

    The context establishment occurs in a loop where the initiator calls initSecContext and the acceptor calls acceptSecContext until the context is established. While in this loop the initSecContext and acceptSecContext methods produce tokens that the application sends over to the peer. The peer passes any such token as input to its acceptSecContext or initSecContext as the case may be.

    During the context establishment phase, the isProtReady method may be called to determine if the context can be used for the per-message operations of wrap and getMIC. This allows applications to use per-message operations on contexts which aren't yet fully established.

    After the context has been established or the isProtReady method returns true, the query routines can be invoked to determine the actual characteristics and services of the established context. The application can also start using the per-message methods of wrap and getMIC to obtain cryptographic operations on application supplied data.

    When the context is no longer needed, the application should call dispose to release any system resources the context may be using.

    A security context typically maintains sequencing and replay detection information about the tokens it processes. Therefore, the sequence in which any tokens are presented to this context for processing can be important. Also note that none of the methods in this interface are synchronized. Therefore, it is not advisable to share a GSSContext among several threads unless some application level synchronization is in place.

    Finally, different mechanism providers might place different security restrictions on using GSS-API contexts. These will be documented by the mechanism provider. The application will need to ensure that it has the appropriate permissions if such checks are made in the mechanism layer.

    The example code presented below demonstrates the usage of the GSSContext interface for the initiating peer. Different operations on the GSSContext object are presented, including: object instantiation, setting of desired flags, context establishment, query of actual context flags, per-message operations on application data, and finally context deletion.

        // Create a context using default credentials
    // and the implementation specific default mechanism
    GSSManager manager ...
    GSSName targetName ...
    GSSContext context = manager.createContext(targetName, null, null,
                                           GSSContext.INDEFINITE_LIFETIME);

    // set desired context options prior to context establishment
    context.requestConf(true);
    context.requestMutualAuth(true);
    context.requestReplayDet(true);
    context.requestSequenceDet(true);

    // establish a context between peers

    byte []inToken = new byte[0];

    // Loop while there still is a token to be processed

    while (!context.isEstablished()) {

        byte[] outToken
            = context.initSecContext(inToken, 0, inToken.length);

        // send the output token if generated
        if (outToken != null)
            sendToken(outToken);

        if (!context.isEstablished()) {
            inToken = readToken();
    }

     // display context information
     System.out.println("Remaining lifetime in seconds = "
                                          + context.getLifetime());
     System.out.println("Context mechanism = " + context.getMech());
     System.out.println("Initiator = " + context.getSrcName());
     System.out.println("Acceptor = " + context.getTargName());

     if (context.getConfState())
             System.out.println("Confidentiality (i.e., privacy) is available");

     if (context.getIntegState())
             System.out.println("Integrity is available");

     // perform wrap on an application supplied message, appMsg,
     // using QOP = 0, and requesting privacy service
     byte [] appMsg ...

     MessageProp mProp = new MessageProp(0, true);

     byte []tok = context.wrap(appMsg, 0, appMsg.length, mProp);

     sendToken(tok);

     // release the local-end of the context
     context.dispose();
    从以下版本开始：
    1.4

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DEFAULT_LIFETIME
      A lifetime constant representing the default context lifetime.
      static int INDEFINITE_LIFETIME
      A lifetime constant representing indefinite context lifetime.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] acceptSecContext(byte[] inToken, int offset, int len)
      Called by the context acceptor upon receiving a token from the peer.
      void acceptSecContext(InputStream inStream, OutputStream outStream)
      Called by the context acceptor to process a token from the peer using streams.
      void dispose()
      Releases any system resources and cryptographic information stored in the context object and invalidates the context.
      byte[] export()
      Exports this context so that another process may import it..
      boolean getAnonymityState()
      Determines if the context initiator is anonymously authenticated to the context acceptor.
      boolean getConfState()
      Determines if data confidentiality is available over the context.
      boolean getCredDelegState()
      Determines if credential delegation is enabled on this context.
      GSSCredential getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      boolean getIntegState()
      Determines if data integrity is available over the context.
      int getLifetime()
      Determines what the remaining lifetime for this context is.
      Oid getMech()
      Determines what mechanism is being used for this context.
      byte[] getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      boolean getMutualAuthState()
      Determines if mutual authentication is enabled on this context.
      boolean getReplayDetState()
      Determines if replay detection is enabled for the per-message security services from this context.
      boolean getSequenceDetState()
      Determines if sequence checking is enabled for the per-message security services from this context.
      GSSName getSrcName()
      Returns the name of the context initiator.
      GSSName getTargName()
      Returns the name of the context acceptor.
      int getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize)
      Used to determine limits on the size of the message that can be passed to wrap.
      byte[] initSecContext(byte[] inputBuf, int offset, int len)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
      int initSecContext(InputStream inStream, OutputStream outStream)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
      boolean isEstablished()
      Used during context establishment to determine the state of the context.
      boolean isInitiator()
      Determines if this is the context initiator.
      boolean isProtReady()
      Determines if the context is ready for per message operations to be used over it.
      boolean isTransferable()
      Determines if the context is transferable to other processes through the use of the export method.
      void requestAnonymity(boolean state)
      Requests that the initiator's identity not be disclosed to the acceptor.
      void requestConf(boolean state)
      Requests that data confidentiality be enabled for the wrap method.
      void requestCredDeleg(boolean state)
      Requests that the initiator's credentials be delegated to the acceptor during context establishment.
      void requestInteg(boolean state)
      Requests that data integrity be enabled for the wrap and getMICmethods.
      void requestLifetime(int lifetime)
      Requests a lifetime in seconds for the context.
      void requestMutualAuth(boolean state)
      Requests that mutual authentication be done during context establishment.
      void requestReplayDet(boolean state)
      Requests that replay detection be enabled for the per-message security services after context establishment.
      void requestSequenceDet(boolean state)
      Requests that sequence checking be enabled for the per-message security services after context establishment.
      void setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
      byte[] unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.

    • 字段详细信息

      • DEFAULT_LIFETIME

        static final int DEFAULT_LIFETIME
        A lifetime constant representing the default context lifetime. This value is set to 0.
        另请参见：
        Constant Field Values

      • INDEFINITE_LIFETIME

        static final int INDEFINITE_LIFETIME
        A lifetime constant representing indefinite context lifetime. This value must is set to the maximum integer value in Java - Integer.MAX_VALUE.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • initSecContext

        byte[] initSecContext(byte[] inputBuf,
                    int offset,
                    int len)
                      throws GSSException
        Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method. This method may return an output token which the application will need to send to the peer for processing by its acceptSecContext method. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to initSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that the initSecContext method return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        参数：
        inputBuf - token generated by the peer. This parameter is ignored on the first call since no token has been received from the peer.
        offset - the offset within the inputBuf where the token begins.
        len - the length of the token.
        返回：
        a byte[] containing the token to be sent to the peer. null indicates that no token is generated.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_NAMETYPE, GSSException.BAD_MECH, GSSException.FAILURE

      • initSecContext

        int initSecContext(InputStream inStream,
                 OutputStream outStream)
                   throws GSSException
        Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams. This method may write an output token to the OutpuStream, which the application will need to send to the peer for processing by its acceptSecContext call. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers. The application can determine if a token is written to the OutputStream from the return value of this method. A return value of 0 indicates that no token was written. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to initSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that the initSecContext method return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        The GSS-API authentication tokens contain a definitive start and end. This method will attempt to read one of these tokens per invocation, and may block on the stream if only part of the token is available. In all other respects this method is equivalent to the byte array based initSecContext.

        Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.initSecContext(is, os);

         // send output token if generated
         os.flush();
     }
        参数：
        inStream - an InputStream that contains the token generated by the peer. This parameter is ignored on the first call since no token has been or will be received from the peer at that point.
        outStream - an OutputStream where the output token will be written. During the final stage of context establishment, there may be no bytes written.
        返回：
        the number of bytes written to the OutputStream as part of the token to be sent to the peer. A value of 0 indicates that no token needs to be sent.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_NAMETYPE, GSSException.BAD_MECH, GSSException.FAILURE

      • acceptSecContext

        byte[] acceptSecContext(byte[] inToken,
                      int offset,
                      int len)
                        throws GSSException
        Called by the context acceptor upon receiving a token from the peer. This method may return an output token which the application will need to send to the peer for further processing by its initSecContext call.

        The application can call isEstablished to determine if the context establishment phase is complete for this peer. A return value of false from isEstablished indicates that more tokens are expected to be supplied to this method. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that acceptSecContext return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             byte[] inToken;
     byte[] outToken;
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {
         inToken = readToken();
         outToken = context.acceptSecContext(inToken, 0,
                                             inToken.length);
         // send output token if generated
         if (outToken != null)
             sendToken(outToken);
     }
        参数：
        inToken - token generated by the peer.
        offset - the offset within the inToken where the token begins.
        len - the length of the token.
        返回：
        a byte[] containing the token to be sent to the peer. null indicates that no token is generated.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_MECH, GSSException.FAILURE

      • acceptSecContext

        void acceptSecContext(InputStream inStream,
                    OutputStream outStream)
                      throws GSSException
        Called by the context acceptor to process a token from the peer using streams. It may write an output token to the OutputStream, which the application will need to send to the peer for processing by its initSecContext method. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers. The application can call isEstablished to determine if the context establishment phase is complete on this side of the context. A return value of false from isEstablished indicates that more tokens are expected to be supplied to acceptSecContext. Upon completion of the context establishment, the available context options may be queried through the get methods.

        Note that it is possible that acceptSecContext return a token for the peer, and isEstablished return true also. This indicates that the token needs to be sent to the peer, but the local end of the context is now fully established.

        The GSS-API authentication tokens contain a definitive start and end. This method will attempt to read one of these tokens per invocation, and may block on the stream if only part of the token is available. In all other respects this method is equivalent to the byte array based acceptSecContext.

        Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        The following example code demonstrates how this method might be used:

             InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.acceptSecContext(is, os);

         // send output token if generated
         os.flush();
     }
        参数：
        inStream - an InputStream that contains the token generated by the peer.
        outStream - an OutputStream where the output token will be written. During the final stage of context establishment, there may be no bytes written.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.BAD_BINDINGS, GSSException.OLD_TOKEN, GSSException.DUPLICATE_TOKEN, GSSException.BAD_MECH, GSSException.FAILURE

      • isEstablished

        boolean isEstablished()
        Used during context establishment to determine the state of the context.
        返回：
        true if this is a fully established context on the caller's side and no more tokens are needed from the peer.

      • dispose

        void dispose()
             throws GSSException
        Releases any system resources and cryptographic information stored in the context object and invalidates the context.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getWrapSizeLimit

        int getWrapSizeLimit(int qop,
                   boolean confReq,
                   int maxTokenSize)
                     throws GSSException
        Used to determine limits on the size of the message that can be passed to wrap. Returns the maximum message size that, if presented to the wrap method with the same confReq and qop parameters, will result in an output token containing no more than maxTokenSize bytes.

        This call is intended for use by applications that communicate over protocols that impose a maximum message size. It enables the application to fragment messages prior to applying protection.

        GSS-API implementations are recommended but not required to detect invalid QOP values when getWrapSizeLimit is called. This routine guarantees only a maximum message size, not the availability of specific QOP values for message protection.

        参数：
        qop - the level of protection wrap will be asked to provide.
        confReq - true if wrap will be asked to provide privacy, false otherwise.
        maxTokenSize - the desired maximum size of the token emitted by wrap.
        返回：
        the maximum size of the input token for the given output token size
        抛出：
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • wrap

        byte[] wrap(byte[] inBuf,
          int offset,
          int len,
          MessageProp msgProp)
            throws GSSException
        Applies per-message security services over the established security context. The method will return a token with the application supplied data and a cryptographic MIC over it. The data may be encrypted if confidentiality (privacy) was requested.

        The MessageProp object is instantiated by the application and used to specify a QOP value which selects cryptographic algorithms, and a privacy service to optionally encrypt the message. The underlying mechanism that is used in the call may not be able to provide the privacy service. It sets the actual privacy service that it does provide in this MessageProp object which the caller should then query upon return. If the mechanism is not able to provide the requested QOP, it throws a GSSException with the BAD_QOP code.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping of zero-length messages.

        The application will be responsible for sending the token to the peer.

        参数：
        inBuf - application data to be protected.
        offset - the offset within the inBuf where the data begins.
        len - the length of the data
        msgProp - instance of MessageProp that is used by the application to set the desired QOP and privacy state. Set the desired QOP to 0 to request the default QOP. Upon return from this method, this object will contain the the actual privacy state that was applied to the message by the underlying mechanism.
        返回：
        a byte[] containing the token to be sent to the peer.
        抛出：
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • wrap

        void wrap(InputStream inStream,
        OutputStream outStream,
        MessageProp msgProp)
          throws GSSException
        Applies per-message security services over the established security context using streams. The method will return a token with the application supplied data and a cryptographic MIC over it. The data may be encrypted if confidentiality (privacy) was requested. This method is equivalent to the byte array based wrap method.

        The application will be responsible for sending the token to the peer. Typically, the application would ensure this by calling the flush method on an OutputStream that encapsulates the connection between the two peers.

        The MessageProp object is instantiated by the application and used to specify a QOP value which selects cryptographic algorithms, and a privacy service to optionally encrypt the message. The underlying mechanism that is used in the call may not be able to provide the privacy service. It sets the actual privacy service that it does provide in this MessageProp object which the caller should then query upon return. If the mechanism is not able to provide the requested QOP, it throws a GSSException with the BAD_QOP code.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping of zero-length messages.

        参数：
        inStream - an InputStream containing the application data to be protected. All of the data that is available in inStream is used.
        outStream - an OutputStream to write the protected message to.
        msgProp - instance of MessageProp that is used by the application to set the desired QOP and privacy state. Set the desired QOP to 0 to request the default QOP. Upon return from this method, this object will contain the the actual privacy state that was applied to the message by the underlying mechanism.
        抛出：
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • unwrap

        byte[] unwrap(byte[] inBuf,
            int offset,
            int len,
            MessageProp msgProp)
              throws GSSException
        Used to process tokens generated by the wrap method on the other side of the context. The method will return the message supplied by the peer application to its wrap call, while at the same time verifying the embedded MIC for that message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP, whether confidentiality was applied to the message, and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping and unwrapping of zero-length messages.

        参数：
        inBuf - a byte array containing the wrap token received from peer.
        offset - the offset where the token begins.
        len - the length of the token
        msgProp - upon return from the method, this object will contain the applied QOP, the privacy state of the message, and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        返回：
        a byte[] containing the message unwrapped from the input token.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.CONTEXT_EXPIRED, GSSException.FAILURE

      • unwrap

        void unwrap(InputStream inStream,
          OutputStream outStream,
          MessageProp msgProp)
            throws GSSException
        Uses streams to process tokens generated by the wrap method on the other side of the context. The method will return the message supplied by the peer application to its wrap call, while at the same time verifying the embedded MIC for that message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP, whether confidentiality was applied to the message, and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by wrap to provide "secure framing", implementations should support the wrapping and unwrapping of zero-length messages.

        The format of the input token that this method reads is defined in the specification for the underlying mechanism that will be used. This method will attempt to read one of these tokens per invocation. If the mechanism token contains a definitive start and end this method may block on the InputStream if only part of the token is available. If the start and end of the token are not definitive then the method will attempt to treat all available bytes as part of the token.

        Other than the possible blocking behavior described above, this method is equivalent to the byte array based unwrap method.

        参数：
        inStream - an InputStream that contains the wrap token generated by the peer.
        outStream - an OutputStream to write the application message to.
        msgProp - upon return from the method, this object will contain the applied QOP, the privacy state of the message, and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN, GSSException.BAD_MIC, GSSException.CONTEXT_EXPIRED, GSSException.FAILURE

      • getMIC

        byte[] getMIC(byte[] inMsg,
            int offset,
            int len,
            MessageProp msgProp)
              throws GSSException
        Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application. Unlike wrap, which encapsulates the user message in the returned token, only the message MIC is returned in the output token.

        Note that privacy can only be applied through the wrap call.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support derivation of MICs from zero-length messages.

        参数：
        inMsg - the message to generate the MIC over.
        offset - offset within the inMsg where the message begins.
        len - the length of the message
        msgProp - an instance of MessageProp that is used by the application to set the desired QOP. Set the desired QOP to 0 in msgProp to request the default QOP. Alternatively pass in null for msgProp to request the default QOP.
        返回：
        a byte[] containing the token to be sent to the peer.
        抛出：
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • getMIC

        void getMIC(InputStream inStream,
          OutputStream outStream,
          MessageProp msgProp)
            throws GSSException
        Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application. Unlike wrap, which encapsulates the user message in the returned token, only the message MIC is produced in the output token. This method is equivalent to the byte array based getMIC method. Note that privacy can only be applied through the wrap call.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support derivation of MICs from zero-length messages.

        参数：
        inStream - an InputStream containing the message to generate the MIC over. All of the data that is available in inStream is used.
        outStream - an OutputStream to write the output token to.
        msgProp - an instance of MessageProp that is used by the application to set the desired QOP. Set the desired QOP to 0 in msgProp to request the default QOP. Alternatively pass in null for msgProp to request the default QOP.
        抛出：
        GSSException - containing the following major error codes: GSSException.CONTEXT_EXPIRED, GSSException.BAD_QOP, GSSException.FAILURE

      • verifyMIC

        void verifyMIC(byte[] inToken,
             int tokOffset,
             int tokLen,
             byte[] inMsg,
             int msgOffset,
             int msgLen,
             MessageProp msgProp)
               throws GSSException
        Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.

        The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP indicating the strength of protection that was applied to the message and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support the calculation and verification of MICs over zero-length messages.

        参数：
        inToken - the token generated by peer's getMIC method.
        tokOffset - the offset within the inToken where the token begins.
        tokLen - the length of the token.
        inMsg - the application message to verify the cryptographic MIC over.
        msgOffset - the offset in inMsg where the message begins.
        msgLen - the length of the message.
        msgProp - upon return from the method, this object will contain the applied QOP and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN GSSException.BAD_MIC GSSException.CONTEXT_EXPIRED GSSException.FAILURE

      • verifyMIC

        void verifyMIC(InputStream tokStream,
             InputStream msgStream,
             MessageProp msgProp)
               throws GSSException
        Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message. This method is equivalent to the byte array based verifyMIC method. The MessageProp object is instantiated by the application and is used by the underlying mechanism to return information to the caller such as the QOP indicating the strength of protection that was applied to the message and other supplementary message state information.

        Since some application-level protocols may wish to use tokens emitted by getMIC to provide "secure framing", implementations should support the calculation and verification of MICs over zero-length messages.

        The format of the input token that this method reads is defined in the specification for the underlying mechanism that will be used. This method will attempt to read one of these tokens per invocation. If the mechanism token contains a definitive start and end this method may block on the InputStream if only part of the token is available. If the start and end of the token are not definitive then the method will attempt to treat all available bytes as part of the token.

        Other than the possible blocking behavior described above, this method is equivalent to the byte array based verifyMIC method.

        参数：
        tokStream - an InputStream containing the token generated by the peer's getMIC method.
        msgStream - an InputStream containing the application message to verify the cryptographic MIC over. All of the data that is available in msgStream is used.
        msgProp - upon return from the method, this object will contain the applied QOP and supplementary information stating if the token was a duplicate, old, out of sequence or arriving after a gap.
        抛出：
        GSSException - containing the following major error codes: GSSException.DEFECTIVE_TOKEN GSSException.BAD_MIC GSSException.CONTEXT_EXPIRED GSSException.FAILURE

      • export

        byte[] export()
              throws GSSException
        Exports this context so that another process may import it.. Provided to support the sharing of work between multiple processes. This routine will typically be used by the context-acceptor, in an application where a single process receives incoming connection requests and accepts security contexts over them, then passes the established context to one or more other processes for message exchange.

        This method deactivates the security context and creates an interprocess token which, when passed to GSSManager.createContext in another process, will re-activate the context in the second process. Only a single instantiation of a given context may be active at any one time; a subsequent attempt by a context exporter to access the exported security context will fail.

        The implementation may constrain the set of processes by which the interprocess token may be imported, either as a function of local security policy, or as a result of implementation decisions. For example, some implementations may constrain contexts to be passed only between processes that run under the same account, or which are part of the same process group.

        The interprocess token may contain security-sensitive information (for example cryptographic keys). While mechanisms are encouraged to either avoid placing such sensitive information within interprocess tokens, or to encrypt the token before returning it to the application, in a typical GSS-API implementation this may not be possible. Thus the application must take care to protect the interprocess token, and ensure that any process to which the token is transferred is trustworthy.

        Implementations are not required to support the inter-process transfer of security contexts. Calling the isTransferable method will indicate if the context object is transferable.

        Calling this method on a context that is not exportable will result in this exception being thrown with the error code GSSException.UNAVAILABLE.

        返回：
        a byte[] containing the exported context
        抛出：
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.CONTEXT_EXPIRED, GSSException.NO_CONTEXT, GSSException.FAILURE
        另请参见：
        GSSManager.createContext(byte[])

      • requestMutualAuth

        void requestMutualAuth(boolean state)
                       throws GSSException
        Requests that mutual authentication be done during context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext.

        Not all mechanisms support mutual authentication and some mechanisms might require mutual authentication even if the application doesn't. Therefore, the application should check to see if the request was honored with the getMutualAuthState method.

        参数：
        state - a boolean value indicating whether mutual authentication should be used or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getMutualAuthState()

      • requestReplayDet

        void requestReplayDet(boolean state)
                      throws GSSException
        Requests that replay detection be enabled for the per-message security services after context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. During context establishment replay detection is not an option and is a function of the underlying mechanism's capabilities.

        Not all mechanisms support replay detection and some mechanisms might require replay detection even if the application doesn't. Therefore, the application should check to see if the request was honored with the getReplayDetState method. If replay detection is enabled then the MessageProp.isDuplicateToken and MessageProp.isOldToken methods will return valid results for the MessageProp object that is passed in to the unwrap method or the verifyMIC method.

        参数：
        state - a boolean value indicating whether replay detection should be enabled over the established context or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getReplayDetState()

      • requestSequenceDet

        void requestSequenceDet(boolean state)
                        throws GSSException
        Requests that sequence checking be enabled for the per-message security services after context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. During context establishment sequence checking is not an option and is a function of the underlying mechanism's capabilities.

        Not all mechanisms support sequence checking and some mechanisms might require sequence checking even if the application doesn't. Therefore, the application should check to see if the request was honored with the getSequenceDetState method. If sequence checking is enabled then the MessageProp.isDuplicateToken, MessageProp.isOldToken, MessageProp.isUnseqToken, and MessageProp.isGapToken methods will return valid results for the MessageProp object that is passed in to the unwrap method or the verifyMIC method.

        参数：
        state - a boolean value indicating whether sequence checking should be enabled over the established context or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getSequenceDetState()

      • requestCredDeleg

        void requestCredDeleg(boolean state)
                      throws GSSException
        Requests that the initiator's credentials be delegated to the acceptor during context establishment. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support credential delegation. Therefore, an application that desires delegation should check to see if the request was honored with the getCredDelegState method. If the application indicates that delegation must not be used, then the mechanism will honor the request and delegation will not occur. This is an exception to the general rule that a mechanism may enable a service even if it is not requested.

        参数：
        state - a boolean value indicating whether the credentials should be delegated or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getCredDelegState()

      • requestAnonymity

        void requestAnonymity(boolean state)
                      throws GSSException
        Requests that the initiator's identity not be disclosed to the acceptor. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support anonymity for the initiator. Therefore, the application should check to see if the request was honored with the getAnonymityState method.

        参数：
        state - a boolean value indicating if the initiator should be authenticated to the acceptor as an anonymous principal.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getAnonymityState()

      • requestConf

        void requestConf(boolean state)
                 throws GSSException
        Requests that data confidentiality be enabled for the wrap method. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support confidentiality and other mechanisms might enable it even if the application doesn't request it. The application may check to see if the request was honored with the getConfState method. If confidentiality is enabled, only then will the mechanism honor a request for privacy in the MessageProp object that is passed in to the wrap method.

        Enabling confidentiality will also automatically enable integrity.

        参数：
        state - a boolean value indicating whether confidentiality should be enabled or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getConfState(), getIntegState(), requestInteg(boolean), MessageProp

      • requestInteg

        void requestInteg(boolean state)
                  throws GSSException
        Requests that data integrity be enabled for the wrap and getMICmethods. This request can only be made on the context initiator's side and it has to be done prior to the first call to initSecContext. Not all mechanisms support integrity and other mechanisms might enable it even if the application doesn't request it. The application may check to see if the request was honored with the getIntegState method.

        Disabling integrity will also automatically disable confidentiality.

        参数：
        state - a boolean value indicating whether integrity should be enabled or not.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getIntegState()

      • requestLifetime

        void requestLifetime(int lifetime)
                     throws GSSException
        Requests a lifetime in seconds for the context. This method can only be called on the context initiator's side and it has to be done prior to the first call to initSecContext.

        The actual lifetime of the context will depend on the capabilites of the underlying mechanism and the application should call the getLifetime method to determine this.

        参数：
        lifetime - the desired context lifetime in seconds. Use INDEFINITE_LIFETIME to request an indefinite lifetime and DEFAULT_LIFETIME to request a default lifetime.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getLifetime()

      • setChannelBinding

        void setChannelBinding(ChannelBinding cb)
                       throws GSSException
        Sets the channel bindings to be used during context establishment. This method can be called on both the context initiator's and the context acceptor's side, but it must be called before context establishment begins. This means that an initiator must call it before the first call to initSecContext and the acceptor must call it before the first call to acceptSecContext.
        参数：
        cb - the channel bindings to use.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getCredDelegState

        boolean getCredDelegState()
        Determines if credential delegation is enabled on this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. Note that if an initiator requests that delegation not be allowed the requestCredDeleg method will honor that request and this method will return false on the initiator's side from that point onwards.

        返回：
        true if delegation is enabled, false otherwise.
        另请参见：
        requestCredDeleg(boolean)

      • getMutualAuthState

        boolean getMutualAuthState()
        Determines if mutual authentication is enabled on this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests mutual authentication can call this method after context completion and dispose the context if its request was not honored.

        返回：
        true if mutual authentication is enabled, false otherwise.
        另请参见：
        requestMutualAuth(boolean)

      • getReplayDetState

        boolean getReplayDetState()
        Determines if replay detection is enabled for the per-message security services from this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests replay detection can call this method after context completion and dispose the context if its request was not honored.

        返回：
        true if replay detection is enabled, false otherwise.
        另请参见：
        requestReplayDet(boolean)

      • getSequenceDetState

        boolean getSequenceDetState()
        Determines if sequence checking is enabled for the per-message security services from this context. It can be called by both the context initiator and the context acceptor. For a definitive answer this method must be called only after context establishment is complete. An initiator that requests sequence checking can call this method after context completion and dispose the context if its request was not honored.

        返回：
        true if sequence checking is enabled, false otherwise.
        另请参见：
        requestSequenceDet(boolean)

      • getAnonymityState

        boolean getAnonymityState()
        Determines if the context initiator is anonymously authenticated to the context acceptor. It can be called by both the context initiator and the context acceptor, and at any time. On the initiator side, a call to this method determines if the identity of the initiator has been disclosed in any of the context establishment tokens that might have been generated thus far by initSecContext. An initiator that absolutely must be authenticated anonymously should call this method after each call to initSecContext to determine if the generated token should be sent to the peer or the context aborted. On the acceptor side, a call to this method determines if any of the tokens processed by acceptSecContext thus far have divulged the identity of the initiator.

        返回：
        true if the context initiator is still anonymous, false otherwise.
        另请参见：
        requestAnonymity(boolean)

      • isTransferable

        boolean isTransferable()
                       throws GSSException
        Determines if the context is transferable to other processes through the use of the export method. This call is only valid on fully established contexts.
        返回：
        true if this context can be exported, false otherwise.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isProtReady

        boolean isProtReady()
        Determines if the context is ready for per message operations to be used over it. Some mechanisms may allow the usage of the per-message operations before the context is fully established.
        返回：
        true if methods like wrap, unwrap, getMIC, and verifyMIC can be used with this context at the current stage of context establishment, false otherwise.

      • getConfState

        boolean getConfState()
        Determines if data confidentiality is available over the context. This method can be called by both the context initiator and the context acceptor, but only after one of isProtReady or isEstablished return true. If this method returns true, so will getIntegState

        返回：
        true if confidentiality services are available, false otherwise.
        另请参见：
        requestConf(boolean)

      • getIntegState

        boolean getIntegState()
        Determines if data integrity is available over the context. This method can be called by both the context initiator and the context acceptor, but only after one of isProtReady or isEstablished return true. This method will always return true if getConfState returns true.

        返回：
        true if integrity services are available, false otherwise.
        另请参见：
        requestInteg(boolean)

      • getLifetime

        int getLifetime()
        Determines what the remaining lifetime for this context is. It can be called by both the context initiator and the context acceptor, but for a definitive answer it should be called only after isEstablished returns true.

        返回：
        the remaining lifetime in seconds
        另请参见：
        requestLifetime(int)

      • getSrcName

        GSSName getSrcName()
                   throws GSSException
        Returns the name of the context initiator. This call is valid only after one of isProtReady or isEstablished return true.
        返回：
        a GSSName that is an MN containing the name of the context initiator.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        GSSName

      • getTargName

        GSSName getTargName()
                    throws GSSException
        Returns the name of the context acceptor. This call is valid only after one of isProtReady or isEstablished return true.
        返回：
        a GSSName that is an MN containing the name of the context acceptor.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getMech

        Oid getMech()
            throws GSSException
        Determines what mechanism is being used for this context. This method may be called before the context is fully established, but the mechanism returned may change on successive calls in the negotiated mechanism case.
        返回：
        the Oid of the mechanism being used
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getDelegCred

        GSSCredential getDelegCred()
                           throws GSSException
        Obtains the credentials delegated by the context initiator to the context acceptor. It should be called only on the context acceptor's side, and once the context is fully established. The caller can use the method getCredDelegState to determine if there are any delegated credentials.
        返回：
        a GSSCredential containing the initiator's delegated credentials, or null is no credentials were delegated.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isInitiator

        boolean isInitiator()
                    throws GSSException
        Determines if this is the context initiator. This can be called on both the context initiator's and context acceptor's side.
        返回：
        true if this is the context initiator, false if it is the context acceptor.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


GSSCredential

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.ietf.jgss

Interface GSSCredential

  • All Superinterfaces:
    Cloneable

    public interface GSSCredential
extends Cloneable
    This interface encapsulates the GSS-API credentials for an entity. A credential contains all the necessary cryptographic information to enable the creation of a context on behalf of the entity that it represents. It may contain multiple, distinct, mechanism specific credential elements, each containing information for a specific security mechanism, but all referring to the same entity. A credential may be used to perform context initiation, acceptance, or both.

    Credentials are instantiated using one of the createCredential methods in the GSSManager class. GSS-API credential creation is not intended to provide a "login to the network" function, as such a function would involve the creation of new credentials rather than merely acquiring a handle to existing credentials. The section on credential acquisition in the package level description describes how existing credentials are acquired in the Java platform. GSS-API implementations must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled.

    Applications will create a credential object passing the desired parameters. The application can then use the query methods to obtain specific information about the instantiated credential object. When the credential is no longer needed, the application should call the dispose method to release any resources held by the credential object and to destroy any cryptographically sensitive information.

    This example code demonstrates the creation of a GSSCredential implementation for a specific entity, querying of its fields, and its release when it is no longer needed:

        GSSManager manager = GSSManager.getInstance();

    // start by creating a name object for the entity
    GSSName name = manager.createName("myusername", GSSName.NT_USER_NAME);

    // now acquire credentials for the entity
    GSSCredential cred = manager.createCredential(name,
                    GSSCredential.ACCEPT_ONLY);

    // display credential information - name, remaining lifetime,
    // and the mechanisms it has been acquired over
    System.out.println(cred.getName().toString());
    System.out.println(cred.getRemainingLifetime());

    Oid [] mechs = cred.getMechs();
    if (mechs != null) {
            for (int i = 0; i < mechs.length; i++)
                    System.out.println(mechs[i].toString());
    }

    // release system resources held by the credential
    cred.dispose();
    从以下版本开始：
    1.4
    另请参见：
    GSSManager.createCredential(int),
GSSManager.createCredential(GSSName, int, Oid, int),
GSSManager.createCredential(GSSName, int, Oid[], int),
dispose()

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int ACCEPT_ONLY
      Credential usage flag requesting that it be usable for context acceptance only.
      static int DEFAULT_LIFETIME
      A lifetime constant representing the default credential lifetime.
      static int INDEFINITE_LIFETIME
      A lifetime constant representing indefinite credential lifetime.
      static int INITIATE_AND_ACCEPT
      Credential usage flag requesting that it be usable for both context initiation and acceptance.
      static int INITIATE_ONLY
      Credential usage flag requesting that it be usable for context initiation only.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      void dispose()
      Releases any sensitive information that the GSSCredential object may be containing.
      boolean equals(Object another)
      Tests if this GSSCredential asserts the same entity as the supplied object.
      Oid[] getMechs()
      Returns a list of mechanisms supported by this credential.
      GSSName getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      int getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int getRemainingLifetime()
      Returns the remaining lifetime in seconds for a credential.
      int getUsage()
      Returns the credential usage mode.
      int getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
      int hashCode()
      Returns a hashcode value for this GSSCredential.

    • 字段详细信息

      • INITIATE_AND_ACCEPT

        static final int INITIATE_AND_ACCEPT
        Credential usage flag requesting that it be usable for both context initiation and acceptance.
        另请参见：
        Constant Field Values

      • INITIATE_ONLY

        static final int INITIATE_ONLY
        Credential usage flag requesting that it be usable for context initiation only.
        另请参见：
        Constant Field Values

      • ACCEPT_ONLY

        static final int ACCEPT_ONLY
        Credential usage flag requesting that it be usable for context acceptance only.
        另请参见：
        Constant Field Values

      • DEFAULT_LIFETIME

        static final int DEFAULT_LIFETIME
        A lifetime constant representing the default credential lifetime. This value it set to 0.
        另请参见：
        Constant Field Values

      • INDEFINITE_LIFETIME

        static final int INDEFINITE_LIFETIME
        A lifetime constant representing indefinite credential lifetime. This value must is set to the maximum integer value in Java - Integer.MAX_VALUE.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • dispose

        void dispose()
             throws GSSException
        Releases any sensitive information that the GSSCredential object may be containing. Applications should call this method as soon as the credential is no longer needed to minimize the time any sensitive information is maintained.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getName

        GSSName getName()
                throws GSSException
        Retrieves the name of the entity that the credential asserts.
        返回：
        a GSSName representing the entity
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getName

        GSSName getName(Oid mech)
                throws GSSException
        Retrieves a Mechanism Name of the entity that the credential asserts. This is equivalent to calling canonicalize on the value returned by the other form of getName.
        参数：
        mech - the Oid of the mechanism for which the Mechanism Name should be returned.
        返回：
        a GSSName representing the entity canonicalized for the desired mechanism
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getRemainingLifetime

        int getRemainingLifetime()
                         throws GSSException
        Returns the remaining lifetime in seconds for a credential. The remaining lifetime is the minimum lifetime amongst all of the underlying mechanism specific credential elements.
        返回：
        the minimum remaining lifetime in seconds for this credential. A return value of INDEFINITE_LIFETIME indicates that the credential does not expire. A return value of 0 indicates that the credential is already expired.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE
        另请参见：
        getRemainingInitLifetime(Oid), getRemainingAcceptLifetime(Oid)

      • getRemainingInitLifetime

        int getRemainingInitLifetime(Oid mech)
                             throws GSSException
        Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism. This method queries the initiator credential element that belongs to the specified mechanism.
        参数：
        mech - the Oid of the mechanism whose intiator credential element should be queried.
        返回：
        the number of seconds remaining in the life of this credential element. A return value of INDEFINITE_LIFETIME indicates that the credential element does not expire. A return value of 0 indicates that the credential element is already expired.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getRemainingAcceptLifetime

        int getRemainingAcceptLifetime(Oid mech)
                               throws GSSException
        Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism. This method queries the acceptor credential element that belongs to the specified mechanism.
        参数：
        mech - the Oid of the mechanism whose acceptor credential element should be queried.
        返回：
        the number of seconds remaining in the life of this credential element. A return value of INDEFINITE_LIFETIME indicates that the credential element does not expire. A return value of 0 indicates that the credential element is already expired.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getUsage

        int getUsage()
             throws GSSException
        Returns the credential usage mode. In other words, it tells us if this credential can be used for initiating or accepting security contexts. It does not tell us which mechanism(s) has to be used in order to do so. It is expected that an application will allow the GSS-API to pick a default mechanism after calling this method.
        返回：
        The return value will be one of INITIATE_ONLY, ACCEPT_ONLY, and INITIATE_AND_ACCEPT.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • getUsage

        int getUsage(Oid mech)
             throws GSSException
        Returns the credential usage mode for a specific mechanism. In other words, it tells us if this credential can be used for initiating or accepting security contexts with a given underlying mechanism.
        参数：
        mech - the Oid of the mechanism whose credentials usage mode is to be determined.
        返回：
        The return value will be one of INITIATE_ONLY, ACCEPT_ONLY, and INITIATE_AND_ACCEPT.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.FAILURE

      • getMechs

        Oid[] getMechs()
               throws GSSException
        Returns a list of mechanisms supported by this credential. It does not tell us which ones can be used to initiate contexts and which ones can be used to accept contexts. The application must call the getUsage method with each of the returned Oid's to determine the possible modes of usage.
        返回：
        an array of Oid's corresponding to the supported mechanisms.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • add

        void add(GSSName name,
       int initLifetime,
       int acceptLifetime,
       Oid mech,
       int usage)
         throws GSSException
        Adds a mechanism specific credential-element to an existing credential. This method allows the construction of credentials, one mechanism at a time.

        This routine is envisioned to be used mainly by context acceptors during the creation of acceptor credentials which are to be used with a variety of clients using different security mechanisms.

        This routine adds the new credential element "in-place". To add the element in a new credential, first call clone to obtain a copy of this credential, then call its add method.

        As always, GSS-API implementations must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. Non-default values for initLifetime and acceptLifetime cannot always be honored by the underlying mechanisms, thus callers should be prepared to call getRemainingInitLifetime and getRemainingAcceptLifetime on the credential.

        参数：
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        initLifetime - the number of seconds that the credential element should remain valid for initiating of security contexts. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime for this. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime for this.
        acceptLifetime - the number of seconds that the credential element should remain valid for accepting security contexts. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime for this. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime for this.
        mech - the mechanism over which the credential is to be acquired.
        usage - the usage mode that this credential element should add to the credential. The value of this parameter must be one of: INITIATE_AND_ACCEPT, ACCEPT_ONLY, and INITIATE_ONLY.
        抛出：
        GSSException - containing the following major error codes: GSSException.DUPLICATE_ELEMENT, GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.FAILURE

      • equals

        boolean equals(Object another)
        Tests if this GSSCredential asserts the same entity as the supplied object. The two credentials must be acquired over the same mechanisms and must refer to the same principal.
        重载：
        equals in class Object
        参数：
        another - another GSSCredential for comparison to this one
        返回：
        true if the two GSSCredentials assert the same entity; false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • hashCode

        int hashCode()
        Returns a hashcode value for this GSSCredential.
        重载：
        hashCode in class Object
        返回：
        a hashCode value
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

_eMeGSoSSocddoccImEEeceocGFETIEFCNSt_DtT


GSSException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.ietf.jgss

类 GSSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.ietf.jgss.GSSException
  • 所有已实现的接口：
    Serializable

    public class GSSException
extends Exception
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error. It may contain both the major and the minor GSS-API status codes. Major error codes are those defined at the GSS-API level in this class. Minor error codes are mechanism specific error codes that can provide additional information. The underlying mechanism implementation is responsible for setting appropriate minor status codes when throwing this exception. Aside from delivering the numeric error codes to the caller, this class performs the mapping from their numeric values to textual representations.

    从以下版本开始：
    1.4
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int BAD_BINDINGS
      Channel bindings mismatch.
      static int BAD_MECH
      Unsupported mechanism requested.
      static int BAD_MIC
      Token had invalid integrity check.
      static int BAD_NAME
      Invalid name provided.
      static int BAD_NAMETYPE
      Name of unsupported type provided.
      static int BAD_QOP
      Unsupported QOP value.
      static int BAD_STATUS
      Invalid status code.
      static int CONTEXT_EXPIRED
      Security context expired.
      static int CREDENTIALS_EXPIRED
      Expired credentials.
      static int DEFECTIVE_CREDENTIAL
      Defective credentials.
      static int DEFECTIVE_TOKEN
      Defective token.
      static int DUPLICATE_ELEMENT
      Duplicate credential element requested.
      static int DUPLICATE_TOKEN
      The token was a duplicate of an earlier token.
      static int FAILURE
      General failure, unspecified at GSS-API level.
      static int GAP_TOKEN
      An expected per-message token was not received.
      static int NAME_NOT_MN
      Name contains multi-mechanism elements.
      static int NO_CONTEXT
      Invalid security context.
      static int NO_CRED
      Invalid credentials.
      static int OLD_TOKEN
      The token's validity period has expired.
      static int UNAUTHORIZED
      Operation unauthorized.
      static int UNAVAILABLE
      Operation unavailable.
      static int UNSEQ_TOKEN
      A later token has already been processed.

    • 构造方法摘要

      Constructors
      构造方法与描述
      GSSException(int majorCode)
      Creates a GSSException object with a specified major code.
      GSSException(int majorCode, int minorCode, String minorString)
      Creates a GSSException object with the specified major code, minor code, and minor code textual explanation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getMajor()
      Returns the GSS-API level major error code for the problem causing this exception to be thrown.
      String getMajorString()
      Returns a string explaining the GSS-API level major error code in this exception.
      String getMessage()
      Returns a textual representation of both the major and the minor status codes.
      int getMinor()
      Returns the mechanism level error code for the problem causing this exception to be thrown.
      String getMinorString()
      Returns a string explaining the mechanism specific error code.
      void setMinor(int minorCode, String message)
      Used by the exception thrower to set the mechanism level minor error code and its string explanation.
      String toString()
      Returns a textual representation of both the major and the minor status codes.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • BAD_BINDINGS

        public static final int BAD_BINDINGS
        Channel bindings mismatch.
        另请参见：
        Constant Field Values

      • BAD_MECH

        public static final int BAD_MECH
        Unsupported mechanism requested.
        另请参见：
        Constant Field Values

      • BAD_NAME

        public static final int BAD_NAME
        Invalid name provided.
        另请参见：
        Constant Field Values

      • BAD_NAMETYPE

        public static final int BAD_NAMETYPE
        Name of unsupported type provided.
        另请参见：
        Constant Field Values

      • BAD_STATUS

        public static final int BAD_STATUS
        Invalid status code.
        另请参见：
        Constant Field Values

      • BAD_MIC

        public static final int BAD_MIC
        Token had invalid integrity check.
        另请参见：
        Constant Field Values

      • CONTEXT_EXPIRED

        public static final int CONTEXT_EXPIRED
        Security context expired.
        另请参见：
        Constant Field Values

      • CREDENTIALS_EXPIRED

        public static final int CREDENTIALS_EXPIRED
        Expired credentials.
        另请参见：
        Constant Field Values

      • DEFECTIVE_CREDENTIAL

        public static final int DEFECTIVE_CREDENTIAL
        Defective credentials.
        另请参见：
        Constant Field Values

      • DEFECTIVE_TOKEN

        public static final int DEFECTIVE_TOKEN
        Defective token.
        另请参见：
        Constant Field Values

      • FAILURE

        public static final int FAILURE
        General failure, unspecified at GSS-API level.
        另请参见：
        Constant Field Values

      • NO_CONTEXT

        public static final int NO_CONTEXT
        Invalid security context.
        另请参见：
        Constant Field Values

      • NO_CRED

        public static final int NO_CRED
        Invalid credentials.
        另请参见：
        Constant Field Values

      • BAD_QOP

        public static final int BAD_QOP
        Unsupported QOP value.
        另请参见：
        Constant Field Values

      • UNAUTHORIZED

        public static final int UNAUTHORIZED
        Operation unauthorized.
        另请参见：
        Constant Field Values

      • UNAVAILABLE

        public static final int UNAVAILABLE
        Operation unavailable.
        另请参见：
        Constant Field Values

      • DUPLICATE_ELEMENT

        public static final int DUPLICATE_ELEMENT
        Duplicate credential element requested.
        另请参见：
        Constant Field Values

      • NAME_NOT_MN

        public static final int NAME_NOT_MN
        Name contains multi-mechanism elements.
        另请参见：
        Constant Field Values

      • DUPLICATE_TOKEN

        public static final int DUPLICATE_TOKEN
        The token was a duplicate of an earlier token. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        另请参见：
        Constant Field Values

      • OLD_TOKEN

        public static final int OLD_TOKEN
        The token's validity period has expired. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        另请参见：
        Constant Field Values

      • UNSEQ_TOKEN

        public static final int UNSEQ_TOKEN
        A later token has already been processed. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        另请参见：
        Constant Field Values

      • GAP_TOKEN

        public static final int GAP_TOKEN
        An expected per-message token was not received. This is a fatal error code that may occur during context establishment. It is not used to indicate supplementary status values. The MessageProp object is used for that purpose.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • GSSException

        public GSSException(int majorCode)
        Creates a GSSException object with a specified major code.
        参数：
        majorCode - the The GSS error code for the problem causing this exception to be thrown.

      • GSSException

        public GSSException(int majorCode,
            int minorCode,
            String minorString)
        Creates a GSSException object with the specified major code, minor code, and minor code textual explanation. This constructor is to be used when the exception is originating from the underlying mechanism level. It allows the setting of both the GSS code and the mechanism code.
        参数：
        majorCode - the GSS error code for the problem causing this exception to be thrown.
        minorCode - the mechanism level error code for the problem causing this exception to be thrown.
        minorString - the textual explanation of the mechanism error code.

    • 方法详细信息

      • getMajor

        public int getMajor()
        Returns the GSS-API level major error code for the problem causing this exception to be thrown. Major error codes are defined at the mechanism independent GSS-API level in this class. Mechanism specific error codes that might provide more information aer set as the minor error code.
        返回：
        int the GSS-API level major error code causing this exception
        另请参见：
        getMajorString(),
getMinor(),
getMinorString()

      • getMinor

        public int getMinor()
        Returns the mechanism level error code for the problem causing this exception to be thrown. The minor code is set by the underlying mechanism.
        返回：
        int the mechanism error code; 0 indicates that it has not been set.
        另请参见：
        getMinorString(), setMinor(int, java.lang.String)

      • getMajorString

        public String getMajorString()
        Returns a string explaining the GSS-API level major error code in this exception.
        返回：
        String explanation string for the major error code
        另请参见：
        getMajor(), toString()

      • getMinorString

        public String getMinorString()
        Returns a string explaining the mechanism specific error code. If the minor status code is 0, then no mechanism level error details will be available.
        返回：
        String a textual explanation of mechanism error code
        另请参见：
        getMinor(),
getMajorString(),
toString()

      • setMinor

        public void setMinor(int minorCode,
            String message)
        Used by the exception thrower to set the mechanism level minor error code and its string explanation. This is used by mechanism providers to indicate error details.
        参数：
        minorCode - the mechanism specific error code
        message - textual explanation of the mechanism error code
        另请参见：
        getMinor()

      • toString

        public String toString()
        Returns a textual representation of both the major and the minor status codes.
        重载：
        toString in class Throwable
        返回：
        a String with the error descriptions

      • getMessage

        public String getMessage()
        Returns a textual representation of both the major and the minor status codes.
        重载：
        getMessage in class Throwable
        返回：
        a String with the error descriptions
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:e/= =<=p=fhtp:bthzz= = EOO -=->=ATVF c"=pl=z


GSSManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.ietf.jgss

类 GSSManager

  • java.lang.Object
    • org.ietf.jgss.GSSManager

  • public abstract class GSSManager
extends Object
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported. It can create instances of classes implementing the following three GSS-API interfaces: GSSName, GSSCredential, and GSSContext. It also has methods to query for the list of available mechanisms and the nametypes that each mechanism supports.

    An instance of the default GSSManager subclass may be obtained through the static method getInstance, but applications are free to instantiate other subclasses of GSSManager. The default GSSManager instance will support the Kerberos v5 GSS-API mechanism in addition to any others. This mechanism is identified by the Oid "1.2.840.113554.1.2.2" and is defined in RFC 1964.

    A subclass extending the GSSManager abstract class may be implemented as a modular provider based layer that utilizes some well known service provider specification. The GSSManager API allows the application to set provider preferences on such an implementation. These methods also allow the implementation to throw a well-defined exception in case provider based configuration is not supported. Applications that expect to be portable should be aware of this and recover cleanly by catching the exception.

    It is envisioned that there will be three most common ways in which providers will be used:

    1. The application does not care about what provider is used (the default case).
    2. The application wants a particular provider to be used preferentially, either for a particular mechanism or all the time, irrespective of mechanism.
    3. The application wants to use the locally configured providers as far as possible but if support is missing for one or more mechanisms then it wants to fall back on its own provider.

    The GSSManager class has two methods that enable these modes of usage: addProviderAtFront and addProviderAtEnd. These methods have the effect of creating an ordered list of <provider, oid> pairs where each pair indicates a preference of provider for a given oid.

    It is important to note that there are certain interactions between the different GSS-API objects that are created by a GSSManager, where the provider that is used for a particular mechanism might need to be consistent across all objects. For instance, if a GSSCredential contains elements from a provider p for a mechanism m, it should generally be passed in to a GSSContext that will use provider p for the mechanism m. A simple rule of thumb that will maximize portability is that objects created from different GSSManager's should not be mixed, and if possible, a different GSSManager instance should be created if the application wants to invoke the addProviderAtFront method on a GSSManager that has already created an object.

    Here is some sample code showing how the GSSManager might be used:

         GSSManager manager = GSSManager.getInstance();

     Oid krb5Mechanism = new Oid("1.2.840.113554.1.2.2");
     Oid krb5PrincipalNameType = new Oid("1.2.840.113554.1.2.2.1");

     // Identify who the client wishes to be
     GSSName userName = manager.createName("duke", GSSName.NT_USER_NAME);

     // Identify the name of the server. This uses a Kerberos specific
     // name format.
     GSSName serverName = manager.createName("nfs/foo.sun.com",
                                             krb5PrincipalNameType);

     // Acquire credentials for the user
     GSSCredential userCreds = manager.createCredential(userName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.INITIATE_ONLY);

     // Instantiate and initialize a security context that will be
     // established with the server
     GSSContext context = manager.createContext(serverName,
                                                krb5Mechanism,
                                                userCreds,
                                                GSSContext.DEFAULT_LIFETIME);

    The server side might use the following variation of this source:

         // Acquire credentials for the server
     GSSCredential serverCreds = manager.createCredential(serverName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.ACCEPT_ONLY);

     // Instantiate and initialize a security context that will
     // wait for an establishment request token from the client
     GSSContext context = manager.createContext(serverCreds);
    从以下版本开始：
    1.4
    另请参见：
    GSSName, GSSCredential, GSSContext

    • 构造方法摘要

      Constructors
      构造方法与描述
      GSSManager()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      abstract GSSContext createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential createCredential(int usage)
      Factory method for acquiring default credentials.
      abstract GSSName createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      static GSSManager getInstance()
      Returns the default GSSManager implementation.
      abstract Oid[] getMechs()
      Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.
      abstract Oid[] getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      abstract Oid[] getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • GSSManager

        public GSSManager()

    • 方法详细信息

      • getInstance

        public static GSSManager getInstance()
        Returns the default GSSManager implementation.
        返回：
        a GSSManager implementation

      • getMechs

        public abstract Oid[] getMechs()
        Returns a list of mechanisms that are available to GSS-API callers through this GSSManager. The default GSSManager obtained from the getInstance() method includes the Oid "1.2.840.113554.1.2.2" in its list. This Oid identifies the Kerberos v5 GSS-API mechanism that is defined in RFC 1964.
        返回：
        an array of Oid objects corresponding to the mechanisms that are available. A null value is returned when no mechanism are available (an example of this would be when mechanism are dynamically configured, and currently no mechanisms are installed).

      • getNamesForMech

        public abstract Oid[] getNamesForMech(Oid mech)
                               throws GSSException
        Returns then name types supported by the indicated mechanism.

        The default GSSManager instance includes support for the Kerberos v5 mechanism. When this mechanism ("1.2.840.113554.1.2.2") is indicated, the returned list will contain at least the following nametypes: GSSName.NT_HOSTBASED_SERVICE, GSSName.NT_EXPORT_NAME, and the Kerberos v5 specific Oid "1.2.840.113554.1.2.2.1". The namespace for the Oid "1.2.840.113554.1.2.2.1" is defined in RFC 1964.

        参数：
        mech - the Oid of the mechanism to query
        返回：
        an array of Oid objects corresponding to the name types that the mechanism supports.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH GSSException.FAILURE
        另请参见：
        getMechsForName(Oid)

      • getMechsForName

        public abstract Oid[] getMechsForName(Oid nameType)
        Returns a list of mechanisms that support the indicated name type.

        The Kerberos v5 mechanism ("1.2.840.113554.1.2.2") will always be returned in this list when the indicated nametype is one of GSSName.NT_HOSTBASED_SERVICE, GSSName.NT_EXPORT_NAME, or "1.2.840.113554.1.2.2.1".

        参数：
        nameType - the Oid of the name type to look for
        返回：
        an array of Oid objects corresponding to the mechanisms that support the specified name type. null is returned when no mechanisms are found to support the specified name type.
        另请参见：
        getNamesForMech(Oid)

      • createName

        public abstract GSSName createName(String nameStr,
                 Oid nameType)
                            throws GSSException
        Factory method to convert a string name from the specified namespace to a GSSName object. In general, the GSSName object created will contain multiple representations of the name, one for each mechanism that is supported; two examples that are exceptions to this are when the namespace type parameter indicates NT_EXPORT_NAME or when the GSS-API implementation is not multi-mechanism. It is not recommended to use this method with a NT_EXPORT_NAME type because representing a previously exported name consisting of abitrary bytes as a String might cause problems with character encoding schemes. In such cases it is recommended that the bytes be passed in directly to the overloaded form of this method createName.
        参数：
        nameStr - the string representing a printable form of the name to create.
        nameType - the Oid specifying the namespace of the printable name supplied. null can be used to specify that a mechanism specific default printable syntax should be assumed by each mechanism that examines nameStr. It is not advisable to use the nametype NT_EXPORT_NAME with this method.
        返回：
        a GSSName representing the indicated principal
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        另请参见：
        GSSName, GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(byte[] name,
                 Oid nameType)
                            throws GSSException
        Factory method to convert a byte array containing a name from the specified namespace to a GSSName object. In general, the GSSName object created will contain multiple representations of the name, one for each mechanism that is supported; two examples that are exceptions to this are when the namespace type parameter indicates NT_EXPORT_NAME or when the GSS-API implementation is not multi-mechanism. The bytes that are passed in are interpreted by each underlying mechanism according to some encoding scheme of its choice for the given nametype.
        参数：
        name - the byte array containing the name to create
        nameType - the Oid specifying the namespace of the name supplied in the byte array. null can be used to specify that a mechanism specific default syntax should be assumed by each mechanism that examines the byte array.
        返回：
        a GSSName representing the indicated principal
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        另请参见：
        GSSName, GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(String nameStr,
                 Oid nameType,
                 Oid mech)
                            throws GSSException
        Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism. In other words, this method is a utility that does the equivalent of two steps: the createName and then also the GSSName.canonicalize.
        参数：
        nameStr - the string representing a printable form of the name to create.
        nameType - the Oid specifying the namespace of the printable name supplied. null can be used to specify that a mechanism specific default printable syntax should be assumed by each mechanism that examines nameStr. It is not advisable to use the nametype NT_EXPORT_NAME with this method.
        mech - Oid specifying the mechanism for which the name should be canonicalized
        返回：
        a GSSName representing the indicated principal
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        另请参见：
        GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

      • createName

        public abstract GSSName createName(byte[] name,
                 Oid nameType,
                 Oid mech)
                            throws GSSException
        Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism. In other words, this method is a utility that does the equivalent of two steps: the createName and then also GSSName.canonicalize.
        参数：
        name - the byte array containing the name to create
        nameType - the Oid specifying the namespace of the name supplied in the byte array. null can be used to specify that a mechanism specific default syntax should be assumed by each mechanism that examines the byte array.
        mech - Oid specifying the mechanism for which the name should be canonicalized
        返回：
        a GSSName representing the indicated principal
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.BAD_MECH, GSSException.FAILURE
        另请参见：
        GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

      • createCredential

        public abstract GSSCredential createCredential(int usage)
                                        throws GSSException
        Factory method for acquiring default credentials. This will cause the GSS-API to use system specific defaults for the set of mechanisms, name, and lifetime.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        参数：
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        返回：
        a GSSCredential of the requested type.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        另请参见：
        GSSCredential

      • createCredential

        public abstract GSSCredential createCredential(GSSName name,
                             int lifetime,
                             Oid mech,
                             int usage)
                                        throws GSSException
        Factory method for acquiring a single mechanism credential.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanisms, thus applications should be prepared to call getRemainingLifetime on the returned credential.

        参数：
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        lifetime - The number of seconds that credentials should remain valid. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime.
        mech - the Oid of the desired mechanism. Use (Oid) null to request the default mechanism.
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        返回：
        a GSSCredential of the requested type.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        另请参见：
        GSSCredential

      • createCredential

        public abstract GSSCredential createCredential(GSSName name,
                             int lifetime,
                             Oid[] mechs,
                             int usage)
                                        throws GSSException
        Factory method for acquiring credentials over a set of mechanisms. This method attempts to acquire credentials for each of the mechanisms specified in the array called mechs. To determine the list of mechanisms for which the acquisition of credentials succeeded, the caller should use the GSSCredential.getMechs method.

        GSS-API mechanism providers must impose a local access-control policy on callers to prevent unauthorized callers from acquiring credentials to which they are not entitled. The kinds of permissions needed by different mechanism providers will be documented on a per-mechanism basis. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanisms, thus applications should be prepared to call getRemainingLifetime on the returned credential.

        参数：
        name - the name of the principal for whom this credential is to be acquired. Use null to specify the default principal.
        lifetime - The number of seconds that credentials should remain valid. Use GSSCredential.INDEFINITE_LIFETIME to request that the credentials have the maximum permitted lifetime. Use GSSCredential.DEFAULT_LIFETIME to request default credential lifetime.
        mechs - an array of Oid's indicating the mechanisms over which the credential is to be acquired. Use (Oid[]) null for requesting a system specific default set of mechanisms.
        usage - The intended usage for this credential object. The value of this parameter must be one of: GSSCredential.INITIATE_AND_ACCEPT, GSSCredential.ACCEPT_ONLY, and GSSCredential.INITIATE_ONLY.
        返回：
        a GSSCredential of the requested type.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.CREDENTIALS_EXPIRED, GSSException.NO_CRED, GSSException.FAILURE
        另请参见：
        GSSCredential

      • createContext

        public abstract GSSContext createContext(GSSName peer,
                       Oid mech,
                       GSSCredential myCred,
                       int lifetime)
                                  throws GSSException
        Factory method for creating a context on the initiator's side. Some mechanism providers might require that the caller be granted permission to initiate a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        Non-default values for lifetime cannot always be honored by the underlying mechanism, thus applications should be prepared to call getLifetime on the returned context.

        参数：
        peer - the name of the target peer.
        mech - the Oid of the desired mechanism. Use null to request the default mechanism.
        myCred - the credentials of the initiator. Use null to act as the default initiator principal.
        lifetime - the lifetime, in seconds, requested for the context. Use GSSContext.INDEFINITE_LIFETIME to request that the context have the maximum permitted lifetime. Use GSSContext.DEFAULT_LIFETIME to request a default lifetime for the context.
        返回：
        an unestablished GSSContext
        抛出：
        GSSException - containing the following major error codes: GSSException.NO_CRED GSSException.CREDENTIALS_EXPIRED GSSException.BAD_NAMETYPE GSSException.BAD_MECH GSSException.FAILURE
        另请参见：
        GSSContext

      • createContext

        public abstract GSSContext createContext(GSSCredential myCred)
                                  throws GSSException
        Factory method for creating a context on the acceptor' side. The context's properties will be determined from the input token supplied to the accept method. Some mechanism providers might require that the caller be granted permission to accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.
        参数：
        myCred - the credentials for the acceptor. Use null to act as a default acceptor principal.
        返回：
        an unestablished GSSContext
        抛出：
        GSSException - containing the following major error codes: GSSException.NO_CRED GSSException.CREDENTIALS_EXPIRED GSSException.BAD_MECH GSSException.FAILURE
        另请参见：
        GSSContext

      • createContext

        public abstract GSSContext createContext(byte[] interProcessToken)
                                  throws GSSException
        Factory method for creating a previously exported context. The context properties will be determined from the input token and cannot be modified through the set methods.

        Implementations are not required to support the inter-process transfer of security contexts. Before exporting a context, calling the GSSContext.isTransferable will indicate if the context is transferable. Calling this method in an implementation that does not support it will result in a GSSException with the error code GSSException.UNAVAILABLE. Some mechanism providers might require that the caller be granted permission to initiate or accept a security context. A failed permission check might cause a SecurityException to be thrown from this method.

        参数：
        interProcessToken - the token previously emitted from the export method.
        返回：
        the previously established GSSContext
        抛出：
        GSSException - containing the following major error codes: GSSException.NO_CONTEXT, GSSException.DEFECTIVE_TOKEN, GSSException.UNAVAILABLE, GSSException.UNAUTHORIZED, GSSException.FAILURE
        另请参见：
        GSSContext

      • addProviderAtFront

        public abstract void addProviderAtFront(Provider p,
                      Oid mech)
                                 throws GSSException
        This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism. When a value of null is used instead of an Oid for the mechanism, the GSSManager must use the indicated provider ahead of all others no matter what the mechanism is. Only when the indicated provider does not support the needed mechanism should the GSSManager move on to a different provider.

        Calling this method repeatedly preserves the older settings but lowers them in preference thus forming an ordered list of provider and Oid pairs that grows at the top.

        Calling addProviderAtFront with a null Oid will remove all previous preferences that were set for this provider in the GSSManager instance. Calling addProviderAtFront with a non-null Oid will remove any previous preference that was set using this mechanism and this provider together.

        If the GSSManager implementation does not support an SPI with a pluggable provider architecture it should throw a GSSException with the status code GSSException.UNAVAILABLE to indicate that the operation is unavailable.

        Suppose an application desired that the provider A always be checked first when any mechanism is needed, it would call:

                 GSSManager mgr = GSSManager.getInstance();
         // mgr may at this point have its own pre-configured list
         // of provider preferences. The following will prepend to
         // any such list:

         mgr.addProviderAtFront(A, null);
        Now if it also desired that the mechanism of Oid m1 always be obtained from the provider B before the previously set A was checked, it would call:

                 mgr.addProviderAtFront(B, m1);
        The GSSManager would then first check with B if m1 was needed. In case B did not provide support for m1, the GSSManager would continue on to check with A. If any mechanism m2 is needed where m2 is different from m1 then the GSSManager would skip B and check with A directly.

        Suppose at a later time the following call is made to the same GSSManager instance:

                 mgr.addProviderAtFront(B, null)
        then the previous setting with the pair (B, m1) is subsumed by this and should be removed. Effectively the list of preferences now becomes {(B, null), (A, null), ... //followed by the pre-configured list.

        Please note, however, that the following call:

                 mgr.addProviderAtFront(A, m3)
        does not subsume the previous setting of (A, null) and the list will effectively become {(A, m3), (B, null), (A, null), ...}
        参数：
        p - the provider instance that should be used whenever support is needed for mech.
        mech - the mechanism for which the provider is being set
        抛出：
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.FAILURE

      • addProviderAtEnd

        public abstract void addProviderAtEnd(Provider p,
                    Oid mech)
                               throws GSSException
        This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism. When a value of null is used instead of an Oid for the mechanism, the GSSManager must use the indicated provider for any mechanism.

        Calling this method repeatedly preserves the older settings but raises them above newer ones in preference thus forming an ordered list of providers and Oid pairs that grows at the bottom. Thus the older provider settings will be utilized first before this one is.

        If there are any previously existing preferences that conflict with the preference being set here, then the GSSManager should ignore this request.

        If the GSSManager implementation does not support an SPI with a pluggable provider architecture it should throw a GSSException with the status code GSSException.UNAVAILABLE to indicate that the operation is unavailable.

        Suppose an application desired that when a mechanism of Oid m1 is needed the system default providers always be checked first, and only when they do not support m1 should a provider A be checked. It would then make the call:

                 GSSManager mgr = GSSManager.getInstance();
         mgr.addProviderAtEnd(A, m1);
        Now, if it also desired that for all mechanisms the provider B be checked after all configured providers have been checked, it would then call:

                 mgr.addProviderAtEnd(B, null);
        Effectively the list of preferences now becomes {..., (A, m1), (B, null)}.

        Suppose at a later time the following call is made to the same GSSManager instance:

                 mgr.addProviderAtEnd(B, m2)
        then the previous setting with the pair (B, null) subsumes this and therefore this request should be ignored. The same would happen if a request is made for the already existing pairs of (A, m1) or (B, null).

        Please note, however, that the following call:

                 mgr.addProviderAtEnd(A, null)
        is not subsumed by the previous setting of (A, m1) and the list will effectively become {..., (A, m1), (B, null), (A, null)}
        参数：
        p - the provider instance that should be used whenever support is needed for mech.
        mech - the mechanism for which the provider is being set
        抛出：
        GSSException - containing the following major error codes: GSSException.UNAVAILABLE, GSSException.FAILURE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


GSSName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.ietf.jgss

Interface GSSName

  • public interface GSSName
    This interface encapsulates a single GSS-API principal entity. The application obtains an implementation of this interface through one of the createName methods that exist in the GSSManager class. Conceptually a GSSName contains many representations of the entity or many primitive name elements, one for each supported underlying mechanism. In GSS terminology, a GSSName that contains an element from just one mechanism is called a Mechanism Name (MN)

    Since different authentication mechanisms may employ different namespaces for identifying their principals, GSS-API's naming support is necessarily complex in multi-mechanism environments (or even in some single-mechanism environments where the underlying mechanism supports multiple namespaces). Different name formats and their definitions are identified with Oid's and some standard types are defind in this interface. The format of the names can be derived based on the unique Oid of its name type.

    Included below are code examples utilizing the GSSName interface. The code below creates a GSSName, converts it to an MN, performs a comparison, obtains a printable representation of the name, exports it to a byte array and then re-imports to obtain a new GSSName.

          GSSManager manager = GSSManager.getInstance();

      // create a host based service name
      GSSName name = manager.createName("service@host",
                   GSSName.NT_HOSTBASED_SERVICE);

      Oid krb5 = new Oid("1.2.840.113554.1.2.2");

      GSSName mechName = name.canonicalize(krb5);

      // the above two steps are equivalent to the following
      GSSName mechName = manager.createName("service@host",
                      GSSName.NT_HOSTBASED_SERVICE, krb5);

      // perform name comparison
      if (name.equals(mechName))
              print("Names are equals.");

      // obtain textual representation of name and its printable
      // name type
      print(mechName.toString() +
                      mechName.getStringNameType().toString());

      // export and re-import the name
      byte [] exportName = mechName.export();

      // create a new name object from the exported buffer
      GSSName newName = manager.createName(exportName,
                      GSSName.NT_EXPORT_NAME);
    从以下版本开始：
    1.4
    另请参见：
    export(),
equals(GSSName),
GSSManager.createName(String, Oid),
GSSManager.createName(String, Oid, Oid),
GSSManager.createName(byte[], Oid)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static Oid NT_ANONYMOUS
      Name type for representing an anonymous entity.
      static Oid NT_EXPORT_NAME
      Name type used to indicate an exported name produced by the export method.
      static Oid NT_HOSTBASED_SERVICE
      Oid indicating a host-based service name form.
      static Oid NT_MACHINE_UID_NAME
      Name type to indicate a numeric user identifier corresponding to a user on a local system.
      static Oid NT_STRING_UID_NAME
      Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.
      static Oid NT_USER_NAME
      Name type to indicate a named user on a local system.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      GSSName canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      boolean equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
      boolean equals(Object another)
      Compares this GSSName object to another Object that might be a GSSName.
      byte[] export()
      Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
      Oid getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      int hashCode()
      Returns a hashcode value for this GSSName.
      boolean isAnonymous()
      Tests if this name object represents an anonymous entity.
      boolean isMN()
      Tests if this name object represents a Mechanism Name (MN).
      String toString()
      Returns a textual representation of the GSSName object.

    • 字段详细信息

      • NT_HOSTBASED_SERVICE

        static final Oid NT_HOSTBASED_SERVICE
        Oid indicating a host-based service name form. It is used to represent services associated with host computers. This name form is constructed using two elements, "service" and "hostname", as follows: service@hostname.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1) service_name(4)
 }

      • NT_USER_NAME

        static final Oid NT_USER_NAME
        Name type to indicate a named user on a local system.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1) user_name(1)
 }

      • NT_MACHINE_UID_NAME

        static final Oid NT_MACHINE_UID_NAME
        Name type to indicate a numeric user identifier corresponding to a user on a local system. (e.g. Uid).

        It represents the following Oid value:
        { iso(1) member-body(2) United States(840) mit(113554) infosys(1) gssapi(2) generic(1) machine_uid_name(2) }

      • NT_STRING_UID_NAME

        static final Oid NT_STRING_UID_NAME
        Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.

         It represents the following Oid value:
{ iso(1) member-body(2) United
 States(840) mit(113554) infosys(1) gssapi(2) generic(1)
 string_uid_name(3) }

      • NT_ANONYMOUS

        static final Oid NT_ANONYMOUS
        Name type for representing an anonymous entity.

        It represents the following Oid value:
        { 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 3(gss-anonymous-name) }

      • NT_EXPORT_NAME

        static final Oid NT_EXPORT_NAME
        Name type used to indicate an exported name produced by the export method.

        It represents the following Oid value:
        { 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 4(gss-api-exported-name) }

    • 方法详细信息

      • equals

        boolean equals(GSSName another)
               throws GSSException
        Compares two GSSName objects to determine if they refer to the same entity.
        参数：
        another - the GSSName to compare this name with
        返回：
        true if the two names contain at least one primitive element in common. If either of the names represents an anonymous entity, the method will return false.
        抛出：
        GSSException - when the names cannot be compared, containing the following major error codes: GSSException.BAD_NAMETYPE, GSSException.FAILURE

      • equals

        boolean equals(Object another)
        Compares this GSSName object to another Object that might be a GSSName. The behaviour is exactly the same as in equals except that no GSSException is thrown; instead, false will be returned in the situation where an error occurs.
        重载：
        equals in class Object
        参数：
        another - the object to compare this name to
        返回：
        true if the object to compare to is also a GSSName and the two names refer to the same entity.
        另请参见：
        equals(GSSName)

      • hashCode

        int hashCode()
        Returns a hashcode value for this GSSName.
        重载：
        hashCode in class Object
        返回：
        a hashCode value
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • canonicalize

        GSSName canonicalize(Oid mech)
                     throws GSSException
        Creates a name that is canonicalized for some mechanism.
        参数：
        mech - the oid for the mechanism for which the canonical form of the name is requested.
        返回：
        a GSSName that contains just one primitive element representing this name in a canonicalized form for the desired mechanism.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.BAD_NAME, GSSException.FAILURE

      • export

        byte[] export()
              throws GSSException
        Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions. If the name is not an MN, implementations may throw a GSSException with the NAME_NOT_MN status code. If an implementation chooses not to throw an exception, it should use some system specific default mechanism to canonicalize the name and then export it. Structurally, an exported name object consists of a header containing an OID identifying the mechanism that authenticated the name, and a trailer containing the name itself, where the syntax of the trailer is defined by the individual mechanism specification. The format of the header of the output buffer is specified in RFC 2743.

        The exported name is useful when used in large access control lists where the overhead of creating a GSSName object on each name and invoking the equals method on each name from the ACL may be prohibitive.

        Exported names may be re-imported by using the byte array factory method GSSManager.createName and specifying the NT_EXPORT_NAME as the name type object identifier. The resulting GSSName name will also be a MN.

        返回：
        a byte[] containing the exported name. RFC 2743 defines the "Mechanism-Independent Exported Name Object Format" for these bytes.
        抛出：
        GSSException - containing the following major error codes: GSSException.BAD_NAME, GSSException.BAD_NAMETYPE, GSSException.FAILURE

      • toString

        String toString()
        Returns a textual representation of the GSSName object. To retrieve the printed name format, which determines the syntax of the returned string, use the getStringNameType method.
        重载：
        toString in class Object
        返回：
        a String representing this name in printable form.

      • getStringNameType

        Oid getStringNameType()
                      throws GSSException
        Returns the name type of the printable representation of this name that can be obtained from the toString method.
        返回：
        an Oid representing the namespace of the name returned from the toString method.
        抛出：
        GSSException - containing the following major error codes: GSSException.FAILURE

      • isAnonymous

        boolean isAnonymous()
        Tests if this name object represents an anonymous entity.
        返回：
        true if this is an anonymous name, false otherwise.

      • isMN

        boolean isMN()
        Tests if this name object represents a Mechanism Name (MN). An MN is a GSSName the contains exactly one mechanism's primitive name element.
        返回：
        true if this is an MN, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f"=o yyo.. .../e/g//hOeo.gf


MessageProp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.ietf.jgss

类 MessageProp

  • java.lang.Object
    • org.ietf.jgss.MessageProp

  • public class MessageProp
extends Object
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.

    When used with the GSSContext interface's wrap and getMIC methods, an instance of this class is used to indicate the desired Quality-of-Protection (QOP) and to request if confidentiality services are to be applied to caller supplied data (wrap only). To request default QOP, the value of 0 should be used for QOP.

    When used with the unwrap and verifyMIC methods of the GSSContext interface, an instance of this class will be used to indicate the applied QOP and confidentiality services over the supplied message. In the case of verifyMIC, the confidentiality state will always be false. Upon return from these methods, this object will also contain any supplementary status values applicable to the processed token. The supplementary status values can indicate old tokens, out of sequence tokens, gap tokens or duplicate tokens.

    从以下版本开始：
    1.4
    另请参见：
    GSSContext.wrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.unwrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.getMIC(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.verifyMIC(byte[], int, int, byte[], int, int, org.ietf.jgss.MessageProp)

    • 构造方法摘要

      Constructors
      构造方法与描述
      MessageProp(boolean privState)
      Constructor which sets the desired privacy state.
      MessageProp(int qop, boolean privState)
      Constructor which sets the values for the qop and privacy state.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getMinorStatus()
      Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.
      String getMinorString()
      Retrieves a string explaining the minor status code.
      boolean getPrivacy()
      Retrieves the privacy state.
      int getQOP()
      Retrieves the QOP value.
      boolean isDuplicateToken()
      Tests if this is a duplicate of an earlier token.
      boolean isGapToken()
      Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
      boolean isOldToken()
      Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
      boolean isUnseqToken()
      Tests if a later token had already been processed.
      void setPrivacy(boolean privState)
      Sets the privacy state.
      void setQOP(int qop)
      Sets the QOP value.
      void setSupplementaryStates(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString)
      This method sets the state for the supplementary information flags and the minor status in MessageProp.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MessageProp

        public MessageProp(boolean privState)
        Constructor which sets the desired privacy state. The QOP value used is 0.
        参数：
        privState - the privacy (i.e. confidentiality) state

      • MessageProp

        public MessageProp(int qop,
           boolean privState)
        Constructor which sets the values for the qop and privacy state.
        参数：
        qop - the QOP value
        privState - the privacy (i.e. confidentiality) state

    • 方法详细信息

      • getQOP

        public int getQOP()
        Retrieves the QOP value.
        返回：
        an int representing the QOP value
        另请参见：
        setQOP(int)

      • getPrivacy

        public boolean getPrivacy()
        Retrieves the privacy state.
        返回：
        true if the privacy (i.e., confidentiality) state is true, false otherwise.
        另请参见：
        setPrivacy(boolean)

      • setQOP

        public void setQOP(int qop)
        Sets the QOP value.
        参数：
        qop - the int value to set the QOP to
        另请参见：
        getQOP()

      • setPrivacy

        public void setPrivacy(boolean privState)
        Sets the privacy state.
        参数：
        privState - true is the privacy (i.e., confidentiality) state is true, false otherwise.
        另请参见：
        getPrivacy()

      • isDuplicateToken

        public boolean isDuplicateToken()
        Tests if this is a duplicate of an earlier token.
        返回：
        true if this is a duplicate, false otherwise.

      • isOldToken

        public boolean isOldToken()
        Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
        返回：
        true if the token's validity period has expired, false otherwise.

      • isUnseqToken

        public boolean isUnseqToken()
        Tests if a later token had already been processed.
        返回：
        true if a later token had already been processed, false otherwise.

      • isGapToken

        public boolean isGapToken()
        Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
        返回：
        true if an expected per-message token was not received, false otherwise.

      • getMinorStatus

        public int getMinorStatus()
        Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.
        返回：
        the int minor status

      • getMinorString

        public String getMinorString()
        Retrieves a string explaining the minor status code.
        返回：
        a String corresponding to the minor status code. null will be returned when no minor status code has been set.

      • setSupplementaryStates

        public void setSupplementaryStates(boolean duplicate,
                          boolean old,
                          boolean unseq,
                          boolean gap,
                          int minorStatus,
                          String minorString)
        This method sets the state for the supplementary information flags and the minor status in MessageProp. It is not used by the application but by the GSS implementation to return this information to the caller of a per-message context method.
        参数：
        duplicate - true if the token was a duplicate of an earlier token, false otherwise
        old - true if the token's validity period has expired, false otherwise
        unseq - true if a later token has already been processed, false otherwise
        gap - true if one or more predecessor tokens have not yet been successfully processed, false otherwise
        minorStatus - the int minor status code for the per-message operation
        minorString - the textual representation of the minorStatus value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.=FSoe"de"E>>"EEAn//SGBEoieS//cNoBB<._t>a


Oid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.ietf.jgss

类 Oid

  • java.lang.Object
    • org.ietf.jgss.Oid

  • public class Oid
extends Object
    This class represents Universal Object Identifiers (Oids) and their associated operations.

    Oids are hierarchically globally-interpretable identifiers used within the GSS-API framework to identify mechanisms and name formats.

    The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. For example the Oid representation of Kerberos V5 mechanism is "1.2.840.113554.1.2.2"

    The GSSName name class contains public static Oid objects representing the standard name types defined in GSS-API.

    从以下版本开始：
    1.4

    • 构造方法摘要

      Constructors
      构造方法与描述
      Oid(byte[] data)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(InputStream derOid)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(String strOid)
      Constructs an Oid object from a string representation of its integer components.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean containedIn(Oid[] oids)
      A utility method to test if this Oid value is contained within the supplied Oid array.
      boolean equals(Object other)
      Tests if two Oid objects represent the same Object identifier value.
      byte[] getDER()
      Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
      int hashCode()
      Returns a hashcode value for this Oid.
      String toString()
      Returns a string representation of the oid's integer components in dot separated notation.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Oid

        public Oid(String strOid)
    throws GSSException
        Constructs an Oid object from a string representation of its integer components.
        参数：
        strOid - the dot separated string representation of the oid. For instance, "1.2.840.113554.1.2.2".
        抛出：
        GSSException - may be thrown when the string is incorrectly formatted

      • Oid

        public Oid(InputStream derOid)
    throws GSSException
        Creates an Oid object from its ASN.1 DER encoding. This refers to the full encoding including tag and length. The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. This method is identical in functionality to its byte array counterpart.
        参数：
        derOid - stream containing the DER encoded oid
        抛出：
        GSSException - may be thrown when the DER encoding does not follow the prescribed format.

      • Oid

        public Oid(byte[] data)
    throws GSSException
        Creates an Oid object from its ASN.1 DER encoding. This refers to the full encoding including tag and length. The structure and encoding of Oids is defined in ISOIEC-8824 and ISOIEC-8825. This method is identical in functionality to its InputStream conterpart.
        参数：
        data - byte array containing the DER encoded oid
        抛出：
        GSSException - may be thrown when the DER encoding does not follow the prescribed format.

    • 方法详细信息

      • toString

        public String toString()
        Returns a string representation of the oid's integer components in dot separated notation.
        重载：
        toString in class Object
        返回：
        string representation in the following format: "1.2.3.4.5"

      • equals

        public boolean equals(Object other)
        Tests if two Oid objects represent the same Object identifier value.
        重载：
        equals in class Object
        参数：
        other - the Oid object that has to be compared to this one
        返回：
        true if the two Oid objects represent the same value, false otherwise.
        另请参见：
        Object.hashCode(), HashMap

      • getDER

        public byte[] getDER()
              throws GSSException
        Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
        返回：
        byte array containing the DER encoding of this oid object.
        抛出：
        GSSException - may be thrown when the oid can't be encoded

      • containedIn

        public boolean containedIn(Oid[] oids)
        A utility method to test if this Oid value is contained within the supplied Oid array.
        参数：
        oids - the array of Oid's to search
        返回：
        true if the array contains this Oid value, false otherwise

      • hashCode

        public int hashCode()
        Returns a hashcode value for this Oid.
        重载：
        hashCode in class Object
        返回：
        a hashCode value
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nStefraoratttatttokk="sisaatsi.nl gg=ji "i


org.ietf.jgss

Interfaces

  • GSSContext
  • GSSCredential
  • GSSName

Classes

  • ChannelBinding
  • GSSManager
  • MessageProp
  • Oid

Exceptions

  • GSSException
l


org.ietf.jgss

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.ietf.jgss

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

请参见： 描述

  • 接口摘要
    接口 描述
    GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context.
    GSSCredential
    This interface encapsulates the GSS-API credentials for an entity.
    GSSName
    This interface encapsulates a single GSS-API principal entity.
  • Class Summary
    类 描述
    ChannelBinding
    This class encapsulates the concept of caller-provided channel binding information.
    GSSManager
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.
    MessageProp
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.
    Oid
    This class represents Universal Object Identifiers (Oids) and their associated operations.
  • Exception Summary
    Exception 描述
    GSSException
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.

软件包 org.ietf.jgss Description

This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API. The security mechanisms that an application can chose to use are identified with unique object identifiers. One example of such a mechanism is the Kerberos v5 GSS-API mechanism (object identifier 1.2.840.113554.1.2.2). This mechanism is available through the default instance of the GSSManager class.

The GSS-API is defined in a language independent way in RFC 2743. The Java language bindings are defined in RFC 2853

An application starts out by instantiating a GSSManager which then serves as a factory for a security context. An application can use specific principal names and credentials that are also created using the GSSManager; or it can instantiate a context with system defaults. It then goes through a context establishment loop. Once a context is established with the peer, authentication is complete. Data protection such as integrity and confidentiality can then be obtained from this context.

The GSS-API does not perform any communication with the peer. It merely produces tokens that the application must somehow transport to the other end.

Credential Acquisition

The GSS-API itself does not dictate how an underlying mechanism obtains the credentials that are needed for authentication. It is assumed that prior to calling the GSS-API, these credentials are obtained and stored in a location that the mechanism provider is aware of. However, the default model in the Java platform will be that mechanism providers must obtain credentials only from the private or public credential sets associated with the Subject in the current access control context. The Kerberos v5 mechanism will search for the required INITIATE and ACCEPT credentials (KerberosTicket and KerberosKey) in the private credential set where as some other mechanism might look in the public set or in both. If the desired credential is not present in the appropriate sets of the current Subject, the GSS-API call must fail.

This model has the advantage that credential management is simple and predictable from the applications point of view. An application, given the right permissions, can purge the credentials in the Subject or renew them using standard Java API's. If it purged the credentials, it would be sure that the JGSS mechanism would fail, or if it renewed a time based credential it would be sure that a JGSS mechanism would succeed.

This model does require that a JAAS login be performed in order to authenticate and populate a Subject that the JGSS mechnanism can later utilize. However, applications have the ability to relax this restiction by means of a system property: javax.security.auth.useSubjectCredsOnly. By default this system property will be assumed to be true (even when it is unset) indicating that providers must only use the credentials that are present in the current Subject. However, if this property is explicitly set to false by the application, then it indicates that the provider is free to use any credentials cache of its choice. Such a credential cache might be a disk cache, an in-memory cache, or even just the current Subject itself.

Related Documentation

For an online tutorial on using Java GSS-API, please see Introduction to JAAS and Java GSS-API.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cH<>c>>


org.ietf.jgss Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.ietf.jgss

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.ietf.jgss.ChannelBinding
    • org.ietf.jgss.GSSManager
    • org.ietf.jgss.MessageProp
    • org.ietf.jgss.Oid
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.ietf.jgss.GSSException

Interface Hierarchy

  • java.lang.Cloneable
    • org.ietf.jgss.GSSCredential
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eacf lpeeexsttathhre


Uses of Package org.ietf.jgss

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.ietf.jgss

  • Packages that use org.ietf.jgss
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.
  • Classes in org.ietf.jgss used by org.ietf.jgss
    类与描述
    ChannelBinding
    This class encapsulates the concept of caller-provided channel binding information.
    GSSContext
    This interface encapsulates the GSS-API security context and provides the security services that are available over the context.
    GSSCredential
    This interface encapsulates the GSS-API credentials for an entity.
    GSSException
    This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.
    GSSManager
    This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.
    GSSName
    This interface encapsulates a single GSS-API principal entity.
    MessageProp
    This is a utility class used within the per-message GSSContext methods to convey per-message properties.
    Oid
    This class represents Universal Object Identifiers (Oids) and their associated operations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/<3tt .rrreaoo蝖 otCo


Uses of Class org.ietf.jgss.ChannelBinding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.ietf.jgss.ChannelBinding

  • Packages that use ChannelBinding
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of ChannelBinding in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type ChannelBinding
      修饰符与类型 方法与描述
      void GSSContext.setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

he<"gatss


Uses of Class org.ietf.jgss.GSSException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.ietf.jgss.GSSException

  • Packages that use GSSException
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSException in org.ietf.jgss

      Methods in org.ietf.jgss that throw GSSException
      修饰符与类型 方法与描述
      byte[] GSSContext.acceptSecContext(byte[] inToken, int offset, int len)
      Called by the context acceptor upon receiving a token from the peer.
      void GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream)
      Called by the context acceptor to process a token from the peer using streams.
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract void GSSManager.addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void GSSManager.addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      abstract GSSContext GSSManager.createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential GSSManager.createCredential(int usage)
      Factory method for acquiring default credentials.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      void GSSContext.dispose()
      Releases any system resources and cryptographic information stored in the context object and invalidates the context.
      void GSSCredential.dispose()
      Releases any sensitive information that the GSSCredential object may be containing.
      boolean GSSName.equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
      byte[] GSSContext.export()
      Exports this context so that another process may import it..
      byte[] GSSName.export()
      Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
      GSSCredential GSSContext.getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      byte[] Oid.getDER()
      Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.
      Oid GSSContext.getMech()
      Determines what mechanism is being used for this context.
      Oid[] GSSCredential.getMechs()
      Returns a list of mechanisms supported by this credential.
      byte[] GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      GSSName GSSCredential.getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      int GSSCredential.getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int GSSCredential.getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int GSSCredential.getRemainingLifetime()
      Returns the remaining lifetime in seconds for a credential.
      GSSName GSSContext.getSrcName()
      Returns the name of the context initiator.
      Oid GSSName.getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      GSSName GSSContext.getTargName()
      Returns the name of the context acceptor.
      int GSSCredential.getUsage()
      Returns the credential usage mode.
      int GSSCredential.getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
      int GSSContext.getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize)
      Used to determine limits on the size of the message that can be passed to wrap.
      byte[] GSSContext.initSecContext(byte[] inputBuf, int offset, int len)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
      int GSSContext.initSecContext(InputStream inStream, OutputStream outStream)
      Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
      boolean GSSContext.isInitiator()
      Determines if this is the context initiator.
      boolean GSSContext.isTransferable()
      Determines if the context is transferable to other processes through the use of the export method.
      void GSSContext.requestAnonymity(boolean state)
      Requests that the initiator's identity not be disclosed to the acceptor.
      void GSSContext.requestConf(boolean state)
      Requests that data confidentiality be enabled for the wrap method.
      void GSSContext.requestCredDeleg(boolean state)
      Requests that the initiator's credentials be delegated to the acceptor during context establishment.
      void GSSContext.requestInteg(boolean state)
      Requests that data integrity be enabled for the wrap and getMICmethods.
      void GSSContext.requestLifetime(int lifetime)
      Requests a lifetime in seconds for the context.
      void GSSContext.requestMutualAuth(boolean state)
      Requests that mutual authentication be done during context establishment.
      void GSSContext.requestReplayDet(boolean state)
      Requests that replay detection be enabled for the per-message security services after context establishment.
      void GSSContext.requestSequenceDet(boolean state)
      Requests that sequence checking be enabled for the per-message security services after context establishment.
      void GSSContext.setChannelBinding(ChannelBinding cb)
      Sets the channel bindings to be used during context establishment.
      byte[] GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.
      Constructors in org.ietf.jgss that throw GSSException
      构造方法与描述
      Oid(byte[] data)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(InputStream derOid)
      Creates an Oid object from its ASN.1 DER encoding.
      Oid(String strOid)
      Constructs an Oid object from a string representation of its integer components.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.ietf.jgss.GSSManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.ietf.jgss.GSSManager

  • Packages that use GSSManager
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSManager in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSManager
      修饰符与类型 方法与描述
      static GSSManager GSSManager.getInstance()
      Returns the default GSSManager implementation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.///


Uses of Class org.ietf.jgss.MessageProp

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.ietf.jgss.MessageProp

  • Packages that use MessageProp
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of MessageProp in org.ietf.jgss

      Methods in org.ietf.jgss with parameters of type MessageProp
      修饰符与类型 方法与描述
      byte[] GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp)
      Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.
      void GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.
      byte[] GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Used to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Uses streams to process tokens generated by the wrap method on the other side of the context.
      void GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp)
      Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
      void GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp)
      Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
      byte[] GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp)
      Applies per-message security services over the established security context.
      void GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp)
      Applies per-message security services over the established security context using streams.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"n. f n.oa t.i


Uses of Class org.ietf.jgss.Oid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.ietf.jgss.Oid

  • Packages that use Oid
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of Oid in org.ietf.jgss

      Fields in org.ietf.jgss declared as Oid
      修饰符与类型 字段与描述
      static Oid GSSName.NT_ANONYMOUS
      Name type for representing an anonymous entity.
      static Oid GSSName.NT_EXPORT_NAME
      Name type used to indicate an exported name produced by the export method.
      static Oid GSSName.NT_HOSTBASED_SERVICE
      Oid indicating a host-based service name form.
      static Oid GSSName.NT_MACHINE_UID_NAME
      Name type to indicate a numeric user identifier corresponding to a user on a local system.
      static Oid GSSName.NT_STRING_UID_NAME
      Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.
      static Oid GSSName.NT_USER_NAME
      Name type to indicate a named user on a local system.
      Methods in org.ietf.jgss that return Oid
      修饰符与类型 方法与描述
      Oid GSSContext.getMech()
      Determines what mechanism is being used for this context.
      abstract Oid[] GSSManager.getMechs()
      Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.
      Oid[] GSSCredential.getMechs()
      Returns a list of mechanisms supported by this credential.
      abstract Oid[] GSSManager.getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      Oid GSSName.getStringNameType()
      Returns the name type of the printable representation of this name that can be obtained from the toString method.
      Methods in org.ietf.jgss with parameters of type Oid
      修饰符与类型 方法与描述
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract void GSSManager.addProviderAtEnd(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
      abstract void GSSManager.addProviderAtFront(Provider p, Oid mech)
      This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      boolean Oid.containedIn(Oid[] oids)
      A utility method to test if this Oid value is contained within the supplied Oid array.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract Oid[] GSSManager.getMechsForName(Oid nameType)
      Returns a list of mechanisms that support the indicated name type.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      abstract Oid[] GSSManager.getNamesForMech(Oid mech)
      Returns then name types supported by the indicated mechanism.
      int GSSCredential.getRemainingAcceptLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.
      int GSSCredential.getRemainingInitLifetime(Oid mech)
      Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.
      int GSSCredential.getUsage(Oid mech)
      Returns the credential usage mode for a specific mechanism.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

trno/tls� �


Uses of Interface org.ietf.jgss.GSSContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.ietf.jgss.GSSContext

  • Packages that use GSSContext
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSContext in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSContext
      修饰符与类型 方法与描述
      abstract GSSContext GSSManager.createContext(byte[] interProcessToken)
      Factory method for creating a previously exported context.
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s< / a <


Uses of Interface org.ietf.jgss.GSSCredential

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.ietf.jgss.GSSCredential

  • Packages that use GSSCredential
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSCredential in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSCredential
      修饰符与类型 方法与描述
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      abstract GSSCredential GSSManager.createCredential(int usage)
      Factory method for acquiring default credentials.
      GSSCredential GSSContext.getDelegCred()
      Obtains the credentials delegated by the context initiator to the context acceptor.
      Methods in org.ietf.jgss with parameters of type GSSCredential
      修饰符与类型 方法与描述
      abstract GSSContext GSSManager.createContext(GSSCredential myCred)
      Factory method for creating a context on the acceptor' side.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rlaiea e辤<瞔ats� ea


Uses of Interface org.ietf.jgss.GSSName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.ietf.jgss.GSSName

  • Packages that use GSSName
    软件包 描述
    org.ietf.jgss
    This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.

    • Uses of GSSName in org.ietf.jgss

      Methods in org.ietf.jgss that return GSSName
      修饰符与类型 方法与描述
      GSSName GSSName.canonicalize(Oid mech)
      Creates a name that is canonicalized for some mechanism.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(byte[] name, Oid nameType, Oid mech)
      Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType)
      Factory method to convert a string name from the specified namespace to a GSSName object.
      abstract GSSName GSSManager.createName(String nameStr, Oid nameType, Oid mech)
      Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
      GSSName GSSCredential.getName()
      Retrieves the name of the entity that the credential asserts.
      GSSName GSSCredential.getName(Oid mech)
      Retrieves a Mechanism Name of the entity that the credential asserts.
      GSSName GSSContext.getSrcName()
      Returns the name of the context initiator.
      GSSName GSSContext.getTargName()
      Returns the name of the context acceptor.
      Methods in org.ietf.jgss with parameters of type GSSName
      修饰符与类型 方法与描述
      void GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage)
      Adds a mechanism specific credential-element to an existing credential.
      abstract GSSContext GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime)
      Factory method for creating a context on the initiator's side.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage)
      Factory method for acquiring credentials over a set of mechanisms.
      abstract GSSCredential GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage)
      Factory method for acquiring a single mechanism credential.
      boolean GSSName.equals(GSSName another)
      Compares two GSSName objects to determine if they refer to the same entity.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tksloon -d m""c=


ACTIVITY_COMPLETED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 ACTIVITY_COMPLETED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
  • 所有已实现的接口：
    Serializable

    public final class ACTIVITY_COMPLETED
extends SystemException
    The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed. It indicates that the Activity context in which the method call was made has been completed due to a timeout of either the Activity itself or a transaction that encompasses the Activity, or that the Activity completed in a manner other than that originally requested.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      ACTIVITY_COMPLETED()
      Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
      ACTIVITY_COMPLETED(String detailMessage)
      Constructs an ACTIVITY_COMPLETED exception with the specified message.
      ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED()
        Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(String detailMessage)
        Constructs an ACTIVITY_COMPLETED exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(int minorCode,
                  CompletionStatus completionStatus)
        Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • ACTIVITY_COMPLETED

        public ACTIVITY_COMPLETED(String detailMessage,
                  int minorCode,
                  CompletionStatus completionStatus)
        Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method


ACTIVITY_REQUIRED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 ACTIVITY_REQUIRED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_REQUIRED
  • 所有已实现的接口：
    Serializable

    public final class ACTIVITY_REQUIRED
extends SystemException
    The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required. It indicates that an Activity context was necessary to perform the invoked operation, but one was not found associated with the calling thread.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      ACTIVITY_REQUIRED()
      Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
      ACTIVITY_REQUIRED(String detailMessage)
      Constructs an ACTIVITY_REQUIRED exception with the specified message.
      ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED()
        Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(String detailMessage)
        Constructs an ACTIVITY_REQUIRED exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(int minorCode,
                 CompletionStatus completionStatus)
        Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • ACTIVITY_REQUIRED

        public ACTIVITY_REQUIRED(String detailMessage,
                 int minorCode,
                 CompletionStatus completionStatus)
        Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/d.ee.er=..//.g.�/.=///ggrlp.癶y�.1>�


Any

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 Any

  • java.lang.Object
    • org.omg.CORBA.Any
  • 所有已实现的接口：
    Serializable, IDLEntity

    public abstract class Any
extends Object
implements IDLEntity
    Serves as a container for any data that can be described in IDL or for any IDL primitive type. An Any object is used as a component of a NamedValue object, which provides information about arguments or return values in requests, and which is used to define name/value pairs in Context objects.

    An Any object consists of two parts:

    1. a data value
    2. a TypeCode object describing the type of the data value contained in the Any object. For example, a TypeCode object for an array contains a field for the length of the array and a field for the type of elements in the array. (Note that in this case, the second field of the TypeCode object is itself a TypeCode object.)

    A large part of the Any class consists of pairs of methods for inserting values into and extracting values from an Any object.

    For a given primitive type X, these methods are:

    void insert_X(X x)
    This method allows the insertion of an instance x of primitive type X into the value field of the Any object. Note that the method insert_X also resets the Any object's type field if necessary.
    X extract_X()
    This method allows the extraction of an instance of type X from the Any object.

    This method throws the exception BAD_OPERATION under two conditions:

    1. the type of the element contained in the Any object is not X
    2. the method extract_X is called before the value field of the Any object has been set

    There are distinct method pairs for each primitive IDL data type (insert_long and extract_long, insert_string and extract_string, and so on).

    The class Any also has methods for getting and setting the type code, for testing two Any objects for equality, and for reading an Any object from a stream or writing it to a stream.

    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      Any()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract InputStream create_input_stream()
      Creates an input stream from which this Any object's value can be unmarshalled.
      abstract OutputStream create_output_stream()
      Creates an output stream into which this Any object's value can be marshalled.
      abstract boolean equal(Any a)
      Checks for equality between this Any object and the given Any object.
      abstract Any extract_any()
      Extracts the Any object in this Any object's value field.
      abstract boolean extract_boolean()
      Extracts the boolean in this Any object's value field.
      abstract char extract_char()
      Extracts the char in this Any object's value field.
      abstract double extract_double()
      Extracts the double in this Any object's value field.
      BigDecimal extract_fixed()
      Extracts the java.math.BigDecimal object in this Any object's value field.
      abstract float extract_float()
      Extracts the float in this Any object's value field.
      abstract int extract_long()
      Extracts the int in this Any object's value field.
      abstract long extract_longlong()
      Extracts the long in this Any object's value field.
      abstract Object extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      abstract byte extract_octet()
      Extracts the byte in this Any object's value field.
      Principal extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract short extract_short()
      Extracts the short in this Any object's value field.
      Streamable extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      abstract String extract_string()
      Extracts the String object in this Any object's value field.
      abstract TypeCode extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract int extract_ulong()
      Extracts the int in this Any object's value field.
      abstract long extract_ulonglong()
      Extracts the long in this Any object's value field.
      abstract short extract_ushort()
      Extracts the short in this Any object's value field.
      abstract Serializable extract_Value()
      Extracts the java.io.Serializable object in this Any object's value field.
      abstract char extract_wchar()
      Extracts the char in this Any object's value field.
      abstract String extract_wstring()
      Extracts the String object in this Any object's value field.
      abstract void insert_any(Any a)
      Inserts the given Any object into this Any object's value field.
      abstract void insert_boolean(boolean b)
      Inserts the given boolean into this Any object's value field.
      abstract void insert_char(char c)
      Inserts the given char into this Any object's value field.
      abstract void insert_double(double d)
      Inserts the given double into this Any object's value field.
      void insert_fixed(BigDecimal value)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void insert_float(float f)
      Inserts the given float into this Any object's value field.
      abstract void insert_long(int l)
      Inserts the given int into this Any object's value field.
      abstract void insert_longlong(long l)
      Inserts the given long into this Any object's value field.
      abstract void insert_Object(Object o)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void insert_octet(byte b)
      Inserts the given byte into this Any object's value field.
      void insert_Principal(Principal p)
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void insert_short(short s)
      Inserts the given short into this Any object's value field.
      void insert_Streamable(Streamable s)
      Inserts the given Streamable object into this Any object's value field.
      abstract void insert_string(String s)
      Inserts the given String object into this Any object's value field.
      abstract void insert_TypeCode(TypeCode t)
      Inserts the given TypeCode object into this Any object's value field.
      abstract void insert_ulong(int l)
      Inserts the given int into this Any object's value field.
      abstract void insert_ulonglong(long l)
      Inserts the given long into this Any object's value field.
      abstract void insert_ushort(short s)
      Inserts the given short into this Any object's value field.
      abstract void insert_Value(Serializable v)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void insert_wchar(char c)
      Inserts the given char into this Any object's value field.
      abstract void insert_wstring(String s)
      Inserts the given String object into this Any object's value field.
      abstract void read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      abstract TypeCode type()
      Returns type information for the element contained in this Any object.
      abstract void type(TypeCode t)
      Sets this Any object's type field to the given TypeCode object and clears its value.
      abstract void write_value(OutputStream os)
      Writes out the value of this Any object to the given output stream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Any

        public Any()

    • 方法详细信息

      • equal

        public abstract boolean equal(Any a)
        Checks for equality between this Any object and the given Any object. Two Any objects are equal if both their values and type codes are equal.
        参数：
        a - the Any object to test for equality
        返回：
        true if the Any objects are equal; false otherwise
        另请参见：
        CORBA package comments for unimplemented features

      • type

        public abstract TypeCode type()
        Returns type information for the element contained in this Any object.
        返回：
        the TypeCode object containing type information about the value contained in this Any object

      • type

        public abstract void type(TypeCode t)
        Sets this Any object's type field to the given TypeCode object and clears its value.

        Note that using this method to set the type code wipes out the value if there is one. The method is provided primarily so that the type may be set properly for IDL out parameters. Generally, setting the type is done by the insert_X methods, which will set the type to X if it is not already set to X.

        参数：
        t - the TypeCode object giving information for the value in this Any object

      • read_value

        public abstract void read_value(InputStream is,
              TypeCode t)
                         throws MARSHAL
        Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
        参数：
        is - the org.omg.CORBA.portable.InputStream object from which to read the value contained in this Any object
        t - a TypeCode object containing type information about the value to be read
        抛出：
        MARSHAL - when the given TypeCode object is not consistent with the value that was contained in the input stream

      • write_value

        public abstract void write_value(OutputStream os)
        Writes out the value of this Any object to the given output stream. If both typecode and value need to be written, use create_output_stream() to create an OutputStream, then use write_any on the OutputStream.

        If this method is called on an Any object that has not had a value inserted into its value field, it will throw the exception java.lang.NullPointerException.

        参数：
        os - the org.omg.CORBA.portable.OutputStream object into which to marshal the value of this Any object

      • create_output_stream

        public abstract OutputStream create_output_stream()
        Creates an output stream into which this Any object's value can be marshalled.
        返回：
        the newly-created OutputStream

      • create_input_stream

        public abstract InputStream create_input_stream()
        Creates an input stream from which this Any object's value can be unmarshalled.
        返回：
        the newly-created InputStream

      • extract_short

        public abstract short extract_short()
                             throws BAD_OPERATION
        Extracts the short in this Any object's value field.
        返回：
        the short stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a short or the value field has not yet been set

      • insert_short

        public abstract void insert_short(short s)
        Inserts the given short into this Any object's value field.
        参数：
        s - the short to insert into this Any object

      • extract_long

        public abstract int extract_long()
                          throws BAD_OPERATION
        Extracts the int in this Any object's value field.
        返回：
        the int stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than an int or the value field has not yet been set

      • insert_long

        public abstract void insert_long(int l)
        Inserts the given int into this Any object's value field.
        参数：
        l - the int to insert into this Any object

      • extract_longlong

        public abstract long extract_longlong()
                               throws BAD_OPERATION
        Extracts the long in this Any object's value field.
        返回：
        the long stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a long or the value field has not yet been set

      • insert_longlong

        public abstract void insert_longlong(long l)
        Inserts the given long into this Any object's value field.
        参数：
        l - the long to insert into this Any object

      • extract_ushort

        public abstract short extract_ushort()
                              throws BAD_OPERATION
        Extracts the short in this Any object's value field.
        返回：
        the short stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a short or the value field has not yet been set

      • insert_ushort

        public abstract void insert_ushort(short s)
        Inserts the given short into this Any object's value field.
        参数：
        s - the short to insert into this Any object

      • extract_ulong

        public abstract int extract_ulong()
                           throws BAD_OPERATION
        Extracts the int in this Any object's value field.
        返回：
        the int stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than an int or the value field has not yet been set

      • insert_ulong

        public abstract void insert_ulong(int l)
        Inserts the given int into this Any object's value field.
        参数：
        l - the int to insert into this Any object

      • extract_ulonglong

        public abstract long extract_ulonglong()
                                throws BAD_OPERATION
        Extracts the long in this Any object's value field.
        返回：
        the long stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a long or the value field has not yet been set

      • insert_ulonglong

        public abstract void insert_ulonglong(long l)
        Inserts the given long into this Any object's value field.
        参数：
        l - the long to insert into this Any object

      • extract_float

        public abstract float extract_float()
                             throws BAD_OPERATION
        Extracts the float in this Any object's value field.
        返回：
        the float stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a float or the value field has not yet been set

      • insert_float

        public abstract void insert_float(float f)
        Inserts the given float into this Any object's value field.
        参数：
        f - the float to insert into this Any object

      • extract_double

        public abstract double extract_double()
                               throws BAD_OPERATION
        Extracts the double in this Any object's value field.
        返回：
        the double stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a double or the value field has not yet been set

      • insert_double

        public abstract void insert_double(double d)
        Inserts the given double into this Any object's value field.
        参数：
        d - the double to insert into this Any object

      • extract_boolean

        public abstract boolean extract_boolean()
                                 throws BAD_OPERATION
        Extracts the boolean in this Any object's value field.
        返回：
        the boolean stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a boolean or the value field has not yet been set

      • insert_boolean

        public abstract void insert_boolean(boolean b)
        Inserts the given boolean into this Any object's value field.
        参数：
        b - the boolean to insert into this Any object

      • extract_char

        public abstract char extract_char()
                           throws BAD_OPERATION
        Extracts the char in this Any object's value field.
        返回：
        the char stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a char or the value field has not yet been set

      • insert_char

        public abstract void insert_char(char c)
                          throws DATA_CONVERSION
        Inserts the given char into this Any object's value field.
        参数：
        c - the char to insert into this Any object
        抛出：
        DATA_CONVERSION - if there is a data conversion error

      • extract_wchar

        public abstract char extract_wchar()
                            throws BAD_OPERATION
        Extracts the char in this Any object's value field.
        返回：
        the char stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a char or the value field has not yet been set

      • insert_wchar

        public abstract void insert_wchar(char c)
        Inserts the given char into this Any object's value field.
        参数：
        c - the char to insert into this Any object

      • extract_octet

        public abstract byte extract_octet()
                            throws BAD_OPERATION
        Extracts the byte in this Any object's value field.
        返回：
        the byte stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a byte or the value field has not yet been set

      • insert_octet

        public abstract void insert_octet(byte b)
        Inserts the given byte into this Any object's value field.
        参数：
        b - the byte to insert into this Any object

      • extract_any

        public abstract Any extract_any()
                         throws BAD_OPERATION
        Extracts the Any object in this Any object's value field.
        返回：
        the Any object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than an Any object or the value field has not yet been set

      • insert_any

        public abstract void insert_any(Any a)
        Inserts the given Any object into this Any object's value field.
        参数：
        a - the Any object to insert into this Any object

      • extract_Object

        public abstract Object extract_Object()
                               throws BAD_OPERATION
        Extracts the org.omg.CORBA.Object in this Any object's value field.
        返回：
        the org.omg.CORBA.Object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than an org.omg.CORBA.Object or the value field has not yet been set

      • insert_Object

        public abstract void insert_Object(Object o)
        Inserts the given org.omg.CORBA.Object object into this Any object's value field.
        参数：
        o - the org.omg.CORBA.Object object to insert into this Any object

      • extract_Value

        public abstract Serializable extract_Value()
                                    throws BAD_OPERATION
        Extracts the java.io.Serializable object in this Any object's value field.
        返回：
        the java.io.Serializable object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a java.io.Serializable object or the value field has not yet been set

      • insert_Value

        public abstract void insert_Value(Serializable v)
        Inserts the given java.io.Serializable object into this Any object's value field.
        参数：
        v - the java.io.Serializable object to insert into this Any object

      • insert_Value

        public abstract void insert_Value(Serializable v,
                TypeCode t)
                           throws MARSHAL
        Inserts the given java.io.Serializable object into this Any object's value field.
        参数：
        v - the java.io.Serializable object to insert into this Any object
        t - the TypeCode object that is to be inserted into this Any object's type field and that describes the java.io.Serializable object being inserted
        抛出：
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • insert_Object

        public abstract void insert_Object(Object o,
                 TypeCode t)
                            throws BAD_PARAM
        Inserts the given org.omg.CORBA.Object object into this Any object's value field.
        参数：
        o - the org.omg.CORBA.Object instance to insert into this Any object
        t - the TypeCode object that is to be inserted into this Any object and that describes the Object being inserted
        抛出：
        BAD_OPERATION - if this method is invalid for this Any object
        BAD_PARAM

      • extract_string

        public abstract String extract_string()
                               throws BAD_OPERATION
        Extracts the String object in this Any object's value field.
        返回：
        the String object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a String object or the value field has not yet been set

      • insert_string

        public abstract void insert_string(String s)
                            throws DATA_CONVERSION,
                                   MARSHAL
        Inserts the given String object into this Any object's value field.
        参数：
        s - the String object to insert into this Any object
        抛出：
        DATA_CONVERSION - if there is a data conversion error
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • extract_wstring

        public abstract String extract_wstring()
                                throws BAD_OPERATION
        Extracts the String object in this Any object's value field.
        返回：
        the String object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a String object or the value field has not yet been set

      • insert_wstring

        public abstract void insert_wstring(String s)
                             throws MARSHAL
        Inserts the given String object into this Any object's value field.
        参数：
        s - the String object to insert into this Any object
        抛出：
        MARSHAL - if the ORB has a problem marshalling or unmarshalling parameters

      • extract_TypeCode

        public abstract TypeCode extract_TypeCode()
                                   throws BAD_OPERATION
        Extracts the TypeCode object in this Any object's value field.
        返回：
        the TypeCode object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a TypeCode object or the value field has not yet been set

      • insert_TypeCode

        public abstract void insert_TypeCode(TypeCode t)
        Inserts the given TypeCode object into this Any object's value field.
        参数：
        t - the TypeCode object to insert into this Any object

      • extract_Principal

        @Deprecated
public Principal extract_Principal()
                            throws BAD_OPERATION
        Deprecated. Deprecated by CORBA 2.2.
        Extracts the Principal object in this Any object's value field. Note that the class Principal has been deprecated.
        返回：
        the Principal object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a Principal object or the value field has not yet been set
        另请参见：
        CORBA package comments for unimplemented features

      • insert_Principal

        @Deprecated
public void insert_Principal(Principal p)
        Deprecated. Deprecated by CORBA 2.2.
        Inserts the given Principal object into this Any object's value field. Note that the class Principal has been deprecated.
        参数：
        p - the Principal object to insert into this Any object
        另请参见：
        CORBA package comments for unimplemented features

      • extract_Streamable

        public Streamable extract_Streamable()
                              throws BAD_INV_ORDER
        Extracts a Streamable from this Any object's value field. This method allows the extraction of non-primitive IDL types.
        返回：
        the Streamable stored in the Any object.
        抛出：
        BAD_INV_ORDER - if the caller has invoked operations in the wrong order
        另请参见：
        CORBA package comments for unimplemented features

      • insert_Streamable

        public void insert_Streamable(Streamable s)
        Inserts the given Streamable object into this Any object's value field. This method allows the insertion of non-primitive IDL types.
        参数：
        s - the Streamable object to insert into this Any object; may be a non-primitive IDL type
        另请参见：
        CORBA package comments for unimplemented features

      • extract_fixed

        public BigDecimal extract_fixed()
        Extracts the java.math.BigDecimal object in this Any object's value field.
        返回：
        the java.math.BigDecimal object stored in this Any object
        抛出：
        BAD_OPERATION - if this Any object contains something other than a java.math.BigDecimal object or the value field has not yet been set
        另请参见：
        CORBA package comments for unimplemented features

      • insert_fixed

        public void insert_fixed(BigDecimal value)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Inserts the given java.math.BigDecimal object into this Any object's value field.

        参数：
        value - the java.math.BigDecimal object to insert into this Any object
        另请参见：
        CORBA package comments for unimplemented features

      • insert_fixed

        public void insert_fixed(BigDecimal value,
                TypeCode type)
                  throws BAD_INV_ORDER
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Inserts the given java.math.BigDecimal object into this Any object's value field.

        参数：
        value - the java.math.BigDecimal object to insert into this Any object
        type - the TypeCode object that is to be inserted into this Any object's type field and that describes the java.math.BigDecimal object being inserted
        抛出：
        BAD_INV_ORDER - if this method is invoked improperly
        另请参见：
        CORBA package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


AnyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 AnyHolder

  • java.lang.Object
    • org.omg.CORBA.AnyHolder
  • 所有已实现的接口：
    Streamable

    public final class AnyHolder
extends Object
implements Streamable
    The Holder for Any. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for Any objects that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL any as an "out" or "inout" parameter, the programmer must pass an instance of AnyHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myAnyHolder is an instance of AnyHolder, the value stored in its value field can be accessed with myAnyHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Any value
      The Any value held by this AnyHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AnyHolder()
      Constructs a new AnyHolder object with its value field initialized to null.
      AnyHolder(Any initial)
      Constructs a new AnyHolder object for the given Any object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in this AnyHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this AnyHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Any value
        The Any value held by this AnyHolder object.

    • 构造方法详细信息

      • AnyHolder

        public AnyHolder()
        Constructs a new AnyHolder object with its value field initialized to null.

      • AnyHolder

        public AnyHolder(Any initial)
        Constructs a new AnyHolder object for the given Any object.
        参数：
        initial - the Any object with which to initialize the value field of the new AnyHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this AnyHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in this AnyHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this AnyHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

turouoaloarccarr"n##t>dc<


AnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 AnySeqHelper

  • java.lang.Object
    • org.omg.CORBA.AnySeqHelper

  • public abstract class AnySeqHelper
extends Object
    The Helper for AnySeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/AnySeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      AnySeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Any[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Any[] that)
      static Any[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Any[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AnySeqHelper

        public AnySeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Any[] that)

      • extract

        public static Any[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Any[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Any[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>_=n"aeem<-


AnySeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 AnySeqHolder

  • java.lang.Object
    • org.omg.CORBA.AnySeqHolder
  • 所有已实现的接口：
    Streamable

    public final class AnySeqHolder
extends Object
implements Streamable
    The Holder for AnySeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/AnySeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Any[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      AnySeqHolder()
      AnySeqHolder(Any[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Any[] value

    • 构造方法详细信息

      • AnySeqHolder

        public AnySeqHolder()

      • AnySeqHolder

        public AnySeqHolder(Any[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tio=rncetnot_u"<a />#_he>>l


ARG_IN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_IN

  • public interface ARG_IN
    Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server. ARG_IN.value is one of the possible values used to indicate the direction in which a parameter is being passed during an invocation performed using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

        ORB orb = ORB.init(args, null);
    org.omg.CORBA.NamedValue nv = orb.create_named_value(
         "IDLArgumentIdentifier", myAny, org.omg.CORBA.ARG_IN.value);
    从以下版本开始：
    JDK1.2
    另请参见：
    NamedValue

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value indicating an input argument.

    • 字段详细信息

      • value

        static final int value
        The value indicating an input argument.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/as=ci"citttitttO..- <>3srrhrea


ARG_INOUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_INOUT

  • public interface ARG_INOUT
    Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client. ARG_INOUT.value is one of the possible values used to indicate the direction in which a parameter is being passed during a dynamic invocation using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

      ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_INOUT.value);
    从以下版本开始：
    JDK1.2
    另请参见：
    NamedValue

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The constant value indicating an argument used for both input and output.

    • 字段详细信息

      • value

        static final int value
        The constant value indicating an argument used for both input and output.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)bOjjbO.llcW


ARG_OUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface ARG_OUT

  • public interface ARG_OUT
    A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client. ARG_OUT.value is one of the possible values used to indicate the direction in which a parameter is being passed during a dynamic invocation using the Dynamic Invocation Interface (DII).

    The code fragment below shows a typical usage:

      ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_OUT.value);
    从以下版本开始：
    JDK1.2
    另请参见：
    NamedValue

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The constant value indicating an output argument.

    • 字段详细信息

      • value

        static final int value
        The constant value indicating an output argument.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/c13191r10,Orae扑cg捌O� 嘶＊c


BAD_CONTEXT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_CONTEXT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_CONTEXT
  • 所有已实现的接口：
    Serializable

    public final class BAD_CONTEXT
extends SystemException
    Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_CONTEXT()
      Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_CONTEXT(int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
      BAD_CONTEXT(String s)
      Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
      BAD_CONTEXT(String s, int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_CONTEXT

        public BAD_CONTEXT()
        Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_CONTEXT

        public BAD_CONTEXT(String s)
        Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
        参数：
        s - a String object containing a detail message

      • BAD_CONTEXT

        public BAD_CONTEXT(int minor,
           CompletionStatus completed)
        Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_CONTEXT

        public BAD_CONTEXT(String s,
           int minor,
           CompletionStatus completed)
        Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

贩>a>f<#>.u#h


BAD_INV_ORDER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_INV_ORDER

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_INV_ORDER
  • 所有已实现的接口：
    Serializable

    public final class BAD_INV_ORDER
extends SystemException
    This exception indicates that the caller has invoked operations in the wrong order. For example, it can be raised by an ORB if an application makes an ORB-related call without having correctly initialized the ORB first.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_INV_ORDER()
      Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_INV_ORDER(int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
      BAD_INV_ORDER(String s)
      Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_INV_ORDER

        public BAD_INV_ORDER()
        Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_INV_ORDER

        public BAD_INV_ORDER(String s)
        Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • BAD_INV_ORDER

        public BAD_INV_ORDER(int minor,
             CompletionStatus completed)
        Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_INV_ORDER

        public BAD_INV_ORDER(String s,
             int minor,
             CompletionStatus completed)
        Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"薳=FAxc""go avtooo-!-= N> ;


BAD_OPERATION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_OPERATION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_OPERATION
  • 所有已实现的接口：
    Serializable

    public final class BAD_OPERATION
extends SystemException
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_OPERATION()
      Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_OPERATION(int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified minor code and completion status.
      BAD_OPERATION(String s)
      Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_OPERATION(String s, int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_OPERATION

        public BAD_OPERATION()
        Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_OPERATION

        public BAD_OPERATION(String s)
        Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • BAD_OPERATION

        public BAD_OPERATION(int minor,
             CompletionStatus completed)
        Constructs a BAD_OPERATION exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_OPERATION

        public BAD_OPERATION(String s,
             int minor,
             CompletionStatus completed)
        Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<<<>b ///ym "lxo>�


BAD_PARAM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_PARAM

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_PARAM
  • 所有已实现的接口：
    Serializable

    public final class BAD_PARAM
extends SystemException
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal. An ORB may raise this exception if null values or null pointers are passed to an operation (for language mappings where the concept of a null pointers or null values applies). BAD_PARAM can also be raised as a result of a client generating requests with incorrect parameters using the DII.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions, meaning of minor codes

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_PARAM()
      Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_PARAM(int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified minor code and completion status.
      BAD_PARAM(String s)
      Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_PARAM(String s, int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_PARAM

        public BAD_PARAM()
        Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_PARAM

        public BAD_PARAM(String s)
        Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message describing this exception

      • BAD_PARAM

        public BAD_PARAM(int minor,
         CompletionStatus completed)
        Constructs a BAD_PARAM exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • BAD_PARAM

        public BAD_PARAM(String s,
         int minor,
         CompletionStatus completed)
        Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/tb>r�>/>lahu/gfe==ENOTBTTBaVsl=ptrps


BAD_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY

  • public interface BAD_POLICY
    A PolicyErrorCode which would be filled in the PolicyError exception.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The Error code in PolicyError exception.

    • 字段详细信息

      • value

        static final short value
        The Error code in PolicyError exception.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i "caTTfc fas ta n


BAD_POLICY_TYPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY_TYPE

  • public interface BAD_POLICY_TYPE
    A PolicyErrorCode which would be filled in the PolicyError exception.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The Error code in PolicyError exception.

    • 字段详细信息

      • value

        static final short value
        The Error code in PolicyError exception.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method


BAD_POLICY_VALUE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface BAD_POLICY_VALUE

  • public interface BAD_POLICY_VALUE
    Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The value used to represent a bad policy value error in a PolicyError exception.

    • 字段详细信息

      • value

        static final short value
        The value used to represent a bad policy value error in a PolicyError exception.
        另请参见：
        PolicyError, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=htRo.rmgo rro sttttt so;n,;R


BAD_QOS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_QOS

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_QOS
  • 所有已实现的接口：
    Serializable

    public final class BAD_QOS
extends SystemException
    The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_QOS()
      Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      BAD_QOS(int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified minor code and completion status.
      BAD_QOS(String detailMessage)
      Constructs an BAD_QOS exception with the specified message.
      BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_QOS

        public BAD_QOS()
        Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • BAD_QOS

        public BAD_QOS(String detailMessage)
        Constructs an BAD_QOS exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • BAD_QOS

        public BAD_QOS(int minorCode,
       CompletionStatus completionStatus)
        Constructs an BAD_QOS exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • BAD_QOS

        public BAD_QOS(String detailMessage,
       int minorCode,
       CompletionStatus completionStatus)
        Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

:toakma_anbr_btei u"_)_tt筼>�/旃brd<<


BAD_TYPECODE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 BAD_TYPECODE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.BAD_TYPECODE
  • 所有已实现的接口：
    Serializable

    public final class BAD_TYPECODE
extends SystemException
    Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      BAD_TYPECODE()
      Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      BAD_TYPECODE(int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
      BAD_TYPECODE(String s)
      Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
      BAD_TYPECODE(String s, int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BAD_TYPECODE

        public BAD_TYPECODE()
        Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • BAD_TYPECODE

        public BAD_TYPECODE(String s)
        Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • BAD_TYPECODE

        public BAD_TYPECODE(int minor,
            CompletionStatus completed)
        Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • BAD_TYPECODE

        public BAD_TYPECODE(String s,
            int minor,
            CompletionStatus completed)
        Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nRlpgyptpcrhtm>t<


BooleanHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 BooleanHolder

  • java.lang.Object
    • org.omg.CORBA.BooleanHolder
  • 所有已实现的接口：
    Streamable

    public final class BooleanHolder
extends Object
implements Streamable
    The Holder for Boolean. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a boolean that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL boolean as an "out" or "inout" parameter, the programmer must pass an instance of BooleanHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myBooleanHolder is an instance of BooleanHolder, the value stored in its value field can be accessed with myBooleanHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      boolean value
      The boolean value held by this BooleanHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BooleanHolder()
      Constructs a new BooleanHolder object with its value field initialized to false.
      BooleanHolder(boolean initial)
      Constructs a new BooleanHolder object with its value field initialized with the given boolean.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
      void _write(OutputStream output)
      Marshals the value in this BooleanHolder object's value field to the output stream output.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public boolean value
        The boolean value held by this BooleanHolder object.

    • 构造方法详细信息

      • BooleanHolder

        public BooleanHolder()
        Constructs a new BooleanHolder object with its value field initialized to false.

      • BooleanHolder

        public BooleanHolder(boolean initial)
        Constructs a new BooleanHolder object with its value field initialized with the given boolean.
        参数：
        initial - the boolean with which to initialize the value field of the newly-created BooleanHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream object containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals the value in this BooleanHolder object's value field to the output stream output.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode for the value held in this BooleanHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lla穉bA/f7".ge e =


BooleanSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 BooleanSeqHelper

  • java.lang.Object
    • org.omg.CORBA.BooleanSeqHelper

  • public abstract class BooleanSeqHelper
extends Object
    The Helper for BooleanSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/BooleanSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      BooleanSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static boolean[] | extract(Any a)
      static String | id()
      static void | insert(Any a, boolean[] that)
      static boolean[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, boolean[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BooleanSeqHelper

        public BooleanSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          boolean[] that)

      • extract

        public static boolean[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static boolean[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         boolean[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ogm.f" =" ahh aao>// oiedd>>< dvv<>/


BooleanSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 BooleanSeqHolder

  • java.lang.Object
    • org.omg.CORBA.BooleanSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class BooleanSeqHolder
extends Object
implements Streamable
    The Holder for BooleanSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/BooleanSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      boolean[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      BooleanSeqHolder()
      BooleanSeqHolder(boolean[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public boolean[] value

    • 构造方法详细信息

      • BooleanSeqHolder

        public BooleanSeqHolder()

      • BooleanSeqHolder

        public BooleanSeqHolder(boolean[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i nynln;n"n"; }" tta taallie.tk..dLkk oipskt


Bounds

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 Bounds

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.Bounds
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Bounds
extends UserException
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    另请参见：
    documentation on Java IDL exceptions

    • 构造方法摘要

      Constructors
      构造方法与描述
      Bounds()
      Constructs an Bounds with no specified detail message.
      Bounds(String reason)
      Constructs an Bounds with the specified detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Bounds

        public Bounds()
        Constructs an Bounds with no specified detail message.

      • Bounds

        public Bounds(String reason)
        Constructs an Bounds with the specified detail message.
        参数：
        reason - the detail message.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>b


ByteHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ByteHolder

  • java.lang.Object
    • org.omg.CORBA.ByteHolder
  • 所有已实现的接口：
    Streamable

    public final class ByteHolder
extends Object
implements Streamable
    The Holder for Byte. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a byte that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL octet as an "out" or "inout" parameter, the programmer must pass an instance of ByteHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myByteHolder is an instance of ByteHolder, the value stored in its value field can be accessed with myByteHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      byte value
      The byte value held by this ByteHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ByteHolder()
      Constructs a new ByteHolder object with its value field initialized to 0.
      ByteHolder(byte initial)
      Constructs a new ByteHolder object for the given byte.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ByteHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this ByteHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public byte value
        The byte value held by this ByteHolder object.

    • 构造方法详细信息

      • ByteHolder

        public ByteHolder()
        Constructs a new ByteHolder object with its value field initialized to 0.

      • ByteHolder

        public ByteHolder(byte initial)
        Constructs a new ByteHolder object for the given byte.
        参数：
        initial - the byte with which to initialize the value field of the new ByteHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ByteHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ByteHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this ByteHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/7aaoaa<絪m fs>>sne"ae> zzf=-f 遽


CharHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CharHolder

  • java.lang.Object
    • org.omg.CORBA.CharHolder
  • 所有已实现的接口：
    Streamable

    public final class CharHolder
extends Object
implements Streamable
    The Holder for Char. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a char that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL char as an "out" or "inout" parameter, the programmer must pass an instance of CharHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myCharHolder is an instance of CharHolder, the value stored in its value field can be accessed with myCharHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      char value
      The char value held by this CharHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CharHolder()
      Constructs a new CharHolder object with its value field initialized to 0.
      CharHolder(char initial)
      Constructs a new CharHolder object for the given char.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in this CharHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this CharHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public char value
        The char value held by this CharHolder object.

    • 构造方法详细信息

      • CharHolder

        public CharHolder()
        Constructs a new CharHolder object with its value field initialized to 0.

      • CharHolder

        public CharHolder(char initial)
        Constructs a new CharHolder object for the given char.
        参数：
        initial - the char with which to initialize the value field of the new CharHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this CharHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in this CharHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this CharHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tope


CharSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CharSeqHelper

  • java.lang.Object
    • org.omg.CORBA.CharSeqHelper

  • public abstract class CharSeqHelper
extends Object
    The Helper for CharSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CharSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      CharSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static char[] | extract(Any a)
      static String | id()
      static void | insert(Any a, char[] that)
      static char[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, char[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CharSeqHelper

        public CharSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          char[] that)

      • extract

        public static char[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static char[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         char[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

- a va ftt ffohnnrBSpelldsaps<<>豩


CharSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CharSeqHolder

  • java.lang.Object
    • org.omg.CORBA.CharSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class CharSeqHolder
extends Object
implements Streamable
    The Holder for CharSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/CharSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      char[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      CharSeqHolder()
      CharSeqHolder(char[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public char[] value

    • 构造方法详细信息

      • CharSeqHolder

        public CharSeqHolder()

      • CharSeqHolder

        public CharSeqHolder(char[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ph;aeaasa/&bsp&bl__//au蔿l=auNsiugssoi衪cvsN


CODESET_INCOMPATIBLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 CODESET_INCOMPATIBLE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.CODESET_INCOMPATIBLE
  • 所有已实现的接口：
    Serializable

    public final class CODESET_INCOMPATIBLE
extends SystemException
    This exception is raised whenever meaningful communication is not possible between client and server native code sets.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      CODESET_INCOMPATIBLE()
      Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
      CODESET_INCOMPATIBLE(String detailMessage)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message.
      CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE()
        Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(String detailMessage)
        Constructs an CODESET_INCOMPATIBLE exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(int minorCode,
                    CompletionStatus completionStatus)
        Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • CODESET_INCOMPATIBLE

        public CODESET_INCOMPATIBLE(String detailMessage,
                    int minorCode,
                    CompletionStatus completionStatus)
        Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AaProrr ruhr A eA>>">fr==/f:r"e.ac岷


COMM_FAILURE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 COMM_FAILURE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.COMM_FAILURE
  • 所有已实现的接口：
    Serializable

    public final class COMM_FAILURE
extends SystemException
    This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    meaning of minor codes

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      COMM_FAILURE()
      Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      COMM_FAILURE(int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified minor code and completion status.
      COMM_FAILURE(String s)
      Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      COMM_FAILURE(String s, int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • COMM_FAILURE

        public COMM_FAILURE()
        Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • COMM_FAILURE

        public COMM_FAILURE(String s)
        Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message describing this exception

      • COMM_FAILURE

        public COMM_FAILURE(int minor,
            CompletionStatus completed)
        Constructs a COMM_FAILURE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status, which must be one of COMPLETED_YES, COMPLETED_NO, or COMPLETED_MAYBE.

      • COMM_FAILURE

        public COMM_FAILURE(String s,
            int minor,
            CompletionStatus completed)
        Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status, which must be one of COMPLETED_YES, COMPLETED_NO, or COMPLETED_MAYBE.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--mo/smlpbaa/pyfo>>lm騬襰 m�<


CompletionStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

类 CompletionStatus

  • java.lang.Object
    • org.omg.CORBA.CompletionStatus
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class CompletionStatus
extends Object
implements IDLEntity
    An object that indicates whether a method had completed running when a SystemException was thrown.

    The class CompletionStatus contains three CompletionStatus instances, which are constants representing each possible completion status: COMPLETED_MAYBE, COMPLETED_NO, and COMPLETED_YES. It also contains three int members, each a constant corresponding to one of the CompletionStatus instances. These int members make it possible to use a switch statement.

    The class also contains two methods:

    • public int value() -- which accesses the value field of a CompletionStatus object
    • public static CompletionStatus from_int(int i) -- for creating an instance from one of the int members
    从以下版本开始：
    JDK1.2
    另请参见：
    SystemException

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int _COMPLETED_MAYBE
      The constant indicating that a method completed running before a SystemException was thrown.
      static int _COMPLETED_NO
      The constant indicating that a method completed running before a SystemException was thrown.
      static int _COMPLETED_YES
      The constant indicating that a method completed running before a SystemException was thrown.
      static CompletionStatus COMPLETED_MAYBE
      An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
      static CompletionStatus COMPLETED_NO
      An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
      static CompletionStatus COMPLETED_YES
      An instance of CompletionStatus initialized with the constant _COMPLETED_YES.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static CompletionStatus from_int(int i)
      Creates a CompletionStatus object from the given int.
      int value()
      Retrieves the value of this CompletionStatus object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _COMPLETED_YES

        public static final int _COMPLETED_YES
        The constant indicating that a method completed running before a SystemException was thrown.
        另请参见：
        Constant Field Values

      • _COMPLETED_NO

        public static final int _COMPLETED_NO
        The constant indicating that a method completed running before a SystemException was thrown.
        另请参见：
        Constant Field Values

      • _COMPLETED_MAYBE

        public static final int _COMPLETED_MAYBE
        The constant indicating that a method completed running before a SystemException was thrown.
        另请参见：
        Constant Field Values

      • COMPLETED_YES

        public static final CompletionStatus COMPLETED_YES
        An instance of CompletionStatus initialized with the constant _COMPLETED_YES.

      • COMPLETED_NO

        public static final CompletionStatus COMPLETED_NO
        An instance of CompletionStatus initialized with the constant _COMPLETED_NO.

      • COMPLETED_MAYBE

        public static final CompletionStatus COMPLETED_MAYBE
        An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.

    • 方法详细信息

      • value

        public int value()
        Retrieves the value of this CompletionStatus object.
        返回：
        one of the possible CompletionStatus values: _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE

      • from_int

        public static CompletionStatus from_int(int i)
        Creates a CompletionStatus object from the given int.
        参数：
        i - one of _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE
        返回：
        one of the possible CompletionStatus objects with values: _COMPLETED_YES, _COMPLETED_NO, or _COMPLETED_MAYBE
        抛出：
        BAD_PARAM - if the argument given is not one of the int constants defined in CompletionStatus
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

daAp"moms"nd/od蝍r黶omj_aIoGagtOa>_b.�


CompletionStatusHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CompletionStatusHelper

  • java.lang.Object
    • org.omg.CORBA.CompletionStatusHelper

  • public abstract class CompletionStatusHelper
extends Object
    The Helper for CompletionStatus. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CompletionStatusHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      CompletionStatusHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static CompletionStatus | extract(Any a)
      static String | id()
      static void | insert(Any a, CompletionStatus that)
      static CompletionStatus | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, CompletionStatus value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CompletionStatusHelper

        public CompletionStatusHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          CompletionStatus that)

      • extract

        public static CompletionStatus extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CompletionStatus read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         CompletionStatus value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

CaOo-od odoeedoo>d//ehegc<g


Context

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 Context

  • java.lang.Object
    • org.omg.CORBA.Context

  • public abstract class Context
extends Object
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation. A Context object contains a list of properties in the form of NamedValue objects. These properties represent information about the client, the environment, or the circumstances of a request and generally are properties that might be inconvenient to pass as parameters.

    A Context object is created by first calling the ORB method get_default_context and then calling the method create_child on the default context.

    Each property in a Context object is represented by a NamedValue object. The property name is contained in the NamedValue object's name field, and the value associated with the name is contained in the Any object that was assigned to the NamedValue object's value field.

    Context properties can represent a portion of a client's or application's environment that is meant to be propagated to (and made implicitly part of) a server's environment. (Examples might be a window identifier or user preference information). Once a server has been invoked (that is, after the properties are propagated), the server may query its Context object for these properties using the method get_values.

    When an operation declaration includes a context clause, the stubs and skeletons will have an additional argument added for the context. When an operation invocation occurs, the ORB causes the properties that were named in the operation definition in IDL and that are present in the client's Context object to be provided in the Context object parameter to the invoked method.

    Context property names (which are strings) typically have the form of an OMG IDL identifier or a series of OMG IDL identifiers separated by periods. A context property name pattern is either a property name or a property name followed by a single "*". A property name pattern without a trailing "*" is said to match only itself. A property name pattern of the form "<name>*" matches any property name that starts with <name> and continues with zero or more additional characters.

    Property name patterns are used in the context clause of an operation definition and as a parameter for the method Context.get_values.

    Context objects may be "chained" together to achieve a particular defaulting behavior. A Context object created with the method create_child will be chained to its parent (the Context object that created it), and that means that the parent will be searched after the child in a search for property names.

    Properties defined in a particular Context object effectively override those properties in the next higher level. The scope used in a search for properties may be restricted by specifying a starting scope and by using the flag CTX_RESTRICT_SCOPE when invoking the method get_values.

    A Context object may be named for purposes of specifying a starting search scope.

    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      Context()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String context_name()
      Retrieves the name of this Context object.
      abstract Context create_child(String child_ctx_name)
      Creates a Context object with the given string as its name and with this Context object set as its parent.
      abstract void delete_values(String propname)
      Deletes from this Context object the NamedValue object(s) whose name field matches the given property name.
      abstract NVList get_values(String start_scope, int op_flags, String pattern)
      Retrieves the NamedValue objects whose name field matches the given name or name pattern.
      abstract Context parent()
      Retrieves the parent of this Context object.
      abstract void set_one_value(String propname, Any propvalue)
      Creates a NamedValue object and adds it to this Context object.
      abstract void set_values(NVList values)
      I Sets one or more property values in this Context object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Context

        public Context()

    • 方法详细信息

      • context_name

        public abstract String context_name()
        Retrieves the name of this Context object.
        返回：
        the name of this Context object

      • parent

        public abstract Context parent()
        Retrieves the parent of this Context object.
        返回：
        the Context object that is the parent of this Context object

      • create_child

        public abstract Context create_child(String child_ctx_name)
        Creates a Context object with the given string as its name and with this Context object set as its parent.

        The new Context object is chained into its parent Context object. This means that in a search for matching property names, if a match is not found in this context, the search will continue in the parent. If that is not successful, the search will continue in the grandparent, if there is one, and so on.

        参数：
        child_ctx_name - the String object to be set as the name of the new Context object
        返回：
        the newly-created child Context object initialized with the specified name

      • set_one_value

        public abstract void set_one_value(String propname,
                 Any propvalue)
        Creates a NamedValue object and adds it to this Context object. The name field of the new NamedValue object is set to the given string, the value field is set to the given Any object, and the flags field is set to zero.
        参数：
        propname - the name of the property to be set
        propvalue - the Any object to which the value of the property will be set. The Any object's value field contains the value to be associated with the given propname; the kind field must be set to TCKind.tk_string.

      • set_values

        public abstract void set_values(NVList values)
        I Sets one or more property values in this Context object. The NVList supplied to this method contains one or more NamedValue objects. In each NamedValue object, the name field holds the name of the property, and the flags field must be set to zero. The NamedValue object's value field contains an Any object, which, in turn, contains the value for the property. Since the value is always a string, the Any object must have the kind field of its TypeCode set to TCKind.tk_string.
        参数：
        values - an NVList containing the property names and associated values to be set
        另请参见：
        get_values(java.lang.String, int, java.lang.String), NamedValue, Any

      • delete_values

        public abstract void delete_values(String propname)
        Deletes from this Context object the NamedValue object(s) whose name field matches the given property name. If the String object supplied for propname has a trailing wildcard character ("*"), then all NamedValue objects whose name fields match will be deleted. The search scope is always limited to this Context object.

        If no matching property is found, an exception is returned.

        参数：
        propname - name of the property to be deleted

      • get_values

        public abstract NVList get_values(String start_scope,
                int op_flags,
                String pattern)
        Retrieves the NamedValue objects whose name field matches the given name or name pattern. This method allows for wildcard searches, which means that there can be multiple matches and therefore multiple values returned. If the property is not found at the indicated level, the search continues up the context object tree until a match is found or all Context objects in the chain have been exhausted.

        If no match is found, an error is returned and no property list is returned.

        参数：
        start_scope - a String object indicating the context object level at which to initiate the search for the specified properties (for example, "_USER", "_GROUP", "_SYSTEM"). Valid scope names are implementation-specific. If a scope name is omitted, the search begins with the specified context object. If the specified scope name is not found, an exception is returned.
        op_flags - an operation flag. The one flag that may be specified is CTX_RESTRICT_SCOPE. If this flag is specified, searching is limited to the specified start_scope or this Context object.
        pattern - the property name whose values are to be retrieved. pattern may be a name or a name with a trailing wildcard character ("*").
        返回：
        an NVList containing all the property values (in the form of NamedValue objects) whose associated property name matches the given name or name pattern
        另请参见：
        set_values(org.omg.CORBA.NVList), NamedValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

0rig.o/t".dhoccNvm d>>ai>ixl idSs.a.g


ContextList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ContextList

  • java.lang.Object
    • org.omg.CORBA.ContextList

  • public abstract class ContextList
extends Object
    An object containing a modifiable list of String objects that represent property names. This class is used in Request operations to describe the contexts that need to be resolved and sent with the invocation. (A context is resolved by giving a property name and getting back the value associated with it.) This is done by calling the Context method get_values and supplying a string from a ContextList object as the third parameter. The method get_values returns an NVList object containing the NamedValue objects that hold the value(s) identified by the given string.

    A ContextList object is created by the ORB, as illustrated here:

       ORB orb = ORB.init(args, null);
   org.omg.CORBA.ContextList ctxList = orb.create_context_list();
    The variable ctxList represents an empty ContextList object. Strings are added to the list with the method add, accessed with the method item, and removed with the method remove.
    从以下版本开始：
    JDK1.2
    另请参见：
    Context

    • 构造方法摘要

      Constructors
      构造方法与描述
      ContextList()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void add(String ctx)
      Adds a String object to this ContextList object.
      abstract int count()
      Returns the number of String objects in this ContextList object.
      abstract String item(int index)
      Returns the String object at the given index.
      abstract void remove(int index)
      Removes the String object at the given index.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ContextList

        public ContextList()

    • 方法详细信息

      • count

        public abstract int count()
        Returns the number of String objects in this ContextList object.
        返回：
        an int representing the number of Strings in this ContextList object

      • add

        public abstract void add(String ctx)
        Adds a String object to this ContextList object.
        参数：
        ctx - the String object to be added

      • item

        public abstract String item(int index)
                     throws Bounds
        Returns the String object at the given index.
        参数：
        index - the index of the string desired, with 0 being the index of the first string
        返回：
        the string at the given index
        抛出：
        Bounds - if the index is greater than or equal to the number of strings in this ContextList object

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the String object at the given index. Note that the indices of all strings following the one removed are shifted down by one.
        参数：
        index - the index of the String object to be removed, with 0 designating the first string
        抛出：
        Bounds - if the index is greater than or equal to the number of String objects in this ContextList object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pnr hfe fesaaessintttoc>/<


CTX_RESTRICT_SCOPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface CTX_RESTRICT_SCOPE

  • public interface CTX_RESTRICT_SCOPE
    A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope. When this flag is used, it restricts the search for context values to this particular Context object or to the scope specified in the first parameter to Context.get_values.

    Usage:

         NVList props = myContext.get_values("_USER",
                     CTX_RESTRICT_SCOPE.value, "id*");
    从以下版本开始：
    JDK1.2
    另请参见：
    Context.get_values(String, int, String)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The field containing the int value of a CTX_RESTRICT_SCOPE flag.

    • 字段详细信息

      • value

        static final int value
        The field containing the int value of a CTX_RESTRICT_SCOPE flag.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t>tjcgecgn//gnnv.</<>,


Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface Current

  • All Superinterfaces:
    CurrentOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    Current, Current

    public interface Current
extends CurrentOperations, Object, IDLEntity
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running. This information is accessed in a structured manner using interfaces derived from the Current interface defined in the CORBA module.

    Each ORB or CORBA service that needs its own context derives an interface from the CORBA module's Current. Users of the service can obtain an instance of the appropriate Current interface by invoking ORB::resolve_initial_references.

    org/omg/CORBA/Current.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mbe//i/li>>l


CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CurrentHelper

  • java.lang.Object
    • org.omg.CORBA.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    The Helper for Current. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/CurrentHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      CurrentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Current value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CurrentHelper

        public CurrentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Current value)

      • narrow

        public static Current narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/tniu(nueoone� lc>pha/eo衦 afthhmi


CurrentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 CurrentHolder

  • java.lang.Object
    • org.omg.CORBA.CurrentHolder
  • 所有已实现的接口：
    Streamable

    public final class CurrentHolder
extends Object
implements Streamable
    The Holder for Current. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/CurrentHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Current value

    • 构造方法摘要

      Constructors
      构造方法与描述
      CurrentHolder()
      CurrentHolder(Current initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Current value

    • 构造方法详细信息

      • CurrentHolder

        public CurrentHolder()

      • CurrentHolder

        public CurrentHolder(Current initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c etct"ooE>>/>d/.ncx//>o�


CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface CurrentOperations

  • All Known Subinterfaces:
    Current, Current, Current, CurrentOperations, CurrentOperations

    public interface CurrentOperations
    The interface for Current. For more information on Operations interfaces, see "Generated Files". org/omg/CORBA/CurrentOperations.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lc"S/naInatbbattAo..#her.i


CustomMarshal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface CustomMarshal

  • All Known Subinterfaces:
    CustomValue

    public interface CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user. Semantically it is treated as a custom value type's implicit base class, although the custom valuetype does not actually inherit it in IDL. The implementer of a custom value type shall provide an implementation of the CustomMarshal operations. The manner in which this is done is specified in the IDL to Java langauge mapping. Each custom marshaled value type shall have its own implementation.
    另请参见：
    DataInputStream

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void marshal(DataOutputStream os)
      Marshal method has to be implemented by the Customized Marshal class.
      void unmarshal(DataInputStream is)
      Unmarshal method has to be implemented by the Customized Marshal class.

    • 方法详细信息

      • marshal

        void marshal(DataOutputStream os)
        Marshal method has to be implemented by the Customized Marshal class. This is the method invoked for Marshalling.
        参数：
        os - a DataOutputStream

      • unmarshal

        void unmarshal(DataInputStream is)
        Unmarshal method has to be implemented by the Customized Marshal class. This is the method invoked for Unmarshalling.
        参数：
        is - a DataInputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)asetCl"=l a=n n!oO/ t0c>->>>b"


DATA_CONVERSION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 DATA_CONVERSION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.DATA_CONVERSION
  • 所有已实现的接口：
    Serializable

    public final class DATA_CONVERSION
extends SystemException
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa. For example, DATA_CONVERSION can be raised if wide character codeset conversion fails, or if an ORB cannot convert floating point values between different representations.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      DATA_CONVERSION()
      Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      DATA_CONVERSION(int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
      DATA_CONVERSION(String s)
      Constructs a DATA_CONVERSION exception with the specified detail.
      DATA_CONVERSION(String s, int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DATA_CONVERSION

        public DATA_CONVERSION()
        Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • DATA_CONVERSION

        public DATA_CONVERSION(String s)
        Constructs a DATA_CONVERSION exception with the specified detail.
        参数：
        s - the String containing a detail message

      • DATA_CONVERSION

        public DATA_CONVERSION(int minor,
               CompletionStatus completed)
        Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • DATA_CONVERSION

        public DATA_CONVERSION(String s,
               int minor,
               CompletionStatus completed)
        Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&on s[tteStw.ter#ramtaStOth.


DataInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DataInputStream

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase

    public interface DataInputStream
extends ValueBase
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types. This interface is used by user written custom unmarshaling code for custom value types.
    另请参见：
    DataOutputStream, CustomMarshal

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object read_Abstract()
      Reads an IDL Abstract interface from the input stream.
      void read_any_array(AnySeqHolder seq, int offset, int length)
      Reads array of IDL Anys from offset for length elements from the input stream.
      Any read_any()
      Reads an IDL Any value from the input stream.
      void read_boolean_array(BooleanSeqHolder seq, int offset, int length)
      Reads array of IDL booleans from offset for length elements from the input stream.
      boolean read_boolean()
      Reads an IDL boolean value from the input stream.
      void read_char_array(CharSeqHolder seq, int offset, int length)
      Reads array of IDL characters from offset for length elements from the input stream.
      char read_char()
      Reads an IDL character value from the input stream.
      void read_double_array(DoubleSeqHolder seq, int offset, int length)
      Reads array of IDL doubles from offset for length elements from the input stream.
      double read_double()
      Reads an IDL double from the input stream.
      void read_float_array(FloatSeqHolder seq, int offset, int length)
      Reads array of IDL floats from offset for length elements from the input stream.
      float read_float()
      Reads an IDL float from the input stream.
      void read_long_array(LongSeqHolder seq, int offset, int length)
      Reads array of IDL longs from offset for length elements from the input stream.
      int read_long()
      Reads an IDL long from the input stream.
      void read_longlong_array(LongLongSeqHolder seq, int offset, int length)
      Reads array of IDL long longs from offset for length elements from the input stream.
      long read_longlong()
      Reads an IDL long long from the input stream.
      Object read_Object()
      Reads an IDL CORBA::Object from the input stream.
      void read_octet_array(OctetSeqHolder seq, int offset, int length)
      Reads array of IDL octets from offset for length elements from the input stream.
      byte read_octet()
      Reads an IDL octet value from the input stream.
      void read_short_array(ShortSeqHolder seq, int offset, int length)
      Reads array of IDL shorts from offset for length elements from the input stream.
      short read_short()
      Reads an IDL short from the input stream.
      String read_string()
      Reads an IDL string from the input stream.
      TypeCode read_TypeCode()
      Reads an IDL typecode from the input stream.
      void read_ulong_array(ULongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned longs from offset for length elements from the input stream.
      int read_ulong()
      Reads an IDL unsigned long from the input stream.
      void read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned long longs from offset for length elements from the input stream.
      long read_ulonglong()
      Reads an unsigned IDL long long from the input stream.
      void read_ushort_array(UShortSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned shorts from offset for length elements from the input stream.
      short read_ushort()
      Reads an IDL unsigned short from the input stream.
      Serializable read_Value()
      Reads an IDL value type from the input stream.
      void read_wchar_array(WCharSeqHolder seq, int offset, int length)
      Reads array of IDL wide characters from offset for length elements from the input stream.
      char read_wchar()
      Reads an IDL wide character value from the input stream.
      String read_wstring()
      Reads an IDL wide string from the input stream.

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • 方法详细信息

      • read_any

        Any read_any()
        Reads an IDL Any value from the input stream.
        返回：
        the Any read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_boolean

        boolean read_boolean()
        Reads an IDL boolean value from the input stream.
        返回：
        the boolean read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_char

        char read_char()
        Reads an IDL character value from the input stream.
        返回：
        the character read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wchar

        char read_wchar()
        Reads an IDL wide character value from the input stream.
        返回：
        the wide character read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_octet

        byte read_octet()
        Reads an IDL octet value from the input stream.
        返回：
        the octet value read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_short

        short read_short()
        Reads an IDL short from the input stream.
        返回：
        the short read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ushort

        short read_ushort()
        Reads an IDL unsigned short from the input stream.
        返回：
        the unsigned short read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_long

        int read_long()
        Reads an IDL long from the input stream.
        返回：
        the long read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulong

        int read_ulong()
        Reads an IDL unsigned long from the input stream.
        返回：
        the unsigned long read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_longlong

        long read_longlong()
        Reads an IDL long long from the input stream.
        返回：
        the long long read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulonglong

        long read_ulonglong()
        Reads an unsigned IDL long long from the input stream.
        返回：
        the unsigned long long read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_float

        float read_float()
        Reads an IDL float from the input stream.
        返回：
        the float read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_double

        double read_double()
        Reads an IDL double from the input stream.
        返回：
        the double read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_string

        String read_string()
        Reads an IDL string from the input stream.
        返回：
        the string read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wstring

        String read_wstring()
        Reads an IDL wide string from the input stream.
        返回：
        the wide string read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Object

        Object read_Object()
        Reads an IDL CORBA::Object from the input stream.
        返回：
        the CORBA::Object read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Abstract

        Object read_Abstract()
        Reads an IDL Abstract interface from the input stream.
        返回：
        the Abstract interface read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_Value

        Serializable read_Value()
        Reads an IDL value type from the input stream.
        返回：
        the value type read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_TypeCode

        TypeCode read_TypeCode()
        Reads an IDL typecode from the input stream.
        返回：
        the typecode read.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_any_array

        void read_any_array(AnySeqHolder seq,
                  int offset,
                  int length)
        Reads array of IDL Anys from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_boolean_array

        void read_boolean_array(BooleanSeqHolder seq,
                      int offset,
                      int length)
        Reads array of IDL booleans from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_char_array

        void read_char_array(CharSeqHolder seq,
                   int offset,
                   int length)
        Reads array of IDL characters from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_wchar_array

        void read_wchar_array(WCharSeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL wide characters from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_octet_array

        void read_octet_array(OctetSeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL octets from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_short_array

        void read_short_array(ShortSeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL shorts from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ushort_array

        void read_ushort_array(UShortSeqHolder seq,
                     int offset,
                     int length)
        Reads array of IDL unsigned shorts from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_long_array

        void read_long_array(LongSeqHolder seq,
                   int offset,
                   int length)
        Reads array of IDL longs from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulong_array

        void read_ulong_array(ULongSeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL unsigned longs from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_ulonglong_array

        void read_ulonglong_array(ULongLongSeqHolder seq,
                        int offset,
                        int length)
        Reads array of IDL unsigned long longs from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_longlong_array

        void read_longlong_array(LongLongSeqHolder seq,
                       int offset,
                       int length)
        Reads array of IDL long longs from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_float_array

        void read_float_array(FloatSeqHolder seq,
                    int offset,
                    int length)
        Reads array of IDL floats from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.

      • read_double_array

        void read_double_array(DoubleSeqHolder seq,
                     int offset,
                     int length)
        Reads array of IDL doubles from offset for length elements from the input stream.
        参数：
        seq - The out parameter holder for the array to be read.
        offset - The index into seq of the first element to read from the input stream.
        length - The number of elements to read from the input stream.
        抛出：
        org.omg.CORBA.MARSHAL - If an inconsistency is detected, including not having registered a streaming policy, then the standard system exception MARSHAL is raised.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DataOutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DataOutputStream

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase

    public interface DataOutputStream
extends ValueBase
    Defines the methods used to write primitive data types to output streams for marshalling custom value types. This interface is used by user written custom marshalling code for custom value types.
    另请参见：
    DataInputStream, CustomMarshal

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void write_Abstract(Object value)
      Writes the IDL Abstract interface type to the output stream.
      void write_any_array(Any[] seq, int offset, int length)
      Writes the array of IDL Anys from offset for length elements to the output stream.
      void write_any(Any value)
      Writes the Any value to the output stream.
      void write_boolean_array(boolean[] seq, int offset, int length)
      Writes the array of IDL booleans from offset for length elements to the output stream.
      void write_boolean(boolean value)
      Writes the boolean value to the output stream.
      void write_char_array(char[] seq, int offset, int length)
      Writes the array of IDL characters from offset for length elements to the output stream.
      void write_char(char value)
      Writes the IDL character value to the output stream.
      void write_double_array(double[] seq, int offset, int length)
      Writes the array of IDL doubles from offset for length elements to the output stream.
      void write_double(double value)
      Writes the IDL double value to the output stream.
      void write_float_array(float[] seq, int offset, int length)
      Writes the array of IDL floats from offset for length elements to the output stream.
      void write_float(float value)
      Writes the IDL float value to the output stream.
      void write_long_array(int[] seq, int offset, int length)
      Writes the array of IDL longs from offset for length elements to the output stream.
      void write_long(int value)
      Writes the IDL long value (represented as a Java int) to the output stream.
      void write_longlong_array(long[] seq, int offset, int length)
      Writes the array of IDL long longs from offset for length elements to the output stream.
      void write_longlong(long value)
      Writes the IDL long long value (represented as a Java long) to the output stream.
      void write_Object(Object value)
      Writes the IDL CORBA::Object value to the output stream.
      void write_octet_array(byte[] seq, int offset, int length)
      Writes the array of IDL octets from offset for length elements to the output stream.
      void write_octet(byte value)
      Writes the IDL octet value (represented as a Java byte) to the output stream.
      void write_short_array(short[] seq, int offset, int length)
      Writes the array of IDL shorts from offset for length elements to the output stream.
      void write_short(short value)
      Writes the IDL short value to the output stream.
      void write_string(String value)
      Writes the IDL string value to the output stream.
      void write_TypeCode(TypeCode value)
      Writes the typecode to the output stream.
      void write_ulong_array(int[] seq, int offset, int length)
      Writes the array of IDL unsigned longs (represented as Java ints) from offset for length elements to the output stream.
      void write_ulong(int value)
      Writes the IDL unsigned long value (represented as a Java int) to the output stream.
      void write_ulonglong_array(long[] seq, int offset, int length)
      Writes the array of IDL unsigned long longs (represented as Java longs) from offset for length elements to the output stream.
      void write_ulonglong(long value)
      Writes the IDL unsigned long long value (represented as a Java long) to the output stream.
      void write_ushort_array(short[] seq, int offset, int length)
      Writes the array of IDL unsigned shorts (represented as Java shorts) from offset for length elements to the output stream.
      void write_ushort(short value)
      Writes the IDL unsigned short value (represented as a Java short value) to the output stream.
      void write_Value(Serializable value)
      Writes the IDL value type value to the output stream.
      void write_wchar_array(char[] seq, int offset, int length)
      Writes the array of IDL wide characters from offset for length elements to the output stream.
      void write_wchar(char value)
      Writes the IDL wide character value to the output stream.
      void write_wstring(String value)
      Writes the IDL wide string value (represented as a Java String) to the output stream.

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • 方法详细信息

      • write_any

        void write_any(Any value)
        Writes the Any value to the output stream.
        参数：
        value - The value to be written.

      • write_boolean

        void write_boolean(boolean value)
        Writes the boolean value to the output stream.
        参数：
        value - The value to be written.

      • write_char

        void write_char(char value)
        Writes the IDL character value to the output stream.
        参数：
        value - The value to be written.

      • write_wchar

        void write_wchar(char value)
        Writes the IDL wide character value to the output stream.
        参数：
        value - The value to be written.

      • write_octet

        void write_octet(byte value)
        Writes the IDL octet value (represented as a Java byte) to the output stream.
        参数：
        value - The value to be written.

      • write_short

        void write_short(short value)
        Writes the IDL short value to the output stream.
        参数：
        value - The value to be written.

      • write_ushort

        void write_ushort(short value)
        Writes the IDL unsigned short value (represented as a Java short value) to the output stream.
        参数：
        value - The value to be written.

      • write_long

        void write_long(int value)
        Writes the IDL long value (represented as a Java int) to the output stream.
        参数：
        value - The value to be written.

      • write_ulong

        void write_ulong(int value)
        Writes the IDL unsigned long value (represented as a Java int) to the output stream.
        参数：
        value - The value to be written.

      • write_longlong

        void write_longlong(long value)
        Writes the IDL long long value (represented as a Java long) to the output stream.
        参数：
        value - The value to be written.

      • write_ulonglong

        void write_ulonglong(long value)
        Writes the IDL unsigned long long value (represented as a Java long) to the output stream.
        参数：
        value - The value to be written.

      • write_float

        void write_float(float value)
        Writes the IDL float value to the output stream.
        参数：
        value - The value to be written.

      • write_double

        void write_double(double value)
        Writes the IDL double value to the output stream.
        参数：
        value - The value to be written.

      • write_string

        void write_string(String value)
        Writes the IDL string value to the output stream.
        参数：
        value - The value to be written.

      • write_wstring

        void write_wstring(String value)
        Writes the IDL wide string value (represented as a Java String) to the output stream.
        参数：
        value - The value to be written.

      • write_Object

        void write_Object(Object value)
        Writes the IDL CORBA::Object value to the output stream.
        参数：
        value - The value to be written.

      • write_Abstract

        void write_Abstract(Object value)
        Writes the IDL Abstract interface type to the output stream.
        参数：
        value - The value to be written.

      • write_Value

        void write_Value(Serializable value)
        Writes the IDL value type value to the output stream.
        参数：
        value - The value to be written.

      • write_TypeCode

        void write_TypeCode(TypeCode value)
        Writes the typecode to the output stream.
        参数：
        value - The value to be written.

      • write_any_array

        void write_any_array(Any[] seq,
                   int offset,
                   int length)
        Writes the array of IDL Anys from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_boolean_array

        void write_boolean_array(boolean[] seq,
                       int offset,
                       int length)
        Writes the array of IDL booleans from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_char_array

        void write_char_array(char[] seq,
                    int offset,
                    int length)
        Writes the array of IDL characters from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_wchar_array

        void write_wchar_array(char[] seq,
                     int offset,
                     int length)
        Writes the array of IDL wide characters from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_octet_array

        void write_octet_array(byte[] seq,
                     int offset,
                     int length)
        Writes the array of IDL octets from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_short_array

        void write_short_array(short[] seq,
                     int offset,
                     int length)
        Writes the array of IDL shorts from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ushort_array

        void write_ushort_array(short[] seq,
                      int offset,
                      int length)
        Writes the array of IDL unsigned shorts (represented as Java shorts) from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_long_array

        void write_long_array(int[] seq,
                    int offset,
                    int length)
        Writes the array of IDL longs from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ulong_array

        void write_ulong_array(int[] seq,
                     int offset,
                     int length)
        Writes the array of IDL unsigned longs (represented as Java ints) from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_ulonglong_array

        void write_ulonglong_array(long[] seq,
                         int offset,
                         int length)
        Writes the array of IDL unsigned long longs (represented as Java longs) from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_longlong_array

        void write_longlong_array(long[] seq,
                        int offset,
                        int length)
        Writes the array of IDL long longs from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_float_array

        void write_float_array(float[] seq,
                     int offset,
                     int length)
        Writes the array of IDL floats from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.

      • write_double_array

        void write_double_array(double[] seq,
                      int offset,
                      int length)
        Writes the array of IDL doubles from offset for length elements to the output stream.
        参数：
        seq - The array to be written.
        offset - The index into seq of the first element to write to the output stream.
        length - The number of elements to write to the output stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irn serter eer antt><<>e=


DefinitionKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DefinitionKind

  • java.lang.Object
    • org.omg.CORBA.DefinitionKind
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class DefinitionKind
extends Object
implements IDLEntity
    The class that provides the constants used to identify the type of an Interface Repository object. This class contains two kinds of constants, those that are an int and those that are an instance of the class DefinitionKind. This class provides the method from_int, which given one of the int constants, creates the corresponding DefinitionKind instance. It also provides the method value, which returns the int constant that is the value for a DefinitionKind instance.
    另请参见：
    IRObject

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int _dk_AbstractInterface
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Alias
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_all
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Array
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Attribute
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Constant
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Enum
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Exception
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Fixed
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Interface
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Module
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Native
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_none
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Operation
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Primitive
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Repository
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Sequence
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_String
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Struct
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Typedef
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Union
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Value
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_ValueBox
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_ValueMember
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static int _dk_Wstring
      The constant that indicates that an Interface Repository object does not have a definition kind.
      static DefinitionKind dk_AbstractInterface
      The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
      static DefinitionKind dk_Alias
      The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
      static DefinitionKind dk_all
      The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
      static DefinitionKind dk_Array
      The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
      static DefinitionKind dk_Attribute
      The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
      static DefinitionKind dk_Constant
      The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
      static DefinitionKind dk_Enum
      The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
      static DefinitionKind dk_Exception
      The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
      static DefinitionKind dk_Fixed
      The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
      static DefinitionKind dk_Interface
      The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
      static DefinitionKind dk_Module
      The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
      static DefinitionKind dk_Native
      The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
      static DefinitionKind dk_none
      The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
      static DefinitionKind dk_Operation
      The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
      static DefinitionKind dk_Primitive
      The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
      static DefinitionKind dk_Repository
      The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
      static DefinitionKind dk_Sequence
      The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
      static DefinitionKind dk_String
      The static instance of DefinitionKind indicating that an Interface Repository object is a String.
      static DefinitionKind dk_Struct
      The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
      static DefinitionKind dk_Typedef
      The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
      static DefinitionKind dk_Union
      The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
      static DefinitionKind dk_Value
      The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
      static DefinitionKind dk_ValueBox
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
      static DefinitionKind dk_ValueMember
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
      static DefinitionKind dk_Wstring
      The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected DefinitionKind(int _value)
      Constructs a DefinitionKind object with its _value field initialized with the given value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static DefinitionKind from_int(int i)
      Creates a DefinitionKind instance corresponding to the given code .
      int value()
      Returns the int constant identifying the type of an IR object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _dk_none

        public static final int _dk_none
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_all

        public static final int _dk_all
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Attribute

        public static final int _dk_Attribute
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Constant

        public static final int _dk_Constant
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Exception

        public static final int _dk_Exception
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Interface

        public static final int _dk_Interface
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Module

        public static final int _dk_Module
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Operation

        public static final int _dk_Operation
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Typedef

        public static final int _dk_Typedef
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Alias

        public static final int _dk_Alias
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Struct

        public static final int _dk_Struct
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Union

        public static final int _dk_Union
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Enum

        public static final int _dk_Enum
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Primitive

        public static final int _dk_Primitive
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_String

        public static final int _dk_String
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Sequence

        public static final int _dk_Sequence
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Array

        public static final int _dk_Array
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Repository

        public static final int _dk_Repository
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Wstring

        public static final int _dk_Wstring
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Fixed

        public static final int _dk_Fixed
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Value

        public static final int _dk_Value
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_ValueBox

        public static final int _dk_ValueBox
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_ValueMember

        public static final int _dk_ValueMember
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_Native

        public static final int _dk_Native
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • _dk_AbstractInterface

        public static final int _dk_AbstractInterface
        The constant that indicates that an Interface Repository object does not have a definition kind.
        另请参见：
        Constant Field Values

      • dk_none

        public static final DefinitionKind dk_none
        The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.

      • dk_all

        public static final DefinitionKind dk_all
        The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate. The Container's contents method makes use of this constant to return all contained definitions of any kind.

      • dk_Attribute

        public static final DefinitionKind dk_Attribute
        The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.

      • dk_Constant

        public static final DefinitionKind dk_Constant
        The static instance of DefinitionKind indicating that an Interface Repository object is a constant.

      • dk_Exception

        public static final DefinitionKind dk_Exception
        The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.

      • dk_Interface

        public static final DefinitionKind dk_Interface
        The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.

      • dk_Module

        public static final DefinitionKind dk_Module
        The static instance of DefinitionKind indicating that an Interface Repository object is a Module.

      • dk_Operation

        public static final DefinitionKind dk_Operation
        The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.

      • dk_Typedef

        public static final DefinitionKind dk_Typedef
        The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.

      • dk_Alias

        public static final DefinitionKind dk_Alias
        The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.

      • dk_Struct

        public static final DefinitionKind dk_Struct
        The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.

      • dk_Union

        public static final DefinitionKind dk_Union
        The static instance of DefinitionKind indicating that an Interface Repository object is a Union.

      • dk_Enum

        public static final DefinitionKind dk_Enum
        The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.

      • dk_Primitive

        public static final DefinitionKind dk_Primitive
        The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.

      • dk_String

        public static final DefinitionKind dk_String
        The static instance of DefinitionKind indicating that an Interface Repository object is a String.

      • dk_Sequence

        public static final DefinitionKind dk_Sequence
        The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.

      • dk_Array

        public static final DefinitionKind dk_Array
        The static instance of DefinitionKind indicating that an Interface Repository object is an Array.

      • dk_Repository

        public static final DefinitionKind dk_Repository
        The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.

      • dk_Wstring

        public static final DefinitionKind dk_Wstring
        The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.

      • dk_Fixed

        public static final DefinitionKind dk_Fixed
        The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.

      • dk_Value

        public static final DefinitionKind dk_Value
        The static instance of DefinitionKind indicating that an Interface Repository object is a Value.

      • dk_ValueBox

        public static final DefinitionKind dk_ValueBox
        The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.

      • dk_ValueMember

        public static final DefinitionKind dk_ValueMember
        The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.

      • dk_Native

        public static final DefinitionKind dk_Native
        The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.

      • dk_AbstractInterface

        public static final DefinitionKind dk_AbstractInterface
        The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.

    • 构造方法详细信息

      • DefinitionKind

        protected DefinitionKind(int _value)
        Constructs a DefinitionKind object with its _value field initialized with the given value.
        参数：
        _value - one of the int constants defined in the class DefinitionKind

    • 方法详细信息

      • value

        public int value()
        Returns the int constant identifying the type of an IR object.
        返回：
        the int constant from the class DefinitionKind that is the value of this DefinitionKind instance

      • from_int

        public static DefinitionKind from_int(int i)
        Creates a DefinitionKind instance corresponding to the given code .
        参数：
        i - one of the int constants from the class DefinitionKind
        返回：
        the DefinitionKind instance corresponding to the given code
        抛出：
        BAD_PARAM - if the given parameter is not one of the int constants from the class DefinitionKind
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DefinitionKindHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DefinitionKindHelper

  • java.lang.Object
    • org.omg.CORBA.DefinitionKindHelper

  • public abstract class DefinitionKindHelper
extends Object
    The Helper for DefinitionKind. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/DefinitionKindHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefinitionKindHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DefinitionKind | extract(Any a)
      static String | id()
      static void | insert(Any a, DefinitionKind that)
      static DefinitionKind | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DefinitionKind value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefinitionKindHelper

        public DefinitionKindHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DefinitionKind that)

      • extract

        public static DefinitionKind extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DefinitionKind read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DefinitionKind value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.a//dvtdvi>>viidtaaeknTsnnchatnoll a


DomainManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface DomainManager

  • All Superinterfaces:
    DomainManagerOperations, IDLEntity, Object, Serializable

    public interface DomainManager
extends DomainManagerOperations, Object, IDLEntity
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies. The DomainManager has associated with it the policy objects for a particular domain. The domain manager also records the membership of the domain and provides the means to add and remove members. The domain manager is itself a member of a domain, possibly the domain it manages. The domain manager provides mechanisms for establishing and navigating relationships to superior and subordinate domains and creating and accessing policies.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.DomainManagerOperations

        get_domain_policy

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

neygog rg sii ss""RRhs >n/iA


DomainManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DomainManagerOperations

  • All Known Subinterfaces:
    DomainManager

    public interface DomainManagerOperations
    Provides the DomainManager with the means to access policies.

    The DomainManager has associated with it the policy objects for a particular domain. The domain manager also records the membership of the domain and provides the means to add and remove members. The domain manager is itself a member of a domain, possibly the domain it manages. The domain manager provides mechanisms for establishing and navigating relationships to superior and subordinate domains and creating and accessing policies.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Policy get_domain_policy(int policy_type)
      This returns the policy of the specified type for objects in this domain.

    • 方法详细信息

      • get_domain_policy

        Policy get_domain_policy(int policy_type)
        This returns the policy of the specified type for objects in this domain. The types of policies available are domain specific. See the CORBA specification for a list of standard ORB policies.
        参数：
        policy_type - Type of policy to request
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nibbsbob&bnp|&np|tll誰a< t>Laapb


DoubleHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DoubleHolder

  • java.lang.Object
    • org.omg.CORBA.DoubleHolder
  • 所有已实现的接口：
    Streamable

    public final class DoubleHolder
extends Object
implements Streamable
    The Holder for Double. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a double that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL double as an "out" or "inout" parameter, the programmer must pass an instance of DoubleHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myDoubleHolder is an instance of DoubleHolder, the value stored in its value field can be accessed with myDoubleHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      double value
      The double value held by this DoubleHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DoubleHolder()
      Constructs a new DoubleHolder object with its value field initialized to 0.0.
      DoubleHolder(double initial)
      Constructs a new DoubleHolder object for the given double.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Read a double value from the input stream and store it in the value member.
      TypeCode _type()
      Return the TypeCode of this holder object.
      void _write(OutputStream output)
      Write the double value stored in this holder to an OutputStream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public double value
        The double value held by this DoubleHolder object.

    • 构造方法详细信息

      • DoubleHolder

        public DoubleHolder()
        Constructs a new DoubleHolder object with its value field initialized to 0.0.

      • DoubleHolder

        public DoubleHolder(double initial)
        Constructs a new DoubleHolder object for the given double.
        参数：
        initial - the double with which to initialize the value field of the new DoubleHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Read a double value from the input stream and store it in the value member.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the double value stored in this holder to an OutputStream.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this holder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ti .r/.L.c �<=l/R"n. "D"i r a /s r/


DoubleSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DoubleSeqHelper

  • java.lang.Object
    • org.omg.CORBA.DoubleSeqHelper

  • public abstract class DoubleSeqHelper
extends Object
    The Helper for DoubleSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/DoubleSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      DoubleSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static double[] | extract(Any a)
      static String | id()
      static void | insert(Any a, double[] that)
      static double[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, double[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DoubleSeqHelper

        public DoubleSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          double[] that)

      • extract

        public static double[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static double[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         double[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttt-"sr#srheerhha ttA=OSFOO=stsoaatan


DoubleSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DoubleSeqHolder

  • java.lang.Object
    • org.omg.CORBA.DoubleSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class DoubleSeqHolder
extends Object
implements Streamable
    The Holder for DoubleSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/DoubleSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      double[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      DoubleSeqHolder()
      DoubleSeqHolder(double[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public double[] value

    • 构造方法详细信息

      • DoubleSeqHolder

        public DoubleSeqHolder()

      • DoubleSeqHolder

        public DoubleSeqHolder(double[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

semoMo~ogd<> a <-- -a//== !d/<


DynamicImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 DynamicImplementation

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
  • 所有已实现的接口：
    Object
    直接已知子类：
    _BindingIteratorImplBase, _NamingContextImplBase
    Deprecated.
    org.omg.CORBA.DynamicImplementation

    @Deprecated
public class DynamicImplementation
extends ObjectImpl

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynamicImplementation()
      Deprecated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Deprecated.
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void invoke(ServerRequest request)
      Deprecated.
      Deprecated by Portable Object Adapter

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • DynamicImplementation

        public DynamicImplementation()
        Deprecated.

    • 方法详细信息

      • invoke

        @Deprecated
public void invoke(ServerRequest request)
        Deprecated. Deprecated by Portable Object Adapter

      • _ids

        public String[] _ids()
        Deprecated.
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nndnknonanus anwiod/肌凸闺旺<=a" aem.<


DynAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynAny

  • All Superinterfaces:
    Object
    All Known Subinterfaces:
    DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue
    Deprecated.
    Use the new DynAny instead

    @Deprecated
public interface DynAny
extends Object
    Enables org.omg.CORBA.Any values to be dynamically interpreted (traversed) and constructed. A DynAny object is associated with a data value which may correspond to a copy of the value inserted into an Any. The DynAny APIs enable traversal of the data value associated with an Any at runtime and extraction of the primitive constituents of the data value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
      DynAny copy()
      Deprecated.
      Clones this DynAny object.
      DynAny current_component()
      Deprecated.
      Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
      void destroy()
      Deprecated.
      Destroys this DynAny object and frees any resources used to represent the data value associated with it.
      void from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      Any get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      boolean get_boolean()
      Deprecated.
      Retrieves the boolean contained in this DynAny object.
      char get_char()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      double get_double()
      Deprecated.
      Retrieves the double contained in this DynAny object.
      float get_float()
      Deprecated.
      Retrieves the float contained in this DynAny object.
      int get_long()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long get_longlong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      byte get_octet()
      Deprecated.
      Retrieves the byte contained in this DynAny object.
      Object get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      short get_short()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      String get_string()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      TypeCode get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      int get_ulong()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long get_ulonglong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      short get_ushort()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      Serializable get_val()
      Deprecated.
      Retrieves the java.io.Serializable object contained in this DynAny object.
      char get_wchar()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      String get_wstring()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      void insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      void insert_boolean(boolean value)
      Deprecated.
      Inserts the given boolean as the value for this DynAny object.
      void insert_char(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void insert_double(double value)
      Deprecated.
      Inserts the given double as the value for this DynAny object.
      void insert_float(float value)
      Deprecated.
      Inserts the given float as the value for this DynAny object.
      void insert_long(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void insert_longlong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void insert_octet(byte value)
      Deprecated.
      Inserts the given byte as the value for this DynAny object.
      void insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      void insert_short(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void insert_string(String value)
      Deprecated.
      Inserts the given String object as the value for this DynAny object.
      void insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      void insert_ulong(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void insert_ulonglong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void insert_ushort(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void insert_val(Serializable value)
      Deprecated.
      Inserts the given java.io.Serializable object as the value for this DynAny object.
      void insert_wchar(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void insert_wstring(String value)
      Deprecated.
      Inserts the given String as the value for this DynAny object.
      boolean 下一个()
      Deprecated.
      Moves to the next component of this DynAny object.
      void rewind()
      Deprecated.
      Moves the internal pointer to the first component.
      boolean seek(int index)
      Deprecated.
      Moves the internal pointer to the given index.
      Any to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
      TypeCode type()
      Deprecated.
      Returns the TypeCode of the object inserted into this DynAny.

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • type

        TypeCode type()
        Deprecated.
        Returns the TypeCode of the object inserted into this DynAny.
        返回：
        the TypeCode object.

      • assign

        void assign(DynAny dyn_any)
            throws Invalid
        Deprecated.
        Copy the contents from one Dynamic Any into another.
        参数：
        dyn_any - the DynAny object whose contents are assigned to this DynAny.
        抛出：
        Invalid - if the source DynAny is invalid

      • from_any

        void from_any(Any value)
              throws Invalid
        Deprecated.
        Make a DynAny object from an Any object.
        参数：
        value - the Any object.
        抛出：
        Invalid - if the source Any object is empty or bad

      • to_any

        Any to_any()
           throws Invalid
        Deprecated.
        Convert a DynAny object to an Any object.
        返回：
        the Any object.
        抛出：
        Invalid - if this DynAny is empty or bad. created or does not contain a meaningful value

      • destroy

        void destroy()
        Deprecated.
        Destroys this DynAny object and frees any resources used to represent the data value associated with it. This method also destroys all DynAny objects obtained from it.

        Destruction of DynAny objects should be handled with care, taking into account issues dealing with the representation of data values associated with DynAny objects. A programmer who wants to destroy a DynAny object but still be able to manipulate some component of the data value associated with it, should first create a DynAny object for the component and then make a copy of the created DynAny object.

      • copy

        DynAny copy()
        Deprecated.
        Clones this DynAny object.
        返回：
        a copy of this DynAny object

      • insert_boolean

        void insert_boolean(boolean value)
                    throws InvalidValue
        Deprecated.
        Inserts the given boolean as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the boolean to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_octet

        void insert_octet(byte value)
                  throws InvalidValue
        Deprecated.
        Inserts the given byte as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the byte to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_char

        void insert_char(char value)
                 throws InvalidValue
        Deprecated.
        Inserts the given char as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the char to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_short

        void insert_short(short value)
                  throws InvalidValue
        Deprecated.
        Inserts the given short as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the short to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ushort

        void insert_ushort(short value)
                   throws InvalidValue
        Deprecated.
        Inserts the given short as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the short to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_long

        void insert_long(int value)
                 throws InvalidValue
        Deprecated.
        Inserts the given int as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the int to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ulong

        void insert_ulong(int value)
                  throws InvalidValue
        Deprecated.
        Inserts the given int as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the int to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_float

        void insert_float(float value)
                  throws InvalidValue
        Deprecated.
        Inserts the given float as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the float to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_double

        void insert_double(double value)
                   throws InvalidValue
        Deprecated.
        Inserts the given double as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the double to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_string

        void insert_string(String value)
                   throws InvalidValue
        Deprecated.
        Inserts the given String object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the String to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_reference

        void insert_reference(Object value)
                      throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.Object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the org.omg.CORBA.Object to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_typecode

        void insert_typecode(TypeCode value)
                     throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the org.omg.CORBA.TypeCode to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_longlong

        void insert_longlong(long value)
                     throws InvalidValue
        Deprecated.
        Inserts the given long as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the long to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_ulonglong

        void insert_ulonglong(long value)
                      throws InvalidValue
        Deprecated.
        Inserts the given long as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the long to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_wchar

        void insert_wchar(char value)
                  throws InvalidValue
        Deprecated.
        Inserts the given char as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the char to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_wstring

        void insert_wstring(String value)
                    throws InvalidValue
        Deprecated.
        Inserts the given String as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the String to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_any

        void insert_any(Any value)
                throws InvalidValue
        Deprecated.
        Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the org.omg.CORBA.Any object to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • insert_val

        void insert_val(Serializable value)
                throws InvalidValue
        Deprecated.
        Inserts the given java.io.Serializable object as the value for this DynAny object.

        If this method is called on a constructed DynAny object, it initializes the next component of the constructed data value associated with this DynAny object.

        参数：
        value - the java.io.Serializable object to insert into this DynAny object
        抛出：
        InvalidValue - if the value inserted is not consistent with the type of the accessed component in this DynAny object

      • get_val

        Serializable get_val()
                     throws TypeMismatch
        Deprecated.
        Retrieves the java.io.Serializable object contained in this DynAny object.
        返回：
        the java.io.Serializable object that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a java.io.Serializable object

      • get_boolean

        boolean get_boolean()
                    throws TypeMismatch
        Deprecated.
        Retrieves the boolean contained in this DynAny object.
        返回：
        the boolean that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a boolean

      • get_octet

        byte get_octet()
               throws TypeMismatch
        Deprecated.
        Retrieves the byte contained in this DynAny object.
        返回：
        the byte that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a byte

      • get_char

        char get_char()
              throws TypeMismatch
        Deprecated.
        Retrieves the char contained in this DynAny object.
        返回：
        the char that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a char

      • get_short

        short get_short()
                throws TypeMismatch
        Deprecated.
        Retrieves the short contained in this DynAny object.
        返回：
        the short that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a short

      • get_ushort

        short get_ushort()
                 throws TypeMismatch
        Deprecated.
        Retrieves the short contained in this DynAny object.
        返回：
        the short that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a short

      • get_long

        int get_long()
             throws TypeMismatch
        Deprecated.
        Retrieves the int contained in this DynAny object.
        返回：
        the int that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a int

      • get_ulong

        int get_ulong()
              throws TypeMismatch
        Deprecated.
        Retrieves the int contained in this DynAny object.
        返回：
        the int that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a int

      • get_float

        float get_float()
                throws TypeMismatch
        Deprecated.
        Retrieves the float contained in this DynAny object.
        返回：
        the float that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a float

      • get_double

        double get_double()
                  throws TypeMismatch
        Deprecated.
        Retrieves the double contained in this DynAny object.
        返回：
        the double that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a double

      • get_string

        String get_string()
                  throws TypeMismatch
        Deprecated.
        Retrieves the String contained in this DynAny object.
        返回：
        the String that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a String

      • get_reference

        Object get_reference()
                     throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.Other contained in this DynAny object.
        返回：
        the org.omg.CORBA.Other that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for an org.omg.CORBA.Other

      • get_typecode

        TypeCode get_typecode()
                      throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
        返回：
        the org.omg.CORBA.TypeCode that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a org.omg.CORBA.TypeCode

      • get_longlong

        long get_longlong()
                  throws TypeMismatch
        Deprecated.
        Retrieves the long contained in this DynAny object.
        返回：
        the long that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a long

      • get_ulonglong

        long get_ulonglong()
                   throws TypeMismatch
        Deprecated.
        Retrieves the long contained in this DynAny object.
        返回：
        the long that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a long

      • get_wchar

        char get_wchar()
               throws TypeMismatch
        Deprecated.
        Retrieves the char contained in this DynAny object.
        返回：
        the char that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a char

      • get_wstring

        String get_wstring()
                   throws TypeMismatch
        Deprecated.
        Retrieves the String contained in this DynAny object.
        返回：
        the String that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for a String

      • get_any

        Any get_any()
            throws TypeMismatch
        Deprecated.
        Retrieves the org.omg.CORBA.Any contained in this DynAny object.
        返回：
        the org.omg.CORBA.Any that is the value for this DynAny object
        抛出：
        TypeMismatch - if the type code of the accessed component in this DynAny object is not equivalent to the type code for an org.omg.CORBA.Any

      • current_component

        DynAny current_component()
        Deprecated.
        Returns a DynAny object reference that can be used to get/set the value of the component currently accessed. The appropriate insert method can be called on the resulting DynAny object to initialize the component. The appropriate get method can be called on the resulting DynAny object to extract the value of the component.
        返回：
        a DynAny object reference that can be used to retrieve or set the value of the component currently accessed

      • 下一个

        boolean next()
        Deprecated.
        Moves to the next component of this DynAny object. This method is used for iterating through the components of a constructed type, effectively moving a pointer from one component to the next. The pointer starts out on the first component when a DynAny object is created.
        返回：
        true if the pointer points to a component; false if there are no more components or this DynAny is associated with a basic type rather than a constructed type

      • seek

        boolean seek(int index)
        Deprecated.
        Moves the internal pointer to the given index. Logically, this method sets a new offset for this pointer.
        参数：
        index - an int indicating the position to which the pointer should move. The first position is 0.
        返回：
        true if the pointer points to a component; false if there is no component at the designated index. If this DynAny object is associated with a basic type, this method returns false for any index other than 0.

      • rewind

        void rewind()
        Deprecated.
        Moves the internal pointer to the first component.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DynArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynArray

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynArray instead

    @Deprecated
public interface DynArray
extends Object, DynAny
    Represents a DynAny object associated with an array.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Any[] get_elements()
      Deprecated.
      Returns the value of all the elements of this array.
      void set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • get_elements

        Any[] get_elements()
        Deprecated.
        Returns the value of all the elements of this array.
        返回：
        the array of Any objects that is the value for this DynArray object
        另请参见：
        set_elements(org.omg.CORBA.Any[])

      • set_elements

        void set_elements(Any[] value)
                  throws InvalidSeq
        Deprecated.
        Sets the value of this DynArray object to the given array.
        参数：
        value - the array of Any objects
        抛出：
        InvalidSeq - if the sequence is bad
        另请参见：
        get_elements()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ol.otevheveeeveeR" on


DynEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynEnum

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynEnum instead

    @Deprecated
public interface DynEnum
extends Object, DynAny
    Represents a DynAny object associated with an IDL enum.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String value_as_string()
      Deprecated.
      Return the value of the IDL enum stored in this DynEnum as a string.
      void value_as_string(String arg)
      Deprecated.
      Set a particular enum in this DynEnum.
      int value_as_ulong()
      Deprecated.
      Return the value of the IDL enum as a Java int.
      void value_as_ulong(int arg)
      Deprecated.
      Set the value of the IDL enum.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • value_as_string

        String value_as_string()
        Deprecated.
        Return the value of the IDL enum stored in this DynEnum as a string.
        返回：
        the stringified value.

      • value_as_string

        void value_as_string(String arg)
        Deprecated.
        Set a particular enum in this DynEnum.
        参数：
        arg - the string corresponding to the value.

      • value_as_ulong

        int value_as_ulong()
        Deprecated.
        Return the value of the IDL enum as a Java int.
        返回：
        the integer value.

      • value_as_ulong

        void value_as_ulong(int arg)
        Deprecated.
        Set the value of the IDL enum.
        参数：
        arg - the int value of the enum.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o#nosfaits


DynFixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynFixed

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynFixed instead

    @Deprecated
public interface DynFixed
extends Object, DynAny
    Represents a DynAny object that is associated with an IDL fixed type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] get_value()
      Deprecated.
      Returns the value of the fixed type represented in this DynFixed object.
      void set_value(byte[] val)
      Deprecated.
      Sets the given fixed type instance as the value for this DynFixed object.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • get_value

        byte[] get_value()
        Deprecated.
        Returns the value of the fixed type represented in this DynFixed object.
        返回：
        the value as a byte array
        另请参见：
        set_value(byte[])

      • set_value

        void set_value(byte[] val)
               throws InvalidValue
        Deprecated.
        Sets the given fixed type instance as the value for this DynFixed object.
        参数：
        val - the value of the fixed type as a byte array
        抛出：
        InvalidValue - if the given argument is bad
        另请参见：
        get_value()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yf:S S"SrS>maryna


DynSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynSequence

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynSequence instead

    @Deprecated
public interface DynSequence
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL sequence.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Any[] get_elements()
      Deprecated.
      Returns the value of every element in this sequence.
      int length()
      Deprecated.
      Returns the length of the sequence represented by this DynFixed object.
      void length(int arg)
      Deprecated.
      Sets the length of the sequence represented by this DynFixed object to the given argument.
      void set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • length

        int length()
        Deprecated.
        Returns the length of the sequence represented by this DynFixed object.
        返回：
        the length of the sequence

      • length

        void length(int arg)
        Deprecated.
        Sets the length of the sequence represented by this DynFixed object to the given argument.
        参数：
        arg - the length of the sequence

      • get_elements

        Any[] get_elements()
        Deprecated.
        Returns the value of every element in this sequence.
        返回：
        an array of Any objects containing the values in the sequence
        另请参见：
        set_elements(org.omg.CORBA.Any[])

      • set_elements

        void set_elements(Any[] value)
                  throws InvalidSeq
        Deprecated.
        Sets the values of all elements in this sequence with the given array.
        参数：
        value - the array of Any objects to be set
        抛出：
        InvalidSeq - if the array of values is bad
        另请参见：
        get_elements()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.<>".dwocn e;"l�.sumU>yi


DynStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynStruct

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynStruct instead

    @Deprecated
public interface DynStruct
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL struct.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the kind of the current member.
      String current_member_name()
      Deprecated.
      During a traversal, returns the name of the current member.
      NameValuePair[] get_members()
      Deprecated.
      Returns an array containing all the members of the stored struct.
      void set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • current_member_name

        String current_member_name()
        Deprecated.
        During a traversal, returns the name of the current member.
        返回：
        the string name of the current member

      • current_member_kind

        TCKind current_member_kind()
        Deprecated.
        Returns the TCKind object that describes the kind of the current member.
        返回：
        the TCKind object that describes the current member

      • get_members

        NameValuePair[] get_members()
        Deprecated.
        Returns an array containing all the members of the stored struct.
        返回：
        the array of name-value pairs
        另请参见：
        set_members(org.omg.CORBA.NameValuePair[])

      • set_members

        void set_members(NameValuePair[] value)
                 throws InvalidSeq
        Deprecated.
        Set the members of the struct.
        参数：
        value - the array of name-value pairs.
        抛出：
        InvalidSeq - if the given argument is invalid
        另请参见：
        get_members()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h a< lci0bsouraeasteitaC. <篹� a


DynUnion

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynUnion

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynUnion instead

    @Deprecated
public interface DynUnion
extends Object, DynAny
    The DynUnion interface represents a DynAny object that is associated with an IDL union. Union values can be traversed using the operations defined in DynAny. The first component in the union corresponds to the discriminator; the second corresponds to the actual value of the union. Calling the method next() twice allows you to access both components.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind discriminator_kind()
      Deprecated.
      Returns the TCKind object associated with the discriminator of this union.
      DynAny discriminator()
      Deprecated.
      Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
      TCKind member_kind()
      Deprecated.
      Returns the TCKind associated with the member of this union.
      String member_name()
      Deprecated.
      Allows for the inspection of the name of this union member without checking the value of the discriminator.
      void member_name(String arg)
      Deprecated.
      Allows for the assignment of the name of this union member.
      DynAny member()
      Deprecated.
      Returns a DynAny object reference that is used in order to insert/get a member of this union.
      boolean set_as_default()
      Deprecated.
      Determines whether the discriminator associated with this union has been assigned a valid default value.
      void set_as_default(boolean arg)
      Deprecated.
      Determines whether the discriminator associated with this union gets assigned a valid default value.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • set_as_default

        boolean set_as_default()
        Deprecated.
        Determines whether the discriminator associated with this union has been assigned a valid default value.
        返回：
        true if the discriminator has a default value; false otherwise

      • set_as_default

        void set_as_default(boolean arg)
        Deprecated.
        Determines whether the discriminator associated with this union gets assigned a valid default value.
        参数：
        arg - true if the discriminator gets assigned a default value

      • discriminator

        DynAny discriminator()
        Deprecated.
        Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
        返回：
        a DynAny object reference representing the discriminator value

      • discriminator_kind

        TCKind discriminator_kind()
        Deprecated.
        Returns the TCKind object associated with the discriminator of this union.
        返回：
        the TCKind object associated with the discriminator of this union

      • member

        DynAny member()
        Deprecated.
        Returns a DynAny object reference that is used in order to insert/get a member of this union.
        返回：
        the DynAny object representing a member of this union

      • member_name

        String member_name()
        Deprecated.
        Allows for the inspection of the name of this union member without checking the value of the discriminator.
        返回：
        the name of this union member

      • member_name

        void member_name(String arg)
        Deprecated.
        Allows for the assignment of the name of this union member.
        参数：
        arg - the new name of this union member

      • member_kind

        TCKind member_kind()
        Deprecated.
        Returns the TCKind associated with the member of this union.
        返回：
        the TCKind object associated with the member of this union
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

in g eC , > y癮e薬 e .竐e


DynValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface DynValue

  • All Superinterfaces:
    DynAny, Object
    Deprecated.
    Use the new DynValue instead

    @Deprecated
public interface DynValue
extends Object, DynAny
    The representation of a DynAny object that is associated with an IDL value type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the current member.
      String current_member_name()
      Deprecated.
      Returns the name of the current member while traversing a DynAny object that represents a Value object.
      NameValuePair[] get_members()
      Deprecated.
      Returns an array containing all the members of the value object stored in this DynValue.
      void set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.

      • 方法 - 继承于接口 org.omg.CORBA.DynAny

        assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 方法详细信息

      • current_member_name

        String current_member_name()
        Deprecated.
        Returns the name of the current member while traversing a DynAny object that represents a Value object.
        返回：
        the name of the current member

      • current_member_kind

        TCKind current_member_kind()
        Deprecated.
        Returns the TCKind object that describes the current member.
        返回：
        the TCKind object corresponding to the current member

      • get_members

        NameValuePair[] get_members()
        Deprecated.
        Returns an array containing all the members of the value object stored in this DynValue.
        返回：
        an array of name-value pairs.
        另请参见：
        set_members(org.omg.CORBA.NameValuePair[])

      • set_members

        void set_members(NameValuePair[] value)
                 throws InvalidSeq
        Deprecated.
        Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
        参数：
        value - the array of name-value pairs to be set
        抛出：
        InvalidSeq - if an inconsistent value is part of the given array
        另请参见：
        get_members()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nC../e./erfferr>hee> r>"d- t


Environment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 Environment

  • java.lang.Object
    • org.omg.CORBA.Environment

  • public abstract class Environment
extends Object
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client. An Environment object is created with the ORB method create_environment.
    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      Environment()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void clear()
      Clears this Environment object of its exception.
      abstract Exception exception()
      Retrieves the exception in this Environment object.
      abstract void exception(Exception except)
      Inserts the given exception into this Environment object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Environment

        public Environment()

    • 方法详细信息

      • exception

        public abstract Exception exception()
        Retrieves the exception in this Environment object.
        返回：
        the exception in this Environment object

      • exception

        public abstract void exception(Exception except)
        Inserts the given exception into this Environment object.
        参数：
        except - the exception to be set

      • clear

        public abstract void clear()
        Clears this Environment object of its exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ra>aerser_eer__h/rrCmcCej/jAgo//..."rth


ExceptionList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ExceptionList

  • java.lang.Object
    • org.omg.CORBA.ExceptionList

  • public abstract class ExceptionList
extends Object
    An object used in Request operations to describe the exceptions that can be thrown by a method. It maintains a modifiable list of TypeCodes of the exceptions.

    The following code fragment demonstrates creating an ExceptionList object:

        ORB orb = ORB.init(args, null);
    org.omg.CORBA.ExceptionList excList = orb.create_exception_list();
    The variable excList represents an ExceptionList object with no TypeCode objects in it.

    To add items to the list, you first create a TypeCode object for the exception you want to include, using the ORB method create_exception_tc. Then you use the ExceptionList method add to add it to the list. The class ExceptionList has a method for getting the number of TypeCode objects in the list, and after items have been added, it is possible to call methods for accessing or deleting an item at a designated index.

    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      ExceptionList()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void add(TypeCode exc)
      Adds a TypeCode object describing an exception to this ExceptionList object.
      abstract int count()
      Retrieves the number of TypeCode objects in this ExceptionList object.
      abstract TypeCode item(int index)
      Returns the TypeCode object at the given index.
      abstract void remove(int index)
      Removes the TypeCode object at the given index.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ExceptionList

        public ExceptionList()

    • 方法详细信息

      • count

        public abstract int count()
        Retrieves the number of TypeCode objects in this ExceptionList object.
        返回：
        the number of TypeCode objects in this ExceptionList object

      • add

        public abstract void add(TypeCode exc)
        Adds a TypeCode object describing an exception to this ExceptionList object.
        参数：
        exc - the TypeCode object to be added

      • item

        public abstract TypeCode item(int index)
                       throws Bounds
        Returns the TypeCode object at the given index. The first item is at index 0.
        参数：
        index - the index of the TypeCode object desired. This must be an int between 0 and the number of TypeCode objects minus one, inclusive.
        返回：
        the TypeCode object at the given index
        抛出：
        Bounds - if the index given is greater than or equal to the number of TypeCode objects in this ExceptionList object

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the TypeCode object at the given index. Note that the indices of all the TypeCoded objects following the one deleted are shifted down by one.
        参数：
        index - the index of the TypeCode object to be removed. This must be an int between 0 and the number of TypeCode objects minus one, inclusive.
        抛出：
        Bounds - if the index is greater than or equal to the number of TypeCode objects in this ExceptionList object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ad/g/.d....//...r<< tt lsiu TVceOonprs


FieldNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 FieldNameHelper

  • java.lang.Object
    • org.omg.CORBA.FieldNameHelper

  • public abstract class FieldNameHelper
extends Object
    The Helper for FieldName. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/FieldNameHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      FieldNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FieldNameHelper

        public FieldNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

apy.s.k.l.eipla=ptll=w{d )) a s dsC


FixedHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 FixedHolder

  • java.lang.Object
    • org.omg.CORBA.FixedHolder
  • 所有已实现的接口：
    Streamable

    public final class FixedHolder
extends Object
implements Streamable
    The Holder for Fixed. For more information on Holder files, see "Generated Files: Holder Files".

    FixedHolder is a container class for values of IDL type "fixed", which is mapped to the Java class java.math.BigDecimal. It is usually used to store "out" and "inout" IDL method parameters. If an IDL method signature has a fixed as an "out" or "inout" parameter, the programmer must pass an instance of FixedHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the contained value corresponding to the "out" value returned from the server.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      BigDecimal value
      The value held by the FixedHolder

    • 构造方法摘要

      Constructors
      构造方法与描述
      FixedHolder()
      Construct the FixedHolder without initializing the contained value.
      FixedHolder(BigDecimal initial)
      Construct the FixedHolder and initialize it with the given value.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Read a fixed point value from the input stream and store it in the value member.
      TypeCode _type()
      Return the TypeCode of this holder object.
      void _write(OutputStream output)
      Write the fixed point value stored in this holder to an OutputStream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public BigDecimal value
        The value held by the FixedHolder

    • 构造方法详细信息

      • FixedHolder

        public FixedHolder()
        Construct the FixedHolder without initializing the contained value.

      • FixedHolder

        public FixedHolder(BigDecimal initial)
        Construct the FixedHolder and initialize it with the given value.
        参数：
        initial - the value used to initialize the FixedHolder

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Read a fixed point value from the input stream and store it in the value member.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the fixed point value stored in this holder to an OutputStream.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this holder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.noilitigi ro steSnti赶>s=p/leg//eirt/L�


FloatHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 FloatHolder

  • java.lang.Object
    • org.omg.CORBA.FloatHolder
  • 所有已实现的接口：
    Streamable

    public final class FloatHolder
extends Object
implements Streamable
    The Holder for Float. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a float that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL float as an "out" or "inout" parameter, the programmer must pass an instance of FloatHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myFloatHolder is an instance of FloatHolder, the value stored in its value field can be accessed with myFloatHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      float value
      The float value held by this FloatHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      FloatHolder()
      Constructs a new FloatHolder object with its value field initialized to 0.0.
      FloatHolder(float initial)
      Constructs a new FloatHolder object for the given float.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Read a float from an input stream and initialize the value member with the float value.
      TypeCode _type()
      Return the TypeCode of this Streamable.
      void _write(OutputStream output)
      Write the float value into an output stream.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public float value
        The float value held by this FloatHolder object.

    • 构造方法详细信息

      • FloatHolder

        public FloatHolder()
        Constructs a new FloatHolder object with its value field initialized to 0.0.

      • FloatHolder

        public FloatHolder(float initial)
        Constructs a new FloatHolder object for the given float.
        参数：
        initial - the float with which to initialize the value field of the new FloatHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Read a float from an input stream and initialize the value member with the float value.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream to read from.

      • _write

        public void _write(OutputStream output)
        Write the float value into an output stream.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream to write into.

      • _type

        public TypeCode _type()
        Return the TypeCode of this Streamable.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l uiu"uuu/>纓i<.t.enRB娩詉e间�<觧l


FloatSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 FloatSeqHelper

  • java.lang.Object
    • org.omg.CORBA.FloatSeqHelper

  • public abstract class FloatSeqHelper
extends Object
    The Helper for FloatSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/FloatSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      FloatSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static float[] | extract(Any a)
      static String | id()
      static void | insert(Any a, float[] that)
      static float[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, float[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FloatSeqHelper

        public FloatSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          float[] that)

      • extract

        public static float[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static float[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         float[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!a-rtm_om_rbb_rrnallo_-t< frm_"aaiis


FloatSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 FloatSeqHolder

  • java.lang.Object
    • org.omg.CORBA.FloatSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class FloatSeqHolder
extends Object
implements Streamable
    The Holder for FloatSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/FloatSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      float[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      FloatSeqHolder()
      FloatSeqHolder(float[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public float[] value

    • 构造方法详细信息

      • FloatSeqHolder

        public FloatSeqHolder()

      • FloatSeqHolder

        public FloatSeqHolder(float[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

idt"p""m"/Sbmia給nn ci"萻slep"ompaaoonel> o"


FREE_MEM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 FREE_MEM

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.FREE_MEM
  • 所有已实现的接口：
    Serializable

    public final class FREE_MEM
extends SystemException
    Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      FREE_MEM()
      Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      FREE_MEM(int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified minor code and completion status.
      FREE_MEM(String s)
      Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      FREE_MEM(String s, int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FREE_MEM

        public FREE_MEM()
        Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • FREE_MEM

        public FREE_MEM(String s)
        Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • FREE_MEM

        public FREE_MEM(int minor,
        CompletionStatus completed)
        Constructs a FREE_MEM exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • FREE_MEM

        public FREE_MEM(String s,
        int minor,
        CompletionStatus completed)
        Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ek fPffcferncene篈Ahtg>brrsg.灰贷黵蟖�


IdentifierHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 IdentifierHelper

  • java.lang.Object
    • org.omg.CORBA.IdentifierHelper

  • public abstract class IdentifierHelper
extends Object
    The Helper for Identifier. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/IdentifierHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:42 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      IdentifierHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IdentifierHelper

        public IdentifierHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p=aBgBoBsBR""ABBgnttsual"== ie>>"=Rrs


IDLType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface IDLType

  • All Superinterfaces:
    IDLEntity, IDLTypeOperations, IRObject, IRObjectOperations, Object, Serializable
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IDLType
extends IDLTypeOperations, IRObject, IDLEntity
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types. It provides access to the TypeCode object describing the type and is used in defining the other interfaces wherever definitions of IDLType must be referenced.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.IDLTypeOperations

        type

      • 方法 - 继承于接口 org.omg.CORBA.IRObjectOperations

        def_kind, destroy

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/<.anstbstaiitaaip>>ya(e==-o


IDLTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 IDLTypeHelper

  • java.lang.Object
    • org.omg.CORBA.IDLTypeHelper

  • public abstract class IDLTypeHelper
extends Object
    The Helper for IDLType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/IDLTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      IDLTypeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static IDLType | extract(Any a)
      static String | id()
      static void | insert(Any a, IDLType that)
      static IDLType | narrow(Object obj)
      static IDLType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, IDLType value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IDLTypeHelper

        public IDLTypeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          IDLType that)

      • extract

        public static IDLType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IDLType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         IDLType value)

      • narrow

        public static IDLType narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.stAtwtctsmxceix.rrl>|bos;�>nt


IDLTypeOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface IDLTypeOperations

  • All Superinterfaces:
    IRObjectOperations
    All Known Subinterfaces:
    IDLType
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IDLTypeOperations
extends IRObjectOperations
    This interface must be implemented by all IDLType objects. The IDLType is inherited by all IR objects that represent IDL types, including interfaces, typedefs, and anonymous types.
    另请参见：
    IDLType, IRObject, IRObjectOperations

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TypeCode type()
      The type attribute describes the type defined by an object derived from IDLType.

      • 方法 - 继承于接口 org.omg.CORBA.IRObjectOperations

        def_kind, destroy

    • 方法详细信息

      • type

        TypeCode type()
        The type attribute describes the type defined by an object derived from IDLType.
        返回：
        the TypeCode defined by this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>4hhtb hlciaa>e


_IDLTypeStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 _IDLTypeStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA._IDLTypeStub
  • 所有已实现的接口：
    Serializable, IDLType, IDLTypeOperations, IRObject, IRObjectOperations, Object, IDLEntity

    public class _IDLTypeStub
extends ObjectImpl
implements IDLType
    The Stub for IDLType. For more information on Stub files, see "Generated Files: Stubs".

    org/omg/CORBA/_IDLTypeStub.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl. 03 June 1999 11:33:44 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      _IDLTypeStub()
      Constructs a default _IDLTypeStub object.
      _IDLTypeStub(Delegate delegate)
      Constructs an _IDLTypeStub object initialized with the given Delegate object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      DefinitionKind def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      void destroy()
      Destroys this object.
      TypeCode type()
      The type attribute describes the type defined by an object derived from IDLType.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _IDLTypeStub

        public _IDLTypeStub()
        Constructs a default _IDLTypeStub object. NOTE: If the default constructor is used, the object is useless until the method _set_delegate has been called.

      • _IDLTypeStub

        public _IDLTypeStub(Delegate delegate)
        Constructs an _IDLTypeStub object initialized with the given Delegate object.
        参数：
        delegate - a Delegate object

    • 方法详细信息

      • type

        public TypeCode type()
        从接口复制的描述： IDLTypeOperations
        The type attribute describes the type defined by an object derived from IDLType.
        指定者：
        type in interface IDLTypeOperations
        返回：
        the TypeCode defined by this object.

      • def_kind

        public DefinitionKind def_kind()
        从接口复制的描述： IRObjectOperations
        Returns the DefinitionKind corresponding to this Interface Repository object.
        指定者：
        def_kind in interface IRObjectOperations
        返回：
        the DefinitionKind corresponding to this Interface Repository object.

      • destroy

        public void destroy()
        从接口复制的描述： IRObjectOperations
        Destroys this object. If the object is a Container, this method is applied to all its contents. If the object contains an IDLType attribute for an anonymous type, that IDLType is destroyed. If the object is currently contained in some other object, it is removed. If the method is invoked on a Repository or on a PrimitiveDef then the BAD_INV_ORDER exception is raised with minor value 2. An attempt to destroy an object that would leave the repository in an incoherent state causes BAD_INV_ORDER exception to be raised with the minor code 1.
        指定者：
        destroy in interface IRObjectOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tihll=ifcaalcaC秗aa


IMP_LIMIT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 IMP_LIMIT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.IMP_LIMIT
  • 所有已实现的接口：
    Serializable

    public final class IMP_LIMIT
extends SystemException
    This exception indicates that an implementation limit was exceeded in the ORB run time. For example, an ORB may reach the maximum number of references it can hold simultaneously in an address space, the size of a parameter may have exceeded the allowed maximum, or an ORB may impose a maximum on the number of clients or servers that can run simultaneously.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      IMP_LIMIT()
      Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      IMP_LIMIT(int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified minor code and completion status.
      IMP_LIMIT(String s)
      Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      IMP_LIMIT(String s, int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • IMP_LIMIT

        public IMP_LIMIT()
        Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • IMP_LIMIT

        public IMP_LIMIT(String s)
        Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • IMP_LIMIT

        public IMP_LIMIT(int minor,
         CompletionStatus completed)
        Constructs an IMP_LIMIT exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • IMP_LIMIT

        public IMP_LIMIT(String s,
         int minor,
         CompletionStatus completed)
        Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hl,a asadakondsawn,g褂筰"い� �..<>>e 0


INITIALIZE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INITIALIZE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INITIALIZE
  • 所有已实现的接口：
    Serializable

    public final class INITIALIZE
extends SystemException
    Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INITIALIZE()
      Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.
      INITIALIZE(int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified minor code and completion status.
      INITIALIZE(String s)
      Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
      INITIALIZE(String s, int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INITIALIZE

        public INITIALIZE()
        Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.

      • INITIALIZE

        public INITIALIZE(String s)
        Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INITIALIZE

        public INITIALIZE(int minor,
          CompletionStatus completed)
        Constructs an INITIALIZE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status of the method that threw this exception

      • INITIALIZE

        public INITIALIZE(String s,
          int minor,
          CompletionStatus completed)
        Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status of the method that threw this exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ie hyhoh h/l l iuu auu/>=>>t�.rx=�


INTERNAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INTERNAL

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INTERNAL
  • 所有已实现的接口：
    Serializable

    public final class INTERNAL
extends SystemException
    This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section meaning of minor codes to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INTERNAL()
      Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INTERNAL(int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified minor code and completion status.
      INTERNAL(String s)
      Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INTERNAL(String s, int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INTERNAL

        public INTERNAL()
        Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INTERNAL

        public INTERNAL(String s)
        Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INTERNAL

        public INTERNAL(int minor,
        CompletionStatus completed)
        Constructs an INTERNAL exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus that indicates the completion status of the method that threw this exception

      • INTERNAL

        public INTERNAL(String s,
        int minor,
        CompletionStatus completed)
        Constructs an INTERNAL exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus that indicates the completion status of the method that threw this exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<<&gsg>gFgn舶�&sa8ne;瞓&b88n1rgl>op-hau


INTF_REPOS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INTF_REPOS

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INTF_REPOS
  • 所有已实现的接口：
    Serializable

    public final class INTF_REPOS
extends SystemException
    Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INTF_REPOS()
      Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INTF_REPOS(int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified minor code and completion status.
      INTF_REPOS(String s)
      Constructs an INTF_REPOS exception with the specified detail.
      INTF_REPOS(String s, int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INTF_REPOS

        public INTF_REPOS()
        Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INTF_REPOS

        public INTF_REPOS(String s)
        Constructs an INTF_REPOS exception with the specified detail.
        参数：
        s - the String containing a detail message

      • INTF_REPOS

        public INTF_REPOS(int minor,
          CompletionStatus completed)
        Constructs an INTF_REPOS exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • INTF_REPOS

        public INTF_REPOS(String s,
          int minor,
          CompletionStatus completed)
        Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.,non noneaionsp殊�


IntHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 IntHolder

  • java.lang.Object
    • org.omg.CORBA.IntHolder
  • 所有已实现的接口：
    Streamable

    public final class IntHolder
extends Object
implements Streamable
    The Holder for Int. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for an int that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL long as an "out" or "inout" parameter, the programmer must pass an instance of IntHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myIntHolder is an instance of IntHolder, the value stored in its value field can be accessed with myIntHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      int value
      The int value held by this IntHolder object in its value field.

    • 构造方法摘要

      Constructors
      构造方法与描述
      IntHolder()
      Constructs a new IntHolder object with its value field initialized to 0.
      IntHolder(int initial)
      Constructs a new IntHolder object with its value field initialized to the given int.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
      void _write(OutputStream output)
      Marshals the value in this IntHolder object's value field to the output stream output.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public int value
        The int value held by this IntHolder object in its value field.

    • 构造方法详细信息

      • IntHolder

        public IntHolder()
        Constructs a new IntHolder object with its value field initialized to 0.

      • IntHolder

        public IntHolder(int initial)
        Constructs a new IntHolder object with its value field initialized to the given int.
        参数：
        initial - the int with which to initialize the value field of the newly-created IntHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream object containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals the value in this IntHolder object's value field to the output stream output.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream object that will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
        指定者：
        _type in interface Streamable
        返回：
        the type code for the value held in this IntHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ph.>>>>d>iild&sl |=vsk b>pi eshl se


INV_FLAG

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INV_FLAG

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_FLAG
  • 所有已实现的接口：
    Serializable

    public final class INV_FLAG
extends SystemException
    Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INV_FLAG()
      Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_FLAG(int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified minor code and completion status.
      INV_FLAG(String s)
      Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_FLAG(String s, int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INV_FLAG

        public INV_FLAG()
        Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_FLAG

        public INV_FLAG(String s)
        Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INV_FLAG

        public INV_FLAG(int minor,
        CompletionStatus completed)
        Constructs an INV_FLAG exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status

      • INV_FLAG

        public INV_FLAG(String s,
        int minor,
        CompletionStatus completed)
        Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - an instance of CompletionStatus indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

evn v J m Eoumean.怂lntd/drro..me/coals


INV_IDENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INV_IDENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_IDENT
  • 所有已实现的接口：
    Serializable

    public final class INV_IDENT
extends SystemException
    This exception indicates that an IDL identifier is syntactically invalid. It may be raised if, for example, an identifier passed to the interface repository does not conform to IDL identifier syntax, or if an illegal operation name is used with the DII.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INV_IDENT()
      Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_IDENT(int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified minor code and completion status.
      INV_IDENT(String s)
      Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_IDENT(String s, int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INV_IDENT

        public INV_IDENT()
        Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_IDENT

        public INV_IDENT(String s)
        Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INV_IDENT

        public INV_IDENT(int minor,
         CompletionStatus completed)
        Constructs an INV_IDENT exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - a CompletionStatus object indicating the completion status

      • INV_IDENT

        public INV_IDENT(String s,
         int minor,
         CompletionStatus completed)
        Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - a CompletionStatus object indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

shblbkbab<>


INV_OBJREF

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INV_OBJREF

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_OBJREF
  • 所有已实现的接口：
    Serializable

    public final class INV_OBJREF
extends SystemException
    This exception indicates that an object reference is internally malformed. For example, the repository ID may have incorrect syntax or the addressing information may be invalid. This exception is raised by ORB::string_to_object if the passed string does not decode correctly. An ORB may choose to detect calls via nil references (but is not obliged to do detect them). INV_OBJREF is used to indicate this.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INV_OBJREF()
      Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INV_OBJREF(int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified minor code and completion status.
      INV_OBJREF(String s)
      Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_OBJREF(String s, int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INV_OBJREF

        public INV_OBJREF()
        Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INV_OBJREF

        public INV_OBJREF(String s)
        Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INV_OBJREF

        public INV_OBJREF(int minor,
          CompletionStatus completed)
        Constructs an INV_OBJREF exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - a CompletionStatus instance indicating the completion status

      • INV_OBJREF

        public INV_OBJREF(String s,
          int minor,
          CompletionStatus completed)
        Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - a CompletionStatus instance indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ecrea epedeopedm低酮r m.mop纄a�>=嫉�


INV_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INV_POLICY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INV_POLICY
  • 所有已实现的接口：
    Serializable

    public final class INV_POLICY
extends SystemException
    Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation. It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INV_POLICY()
      Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      INV_POLICY(int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified minor code and completion status.
      INV_POLICY(String s)
      Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      INV_POLICY(String s, int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INV_POLICY

        public INV_POLICY()
        Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • INV_POLICY

        public INV_POLICY(String s)
        Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • INV_POLICY

        public INV_POLICY(int minor,
          CompletionStatus completed)
        Constructs a INV_POLICY exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • INV_POLICY

        public INV_POLICY(String s,
          int minor,
          CompletionStatus completed)
        Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p,o/t/"/e//ureptrt F=TETMMRTB ==A lA>


INVALID_ACTIVITY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INVALID_ACTIVITY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INVALID_ACTIVITY
  • 所有已实现的接口：
    Serializable

    public final class INVALID_ACTIVITY
extends SystemException
    The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended. It is also raised when an attempted invocation is made that is incompatible with the Activity's current state.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INVALID_ACTIVITY()
      Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
      INVALID_ACTIVITY(String detailMessage)
      Constructs an INVALID_ACTIVITY exception with the specified message.
      INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY()
        Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(String detailMessage)
        Constructs an INVALID_ACTIVITY exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(int minorCode,
                CompletionStatus completionStatus)
        Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • INVALID_ACTIVITY

        public INVALID_ACTIVITY(String detailMessage,
                int minorCode,
                CompletionStatus completionStatus)
        Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"b>dcdrdld_til"oitff//&>fa;>n


INVALID_TRANSACTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 INVALID_TRANSACTION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.INVALID_TRANSACTION
  • 所有已实现的接口：
    Serializable

    public final class INVALID_TRANSACTION
extends SystemException
    Exception thrown when the request carried an invalid transaction context. For example, this exception could be raised if an error occurred when trying to register a resource.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      INVALID_TRANSACTION()
      Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
      INVALID_TRANSACTION(int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
      INVALID_TRANSACTION(String s)
      Constructs an INVALID_TRANSACTION exception with the specified detail message.
      INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION()
        Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(String s)
        Constructs an INVALID_TRANSACTION exception with the specified detail message.
        参数：
        s - the String containing a detail message

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(int minor,
                   CompletionStatus completed)
        Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • INVALID_TRANSACTION

        public INVALID_TRANSACTION(String s,
                   int minor,
                   CompletionStatus completed)
        Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        s - the String containing a detail message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oE=-j======= D=-aaet


IRObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface IRObject

  • All Superinterfaces:
    IDLEntity, IRObjectOperations, Object, Serializable
    All Known Subinterfaces:
    IDLType
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IRObject
extends IRObjectOperations, Object, IDLEntity
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.IRObjectOperations

        def_kind, destroy

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=rrp>>ePaan(tna#.v


IRObjectOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface IRObjectOperations

  • All Known Subinterfaces:
    IDLType, IDLTypeOperations, IRObject
    All Known Implementing Classes:
    _IDLTypeStub

    public interface IRObjectOperations
    This is the Operations interface for the mapping from IRObject. Several interfaces are used as base interfaces for objects in the Interface Repository (IR). These base interfaces are not instantiable. A common set of operations is used to locate objects within the Interface Repository. Some of these operations are defined in the IRObject. All IR objects inherit from the IRObject interface, which provides an operation for identifying the actual type of the object. (The IDL base interface IRObject represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.) All java implementations of IR objects must implement the IRObjectOperations interface.
    另请参见：
    IDLTypeOperations, IDLType, IRObject

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DefinitionKind def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      void destroy()
      Destroys this object.

    • 方法详细信息

      • def_kind

        DefinitionKind def_kind()
        Returns the DefinitionKind corresponding to this Interface Repository object.
        返回：
        the DefinitionKind corresponding to this Interface Repository object.

      • destroy

        void destroy()
        Destroys this object. If the object is a Container, this method is applied to all its contents. If the object contains an IDLType attribute for an anonymous type, that IDLType is destroyed. If the object is currently contained in some other object, it is removed. If the method is invoked on a Repository or on a PrimitiveDef then the BAD_INV_ORDER exception is raised with minor value 2. An attempt to destroy an object that would leave the repository in an incoherent state causes BAD_INV_ORDER exception to be raised with the minor code 1.
        抛出：
        BAD_INV_ORDER - if this method is invoked on a repository or PrimitiveDef, or if an attempt to destroy an object would leave the repository in an incoherent state
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

==s >i < l Lnna


LocalObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LocalObject

  • java.lang.Object
    • org.omg.CORBA.LocalObject
  • 所有已实现的接口：
    Object

    public class LocalObject
extends Object
implements Object

    Used as a base class for implementation of a local IDL interface in the Java language mapping. It is a class which implements all the operations in the org.omg.CORBA.Object interface.

    Local interfaces are implemented by using CORBA::LocalObject to provide implementations of Object pseudo operations and any other ORB-specific support mechanisms that are appropriate for such objects. Object implementation techniques are inherently language-mapping specific. Therefore, the LocalObject type is not defined in IDL, but is specified in each language mapping.

    Methods that do not apply to local objects throw an org.omg.CORBA.NO_IMPLEMENT exception with the message, "This is a locally contrained object." Attempting to use a LocalObject to create a DII request results in NO_IMPLEMENT system exception. Attempting to marshal or stringify a LocalObject results in a MARSHAL system exception. Narrowing and widening references to LocalObjects must work as for regular object references.

    LocalObject is to be used as the base class of locally constrained objects, such as those in the PortableServer module. The specification here is based on the CORBA Components Volume I - orbos/99-07-01

    另请参见：
    CORBA package comments for unimplemented features

    • 构造方法摘要

      Constructors
      构造方法与描述
      LocalObject()
      Constructs a default LocalObject instance.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _duplicate()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      DomainManager[] _get_domain_managers()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object _get_interface_def()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _get_interface()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Policy _get_policy(int policy_type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      int _hash(int maximum)
      Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum.
      InputStream _invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      boolean _is_a(String repository_id)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      boolean _is_equivalent(Object that)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean _is_local()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      boolean _non_existent()
      Always returns false.
      ORB _orb()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _release()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _releaseReply(InputStream input)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request _request(String operation)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      OutputStream _request(String operation, boolean responseExpected)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void _servant_postinvoke(ServantObject servant)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      ServantObject _servant_preinvoke(String operation, 类 expectedType)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      boolean validate_connection()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocalObject

        public LocalObject()
        Constructs a default LocalObject instance.

    • 方法详细信息

      • _is_equivalent

        public boolean _is_equivalent(Object that)

        Determines whether the two object references are equivalent, so far as the ORB can easily determine. Two object references are equivalent if they are identical. Two distinct object references which in fact refer to the same object are also equivalent. However, ORBs are not required to attempt determination of whether two distinct object references refer to the same object, since such determination could be impractically expensive.

        Default implementation of the org.omg.CORBA.Object method.

        指定者：
        _is_equivalent in interface Object
        参数：
        that - the object reference with which to check for equivalence
        返回：
        true if this object reference is known to be equivalent to the given object reference. Note that false indicates only that the two object references are distinct, not necessarily that they reference distinct objects.

      • _non_existent

        public boolean _non_existent()
        Always returns false. This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _non_existent in interface Object
        返回：
        false

      • _hash

        public int _hash(int maximum)
        Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum. This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _hash in interface Object
        参数：
        maximum - an int identifying maximum value of the hashcode
        返回：
        this instance's hashcode

      • _is_a

        public boolean _is_a(String repository_id)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _is_a in interface Object
        参数：
        repository_id - a String
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _duplicate

        public Object _duplicate()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _duplicate in interface Object
        返回：
        a duplicate of this LocalObject instance.
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _release

        public void _release()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _release in interface Object
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _request

        public Request _request(String operation)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _request in interface Object
        参数：
        operation - a String giving the name of an operation to be performed by the request that is returned
        返回：
        a Request object with the given operation
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _create_request

        public Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _create_request in interface Object
        参数：
        ctx - a Context object containing a list of properties
        operation - the String representing the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        返回：
        a new Request object initialized with the given arguments
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _create_request

        public Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result,
                      ExceptionList exceptions,
                      ContextList contexts)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _create_request in interface Object
        参数：
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        exceptions - an ExceptionList object containing a list of possible exceptions the method can throw
        contexts - a ContextList object containing a list of context strings that need to be resolved and sent with the Request instance
        返回：
        the new Request object initialized with the given arguments
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _get_interface

        public Object _get_interface()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _get_interface_def

        public Object _get_interface_def()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _get_interface_def in interface Object
        返回：
        the InterfaceDef object in the Interface Repository which provides type information about the object referred to by this object reference
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _orb

        public ORB _orb()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        返回：
        the ORB instance that created the Delegate contained in this ObjectImpl
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _get_policy

        public Policy _get_policy(int policy_type)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _get_policy in interface Object
        参数：
        policy_type - an int
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _get_domain_managers

        public DomainManager[] _get_domain_managers()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        指定者：
        _get_domain_managers in interface Object
        返回：
        the list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _set_policy_override

        public Object _set_policy_override(Policy[] policies,
                          SetOverrideType set_add)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.
        指定者：
        _set_policy_override in interface Object
        参数：
        policies - an array
        set_add - a flag
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _is_local

        public boolean _is_local()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Returns true for this LocalObject instance.

        返回：
        true always
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _servant_preinvoke

        public ServantObject _servant_preinvoke(String operation,
                               类 expectedType)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        参数：
        operation - a String indicating which operation to preinvoke
        expectedType - the class of the type of operation mentioned above
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local object
        另请参见：
        CORBA package comments for unimplemented features

      • _servant_postinvoke

        public void _servant_postinvoke(ServantObject servant)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        参数：
        servant - the servant object on which to post-invoke
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • _request

        public OutputStream _request(String operation,
                    boolean responseExpected)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Called by a stub to obtain an OutputStream for marshaling arguments. The stub must supply the operation name, and indicate if a response is expected (i.e is this a oneway call).

        参数：
        operation - the name of the operation being requested
        responseExpected - true if a response is expected, false if it is a one-way call
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _invoke

        public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        Called to invoke an operation. The stub provides an OutputStream that was previously returned by a _request() call. _invoke returns an InputStream which contains the marshaled reply. If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.

        参数：
        output - the OutputStream to invoke
        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        ApplicationException - If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        RemarshalException - If an exception occurs, _invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features

      • _releaseReply

        public void _releaseReply(InputStream input)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

        May optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed. The stub passes the InputStream returned by _invoke() or ApplicationException.getInputStream(). A null value may also be passed to _releaseReply, in which case the method is a no-op.

        参数：
        input - the reply stream back to the ORB or null
        抛出：
        NO_IMPLEMENT
        另请参见：
        CORBA package comments for unimplemented features

      • validate_connection

        public boolean validate_connection()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented. This method is the default implementation of the org.omg.CORBA.Object method.

        返回：
        NO_IMPLEMENT because this is a locally constrained object and this method does not apply to local objects
        抛出：
        NO_IMPLEMENT - because this is a locally constrained object and this method does not apply to local objects
        另请参见：
        CORBA package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LongHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LongHolder

  • java.lang.Object
    • org.omg.CORBA.LongHolder
  • 所有已实现的接口：
    Streamable

    public final class LongHolder
extends Object
implements Streamable
    The Holder for Long. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a long that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL long long as an "out" or "inout" parameter, the programmer must pass an instance of LongHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myLongHolder is an instance of LongHolder, the value stored in its value field can be accessed with myLongHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      long value
      The long value held by this LongHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LongHolder()
      Constructs a new LongHolder object with its value field initialized to 0.
      LongHolder(long initial)
      Constructs a new LongHolder object with its value field initialized to the given long.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      void _write(OutputStream output)
      Marshals to output the value in the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public long value
        The long value held by this LongHolder object.

    • 构造方法详细信息

      • LongHolder

        public LongHolder()
        Constructs a new LongHolder object with its value field initialized to 0.

      • LongHolder

        public LongHolder(long initial)
        Constructs a new LongHolder object with its value field initialized to the given long.
        参数：
        initial - the long with which to initialize the value field of the newly-created LongHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in the Holder.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/ieARC/RC/OOC//g.<


LongLongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LongLongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.LongLongSeqHelper

  • public abstract class LongLongSeqHelper
extends Object
    The Helper for LongLongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/LongLongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      LongLongSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static long[] | extract(Any a)
      static String | id()
      static void | insert(Any a, long[] that)
      static long[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, long[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LongLongSeqHelper

        public LongLongSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          long[] that)

      • extract

        public static long[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static long[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         long[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i NVTAVTTOOTTTO= ii =F ==<==


LongLongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LongLongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.LongLongSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class LongLongSeqHolder
extends Object
implements Streamable
    The Holder for LongLongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/LongLongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      long[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      LongLongSeqHolder()
      LongLongSeqHolder(long[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public long[] value

    • 构造方法详细信息

      • LongLongSeqHolder

        public LongLongSeqHolder()

      • LongLongSeqHolder

        public LongLongSeqHolder(long[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=s=-v-#-=--il�<>>a�/i


LongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.LongSeqHelper

  • public abstract class LongSeqHelper
extends Object
    The Helper for LongSeqHelper. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/LongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      LongSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int[] | extract(Any a)
      static String | id()
      static void | insert(Any a, int[] that)
      static int[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LongSeqHelper

        public LongSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int[] that)

      • extract

        public static int[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa < a < ><< >>>>nnd.e.cee蔵e>fll.sl


LongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 LongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.LongSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class LongSeqHolder
extends Object
implements Streamable
    The Holder for LongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/LongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      int[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      LongSeqHolder()
      LongSeqHolder(int[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public int[] value

    • 构造方法详细信息

      • LongSeqHolder

        public LongSeqHolder()

      • LongSeqHolder

        public LongSeqHolder(int[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

8&渔觭�>御 x99&瞐93o011 r,e 0,,八a税o>


MARSHAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 MARSHAL

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.MARSHAL
  • 所有已实现的接口：
    Serializable

    public final class MARSHAL
extends SystemException
    A request or reply from the network is structurally invalid. This error typically indicates a bug in either the client-side or server-side run time. For example, if a reply from the server indicates that the message contains 1000 bytes, but the actual message is shorter or longer than 1000 bytes, the ORB raises this exception. MARSHAL can also be caused by using the DII or DSI incorrectly, for example, if the type of the actual parameters sent does not agree with IDL signature of an operation.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      MARSHAL()
      Constructs a MARSHAL exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      MARSHAL(int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified minor code and completion status.
      MARSHAL(String s)
      Constructs a MARSHAL exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      MARSHAL(String s, int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • MARSHAL

        public MARSHAL()
        Constructs a MARSHAL exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • MARSHAL

        public MARSHAL(String s)
        Constructs a MARSHAL exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description of the exception

      • MARSHAL

        public MARSHAL(int minor,
       CompletionStatus completed)
        Constructs a MARSHAL exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • MARSHAL

        public MARSHAL(String s,
       int minor,
       CompletionStatus completed)
        Constructs a MARSHAL exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ap k_kkvan>avaEcvaattan>a薳a.s./mme萴


NamedValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 NamedValue

  • java.lang.Object
    • org.omg.CORBA.NamedValue

  • public abstract class NamedValue
extends Object
    An object used in the DII and DSI to describe arguments and return values. NamedValue objects are also used in the Context object routines to pass lists of property names and values.

    A NamedValue object contains:

    • a name -- If the NamedValue object is used to describe arguments to a request, the name will be an argument identifier specified in the OMG IDL interface definition for the operation being described.
    • a value -- an Any object
    • an argument mode flag -- one of the following:
      • ARG_IN.value
      • ARG_OUT.value
      • ARG_INOUT.value
      • zero -- if this NamedValue object represents a property in a Context object rather than a parameter or return value

    The class NamedValue has three methods, which access its fields. The following code fragment demonstrates creating a NamedValue object and then accessing its fields:

        ORB orb = ORB.init(args, null);
    String s = "argument_1";
    org.omg.CORBA.Any myAny = orb.create_any();
    myAny.insert_long(12345);
    int in = org.omg.CORBA.ARG_IN.value;

    org.omg.CORBA.NamedValue nv = orb.create_named_value(
        s, myAny, in);
    System.out.println("This nv name is " + nv.name());
    try {
        System.out.println("This nv value is " + nv.value().extract_long());
        System.out.println("This nv flag is " + nv.flags());
    } catch (org.omg.CORBA.BAD_OPERATION b) {
      System.out.println("extract failed");
    }

    If this code fragment were put into a main method, the output would be something like the following:

        This nv name is argument_1
    This nv value is 12345
    This nv flag is 1

    Note that the method value returns an Any object. In order to access the long contained in the Any object, we used the method extract_long.

    从以下版本开始：
    JDK1.2
    另请参见：
    Any, ARG_IN, ARG_INOUT, ARG_OUT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamedValue()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract int flags()
      Retrieves the argument mode flag for this NamedValue object.
      abstract String name()
      Retrieves the name for this NamedValue object.
      abstract Any value()
      Retrieves the value for this NamedValue object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NamedValue

        public NamedValue()

    • 方法详细信息

      • name

        public abstract String name()
        Retrieves the name for this NamedValue object.
        返回：
        a String object representing the name of this NamedValue object

      • value

        public abstract Any value()
        Retrieves the value for this NamedValue object.
        返回：
        an Any object containing the value of this NamedValue object

      • flags

        public abstract int flags()
        Retrieves the argument mode flag for this NamedValue object.
        返回：
        an int representing the argument mode for this NamedValue object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.sgsggn>>gnn/&aa<gulcgc;a7


NameValuePair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NameValuePair

  • java.lang.Object
    • org.omg.CORBA.NameValuePair
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NameValuePair
extends Object
implements IDLEntity
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String id
      The name to be associated with a value by this NameValuePair object.
      Any value
      The value to be associated with a name by this NameValuePair object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameValuePair()
      Constructs an empty NameValuePair object.
      NameValuePair(String __id, Any __value)
      Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • id

        public String id
        The name to be associated with a value by this NameValuePair object.

      • value

        public Any value
        The value to be associated with a name by this NameValuePair object.

    • 构造方法详细信息

      • NameValuePair

        public NameValuePair()
        Constructs an empty NameValuePair object. To associate a name with a value after using this constructor, the fields of this object have to be accessed individually.

      • NameValuePair

        public NameValuePair(String __id,
             Any __value)
        Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.
        参数：
        __id - the name to be associated with the given Any object
        __value - the Any object to be associated with the given name
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t}c c c co" "ee(yllysslyIneImdaaa")


NameValuePairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 NameValuePairHelper

  • java.lang.Object
    • org.omg.CORBA.NameValuePairHelper

  • public abstract class NameValuePairHelper
extends Object
    The Helper for NameValuePair. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/NameValuePairHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameValuePairHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameValuePair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair that)
      static NameValuePair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameValuePairHelper

        public NameValuePairHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameValuePair that)

      • extract

        public static NameValuePair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameValuePair value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g>/o.o/omo/ggroo.e""al8 1bb>evmg31u h


NO_IMPLEMENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NO_IMPLEMENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_IMPLEMENT
  • 所有已实现的接口：
    Serializable

    public final class NO_IMPLEMENT
extends SystemException
    This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists. NO_IMPLEMENT can, for example, be raised by an ORB if a client asks for an object's type definition from the interface repository, but no interface repository is provided by the ORB.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      NO_IMPLEMENT()
      Constructs a NO_IMPLEMENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_IMPLEMENT(int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
      NO_IMPLEMENT(String s)
      Constructs a NO_IMPLEMENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NO_IMPLEMENT

        public NO_IMPLEMENT()
        Constructs a NO_IMPLEMENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_IMPLEMENT

        public NO_IMPLEMENT(String s)
        Constructs a NO_IMPLEMENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description of the exception

      • NO_IMPLEMENT

        public NO_IMPLEMENT(int minor,
            CompletionStatus completed)
        Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
        参数：
        minor - an int specifying the minor code
        completed - a CompletionStatus instance indicating the completion status

      • NO_IMPLEMENT

        public NO_IMPLEMENT(String s,
            int minor,
            CompletionStatus completed)
        Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - an int specifying the minor code
        completed - a CompletionStatus instance indicating the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

it/ㄋè 腥 l


NO_MEMORY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NO_MEMORY

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_MEMORY
  • 所有已实现的接口：
    Serializable

    public final class NO_MEMORY
extends SystemException
    Exception thrown when the ORB run time has run out of memory.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      NO_MEMORY()
      Constructs a NO_MEMORY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_MEMORY(int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified minor code and completion status.
      NO_MEMORY(String s)
      Constructs a NO_MEMORY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_MEMORY(String s, int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NO_MEMORY

        public NO_MEMORY()
        Constructs a NO_MEMORY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_MEMORY

        public NO_MEMORY(String s)
        Constructs a NO_MEMORY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • NO_MEMORY

        public NO_MEMORY(int minor,
         CompletionStatus completed)
        Constructs a NO_MEMORY exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • NO_MEMORY

        public NO_MEMORY(String s,
         int minor,
         CompletionStatus completed)
        Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r-=B=A======= >=A a<>ada==ne-vtbn>a-oN


NO_PERMISSION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NO_PERMISSION

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_PERMISSION
  • 所有已实现的接口：
    Serializable

    public final class NO_PERMISSION
extends SystemException
    Exception thrown when an invocation failed because the caller has insufficient privileges.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      NO_PERMISSION()
      Constructs a NO_PERMISSION exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_PERMISSION(int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified minor code and completion status.
      NO_PERMISSION(String s)
      Constructs a NO_PERMISSION exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_PERMISSION(String s, int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NO_PERMISSION

        public NO_PERMISSION()
        Constructs a NO_PERMISSION exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_PERMISSION

        public NO_PERMISSION(String s)
        Constructs a NO_PERMISSION exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • NO_PERMISSION

        public NO_PERMISSION(int minor,
             CompletionStatus completed)
        Constructs a NO_PERMISSION exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • NO_PERMISSION

        public NO_PERMISSION(String s,
             int minor,
             CompletionStatus completed)
        Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a cododoroldoraemaaa 悬<挡O 客o踩h篴


NO_RESOURCES

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NO_RESOURCES

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_RESOURCES
  • 所有已实现的接口：
    Serializable

    public final class NO_RESOURCES
extends SystemException
    Exception thrown when the ORB has encountered some general resource limitation. For example, the run time may have reached the maximum permissible number of open connections.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      NO_RESOURCES()
      Constructs a NO_RESOURCES exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_RESOURCES(int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified minor code and completion status.
      NO_RESOURCES(String s)
      Constructs a NO_RESOURCES exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_RESOURCES(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NO_RESOURCES

        public NO_RESOURCES()
        Constructs a NO_RESOURCES exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_RESOURCES

        public NO_RESOURCES(String s)
        Constructs a NO_RESOURCES exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • NO_RESOURCES

        public NO_RESOURCES(int minor,
            CompletionStatus completed)
        Constructs a NO_RESOURCES exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • NO_RESOURCES

        public NO_RESOURCES(String s,
            int minor,
            CompletionStatus completed)
        Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"cax/xxlxetml"atl""�默e� art< d/t.


NO_RESPONSE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 NO_RESPONSE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.NO_RESPONSE
  • 所有已实现的接口：
    Serializable

    public final class NO_RESPONSE
extends SystemException
    This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      NO_RESPONSE()
      Constructs a NO_RESPONSE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      NO_RESPONSE(int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified minor code and completion status.
      NO_RESPONSE(String s)
      Constructs a NO_RESPONSE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      NO_RESPONSE(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NO_RESPONSE

        public NO_RESPONSE()
        Constructs a NO_RESPONSE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • NO_RESPONSE

        public NO_RESPONSE(String s)
        Constructs a NO_RESPONSE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • NO_RESPONSE

        public NO_RESPONSE(int minor,
           CompletionStatus completed)
        Constructs a NO_RESPONSE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • NO_RESPONSE

        public NO_RESPONSE(String s,
           int minor,
           CompletionStatus completed)
        Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRoRtRnRD竛bse1sp b-�8s8ss<<3e>�


NVList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 NVList

  • java.lang.Object
    • org.omg.CORBA.NVList

  • public abstract class NVList
extends Object
    A modifiable list containing NamedValue objects.

    The class NVList is used as follows:

    • to describe arguments for a Request object in the Dynamic Invocation Interface and the Dynamic Skeleton Interface
    • to describe context values in a Context object

    Each NamedValue object consists of the following:

    • a name, which is a String object
    • a value, as an Any object
    • an argument mode flag

    An NVList object may be created using one of the following ORB methods:

    1. org.omg.CORBA.ORB.create_list
          org.omg.CORBA.NVList nv = orb.create_list(3);
      The variable nv represents a newly-created NVList object. The argument is a memory-management hint to the orb and does not imply the actual length of the list. If, for example, you want to use an NVList object in a request, and the method being invoked takes three parameters, you might optimize by supplying 3 to the method create_list. Note that the new NVList will not necessarily have a length of 3; it could have a length of 2 or 4, for instance. Note also that you can add any number of NamedValue objects to this list regardless of its original length.

    2. org.omg.CORBA.ORB.create_operation_list
          org.omg.CORBA.NVList nv = orb.create_operation_list(myOperationDef);
      The variable nv represents a newly-created NVList object that contains descriptions of the arguments to the method described in the given OperationDef object.

    The methods in the class NVList all deal with the NamedValue objects in the list. There are three methods for adding a NamedValue object, a method for getting the count of NamedValue objects in the list, a method for retrieving a NamedValue object at a given index, and a method for removing a NamedValue object at a given index.

    从以下版本开始：
    JDK1.2
    另请参见：
    Request, ServerRequest, NamedValue, Context

    • 构造方法摘要

      Constructors
      构造方法与描述
      NVList()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract NamedValue add_item(String item_name, int flags)
      Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
      abstract NamedValue add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      abstract NamedValue add(int flags)
      Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
      abstract int count()
      Returns the number of NamedValue objects that have been added to this NVList object.
      abstract NamedValue item(int index)
      Retrieves the NamedValue object at the given index.
      abstract void remove(int index)
      Removes the NamedValue object at the given index.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NVList

        public NVList()

    • 方法详细信息

      • count

        public abstract int count()
        Returns the number of NamedValue objects that have been added to this NVList object.
        返回：
        an int indicating the number of NamedValue objects in this NVList.

      • add

        public abstract NamedValue add(int flags)
        Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object. The flag can be any one of the argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        参数：
        flags - one of the argument mode flags
        返回：
        the newly-created NamedValue object

      • add_item

        public abstract NamedValue add_item(String item_name,
                  int flags)
        Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object. The flag can be any one of the argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        参数：
        item_name - the name for the new NamedValue object
        flags - one of the argument mode flags
        返回：
        the newly-created NamedValue object

      • add_value

        public abstract NamedValue add_value(String item_name,
                   Any val,
                   int flags)
        Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
        参数：
        item_name - the name for the new NamedValue object
        val - an Any object containing the value for the new NamedValue object
        flags - one of the following argument passing modes: ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value
        返回：
        the newly created NamedValue object

      • item

        public abstract NamedValue item(int index)
                         throws Bounds
        Retrieves the NamedValue object at the given index.
        参数：
        index - the index of the desired NamedValue object, which must be between zero and the length of the list minus one, inclusive. The first item is at index zero.
        返回：
        the NamedValue object at the given index
        抛出：
        Bounds - if the index is greater than or equal to number of NamedValue objects

      • remove

        public abstract void remove(int index)
                     throws Bounds
        Removes the NamedValue object at the given index. Note that the indices of all NamedValue objects following the one removed are shifted down by one.
        参数：
        index - the index of the NamedValue object to be removed, which must be between zero and the length of the list minus one, inclusive. The first item is at index zero.
        抛出：
        Bounds - if the index is greater than or equal to number of NamedValue objects in the list
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s<hre<#r<&a鰎.msi/s=鄌u;>ta=eo


OBJ_ADAPTER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 OBJ_ADAPTER

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.OBJ_ADAPTER
  • 所有已实现的接口：
    Serializable

    public final class OBJ_ADAPTER
extends SystemException
    This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      OBJ_ADAPTER()
      Constructs an OBJ_ADAPTER exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      OBJ_ADAPTER(int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
      OBJ_ADAPTER(String s)
      Constructs an OBJ_ADAPTER exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OBJ_ADAPTER

        public OBJ_ADAPTER()
        Constructs an OBJ_ADAPTER exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • OBJ_ADAPTER

        public OBJ_ADAPTER(String s)
        Constructs an OBJ_ADAPTER exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • OBJ_ADAPTER

        public OBJ_ADAPTER(int minor,
           CompletionStatus completed)
        Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • OBJ_ADAPTER

        public OBJ_ADAPTER(String s,
           int minor,
           CompletionStatus completed)
        Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>iFauaaara/ br>rrr蝌f<"tmtii" ->e 1tngr�


Object

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface Object

  • All Known Subinterfaces:
    AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, DomainManager, DynAny, DynAny, DynAnyFactory, DynArray, DynArray, DynEnum, DynEnum, DynFixed, DynFixed, DynSequence, DynSequence, DynStruct, DynStruct, DynUnion, DynUnion, DynValue, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, ThreadPolicy
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _Remote_Stub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, LocalObject, ObjectImpl, ObjectImpl, Stub

    public interface Object
    The definition for a CORBA object reference.

    A CORBA object reference is a handle for a particular CORBA object implemented by a server. A CORBA object reference identifies the same CORBA object each time the reference is used to invoke a method on the object. A CORBA object may have multiple, distinct object references.

    The org.omg.CORBA.Object interface is the root of the inheritance hierarchy for all CORBA object references in the Java programming language, analogous to java.rmi.Remote for RMI remote objects.

    A CORBA object may be either local or remote. If it is a local object (that is, running in the same VM as the client), invocations may be directly serviced by the object instance, and the object reference could point to the actual instance of the object implementation class. If a CORBA object is a remote object (that is, running in a different VM from the client), the object reference points to a stub (proxy) which uses the ORB machinery to make a remote invocation on the server where the object implementation resides.

    Default implementations of the methods in the interface org.omg.CORBA.Object are provided in the class org.omg.CORBA.portable.ObjectImpl, which is the base class for stubs and object implementations.

    另请参见：
    ObjectImpl

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      Object _duplicate()
      Returns a duplicate of this CORBA object reference.
      DomainManager[] _get_domain_managers()
      Retrieves the DomainManagers of this object.
      Object _get_interface_def()
      Obtains an InterfaceDef for the object implementation referenced by this object reference.
      Policy _get_policy(int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      int _hash(int maximum)
      Returns an ORB-internal identifier for this object reference.
      boolean _is_a(String repositoryIdentifier)
      Checks whether this object is an instance of a class that implements the given interface.
      boolean _is_equivalent(Object other)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean _non_existent()
      Determines whether the server object for this object reference has been destroyed.
      void _release()
      Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released.
      Request _request(String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.

    • 方法详细信息

      • _is_a

        boolean _is_a(String repositoryIdentifier)
        Checks whether this object is an instance of a class that implements the given interface.
        参数：
        repositoryIdentifier - the interface to check against
        返回：
        true if this object reference is an instance of a class that implements the interface; false otherwise

      • _is_equivalent

        boolean _is_equivalent(Object other)
        Determines whether the two object references are equivalent, so far as the ORB can easily determine. Two object references are equivalent if they are identical. Two distinct object references which in fact refer to the same object are also equivalent. However, ORBs are not required to attempt determination of whether two distinct object references refer to the same object, since such determination could be impractically expensive.
        参数：
        other - the other object reference with which to check for equivalence
        返回：
        true if this object reference is known to be equivalent to the given object reference. Note that false indicates only that the two object references are distinct, not necessarily that they reference distinct objects.

      • _non_existent

        boolean _non_existent()
        Determines whether the server object for this object reference has been destroyed.
        返回：
        true if the ORB knows authoritatively that the server object does not exist; false otherwise

      • _hash

        int _hash(int maximum)
        Returns an ORB-internal identifier for this object reference. This is a hash identifier, which does not change during the lifetime of the object reference, and so neither will any hash function of that identifier change. The value returned is not guaranteed to be unique; in other words, another object reference may have the same hash value. If two object references hash differently, then they are distinct object references; however, both may still refer to the same CORBA object.
        参数：
        maximum - the upper bound on the hash value returned by the ORB
        返回：
        the ORB-internal hash identifier for this object reference

      • _duplicate

        Object _duplicate()
        Returns a duplicate of this CORBA object reference. The server object implementation is not involved in creating the duplicate, and the implementation cannot distinguish whether the original object reference or a duplicate was used to make a request.

        Note that this method is not very useful in the Java platform, since memory management is handled by the VM. It is included for compliance with the CORBA APIs.

        The method _duplicate may return this object reference itself.

        返回：
        a duplicate of this object reference or this object reference itself

      • _release

        void _release()
        Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released. Note that the object implementation is not involved in this operation, and other references to the same object are not affected.

      • _get_interface_def

        Object _get_interface_def()
        Obtains an InterfaceDef for the object implementation referenced by this object reference. The InterfaceDef object may be used to introspect on the methods, attributes, and other type information for the object referred to by this object reference.
        返回：
        the InterfaceDef object in the Interface Repository which provides type information about the object referred to by this object reference

      • _request

        Request _request(String operation)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        参数：
        operation - the name of the method to be invoked using the Request instance
        返回：
        the newly-created Request instance

      • _create_request

        Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result)
        Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
        参数：
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        返回：
        the newly-created Request object
        另请参见：
        Request, NVList, NamedValue

      • _create_request

        Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result,
                      ExceptionList exclist,
                      ContextList ctxlist)
        Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
        参数：
        ctx - a Context object containing a list of properties
        operation - the name of the method to be invoked
        arg_list - an NVList containing the actual arguments to the method being invoked
        result - a NamedValue object to serve as a container for the method's return value
        exclist - an ExceptionList object containing a list of possible exceptions the method can throw
        ctxlist - a ContextList object containing a list of context strings that need to be resolved and sent with the Request instance
        返回：
        the newly-created Request object
        另请参见：
        Request, NVList, NamedValue, ExceptionList, ContextList

      • _get_policy

        Policy _get_policy(int policy_type)
        Returns the Policy object of the specified type which applies to this object.
        参数：
        policy_type - the type of policy to be obtained
        返回：
        A Policy object of the type specified by the policy_type parameter
        抛出：
        BAD_PARAM - when the value of policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object

      • _get_domain_managers

        DomainManager[] _get_domain_managers()
        Retrieves the DomainManagers of this object. This allows administration services (and applications) to retrieve the domain managers, and hence the security and other policies applicable to individual objects that are members of the domain.
        返回：
        the list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.

      • _set_policy_override

        Object _set_policy_override(Policy[] policies,
                          SetOverrideType set_add)
        Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
        参数：
        policies - an array of Policy objects containing the policies to be added or to be used as replacements
        set_add - either SetOverrideType.SET_OVERRIDE, indicating that the given policies will replace any existing ones, or SetOverrideType.ADD_OVERRIDE, indicating that the given policies should be added to any existing ones
        返回：
        a new Object with the given policies replacing or added to those in this Object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


OBJECT_NOT_EXIST

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 OBJECT_NOT_EXIST

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.OBJECT_NOT_EXIST
  • 所有已实现的接口：
    Serializable

    public final class OBJECT_NOT_EXIST
extends SystemException
    Exception raised whenever an invocation on a deleted object was performed. It is an authoritative "hard" fault report. Anyone receiving it is allowed (even expected) to delete all copies of this object reference and to perform other appropriate "final recovery" style procedures. Bridges forward this exception to clients, also destroying any records they may hold (for example, proxy objects used in reference translation). The clients could in turn purge any of their own data structures.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    从以下版本开始：
    JDK1.2
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      OBJECT_NOT_EXIST()
      Constructs an OBJECT_NOT_EXIST exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
      OBJECT_NOT_EXIST(String s)
      Constructs an OBJECT_NOT_EXIST exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
      OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST()
        Constructs an OBJECT_NOT_EXIST exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(String s)
        Constructs an OBJECT_NOT_EXIST exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a description message

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(int minor,
                CompletionStatus completed)
        Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • OBJECT_NOT_EXIST

        public OBJECT_NOT_EXIST(String s,
                int minor,
                CompletionStatus completed)
        Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ecreaeeepedeopedm低蚾r/oo.mmpoea�>丶A地


ObjectHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ObjectHelper

  • java.lang.Object
    • org.omg.CORBA.ObjectHelper

  • public abstract class ObjectHelper
extends Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Object | extract(Any a)
      static String | id()
      static void | insert(Any a, Object that)
      static Object | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Object value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectHelper

        public ObjectHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Object that)

      • extract

        public static Object extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Object read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Object value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l,eoftc tcneecnniaoor vrreytiyv) ssar


ObjectHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ObjectHolder

  • java.lang.Object
    • org.omg.CORBA.ObjectHolder
  • 所有已实现的接口：
    Streamable

    public final class ObjectHolder
extends Object
implements Streamable
    The Holder for Object. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a CORBA object reference (a value of type org.omg.CORBA.Object). It is usually used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has a CORBA Object reference as an "out" or "inout" parameter, the programmer must pass an instance of ObjectHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myObjectHolder is an instance of ObjectHolder, the value stored in its value field can be accessed with myObjectHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object value
      The Object value held by this ObjectHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectHolder()
      Constructs a new ObjectHolder object with its value field initialized to null.
      ObjectHolder(Object initial)
      Constructs a new ObjectHolder object with its value field initialized to the given Object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ObjectHolder object
      void _write(OutputStream output)
      Marshals to output the value in this ObjectHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Object value
        The Object value held by this ObjectHolder object.

    • 构造方法详细信息

      • ObjectHolder

        public ObjectHolder()
        Constructs a new ObjectHolder object with its value field initialized to null.

      • ObjectHolder

        public ObjectHolder(Object initial)
        Constructs a new ObjectHolder object with its value field initialized to the given Object.
        参数：
        initial - the Object with which to initialize the value field of the newly-created ObjectHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ObjectHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ObjectHolder object
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this ObjectHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u


OctetSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 OctetSeqHelper

  • java.lang.Object
    • org.omg.CORBA.OctetSeqHelper

  • public abstract class OctetSeqHelper
extends Object
    The Helper for OctetSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/OctetSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      OctetSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static byte[] | extract(Any a)
      static String | id()
      static void | insert(Any a, byte[] that)
      static byte[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, byte[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OctetSeqHelper

        public OctetSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          byte[] that)

      • extract

        public static byte[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static byte[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         byte[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/=a>.tmhtmmaammme.rrrtwortt ->--rtia.


OctetSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 OctetSeqHolder

  • java.lang.Object
    • org.omg.CORBA.OctetSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class OctetSeqHolder
extends Object
implements Streamable
    The Holder for OctetSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/OctetSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      byte[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      OctetSeqHolder()
      OctetSeqHolder(byte[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public byte[] value

    • 构造方法详细信息

      • OctetSeqHolder

        public OctetSeqHolder()

      • OctetSeqHolder

        public OctetSeqHolder(byte[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pn:fafritfeiutp/n.pp因"鈏忖 <裔"�>o.mo蘲r�>o/


OMGVMCID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface OMGVMCID

  • public interface OMGVMCID
    The vendor minor code ID reserved for OMG. Minor codes for the standard exceptions are prefaced by the VMCID assigned to OMG, defined as the constant OMGVMCID, which, like all VMCIDs, occupies the high order 20 bits.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The vendor minor code ID reserved for OMG.

    • 字段详细信息

      • value

        static final int value
        The vendor minor code ID reserved for OMG. This value is or'd with the high order 20 bits of the minor code to produce the minor value in a system exception.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

akmcsts tsrhhsrrksddthtl"i.Rab<


ORB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ORB

  • java.lang.Object
    • org.omg.CORBA.ORB
  • 直接已知子类：
    ORB

    public abstract class ORB
extends Object
    A class providing APIs for the CORBA Object Request Broker features. The ORB class also provides "pluggable ORB implementation" APIs that allow another vendor's ORB implementation to be used.

    An ORB makes it possible for CORBA objects to communicate with each other by connecting objects making requests (clients) with objects servicing requests (servers).

    The ORB class, which encapsulates generic CORBA functionality, does the following: (Note that items 5 and 6, which include most of the methods in the class ORB, are typically used with the Dynamic Invocation Interface (DII) and the Dynamic Skeleton Interface (DSI). These interfaces may be used by a developer directly, but most commonly they are used by the ORB internally and are not seen by the general programmer.)

    1. initializes the ORB implementation by supplying values for predefined properties and environmental parameters
    2. obtains initial object references to services such as the NameService using the method resolve_initial_references
    3. converts object references to strings and back
    4. connects the ORB to a servant (an instance of a CORBA object implementation) and disconnects the ORB from a servant
    5. creates objects such as
      • TypeCode
      • Any
      • NamedValue
      • Context
      • Environment
      • lists (such as NVList) containing these objects
    6. sends multiple messages in the DII

    The ORB class can be used to obtain references to objects implemented anywhere on the network.

    An application or applet gains access to the CORBA environment by initializing itself into an ORB using one of three init methods. Two of the three methods use the properties (associations of a name with a value) shown in the table below.

    Property Name | Property Value
    Standard Java CORBA Properties:
    org.omg.CORBA.ORBClass | class name of an ORB implementation
    org.omg.CORBA.ORBSingletonClass | class name of the ORB returned by init()

    These properties allow a different vendor's ORB implementation to be "plugged in."

    When an ORB instance is being created, the class name of the ORB implementation is located using the following standard search order:

    1. check in Applet parameter or application string array, if any
    2. check in properties parameter, if any
    3. check in the System properties
    4. check in the orb.properties file located in the user.home directory (if any)
    5. check in the orb.properties file located in the java.home/lib directory (if any)
    6. fall back on a hardcoded default behavior (use the Java IDL implementation)

    Note that Java IDL provides a default implementation for the fully-functional ORB and for the Singleton ORB. When the method init is given no parameters, the default Singleton ORB is returned. When the method init is given parameters but no ORB class is specified, the Java IDL ORB implementation is returned.

    The following code fragment creates an ORB object initialized with the default ORB Singleton. This ORB has a restricted implementation to prevent malicious applets from doing anything beyond creating typecodes. It is called a singleton because there is only one instance for an entire virtual machine.

        ORB orb = ORB.init();

    The following code fragment creates an ORB object for an application. The parameter args represents the arguments supplied to the application's main method. Since the property specifies the ORB class to be "SomeORBImplementation", the new ORB will be initialized with that ORB implementation. If p had been null, and the arguments had not specified an ORB class, the new ORB would have been initialized with the default Java IDL implementation.

        Properties p = new Properties();
    p.put("org.omg.CORBA.ORBClass", "SomeORBImplementation");
    ORB orb = ORB.init(args, p);

    The following code fragment creates an ORB object for the applet supplied as the first parameter. If the given applet does not specify an ORB class, the new ORB will be initialized with the default Java IDL implementation.

        ORB orb = ORB.init(myApplet, null);

    An application or applet can be initialized in one or more ORBs. ORB initialization is a bootstrap call into the CORBA world.

    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      ORB()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void connect(Object obj)
      Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
      TypeCode create_abstract_interface_tc(String id, String name)
      Create a TypeCode object for an IDL abstract interface.
      abstract TypeCode create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract Any create_any()
      Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
      abstract TypeCode create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      DynAny create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract ContextList create_context_list()
      Creates an empty ContextList object.
      DynAny create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract TypeCode create_enum_tc(String id, String name, String[] members)
      Creates a TypeCode object representing an IDL enum.
      abstract Environment create_environment()
      Creates an Environment object.
      abstract ExceptionList create_exception_list()
      Creates an empty ExceptionList object.
      abstract TypeCode create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      TypeCode create_fixed_tc(short digits, short scale)
      Create a TypeCode object for an IDL fixed type.
      abstract TypeCode create_interface_tc(String id, String name)
      Creates a TypeCode object representing an IDL 接口.
      abstract NVList create_list(int count)
      Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
      abstract NamedValue create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      TypeCode create_native_tc(String id, String name)
      Create a TypeCode object for an IDL native type.
      NVList create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      abstract OutputStream create_output_stream()
      Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
      Policy create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      abstract TypeCode create_recursive_sequence_tc(int bound, int offset)
      Deprecated.
      Use a combination of create_recursive_tc and create_sequence_tc instead
      TypeCode create_recursive_tc(String id)
      Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
      abstract TypeCode create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode create_string_tc(int bound)
      Creates a TypeCode object representing a bounded IDL string.
      abstract TypeCode create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      abstract TypeCode create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract TypeCode create_wstring_tc(int bound)
      Creates a TypeCode object representing a bounded IDL wstring (wide string).
      void destroy()
      Destroys the ORB so that its resources can be reclaimed.
      void disconnect(Object obj)
      Disconnects the given servant object from the ORB.
      Current get_current()
      Deprecated.
      use resolve_initial_references.
      abstract Context get_default_context()
      Gets the default Context object.
      abstract Request get_next_response()
      Gets the next Request instance for which a response has been received.
      abstract TypeCode get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.
      boolean get_service_information(short service_type, ServiceInformationHolder service_info)
      Used to obtain information about CORBA facilities and services that are supported by this ORB.
      static ORB init()
      Returns the ORB singleton object.
      static ORB init(Applet app, Properties props)
      Creates a new ORB instance for an applet.
      static ORB init(String[] args, Properties props)
      Creates a new ORB instance for a standalone application.
      abstract String[] list_initial_services()
      Returns a list of the initially available CORBA object references, such as "NameService" and "InterfaceRepository".
      abstract String object_to_string(Object obj)
      Converts the given CORBA object reference to a string.
      void perform_work()
      Performs an implementation-dependent unit of work if called by the main thread.
      abstract boolean poll_next_response()
      Finds out if any of the deferred (asynchronous) invocations have a response yet.
      abstract Object resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
      void run()
      This operation blocks the current thread until the ORB has completed the shutdown process, initiated when some thread calls shutdown.
      abstract void send_multiple_requests_deferred(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously.
      abstract void send_multiple_requests_oneway(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously without expecting any responses.
      protected abstract void set_parameters(Applet app, Properties props)
      Allows the ORB implementation to be initialized with the given applet and parameters.
      protected abstract void set_parameters(String[] args, Properties props)
      Allows the ORB implementation to be initialized with the given parameters and properties.
      void shutdown(boolean wait_for_completion)
      Instructs the ORB to shut down, which causes all object adapters to shut down, in preparation for destruction.
      If the wait_for_completion parameter is true, this operation blocks until all ORB processing (including processing of currently executing requests, object deactivation, and other object adapter operations) has completed.
      abstract Object string_to_object(String str)
      Converts a string produced by the method object_to_string back to a CORBA object reference.
      boolean work_pending()
      Returns true if the ORB needs the main thread to perform some work, and false if the ORB does not need the main thread.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ORB

        public ORB()

    • 方法详细信息

      • init

        public static ORB init()
        Returns the ORB singleton object. This method always returns the same ORB instance, which is an instance of the class described by the org.omg.CORBA.ORBSingletonClass system property.

        This no-argument version of the method init is used primarily as a factory for TypeCode objects, which are used by Helper classes to implement the method type. It is also used to create Any objects that are used to describe union labels (as part of creating a TypeCode object for a union).

        This method is not intended to be used by applets, and in the event that it is called in an applet environment, the ORB it returns is restricted so that it can be used only as a factory for TypeCode objects. Any TypeCode objects it produces can be safely shared among untrusted applets.

        If an ORB is created using this method from an applet, a system exception will be thrown if methods other than those for creating TypeCode objects are invoked.

        返回：
        the singleton ORB

      • init

        public static ORB init(String[] args,
       Properties props)
        Creates a new ORB instance for a standalone application. This method may be called from applications only and returns a new fully functional ORB object each time it is called.
        参数：
        args - command-line arguments for the application's main method; may be null
        props - application-specific properties; may be null
        返回：
        the newly-created ORB instance

      • init

        public static ORB init(Applet app,
       Properties props)
        Creates a new ORB instance for an applet. This method may be called from applets only and returns a new fully-functional ORB object each time it is called.
        参数：
        app - the applet; may be null
        props - applet-specific properties; may be null
        返回：
        the newly-created ORB instance

      • set_parameters

        protected abstract void set_parameters(String[] args,
                  Properties props)
        Allows the ORB implementation to be initialized with the given parameters and properties. This method, used in applications only, is implemented by subclass ORB implementations and called by the appropriate init method to pass in its parameters.
        参数：
        args - command-line arguments for the application's main method; may be null
        props - application-specific properties; may be null

      • set_parameters

        protected abstract void set_parameters(Applet app,
                  Properties props)
        Allows the ORB implementation to be initialized with the given applet and parameters. This method, used in applets only, is implemented by subclass ORB implementations and called by the appropriate init method to pass in its parameters.
        参数：
        app - the applet; may be null
        props - applet-specific properties; may be null

      • connect

        public void connect(Object obj)
        Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB. The servant class must extend the ImplBase class corresponding to the interface that is supported by the server. The servant must thus be a CORBA object reference, and inherit from org.omg.CORBA.Object. Servants created by the user can start receiving remote invocations after the method connect has been called. A servant may also be automatically and implicitly connected to the ORB if it is passed as an IDL parameter in an IDL method invocation on a non-local object, that is, if the servant object has to be marshalled and sent outside of the process address space.

        Calling the method connect has no effect when the servant object is already connected to the ORB.

        Deprecated by the OMG in favor of the Portable Object Adapter APIs.

        参数：
        obj - The servant object reference

      • destroy

        public void destroy()
        Destroys the ORB so that its resources can be reclaimed. Any operation invoked on a destroyed ORB reference will throw the OBJECT_NOT_EXIST exception. Once an ORB has been destroyed, another call to init with the same ORBid will return a reference to a newly constructed ORB.

        If destroy is called on an ORB that has not been shut down, it will start the shut down process and block until the ORB has shut down before it destroys the ORB.
        If an application calls destroy in a thread that is currently servicing an invocation, the BAD_INV_ORDER system exception will be thrown with the OMG minor code 3, since blocking would result in a deadlock.

        For maximum portability and to avoid resource leaks, an application should always call shutdown and destroy on all ORB instances before exiting.

        抛出：
        BAD_INV_ORDER - if the current thread is servicing an invocation

      • disconnect

        public void disconnect(Object obj)
        Disconnects the given servant object from the ORB. After this method returns, the ORB will reject incoming remote requests for the disconnected servant and will send the exception org.omg.CORBA.OBJECT_NOT_EXIST back to the remote client. Thus the object appears to be destroyed from the point of view of remote clients. Note, however, that local requests issued using the servant directly do not pass through the ORB; hence, they will continue to be processed by the servant.

        Calling the method disconnect has no effect if the servant is not connected to the ORB.

        Deprecated by the OMG in favor of the Portable Object Adapter APIs.

        参数：
        obj - The servant object to be disconnected from the ORB

      • list_initial_services

        public abstract String[] list_initial_services()
        Returns a list of the initially available CORBA object references, such as "NameService" and "InterfaceRepository".
        返回：
        an array of String objects that represent the object references for CORBA services that are initially available with this ORB

      • resolve_initial_references

        public abstract Object resolve_initial_references(String object_name)
                                           throws InvalidName
        Resolves a specific object reference from the set of available initial service names.
        参数：
        object_name - the name of the initial service as a string
        返回：
        the object reference associated with the given name
        抛出：
        InvalidName - if the given name is not associated with a known service

      • object_to_string

        public abstract String object_to_string(Object obj)
        Converts the given CORBA object reference to a string. Note that the format of this string is predefined by IIOP, allowing strings generated by a different ORB to be converted back into an object reference.

        The resulting String object may be stored or communicated in any way that a String object can be manipulated.

        参数：
        obj - the object reference to stringify
        返回：
        the string representing the object reference

      • string_to_object

        public abstract Object string_to_object(String str)
        Converts a string produced by the method object_to_string back to a CORBA object reference.
        参数：
        str - the string to be converted back to an object reference. It must be the result of converting an object reference to a string using the method object_to_string.
        返回：
        the object reference

      • create_list

        public abstract NVList create_list(int count)
        Allocates an NVList with (probably) enough space for the specified number of NamedValue objects. Note that the specified size is only a hint to help with storage allocation and does not imply the maximum size of the list.
        参数：
        count - suggested number of NamedValue objects for which to allocate space
        返回：
        the newly-created NVList
        另请参见：
        NVList

      • create_operation_list

        public NVList create_operation_list(Object oper)
        Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object. This OperationDef object is obtained from an Interface Repository. The arguments in the returned NVList object are in the same order as in the original IDL operation definition, which makes it possible for the list to be used in dynamic invocation requests.
        参数：
        oper - the OperationDef object to use to create the list
        返回：
        a newly-created NVList object containing descriptions of the arguments to the method described in the given OperationDef object
        另请参见：
        NVList

      • create_named_value

        public abstract NamedValue create_named_value(String s,
                            Any any,
                            int flags)
        Creates a NamedValue object using the given name, value, and argument mode flags.

        A NamedValue object serves as (1) a parameter or return value or (2) a context property. It may be used by itself or as an element in an NVList object.

        参数：
        s - the name of the NamedValue object
        any - the Any value to be inserted into the NamedValue object
        flags - the argument mode flags for the NamedValue: one of ARG_IN.value, ARG_OUT.value, or ARG_INOUT.value.
        返回：
        the newly-created NamedValue object
        另请参见：
        NamedValue

      • create_exception_list

        public abstract ExceptionList create_exception_list()
        Creates an empty ExceptionList object.
        返回：
        the newly-created ExceptionList object

      • create_context_list

        public abstract ContextList create_context_list()
        Creates an empty ContextList object.
        返回：
        the newly-created ContextList object
        另请参见：
        ContextList, Context

      • get_default_context

        public abstract Context get_default_context()
        Gets the default Context object.
        返回：
        the default Context object
        另请参见：
        Context

      • create_environment

        public abstract Environment create_environment()
        Creates an Environment object.
        返回：
        the newly-created Environment object
        另请参见：
        Environment

      • create_output_stream

        public abstract OutputStream create_output_stream()
        Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
        返回：
        the newly-created org.omg.CORBA.portable.OutputStream object

      • send_multiple_requests_oneway

        public abstract void send_multiple_requests_oneway(Request[] req)
        Sends multiple dynamic (DII) requests asynchronously without expecting any responses. Note that oneway invocations are not guaranteed to reach the server.
        参数：
        req - an array of request objects

      • send_multiple_requests_deferred

        public abstract void send_multiple_requests_deferred(Request[] req)
        Sends multiple dynamic (DII) requests asynchronously.
        参数：
        req - an array of Request objects

      • poll_next_response

        public abstract boolean poll_next_response()
        Finds out if any of the deferred (asynchronous) invocations have a response yet.
        返回：
        true if there is a response available; false otherwise

      • get_next_response

        public abstract Request get_next_response()
                                   throws WrongTransaction
        Gets the next Request instance for which a response has been received.
        返回：
        the next Request object ready with a response
        抛出：
        WrongTransaction - if the method get_next_response is called from a transaction scope different from the one from which the original request was sent. See the OMG Transaction Service specification for details.

      • get_primitive_tc

        public abstract TypeCode get_primitive_tc(TCKind tcKind)
        Retrieves the TypeCode object that represents the given primitive IDL type.
        参数：
        tcKind - the TCKind instance corresponding to the desired primitive type
        返回：
        the requested TypeCode object

      • create_struct_tc

        public abstract TypeCode create_struct_tc(String id,
                        String name,
                        StructMember[] members)
        Creates a TypeCode object representing an IDL struct. The TypeCode object is initialized with the given id, name, and members.
        参数：
        id - the repository id for the struct
        name - the name of the struct
        members - an array describing the members of the struct
        返回：
        a newly-created TypeCode object describing an IDL struct

      • create_union_tc

        public abstract TypeCode create_union_tc(String id,
                       String name,
                       TypeCode discriminator_type,
                       UnionMember[] members)
        Creates a TypeCode object representing an IDL union. The TypeCode object is initialized with the given id, name, discriminator type, and members.
        参数：
        id - the repository id of the union
        name - the name of the union
        discriminator_type - the type of the union discriminator
        members - an array describing the members of the union
        返回：
        a newly-created TypeCode object describing an IDL union

      • create_enum_tc

        public abstract TypeCode create_enum_tc(String id,
                      String name,
                      String[] members)
        Creates a TypeCode object representing an IDL enum. The TypeCode object is initialized with the given id, name, and members.
        参数：
        id - the repository id for the enum
        name - the name for the enum
        members - an array describing the members of the enum
        返回：
        a newly-created TypeCode object describing an IDL enum

      • create_alias_tc

        public abstract TypeCode create_alias_tc(String id,
                       String name,
                       TypeCode original_type)
        Creates a TypeCode object representing an IDL alias (typedef). The TypeCode object is initialized with the given id, name, and original type.
        参数：
        id - the repository id for the alias
        name - the name for the alias
        original_type - the TypeCode object describing the original type for which this is an alias
        返回：
        a newly-created TypeCode object describing an IDL alias

      • create_exception_tc

        public abstract TypeCode create_exception_tc(String id,
                           String name,
                           StructMember[] members)
        Creates a TypeCode object representing an IDL exception. The TypeCode object is initialized with the given id, name, and members.
        参数：
        id - the repository id for the exception
        name - the name for the exception
        members - an array describing the members of the exception
        返回：
        a newly-created TypeCode object describing an IDL exception

      • create_interface_tc

        public abstract TypeCode create_interface_tc(String id,
                           String name)
        Creates a TypeCode object representing an IDL 接口. The TypeCode object is initialized with the given id and name.
        参数：
        id - the repository id for the interface
        name - the name for the interface
        返回：
        a newly-created TypeCode object describing an IDL 接口

      • create_string_tc

        public abstract TypeCode create_string_tc(int bound)
        Creates a TypeCode object representing a bounded IDL string. The TypeCode object is initialized with the given bound, which represents the maximum length of the string. Zero indicates that the string described by this type code is unbounded.
        参数：
        bound - the bound for the string; cannot be negative
        返回：
        a newly-created TypeCode object describing a bounded IDL string
        抛出：
        BAD_PARAM - if bound is a negative value

      • create_wstring_tc

        public abstract TypeCode create_wstring_tc(int bound)
        Creates a TypeCode object representing a bounded IDL wstring (wide string). The TypeCode object is initialized with the given bound, which represents the maximum length of the wide string. Zero indicates that the string described by this type code is unbounded.
        参数：
        bound - the bound for the wstring; cannot be negative
        返回：
        a newly-created TypeCode object describing a bounded IDL wstring
        抛出：
        BAD_PARAM - if bound is a negative value

      • create_sequence_tc

        public abstract TypeCode create_sequence_tc(int bound,
                          TypeCode element_type)
        Creates a TypeCode object representing an IDL sequence. The TypeCode object is initialized with the given bound and element type.
        参数：
        bound - the bound for the sequence, 0 if unbounded
        element_type - the TypeCode object describing the elements contained in the sequence
        返回：
        a newly-created TypeCode object describing an IDL sequence

      • create_recursive_sequence_tc

        @Deprecated
public abstract TypeCode create_recursive_sequence_tc(int bound,
                                               int offset)
        Deprecated. Use a combination of create_recursive_tc and create_sequence_tc instead
        Creates a TypeCode object representing a a recursive IDL sequence.

        For the IDL struct Node in following code fragment, the offset parameter for creating its sequence would be 1:

            Struct Node {
        long value;
        Sequence <Node> subnodes;
    };
        参数：
        bound - the bound for the sequence, 0 if unbounded
        offset - the index to the enclosing TypeCode object that describes the elements of this sequence
        返回：
        a newly-created TypeCode object describing a recursive sequence
        另请参见：
        create_recursive_tc, create_sequence_tc

      • create_array_tc

        public abstract TypeCode create_array_tc(int length,
                       TypeCode element_type)
        Creates a TypeCode object representing an IDL array. The TypeCode object is initialized with the given length and element type.
        参数：
        length - the length of the array
        element_type - a TypeCode object describing the type of element contained in the array
        返回：
        a newly-created TypeCode object describing an IDL array

      • create_native_tc

        public TypeCode create_native_tc(String id,
                        String name)
        Create a TypeCode object for an IDL native type.
        参数：
        id - the logical id for the native type.
        name - the name of the native type.
        返回：
        the requested TypeCode.

      • create_abstract_interface_tc

        public TypeCode create_abstract_interface_tc(String id,
                                    String name)
        Create a TypeCode object for an IDL abstract interface.
        参数：
        id - the logical id for the abstract interface type.
        name - the name of the abstract interface type.
        返回：
        the requested TypeCode.

      • create_fixed_tc

        public TypeCode create_fixed_tc(short digits,
                       short scale)
        Create a TypeCode object for an IDL fixed type.
        参数：
        digits - specifies the total number of decimal digits in the number and must be from 1 to 31 inclusive.
        scale - specifies the position of the decimal point.
        返回：
        the requested TypeCode.

      • create_value_tc

        public TypeCode create_value_tc(String id,
                       String name,
                       short type_modifier,
                       TypeCode concrete_base,
                       ValueMember[] members)
        Create a TypeCode object for an IDL value type. The concrete_base parameter is the TypeCode for the immediate concrete valuetype base of the valuetype for which the TypeCode is being created. It may be null if the valuetype does not have a concrete base.
        参数：
        id - the logical id for the value type.
        name - the name of the value type.
        type_modifier - one of the value type modifier constants: VM_NONE, VM_CUSTOM, VM_ABSTRACT or VM_TRUNCATABLE
        concrete_base - a TypeCode object describing the concrete valuetype base
        members - an array containing the members of the value type
        返回：
        the requested TypeCode

      • create_recursive_tc

        public TypeCode create_recursive_tc(String id)
        Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion. The id parameter specifies the repository id of the type for which the recursive TypeCode is serving as a placeholder. Once the recursive TypeCode has been properly embedded in the enclosing TypeCode which corresponds to the specified repository id, it will function as a normal TypeCode. Invoking operations on the recursive TypeCode before it has been embedded in the enclosing TypeCode will result in a BAD_TYPECODE exception.

        For example, the following IDL type declaration contains recursion:

            Struct Node {
        Sequence<Node> subnodes;
    };

        To create a TypeCode for struct Node, you would invoke the TypeCode creation operations as shown below:

         String nodeID = "IDL:Node:1.0";
 TypeCode recursiveSeqTC = orb.create_sequence_tc(0, orb.create_recursive_tc(nodeID));
 StructMember[] members = { new StructMember("subnodes", recursiveSeqTC, null) };
 TypeCode structNodeTC = orb.create_struct_tc(nodeID, "Node", members);

        Also note that the following is an illegal IDL type declaration:

            Struct Node {
        Node next;
    };

        Recursive types can only appear within sequences which can be empty. That way marshaling problems, when transmitting the struct in an Any, are avoided.

        参数：
        id - the logical id of the referenced type
        返回：
        the requested TypeCode

      • create_value_box_tc

        public TypeCode create_value_box_tc(String id,
                           String name,
                           TypeCode boxed_type)
        Creates a TypeCode object for an IDL value box.
        参数：
        id - the logical id for the value type
        name - the name of the value type
        boxed_type - the TypeCode for the type
        返回：
        the requested TypeCode

      • create_any

        public abstract Any create_any()
        Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
        返回：
        a newly-created Any object

      • get_current

        @Deprecated
public Current get_current()
        Deprecated. use resolve_initial_references.
        Retrieves a Current object. The Current interface is used to manage thread-specific information for use by services such as transactions and security.
        返回：
        a newly-created Current object
        另请参见：
        CORBA package comments for unimplemented features

      • run

        public void run()
        This operation blocks the current thread until the ORB has completed the shutdown process, initiated when some thread calls shutdown. It may be used by multiple threads which get all notified when the ORB shuts down.

      • shutdown

        public void shutdown(boolean wait_for_completion)
        Instructs the ORB to shut down, which causes all object adapters to shut down, in preparation for destruction.
        If the wait_for_completion parameter is true, this operation blocks until all ORB processing (including processing of currently executing requests, object deactivation, and other object adapter operations) has completed. If an application does this in a thread that is currently servicing an invocation, the BAD_INV_ORDER system exception will be thrown with the OMG minor code 3, since blocking would result in a deadlock.
        If the wait_for_completion parameter is FALSE, then shutdown may not have completed upon return.

        While the ORB is in the process of shutting down, the ORB operates as normal, servicing incoming and outgoing requests until all requests have been completed. Once an ORB has shutdown, only object reference management operations may be invoked on the ORB or any object reference obtained from it. An application may also invoke the destroy operation on the ORB itself. Invoking any other operation will throw the BAD_INV_ORDER system exception with the OMG minor code 4.

        The ORB.run method will return after shutdown has been called.

        参数：
        wait_for_completion - true if the call should block until the shutdown is complete; false if it should return immediately
        抛出：
        BAD_INV_ORDER - if the current thread is servicing an invocation

      • work_pending

        public boolean work_pending()
        Returns true if the ORB needs the main thread to perform some work, and false if the ORB does not need the main thread.
        返回：
        true if there is work pending, meaning that the ORB needs the main thread to perform some work; false if there is no work pending and thus the ORB does not need the main thread

      • perform_work

        public void perform_work()
        Performs an implementation-dependent unit of work if called by the main thread. Otherwise it does nothing. The methods work_pending and perform_work can be used in conjunction to implement a simple polling loop that multiplexes the main thread among the ORB and other activities.

      • get_service_information

        public boolean get_service_information(short service_type,
                              ServiceInformationHolder service_info)
        Used to obtain information about CORBA facilities and services that are supported by this ORB. The service type for which information is being requested is passed in as the in parameter service_type, the values defined by constants in the CORBA module. If service information is available for that type, that is returned in the out parameter service_info, and the operation returns the value true. If no information for the requested services type is available, the operation returns false (i.e., the service is not supported by this ORB).

        参数：
        service_type - a short indicating the service type for which information is being requested
        service_info - a ServiceInformationHolder object that will hold the ServiceInformation object produced by this method
        返回：
        true if service information is available for the service_type; false if no information for the requested services type is available
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_any

        @Deprecated
public DynAny create_dyn_any(Any value)
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynAny object from the given Any object.

        参数：
        value - the Any object from which to create a new DynAny object
        返回：
        the new DynAny object created from the given Any object
        另请参见：
        CORBA package comments for unimplemented features

      • create_basic_dyn_any

        @Deprecated
public DynAny create_basic_dyn_any(TypeCode type)
                            throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a basic DynAny object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynAny object
        返回：
        the new DynAny object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_struct

        @Deprecated
public DynStruct create_dyn_struct(TypeCode type)
                            throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynStruct object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynStruct object
        返回：
        the new DynStruct object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_sequence

        @Deprecated
public DynSequence create_dyn_sequence(TypeCode type)
                                throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynSequence object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynSequence object
        返回：
        the new DynSequence object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_array

        @Deprecated
public DynArray create_dyn_array(TypeCode type)
                          throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynArray object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynArray object
        返回：
        the new DynArray object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_union

        @Deprecated
public DynUnion create_dyn_union(TypeCode type)
                          throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynUnion object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynUnion object
        返回：
        the new DynUnion object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_dyn_enum

        @Deprecated
public DynEnum create_dyn_enum(TypeCode type)
                        throws InconsistentTypeCode
        Deprecated. Use the new DynAnyFactory API instead
        Creates a new DynEnum object from the given TypeCode object.

        参数：
        type - the TypeCode object from which to create a new DynEnum object
        返回：
        the new DynEnum object created from the given TypeCode object
        抛出：
        InconsistentTypeCode - if the given TypeCode object is not consistent with the operation.
        另请参见：
        CORBA package comments for unimplemented features

      • create_policy

        public Policy create_policy(int type,
                   Any val)
                     throws PolicyError
        Can be invoked to create new instances of policy objects of a specific type with specified initial state. If create_policy fails to instantiate a new Policy object due to its inability to interpret the requested type and content of the policy, it raises the PolicyError exception with the appropriate reason.
        参数：
        type - the PolicyType of the policy object to be created
        val - the value that will be used to set the initial state of the Policy object that is created
        返回：
        Reference to a newly created Policy object of type specified by the type parameter and initialized to a state specified by the val parameter
        抛出：
        org.omg.CORBA.PolicyError - when the requested policy is not supported or a requested initial state for the policy is not supported.
        PolicyError
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


org.omg.CORBA

Interfaces

  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • CTX_RESTRICT_SCOPE
  • Current
  • CurrentOperations
  • CustomMarshal
  • DataInputStream
  • DataOutputStream
  • DomainManager
  • DomainManagerOperations
  • DynAny
  • DynArray
  • DynEnum
  • DynFixed
  • DynSequence
  • DynStruct
  • DynUnion
  • DynValue
  • IDLType
  • IDLTypeOperations
  • IRObject
  • IRObjectOperations
  • Object
  • OMGVMCID
  • Policy
  • PolicyOperations
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_NONE
  • VM_TRUNCATABLE

Classes

  • _IDLTypeStub
  • _PolicyStub
  • Any
  • AnyHolder
  • AnySeqHelper
  • AnySeqHolder
  • BooleanHolder
  • BooleanSeqHelper
  • BooleanSeqHolder
  • ByteHolder
  • CharHolder
  • CharSeqHelper
  • CharSeqHolder
  • CompletionStatus
  • CompletionStatusHelper
  • Context
  • ContextList
  • CurrentHelper
  • CurrentHolder
  • DefinitionKind
  • DefinitionKindHelper
  • DoubleHolder
  • DoubleSeqHelper
  • DoubleSeqHolder
  • DynamicImplementation
  • Environment
  • ExceptionList
  • FieldNameHelper
  • FixedHolder
  • FloatHolder
  • FloatSeqHelper
  • FloatSeqHolder
  • IdentifierHelper
  • IDLTypeHelper
  • IntHolder
  • LocalObject
  • LongHolder
  • LongLongSeqHelper
  • LongLongSeqHolder
  • LongSeqHelper
  • LongSeqHolder
  • NamedValue
  • NameValuePair
  • NameValuePairHelper
  • NVList
  • ObjectHelper
  • ObjectHolder
  • OctetSeqHelper
  • OctetSeqHolder
  • ORB
  • ParameterMode
  • ParameterModeHelper
  • ParameterModeHolder
  • PolicyErrorCodeHelper
  • PolicyErrorHelper
  • PolicyErrorHolder
  • PolicyHelper
  • PolicyHolder
  • PolicyListHelper
  • PolicyListHolder
  • PolicyTypeHelper
  • Principal
  • PrincipalHolder
  • RepositoryIdHelper
  • Request
  • ServerRequest
  • ServiceDetail
  • ServiceDetailHelper
  • ServiceInformation
  • ServiceInformationHelper
  • ServiceInformationHolder
  • SetOverrideType
  • SetOverrideTypeHelper
  • ShortHolder
  • ShortSeqHelper
  • ShortSeqHolder
  • StringHolder
  • StringSeqHelper
  • StringSeqHolder
  • StringValueHelper
  • StructMember
  • StructMemberHelper
  • TCKind
  • TypeCode
  • TypeCodeHolder
  • ULongLongSeqHelper
  • ULongLongSeqHolder
  • ULongSeqHelper
  • ULongSeqHolder
  • UnionMember
  • UnionMemberHelper
  • UnknownUserExceptionHelper
  • UnknownUserExceptionHolder
  • UShortSeqHelper
  • UShortSeqHolder
  • ValueBaseHelper
  • ValueBaseHolder
  • ValueMember
  • ValueMemberHelper
  • VersionSpecHelper
  • VisibilityHelper
  • WCharSeqHelper
  • WCharSeqHolder
  • WrongTransactionHelper
  • WrongTransactionHolder
  • WStringSeqHelper
  • WStringSeqHolder
  • WStringValueHelper

Exceptions

  • ACTIVITY_COMPLETED
  • ACTIVITY_REQUIRED
  • BAD_CONTEXT
  • BAD_INV_ORDER
  • BAD_OPERATION
  • BAD_PARAM
  • BAD_QOS
  • BAD_TYPECODE
  • Bounds
  • CODESET_INCOMPATIBLE
  • COMM_FAILURE
  • DATA_CONVERSION
  • FREE_MEM
  • IMP_LIMIT
  • INITIALIZE
  • INTERNAL
  • INTF_REPOS
  • INV_FLAG
  • INV_IDENT
  • INV_OBJREF
  • INV_POLICY
  • INVALID_ACTIVITY
  • INVALID_TRANSACTION
  • MARSHAL
  • NO_IMPLEMENT
  • NO_MEMORY
  • NO_PERMISSION
  • NO_RESOURCES
  • NO_RESPONSE
  • OBJ_ADAPTER
  • OBJECT_NOT_EXIST
  • PERSIST_STORE
  • PolicyError
  • REBIND
  • SystemException
  • TIMEOUT
  • TRANSACTION_MODE
  • TRANSACTION_REQUIRED
  • TRANSACTION_ROLLEDBACK
  • TRANSACTION_UNAVAILABLE
  • TRANSIENT
  • UNKNOWN
  • UnknownUserException
  • UserException
  • WrongTransaction
R


org.omg.CORBA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA

Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

请参见： 描述

  • 接口摘要
    接口 描述
    ARG_IN
    Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server.
    ARG_INOUT
    Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client.
    ARG_OUT
    A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client.
    BAD_POLICY
    A PolicyErrorCode which would be filled in the PolicyError exception.
    BAD_POLICY_TYPE
    A PolicyErrorCode which would be filled in the PolicyError exception.
    BAD_POLICY_VALUE
    Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.
    CTX_RESTRICT_SCOPE
    A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user.
    DataInputStream
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
    DataOutputStream
    Defines the methods used to write primitive data types to output streams for marshalling custom value types.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    DomainManagerOperations
    Provides the DomainManager with the means to access policies.
    DynAny Deprecated
    Use the new DynAny instead
    DynArray Deprecated
    Use the new DynArray instead
    DynEnum Deprecated
    Use the new DynEnum instead
    DynFixed Deprecated
    Use the new DynFixed instead
    DynSequence Deprecated
    Use the new DynSequence instead
    DynStruct Deprecated
    Use the new DynStruct instead
    DynUnion Deprecated
    Use the new DynUnion instead
    DynValue Deprecated
    Use the new DynValue instead
    IDLType
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
    IDLTypeOperations
    This interface must be implemented by all IDLType objects.
    IRObject
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
    IRObjectOperations
    This is the Operations interface for the mapping from IRObject.
    Object
    The definition for a CORBA object reference.
    OMGVMCID
    The vendor minor code ID reserved for OMG.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyOperations
    Provides the operations for a Policy object.
    PRIVATE_MEMBER
    Constant to define a private member in the ValueMember class.
    PUBLIC_MEMBER
    Constant to define a public member in the ValueMember class.
    UNSUPPORTED_POLICY
    One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.
    UNSUPPORTED_POLICY_VALUE
    A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.
    VM_ABSTRACT
    Defines the code used to represent an Abstract interface in a typecode.
    VM_CUSTOM
    Defines the code used to represent a custom marshalled value type in a typecode.
    VM_NONE
    Defines the code used to represent the one of the values of a value type in a typecode.
    VM_TRUNCATABLE
    Defines the code used to represent a truncatable value type in a typecode.
  • Class Summary
    类 描述
    _IDLTypeStub
    The Stub for IDLType.
    _PolicyStub
    The Stub for Policy.
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    AnyHolder
    The Holder for Any.
    AnySeqHelper
    The Helper for AnySeq.
    AnySeqHolder
    The Holder for AnySeq.
    BooleanHolder
    The Holder for Boolean.
    BooleanSeqHelper
    The Helper for BooleanSeq.
    BooleanSeqHolder
    The Holder for BooleanSeq.
    ByteHolder
    The Holder for Byte.
    CharHolder
    The Holder for Char.
    CharSeqHelper
    The Helper for CharSeq.
    CharSeqHolder
    The Holder for CharSeq.
    CompletionStatus
    An object that indicates whether a method had completed running when a SystemException was thrown.
    CompletionStatusHelper
    The Helper for CompletionStatus.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    CurrentHelper
    The Helper for Current.
    CurrentHolder
    The Holder for Current.
    DefinitionKind
    The class that provides the constants used to identify the type of an Interface Repository object.
    DefinitionKindHelper
    The Helper for DefinitionKind.
    DoubleHolder
    The Holder for Double.
    DoubleSeqHelper
    The Helper for DoubleSeq.
    DoubleSeqHolder
    The Holder for DoubleSeq.
    DynamicImplementation Deprecated
    org.omg.CORBA.DynamicImplementation
    Environment
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    FieldNameHelper
    The Helper for FieldName.
    FixedHolder
    The Holder for Fixed.
    FloatHolder
    The Holder for Float.
    FloatSeqHelper
    The Helper for FloatSeq.
    FloatSeqHolder
    The Holder for FloatSeq.
    IdentifierHelper
    The Helper for Identifier.
    IDLTypeHelper
    The Helper for IDLType.
    IntHolder
    The Holder for Int.
    LocalObject
    Used as a base class for implementation of a local IDL interface in the Java language mapping.
    LongHolder
    The Holder for Long.
    LongLongSeqHelper
    The Helper for LongLongSeq.
    LongLongSeqHolder
    The Holder for LongLongSeq.
    LongSeqHelper
    The Helper for LongSeqHelper.
    LongSeqHolder
    The Holder for LongSeq.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NameValuePair
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
    NameValuePairHelper
    The Helper for NameValuePair.
    NVList
    A modifiable list containing NamedValue objects.
    ObjectHelper
    ObjectHolder
    The Holder for Object.
    OctetSeqHelper
    The Helper for OctetSeq.
    OctetSeqHolder
    The Holder for OctetSeq.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ParameterMode
    Enumeration of parameter modes for Parameter.
    ParameterModeHelper
    Enumeration of parameter modes for Parameter.
    ParameterModeHolder
    Enumeration of parameter modes for Parameter.
    PolicyErrorCodeHelper
    Encapsulates a reason a Policy may be invalid.
    PolicyErrorHelper
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
    PolicyErrorHolder
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
    PolicyHelper
    The Helper for Policy.
    PolicyHolder
    The Holder for Policy.
    PolicyListHelper
    The Helper for PolicyList.
    PolicyListHolder
    The Holder for PolicyList.
    PolicyTypeHelper
    The Helper for PolicyType.
    Principal Deprecated
    Deprecated by CORBA 2.2.
    PrincipalHolder Deprecated
    Deprecated by CORBA 2.2.
    RepositoryIdHelper
    The Helper for RepositoryId.
    Request
    An object containing the information necessary for invoking a method.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    ServiceDetail
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
    ServiceDetailHelper
    ServiceInformation
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
    ServiceInformationHelper
    ServiceInformationHolder
    The Holder for ServiceInformation.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    SetOverrideTypeHelper
    The Helper for SetOverrideType.
    ShortHolder
    The Holder for Short.
    ShortSeqHelper
    The Helper for ShortSeqHelper.
    ShortSeqHolder
    The Holder for ShortSeq.
    StringHolder
    The Holder for String.
    StringSeqHelper
    An array of Strings
    StringSeqHolder
    An array of Strings
    StringValueHelper
    The Helper for StringValue.
    StructMember
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
    StructMemberHelper
    The Helper for StructMember.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
    TypeCodeHolder
    The Holder for TypeCode.
    ULongLongSeqHelper
    The Helper for ULongLongSeq.
    ULongLongSeqHolder
    The Holder for ULongLongSeq.
    ULongSeqHelper
    The Helper for ULongSeq.
    ULongSeqHolder
    The Holder for ULongSeq.
    UnionMember
    A description in the Interface Repository of a member of an IDL union.
    UnionMemberHelper
    The Helper for UnionMember.
    UnknownUserExceptionHelper
    The Helper for UnknownUserException.
    UnknownUserExceptionHolder
    The Holder for UnknownUserException.
    UShortSeqHelper
    The Helper for UShortSeq.
    UShortSeqHolder
    The Holder for UShortSeq.
    ValueBaseHelper
    ValueBaseHolder
    The Holder for ValueBase.
    ValueMember
    A description in the Interface Repository of a member of a value object.
    ValueMemberHelper
    The Helper for ValueMember.
    VersionSpecHelper
    The Helper for VersionSpec.
    VisibilityHelper
    The Helper for Visibility.
    WCharSeqHelper
    The Helper for WCharSeq.
    WCharSeqHolder
    The Holder for WCharSeq.
    WrongTransactionHelper
    The Helper for WrongTransaction.
    WrongTransactionHolder
    The Holder for WrongTransaction.
    WStringSeqHelper
    An array of WStrings
    WStringSeqHolder
    An array of WStrings
    WStringValueHelper
    org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications : ORB core as defined by CORBA 2.3.1 (formal/99-10-07) IDL/Java Language Mapping as defined in ptc/00-01-08
  • Exception Summary
    Exception 描述
    ACTIVITY_COMPLETED
    The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
    ACTIVITY_REQUIRED
    The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
    BAD_CONTEXT
    Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
    BAD_INV_ORDER
    This exception indicates that the caller has invoked operations in the wrong order.
    BAD_OPERATION
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    BAD_QOS
    The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
    BAD_TYPECODE
    Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
    Bounds
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    CODESET_INCOMPATIBLE
    This exception is raised whenever meaningful communication is not possible between client and server native code sets.
    COMM_FAILURE
    This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
    DATA_CONVERSION
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
    FREE_MEM
    Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
    IMP_LIMIT
    This exception indicates that an implementation limit was exceeded in the ORB run time.
    INITIALIZE
    Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
    INTERNAL
    This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
    INTF_REPOS
    Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
    INV_FLAG
    Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
    INV_IDENT
    This exception indicates that an IDL identifier is syntactically invalid.
    INV_OBJREF
    This exception indicates that an object reference is internally malformed.
    INV_POLICY
    Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
    INVALID_ACTIVITY
    The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
    INVALID_TRANSACTION
    Exception thrown when the request carried an invalid transaction context.
    MARSHAL
    A request or reply from the network is structurally invalid.
    NO_IMPLEMENT
    This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists.
    NO_MEMORY
    Exception thrown when the ORB run time has run out of memory.
    NO_PERMISSION
    Exception thrown when an invocation failed because the caller has insufficient privileges.
    NO_RESOURCES
    Exception thrown when the ORB has encountered some general resource limitation.
    NO_RESPONSE
    This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.
    OBJ_ADAPTER
    This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.
    OBJECT_NOT_EXIST
    Exception raised whenever an invocation on a deleted object was performed.
    PERSIST_STORE
    This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.
    PolicyError
    A user exception thrown when a policy error occurs.
    REBIND
    REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD.
    SystemException
    The root class for all CORBA standard exceptions.
    TIMEOUT
    TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded.
    TRANSACTION_MODE
    The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation).
    TRANSACTION_REQUIRED
    Exception indicates that the request carried a null transaction context, but an active transaction is required.
    TRANSACTION_ROLLEDBACK
    Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back.
    TRANSACTION_UNAVAILABLE
    The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated.
    TRANSIENT
    Exception thrown when the ORB attempted to reach an object and failed.
    UNKNOWN
    This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression.
    UnknownUserException
    A class that contains user exceptions returned by the server.
    UserException
    The root class for CORBA IDL-defined user exceptions.
    WrongTransaction
    The CORBA WrongTransaction user-defined exception.

软件包 org.omg.CORBA Description

Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

For a precise list of supported sections of official CORBA specifications with which the Java[TM] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[TM] SE 6.

General Information

The information in this section is information relevant to someone who compiles Interface Definition Language (IDL) files and uses the ORB to write clients and servers.

The classes and interfaces described in this section can be put into four groups: ORB classes, Exceptions, Helper classes, and Holder classes.

The ORB Class

An ORB handles (or brokers) method invocations between a client and the method's implementation on a server. Because the client and server may be anywhere on a network, and because the invocation and implementation may be written in different programming languages, an ORB does a great deal of work behind the scenes to accomplish this communication.

Most of what an ORB does is completely transparent to the user, and a major portion of the CORBA package consists of classes used by the ORB behind the scenes. The result is that most programmers will use only a small part of this package directly. In fact, most programmers will use only a few methods from the ORB class, some exceptions, and occasionally, a holder class.

ORB Methods

Before an application can enter the CORBA environment, it must first:

  • Be initialized into the ORB and possibly the object adapter (POA) environments.
  • Get references to ORB object (for use in future ORB operations) and perhaps other objects (including the root POA or some Object Adapter objects).

The following operations are provided to initialize applications and obtain the appropriate object references:

  • Operations providing access to the ORB, which are discussed in this section.
  • Operations providing access to Object Adapters, Interface Repository, Naming Service, and other Object Services. These operations are described in Other Classes.

When an application requires a CORBA environment it needs a mechanism to get an ORB object reference and possibly an OA object reference (such as the root POA). This serves two purposes. First, it initializes an application into the ORB and OA environments. Second, it returns the ORB object reference and the OA object reference to the application for use in future ORB and OA operations.

In order to obtain an ORB object reference, applications call the ORB.init operation. The parameters to the call can comprise an identifier for the ORB for which the object reference is required, and an arg_list, which is used to allow environment-specific data to be passed into the call.

These are the ORB methods that provide access to the ORB:

  • init()
  • init(String [] args, Properties props)
  • init(Applet app, Properties props)

Using the init() method without parameters initiates a singleton ORB, which can only give typecode creation anys needed in code generated in Helper classes by idlj.

Applications require a portable means by which to obtain their initial object references. References are required for the root POA, POA Current, Interface Repository, and various Object Services instances. The functionality required by the application is similar to that provided by the Naming Service. However, the OMG does not want to mandate that the Naming Service be made available to all applications in order that they may be portably initialized. Consequently, the operations shown in this section provide a simplified, local version of the Naming Service that applications can use to obtain a small, defined set of object references which are essential to its operation. Because only a small well-defined set of objects are expected with this mechanism, the naming context can be flattened to be a single-level name space. This simplification results in only two operations being defined to achieve the functionality required.

Initial references are obtained via two operations provided in the ORB object interface, providing facilities to list and resolve initial object references. These are:

  • resolve_initial_references(String name)
  • list_initial_services()
  • register_initial_reference(String id, org.omg.CORBA.Object obj)

An example that uses some of these methods is Getting Started with Java IDL.

Exceptions

Exceptions in Java IDL are similar to those in any code written in the Java programming language. If a method is defined to throw an exception, then any code using that method must have a try/catch block and handle that exception when it is thrown.

The documentation on Java IDL exceptions has more information and explains the difference between system exceptions and user-defined exceptions.

The following is a list of the system exceptions (which are unchecked exceptions inheriting through org.omg.CORBA.SystemException from java.lang.RuntimeException) that are defined in the package org.omg.CORBA:

        BAD_CONTEXT
        BAD_INV_ORDER
        BAD_OPERATION
        BAD_PARAM
        BAD_TYPECODE
        COMM_FAILURE
        DATA_CONVERSION
        FREE_MEM
        IMP_LIMIT
        INITIALIZE
        INTERNAL
        INTF_REPOS
        INVALID_TRANSACTION
        INV_FLAG
        INV_IDENT
        INV_OBJREF
        INV_POLICY
        MARSHAL
        NO_IMPLEMENT
        NO_MEMORY
        NO_PERMISSION
        NO_RESOURCES
        NO_RESPONSE
        OBJECT_NOT_EXIST
        OBJ_ADAPTER
        PERSIST_STORE
        TRANSACTION_REQUIRED
        TRANSACTION_ROLLEDBACK
        TRANSIENT
        UNKNOWN

The following is a list of user-defined exceptions defined in the package org.omg.CORBA.

        Bounds
        UnknownUserException
        WrongTransaction
        PolicyError

Subpackages

There are some packages inside the CORBA package with "Package" as part of their names. These packages are generally quite small because all they do is provide exceptions or classes for use by interfaces and classes in the CORBA package.

For example, the package org.omg.CORBA.TypeCodePackage contains two exceptions thrown by methods in the class TypeCode. These exceptions are:

  • BadKind
  • Bounds
The package org.omg.CORBA.ORBPackage contains two exceptions:
  • InvalidName
  • InconsistentTypeCode

Another package that is a subpackage of CORBA is the portable package. It provides a set of ORB APIs that makes it possible for code generated by one vendor's IDL compiler to run on another vendor's ORB.

Holder classes

Support for out and inout parameter passing modes requires the use of additional holder classes. Because the Java programming language does not support out or inout parameters, holder classes are needed as a means of passing a parameter that can be modified. To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

Holder classes are named by appending "Holder" to the name of the type. The name of the type refers to its name in the Java programming language. For example, a holder class for the interface named Account in the Java programming language would be named AccountHolder.

Holder classes are available for all of the basic IDL datatypes in the org.omg.CORBA package. So, for example, there are already-defined classes for LongHolder, ShortHolder, FloatHolder, and so on. Classes are also generated for all named user-defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

Each holder class has:

  • a constructor from an instance
  • a default constructor
  • a public instance member, value which is the typed value.
  • a method for reading an input stream and assigning the contents to the type's value field
  • a method for writing the value of the value field to an output stream
  • a method for getting the typecode of the type

The default constructor sets the value field to the default value for the type as defined by the Java language:

  • false for boolean
  • 0 for numeric and char types
  • null for strings and object references

As an example, if the interface Account, defined in OMG IDL, were mapped to the Java programming language, the following holder class would be generated:

public final class AccountHolder implements
    org.omg.CORBA.portable.Streamable
{
  // field that holds an Account object
  public Account value = null;

  // default constructor
  public AccountHolder ()
  {
  }

  // creates a new AccountHolder from initialValue
  public AccountHolder (Account initialValue)
  {
    value = initialValue;
  }

  // reads the contents of i and assigns the contents to value
  public void _read (org.omg.CORBA.portable.InputStream i)
  {
    value = AccountHelper.read (i);
  }

  // writes value to o
  public void _write (org.omg.CORBA.portable.OutputStream o)
  {
    AccountHelper.write (o, value);
  }

  // returns the typecode for Account
  public org.omg.CORBA.TypeCode _type ()
  {
    return AccountHelper.type ();
  }

}

For more information on Holder classes, see Chapter 1.4, Mapping for Basic Types in the OMG IDL to Java Language Mapping. The Holder classes defined in the package org.omg.CORBA are:

     AnyHolder
     AnySeqHolder
     BooleanHolder
     BooleanSeqHolder
     ByteHolder
     CharHolder
     CharSeqHolder
     CurrentHolder
     DoubleHolder
     DoubleSeqHolder
     FixedHolder
     FloatHolder
     FloatSeqHolder
     IntHolder
     LongHolder
     LongLongSeqHolder
     LongSeqHolder
     ObjectHolder
     OctetSeqHolder
     ParameterModeHolder
     PolicyErrorHolder
     PolicyListHolder
     PrincipalHolder
     ServiceInformationHolder
     ShortHolder
     ShortSeqHolder
     StringHolder
     StringSeqHolder
     TypeCodeHolder
     ULongLongSeqHolder
     ULongSeqHolder
     UnknownUserExceptionHolder
     UShortSeqHolder
     ValueBaseHolder
     WCharSeqHolder
     WrongTransactionHolder
     WStringSeqHolder

Helper Classes

Helper files supply several static methods needed to manipulate the type. These include:

  • Any insert and extract operations for the type
  • getting the repository id
  • getting the typecode
  • reading and writing the type from and to a stream
  • implement the ValueHelper interface (if it is a user-defined value type)

The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA.BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null. Generally, the only helper method an application programmer uses is the narrow method. The other methods are normally used behind the scenes and are transparent to the programmer.

Helper classes fall into two broad categories, helpers for value types and helpers for non value types. Because all of the helper classes in one category provide the same methods, one generic explanation of each category of helper classes is presented here.

When OMG IDL is mapped to the Java programming language, a "helper" class is generated for each user-defined type. This generated class will have the name of the user-defined type with the suffix Helper appended. For example, if the interface Account is defined in OMG IDL, the idlj compiler will automatically generate a class named AccountHelper. The AccountHelper class will contain the static methods needed for manipulating instances of the type, in this case, Account objects.

The narrow Method

When an object is the return value for a method, it is returned in the form of a generic object, either an org.omg.CORBA.Object object or a java.lang.Object object. This object must be cast to its more specific type before it can be operated on. For example, an Account object will be returned as a generic object and must be narrowed to an Account object so that Account methods may be called on it.

The narrow method has two forms, one that takes an org.omg.CORBA.Object object and one that takes a java.lang.Object object. Whether the interface is abstract or not determines which narrow method its helper class will provide. The helper class for an interface that is not abstract will have a narrow method that takes a CORBA object, whereas the narrow method for an interface that is abstract will take an object in the Java programming language. The helper class for a non-abstract interface that has at least one abstract base interface will provide both versions of the narrow method.

The Hello World tutorial uses a narrow method that looks like this:

        // create and initialize the ORB
        ORB orb = ORB.init(args, null);

        // get the root naming context
        org.omg.CORBA.Object objRef =
            orb.resolve_initial_references("NameService");
        // Use NamingContextExt instead of NamingContext. This is
        // part of latest Inter-Operable naming Service.
        NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

        // resolve the Object Reference in Naming
        String name = "Hello";
        helloImpl = HelloHelper.narrow(ncRef.resolve_str(name));

Example of a Basic Helper Class

A basic helper class, for purposes of this explanation, is one with the methods that are provided by every helper class, plus a narrow method if the type defined in OMG IDL maps to an interface in the Java programming language. Types that are not value types will have a basic helper class generated for them.

For example, assuming that the interface Account is not a value type IDL type and is also not an abstract interface and has no abstract base interfaces, its AccountHelper class will look like this:

abstract public class AccountHelper
{
  private static String  _id = "IDL:Account:1.0";

  // inserts an Account object into an Any object
  public static void insert (org.omg.CORBA.Any a, Account that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
    a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // extracts an Account object from an Any object
  public static Account extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  // gets the typecode for this type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      __typeCode = org.omg.CORBA.ORB.init ().create_interface_tc (AccountHelper.id (), "Account");
    }
    return __typeCode;
  }

  // gets the repository id for this type
  public static String id ()
  {
    return _id;
  }

  // reads an Account object from an input stream
  public static Account read (org.omg.CORBA.portable.InputStream istream)
  {
    return narrow (istream.read_Object (_AccountStub.class));
  }

  // writes an Account object to an outputstream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Account value)
  {
    ostream.write_Object ((org.omg.CORBA.Object) value);
  }

  // converts (narrows) an Object to an Account object
  public static Account narrow (org.omg.CORBA.Object obj)
  {
    if (obj == null)
      return null;
    else if (obj instanceof Account)
      return (Account)obj;
    else if (!obj._is_a (id ()))
      throw new org.omg.CORBA.BAD_PARAM ();
    else
    {
      org.omg.CORBA.portable.Delegate delegate = ((org.omg.CORBA.portable.ObjectImpl)obj)._get_delegate ();
      _AccountStub stub = new _AccountStub ();
      stub._set_delegate(delegate);
      return stub;
    }
  }

}

Value Type Helper Classes

A helper class for a value type includes different renderings of the same methods generated for non-value type methods. The main difference is that value types are types that can be passed by value as parameters or return values of a method, which means that they must be serializable.

Assuming that Address is a value type, the AddressHelper class will look like this:

abstract public class AddressHelper
{
  private static String  _id = "IDL:Address:1.0";

  // same as for non-value type
  public static void insert (org.omg.CORBA.Any a, Address that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
    a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // same as for non-value type
  public static Address extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  private static boolean __active = false;

  // getting the typecode for the type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      synchronized (org.omg.CORBA.TypeCode.class)
      {
        if (__typeCode == null)
        {
          if (__active)
          {
            return org.omg.CORBA.ORB.init().create_recursive_tc ( _id );
          }
          __active = true;
          org.omg.CORBA.ValueMember[] _members0 = new org.omg.CORBA.ValueMember[0];
          org.omg.CORBA.TypeCode _tcOf_members0 = null;
          __typeCode = org.omg.CORBA.ORB.init ().create_value_tc (_id, "Address", org.omg.CORBA.VM_NONE.value, null, _members0);
          __active = false;
        }
      }
    }
    return __typeCode;
  }

  // same as for non-value type
  public static String id ()
  {
    return _id;
  }

  // reads a serializable instance of Address from the given input stream
  public static Address read (org.omg.CORBA.portable.InputStream istream)
  {
    return (Address)((org.omg.CORBA_2_3.portable.InputStream) istream).read_value (id ());
  }

  // writes a serializable instance of Address to the given output stream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Address value)
  {
    ((org.omg.CORBA_2_3.portable.OutputStream) ostream).write_value (value, id ());
  }

}

The Helper classes defined in the package org.omg.CORBA are:

     AnySeqHelper
     BooleanSeqHelper
     CharSeqHelper
     CompletionStatusHelper
     CurrentHelper
     DefinitionKindHelper
     DoubleSeqHelper
     FieldNameHelper
     FloatSeqHelper
     IdentifierHelper
     IDLTypeHelper
     LongLongSeqHelper
     LongSeqHelper
     NameValuePairHelper
     ObjectHelper
     OctetSeqHelper
     ParameterModeHelper
     PolicyErrorCodeHelper
     PolicyErrorHelper
     PolicyHelper
     PolicyListHelper
     PolicyTypeHelper
     RepositoryIdHelper
     ServiceDetailHelper
     ServiceInformationHelper
     SetOverrideTypeHelper
     ShortSeqHelper
     StringSeqHelper
     StringValueHelper
     StructMemberHelper
     ULongLongSeqHelper
     ULongSeqHelper
     UnionMemberHelper
     UnknownUserExceptionHelper
     UShortSeqHelper
     ValueBaseHelper
     ValueMemberHelper
     VersionSpecHelper
     VisibilityHelper
     WCharSeqHelper
     WrongTransactionHelper
     WStringSeqHelper
     WStringValueHelper

Other Classes

The other classes and interfaces in the CORBA package, which are used behind the scenes, can be put into four groups. Three of the groups are used with requests in some capacity, and the fourth group, concerning the Interface Repository, is a category by itself.

Classes Created by an ORB

The first group contains classes that are created by an ORB and contain information used in request operations.
  • TCKind -- indicates the kind (datatype) for a TypeCode object
  • TypeCode -- indicates a datatype and possibly other information
  • Any -- contains a value and its typecode
  • NamedValue -- contains a name, an Any object, and an argument mode flag. NamedValue objects contain information about method arguments, method return values, or a context.
  • ContextList -- a list of strings that describe the contexts that need to be resolved and sent with an invocation
  • ExceptionList -- a list of TypeCodes for exceptions that may be thrown by a method
  • Environment -- a container for the exception thrown during a method invocation
  • Context -- a list of NamedValue objects used to pass auxiliary information from client to server
  • NVList -- a list of NamedValue objects, used to pass arguments or get results

Classes That Deal with Requests

The second group of classes deals with requests:
  • Object -- the base class for all CORBA object references
  • Request -- the main class in the DII, which contains methods for adding arguments to the request, for accessing information about the method being invoked (the method name, its arguments, exceptions it throws, and so on), and for making invocations on the request
  • DynamicImplementation -- the base class for server implementations using the DSI. It has the method invoke, which is used by an implementation of this class to determine the state of a ServerRequest object and to set its result or exception
  • ServerRequest -- captures the explicit state of a request for the Dynamic Skeleton Interface

Interfaces That Serve as Constants

The third group contains interfaces that serve as constants. The IDL-to-Java mapping mandates that IDL enums are mapped to a Java class with the enumerated values represented as public static final fields in that class (e.g. DefinitionKind). On the other hand IDL constants defined outside of an IDL interface are mapped to a Java interface for each constant.

This is why several interfaces in the org.omg.CORBA package consist of a single field, value, which is a short. This field is a constant used for such things as an error code or value modifier. For example, the value field of the interface BAD_POLICY is one of the possible reasons for the exception PolicyError to be thrown. To specify this error code, you would use BAD_POLICY.value.

The exception PolicyError uses the value field of the following interfaces as its possible error codes.

  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
The method TypeCode.type_modifier returns the value field of one of the following interfaces. The VM in the names of these interfaces stands for "value modifier."
  • VM_NONE
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_TRUNCATABLE
The following constants are returned by a ValueMember object's access method to denote the visibility of the ValueMember object.
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
These flags, used in NamedValue objects or as parameters to methods, are defined in the following interfaces:
  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • CTX_RESTRICT_SCOPE

Interface Repository Interfaces and Classes

A fourth group contains the Interface Repository interfaces and classes, which are generated by the idlj compiler from the OMG IDL interface ir.idl. The purpose of the Interface Repository is to identify the interfaces stored in it so that they can be accessed by an ORB. Each module, type, interface, attribute, operation, parameter, exception, constant, and so on is described completely by the Interface Repository API.

An ORB does not require that there be an interface repository, and Java IDL does not include one. Even though this release does not include an implementation of an interface repository, the following IR classes and interfaces have been included for the purpose of creating typecodes (see create_value_tc, create_struct_tc, create_union_tc and create_exception_tc methods in interface org.omg.CORBA.ORB):
&nbs

  • IRObject
  • IDLType
  • DefinitionKind
  • StructMember
  • UnionMember
  • ValueMember

Related Documentation

For overviews, guides, and a tutorial, please see:
  • Java IDL home page

CORBA Features Not Implemented in Java IDL

Some of the API included in org.omg subpackages is provided for conformance with the current OMG CORBA specification but is not implemented in Sun's release of the JDKTM. This enables other JDK licensees to provide implementations of this API in standard extensions and products.

Features That Throw NO_IMPLEMENT

Some of the API included in org.omg subpackages throw NO_IMPLEMENT exceptions for various reasons. Among these reasons are:

  • In some cases, for example LocalObject, the complete implementation according to the specification indicates that these API should throw NO_IMPLEMENT.

  • In most cases, for example methods in ORB.java, methods that throw NO_IMPLEMENT are actually implemented in subclasses elsewhere in the ORB code.

  • In some cases, for example _get_interface_def() and _get_interface, API are really not yet implemented.

General Summary of Features or API Not Implemented in This Release:

  • Interface Repository. An Interface Repository is not required for normal operation of Java IDL.
  • Java IDL does not support long double.
  • Policies (org.omg.CORBA.Policy) and methods for getting them are not implemented.
  • Domain managers (org.omg.CORBA.DomainManager) and methods for getting them are not implemented.
  • Service Information org.omg.CORBA.ServiceInformation and ORB method public boolean get_service_information(short service_type, ServiceInformationHolder service_info) are not implemented.
  • ORB methods for supporting single-threading (perform_work, work_pending) are not implemented.
  • IDL contexts.

Specific List of Unimplemented Features in Package org.omg.CORBA

Unimplemented Methods in package org.omg.CORBA:

  • ORB
    • public org.omg.CORBA.Policy create_policy(int type, org.omg.CORBA.Any val)
    • public void perform_work()
    • public boolean work_pending()
    • public org.omg.CORBA.Current get_current()
    • create_operation_list
    • get_default_context
    • get_service_information
    • obsolete DynAnys (deprecated in favor of DynamicAny package)
从以下版本开始：
JDK1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


org.omg.CORBA Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • org.omg.CORBA.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.Environment
    • org.omg.CORBA.ExceptionList
    • org.omg.CORBA.FieldNameHelper
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IdentifierHelper
    • org.omg.CORBA.IDLTypeHelper
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.CORBA.NVList
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.CORBA.DynamicImplementation
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ORB
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyTypeHelper
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.CORBA.ServerRequest
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • org.omg.CORBA.TCKind
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.PolicyError
          • org.omg.CORBA.UnknownUserException
          • org.omg.CORBA.WrongTransaction
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • org.omg.CORBA.VersionSpecHelper
    • org.omg.CORBA.VisibilityHelper
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)

Interface Hierarchy

  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CustomMarshal
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (also extends org.omg.CORBA.Object)
    • org.omg.CORBA.DynArray (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynValue (also extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
  • org.omg.CORBA.OMGVMCID
  • org.omg.CORBA.PolicyOperations
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PRIVATE_MEMBER
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.CORBA.IRObject (also extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d EoT<>ccccassTIooIl


ParameterMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ParameterMode

  • java.lang.Object
    • org.omg.CORBA.ParameterMode
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class ParameterMode
extends Object
implements IDLEntity
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _PARAM_IN
      static int | _PARAM_INOUT
      static int | _PARAM_OUT
      static ParameterMode | PARAM_IN
      static ParameterMode | PARAM_INOUT
      static ParameterMode | PARAM_OUT

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ParameterMode(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ParameterMode | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _PARAM_IN

        public static final int _PARAM_IN
        另请参见：
        Constant Field Values

      • PARAM_IN

        public static final ParameterMode PARAM_IN

      • _PARAM_OUT

        public static final int _PARAM_OUT
        另请参见：
        Constant Field Values

      • PARAM_OUT

        public static final ParameterMode PARAM_OUT

      • _PARAM_INOUT

        public static final int _PARAM_INOUT
        另请参见：
        Constant Field Values

      • PARAM_INOUT

        public static final ParameterMode PARAM_INOUT

    • 构造方法详细信息

      • ParameterMode

        protected ParameterMode(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static ParameterMode from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mightSeSteltloCC-B//d.t>>>dldoloo>s/


ParameterModeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ParameterModeHelper

  • java.lang.Object
    • org.omg.CORBA.ParameterModeHelper

  • public abstract class ParameterModeHelper
extends Object
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParameterModeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ParameterMode | extract(Any a)
      static String | id()
      static void | insert(Any a, ParameterMode that)
      static ParameterMode | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ParameterMode value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ParameterModeHelper

        public ParameterModeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ParameterMode that)

      • extract

        public static ParameterMode extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ParameterMode read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ParameterMode value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;<<|n|>|p|;nsp;lsbCCue譥y""b<=a">>nfs


ParameterModeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ParameterModeHolder

  • java.lang.Object
    • org.omg.CORBA.ParameterModeHolder
  • 所有已实现的接口：
    Streamable

    public final class ParameterModeHolder
extends Object
implements Streamable
    Enumeration of parameter modes for Parameter. Possible vaues:
    • PARAM_IN - Represents an "in" parameter.
    • PARAM_OUT - Represents an "out" parameter.
    • PARAM_INOUT - Represents an "inout" parameter.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ParameterMode value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParameterModeHolder()
      ParameterModeHolder(ParameterMode initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ParameterMode value

    • 构造方法详细信息

      • ParameterModeHolder

        public ParameterModeHolder()

      • ParameterModeHolder

        public ParameterModeHolder(ParameterMode initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dawete薽 o dsa>蚭


PERSIST_STORE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 PERSIST_STORE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.PERSIST_STORE
  • 所有已实现的接口：
    Serializable

    public final class PERSIST_STORE
extends SystemException
    This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      PERSIST_STORE()
      Constructs a PERSIST_STORE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      PERSIST_STORE(int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified minor code and completion status.
      PERSIST_STORE(String s)
      Constructs a PERSIST_STORE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      PERSIST_STORE(String s, int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • PERSIST_STORE

        public PERSIST_STORE()
        Constructs a PERSIST_STORE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • PERSIST_STORE

        public PERSIST_STORE(String s)
        Constructs a PERSIST_STORE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • PERSIST_STORE

        public PERSIST_STORE(int minor,
             CompletionStatus completed)
        Constructs a PERSIST_STORE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • PERSIST_STORE

        public PERSIST_STORE(String s,
             int minor,
             CompletionStatus completed)
        Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/wsrsksdsd nd rgew>珊⒙纱腚<拢.l.p�0e<


Policy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface Policy

  • All Superinterfaces:
    IDLEntity, Object, PolicyOperations, Serializable
    All Known Subinterfaces:
    IdAssignmentPolicy, IdUniquenessPolicy, ImplicitActivationPolicy, LifespanPolicy, RequestProcessingPolicy, ServantRetentionPolicy, ThreadPolicy
    All Known Implementing Classes:
    _PolicyStub

    public interface Policy
extends PolicyOperations, Object, IDLEntity
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation. This information is accessed in a structured manner using interfaces derived from the Policy interface defined in the CORBA module. A CORBA service does not have to use this method of accessing operating options, but may choose to do so. The Security Service in particular uses this technique for associating Security Policy with objects in the system. An interface generated by the IDL-to-Java compiler. org/omg/CORBA/Policy.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>n< -! -!<--!<


PolicyError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 PolicyError

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.PolicyError
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class PolicyError
extends UserException
    A user exception thrown when a policy error occurs. A PolicyError exception may include one of the following policy error reason codes defined in the org.omg.CORBA package: BAD_POLICY, BAD_POLICY_TYPE, BAD_POLICY_VALUE, UNSUPPORTED_POLICY, UNSUPPORTED_POLICY_VALUE.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      short reason
      The reason for the PolicyError exception being thrown.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyError()
      Constructs a default PolicyError user exception with no reason code and an empty reason detail message.
      PolicyError(short __reason)
      Constructs a PolicyError user exception initialized with the given reason code and an empty reason detail message.
      PolicyError(String reason_string, short __reason)
      Constructs a PolicyError user exception initialized with the given reason detail message and reason code.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • reason

        public short reason
        The reason for the PolicyError exception being thrown.

    • 构造方法详细信息

      • PolicyError

        public PolicyError()
        Constructs a default PolicyError user exception with no reason code and an empty reason detail message.

      • PolicyError

        public PolicyError(short __reason)
        Constructs a PolicyError user exception initialized with the given reason code and an empty reason detail message.
        参数：
        __reason - the reason code.

      • PolicyError

        public PolicyError(String reason_string,
           short __reason)
        Constructs a PolicyError user exception initialized with the given reason detail message and reason code.
        参数：
        reason_string - the reason detail message.
        __reason - the reason code.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< / > a s tls� 缆t


PolicyErrorCodeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyErrorCodeHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorCodeHelper

  • public abstract class PolicyErrorCodeHelper
extends Object
    Encapsulates a reason a Policy may be invalid.
    另请参见：
    PolicyError

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyErrorCodeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicyErrorCodeHelper

        public PolicyErrorCodeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/lldMd"d>eTTn▅


PolicyErrorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyErrorHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorHelper

  • public abstract class PolicyErrorHelper
extends Object
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyErrorHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static PolicyError | extract(Any a)
      static String | id()
      static void | insert(Any a, PolicyError that)
      static PolicyError | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, PolicyError value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicyErrorHelper

        public PolicyErrorHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          PolicyError that)

      • extract

        public static PolicyError extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static PolicyError read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         PolicyError value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tuaonomonoi on


PolicyErrorHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyErrorHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyErrorHolder
  • 所有已实现的接口：
    Streamable

    public final class PolicyErrorHolder
extends Object
implements Streamable
    Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      PolicyError value

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyErrorHolder()
      PolicyErrorHolder(PolicyError initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public PolicyError value

    • 构造方法详细信息

      • PolicyErrorHolder

        public PolicyErrorHolder()

      • PolicyErrorHolder

        public PolicyErrorHolder(PolicyError initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

@ �/ �h@>�饂


PolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyHelper

  • public abstract class PolicyHelper
extends Object
    The Helper for Policy. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Policy | extract(Any a)
      static String | id()
      static void | insert(Any a, Policy that)
      static Policy | narrow(Object obj)
      static Policy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Policy value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicyHelper

        public PolicyHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Policy that)

      • extract

        public static Policy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Policy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Policy value)

      • narrow

        public static Policy narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. d.s.s.e.ktle.slL c edtnnc_"b)rrl n


PolicyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyHolder
  • 所有已实现的接口：
    Streamable

    public final class PolicyHolder
extends Object
implements Streamable
    The Holder for Policy. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/PolicyHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Policy value

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyHolder()
      PolicyHolder(Policy initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Policy value

    • 构造方法详细信息

      • PolicyHolder

        public PolicyHolder()

      • PolicyHolder

        public PolicyHolder(Policy initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1<1999B9099,20" c坝/a技肆浴崃贼冕狴1<


PolicyListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyListHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyListHelper

  • public abstract class PolicyListHelper
extends Object
    The Helper for PolicyList. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyListHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyListHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Policy[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Policy[] that)
      static Policy[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Policy[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicyListHelper

        public PolicyListHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Policy[] that)

      • extract

        public static Policy[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Policy[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Policy[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sg=v>vivsvicc vv>vnnmanoS>>prn>gbbmto


PolicyListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyListHolder

  • java.lang.Object
    • org.omg.CORBA.PolicyListHolder
  • 所有已实现的接口：
    Streamable

    public final class PolicyListHolder
extends Object
implements Streamable
    The Holder for PolicyList. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/PolicyListHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:21 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Policy[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyListHolder()
      PolicyListHolder(Policy[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Policy[] value

    • 构造方法详细信息

      • PolicyListHolder

        public PolicyListHolder()

      • PolicyListHolder

        public PolicyListHolder(Policy[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iak m=ptda胊/�,e蝦bSgtg/pu雛c=rr>albctno


PolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA

Interface PolicyOperations

  • All Known Subinterfaces:
    IdAssignmentPolicy, IdAssignmentPolicyOperations, IdUniquenessPolicy, IdUniquenessPolicyOperations, ImplicitActivationPolicy, ImplicitActivationPolicyOperations, LifespanPolicy, LifespanPolicyOperations, Policy, RequestProcessingPolicy, RequestProcessingPolicyOperations, ServantRetentionPolicy, ServantRetentionPolicyOperations, ThreadPolicy, ThreadPolicyOperations
    All Known Implementing Classes:
    _PolicyStub

    public interface PolicyOperations
    Provides the operations for a Policy object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Policy copy()
      Returns a copy of the Policy object.
      void destroy()
      Destroys the Policy object.
      int policy_type()
      Returns the constant value that corresponds to the type of the policy object.

    • 方法详细信息

      • policy_type

        int policy_type()
        Returns the constant value that corresponds to the type of the policy object. The values of the policy objects are allocated by the OMG. New values for PolicyType should be obtained from the OMG by sending mail to request@omg.org. In general the constant values that are allocated are defined in conjunction with the definition of the corresponding policy object.
        返回：
        the constant value that corresponds to the type of the policy object

      • copy

        Policy copy()
        Returns a copy of the Policy object. The copy does not retain any relationships that the policy had with any domain or object.
        返回：
        a copy of the Policy object

      • destroy

        void destroy()
        Destroys the Policy object. It is the responsibility of the Policy object to determine whether it can be destroyed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"r>AgCg.Cgr..grr emmbnrile/lA/.a


_PolicyStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 _PolicyStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA._PolicyStub
  • 所有已实现的接口：
    Serializable, Object, Policy, PolicyOperations, IDLEntity

    public class _PolicyStub
extends ObjectImpl
implements Policy
    The Stub for Policy. For more information on Stub files, see "Generated Files: Stubs".

    org/omg/CORBA/_PolicyStub.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl. Saturday, July 17, 1999 12:26:20 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      _PolicyStub()
      Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.
      _PolicyStub(Delegate delegate)
      Constructs a _PolicyStub object initialized with the given Delegate object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      Policy copy()
      Copies the policy object.
      void destroy()
      Destroys the policy object.
      int policy_type()
      Returns the constant value that corresponds to the type of the policy object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _PolicyStub

        public _PolicyStub()
        Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.

      • _PolicyStub

        public _PolicyStub(Delegate delegate)
        Constructs a _PolicyStub object initialized with the given Delegate object.
        参数：
        delegate - a Delegate Object

    • 方法详细信息

      • policy_type

        public int policy_type()
        Returns the constant value that corresponds to the type of the policy object. The values of the polivy objectys are allocated by the OMG. New values for PolicyType should be obtained from the OMG by sending mail to request@omg.org. In general the constant values that are allocated are defined in conjunction with the definition of the corresponding policy object.
        指定者：
        policy_type in interface PolicyOperations
        返回：
        the constant value that corresponds to the type of the policy object.

      • copy

        public Policy copy()
        Copies the policy object. The copy does not retain any relationships that the policy had with any domain or object.
        指定者：
        copy in interface PolicyOperations
        返回：
        the copy of the policy object.

      • destroy

        public void destroy()
        Destroys the policy object. It is the responsibility of the policy object to determine whether it can be destroyed.
        指定者：
        destroy in interface PolicyOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dt<>m>u>o>"e>Mdaha## "i"##usuucmrrr絬n靉s


PolicyTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PolicyTypeHelper

  • java.lang.Object
    • org.omg.CORBA.PolicyTypeHelper

  • public abstract class PolicyTypeHelper
extends Object
    The Helper for PolicyType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/PolicyTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ../../../../../src/share/classes/org/omg/PortableServer/corba.idl Saturday, July 17, 1999 12:26:20 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      PolicyTypeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • PolicyTypeHelper

        public PolicyTypeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t ><< v> iaiohC>yTT nh eel<-


Principal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 Principal

  • java.lang.Object
    • org.omg.CORBA.Principal
  • Deprecated.
    Deprecated by CORBA 2.2.

    @Deprecated
public class Principal
extends Object
    A class that contains information about the identity of the client, for access control and other purposes. It contains a single attribute, the name of the Principal, encoded as a sequence of bytes.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Principal()
      Deprecated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] name()
      Deprecated.
      Deprecated by CORBA 2.2.
      void name(byte[] value)
      Deprecated.
      Deprecated by CORBA 2.2.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Principal

        public Principal()
        Deprecated.

    • 方法详细信息

      • name

        @Deprecated
public void name(byte[] value)
        Deprecated. Deprecated by CORBA 2.2.
        Sets the name of this Principal object to the given value.
        参数：
        value - the value to be set in the Principal

      • name

        @Deprecated
public byte[] name()
        Deprecated. Deprecated by CORBA 2.2.
        Gets the name of this Principal object.
        返回：
        the name of this Principal object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/mdee/<


PrincipalHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 PrincipalHolder

  • java.lang.Object
    • org.omg.CORBA.PrincipalHolder
  • 所有已实现的接口：
    Streamable
    Deprecated.
    Deprecated by CORBA 2.2.

    @Deprecated
public final class PrincipalHolder
extends Object
implements Streamable
    The Holder for Principal. For more information on Holder files, see "Generated Files: Holder Files".

    A container class for values of type Principal that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL Principal as an "out" or "inout" parameter, the programmer must pass an instance of PrincipalHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myPrincipalHolder is an instance of PrincipalHolder, the value stored in its value field can be accessed with myPrincipalHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Principal value
      Deprecated.
      The Principal value held by this PrincipalHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      PrincipalHolder()
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to null.
      PrincipalHolder(Principal initial)
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Deprecated.
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Deprecated.
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream output)
      Deprecated.
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Principal value
        Deprecated.
        The Principal value held by this PrincipalHolder object.

    • 构造方法详细信息

      • PrincipalHolder

        public PrincipalHolder()
        Deprecated.
        Constructs a new PrincipalHolder object with its value field initialized to null.

      • PrincipalHolder

        public PrincipalHolder(Principal initial)
        Deprecated.
        Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.
        参数：
        initial - the Principal with which to initialize the value field of the newly-created PrincipalHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Deprecated.
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream output)
        Deprecated.
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        output - the CDR OutputStream

      • _type

        public TypeCode _type()
        Deprecated.
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sis/ca /aapll&皊lcn-sh-anaale=E".h==vabsnl.a


PRIVATE_MEMBER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface PRIVATE_MEMBER

  • public interface PRIVATE_MEMBER
    Constant to define a private member in the ValueMember class.

    PRIVATE_MEMBER is one of the two constants of typedef Visibility used in the interface repository to identify visibility of a ValueMember type. The other constant is PUBLIC_MEMBER.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static short | value

    • 字段详细信息

      • value

        static final short value
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"gm"cL"kL"=bb"==ctsst//b> <=E==


PUBLIC_MEMBER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface PUBLIC_MEMBER

  • public interface PUBLIC_MEMBER
    Constant to define a public member in the ValueMember class.

    PUBLIC_MEMBER is one of the two constants of typedef Visibility used in the interface repository to identify visibility of a ValueMember type. The other constant is PRIVATE_MEMBER.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static short | value

    • 字段详细信息

      • value

        static final short value
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<L"


REBIND

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 REBIND

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.REBIND
  • 所有已实现的接口：
    Serializable

    public final class REBIND
extends SystemException
    REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD. This exception is also raised if the current effective RebindPolicy has a value of NO_RECONNECT and a connection must be reopened.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      REBIND()
      Constructs an REBIND exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      REBIND(int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified minor code and completion status.
      REBIND(String detailMessage)
      Constructs an REBIND exception with the specified message.
      REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • REBIND

        public REBIND()
        Constructs an REBIND exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • REBIND

        public REBIND(String detailMessage)
        Constructs an REBIND exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • REBIND

        public REBIND(int minorCode,
      CompletionStatus completionStatus)
        Constructs an REBIND exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • REBIND

        public REBIND(String detailMessage,
      int minorCode,
      CompletionStatus completionStatus)
        Constructs an REBIND exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

omce.te<;==-l"/aa<>p&lnbil .h.Ootx"


RepositoryIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 RepositoryIdHelper

  • java.lang.Object
    • org.omg.CORBA.RepositoryIdHelper

  • public abstract class RepositoryIdHelper
extends Object
    The Helper for RepositoryId. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/RepositoryIdHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      RepositoryIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • RepositoryIdHelper

        public RepositoryIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=/" < " s nlsallpOiil/ l<>>..g/.<>dpg


Request

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 Request

  • java.lang.Object
    • org.omg.CORBA.Request

  • public abstract class Request
extends Object
    An object containing the information necessary for invoking a method. This class is the cornerstone of the ORB Dynamic Invocation Interface (DII), which allows dynamic creation and invocation of requests. A server cannot tell the difference between a client invocation using a client stub and a request using the DII.

    A Request object consists of:

    • the name of the operation to be invoked
    • an NVList containing arguments for the operation.
      Each item in the list is a NamedValue object, which has three parts:
      1. the name of the argument
      2. the value of the argument (as an Any object)
      3. the argument mode flag indicating whether the argument is for input, output, or both

    Request objects may also contain additional information, depending on how an operation was defined in the original IDL interface definition. For example, where appropriate, they may contain a NamedValue object to hold the return value or exception, a context, a list of possible exceptions, and a list of context strings that need to be resolved.

    New Request objects are created using one of the create_request methods in the Object class. In other words, a create_request method is performed on the object which is to be invoked.

    另请参见：
    NamedValue

    • 构造方法摘要

      Constructors
      构造方法与描述
      Request()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Any add_in_arg()
      Creates an input argument and adds it to this Request object.
      abstract Any add_inout_arg()
      Adds an input/output argument to this Request object.
      abstract Any add_named_in_arg(String name)
      Creates an input argument with the given name and adds it to this Request object.
      abstract Any add_named_inout_arg(String name)
      Adds an input/output argument with the given name to this Request object.
      abstract Any add_named_out_arg(String name)
      Adds an output argument with the given name to this Request object.
      abstract Any add_out_arg()
      Adds an output argument to this Request object.
      abstract NVList arguments()
      Retrieves the NVList object containing the arguments to the method being invoked.
      abstract ContextList contexts()
      Retrieves the ContextList object for this request.
      abstract Context ctx()
      Retrieves the Context object for this request.
      abstract void ctx(Context c)
      Sets this request's Context object to the one given.
      abstract Environment env()
      Retrieves the Environment object for this request.
      abstract ExceptionList exceptions()
      Retrieves the ExceptionList object for this request.
      abstract void get_response()
      Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
      abstract void invoke()
      Makes a synchronous invocation using the information in the Request object.
      abstract String operation()
      Retrieves the name of the method to be invoked.
      abstract boolean poll_response()
      Allows the user to determine whether a response has been received for the invocation triggered earlier with the send_deferred method.
      abstract NamedValue result()
      Retrieves the NamedValue object containing the return value for the method.
      abstract Any return_value()
      Returns the Any object that contains the value for the result of the method.
      abstract void send_deferred()
      Makes an asynchronous invocation on the request.
      abstract void send_oneway()
      Makes a oneway invocation on the request.
      abstract void set_return_type(TypeCode tc)
      Sets the typecode for the return value of the method.
      abstract Object target()
      Retrieves the the target object reference.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Request

        public Request()

    • 方法详细信息

      • target

        public abstract Object target()
        Retrieves the the target object reference.
        返回：
        the object reference that points to the object implementation for the method to be invoked

      • operation

        public abstract String operation()
        Retrieves the name of the method to be invoked.
        返回：
        the name of the method to be invoked

      • arguments

        public abstract NVList arguments()
        Retrieves the NVList object containing the arguments to the method being invoked. The elements in the list are NamedValue objects, with each one describing an argument to the method.
        返回：
        the NVList object containing the arguments for the method

      • result

        public abstract NamedValue result()
        Retrieves the NamedValue object containing the return value for the method.
        返回：
        the NamedValue object containing the result of the method

      • env

        public abstract Environment env()
        Retrieves the Environment object for this request. It contains the exception that the method being invoked has thrown (after the invocation returns).
        返回：
        the Environment object for this request

      • exceptions

        public abstract ExceptionList exceptions()
        Retrieves the ExceptionList object for this request. This list contains TypeCode objects describing the exceptions that may be thrown by the method being invoked.
        返回：
        the ExceptionList object describing the exceptions that may be thrown by the method being invoked

      • contexts

        public abstract ContextList contexts()
        Retrieves the ContextList object for this request. This list contains context Strings that need to be resolved and sent with the invocation.
        返回：
        the list of context strings whose values need to be resolved and sent with the invocation.

      • ctx

        public abstract Context ctx()
        Retrieves the Context object for this request. This is a list of properties giving information about the client, the environment, or the circumstances of this request.
        返回：
        the Context object that is to be used to resolve any context strings whose values need to be sent with the invocation

      • ctx

        public abstract void ctx(Context c)
        Sets this request's Context object to the one given.
        参数：
        c - the new Context object to be used for resolving context strings

      • add_in_arg

        public abstract Any add_in_arg()
        Creates an input argument and adds it to this Request object.
        返回：
        an Any object that contains the value and typecode for the input argument added

      • add_named_in_arg

        public abstract Any add_named_in_arg(String name)
        Creates an input argument with the given name and adds it to this Request object.
        参数：
        name - the name of the argument being added
        返回：
        an Any object that contains the value and typecode for the input argument added

      • add_inout_arg

        public abstract Any add_inout_arg()
        Adds an input/output argument to this Request object.
        返回：
        an Any object that contains the value and typecode for the input/output argument added

      • add_named_inout_arg

        public abstract Any add_named_inout_arg(String name)
        Adds an input/output argument with the given name to this Request object.
        参数：
        name - the name of the argument being added
        返回：
        an Any object that contains the value and typecode for the input/output argument added

      • add_out_arg

        public abstract Any add_out_arg()
        Adds an output argument to this Request object.
        返回：
        an Any object that contains the value and typecode for the output argument added

      • add_named_out_arg

        public abstract Any add_named_out_arg(String name)
        Adds an output argument with the given name to this Request object.
        参数：
        name - the name of the argument being added
        返回：
        an Any object that contains the value and typecode for the output argument added

      • set_return_type

        public abstract void set_return_type(TypeCode tc)
        Sets the typecode for the return value of the method.
        参数：
        tc - the TypeCode object containing type information for the return value

      • return_value

        public abstract Any return_value()
        Returns the Any object that contains the value for the result of the method.
        返回：
        an Any object containing the value and typecode for the return value

      • invoke

        public abstract void invoke()
        Makes a synchronous invocation using the information in the Request object. Exception information is placed into the Request object's environment object.

      • send_oneway

        public abstract void send_oneway()
        Makes a oneway invocation on the request. In other words, it does not expect or wait for a response. Note that this can be used even if the operation was not declared as oneway in the IDL declaration. No response or exception information is returned.

      • send_deferred

        public abstract void send_deferred()
        Makes an asynchronous invocation on the request. In other words, it does not wait for a response before it returns to the user. The user can then later use the methods poll_response and get_response to get the result or exception information for the invocation.

      • poll_response

        public abstract boolean poll_response()
        Allows the user to determine whether a response has been received for the invocation triggered earlier with the send_deferred method.
        返回：
        true if the method response has been received; false otherwise

      • get_response

        public abstract void get_response()
                           throws WrongTransaction
        Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
        抛出：
        WrongTransaction - if the method get_response was invoked from a different transaction's scope than the one from which the request was originally sent. See the OMG Transaction Service specification for details.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ServerRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ServerRequest

  • java.lang.Object
    • org.omg.CORBA.ServerRequest

  • public abstract class ServerRequest
extends Object
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI). This class, the cornerstone of the DSI, is analogous to the Request object in the DII.

    The ORB is responsible for creating this embodiment of a request, and delivering it to a Dynamic Implementation Routine (DIR). A dynamic servant (a DIR) is created by implementing the DynamicImplementation class, which has a single invoke method. This method accepts a ServerRequest object. The abstract class ServerRequest defines methods for accessing the method name, the arguments and the context of the request, as well as methods for setting the result of the request either as a return value or an exception.

    A subtlety with accessing the arguments of the request is that the DIR needs to provide type information about the expected arguments, since there is no compiled information about these. This information is provided through an NVList, which is a list of NamedValue objects. Each NamedValue object contains an Any object, which in turn has a TypeCode object representing the type of the argument.

    Similarly, type information needs to be provided for the response, for either the expected result or for an exception, so the methods result and except take an Any object as a parameter.

    另请参见：
    DynamicImplementation, NVList, NamedValue

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServerRequest()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void arguments(NVList args)
      Specifies method parameter types and retrieves "in" and "inout" argument values.
      abstract Context ctx()
      Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
      void except(Any any)
      Deprecated.
      use set_exception()
      String op_name()
      Deprecated.
      use operation()
      String operation()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void params(NVList params)
      Deprecated.
      use the method arguments
      void result(Any any)
      Deprecated.
      use the method set_result
      void set_exception(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void set_result(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServerRequest

        public ServerRequest()

    • 方法详细信息

      • op_name

        @Deprecated
public String op_name()
        Deprecated. use operation()
        Retrieves the name of the operation being invoked. According to OMG IDL's rules, these names must be unique among all operations supported by this object's "most-derived" interface. Note that the operation names for getting and setting attributes are _get_<attribute_name> and _set_<attribute_name>, respectively.
        返回：
        the name of the operation to be invoked

      • operation

        public String operation()
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Retrieves the name of the operation being invoked. According to OMG IDL's rules, these names must be unique among all operations supported by this object's "most-derived" interface. Note that the operation names for getting and setting attributes are _get_<attribute_name> and _set_<attribute_name>, respectively.

        返回：
        the name of the operation to be invoked
        另请参见：
        CORBA package comments for unimplemented features

      • params

        @Deprecated
public void params(NVList params)
        Deprecated. use the method arguments
        Specifies method parameter types and retrieves "in" and "inout" argument values.

        Note that this method is deprecated; use the method arguments in its place.

        Unless it calls the method set_exception, the DIR must call this method exactly once, even if the method signature contains no parameters. Once the method arguments or set_exception has been called, calling arguments on the same ServerRequest object will result in a BAD_INV_ORDER system exception. The DIR must pass in to the method arguments an NVList initialized with TypeCodes and Flags describing the parameter types for the operation, in the order in which they appear in the IDL specification (left to right). A potentially-different NVList will be returned from arguments, with the "in" and "inout" argument values supplied. If it does not call the method set_exception, the DIR must supply the returned NVList with return values for any "out" arguments before returning, and may also change the return values for any "inout" arguments.

        参数：
        params - the arguments of the method, in the form of an NVList object

      • arguments

        public void arguments(NVList args)
        Specifies method parameter types and retrieves "in" and "inout" argument values. Unless it calls the method set_exception, the DIR must call this method exactly once, even if the method signature contains no parameters. Once the method arguments or set_exception has been called, calling arguments on the same ServerRequest object will result in a BAD_INV_ORDER system exception. The DIR must pass in to the method arguments an NVList initialized with TypeCodes and Flags describing the parameter types for the operation, in the order in which they appear in the IDL specification (left to right). A potentially-different NVList will be returned from arguments, with the "in" and "inout" argument values supplied. If it does not call the method set_exception, the DIR must supply the returned NVList with return values for any "out" arguments before returning, and it may also change the return values for any "inout" arguments.
        参数：
        args - the arguments of the method, in the form of an NVList
        另请参见：
        CORBA package comments for unimplemented features

      • result

        @Deprecated
public void result(Any any)
        Deprecated. use the method set_result
        Specifies any return value for the call.

        Note that this method is deprecated; use the method set_result in its place.

        Unless the method set_exception is called, if the invoked method has a non-void result type, the method set_result must be called exactly once before the DIR returns. If the operation has a void result type, the method set_result may optionally be called once with an Any object whose type is tk_void. Calling the method set_result before the method arguments has been called or after the method set_result or set_exception has been called will result in a BAD_INV_ORDER exception. Calling the method set_result without having previously called the method ctx when the IDL operation contains a context expression, or when the NVList passed to arguments did not describe all parameters passed by the client, may result in a MARSHAL system exception.

        参数：
        any - an Any object containing the return value to be set

      • set_result

        public void set_result(Any any)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Specifies any return value for the call. Unless the method set_exception is called, if the invoked method has a non-void result type, the method set_result must be called exactly once before the DIR returns. If the operation has a void result type, the method set_result may optionally be called once with an Any object whose type is tk_void. Calling the method set_result before the method arguments has been called or after the method set_result or set_exception has been called will result in a BAD_INV_ORDER exception. Calling the method set_result without having previously called the method ctx when the IDL operation contains a context expression, or when the NVList passed to arguments did not describe all parameters passed by the client, may result in a MARSHAL system exception.

        参数：
        any - an Any object containing the return value to be set
        另请参见：
        CORBA package comments for unimplemented features

      • except

        @Deprecated
public void except(Any any)
        Deprecated. use set_exception()
        The DIR may call set_exception at any time to return an exception to the client. The Any passed to set_exception must contain either a system exception or a user exception specified in the raises expression of the invoked operation's IDL definition. Passing in an Any that does not contain an exception will result in a BAD_PARAM system exception. Passing in an unlisted user exception will result in either the DIR receiving a BAD_PARAM system exception or in the client receiving an UNKNOWN_EXCEPTION system exception.
        参数：
        any - the Any object containing the exception

      • set_exception

        public void set_exception(Any any)
        Throws an org.omg.CORBA.NO_IMPLEMENT exception.

        Returns the given exception to the client. This method is invoked by the DIR, which may call it at any time. The Any object passed to this method must contain either a system exception or one of the user exceptions specified in the invoked operation's IDL definition. Passing in an Any object that does not contain an exception will cause a BAD_PARAM system exception to be thrown. Passing in an unlisted user exception will result in either the DIR receiving a BAD_PARAM system exception or in the client receiving an UNKNOWN_EXCEPTION system exception.

        参数：
        any - the Any object containing the exception
        抛出：
        BAD_PARAM - if the given Any object does not contain an exception or the exception is an unlisted user exception
        UNKNOWN_EXCEPTION - if the given exception is an unlisted user exception and the DIR did not receive a BAD_PARAM exception
        另请参见：
        CORBA package comments for unimplemented features

      • ctx

        public abstract Context ctx()
        Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference. Calling the method ctx before the method arguments has been called or after the method ctx, set_result, or set_exception has been called will result in a BAD_INV_ORDER system exception.
        返回：
        the context object that is to be used to resolve any context strings whose values need to be sent with the invocation.
        抛出：
        BAD_INV_ORDER - if (1) the method ctx is called before the method arguments or (2) the method ctx is called after calling set_result or set_exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

isssl "i "t>>"ttca tisoi ird>. eena n c


ServiceDetail

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 ServiceDetail

  • java.lang.Object
    • org.omg.CORBA.ServiceDetail
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ServiceDetail
extends Object
implements IDLEntity
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      byte[] service_detail
      The data describing the ORB service that this ServiceDetail object represents.
      int service_detail_type
      The type of the ORB service that this ServiceDetail object represents.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceDetail()
      Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.
      ServiceDetail(int service_detail_type, byte[] service_detail)
      Constructs a ServiceDetail object with the given ORB service type and the given description.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • service_detail_type

        public int service_detail_type
        The type of the ORB service that this ServiceDetail object represents.

      • service_detail

        public byte[] service_detail
        The data describing the ORB service that this ServiceDetail object represents.

    • 构造方法详细信息

      • ServiceDetail

        public ServiceDetail()
        Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.

      • ServiceDetail

        public ServiceDetail(int service_detail_type,
             byte[] service_detail)
        Constructs a ServiceDetail object with the given ORB service type and the given description.
        参数：
        service_detail_type - an int specifying the type of ORB service
        service_detail - a byte array describing the ORB service
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

deioprsersueesuuppppt"vn">>/">aa>.Siibik


ServiceDetailHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ServiceDetailHelper

  • java.lang.Object
    • org.omg.CORBA.ServiceDetailHelper

  • public abstract class ServiceDetailHelper
extends Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceDetailHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServiceDetail | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceDetail that)
      static ServiceDetail | read(InputStream in)
      static TypeCode | type()
      static void | write(OutputStream out, ServiceDetail that)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceDetailHelper

        public ServiceDetailHelper()

    • 方法详细信息

      • write

        public static void write(OutputStream out,
         ServiceDetail that)

      • read

        public static ServiceDetail read(InputStream in)

      • extract

        public static ServiceDetail extract(Any a)

      • insert

        public static void insert(Any a,
          ServiceDetail that)

      • type

        public static TypeCode type()

      • id

        public static String id()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e >re>


ServiceInformation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 ServiceInformation

  • java.lang.Object
    • org.omg.CORBA.ServiceInformation
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ServiceInformation
extends Object
implements IDLEntity
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ServiceDetail[] service_details
      Array of ServiceDetails giving more details about the service.
      int[] service_options
      Array of ints representing service options.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceInformation()
      Constructs a ServiceInformation object with empty service_options and service_details.
      ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
      Constructs a ServiceInformation object with the given service_options and service_details.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • service_options

        public int[] service_options
        Array of ints representing service options.

      • service_details

        public ServiceDetail[] service_details
        Array of ServiceDetails giving more details about the service.

    • 构造方法详细信息

      • ServiceInformation

        public ServiceInformation()
        Constructs a ServiceInformation object with empty service_options and service_details.

      • ServiceInformation

        public ServiceInformation(int[] __service_options,
                  ServiceDetail[] __service_details)
        Constructs a ServiceInformation object with the given service_options and service_details.
        参数：
        __service_options - An array of ints describing the service options.
        __service_details - An array of ServiceDetails describing the service details.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fc=< ref#r<&&tL" L照iisausbt >


ServiceInformationHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ServiceInformationHelper

  • java.lang.Object
    • org.omg.CORBA.ServiceInformationHelper

  • public abstract class ServiceInformationHelper
extends Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceInformationHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServiceInformation | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceInformation that)
      static ServiceInformation | read(InputStream in)
      static TypeCode | type()
      static void | write(OutputStream out, ServiceInformation that)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceInformationHelper

        public ServiceInformationHelper()

    • 方法详细信息

      • write

        public static void write(OutputStream out,
         ServiceInformation that)

      • read

        public static ServiceInformation read(InputStream in)

      • extract

        public static ServiceInformation extract(Any a)

      • insert

        public static void insert(Any a,
          ServiceInformation that)

      • type

        public static TypeCode type()

      • id

        public static String id()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oln>le ti hmichs /asecmolloLrilkk=ea


ServiceInformationHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ServiceInformationHolder

  • java.lang.Object
    • org.omg.CORBA.ServiceInformationHolder
  • 所有已实现的接口：
    Streamable

    public final class ServiceInformationHolder
extends Object
implements Streamable
    The Holder for ServiceInformation. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a ServiceInformation object that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL xxx as an "out" or "inout" parameter, the programmer must pass an instance of ServiceInformationHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myServiceInformationHolder is an instance of ServiceInformationHolder, the value stored in its value field can be accessed with myServiceInformationHolder.value.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ServiceInformation value
      The ServiceInformation value held by this ServiceInformationHolder object in its value field.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceInformationHolder()
      Constructs a new ServiceInformationHolder object with its value field initialized to null.
      ServiceInformationHolder(ServiceInformation arg)
      Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream in)
      Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
      void _write(OutputStream out)
      Marshals the value in this ServiceInformationHolder object's value field to the output stream out.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ServiceInformation value
        The ServiceInformation value held by this ServiceInformationHolder object in its value field.

    • 构造方法详细信息

      • ServiceInformationHolder

        public ServiceInformationHolder()
        Constructs a new ServiceInformationHolder object with its value field initialized to null.

      • ServiceInformationHolder

        public ServiceInformationHolder(ServiceInformation arg)
        Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.
        参数：
        arg - the ServiceInformation object with which to initialize the value field of the newly-created ServiceInformationHolder object

    • 方法详细信息

      • _write

        public void _write(OutputStream out)
        Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
        指定者：
        _write in interface Streamable
        参数：
        out - the OutputStream object that will contain the CDR formatted data

      • _read

        public void _read(InputStream in)
        Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
        指定者：
        _read in interface Streamable
        参数：
        in - the InputStream object containing CDR formatted data from the wire

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
        指定者：
        _type in interface Streamable
        返回：
        the type code for the value held in this ServiceInformationHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ond_a>ae>a


SetOverrideType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 SetOverrideType

  • java.lang.Object
    • org.omg.CORBA.SetOverrideType
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class SetOverrideType
extends Object
implements IDLEntity
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.

    The method Object._set_policy_override(org.omg.CORBA.Policy[], org.omg.CORBA.SetOverrideType) takes either SetOverrideType.SET_OVERRIDE or SetOverrideType.ADD_OVERRIDE as its second argument. The method _set_policy_override creates a new Object initialized with the Policy objects supplied as the first argument. If the second argument is ADD_OVERRIDE, the new policies are added to those of the Object instance that is calling the _set_policy_override method. If SET_OVERRIDE is given instead, the existing policies are replaced with the given ones.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int _ADD_OVERRIDE
      The int constant for the enum value ADD_OVERRIDE.
      static int _SET_OVERRIDE
      The int constant for the enum value SET_OVERRIDE.
      static SetOverrideType ADD_OVERRIDE
      The SetOverrideType constant for the enum value ADD_OVERRIDE.
      static SetOverrideType SET_OVERRIDE
      The SetOverrideType constant for the enum value SET_OVERRIDE.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SetOverrideType(int _value)
      Constructs a SetOverrideType instance from an int.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static SetOverrideType from_int(int i)
      Converts the given int to the corresponding SetOverrideType instance.
      int value()
      Retrieves the value of this SetOverrideType instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _SET_OVERRIDE

        public static final int _SET_OVERRIDE
        The int constant for the enum value SET_OVERRIDE.
        另请参见：
        Constant Field Values

      • _ADD_OVERRIDE

        public static final int _ADD_OVERRIDE
        The int constant for the enum value ADD_OVERRIDE.
        另请参见：
        Constant Field Values

      • SET_OVERRIDE

        public static final SetOverrideType SET_OVERRIDE
        The SetOverrideType constant for the enum value SET_OVERRIDE.

      • ADD_OVERRIDE

        public static final SetOverrideType ADD_OVERRIDE
        The SetOverrideType constant for the enum value ADD_OVERRIDE.

    • 构造方法详细信息

      • SetOverrideType

        protected SetOverrideType(int _value)
        Constructs a SetOverrideType instance from an int.
        参数：
        _value - must be either SET_OVERRIDE or ADD_OVERRIDE

    • 方法详细信息

      • value

        public int value()
        Retrieves the value of this SetOverrideType instance.
        返回：
        the int for this SetOverrideType instance.

      • from_int

        public static SetOverrideType from_int(int i)
        Converts the given int to the corresponding SetOverrideType instance.
        参数：
        i - the int to convert; must be either SetOverrideType._SET_OVERRIDE or SetOverrideType._ADD_OVERRIDE
        返回：
        the SetOverrideType instance whose value matches the given int
        抛出：
        BAD_PARAM - if the given int does not match the value of any SetOverrideType instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"a# l = arf="efibbbb蝞abbini>aie>f iis_t">焦o


SetOverrideTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 SetOverrideTypeHelper

  • java.lang.Object
    • org.omg.CORBA.SetOverrideTypeHelper

  • public abstract class SetOverrideTypeHelper
extends Object
    The Helper for SetOverrideType. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/SetOverrideTypeHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" 03 June 1999 11:52:03 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      SetOverrideTypeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static SetOverrideType | extract(Any a)
      static String | id()
      static void | insert(Any a, SetOverrideType that)
      static SetOverrideType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, SetOverrideType value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SetOverrideTypeHelper

        public SetOverrideTypeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          SetOverrideType that)

      • extract

        public static SetOverrideType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static SetOverrideType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         SetOverrideType value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AoS == == -== -->v>>dyectee>></>


ShortHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ShortHolder

  • java.lang.Object
    • org.omg.CORBA.ShortHolder
  • 所有已实现的接口：
    Streamable

    public final class ShortHolder
extends Object
implements Streamable
    The Holder for Short. For more information on Holder files, see "Generated Files: Holder Files".

    short that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL short as an "out" or "inout" parameter, the programmer must pass an instance of ShortHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myShortHolder is an instance of ShortHolder, the value stored in its value field can be accessed with myShortHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      short value
      The short value held by this ShortHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ShortHolder()
      Constructs a new ShortHolder object with its value field initialized to 0.
      ShortHolder(short initial)
      Constructs a new ShortHolder object with its value field initialized to the given short.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this ShortHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this ShortHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public short value
        The short value held by this ShortHolder object.

    • 构造方法详细信息

      • ShortHolder

        public ShortHolder()
        Constructs a new ShortHolder object with its value field initialized to 0.

      • ShortHolder

        public ShortHolder(short initial)
        Constructs a new ShortHolder object with its value field initialized to the given short.
        参数：
        initial - the short with which to initialize the value field of the newly-created ShortHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this ShortHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this ShortHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this ShortHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/djl.lplmlc.omev/c// A坎蚕亢肯群俗媳嫉b衔o


ShortSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ShortSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ShortSeqHelper

  • public abstract class ShortSeqHelper
extends Object
    The Helper for ShortSeqHelper. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      ShortSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short[] | extract(Any a)
      static String | id()
      static void | insert(Any a, short[] that)
      static short[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ShortSeqHelper

        public ShortSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short[] that)

      • extract

        public static short[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r


ShortSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ShortSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ShortSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class ShortSeqHolder
extends Object
implements Streamable
    The Holder for ShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ShortSeqHolder()
      ShortSeqHolder(short[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public short[] value

    • 构造方法详细信息

      • ShortSeqHolder

        public ShortSeqHolder()

      • ShortSeqHolder

        public ShortSeqHolder(short[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

#imhih/h&h e="#t=>ssssrbass>/l>


StringHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 StringHolder

  • java.lang.Object
    • org.omg.CORBA.StringHolder
  • 所有已实现的接口：
    Streamable

    public final class StringHolder
extends Object
implements Streamable
    The Holder for String. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a String that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL string as an "out" or "inout" parameter, the programmer must pass an instance of StringHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myStringHolder is an instance of StringHolder, the value stored in its value field can be accessed with myStringHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String value
      The String value held by this StringHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringHolder()
      Constructs a new StringHolder object with its value field initialized to null.
      StringHolder(String initial)
      Constructs a new StringHolder object with its value field initialized to the given String.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
      TypeCode _type()
      Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
      void _write(OutputStream output)
      Marshals the value held by this StringHolder object to the output stream output.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public String value
        The String value held by this StringHolder object.

    • 构造方法详细信息

      • StringHolder

        public StringHolder()
        Constructs a new StringHolder object with its value field initialized to null.

      • StringHolder

        public StringHolder(String initial)
        Constructs a new StringHolder object with its value field initialized to the given String.
        参数：
        initial - the String with which to initialize the value field of the newly-created StringHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire.

      • _write

        public void _write(OutputStream output)
        Marshals the value held by this StringHolder object to the output stream output.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data.

      • _type

        public TypeCode _type()
        Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the type code of the value held in this StringHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

voL"l""p"=uN "sNaa>|sbpnlbi;nn


StringSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 StringSeqHelper

  • java.lang.Object
    • org.omg.CORBA.StringSeqHelper

  • public abstract class StringSeqHelper
extends Object
    An array of Strings

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringSeqHelper

        public StringSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hvrc>u


StringSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 StringSeqHolder

  • java.lang.Object
    • org.omg.CORBA.StringSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class StringSeqHolder
extends Object
implements Streamable
    An array of Strings

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringSeqHolder()
      StringSeqHolder(String[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public String[] value

    • 构造方法详细信息

      • StringSeqHolder

        public StringSeqHolder()

      • StringSeqHolder

        public StringSeqHolder(String[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"s>s/sistsarpt"!p .. .e//caseCosfla紅lrm鱨a


StringValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 StringValueHelper

  • java.lang.Object
    • org.omg.CORBA.StringValueHelper
  • 所有已实现的接口：
    BoxedValueHelper

    public class StringValueHelper
extends Object
implements BoxedValueHelper
    The Helper for StringValue. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/StringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringValueHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      String get_id()
      static String | id()
      static void | insert(Any a, String that)
      Serializable | read_value(InputStream istream)
      static String | read(InputStream istream)
      static TypeCode | type()
      void | write_value(OutputStream ostream, Serializable value)
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringValueHelper

        public StringValueHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • read_value

        public Serializable read_value(InputStream istream)
        指定者：
        read_value in interface BoxedValueHelper

      • write

        public static void write(OutputStream ostream,
         String value)

      • write_value

        public void write_value(OutputStream ostream,
               Serializable value)
        指定者：
        write_value in interface BoxedValueHelper

      • get_id

        public String get_id()
        指定者：
        get_id in interface BoxedValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f彼�;/藄嗣岜thc欲�;d


StructMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 StructMember

  • java.lang.Object
    • org.omg.CORBA.StructMember
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class StructMember
extends Object
implements IDLEntity
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String name
      The name of the struct member described by this StructMember object.
      TypeCode type
      The type of the struct member described by this StructMember object.
      IDLType type_def
      The typedef that represents the IDL type of the struct member described by this StructMember object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StructMember()
      Constructs a default StructMember object.
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        public String name
        The name of the struct member described by this StructMember object.

      • type

        public TypeCode type
        The type of the struct member described by this StructMember object.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the struct member described by this StructMember object.

    • 构造方法详细信息

      • StructMember

        public StructMember()
        Constructs a default StructMember object.

      • StructMember

        public StructMember(String __name,
            TypeCode __type,
            IDLType __type_def)
        Constructs a StructMember object initialized with the given values.
        参数：
        __name - a String object with the name of the struct member
        __type - a TypeCode object describing the type of the struct member
        __type_def - an IDLType object representing the IDL type of the struct member
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taprRAgBAgm..gmmolmmninpitteit;btseaa.


StructMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 StructMemberHelper

  • java.lang.Object
    • org.omg.CORBA.StructMemberHelper

  • public abstract class StructMemberHelper
extends Object
    The Helper for StructMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/StructMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      StructMemberHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static StructMember | extract(Any a)
      static String | id()
      static void | insert(Any a, StructMember that)
      static StructMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, StructMember value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StructMemberHelper

        public StructMemberHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          StructMember that)

      • extract

        public static StructMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static StructMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         StructMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jea" rhr #


SystemException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 SystemException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    ACTIVITY_COMPLETED, ACTIVITY_REQUIRED, BAD_CONTEXT, BAD_INV_ORDER, BAD_OPERATION, BAD_PARAM, BAD_QOS, BAD_TYPECODE, CODESET_INCOMPATIBLE, COMM_FAILURE, DATA_CONVERSION, FREE_MEM, IMP_LIMIT, IndirectionException, INITIALIZE, INTERNAL, INTF_REPOS, INV_FLAG, INV_IDENT, INV_OBJREF, INV_POLICY, INVALID_ACTIVITY, INVALID_TRANSACTION, MARSHAL, NO_IMPLEMENT, NO_MEMORY, NO_PERMISSION, NO_RESOURCES, NO_RESPONSE, OBJ_ADAPTER, OBJECT_NOT_EXIST, PERSIST_STORE, REBIND, TIMEOUT, TRANSACTION_MODE, TRANSACTION_REQUIRED, TRANSACTION_ROLLEDBACK, TRANSACTION_UNAVAILABLE, TRANSIENT, UNKNOWN, UnknownException

    public abstract class SystemException
extends RuntimeException
    The root class for all CORBA standard exceptions. These exceptions may be thrown as a result of any CORBA operation invocation and may also be returned by many standard CORBA API methods. The standard exceptions contain a minor code, allowing more detailed specification, and a completion status. This class is subclassed to generate each one of the set of standard ORB exceptions. SystemException extends java.lang.RuntimeException; thus none of the SystemException exceptions need to be declared in signatures of the Java methods mapped from operations in IDL interfaces.
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      CompletionStatus completed
      The status of the operation that threw this exception.
      int minor
      The CORBA Exception minor code.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected SystemException(String reason, int minor, CompletionStatus completed)
      Constructs a SystemException exception with the specified detail message, minor code, and completion status.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String toString()
      Converts this exception to a representative string.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • minor

        public int minor
        The CORBA Exception minor code.

      • completed

        public CompletionStatus completed
        The status of the operation that threw this exception.

    • 构造方法详细信息

      • SystemException

        protected SystemException(String reason,
               int minor,
               CompletionStatus completed)
        Constructs a SystemException exception with the specified detail message, minor code, and completion status. A detail message is a String that describes this particular exception.
        参数：
        reason - the String containing a detail message
        minor - the minor code
        completed - the completion status

    • 方法详细信息

      • toString

        public String toString()
        Converts this exception to a representative string.
        重载：
        toString in class Throwable
        返回：
        a string representation of this throwable.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rAsg7>ts>cn萲s<.psD ;L"hal/sttnoldepo ee


TCKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 TCKind

  • java.lang.Object
    • org.omg.CORBA.TCKind

  • public class TCKind
extends Object
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object. There is one kind for each primitive and essential IDL data type.

    The class TCKind consists of:

    • a set of int constants, one for each kind of IDL data type. These int constants make it possible to use a switch statement.
    • a set of TCKind constants, one for each kind of IDL data type. The value field for each TCKind instance is initialized with the int constant that corresponds with the IDL data type that the instance represents.
    • the method from_intfor converting an int to its corresponding TCKind instance

      Example:

            org.omg.CORBA.TCKind k = org.omg.CORBA.TCKind.from_int(
                         org.omg.CORBA.TCKind._tk_string);
      The variable k represents the TCKind instance for the IDL type string, which is tk_string.

    • the method value for accessing the _value field of a TCKind constant

      Example:

         int i = org.omg.CORBA.TCKind.tk_char.value();
      The variable i represents 9, the value for the IDL data type char.

    The value field of a TCKind instance is the CDR encoding used for a TypeCode object in an IIOP message.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int _tk_abstract_interface
      The int constant for the IDL data type abstract interface.
      static int _tk_alias
      The int constant for the IDL data type alias.
      static int _tk_any
      The int constant for the IDL data type any.
      static int _tk_array
      The int constant for the IDL data type array.
      static int _tk_boolean
      The int constant for the IDL data type boolean.
      static int _tk_char
      The int constant for the IDL data type char.
      static int _tk_double
      The int constant for the IDL data type double.
      static int _tk_enum
      The int constant for the IDL data type enum.
      static int _tk_except
      The int constant for the IDL data type except.
      static int _tk_fixed
      The int constant for the IDL data type fixed.
      static int _tk_float
      The int constant for the IDL data type float.
      static int _tk_long
      The int constant for the IDL data type long.
      static int _tk_longdouble
      The int constant for the IDL data type longdouble.
      static int _tk_longlong
      The int constant for the IDL data type longlong.
      static int _tk_native
      The int constant for the IDL data type native.
      static int _tk_null
      The int constant for a null IDL data type.
      static int _tk_objref
      The int constant for the IDL data type objref.
      static int _tk_octet
      The int constant for the IDL data type octet.
      static int _tk_Principal
      The int constant for the IDL data type Principal.
      static int _tk_sequence
      The int constant for the IDL data type sequence.
      static int _tk_short
      The int constant for the IDL data type short.
      static int _tk_string
      The int constant for the IDL data type string.
      static int _tk_struct
      The int constant for the IDL data type struct.
      static int _tk_TypeCode
      The int constant for the IDL data type TypeCode.
      static int _tk_ulong
      The int constant for the IDL data type ulong.
      static int _tk_ulonglong
      The int constant for the IDL data type ulonglong.
      static int _tk_union
      The int constant for the IDL data type union.
      static int _tk_ushort
      The int constant for the IDL data type ushort.
      static int _tk_value
      The int constant for the IDL data type value.
      static int _tk_value_box
      The int constant for the IDL data type value_box.
      static int _tk_void
      The int constant for the IDL data type void.
      static int _tk_wchar
      The int constant for the IDL data type wchar.
      static int _tk_wstring
      The int constant for the IDL data type wstring.
      static TCKind tk_abstract_interface
      The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
      static TCKind tk_alias
      The TCKind constant whose value field is initialized with TCKind._tk_alias.
      static TCKind tk_any
      The TCKind constant whose value field is initialized with TCKind._tk_any.
      static TCKind tk_array
      The TCKind constant whose value field is initialized with TCKind._tk_array.
      static TCKind tk_boolean
      The TCKind constant whose value field is initialized with TCKind._tk_boolean.
      static TCKind tk_char
      The TCKind constant whose value field is initialized with TCKind._tk_char.
      static TCKind tk_double
      The TCKind constant whose value field is initialized with TCKind._tk_double.
      static TCKind tk_enum
      The TCKind constant whose value field is initialized with TCKind._tk_enum.
      static TCKind tk_except
      The TCKind constant whose value field is initialized with TCKind._tk_except.
      static TCKind tk_fixed
      The TCKind constant whose value field is initialized with TCKind._tk_fixed.
      static TCKind tk_float
      The TCKind constant whose value field is initialized with TCKind._tk_float.
      static TCKind tk_long
      The TCKind constant whose value field is initialized with TCKind._tk_long.
      static TCKind tk_longdouble
      The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
      static TCKind tk_longlong
      The TCKind constant whose value field is initialized with TCKind._tk_longlong.
      static TCKind tk_native
      The TCKind constant whose value field is initialized with TCKind._tk_native.
      static TCKind tk_null
      The TCKind constant whose value field is initialized with TCKind._tk_null.
      static TCKind tk_objref
      The TCKind constant whose value field is initialized with TCKind._tk_objref.
      static TCKind tk_octet
      The TCKind constant whose value field is initialized with TCKind._tk_octet.
      static TCKind tk_Principal
      The TCKind constant whose value field is initialized with TCKind._tk_Principal.
      static TCKind tk_sequence
      The TCKind constant whose value field is initialized with TCKind._tk_sequence.
      static TCKind tk_short
      The TCKind constant whose value field is initialized with TCKind._tk_short.
      static TCKind tk_string
      The TCKind constant whose value field is initialized with TCKind._tk_string.
      static TCKind tk_struct
      The TCKind constant whose value field is initialized with TCKind._tk_struct.
      static TCKind tk_TypeCode
      The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
      static TCKind tk_ulong
      The TCKind constant whose value field is initialized with TCKind._tk_ulong.
      static TCKind tk_ulonglong
      The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
      static TCKind tk_union
      The TCKind constant whose value field is initialized with TCKind._tk_union.
      static TCKind tk_ushort
      The TCKind constant whose value field is initialized with TCKind._tk_ushort.
      static TCKind tk_value
      The TCKind constant whose value field is initialized with TCKind._tk_value.
      static TCKind tk_value_box
      The TCKind constant whose value field is initialized with TCKind._tk_value_box.
      static TCKind tk_void
      The TCKind constant whose value field is initialized with TCKind._tk_void.
      static TCKind tk_wchar
      The TCKind constant whose value field is initialized with TCKind._tk_wchar.
      static TCKind tk_wstring
      The TCKind constant whose value field is initialized with TCKind._tk_wstring.

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected TCKind(int _value)
      Deprecated.
      Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static TCKind from_int(int i)
      Converts the given int to the corresponding TCKind instance.
      int value()
      Retrieves the value of this TCKind instance.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _tk_null

        public static final int _tk_null
        The int constant for a null IDL data type.
        另请参见：
        Constant Field Values

      • _tk_void

        public static final int _tk_void
        The int constant for the IDL data type void.
        另请参见：
        Constant Field Values

      • _tk_short

        public static final int _tk_short
        The int constant for the IDL data type short.
        另请参见：
        Constant Field Values

      • _tk_long

        public static final int _tk_long
        The int constant for the IDL data type long.
        另请参见：
        Constant Field Values

      • _tk_ushort

        public static final int _tk_ushort
        The int constant for the IDL data type ushort.
        另请参见：
        Constant Field Values

      • _tk_ulong

        public static final int _tk_ulong
        The int constant for the IDL data type ulong.
        另请参见：
        Constant Field Values

      • _tk_float

        public static final int _tk_float
        The int constant for the IDL data type float.
        另请参见：
        Constant Field Values

      • _tk_double

        public static final int _tk_double
        The int constant for the IDL data type double.
        另请参见：
        Constant Field Values

      • _tk_boolean

        public static final int _tk_boolean
        The int constant for the IDL data type boolean.
        另请参见：
        Constant Field Values

      • _tk_char

        public static final int _tk_char
        The int constant for the IDL data type char.
        另请参见：
        Constant Field Values

      • _tk_octet

        public static final int _tk_octet
        The int constant for the IDL data type octet.
        另请参见：
        Constant Field Values

      • _tk_any

        public static final int _tk_any
        The int constant for the IDL data type any.
        另请参见：
        Constant Field Values

      • _tk_TypeCode

        public static final int _tk_TypeCode
        The int constant for the IDL data type TypeCode.
        另请参见：
        Constant Field Values

      • _tk_Principal

        public static final int _tk_Principal
        The int constant for the IDL data type Principal.
        另请参见：
        Constant Field Values

      • _tk_objref

        public static final int _tk_objref
        The int constant for the IDL data type objref.
        另请参见：
        Constant Field Values

      • _tk_struct

        public static final int _tk_struct
        The int constant for the IDL data type struct.
        另请参见：
        Constant Field Values

      • _tk_union

        public static final int _tk_union
        The int constant for the IDL data type union.
        另请参见：
        Constant Field Values

      • _tk_enum

        public static final int _tk_enum
        The int constant for the IDL data type enum.
        另请参见：
        Constant Field Values

      • _tk_string

        public static final int _tk_string
        The int constant for the IDL data type string.
        另请参见：
        Constant Field Values

      • _tk_sequence

        public static final int _tk_sequence
        The int constant for the IDL data type sequence.
        另请参见：
        Constant Field Values

      • _tk_array

        public static final int _tk_array
        The int constant for the IDL data type array.
        另请参见：
        Constant Field Values

      • _tk_alias

        public static final int _tk_alias
        The int constant for the IDL data type alias.
        另请参见：
        Constant Field Values

      • _tk_except

        public static final int _tk_except
        The int constant for the IDL data type except.
        另请参见：
        Constant Field Values

      • _tk_longlong

        public static final int _tk_longlong
        The int constant for the IDL data type longlong.
        另请参见：
        Constant Field Values

      • _tk_ulonglong

        public static final int _tk_ulonglong
        The int constant for the IDL data type ulonglong.
        另请参见：
        Constant Field Values

      • _tk_longdouble

        public static final int _tk_longdouble
        The int constant for the IDL data type longdouble.
        另请参见：
        Constant Field Values

      • _tk_wchar

        public static final int _tk_wchar
        The int constant for the IDL data type wchar.
        另请参见：
        Constant Field Values

      • _tk_wstring

        public static final int _tk_wstring
        The int constant for the IDL data type wstring.
        另请参见：
        Constant Field Values

      • _tk_fixed

        public static final int _tk_fixed
        The int constant for the IDL data type fixed.
        另请参见：
        Constant Field Values

      • _tk_value

        public static final int _tk_value
        The int constant for the IDL data type value.
        另请参见：
        Constant Field Values

      • _tk_value_box

        public static final int _tk_value_box
        The int constant for the IDL data type value_box.
        另请参见：
        Constant Field Values

      • _tk_native

        public static final int _tk_native
        The int constant for the IDL data type native.
        另请参见：
        Constant Field Values

      • _tk_abstract_interface

        public static final int _tk_abstract_interface
        The int constant for the IDL data type abstract interface.
        另请参见：
        Constant Field Values

      • tk_null

        public static final TCKind tk_null
        The TCKind constant whose value field is initialized with TCKind._tk_null.

      • tk_void

        public static final TCKind tk_void
        The TCKind constant whose value field is initialized with TCKind._tk_void.

      • tk_short

        public static final TCKind tk_short
        The TCKind constant whose value field is initialized with TCKind._tk_short.

      • tk_long

        public static final TCKind tk_long
        The TCKind constant whose value field is initialized with TCKind._tk_long.

      • tk_ushort

        public static final TCKind tk_ushort
        The TCKind constant whose value field is initialized with TCKind._tk_ushort.

      • tk_ulong

        public static final TCKind tk_ulong
        The TCKind constant whose value field is initialized with TCKind._tk_ulong.

      • tk_float

        public static final TCKind tk_float
        The TCKind constant whose value field is initialized with TCKind._tk_float.

      • tk_double

        public static final TCKind tk_double
        The TCKind constant whose value field is initialized with TCKind._tk_double.

      • tk_boolean

        public static final TCKind tk_boolean
        The TCKind constant whose value field is initialized with TCKind._tk_boolean.

      • tk_char

        public static final TCKind tk_char
        The TCKind constant whose value field is initialized with TCKind._tk_char.

      • tk_octet

        public static final TCKind tk_octet
        The TCKind constant whose value field is initialized with TCKind._tk_octet.

      • tk_any

        public static final TCKind tk_any
        The TCKind constant whose value field is initialized with TCKind._tk_any.

      • tk_TypeCode

        public static final TCKind tk_TypeCode
        The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.

      • tk_Principal

        public static final TCKind tk_Principal
        The TCKind constant whose value field is initialized with TCKind._tk_Principal.

      • tk_objref

        public static final TCKind tk_objref
        The TCKind constant whose value field is initialized with TCKind._tk_objref.

      • tk_struct

        public static final TCKind tk_struct
        The TCKind constant whose value field is initialized with TCKind._tk_struct.

      • tk_union

        public static final TCKind tk_union
        The TCKind constant whose value field is initialized with TCKind._tk_union.

      • tk_enum

        public static final TCKind tk_enum
        The TCKind constant whose value field is initialized with TCKind._tk_enum.

      • tk_string

        public static final TCKind tk_string
        The TCKind constant whose value field is initialized with TCKind._tk_string.

      • tk_sequence

        public static final TCKind tk_sequence
        The TCKind constant whose value field is initialized with TCKind._tk_sequence.

      • tk_array

        public static final TCKind tk_array
        The TCKind constant whose value field is initialized with TCKind._tk_array.

      • tk_alias

        public static final TCKind tk_alias
        The TCKind constant whose value field is initialized with TCKind._tk_alias.

      • tk_except

        public static final TCKind tk_except
        The TCKind constant whose value field is initialized with TCKind._tk_except.

      • tk_longlong

        public static final TCKind tk_longlong
        The TCKind constant whose value field is initialized with TCKind._tk_longlong.

      • tk_ulonglong

        public static final TCKind tk_ulonglong
        The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.

      • tk_longdouble

        public static final TCKind tk_longdouble
        The TCKind constant whose value field is initialized with TCKind._tk_longdouble.

      • tk_wchar

        public static final TCKind tk_wchar
        The TCKind constant whose value field is initialized with TCKind._tk_wchar.

      • tk_wstring

        public static final TCKind tk_wstring
        The TCKind constant whose value field is initialized with TCKind._tk_wstring.

      • tk_fixed

        public static final TCKind tk_fixed
        The TCKind constant whose value field is initialized with TCKind._tk_fixed.

      • tk_value

        public static final TCKind tk_value
        The TCKind constant whose value field is initialized with TCKind._tk_value.

      • tk_value_box

        public static final TCKind tk_value_box
        The TCKind constant whose value field is initialized with TCKind._tk_value_box.

      • tk_native

        public static final TCKind tk_native
        The TCKind constant whose value field is initialized with TCKind._tk_native.

      • tk_abstract_interface

        public static final TCKind tk_abstract_interface
        The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.

    • 构造方法详细信息

      • TCKind

        @Deprecated
protected TCKind(int _value)
        Deprecated. Do not use this constructor as this method should be private according to the OMG specification. Use from_int(int) instead.
        Creates a new TCKind instance initialized with the given int.
        参数：
        _value - the int to convert. It must be one of the int constants in the class TCKind.

    • 方法详细信息

      • value

        public int value()
        Retrieves the value of this TCKind instance.
        返回：
        the int that represents the kind of IDL data type for this TCKind instance

      • from_int

        public static TCKind from_int(int i)
        Converts the given int to the corresponding TCKind instance.
        参数：
        i - the int to convert. It must be one of the int constants in the class TCKind.
        返回：
        the TCKind instance whose value field matches the given int
        抛出：
        BAD_PARAM - if the given int does not match the _value field of any TCKind instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TIMEOUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TIMEOUT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TIMEOUT
  • 所有已实现的接口：
    Serializable

    public final class TIMEOUT
extends SystemException
    TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded. It is a standard system exception because time-to-live QoS can be applied to any invocation.
    从以下版本开始：
    J2SE 1.5
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TIMEOUT()
      Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
      TIMEOUT(int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified minor code and completion status.
      TIMEOUT(String detailMessage)
      Constructs an TIMEOUT exception with the specified message.
      TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TIMEOUT

        public TIMEOUT()
        Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.

      • TIMEOUT

        public TIMEOUT(String detailMessage)
        Constructs an TIMEOUT exception with the specified message.
        参数：
        detailMessage - string containing a detailed message.

      • TIMEOUT

        public TIMEOUT(int minorCode,
       CompletionStatus completionStatus)
        Constructs an TIMEOUT exception with the specified minor code and completion status.
        参数：
        minorCode - minor code.
        completionStatus - completion status.

      • TIMEOUT

        public TIMEOUT(String detailMessage,
       int minorCode,
       CompletionStatus completionStatus)
        Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
        参数：
        detailMessage - string containing a detailed message.
        minorCode - minor code.
        completionStatus - completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toac>ncinc=>>..r//orr/..Ro.erea</


TRANSACTION_MODE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TRANSACTION_MODE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_MODE
  • 所有已实现的接口：
    Serializable

    public final class TRANSACTION_MODE
extends SystemException
    The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation). It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TRANSACTION_MODE()
      Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_MODE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
      TRANSACTION_MODE(String s)
      Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TRANSACTION_MODE

        public TRANSACTION_MODE()
        Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_MODE

        public TRANSACTION_MODE(String s)
        Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • TRANSACTION_MODE

        public TRANSACTION_MODE(int minor,
                CompletionStatus completed)
        Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • TRANSACTION_MODE

        public TRANSACTION_MODE(String s,
                int minor,
                CompletionStatus completed)
        Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt>el

go Rhddlma/Aaddcodd< o


TRANSACTION_REQUIRED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TRANSACTION_REQUIRED

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_REQUIRED
  • 所有已实现的接口：
    Serializable

    public final class TRANSACTION_REQUIRED
extends SystemException
    Exception indicates that the request carried a null transaction context, but an active transaction is required.

    It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG Transaction Service specfication has details.

    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TRANSACTION_REQUIRED()
      Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
      TRANSACTION_REQUIRED(String s)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED()
        Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(String s)
        Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(int minor,
                    CompletionStatus completed)
        Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • TRANSACTION_REQUIRED

        public TRANSACTION_REQUIRED(String s,
                    int minor,
                    CompletionStatus completed)
        Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aT<<> "asss>i a!!===<= st s


TRANSACTION_ROLLEDBACK

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TRANSACTION_ROLLEDBACK

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
  • 所有已实现的接口：
    Serializable

    public final class TRANSACTION_ROLLEDBACK
extends SystemException
    Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back. Thus, the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.

    See the OMG Transaction Service specification for details. It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TRANSACTION_ROLLEDBACK()
      Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
      TRANSACTION_ROLLEDBACK(String s)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK()
        Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(String s)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(int minor,
                      CompletionStatus completed)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • TRANSACTION_ROLLEDBACK

        public TRANSACTION_ROLLEDBACK(String s,
                      int minor,
                      CompletionStatus completed)
        Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.evk>">bnllb""a>tt/.arllr lltan>ii<


TRANSACTION_UNAVAILABLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TRANSACTION_UNAVAILABLE

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
  • 所有已实现的接口：
    Serializable

    public final class TRANSACTION_UNAVAILABLE
extends SystemException
    The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated. It contains a minor code, which gives information about what caused the exception, and a completion status. It may also contain a string describing the exception. The OMG CORBA core 2.4 specification has details.
    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TRANSACTION_UNAVAILABLE()
      Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
      TRANSACTION_UNAVAILABLE(String s)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE()
        Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(String s)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(int minor,
                       CompletionStatus completed)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • TRANSACTION_UNAVAILABLE

        public TRANSACTION_UNAVAILABLE(String s,
                       int minor,
                       CompletionStatus completed)
        Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rrbDrDsD&D>�&nb;b/s�-a�3b3//>8n<>/g >l.


TRANSIENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 TRANSIENT

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.TRANSIENT
  • 所有已实现的接口：
    Serializable

    public final class TRANSIENT
extends SystemException
    Exception thrown when the ORB attempted to reach an object and failed. It is not an indication that an object does not exist. Instead, it simply means that no further determination of an object's status was possible because it could not be reached. This exception is raised if an attempt to establish a connection fails, for example, because the server or the implementation repository is down.

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      TRANSIENT()
      Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      TRANSIENT(int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified minor code and completion status.
      TRANSIENT(String s)
      Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      TRANSIENT(String s, int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TRANSIENT

        public TRANSIENT()
        Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • TRANSIENT

        public TRANSIENT(String s)
        Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • TRANSIENT

        public TRANSIENT(int minor,
         CompletionStatus completed)
        Constructs a TRANSIENT exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • TRANSIENT

        public TRANSIENT(String s,
         int minor,
         CompletionStatus completed)
        Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bomtrtututr"Subt蘣ss< =c=cssalel


TypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 TypeCode

  • java.lang.Object
    • org.omg.CORBA.TypeCode
  • 所有已实现的接口：
    Serializable, IDLEntity

    public abstract class TypeCode
extends Object
implements IDLEntity
    A container for information about a specific CORBA data type.

    TypeCode objects are used:

    • in the Dynamic Invocation Interface -- to indicate the types of the actual arguments or the type of the return value.
      NamedValue objects are used to represent arguments and return values. One of their components is an Any object, which in turn has as one of its components a TypeCode object.
    • by an Interface Repository to represent the type specifications that are part of many OMG IDL declarations

    The representation of a TypeCode object is opaque, but abstractly, a TypeCode object consists of:

    • a kind field, which is set to an instance of the class TCKind
    • zero or more additional fields appropriate for the particular kind. For example, the TypeCode object describing the OMG IDL type 1ong has kind TCKind.tk_long and no additional fields. The TypeCode describing OMG IDL type sequence<boolean, 10> has a kind field with the value TCKind.tk_sequence and also fields with the values boolean and 10 for the type of sequence elements and the length of the sequence.

    TypeCode objects can be obtained in various ways:
    1. from a call to the method Any.insert_X, where X is a basic IDL type. This method creates a TypeCode object for type X and assigns it to the Any object's type field.
    2. from invocations of methods in the ORB class

      For example, the following creates a TypeCode object for a string with a maximum of 30 characters:

         org.omg.CORBA.TypeCode tcString = orb.create_string_tc(30);

      The following creates a TypeCode object for an array of five strings:

         org.omg.CORBA.TypeCode tcArray = orb.create_array_tc(
                                       5, TCKind.tk_string);

      The following creates a TypeCode object for an interface named "Account":

         org.omg.CORBA.TypeCode tcInterface = orb.create_interface_tc(
                                                 "thisId", "Account");
    3. as the return value from the _type method in Holder classes for user-defined IDL types. These Holder classes are generated by the idltojava compiler.
    4. from a CORBA Interface Repository

    Most of the methods in the class TypeCode are accessors, and the information contained in a TypeCode object is specific to a particular type. Therefore, methods must be invoked only on the kind of type codes to which they apply. If an accessor method tries to access information from an inappropriate kind of type code, it will throw the exception TypeCodePackage.BadKind. For example, if the method discriminator_type is called on anything other than a union, it will throw BadKind because only unions have a discriminator. The following list shows which methods apply to which kinds of type codes:

    These methods may be invoked on all TypeCode kinds:

    • equal
    • kind

    These methods may be invoked on objref, struct, union, enum, alias, exception, value, value_box, native, and abstract_interface:

    • id
    • name

    These methods may be invoked on struct, union, enum, and exception:

    • member_count
    • member_name

    These methods may be invoked on struct, union, and exception:

    • member_type(int index)

    These methods may be invoked on union:

    • member_label
    • discriminator_type
    • default_index

    These methods may be invoked on string, sequence, and array:

    • length

    These methods may be invoked on alias, sequence, array, and value_box:

    • content_type

    Unlike other CORBA pseudo-objects, TypeCode objects can be passed as general IDL parameters.

    The methods parameter and param_count, which are deprecated, are not mapped.

    Java IDL extends the CORBA specification to allow all operations permitted on a struct TypeCode to be permitted on an exception TypeCode as well.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeCode()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract TypeCode concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      abstract int default_index()
      Returns the index of the default member, or -1 if there is no default member.
      abstract TypeCode discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract boolean equal(TypeCode tc)
      Compares this TypeCode object with the given one, testing for equality.
      abstract boolean equivalent(TypeCode tc)
      Tests to see if the given TypeCode object is equivalent to this TypeCode object.
      abstract short fixed_digits()
      Returns the number of digits in the fixed type described by this TypeCode object.
      abstract short fixed_scale()
      Returns the scale of the fixed type described by this TypeCode object.
      abstract TypeCode get_compact_typecode()
      Strips out all optional name and member name fields, but leaves all alias typecodes intact.
      abstract String id()
      Retrieves the RepositoryId globally identifying the type of this TypeCode object.
      abstract TCKind kind()
      Retrieves the kind of this TypeCode object.
      abstract int length()
      Returns the number of elements in the type described by this TypeCode object.
      abstract int member_count()
      Retrieves the number of members in the type described by this TypeCode object.
      abstract Any member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
      abstract String name()
      Retrieves the simple name identifying this TypeCode object within its enclosing scope.
      abstract short type_modifier()
      Returns a constant indicating the modifier of the value type that this TypeCode object describes.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TypeCode

        public TypeCode()

    • 方法详细信息

      • equal

        public abstract boolean equal(TypeCode tc)
        Compares this TypeCode object with the given one, testing for equality. TypeCode objects are equal if they are interchangeable and give identical results when TypeCode operations are applied to them.
        参数：
        tc - the TypeCode object to compare against
        返回：
        true if the type codes are equal; false otherwise

      • equivalent

        public abstract boolean equivalent(TypeCode tc)
        Tests to see if the given TypeCode object is equivalent to this TypeCode object.

        参数：
        tc - the typecode to compare with this typecode
        返回：
        true if the given typecode is equivalent to this typecode; false otherwise

      • get_compact_typecode

        public abstract TypeCode get_compact_typecode()
        Strips out all optional name and member name fields, but leaves all alias typecodes intact.
        返回：
        a TypeCode object with optional name and member name fields stripped out, except for alias typecodes, which are left intact
        另请参见：
        CORBA package comments for unimplemented features

      • kind

        public abstract TCKind kind()
        Retrieves the kind of this TypeCode object. The kind of a type code determines which TypeCode methods may legally be invoked on it.

        The method kind may be invoked on any TypeCode object.

        返回：
        the TCKind instance indicating the value of the kind field of this TypeCode object

      • id

        public abstract String id()
                   throws BadKind
        Retrieves the RepositoryId globally identifying the type of this TypeCode object.

        The method id can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface type codes. Object reference, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects always have a RepositoryId. Structure, union, enumeration, and alias TypeCode objects obtained from the Interface Repository or the method ORB.create_operation_list also always have a RepositoryId. If there is no RepositoryId, the method can return an empty string.

        返回：
        the RepositoryId for this TypeCode object or an empty string if there is no RepositoryID
        抛出：
        BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

      • name

        public abstract String name()
                     throws BadKind
        Retrieves the simple name identifying this TypeCode object within its enclosing scope. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the type in any particular Repository, and may even be an empty string.

        The method name can be invoked on object reference, structure, union, enumeration, alias, exception, valuetype, boxed valuetype, native, and abstract interface TypeCode objects.

        返回：
        the name identifying this TypeCode object or an empty string
        抛出：
        BadKind - if the method is invoked on an inappropriate kind ofTypeCode object

      • member_count

        public abstract int member_count()
                          throws BadKind
        Retrieves the number of members in the type described by this TypeCode object.

        The method member_count can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        返回：
        the number of members constituting the type described by this TypeCode object
        抛出：
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_name

        public abstract String member_name(int index)
                            throws BadKind,
                                   Bounds
        Retrieves the simple name of the member identified by the given index. Since names are local to a Repository, the name returned from a TypeCode object may not match the name of the member in any particular Repository, and may even be an empty string.

        The method member_name can be invoked on structure, union, and enumeration TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        参数：
        index - index of the member for which a name is being reqested
        返回：
        simple name of the member identified by the index or an empty string
        抛出：
        Bounds - if the index is equal to or greater than the number of members constituting the type
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_type

        public abstract TypeCode member_type(int index)
                              throws BadKind,
                                     Bounds
        Retrieves the TypeCode object describing the type of the member identified by the given index.

        The method member_type can be invoked on structure and union TypeCode objects. Java IDL extends the CORBA specification to allow this method to operate on exceptions as well.

        参数：
        index - index of the member for which type information is begin requested
        返回：
        the TypeCode object describing the member at the given index
        抛出：
        Bounds - if the index is equal to or greater than the number of members constituting the type
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • member_label

        public abstract Any member_label(int index)
                          throws BadKind,
                                 Bounds
        Retrieves the label of the union member identified by the given index. For the default member, the label is the zero octet.

        The method member_label can only be invoked on union TypeCode objects.

        参数：
        index - index of the union member for which the label is being requested
        返回：
        an Any object describing the label of the requested union member or the zero octet for the default member
        抛出：
        Bounds - if the index is equal to or greater than the number of members constituting the union
        BadKind - if the method is invoked on a non-union TypeCode object

      • discriminator_type

        public abstract TypeCode discriminator_type()
                                     throws BadKind
        Returns a TypeCode object describing all non-default member labels. The method discriminator_type can be invoked only on union TypeCode objects.
        返回：
        the TypeCode object describing the non-default member labels
        抛出：
        BadKind - if the method is invoked on a non-union TypeCode object

      • default_index

        public abstract int default_index()
                           throws BadKind
        Returns the index of the default member, or -1 if there is no default member.

        The method default_index can be invoked only on union TypeCode objects.

        返回：
        the index of the default member, or -1 if there is no default member
        抛出：
        BadKind - if the method is invoked on a non-union TypeCode object

      • length

        public abstract int length()
                    throws BadKind
        Returns the number of elements in the type described by this TypeCode object. For strings and sequences, it returns the bound, with zero indicating an unbounded string or sequence. For arrays, it returns the number of elements in the array.

        The method length can be invoked on string, sequence, and array TypeCode objects.

        返回：
        the bound for strings and sequences, or the number of elements for arrays
        抛出：
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • content_type

        public abstract TypeCode content_type()
                               throws BadKind
        Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object. For sequences and arrays, it returns the element type. For aliases, it returns the original type. Note that multidimensional arrays are represented by nesting TypeCode objects, one per dimension. For boxed valuetypes, it returns the boxed type.

        The method content_type can be invoked on sequence, array, alias, and boxed valuetype TypeCode objects.

        返回：
        a TypeCode object representing the element type for sequences and arrays, the original type for aliases, or the boxed type for boxed valuetypes.
        抛出：
        BadKind - if the method is invoked on an inappropriate kind of TypeCode object

      • fixed_digits

        public abstract short fixed_digits()
                            throws BadKind
        Returns the number of digits in the fixed type described by this TypeCode object. For example, the typecode for the number 3000.275d could be fixed<7,3>, where 7 is the precision and 3 is the scale.
        返回：
        the total number of digits
        抛出：
        BadKind - if this method is invoked on an inappropriate kind of TypeCode object

      • fixed_scale

        public abstract short fixed_scale()
                           throws BadKind
        Returns the scale of the fixed type described by this TypeCode object. A positive number indicates the number of digits to the right of the decimal point. For example, the number 3000d could have the typecode fixed<4,0>, where the first number is the precision and the second number is the scale. A negative number is also possible and adds zeroes to the left of the decimal point. In this case, fixed<1,-3>, could be the typecode for the number 3000d.
        返回：
        the scale of the fixed type that this TypeCode object describes
        抛出：
        BadKind - if this method is invoked on an inappropriate kind of TypeCode object

      • member_visibility

        public abstract short member_visibility(int index)
                                 throws BadKind,
                                        Bounds
        Returns the constant that indicates the visibility of the member at the given index. This operation can only be invoked on non-boxed value TypeCode objects.
        参数：
        index - an int indicating the index into the value
        返回：
        either PRIVATE_MEMBER.value or PUBLIC_MEMBER.value
        抛出：
        BadKind - if this method is invoked on a non-value type TypeCode object
        Bounds - if the given index is out of bounds
        另请参见：
        CORBA package comments for unimplemented features

      • type_modifier

        public abstract short type_modifier()
                             throws BadKind
        Returns a constant indicating the modifier of the value type that this TypeCode object describes. The constant returned must be one of the following: VM_NONE.value, VM_ABSTRACT.value, VM_CUSTOM.value, or VM_TRUNCATABLE.value,
        返回：
        a constant describing the value type that this TypeCode object describes
        抛出：
        BadKind - if this method is invoked on a non-value type TypeCode object
        另请参见：
        CORBA package comments for unimplemented features

      • concrete_base_type

        public abstract TypeCode concrete_base_type()
                                     throws BadKind
        Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes. Returns null if it doesn't have a concrete base type.
        返回：
        the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes
        抛出：
        BadKind - if this method is invoked on a non-boxed value type TypeCode object
        另请参见：
        CORBA package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


TypeCodeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 TypeCodeHolder

  • java.lang.Object
    • org.omg.CORBA.TypeCodeHolder
  • 所有已实现的接口：
    Streamable

    public final class TypeCodeHolder
extends Object
implements Streamable
    The Holder for TypeCode. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a TypeCode object that is used to store "out" and "inout" parameters in IDL operations. If an IDL operation signature has an IDL TypeCode as an "out" or "inout" parameter, the programmer must pass an instance of TypeCodeHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myTypeCodeHolder is an instance of TypeCodeHolder, the value stored in its value field can be accessed with myTypeCodeHolder.value.

    从以下版本开始：
    JDK1.2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      TypeCode value
      The TypeCode value held by this TypeCodeHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeCodeHolder()
      Constructs a new TypeCodeHolder object with its value field initialized to null.
      TypeCodeHolder(TypeCode initial)
      Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
      void _write(OutputStream output)
      Marshals to output the value in this TypeCodeHolder object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public TypeCode value
        The TypeCode value held by this TypeCodeHolder object.

    • 构造方法详细信息

      • TypeCodeHolder

        public TypeCodeHolder()
        Constructs a new TypeCodeHolder object with its value field initialized to null.

      • TypeCodeHolder

        public TypeCodeHolder(TypeCode initial)
        Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
        参数：
        initial - the TypeCode object with which to initialize the value field of the newly-created TypeCodeHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in this TypeCodeHolder object.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in this TypeCodeHolder object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

clooasdssdt dttr">>iittheevtettdhintnnrssR=t


ULongLongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ULongLongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ULongLongSeqHelper

  • public abstract class ULongLongSeqHelper
extends Object
    The Helper for ULongLongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ULongLongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      ULongLongSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static long[] | extract(Any a)
      static String | id()
      static void | insert(Any a, long[] that)
      static long[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, long[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ULongLongSeqHelper

        public ULongLongSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          long[] that)

      • extract

        public static long[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static long[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         long[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>p .h.aaBgg


ULongLongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ULongLongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ULongLongSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class ULongLongSeqHolder
extends Object
implements Streamable
    The Holder for ULongLongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ULongLongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:37 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      long[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ULongLongSeqHolder()
      ULongLongSeqHolder(long[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public long[] value

    • 构造方法详细信息

      • ULongLongSeqHolder

        public ULongLongSeqHolder()

      • ULongLongSeqHolder

        public ULongLongSeqHolder(long[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ynaLalsiLi slpponlepmm"tl Aslsl"A<


ULongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ULongSeqHelper

  • java.lang.Object
    • org.omg.CORBA.ULongSeqHelper

  • public abstract class ULongSeqHelper
extends Object
    The Helper for ULongSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ULongSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      ULongSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int[] | extract(Any a)
      static String | id()
      static void | insert(Any a, int[] that)
      static int[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ULongSeqHelper

        public ULongSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int[] that)

      • extract

        public static int[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b<>e>n>>>a<<>aa�.ii.=p./.."l>i


ULongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ULongSeqHolder

  • java.lang.Object
    • org.omg.CORBA.ULongSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class ULongSeqHolder
extends Object
implements Streamable
    The Holder for ULongSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/ULongSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      int[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ULongSeqHolder()
      ULongSeqHolder(int[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public int[] value

    • 构造方法详细信息

      • ULongSeqHolder

        public ULongSeqHolder()

      • ULongSeqHolder

        public ULongSeqHolder(int[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ao9 � e 0 >#00a 319b93#=n0&a e糽羍猺ll耍埃税n


UnionMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 UnionMember

  • java.lang.Object
    • org.omg.CORBA.UnionMember
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class UnionMember
extends Object
implements IDLEntity
    A description in the Interface Repository of a member of an IDL union.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Any label
      The label of the union member described by this UnionMember object.
      String name
      The name of the union member described by this UnionMember object.
      TypeCode type
      The type of the union member described by this UnionMember object.
      IDLType type_def
      The typedef that represents the IDL type of the union member described by this UnionMember object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnionMember()
      Constructs a new UnionMember object with its fields initialized to null.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        public String name
        The name of the union member described by this UnionMember object.

      • label

        public Any label
        The label of the union member described by this UnionMember object.

      • type

        public TypeCode type
        The type of the union member described by this UnionMember object.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the union member described by this UnionMember object.

    • 构造方法详细信息

      • UnionMember

        public UnionMember()
        Constructs a new UnionMember object with its fields initialized to null.

      • UnionMember

        public UnionMember(String __name,
           Any __label,
           TypeCode __type,
           IDLType __type_def)
        Constructs a new UnionMember object with its fields initialized to the given values.
        参数：
        __name - a String object with the name of this UnionMember object
        __label - an Any object with the label of this UnionMember object
        __type - a TypeCode object describing the type of this UnionMember object
        __type_def - an IDLType object that represents the IDL type of this UnionMember object
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tBhi_ioieia"MetdMdeeli;r ffscuerl_"�> <-


UnionMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 UnionMemberHelper

  • java.lang.Object
    • org.omg.CORBA.UnionMemberHelper

  • public abstract class UnionMemberHelper
extends Object
    The Helper for UnionMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UnionMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnionMemberHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static UnionMember | extract(Any a)
      static String | id()
      static void | insert(Any a, UnionMember that)
      static UnionMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnionMember value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UnionMemberHelper

        public UnionMemberHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          UnionMember that)

      • extract

        public static UnionMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnionMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         UnionMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/jljlslOl.n.Obc.aff_cytmaa&/ilsn& ;l


UNKNOWN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 UNKNOWN

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.UNKNOWN
  • 所有已实现的接口：
    Serializable

    public final class UNKNOWN
extends SystemException
    This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression. UNKNOWN is also raised if the server returns a system exception that is unknown to the client. (This can happen if the server uses a later version of CORBA than the client and new system exceptions have been added to the later version.)

    It contains a minor code, which gives more detailed information about what caused the exception, and a completion status. It may also contain a string describing the exception.

    See the section Minor Code Meanings to see the minor codes for this exception.

    另请参见：
    documentation on Java IDL exceptions

    • 字段摘要

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      UNKNOWN()
      Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
      UNKNOWN(int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified minor code and completion status.
      UNKNOWN(String s)
      Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
      UNKNOWN(String s, int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UNKNOWN

        public UNKNOWN()
        Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.

      • UNKNOWN

        public UNKNOWN(String s)
        Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
        参数：
        s - the String containing a detail message

      • UNKNOWN

        public UNKNOWN(int minor,
       CompletionStatus completed)
        Constructs an UNKNOWN exception with the specified minor code and completion status.
        参数：
        minor - the minor code
        completed - the completion status

      • UNKNOWN

        public UNKNOWN(String s,
       int minor,
       CompletionStatus completed)
        Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
        参数：
        s - the String containing a description message
        minor - the minor code
        completed - the completion status
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ityny.nyr>ans;.


UnknownUserException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 UnknownUserException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.UnknownUserException
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class UnknownUserException
extends UserException
    A class that contains user exceptions returned by the server. When the client uses the DII to make an invocation, any user exception returned from the server is enclosed in an Any object contained in the UnknownUserException object. This is available from the Environment object returned by the method Request.env.
    另请参见：
    documentation on Java IDL exceptions, Request

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Any except
      The Any instance that contains the actual user exception thrown by the server.

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownUserException()
      Constructs an UnknownUserException object.
      UnknownUserException(Any a)
      Constructs an UnknownUserException object that contains the given Any object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • except

        public Any except
        The Any instance that contains the actual user exception thrown by the server.

    • 构造方法详细信息

      • UnknownUserException

        public UnknownUserException()
        Constructs an UnknownUserException object.

      • UnknownUserException

        public UnknownUserException(Any a)
        Constructs an UnknownUserException object that contains the given Any object.
        参数：
        a - an Any object that contains a user exception returned by the server
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-sd./...p..//.... <<>li裻北l�<<�><襱"leea


UnknownUserExceptionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 UnknownUserExceptionHelper

  • java.lang.Object
    • org.omg.CORBA.UnknownUserExceptionHelper

  • public abstract class UnknownUserExceptionHelper
extends Object
    The Helper for UnknownUserException. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UnknownUserExceptionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownUserExceptionHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static UnknownUserException | extract(Any a)
      static String | id()
      static void | insert(Any a, UnknownUserException that)
      static UnknownUserException | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnknownUserException value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UnknownUserExceptionHelper

        public UnknownUserExceptionHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          UnknownUserException that)

      • extract

        public static UnknownUserException extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnknownUserException read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         UnknownUserException value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>t<"v"r"i"t lillt=llcC.s p襰


UnknownUserExceptionHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 UnknownUserExceptionHolder

  • java.lang.Object
    • org.omg.CORBA.UnknownUserExceptionHolder
  • 所有已实现的接口：
    Streamable

    public final class UnknownUserExceptionHolder
extends Object
implements Streamable
    The Holder for UnknownUserException. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/UnknownUserExceptionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:52:22 PM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      UnknownUserException value

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownUserExceptionHolder()
      UnknownUserExceptionHolder(UnknownUserException initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public UnknownUserException value

    • 构造方法详细信息

      • UnknownUserExceptionHolder

        public UnknownUserExceptionHolder()

      • UnknownUserExceptionHolder

        public UnknownUserExceptionHolder(UnknownUserException initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bSAOaO"8 OBTr NBMO== / i aa/ s> evokae>.


UNSUPPORTED_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface UNSUPPORTED_POLICY

  • public interface UNSUPPORTED_POLICY
    One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The Error code for PolicyError exception.

    • 字段详细信息

      • value

        static final short value
        The Error code for PolicyError exception.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ilncbeejeed>>edde>eelopet>


UNSUPPORTED_POLICY_VALUE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface UNSUPPORTED_POLICY_VALUE

  • public interface UNSUPPORTED_POLICY_VALUE
    A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The Error code for PolicyError exception.

    • 字段详细信息

      • value

        static final short value
        The Error code for PolicyError exception.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

so=>>/<<-L/c /rHiiLCusnf ve


UserException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 UserException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
  • 所有已实现的接口：
    Serializable, IDLEntity
    直接已知子类：
    AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, BadKind, Bounds, Bounds, CannotProceed, DuplicateName, FormatMismatch, ForwardRequest, ForwardRequest, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, NoContext, NoServant, NotEmpty, NotFound, ObjectAlreadyActive, ObjectNotActive, PolicyError, ServantAlreadyActive, ServantNotActive, TypeMismatch, TypeMismatch, TypeMismatch, UnknownEncoding, UnknownUserException, WrongAdapter, WrongPolicy, WrongTransaction

    public abstract class UserException
extends Exception
implements IDLEntity
    The root class for CORBA IDL-defined user exceptions. All CORBA user exceptions are checked exceptions, which means that they need to be declared in method signatures.
    另请参见：
    documentation on Java IDL exceptions

    • 构造方法摘要

      Constructors
      修饰符 构造方法与描述
      protected UserException()
      Constructs a UserException object.
      protected UserException(String reason)
      Constructs a UserException object with a detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UserException

        protected UserException()
        Constructs a UserException object. This method is called only by subclasses.

      • UserException

        protected UserException(String reason)
        Constructs a UserException object with a detail message. This method is called only by subclasses.
        参数：
        reason - a String object giving the reason for this exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f<=< ie> <<>iii�.omul�"ihe>U /h.Bhc�


Uses of Package org.omg.CORBA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA

  • Packages that use org.omg.CORBA
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA used by javax.rmi.CORBA
    类与描述
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    SystemException
    The root class for all CORBA standard exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    AnySeqHolder
    The Holder for AnySeq.
    BAD_INV_ORDER
    This exception indicates that the caller has invoked operations in the wrong order.
    BAD_OPERATION
    Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    BooleanSeqHolder
    The Holder for BooleanSeq.
    Bounds
    A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
    CharSeqHolder
    The Holder for CharSeq.
    CompletionStatus
    An object that indicates whether a method had completed running when a SystemException was thrown.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    DATA_CONVERSION
    This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
    DataInputStream
    Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
    DataOutputStream
    Defines the methods used to write primitive data types to output streams for marshalling custom value types.
    DefinitionKind
    The class that provides the constants used to identify the type of an Interface Repository object.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    DomainManagerOperations
    Provides the DomainManager with the means to access policies.
    DoubleSeqHolder
    The Holder for DoubleSeq.
    DynAny
    Deprecated.
    Use the new DynAny instead
    DynArray
    Deprecated.
    Use the new DynArray instead
    DynEnum
    Deprecated.
    Use the new DynEnum instead
    DynSequence
    Deprecated.
    Use the new DynSequence instead
    DynStruct
    Deprecated.
    Use the new DynStruct instead
    DynUnion
    Deprecated.
    Use the new DynUnion instead
    Environment
    A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    FloatSeqHolder
    The Holder for FloatSeq.
    IDLType
    An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
    IDLTypeOperations
    This interface must be implemented by all IDLType objects.
    IRObject
    An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
    IRObjectOperations
    This is the Operations interface for the mapping from IRObject.
    LongLongSeqHolder
    The Holder for LongLongSeq.
    LongSeqHolder
    The Holder for LongSeq.
    MARSHAL
    A request or reply from the network is structurally invalid.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NameValuePair
    Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
    NVList
    A modifiable list containing NamedValue objects.
    Object
    The definition for a CORBA object reference.
    OctetSeqHolder
    The Holder for OctetSeq.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ParameterMode
    Enumeration of parameter modes for Parameter.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyError
    A user exception thrown when a policy error occurs.
    PolicyOperations
    Provides the operations for a Policy object.
    Principal
    Deprecated.
    Deprecated by CORBA 2.2.
    Request
    An object containing the information necessary for invoking a method.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    ServiceDetail
    An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
    ServiceInformation
    An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
    ServiceInformationHolder
    The Holder for ServiceInformation.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    ShortSeqHolder
    The Holder for ShortSeq.
    StructMember
    Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
    SystemException
    The root class for all CORBA standard exceptions.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
    ULongLongSeqHolder
    The Holder for ULongLongSeq.
    ULongSeqHolder
    The Holder for ULongSeq.
    UnionMember
    A description in the Interface Repository of a member of an IDL union.
    UnknownUserException
    A class that contains user exceptions returned by the server.
    UserException
    The root class for CORBA IDL-defined user exceptions.
    UShortSeqHolder
    The Holder for UShortSeq.
    ValueMember
    A description in the Interface Repository of a member of a value object.
    WCharSeqHolder
    The Holder for WCharSeq.
    WrongTransaction
    The CORBA WrongTransaction user-defined exception.
  • Classes in org.omg.CORBA used by org.omg.CORBA.DynAnyPackage
    类与描述
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.ORBPackage
    类与描述
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.TypeCodePackage
    类与描述
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CORBA.portable
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Context
    An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
    ContextList
    An object containing a modifiable list of String objects that represent property names.
    CustomMarshal
    An abstract value type that is meant to be used by the ORB, not the user.
    DomainManager
    Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
    ExceptionList
    An object used in Request operations to describe the exceptions that can be thrown by a method.
    NamedValue
    An object used in the DII and DSI to describe arguments and return values.
    NVList
    A modifiable list containing NamedValue objects.
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    Principal
    Deprecated.
    Deprecated by CORBA 2.2.
    Request
    An object containing the information necessary for invoking a method.
    SetOverrideType
    The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
    SystemException
    The root class for all CORBA standard exceptions.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.CORBA_2_3
    类与描述
    BAD_PARAM
    Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
  • Classes in org.omg.CORBA used by org.omg.CosNaming
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    DynamicImplementation
    Deprecated.
    org.omg.CORBA.DynamicImplementation
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    ServerRequest
    An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.CosNaming.NamingContextExtPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.CosNaming.NamingContextPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.Dynamic
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    ParameterMode
    Enumeration of parameter modes for Parameter.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    TCKind
    The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny.DynAnyFactoryPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.DynamicAny.DynAnyPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.IOP
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.IOP.CodecFactoryPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.IOP.CodecPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.Messaging
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.PortableInterceptor
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Object
    The definition for a CORBA object reference.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyError
    A user exception thrown when a policy error occurs.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableInterceptor.ORBInitInfoPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    Current
    Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
    CurrentOperations
    The interface for Current.
    Object
    The definition for a CORBA object reference.
    ORB
    A class providing APIs for the CORBA Object Request Broker features.
    Policy
    Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
    PolicyOperations
    Provides the operations for a Policy object.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.CurrentPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.POAManagerPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.POAPackage
    类与描述
    Any
    Serves as a container for any data that can be described in IDL or for any IDL primitive type.
    TypeCode
    A container for information about a specific CORBA data type.
    UserException
    The root class for CORBA IDL-defined user exceptions.
  • Classes in org.omg.CORBA used by org.omg.PortableServer.ServantLocatorPackage
    类与描述
    TypeCode
    A container for information about a specific CORBA data type.
  • Classes in org.omg.CORBA used by org.omg.SendingContext
    类与描述
    Object
    The definition for a CORBA object reference.
  • Classes in org.omg.CORBA used by org.omg.stub.java.rmi
    类与描述
    Object
    The definition for a CORBA object reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A


UShortSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 UShortSeqHelper

  • java.lang.Object
    • org.omg.CORBA.UShortSeqHelper

  • public abstract class UShortSeqHelper
extends Object
    The Helper for UShortSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/UShortSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      UShortSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short[] | extract(Any a)
      static String | id()
      static void | insert(Any a, short[] that)
      static short[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UShortSeqHelper

        public UShortSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short[] that)

      • extract

        public static short[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"n/".r..rheerhh,wwwnjbaO//t"/>iej,>t


UShortSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 UShortSeqHolder

  • java.lang.Object
    • org.omg.CORBA.UShortSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class UShortSeqHolder
extends Object
implements Streamable
    The Holder for UShortSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/UShortSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      UShortSeqHolder()
      UShortSeqHolder(short[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public short[] value

    • 构造方法详细信息

      • UShortSeqHolder

        public UShortSeqHolder()

      • UShortSeqHolder

        public UShortSeqHolder(short[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

L.UIDIuIAILYYCIIDSoil i>vv cd iiv>so�<<竐s8s


ValueBaseHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ValueBaseHelper

  • java.lang.Object
    • org.omg.CORBA.ValueBaseHelper

  • public abstract class ValueBaseHelper
extends Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValueBaseHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Serializable | extract(Any a)
      static String | id()
      static void | insert(Any a, Serializable that)
      static Serializable | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Serializable value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ValueBaseHelper

        public ValueBaseHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Serializable that)

      • extract

        public static Serializable extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Serializable read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Serializable value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>iJsall<>>�/<<..癶颿cavr


ValueBaseHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ValueBaseHolder

  • java.lang.Object
    • org.omg.CORBA.ValueBaseHolder
  • 所有已实现的接口：
    Streamable

    public final class ValueBaseHolder
extends Object
implements Streamable
    The Holder for ValueBase. For more information on Holder files, see "Generated Files: Holder Files".

    A Holder class for a java.io.Serializable that is used to store "out" and "inout" parameters in IDL methods. If an IDL method signature has an IDL ValueBase as an "out" or "inout" parameter, the programmer must pass an instance of ValueBaseHolder as the corresponding parameter in the method invocation; for "inout" parameters, the programmer must also fill the "in" value to be sent to the server. Before the method invocation returns, the ORB will fill in the value corresponding to the "out" value returned from the server.

    If myValueBaseHolder is an instance of ValueBaseHolder, the value stored in its value field can be accessed with myValueBaseHolder.value.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Serializable value
      The java.io.Serializable value held by this ValueBaseHolder object.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValueBaseHolder()
      Constructs a new ValueBaseHolder object with its value field initialized to 0.
      ValueBaseHolder(Serializable initial)
      Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      TypeCode _type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      void _write(OutputStream output)
      Marshals to output the value in the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Serializable value
        The java.io.Serializable value held by this ValueBaseHolder object.

    • 构造方法详细信息

      • ValueBaseHolder

        public ValueBaseHolder()
        Constructs a new ValueBaseHolder object with its value field initialized to 0.

      • ValueBaseHolder

        public ValueBaseHolder(Serializable initial)
        Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.
        参数：
        initial - the java.io.Serializable with which to initialize the value field of the newly-created ValueBaseHolder object

    • 方法详细信息

      • _read

        public void _read(InputStream input)
        Reads from input and initalizes the value in the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        input - the InputStream containing CDR formatted data from the wire

      • _write

        public void _write(OutputStream output)
        Marshals to output the value in the Holder.
        指定者：
        _write in interface Streamable
        参数：
        output - the OutputStream which will contain the CDR formatted data

      • _type

        public TypeCode _type()
        Returns the TypeCode object corresponding to the value held in the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode of the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g>asps sesa=l.gCl r"taabMrrm"tnip=i enuM


ValueMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 ValueMember

  • java.lang.Object
    • org.omg.CORBA.ValueMember
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ValueMember
extends Object
implements IDLEntity
    A description in the Interface Repository of a member of a value object.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      short access
      The type of access (public, private) for the value member described by this ValueMember object.
      String defined_in
      The repository ID of the value in which this member is defined.
      String id
      The repository ID of the value member described by this ValueMember object;
      String name
      The name of the value member described by this ValueMember object.
      TypeCode type
      The type of of this value member.
      IDLType type_def
      The typedef that represents the IDL type of the value member described by this ValueMember object.
      String version
      The version of the value in which this member is defined.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValueMember()
      Constructs a default ValueMember object.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • name

        public String name
        The name of the value member described by this ValueMember object.

      • id

        public String id
        The repository ID of the value member described by this ValueMember object;

      • defined_in

        public String defined_in
        The repository ID of the value in which this member is defined.

      • version

        public String version
        The version of the value in which this member is defined.

      • type

        public TypeCode type
        The type of of this value member.

      • type_def

        public IDLType type_def
        The typedef that represents the IDL type of the value member described by this ValueMember object.

      • access

        public short access
        The type of access (public, private) for the value member described by this ValueMember object.

    • 构造方法详细信息

      • ValueMember

        public ValueMember()
        Constructs a default ValueMember object.

      • ValueMember

        public ValueMember(String __name,
           String __id,
           String __defined_in,
           String __version,
           TypeCode __type,
           IDLType __type_def,
           short __access)
        Constructs a ValueMember object initialized with the given values.
        参数：
        __name - The name of the value member described by this ValueMember object.
        __id - The repository ID of the value member described by this ValueMember object;
        __defined_in - The repository ID of the value in which this member is defined.
        __version - The version of the value in which this member is defined.
        __type - The type of of this value member.
        __type_def - The typedef that represents the IDL type of the value member described by this ValueMember object.
        __access - The type of access (public, private) for the value member described by this ValueMember object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lsanal PnTbbo&brgRi/a >olll>a鷑


ValueMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 ValueMemberHelper

  • java.lang.Object
    • org.omg.CORBA.ValueMemberHelper

  • public abstract class ValueMemberHelper
extends Object
    The Helper for ValueMember. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/ValueMemberHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      ValueMemberHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ValueMember | extract(Any a)
      static String | id()
      static void | insert(Any a, ValueMember that)
      static ValueMember | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ValueMember value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ValueMemberHelper

        public ValueMemberHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ValueMember that)

      • extract

        public static ValueMember extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ValueMember read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ValueMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ceo


VersionSpecHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 VersionSpecHelper

  • java.lang.Object
    • org.omg.CORBA.VersionSpecHelper

  • public abstract class VersionSpecHelper
extends Object
    The Helper for VersionSpec. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/VersionSpecHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:43 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      VersionSpecHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VersionSpecHelper

        public VersionSpecHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rn.a.a/ayag/pyrt>�. "l藋权ㄓ/0a0<< x�


VisibilityHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 VisibilityHelper

  • java.lang.Object
    • org.omg.CORBA.VisibilityHelper

  • public abstract class VisibilityHelper
extends Object
    The Helper for Visibility. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/VisibilityHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from ir.idl 03 June 1999 11:33:44 o'clock GMT+00:00

    • 构造方法摘要

      Constructors
      构造方法与描述
      VisibilityHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • VisibilityHelper

        public VisibilityHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a<===R=>== -> -=TTm/i>skk-vtbtaa>oN


VM_ABSTRACT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_ABSTRACT

  • public interface VM_ABSTRACT
    Defines the code used to represent an Abstract interface in a typecode. This is one of the possible results of the type_modified method on the TypeCode interface.
    另请参见：
    TypeCode

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The value representing an abstract interface value type in a typecode.

    • 字段详细信息

      • value

        static final short value
        The value representing an abstract interface value type in a typecode.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.f. e/h


VM_CUSTOM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_CUSTOM

  • public interface VM_CUSTOM
    Defines the code used to represent a custom marshalled value type in a typecode. This is one of the possible results of the type_modifier method on the TypeCode interface.
    另请参见：
    TypeCode

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The value representing a custom marshalled value type in a typecode.

    • 字段详细信息

      • value

        static final short value
        The value representing a custom marshalled value type in a typecode.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/iy>l>a>o>p/ody>tmo>/f.h hf


VM_NONE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_NONE

  • public interface VM_NONE
    Defines the code used to represent the one of the values of a value type in a typecode.
    从以下版本开始：
    JDK1.2
    另请参见：
    TypeCode

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The value representing the value type in a typecode as per CORBA 2.3 spec.

    • 字段详细信息

      • value

        static final short value
        The value representing the value type in a typecode as per CORBA 2.3 spec.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rl/s>�


VM_TRUNCATABLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA

Interface VM_TRUNCATABLE

  • public interface VM_TRUNCATABLE
    Defines the code used to represent a truncatable value type in a typecode. A value type is truncatable if it inherits "safely" from another value type, which means it can be cast to a more general inherited type. This is one of the possible results of the type_modifier method on the TypeCode interface.
    另请参见：
    TypeCode

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The value representing a truncatable value type in a typecode.

    • 字段详细信息

      • value

        static final short value
        The value representing a truncatable value type in a typecode.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

maojag"n<< er>.


WCharSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WCharSeqHelper

  • java.lang.Object
    • org.omg.CORBA.WCharSeqHelper

  • public abstract class WCharSeqHelper
extends Object
    The Helper for WCharSeq. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/WCharSeqHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :

    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      WCharSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static char[] | extract(Any a)
      static String | id()
      static void | insert(Any a, char[] that)
      static char[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, char[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WCharSeqHelper

        public WCharSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          char[] that)

      • extract

        public static char[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static char[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         char[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>s rrc iohtit� x黺昝湘舷�.�


WCharSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WCharSeqHolder

  • java.lang.Object
    • org.omg.CORBA.WCharSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class WCharSeqHolder
extends Object
implements Streamable
    The Holder for WCharSeq. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/WCharSeqHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from streams.idl 13 May 1999 22:41:36 o'clock GMT+00:00

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      char[] | value

    • 构造方法摘要

      Constructors
      构造方法与描述
      WCharSeqHolder()
      WCharSeqHolder(char[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public char[] value

    • 构造方法详细信息

      • WCharSeqHolder

        public WCharSeqHolder()

      • WCharSeqHolder

        public WCharSeqHolder(char[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fsbEbebOnisGlr;o- e栏tal<磂


WrongTransaction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA

类 WrongTransaction

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.WrongTransaction
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class WrongTransaction
extends UserException
    The CORBA WrongTransaction user-defined exception. This exception is thrown only by the methods Request.get_response and ORB.get_next_response when they are invoked from a transaction scope that is different from the one in which the client originally sent the request. See the OMG Transaction Service Specification for details.
    另请参见：
    documentation on Java IDL exceptions

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongTransaction()
      Constructs a WrongTransaction object with an empty detail message.
      WrongTransaction(String reason)
      Constructs a WrongTransaction object with the given detail message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WrongTransaction

        public WrongTransaction()
        Constructs a WrongTransaction object with an empty detail message.

      • WrongTransaction

        public WrongTransaction(String reason)
        Constructs a WrongTransaction object with the given detail message.
        参数：
        reason - The detail message explaining what caused this exception to be thrown.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rco/e/m_aa otrett:n//.grt/t


WrongTransactionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WrongTransactionHelper

  • java.lang.Object
    • org.omg.CORBA.WrongTransactionHelper

  • public abstract class WrongTransactionHelper
extends Object
    The Helper for WrongTransaction. For more information on Helper files, see "Generated Files: Helper Files".

    org/omg/CORBA/WrongTransactionHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongTransactionHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static WrongTransaction | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongTransaction that)
      static WrongTransaction | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongTransaction value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WrongTransactionHelper

        public WrongTransactionHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          WrongTransaction that)

      • extract

        public static WrongTransaction extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongTransaction read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         WrongTransaction value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<"d lllslb n/_a.l.a//<觘


WrongTransactionHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WrongTransactionHolder

  • java.lang.Object
    • org.omg.CORBA.WrongTransactionHolder
  • 所有已实现的接口：
    Streamable

    public final class WrongTransactionHolder
extends Object
implements Streamable
    The Holder for WrongTransaction. For more information on Holder files, see "Generated Files: Holder Files".

    org/omg/CORBA/WrongTransactionHolder.java Generated by the IDL-to-Java compiler (portable), version "3.0" from CORBA.idl Thursday, August 24, 2000 5:32:50 PM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      WrongTransaction value

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongTransactionHolder()
      WrongTransactionHolder(WrongTransaction initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public WrongTransaction value

    • 构造方法详细信息

      • WrongTransactionHolder

        public WrongTransactionHolder()

      • WrongTransactionHolder

        public WrongTransactionHolder(WrongTransaction initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

le>brm"lrea/dvga mium>


WStringSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WStringSeqHelper

  • java.lang.Object
    • org.omg.CORBA.WStringSeqHelper

  • public abstract class WStringSeqHelper
extends Object
    An array of WStrings

    • 构造方法摘要

      Constructors
      构造方法与描述
      WStringSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WStringSeqHelper

        public WStringSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!>-babevbem==emm


WStringSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WStringSeqHolder

  • java.lang.Object
    • org.omg.CORBA.WStringSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class WStringSeqHolder
extends Object
implements Streamable
    An array of WStrings

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      WStringSeqHolder()
      WStringSeqHolder(String[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public String[] value

    • 构造方法详细信息

      • WStringSeqHolder

        public WStringSeqHolder()

      • WStringSeqHolder

        public WStringSeqHolder(String[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lP>>C>�>l>"sallfaoll--i>s-->=


WStringValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA

类 WStringValueHelper

  • java.lang.Object
    • org.omg.CORBA.WStringValueHelper
  • 所有已实现的接口：
    BoxedValueHelper

    public class WStringValueHelper
extends Object
implements BoxedValueHelper
    org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications :
    • ORB core as defined by CORBA 2.3.1 (formal/99-10-07)
    • IDL/Java Language Mapping as defined in ptc/00-01-08

    • 构造方法摘要

      Constructors
      构造方法与描述
      WStringValueHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      String get_id()
      static String | id()
      static void | insert(Any a, String that)
      Serializable | read_value(InputStream istream)
      static String | read(InputStream istream)
      static TypeCode | type()
      void | write_value(OutputStream ostream, Serializable value)
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WStringValueHelper

        public WStringValueHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • read_value

        public Serializable read_value(InputStream istream)
        指定者：
        read_value in interface BoxedValueHelper

      • write

        public static void write(OutputStream ostream,
         String value)

      • write_value

        public void write_value(OutputStream ostream,
               Serializable value)
        指定者：
        write_value in interface BoxedValueHelper

      • get_id

        public String get_id()
        指定者：
        get_id in interface BoxedValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"#>leltlonpa譨


Uses of Class org.omg.CORBA._IDLTypeStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA._IDLTypeStub

No usage of org.omg.CORBA._IDLTypeStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>esRo>T>g莞be3& a癰b<


Uses of Class org.omg.CORBA._PolicyStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA._PolicyStub

No usage of org.omg.CORBA._PolicyStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>>t>R>leRT�4osbs3Ta


Uses of Class org.omg.CORBA.ACTIVITY_COMPLETED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ACTIVITY_COMPLETED

No usage of org.omg.CORBA.ACTIVITY_COMPLETED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/


Uses of Class org.omg.CORBA.ACTIVITY_REQUIRED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ACTIVITY_REQUIRED

No usage of org.omg.CORBA.ACTIVITY_REQUIRED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>l�/t>/>l


Uses of Class org.omg.CORBA.Any

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Any

  • Packages that use Any
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of Any in org.omg.CORBA

      Fields in org.omg.CORBA declared as Any
      修饰符与类型 | 字段与描述
      Any UnknownUserException.except
      The Any instance that contains the actual user exception thrown by the server.
      Any UnionMember.label
      The label of the union member described by this UnionMember object.
      Any[] | AnySeqHolder.value
      Any AnyHolder.value
      The Any value held by this AnyHolder object.
      Any NameValuePair.value
      The value to be associated with a name by this NameValuePair object.
      Methods in org.omg.CORBA that return Any
      修饰符与类型 | 方法与描述
      abstract Any Request.add_in_arg()
      Creates an input argument and adds it to this Request object.
      abstract Any Request.add_inout_arg()
      Adds an input/output argument to this Request object.
      abstract Any Request.add_named_in_arg(String name)
      Creates an input argument with the given name and adds it to this Request object.
      abstract Any Request.add_named_inout_arg(String name)
      Adds an input/output argument with the given name to this Request object.
      abstract Any Request.add_named_out_arg(String name)
      Adds an output argument with the given name to this Request object.
      abstract Any Request.add_out_arg()
      Adds an output argument to this Request object.
      abstract Any ORB.create_any()
      Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
      abstract Any Any.extract_any()
      Extracts the Any object in this Any object's value field.
      static Any[] | AnySeqHelper.extract(Any a)
      Any DynAny.get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      Any[] DynArray.get_elements()
      Deprecated.
      Returns the value of all the elements of this array.
      Any[] DynSequence.get_elements()
      Deprecated.
      Returns the value of every element in this sequence.
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      Any DataInputStream.read_any()
      Reads an IDL Any value from the input stream.
      static Any[] | AnySeqHelper.read(InputStream istream)
      abstract Any Request.return_value()
      Returns the Any object that contains the value for the result of the method.
      Any DynAny.to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
      abstract Any NamedValue.value()
      Retrieves the value for this NamedValue object.
      Methods in org.omg.CORBA with parameters of type Any
      修饰符与类型 | 方法与描述
      abstract NamedValue NVList.add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      DynAny ORB.create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract NamedValue ORB.create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      abstract boolean Any.equal(Any a)
      Checks for equality between this Any object and the given Any object.
      void ServerRequest.except(Any any)
      Deprecated.
      use set_exception()
      static String[] | WStringSeqHelper.extract(Any a)
      static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
      static String[] | StringSeqHelper.extract(Any a)
      static PolicyError | PolicyErrorHelper.extract(Any a)
      static short | PolicyErrorCodeHelper.extract(Any a)
      static ParameterMode | ParameterModeHelper.extract(Any a)
      static String | WStringValueHelper.extract(Any a)
      static char[] | WCharSeqHelper.extract(Any a)
      static short | VisibilityHelper.extract(Any a)
      static String | VersionSpecHelper.extract(Any a)
      static ValueMember | ValueMemberHelper.extract(Any a)
      static Serializable | ValueBaseHelper.extract(Any a)
      static UnionMember | UnionMemberHelper.extract(Any a)
      static short[] | UShortSeqHelper.extract(Any a)
      static int[] | ULongSeqHelper.extract(Any a)
      static long[] | ULongLongSeqHelper.extract(Any a)
      static StructMember | StructMemberHelper.extract(Any a)
      static String | StringValueHelper.extract(Any a)
      static short[] | ShortSeqHelper.extract(Any a)
      static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
      static String | RepositoryIdHelper.extract(Any a)
      static Policy[] | PolicyListHelper.extract(Any a)
      static int | PolicyTypeHelper.extract(Any a)
      static Policy | PolicyHelper.extract(Any a)
      static byte[] | OctetSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      static int[] | LongSeqHelper.extract(Any a)
      static long[] | LongLongSeqHelper.extract(Any a)
      static String | IdentifierHelper.extract(Any a)
      static IDLType | IDLTypeHelper.extract(Any a)
      static float[] | FloatSeqHelper.extract(Any a)
      static String | FieldNameHelper.extract(Any a)
      static double[] | DoubleSeqHelper.extract(Any a)
      static DefinitionKind | DefinitionKindHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static CompletionStatus | CompletionStatusHelper.extract(Any a)
      static char[] | CharSeqHelper.extract(Any a)
      static boolean[] | BooleanSeqHelper.extract(Any a)
      static Any[] | AnySeqHelper.extract(Any a)
      static ServiceDetail | ServiceDetailHelper.extract(Any a)
      static Object | ObjectHelper.extract(Any a)
      static ServiceInformation | ServiceInformationHelper.extract(Any a)
      static WrongTransaction | WrongTransactionHelper.extract(Any a)
      void DynAny.from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      void DynAny.insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      abstract void Any.insert_any(Any a)
      Inserts the given Any object into this Any object's value field.
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | BooleanSeqHelper.insert(Any a, boolean[] that)
      static void | OctetSeqHelper.insert(Any a, byte[] that)
      static void | WCharSeqHelper.insert(Any a, char[] that)
      static void | CharSeqHelper.insert(Any a, char[] that)
      static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
      static void | DoubleSeqHelper.insert(Any a, double[] that)
      static void | FloatSeqHelper.insert(Any a, float[] that)
      static void | IDLTypeHelper.insert(Any a, IDLType that)
      static void | PolicyTypeHelper.insert(Any a, int that)
      static void | ULongSeqHelper.insert(Any a, int[] that)
      static void | LongSeqHelper.insert(Any a, int[] that)
      static void | ULongLongSeqHelper.insert(Any a, long[] that)
      static void | LongLongSeqHelper.insert(Any a, long[] that)
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | ObjectHelper.insert(Any a, Object that)
      static void | ParameterModeHelper.insert(Any a, ParameterMode that)
      static void | PolicyHelper.insert(Any a, Policy that)
      static void | PolicyListHelper.insert(Any a, Policy[] that)
      static void | PolicyErrorHelper.insert(Any a, PolicyError that)
      static void | ValueBaseHelper.insert(Any a, Serializable that)
      static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
      static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
      static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
      static void | PolicyErrorCodeHelper.insert(Any a, short that)
      static void | VisibilityHelper.insert(Any a, short that)
      static void | UShortSeqHelper.insert(Any a, short[] that)
      static void | ShortSeqHelper.insert(Any a, short[] that)
      static void | WStringValueHelper.insert(Any a, String that)
      static void | VersionSpecHelper.insert(Any a, String that)
      static void | StringValueHelper.insert(Any a, String that)
      static void | RepositoryIdHelper.insert(Any a, String that)
      static void | IdentifierHelper.insert(Any a, String that)
      static void | FieldNameHelper.insert(Any a, String that)
      static void | WStringSeqHelper.insert(Any a, String[] that)
      static void | StringSeqHelper.insert(Any a, String[] that)
      static void | StructMemberHelper.insert(Any a, StructMember that)
      static void | UnionMemberHelper.insert(Any a, UnionMember that)
      static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
      static void | ValueMemberHelper.insert(Any a, ValueMember that)
      static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
      void ServerRequest.result(Any any)
      Deprecated.
      use the method set_result
      void DynArray.set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.
      void DynSequence.set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.
      void ServerRequest.set_exception(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void Context.set_one_value(String propname, Any propvalue)
      Creates a NamedValue object and adds it to this Context object.
      void ServerRequest.set_result(Any any)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      void DataOutputStream.write_any_array(Any[] seq, int offset, int length)
      Writes the array of IDL Anys from offset for length elements to the output stream.
      void DataOutputStream.write_any(Any value)
      Writes the Any value to the output stream.
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      Constructors in org.omg.CORBA with parameters of type Any
      构造方法与描述
      AnyHolder(Any initial)
      Constructs a new AnyHolder object for the given Any object.
      AnySeqHolder(Any[] initialValue)
      NameValuePair(String __id, Any __value)
      Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      UnknownUserException(Any a)
      Constructs an UnknownUserException object that contains the given Any object.

    • Uses of Any in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Any
      修饰符与类型 方法与描述
      abstract Any InputStream.read_any()
      Reads an Any from this input stream.
      Methods in org.omg.CORBA.portable with parameters of type Any
      修饰符与类型 方法与描述
      abstract void OutputStream.write_any(Any value)
      Writes an Any on this output stream.

    • Uses of Any in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type Any
      修饰符与类型 | 方法与描述
      static NamingContextExt | NamingContextExtHelper.extract(Any a)
      static NamingContext | NamingContextHelper.extract(Any a)
      static NameComponent[] | NameHelper.extract(Any a)
      static NameComponent | NameComponentHelper.extract(Any a)
      static BindingType | BindingTypeHelper.extract(Any a)
      static Binding[] | BindingListHelper.extract(Any a)
      static BindingIterator | BindingIteratorHelper.extract(Any a)
      static Binding | BindingHelper.extract(Any a)
      static String | IstringHelper.extract(Any a)
      static void | BindingHelper.insert(Any a, Binding that)
      static void | BindingListHelper.insert(Any a, Binding[] that)
      static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
      static void | BindingTypeHelper.insert(Any a, BindingType that)
      static void | NameComponentHelper.insert(Any a, NameComponent that)
      static void | NameHelper.insert(Any a, NameComponent[] that)
      static void | NamingContextHelper.insert(Any a, NamingContext that)
      static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
      static void | IstringHelper.insert(Any a, String that)

    • Uses of Any in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static String | URLStringHelper.extract(Any a)
      static String | StringNameHelper.extract(Any a)
      static InvalidAddress | InvalidAddressHelper.extract(Any a)
      static String | AddressHelper.extract(Any a)
      static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
      static void | URLStringHelper.insert(Any a, String that)
      static void | StringNameHelper.insert(Any a, String that)
      static void | AddressHelper.insert(Any a, String that)

    • Uses of Any in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static NotFoundReason | NotFoundReasonHelper.extract(Any a)
      static NotFound | NotFoundHelper.extract(Any a)
      static NotEmpty | NotEmptyHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.extract(Any a)
      static CannotProceed | CannotProceedHelper.extract(Any a)
      static AlreadyBound | AlreadyBoundHelper.extract(Any a)
      static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
      static void | CannotProceedHelper.insert(Any a, CannotProceed that)
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | NotEmptyHelper.insert(Any a, NotEmpty that)
      static void | NotFoundHelper.insert(Any a, NotFound that)
      static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)

    • Uses of Any in org.omg.Dynamic

      Fields in org.omg.Dynamic declared as Any
      修饰符与类型 | 字段与描述
      Any | Parameter.argument
      Constructors in org.omg.Dynamic with parameters of type Any
      构造方法与描述
      Parameter(Any _argument, ParameterMode _mode)

    • Uses of Any in org.omg.DynamicAny

      Fields in org.omg.DynamicAny declared as Any
      修饰符与类型 字段与描述
      Any NameValuePair.value
      The Any value associated with the name.
      Methods in org.omg.DynamicAny that return Any
      修饰符与类型 | 方法与描述
      static Any[] | AnySeqHelper.extract(Any a)
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynValueBoxOperations.get_boxed_value()
      Returns the boxed value as an Any.
      Any[] _DynSequenceStub.get_elements()
      Returns the elements of the sequence.
      Any[] _DynArrayStub.get_elements()
      Returns the elements of the DynArray.
      Any[] DynSequenceOperations.get_elements()
      Returns the elements of the sequence.
      Any[] DynArrayOperations.get_elements()
      Returns the elements of the DynArray.
      static Any[] | AnySeqHelper.read(InputStream istream)
      Any _DynValueStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynUnionStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynStructStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynSequenceStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynFixedStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynEnumStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynArrayStub.to_any()
      Creates an any value from a DynAny object.
      Any _DynAnyStub.to_any()
      Creates an any value from a DynAny object.
      Any DynAnyOperations.to_any()
      Creates an any value from a DynAny object.
      Methods in org.omg.DynamicAny with parameters of type Any
      修饰符与类型 | 方法与描述
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
      static DynSequence | DynSequenceHelper.extract(Any a)
      static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
      static String | FieldNameHelper.extract(Any a)
      static DynFixed | DynFixedHelper.extract(Any a)
      static DynEnum | DynEnumHelper.extract(Any a)
      static DynAny[] | DynAnySeqHelper.extract(Any a)
      static DynArray | DynArrayHelper.extract(Any a)
      static DynValue | DynValueHelper.extract(Any a)
      static DynAny | DynAnyHelper.extract(Any a)
      static DynUnion | DynUnionHelper.extract(Any a)
      static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
      static DynStruct | DynStructHelper.extract(Any a)
      static Any[] | AnySeqHelper.extract(Any a)
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | AnySeqHelper.insert(Any a, Any[] that)
      static void | DynAnyHelper.insert(Any a, DynAny that)
      static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
      static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
      static void | DynArrayHelper.insert(Any a, DynArray that)
      static void | DynEnumHelper.insert(Any a, DynEnum that)
      static void | DynFixedHelper.insert(Any a, DynFixed that)
      static void | DynSequenceHelper.insert(Any a, DynSequence that)
      static void | DynStructHelper.insert(Any a, DynStruct that)
      static void | DynUnionHelper.insert(Any a, DynUnion that)
      static void | DynValueHelper.insert(Any a, DynValue that)
      static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
      static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
      static void | FieldNameHelper.insert(Any a, String that)
      void DynValueBoxOperations.set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      Constructors in org.omg.DynamicAny with parameters of type Any
      构造方法与描述
      NameValuePair(String _id, Any _value)

    • Uses of Any in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
      static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)

    • Uses of Any in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static InvalidValue | InvalidValueHelper.extract(Any a)
      static void | InvalidValueHelper.insert(Any a, InvalidValue that)
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

    • Uses of Any in org.omg.IOP

      Methods in org.omg.IOP that return Any
      修饰符与类型 方法与描述
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any CodecOperations.decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.
      Methods in org.omg.IOP with parameters of type Any
      修饰符与类型 | 方法与描述
      byte[] CodecOperations.encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] CodecOperations.encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      static TaggedProfile | TaggedProfileHelper.extract(Any a)
      static TaggedComponent | TaggedComponentHelper.extract(Any a)
      static int | ServiceIdHelper.extract(Any a)
      static ServiceContext[] | ServiceContextListHelper.extract(Any a)
      static ServiceContext | ServiceContextHelper.extract(Any a)
      static int | ProfileIdHelper.extract(Any a)
      static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
      static IOR | IORHelper.extract(Any a)
      static int | ComponentIdHelper.extract(Any a)
      static CodecFactory | CodecFactoryHelper.extract(Any a)
      static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
      static void | ServiceIdHelper.insert(Any a, int that)
      static void | ProfileIdHelper.insert(Any a, int that)
      static void | ComponentIdHelper.insert(Any a, int that)
      static void | IORHelper.insert(Any a, IOR that)
      static void | ServiceContextHelper.insert(Any a, ServiceContext that)
      static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
      static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
      static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
      static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)

    • Uses of Any in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
      static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)

    • Uses of Any in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
      static FormatMismatch | FormatMismatchHelper.extract(Any a)
      static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
      static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

    • Uses of Any in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type Any
      修饰符与类型 | 方法与描述
      static short | SyncScopeHelper.extract(Any a)
      static void | SyncScopeHelper.insert(Any a, short that)

    • Uses of Any in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Any
      修饰符与类型 方法与描述
      Any CurrentOperations.get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      Any RequestInfoOperations.get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      Any ClientRequestInfoOperations.received_exception()
      Returns an any which contains the exception to be returned to the client.
      Any RequestInfoOperations.result()
      Returns an any containing the result of the operation invocation.
      Any ServerRequestInfoOperations.sending_exception()
      Returns an any which contains the exception to be returned to the client.
      Methods in org.omg.PortableInterceptor with parameters of type Any
      修饰符与类型 | 方法与描述
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
      static String | ServerIdHelper.extract(Any a)
      static String | ORBIdHelper.extract(Any a)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
      static byte[] | ObjectIdHelper.extract(Any a)
      static InvalidSlot | InvalidSlotHelper.extract(Any a)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static short | AdapterStateHelper.extract(Any a)
      static String[] | AdapterNameHelper.extract(Any a)
      static int | AdapterManagerIdHelper.extract(Any a)
      static void | ObjectIdHelper.insert(Any a, byte[] that)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | AdapterManagerIdHelper.insert(Any a, int that)
      static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
      static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
      static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
      static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
      static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
      static void | AdapterStateHelper.insert(Any a, short that)
      static void | ServerIdHelper.insert(Any a, String that)
      static void | ORBIdHelper.insert(Any a, String that)
      static void | AdapterNameHelper.insert(Any a, String[] that)
      void ServerRequestInfoOperations.set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      void CurrentOperations.set_slot(int id, Any data)
      Sets data in a slot.

    • Uses of Any in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static String | ObjectIdHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.extract(Any a)
      static DuplicateName | DuplicateNameHelper.extract(Any a)
      static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | ObjectIdHelper.insert(Any a, String that)

    • Uses of Any in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type Any
      修饰符与类型 | 方法与描述
      static ServantLocator | ServantLocatorHelper.extract(Any a)
      static ServantActivator | ServantActivatorHelper.extract(Any a)
      static POA | POAHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static Current | CurrentHelper.extract(Any a)
      static void | CurrentHelper.insert(Any a, Current that)
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | POAHelper.insert(Any a, POA that)
      static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
      static void | ServantLocatorHelper.insert(Any a, ServantLocator that)

    • Uses of Any in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static NoContext | NoContextHelper.extract(Any a)
      static void | NoContextHelper.insert(Any a, NoContext that)

    • Uses of Any in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static AdapterInactive | AdapterInactiveHelper.extract(Any a)
      static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)

    • Uses of Any in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type Any
      修饰符与类型 | 方法与描述
      static WrongPolicy | WrongPolicyHelper.extract(Any a)
      static WrongAdapter | WrongAdapterHelper.extract(Any a)
      static ServantNotActive | ServantNotActiveHelper.extract(Any a)
      static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
      static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
      static NoServant | NoServantHelper.extract(Any a)
      static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
      static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
      static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
      static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
      static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
      static void | NoServantHelper.insert(Any a, NoServant that)
      static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
      static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
      static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
      static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
      static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
      static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.AnyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.AnyHolder

No usage of org.omg.CORBA.AnyHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ ti.Dy.gooo>a##.o/dF


Uses of Class org.omg.CORBA.AnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.AnySeqHelper

No usage of org.omg.CORBA.AnySeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r" .arnt/�"


Uses of Class org.omg.CORBA.AnySeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.AnySeqHolder

  • Packages that use AnySeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of AnySeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type AnySeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_any_array(AnySeqHolder seq, int offset, int length)
      Reads array of IDL Anys from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

L etm.=/


Uses of Class org.omg.CORBA.BAD_CONTEXT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_CONTEXT

No usage of org.omg.CORBA.BAD_CONTEXT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. � n9 s.�,碞r.�.t


Uses of Class org.omg.CORBA.BAD_INV_ORDER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_INV_ORDER

  • Packages that use BAD_INV_ORDER
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BAD_INV_ORDER in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_INV_ORDER
      修饰符与类型 方法与描述
      Streamable Any.extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      void Any.insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Agtsgaryara>ir irw o縜躶t


Uses of Class org.omg.CORBA.BAD_OPERATION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_OPERATION

  • Packages that use BAD_OPERATION
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BAD_OPERATION in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_OPERATION
      修饰符与类型 方法与描述
      abstract Any Any.extract_any()
      Extracts the Any object in this Any object's value field.
      abstract boolean Any.extract_boolean()
      Extracts the boolean in this Any object's value field.
      abstract char Any.extract_char()
      Extracts the char in this Any object's value field.
      abstract double Any.extract_double()
      Extracts the double in this Any object's value field.
      abstract float Any.extract_float()
      Extracts the float in this Any object's value field.
      abstract int Any.extract_long()
      Extracts the int in this Any object's value field.
      abstract long Any.extract_longlong()
      Extracts the long in this Any object's value field.
      abstract Object Any.extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      abstract byte Any.extract_octet()
      Extracts the byte in this Any object's value field.
      Principal Any.extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract short Any.extract_short()
      Extracts the short in this Any object's value field.
      abstract String Any.extract_string()
      Extracts the String object in this Any object's value field.
      abstract TypeCode Any.extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract int Any.extract_ulong()
      Extracts the int in this Any object's value field.
      abstract long Any.extract_ulonglong()
      Extracts the long in this Any object's value field.
      abstract short Any.extract_ushort()
      Extracts the short in this Any object's value field.
      abstract Serializable Any.extract_Value()
      Extracts the java.io.Serializable object in this Any object's value field.
      abstract char Any.extract_wchar()
      Extracts the char in this Any object's value field.
      abstract String Any.extract_wstring()
      Extracts the String object in this Any object's value field.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a�(sisnurMai>� _>糿//


Uses of Class org.omg.CORBA.BAD_PARAM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_PARAM

  • Packages that use BAD_PARAM
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

    • Uses of BAD_PARAM in org.omg.CORBA

      Methods in org.omg.CORBA that throw BAD_PARAM
      修饰符与类型 方法与描述
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.

    • Uses of BAD_PARAM in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that throw BAD_PARAM
      修饰符与类型 | 方法与描述
      Object | ORB.get_value_def(String repid)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tlrdv> <.///ecccttsdao"c


Uses of Class org.omg.CORBA.BAD_QOS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_QOS

No usage of org.omg.CORBA.BAD_QOS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ed 21a11 rl懊an芆羖�


Uses of Class org.omg.CORBA.BAD_TYPECODE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BAD_TYPECODE

No usage of org.omg.CORBA.BAD_TYPECODE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bn>orA-�>�& b癮x.&.


Uses of Class org.omg.CORBA.BooleanHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BooleanHolder

No usage of org.omg.CORBA.BooleanHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!$� | �>猳thxGa


Uses of Class org.omg.CORBA.BooleanSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BooleanSeqHelper

No usage of org.omg.CORBA.BooleanSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lho0(>p/d>/L� na-J/s


Uses of Class org.omg.CORBA.BooleanSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.BooleanSeqHolder

  • Packages that use BooleanSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BooleanSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type BooleanSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_boolean_array(BooleanSeqHolder seq, int offset, int length)
      Reads array of IDL booleans from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oh/e)l�;r"p"t.tiea.a�>-


Uses of Class org.omg.CORBA.Bounds

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Bounds

  • Packages that use Bounds
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Bounds in org.omg.CORBA

      Methods in org.omg.CORBA that throw Bounds
      修饰符与类型 方法与描述
      abstract String ContextList.item(int index)
      Returns the String object at the given index.
      abstract TypeCode ExceptionList.item(int index)
      Returns the TypeCode object at the given index.
      abstract NamedValue NVList.item(int index)
      Retrieves the NamedValue object at the given index.
      abstract void ContextList.remove(int index)
      Removes the String object at the given index.
      abstract void ExceptionList.remove(int index)
      Removes the TypeCode object at the given index.
      abstract void NVList.remove(int index)
      Removes the NamedValue object at the given index.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>19


Uses of Class org.omg.CORBA.ByteHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ByteHolder

No usage of org.omg.CORBA.ByteHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


Uses of Class org.omg.CORBA.CharHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CharHolder

No usage of org.omg.CORBA.CharHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.鈚5


Uses of Class org.omg.CORBA.CharSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CharSeqHelper

No usage of org.omg.CORBA.CharSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts- >


Uses of Class org.omg.CORBA.CharSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CharSeqHolder

  • Packages that use CharSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of CharSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type CharSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_char_array(CharSeqHolder seq, int offset, int length)
      Reads array of IDL characters from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"-b"af/be.te0


Uses of Class org.omg.CORBA.CODESET_INCOMPATIBLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CODESET_INCOMPATIBLE

No usage of org.omg.CORBA.CODESET_INCOMPATIBLE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-"nra><>- "aaT R v


Uses of Class org.omg.CORBA.COMM_FAILURE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.COMM_FAILURE

No usage of org.omg.CORBA.COMM_FAILURE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"tＨ�/�o>


Uses of Class org.omg.CORBA.CompletionStatus

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CompletionStatus

  • Packages that use CompletionStatus
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of CompletionStatus in org.omg.CORBA

      Fields in org.omg.CORBA declared as CompletionStatus
      修饰符与类型 字段与描述
      CompletionStatus SystemException.completed
      The status of the operation that threw this exception.
      static CompletionStatus CompletionStatus.COMPLETED_MAYBE
      An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
      static CompletionStatus CompletionStatus.COMPLETED_NO
      An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
      static CompletionStatus CompletionStatus.COMPLETED_YES
      An instance of CompletionStatus initialized with the constant _COMPLETED_YES.
      Methods in org.omg.CORBA that return CompletionStatus
      修饰符与类型 | 方法与描述
      static CompletionStatus | CompletionStatusHelper.extract(Any a)
      static CompletionStatus CompletionStatus.from_int(int i)
      Creates a CompletionStatus object from the given int.
      static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type CompletionStatus
      修饰符与类型 | 方法与描述
      static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
      static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
      Constructors in org.omg.CORBA with parameters of type CompletionStatus
      构造方法与描述
      ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
      ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
      ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
      ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
      BAD_CONTEXT(int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
      BAD_CONTEXT(String s, int minor, CompletionStatus completed)
      Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.
      BAD_INV_ORDER(int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
      BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
      Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.
      BAD_OPERATION(int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified minor code and completion status.
      BAD_OPERATION(String s, int minor, CompletionStatus completed)
      Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.
      BAD_PARAM(int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified minor code and completion status.
      BAD_PARAM(String s, int minor, CompletionStatus completed)
      Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.
      BAD_QOS(int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified minor code and completion status.
      BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
      BAD_TYPECODE(int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
      BAD_TYPECODE(String s, int minor, CompletionStatus completed)
      Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.
      CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
      CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
      COMM_FAILURE(int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified minor code and completion status.
      COMM_FAILURE(String s, int minor, CompletionStatus completed)
      Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.
      DATA_CONVERSION(int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
      DATA_CONVERSION(String s, int minor, CompletionStatus completed)
      Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.
      FREE_MEM(int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified minor code and completion status.
      FREE_MEM(String s, int minor, CompletionStatus completed)
      Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.
      IMP_LIMIT(int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified minor code and completion status.
      IMP_LIMIT(String s, int minor, CompletionStatus completed)
      Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.
      INITIALIZE(int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified minor code and completion status.
      INITIALIZE(String s, int minor, CompletionStatus completed)
      Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.
      INTERNAL(int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified minor code and completion status.
      INTERNAL(String s, int minor, CompletionStatus completed)
      Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.
      INTF_REPOS(int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified minor code and completion status.
      INTF_REPOS(String s, int minor, CompletionStatus completed)
      Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.
      INV_FLAG(int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified minor code and completion status.
      INV_FLAG(String s, int minor, CompletionStatus completed)
      Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.
      INV_IDENT(int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified minor code and completion status.
      INV_IDENT(String s, int minor, CompletionStatus completed)
      Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.
      INV_OBJREF(int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified minor code and completion status.
      INV_OBJREF(String s, int minor, CompletionStatus completed)
      Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.
      INV_POLICY(int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified minor code and completion status.
      INV_POLICY(String s, int minor, CompletionStatus completed)
      Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
      INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
      INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
      INVALID_TRANSACTION(int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
      INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
      Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.
      MARSHAL(int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified minor code and completion status.
      MARSHAL(String s, int minor, CompletionStatus completed)
      Constructs a MARSHAL exception with the specified description message, minor code, and completion status.
      NO_IMPLEMENT(int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
      NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
      Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.
      NO_MEMORY(int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified minor code and completion status.
      NO_MEMORY(String s, int minor, CompletionStatus completed)
      Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.
      NO_PERMISSION(int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified minor code and completion status.
      NO_PERMISSION(String s, int minor, CompletionStatus completed)
      Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.
      NO_RESOURCES(int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified minor code and completion status.
      NO_RESOURCES(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.
      NO_RESPONSE(int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified minor code and completion status.
      NO_RESPONSE(String s, int minor, CompletionStatus completed)
      Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.
      OBJ_ADAPTER(int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
      OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
      Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.
      OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
      OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
      Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.
      PERSIST_STORE(int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified minor code and completion status.
      PERSIST_STORE(String s, int minor, CompletionStatus completed)
      Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.
      REBIND(int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified minor code and completion status.
      REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an REBIND exception with the specified message, minor code, and completion status.
      SystemException(String reason, int minor, CompletionStatus completed)
      Constructs a SystemException exception with the specified detail message, minor code, and completion status.
      TIMEOUT(int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified minor code and completion status.
      TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
      Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
      TRANSACTION_MODE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
      TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
      TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
      TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
      TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
      TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
      TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
      TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
      Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
      TRANSIENT(int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified minor code and completion status.
      TRANSIENT(String s, int minor, CompletionStatus completed)
      Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
      UNKNOWN(int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified minor code and completion status.
      UNKNOWN(String s, int minor, CompletionStatus completed)
      Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.CompletionStatusHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CompletionStatusHelper

No usage of org.omg.CORBA.CompletionStatusHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

YaBMtmlutsssSmooiC.So


Uses of Class org.omg.CORBA.Context

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Context

  • Packages that use Context
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Context in org.omg.CORBA

      Methods in org.omg.CORBA that return Context
      修饰符与类型 方法与描述
      abstract Context Context.create_child(String child_ctx_name)
      Creates a Context object with the given string as its name and with this Context object set as its parent.
      abstract Context ServerRequest.ctx()
      Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
      abstract Context Request.ctx()
      Retrieves the Context object for this request.
      abstract Context ORB.get_default_context()
      Gets the default Context object.
      abstract Context Context.parent()
      Retrieves the parent of this Context object.
      Methods in org.omg.CORBA with parameters of type Context
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      abstract void Request.ctx(Context c)
      Sets this request's Context object to the one given.

    • Uses of Context in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Context
      修饰符与类型 方法与描述
      Context InputStream.read_Context()
      Reads a CORBA context from the stream.
      Methods in org.omg.CORBA.portable with parameters of type Context
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      void OutputStream.write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

soJ& .tdde tv竤t


Uses of Class org.omg.CORBA.ContextList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ContextList

  • Packages that use ContextList
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ContextList in org.omg.CORBA

      Methods in org.omg.CORBA that return ContextList
      修饰符与类型 方法与描述
      abstract ContextList Request.contexts()
      Retrieves the ContextList object for this request.
      abstract ContextList ORB.create_context_list()
      Creates an empty ContextList object.
      Methods in org.omg.CORBA with parameters of type ContextList
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of ContextList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ContextList
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      void OutputStream.write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"m.../erfffa ss"Vt. "ll_


Uses of Class org.omg.CORBA.CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CurrentHelper

No usage of org.omg.CORBA.CurrentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i oolan neeedh = p"


Uses of Class org.omg.CORBA.CurrentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.CurrentHolder

No usage of org.omg.CORBA.CurrentHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<-�+ n纝誦<h s


Uses of Class org.omg.CORBA.DATA_CONVERSION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DATA_CONVERSION

  • Packages that use DATA_CONVERSION
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DATA_CONVERSION in org.omg.CORBA

      Methods in org.omg.CORBA that throw DATA_CONVERSION
      修饰符与类型 方法与描述
      abstract void Any.insert_char(char c)
      Inserts the given char into this Any object's value field.
      abstract void Any.insert_string(String s)
      Inserts the given String object into this Any object's value field.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtBl?g- ivooidl/rfLaa"ft=


Uses of Class org.omg.CORBA.DefinitionKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DefinitionKind

  • Packages that use DefinitionKind
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DefinitionKind in org.omg.CORBA

      Fields in org.omg.CORBA declared as DefinitionKind
      修饰符与类型 字段与描述
      static DefinitionKind DefinitionKind.dk_AbstractInterface
      The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
      static DefinitionKind DefinitionKind.dk_Alias
      The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
      static DefinitionKind DefinitionKind.dk_all
      The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
      static DefinitionKind DefinitionKind.dk_Array
      The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
      static DefinitionKind DefinitionKind.dk_Attribute
      The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
      static DefinitionKind DefinitionKind.dk_Constant
      The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
      static DefinitionKind DefinitionKind.dk_Enum
      The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
      static DefinitionKind DefinitionKind.dk_Exception
      The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
      static DefinitionKind DefinitionKind.dk_Fixed
      The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
      static DefinitionKind DefinitionKind.dk_Interface
      The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
      static DefinitionKind DefinitionKind.dk_Module
      The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
      static DefinitionKind DefinitionKind.dk_Native
      The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
      static DefinitionKind DefinitionKind.dk_none
      The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
      static DefinitionKind DefinitionKind.dk_Operation
      The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
      static DefinitionKind DefinitionKind.dk_Primitive
      The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
      static DefinitionKind DefinitionKind.dk_Repository
      The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
      static DefinitionKind DefinitionKind.dk_Sequence
      The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
      static DefinitionKind DefinitionKind.dk_String
      The static instance of DefinitionKind indicating that an Interface Repository object is a String.
      static DefinitionKind DefinitionKind.dk_Struct
      The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
      static DefinitionKind DefinitionKind.dk_Typedef
      The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
      static DefinitionKind DefinitionKind.dk_Union
      The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
      static DefinitionKind DefinitionKind.dk_Value
      The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
      static DefinitionKind DefinitionKind.dk_ValueBox
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
      static DefinitionKind DefinitionKind.dk_ValueMember
      The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
      static DefinitionKind DefinitionKind.dk_Wstring
      The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.
      Methods in org.omg.CORBA that return DefinitionKind
      修饰符与类型 | 方法与描述
      DefinitionKind | _IDLTypeStub.def_kind()
      DefinitionKind IRObjectOperations.def_kind()
      Returns the DefinitionKind corresponding to this Interface Repository object.
      static DefinitionKind | DefinitionKindHelper.extract(Any a)
      static DefinitionKind DefinitionKind.from_int(int i)
      Creates a DefinitionKind instance corresponding to the given code .
      static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type DefinitionKind
      修饰符与类型 | 方法与描述
      static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
      static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.j/nv.aft/./9m�


Uses of Class org.omg.CORBA.DefinitionKindHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DefinitionKindHelper

No usage of org.omg.CORBA.DefinitionKindHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.cDrtooo=accrsRoc


Uses of Class org.omg.CORBA.DoubleHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DoubleHolder

No usage of org.omg.CORBA.DoubleHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g<=AVBOTMMMBT--ii >


Uses of Class org.omg.CORBA.DoubleSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DoubleSeqHelper

No usage of org.omg.CORBA.DoubleSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�>t>c">bs輔o au#�


Uses of Class org.omg.CORBA.DoubleSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DoubleSeqHolder

  • Packages that use DoubleSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DoubleSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DoubleSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_double_array(DoubleSeqHolder seq, int offset, int length)
      Reads array of IDL doubles from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/smcjse.DtbhppDe-


Uses of Class org.omg.CORBA.DynamicImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DynamicImplementation

  • Packages that use DynamicImplementation
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of DynamicImplementation in org.omg.CosNaming

      Subclasses of DynamicImplementation in org.omg.CosNaming
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  | _NamingContextImplBase
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�;�>hl萳m>嫠<&萣<1&9,;#轩


Uses of Class org.omg.CORBA.Environment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Environment

  • Packages that use Environment
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Environment in org.omg.CORBA

      Methods in org.omg.CORBA that return Environment
      修饰符与类型 方法与描述
      abstract Environment ORB.create_environment()
      Creates an Environment object.
      abstract Environment Request.env()
      Retrieves the Environment object for this request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

omaif/<.t 騬hsktd�


Uses of Class org.omg.CORBA.ExceptionList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ExceptionList

  • Packages that use ExceptionList
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ExceptionList in org.omg.CORBA

      Methods in org.omg.CORBA that return ExceptionList
      修饰符与类型 方法与描述
      abstract ExceptionList ORB.create_exception_list()
      Creates an empty ExceptionList object.
      abstract ExceptionList Request.exceptions()
      Retrieves the ExceptionList object for this request.
      Methods in org.omg.CORBA with parameters of type ExceptionList
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of ExceptionList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ExceptionList
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

me///"aaeerhB >� r o


Uses of Class org.omg.CORBA.FieldNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FieldNameHelper

No usage of org.omg.CORBA.FieldNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oodiExcocdddy ooa(t_c


Uses of Class org.omg.CORBA.FixedHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FixedHolder

No usage of org.omg.CORBA.FixedHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><;>g/s


Uses of Class org.omg.CORBA.FloatHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FloatHolder

No usage of org.omg.CORBA.FloatHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-d�asct纋鬺A>杇o


Uses of Class org.omg.CORBA.FloatSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FloatSeqHelper

No usage of org.omg.CORBA.FloatSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>i/p aoiind sP! -o


Uses of Class org.omg.CORBA.FloatSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FloatSeqHolder

  • Packages that use FloatSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of FloatSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type FloatSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_float_array(FloatSeqHolder seq, int offset, int length)
      Reads array of IDL floats from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.aU gdf Xclmtn>mtduc


Uses of Class org.omg.CORBA.FREE_MEM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.FREE_MEM

No usage of org.omg.CORBA.FREE_MEM
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bue


Uses of Class org.omg.CORBA.IdentifierHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.IdentifierHelper

No usage of org.omg.CORBA.IdentifierHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d >=Fr&瞭


Uses of Class org.omg.CORBA.IDLTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.IDLTypeHelper

No usage of org.omg.CORBA.IDLTypeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

scshypenaddde"""pssds


Uses of Class org.omg.CORBA.IMP_LIMIT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.IMP_LIMIT

No usage of org.omg.CORBA.IMP_LIMIT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hftepacROBBBg.==iee


Uses of Class org.omg.CORBA.INITIALIZE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INITIALIZE

No usage of org.omg.CORBA.INITIALIZE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tph賏9e#td/$#


Uses of Class org.omg.CORBA.INTERNAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INTERNAL

No usage of org.omg.CORBA.INTERNAL
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.INTF_REPOS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INTF_REPOS

No usage of org.omg.CORBA.INTF_REPOS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t l kr佥 "nS/ter


Uses of Class org.omg.CORBA.IntHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.IntHolder

No usage of org.omg.CORBA.IntHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>p@tt> >l r lnrp


Uses of Class org.omg.CORBA.INV_FLAG

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INV_FLAG

No usage of org.omg.CORBA.INV_FLAG
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


Uses of Class org.omg.CORBA.INV_IDENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INV_IDENT

No usage of org.omg.CORBA.INV_IDENT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

to.#�


Uses of Class org.omg.CORBA.INV_OBJREF

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INV_OBJREF

No usage of org.omg.CORBA.INV_OBJREF
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

de.cn�pw >�&


Uses of Class org.omg.CORBA.INV_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INV_POLICY

No usage of org.omg.CORBA.INV_POLICY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Nt9f@举�牘 鈝j


Uses of Class org.omg.CORBA.INVALID_ACTIVITY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INVALID_ACTIVITY

No usage of org.omg.CORBA.INVALID_ACTIVITY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.i mf<.a"lC.etlo�/<


Uses of Class org.omg.CORBA.INVALID_TRANSACTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.INVALID_TRANSACTION

No usage of org.omg.CORBA.INVALID_TRANSACTION
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

D"i> 萫scmc /3d/n


Uses of Class org.omg.CORBA.LocalObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LocalObject

No usage of org.omg.CORBA.LocalObject
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

OdpAg.Cgr...ne""et>sa


Uses of Class org.omg.CORBA.LongHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LongHolder

No usage of org.omg.CORBA.LongHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>4Ot>A>ldAC.gg.peC<


Uses of Class org.omg.CORBA.LongLongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LongLongSeqHelper

No usage of org.omg.CORBA.LongLongSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dAs"booe<=.f>uw"/.


Uses of Class org.omg.CORBA.LongLongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LongLongSeqHolder

  • Packages that use LongLongSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of LongLongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type LongLongSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_longlong_array(LongLongSeqHolder seq, int offset, int length)
      Reads array of IDL long longs from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dsread luCl�.<輓ry


Uses of Class org.omg.CORBA.LongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LongSeqHelper

No usage of org.omg.CORBA.LongSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>= yittn fl


Uses of Class org.omg.CORBA.LongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.LongSeqHolder

  • Packages that use LongSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of LongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type LongSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_long_array(LongSeqHolder seq, int offset, int length)
      Reads array of IDL longs from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iL ig"藅h>lh�>.iyrl


Uses of Class org.omg.CORBA.MARSHAL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.MARSHAL

  • Packages that use MARSHAL
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of MARSHAL in org.omg.CORBA

      Methods in org.omg.CORBA that throw MARSHAL
      修饰符与类型 方法与描述
      abstract void Any.insert_string(String s)
      Inserts the given String object into this Any object's value field.
      abstract void Any.insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void Any.insert_wstring(String s)
      Inserts the given String object into this Any object's value field.
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ndmsas=&dp"縟k U it


Uses of Class org.omg.CORBA.NamedValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NamedValue

  • Packages that use NamedValue
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of NamedValue in org.omg.CORBA

      Methods in org.omg.CORBA that return NamedValue
      修饰符与类型 方法与描述
      abstract NamedValue NVList.add_item(String item_name, int flags)
      Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
      abstract NamedValue NVList.add_value(String item_name, Any val, int flags)
      Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
      abstract NamedValue NVList.add(int flags)
      Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
      abstract NamedValue ORB.create_named_value(String s, Any any, int flags)
      Creates a NamedValue object using the given name, value, and argument mode flags.
      abstract NamedValue NVList.item(int index)
      Retrieves the NamedValue object at the given index.
      abstract NamedValue Request.result()
      Retrieves the NamedValue object containing the return value for the method.
      Methods in org.omg.CORBA with parameters of type NamedValue
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.

    • Uses of NamedValue in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type NamedValue
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bu/f/vt"ni e vB/>< lt


Uses of Class org.omg.CORBA.NameValuePair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NameValuePair

  • Packages that use NameValuePair
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of NameValuePair in org.omg.CORBA

      Methods in org.omg.CORBA that return NameValuePair
      修饰符与类型 | 方法与描述
      static NameValuePair | NameValuePairHelper.extract(Any a)
      NameValuePair[] DynValue.get_members()
      Deprecated.
      Returns an array containing all the members of the value object stored in this DynValue.
      NameValuePair[] DynStruct.get_members()
      Deprecated.
      Returns an array containing all the members of the stored struct.
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type NameValuePair
      修饰符与类型 | 方法与描述
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      void DynValue.set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
      void DynStruct.set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jaa"titmtlllgn...tnciors


Uses of Class org.omg.CORBA.NameValuePairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NameValuePairHelper

No usage of org.omg.CORBA.NameValuePairHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eitl/DyOCRRRm.ffpa= =


Uses of Class org.omg.CORBA.NO_IMPLEMENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NO_IMPLEMENT

No usage of org.omg.CORBA.NO_IMPLEMENT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

enrnr&sf�>皉/


Uses of Class org.omg.CORBA.NO_MEMORY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NO_MEMORY

No usage of org.omg.CORBA.NO_MEMORY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nh/>slpla/y/


Uses of Class org.omg.CORBA.NO_PERMISSION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NO_PERMISSION

No usage of org.omg.CORBA.NO_PERMISSION
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/xre=sek;vs /� l�(


Uses of Class org.omg.CORBA.NO_RESOURCES

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NO_RESOURCES

No usage of org.omg.CORBA.NO_RESOURCES
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>e8/t>e>lxe=mvr ;


Uses of Class org.omg.CORBA.NO_RESPONSE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NO_RESPONSE

No usage of org.omg.CORBA.NO_RESPONSE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> >t>/>le/ee膖"8eO


Uses of Class org.omg.CORBA.NVList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.NVList

  • Packages that use NVList
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of NVList in org.omg.CORBA

      Methods in org.omg.CORBA that return NVList
      修饰符与类型 方法与描述
      abstract NVList Request.arguments()
      Retrieves the NVList object containing the arguments to the method being invoked.
      abstract NVList ORB.create_list(int count)
      Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
      NVList ORB.create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      abstract NVList Context.get_values(String start_scope, int op_flags, String pattern)
      Retrieves the NamedValue objects whose name field matches the given name or name pattern.
      Methods in org.omg.CORBA with parameters of type NVList
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      void ServerRequest.arguments(NVList args)
      Specifies method parameter types and retrieves "in" and "inout" argument values.
      void ServerRequest.params(NVList params)
      Deprecated.
      use the method arguments
      abstract void Context.set_values(NVList values)
      I Sets one or more property values in this Context object.

    • Uses of NVList in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type NVList
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s p.l


Uses of Class org.omg.CORBA.OBJ_ADAPTER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.OBJ_ADAPTER

No usage of org.omg.CORBA.OBJ_ADAPTER
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AA/ab;1;p-1


Uses of Class org.omg.CORBA.OBJECT_NOT_EXIST

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.OBJECT_NOT_EXIST

No usage of org.omg.CORBA.OBJECT_NOT_EXIST
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bnr>ucT>liatCD


Uses of Class org.omg.CORBA.ObjectHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ObjectHelper

No usage of org.omg.CORBA.ObjectHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rc >> ad


Uses of Class org.omg.CORBA.ObjectHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ObjectHolder

No usage of org.omg.CORBA.ObjectHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r p�<@.�x@ao


Uses of Class org.omg.CORBA.OctetSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.OctetSeqHelper

No usage of org.omg.CORBA.OctetSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<ttvuxub/t>


Uses of Class org.omg.CORBA.OctetSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.OctetSeqHolder

  • Packages that use OctetSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of OctetSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type OctetSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_octet_array(OctetSeqHolder seq, int offset, int length)
      Reads array of IDL octets from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ak..>.Bao> " tbs蹇t


Uses of Class org.omg.CORBA.ORB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ORB

  • Packages that use ORB
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ORB in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return ORB
      修饰符与类型 方法与描述
      ORB Tie.orb()
      Returns the ORB for this tie.
      Methods in javax.rmi.CORBA with parameters of type ORB
      修饰符与类型 方法与描述
      void Stub.connect(ORB orb)
      Connects this stub to an ORB.
      void StubDelegate.connect(Stub self, ORB orb)
      Delegation call for Stub.connect(org.omg.CORBA.ORB).
      Object UtilDelegate.copyObject(Object obj, ORB orb)
      Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
      static Object Util.copyObject(Object obj, ORB orb)
      Copies or connects an object.
      Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
      Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
      static Object[] Util.copyObjects(Object[] obj, ORB orb)
      Copies or connects an array of objects.
      void Tie.orb(ORB orb)
      Sets the ORB for this tie.

    • Uses of ORB in org.omg.CORBA

      Methods in org.omg.CORBA that return ORB
      修饰符与类型 方法与描述
      ORB LocalObject._orb()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      static ORB ORB.init()
      Returns the ORB singleton object.
      static ORB ORB.init(Applet app, Properties props)
      Creates a new ORB instance for an applet.
      static ORB ORB.init(String[] args, Properties props)
      Creates a new ORB instance for a standalone application.

    • Uses of ORB in org.omg.CORBA_2_3

      Subclasses of ORB in org.omg.CORBA_2_3
      修饰符与类型 类与描述
      class  ORB
      A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

    • Uses of ORB in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return ORB
      修饰符与类型 方法与描述
      ORB ObjectImpl._orb()
      Returns a reference to the ORB associated with this object and its delegate.
      ORB InputStream.orb()
      Returns the ORB that created this InputStream.
      ORB OutputStream.orb()
      Returns the ORB that created this OutputStream.
      ORB Delegate.orb(Object obj)
      Provides a reference to the orb associated with its parameter.

    • Uses of ORB in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ORB
      修饰符与类型 | 方法与描述
      NamingContextExt | NamingContextExtPOA._this(ORB orb)
      NamingContext | NamingContextPOA._this(ORB orb)
      BindingIterator | BindingIteratorPOA._this(ORB orb)

    • Uses of ORB in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ORB
      修饰符与类型 方法与描述
      ORB Servant._orb()
      Returns the instance of the ORB currently associated with the Servant (convenience method).
      Methods in org.omg.PortableServer with parameters of type ORB
      修饰符与类型 | 方法与描述
      Object Servant._this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
      ServantLocator | ServantLocatorPOA._this(ORB orb)
      ServantActivator | ServantActivatorPOA._this(ORB orb)

    • Uses of ORB in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return ORB
      修饰符与类型 方法与描述
      ORB Delegate.orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e;eanx/c s re


Uses of Class org.omg.CORBA.ParameterMode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ParameterMode

  • Packages that use ParameterMode
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.

    • Uses of ParameterMode in org.omg.CORBA

      Fields in org.omg.CORBA declared as ParameterMode
      修饰符与类型 | 字段与描述
      static ParameterMode | ParameterMode.PARAM_IN
      static ParameterMode | ParameterMode.PARAM_INOUT
      static ParameterMode | ParameterMode.PARAM_OUT
      ParameterMode | ParameterModeHolder.value
      Methods in org.omg.CORBA that return ParameterMode
      修饰符与类型 | 方法与描述
      static ParameterMode | ParameterModeHelper.extract(Any a)
      static ParameterMode | ParameterMode.from_int(int value)
      static ParameterMode | ParameterModeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type ParameterMode
      修饰符与类型 | 方法与描述
      static void | ParameterModeHelper.insert(Any a, ParameterMode that)
      static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
      Constructors in org.omg.CORBA with parameters of type ParameterMode
      构造方法与描述
      ParameterModeHolder(ParameterMode initialValue)

    • Uses of ParameterMode in org.omg.Dynamic

      Fields in org.omg.Dynamic declared as ParameterMode
      修饰符与类型 | 字段与描述
      ParameterMode | Parameter.mode
      Constructors in org.omg.Dynamic with parameters of type ParameterMode
      构造方法与描述
      Parameter(Any _argument, ParameterMode _mode)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t.m_/CO/gooo/.<


Uses of Class org.omg.CORBA.ParameterModeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ParameterModeHelper

No usage of org.omg.CORBA.ParameterModeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"=>Col"=rrra>ppeAhrp


Uses of Class org.omg.CORBA.ParameterModeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ParameterModeHolder

No usage of org.omg.CORBA.ParameterModeHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"|訟p=r貏詓�>鳤p


Uses of Class org.omg.CORBA.PERSIST_STORE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PERSIST_STORE

No usage of org.omg.CORBA.PERSIST_STORE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo>T>g莞be3&a癰b


Uses of Class org.omg.CORBA.PolicyError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyError

  • Packages that use PolicyError
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyError in org.omg.CORBA

      Fields in org.omg.CORBA declared as PolicyError
      修饰符与类型 | 字段与描述
      PolicyError | PolicyErrorHolder.value
      Methods in org.omg.CORBA that return PolicyError
      修饰符与类型 | 方法与描述
      static PolicyError | PolicyErrorHelper.extract(Any a)
      static PolicyError | PolicyErrorHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type PolicyError
      修饰符与类型 | 方法与描述
      static void | PolicyErrorHelper.insert(Any a, PolicyError that)
      static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
      Methods in org.omg.CORBA that throw PolicyError
      修饰符与类型 方法与描述
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      Constructors in org.omg.CORBA with parameters of type PolicyError
      构造方法与描述
      PolicyErrorHolder(PolicyError initialValue)

    • Uses of PolicyError in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw PolicyError
      修饰符与类型 方法与描述
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ah"lFi=s"""l"ssi ybenjTd f


Uses of Class org.omg.CORBA.PolicyErrorCodeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyErrorCodeHelper

No usage of org.omg.CORBA.PolicyErrorCodeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.i.e


Uses of Class org.omg.CORBA.PolicyErrorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyErrorHelper

No usage of org.omg.CORBA.PolicyErrorHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-motsn>sl><>g/s


Uses of Class org.omg.CORBA.PolicyErrorHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyErrorHolder

No usage of org.omg.CORBA.PolicyErrorHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�纒$� >g�


Uses of Class org.omg.CORBA.PolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyHelper

No usage of org.omg.CORBA.PolicyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

AD/ab;1;p-1


Uses of Class org.omg.CORBA.PolicyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyHolder

No usage of org.omg.CORBA.PolicyHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eX;Dp鈔�n


Uses of Class org.omg.CORBA.PolicyListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyListHelper

No usage of org.omg.CORBA.PolicyListHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<╤ o>ila塎y.�g


Uses of Class org.omg.CORBA.PolicyListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyListHolder

No usage of org.omg.CORBA.PolicyListHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

w�x>l�..0g


Uses of Class org.omg.CORBA.PolicyTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PolicyTypeHelper

No usage of org.omg.CORBA.PolicyTypeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i oifecta sstdo v


Uses of Class org.omg.CORBA.Principal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Principal

  • Packages that use Principal
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Principal in org.omg.CORBA

      Fields in org.omg.CORBA declared as Principal
      修饰符与类型 字段与描述
      Principal PrincipalHolder.value
      Deprecated.
      The Principal value held by this PrincipalHolder object.
      Methods in org.omg.CORBA that return Principal
      修饰符与类型 方法与描述
      Principal Any.extract_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      Methods in org.omg.CORBA with parameters of type Principal
      修饰符与类型 方法与描述
      void Any.insert_Principal(Principal p)
      Deprecated.
      Deprecated by CORBA 2.2.
      Constructors in org.omg.CORBA with parameters of type Principal
      构造方法与描述
      PrincipalHolder(Principal initial)
      Deprecated.
      Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.

    • Uses of Principal in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Principal
      修饰符与类型 方法与描述
      Principal InputStream.read_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      Methods in org.omg.CORBA.portable with parameters of type Principal
      修饰符与类型 方法与描述
      void OutputStream.write_Principal(Principal value)
      Deprecated.
      Deprecated by CORBA 2.2.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et=a dri-


Uses of Class org.omg.CORBA.PrincipalHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.PrincipalHolder

No usage of org.omg.CORBA.PrincipalHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lmdrcodihsssye<


Uses of Class org.omg.CORBA.REBIND

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.REBIND

No usage of org.omg.CORBA.REBIND
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s冃贬◆”绷 �>溃※g


Uses of Class org.omg.CORBA.RepositoryIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.RepositoryIdHelper

No usage of org.omg.CORBA.RepositoryIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eeAcpTci-Pdlec>t>P


Uses of Class org.omg.CORBA.Request

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.Request

  • Packages that use Request
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Request in org.omg.CORBA

      Methods in org.omg.CORBA that return Request
      修饰符与类型 方法与描述
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
      Request LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
      Request LocalObject._request(String operation)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Request Object._request(String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request ORB.get_next_response()
      Gets the next Request instance for which a response has been received.
      Methods in org.omg.CORBA with parameters of type Request
      修饰符与类型 方法与描述
      abstract void ORB.send_multiple_requests_deferred(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously.
      abstract void ORB.send_multiple_requests_oneway(Request[] req)
      Sends multiple dynamic (DII) requests asynchronously without expecting any responses.

    • Uses of Request in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Request
      修饰符与类型 方法与描述
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      Request ObjectImpl._request(String operation)
      Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n1sti raehrhti


Uses of Class org.omg.CORBA.ServerRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServerRequest

  • Packages that use ServerRequest
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServerRequest in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ServerRequest
      修饰符与类型 方法与描述
      void DynamicImplementation.invoke(ServerRequest request)
      Deprecated.
      Deprecated by Portable Object Adapter

    • Uses of ServerRequest in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ServerRequest
      修饰符与类型 | 方法与描述
      void | _BindingIteratorImplBase.invoke(ServerRequest r)
      void | _NamingContextImplBase.invoke(ServerRequest r)

    • Uses of ServerRequest in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type ServerRequest
      修饰符与类型 方法与描述
      abstract void DynamicImplementation.invoke(ServerRequest request)
      Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/tae ni sccca


Uses of Class org.omg.CORBA.ServiceDetail

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServiceDetail

  • Packages that use ServiceDetail
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceDetail in org.omg.CORBA

      Fields in org.omg.CORBA declared as ServiceDetail
      修饰符与类型 字段与描述
      ServiceDetail[] ServiceInformation.service_details
      Array of ServiceDetails giving more details about the service.
      Methods in org.omg.CORBA that return ServiceDetail
      修饰符与类型 | 方法与描述
      static ServiceDetail | ServiceDetailHelper.extract(Any a)
      static ServiceDetail | ServiceDetailHelper.read(InputStream in)
      Methods in org.omg.CORBA with parameters of type ServiceDetail
      修饰符与类型 | 方法与描述
      static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
      static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
      Constructors in org.omg.CORBA with parameters of type ServiceDetail
      构造方法与描述
      ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
      Constructs a ServiceInformation object with the given service_options and service_details.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d ldle < tS /y


Uses of Class org.omg.CORBA.ServiceDetailHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServiceDetailHelper

No usage of org.omg.CORBA.ServiceDetailHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osr"titmtlllliggrhRog


Uses of Class org.omg.CORBA.ServiceInformation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServiceInformation

  • Packages that use ServiceInformation
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceInformation in org.omg.CORBA

      Fields in org.omg.CORBA declared as ServiceInformation
      修饰符与类型 字段与描述
      ServiceInformation ServiceInformationHolder.value
      The ServiceInformation value held by this ServiceInformationHolder object in its value field.
      Methods in org.omg.CORBA that return ServiceInformation
      修饰符与类型 | 方法与描述
      static ServiceInformation | ServiceInformationHelper.extract(Any a)
      static ServiceInformation | ServiceInformationHelper.read(InputStream in)
      Methods in org.omg.CORBA with parameters of type ServiceInformation
      修饰符与类型 | 方法与描述
      static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
      static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
      Constructors in org.omg.CORBA with parameters of type ServiceInformation
      构造方法与描述
      ServiceInformationHolder(ServiceInformation arg)
      Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.ECORooSlm- ...O


Uses of Class org.omg.CORBA.ServiceInformationHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServiceInformationHelper

No usage of org.omg.CORBA.ServiceInformationHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aftRomgo>rrrmmAApnaoA


Uses of Class org.omg.CORBA.ServiceInformationHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ServiceInformationHolder

  • Packages that use ServiceInformationHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ServiceInformationHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ServiceInformationHolder
      修饰符与类型 方法与描述
      boolean ORB.get_service_information(short service_type, ServiceInformationHolder service_info)
      Used to obtain information about CORBA facilities and services that are supported by this ORB.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gd."ssl"alpncivaA.�<<=i o


Uses of Class org.omg.CORBA.SetOverrideType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.SetOverrideType

  • Packages that use SetOverrideType
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of SetOverrideType in org.omg.CORBA

      Fields in org.omg.CORBA declared as SetOverrideType
      修饰符与类型 字段与描述
      static SetOverrideType SetOverrideType.ADD_OVERRIDE
      The SetOverrideType constant for the enum value ADD_OVERRIDE.
      static SetOverrideType SetOverrideType.SET_OVERRIDE
      The SetOverrideType constant for the enum value SET_OVERRIDE.
      Methods in org.omg.CORBA that return SetOverrideType
      修饰符与类型 | 方法与描述
      static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
      static SetOverrideType SetOverrideType.from_int(int i)
      Converts the given int to the corresponding SetOverrideType instance.
      static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type SetOverrideType
      修饰符与类型 | 方法与描述
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
      static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)

    • Uses of SetOverrideType in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type SetOverrideType
      修饰符与类型 方法与描述
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

auwii.nslef, b",<"x


Uses of Class org.omg.CORBA.SetOverrideTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.SetOverrideTypeHelper

No usage of org.omg.CORBA.SetOverrideTypeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vv>RDD_uleee tooegl


Uses of Class org.omg.CORBA.ShortHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ShortHolder

No usage of org.omg.CORBA.ShortHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

av—间讳篇嗽冰籶Ｃ粼3


Uses of Class org.omg.CORBA.ShortSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ShortSeqHelper

No usage of org.omg.CORBA.ShortSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r" io=t皃r"&mle 皉


Uses of Class org.omg.CORBA.ShortSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ShortSeqHolder

  • Packages that use ShortSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ShortSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ShortSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_short_array(ShortSeqHolder seq, int offset, int length)
      Reads array of IDL shorts from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la.o tasgDn>a=ta>


Uses of Class org.omg.CORBA.StringHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StringHolder

No usage of org.omg.CORBA.StringHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Fr = ==< !!!i///ptm u


Uses of Class org.omg.CORBA.StringSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StringSeqHelper

No usage of org.omg.CORBA.StringSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sa =.kSsRRNe= mp ax


Uses of Class org.omg.CORBA.StringSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StringSeqHolder

No usage of org.omg.CORBA.StringSeqHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nx0�)S 蹳<


Uses of Class org.omg.CORBA.StringValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StringValueHelper

No usage of org.omg.CORBA.StringValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-cebi ljsssddV".筧


Uses of Class org.omg.CORBA.StructMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StructMember

  • Packages that use StructMember
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of StructMember in org.omg.CORBA

      Methods in org.omg.CORBA that return StructMember
      修饰符与类型 | 方法与描述
      static StructMember | StructMemberHelper.extract(Any a)
      static StructMember | StructMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type StructMember
      修饰符与类型 | 方法与描述
      abstract TypeCode ORB.create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      abstract TypeCode ORB.create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      static void | StructMemberHelper.insert(Any a, StructMember that)
      static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Isr=ss Bhxarfc#=薭bn


Uses of Class org.omg.CORBA.StructMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.StructMemberHelper

No usage of org.omg.CORBA.StructMemberHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m/bAg/Cgr///./>> "ta<


Uses of Class org.omg.CORBA.SystemException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.SystemException

  • Packages that use SystemException
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of SystemException in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type SystemException
      修饰符与类型 方法与描述
      RemoteException UtilDelegate.mapSystemException(SystemException ex)
      Delegation call for Util.mapSystemException(org.omg.CORBA.SystemException).
      static RemoteException Util.mapSystemException(SystemException ex)
      Maps a SystemException to a RemoteException.

    • Uses of SystemException in org.omg.CORBA

      Subclasses of SystemException in org.omg.CORBA
      修饰符与类型 类与描述
      class  ACTIVITY_COMPLETED
      The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
      class  ACTIVITY_REQUIRED
      The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
      class  BAD_CONTEXT
      Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
      class  BAD_INV_ORDER
      This exception indicates that the caller has invoked operations in the wrong order.
      class  BAD_OPERATION
      Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
      class  BAD_PARAM
      Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
      class  BAD_QOS
      The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
      class  BAD_TYPECODE
      Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
      class  CODESET_INCOMPATIBLE
      This exception is raised whenever meaningful communication is not possible between client and server native code sets.
      class  COMM_FAILURE
      This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
      class  DATA_CONVERSION
      This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
      class  FREE_MEM
      Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
      class  IMP_LIMIT
      This exception indicates that an implementation limit was exceeded in the ORB run time.
      class  INITIALIZE
      Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
      class  INTERNAL
      This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
      class  INTF_REPOS
      Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
      class  INV_FLAG
      Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
      class  INV_IDENT
      This exception indicates that an IDL identifier is syntactically invalid.
      class  INV_OBJREF
      This exception indicates that an object reference is internally malformed.
      class  INV_POLICY
      Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
      class  INVALID_ACTIVITY
      The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
      class  INVALID_TRANSACTION
      Exception thrown when the request carried an invalid transaction context.
      class  MARSHAL
      A request or reply from the network is structurally invalid.
      class  NO_IMPLEMENT
      This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists.
      class  NO_MEMORY
      Exception thrown when the ORB run time has run out of memory.
      class  NO_PERMISSION
      Exception thrown when an invocation failed because the caller has insufficient privileges.
      class  NO_RESOURCES
      Exception thrown when the ORB has encountered some general resource limitation.
      class  NO_RESPONSE
      This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.
      class  OBJ_ADAPTER
      This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.
      class  OBJECT_NOT_EXIST
      Exception raised whenever an invocation on a deleted object was performed.
      class  PERSIST_STORE
      This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.
      class  REBIND
      REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD.
      class  TIMEOUT
      TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded.
      class  TRANSACTION_MODE
      The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation).
      class  TRANSACTION_REQUIRED
      Exception indicates that the request carried a null transaction context, but an active transaction is required.
      class  TRANSACTION_ROLLEDBACK
      Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back.
      class  TRANSACTION_UNAVAILABLE
      The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated.
      class  TRANSIENT
      Exception thrown when the ORB attempted to reach an object and failed.
      class  UNKNOWN
      This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression.

    • Uses of SystemException in org.omg.CORBA.portable

      Subclasses of SystemException in org.omg.CORBA.portable
      修饰符与类型 类与描述
      class  IndirectionException
      The Indirection exception is a Java specific system exception.
      class  UnknownException
      The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.
      Methods in org.omg.CORBA.portable that throw SystemException
      修饰符与类型 方法与描述
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"eOr :=ane r�.gg


Uses of Class org.omg.CORBA.TCKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TCKind

  • Packages that use TCKind
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of TCKind in org.omg.CORBA

      Fields in org.omg.CORBA declared as TCKind
      修饰符与类型 字段与描述
      static TCKind TCKind.tk_abstract_interface
      The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
      static TCKind TCKind.tk_alias
      The TCKind constant whose value field is initialized with TCKind._tk_alias.
      static TCKind TCKind.tk_any
      The TCKind constant whose value field is initialized with TCKind._tk_any.
      static TCKind TCKind.tk_array
      The TCKind constant whose value field is initialized with TCKind._tk_array.
      static TCKind TCKind.tk_boolean
      The TCKind constant whose value field is initialized with TCKind._tk_boolean.
      static TCKind TCKind.tk_char
      The TCKind constant whose value field is initialized with TCKind._tk_char.
      static TCKind TCKind.tk_double
      The TCKind constant whose value field is initialized with TCKind._tk_double.
      static TCKind TCKind.tk_enum
      The TCKind constant whose value field is initialized with TCKind._tk_enum.
      static TCKind TCKind.tk_except
      The TCKind constant whose value field is initialized with TCKind._tk_except.
      static TCKind TCKind.tk_fixed
      The TCKind constant whose value field is initialized with TCKind._tk_fixed.
      static TCKind TCKind.tk_float
      The TCKind constant whose value field is initialized with TCKind._tk_float.
      static TCKind TCKind.tk_long
      The TCKind constant whose value field is initialized with TCKind._tk_long.
      static TCKind TCKind.tk_longdouble
      The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
      static TCKind TCKind.tk_longlong
      The TCKind constant whose value field is initialized with TCKind._tk_longlong.
      static TCKind TCKind.tk_native
      The TCKind constant whose value field is initialized with TCKind._tk_native.
      static TCKind TCKind.tk_null
      The TCKind constant whose value field is initialized with TCKind._tk_null.
      static TCKind TCKind.tk_objref
      The TCKind constant whose value field is initialized with TCKind._tk_objref.
      static TCKind TCKind.tk_octet
      The TCKind constant whose value field is initialized with TCKind._tk_octet.
      static TCKind TCKind.tk_Principal
      The TCKind constant whose value field is initialized with TCKind._tk_Principal.
      static TCKind TCKind.tk_sequence
      The TCKind constant whose value field is initialized with TCKind._tk_sequence.
      static TCKind TCKind.tk_short
      The TCKind constant whose value field is initialized with TCKind._tk_short.
      static TCKind TCKind.tk_string
      The TCKind constant whose value field is initialized with TCKind._tk_string.
      static TCKind TCKind.tk_struct
      The TCKind constant whose value field is initialized with TCKind._tk_struct.
      static TCKind TCKind.tk_TypeCode
      The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
      static TCKind TCKind.tk_ulong
      The TCKind constant whose value field is initialized with TCKind._tk_ulong.
      static TCKind TCKind.tk_ulonglong
      The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
      static TCKind TCKind.tk_union
      The TCKind constant whose value field is initialized with TCKind._tk_union.
      static TCKind TCKind.tk_ushort
      The TCKind constant whose value field is initialized with TCKind._tk_ushort.
      static TCKind TCKind.tk_value
      The TCKind constant whose value field is initialized with TCKind._tk_value.
      static TCKind TCKind.tk_value_box
      The TCKind constant whose value field is initialized with TCKind._tk_value_box.
      static TCKind TCKind.tk_void
      The TCKind constant whose value field is initialized with TCKind._tk_void.
      static TCKind TCKind.tk_wchar
      The TCKind constant whose value field is initialized with TCKind._tk_wchar.
      static TCKind TCKind.tk_wstring
      The TCKind constant whose value field is initialized with TCKind._tk_wstring.
      Methods in org.omg.CORBA that return TCKind
      修饰符与类型 方法与描述
      TCKind DynValue.current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the current member.
      TCKind DynStruct.current_member_kind()
      Deprecated.
      Returns the TCKind object that describes the kind of the current member.
      TCKind DynUnion.discriminator_kind()
      Deprecated.
      Returns the TCKind object associated with the discriminator of this union.
      static TCKind TCKind.from_int(int i)
      Converts the given int to the corresponding TCKind instance.
      abstract TCKind TypeCode.kind()
      Retrieves the kind of this TypeCode object.
      TCKind DynUnion.member_kind()
      Deprecated.
      Returns the TCKind associated with the member of this union.
      Methods in org.omg.CORBA with parameters of type TCKind
      修饰符与类型 方法与描述
      abstract TypeCode ORB.get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.

    • Uses of TCKind in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return TCKind
      修饰符与类型 方法与描述
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynUnionStub.discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      TCKind DynUnionOperations.discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      TCKind _DynUnionStub.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      TCKind DynUnionOperations.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>91c/0cn1b>�


Uses of Class org.omg.CORBA.TIMEOUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TIMEOUT

No usage of org.omg.CORBA.TIMEOUT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stt/CKidoeee oii_beti


Uses of Class org.omg.CORBA.TRANSACTION_MODE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TRANSACTION_MODE

No usage of org.omg.CORBA.TRANSACTION_MODE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tltsnnesr�-areOp萾/


Uses of Class org.omg.CORBA.TRANSACTION_REQUIRED

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TRANSACTION_REQUIRED

No usage of org.omg.CORBA.TRANSACTION_REQUIRED
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.nasoIc.oho nwl


Uses of Class org.omg.CORBA.TRANSACTION_ROLLEDBACK

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TRANSACTION_ROLLEDBACK

No usage of org.omg.CORBA.TRANSACTION_ROLLEDBACK
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eAa jcle g;/edc


Uses of Class org.omg.CORBA.TRANSACTION_UNAVAILABLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TRANSACTION_UNAVAILABLE

No usage of org.omg.CORBA.TRANSACTION_UNAVAILABLE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

 #.m"/h


Uses of Class org.omg.CORBA.TypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TypeCode

  • Packages that use TypeCode
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of TypeCode in org.omg.CORBA

      Fields in org.omg.CORBA declared as TypeCode
      修饰符与类型 字段与描述
      TypeCode ValueMember.type
      The type of of this value member.
      TypeCode UnionMember.type
      The type of the union member described by this UnionMember object.
      TypeCode StructMember.type
      The type of the struct member described by this StructMember object.
      TypeCode TypeCodeHolder.value
      The TypeCode value held by this TypeCodeHolder object.
      Methods in org.omg.CORBA that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | WrongTransactionHolder._type()
      TypeCode | WStringSeqHolder._type()
      TypeCode | UnknownUserExceptionHolder._type()
      TypeCode | StringSeqHolder._type()
      TypeCode | PolicyErrorHolder._type()
      TypeCode | ParameterModeHolder._type()
      TypeCode ValueBaseHolder._type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      TypeCode | PolicyListHolder._type()
      TypeCode | PolicyHolder._type()
      TypeCode | DoubleSeqHolder._type()
      TypeCode | FloatSeqHolder._type()
      TypeCode | LongLongSeqHolder._type()
      TypeCode | ULongLongSeqHolder._type()
      TypeCode | ULongSeqHolder._type()
      TypeCode | LongSeqHolder._type()
      TypeCode | UShortSeqHolder._type()
      TypeCode | ShortSeqHolder._type()
      TypeCode | OctetSeqHolder._type()
      TypeCode | WCharSeqHolder._type()
      TypeCode | CurrentHolder._type()
      TypeCode | CharSeqHolder._type()
      TypeCode | BooleanSeqHolder._type()
      TypeCode | AnySeqHolder._type()
      TypeCode TypeCodeHolder._type()
      Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
      TypeCode StringHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
      TypeCode ShortHolder._type()
      Returns the TypeCode corresponding to the value held in this ShortHolder object.
      TypeCode PrincipalHolder._type()
      Deprecated.
      TypeCode ObjectHolder._type()
      Returns the TypeCode corresponding to the value held in this ObjectHolder object
      TypeCode LongHolder._type()
      Returns the TypeCode object corresponding to the value held in the Holder.
      TypeCode IntHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
      TypeCode FloatHolder._type()
      Return the TypeCode of this Streamable.
      TypeCode FixedHolder._type()
      Return the TypeCode of this holder object.
      TypeCode DoubleHolder._type()
      Return the TypeCode of this holder object.
      TypeCode CharHolder._type()
      Returns the TypeCode object corresponding to the value held in this CharHolder object.
      TypeCode ByteHolder._type()
      Returns the TypeCode corresponding to the value held in this ByteHolder object.
      TypeCode BooleanHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
      TypeCode AnyHolder._type()
      Returns the TypeCode object corresponding to the value held in this AnyHolder object.
      TypeCode ServiceInformationHolder._type()
      Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
      abstract TypeCode TypeCode.concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode TypeCode.content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      TypeCode ORB.create_abstract_interface_tc(String id, String name)
      Create a TypeCode object for an IDL abstract interface.
      abstract TypeCode ORB.create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract TypeCode ORB.create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      abstract TypeCode ORB.create_enum_tc(String id, String name, String[] members)
      Creates a TypeCode object representing an IDL enum.
      abstract TypeCode ORB.create_exception_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL exception.
      TypeCode ORB.create_fixed_tc(short digits, short scale)
      Create a TypeCode object for an IDL fixed type.
      abstract TypeCode ORB.create_interface_tc(String id, String name)
      Creates a TypeCode object representing an IDL 接口.
      TypeCode ORB.create_native_tc(String id, String name)
      Create a TypeCode object for an IDL native type.
      abstract TypeCode ORB.create_recursive_sequence_tc(int bound, int offset)
      Deprecated.
      Use a combination of create_recursive_tc and create_sequence_tc instead
      TypeCode ORB.create_recursive_tc(String id)
      Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
      abstract TypeCode ORB.create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode ORB.create_string_tc(int bound)
      Creates a TypeCode object representing a bounded IDL string.
      abstract TypeCode ORB.create_struct_tc(String id, String name, StructMember[] members)
      Creates a TypeCode object representing an IDL struct.
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract TypeCode ORB.create_wstring_tc(int bound)
      Creates a TypeCode object representing a bounded IDL wstring (wide string).
      abstract TypeCode TypeCode.discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract TypeCode Any.extract_TypeCode()
      Extracts the TypeCode object in this Any object's value field.
      abstract TypeCode TypeCode.get_compact_typecode()
      Strips out all optional name and member name fields, but leaves all alias typecodes intact.
      abstract TypeCode ORB.get_primitive_tc(TCKind tcKind)
      Retrieves the TypeCode object that represents the given primitive IDL type.
      TypeCode DynAny.get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      abstract TypeCode ExceptionList.item(int index)
      Returns the TypeCode object at the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      TypeCode DataInputStream.read_TypeCode()
      Reads an IDL typecode from the input stream.
      static TypeCode | WStringSeqHelper.type()
      static TypeCode | UnknownUserExceptionHelper.type()
      static TypeCode | StringSeqHelper.type()
      static TypeCode | PolicyErrorHelper.type()
      static TypeCode | PolicyErrorCodeHelper.type()
      static TypeCode | ParameterModeHelper.type()
      TypeCode | _IDLTypeStub.type()
      static TypeCode | WStringValueHelper.type()
      static TypeCode | WCharSeqHelper.type()
      static TypeCode | VisibilityHelper.type()
      static TypeCode | VersionSpecHelper.type()
      static TypeCode | ValueMemberHelper.type()
      static TypeCode | ValueBaseHelper.type()
      static TypeCode | UnionMemberHelper.type()
      static TypeCode | UShortSeqHelper.type()
      static TypeCode | ULongSeqHelper.type()
      static TypeCode | ULongLongSeqHelper.type()
      static TypeCode | StructMemberHelper.type()
      static TypeCode | StringValueHelper.type()
      static TypeCode | ShortSeqHelper.type()
      static TypeCode | SetOverrideTypeHelper.type()
      static TypeCode | RepositoryIdHelper.type()
      static TypeCode | PolicyListHelper.type()
      static TypeCode | PolicyTypeHelper.type()
      static TypeCode | PolicyHelper.type()
      static TypeCode | OctetSeqHelper.type()
      static TypeCode | NameValuePairHelper.type()
      static TypeCode | LongSeqHelper.type()
      static TypeCode | LongLongSeqHelper.type()
      static TypeCode | IdentifierHelper.type()
      static TypeCode | IDLTypeHelper.type()
      static TypeCode | FloatSeqHelper.type()
      static TypeCode | FieldNameHelper.type()
      static TypeCode | DoubleSeqHelper.type()
      static TypeCode | DefinitionKindHelper.type()
      static TypeCode | CurrentHelper.type()
      static TypeCode | CompletionStatusHelper.type()
      static TypeCode | CharSeqHelper.type()
      static TypeCode | BooleanSeqHelper.type()
      static TypeCode | AnySeqHelper.type()
      static TypeCode | ServiceDetailHelper.type()
      static TypeCode | ObjectHelper.type()
      static TypeCode | ServiceInformationHelper.type()
      static TypeCode | WrongTransactionHelper.type()
      TypeCode IDLTypeOperations.type()
      The type attribute describes the type defined by an object derived from IDLType.
      TypeCode DynAny.type()
      Deprecated.
      Returns the TypeCode of the object inserted into this DynAny.
      abstract TypeCode Any.type()
      Returns type information for the element contained in this Any object.
      Methods in org.omg.CORBA with parameters of type TypeCode
      修饰符与类型 方法与描述
      abstract void ExceptionList.add(TypeCode exc)
      Adds a TypeCode object describing an exception to this ExceptionList object.
      abstract TypeCode ORB.create_alias_tc(String id, String name, TypeCode original_type)
      Creates a TypeCode object representing an IDL alias (typedef).
      abstract TypeCode ORB.create_array_tc(int length, TypeCode element_type)
      Creates a TypeCode object representing an IDL array.
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      abstract TypeCode ORB.create_sequence_tc(int bound, TypeCode element_type)
      Creates a TypeCode object representing an IDL sequence.
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      TypeCode ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
      Creates a TypeCode object for an IDL value box.
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      abstract boolean TypeCode.equal(TypeCode tc)
      Compares this TypeCode object with the given one, testing for equality.
      abstract boolean TypeCode.equivalent(TypeCode tc)
      Tests to see if the given TypeCode object is equivalent to this TypeCode object.
      void Any.insert_fixed(BigDecimal value, TypeCode type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception.
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      void DynAny.insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      abstract void Any.insert_TypeCode(TypeCode t)
      Inserts the given TypeCode object into this Any object's value field.
      abstract void Any.insert_Value(Serializable v, TypeCode t)
      Inserts the given java.io.Serializable object into this Any object's value field.
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      abstract void Request.set_return_type(TypeCode tc)
      Sets the typecode for the return value of the method.
      abstract void Any.type(TypeCode t)
      Sets this Any object's type field to the given TypeCode object and clears its value.
      void DataOutputStream.write_TypeCode(TypeCode value)
      Writes the typecode to the output stream.
      Constructors in org.omg.CORBA with parameters of type TypeCode
      构造方法与描述
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.
      TypeCodeHolder(TypeCode initial)
      Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.

    • Uses of TypeCode in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return TypeCode
      修饰符与类型 方法与描述
      TypeCode Streamable._type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      abstract TypeCode InputStream.read_TypeCode()
      Reads a TypeCode from this input stream.
      Methods in org.omg.CORBA.portable with parameters of type TypeCode
      修饰符与类型 方法与描述
      abstract void OutputStream.write_TypeCode(TypeCode value)
      Writes a TypeCode on this output stream.

    • Uses of TypeCode in org.omg.CosNaming

      Methods in org.omg.CosNaming that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | NamingContextExtHolder._type()
      TypeCode | NamingContextHolder._type()
      TypeCode | NameHolder._type()
      TypeCode | NameComponentHolder._type()
      TypeCode | BindingTypeHolder._type()
      TypeCode | BindingIteratorHolder._type()
      TypeCode | BindingListHolder._type()
      TypeCode | BindingHolder._type()
      static TypeCode | NamingContextExtHelper.type()
      static TypeCode | NamingContextHelper.type()
      static TypeCode | NameHelper.type()
      static TypeCode | NameComponentHelper.type()
      static TypeCode | BindingTypeHelper.type()
      static TypeCode | BindingListHelper.type()
      static TypeCode | BindingIteratorHelper.type()
      static TypeCode | BindingHelper.type()
      static TypeCode | IstringHelper.type()

    • Uses of TypeCode in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | InvalidAddressHolder._type()
      static TypeCode | URLStringHelper.type()
      static TypeCode | StringNameHelper.type()
      static TypeCode | InvalidAddressHelper.type()
      static TypeCode | AddressHelper.type()

    • Uses of TypeCode in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | NotFoundReasonHolder._type()
      TypeCode | NotFoundHolder._type()
      TypeCode | NotEmptyHolder._type()
      TypeCode | InvalidNameHolder._type()
      TypeCode | CannotProceedHolder._type()
      TypeCode | AlreadyBoundHolder._type()
      static TypeCode | NotFoundReasonHelper.type()
      static TypeCode | NotFoundHelper.type()
      static TypeCode | NotEmptyHelper.type()
      static TypeCode | InvalidNameHelper.type()
      static TypeCode | CannotProceedHelper.type()
      static TypeCode | AlreadyBoundHelper.type()

    • Uses of TypeCode in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynValueStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynUnionStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynStructStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynSequenceStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynFixedStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynEnumStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynArrayStub.type()
      Returns the TypeCode associated with this DynAny object.
      TypeCode _DynAnyStub.type()
      Returns the TypeCode associated with this DynAny object.
      static TypeCode | NameValuePairSeqHelper.type()
      static TypeCode | NameValuePairHelper.type()
      static TypeCode | NameDynAnyPairSeqHelper.type()
      static TypeCode | DynSequenceHelper.type()
      static TypeCode | NameDynAnyPairHelper.type()
      static TypeCode | FieldNameHelper.type()
      static TypeCode | DynFixedHelper.type()
      static TypeCode | DynEnumHelper.type()
      static TypeCode | DynAnySeqHelper.type()
      static TypeCode | DynArrayHelper.type()
      static TypeCode | DynValueHelper.type()
      static TypeCode | DynAnyHelper.type()
      static TypeCode | DynUnionHelper.type()
      static TypeCode | DynAnyFactoryHelper.type()
      static TypeCode | DynStructHelper.type()
      static TypeCode | AnySeqHelper.type()
      TypeCode DynAnyOperations.type()
      Returns the TypeCode associated with this DynAny object.
      Methods in org.omg.DynamicAny with parameters of type TypeCode
      修饰符与类型 方法与描述
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.

    • Uses of TypeCode in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | InconsistentTypeCodeHelper.type()

    • Uses of TypeCode in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | TypeMismatchHelper.type()
      static TypeCode | InvalidValueHelper.type()

    • Uses of TypeCode in org.omg.IOP

      Methods in org.omg.IOP that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | TaggedProfileHolder._type()
      TypeCode | TaggedComponentHolder._type()
      TypeCode | ServiceContextListHolder._type()
      TypeCode | ServiceContextHolder._type()
      TypeCode | MultipleComponentProfileHolder._type()
      TypeCode | IORHolder._type()
      static TypeCode | TaggedProfileHelper.type()
      static TypeCode | TaggedComponentHelper.type()
      static TypeCode | ServiceIdHelper.type()
      static TypeCode | ServiceContextListHelper.type()
      static TypeCode | ServiceContextHelper.type()
      static TypeCode | ProfileIdHelper.type()
      static TypeCode | MultipleComponentProfileHelper.type()
      static TypeCode | IORHelper.type()
      static TypeCode | ComponentIdHelper.type()
      static TypeCode | CodecFactoryHelper.type()
      Methods in org.omg.IOP with parameters of type TypeCode
      修饰符与类型 方法与描述
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

    • Uses of TypeCode in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | UnknownEncodingHelper.type()

    • Uses of TypeCode in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | TypeMismatchHelper.type()
      static TypeCode | InvalidTypeForEncodingHelper.type()
      static TypeCode | FormatMismatchHelper.type()

    • Uses of TypeCode in org.omg.Messaging

      Methods in org.omg.Messaging that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | SyncScopeHelper.type()

    • Uses of TypeCode in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | ObjectReferenceTemplateSeqHolder._type()
      TypeCode | ObjectReferenceTemplateHolder._type()
      TypeCode | ObjectReferenceFactoryHolder._type()
      TypeCode | IORInterceptor_3_0Holder._type()
      TypeCode[] RequestInfoOperations.exceptions()
      Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
      static TypeCode | ServerIdHelper.type()
      static TypeCode | ORBIdHelper.type()
      static TypeCode | ObjectReferenceTemplateSeqHelper.type()
      static TypeCode | ObjectReferenceTemplateHelper.type()
      static TypeCode | ObjectReferenceFactoryHelper.type()
      static TypeCode | ObjectIdHelper.type()
      static TypeCode | InvalidSlotHelper.type()
      static TypeCode | IORInterceptor_3_0Helper.type()
      static TypeCode | ForwardRequestHelper.type()
      static TypeCode | CurrentHelper.type()
      static TypeCode | AdapterStateHelper.type()
      static TypeCode | AdapterNameHelper.type()
      static TypeCode | AdapterManagerIdHelper.type()

    • Uses of TypeCode in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | ObjectIdHelper.type()
      static TypeCode | InvalidNameHelper.type()
      static TypeCode | DuplicateNameHelper.type()

    • Uses of TypeCode in org.omg.PortableServer

      Methods in org.omg.PortableServer that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | ServantLocatorHelper.type()
      static TypeCode | ServantActivatorHelper.type()
      static TypeCode | POAHelper.type()
      static TypeCode | ForwardRequestHelper.type()
      static TypeCode | CurrentHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | NoContextHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | AdapterInactiveHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return TypeCode
      修饰符与类型 | 方法与描述
      static TypeCode | WrongPolicyHelper.type()
      static TypeCode | WrongAdapterHelper.type()
      static TypeCode | ServantNotActiveHelper.type()
      static TypeCode | ServantAlreadyActiveHelper.type()
      static TypeCode | ObjectNotActiveHelper.type()
      static TypeCode | ObjectAlreadyActiveHelper.type()
      static TypeCode | NoServantHelper.type()
      static TypeCode | InvalidPolicyHelper.type()
      static TypeCode | AdapterNonExistentHelper.type()
      static TypeCode | AdapterAlreadyExistsHelper.type()

    • Uses of TypeCode in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage that return TypeCode
      修饰符与类型 | 方法与描述
      TypeCode | CookieHolder._type()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.TypeCodeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TypeCodeHolder

No usage of org.omg.CORBA.TypeCodeHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

trd/ckaroyyya.gga i=y


Uses of Class org.omg.CORBA.ULongLongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ULongLongSeqHelper

No usage of org.omg.CORBA.ULongLongSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s t /b-/rsv


Uses of Class org.omg.CORBA.ULongLongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ULongLongSeqHolder

  • Packages that use ULongLongSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ULongLongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ULongLongSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned long longs from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.olcWlm


Uses of Class org.omg.CORBA.ULongSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ULongSeqHelper

No usage of org.omg.CORBA.ULongSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>b


Uses of Class org.omg.CORBA.ULongSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ULongSeqHolder

  • Packages that use ULongSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ULongSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type ULongSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_ulong_array(ULongSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned longs from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Q.�.;rh..�"l�=d龋>o t


Uses of Class org.omg.CORBA.UnionMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UnionMember

  • Packages that use UnionMember
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UnionMember in org.omg.CORBA

      Methods in org.omg.CORBA that return UnionMember
      修饰符与类型 | 方法与描述
      static UnionMember | UnionMemberHelper.extract(Any a)
      static UnionMember | UnionMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type UnionMember
      修饰符与类型 | 方法与描述
      abstract TypeCode ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
      Creates a TypeCode object representing an IDL union.
      static void | UnionMemberHelper.insert(Any a, UnionMember that)
      static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e..r/tnae>:>

.dsTrA


Uses of Class org.omg.CORBA.UnionMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UnionMemberHelper

No usage of org.omg.CORBA.UnionMemberHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.IhmnioBRAAA//""scno.


Uses of Class org.omg.CORBA.UNKNOWN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UNKNOWN

No usage of org.omg.CORBA.UNKNOWN
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aI—间讳篇嗽冰籶Ｃ粼3


Uses of Class org.omg.CORBA.UnknownUserException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UnknownUserException

  • Packages that use UnknownUserException
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UnknownUserException in org.omg.CORBA

      Fields in org.omg.CORBA declared as UnknownUserException
      修饰符与类型 | 字段与描述
      UnknownUserException | UnknownUserExceptionHolder.value
      Methods in org.omg.CORBA that return UnknownUserException
      修饰符与类型 | 方法与描述
      static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
      static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type UnknownUserException
      修饰符与类型 | 方法与描述
      static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
      static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
      Constructors in org.omg.CORBA with parameters of type UnknownUserException
      构造方法与描述
      UnknownUserExceptionHolder(UnknownUserException initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

so>o.p.m鎟< .a


Uses of Class org.omg.CORBA.UnknownUserExceptionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UnknownUserExceptionHelper

No usage of org.omg.CORBA.UnknownUserExceptionHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aosn>


Uses of Class org.omg.CORBA.UnknownUserExceptionHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UnknownUserExceptionHolder

No usage of org.omg.CORBA.UnknownUserExceptionHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oyc .o>^ts疷餺


Uses of Class org.omg.CORBA.UserException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UserException

  • Packages that use UserException
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of UserException in org.omg.CORBA

      Subclasses of UserException in org.omg.CORBA
      修饰符与类型 类与描述
      class  Bounds
      A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
      class  PolicyError
      A user exception thrown when a policy error occurs.
      class  UnknownUserException
      A class that contains user exceptions returned by the server.
      class  WrongTransaction
      The CORBA WrongTransaction user-defined exception.

    • Uses of UserException in org.omg.CORBA.DynAnyPackage

      Subclasses of UserException in org.omg.CORBA.DynAnyPackage
      修饰符与类型 | 类与描述
      class  Invalid
      Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
      class  InvalidSeq
      The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
      class  | InvalidValue
      class  TypeMismatch
      TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • Uses of UserException in org.omg.CORBA.ORBPackage

      Subclasses of UserException in org.omg.CORBA.ORBPackage
      修饰符与类型 类与描述
      class  InconsistentTypeCode
      InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
      class  InvalidName
      The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

    • Uses of UserException in org.omg.CORBA.TypeCodePackage

      Subclasses of UserException in org.omg.CORBA.TypeCodePackage
      修饰符与类型 类与描述
      class  BadKind
      The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.

    • Uses of UserException in org.omg.CosNaming.NamingContextExtPackage

      Subclasses of UserException in org.omg.CosNaming.NamingContextExtPackage
      修饰符与类型 类与描述
      class  InvalidAddress
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

    • Uses of UserException in org.omg.CosNaming.NamingContextPackage

      Subclasses of UserException in org.omg.CosNaming.NamingContextPackage
      修饰符与类型 类与描述
      class  AlreadyBound
      org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
      class  CannotProceed
      org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
      class  NotEmpty
      org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
      class  NotFound
      org/omg/CosNaming/NamingContextPackage/NotFound.java .

    • Uses of UserException in org.omg.IOP.CodecFactoryPackage

      Subclasses of UserException in org.omg.IOP.CodecFactoryPackage
      修饰符与类型 类与描述
      class  UnknownEncoding
      org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

    • Uses of UserException in org.omg.IOP.CodecPackage

      Subclasses of UserException in org.omg.IOP.CodecPackage
      修饰符与类型 类与描述
      class  FormatMismatch
      org/omg/IOP/CodecPackage/FormatMismatch.java .
      class  InvalidTypeForEncoding
      org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .

    • Uses of UserException in org.omg.PortableInterceptor

      Subclasses of UserException in org.omg.PortableInterceptor
      修饰符与类型 类与描述
      class  InvalidSlot
      org/omg/PortableInterceptor/InvalidSlot.java .

    • Uses of UserException in org.omg.PortableInterceptor.ORBInitInfoPackage

      Subclasses of UserException in org.omg.PortableInterceptor.ORBInitInfoPackage
      修饰符与类型 类与描述
      class  DuplicateName
      org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .

    • Uses of UserException in org.omg.PortableServer

      Subclasses of UserException in org.omg.PortableServer
      修饰符与类型 类与描述
      class  ForwardRequest
      org/omg/PortableServer/ForwardRequest.java .

    • Uses of UserException in org.omg.PortableServer.CurrentPackage

      Subclasses of UserException in org.omg.PortableServer.CurrentPackage
      修饰符与类型 类与描述
      class  NoContext
      org/omg/PortableServer/CurrentPackage/NoContext.java .

    • Uses of UserException in org.omg.PortableServer.POAManagerPackage

      Subclasses of UserException in org.omg.PortableServer.POAManagerPackage
      修饰符与类型 类与描述
      class  AdapterInactive
      org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

    • Uses of UserException in org.omg.PortableServer.POAPackage

      Subclasses of UserException in org.omg.PortableServer.POAPackage
      修饰符与类型 类与描述
      class  AdapterAlreadyExists
      org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
      class  AdapterNonExistent
      org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
      class  InvalidPolicy
      org/omg/PortableServer/POAPackage/InvalidPolicy.java .
      class  NoServant
      org/omg/PortableServer/POAPackage/NoServant.java .
      class  ObjectAlreadyActive
      org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
      class  ObjectNotActive
      org/omg/PortableServer/POAPackage/ObjectNotActive.java .
      class  ServantAlreadyActive
      org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
      class  ServantNotActive
      org/omg/PortableServer/POAPackage/ServantNotActive.java .
      class  WrongAdapter
      org/omg/PortableServer/POAPackage/WrongAdapter.java .
      class  WrongPolicy
      org/omg/PortableServer/POAPackage/WrongPolicy.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.UShortSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UShortSeqHelper

No usage of org.omg.CORBA.UShortSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sasd/a>akgggPgNN" "la


Uses of Class org.omg.CORBA.UShortSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.UShortSeqHolder

  • Packages that use UShortSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of UShortSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type UShortSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_ushort_array(UShortSeqHolder seq, int offset, int length)
      Reads array of IDL unsigned shorts from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Pm dbd>oaP"


Uses of Class org.omg.CORBA.ValueBaseHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ValueBaseHelper

No usage of org.omg.CORBA.ValueBaseHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

TtTT=== -===< s de<


Uses of Class org.omg.CORBA.ValueBaseHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ValueBaseHolder

No usage of org.omg.CORBA.ValueBaseHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>4屨>-tX蒆� � �


Uses of Class org.omg.CORBA.ValueMember

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ValueMember

  • Packages that use ValueMember
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of ValueMember in org.omg.CORBA

      Methods in org.omg.CORBA that return ValueMember
      修饰符与类型 | 方法与描述
      static ValueMember | ValueMemberHelper.extract(Any a)
      static ValueMember | ValueMemberHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type ValueMember
      修饰符与类型 | 方法与描述
      TypeCode ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
      Create a TypeCode object for an IDL value type.
      static void | ValueMemberHelper.insert(Any a, ValueMember that)
      static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t鵸go<-.<"t>>eo.gIL


Uses of Class org.omg.CORBA.ValueMemberHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ValueMemberHelper

No usage of org.omg.CORBA.ValueMemberHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.IhmaluBRAAA//""scao.


Uses of Class org.omg.CORBA.VersionSpecHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.VersionSpecHelper

No usage of org.omg.CORBA.VersionSpecHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hhH$


Uses of Class org.omg.CORBA.VisibilityHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.VisibilityHelper

No usage of org.omg.CORBA.VisibilityHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>oXt>H>lhH蟣h�


Uses of Class org.omg.CORBA.WCharSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WCharSeqHelper

No usage of org.omg.CORBA.WCharSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

llho>/>//l� >>y�/m


Uses of Class org.omg.CORBA.WCharSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WCharSeqHolder

  • Packages that use WCharSeqHolder
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of WCharSeqHolder in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type WCharSeqHolder
      修饰符与类型 方法与描述
      void DataInputStream.read_wchar_array(WCharSeqHolder seq, int offset, int length)
      Reads array of IDL wide characters from offset for length elements from the input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea=;/9r/caaCmjMhjar


Uses of Class org.omg.CORBA.WrongTransaction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WrongTransaction

  • Packages that use WrongTransaction
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of WrongTransaction in org.omg.CORBA

      Fields in org.omg.CORBA declared as WrongTransaction
      修饰符与类型 | 字段与描述
      WrongTransaction | WrongTransactionHolder.value
      Methods in org.omg.CORBA that return WrongTransaction
      修饰符与类型 | 方法与描述
      static WrongTransaction | WrongTransactionHelper.extract(Any a)
      static WrongTransaction | WrongTransactionHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type WrongTransaction
      修饰符与类型 | 方法与描述
      static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
      static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)
      Methods in org.omg.CORBA that throw WrongTransaction
      修饰符与类型 方法与描述
      abstract Request ORB.get_next_response()
      Gets the next Request instance for which a response has been received.
      abstract void Request.get_response()
      Allows the user to access the response for the invocation triggered earlier with the send_deferred method.
      Constructors in org.omg.CORBA with parameters of type WrongTransaction
      构造方法与描述
      WrongTransactionHolder(WrongTransaction initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ses/f�" >c<>>t;eAoaSh<2a


Uses of Class org.omg.CORBA.WrongTransactionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WrongTransactionHelper

No usage of org.omg.CORBA.WrongTransactionHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ieopsp;>"&&&Eapp"ocip


Uses of Class org.omg.CORBA.WrongTransactionHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WrongTransactionHolder

No usage of org.omg.CORBA.WrongTransactionHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/i}sQ�"r� a5o"


Uses of Class org.omg.CORBA.WStringSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WStringSeqHelper

No usage of org.omg.CORBA.WStringSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> sRo>T>g莞be3& a癰bs


Uses of Class org.omg.CORBA.WStringSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WStringSeqHolder

No usage of org.omg.CORBA.WStringSeqHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

wL>gf .�3s


Uses of Class org.omg.CORBA.WStringValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.WStringValueHelper

No usage of org.omg.CORBA.WStringValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=d" <>btM /le.m>/<.o<


Uses of Interface org.omg.CORBA.ARG_IN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.ARG_IN

No usage of org.omg.CORBA.ARG_IN
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Fr = ==< !!!i///ptm u


Uses of Interface org.omg.CORBA.ARG_INOUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.ARG_INOUT

No usage of org.omg.CORBA.ARG_INOUT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/laH>l/R Sa.舉


Uses of Interface org.omg.CORBA.ARG_OUT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.ARG_OUT

No usage of org.omg.CORBA.ARG_OUT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


Uses of Interface org.omg.CORBA.BAD_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.BAD_POLICY

No usage of org.omg.CORBA.BAD_POLICY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cAtnhtmA/nnnRg//pa= .


Uses of Interface org.omg.CORBA.BAD_POLICY_TYPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.BAD_POLICY_TYPE

No usage of org.omg.CORBA.BAD_POLICY_TYPE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.t_dc


Uses of Interface org.omg.CORBA.BAD_POLICY_VALUE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.BAD_POLICY_VALUE

No usage of org.omg.CORBA.BAD_POLICY_VALUE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t �rc�* )碼" @


Uses of Interface org.omg.CORBA.CTX_RESTRICT_SCOPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.CTX_RESTRICT_SCOPE

No usage of org.omg.CORBA.CTX_RESTRICT_SCOPE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rdetde>>"<<


Uses of Interface org.omg.CORBA.Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.Current

  • Packages that use Current
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Current in org.omg.CORBA

      Fields in org.omg.CORBA declared as Current
      修饰符与类型 | 字段与描述
      Current | CurrentHolder.value
      Methods in org.omg.CORBA that return Current
      修饰符与类型 | 方法与描述
      static Current | CurrentHelper.extract(Any a)
      Current ORB.get_current()
      Deprecated.
      use resolve_initial_references.
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type Current
      修饰符与类型 | 方法与描述
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      Constructors in org.omg.CORBA with parameters of type Current
      构造方法与描述
      CurrentHolder(Current initialValue)

    • Uses of Current in org.omg.PortableServer

      Subinterfaces of Current in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  Current
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> ebasvv>


Uses of Interface org.omg.CORBA.CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.CurrentOperations

  • Packages that use CurrentOperations
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CurrentOperations in org.omg.CORBA

      Subinterfaces of CurrentOperations in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.

    • Uses of CurrentOperations in org.omg.PortableServer

      Subinterfaces of CurrentOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  CurrentOperations
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>.Crm> o3


Uses of Interface org.omg.CORBA.CustomMarshal

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.CustomMarshal

  • Packages that use CustomMarshal
    软件包 描述
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of CustomMarshal in org.omg.CORBA.portable

      Subinterfaces of CustomMarshal in org.omg.CORBA.portable
      修饰符与类型 Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f<=<


Uses of Interface org.omg.CORBA.DataInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DataInputStream

  • Packages that use DataInputStream
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DataInputStream in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DataInputStream
      修饰符与类型 方法与描述
      void CustomMarshal.unmarshal(DataInputStream is)
      Unmarshal method has to be implemented by the Customized Marshal class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ob"oe-"bsrdd/.taal>/a nrh


Uses of Interface org.omg.CORBA.DataOutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DataOutputStream

  • Packages that use DataOutputStream
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DataOutputStream in org.omg.CORBA

      Methods in org.omg.CORBA with parameters of type DataOutputStream
      修饰符与类型 方法与描述
      void CustomMarshal.marshal(DataOutputStream os)
      Marshal method has to be implemented by the Customized Marshal class.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j躠�aF.郞c$包Dn杘b


Uses of Interface org.omg.CORBA.DomainManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DomainManager

  • Packages that use DomainManager
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of DomainManager in org.omg.CORBA

      Methods in org.omg.CORBA that return DomainManager
      修饰符与类型 方法与描述
      DomainManager[] LocalObject._get_domain_managers()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      DomainManager[] Object._get_domain_managers()
      Retrieves the DomainManagers of this object.

    • Uses of DomainManager in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return DomainManager
      修饰符与类型 方法与描述
      DomainManager[] ObjectImpl._get_domain_managers()
      Retrieves a list of the domain managers for this ObjectImpl object.
      DomainManager[] Delegate.get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ddoXio>oovRn< ic


Uses of Interface org.omg.CORBA.DomainManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DomainManagerOperations

  • Packages that use DomainManagerOperations
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DomainManagerOperations in org.omg.CORBA

      Subinterfaces of DomainManagerOperations in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tb_tDelballlo/..pgge/ee/


Uses of Interface org.omg.CORBA.DynAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynAny

  • Packages that use DynAny
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynAny in org.omg.CORBA

      Subinterfaces of DynAny in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  DynArray
      Deprecated.
      Use the new DynArray instead
      interface  DynEnum
      Deprecated.
      Use the new DynEnum instead
      interface  DynFixed
      Deprecated.
      Use the new DynFixed instead
      interface  DynSequence
      Deprecated.
      Use the new DynSequence instead
      interface  DynStruct
      Deprecated.
      Use the new DynStruct instead
      interface  DynUnion
      Deprecated.
      Use the new DynUnion instead
      interface  DynValue
      Deprecated.
      Use the new DynValue instead
      Methods in org.omg.CORBA that return DynAny
      修饰符与类型 方法与描述
      DynAny DynAny.copy()
      Deprecated.
      Clones this DynAny object.
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynAny ORB.create_dyn_any(Any value)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynAny DynAny.current_component()
      Deprecated.
      Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
      DynAny DynUnion.discriminator()
      Deprecated.
      Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
      DynAny DynUnion.member()
      Deprecated.
      Returns a DynAny object reference that is used in order to insert/get a member of this union.
      Methods in org.omg.CORBA with parameters of type DynAny
      修饰符与类型 方法与描述
      void DynAny.assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cnt<"p oBcjKKgsoais>>


Uses of Interface org.omg.CORBA.DynArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynArray

  • Packages that use DynArray
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynArray in org.omg.CORBA

      Methods in org.omg.CORBA that return DynArray
      修饰符与类型 方法与描述
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taam0" nigggp3eeeil"a>


Uses of Interface org.omg.CORBA.DynEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynEnum

  • Packages that use DynEnum
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynEnum in org.omg.CORBA

      Methods in org.omg.CORBA that return DynEnum
      修饰符与类型 方法与描述
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pp> byhyd


Uses of Interface org.omg.CORBA.DynFixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynFixed

No usage of org.omg.CORBA.DynFixed
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

- - >rnI/


Uses of Interface org.omg.CORBA.DynSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynSequence

  • Packages that use DynSequence
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynSequence in org.omg.CORBA

      Methods in org.omg.CORBA that return DynSequence
      修饰符与类型 方法与描述
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>caXo/Fnfieereiilpi醠


Uses of Interface org.omg.CORBA.DynStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynStruct

  • Packages that use DynStruct
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynStruct in org.omg.CORBA

      Methods in org.omg.CORBA that return DynStruct
      修饰符与类型 方法与描述
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

88>


Uses of Interface org.omg.CORBA.DynUnion

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynUnion

  • Packages that use DynUnion
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of DynUnion in org.omg.CORBA

      Methods in org.omg.CORBA that return DynUnion
      修饰符与类型 方法与描述
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pp> byhyd


Uses of Interface org.omg.CORBA.DynValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.DynValue

No usage of org.omg.CORBA.DynValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>< <


Uses of Interface org.omg.CORBA.IDLType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.IDLType

  • Packages that use IDLType
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IDLType in org.omg.CORBA

      Classes in org.omg.CORBA that implement IDLType
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
      Fields in org.omg.CORBA declared as IDLType
      修饰符与类型 字段与描述
      IDLType ValueMember.type_def
      The typedef that represents the IDL type of the value member described by this ValueMember object.
      IDLType UnionMember.type_def
      The typedef that represents the IDL type of the union member described by this UnionMember object.
      IDLType StructMember.type_def
      The typedef that represents the IDL type of the struct member described by this StructMember object.
      Methods in org.omg.CORBA that return IDLType
      修饰符与类型 | 方法与描述
      static IDLType | IDLTypeHelper.extract(Any a)
      static IDLType | IDLTypeHelper.narrow(Object obj)
      static IDLType | IDLTypeHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type IDLType
      修饰符与类型 | 方法与描述
      static void | IDLTypeHelper.insert(Any a, IDLType that)
      static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
      Constructors in org.omg.CORBA with parameters of type IDLType
      构造方法与描述
      StructMember(String __name, TypeCode __type, IDLType __type_def)
      Constructs a StructMember object initialized with the given values.
      UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
      Constructs a new UnionMember object with its fields initialized to the given values.
      ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
      Constructs a ValueMember object initialized with the given values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>g=ifasa=i tt_e..rs


Uses of Interface org.omg.CORBA.IDLTypeOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.IDLTypeOperations

  • Packages that use IDLTypeOperations
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IDLTypeOperations in org.omg.CORBA

      Subinterfaces of IDLTypeOperations in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      Classes in org.omg.CORBA that implement IDLTypeOperations
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/cA>b.rishsoa>>;cbl.t


Uses of Interface org.omg.CORBA.IRObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.IRObject

  • Packages that use IRObject
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IRObject in org.omg.CORBA

      Subinterfaces of IRObject in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      Classes in org.omg.CORBA that implement IRObject
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vl.eorit "e


Uses of Interface org.omg.CORBA.IRObjectOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.IRObjectOperations

  • Packages that use IRObjectOperations
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of IRObjectOperations in org.omg.CORBA

      Subinterfaces of IRObjectOperations in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IDLTypeOperations
      This interface must be implemented by all IDLType objects.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      Classes in org.omg.CORBA that implement IRObjectOperations
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nyye9sn=pne/. e/geoa >


Uses of Interface org.omg.CORBA.Object

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.Object

  • Packages that use Object
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of Object in javax.rmi.CORBA

      Classes in javax.rmi.CORBA that implement Object
      修饰符与类型 类与描述
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.
      Methods in javax.rmi.CORBA that return Object
      修饰符与类型 方法与描述
      Object Tie.thisObject()
      Returns an object reference for the target object represented by this tie.

    • Uses of Object in org.omg.CORBA

      Subinterfaces of Object in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
      interface  DynAny
      Deprecated.
      Use the new DynAny instead
      interface  DynArray
      Deprecated.
      Use the new DynArray instead
      interface  DynEnum
      Deprecated.
      Use the new DynEnum instead
      interface  DynFixed
      Deprecated.
      Use the new DynFixed instead
      interface  DynSequence
      Deprecated.
      Use the new DynSequence instead
      interface  DynStruct
      Deprecated.
      Use the new DynStruct instead
      interface  DynUnion
      Deprecated.
      Use the new DynUnion instead
      interface  DynValue
      Deprecated.
      Use the new DynValue instead
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement Object
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  DynamicImplementation
      Deprecated.
      org.omg.CORBA.DynamicImplementation
      class  LocalObject
      Used as a base class for implementation of a local IDL interface in the Java language mapping.
      Fields in org.omg.CORBA declared as Object
      修饰符与类型 字段与描述
      Object ObjectHolder.value
      The Object value held by this ObjectHolder object.
      Methods in org.omg.CORBA that return Object
      修饰符与类型 | 方法与描述
      Object LocalObject._duplicate()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object Object._duplicate()
      Returns a duplicate of this CORBA object reference.
      Object LocalObject._get_interface_def()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Object Object._get_interface_def()
      Obtains an InterfaceDef for the object implementation referenced by this object reference.
      Object LocalObject._get_interface()
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      abstract Object Any.extract_Object()
      Extracts the org.omg.CORBA.Object in this Any object's value field.
      static Object | ObjectHelper.extract(Any a)
      Object DynAny.get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      Object DataInputStream.read_Object()
      Reads an IDL CORBA::Object from the input stream.
      static Object | ObjectHelper.read(InputStream istream)
      abstract Object ORB.resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
      abstract Object ORB.string_to_object(String str)
      Converts a string produced by the method object_to_string back to a CORBA object reference.
      abstract Object Request.target()
      Retrieves the the target object reference.
      Methods in org.omg.CORBA with parameters of type Object
      修饰符与类型 | 方法与描述
      boolean LocalObject._is_equivalent(Object that)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      boolean Object._is_equivalent(Object other)
      Determines whether the two object references are equivalent, so far as the ORB can easily determine.
      void ORB.connect(Object obj)
      Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
      NVList ORB.create_operation_list(Object oper)
      Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
      void ORB.disconnect(Object obj)
      Disconnects the given servant object from the ORB.
      abstract void Any.insert_Object(Object o)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      abstract void Any.insert_Object(Object o, TypeCode t)
      Inserts the given org.omg.CORBA.Object object into this Any object's value field.
      void DynAny.insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      static void | ObjectHelper.insert(Any a, Object that)
      static Policy | PolicyHelper.narrow(Object obj)
      static IDLType | IDLTypeHelper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      abstract String ORB.object_to_string(Object obj)
      Converts the given CORBA object reference to a string.
      void DataOutputStream.write_Object(Object value)
      Writes the IDL CORBA::Object value to the output stream.
      static void | ObjectHelper.write(OutputStream ostream, Object value)
      Constructors in org.omg.CORBA with parameters of type Object
      构造方法与描述
      ObjectHolder(Object initial)
      Constructs a new ObjectHolder object with its value field initialized to the given Object.

    • Uses of Object in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that return Object
      修饰符与类型 | 方法与描述
      Object | ORB.get_value_def(String repid)

    • Uses of Object in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable with parameters of type Object
      修饰符与类型 方法与描述
      String Delegate.get_codebase(Object self)
      Returns the codebase for object reference provided.

    • Uses of Object in org.omg.CORBA.portable

      Classes in org.omg.CORBA.portable that implement Object
      修饰符与类型 类与描述
      class  ObjectImpl
      The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
      Methods in org.omg.CORBA.portable that return Object
      修饰符与类型 方法与描述
      Object ObjectImpl._duplicate()
      Returns a duplicate of this ObjectImpl object.
      Object ObjectImpl._get_interface_def()
      Retrieves the interface definition for this ObjectImpl object.
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      abstract Object Delegate.duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      abstract Object Delegate.get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      abstract Object InputStream.read_Object()
      Reads a CORBA object from this input stream.
      Object InputStream.read_Object(类 clz)
      Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      Methods in org.omg.CORBA.portable with parameters of type Object
      修饰符与类型 方法与描述
      boolean ObjectImpl._is_equivalent(Object that)
      Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Object Delegate.duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      boolean Delegate.equals(Object self, Object obj)
      Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
      DomainManager[] Delegate.get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
      abstract Object Delegate.get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      Policy Delegate.get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      abstract int Delegate.hash(Object obj, int max)
      Returns an ORB-internal identifier (hashcode) for this object reference.
      int Delegate.hashCode(Object self)
      Provides the implementation to override the hashCode() method of the delegating CORBA object.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      abstract boolean Delegate.is_a(Object obj, String repository_id)
      Checks if the object reference is an instance of the given interface.
      abstract boolean Delegate.is_equivalent(Object obj, Object other)
      Determines if the two object references are equivalent.
      boolean Delegate.is_local(Object self)
      Returns true if this object is implemented by a local servant.
      abstract boolean Delegate.non_existent(Object obj)
      Determines whether the server object for the object reference has been destroyed.
      ORB Delegate.orb(Object obj)
      Provides a reference to the orb associated with its parameter.
      abstract void Delegate.release(Object obj)
      Releases resources associated with the object reference provided.
      void Delegate.releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      abstract Request Delegate.request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      void Delegate.servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
      ServantObject Delegate.servant_preinvoke(Object self, String operation, 类 expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      String Delegate.toString(Object self)
      Provides the implementation to override the toString() method of the delegating CORBA object.
      abstract void OutputStream.write_Object(Object value)
      Writes a CORBA Object on this output stream.

    • Uses of Object in org.omg.CosNaming

      Subinterfaces of Object in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement Object
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      Methods in org.omg.CosNaming that return Object
      修饰符与类型 方法与描述
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Methods in org.omg.CosNaming with parameters of type Object
      修饰符与类型 | 方法与描述
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
      static NamingContext | NamingContextHelper.narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.narrow(Object obj)
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
      static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.DynamicAny

      Subinterfaces of Object in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement Object
      修饰符与类型 类与描述
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Methods in org.omg.DynamicAny that return Object
      修饰符与类型 方法与描述
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Methods in org.omg.DynamicAny with parameters of type Object
      修饰符与类型 | 方法与描述
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      static DynSequence | DynSequenceHelper.narrow(Object obj)
      static DynFixed | DynFixedHelper.narrow(Object obj)
      static DynEnum | DynEnumHelper.narrow(Object obj)
      static DynArray | DynArrayHelper.narrow(Object obj)
      static DynValue | DynValueHelper.narrow(Object obj)
      static DynAny | DynAnyHelper.narrow(Object obj)
      static DynUnion | DynUnionHelper.narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
      static DynStruct | DynStructHelper.narrow(Object obj)
      static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
      static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
      static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
      static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
      static DynValue | DynValueHelper.unchecked_narrow(Object obj)
      static DynAny | DynAnyHelper.unchecked_narrow(Object obj)
      static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
      static DynStruct | DynStructHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.IOP

      Subinterfaces of Object in org.omg.IOP
      修饰符与类型 Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
      Methods in org.omg.IOP with parameters of type Object
      修饰符与类型 | 方法与描述
      static CodecFactory | CodecFactoryHelper.narrow(Object obj)
      static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

    • Uses of Object in org.omg.PortableInterceptor

      Subinterfaces of Object in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      Fields in org.omg.PortableInterceptor declared as Object
      修饰符与类型 字段与描述
      Object ForwardRequest.forward
      The new object to forward the request to.
      Methods in org.omg.PortableInterceptor that return Object
      修饰符与类型 方法与描述
      Object ClientRequestInfoOperations.effective_target()
      Returns the actual object on which the operation will be invoked.
      Object RequestInfoOperations.forward_reference()
      Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
      Object ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id)
      make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
      Object ORBInitInfoOperations.resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.
      Object ClientRequestInfoOperations.target()
      Returns the object which the client called to perform the operation.
      Methods in org.omg.PortableInterceptor with parameters of type Object
      修饰符与类型 | 方法与描述
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      void ORBInitInfoOperations.register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)
      static Current | CurrentHelper.unchecked_narrow(Object obj)
      Constructors in org.omg.PortableInterceptor with parameters of type Object
      构造方法与描述
      ForwardRequest(Object _forward)
      ForwardRequest(String $reason, Object _forward)

    • Uses of Object in org.omg.PortableServer

      Subinterfaces of Object in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  POA
      A POA object manages the implementation of a collection of objects.
      interface  POAManager
      Each POA object has an associated POAManager object.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Classes in org.omg.PortableServer that implement Object
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Fields in org.omg.PortableServer declared as Object
      修饰符与类型 | 字段与描述
      Object | ForwardRequest.forward_reference
      Methods in org.omg.PortableServer that return Object
      修饰符与类型 方法与描述
      Object Servant._get_interface_def()
      Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
      Object Servant._this_object()
      Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
      Object Servant._this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
      Object POAOperations.create_reference_with_id(byte[] oid, String intf)
      This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
      Object POAOperations.create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      Methods in org.omg.PortableServer with parameters of type Object
      修饰符与类型 | 方法与描述
      static ServantLocator | ServantLocatorHelper.narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.narrow(Object obj)
      static POA | POAHelper.narrow(Object obj)
      static Current | CurrentHelper.narrow(Object obj)
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
      Constructors in org.omg.PortableServer with parameters of type Object
      构造方法与描述
      ForwardRequest(Object _forward_reference)
      ForwardRequest(String $reason, Object _forward_reference)

    • Uses of Object in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return Object
      修饰符与类型 方法与描述
      Object Delegate.get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      Object Delegate.this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

    • Uses of Object in org.omg.SendingContext

      Subinterfaces of Object in org.omg.SendingContext
      修饰符与类型 Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.

    • Uses of Object in org.omg.stub.java.rmi

      Classes in org.omg.stub.java.rmi that implement Object
      修饰符与类型 类与描述
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.CORBA.OMGVMCID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.OMGVMCID

No usage of org.omg.CORBA.OMGVMCID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< ><<


Uses of Interface org.omg.CORBA.Policy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.Policy

  • Packages that use Policy
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Policy in org.omg.CORBA

      Classes in org.omg.CORBA that implement Policy
      修饰符与类型 类与描述
      class  _PolicyStub
      The Stub for Policy.
      Fields in org.omg.CORBA declared as Policy
      修饰符与类型 | 字段与描述
      Policy[] | PolicyListHolder.value
      Policy | PolicyHolder.value
      Methods in org.omg.CORBA that return Policy
      修饰符与类型 | 方法与描述
      Policy LocalObject._get_policy(int policy_type)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Policy Object._get_policy(int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      Policy _PolicyStub.copy()
      Copies the policy object.
      Policy PolicyOperations.copy()
      Returns a copy of the Policy object.
      Policy ORB.create_policy(int type, Any val)
      Can be invoked to create new instances of policy objects of a specific type with specified initial state.
      static Policy[] | PolicyListHelper.extract(Any a)
      static Policy | PolicyHelper.extract(Any a)
      Policy DomainManagerOperations.get_domain_policy(int policy_type)
      This returns the policy of the specified type for objects in this domain.
      static Policy | PolicyHelper.narrow(Object obj)
      static Policy[] | PolicyListHelper.read(InputStream istream)
      static Policy | PolicyHelper.read(InputStream istream)
      Methods in org.omg.CORBA with parameters of type Policy
      修饰符与类型 | 方法与描述
      Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
      Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
      static void | PolicyHelper.insert(Any a, Policy that)
      static void | PolicyListHelper.insert(Any a, Policy[] that)
      static void | PolicyHelper.write(OutputStream ostream, Policy value)
      static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
      Constructors in org.omg.CORBA with parameters of type Policy
      构造方法与描述
      PolicyHolder(Policy initialValue)
      PolicyListHolder(Policy[] initialValue)

    • Uses of Policy in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Policy
      修饰符与类型 方法与描述
      Policy ObjectImpl._get_policy(int policy_type)
      Retrieves the Policy object for this ObjectImpl object that has the given policy type.
      Policy Delegate.get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      Methods in org.omg.CORBA.portable with parameters of type Policy
      修饰符与类型 方法与描述
      Object ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.

    • Uses of Policy in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Policy
      修饰符与类型 方法与描述
      Policy PolicyFactoryOperations.create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
      Policy IORInfoOperations.get_effective_policy(int type)
      Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
      Policy ClientRequestInfoOperations.get_request_policy(int type)
      Returns the given policy in effect for this operation.
      Policy ServerRequestInfoOperations.get_server_policy(int type)
      Returns the policy in effect for this operation for the given policy type.

    • Uses of Policy in org.omg.PortableServer

      Subinterfaces of Policy in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Methods in org.omg.PortableServer with parameters of type Policy
      修饰符与类型 方法与描述
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.CORBA.PolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.PolicyOperations

  • Packages that use PolicyOperations
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of PolicyOperations in org.omg.CORBA

      Subinterfaces of PolicyOperations in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement PolicyOperations
      修饰符与类型 类与描述
      class  _PolicyStub
      The Stub for Policy.

    • Uses of PolicyOperations in org.omg.PortableServer

      Subinterfaces of PolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdAssignmentPolicyOperations
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  IdUniquenessPolicyOperations
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  ImplicitActivationPolicyOperations
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  LifespanPolicyOperations
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  RequestProcessingPolicyOperations
      This policy specifies how requests are processed by the created POA.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ServantRetentionPolicyOperations
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      interface  ThreadPolicyOperations
      The ThreadPolicy specifies the threading model used with the created POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pog/o>/n


Uses of Interface org.omg.CORBA.PRIVATE_MEMBER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.PRIVATE_MEMBER

No usage of org.omg.CORBA.PRIVATE_MEMBER
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!8 w(i cfy.b�


Uses of Interface org.omg.CORBA.PUBLIC_MEMBER

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.PUBLIC_MEMBER

No usage of org.omg.CORBA.PUBLIC_MEMBER
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>�!t>w>l8wi C f


Uses of Interface org.omg.CORBA.UNSUPPORTED_POLICY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.UNSUPPORTED_POLICY

No usage of org.omg.CORBA.UNSUPPORTED_POLICY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ss;FgRnRD竛p-


Uses of Interface org.omg.CORBA.UNSUPPORTED_POLICY_VALUE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.UNSUPPORTED_POLICY_VALUE

No usage of org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lorn�$i .=i渟鴒T


Uses of Interface org.omg.CORBA.VM_ABSTRACT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.VM_ABSTRACT

No usage of org.omg.CORBA.VM_ABSTRACT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/o/a> >lp b>t/by


Uses of Interface org.omg.CORBA.VM_CUSTOM

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.VM_CUSTOM

No usage of org.omg.CORBA.VM_CUSTOM
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< ot>


Uses of Interface org.omg.CORBA.VM_NONE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.VM_NONE

No usage of org.omg.CORBA.VM_NONE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<)my


Uses of Interface org.omg.CORBA.VM_TRUNCATABLE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.VM_TRUNCATABLE

No usage of org.omg.CORBA.VM_TRUNCATABLE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

纄１r�


IDL-to-Java Generated Files

The files that are generated by the IDL-to-Java compiler, in accordance with the IDL-to-Java Language Mapping Specification, which is implemented in JavaTM SE 6 according the compliance document.

In general IDL names and identifiers are mapped to Java names and identifiers with no change. Because of the nature of the Java language, a single IDL construct may be mapped to several (differently named) Java constructs. The additional names are constructed by appending a descriptive suffix. For example, the IDL interface foo is mapped to the Java interfaces foo and fooOperations, and additional Java classes fooHelper, fooHolder, fooPOA, and optionally fooPOATie.

The mapping in effect reserves the use of several names for its own purposes. These are:

  • The Java class <type>Helper, where <type> is the name of an IDL defined type.
  • The Java class <type>Holder, where <type> is the name of an IDL defined type (with certain exceptions such as typedef aliases).
  • The Java classes <basicJavaType>Holder, where <basicJavaType> is one of the Java primitive datatypes that is used by one of the IDL basic datatypes.
  • The Java classes <interface>Operations, <interface>POA, and <interface>POATie, where <interface> is the name of an IDL interface type.
  • The nested scope Java package name <interface>Package, where <interface> is the name of an IDL interface.

    Helper Files

    Helper files supply several static methods needed to manipulate the type. These include Any insert and extract operations for the type, getting the repository id, getting the typecode, and reading and writing the type from and to a stream.

    The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA::BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null.

    Holder Files

    Support for out and inout parameter passing modes requires the use of additional holder classes. These classes are available for all of the basic IDL datatypes in the org.omg.CORBA package and are generated for all named user defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

    Each holder class has a constructor from an instance, a default constructor, and has a public instance member, value which is the typed value. The default constructor sets the value field to the default value for the type as defined by the Java language: false for boolean, 0 for numeric and char types, null for strings, null for object references.

    To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

    Operations Files

    A non abstract IDL interface is mapped to two public Java interfaces: a signature interface and an operations interface. The signature interface, which extends IDLEntity, has the same name as the IDL interface name and is used as the signature type in method declarations when interfaces of the specified type are used in other interfaces. The operations interface has the same name as the IDL interface with the suffix Operations appended to the end and is used in the server-side mapping and as a mechanism for providing optimized calls for collocated client and servers.

    The Java operations interface contains the mapped operation signatures. The Java signature interface extends the operations interface, the (mapped) base org.omg.CORBA.Object, as well as org.omg.portable.IDLEntity. Methods can be invoked on the signature interface. Interface inheritance expressed in IDL is reflected in both the Java signature interface and operations interface hierarchies.

    Stubs

    For the mapping of a non-object-oriented language, there will be a programming interface to the stubs for each interface type. Generally, the stubs will present access to the OMG IDL-defined operations on an object in a way that is easy for programmers to predict once they are familiar with OMG IDL and the language mapping for the particular programming language. The stubs make calls on the rest of the ORB using interfaces that are private to, and presumably optimized for, the particular ORB Core. If more than one ORB is available, there may be different stubs corresponding to the different ORBs. In this case, it is necessary for the ORB and language mapping to cooperate to associate the correct stubs with the particular object reference.

    Object-oriented programming languages, such as Java, C++, and Smalltalk, do not require stub interfaces.


Official Specifications for CORBA support in Java[tm] SE 6

Specification References

The specifications with which the Java[tm] Platform, Standard Edition (Java SE) v.1.6.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-03-04)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in Java[tm] SE 6. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The Java SE 6 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.


Invalid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.DynAnyPackage

类 Invalid

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.Invalid
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Invalid
extends UserException
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Invalid()
      Constructs an Invalid object.
      Invalid(String reason)
      Constructs an Invalid object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Invalid

        public Invalid()
        Constructs an Invalid object.

      • Invalid

        public Invalid(String reason)
        Constructs an Invalid object.
        参数：
        reason - a String giving more information regarding the bad parameter passed to a dynamic any operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eaadvcal c>n aewa


InvalidSeq

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.DynAnyPackage

类 InvalidSeq

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidSeq
extends UserException
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidSeq()
      Constructs an InvalidSeq object.
      InvalidSeq(String reason)
      Constructs an InvalidSeq object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidSeq

        public InvalidSeq()
        Constructs an InvalidSeq object.

      • InvalidSeq

        public InvalidSeq(String reason)
        Constructs an InvalidSeq object.
        参数：
        reason - a String giving more information regarding the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>leiagc..- c2ni>ialtLe c.


InvalidValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.DynAnyPackage

类 InvalidValue

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.InvalidValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidValue
extends UserException

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidValue()
      Constructs an InvalidValue object.
      InvalidValue(String reason)
      Constructs an InvalidValue object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidValue

        public InvalidValue()
        Constructs an InvalidValue object.

      • InvalidValue

        public InvalidValue(String reason)
        Constructs an InvalidValue object.
        参数：
        reason - a String giving more information regarding the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>崞l芶扑瓢撩嘶保俞>变了所鹢〃］//


org.omg.CORBA.DynAnyPackage

Exceptions

  • Invalid
  • InvalidSeq
  • InvalidValue
  • TypeMismatch
n


org.omg.CORBA.DynAnyPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA.DynAnyPackage

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).

请参见： 描述

  • Exception Summary
    Exception 描述
    Invalid
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
    InvalidSeq
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
    InvalidValue
    TypeMismatch
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

软件包 org.omg.CORBA.DynAnyPackage Description

Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
从以下版本开始：
JDK1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a\/e.=h".h s""hlss


org.omg.CORBA.DynAnyPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA.DynAnyPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rt ATTMNBMO==- /p


TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.DynAnyPackage

类 TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeMismatch()
      Constructs a TypeMismatch object.
      TypeMismatch(String reason)
      Constructs a TypeMismatch object.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TypeMismatch

        public TypeMismatch()
        Constructs a TypeMismatch object.

      • TypeMismatch

        public TypeMismatch(String reason)
        Constructs a TypeMismatch object.
        参数：
        reason - a String giving more information regarding the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-e"f3a3e39A01"be"


Uses of Package org.omg.CORBA.DynAnyPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA.DynAnyPackage

  • Packages that use org.omg.CORBA.DynAnyPackage
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.DynAnyPackage used by org.omg.CORBA
    类与描述
    Invalid
    Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
    InvalidSeq
    The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
    InvalidValue
    TypeMismatch
    TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dehad=d seihi".鼙５�


Uses of Class org.omg.CORBA.DynAnyPackage.Invalid

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DynAnyPackage.Invalid

  • Packages that use Invalid
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Invalid in org.omg.CORBA

      Methods in org.omg.CORBA that throw Invalid
      修饰符与类型 方法与描述
      void DynAny.assign(DynAny dyn_any)
      Deprecated.
      Copy the contents from one Dynamic Any into another.
      void DynAny.from_any(Any value)
      Deprecated.
      Make a DynAny object from an Any object.
      Any DynAny.to_any()
      Deprecated.
      Convert a DynAny object to an Any object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/m" a"


Uses of Class org.omg.CORBA.DynAnyPackage.InvalidSeq

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DynAnyPackage.InvalidSeq

  • Packages that use InvalidSeq
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidSeq in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidSeq
      修饰符与类型 方法与描述
      void DynArray.set_elements(Any[] value)
      Deprecated.
      Sets the value of this DynArray object to the given array.
      void DynSequence.set_elements(Any[] value)
      Deprecated.
      Sets the values of all elements in this sequence with the given array.
      void DynValue.set_members(NameValuePair[] value)
      Deprecated.
      Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.
      void DynStruct.set_members(NameValuePair[] value)
      Deprecated.
      Set the members of the struct.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>d >Jotsnie/edbe".s


Uses of Class org.omg.CORBA.DynAnyPackage.InvalidValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DynAnyPackage.InvalidValue

  • Packages that use InvalidValue
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidValue in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidValue
      修饰符与类型 方法与描述
      void DynAny.insert_any(Any value)
      Deprecated.
      Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
      void DynAny.insert_boolean(boolean value)
      Deprecated.
      Inserts the given boolean as the value for this DynAny object.
      void DynAny.insert_char(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void DynAny.insert_double(double value)
      Deprecated.
      Inserts the given double as the value for this DynAny object.
      void DynAny.insert_float(float value)
      Deprecated.
      Inserts the given float as the value for this DynAny object.
      void DynAny.insert_long(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void DynAny.insert_longlong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void DynAny.insert_octet(byte value)
      Deprecated.
      Inserts the given byte as the value for this DynAny object.
      void DynAny.insert_reference(Object value)
      Deprecated.
      Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
      void DynAny.insert_short(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void DynAny.insert_string(String value)
      Deprecated.
      Inserts the given String object as the value for this DynAny object.
      void DynAny.insert_typecode(TypeCode value)
      Deprecated.
      Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
      void DynAny.insert_ulong(int value)
      Deprecated.
      Inserts the given int as the value for this DynAny object.
      void DynAny.insert_ulonglong(long value)
      Deprecated.
      Inserts the given long as the value for this DynAny object.
      void DynAny.insert_ushort(short value)
      Deprecated.
      Inserts the given short as the value for this DynAny object.
      void DynAny.insert_val(Serializable value)
      Deprecated.
      Inserts the given java.io.Serializable object as the value for this DynAny object.
      void DynAny.insert_wchar(char value)
      Deprecated.
      Inserts the given char as the value for this DynAny object.
      void DynAny.insert_wstring(String value)
      Deprecated.
      Inserts the given String as the value for this DynAny object.
      void DynFixed.set_value(byte[] val)
      Deprecated.
      Sets the given fixed type instance as the value for this DynFixed object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c/or/ sg"/<>w li/a


Uses of Class org.omg.CORBA.DynAnyPackage.TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.DynAnyPackage.TypeMismatch

  • Packages that use TypeMismatch
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of TypeMismatch in org.omg.CORBA

      Methods in org.omg.CORBA that throw TypeMismatch
      修饰符与类型 方法与描述
      Any DynAny.get_any()
      Deprecated.
      Retrieves the org.omg.CORBA.Any contained in this DynAny object.
      boolean DynAny.get_boolean()
      Deprecated.
      Retrieves the boolean contained in this DynAny object.
      char DynAny.get_char()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      double DynAny.get_double()
      Deprecated.
      Retrieves the double contained in this DynAny object.
      float DynAny.get_float()
      Deprecated.
      Retrieves the float contained in this DynAny object.
      int DynAny.get_long()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long DynAny.get_longlong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      byte DynAny.get_octet()
      Deprecated.
      Retrieves the byte contained in this DynAny object.
      Object DynAny.get_reference()
      Deprecated.
      Retrieves the org.omg.CORBA.Other contained in this DynAny object.
      short DynAny.get_short()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      String DynAny.get_string()
      Deprecated.
      Retrieves the String contained in this DynAny object.
      TypeCode DynAny.get_typecode()
      Deprecated.
      Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.
      int DynAny.get_ulong()
      Deprecated.
      Retrieves the int contained in this DynAny object.
      long DynAny.get_ulonglong()
      Deprecated.
      Retrieves the long contained in this DynAny object.
      short DynAny.get_ushort()
      Deprecated.
      Retrieves the short contained in this DynAny object.
      Serializable DynAny.get_val()
      Deprecated.
      Retrieves the java.io.Serializable object contained in this DynAny object.
      char DynAny.get_wchar()
      Deprecated.
      Retrieves the char contained in this DynAny object.
      String DynAny.get_wstring()
      Deprecated.
      Retrieves the String contained in this DynAny object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v>Lsll"lcs=as >>>>>eo苘og


InconsistentTypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.ORBPackage

类 InconsistentTypeCode

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InconsistentTypeCode
extends UserException
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.

    • 构造方法摘要

      Constructors
      构造方法与描述
      InconsistentTypeCode()
      Constructs an InconsistentTypeCode user exception with no reason message.
      InconsistentTypeCode(String reason)
      Constructs an InconsistentTypeCode user exception with the specified reason message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InconsistentTypeCode

        public InconsistentTypeCode()
        Constructs an InconsistentTypeCode user exception with no reason message.

      • InconsistentTypeCode

        public InconsistentTypeCode(String reason)
        Constructs an InconsistentTypeCode user exception with the specified reason message.
        参数：
        reason - The String containing a reason message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.nagH .>ti -ac_ r


InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.ORBPackage

类 InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.ORBPackage.InvalidName
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
    从以下版本开始：
    JDK1.2
    另请参见：
    ORB.resolve_initial_references(String)

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidName()
      Constructs an InvalidName exception with no reason message.
      InvalidName(String reason)
      Constructs an InvalidName exception with the specified reason message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidName

        public InvalidName()
        Constructs an InvalidName exception with no reason message.

      • InvalidName

        public InvalidName(String reason)
        Constructs an InvalidName exception with the specified reason message.
        参数：
        reason - the String containing a reason message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..dn琣� .t--�>ri�? 蛗p


org.omg.CORBA.ORBPackage

Exceptions

  • InconsistentTypeCode
  • InvalidName
�


org.omg.CORBA.ORBPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA.ORBPackage

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

请参见： 描述

  • Exception Summary
    Exception 描述
    InconsistentTypeCode
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
    InvalidName
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

软件包 org.omg.CORBA.ORBPackage Description

Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.

Related Documentation

For an overview, please see:
  • comments on the CORBA package
从以下版本开始：
JDK1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.oewa//l/.l///.<


org.omg.CORBA.ORBPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA.ORBPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.CORBA.ORBPackage.InvalidName
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lrC t ) a = tsaala


Uses of Package org.omg.CORBA.ORBPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA.ORBPackage

  • Packages that use org.omg.CORBA.ORBPackage
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.ORBPackage used by org.omg.CORBA
    类与描述
    InconsistentTypeCode
    InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
    InvalidName
    The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taomeruree es�"pUspnoR


Uses of Class org.omg.CORBA.ORBPackage.InconsistentTypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ORBPackage.InconsistentTypeCode

  • Packages that use InconsistentTypeCode
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InconsistentTypeCode in org.omg.CORBA

      Methods in org.omg.CORBA that throw InconsistentTypeCode
      修饰符与类型 方法与描述
      DynAny ORB.create_basic_dyn_any(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynArray ORB.create_dyn_array(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynEnum ORB.create_dyn_enum(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynSequence ORB.create_dyn_sequence(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynStruct ORB.create_dyn_struct(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
      DynUnion ORB.create_dyn_union(TypeCode type)
      Deprecated.
      Use the new DynAnyFactory API instead
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

j _(ae/


Uses of Class org.omg.CORBA.ORBPackage.InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.ORBPackage.InvalidName

  • Packages that use InvalidName
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of InvalidName in org.omg.CORBA

      Methods in org.omg.CORBA that throw InvalidName
      修饰符与类型 方法与描述
      abstract Object ORB.resolve_initial_references(String object_name)
      Resolves a specific object reference from the set of available initial service names.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ge"apan"t>>>La<


ApplicationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA.portable

类 ApplicationException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.portable.ApplicationException
  • 所有已实现的接口：
    Serializable

    public class ApplicationException
extends Exception
    This class is used for reporting application level exceptions between ORBs and stubs.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ApplicationException(String id, InputStream ins)
      Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getId()
      Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.
      InputStream getInputStream()
      Returns the input stream from which the exception data can be read as its parameters.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ApplicationException

        public ApplicationException(String id,
                    InputStream ins)
        Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.
        参数：
        id - the repository id of the user exception
        ins - the stream which contains the user exception data

    • 方法详细信息

      • getId

        public String getId()
        Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.
        返回：
        The CORBA repository ID of this exception

      • getInputStream

        public InputStream getInputStream()
        Returns the input stream from which the exception data can be read as its parameters.
        返回：
        The stream which contains the user exception data
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r_n&.<(d 虽�>tok;�


BoxedValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface BoxedValueHelper

  • All Known Implementing Classes:
    StringValueHelper, WStringValueHelper

    public interface BoxedValueHelper

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String get_id()
      Serializable | read_value(InputStream is)
      void | write_value(OutputStream os, Serializable value)

    • 方法详细信息

      • read_value

        Serializable read_value(InputStream is)

      • write_value

        void write_value(OutputStream os,
               Serializable value)

      • get_id

        String get_id()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>c&t"Ia>IatbtrttAoll f/pm."


CustomValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface CustomValue

  • All Superinterfaces:
    CustomMarshal, IDLEntity, Serializable, ValueBase

    public interface CustomValue
extends ValueBase, CustomMarshal
    An extension of ValueBase that is implemented by custom value types.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids

      • 方法 - 继承于接口 org.omg.CORBA.CustomMarshal

        marshal, unmarshal
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e tetttctnrafrr""oo敢ps>l�.


Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA.portable

类 Delegate

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
  • 直接已知子类：
    Delegate

    public abstract class Delegate
extends Object
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods. Each stub (proxy) contains a delegate object, to which all org.omg.CORBA.Object methods are forwarded. This allows a stub generated by one vendor's ORB to work with the delegate from another vendor's ORB.
    另请参见：
    Object

    • 构造方法摘要

      Constructors
      构造方法与描述
      Delegate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      abstract Object duplicate(Object obj)
      Returns a duplicate of the object reference provided.
      boolean equals(Object self, Object obj)
      Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
      DomainManager[] get_domain_managers(Object self)
      Retrieves the DomainManagers of this object.
      abstract Object get_interface_def(Object self)
      Return an InterfaceDef for the object reference provided.
      Policy get_policy(Object self, int policy_type)
      Returns the Policy object of the specified type which applies to this object.
      abstract int hash(Object obj, int max)
      Returns an ORB-internal identifier (hashcode) for this object reference.
      int hashCode(Object self)
      Provides the implementation to override the hashCode() method of the delegating CORBA object.
      InputStream invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      abstract boolean is_a(Object obj, String repository_id)
      Checks if the object reference is an instance of the given interface.
      abstract boolean is_equivalent(Object obj, Object other)
      Determines if the two object references are equivalent.
      boolean is_local(Object self)
      Returns true if this object is implemented by a local servant.
      abstract boolean non_existent(Object obj)
      Determines whether the server object for the object reference has been destroyed.
      ORB orb(Object obj)
      Provides a reference to the orb associated with its parameter.
      abstract void release(Object obj)
      Releases resources associated with the object reference provided.
      void releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      abstract Request request(Object obj, String operation)
      Creates a Request instance for use in the Dynamic Invocation Interface.
      OutputStream request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      void servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
      ServantObject servant_preinvoke(Object self, String operation, 类 expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Object set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
      Associates the policies passed in with a newly created object reference that it returns.
      String toString(Object self)
      Provides the implementation to override the toString() method of the delegating CORBA object.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Delegate

        public Delegate()

    • 方法详细信息

      • get_interface_def

        public abstract Object get_interface_def(Object self)
        Return an InterfaceDef for the object reference provided.
        参数：
        self - The object reference whose InterfaceDef needs to be returned
        返回：
        the InterfaceDef

      • duplicate

        public abstract Object duplicate(Object obj)
        Returns a duplicate of the object reference provided.
        参数：
        obj - The object reference whose duplicate needs to be returned
        返回：
        the duplicate object reference

      • release

        public abstract void release(Object obj)
        Releases resources associated with the object reference provided.
        参数：
        obj - The object reference whose resources need to be released

      • is_a

        public abstract boolean is_a(Object obj,
           String repository_id)
        Checks if the object reference is an instance of the given interface.
        参数：
        obj - The object reference to be checked.
        repository_id - The repository identifier of the interface to check against.
        返回：
        true if the object reference supports the interface

      • non_existent

        public abstract boolean non_existent(Object obj)
        Determines whether the server object for the object reference has been destroyed.
        参数：
        obj - The object reference which delegated to this delegate.
        返回：
        true if the ORB knows authoritatively that the server object does not exist, false otherwise

      • is_equivalent

        public abstract boolean is_equivalent(Object obj,
                    Object other)
        Determines if the two object references are equivalent.
        参数：
        obj - The object reference which delegated to this delegate.
        other - The object reference to check equivalence against.
        返回：
        true if the objects are CORBA-equivalent.

      • hash

        public abstract int hash(Object obj,
       int max)
        Returns an ORB-internal identifier (hashcode) for this object reference.
        参数：
        obj - The object reference which delegated to this delegate.
        max - specifies an upper bound on the hash value returned by the ORB.
        返回：
        ORB-internal hash identifier for object reference

      • request

        public abstract Request request(Object obj,
              String operation)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        参数：
        obj - The object reference which delegated to this delegate.
        operation - The name of the operation to be invoked using the Request instance.
        返回：
        the created Request instance

      • create_request

        public abstract Request create_request(Object obj,
                     Context ctx,
                     String operation,
                     NVList arg_list,
                     NamedValue result)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        参数：
        obj - The object reference which delegated to this delegate.
        ctx - The context to be used.
        operation - The name of the operation to be invoked.
        arg_list - The arguments to the operation in the form of an NVList.
        result - A container for the result as a NamedValue.
        返回：
        The created Request object.

      • create_request

        public abstract Request create_request(Object obj,
                     Context ctx,
                     String operation,
                     NVList arg_list,
                     NamedValue result,
                     ExceptionList exclist,
                     ContextList ctxlist)
        Creates a Request instance for use in the Dynamic Invocation Interface.
        参数：
        obj - The object reference which delegated to this delegate.
        ctx - The context to be used.
        operation - The name of the operation to be invoked.
        arg_list - The arguments to the operation in the form of an NVList.
        result - A container for the result as a NamedValue.
        exclist - A list of possible exceptions the operation can throw.
        ctxlist - A list of context strings that need to be resolved and sent with the Request.
        返回：
        The created Request object.

      • orb

        public ORB orb(Object obj)
        Provides a reference to the orb associated with its parameter.
        参数：
        obj - the object reference which delegated to this delegate.
        返回：
        the associated orb.
        另请参见：
        portable package comments for unimplemented features

      • get_policy

        public Policy get_policy(Object self,
                int policy_type)
        Returns the Policy object of the specified type which applies to this object.
        参数：
        self - The object reference which delegated to this delegate.
        policy_type - The type of policy to be obtained.
        返回：
        A Policy object of the type specified by the policy_type parameter.
        抛出：
        BAD_PARAM - raised when the value of policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object.
        另请参见：
        portable package comments for unimplemented features

      • get_domain_managers

        public DomainManager[] get_domain_managers(Object self)
        Retrieves the DomainManagers of this object. This allows administration services (and applications) to retrieve the domain managers, and hence the security and other policies applicable to individual objects that are members of the domain.
        参数：
        self - The object reference which delegated to this delegate.
        返回：
        The list of immediately enclosing domain managers of this object. At least one domain manager is always returned in the list since by default each object is associated with at least one domain manager at creation.
        另请参见：
        portable package comments for unimplemented features

      • set_policy_override

        public Object set_policy_override(Object self,
                         Policy[] policies,
                         SetOverrideType set_add)
        Associates the policies passed in with a newly created object reference that it returns. Only certain policies that pertain to the invocation of an operation at the client end can be overridden using this operation. Attempts to override any other policy will result in the raising of the CORBA::NO_PERMISSION exception.
        参数：
        self - The object reference which delegated to this delegate.
        policies - A sequence of references to Policy objects.
        set_add - Indicates whether these policies should be added onto any otheroverrides that already exist (ADD_OVERRIDE) in the object reference, or they should be added to a clean override free object reference (SET_OVERRIDE).
        返回：
        A new object reference with the new policies associated with it.
        另请参见：
        portable package comments for unimplemented features

      • is_local

        public boolean is_local(Object self)
        Returns true if this object is implemented by a local servant.
        参数：
        self - The object reference which delegated to this delegate.
        返回：
        true only if the servant incarnating this object is located in this Java VM. Return false if the servant is not local or the ORB does not support local stubs for this particular servant. The default behavior of is_local() is to return false.

      • servant_preinvoke

        public ServantObject servant_preinvoke(Object self,
                              String operation,
                              类 expectedType)
        Returns a Java reference to the servant which should be used for this request. servant_preinvoke() is invoked by a local stub. If a ServantObject object is returned, then its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation, and cannot be used for more than one invocation.
        参数：
        self - The object reference which delegated to this delegate.
        operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
        expectedType - a Class object representing the expected type of the servant. The expected type is the Class object associated with the operations class of the stub's interface (e.g. A stub for an interface Foo, would pass the Class object for the FooOperations interface).
        返回：
        a ServantObject object. The method may return a null value if it does not wish to support this optimization (e.g. due to security, transactions, etc). The method must return null if the servant is not of the expected type.

      • servant_postinvoke

        public void servant_postinvoke(Object self,
                      ServantObject servant)
        servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant. This method must be called if servant_preinvoke() returned a non-null value, even if an exception was thrown by the servant's method. For this reason, the call to servant_postinvoke() should be placed in a Java finally clause.
        参数：
        self - The object reference which delegated to this delegate.
        servant - the instance of the ServantObject returned from the servant_preinvoke() method.

      • request

        public OutputStream request(Object self,
                   String operation,
                   boolean responseExpected)
        request is called by a stub to obtain an OutputStream for marshaling arguments. The stub must supply the operation name, and indicate if a response is expected (i.e is this a oneway call).
        参数：
        self - The object reference which delegated to this delegate.
        operation - a string containing the operation name. The operation name corresponds to the operation name as it would be encoded in a GIOP request.
        responseExpected - false if the operation is a one way operation, and true otherwise.
        返回：
        OutputStream the OutputStream into which request arguments can be marshaled.
        另请参见：
        portable package comments for unimplemented features

      • invoke

        public InputStream invoke(Object self,
                 OutputStream output)
                   throws ApplicationException,
                          RemarshalException
        invoke is called by a stub to invoke an operation. The stub provides an OutputStream that was previously returned by a request() call. invoke returns an InputStream which contains the marshaled reply. If an exception occurs, invoke may throw an ApplicationException object which contains an InputStream from which the user exception state may be unmarshaled.
        参数：
        self - The object reference which delegated to this delegate.
        output - the OutputStream which contains marshaled arguments
        返回：
        input the InputStream from which reply parameters can be unmarshaled.
        抛出：
        ApplicationException - thrown when implementation throws (upon invocation) an exception defined as part of its remote method definition.
        RemarshalException - thrown when remarshalling fails.
        另请参见：
        portable package comments for unimplemented features

      • releaseReply

        public void releaseReply(Object self,
                InputStream input)
        releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed. The stub passes the InputStream returned by invoke() or ApplicationException.getInputStream(). A null value may also be passed to releaseReply, in which case the method is a noop.
        参数：
        self - The object reference which delegated to this delegate.
        input - the InputStream returned from invoke().
        另请参见：
        portable package comments for unimplemented features

      • toString

        public String toString(Object self)
        Provides the implementation to override the toString() method of the delegating CORBA object.
        参数：
        self - the object reference that delegated to this delegate
        返回：
        a String object that represents the object reference that delegated to this Delegate object

      • hashCode

        public int hashCode(Object self)
        Provides the implementation to override the hashCode() method of the delegating CORBA object.
        参数：
        self - the object reference that delegated to this delegate
        返回：
        an int that represents the hashcode for the object reference that delegated to this Delegate object

      • equals

        public boolean equals(Object self,
             Object obj)
        Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
        参数：
        self - the object reference that delegated to this delegate
        obj - the Object with which to compare
        返回：
        true if obj equals self; false otherwise
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


IDLEntity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface IDLEntity

  • All Superinterfaces:
    Serializable
    All Known Subinterfaces:
    AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, CustomValue, DataInputStream, DataOutputStream, DomainManager, DynAny, DynAnyFactory, DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ObjectReferenceFactory, ObjectReferenceTemplate, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, StreamableValue, ThreadPolicy, ValueBase
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, Any, BadKind, Binding, BindingType, Bounds, Bounds, CannotProceed, CompletionStatus, DefinitionKind, DuplicateName, Encoding, FormatMismatch, ForwardRequest, ForwardRequest, IdAssignmentPolicyValue, IdUniquenessPolicyValue, ImplicitActivationPolicyValue, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, IOR, LifespanPolicyValue, NameComponent, NameDynAnyPair, NameValuePair, NameValuePair, NoContext, NoServant, NotEmpty, NotFound, NotFoundReason, ObjectAlreadyActive, ObjectNotActive, Parameter, ParameterMode, PolicyError, RequestProcessingPolicyValue, ServantAlreadyActive, ServantNotActive, ServantRetentionPolicyValue, ServiceContext, ServiceDetail, ServiceInformation, SetOverrideType, State, StructMember, TaggedComponent, TaggedProfile, ThreadPolicyValue, TypeCode, TypeMismatch, TypeMismatch, TypeMismatch, UnionMember, UnknownEncoding, UnknownUserException, UserException, ValueMember, WrongAdapter, WrongPolicy, WrongTransaction

    public interface IDLEntity
extends Serializable
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class. RMI IIOP serialization looks for such a marker to perform marshalling/unmarshalling.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gaatfcnacnittnii isscer s


IndirectionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.portable

类 IndirectionException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.IndirectionException
  • 所有已实现的接口：
    Serializable

    public class IndirectionException
extends SystemException
    The Indirection exception is a Java specific system exception. It is thrown when the ORB's input stream is called to demarshal a value that is encoded as an indirection that is in the process of being demarshaled. This can occur when the ORB input stream calls the ValueHandler to demarshal an RMI value whose state contains a recursive reference to itself. Because the top-level ValueHandler.read_value() call has not yet returned a value, the ORB input stream's indirection table does not contain an entry for an object with the stream offset specified by the indirection tag. The stream offset is returned in the exception's offset field.
    另请参见：
    InputStream, OutputStream

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      int offset
      Points to the stream's offset.

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      IndirectionException(int offset)
      Creates an IndirectionException with the right offset value.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • offset

        public int offset
        Points to the stream's offset.

    • 构造方法详细信息

      • IndirectionException

        public IndirectionException(int offset)
        Creates an IndirectionException with the right offset value. The stream offset is returned in the exception's offset field. This exception is constructed and thrown during reading recursively defined values off of a stream.
        参数：
        offset - the stream offset where recursion is detected.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c"t/Sraeratbbattg.==ltl"tsl""tmePueabaP


InputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA.portable

类 InputStream

  • java.lang.Object
    • java.io.InputStream
      • org.omg.CORBA.portable.InputStream
  • 所有已实现的接口：
    Closeable, AutoCloseable
    直接已知子类：
    InputStream

    public abstract class InputStream
extends InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams. These methods are used by the ORB to unmarshal IDL types as well as to extract IDL types out of Anys. The _array versions of the methods can be directly used to read sequences and arrays of IDL types.
    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputStream()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ORB orb()
      Returns the ORB that created this InputStream.
      abstract Any read_any()
      Reads an Any from this input stream.
      abstract void read_boolean_array(boolean[] value, int offset, int length)
      Reads an array of booleans from this input stream.
      abstract boolean read_boolean()
      Reads a boolean value from this input stream.
      abstract void read_char_array(char[] value, int offset, int length)
      Reads an array of chars from this input stream.
      abstract char read_char()
      Reads a char value from this input stream.
      Context read_Context()
      Reads a CORBA context from the stream.
      abstract void read_double_array(double[] value, int offset, int length)
      Reads an array of doubles from this input stream.
      abstract double read_double()
      Reads a double value from this input stream.
      BigDecimal read_fixed()
      Reads a BigDecimal number.
      abstract void read_float_array(float[] value, int offset, int length)
      Reads an array of floats from this input stream.
      abstract float read_float()
      Reads a float value from this input stream.
      abstract void read_long_array(int[] value, int offset, int length)
      Reads an array of CORBA longs (that is, Java ints) from this input stream.
      abstract int read_long()
      Reads a CORBA long (that is, Java int) value from this input stream.
      abstract void read_longlong_array(long[] value, int offset, int length)
      Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
      abstract long read_longlong()
      Reads a CORBA longlong (that is, Java long) value from this input stream.
      abstract Object read_Object()
      Reads a CORBA object from this input stream.
      Object read_Object(类 clz)
      Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
      abstract void read_octet_array(byte[] value, int offset, int length)
      Reads an array of octets (that is, bytes) from this input stream.
      abstract byte read_octet()
      Reads an octet (that is, a byte) value from this input stream.
      Principal read_Principal()
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void read_short_array(short[] value, int offset, int length)
      Reads an array of shorts from this input stream.
      abstract short read_short()
      Reads a short value from this input stream.
      abstract String read_string()
      Reads a string value from this input stream.
      abstract TypeCode read_TypeCode()
      Reads a TypeCode from this input stream.
      abstract void read_ulong_array(int[] value, int offset, int length)
      Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
      abstract int read_ulong()
      Reads an unsigned CORBA long (that is, Java int) value from this input stream.
      abstract void read_ulonglong_array(long[] value, int offset, int length)
      Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
      abstract long read_ulonglong()
      Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
      abstract void read_ushort_array(short[] value, int offset, int length)
      Reads an array of unsigned shorts from this input stream.
      abstract short read_ushort()
      Reads a unsigned short value from this input stream.
      abstract void read_wchar_array(char[] value, int offset, int length)
      Reads an array of wide chars from this input stream.
      abstract char read_wchar()
      Reads a wide char value from this input stream.
      abstract String read_wstring()
      Reads a wide string value from this input stream.
      int read()
      Reads the next byte of data from the input stream.

      • 方法 - 继承于类 java.io.InputStream

        available, close, mark, markSupported, read, read, reset, skip

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputStream

        public InputStream()

    • 方法详细信息

      • read_boolean

        public abstract boolean read_boolean()
        Reads a boolean value from this input stream.
        返回：
        the boolean value read from this input stream

      • read_char

        public abstract char read_char()
        Reads a char value from this input stream.
        返回：
        the char value read from this input stream

      • read_wchar

        public abstract char read_wchar()
        Reads a wide char value from this input stream.
        返回：
        the char value read from this input stream

      • read_octet

        public abstract byte read_octet()
        Reads an octet (that is, a byte) value from this input stream.
        返回：
        the byte value read from this input stream

      • read_short

        public abstract short read_short()
        Reads a short value from this input stream.
        返回：
        the short value read from this input stream

      • read_ushort

        public abstract short read_ushort()
        Reads a unsigned short value from this input stream.
        返回：
        the short value read from this input stream

      • read_long

        public abstract int read_long()
        Reads a CORBA long (that is, Java int) value from this input stream.
        返回：
        the int value read from this input stream

      • read_ulong

        public abstract int read_ulong()
        Reads an unsigned CORBA long (that is, Java int) value from this input stream.
        返回：
        the int value read from this input stream

      • read_longlong

        public abstract long read_longlong()
        Reads a CORBA longlong (that is, Java long) value from this input stream.
        返回：
        the long value read from this input stream

      • read_ulonglong

        public abstract long read_ulonglong()
        Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
        返回：
        the long value read from this input stream

      • read_float

        public abstract float read_float()
        Reads a float value from this input stream.
        返回：
        the float value read from this input stream

      • read_double

        public abstract double read_double()
        Reads a double value from this input stream.
        返回：
        the double value read from this input stream

      • read_string

        public abstract String read_string()
        Reads a string value from this input stream.
        返回：
        the String value read from this input stream

      • read_wstring

        public abstract String read_wstring()
        Reads a wide string value from this input stream.
        返回：
        the String value read from this input stream

      • read_boolean_array

        public abstract void read_boolean_array(boolean[] value,
                      int offset,
                      int length)
        Reads an array of booleans from this input stream.
        参数：
        value - returned array of booleans.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_char_array

        public abstract void read_char_array(char[] value,
                   int offset,
                   int length)
        Reads an array of chars from this input stream.
        参数：
        value - returned array of chars.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_wchar_array

        public abstract void read_wchar_array(char[] value,
                    int offset,
                    int length)
        Reads an array of wide chars from this input stream.
        参数：
        value - returned array of wide chars.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_octet_array

        public abstract void read_octet_array(byte[] value,
                    int offset,
                    int length)
        Reads an array of octets (that is, bytes) from this input stream.
        参数：
        value - returned array of octets (that is, bytes).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_short_array

        public abstract void read_short_array(short[] value,
                    int offset,
                    int length)
        Reads an array of shorts from this input stream.
        参数：
        value - returned array of shorts.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ushort_array

        public abstract void read_ushort_array(short[] value,
                     int offset,
                     int length)
        Reads an array of unsigned shorts from this input stream.
        参数：
        value - returned array of shorts.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_long_array

        public abstract void read_long_array(int[] value,
                   int offset,
                   int length)
        Reads an array of CORBA longs (that is, Java ints) from this input stream.
        参数：
        value - returned array of CORBA longs (that is, Java ints).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ulong_array

        public abstract void read_ulong_array(int[] value,
                    int offset,
                    int length)
        Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
        参数：
        value - returned array of CORBA longs (that is, Java ints).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_longlong_array

        public abstract void read_longlong_array(long[] value,
                       int offset,
                       int length)
        Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
        参数：
        value - returned array of CORBA longs (that is, Java longs).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_ulonglong_array

        public abstract void read_ulonglong_array(long[] value,
                        int offset,
                        int length)
        Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
        参数：
        value - returned array of CORBA longs (that is, Java longs).
        offset - offset on the stream.
        length - length of buffer to read.

      • read_float_array

        public abstract void read_float_array(float[] value,
                    int offset,
                    int length)
        Reads an array of floats from this input stream.
        参数：
        value - returned array of floats.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_double_array

        public abstract void read_double_array(double[] value,
                     int offset,
                     int length)
        Reads an array of doubles from this input stream.
        参数：
        value - returned array of doubles.
        offset - offset on the stream.
        length - length of buffer to read.

      • read_Object

        public abstract Object read_Object()
        Reads a CORBA object from this input stream.
        返回：
        the Object instance read from this input stream.

      • read_TypeCode

        public abstract TypeCode read_TypeCode()
        Reads a TypeCode from this input stream.
        返回：
        the TypeCode instance read from this input stream.

      • read_any

        public abstract Any read_any()
        Reads an Any from this input stream.
        返回：
        the Any instance read from this input stream.

      • read_Principal

        @Deprecated
public Principal read_Principal()
        Deprecated. Deprecated by CORBA 2.2.
        Returns principal for invocation.
        返回：
        Principal for invocation.

      • read

        public int read()
         throws IOException
        Description copied from class: InputStream
        Reads the next byte of data from the input stream. The value byte is returned as an int in the range 0 to 255. If no byte is available because the end of the stream has been reached, the value -1 is returned. This method blocks until input data is available, the end of the stream is detected, or an exception is thrown.

        A subclass must provide an implementation of this method.

        指定者：
        read in class InputStream
        返回：
        the next byte of data, or -1 if the end of the stream is reached.
        抛出：
        IOException - if an I/O error occurs.
        另请参见：
        portable package comments for unimplemented features

      • read_fixed

        public BigDecimal read_fixed()
        Reads a BigDecimal number.
        返回：
        a java.math.BigDecimal number

      • read_Context

        public Context read_Context()
        Reads a CORBA context from the stream.
        返回：
        a CORBA context
        另请参见：
        portable package comments for unimplemented features

      • read_Object

        public Object read_Object(类 clz)
        Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument. This class is the stub class of the expected type.
        参数：
        clz - The Class object for the stub class which corresponds to the type that is statistically expected, or the Class object for the RMI/IDL interface type that is statistically expected.
        返回：
        an Object instance of clz read from this stream
        另请参见：
        portable package comments for unimplemented features

      • orb

        public ORB orb()
        Returns the ORB that created this InputStream.
        返回：
        the ORB object that created this stream
        另请参见：
        portable package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InvokeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface InvokeHandler

  • All Known Subinterfaces:
    Tie
    All Known Implementing Classes:
    BindingIteratorPOA, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA

    public interface InvokeHandler
    This interface provides a dispatching mechanism for an incoming call. It is invoked by the ORB to dispatch a request to a servant.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      OutputStream _invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.

    • 方法详细信息

      • _invoke

        OutputStream _invoke(String method,
                   InputStream input,
                   ResponseHandler handler)
                     throws SystemException
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        参数：
        method - The method name.
        input - The InputStream containing the marshalled arguments.
        handler - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply
        抛出：
        SystemException - is thrown when invocation fails due to a CORBA system exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ti fo lo yoo yy Raa a f s e


ObjectImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA.portable

类 ObjectImpl

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
  • 所有已实现的接口：
    Object
    直接已知子类：
    _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, ObjectImpl

    public abstract class ObjectImpl
extends Object
implements Object
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods. All method implementations are forwarded to a Delegate object stored in the ObjectImpl instance. ObjectImpl allows for portable stubs because the Delegate can be implemented by a different vendor-specific ORB.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectImpl()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
      Creates a Request object that contains the given context, method, argument list, and container for the result.
      Request _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
      Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
      Object _duplicate()
      Returns a duplicate of this ObjectImpl object.
      Delegate _get_delegate()
      Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
      DomainManager[] _get_domain_managers()
      Retrieves a list of the domain managers for this ObjectImpl object.
      Object _get_interface_def()
      Retrieves the interface definition for this ObjectImpl object.
      Policy _get_policy(int policy_type)
      Retrieves the Policy object for this ObjectImpl object that has the given policy type.
      int _hash(int maximum)
      Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
      abstract String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      InputStream _invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      boolean _is_a(String repository_id)
      Checks whether the object identified by the given repository identifier is an ObjectImpl object.
      boolean _is_equivalent(Object that)
      Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
      boolean _is_local()
      Checks whether this ObjectImpl object is implemented by a local servant.
      boolean _non_existent()
      Checks whether the server object for this ObjectImpl object has been destroyed.
      ORB _orb()
      Returns a reference to the ORB associated with this object and its delegate.
      void _release()
      Releases the resources associated with this ObjectImpl object.
      void _releaseReply(InputStream input)
      Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
      Request _request(String operation)
      Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
      OutputStream _request(String operation, boolean responseExpected)
      Returns an OutputStream object to use for marshalling the arguments of the given method.
      void _servant_postinvoke(ServantObject servant)
      Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
      ServantObject _servant_preinvoke(String operation, 类 expectedType)
      Returns a Java reference to the local servant that should be used for sending a request for the method specified.
      void _set_delegate(Delegate delegate)
      Sets the Delegate for this ObjectImpl instance to the given Delegate object.
      Object _set_policy_override(Policy[] policies, SetOverrideType set_add)
      Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
      boolean equals(Object obj)
      Compares this ObjectImpl object with the given one for equality.
      int hashCode()
      Returns the hash code for this ObjectImpl object.
      String toString()
      Returns a String object that represents this ObjectImpl object.

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ObjectImpl

        public ObjectImpl()

    • 方法详细信息

      • _get_delegate

        public Delegate _get_delegate()
        Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
        返回：
        the Delegate contained in this ObjectImpl instance
        抛出：
        BAD_OPERATION - if the delegate has not been set
        另请参见：
        _set_delegate(org.omg.CORBA.portable.Delegate)

      • _set_delegate

        public void _set_delegate(Delegate delegate)
        Sets the Delegate for this ObjectImpl instance to the given Delegate object. All method invocations on this ObjectImpl object will be forwarded to this delegate.
        参数：
        delegate - the Delegate instance to which all method calls on this ObjectImpl object will be delegated; may be implemented by a third-party ORB
        另请参见：
        _get_delegate()

      • _ids

        public abstract String[] _ids()
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance

      • _duplicate

        public Object _duplicate()
        Returns a duplicate of this ObjectImpl object.
        指定者：
        _duplicate in interface Object
        返回：
        an orb.omg.CORBA.Object object that is a duplicate of this object

      • _release

        public void _release()
        Releases the resources associated with this ObjectImpl object.
        指定者：
        _release in interface Object

      • _is_a

        public boolean _is_a(String repository_id)
        Checks whether the object identified by the given repository identifier is an ObjectImpl object.
        指定者：
        _is_a in interface Object
        参数：
        repository_id - a String object with the repository identifier to check
        返回：
        true if the object identified by the given repository id is an instance of ObjectImpl; false otherwise

      • _is_equivalent

        public boolean _is_equivalent(Object that)
        Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
        指定者：
        _is_equivalent in interface Object
        参数：
        that - an instance of ObjectImpl to compare with this ObjectImpl object
        返回：
        true if the given object is equivalent to this ObjectImpl object; false otherwise

      • _non_existent

        public boolean _non_existent()
        Checks whether the server object for this ObjectImpl object has been destroyed.
        指定者：
        _non_existent in interface Object
        返回：
        true if the ORB knows authoritatively that the server object does not exist; false otherwise

      • _hash

        public int _hash(int maximum)
        Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
        指定者：
        _hash in interface Object
        参数：
        maximum - an int indicating the upper bound on the hash value returned by the ORB
        返回：
        an int representing the hash code for this ObjectImpl object

      • _request

        public Request _request(String operation)
        Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
        指定者：
        _request in interface Object
        参数：
        operation - the method to be invoked by the new Request object
        返回：
        a new Request object initialized with the given method

      • _create_request

        public Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result)
        Creates a Request object that contains the given context, method, argument list, and container for the result.
        指定者：
        _create_request in interface Object
        参数：
        ctx - the Context for the request
        operation - the method that the new Request object will invoke
        arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
        result - a NamedValue object to be used for returning the result of executing the request's method
        返回：
        a new Request object initialized with the given context, method, argument list, and container for the return value
        另请参见：
        Request, NVList, NamedValue

      • _create_request

        public Request _create_request(Context ctx,
                      String operation,
                      NVList arg_list,
                      NamedValue result,
                      ExceptionList exceptions,
                      ContextList contexts)
        Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings. This Request object is for use in the Dynamic Invocation Interface.
        指定者：
        _create_request in interface Object
        参数：
        ctx - the Context object that contains the context strings that must be resolved before they are sent along with the request
        operation - the method that the new Request object will invoke
        arg_list - the arguments for the method; an NVList in which each argument is a NamedValue object
        result - a NamedValue object to be used for returning the result of executing the request's method
        exceptions - a list of the exceptions that the given method throws
        contexts - a list of the properties that are needed to resolve the contexts in ctx; the strings in contexts are used as arguments to the method Context.get_values, which returns the value associated with the given property
        返回：
        a new Request object initialized with the given context strings to resolve, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings
        另请参见：
        Request, NVList, NamedValue, ExceptionList, ContextList

      • _get_interface_def

        public Object _get_interface_def()
        Retrieves the interface definition for this ObjectImpl object.
        指定者：
        _get_interface_def in interface Object
        返回：
        the org.omg.CORBA.Object instance that is the interface definition for this ObjectImpl object

      • _orb

        public ORB _orb()
        Returns a reference to the ORB associated with this object and its delegate. This is the ORB object that created the delegate.
        返回：
        the ORB instance that created the Delegate object contained in this ObjectImpl object

      • _get_policy

        public Policy _get_policy(int policy_type)
        Retrieves the Policy object for this ObjectImpl object that has the given policy type.
        指定者：
        _get_policy in interface Object
        参数：
        policy_type - an int indicating the policy type
        返回：
        the Policy object that is the specified policy type and that applies to this ObjectImpl object
        另请参见：
        PolicyOperations.policy_type()

      • _get_domain_managers

        public DomainManager[] _get_domain_managers()
        Retrieves a list of the domain managers for this ObjectImpl object.
        指定者：
        _get_domain_managers in interface Object
        返回：
        an array containing the DomainManager objects for this instance of ObjectImpl

      • _set_policy_override

        public Object _set_policy_override(Policy[] policies,
                          SetOverrideType set_add)
        Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
        指定者：
        _set_policy_override in interface Object
        参数：
        policies - an array of Policy objects with the policies that will replace the current policies or be added to the current policies
        set_add - either SetOverrideType.SET_OVERRIDE, indicating that the given policies will replace any existing ones, or SetOverrideType.ADD_OVERRIDE, indicating that the given policies should be added to any existing ones
        返回：
        an Object with the given policies replacing or added to its previous policies

      • _is_local

        public boolean _is_local()
        Checks whether this ObjectImpl object is implemented by a local servant. If so, local invocation API's may be used.
        返回：
        true if this object is implemented by a local servant; false otherwise

      • _servant_preinvoke

        public ServantObject _servant_preinvoke(String operation,
                               类 expectedType)
        Returns a Java reference to the local servant that should be used for sending a request for the method specified. If this ObjectImpl object is a local stub, it will invoke the _servant_preinvoke method before sending a request in order to obtain the ServantObject instance to use.

        If a ServantObject object is returned, its servant field has been set to an object of the expected type (Note: the object may or may not be the actual servant instance). The local stub may cast the servant field to the expected type, and then invoke the operation directly. The ServantRequest object is valid for only one invocation and cannot be used for more than one invocation.

        参数：
        operation - a String containing the name of the method to be invoked. This name should correspond to the method name as it would be encoded in a GIOP request.
        expectedType - a 类 object representing the expected type of the servant that is returned. This expected type is the 类 object associated with the operations class for the stub's interface. For example, a stub for an interface Foo would pass the 类 object for the FooOperations interface.
        返回：
        (1) a ServantObject object, which may or may not be the actual servant instance, or (2) null if (a) the servant is not local or (b) the servant has ceased to be local due to a ForwardRequest from a POA ServantManager
        抛出：
        BAD_PARAM - if the servant is not the expected type

      • _servant_postinvoke

        public void _servant_postinvoke(ServantObject servant)
        Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke. The _servant_postinvoke method must be called if the _servant_preinvoke method returned a non-null value, even if an exception was thrown by the method invoked by the servant. For this reason, the call to the method _servant_postinvoke should be placed in a Java finally clause.
        参数：
        servant - the instance of the ServantObject returned by the _servant_preinvoke method

      • _request

        public OutputStream _request(String operation,
                    boolean responseExpected)
        Returns an OutputStream object to use for marshalling the arguments of the given method. This method is called by a stub, which must indicate if a response is expected, that is, whether or not the call is oneway.
        参数：
        operation - a String giving the name of the method.
        responseExpected - a boolean -- true if the request is not one way, that is, a response is expected
        返回：
        an OutputStream object for dispatching the request

      • _invoke

        public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
        Invokes an operation and returns an InputStream object for reading the response. The stub provides the OutputStream object that was previously returned by a call to the _request method. The method specified as an argument to _request when it was called previously is the method that this method invokes.

        If an exception occurs, the _invoke method may throw an ApplicationException object that contains an InputStream from which the user exception state may be unmarshalled.

        参数：
        output - an OutputStream object for dispatching the request
        返回：
        an InputStream object containing the marshalled response to the method invoked
        抛出：
        ApplicationException - if the invocation meets application-defined exception
        RemarshalException - if the invocation leads to a remarshalling error
        另请参见：
        _request(java.lang.String)

      • _releaseReply

        public void _releaseReply(InputStream input)
        Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke. Calling this method is optional for the stub.
        参数：
        input - the InputStream object that was returned by the _invoke method or the ApplicationException.getInputStream method; may be null, in which case this method does nothing
        另请参见：
        _invoke(org.omg.CORBA.portable.OutputStream)

      • toString

        public String toString()
        Returns a String object that represents this ObjectImpl object.
        重载：
        toString in class Object
        返回：
        the String representation of this object

      • hashCode

        public int hashCode()
        Returns the hash code for this ObjectImpl object.
        重载：
        hashCode in class Object
        返回：
        the hash code for this object
        另请参见：
        Object.equals(java.lang.Object), System.identityHashCode(java.lang.Object)

      • equals

        public boolean equals(Object obj)
        Compares this ObjectImpl object with the given one for equality.
        重载：
        equals in class Object
        参数：
        obj - the object with which to compare this object
        返回：
        true if the two objects are equal; false otherwise
        另请参见：
        Object.hashCode(), HashMap
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


org.omg.CORBA.portable

Interfaces

  • BoxedValueHelper
  • CustomValue
  • IDLEntity
  • InvokeHandler
  • ResponseHandler
  • Streamable
  • StreamableValue
  • ValueBase
  • ValueFactory
  • ValueInputStream
  • ValueOutputStream

Classes

  • Delegate
  • InputStream
  • ObjectImpl
  • OutputStream
  • ServantObject

Exceptions

  • ApplicationException
  • IndirectionException
  • RemarshalException
  • UnknownException
�


org.omg.CORBA.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA.portable

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

请参见： 描述

  • 接口摘要
    接口 描述
    BoxedValueHelper
    CustomValue
    An extension of ValueBase that is implemented by custom value types.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    StreamableValue
    Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
    ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
    ValueInputStream
    Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.
    ValueOutputStream
    Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.
  • Class Summary
    类 描述
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
  • Exception Summary
    Exception 描述
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    IndirectionException
    The Indirection exception is a Java specific system exception.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    UnknownException
    The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.

软件包 org.omg.CORBA.portable Description

Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB. Stubs and other code, generated either from IDL or interfaces written in the Java programming language, can call into these ORB APIs.

CORBA Features Throwing NO_IMPLEMENT() Exceptions

Some methods throw NO_IMPLEMENT() exceptions by default, but ORB vendors can override them to provide real implementations. The ORB included in Sun's release of the Java[tm] Platform, Standard Edition 6, includes implementations for the following methods.

List of Unimplemented Features in Package org.omg.CORBA.portable

Unimplemented Interfaces in package org.omg.CORBA.portable

  • InvokeHandler
  • ResponseHandler

Unimplemented Methods in package org.omg.CORBA.portable

  • InputStream
    • public int read()
    • public.math.BigDecimal read_fixed()
    • public org.omg.CORBA.Context read_Context()
    • public org.omg.CORBA.Object read_Object(java.lang.Class clz)
    • public org.omg.CORBA.ORB orb()
  • OutputStream
    • public org.omg.CORBA.ORB orb()
    • public void write_Context(org.omg.CORBA.Context ctx, org.omg.CORBA.ContextList contexts)
    • public void write_fixed(java.math.BigDecimal value)
    • public void write(int b)
  • Delegate
    • public void releaseReply(org.omg.CORBA.Object self, InputStream input)
    • public InputStream invoke(org.omg.CORBA.Object self, OutputStream output)
    • public OutputStream request(org.omg.CORBA.Object self, String operation, boolean responseExpected)
    • public org.omg.CORBA.Object set_policy_override(org.omg.CORBA.Object self, org.omg.CORBA.Policy[] policies, org.omg.CORBA.SetOverrideType set_add)
    • public org.omg.CORBA.DomainManager[] get_domain_managers( org.omg.CORBA.Object self)
    • public org.omg.CORBA.Policy get_policy(org.omg.CORBA.Object self, int policy_type)
从以下版本开始：
JDK1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.=i">(tsr>tli>(o_m.


org.omg.CORBA.portable Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA.portable

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
    • org.omg.CORBA.portable.ServantObject
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.portable.ApplicationException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.portable.UnknownException

Interface Hierarchy

  • org.omg.CORBA.portable.BoxedValueHelper
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.InvokeHandler
  • org.omg.CORBA.portable.ResponseHandler
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.ValueFactory
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

olntRCC.OOOo )xxR.


OutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA.portable

类 OutputStream

  • java.lang.Object
    • java.io.OutputStream
      • org.omg.CORBA.portable.OutputStream
  • 所有已实现的接口：
    Closeable, Flushable, AutoCloseable
    直接已知子类：
    OutputStream

    public abstract class OutputStream
extends OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams. These methods are used by the ORB to marshal IDL types as well as to insert IDL types into Anys. The _array versions of the methods can be directly used to write sequences and arrays of IDL types.
    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      OutputStream()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract InputStream create_input_stream()
      Returns an input stream with the same buffer.
      ORB orb()
      Returns the ORB that created this OutputStream.
      abstract void write_any(Any value)
      Writes an Any on this output stream.
      abstract void write_boolean_array(boolean[] value, int offset, int length)
      Writes an array of booleans on this output stream.
      abstract void write_boolean(boolean value)
      Writes a boolean value to this stream.
      abstract void write_char_array(char[] value, int offset, int length)
      Writes an array of chars on this output stream.
      abstract void write_char(char value)
      Writes a char value to this stream.
      void write_Context(Context ctx, ContextList contexts)
      Writes a CORBA context on this stream.
      abstract void write_double_array(double[] value, int offset, int length)
      Writes an array of doubles on this output stream.
      abstract void write_double(double value)
      Writes a double value to this stream.
      void write_fixed(BigDecimal value)
      Writes a BigDecimal number.
      abstract void write_float_array(float[] value, int offset, int length)
      Writes an array of floats on this output stream.
      abstract void write_float(float value)
      Writes a float value to this stream.
      abstract void write_long_array(int[] value, int offset, int length)
      Writes an array of CORBA longs (i.e.
      abstract void write_long(int value)
      Writes a CORBA long (i.e.
      abstract void write_longlong_array(long[] value, int offset, int length)
      Writes an array of CORBA longlongs (i.e.
      abstract void write_longlong(long value)
      Writes a CORBA longlong (i.e.
      abstract void write_Object(Object value)
      Writes a CORBA Object on this output stream.
      abstract void write_octet_array(byte[] value, int offset, int length)
      Writes an array of CORBA octets (bytes) on this output stream.
      abstract void write_octet(byte value)
      Writes a CORBA octet (i.e.
      void write_Principal(Principal value)
      Deprecated.
      Deprecated by CORBA 2.2.
      abstract void write_short_array(short[] value, int offset, int length)
      Writes an array of shorts on this output stream.
      abstract void write_short(short value)
      Writes a short value to this stream.
      abstract void write_string(String value)
      Writes a string value to this stream.
      abstract void write_TypeCode(TypeCode value)
      Writes a TypeCode on this output stream.
      abstract void write_ulong_array(int[] value, int offset, int length)
      Writes an array of unsigned CORBA longs (i.e.
      abstract void write_ulong(int value)
      Writes an unsigned CORBA long (i.e.
      abstract void write_ulonglong_array(long[] value, int offset, int length)
      Writes an array of unsigned CORBA longlongs (i.e.
      abstract void write_ulonglong(long value)
      Writes an unsigned CORBA longlong (i.e.
      abstract void write_ushort_array(short[] value, int offset, int length)
      Writes an array of unsigned shorts on this output stream.
      abstract void write_ushort(short value)
      Writes an unsigned short value to this stream.
      abstract void write_wchar_array(char[] value, int offset, int length)
      Writes an array of wide chars on this output stream.
      abstract void write_wchar(char value)
      Writes a wide char value to this stream.
      abstract void write_wstring(String value)
      Writes a wide string value to this stream.
      void write(int b)
      Writes an integer (length of arrays) onto this stream.

      • 方法 - 继承于类 java.io.OutputStream

        close, flush, write, write

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OutputStream

        public OutputStream()

    • 方法详细信息

      • create_input_stream

        public abstract InputStream create_input_stream()
        Returns an input stream with the same buffer.
        返回：
        an input stream with the same buffer.

      • write_boolean

        public abstract void write_boolean(boolean value)
        Writes a boolean value to this stream.
        参数：
        value - the value to be written.

      • write_char

        public abstract void write_char(char value)
        Writes a char value to this stream.
        参数：
        value - the value to be written.

      • write_wchar

        public abstract void write_wchar(char value)
        Writes a wide char value to this stream.
        参数：
        value - the value to be written.

      • write_octet

        public abstract void write_octet(byte value)
        Writes a CORBA octet (i.e. byte) value to this stream.
        参数：
        value - the value to be written.

      • write_short

        public abstract void write_short(short value)
        Writes a short value to this stream.
        参数：
        value - the value to be written.

      • write_ushort

        public abstract void write_ushort(short value)
        Writes an unsigned short value to this stream.
        参数：
        value - the value to be written.

      • write_long

        public abstract void write_long(int value)
        Writes a CORBA long (i.e. Java int) value to this stream.
        参数：
        value - the value to be written.

      • write_ulong

        public abstract void write_ulong(int value)
        Writes an unsigned CORBA long (i.e. Java int) value to this stream.
        参数：
        value - the value to be written.

      • write_longlong

        public abstract void write_longlong(long value)
        Writes a CORBA longlong (i.e. Java long) value to this stream.
        参数：
        value - the value to be written.

      • write_ulonglong

        public abstract void write_ulonglong(long value)
        Writes an unsigned CORBA longlong (i.e. Java long) value to this stream.
        参数：
        value - the value to be written.

      • write_float

        public abstract void write_float(float value)
        Writes a float value to this stream.
        参数：
        value - the value to be written.

      • write_double

        public abstract void write_double(double value)
        Writes a double value to this stream.
        参数：
        value - the value to be written.

      • write_string

        public abstract void write_string(String value)
        Writes a string value to this stream.
        参数：
        value - the value to be written.

      • write_wstring

        public abstract void write_wstring(String value)
        Writes a wide string value to this stream.
        参数：
        value - the value to be written.

      • write_boolean_array

        public abstract void write_boolean_array(boolean[] value,
                       int offset,
                       int length)
        Writes an array of booleans on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_char_array

        public abstract void write_char_array(char[] value,
                    int offset,
                    int length)
        Writes an array of chars on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_wchar_array

        public abstract void write_wchar_array(char[] value,
                     int offset,
                     int length)
        Writes an array of wide chars on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_octet_array

        public abstract void write_octet_array(byte[] value,
                     int offset,
                     int length)
        Writes an array of CORBA octets (bytes) on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_short_array

        public abstract void write_short_array(short[] value,
                     int offset,
                     int length)
        Writes an array of shorts on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ushort_array

        public abstract void write_ushort_array(short[] value,
                      int offset,
                      int length)
        Writes an array of unsigned shorts on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_long_array

        public abstract void write_long_array(int[] value,
                    int offset,
                    int length)
        Writes an array of CORBA longs (i.e. Java ints) on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ulong_array

        public abstract void write_ulong_array(int[] value,
                     int offset,
                     int length)
        Writes an array of unsigned CORBA longs (i.e. Java ints) on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_longlong_array

        public abstract void write_longlong_array(long[] value,
                        int offset,
                        int length)
        Writes an array of CORBA longlongs (i.e. Java longs) on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_ulonglong_array

        public abstract void write_ulonglong_array(long[] value,
                         int offset,
                         int length)
        Writes an array of unsigned CORBA longlongs (i.e. Java ints) on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_float_array

        public abstract void write_float_array(float[] value,
                     int offset,
                     int length)
        Writes an array of floats on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_double_array

        public abstract void write_double_array(double[] value,
                      int offset,
                      int length)
        Writes an array of doubles on this output stream.
        参数：
        value - the array to be written.
        offset - offset on the stream.
        length - length of buffer to write.

      • write_Object

        public abstract void write_Object(Object value)
        Writes a CORBA Object on this output stream.
        参数：
        value - the value to be written.

      • write_TypeCode

        public abstract void write_TypeCode(TypeCode value)
        Writes a TypeCode on this output stream.
        参数：
        value - the value to be written.

      • write_any

        public abstract void write_any(Any value)
        Writes an Any on this output stream.
        参数：
        value - the value to be written.

      • write_Principal

        @Deprecated
public void write_Principal(Principal value)
        Deprecated. Deprecated by CORBA 2.2.
        Writes a Principle on this output stream.
        参数：
        value - the value to be written.

      • write

        public void write(int b)
           throws IOException
        Writes an integer (length of arrays) onto this stream.
        指定者：
        write in class OutputStream
        参数：
        b - the value to be written.
        抛出：
        IOException - if there is an input/output error
        另请参见：
        portable package comments for unimplemented features

      • write_fixed

        public void write_fixed(BigDecimal value)
        Writes a BigDecimal number.
        参数：
        value - a BidDecimal--value to be written.

      • write_Context

        public void write_Context(Context ctx,
                 ContextList contexts)
        Writes a CORBA context on this stream. The Context is marshaled as a sequence of strings. Only those Context values specified in the contexts parameter are actually written.
        参数：
        ctx - a CORBA context
        contexts - a ContextList object containing the list of contexts to be written
        另请参见：
        portable package comments for unimplemented features

      • orb

        public ORB orb()
        Returns the ORB that created this OutputStream.
        返回：
        the ORB that created this OutputStream
        另请参见：
        portable package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oatsd> e> ;<< ;;r er:gsnna>R/a>n


RemarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.portable

类 RemarshalException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.portable.RemarshalException
  • 所有已实现的接口：
    Serializable

    public final class RemarshalException
extends Exception
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB. In this case the ORB must remarshal the request before trying again. Stubs which use the stream-based model shall catch the RemarshalException which is potentially thrown from the _invoke() method of ObjectImpl. Upon catching the exception, the stub shall immediately remarshal the request by calling _request(), marshalling the arguments (if any), and then calling _invoke(). The stub shall repeat this process until _invoke() returns normally or raises some exception other than RemarshalException.

    • 构造方法摘要

      Constructors
      构造方法与描述
      RemarshalException()
      Constructs a RemarshalException.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • RemarshalException

        public RemarshalException()
        Constructs a RemarshalException.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"p#"losolsasa dd"a Pkevlsiolasc"gr


ResponseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface ResponseHandler

  • public interface ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      OutputStream createExceptionReply()
      Called by the servant during a method invocation.
      OutputStream createReply()
      Called by the servant during a method invocation.

    • 方法详细信息

      • createReply

        OutputStream createReply()
        Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if no exception occurred.
        返回：
        an OutputStream suitable for marshalling the reply.
        另请参见：
        portable package comments for unimplemented features

      • createExceptionReply

        OutputStream createExceptionReply()
        Called by the servant during a method invocation. The servant should call this method to create a reply marshal buffer if a user exception occurred.
        返回：
        an OutputStream suitable for marshalling the exception ID and the user exception body.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a r>r>f>d>rSS>rrosvvp.../dc


ServantObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.portable

类 ServantObject

  • java.lang.Object
    • org.omg.CORBA.portable.ServantObject

  • public class ServantObject
extends Object
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e. clients and servers residing in the same Java VM). The local stub API is supported via three additional methods on ObjectImpl and Delegate. ORB vendors may subclass this class to return additional request state that may be required by their implementations.
    另请参见：
    ObjectImpl, Delegate

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object servant
      The real servant.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantObject()

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • servant

        public Object servant
        The real servant. The local stub may cast this field to the expected type, and then invoke the operation directly. Note, the object may or may not be the actual servant instance.

    • 构造方法详细信息

      • ServantObject

        public ServantObject()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Jnoltlgl>lbn">Ja mJJrr莊詐pto:totfhmca


Streamable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface Streamable

  • All Known Subinterfaces:
    StreamableValue
    All Known Implementing Classes:
    AlreadyBoundHolder, AnyHolder, AnySeqHolder, BindingHolder, BindingIteratorHolder, BindingListHolder, BindingTypeHolder, BooleanHolder, BooleanSeqHolder, ByteHolder, CannotProceedHolder, CharHolder, CharSeqHolder, CookieHolder, CurrentHolder, DoubleHolder, DoubleSeqHolder, FixedHolder, FloatHolder, FloatSeqHolder, IntHolder, InvalidAddressHolder, InvalidNameHolder, IORHolder, IORInterceptor_3_0Holder, LongHolder, LongLongSeqHolder, LongSeqHolder, MultipleComponentProfileHolder, NameComponentHolder, NameHolder, NamingContextExtHolder, NamingContextHolder, NotEmptyHolder, NotFoundHolder, NotFoundReasonHolder, ObjectHolder, ObjectReferenceFactoryHolder, ObjectReferenceTemplateHolder, ObjectReferenceTemplateSeqHolder, OctetSeqHolder, ParameterModeHolder, PolicyErrorHolder, PolicyHolder, PolicyListHolder, PrincipalHolder, ServiceContextHolder, ServiceContextListHolder, ServiceInformationHolder, ShortHolder, ShortSeqHolder, StringHolder, StringSeqHolder, TaggedComponentHolder, TaggedProfileHolder, TypeCodeHolder, ULongLongSeqHolder, ULongSeqHolder, UnknownUserExceptionHolder, UShortSeqHolder, ValueBaseHolder, WCharSeqHolder, WrongTransactionHolder, WStringSeqHolder

    public interface Streamable
    The base class for the Holder classess of all complex IDL types. The ORB treats all generated Holders as Streamable to invoke the methods for marshalling and unmarshalling.
    从以下版本开始：
    JDK1.2

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream istream)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream ostream)
      Marshals to ostream the value in the value field of the Holder.

    • 方法详细信息

      • _read

        void _read(InputStream istream)
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        参数：
        istream - the InputStream that represents the CDR data from the wire.

      • _write

        void _write(OutputStream ostream)
        Marshals to ostream the value in the value field of the Holder.
        参数：
        ostream - the CDR OutputStream

      • _type

        TypeCode _type()
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"PeR.m


StreamableValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CORBA.portable

Interface StreamableValue

  • All Superinterfaces:
    IDLEntity, Serializable, Streamable, ValueBase

    public interface StreamableValue
extends Streamable, ValueBase
    Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled. All value types implement ValueBase either directly or indirectly by implementing either the StreamableValue or CustomValue interface.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.portable.Streamable

        _read, _type, _write

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/,aSmlcplcneecnne>IIrttcbt.T


UnknownException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.portable

类 UnknownException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.UnknownException
  • 所有已实现的接口：
    Serializable

    public class UnknownException
extends SystemException
    The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs. It provides a Java representation of an UNKNOWN system exception that has an UnknownExceptionInfo service context. If the CORBA system exception org.omg.CORBA.portable.UnknownException is thrown, then the stub does one of the following: (1) Translates it to org.omg.CORBA.UNKNOWN. (2) Translates it to the nested exception that the UnknownException contains. (3) Passes it on directly to the user.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Throwable originalEx
      A throwable--the original exception that was wrapped in a CORBA UnknownException.

      • Fields inherited from class org.omg.CORBA.SystemException

        completed, minor

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownException(Throwable ex)
      Constructs an UnknownException object.

    • 方法摘要

      • 方法 - 继承于类 org.omg.CORBA.SystemException

        toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • originalEx

        public Throwable originalEx
        A throwable--the original exception that was wrapped in a CORBA UnknownException.

    • 构造方法详细信息

      • UnknownException

        public UnknownException(Throwable ex)
        Constructs an UnknownException object.
        参数：
        ex - a Throwable object--to be wrapped in this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/o


Uses of Package org.omg.CORBA.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA.portable

  • Packages that use org.omg.CORBA.portable
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA.portable used by javax.rmi.CORBA
    类与描述
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA
    类与描述
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    BoxedValueHelper
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.DynAnyPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.ORBPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.TypeCodePackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA.portable
    类与描述
    ApplicationException
    This class is used for reporting application level exceptions between ORBs and stubs.
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    RemarshalException
    This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    ServantObject
    This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA_2_3
    类与描述
    ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
  • Classes in org.omg.CORBA.portable used by org.omg.CORBA_2_3.portable
    类与描述
    BoxedValueHelper
    Delegate
    Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming.NamingContextExtPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.CosNaming.NamingContextPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.Dynamic
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny.DynAnyFactoryPackage
    类与描述
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.DynamicAny.DynAnyPackage
    类与描述
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP.CodecFactoryPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.IOP.CodecPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.Messaging
    类与描述
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableInterceptor
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
    ValueBase
    The generated Java classes corresponding to valuetype IDL types implement this interface.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableInterceptor.ORBInitInfoPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    InvokeHandler
    This interface provides a dispatching mechanism for an incoming call.
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    ResponseHandler
    This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.CurrentPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.POAManagerPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.POAPackage
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
  • Classes in org.omg.CORBA.portable used by org.omg.PortableServer.ServantLocatorPackage
    类与描述
    InputStream
    InputStream is the Java API for reading IDL types from CDR marshal streams.
    OutputStream
    OuputStream is the Java API for writing IDL types to CDR marshal streams.
    Streamable
    The base class for the Holder classess of all complex IDL types.
  • Classes in org.omg.CORBA.portable used by org.omg.SendingContext
    类与描述
    IDLEntity
    An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
  • Classes in org.omg.CORBA.portable used by org.omg.stub.java.rmi
    类与描述
    ObjectImpl
    The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


ValueBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface ValueBase

  • All Superinterfaces:
    IDLEntity, Serializable
    All Known Subinterfaces:
    CustomValue, DataInputStream, DataOutputStream, ObjectReferenceFactory, ObjectReferenceTemplate, StreamableValue

    public interface ValueBase
extends IDLEntity
    The generated Java classes corresponding to valuetype IDL types implement this interface. In other words, the Java mapping of valuetype objects implement the ValueBase interface. The generated Java class for valuetype's shall provide an implementation of the ValueBase interface for the corresponding value type. For value types that are streamable (i.e. non-custom), the generated Java class shall also provide an implementation for the org.omg.CORBA.portable.Streamable interface. (CORBA::ValueBase is mapped to java.io.Serializable.)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _truncatable_ids()
      Provides truncatable repository ids.

    • 方法详细信息

      • _truncatable_ids

        String[] _truncatable_ids()
        Provides truncatable repository ids.
        返回：
        a String array--list of truncatable repository ids.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

njeotlcmlcettceegj..gl.vale"nnf>


ValueFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface ValueFactory

  • public interface ValueFactory
    The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory. The read_value() method is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory. In the implementation, the user shall call is.read_value(java.io.Serializable) with a uninitialized valuetype to use for unmarshaling. The value returned by the stream is the same value passed in, with all the data unmarshaled.
    另请参见：
    ORB

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Serializable read_value(InputStream is)
      Is called by the ORB runtime while in the process of unmarshaling a value type.

    • 方法详细信息

      • read_value

        Serializable read_value(InputStream is)
        Is called by the ORB runtime while in the process of unmarshaling a value type. A user shall implement this method as part of implementing a type specific value factory.
        参数：
        is - an InputStream object--from which the value will be read.
        返回：
        a Serializable object--the value read off of "is" Input stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atnttt"tlte"bla"v aa =雃fhtpnhh=pt


ValueInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface ValueInputStream

  • public interface ValueInputStream
    Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end_value()
      The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
      void start_value()
      The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

    • 方法详细信息

      • start_value

        void start_value()
        The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

      • end_value

        void end_value()
        The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.,non noneaions


ValueOutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CORBA.portable

Interface ValueOutputStream

  • public interface ValueOutputStream
    Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void end_value()
      The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
      void start_value(String rep_id)
      The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

    • 方法详细信息

      • start_value

        void start_value(String rep_id)
        The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

      • end_value

        void end_value()
        The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tS"b"""a"-Jva un td�//dws/ca


Uses of Class org.omg.CORBA.portable.ApplicationException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.ApplicationException

  • Packages that use ApplicationException
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ApplicationException in org.omg.CORBA

      Methods in org.omg.CORBA that throw ApplicationException
      修饰符与类型 方法与描述
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of ApplicationException in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that throw ApplicationException
      修饰符与类型 方法与描述
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.Sm.seV> t


Uses of Class org.omg.CORBA.portable.Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.Delegate

  • Packages that use Delegate
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of Delegate in org.omg.CORBA

      Constructors in org.omg.CORBA with parameters of type Delegate
      构造方法与描述
      _IDLTypeStub(Delegate delegate)
      Constructs an _IDLTypeStub object initialized with the given Delegate object.
      _PolicyStub(Delegate delegate)
      Constructs a _PolicyStub object initialized with the given Delegate object.

    • Uses of Delegate in org.omg.CORBA_2_3.portable

      Subclasses of Delegate in org.omg.CORBA_2_3.portable
      修饰符与类型 类与描述
      class  Delegate
      Delegate class provides the ORB vendor specific implementation of CORBA object.

    • Uses of Delegate in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return Delegate
      修饰符与类型 方法与描述
      Delegate ObjectImpl._get_delegate()
      Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
      Methods in org.omg.CORBA.portable with parameters of type Delegate
      修饰符与类型 方法与描述
      void ObjectImpl._set_delegate(Delegate delegate)
      Sets the Delegate for this ObjectImpl instance to the given Delegate object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sEv/ial.p/la.R>o ne>"t


Uses of Class org.omg.CORBA.portable.IndirectionException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.IndirectionException

No usage of org.omg.CORBA.portable.IndirectionException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtgarstocllls<""rl i<


Uses of Class org.omg.CORBA.portable.InputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.InputStream

  • Packages that use InputStream
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of InputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type InputStream
      修饰符与类型 方法与描述
      Object UtilDelegate.readAny(InputStream in)
      Delegation call for Util.readAny(org.omg.CORBA.portable.InputStream).
      static Object Util.readAny(InputStream in)
      Reads a java.lang.Object as a CORBA any.
      Serializable ValueHandler.readValue(InputStream in, int offset, 类 clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.

    • Uses of InputStream in org.omg.CORBA

      Methods in org.omg.CORBA that return InputStream
      修饰符与类型 方法与描述
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      abstract InputStream Any.create_input_stream()
      Creates an input stream from which this Any object's value can be unmarshalled.
      Methods in org.omg.CORBA with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | WrongTransactionHolder._read(InputStream i)
      void | WStringSeqHolder._read(InputStream i)
      void | UnknownUserExceptionHolder._read(InputStream i)
      void | StringSeqHolder._read(InputStream i)
      void | PolicyErrorHolder._read(InputStream i)
      void | ParameterModeHolder._read(InputStream i)
      void ValueBaseHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void | PolicyListHolder._read(InputStream i)
      void | PolicyHolder._read(InputStream i)
      void | DoubleSeqHolder._read(InputStream i)
      void | FloatSeqHolder._read(InputStream i)
      void | LongLongSeqHolder._read(InputStream i)
      void | ULongLongSeqHolder._read(InputStream i)
      void | ULongSeqHolder._read(InputStream i)
      void | LongSeqHolder._read(InputStream i)
      void | UShortSeqHolder._read(InputStream i)
      void | ShortSeqHolder._read(InputStream i)
      void | OctetSeqHolder._read(InputStream i)
      void | WCharSeqHolder._read(InputStream i)
      void | CurrentHolder._read(InputStream i)
      void | CharSeqHolder._read(InputStream i)
      void | BooleanSeqHolder._read(InputStream i)
      void | AnySeqHolder._read(InputStream i)
      void TypeCodeHolder._read(InputStream input)
      Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
      void StringHolder._read(InputStream input)
      Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
      void ShortHolder._read(InputStream input)
      Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
      void PrincipalHolder._read(InputStream input)
      Deprecated.
      void ObjectHolder._read(InputStream input)
      Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
      void LongHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void IntHolder._read(InputStream input)
      Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
      void FloatHolder._read(InputStream input)
      Read a float from an input stream and initialize the value member with the float value.
      void FixedHolder._read(InputStream input)
      Read a fixed point value from the input stream and store it in the value member.
      void DoubleHolder._read(InputStream input)
      Read a double value from the input stream and store it in the value member.
      void CharHolder._read(InputStream input)
      Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
      void ByteHolder._read(InputStream input)
      Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
      void BooleanHolder._read(InputStream input)
      Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
      void AnyHolder._read(InputStream input)
      Reads from input and initalizes the value in the Holder with the unmarshalled data.
      void ServiceInformationHolder._read(InputStream in)
      Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
      void LocalObject._releaseReply(InputStream input)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Serializable | WStringValueHelper.read_value(InputStream istream)
      Serializable | StringValueHelper.read_value(InputStream istream)
      abstract void Any.read_value(InputStream is, TypeCode t)
      Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
      static String[] | WStringSeqHelper.read(InputStream istream)
      static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
      static String[] | StringSeqHelper.read(InputStream istream)
      static PolicyError | PolicyErrorHelper.read(InputStream istream)
      static short | PolicyErrorCodeHelper.read(InputStream istream)
      static ParameterMode | ParameterModeHelper.read(InputStream istream)
      static String | WStringValueHelper.read(InputStream istream)
      static char[] | WCharSeqHelper.read(InputStream istream)
      static short | VisibilityHelper.read(InputStream istream)
      static String | VersionSpecHelper.read(InputStream istream)
      static ValueMember | ValueMemberHelper.read(InputStream istream)
      static Serializable | ValueBaseHelper.read(InputStream istream)
      static UnionMember | UnionMemberHelper.read(InputStream istream)
      static short[] | UShortSeqHelper.read(InputStream istream)
      static int[] | ULongSeqHelper.read(InputStream istream)
      static long[] | ULongLongSeqHelper.read(InputStream istream)
      static StructMember | StructMemberHelper.read(InputStream istream)
      static String | StringValueHelper.read(InputStream istream)
      static short[] | ShortSeqHelper.read(InputStream istream)
      static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
      static String | RepositoryIdHelper.read(InputStream istream)
      static Policy[] | PolicyListHelper.read(InputStream istream)
      static int | PolicyTypeHelper.read(InputStream istream)
      static Policy | PolicyHelper.read(InputStream istream)
      static byte[] | OctetSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      static int[] | LongSeqHelper.read(InputStream istream)
      static long[] | LongLongSeqHelper.read(InputStream istream)
      static String | IdentifierHelper.read(InputStream istream)
      static IDLType | IDLTypeHelper.read(InputStream istream)
      static float[] | FloatSeqHelper.read(InputStream istream)
      static String | FieldNameHelper.read(InputStream istream)
      static double[] | DoubleSeqHelper.read(InputStream istream)
      static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)
      static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
      static char[] | CharSeqHelper.read(InputStream istream)
      static boolean[] | BooleanSeqHelper.read(InputStream istream)
      static Any[] | AnySeqHelper.read(InputStream istream)
      static ServiceDetail | ServiceDetailHelper.read(InputStream in)
      static Object | ObjectHelper.read(InputStream istream)
      static ServiceInformation | ServiceInformationHelper.read(InputStream in)
      static WrongTransaction | WrongTransactionHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CORBA_2_3.portable

      Subclasses of InputStream in org.omg.CORBA_2_3.portable
      修饰符与类型 类与描述
      class  InputStream
      InputStream provides for the reading of all of the mapped IDL types from the stream.

    • Uses of InputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return InputStream
      修饰符与类型 方法与描述
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      abstract InputStream OutputStream.create_input_stream()
      Returns an input stream with the same buffer.
      InputStream ApplicationException.getInputStream()
      Returns the input stream from which the exception data can be read as its parameters.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      Methods in org.omg.CORBA.portable with parameters of type InputStream
      修饰符与类型 | 方法与描述
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
      void Streamable._read(InputStream istream)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      void ObjectImpl._releaseReply(InputStream input)
      Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
      Serializable | BoxedValueHelper.read_value(InputStream is)
      void Delegate.releaseReply(Object self, InputStream input)
      releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
      Constructors in org.omg.CORBA.portable with parameters of type InputStream
      构造方法与描述
      ApplicationException(String id, InputStream ins)
      Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.

    • Uses of InputStream in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type InputStream
      修饰符与类型 | 方法与描述
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      void | NamingContextExtHolder._read(InputStream i)
      void | NamingContextHolder._read(InputStream i)
      void | NameHolder._read(InputStream i)
      void | NameComponentHolder._read(InputStream i)
      void | BindingTypeHolder._read(InputStream i)
      void | BindingIteratorHolder._read(InputStream i)
      void | BindingListHolder._read(InputStream i)
      void | BindingHolder._read(InputStream i)
      static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
      static NamingContext | NamingContextHelper.read(InputStream istream)
      static NameComponent[] | NameHelper.read(InputStream istream)
      static NameComponent | NameComponentHelper.read(InputStream istream)
      static BindingType | BindingTypeHelper.read(InputStream istream)
      static Binding[] | BindingListHelper.read(InputStream istream)
      static BindingIterator | BindingIteratorHelper.read(InputStream istream)
      static Binding | BindingHelper.read(InputStream istream)
      static String | IstringHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | InvalidAddressHolder._read(InputStream i)
      static String | URLStringHelper.read(InputStream istream)
      static String | StringNameHelper.read(InputStream istream)
      static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
      static String | AddressHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | NotFoundReasonHolder._read(InputStream i)
      void | NotFoundHolder._read(InputStream i)
      void | NotEmptyHolder._read(InputStream i)
      void | InvalidNameHolder._read(InputStream i)
      void | CannotProceedHolder._read(InputStream i)
      void | AlreadyBoundHolder._read(InputStream i)
      static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)
      static NotFound | NotFoundHelper.read(InputStream istream)
      static NotEmpty | NotEmptyHelper.read(InputStream istream)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      static CannotProceed | CannotProceedHelper.read(InputStream istream)
      static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny

      Methods in org.omg.DynamicAny with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
      static DynSequence | DynSequenceHelper.read(InputStream istream)
      static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
      static String | FieldNameHelper.read(InputStream istream)
      static DynFixed | DynFixedHelper.read(InputStream istream)
      static DynEnum | DynEnumHelper.read(InputStream istream)
      static DynAny[] | DynAnySeqHelper.read(InputStream istream)
      static DynArray | DynArrayHelper.read(InputStream istream)
      static DynValue | DynValueHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.read(InputStream istream)
      static DynUnion | DynUnionHelper.read(InputStream istream)
      static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
      static DynStruct | DynStructHelper.read(InputStream istream)
      static Any[] | AnySeqHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      static InvalidValue | InvalidValueHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP

      Methods in org.omg.IOP with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | TaggedProfileHolder._read(InputStream i)
      void | TaggedComponentHolder._read(InputStream i)
      void | ServiceContextListHolder._read(InputStream i)
      void | ServiceContextHolder._read(InputStream i)
      void | MultipleComponentProfileHolder._read(InputStream i)
      void | IORHolder._read(InputStream i)
      static TaggedProfile | TaggedProfileHelper.read(InputStream istream)
      static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
      static int | ServiceIdHelper.read(InputStream istream)
      static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
      static ServiceContext | ServiceContextHelper.read(InputStream istream)
      static int | ProfileIdHelper.read(InputStream istream)
      static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
      static IOR | IORHelper.read(InputStream istream)
      static int | ComponentIdHelper.read(InputStream istream)
      static CodecFactory | CodecFactoryHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
      static FormatMismatch | FormatMismatchHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static short | SyncScopeHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | ObjectReferenceTemplateSeqHolder._read(InputStream i)
      void | ObjectReferenceTemplateHolder._read(InputStream i)
      void | ObjectReferenceFactoryHolder._read(InputStream i)
      void | IORInterceptor_3_0Holder._read(InputStream i)
      static String | ServerIdHelper.read(InputStream istream)
      static String | ORBIdHelper.read(InputStream istream)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
      static byte[] | ObjectIdHelper.read(InputStream istream)
      static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)
      static short | AdapterStateHelper.read(InputStream istream)
      static String[] | AdapterNameHelper.read(InputStream istream)
      static int | AdapterManagerIdHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static String | ObjectIdHelper.read(InputStream istream)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      static DuplicateName | DuplicateNameHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type InputStream
      修饰符与类型 | 方法与描述
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      static ServantLocator | ServantLocatorHelper.read(InputStream istream)
      static ServantActivator | ServantActivatorHelper.read(InputStream istream)
      static POA | POAHelper.read(InputStream istream)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      static Current | CurrentHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static NoContext | NoContextHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      static WrongPolicy | WrongPolicyHelper.read(InputStream istream)
      static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
      static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
      static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
      static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
      static NoServant | NoServantHelper.read(InputStream istream)
      static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
      static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)

    • Uses of InputStream in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage with parameters of type InputStream
      修饰符与类型 | 方法与描述
      void | CookieHolder._read(InputStream is)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.portable.ObjectImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.ObjectImpl

  • Packages that use ObjectImpl
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of ObjectImpl in javax.rmi.CORBA

      Subclasses of ObjectImpl in javax.rmi.CORBA
      修饰符与类型 类与描述
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.

    • Uses of ObjectImpl in org.omg.CORBA

      Subclasses of ObjectImpl in org.omg.CORBA
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  DynamicImplementation
      Deprecated.
      org.omg.CORBA.DynamicImplementation

    • Uses of ObjectImpl in org.omg.CORBA_2_3.portable

      Subclasses of ObjectImpl in org.omg.CORBA_2_3.portable
      修饰符与类型 类与描述
      class  ObjectImpl
      ObjectImpl class is the base class for all stubs.

    • Uses of ObjectImpl in org.omg.CosNaming

      Subclasses of ObjectImpl in org.omg.CosNaming
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of ObjectImpl in org.omg.DynamicAny

      Subclasses of ObjectImpl in org.omg.DynamicAny
      修饰符与类型 类与描述
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.

    • Uses of ObjectImpl in org.omg.PortableServer

      Subclasses of ObjectImpl in org.omg.PortableServer
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

    • Uses of ObjectImpl in org.omg.stub.java.rmi

      Subclasses of ObjectImpl in org.omg.stub.java.rmi
      修饰符与类型 类与描述
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hgPP� P>m=me


Uses of Class org.omg.CORBA.portable.OutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.OutputStream

  • Packages that use OutputStream
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.Messaging
    This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of OutputStream in javax.rmi.CORBA

      Methods in javax.rmi.CORBA with parameters of type OutputStream
      修饰符与类型 方法与描述
      void UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
      Delegation call for Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      static void Util.writeAbstractObject(OutputStream out, Object obj)
      Writes a java.lang.Object as either a value or a CORBA Object.
      void UtilDelegate.writeAny(OutputStream out, Object obj)
      Delegation call for Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      static void Util.writeAny(OutputStream out, Object obj)
      Writes any java.lang.Object as a CORBA any.
      void UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
      Delegation call for Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
      static void Util.writeRemoteObject(OutputStream out, Object obj)
      Writes a java.lang.Object as a CORBA Object.
      void ValueHandler.writeValue(OutputStream out, Serializable value)
      Writes a value to the stream using Java semantics.
      void ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion)
      Allows the ORB to pass the stream format version for RMI/IDL custom value types.

    • Uses of OutputStream in org.omg.CORBA

      Methods in org.omg.CORBA that return OutputStream
      修饰符与类型 方法与描述
      OutputStream LocalObject._request(String operation, boolean responseExpected)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      abstract OutputStream Any.create_output_stream()
      Creates an output stream into which this Any object's value can be marshalled.
      abstract OutputStream ORB.create_output_stream()
      Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
      Methods in org.omg.CORBA with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      void | WrongTransactionHolder._write(OutputStream o)
      void | WStringSeqHolder._write(OutputStream o)
      void | UnknownUserExceptionHolder._write(OutputStream o)
      void | StringSeqHolder._write(OutputStream o)
      void | PolicyErrorHolder._write(OutputStream o)
      void | ParameterModeHolder._write(OutputStream o)
      void ValueBaseHolder._write(OutputStream output)
      Marshals to output the value in the Holder.
      void | PolicyListHolder._write(OutputStream o)
      void | PolicyHolder._write(OutputStream o)
      void | DoubleSeqHolder._write(OutputStream o)
      void | FloatSeqHolder._write(OutputStream o)
      void | LongLongSeqHolder._write(OutputStream o)
      void | ULongLongSeqHolder._write(OutputStream o)
      void | ULongSeqHolder._write(OutputStream o)
      void | LongSeqHolder._write(OutputStream o)
      void | UShortSeqHolder._write(OutputStream o)
      void | ShortSeqHolder._write(OutputStream o)
      void | OctetSeqHolder._write(OutputStream o)
      void | WCharSeqHolder._write(OutputStream o)
      void | CurrentHolder._write(OutputStream o)
      void | CharSeqHolder._write(OutputStream o)
      void | BooleanSeqHolder._write(OutputStream o)
      void | AnySeqHolder._write(OutputStream o)
      void TypeCodeHolder._write(OutputStream output)
      Marshals to output the value in this TypeCodeHolder object.
      void StringHolder._write(OutputStream output)
      Marshals the value held by this StringHolder object to the output stream output.
      void ShortHolder._write(OutputStream output)
      Marshals to output the value in this ShortHolder object.
      void PrincipalHolder._write(OutputStream output)
      Deprecated.
      void ObjectHolder._write(OutputStream output)
      Marshals to output the value in this ObjectHolder object.
      void LongHolder._write(OutputStream output)
      Marshals to output the value in the Holder.
      void IntHolder._write(OutputStream output)
      Marshals the value in this IntHolder object's value field to the output stream output.
      void FloatHolder._write(OutputStream output)
      Write the float value into an output stream.
      void FixedHolder._write(OutputStream output)
      Write the fixed point value stored in this holder to an OutputStream.
      void DoubleHolder._write(OutputStream output)
      Write the double value stored in this holder to an OutputStream.
      void CharHolder._write(OutputStream output)
      Marshals to output the value in this CharHolder object.
      void ByteHolder._write(OutputStream output)
      Marshals to output the value in this ByteHolder object.
      void BooleanHolder._write(OutputStream output)
      Marshals the value in this BooleanHolder object's value field to the output stream output.
      void AnyHolder._write(OutputStream output)
      Marshals to output the value in this AnyHolder object.
      void ServiceInformationHolder._write(OutputStream out)
      Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
      abstract void Any.write_value(OutputStream os)
      Writes out the value of this Any object to the given output stream.
      void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
      void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      static void | BooleanSeqHelper.write(OutputStream ostream, boolean[] value)
      static void | OctetSeqHelper.write(OutputStream ostream, byte[] value)
      static void | WCharSeqHelper.write(OutputStream ostream, char[] value)
      static void | CharSeqHelper.write(OutputStream ostream, char[] value)
      static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
      static void | DoubleSeqHelper.write(OutputStream ostream, double[] value)
      static void | FloatSeqHelper.write(OutputStream ostream, float[] value)
      static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
      static void | PolicyTypeHelper.write(OutputStream ostream, int value)
      static void | ULongSeqHelper.write(OutputStream ostream, int[] value)
      static void | LongSeqHelper.write(OutputStream ostream, int[] value)
      static void | ULongLongSeqHelper.write(OutputStream ostream, long[] value)
      static void | LongLongSeqHelper.write(OutputStream ostream, long[] value)
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | ObjectHelper.write(OutputStream ostream, Object value)
      static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
      static void | PolicyHelper.write(OutputStream ostream, Policy value)
      static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
      static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
      static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)
      static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
      static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
      static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)
      static void | PolicyErrorCodeHelper.write(OutputStream ostream, short value)
      static void | VisibilityHelper.write(OutputStream ostream, short value)
      static void | UShortSeqHelper.write(OutputStream ostream, short[] value)
      static void | ShortSeqHelper.write(OutputStream ostream, short[] value)
      static void | WStringValueHelper.write(OutputStream ostream, String value)
      static void | VersionSpecHelper.write(OutputStream ostream, String value)
      static void | StringValueHelper.write(OutputStream ostream, String value)
      static void | RepositoryIdHelper.write(OutputStream ostream, String value)
      static void | IdentifierHelper.write(OutputStream ostream, String value)
      static void | FieldNameHelper.write(OutputStream ostream, String value)
      static void | WStringSeqHelper.write(OutputStream ostream, String[] value)
      static void | StringSeqHelper.write(OutputStream ostream, String[] value)
      static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
      static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
      static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
      static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
      static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

    • Uses of OutputStream in org.omg.CORBA_2_3.portable

      Subclasses of OutputStream in org.omg.CORBA_2_3.portable
      修饰符与类型 类与描述
      class  OutputStream
      OutputStream provides interface for writing of all of the mapped IDL type to the stream.

    • Uses of OutputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return OutputStream
      修饰符与类型 方法与描述
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.
      OutputStream ObjectImpl._request(String operation, boolean responseExpected)
      Returns an OutputStream object to use for marshalling the arguments of the given method.
      OutputStream ResponseHandler.createExceptionReply()
      Called by the servant during a method invocation.
      OutputStream ResponseHandler.createReply()
      Called by the servant during a method invocation.
      OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
      request is called by a stub to obtain an OutputStream for marshaling arguments.
      Methods in org.omg.CORBA.portable with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      void Streamable._write(OutputStream ostream)
      Marshals to ostream the value in the value field of the Holder.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
      void | BoxedValueHelper.write_value(OutputStream os, Serializable value)

    • Uses of OutputStream in org.omg.CosNaming

      Methods in org.omg.CosNaming that return OutputStream
      修饰符与类型 | 方法与描述
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      Methods in org.omg.CosNaming with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | NamingContextExtHolder._write(OutputStream o)
      void | NamingContextHolder._write(OutputStream o)
      void | NameHolder._write(OutputStream o)
      void | NameComponentHolder._write(OutputStream o)
      void | BindingTypeHolder._write(OutputStream o)
      void | BindingIteratorHolder._write(OutputStream o)
      void | BindingListHolder._write(OutputStream o)
      void | BindingHolder._write(OutputStream o)
      static void | BindingHelper.write(OutputStream ostream, Binding value)
      static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
      static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
      static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
      static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
      static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
      static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
      static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
      static void | IstringHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.CosNaming.NamingContextExtPackage

      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | InvalidAddressHolder._write(OutputStream o)
      static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
      static void | URLStringHelper.write(OutputStream ostream, String value)
      static void | StringNameHelper.write(OutputStream ostream, String value)
      static void | AddressHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.CosNaming.NamingContextPackage

      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | NotFoundReasonHolder._write(OutputStream o)
      void | NotFoundHolder._write(OutputStream o)
      void | NotEmptyHolder._write(OutputStream o)
      void | InvalidNameHolder._write(OutputStream o)
      void | CannotProceedHolder._write(OutputStream o)
      void | AlreadyBoundHolder._write(OutputStream o)
      static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
      static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
      static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
      static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

    • Uses of OutputStream in org.omg.DynamicAny

      Methods in org.omg.DynamicAny with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
      static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
      static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
      static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
      static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
      static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
      static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
      static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
      static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
      static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
      static void | DynValueHelper.write(OutputStream ostream, DynValue value)
      static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
      static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
      static void | FieldNameHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

    • Uses of OutputStream in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

    • Uses of OutputStream in org.omg.IOP

      Methods in org.omg.IOP with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | TaggedProfileHolder._write(OutputStream o)
      void | TaggedComponentHolder._write(OutputStream o)
      void | ServiceContextListHolder._write(OutputStream o)
      void | ServiceContextHolder._write(OutputStream o)
      void | MultipleComponentProfileHolder._write(OutputStream o)
      void | IORHolder._write(OutputStream o)
      static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)
      static void | ServiceIdHelper.write(OutputStream ostream, int value)
      static void | ProfileIdHelper.write(OutputStream ostream, int value)
      static void | ComponentIdHelper.write(OutputStream ostream, int value)
      static void | IORHelper.write(OutputStream ostream, IOR value)
      static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
      static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
      static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
      static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
      static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

    • Uses of OutputStream in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

    • Uses of OutputStream in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
      static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

    • Uses of OutputStream in org.omg.Messaging

      Methods in org.omg.Messaging with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | SyncScopeHelper.write(OutputStream ostream, short value)

    • Uses of OutputStream in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | ObjectReferenceTemplateSeqHolder._write(OutputStream o)
      void | ObjectReferenceTemplateHolder._write(OutputStream o)
      void | ObjectReferenceFactoryHolder._write(OutputStream o)
      void | IORInterceptor_3_0Holder._write(OutputStream o)
      static void | ObjectIdHelper.write(OutputStream ostream, byte[] value)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      static void | AdapterManagerIdHelper.write(OutputStream ostream, int value)
      static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
      static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
      static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
      static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
      static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
      static void | AdapterStateHelper.write(OutputStream ostream, short value)
      static void | ServerIdHelper.write(OutputStream ostream, String value)
      static void | ORBIdHelper.write(OutputStream ostream, String value)
      static void | AdapterNameHelper.write(OutputStream ostream, String[] value)

    • Uses of OutputStream in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      static void | ObjectIdHelper.write(OutputStream ostream, String value)

    • Uses of OutputStream in org.omg.PortableServer

      Methods in org.omg.PortableServer that return OutputStream
      修饰符与类型 | 方法与描述
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      Methods in org.omg.PortableServer with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | CurrentHelper.write(OutputStream ostream, Current value)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      static void | POAHelper.write(OutputStream ostream, POA value)
      static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
      static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

    • Uses of OutputStream in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | NoContextHelper.write(OutputStream ostream, NoContext value)

    • Uses of OutputStream in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

    • Uses of OutputStream in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
      static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
      static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
      static void | NoServantHelper.write(OutputStream ostream, NoServant value)
      static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
      static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
      static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
      static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
      static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
      static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

    • Uses of OutputStream in org.omg.PortableServer.ServantLocatorPackage

      Methods in org.omg.PortableServer.ServantLocatorPackage with parameters of type OutputStream
      修饰符与类型 | 方法与描述
      void | CookieHolder._write(OutputStream os)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CORBA.portable.RemarshalException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.RemarshalException

  • Packages that use RemarshalException
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of RemarshalException in org.omg.CORBA

      Methods in org.omg.CORBA that throw RemarshalException
      修饰符与类型 方法与描述
      InputStream LocalObject._invoke(OutputStream output)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of RemarshalException in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that throw RemarshalException
      修饰符与类型 方法与描述
      InputStream ObjectImpl._invoke(OutputStream output)
      Invokes an operation and returns an InputStream object for reading the response.
      InputStream Delegate.invoke(Object self, OutputStream output)
      invoke is called by a stub to invoke an operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taa/rg/./.../.oo oL=k to"


Uses of Class org.omg.CORBA.portable.ServantObject

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.ServantObject

  • Packages that use ServantObject
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of ServantObject in org.omg.CORBA

      Methods in org.omg.CORBA that return ServantObject
      修饰符与类型 方法与描述
      ServantObject LocalObject._servant_preinvoke(String operation, 类 expectedType)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
      Methods in org.omg.CORBA with parameters of type ServantObject
      修饰符与类型 方法与描述
      void LocalObject._servant_postinvoke(ServantObject servant)
      Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.

    • Uses of ServantObject in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable that return ServantObject
      修饰符与类型 方法与描述
      ServantObject ObjectImpl._servant_preinvoke(String operation, 类 expectedType)
      Returns a Java reference to the local servant that should be used for sending a request for the method specified.
      ServantObject Delegate.servant_preinvoke(Object self, String operation, 类 expectedType)
      Returns a Java reference to the servant which should be used for this request.
      Methods in org.omg.CORBA.portable with parameters of type ServantObject
      修饰符与类型 方法与描述
      void ObjectImpl._servant_postinvoke(ServantObject servant)
      Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
      void Delegate.servant_postinvoke(Object self, ServantObject servant)
      servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lAl"lpspo"


Uses of Class org.omg.CORBA.portable.UnknownException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.portable.UnknownException

No usage of org.omg.CORBA.portable.UnknownException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

do�>/mwmt wgree>t>g"


Uses of Interface org.omg.CORBA.portable.BoxedValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.BoxedValueHelper

  • Packages that use BoxedValueHelper
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA_2_3.portable
    Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

    • Uses of BoxedValueHelper in org.omg.CORBA

      Classes in org.omg.CORBA that implement BoxedValueHelper
      修饰符与类型 类与描述
      class  StringValueHelper
      The Helper for StringValue.
      class  WStringValueHelper
      org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications : ORB core as defined by CORBA 2.3.1 (formal/99-10-07) IDL/Java Language Mapping as defined in ptc/00-01-08

    • Uses of BoxedValueHelper in org.omg.CORBA_2_3.portable

      Methods in org.omg.CORBA_2_3.portable with parameters of type BoxedValueHelper
      修饰符与类型 方法与描述
      Serializable InputStream.read_value(BoxedValueHelper factory)
      Unmarshalls a value type from the input stream.
      void OutputStream.write_value(Serializable value, BoxedValueHelper factory)
      Marshals a value type to the output stream.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Bet&anS" t//ae"n.mlpetCe


Uses of Interface org.omg.CORBA.portable.CustomValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.CustomValue

No usage of org.omg.CORBA.portable.CustomValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/gtv>.<llBo/ee


Uses of Interface org.omg.CORBA.portable.IDLEntity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.IDLEntity

  • Packages that use IDLEntity
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.DynAnyPackage
    Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
    org.omg.CORBA.ORBPackage
    Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CORBA.TypeCodePackage
    Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.Dynamic
    This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
    org.omg.SendingContext
    Provides support for the marshalling of value types.

    • Uses of IDLEntity in org.omg.CORBA

      Subinterfaces of IDLEntity in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  Current
      Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
      interface  DataInputStream
      Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
      interface  DataOutputStream
      Defines the methods used to write primitive data types to output streams for marshalling custom value types.
      interface  DomainManager
      Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
      interface  IDLType
      An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
      interface  IRObject
      An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
      interface  Policy
      Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
      Classes in org.omg.CORBA that implement IDLEntity
      修饰符与类型 类与描述
      class  _IDLTypeStub
      The Stub for IDLType.
      class  _PolicyStub
      The Stub for Policy.
      class  Any
      Serves as a container for any data that can be described in IDL or for any IDL primitive type.
      class  Bounds
      A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
      class  CompletionStatus
      An object that indicates whether a method had completed running when a SystemException was thrown.
      class  DefinitionKind
      The class that provides the constants used to identify the type of an Interface Repository object.
      class  NameValuePair
      Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
      class  ParameterMode
      Enumeration of parameter modes for Parameter.
      class  PolicyError
      A user exception thrown when a policy error occurs.
      class  ServiceDetail
      An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.
      class  ServiceInformation
      An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.
      class  SetOverrideType
      The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.
      class  StructMember
      Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.
      class  TypeCode
      A container for information about a specific CORBA data type.
      class  UnionMember
      A description in the Interface Repository of a member of an IDL union.
      class  UnknownUserException
      A class that contains user exceptions returned by the server.
      class  UserException
      The root class for CORBA IDL-defined user exceptions.
      class  ValueMember
      A description in the Interface Repository of a member of a value object.
      class  WrongTransaction
      The CORBA WrongTransaction user-defined exception.

    • Uses of IDLEntity in org.omg.CORBA.DynAnyPackage

      Classes in org.omg.CORBA.DynAnyPackage that implement IDLEntity
      修饰符与类型 | 类与描述
      class  Invalid
      Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
      class  InvalidSeq
      The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
      class  | InvalidValue
      class  TypeMismatch
      TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.

    • Uses of IDLEntity in org.omg.CORBA.ORBPackage

      Classes in org.omg.CORBA.ORBPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  InconsistentTypeCode
      InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
      class  InvalidName
      The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.

    • Uses of IDLEntity in org.omg.CORBA.portable

      Subinterfaces of IDLEntity in org.omg.CORBA.portable
      修饰符与类型 Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.
      interface  ValueBase
      The generated Java classes corresponding to valuetype IDL types implement this interface.

    • Uses of IDLEntity in org.omg.CORBA.TypeCodePackage

      Classes in org.omg.CORBA.TypeCodePackage that implement IDLEntity
      修饰符与类型 类与描述
      class  BadKind
      The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.

    • Uses of IDLEntity in org.omg.CosNaming

      Subinterfaces of IDLEntity in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement IDLEntity
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      class  Binding
      org/omg/CosNaming/Binding.java .
      class  BindingType
      Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
      class  NameComponent
      org/omg/CosNaming/NameComponent.java .

    • Uses of IDLEntity in org.omg.CosNaming.NamingContextExtPackage

      Classes in org.omg.CosNaming.NamingContextExtPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  InvalidAddress
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

    • Uses of IDLEntity in org.omg.CosNaming.NamingContextPackage

      Classes in org.omg.CosNaming.NamingContextPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  AlreadyBound
      org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
      class  CannotProceed
      org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
      class  NotEmpty
      org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
      class  NotFound
      org/omg/CosNaming/NamingContextPackage/NotFound.java .
      class  NotFoundReason
      Indicates the reason for not able to resolve.

    • Uses of IDLEntity in org.omg.Dynamic

      Classes in org.omg.Dynamic that implement IDLEntity
      修饰符与类型 类与描述
      class  Parameter
      org/omg/Dynamic/Parameter.java .

    • Uses of IDLEntity in org.omg.DynamicAny

      Subinterfaces of IDLEntity in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynAny
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement IDLEntity
      修饰符与类型 类与描述
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      class  NameDynAnyPair
      org/omg/DynamicAny/NameDynAnyPair.java .

    • Uses of IDLEntity in org.omg.IOP

      Subinterfaces of IDLEntity in org.omg.IOP
      修饰符与类型 Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
      Classes in org.omg.IOP that implement IDLEntity
      修饰符与类型 类与描述
      class  Encoding
      org/omg/IOP/Encoding.java .
      class  IOR
      org/omg/IOP/IOR.java .
      class  ServiceContext
      org/omg/IOP/ServiceContext.java .
      class  TaggedComponent
      org/omg/IOP/TaggedComponent.java .
      class  TaggedProfile
      org/omg/IOP/TaggedProfile.java .

    • Uses of IDLEntity in org.omg.IOP.CodecFactoryPackage

      Classes in org.omg.IOP.CodecFactoryPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  UnknownEncoding
      org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

    • Uses of IDLEntity in org.omg.IOP.CodecPackage

      Classes in org.omg.IOP.CodecPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  FormatMismatch
      org/omg/IOP/CodecPackage/FormatMismatch.java .
      class  InvalidTypeForEncoding
      org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .

    • Uses of IDLEntity in org.omg.PortableInterceptor

      Subinterfaces of IDLEntity in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ObjectReferenceFactory
      The object reference factory.
      interface  ObjectReferenceTemplate
      The object reference template.
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      Classes in org.omg.PortableInterceptor that implement IDLEntity
      修饰符与类型 类与描述
      class  InvalidSlot
      org/omg/PortableInterceptor/InvalidSlot.java .

    • Uses of IDLEntity in org.omg.PortableInterceptor.ORBInitInfoPackage

      Classes in org.omg.PortableInterceptor.ORBInitInfoPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  DuplicateName
      org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .

    • Uses of IDLEntity in org.omg.PortableServer

      Subinterfaces of IDLEntity in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
      interface  POA
      A POA object manages the implementation of a collection of objects.
      interface  POAManager
      Each POA object has an associated POAManager object.
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
      Classes in org.omg.PortableServer that implement IDLEntity
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ForwardRequest
      org/omg/PortableServer/ForwardRequest.java .
      class  IdAssignmentPolicyValue
      The IdAssignmentPolicyValue can have the following values.
      class  IdUniquenessPolicyValue
      IdUniquenessPolicyValue can have the following values.
      class  ImplicitActivationPolicyValue
      ImplicitActivationPolicyValue has the following semantics.
      class  LifespanPolicyValue
      The LifespanPolicyValue can have the following values.
      class  RequestProcessingPolicyValue
      The RequestProcessingPolicyValue can have the following values.
      class  ServantRetentionPolicyValue
      ServantRetentionPolicyValue can have the following values.
      class  ThreadPolicyValue
      The ThreadPolicyValue can have the following values.

    • Uses of IDLEntity in org.omg.PortableServer.CurrentPackage

      Classes in org.omg.PortableServer.CurrentPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  NoContext
      org/omg/PortableServer/CurrentPackage/NoContext.java .

    • Uses of IDLEntity in org.omg.PortableServer.POAManagerPackage

      Classes in org.omg.PortableServer.POAManagerPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  AdapterInactive
      org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
      class  State
      Specifies the states for the POAManager

    • Uses of IDLEntity in org.omg.PortableServer.POAPackage

      Classes in org.omg.PortableServer.POAPackage that implement IDLEntity
      修饰符与类型 类与描述
      class  AdapterAlreadyExists
      org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
      class  AdapterNonExistent
      org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
      class  InvalidPolicy
      org/omg/PortableServer/POAPackage/InvalidPolicy.java .
      class  NoServant
      org/omg/PortableServer/POAPackage/NoServant.java .
      class  ObjectAlreadyActive
      org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
      class  ObjectNotActive
      org/omg/PortableServer/POAPackage/ObjectNotActive.java .
      class  ServantAlreadyActive
      org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
      class  ServantNotActive
      org/omg/PortableServer/POAPackage/ServantNotActive.java .
      class  WrongAdapter
      org/omg/PortableServer/POAPackage/WrongAdapter.java .
      class  WrongPolicy
      org/omg/PortableServer/POAPackage/WrongPolicy.java .

    • Uses of IDLEntity in org.omg.SendingContext

      Subinterfaces of IDLEntity in org.omg.SendingContext
      修饰符与类型 Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.CORBA.portable.InvokeHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.InvokeHandler

  • Packages that use InvokeHandler
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of InvokeHandler in javax.rmi.CORBA

      Subinterfaces of InvokeHandler in javax.rmi.CORBA
      修饰符与类型 Interface and Description
      interface  Tie
      Defines methods which all RMI-IIOP server side ties must implement.

    • Uses of InvokeHandler in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement InvokeHandler
      修饰符与类型 类与描述
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of InvokeHandler in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement InvokeHandler
      修饰符与类型 类与描述
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yu(tgatDleeeUi// c> "cc>t


Uses of Interface org.omg.CORBA.portable.ResponseHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.ResponseHandler

  • Packages that use ResponseHandler
    软件包 描述
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ResponseHandler in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type ResponseHandler
      修饰符与类型 方法与描述
      OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
      Invoked by the ORB to dispatch a request to the servant.

    • Uses of ResponseHandler in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type ResponseHandler
      修饰符与类型 | 方法与描述
      OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

    • Uses of ResponseHandler in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type ResponseHandler
      修饰符与类型 | 方法与描述
      OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
      OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e">mlcyr=.lo.


Uses of Interface org.omg.CORBA.portable.Streamable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.Streamable

  • Packages that use Streamable
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableServer.ServantLocatorPackage
    Provides classes and interfaces for locating the servant.

    • Uses of Streamable in org.omg.CORBA

      Classes in org.omg.CORBA that implement Streamable
      修饰符与类型 类与描述
      class  AnyHolder
      The Holder for Any.
      class  AnySeqHolder
      The Holder for AnySeq.
      class  BooleanHolder
      The Holder for Boolean.
      class  BooleanSeqHolder
      The Holder for BooleanSeq.
      class  ByteHolder
      The Holder for Byte.
      class  CharHolder
      The Holder for Char.
      class  CharSeqHolder
      The Holder for CharSeq.
      class  CurrentHolder
      The Holder for Current.
      class  DoubleHolder
      The Holder for Double.
      class  DoubleSeqHolder
      The Holder for DoubleSeq.
      class  FixedHolder
      The Holder for Fixed.
      class  FloatHolder
      The Holder for Float.
      class  FloatSeqHolder
      The Holder for FloatSeq.
      class  IntHolder
      The Holder for Int.
      class  LongHolder
      The Holder for Long.
      class  LongLongSeqHolder
      The Holder for LongLongSeq.
      class  LongSeqHolder
      The Holder for LongSeq.
      class  ObjectHolder
      The Holder for Object.
      class  OctetSeqHolder
      The Holder for OctetSeq.
      class  ParameterModeHolder
      Enumeration of parameter modes for Parameter.
      class  PolicyErrorHolder
      Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
      class  PolicyHolder
      The Holder for Policy.
      class  PolicyListHolder
      The Holder for PolicyList.
      class  PrincipalHolder
      Deprecated.
      Deprecated by CORBA 2.2.
      class  ServiceInformationHolder
      The Holder for ServiceInformation.
      class  ShortHolder
      The Holder for Short.
      class  ShortSeqHolder
      The Holder for ShortSeq.
      class  StringHolder
      The Holder for String.
      class  StringSeqHolder
      An array of Strings
      class  TypeCodeHolder
      The Holder for TypeCode.
      class  ULongLongSeqHolder
      The Holder for ULongLongSeq.
      class  ULongSeqHolder
      The Holder for ULongSeq.
      class  UnknownUserExceptionHolder
      The Holder for UnknownUserException.
      class  UShortSeqHolder
      The Holder for UShortSeq.
      class  ValueBaseHolder
      The Holder for ValueBase.
      class  WCharSeqHolder
      The Holder for WCharSeq.
      class  WrongTransactionHolder
      The Holder for WrongTransaction.
      class  WStringSeqHolder
      An array of WStrings
      Methods in org.omg.CORBA that return Streamable
      修饰符与类型 方法与描述
      Streamable Any.extract_Streamable()
      Extracts a Streamable from this Any object's value field.
      Methods in org.omg.CORBA with parameters of type Streamable
      修饰符与类型 方法与描述
      void Any.insert_Streamable(Streamable s)
      Inserts the given Streamable object into this Any object's value field.

    • Uses of Streamable in org.omg.CORBA.portable

      Subinterfaces of Streamable in org.omg.CORBA.portable
      修饰符与类型 Interface and Description
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.

    • Uses of Streamable in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement Streamable
      修饰符与类型 类与描述
      class  BindingHolder
      org/omg/CosNaming/BindingHolder.java .
      class  BindingIteratorHolder
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  BindingListHolder
      List of Bindings.
      class  BindingTypeHolder
      Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
      class  NameComponentHolder
      org/omg/CosNaming/NameComponentHolder.java .
      class  NameHolder
      A name is a sequence of name components.
      class  NamingContextExtHolder
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextHolder
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of Streamable in org.omg.CosNaming.NamingContextExtPackage

      Classes in org.omg.CosNaming.NamingContextExtPackage that implement Streamable
      修饰符与类型 类与描述
      class  InvalidAddressHolder
      org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .

    • Uses of Streamable in org.omg.CosNaming.NamingContextPackage

      Classes in org.omg.CosNaming.NamingContextPackage that implement Streamable
      修饰符与类型 类与描述
      class  AlreadyBoundHolder
      org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
      class  CannotProceedHolder
      org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
      class  InvalidNameHolder
      org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
      class  NotEmptyHolder
      org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
      class  NotFoundHolder
      org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
      class  NotFoundReasonHolder
      Indicates the reason for not able to resolve.

    • Uses of Streamable in org.omg.IOP

      Classes in org.omg.IOP that implement Streamable
      修饰符与类型 类与描述
      class  IORHolder
      org/omg/IOP/IORHolder.java .
      class  MultipleComponentProfileHolder
      An array of tagged components, forming a multiple component profile.
      class  ServiceContextHolder
      org/omg/IOP/ServiceContextHolder.java .
      class  ServiceContextListHolder
      An array of service contexts, forming a service context list.
      class  TaggedComponentHolder
      org/omg/IOP/TaggedComponentHolder.java .
      class  TaggedProfileHolder
      org/omg/IOP/TaggedProfileHolder.java .

    • Uses of Streamable in org.omg.PortableInterceptor

      Classes in org.omg.PortableInterceptor that implement Streamable
      修饰符与类型 类与描述
      class  IORInterceptor_3_0Holder
      org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
      class  ObjectReferenceFactoryHolder
      The object reference factory.
      class  ObjectReferenceTemplateHolder
      The object reference template.
      class  ObjectReferenceTemplateSeqHolder
      Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Uses of Streamable in org.omg.PortableServer.ServantLocatorPackage

      Classes in org.omg.PortableServer.ServantLocatorPackage that implement Streamable
      修饰符与类型 类与描述
      class  CookieHolder
      The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.CORBA.portable.StreamableValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.StreamableValue

No usage of org.omg.CORBA.portable.StreamableValue
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

twePg.o"r>>>pe..i3 t


Uses of Interface org.omg.CORBA.portable.ValueBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.ValueBase

  • Packages that use ValueBase
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ValueBase in org.omg.CORBA

      Subinterfaces of ValueBase in org.omg.CORBA
      修饰符与类型 Interface and Description
      interface  DataInputStream
      Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
      interface  DataOutputStream
      Defines the methods used to write primitive data types to output streams for marshalling custom value types.

    • Uses of ValueBase in org.omg.CORBA.portable

      Subinterfaces of ValueBase in org.omg.CORBA.portable
      修饰符与类型 Interface and Description
      interface  CustomValue
      An extension of ValueBase that is implemented by custom value types.
      interface  StreamableValue
      Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.

    • Uses of ValueBase in org.omg.PortableInterceptor

      Subinterfaces of ValueBase in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ObjectReferenceFactory
      The object reference factory.
      interface  ObjectReferenceTemplate
      The object reference template.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iepanl>/.eehgels.


Uses of Interface org.omg.CORBA.portable.ValueFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.ValueFactory

  • Packages that use ValueFactory
    软件包 描述
    org.omg.CORBA_2_3
    The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

    • Uses of ValueFactory in org.omg.CORBA_2_3

      Methods in org.omg.CORBA_2_3 that return ValueFactory
      修饰符与类型 | 方法与描述
      ValueFactory | ORB.lookup_value_factory(String id)
      ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)
      Methods in org.omg.CORBA_2_3 with parameters of type ValueFactory
      修饰符与类型 | 方法与描述
      ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

BeAmorg/....."<<<>e.v-i//


Uses of Interface org.omg.CORBA.portable.ValueInputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.ValueInputStream

No usage of org.omg.CORBA.portable.ValueInputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/a.re><<>cccs=""atdn>


Uses of Interface org.omg.CORBA.portable.ValueOutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CORBA.portable.ValueOutputStream

No usage of org.omg.CORBA.portable.ValueOutputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3y�,rr%/鷛怳e


BadKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.TypeCodePackage

类 BadKind

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.TypeCodePackage.BadKind
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class BadKind
extends UserException
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object. For example, invoking the method discriminator_type() on an instance of TypeCode that does not represent an IDL union will cause the exception BadKind to be thrown.
    从以下版本开始：
    JDK1.2
    另请参见：
    TypeCode

    • 构造方法摘要

      Constructors
      构造方法与描述
      BadKind()
      Constructs a BadKind exception with no reason message.
      BadKind(String reason)
      Constructs a BadKind exception with the specified reason message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • BadKind

        public BadKind()
        Constructs a BadKind exception with no reason message.

      • BadKind

        public BadKind(String reason)
        Constructs a BadKind exception with the specified reason message.
        参数：
        reason - the String containing a reason message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

su /p irs/eej�


Bounds

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CORBA.TypeCodePackage

类 Bounds

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CORBA.TypeCodePackage.Bounds
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Bounds
extends UserException
    Provides the TypeCode operations member_name(), member_type(), and member_label. These methods raise Bounds when the index parameter is greater than or equal to the number of members constituting the type.
    从以下版本开始：
    JDK1.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      Bounds()
      Constructs a Bounds exception with no reason message.
      Bounds(String reason)
      Constructs a Bounds exception with the specified reason message.

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • Bounds

        public Bounds()
        Constructs a Bounds exception with no reason message.

      • Bounds

        public Bounds(String reason)
        Constructs a Bounds exception with the specified reason message.
        参数：
        reason - the String containing a reason message
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r kmfm momr,morrdnkh锾ㄊ濉〖霉脊减 蚭


org.omg.CORBA.TypeCodePackage

Exceptions

  • BadKind
  • Bounds
�


org.omg.CORBA.TypeCodePackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA.TypeCodePackage

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

请参见： 描述

  • Exception Summary
    Exception 描述
    BadKind
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
    Bounds
    Provides the TypeCode operations member_name(), member_type(), and member_label.

软件包 org.omg.CORBA.TypeCodePackage Description

Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.

Related Documentation

For an overview, please see:
  • comments on the CORBA package
从以下版本开始：
JDK1.2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/.e.eaf=a< ffaeeen(Cts.#.


org.omg.CORBA.TypeCodePackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA.TypeCodePackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.TypeCodePackage.Bounds
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nftly>s -=


Uses of Package org.omg.CORBA.TypeCodePackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA.TypeCodePackage

  • Packages that use org.omg.CORBA.TypeCodePackage
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
  • Classes in org.omg.CORBA.TypeCodePackage used by org.omg.CORBA
    类与描述
    BadKind
    The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
    Bounds
    Provides the TypeCode operations member_name(), member_type(), and member_label.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/woopR>ulvl><>�.湘竤远


Uses of Class org.omg.CORBA.TypeCodePackage.BadKind

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TypeCodePackage.BadKind

  • Packages that use BadKind
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of BadKind in org.omg.CORBA

      Methods in org.omg.CORBA that throw BadKind
      修饰符与类型 方法与描述
      abstract TypeCode TypeCode.concrete_base_type()
      Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
      abstract TypeCode TypeCode.content_type()
      Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
      abstract int TypeCode.default_index()
      Returns the index of the default member, or -1 if there is no default member.
      abstract TypeCode TypeCode.discriminator_type()
      Returns a TypeCode object describing all non-default member labels.
      abstract short TypeCode.fixed_digits()
      Returns the number of digits in the fixed type described by this TypeCode object.
      abstract short TypeCode.fixed_scale()
      Returns the scale of the fixed type described by this TypeCode object.
      abstract String TypeCode.id()
      Retrieves the RepositoryId globally identifying the type of this TypeCode object.
      abstract int TypeCode.length()
      Returns the number of elements in the type described by this TypeCode object.
      abstract int TypeCode.member_count()
      Retrieves the number of members in the type described by this TypeCode object.
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String TypeCode.member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short TypeCode.member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
      abstract String TypeCode.name()
      Retrieves the simple name identifying this TypeCode object within its enclosing scope.
      abstract short TypeCode.type_modifier()
      Returns a constant indicating the modifier of the value type that this TypeCode object describes.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<1bv>L


Uses of Class org.omg.CORBA.TypeCodePackage.Bounds

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA.TypeCodePackage.Bounds

  • Packages that use Bounds
    软件包 描述
    org.omg.CORBA
    Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).

    • Uses of Bounds in org.omg.CORBA

      Methods in org.omg.CORBA that throw Bounds
      修饰符与类型 方法与描述
      abstract Any TypeCode.member_label(int index)
      Retrieves the label of the union member identified by the given index.
      abstract String TypeCode.member_name(int index)
      Retrieves the simple name of the member identified by the given index.
      abstract TypeCode TypeCode.member_type(int index)
      Retrieves the TypeCode object describing the type of the member identified by the given index.
      abstract short TypeCode.member_visibility(int index)
      Returns the constant that indicates the visibility of the member at the given index.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.er menuiiihbiimemnear>v


ORB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA_2_3

类 ORB

  • java.lang.Object
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB

  • public abstract class ORB
extends ORB
    A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ORB()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Object | get_value_def(String repid)
      ValueFactory | lookup_value_factory(String id)
      ValueFactory | register_value_factory(String id, ValueFactory factory)
      void | set_delegate(Object wrapper)
      void | unregister_value_factory(String id)

      • 方法 - 继承于类 org.omg.CORBA.ORB

        connect, create_abstract_interface_tc, create_alias_tc, create_any, create_array_tc, create_basic_dyn_any, create_context_list, create_dyn_any, create_dyn_array, create_dyn_enum, create_dyn_sequence, create_dyn_struct, create_dyn_union, create_enum_tc, create_environment, create_exception_list, create_exception_tc, create_fixed_tc, create_interface_tc, create_list, create_named_value, create_native_tc, create_operation_list, create_output_stream, create_policy, create_recursive_sequence_tc, create_recursive_tc, create_sequence_tc, create_string_tc, create_struct_tc, create_union_tc, create_value_box_tc, create_value_tc, create_wstring_tc, destroy, disconnect, get_current, get_default_context, get_next_response, get_primitive_tc, get_service_information, init, init, init, list_initial_services, object_to_string, perform_work, poll_next_response, resolve_initial_references, run, send_multiple_requests_deferred, send_multiple_requests_oneway, set_parameters, set_parameters, shutdown, string_to_object, work_pending

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ORB

        public ORB()

    • 方法详细信息

      • register_value_factory

        public ValueFactory register_value_factory(String id,
                                  ValueFactory factory)

      • unregister_value_factory

        public void unregister_value_factory(String id)

      • lookup_value_factory

        public ValueFactory lookup_value_factory(String id)

      • get_value_def

        public Object get_value_def(String repid)
                     throws BAD_PARAM
        抛出：
        BAD_PARAM
        另请参见：
        CORBA_2_3 package comments for unimplemented features

      • set_delegate

        public void set_delegate(Object wrapper)
        另请参见：
        CORBA_2_3 package comments for unimplemented features
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/=&n&p&<;


org.omg.CORBA_2_3

Classes

  • ORB
1


org.omg.CORBA_2_3

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA_2_3

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

请参见： 描述

  • Class Summary
    类 描述
    ORB
    A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.

软件包 org.omg.CORBA_2_3 Description

The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

The following methods in the abstract class org.omg.CORBA_2_3.ORB are unimplemented:

  • public org.omg.CORBA.portable.ValueFactory register_value_factory(String id, org.omg.CORBA.portable.ValueFactory factory)
  • public void unregister_value_factory(String id)
  • public org.omg.CORBA.portable.ValueFactory lookup_value_factory(String id)
  • public org.omg.CORBA.Object get_value_def(String repid)
  • public void set_delegate(java.lang.Object wrapper)
从以下版本开始：
JDK 1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/Cgc/.r/.fe=//f,>>ecceB.=r


org.omg.CORBA_2_3 Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA_2_3

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k"sgiaS"kkkltpp==sva>


Uses of Package org.omg.CORBA_2_3

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA_2_3

No usage of org.omg.CORBA_2_3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oTnyidad.sl ssCCpi w


Uses of Class org.omg.CORBA_2_3.ORB

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA_2_3.ORB

No usage of org.omg.CORBA_2_3.ORB
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sxn el


Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA_2_3.portable

类 Delegate

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate

  • public abstract class Delegate
extends Delegate
    Delegate class provides the ORB vendor specific implementation of CORBA object. It extends org.omg.CORBA.portable.Delegate and provides new methods that were defined by CORBA 2.3.
    从以下版本开始：
    JDK1.2
    另请参见：
    Delegate

    • 构造方法摘要

      Constructors
      构造方法与描述
      Delegate()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String get_codebase(Object self)
      Returns the codebase for object reference provided.

      • 方法 - 继承于类 org.omg.CORBA.portable.Delegate

        create_request, create_request, duplicate, equals, get_domain_managers, get_interface_def, get_policy, hash, hashCode, invoke, is_a, is_equivalent, is_local, non_existent, orb, release, releaseReply, request, request, servant_postinvoke, servant_preinvoke, set_policy_override, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Delegate

        public Delegate()

    • 方法详细信息

      • get_codebase

        public String get_codebase(Object self)
        Returns the codebase for object reference provided.
        参数：
        self - the object reference whose codebase needs to be returned.
        返回：
        the codebase as a space delimited list of url strings or null if none.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o o/& /ih


InputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA_2_3.portable

类 InputStream

  • java.lang.Object
    • java.io.InputStream
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
  • 所有已实现的接口：
    Closeable, AutoCloseable

    public abstract class InputStream
extends InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream. It extends org.omg.CORBA.portable.InputStream. This class defines new methods that were added for CORBA 2.3.
    从以下版本开始：
    JDK1.2
    另请参见：
    InputStream

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputStream()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object read_abstract_interface()
      Unmarshal the value object or a suitable stub object.
      Object read_abstract_interface(类 clz)
      Unmarshal the class object or the stub class corresponding to the passed type.
      Serializable read_value()
      Unmarshalls a value type from the input stream.
      Serializable read_value(BoxedValueHelper factory)
      Unmarshalls a value type from the input stream.
      Serializable read_value(类 clz)
      Unmarshalls a value type from the input stream.
      Serializable read_value(Serializable value)
      Unmarshalls a value type from the input stream.
      Serializable read_value(String rep_id)
      Unmarshalls a value type from the input stream.

      • 方法 - 继承于类 org.omg.CORBA.portable.InputStream

        orb, read_any, read_boolean_array, read_boolean, read_char_array, read_char, read_Context, read_double_array, read_double, read_fixed, read_float_array, read_float, read_long_array, read_long, read_longlong_array, read_longlong, read_Object, read_Object, read_octet_array, read_octet, read_Principal, read_short_array, read_short, read_string, read_TypeCode, read_ulong_array, read_ulong, read_ulonglong_array, read_ulonglong, read_ushort_array, read_ushort, read_wchar_array, read_wchar, read_wstring, read

      • 方法 - 继承于类 java.io.InputStream

        available, close, mark, markSupported, read, read, reset, skip

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputStream

        public InputStream()

    • 方法详细信息

      • read_value

        public Serializable read_value()
        Unmarshalls a value type from the input stream.
        返回：
        the value type unmarshalled from the input stream

      • read_value

        public Serializable read_value(类 clz)
        Unmarshalls a value type from the input stream.
        参数：
        clz - is the declared type of the value to be unmarshalled
        返回：
        the value unmarshalled from the input stream

      • read_value

        public Serializable read_value(BoxedValueHelper factory)
        Unmarshalls a value type from the input stream.
        参数：
        factory - is the instance fo the helper to be used for unmarshalling the value type
        返回：
        the value unmarshalled from the input stream

      • read_value

        public Serializable read_value(String rep_id)
        Unmarshalls a value type from the input stream.
        参数：
        rep_id - identifies the type of the value to be unmarshalled
        返回：
        value type unmarshalled from the input stream

      • read_value

        public Serializable read_value(Serializable value)
        Unmarshalls a value type from the input stream.
        参数：
        value - is an uninitialized value which is added to the orb's indirection table before calling Streamable._read() or CustomMarshal.unmarshal() to unmarshal the value.
        返回：
        value type unmarshalled from the input stream

      • read_abstract_interface

        public Object read_abstract_interface()
        Unmarshal the value object or a suitable stub object.
        返回：
        ORB runtime returns the value object or a suitable stub object.

      • read_abstract_interface

        public Object read_abstract_interface(类 clz)
        Unmarshal the class object or the stub class corresponding to the passed type.
        参数：
        clz - is the Class object for the stub class which corresponds to the type that is statically expected.
        返回：
        ORB runtime returns the value object or a suitable stub object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n ll_gt.h."/tak.io磈/.cjnb"s lへA


ObjectImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA_2_3.portable

类 ObjectImpl

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
  • 所有已实现的接口：
    Object
    直接已知子类：
    Stub

    public abstract class ObjectImpl
extends ObjectImpl
    ObjectImpl class is the base class for all stubs. It provides the basic delegation mechanism. It extends org.omg.CORBA.portable.ObjectImpl and provides new methods defined by CORBA 2.3.
    从以下版本开始：
    JDK1.2
    另请参见：
    ObjectImpl

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectImpl()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String _get_codebase()
      Returns the codebase for this object reference.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ObjectImpl

        public ObjectImpl()

    • 方法详细信息

      • _get_codebase

        public String _get_codebase()
        Returns the codebase for this object reference.
        返回：
        the codebase as a space delimited list of url strings or null if none.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

temgv/.a/..//....e .f...//a.f..v/a...acg>


org.omg.CORBA_2_3.portable

Classes

  • Delegate
  • InputStream
  • ObjectImpl
  • OutputStream


org.omg.CORBA_2_3.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CORBA_2_3.portable

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

请参见： 描述

  • Class Summary
    类 描述
    Delegate
    Delegate class provides the ORB vendor specific implementation of CORBA object.
    InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream.
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
    OutputStream
    OutputStream provides interface for writing of all of the mapped IDL type to the stream.

软件包 org.omg.CORBA_2_3.portable Description

Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.

从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iar/ij/av/..aa/.ggpltir)"e


org.omg.CORBA_2_3.portable Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CORBA_2_3.portable

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d"repsp


OutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CORBA_2_3.portable

类 OutputStream

  • java.lang.Object
    • java.io.OutputStream
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
  • 所有已实现的接口：
    Closeable, Flushable, AutoCloseable

    public abstract class OutputStream
extends OutputStream
    OutputStream provides interface for writing of all of the mapped IDL type to the stream. It extends org.omg.CORBA.portable.OutputStream, and defines new methods defined by CORBA 2.3.
    从以下版本开始：
    JDK1.2
    另请参见：
    OutputStream

    • 构造方法摘要

      Constructors
      构造方法与描述
      OutputStream()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void write_abstract_interface(Object obj)
      Marshals a value object or a stub object.
      void write_value(Serializable value)
      Marshals a value type to the output stream.
      void write_value(Serializable value, BoxedValueHelper factory)
      Marshals a value type to the output stream.
      void write_value(Serializable value, 类 clz)
      Marshals a value type to the output stream.
      void write_value(Serializable value, String repository_id)
      Marshals a value type to the output stream.

      • 方法 - 继承于类 org.omg.CORBA.portable.OutputStream

        create_input_stream, orb, write_any, write_boolean_array, write_boolean, write_char_array, write_char, write_Context, write_double_array, write_double, write_fixed, write_float_array, write_float, write_long_array, write_long, write_longlong_array, write_longlong, write_Object, write_octet_array, write_octet, write_Principal, write_short_array, write_short, write_string, write_TypeCode, write_ulong_array, write_ulong, write_ulonglong_array, write_ulonglong, write_ushort_array, write_ushort, write_wchar_array, write_wchar, write_wstring, write

      • 方法 - 继承于类 java.io.OutputStream

        close, flush, write, write

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • OutputStream

        public OutputStream()

    • 方法详细信息

      • write_value

        public void write_value(Serializable value)
        Marshals a value type to the output stream.
        参数：
        value - is the acutal value to write

      • write_value

        public void write_value(Serializable value,
               类 clz)
        Marshals a value type to the output stream.
        参数：
        value - is the acutal value to write
        clz - is the declared type of the value to be marshaled

      • write_value

        public void write_value(Serializable value,
               String repository_id)
        Marshals a value type to the output stream.
        参数：
        value - is the acutal value to write
        repository_id - identifies the type of the value type to be marshaled

      • write_value

        public void write_value(Serializable value,
               BoxedValueHelper factory)
        Marshals a value type to the output stream.
        参数：
        value - is the acutal value to write
        factory - is the instance of the helper to be used for marshaling the boxed value

      • write_abstract_interface

        public void write_abstract_interface(Object obj)
        Marshals a value object or a stub object.
        参数：
        obj - the actual value object to marshal or the stub to be marshalled
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l..=..//.../..el眅-l/mtta�


Uses of Package org.omg.CORBA_2_3.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CORBA_2_3.portable

  • Packages that use org.omg.CORBA_2_3.portable
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
  • Classes in org.omg.CORBA_2_3.portable used by javax.rmi.CORBA
    类与描述
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
  • Classes in org.omg.CORBA_2_3.portable used by org.omg.CORBA.portable
    类与描述
    InputStream
    InputStream provides for the reading of all of the mapped IDL types from the stream.
  • Classes in org.omg.CORBA_2_3.portable used by org.omg.stub.java.rmi
    类与描述
    ObjectImpl
    ObjectImpl class is the base class for all stubs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>M litt/llaf>=箆yR/oe>e


Uses of Class org.omg.CORBA_2_3.portable.Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA_2_3.portable.Delegate

No usage of org.omg.CORBA_2_3.portable.Delegate
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st/鬉t


Uses of Class org.omg.CORBA_2_3.portable.InputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA_2_3.portable.InputStream

  • Packages that use InputStream
    软件包 描述
    org.omg.CORBA.portable
    Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.

    • Uses of InputStream in org.omg.CORBA.portable

      Methods in org.omg.CORBA.portable with parameters of type InputStream
      修饰符与类型 方法与描述
      Serializable ValueFactory.read_value(InputStream is)
      Is called by the ORB runtime while in the process of unmarshaling a value type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mn> =iraClc


Uses of Class org.omg.CORBA_2_3.portable.ObjectImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA_2_3.portable.ObjectImpl

  • Packages that use ObjectImpl
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.stub.java.rmi
    Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

    • Uses of ObjectImpl in javax.rmi.CORBA

      Subclasses of ObjectImpl in javax.rmi.CORBA
      修饰符与类型 类与描述
      class  Stub
      Base class from which all RMI-IIOP stubs must inherit.

    • Uses of ObjectImpl in org.omg.stub.java.rmi

      Subclasses of ObjectImpl in org.omg.stub.java.rmi
      修饰符与类型 类与描述
      class  _Remote_Stub
      This class provides the Stub for the Remote Type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ml lr aal&/la/eig


Uses of Class org.omg.CORBA_2_3.portable.OutputStream

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CORBA_2_3.portable.OutputStream

No usage of org.omg.CORBA_2_3.portable.OutputStream
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming

类 Binding

  • java.lang.Object
    • org.omg.CosNaming.Binding
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Binding
extends Object
implements IDLEntity
    org/omg/CosNaming/Binding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NameComponent[] binding_name
      BindingType binding_type

    • 构造方法摘要

      Constructors
      构造方法与描述
      Binding()
      Binding(NameComponent[] _binding_name, BindingType _binding_type)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • binding_name

        public NameComponent[] binding_name

      • binding_type

        public BindingType binding_type

    • 构造方法详细信息

      • Binding

        public Binding()

      • Binding

        public Binding(NameComponent[] _binding_name,
       BindingType _binding_type)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bnalvvrnmpl<鈇an.�


BindingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingHelper

  • public abstract class BindingHelper
extends Object
    org/omg/CosNaming/BindingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Binding | extract(Any a)
      static String | id()
      static void | insert(Any a, Binding that)
      static Binding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Binding value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BindingHelper

        public BindingHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Binding that)

      • extract

        public static Binding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Binding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Binding value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//he.frE""lnv ntt


BindingHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingHolder
  • 所有已实现的接口：
    Streamable

    public final class BindingHolder
extends Object
implements Streamable
    org/omg/CosNaming/BindingHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Binding value

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingHolder()
      BindingHolder(Binding initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Binding value

    • 构造方法详细信息

      • BindingHolder

        public BindingHolder()

      • BindingHolder

        public BindingHolder(Binding initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y>"=sprryRntba


BindingIterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CosNaming

Interface BindingIterator

  • All Superinterfaces:
    BindingIteratorOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub

    public interface BindingIterator
extends BindingIteratorOperations, Object, IDLEntity
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>o" a>na>3 >33ih<


BindingIteratorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingIteratorHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingIteratorHelper

  • public abstract class BindingIteratorHelper
extends Object
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingIteratorHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static BindingIterator | extract(Any a)
      static String | id()
      static void | insert(Any a, BindingIterator that)
      static BindingIterator | narrow(Object obj)
      static BindingIterator | read(InputStream istream)
      static TypeCode | type()
      static BindingIterator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, BindingIterator value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BindingIteratorHelper

        public BindingIteratorHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          BindingIterator that)

      • extract

        public static BindingIterator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static BindingIterator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         BindingIterator value)

      • narrow

        public static BindingIterator narrow(Object obj)

      • unchecked_narrow

        public static BindingIterator unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rh.ry/i1�"slRa/v<


BindingIteratorHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingIteratorHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingIteratorHolder
  • 所有已实现的接口：
    Streamable

    public final class BindingIteratorHolder
extends Object
implements Streamable
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      BindingIterator value

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingIteratorHolder()
      BindingIteratorHolder(BindingIterator initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public BindingIterator value

    • 构造方法详细信息

      • BindingIteratorHolder

        public BindingIteratorHolder()

      • BindingIteratorHolder

        public BindingIteratorHolder(BindingIterator initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a=


_BindingIteratorImplBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 _BindingIteratorImplBase

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations

    public abstract class _BindingIteratorImplBase
extends DynamicImplementation
implements BindingIterator
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      _BindingIteratorImplBase()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void | invoke(ServerRequest r)

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _BindingIteratorImplBase

        public _BindingIteratorImplBase()

    • 方法详细信息

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        重载：
        _ids in class DynamicImplementation
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance

      • invoke

        public void invoke(ServerRequest r)
        重载：
        invoke in class DynamicImplementation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--"b_aar"=n=ann"odd>/>i>/>l>ptaNNN"Eg


BindingIteratorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CosNaming

Interface BindingIteratorOperations

  • All Known Subinterfaces:
    BindingIterator
    All Known Implementing Classes:
    _BindingIteratorImplBase, _BindingIteratorStub, BindingIteratorPOA

    public interface BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      This operation destroys the iterator.
      boolean next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean next_one(BindingHolder b)
      This operation returns the next binding.

    • 方法详细信息

      • next_one

        boolean next_one(BindingHolder b)
        This operation returns the next binding. If there are no more bindings, false is returned.
        参数：
        b - the returned binding

      • next_n

        boolean next_n(int how_many,
             BindingListHolder bl)
        This operation returns at most the requested number of bindings.
        参数：
        how_many - the maximum number of bindings tro return

        bl - the returned bindings

      • destroy

        void destroy()
        This operation destroys the iterator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" >he" =" ann aas">>/=us ae


BindingIteratorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingIteratorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA
  • 所有已实现的接口：
    InvokeHandler, BindingIteratorOperations

    public abstract class BindingIteratorPOA
extends Servant
implements BindingIteratorOperations, InvokeHandler
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingIteratorPOA()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      BindingIterator _this()
      BindingIterator | _this(ORB orb)

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CosNaming.BindingIteratorOperations

        destroy, next_n, next_one

    • 构造方法详细信息

      • BindingIteratorPOA

        public BindingIteratorPOA()

    • 方法详细信息

      • _invoke

        public OutputStream _invoke(String $method,
                   InputStream in,
                   ResponseHandler $rh)
        从接口复制的描述： InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        指定者：
        _invoke in interface InvokeHandler
        参数：
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        指定者：
        _all_interfaces in class Servant
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.

      • _this

        public BindingIterator _this()

      • _this

        public BindingIterator _this(ORB orb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rq >lshr"dla)c >Se>t薵o藅h


_BindingIteratorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 _BindingIteratorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._BindingIteratorStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations

    public class _BindingIteratorStub
extends ObjectImpl
implements BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations. The bindings iterator is obtained by using the list method on the NamingContext.
    另请参见：
    NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder), Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      _BindingIteratorStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void destroy()
      This operation destroys the iterator.
      boolean next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean next_one(BindingHolder b)
      This operation returns the next binding.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _BindingIteratorStub

        public _BindingIteratorStub()

    • 方法详细信息

      • next_one

        public boolean next_one(BindingHolder b)
        This operation returns the next binding. If there are no more bindings, false is returned.
        指定者：
        next_one in interface BindingIteratorOperations
        参数：
        b - the returned binding

      • next_n

        public boolean next_n(int how_many,
             BindingListHolder bl)
        This operation returns at most the requested number of bindings.
        指定者：
        next_n in interface BindingIteratorOperations
        参数：
        how_many - the maximum number of bindings tro return

        bl - the returned bindings

      • destroy

        public void destroy()
        This operation destroys the iterator.
        指定者：
        destroy in interface BindingIteratorOperations

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdn i ii p> >o tsraoehh


BindingListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingListHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingListHelper

  • public abstract class BindingListHelper
extends Object
    List of Bindings.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingListHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Binding[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Binding[] that)
      static Binding[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Binding[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BindingListHelper

        public BindingListHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Binding[] that)

      • extract

        public static Binding[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Binding[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Binding[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r.elprRorROBBROOonvvd aa..o.m//klu


BindingListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingListHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingListHolder
  • 所有已实现的接口：
    Streamable

    public final class BindingListHolder
extends Object
implements Streamable
    List of Bindings.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Binding[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingListHolder()
      BindingListHolder(Binding[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Binding[] value

    • 构造方法详细信息

      • BindingListHolder

        public BindingListHolder()

      • BindingListHolder

        public BindingListHolder(Binding[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>>s4_c>_>" >""ksssd<�/doi<蔯b/jdebb>


BindingType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingType

  • java.lang.Object
    • org.omg.CosNaming.BindingType
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class BindingType
extends Object
implements IDLEntity
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _ncontext
      static int | _nobject
      static BindingType | ncontext
      static BindingType | nobject

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | BindingType(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static BindingType | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _nobject

        public static final int _nobject
        另请参见：
        Constant Field Values

      • nobject

        public static final BindingType nobject

      • _ncontext

        public static final int _ncontext
        另请参见：
        Constant Field Values

      • ncontext

        public static final BindingType ncontext

    • 构造方法详细信息

      • BindingType

        protected BindingType(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static BindingType from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"


BindingTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingTypeHelper

  • java.lang.Object
    • org.omg.CosNaming.BindingTypeHelper

  • public abstract class BindingTypeHelper
extends Object
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingTypeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static BindingType | extract(Any a)
      static String | id()
      static void | insert(Any a, BindingType that)
      static BindingType | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, BindingType value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • BindingTypeHelper

        public BindingTypeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          BindingType that)

      • extract

        public static BindingType extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static BindingType read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         BindingType value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nadioi"iiimgonaiorh=>td>mml �.rp


BindingTypeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 BindingTypeHolder

  • java.lang.Object
    • org.omg.CosNaming.BindingTypeHolder
  • 所有已实现的接口：
    Streamable

    public final class BindingTypeHolder
extends Object
implements Streamable
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      BindingType value

    • 构造方法摘要

      Constructors
      构造方法与描述
      BindingTypeHolder()
      BindingTypeHolder(BindingType initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public BindingType value

    • 构造方法详细信息

      • BindingTypeHolder

        public BindingTypeHolder()

      • BindingTypeHolder

        public BindingTypeHolder(BindingType initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttonn"vg"Nsa Nhcl a/p>P u/o>li =.go


IstringHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 IstringHelper

  • java.lang.Object
    • org.omg.CosNaming.IstringHelper

  • public abstract class IstringHelper
extends Object
    org/omg/CosNaming/IstringHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      IstringHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IstringHelper

        public IstringHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

al>aea>a/岩构岩襱d..<>>�/<>


NameComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming

类 NameComponent

  • java.lang.Object
    • org.omg.CosNaming.NameComponent
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NameComponent
extends Object
implements IDLEntity
    org/omg/CosNaming/NameComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String id
      String kind

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameComponent()
      NameComponent(String _id, String _kind)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • id

        public String id

      • kind

        public String kind

    • 构造方法详细信息

      • NameComponent

        public NameComponent()

      • NameComponent

        public NameComponent(String _id,
             String _kind)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cc>m>N>n>"ss<>>mmaa<"n>"rr >


NameComponentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NameComponentHelper

  • java.lang.Object
    • org.omg.CosNaming.NameComponentHelper

  • public abstract class NameComponentHelper
extends Object
    org/omg/CosNaming/NameComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameComponentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameComponent | extract(Any a)
      static String | id()
      static void | insert(Any a, NameComponent that)
      static NameComponent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameComponent value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameComponentHelper

        public NameComponentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameComponent that)

      • extract

        public static NameComponent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameComponent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameComponent value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/CrC a嗬鲻Rsssm鎠io."os=tl"n


NameComponentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NameComponentHolder

  • java.lang.Object
    • org.omg.CosNaming.NameComponentHolder
  • 所有已实现的接口：
    Streamable

    public final class NameComponentHolder
extends Object
implements Streamable
    org/omg/CosNaming/NameComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NameComponent value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameComponentHolder()
      NameComponentHolder(NameComponent initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NameComponent value

    • 构造方法详细信息

      • NameComponentHolder

        public NameComponentHolder()

      • NameComponentHolder

        public NameComponentHolder(NameComponent initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.i.e;ar<>n&brn.&s>lhRA\t >tOi aOa gl).


NameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NameHelper

  • java.lang.Object
    • org.omg.CosNaming.NameHelper

  • public abstract class NameHelper
extends Object
    A name is a sequence of name components.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameComponent[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameComponent[] that)
      static NameComponent[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameComponent[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameHelper

        public NameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameComponent[] that)

      • extract

        public static NameComponent[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameComponent[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameComponent[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


NameHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NameHolder

  • java.lang.Object
    • org.omg.CosNaming.NameHolder
  • 所有已实现的接口：
    Streamable

    public final class NameHolder
extends Object
implements Streamable
    A name is a sequence of name components.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NameComponent[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameHolder()
      NameHolder(NameComponent[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NameComponent[] value

    • 构造方法详细信息

      • NameHolder

        public NameHolder()

      • NameHolder

        public NameHolder(NameComponent[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ee//e/g/s/maase/"eee慰簘亮⒖晕耍詀匪穗<�<隺s


NamingContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContext

  • All Superinterfaces:
    IDLEntity, NamingContextOperations, Object, Serializable
    All Known Subinterfaces:
    NamingContextExt
    All Known Implementing Classes:
    _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub

    public interface NamingContext
extends NamingContextOperations, Object, IDLEntity
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.< !m


NamingContextExt

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.CosNaming

Interface NamingContextExt

  • All Superinterfaces:
    IDLEntity, NamingContext, NamingContextExtOperations, NamingContextOperations, Object, Serializable
    All Known Implementing Classes:
    _NamingContextExtStub

    public interface NamingContextExt
extends NamingContextExtOperations, NamingContext, IDLEntity
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextExtOperations

        resolve_str, to_name, to_string, to_url

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R


NamingContextExtHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextExtHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtHelper

  • public abstract class NamingContextExtHelper
extends Object
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextExtHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NamingContextExt | extract(Any a)
      static String | id()
      static void | insert(Any a, NamingContextExt that)
      static NamingContextExt | narrow(Object obj)
      static NamingContextExt | read(InputStream istream)
      static TypeCode | type()
      static NamingContextExt | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, NamingContextExt value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NamingContextExtHelper

        public NamingContextExtHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NamingContextExt that)

      • extract

        public static NamingContextExt extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NamingContextExt read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NamingContextExt value)

      • narrow

        public static NamingContextExt narrow(Object obj)

      • unchecked_narrow

        public static NamingContextExt unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>o/eftaeclTt/vucno.teaBgv


NamingContextExtHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextExtHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtHolder
  • 所有已实现的接口：
    Streamable

    public final class NamingContextExtHolder
extends Object
implements Streamable
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NamingContextExt value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextExtHolder()
      NamingContextExtHolder(NamingContextExt initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NamingContextExt value

    • 构造方法详细信息

      • NamingContextExtHolder

        public NamingContextExtHolder()

      • NamingContextExtHolder

        public NamingContextExtHolder(NamingContextExt initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iop ottbab"malbmeleuM.l� =�>T� >u.p/肂B


NamingContextExtOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CosNaming

Interface NamingContextExtOperations

  • All Superinterfaces:
    NamingContextOperations
    All Known Subinterfaces:
    NamingContextExt
    All Known Implementing Classes:
    _NamingContextExtStub, NamingContextExtPOA

    public interface NamingContextExtOperations
extends NamingContextOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      NameComponent[] to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • 方法详细信息

      • to_string

        String to_string(NameComponent[] n)
                 throws InvalidName
        This operation creates a stringified name from the array of Name components.
        参数：
        n - Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_name

        NameComponent[] to_name(String sn)
                        throws InvalidName
        This operation converts a Stringified Name into an equivalent array of Name Components.
        参数：
        sn - Stringified Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_url

        String to_url(String addr,
            String sn)
              throws InvalidAddress,
                     InvalidName
        This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
        参数：
        addr - internet based address of the host machine where Name Service is running

        sn - Stringified Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

        InvalidAddress
        InvalidName

      • resolve_str

        Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
        This operation resolves the Stringified name into the object reference.
        参数：
        sn - Stringified Name of the object

        抛出：
        NotFound - Indicates there is no object reference for the given name.

        CannotProceed - Indicates that the given compound name is incorrect

        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>rdgd=d dncrt薎/aatec


NamingContextExtPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextExtPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.NamingContextExtPOA
  • 所有已实现的接口：
    InvokeHandler, NamingContextExtOperations, NamingContextOperations

    public abstract class NamingContextExtPOA
extends Servant
implements NamingContextExtOperations, InvokeHandler
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextExtPOA()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      NamingContextExt _this()
      NamingContextExt | _this(ORB orb)

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextExtOperations

        resolve_str, to_name, to_string, to_url

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • 构造方法详细信息

      • NamingContextExtPOA

        public NamingContextExtPOA()

    • 方法详细信息

      • _invoke

        public OutputStream _invoke(String $method,
                   InputStream in,
                   ResponseHandler $rh)
        从接口复制的描述： InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        指定者：
        _invoke in interface InvokeHandler
        参数：
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        指定者：
        _all_interfaces in class Servant
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.

      • _this

        public NamingContextExt _this()

      • _this

        public NamingContextExt _this(ORB orb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< =ltdram",l>Ain ttds=b.t>itl=sabu ">af� �


_NamingContextExtStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 _NamingContextExtStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._NamingContextExtStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, NamingContext, NamingContextExt, NamingContextExtOperations, NamingContextOperations

    public class _NamingContextExtStub
extends ObjectImpl
implements NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service. Different names can be bound to an object in the same or different contexts at the same time. Using NamingContextExt, you can use URL-based names to bind and resolve.

    See CORBA COS Naming Specification.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      _NamingContextExtStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      NameComponent[] to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _NamingContextExtStub

        public _NamingContextExtStub()

    • 方法详细信息

      • to_string

        public String to_string(NameComponent[] n)
                 throws InvalidName
        This operation creates a stringified name from the array of Name components.
        指定者：
        to_string in interface NamingContextExtOperations
        参数：
        n - Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_name

        public NameComponent[] to_name(String sn)
                        throws InvalidName
        This operation converts a Stringified Name into an equivalent array of Name Components.
        指定者：
        to_name in interface NamingContextExtOperations
        参数：
        sn - Stringified Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • to_url

        public String to_url(String addr,
            String sn)
              throws InvalidAddress,
                     InvalidName
        This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
        指定者：
        to_url in interface NamingContextExtOperations
        参数：
        addr - internet based address of the host machine where Name Service is running

        sn - Stringified Name of the object

        抛出：
        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        org.omg.CosNaming.NamingContextPackage.InvalidAddress - Indicates the internet based address of the host machine is incorrect

        InvalidAddress
        InvalidName

      • resolve_str

        public Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
        This operation resolves the Stringified name into the object reference.
        指定者：
        resolve_str in interface NamingContextExtOperations
        参数：
        sn - Stringified Name of the object

        抛出：
        NotFound - Indicates there is no object reference for the given name.

        CannotProceed - Indicates that the given compound name is incorrect

        org.omg.CosNaming.NamingContextExtPackage.InvalidName - Indicates the name does not identify a binding.

        InvalidName

      • bind

        public void bind(NameComponent[] n,
        Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        指定者：
        bind in interface NamingContextOperations
        参数：
        n - Name of the object

        obj - The Object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        public void bind_context(NameComponent[] n,
                NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        指定者：
        bind_context in interface NamingContextOperations
        参数：
        n - Name of the object

        nc - NamingContect object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        public void rebind(NameComponent[] n,
          Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        指定者：
        rebind in interface NamingContextOperations
        参数：
        n - Name of the object

        obj - The Object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        public void rebind_context(NameComponent[] n,
                  NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        指定者：
        rebind_context in interface NamingContextOperations
        参数：
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        指定者：
        resolve in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        The unbind operation removes a name binding from a context.
        指定者：
        unbind in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        public void list(int how_many,
        BindingListHolder bl,
        BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        指定者：
        list in interface NamingContextOperations
        参数：
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        public NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.
        指定者：
        new_context in interface NamingContextOperations

      • bind_new_context

        public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        指定者：
        bind_new_context in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        public void destroy()
             throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        指定者：
        destroy in interface NamingContextOperations
        抛出：
        NotEmpty - Indicates that the Naming Context contains bindings.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


NamingContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextHelper

  • public abstract class NamingContextHelper
extends Object
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NamingContext | extract(Any a)
      static String | id()
      static void | insert(Any a, NamingContext that)
      static NamingContext | narrow(Object obj)
      static NamingContext | read(InputStream istream)
      static TypeCode | type()
      static NamingContext | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, NamingContext value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NamingContextHelper

        public NamingContextHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NamingContext that)

      • extract

        public static NamingContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NamingContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NamingContext value)

      • narrow

        public static NamingContext narrow(Object obj)

      • unchecked_narrow

        public static NamingContext unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acm> c s"ggs//sd<< di


NamingContextHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextHolder
  • 所有已实现的接口：
    Streamable

    public final class NamingContextHolder
extends Object
implements Streamable
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NamingContext value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextHolder()
      NamingContextHolder(NamingContext initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NamingContext value

    • 构造方法详细信息

      • NamingContextHolder

        public NamingContextHolder()

      • NamingContextHolder

        public NamingContextHolder(NamingContext initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Psosefirf_lii_ll=e tr cbb b aet/ddret as


_NamingContextImplBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 _NamingContextImplBase

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._NamingContextImplBase
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, NamingContext, NamingContextOperations

    public abstract class _NamingContextImplBase
extends DynamicImplementation
implements NamingContext
    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      _NamingContextImplBase()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void | invoke(ServerRequest r)

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _NamingContextImplBase

        public _NamingContextImplBase()

    • 方法详细信息

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        重载：
        _ids in class DynamicImplementation
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance

      • invoke

        public void invoke(ServerRequest r)
        重载：
        invoke in class DynamicImplementation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dns >< < OggllssiLLlsi=>""tko>=


NamingContextOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.CosNaming

Interface NamingContextOperations

  • All Known Subinterfaces:
    NamingContext, NamingContextExt, NamingContextExtOperations
    All Known Implementing Classes:
    _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, NamingContextExtPOA, NamingContextPOA

    public interface NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • 方法详细信息

      • bind

        void bind(NameComponent[] n,
        Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        参数：
        n - Name of the object

        obj - The Object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        void bind_context(NameComponent[] n,
                NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        参数：
        n - Name of the object

        nc - NamingContect object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        void rebind(NameComponent[] n,
          Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        参数：
        n - Name of the object

        obj - The Object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        void rebind_context(NameComponent[] n,
                  NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        参数：
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        The unbind operation removes a name binding from a context.
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        void list(int how_many,
        BindingListHolder bl,
        BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        参数：
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.

      • bind_new_context

        NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        void destroy()
             throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        抛出：
        NotEmpty - Indicates that the Naming Context contains bindings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


NamingContextPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 NamingContextPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.NamingContextPOA
  • 所有已实现的接口：
    InvokeHandler, NamingContextOperations

    public abstract class NamingContextPOA
extends Servant
implements NamingContextOperations, InvokeHandler
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamingContextPOA()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      NamingContext _this()
      NamingContext | _this(ORB orb)

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CosNaming.NamingContextOperations

        bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

    • 构造方法详细信息

      • NamingContextPOA

        public NamingContextPOA()

    • 方法详细信息

      • _invoke

        public OutputStream _invoke(String $method,
                   InputStream in,
                   ResponseHandler $rh)
        从接口复制的描述： InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        指定者：
        _invoke in interface InvokeHandler
        参数：
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        指定者：
        _all_interfaces in class Servant
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.

      • _this

        public NamingContext _this()

      • _this

        public NamingContext _this(ORB orb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


_NamingContextStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming

类 _NamingContextStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CosNaming._NamingContextStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, NamingContext, NamingContextOperations

    public class _NamingContextStub
extends ObjectImpl
implements NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique. Different names can be bound to an object in the same or different contexts at the same time.

    See CORBA COS Naming Specification.

    另请参见：
    Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      _NamingContextStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void destroy()
      The destroy operation deletes a naming context.
      void list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      NamingContext new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      void rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 构造方法详细信息

      • _NamingContextStub

        public _NamingContextStub()

    • 方法详细信息

      • bind

        public void bind(NameComponent[] n,
        Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
        Creates a binding of a name and an object in the naming context. Naming contexts that are bound using bind do not participate in name resolution when compound names are passed to be resolved.
        指定者：
        bind in interface NamingContextOperations
        参数：
        n - Name of the object

        obj - The Object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • bind_context

        public void bind_context(NameComponent[] n,
                NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
        Names an object that is a naming context. Naming contexts that are bound using bind_context() participate in name resolution when compound names are passed to be resolved.
        指定者：
        bind_context in interface NamingContextOperations
        参数：
        n - Name of the object

        nc - NamingContect object to bind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

        AlreadyBound - Indicates an object is already bound to the specified name.

      • rebind

        public void rebind(NameComponent[] n,
          Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        Creates a binding of a name and an object in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind do not participate in name resolution when compound names are passed to be resolved.
        指定者：
        rebind in interface NamingContextOperations
        参数：
        n - Name of the object

        obj - The Object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • rebind_context

        public void rebind_context(NameComponent[] n,
                  NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
        Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context. Naming contexts that are bound using rebind_context() participate in name resolution when compound names are passed to be resolved.
        指定者：
        rebind_context in interface NamingContextOperations
        参数：
        n - Name of the object

        nc - NamingContect object to rebind with the given name

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • resolve

        public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
        The resolve operation is the process of retrieving an object bound to a name in a given context. The given name must exactly match the bound name. The naming service does not return the type of the object. Clients are responsible for "narrowing" the object to the appropriate type. That is, clients typically cast the returned object from Object to a more specialized interface.
        指定者：
        resolve in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • unbind

        public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
        The unbind operation removes a name binding from a context.
        指定者：
        unbind in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • list

        public void list(int how_many,
        BindingListHolder bl,
        BindingIteratorHolder bi)
        The list operation allows a client to iterate through a set of bindings in a naming context.

        The list operation returns at most the requested number of bindings in BindingList bl.

        • If the naming context contains additional bindings, the list operation returns a BindingIterator with the additional bindings.
        • If the naming context does not contain additional bindings, the binding iterator is a nil object reference.
        指定者：
        list in interface NamingContextOperations
        参数：
        how_many - the maximum number of bindings to return

        bl - the returned list of bindings

        bi - the returned binding iterator

      • new_context

        public NamingContext new_context()
        This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked. The new context is not bound to any name.
        指定者：
        new_context in interface NamingContextOperations

      • bind_new_context

        public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
        This operation creates a new context and binds it to the name supplied as an argument. The newly-created context is implemented by the same naming server as the context in which it was bound (that is, the naming server that implements the context denoted by the name argument excluding the last component).
        指定者：
        bind_new_context in interface NamingContextOperations
        参数：
        n - Name of the object

        抛出：
        NotFound - Indicates the name does not identify a binding.

        AlreadyBound - Indicates an object is already bound to the specified name.

        CannotProceed - Indicates that the implementation has given up for some reason. The client, however, may be able to continue the operation at the returned naming context.

        InvalidName - Indicates that the name is invalid.

      • destroy

        public void destroy()
             throws NotEmpty
        The destroy operation deletes a naming context. If the naming context contains bindings, the NotEmpty exception is raised.
        指定者：
        destroy in interface NamingContextOperations
        抛出：
        NotEmpty - Indicates that the Naming Context contains bindings.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


org.omg.CosNaming

Interfaces

  • BindingIterator
  • BindingIteratorOperations
  • NamingContext
  • NamingContextExt
  • NamingContextExtOperations
  • NamingContextOperations

Classes

  • _BindingIteratorImplBase
  • _BindingIteratorStub
  • _NamingContextExtStub
  • _NamingContextImplBase
  • _NamingContextStub
  • Binding
  • BindingHelper
  • BindingHolder
  • BindingIteratorHelper
  • BindingIteratorHolder
  • BindingIteratorPOA
  • BindingListHelper
  • BindingListHolder
  • BindingType
  • BindingTypeHelper
  • BindingTypeHolder
  • IstringHelper
  • NameComponent
  • NameComponentHelper
  • NameComponentHolder
  • NameHelper
  • NameHolder
  • NamingContextExtHelper
  • NamingContextExtHolder
  • NamingContextExtPOA
  • NamingContextHelper
  • NamingContextHolder
  • NamingContextPOA
f


org.omg.CosNaming

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CosNaming

Provides a naming service for Java IDL.

请参见： 描述

  • 接口摘要
    接口 描述
    BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique.
  • Class Summary
    类 描述
    _BindingIteratorImplBase
    _BindingIteratorStub
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    _NamingContextExtStub
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    _NamingContextImplBase
    _NamingContextStub
    A naming context is an object that contains a set of name bindings in which each name is unique.
    Binding
    org/omg/CosNaming/Binding.java .
    BindingHelper
    org/omg/CosNaming/BindingHelper.java .
    BindingHolder
    org/omg/CosNaming/BindingHolder.java .
    BindingIteratorHelper
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorHolder
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorPOA
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingListHelper
    List of Bindings.
    BindingListHolder
    List of Bindings.
    BindingType
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    BindingTypeHelper
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    BindingTypeHolder
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    IstringHelper
    org/omg/CosNaming/IstringHelper.java .
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NameComponentHelper
    org/omg/CosNaming/NameComponentHelper.java .
    NameComponentHolder
    org/omg/CosNaming/NameComponentHolder.java .
    NameHelper
    A name is a sequence of name components.
    NameHolder
    A name is a sequence of name components.
    NamingContextExtHelper
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtHolder
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtPOA
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextHelper
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextHolder
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextPOA
    A naming context is an object that contains a set of name bindings in which each name is unique.

软件包 org.omg.CosNaming Description

Provides a naming service for Java IDL. The Object Request Broker Daemon (ORBD) also includes both a transient and persistent naming service.

The package and all its classes and interfaces were generated by running the tool idlj on the file nameservice.idl, which is a module written in OMG IDL.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Interfaces

The package org.omg.CosNaming contains two public interfaces and several auxiliary classes.

The interfaces are:

  • NamingContext
  • BindingIterator

These two interfaces provide the means to bind/unbind names and object references, to retrieve bound object references, and to iterate through a list of bindings. The NamingContext interface supplies the main functionality for the naming service, and BindingIterator provides a means of iterating through a list of name/object reference bindings.

Auxiliary Classes

In order to map an OMG IDL interface to the Java programming language, the idlj compiler creates Java classes that can be thought of as auxiliary classes. Comments for the generated auxiliary classes used by the interfaces NamingContext and BindingIterator are included here.

Classes Used by NamingContext and BindingIterator

The following are classes used by the naming service. (Helper and holder classes, which are generated for each of the classes listed here, are discussed below.)
  • public final class NameComponent -- a building block for names. (Names are bound to object references in a naming context.)

    A name is an array of one or more NameComponent objects. A name with a single NameComponent is called a simple name; a name with multiple NameComponent objects is called a compound name.

    A NameComponent object consists of two fields:

    1. id -- a String used as an identifier
    2. kind -- a String that can be used for any descriptive purpose. Its importance is that it can be used to describe an object without affecting syntax. The C programming language, for example, uses the the syntactic convention of appending the extension ".c" to a file name to indicate that it is a source code file. In a NameComponent object, the kind field can be used to describe the type of object rather than a file extension or some other syntactic convention. Examples of the value of the kind field include the strings "c_source", "object_code", "executable", "postscript", and "". It is not unusual for the kind field to be the empty string.

    In a name, each NameComponent object except the last denotes a NamingContext object; the last NameComponent object denotes the bound object reference. This is similar to a path name, in which the last name is the file name, and all names before it are directory names.

  • public final class Binding -- an object that associates a name with an object reference or a naming context. A Binding object has two fields:
    1. binding_name - an array of one or more NameComponent objects that represents the bound name
    2. binding_type - a BindingType object indicating whether the binding is between a name and an object reference or between a name and a naming context

    The interface NamingContext has methods for binding/unbinding names with object references or naming contexts, for listing bindings, and for resolving bindings (given a name, the method resolve returns the object reference bound to it).

  • public final class BindingType -- an object that specifies whether the given Binding object is a binding between a name and an object reference (that is, not a naming context) or between a name and a naming context.

    The classBindingType consists of two methods and four constants. Two of these constants are BindingType objects, and two are ints.

    The BindingType objects can be passed to the constructor for the class Binding or used as parameters or return values. These BindingType objects are:

    • public static final BindingType nobject -- to indicate that the binding is with an object reference
    • public static final BindingType ncontext -- to indicate that the binding is with a naming context

    The int constants can be supplied to the method from_int to create BindingType objects, or they can be return values for the method value. These constants are:

    • public static final int _nobject
    • public static final int _ncontext
    If the method from_int is supplied with anything other than _nobject or _ncontext, it will throw the exception org.omg.CORBA.BAD_PARAM.

    Usage is as follows:

           BindingType btObject = from_int(_nobject);
       BindingType btContext = from_int(_ncontext);
    The variable btObject refers to a BindingType object initialized to represent a binding with an object reference. The variable btContext refers to a BindingType object initialized to represent a binding with a NamingContex object.

    The method value returns either _nobject or _ncontext, so in the following line of code, the variable bt will contain _nobject or _ncontext:

           int bt = BindingType.value();

Holder Classes

OMG IDL uses OUT and INOUT parameters for returning values from operations. The mapping to the Java programming language, which does not have OUT and INOUT parameters, creates a special class for each type, called a holder class. An instance of a holder class can be passed to a Java method as a parameter, and a value can be assigned to its value field. This allows it to perform the function of an OUT or INOUT parameter.

The following holder classes are generated for the package org.omg.CosNaming:

  • NamingContextHolder
  • BindingIteratorHolder
  • BindingHolder
  • BindingListHolder
  • BindingTypeHolder
  • NameComponentHolder
  • NameHolder

Note that in the org.omg.CORBA package, there is a holder class for each of the basic Java types: IntHolder, ShortHolder, StringHolder, and so on.

Note also that there is a NameHolder class even though there is no Name class; similarly, there is a BindingListHolder class even though there is no BindingList class. This is true because in the OMG IDL interface, Name and BindingList are typedefs. There is no mapping from an IDL typedef to a Java construct, but holder classes are generated if the typedef is for a sequence or an array. As mapped to the Java programming language, Name is an array of NameComponent objects, and a BindingList is an array of Binding objects. All holder classes have at least two constructors and one field:

  • value field -- an instance of the type being used as an OUT or INOUT parameter. For example, the value field of a NamingContextHolder will be a NamingContext object.
  • default constructor -- a constructor that creates a new holder object initialized with the default value for the type. For example, a new BindingHolder object created with the default constructor will have its value field set to null because that is the default value for an object. Other defaults are false for boolean, 0 for numeric and char types, and null for object references.
  • constructor from an instance -- a constructor that creates a new holder object whose value field is initialized with the instance supplied

A holder class for a user-defined type (a Java class) has three more methods, but application developers do not use them directly.

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types.

There is only one method in a helper class that an application programmer uses: the method narrow. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the CosNaming package, only the classes NamingContextHelper and BindingIteratorHelper have a narrow method.

  • public static NamingContext narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a NamingContext object
  • public static BindingIterator narrow(org.omg.CORBA.Object obj) -- converts the given CORBA object to a BindingIterator object

Package org.omg.CosNaming.NamingContextPackage

This package supplies Helper and Holder classes for the exceptions used in the package org.omg.CosNaming and also for the class NotFoundReason, which supplies a reason for the exception NotFound.

There are Helper and Holder classes for the following exceptions:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound

Naming Service Compatibility

Sun's implementation of the CosNaming package complies with the OMG COSNaming specification. In other words, the APIs in Sun's naming service are implemented according to the guidelines for a naming service provided by OMG. Therefore, if a third-party vendor has implemented a naming service that is OMG compliant, it is possible to switch between Sun's implementation of CosNaming and the third-party vendor's implementation. However, it is important to understand that there can be minor variations in the way different vendors implement the naming service, such as differences in the exception strings.

Instructions for Using a Third Party's Naming Service

Although we encourage using an ORB and ORB services that are both from one vendor, it is possible to plug in a third party's COSNaming implementation with Sun's RMI-IIOP ORB. Here are the steps to follow:
  1. Create a properties file for the Bootstrap server and give it two entries. For example, you could call this properties file /tmp/services and put the following in it: NameService, <Stringified IOR of the Root Naming Context>.

    This associates NameService with the Root Naming Context of the CosNaming implementation that you want to use.

  2. Start the standalone Bootstrap server using the following command:

      java -classpath $(CLASSPATH)
      com.sun.corba.ee.internal.CosNaming.BootstrapServer -InitialServicesFile
      "/tmp/services" [-ORBInitialPort port]

    Note that the square brackets at the end of the command indicate that specifying a port number is optional.

Now when an application calls the method org.omg.CORBA.ORB.resolve_initial_references, CORBA processes will contact the Bootstrap Server to get the Root Naming Context.

Package Specification

  • Interoperable Naming Service (ptc/00-08-07)

Related Documentation

For an overview and examples of how to use the CosNaming API, please see:
  • Naming Service

For an overview of Java IDL, please see:

  • Java IDL home page
从以下版本开始：
JDK1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ss.xl."Ootlt>bll=ci


org.omg.CosNaming Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CosNaming

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.IstringHelper
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)

Interface Hierarchy

  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.omg.CORBA.Object
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContext (also extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dtde/notttbe >oo e


Uses of Package org.omg.CosNaming

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CosNaming

  • Packages that use org.omg.CosNaming
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
  • Classes in org.omg.CosNaming used by org.omg.CosNaming
    类与描述
    Binding
    org/omg/CosNaming/Binding.java .
    BindingHolder
    org/omg/CosNaming/BindingHolder.java .
    BindingIterator
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorHolder
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingIteratorOperations
    The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
    BindingListHolder
    List of Bindings.
    BindingType
    Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
    NamingContextExt
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextExtOperations
    NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
    NamingContextOperations
    A naming context is an object that contains a set of name bindings in which each name is unique.
  • Classes in org.omg.CosNaming used by org.omg.CosNaming.NamingContextPackage
    类与描述
    NameComponent
    org/omg/CosNaming/NameComponent.java .
    NamingContext
    A naming context is an object that contains a set of name bindings in which each name is unique.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtaBaNagm///g.<


Uses of Class org.omg.CosNaming._BindingIteratorImplBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming._BindingIteratorImplBase

No usage of org.omg.CosNaming._BindingIteratorImplBase
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N n=feaptttx.tatmojr


Uses of Class org.omg.CosNaming._BindingIteratorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming._BindingIteratorStub

No usage of org.omg.CosNaming._BindingIteratorStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s(


Uses of Class org.omg.CosNaming._NamingContextExtStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming._NamingContextExtStub

No usage of org.omg.CosNaming._NamingContextExtStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gft�Rsn�/r0


Uses of Class org.omg.CosNaming._NamingContextImplBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming._NamingContextImplBase

No usage of org.omg.CosNaming._NamingContextImplBase
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Uf sl�


Uses of Class org.omg.CosNaming._NamingContextStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming._NamingContextStub

No usage of org.omg.CosNaming._NamingContextStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s�


Uses of Class org.omg.CosNaming.Binding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.Binding

  • Packages that use Binding
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of Binding in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as Binding
      修饰符与类型 | 字段与描述
      Binding[] | BindingListHolder.value
      Binding | BindingHolder.value
      Methods in org.omg.CosNaming that return Binding
      修饰符与类型 | 方法与描述
      static Binding[] | BindingListHelper.extract(Any a)
      static Binding | BindingHelper.extract(Any a)
      static Binding[] | BindingListHelper.read(InputStream istream)
      static Binding | BindingHelper.read(InputStream istream)
      Methods in org.omg.CosNaming with parameters of type Binding
      修饰符与类型 | 方法与描述
      static void | BindingHelper.insert(Any a, Binding that)
      static void | BindingListHelper.insert(Any a, Binding[] that)
      static void | BindingHelper.write(OutputStream ostream, Binding value)
      static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
      Constructors in org.omg.CosNaming with parameters of type Binding
      构造方法与描述
      BindingHolder(Binding initialValue)
      BindingListHolder(Binding[] initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eoO./pei\


Uses of Class org.omg.CosNaming.BindingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingHelper

No usage of org.omg.CosNaming.BindingHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raeetha/


Uses of Class org.omg.CosNaming.BindingHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingHolder

  • Packages that use BindingHolder
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingHolder
      修饰符与类型 方法与描述
      boolean _BindingIteratorStub.next_one(BindingHolder b)
      This operation returns the next binding.
      boolean BindingIteratorOperations.next_one(BindingHolder b)
      This operation returns the next binding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ltav


Uses of Class org.omg.CosNaming.BindingIteratorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingIteratorHelper

No usage of org.omg.CosNaming.BindingIteratorHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.gClry.usmmmgn// dt>m


Uses of Class org.omg.CosNaming.BindingIteratorHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingIteratorHolder

  • Packages that use BindingIteratorHolder
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIteratorHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingIteratorHolder
      修饰符与类型 方法与描述
      void _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n=gm >rtc-dsgio>/g ..St


Uses of Class org.omg.CosNaming.BindingIteratorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingIteratorPOA

No usage of org.omg.CosNaming.BindingIteratorPOA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"oimonsreaaargaa.magr


Uses of Class org.omg.CosNaming.BindingListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingListHelper

No usage of org.omg.CosNaming.BindingListHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>v"t>m>lomsa/ooaigs"


Uses of Class org.omg.CosNaming.BindingListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingListHolder

  • Packages that use BindingListHolder
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingListHolder in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type BindingListHolder
      修饰符与类型 方法与描述
      void _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      void NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi)
      The list operation allows a client to iterate through a set of bindings in a naming context.
      boolean _BindingIteratorStub.next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
      boolean BindingIteratorOperations.next_n(int how_many, BindingListHolder bl)
      This operation returns at most the requested number of bindings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn Lspv>i/�/li


Uses of Class org.omg.CosNaming.BindingType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingType

  • Packages that use BindingType
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingType in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as BindingType
      修饰符与类型 | 字段与描述
      BindingType | Binding.binding_type
      static BindingType | BindingType.ncontext
      static BindingType | BindingType.nobject
      BindingType | BindingTypeHolder.value
      Methods in org.omg.CosNaming that return BindingType
      修饰符与类型 | 方法与描述
      static BindingType | BindingTypeHelper.extract(Any a)
      static BindingType | BindingType.from_int(int value)
      static BindingType | BindingTypeHelper.read(InputStream istream)
      Methods in org.omg.CosNaming with parameters of type BindingType
      修饰符与类型 | 方法与描述
      static void | BindingTypeHelper.insert(Any a, BindingType that)
      static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
      Constructors in org.omg.CosNaming with parameters of type BindingType
      构造方法与描述
      Binding(NameComponent[] _binding_name, BindingType _binding_type)
      BindingTypeHolder(BindingType initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slrbAe /d.輙>g&ii


Uses of Class org.omg.CosNaming.BindingTypeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingTypeHelper

No usage of org.omg.CosNaming.BindingTypeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p/e>tross===c"aai"goa


Uses of Class org.omg.CosNaming.BindingTypeHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.BindingTypeHolder

No usage of org.omg.CosNaming.BindingTypeHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/;F<坰�蒩""o


Uses of Class org.omg.CosNaming.IstringHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.IstringHelper

No usage of org.omg.CosNaming.IstringHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl><<>g/s@


Uses of Class org.omg.CosNaming.NameComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NameComponent

  • Packages that use NameComponent
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NameComponent in org.omg.CosNaming

      Fields in org.omg.CosNaming declared as NameComponent
      修饰符与类型 | 字段与描述
      NameComponent[] | Binding.binding_name
      NameComponent[] | NameHolder.value
      NameComponent | NameComponentHolder.value
      Methods in org.omg.CosNaming that return NameComponent
      修饰符与类型 | 方法与描述
      static NameComponent[] | NameHelper.extract(Any a)
      static NameComponent | NameComponentHelper.extract(Any a)
      static NameComponent[] | NameHelper.read(InputStream istream)
      static NameComponent | NameComponentHelper.read(InputStream istream)
      NameComponent[] _NamingContextExtStub.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      NameComponent[] NamingContextExtOperations.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      Methods in org.omg.CosNaming with parameters of type NameComponent
      修饰符与类型 | 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      static void | NameComponentHelper.insert(Any a, NameComponent that)
      static void | NameHelper.insert(Any a, NameComponent[] that)
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      String _NamingContextExtStub.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String NamingContextExtOperations.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
      static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
      Constructors in org.omg.CosNaming with parameters of type NameComponent
      构造方法与描述
      Binding(NameComponent[] _binding_name, BindingType _binding_type)
      NameComponentHolder(NameComponent initialValue)
      NameHolder(NameComponent[] initialValue)

    • Uses of NameComponent in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NameComponent
      修饰符与类型 | 字段与描述
      NameComponent[] | CannotProceed.rest_of_name
      NameComponent[] | NotFound.rest_of_name
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NameComponent
      构造方法与描述
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CosNaming.NameComponentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NameComponentHelper

No usage of org.omg.CosNaming.NameComponentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d enosNmogggr/ >oap


Uses of Class org.omg.CosNaming.NameComponentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NameComponentHolder

No usage of org.omg.CosNaming.NameComponentHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snt塷rs>/ ol


Uses of Class org.omg.CosNaming.NameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NameHelper

No usage of org.omg.CosNaming.NameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s北Ａ诵�/�<◆ �<


Uses of Class org.omg.CosNaming.NameHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NameHolder

No usage of org.omg.CosNaming.NameHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h�3廨fiU*�/K�


Uses of Class org.omg.CosNaming.NamingContextExtHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtHelper

No usage of org.omg.CosNaming.NamingContextExtHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i >>"xocs


Uses of Class org.omg.CosNaming.NamingContextExtHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtHolder

No usage of org.omg.CosNaming.NamingContextExtHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iL�<璩nsO鴾>�=閤c


Uses of Class org.omg.CosNaming.NamingContextExtPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPOA

No usage of org.omg.CosNaming.NamingContextExtPOA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aN mtha/niag


Uses of Class org.omg.CosNaming.NamingContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextHelper

No usage of org.omg.CosNaming.NamingContextHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N挠<


Uses of Class org.omg.CosNaming.NamingContextHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextHolder

No usage of org.omg.CosNaming.NamingContextHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

N腦xl


Uses of Class org.omg.CosNaming.NamingContextPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPOA

No usage of org.omg.CosNaming.NamingContextPOA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


Uses of Interface org.omg.CosNaming.BindingIterator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.BindingIterator

  • Packages that use BindingIterator
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIterator in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement BindingIterator
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      Fields in org.omg.CosNaming declared as BindingIterator
      修饰符与类型 | 字段与描述
      BindingIterator | BindingIteratorHolder.value
      Methods in org.omg.CosNaming that return BindingIterator
      修饰符与类型 | 方法与描述
      BindingIterator | BindingIteratorPOA._this()
      BindingIterator | BindingIteratorPOA._this(ORB orb)
      static BindingIterator | BindingIteratorHelper.extract(Any a)
      static BindingIterator | BindingIteratorHelper.narrow(Object obj)
      static BindingIterator | BindingIteratorHelper.read(InputStream istream)
      static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type BindingIterator
      修饰符与类型 | 方法与描述
      static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
      static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
      Constructors in org.omg.CosNaming with parameters of type BindingIterator
      构造方法与描述
      BindingIteratorHolder(BindingIterator initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/O.cc".wr醓mee=tbtl=


Uses of Interface org.omg.CosNaming.BindingIteratorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.BindingIteratorOperations

  • Packages that use BindingIteratorOperations
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of BindingIteratorOperations in org.omg.CosNaming

      Subinterfaces of BindingIteratorOperations in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  BindingIterator
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      Classes in org.omg.CosNaming that implement BindingIteratorOperations
      修饰符与类型 | 类与描述
      class  | _BindingIteratorImplBase
      class  _BindingIteratorStub
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i粼；嗽。� o∮�/


Uses of Interface org.omg.CosNaming.NamingContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.NamingContext

  • Packages that use NamingContext
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NamingContext in org.omg.CosNaming

      Subinterfaces of NamingContext in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContext
      修饰符与类型 | 类与描述
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      Fields in org.omg.CosNaming declared as NamingContext
      修饰符与类型 | 字段与描述
      NamingContext | NamingContextHolder.value
      Methods in org.omg.CosNaming that return NamingContext
      修饰符与类型 | 方法与描述
      NamingContext | NamingContextPOA._this()
      NamingContext | NamingContextPOA._this(ORB orb)
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      static NamingContext | NamingContextHelper.extract(Any a)
      static NamingContext | NamingContextHelper.narrow(Object obj)
      NamingContext _NamingContextExtStub.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      NamingContext _NamingContextStub.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      NamingContext NamingContextOperations.new_context()
      This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
      static NamingContext | NamingContextHelper.read(InputStream istream)
      static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type NamingContext
      修饰符与类型 | 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      static void | NamingContextHelper.insert(Any a, NamingContext that)
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
      Constructors in org.omg.CosNaming with parameters of type NamingContext
      构造方法与描述
      NamingContextHolder(NamingContext initialValue)

    • Uses of NamingContext in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NamingContext
      修饰符与类型 | 字段与描述
      NamingContext | CannotProceed.cxt
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NamingContext
      构造方法与描述
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e_rt/�=mdlttv祍na轈e


Uses of Interface org.omg.CosNaming.NamingContextExt

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.NamingContextExt

  • Packages that use NamingContextExt
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextExt in org.omg.CosNaming

      Classes in org.omg.CosNaming that implement NamingContextExt
      修饰符与类型 类与描述
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Fields in org.omg.CosNaming declared as NamingContextExt
      修饰符与类型 | 字段与描述
      NamingContextExt | NamingContextExtHolder.value
      Methods in org.omg.CosNaming that return NamingContextExt
      修饰符与类型 | 方法与描述
      NamingContextExt | NamingContextExtPOA._this()
      NamingContextExt | NamingContextExtPOA._this(ORB orb)
      static NamingContextExt | NamingContextExtHelper.extract(Any a)
      static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
      static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
      static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
      Methods in org.omg.CosNaming with parameters of type NamingContextExt
      修饰符与类型 | 方法与描述
      static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
      static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
      Constructors in org.omg.CosNaming with parameters of type NamingContextExt
      构造方法与描述
      NamingContextExtHolder(NamingContextExt initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aNmmmConn.rttstsF


Uses of Interface org.omg.CosNaming.NamingContextExtOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.NamingContextExtOperations

  • Packages that use NamingContextExtOperations
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextExtOperations in org.omg.CosNaming

      Subinterfaces of NamingContextExtOperations in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContextExtOperations
      修饰符与类型 类与描述
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t=hg> timngns"-x.C/iia;t


Uses of Interface org.omg.CosNaming.NamingContextOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.CosNaming.NamingContextOperations

  • Packages that use NamingContextOperations
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.

    • Uses of NamingContextOperations in org.omg.CosNaming

      Subinterfaces of NamingContextOperations in org.omg.CosNaming
      修饰符与类型 Interface and Description
      interface  NamingContext
      A naming context is an object that contains a set of name bindings in which each name is unique.
      interface  NamingContextExt
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      interface  NamingContextExtOperations
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      Classes in org.omg.CosNaming that implement NamingContextOperations
      修饰符与类型 | 类与描述
      class  _NamingContextExtStub
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  | _NamingContextImplBase
      class  _NamingContextStub
      A naming context is an object that contains a set of name bindings in which each name is unique.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

C<= .pn#l..a&.uneiieo.s


AddressHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextExtPackage

类 AddressHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper

  • public abstract class AddressHelper
extends Object
    Address is the Host and Port information represented as a String.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AddressHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AddressHelper

        public AddressHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o mln>


InvalidAddress

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextExtPackage

类 InvalidAddress

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidAddress
extends UserException
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAddress()
      InvalidAddress(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidAddress

        public InvalidAddress()

      • InvalidAddress

        public InvalidAddress(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dNiimi/i/id>idiimr;;;a;;all;trftEf<


InvalidAddressHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextExtPackage

类 InvalidAddressHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

  • public abstract class InvalidAddressHelper
extends Object
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAddressHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidAddress | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidAddress that)
      static InvalidAddress | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidAddress value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidAddressHelper

        public InvalidAddressHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidAddress that)

      • extract

        public static InvalidAddress extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidAddress read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidAddress value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g.n"s cmc <=ipulta<.r .n.g=o!


InvalidAddressHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextExtPackage

类 InvalidAddressHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
  • 所有已实现的接口：
    Streamable

    public final class InvalidAddressHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      InvalidAddress value

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidAddressHolder()
      InvalidAddressHolder(InvalidAddress initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public InvalidAddress value

    • 构造方法详细信息

      • InvalidAddressHolder

        public InvalidAddressHolder()

      • InvalidAddressHolder

        public InvalidAddressHolder(InvalidAddress initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

er<<"N e a.>brMf>-e/c/ci#=�


org.omg.CosNaming.NamingContextExtPackage

Classes

  • AddressHelper
  • InvalidAddressHelper
  • InvalidAddressHolder
  • StringNameHelper
  • URLStringHelper

Exceptions

  • InvalidAddress
p


org.omg.CosNaming.NamingContextExtPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CosNaming.NamingContextExtPackage

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

请参见： 描述

  • Class Summary
    类 描述
    AddressHelper
    Address is the Host and Port information represented as a String.
    InvalidAddressHelper
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java .
    InvalidAddressHolder
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .
    StringNameHelper
    StringName is the Stringified Name, Array of Name Components represented as a String.
    URLStringHelper
    URLString is the URL address (corbaloc: or corbaname:) represented as a String.
  • Exception Summary
    Exception 描述
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .

软件包 org.omg.CosNaming.NamingContextExtPackage Description

This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

  • AddressHelper
  • StringNameHelper
  • URLStringHelper
  • InvalidAddress

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c__/criiti_niiimttasemst"l


org.omg.CosNaming.NamingContextExtPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CosNaming.NamingContextExtPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=a"t.rlm hsaavs.".t


StringNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextExtPackage

类 StringNameHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

  • public abstract class StringNameHelper
extends Object
    StringName is the Stringified Name, Array of Name Components represented as a String.

    • 构造方法摘要

      Constructors
      构造方法与描述
      StringNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • StringNameHelper

        public StringNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i ;to>l/niif_>ans->


URLStringHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextExtPackage

类 URLStringHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

  • public abstract class URLStringHelper
extends Object
    URLString is the URL address (corbaloc: or corbaname:) represented as a String.

    • 构造方法摘要

      Constructors
      构造方法与描述
      URLStringHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • URLStringHelper

        public URLStringHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lDanalaEaJaSE cno /hl=wnnaocro..a."


Uses of Package org.omg.CosNaming.NamingContextExtPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CosNaming.NamingContextExtPackage

  • Packages that use org.omg.CosNaming.NamingContextExtPackage
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
  • Classes in org.omg.CosNaming.NamingContextExtPackage used by org.omg.CosNaming
    类与描述
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
  • Classes in org.omg.CosNaming.NamingContextExtPackage used by org.omg.CosNaming.NamingContextExtPackage
    类与描述
    InvalidAddress
    org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/r.e< r >ahf..re/ ==aぜ/


Uses of Class org.omg.CosNaming.NamingContextExtPackage.AddressHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.AddressHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.AddressHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ahtSanvd


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddress

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddress

  • Packages that use InvalidAddress
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextExtPackage
    This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:

    • Uses of InvalidAddress in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw InvalidAddress
      修饰符与类型 方法与描述
      String _NamingContextExtStub.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      String NamingContextExtOperations.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.

    • Uses of InvalidAddress in org.omg.CosNaming.NamingContextExtPackage

      Fields in org.omg.CosNaming.NamingContextExtPackage declared as InvalidAddress
      修饰符与类型 | 字段与描述
      InvalidAddress | InvalidAddressHolder.value
      Methods in org.omg.CosNaming.NamingContextExtPackage that return InvalidAddress
      修饰符与类型 | 方法与描述
      static InvalidAddress | InvalidAddressHelper.extract(Any a)
      static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextExtPackage with parameters of type InvalidAddress
      修饰符与类型 | 方法与描述
      static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
      static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
      Constructors in org.omg.CosNaming.NamingContextExtPackage with parameters of type InvalidAddress
      构造方法与描述
      InvalidAddressHolder(InvalidAddress initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

MRtli< | JeeChs>


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k>"l>./a.S


Uses of Class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder

No usage of org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c><竜;e`nn/


Uses of Class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

->motsn>sl>g/sd


Uses of Class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

No usage of org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>-t>o>l>o>>�>t


AlreadyBound

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextPackage

类 AlreadyBound

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class AlreadyBound
extends UserException
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AlreadyBound()
      AlreadyBound(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AlreadyBound

        public AlreadyBound()

      • AlreadyBound

        public AlreadyBound(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k< R


AlreadyBoundHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 AlreadyBoundHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

  • public abstract class AlreadyBoundHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AlreadyBoundHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static AlreadyBound | extract(Any a)
      static String | id()
      static void | insert(Any a, AlreadyBound that)
      static AlreadyBound | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AlreadyBound value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AlreadyBoundHelper

        public AlreadyBoundHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          AlreadyBound that)

      • extract

        public static AlreadyBound extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AlreadyBound read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         AlreadyBound value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.N >/_dasmma/r0nt<v"/>kaelvll-a


AlreadyBoundHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 AlreadyBoundHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
  • 所有已实现的接口：
    Streamable

    public final class AlreadyBoundHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      AlreadyBound value

    • 构造方法摘要

      Constructors
      构造方法与描述
      AlreadyBoundHolder()
      AlreadyBoundHolder(AlreadyBound initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public AlreadyBound value

    • 构造方法详细信息

      • AlreadyBoundHolder

        public AlreadyBoundHolder()

      • AlreadyBoundHolder

        public AlreadyBoundHolder(AlreadyBound initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/>m....m/=hl /cli.癳� � a絟�>a>a 眛


CannotProceed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextPackage

类 CannotProceed

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class CannotProceed
extends UserException
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NamingContext cxt
      NameComponent[] rest_of_name

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotProceed()
      CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
      CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • cxt

        public NamingContext cxt

      • rest_of_name

        public NameComponent[] rest_of_name

    • 构造方法详细信息

      • CannotProceed

        public CannotProceed()

      • CannotProceed

        public CannotProceed(NamingContext _cxt,
             NameComponent[] _rest_of_name)

      • CannotProceed

        public CannotProceed(String $reason,
             NamingContext _cxt,
             NameComponent[] _rest_of_name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.oaaa.a-alss-nrsl..>i


CannotProceedHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 CannotProceedHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

  • public abstract class CannotProceedHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotProceedHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static CannotProceed | extract(Any a)
      static String | id()
      static void | insert(Any a, CannotProceed that)
      static CannotProceed | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, CannotProceed value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CannotProceedHelper

        public CannotProceedHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          CannotProceed that)

      • extract

        public static CannotProceed extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CannotProceed read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         CannotProceed value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts >o>t>a>a hatoei 礱e7eavv.""_gh.ak�


CannotProceedHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 CannotProceedHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
  • 所有已实现的接口：
    Streamable

    public final class CannotProceedHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      CannotProceed value

    • 构造方法摘要

      Constructors
      构造方法与描述
      CannotProceedHolder()
      CannotProceedHolder(CannotProceed initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public CannotProceed value

    • 构造方法详细信息

      • CannotProceedHolder

        public CannotProceedHolder()

      • CannotProceedHolder

        public CannotProceedHolder(CannotProceed initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;gie"#app &0a9R�!, �, =hia1lt� es藀e ａ&>


InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextPackage

类 InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.InvalidName
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    org/omg/CosNaming/NamingContextPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidName()
      InvalidName(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidName

        public InvalidName()

      • InvalidName

        public InvalidName(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> <>


InvalidNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 InvalidNameHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

  • public abstract class InvalidNameHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidName | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidName that)
      static InvalidName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidName value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidNameHelper

        public InvalidNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidName that)

      • extract

        public static InvalidName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidName value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ii>l/l/lll/>< >>>s""tsc"anctkoo�/


InvalidNameHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 InvalidNameHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
  • 所有已实现的接口：
    Streamable

    public final class InvalidNameHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      InvalidName value

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidNameHolder()
      InvalidNameHolder(InvalidName initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public InvalidName value

    • 构造方法详细信息

      • InvalidNameHolder

        public InvalidNameHolder()

      • InvalidNameHolder

        public InvalidNameHolder(InvalidName initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hho/�o藅輌&b竐&a哺竍sssbg"


NotEmpty

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextPackage

类 NotEmpty

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NotEmpty
extends UserException
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotEmpty()
      NotEmpty(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NotEmpty

        public NotEmpty()

      • NotEmpty

        public NotEmpty(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< //mbtabtSrrtSSbB = .....re.amcee


NotEmptyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotEmptyHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

  • public abstract class NotEmptyHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotEmptyHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NotEmpty | extract(Any a)
      static String | id()
      static void | insert(Any a, NotEmpty that)
      static NotEmpty | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotEmpty value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NotEmptyHelper

        public NotEmptyHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NotEmpty that)

      • extract

        public static NotEmpty extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotEmpty read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NotEmpty value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gmCa.U.n.gaaN..aoll.錱hggC/dINeenl


NotEmptyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotEmptyHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
  • 所有已实现的接口：
    Streamable

    public final class NotEmptyHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NotEmpty value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotEmptyHolder()
      NotEmptyHolder(NotEmpty initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NotEmpty value

    • 构造方法详细信息

      • NotEmptyHolder

        public NotEmptyHolder()

      • NotEmptyHolder

        public NotEmptyHolder(NotEmpty initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/c1311r10,Orae扑cg捌突妹Ｔ了Ｈ哩。｛f鵩鹴n


NotFound

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.CosNaming.NamingContextPackage

类 NotFound

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.CosNaming.NamingContextPackage.NotFound
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NotFound
extends UserException
    org/omg/CosNaming/NamingContextPackage/NotFound.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NameComponent[] rest_of_name
      NotFoundReason why

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotFound()
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • why

        public NotFoundReason why

      • rest_of_name

        public NameComponent[] rest_of_name

    • 构造方法详细信息

      • NotFound

        public NotFound()

      • NotFound

        public NotFound(NotFoundReason _why,
        NameComponent[] _rest_of_name)

      • NotFound

        public NotFound(String $reason,
        NotFoundReason _why,
        NameComponent[] _rest_of_name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/=s/}/ /


NotFoundHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotFoundHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper

  • public abstract class NotFoundHelper
extends Object
    org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotFoundHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NotFound | extract(Any a)
      static String | id()
      static void | insert(Any a, NotFound that)
      static NotFound | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotFound value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NotFoundHelper

        public NotFoundHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NotFound that)

      • extract

        public static NotFound extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotFound read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NotFound value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-too"> -"r==to詏illbiM>;sbd>r


NotFoundHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotFoundHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder
  • 所有已实现的接口：
    Streamable

    public final class NotFoundHolder
extends Object
implements Streamable
    org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NotFound value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotFoundHolder()
      NotFoundHolder(NotFound initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NotFound value

    • 构造方法详细信息

      • NotFoundHolder

        public NotFoundHolder()

      • NotFoundHolder

        public NotFoundHolder(NotFound initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

$0(l��7"sd, � �


NotFoundReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotFoundReason

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class NotFoundReason
extends Object
implements IDLEntity
    Indicates the reason for not able to resolve.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _missing_node
      static int | _not_context
      static int | _not_object
      static NotFoundReason | missing_node
      static NotFoundReason | not_context
      static NotFoundReason | not_object

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | NotFoundReason(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NotFoundReason | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _missing_node

        public static final int _missing_node
        另请参见：
        Constant Field Values

      • missing_node

        public static final NotFoundReason missing_node

      • _not_context

        public static final int _not_context
        另请参见：
        Constant Field Values

      • not_context

        public static final NotFoundReason not_context

      • _not_object

        public static final int _not_object
        另请参见：
        Constant Field Values

      • not_object

        public static final NotFoundReason not_object

    • 构造方法详细信息

      • NotFoundReason

        protected NotFoundReason(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static NotFoundReason from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nlav vlv vi a nea<<


NotFoundReasonHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotFoundReasonHelper

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

  • public abstract class NotFoundReasonHelper
extends Object
    Indicates the reason for not able to resolve.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotFoundReasonHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NotFoundReason | extract(Any a)
      static String | id()
      static void | insert(Any a, NotFoundReason that)
      static NotFoundReason | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NotFoundReason value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NotFoundReasonHelper

        public NotFoundReasonHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NotFoundReason that)

      • extract

        public static NotFoundReason extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NotFoundReason read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NotFoundReason value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dh_"h"a"l"=felduerlllcc s>p bb>il


NotFoundReasonHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.CosNaming.NamingContextPackage

类 NotFoundReasonHolder

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
  • 所有已实现的接口：
    Streamable

    public final class NotFoundReasonHolder
extends Object
implements Streamable
    Indicates the reason for not able to resolve.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      NotFoundReason value

    • 构造方法摘要

      Constructors
      构造方法与描述
      NotFoundReasonHolder()
      NotFoundReasonHolder(NotFoundReason initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public NotFoundReason value

    • 构造方法详细信息

      • NotFoundReasonHolder

        public NotFoundReasonHolder()

      • NotFoundReasonHolder

        public NotFoundReasonHolder(NotFoundReason initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aclntnCnunoetuaov,lr⒚发靠比tE囊迷阅陌碰虐


org.omg.CosNaming.NamingContextPackage

Classes

  • AlreadyBoundHelper
  • AlreadyBoundHolder
  • CannotProceedHelper
  • CannotProceedHolder
  • InvalidNameHelper
  • InvalidNameHolder
  • NotEmptyHelper
  • NotEmptyHolder
  • NotFoundHelper
  • NotFoundHolder
  • NotFoundReason
  • NotFoundReasonHelper
  • NotFoundReasonHolder

Exceptions

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound
&


org.omg.CosNaming.NamingContextPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.CosNaming.NamingContextPackage

This package contains Exception classes for the org.omg.CosNaming package.

请参见： 描述

  • Class Summary
    类 描述
    AlreadyBoundHelper
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java .
    AlreadyBoundHolder
    org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
    CannotProceedHelper
    org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java .
    CannotProceedHolder
    org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
    InvalidNameHelper
    org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java .
    InvalidNameHolder
    org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
    NotEmptyHelper
    org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java .
    NotEmptyHolder
    org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
    NotFoundHelper
    org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java .
    NotFoundHolder
    org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
    NotFoundReason
    Indicates the reason for not able to resolve.
    NotFoundReasonHelper
    Indicates the reason for not able to resolve.
    NotFoundReasonHolder
    Indicates the reason for not able to resolve.
  • Exception Summary
    Exception 描述
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .

软件包 org.omg.CosNaming.NamingContextPackage Description

This package contains Exception classes for the org.omg.CosNaming package. The list of exception classes are:

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound
  • NotFoundReason

    Package Specification

    For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cv<.cev iv a vd>>he>ed o>


org.omg.CosNaming.NamingContextPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.CosNaming.NamingContextPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se< tr>"oF�"eyykx".le


Uses of Package org.omg.CosNaming.NamingContextPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.CosNaming.NamingContextPackage

  • Packages that use org.omg.CosNaming.NamingContextPackage
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.
  • Classes in org.omg.CosNaming.NamingContextPackage used by org.omg.CosNaming
    类与描述
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .
  • Classes in org.omg.CosNaming.NamingContextPackage used by org.omg.CosNaming.NamingContextPackage
    类与描述
    AlreadyBound
    org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
    CannotProceed
    org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
    InvalidName
    org/omg/CosNaming/NamingContextPackage/InvalidName.java .
    NotEmpty
    org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
    NotFound
    org/omg/CosNaming/NamingContextPackage/NotFound.java .
    NotFoundReason
    Indicates the reason for not able to resolve.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/gt"=u=s"""l>aadiiif"a<


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBound

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBound

  • Packages that use AlreadyBound
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of AlreadyBound in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw AlreadyBound
      修饰符与类型 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.

    • Uses of AlreadyBound in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as AlreadyBound
      修饰符与类型 | 字段与描述
      AlreadyBound | AlreadyBoundHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return AlreadyBound
      修饰符与类型 | 方法与描述
      static AlreadyBound | AlreadyBoundHelper.extract(Any a)
      static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type AlreadyBound
      修饰符与类型 | 方法与描述
      static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
      static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type AlreadyBound
      构造方法与描述
      AlreadyBoundHolder(AlreadyBound initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ts /.lli-evstn羠


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

No usage of org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s/ lassvi )<


Uses of Class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder

No usage of org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cò"i< L�.U)Qe


Uses of Class org.omg.CosNaming.NamingContextPackage.CannotProceed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.CannotProceed

  • Packages that use CannotProceed
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of CannotProceed in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw CannotProceed
      修饰符与类型 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of CannotProceed in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as CannotProceed
      修饰符与类型 | 字段与描述
      CannotProceed | CannotProceedHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return CannotProceed
      修饰符与类型 | 方法与描述
      static CannotProceed | CannotProceedHelper.extract(Any a)
      static CannotProceed | CannotProceedHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type CannotProceed
      修饰符与类型 | 方法与描述
      static void | CannotProceedHelper.insert(Any a, CannotProceed that)
      static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type CannotProceed
      构造方法与描述
      CannotProceedHolder(CannotProceed initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=a=MFtOAx.R=ia/r/rmS1


Uses of Class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

No usage of org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mde"clad


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidName

  • Packages that use InvalidName
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of InvalidName in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw InvalidName
      修饰符与类型 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      NameComponent[] _NamingContextExtStub.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      NameComponent[] NamingContextExtOperations.to_name(String sn)
      This operation converts a Stringified Name into an equivalent array of Name Components.
      String _NamingContextExtStub.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String NamingContextExtOperations.to_string(NameComponent[] n)
      This operation creates a stringified name from the array of Name components.
      String _NamingContextExtStub.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      String NamingContextExtOperations.to_url(String addr, String sn)
      This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of InvalidName in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as InvalidName
      修饰符与类型 | 字段与描述
      InvalidName | InvalidNameHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return InvalidName
      修饰符与类型 | 方法与描述
      static InvalidName | InvalidNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type InvalidName
      修饰符与类型 | 方法与描述
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type InvalidName
      构造方法与描述
      InvalidNameHolder(InvalidName initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

No usage of org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aoncs="c llld/aa tnt>


Uses of Class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.InvalidNameHolder

No usage of org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oa�"d a�黙)/�/痶g


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmpty

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmpty

  • Packages that use NotEmpty
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotEmpty in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw NotEmpty
      修饰符与类型 方法与描述
      void _NamingContextExtStub.destroy()
      The destroy operation deletes a naming context.
      void _NamingContextStub.destroy()
      The destroy operation deletes a naming context.
      void NamingContextOperations.destroy()
      The destroy operation deletes a naming context.

    • Uses of NotEmpty in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotEmpty
      修饰符与类型 | 字段与描述
      NotEmpty | NotEmptyHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return NotEmpty
      修饰符与类型 | 方法与描述
      static NotEmpty | NotEmptyHelper.extract(Any a)
      static NotEmpty | NotEmptyHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotEmpty
      修饰符与类型 | 方法与描述
      static void | NotEmptyHelper.insert(Any a, NotEmpty that)
      static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotEmpty
      构造方法与描述
      NotEmptyHolder(NotEmpty initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x/ue� n� "i


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oopeck""=bbba nnnCg_g


Uses of Class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotEmptyHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oT�"=bDX竌� gC/


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFound

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFound

  • Packages that use NotFound
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotFound in org.omg.CosNaming

      Methods in org.omg.CosNaming that throw NotFound
      修饰符与类型 方法与描述
      void _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      void NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc)
      Names an object that is a naming context.
      NamingContext _NamingContextExtStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext _NamingContextStub.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      NamingContext NamingContextOperations.bind_new_context(NameComponent[] n)
      This operation creates a new context and binds it to the name supplied as an argument.
      void _NamingContextExtStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextStub.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void NamingContextOperations.bind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context.
      void _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc)
      Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
      void _NamingContextExtStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void _NamingContextStub.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      void NamingContextOperations.rebind(NameComponent[] n, Object obj)
      Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
      Object _NamingContextExtStub.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object NamingContextExtOperations.resolve_str(String sn)
      This operation resolves the Stringified name into the object reference.
      Object _NamingContextExtStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object _NamingContextStub.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      Object NamingContextOperations.resolve(NameComponent[] n)
      The resolve operation is the process of retrieving an object bound to a name in a given context.
      void _NamingContextExtStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void _NamingContextStub.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.
      void NamingContextOperations.unbind(NameComponent[] n)
      The unbind operation removes a name binding from a context.

    • Uses of NotFound in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotFound
      修饰符与类型 | 字段与描述
      NotFound | NotFoundHolder.value
      Methods in org.omg.CosNaming.NamingContextPackage that return NotFound
      修饰符与类型 | 方法与描述
      static NotFound | NotFoundHelper.extract(Any a)
      static NotFound | NotFoundHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotFound
      修饰符与类型 | 方法与描述
      static void | NotFoundHelper.insert(Any a, NotFound that)
      static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotFound
      构造方法与描述
      NotFoundHolder(NotFound initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

萯wei.iv,eis .遇<迷允�


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etcmck""=bbba pp="cn;


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t�皢"=b晕4�< "a


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReason

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReason

  • Packages that use NotFoundReason
    软件包 描述
    org.omg.CosNaming.NamingContextPackage
    This package contains Exception classes for the org.omg.CosNaming package.

    • Uses of NotFoundReason in org.omg.CosNaming.NamingContextPackage

      Fields in org.omg.CosNaming.NamingContextPackage declared as NotFoundReason
      修饰符与类型 | 字段与描述
      static NotFoundReason | NotFoundReason.missing_node
      static NotFoundReason | NotFoundReason.not_context
      static NotFoundReason | NotFoundReason.not_object
      NotFoundReason | NotFoundReasonHolder.value
      NotFoundReason | NotFound.why
      Methods in org.omg.CosNaming.NamingContextPackage that return NotFoundReason
      修饰符与类型 | 方法与描述
      static NotFoundReason | NotFoundReasonHelper.extract(Any a)
      static NotFoundReason | NotFoundReason.from_int(int value)
      static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)
      Methods in org.omg.CosNaming.NamingContextPackage with parameters of type NotFoundReason
      修饰符与类型 | 方法与描述
      static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)
      static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)
      Constructors in org.omg.CosNaming.NamingContextPackage with parameters of type NotFoundReason
      构造方法与描述
      NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
      NotFoundReasonHolder(NotFoundReason initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.o.(///==cga


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"e>san >"<<


Uses of Class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder

No usage of org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>s� x"0僾s./


org.omg.Dynamic

Classes

  • Parameter


org.omg.Dynamic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.Dynamic

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.

请参见： 描述

  • Class Summary
    类 描述
    Parameter
    org/omg/Dynamic/Parameter.java .

软件包 org.omg.Dynamic Description

This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n )T a


org.omg.Dynamic Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.Dynamic

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"r..tdnxxx/.llyosk-s


Parameter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.Dynamic

类 Parameter

  • java.lang.Object
    • org.omg.Dynamic.Parameter
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Parameter
extends Object
implements IDLEntity
    org/omg/Dynamic/Parameter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Any argument
      ParameterMode mode

    • 构造方法摘要

      Constructors
      构造方法与描述
      Parameter()
      Parameter(Any _argument, ParameterMode _mode)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • argument

        public Any argument

      • mode

        public ParameterMode mode

    • 构造方法详细信息

      • Parameter

        public Parameter()

      • Parameter

        public Parameter(Any _argument,
         ParameterMode _mode)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oi fepeni"dgnt"E =.n rties#T�


Uses of Package org.omg.Dynamic

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.Dynamic

  • Packages that use org.omg.Dynamic
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.Dynamic used by org.omg.PortableInterceptor
    类与描述
    Parameter
    org/omg/Dynamic/Parameter.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"t- l>t>lrns>


Uses of Class org.omg.Dynamic.Parameter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.Dynamic.Parameter

  • Packages that use Parameter
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Parameter in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Parameter
      修饰符与类型 方法与描述
      Parameter[] RequestInfoOperations.arguments()
      Returns an array of Parameter objects, containing the arguments on the operation being invoked.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t ohABs


AnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 AnySeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper

  • public abstract class AnySeqHelper
extends Object
    org/omg/DynamicAny/AnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AnySeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Any[] | extract(Any a)
      static String | id()
      static void | insert(Any a, Any[] that)
      static Any[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Any[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AnySeqHelper

        public AnySeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Any[] that)

      • extract

        public static Any[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Any[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Any[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ea �-;ch etttss籄


DynAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAny

  • All Superinterfaces:
    DynAnyOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon
    All Known Implementing Classes:
    _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub

    public interface DynAny
extends DynAnyOperations, Object, IDLEntity
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ssN/l胕萳ry/td, 鵤"羒"g�


DynAnyFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynAnyFactory

  • All Superinterfaces:
    DynAnyFactoryOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynAnyFactoryStub

    public interface DynAnyFactory
extends DynAnyFactoryOperations, Object, IDLEntity
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyFactoryOperations

        create_dyn_any_from_type_code, create_dyn_any

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<-=MR AR DSS DDM=tt>>/M


DynAnyFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynAnyFactoryHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryHelper

  • public abstract class DynAnyFactoryHelper
extends Object
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynAnyFactoryHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynAnyFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAnyFactory that)
      static DynAnyFactory | narrow(Object obj)
      static DynAnyFactory | read(InputStream istream)
      static TypeCode | type()
      static DynAnyFactory | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynAnyFactory value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynAnyFactoryHelper

        public DynAnyFactoryHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynAnyFactory that)

      • extract

        public static DynAnyFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAnyFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynAnyFactory value)

      • narrow

        public static DynAnyFactory narrow(Object obj)

      • unchecked_narrow

        public static DynAnyFactory unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yptoAvBAgm..gmm纋ooat .<>/e>rneuu)C


DynAnyFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynAnyFactoryOperations

  • All Known Subinterfaces:
    DynAnyFactory
    All Known Implementing Classes:
    _DynAnyFactoryStub

    public interface DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DynAny create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

    • 方法详细信息

      • create_dyn_any

        DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
        Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise
        抛出：
        InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

      • create_dyn_any_from_type_code

        DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
        Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
        • false for boolean
        • zero for numeric types
        • zero for types octet, char, and wchar
        • the empty string for string and wstring
        • null for object references
        • a type code with a TCKind value of tk_null for type codes
        • for any values, an any containing a type code with a TCKind value of tk_null type and no value
        For complex types, creation of the corresponding DynAny assigns a default value as follows:
        • For DynSequence it sets the current position to -1 and creates an empty sequence.
        • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
        • For DynFixed it sets the current position to -1 and sets the value zero.
        • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
        • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
        • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
        • For DynValue and DynValueBox it initializes to a null value.
        抛出：
        InconsistentTypeCode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=s" a aemmaee;/uuR/.gmRelrree


_DynAnyFactoryStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynAnyFactoryStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyFactoryStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAnyFactory, DynAnyFactoryOperations

    public class _DynAnyFactoryStub
extends ObjectImpl
implements DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynAnyFactoryStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      DynAny create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynAnyFactoryStub

        public _DynAnyFactoryStub()

    • 方法详细信息

      • create_dyn_any

        public DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
        Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise
        指定者：
        create_dyn_any in interface DynAnyFactoryOperations
        抛出：
        InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

      • create_dyn_any_from_type_code

        public DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
        Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
        • false for boolean
        • zero for numeric types
        • zero for types octet, char, and wchar
        • the empty string for string and wstring
        • null for object references
        • a type code with a TCKind value of tk_null for type codes
        • for any values, an any containing a type code with a TCKind value of tk_null type and no value
        For complex types, creation of the corresponding DynAny assigns a default value as follows:
        • For DynSequence it sets the current position to -1 and creates an empty sequence.
        • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
        • For DynFixed it sets the current position to -1 and sets the value zero.
        • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
        • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
        • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
        • For DynValue and DynValueBox it initializes to a null value.
        指定者：
        create_dyn_any_from_type_code in interface DynAnyFactoryOperations
        抛出：
        InconsistentTypeCode

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< a8ann>LinninDeD>eig


DynAnyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynAnyHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyHelper

  • public abstract class DynAnyHelper
extends Object
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynAnyHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynAny | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAny that)
      static DynAny | narrow(Object obj)
      static DynAny | read(InputStream istream)
      static TypeCode | type()
      static DynAny | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynAny value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynAnyHelper

        public DynAnyHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynAny that)

      • extract

        public static DynAny extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAny read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynAny value)

      • narrow

        public static DynAny narrow(Object obj)

      • unchecked_narrow

        public static DynAny unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

x1aC_Lt/ClOmte


DynAnyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynAnyOperations

  • All Known Subinterfaces:
    DynAny, DynArray, DynArrayOperations, DynEnum, DynEnumOperations, DynFixed, DynFixedOperations, DynSequence, DynSequenceOperations, DynStruct, DynStructOperations, DynUnion, DynUnionOperations, DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations
    All Known Implementing Classes:
    _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub

    public interface DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

    • 方法详细信息

      • type

        TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        返回：
        The TypeCode associated with this DynAny object

      • assign

        void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        返回：
        a new Any object with the same value and TypeCode

      • equal

        boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.

      • copy

        DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.

      • rewind

        void rewind()
        Is equivalent to seek(0).

      • 下一个

        boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.

      • component_count

        int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.

      • current_component

        DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DynAnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynAnySeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnySeqHelper

  • public abstract class DynAnySeqHelper
extends Object
    org/omg/DynamicAny/DynAnySeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynAnySeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynAny[] | extract(Any a)
      static String | id()
      static void | insert(Any a, DynAny[] that)
      static DynAny[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DynAny[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynAnySeqHelper

        public DynAnySeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynAny[] that)

      • extract

        public static DynAny[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynAny[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynAny[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s"soprAerAnnnAnnnD//"ri"ovdvosctsaa">


_DynAnyStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynAnyStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations

    public class _DynAnyStub
extends ObjectImpl
implements DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynAnyStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynAnyStub

        public _DynAnyStub()

    • 方法详细信息

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DynArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynArray

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynArrayOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynArrayStub

    public interface DynArray
extends DynArrayOperations, DynAny, IDLEntity
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynArrayOperations

        get_elements_as_dyn_any, get_elements, set_elements_as_dyn_any, set_elements

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"O>"cnclai /lm#a-torhto y


DynArrayHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynArrayHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynArrayHelper

  • public abstract class DynArrayHelper
extends Object
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynArrayHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynArray | extract(Any a)
      static String | id()
      static void | insert(Any a, DynArray that)
      static DynArray | narrow(Object obj)
      static DynArray | read(InputStream istream)
      static TypeCode | type()
      static DynArray | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynArray value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynArrayHelper

        public DynArrayHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynArray that)

      • extract

        public static DynArray extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynArray read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynArray value)

      • narrow

        public static DynArray narrow(Object obj)

      • unchecked_narrow

        public static DynArray unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

) <>efagh"Sa-"> te.o>4gh riecppspg


DynArrayOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynArrayOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynArray
    All Known Implementing Classes:
    _DynArrayStub

    public interface DynArrayOperations
extends DynAnyOperations
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DynAny[] get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      Any[] get_elements()
      Returns the elements of the DynArray.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_elements

        Any[] get_elements()
        Returns the elements of the DynArray.

      • set_elements

        void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the DynArray to contain the passed elements.
        抛出：
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • get_elements_as_dyn_any

        DynAny[] get_elements_as_dyn_any()
        Returns the elements of the DynArray as DynAnys.

      • set_elements_as_dyn_any

        void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the DynArray to contain the passed elements.
        抛出：
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

OtjR BA;m/>gm&s.wmaynnyeit>re=r


_DynArrayStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynArrayStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynArrayStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynArray, DynArrayOperations

    public class _DynArrayStub
extends ObjectImpl
implements DynArray
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynArrayStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      Any[] get_elements()
      Returns the elements of the DynArray.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynArrayStub

        public _DynArrayStub()

    • 方法详细信息

      • get_elements

        public Any[] get_elements()
        Returns the elements of the DynArray.
        指定者：
        get_elements in interface DynArrayOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the DynArray to contain the passed elements.
        指定者：
        set_elements in interface DynArrayOperations
        抛出：
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the elements of the DynArray as DynAnys.
        指定者：
        get_elements_as_dyn_any in interface DynArrayOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the DynArray to contain the passed elements.
        指定者：
        set_elements_as_dyn_any in interface DynArrayOperations
        抛出：
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DynEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynEnum

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynEnumOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynEnumStub

    public interface DynEnum
extends DynEnumOperations, DynAny, IDLEntity
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynEnumOperations

        get_as_string, get_as_ulong, set_as_string, set_as_ulong

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aeval ii il>>ill/>uur /.o� >


DynEnumHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynEnumHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynEnumHelper

  • public abstract class DynEnumHelper
extends Object
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynEnumHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynEnum | extract(Any a)
      static String | id()
      static void | insert(Any a, DynEnum that)
      static DynEnum | narrow(Object obj)
      static DynEnum | read(InputStream istream)
      static TypeCode | type()
      static DynEnum | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynEnum value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynEnumHelper

        public DynEnumHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynEnum that)

      • extract

        public static DynEnum extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynEnum read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynEnum value)

      • narrow

        public static DynEnum narrow(Object obj)

      • unchecked_narrow

        public static DynEnum unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r asa/aia/
  • /lell= esscsliLd""a"f


DynEnumOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynEnumOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynEnum
    All Known Implementing Classes:
    _DynEnumStub

    public interface DynEnumOperations
extends DynAnyOperations
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String get_as_string()
      Returns the value of the DynEnum as an IDL identifier.
      int get_as_ulong()
      Returns the value of the DynEnum as the enumerated value's ordinal value.
      void set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_as_string

        String get_as_string()
        Returns the value of the DynEnum as an IDL identifier.

      • set_as_string

        void set_as_string(String value)
                   throws InvalidValue
        Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
        抛出：
        InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

      • get_as_ulong

        int get_as_ulong()
        Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.

      • set_as_ulong

        void set_as_ulong(int value)
                  throws InvalidValue
        Sets the value of the DynEnum as the enumerated value's ordinal value.
        抛出：
        InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tl"N=NNsNbvist i">>trrpbppns>baa


_DynEnumStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynEnumStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynEnumStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynEnum, DynEnumOperations

    public class _DynEnumStub
extends ObjectImpl
implements DynEnum
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynEnumStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      String get_as_string()
      Returns the value of the DynEnum as an IDL identifier.
      int get_as_ulong()
      Returns the value of the DynEnum as the enumerated value's ordinal value.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynEnumStub

        public _DynEnumStub()

    • 方法详细信息

      • get_as_string

        public String get_as_string()
        Returns the value of the DynEnum as an IDL identifier.
        指定者：
        get_as_string in interface DynEnumOperations

      • set_as_string

        public void set_as_string(String value)
                   throws InvalidValue
        Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
        指定者：
        set_as_string in interface DynEnumOperations
        抛出：
        InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

      • get_as_ulong

        public int get_as_ulong()
        Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.
        指定者：
        get_as_ulong in interface DynEnumOperations

      • set_as_ulong

        public void set_as_ulong(int value)
                  throws InvalidValue
        Sets the value of the DynEnum as the enumerated value's ordinal value.
        指定者：
        set_as_ulong in interface DynEnumOperations
        抛出：
        InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<=l <>>b//>"s


DynFixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynFixed

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynFixedOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynFixedStub

    public interface DynFixed
extends DynFixedOperations, DynAny, IDLEntity
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynFixedOperations

        get_value, set_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/vaua anals"n""ll//etrenatta


DynFixedHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynFixedHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynFixedHelper

  • public abstract class DynFixedHelper
extends Object
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynFixedHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynFixed | extract(Any a)
      static String | id()
      static void | insert(Any a, DynFixed that)
      static DynFixed | narrow(Object obj)
      static DynFixed | read(InputStream istream)
      static TypeCode | type()
      static DynFixed | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynFixed value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynFixedHelper

        public DynFixedHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynFixed that)

      • extract

        public static DynFixed extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynFixed read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynFixed value)

      • narrow

        public static DynFixed narrow(Object obj)

      • unchecked_narrow

        public static DynFixed unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e


DynFixedOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynFixedOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynFixed
    All Known Implementing Classes:
    _DynFixedStub

    public interface DynFixedOperations
extends DynAnyOperations
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String get_value()
      Returns the value of a DynFixed.
      boolean set_value(String val)
      Sets the value of the DynFixed.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_value

        String get_value()
        Returns the value of a DynFixed.

      • set_value

        boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
        Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.
        抛出：
        TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
        InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tbatstotetcrdetldt "slssb舷in蟜


_DynFixedStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynFixedStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynFixedStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynFixed, DynFixedOperations

    public class _DynFixedStub
extends ObjectImpl
implements DynFixed
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynFixedStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      String get_value()
      Returns the value of a DynFixed.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      boolean set_value(String val)
      Sets the value of the DynFixed.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynFixedStub

        public _DynFixedStub()

    • 方法详细信息

      • get_value

        public String get_value()
        Returns the value of a DynFixed.
        指定者：
        get_value in interface DynFixedOperations

      • set_value

        public boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
        Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.
        指定者：
        set_value in interface DynFixedOperations
        抛出：
        TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
        InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.eh/././x/.nexee."<<<>m Ann=atos>t蟬ssg>>tl>a�>h


DynSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynSequence

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynSequenceOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynSequenceStub

    public interface DynSequence
extends DynSequenceOperations, DynAny, IDLEntity
    DynSequence objects support the manipulation of IDL sequences.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynSequenceOperations

        get_elements_as_dyn_any, get_elements, get_length, set_elements_as_dyn_any, set_elements, set_length

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xs0/�/�/#/<>¡ 0� ;1, �,9f


DynSequenceOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynSequenceOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynSequence
    All Known Implementing Classes:
    _DynSequenceStub

    public interface DynSequenceOperations
extends DynAnyOperations
    DynSequence objects support the manipulation of IDL sequences.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DynAny[] get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      Any[] get_elements()
      Returns the elements of the sequence.
      int get_length()
      Returns the current length of the sequence.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void set_elements(Any[] value)
      Sets the elements of a sequence.
      void set_length(int len)
      Sets the length of the sequence.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_length

        int get_length()
        Returns the current length of the sequence.

      • set_length

        void set_length(int len)
                throws InvalidValue
        Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
        • If the length of the sequence is set to zero, the current position is set to -1.
        • If the current position is -1 before decreasing the length, it remains at -1.
        • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
        • If the current position indicates a valid element and that element is removed, the current position is set to -1.
        抛出：
        InvalidValue - if this is a bounded sequence and len is larger than the bound

      • get_elements

        Any[] get_elements()
        Returns the elements of the sequence.

      • set_elements

        void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        抛出：
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • get_elements_as_dyn_any

        DynAny[] get_elements_as_dyn_any()
        Returns the DynAnys representing the elements of the sequence.

      • set_elements_as_dyn_any

        void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        抛出：
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alvsa'>>d


_DynSequenceStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynSequenceStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynSequenceStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynSequence, DynSequenceOperations

    public class _DynSequenceStub
extends ObjectImpl
implements DynSequence
    DynSequence objects support the manipulation of IDL sequences.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynSequenceStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      Any[] get_elements()
      Returns the elements of the sequence.
      float get_float()
      Extracts the float value from this DynAny.
      int get_length()
      Returns the current length of the sequence.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void set_elements(Any[] value)
      Sets the elements of a sequence.
      void set_length(int len)
      Sets the length of the sequence.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynSequenceStub

        public _DynSequenceStub()

    • 方法详细信息

      • get_length

        public int get_length()
        Returns the current length of the sequence.
        指定者：
        get_length in interface DynSequenceOperations

      • set_length

        public void set_length(int len)
                throws InvalidValue
        Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
        • If the length of the sequence is set to zero, the current position is set to -1.
        • If the current position is -1 before decreasing the length, it remains at -1.
        • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
        • If the current position indicates a valid element and that element is removed, the current position is set to -1.
        指定者：
        set_length in interface DynSequenceOperations
        抛出：
        InvalidValue - if this is a bounded sequence and len is larger than the bound

      • get_elements

        public Any[] get_elements()
        Returns the elements of the sequence.
        指定者：
        get_elements in interface DynSequenceOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        指定者：
        set_elements in interface DynSequenceOperations
        抛出：
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the DynAnys representing the elements of the sequence.
        指定者：
        get_elements_as_dyn_any in interface DynSequenceOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        指定者：
        set_elements_as_dyn_any in interface DynSequenceOperations
        抛出：
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DynStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynStruct

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynStructOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynStructStub

    public interface DynStruct
extends DynStructOperations, DynAny, IDLEntity
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynStructOperations

        current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

annhog"ng"=ss"==ct// ih -f ou


DynStructHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynStructHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynStructHelper

  • public abstract class DynStructHelper
extends Object
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynStructHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynStruct | extract(Any a)
      static String | id()
      static void | insert(Any a, DynStruct that)
      static DynStruct | narrow(Object obj)
      static DynStruct | read(InputStream istream)
      static TypeCode | type()
      static DynStruct | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynStruct value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynStructHelper

        public DynStructHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynStruct that)

      • extract

        public static DynStruct extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynStruct read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynStruct value)

      • narrow

        public static DynStruct narrow(Object obj)

      • unchecked_narrow

        public static DynStruct unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o m.f"=" ahh aaa_ss>sssa aiti"ookat


DynStructOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynStructOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynStruct
    All Known Implementing Classes:
    _DynStructStub

    public interface DynStructOperations
extends DynAnyOperations
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • current_member_name

        String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        抛出：
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        抛出：
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • get_members

        NameValuePair[] get_members()
        Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

      • set_members

        void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • get_members_as_dyn_any

        NameDynAnyPair[] get_members_as_dyn_any()
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.

      • set_members_as_dyn_any

        void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ntgo/tm_t>rnst"Tar cnpVna {rxcy a


_DynStructStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynStructStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynStructStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynStruct, DynStructOperations

    public class _DynStructStub
extends ObjectImpl
implements DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynStructStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynStructStub

        public _DynStructStub()

    • 方法详细信息

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        指定者：
        current_member_name in interface DynStructOperations
        抛出：
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        指定者：
        current_member_kind in interface DynStructOperations
        抛出：
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
        Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        指定者：
        get_members in interface DynStructOperations

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        指定者：
        set_members in interface DynStructOperations
        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        指定者：
        get_members_as_dyn_any in interface DynStructOperations

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        指定者：
        set_members_as_dyn_any in interface DynStructOperations
        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DynUnion

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynUnion

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynUnionOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynUnionStub

    public interface DynUnion
extends DynUnionOperations, DynAny, IDLEntity
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynUnionOperations

        discriminator_kind, get_discriminator, has_no_active_member, member_kind, member_name, member, set_discriminator, set_to_default_member, set_to_no_active_member

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<


DynUnionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynUnionHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynUnionHelper

  • public abstract class DynUnionHelper
extends Object
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynUnionHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynUnion | extract(Any a)
      static String | id()
      static void | insert(Any a, DynUnion that)
      static DynUnion | narrow(Object obj)
      static DynUnion | read(InputStream istream)
      static TypeCode | type()
      static DynUnion | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynUnion value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynUnionHelper

        public DynUnionHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynUnion that)

      • extract

        public static DynUnion extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynUnion read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynUnion value)

      • narrow

        public static DynUnion narrow(Object obj)

      • unchecked_narrow

        public static DynUnion unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nadturuhteehtti>ll"loa nsnse"=hhmta


DynUnionOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynUnionOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynUnion
    All Known Implementing Classes:
    _DynUnionStub

    public interface DynUnionOperations
extends DynAnyOperations
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      DynAny get_discriminator()
      Returns the current discriminator value.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_discriminator

        DynAny get_discriminator()
        Returns the current discriminator value.

      • set_discriminator

        void set_discriminator(DynAny d)
                       throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        抛出：
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        void set_to_default_member()
                           throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        抛出：
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        void set_to_no_active_member()
                             throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        抛出：
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.

      • discriminator_kind

        TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.

      • member_kind

        TCKind member_kind()
                   throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        抛出：
        InvalidValue - if the union does not have a currently active member

      • member

        DynAny member()
              throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        抛出：
        InvalidValue - if the union has no active member

      • member_name

        String member_name()
                   throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        抛出：
        InvalidValue - if the union has no active member
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mxl


_DynUnionStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynUnionStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynUnionStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynUnion, DynUnionOperations

    public class _DynUnionStub
extends ObjectImpl
implements DynUnion
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynUnionStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      DynAny get_discriminator()
      Returns the current discriminator value.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynUnionStub

        public _DynUnionStub()

    • 方法详细信息

      • get_discriminator

        public DynAny get_discriminator()
        Returns the current discriminator value.
        指定者：
        get_discriminator in interface DynUnionOperations

      • set_discriminator

        public void set_discriminator(DynAny d)
                       throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        指定者：
        set_discriminator in interface DynUnionOperations
        抛出：
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        public void set_to_default_member()
                           throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        指定者：
        set_to_default_member in interface DynUnionOperations
        抛出：
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        public void set_to_no_active_member()
                             throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        指定者：
        set_to_no_active_member in interface DynUnionOperations
        抛出：
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        public boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.
        指定者：
        has_no_active_member in interface DynUnionOperations

      • discriminator_kind

        public TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.
        指定者：
        discriminator_kind in interface DynUnionOperations

      • member_kind

        public TCKind member_kind()
                   throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        指定者：
        member_kind in interface DynUnionOperations
        抛出：
        InvalidValue - if the union does not have a currently active member

      • member

        public DynAny member()
              throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        指定者：
        member in interface DynUnionOperations
        抛出：
        InvalidValue - if the union has no active member

      • member_name

        public String member_name()
                   throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        指定者：
        member_name in interface DynUnionOperations
        抛出：
        InvalidValue - if the union has no active member

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DynValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValue

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValue
extends DynValueOperations, DynValueCommon, IDLEntity
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueOperations

        current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fg=o rr"ss>ne tr


DynValueBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueBox

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, IDLEntity, Object, Serializable

    public interface DynValueBox
extends DynValueBoxOperations, DynValueCommon, IDLEntity
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueBoxOperations

        get_boxed_value_as_dyn_any, get_boxed_value, set_boxed_value_as_dyn_any, set_boxed_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-do/i> uie;;it细蟗ｊo


DynValueBoxOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynValueBoxOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValueBox

    public interface DynValueBoxOperations
extends DynValueCommonOperations
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DynAny get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      Any get_boxed_value()
      Returns the boxed value as an Any.
      void set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • get_boxed_value

        Any get_boxed_value()
                    throws InvalidValue
        Returns the boxed value as an Any.
        抛出：
        InvalidValue - if this object represents a null value box type

      • set_boxed_value

        void set_boxed_value(Any boxed)
                     throws TypeMismatch
        Replaces the boxed value with the specified value. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        抛出：
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.

      • get_boxed_value_as_dyn_any

        DynAny get_boxed_value_as_dyn_any()
                                  throws InvalidValue
        Returns the boxed value as a DynAny.
        抛出：
        InvalidValue - if this object represents a null value box type

      • set_boxed_value_as_dyn_any

        void set_boxed_value_as_dyn_any(DynAny boxed)
                                throws TypeMismatch
        Replaces the boxed value with the value contained in the parameter. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        抛出：
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/Vo=ah hwosswor ((A/AB/CtpCtr/o


DynValueCommon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueCommon

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommonOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    DynValue, DynValueBox
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommon
extends DynValueCommonOperations, DynAny, IDLEntity
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s =


DynValueCommonOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynValueCommonOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueOperations
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommonOperations
extends DynAnyOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • is_null

        boolean is_null()
        Returns true if the DynValueCommon represents a null value type.

      • set_to_null

        void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.

      • set_to_value

        void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xTe r . maeemaaeeaaMiM>imaM皏t


DynValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 DynValueHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynValueHelper

  • public abstract class DynValueHelper
extends Object
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynValueHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DynValue | extract(Any a)
      static String | id()
      static void | insert(Any a, DynValue that)
      static DynValue | narrow(Object obj)
      static DynValue | read(InputStream istream)
      static TypeCode | type()
      static DynValue | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynValue value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynValueHelper

        public DynValueHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DynValue that)

      • extract

        public static DynValue extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynValue read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DynValue value)

      • narrow

        public static DynValue narrow(Object obj)

      • unchecked_narrow

        public static DynValue unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

elCyAyyuyDVl


DynValueOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.DynamicAny

Interface DynValueOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValue
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueOperations
extends DynValueCommonOperations
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.

      • 方法 - 继承于接口 org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • 方法 - 继承于接口 org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, 下一个, rewind, seek, to_any, type

    • 方法详细信息

      • current_member_name

        String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        抛出：
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        抛出：
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        NameValuePair[] get_members()
                            throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        抛出：
        InvalidValue - if this object represents a null value type

      • set_members

        void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        抛出：
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=g"eipos eae/n rmkjedhk.a<a nBs


_DynValueStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 _DynValueStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynValueStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynValue, DynValueCommon, DynValueCommonOperations, DynValueOperations

    public class _DynValueStub
extends ObjectImpl
implements DynValue
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _DynValueStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      boolean 下一个()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _DynValueStub

        public _DynValueStub()

    • 方法详细信息

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        指定者：
        current_member_name in interface DynValueOperations
        抛出：
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        指定者：
        current_member_kind in interface DynValueOperations
        抛出：
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
                            throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        指定者：
        get_members in interface DynValueOperations
        抛出：
        InvalidValue - if this object represents a null value type

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        指定者：
        set_members in interface DynValueOperations
        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        指定者：
        get_members_as_dyn_any in interface DynValueOperations
        抛出：
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        指定者：
        set_members_as_dyn_any in interface DynValueOperations
        抛出：
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • is_null

        public boolean is_null()
        Returns true if the DynValueCommon represents a null value type.
        指定者：
        is_null in interface DynValueCommonOperations

      • set_to_null

        public void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.
        指定者：
        set_to_null in interface DynValueCommonOperations

      • set_to_value

        public void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
        指定者：
        set_to_value in interface DynValueCommonOperations

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        指定者：
        type in interface DynAnyOperations
        返回：
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        assign in interface DynAnyOperations
        参数：
        dyn_any -
        抛出：
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        指定者：
        from_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        指定者：
        to_any in interface DynAnyOperations
        返回：
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        指定者：
        equal in interface DynAnyOperations
        返回：
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        指定者：
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        指定者：
        copy in interface DynAnyOperations
        返回：
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        指定者：
        insert_boolean in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        insert_octet in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        指定者：
        insert_char in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        指定者：
        insert_short in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        insert_ushort in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        insert_long in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        insert_ulong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        指定者：
        insert_float in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        指定者：
        insert_double in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_string in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        指定者：
        insert_reference in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        指定者：
        insert_typecode in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        insert_longlong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        insert_ulonglong in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        insert_wchar in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        指定者：
        insert_wstring in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        指定者：
        insert_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        指定者：
        insert_dyn_any in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        insert_val in interface DynAnyOperations
        抛出：
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        指定者：
        get_boolean in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        指定者：
        get_octet in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        指定者：
        get_char in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        指定者：
        get_short in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        指定者：
        get_ushort in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        指定者：
        get_long in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        指定者：
        get_ulong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        指定者：
        get_float in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        指定者：
        get_double in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_string in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        指定者：
        get_reference in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        指定者：
        get_typecode in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        指定者：
        get_longlong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        指定者：
        get_ulonglong in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        指定者：
        get_wchar in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        指定者：
        get_wstring in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        指定者：
        get_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        指定者：
        get_dyn_any in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        指定者：
        get_val in interface DynAnyOperations
        抛出：
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        指定者：
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        指定者：
        rewind in interface DynAnyOperations

      • 下一个

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        指定者：
        下一个 in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        指定者：
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        指定者：
        current_component in interface DynAnyOperations
        抛出：
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


FieldNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 FieldNameHelper

  • java.lang.Object
    • org.omg.DynamicAny.FieldNameHelper

  • public abstract class FieldNameHelper
extends Object
    org/omg/DynamicAny/FieldNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      FieldNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FieldNameHelper

        public FieldNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=e=DEH=TH========!lli


NameDynAnyPair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.DynamicAny

类 NameDynAnyPair

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPair
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NameDynAnyPair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameDynAnyPair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String id
      The name associated with the DynAny.
      DynAny value
      The DynAny value associated with the name.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameDynAnyPair()
      NameDynAnyPair(String _id, DynAny _value)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • id

        public String id
        The name associated with the DynAny.

      • value

        public DynAny value
        The DynAny value associated with the name.

    • 构造方法详细信息

      • NameDynAnyPair

        public NameDynAnyPair()

      • NameDynAnyPair

        public NameDynAnyPair(String _id,
              DynAny _value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltia纑r/ADmAAAynyinya/mhnc


NameDynAnyPairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 NameDynAnyPairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairHelper

  • public abstract class NameDynAnyPairHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameDynAnyPairHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameDynAnyPair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair that)
      static NameDynAnyPair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameDynAnyPairHelper

        public NameDynAnyPairHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameDynAnyPair that)

      • extract

        public static NameDynAnyPair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameDynAnyPair value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dtm"nl"h>..ccig//( " mbed _ .


NameDynAnyPairSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 NameDynAnyPairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper

  • public abstract class NameDynAnyPairSeqHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameDynAnyPairSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameDynAnyPair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair[] that)
      static NameDynAnyPair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameDynAnyPairSeqHelper

        public NameDynAnyPairSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameDynAnyPair[] that)

      • extract

        public static NameDynAnyPair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameDynAnyPair[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rpB y a P cnslmthtcMeiaoc蝞


NameValuePair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.DynamicAny

类 NameValuePair

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePair
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NameValuePair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameValuePair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String id
      The name associated with the Any.
      Any value
      The Any value associated with the name.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameValuePair()
      NameValuePair(String _id, Any _value)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • id

        public String id
        The name associated with the Any.

      • value

        public Any value
        The Any value associated with the name.

    • 构造方法详细信息

      • NameValuePair

        public NameValuePair()

      • NameValuePair

        public NameValuePair(String _id,
             Any _value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>/> >a<<>aa>e==ai/ricc=><are"<


NameValuePairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 NameValuePairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairHelper

  • public abstract class NameValuePairHelper
extends Object
    org/omg/DynamicAny/NameValuePairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameValuePairHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameValuePair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair that)
      static NameValuePair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameValuePairHelper

        public NameValuePairHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameValuePair that)

      • extract

        public static NameValuePair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameValuePair value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ao9 � �0 >#00a<319b9&1/200,i癮芆O眉n


NameValuePairSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny

类 NameValuePairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairSeqHelper

  • public abstract class NameValuePairSeqHelper
extends Object
    org/omg/DynamicAny/NameValuePairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NameValuePairSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NameValuePair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair[] that)
      static NameValuePair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NameValuePairSeqHelper

        public NameValuePairSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NameValuePair[] that)

      • extract

        public static NameValuePair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NameValuePair[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<-/萳萾刃孺擞�<>x;/o#�;衋9913,, 99c1>


org.omg.DynamicAny

Interfaces

  • DynAny
  • DynAnyFactory
  • DynAnyFactoryOperations
  • DynAnyOperations
  • DynArray
  • DynArrayOperations
  • DynEnum
  • DynEnumOperations
  • DynFixed
  • DynFixedOperations
  • DynSequence
  • DynSequenceOperations
  • DynStruct
  • DynStructOperations
  • DynUnion
  • DynUnionOperations
  • DynValue
  • DynValueBox
  • DynValueBoxOperations
  • DynValueCommon
  • DynValueCommonOperations
  • DynValueOperations

Classes

  • _DynAnyFactoryStub
  • _DynAnyStub
  • _DynArrayStub
  • _DynEnumStub
  • _DynFixedStub
  • _DynSequenceStub
  • _DynStructStub
  • _DynUnionStub
  • _DynValueStub
  • AnySeqHelper
  • DynAnyFactoryHelper
  • DynAnyHelper
  • DynAnySeqHelper
  • DynArrayHelper
  • DynEnumHelper
  • DynFixedHelper
  • DynSequenceHelper
  • DynStructHelper
  • DynUnionHelper
  • DynValueHelper
  • FieldNameHelper
  • NameDynAnyPair
  • NameDynAnyPairHelper
  • NameDynAnyPairSeqHelper
  • NameValuePair
  • NameValuePairHelper
  • NameValuePairSeqHelper
e


org.omg.DynamicAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.DynamicAny

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

请参见： 描述

  • 接口摘要
    接口 描述
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBox
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
  • Class Summary
    类 描述
    _DynAnyFactoryStub
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    _DynAnyStub
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    _DynArrayStub
    DynArray objects support the manipulation of IDL arrays.
    _DynEnumStub
    DynEnum objects support the manipulation of IDL enumerated values.
    _DynFixedStub
    DynFixed objects support the manipulation of IDL fixed values.
    _DynSequenceStub
    DynSequence objects support the manipulation of IDL sequences.
    _DynStructStub
    DynStruct objects support the manipulation of IDL struct and exception values.
    _DynUnionStub
    DynUnion objects support the manipulation of IDL unions.
    _DynValueStub
    DynValue objects support the manipulation of IDL non-boxed value types.
    AnySeqHelper
    org/omg/DynamicAny/AnySeqHelper.java .
    DynAnyFactoryHelper
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyHelper
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnySeqHelper
    org/omg/DynamicAny/DynAnySeqHelper.java .
    DynArrayHelper
    DynArray objects support the manipulation of IDL arrays.
    DynEnumHelper
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixedHelper
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequenceHelper
    DynSequence objects support the manipulation of IDL sequences.
    DynStructHelper
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnionHelper
    DynUnion objects support the manipulation of IDL unions.
    DynValueHelper
    DynValue objects support the manipulation of IDL non-boxed value types.
    FieldNameHelper
    org/omg/DynamicAny/FieldNameHelper.java .
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameDynAnyPairHelper
    org/omg/DynamicAny/NameDynAnyPairHelper.java .
    NameDynAnyPairSeqHelper
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
    NameValuePairHelper
    org/omg/DynamicAny/NameValuePairHelper.java .
    NameValuePairSeqHelper
    org/omg/DynamicAny/NameValuePairSeqHelper.java .

软件包 org.omg.DynamicAny Description

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

An any can be passed to a program that doesn't have any static information for the type of the any (code generated for the type by an IDL compiler has not been compiled with the object implementation). As a result, the object receiving the any does not have a portable method of using it.

DynAnys enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value. This is especially helpful for writing powerful generic servers (bridges, event channels supporting filtering). Similarly, this facility enables the construction of an any at runtime, without having static knowledge of its type. This is especially helpful for writing generic clients (bridges, browsers, debuggers, user interface tools).

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an Any. A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty.

Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and 下一个 can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type). A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Handling DynAny objects

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

Basic operations include:

  • insert_boolean, get_boolean
  • insert_char, get_char
  • insert_short, get_short
  • insert_ushort, get_ushort
  • insert_long, get_long
  • insert_ulong, get_ulong
  • insert_double, get_double
  • insert_string, get_string
  • insert_reference, get_reference
  • insert_typecode, get_typecode
  • insert_longlong, get_longlong
  • insert_ulonglong, get_ulonglong
  • insert_longdouble, get_longdouble
  • insert_wchar, get_wchar
  • insert_wstring, get_wstring
  • insert_any, get_any
  • insert_dyn_any, get_dyn_any
  • insert_val, get_val
  • insert_octet, get_octet
  • insert_float, get_float
  • get_value
  • get_as_string
  • get_as_ulong
  • get_members
  • get_members_as_dyn_any
  • get_discriminator
  • get_length
  • get_elements
  • get_elements_as_dyn_any
  • get_boxed_value
  • get_boxed_value_as_dyn_any

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/he"rfuf1eS =yd�.kl9>mh


org.omg.DynamicAny Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.DynamicAny

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • org.omg.DynamicAny.FieldNameHelper
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)

Interface Hierarchy

  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • org.omg.CORBA.Object
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Package org.omg.DynamicAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.DynamicAny

  • Packages that use org.omg.DynamicAny
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
  • Classes in org.omg.DynamicAny used by org.omg.DynamicAny
    类与描述
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rBgopOpnyEEE"nnn=


Uses of Class org.omg.DynamicAny._DynAnyFactoryStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynAnyFactoryStub

No usage of org.omg.DynamicAny._DynAnyFactoryStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-ymotsn>sl>g/s


Uses of Class org.omg.DynamicAny._DynAnyStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynAnyStub

No usage of org.omg.DynamicAny._DynAnyStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tnrnr&s<�>皉/


Uses of Class org.omg.DynamicAny._DynArrayStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynArrayStub

No usage of org.omg.DynamicAny._DynArrayStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cof藅r";psv.a鸻hob{


Uses of Class org.omg.DynamicAny._DynEnumStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynEnumStub

No usage of org.omg.DynamicAny._DynEnumStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o纁t>�>lo�"veth.f�"<


Uses of Class org.omg.DynamicAny._DynFixedStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynFixedStub

No usage of org.omg.DynamicAny._DynFixedStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9rch~<>.� 扵x�


Uses of Class org.omg.DynamicAny._DynSequenceStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynSequenceStub

No usage of org.omg.DynamicAny._DynSequenceStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

as/ /sitbdiml9 u/


Uses of Class org.omg.DynamicAny._DynStructStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynStructStub

No usage of org.omg.DynamicAny._DynStructStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.DynamicAny._DynUnionStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynUnionStub

No usage of org.omg.DynamicAny._DynUnionStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>y|y>l/y<<


Uses of Class org.omg.DynamicAny._DynValueStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny._DynValueStub

No usage of org.omg.DynamicAny._DynValueStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"|�.餷 W)# 鋣ms


Uses of Class org.omg.DynamicAny.AnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.AnySeqHelper

No usage of org.omg.DynamicAny.AnySeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-s


Uses of Class org.omg.DynamicAny.DynAnyFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyFactoryHelper

No usage of org.omg.DynamicAny.DynAnyFactoryHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a"bnn>


Uses of Class org.omg.DynamicAny.DynAnyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyHelper

No usage of org.omg.DynamicAny.DynAnyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mAg../.fe=== e>> i"m"


Uses of Class org.omg.DynamicAny.DynAnySeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnySeqHelper

No usage of org.omg.DynamicAny.DynAnySeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rsrnulaamnnnhuaa.onno


Uses of Class org.omg.DynamicAny.DynArrayHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynArrayHelper

No usage of org.omg.DynamicAny.DynArrayHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" = cl ><<<i<


Uses of Class org.omg.DynamicAny.DynEnumHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynEnumHelper

No usage of org.omg.DynamicAny.DynEnumHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iorl &&f=cDb


Uses of Class org.omg.DynamicAny.DynFixedHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynFixedHelper

No usage of org.omg.DynamicAny.DynFixedHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltF r> >n ta""rei.&


Uses of Class org.omg.DynamicAny.DynSequenceHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynSequenceHelper

No usage of org.omg.DynamicAny.DynSequenceHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.DynamicAny.DynStructHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynStructHelper

No usage of org.omg.DynamicAny.DynStructHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

osnap;<&>nnnnsaau/f">


Uses of Class org.omg.DynamicAny.DynUnionHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynUnionHelper

No usage of org.omg.DynamicAny.DynUnionHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" = cl ><<<i<


Uses of Class org.omg.DynamicAny.DynValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynValueHelper

No usage of org.omg.DynamicAny.DynValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

" >Dg.oni c"hh>otoy


Uses of Class org.omg.DynamicAny.FieldNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.FieldNameHelper

No usage of org.omg.DynamicAny.FieldNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>li/Dy/gooo/.<


Uses of Class org.omg.DynamicAny.NameDynAnyPair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameDynAnyPair

  • Packages that use NameDynAnyPair
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of NameDynAnyPair in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return NameDynAnyPair
      修饰符与类型 | 方法与描述
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
      static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
      NameDynAnyPair[] _DynValueStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameDynAnyPair[] _DynStructStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameDynAnyPair[] DynValueOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameDynAnyPair[] DynStructOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
      static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny with parameters of type NameDynAnyPair
      修饰符与类型 | 方法与描述
      static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
      static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
      static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a g.s"d;l">,_slat= vl.


Uses of Class org.omg.DynamicAny.NameDynAnyPairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameDynAnyPairHelper

No usage of org.omg.DynamicAny.NameDynAnyPairHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.=. ong<>ssso/PPtcl a


Uses of Class org.omg.DynamicAny.NameDynAnyPairSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameDynAnyPairSeqHelper

No usage of org.omg.DynamicAny.NameDynAnyPairSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ye


Uses of Class org.omg.DynamicAny.NameValuePair

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameValuePair

  • Packages that use NameValuePair
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of NameValuePair in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that return NameValuePair
      修饰符与类型 | 方法与描述
      static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
      static NameValuePair | NameValuePairHelper.extract(Any a)
      NameValuePair[] _DynValueStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      NameValuePair[] _DynStructStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] DynValueOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      NameValuePair[] DynStructOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)
      static NameValuePair | NameValuePairHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny with parameters of type NameValuePair
      修饰符与类型 | 方法与描述
      static void | NameValuePairHelper.insert(Any a, NameValuePair that)
      static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
      static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c=V.ifais舠d.体k父ga


Uses of Class org.omg.DynamicAny.NameValuePairHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameValuePairHelper

No usage of org.omg.DynamicAny.NameValuePairHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o/r/ef=a< ndrrcdls.


Uses of Class org.omg.DynamicAny.NameValuePairSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.NameValuePairSeqHelper

No usage of org.omg.DynamicAny.NameValuePairSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ek=v詉limsccSr..2Ba


Uses of Interface org.omg.DynamicAny.DynAny

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynAny

  • Packages that use DynAny
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAny in org.omg.DynamicAny

      Subinterfaces of DynAny in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      Classes in org.omg.DynamicAny that implement DynAny
      修饰符与类型 类与描述
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Fields in org.omg.DynamicAny declared as DynAny
      修饰符与类型 字段与描述
      DynAny NameDynAnyPair.value
      The DynAny value associated with the name.
      Methods in org.omg.DynamicAny that return DynAny
      修饰符与类型 | 方法与描述
      DynAny _DynValueStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynUnionStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynStructStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynSequenceStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynFixedStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynEnumStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynArrayStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynAnyStub.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny DynAnyOperations.copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny _DynValueStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynUnionStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynStructStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynSequenceStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynFixedStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynEnumStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynArrayStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynAnyStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny DynAnyOperations.current_component()
      Returns the DynAny for the component at the current position.
      static DynAny[] | DynAnySeqHelper.extract(Any a)
      static DynAny | DynAnyHelper.extract(Any a)
      DynAny DynValueBoxOperations.get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      DynAny _DynUnionStub.get_discriminator()
      Returns the current discriminator value.
      DynAny DynUnionOperations.get_discriminator()
      Returns the current discriminator value.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] _DynSequenceStub.get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      DynAny[] _DynArrayStub.get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      DynAny[] DynSequenceOperations.get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      DynAny[] DynArrayOperations.get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      DynAny _DynUnionStub.member()
      Returns the currently active member.
      DynAny DynUnionOperations.member()
      Returns the currently active member.
      static DynAny | DynAnyHelper.narrow(Object obj)
      static DynAny[] | DynAnySeqHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.read(InputStream istream)
      static DynAny | DynAnyHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynAny
      修饰符与类型 | 方法与描述
      void _DynValueStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynUnionStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynStructStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynSequenceStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynFixedStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynEnumStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynArrayStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynAnyStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void DynAnyOperations.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      boolean _DynValueStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynUnionStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynStructStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynSequenceStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynFixedStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynEnumStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynArrayStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean _DynAnyStub.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      boolean DynAnyOperations.equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      static void | DynAnyHelper.insert(Any a, DynAny that)
      static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
      void DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void _DynUnionStub.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void DynUnionOperations.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
      static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
      Constructors in org.omg.DynamicAny with parameters of type DynAny
      构造方法与描述
      NameDynAnyPair(String _id, DynAny _value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.DynamicAny.DynAnyFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynAnyFactory

  • Packages that use DynAnyFactory
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyFactory in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynAnyFactory
      修饰符与类型 类与描述
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      Methods in org.omg.DynamicAny that return DynAnyFactory
      修饰符与类型 | 方法与描述
      static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
      static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
      static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
      static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynAnyFactory
      修饰符与类型 | 方法与描述
      static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
      static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lue"e>>>araas.ratNA"s.


Uses of Interface org.omg.DynamicAny.DynAnyFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynAnyFactoryOperations

  • Packages that use DynAnyFactoryOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyFactoryOperations in org.omg.DynamicAny

      Subinterfaces of DynAnyFactoryOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynAnyFactory
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
      Classes in org.omg.DynamicAny that implement DynAnyFactoryOperations
      修饰符与类型 类与描述
      class  _DynAnyFactoryStub
      DynAny objects can be created by invoking operations on the DynAnyFactory object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aantro..d>yeohmAorob


Uses of Interface org.omg.DynamicAny.DynAnyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynAnyOperations

  • Packages that use DynAnyOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynAnyOperations in org.omg.DynamicAny

      Subinterfaces of DynAnyOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynAny
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      interface  DynArrayOperations
      DynArray objects support the manipulation of IDL arrays.
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynEnumOperations
      DynEnum objects support the manipulation of IDL enumerated values.
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynFixedOperations
      DynFixed objects support the manipulation of IDL fixed values.
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynSequenceOperations
      DynSequence objects support the manipulation of IDL sequences.
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynStructOperations
      DynStruct objects support the manipulation of IDL struct and exception values.
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      interface  DynUnionOperations
      DynUnion objects support the manipulation of IDL unions.
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueBoxOperations
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueCommonOperations
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueOperations
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynAnyOperations
      修饰符与类型 类与描述
      class  _DynAnyStub
      Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9>m tt"o>nl/"./wy


Uses of Interface org.omg.DynamicAny.DynArray

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynArray

  • Packages that use DynArray
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynArray in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynArray
      修饰符与类型 类与描述
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
      Methods in org.omg.DynamicAny that return DynArray
      修饰符与类型 | 方法与描述
      static DynArray | DynArrayHelper.extract(Any a)
      static DynArray | DynArrayHelper.narrow(Object obj)
      static DynArray | DynArrayHelper.read(InputStream istream)
      static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynArray
      修饰符与类型 | 方法与描述
      static void | DynArrayHelper.insert(Any a, DynArray that)
      static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

acomu asssg,jot


Uses of Interface org.omg.DynamicAny.DynArrayOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynArrayOperations

  • Packages that use DynArrayOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynArrayOperations in org.omg.DynamicAny

      Subinterfaces of DynArrayOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynArray
      DynArray objects support the manipulation of IDL arrays.
      Classes in org.omg.DynamicAny that implement DynArrayOperations
      修饰符与类型 类与描述
      class  _DynArrayStub
      DynArray objects support the manipulation of IDL arrays.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

st"ban saaem=CD.s


Uses of Interface org.omg.DynamicAny.DynEnum

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynEnum

  • Packages that use DynEnum
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynEnum in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynEnum
      修饰符与类型 类与描述
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
      Methods in org.omg.DynamicAny that return DynEnum
      修饰符与类型 | 方法与描述
      static DynEnum | DynEnumHelper.extract(Any a)
      static DynEnum | DynEnumHelper.narrow(Object obj)
      static DynEnum | DynEnumHelper.read(InputStream istream)
      static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynEnum
      修饰符与类型 | 方法与描述
      static void | DynEnumHelper.insert(Any a, DynEnum that)
      static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g/,=>l/m< dta/mlf >l s


Uses of Interface org.omg.DynamicAny.DynEnumOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynEnumOperations

  • Packages that use DynEnumOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynEnumOperations in org.omg.DynamicAny

      Subinterfaces of DynEnumOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynEnum
      DynEnum objects support the manipulation of IDL enumerated values.
      Classes in org.omg.DynamicAny that implement DynEnumOperations
      修饰符与类型 类与描述
      class  _DynEnumStub
      DynEnum objects support the manipulation of IDL enumerated values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

atecTty/;/>llso.t..m/r=


Uses of Interface org.omg.DynamicAny.DynFixed

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynFixed

  • Packages that use DynFixed
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynFixed in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynFixed
      修饰符与类型 类与描述
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
      Methods in org.omg.DynamicAny that return DynFixed
      修饰符与类型 | 方法与描述
      static DynFixed | DynFixedHelper.extract(Any a)
      static DynFixed | DynFixedHelper.narrow(Object obj)
      static DynFixed | DynFixedHelper.read(InputStream istream)
      static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynFixed
      修饰符与类型 | 方法与描述
      static void | DynFixedHelper.insert(Any a, DynFixed that)
      static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.=mwM/i=gcTh>S>圠Uji


Uses of Interface org.omg.DynamicAny.DynFixedOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynFixedOperations

  • Packages that use DynFixedOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynFixedOperations in org.omg.DynamicAny

      Subinterfaces of DynFixedOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynFixed
      DynFixed objects support the manipulation of IDL fixed values.
      Classes in org.omg.DynamicAny that implement DynFixedOperations
      修饰符与类型 类与描述
      class  _DynFixedStub
      DynFixed objects support the manipulation of IDL fixed values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.DynamicAny.DynSequence

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynSequence

  • Packages that use DynSequence
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynSequence in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynSequence
      修饰符与类型 类与描述
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
      Methods in org.omg.DynamicAny that return DynSequence
      修饰符与类型 | 方法与描述
      static DynSequence | DynSequenceHelper.extract(Any a)
      static DynSequence | DynSequenceHelper.narrow(Object obj)
      static DynSequence | DynSequenceHelper.read(InputStream istream)
      static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynSequence
      修饰符与类型 | 方法与描述
      static void | DynSequenceHelper.insert(Any a, DynSequence that)
      static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.jxol/ Fenomhlsoa =oc �


Uses of Interface org.omg.DynamicAny.DynSequenceOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynSequenceOperations

  • Packages that use DynSequenceOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynSequenceOperations in org.omg.DynamicAny

      Subinterfaces of DynSequenceOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynSequence
      DynSequence objects support the manipulation of IDL sequences.
      Classes in org.omg.DynamicAny that implement DynSequenceOperations
      修饰符与类型 类与描述
      class  _DynSequenceStub
      DynSequence objects support the manipulation of IDL sequences.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f oodoco.ups/"(,iyoao糴


Uses of Interface org.omg.DynamicAny.DynStruct

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynStruct

  • Packages that use DynStruct
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynStruct in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynStruct
      修饰符与类型 类与描述
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
      Methods in org.omg.DynamicAny that return DynStruct
      修饰符与类型 | 方法与描述
      static DynStruct | DynStructHelper.extract(Any a)
      static DynStruct | DynStructHelper.narrow(Object obj)
      static DynStruct | DynStructHelper.read(InputStream istream)
      static DynStruct | DynStructHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynStruct
      修饰符与类型 | 方法与描述
      static void | DynStructHelper.insert(Any a, DynStruct that)
      static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r>Bonoibicr"b8>


Uses of Interface org.omg.DynamicAny.DynStructOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynStructOperations

  • Packages that use DynStructOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynStructOperations in org.omg.DynamicAny

      Subinterfaces of DynStructOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynStruct
      DynStruct objects support the manipulation of IDL struct and exception values.
      Classes in org.omg.DynamicAny that implement DynStructOperations
      修饰符与类型 类与描述
      class  _DynStructStub
      DynStruct objects support the manipulation of IDL struct and exception values.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r bt>tnie athptes蔲m .


Uses of Interface org.omg.DynamicAny.DynUnion

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynUnion

  • Packages that use DynUnion
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynUnion in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynUnion
      修饰符与类型 类与描述
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
      Methods in org.omg.DynamicAny that return DynUnion
      修饰符与类型 | 方法与描述
      static DynUnion | DynUnionHelper.extract(Any a)
      static DynUnion | DynUnionHelper.narrow(Object obj)
      static DynUnion | DynUnionHelper.read(InputStream istream)
      static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynUnion
      修饰符与类型 | 方法与描述
      static void | DynUnionHelper.insert(Any a, DynUnion that)
      static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

� 8/h


Uses of Interface org.omg.DynamicAny.DynUnionOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynUnionOperations

  • Packages that use DynUnionOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynUnionOperations in org.omg.DynamicAny

      Subinterfaces of DynUnionOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynUnion
      DynUnion objects support the manipulation of IDL unions.
      Classes in org.omg.DynamicAny that implement DynUnionOperations
      修饰符与类型 类与描述
      class  _DynUnionStub
      DynUnion objects support the manipulation of IDL unions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Aa/od.epNbDac


Uses of Interface org.omg.DynamicAny.DynValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValue

  • Packages that use DynValue
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValue in org.omg.DynamicAny

      Classes in org.omg.DynamicAny that implement DynValue
      修饰符与类型 类与描述
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
      Methods in org.omg.DynamicAny that return DynValue
      修饰符与类型 | 方法与描述
      static DynValue | DynValueHelper.extract(Any a)
      static DynValue | DynValueHelper.narrow(Object obj)
      static DynValue | DynValueHelper.read(InputStream istream)
      static DynValue | DynValueHelper.unchecked_narrow(Object obj)
      Methods in org.omg.DynamicAny with parameters of type DynValue
      修饰符与类型 | 方法与描述
      static void | DynValueHelper.insert(Any a, DynValue that)
      static void | DynValueHelper.write(OutputStream ostream, DynValue value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>a<;w ab =s/eo


Uses of Interface org.omg.DynamicAny.DynValueBox

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValueBox

No usage of org.omg.DynamicAny.DynValueBox
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.DynamicAny.DynValueBoxOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValueBoxOperations

  • Packages that use DynValueBoxOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueBoxOperations in org.omg.DynamicAny

      Subinterfaces of DynValueBoxOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

maanAt< "t n=orr/jnbe.ea


Uses of Interface org.omg.DynamicAny.DynValueCommon

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValueCommon

  • Packages that use DynValueCommon
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueCommon in org.omg.DynamicAny

      Subinterfaces of DynValueCommon in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueCommon
      修饰符与类型 类与描述
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

le=lhT/=ssealshs r=iUan3s


Uses of Interface org.omg.DynamicAny.DynValueCommonOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValueCommonOperations

  • Packages that use DynValueCommonOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueCommonOperations in org.omg.DynamicAny

      Subinterfaces of DynValueCommonOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      interface  DynValueBox
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueBoxOperations
      DynValueBox objects support the manipulation of IDL boxed value types.
      interface  DynValueCommon
      DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
      interface  DynValueOperations
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueCommonOperations
      修饰符与类型 类与描述
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

; crl齦>辵p


Uses of Interface org.omg.DynamicAny.DynValueOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.DynamicAny.DynValueOperations

  • Packages that use DynValueOperations
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

    • Uses of DynValueOperations in org.omg.DynamicAny

      Subinterfaces of DynValueOperations in org.omg.DynamicAny
      修饰符与类型 Interface and Description
      interface  DynValue
      DynValue objects support the manipulation of IDL non-boxed value types.
      Classes in org.omg.DynamicAny that implement DynValueOperations
      修饰符与类型 类与描述
      class  _DynValueStub
      DynValue objects support the manipulation of IDL non-boxed value types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

addpi>.>gf.Jr>>oelie.


InconsistentTypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.DynamicAny.DynAnyFactoryPackage

类 InconsistentTypeCode

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InconsistentTypeCode
extends UserException
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InconsistentTypeCode()
      InconsistentTypeCode(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InconsistentTypeCode

        public InconsistentTypeCode()

      • InconsistentTypeCode

        public InconsistentTypeCode(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.pp ╨a>gzeth


InconsistentTypeCodeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny.DynAnyFactoryPackage

类 InconsistentTypeCodeHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

  • public abstract class InconsistentTypeCodeHelper
extends Object
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InconsistentTypeCodeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InconsistentTypeCode | extract(Any a)
      static String | id()
      static void | insert(Any a, InconsistentTypeCode that)
      static InconsistentTypeCode | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InconsistentTypeCode value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InconsistentTypeCodeHelper

        public InconsistentTypeCodeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InconsistentTypeCode that)

      • extract

        public static InconsistentTypeCode extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InconsistentTypeCode read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InconsistentTypeCode value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/oe/tDgs.-lnr1Jsdc蕁r>


org.omg.DynamicAny.DynAnyFactoryPackage

Classes

  • InconsistentTypeCodeHelper

Exceptions

  • InconsistentTypeCode
8


org.omg.DynamicAny.DynAnyFactoryPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.DynamicAny.DynAnyFactoryPackage

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.

请参见： 描述

  • Class Summary
    类 描述
    InconsistentTypeCodeHelper
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java .
  • Exception Summary
    Exception 描述
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .

软件包 org.omg.DynamicAny.DynAnyFactoryPackage Description

This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类


org.omg.DynamicAny.DynAnyFactoryPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.DynamicAny.DynAnyFactoryPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/eo.//.////.rlli"g.r�


Uses of Package org.omg.DynamicAny.DynAnyFactoryPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.DynamicAny.DynAnyFactoryPackage

  • Packages that use org.omg.DynamicAny.DynAnyFactoryPackage
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
  • Classes in org.omg.DynamicAny.DynAnyFactoryPackage used by org.omg.DynamicAny
    类与描述
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
  • Classes in org.omg.DynamicAny.DynAnyFactoryPackage used by org.omg.DynamicAny.DynAnyFactoryPackage
    类与描述
    InconsistentTypeCode
    org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tia>srpsbsso>egvtp皌</


Uses of Class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode

  • Packages that use InconsistentTypeCode
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyFactoryPackage
    This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.

    • Uses of InconsistentTypeCode in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw InconsistentTypeCode
      修饰符与类型 方法与描述
      DynAny _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny _DynAnyFactoryStub.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.
      DynAny DynAnyFactoryOperations.create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

    • Uses of InconsistentTypeCode in org.omg.DynamicAny.DynAnyFactoryPackage

      Methods in org.omg.DynamicAny.DynAnyFactoryPackage that return InconsistentTypeCode
      修饰符与类型 | 方法与描述
      static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
      static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyFactoryPackage with parameters of type InconsistentTypeCode
      修饰符与类型 | 方法与描述
      static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)
      static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"er<&.�; rer<


Uses of Class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

No usage of org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aSs"olLss===ct//yyita


InvalidValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.DynamicAny.DynAnyPackage

类 InvalidValue

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidValue
extends UserException
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidValue()
      InvalidValue(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidValue

        public InvalidValue()

      • InvalidValue

        public InvalidValue(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i=ct=j.a ><


InvalidValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny.DynAnyPackage

类 InvalidValueHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

  • public abstract class InvalidValueHelper
extends Object
    org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidValueHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidValue | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidValue that)
      static InvalidValue | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidValue value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidValueHelper

        public InvalidValueHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidValue that)

      • extract

        public static InvalidValue extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidValue read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidValue value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

JJ蜤� 許<�/9


org.omg.DynamicAny.DynAnyPackage

Classes

  • InvalidValueHelper
  • TypeMismatchHelper

Exceptions

  • InvalidValue
  • TypeMismatch
>


org.omg.DynamicAny.DynAnyPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.DynamicAny.DynAnyPackage

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

请参见： 描述

  • Class Summary
    类 描述
    InvalidValueHelper
    org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java .
    TypeMismatchHelper
    org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java .
  • Exception Summary
    Exception 描述
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .

软件包 org.omg.DynamicAny.DynAnyPackage Description

This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

k"cakc&n


org.omg.DynamicAny.DynAnyPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.DynamicAny.DynAnyPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.DynamicAny.DynAnyPackage

类 TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeMismatch()
      TypeMismatch(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TypeMismatch

        public TypeMismatch()

      • TypeMismatch

        public TypeMismatch(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f e>eo"/oPdr/.<./ltt."tall"srsot>>


TypeMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.DynamicAny.DynAnyPackage

类 TypeMismatchHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

  • public abstract class TypeMismatchHelper
extends Object
    org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl Thursday, April 14, 2011 2:04:18 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeMismatchHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static TypeMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, TypeMismatch that)
      static TypeMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TypeMismatch value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TypeMismatchHelper

        public TypeMismatchHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          TypeMismatch that)

      • extract

        public static TypeMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TypeMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         TypeMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nh.agyg r dcs<i./ >>改傅胃o=


Uses of Package org.omg.DynamicAny.DynAnyPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.DynamicAny.DynAnyPackage

  • Packages that use org.omg.DynamicAny.DynAnyPackage
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
  • Classes in org.omg.DynamicAny.DynAnyPackage used by org.omg.DynamicAny
    类与描述
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .
  • Classes in org.omg.DynamicAny.DynAnyPackage used by org.omg.DynamicAny.DynAnyPackage
    类与描述
    InvalidValue
    org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
    TypeMismatch
    org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y// gsdtd nwv/d


Uses of Class org.omg.DynamicAny.DynAnyPackage.InvalidValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyPackage.InvalidValue

  • Packages that use InvalidValue
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

    • Uses of InvalidValue in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw InvalidValue
      修饰符与类型 方法与描述
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String _DynValueStub.current_member_name()
      Returns the name of the member at the current position.
      String _DynStructStub.current_member_name()
      Returns the name of the member at the current position.
      String DynValueOperations.current_member_name()
      Returns the name of the member at the current position.
      String DynStructOperations.current_member_name()
      Returns the name of the member at the current position.
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean _DynValueStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynUnionStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynStructStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynSequenceStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynFixedStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynEnumStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynArrayStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynAnyStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean DynAnyOperations.get_boolean()
      Extracts the boolean value from this DynAny.
      DynAny DynValueBoxOperations.get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      Any DynValueBoxOperations.get_boxed_value()
      Returns the boxed value as an Any.
      char _DynValueStub.get_char()
      Extracts the char value from this DynAny.
      char _DynUnionStub.get_char()
      Extracts the char value from this DynAny.
      char _DynStructStub.get_char()
      Extracts the char value from this DynAny.
      char _DynSequenceStub.get_char()
      Extracts the char value from this DynAny.
      char _DynFixedStub.get_char()
      Extracts the char value from this DynAny.
      char _DynEnumStub.get_char()
      Extracts the char value from this DynAny.
      char _DynArrayStub.get_char()
      Extracts the char value from this DynAny.
      char _DynAnyStub.get_char()
      Extracts the char value from this DynAny.
      char DynAnyOperations.get_char()
      Extracts the char value from this DynAny.
      double _DynValueStub.get_double()
      Extracts the double value from this DynAny.
      double _DynUnionStub.get_double()
      Extracts the double value from this DynAny.
      double _DynStructStub.get_double()
      Extracts the double value from this DynAny.
      double _DynSequenceStub.get_double()
      Extracts the double value from this DynAny.
      double _DynFixedStub.get_double()
      Extracts the double value from this DynAny.
      double _DynEnumStub.get_double()
      Extracts the double value from this DynAny.
      double _DynArrayStub.get_double()
      Extracts the double value from this DynAny.
      double _DynAnyStub.get_double()
      Extracts the double value from this DynAny.
      double DynAnyOperations.get_double()
      Extracts the double value from this DynAny.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float _DynValueStub.get_float()
      Extracts the float value from this DynAny.
      float _DynUnionStub.get_float()
      Extracts the float value from this DynAny.
      float _DynStructStub.get_float()
      Extracts the float value from this DynAny.
      float _DynSequenceStub.get_float()
      Extracts the float value from this DynAny.
      float _DynFixedStub.get_float()
      Extracts the float value from this DynAny.
      float _DynEnumStub.get_float()
      Extracts the float value from this DynAny.
      float _DynArrayStub.get_float()
      Extracts the float value from this DynAny.
      float _DynAnyStub.get_float()
      Extracts the float value from this DynAny.
      float DynAnyOperations.get_float()
      Extracts the float value from this DynAny.
      int _DynValueStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynFixedStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_long()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_long()
      Extracts the integer value from this DynAny.
      long _DynValueStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynFixedStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_longlong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] _DynValueStub.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameDynAnyPair[] DynValueOperations.get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] _DynValueStub.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      NameValuePair[] DynValueOperations.get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      byte _DynValueStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynUnionStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynStructStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynSequenceStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynFixedStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynEnumStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynArrayStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynAnyStub.get_octet()
      Extracts the byte value from this DynAny.
      byte DynAnyOperations.get_octet()
      Extracts the byte value from this DynAny.
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short _DynValueStub.get_short()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_short()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_short()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_short()
      Extracts the short value from this DynAny.
      short _DynFixedStub.get_short()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_short()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_short()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_short()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_short()
      Extracts the short value from this DynAny.
      String _DynValueStub.get_string()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_string()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_string()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_string()
      Extracts the string value from this DynAny.
      String _DynFixedStub.get_string()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_string()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_string()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_string()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_string()
      Extracts the string value from this DynAny.
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      int _DynValueStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynFixedStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_ulong()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_ulong()
      Extracts the integer value from this DynAny.
      long _DynValueStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynFixedStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_ulonglong()
      Extracts the long value from this DynAny.
      short _DynValueStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynFixedStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_ushort()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_ushort()
      Extracts the short value from this DynAny.
      Serializable _DynValueStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynUnionStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynStructStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynSequenceStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynFixedStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynEnumStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynArrayStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynAnyStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable DynAnyOperations.get_val()
      Extracts a Serializable object from this DynAny.
      char _DynValueStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynUnionStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynStructStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynSequenceStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynFixedStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynEnumStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynArrayStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynAnyStub.get_wchar()
      Extracts the long value from this DynAny.
      char DynAnyOperations.get_wchar()
      Extracts the long value from this DynAny.
      String _DynValueStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynFixedStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_wstring()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_wstring()
      Extracts the string value from this DynAny.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynValueStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynUnionStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynStructStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynSequenceStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynFixedStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynEnumStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynArrayStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynAnyStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void DynAnyOperations.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynValueStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynUnionStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynStructStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynSequenceStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynFixedStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynEnumStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynArrayStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynAnyStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void DynAnyOperations.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynValueStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynUnionStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynStructStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynSequenceStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynFixedStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynEnumStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynArrayStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynAnyStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void DynAnyOperations.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynValueStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynUnionStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynStructStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynSequenceStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynFixedStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynEnumStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynArrayStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynAnyStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void DynAnyOperations.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynValueStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynValueStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynUnionStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynStructStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynSequenceStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynFixedStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynEnumStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynArrayStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynAnyStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void DynAnyOperations.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynValueStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_wstring(String value)
      Inserts a string value into the DynAny.
      TCKind _DynUnionStub.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      TCKind DynUnionOperations.member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String _DynUnionStub.member_name()
      Returns the name of the currently active member.
      String DynUnionOperations.member_name()
      Returns the name of the currently active member.
      DynAny _DynUnionStub.member()
      Returns the currently active member.
      DynAny DynUnionOperations.member()
      Returns the currently active member.
      void _DynEnumStub.set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void DynEnumOperations.set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void _DynEnumStub.set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      void DynEnumOperations.set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void _DynSequenceStub.set_length(int len)
      Sets the length of the sequence.
      void DynSequenceOperations.set_length(int len)
      Sets the length of the sequence.
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      boolean _DynFixedStub.set_value(String val)
      Sets the value of the DynFixed.
      boolean DynFixedOperations.set_value(String val)
      Sets the value of the DynFixed.

    • Uses of InvalidValue in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return InvalidValue
      修饰符与类型 | 方法与描述
      static InvalidValue | InvalidValueHelper.extract(Any a)
      static InvalidValue | InvalidValueHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type InvalidValue
      修饰符与类型 | 方法与描述
      static void | InvalidValueHelper.insert(Any a, InvalidValue that)
      static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

No usage of org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/v..ref<>aaaoouudoa


Uses of Class org.omg.DynamicAny.DynAnyPackage.TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyPackage.TypeMismatch

  • Packages that use TypeMismatch
    软件包 描述
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
    org.omg.DynamicAny.DynAnyPackage
    This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.

    • Uses of TypeMismatch in org.omg.DynamicAny

      Methods in org.omg.DynamicAny that throw TypeMismatch
      修饰符与类型 方法与描述
      void _DynValueStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynUnionStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynStructStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynSequenceStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynFixedStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynEnumStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynArrayStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void _DynAnyStub.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      void DynAnyOperations.assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      DynAny _DynValueStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynUnionStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynStructStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynSequenceStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynFixedStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynEnumStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynArrayStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny _DynAnyStub.current_component()
      Returns the DynAny for the component at the current position.
      DynAny DynAnyOperations.current_component()
      Returns the DynAny for the component at the current position.
      TCKind _DynValueStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind _DynStructStub.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynValueOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      TCKind DynStructOperations.current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String _DynValueStub.current_member_name()
      Returns the name of the member at the current position.
      String _DynStructStub.current_member_name()
      Returns the name of the member at the current position.
      String DynValueOperations.current_member_name()
      Returns the name of the member at the current position.
      String DynStructOperations.current_member_name()
      Returns the name of the member at the current position.
      void _DynValueStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynUnionStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynStructStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynSequenceStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynFixedStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynEnumStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynArrayStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void _DynAnyStub.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      void DynAnyOperations.from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any _DynValueStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynUnionStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynStructStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynSequenceStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynFixedStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynEnumStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynArrayStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any _DynAnyStub.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      Any DynAnyOperations.get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean _DynValueStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynUnionStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynStructStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynSequenceStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynFixedStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynEnumStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynArrayStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean _DynAnyStub.get_boolean()
      Extracts the boolean value from this DynAny.
      boolean DynAnyOperations.get_boolean()
      Extracts the boolean value from this DynAny.
      char _DynValueStub.get_char()
      Extracts the char value from this DynAny.
      char _DynUnionStub.get_char()
      Extracts the char value from this DynAny.
      char _DynStructStub.get_char()
      Extracts the char value from this DynAny.
      char _DynSequenceStub.get_char()
      Extracts the char value from this DynAny.
      char _DynFixedStub.get_char()
      Extracts the char value from this DynAny.
      char _DynEnumStub.get_char()
      Extracts the char value from this DynAny.
      char _DynArrayStub.get_char()
      Extracts the char value from this DynAny.
      char _DynAnyStub.get_char()
      Extracts the char value from this DynAny.
      char DynAnyOperations.get_char()
      Extracts the char value from this DynAny.
      double _DynValueStub.get_double()
      Extracts the double value from this DynAny.
      double _DynUnionStub.get_double()
      Extracts the double value from this DynAny.
      double _DynStructStub.get_double()
      Extracts the double value from this DynAny.
      double _DynSequenceStub.get_double()
      Extracts the double value from this DynAny.
      double _DynFixedStub.get_double()
      Extracts the double value from this DynAny.
      double _DynEnumStub.get_double()
      Extracts the double value from this DynAny.
      double _DynArrayStub.get_double()
      Extracts the double value from this DynAny.
      double _DynAnyStub.get_double()
      Extracts the double value from this DynAny.
      double DynAnyOperations.get_double()
      Extracts the double value from this DynAny.
      DynAny _DynValueStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynUnionStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynStructStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynSequenceStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynFixedStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynEnumStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynArrayStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny _DynAnyStub.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny DynAnyOperations.get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float _DynValueStub.get_float()
      Extracts the float value from this DynAny.
      float _DynUnionStub.get_float()
      Extracts the float value from this DynAny.
      float _DynStructStub.get_float()
      Extracts the float value from this DynAny.
      float _DynSequenceStub.get_float()
      Extracts the float value from this DynAny.
      float _DynFixedStub.get_float()
      Extracts the float value from this DynAny.
      float _DynEnumStub.get_float()
      Extracts the float value from this DynAny.
      float _DynArrayStub.get_float()
      Extracts the float value from this DynAny.
      float _DynAnyStub.get_float()
      Extracts the float value from this DynAny.
      float DynAnyOperations.get_float()
      Extracts the float value from this DynAny.
      int _DynValueStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynFixedStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_long()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_long()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_long()
      Extracts the integer value from this DynAny.
      long _DynValueStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynFixedStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_longlong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_longlong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_longlong()
      Extracts the long value from this DynAny.
      byte _DynValueStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynUnionStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynStructStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynSequenceStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynFixedStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynEnumStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynArrayStub.get_octet()
      Extracts the byte value from this DynAny.
      byte _DynAnyStub.get_octet()
      Extracts the byte value from this DynAny.
      byte DynAnyOperations.get_octet()
      Extracts the byte value from this DynAny.
      Object _DynValueStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynUnionStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynStructStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynSequenceStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynFixedStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynEnumStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynArrayStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object _DynAnyStub.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      Object DynAnyOperations.get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short _DynValueStub.get_short()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_short()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_short()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_short()
      Extracts the short value from this DynAny.
      short _DynFixedStub.get_short()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_short()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_short()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_short()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_short()
      Extracts the short value from this DynAny.
      String _DynValueStub.get_string()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_string()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_string()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_string()
      Extracts the string value from this DynAny.
      String _DynFixedStub.get_string()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_string()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_string()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_string()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_string()
      Extracts the string value from this DynAny.
      TypeCode _DynValueStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynUnionStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynStructStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynSequenceStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynFixedStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynEnumStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynArrayStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode _DynAnyStub.get_typecode()
      Extracts the TypeCode object from this DynAny.
      TypeCode DynAnyOperations.get_typecode()
      Extracts the TypeCode object from this DynAny.
      int _DynValueStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynUnionStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynStructStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynSequenceStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynFixedStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynEnumStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynArrayStub.get_ulong()
      Extracts the integer value from this DynAny.
      int _DynAnyStub.get_ulong()
      Extracts the integer value from this DynAny.
      int DynAnyOperations.get_ulong()
      Extracts the integer value from this DynAny.
      long _DynValueStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynUnionStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynStructStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynSequenceStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynFixedStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynEnumStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynArrayStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long _DynAnyStub.get_ulonglong()
      Extracts the long value from this DynAny.
      long DynAnyOperations.get_ulonglong()
      Extracts the long value from this DynAny.
      short _DynValueStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynUnionStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynStructStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynSequenceStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynFixedStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynEnumStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynArrayStub.get_ushort()
      Extracts the short value from this DynAny.
      short _DynAnyStub.get_ushort()
      Extracts the short value from this DynAny.
      short DynAnyOperations.get_ushort()
      Extracts the short value from this DynAny.
      Serializable _DynValueStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynUnionStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynStructStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynSequenceStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynFixedStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynEnumStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynArrayStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable _DynAnyStub.get_val()
      Extracts a Serializable object from this DynAny.
      Serializable DynAnyOperations.get_val()
      Extracts a Serializable object from this DynAny.
      char _DynValueStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynUnionStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynStructStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynSequenceStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynFixedStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynEnumStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynArrayStub.get_wchar()
      Extracts the long value from this DynAny.
      char _DynAnyStub.get_wchar()
      Extracts the long value from this DynAny.
      char DynAnyOperations.get_wchar()
      Extracts the long value from this DynAny.
      String _DynValueStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynUnionStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynStructStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynSequenceStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynFixedStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynEnumStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynArrayStub.get_wstring()
      Extracts the string value from this DynAny.
      String _DynAnyStub.get_wstring()
      Extracts the string value from this DynAny.
      String DynAnyOperations.get_wstring()
      Extracts the string value from this DynAny.
      void _DynValueStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynUnionStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynStructStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynSequenceStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynFixedStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynEnumStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynArrayStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynAnyStub.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void DynAnyOperations.insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void _DynValueStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynUnionStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynStructStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynSequenceStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynFixedStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynEnumStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynArrayStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynAnyStub.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void DynAnyOperations.insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void _DynValueStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_char(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_char(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynUnionStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynStructStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynSequenceStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynFixedStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynEnumStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynArrayStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynAnyStub.insert_double(double value)
      Inserts a double value into the DynAny.
      void DynAnyOperations.insert_double(double value)
      Inserts a double value into the DynAny.
      void _DynValueStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynUnionStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynStructStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynSequenceStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynFixedStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynEnumStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynArrayStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynAnyStub.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void DynAnyOperations.insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void _DynValueStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynUnionStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynStructStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynSequenceStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynFixedStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynEnumStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynArrayStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynAnyStub.insert_float(float value)
      Inserts a float value into the DynAny.
      void DynAnyOperations.insert_float(float value)
      Inserts a float value into the DynAny.
      void _DynValueStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_long(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_long(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_longlong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynUnionStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynStructStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynSequenceStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynFixedStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynEnumStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynArrayStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynAnyStub.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void DynAnyOperations.insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void _DynValueStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynUnionStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynStructStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynSequenceStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynFixedStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynEnumStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynArrayStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynAnyStub.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void DynAnyOperations.insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void _DynValueStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_short(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_short(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_string(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_string(String value)
      Inserts a string value into the DynAny.
      void _DynValueStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynUnionStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynStructStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynSequenceStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynFixedStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynEnumStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynArrayStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynAnyStub.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void DynAnyOperations.insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void _DynValueStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynUnionStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynStructStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynSequenceStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynFixedStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynEnumStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynArrayStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynAnyStub.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void DynAnyOperations.insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void _DynValueStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynUnionStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynStructStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynSequenceStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynFixedStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynEnumStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynArrayStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynAnyStub.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void DynAnyOperations.insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void _DynValueStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynUnionStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynStructStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynSequenceStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynFixedStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynEnumStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynArrayStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynAnyStub.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void DynAnyOperations.insert_ushort(short value)
      Inserts a short value into the DynAny.
      void _DynValueStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynUnionStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynStructStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynSequenceStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynFixedStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynEnumStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynArrayStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynAnyStub.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void DynAnyOperations.insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void _DynValueStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynUnionStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynStructStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynSequenceStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynFixedStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynEnumStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynArrayStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynAnyStub.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void DynAnyOperations.insert_wchar(char value)
      Inserts a char value into the DynAny.
      void _DynValueStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynUnionStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynStructStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynSequenceStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynFixedStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynEnumStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynArrayStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void _DynAnyStub.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynAnyOperations.insert_wstring(String value)
      Inserts a string value into the DynAny.
      void DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void DynValueBoxOperations.set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.
      void _DynUnionStub.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void DynUnionOperations.set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void _DynArrayStub.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void DynArrayOperations.set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void _DynSequenceStub.set_elements(Any[] value)
      Sets the elements of a sequence.
      void _DynArrayStub.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void DynSequenceOperations.set_elements(Any[] value)
      Sets the elements of a sequence.
      void DynArrayOperations.set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      void _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void _DynValueStub.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void _DynStructStub.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void DynValueOperations.set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void DynStructOperations.set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      void _DynUnionStub.set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void DynUnionOperations.set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void _DynUnionStub.set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      void DynUnionOperations.set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      boolean _DynFixedStub.set_value(String val)
      Sets the value of the DynFixed.
      boolean DynFixedOperations.set_value(String val)
      Sets the value of the DynFixed.

    • Uses of TypeMismatch in org.omg.DynamicAny.DynAnyPackage

      Methods in org.omg.DynamicAny.DynAnyPackage that return TypeMismatch
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      Methods in org.omg.DynamicAny.DynAnyPackage with parameters of type TypeMismatch
      修饰符与类型 | 方法与描述
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

No usage of org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/yssny)D.yyyA.ss. ..i


Codec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface Codec

  • All Superinterfaces:
    CodecOperations, IDLEntity, Object, Serializable

    public interface Codec
extends CodecOperations, Object, IDLEntity
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • 方法摘要

      • 方法 - 继承于接口 org.omg.IOP.CodecOperations

        decode_value, decode, encode_value, encode

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>sctp .f"


CodecFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface CodecFactory

  • All Superinterfaces:
    CodecFactoryOperations, IDLEntity, Object, Serializable

    public interface CodecFactory
extends CodecFactoryOperations, Object, IDLEntity
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • 方法摘要

      • 方法 - 继承于接口 org.omg.IOP.CodecFactoryOperations

        create_codec

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s3,foftfmfotf swad,r“术毒�.


CodecFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 CodecFactoryHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper

  • public abstract class CodecFactoryHelper
extends Object
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • 构造方法摘要

      Constructors
      构造方法与描述
      CodecFactoryHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static CodecFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, CodecFactory that)
      static CodecFactory | narrow(Object obj)
      static CodecFactory | read(InputStream istream)
      static TypeCode | type()
      static CodecFactory | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, CodecFactory value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CodecFactoryHelper

        public CodecFactoryHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          CodecFactory that)

      • extract

        public static CodecFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CodecFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         CodecFactory value)

      • narrow

        public static CodecFactory narrow(Object obj)

      • unchecked_narrow

        public static CodecFactory unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.o.>ise/n -v> peU-peL l a


CodecFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.IOP

Interface CodecFactoryOperations

  • All Known Subinterfaces:
    CodecFactory

    public interface CodecFactoryOperations
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Codec create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • 方法详细信息

      • create_codec

        Codec create_codec(Encoding enc)
                   throws UnknownEncoding
        Create a Codec of the given encoding.

        参数：
        enc - The encoding for which to create a Codec.
        返回：
        A Codec obtained with the given encoding.
        抛出：
        UnknownEncoding - thrown if this factory cannot create a Codec of the given encoding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.>.e>ac


CodecOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.IOP

Interface CodecOperations

  • All Known Subinterfaces:
    Codec

    public interface CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Any decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.
      byte[] encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • 方法详细信息

      • encode

        byte[] encode(Any data)
              throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec.
        参数：
        data - The data, in the form of an any, to be encoded into a byte array.
        返回：
        A byte array containing the encoded Any. This byte array contains both the TypeCode and the data of the type.
        抛出：
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode

        Any decode(byte[] data)
           throws FormatMismatch
        Decodes the given byte array into an Any based on the encoding format effective for this Codec.
        参数：
        data - The data, in the form of a byte array, to be decoded into an Any.
        返回：
        An Any containing the data from the decoded byte array.
        抛出：
        FormatMismatch - is thrown if the byte array cannot be decoded into an Any.

      • encode_value

        byte[] encode_value(Any data)
                    throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec. Only the data from the Any is encoded, not the TypeCode.
        参数：
        data - The data, in the form of an Any, to be encoded into a byte array.
        返回：
        A byte array containing the data from the encoded any.
        抛出：
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode_value

        Any decode_value(byte[] data,
               TypeCode tc)
                 throws FormatMismatch,
                        TypeMismatch
        Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
        参数：
        data - The data, in the form of a byte array, to be decoded into an Any.
        tc - The TypeCode to be used to decode the data.
        返回：
        An Any containing the data from the decoded byte array.
        抛出：
        FormatMismatch - thrown if the byte array cannot be decoded into an Any.
        TypeMismatch
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esrte/ptcrOmrrF.m膔o藅s,sr�<


CodeSets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface CodeSets

  • public interface CodeSets
    org/omg/IOP/CodeSets.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.

    • 字段详细信息

      • value

        static final int value
        Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;dl /l><="


ComponentIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ComponentIdHelper

  • java.lang.Object
    • org.omg.IOP.ComponentIdHelper

  • public abstract class ComponentIdHelper
extends Object
    Standard way of representing multicomponent profiles. This would be encapsulated in a TaggedProfile.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ComponentIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ComponentIdHelper

        public ComponentIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Dde>L>a>>"Daiiaa sivi>/><&nnssf<


Encoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP

类 Encoding

  • java.lang.Object
    • org.omg.IOP.Encoding
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class Encoding
extends Object
implements IDLEntity
    org/omg/IOP/Encoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      short format
      The encoding format.
      byte major_version
      The major version of this Encoding format.
      byte minor_version
      The minor version of this Encoding format.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Encoding()
      Encoding(short _format, byte _major_version, byte _minor_version)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • format

        public short format
        The encoding format.

      • major_version

        public byte major_version
        The major version of this Encoding format.

      • minor_version

        public byte minor_version
        The minor version of this Encoding format.

    • 构造方法详细信息

      • Encoding

        public Encoding()

      • Encoding

        public Encoding(short _format,
        byte _major_version,
        byte _minor_version)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snpynyLyiytedisadklloi =i pnd( dio=l


ENCODING_CDR_ENCAPS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface ENCODING_CDR_ENCAPS

  • public interface ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      The CDR Encapsulation encoding.

    • 字段详细信息

      • value

        static final short value
        The CDR Encapsulation encoding.
        另请参见：
        CodecFactory, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/oit>k">kcLLkcc=u lenl" /�=s


ExceptionDetailMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface ExceptionDetailMessage

  • public interface ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16.

    • 字段详细信息

      • value

        static final int value
        CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16. This service context may be sent on Reply messages with a reply_status of SYSTEM_EXCEPTION or USER_EXCEPTION. The usage of this service context is defined by language mappings.

        IDL/Java: ptc/02-01-22: 1.15.2: When a System Exception is marshaled, its GIOP Reply message shall include an associated ExceptionDetailMessage service context. The callee's stack trace is often very valuable debugging information but may contain sensitive or unwanted information. The wstring within the service context will therefore contain additional information relating to the exception, for example the result of calling either printStackTrace(PrintWriter) or getMessage() on the exception. When unmarshaling a System Exception on the client side, the wstring from any ExceptionDetailMessage service context shall become the Java error message in the unmarshaled exception object.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-"4>kt�>lttoaaanlfnton s4


IOR

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP

类 IOR

  • java.lang.Object
    • org.omg.IOP.IOR
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class IOR
extends Object
implements IDLEntity
    org/omg/IOP/IOR.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      TaggedProfile[] profiles
      An array of tagged profiles associated with this object reference.
      String type_id
      The type id, represented as a String.

    • 构造方法摘要

      Constructors
      构造方法与描述
      IOR()
      IOR(String _type_id, TaggedProfile[] _profiles)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • type_id

        public String type_id
        The type id, represented as a String.

      • profiles

        public TaggedProfile[] profiles
        An array of tagged profiles associated with this object reference.

    • 构造方法详细信息

      • IOR

        public IOR()

      • IOR

        public IOR(String _type_id,
   TaggedProfile[] _profiles)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cJTa衟yiinte�/Lkkekd燼� p� d=pnl


IORHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 IORHelper

  • java.lang.Object
    • org.omg.IOP.IORHelper

  • public abstract class IORHelper
extends Object
    org/omg/IOP/IORHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      IORHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static IOR | extract(Any a)
      static String | id()
      static void | insert(Any a, IOR that)
      static IOR | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, IOR value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IORHelper

        public IORHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          IOR that)

      • extract

        public static IOR extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IOR read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         IOR value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9;a/�/t/fe


IORHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 IORHolder

  • java.lang.Object
    • org.omg.IOP.IORHolder
  • 所有已实现的接口：
    Streamable

    public final class IORHolder
extends Object
implements Streamable
    org/omg/IOP/IORHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      IOR value

    • 构造方法摘要

      Constructors
      构造方法与描述
      IORHolder()
      IORHolder(IOR initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public IOR value

    • 构造方法详细信息

      • IORHolder

        public IORHolder()

      • IORHolder

        public IORHolder(IOR initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d nha-othb.>mvt0/fu/sdlf=>al>


MultipleComponentProfileHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 MultipleComponentProfileHelper

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHelper

  • public abstract class MultipleComponentProfileHelper
extends Object
    An array of tagged components, forming a multiple component profile.

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultipleComponentProfileHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static TaggedComponent[] | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent[] that)
      static TaggedComponent[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • MultipleComponentProfileHelper

        public MultipleComponentProfileHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          TaggedComponent[] that)

      • extract

        public static TaggedComponent[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         TaggedComponent[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

glelrldlrlm argg"dhhn/l/h..ortgoaaI


MultipleComponentProfileHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 MultipleComponentProfileHolder

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHolder
  • 所有已实现的接口：
    Streamable

    public final class MultipleComponentProfileHolder
extends Object
implements Streamable
    An array of tagged components, forming a multiple component profile.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      TaggedComponent[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      MultipleComponentProfileHolder()
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public TaggedComponent[] value

    • 构造方法详细信息

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder()

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a=ttIa=xd veomaimys &hmdsp3�>f eLm.bg0psk


org.omg.IOP

Interfaces

  • Codec
  • CodecFactory
  • CodecFactoryOperations
  • CodecOperations
  • CodeSets
  • ENCODING_CDR_ENCAPS
  • ExceptionDetailMessage
  • RMICustomMaxStreamFormat
  • TAG_ALTERNATE_IIOP_ADDRESS
  • TAG_CODE_SETS
  • TAG_INTERNET_IOP
  • TAG_JAVA_CODEBASE
  • TAG_MULTIPLE_COMPONENTS
  • TAG_ORB_TYPE
  • TAG_POLICIES
  • TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • TransactionService

Classes

  • CodecFactoryHelper
  • ComponentIdHelper
  • Encoding
  • IOR
  • IORHelper
  • IORHolder
  • MultipleComponentProfileHelper
  • MultipleComponentProfileHolder
  • ProfileIdHelper
  • ServiceContext
  • ServiceContextHelper
  • ServiceContextHolder
  • ServiceContextListHelper
  • ServiceContextListHolder
  • ServiceIdHelper
  • TaggedComponent
  • TaggedComponentHelper
  • TaggedComponentHolder
  • TaggedProfile
  • TaggedProfileHelper
  • TaggedProfileHolder
/


org.omg.IOP

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.IOP

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

请参见： 描述

  • 接口摘要
    接口 描述
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodeSets
    org/omg/IOP/CodeSets.java .
    ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java .
    ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java .
    RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java .
    TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java .
    TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java .
    TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java .
    TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java .
    TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java .
    TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java .
    TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java .
    TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java .
    TransactionService
    org/omg/IOP/TransactionService.java .
  • Class Summary
    类 描述
    CodecFactoryHelper
    Codecs are obtained from the CodecFactory.
    ComponentIdHelper
    Standard way of representing multicomponent profiles.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    IORHelper
    org/omg/IOP/IORHelper.java .
    IORHolder
    org/omg/IOP/IORHolder.java .
    MultipleComponentProfileHelper
    An array of tagged components, forming a multiple component profile.
    MultipleComponentProfileHolder
    An array of tagged components, forming a multiple component profile.
    ProfileIdHelper
    Profile ID
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    ServiceContextHelper
    org/omg/IOP/ServiceContextHelper.java .
    ServiceContextHolder
    org/omg/IOP/ServiceContextHolder.java .
    ServiceContextListHelper
    An array of service contexts, forming a service context list.
    ServiceContextListHolder
    An array of service contexts, forming a service context list.
    ServiceIdHelper
    A service id, represented as an int
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedComponentHelper
    org/omg/IOP/TaggedComponentHelper.java .
    TaggedComponentHolder
    org/omg/IOP/TaggedComponentHolder.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
    TaggedProfileHelper
    org/omg/IOP/TaggedProfileHelper.java .
    TaggedProfileHolder
    org/omg/IOP/TaggedProfileHolder.java .

软件包 org.omg.IOP Description

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the IOP module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

liilirt"nrrs >. e.,.>A莂tn.1t


org.omg.IOP Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.IOP

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper
    • org.omg.IOP.ComponentIdHelper
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ProfileIdHelper
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceIdHelper
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)

Interface Hierarchy

  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.omg.IOP.ExceptionDetailMessage
  • org.omg.CORBA.Object
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • org.omg.IOP.TransactionService
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<-a>b


ProfileIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ProfileIdHelper

  • java.lang.Object
    • org.omg.IOP.ProfileIdHelper

  • public abstract class ProfileIdHelper
extends Object
    Profile ID

    • 构造方法摘要

      Constructors
      构造方法与描述
      ProfileIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ProfileIdHelper

        public ProfileIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>a


RMICustomMaxStreamFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface RMICustomMaxStreamFormat

  • public interface RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version.

    • 字段详细信息

      • value

        static final int value
        Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version. See Java to IDL ptc/02-01-12 1.4.12.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eotse" =" ann aas">>sk=""


ServiceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP

类 ServiceContext

  • java.lang.Object
    • org.omg.IOP.ServiceContext
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ServiceContext
extends Object
implements IDLEntity
    org/omg/IOP/ServiceContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      byte[] context_data
      The data associated with this service context
      int context_id
      The service context id

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceContext()
      ServiceContext(int _context_id, byte[] _context_data)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • context_id

        public int context_id
        The service context id

      • context_data

        public byte[] context_data
        The data associated with this service context

    • 构造方法详细信息

      • ServiceContext

        public ServiceContext()

      • ServiceContext

        public ServiceContext(int _context_id,
              byte[] _context_data)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

琲s<<<_tN< lc"<<糭ttrtgs>>躮


ServiceContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ServiceContextHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextHelper

  • public abstract class ServiceContextHelper
extends Object
    org/omg/IOP/ServiceContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceContextHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServiceContext | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext that)
      static ServiceContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceContextHelper

        public ServiceContextHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServiceContext that)

      • extract

        public static ServiceContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServiceContext value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=o meah -h �>


ServiceContextHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ServiceContextHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextHolder
  • 所有已实现的接口：
    Streamable

    public final class ServiceContextHolder
extends Object
implements Streamable
    org/omg/IOP/ServiceContextHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ServiceContext value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceContextHolder()
      ServiceContextHolder(ServiceContext initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ServiceContext value

    • 构造方法详细信息

      • ServiceContextHolder

        public ServiceContextHolder()

      • ServiceContextHolder

        public ServiceContextHolder(ServiceContext initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drk prtc raor&,osda"g龈镲<∽冶鎍�.o/怂 =tnt=


ServiceContextListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ServiceContextListHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHelper

  • public abstract class ServiceContextListHelper
extends Object
    An array of service contexts, forming a service context list.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceContextListHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServiceContext[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext[] that)
      static ServiceContext[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceContextListHelper

        public ServiceContextListHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServiceContext[] that)

      • extract

        public static ServiceContext[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServiceContext[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n/g>">g>o>m<<>mmet 襩l�>aa.o"c>dd=ds


ServiceContextListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ServiceContextListHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHolder
  • 所有已实现的接口：
    Streamable

    public final class ServiceContextListHolder
extends Object
implements Streamable
    An array of service contexts, forming a service context list.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ServiceContext[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceContextListHolder()
      ServiceContextListHolder(ServiceContext[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ServiceContext[] value

    • 构造方法详细信息

      • ServiceContextListHolder

        public ServiceContextListHolder()

      • ServiceContextListHolder

        public ServiceContextListHolder(ServiceContext[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

///snsts>s/l>tr dr lddaspst �


ServiceIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 ServiceIdHelper

  • java.lang.Object
    • org.omg.IOP.ServiceIdHelper

  • public abstract class ServiceIdHelper
extends Object
    A service id, represented as an int

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServiceIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServiceIdHelper

        public ServiceIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"a/r/.g/./...//.annRmaCoppmy


TAG_ALTERNATE_IIOP_ADDRESS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ALTERNATE_IIOP_ADDRESS

  • public interface TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

    • 字段详细信息

      • value

        static final int value
        In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

        The TAG_ALTERNATE_IIOP_ADDRESS component has an associated value of type:

             struct {
         string HostID,
         short Port
     };
        encoded as a CDR encapsulation.

        Zero or more instances of the TAG_ALTERNATE_IIOP_ADDRESS component type may be included in a version 1.2 TAG_INTERNET_IOP Profile. Each of these alternative addresses may be used by the client orb, in addition to the host and port address expressed in the body of the Profile. In cases where one or more TAG_ALTERNATE_IIOP_ADDRESS components are present in a TAG_INTERNET_IOP Profile, no order of use is prescribed by Version 1.2 of IIOP.

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//.r,<< <


TAG_CODE_SETS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_CODE_SETS

  • public interface TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The code set component of the IOR multi-component profile structure contains: server's native char code set and conversion code sets, and server's native wchar code set and conversion code sets. Both char and wchar conversion code sets are listed in order of preference.

    • 字段详细信息

      • value

        static final int value
        The code set component of the IOR multi-component profile structure contains:
        • server's native char code set and conversion code sets, and
        • server's native wchar code set and conversion code sets.
        Both char and wchar conversion code sets are listed in order of preference.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pfyeseleoelaCop>Cs ttamo <-"


TAG_INTERNET_IOP

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_INTERNET_IOP

  • public interface TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Identifies profiles that support the Internet Inter-ORB Protocol.

    • 字段详细信息

      • value

        static final int value
        Identifies profiles that support the Internet Inter-ORB Protocol. The ProfileBody of this profile contains a CDR encapsulation of a structure containing addressing and object identification information used by IIOP. Version 1.1 of the TAG_INTERNET_IOP profile also includes an array of TaggedComponent objects that can contain additional information supporting optional IIOP features, ORB services such as security, and future protocol extensions.

        Protocols other than IIOP (such as ESIOPs and other GIOPs) can share profile information (such as object identity or security information) with IIOP by encoding their additional profile information as components in the TAG_INTERNET_IOP profile. All TAG_INTERNET_IOP profiles support IIOP, regardless of whether they also support additional protocols. Interoperable ORBs are not required to create or understand any other profile, nor are they required to create or understand any of the components defined for other protocols that might share the TAG_INTERNET_IOP profile with IIOP.

        The profile_data for the TAG_INTERNET_IOP profile is a CDR encapsulation of the IIOP.ProfileBody_1_1 type.

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>Dl/oeR i<


TAG_JAVA_CODEBASE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_JAVA_CODEBASE

  • public interface TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Class downloading is supported for stubs, ties, values, and value helpers.

    • 字段详细信息

      • value

        static final int value
        Class downloading is supported for stubs, ties, values, and value helpers. The specification allows transmission of codebase information on the wire for stubs and ties, and enables usage of pre-existing ClassLoaders when relevant.

        For values and value helpers, the codebase is transmitted after the value tag. For stubs and ties, the codebase is transmitted as the TaggedComponent TAG_JAVA_CODEBASE in the IOR profile, where the component_data is a CDR encapsulation of the codebase written as an IDL string. The codebase is a space-separated list of one or more URLs.

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< fspsCs>s


TAG_MULTIPLE_COMPONENTS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_MULTIPLE_COMPONENTS

  • public interface TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Indicates that the value encapsulated is of type MultipleComponentProfile.

    • 字段详细信息

      • value

        static final int value
        Indicates that the value encapsulated is of type MultipleComponentProfile. In this case, the profile consists of a list of protocol components, the use of which must be specified by the protocol using this profile. This profile may be used to carry IOR components.

        The profile_data for the TAG_MULTIPLE_COMPONENTS profile is a CDR encapsulation of the MultipleComponentProfile type shown above.

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>ETn莅竍e3&;e�-p38nbt<


TAG_ORB_TYPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ORB_TYPE

  • public interface TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

    • 字段详细信息

      • value

        static final int value
        It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

        The TAG_ORB_TYPE component has an associated value of type unsigned long (Java long), encoded as a CDR encapsulation, designating an ORB type ID allocated by the OMG for the ORB type of the originating ORB. Anyone may register any ORB types by submitting a short (one-paragraph) description of the ORB type to the OMG, and will receive a new ORB type ID in return. A list of ORB type descriptions and values will be made available on the OMG web server.

        The TAG_ORB_TYPE component can appear at most once in any IOR profile. For profiles supporting IIOP 1.1 or greater, it is optionally present.

        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n ,o itt.hgoacel a<<_//tko>vn


TAG_POLICIES

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_POLICIES

  • public interface TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.

    • 字段详细信息

      • value

        static final int value
        A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;<<|n|>|p|;nsp;lsb>> lscsus=v=


TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

  • public interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      RMI-IIOP has multiple stream format versions.

    • 字段详细信息

      • value

        static final int value
        RMI-IIOP has multiple stream format versions. A server can specify its maximum version by including the TAG_RMI_CUSTOM_MAX_STREAM_FORMAT tagged component or rely on the default of version 1 for GIOP 1.2 and less and version 2 for GIOP 1.3 and higher. See Java to IDL ptc/02-01-12 1.4.11.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

orwtsrxdti:/hsl..on:" r>apa<


TaggedComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP

类 TaggedComponent

  • java.lang.Object
    • org.omg.IOP.TaggedComponent
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class TaggedComponent
extends Object
implements IDLEntity
    org/omg/IOP/TaggedComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      byte[] component_data
      The component data associated with the component id.
      int tag
      The tag, represented as a component id.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedComponent()
      TaggedComponent(int _tag, byte[] _component_data)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • tag

        public int tag
        The tag, represented as a component id.

      • component_data

        public byte[] component_data
        The component data associated with the component id.

    • 构造方法详细信息

      • TaggedComponent

        public TaggedComponent()

      • TaggedComponent

        public TaggedComponent(int _tag,
               byte[] _component_data)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tcoa_aeatab_ott"on""dc=lchhreIvSIedlr.l


TaggedComponentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 TaggedComponentHelper

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHelper

  • public abstract class TaggedComponentHelper
extends Object
    org/omg/IOP/TaggedComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedComponentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static TaggedComponent | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent that)
      static TaggedComponent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TaggedComponentHelper

        public TaggedComponentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          TaggedComponent that)

      • extract

        public static TaggedComponent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         TaggedComponent value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>L>fr;Eao�"


TaggedComponentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 TaggedComponentHolder

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHolder
  • 所有已实现的接口：
    Streamable

    public final class TaggedComponentHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      TaggedComponent value

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedComponentHolder()
      TaggedComponentHolder(TaggedComponent initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public TaggedComponent value

    • 构造方法详细信息

      • TaggedComponentHolder

        public TaggedComponentHolder()

      • TaggedComponentHolder

        public TaggedComponentHolder(TaggedComponent initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lrb.>c erc dcs猳el as蒀鼢r&室鲈pbc>�.�>� s


TaggedProfile

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP

类 TaggedProfile

  • java.lang.Object
    • org.omg.IOP.TaggedProfile
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class TaggedProfile
extends Object
implements IDLEntity
    org/omg/IOP/TaggedProfile.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      byte[] profile_data
      The associated profile data.
      int tag
      The tag, represented as a profile id.

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedProfile()
      TaggedProfile(int _tag, byte[] _profile_data)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • tag

        public int tag
        The tag, represented as a profile id.

      • profile_data

        public byte[] profile_data
        The associated profile data.

    • 构造方法详细信息

      • TaggedProfile

        public TaggedProfile()

      • TaggedProfile

        public TaggedProfile(int _tag,
             byte[] _profile_data)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>= emtamtuSStuu.pggestts t fe rte/a>>


TaggedProfileHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 TaggedProfileHelper

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHelper

  • public abstract class TaggedProfileHelper
extends Object
    org/omg/IOP/TaggedProfileHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedProfileHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static TaggedProfile | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedProfile that)
      static TaggedProfile | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedProfile value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TaggedProfileHelper

        public TaggedProfileHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          TaggedProfile that)

      • extract

        public static TaggedProfile extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedProfile read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         TaggedProfile value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>o/./e/-/.hh"..ahic襱vp笔#fh/esnnlae


TaggedProfileHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP

类 TaggedProfileHolder

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHolder
  • 所有已实现的接口：
    Streamable

    public final class TaggedProfileHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedProfileHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      TaggedProfile value

    • 构造方法摘要

      Constructors
      构造方法与描述
      TaggedProfileHolder()
      TaggedProfileHolder(TaggedProfile initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public TaggedProfile value

    • 构造方法详细信息

      • TaggedProfileHolder

        public TaggedProfileHolder()

      • TaggedProfileHolder

        public TaggedProfileHolder(TaggedProfile initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>sRo cenRD竛rses笻b1 /o>osae穝/e//>dld>魇


TransactionService

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.IOP

Interface TransactionService

  • public interface TransactionService
    org/omg/IOP/TransactionService.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.

    • 字段详细信息

      • value

        static final int value
        Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/djl.lalmlc.om/v/c// A笽奈客 羖


Uses of Package org.omg.IOP

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.IOP

  • Packages that use org.omg.IOP
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.IOP used by org.omg.IOP
    类与描述
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
  • Classes in org.omg.IOP used by org.omg.PortableInterceptor
    类与描述
    CodecFactory
    Codecs are obtained from the CodecFactory.
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

RtBorirpyeeei


Uses of Class org.omg.IOP.CodecFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecFactoryHelper

No usage of org.omg.IOP.CodecFactoryHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R.Boss "=cccthgg.gty/


Uses of Class org.omg.IOP.ComponentIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ComponentIdHelper

No usage of org.omg.IOP.ComponentIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o� &ptX=sr> =alc. an


Uses of Class org.omg.IOP.Encoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.Encoding

  • Packages that use Encoding
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Encoding in org.omg.IOP

      Methods in org.omg.IOP with parameters of type Encoding
      修饰符与类型 方法与描述
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>jAi/ei lelr


Uses of Class org.omg.IOP.IOR

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.IOR

  • Packages that use IOR
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of IOR in org.omg.IOP

      Fields in org.omg.IOP declared as IOR
      修饰符与类型 | 字段与描述
      IOR | IORHolder.value
      Methods in org.omg.IOP that return IOR
      修饰符与类型 | 方法与描述
      static IOR | IORHelper.extract(Any a)
      static IOR | IORHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type IOR
      修饰符与类型 | 方法与描述
      static void | IORHelper.insert(Any a, IOR that)
      static void | IORHelper.write(OutputStream ostream, IOR value)
      Constructors in org.omg.IOP with parameters of type IOR
      构造方法与描述
      IORHolder(IOR initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

astrtx re -e<糰s


Uses of Class org.omg.IOP.IORHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.IORHelper

No usage of org.omg.IOP.IORHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sochl">=e"""clttt "ca


Uses of Class org.omg.IOP.IORHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.IORHolder

No usage of org.omg.IOP.IORHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.躌e掺@鞇p塴�


Uses of Class org.omg.IOP.MultipleComponentProfileHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.MultipleComponentProfileHelper

No usage of org.omg.IOP.MultipleComponentProfileHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fxrD r lr


Uses of Class org.omg.IOP.MultipleComponentProfileHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.MultipleComponentProfileHolder

No usage of org.omg.IOP.MultipleComponentProfileHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sx鴑黮>/�nd�=


Uses of Class org.omg.IOP.ProfileIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ProfileIdHelper

No usage of org.omg.IOP.ProfileIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lA"yachc/y.m谤h<鎟╩�


Uses of Class org.omg.IOP.ServiceContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceContext

  • Packages that use ServiceContext
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServiceContext in org.omg.IOP

      Fields in org.omg.IOP declared as ServiceContext
      修饰符与类型 | 字段与描述
      ServiceContext[] | ServiceContextListHolder.value
      ServiceContext | ServiceContextHolder.value
      Methods in org.omg.IOP that return ServiceContext
      修饰符与类型 | 方法与描述
      static ServiceContext[] | ServiceContextListHelper.extract(Any a)
      static ServiceContext | ServiceContextHelper.extract(Any a)
      static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
      static ServiceContext | ServiceContextHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type ServiceContext
      修饰符与类型 | 方法与描述
      static void | ServiceContextHelper.insert(Any a, ServiceContext that)
      static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
      static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
      static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
      Constructors in org.omg.IOP with parameters of type ServiceContext
      构造方法与描述
      ServiceContextHolder(ServiceContext initialValue)
      ServiceContextListHolder(ServiceContext[] initialValue)

    • Uses of ServiceContext in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ServiceContext
      修饰符与类型 方法与描述
      ServiceContext RequestInfoOperations.get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext RequestInfoOperations.get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Methods in org.omg.PortableInterceptor with parameters of type ServiceContext
      修饰符与类型 方法与描述
      void ServerRequestInfoOperations.add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      void ClientRequestInfoOperations.add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/v==o"t/ae da=cc


Uses of Class org.omg.IOP.ServiceContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceContextHelper

No usage of org.omg.IOP.ServiceContextHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xStrIOPo/mmmo.aa<; ra


Uses of Class org.omg.IOP.ServiceContextHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceContextHolder

No usage of org.omg.IOP.ServiceContextHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vhDw�/ Jm礕 �.i;


Uses of Class org.omg.IOP.ServiceContextListHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceContextListHelper

No usage of org.omg.IOP.ServiceContextListHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

em g > l.follx"/Dls


Uses of Class org.omg.IOP.ServiceContextListHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceContextListHolder

No usage of org.omg.IOP.ServiceContextListHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r&� �le鴢"6li/s


Uses of Class org.omg.IOP.ServiceIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.ServiceIdHelper

No usage of org.omg.IOP.ServiceIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

北Ａ诵�/�<◆ �<


Uses of Class org.omg.IOP.TaggedComponent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedComponent

  • Packages that use TaggedComponent
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedComponent in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedComponent
      修饰符与类型 | 字段与描述
      TaggedComponent | TaggedComponentHolder.value
      TaggedComponent[] | MultipleComponentProfileHolder.value
      Methods in org.omg.IOP that return TaggedComponent
      修饰符与类型 | 方法与描述
      static TaggedComponent | TaggedComponentHelper.extract(Any a)
      static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
      static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
      static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedComponent
      修饰符与类型 | 方法与描述
      static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
      static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
      static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
      static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
      Constructors in org.omg.IOP with parameters of type TaggedComponent
      构造方法与描述
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)
      TaggedComponentHolder(TaggedComponent initialValue)

    • Uses of TaggedComponent in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedComponent
      修饰符与类型 方法与描述
      TaggedComponent ClientRequestInfoOperations.get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] ClientRequestInfoOperations.get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Methods in org.omg.PortableInterceptor with parameters of type TaggedComponent
      修饰符与类型 方法与描述
      void IORInfoOperations.add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void IORInfoOperations.add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e aanpcbv


Uses of Class org.omg.IOP.TaggedComponentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedComponentHelper

No usage of org.omg.IOP.TaggedComponentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hMtCTagI/OOOo/ee>dste


Uses of Class org.omg.IOP.TaggedComponentHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedComponentHolder

No usage of org.omg.IOP.TaggedComponentHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dg/O缊.�/纃e


Uses of Class org.omg.IOP.TaggedProfile

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedProfile

  • Packages that use TaggedProfile
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedProfile in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedProfile
      修饰符与类型 | 字段与描述
      TaggedProfile[] IOR.profiles
      An array of tagged profiles associated with this object reference.
      TaggedProfile | TaggedProfileHolder.value
      Methods in org.omg.IOP that return TaggedProfile
      修饰符与类型 | 方法与描述
      static TaggedProfile | TaggedProfileHelper.extract(Any a)
      static TaggedProfile | TaggedProfileHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedProfile
      修饰符与类型 | 方法与描述
      static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)
      static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)
      Constructors in org.omg.IOP with parameters of type TaggedProfile
      构造方法与描述
      IOR(String _type_id, TaggedProfile[] _profiles)
      TaggedProfileHolder(TaggedProfile initialValue)

    • Uses of TaggedProfile in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedProfile
      修饰符与类型 方法与描述
      TaggedProfile ClientRequestInfoOperations.effective_profile()
      Returns the profile that will be used to send the request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/./ash>sics>.oetllc


Uses of Class org.omg.IOP.TaggedProfileHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedProfileHelper

No usage of org.omg.IOP.TaggedProfileHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


Uses of Class org.omg.IOP.TaggedProfileHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.TaggedProfileHolder

No usage of org.omg.IOP.TaggedProfileHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o<狢 d�*d wet


Uses of Interface org.omg.IOP.Codec

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.Codec

  • Packages that use Codec
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Codec in org.omg.IOP

      Methods in org.omg.IOP that return Codec
      修饰符与类型 方法与描述
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

me/ieL


Uses of Interface org.omg.IOP.CodecFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.CodecFactory

  • Packages that use CodecFactory
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CodecFactory in org.omg.IOP

      Methods in org.omg.IOP that return CodecFactory
      修饰符与类型 | 方法与描述
      static CodecFactory | CodecFactoryHelper.extract(Any a)
      static CodecFactory | CodecFactoryHelper.narrow(Object obj)
      static CodecFactory | CodecFactoryHelper.read(InputStream istream)
      static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)
      Methods in org.omg.IOP with parameters of type CodecFactory
      修饰符与类型 | 方法与描述
      static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
      static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)

    • Uses of CodecFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return CodecFactory
      修饰符与类型 方法与描述
      CodecFactory ORBInitInfoOperations.codec_factory()
      Returns the IOP.CodecFactory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R


Uses of Interface org.omg.IOP.CodecFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.CodecFactoryOperations

  • Packages that use CodecFactoryOperations
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecFactoryOperations in org.omg.IOP

      Subinterfaces of CodecFactoryOperations in org.omg.IOP
      修饰符与类型 Interface and Description
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

3>.l.a/s tet 礱nC/b sr


Uses of Interface org.omg.IOP.CodecOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.CodecOperations

  • Packages that use CodecOperations
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecOperations in org.omg.IOP

      Subinterfaces of CodecOperations in org.omg.IOP
      修饰符与类型 Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/"y>l///< /d> h


Uses of Interface org.omg.IOP.CodeSets

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.CodeSets

No usage of org.omg.IOP.CodeSets
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b"oif=" ahhha tt TAT=


Uses of Interface org.omg.IOP.ENCODING_CDR_ENCAPS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.ENCODING_CDR_ENCAPS

No usage of org.omg.IOP.ENCODING_CDR_ENCAPS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

apvl/a>-->>> wttmr"tt


Uses of Interface org.omg.IOP.ExceptionDetailMessage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.ExceptionDetailMessage

No usage of org.omg.IOP.ExceptionDetailMessage
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ad< sla"Phx it.>ml


Uses of Interface org.omg.IOP.RMICustomMaxStreamFormat

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.RMICustomMaxStreamFormat

No usage of org.omg.IOP.RMICustomMaxStreamFormat
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>la=Prao>lspdsr>ci


Uses of Interface org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS

No usage of org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa.>kldUv xohf-t


Uses of Interface org.omg.IOP.TAG_CODE_SETS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_CODE_SETS

No usage of org.omg.IOP.TAG_CODE_SETS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9n;&<>0>a&xa1 0�9#3a/


Uses of Interface org.omg.IOP.TAG_INTERNET_IOP

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_INTERNET_IOP

No usage of org.omg.IOP.TAG_INTERNET_IOP
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b \.糿�>猲冰"pe锰詒


Uses of Interface org.omg.IOP.TAG_JAVA_CODEBASE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_JAVA_CODEBASE

No usage of org.omg.IOP.TAG_JAVA_CODEBASE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.o Zp 2pr祆Lx=� 鬰


Uses of Interface org.omg.IOP.TAG_MULTIPLE_COMPONENTS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_MULTIPLE_COMPONENTS

No usage of org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

../sg //


Uses of Interface org.omg.IOP.TAG_ORB_TYPE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_ORB_TYPE

No usage of org.omg.IOP.TAG_ORB_TYPE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>皉1 l ,rc 浠l>羇� &


Uses of Interface org.omg.IOP.TAG_POLICIES

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_POLICIES

No usage of org.omg.IOP.TAG_POLICIES
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i<餬橫,r�]>猘>


Uses of Interface org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

No usage of org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iiomc"tl N/Re> a>>ciD


org.omg.IOP.CodecFactoryPackage

Classes

  • UnknownEncodingHelper

Exceptions

  • UnknownEncoding
n


org.omg.IOP.CodecFactoryPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.IOP.CodecFactoryPackage

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

请参见： 描述

  • Class Summary
    类 描述
    UnknownEncodingHelper
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java .
  • Exception Summary
    Exception 描述
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

软件包 org.omg.IOP.CodecFactoryPackage Description

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g.bu}.noes.lo


org.omg.IOP.CodecFactoryPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.IOP.CodecFactoryPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nnaa(slllsslIggiappym


UnknownEncoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP.CodecFactoryPackage

类 UnknownEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class UnknownEncoding
extends UserException
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownEncoding()
      UnknownEncoding(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • UnknownEncoding

        public UnknownEncoding()

      • UnknownEncoding

        public UnknownEncoding(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

thte>blhls.�/e.


UnknownEncodingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP.CodecFactoryPackage

类 UnknownEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

  • public abstract class UnknownEncodingHelper
extends Object
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      UnknownEncodingHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static UnknownEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, UnknownEncoding that)
      static UnknownEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnknownEncoding value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • UnknownEncodingHelper

        public UnknownEncodingHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          UnknownEncoding that)

      • extract

        public static UnknownEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnknownEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         UnknownEncoding value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eS el.oicay>s竩aspoooaedh'erad


Uses of Package org.omg.IOP.CodecFactoryPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.IOP.CodecFactoryPackage

  • Packages that use org.omg.IOP.CodecFactoryPackage
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP
    类与描述
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP.CodecFactoryPackage
    类与描述
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u .rrlrs/ -秔x"os "


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncoding

  • Packages that use UnknownEncoding
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

    • Uses of UnknownEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw UnknownEncoding
      修饰符与类型 方法与描述
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • Uses of UnknownEncoding in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage that return UnknownEncoding
      修饰符与类型 | 方法与描述
      static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
      static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type UnknownEncoding
      修饰符与类型 | 方法与描述
      static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)
      static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

slnisb x


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

No usage of org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

thii/En/gIII/.==rcPo"


FormatMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP.CodecPackage

类 FormatMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.FormatMismatch
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class FormatMismatch
extends UserException
    org/omg/IOP/CodecPackage/FormatMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      FormatMismatch()
      FormatMismatch(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • FormatMismatch

        public FormatMismatch()

      • FormatMismatch

        public FormatMismatch(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-s/Ent iUacsls/<0r


FormatMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP.CodecPackage

类 FormatMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper

  • public abstract class FormatMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      FormatMismatchHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static FormatMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, FormatMismatch that)
      static FormatMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, FormatMismatch value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • FormatMismatchHelper

        public FormatMismatchHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          FormatMismatch that)

      • extract

        public static FormatMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static FormatMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         FormatMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<e /&/o>sy>aap>�'o


InvalidTypeForEncoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP.CodecPackage

类 InvalidTypeForEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidTypeForEncoding
extends UserException
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidTypeForEncoding()
      InvalidTypeForEncoding(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding()

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rs_srfaa<>>>!rr= T=FOOT BV-Bv


InvalidTypeForEncodingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP.CodecPackage

类 InvalidTypeForEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

  • public abstract class InvalidTypeForEncodingHelper
extends Object
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidTypeForEncodingHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidTypeForEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidTypeForEncoding that)
      static InvalidTypeForEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidTypeForEncoding value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidTypeForEncodingHelper

        public InvalidTypeForEncodingHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidTypeForEncoding that)

      • extract

        public static InvalidTypeForEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidTypeForEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidTypeForEncoding value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iIe t.;&o sanru>萴>e os"m<\"�<)nt


org.omg.IOP.CodecPackage

Classes

  • FormatMismatchHelper
  • InvalidTypeForEncodingHelper
  • TypeMismatchHelper

Exceptions

  • FormatMismatch
  • InvalidTypeForEncoding
  • TypeMismatch


org.omg.IOP.CodecPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.IOP.CodecPackage

This package is generated from the IOP::Codec IDL interface definition.

请参见： 描述

  • Class Summary
    类 描述
    FormatMismatchHelper
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
    InvalidTypeForEncodingHelper
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
    TypeMismatchHelper
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java .
  • Exception Summary
    Exception 描述
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .

软件包 org.omg.IOP.CodecPackage Description

This package is generated from the IOP::Codec IDL interface definition. It contains the Java representations of the IDL exceptions specified in IOP::Codec (as part of the Portable Interceptors specification). Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

islricPkL"=bkk"l e;&>h(a>


org.omg.IOP.CodecPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.IOP.CodecPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.IOP.CodecPackage.TypeMismatch
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

raeis< >lllt=llr>M///


TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.IOP.CodecPackage

类 TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.TypeMismatch
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    org/omg/IOP/CodecPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeMismatch()
      TypeMismatch(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • TypeMismatch

        public TypeMismatch()

      • TypeMismatch

        public TypeMismatch(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uoOakilLb�/lb"aac=


TypeMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.IOP.CodecPackage

类 TypeMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.TypeMismatchHelper

  • public abstract class TypeMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      TypeMismatchHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static TypeMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, TypeMismatch that)
      static TypeMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TypeMismatch value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • TypeMismatchHelper

        public TypeMismatchHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          TypeMismatch that)

      • extract

        public static TypeMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TypeMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         TypeMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>n越&穘贩;


Uses of Package org.omg.IOP.CodecPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.IOP.CodecPackage

  • Packages that use org.omg.IOP.CodecPackage
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP
    类与描述
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP.CodecPackage
    类与描述
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

najvkioidgcsetlat1�<视�.


Uses of Class org.omg.IOP.CodecPackage.FormatMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatch

  • Packages that use FormatMismatch
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of FormatMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw FormatMismatch
      修饰符与类型 方法与描述
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any CodecOperations.decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.

    • Uses of FormatMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return FormatMismatch
      修饰符与类型 | 方法与描述
      static FormatMismatch | FormatMismatchHelper.extract(Any a)
      static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type FormatMismatch
      修饰符与类型 | 方法与描述
      static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
      static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m ".;R<=�1lnl


Uses of Class org.omg.IOP.CodecPackage.FormatMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatchHelper

No usage of org.omg.IOP.CodecPackage.FormatMismatchHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dei)bspa/>>>d"rr."o.g


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncoding

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncoding

  • Packages that use InvalidTypeForEncoding
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of InvalidTypeForEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw InvalidTypeForEncoding
      修饰符与类型 方法与描述
      byte[] CodecOperations.encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] CodecOperations.encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • Uses of InvalidTypeForEncoding in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return InvalidTypeForEncoding
      修饰符与类型 | 方法与描述
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type InvalidTypeForEncoding
      修饰符与类型 | 方法与描述
      static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
      static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y s"c


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

No usage of org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.IOP.CodecPackage.TypeMismatch

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatch

  • Packages that use TypeMismatch
    软件包 描述
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of TypeMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw TypeMismatch
      修饰符与类型 方法与描述
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

    • Uses of TypeMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return TypeMismatch
      修饰符与类型 | 方法与描述
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type TypeMismatch
      修饰符与类型 | 方法与描述
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>os e--a A.


Uses of Class org.omg.IOP.CodecPackage.TypeMismatchHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatchHelper

No usage of org.omg.IOP.CodecPackage.TypeMismatchHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cdlotc)bnsssapmm..o.g


org.omg.Messaging

Interfaces

  • SYNC_WITH_TRANSPORT

Classes

  • SyncScopeHelper


org.omg.Messaging

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.Messaging

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.

请参见： 描述

  • 接口摘要
    接口 描述
    SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java .
  • Class Summary
    类 描述
    SyncScopeHelper
    Synchronization scope

软件包 org.omg.Messaging Description

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the Messaging module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bs >ar _nslcne逑>a�"


org.omg.Messaging Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.Messaging

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

Interface Hierarchy

  • org.omg.Messaging.SYNC_WITH_TRANSPORT
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"tncil/


SYNC_WITH_TRANSPORT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.Messaging

Interface SYNC_WITH_TRANSPORT

  • public interface SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Messaging.idl Thursday, April 14, 2011 2:04:16 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.

    • 字段详细信息

      • value

        static final short value
        Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a ien/ag/av//avv.=//ntm((">g.g.


SyncScopeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.Messaging

类 SyncScopeHelper

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

  • public abstract class SyncScopeHelper
extends Object
    Synchronization scope

    • 构造方法摘要

      Constructors
      构造方法与描述
      SyncScopeHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • SyncScopeHelper

        public SyncScopeHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t dse.al r""_/�1o.ot=1o bLna


Uses of Package org.omg.Messaging

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.Messaging

No usage of org.omg.Messaging
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

msegmu.ucetee ll鵨衜a


Uses of Class org.omg.Messaging.SyncScopeHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.Messaging.SyncScopeHelper

No usage of org.omg.Messaging.SyncScopeHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rboI/"


Uses of Interface org.omg.Messaging.SYNC_WITH_TRANSPORT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.Messaging.SYNC_WITH_TRANSPORT

No usage of org.omg.Messaging.SYNC_WITH_TRANSPORT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

re ovamIlc i


ACTIVE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ACTIVE

  • public interface ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Object adapter state that indicates normal request processing.

    • 字段详细信息

      • value

        static final short value
        Object adapter state that indicates normal request processing.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

�"Clb/idC. Be!.


AdapterManagerIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 AdapterManagerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper

  • public abstract class AdapterManagerIdHelper
extends Object
    Adapter manager identifier. Every object adapter has an adapter manager, indicated in this API only through the ID. A group of object adapter instances may share the same adapter manager, in which case state transitions reported for the adapter manager are observed by all object adapters with the same adapter manager ID.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterManagerIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterManagerIdHelper

        public AdapterManagerIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

!l鵲C m� ../ec=� lT>flusr


AdapterNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 AdapterNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterNameHelper

  • public abstract class AdapterNameHelper
extends Object
    The name of an object adapter. This is unique only within the scope of the ORB that created the object adapter.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterNameHelper

        public AdapterNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

manols"tcny r


AdapterStateHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 AdapterStateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterStateHelper

  • public abstract class AdapterStateHelper
extends Object
    Type of object adapter state. State changes are reported either to the object adapter or to the adapter manager.

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterStateHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterStateHelper

        public AdapterStateHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         short value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>I<mll>olpaa-o>m---<> <-


ClientRequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInfo

  • All Superinterfaces:
    ClientRequestInfoOperations, IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable

    public interface ClientRequestInfo
extends ClientRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    另请参见：
    ClientRequestInterceptor

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ClientRequestInfoOperations

        add_request_service_context, effective_profile, effective_target, get_effective_component, get_effective_components, get_request_policy, received_exception_id, received_exception, target

      • 方法 - 继承于接口 org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tUe>/lp<>fraIh >MEm&b�-os>>


ClientRequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ClientRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ClientRequestInfo

    public interface ClientRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    另请参见：
    ClientRequestInterceptor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      TaggedProfile effective_profile()
      Returns the profile that will be used to send the request.
      Object effective_target()
      Returns the actual object on which the operation will be invoked.
      TaggedComponent get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Policy get_request_policy(int type)
      Returns the given policy in effect for this operation.
      String received_exception_id()
      Returns the repository id of the exception to be returned to the client.
      Any received_exception()
      Returns an any which contains the exception to be returned to the client.
      Object target()
      Returns the object which the client called to perform the operation.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • 方法详细信息

      • target

        Object target()
        Returns the object which the client called to perform the operation.
        另请参见：
        effective_target()

      • effective_target

        Object effective_target()
        Returns the actual object on which the operation will be invoked. If the reply_status is LOCATION_FORWARD, then on subsequent requests, effective_target will contain the forwarded IOR while target will remain unchanged.
        另请参见：
        target()

      • effective_profile

        TaggedProfile effective_profile()
        Returns the profile that will be used to send the request. If a location forward has occurred for this operation's object and that object's profile changed accordingly, then this profile will be that located profile.

      • received_exception

        Any received_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don t provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1. However, the repository id of the exception is available in the received_exception_id attribute.

        另请参见：
        received_exception_id()

      • received_exception_id

        String received_exception_id()
        Returns the repository id of the exception to be returned to the client.
        另请参见：
        received_exception(), PortableInterceptor package comments for limitations / unimplemented features

      • get_effective_component

        TaggedComponent get_effective_component(int id)
        Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

        If there is more than one component for a given component ID, it is undefined which component this operation returns. If there is more than one component for a given component ID, get_effective_components should be called instead.

        参数：
        id - The component id of the component which is to be returned.
        返回：
        The IOP.TaggedComponent obtained with the given identifier.
        抛出：
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        另请参见：
        get_effective_components(int)

      • get_effective_components

        TaggedComponent[] get_effective_components(int id)
        Returns an array of all tagged components with the given ID from the profile selected for this request.
        参数：
        id - The component id of the components which are to be returned.
        返回：
        An array of TaggedComponent objects, each of which contains the given identifier.
        抛出：
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        另请参见：
        get_effective_component(int)

      • get_request_policy

        Policy get_request_policy(int type)
        Returns the given policy in effect for this operation.
        参数：
        type - The policy type which specifies the policy to be returned.
        返回：
        The CORBA.Policy obtained with the given type.
        抛出：
        INV_POLICY - thrown, with a standard minor code of 1, if the policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • add_request_service_context

        void add_request_service_context(ServiceContext service_context,
                               boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        参数：
        service_context - The IOP.ServiceContext to be added to the request.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rab<=b1&�＠ih>▕/.1


ClientRequestInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInterceptor

  • All Superinterfaces:
    ClientRequestInterceptorOperations, IDLEntity, Interceptor, InterceptorOperations, Object, Serializable

    public interface ClientRequestInterceptor
extends ClientRequestInterceptorOperations, Interceptor, IDLEntity
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    另请参见：
    ClientRequestInfo

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations

        receive_exception, receive_other, receive_reply, send_poll, send_request

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

isn ee,re,> ,>>/r eblo


ClientRequestInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ClientRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ClientRequestInterceptor

    public interface ClientRequestInterceptorOperations
extends InterceptorOperations
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    另请参见：
    ClientRequestInfo

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • 方法详细信息

      • send_request

        void send_request(ClientRequestInfo ri)
                  throws ForwardRequest
        Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

        This interception point may throw a system exception. If it does, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called. This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_poll

        void send_poll(ClientRequestInfo ri)
        Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.

        With TII, an application may poll for a response to a request sent previously by the polling client or some other client. This poll is reported to Interceptors through the send_poll interception point and the response is returned through the receive_reply or receive_exception interception points. If the response is not available before the poll time-out expires, the system exception TIMEOUT is thrown and receive_exception is called with this exception.

        This interception point may throw a system exception. If it does, no other Interceptors' send_poll operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        TIMEOUT - thrown if the response is not available before the poll time-out expires

      • receive_reply

        void receive_reply(ClientRequestInfo ri)
        Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_reply operations are called. The remaining Interceptors in the Flow Stack shall have their receive_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        参数：
        ri - Information about the current request being intercepted.

      • receive_exception

        void receive_exception(ClientRequestInfo ri)
                       throws ForwardRequest
        Indicates to the interceptor that an exception occurred. Allows an Interceptor to query the exception's information before it is thrown to the client.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to receive_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_exception operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_other interception point called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request s at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        Under some conditions, depending on what policies are in effect, an exception (such as COMM_FAILURE) may result in a retry of the request. While this retry is a new request with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the PortableInterceptor.Current for both the original request and the retrying request is the same.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_other

        void receive_other(ClientRequestInfo ri)
                   throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received); or on asynchronous calls, the reply does not immediately follow the request, but control shall return to the client and an ending interception point shall be called.

        For retries, depending on the policies in effect, a new request may or may not follow when a retry has been indicated. If a new request does follow, while this request is a new request, with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the request scoped PortableInterceptor.Current for both the original request and the retrying request is the same.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_other operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_exception interception point called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' receive_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO. If the target invocation had completed, this interception point would not be called.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aip"m.g."olgriosfVnefe_>teveecrsd


Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.CurrentOperations

        get_slot, set_slot

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o n /oecoeusseuurd /ni edei


CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 CurrentHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CurrentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static Current | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, Current value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CurrentHelper

        public CurrentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Current value)

      • narrow

        public static Current narrow(Object obj)

      • unchecked_narrow

        public static Current unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p>t i dn vieeviie ccf-ih,onh-c aaits


CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Any get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      void set_slot(int id, Any data)
      Sets data in a slot.

    • 方法详细信息

      • get_slot

        Any get_slot(int id)
             throws InvalidSlot
        Retrieves the slot data the application set in PICurrent via get_slot. The data is in the form of an Any.

        If the given slot has not been set, an Any containing a type code with a TCKind value of tk_null and no value is returned.

        参数：
        id - The SlotId of the slot from which the data will be returned.
        返回：
        The data, in the form of an Any, of the given slot identifier.
        抛出：
        InvalidSlot - thrown if get_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if get_slot is called from within an ORB initializer

      • set_slot

        void set_slot(int id,
            Any data)
              throws InvalidSlot
        Sets data in a slot. The data is in the form of an Any. If data already exists in that slot, it is overridden.
        参数：
        id - The SlotId of the slot to which the data will be set.
        data - The data, in the form of an Any, which will be set to the identified slot.
        抛出：
        InvalidSlot - thrown if set_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if set_slot is called from within an ORB initializer.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.e.(xrstrsbppsbb/Cnng//grgC.//tnee


DISCARDING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface DISCARDING

  • public interface DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Object adapter state that causes all requests to be discarded.

    • 字段详细信息

      • value

        static final short value
        Object adapter state that causes all requests to be discarded.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b=l/.//.//.../..ew /og/RA/O."


ForwardRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableInterceptor

类 ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ForwardRequest
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableInterceptor/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object forward
      The new object to forward the request to.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ForwardRequest()
      ForwardRequest(Object _forward)
      ForwardRequest(String $reason, Object _forward)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • forward

        public Object forward
        The new object to forward the request to.

    • 构造方法详细信息

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward)

      • ForwardRequest

        public ForwardRequest(String $reason,
              Object _forward)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

StNe=======< <


ForwardRequestHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableInterceptor/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ForwardRequestHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ForwardRequest value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t amslmSmr<


HOLDING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface HOLDING

  • public interface HOLDING
    org/omg/PortableInterceptor/HOLDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Object adapter state that holds requests temporarily until the state is changed.

    • 字段详细信息

      • value

        static final short value
        Object adapter state that holds requests temporarily until the state is changed.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r;/Iragtagm//gmmo. i"mll="tpah


INACTIVE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface INACTIVE

  • public interface INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Object adapter state that causes all requests to be discarded.

    • 字段详细信息

      • value

        static final short value
        Object adapter state that causes all requests to be discarded. This state indicates that the adapter is shutting down.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>Ue lwnro/.roorao;ogp&ORg萢m


Interceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Interceptor

  • All Superinterfaces:
    IDLEntity, InterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    ClientRequestInterceptor, IORInterceptor, IORInterceptor_3_0, ServerRequestInterceptor

    public interface Interceptor
extends InterceptorOperations, Object, IDLEntity
    All Portable Interceptors implement Interceptor.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m


InterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface InterceptorOperations

  • All Known Subinterfaces:
    ClientRequestInterceptor, ClientRequestInterceptorOperations, Interceptor, IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations, IORInterceptorOperations, ServerRequestInterceptor, ServerRequestInterceptorOperations

    public interface InterceptorOperations
    All Portable Interceptors implement Interceptor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void destroy()
      Provides an opportunity to destroy this interceptor.
      String name()
      Returns the name of the interceptor.

    • 方法详细信息

      • name

        String name()
        Returns the name of the interceptor.

        Each Interceptor may have a name that may be used administratively to order the lists of Interceptors. Only one Interceptor of a given name can be registered with the ORB for each Interceptor type. An Interceptor may be anonymous, i.e., have an empty string as the name attribute. Any number of anonymous Interceptors may be registered with the ORB.

        返回：
        the name of the interceptor.

      • destroy

        void destroy()
        Provides an opportunity to destroy this interceptor. The destroy method is called during ORB.destroy. When an application calls ORB.destroy, the ORB:
        1. waits for all requests in progress to complete
        2. calls the Interceptor.destroy operation for each interceptor
        3. completes destruction of the ORB
        Method invocations from within Interceptor.destroy on object references for objects implemented on the ORB being destroyed result in undefined behavior. However, method invocations on objects implemented on an ORB other than the one being destroyed are permitted. (This means that the ORB being destroyed is still capable of acting as a client, but not as a server.)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d< hp|eo>i a>ii-dg黙s


InvalidSlot

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableInterceptor

类 InvalidSlot

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.InvalidSlot
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidSlot
extends UserException
    org/omg/PortableInterceptor/InvalidSlot.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidSlot()
      InvalidSlot(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidSlot

        public InvalidSlot()

      • InvalidSlot

        public InvalidSlot(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

//ttlr/i ssm


InvalidSlotHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 InvalidSlotHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.InvalidSlotHelper

  • public abstract class InvalidSlotHelper
extends Object
    org/omg/PortableInterceptor/InvalidSlotHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidSlotHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidSlot | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidSlot that)
      static InvalidSlot | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidSlot value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidSlotHelper

        public InvalidSlotHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidSlot that)

      • extract

        public static InvalidSlot extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidSlot read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidSlot value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aoligd.a >#0a e19b�1o./�,r捌g眉n


IORInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInfo

  • All Superinterfaces:
    IDLEntity, IORInfoOperations, Object, Serializable

    public interface IORInfo
extends IORInfoOperations, Object, IDLEntity
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    另请参见：
    IORInterceptor

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.IORInfoOperations

        adapter_template, add_ior_component_to_profile, add_ior_component, current_factory, current_factory, get_effective_policy, manager_id, state

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o"r"ttmitmtllmttoB//l ssse </


IORInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface IORInfoOperations

  • All Known Subinterfaces:
    IORInfo

    public interface IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    另请参见：
    IORInterceptor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ObjectReferenceTemplate adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      void add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      ObjectReferenceFactory current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      void current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      Policy get_effective_policy(int type)
      Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
      int manager_id()
      Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.
      short state()
      Return the adapter state of the object adapter that was just created and is running IOR interceptors.

    • 方法详细信息

      • get_effective_policy

        Policy get_effective_policy(int type)
        Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed. When the IOR being constructed is for an object implemented using a POA, all Policy objects passed to the PortableServer.POA.create_POA call that created that POA are accessable via get_effective_policy.

        If a policy for the given type is not known to the ORB, then this operation will throw INV_POLICY with a standard minor code of 2.

        参数：
        type - an int specifying the type of policy to return.
        返回：
        The effective CORBA.Policy object of the requested type. If the given policy type is known, but no policy of that type is in effect, then this operation will return a nil object reference.

      • add_ior_component

        void add_ior_component(TaggedComponent tagged_component)
        A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in all profiles.

        Any number of components may exist with the same component ID.

        参数：
        tagged_component - The IOP.TaggedComponent to add.

      • add_ior_component_to_profile

        void add_ior_component_to_profile(TaggedComponent tagged_component,
                                int profile_id)
        A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in the specified profile.

        Any number of components may exist with the same component ID.

        参数：
        tagged_component - The IOP.TaggedComponent to add.
        profile_id - The profile id of the profile to which this component will be added.
        抛出：
        BAD_PARAM - thrown, with a standard minor code of 29, if the given profile ID does not define a known profile or it is impossible to add components to that profile.

      • manager_id

        int manager_id()
        Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.

      • state

        short state()
        Return the adapter state of the object adapter that was just created and is running IOR interceptors.

      • adapter_template

        ObjectReferenceTemplate adapter_template()
        Return the object reference template of the object adapter that was just created and is running IOR interceptors.

      • current_factory

        ObjectReferenceFactory current_factory()
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.

      • current_factory

        void current_factory(ObjectReferenceFactory newCurrent_factory)
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aob./lu ionniooinnnao j�.la".f,a


IORInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor
extends IORInterceptorOperations, Interceptor, IDLEntity
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    另请参见：
    IORInfo

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uychueidei nni lwooteo tdmte


IORInterceptor_3_0

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor_3_0

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptor, IORInterceptor_3_0Operations, IORInterceptorOperations, Object, Serializable

    public interface IORInterceptor_3_0
extends IORInterceptor_3_0Operations, IORInterceptor, IDLEntity
    org/omg/PortableInterceptor/IORInterceptor_3_0.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations

        adapter_manager_state_changed, adapter_state_changed, components_established

      • 方法 - 继承于接口 org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p>pbs>np/tn&&tnn aLshonCT


IORInterceptor_3_0Helper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 IORInterceptor_3_0Helper

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper

  • public abstract class IORInterceptor_3_0Helper
extends Object
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      IORInterceptor_3_0Helper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static IORInterceptor_3_0 | extract(Any a)
      static String | id()
      static void | insert(Any a, IORInterceptor_3_0 that)
      static IORInterceptor_3_0 | narrow(Object obj)
      static IORInterceptor_3_0 | read(InputStream istream)
      static TypeCode | type()
      static IORInterceptor_3_0 | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, IORInterceptor_3_0 value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • IORInterceptor_3_0Helper

        public IORInterceptor_3_0Helper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          IORInterceptor_3_0 that)

      • extract

        public static IORInterceptor_3_0 extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IORInterceptor_3_0 read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         IORInterceptor_3_0 value)

      • narrow

        public static IORInterceptor_3_0 narrow(Object obj)

      • unchecked_narrow

        public static IORInterceptor_3_0 unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< l&be&"&|bp;


IORInterceptor_3_0Holder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 IORInterceptor_3_0Holder

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder
  • 所有已实现的接口：
    Streamable

    public final class IORInterceptor_3_0Holder
extends Object
implements Streamable
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      IORInterceptor_3_0 value

    • 构造方法摘要

      Constructors
      构造方法与描述
      IORInterceptor_3_0Holder()
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public IORInterceptor_3_0 value

    • 构造方法详细信息

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder()

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>op->.>a/i> uidmm&ep&ap&|侄i|&in> y|�;;河<


IORInterceptor_3_0Operations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface IORInterceptor_3_0Operations

  • All Superinterfaces:
    InterceptorOperations, IORInterceptorOperations
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor_3_0Operations
extends IORInterceptorOperations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void adapter_manager_state_changed(int id, short state)
      Called whenever the state of an adapter manager changes.
      void adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      void components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • 方法详细信息

      • components_established

        void components_established(IORInfo info)
        The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances. The adapter_template is available in info during this call. The current_factory may be get or set in info during this call.

        Any exception thrown from this method is handled by the Object Adapter that called this interceptor. In the case of the POA, an exception results in a OBJ_ADAPTER exception with an OMG standard minor code of 6.

        参数：
        info - The IORInfo for the object adapter being created.

      • adapter_manager_state_changed

        void adapter_manager_state_changed(int id,
                                 short state)
        Called whenever the state of an adapter manager changes. For the POA, that is the POAManager. If the state change is reported through adapter_manager_state_changed, it is not reported through adapter_state_changed.
        参数：
        id - the adapter manager id of the adapter manager that changed state
        state - the new state of the adapter manager

      • adapter_state_changed

        void adapter_state_changed(ObjectReferenceTemplate[] templates,
                         short state)
        Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager. Such changes are reported to all registered IORInterceptor_3_0 instances.
        参数：
        templates - the sequence of ObjectReferenceTemplate instances on which this state change occurred.
        state - the new AdapterState shared by all of the templates.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tllbaCop"BaRl


IORInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface IORInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations

    public interface IORInterceptorOperations
extends InterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    另请参见：
    IORInfo

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • 方法详细信息

      • establish_components

        void establish_components(IORInfo info)
        A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference. This operation is not necessarily called for each individual object reference. In the case of the POA, this operation is called each time POA::create_POA is called. In any case, establish_components is guaranteed to be called at least once for each distinct set of server policies.

        An implementation of establish_components must not throw exceptions. If it does, the ORB shall ignore the exception and proceed to call the next IOR Interceptor's establish_components operation.

        参数：
        info - The IORInfo instance used by the ORB service to query applicable policies and add components to be included in the generated IORs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m>nPTeh/>e >ee


LOCATION_FORWARD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface LOCATION_FORWARD

  • public interface LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Indicates a LocationForward reply status.

    • 字段详细信息

      • value

        static final short value
        Indicates a LocationForward reply status. One possible value for RequestInfo.reply_status.
        另请参见：
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, TRANSPORT_RETRY, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

se d ntinte tee ytt enah aTtug


NON_EXISTENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface NON_EXISTENT

  • public interface NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Object adapter state indicating that the adapter has been destroyed.

    • 字段详细信息

      • value

        static final short value
        Object adapter state indicating that the adapter has been destroyed.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>-&eleaeaeid/a>b/"ffllt/i> au >


ObjectIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Type of an object id. This provides the identity of a particular object that was created by an object adapter.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static byte[] | extract(Any a)
      static String | id()
      static void | insert(Any a, byte[] that)
      static byte[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, byte[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectIdHelper

        public ObjectIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          byte[] that)

      • extract

        public static byte[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static byte[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         byte[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

horul/T/<> Th iaa.tc/csds/vcacc7t�


ObjectReferenceFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ObjectReferenceFactory

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase
    All Known Subinterfaces:
    ObjectReferenceTemplate

    public interface ObjectReferenceFactory
extends ValueBase
    The object reference factory. This provides the capability of creating an object reference.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Object make_object(String repositoryId, byte[] object_id)
      make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • 方法详细信息

      • make_object

        Object make_object(String repositoryId,
                 byte[] object_id)
        make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=="tCdTodT/yyT//CofficcoliL


ObjectReferenceFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceFactoryHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

  • public abstract class ObjectReferenceFactoryHelper
extends Object
    The object reference factory. This provides the capability of creating an object reference.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceFactoryHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ObjectReferenceFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceFactory that)
      static ObjectReferenceFactory | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceFactory value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectReferenceFactoryHelper

        public ObjectReferenceFactoryHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ObjectReferenceFactory that)

      • extract

        public static ObjectReferenceFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ObjectReferenceFactory value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ra />s>ooo/gt/ggd/>uebdooo


ObjectReferenceFactoryHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceFactoryHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
  • 所有已实现的接口：
    Streamable

    public final class ObjectReferenceFactoryHolder
extends Object
implements Streamable
    The object reference factory. This provides the capability of creating an object reference.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ObjectReferenceFactory value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceFactoryHolder()
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ObjectReferenceFactory value

    • 构造方法详细信息

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder()

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iFoo圓� Hc t 誥┘ �0<>@>�)H


ObjectReferenceTemplate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ObjectReferenceTemplate

  • All Superinterfaces:
    IDLEntity, ObjectReferenceFactory, Serializable, ValueBase

    public interface ObjectReferenceTemplate
extends ObjectReferenceFactory
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] adapter_name()
      String orb_id()
      String server_id()

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ObjectReferenceFactory

        make_object

      • 方法 - 继承于接口 org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • 方法详细信息

      • server_id

        String server_id()

      • orb_id

        String orb_id()

      • adapter_name

        String[] adapter_name()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m>eiboslosasssaalLccl/e>elL=A==o


ObjectReferenceTemplateHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceTemplateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

  • public abstract class ObjectReferenceTemplateHelper
extends Object
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceTemplateHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ObjectReferenceTemplate | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate that)
      static ObjectReferenceTemplate | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectReferenceTemplateHelper

        public ObjectReferenceTemplateHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ObjectReferenceTemplate that)

      • extract

        public static ObjectReferenceTemplate extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ObjectReferenceTemplate value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l i


ObjectReferenceTemplateHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceTemplateHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
  • 所有已实现的接口：
    Streamable

    public final class ObjectReferenceTemplateHolder
extends Object
implements Streamable
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ObjectReferenceTemplate value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceTemplateHolder()
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ObjectReferenceTemplate value

    • 构造方法详细信息

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder()

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>IssEsCmnl>;lpaa <>/a<-tn" s> nm<<<�>


ObjectReferenceTemplateSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceTemplateSeqHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

  • public abstract class ObjectReferenceTemplateSeqHelper
extends Object
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceTemplateSeqHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ObjectReferenceTemplate[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate[] that)
      static ObjectReferenceTemplate[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate[] value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectReferenceTemplateSeqHelper

        public ObjectReferenceTemplateSeqHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ObjectReferenceTemplate[] that)

      • extract

        public static ObjectReferenceTemplate[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ObjectReferenceTemplate[] value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gn.osoaomo ggrooslee< "ierrPebpjccle<


ObjectReferenceTemplateSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ObjectReferenceTemplateSeqHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
  • 所有已实现的接口：
    Streamable

    public final class ObjectReferenceTemplateSeqHolder
extends Object
implements Streamable
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      ObjectReferenceTemplate[] value

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectReferenceTemplateSeqHolder()
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public ObjectReferenceTemplate[] value

    • 构造方法详细信息

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder()

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • 方法详细信息

      • _read

        public void _read(InputStream i)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

觘邪t皌谤�>人/&a衪 &9009 0, O9,,a�1癮rs


ORBIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ORBIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBIdHelper

  • public abstract class ORBIdHelper
extends Object
    org/omg/PortableInterceptor/ORBIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ORBIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ORBIdHelper

        public ORBIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=-=SO EF E NNE =!iiatd h d


ORBInitializer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitializer

  • All Superinterfaces:
    IDLEntity, Object, ORBInitializerOperations, Serializable

    public interface ORBInitializer
extends ORBInitializerOperations, Object, IDLEntity
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    另请参见：
    ORBInitInfo

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ORBInitializerOperations

        post_init, pre_init

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s0 n nsnnnitonsfrw l懊芴铁.�.


ORBInitializerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ORBInitializerOperations

  • All Known Subinterfaces:
    ORBInitializer

    public interface ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    另请参见：
    ORBInitInfo

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void post_init(ORBInitInfo info)
      Called during ORB initialization.
      void pre_init(ORBInitInfo info)
      Called during ORB initialization.

    • 方法详细信息

      • pre_init

        void pre_init(ORBInitInfo info)
        Called during ORB initialization. If it is expected that initial services registered by an interceptor will be used by other interceptors, then those initial services shall be registered at this point via calls to ORBInitInfo.register_initial_reference.
        参数：
        info - provides initialization attributes and operations by which Interceptors can be registered.

      • post_init

        void post_init(ORBInitInfo info)
        Called during ORB initialization. If a service must resolve initial references as part of its initialization, it can assume that all initial references will be available at this point.

        Calling the post_init operations is not the final task of ORB initialization. The final task, following the post_init calls, is attaching the lists of registered interceptors to the ORB. Therefore, the ORB does not contain the interceptors during calls to post_init. If an ORB-mediated call is made from within post_init, no request interceptors will be invoked on that call. Likewise, if an operation is performed which causes an IOR to be created, no IOR interceptors will be invoked.

        参数：
        info - provides initialization attributes and operations by which Interceptors can be registered.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttmesenehdneed:nliffil<>al//>a


ORBInitInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitInfo

  • All Superinterfaces:
    IDLEntity, Object, ORBInitInfoOperations, Serializable

    public interface ORBInitInfo
extends ORBInitInfoOperations, Object, IDLEntity
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    另请参见：
    ORBInitializer

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ORBInitInfoOperations

        add_client_request_interceptor, add_ior_interceptor, add_server_request_interceptor, allocate_slot_id, arguments, codec_factory, orb_id, register_initial_reference, register_policy_factory, resolve_initial_references

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

arcle /> /


ORBInitInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ORBInitInfoOperations

  • All Known Subinterfaces:
    ORBInitInfo

    public interface ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    另请参见：
    ORBInitializer

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
      int allocate_slot_id()
      Called to allocate a slot on PortableInterceptor.Current.
      String[] arguments()
      Returns the arguments passed to ORB.init.
      CodecFactory codec_factory()
      Returns the IOP.CodecFactory.
      String orb_id()
      Returns the ID of the ORB being initialized.
      void register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      void register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
      Object resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • 方法详细信息

      • arguments

        String[] arguments()
        Returns the arguments passed to ORB.init. They may or may not contain the ORB's arguments.

      • orb_id

        String orb_id()
        Returns the ID of the ORB being initialized.

      • codec_factory

        CodecFactory codec_factory()
        Returns the IOP.CodecFactory. The CodecFactory is normally obtained via a call to ORB.resolve_initial_references( "CodecFactory" ), but since the ORB is not yet available and Interceptors, particularly when processing service contexts, will require a Codec, a means of obtaining a Codec is necessary during ORB initialization.

      • register_initial_reference

        void register_initial_reference(String id,
                              Object obj)
                                throws InvalidName
        Identical to ORB.register_initial_reference. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may need to be registered as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA.ORB.ObjectId) and (CORBA.ORB.InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.
        抛出：
        InvalidName

      • resolve_initial_references

        Object resolve_initial_references(String id)
                                  throws InvalidName
        Identical to ORB.resolve_initial_references. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may be required from the ORB as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA::ORB::ObjectId and CORBA::ORB::InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.

        This operation is only valid during post_init.

        抛出：
        InvalidName

      • add_client_request_interceptor

        void add_client_request_interceptor(ClientRequestInterceptor interceptor)
                                    throws DuplicateName
        Used to add a client-side request Interceptor to the list of client-side request Interceptors.
        参数：
        interceptor - The ClientRequestInterceptor to be added.
        抛出：
        DuplicateName - thrown if a client-side request Interceptor has already been registered with this Interceptor's name.

      • add_server_request_interceptor

        void add_server_request_interceptor(ServerRequestInterceptor interceptor)
                                    throws DuplicateName
        Used to add a server-side request Interceptor to the list of server-side request Interceptors.
        参数：
        interceptor - The ServerRequestInterceptor to be added.
        抛出：
        DuplicateName - thrown if a server-side request Interceptor has already been registered with this Interceptor's name

      • add_ior_interceptor

        void add_ior_interceptor(IORInterceptor interceptor)
                         throws DuplicateName
        Used to add an IOR Interceptor to the list of IOR Interceptors.
        参数：
        interceptor - The IORInterceptor to be added.
        抛出：
        DuplicateName - thrown if an IOR Interceptor has already been registered with this Interceptor's name.

      • allocate_slot_id

        int allocate_slot_id()
        Called to allocate a slot on PortableInterceptor.Current.

        Note that while slot id's can be allocated within an ORB initializer, the slots themselves cannot be initialized.

        返回：
        The index to the slot which has been allocated.
        抛出：
        BAD_INV_ORDER - thrown, with a standard minor code of 14, if set_slot or get_slot is called on the PICurrent within an ORB initializer.
        另请参见：
        Current

      • register_policy_factory

        void register_policy_factory(int type,
                           PolicyFactory policy_factory)
        Registers a PolicyFactory for the given PolicyType.
        参数：
        type - The policy type that the given PolicyFactory serves.
        policy_factory - The factory for the given policy type.
        抛出：
        BAD_INV_ORDER - thrown, with a standard minor code of 16, if a PolicyFactory already exists for the given PolicyType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

htteu1


org.omg.PortableInterceptor

Interfaces

  • ACTIVE
  • ClientRequestInfo
  • ClientRequestInfoOperations
  • ClientRequestInterceptor
  • ClientRequestInterceptorOperations
  • Current
  • CurrentOperations
  • DISCARDING
  • HOLDING
  • INACTIVE
  • Interceptor
  • InterceptorOperations
  • IORInfo
  • IORInfoOperations
  • IORInterceptor
  • IORInterceptor_3_0
  • IORInterceptor_3_0Operations
  • IORInterceptorOperations
  • LOCATION_FORWARD
  • NON_EXISTENT
  • ObjectReferenceFactory
  • ObjectReferenceTemplate
  • ORBInitializer
  • ORBInitializerOperations
  • ORBInitInfo
  • ORBInitInfoOperations
  • PolicyFactory
  • PolicyFactoryOperations
  • RequestInfo
  • RequestInfoOperations
  • ServerRequestInfo
  • ServerRequestInfoOperations
  • ServerRequestInterceptor
  • ServerRequestInterceptorOperations
  • SUCCESSFUL
  • SYSTEM_EXCEPTION
  • TRANSPORT_RETRY
  • UNKNOWN
  • USER_EXCEPTION

Classes

  • AdapterManagerIdHelper
  • AdapterNameHelper
  • AdapterStateHelper
  • CurrentHelper
  • ForwardRequestHelper
  • InvalidSlotHelper
  • IORInterceptor_3_0Helper
  • IORInterceptor_3_0Holder
  • ObjectIdHelper
  • ObjectReferenceFactoryHelper
  • ObjectReferenceFactoryHolder
  • ObjectReferenceTemplateHelper
  • ObjectReferenceTemplateHolder
  • ObjectReferenceTemplateSeqHelper
  • ObjectReferenceTemplateSeqHolder
  • ORBIdHelper
  • ServerIdHelper

Exceptions

  • ForwardRequest
  • InvalidSlot
D


org.omg.PortableInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableInterceptor

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

请参见： 描述

  • 接口摘要
    接口 描述
    ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java .
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java .
    HOLDING
    org/omg/PortableInterceptor/HOLDING.java .
    INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java .
    NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java .
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializer
    Facilitates interceptor registration and ORB initialization.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
    SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java .
    SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java .
    TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java .
    UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java .
    USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java .
  • Class Summary
    类 描述
    AdapterManagerIdHelper
    Adapter manager identifier.
    AdapterNameHelper
    The name of an object adapter.
    AdapterStateHelper
    Type of object adapter state.
    CurrentHelper
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequestHelper
    org/omg/PortableInterceptor/ForwardRequestHelper.java .
    InvalidSlotHelper
    org/omg/PortableInterceptor/InvalidSlotHelper.java .
    IORInterceptor_3_0Helper
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
    IORInterceptor_3_0Holder
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
    ObjectIdHelper
    Type of an object id.
    ObjectReferenceFactoryHelper
    The object reference factory.
    ObjectReferenceFactoryHolder
    The object reference factory.
    ObjectReferenceTemplateHelper
    The object reference template.
    ObjectReferenceTemplateHolder
    The object reference template.
    ObjectReferenceTemplateSeqHelper
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ObjectReferenceTemplateSeqHolder
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ORBIdHelper
    org/omg/PortableInterceptor/ORBIdHelper.java .
    ServerIdHelper
    org/omg/PortableInterceptor/ServerIdHelper.java .
  • Exception Summary
    Exception 描述
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .

软件包 org.omg.PortableInterceptor Description

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

Interceptor Types

There are currently three types of interceptors that can be registered:
  • IORInterceptor - Used to establish tagged components in the profiles within an IOR.
  • ClientRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the client side.
  • ServerRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the server side.
See the javadocs for class ORBInitializer for how to go about registering interceptors.

Known limitations / unimplemented methods in package org.omg.PortableInterceptor

  • RequestInfo
    • sync_scope(): Always returns SYNC_WITH_TRANSPORT
    • arguments(): Only supported for DII/DSI calls
    • exceptions(): Only supported for DII calls on client side. Not supported on server-side.
    • contexts(): Only supported for DII calls on client side. Not supported on server-side since our ORB does not send contexts.
    • operation_context(): Only supported for DII calls on client side. Not supported on server-side since ORB does not send contexts.
    • result(): Only supported for DII/DSI calls
  • ClientRequestInfo
    • received_exception_id(): Always returns null in the DII case
    • get_request_policy(int type): Not implemented.
  • ServerRequestInfo
    • sending_exception(): Does not support user exceptions on the server side in non-DSI case.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h. icolmma鬽meinhgP>蔳e


org.omg.PortableInterceptor Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableInterceptor

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ORBIdHelper
    • org.omg.PortableInterceptor.ServerIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.PortableInterceptor.InvalidSlot

Interface Hierarchy

  • org.omg.PortableInterceptor.ACTIVE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableInterceptor.DISCARDING
  • org.omg.PortableInterceptor.HOLDING
  • org.omg.PortableInterceptor.INACTIVE
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.omg.PortableInterceptor.NON_EXISTENT
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.PortableInterceptor.Interceptor (also extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (also extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • org.omg.PortableInterceptor.UNKNOWN
  • org.omg.PortableInterceptor.USER_EXCEPTION
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


PolicyFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface PolicyFactory

  • All Superinterfaces:
    IDLEntity, Object, PolicyFactoryOperations, Serializable

    public interface PolicyFactory
extends PolicyFactoryOperations, Object, IDLEntity
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    另请参见：
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.PolicyFactoryOperations

        create_policy

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ipcsotetoetrtellor==


PolicyFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface PolicyFactoryOperations

  • All Known Subinterfaces:
    PolicyFactory

    public interface PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    另请参见：
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Policy create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

    • 方法详细信息

      • create_policy

        Policy create_policy(int type,
                   Any value)
                     throws PolicyError
        Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

        The ORB calls create_policy on a registered PolicyFactory instance when CORBA.ORB.create_policy is called for the PolicyType under which the PolicyFactory has been registered. The create_policy operation then returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any. If it cannot, it shall throw an exception as described for CORBA.ORB.create_policy.

        参数：
        type - An int specifying the type of policy being created.
        value - An any containing data with which to construct the CORBA.Policy.
        返回：
        A CORBA.Policy object of the specified type and value.
        抛出：
        PolicyError
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ac>kL=s"<>b"eenommdcgds==lcl


RequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface RequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfoOperations, Serializable
    All Known Subinterfaces:
    ClientRequestInfo, ServerRequestInfo

    public interface RequestInfo
extends RequestInfoOperations, Object, IDLEntity
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    另请参见：
    ClientRequestInfo, ServerRequestInfo

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

la=qie!VABpaOO S>!nruc=s>>


RequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface RequestInfoOperations

  • All Known Subinterfaces:
    ClientRequestInfo, ClientRequestInfoOperations, RequestInfo, ServerRequestInfo, ServerRequestInfoOperations

    public interface RequestInfoOperations
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    另请参见：
    ClientRequestInfo, ServerRequestInfo

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Parameter[] arguments()
      Returns an array of Parameter objects, containing the arguments on the operation being invoked.
      String[] contexts()
      Returns an array of String objects describing the contexts that may be passed on this operation invocation.
      TypeCode[] exceptions()
      Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
      Object forward_reference()
      Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
      ServiceContext get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Any get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      String[] operation_context()
      Returns an array of String objects containing the contexts being sent on the request.
      String operation()
      Returns the name of the operation being invoked.
      short reply_status()
      Describes the state of the result of the operation invocation.
      int request_id()
      Returns an id that uniquely identifies an active request/reply sequence.
      boolean response_expected()
      Indicates whether a response is expected.
      Any result()
      Returns an any containing the result of the operation invocation.
      short sync_scope()
      Defines how far the request shall progress before control is returned to the client.

    • 方法详细信息

      • request_id

        int request_id()
        Returns an id that uniquely identifies an active request/reply sequence. Once a request/reply sequence is concluded this ID may be reused. Note that this id is not the same as the GIOP request_id. If GIOP is the transport mechanism used, then these IDs may very well be the same, but this is not guaranteed nor required.

      • operation

        String operation()
        Returns the name of the operation being invoked.

      • arguments

        Parameter[] arguments()
        Returns an array of Parameter objects, containing the arguments on the operation being invoked. If there are no arguments, this attribute will be a zero length array.

        Not all environments provide access to the arguments. With the Java portable bindings, for example, the arguments are not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Arguments are available for DSI/DII calls.

        抛出：
        NO_RESOURCES - thrown if arguments are not available.
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • exceptions

        TypeCode[] exceptions()
        Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw. If there are no user exceptions, this will return a zero length array.

        Not all environments provide access to the exception list. With the Java portable bindings, for example, the exception list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Exceptions are available for DSI/DII calls.

        抛出：
        NO_RESOURCES - thrown if exceptions are not available.
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • contexts

        String[] contexts()
        Returns an array of String objects describing the contexts that may be passed on this operation invocation. If there are no contexts, this will return a zero length array.

        Not all environments provide access to the context list. With the Java portable bindings, for example, the context list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Contexts are available for DSI/DII calls.

        抛出：
        NO_RESOURCES - thrown if contexts are not available.
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • operation_context

        String[] operation_context()
        Returns an array of String objects containing the contexts being sent on the request.

        Not all environments provide access to the context. With the Java portable bindings, for example, the context is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with standard minor code of 1.

        Note: operation_context is available for DSI/DII calls.

        抛出：
        NO_RESOURCES - thrown if operation context is not available.
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • result

        Any result()
        Returns an any containing the result of the operation invocation. If the operation return type is void, this attribute will be an any containing a type code with a TCKind value of tk_void and no value.

        Not all environments provide access to the result. With the Java portable bindings, for example, the result is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Result is available for DSI/DII calls.

        抛出：
        NO_RESOURCES - thrown if result is not available.
        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • response_expected

        boolean response_expected()
        Indicates whether a response is expected.

        On the client, a reply is not returned when response_expected is false, so receive_reply cannot be called. receive_other is called unless an exception occurs, in which case receive_exception is called.

        On the client, within send_poll, this attribute is true.

      • sync_scope

        short sync_scope()
        Defines how far the request shall progress before control is returned to the client. This is defined in the Messaging specification, and is pertinent only when response_expected is false. If response_expected is true, the value of sync_scope is undefined. This attribute may have one of the following values:
        • Messaging.SYNC_NONE
        • Messaging.SYNC_WITH_TRANSPORT
        • Messaging.SYNC_WITH_SERVER
        • Messaging.SYNC_WITH_TARGET
        On the server, for all scopes, a reply will be created from the return of the target operation call, but the reply will not return to the client. Although it does not return to the client, it does occur, so the normal server-side interception points are followed (i.e., receive_request_service_contexts, receive_request, send_reply or send_exception).

        For SYNC_WITH_SERVER and SYNC_WITH_TARGET, the server does send an empty reply back to the client before the target is invoked. This reply is not intercepted by server-side Interceptors.

        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • reply_status

        short reply_status()
        Describes the state of the result of the operation invocation. The return value can be one of the following:
        • PortableInterceptor.SUCCESSFUL
        • PortableInterceptor.SYSTEM_EXCEPTION
        • PortableInterceptor.USER_EXCEPTION
        • PortableInterceptor.LOCATION_FORWARD
        • PortableInterceptor.TRANSPORT_RETRY
        On the client:
        • Within the receive_reply interception point, this will only return SUCCESSFUL
          • .
        • Within the receive_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the receive_other interception point, this will be any of: SUCCESSFUL, LOCATION_FORWARD, or TRANSPORT_RETRY. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status. TRANSPORT_RETRY means that the transport mechanism indicated a retry - a GIOP reply with a status of NEEDS_ADDRESSING_MODE, for instance.
        On the server:
        • Within the send_reply interception point, this will only be SUCCESSFUL.
        • Within the send_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the send_other interception point, this attribute will be any of: SUCCESSFUL, or LOCATION_FORWARD. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status.
        另请参见：
        SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY

      • forward_reference

        Object forward_reference()
        Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD. It is indeterminate whether a forwarded request will actually occur.

      • get_slot

        Any get_slot(int id)
             throws InvalidSlot
        Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

        If the given slot has not been set, then an any containing a type code with a TCKind value of tk_null is returned.

        参数：
        id - The SlotId of the slot which is to be returned.
        返回：
        The slot data, in the form of an any, obtained with the given identifier.
        抛出：
        InvalidSlot - thrown if the ID does not define an allocated slot.
        另请参见：
        Current

      • get_request_service_context

        ServiceContext get_request_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the request.

        参数：
        id - The IOP.ServiceId of the service context which is to be returned.
        返回：
        The IOP.ServiceContext obtained with the given identifier.
        抛出：
        BAD_PARAM - thrown with a standard minor code of 26, if the request's service context does not contain an entry for that ID.

      • get_reply_service_context

        ServiceContext get_reply_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the reply.
        参数：
        id - The IOP.ServiceId of the service context which is to be returned.
        返回：
        The IOP.ServiceContext obtained with the given identifier.
        抛出：
        BAD_PARAM - thrown with a standard minor code of 26 if the request's service context does not contain an entry for that ID.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

恇m m mrt r><>.r1h<台h�


ServerIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor

类 ServerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ServerIdHelper

  • public abstract class ServerIdHelper
extends Object
    org/omg/PortableInterceptor/ServerIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServerIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServerIdHelper

        public ServerIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hrr>nm/an>><


ServerRequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable, ServerRequestInfoOperations

    public interface ServerRequestInfo
extends ServerRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    另请参见：
    ServerRequestInterceptor

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ServerRequestInfoOperations

        adapter_id, adapter_name, add_reply_service_context, get_server_policy, object_id, orb_id, sending_exception, server_id, set_slot, target_is_a, target_most_derived_interface

      • 方法 - 继承于接口 org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

poeilb/ebts/w ss ueeSocCelri


ServerRequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ServerRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ServerRequestInfo

    public interface ServerRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    另请参见：
    ServerRequestInterceptor

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] adapter_id()
      Returns the opaque identifier for the object adapter.
      String[] adapter_name()
      Returns the sequence of strings that identifies the object adapter instance that is handling this request.
      void add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      Policy get_server_policy(int type)
      Returns the policy in effect for this operation for the given policy type.
      byte[] object_id()
      Returns the opaque object_id describing the target of the operation invocation.
      String orb_id()
      Returns the ID that was used to create the ORB.
      Any sending_exception()
      Returns an any which contains the exception to be returned to the client.
      String server_id()
      Returns the server ID that was specified on ORB::init using the -ORBServerId argument.
      void set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      boolean target_is_a(String id)
      Returns true if the servant is the given repository id, false if it is not.
      String target_most_derived_interface()
      Returns the repository id for the most derived interface of the servant.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • 方法详细信息

      • sending_exception

        Any sending_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don't provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1.

        另请参见：
        PortableInterceptor package comments for limitations / unimplemented features

      • object_id

        byte[] object_id()
        Returns the opaque object_id describing the target of the operation invocation.

      • adapter_id

        byte[] adapter_id()
        Returns the opaque identifier for the object adapter.

      • server_id

        String server_id()
        Returns the server ID that was specified on ORB::init using the -ORBServerId argument.

      • orb_id

        String orb_id()
        Returns the ID that was used to create the ORB.

      • adapter_name

        String[] adapter_name()
        Returns the sequence of strings that identifies the object adapter instance that is handling this request.

      • target_most_derived_interface

        String target_most_derived_interface()
        Returns the repository id for the most derived interface of the servant.

      • get_server_policy

        Policy get_server_policy(int type)
        Returns the policy in effect for this operation for the given policy type. The returned CORBA.Policy object shall only be a policy whose type was registered via register_policy_factory.
        参数：
        type - The CORBA.PolicyType which specifies the policy to be returned.
        返回：
        The CORBA.Policy obtained with the given policy type.
        抛出：
        INV_POLICY - thrown, with a standard minor code of 2, if a policy for the given type was not registered via register_policy_factory.
        另请参见：
        ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

      • set_slot

        void set_slot(int id,
            Any data)
              throws InvalidSlot
        Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request. If data already exists in that slot, it will be overwritten.
        参数：
        id - The id of the slot.
        data - The data, in the form of an any, to store in that slot.
        抛出：
        InvalidSlot - thrown if the ID does not define an allocated slot.
        另请参见：
        Current

      • target_is_a

        boolean target_is_a(String id)
        Returns true if the servant is the given repository id, false if it is not.
        参数：
        id - The caller wants to know if the servant is this repository id.
        返回：
        Is the servant the given RepositoryId?

      • add_reply_service_context

        void add_reply_service_context(ServiceContext service_context,
                             boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        参数：
        service_context - The IOP.ServiceContext to add to the reply.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
        抛出：
        BAD_INV_ORDER - thrown, with a standard minor code of 15, if replace is false and a service context already exists with the given ID.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c/soad m-�<>筸e#鵷�


ServerRequestInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, Object, Serializable, ServerRequestInterceptorOperations

    public interface ServerRequestInterceptor
extends ServerRequestInterceptorOperations, Interceptor, IDLEntity
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    另请参见：
    ServerRequestInfo

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations

        receive_request_service_contexts, receive_request, send_exception, send_other, send_reply

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ii>/alvblvaaavaale yree ,v


ServerRequestInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableInterceptor

Interface ServerRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ServerRequestInterceptor

    public interface ServerRequestInterceptorOperations
extends InterceptorOperations
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    另请参见：
    ServerRequestInfo

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.

      • 方法 - 继承于接口 org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • 方法详细信息

      • receive_request_service_contexts

        void receive_request_service_contexts(ServerRequestInfo ri)
                                      throws ForwardRequest
        Allows the interceptor to process service context information.

        At this interception point, Interceptors must get their service context information from the incoming request transfer it to PortableInterceptor.Current's slots.

        This interception point is called before the servant manager is called. Operation parameters are not yet available at this point. This interception point may or may not execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_request

        void receive_request(ServerRequestInfo ri)
                     throws ForwardRequest
        Allows an Interceptor to query request information after all the information, including operation parameters, are available. This interception point shall execute in the same thread as the target invocation.

        In the DSI model, since the parameters are first available when the user code calls arguments, receive_request is called from within arguments. It is possible that arguments is not called in the DSI model. The target may call set_exception before calling arguments. The ORB shall guarantee that receive_request is called once, either through arguments or through set_exception. If it is called through set_exception, requesting the arguments will result in NO_RESOURCES being thrown with a standard minor code of 1.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_reply

        void send_reply(ServerRequestInfo ri)
        Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_reply operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        参数：
        ri - Information about the current request being intercepted.

      • send_exception

        void send_exception(ServerRequestInfo ri)
                    throws ForwardRequest
        Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client. When an exception occurs, this interception point is called. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to send_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_exception operations are called. The remaining Interceptors in the Flow Stack shall have their send_other interception points called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request's at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_other

        void send_other(ServerRequestInfo ri)
                throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received). This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_other operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception points called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' send_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        参数：
        ri - Information about the current request being intercepted.
        抛出：
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>l_c"bI"=/b"=="sstl/tel=fttmdgo


SUCCESSFUL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SUCCESSFUL

  • public interface SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Indicates a successful Reply Status.

    • 字段详细信息

      • value

        static final short value
        Indicates a successful Reply Status. One possible value for RequestInfo.reply_status.
        另请参见：
        RequestInfoOperations.reply_status(), SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eore h<t"ae=ntse


SYSTEM_EXCEPTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SYSTEM_EXCEPTION

  • public interface SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Indicates a SystemException reply status.

    • 字段详细信息

      • value

        static final short value
        Indicates a SystemException reply status. One possible value for RequestInfo.reply_status.
        另请参见：
        RequestInfoOperations.reply_status(), SUCCESSFUL, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t ar mbsafccaffiehhs Pg.a"e-


TRANSPORT_RETRY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface TRANSPORT_RETRY

  • public interface TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Indicates a Transport Retry reply status.

    • 字段详细信息

      • value

        static final short value
        Indicates a Transport Retry reply status. One possible value for RequestInfo.reply_status.
        另请参见：
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<< hyhoh h/l t saaabs faf cha


UNKNOWN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface UNKNOWN

  • public interface UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      XXX

    • 字段详细信息

      • value

        static final short value
        XXX
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ellrsrdrira"Fie


USER_EXCEPTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface USER_EXCEPTION

  • public interface USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short value
      Indicates a UserException reply status.

    • 字段详细信息

      • value

        static final short value
        Indicates a UserException reply status. One possible value for RequestInfo.reply_status.
        另请参见：
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-stebdepn/toe=-rest⒖狫 t担


Uses of Package org.omg.PortableInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableInterceptor

  • Packages that use org.omg.PortableInterceptor
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.PortableInterceptor used by org.omg.PortableInterceptor
    类与描述
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o


Uses of Class org.omg.PortableInterceptor.AdapterManagerIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.AdapterManagerIdHelper

No usage of org.omg.PortableInterceptor.AdapterManagerIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/d ivrhbt.ldts>t0n


Uses of Class org.omg.PortableInterceptor.AdapterNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.AdapterNameHelper

No usage of org.omg.PortableInterceptor.AdapterNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

At/ab;1;p-1


Uses of Class org.omg.PortableInterceptor.AdapterStateHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.AdapterStateHelper

No usage of org.omg.PortableInterceptor.AdapterStateHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oyy竢h; � a


Uses of Class org.omg.PortableInterceptor.CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.CurrentHelper

No usage of org.omg.PortableInterceptor.CurrentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rA.rng"s"tttss==.oIr"


Uses of Class org.omg.PortableInterceptor.ForwardRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ForwardRequest

  • Packages that use ForwardRequest
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ForwardRequest in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ForwardRequest
      修饰符与类型 | 方法与描述
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ForwardRequest
      修饰符与类型 | 方法与描述
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableInterceptor that throw ForwardRequest
      修饰符与类型 方法与描述
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lotbT"#ithcr ath


Uses of Class org.omg.PortableInterceptor.ForwardRequestHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ForwardRequestHelper

No usage of org.omg.PortableInterceptor.ForwardRequestHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

neglspats"""ll>>nc.r<


Uses of Class org.omg.PortableInterceptor.InvalidSlot

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.InvalidSlot

  • Packages that use InvalidSlot
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InvalidSlot in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return InvalidSlot
      修饰符与类型 | 方法与描述
      static InvalidSlot | InvalidSlotHelper.extract(Any a)
      static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type InvalidSlot
      修饰符与类型 | 方法与描述
      static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
      static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
      Methods in org.omg.PortableInterceptor that throw InvalidSlot
      修饰符与类型 方法与描述
      Any CurrentOperations.get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      Any RequestInfoOperations.get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      void ServerRequestInfoOperations.set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      void CurrentOperations.set_slot(int id, Any data)
      Sets data in a slot.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gao<_bondc.=磞s_dn


Uses of Class org.omg.PortableInterceptor.InvalidSlotHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.InvalidSlotHelper

No usage of org.omg.PortableInterceptor.InvalidSlotHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

spptlidI>nnnnsttea>e"


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Helper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Helper

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Helper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Isngorg/.....errktaer


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Holder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Holder

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>l"o郐.s垚a鑕tr


Uses of Class org.omg.PortableInterceptor.ObjectIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ObjectIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<磘>�>ps �


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i"titmtlllycbbt


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

et�.睫tfl� 鹀Ar


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fpe"strsasss tlltt"cl


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l`敗la-翜Lldt錿l


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i<>aeddeallegtgedm�


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>聅�/a F �%g*t�=


Uses of Class org.omg.PortableInterceptor.ORBIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBIdHelper

No usage of org.omg.PortableInterceptor.ORBIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

awsrnanus dr a思疑蔿


Uses of Class org.omg.PortableInterceptor.ServerIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ServerIdHelper

No usage of org.omg.PortableInterceptor.ServerIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"" toOptsIIIqCIIcdlsm


Uses of Interface org.omg.PortableInterceptor.ACTIVE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ACTIVE

No usage of org.omg.PortableInterceptor.ACTIVE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfo

  • Packages that use ClientRequestInfo
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInfo
      修饰符与类型 方法与描述
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void ClientRequestInterceptorOperations.send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"v/rlqjbe//nrte..o"翟


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfoOperations

  • Packages that use ClientRequestInfoOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInfoOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pctb/Po/gooo/.<


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptor

  • Packages that use ClientRequestInterceptor
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInterceptor
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=rtih lop(/soet.es"tsne


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptorOperations

  • Packages that use ClientRequestInterceptorOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInterceptorOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"F>rlptpcrhl嬗t/鎥� 99 �


Uses of Interface org.omg.PortableInterceptor.Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.Current

  • Packages that use Current
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Current in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Current
      修饰符与类型 | 方法与描述
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      static Current | CurrentHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type Current
      修饰符与类型 | 方法与描述
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>pn


Uses of Interface org.omg.PortableInterceptor.CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.CurrentOperations

  • Packages that use CurrentOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CurrentOperations in org.omg.PortableInterceptor

      Subinterfaces of CurrentOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  Current
      Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tXrmg o oll cs /rn= a/.


Uses of Interface org.omg.PortableInterceptor.DISCARDING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.DISCARDING

No usage of org.omg.PortableInterceptor.DISCARDING
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

BbO ===-!--->llllris>


Uses of Interface org.omg.PortableInterceptor.HOLDING

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.HOLDING

No usage of org.omg.PortableInterceptor.HOLDING
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d<鋍,r rOce蔼� /胠话b


Uses of Interface org.omg.PortableInterceptor.INACTIVE

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.INACTIVE

No usage of org.omg.PortableInterceptor.INACTIVE
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(1tada醦ans(nto


Uses of Interface org.omg.PortableInterceptor.Interceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.Interceptor

  • Packages that use Interceptor
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Interceptor in org.omg.PortableInterceptor

      Subinterfaces of Interceptor in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ServerRequestInterceptor
      Server-side request interceptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

P ced>>-/ rettosve)ni1


Uses of Interface org.omg.PortableInterceptor.InterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.InterceptorOperations

  • Packages that use InterceptorOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of InterceptorOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  ClientRequestInterceptorOperations
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
      interface  IORInterceptorOperations
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      interface  ServerRequestInterceptorOperations
      Server-side request interceptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cderl< rLg舋<"


Uses of Interface org.omg.PortableInterceptor.IORInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInfo

  • Packages that use IORInfo
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type IORInfo
      修饰符与类型 方法与描述
      void IORInterceptor_3_0Operations.components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
      void IORInterceptorOperations.establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uc srssaldl cvtee;ofsa


Uses of Interface org.omg.PortableInterceptor.IORInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInfoOperations

  • Packages that use IORInfoOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInfoOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s el l lCsl wwacL nn


Uses of Interface org.omg.PortableInterceptor.IORInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor

  • Packages that use IORInterceptor
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

snmlr>,ah/r gtn>ol///p<.


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0

  • Packages that use IORInterceptor_3_0
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0 in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as IORInterceptor_3_0
      修饰符与类型 | 字段与描述
      IORInterceptor_3_0 | IORInterceptor_3_0Holder.value
      Methods in org.omg.PortableInterceptor that return IORInterceptor_3_0
      修饰符与类型 | 方法与描述
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      修饰符与类型 | 方法与描述
      static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
      static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
      Constructors in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      构造方法与描述
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/dvard< <-rP


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0Operations

  • Packages that use IORInterceptor_3_0Operations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0Operations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor_3_0Operations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oP f rhutI#aet眛p0�


Uses of Interface org.omg.PortableInterceptor.IORInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.IORInterceptorOperations

  • Packages that use IORInterceptorOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptorOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

taennioitn moo.适蹂技�.


Uses of Interface org.omg.PortableInterceptor.LOCATION_FORWARD

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.LOCATION_FORWARD

No usage of org.omg.PortableInterceptor.LOCATION_FORWARD
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aa


Uses of Interface org.omg.PortableInterceptor.NON_EXISTENT

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.NON_EXISTENT

No usage of org.omg.PortableInterceptor.NON_EXISTENT
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

--motsn>sl>< >g/s


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceFactory

  • Packages that use ObjectReferenceFactory
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceFactory in org.omg.PortableInterceptor

      Subinterfaces of ObjectReferenceFactory in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ObjectReferenceTemplate
      The object reference template.
      Fields in org.omg.PortableInterceptor declared as ObjectReferenceFactory
      修饰符与类型 | 字段与描述
      ObjectReferenceFactory | ObjectReferenceFactoryHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceFactory
      修饰符与类型 | 方法与描述
      ObjectReferenceFactory IORInfoOperations.current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      修饰符与类型 | 方法与描述
      void IORInfoOperations.current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
      static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      构造方法与描述
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r籸


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceTemplate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceTemplate

  • Packages that use ObjectReferenceTemplate
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceTemplate in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as ObjectReferenceTemplate
      修饰符与类型 | 字段与描述
      ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHolder.value
      ObjectReferenceTemplate | ObjectReferenceTemplateHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceTemplate
      修饰符与类型 | 方法与描述
      ObjectReferenceTemplate IORInfoOperations.adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      修饰符与类型 | 方法与描述
      void IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
      static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
      static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
      static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      构造方法与描述
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

irrss =t ey-o- p"rr>r


Uses of Interface org.omg.PortableInterceptor.ORBInitializer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ORBInitializer

No usage of org.omg.PortableInterceptor.ORBInitializer
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

;0/u.>pnmmlv2� lah


Uses of Interface org.omg.PortableInterceptor.ORBInitializerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ORBInitializerOperations

  • Packages that use ORBInitializerOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitializerOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitializerOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/o iormes r� bre.lm/癕


Uses of Interface org.omg.PortableInterceptor.ORBInitInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfo

  • Packages that use ORBInitInfo
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ORBInitInfo
      修饰符与类型 方法与描述
      void ORBInitializerOperations.post_init(ORBInitInfo info)
      Called during ORB initialization.
      void ORBInitializerOperations.pre_init(ORBInitInfo info)
      Called during ORB initialization.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iMp<


Uses of Interface org.omg.PortableInterceptor.ORBInitInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfoOperations

  • Packages that use ORBInitInfoOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitInfoOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dnote":"=tp/n.pp夤a>抖>f


Uses of Interface org.omg.PortableInterceptor.PolicyFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.PolicyFactory

  • Packages that use PolicyFactory
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type PolicyFactory
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dg ad>pi s ia..t/aejt.j�


Uses of Interface org.omg.PortableInterceptor.PolicyFactoryOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.PolicyFactoryOperations

  • Packages that use PolicyFactoryOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactoryOperations in org.omg.PortableInterceptor

      Subinterfaces of PolicyFactoryOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rt� rl苐c 傲唬芶蝗ｙ　鵪


Uses of Interface org.omg.PortableInterceptor.RequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.RequestInfo

  • Packages that use RequestInfo
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfo in org.omg.PortableInterceptor

      Subinterfaces of RequestInfo in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt


Uses of Interface org.omg.PortableInterceptor.RequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.RequestInfoOperations

  • Packages that use RequestInfoOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of RequestInfoOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInfoOperations
      Request Information, accessible to client-side request interceptors.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInfoOperations
      Request Information, accessible to server-side request interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"ssl蛃tec.覽b"


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfo

  • Packages that use ServerRequestInfo
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInfo
      修饰符与类型 方法与描述
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ -=saoe


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfoOperations

  • Packages that use ServerRequestInfoOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInfoOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nbg<_res>eeeoqttreutoeIe


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptor

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptor

  • Packages that use ServerRequestInterceptor
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInterceptor
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"rg鵤a


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptorOperations

  • Packages that use ServerRequestInterceptorOperations
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInterceptorOperations in org.omg.PortableInterceptor
      修饰符与类型 Interface and Description
      interface  ServerRequestInterceptor
      Server-side request interceptor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"F>rlptpcrhl嬗t/鎥� 99 �


Uses of Interface org.omg.PortableInterceptor.SUCCESSFUL

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.SUCCESSFUL

No usage of org.omg.PortableInterceptor.SUCCESSFUL
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bue


Uses of Interface org.omg.PortableInterceptor.SYSTEM_EXCEPTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.SYSTEM_EXCEPTION

No usage of org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hha


Uses of Interface org.omg.PortableInterceptor.TRANSPORT_RETRY

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.TRANSPORT_RETRY

No usage of org.omg.PortableInterceptor.TRANSPORT_RETRY
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>o阧t>>lhttsOCd


Uses of Interface org.omg.PortableInterceptor.UNKNOWN

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.UNKNOWN

No usage of org.omg.PortableInterceptor.UNKNOWN
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sptＨ�/�o>


Uses of Interface org.omg.PortableInterceptor.USER_EXCEPTION

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableInterceptor.USER_EXCEPTION

No usage of org.omg.PortableInterceptor.USER_EXCEPTION
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

adeeoltltl>剿s=c


DuplicateName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

类 DuplicateName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class DuplicateName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      String name
      The name for which there was already an interceptor registered.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DuplicateName()
      DuplicateName(String _name)
      DuplicateName(String $reason, String _name)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • name

        public String name
        The name for which there was already an interceptor registered.

    • 构造方法详细信息

      • DuplicateName

        public DuplicateName()

      • DuplicateName

        public DuplicateName(String _name)

      • DuplicateName

        public DuplicateName(String $reason,
             String _name)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u ."i"p<>ra萵蝜.>


DuplicateNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor.ORBInitInfoPackage

类 DuplicateNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

  • public abstract class DuplicateNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      DuplicateNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static DuplicateName | extract(Any a)
      static String | id()
      static void | insert(Any a, DuplicateName that)
      static DuplicateName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DuplicateName value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DuplicateNameHelper

        public DuplicateNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          DuplicateName that)

      • extract

        public static DuplicateName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DuplicateName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         DuplicateName value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/bO rp眞woa


InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

类 InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidName()
      InvalidName(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • InvalidName

        public InvalidName()

      • InvalidName

        public InvalidName(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

utpontOitO.RRO..elgg>a(>.


InvalidNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor.ORBInitInfoPackage

类 InvalidNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

  • public abstract class InvalidNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Thursday, April 14, 2011 2:04:17 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidNameHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidName | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidName that)
      static InvalidName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidName value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidNameHelper

        public InvalidNameHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidName that)

      • extract

        public static InvalidName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidName value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hho欲/�-bm


ObjectIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableInterceptor.ORBInitInfoPackage

类 ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Object id, represented as a String

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectIdHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectIdHelper

        public ObjectIdHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         String value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ka/./=/./..../l..ii縯a"/<<>lli>//l b


org.omg.PortableInterceptor.ORBInitInfoPackage

Classes

  • DuplicateNameHelper
  • InvalidNameHelper
  • ObjectIdHelper

Exceptions

  • DuplicateName
  • InvalidName
l


org.omg.PortableInterceptor.ORBInitInfoPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableInterceptor.ORBInitInfoPackage

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

请参见： 描述

  • Class Summary
    类 描述
    DuplicateNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
    InvalidNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
    ObjectIdHelper
    Object id, represented as a String
  • Exception Summary
    Exception 描述
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .

软件包 org.omg.PortableInterceptor.ORBInitInfoPackage Description

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=-d Llislboiilckk"Lb""= ee


org.omg.PortableInterceptor.ORBInitInfoPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableInterceptor.ORBInitInfoPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l>a<


Uses of Package org.omg.PortableInterceptor.ORBInitInfoPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableInterceptor.ORBInitInfoPackage

  • Packages that use org.omg.PortableInterceptor.ORBInitInfoPackage
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor
    类与描述
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor.ORBInitInfoPackage
    类与描述
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Vc


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName

  • Packages that use DuplicateName
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of DuplicateName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw DuplicateName
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.

    • Uses of DuplicateName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return DuplicateName
      修饰符与类型 | 方法与描述
      static DuplicateName | DuplicateNameHelper.extract(Any a)
      static DuplicateName | DuplicateNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type DuplicateName
      修饰符与类型 | 方法与描述
      static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
      static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ne,olrle �>t╪藆


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

R"BebleoPrrrm...g=tO.


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName

  • Packages that use InvalidName
    软件包 描述
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of InvalidName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw InvalidName
      修饰符与类型 方法与描述
      void ORBInitInfoOperations.register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      Object ORBInitInfoOperations.resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • Uses of InvalidName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return InvalidName
      修饰符与类型 | 方法与描述
      static InvalidName | InvalidNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type InvalidName
      修饰符与类型 | 方法与描述
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"h rttp/o "/i/"lbdyoo=


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ietpnteballlor..Rron/


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n>/>slpla>y/


AdapterActivator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface AdapterActivator

  • All Superinterfaces:
    AdapterActivatorOperations, IDLEntity, Object, Serializable

    public interface AdapterActivator
extends AdapterActivatorOperations, Object, IDLEntity
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.AdapterActivatorOperations

        unknown_adapter

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tseoao.rtpXtu


AdapterActivatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface AdapterActivatorOperations

  • All Known Subinterfaces:
    AdapterActivator

    public interface AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.

    • 方法详细信息

      • unknown_adapter

        boolean unknown_adapter(POA parent,
                      String name)
        This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist. The ORB invokes this operation once for each POA that must be created in order for the target POA to exist.
        参数：
        parent - indicates the parent POA for the POA that needs to be created.
        name - identifies the name of the POA relative to the parent.
        返回：
        returns TRUE if the POA was created or FALSE otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

鵧v vav,vres, ft d.邓耽泉⑾�


Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.CurrentOperations

        get_object_id, get_POA

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i>auseLI古 spoA;


CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 CurrentHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • 构造方法摘要

      Constructors
      构造方法与描述
      CurrentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Current value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • CurrentHelper

        public CurrentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         Current value)

      • narrow

        public static Current narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e->n>= oubo/ld奔bgrs=>ee/�


CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      byte[] get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • 方法详细信息

      • get_POA

        POA get_POA()
            throws NoContext
        Returns reference to the POA implementing the object in whose context it is called.
        返回：
        The poa implementing the object
        抛出：
        NoContext - is raised when the operation is outside the context of a POA-dispatched operation

      • get_object_id

        byte[] get_object_id()
                     throws NoContext
        Returns the ObjectId identifying the object in whose context it is called.
        返回：
        the ObjectId of the object
        抛出：
        NoContext - is raised when the operation is called outside the context of a POA-dispatched operation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.//


DynamicImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 DynamicImplementation

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation

  • public abstract class DynamicImplementation
extends Servant
    Allows dynamic handling of object invocations. POA-based DSI servants inherit from the standard DynamicImplementation class, this class inherits from the Servant class. Based on IDL to Java spec. CORBA V 2.3.1 ptc/00-01-08.pdf.

    • 构造方法摘要

      Constructors
      构造方法与描述
      DynamicImplementation()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract void invoke(ServerRequest request)
      Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _all_interfaces, _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DynamicImplementation

        public DynamicImplementation()

    • 方法详细信息

      • invoke

        public abstract void invoke(ServerRequest request)
        Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
        参数：
        request - the request issued to the CORBA object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

setslca c>/ >/a-< Aylr rsue


ForwardRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer

类 ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.ForwardRequest
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableServer/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:14 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object forward_reference

    • 构造方法摘要

      Constructors
      构造方法与描述
      ForwardRequest()
      ForwardRequest(Object _forward_reference)
      ForwardRequest(String $reason, Object _forward_reference)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • forward_reference

        public Object forward_reference

    • 构造方法详细信息

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward_reference)

      • ForwardRequest

        public ForwardRequest(String $reason,
              Object _forward_reference)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

v


ForwardRequestHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableServer.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableServer/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:14 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ForwardRequestHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ForwardRequest value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a=sl .{{詌


ID_ASSIGNMENT_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_ASSIGNMENT_POLICY_ID

  • public interface ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing ID_ASSIGNMENT_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing ID_ASSIGNMENT_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r">;>nc&nc/ooc//l&///goorUni>m<


ID_UNIQUENESS_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_UNIQUENESS_POLICY_ID

  • public interface ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:14 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing ID_UNIQUENESS_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing ID_UNIQUENESS_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.g�n{ 6 "�po餧/4 Pxc� e


IdAssignmentPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdAssignmentPolicy

  • All Superinterfaces:
    IdAssignmentPolicyOperations, IDLEntity, Object, Policy, PolicyOperations, Serializable

    public interface IdAssignmentPolicy
extends IdAssignmentPolicyOperations, Policy, IDLEntity
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.IdAssignmentPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ta(b


IdAssignmentPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface IdAssignmentPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdAssignmentPolicy

    public interface IdAssignmentPolicyOperations
extends PolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      IdAssignmentPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        IdAssignmentPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpa p C alClsl{iiCat - >jgot


IdAssignmentPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 IdAssignmentPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdAssignmentPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class IdAssignmentPolicyValue
extends Object
implements IDLEntity
    The IdAssignmentPolicyValue can have the following values. USER_ID - Objects created with that POA are assigned Object Ids only by the application. SYSTEM_ID - Objects created with that POA are assigned Object Ids only by the POA. If the POA also has the PERSISTENT policy, assigned Object Ids must be unique across all instantiations of the same POA.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _SYSTEM_ID
      static int | _USER_ID
      static IdAssignmentPolicyValue | SYSTEM_ID
      static IdAssignmentPolicyValue | USER_ID

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | IdAssignmentPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static IdAssignmentPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _USER_ID

        public static final int _USER_ID
        另请参见：
        Constant Field Values

      • USER_ID

        public static final IdAssignmentPolicyValue USER_ID

      • _SYSTEM_ID

        public static final int _SYSTEM_ID
        另请参见：
        Constant Field Values

      • SYSTEM_ID

        public static final IdAssignmentPolicyValue SYSTEM_ID

    • 构造方法详细信息

      • IdAssignmentPolicyValue

        protected IdAssignmentPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static IdAssignmentPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l_i/r�tfit iol/s<<襩l&


IdUniquenessPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdUniquenessPolicy

  • All Superinterfaces:
    IDLEntity, IdUniquenessPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface IdUniquenessPolicy
extends IdUniquenessPolicyOperations, Policy, IDLEntity
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.IdUniquenessPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>> Vggs/givinu


IdUniquenessPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface IdUniquenessPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdUniquenessPolicy

    public interface IdUniquenessPolicyOperations
extends PolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      IdUniquenessPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        IdUniquenessPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nvksls sisaeLinsLlooie ssCaapng


IdUniquenessPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 IdUniquenessPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdUniquenessPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class IdUniquenessPolicyValue
extends Object
implements IDLEntity
    IdUniquenessPolicyValue can have the following values. UNIQUE_ID - Servants activated with that POA support exactly one Object Id. MULTIPLE_ID - a servant activated with that POA may support one or more Object Ids.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _MULTIPLE_ID
      static int | _UNIQUE_ID
      static IdUniquenessPolicyValue | MULTIPLE_ID
      static IdUniquenessPolicyValue | UNIQUE_ID

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | IdUniquenessPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static IdUniquenessPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _UNIQUE_ID

        public static final int _UNIQUE_ID
        另请参见：
        Constant Field Values

      • UNIQUE_ID

        public static final IdUniquenessPolicyValue UNIQUE_ID

      • _MULTIPLE_ID

        public static final int _MULTIPLE_ID
        另请参见：
        Constant Field Values

      • MULTIPLE_ID

        public static final IdUniquenessPolicyValue MULTIPLE_ID

    • 构造方法详细信息

      • IdUniquenessPolicyValue

        protected IdUniquenessPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static IdUniquenessPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

erbem╰D&D>>&Lb;bhs�-b皊><


IMPLICIT_ACTIVATION_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface IMPLICIT_ACTIVATION_POLICY_ID

  • public interface IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing IMPLICIT_ACTIVATION_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing IMPLICIT_ACTIVATION_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dm>


ImplicitActivationPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ImplicitActivationPolicy

  • All Superinterfaces:
    IDLEntity, ImplicitActivationPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface ImplicitActivationPolicy
extends ImplicitActivationPolicyOperations, Policy, IDLEntity
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.ImplicitActivationPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

odcsnx nc<>ss>>4/clg"n&I.p


ImplicitActivationPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface ImplicitActivationPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ImplicitActivationPolicy

    public interface ImplicitActivationPolicyOperations
extends PolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ImplicitActivationPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        ImplicitActivationPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

< )=)o) )p{ l = !a<>p"c"una


ImplicitActivationPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ImplicitActivationPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ImplicitActivationPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class ImplicitActivationPolicyValue
extends Object
implements IDLEntity
    ImplicitActivationPolicyValue has the following semantics. IMPLICIT_ACTIVATION to indicate implicit activation of servants. This requires SYSTEM_ID and RETAIN policies to be set. NO_IMPLICIT_ACTIVATION to indicate no implicit servant activation.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _IMPLICIT_ACTIVATION
      static int | _NO_IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | NO_IMPLICIT_ACTIVATION

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ImplicitActivationPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ImplicitActivationPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _IMPLICIT_ACTIVATION

        public static final int _IMPLICIT_ACTIVATION
        另请参见：
        Constant Field Values

      • IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue IMPLICIT_ACTIVATION

      • _NO_IMPLICIT_ACTIVATION

        public static final int _NO_IMPLICIT_ACTIVATION
        另请参见：
        Constant Field Values

      • NO_IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue NO_IMPLICIT_ACTIVATION

    • 构造方法详细信息

      • ImplicitActivationPolicyValue

        protected ImplicitActivationPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static ImplicitActivationPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e=vmr o"trl.ilja-ntbsAa啶n筬u d.bg


LIFESPAN_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface LIFESPAN_POLICY_ID

  • public interface LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:14 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing LIFESPAN_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing LIFESPAN_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pn;/auslusbppsbbisoo..h./rSLmtc


LifespanPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface LifespanPolicy

  • All Superinterfaces:
    IDLEntity, LifespanPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface LifespanPolicy
extends LifespanPolicyOperations, Policy, IDLEntity
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.LifespanPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o>lcl/C/rIu"srSP_ta=snmt


LifespanPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface LifespanPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    LifespanPolicy

    public interface LifespanPolicyOperations
extends PolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LifespanPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        LifespanPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ldil l lslCsesLkea==ss-allC rmt


LifespanPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 LifespanPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.LifespanPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class LifespanPolicyValue
extends Object
implements IDLEntity
    The LifespanPolicyValue can have the following values. TRANSIENT - The objects implemented in the POA cannot outlive the POA instance in which they are first created. PERSISTENT - The objects implemented in the POA can outlive the process in which they are first created.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _PERSISTENT
      static int | _TRANSIENT
      static LifespanPolicyValue | PERSISTENT
      static LifespanPolicyValue | TRANSIENT

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | LifespanPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static LifespanPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _TRANSIENT

        public static final int _TRANSIENT
        另请参见：
        Constant Field Values

      • TRANSIENT

        public static final LifespanPolicyValue TRANSIENT

      • _PERSISTENT

        public static final int _PERSISTENT
        另请参见：
        Constant Field Values

      • PERSISTENT

        public static final LifespanPolicyValue PERSISTENT

    • 构造方法详细信息

      • LifespanPolicyValue

        protected LifespanPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static LifespanPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

-p v>Rlrni o--=!<-_dfidtt絜./u<


org.omg.PortableServer

Interfaces

  • AdapterActivator
  • AdapterActivatorOperations
  • Current
  • CurrentOperations
  • ID_ASSIGNMENT_POLICY_ID
  • ID_UNIQUENESS_POLICY_ID
  • IdAssignmentPolicy
  • IdAssignmentPolicyOperations
  • IdUniquenessPolicy
  • IdUniquenessPolicyOperations
  • IMPLICIT_ACTIVATION_POLICY_ID
  • ImplicitActivationPolicy
  • ImplicitActivationPolicyOperations
  • LIFESPAN_POLICY_ID
  • LifespanPolicy
  • LifespanPolicyOperations
  • POA
  • POAManager
  • POAManagerOperations
  • POAOperations
  • REQUEST_PROCESSING_POLICY_ID
  • RequestProcessingPolicy
  • RequestProcessingPolicyOperations
  • SERVANT_RETENTION_POLICY_ID
  • ServantActivator
  • ServantActivatorOperations
  • ServantLocator
  • ServantLocatorOperations
  • ServantManager
  • ServantManagerOperations
  • ServantRetentionPolicy
  • ServantRetentionPolicyOperations
  • THREAD_POLICY_ID
  • ThreadPolicy
  • ThreadPolicyOperations

Classes

  • _ServantActivatorStub
  • _ServantLocatorStub
  • CurrentHelper
  • DynamicImplementation
  • ForwardRequestHelper
  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • POAHelper
  • RequestProcessingPolicyValue
  • Servant
  • ServantActivatorHelper
  • ServantActivatorPOA
  • ServantLocatorHelper
  • ServantLocatorPOA
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Exceptions

  • ForwardRequest
�


org.omg.PortableServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

请参见： 描述

  • 接口摘要
    接口 描述
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
    ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java .
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java .
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java .
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java .
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
  • Class Summary
    类 描述
    _ServantActivatorStub
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    _ServantLocatorStub
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    CurrentHelper
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    DynamicImplementation
    Allows dynamic handling of object invocations.
    ForwardRequestHelper
    org/omg/PortableServer/ForwardRequestHelper.java .
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POAHelper
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivatorHelper
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorPOA
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocatorHelper
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorPOA
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Exception Summary
    Exception 描述
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .

软件包 org.omg.PortableServer Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

In Java, Portable Object Adaptor (POA)-based Dynamic Skeleton Interface (DSI) servants inherit from the standard DynamicImplementation class, which inherits from the Servant class. The native Servant type is defined by the PortableServer module for the POA. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

POA-related Interfaces

The PortableServer module defines the following POA-related interfaces:

  • POA
  • POAManager
  • ServantManager
  • ServantActivator
  • ServantLocator
  • AdapterActivator
  • ThreadPolicy
  • LifespanPolicy
  • IdUniquenessPolicy
  • IdAssignmentPolicy
  • ImplicitActivationPolicy
  • ServantRetentionPolicy
  • RequestProcessingPolicy
  • Current

In addition, the POA defines the Servant native type.

Operations classes

Each of the interfaces listed above has an associated Operations interface. The Operations interface is generated by the idlj compiler and contains the method signatures for methods defined in its associated interface. The Operations interface can be accessed by both the client and the server, while its associated interface can only be called by the client.

Value Classes

Classes ending in the suffix PolicyValue provide the values used for the create_POA call, which sets the policy for the POA. See the sample code below for a demonstration. PolicyValue files include the following:

  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • RequestProcessingPolicyValue
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types. There is only one method in a helper class that an application programmer uses: the narrow method. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the PortableServer package, only the following classes have a narrow method:

  • ForwardRequestHelper
  • ServantActivatorHelper
  • ServantLocatorHelper

POA Classes

POA classes are used to implement the ServantActivator or ServantLocator.

Exceptions

The ForwardRequest exception indicates to the ORB that it is responsible for delivering the current request and subsequent ForwardRequest requests to the object denoted in the forward_reference member of the exception.

Interfaces Implemented by the Application Programmer

Most of what PortableServer does is transparent to the user. The result is that programmers will use only a few of the interfaces mentioned above. The remaining interfaces will be provided by the ORB implementation. The interfaces of interest to application programmers are the following:

  • AdapterActivator

    Adapter activators are associated with POAs. An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE. An application server that creates all its needed POAs at the beginning of execution does not need to use or provide an adapter activator; it is necessary only for the case in which POAs need to be created during request processing.

  • ServantLocator

    When the POA has the NON_RETAIN policy, it uses servant managers that are ServantLocators.

  • ServantActivator

    When the POA has the RETAIN policy, it uses servant managers that are ServantActivators.

Package org.omg.PortableServer.ServantLocatorPackage

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Related Documentation

For an overview of Java IDL, please see:

  • Java IDL home page.

    Example Code

    Example Server Code

    import javax.naming.InitialContext;
import javax.naming.Context;
import javax.rmi.PortableRemoteObject ;
import com.sun.corba.se.impl.poa.POAORB;
import org.omg.PortableServer.*;
import java.util.*;
import org.omg.CORBA.*;
import javax.rmi.CORBA.Stub;
import javax.rmi.CORBA.Util;

public class HelloServer {
    public HelloServer(String[] args) {
        try {
            Properties p = System.getProperties();
         //   p.put("org.omg.CORBA.ORBClass", "com.sun.corba.ee.internal.POA.POAORB");
            ORB orb = ORB.init( args, p );

            POA rootPOA = (POA)orb.resolve_initial_references("RootPOA");

            Policy[] tpolicy = new Policy[3];
            tpolicy[0] = rootPOA.create_lifespan_policy(
                LifespanPolicyValue.TRANSIENT );
            tpolicy[1] = rootPOA.create_request_processing_policy(
                RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY );
            tpolicy[2] = rootPOA.create_servant_retention_policy(
                ServantRetentionPolicyValue.RETAIN);
            POA tpoa = rootPOA.create_POA("MyTransientPOA", null, tpolicy);

            String  ObjectId = "MyObjectId";
            byte[] oid = ObjectId.getBytes();

            org.omg.CORBA.Object obj = tpoa.create_reference_with_id(oid,
                new _HelloImpl_Tie()._all_interfaces(tpoa, oid)[0]);
            HelloInterface helloRef = (HelloInterface)PortableRemoteObject.narrow(
                obj, HelloInterface.class );

            Context initialNamingContext = new InitialContext();
            initialNamingContext.rebind("HelloService", helloRef);
            System.out.println("Hello Server: Ready...");
            orb.run();
         } catch (Exception e) {
            System.out.println("Trouble: " + e);
            e.printStackTrace();
         }
     }

     public static void main(String args[]) {
         new HelloServer( args );
     }
}

    • 从以下版本开始：
    1.4
    • 概述
    • 软件包
    • 类
    • 使用
    • 树
    • 已过时
    • 索引
    • 帮助
    Java™ Platform
    Standard Ed. 7
    草案 ea-b138
    • 上一个软件包
    • 下一个软件包
    • 框架
    • 无框架
    • 所有的类


org.omg.PortableServer Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
    • org.omg.PortableServer.POAHelper
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.ForwardRequest

Interface Hierarchy

  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.POA (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.THREAD_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n


POA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface POA

  • All Superinterfaces:
    IDLEntity, Object, POAOperations, Serializable

    public interface POA
extends POAOperations, Object, IDLEntity
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.POAOperations

        activate_object_with_id, activate_object, create_id_assignment_policy, create_id_uniqueness_policy, create_implicit_activation_policy, create_lifespan_policy, create_POA, create_reference_with_id, create_reference, create_request_processing_policy, create_servant_retention_policy, create_thread_policy, deactivate_object, destroy, find_POA, get_servant_manager, get_servant, id_to_reference, id_to_servant, id, reference_to_id, reference_to_servant, servant_to_id, servant_to_reference, set_servant_manager, set_servant, the_activator, the_activator, the_children, the_name, the_parent, the_POAManager

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.a/hen"ne"=c=all


POAHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 POAHelper

  • java.lang.Object
    • org.omg.PortableServer.POAHelper

  • public abstract class POAHelper
extends Object
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • 构造方法摘要

      Constructors
      构造方法与描述
      POAHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static POA | extract(Any a)
      static String | id()
      static void | insert(Any a, POA that)
      static POA | narrow(Object obj)
      static POA | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, POA value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • POAHelper

        public POAHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          POA that)

      • extract

        public static POA extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static POA read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         POA value)

      • narrow

        public static POA narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Saegg<.#o.yhh orsee tlr> r .ghttVa


POAManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAManager

  • All Superinterfaces:
    IDLEntity, Object, POAManagerOperations, Serializable

    public interface POAManager
extends POAManagerOperations, Object, IDLEntity
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.POAManagerOperations

        activate, deactivate, discard_requests, get_state, hold_requests

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aemL"lablalssalli===c


POAManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface POAManagerOperations

  • All Known Subinterfaces:
    POAManager

    public interface POAManagerOperations
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      State get_state()
      This operation returns the state of the POA manager.
      void hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • 方法详细信息

      • activate

        void activate()
              throws AdapterInactive
        This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
        抛出：
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • hold_requests

        void hold_requests(boolean wait_for_completion)
                   throws AdapterInactive
        This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.
        参数：
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        抛出：
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • discard_requests

        void discard_requests(boolean wait_for_completion)
                      throws AdapterInactive
        This operation changes the state of the POA manager to discarding. This causes associated POAs to discard incoming requests.
        参数：
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        抛出：
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • deactivate

        void deactivate(boolean etherealize_objects,
              boolean wait_for_completion)
                throws AdapterInactive
        This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
        参数：
        etherealize_objects - a flag to indicate whether to invoke the etherealize operation of the associated servant manager for all active objects.
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        抛出：
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • get_state

        State get_state()
        This operation returns the state of the POA manager.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i;iuudu/>sseaslce>fiial>


POAOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface POAOperations

  • All Known Subinterfaces:
    POA

    public interface POAOperations
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      POA create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      Object create_reference_with_id(byte[] oid, String intf)
      This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
      Object create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ThreadPolicy create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      void deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      void destroy(boolean etherealize_objects, boolean wait_for_completion)
      This operation destroys the POA and all descendant POAs.
      POA find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      ServantManager get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant get_servant()
      This operation returns the default servant associated with the POA.
      Object id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] id()
      This returns the unique id of the POA in the process in which it is created.
      byte[] reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.
      AdapterActivator the_activator()
      This attribute identifies the adapter activator associated with the POA.
      void the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
      POA[] the_children()
      This attribute identifies the current set of all child POAs of the POA.
      String the_name()
      This attribute identifies the POA relative to its parent.
      POA the_parent()
      This attribute identifies the parent of the POA.
      POAManager the_POAManager()
      This attribute identifies the POA manager associated with the POA.

    • 方法详细信息

      • create_POA

        POA create_POA(String adapter_name,
             POAManager a_POAManager,
             Policy[] policies)
               throws AdapterAlreadyExists,
                      InvalidPolicy
        This operation creates a new POA as a child of the target POA.
        参数：
        adapter_name - identifies the new POA with respect to other POAs with the same parent POA.
        a_POAManager - specifies the POA Manager to be associated with the new POA.
        policies - specifies policy objects to be associated with the POA to control its behavior.
        抛出：
        AdapterAlreadyExists - specifies that the target POA already has a child POA with the specified name.
        InvalidPolicy - is raised if any of the policy objects are not valid for the ORB, or are in conflict, or require an administrative action that has not been performed.

      • find_POA

        POA find_POA(String adapter_name,
           boolean activate_it)
             throws AdapterNonExistent
        If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
        参数：
        adapter_name - POA name to be found.
        activate_it - if a POA with the specified name does not exist and the value of the activate_it parameter is TRUE, the target POA's AdapterActivator, if one exists, is invoked.
        返回：
        POA if one exists or is activated by the AdapterActivator.
        抛出：
        AdapterNonExistent

      • destroy

        void destroy(boolean etherealize_objects,
           boolean wait_for_completion)
        This operation destroys the POA and all descendant POAs. All descendant POAs are destroyed (recursively) before the destruction of the containing POA. The POA so destroyed (that is, the POA with its name) may be re-created later in the same process.
        参数：
        etherealize_objects - flag to indicate whether etherealize operation on servant manager needs to be called.
        wait_for_completion - flag to indicate whether POA and its children need to wait for active requests and the etherealization to complete.

      • create_thread_policy

        ThreadPolicy create_thread_policy(ThreadPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        ThreadPolcy Object

      • create_lifespan_policy

        LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        LifespanPolicy Object.

      • create_id_uniqueness_policy

        IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        IdUniquenessPolicy Object.

      • create_id_assignment_policy

        IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        IdAssignmentPolicy Object.

      • create_implicit_activation_policy

        ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        ImplicitActivationPolicy Object.

      • create_servant_retention_policy

        ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        ServantRetentionPolicy Object.

      • create_request_processing_policy

        RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        参数：
        value - policy type
        返回：
        RequestProcessingPolicy Object.

      • the_name

        String the_name()
        This attribute identifies the POA relative to its parent. This name is assigned when the POA is created.

      • the_parent

        POA the_parent()
        This attribute identifies the parent of the POA. The parent of the root POA is null.

      • the_children

        POA[] the_children()
        This attribute identifies the current set of all child POAs of the POA. The set of child POAs includes only the POA's immediate children, and not their descendants.

      • the_POAManager

        POAManager the_POAManager()
        This attribute identifies the POA manager associated with the POA.

      • the_activator

        AdapterActivator the_activator()
        This attribute identifies the adapter activator associated with the POA.

      • the_activator

        void the_activator(AdapterActivator newThe_activator)
        This attribute identifies the adapter activator associated with the POA.

      • get_servant_manager

        ServantManager get_servant_manager()
                                   throws WrongPolicy
        If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface. For a NON_RETAIN policy, the ServantManager shall support the ServantLocator interface. If the argument is nil, or does not support the required interface, then the OBJ_ADAPTER exception is raised.
        返回：
        ServantManager associated with a POA or null if none exists.
        抛出：
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • set_servant_manager

        void set_servant_manager(ServantManager imgr)
                         throws WrongPolicy
        This operation sets the default servant manager associated with the POA. This operation may only be invoked once after a POA has been created. Attempting to set the servant manager after one has already been set will result in the BAD_INV_ORDER exception being raised.
        参数：
        imgr - servant manager to be used as a default.
        抛出：
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • get_servant

        Servant get_servant()
                    throws NoServant,
                           WrongPolicy
        This operation returns the default servant associated with the POA.
        返回：
        p_servant default servant associated with a POA.
        抛出：
        NoServant - raised if no default servant is associated with the POA.
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • set_servant

        void set_servant(Servant p_servant)
                 throws WrongPolicy
        This operation registers the specified servant with the POA as the default servant. This servant will be used for all requests for which no servant is found in the Active Object Map.
        参数：
        p_servant - servant to be used as a default.
        抛出：
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • activate_object

        byte[] activate_object(Servant p_servant)
                       throws ServantAlreadyActive,
                              WrongPolicy
        This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
        参数：
        p_servant - servant to be associated with an object to be activated.
        返回：
        POA generated object id.
        抛出：
        ServantAlreadyActive - is raised if the POA has UNIQUE_ID policy and servant is is already in the Active Object Map.
        WrongPolicy - raised if the SYSTEM_ID and RETAIN policies are not specified.

      • activate_object_with_id

        void activate_object_with_id(byte[] id,
                           Servant p_servant)
                             throws ServantAlreadyActive,
                                    ObjectAlreadyActive,
                                    WrongPolicy
        This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
        参数：
        id - object id for the object to be activated.
        p_servant - servant to be associated with the object.
        抛出：
        ServantAlreadyActive - raised if the POA has the UNIQUE_ID policy and the servant is already in the Active Object Map.
        ObjectAlreadyActive - raised if the object is already active in the POA.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • deactivate_object

        void deactivate_object(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
        This operation causes the ObjectId specified in the oid parameter to be deactivated. An ObjectId which has been deactivated continues to process requests until there are no active requests for that ObjectId. A deactivated ObjectId is removed from the Active Object Map when all requests executing for that ObjectId have completed.
        参数：
        oid - Object Id for the object to be deactivated.
        抛出：
        ObjectNotActive - if the object with the specified oid is not in the Active Object Map.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • create_reference

        Object create_reference(String intf)
                        throws WrongPolicy
        This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
        参数：
        intf - rep id for creating an object reference.
        返回：
        object reference created using intf.
        抛出：
        WrongPolicy - if SYSTEM_ID policy is not specified.

      • create_reference_with_id

        Object create_reference_with_id(byte[] oid,
                              String intf)
        This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values. It does not cause an activation to take place. The resulting reference may be passed to clients, so that subsequent requests on those references will cause the object to be activated if necessary, or the default servant used, depending on the applicable policies.
        参数：
        oid - object id for creating an objref
        intf - rep id for creating an objref
        返回：
        object reference created using oid and intf
        抛出：
        BAD_PARAM - is raised if the POA has the SYSTEM_ID policy and it detects that the Object Id value was not generated by the system or for this POA.

      • servant_to_id

        byte[] servant_to_id(Servant p_servant)
                     throws ServantNotActive,
                            WrongPolicy
        This operation has four possible behaviors. 1. If the POA has the UNIQUE_ID policy and the specified servant is active, the Object Id associated with that servant is returned. 2. If the POA has the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and that Object Id is returned. 3. If the POA has the USE_DEFAULT_SERVANT policy, the servant specified is the default servant, and the operation is being invoked in the context of executing a request on the default servant, then the ObjectId associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        参数：
        p_servant - servant for which the object disi returned.
        返回：
        object id associated with the servant.
        抛出：
        ServantNotActive - if the above rules and policy combination is not met.
        WrongPolicy - if the USE_DEFAULT_SERVANT policy or a combination of the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies are not present.

      • servant_to_reference

        Object servant_to_reference(Servant p_servant)
                            throws ServantNotActive,
                                   WrongPolicy
        This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA. It has four possible behaviors. 1. If the POA has both the RETAIN and the UNIQUE_ID policy and the specified servant is active, an object reference encapsulating the information used to activate the servant is returned. 2. If the POA has both the RETAIN and the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and a corresponding object reference is returned. 3. If the operation was invoked in the context of executing a request on the specified servant, the reference associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        参数：
        p_servant - servant for which the object reference needs to be obtained.
        返回：
        object reference associated with the servant.
        抛出：
        WrongPolicy - if the operation is not invoked in the context of executing a request on the specified servant and the required policies are not present.
        ServantNotActive - if the above specified policies and rules are not met.

      • reference_to_servant

        Servant reference_to_servant(Object reference)
                             throws ObjectNotActive,
                                    WrongPolicy,
                                    WrongAdapter
        If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant. If the object reference was not created by this POA, the WrongAdapter exception is raised. (OMG Issue on inconsistency with the POA.IDL.
        参数：
        reference - object reference for which the servant is returned.
        返回：
        servant associated with the reference.
        抛出：
        WrongPolicy - if neither the RETAIN policy or the USE_DEFAULT_SERVANT policy is present.
        ObjectNotActive - if the servant is not present in the Active Object Map (for RETAIN) or no default servant is registered (for USE_DEFAULT_POLICY).
        WrongAdapter - if reference was not created by this POA instance.

      • reference_to_id

        byte[] reference_to_id(Object reference)
                       throws WrongAdapter,
                              WrongPolicy
        This operation returns the Object Id value encapsulated by the specified reference. This operation is valid only if the reference was created by the POA on which the operation is being performed. The object denoted by the reference does not have to be active for this operation to succeed.
        参数：
        reference - the object reference from which the object id needs to be returned.
        返回：
        object id encapsulated in the reference.
        抛出：
        WrongAdapter - if the reference was not created by the POA specified in the reference.
        WrongPolicy - declared to allow future extensions.

      • id_to_servant

        Servant id_to_servant(byte[] oid)
                      throws ObjectNotActive,
                             WrongPolicy
        If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant.
        参数：
        oid - object id for the which the servant is returned.
        返回：
        servant associated with oid.
        抛出：
        ObjectNotActive - is raised if ObjectId is is not in the Active Object Map (for RETAIN policy), or no default servant is registered (for USE_DEFAULT_SERVANT policy).
        WrongPolicy - is raised if the RETAIN policy or the USE_DEFAULT_SERVANT policy is not present.

      • id_to_reference

        Object id_to_reference(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
        If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
        参数：
        oid - id of the object for which the reference is returned.
        返回：
        the object reference
        抛出：
        ObjectNotActive - if the Object Id value is not active in the POA.
        WrongPolicy - if the RETAIN policy is not present.

      • id

        byte[] id()
        This returns the unique id of the POA in the process in which it is created. It is for use by portable interceptors.

        This id is guaranteed unique for the life span of the POA in the process. For persistent POAs, this means that if a POA is created in the same path with the same name as another POA, these POAs are identical and, therefore, have the same id. For transient POAs, each POA is unique.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


REQUEST_PROCESSING_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface REQUEST_PROCESSING_POLICY_ID

  • public interface REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing REQUEST_PROCESSING_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing REQUEST_PROCESSING_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rt=aeSewSevrrevvsammkcsiansrct�


RequestProcessingPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface RequestProcessingPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, RequestProcessingPolicyOperations, Serializable

    public interface RequestProcessingPolicy
extends RequestProcessingPolicyOperations, Policy, IDLEntity
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.RequestProcessingPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

efSm reorec ecctiaapbet, l


RequestProcessingPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface RequestProcessingPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    RequestProcessingPolicy

    public interface RequestProcessingPolicyOperations
extends PolicyOperations
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      RequestProcessingPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        RequestProcessingPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/a = w ) l t -s!rtmkr


RequestProcessingPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 RequestProcessingPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.RequestProcessingPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class RequestProcessingPolicyValue
extends Object
implements IDLEntity
    The RequestProcessingPolicyValue can have the following values. USE_ACTIVE_OBJECT_MAP_ONLY - If the Object Id is not found in the Active Object Map, an OBJECT_NOT_EXIST exception is returned to the client. The RETAIN policy is also required. USE_DEFAULT_SERVANT - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a default servant has been registered with the POA using the set_servant operation, the request is dispatched to the default servant. USE_SERVANT_MANAGER - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a servant manager has been registered with the POA using the set_servant_manager operation, the servant manager is given the opportunity to locate a servant or raise an exception.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _USE_ACTIVE_OBJECT_MAP_ONLY
      static int | _USE_DEFAULT_SERVANT
      static int | _USE_SERVANT_MANAGER
      static RequestProcessingPolicyValue | USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | USE_SERVANT_MANAGER

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | RequestProcessingPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static RequestProcessingPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _USE_ACTIVE_OBJECT_MAP_ONLY

        public static final int _USE_ACTIVE_OBJECT_MAP_ONLY
        另请参见：
        Constant Field Values

      • USE_ACTIVE_OBJECT_MAP_ONLY

        public static final RequestProcessingPolicyValue USE_ACTIVE_OBJECT_MAP_ONLY

      • _USE_DEFAULT_SERVANT

        public static final int _USE_DEFAULT_SERVANT
        另请参见：
        Constant Field Values

      • USE_DEFAULT_SERVANT

        public static final RequestProcessingPolicyValue USE_DEFAULT_SERVANT

      • _USE_SERVANT_MANAGER

        public static final int _USE_SERVANT_MANAGER
        另请参见：
        Constant Field Values

      • USE_SERVANT_MANAGER

        public static final RequestProcessingPolicyValue USE_SERVANT_MANAGER

    • 构造方法详细信息

      • RequestProcessingPolicyValue

        protected RequestProcessingPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static RequestProcessingPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.r hpii/tc"=fa.hs


Servant

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 Servant

  • java.lang.Object
    • org.omg.PortableServer.Servant
  • 直接已知子类：
    BindingIteratorPOA, DynamicImplementation, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA

    public abstract class Servant
extends Object
    Defines the native Servant type. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior. Based on IDL to Java spec. (CORBA V2.3.1) ptc/00-01-08.pdf.

    • 构造方法摘要

      Constructors
      构造方法与描述
      Servant()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      abstract String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      POA _default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      Delegate _get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Object _get_interface_def()
      Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
      boolean _is_a(String repository_id)
      Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
      boolean _non_existent()
      Checks for the existence of an Object.
      byte[] _object_id()
      Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
      ORB _orb()
      Returns the instance of the ORB currently associated with the Servant (convenience method).
      POA _poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      void _set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
      Object _this_object()
      Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
      Object _this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • Servant

        public Servant()

    • 方法详细信息

      • _get_delegate

        public final Delegate _get_delegate()
        Gets the ORB vendor-specific implementation of PortableServer::Servant.
        返回：
        _delegate the ORB vendor-specific implementation of PortableServer::Servant.

      • _set_delegate

        public final void _set_delegate(Delegate delegate)
        Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
        参数：
        delegate - ORB vendor-specific implementation of the PortableServer::Servant.

      • _this_object

        public final Object _this_object()
        Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
        返回：
        this_object Object reference associated with the request.

      • _this_object

        public final Object _this_object(ORB orb)
        Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        参数：
        orb - ORB with which the servant is associated.
        返回：
        _this_object reference associated with the request.

      • _orb

        public final ORB _orb()
        Returns the instance of the ORB currently associated with the Servant (convenience method).
        返回：
        orb the instance of the ORB currently associated with the Servant.

      • _poa

        public final POA _poa()
        Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
        返回：
        poa POA associated with the servant.

      • _object_id

        public final byte[] _object_id()
        Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
        返回：
        object_id the Object ID associated with this servant.

      • _default_POA

        public POA _default_POA()
        Returns the root POA from the ORB instance associated with the servant. Subclasses may override this method to return a different POA.
        返回：
        default_POA the POA associated with the Servant.

      • _is_a

        public boolean _is_a(String repository_id)
        Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
        参数：
        repository_id - the repository_id to be checked in the repository list or against the id of generic CORBA objects.
        返回：
        is_a boolean indicating whether the specified repository_id is in the repository list or is same as a generic CORBA object.

      • _non_existent

        public boolean _non_existent()
        Checks for the existence of an Object. The Servant provides a default implementation of _non_existent() that can be overridden by derived servants.
        返回：
        non_existent true if that object does not exist, false otherwise.

      • _get_interface_def

        public Object _get_interface_def()
        Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant. The invoker of _get_interface_def must narrow the result to an InterfaceDef in order to use it.

        This default implementation of _get_interface_def() can be overridden by derived servants if the default behavior is not adequate. As defined in the CORBA 2.3.1 specification, section 11.3.1, the default behavior of _get_interface_def() is to use the most derived interface of a static servant or the most derived interface retrieved from a dynamic servant to obtain the InterfaceDef. This behavior must be supported by the Delegate that implements the Servant.

        返回：
        get_interface_def an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.

      • _all_interfaces

        public abstract String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Used by the ORB to obtain complete type information from the servant.
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f"h/<c


SERVANT_RETENTION_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface SERVANT_RETENTION_POLICY_ID

  • public interface SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing SERVANT_RETENTION_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing SERVANT_RETENTION_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

S egog/rg/.../.."


ServantActivator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantActivator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantActivatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantActivatorStub

    public interface ServantActivator
extends ServantActivatorOperations, ServantManager, IDLEntity
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

esst edv c


ServantActivatorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ServantActivatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantActivatorHelper

  • public abstract class ServantActivatorHelper
extends Object
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantActivatorHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServantActivator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantActivator that)
      static ServantActivator | narrow(Object obj)
      static ServantActivator | read(InputStream istream)
      static TypeCode | type()
      static ServantActivator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantActivator value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServantActivatorHelper

        public ServantActivatorHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServantActivator that)

      • extract

        public static ServantActivator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantActivator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServantActivator value)

      • narrow

        public static ServantActivator narrow(Object obj)

      • unchecked_narrow

        public static ServantActivator unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>eddteii<>bchoe//c >


ServantActivatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface ServantActivatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator
    All Known Implementing Classes:
    _ServantActivatorStub, ServantActivatorPOA

    public interface ServantActivatorOperations
extends ServantManagerOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

    • 方法详细信息

      • incarnate

        Servant incarnate(byte[] oid,
                POA adapter)
                  throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        参数：
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        返回：
        Servant corresponding to oid is created or located by the user supplied servant manager.
        抛出：
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        void etherealize(byte[] oid,
               POA adapter,
               Servant serv,
               boolean cleanup_in_progress,
               boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        参数：
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

A/celSreSrottrooo/ kllb"kc>ooc ta


ServantActivatorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ServantActivatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantActivatorPOA
  • 所有已实现的接口：
    InvokeHandler, ServantActivatorOperations, ServantManagerOperations

    public abstract class ServantActivatorPOA
extends Servant
implements ServantActivatorOperations, InvokeHandler
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantActivatorPOA()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantActivator _this()
      ServantActivator | _this(ORB orb)

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

    • 构造方法详细信息

      • ServantActivatorPOA

        public ServantActivatorPOA()

    • 方法详细信息

      • _invoke

        public OutputStream _invoke(String $method,
                   InputStream in,
                   ResponseHandler $rh)
        从接口复制的描述： InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        指定者：
        _invoke in interface InvokeHandler
        参数：
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        指定者：
        _all_interfaces in class Servant
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.

      • _this

        public ServantActivator _this()

      • _this

        public ServantActivator _this(ORB orb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

peu/ed._dreffreet """mittgea(c)ff-e-/f"n


_ServantActivatorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 _ServantActivatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantActivatorStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, ServantActivator, ServantActivatorOperations, ServantManager, ServantManagerOperations

    public class _ServantActivatorStub
extends ObjectImpl
implements ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _ServantActivatorStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _ServantActivatorStub

        public _ServantActivatorStub()

    • 方法详细信息

      • incarnate

        public Servant incarnate(byte[] oid,
                POA adapter)
                  throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        指定者：
        incarnate in interface ServantActivatorOperations
        参数：
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        返回：
        Servant corresponding to oid is created or located by the user supplied servant manager.
        抛出：
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        public void etherealize(byte[] oid,
               POA adapter,
               Servant serv,
               boolean cleanup_in_progress,
               boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        指定者：
        etherealize in interface ServantActivatorOperations
        参数：
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dr; t s } {sel yys ase_nl"sasI""o_bi cyme


ServantLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantLocator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantLocatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantLocatorStub

    public interface ServantLocator
extends ServantLocatorOperations, ServantManager, IDLEntity
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p"eAevervevrrevvlg..M>htothA


ServantLocatorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ServantLocatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorHelper

  • public abstract class ServantLocatorHelper
extends Object
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantLocatorHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServantLocator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantLocator that)
      static ServantLocator | narrow(Object obj)
      static ServantLocator | read(InputStream istream)
      static TypeCode | type()
      static ServantLocator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantLocator value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServantLocatorHelper

        public ServantLocatorHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServantLocator that)

      • extract

        public static ServantLocator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantLocator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServantLocator value)

      • narrow

        public static ServantLocator narrow(Object obj)

      • unchecked_narrow

        public static ServantLocator unchecked_narrow(Object obj)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>aU.o.A.taootaaA/ffmkh�.yy�/>a <


ServantLocatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface ServantLocatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantLocator
    All Known Implementing Classes:
    _ServantLocatorStub, ServantLocatorPOA

    public interface ServantLocatorOperations
extends ServantManagerOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

    • 方法详细信息

      • preinvoke

        Servant preinvoke(byte[] oid,
                POA adapter,
                String operation,
                CookieHolder the_cookie)
                  throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        参数：
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        返回：
        Servant used to process incoming request.
        抛出：
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        void postinvoke(byte[] oid,
              POA adapter,
              String operation,
              Object the_cookie,
              Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        参数：
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f=atm"tl"tc..tcc/m//.oe n.eoSSelt.


ServantLocatorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ServantLocatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantLocatorPOA
  • 所有已实现的接口：
    InvokeHandler, ServantLocatorOperations, ServantManagerOperations

    public abstract class ServantLocatorPOA
extends Servant
implements ServantLocatorOperations, InvokeHandler
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantLocatorPOA()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantLocator _this()
      ServantLocator | _this(ORB orb)

      • 方法 - 继承于类 org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

    • 构造方法详细信息

      • ServantLocatorPOA

        public ServantLocatorPOA()

    • 方法详细信息

      • _invoke

        public OutputStream _invoke(String $method,
                   InputStream in,
                   ResponseHandler $rh)
        从接口复制的描述： InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        指定者：
        _invoke in interface InvokeHandler
        参数：
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        返回：
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                       byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        指定者：
        _all_interfaces in class Servant
        参数：
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        返回：
        list of type information for the object.

      • _this

        public ServantLocator _this()

      • _this

        public ServantLocator _this(ORB orb)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

it<_ehdefraafrr_ohhdAd ennfnhAe tt R ttd c


_ServantLocatorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 _ServantLocatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantLocatorStub
  • 所有已实现的接口：
    Serializable, Object, IDLEntity, ServantLocator, ServantLocatorOperations, ServantManager, ServantManagerOperations

    public class _ServantLocatorStub
extends ObjectImpl
implements ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static 类 | _opsClass

    • 构造方法摘要

      Constructors
      构造方法与描述
      _ServantLocatorStub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • 字段详细信息

      • _opsClass

        public static final 类 _opsClass

    • 构造方法详细信息

      • _ServantLocatorStub

        public _ServantLocatorStub()

    • 方法详细信息

      • preinvoke

        public Servant preinvoke(byte[] oid,
                POA adapter,
                String operation,
                CookieHolder the_cookie)
                  throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        指定者：
        preinvoke in interface ServantLocatorOperations
        参数：
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        返回：
        Servant used to process incoming request.
        抛出：
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        public void postinvoke(byte[] oid,
              POA adapter,
              String operation,
              Object the_cookie,
              Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        指定者：
        postinvoke in interface ServantLocatorOperations
        参数：
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        指定者：
        _ids in class ObjectImpl
        返回：
        the array of all repository identifiers supported by this ObjectImpl instance
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ipisis//苩l/tsib>rt�"t齮c黣fdO=t


ServantManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManager

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator, ServantLocator
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub

    public interface ServantManager
extends ServantManagerOperations, Object, IDLEntity
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.tralPblP/ooP//g.<


ServantManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManagerOperations

  • All Known Subinterfaces:
    ServantActivator, ServantActivatorOperations, ServantLocator, ServantLocatorOperations, ServantManager
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub, ServantActivatorPOA, ServantLocatorPOA

    public interface ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Lris susvss""=ss a pd<7>


ServantRetentionPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantRetentionPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ServantRetentionPolicyOperations

    public interface ServantRetentionPolicy
extends ServantRetentionPolicyOperations, Policy, IDLEntity
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.ServantRetentionPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fs"cL kL"abb"lcdo eheCj_<


ServantRetentionPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface ServantRetentionPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ServantRetentionPolicy

    public interface ServantRetentionPolicyOperations
extends PolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ServantRetentionPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        ServantRetentionPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s>sa a aaa llassl ddal>la !vtum


ServantRetentionPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ServantRetentionPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ServantRetentionPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class ServantRetentionPolicyValue
extends Object
implements IDLEntity
    ServantRetentionPolicyValue can have the following values. RETAIN - to indicate that the POA will retain active servants in its Active Object Map. NON_RETAIN - to indicate Servants are not retained by the POA. If no ServantRetentionPolicy is specified at POA creation, the default is RETAIN.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _NON_RETAIN
      static int | _RETAIN
      static ServantRetentionPolicyValue | NON_RETAIN
      static ServantRetentionPolicyValue | RETAIN

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ServantRetentionPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServantRetentionPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _RETAIN

        public static final int _RETAIN
        另请参见：
        Constant Field Values

      • RETAIN

        public static final ServantRetentionPolicyValue RETAIN

      • _NON_RETAIN

        public static final int _NON_RETAIN
        另请参见：
        Constant Field Values

      • NON_RETAIN

        public static final ServantRetentionPolicyValue NON_RETAIN

    • 构造方法详细信息

      • ServantRetentionPolicyValue

        protected ServantRetentionPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static ServantRetentionPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p


THREAD_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface THREAD_POLICY_ID

  • public interface THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:14 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int value
      The value representing THREAD_POLICY_ID.

    • 字段详细信息

      • value

        static final int value
        The value representing THREAD_POLICY_ID.
        另请参见：
        Constant Field Values
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a


ThreadPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.PortableServer

Interface ThreadPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ThreadPolicyOperations

    public interface ThreadPolicy
extends ThreadPolicyOperations, Policy, IDLEntity
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.PortableServer.ThreadPolicyOperations

        value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kLkl


ThreadPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer

Interface ThreadPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ThreadPolicy

    public interface ThreadPolicyOperations
extends PolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ThreadPolicyValue value()
      specifies the policy value

      • 方法 - 继承于接口 org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • 方法详细信息

      • value

        ThreadPolicyValue value()
        specifies the policy value
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nvksls sisaeLinsLlooie ssCaapng


ThreadPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer

类 ThreadPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ThreadPolicyValue
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class ThreadPolicyValue
extends Object
implements IDLEntity
    The ThreadPolicyValue can have the following values. ORB_CTRL_MODEL - The ORB is responsible for assigning requests for an ORB- controlled POA to threads. SINGLE_THREAD_MODEL - Requests for a single-threaded POA are processed sequentially.

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _ORB_CTRL_MODEL
      static int | _SINGLE_THREAD_MODEL
      static ThreadPolicyValue | ORB_CTRL_MODEL
      static ThreadPolicyValue | SINGLE_THREAD_MODEL

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | ThreadPolicyValue(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ThreadPolicyValue | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _ORB_CTRL_MODEL

        public static final int _ORB_CTRL_MODEL
        另请参见：
        Constant Field Values

      • ORB_CTRL_MODEL

        public static final ThreadPolicyValue ORB_CTRL_MODEL

      • _SINGLE_THREAD_MODEL

        public static final int _SINGLE_THREAD_MODEL
        另请参见：
        Constant Field Values

      • SINGLE_THREAD_MODEL

        public static final ThreadPolicyValue SINGLE_THREAD_MODEL

    • 构造方法详细信息

      • ThreadPolicyValue

        protected ThreadPolicyValue(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static ThreadPolicyValue from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e> . h ruthir<">faS fftphbufhho:


Uses of Package org.omg.PortableServer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer

  • Packages that use org.omg.PortableServer
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer used by org.omg.CosNaming
    类与描述
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer
    类与描述
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer.portable
    类与描述
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

apbg/./"=...rv..ebrralne


Uses of Class org.omg.PortableServer._ServantActivatorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer._ServantActivatorStub

No usage of org.omg.PortableServer._ServantActivatorStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eatefS"oehE=aLVRr�=f


Uses of Class org.omg.PortableServer._ServantLocatorStub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer._ServantLocatorStub

No usage of org.omg.PortableServer._ServantLocatorStub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<.my


Uses of Class org.omg.PortableServer.CurrentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.CurrentHelper

No usage of org.omg.PortableServer.CurrentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

."hrer/Seeeeao..tlrn/


Uses of Class org.omg.PortableServer.DynamicImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.DynamicImplementation

No usage of org.omg.PortableServer.DynamicImplementation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iutnlasu


Uses of Class org.omg.PortableServer.ForwardRequest

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ForwardRequest

  • Packages that use ForwardRequest
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ForwardRequest in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ForwardRequest
      修饰符与类型 | 方法与描述
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type ForwardRequest
      修饰符与类型 | 方法与描述
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableServer that throw ForwardRequest
      修饰符与类型 方法与描述
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

y. A< shdox/cd<


Uses of Class org.omg.PortableServer.ForwardRequestHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ForwardRequestHelper

No usage of org.omg.PortableServer.ForwardRequestHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/l/..//..... ee"cls>


Uses of Class org.omg.PortableServer.IdAssignmentPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.IdAssignmentPolicyValue

  • Packages that use IdAssignmentPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdAssignmentPolicyValue
      修饰符与类型 | 字段与描述
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.SYSTEM_ID
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.USER_ID
      Methods in org.omg.PortableServer that return IdAssignmentPolicyValue
      修饰符与类型 | 方法与描述
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.from_int(int value)
      IdAssignmentPolicyValue IdAssignmentPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdAssignmentPolicyValue
      修饰符与类型 方法与描述
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t"rn="g=t&= 塱../t">t (


Uses of Class org.omg.PortableServer.IdUniquenessPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.IdUniquenessPolicyValue

  • Packages that use IdUniquenessPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdUniquenessPolicyValue
      修饰符与类型 | 字段与描述
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.MULTIPLE_ID
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.UNIQUE_ID
      Methods in org.omg.PortableServer that return IdUniquenessPolicyValue
      修饰符与类型 | 方法与描述
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.from_int(int value)
      IdUniquenessPolicyValue IdUniquenessPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdUniquenessPolicyValue
      修饰符与类型 方法与描述
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r//Sr/纄(r9e爖 a lx


Uses of Class org.omg.PortableServer.ImplicitActivationPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ImplicitActivationPolicyValue

  • Packages that use ImplicitActivationPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ImplicitActivationPolicyValue
      修饰符与类型 | 字段与描述
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION
      Methods in org.omg.PortableServer that return ImplicitActivationPolicyValue
      修饰符与类型 | 方法与描述
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.from_int(int value)
      ImplicitActivationPolicyValue ImplicitActivationPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ImplicitActivationPolicyValue
      修饰符与类型 方法与描述
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e t"ef0i"e>seonaa>o胐Sbt


Uses of Class org.omg.PortableServer.LifespanPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.LifespanPolicyValue

  • Packages that use LifespanPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as LifespanPolicyValue
      修饰符与类型 | 字段与描述
      static LifespanPolicyValue | LifespanPolicyValue.PERSISTENT
      static LifespanPolicyValue | LifespanPolicyValue.TRANSIENT
      Methods in org.omg.PortableServer that return LifespanPolicyValue
      修饰符与类型 | 方法与描述
      static LifespanPolicyValue | LifespanPolicyValue.from_int(int value)
      LifespanPolicyValue LifespanPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type LifespanPolicyValue
      修饰符与类型 方法与描述
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

doicnnud "nrh栽l�>IrgiiB


Uses of Class org.omg.PortableServer.POAHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAHelper

No usage of org.omg.PortableServer.POAHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bll.es(refffimeetchnx


Uses of Class org.omg.PortableServer.RequestProcessingPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.RequestProcessingPolicyValue

  • Packages that use RequestProcessingPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as RequestProcessingPolicyValue
      修饰符与类型 | 字段与描述
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_SERVANT_MANAGER
      Methods in org.omg.PortableServer that return RequestProcessingPolicyValue
      修饰符与类型 | 方法与描述
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.from_int(int value)
      RequestProcessingPolicyValue RequestProcessingPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type RequestProcessingPolicyValue
      修饰符与类型 方法与描述
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/el-Xpmu/"Fka;sorOar [


Uses of Class org.omg.PortableServer.Servant

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.Servant

  • Packages that use Servant
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Servant in org.omg.CosNaming

      Subclasses of Servant in org.omg.CosNaming
      修饰符与类型 类与描述
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of Servant in org.omg.PortableServer

      Subclasses of Servant in org.omg.PortableServer
      修饰符与类型 类与描述
      class  DynamicImplementation
      Allows dynamic handling of object invocations.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return Servant
      修饰符与类型 方法与描述
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Methods in org.omg.PortableServer with parameters of type Servant
      修饰符与类型 方法与描述
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of Servant in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable with parameters of type Servant
      修饰符与类型 方法与描述
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object Delegate.get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean Delegate.is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean Delegate.non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] Delegate.object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB Delegate.orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object Delegate.this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/e >>g紀�


Uses of Class org.omg.PortableServer.ServantActivatorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantActivatorHelper

No usage of org.omg.PortableServer.ServantActivatorHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nh>rtivnattteemmo.ve.


Uses of Class org.omg.PortableServer.ServantActivatorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantActivatorPOA

No usage of org.omg.PortableServer.ServantActivatorPOA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ritohtmamrrrspttnn


Uses of Class org.omg.PortableServer.ServantLocatorHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantLocatorHelper

No usage of org.omg.PortableServer.ServantLocatorHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aosn>


Uses of Class org.omg.PortableServer.ServantLocatorPOA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantLocatorPOA

No usage of org.omg.PortableServer.ServantLocatorPOA
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Stegorgmtlllyeee"ao


Uses of Class org.omg.PortableServer.ServantRetentionPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantRetentionPolicyValue

  • Packages that use ServantRetentionPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ServantRetentionPolicyValue
      修饰符与类型 | 字段与描述
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.NON_RETAIN
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.RETAIN
      Methods in org.omg.PortableServer that return ServantRetentionPolicyValue
      修饰符与类型 | 方法与描述
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.from_int(int value)
      ServantRetentionPolicyValue ServantRetentionPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ServantRetentionPolicyValue
      修饰符与类型 方法与描述
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1o


Uses of Class org.omg.PortableServer.ThreadPolicyValue

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ThreadPolicyValue

  • Packages that use ThreadPolicyValue
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ThreadPolicyValue
      修饰符与类型 | 字段与描述
      static ThreadPolicyValue | ThreadPolicyValue.ORB_CTRL_MODEL
      static ThreadPolicyValue | ThreadPolicyValue.SINGLE_THREAD_MODEL
      Methods in org.omg.PortableServer that return ThreadPolicyValue
      修饰符与类型 | 方法与描述
      static ThreadPolicyValue | ThreadPolicyValue.from_int(int value)
      ThreadPolicyValue ThreadPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ThreadPolicyValue
      修饰符与类型 方法与描述
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.omg.PortableServer.AdapterActivator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.AdapterActivator

  • Packages that use AdapterActivator
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivator in org.omg.PortableServer

      Methods in org.omg.PortableServer that return AdapterActivator
      修饰符与类型 方法与描述
      AdapterActivator POAOperations.the_activator()
      This attribute identifies the adapter activator associated with the POA.
      Methods in org.omg.PortableServer with parameters of type AdapterActivator
      修饰符与类型 方法与描述
      void POAOperations.the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=ts&lf=lt


Uses of Interface org.omg.PortableServer.AdapterActivatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.AdapterActivatorOperations

  • Packages that use AdapterActivatorOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivatorOperations in org.omg.PortableServer

      Subinterfaces of AdapterActivatorOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

laa(tIlIy(ac(muu jpxssxe


Uses of Interface org.omg.PortableServer.Current

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.Current

  • Packages that use Current
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Current in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Current
      修饰符与类型 | 方法与描述
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type Current
      修饰符与类型 | 方法与描述
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gex..rs"=c<=i=>vj>/ os"


Uses of Interface org.omg.PortableServer.CurrentOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.CurrentOperations

  • Packages that use CurrentOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CurrentOperations in org.omg.PortableServer

      Subinterfaces of CurrentOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  Current
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pnt"Ae iCtC"


Uses of Interface org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID

No usage of org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lleo./o./.../h>>sLsn>


Uses of Interface org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID

No usage of org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

of 纍x/� >ph↙#


Uses of Interface org.omg.PortableServer.IdAssignmentPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicy

  • Packages that use IdAssignmentPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdAssignmentPolicy
      修饰符与类型 方法与描述
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ng" ;ceabeacnn"gbFaoiet


Uses of Interface org.omg.PortableServer.IdAssignmentPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicyOperations

  • Packages that use IdAssignmentPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdAssignmentPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

衋<鎚>�>"妯觓x�>a9x 22 n


Uses of Interface org.omg.PortableServer.IdUniquenessPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicy

  • Packages that use IdUniquenessPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdUniquenessPolicy
      修饰符与类型 方法与描述
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oAldtd>ed>>>/issPnelt aic


Uses of Interface org.omg.PortableServer.IdUniquenessPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicyOperations

  • Packages that use IdUniquenessPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdUniquenessPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

8&渔�/栓�<>x;/ox0;, ,r


Uses of Interface org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID

No usage of org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

otniImpnogggs lllevil


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicy

  • Packages that use ImplicitActivationPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ImplicitActivationPolicy
      修饰符与类型 方法与描述
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pesrral_f=mhsrrgsn>fpw


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicyOperations

  • Packages that use ImplicitActivationPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyOperations in org.omg.PortableServer

      Subinterfaces of ImplicitActivationPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bArp asaxpe< rs2 .r.//.1


Uses of Interface org.omg.PortableServer.LIFESPAN_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.LIFESPAN_POLICY_ID

No usage of org.omg.PortableServer.LIFESPAN_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

en.Pfesre///eo..enca.


Uses of Interface org.omg.PortableServer.LifespanPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.LifespanPolicy

  • Packages that use LifespanPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return LifespanPolicy
      修饰符与类型 方法与描述
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rspsrnd<


Uses of Interface org.omg.PortableServer.LifespanPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.LifespanPolicyOperations

  • Packages that use LifespanPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyOperations in org.omg.PortableServer

      Subinterfaces of LifespanPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

鎛萾p.".rtl八/"n薬/x11x�


Uses of Interface org.omg.PortableServer.POA

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.POA

  • Packages that use POA
    软件包 描述
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POA in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type POA
      修饰符与类型 | 方法与描述
      String[] | NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | NamingContextPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)

    • Uses of POA in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POA
      修饰符与类型 | 方法与描述
      POA Servant._default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      POA Servant._poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      static POA | POAHelper.extract(Any a)
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.
      static POA | POAHelper.narrow(Object obj)
      static POA | POAHelper.read(InputStream istream)
      POA[] POAOperations.the_children()
      This attribute identifies the current set of all child POAs of the POA.
      POA POAOperations.the_parent()
      This attribute identifies the parent of the POA.
      Methods in org.omg.PortableServer with parameters of type POA
      修饰符与类型 | 方法与描述
      String[] | ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)
      abstract String[] Servant._all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      static void | POAHelper.insert(Any a, POA that)
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      boolean AdapterActivatorOperations.unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.
      static void | POAHelper.write(OutputStream ostream, POA value)

    • Uses of POA in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return POA
      修饰符与类型 方法与描述
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ingieb/alt.taa.ut"l�


Uses of Interface org.omg.PortableServer.POAManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.POAManager

  • Packages that use POAManager
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManager in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POAManager
      修饰符与类型 方法与描述
      POAManager POAOperations.the_POAManager()
      This attribute identifies the POA manager associated with the POA.
      Methods in org.omg.PortableServer with parameters of type POAManager
      修饰符与类型 方法与描述
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d>"g=a


Uses of Interface org.omg.PortableServer.POAManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.POAManagerOperations

  • Packages that use POAManagerOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManagerOperations in org.omg.PortableServer

      Subinterfaces of POAManagerOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  POAManager
      Each POA object has an associated POAManager object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gv>/b8r83///bnssv


Uses of Interface org.omg.PortableServer.POAOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.POAOperations

  • Packages that use POAOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAOperations in org.omg.PortableServer

      Subinterfaces of POAOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  POA
      A POA object manages the implementation of a collection of objects.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fＣ傲崃涿槐Ｓ�>ｔ槐行眘


Uses of Interface org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID

No usage of org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cueRron=s"""l>ssebs>s


Uses of Interface org.omg.PortableServer.RequestProcessingPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicy

  • Packages that use RequestProcessingPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return RequestProcessingPolicy
      修饰符与类型 方法与描述
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1 llsi韆bbal l/t-lcfh� ee


Uses of Interface org.omg.PortableServer.RequestProcessingPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicyOperations

  • Packages that use RequestProcessingPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyOperations in org.omg.PortableServer

      Subinterfaces of RequestProcessingPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r/kan, ,sadond 猩蔮b舒


Uses of Interface org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID

No usage of org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a& >>


Uses of Interface org.omg.PortableServer.ServantActivator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantActivator

  • Packages that use ServantActivator
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantActivator
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Methods in org.omg.PortableServer that return ServantActivator
      修饰符与类型 | 方法与描述
      ServantActivator | ServantActivatorPOA._this()
      ServantActivator | ServantActivatorPOA._this(ORB orb)
      static ServantActivator | ServantActivatorHelper.extract(Any a)
      static ServantActivator | ServantActivatorHelper.narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.read(InputStream istream)
      static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantActivator
      修饰符与类型 | 方法与描述
      static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
      static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etf , ;pooon(//rPa lrlm o


Uses of Interface org.omg.PortableServer.ServantActivatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantActivatorOperations

  • Packages that use ServantActivatorOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivatorOperations in org.omg.PortableServer

      Subinterfaces of ServantActivatorOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Classes in org.omg.PortableServer that implement ServantActivatorOperations
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"trjimtlrnr<.p/ge/mtg.癲


Uses of Interface org.omg.PortableServer.ServantLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantLocator

  • Packages that use ServantLocator
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantLocator
      修饰符与类型 类与描述
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantLocator
      修饰符与类型 | 方法与描述
      ServantLocator | ServantLocatorPOA._this()
      ServantLocator | ServantLocatorPOA._this(ORB orb)
      static ServantLocator | ServantLocatorHelper.extract(Any a)
      static ServantLocator | ServantLocatorHelper.narrow(Object obj)
      static ServantLocator | ServantLocatorHelper.read(InputStream istream)
      static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantLocator
      修饰符与类型 | 方法与描述
      static void | ServantLocatorHelper.insert(Any a, ServantLocator that)
      static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nL<篇設>.Ot/h眂 .xf


Uses of Interface org.omg.PortableServer.ServantLocatorOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantLocatorOperations

  • Packages that use ServantLocatorOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocatorOperations in org.omg.PortableServer

      Subinterfaces of ServantLocatorOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantLocatorOperations
      修饰符与类型 类与描述
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ie." zstnttPlrw� ar >n


Uses of Interface org.omg.PortableServer.ServantManager

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantManager

  • Packages that use ServantManager
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManager in org.omg.PortableServer

      Subinterfaces of ServantManager in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantManager
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantManager
      修饰符与类型 方法与描述
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Methods in org.omg.PortableServer with parameters of type ServantManager
      修饰符与类型 方法与描述
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>>lshe(b<.<>ebcl3rat�


Uses of Interface org.omg.PortableServer.ServantManagerOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantManagerOperations

  • Packages that use ServantManagerOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManagerOperations in org.omg.PortableServer

      Subinterfaces of ServantManagerOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantActivatorOperations
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantLocatorOperations
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      Classes in org.omg.PortableServer that implement ServantManagerOperations
      修饰符与类型 类与描述
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rr<<溃o！lgI


Uses of Interface org.omg.PortableServer.ServantRetentionPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicy

  • Packages that use ServantRetentionPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ServantRetentionPolicy
      修饰符与类型 方法与描述
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o mse="t iiimreeac td=>lt


Uses of Interface org.omg.PortableServer.ServantRetentionPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicyOperations

  • Packages that use ServantRetentionPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyOperations in org.omg.PortableServer

      Subinterfaces of ServantRetentionPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f =<<>h>r< e./hl.///aa/,


Uses of Interface org.omg.PortableServer.THREAD_POLICY_ID

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.THREAD_POLICY_ID

No usage of org.omg.PortableServer.THREAD_POLICY_ID
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ee_hValloiiiav//yasl/


Uses of Interface org.omg.PortableServer.ThreadPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ThreadPolicy

  • Packages that use ThreadPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ThreadPolicy
      修饰符与类型 方法与描述
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ap = tils.pxndaoa


Uses of Interface org.omg.PortableServer.ThreadPolicyOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.ThreadPolicyOperations

  • Packages that use ThreadPolicyOperations
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyOperations in org.omg.PortableServer

      Subinterfaces of ThreadPolicyOperations in org.omg.PortableServer
      修饰符与类型 Interface and Description
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mRlpg/./lprt>�. >&薬00a�


NoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.CurrentPackage

类 NoContext

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.CurrentPackage.NoContext
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NoContext
extends UserException
    org/omg/PortableServer/CurrentPackage/NoContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoContext()
      NoContext(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoContext

        public NoContext()

      • NoContext

        public NoContext(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fo/hne;. NMhs


NoContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.CurrentPackage

类 NoContextHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper

  • public abstract class NoContextHelper
extends Object
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoContextHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NoContext | extract(Any a)
      static String | id()
      static void | insert(Any a, NoContext that)
      static NoContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoContext value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NoContextHelper

        public NoContextHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NoContext that)

      • extract

        public static NoContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NoContext value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iefto"


org.omg.PortableServer.CurrentPackage

Classes

  • NoContextHelper

Exceptions

  • NoContext


org.omg.PortableServer.CurrentPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer.CurrentPackage

Provides method implementations with access to the identity of the object on which the method was invoked.

请参见： 描述

  • Class Summary
    类 描述
    NoContextHelper
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java .
  • Exception Summary
    Exception 描述
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .

软件包 org.omg.PortableServer.CurrentPackage Description

Provides method implementations with access to the identity of the object on which the method was invoked. The Current package supports servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g/rCg.i./"=..."


org.omg.PortableServer.CurrentPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer.CurrentPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.CurrentPackage.NoContext
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cvl did>>><>//;trtae


Uses of Package org.omg.PortableServer.CurrentPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer.CurrentPackage

  • Packages that use org.omg.PortableServer.CurrentPackage
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer
    类与描述
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer.CurrentPackage
    类与描述
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

)=unno-


Uses of Class org.omg.PortableServer.CurrentPackage.NoContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContext

  • Packages that use NoContext
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.

    • Uses of NoContext in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoContext
      修饰符与类型 方法与描述
      byte[] CurrentOperations.get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • Uses of NoContext in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage that return NoContext
      修饰符与类型 | 方法与描述
      static NoContext | NoContextHelper.extract(Any a)
      static NoContext | NoContextHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.CurrentPackage with parameters of type NoContext
      修饰符与类型 | 方法与描述
      static void | NoContextHelper.insert(Any a, NoContext that)
      static void | NoContextHelper.write(OutputStream ostream, NoContext value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ i.lwegk


Uses of Class org.omg.PortableServer.CurrentPackage.NoContextHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContextHelper

No usage of org.omg.PortableServer.CurrentPackage.NoContextHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

toe .ht/rPPPrr..l= "/


AdapterInactive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAManagerPackage

类 AdapterInactive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class AdapterInactive
extends UserException
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterInactive()
      AdapterInactive(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AdapterInactive

        public AdapterInactive()

      • AdapterInactive

        public AdapterInactive(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e"C/Let<.<籺eee


AdapterInactiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAManagerPackage

类 AdapterInactiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

  • public abstract class AdapterInactiveHelper
extends Object
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterInactiveHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static AdapterInactive | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterInactive that)
      static AdapterInactive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterInactive value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterInactiveHelper

        public AdapterInactiveHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          AdapterInactive that)

      • extract

        public static AdapterInactive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterInactive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         AdapterInactive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

1>)k&>"ni=taheicao>a//繰R> x/


org.omg.PortableServer.POAManagerPackage

Classes

  • AdapterInactiveHelper
  • State

Exceptions

  • AdapterInactive
�


org.omg.PortableServer.POAManagerPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer.POAManagerPackage

Encapsulates the processing state of the POAs it is associated with.

请参见： 描述

  • Class Summary
    类 描述
    AdapterInactiveHelper
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
    State
    Specifies the states for the POAManager
  • Exception Summary
    Exception 描述
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

软件包 org.omg.PortableServer.POAManagerPackage Description

Encapsulates the processing state of the POAs it is associated with. Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>da/>TBypBRAyyB.ccRtoCmg//l


org.omg.PortableServer.POAManagerPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer.POAManagerPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/{=(tdnw=pwibbjtslav


State

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAManagerPackage

类 State

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.State
  • 所有已实现的接口：
    Serializable, IDLEntity

    public class State
extends Object
implements IDLEntity
    Specifies the states for the POAManager

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      static int | _ACTIVE
      static int | _DISCARDING
      static int | _HOLDING
      static int | _INACTIVE
      static State | ACTIVE
      static State | DISCARDING
      static State | HOLDING
      static State | INACTIVE

    • 构造方法摘要

      Constructors
      修饰符 | 构造方法与描述
      protected | State(int value)

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static State | from_int(int value)
      int | value()

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • _HOLDING

        public static final int _HOLDING
        另请参见：
        Constant Field Values

      • HOLDING

        public static final State HOLDING

      • _ACTIVE

        public static final int _ACTIVE
        另请参见：
        Constant Field Values

      • ACTIVE

        public static final State ACTIVE

      • _DISCARDING

        public static final int _DISCARDING
        另请参见：
        Constant Field Values

      • DISCARDING

        public static final State DISCARDING

      • _INACTIVE

        public static final int _INACTIVE
        另请参见：
        Constant Field Values

      • INACTIVE

        public static final State INACTIVE

    • 构造方法详细信息

      • State

        protected State(int value)

    • 方法详细信息

      • value

        public int value()

      • from_int

        public static State from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.eDoilenp;s gt"b .hnnteam闰elt>yae>


Uses of Package org.omg.PortableServer.POAManagerPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer.POAManagerPackage

  • Packages that use org.omg.PortableServer.POAManagerPackage
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer
    类与描述
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer.POAManagerPackage
    类与描述
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"d Pcgsr"metl= T"s/<


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactive

  • Packages that use AdapterInactive
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of AdapterInactive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterInactive
      修饰符与类型 方法与描述
      void POAManagerOperations.activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void POAManagerOperations.deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void POAManagerOperations.discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      void POAManagerOperations.hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • Uses of AdapterInactive in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage that return AdapterInactive
      修饰符与类型 | 方法与描述
      static AdapterInactive | AdapterInactiveHelper.extract(Any a)
      static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type AdapterInactive
      修饰符与类型 | 方法与描述
      static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)
      static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a>psl=al


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

No usage of org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aes"olLss===ctoo/i


Uses of Class org.omg.PortableServer.POAManagerPackage.State

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAManagerPackage.State

  • Packages that use State
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of State in org.omg.PortableServer

      Methods in org.omg.PortableServer that return State
      修饰符与类型 方法与描述
      State POAManagerOperations.get_state()
      This operation returns the state of the POA manager.

    • Uses of State in org.omg.PortableServer.POAManagerPackage

      Fields in org.omg.PortableServer.POAManagerPackage declared as State
      修饰符与类型 | 字段与描述
      static State | State.ACTIVE
      static State | State.DISCARDING
      static State | State.HOLDING
      static State | State.INACTIVE
      Methods in org.omg.PortableServer.POAManagerPackage that return State
      修饰符与类型 | 方法与描述
      static State | State.from_int(int value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>oalim >>>f>o"cia =sv/d


AdapterAlreadyExists

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 AdapterAlreadyExists

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class AdapterAlreadyExists
extends UserException
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterAlreadyExists()
      AdapterAlreadyExists(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AdapterAlreadyExists

        public AdapterAlreadyExists()

      • AdapterAlreadyExists

        public AdapterAlreadyExists(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

&laa> i�/e


AdapterAlreadyExistsHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 AdapterAlreadyExistsHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

  • public abstract class AdapterAlreadyExistsHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterAlreadyExistsHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static AdapterAlreadyExists | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterAlreadyExists that)
      static AdapterAlreadyExists | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterAlreadyExists value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterAlreadyExistsHelper

        public AdapterAlreadyExistsHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          AdapterAlreadyExists that)

      • extract

        public static AdapterAlreadyExists extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterAlreadyExists read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         AdapterAlreadyExists value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

stm"lcrsbe n_a>a ah1/ii a � /y�


AdapterNonExistent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 AdapterNonExistent

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class AdapterNonExistent
extends UserException
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterNonExistent()
      AdapterNonExistent(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • AdapterNonExistent

        public AdapterNonExistent()

      • AdapterNonExistent

        public AdapterNonExistent(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f/=ibpispioddioobs<<-!>-u<<>l= l> >


AdapterNonExistentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 AdapterNonExistentHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

  • public abstract class AdapterNonExistentHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      AdapterNonExistentHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static AdapterNonExistent | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterNonExistent that)
      static AdapterNonExistent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterNonExistent value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AdapterNonExistentHelper

        public AdapterNonExistentHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          AdapterNonExistent that)

      • extract

        public static AdapterNonExistent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterNonExistent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         AdapterNonExistent value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l泪玲/岜醓�/保巳Ａy�n


InvalidPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 InvalidPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.InvalidPolicy
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class InvalidPolicy
extends UserException
    org/omg/PortableServer/POAPackage/InvalidPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short | index

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidPolicy()
      InvalidPolicy(short _index)
      InvalidPolicy(String $reason, short _index)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • index

        public short index

    • 构造方法详细信息

      • InvalidPolicy

        public InvalidPolicy()

      • InvalidPolicy

        public InvalidPolicy(short _index)

      • InvalidPolicy

        public InvalidPolicy(String $reason,
             short _index)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

O/ArbrtrPree.reee.ss..h..oo./."e.f..P=g


InvalidPolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 InvalidPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper

  • public abstract class InvalidPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      InvalidPolicyHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static InvalidPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidPolicy that)
      static InvalidPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidPolicy value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InvalidPolicyHelper

        public InvalidPolicyHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          InvalidPolicy that)

      • extract

        public static InvalidPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         InvalidPolicy value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9wtstvt,t rsa ro,wy拾�.秔ā购油适魃/


NoServant

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 NoServant

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.NoServant
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class NoServant
extends UserException
    org/omg/PortableServer/POAPackage/NoServant.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoServant()
      NoServant(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • NoServant

        public NoServant()

      • NoServant

        public NoServant(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/.OAgCg/Cgr//grr/.ttissib""slto 4ob


NoServantHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 NoServantHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.NoServantHelper

  • public abstract class NoServantHelper
extends Object
    org/omg/PortableServer/POAPackage/NoServantHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      NoServantHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static NoServant | extract(Any a)
      static String | id()
      static void | insert(Any a, NoServant that)
      static NoServant | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoServant value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • NoServantHelper

        public NoServantHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          NoServant that)

      • extract

        public static NoServant extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoServant read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         NoServant value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

prye/eteoela/ca.lbg�/sc嫠�#


ObjectAlreadyActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 ObjectAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ObjectAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectAlreadyActive()
      ObjectAlreadyActive(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ObjectAlreadyActive

        public ObjectAlreadyActive()

      • ObjectAlreadyActive

        public ObjectAlreadyActive(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n_a>oNbmNb"oob""l>AA=<==NEE=DA = R


ObjectAlreadyActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 ObjectAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

  • public abstract class ObjectAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectAlreadyActiveHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ObjectAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectAlreadyActive that)
      static ObjectAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectAlreadyActive value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectAlreadyActiveHelper

        public ObjectAlreadyActiveHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ObjectAlreadyActive that)

      • extract

        public static ObjectAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ObjectAlreadyActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

FFl/s- -e-e3teoAlo na>e>b /rf


ObjectNotActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 ObjectNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectNotActive
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ObjectNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectNotActive()
      ObjectNotActive(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ObjectNotActive

        public ObjectNotActive()

      • ObjectNotActive

        public ObjectNotActive(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

p u/wi


ObjectNotActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 ObjectNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

  • public abstract class ObjectNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ObjectNotActiveHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ObjectNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectNotActive that)
      static ObjectNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectNotActive value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ObjectNotActiveHelper

        public ObjectNotActiveHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ObjectNotActive that)

      • extract

        public static ObjectNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ObjectNotActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.n....u././a./.lr.la.rOyhl�"鵰m>ㄋ


org.omg.PortableServer.POAPackage

Classes

  • AdapterAlreadyExistsHelper
  • AdapterNonExistentHelper
  • InvalidPolicyHelper
  • NoServantHelper
  • ObjectAlreadyActiveHelper
  • ObjectNotActiveHelper
  • ServantAlreadyActiveHelper
  • ServantNotActiveHelper
  • WrongAdapterHelper
  • WrongPolicyHelper

Exceptions

  • AdapterAlreadyExists
  • AdapterNonExistent
  • InvalidPolicy
  • NoServant
  • ObjectAlreadyActive
  • ObjectNotActive
  • ServantAlreadyActive
  • ServantNotActive
  • WrongAdapter
  • WrongPolicy
<


org.omg.PortableServer.POAPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer.POAPackage

Allows programmers to construct object implementations that are portable between different ORB products.

请参见： 描述

  • Class Summary
    类 描述
    AdapterAlreadyExistsHelper
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
    AdapterNonExistentHelper
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
    InvalidPolicyHelper
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
    NoServantHelper
    org/omg/PortableServer/POAPackage/NoServantHelper.java .
    ObjectAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java .
    ObjectNotActiveHelper
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java .
    ServantAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java .
    ServantNotActiveHelper
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java .
    WrongAdapterHelper
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java .
    WrongPolicyHelper
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java .
  • Exception Summary
    Exception 描述
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .

软件包 org.omg.PortableServer.POAPackage Description

Allows programmers to construct object implementations that are portable between different ORB products.

The Portable Object Adaptor (POA) is designed to meet the following goals:

  • Allow programmers to construct object implementations that are portable between different ORB products.
  • Provide support for objects with persistent identities.
  • Provide support for transparent activation of objects.
  • Allow a single servant to support multiple object identities simultaneously.

Given an interface My defined in My.idl, the file MyPOA.java is generated by the idlj compiler. You must provide the implementation for My and it must inherit from MyPOA.

MyPOA.java is a stream-based skeleton that extends org.omg.PortableServer.Servant and implements the InvokeHandler interface and the operations interface associated with the IDL interface the skeleton implements.

The PortableServer module for the Portable Object Adapter (POA) defines the native Servant type. In the Java programming language, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

All Mapping corresponds to the Chapter 11 of CORBA V2.3.1 specified by OMG document formal/99-10-07.pdf. The exception to this is the id attribute, which is added in ptc/00-08-06, section 11.3.8.26.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uLsbulsvs"b i"buu╞si


org.omg.PortableServer.POAPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer.POAPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tt>h/,ld<<


ServantAlreadyActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 ServantAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ServantAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantAlreadyActive()
      ServantAlreadyActive(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ServantAlreadyActive

        public ServantAlreadyActive()

      • ServantAlreadyActive

        public ServantAlreadyActive(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>c


ServantAlreadyActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 ServantAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

  • public abstract class ServantAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantAlreadyActiveHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServantAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantAlreadyActive that)
      static ServantAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantAlreadyActive value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServantAlreadyActiveHelper

        public ServantAlreadyActiveHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServantAlreadyActive that)

      • extract

        public static ServantAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServantAlreadyActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"lVmnsns/dL郺1gahp�Cmincnoes


ServantNotActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 ServantNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantNotActive
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class ServantNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantNotActive()
      ServantNotActive(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • ServantNotActive

        public ServantNotActive()

      • ServantNotActive

        public ServantNotActive(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t e"cL"kL"=bb"==ctbbamrareer.kPeaP


ServantNotActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 ServantNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper

  • public abstract class ServantNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      ServantNotActiveHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static ServantNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantNotActive that)
      static ServantNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantNotActive value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ServantNotActiveHelper

        public ServantNotActiveHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          ServantNotActive that)

      • extract

        public static ServantNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         ServantNotActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hrrerc< rira hf..le�.�.///m.l..g1


Uses of Package org.omg.PortableServer.POAPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer.POAPackage

  • Packages that use org.omg.PortableServer.POAPackage
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer
    类与描述
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer.POAPackage
    类与描述
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ave/<a>eaS/.nh


WrongAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 WrongAdapter

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class WrongAdapter
extends UserException
    org/omg/PortableServer/POAPackage/WrongAdapter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongAdapter()
      WrongAdapter(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WrongAdapter

        public WrongAdapter()

      • WrongAdapter

        public WrongAdapter(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rmew&bvnbv;oov;;&c>> / >>/


WrongAdapterHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 WrongAdapterHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper

  • public abstract class WrongAdapterHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongAdapterHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static WrongAdapter | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongAdapter that)
      static WrongAdapter | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongAdapter value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WrongAdapterHelper

        public WrongAdapterHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          WrongAdapter that)

      • extract

        public static WrongAdapter extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongAdapter read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         WrongAdapter value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.s.h>heh"h el"....alpr.N.///ca.eelya


WrongPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.omg.PortableServer.POAPackage

类 WrongPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongPolicy
  • 所有已实现的接口：
    Serializable, IDLEntity

    public final class WrongPolicy
extends UserException
    org/omg/PortableServer/POAPackage/WrongPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongPolicy()
      WrongPolicy(String $reason)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • WrongPolicy

        public WrongPolicy()

      • WrongPolicy

        public WrongPolicy(String $reason)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l tbpaspa/>>a//rOAA.//.gmm//pCttCs


WrongPolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.POAPackage

类 WrongPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper

  • public abstract class WrongPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from ../../../../src/share/classes/org/omg/PortableServer/poa.idl Thursday, April 14, 2011 2:04:15 AM PDT

    • 构造方法摘要

      Constructors
      构造方法与描述
      WrongPolicyHelper()

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      static WrongPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongPolicy that)
      static WrongPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongPolicy value)

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • WrongPolicyHelper

        public WrongPolicyHelper()

    • 方法详细信息

      • insert

        public static void insert(Any a,
          WrongPolicy that)

      • extract

        public static WrongPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
         WrongPolicy value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsaoho"bnodreiticia阰/doi>Lxcrmghhra�


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExists

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExists

  • Packages that use AdapterAlreadyExists
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterAlreadyExists
      修饰符与类型 方法与描述
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterAlreadyExists
      修饰符与类型 | 方法与描述
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterAlreadyExists
      修饰符与类型 | 方法与描述
      static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
      static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xesa .e


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

No usage of org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rniain alsss=lggry


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistent

  • Packages that use AdapterNonExistent
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterNonExistent in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterNonExistent
      修饰符与类型 方法与描述
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.

    • Uses of AdapterNonExistent in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterNonExistent
      修饰符与类型 | 方法与描述
      static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
      static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterNonExistent
      修饰符与类型 | 方法与描述
      static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
      static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ip=rse< ari频積i<�-


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

No usage of org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ivt;n&noolll ,aat/lnd


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicy

  • Packages that use InvalidPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of InvalidPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw InvalidPolicy
      修饰符与类型 方法与描述
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of InvalidPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return InvalidPolicy
      修饰符与类型 | 方法与描述
      static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
      static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type InvalidPolicy
      修饰符与类型 | 方法与描述
      static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
      static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ravv3eotor=/od/ 滇=d纤 "


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicyHelper

No usage of org.omg.PortableServer.POAPackage.InvalidPolicyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

agd


Uses of Class org.omg.PortableServer.POAPackage.NoServant

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.NoServant

  • Packages that use NoServant
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of NoServant in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoServant
      修饰符与类型 方法与描述
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.

    • Uses of NoServant in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return NoServant
      修饰符与类型 | 方法与描述
      static NoServant | NoServantHelper.extract(Any a)
      static NoServant | NoServantHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type NoServant
      修饰符与类型 | 方法与描述
      static void | NoServantHelper.insert(Any a, NoServant that)
      static void | NoServantHelper.write(OutputStream ostream, NoServant value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t&e<=B-T=OL >


Uses of Class org.omg.PortableServer.POAPackage.NoServantHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.NoServantHelper

No usage of org.omg.PortableServer.POAPackage.NoServantHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mreiblosasss />>ntaa


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActive

  • Packages that use ObjectAlreadyActive
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectAlreadyActive
      修饰符与类型 方法与描述
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectAlreadyActive
      修饰符与类型 | 方法与描述
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectAlreadyActive
      修饰符与类型 | 方法与描述
      static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
      static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aaFlb>y�//i 9g>lh菽 r


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>iTsiv >e craahell>


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActive

  • Packages that use ObjectNotActive
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectNotActive
      修饰符与类型 方法与描述
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of ObjectNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectNotActive
      修饰符与类型 | 方法与描述
      static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
      static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectNotActive
      修饰符与类型 | 方法与描述
      static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
      static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Rc b <>mtl羑


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lt"OCORo/mmmo.rr>dste


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActive

  • Packages that use ServantAlreadyActive
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantAlreadyActive
      修饰符与类型 方法与描述
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.

    • Uses of ServantAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantAlreadyActive
      修饰符与类型 | 方法与描述
      static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
      static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantAlreadyActive
      修饰符与类型 | 方法与描述
      static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
      static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<= oogtoo"eoblasel=j錏f


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

kc"l


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActive

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActive

  • Packages that use ServantNotActive
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantNotActive
      修饰符与类型 方法与描述
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.

    • Uses of ServantNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantNotActive
      修饰符与类型 | 方法与描述
      static ServantNotActive | ServantNotActiveHelper.extract(Any a)
      static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantNotActive
      修饰符与类型 | 方法与描述
      static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
      static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b/i轩>衖 an,�909cl


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActiveHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantNotActiveHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sn=>> << ///iisst_ /s


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapter

  • Packages that use WrongAdapter
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongAdapter in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongAdapter
      修饰符与类型 方法与描述
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of WrongAdapter in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongAdapter
      修饰符与类型 | 方法与描述
      static WrongAdapter | WrongAdapterHelper.extract(Any a)
      static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongAdapter
      修饰符与类型 | 方法与描述
      static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
      static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a ;xBp


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapterHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapterHelper

No usage of org.omg.PortableServer.POAPackage.WrongAdapterHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tmr>.


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicy

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicy

  • Packages that use WrongPolicy
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongPolicy
      修饰符与类型 方法与描述
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      Object POAOperations.create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of WrongPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongPolicy
      修饰符与类型 | 方法与描述
      static WrongPolicy | WrongPolicyHelper.extract(Any a)
      static WrongPolicy | WrongPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongPolicy
      修饰符与类型 | 方法与描述
      static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
      static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

na/ hos r&<.oAbtto-


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicyHelper

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicyHelper

No usage of org.omg.PortableServer.POAPackage.WrongPolicyHelper
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/no>Tholccc=ittsl.i)


Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.omg.PortableServer.portable

Interface Delegate

  • public interface Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB vendor specific implementation of PortableServer::Servant. Conformant to spec CORBA V2.3.1, ptc/00-01-08.pdf

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      POA default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

    • 方法详细信息

      • orb

        ORB orb(Servant Self)
        Convenience method that returns the instance of the ORB currently associated with the Servant.
        参数：
        Self - the servant.
        返回：
        ORB associated with the Servant.

      • this_object

        Object this_object(Servant Self)
        This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        参数：
        Self - the servant.
        返回：
        Object reference associated with the request.

      • poa

        POA poa(Servant Self)
        The method _poa() is equivalent to calling PortableServer::Current:get_POA.
        参数：
        Self - the servant.
        返回：
        POA associated with the servant.

      • object_id

        byte[] object_id(Servant Self)
        The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
        参数：
        Self - the servant.
        返回：
        ObjectId associated with this servant.

      • default_POA

        POA default_POA(Servant Self)
        The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
        参数：
        Self - the servant.
        返回：
        POA associated with the servant class.

      • is_a

        boolean is_a(Servant Self,
           String Repository_Id)
        This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
        参数：
        Self - the servant.
        Repository_Id - the repository_id to be checked in the repository list or against the id of generic CORBA object.
        返回：
        boolean indicating whether the specified repid is in the list or is same as that got generic CORBA object.

      • non_existent

        boolean non_existent(Servant Self)
        This operation is used to check for the existence of the Object.
        参数：
        Self - the servant.
        返回：
        boolean true to indicate that object does not exist, and false otherwise.

      • get_interface_def

        Object get_interface_def(Servant self)
        This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
        参数：
        self - the servant.
        返回：
        type information corresponding to the object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d lC"s=tdt<


org.omg.PortableServer.portable

Interfaces

  • Delegate
=


org.omg.PortableServer.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer.portable

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

请参见： 描述

  • 接口摘要
    接口 描述
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.

软件包 org.omg.PortableServer.portable Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

The portable package contains interfaces and classes that are designed for and intended to be used by an ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB-vendor-specific implementation of PortableServer::Servant. This package conforms CORBA Specification V2.3.1, ptc/00-01-08.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Sre.SmPg/rogggr/ dl< >


org.omg.PortableServer.portable Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer.portable

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.PortableServer.portable.Delegate
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bel/ooo/gggr/ ab<


Uses of Package org.omg.PortableServer.portable

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer.portable

  • Packages that use org.omg.PortableServer.portable
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.portable used by org.omg.PortableServer
    类与描述
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bsvlftrc<>>e a>l==a


Uses of Interface org.omg.PortableServer.portable.Delegate

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.PortableServer.portable.Delegate

  • Packages that use Delegate
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Delegate in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Delegate
      修饰符与类型 方法与描述
      Delegate Servant._get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Methods in org.omg.PortableServer with parameters of type Delegate
      修饰符与类型 方法与描述
      void Servant._set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ho=sx h=d觮o


CookieHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.PortableServer.ServantLocatorPackage

类 CookieHolder

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder
  • 所有已实现的接口：
    Streamable

    public final class CookieHolder
extends Object
implements Streamable
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object. A CookieHolder class is provided for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      Object value

    • 构造方法摘要

      Constructors
      构造方法与描述
      CookieHolder()
      CookieHolder(Object initial)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void _read(InputStream is)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream os)
      Marshals to ostream the value in the value field of the Holder.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • value

        public Object value

    • 构造方法详细信息

      • CookieHolder

        public CookieHolder()

      • CookieHolder

        public CookieHolder(Object initial)

    • 方法详细信息

      • _read

        public void _read(InputStream is)
        从接口复制的描述： Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        指定者：
        _read in interface Streamable
        参数：
        is - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream os)
        从接口复制的描述： Streamable
        Marshals to ostream the value in the value field of the Holder.
        指定者：
        _write in interface Streamable
        参数：
        os - the CDR OutputStream

      • _type

        public TypeCode _type()
        从接口复制的描述： Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        指定者：
        _type in interface Streamable
        返回：
        the TypeCode object for the value held in the holder
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

yes m{ nollsot"�.c=tbyal


org.omg.PortableServer.ServantLocatorPackage

Classes

  • CookieHolder
n


org.omg.PortableServer.ServantLocatorPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.PortableServer.ServantLocatorPackage

Provides classes and interfaces for locating the servant.

请参见： 描述

  • Class Summary
    类 描述
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.

软件包 org.omg.PortableServer.ServantLocatorPackage Description

Provides classes and interfaces for locating the servant.

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(ode(.lhtlodhhlCaaPHoCckaap


org.omg.PortableServer.ServantLocatorPackage Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.PortableServer.ServantLocatorPackage

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

is>/F>em


Uses of Package org.omg.PortableServer.ServantLocatorPackage

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.PortableServer.ServantLocatorPackage

  • Packages that use org.omg.PortableServer.ServantLocatorPackage
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.ServantLocatorPackage used by org.omg.PortableServer
    类与描述
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pn:o < .=tnafkt�/�


Uses of Class org.omg.PortableServer.ServantLocatorPackage.CookieHolder

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.PortableServer.ServantLocatorPackage.CookieHolder

  • Packages that use CookieHolder
    软件包 描述
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CookieHolder in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type CookieHolder
      修饰符与类型 方法与描述
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=leedbb u


org.omg.SendingContext

Interfaces

  • RunTime
  • RunTimeOperations


org.omg.SendingContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.SendingContext

Provides support for the marshalling of value types.

请参见： 描述

  • 接口摘要
    接口 描述
    RunTime
    Defines the base class that represents the Sending Context of a request.
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.

软件包 org.omg.SendingContext Description

Provides support for the marshalling of value types. Value type marshalling may require access to an implementation of the value type or to meta information about the value type. This information is passed between the sending context and the receiving context using a particular service context containing an instance of the SendingContext.RunTime interface.

A sending context may be either the client side or the server side of an invocation, depending on which contains a value type. The sending context is the client side of an invocation if the request contains a value type. It is the server side if the reply contains a value type. The other party in the communication is the receiving context.

The service context marshalled for SendingContext consists of an encapsulated IOR for the SendingContext.RunTime interface. RunTime is just a marker interface defined to allow extensibility in the future. There is currently only one subinterface of RunTime defined: the SendingContext.CodeBase interface. The interface CodeBase defines operations to obtain code URLs and meta-information about a value type received from the sending context.

Note that these classes are currently defined in the com.sun.org.omg.SendingContext package rather than in the package org.omg.SendingContext. This has been done to avoid including large parts of the interface repository in the JDK core, since the interface repository is still evolving in response to the needs of the CORBA Components work.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ip//d a/nh-.鹯-lt"/vo


org.omg.SendingContext Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.SendingContext

软件包 Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.CORBA.Object
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uhmkegp"caa"


RunTime

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTime

  • All Superinterfaces:
    IDLEntity, Object, RunTimeOperations, Serializable

    public interface RunTime
extends RunTimeOperations, Object, IDLEntity
    Defines the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.

    • 方法摘要

      • 方法 - 继承于接口 org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"putrsh:i =lps;pr衞 =


RunTimeOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTimeOperations

  • All Known Subinterfaces:
    RunTime

    public interface RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

smtaooke-pe_


Uses of Package org.omg.SendingContext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.SendingContext

  • Packages that use org.omg.SendingContext
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
  • Classes in org.omg.SendingContext used by javax.rmi.CORBA
    类与描述
    RunTime
    Defines the base class that represents the Sending Context of a request.
  • Classes in org.omg.SendingContext used by org.omg.SendingContext
    类与描述
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oo-nRD&D>�&sa8n�-竝p癴繿


Uses of Interface org.omg.SendingContext.RunTime

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.SendingContext.RunTime

  • Packages that use RunTime
    软件包 描述
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.

    • Uses of RunTime in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return RunTime
      修饰符与类型 方法与描述
      RunTime ValueHandler.getRunTimeCodeBase()
      Returns the CodeBase for this ValueHandler.
      Methods in javax.rmi.CORBA with parameters of type RunTime
      修饰符与类型 方法与描述
      Serializable ValueHandler.readValue(InputStream in, int offset, 类 clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

cbu/nllcl>r


Uses of Interface org.omg.SendingContext.RunTimeOperations

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.omg.SendingContext.RunTimeOperations

  • Packages that use RunTimeOperations
    软件包 描述
    org.omg.SendingContext
    Provides support for the marshalling of value types.

    • Uses of RunTimeOperations in org.omg.SendingContext

      Subinterfaces of RunTimeOperations in org.omg.SendingContext
      修饰符与类型 Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


org.omg.stub.java.rmi

Classes

  • _Remote_Stub


org.omg.stub.java.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.omg.stub.java.rmi

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

请参见： 描述

  • Class Summary
    类 描述
    _Remote_Stub
    This class provides the Stub for the Remote Type.

软件包 org.omg.stub.java.rmi Description

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

从以下版本开始：
1.3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

peeo<9Ihk�>h


org.omg.stub.java.rmi Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.omg.stub.java.rmi

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.///lehtn"fs}troda.


_Remote_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.omg.stub.java.rmi

类 _Remote_Stub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub
          • org.omg.stub.java.rmi._Remote_Stub
  • 所有已实现的接口：
    Serializable, Remote, Object

    public final class _Remote_Stub
extends Stub
implements Remote
    This class provides the Stub for the Remote Type. The class is generated by the rmic compiler, and is still under works at OMG. It's contents are subject to change without notice as the specification evolves.

    • 构造方法摘要

      Constructors
      构造方法与描述
      _Remote_Stub()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String[] _ids()
      Returns an array of repository ids that an object implements.

      • 方法 - 继承于类 javax.rmi.CORBA.Stub

        connect, equals, hashCode, toString

      • 方法 - 继承于类 org.omg.CORBA_2_3.portable.ObjectImpl

        _get_codebase

      • 方法 - 继承于类 org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override

      • 方法 - 继承于类 java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • _Remote_Stub

        public _Remote_Stub()

    • 方法详细信息

      • _ids

        public String[] _ids()
        Returns an array of repository ids that an object implements. The string at index zero represents the most derived interface. The last id, for the generic CORBA object is (i.e., IDL:omg.org/CORBA/Object:1.0") is implied and not present.
        指定者：
        _ids in class ObjectImpl
        返回：
        an array of repository ids that an object implements.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

imwldtHtt .te./o./0is


Uses of Package org.omg.stub.java.rmi

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.omg.stub.java.rmi

No usage of org.omg.stub.java.rmi
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.omg.stub.java.rmi._Remote_Stub

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.omg.stub.java.rmi._Remote_Stub

No usage of org.omg.stub.java.rmi._Remote_Stub
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>vitr/on.m=


Attr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Attr

  • All Superinterfaces:
    Node

    public interface Attr
extends Node
    The Attr interface represents an attribute in an Element object. Typically the allowable values for the attribute are defined in a schema associated with the document.

    Attr objects inherit the Node interface, but since they are not actually child nodes of the element they describe, the DOM does not consider them part of the document tree. Thus, the Node attributes parentNode, previousSibling, and nextSibling have a null value for Attr objects. The DOM takes the view that attributes are properties of elements rather than having a separate identity from the elements they are associated with; this should make it more efficient to implement such features as default attributes associated with all elements of a given type. Furthermore, Attr nodes may not be immediate children of a DocumentFragment. However, they can be associated with Element nodes contained within a DocumentFragment. In short, users and implementors of the DOM need to be aware that Attr nodes have some things in common with other objects inheriting the Node interface, but they also are quite distinct.

    The attribute's effective value is determined as follows: if this attribute has been explicitly assigned any value, that value is the attribute's effective value; otherwise, if there is a declaration for this attribute, and that declaration includes a default value, then that default value is the attribute's effective value; otherwise, the attribute does not exist on this element in the structure model until it has been explicitly added. Note that the Node.nodeValue attribute on the Attr instance can also be used to retrieve the string version of the attribute's value(s).

    If the attribute was not explicitly given a value in the instance document but has a default value provided by the schema associated with the document, an attribute node will be created with specified set to false. Removing attribute nodes for which a default value is defined in the schema generates a new attribute node with the default value and specified set to false. If validation occurred while invoking Document.normalizeDocument(), attribute nodes with specified equals to false are recomputed according to the default attribute values provided by the schema. If no default value is associate with this attribute in the schema, the attribute node is discarded.

    In XML, where the value of an attribute can contain entity references, the child nodes of the Attr node may be either Text or EntityReference nodes (when these are in use; see the description of EntityReference for discussion).

    The DOM Core represents all attribute values as simple strings, even if the DTD or schema associated with the document declares them of some specific type such as tokenized.

    The way attribute value normalization is performed by the DOM implementation depends on how much the implementation knows about the schema in use. Typically, the value and nodeValue attributes of an Attr node initially returns the normalized value given by the parser. It is also the case after Document.normalizeDocument() is called (assuming the right options have been set). But this may not be the case after mutation, independently of whether the mutation is performed by setting the string value directly or by changing the Attr child nodes. In particular, this is true when character references are involved, given that they are not represented in the DOM and they impact attribute value normalization. On the other hand, if the implementation knows about the schema in use when the attribute value is changed, and it is of a different type than CDATA, it may normalize it again at that time. This is especially true of specialized DOM implementations, such as SVG DOM implementations, which store attribute values in an internal form different from a string.

    The following table gives some examples of the relations between the attribute value in the original document (parsed attribute), the value as exposed in the DOM, and the serialization of the value:

    Examples Parsed attribute value Initial Attr.value Serialized attribute value
    Character reference
    "x&#178;=5"

    "x�=5"

    "x&#178;=5"
    Built-in character entity
    "y&lt;6"

    "y<6"

    "y&lt;6"
    Literal newline between
     "x=5&#10;y=6"

    "x=5 y=6"

    "x=5&#10;y=6"
    Normalized newline between
    "x=5
 y=6"

    "x=5 y=6"

    "x=5 y=6"
    Entity e with literal newline
     <!ENTITY e '...&#10;...'> [...]> "x=5&e;y=6"
             Dependent on Implementation and Load Options Dependent on Implementation and Load/Save Options

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getName()
      Returns the name of this attribute.
      Element getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this attribute.
      boolean getSpecified()
      True if this attribute was explicitly given a value in the instance document, false otherwise.
      String getValue()
      On retrieval, the value of the attribute is returned as a string.
      boolean isId()
      Returns whether this attribute is known to be of type ID (i.e.
      void setValue(String value)
      On retrieval, the value of the attribute is returned as a string.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getName

        String getName()
        Returns the name of this attribute. If Node.localName is different from null, this attribute is a qualified name.

      • getSpecified

        boolean getSpecified()
        True if this attribute was explicitly given a value in the instance document, false otherwise. If the application changed the value of this attribute node (even if it ends up having the same value as the default value) then it is set to true. The implementation may handle attributes with default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.

      • getValue

        String getValue()
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.

      • setValue

        void setValue(String value)
              throws DOMException
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getOwnerElement

        Element getOwnerElement()
        The Element node this attribute is attached to or null if this attribute is not in use.
        从以下版本开始：
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this attribute. While the type information contained in this attribute is guarantee to be correct after loading the document or invoking Document.normalizeDocument(), schemaTypeInfo may not be reliable if the node was moved.
        从以下版本开始：
        DOM Level 3

      • isId

        boolean isId()
        Returns whether this attribute is known to be of type ID (i.e. to contain an identifier for its owner element) or not. When it is and its value is unique, the ownerElement of this attribute can be retrieved using the method Document.getElementById . The implementation could use several ways to determine if an attribute node is known to contain an identifier:
        • If validation occurred using an XML Schema [XML Schema Part 1] while loading the document or while invoking Document.normalizeDocument(), the post-schema-validation infoset contributions (PSVI contributions) values are used to determine if this attribute is a schema-determined ID attribute using the schema-determined ID definition in [XPointer] .
        • If validation occurred using a DTD while loading the document or while invoking Document.normalizeDocument(), the infoset [type definition] value is used to determine if this attribute is a DTD-determined ID attribute using the DTD-determined ID definition in [XPointer] .
        • from the use of the methods Element.setIdAttribute(), Element.setIdAttributeNS(), or Element.setIdAttributeNode(), i.e. it is an user-determined ID attribute;

          Note: XPointer framework (see section 3.2 in [XPointer] ) consider the DOM user-determined ID attribute as being part of the XPointer externally-determined ID definition.

        • using mechanisms that are outside the scope of this specification, it is then an externally-determined ID attribute. This includes using schema languages different from XML schema and DTD.

        If validation occurred while invoking Document.normalizeDocument(), all user-determined ID attributes are reset and all attribute nodes ID information are then reevaluated in accordance to the schema used. As a consequence, if the Attr.schemaTypeInfo attribute contains an ID type, isId will always return true.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

g=//糳a;�=a


CDATASection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.w3c.dom

Interface CDATASection

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface CDATASection
extends Text
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup. The only delimiter that is recognized in a CDATA section is the "]]>" string that ends the CDATA section. CDATA sections cannot be nested. Their primary purpose is for including material such as XML fragments, without needing to escape all the delimiters.

    The CharacterData.data attribute holds the text that is contained by the CDATA section. Note that this may contain characters that need to be escaped outside of CDATA sections and that, depending on the character encoding ("charset") chosen for serialization, it may be impossible to write out some characters as part of a CDATA section.

    The CDATASection interface inherits from the CharacterData interface through the Text interface. Adjacent CDATASection nodes are not merged by use of the normalize method of the Node interface.

    No lexical check is done on the content of a CDATA section and it is therefore possible to have the character sequence "]]>" in the content, which is illegal in a CDATA section per section 2.7 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization or the cdata section must be splitted before the serialization (see also the parameter "split-cdata-sections" in the DOMConfiguration interface).

    Note: Because no markup is recognized within a CDATASection, character numeric references cannot be used as an escape mechanism when serializing. Therefore, action needs to be taken when serializing a CDATASection with a character encoding where some of the contained characters cannot be represented. Failure to do so would not produce well-formed XML.

    Note: One potential solution in the serialization process is to end the CDATA section before the character, output the character using a character reference or entity reference, and open a new CDATA section for any further characters in the text node. Note, however, that some code conversion libraries at the time of writing do not return an error or exception when a character is missing from the encoding, making the task of ensuring that data is not corrupted on serialization more difficult.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • 方法 - 继承于接口 org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

aac#eh/.h/mNmomm3.hhr /..ogtaa


CharacterData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface CharacterData

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    CDATASection, Comment, Text, Text

    public interface CharacterData
extends Node
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM. For clarity this set is defined here rather than on each object that uses these attributes and methods. No DOM objects correspond directly to CharacterData, though Text and others do inherit the interface from it. All offsets in this interface start from 0.

    As explained in the DOMString interface, text strings in the DOM are represented in UTF-16, i.e. as a sequence of 16-bit units. In the following, the term 16-bit units is used whenever necessary to indicate that indexing on CharacterData is done in 16-bit units.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void appendData(String arg)
      Append the string to the end of the character data of the node.
      void deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      String getData()
      The character data of the node that implements this interface.
      int getLength()
      The number of 16-bit units that are available through data and the substringData method below.
      void insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      void setData(String data)
      The character data of the node that implements this interface.
      String substringData(int offset, int count)
      Extracts a range of data from the node.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getData

        String getData()
               throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        抛出：
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setData

        void setData(String data)
             throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getLength

        int getLength()
        The number of 16-bit units that are available through data and the substringData method below. This may have the value zero, i.e., CharacterData nodes may be empty.

      • substringData

        String substringData(int offset,
                   int count)
                     throws DOMException
        Extracts a range of data from the node.
        参数：
        offset - Start offset of substring to extract.
        count - The number of 16-bit units to extract.
        返回：
        The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.
        抛出：
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        DOMSTRING_SIZE_ERR: Raised if the specified range of text does not fit into a DOMString.

      • appendData

        void appendData(String arg)
                throws DOMException
        Append the string to the end of the character data of the node. Upon success, data provides access to the concatenation of data and the DOMString specified.
        参数：
        arg - The DOMString to append.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • insertData

        void insertData(int offset,
              String arg)
                throws DOMException
        Insert a string at the specified 16-bit unit offset.
        参数：
        offset - The character offset at which to insert.
        arg - The DOMString to insert.
        抛出：
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • deleteData

        void deleteData(int offset,
              int count)
                throws DOMException
        Remove a range of 16-bit units from the node. Upon success, data and length reflect the change.
        参数：
        offset - The offset from which to start removing.
        count - The number of 16-bit units to delete. If the sum of offset and count exceeds length then all 16-bit units from offset to the end of the data are deleted.
        抛出：
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • replaceData

        void replaceData(int offset,
               int count,
               String arg)
                 throws DOMException
        Replace the characters starting at the specified 16-bit unit offset with the specified string.
        参数：
        offset - The offset from which to start replacing.
        count - The number of 16-bit units to replace. If the sum of offset and count exceeds length, then all 16-bit units to the end of the data are replaced; (i.e., the effect is the same as a remove method call with the same range, followed by an append method invocation).
        arg - The DOMString with which the range must be replaced.
        抛出：
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ad/ddde ala lwnsnwwctIol


Comment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.w3c.dom

Interface Comment

  • All Superinterfaces:
    CharacterData, Node

    public interface Comment
extends CharacterData
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'. Note that this is the definition of a comment in XML, and, in practice, HTML, although some HTML tools may implement the full SGML comment structure.

    No lexical check is done on the content of a comment and it is therefore possible to have the character sequence "--" (double-hyphen) in the content, which is illegal in a comment per section 2.5 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

..hcog/rg/.../.."


Document

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Document

  • All Superinterfaces:
    Node
    All Known Implementing Classes:
    SOAPPart

    public interface Document
extends Node
    The Document interface represents the entire HTML or XML document. Conceptually, it is the root of the document tree, and provides the primary access to the document's data.

    Since elements, text nodes, comments, processing instructions, etc. cannot exist outside the context of a Document, the Document interface also contains the factory methods needed to create these objects. The Node objects created have a ownerDocument attribute which associates them with the Document within whose context they were created.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Attr createAttribute(String name)
      Creates an Attr of the given name.
      Attr createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Comment createComment(String data)
      Creates a Comment node given the specified string.
      DocumentFragment createDocumentFragment()
      Creates an empty DocumentFragment object.
      Element createElement(String tagName)
      Creates an element of the type specified.
      Element createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      Text createTextNode(String data)
      Creates a Text node given the specified string.
      DocumentType getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Element getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      String getDocumentURI()
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      DOMConfiguration getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.
      Element getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      NodeList getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
      DOMImplementation getImplementation()
      The DOMImplementation object that handles this document.
      String getInputEncoding()
      An attribute specifying the encoding used for this document at the time of the parsing.
      boolean getStrictErrorChecking()
      An attribute specifying whether error checking is enforced or not.
      String getXmlEncoding()
      An attribute specifying, as part of the XML declaration, the encoding of this document.
      boolean getXmlStandalone()
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      String getXmlVersion()
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Node importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      void normalizeDocument()
      This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form.
      Node renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      void setDocumentURI(String documentURI)
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      void setStrictErrorChecking(boolean strictErrorChecking)
      An attribute specifying whether error checking is enforced or not.
      void setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getDoctype

        DocumentType getDoctype()
        The Document Type Declaration (see DocumentType) associated with this document. For XML documents without a document type declaration this returns null. For HTML documents, a DocumentType object may be returned, independently of the presence or absence of document type declaration in the HTML document.
        This provides direct access to the DocumentType node, child node of this Document. This node can be set at document creation time and later changed through the use of child nodes manipulation methods, such as Node.insertBefore, or Node.replaceChild. Note, however, that while some implementations may instantiate different types of Document objects supporting additional features than the "Core", such as "HTML" [DOM Level 2 HTML] , based on the DocumentType specified at creation time, changing it afterwards is very unlikely to result in a change of the features supported.
        从以下版本开始：
        DOM Level 3

      • getImplementation

        DOMImplementation getImplementation()
        The DOMImplementation object that handles this document. A DOM application may use objects from multiple implementations.

      • getDocumentElement

        Element getDocumentElement()
        This is a convenience attribute that allows direct access to the child node that is the document element of the document.

      • createElement

        Element createElement(String tagName)
                      throws DOMException
        Creates an element of the type specified. Note that the instance returned implements the Element interface, so attributes can be specified directly on the returned object.
        In addition, if there are known attributes with default values, Attr nodes representing them are automatically created and attached to the element.
        To create an element with a qualified name and namespace URI, use the createElementNS method.
        参数：
        tagName - The name of the element type to instantiate. For XML, this is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use. In that case, the name is mapped to the canonical form of that markup by the DOM implementation.
        返回：
        A new Element object with the nodeName attribute set to tagName, and localName, prefix, and namespaceURI set to null.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createDocumentFragment

        DocumentFragment createDocumentFragment()
        Creates an empty DocumentFragment object.
        返回：
        A new DocumentFragment.

      • createTextNode

        Text createTextNode(String data)
        Creates a Text node given the specified string.
        参数：
        data - The data for the node.
        返回：
        The new Text object.

      • createComment

        Comment createComment(String data)
        Creates a Comment node given the specified string.
        参数：
        data - The data for the node.
        返回：
        The new Comment object.

      • createCDATASection

        CDATASection createCDATASection(String data)
                                throws DOMException
        Creates a CDATASection node whose value is the specified string.
        参数：
        data - The data for the CDATASection contents.
        返回：
        The new CDATASection object.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createProcessingInstruction

        ProcessingInstruction createProcessingInstruction(String target,
                                                String data)
                                                  throws DOMException
        Creates a ProcessingInstruction node given the specified name and data strings.
        参数：
        target - The target part of the processing instruction.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the target name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the target name is namespace well-formed.
        data - The data for the node.
        返回：
        The new ProcessingInstruction object.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified target is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createAttribute

        Attr createAttribute(String name)
                     throws DOMException
        Creates an Attr of the given name. Note that the Attr instance can then be set on an Element using the setAttributeNode method.
        To create an attribute with a qualified name and namespace URI, use the createAttributeNS method.
        参数：
        name - The name of the attribute.
        返回：
        A new Attr object with the nodeName attribute set to name, and localName, prefix, and namespaceURI set to null. The value of the attribute is the empty string.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createEntityReference

        EntityReference createEntityReference(String name)
                                      throws DOMException
        Creates an EntityReference object. In addition, if the referenced entity is known, the child list of the EntityReference node is made the same as that of the corresponding Entity node.

        Note: If any descendant of the Entity node has an unbound namespace prefix, the corresponding descendant of the created EntityReference node is also unbound; (its namespaceURI is null). The DOM Level 2 and 3 do not support any mechanism to resolve namespace prefixes in this case.

        参数：
        name - The name of the entity to reference.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the entity name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the entity name is namespace well-formed.
        返回：
        The new EntityReference object.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • getElementsByTagName

        NodeList getElementsByTagName(String tagname)
        Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
        参数：
        tagname - The name of the tag to match on. The special value "*" matches all tags. For XML, the tagname parameter is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use.
        返回：
        A new NodeList object containing all the matched Elements.

      • importNode

        Node importNode(Node importedNode,
              boolean deep)
                throws DOMException
        Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node. The returned node has no parent; (parentNode is null).
        For all nodes, importing a node creates a node object owned by the importing document, with attribute values identical to the source node's nodeName and nodeType, plus the attributes related to namespaces (prefix, localName, and namespaceURI). As in the cloneNode operation, the source node is not altered. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Additional information is copied as appropriate to the nodeType, attempting to mirror the behavior expected if a fragment of XML or HTML source was copied from one document to another, recognizing that the two documents may have different DTDs in the XML case. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the generated Attr. The descendants of the source Attr are recursively imported and the resulting nodes reassembled to form the corresponding subtree. Note that the deep parameter has no effect on Attr nodes; they always carry their children with them when imported.
        DOCUMENT_FRAGMENT_NODE
        If the deep option was set to true, the descendants of the source DocumentFragment are recursively imported and the resulting nodes reassembled under the imported DocumentFragment to form the corresponding subtree. Otherwise, this simply generates an empty DocumentFragment.
        DOCUMENT_NODE
        Document nodes cannot be imported.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be imported.
        ELEMENT_NODE
        Specified attribute nodes of the source element are imported, and the generated Attr nodes are attached to the generated Element. Default attributes are not copied, though if the document being imported into defines default attributes for this element name, those are assigned. If the importNode deep parameter was set to true, the descendants of the source element are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_NODE
        Entity nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId, systemId, and notationName attributes are copied. If a deep import is requested, the descendants of the the source Entity are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_REFERENCE_NODE
        Only the EntityReference itself is copied, even if a deep import is requested, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId and systemId attributes are copied. Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        PROCESSING_INSTRUCTION_NODE
        The imported node copies its target and data values from those of the source node.Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These three types of nodes inheriting from CharacterData copy their data and length attributes from those of the source node.Note that the deep parameter has no effect on these types of nodes since they cannot have any children.
        参数：
        importedNode - The node to import.
        deep - If true, recursively import the subtree under the specified node; if false, import only the node itself, as explained above. This has no effect on nodes that cannot have any children, and on Attr, and EntityReference nodes.
        返回：
        The imported node that belongs to this Document.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if the type of node being imported is not supported.
        INVALID_CHARACTER_ERR: Raised if one of the imported names is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute. This may happen when importing an XML 1.1 [XML 1.1] element into an XML 1.0 document, for instance.
        从以下版本开始：
        DOM Level 2

      • createElementNS

        Element createElementNS(String namespaceURI,
                      String qualifiedName)
                        throws DOMException
        Creates an element of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the element to create.
        qualifiedName - The qualified name of the element type to instantiate.
        返回：
        A new Element object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Element.tagName | qualifiedName
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        从以下版本开始：
        DOM Level 2

      • createAttributeNS

        Attr createAttributeNS(String namespaceURI,
                     String qualifiedName)
                       throws DOMException
        Creates an attribute of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to create.
        qualifiedName - The qualified name of the attribute to instantiate.
        返回：
        A new Attr object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Attr.name | qualifiedName
        Node.nodeValue | the empty string
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        从以下版本开始：
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                              String localName)
        Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
        参数：
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        返回：
        A new NodeList object containing all the matched Elements.
        从以下版本开始：
        DOM Level 2

      • getElementById

        Element getElementById(String elementId)
        Returns the Element that has an ID attribute with the given value. If no such element exists, this returns null . If more than one element has an ID attribute with that value, what is returned is undefined.
        The DOM implementation is expected to use the attribute Attr.isId to determine if an attribute is of type ID.

        Note: Attributes with the name "ID" or "id" are not of type ID unless so defined.

        参数：
        elementId - The unique id value for an element.
        返回：
        The matching element or null if there is none.
        从以下版本开始：
        DOM Level 2

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this document at the time of the parsing. This is null when it is not known, such as when the Document was created in memory.
        从以下版本开始：
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the XML declaration, the encoding of this document. This is null when unspecified or when it is not known, such as when the Document was created in memory.
        从以下版本开始：
        DOM Level 3

      • getXmlStandalone

        boolean getXmlStandalone()
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        从以下版本开始：
        DOM Level 3

      • setXmlStandalone

        void setXmlStandalone(boolean xmlStandalone)
                      throws DOMException
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if this document does not support the "XML" feature.
        从以下版本开始：
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        从以下版本开始：
        DOM Level 3

      • setXmlVersion

        void setXmlVersion(String xmlVersion)
                   throws DOMException
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if the version is set to a value that is not supported by this Document or if this document does not support the "XML" feature.
        从以下版本开始：
        DOM Level 3

      • getStrictErrorChecking

        boolean getStrictErrorChecking()
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        从以下版本开始：
        DOM Level 3

      • setStrictErrorChecking

        void setStrictErrorChecking(boolean strictErrorChecking)
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        从以下版本开始：
        DOM Level 3

      • getDocumentURI

        String getDocumentURI()
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        从以下版本开始：
        DOM Level 3

      • setDocumentURI

        void setDocumentURI(String documentURI)
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        从以下版本开始：
        DOM Level 3

      • adoptNode

        Node adoptNode(Node source)
               throws DOMException
        Attempts to adopt a node from another document to this document. If supported, it changes the ownerDocument of the source node, its children, as well as the attached attribute nodes if there are any. If the source node has a parent it is first removed from the child list of its parent. This effectively allows moving a subtree from one document to another (unlike importNode() which create a copy of the source node instead of moving it). When it fails, applications should use Document.importNode() instead. Note that if the adopted node is already part of this document (i.e. the source and target document are the same), this method still has the effect of removing the source node from the child list of its parent, if any. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the adopted Attr. The descendants of the source Attr are recursively adopted.
        DOCUMENT_FRAGMENT_NODE
        The descendants of the source node are recursively adopted.
        DOCUMENT_NODE
        Document nodes cannot be adopted.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be adopted.
        ELEMENT_NODE
        Specified attribute nodes of the source element are adopted. Default attributes are discarded, though if the document being adopted into defines default attributes for this element name, those are assigned. The descendants of the source element are recursively adopted.
        ENTITY_NODE
        Entity nodes cannot be adopted.
        ENTITY_REFERENCE_NODE
        Only the EntityReference node itself is adopted, the descendants are discarded, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes cannot be adopted.
        PROCESSING_INSTRUCTION_NODE, TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These nodes can all be adopted. No specifics.

        Note: Since it does not create new nodes unlike the Document.importNode() method, this method does not raise an INVALID_CHARACTER_ERR exception, and applications should use the Document.normalizeDocument() method to check if an imported name is not an XML name according to the XML version in use.

        参数：
        source - The node to move into this document.
        返回：
        The adopted node, or null if this operation fails, such as when the source node comes from a different implementation.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if the source node is of type DOCUMENT, DOCUMENT_TYPE.
        NO_MODIFICATION_ALLOWED_ERR: Raised when the source node is readonly.
        从以下版本开始：
        DOM Level 3

      • getDomConfig

        DOMConfiguration getDomConfig()
        The configuration used when Document.normalizeDocument() is invoked.
        从以下版本开始：
        DOM Level 3

      • normalizeDocument

        void normalizeDocument()
        This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form. As a consequence, this method updates the replacement tree of EntityReference nodes and normalizes Text nodes, as defined in the method Node.normalize().
        Otherwise, the actual result depends on the features being set on the Document.domConfig object and governing what operations actually take place. Noticeably this method could also make the document namespace well-formed according to the algorithm described in , check the character normalization, remove the CDATASection nodes, etc. See DOMConfiguration for details.
        // Keep in the document
 the information defined // in the XML Information Set (Java example)
 DOMConfiguration docConfig = myDocument.getDomConfig();
 docConfig.setParameter("infoset", Boolean.TRUE);
 myDocument.normalizeDocument();

        Mutation events, when supported, are generated to reflect the changes occurring on the document.
        If errors occur during the invocation of this method, such as an attempt to update a read-only node or a Node.nodeName contains an invalid character according to the XML version in use, errors or warnings (DOMError.SEVERITY_ERROR or DOMError.SEVERITY_WARNING) will be reported using the DOMErrorHandler object associated with the "error-handler " parameter. Note this method might also report fatal errors ( DOMError.SEVERITY_FATAL_ERROR) if an implementation cannot recover from an error.
        从以下版本开始：
        DOM Level 3

      • renameNode

        Node renameNode(Node n,
              String namespaceURI,
              String qualifiedName)
                throws DOMException
        Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
        When possible this simply changes the name of the given node, otherwise this creates a new node with the specified name and replaces the existing node with the new node as described below.
        If simply changing the name of the given node is not possible, the following operations are performed: a new node is created, any registered event listener is registered on the new node, any user data attached to the old node is removed from that node, the old node is removed from its parent if it has one, the children are moved to the new node, if the renamed node is an Element its attributes are moved to the new node, the new node is inserted at the position the old node used to have in its parent's child nodes list if it has one, the user data that was attached to the old node is attached to the new node.
        When the node being renamed is an Element only the specified attributes are moved, default attributes originated from the DTD are updated according to the new element name. In addition, the implementation may update default attributes from other schemas. Applications should use Document.normalizeDocument() to guarantee these attributes are up-to-date.
        When the node being renamed is an Attr that is attached to an Element, the node is first removed from the Element attributes map. Then, once renamed, either by modifying the existing node or creating a new one as described above, it is put back.
        In addition,
        • a user data event NODE_RENAMED is fired,
        • when the implementation supports the feature "MutationNameEvents", each mutation operation involved in this method fires the appropriate event, and in the end the event { http://www.w3.org/2001/xml-events, DOMElementNameChanged} or { http://www.w3.org/2001/xml-events, DOMAttributeNameChanged} is fired.
        参数：
        n - The node to rename.
        namespaceURI - The new namespace URI.
        qualifiedName - The new qualified name.
        返回：
        The renamed node. This is either the specified node or the new node that was created to replace the specified node.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised when the type of the specified node is neither ELEMENT_NODE nor ATTRIBUTE_NODE, or if the implementation does not support the renaming of the document element.
        INVALID_CHARACTER_ERR: Raised if the new qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        WRONG_DOCUMENT_ERR: Raised when the specified node was created from a different document than this document.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] . Also raised, when the node being renamed is an attribute, if the qualifiedName, or its prefix, is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/".
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DocumentFragment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.w3c.dom

Interface DocumentFragment

  • All Superinterfaces:
    Node

    public interface DocumentFragment
extends Node
    DocumentFragment is a "lightweight" or "minimal" Document object. It is very common to want to be able to extract a portion of a document's tree or to create a new fragment of a document. Imagine implementing a user command like cut or rearranging a document by moving fragments around. It is desirable to have an object which can hold such fragments and it is quite natural to use a Node for this purpose. While it is true that a Document object could fulfill this role, a Document object can potentially be a heavyweight object, depending on the underlying implementation. What is really needed for this is a very lightweight object. DocumentFragment is such an object.

    Furthermore, various operations -- such as inserting nodes as children of another Node -- may take DocumentFragment objects as arguments; this results in all the child nodes of the DocumentFragment being moved to the child list of this node.

    The children of a DocumentFragment node are zero or more nodes representing the tops of any sub-trees defining the structure of the document. DocumentFragment nodes do not need to be well-formed XML documents (although they do need to follow the rules imposed upon well-formed XML parsed entities, which can have multiple top nodes). For example, a DocumentFragment might have only one child and that child node could be a Text node. Such a structure model represents neither an HTML document nor a well-formed XML document.

    When a DocumentFragment is inserted into a Document (or indeed any other Node that may take children) the children of the DocumentFragment and not the DocumentFragment itself are inserted into the Node. This makes the DocumentFragment very useful when the user wishes to create nodes that are siblings; the DocumentFragment acts as the parent of these nodes so that the user can use the standard methods from the Node interface, such as Node.insertBefore and Node.appendChild.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dlonfcnacnittniithooslCwosts".


DocumentType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DocumentType

  • All Superinterfaces:
    Node

    public interface DocumentType
extends Node
    Each Document has a doctype attribute whose value is either null or a DocumentType object. The DocumentType interface in the DOM Core provides an interface to the list of entities that are defined for the document, and little else because the effect of namespaces and the various XML schema efforts on DTD representation are not clearly understood as of this writing.

    DOM Level 3 doesn't support editing DocumentType nodes. DocumentType nodes are read-only.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      NamedNodeMap getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      String getInternalSubset()
      The internal subset as a string, or null if there is none.
      String getName()
      The name of DTD; i.e., the name immediately following the DOCTYPE keyword.
      NamedNodeMap getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
      String getPublicId()
      The public identifier of the external subset.
      String getSystemId()
      The system identifier of the external subset.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getName

        String getName()
        The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

      • getEntities

        NamedNodeMap getEntities()
        A NamedNodeMap containing the general entities, both external and internal, declared in the DTD. Parameter entities are not contained. Duplicates are discarded. For example in:
        <!DOCTYPE
 ex SYSTEM "ex.dtd" [ <!ENTITY foo "foo"> <!ENTITY bar
 "bar"> <!ENTITY bar "bar2"> <!ENTITY % baz "baz">
 ]> <ex/>
        the interface provides access to foo and the first declaration of bar but not the second declaration of bar or baz. Every node in this map also implements the Entity interface.
        The DOM Level 2 does not support editing entities, therefore entities cannot be altered in any way.

      • getNotations

        NamedNodeMap getNotations()
        A NamedNodeMap containing the notations declared in the DTD. Duplicates are discarded. Every node in this map also implements the Notation interface.
        The DOM Level 2 does not support editing notations, therefore notations cannot be altered in any way.

      • getPublicId

        String getPublicId()
        The public identifier of the external subset.
        从以下版本开始：
        DOM Level 2

      • getSystemId

        String getSystemId()
        The system identifier of the external subset. This may be an absolute URI or not.
        从以下版本开始：
        DOM Level 2

      • getInternalSubset

        String getInternalSubset()
        The internal subset as a string, or null if there is none. This is does not contain the delimiting square brackets.

        Note: The actual content returned depends on how much information is available to the implementation. This may vary depending on various parameters, including the XML processor used to build the document.

        从以下版本开始：
        DOM Level 2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"cdrd ; sis siii AA萳"slt


DOMConfiguration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMConfiguration

  • public interface DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters. Using the configuration, it is possible to change Document.normalizeDocument() behavior, such as replacing the CDATASection nodes with Text nodes or specifying the type of the schema that must be used when the validation of the Document is requested. DOMConfiguration objects are also used in [DOM Level 3 Load and Save] in the DOMParser and DOMSerializer interfaces.

    The parameter names used by the DOMConfiguration object are defined throughout the DOM Level 3 specifications. Names are case-insensitive. To avoid possible conflicts, as a convention, names referring to parameters defined outside the DOM specification should be made unique. Because parameters are exposed as properties in names are recommended to follow the section 5.16 Identifiers of [Unicode] with the addition of the character '-' (HYPHEN-MINUS) but it is not enforced by the DOM implementation. DOM Level 3 Core Implementations are required to recognize all parameters defined in this specification. Some parameter values may also be required to be supported by the implementation. Refer to the definition of the parameter to know if a value must be supported or not.

    Note: Parameters are similar to features and properties used in SAX2 [SAX].

    The following list of parameters defined in the DOM:

    "canonical-form"
    true
    [optional] Canonicalize the document according to the rules specified in [Canonical XML], such as removing the DocumentType node (if any) from the tree, or removing superfluous namespace declarations from each element. Note that this is limited to what can be represented in the DOM; in particular, there is no way to specify the order of the attributes in the DOM. In addition, Setting this parameter to true will also set the state of the parameters listed below. Later changes to the state of one of those parameters will revert "canonical-form" back to false. Parameters set to false: "entities", " normalize-characters", "cdata-sections". Parameters set to true: "namespaces", "namespace-declarations", "well-formed", "element-content-whitespace". Other parameters are not changed unless explicitly specified in the description of the parameters.
    false
    [required] (default)Do not canonicalize the document.
    "cdata-sections"
    true
    [required] (default)Keep CDATASection nodes in the document.
    false
    [required]Transform CDATASection nodes in the document into Text nodes. The new Text node is then combined with any adjacent Text node.
    "check-character-normalization"
    true
    [optional] Check if the characters in the document are fully normalized, as defined in appendix B of [XML 1.1]. When a sequence of characters is encountered that fails normalization checking, an error with the DOMError.type equals to "check-character-normalization-failure" is issued.
    false
    [required] (default)Do not check if characters are normalized.
    "comments"
    true
    [required] (default)Keep Comment nodes in the document.
    false
    [required]Discard Comment nodes in the document.
    "datatype-normalization"
    true
    [optional] Expose schema normalized values in the tree, such as XML Schema normalized values in the case of XML Schema. Since this parameter requires to have schema information, the "validate" parameter will also be set to true. Having this parameter activated when "validate" is false has no effect and no schema-normalization will happen.

    Note: Since the document contains the result of the XML 1.0 processing, this parameter does not apply to attribute value normalization as defined in section 3.3.3 of [XML 1.0] and is only meant for schema languages other than Document Type Definition (DTD).

    false
    [required] (default) Do not perform schema normalization on the tree.
    "element-content-whitespace"
    true
    [required] (default)Keep all whitespaces in the document.
    false
    [optional] Discard all Text nodes that contain whitespaces in element content, as described in [element content whitespace]. The implementation is expected to use the attribute Text.isElementContentWhitespace to determine if a Text node should be discarded or not.
    "entities"
    true
    [required] (default)Keep EntityReference nodes in the document.
    false
    [required] Remove all EntityReference nodes from the document, putting the entity expansions directly in their place. Text nodes are normalized, as defined in Node.normalize. Only unexpanded entity references are kept in the document.

    Note: This parameter does not affect Entity nodes.

    "error-handler"
    [required] Contains a DOMErrorHandler object. If an error is encountered in the document, the implementation will call back the DOMErrorHandler registered using this parameter. The implementation may provide a default DOMErrorHandler object. When called, DOMError.relatedData will contain the closest node to where the error occurred. If the implementation is unable to determine the node where the error occurs, DOMError.relatedData will contain the Document node. Mutations to the document from within an error handler will result in implementation dependent behavior.
    "infoset"
    true
    [required]Keep in the document the information defined in the XML Information Set [XML Information Set] .This forces the following parameters to false: " validate-if-schema", "entities", "datatype-normalization", "cdata-sections ".This forces the following parameters to true: " namespace-declarations", "well-formed", "element-content-whitespace", " comments", "namespaces".Other parameters are not changed unless explicitly specified in the description of the parameters. Note that querying this parameter with getParameter returns true only if the individual parameters specified above are appropriately set.
    false
    Setting infoset to false has no effect.
    "namespaces"
    true
    [required] (default) Perform the namespace processing as defined in .
    false
    [optional] Do not perform the namespace processing.
    "namespace-declarations"
    This parameter has no effect if the parameter "namespaces" is set to false.
    true
    [required] (default) Include namespace declaration attributes, specified or defaulted from the schema, in the document. See also the sections "Declaring Namespaces" in [XML Namespaces] and [XML Namespaces 1.1] .
    false
    [required]Discard all namespace declaration attributes. The namespace prefixes ( Node.prefix) are retained even if this parameter is set to false.
    "normalize-characters"
    true
    [optional] Fully normalized the characters in the document as defined in appendix B of [XML 1.1].
    false
    [required] (default)Do not perform character normalization.
    "schema-location"
    [optional] Represent a DOMString object containing a list of URIs, separated by whitespaces (characters matching the nonterminal production S defined in section 2.3 [XML 1.0]), that represents the schemas against which validation should occur, i.e. the current schema. The types of schemas referenced in this list must match the type specified with schema-type, otherwise the behavior of an implementation is undefined. The schemas specified using this property take precedence to the schema information specified in the document itself. For namespace aware schema, if a schema specified using this property and a schema specified in the document instance (i.e. using the schemaLocation attribute) in a schema document (i.e. using schema import mechanisms) share the same targetNamespace, the schema specified by the user using this property will be used. If two schemas specified using this property share the same targetNamespace or have no namespace, the behavior is implementation dependent. If no location has been provided, this parameter is null.

    Note: The "schema-location" parameter is ignored unless the "schema-type" parameter value is set. It is strongly recommended that Document.documentURI will be set so that an implementation can successfully resolve any external entities referenced.

    "schema-type"
    [optional] Represent a DOMString object containing an absolute URI and representing the type of the schema language used to validate a document against. Note that no lexical checking is done on the absolute URI. If this parameter is not set, a default value may be provided by the implementation, based on the schema languages supported and on the schema language used at load time. If no value is provided, this parameter is null.

    Note: For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

    "split-cdata-sections"
    true
    [required] (default)Split CDATA sections containing the CDATA section termination marker ']]>'. When a CDATA section is split a warning is issued with a DOMError.type equals to "cdata-sections-splitted" and DOMError.relatedData equals to the first CDATASection node in document order resulting from the split.
    false
    [required]Signal an error if a CDATASection contains an unrepresentable character.
    "validate"
    true
    [optional] Require the validation against a schema (i.e. XML schema, DTD, any other type or representation of schema) of the document as it is being normalized as defined by [XML 1.0]. If validation errors are found, or no schema was found, the error handler is notified. Schema-normalized values will not be exposed according to the schema in used unless the parameter "datatype-normalization" is true. This parameter will reevaluate:
    • Attribute nodes with Attr.specified equals to false, as specified in the description of the Attr interface;
    • The value of the attribute Text.isElementContentWhitespace for all Text nodes;
    • The value of the attribute Attr.isId for all Attr nodes;
    • The attributes Element.schemaTypeInfo and Attr.schemaTypeInfo.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false. Applications should also consider setting the parameter "well-formed" to true, which is the default for that option, when validating the document.

    false
    [required] (default) Do not accomplish schema processing, including the internal subset processing. Default attribute values information are kept. Note that validation might still happen if "validate-if-schema" is true .
    "validate-if-schema"
    true
    [optional]Enable validation only if a declaration for the document element can be found in a schema (independently of where it is found, i.e. XML schema, DTD, or any other type or representation of schema). If validation is enabled, this parameter has the same behavior as the parameter "validate" set to true.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false.

    false
    [required] (default) No schema processing should be performed if the document has a schema, including internal subset processing. Default attribute values information are kept. Note that validation must still happen if "validate " is true.
    "well-formed"
    true
    [required] (default) Check if all nodes are XML well formed according to the XML version in use in Document.xmlVersion:
    • check if the attribute Node.nodeName contains invalid characters according to its node type and generate a DOMError of type "wf-invalid-character-in-node-name", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the text content inside Attr, Element, Comment, Text, CDATASection nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the data inside ProcessingInstruction nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    false
    [optional] Do not check for XML well-formedness.

    The resolution of the system identifiers associated with entities is done using Document.documentURI. However, when the feature "LS" defined in [DOM Level 3 Load and Save] is supported by the DOM implementation, the parameter "resource-resolver" can also be used on DOMConfiguration objects attached to Document nodes. If this parameter is set, Document.normalizeDocument() will invoke the resource resolver instead of using Document.documentURI.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean canSetParameter(String name, Object value)
      Check if setting a parameter to a specific value is supported.
      Object getParameter(String name)
      Return the value of a parameter if known.
      DOMStringList getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
      void setParameter(String name, Object value)
      Set the value of a parameter.

    • 方法详细信息

      • setParameter

        void setParameter(String name,
                Object value)
                  throws DOMException
        Set the value of a parameter.
        参数：
        name - The name of the parameter to set.
        value - The new value or null if the user wishes to unset the parameter. While the type of the value parameter is defined as DOMUserData, the object type must match the type defined by the definition of the parameter. For example, if the parameter is "error-handler", the value must be of type DOMErrorHandler.
        抛出：
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.
        NOT_SUPPORTED_ERR: Raised when the parameter name is recognized but the requested value cannot be set.
        TYPE_MISMATCH_ERR: Raised if the value type for this parameter name is incompatible with the expected value type.

      • getParameter

        Object getParameter(String name)
                    throws DOMException
        Return the value of a parameter if known.
        参数：
        name - The name of the parameter.
        返回：
        The current object associated with the specified parameter or null if no object has been associated or if the parameter is not supported.
        抛出：
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.

      • canSetParameter

        boolean canSetParameter(String name,
                      Object value)
        Check if setting a parameter to a specific value is supported.
        参数：
        name - The name of the parameter to check.
        value - An object. if null, the returned value is true.
        返回：
        true if the parameter could be successfully set to the specified value, or false if the parameter is not recognized or the requested value is not supported. This does not change the current value of the parameter itself.

      • getParameterNames

        DOMStringList getParameterNames()
        The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application. Note that this list can also contain parameter names defined outside this specification.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>h>g�&p-"


DOMError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMError

  • public interface DOMError
    DOMError is an interface that describes an error.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short SEVERITY_ERROR
      The severity of the error described by the DOMError is error.
      static short SEVERITY_FATAL_ERROR
      The severity of the error described by the DOMError is fatal error.
      static short SEVERITY_WARNING
      The severity of the error described by the DOMError is warning.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DOMLocator getLocation()
      The location of the error.
      String getMessage()
      An implementation specific string describing the error that occurred.
      Object getRelatedData()
      The related DOMError.type dependent data if any.
      Object getRelatedException()
      The related platform dependent exception if any.
      short getSeverity()
      The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.
      String getType()
      A DOMString indicating which related data is expected in relatedData.

    • 字段详细信息

      • SEVERITY_WARNING

        static final short SEVERITY_WARNING
        The severity of the error described by the DOMError is warning. A SEVERITY_WARNING will not cause the processing to stop, unless DOMErrorHandler.handleError() returns false.
        另请参见：
        Constant Field Values

      • SEVERITY_ERROR

        static final short SEVERITY_ERROR
        The severity of the error described by the DOMError is error. A SEVERITY_ERROR may not cause the processing to stop if the error can be recovered, unless DOMErrorHandler.handleError() returns false.
        另请参见：
        Constant Field Values

      • SEVERITY_FATAL_ERROR

        static final short SEVERITY_FATAL_ERROR
        The severity of the error described by the DOMError is fatal error. A SEVERITY_FATAL_ERROR will cause the normal processing to stop. The return value of DOMErrorHandler.handleError() is ignored unless the implementation chooses to continue, in which case the behavior becomes undefined.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getSeverity

        short getSeverity()
        The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

      • getMessage

        String getMessage()
        An implementation specific string describing the error that occurred.

      • getType

        String getType()
        A DOMString indicating which related data is expected in relatedData. Users should refer to the specification of the error in order to find its DOMString type and relatedData definitions if any.

        Note: As an example, Document.normalizeDocument() does generate warnings when the "split-cdata-sections" parameter is in use. Therefore, the method generates a SEVERITY_WARNING with type "cdata-sections-splitted" and the first CDATASection node in document order resulting from the split is returned by the relatedData attribute.

      • getRelatedException

        Object getRelatedException()
        The related platform dependent exception if any.

      • getRelatedData

        Object getRelatedData()
        The related DOMError.type dependent data if any.

      • getLocation

        DOMLocator getLocation()
        The location of the error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

neatT A eCC eencTTo >ioot


DOMErrorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMErrorHandler

  • public interface DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g. validating a document). A DOMErrorHandler object can be attached to a Document using the "error-handler" on the DOMConfiguration interface. If more than one error needs to be reported during an operation, the sequence and numbers of the errors passed to the error handler are implementation dependent.

    The application that is using the DOM implementation is expected to implement this interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean handleError(DOMError error)
      This method is called on the error handler when an error occurs.

    • 方法详细信息

      • handleError

        boolean handleError(DOMError error)
        This method is called on the error handler when an error occurs.
        If an exception is thrown from this method, it is considered to be equivalent of returning true.
        参数：
        error - The error object that describes the error. This object may be reused by the DOM implementation across multiple calls to the handleError method.
        返回：
        If the handleError method returns false, the DOM implementation should stop the current processing when possible. If the method returns true, the processing may continue depending on DOMError.severity.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

es tmydaydoeedooORAA vc eoderreers


DOMException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.w3c.dom

类 DOMException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException
  • 所有已实现的接口：
    Serializable

    public class DOMException
extends RuntimeException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable). In general, DOM methods return specific error values in ordinary processing situations, such as out-of-bound errors when using NodeList.

    Implementations should raise other exceptions under other circumstances. For example, implementations should raise an implementation-dependent exception if a null argument is passed when null was not expected.

    Some languages and object systems do not support the concept of exceptions. For such systems, error conditions may be indicated using native error reporting mechanisms. For some bindings, for example, methods may return error codes similar to those listed in the corresponding method descriptions.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short | code
      static short DOMSTRING_SIZE_ERR
      If the specified range of text does not fit into a DOMString.
      static short HIERARCHY_REQUEST_ERR
      If any Node is inserted somewhere it doesn't belong.
      static short INDEX_SIZE_ERR
      If index or size is negative, or greater than the allowed value.
      static short INUSE_ATTRIBUTE_ERR
      If an attempt is made to add an attribute that is already in use elsewhere.
      static short INVALID_ACCESS_ERR
      If a parameter or an operation is not supported by the underlying object.
      static short INVALID_CHARACTER_ERR
      If an invalid or illegal character is specified, such as in an XML name.
      static short INVALID_MODIFICATION_ERR
      If an attempt is made to modify the type of the underlying object.
      static short INVALID_STATE_ERR
      If an attempt is made to use an object that is not, or is no longer, usable.
      static short NAMESPACE_ERR
      If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
      static short NO_DATA_ALLOWED_ERR
      If data is specified for a Node which does not support data.
      static short NO_MODIFICATION_ALLOWED_ERR
      If an attempt is made to modify an object where modifications are not allowed.
      static short NOT_FOUND_ERR
      If an attempt is made to reference a Node in a context where it does not exist.
      static short NOT_SUPPORTED_ERR
      If the implementation does not support the requested type of object or operation.
      static short SYNTAX_ERR
      If an invalid or illegal string is specified.
      static short TYPE_MISMATCH_ERR
      If the type of an object is incompatible with the expected type of the parameter associated to the object.
      static short VALIDATION_ERR
      If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.
      static short WRONG_DOCUMENT_ERR
      If a Node is used in a different document than the one that created it (that doesn't support it).

    • 构造方法摘要

      Constructors
      构造方法与描述
      DOMException(short code, String message)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • code

        public short code

      • INDEX_SIZE_ERR

        public static final short INDEX_SIZE_ERR
        If index or size is negative, or greater than the allowed value.
        另请参见：
        Constant Field Values

      • DOMSTRING_SIZE_ERR

        public static final short DOMSTRING_SIZE_ERR
        If the specified range of text does not fit into a DOMString.
        另请参见：
        Constant Field Values

      • HIERARCHY_REQUEST_ERR

        public static final short HIERARCHY_REQUEST_ERR
        If any Node is inserted somewhere it doesn't belong.
        另请参见：
        Constant Field Values

      • WRONG_DOCUMENT_ERR

        public static final short WRONG_DOCUMENT_ERR
        If a Node is used in a different document than the one that created it (that doesn't support it).
        另请参见：
        Constant Field Values

      • INVALID_CHARACTER_ERR

        public static final short INVALID_CHARACTER_ERR
        If an invalid or illegal character is specified, such as in an XML name.
        另请参见：
        Constant Field Values

      • NO_DATA_ALLOWED_ERR

        public static final short NO_DATA_ALLOWED_ERR
        If data is specified for a Node which does not support data.
        另请参见：
        Constant Field Values

      • NO_MODIFICATION_ALLOWED_ERR

        public static final short NO_MODIFICATION_ALLOWED_ERR
        If an attempt is made to modify an object where modifications are not allowed.
        另请参见：
        Constant Field Values

      • NOT_FOUND_ERR

        public static final short NOT_FOUND_ERR
        If an attempt is made to reference a Node in a context where it does not exist.
        另请参见：
        Constant Field Values

      • NOT_SUPPORTED_ERR

        public static final short NOT_SUPPORTED_ERR
        If the implementation does not support the requested type of object or operation.
        另请参见：
        Constant Field Values

      • INUSE_ATTRIBUTE_ERR

        public static final short INUSE_ATTRIBUTE_ERR
        If an attempt is made to add an attribute that is already in use elsewhere.
        另请参见：
        Constant Field Values

      • INVALID_STATE_ERR

        public static final short INVALID_STATE_ERR
        If an attempt is made to use an object that is not, or is no longer, usable.
        从以下版本开始：
        DOM Level 2
        另请参见：
        Constant Field Values

      • SYNTAX_ERR

        public static final short SYNTAX_ERR
        If an invalid or illegal string is specified.
        从以下版本开始：
        DOM Level 2
        另请参见：
        Constant Field Values

      • INVALID_MODIFICATION_ERR

        public static final short INVALID_MODIFICATION_ERR
        If an attempt is made to modify the type of the underlying object.
        从以下版本开始：
        DOM Level 2
        另请参见：
        Constant Field Values

      • NAMESPACE_ERR

        public static final short NAMESPACE_ERR
        If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
        从以下版本开始：
        DOM Level 2
        另请参见：
        Constant Field Values

      • INVALID_ACCESS_ERR

        public static final short INVALID_ACCESS_ERR
        If a parameter or an operation is not supported by the underlying object.
        从以下版本开始：
        DOM Level 2
        另请参见：
        Constant Field Values

      • VALIDATION_ERR

        public static final short VALIDATION_ERR
        If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done. This code is used in [DOM Level 3 Validation] . Refer to this specification for further information.
        从以下版本开始：
        DOM Level 3
        另请参见：
        Constant Field Values

      • TYPE_MISMATCH_ERR

        public static final short TYPE_MISMATCH_ERR
        If the type of an object is incompatible with the expected type of the parameter associated to the object.
        从以下版本开始：
        DOM Level 3
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • DOMException

        public DOMException(short code,
            String message)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>d癮aa<>>>kpt9krtm�2ie11fe=


DOMImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMImplementation

  • public interface DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Document createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.
      boolean hasFeature(String feature, String version)
      Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.

    • 方法详细信息

      • hasFeature

        boolean hasFeature(String feature,
                 String version)
        Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.
        参数：
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        返回：
        true if the feature is implemented in the specified version, false otherwise.

      • createDocumentType

        DocumentType createDocumentType(String qualifiedName,
                              String publicId,
                              String systemId)
                                throws DOMException
        Creates an empty DocumentType node. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur..
        参数：
        qualifiedName - The qualified name of the document type to be created.
        publicId - The external subset public identifier.
        systemId - The external subset system identifier.
        返回：
        A new DocumentType node with Node.ownerDocument set to null.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • createDocument

        Document createDocument(String namespaceURI,
                      String qualifiedName,
                      DocumentType doctype)
                        throws DOMException
        Creates a DOM Document object of the specified type with its document element.
        Note that based on the DocumentType given to create the document, the implementation may instantiate specialized Document objects that support additional features than the "Core", such as "HTML" [DOM Level 2 HTML] . On the other hand, setting the DocumentType after the document was created makes this very unlikely to happen. Alternatively, specialized Document creation methods, such as createHTMLDocument [DOM Level 2 HTML] , can be used to obtain specific types of Document objects.
        参数：
        namespaceURI - The namespace URI of the document element to create or null.
        qualifiedName - The qualified name of the document element to be created or null.
        doctype - The type of document to be created or null. When doctype is not null, its Node.ownerDocument attribute is set to the document being created.
        返回：
        A new Document object with its document element. If the NamespaceURI, qualifiedName, and doctype are null, the returned Document is empty with no document element.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName is null and the namespaceURI is different from null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the DOM implementation does not support the "XML" feature but a non-null namespace URI was provided, since namespaces were defined by XML.
        WRONG_DOCUMENT_ERR: Raised if doctype has already been used with a different document or was created from a different implementation.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • getFeature

        Object getFeature(String feature,
                String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features. The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the DOMImplementation interface.
        参数：
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        返回：
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the DOMImplementation interface, it must delegate to the primary core DOMImplementation and not return results inconsistent with the primary core DOMImplementation such as hasFeature, getFeature, etc.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

u en/......//...r<<>llc .".


DOMImplementationList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMImplementationList

  • public interface DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented. The items in the DOMImplementationList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getLength()
      The number of DOMImplementations in the list.
      DOMImplementation item(int index)
      Returns the indexth item in the collection.

    • 方法详细信息

      • item

        DOMImplementation item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMImplementations in the list, this returns null.
        参数：
        index - Index into the collection.
        返回：
        The DOMImplementation at the index th position in the DOMImplementationList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMImplementations in the list. The range of valid child node indices is 0 to length-1 inclusive.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

addafu au d ddneyye>Ted>nnedn dl


DOMImplementationSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMImplementationSource

  • public interface DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features. Each implemented DOMImplementationSource object is listed in the binding-specific list of available sources so that its DOMImplementation objects are made available.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DOMImplementation getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementationList getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • 方法详细信息

      • getDOMImplementation

        DOMImplementation getDOMImplementation(String features)
        A method to request the first DOM implementation that supports the specified features.
        参数：
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This method returns the first item of the list returned by getDOMImplementationList. As an example, the string "XML 3.0 Traversal +Events 2.0" will request a DOM implementation that supports the module "XML" for its 3.0 version, a module that support of the "Traversal" module for any version, and the module "Events" for its 2.0 version. The module "Events" must be accessible using the method Node.getFeature() and DOMImplementation.getFeature().
        返回：
        The first DOM implementation that support the desired features, or null if this source has none.

      • getDOMImplementationList

        DOMImplementationList getDOMImplementationList(String features)
        A method to request a list of DOM implementations that support the specified features and versions, as specified in .
        参数：
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 3.0 Traversal +Events 2.0"
        返回：
        A list of DOM implementations that support the desired features.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

mtpctom oucmmuccOa==ti=tpn t hm<


DOMLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMLocator

  • public interface DOMLocator
    DOMLocator is an interface that describes a location (e.g. where an error occurred).

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getByteOffset()
      The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.
      int getColumnNumber()
      The column number this locator is pointing to, or -1 if there is no column number available.
      int getLineNumber()
      The line number this locator is pointing to, or -1 if there is no column number available.
      Node getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      String getUri()
      The URI this locator is pointing to, or null if no URI is available.
      int getUtf16Offset()
      The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

    • 方法详细信息

      • getLineNumber

        int getLineNumber()
        The line number this locator is pointing to, or -1 if there is no column number available.

      • getColumnNumber

        int getColumnNumber()
        The column number this locator is pointing to, or -1 if there is no column number available.

      • getByteOffset

        int getByteOffset()
        The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

      • getUtf16Offset

        int getUtf16Offset()
        The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

      • getRelatedNode

        Node getRelatedNode()
        The node this locator is pointing to, or null if no node is available.

      • getUri

        String getUri()
        The URI this locator is pointing to, or null if no URI is available.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l"onnattalpeelpphuaaem/elnreae


DOMStringList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface DOMStringList

  • public interface DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented. The items in the DOMStringList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(String str)
      Test if a string is part of this DOMStringList.
      int getLength()
      The number of DOMStrings in the list.
      String item(int index)
      Returns the indexth item in the collection.

    • 方法详细信息

      • item

        String item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMStrings in the list, this returns null.
        参数：
        index - Index into the collection.
        返回：
        The DOMString at the indexth position in the DOMStringList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMStrings in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a string is part of this DOMStringList.
        参数：
        str - The string to look for.
        返回：
        true if the string has been found, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

sysa ataaa"llasslisslial_


Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Element

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
    All Known Implementing Classes:
    IIOMetadataNode

    public interface Element
extends Node
    The Element interface represents an element in an HTML or XML document. Elements may have attributes associated with them; since the Element interface inherits from Node, the generic Node interface attribute attributes may be used to retrieve the set of all attributes for an element. There are methods on the Element interface to retrieve either an Attr object by name or an attribute value by name. In XML, where an attribute value may contain entity references, an Attr object should be retrieved to examine the possibly fairly complex sub-tree representing the attribute value. On the other hand, in HTML, where all attributes have simple string values, methods to directly access an attribute value can safely be used as a convenience.

    Note: In DOM Level 2, the method normalize is inherited from the Node interface where it was moved.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getAttribute(String name)
      Retrieves an attribute value by name.
      Attr getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      NodeList getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this element.
      String getTagName()
      The name of the element.
      boolean hasAttribute(String name)
      Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
      boolean hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      void removeAttribute(String name)
      Removes an attribute by name.
      Attr removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      void setAttribute(String name, String value)
      Adds a new attribute.
      Attr setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getTagName

        String getTagName()
        The name of the element. If Node.localName is different from null, this attribute is a qualified name. For example, in:
         <elementExample id="demo"> ...
 </elementExample> ,
        tagName has the value "elementExample". Note that this is case-preserving in XML, as are all of the operations of the DOM. The HTML DOM returns the tagName of an HTML element in the canonical uppercase form, regardless of the case in the source HTML document.

      • getAttribute

        String getAttribute(String name)
        Retrieves an attribute value by name.
        参数：
        name - The name of the attribute to retrieve.
        返回：
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.

      • setAttribute

        void setAttribute(String name,
                String value)
                  throws DOMException
        Adds a new attribute. If an attribute with that name is already present in the element, its value is changed to be that of the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNode to assign it as the value of an attribute.
        To set an attribute with a qualified name and namespace URI, use the setAttributeNS method.
        参数：
        name - The name of the attribute to create or alter.
        value - Value to set in string form.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • removeAttribute

        void removeAttribute(String name)
                     throws DOMException
        Removes an attribute by name. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this name is found, this method has no effect.
        To remove an attribute by local name and namespace URI, use the removeAttributeNS method.
        参数：
        name - The name of the attribute to remove.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • getAttributeNode

        Attr getAttributeNode(String name)
        Retrieves an attribute node by name.
        To retrieve an attribute node by qualified name and namespace URI, use the getAttributeNodeNS method.
        参数：
        name - The name (nodeName) of the attribute to retrieve.
        返回：
        The Attr node with the specified name ( nodeName) or null if there is no such attribute.

      • setAttributeNode

        Attr setAttributeNode(Attr newAttr)
                      throws DOMException
        Adds a new attribute node. If an attribute with that name ( nodeName) is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        To add a new attribute node with a qualified name and namespace URI, use the setAttributeNodeNS method.
        参数：
        newAttr - The Attr node to add to the attribute list.
        返回：
        If the newAttr attribute replaces an existing attribute, the replaced Attr node is returned, otherwise null is returned.
        抛出：
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.

      • removeAttributeNode

        Attr removeAttributeNode(Attr oldAttr)
                         throws DOMException
        Removes the specified attribute node. If a default value for the removed Attr node is defined in the DTD, a new node immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        参数：
        oldAttr - The Attr node to remove from the attribute list.
        返回：
        The Attr node that was removed.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldAttr is not an attribute of the element.

      • getElementsByTagName

        NodeList getElementsByTagName(String name)
        Returns a NodeList of all descendant Elements with a given tag name, in document order.
        参数：
        name - The name of the tag to match on. The special value "*" matches all tags.
        返回：
        A list of matching Element nodes.

      • getAttributeNS

        String getAttributeNS(String namespaceURI,
                    String localName)
                      throws DOMException
        Retrieves an attribute value by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        返回：
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • setAttributeNS

        void setAttributeNS(String namespaceURI,
                  String qualifiedName,
                  String value)
                    throws DOMException
        Adds a new attribute. If an attribute with the same local name and namespace URI is already present on the element, its prefix is changed to be the prefix part of the qualifiedName, and its value is changed to be the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNodeNS or setAttributeNode to assign it as the value of an attribute.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to create or alter.
        qualifiedName - The qualified name of the attribute to create or alter.
        value - The value to set in string form.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the qualifiedName is malformed per the Namespaces in XML specification, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • removeAttributeNS

        void removeAttributeNS(String namespaceURI,
                     String localName)
                       throws DOMException
        Removes an attribute by local name and namespace URI. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this local name and namespace URI is found, this method has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to remove.
        localName - The local name of the attribute to remove.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • getAttributeNodeNS

        Attr getAttributeNodeNS(String namespaceURI,
                      String localName)
                        throws DOMException
        Retrieves an Attr node by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        返回：
        The Attr node with the specified attribute local name and namespace URI or null if there is no such attribute.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • setAttributeNodeNS

        Attr setAttributeNodeNS(Attr newAttr)
                        throws DOMException
        Adds a new attribute. If an attribute with that local name and that namespace URI is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        newAttr - The Attr node to add to the attribute list.
        返回：
        If the newAttr attribute replaces an existing attribute with the same local name and namespace URI, the replaced Attr node is returned, otherwise null is returned.
        抛出：
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                              String localName)
                                throws DOMException
        Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
        参数：
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        返回：
        A new NodeList object containing all the matched Elements.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • hasAttribute

        boolean hasAttribute(String name)
        Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
        参数：
        name - The name of the attribute to look for.
        返回：
        true if an attribute with the given name is specified on this element or has a default value, false otherwise.
        从以下版本开始：
        DOM Level 2

      • hasAttributeNS

        boolean hasAttributeNS(String namespaceURI,
                     String localName)
                       throws DOMException
        Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the attribute to look for.
        localName - The local name of the attribute to look for.
        返回：
        true if an attribute with the given local name and namespace URI is specified or has a default value on this element, false otherwise.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this element.
        从以下版本开始：
        DOM Level 3

      • setIdAttribute

        void setIdAttribute(String name,
                  boolean isId)
                    throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        To specify an attribute by local name and namespace URI, use the setIdAttributeNS method.
        参数：
        name - The name of the attribute.
        isId - Whether the attribute is a of type ID.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        从以下版本开始：
        DOM Level 3

      • setIdAttributeNS

        void setIdAttributeNS(String namespaceURI,
                    String localName,
                    boolean isId)
                      throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        参数：
        namespaceURI - The namespace URI of the attribute.
        localName - The local name of the attribute.
        isId - Whether the attribute is a of type ID.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        从以下版本开始：
        DOM Level 3

      • setIdAttributeNode

        void setIdAttributeNode(Attr idAttr,
                      boolean isId)
                        throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        参数：
        idAttr - The attribute node.
        isId - Whether the attribute is a of type ID.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Entity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Entity

  • All Superinterfaces:
    Node

    public interface Entity
extends Node
    This interface represents a known entity, either parsed or unparsed, in an XML document. Note that this models the entity itself not the entity declaration.

    The nodeName attribute that is inherited from Node contains the name of the entity.

    An XML processor may choose to completely expand entities before the structure model is passed to the DOM; in this case there will be no EntityReference nodes in the document tree.

    XML does not mandate that a non-validating XML processor read and process entity declarations made in the external subset or declared in parameter entities. This means that parsed entities declared in the external subset need not be expanded by some classes of applications, and that the replacement text of the entity may not be available. When the replacement text is available, the corresponding Entity node's child list represents the structure of that replacement value. Otherwise, the child list is empty.

    DOM Level 3 does not support editing Entity nodes; if a user wants to make changes to the contents of an Entity, every related EntityReference node has to be replaced in the structure model by a clone of the Entity's contents, and then the desired changes must be made to each of those clones instead. Entity nodes and all their descendants are readonly.

    An Entity node does not have any parent.

    Note: If the entity contains an unbound namespace prefix, the namespaceURI of the corresponding node in the Entity node subtree is null. The same is true for EntityReference nodes that refer to this entity, when they are created using the createEntityReference method of the Document interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getInputEncoding()
      An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.
      String getNotationName()
      For unparsed entities, the name of the notation for the entity.
      String getPublicId()
      The public identifier associated with the entity if specified, and null otherwise.
      String getSystemId()
      The system identifier associated with the entity if specified, and null otherwise.
      String getXmlEncoding()
      An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.
      String getXmlVersion()
      An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getPublicId

        String getPublicId()
        The public identifier associated with the entity if specified, and null otherwise.

      • getSystemId

        String getSystemId()
        The system identifier associated with the entity if specified, and null otherwise. This may be an absolute URI or not.

      • getNotationName

        String getNotationName()
        For unparsed entities, the name of the notation for the entity. For parsed entities, this is null.

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is null if it an entity from the internal subset or if it is not known.
        从以下版本开始：
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is null otherwise.
        从以下版本开始：
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is null otherwise.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/eo=ah> h>a,,>aaia..a>ma/>>ewe


EntityReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method
org.w3c.dom

Interface EntityReference

  • All Superinterfaces:
    Node

    public interface EntityReference
extends Node
    EntityReference nodes may be used to represent an entity reference in the tree. Note that character references and references to predefined entities are considered to be expanded by the HTML or XML processor so that characters are represented by their Unicode equivalent rather than by an entity reference. Moreover, the XML processor may completely expand references to entities while building the Document, instead of providing EntityReference nodes. If it does provide such nodes, then for an EntityReference node that represents a reference to a known entity an Entity exists, and the subtree of the EntityReference node is a copy of the Entity node subtree. However, the latter may not be true when an entity contains an unbound namespace prefix. In such a case, because the namespace prefix resolution depends on where the entity reference is, the descendants of the EntityReference node may be bound to different namespace URIs. When an EntityReference node represents a reference to an unknown entity, the node has no children and its replacement value, when used by Attr.value for example, is empty.

    As for Entity nodes, EntityReference nodes and all their descendants are readonly.

    Note: EntityReference nodes may cause element content and attribute value normalization problems when, such as in XML 1.0 and XML Schema, the normalization is performed after entity reference are expanded.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • Method
  • 详细信息：
  • 字段 |
  • Constr |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/dNr.../.."...""h/""gikoua<.e)


NamedNodeMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface NamedNodeMap

  • public interface NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name. Note that NamedNodeMap does not inherit from NodeList; NamedNodeMaps are not maintained in any particular order. Objects contained in an object implementing NamedNodeMap may also be accessed by an ordinal index, but this is simply to allow convenient enumeration of the contents of a NamedNodeMap, and does not imply that the DOM specifies an order to these Nodes.

    NamedNodeMap objects in the DOM are live.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getLength()
      The number of nodes in this map.
      Node getNamedItem(String name)
      Retrieves a node specified by name.
      Node getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node item(int index)
      Returns the indexth item in the map.
      Node removeNamedItem(String name)
      Removes a node specified by name.
      Node removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • 方法详细信息

      • getNamedItem

        Node getNamedItem(String name)
        Retrieves a node specified by name.
        参数：
        name - The nodeName of a node to retrieve.
        返回：
        A Node (of any type) with the specified nodeName, or null if it does not identify any node in this map.

      • setNamedItem

        Node setNamedItem(Node arg)
                  throws DOMException
        Adds a node using its nodeName attribute. If a node with that name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        As the nodeName attribute is used to derive the name which the node must be stored under, multiple nodes of certain types (those that have a "special" string value) cannot be stored as the names would clash. This is seen as preferable to allowing nodes to be aliased.
        参数：
        arg - A node to store in this map. The node will later be accessible using the value of its nodeName attribute.
        返回：
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        抛出：
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.

      • removeNamedItem

        Node removeNamedItem(String name)
                     throws DOMException
        Removes a node specified by name. When this map contains the attributes attached to an element, if the removed attribute is known to have a default value, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        参数：
        name - The nodeName of the node to remove.
        返回：
        The node removed from this map if a node with such a name exists.
        抛出：
        DOMException - NOT_FOUND_ERR: Raised if there is no node named name in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.

      • item

        Node item(int index)
        Returns the indexth item in the map. If index is greater than or equal to the number of nodes in this map, this returns null.
        参数：
        index - Index into this map.
        返回：
        The node at the indexth position in the map, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in this map. The range of valid child node indices is 0 to length-1 inclusive.

      • getNamedItemNS

        Node getNamedItemNS(String namespaceURI,
                  String localName)
                    throws DOMException
        Retrieves a node specified by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the node to retrieve.
        localName - The local name of the node to retrieve.
        返回：
        A Node (of any type) with the specified local name and namespace URI, or null if they do not identify any node in this map.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • setNamedItemNS

        Node setNamedItemNS(Node arg)
                    throws DOMException
        Adds a node using its namespaceURI and localName. If a node with that namespace URI and that local name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        arg - A node to store in this map. The node will later be accessible using the value of its namespaceURI and localName attributes.
        返回：
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        抛出：
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2

      • removeNamedItemNS

        Node removeNamedItemNS(String namespaceURI,
                     String localName)
                       throws DOMException
        Removes a node specified by local name and namespace URI. A removed attribute may be known to have a default value when this map contains the attributes attached to an element, as returned by the attributes attribute of the Node interface. If so, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        参数：
        namespaceURI - The namespace URI of the node to remove.
        localName - The local name of the node to remove.
        返回：
        The node removed from this map if a node with such a local name and namespace URI exists.
        抛出：
        DOMException - NOT_FOUND_ERR: Raised if there is no node with the specified namespaceURI and localName in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        从以下版本开始：
        DOM Level 2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/|t>/=//<>>ee>>.=t/hfohauv


NameList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface NameList

  • public interface NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented. The items in the NameList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean contains(String str)
      Test if a name is part of this NameList.
      boolean containsNS(String namespaceURI, String name)
      Test if the pair namespaceURI/name is part of this NameList.
      int getLength()
      The number of pairs (name and namespaceURI) in the list.
      String getName(int index)
      Returns the indexth name item in the collection.
      String getNamespaceURI(int index)
      Returns the indexth namespaceURI item in the collection.

    • 方法详细信息

      • getName

        String getName(int index)
        Returns the indexth name item in the collection.
        参数：
        index - Index into the collection.
        返回：
        The name at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getNamespaceURI

        String getNamespaceURI(int index)
        Returns the indexth namespaceURI item in the collection.
        参数：
        index - Index into the collection.
        返回：
        The namespace URI at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getLength

        int getLength()
        The number of pairs (name and namespaceURI) in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a name is part of this NameList.
        参数：
        str - The name to look for.
        返回：
        true if the name has been found, false otherwise.

      • containsNS

        boolean containsNS(String namespaceURI,
                 String name)
        Test if the pair namespaceURI/name is part of this NameList.
        参数：
        namespaceURI - The namespace URI to look for.
        name - The name to look for.
        返回：
        true if the pair namespaceURI/name has been found, false otherwise.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Node

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Node

  • All Known Subinterfaces:
    Attr, CDATASection, CharacterData, Comment, Detail, DetailEntry, Document, DocumentFragment, DocumentType, Element, Entity, EntityReference, Node, Notation, ProcessingInstruction, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text, Text
    All Known Implementing Classes:
    IIOMetadataNode, SOAPPart

    public interface Node
    The Node interface is the primary datatype for the entire Document Object Model. It represents a single node in the document tree. While all objects implementing the Node interface expose methods for dealing with children, not all objects implementing the Node interface may have children. For example, Text nodes may not have children, and adding children to such nodes results in a DOMException being raised.

    The attributes nodeName, nodeValue and attributes are included as a mechanism to get at node information without casting down to the specific derived interface. In cases where there is no obvious mapping of these attributes for a specific nodeType (e.g., nodeValue for an Element or attributes for a Comment ), this returns null. Note that the specialized interfaces may contain additional and more convenient mechanisms to get and set the relevant information.

    The values of nodeName, nodeValue, and attributes vary according to the node type as follows:

    接口 | nodeName | nodeValue | attributes
    Attr | same as Attr.name | same as Attr.value | null
    CDATASection | "#cdata-section" | same as CharacterData.data, the content of the CDATA Section | null
    Comment | "#comment" | same as CharacterData.data, the content of the comment | null
    Document | "#document" | null | null
    DocumentFragment | "#document-fragment" | null | null
    DocumentType | same as DocumentType.name | null | null
    Element | same as Element.tagName | null | NamedNodeMap
    Entity | entity name | null | null
    EntityReference | name of entity referenced | null | null
    Notation | notation name | null | null
    ProcessingInstruction | same as ProcessingInstruction.target | same as ProcessingInstruction.data | null
    Text | "#text" | same as CharacterData.data, the content of the text node | null

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short ATTRIBUTE_NODE
      The node is an Attr.
      static short CDATA_SECTION_NODE
      The node is a CDATASection.
      static short COMMENT_NODE
      The node is a Comment.
      static short DOCUMENT_FRAGMENT_NODE
      The node is a DocumentFragment.
      static short DOCUMENT_NODE
      The node is a Document.
      static short DOCUMENT_POSITION_CONTAINED_BY
      The node is contained by the reference node.
      static short DOCUMENT_POSITION_CONTAINS
      The node contains the reference node.
      static short DOCUMENT_POSITION_DISCONNECTED
      The two nodes are disconnected.
      static short DOCUMENT_POSITION_FOLLOWING
      The node follows the reference node.
      static short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
      The determination of preceding versus following is implementation-specific.
      static short DOCUMENT_POSITION_PRECEDING
      The second node precedes the reference node.
      static short DOCUMENT_TYPE_NODE
      The node is a DocumentType.
      static short ELEMENT_NODE
      The node is an Element.
      static short ENTITY_NODE
      The node is an Entity.
      static short ENTITY_REFERENCE_NODE
      The node is an EntityReference.
      static short NOTATION_NODE
      The node is a Notation.
      static short PROCESSING_INSTRUCTION_NODE
      The node is a ProcessingInstruction.
      static short TEXT_NODE
      The node is a Text node.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Node appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      short compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      NamedNodeMap getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      String getBaseURI()
      The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.
      NodeList getChildNodes()
      A NodeList that contains all children of this node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .
      Node getFirstChild()
      The first child of this node.
      Node getLastChild()
      The last child of this node.
      String getLocalName()
      Returns the local part of the qualified name of this node.
      String getNamespaceURI()
      The namespace URI of this node, or null if it is unspecified (see ).
      Node getNextSibling()
      The node immediately following this node.
      String getNodeName()
      The name of this node, depending on its type; see the table above.
      short getNodeType()
      A code representing the type of the underlying object, as defined above.
      String getNodeValue()
      The value of this node, depending on its type; see the table above.
      Document getOwnerDocument()
      The Document object associated with this node.
      Node getParentNode()
      The parent of this node.
      String getPrefix()
      The namespace prefix of this node, or null if it is unspecified.
      Node getPreviousSibling()
      The node immediately preceding this node.
      String getTextContent()
      This attribute returns the text content of this node and its descendants.
      Object getUserData(String key)
      Retrieves the object associated to a key on a this node.
      boolean hasAttributes()
      Returns whether this node (if it is an element) has any attributes.
      boolean hasChildNodes()
      Returns whether this node has any children.
      Node insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean isDefaultNamespace(String namespaceURI)
      This method checks if the specified namespaceURI is the default namespace or not.
      boolean isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      boolean isSupported(String feature, String version)
      Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
      String lookupNamespaceURI(String prefix)
      Look up the namespace URI associated to the given prefix, starting from this node.
      String lookupPrefix(String namespaceURI)
      Look up the prefix associated to the given namespace URI, starting from this node.
      void normalize()
      Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
      Node removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      Object setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.

    • 字段详细信息

      • ELEMENT_NODE

        static final short ELEMENT_NODE
        The node is an Element.
        另请参见：
        Constant Field Values

      • ATTRIBUTE_NODE

        static final short ATTRIBUTE_NODE
        The node is an Attr.
        另请参见：
        Constant Field Values

      • TEXT_NODE

        static final short TEXT_NODE
        The node is a Text node.
        另请参见：
        Constant Field Values

      • CDATA_SECTION_NODE

        static final short CDATA_SECTION_NODE
        The node is a CDATASection.
        另请参见：
        Constant Field Values

      • ENTITY_REFERENCE_NODE

        static final short ENTITY_REFERENCE_NODE
        The node is an EntityReference.
        另请参见：
        Constant Field Values

      • ENTITY_NODE

        static final short ENTITY_NODE
        The node is an Entity.
        另请参见：
        Constant Field Values

      • PROCESSING_INSTRUCTION_NODE

        static final short PROCESSING_INSTRUCTION_NODE
        The node is a ProcessingInstruction.
        另请参见：
        Constant Field Values

      • COMMENT_NODE

        static final short COMMENT_NODE
        The node is a Comment.
        另请参见：
        Constant Field Values

      • DOCUMENT_NODE

        static final short DOCUMENT_NODE
        The node is a Document.
        另请参见：
        Constant Field Values

      • DOCUMENT_TYPE_NODE

        static final short DOCUMENT_TYPE_NODE
        The node is a DocumentType.
        另请参见：
        Constant Field Values

      • DOCUMENT_FRAGMENT_NODE

        static final short DOCUMENT_FRAGMENT_NODE
        The node is a DocumentFragment.
        另请参见：
        Constant Field Values

      • NOTATION_NODE

        static final short NOTATION_NODE
        The node is a Notation.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_DISCONNECTED

        static final short DOCUMENT_POSITION_DISCONNECTED
        The two nodes are disconnected. Order between disconnected nodes is always implementation-specific.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_PRECEDING

        static final short DOCUMENT_POSITION_PRECEDING
        The second node precedes the reference node.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_FOLLOWING

        static final short DOCUMENT_POSITION_FOLLOWING
        The node follows the reference node.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINS

        static final short DOCUMENT_POSITION_CONTAINS
        The node contains the reference node. A node which contains is always preceding, too.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINED_BY

        static final short DOCUMENT_POSITION_CONTAINED_BY
        The node is contained by the reference node. A node which is contained is always following, too.
        另请参见：
        Constant Field Values

      • DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

        static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
        The determination of preceding versus following is implementation-specific.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getNodeName

        String getNodeName()
        The name of this node, depending on its type; see the table above.

      • getNodeValue

        String getNodeValue()
                    throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        抛出：
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setNodeValue

        void setNodeValue(String nodeValue)
                  throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly and if it is not defined to be null.

      • getNodeType

        short getNodeType()
        A code representing the type of the underlying object, as defined above.

      • getParentNode

        Node getParentNode()
        The parent of this node. All nodes, except Attr, Document, DocumentFragment, Entity, and Notation may have a parent. However, if a node has just been created and not yet added to the tree, or if it has been removed from the tree, this is null.

      • getChildNodes

        NodeList getChildNodes()
        A NodeList that contains all children of this node. If there are no children, this is a NodeList containing no nodes.

      • getFirstChild

        Node getFirstChild()
        The first child of this node. If there is no such node, this returns null.

      • getLastChild

        Node getLastChild()
        The last child of this node. If there is no such node, this returns null.

      • getPreviousSibling

        Node getPreviousSibling()
        The node immediately preceding this node. If there is no such node, this returns null.

      • getNextSibling

        Node getNextSibling()
        The node immediately following this node. If there is no such node, this returns null.

      • getAttributes

        NamedNodeMap getAttributes()
        A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

      • getOwnerDocument

        Document getOwnerDocument()
        The Document object associated with this node. This is also the Document object used to create new nodes. When this node is a Document or a DocumentType which is not used with any Document yet, this is null.
        从以下版本开始：
        DOM Level 2

      • insertBefore

        Node insertBefore(Node newChild,
                Node refChild)
                  throws DOMException
        Inserts the node newChild before the existing child node refChild. If refChild is null, insert newChild at the end of the list of children.
        If newChild is a DocumentFragment object, all of its children are inserted, in the same order, before refChild. If the newChild is already in the tree, it is first removed.

        Note: Inserting a node before itself is implementation dependent.

        参数：
        newChild - The node to insert.
        refChild - The reference node, i.e., the node before which the new node must be inserted.
        返回：
        The node being inserted.
        抛出：
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to insert is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to insert a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the parent of the node being inserted is readonly.
        NOT_FOUND_ERR: Raised if refChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the insertion of a DocumentType or Element node.
        从以下版本开始：
        DOM Level 3

      • replaceChild

        Node replaceChild(Node newChild,
                Node oldChild)
                  throws DOMException
        Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
        If newChild is a DocumentFragment object, oldChild is replaced by all of the DocumentFragment children, which are inserted in the same order. If the newChild is already in the tree, it is first removed.

        Note: Replacing a node with itself is implementation dependent.

        参数：
        newChild - The new node to put in the child list.
        oldChild - The node being replaced in the list.
        返回：
        The node replaced.
        抛出：
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to put in is one of this node's ancestors or this node itself, or if this node is of type Document and the result of the replacement operation would add a second DocumentType or Element on the Document node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node or the parent of the new node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        从以下版本开始：
        DOM Level 3

      • removeChild

        Node removeChild(Node oldChild)
                 throws DOMException
        Removes the child node indicated by oldChild from the list of children, and returns it.
        参数：
        oldChild - The node being removed.
        返回：
        The node removed.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or the Element child.
        从以下版本开始：
        DOM Level 3

      • appendChild

        Node appendChild(Node newChild)
                 throws DOMException
        Adds the node newChild to the end of the list of children of this node. If the newChild is already in the tree, it is first removed.
        参数：
        newChild - The node to add.If it is a DocumentFragment object, the entire contents of the document fragment are moved into the child list of this node
        返回：
        The node added.
        抛出：
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to append is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to append a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the previous parent of the node being inserted is readonly.
        NOT_SUPPORTED_ERR: if the newChild node is a child of the Document node, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or Element child.
        从以下版本开始：
        DOM Level 3

      • hasChildNodes

        boolean hasChildNodes()
        Returns whether this node has any children.
        返回：
        Returns true if this node has any children, false otherwise.

      • cloneNode

        Node cloneNode(boolean deep)
        Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes. The duplicate node has no parent ( parentNode is null) and no user data. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Cloning an Element copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes, but this method does not copy any children it contains unless it is a deep clone. This includes text contained in an the Element since the text is contained in a child Text node. Cloning an Attr directly, as opposed to be cloned as part of an Element cloning operation, returns a specified attribute (specified is true). Cloning an Attr always clones its children, since they represent its value, no matter whether this is a deep clone or not. Cloning an EntityReference automatically constructs its subtree if a corresponding Entity is available, no matter whether this is a deep clone or not. Cloning any other type of node simply returns a copy of this node.
        Note that cloning an immutable subtree results in a mutable copy, but the children of an EntityReference clone are readonly . In addition, clones of unspecified Attr nodes are specified. And, cloning Document, DocumentType, Entity, and Notation nodes is implementation dependent.
        参数：
        deep - If true, recursively clone the subtree under the specified node; if false, clone only the node itself (and its attributes, if it is an Element).
        返回：
        The duplicate node.

      • normalize

        void normalize()
        Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer [XPointer] lookups) that depend on a particular document tree structure are to be used. If the parameter "normalize-characters" of the DOMConfiguration object attached to the Node.ownerDocument is true, this method will also fully normalize the characters of the Text nodes.

        Note: In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

        从以下版本开始：
        DOM Level 3

      • isSupported

        boolean isSupported(String feature,
                  String version)
        Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
        参数：
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        返回：
        Returns true if the specified feature is supported on this node, false otherwise.
        从以下版本开始：
        DOM Level 2

      • getNamespaceURI

        String getNamespaceURI()
        The namespace URI of this node, or null if it is unspecified (see ).
        This is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.

        Note: Per the Namespaces in XML Specification [XML Namespaces] an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

        从以下版本开始：
        DOM Level 2

      • getPrefix

        String getPrefix()
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        从以下版本开始：
        DOM Level 2

      • setPrefix

        void setPrefix(String prefix)
               throws DOMException
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        抛出：
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified prefix contains an illegal character according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the specified prefix is malformed per the Namespaces in XML specification, if the namespaceURI of this node is null, if the specified prefix is "xml" and the namespaceURI of this node is different from " http://www.w3.org/XML/1998/namespace", if this node is an attribute and the specified prefix is "xmlns" and the namespaceURI of this node is different from "http://www.w3.org/2000/xmlns/", or if this node is an attribute and the qualifiedName of this node is "xmlns" [XML Namespaces] .
        从以下版本开始：
        DOM Level 2

      • getLocalName

        String getLocalName()
        Returns the local part of the qualified name of this node.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.
        从以下版本开始：
        DOM Level 2

      • hasAttributes

        boolean hasAttributes()
        Returns whether this node (if it is an element) has any attributes.
        返回：
        Returns true if this node has any attributes, false otherwise.
        从以下版本开始：
        DOM Level 2

      • getBaseURI

        String getBaseURI()
        The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI. This value is computed as described in . However, when the Document supports the feature "HTML" [DOM Level 2 HTML] , the base URI is computed using first the value of the href attribute of the HTML BASE element if any, and the value of the documentURI attribute from the Document interface otherwise.
        从以下版本开始：
        DOM Level 3

      • compareDocumentPosition

        short compareDocumentPosition(Node other)
                              throws DOMException
        Compares the reference node, i.e. the node on which this method is being called, with a node, i.e. the one passed as a parameter, with regard to their position in the document and according to the document order.
        参数：
        other - The node to compare against the reference node.
        返回：
        Returns how the node is positioned relatively to the reference node.
        抛出：
        DOMException - NOT_SUPPORTED_ERR: when the compared nodes are from different DOM implementations that do not coordinate to return consistent implementation-specific results.
        从以下版本开始：
        DOM Level 3

      • getTextContent

        String getTextContent()
                      throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        抛出：
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.
        从以下版本开始：
        DOM Level 3

      • setTextContent

        void setTextContent(String textContent)
                    throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
        从以下版本开始：
        DOM Level 3

      • isSameNode

        boolean isSameNode(Node other)
        Returns whether this node is the same node as the given one.
        This method provides a way to determine whether two Node references returned by the implementation reference the same object. When two Node references are references to the same object, even if through a proxy, the references may be used completely interchangeably, such that all attributes have the same values and calling the same DOM method on either reference always has exactly the same effect.
        参数：
        other - The node to test against.
        返回：
        Returns true if the nodes are the same, false otherwise.
        从以下版本开始：
        DOM Level 3

      • lookupPrefix

        String lookupPrefix(String namespaceURI)
        Look up the prefix associated to the given namespace URI, starting from this node. The default namespace declarations are ignored by this method.
        See for details on the algorithm used by this method.
        参数：
        namespaceURI - The namespace URI to look for.
        返回：
        Returns an associated namespace prefix if found or null if none is found. If more than one prefix are associated to the namespace prefix, the returned namespace prefix is implementation dependent.
        从以下版本开始：
        DOM Level 3

      • isDefaultNamespace

        boolean isDefaultNamespace(String namespaceURI)
        This method checks if the specified namespaceURI is the default namespace or not.
        参数：
        namespaceURI - The namespace URI to look for.
        返回：
        Returns true if the specified namespaceURI is the default namespace, false otherwise.
        从以下版本开始：
        DOM Level 3

      • lookupNamespaceURI

        String lookupNamespaceURI(String prefix)
        Look up the namespace URI associated to the given prefix, starting from this node.
        See for details on the algorithm used by this method.
        参数：
        prefix - The prefix to look for. If this parameter is null, the method will return the default namespace URI if any.
        返回：
        Returns the associated namespace URI or null if none is found.
        从以下版本开始：
        DOM Level 3

      • isEqualNode

        boolean isEqualNode(Node arg)
        Tests whether two nodes are equal.
        This method tests for equality of nodes, not sameness (i.e., whether the two nodes are references to the same object) which can be tested with Node.isSameNode(). All nodes that are the same will also be equal, though the reverse may not be true.
        Two nodes are equal if and only if the following conditions are satisfied:
        • The two nodes are of the same type.
        • The following string attributes are equal: nodeName, localName, namespaceURI, prefix, nodeValue . This is: they are both null, or they have the same length and are character for character identical.
        • The attributes NamedNodeMaps are equal. This is: they are both null, or they have the same length and for each node that exists in one map there is a node that exists in the other map and is equal, although not necessarily at the same index.
        • The childNodes NodeLists are equal. This is: they are both null, or they have the same length and contain equal nodes at the same index. Note that normalization can affect equality; to avoid this, nodes should be normalized before being compared.

        For two DocumentType nodes to be equal, the following conditions must also be satisfied:
        • The following string attributes are equal: publicId, systemId, internalSubset.
        • The entities NamedNodeMaps are equal.
        • The notations NamedNodeMaps are equal.

        On the other hand, the following do not affect equality: the ownerDocument, baseURI, and parentNode attributes, the specified attribute for Attr nodes, the schemaTypeInfo attribute for Attr and Element nodes, the Text.isElementContentWhitespace attribute for Text nodes, as well as any user data or event listeners registered on the nodes.

        Note: As a general rule, anything not mentioned in the description above is not significant in consideration of equality checking. Note that future versions of this specification may take into account more attributes and implementations conform to this specification are expected to be updated accordingly.

        参数：
        arg - The node to compare equality with.
        返回：
        Returns true if the nodes are equal, false otherwise.
        从以下版本开始：
        DOM Level 3

      • getFeature

        Object getFeature(String feature,
                String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in . The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the Node interface.
        参数：
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        返回：
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the Node interface, it must delegate to the primary core Node and not return results inconsistent with the primary core Node such as attributes, childNodes, etc.
        从以下版本开始：
        DOM Level 3

      • setUserData

        Object setUserData(String key,
                 Object data,
                 UserDataHandler handler)
        Associate an object to a key on this node. The object can later be retrieved from this node by calling getUserData with the same key.
        参数：
        key - The key to associate the object to.
        data - The object to associate to the given key, or null to remove any existing association to that key.
        handler - The handler to associate to that key, or null.
        返回：
        Returns the DOMUserData previously associated to the given key on this node, or null if there was none.
        从以下版本开始：
        DOM Level 3

      • getUserData

        Object getUserData(String key)
        Retrieves the object associated to a key on a this node. The object must first have been set to this node by calling setUserData with the same key.
        参数：
        key - The key the object is associated to.
        返回：
        Returns the DOMUserData associated to the given key on this node, or null if there was none.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


NodeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface NodeList

  • All Known Implementing Classes:
    IIOMetadataNode

    public interface NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented. NodeList objects in the DOM are live.

    The items in the NodeList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getLength()
      The number of nodes in the list.
      Node item(int index)
      Returns the indexth item in the collection.

    • 方法详细信息

      • item

        Node item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of nodes in the list, this returns null.
        参数：
        index - Index into the collection.
        返回：
        The node at the indexth position in the NodeList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in the list. The range of valid child node indices is 0 to length-1 inclusive.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etV cdmodmaeemaanshht it rhieeidl


Notation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Notation

  • All Superinterfaces:
    Node

    public interface Notation
extends Node
    This interface represents a notation declared in the DTD. A notation either declares, by name, the format of an unparsed entity (see section 4.7 of the XML 1.0 specification [XML 1.0]), or is used for formal declaration of processing instruction targets (see section 2.6 of the XML 1.0 specification [XML 1.0]). The nodeName attribute inherited from Node is set to the declared name of the notation.

    The DOM Core does not support editing Notation nodes; they are therefore readonly.

    A Notation node does not have any parent.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getPublicId()
      The public identifier of this notation.
      String getSystemId()
      The system identifier of this notation.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getPublicId

        String getPublicId()
        The public identifier of this notation. If the public identifier was not specified, this is null.

      • getSystemId

        String getSystemId()
        The system identifier of this notation. If the system identifier was not specified, this is null. This may be an absolute URI or not.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

clr yat"DpdcO>mfL


org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

请参见： 描述

  • 接口摘要
    接口 描述
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception 描述
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

软件包 org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing. The Document Object Model Level 2 Core API allows programs to dynamically access and update the content and structure of documents. See the specification for more information.
从以下版本开始：
JDK1.4
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"h>evnes;trboimn=LLb =


org.w3c.dom Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.w3c.dom

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException

Interface Hierarchy

  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
  • org.w3c.dom.NodeList
  • org.w3c.dom.TypeInfo
  • org.w3c.dom.UserDataHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c tpotayyydpff/


ProcessingInstruction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface ProcessingInstruction

  • All Superinterfaces:
    Node

    public interface ProcessingInstruction
extends Node
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.

    No lexical check is done on the content of a processing instruction and it is therefore possible to have the character sequence "?>" in the content, which is illegal a processing instruction per section 2.6 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getData()
      The content of this processing instruction.
      String getTarget()
      The target of this processing instruction.
      void setData(String data)
      The content of this processing instruction.

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • getTarget

        String getTarget()
        The target of this processing instruction. XML defines this as being the first token following the markup that begins the processing instruction.

      • getData

        String getData()
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.

      • setData

        void setData(String data)
             throws DOMException
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oCddhToTholcl=ss /..


Text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface Text

  • All Superinterfaces:
    CharacterData, Node
    All Known Subinterfaces:
    CDATASection, Text

    public interface Text
extends CharacterData
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr. If there is no markup inside an element's content, the text is contained in a single object implementing the Text interface that is the only child of the element. If there is markup, it is parsed into the information items (elements, comments, etc.) and Text nodes that form the list of children of the element.

    When a document is first made available via the DOM, there is only one Text node for each block of text. Users may create adjacent Text nodes that represent the contents of a given element without any intervening markup, but should be aware that there is no way to represent the separations between these nodes in XML or HTML, so they will not (in general) persist between DOM editing sessions. The Node.normalize() method merges any such adjacent Text objects into a single node for each block of text.

    No lexical check is done on the content of a Text node and, depending on its position in the document, some characters must be escaped during serialization using character references; e.g. the characters "<&" if the textual content is part of an element or of an attribute, the character sequence "]]>" when part of an element, the quotation mark character " or the apostrophe character ' when part of an attribute.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getWholeText()
      Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
      boolean isElementContentWhitespace()
      Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
      Text replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

      • 方法 - 继承于接口 org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • 方法 - 继承于接口 org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • 方法详细信息

      • splitText

        Text splitText(int offset)
               throws DOMException
        Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings. After being split, this node will contain all the content up to the offset point. A new node of the same type, which contains all the content at and after the offset point, is returned. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.
        参数：
        offset - The 16-bit unit offset at which to split, starting from 0.
        返回：
        The new node, of the same type as this node.
        抛出：
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • isElementContentWhitespace

        boolean isElementContentWhitespace()
        Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace". The text node is determined to contain whitespace in element content during the load of the document or if validation occurs while using Document.normalizeDocument().
        从以下版本开始：
        DOM Level 3

      • getWholeText

        String getWholeText()
        Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
        For instance, in the example below wholeText on the Text node that contains "bar" returns "barfoo", while on the Text node that contains "foo" it returns "barfoo".
                             +-----+
                     | <p> |
                     +-----+
                       /\
                      /  \
               /-----\    +-------+
               | bar |    | &ent; |
               \-----/    +-------+
                              |
                              |
                           /-----\
                           | foo |
                           \-----/
        Figure: barTextNode.wholeText value is "barfoo"
        从以下版本开始：
        DOM Level 3

      • replaceWholeText

        Text replaceWholeText(String content)
                      throws DOMException
        Replaces the text of the current node and all logically-adjacent text nodes with the specified text. All logically-adjacent text nodes are removed including the current node unless it was the recipient of the replacement text.

        This method returns the node which received the replacement text. The returned node is:

        • null, when the replacement text is the empty string;
        • the current node, except when the current node is read-only;
        • a new Text node of the same type ( Text or CDATASection) as the current node inserted at the location of the replacement.

        For instance, in the above example calling replaceWholeText on the Text node that contains "bar" with "yo" in argument results in the following:

                             +-----+
                     | <p> |
                     +-----+
                        |
                        |
                     /-----\
                     | yo  |
                     \-----/
        Figure: barTextNode.replaceWholeText("yo") modifies the textual content of barTextNode with "yo"

        Where the nodes to be removed are read-only descendants of an EntityReference, the EntityReference must be removed instead of the read-only nodes. If any EntityReference to be removed has descendants that are not EntityReference, Text, or CDATASection nodes, the replaceWholeText method must fail before performing any modification of the document, raising a DOMException with the code NO_MODIFICATION_ALLOWED_ERR.

        For instance, in the example below calling replaceWholeText on the Text node that contains "bar" fails, because the EntityReference node "ent" contains an Element node which cannot be removed.

        参数：
        content - The content of the replacing Text node.
        返回：
        The Text node created with the specified content.
        抛出：
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if one of the Text nodes being replaced is readonly.
        从以下版本开始：
        DOM Level 3
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ed"d>e>fO/ =eikwshIkOgbt"> uatlSEa


TypeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface TypeInfo

  • public interface TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document. The type is a pair of a namespace URI and name properties, and depends on the document's schema.

    If the document's schema is an XML DTD [XML 1.0], the values are computed as follows:

    • If this type is referenced from an Attr node, typeNamespace is "http://www.w3.org/TR/REC-xml" and typeName represents the [attribute type] property in the [XML Information Set] . If there is no declaration for the attribute, typeNamespace and typeName are null.
    • If this type is referenced from an Element node, typeNamespace and typeName are null.

    If the document's schema is an XML Schema [XML Schema Part 1] , the values are computed as follows using the post-schema-validation infoset contributions (also called PSVI contributions):

    • If the [validity] property exists AND is "invalid" or "notKnown": the {target namespace} and {name} properties of the declared type if available, otherwise null.

      Note: At the time of writing, the XML Schema specification does not require exposing the declared type. Thus, DOM implementations might choose not to provide type information if validity is not valid.

    • If the [validity] property exists and is "valid":
      1. If [member type definition] exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [member type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      2. If the [type definition] property exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      3. If the [member type definition anonymous] exists:
        1. If it is false, then expose [member type definition name] and [member type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      4. If the [type definition anonymous] exists:
        1. If it is false, then expose [type definition name] and [type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.

    Note: Other schema languages are outside the scope of the W3C and therefore should define how to represent their type systems using TypeInfo.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static int DERIVATION_EXTENSION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
      static int DERIVATION_LIST
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
      static int DERIVATION_RESTRICTION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
      static int DERIVATION_UNION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getTypeName()
      The name of a type declared for the associated element or attribute, or null if unknown.
      String getTypeNamespace()
      The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.
      boolean isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod)
      This method returns if there is a derivation between the reference type definition, i.e.

    • 字段详细信息

      • DERIVATION_RESTRICTION

        static final int DERIVATION_RESTRICTION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
        The reference type definition is derived by restriction from the other type definition if the other type definition is the same as the reference type definition, or if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and all the derivation methods involved are restriction.
        另请参见：
        Constant Field Values

      • DERIVATION_EXTENSION

        static final int DERIVATION_EXTENSION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
        The reference type definition is derived by extension from the other type definition if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and at least one of the derivation methods involved is an extension.
        另请参见：
        Constant Field Values

      • DERIVATION_UNION

        static final int DERIVATION_UNION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
        The reference type definition is derived by union from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} union, and one of the {member type definitions} is T2. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        另请参见：
        Constant Field Values

      • DERIVATION_LIST

        static final int DERIVATION_LIST
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
        The reference type definition is derived by list from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} list, and T2 is the {item type definition}. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getTypeName

        String getTypeName()
        The name of a type declared for the associated element or attribute, or null if unknown.

      • getTypeNamespace

        String getTypeNamespace()
        The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

      • isDerivedFrom

        boolean isDerivedFrom(String typeNamespaceArg,
                    String typeNameArg,
                    int derivationMethod)
        This method returns if there is a derivation between the reference type definition, i.e. the TypeInfo on which the method is being called, and the other type definition, i.e. the one passed as parameters.
        参数：
        typeNamespaceArg - the namespace of the other type definition.
        typeNameArg - the name of the other type definition.
        derivationMethod - the type of derivation and conditions applied between two types, as described in the list of constants provided in this interface.
        返回：
        If the document's schema is a DTD or no schema is associated with the document, this method will always return false . If the document's schema is an XML Schema, the method will return true if the reference type definition is derived from the other type definition according to the derivation parameter. If the value of the parameter is 0 (no bit is set to 1 for the derivationMethod parameter), the method will return true if the other type definition can be reached by recursing any combination of {base type definition}, {item type definition}, or {member type definitions} from the reference type definition.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

harllla<>>><换sgIPnnioIn cittoe�


UserDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom

Interface UserDataHandler

  • public interface UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed. This can be used by the application to implement various behaviors regarding the data it associates to the DOM nodes. This interface defines that handler.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    从以下版本开始：
    DOM Level 3

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short NODE_ADOPTED
      The node is adopted, using Document.adoptNode().
      static short NODE_CLONED
      The node is cloned, using Node.cloneNode().
      static short NODE_DELETED
      The node is deleted.
      static short NODE_IMPORTED
      The node is imported, using Document.importNode().
      static short NODE_RENAMED
      The node is renamed, using Document.renameNode().

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.

    • 字段详细信息

      • NODE_CLONED

        static final short NODE_CLONED
        The node is cloned, using Node.cloneNode().
        另请参见：
        Constant Field Values

      • NODE_IMPORTED

        static final short NODE_IMPORTED
        The node is imported, using Document.importNode().
        另请参见：
        Constant Field Values

      • NODE_DELETED

        static final short NODE_DELETED
        The node is deleted.

        Note: This may not be supported or may not be reliable in certain environments, such as Java, where the implementation has no real control over when objects are actually deleted.

        另请参见：
        Constant Field Values

      • NODE_RENAMED

        static final short NODE_RENAMED
        The node is renamed, using Document.renameNode().
        另请参见：
        Constant Field Values

      • NODE_ADOPTED

        static final short NODE_ADOPTED
        The node is adopted, using Document.adoptNode().
        另请参见：
        Constant Field Values

    • 方法详细信息

      • handle

        void handle(short operation,
          String key,
          Object data,
          Node src,
          Node dst)
        This method is called whenever the node for which this handler is registered is imported or cloned.
        DOM applications must not raise exceptions in a UserDataHandler. The effect of throwing exceptions from the handler is DOM implementation dependent.
        参数：
        operation - Specifies the type of operation that is being performed on the node.
        key - Specifies the key for which this handler is being called.
        data - Specifies the data for which this handler is being called.
        src - Specifies the node being cloned, adopted, imported, or renamed. This is null when the node is being deleted.
        dst - Specifies the node newly created if any, or null.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/'we[aearibp&ninn


Uses of Package org.w3c.dom

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.w3c.dom

  • Packages that use org.w3c.dom
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom used by javax.imageio.metadata
    类与描述
    Attr
    The Attr interface represents an attribute in an Element object.
    Document
    The Document interface represents the entire HTML or XML document.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by javax.xml.bind
    类与描述
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.bind.annotation
    类与描述
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.bind.helpers
    类与描述
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dom
    类与描述
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dsig.dom
    类与描述
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.parsers
    类与描述
    Document
    The Document interface represents the entire HTML or XML document.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
  • Classes in org.w3c.dom used by javax.xml.soap
    类与描述
    Document
    The Document interface represents the entire HTML or XML document.
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
  • Classes in org.w3c.dom used by javax.xml.transform.dom
    类与描述
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.validation
    类与描述
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
  • Classes in org.w3c.dom used by javax.xml.ws
    类与描述
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.spi
    类与描述
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.wsaddressing
    类与描述
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by org.w3c.dom
    类与描述
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by org.w3c.dom.bootstrap
    类与描述
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
  • Classes in org.w3c.dom used by org.w3c.dom.events
    类与描述
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by org.w3c.dom.ls
    类与描述
    Document
    The Document interface represents the entire HTML or XML document.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


DOMImplementationRegistry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.bootstrap

类 DOMImplementationRegistry

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry

  • public final class DOMImplementationRegistry
extends Object
    A factory that enables applications to obtain instances of DOMImplementation.

    Example:

      // get an instance of the DOMImplementation registry
  DOMImplementationRegistry registry =
       DOMImplementationRegistry.newInstance();
  // get a DOM implementation the Level 3 XML module
  DOMImplementation domImpl =
       registry.getDOMImplementation("XML 3.0");

    This provides an application with an implementation-independent starting point. DOM implementations may modify this class to meet new security standards or to provide *additional* fallbacks for the list of DOMImplementationSources.

    从以下版本开始：
    DOM Level 3
    另请参见：
    DOMImplementation, DOMImplementationSource

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String PROPERTY
      The system property to specify the DOMImplementationSource class names.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addSource(DOMImplementationSource s)
      Register an implementation.
      DOMImplementation getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
      DOMImplementationList getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
      static DOMImplementationRegistry newInstance()
      Obtain a new instance of a DOMImplementationRegistry.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • PROPERTY

        public static final String PROPERTY
        The system property to specify the DOMImplementationSource class names.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • newInstance

        public static DOMImplementationRegistry newInstance()
                                             throws ClassNotFoundException,
                                                    InstantiationException,
                                                    IllegalAccessException,
                                                    ClassCastException
        Obtain a new instance of a DOMImplementationRegistry. The DOMImplementationRegistry is initialized by the application or the implementation, depending on the context, by first checking the value of the Java system property org.w3c.dom.DOMImplementationSourceList and the service provider whose contents are at "META_INF/services/org.w3c.dom.DOMImplementationSourceList". The value of this property is a white-space separated list of names of availables classes implementing the DOMImplementationSource interface. Each class listed in the class name list is instantiated and any exceptions encountered are thrown to the application.
        返回：
        an initialized instance of DOMImplementationRegistry
        抛出：
        ClassNotFoundException - If any specified class can not be found
        InstantiationException - If any specified class is an interface or abstract class
        IllegalAccessException - If the default constructor of a specified class is not accessible
        ClassCastException - If any specified class does not implement DOMImplementationSource

      • getDOMImplementation

        public DOMImplementation getDOMImplementation(String features)
        Return the first implementation that has the desired features, or null if none is found.
        参数：
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        返回：
        An implementation that has the desired features, or null if none found.

      • getDOMImplementationList

        public DOMImplementationList getDOMImplementationList(String features)
        Return a list of implementations that support the desired features.
        参数：
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        返回：
        A list of DOMImplementations that support the desired features.

      • addSource

        public void addSource(DOMImplementationSource s)
        Register an implementation.
        参数：
        s - The source to be registered, may not be null
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=deilo>htssgaissBse


org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry
m


org.w3c.dom.bootstrap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.w3c.dom.bootstrap

  • Class Summary
    类 描述
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nttDrOMrtaOOrm..tt/cod


org.w3c.dom.bootstrap Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.w3c.dom.bootstrap

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ppedavde elrgv躹k<钡�


Uses of Package org.w3c.dom.bootstrap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.w3c.dom.bootstrap

  • Packages that use org.w3c.dom.bootstrap
    软件包 描述
    org.w3c.dom.bootstrap
  • Classes in org.w3c.dom.bootstrap used by org.w3c.dom.bootstrap
    类与描述
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d;>aume0iu"epho藄/>o"<


Uses of Class org.w3c.dom.bootstrap.DOMImplementationRegistry

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.w3c.dom.bootstrap.DOMImplementationRegistry

  • Packages that use DOMImplementationRegistry
    软件包 描述
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationRegistry in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationRegistry
      修饰符与类型 方法与描述
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
      Obtain a new instance of a DOMImplementationRegistry.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ariesawe>at=.


Uses of Class org.w3c.dom.DOMException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.w3c.dom.DOMException

  • Packages that use DOMException
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of DOMException in javax.imageio.metadata

      Methods in javax.imageio.metadata that throw DOMException
      修饰符与类型 | 方法与描述
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getBaseURI()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getFeature(String feature, String version)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getNamespaceURI()
      Returns null, since namespaces are not supported.
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getTextContent()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getUserData(String key)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isDefaultNamespace(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupNamespaceURI(String prefix)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupPrefix(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      void IIOMetadataNode.setIdAttribute(String name, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setTextContent(String textContent)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of DOMException in org.w3c.dom

      Methods in org.w3c.dom that throw DOMException
      修饰符与类型 方法与描述
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      void CharacterData.appendData(String arg)
      Append the string to the end of the character data of the node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      void CharacterData.deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String Element.getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      String CharacterData.getData()
      The character data of the node that implements this interface.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      String Node.getNodeValue()
      The value of this node, depending on its type; see the table above.
      Object DOMConfiguration.getParameter(String name)
      Return the value of a parameter if known.
      String Node.getTextContent()
      This attribute returns the text content of this node and its descendants.
      boolean Element.hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      void CharacterData.insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void Element.removeAttribute(String name)
      Removes an attribute by name.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void Element.removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void CharacterData.replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      void Element.setAttribute(String name, String value)
      Adds a new attribute.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void ProcessingInstruction.setData(String data)
      The content of this processing instruction.
      void CharacterData.setData(String data)
      The character data of the node that implements this interface.
      void Element.setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      void Node.setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void DOMConfiguration.setParameter(String name, Object value)
      Set the value of a parameter.
      void Node.setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void Node.setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      void Attr.setValue(String value)
      On retrieval, the value of the attribute is returned as a string.
      void Document.setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void Document.setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
      String CharacterData.substringData(int offset, int count)
      Extracts a range of data from the node.

    • Uses of DOMException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw DOMException
      修饰符与类型 | 方法与描述
      Event | DocumentEvent.createEvent(String eventType)

    • Uses of DOMException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw DOMException
      修饰符与类型 方法与描述
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.w3c.dom.Attr

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Attr

  • Packages that use Attr
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Attr in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Attr
      修饰符与类型 | 方法与描述
      Attr | IIOMetadataNode.getAttributeNode(String name)
      Attr IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName)
      Equivalent to getAttributeNode(localName).
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      Methods in javax.imageio.metadata with parameters of type Attr
      修饰符与类型 | 方法与描述
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of Attr in org.w3c.dom

      Methods in org.w3c.dom that return Attr
      修饰符与类型 方法与描述
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      Attr Element.getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      Methods in org.w3c.dom with parameters of type Attr
      修饰符与类型 方法与描述
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gx" oen>> e


Uses of Interface org.w3c.dom.CDATASection

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.CDATASection

  • Packages that use CDATASection
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of CDATASection in org.w3c.dom

      Methods in org.w3c.dom that return CDATASection
      修饰符与类型 方法与描述
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

Ums ng=psaaaen00erebdteNb


Uses of Interface org.w3c.dom.CharacterData

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.CharacterData

  • Packages that use CharacterData
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of CharacterData in org.w3c.dom

      Subinterfaces of CharacterData in org.w3c.dom
      修饰符与类型 Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gn /s o0rbgA"3


Uses of Interface org.w3c.dom.Comment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Comment

  • Packages that use Comment
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Comment in org.w3c.dom

      Methods in org.w3c.dom that return Comment
      修饰符与类型 方法与描述
      Comment Document.createComment(String data)
      Creates a Comment node given the specified string.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d (eteBeletIe.kk>s�.>览>a


Uses of Interface org.w3c.dom.Document

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Document

  • Packages that use Document
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of Document in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Document
      修饰符与类型 方法与描述
      Document IIOMetadataNode.getOwnerDocument()
      Returns null, since IIOMetadataNodes do not belong to any Document.

    • Uses of Document in javax.xml.parsers

      Methods in javax.xml.parsers that return Document
      修饰符与类型 方法与描述
      abstract Document DocumentBuilder.newDocument()
      Obtain a new instance of a DOM Document object to build a DOM tree with.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.

    • Uses of Document in javax.xml.soap

      Classes in javax.xml.soap that implement Document
      修饰符与类型 类与描述
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.
      Methods in javax.xml.soap that return Document
      修饰符与类型 方法与描述
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      Methods in javax.xml.soap with parameters of type Document
      修饰符与类型 方法与描述
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.

    • Uses of Document in org.w3c.dom

      Methods in org.w3c.dom that return Document
      修饰符与类型 方法与描述
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      Document Node.getOwnerDocument()
      The Document object associated with this node.

    • Uses of Document in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Document
      修饰符与类型 方法与描述
      Document LSLoadEvent.getNewDocument()
      The document that finished loading.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fsich O/ de stt=[>sho_


Uses of Interface org.w3c.dom.DocumentFragment

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DocumentFragment

  • Packages that use DocumentFragment
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DocumentFragment in org.w3c.dom

      Methods in org.w3c.dom that return DocumentFragment
      修饰符与类型 方法与描述
      DocumentFragment Document.createDocumentFragment()
      Creates an empty DocumentFragment object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/ >>


Uses of Interface org.w3c.dom.DocumentType

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DocumentType

  • Packages that use DocumentType
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DocumentType in org.w3c.dom

      Methods in org.w3c.dom that return DocumentType
      修饰符与类型 方法与描述
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      DocumentType Document.getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Methods in org.w3c.dom with parameters of type DocumentType
      修饰符与类型 方法与描述
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f/sn< mvl/i- oj/as/e./A/a


Uses of Interface org.w3c.dom.DOMConfiguration

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMConfiguration

  • Packages that use DOMConfiguration
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of DOMConfiguration in org.w3c.dom

      Methods in org.w3c.dom that return DOMConfiguration
      修饰符与类型 方法与描述
      DOMConfiguration Document.getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.

    • Uses of DOMConfiguration in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return DOMConfiguration
      修饰符与类型 方法与描述
      DOMConfiguration LSSerializer.getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
      DOMConfiguration LSParser.getDomConfig()
      The DOMConfiguration object used when parsing an input source.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d╡iorsreiw ios=枋目增鲈�


Uses of Interface org.w3c.dom.DOMError

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMError

  • Packages that use DOMError
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMError in org.w3c.dom

      Methods in org.w3c.dom with parameters of type DOMError
      修饰符与类型 方法与描述
      boolean DOMErrorHandler.handleError(DOMError error)
      This method is called on the error handler when an error occurs.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdmmge-apccc.a>>ifiolra <


Uses of Interface org.w3c.dom.DOMErrorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMErrorHandler

No usage of org.w3c.dom.DOMErrorHandler
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e3-pf=" ahhhial


Uses of Interface org.w3c.dom.DOMImplementation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMImplementation

  • Packages that use DOMImplementation
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap

    • Uses of DOMImplementation in javax.xml.parsers

      Methods in javax.xml.parsers that return DOMImplementation
      修饰符与类型 方法与描述
      abstract DOMImplementation DocumentBuilder.getDOMImplementation()
      Obtain an instance of a DOMImplementation object.

    • Uses of DOMImplementation in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementation
      修饰符与类型 方法与描述
      DOMImplementation DOMImplementationSource.getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementation Document.getImplementation()
      The DOMImplementation object that handles this document.
      DOMImplementation DOMImplementationList.item(int index)
      Returns the indexth item in the collection.

    • Uses of DOMImplementation in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementation
      修饰符与类型 方法与描述
      DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d/ e>wfflct<


Uses of Interface org.w3c.dom.DOMImplementationList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMImplementationList

  • Packages that use DOMImplementationList
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationList in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementationList
      修饰符与类型 方法与描述
      DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Uses of DOMImplementationList in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationList
      修饰符与类型 方法与描述
      DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lAlrresefaaade s"esdv


Uses of Interface org.w3c.dom.DOMImplementationSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMImplementationSource

  • Packages that use DOMImplementationSource
    软件包 描述
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationSource in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap with parameters of type DOMImplementationSource
      修饰符与类型 方法与描述
      void DOMImplementationRegistry.addSource(DOMImplementationSource s)
      Register an implementation.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l/i


Uses of Interface org.w3c.dom.DOMLocator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMLocator

  • Packages that use DOMLocator
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMLocator in org.w3c.dom

      Methods in org.w3c.dom that return DOMLocator
      修饰符与类型 方法与描述
      DOMLocator DOMError.getLocation()
      The location of the error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gi w dkdnwrnoxk>ぞ醇な胜h


Uses of Interface org.w3c.dom.DOMStringList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.DOMStringList

  • Packages that use DOMStringList
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMStringList in org.w3c.dom

      Methods in org.w3c.dom that return DOMStringList
      修饰符与类型 方法与描述
      DOMStringList DOMConfiguration.getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pc/mo ymlshhl"ahloo�<


Uses of Interface org.w3c.dom.Element

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Element

  • Packages that use Element
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of Element in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Element
      修饰符与类型 类与描述
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.

    • Uses of Element in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return Element
      修饰符与类型 | 方法与描述
      Element | W3CDomHandler.getElement(DOMResult r)
      Methods in javax.xml.bind.annotation with parameters of type Element
      修饰符与类型 | 方法与描述
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of Element in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Element
      修饰符与类型 方法与描述
      Element DOMCryptoContext.getElementById(String idValue)
      Returns the Element with the specified ID attribute value.
      Methods in javax.xml.crypto.dom with parameters of type Element
      修饰符与类型 方法与描述
      void DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
      Registers the element's attribute specified by the namespace URI and local name to be of type ID.

    • Uses of Element in javax.xml.soap

      Subinterfaces of Element in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap with parameters of type Element
      修饰符与类型 方法与描述
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.

    • Uses of Element in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Element
      修饰符与类型 方法与描述
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(类<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.

    • Uses of Element in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Element
      修饰符与类型 方法与描述
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of Element in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type Element
      修饰符与类型 方法与描述
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.

    • Uses of Element in org.w3c.dom

      Methods in org.w3c.dom that return Element
      修饰符与类型 方法与描述
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      Element Document.getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      Element Document.getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      Element Attr.getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.

    • Uses of Element in org.w3c.dom.ls

      Methods in org.w3c.dom.ls with parameters of type Element
      修饰符与类型 方法与描述
      short LSParserFilter.startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.w3c.dom.Entity

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Entity

No usage of org.w3c.dom.Entity
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tsd.ng


Uses of Interface org.w3c.dom.EntityReference

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.EntityReference

  • Packages that use EntityReference
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of EntityReference in org.w3c.dom

      Methods in org.w3c.dom that return EntityReference
      修饰符与类型 方法与描述
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e de=tr>Bnm Lasp /e .l


Uses of Interface org.w3c.dom.NamedNodeMap

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.NamedNodeMap

  • Packages that use NamedNodeMap
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of NamedNodeMap in javax.imageio.metadata

      Methods in javax.imageio.metadata that return NamedNodeMap
      修饰符与类型 方法与描述
      NamedNodeMap IIOMetadataNode.getAttributes()
      Returns a NamedNodeMap containing the attributes of this node.

    • Uses of NamedNodeMap in org.w3c.dom

      Methods in org.w3c.dom that return NamedNodeMap
      修饰符与类型 方法与描述
      NamedNodeMap Node.getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      NamedNodeMap DocumentType.getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      NamedNodeMap DocumentType.getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

jlc/>g e/"0胠.


Uses of Interface org.w3c.dom.NameList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.NameList

No usage of org.w3c.dom.NameList
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> n th soooueoodc= n


Uses of Interface org.w3c.dom.Node

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Node

  • Packages that use Node
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Node in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Node
      修饰符与类型 类与描述
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Fields in javax.imageio.metadata declared as Node
      修饰符与类型 字段与描述
      protected Node IIOInvalidTreeException.offendingNode
      The Node that led to the parsing error, or null.
      Methods in javax.imageio.metadata that return Node
      修饰符与类型 | 方法与描述
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node IIOMetadataNode.cloneNode(boolean deep)
      Returns a duplicate of this node.
      abstract Node IIOMetadata.getAsTree(String formatName)
      Returns an XML DOM Node object that represents the root of a tree of metadata contained within this object according to the conventions defined by a given metadata format.
      Node IIOMetadataNode.getFirstChild()
      Returns the first child of this node, or null if the node has no children.
      Node IIOMetadataNode.getLastChild()
      Returns the last child of this node, or null if the node has no children.
      Node IIOMetadataNode.getNextSibling()
      Returns the next sibling of this node, or null if the node has no next sibling.
      Node IIOInvalidTreeException.getOffendingNode()
      Returns the Node that caused the error in parsing.
      Node IIOMetadataNode.getParentNode()
      Returns the parent of this node.
      Node IIOMetadataNode.getPreviousSibling()
      Returns the previous sibling of this node, or null if this node has no previous sibling.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node | IIOMetadataNode.item(int index)
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Methods in javax.imageio.metadata with parameters of type Node
      修饰符与类型 方法与描述
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      abstract void IIOMetadata.mergeTree(String formatName, Node root)
      Alters the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void IIOMetadata.setFromTree(String formatName, Node root)
      Sets the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Constructors in javax.imageio.metadata with parameters of type Node
      构造方法与描述
      IIOInvalidTreeException(String message, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string and a reference to the Node that caused the parsing error.
      IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string, a reference to an exception that caused this exception, and a reference to the Node that caused the parsing error.

    • Uses of Node in javax.xml.bind

      Methods in javax.xml.bind that return Node
      修饰符与类型 方法与描述
      Node ValidationEventLocator.getNode()
      Return a reference to the DOM Node if available
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Methods in javax.xml.bind that return types with arguments of type Node
      修饰符与类型 方法与描述
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      Methods in javax.xml.bind with parameters of type Node
      修饰符与类型 方法与描述
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, 类<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

    • Uses of Node in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Node
      修饰符与类型 | 方法与描述
      Node | ValidationEventLocatorImpl.getNode()
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      Methods in javax.xml.bind.helpers with parameters of type Node
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void ValidationEventLocatorImpl.setNode(Node _node)
      Set the Node field on this event locator.
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, 类<T> expectedType)
      Constructors in javax.xml.bind.helpers with parameters of type Node
      构造方法与描述
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.

    • Uses of Node in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Node
      修饰符与类型 方法与描述
      Node DOMURIReference.getHere()
      Returns the here node.
      Node DOMStructure.getNode()
      Returns the node contained in this DOMStructure.
      Constructors in javax.xml.crypto.dom with parameters of type Node
      构造方法与描述
      DOMStructure(Node node)
      Creates a DOMStructure containing the specified node.

    • Uses of Node in javax.xml.crypto.dsig.dom

      Methods in javax.xml.crypto.dsig.dom that return Node
      修饰符与类型 方法与描述
      Node DOMSignContext.getNextSibling()
      Returns the nextSibling node.
      Node DOMValidateContext.getNode()
      Returns the node.
      Node DOMSignContext.getParent()
      Returns the parent node.
      Methods in javax.xml.crypto.dsig.dom with parameters of type Node
      修饰符与类型 方法与描述
      void DOMSignContext.setNextSibling(Node nextSibling)
      Sets the next sibling node.
      void DOMValidateContext.setNode(Node node)
      Sets the node.
      void DOMSignContext.setParent(Node parent)
      Sets the parent node.
      Constructors in javax.xml.crypto.dsig.dom with parameters of type Node
      构造方法与描述
      DOMSignContext(Key signingKey, Node parent)
      Creates a DOMSignContext with the specified signing key and parent node.
      DOMSignContext(Key signingKey, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
      DOMValidateContext(Key validatingKey, Node node)
      Creates a DOMValidateContext containing the specified key and node.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  Node
      A representation of a node (element) in an XML document.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Classes in javax.xml.soap that implement Node
      修饰符与类型 类与描述
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.

    • Uses of Node in javax.xml.transform.dom

      Methods in javax.xml.transform.dom that return Node
      修饰符与类型 方法与描述
      Node DOMResult.getNextSibling()
      Get the child node before which the result nodes will be inserted.
      Node DOMSource.getNode()
      Get the node that represents a Source DOM tree.
      Node DOMResult.getNode()
      Get the node that will contain the result DOM tree.
      Node DOMLocator.getOriginatingNode()
      Return the node where the event occurred.
      Methods in javax.xml.transform.dom with parameters of type Node
      修饰符与类型 方法与描述
      void DOMResult.setNextSibling(Node nextSibling)
      Set the child node before which the result nodes will be inserted.
      void DOMSource.setNode(Node node)
      Set the node that will represents a Source DOM tree.
      void DOMResult.setNode(Node node)
      Set the node that will contain the result DOM tree.
      Constructors in javax.xml.transform.dom with parameters of type Node
      构造方法与描述
      DOMResult(Node node)
      Use a DOM node to create a new output target.
      DOMResult(Node node, Node nextSibling)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
      DOMResult(Node node, Node nextSibling, String systemId)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
      DOMResult(Node node, String systemId)
      Use a DOM node to create a new output target with the specified System ID.
      DOMSource(Node n)
      Create a new input source with a DOM node.
      DOMSource(Node node, String systemID)
      Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

    • Uses of Node in org.w3c.dom

      Subinterfaces of Node in org.w3c.dom
      修饰符与类型 Interface and Description
      interface  Attr
      The Attr interface represents an attribute in an Element object.
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  CharacterData
      The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Document
      The Document interface represents the entire HTML or XML document.
      interface  DocumentFragment
      DocumentFragment is a "lightweight" or "minimal" Document object.
      interface  DocumentType
      Each Document has a doctype attribute whose value is either null or a DocumentType object.
      interface  Element
      The Element interface represents an element in an HTML or XML document.
      interface  Entity
      This interface represents a known entity, either parsed or unparsed, in an XML document.
      interface  EntityReference
      EntityReference nodes may be used to represent an entity reference in the tree.
      interface  Notation
      This interface represents a notation declared in the DTD.
      interface  ProcessingInstruction
      The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
      Methods in org.w3c.dom that return Node
      修饰符与类型 方法与描述
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node Node.cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      Node Node.getFirstChild()
      The first child of this node.
      Node Node.getLastChild()
      The last child of this node.
      Node NamedNodeMap.getNamedItem(String name)
      Retrieves a node specified by name.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node Node.getNextSibling()
      The node immediately following this node.
      Node Node.getParentNode()
      The parent of this node.
      Node Node.getPreviousSibling()
      The node immediately preceding this node.
      Node DOMLocator.getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node NodeList.item(int index)
      Returns the indexth item in the collection.
      Node NamedNodeMap.item(int index)
      Returns the indexth item in the map.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      Methods in org.w3c.dom with parameters of type Node
      修饰符与类型 方法与描述
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      void UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean Node.isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean Node.isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • Uses of Node in org.w3c.dom.events

      Methods in org.w3c.dom.events that return Node
      修饰符与类型 方法与描述
      Node MutationEvent.getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      Methods in org.w3c.dom.events with parameters of type Node
      修饰符与类型 方法与描述
      void MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

    • Uses of Node in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Node
      修饰符与类型 方法与描述
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      Methods in org.w3c.dom.ls with parameters of type Node
      修饰符与类型 方法与描述
      short LSParserFilter.acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.w3c.dom.NodeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.NodeList

  • Packages that use NodeList
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of NodeList in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement NodeList
      修饰符与类型 类与描述
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Methods in javax.imageio.metadata that return NodeList
      修饰符与类型 | 方法与描述
      NodeList IIOMetadataNode.getChildNodes()
      Returns a NodeList that contains all children of this node.
      NodeList | IIOMetadataNode.getElementsByTagName(String name)
      NodeList IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName)
      Equivalent to getElementsByTagName(localName).

    • Uses of NodeList in org.w3c.dom

      Methods in org.w3c.dom that return NodeList
      修饰符与类型 方法与描述
      NodeList Node.getChildNodes()
      A NodeList that contains all children of this node.
      NodeList Element.getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList Document.getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      NodeList Document.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n.onexit hhhoo>>pdo.N>r/>s


Uses of Interface org.w3c.dom.Notation

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Notation

No usage of org.w3c.dom.Notation
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t>o llollyyyodiii.het


Uses of Interface org.w3c.dom.ProcessingInstruction

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ProcessingInstruction

  • Packages that use ProcessingInstruction
    软件包 描述
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of ProcessingInstruction in org.w3c.dom

      Methods in org.w3c.dom that return ProcessingInstruction
      修饰符与类型 方法与描述
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

etamhr n s/nle.ar/oy>


Uses of Interface org.w3c.dom.Text

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.Text

  • Packages that use Text
    软件包 描述
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Text in javax.xml.soap

      Subinterfaces of Text in javax.xml.soap
      修饰符与类型 Interface and Description
      interface  Text
      A representation of a node whose value is text.

    • Uses of Text in org.w3c.dom

      Subinterfaces of Text in org.w3c.dom
      修饰符与类型 Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      Methods in org.w3c.dom that return Text
      修饰符与类型 方法与描述
      Text Document.createTextNode(String data)
      Creates a Text node given the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rn


Uses of Interface org.w3c.dom.TypeInfo

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.TypeInfo

  • Packages that use TypeInfo
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of TypeInfo in javax.imageio.metadata

      Methods in javax.imageio.metadata that return TypeInfo
      修饰符与类型 方法与描述
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of TypeInfo in javax.xml.validation

      Methods in javax.xml.validation that return TypeInfo
      修饰符与类型 方法与描述
      abstract TypeInfo TypeInfoProvider.getAttributeTypeInfo(int index)
      Returns the immutable TypeInfo object for the specified attribute of the current element.
      abstract TypeInfo TypeInfoProvider.getElementTypeInfo()
      Returns the immutable TypeInfo object for the current element.

    • Uses of TypeInfo in org.w3c.dom

      Methods in org.w3c.dom that return TypeInfo
      修饰符与类型 方法与描述
      TypeInfo Element.getSchemaTypeInfo()
      The type information associated with this element.
      TypeInfo Attr.getSchemaTypeInfo()
      The type information associated with this attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.w3c.dom.UserDataHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.UserDataHandler

  • Packages that use UserDataHandler
    软件包 描述
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of UserDataHandler in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type UserDataHandler
      修饰符与类型 方法与描述
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of UserDataHandler in org.w3c.dom

      Methods in org.w3c.dom with parameters of type UserDataHandler
      修饰符与类型 方法与描述
      Object Node.setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


DocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface DocumentEvent

  • public interface DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation. It is expected that the DocumentEvent interface will be implemented on the same object which implements the Document interface in an implementation which supports the Event model.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 方法摘要

      Methods
      修饰符与类型 | 方法与描述
      Event | createEvent(String eventType)

    • 方法详细信息

      • createEvent

        Event createEvent(String eventType)
                  throws DOMException
        参数：
        eventType - The eventType parameter specifies the type of Event interface to be created. If the Event interface specified is supported by the implementation this method will return a new Event of the interface type requested. If the Event is to be dispatched via the dispatchEvent method the appropriate event init method must be called after creation in order to initialize the Event's values. As an example, a user wishing to synthesize some kind of UIEvent would call createEvent with the parameter "UIEvents". The initUIEvent method could then be called on the newly created UIEvent to set the specific type of UIEvent to be dispatched and set its context information.The createEvent method is used in creating Events when it is either inconvenient or unnecessary for the user to create an Event themselves. In cases where the implementation provided Event is insufficient, users may supply their own Event implementations for use with the dispatchEvent method.
        返回：
        The newly created Event
        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if the implementation does not support the type of Event interface requested
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

clRtty;>.=yi(pasoot


Event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface Event

  • All Known Subinterfaces:
    LSLoadEvent, LSProgressEvent, MouseEvent, MutationEvent, UIEvent

    public interface Event
    The Event interface is used to provide contextual information about an event to the handler processing the event. An object which implements the Event interface is generally passed as the first parameter to an event handler. More specific context information is passed to event handlers by deriving additional interfaces from Event which contain information directly relating to the type of event they accompany. These derived interfaces are also implemented by the object passed to the event listener.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short AT_TARGET
      The event is currently being evaluated at the target EventTarget.
      static short BUBBLING_PHASE
      The current event phase is the bubbling phase.
      static short CAPTURING_PHASE
      The current event phase is the capturing phase.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean getBubbles()
      Used to indicate whether or not an event is a bubbling event.
      boolean getCancelable()
      Used to indicate whether or not an event can have its default action prevented.
      EventTarget getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      short getEventPhase()
      Used to indicate which phase of event flow is currently being evaluated.
      EventTarget getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      long getTimeStamp()
      Used to specify the time (in milliseconds relative to the epoch) at which the event was created.
      String getType()
      The name of the event (case-insensitive).
      void initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)
      The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
      void preventDefault()
      If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur.
      void stopPropagation()
      The stopPropagation method is used prevent further propagation of an event during event flow.

    • 字段详细信息

      • CAPTURING_PHASE

        static final short CAPTURING_PHASE
        The current event phase is the capturing phase.
        另请参见：
        Constant Field Values

      • AT_TARGET

        static final short AT_TARGET
        The event is currently being evaluated at the target EventTarget.
        另请参见：
        Constant Field Values

      • BUBBLING_PHASE

        static final short BUBBLING_PHASE
        The current event phase is the bubbling phase.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getType

        String getType()
        The name of the event (case-insensitive). The name must be an XML name.

      • getTarget

        EventTarget getTarget()
        Used to indicate the EventTarget to which the event was originally dispatched.

      • getCurrentTarget

        EventTarget getCurrentTarget()
        Used to indicate the EventTarget whose EventListeners are currently being processed. This is particularly useful during capturing and bubbling.

      • getEventPhase

        short getEventPhase()
        Used to indicate which phase of event flow is currently being evaluated.

      • getBubbles

        boolean getBubbles()
        Used to indicate whether or not an event is a bubbling event. If the event can bubble the value is true, else the value is false.

      • getCancelable

        boolean getCancelable()
        Used to indicate whether or not an event can have its default action prevented. If the default action can be prevented the value is true, else the value is false.

      • getTimeStamp

        long getTimeStamp()
        Used to specify the time (in milliseconds relative to the epoch) at which the event was created. Due to the fact that some systems may not provide this information the value of timeStamp may be not available for all events. When not available, a value of 0 will be returned. Examples of epoch time are the time of the system start or 0:0:0 UTC 1st January 1970.

      • stopPropagation

        void stopPropagation()
        The stopPropagation method is used prevent further propagation of an event during event flow. If this method is called by any EventListener the event will cease propagating through the tree. The event will complete dispatch to all listeners on the current EventTarget before event flow stops. This method may be used during any stage of event flow.

      • preventDefault

        void preventDefault()
        If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur. If, during any stage of event flow, the preventDefault method is called the event is canceled. Any default action associated with the event will not occur. Calling this method for a non-cancelable event has no effect. Once preventDefault has been called it will remain in effect throughout the remainder of the event's propagation. This method may be used during any stage of event flow.

      • initEvent

        void initEvent(String eventTypeArg,
             boolean canBubbleArg,
             boolean cancelableArg)
        The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface. This method may only be called before the Event has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times the final invocation takes precedence. If called from a subclass of Event interface only the values specified in the initEvent method are modified, all other attributes are left unchanged.
        参数：
        eventTypeArg - Specifies the event type. This type may be any event type currently defined in this specification or a new event type.. The string must be an XML name. Any new event type must not begin with any upper, lower, or mixed case version of the string "DOM". This prefix is reserved for future DOM event sets. It is also strongly recommended that third parties adding their own events use their own prefix to avoid confusion and lessen the probability of conflicts with other new events.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tscauea, der>a莕petaren>�


EventException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.w3c.dom.events

类 EventException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException
  • 所有已实现的接口：
    Serializable

    public class EventException
extends RuntimeException
    Event operations may throw an EventException as specified in their method descriptions.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2
    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short | code
      static short UNSPECIFIED_EVENT_TYPE_ERR
      If the Event's type was not specified by initializing the event before the method was called.

    • 构造方法摘要

      Constructors
      构造方法与描述
      EventException(short code, String message)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • code

        public short code

      • UNSPECIFIED_EVENT_TYPE_ERR

        public static final short UNSPECIFIED_EVENT_TYPE_ERR
        If the Event's type was not specified by initializing the event before the method was called. Specification of the Event's type as null or an empty string will also trigger this exception.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • EventException

        public EventException(short code,
              String message)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

entslcsocss==sssiillbb in i/ gv>/ldinag


EventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface EventListener

  • public interface EventListener
    The EventListener interface is the primary method for handling events. Users implement the EventListener interface and register their listener on an EventTarget using the AddEventListener method. The users should also remove their EventListener from its EventTarget after they have completed using the listener.

    When a Node is copied using the cloneNode method the EventListeners attached to the source Node are not attached to the copied Node. If the user wishes the same EventListeners to be added to the newly created copy the user must add them manually.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • 方法详细信息

      • handleEvent

        void handleEvent(Event evt)
        This method is called whenever an event occurs of the type for which the EventListener interface was registered.
        参数：
        evt - The Event contains contextual information about the event. It also contains the stopPropagation and preventDefault methods which are used in determining the event's flow and default action.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gl)lc.Ot.O/bbO////eelyltor.bjj=(O


EventTarget

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface EventTarget

  • public interface EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model. Therefore, this interface can be obtained by using binding-specific casting methods on an instance of the Node interface. The interface allows registration and removal of EventListeners on an EventTarget and dispatch of events to that EventTarget.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      boolean dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.

    • 方法详细信息

      • addEventListener

        void addEventListener(String type,
                    EventListener listener,
                    boolean useCapture)
        This method allows the registration of event listeners on the event target. If an EventListener is added to an EventTarget while it is processing an event, it will not be triggered by the current actions but may be triggered during a later stage of event flow, such as the bubbling phase.
        If multiple identical EventListeners are registered on the same EventTarget with the same parameters the duplicate instances are discarded. They do not cause the EventListener to be called twice and since they are discarded they do not need to be removed with the removeEventListener method.
        参数：
        type - The event type for which the user is registering
        listener - The listener parameter takes an interface implemented by the user which contains the methods to be called when the event occurs.
        useCapture - If true, useCapture indicates that the user wishes to initiate capture. After initiating capture, all events of the specified type will be dispatched to the registered EventListener before being dispatched to any EventTargets beneath them in the tree. Events which are bubbling upward through the tree will not trigger an EventListener designated to use capture.

      • removeEventListener

        void removeEventListener(String type,
                       EventListener listener,
                       boolean useCapture)
        This method allows the removal of event listeners from the event target. If an EventListener is removed from an EventTarget while it is processing an event, it will not be triggered by the current actions. EventListeners can never be invoked after being removed.
        Calling removeEventListener with arguments which do not identify any currently registered EventListener on the EventTarget has no effect.
        参数：
        type - Specifies the event type of the EventListener being removed.
        listener - The EventListener parameter indicates the EventListener to be removed.
        useCapture - Specifies whether the EventListener being removed was registered as a capturing listener or not. If a listener was registered twice, one with capture and one without, each must be removed separately. Removal of a capturing listener does not affect a non-capturing version of the same listener, and vice versa.

      • dispatchEvent

        boolean dispatchEvent(Event evt)
                      throws EventException
        This method allows the dispatch of events into the implementations event model. Events dispatched in this manner will have the same capturing and bubbling behavior as events dispatched directly by the implementation. The target of the event is the EventTarget on which dispatchEvent is called.
        参数：
        evt - Specifies the event type, behavior, and contextual information to be used in processing the event.
        返回：
        The return value of dispatchEvent indicates whether any of the listeners which handled the event called preventDefault. If preventDefault was called the value is false, else the value is true.
        抛出：
        EventException - UNSPECIFIED_EVENT_TYPE_ERR: Raised if the Event's type was not specified by initializing the event before dispatchEvent was called. Specification of the Event's type as null or an empty string will also trigger this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lpli hythceiic>etk k:"b"e/TL"Lti


MouseEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface MouseEvent

  • All Superinterfaces:
    Event, UIEvent

    public interface MouseEvent
extends UIEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.

    The detail attribute inherited from UIEvent indicates the number of times a mouse button has been pressed and released over the same screen location during a user action. The attribute value is 1 when the user begins this action and increments by 1 for each full sequence of pressing and releasing. If the user moves the mouse between the mousedown and mouseup the value will be set to 0, indicating that no click is occurring.

    In the case of nested elements mouse events are always targeted at the most deeply nested element. Ancestors of the targeted element may use bubbling to obtain notification of mouse events which occur within its descendent elements.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean getAltKey()
      Used to indicate whether the 'alt' key was depressed during the firing of the event.
      short getButton()
      During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.
      int getClientX()
      The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.
      int getClientY()
      The vertical coordinate at which the event occurred relative to the DOM implementation's client area.
      boolean getCtrlKey()
      Used to indicate whether the 'ctrl' key was depressed during the firing of the event.
      boolean getMetaKey()
      Used to indicate whether the 'meta' key was depressed during the firing of the event.
      EventTarget getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      int getScreenX()
      The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.
      int getScreenY()
      The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.
      boolean getShiftKey()
      Used to indicate whether the 'shift' key was depressed during the firing of the event.
      void initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.

      • 方法 - 继承于接口 org.w3c.dom.events.UIEvent

        getDetail, getView, initUIEvent

      • 方法 - 继承于接口 org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • 方法详细信息

      • getScreenX

        int getScreenX()
        The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getScreenY

        int getScreenY()
        The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getClientX

        int getClientX()
        The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

      • getClientY

        int getClientY()
        The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

      • getCtrlKey

        boolean getCtrlKey()
        Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

      • getShiftKey

        boolean getShiftKey()
        Used to indicate whether the 'shift' key was depressed during the firing of the event.

      • getAltKey

        boolean getAltKey()
        Used to indicate whether the 'alt' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getMetaKey

        boolean getMetaKey()
        Used to indicate whether the 'meta' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getButton

        short getButton()
        During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state. The values for button range from zero to indicate the left button of the mouse, one to indicate the middle button if present, and two to indicate the right button. For mice configured for left handed use in which the button actions are reversed the values are instead read from right to left.

      • getRelatedTarget

        EventTarget getRelatedTarget()
        Used to identify a secondary EventTarget related to a UI event. Currently this attribute is used with the mouseover event to indicate the EventTarget which the pointing device exited and with the mouseout event to indicate the EventTarget which the pointing device entered.

      • initMouseEvent

        void initMouseEvent(String typeArg,
                  boolean canBubbleArg,
                  boolean cancelableArg,
                  org.w3c.dom.views.AbstractView viewArg,
                  int detailArg,
                  int screenXArg,
                  int screenYArg,
                  int clientXArg,
                  int clientYArg,
                  boolean ctrlKeyArg,
                  boolean altKeyArg,
                  boolean shiftKeyArg,
                  boolean metaKeyArg,
                  short buttonArg,
                  EventTarget relatedTargetArg)
        The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface. This method may only be called before the MouseEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        参数：
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's mouse click count.
        screenXArg - Specifies the Event's screen x coordinate
        screenYArg - Specifies the Event's screen y coordinate
        clientXArg - Specifies the Event's client x coordinate
        clientYArg - Specifies the Event's client y coordinate
        ctrlKeyArg - Specifies whether or not control key was depressed during the Event.
        altKeyArg - Specifies whether or not alt key was depressed during the Event.
        shiftKeyArg - Specifies whether or not shift key was depressed during the Event.
        metaKeyArg - Specifies whether or not meta key was depressed during the Event.
        buttonArg - Specifies the Event's mouse button.
        relatedTargetArg - Specifies the Event's related EventTarget.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

xlop.nLin -.t>srho >eb <-"na�/iei


MutationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface MutationEvent

  • All Superinterfaces:
    Event

    public interface MutationEvent
extends Event
    The MutationEvent interface provides specific contextual information associated with Mutation events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short ADDITION
      The Attr was just added.
      static short MODIFICATION
      The Attr was modified in place.
      static short REMOVAL
      The Attr was just removed.

      • 字段 - 继承于接口 org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      short getAttrChange()
      attrChange indicates the type of change which triggered the DOMAttrModified event.
      String getAttrName()
      attrName indicates the name of the changed Attr node in a DOMAttrModified event.
      String getNewValue()
      newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      String getPrevValue()
      prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      Node getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      void initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

      • 方法 - 继承于接口 org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • 字段详细信息

      • MODIFICATION

        static final short MODIFICATION
        The Attr was modified in place.
        另请参见：
        Constant Field Values

      • ADDITION

        static final short ADDITION
        The Attr was just added.
        另请参见：
        Constant Field Values

      • REMOVAL

        static final short REMOVAL
        The Attr was just removed.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getRelatedNode

        Node getRelatedNode()
        relatedNode is used to identify a secondary node related to a mutation event. For example, if a mutation event is dispatched to a node indicating that its parent has changed, the relatedNode is the changed parent. If an event is instead dispatched to a subtree indicating a node was changed within it, the relatedNode is the changed node. In the case of the DOMAttrModified event it indicates the Attr node which was modified, added, or removed.

      • getPrevValue

        String getPrevValue()
        prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getNewValue

        String getNewValue()
        newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getAttrName

        String getAttrName()
        attrName indicates the name of the changed Attr node in a DOMAttrModified event.

      • getAttrChange

        short getAttrChange()
        attrChange indicates the type of change which triggered the DOMAttrModified event. The values can be MODIFICATION , ADDITION, or REMOVAL.

      • initMutationEvent

        void initMutationEvent(String typeArg,
                     boolean canBubbleArg,
                     boolean cancelableArg,
                     Node relatedNodeArg,
                     String prevValueArg,
                     String newValueArg,
                     String attrNameArg,
                     short attrChangeArg)
        The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface. This method may only be called before the MutationEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        参数：
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        relatedNodeArg - Specifies the Event's related Node.
        prevValueArg - Specifies the Event's prevValue attribute. This value may be null.
        newValueArg - Specifies the Event's newValue attribute. This value may be null.
        attrNameArg - Specifies the Event's attrName attribute. This value may be null.
        attrChangeArg - Specifies the Event's attrChange attribute
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

S>trlr;r>rommrooPenn../=..p-./././. >mu


org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException
e


org.w3c.dom.events

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.w3c.dom.events

  • 接口摘要
    接口 描述
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception 描述
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tdivoenodmeeor..socs="lt�


org.w3c.dom.events Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.w3c.dom.events

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException

Interface Hierarchy

  • org.w3c.dom.events.DocumentEvent
  • org.w3c.dom.events.Event
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

iidLssn"vi"vl a騛arl


UIEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.events

Interface UIEvent

  • All Superinterfaces:
    Event
    All Known Subinterfaces:
    MouseEvent

    public interface UIEvent
extends Event
    The UIEvent interface provides specific contextual information associated with User Interface events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    从以下版本开始：
    DOM Level 2

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getDetail()
      Specifies some detail information about the Event, depending on the type of event.
      org.w3c.dom.views.AbstractView getView()
      The view attribute identifies the AbstractView from which the event was generated.
      void initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

      • 方法 - 继承于接口 org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • 方法详细信息

      • getView

        org.w3c.dom.views.AbstractView getView()
        The view attribute identifies the AbstractView from which the event was generated.

      • getDetail

        int getDetail()
        Specifies some detail information about the Event, depending on the type of event.

      • initUIEvent

        void initUIEvent(String typeArg,
               boolean canBubbleArg,
               boolean cancelableArg,
               org.w3c.dom.views.AbstractView viewArg,
               int detailArg)
        The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface. This method may only be called before the UIEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        参数：
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's detail.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

<===l.A/IIA


Uses of Package org.w3c.dom.events

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.w3c.dom.events

  • Packages that use org.w3c.dom.events
    软件包 描述
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom.events used by org.w3c.dom.events
    类与描述
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Classes in org.w3c.dom.events used by org.w3c.dom.ls
    类与描述
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n liwsds/ eno.fl�.！蘳ib


Uses of Class org.w3c.dom.events.EventException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.w3c.dom.events.EventException

  • Packages that use EventException
    软件包 描述
    org.w3c.dom.events

    • Uses of EventException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw EventException
      修饰符与类型 方法与描述
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>E<.///gEssrco


Uses of Interface org.w3c.dom.events.DocumentEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.DocumentEvent

No usage of org.w3c.dom.events.DocumentEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ad.�/>


Uses of Interface org.w3c.dom.events.Event

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.Event

  • Packages that use Event
    软件包 描述
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Event in org.w3c.dom.events

      Subinterfaces of Event in org.w3c.dom.events
      修饰符与类型 Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
      interface  MutationEvent
      The MutationEvent interface provides specific contextual information associated with Mutation events.
      interface  UIEvent
      The UIEvent interface provides specific contextual information associated with User Interface events.
      Methods in org.w3c.dom.events that return Event
      修饰符与类型 | 方法与描述
      Event | DocumentEvent.createEvent(String eventType)
      Methods in org.w3c.dom.events with parameters of type Event
      修饰符与类型 方法与描述
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void EventListener.handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Uses of Event in org.w3c.dom.ls

      Subinterfaces of Event in org.w3c.dom.ls
      修饰符与类型 Interface and Description
      interface  LSLoadEvent
      This interface represents a load event object that signals the completion of a document load.
      interface  LSProgressEvent
      This interface represents a progress event object that notifies the application about progress as a document is parsed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

. es>trv獃<


Uses of Interface org.w3c.dom.events.EventListener

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.EventListener

  • Packages that use EventListener
    软件包 描述
    org.w3c.dom.events

    • Uses of EventListener in org.w3c.dom.events

      Methods in org.w3c.dom.events with parameters of type EventListener
      修饰符与类型 方法与描述
      void EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      void EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>tVglas/


Uses of Interface org.w3c.dom.events.EventTarget

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.EventTarget

  • Packages that use EventTarget
    软件包 描述
    org.w3c.dom.events

    • Uses of EventTarget in org.w3c.dom.events

      Methods in org.w3c.dom.events that return EventTarget
      修饰符与类型 方法与描述
      EventTarget Event.getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      EventTarget MouseEvent.getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      EventTarget Event.getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      Methods in org.w3c.dom.events with parameters of type EventTarget
      修饰符与类型 方法与描述
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/noel"�..htmv.alMt>{> /f


Uses of Interface org.w3c.dom.events.MouseEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.MouseEvent

No usage of org.w3c.dom.events.MouseEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

drafide dtttU" Rtra<


Uses of Interface org.w3c.dom.events.MutationEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.MutationEvent

No usage of org.w3c.dom.events.MutationEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i.osra葀nn>naticd..f


Uses of Interface org.w3c.dom.events.UIEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.events.UIEvent

  • Packages that use UIEvent
    软件包 描述
    org.w3c.dom.events

    • Uses of UIEvent in org.w3c.dom.events

      Subinterfaces of UIEvent in org.w3c.dom.events
      修饰符与类型 Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ebii


DOMImplementationLS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface DOMImplementationLS

  • public interface DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.

    The expectation is that an instance of the DOMImplementationLS interface can be obtained by using binding-specific casting methods on an instance of the DOMImplementation interface or, if the Document supports the feature "Core" version "3.0" defined in [DOM Level 3 Core] , by using the method DOMImplementation.getFeature with parameter values "LS" (or "LS-Async") and "3.0" (respectively).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short MODE_ASYNCHRONOUS
      Create an asynchronous LSParser.
      static short MODE_SYNCHRONOUS
      Create a synchronous LSParser.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LSInput createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSOutput createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      LSParser createLSParser(short mode, String schemaType)
      Create a new LSParser.
      LSSerializer createLSSerializer()
      Create a new LSSerializer object.

    • 字段详细信息

      • MODE_SYNCHRONOUS

        static final short MODE_SYNCHRONOUS
        Create a synchronous LSParser.
        另请参见：
        Constant Field Values

      • MODE_ASYNCHRONOUS

        static final short MODE_ASYNCHRONOUS
        Create an asynchronous LSParser.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • createLSParser

        LSParser createLSParser(short mode,
                      String schemaType)
                        throws DOMException
        Create a new LSParser. The newly constructed parser may then be configured by means of its DOMConfiguration object, and used to parse documents by means of its parse method.
        参数：
        mode - The mode argument is either MODE_SYNCHRONOUS or MODE_ASYNCHRONOUS, if mode is MODE_SYNCHRONOUS then the LSParser that is created will operate in synchronous mode, if it's MODE_ASYNCHRONOUS then the LSParser that is created will operate in asynchronous mode.
        schemaType - An absolute URI representing the type of the schema language used during the load of a Document using the newly created LSParser. Note that no lexical checking is done on the absolute URI. In order to create a LSParser for any kind of schema types (i.e. the LSParser will be free to use any schema found), use the value null.

        Note: For W3C XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other Schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

        返回：
        The newly created LSParser object. This LSParser is either synchronous or asynchronous depending on the value of the mode argument.

        Note: By default, the newly created LSParser does not contain a DOMErrorHandler, i.e. the value of the " error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSParser object contains a reference to the default error handler.

        抛出：
        DOMException - NOT_SUPPORTED_ERR: Raised if the requested mode or schema type is not supported.

      • createLSSerializer

        LSSerializer createLSSerializer()
        Create a new LSSerializer object.
        返回：
        The newly created LSSerializer object.

        Note: By default, the newly created LSSerializer has no DOMErrorHandler, i.e. the value of the "error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSSerializer object contains a reference to the default error handler.

      • createLSInput

        LSInput createLSInput()
        Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
        返回：
        The newly created input object.

      • createLSOutput

        LSOutput createLSOutput()
        Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
        返回：
        The newly created output object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e>cotrgvmh=b


LSException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.w3c.dom.ls

类 LSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException
  • 所有已实现的接口：
    Serializable

    public class LSException
extends RuntimeException
    Parser or write operations may throw an LSException if the processing is stopped. The processing can be stopped due to a DOMError with a severity of DOMError.SEVERITY_FATAL_ERROR or a non recovered DOMError.SEVERITY_ERROR, or if DOMErrorHandler.handleError() returned false.

    Note: As suggested in the definition of the constants in the DOMError interface, a DOM implementation may choose to continue after a fatal error, but the resulting DOM tree is then implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    另请参见：
    Serialized Form

    • 字段摘要

      Fields
      修饰符与类型 | 字段与描述
      short | code
      static short PARSE_ERR
      If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
      static short SERIALIZE_ERR
      If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.

    • 构造方法摘要

      Constructors
      构造方法与描述
      LSException(short code, String message)

    • 方法摘要

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 字段详细信息

      • code

        public short code

      • PARSE_ERR

        public static final short PARSE_ERR
        If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
        另请参见：
        Constant Field Values

      • SERIALIZE_ERR

        public static final short SERIALIZE_ERR
        If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.
        另请参见：
        Constant Field Values

    • 构造方法详细信息

      • LSException

        public LSException(short code,
           String message)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=k= BT OT TOTRTT ==>i/ />> ///ul /=


LSInput

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSInput

  • public interface LSInput
    This interface represents an input source for data.

    This interface allows an application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSInput() to create objects that implement this interface.

    The LSParser will use the LSInput object to determine how to read data. The LSParser will look at the different inputs specified in the LSInput in the following order to know which one to read from, the first one that is not null and not an empty string will be used:

    1. LSInput.characterStream
    2. LSInput.byteStream
    3. LSInput.stringData
    4. LSInput.systemId
    5. LSInput.publicId

    If all inputs are null, the LSParser will report a DOMError with its DOMError.type set to "no-input-specified" and its DOMError.severity set to DOMError.SEVERITY_FATAL_ERROR.

    LSInput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getBaseURI()
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      InputStream getByteStream()
      An attribute of a language and binding dependent type that represents a stream of bytes.
      boolean getCertifiedText()
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      Reader getCharacterStream()
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      String getEncoding()
      The character encoding, if known.
      String getPublicId()
      The public identifier for this input source.
      String getStringData()
      String data to parse.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this input source.
      void setBaseURI(String baseURI)
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      void setByteStream(InputStream byteStream)
      An attribute of a language and binding dependent type that represents a stream of bytes.
      void setCertifiedText(boolean certifiedText)
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      void setCharacterStream(Reader characterStream)
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      void setEncoding(String encoding)
      The character encoding, if known.
      void setPublicId(String publicId)
      The public identifier for this input source.
      void setStringData(String stringData)
      String data to parse.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this input source.

    • 方法详细信息

      • getCharacterStream

        Reader getCharacterStream()
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setCharacterStream

        void setCharacterStream(Reader characterStream)
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getByteStream

        InputStream getByteStream()
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • setByteStream

        void setByteStream(InputStream byteStream)
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • getStringData

        String getStringData()
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setStringData

        void setStringData(String stringData)
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • getPublicId

        String getPublicId()
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • setPublicId

        void setPublicId(String publicId)
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • getBaseURI

        String getBaseURI()
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • setBaseURI

        void setBaseURI(String baseURI)
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • setEncoding

        void setEncoding(String encoding)
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • getCertifiedText

        boolean getCertifiedText()
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

      • setCertifiedText

        void setCertifiedText(boolean certifiedText)
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r>vat eh.e di/mo<>l e�>


LSLoadEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSLoadEvent

  • All Superinterfaces:
    Event

    public interface LSLoadEvent
extends Event
    This interface represents a load event object that signals the completion of a document load.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LSInput getInput()
      The input source that was parsed.
      Document getNewDocument()
      The document that finished loading.

      • 方法 - 继承于接口 org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • 方法详细信息

      • getNewDocument

        Document getNewDocument()
        The document that finished loading.

      • getInput

        LSInput getInput()
        The input source that was parsed.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltet/>ea>eTxxeTTi>xxe>aed


LSOutput

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSOutput

  • public interface LSOutput
    This interface represents an output destination for data.

    This interface allows an application to encapsulate information about an output destination in a single object, which may include a URI, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSOutput() to create objects that implement this interface.

    The LSSerializer will use the LSOutput object to determine where to serialize the output to. The LSSerializer will look at the different outputs specified in the LSOutput in the following order to know which one to output to, the first one that is not null and not an empty string will be used:

    1. LSOutput.characterStream
    2. LSOutput.byteStream
    3. LSOutput.systemId

    LSOutput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      OutputStream getByteStream()
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      Writer getCharacterStream()
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      String getEncoding()
      The character encoding to use for the output.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.
      void setByteStream(OutputStream byteStream)
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      void setCharacterStream(Writer characterStream)
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      void setEncoding(String encoding)
      The character encoding to use for the output.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.

    • 方法详细信息

      • getCharacterStream

        Writer getCharacterStream()
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • setCharacterStream

        void setCharacterStream(Writer characterStream)
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • getByteStream

        OutputStream getByteStream()
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • setByteStream

        void setByteStream(OutputStream byteStream)
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.

      • setEncoding

        void setEncoding(String encoding)
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

vta.=. ".h rrh tSool vlu llls


LSParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSParser

  • public interface LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.

    LSParser provides an API for parsing XML and building the corresponding DOM document structure. A LSParser instance can be obtained by invoking the DOMImplementationLS.createLSParser() method.

    As specified in [DOM Level 3 Core] , when a document is first made available via the LSParser:

    • there will never be two adjacent nodes of type NODE_TEXT, and there will never be empty text nodes.
    • it is expected that the value and nodeValue attributes of an Attr node initially return the XML 1.0 normalized value. However, if the parameters " validate-if-schema" and " datatype-normalization" are set to true, depending on the attribute normalization used, the attribute values may differ from the ones obtained by the XML 1.0 attribute normalization. If the parameters " datatype-normalization" is set to false, the XML 1.0 attribute normalization is guaranteed to occur, and if the attributes list does not contain namespace declarations, the attributes attribute on Element node represents the property [attributes] defined in [XML Information Set] .

    Asynchronous LSParser objects are expected to also implement the events::EventTarget interface so that event listeners can be registered on asynchronous LSParser objects.

    Events supported by asynchronous LSParser objects are:

    load
    The LSParser finishes to load the document. See also the definition of the LSLoadEvent interface.
    progress
    The LSParser signals progress as data is parsed. This specification does not attempt to define exactly when progress events should be dispatched. That is intentionally left as implementation-dependent. Here is one example of how an application might dispatch progress events: Once the parser starts receiving data, a progress event is dispatched to indicate that the parsing starts. From there on, a progress event is dispatched for every 4096 bytes of data that is received and processed. This is only one example, though, and implementations can choose to dispatch progress events at any time while parsing, or not dispatch them at all. See also the definition of the LSProgressEvent interface.

    Note: All events defined in this specification use the namespace URI "http://www.w3.org/2002/DOMLS".

    While parsing an input source, errors are reported to the application through the error handler (LSParser.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors that can occur while parsing XML, or any other markup, but some common error cases are defined. The types (DOMError.type) of errors and warnings defined by this specification are:

    "check-character-normalization-failure" [error]
    Raised if the parameter " check-character-normalization" is set to true and a string is encountered that fails normalization checking.
    "doctype-not-allowed" [fatal]
    Raised if the configuration parameter "disallow-doctype" is set to true and a doctype is encountered.
    "no-input-specified" [fatal]
    Raised when loading a document and no input is specified in the LSInput object.
    "pi-base-uri-not-preserved" [warning]
    Raised if a processing instruction is encountered in a location where the base URI of the processing instruction can not be preserved. One example of a case where this warning will be raised is if the configuration parameter " entities" is set to false and the following XML file is parsed:
     <!DOCTYPE root [ <!ENTITY e SYSTEM 'subdir/myentity.ent' ]>
 <root> &e; </root>
    And subdir/myentity.ent contains:
    <one> <two/> </one> <?pi 3.14159?>
 <more/>
    "unbound-prefix-in-entity" [warning]
    An implementation dependent warning that may be raised if the configuration parameter " namespaces" is set to true and an unbound namespace prefix is encountered in an entity's replacement text. Raising this warning is not enforced since some existing parsers may not recognize unbound namespace prefixes in the replacement text of entities.
    "unknown-character-denormalization" [fatal]
    Raised if the configuration parameter "ignore-unknown-character-denormalizations" is set to false and a character is encountered for which the processor cannot determine the normalization properties.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.
    "unsupported-media-type" [fatal]
    Raised if the configuration parameter "supported-media-types-only" is set to true and an unsupported media type is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...), XML well-formedness errors, and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short ACTION_APPEND_AS_CHILDREN
      Append the result of the parse operation as children of the context node.
      static short ACTION_INSERT_AFTER
      Insert the result of the parse operation as the immediately following sibling of the context node.
      static short ACTION_INSERT_BEFORE
      Insert the result of the parse operation as the immediately preceding sibling of the context node.
      static short ACTION_REPLACE
      Replace the context node with the result of the parse operation.
      static short ACTION_REPLACE_CHILDREN
      Replace all the children of the context node with the result of the parse operation.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void abort()
      Abort the loading of the document that is currently being loaded by the LSParser.
      boolean getAsync()
      true if the LSParser is asynchronous, false if it is synchronous.
      boolean getBusy()
      true if the LSParser is currently busy loading a document, otherwise false.
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used when parsing an input source.
      LSParserFilter getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Document parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      void setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

    • 字段详细信息

      • ACTION_APPEND_AS_CHILDREN

        static final short ACTION_APPEND_AS_CHILDREN
        Append the result of the parse operation as children of the context node. For this action to work, the context node must be an Element or a DocumentFragment.
        另请参见：
        Constant Field Values

      • ACTION_REPLACE_CHILDREN

        static final short ACTION_REPLACE_CHILDREN
        Replace all the children of the context node with the result of the parse operation. For this action to work, the context node must be an Element, a Document, or a DocumentFragment.
        另请参见：
        Constant Field Values

      • ACTION_INSERT_BEFORE

        static final short ACTION_INSERT_BEFORE
        Insert the result of the parse operation as the immediately preceding sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        另请参见：
        Constant Field Values

      • ACTION_INSERT_AFTER

        static final short ACTION_INSERT_AFTER
        Insert the result of the parse operation as the immediately following sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        另请参见：
        Constant Field Values

      • ACTION_REPLACE

        static final short ACTION_REPLACE
        Replace the context node with the result of the parse operation. For this action to work, the context node must have a parent, and the parent must be an Element or a DocumentFragment.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used when parsing an input source. This DOMConfiguration is specific to the parse operation. No parameter values from this DOMConfiguration object are passed automatically to the DOMConfiguration object on the Document that is created, or used, by the parse operation. The DOM application is responsible for passing any needed parameter values from this DOMConfiguration object to the DOMConfiguration object referenced by the Document object.
        In addition to the parameters recognized in on the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSParser add or modify the following parameters:
        "charset-overrides-xml-encoding"
        true
        [optional] (default) If a higher level protocol such as HTTP [IETF RFC 2616] provides an indication of the character encoding of the input stream being processed, that will override any encoding specified in the XML declaration or the Text declaration (see also section 4.3.3, "Character Encoding in Entities", in [XML 1.0]). Explicitly setting an encoding in the LSInput overrides any encoding from the protocol.
        false
        [required] The parser ignores any character set encoding information from higher-level protocols.
        "disallow-doctype"
        true
        [optional] Throw a fatal "doctype-not-allowed" error if a doctype node is found while parsing the document. This is useful when dealing with things like SOAP envelopes where doctype nodes are not allowed.
        false
        [required] (default) Allow doctype nodes in the document.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a processor encounters characters for which it cannot determine the normalization properties, then the processor will ignore any possible denormalizations caused by these characters. This parameter is ignored for [XML 1.0].
        false
        [optional] Report an fatal "unknown-character-denormalization" error if a character is encountered for which the processor cannot determine the normalization properties.
        "infoset"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter will default to true for LSParser.
        "namespaces"
        true
        [required] (default) Perform the namespace processing as defined in [XML Namespaces] and [XML Namespaces 1.1] .
        false
        [optional] Do not perform the namespace processing.
        "resource-resolver"
        [required] A reference to a LSResourceResolver object, or null. If the value of this parameter is not null when an external resource (such as an external XML entity or an XML schema location) is encountered, the implementation will request that the LSResourceResolver referenced in this parameter resolves the resource.
        "supported-media-types-only"
        true
        [optional] Check that the media type of the parsed resource is a supported media type. If an unsupported media type is encountered, a fatal error of type "unsupported-media-type" will be raised. The media types defined in [IETF RFC 3023] must always be accepted.
        false
        [required] (default) Accept any media type.
        "validate"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "validate-if-schema"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "well-formed"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter cannot be set to false.

      • getFilter

        LSParserFilter getFilter()
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • setFilter

        void setFilter(LSParserFilter filter)
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • getAsync

        boolean getAsync()
        true if the LSParser is asynchronous, false if it is synchronous.

      • getBusy

        boolean getBusy()
        true if the LSParser is currently busy loading a document, otherwise false.

      • parse

        Document parse(LSInput input)
               throws DOMException,
                      LSException
        Parse an XML document from a resource identified by a LSInput.
        参数：
        input - The LSInput from which the source of the document is to be read.
        返回：
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        抛出：
        DOMException - INVALID_STATE_ERR: Raised if the LSParser's LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseURI

        Document parseURI(String uri)
                  throws DOMException,
                         LSException
        Parse an XML document from a location identified by a URI reference [IETF RFC 2396]. If the URI contains a fragment identifier (see section 4.1 in [IETF RFC 2396]), the behavior is not defined by this specification, future versions of this specification may define the behavior.
        参数：
        uri - The location of the XML document to be read.
        返回：
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned, or null if an error occured. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        抛出：
        DOMException - INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseWithContext

        Node parseWithContext(LSInput input,
                    Node contextArg,
                    short action)
                      throws DOMException,
                             LSException
        Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments. When parsing the input stream, the context node (or its parent, depending on where the result will be inserted) is used for resolving unbound namespace prefixes. The context node's ownerDocument node (or the node itself if the node of type DOCUMENT_NODE) is used to resolve default attributes and entity references.
        As the new data is inserted into the document, at least one mutation event is fired per new immediate child or sibling of the context node.
        If the context node is a Document node and the action is ACTION_REPLACE_CHILDREN, then the document that is passed as the context node will be changed such that its xmlEncoding, documentURI, xmlVersion, inputEncoding, xmlStandalone, and all other such attributes are set to what they would be set to if the input source was parsed using LSParser.parse().
        This method is always synchronous, even if the LSParser is asynchronous (LSParser.async is true).
        If an error occurs while parsing, the caller is notified through the ErrorHandler instance associated with the " error-handler" parameter of the DOMConfiguration.
        When calling parseWithContext, the values of the following configuration parameters will be ignored and their default values will always be used instead: " validate", " validate-if-schema", and " element-content-whitespace". Other parameters will be treated normally, and the parser is expected to call the LSParserFilter just as if a whole document was parsed.
        参数：
        input - The LSInput from which the source document is to be read. The source document must be an XML fragment, i.e. anything except a complete XML document (except in the case where the context node of type DOCUMENT_NODE, and the action is ACTION_REPLACE_CHILDREN), a DOCTYPE (internal subset), entity declaration(s), notation declaration(s), or XML or text declaration(s).
        contextArg - The node that is used as the context for the data that is being parsed. This node must be a Document node, a DocumentFragment node, or a node of a type that is allowed as a child of an Element node, e.g. it cannot be an Attribute node.
        action - This parameter describes which action should be taken between the new set of nodes being inserted and the existing children of the context node. The set of possible actions is defined in ACTION_TYPES above.
        返回：
        Return the node that is the result of the parse operation. If the result is more than one top-level node, the first one is returned.
        抛出：
        DOMException - HIERARCHY_REQUEST_ERR: Raised if the content cannot replace, be inserted before, after, or as a child of the context node (see also Node.insertBefore or Node.replaceChild in [DOM Level 3 Core] ).
        NOT_SUPPORTED_ERR: Raised if the LSParser doesn't support this method, or if the context node is of type Document and the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        NO_MODIFICATION_ALLOWED_ERR: Raised if the context node is a read only node and the content is being appended to its child list, or if the parent node of the context node is read only node and the content is being inserted in its child list.
        INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML fragment. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • abort

        void abort()
        Abort the loading of the document that is currently being loaded by the LSParser. If the LSParser is currently not busy, a call to this method does nothing.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


LSParserFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSParserFilter

  • public interface LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing. As each node is examined, it may be modified or removed, or the entire parse may be terminated early.

    At the time any of the filter methods are called by the parser, the owner Document and DOMImplementation objects exist and are accessible. The document element is never passed to the LSParserFilter methods, i.e. it is not possible to filter out the document element. Document, DocumentType, Notation, Entity, and Attr nodes are never passed to the acceptNode method on the filter. The child nodes of an EntityReference node are passed to the filter if the parameter " entities" is set to false. Note that, as described by the parameter " entities", unexpanded entity reference nodes are never discarded and are always passed to the filter.

    All validity checking while parsing a document occurs on the source document as it appears on the input stream, not on the DOM document as it is built in memory. With filters, the document in memory may be a subset of the document on the stream, and its validity may have been affected by the filtering.

    All default attributes must be present on elements when the elements are passed to the filter methods. All other default content must be passed to the filter methods.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static short FILTER_ACCEPT
      Accept the node.
      static short FILTER_INTERRUPT
      Interrupt the normal processing of the document.
      static short FILTER_REJECT
      Reject the node and its children.
      static short FILTER_SKIP
      Skip this single node.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      short acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      int getWhatToShow()
      Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.
      short startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.

    • 字段详细信息

      • FILTER_ACCEPT

        static final short FILTER_ACCEPT
        Accept the node.
        另请参见：
        Constant Field Values

      • FILTER_REJECT

        static final short FILTER_REJECT
        Reject the node and its children.
        另请参见：
        Constant Field Values

      • FILTER_SKIP

        static final short FILTER_SKIP
        Skip this single node. The children of this node will still be considered.
        另请参见：
        Constant Field Values

      • FILTER_INTERRUPT

        static final short FILTER_INTERRUPT
        Interrupt the normal processing of the document.
        另请参见：
        Constant Field Values

    • 方法详细信息

      • startElement

        short startElement(Element elementArg)
        The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed. The intent is to allow the element, including any children, to be efficiently skipped. Note that only element nodes are passed to the startElement function.
        The element node passed to startElement for filtering will include all of the Element's attributes, but none of the children nodes. The Element may not yet be in place in the document being constructed (it may not have a parent node.)
        A startElement filter function may access or change the attributes for the Element. Changing Namespace declarations will have no effect on namespace resolution by the parser.
        For efficiency, the Element node passed to the filter may not be the same one as is actually placed in the tree if the node is accepted. And the actual node (node object identity) may be reused during the process of reading in and filtering a document.
        参数：
        elementArg - The newly encountered element. At the time this method is called, the element is incomplete - it will have its attributes, but no children.
        返回：
        • FILTER_ACCEPT if the Element should be included in the DOM document being built.
        • FILTER_REJECT if the Element and all of its children should be rejected.
        • FILTER_SKIP if the Element should be skipped. All of its children are inserted in place of the skipped Element node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Element is rejected.
        Returning any other values will result in unspecified behavior.

      • acceptNode

        short acceptNode(Node nodeArg)
        This method will be called by the parser at the completion of the parsing of each node. The node and all of its descendants will exist and be complete. The parent node will also exist, although it may be incomplete, i.e. it may have additional children that have not yet been parsed. Attribute nodes are never passed to this function.
        From within this method, the new node may be freely modified - children may be added or removed, text nodes modified, etc. The state of the rest of the document outside this node is not defined, and the affect of any attempt to navigate to, or to modify any other part of the document is undefined.
        For validating parsers, the checks are made on the original document, before any modification by the filter. No validity checks are made on any document modifications made by the filter.
        If this new node is rejected, the parser might reuse the new node and any of its descendants.
        参数：
        nodeArg - The newly constructed element. At the time this method is called, the element is complete - it has all of its children (and their children, recursively) and attributes, and is attached as a child to its parent.
        返回：
        • FILTER_ACCEPT if this Node should be included in the DOM document being built.
        • FILTER_REJECT if the Node and all of its children should be rejected.
        • FILTER_SKIP if the Node should be skipped and the Node should be replaced by all the children of the Node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Node is accepted and will be the last completely parsed node.

      • getWhatToShow

        int getWhatToShow()
        Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode. If a node is not shown to the filter using this attribute, it is automatically included in the DOM document being built. See NodeFilter for definition of the constants. The constants SHOW_ATTRIBUTE , SHOW_DOCUMENT, SHOW_DOCUMENT_TYPE, SHOW_NOTATION, SHOW_ENTITY, and SHOW_DOCUMENT_FRAGMENT are meaningless here. Those nodes will never be passed to LSParserFilter.acceptNode.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oorai sc s>tts>> TOO"R"SRT< - <


LSProgressEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSProgressEvent

  • All Superinterfaces:
    Event

    public interface LSProgressEvent
extends Event
    This interface represents a progress event object that notifies the application about progress as a document is parsed. It extends the Event interface defined in [DOM Level 3 Events] .

    The units used for the attributes position and totalSize are not specified and can be implementation and input dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LSInput getInput()
      The input source that is being parsed.
      int getPosition()
      The current position in the input source, including all external entities and other resources that have been read.
      int getTotalSize()
      The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.

      • 方法 - 继承于接口 org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • 方法详细信息

      • getInput

        LSInput getInput()
        The input source that is being parsed.

      • getPosition

        int getPosition()
        The current position in the input source, including all external entities and other resources that have been read.

      • getTotalSize

        int getTotalSize()
        The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen. A value of 0 is returned if the total size cannot be determined or estimated.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

hoeuattttt hht asiiandamtneneaau


LSResourceResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSResourceResolver

  • public interface LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.

    Applications needing to implement custom handling for external resources can implement this interface and register their implementation by setting the "resource-resolver" parameter of DOMConfiguration objects attached to LSParser and LSSerializer. It can also be register on DOMConfiguration objects attached to Document if the "LS" feature is supported.

    The LSParser will then allow the application to intercept any external entities, including the external DTD subset and external parameter entities, before including them. The top-level document entity is never passed to the resolveResource method.

    Many DOM applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialized input sources, or for applications that use URNs.

    Note: LSResourceResolver is based on the SAX2 [SAX] EntityResolver interface.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      LSInput resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.

    • 方法详细信息

      • resolveResource

        LSInput resolveResource(String type,
                      String namespaceURI,
                      String publicId,
                      String systemId,
                      String baseURI)
        Allow the application to resolve external resources.
        The LSParser will call this method before opening any external resource, including the external DTD subset, external entities referenced within the DTD, and external entities referenced within the document element (however, the top-level document entity is not passed to this method). The application may then request that the LSParser resolve the external resource itself, that it use an alternative URI, or that it use an entirely different input source.
        Application writers can use this method to redirect external system identifiers to secure and/or local URI, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box).
        参数：
        type - The type of the resource being resolved. For XML [XML 1.0] resources (i.e. entities), applications must use the value "http://www.w3.org/TR/REC-xml". For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". Other types of resources are outside the scope of this specification and therefore should recommend an absolute URI in order to use this method.
        namespaceURI - The namespace of the resource being resolved, e.g. the target namespace of the XML Schema [XML Schema Part 1] when resolving XML Schema resources.
        publicId - The public identifier of the external entity being referenced, or null if no public identifier was supplied or if the resource is not an entity.
        systemId - The system identifier, a URI reference [IETF RFC 2396], of the external resource being referenced, or null if no system identifier was supplied.
        baseURI - The absolute base URI of the resource being parsed, or null if there is no base URI.
        返回：
        A LSInput object describing the new input source, or null to request that the parser open a regular URI connection to the resource.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d /icdCodCETTCSER/ eim


LSSerializer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSSerializer

  • public interface LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML. The XML data is written to a string or an output stream. Any changes or fixups made during the serialization affect only the serialized data. The Document object and its children are never altered by the serialization operation.

    During serialization of XML data, namespace fixup is done as defined in [DOM Level 3 Core] , Appendix B. [DOM Level 2 Core] allows empty strings as a real namespace URI. If the namespaceURI of a Node is empty string, the serialization will treat them as null, ignoring the prefix if any.

    LSSerializer accepts any node type for serialization. For nodes of type Document or Entity, well-formed XML will be created when possible (well-formedness is guaranteed if the document or entity comes from a parse operation and is unchanged since it was created). The serialized output for these node types is either as a XML document or an External XML Entity, respectively, and is acceptable input for an XML parser. For all other types of nodes the serialized form is implementation dependent.

    Within a Document, DocumentFragment, or Entity being serialized, Nodes are processed as follows

    • Document nodes are written, including the XML declaration (unless the parameter "xml-declaration" is set to false) and a DTD subset, if one exists in the DOM. Writing a Document node serializes the entire document.
    • Entity nodes, when written directly by LSSerializer.write, outputs the entity expansion but no namespace fixup is done. The resulting output will be valid as an external entity.
    • If the parameter " entities" is set to true, EntityReference nodes are serialized as an entity reference of the form " &entityName;" in the output. Child nodes (the expansion) of the entity reference are ignored. If the parameter " entities" is set to false, only the children of the entity reference are serialized. EntityReference nodes with no children (no corresponding Entity node or the corresponding Entity nodes have no children) are always serialized.
    • CDATAsections containing content characters that cannot be represented in the specified output encoding are handled according to the " split-cdata-sections" parameter. If the parameter is set to true, CDATAsections are split, and the unrepresentable characters are serialized as numeric character references in ordinary content. The exact position and number of splits is not specified. If the parameter is set to false, unrepresentable characters in a CDATAsection are reported as "wf-invalid-character" errors if the parameter " well-formed" is set to true. The error is not recoverable - there is no mechanism for supplying alternative characters and continuing with the serialization.
    • DocumentFragment nodes are serialized by serializing the children of the document fragment in the order they appear in the document fragment.
    • All other node types (Element, Text, etc.) are serialized to their corresponding XML source form.

    Note: The serialization of a Node does not always generate a well-formed XML document, i.e. a LSParser might throw fatal errors when parsing the resulting serialization.

    Within the character data of a document (outside of markup), any characters that cannot be represented directly are replaced with character references. Occurrences of '<' and '&' are replaced by the predefined entities &lt; and &amp;. The other predefined entities (&gt;, &apos;, and &quot;) might not be used, except where needed (e.g. using &gt; in cases such as ']]>'). Any characters that cannot be represented directly in the output character encoding are serialized as numeric character references (and since character encoding standards commonly use hexadecimal representations of characters, using the hexadecimal representation when serializing character references is encouraged).

    To allow attribute values to contain both single and double quotes, the apostrophe or single-quote character (') may be represented as "&apos;", and the double-quote character (") as "&quot;". New line characters and other characters that cannot be represented directly in attribute values in the output character encoding are serialized as a numeric character reference.

    Within markup, but outside of attributes, any occurrence of a character that cannot be represented in the output character encoding is reported as a DOMError fatal error. An example would be serializing the element <LaCa馻da/> with encoding="us-ascii". This will result with a generation of a DOMError "wf-invalid-character-in-node-name" (as proposed in " well-formed").

    When requested by setting the parameter " normalize-characters" on LSSerializer to true, character normalization is performed according to the definition of fully normalized characters included in appendix E of [XML 1.1] on all data to be serialized, both markup and character data. The character normalization process affects only the data as it is being written; it does not alter the DOM's view of the document after serialization has completed.

    Implementations are required to support the encodings "UTF-8", "UTF-16", "UTF-16BE", and "UTF-16LE" to guarantee that data is serializable in all encodings that are required to be supported by all XML parsers. When the encoding is UTF-8, whether or not a byte order mark is serialized, or if the output is big-endian or little-endian, is implementation dependent. When the encoding is UTF-16, whether or not the output is big-endian or little-endian is implementation dependent, but a Byte Order Mark must be generated for non-character outputs, such as LSOutput.byteStream or LSOutput.systemId. If the Byte Order Mark is not generated, a "byte-order-mark-needed" warning is reported. When the encoding is UTF-16LE or UTF-16BE, the output is big-endian (UTF-16BE) or little-endian (UTF-16LE) and the Byte Order Mark is not be generated. In all cases, the encoding declaration, if generated, will correspond to the encoding used during the serialization (e.g. encoding="UTF-16" will appear if UTF-16 was requested).

    Namespaces are fixed up during serialization, the serialization process will verify that namespace declarations, namespace prefixes and the namespace URI associated with elements and attributes are consistent. If inconsistencies are found, the serialized form of the document will be altered to remove them. The method used for doing the namespace fixup while serializing a document is the algorithm defined in Appendix B.1, "Namespace normalization", of [DOM Level 3 Core] .

    While serializing a document, the parameter "discard-default-content" controls whether or not non-specified data is serialized.

    While serializing, errors and warnings are reported to the application through the error handler (LSSerializer.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors and warnings that can occur while serializing a DOM node, but some common error and warning cases are defined. The types ( DOMError.type) of errors and warnings defined by this specification are:

    "no-output-specified" [fatal]
    Raised when writing to a LSOutput if no output is specified in the LSOutput.
    "unbound-prefix-in-entity-reference" [fatal]
    Raised if the configuration parameter " namespaces" is set to true and an entity whose replacement text contains unbound namespace prefixes is referenced in a location where there are no bindings for the namespace prefixes.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...) and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
      LSSerializerFilter getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      String getNewLine()
      The end-of-line sequence of characters to be used in the XML being written out.
      void setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      void setNewLine(String newLine)
      The end-of-line sequence of characters to be used in the XML being written out.
      boolean write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.

    • 方法详细信息

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
        In addition to the parameters recognized by the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSSerializer adds, or modifies, the following parameters:
        "canonical-form"
        true
        [optional] Writes the document according to the rules specified in [Canonical XML]. In addition to the behavior described in " canonical-form" [DOM Level 3 Core] , setting this parameter to true will set the parameters "format-pretty-print", "discard-default-content", and "xml-declaration ", to false. Setting one of those parameters to true will set this parameter to false. Serializing an XML 1.1 document when "canonical-form" is true will generate a fatal error.
        false
        [required] (default) Do not canonicalize the output.
        "discard-default-content"
        true
        [required] (default) Use the Attr.specified attribute to decide what attributes should be discarded. Note that some implementations might use whatever information available to the implementation (i.e. XML schema, DTD, the Attr.specified attribute, and so on) to determine what attributes and content to discard if this parameter is set to true.
        false
        [required]Keep all attributes and all content.
        "format-pretty-print"
        true
        [optional] Formatting the output by adding whitespace to produce a pretty-printed, indented, human-readable form. The exact form of the transformations is not specified by this specification. Pretty-printing changes the content of the document and may affect the validity of the document, validating implementations should preserve validity.
        false
        [required] (default) Don't pretty-print the result.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a character is encountered for which the normalization properties cannot be determined, then raise a "unknown-character-denormalization" warning (instead of raising an error, if this parameter is not set) and ignore any possible denormalizations caused by these characters.
        false
        [optional] Report a fatal error if a character is encountered for which the processor cannot determine the normalization properties.
        "normalize-characters"
        This parameter is equivalent to the one defined by DOMConfiguration in [DOM Level 3 Core] . Unlike in the Core, the default value for this parameter is true. While DOM implementations are not required to support fully normalizing the characters in the document according to appendix E of [XML 1.1], this parameter must be activated by default if supported.
        "xml-declaration"
        true
        [required] (default) If a Document, Element, or Entity node is serialized, the XML declaration, or text declaration, should be included. The version (Document.xmlVersion if the document is a Level 3 document and the version is non-null, otherwise use the value "1.0"), and the output encoding (see LSSerializer.write for details on how to find the output encoding) are specified in the serialized XML declaration.
        false
        [required] Do not serialize the XML and text declarations. Report a "xml-declaration-needed" warning if this will cause problems (i.e. the serialized data is of an XML version other than [XML 1.0], or an encoding would be needed to be able to re-parse the serialized data).

      • getNewLine

        String getNewLine()
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • setNewLine

        void setNewLine(String newLine)
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • getFilter

        LSSerializerFilter getFilter()
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • setFilter

        void setFilter(LSSerializerFilter filter)
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • write

        boolean write(Node nodeArg,
            LSOutput destination)
              throws LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to the supplied LSOutput.
        When writing to a LSOutput, the encoding is found by looking at the encoding information that is reachable through the LSOutput and the item to be written (or its owner document) in this order:
        1. LSOutput.encoding,
        2. Document.inputEncoding,
        3. Document.xmlEncoding.

        If no encoding is reachable through the above properties, a default encoding of "UTF-8" will be used. If the specified encoding is not supported an "unsupported-encoding" fatal error is raised.
        If no output is specified in the LSOutput, a "no-output-specified" fatal error is raised.
        The implementation is responsible of associating the appropriate media type with the serialized data.
        When writing to a HTTP URI, a HTTP PUT is performed. When writing to other types of URIs, the mechanism for writing the data to the URI is implementation dependent.
        参数：
        nodeArg - The node to serialize.
        destination - The destination for the serialized DOM.
        返回：
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        抛出：
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToURI

        boolean writeToURI(Node nodeArg,
                 String uri)
                   throws LSException
        A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
        参数：
        nodeArg - The node to serialize.
        uri - The URI to write to.
        返回：
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        抛出：
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToString

        String writeToString(Node nodeArg)
                     throws DOMException,
                            LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to a DOMString that is returned to the caller. The encoding used is the encoding of the DOMString type, i.e. UTF-16. Note that no Byte Order Mark is generated in a DOMString object.
        参数：
        nodeArg - The node to serialize.
        返回：
        Returns the serialized data.
        抛出：
        DOMException - DOMSTRING_SIZE_ERR: Raised if the resulting string is too long to fit in a DOMString.
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


LSSerializerFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.w3c.dom.ls

Interface LSSerializerFilter

  • All Superinterfaces:
    org.w3c.dom.traversal.NodeFilter

    public interface LSSerializerFilter
extends org.w3c.dom.traversal.NodeFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not. The LSSerializerFilter interface is based on the NodeFilter interface defined in [DOM Level 2 Traversal and Range] .

    Document, DocumentType, DocumentFragment, Notation, Entity , and children of Attr nodes are not passed to the filter. The child nodes of an EntityReference node are only passed to the filter if the EntityReference node is skipped by the method LSParserFilter.acceptNode().

    When serializing an Element, the element is passed to the filter before any of its attributes are passed to the filter. Namespace declaration attributes, and default attributes (except in the case when " discard-default-content" is set to false), are never passed to the filter.

    The result of any attempt to modify a node passed to a LSSerializerFilter is implementation dependent.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    For efficiency, a node passed to the filter may not be the same as the one that is actually in the tree. And the actual node (node object identity) may be reused during the process of filtering and serializing a document.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • 字段摘要

      • 字段 - 继承于接口 org.w3c.dom.traversal.NodeFilter

        FILTER_ACCEPT, FILTER_REJECT, FILTER_SKIP, SHOW_ALL, SHOW_ATTRIBUTE, SHOW_CDATA_SECTION, SHOW_COMMENT, SHOW_DOCUMENT, SHOW_DOCUMENT_FRAGMENT, SHOW_DOCUMENT_TYPE, SHOW_ELEMENT, SHOW_ENTITY, SHOW_ENTITY_REFERENCE, SHOW_NOTATION, SHOW_PROCESSING_INSTRUCTION, SHOW_TEXT

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getWhatToShow()
      Tells the LSSerializer what types of nodes to show to the filter.

      • 方法 - 继承于接口 org.w3c.dom.traversal.NodeFilter

        acceptNode

    • 方法详细信息

      • getWhatToShow

        int getWhatToShow()
        Tells the LSSerializer what types of nodes to show to the filter. If a node is not shown to the filter using this attribute, it is automatically serialized. See NodeFilter for definition of the constants. The constants SHOW_DOCUMENT , SHOW_DOCUMENT_TYPE, SHOW_DOCUMENT_FRAGMENT , SHOW_NOTATION, and SHOW_ENTITY are meaningless here, such nodes will never be passed to a LSSerializerFilter.
        Unlike [DOM Level 2 Traversal and Range] , the SHOW_ATTRIBUTE constant indicates that the Attr nodes are shown and passed to the filter.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

(gel e se gtt ggdnoo Ie .tneadtt-e


org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException
f


org.w3c.dom.ls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.w3c.dom.ls

  • 接口摘要
    接口 描述
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception 描述
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r<o>ma==v>a


org.w3c.dom.ls Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.w3c.dom.ls

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException

Interface Hierarchy

  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/car_m"pF靠tammna""/a


Uses of Package org.w3c.dom.ls

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.w3c.dom.ls

  • Packages that use org.w3c.dom.ls
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom.ls
  • Classes in org.w3c.dom.ls used by javax.xml.validation
    类与描述
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
  • Classes in org.w3c.dom.ls used by org.w3c.dom.ls
    类与描述
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
    LSInput
    This interface represents an input source for data.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lloden>neea raII:"/.r.ib


Uses of Class org.w3c.dom.ls.LSException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.w3c.dom.ls.LSException

  • Packages that use LSException
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw LSException
      修饰符与类型 方法与描述
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Interface org.w3c.dom.ls.DOMImplementationLS

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.DOMImplementationLS

No usage of org.w3c.dom.ls.DOMImplementationLS
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>s sht o 胊


Uses of Interface org.w3c.dom.ls.LSInput

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSInput

  • Packages that use LSInput
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSInput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSInput
      修饰符与类型 方法与描述
      LSInput DOMImplementationLS.createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSInput LSProgressEvent.getInput()
      The input source that is being parsed.
      LSInput LSLoadEvent.getInput()
      The input source that was parsed.
      LSInput LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.
      Methods in org.w3c.dom.ls with parameters of type LSInput
      修饰符与类型 方法与描述
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e/q.s


Uses of Interface org.w3c.dom.ls.LSLoadEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSLoadEvent

No usage of org.w3c.dom.ls.LSLoadEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

r odg/w..///..ggsLsn>


Uses of Interface org.w3c.dom.ls.LSOutput

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSOutput

  • Packages that use LSOutput
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSOutput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSOutput
      修饰符与类型 方法与描述
      LSOutput DOMImplementationLS.createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      Methods in org.w3c.dom.ls with parameters of type LSOutput
      修饰符与类型 方法与描述
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fc">p.ncsf"r.>naosa


Uses of Interface org.w3c.dom.ls.LSParser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSParser

  • Packages that use LSParser
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSParser in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParser
      修饰符与类型 方法与描述
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>lll/><


Uses of Interface org.w3c.dom.ls.LSParserFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSParserFilter

  • Packages that use LSParserFilter
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSParserFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParserFilter
      修饰符与类型 方法与描述
      LSParserFilter LSParser.getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Methods in org.w3c.dom.ls with parameters of type LSParserFilter
      修饰符与类型 方法与描述
      void LSParser.setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a�yl了胋�<�>�/.r衛他鹐"


Uses of Interface org.w3c.dom.ls.LSProgressEvent

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSProgressEvent

No usage of org.w3c.dom.ls.LSProgressEvent
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a="ccsooot">>


Uses of Interface org.w3c.dom.ls.LSResourceResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSResourceResolver

  • Packages that use LSResourceResolver
    软件包 描述
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of LSResourceResolver in javax.xml.validation

      Methods in javax.xml.validation that return LSResourceResolver
      修饰符与类型 方法与描述
      abstract LSResourceResolver ValidatorHandler.getResourceResolver()
      Gets the current LSResourceResolver set to this ValidatorHandler.
      abstract LSResourceResolver Validator.getResourceResolver()
      Gets the current LSResourceResolver set to this Validator.
      abstract LSResourceResolver SchemaFactory.getResourceResolver()
      Gets the current LSResourceResolver set to this SchemaFactory.
      Methods in javax.xml.validation with parameters of type LSResourceResolver
      修饰符与类型 方法与描述
      abstract void ValidatorHandler.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      abstract void Validator.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      abstract void SchemaFactory.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution when parsing schemas.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

9eutstl=i9Liven.<=i


Uses of Interface org.w3c.dom.ls.LSSerializer

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSSerializer

  • Packages that use LSSerializer
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSSerializer in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializer
      修饰符与类型 方法与描述
      LSSerializer DOMImplementationLS.createLSSerializer()
      Create a new LSSerializer object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=a"r"coalsssh nn.>.ocsmw"


Uses of Interface org.w3c.dom.ls.LSSerializerFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.w3c.dom.ls.LSSerializerFilter

  • Packages that use LSSerializerFilter
    软件包 描述
    org.w3c.dom.ls

    • Uses of LSSerializerFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializerFilter
      修饰符与类型 方法与描述
      LSSerializerFilter LSSerializer.getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      Methods in org.w3c.dom.ls with parameters of type LSSerializerFilter
      修饰符与类型 方法与描述
      void LSSerializer.setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

lwTsr)i sal.evvvi< kld-


AttributeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface AttributeList

  • All Known Implementing Classes:
    AttributeListImpl
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.

    public interface AttributeList
    Interface for an element's attribute specifications.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the original SAX1 interface for reporting an element's attributes. Unlike the new Attributes interface, it does not support Namespace-related information.

    When an attribute list is supplied as part of a startElement event, the list will return valid results only during the scope of the event; once the event handler returns control to the parser, the attribute list is invalid. To save a persistent copy of the attribute list, use the SAX1 AttributeListImpl helper class.

    An attribute list includes only attributes that have been specified or defaulted: #IMPLIED attributes will not be included.

    There are two ways for the SAX application to obtain information from the AttributeList. First, it can iterate through the entire list:

     public void startElement (String name, AttributeList atts) {
   for (int i = 0; i < atts.getLength(); i++) {
     String name = atts.getName(i);
     String type = atts.getType(i);
     String value = atts.getValue(i);
     [...]
   }
 }

    (Note that the result of getLength() will be zero if there are no attributes.)

    As an alternative, the application can request the value or type of specific attributes:

     public void startElement (String name, AttributeList atts) {
   String identifier = atts.getValue("id");
   String label = atts.getValue("label");
   [...]
 }
    从以下版本开始：
    SAX 1.0
    另请参见：
    startElement, AttributeListImpl

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getLength()
      Deprecated.
      Return the number of attributes in this list.
      String getName(int i)
      Deprecated.
      Return the name of an attribute in this list (by position).
      String getType(int i)
      Deprecated.
      Return the type of an attribute in the list (by position).
      String getType(String name)
      Deprecated.
      Return the type of an attribute in the list (by name).
      String getValue(int i)
      Deprecated.
      Return the value of an attribute in the list (by position).
      String getValue(String name)
      Deprecated.
      Return the value of an attribute in the list (by name).

    • 方法详细信息

      • getLength

        int getLength()
        Deprecated.
        Return the number of attributes in this list.

        The SAX parser may provide attributes in any arbitrary order, regardless of the order in which they were declared or specified. The number of attributes may be zero.

        返回：
        The number of attributes in the list.

      • getName

        String getName(int i)
        Deprecated.
        Return the name of an attribute in this list (by position).

        The names must be unique: the SAX parser shall not include the same attribute twice. Attributes without values (those declared #IMPLIED without a value specified in the start tag) will be omitted from the list.

        If the attribute name has a namespace prefix, the prefix will still be attached.

        参数：
        i - The index of the attribute in the list (starting at 0).
        返回：
        The name of the indexed attribute, or null if the index is out of range.
        另请参见：
        getLength()

      • getType

        String getType(int i)
        Deprecated.
        Return the type of an attribute in the list (by position).

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommentation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        参数：
        i - The index of the attribute in the list (starting at 0).
        返回：
        The attribute type as a string, or null if the index is out of range.
        另请参见：
        getLength(), getType(java.lang.String)

      • getValue

        String getValue(int i)
        Deprecated.
        Return the value of an attribute in the list (by position).

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string separated by whitespace.

        参数：
        i - The index of the attribute in the list (starting at 0).
        返回：
        The attribute value as a string, or null if the index is out of range.
        另请参见：
        getLength(), getValue(java.lang.String)

      • getType

        String getType(String name)
        Deprecated.
        Return the type of an attribute in the list (by name).

        The return value is the same as the return value for getType(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        参数：
        name - The name of the attribute.
        返回：
        The attribute type as a string, or null if no such attribute exists.
        另请参见：
        getType(int)

      • getValue

        String getValue(String name)
        Deprecated.
        Return the value of an attribute in the list (by name).

        The return value is the same as the return value for getValue(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        参数：
        name - the name of the attribute to return
        返回：
        The attribute value as a string, or null if no such attribute exists.
        另请参见：
        getValue(int)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

uleNc.cs agaoe


Attributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface Attributes

  • All Known Subinterfaces:
    Attributes2
    All Known Implementing Classes:
    Attributes2Impl, AttributesImpl

    public interface Attributes
    Interface for a list of XML attributes.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This interface allows access to a list of attributes in three different ways:

    1. by attribute index;
    2. by Namespace-qualified name; or
    3. by qualified (prefixed) name.

    The list will not contain attributes that were declared #IMPLIED but not specified in the start tag. It will also not contain attributes used as Namespace declarations (xmlns*) unless the http://xml.org/sax/features/namespace-prefixes feature is set to true (it is false by default). Because SAX2 conforms to the original "Namespaces in XML" recommendation, it normally does not give namespace declaration attributes a namespace URI.

    Some SAX2 parsers may support using an optional feature flag (http://xml.org/sax/features/xmlns-uris) to request that those attributes be given URIs, conforming to a later backwards-incompatible revision of that recommendation. (The attribute's "local name" will be the prefix, or "xmlns" when defining a default element namespace.) For portability, handler code should always resolve that conflict, rather than requiring parsers that can change the setting of that feature flag.

    If the namespace-prefixes feature (see above) is false, access by qualified name may not be available; if the http://xml.org/sax/features/namespaces feature is false, access by Namespace-qualified names may not be available.

    This interface replaces the now-deprecated SAX1 AttributeList interface, which does not contain Namespace support. In addition to Namespace support, it adds the getIndex methods (below).

    The order of attributes in the list is unspecified, and will vary from implementation to implementation.

    从以下版本开始：
    SAX 2.0
    另请参见：
    AttributesImpl, DeclHandler.attributeDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getIndex(String qName)
      Look up the index of an attribute by XML qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up the index of an attribute by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Look up an attribute's local name by index.
      String getQName(int index)
      Look up an attribute's XML qualified (prefixed) name by index.
      String getType(int index)
      Look up an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by XML qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace name.
      String getURI(int index)
      Look up an attribute's Namespace URI by index.
      String getValue(int index)
      Look up an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by XML qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace name.

    • 方法详细信息

      • getLength

        int getLength()
        Return the number of attributes in the list.

        Once you know the number of attributes, you can iterate through the list.

        返回：
        The number of attributes in the list.
        另请参见：
        getURI(int), getLocalName(int), getQName(int), getType(int), getValue(int)

      • getURI

        String getURI(int index)
        Look up an attribute's Namespace URI by index.
        参数：
        index - The attribute index (zero-based).
        返回：
        The Namespace URI, or the empty string if none is available, or null if the index is out of range.
        另请参见：
        getLength()

      • getLocalName

        String getLocalName(int index)
        Look up an attribute's local name by index.
        参数：
        index - The attribute index (zero-based).
        返回：
        The local name, or the empty string if Namespace processing is not being performed, or null if the index is out of range.
        另请参见：
        getLength()

      • getQName

        String getQName(int index)
        Look up an attribute's XML qualified (prefixed) name by index.
        参数：
        index - The attribute index (zero-based).
        返回：
        The XML qualified name, or the empty string if none is available, or null if the index is out of range.
        另请参见：
        getLength()

      • getType

        String getType(int index)
        Look up an attribute's type by index.

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommendation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        参数：
        index - The attribute index (zero-based).
        返回：
        The attribute's type as a string, or null if the index is out of range.
        另请参见：
        getLength()

      • getValue

        String getValue(int index)
        Look up an attribute's value by index.

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string with each token separated by a single space.

        参数：
        index - The attribute index (zero-based).
        返回：
        The attribute's value as a string, or null if the index is out of range.
        另请参见：
        getLength()

      • getIndex

        int getIndex(String uri,
           String localName)
        Look up the index of an attribute by Namespace name.
        参数：
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        返回：
        The index of the attribute, or -1 if it does not appear in the list.

      • getIndex

        int getIndex(String qName)
        Look up the index of an attribute by XML qualified (prefixed) name.
        参数：
        qName - The qualified (prefixed) name.
        返回：
        The index of the attribute, or -1 if it does not appear in the list.

      • getType

        String getType(String uri,
             String localName)
        Look up an attribute's type by Namespace name.

        See getType(int) for a description of the possible types.

        参数：
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        返回：
        The attribute type as a string, or null if the attribute is not in the list or if Namespace processing is not being performed.

      • getType

        String getType(String qName)
        Look up an attribute's type by XML qualified (prefixed) name.

        See getType(int) for a description of the possible types.

        参数：
        qName - The XML qualified name.
        返回：
        The attribute type as a string, or null if the attribute is not in the list or if qualified names are not available.

      • getValue

        String getValue(String uri,
              String localName)
        Look up an attribute's value by Namespace name.

        See getValue(int) for a description of the possible values.

        参数：
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        返回：
        The attribute value as a string, or null if the attribute is not in the list.

      • getValue

        String getValue(String qName)
        Look up an attribute's value by XML qualified (prefixed) name.

        See getValue(int) for a description of the possible values.

        参数：
        qName - The XML qualified name.
        返回：
        The attribute value as a string, or null if the attribute is not in the list or if qualified names are not available.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

- o otitta>ed �=ADeA==Oa� >mv


ContentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface ContentHandler

  • All Known Subinterfaces:
    TemplatesHandler, TransformerHandler, UnmarshallerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, ValidatorHandler, XMLFilterImpl, XMLReaderAdapter

    public interface ContentHandler
    Receive notification of the logical content of a document.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the main interface that most SAX applications implement: if the application needs to be informed of basic parsing events, it implements this interface and registers an instance with the SAX parser using the setContentHandler method. The parser uses the instance to report basic document-related events like the start and end of elements and character data.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    This interface is similar to the now-deprecated SAX 1.0 DocumentHandler interface, but it adds support for Namespaces and for reporting skipped entities (in non-validating XML processors).

    Implementors should note that there is also a ContentHandler class in the java.net package; that means that it's probably a bad idea to do

    import java.net.*;
 import org.xml.sax.*;

    In fact, "import ...*" is usually a sign of sloppy programming anyway, so the user should consider this a feature rather than a bug.

    从以下版本开始：
    SAX 2.0
    另请参见：
    XMLReader, DTDHandler, ErrorHandler

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Receive notification of character data.
      void endDocument()
      Receive notification of the end of a document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of a document.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.

    • 方法详细信息

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the ContentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation SAX event callbacks after startDocument returns and before endDocument is called. The application should not attempt to use it at any other time.

        参数：
        locator - an object that can return the location of any SAX document event
        另请参见：
        Locator

      • startDocument

        void startDocument()
                   throws SAXException
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other event callbacks (except for setDocumentLocator).

        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
        另请参见：
        endDocument()

      • endDocument

        void endDocument()
                 throws SAXException
        Receive notification of the end of a document.

        There is an apparent contradiction between the documentation for this method and the documentation for ErrorHandler.fatalError(org.xml.sax.SAXParseException). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
        另请参见：
        startDocument()

      • startPrefixMapping

        void startPrefixMapping(String prefix,
                      String uri)
                        throws SAXException
        Begin the scope of a prefix-URI Namespace mapping.

        The information from this event is not necessary for normal Namespace processing: the SAX XML reader will automatically replace prefixes for element and attribute names when the http://xml.org/sax/features/namespaces feature is true (the default).

        There are cases, however, when applications need to use prefixes in character data or in attribute values, where they cannot safely be expanded automatically; the start/endPrefixMapping event supplies the information to the application to expand prefixes in those contexts itself, if necessary.

        Note that start/endPrefixMapping events are not guaranteed to be properly nested relative to each other: all startPrefixMapping events will occur immediately before the corresponding startElement event, and all endPrefixMapping events will occur immediately after the corresponding endElement event, but their order is not otherwise guaranteed.

        There should never be start/endPrefixMapping events for the "xml" prefix, since it is predeclared and immutable.

        参数：
        prefix - the Namespace prefix being declared. An empty string is used for the default element namespace, which has no prefix.
        uri - the Namespace URI the prefix is mapped to
        抛出：
        SAXException - the client may throw an exception during processing
        另请参见：
        endPrefixMapping(java.lang.String), startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        void endPrefixMapping(String prefix)
                      throws SAXException
        End the scope of a prefix-URI mapping.

        See startPrefixMapping for details. These events will always occur immediately after the corresponding endElement event, but the order of endPrefixMapping events is not otherwise guaranteed.

        参数：
        prefix - the prefix that was being mapped. This is the empty string when a default mapping scope ends.
        抛出：
        SAXException - the client may throw an exception during processing
        另请参见：
        startPrefixMapping(java.lang.String, java.lang.String), endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        void startElement(String uri,
                String localName,
                String qName,
                Attributes atts)
                  throws SAXException
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement event for every startElement event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement event.

        This event allows up to three name components for each element:

        1. the Namespace URI;
        2. the local name; and
        3. the qualified (prefixed) name.

        Any or all of these may be provided, depending on the values of the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes properties:

        • the Namespace URI and local name are required when the namespaces property is true (the default), and are optional when the namespaces property is false (if one is specified, both must be);
        • the qualified name is required when the namespace-prefixes property is true, and is optional when the namespace-prefixes property is false (the default).

        Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted. The attribute list will contain attributes used for Namespace declarations (xmlns* attributes) only if the http://xml.org/sax/features/namespace-prefixes property is true (it is false by default, and support for a true value is optional).

        Like characters(), attribute values may have characters that need more than one char value.

        参数：
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified name (with prefix), or the empty string if qualified names are not available
        atts - the attributes attached to the element. If there are no attributes, it shall be an empty Attributes object. The value of this object after startElement returns is undefined
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
        另请参见：
        endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        void endElement(String uri,
              String localName,
              String qName)
                throws SAXException
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement event for every endElement event (even when the element is empty).

        For information on the names, see startElement.

        参数：
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified XML name (with prefix), or the empty string if qualified names are not available
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception

      • characters

        void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Individual characters may consist of more than one Java char value. There are two important cases where this happens, because characters can't be represented in just sixteen bits. In one case, characters are represented in a Surrogate Pair, using two special Unicode values. Such characters are in the so-called "Astral Planes", with a code point above U+FFFF. A second case involves composite characters, such as a base character combining with one or more accent characters.

        Your code should not assume that algorithms using char-at-a-time idioms will be working in character units; in some cases they will split characters. This is relevant wherever XML permits arbitrary characters, such as attribute values, processing instruction data, and comments as well as in data reported from this method. It's also generally relevant whenever Java code manipulates internationalized text; the issue isn't unique to XML.

        Note that some parsers will report whitespace in element content using the ignorableWhitespace method rather than this one (validating parsers must do so).

        参数：
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
        另请参见：
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of whitespace in element content (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        参数：
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
        另请参见：
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                         String data)
                           throws SAXException
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser must never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        Like characters(), processing instruction data may have characters that need more than one char value.

        参数：
        target - the processing instruction target
        data - the processing instruction data, or null if none was supplied. The data does not include any whitespace separating it from the target
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception

      • skippedEntity

        void skippedEntity(String name)
                   throws SAXException
        Receive notification of a skipped entity. This is not called for entity references within markup constructs such as element start tags or markup declarations. (The XML recommendation requires reporting skipped external entities. SAX also reports internal entity expansion/non-expansion, except within markup constructs.)

        The Parser will invoke this method each time the entity is skipped. Non-validating processors may skip entities if they have not seen the declarations (because, for example, the entity was declared in an external DTD subset). All processors may skip external entities, depending on the values of the http://xml.org/sax/features/external-general-entities and the http://xml.org/sax/features/external-parameter-entities properties.

        参数：
        name - the name of the skipped entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be the string "[dtd]"
        抛出：
        SAXException - any SAX exception, possibly wrapping another exception
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


DocumentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface DocumentHandler

  • All Known Implementing Classes:
    HandlerBase, ParserAdapter
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.

    public interface DocumentHandler
    Receive notification of general document events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event-handling interface for SAX1; in SAX2, it has been replaced by ContentHandler, which provides Namespace support and reporting of skipped entities. This interface is included in SAX2 only to support legacy SAX1 applications.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    Application writers who do not want to implement the entire interface can derive a class from HandlerBase, which implements the default functionality; parser writers can instantiate HandlerBase to obtain a default handler. The application can find the location of any document event using the Locator interface supplied by the Parser through the setDocumentLocator method.

    从以下版本开始：
    SAX 1.0
    另请参见：
    Parser.setDocumentHandler(org.xml.sax.DocumentHandler), Locator, HandlerBase

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.

    • 方法详细信息

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Deprecated.
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the DocumentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation of the events in this interface. The application should not attempt to use it at any other time.

        参数：
        locator - An object that can return the location of any SAX document event.
        另请参见：
        Locator

      • startDocument

        void startDocument()
                   throws SAXException
        Deprecated.
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other methods in this interface or in DTDHandler (except for setDocumentLocator).

        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.

      • endDocument

        void endDocument()
                 throws SAXException
        Deprecated.
        Receive notification of the end of a document.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.

      • startElement

        void startElement(String name,
                AttributeList atts)
                  throws SAXException
        Deprecated.
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement() event for every startElement() event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement() event.

        If the element name has a namespace prefix, the prefix will still be attached. Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted.

        参数：
        name - The element type name.
        atts - The attributes attached to the element, if any.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        endElement(java.lang.String), AttributeList

      • endElement

        void endElement(String name)
                throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement() event for every endElement() event (even when the element is empty).

        If the element name has a namespace prefix, the prefix will still be attached to the name.

        参数：
        name - The element type name
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.

      • characters

        void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Deprecated.
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Note that some parsers will report whitespace using the ignorableWhitespace() method rather than this one (validating parsers must do so).

        参数：
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of ignorable whitespace (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        参数：
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                         String data)
                           throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser should never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        参数：
        target - The processing instruction target.
        data - The processing instruction data, or null if none was supplied.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h eae is irbbirredoo te rrte te,i


DTDHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface DTDHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface DTDHandler
    Receive notification of basic DTD-related events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs information about notations and unparsed entities, then the application implements this interface and registers an instance with the SAX parser using the parser's setDTDHandler method. The parser uses the instance to report notation and unparsed entity declarations to the application.

    Note that this interface includes only those DTD events that the XML recommendation requires processors to report: notation and unparsed entity declarations.

    The SAX parser may report these events in any order, regardless of the order in which the notations and unparsed entities were declared; however, all DTD events must be reported after the document handler's startDocument event, and before the first startElement event. (If the LexicalHandler is used, these events must also be reported before the endDTD event.)

    It is up to the application to store the information for future use (perhaps in a hash table or object tree). If the application encounters attributes of type "NOTATION", "ENTITY", or "ENTITIES", it can use the information that it obtained through this interface to find the entity and/or notation corresponding with the attribute value.

    从以下版本开始：
    SAX 1.0
    另请参见：
    XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.

    • 方法详细信息

      • notationDecl

        void notationDecl(String name,
                String publicId,
                String systemId)
                  throws SAXException
        Receive notification of a notation declaration event.

        It is up to the application to record the notation for later reference, if necessary; notations may appear as attribute values and in unparsed entity declarations, and are sometime used with processing instruction target names.

        At least one of publicId and systemId must be non-null. If a system identifier is present, and it is a URL, the SAX parser must resolve it fully before passing it to the application through this event.

        There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

        参数：
        name - The notation name.
        publicId - The notation's public identifier, or null if none was given.
        systemId - The notation's system identifier, or null if none was given.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        void unparsedEntityDecl(String name,
                      String publicId,
                      String systemId,
                      String notationName)
                        throws SAXException
        Receive notification of an unparsed entity declaration event.

        Note that the notation name corresponds to a notation reported by the notationDecl event. It is up to the application to record the entity for later reference, if necessary; unparsed entities may appear as attribute values.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        参数：
        name - The unparsed entity's name.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        notationName - The name of the associated notation.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o oinconcxeecxxS>oo..f./.oga/a"xlx


EntityResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface EntityResolver

  • All Known Subinterfaces:
    EntityResolver2
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface EntityResolver
    Basic interface for resolving entities.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized handling for external entities, it must implement this interface and register an instance with the SAX driver using the setEntityResolver method.

    The XML reader will then allow the application to intercept any external entities (including the external DTD subset and external parameter entities, if any) before including them.

    Many SAX applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialised input sources, or for applications that use URI types other than URLs.

    The following resolver would provide the application with a special character stream for the entity with the system identifier "http://www.myhost.com/today":

     import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

 public class MyResolver implements EntityResolver {
   public InputSource resolveEntity (String publicId, String systemId)
   {
     if (systemId.equals("http://www.myhost.com/today")) {
              // return a special input source
       MyReader reader = new MyReader();
       return new InputSource(reader);
     } else {
              // use the default behaviour
       return null;
     }
   }
 }

    The application can also use this interface to redirect system identifiers to local URIs or to look up replacements in a catalog (possibly by using the public identifier).

    从以下版本开始：
    SAX 1.0
    另请参见：
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver), InputSource

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InputSource resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.

    • 方法详细信息

      • resolveEntity

        InputSource resolveEntity(String publicId,
                        String systemId)
                          throws SAXException,
                                 IOException
        Allow the application to resolve external entities.

        The parser will call this method before opening any external entity except the top-level document entity. Such entities include the external DTD subset and external parameter entities referenced within the DTD (in either case, only if the parser reads external parameter entities), and external general entities referenced within the document element (if the parser reads external general entities). The application may request that the parser locate the entity itself, that it use an alternative URI, or that it use data provided by the application (as a character or byte input stream).

        Application writers can use this method to redirect external system identifiers to secure and/or local URIs, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box). Neither XML nor SAX specifies a preferred policy for using public or system IDs to resolve resources. However, SAX specifies how to interpret any InputSource returned by this method, and that if none is returned, then the system ID will be dereferenced as a URL.

        If the system identifier is a URL, the SAX parser must resolve it fully before reporting it to the application.

        参数：
        publicId - The public identifier of the external entity being referenced, or null if none was supplied.
        systemId - The system identifier of the external entity being referenced.
        返回：
        An InputSource object describing the new input source, or null to request that the parser open a regular URI connection to the system identifier.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        另请参见：
        InputSource
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>r/<>>/蟬sxm.x/.m/cxcx/Dul


ErrorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface ErrorHandler

  • All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface ErrorHandler
    Basic interface for SAX error handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized error handling, it must implement this interface and then register an instance with the XML reader using the setErrorHandler method. The parser will then report all errors and warnings through this interface.

    警告： If an application does not register an ErrorHandler, XML parsing errors will go unreported, except that SAXParseExceptions will be thrown for fatal errors. In order to detect validity errors, an ErrorHandler that does something with error() calls must be registered.

    For XML processing errors, a SAX driver must use this interface in preference to throwing an exception: it is up to the application to decide whether to throw an exception for different types of errors and warnings. Note, however, that there is no requirement that the parser continue to report additional errors after a call to fatalError. In other words, a SAX driver class may throw an exception after reporting any fatalError. Also parsers may throw appropriate exceptions for non-XML errors. For example, XMLReader.parse() would throw an IOException for errors accessing entities or the document.

    从以下版本开始：
    SAX 1.0
    另请参见：
    XMLReader.setErrorHandler(org.xml.sax.ErrorHandler), SAXParseException

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void error(SAXParseException exception)
      Receive notification of a recoverable error.
      void fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void warning(SAXParseException exception)
      Receive notification of a warning.

    • 方法详细信息

      • warning

        void warning(SAXParseException exception)
             throws SAXException
        Receive notification of a warning.

        SAX parsers will use this method to report conditions that are not errors or fatal errors as defined by the XML recommendation. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end.

        Filters may use this method to report other, non-XML warnings as well.

        参数：
        exception - The warning information encapsulated in a SAX parse exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        SAXParseException

      • error

        void error(SAXParseException exception)
           throws SAXException
        Receive notification of a recoverable error.

        This corresponds to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a validating parser would use this callback to report the violation of a validity constraint. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end. If the application cannot do so, then the parser should report a fatal error even if the XML recommendation does not require it to do so.

        Filters may use this method to report other, non-XML errors as well.

        参数：
        exception - The error information encapsulated in a SAX parse exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        SAXParseException

      • fatalError

        void fatalError(SAXParseException exception)
                throws SAXException
        Receive notification of a non-recoverable error.

        There is an apparent contradiction between the documentation for this method and the documentation for ContentHandler.endDocument(). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        This corresponds to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a parser would use this callback to report the violation of a well-formedness constraint.

        The application must assume that the document is unusable after the parser has invoked this method, and should continue (if at all) only for the sake of collecting additional error messages: in fact, SAX parsers are free to stop reporting any other events once this method has been invoked.

        参数：
        exception - The error information encapsulated in a SAX parse exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        SAXParseException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

> Dsncv c<>ssA>>lc<


HandlerBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax

类 HandlerBase

  • java.lang.Object
    • org.xml.sax.HandlerBase
  • 所有已实现的接口：
    DocumentHandler, DTDHandler, EntityResolver, ErrorHandler
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.

    public class HandlerBase
extends Object
implements EntityResolver, DTDHandler, DocumentHandler, ErrorHandler
    Default base class for handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class implements the default behaviour for four SAX1 interfaces: EntityResolver, DTDHandler, DocumentHandler, and ErrorHandler. It is now obsolete, but is included in SAX2 to support legacy SAX1 applications. SAX2 applications should use the DefaultHandler class instead.

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    Note that the use of this class is optional.

    从以下版本开始：
    SAX 1.0
    另请参见：
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

    • 构造方法摘要

      Constructors
      构造方法与描述
      HandlerBase()
      Deprecated.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Deprecated.
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Deprecated.
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • HandlerBase

        public HandlerBase()
        Deprecated.

    • 方法详细信息

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                        String systemId)
                          throws SAXException
        Deprecated.
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        指定者：
        resolveEntity in interface EntityResolver
        参数：
        publicId - The public identifer, or null if none is available.
        systemId - The system identifier provided in the XML document.
        返回：
        The new input source, or null to require the default behaviour.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                String publicId,
                String systemId)
        Deprecated.
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        指定者：
        notationDecl in interface DTDHandler
        参数：
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        另请参见：
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                      String publicId,
                      String systemId,
                      String notationName)
        Deprecated.
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        指定者：
        unparsedEntityDecl in interface DTDHandler
        参数：
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        另请参见：
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Deprecated.
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        指定者：
        setDocumentLocator in interface DocumentHandler
        参数：
        locator - A locator for all SAX document events.
        另请参见：
        DocumentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Deprecated.
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        指定者：
        startDocument in interface DocumentHandler
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Deprecated.
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        指定者：
        endDocument in interface DocumentHandler
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String name,
                AttributeList attributes)
                  throws SAXException
        Deprecated.
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        指定者：
        startElement in interface DocumentHandler
        参数：
        name - The element type name.
        attributes - The specified or defaulted attributes.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • endElement

        public void endElement(String name)
                throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        指定者：
        endElement in interface DocumentHandler
        参数：
        name - the element name
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Deprecated.
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        指定者：
        characters in interface DocumentHandler
        参数：
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        指定者：
        ignorableWhitespace in interface DocumentHandler
        参数：
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                         String data)
                           throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        指定者：
        processingInstruction in interface DocumentHandler
        参数：
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Deprecated.
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        指定者：
        warning in interface ErrorHandler
        参数：
        e - The warning information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Deprecated.
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        指定者：
        error in interface ErrorHandler
        参数：
        e - The warning information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Deprecated.
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        指定者：
        fatalError in interface ErrorHandler
        参数：
        e - The error information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


InputSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax

类 InputSource

  • java.lang.Object
    • org.xml.sax.InputSource

  • public class InputSource
extends Object
    A single input source for an XML entity.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class allows a SAX application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), and/or a character stream.

    There are two places that the application can deliver an input source to the parser: as the argument to the Parser.parse method, or as the return value of the EntityResolver.resolveEntity method.

    The SAX parser will use the InputSource object to determine how to read XML input. If there is a character stream available, the parser will read that stream directly, disregarding any text encoding declaration found in that stream. If there is no character stream, but there is a byte stream, the parser will use that byte stream, using the encoding specified in the InputSource or else (if no encoding is specified) autodetecting the character encoding using an algorithm such as the one in the XML specification. If neither a character stream nor a byte stream is available, the parser will attempt to open a URI connection to the resource identified by the system identifier.

    An InputSource object belongs to the application: the SAX parser shall never modify it in any way (it may modify a copy if necessary). However, standard processing of both byte and character streams is to close them on as part of end-of-parse cleanup, so applications should not attempt to re-use such streams after they have been handed to a parser.

    从以下版本开始：
    SAX 1.0
    另请参见：
    XMLReader.parse(org.xml.sax.InputSource), EntityResolver.resolveEntity(java.lang.String, java.lang.String), InputStream, Reader

    • 构造方法摘要

      Constructors
      构造方法与描述
      InputSource()
      Zero-argument default constructor.
      InputSource(InputStream byteStream)
      Create a new input source with a byte stream.
      InputSource(Reader characterStream)
      Create a new input source with a character stream.
      InputSource(String systemId)
      Create a new input source with a system identifier.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InputStream getByteStream()
      Get the byte stream for this input source.
      Reader getCharacterStream()
      Get the character stream for this input source.
      String getEncoding()
      Get the character encoding for a byte stream or URI.
      String getPublicId()
      Get the public identifier for this input source.
      String getSystemId()
      Get the system identifier for this input source.
      void setByteStream(InputStream byteStream)
      Set the byte stream for this input source.
      void setCharacterStream(Reader characterStream)
      Set the character stream for this input source.
      void setEncoding(String encoding)
      Set the character encoding, if known.
      void setPublicId(String publicId)
      Set the public identifier for this input source.
      void setSystemId(String systemId)
      Set the system identifier for this input source.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • InputSource

        public InputSource()
        Zero-argument default constructor.
        另请参见：
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader),
setEncoding(java.lang.String)

      • InputSource

        public InputSource(String systemId)
        Create a new input source with a system identifier.

        Applications may use setPublicId to include a public identifier as well, or setEncoding to specify the character encoding, if known.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        参数：
        systemId - The system identifier (URI).
        另请参见：
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setEncoding(java.lang.String),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(InputStream byteStream)
        Create a new input source with a byte stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, may use setPublicId to include a public identifier, and may use setEncoding to specify the object's character encoding.

        参数：
        byteStream - The raw byte stream containing the document.
        另请参见：
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setEncoding(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(Reader characterStream)
        Create a new input source with a character stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, and may use setPublicId to include a public identifier.

        The character stream shall not include a byte order mark.

        另请参见：
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

    • 方法详细信息

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this input source.

        The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

        参数：
        publicId - The public identifier as a string.
        另请参见：
        getPublicId(),
Locator.getPublicId(),
SAXParseException.getPublicId()

      • getPublicId

        public String getPublicId()
        Get the public identifier for this input source.
        返回：
        The public identifier, or null if none was supplied.
        另请参见：
        setPublicId(java.lang.String)

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this input source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

        If the application knows the character encoding of the object pointed to by the system identifier, it can register the encoding using the setEncoding method.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        参数：
        systemId - The system identifier as a string.
        另请参见：
        setEncoding(java.lang.String),
getSystemId(),
Locator.getSystemId(),
SAXParseException.getSystemId()

      • getSystemId

        public String getSystemId()
        Get the system identifier for this input source.

        The getEncoding method will return the character encoding of the object pointed to, or null if unknown.

        If the system ID is a URL, it will be fully resolved.

        返回：
        The system identifier, or null if none was supplied.
        另请参见：
        setSystemId(java.lang.String), getEncoding()

      • setByteStream

        public void setByteStream(InputStream byteStream)
        Set the byte stream for this input source.

        The SAX parser will ignore this if there is also a character stream specified, but it will use a byte stream in preference to opening a URI connection itself.

        If the application knows the character encoding of the byte stream, it should set it with the setEncoding method.

        参数：
        byteStream - A byte stream containing an XML document or other entity.
        另请参见：
        setEncoding(java.lang.String),
getByteStream(),
getEncoding(),
InputStream

      • getByteStream

        public InputStream getByteStream()
        Get the byte stream for this input source.

        The getEncoding method will return the character encoding for this byte stream, or null if unknown.

        返回：
        The byte stream, or null if none was supplied.
        另请参见：
        getEncoding(), setByteStream(java.io.InputStream)

      • setEncoding

        public void setEncoding(String encoding)
        Set the character encoding, if known.

        The encoding must be a string acceptable for an XML encoding declaration (see section 4.3.3 of the XML 1.0 recommendation).

        This method has no effect when the application provides a character stream.

        参数：
        encoding - A string describing the character encoding.
        另请参见：
        setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
getEncoding()

      • getEncoding

        public String getEncoding()
        Get the character encoding for a byte stream or URI. This value will be ignored when the application provides a character stream.
        返回：
        The encoding, or null if none was supplied.
        另请参见：
        setByteStream(java.io.InputStream),
getSystemId(),
getByteStream()

      • setCharacterStream

        public void setCharacterStream(Reader characterStream)
        Set the character stream for this input source.

        If there is a character stream specified, the SAX parser will ignore any byte stream and will not attempt to open a URI connection to the system identifier.

        参数：
        characterStream - The character stream containing the XML document or other entity.
        另请参见：
        getCharacterStream(), Reader

      • getCharacterStream

        public Reader getCharacterStream()
        Get the character stream for this input source.
        返回：
        The character stream, or null if none was supplied.
        另请参见：
        setCharacterStream(java.io.Reader)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.;.e>ac


Locator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface Locator

  • All Known Subinterfaces:
    Locator2
    All Known Implementing Classes:
    Locator2Impl, LocatorImpl

    public interface Locator
    Interface for associating a SAX event with a document location.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX parser provides location information to the SAX application, it does so by implementing this interface and then passing an instance to the application using the content handler's setDocumentLocator method. The application can use the object to obtain the location of any other SAX event in the XML source document.

    Note that the results returned by the object will be valid only during the scope of each callback method: the application will receive unpredictable results if it attempts to use the locator at any other time, or after parsing completes.

    SAX parsers are not required to supply a locator, but they are very strongly encouraged to do so. If the parser supplies a locator, it must do so before reporting any other document events. If no locator has been set by the time the application receives the startDocument event, the application should assume that a locator is not available.

    从以下版本开始：
    SAX 1.0
    另请参见：
    ContentHandler.setDocumentLocator(org.xml.sax.Locator)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Return the column number where the current document event ends.
      int getLineNumber()
      Return the line number where the current document event ends.
      String getPublicId()
      Return the public identifier for the current document event.
      String getSystemId()
      Return the system identifier for the current document event.

    • 方法详细信息

      • getPublicId

        String getPublicId()
        Return the public identifier for the current document event.

        The return value is the public identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        返回：
        A string containing the public identifier, or null if none is available.
        另请参见：
        getSystemId()

      • getSystemId

        String getSystemId()
        Return the system identifier for the current document event.

        The return value is the system identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application. For example, a file name must always be provided as a file:... URL, and other kinds of relative URI are also resolved against their bases.

        返回：
        A string containing the system identifier, or null if none is available.
        另请参见：
        getPublicId()

      • getLineNumber

        int getLineNumber()
        Return the line number where the current document event ends. Lines are delimited by line ends, which are defined in the XML specification.

        警告： The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. In some cases, these "line" numbers match what would be displayed as columns, and in others they may not match the source text due to internal entity expansion.

        The return value is an approximation of the line number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first line is line 1.

        返回：
        The line number, or -1 if none is available.
        另请参见：
        getColumnNumber()

      • getColumnNumber

        int getColumnNumber()
        Return the column number where the current document event ends. This is one-based number of Java char values since the last line end.

        警告： The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. For example, when lines contain combining character sequences, wide characters, surrogate pairs, or bi-directional text, the value may not correspond to the column in a text editor's display.

        The return value is an approximation of the column number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first column in each line is column 1.

        返回：
        The column number, or -1 if none is available.
        另请参见：
        getLineNumber()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

gmp pr


org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException
c


org.xml.sax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.xml.sax

This package provides the core SAX APIs.

请参见： 描述

  • 接口摘要
    接口 描述
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    类 描述
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception 描述
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

软件包 org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | 描述
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | 描述
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>F eb bil� bnSSl.


org.xml.sax Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.xml.sax

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.InputSource
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException

Interface Hierarchy

  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
  • org.xml.sax.ContentHandler
  • org.xml.sax.DocumentHandler
  • org.xml.sax.DTDHandler
  • org.xml.sax.EntityResolver
  • org.xml.sax.ErrorHandler
  • org.xml.sax.Locator
  • org.xml.sax.Parser
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

alre sMXLLLap""osoo


Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface Parser

  • All Known Implementing Classes:
    XMLReaderAdapter
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.

    public interface Parser
    Basic interface for SAX (Simple API for XML) parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event supplier interface for SAX1; it has been replaced in SAX2 by XMLReader, which includes Namespace support and sophisticated configurability and extensibility.

    All SAX1 parsers must implement this basic interface: it allows applications to register handlers for different types of events and to initiate a parse from a URI, or a character stream.

    All SAX1 parsers must also implement a zero-argument constructor (though other constructors are also allowed).

    SAX1 parsers are reusable but not re-entrant: the application may reuse a parser object (possibly with a different input source) once the first parse has completed successfully, but it may not invoke the parse() methods recursively within a parse.

    从以下版本开始：
    SAX 1.0
    另请参见：
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler, HandlerBase, InputSource

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.
      void setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.
      void setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.

    • 方法详细信息

      • setLocale

        void setLocale(Locale locale)
               throws SAXException
        Deprecated.
        Allow an application to request a locale for errors and warnings.

        SAX parsers are not required to provide localisation for errors and warnings; if they cannot support the requested locale, however, they must throw a SAX exception. Applications may not request a locale change in the middle of a parse.

        参数：
        locale - A Java Locale object.
        抛出：
        SAXException - Throws an exception (using the previous or default locale) if the requested locale is not supported.
        另请参见：
        SAXException, SAXParseException

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Deprecated.
        Allow an application to register a custom entity resolver.

        If the application does not register an entity resolver, the SAX parser will resolve system identifiers and open connections to entities itself (this is the default behaviour implemented in HandlerBase).

        Applications may register a new or different entity resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        参数：
        resolver - The object for resolving entities.
        另请参见：
        EntityResolver, HandlerBase

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Deprecated.
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The DTD handler.
        另请参见：
        DTDHandler, HandlerBase

      • setDocumentHandler

        void setDocumentHandler(DocumentHandler handler)
        Deprecated.
        Allow an application to register a document event handler.

        If the application does not register a document handler, all document events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The document handler.
        另请参见：
        DocumentHandler, HandlerBase

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Deprecated.
        Allow an application to register an error event handler.

        If the application does not register an error event handler, all error events reported by the SAX parser will be silently ignored, except for fatalError, which will throw a SAXException (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The error handler.
        另请参见：
        ErrorHandler, SAXException, HandlerBase

      • parse

        void parse(InputSource source)
           throws SAXException,
                  IOException
        Deprecated.
        Parse an XML document.

        The application can use this method to instruct the SAX parser to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new Parser instead for each additional XML document). Once a parse is complete, an application may reuse the same Parser object, possibly with a different input source.

        参数：
        source - The input source for the top-level of the XML document.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setDocumentHandler(org.xml.sax.DocumentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
           throws SAXException,
                  IOException
        Deprecated.
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        参数：
        systemId - The system identifier (URI).
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        parse(org.xml.sax.InputSource)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"l>stci s HH.ml.


SAXException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax

类 SAXException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
  • 所有已实现的接口：
    Serializable
    直接已知子类：
    SAXNotRecognizedException, SAXNotSupportedException, SAXParseException

    public class SAXException
extends Exception
    Encapsulate a general SAX error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class can contain basic error or warning information from either the XML parser or the application: a parser writer or application writer can subclass it to provide additional functionality. SAX handlers may throw this exception or any exception subclassed from it.

    If the application needs to pass through other types of exceptions, it must wrap those exceptions in a SAXException or an exception derived from a SAXException.

    If the parser or application needs to include information about a specific location in an XML document, it should use the SAXParseException subclass.

    从以下版本开始：
    SAX 1.0
    另请参见：
    SAXParseException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXException()
      Create a new SAXException.
      SAXException(Exception e)
      Create a new SAXException wrapping an existing exception.
      SAXException(String message)
      Create a new SAXException.
      SAXException(String message, Exception e)
      Create a new SAXException from an existing exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      Throwable getCause()
      Return the cause of the exception
      Exception getException()
      Return the embedded exception, if any.
      String getMessage()
      Return a detail message for this exception.
      String toString()
      Override toString to pick up any embedded exception.

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SAXException

        public SAXException()
        Create a new SAXException.

      • SAXException

        public SAXException(String message)
        Create a new SAXException.
        参数：
        message - The error or warning message.

      • SAXException

        public SAXException(Exception e)
        Create a new SAXException wrapping an existing exception.

        The existing exception will be embedded in the new one, and its message will become the default message for the SAXException.

        参数：
        e - The exception to be wrapped in a SAXException.

      • SAXException

        public SAXException(String message,
            Exception e)
        Create a new SAXException from an existing exception.

        The existing exception will be embedded in the new one, but the new exception will have its own message.

        参数：
        message - The detail message.
        e - The exception to be wrapped in a SAXException.

    • 方法详细信息

      • getMessage

        public String getMessage()
        Return a detail message for this exception.

        If there is an embedded exception, and if the SAXException has no detail message of its own, this method will return the detail message from the embedded exception.

        重载：
        getMessage in class Throwable
        返回：
        The error or warning message.

      • getException

        public Exception getException()
        Return the embedded exception, if any.
        返回：
        The embedded exception, or null if there is none.

      • getCause

        public Throwable getCause()
        Return the cause of the exception
        重载：
        getCause in class Throwable
        返回：
        Return the cause of the exception

      • toString

        public String toString()
        Override toString to pick up any embedded exception.
        重载：
        toString in class Throwable
        返回：
        A string representation of this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

eirosessesi siieohh>pt> fp


SAXNotRecognizedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.xml.sax

类 SAXNotRecognizedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
  • 所有已实现的接口：
    Serializable

    public class SAXNotRecognizedException
extends SAXException
    Exception class for an unrecognized identifier.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it finds an unrecognized feature or property identifier; SAX applications and extensions may use this class for other, similar purposes.

    从以下版本开始：
    SAX 2.0
    另请参见：
    SAXNotSupportedException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXNotRecognizedException()
      Default constructor.
      SAXNotRecognizedException(String message)
      Construct a new exception with the given message.

    • 方法摘要

      • 方法 - 继承于类 org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SAXNotRecognizedException

        public SAXNotRecognizedException()
        Default constructor.

      • SAXNotRecognizedException

        public SAXNotRecognizedException(String message)
        Construct a new exception with the given message.
        参数：
        message - The text message of the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e tos"c="c llc <<..n dntiisaee umeet>


SAXNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method
org.xml.sax

类 SAXNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotSupportedException
  • 所有已实现的接口：
    Serializable

    public class SAXNotSupportedException
extends SAXException
    Exception class for an unsupported operation.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it recognizes a feature or property identifier, but cannot perform the requested operation (setting a state or value). Other SAX2 applications and extensions may use this class for similar purposes.

    从以下版本开始：
    SAX 2.0
    另请参见：
    SAXNotRecognizedException, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXNotSupportedException()
      Construct a new exception with no message.
      SAXNotSupportedException(String message)
      Construct a new exception with the given message.

    • 方法摘要

      • 方法 - 继承于类 org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SAXNotSupportedException

        public SAXNotSupportedException()
        Construct a new exception with no message.

      • SAXNotSupportedException

        public SAXNotSupportedException(String message)
        Construct a new exception with the given message.
        参数：
        message - The text message of the exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • Method

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>i .et,ptXp/EXAAnrttsll/sssos:>e


SAXParseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax

类 SAXParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXParseException
  • 所有已实现的接口：
    Serializable

    public class SAXParseException
extends SAXException
    Encapsulate an XML parse error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This exception may include information for locating the error in the original XML document, as if it came from a Locator object. Note that although the application will receive a SAXParseException as the argument to the handlers in the ErrorHandler interface, the application is not actually required to throw the exception; instead, it can simply read the information in it and take a different action.

    Since this exception is a subclass of SAXException, it inherits the ability to wrap another exception.

    从以下版本开始：
    SAX 1.0
    另请参见：
    SAXException, Locator, ErrorHandler, Serialized Form

    • 构造方法摘要

      Constructors
      构造方法与描述
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
      Create a new SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
      Create a new SAXParseException with an embedded exception.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      The column number of the end of the text where the exception occurred.
      int getLineNumber()
      The line number of the end of the text where the exception occurred.
      String getPublicId()
      Get the public identifier of the entity where the exception occurred.
      String getSystemId()
      Get the system identifier of the entity where the exception occurred.
      String toString()
      Override toString to provide more detailed error message.

      • 方法 - 继承于类 org.xml.sax.SAXException

        getCause, getException, getMessage

      • 方法 - 继承于类 java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • 构造方法详细信息

      • SAXParseException

        public SAXParseException(String message,
                 Locator locator)
        Create a new SAXParseException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback.

        参数：
        message - The error or warning message.
        locator - The locator object for the error or warning (may be null).
        另请参见：
        Locator

      • SAXParseException

        public SAXParseException(String message,
                 Locator locator,
                 Exception e)
        Wrap an existing exception in a SAXParseException.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback, and needs to wrap an existing exception that is not a subclass of SAXException.

        参数：
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning (may be null).
        e - Any exception.
        另请参见：
        Locator

      • SAXParseException

        public SAXParseException(String message,
                 String publicId,
                 String systemId,
                 int lineNumber,
                 int columnNumber)
        Create a new SAXParseException.

        This constructor is most useful for parser writers.

        All parameters except the message are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        参数：
        message - The error or warning message.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.

      • SAXParseException

        public SAXParseException(String message,
                 String publicId,
                 String systemId,
                 int lineNumber,
                 int columnNumber,
                 Exception e)
        Create a new SAXParseException with an embedded exception.

        This constructor is most useful for parser writers who need to wrap an exception that is not a subclass of SAXException.

        All parameters except the message and exception are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        参数：
        message - The error or warning message, or null to use the message from the embedded exception.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.
        e - Another exception to embed in this one.

    • 方法详细信息

      • getPublicId

        public String getPublicId()
        Get the public identifier of the entity where the exception occurred.
        返回：
        A string containing the public identifier, or null if none is available.
        另请参见：
        Locator.getPublicId()

      • getSystemId

        public String getSystemId()
        Get the system identifier of the entity where the exception occurred.

        If the system identifier is a URL, it will have been resolved fully.

        返回：
        A string containing the system identifier, or null if none is available.
        另请参见：
        Locator.getSystemId()

      • getLineNumber

        public int getLineNumber()
        The line number of the end of the text where the exception occurred.

        The first line is line 1.

        返回：
        An integer representing the line number, or -1 if none is available.
        另请参见：
        Locator.getLineNumber()

      • getColumnNumber

        public int getColumnNumber()
        The column number of the end of the text where the exception occurred.

        The first column in a line is position 1.

        返回：
        An integer representing the column number, or -1 if none is available.
        另请参见：
        Locator.getColumnNumber()

      • toString

        public String toString()
        Override toString to provide more detailed error message.
        重载：
        toString in class SAXException
        返回：
        A string representation of this exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ha/>/�>>hg "c癳绊"mmmyse<>aauvmln-


Uses of Package org.xml.sax

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.xml.sax

  • Packages that use org.xml.sax
    软件包 描述
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.
  • Classes in org.xml.sax used by java.beans
    类与描述
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind
    类与描述
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind.helpers
    类与描述
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.parsers
    类与描述
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    HandlerBase
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
    InputSource
    A single input source for an XML entity.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.transform.sax
    类与描述
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    InputSource
    A single input source for an XML entity.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.validation
    类与描述
    ContentHandler
    Receive notification of the logical content of a document.
    ErrorHandler
    Basic interface for SAX error handlers.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
  • Classes in org.xml.sax used by javax.xml.xpath
    类与描述
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by org.xml.sax
    类与描述
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by org.xml.sax.ext
    类与描述
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
  • Classes in org.xml.sax used by org.xml.sax.helpers
    类与描述
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>- U<�<╤i衑nw<


XMLFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface XMLFilter

  • All Superinterfaces:
    XMLReader
    All Known Implementing Classes:
    XMLFilterImpl

    public interface XMLFilter
extends XMLReader
    Interface for an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XML filter is like an XML reader, except that it obtains its events from another XML reader rather than a primary source like an XML document or database. Filters can modify a stream of events as they pass on to the final application.

    The XMLFilterImpl helper class provides a convenient base for creating SAX2 filters, by passing on all EntityResolver, DTDHandler, ContentHandler and ErrorHandler events automatically.

    从以下版本开始：
    SAX 2.0
    另请参见：
    XMLFilterImpl

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      XMLReader getParent()
      Get the parent reader.
      void setParent(XMLReader parent)
      Set the parent reader.

      • 方法 - 继承于接口 org.xml.sax.XMLReader

        getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getProperty, parse, parse, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setProperty

    • 方法详细信息

      • setParent

        void setParent(XMLReader parent)
        Set the parent reader.

        This method allows the application to link the filter to a parent reader (which may be another filter). The argument may not be null.

        参数：
        parent - The parent reader.

      • getParent

        XMLReader getParent()
        Get the parent reader.

        This method allows the application to query the parent reader (which may be another filter). It is generally a bad idea to perform any operations on the parent reader directly: they should all pass through this filter.

        返回：
        The parent filter, or null if none has been set.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

l.a"ehw.hwoaawoogjff"baaw<-nddde 啜/


XMLReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax

Interface XMLReader

  • All Known Subinterfaces:
    XMLFilter
    All Known Implementing Classes:
    ParserAdapter, XMLFilterImpl

    public interface XMLReader
    Interface for reading an XML document using callbacks.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: despite its name, this interface does not extend the standard Java Reader interface, because reading XML is a fundamentally different activity than reading character data.

    XMLReader is the interface that an XML parser's SAX2 driver must implement. This interface allows an application to set and query features and properties in the parser, to register event handlers for document processing, and to initiate a document parse.

    All SAX interfaces are assumed to be synchronous: the parse methods must not return until parsing is complete, and readers must wait for an event-handler callback to return before reporting the next event.

    This interface replaces the (now deprecated) SAX 1.0 Parser interface. The XMLReader interface contains two important enhancements over the old Parser interface (as well as some minor ones):

    1. it adds a standard way to query and set features and properties; and
    2. it adds Namespace support, which is required for many higher-level XML standards.

    There are adapters available to convert a SAX1 Parser to a SAX2 XMLReader and vice-versa.

    从以下版本开始：
    SAX 2.0
    另请参见：
    XMLFilter, ParserAdapter, XMLReaderAdapter

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.
      void setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature flag.
      void setProperty(String name, Object value)
      Set the value of a property.

    • 方法详细信息

      • getFeature

        boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a parse. Also, some feature values may not be programmatically accessible. (In the case of an adapter for SAX1 Parser, there is no implementation-independent way to expose whether the underlying parser is performing validation, expanding external entities, and so forth.)

        All XMLReaders are required to recognize the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes feature names.

        Typical usage is something like this:

         XMLReader r = new MySAXDriver();

                         // try to activate validation
 try {
   r.setFeature("http://xml.org/sax/features/validation", true);
 } catch (SAXException e) {
   System.err.println("Cannot activate validation.");
 }

                         // register event handlers
 r.setContentHandler(new MyContentHandler());
 r.setErrorHandler(new MyErrorHandler());

                         // parse the first document
 try {
   r.parse("http://www.foo.com/mydoc.xml");
 } catch (IOException e) {
   System.err.println("I/O exception reading XML document");
 } catch (SAXException e) {
   System.err.println("XML exception reading document.");
 }

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        参数：
        name - The feature name, which is a fully-qualified URI.
        返回：
        The current value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot determine its value at this time.
        另请参见：
        setFeature(java.lang.String, boolean)

      • setFeature

        void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        All XMLReaders are required to support setting http://xml.org/sax/features/namespaces to true and http://xml.org/sax/features/namespace-prefixes to false.

        参数：
        name - The feature name, which is a fully-qualified URI.
        value - The requested value of the feature (true or false).
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot set the requested value.
        另请参见：
        getFeature(java.lang.String)

      • getProperty

        Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize any specific property names, though an initial core set is documented for SAX2.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        参数：
        name - The property name, which is a fully-qualified URI.
        返回：
        The current value of the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        另请参见：
        setProperty(java.lang.String, java.lang.Object)

      • setProperty

        void setProperty(String name,
               Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize setting any specific property names, though a core set is defined by SAX2.

        This method is also the standard mechanism for setting extended handlers.

        参数：
        name - The property name, which is a fully-qualified URI.
        value - The requested value for the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot set the requested value.

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Allow an application to register an entity resolver.

        If the application does not register an entity resolver, the XMLReader will perform its own default resolution.

        Applications may register a new or different resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        参数：
        resolver - The entity resolver.
        另请参见：
        getEntityResolver()

      • getEntityResolver

        EntityResolver getEntityResolver()
        Return the current entity resolver.
        返回：
        The current entity resolver, or null if none has been registered.
        另请参见：
        setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The DTD handler.
        另请参见：
        getDTDHandler()

      • getDTDHandler

        DTDHandler getDTDHandler()
        Return the current DTD handler.
        返回：
        The current DTD handler, or null if none has been registered.
        另请参见：
        setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        void setContentHandler(ContentHandler handler)
        Allow an application to register a content event handler.

        If the application does not register a content handler, all content events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The content handler.
        另请参见：
        getContentHandler()

      • getContentHandler

        ContentHandler getContentHandler()
        Return the current content handler.
        返回：
        The current content handler, or null if none has been registered.
        另请参见：
        setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Allow an application to register an error event handler.

        If the application does not register an error handler, all error events reported by the SAX parser will be silently ignored; however, normal processing may not continue. It is highly recommended that all SAX applications implement an error handler to avoid unexpected bugs.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        参数：
        handler - The error handler.
        另请参见：
        getErrorHandler()

      • getErrorHandler

        ErrorHandler getErrorHandler()
        Return the current error handler.
        返回：
        The current error handler, or null if none has been registered.
        另请参见：
        setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse an XML document.

        The application can use this method to instruct the XML reader to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new XMLReader instead for each nested XML document). Once a parse is complete, an application may reuse the same XMLReader object, possibly with a different input source. Configuration of the XMLReader object (such as handler bindings and values established for feature flags and properties) is unchanged by completion of a parse, unless the definition of that aspect of the configuration explicitly specifies other behavior. (For example, feature flags or properties exposing characteristics of the document being parsed.)

        During the parse, the XMLReader will provide information about the XML document through the registered event handlers.

        This method is synchronous: it will not return until parsing has ended. If a client application wants to terminate parsing early, it should throw an exception.

        参数：
        input - The input source for the top-level of the XML document.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setContentHandler(org.xml.sax.ContentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
           throws IOException,
                  SAXException
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        参数：
        systemId - The system identifier (URI).
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        parse(org.xml.sax.InputSource)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法


Uses of Class org.xml.sax.HandlerBase

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.HandlerBase

  • Packages that use HandlerBase
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of HandlerBase in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type HandlerBase
      修饰符与类型 方法与描述
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

c"l<


Uses of Class org.xml.sax.InputSource

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.InputSource

  • Packages that use InputSource
    软件包 描述
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of InputSource in java.beans

      Constructors in java.beans with parameters of type InputSource
      构造方法与描述
      XMLDecoder(InputSource is)
      Creates a new decoder to parse XML archives created by the XMLEncoder class.

    • Uses of InputSource in javax.xml.bind

      Methods in javax.xml.bind with parameters of type InputSource
      修饰符与类型 方法与描述
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

    • Uses of InputSource in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type InputSource
      修饰符与类型 | 方法与描述
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of InputSource in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type InputSource
      修饰符与类型 方法与描述
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.

    • Uses of InputSource in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return InputSource
      修饰符与类型 方法与描述
      InputSource SAXSource.getInputSource()
      Get the SAX InputSource to be used for the Source.
      static InputSource SAXSource.sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.
      Methods in javax.xml.transform.sax with parameters of type InputSource
      修饰符与类型 方法与描述
      void SAXSource.setInputSource(InputSource inputSource)
      Set the SAX InputSource to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type InputSource
      构造方法与描述
      SAXSource(InputSource inputSource)
      Create a SAXSource, using a SAX InputSource.
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of InputSource in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type InputSource
      修饰符与类型 方法与描述
      String XPathExpression.evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPath.evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.

    • Uses of InputSource in org.xml.sax

      Methods in org.xml.sax that return InputSource
      修饰符与类型 方法与描述
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      Methods in org.xml.sax with parameters of type InputSource
      修饰符与类型 方法与描述
      void XMLReader.parse(InputSource input)
      Parse an XML document.
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.

    • Uses of InputSource in org.xml.sax.ext

      Methods in org.xml.sax.ext that return InputSource
      修饰符与类型 方法与描述
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.

    • Uses of InputSource in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that return InputSource
      修饰符与类型 方法与描述
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      Methods in org.xml.sax.helpers with parameters of type InputSource
      修饰符与类型 方法与描述
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.xml.sax.SAXException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.SAXException

  • Packages that use SAXException
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type SAXException
      修饰符与类型 方法与描述
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.

    • Uses of SAXException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXException
      修饰符与类型 方法与描述
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.

    • Uses of SAXException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXException
      修饰符与类型 方法与描述
      abstract Schema SchemaFactory.newSchema()
      Creates a special Schema object.
      Schema SchemaFactory.newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema SchemaFactory.newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
      void Validator.validate(Source source)
      Validates the specified input.
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of SAXException in org.xml.sax

      Subclasses of SAXException in org.xml.sax
      修饰符与类型 类与描述
      class  SAXNotRecognizedException
      Exception class for an unrecognized identifier.
      class  SAXNotSupportedException
      Exception class for an unsupported operation.
      class  SAXParseException
      Encapsulate an XML parse error or warning.
      Methods in org.xml.sax that throw SAXException
      修饰符与类型 方法与描述
      void HandlerBase.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void DocumentHandler.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void ContentHandler.characters(char[] ch, int start, int length)
      Receive notification of character data.
      void HandlerBase.endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void DocumentHandler.endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void ContentHandler.endDocument()
      Receive notification of the end of a document.
      void HandlerBase.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void DocumentHandler.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ContentHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void ContentHandler.endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void DocumentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void ContentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void DTDHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void XMLReader.parse(InputSource input)
      Parse an XML document.
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void XMLReader.parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void Parser.parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void HandlerBase.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void DocumentHandler.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void ContentHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      void Parser.setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.
      void ContentHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void HandlerBase.startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void DocumentHandler.startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void ContentHandler.startDocument()
      Receive notification of the beginning of a document.
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void ContentHandler.startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.
      void DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.

    • Uses of SAXException in org.xml.sax.ext

      Methods in org.xml.sax.ext that throw SAXException
      修饰符与类型 | 方法与描述
      void | DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)
      void DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void LexicalHandler.comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void | DefaultHandler2.comment(char[] ch, int start, int length)
      void | DefaultHandler2.elementDecl(String name, String model)
      void DeclHandler.elementDecl(String name, String model)
      Report an element type declaration.
      void LexicalHandler.endCDATA()
      Report the end of a CDATA section.
      void | DefaultHandler2.endCDATA()
      void LexicalHandler.endDTD()
      Report the end of DTD declarations.
      void | DefaultHandler2.endDTD()
      void LexicalHandler.endEntity(String name)
      Report the end of an entity.
      void | DefaultHandler2.endEntity(String name)
      void | DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)
      void DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      void | DefaultHandler2.internalEntityDecl(String name, String value)
      void DeclHandler.internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      void LexicalHandler.startCDATA()
      Report the start of a CDATA section.
      void | DefaultHandler2.startCDATA()
      void LexicalHandler.startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void | DefaultHandler2.startDTD(String name, String publicId, String systemId)
      void LexicalHandler.startEntity(String name)
      Report the beginning of some internal and external XML entities.
      void | DefaultHandler2.startEntity(String name)

    • Uses of SAXException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXException
      修饰符与类型 方法与描述
      void XMLReaderAdapter.characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      void XMLFilterImpl.characters(char[] ch, int start, int length)
      Filter a character data event.
      void ParserAdapter.characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void DefaultHandler.characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      void XMLReaderAdapter.endDocument()
      End document event.
      void XMLFilterImpl.endDocument()
      Filter an end document event.
      void ParserAdapter.endDocument()
      Adapter implementation method; do not call.
      void DefaultHandler.endDocument()
      Receive notification of the end of the document.
      void ParserAdapter.endElement(String qName)
      Adapter implementation method; do not call.
      void XMLReaderAdapter.endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void XMLFilterImpl.endElement(String uri, String localName, String qName)
      Filter an end element event.
      void DefaultHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void XMLFilterImpl.endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void DefaultHandler.endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void XMLReaderAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void XMLFilterImpl.ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void ParserAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void DefaultHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void XMLFilterImpl.notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void DefaultHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
      void XMLReaderAdapter.parse(String systemId)
      Parse the document.
      void XMLFilterImpl.parse(String systemId)
      Parse a document.
      void ParserAdapter.parse(String systemId)
      Parse an XML document.
      void XMLReaderAdapter.processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      void XMLFilterImpl.processingInstruction(String target, String data)
      Filter a processing instruction event.
      void ParserAdapter.processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      void DefaultHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      void XMLReaderAdapter.setLocale(Locale locale)
      Set the locale for error reporting.
      void XMLReaderAdapter.skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void XMLFilterImpl.skippedEntity(String name)
      Filter a skipped entity event.
      void DefaultHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void XMLReaderAdapter.startDocument()
      Start document event.
      void XMLFilterImpl.startDocument()
      Filter a start document event.
      void ParserAdapter.startDocument()
      Adapter implementation method; do not call.
      void DefaultHandler.startDocument()
      Receive notification of the beginning of the document.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void XMLFilterImpl.startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void DefaultHandler.startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
      Constructors in org.xml.sax.helpers that throw SAXException
      构造方法与描述
      ParserAdapter()
      Construct a new parser adapter.
      XMLReaderAdapter()
      Create a new adapter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类


Uses of Class org.xml.sax.SAXNotRecognizedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.SAXNotRecognizedException

  • Packages that use SAXNotRecognizedException
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotRecognizedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotRecognizedException
      修饰符与类型 方法与描述
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotRecognizedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotRecognizedException
      修饰符与类型 方法与描述
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotRecognizedException
      修饰符与类型 方法与描述
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotRecognizedException
      修饰符与类型 方法与描述
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

e =hesurommmn///mrt. "ll>


Uses of Class org.xml.sax.SAXNotSupportedException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.SAXNotSupportedException

  • Packages that use SAXNotSupportedException
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotSupportedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotSupportedException
      修饰符与类型 方法与描述
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotSupportedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotSupportedException
      修饰符与类型 方法与描述
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotSupportedException
      修饰符与类型 方法与描述
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotSupportedException
      修饰符与类型 方法与描述
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

s> >pbp/ooodmo/ee/


Uses of Class org.xml.sax.SAXParseException

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.SAXParseException

  • Packages that use SAXParseException
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXParseException in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type SAXParseException
      构造方法与描述
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • Uses of SAXParseException in org.xml.sax

      Methods in org.xml.sax with parameters of type SAXParseException
      修饰符与类型 方法与描述
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.

    • Uses of SAXParseException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers with parameters of type SAXParseException
      修饰符与类型 方法与描述
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i3npedEppoootxnn.r. hs se


Uses of Interface org.xml.sax.AttributeList

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.AttributeList

  • Packages that use AttributeList
    软件包 描述
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of AttributeList in org.xml.sax

      Methods in org.xml.sax with parameters of type AttributeList
      修饰符与类型 方法与描述
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.

    • Uses of AttributeList in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement AttributeList
      修饰符与类型 类与描述
      class  AttributeListImpl
      Deprecated.
      This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
      Methods in org.xml.sax.helpers with parameters of type AttributeList
      修饰符与类型 方法与描述
      void AttributeListImpl.setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      Constructors in org.xml.sax.helpers with parameters of type AttributeList
      构造方法与描述
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bxslaslr�


Uses of Interface org.xml.sax.Attributes

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.Attributes

  • Packages that use Attributes
    软件包 描述
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Attributes in org.xml.sax

      Methods in org.xml.sax with parameters of type Attributes
      修饰符与类型 方法与描述
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.

    • Uses of Attributes in org.xml.sax.ext

      Subinterfaces of Attributes in org.xml.sax.ext
      修饰符与类型 Interface and Description
      interface  Attributes2
      SAX2 extension to augment the per-attribute information provided though Attributes.
      Classes in org.xml.sax.ext that implement Attributes
      修饰符与类型 类与描述
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
      Methods in org.xml.sax.ext with parameters of type Attributes
      修饰符与类型 方法与描述
      void Attributes2Impl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      Constructors in org.xml.sax.ext with parameters of type Attributes
      构造方法与描述
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • Uses of Attributes in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Attributes
      修饰符与类型 类与描述
      class  AttributesImpl
      Default implementation of the Attributes interface.
      Methods in org.xml.sax.helpers with parameters of type Attributes
      修饰符与类型 方法与描述
      void AttributesImpl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      Constructors in org.xml.sax.helpers with parameters of type Attributes
      构造方法与描述
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=.nsnfAlteOe �/d


Uses of Interface org.xml.sax.ContentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ContentHandler

  • Packages that use ContentHandler
    软件包 描述
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ContentHandler in javax.xml.bind

      Subinterfaces of ContentHandler in javax.xml.bind
      修饰符与类型 Interface and Description
      interface  UnmarshallerHandler
      Unmarshaller implemented as SAX ContentHandler.
      Methods in javax.xml.bind with parameters of type ContentHandler
      修饰符与类型 方法与描述
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.

    • Uses of ContentHandler in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type ContentHandler
      修饰符与类型 | 方法与描述
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

    • Uses of ContentHandler in javax.xml.transform.sax

      Subinterfaces of ContentHandler in javax.xml.transform.sax
      修饰符与类型 Interface and Description
      interface  TemplatesHandler
      A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return ContentHandler
      修饰符与类型 方法与描述
      ContentHandler SAXResult.getHandler()
      Get the ContentHandler that is the Result.
      Methods in javax.xml.transform.sax with parameters of type ContentHandler
      修饰符与类型 方法与描述
      void SAXResult.setHandler(ContentHandler handler)
      Set the target to be a SAX2 ContentHandler.
      Constructors in javax.xml.transform.sax with parameters of type ContentHandler
      构造方法与描述
      SAXResult(ContentHandler handler)
      Create a SAXResult that targets a SAX2 ContentHandler.

    • Uses of ContentHandler in javax.xml.validation

      Classes in javax.xml.validation that implement ContentHandler
      修饰符与类型 类与描述
      class  ValidatorHandler
      Streaming validator that works on SAX stream.
      Methods in javax.xml.validation that return ContentHandler
      修饰符与类型 方法与描述
      abstract ContentHandler ValidatorHandler.getContentHandler()
      Gets the ContentHandler which receives the augmented validation result.
      Methods in javax.xml.validation with parameters of type ContentHandler
      修饰符与类型 方法与描述
      abstract void ValidatorHandler.setContentHandler(ContentHandler receiver)
      Sets the ContentHandler which receives the augmented validation result.

    • Uses of ContentHandler in org.xml.sax

      Methods in org.xml.sax that return ContentHandler
      修饰符与类型 方法与描述
      ContentHandler XMLReader.getContentHandler()
      Return the current content handler.
      Methods in org.xml.sax with parameters of type ContentHandler
      修饰符与类型 方法与描述
      void XMLReader.setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.

    • Uses of ContentHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ContentHandler
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ContentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ContentHandler
      修饰符与类型 类与描述
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return ContentHandler
      修饰符与类型 方法与描述
      ContentHandler XMLFilterImpl.getContentHandler()
      Get the content event handler.
      ContentHandler ParserAdapter.getContentHandler()
      Return the current content handler.
      Methods in org.xml.sax.helpers with parameters of type ContentHandler
      修饰符与类型 方法与描述
      void XMLFilterImpl.setContentHandler(ContentHandler handler)
      Set the content event handler.
      void ParserAdapter.setContentHandler(ContentHandler handler)
      Set the content handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rv>f;amaltttparrat r>a9sit.


Uses of Interface org.xml.sax.DocumentHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.DocumentHandler

  • Packages that use DocumentHandler
    软件包 描述
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DocumentHandler in org.xml.sax

      Classes in org.xml.sax that implement DocumentHandler
      修饰符与类型 类与描述
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax with parameters of type DocumentHandler
      修饰符与类型 方法与描述
      void Parser.setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.

    • Uses of DocumentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DocumentHandler
      修饰符与类型 类与描述
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      Methods in org.xml.sax.helpers with parameters of type DocumentHandler
      修饰符与类型 方法与描述
      void XMLReaderAdapter.setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

fs= cl ><<


Uses of Interface org.xml.sax.DTDHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.DTDHandler

  • Packages that use DTDHandler
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DTDHandler in javax.xml.transform.sax

      Subinterfaces of DTDHandler in javax.xml.transform.sax
      修饰符与类型 Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

    • Uses of DTDHandler in org.xml.sax

      Classes in org.xml.sax that implement DTDHandler
      修饰符与类型 类与描述
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return DTDHandler
      修饰符与类型 方法与描述
      DTDHandler XMLReader.getDTDHandler()
      Return the current DTD handler.
      Methods in org.xml.sax with parameters of type DTDHandler
      修饰符与类型 方法与描述
      void XMLReader.setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.
      void Parser.setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.

    • Uses of DTDHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DTDHandler
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of DTDHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DTDHandler
      修饰符与类型 类与描述
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return DTDHandler
      修饰符与类型 方法与描述
      DTDHandler XMLFilterImpl.getDTDHandler()
      Get the current DTD event handler.
      DTDHandler ParserAdapter.getDTDHandler()
      Return the current DTD handler.
      Methods in org.xml.sax.helpers with parameters of type DTDHandler
      修饰符与类型 方法与描述
      void XMLReaderAdapter.setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
      void XMLFilterImpl.setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void ParserAdapter.setDTDHandler(DTDHandler handler)
      Set the DTD handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

tmy>tt


Uses of Interface org.xml.sax.EntityResolver

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.EntityResolver

  • Packages that use EntityResolver
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of EntityResolver in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type EntityResolver
      修饰符与类型 方法与描述
      abstract void DocumentBuilder.setEntityResolver(EntityResolver er)
      Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.

    • Uses of EntityResolver in org.xml.sax

      Classes in org.xml.sax that implement EntityResolver
      修饰符与类型 类与描述
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return EntityResolver
      修饰符与类型 方法与描述
      EntityResolver XMLReader.getEntityResolver()
      Return the current entity resolver.
      Methods in org.xml.sax with parameters of type EntityResolver
      修饰符与类型 方法与描述
      void XMLReader.setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.
      void Parser.setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.

    • Uses of EntityResolver in org.xml.sax.ext

      Subinterfaces of EntityResolver in org.xml.sax.ext
      修饰符与类型 Interface and Description
      interface  EntityResolver2
      Extended interface for mapping external entity references to input sources, or providing a missing external subset.
      Classes in org.xml.sax.ext that implement EntityResolver
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of EntityResolver in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement EntityResolver
      修饰符与类型 类与描述
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return EntityResolver
      修饰符与类型 方法与描述
      EntityResolver XMLFilterImpl.getEntityResolver()
      Get the current entity resolver.
      EntityResolver ParserAdapter.getEntityResolver()
      Return the current entity resolver.
      Methods in org.xml.sax.helpers with parameters of type EntityResolver
      修饰符与类型 方法与描述
      void XMLReaderAdapter.setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
      void XMLFilterImpl.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void ParserAdapter.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ltt/adutrol�>


Uses of Interface org.xml.sax.ErrorHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ErrorHandler

  • Packages that use ErrorHandler
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ErrorHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type ErrorHandler
      修饰符与类型 方法与描述
      abstract void DocumentBuilder.setErrorHandler(ErrorHandler eh)
      Specify the ErrorHandler to be used by the parser.

    • Uses of ErrorHandler in javax.xml.validation

      Methods in javax.xml.validation that return ErrorHandler
      修饰符与类型 方法与描述
      abstract ErrorHandler ValidatorHandler.getErrorHandler()
      Gets the current ErrorHandler set to this ValidatorHandler.
      abstract ErrorHandler Validator.getErrorHandler()
      Gets the current ErrorHandler set to this Validator.
      abstract ErrorHandler SchemaFactory.getErrorHandler()
      Gets the current ErrorHandler set to this SchemaFactory.
      Methods in javax.xml.validation with parameters of type ErrorHandler
      修饰符与类型 方法与描述
      abstract void ValidatorHandler.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validation.
      abstract void Validator.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validate method invocation.
      abstract void SchemaFactory.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.

    • Uses of ErrorHandler in org.xml.sax

      Classes in org.xml.sax that implement ErrorHandler
      修饰符与类型 类与描述
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return ErrorHandler
      修饰符与类型 方法与描述
      ErrorHandler XMLReader.getErrorHandler()
      Return the current error handler.
      Methods in org.xml.sax with parameters of type ErrorHandler
      修饰符与类型 方法与描述
      void XMLReader.setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.
      void Parser.setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.

    • Uses of ErrorHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ErrorHandler
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ErrorHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ErrorHandler
      修饰符与类型 类与描述
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return ErrorHandler
      修饰符与类型 方法与描述
      ErrorHandler XMLFilterImpl.getErrorHandler()
      Get the current error event handler.
      ErrorHandler ParserAdapter.getErrorHandler()
      Return the current error handler.
      Methods in org.xml.sax.helpers with parameters of type ErrorHandler
      修饰符与类型 方法与描述
      void XMLReaderAdapter.setErrorHandler(ErrorHandler handler)
      Register the error event handler.
      void XMLFilterImpl.setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void ParserAdapter.setErrorHandler(ErrorHandler handler)
      Set the error handler.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ttostd萪t>>>>aee>>x�.x stc


Uses of Interface org.xml.sax.Locator

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.Locator

  • Packages that use Locator
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Locator in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type Locator
      构造方法与描述
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.

    • Uses of Locator in org.xml.sax

      Methods in org.xml.sax with parameters of type Locator
      修饰符与类型 方法与描述
      void HandlerBase.setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      void DocumentHandler.setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      void ContentHandler.setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      Constructors in org.xml.sax with parameters of type Locator
      构造方法与描述
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.

    • Uses of Locator in org.xml.sax.ext

      Subinterfaces of Locator in org.xml.sax.ext
      修饰符与类型 Interface and Description
      interface  Locator2
      SAX2 extension to augment the entity information provided though a Locator.
      Classes in org.xml.sax.ext that implement Locator
      修饰符与类型 类与描述
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
      Constructors in org.xml.sax.ext with parameters of type Locator
      构造方法与描述
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • Uses of Locator in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Locator
      修饰符与类型 类与描述
      class  LocatorImpl
      Provide an optional convenience implementation of Locator.
      Methods in org.xml.sax.helpers with parameters of type Locator
      修饰符与类型 方法与描述
      void XMLReaderAdapter.setDocumentLocator(Locator locator)
      Set a document locator.
      void XMLFilterImpl.setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void ParserAdapter.setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      void DefaultHandler.setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      Constructors in org.xml.sax.helpers with parameters of type Locator
      构造方法与描述
      LocatorImpl(Locator locator)
      Copy constructor.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

oodlss= dccc wttsa> lae r>i


Uses of Interface org.xml.sax.Parser

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.Parser

  • Packages that use Parser
    软件包 描述
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Parser in javax.xml.parsers

      Methods in javax.xml.parsers that return Parser
      修饰符与类型 方法与描述
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.

    • Uses of Parser in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Parser
      修饰符与类型 类与描述
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return Parser
      修饰符与类型 方法与描述
      static Parser ParserFactory.makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser ParserFactory.makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.
      Constructors in org.xml.sax.helpers with parameters of type Parser
      构造方法与描述
      ParserAdapter(Parser parser)
      Construct a new parser adapter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

=F"tato/xLLL//""paasr/ts//s


Uses of Interface org.xml.sax.XMLFilter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.XMLFilter

  • Packages that use XMLFilter
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLFilter in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLFilter
      修饰符与类型 方法与描述
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..

    • Uses of XMLFilter in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLFilter
      修饰符与类型 类与描述
      class  XMLFilterImpl
      Base class for deriving an XML filter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

pUaxxmlo/rrr/.iirltspttax"


Uses of Interface org.xml.sax.XMLReader

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.XMLReader

  • Packages that use XMLReader
    软件包 描述
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return XMLReader
      修饰符与类型 方法与描述
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      Methods in javax.xml.bind.helpers with parameters of type XMLReader
      修饰符与类型 方法与描述
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of XMLReader in javax.xml.parsers

      Methods in javax.xml.parsers that return XMLReader
      修饰符与类型 方法与描述
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.

    • Uses of XMLReader in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLReader
      修饰符与类型 方法与描述
      XMLReader SAXSource.getXMLReader()
      Get the XMLReader to be used for the Source.
      Methods in javax.xml.transform.sax with parameters of type XMLReader
      修饰符与类型 方法与描述
      void SAXSource.setXMLReader(XMLReader reader)
      Set the XMLReader to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type XMLReader
      构造方法与描述
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of XMLReader in org.xml.sax

      Subinterfaces of XMLReader in org.xml.sax
      修饰符与类型 Interface and Description
      interface  XMLFilter
      Interface for an XML filter.
      Methods in org.xml.sax that return XMLReader
      修饰符与类型 方法与描述
      XMLReader XMLFilter.getParent()
      Get the parent reader.
      Methods in org.xml.sax with parameters of type XMLReader
      修饰符与类型 方法与描述
      void XMLFilter.setParent(XMLReader parent)
      Set the parent reader.

    • Uses of XMLReader in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLReader
      修饰符与类型 类与描述
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return XMLReader
      修饰符与类型 方法与描述
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      XMLReader XMLFilterImpl.getParent()
      Get the parent reader.
      Methods in org.xml.sax.helpers with parameters of type XMLReader
      修饰符与类型 方法与描述
      void XMLFilterImpl.setParent(XMLReader parent)
      Set the parent reader.
      Constructors in org.xml.sax.helpers with parameters of type XMLReader
      构造方法与描述
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/..


Attributes2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.ext

Interface Attributes2

  • All Superinterfaces:
    Attributes
    All Known Implementing Classes:
    Attributes2Impl

    public interface Attributes2
extends Attributes
    SAX2 extension to augment the per-attribute information provided though Attributes. If an implementation supports this extension, the attributes provided in ContentHandler.startElement() will implement this interface, and the http://xml.org/sax/features/use-attributes2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    Note that if an attribute was defaulted (!isSpecified()) it will of necessity also have been declared (isDeclared()) in the DTD. Similarly if an attribute's type is anything except CDATA, then it must have been declared.

    从以下版本开始：
    SAX 2.0 (extensions 1.1 alpha)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean isDeclared(int index)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String qName)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String uri, String localName)
      Returns false unless the attribute was declared in the DTD.
      boolean isSpecified(int index)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String qName)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String uri, String localName)
      Returns true unless the attribute value was provided by DTD defaulting.

      • 方法 - 继承于接口 org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • 方法详细信息

      • isDeclared

        boolean isDeclared(int index)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        参数：
        index - The attribute index (zero-based).
        返回：
        true if the attribute was declared in the DTD, false otherwise.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isDeclared

        boolean isDeclared(String qName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        参数：
        qName - The XML qualified (prefixed) name.
        返回：
        true if the attribute was declared in the DTD, false otherwise.
        抛出：
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • isDeclared

        boolean isDeclared(String uri,
                 String localName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        参数：
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        返回：
        true if the attribute was declared in the DTD, false otherwise.
        抛出：
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(int index)
        Returns true unless the attribute value was provided by DTD defaulting.
        参数：
        index - The attribute index (zero-based).
        返回：
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        boolean isSpecified(String uri,
                  String localName)
        Returns true unless the attribute value was provided by DTD defaulting.

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        参数：
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        返回：
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        抛出：
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(String qName)
        Returns true unless the attribute value was provided by DTD defaulting.
        参数：
        qName - The XML qualified (prefixed) name.
        返回：
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        抛出：
        IllegalArgumentException - When the supplied name does not identify an attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/nr>pofatanxxddkeM" or


Attributes2Impl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.ext

类 Attributes2Impl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
      • org.xml.sax.ext.Attributes2Impl
  • 所有已实现的接口：
    Attributes, Attributes2

    public class Attributes2Impl
extends AttributesImpl
implements Attributes2
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    The specified flag for each attribute will always be true, unless it has been set to false in the copy constructor or using setSpecified(int, boolean). Similarly, the declared flag for each attribute will always be false, except for defaulted attributes (specified is false), non-CDATA attributes, or when it is set to true using setDeclared(int, boolean). If you change an attribute's type by hand, you may need to modify its declared flag to match.

    从以下版本开始：
    SAX 2.0 (extensions 1.1 alpha)

    • 构造方法摘要

      Constructors
      构造方法与描述
      Attributes2Impl()
      Construct a new, empty Attributes2Impl object.
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list, setting its "specified" flag to true.
      boolean isDeclared(int index)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String qName)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String uri, String localName)
      Returns the current value of the attribute's "declared" flag.
      boolean isSpecified(int index)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String qName)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String uri, String localName)
      Returns the current value of an attribute's "specified" flag.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setDeclared(int index, boolean value)
      Assign a value to the "declared" flag of a specific attribute.
      void setSpecified(int index, boolean value)
      Assign a value to the "specified" flag of a specific attribute.

      • 方法 - 继承于类 org.xml.sax.helpers.AttributesImpl

        clear, getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue, setAttribute, setLocalName, setQName, setType, setURI, setValue

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • 构造方法详细信息

      • Attributes2Impl

        public Attributes2Impl()
        Construct a new, empty Attributes2Impl object.

      • Attributes2Impl

        public Attributes2Impl(Attributes atts)
        Copy an existing Attributes or Attributes2 object. If the object implements Attributes2, values of the specified and declared flags for each attribute are copied. Otherwise the flag values are defaulted to assume no DTD was used, unless there is evidence to the contrary (such as attributes with type other than CDATA, which must have been declared).

        This constructor is especially useful inside a startElement event.

        参数：
        atts - The existing Attributes object.

    • 方法详细信息

      • isDeclared

        public boolean isDeclared(int index)
        Returns the current value of the attribute's "declared" flag.
        指定者：
        isDeclared in interface Attributes2
        参数：
        index - The attribute index (zero-based).
        返回：
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String uri,
                 String localName)
        Returns the current value of the attribute's "declared" flag.
        指定者：
        isDeclared in interface Attributes2
        参数：
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        返回：
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String qName)
        Returns the current value of the attribute's "declared" flag.
        指定者：
        isDeclared in interface Attributes2
        参数：
        qName - The XML qualified (prefixed) name.
        返回：
        true if the attribute was declared in the DTD, false otherwise.

      • isSpecified

        public boolean isSpecified(int index)
        Returns the current value of an attribute's "specified" flag.
        指定者：
        isSpecified in interface Attributes2
        参数：
        index - The attribute index (zero-based).
        返回：
        current flag value
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        public boolean isSpecified(String uri,
                  String localName)
        Returns the current value of an attribute's "specified" flag.
        指定者：
        isSpecified in interface Attributes2
        参数：
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        返回：
        current flag value
        抛出：
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        public boolean isSpecified(String qName)
        Returns the current value of an attribute's "specified" flag.
        指定者：
        isSpecified in interface Attributes2
        参数：
        qName - The XML qualified (prefixed) name.
        返回：
        current flag value
        抛出：
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object. The "specified" flags are assigned as true, and "declared" flags as false (except when an attribute's type is not CDATA), unless the object is an Attributes2 object. In that case those flag values are all copied.
        重载：
        setAttributes in class AttributesImpl
        参数：
        atts - The attributes to copy.
        另请参见：
        AttributesImpl.setAttributes(org.xml.sax.Attributes)

      • addAttribute

        public void addAttribute(String uri,
                String localName,
                String qName,
                String type,
                String value)
        Add an attribute to the end of the list, setting its "specified" flag to true. To set that flag's value to false, use setSpecified(int, boolean).

        Unless the attribute type is CDATA, this attribute is marked as being declared in the DTD. To set that flag's value to true for CDATA attributes, use setDeclared(int, boolean).

        重载：
        addAttribute in class AttributesImpl
        参数：
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        另请参见：
        AttributesImpl.addAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • removeAttribute

        public void removeAttribute(int index)
        Description copied from class: AttributesImpl
        Remove an attribute from the list.
        重载：
        removeAttribute in class AttributesImpl
        参数：
        index - The index of the attribute (zero-based).

      • setDeclared

        public void setDeclared(int index,
               boolean value)
        Assign a value to the "declared" flag of a specific attribute. This is normally needed only for attributes of type CDATA, including attributes whose type is changed to or from CDATA.
        参数：
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
        另请参见：
        AttributesImpl.setType(int, java.lang.String)

      • setSpecified

        public void setSpecified(int index,
                boolean value)
        Assign a value to the "specified" flag of a specific attribute. This is the only way this flag can be cleared, except clearing by initialization with the copy constructor.
        参数：
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


DeclHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.ext

Interface DeclHandler

  • All Known Implementing Classes:
    DefaultHandler2

    public interface DeclHandler
    SAX2 extension handler for DTD declaration events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide more complete information about DTD declarations in an XML document. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    Note that data-related DTD declarations (unparsed entities and notations) are already reported through the DTDHandler interface.

    If you are using the declaration handler together with a lexical handler, all of the events will occur between the startDTD and the endDTD events.

    To set the DeclHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/declaration-handler and an object implementing this interface (or null) as the value. If the reader does not report declaration events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    从以下版本开始：
    SAX 2.0 (extensions 1.0)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.

    • 方法详细信息

      • elementDecl

        void elementDecl(String name,
               String model)
                 throws SAXException
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        参数：
        name - The element type name.
        model - The content model as a normalized string.
        抛出：
        SAXException - The application may raise an exception.

      • attributeDecl

        void attributeDecl(String eName,
                 String aName,
                 String type,
                 String mode,
                 String value)
                   throws SAXException
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        参数：
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        抛出：
        SAXException - The application may raise an exception.

      • internalEntityDecl

        void internalEntityDecl(String name,
                      String value)
                        throws SAXException
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • externalEntityDecl

        void externalEntityDecl(String name,
                      String publicId,
                      String systemId)
                        throws SAXException
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bau/m/rl/roggroo."oodsa'eaaret> > x


DefaultHandler2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.ext

类 DefaultHandler2

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
      • org.xml.sax.ext.DefaultHandler2
  • 所有已实现的接口：
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, DeclHandler, EntityResolver2, LexicalHandler

    public class DefaultHandler2
extends DefaultHandler
implements LexicalHandler, DeclHandler, EntityResolver2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions. Except for overriding the original SAX1 resolveEntity() method the added handler methods just return. Subclassers may override everything on a method-by-method basis.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    Note: this class might yet learn that the ContentHandler.setDocumentLocator() call might be passed a Locator2 object, and that the ContentHandler.startElement() call might be passed a Attributes2 object.

    从以下版本开始：
    SAX 2.0 (extensions 1.1 alpha)

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultHandler2()
      Constructs a handler which ignores all parsing events.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      InputSource getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      InputSource resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

      • 方法 - 继承于类 org.xml.sax.helpers.DefaultHandler

        characters, endDocument, endElement, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping, unparsedEntityDecl, warning

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultHandler2

        public DefaultHandler2()
        Constructs a handler which ignores all parsing events.

    • 方法详细信息

      • startCDATA

        public void startCDATA()
                throws SAXException
        从接口复制的描述： LexicalHandler
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        指定者：
        startCDATA in interface LexicalHandler
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.endCDATA()

      • endCDATA

        public void endCDATA()
              throws SAXException
        从接口复制的描述： LexicalHandler
        Report the end of a CDATA section.
        指定者：
        endCDATA in interface LexicalHandler
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.startCDATA()

      • startDTD

        public void startDTD(String name,
            String publicId,
            String systemId)
              throws SAXException
        从接口复制的描述： LexicalHandler
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        指定者：
        startDTD in interface LexicalHandler
        参数：
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.endDTD(), LexicalHandler.startEntity(java.lang.String)

      • endDTD

        public void endDTD()
            throws SAXException
        从接口复制的描述： LexicalHandler
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        指定者：
        endDTD in interface LexicalHandler
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        public void startEntity(String name)
                 throws SAXException
        从接口复制的描述： LexicalHandler
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        指定者：
        startEntity in interface LexicalHandler
        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        public void endEntity(String name)
               throws SAXException
        从接口复制的描述： LexicalHandler
        Report the end of an entity.
        指定者：
        endEntity in interface LexicalHandler
        参数：
        name - The name of the entity that is ending.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        LexicalHandler.startEntity(java.lang.String)

      • comment

        public void comment(char[] ch,
           int start,
           int length)
             throws SAXException
        从接口复制的描述： LexicalHandler
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        指定者：
        comment in interface LexicalHandler
        参数：
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        抛出：
        SAXException - The application may raise an exception.

      • attributeDecl

        public void attributeDecl(String eName,
                 String aName,
                 String type,
                 String mode,
                 String value)
                   throws SAXException
        从接口复制的描述： DeclHandler
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        指定者：
        attributeDecl in interface DeclHandler
        参数：
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        抛出：
        SAXException - The application may raise an exception.

      • elementDecl

        public void elementDecl(String name,
               String model)
                 throws SAXException
        从接口复制的描述： DeclHandler
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        指定者：
        elementDecl in interface DeclHandler
        参数：
        name - The element type name.
        model - The content model as a normalized string.
        抛出：
        SAXException - The application may raise an exception.

      • externalEntityDecl

        public void externalEntityDecl(String name,
                      String publicId,
                      String systemId)
                        throws SAXException
        从接口复制的描述： DeclHandler
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        指定者：
        externalEntityDecl in interface DeclHandler
        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        DeclHandler.internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • internalEntityDecl

        public void internalEntityDecl(String name,
                      String value)
                        throws SAXException
        从接口复制的描述： DeclHandler
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        指定者：
        internalEntityDecl in interface DeclHandler
        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • getExternalSubset

        public InputSource getExternalSubset(String name,
                            String baseURI)
                              throws SAXException,
                                     IOException
        Tells the parser that if no external subset has been declared in the document text, none should be used.
        指定者：
        getExternalSubset in interface EntityResolver2
        参数：
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        返回：
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String name,
                        String publicId,
                        String baseURI,
                        String systemId)
                          throws SAXException,
                                 IOException
        Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI. Note that because the older DefaultHandler.resolveEntity(), method is overridden to call this one, this method may sometimes be invoked with null name and baseURI, and with the systemId already absolutized.
        指定者：
        resolveEntity in interface EntityResolver2
        参数：
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        返回：
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                        String systemId)
                          throws SAXException,
                                 IOException
        Invokes EntityResolver2.resolveEntity() with null entity name and base URI. You only need to override that method to use this class.
        指定者：
        resolveEntity in interface EntityResolver
        重载：
        resolveEntity in class DefaultHandler
        参数：
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        返回：
        The new input source, or null to require the default behaviour.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        另请参见：
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


EntityResolver2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.ext

Interface EntityResolver2

  • All Superinterfaces:
    EntityResolver
    All Known Implementing Classes:
    DefaultHandler2

    public interface EntityResolver2
extends EntityResolver
    Extended interface for mapping external entity references to input sources, or providing a missing external subset. The XMLReader.setEntityResolver() method is used to provide implementations of this interface to parsers. When a parser uses the methods in this interface, the EntityResolver2.resolveEntity() method (in this interface) is used instead of the older (SAX 1.0) EntityResolver.resolveEntity() method.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    If a SAX application requires the customized handling which this interface defines for external entities, it must ensure that it uses an XMLReader with the http://xml.org/sax/features/use-entity-resolver2 feature flag set to true (which is its default value when the feature is recognized). If that flag is unrecognized, or its value is false, or the resolver does not implement this interface, then only the EntityResolver method will be used.

    That supports three categories of application that modify entity resolution. Old Style applications won't know about this interface; they will provide an EntityResolver. Transitional Mode provide an EntityResolver2 and automatically get the benefit of its methods in any systems (parsers or other tools) supporting it, due to polymorphism. Both Old Style and Transitional Mode applications will work with any SAX2 parser. New style applications will fail to run except on SAX2 parsers that support this particular feature. They will insist that feature flag have a value of "true", and the EntityResolver2 implementation they provide might throw an exception if the original SAX 1.0 style entity resolution method is invoked.

    从以下版本开始：
    SAX 2.0 (extensions 1.1 alpha)
    另请参见：
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      InputSource getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.

      • 方法 - 继承于接口 org.xml.sax.EntityResolver

        resolveEntity

    • 方法详细信息

      • getExternalSubset

        InputSource getExternalSubset(String name,
                            String baseURI)
                              throws SAXException,
                                     IOException
        Allows applications to provide an external subset for documents that don't explicitly define one. Documents with DOCTYPE declarations that omit an external subset can thus augment the declarations available for validation, entity processing, and attribute processing (normalization, defaulting, and reporting types including ID). This augmentation is reported through the startDTD() method as if the document text had originally included the external subset; this callback is made before any internal subset data or errors are reported.

        This method can also be used with documents that have no DOCTYPE declaration. When the root element is encountered, but no DOCTYPE declaration has been seen, this method is invoked. If it returns a value for the external subset, that root element is declared to be the root element, giving the effect of splicing a DOCTYPE declaration at the end the prolog of a document that could not otherwise be valid. The sequence of parser callbacks in that case logically resembles this:

         ... comments and PIs from the prolog (as usual)
 startDTD ("rootName", source.getPublicId (), source.getSystemId ());
 startEntity ("[dtd]");
 ... declarations, comments, and PIs from the external subset
 endEntity ("[dtd]");
 endDTD ();
 ... then the rest of the document (as usual)
 startElement (..., "rootName", ...);

        Note that the InputSource gets no further resolution. Implementations of this method may wish to invoke resolveEntity() to gain benefits such as use of local caches of DTD entities. Also, this method will never be used by a (non-validating) processor that is not including external parameter entities.

        Uses for this method include facilitating data validation when interoperating with XML processors that would always require undesirable network accesses for external entities, or which for other reasons adopt a "no DTDs" policy. Non-validation motives include forcing documents to include DTDs so that attributes are handled consistently. For example, an XPath processor needs to know which attibutes have type "ID" before it can process a widely used type of reference.

        警告： Returning an external subset modifies the input document. By providing definitions for general entities, it can make a malformed document appear to be well formed.

        参数：
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        返回：
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        InputSource resolveEntity(String name,
                        String publicId,
                        String baseURI,
                        String systemId)
                          throws SAXException,
                                 IOException
        Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution. This method is only called for external entities which have been properly declared. This method provides more flexibility than the EntityResolver interface, supporting implementations of more complex catalogue schemes such as the one defined by the OASIS XML Catalogs specification.

        Parsers configured to use this resolver method will call it to determine the input source to use for any external entity being included because of a reference in the XML text. That excludes the document entity, and any external entity returned by getExternalSubset(). When a (non-validating) processor is configured not to include a class of entities (parameter or general) through use of feature flags, this method is not invoked for such entities.

        Note that the entity naming scheme used here is the same one used in the LexicalHandler, or in the ContentHandler.skippedEntity() method.

        参数：
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        返回：
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.ao/>ia>itooittEs d>/tdc


LexicalHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.ext

Interface LexicalHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler2

    public interface LexicalHandler
    SAX2 extension handler for lexical events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide lexical information about an XML document, such as comments and CDATA section boundaries. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    The events in the lexical handler apply to the entire document, not just to the document element, and all lexical handler events must appear between the content handler's startDocument and endDocument events.

    To set the LexicalHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/lexical-handler and an object implementing this interface (or null) as the value. If the reader does not report lexical events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    从以下版本开始：
    SAX 2.0 (extensions 1.0)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

    • 方法详细信息

      • startDTD

        void startDTD(String name,
            String publicId,
            String systemId)
              throws SAXException
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        参数：
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        endDTD(), startEntity(java.lang.String)

      • endDTD

        void endDTD()
            throws SAXException
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        void startEntity(String name)
                 throws SAXException
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        参数：
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        void endEntity(String name)
               throws SAXException
        Report the end of an entity.
        参数：
        name - The name of the entity that is ending.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        startEntity(java.lang.String)

      • startCDATA

        void startCDATA()
                throws SAXException
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        endCDATA()

      • endCDATA

        void endCDATA()
              throws SAXException
        Report the end of a CDATA section.
        抛出：
        SAXException - The application may raise an exception.
        另请参见：
        startCDATA()

      • comment

        void comment(char[] ch,
           int start,
           int length)
             throws SAXException
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        参数：
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        抛出：
        SAXException - The application may raise an exception.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nralC


Locator2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.ext

Interface Locator2

  • All Superinterfaces:
    Locator
    All Known Implementing Classes:
    Locator2Impl

    public interface Locator2
extends Locator
    SAX2 extension to augment the entity information provided though a Locator. If an implementation supports this extension, the Locator provided in ContentHandler.setDocumentLocator() will implement this interface, and the http://xml.org/sax/features/use-locator2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    从以下版本开始：
    SAX 2.0 (extensions 1.1 alpha)

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getEncoding()
      Returns the name of the character encoding for the entity.
      String getXMLVersion()
      Returns the version of XML used for the entity.

      • 方法 - 继承于接口 org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • 方法详细信息

      • getXMLVersion

        String getXMLVersion()
        Returns the version of XML used for the entity. This will normally be the identifier from the current entity's <?xml version='...' ...?> declaration, or be defaulted by the parser.
        返回：
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.

      • getEncoding

        String getEncoding()
        Returns the name of the character encoding for the entity. If the encoding was declared externally (for example, in a MIME Content-Type header), that will be the name returned. Else if there was an <?xml ...encoding='...'?> declaration at the start of the document, that encoding name will be returned. Otherwise the encoding will been inferred (normally to be UTF-8, or some UTF-16 variant), and that inferred name will be returned.

        When an InputSource is used to provide an entity's character stream, this method returns the encoding provided in that input stream.

        Note that some recent W3C specifications require that text in some encodings be normalized, using Unicode Normalization Form C, before processing. Such normalization must be performed by applications, and would normally be triggered based on the value returned by this method.

        Encoding names may be those used by the underlying JVM, and comparisons should be case-insensitive.

        返回：
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ dbpispioddioopD""e=leme"(mnle>s


Locator2Impl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.ext

类 Locator2Impl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
      • org.xml.sax.ext.Locator2Impl
  • 所有已实现的接口：
    Locator2, Locator

    public class Locator2Impl
extends LocatorImpl
implements Locator2
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    从以下版本开始：
    SAX 2.0.2

    • 构造方法摘要

      Constructors
      构造方法与描述
      Locator2Impl()
      Construct a new, empty Locator2Impl object.
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      String getEncoding()
      Returns the current value of the encoding property.
      String getXMLVersion()
      Returns the current value of the version property.
      void setEncoding(String encoding)
      Assigns the current value of the encoding property.
      void setXMLVersion(String version)
      Assigns the current value of the version property.

      • 方法 - 继承于类 org.xml.sax.helpers.LocatorImpl

        getColumnNumber, getLineNumber, getPublicId, getSystemId, setColumnNumber, setLineNumber, setPublicId, setSystemId

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • 方法 - 继承于接口 org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • 构造方法详细信息

      • Locator2Impl

        public Locator2Impl()
        Construct a new, empty Locator2Impl object. This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • Locator2Impl

        public Locator2Impl(Locator locator)
        Copy an existing Locator or Locator2 object. If the object implements Locator2, values of the encoding and versionstrings are copied, otherwise they set to null.
        参数：
        locator - The existing Locator object.

    • 方法详细信息

      • getXMLVersion

        public String getXMLVersion()
        Returns the current value of the version property.
        指定者：
        getXMLVersion in interface Locator2
        返回：
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.
        另请参见：
        setXMLVersion(java.lang.String)

      • getEncoding

        public String getEncoding()
        Returns the current value of the encoding property.
        指定者：
        getEncoding in interface Locator2
        返回：
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
        另请参见：
        setEncoding(java.lang.String)

      • setXMLVersion

        public void setXMLVersion(String version)
        Assigns the current value of the version property.
        参数：
        version - the new "version" value
        另请参见：
        getXMLVersion()

      • setEncoding

        public void setEncoding(String encoding)
        Assigns the current value of the encoding property.
        参数：
        encoding - the new "encoding" value
        另请参见：
        getEncoding()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dhisC"DAfk foo pssx"olm.oapE/k//Xo.. /


org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl
e


org.xml.sax.ext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

请参见： 描述

  • 接口摘要
    接口 描述
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    类 描述
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

软件包 org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/<<=/o>de>a
tII


org.xml.sax.ext Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.xml.sax.ext

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)

Interface Hierarchy

  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • org.xml.sax.ext.DeclHandler
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • org.xml.sax.ext.LexicalHandler
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

a/gtsabaooosd//-iii/c


Uses of Package org.xml.sax.ext

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.xml.sax.ext

  • Packages that use org.xml.sax.ext
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.ext used by javax.xml.transform.sax
    类与描述
    LexicalHandler
    SAX2 extension handler for lexical events.
  • Classes in org.xml.sax.ext used by org.xml.sax.ext
    类与描述
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

"Bnl.epeldsadkllt(oofaas


Uses of Class org.xml.sax.ext.Attributes2Impl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.ext.Attributes2Impl

No usage of org.xml.sax.ext.Attributes2Impl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

txm-erv..///..iirta-<


Uses of Class org.xml.sax.ext.DefaultHandler2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.ext.DefaultHandler2

No usage of org.xml.sax.ext.DefaultHandler2
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nc= ==VABBBMO==//td=


Uses of Class org.xml.sax.ext.Locator2Impl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.ext.Locator2Impl

No usage of org.xml.sax.ext.Locator2Impl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/ca>.htmmaaa-o.. >nl/


Uses of Interface org.xml.sax.ext.Attributes2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ext.Attributes2

  • Packages that use Attributes2
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Attributes2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Attributes2
      修饰符与类型 类与描述
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

h ,u�>rPue


Uses of Interface org.xml.sax.ext.DeclHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ext.DeclHandler

  • Packages that use DeclHandler
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DeclHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DeclHandler
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

bl


Uses of Interface org.xml.sax.ext.EntityResolver2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ext.EntityResolver2

  • Packages that use EntityResolver2
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of EntityResolver2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement EntityResolver2
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

W/irieeroeget�.oy-rt>.


Uses of Interface org.xml.sax.ext.LexicalHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ext.LexicalHandler

  • Packages that use LexicalHandler
    软件包 描述
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LexicalHandler in javax.xml.transform.sax

      Subinterfaces of LexicalHandler in javax.xml.transform.sax
      修饰符与类型 Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return LexicalHandler
      修饰符与类型 方法与描述
      LexicalHandler SAXResult.getLexicalHandler()
      Get a SAX2 LexicalHandler for the output.
      Methods in javax.xml.transform.sax with parameters of type LexicalHandler
      修饰符与类型 方法与描述
      void SAXResult.setLexicalHandler(LexicalHandler handler)
      Set the SAX2 LexicalHandler for the output.

    • Uses of LexicalHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement LexicalHandler
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t/dau xo>"


Uses of Interface org.xml.sax.ext.Locator2

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Interface
org.xml.sax.ext.Locator2

  • Packages that use Locator2
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Locator2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Locator2
      修饰符与类型 类与描述
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>"Ssiv >e cn<


AttributeListImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 AttributeListImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl
  • 所有已实现的接口：
    AttributeList
    Deprecated.
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.

    public class AttributeListImpl
extends Object
implements AttributeList
    Default implementation for AttributeList.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    AttributeList implements the deprecated SAX1 AttributeList interface, and has been replaced by the new SAX2 AttributesImpl interface.

    This class provides a convenience implementation of the SAX AttributeList interface. This implementation is useful both for SAX parser writers, who can use it to provide attributes to the application, and for SAX application writers, who can use it to create a persistent copy of an element's attribute specifications:

     private AttributeList myatts;

 public void startElement (String name, AttributeList atts)
 {
              // create a persistent copy of the attribute list
              // for use outside this method
   myatts = new AttributeListImpl(atts);
   [...]
 }

    Please note that SAX parsers are not required to use this class to provide an implementation of AttributeList; it is supplied only as an optional convenience. In particular, parser writers are encouraged to invent more efficient implementations.

    从以下版本开始：
    SAX 1.0
    另请参见：
    AttributeList, DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttributeListImpl()
      Deprecated.
      Create an empty attribute list.
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(String name, String type, String value)
      Deprecated.
      Add an attribute to an attribute list.
      void clear()
      Deprecated.
      Clear the attribute list.
      int getLength()
      Deprecated.
      Return the number of attributes in the list.
      String getName(int i)
      Deprecated.
      Get the name of an attribute (by position).
      String getType(int i)
      Deprecated.
      Get the type of an attribute (by position).
      String getType(String name)
      Deprecated.
      Get the type of an attribute (by name).
      String getValue(int i)
      Deprecated.
      Get the value of an attribute (by position).
      String getValue(String name)
      Deprecated.
      Get the value of an attribute (by name).
      void removeAttribute(String name)
      Deprecated.
      Remove an attribute from the list.
      void setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttributeListImpl

        public AttributeListImpl()
        Deprecated.
        Create an empty attribute list.

        This constructor is most useful for parser writers, who will use it to create a single, reusable attribute list that can be reset with the clear method between elements.

        另请参见：
        addAttribute(java.lang.String, java.lang.String, java.lang.String), clear()

      • AttributeListImpl

        public AttributeListImpl(AttributeList atts)
        Deprecated.
        Construct a persistent copy of an existing attribute list.

        This constructor is most useful for application writers, who will use it to create a persistent copy of an existing attribute list.

        参数：
        atts - The attribute list to copy
        另请参见：
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • 方法详细信息

      • setAttributeList

        public void setAttributeList(AttributeList atts)
        Deprecated.
        Set the attribute list, discarding previous contents.

        This method allows an application writer to reuse an attribute list easily.

        参数：
        atts - The attribute list to copy.

      • addAttribute

        public void addAttribute(String name,
                String type,
                String value)
        Deprecated.
        Add an attribute to an attribute list.

        This method is provided for SAX parser writers, to allow them to build up an attribute list incrementally before delivering it to the application.

        参数：
        name - The attribute name.
        type - The attribute type ("NMTOKEN" for an enumeration).
        value - The attribute value (must not be null).
        另请参见：
        removeAttribute(java.lang.String), DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • removeAttribute

        public void removeAttribute(String name)
        Deprecated.
        Remove an attribute from the list.

        SAX application writers can use this method to filter an attribute out of an AttributeList. Note that invoking this method will change the length of the attribute list and some of the attribute's indices.

        If the requested attribute is not in the list, this is a no-op.

        参数：
        name - The attribute name.
        另请参见：
        addAttribute(java.lang.String, java.lang.String, java.lang.String)

      • clear

        public void clear()
        Deprecated.
        Clear the attribute list.

        SAX parser writers can use this method to reset the attribute list between DocumentHandler.startElement events. Normally, it will make sense to reuse the same AttributeListImpl object rather than allocating a new one each time.

        另请参见：
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • getLength

        public int getLength()
        Deprecated.
        Return the number of attributes in the list.
        指定者：
        getLength in interface AttributeList
        返回：
        The number of attributes in the list.
        另请参见：
        AttributeList.getLength()

      • getName

        public String getName(int i)
        Deprecated.
        Get the name of an attribute (by position).
        指定者：
        getName in interface AttributeList
        参数：
        i - The position of the attribute in the list.
        返回：
        The attribute name as a string, or null if there is no attribute at that position.
        另请参见：
        AttributeList.getName(int)

      • getType

        public String getType(int i)
        Deprecated.
        Get the type of an attribute (by position).
        指定者：
        getType in interface AttributeList
        参数：
        i - The position of the attribute in the list.
        返回：
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read), or null if there is no attribute at that position.
        另请参见：
        AttributeList.getType(int)

      • getValue

        public String getValue(int i)
        Deprecated.
        Get the value of an attribute (by position).
        指定者：
        getValue in interface AttributeList
        参数：
        i - The position of the attribute in the list.
        返回：
        The attribute value as a string, or null if there is no attribute at that position.
        另请参见：
        AttributeList.getValue(int)

      • getType

        public String getType(String name)
        Deprecated.
        Get the type of an attribute (by name).
        指定者：
        getType in interface AttributeList
        参数：
        name - The attribute name.
        返回：
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read).
        另请参见：
        AttributeList.getType(java.lang.String)

      • getValue

        public String getValue(String name)
        Deprecated.
        Get the value of an attribute (by name).
        指定者：
        getValue in interface AttributeList
        参数：
        name - The attribute name.
        返回：
        The attribute value as a string, or null if no such attribute exists.
        另请参见：
        AttributeList.getValue(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

f=Adeeh>n絜b&";s 9p�


AttributesImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 AttributesImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
  • 所有已实现的接口：
    Attributes
    直接已知子类：
    Attributes2Impl

    public class AttributesImpl
extends Object
implements Attributes
    Default implementation of the Attributes interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class provides a default implementation of the SAX2 Attributes interface, with the addition of manipulators so that the list can be modified or reused.

    There are two typical uses of this class:

    1. to take a persistent snapshot of an Attributes object in a startElement event; or
    2. to construct or modify an Attributes object in a SAX2 driver or filter.

    This class replaces the now-deprecated SAX1 AttributeListImpl class; in addition to supporting the updated Attributes interface rather than the deprecated AttributeList interface, it also includes a much more efficient implementation using a single array rather than a set of Vectors.

    从以下版本开始：
    SAX 2.0

    • 构造方法摘要

      Constructors
      构造方法与描述
      AttributesImpl()
      Construct a new, empty AttributesImpl object.
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list.
      void clear()
      Clear the attribute list for reuse.
      int getIndex(String qName)
      Look up an attribute's index by qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up an attribute's index by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Return an attribute's local name.
      String getQName(int index)
      Return an attribute's qualified (prefixed) name.
      String getType(int index)
      Return an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace-qualified name.
      String getURI(int index)
      Return an attribute's Namespace URI.
      String getValue(int index)
      Return an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace-qualified name.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttribute(int index, String uri, String localName, String qName, String type, String value)
      Set an attribute in the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setLocalName(int index, String localName)
      Set the local name of a specific attribute.
      void setQName(int index, String qName)
      Set the qualified name of a specific attribute.
      void setType(int index, String type)
      Set the type of a specific attribute.
      void setURI(int index, String uri)
      Set the Namespace URI of a specific attribute.
      void setValue(int index, String value)
      Set the value of a specific attribute.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • AttributesImpl

        public AttributesImpl()
        Construct a new, empty AttributesImpl object.

      • AttributesImpl

        public AttributesImpl(Attributes atts)
        Copy an existing Attributes object.

        This constructor is especially useful inside a startElement event.

        参数：
        atts - The existing Attributes object.

    • 方法详细信息

      • getLength

        public int getLength()
        Return the number of attributes in the list.
        指定者：
        getLength in interface Attributes
        返回：
        The number of attributes in the list.
        另请参见：
        Attributes.getLength()

      • getURI

        public String getURI(int index)
        Return an attribute's Namespace URI.
        指定者：
        getURI in interface Attributes
        参数：
        index - The attribute's index (zero-based).
        返回：
        The Namespace URI, the empty string if none is available, or null if the index is out of range.
        另请参见：
        Attributes.getURI(int)

      • getLocalName

        public String getLocalName(int index)
        Return an attribute's local name.
        指定者：
        getLocalName in interface Attributes
        参数：
        index - The attribute's index (zero-based).
        返回：
        The attribute's local name, the empty string if none is available, or null if the index if out of range.
        另请参见：
        Attributes.getLocalName(int)

      • getQName

        public String getQName(int index)
        Return an attribute's qualified (prefixed) name.
        指定者：
        getQName in interface Attributes
        参数：
        index - The attribute's index (zero-based).
        返回：
        The attribute's qualified name, the empty string if none is available, or null if the index is out of bounds.
        另请参见：
        Attributes.getQName(int)

      • getType

        public String getType(int index)
        Return an attribute's type by index.
        指定者：
        getType in interface Attributes
        参数：
        index - The attribute's index (zero-based).
        返回：
        The attribute's type, "CDATA" if the type is unknown, or null if the index is out of bounds.
        另请参见：
        Attributes.getType(int)

      • getValue

        public String getValue(int index)
        Return an attribute's value by index.
        指定者：
        getValue in interface Attributes
        参数：
        index - The attribute's index (zero-based).
        返回：
        The attribute's value or null if the index is out of bounds.
        另请参见：
        Attributes.getValue(int)

      • getIndex

        public int getIndex(String uri,
           String localName)
        Look up an attribute's index by Namespace name.

        In many cases, it will be more efficient to look up the name once and use the index query methods rather than using the name query methods repeatedly.

        指定者：
        getIndex in interface Attributes
        参数：
        uri - The attribute's Namespace URI, or the empty string if none is available.
        localName - The attribute's local name.
        返回：
        The attribute's index, or -1 if none matches.
        另请参见：
        Attributes.getIndex(java.lang.String,java.lang.String)

      • getIndex

        public int getIndex(String qName)
        Look up an attribute's index by qualified (prefixed) name.
        指定者：
        getIndex in interface Attributes
        参数：
        qName - The qualified name.
        返回：
        The attribute's index, or -1 if none matches.
        另请参见：
        Attributes.getIndex(java.lang.String)

      • getType

        public String getType(String uri,
             String localName)
        Look up an attribute's type by Namespace-qualified name.
        指定者：
        getType in interface Attributes
        参数：
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        返回：
        The attribute's type, or null if there is no matching attribute.
        另请参见：
        Attributes.getType(java.lang.String,java.lang.String)

      • getType

        public String getType(String qName)
        Look up an attribute's type by qualified (prefixed) name.
        指定者：
        getType in interface Attributes
        参数：
        qName - The qualified name.
        返回：
        The attribute's type, or null if there is no matching attribute.
        另请参见：
        Attributes.getType(java.lang.String)

      • getValue

        public String getValue(String uri,
              String localName)
        Look up an attribute's value by Namespace-qualified name.
        指定者：
        getValue in interface Attributes
        参数：
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        返回：
        The attribute's value, or null if there is no matching attribute.
        另请参见：
        Attributes.getValue(java.lang.String,java.lang.String)

      • getValue

        public String getValue(String qName)
        Look up an attribute's value by qualified (prefixed) name.
        指定者：
        getValue in interface Attributes
        参数：
        qName - The qualified name.
        返回：
        The attribute's value, or null if there is no matching attribute.
        另请参见：
        Attributes.getValue(java.lang.String)

      • clear

        public void clear()
        Clear the attribute list for reuse.

        Note that little memory is freed by this call: the current array is kept so it can be reused.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object.

        It may be more efficient to reuse an existing object rather than constantly allocating new ones.

        参数：
        atts - The attributes to copy.

      • addAttribute

        public void addAttribute(String uri,
                String localName,
                String qName,
                String type,
                String value)
        Add an attribute to the end of the list.

        For the sake of speed, this method does no checking to see if the attribute is already in the list: that is the responsibility of the application.

        参数：
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.

      • setAttribute

        public void setAttribute(int index,
                String uri,
                String localName,
                String qName,
                String type,
                String value)
        Set an attribute in the list.

        For the sake of speed, this method does no checking for name conflicts or well-formedness: such checks are the responsibility of the application.

        参数：
        index - The index of the attribute (zero-based).
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • removeAttribute

        public void removeAttribute(int index)
        Remove an attribute from the list.
        参数：
        index - The index of the attribute (zero-based).
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setURI

        public void setURI(int index,
          String uri)
        Set the Namespace URI of a specific attribute.
        参数：
        index - The index of the attribute (zero-based).
        uri - The attribute's Namespace URI, or the empty string for none.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setLocalName

        public void setLocalName(int index,
                String localName)
        Set the local name of a specific attribute.
        参数：
        index - The index of the attribute (zero-based).
        localName - The attribute's local name, or the empty string for none.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setQName

        public void setQName(int index,
            String qName)
        Set the qualified name of a specific attribute.
        参数：
        index - The index of the attribute (zero-based).
        qName - The attribute's qualified name, or the empty string for none.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setType

        public void setType(int index,
           String type)
        Set the type of a specific attribute.
        参数：
        index - The index of the attribute (zero-based).
        type - The attribute's type.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setValue

        public void setValue(int index,
            String value)
        Set the value of a specific attribute.
        参数：
        index - The index of the attribute (zero-based).
        value - The attribute's value.
        抛出：
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

d


DefaultHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 DefaultHandler

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
  • 所有已实现的接口：
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler
    直接已知子类：
    DefaultHandler2

    public class DefaultHandler
extends Object
implements EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Default base class for SAX2 event handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available as a convenience base class for SAX2 applications: it provides default implementations for all of the callbacks in the four core SAX2 handler classes:

    • EntityResolver
    • DTDHandler
    • ContentHandler
    • ErrorHandler

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    This class replaces the deprecated SAX1 HandlerBase class.

    从以下版本开始：
    SAX 2.0
    另请参见：
    EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • 构造方法摘要

      Constructors
      构造方法与描述
      DefaultHandler()

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      void endDocument()
      Receive notification of the end of the document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of the document.
      void startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Receive notification of a parser warning.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • DefaultHandler

        public DefaultHandler()

    • 方法详细信息

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                        String systemId)
                          throws IOException,
                                 SAXException
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        指定者：
        resolveEntity in interface EntityResolver
        参数：
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        返回：
        The new input source, or null to require the default behaviour.
        抛出：
        IOException - If there is an error setting up the new input source.
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                String publicId,
                String systemId)
                  throws SAXException
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        指定者：
        notationDecl in interface DTDHandler
        参数：
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                      String publicId,
                      String systemId,
                      String notationName)
                        throws SAXException
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        指定者：
        unparsedEntityDecl in interface DTDHandler
        参数：
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        指定者：
        setDocumentLocator in interface ContentHandler
        参数：
        locator - A locator for all SAX document events.
        另请参见：
        ContentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        指定者：
        startDocument in interface ContentHandler
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        指定者：
        endDocument in interface ContentHandler
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                      String uri)
                        throws SAXException
        Receive notification of the start of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each Namespace prefix scope (such as storing the prefix mapping).

        指定者：
        startPrefixMapping in interface ContentHandler
        参数：
        prefix - The Namespace prefix being declared.
        uri - The Namespace URI mapped to the prefix.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Receive notification of the end of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each prefix mapping.

        指定者：
        endPrefixMapping in interface ContentHandler
        参数：
        prefix - The Namespace prefix being declared.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                String localName,
                String qName,
                Attributes attributes)
                  throws SAXException
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        指定者：
        startElement in interface ContentHandler
        参数：
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        attributes - The attributes attached to the element. If there are no attributes, it shall be an empty Attributes object.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endElement

        public void endElement(String uri,
              String localName,
              String qName)
                throws SAXException
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        指定者：
        endElement in interface ContentHandler
        参数：
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        指定者：
        characters in interface ContentHandler
        参数：
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        指定者：
        ignorableWhitespace in interface ContentHandler
        参数：
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                         String data)
                           throws SAXException
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        指定者：
        processingInstruction in interface ContentHandler
        参数：
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Receive notification of a skipped entity.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        指定者：
        skippedEntity in interface ContentHandler
        参数：
        name - The name of the skipped entity.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        指定者：
        warning in interface ErrorHandler
        参数：
        e - The warning information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        指定者：
        error in interface ErrorHandler
        参数：
        e - The error information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        指定者：
        fatalError in interface ErrorHandler
        参数：
        e - The error information encoded as an exception.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        另请参见：
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


LocatorImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 LocatorImpl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
  • 所有已实现的接口：
    Locator
    直接已知子类：
    Locator2Impl

    public class LocatorImpl
extends Object
implements Locator
    Provide an optional convenience implementation of Locator.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available mainly for application writers, who can use it to make a persistent snapshot of a locator at any point during a document parse:

     Locator locator;
 Locator startloc;

 public void setLocator (Locator locator)
 {
         // note the locator
   this.locator = locator;
 }

 public void startDocument ()
 {
         // save the location of the start of the document
         // for future use.
   Locator startloc = new LocatorImpl(locator);
 }

    Normally, parser writers will not use this class, since it is more efficient to provide location information only when requested, rather than constantly updating a Locator object.

    从以下版本开始：
    SAX 1.0
    另请参见：
    Locator

    • 构造方法摘要

      Constructors
      构造方法与描述
      LocatorImpl()
      Zero-argument constructor.
      LocatorImpl(Locator locator)
      Copy constructor.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      int getColumnNumber()
      Return the saved column number (1-based).
      int getLineNumber()
      Return the saved line number (1-based).
      String getPublicId()
      Return the saved public identifier.
      String getSystemId()
      Return the saved system identifier.
      void setColumnNumber(int columnNumber)
      Set the column number for this locator (1-based).
      void setLineNumber(int lineNumber)
      Set the line number for this locator (1-based).
      void setPublicId(String publicId)
      Set the public identifier for this locator.
      void setSystemId(String systemId)
      Set the system identifier for this locator.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • LocatorImpl

        public LocatorImpl()
        Zero-argument constructor.

        This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • LocatorImpl

        public LocatorImpl(Locator locator)
        Copy constructor.

        Create a persistent copy of the current state of a locator. When the original locator changes, this copy will still keep the original values (and it can be used outside the scope of DocumentHandler methods).

        参数：
        locator - The locator to copy.

    • 方法详细信息

      • getPublicId

        public String getPublicId()
        Return the saved public identifier.
        指定者：
        getPublicId in interface Locator
        返回：
        The public identifier as a string, or null if none is available.
        另请参见：
        Locator.getPublicId(), setPublicId(java.lang.String)

      • getSystemId

        public String getSystemId()
        Return the saved system identifier.
        指定者：
        getSystemId in interface Locator
        返回：
        The system identifier as a string, or null if none is available.
        另请参见：
        Locator.getSystemId(), setSystemId(java.lang.String)

      • getLineNumber

        public int getLineNumber()
        Return the saved line number (1-based).
        指定者：
        getLineNumber in interface Locator
        返回：
        The line number as an integer, or -1 if none is available.
        另请参见：
        Locator.getLineNumber(), setLineNumber(int)

      • getColumnNumber

        public int getColumnNumber()
        Return the saved column number (1-based).
        指定者：
        getColumnNumber in interface Locator
        返回：
        The column number as an integer, or -1 if none is available.
        另请参见：
        Locator.getColumnNumber(), setColumnNumber(int)

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this locator.
        参数：
        publicId - The new public identifier, or null if none is available.
        另请参见：
        getPublicId()

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this locator.
        参数：
        systemId - The new system identifier, or null if none is available.
        另请参见：
        getSystemId()

      • setLineNumber

        public void setLineNumber(int lineNumber)
        Set the line number for this locator (1-based).
        参数：
        lineNumber - The line number, or -1 if none is available.
        另请参见：
        getLineNumber()

      • setColumnNumber

        public void setColumnNumber(int columnNumber)
        Set the column number for this locator (1-based).
        参数：
        columnNumber - The column number, or -1 if none is available.
        另请参见：
        getColumnNumber()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

i"tngS//S/all/aa./ nnlSmttte.lsv ass mvfSan


NamespaceSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 NamespaceSupport

  • java.lang.Object
    • org.xml.sax.helpers.NamespaceSupport

  • public class NamespaceSupport
extends Object
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class encapsulates the logic of Namespace processing: it tracks the declarations currently in force for each context and automatically processes qualified XML names into their Namespace parts; it can also be used in reverse for generating XML qnames from Namespaces.

    Namespace support objects are reusable, but the reset method must be invoked between each session.

    Here is a simple session:

     String parts[] = new String[3];
 NamespaceSupport support = new NamespaceSupport();

 support.pushContext();
 support.declarePrefix("", "http://www.w3.org/1999/xhtml");
 support.declarePrefix("dc", "http://www.purl.org/dc#");

 parts = support.processName("p", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 parts = support.processName("dc:title", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 support.popContext();

    Note that this class is optimized for the use case where most elements do not contain Namespace declarations: if the same prefix/URI mapping is repeated for each context (for example), this class will be somewhat less efficient.

    Although SAX drivers (parsers) may choose to use this class to implement namespace handling, they are not required to do so. Applications must track namespace information themselves if they want to use namespace information.

    从以下版本开始：
    SAX 2.0

    • 字段摘要

      Fields
      修饰符与类型 字段与描述
      static String NSDECL
      The namespace declaration URI as a constant.
      static String XMLNS
      The XML Namespace URI as a constant.

    • 构造方法摘要

      Constructors
      构造方法与描述
      NamespaceSupport()
      Create a new Namespace support object.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      boolean declarePrefix(String prefix, String uri)
      Declare a Namespace prefix.
      Enumeration getDeclaredPrefixes()
      Return an enumeration of all prefixes declared in this context.
      String getPrefix(String uri)
      Return one of the prefixes mapped to a Namespace URI.
      Enumeration getPrefixes()
      Return an enumeration of all prefixes whose declarations are active in the current context.
      Enumeration getPrefixes(String uri)
      Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.
      String getURI(String prefix)
      Look up a prefix and get the currently-mapped Namespace URI.
      boolean isNamespaceDeclUris()
      Returns true if namespace declaration attributes are placed into a namespace.
      void popContext()
      Revert to the previous Namespace context.
      String[] processName(String qName, String[] parts, boolean isAttribute)
      Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().
      void pushContext()
      Start a new Namespace context.
      void reset()
      Reset this Namespace support object for reuse.
      void setNamespaceDeclUris(boolean value)
      Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName().

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 字段详细信息

      • XMLNS

        public static final String XMLNS
        The XML Namespace URI as a constant. The value is http://www.w3.org/XML/1998/namespace as defined in the "Namespaces in XML" * recommendation.

        This is the Namespace URI that is automatically mapped to the "xml" prefix.

        另请参见：
        Constant Field Values

      • NSDECL

        public static final String NSDECL
        The namespace declaration URI as a constant. The value is http://www.w3.org/xmlns/2000/, as defined in a backwards-incompatible erratum to the "Namespaces in XML" recommendation. Because that erratum postdated SAX2, SAX2 defaults to the original recommendation, and does not normally use this URI.

        This is the Namespace URI that is optionally applied to xmlns and xmlns:* attributes, which are used to declare namespaces.

        从以下版本开始：
        SAX 2.1alpha
        另请参见：
        setNamespaceDeclUris(boolean), isNamespaceDeclUris(), Constant Field Values

    • 构造方法详细信息

      • NamespaceSupport

        public NamespaceSupport()
        Create a new Namespace support object.

    • 方法详细信息

      • reset

        public void reset()
        Reset this Namespace support object for reuse.

        It is necessary to invoke this method before reusing the Namespace support object for a new session. If namespace declaration URIs are to be supported, that flag must also be set to a non-default value.

        另请参见：
        setNamespaceDeclUris(boolean)

      • pushContext

        public void pushContext()
        Start a new Namespace context. The new context will automatically inherit the declarations of its parent context, but it will also keep track of which declarations were made within this context.

        Event callback code should start a new context once per element. This means being ready to call this in either of two places. For elements that don't include namespace declarations, the ContentHandler.startElement() callback is the right place. For elements with such a declaration, it'd done in the first ContentHandler.startPrefixMapping() callback. A boolean flag can be used to track whether a context has been started yet. When either of those methods is called, it checks the flag to see if a new context needs to be started. If so, it starts the context and sets the flag. After ContentHandler.startElement() does that, it always clears the flag.

        Normally, SAX drivers would push a new context at the beginning of each XML element. Then they perform a first pass over the attributes to process all namespace declarations, making ContentHandler.startPrefixMapping() callbacks. Then a second pass is made, to determine the namespace-qualified names for all attributes and for the element name. Finally all the information for the ContentHandler.startElement() callback is available, so it can then be made.

        The Namespace support object always starts with a base context already in force: in this context, only the "xml" prefix is declared.

        另请参见：
        ContentHandler, popContext()

      • popContext

        public void popContext()
        Revert to the previous Namespace context.

        Normally, you should pop the context at the end of each XML element. After popping the context, all Namespace prefix mappings that were previously in force are restored.

        You must not attempt to declare additional Namespace prefixes after popping a context, unless you push another context first.

        另请参见：
        pushContext()

      • declarePrefix

        public boolean declarePrefix(String prefix,
                    String uri)
        Declare a Namespace prefix. All prefixes must be declared before they are referenced. For example, a SAX driver (parser) would scan an element's attributes in two passes: first for namespace declarations, then a second pass using processName() to interpret prefixes against (potentially redefined) prefixes.

        This method declares a prefix in the current Namespace context; the prefix will remain in force until this context is popped, unless it is shadowed in a descendant context.

        To declare the default element Namespace, use the empty string as the prefix.

        Note that there is an asymmetry in this library: getPrefix will not return the "" prefix, even if you have declared a default element namespace. To check for a default namespace, you have to look it up explicitly using getURI. This asymmetry exists to make it easier to look up prefixes for attribute names, where the default prefix is not allowed.

        参数：
        prefix - The prefix to declare, or the empty string to indicate the default element namespace. This may never have the value "xml" or "xmlns".
        uri - The Namespace URI to associate with the prefix.
        返回：
        true if the prefix was legal, false otherwise
        另请参见：
        processName(java.lang.String, java.lang.String[], boolean),
getURI(java.lang.String),
getPrefix(java.lang.String)

      • processName

        public String[] processName(String qName,
                   String[] parts,
                   boolean isAttribute)
        Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().

        This method processes a raw XML qualified name in the current context by removing the prefix and looking it up among the prefixes currently declared. The return value will be the array supplied by the caller, filled in as follows:

        parts[0]
        The Namespace URI, or an empty string if none is in use.
        parts[1]
        The local name (without prefix).
        parts[2]
        The original raw name.

        All of the strings in the array will be internalized. If the raw name has a prefix that has not been declared, then the return value will be null.

        Note that attribute names are processed differently than element names: an unprefixed element name will receive the default Namespace (if any), while an unprefixed attribute name will not.

        参数：
        qName - The XML qualified name to be processed.
        parts - An array supplied by the caller, capable of holding at least three members.
        isAttribute - A flag indicating whether this is an attribute name (true) or an element name (false).
        返回：
        The supplied array holding three internalized strings representing the Namespace URI (or empty string), the local name, and the XML qualified name; or null if there is an undeclared prefix.
        另请参见：
        declarePrefix(java.lang.String, java.lang.String), String.intern()

      • getURI

        public String getURI(String prefix)
        Look up a prefix and get the currently-mapped Namespace URI.

        This method looks up the prefix in the current context. Use the empty string ("") for the default Namespace.

        参数：
        prefix - The prefix to look up.
        返回：
        The associated Namespace URI, or null if the prefix is undeclared in this context.
        另请参见：
        getPrefix(java.lang.String), getPrefixes()

      • getPrefixes

        public Enumeration getPrefixes()
        Return an enumeration of all prefixes whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        Note: if there is a default prefix, it will not be returned in this enumeration; check for the default prefix using the getURI with an argument of "".

        返回：
        An enumeration of prefixes (never empty).
        另请参见：
        getDeclaredPrefixes(), getURI(java.lang.String)

      • getPrefix

        public String getPrefix(String uri)
        Return one of the prefixes mapped to a Namespace URI.

        If more than one prefix is currently mapped to the same URI, this method will make an arbitrary selection; if you want all of the prefixes, use the getPrefixes() method instead.

        Note: this will never return the empty (default) prefix; to check for a default prefix, use the getURI method with an argument of "".

        参数：
        uri - the namespace URI
        返回：
        one of the prefixes currently mapped to the URI supplied, or null if none is mapped or if the URI is assigned to the default namespace
        另请参见：
        getPrefixes(java.lang.String), getURI(java.lang.String)

      • getPrefixes

        public Enumeration getPrefixes(String uri)
        Return an enumeration of all prefixes for a given URI whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        This method returns prefixes mapped to a specific Namespace URI. The xml: prefix will be included. If you want only one prefix that's mapped to the Namespace URI, and you don't care which one you get, use the getPrefix method instead.

        Note: the empty (default) prefix is never included in this enumeration; to check for the presence of a default Namespace, use the getURI method with an argument of "".

        参数：
        uri - The Namespace URI.
        返回：
        An enumeration of prefixes (never empty).
        另请参见：
        getPrefix(java.lang.String),
getDeclaredPrefixes(),
getURI(java.lang.String)

      • getDeclaredPrefixes

        public Enumeration getDeclaredPrefixes()
        Return an enumeration of all prefixes declared in this context.

        The empty (default) prefix will be included in this enumeration; note that this behaviour differs from that of getPrefix(java.lang.String) and getPrefixes().

        返回：
        An enumeration of all prefixes declared in this context.
        另请参见：
        getPrefixes(), getURI(java.lang.String)

      • setNamespaceDeclUris

        public void setNamespaceDeclUris(boolean value)
        Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName(). This may only be changed before any contexts have been pushed.
        抛出：
        IllegalStateException - when attempting to set this after any context has been pushed.
        从以下版本开始：
        SAX 2.1alpha

      • isNamespaceDeclUris

        public boolean isNamespaceDeclUris()
        Returns true if namespace declaration attributes are placed into a namespace. This behavior is not the default.
        从以下版本开始：
        SAX 2.1alpha
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory
l


org.xml.sax.helpers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

请参见： 描述

  • Class Summary
    类 描述
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

软件包 org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个软件包
  • 下一个软件包
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t triij./>


org.xml.sax.helpers Class Hierarchy

  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Hierarchy For Package org.xml.sax.helpers

软件包 Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
    • org.xml.sax.helpers.NamespaceSupport
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • Tree
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rtgmn".xtltebll翟"h=t


ParserAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 ParserAdapter

  • java.lang.Object
    • org.xml.sax.helpers.ParserAdapter
  • 所有已实现的接口：
    DocumentHandler, XMLReader

    public class ParserAdapter
extends Object
implements XMLReader, DocumentHandler
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX1 Parser and makes it act as a SAX2 XMLReader, with feature, property, and Namespace support. Note that it is not possible to report skippedEntity events, since SAX1 does not make that information available.

    This adapter does not test for duplicate Namespace-qualified attribute names.

    从以下版本开始：
    SAX 2.0
    另请参见：
    XMLReaderAdapter, XMLReader, Parser

    • 构造方法摘要

      Constructors
      构造方法与描述
      ParserAdapter()
      Construct a new parser adapter.
      ParserAdapter(Parser parser)
      Construct a new parser adapter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void endDocument()
      Adapter implementation method; do not call.
      void endElement(String qName)
      Adapter implementation method; do not call.
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Check a parser feature flag.
      Object getProperty(String name)
      Get a parser property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document.
      void processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      void setContentHandler(ContentHandler handler)
      Set the content handler.
      void setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      void setDTDHandler(DTDHandler handler)
      Set the DTD handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error handler.
      void setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void setProperty(String name, Object value)
      Set a parser property.
      void startDocument()
      Adapter implementation method; do not call.
      void startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • ParserAdapter

        public ParserAdapter()
              throws SAXException
        Construct a new parser adapter.

        Use the "org.xml.sax.parser" property to locate the embedded SAX1 driver.

        抛出：
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.parser property is not specified.

      • ParserAdapter

        public ParserAdapter(Parser parser)
        Construct a new parser adapter.

        Note that the embedded parser cannot be changed once the adapter is created; to embed a different parser, allocate a new ParserAdapter.

        参数：
        parser - The SAX1 parser to embed.
        抛出：
        NullPointerException - If the parser parameter is null.

    • 方法详细信息

      • setFeature

        public void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set a feature flag for the parser.

        The only features recognized are namespaces and namespace-prefixes.

        指定者：
        setFeature in interface XMLReader
        参数：
        name - The feature name, as a complete URI.
        value - The requested feature value.
        抛出：
        SAXNotRecognizedException - If the feature can't be assigned or retrieved.
        SAXNotSupportedException - If the feature can't be assigned that value.
        另请参见：
        XMLReader.setFeature(java.lang.String, boolean)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Check a parser feature flag.

        The only features recognized are namespaces and namespace-prefixes.

        指定者：
        getFeature in interface XMLReader
        参数：
        name - The feature name, as a complete URI.
        返回：
        The current feature value.
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - If the feature is not currently readable.
        另请参见：
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set a parser property.

        No properties are currently recognized.

        指定者：
        setProperty in interface XMLReader
        参数：
        name - The property name.
        value - The property value.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property can't be assigned that value.
        另请参见：
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Get a parser property.

        No properties are currently recognized.

        指定者：
        getProperty in interface XMLReader
        参数：
        name - The property name.
        返回：
        The property value.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property value is not currently readable.
        另请参见：
        XMLReader.getProperty(java.lang.String)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        指定者：
        setEntityResolver in interface XMLReader
        参数：
        resolver - The new entity resolver.
        另请参见：
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Return the current entity resolver.
        指定者：
        getEntityResolver in interface XMLReader
        返回：
        The current entity resolver, or null if none was supplied.
        另请参见：
        XMLReader.getEntityResolver()

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD handler.
        指定者：
        setDTDHandler in interface XMLReader
        参数：
        handler - the new DTD handler
        另请参见：
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Return the current DTD handler.
        指定者：
        getDTDHandler in interface XMLReader
        返回：
        the current DTD handler, or null if none was supplied
        另请参见：
        XMLReader.getEntityResolver()

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content handler.
        指定者：
        setContentHandler in interface XMLReader
        参数：
        handler - the new content handler
        另请参见：
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getContentHandler

        public ContentHandler getContentHandler()
        Return the current content handler.
        指定者：
        getContentHandler in interface XMLReader
        返回：
        The current content handler, or null if none was supplied.
        另请参见：
        XMLReader.getEntityResolver()

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error handler.
        指定者：
        setErrorHandler in interface XMLReader
        参数：
        handler - The new error handler.
        另请参见：
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Return the current error handler.
        指定者：
        getErrorHandler in interface XMLReader
        返回：
        The current error handler, or null if none was supplied.
        另请参见：
        XMLReader.getEntityResolver()

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse an XML document.
        指定者：
        parse in interface XMLReader
        参数：
        systemId - The absolute URL of the document.
        抛出：
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        另请参见：
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse an XML document.
        指定者：
        parse in interface XMLReader
        参数：
        input - An input source for the document.
        抛出：
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        另请参见：
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Adapter implementation method; do not call. Adapt a SAX1 document locator event.
        指定者：
        setDocumentLocator in interface DocumentHandler
        参数：
        locator - A document locator.
        另请参见：
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 start document event.
        指定者：
        startDocument in interface DocumentHandler
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end document event.
        指定者：
        endDocument in interface DocumentHandler
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String qName,
                AttributeList qAtts)
                  throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 startElement event.

        If necessary, perform Namespace processing.

        指定者：
        startElement in interface DocumentHandler
        参数：
        qName - The qualified (prefixed) name.
        qAtts - The XML attribute list (with qnames).
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.endElement(java.lang.String), AttributeList

      • endElement

        public void endElement(String qName)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end element event.
        指定者：
        endElement in interface DocumentHandler
        参数：
        qName - The qualified (prefixed) name.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 characters event.
        指定者：
        characters in interface DocumentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 ignorable whitespace event.
        指定者：
        ignorableWhitespace in interface DocumentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                         String data)
                           throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 processing instruction event.
        指定者：
        processingInstruction in interface DocumentHandler
        参数：
        target - The processing instruction target.
        data - The remainder of the processing instruction
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


ParserFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.helpers

类 ParserFactory

  • java.lang.Object
    • org.xml.sax.helpers.ParserFactory
  • Deprecated.
    This class works with the deprecated Parser interface.

    public class ParserFactory
extends Object
    Java-specific class for dynamically loading SAX parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: This class is designed to work with the now-deprecated SAX1 Parser class. SAX2 applications should use XMLReaderFactory instead.

    ParserFactory is not part of the platform-independent definition of SAX; it is an additional convenience class designed specifically for Java XML application writers. SAX applications can use the static methods in this class to allocate a SAX parser dynamically at run-time based either on the value of the `org.xml.sax.parser' system property or on a string containing the class name.

    Note that the application still requires an XML parser that implements SAX1.

    从以下版本开始：
    SAX 1.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static Parser makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • makeParser

        public static Parser makeParser()
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                NullPointerException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser using the `org.xml.sax.parser' system property.

        The named class must exist and must implement the Parser interface.

        抛出：
        NullPointerException - There is no value for the `org.xml.sax.parser' system property.
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        另请参见：
        makeParser(java.lang.String), Parser

      • makeParser

        public static Parser makeParser(String className)
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser object using the class name provided.

        The named class must exist and must implement the Parser interface.

        参数：
        className - A string containing the name of the SAX parser class.
        抛出：
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        另请参见：
        makeParser(), Parser
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

>/<= l cl ><< >>>issaal ttrprc yt/.


Uses of Package org.xml.sax.helpers

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Package
org.xml.sax.helpers

  • Packages that use org.xml.sax.helpers
    软件包 描述
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.helpers used by java.beans
    类与描述
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by javax.xml.parsers
    类与描述
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by org.xml.sax.ext
    类与描述
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

dOsk,srsm oanar.杜适傅


XMLFilterImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 XMLFilterImpl

  • java.lang.Object
    • org.xml.sax.helpers.XMLFilterImpl
  • 所有已实现的接口：
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, XMLFilter, XMLReader

    public class XMLFilterImpl
extends Object
implements XMLFilter, EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Base class for deriving an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is designed to sit between an XMLReader and the client application's event handlers. By default, it does nothing but pass requests up to the reader and events on to the handlers unmodified, but subclasses can override specific methods to modify the event stream or the configuration requests as they pass through.

    从以下版本开始：
    SAX 2.0
    另请参见：
    XMLFilter, XMLReader, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLFilterImpl()
      Construct an empty XML filter, with no parent.
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Filter a character data event.
      void endDocument()
      Filter an end document event.
      void endElement(String uri, String localName, String qName)
      Filter an end element event.
      void endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void error(SAXParseException e)
      Filter an error event.
      void fatalError(SAXParseException e)
      Filter a fatal error event.
      ContentHandler getContentHandler()
      Get the content event handler.
      DTDHandler getDTDHandler()
      Get the current DTD event handler.
      EntityResolver getEntityResolver()
      Get the current entity resolver.
      ErrorHandler getErrorHandler()
      Get the current error event handler.
      boolean getFeature(String name)
      Look up the value of a feature.
      XMLReader getParent()
      Get the parent reader.
      Object getProperty(String name)
      Look up the value of a property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void parse(InputSource input)
      Parse a document.
      void parse(String systemId)
      Parse a document.
      void processingInstruction(String target, String data)
      Filter a processing instruction event.
      InputSource resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      void setContentHandler(ContentHandler handler)
      Set the content event handler.
      void setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature.
      void setParent(XMLReader parent)
      Set the parent reader.
      void setProperty(String name, Object value)
      Set the value of a property.
      void skippedEntity(String name)
      Filter a skipped entity event.
      void startDocument()
      Filter a start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void warning(SAXParseException e)
      Filter a warning event.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLFilterImpl

        public XMLFilterImpl()
        Construct an empty XML filter, with no parent.

        This filter will have no parent: you must assign a parent before you start a parse or do any configuration with setFeature or setProperty, unless you use this as a pure event consumer rather than as an XMLReader.

        另请参见：
        XMLReader.setFeature(java.lang.String, boolean),
XMLReader.setProperty(java.lang.String, java.lang.Object),
setParent(org.xml.sax.XMLReader)

      • XMLFilterImpl

        public XMLFilterImpl(XMLReader parent)
        Construct an XML filter with the specified parent.
        另请参见：
        setParent(org.xml.sax.XMLReader), getParent()

    • 方法详细信息

      • setParent

        public void setParent(XMLReader parent)
        Set the parent reader.

        This is the XMLReader from which this filter will obtain its events and to which it will pass its configuration requests. The parent may itself be another filter.

        If there is no parent reader set, any attempt to parse or to set or get a feature or property will fail.

        指定者：
        setParent in interface XMLFilter
        参数：
        parent - The parent XML reader.
        另请参见：
        getParent()

      • getParent

        public XMLReader getParent()
        Get the parent reader.
        指定者：
        getParent in interface XMLFilter
        返回：
        The parent XML reader, or null if none is set.
        另请参见：
        setParent(org.xml.sax.XMLReader)

      • setFeature

        public void setFeature(String name,
              boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature.

        This will always fail if the parent is null.

        指定者：
        setFeature in interface XMLReader
        参数：
        name - The feature name.
        value - The requested feature value.
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot set the requested value.
        另请参见：
        XMLReader.getFeature(java.lang.String)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature.

        This will always fail if the parent is null.

        指定者：
        getFeature in interface XMLReader
        参数：
        name - The feature name.
        返回：
        The current value of the feature.
        抛出：
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot determine its value at this time.
        另请参见：
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
               Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        This will always fail if the parent is null.

        指定者：
        setProperty in interface XMLReader
        参数：
        name - The property name.
        value - The requested property value.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot set the requested value.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.
        指定者：
        getProperty in interface XMLReader
        参数：
        name - The property name.
        返回：
        The current value of the property.
        抛出：
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot determine its value at this time.
        另请参见：
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        指定者：
        setEntityResolver in interface XMLReader
        参数：
        resolver - The new entity resolver.
        另请参见：
        XMLReader.getEntityResolver()

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Get the current entity resolver.
        指定者：
        getEntityResolver in interface XMLReader
        返回：
        The current entity resolver, or null if none was set.
        另请参见：
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD event handler.
        指定者：
        setDTDHandler in interface XMLReader
        参数：
        handler - the new DTD handler
        另请参见：
        XMLReader.getDTDHandler()

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Get the current DTD event handler.
        指定者：
        getDTDHandler in interface XMLReader
        返回：
        The current DTD handler, or null if none was set.
        另请参见：
        XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content event handler.
        指定者：
        setContentHandler in interface XMLReader
        参数：
        handler - the new content handler
        另请参见：
        XMLReader.getContentHandler()

      • getContentHandler

        public ContentHandler getContentHandler()
        Get the content event handler.
        指定者：
        getContentHandler in interface XMLReader
        返回：
        The current content handler, or null if none was set.
        另请参见：
        XMLReader.setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error event handler.
        指定者：
        setErrorHandler in interface XMLReader
        参数：
        handler - the new error handler
        另请参见：
        XMLReader.getErrorHandler()

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Get the current error event handler.
        指定者：
        getErrorHandler in interface XMLReader
        返回：
        The current error handler, or null if none was set.
        另请参见：
        XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(InputSource input)
           throws SAXException,
                  IOException
        Parse a document.
        指定者：
        parse in interface XMLReader
        参数：
        input - The input source for the document entity.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        InputSource,
XMLReader.parse(java.lang.String),
XMLReader.setEntityResolver(org.xml.sax.EntityResolver),
XMLReader.setDTDHandler(org.xml.sax.DTDHandler),
XMLReader.setContentHandler(org.xml.sax.ContentHandler),
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws SAXException,
                  IOException
        Parse a document.
        指定者：
        parse in interface XMLReader
        参数：
        systemId - The system identifier as a fully-qualified URI.
        抛出：
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        另请参见：
        XMLReader.parse(org.xml.sax.InputSource)

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                        String systemId)
                          throws SAXException,
                                 IOException
        Filter an external entity resolution.
        指定者：
        resolveEntity in interface EntityResolver
        参数：
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier.
        返回：
        A new InputSource or null for the default.
        抛出：
        SAXException - The client may throw an exception during processing.
        IOException - The client may throw an I/O-related exception while obtaining the new InputSource.
        另请参见：
        InputSource

      • notationDecl

        public void notationDecl(String name,
                String publicId,
                String systemId)
                  throws SAXException
        Filter a notation declaration event.
        指定者：
        notationDecl in interface DTDHandler
        参数：
        name - The notation name.
        publicId - The notation's public identifier, or null.
        systemId - The notation's system identifier, or null.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                      String publicId,
                      String systemId,
                      String notationName)
                        throws SAXException
        Filter an unparsed entity declaration event.
        指定者：
        unparsedEntityDecl in interface DTDHandler
        参数：
        name - The entity name.
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier, or null.
        notationName - The name of the associated notation.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Filter a new document locator event.
        指定者：
        setDocumentLocator in interface ContentHandler
        参数：
        locator - The document locator.
        另请参见：
        Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Filter a start document event.
        指定者：
        startDocument in interface ContentHandler
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.endDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Filter an end document event.
        指定者：
        endDocument in interface ContentHandler
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.startDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                      String uri)
                        throws SAXException
        Filter a start Namespace prefix mapping event.
        指定者：
        startPrefixMapping in interface ContentHandler
        参数：
        prefix - The Namespace prefix.
        uri - The Namespace URI.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.endPrefixMapping(java.lang.String), ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Filter an end Namespace prefix mapping event.
        指定者：
        endPrefixMapping in interface ContentHandler
        参数：
        prefix - The Namespace prefix.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String), ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        public void startElement(String uri,
                String localName,
                String qName,
                Attributes atts)
                  throws SAXException
        Filter a start element event.
        指定者：
        startElement in interface ContentHandler
        参数：
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        atts - The element's attributes.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        public void endElement(String uri,
              String localName,
              String qName)
                throws SAXException
        Filter an end element event.
        指定者：
        endElement in interface ContentHandler
        参数：
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        抛出：
        SAXException - The client may throw an exception during processing.

      • characters

        public void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Filter a character data event.
        指定者：
        characters in interface ContentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Filter an ignorable whitespace event.
        指定者：
        ignorableWhitespace in interface ContentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        ContentHandler.characters(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                         String data)
                           throws SAXException
        Filter a processing instruction event.
        指定者：
        processingInstruction in interface ContentHandler
        参数：
        target - The processing instruction target.
        data - The text following the target.
        抛出：
        SAXException - The client may throw an exception during processing.

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Filter a skipped entity event.
        指定者：
        skippedEntity in interface ContentHandler
        参数：
        name - The name of the skipped entity.
        抛出：
        SAXException - The client may throw an exception during processing.

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Filter a warning event.
        指定者：
        warning in interface ErrorHandler
        参数：
        e - The warning as an exception.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Filter an error event.
        指定者：
        error in interface ErrorHandler
        参数：
        e - The error as an exception.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Filter a fatal error event.
        指定者：
        fatalError in interface ErrorHandler
        参数：
        e - The error as an exception.
        抛出：
        SAXException - The client may throw an exception during processing.
        另请参见：
        SAXParseException
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法


XMLReaderAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法
org.xml.sax.helpers

类 XMLReaderAdapter

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderAdapter
  • 所有已实现的接口：
    ContentHandler, Parser

    public class XMLReaderAdapter
extends Object
implements Parser, ContentHandler
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX2 XMLReader and makes it act as a SAX1 Parser. The XMLReader must support a true value for the http://xml.org/sax/features/namespace-prefixes property or parsing will fail with a SAXException; if the XMLReader supports a false value for the http://xml.org/sax/features/namespaces property, that will also be used to improve efficiency.

    从以下版本开始：
    SAX 2.0
    另请参见：
    Parser, XMLReader

    • 构造方法摘要

      Constructors
      构造方法与描述
      XMLReaderAdapter()
      Create a new adapter.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      void characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      void endDocument()
      End document event.
      void endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void endPrefixMapping(String prefix)
      Adapt a SAX2 end prefix mapping event.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void parse(InputSource input)
      Parse the document.
      void parse(String systemId)
      Parse the document.
      void processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      void setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
      void setDocumentLocator(Locator locator)
      Set a document locator.
      void setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Register the error event handler.
      void setLocale(Locale locale)
      Set the locale for error reporting.
      void skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void startDocument()
      Start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void startPrefixMapping(String prefix, String uri)
      Adapt a SAX2 start prefix mapping event.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 构造方法详细信息

      • XMLReaderAdapter

        public XMLReaderAdapter()
                 throws SAXException
        Create a new adapter.

        Use the "org.xml.sax.driver" property to locate the SAX2 driver to embed.

        抛出：
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.driver property is not specified.

      • XMLReaderAdapter

        public XMLReaderAdapter(XMLReader xmlReader)
        Create a new adapter.

        Create a new adapter, wrapped around a SAX2 XMLReader. The adapter will make the XMLReader act like a SAX1 Parser.

        参数：
        xmlReader - The SAX2 XMLReader to wrap.
        抛出：
        NullPointerException - If the argument is null.

    • 方法详细信息

      • setLocale

        public void setLocale(Locale locale)
               throws SAXException
        Set the locale for error reporting.

        This is not supported in SAX2, and will always throw an exception.

        指定者：
        setLocale in interface Parser
        参数：
        locale - the locale for error reporting.
        抛出：
        SAXException - Thrown unless overridden.
        另请参见：
        Parser.setLocale(java.util.Locale)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Register the entity resolver.
        指定者：
        setEntityResolver in interface Parser
        参数：
        resolver - The new resolver.
        另请参见：
        Parser.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Register the DTD event handler.
        指定者：
        setDTDHandler in interface Parser
        参数：
        handler - The new DTD event handler.
        另请参见：
        Parser.setDTDHandler(org.xml.sax.DTDHandler)

      • setDocumentHandler

        public void setDocumentHandler(DocumentHandler handler)
        Register the SAX1 document event handler.

        Note that the SAX1 document handler has no Namespace support.

        指定者：
        setDocumentHandler in interface Parser
        参数：
        handler - The new SAX1 document event handler.
        另请参见：
        Parser.setDocumentHandler(org.xml.sax.DocumentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Register the error event handler.
        指定者：
        setErrorHandler in interface Parser
        参数：
        handler - The new error event handler.
        另请参见：
        Parser.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        指定者：
        parse in interface Parser
        参数：
        systemId - The absolute URL of the document.
        抛出：
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        另请参见：
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        指定者：
        parse in interface Parser
        参数：
        input - An input source for the document.
        抛出：
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        另请参见：
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Set a document locator.
        指定者：
        setDocumentLocator in interface ContentHandler
        参数：
        locator - The document locator.
        另请参见：
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Start document event.
        指定者：
        startDocument in interface ContentHandler
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        End document event.
        指定者：
        endDocument in interface ContentHandler
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                      String uri)
        Adapt a SAX2 start prefix mapping event.
        指定者：
        startPrefixMapping in interface ContentHandler
        参数：
        prefix - The prefix being mapped.
        uri - The Namespace URI being mapped to.
        另请参见：
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
        Adapt a SAX2 end prefix mapping event.
        指定者：
        endPrefixMapping in interface ContentHandler
        参数：
        prefix - The prefix being mapped.
        另请参见：
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                String localName,
                String qName,
                Attributes atts)
                  throws SAXException
        Adapt a SAX2 start element event.
        指定者：
        startElement in interface ContentHandler
        参数：
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        atts - The SAX2 attributes.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.endDocument()

      • endElement

        public void endElement(String uri,
              String localName,
              String qName)
                throws SAXException
        Adapt a SAX2 end element event.
        指定者：
        endElement in interface ContentHandler
        参数：
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
              int start,
              int length)
                throws SAXException
        Adapt a SAX2 characters event.
        指定者：
        characters in interface ContentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                       int start,
                       int length)
                         throws SAXException
        Adapt a SAX2 ignorable whitespace event.
        指定者：
        ignorableWhitespace in interface ContentHandler
        参数：
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                         String data)
                           throws SAXException
        Adapt a SAX2 processing instruction event.
        指定者：
        processingInstruction in interface ContentHandler
        参数：
        target - The processing instruction target.
        data - The remainder of the processing instruction
        抛出：
        SAXException - The client may raise a processing exception.
        另请参见：
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Adapt a SAX2 skipped entity event.
        指定者：
        skippedEntity in interface ContentHandler
        参数：
        name - The name of the skipped entity.
        抛出：
        SAXException - Throwable by subclasses.
        另请参见：
        ContentHandler.skippedEntity(java.lang.String)
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • 构造方法 |
  • 方法
  • 详细信息：
  • 字段 |
  • 构造方法 |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.o." rehred>>eddpfbbx.xoassR.ee#rpddec


XMLReaderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法
org.xml.sax.helpers

类 XMLReaderFactory

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderFactory

  • public final class XMLReaderFactory
extends Object
    Factory for creating an XML reader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class contains static methods for creating an XML reader from an explicit class name, or based on runtime defaults:

     try {
   XMLReader myReader = XMLReaderFactory.createXMLReader();
 } catch (SAXException e) {
   System.err.println(e.getMessage());
 }

    Note to Distributions bundled with parsers: You should modify the implementation of the no-arguments createXMLReader to handle cases where the external configuration mechanisms aren't set up. That method should do its best to return a parser when one is in the class path, even when nothing bound its class name to org.xml.sax.driver so those configuration mechanisms would see it.

    从以下版本开始：
    SAX 2.0

    • 方法摘要

      Methods
      修饰符与类型 方法与描述
      static XMLReader createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader createXMLReader(String className)
      Attempt to create an XML reader from a class name.

      • 方法 - 继承于类 java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • 方法详细信息

      • createXMLReader

        public static XMLReader createXMLReader()
                                 throws SAXException
        Attempt to create an XMLReader from system defaults. In environments which can support it, the name of the XMLReader class is determined by trying each these options in order, and using the first one which succeeds:

        • If the system property org.xml.sax.driver has a value, that is used as an XMLReader class name.
        • The JAR "Services API" is used to look for a class name in the META-INF/services/org.xml.sax.driver file in jarfiles available to the runtime.
        • SAX parser distributions are strongly encouraged to provide a default XMLReader class name that will take effect only when previous options (on this list) are not successful.
        • Finally, if ParserFactory.makeParser() can return a system default SAX1 parser, that parser is wrapped in a ParserAdapter. (This is a migration aid for SAX1 environments, where the org.xml.sax.parser system property will often be usable.)

        In environments such as small embedded systems, which can not support that flexibility, other mechanisms to determine the default may be used.

        Note that many Java environments allow system properties to be initialized on a command line. This means that in most cases setting a good value for that property ensures that calls to this method will succeed, except when security policies intervene. This will also maximize application portability to older SAX environments, with less robust implementations of this method.

        返回：
        A new XMLReader.
        抛出：
        SAXException - If no default XMLReader class can be identified and instantiated.
        另请参见：
        createXMLReader(java.lang.String)

      • createXMLReader

        public static XMLReader createXMLReader(String className)
                                 throws SAXException
        Attempt to create an XML reader from a class name.

        Given a class name, this method attempts to load and instantiate the class as an XML reader.

        Note that this method will not be usable in environments where the caller (perhaps an applet) is not permitted to load classes dynamically.

        返回：
        A new XML reader.
        抛出：
        SAXException - If the class cannot be loaded, instantiated, and cast to XMLReader.
        另请参见：
        createXMLReader()
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • 上一个类
  • 下一个类
  • 框架
  • 无框架
  • 所有的类
  • 摘要：
  • 嵌套 |
  • 字段 |
  • Constr |
  • 方法
  • 详细信息：
  • 字段 |
  • Constr |
  • 方法

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

o(nsoccdrt>i


Uses of Class org.xml.sax.helpers.AttributeListImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.AttributeListImpl

No usage of org.xml.sax.helpers.AttributeListImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

/at蝞


Uses of Class org.xml.sax.helpers.AttributesImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.AttributesImpl

  • Packages that use AttributesImpl
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of AttributesImpl in org.xml.sax.ext

      Subclasses of AttributesImpl in org.xml.sax.ext
      修饰符与类型 类与描述
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b=no.>cstlssm lba1r .s


Uses of Class org.xml.sax.helpers.DefaultHandler

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.DefaultHandler

  • Packages that use DefaultHandler
    软件包 描述
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DefaultHandler in java.beans

      Methods in java.beans that return DefaultHandler
      修饰符与类型 方法与描述
      static DefaultHandler XMLDecoder.createHandler(Object owner, ExceptionListener el, ClassLoader cl)
      Creates a new handler for SAX parser that can be used to parse embedded XML archives created by the XMLEncoder class.

    • Uses of DefaultHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type DefaultHandler
      修饰符与类型 方法与描述
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.

    • Uses of DefaultHandler in org.xml.sax.ext

      Subclasses of DefaultHandler in org.xml.sax.ext
      修饰符与类型 类与描述
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

trrs= e-O"=rClt/o>.


Uses of Class org.xml.sax.helpers.LocatorImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.LocatorImpl

  • Packages that use LocatorImpl
    软件包 描述
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LocatorImpl in org.xml.sax.ext

      Subclasses of LocatorImpl in org.xml.sax.ext
      修饰符与类型 类与描述
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.l. cif ssstLccp=vsk=do


Uses of Class org.xml.sax.helpers.NamespaceSupport

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.NamespaceSupport

No usage of org.xml.sax.helpers.NamespaceSupport
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

m ma./pfe=== >父et <�


Uses of Class org.xml.sax.helpers.ParserAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.ParserAdapter

No usage of org.xml.sax.helpers.ParserAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nn/>slpla>y/


Uses of Class org.xml.sax.helpers.ParserFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.ParserFactory

No usage of org.xml.sax.helpers.ParserFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

n|呐 a<|廃@>B/�/o


Uses of Class org.xml.sax.helpers.XMLFilterImpl

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.XMLFilterImpl

No usage of org.xml.sax.helpers.XMLFilterImpl
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

nL�laB@t/o


Uses of Class org.xml.sax.helpers.XMLReaderAdapter

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.XMLReaderAdapter

No usage of org.xml.sax.helpers.XMLReaderAdapter
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

moiaspemIa格mbt�


Uses of Class org.xml.sax.helpers.XMLReaderFactory

Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

Uses of Class
org.xml.sax.helpers.XMLReaderFactory

No usage of org.xml.sax.helpers.XMLReaderFactory
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • 索引
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev
  • 下一个
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

t�p罃soY処格膍�


_-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_ADD_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The int constant for the enum value ADD_OVERRIDE.
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.BindingIteratorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.NamingContextExtPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.NamingContextPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.Servant
Used by the ORB to obtain complete type information from the servant.
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.ServantActivatorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.ServantLocatorPOA
_BindingIteratorImplBase - Class in org.omg.CosNaming
_BindingIteratorImplBase() - Constructor for class org.omg.CosNaming._BindingIteratorImplBase
_BindingIteratorStub - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
_BindingIteratorStub() - Constructor for class org.omg.CosNaming._BindingIteratorStub
_COMPLETED_MAYBE - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_COMPLETED_NO - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_COMPLETED_YES - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_create_request(Context, String, NVList, NamedValue) - Method in interface org.omg.CORBA.Object
Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in interface org.omg.CORBA.Object
Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object that contains the given context, method, argument list, and container for the result.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
_default_POA() - Method in class org.omg.PortableServer.Servant
Returns the root POA from the ORB instance associated with the servant.
_DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_dk_AbstractInterface - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Alias - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_all - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Array - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Attribute - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Constant - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Enum - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Exception - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Fixed - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Interface - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Module - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Native - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_none - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Operation - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Primitive - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Repository - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Sequence - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_String - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Struct - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Typedef - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Union - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Value - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_ValueBox - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_ValueMember - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Wstring - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_duplicate() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_duplicate() - Method in interface org.omg.CORBA.Object
Returns a duplicate of this CORBA object reference.
_duplicate() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a duplicate of this ObjectImpl object.
_DynAnyFactoryStub - Class in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
_DynAnyFactoryStub() - Constructor for class org.omg.DynamicAny._DynAnyFactoryStub
_DynAnyStub - Class in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
_DynAnyStub() - Constructor for class org.omg.DynamicAny._DynAnyStub
_DynArrayStub - Class in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
_DynArrayStub() - Constructor for class org.omg.DynamicAny._DynArrayStub
_DynEnumStub - Class in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
_DynEnumStub() - Constructor for class org.omg.DynamicAny._DynEnumStub
_DynFixedStub - Class in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
_DynFixedStub() - Constructor for class org.omg.DynamicAny._DynFixedStub
_DynSequenceStub - Class in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
_DynSequenceStub() - Constructor for class org.omg.DynamicAny._DynSequenceStub
_DynStructStub - Class in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
_DynStructStub() - Constructor for class org.omg.DynamicAny._DynStructStub
_DynUnionStub - Class in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
_DynUnionStub() - Constructor for class org.omg.DynamicAny._DynUnionStub
_DynValueStub - Class in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
_DynValueStub() - Constructor for class org.omg.DynamicAny._DynValueStub
_get_codebase() - Method in class org.omg.CORBA_2_3.portable.ObjectImpl
Returns the codebase for this object reference.
_get_delegate() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
_get_delegate() - Method in class org.omg.PortableServer.Servant
Gets the ORB vendor-specific implementation of PortableServer::Servant.
_get_domain_managers() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_domain_managers() - Method in interface org.omg.CORBA.Object
Retrieves the DomainManagers of this object.
_get_domain_managers() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves a list of the domain managers for this ObjectImpl object.
_get_interface() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_interface_def() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_get_interface_def() - Method in interface org.omg.CORBA.Object
Obtains an InterfaceDef for the object implementation referenced by this object reference.
_get_interface_def() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the interface definition for this ObjectImpl object.
_get_interface_def() - Method in class org.omg.PortableServer.Servant
Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
_get_policy(int) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_policy(int) - Method in interface org.omg.CORBA.Object
Returns the Policy object of the specified type which applies to this object.
_get_policy(int) - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the Policy object for this ObjectImpl object that has the given policy type.
_hash(int) - Method in class org.omg.CORBA.LocalObject
Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum.
_hash(int) - Method in interface org.omg.CORBA.Object
Returns an ORB-internal identifier for this object reference.
_hash(int) - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
_HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_IDLTypeStub - Class in org.omg.CORBA
The Stub for IDLType.
_IDLTypeStub() - Constructor for class org.omg.CORBA._IDLTypeStub
Constructs a default _IDLTypeStub object.
_IDLTypeStub(Delegate) - Constructor for class org.omg.CORBA._IDLTypeStub
Constructs an _IDLTypeStub object initialized with the given Delegate object.
_ids() - Method in class org.omg.CORBA._IDLTypeStub
_ids() - Method in class org.omg.CORBA._PolicyStub
_ids() - Method in class org.omg.CORBA.DynamicImplementation
Deprecated.
_ids() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
_ids() - Method in class org.omg.CosNaming._BindingIteratorImplBase
_ids() - Method in class org.omg.CosNaming._BindingIteratorStub
_ids() - Method in class org.omg.CosNaming._NamingContextExtStub
_ids() - Method in class org.omg.CosNaming._NamingContextImplBase
_ids() - Method in class org.omg.CosNaming._NamingContextStub
_ids() - Method in class org.omg.DynamicAny._DynAnyFactoryStub
_ids() - Method in class org.omg.DynamicAny._DynAnyStub
_ids() - Method in class org.omg.DynamicAny._DynArrayStub
_ids() - Method in class org.omg.DynamicAny._DynEnumStub
_ids() - Method in class org.omg.DynamicAny._DynFixedStub
_ids() - Method in class org.omg.DynamicAny._DynSequenceStub
_ids() - Method in class org.omg.DynamicAny._DynStructStub
_ids() - Method in class org.omg.DynamicAny._DynUnionStub
_ids() - Method in class org.omg.DynamicAny._DynValueStub
_ids() - Method in class org.omg.PortableServer._ServantActivatorStub
_ids() - Method in class org.omg.PortableServer._ServantLocatorStub
_ids() - Method in class org.omg.stub.java.rmi._Remote_Stub
Returns an array of repository ids that an object implements.
_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
_INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_invoke(OutputStream) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_invoke(String, InputStream, ResponseHandler) - Method in interface org.omg.CORBA.portable.InvokeHandler
Invoked by the ORB to dispatch a request to the servant.
_invoke(OutputStream) - Method in class org.omg.CORBA.portable.ObjectImpl
Invokes an operation and returns an InputStream object for reading the response.
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.BindingIteratorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.NamingContextExtPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.NamingContextPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer.ServantActivatorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer.ServantLocatorPOA
_is_a(String) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_is_a(String) - Method in interface org.omg.CORBA.Object
Checks whether this object is an instance of a class that implements the given interface.
_is_a(String) - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the object identified by the given repository identifier is an ObjectImpl object.
_is_a(String) - Method in class org.omg.PortableServer.Servant
Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
_is_equivalent(Object) - Method in class org.omg.CORBA.LocalObject
Determines whether the two object references are equivalent, so far as the ORB can easily determine.
_is_equivalent(Object) - Method in interface org.omg.CORBA.Object
Determines whether the two object references are equivalent, so far as the ORB can easily determine.
_is_equivalent(Object) - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
_is_local() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_is_local() - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether this ObjectImpl object is implemented by a local servant.
_missing_node - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_MULTIPLE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
_NamingContextExtStub - Class in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
_NamingContextExtStub() - Constructor for class org.omg.CosNaming._NamingContextExtStub
_NamingContextImplBase - Class in org.omg.CosNaming
_NamingContextImplBase() - Constructor for class org.omg.CosNaming._NamingContextImplBase
_NamingContextStub - Class in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
_NamingContextStub() - Constructor for class org.omg.CosNaming._NamingContextStub
_ncontext - Static variable in class org.omg.CosNaming.BindingType
_NO_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
_nobject - Static variable in class org.omg.CosNaming.BindingType
_non_existent() - Method in class org.omg.CORBA.LocalObject
Always returns false.
_non_existent() - Method in interface org.omg.CORBA.Object
Determines whether the server object for this object reference has been destroyed.
_non_existent() - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the server object for this ObjectImpl object has been destroyed.
_non_existent() - Method in class org.omg.PortableServer.Servant
Checks for the existence of an Object.
_NON_RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
_not_context - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_not_object - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_object_id() - Method in class org.omg.PortableServer.Servant
Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
_opsClass - Static variable in class org.omg.DynamicAny._DynAnyFactoryStub
_opsClass - Static variable in class org.omg.DynamicAny._DynAnyStub
_opsClass - Static variable in class org.omg.DynamicAny._DynArrayStub
_opsClass - Static variable in class org.omg.DynamicAny._DynEnumStub
_opsClass - Static variable in class org.omg.DynamicAny._DynFixedStub
_opsClass - Static variable in class org.omg.DynamicAny._DynSequenceStub
_opsClass - Static variable in class org.omg.DynamicAny._DynStructStub
_opsClass - Static variable in class org.omg.DynamicAny._DynUnionStub
_opsClass - Static variable in class org.omg.DynamicAny._DynValueStub
_opsClass - Static variable in class org.omg.PortableServer._ServantActivatorStub
_opsClass - Static variable in class org.omg.PortableServer._ServantLocatorStub
_orb() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_orb() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a reference to the ORB associated with this object and its delegate.
_orb() - Method in class org.omg.PortableServer.Servant
Returns the instance of the ORB currently associated with the Servant (convenience method).
_ORB_CTRL_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue
_PARAM_IN - Static variable in class org.omg.CORBA.ParameterMode
_PARAM_INOUT - Static variable in class org.omg.CORBA.ParameterMode
_PARAM_OUT - Static variable in class org.omg.CORBA.ParameterMode
_PERSISTENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
_poa() - Method in class org.omg.PortableServer.Servant
Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
_PolicyStub - Class in org.omg.CORBA
The Stub for Policy.
_PolicyStub() - Constructor for class org.omg.CORBA._PolicyStub
Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.
_PolicyStub(Delegate) - Constructor for class org.omg.CORBA._PolicyStub
Constructs a _PolicyStub object initialized with the given Delegate object.
_postEdit(UndoableEdit) - Method in class javax.swing.undo.UndoableEditSupport
Called only from postEdit and endUpdate.
_read(InputStream) - Method in class org.omg.CORBA.AnyHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.AnySeqHolder
_read(InputStream) - Method in class org.omg.CORBA.BooleanHolder
Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
_read(InputStream) - Method in class org.omg.CORBA.BooleanSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ByteHolder
Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.CharHolder
Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.CharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.CurrentHolder
_read(InputStream) - Method in class org.omg.CORBA.DoubleHolder
Read a double value from the input stream and store it in the value member.
_read(InputStream) - Method in class org.omg.CORBA.DoubleSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.FixedHolder
Read a fixed point value from the input stream and store it in the value member.
_read(InputStream) - Method in class org.omg.CORBA.FloatHolder
Read a float from an input stream and initialize the value member with the float value.
_read(InputStream) - Method in class org.omg.CORBA.FloatSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.IntHolder
Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
_read(InputStream) - Method in class org.omg.CORBA.LongHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.LongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.LongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ObjectHolder
Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.OctetSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ParameterModeHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyErrorHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyListHolder
_read(InputStream) - Method in interface org.omg.CORBA.portable.Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_read(InputStream) - Method in class org.omg.CORBA.ServiceInformationHolder
Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
_read(InputStream) - Method in class org.omg.CORBA.ShortHolder
Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.ShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.StringHolder
Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
_read(InputStream) - Method in class org.omg.CORBA.StringSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.TypeCodeHolder
Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.ULongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ULongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_read(InputStream) - Method in class org.omg.CORBA.UShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ValueBaseHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.WCharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.WrongTransactionHolder
_read(InputStream) - Method in class org.omg.CORBA.WStringSeqHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingIteratorHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingListHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingTypeHolder
_read(InputStream) - Method in class org.omg.CosNaming.NameComponentHolder
_read(InputStream) - Method in class org.omg.CosNaming.NameHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextExtHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_read(InputStream) - Method in class org.omg.IOP.IORHolder
_read(InputStream) - Method in class org.omg.IOP.MultipleComponentProfileHolder
_read(InputStream) - Method in class org.omg.IOP.ServiceContextHolder
_read(InputStream) - Method in class org.omg.IOP.ServiceContextListHolder
_read(InputStream) - Method in class org.omg.IOP.TaggedComponentHolder
_read(InputStream) - Method in class org.omg.IOP.TaggedProfileHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_read(InputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
_release() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_release() - Method in interface org.omg.CORBA.Object
Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released.
_release() - Method in class org.omg.CORBA.portable.ObjectImpl
Releases the resources associated with this ObjectImpl object.
_releaseReply(InputStream) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_releaseReply(InputStream) - Method in class org.omg.CORBA.portable.ObjectImpl
Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
_Remote_Stub - Class in org.omg.stub.java.rmi
This class provides the Stub for the Remote Type.
_Remote_Stub() - Constructor for class org.omg.stub.java.rmi._Remote_Stub
_request(String) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_request(String, boolean) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_request(String) - Method in interface org.omg.CORBA.Object
Creates a Request instance for use in the Dynamic Invocation Interface.
_request(String) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
_request(String, boolean) - Method in class org.omg.CORBA.portable.ObjectImpl
Returns an OutputStream object to use for marshalling the arguments of the given method.
_RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA.portable.ObjectImpl
Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a Java reference to the local servant that should be used for sending a request for the method specified.
_ServantActivatorStub - Class in org.omg.PortableServer
When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
_ServantActivatorStub() - Constructor for class org.omg.PortableServer._ServantActivatorStub
_ServantLocatorStub - Class in org.omg.PortableServer
When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
_ServantLocatorStub() - Constructor for class org.omg.PortableServer._ServantLocatorStub
_set_delegate(Delegate) - Method in class org.omg.CORBA.portable.ObjectImpl
Sets the Delegate for this ObjectImpl instance to the given Delegate object.
_set_delegate(Delegate) - Method in class org.omg.PortableServer.Servant
Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
_SET_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The int constant for the enum value SET_OVERRIDE.
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_set_policy_override(Policy[], SetOverrideType) - Method in interface org.omg.CORBA.Object
Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA.portable.ObjectImpl
Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
_SINGLE_THREAD_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue
_SYSTEM_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue
_this() - Method in class org.omg.CosNaming.BindingIteratorPOA
_this(ORB) - Method in class org.omg.CosNaming.BindingIteratorPOA
_this() - Method in class org.omg.CosNaming.NamingContextExtPOA
_this(ORB) - Method in class org.omg.CosNaming.NamingContextExtPOA
_this() - Method in class org.omg.CosNaming.NamingContextPOA
_this(ORB) - Method in class org.omg.CosNaming.NamingContextPOA
_this() - Method in class org.omg.PortableServer.ServantActivatorPOA
_this(ORB) - Method in class org.omg.PortableServer.ServantActivatorPOA
_this() - Method in class org.omg.PortableServer.ServantLocatorPOA
_this(ORB) - Method in class org.omg.PortableServer.ServantLocatorPOA
_this_object() - Method in class org.omg.PortableServer.Servant
Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
_this_object(ORB) - Method in class org.omg.PortableServer.Servant
Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
_tk_abstract_interface - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type abstract interface.
_tk_alias - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type alias.
_tk_any - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type any.
_tk_array - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type array.
_tk_boolean - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type boolean.
_tk_char - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type char.
_tk_double - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type double.
_tk_enum - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type enum.
_tk_except - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type except.
_tk_fixed - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type fixed.
_tk_float - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type float.
_tk_long - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type long.
_tk_longdouble - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type longdouble.
_tk_longlong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type longlong.
_tk_native - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type native.
_tk_null - Static variable in class org.omg.CORBA.TCKind
The int constant for a null IDL data type.
_tk_objref - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type objref.
_tk_octet - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type octet.
_tk_Principal - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type Principal.
_tk_sequence - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type sequence.
_tk_short - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type short.
_tk_string - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type string.
_tk_struct - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type struct.
_tk_TypeCode - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type TypeCode.
_tk_ulong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ulong.
_tk_ulonglong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ulonglong.
_tk_union - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type union.
_tk_ushort - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ushort.
_tk_value - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type value.
_tk_value_box - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type value_box.
_tk_void - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type void.
_tk_wchar - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type wchar.
_tk_wstring - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type wstring.
_TRANSIENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
_truncatable_ids() - Method in interface org.omg.CORBA.portable.ValueBase
Provides truncatable repository ids.
_type() - Method in class org.omg.CORBA.AnyHolder
Returns the TypeCode object corresponding to the value held in this AnyHolder object.
_type() - Method in class org.omg.CORBA.AnySeqHolder
_type() - Method in class org.omg.CORBA.BooleanHolder
Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
_type() - Method in class org.omg.CORBA.BooleanSeqHolder
_type() - Method in class org.omg.CORBA.ByteHolder
Returns the TypeCode corresponding to the value held in this ByteHolder object.
_type() - Method in class org.omg.CORBA.CharHolder
Returns the TypeCode object corresponding to the value held in this CharHolder object.
_type() - Method in class org.omg.CORBA.CharSeqHolder
_type() - Method in class org.omg.CORBA.CurrentHolder
_type() - Method in class org.omg.CORBA.DoubleHolder
Return the TypeCode of this holder object.
_type() - Method in class org.omg.CORBA.DoubleSeqHolder
_type() - Method in class org.omg.CORBA.FixedHolder
Return the TypeCode of this holder object.
_type() - Method in class org.omg.CORBA.FloatHolder
Return the TypeCode of this Streamable.
_type() - Method in class org.omg.CORBA.FloatSeqHolder
_type() - Method in class org.omg.CORBA.IntHolder
Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
_type() - Method in class org.omg.CORBA.LongHolder
Returns the TypeCode object corresponding to the value held in the Holder.
_type() - Method in class org.omg.CORBA.LongLongSeqHolder
_type() - Method in class org.omg.CORBA.LongSeqHolder
_type() - Method in class org.omg.CORBA.ObjectHolder
Returns the TypeCode corresponding to the value held in this ObjectHolder object
_type() - Method in class org.omg.CORBA.OctetSeqHolder
_type() - Method in class org.omg.CORBA.ParameterModeHolder
_type() - Method in class org.omg.CORBA.PolicyErrorHolder
_type() - Method in class org.omg.CORBA.PolicyHolder
_type() - Method in class org.omg.CORBA.PolicyListHolder
_type() - Method in interface org.omg.CORBA.portable.Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
_type() - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_type() - Method in class org.omg.CORBA.ServiceInformationHolder
Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
_type() - Method in class org.omg.CORBA.ShortHolder
Returns the TypeCode corresponding to the value held in this ShortHolder object.
_type() - Method in class org.omg.CORBA.ShortSeqHolder
_type() - Method in class org.omg.CORBA.StringHolder
Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
_type() - Method in class org.omg.CORBA.StringSeqHolder
_type() - Method in class org.omg.CORBA.TypeCodeHolder
Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
_type() - Method in class org.omg.CORBA.ULongLongSeqHolder
_type() - Method in class org.omg.CORBA.ULongSeqHolder
_type() - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_type() - Method in class org.omg.CORBA.UShortSeqHolder
_type() - Method in class org.omg.CORBA.ValueBaseHolder
Returns the TypeCode object corresponding to the value held in the Holder.
_type() - Method in class org.omg.CORBA.WCharSeqHolder
_type() - Method in class org.omg.CORBA.WrongTransactionHolder
_type() - Method in class org.omg.CORBA.WStringSeqHolder
_type() - Method in class org.omg.CosNaming.BindingHolder
_type() - Method in class org.omg.CosNaming.BindingIteratorHolder
_type() - Method in class org.omg.CosNaming.BindingListHolder
_type() - Method in class org.omg.CosNaming.BindingTypeHolder
_type() - Method in class org.omg.CosNaming.NameComponentHolder
_type() - Method in class org.omg.CosNaming.NameHolder
_type() - Method in class org.omg.CosNaming.NamingContextExtHolder
_type() - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_type() - Method in class org.omg.CosNaming.NamingContextHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_type() - Method in class org.omg.IOP.IORHolder
_type() - Method in class org.omg.IOP.MultipleComponentProfileHolder
_type() - Method in class org.omg.IOP.ServiceContextHolder
_type() - Method in class org.omg.IOP.ServiceContextListHolder
_type() - Method in class org.omg.IOP.TaggedComponentHolder
_type() - Method in class org.omg.IOP.TaggedProfileHolder
_type() - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_type() - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
_UNIQUE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
_USE_ACTIVE_OBJECT_MAP_ONLY - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USE_DEFAULT_SERVANT - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USE_SERVANT_MANAGER - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USER_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue
_write(OutputStream) - Method in class org.omg.CORBA.AnyHolder
Marshals to output the value in this AnyHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.AnySeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.BooleanHolder
Marshals the value in this BooleanHolder object's value field to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.BooleanSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ByteHolder
Marshals to output the value in this ByteHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.CharHolder
Marshals to output the value in this CharHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.CharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.CurrentHolder
_write(OutputStream) - Method in class org.omg.CORBA.DoubleHolder
Write the double value stored in this holder to an OutputStream.
_write(OutputStream) - Method in class org.omg.CORBA.DoubleSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.FixedHolder
Write the fixed point value stored in this holder to an OutputStream.
_write(OutputStream) - Method in class org.omg.CORBA.FloatHolder
Write the float value into an output stream.
_write(OutputStream) - Method in class org.omg.CORBA.FloatSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.IntHolder
Marshals the value in this IntHolder object's value field to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.LongHolder
Marshals to output the value in the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.LongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.LongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ObjectHolder
Marshals to output the value in this ObjectHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.OctetSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ParameterModeHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyErrorHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyListHolder
_write(OutputStream) - Method in interface org.omg.CORBA.portable.Streamable
Marshals to ostream the value in the value field of the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_write(OutputStream) - Method in class org.omg.CORBA.ServiceInformationHolder
Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
_write(OutputStream) - Method in class org.omg.CORBA.ShortHolder
Marshals to output the value in this ShortHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.ShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.StringHolder
Marshals the value held by this StringHolder object to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.StringSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.TypeCodeHolder
Marshals to output the value in this TypeCodeHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.ULongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ULongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_write(OutputStream) - Method in class org.omg.CORBA.UShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ValueBaseHolder
Marshals to output the value in the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.WCharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.WrongTransactionHolder
_write(OutputStream) - Method in class org.omg.CORBA.WStringSeqHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingIteratorHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingListHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingTypeHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NameComponentHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NameHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextExtHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_write(OutputStream) - Method in class org.omg.IOP.IORHolder
_write(OutputStream) - Method in class org.omg.IOP.MultipleComponentProfileHolder
_write(OutputStream) - Method in class org.omg.IOP.ServiceContextHolder
_write(OutputStream) - Method in class org.omg.IOP.ServiceContextListHolder
_write(OutputStream) - Method in class org.omg.IOP.TaggedComponentHolder
_write(OutputStream) - Method in class org.omg.IOP.TaggedProfileHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_write(OutputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类


A-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

a - Variable in class java.awt.AWTEventMulticaster
A - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering A, 8 1/2 x 11 in.
A - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering A size, 8.5 inch by 11 inch.
A - Static variable in class javax.print.attribute.standard.MediaSizeName
A size .
A - Static variable in class javax.swing.text.html.HTML.Tag
A0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A0.
A0 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A0 size, 841 mm by 1189 mm.
A1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A1.
A1 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A1 size, 594 mm by 841 mm.
A10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A10.
A10 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A10 size, 26 mm by 37 mm.
A2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A2.
A2 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A2 size, 420 mm by 594 mm.
A3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A3.
A3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A3 size, 297 mm by 420 mm.
A4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A4.
A4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A4 size, 210 mm by 297 mm.
A5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A5.
A5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A5 size, 148 mm by 210 mm.
A6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A6.
A6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A6 size, 105 mm by 148 mm.
A7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A7.
A7 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A7 size, 74 mm by 105 mm.
A8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A8.
A8 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A8 size, 52 mm by 74 mm.
A9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A9.
A9 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A9 size, 37 mm by 52 mm.
ABORT - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that an image which was being tracked asynchronously was aborted before production was complete.
abort() - Method in class java.net.CacheRequest
Aborts the attempt to cache the response.
abort(Executor) - Method in interface java.sql.Connection
Terminates an open connection.
abort() - Method in class javax.imageio.ImageReader
Requests that any current read operation be aborted.
abort() - Method in class javax.imageio.ImageWriter
Requests that any current write operation be aborted.
abort() - Method in interface javax.security.auth.spi.LoginModule
Method to abort the authentication process (phase 2).
abort() - Method in interface org.w3c.dom.ls.LSParser
Abort the loading of the document that is currently being loaded by the LSParser.
ABORTED - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media was aborted.
ABORTED - Static variable in class javax.print.attribute.standard.JobState
The job has been aborted by the system (usually while the job was in the PROCESSING or PROCESSING_STOPPED state), the printer has completed aborting the job, and all job status attributes have reached their final values for the job.
ABORTED_BY_SYSTEM - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system.
abortGrabbing() - Method in class java.awt.image.PixelGrabber
Request the PixelGrabber to abort the image fetch.
abortRequested() - Method in class javax.imageio.ImageReader
Returns true if a request to abort the current read operation has been made since the reader was instantiated or clearAbortRequest was called.
abortRequested() - Method in class javax.imageio.ImageWriter
Returns true if a request to abort the current write operation has been made since the writer was instantiated or clearAbortRequest was called.
ABOUT_UIROLE - Static variable in class javax.print.ServiceUIFactory
Denotes a UI which performs an informative "About" role.
ABOVE_BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title above the border's bottom line.
ABOVE_TOP - Static variable in class javax.swing.border.TitledBorder
Position the title above the border's top line.
abs(int) - Static method in class java.lang.Math
Returns the absolute value of an int value.
abs(long) - Static method in class java.lang.Math
Returns the absolute value of a long value.
abs(float) - Static method in class java.lang.Math
Returns the absolute value of a float value.
abs(double) - Static method in class java.lang.Math
Returns the absolute value of a double value.
abs(int) - Static method in class java.lang.StrictMath
Returns the absolute value of an int value..
abs(long) - Static method in class java.lang.StrictMath
Returns the absolute value of a long value.
abs(float) - Static method in class java.lang.StrictMath
Returns the absolute value of a float value.
abs(double) - Static method in class java.lang.StrictMath
Returns the absolute value of a double value.
abs() - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the absolute value of this BigDecimal, and whose scale is this.scale().
abs(MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the absolute value of this BigDecimal, with rounding according to the context settings.
abs() - Method in class java.math.BigInteger
Returns a BigInteger whose value is the absolute value of this BigInteger.
absolute(int) - Method in interface java.sql.ResultSet
Moves the cursor to the given row number in this ResultSet object.
absolutePath() - Method in class java.util.prefs.AbstractPreferences
Implements the absolutePath method as per the specification in Preferences.absolutePath().
absolutePath() - Method in class java.util.prefs.Preferences
Returns this preference node's absolute path name.
ABSTRACT - Static variable in class java.lang.reflect.修饰符
The int value representing the abstract modifier.
AbstractAction - Class in javax.swing
This class provides default implementations for the JFC Action interface.
AbstractAction() - Constructor for class javax.swing.AbstractAction
Creates an Action.
AbstractAction(String) - Constructor for class javax.swing.AbstractAction
Creates an Action with the specified name.
AbstractAction(String, Icon) - Constructor for class javax.swing.AbstractAction
Creates an Action with the specified name and small icon.
AbstractAnnotationValueVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor for annotation values with default behavior appropriate for the RELEASE_6 source version.
AbstractAnnotationValueVisitor6() - Constructor for class javax.lang.model.util.AbstractAnnotationValueVisitor6
Constructor for concrete subclasses to call.
AbstractAnnotationValueVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor for annotation values with default behavior appropriate for the RELEASE_7 source version.
AbstractAnnotationValueVisitor7() - Constructor for class javax.lang.model.util.AbstractAnnotationValueVisitor7
Constructor for concrete subclasses to call.
AbstractBorder - Class in javax.swing.border
A class that implements an empty border with no size.
AbstractBorder() - Constructor for class javax.swing.border.AbstractBorder
AbstractButton - Class in javax.swing
Defines common behaviors for buttons and menu items.
AbstractButton() - Constructor for class javax.swing.AbstractButton
AbstractButton.AccessibleAbstractButton - Class in javax.swing
This class implements accessibility support for the AbstractButton class.
AbstractButton.AccessibleAbstractButton() - Constructor for class javax.swing.AbstractButton.AccessibleAbstractButton
AbstractButton.ButtonChangeListener - Class in javax.swing
Extends ChangeListener to be serializable.
AbstractCellEditor - Class in javax.swing
A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue().
AbstractCellEditor() - Constructor for class javax.swing.AbstractCellEditor
AbstractCollection<E> - Class in java.util
This class provides a skeletal implementation of the Collection interface, to minimize the effort required to implement this interface.
AbstractCollection() - Constructor for class java.util.AbstractCollection
Sole constructor.
AbstractColorChooserPanel - Class in javax.swing.colorchooser
This is the abstract superclass for color choosers.
AbstractColorChooserPanel() - Constructor for class javax.swing.colorchooser.AbstractColorChooserPanel
AbstractDocument - Class in javax.swing.text
An implementation of the document interface to serve as a basis for implementing various kinds of documents.
AbstractDocument(AbstractDocument.Content) - Constructor for class javax.swing.text.AbstractDocument
Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext) - Constructor for class javax.swing.text.AbstractDocument
Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
AbstractDocument.AbstractElement - Class in javax.swing.text
Implements the abstract part of an element.
AbstractDocument.AbstractElement(Element, AttributeSet) - Constructor for class javax.swing.text.AbstractDocument.AbstractElement
Creates a new AbstractElement.
AbstractDocument.AttributeContext - Interface in javax.swing.text
An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
AbstractDocument.BranchElement - Class in javax.swing.text
Implements a composite element that contains other elements.
AbstractDocument.BranchElement(Element, AttributeSet) - Constructor for class javax.swing.text.AbstractDocument.BranchElement
Constructs a composite element that initially contains no children.
AbstractDocument.Content - Interface in javax.swing.text
Interface to describe a sequence of character content that can be edited.
AbstractDocument.DefaultDocumentEvent - Class in javax.swing.text
Stores document changes as the document is being modified.
AbstractDocument.DefaultDocumentEvent(int, int, DocumentEvent.EventType) - Constructor for class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Constructs a change record.
AbstractDocument.ElementEdit - Class in javax.swing.text
An implementation of ElementChange that can be added to the document event.
AbstractDocument.ElementEdit(Element, int, Element[], Element[]) - Constructor for class javax.swing.text.AbstractDocument.ElementEdit
Constructs an edit record.
AbstractDocument.LeafElement - Class in javax.swing.text
Implements an element that directly represents content of some kind.
AbstractDocument.LeafElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text.AbstractDocument.LeafElement
Constructs an element that represents content within the document (has no children).
AbstractElementVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor of program elements with default behavior appropriate for the RELEASE_6 source version.
AbstractElementVisitor6() - Constructor for class javax.lang.model.util.AbstractElementVisitor6
Constructor for concrete subclasses to call.
AbstractElementVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor of program elements with default behavior appropriate for the RELEASE_7 source version.
AbstractElementVisitor7() - Constructor for class javax.lang.model.util.AbstractElementVisitor7
Constructor for concrete subclasses to call.
AbstractExecutorService - Class in java.util.concurrent
Provides default implementations of ExecutorService execution methods.
AbstractExecutorService() - Constructor for class java.util.concurrent.AbstractExecutorService
AbstractInterruptibleChannel - Class in java.nio.channels.spi
Base implementation class for interruptible channels.
AbstractInterruptibleChannel() - Constructor for class java.nio.channels.spi.AbstractInterruptibleChannel
Initializes a new instance of this class.
AbstractLayoutCache - Class in javax.swing.tree
警告： Serialized objects of this class will not be compatible with future Swing releases.
AbstractLayoutCache() - Constructor for class javax.swing.tree.AbstractLayoutCache
AbstractLayoutCache.NodeDimensions - Class in javax.swing.tree
Used by AbstractLayoutCache to determine the size and x origin of a particular node.
AbstractLayoutCache.NodeDimensions() - Constructor for class javax.swing.tree.AbstractLayoutCache.NodeDimensions
AbstractList<E> - Class in java.util
This class provides a skeletal implementation of the List interface to minimize the effort required to implement this interface backed by a "random access" data store (such as an array).
AbstractList() - Constructor for class java.util.AbstractList
Sole constructor.
AbstractListModel<E> - Class in javax.swing
The abstract definition for the data model that provides a List with its contents.
AbstractListModel() - Constructor for class javax.swing.AbstractListModel
AbstractMap<K,V> - Class in java.util
This class provides a skeletal implementation of the Map interface, to minimize the effort required to implement this interface.
AbstractMap() - Constructor for class java.util.AbstractMap
Sole constructor.
AbstractMap.SimpleEntry<K,V> - Class in java.util
An Entry maintaining a key and a value.
AbstractMap.SimpleEntry(K, V) - Constructor for class java.util.AbstractMap.SimpleEntry
Creates an entry representing a mapping from the specified key to the specified value.
AbstractMap.SimpleEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util.AbstractMap.SimpleEntry
Creates an entry representing the same mapping as the specified entry.
AbstractMap.SimpleImmutableEntry<K,V> - Class in java.util
An Entry maintaining an immutable key and value.
AbstractMap.SimpleImmutableEntry(K, V) - Constructor for class java.util.AbstractMap.SimpleImmutableEntry
Creates an entry representing a mapping from the specified key to the specified value.
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util.AbstractMap.SimpleImmutableEntry
Creates an entry representing the same mapping as the specified entry.
AbstractMarshallerImpl - Class in javax.xml.bind.helpers
Partial default Marshaller implementation.
AbstractMarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractMarshallerImpl
AbstractMethodError - Error in java.lang
Thrown when an application tries to call an abstract method.
AbstractMethodError() - Constructor for error java.lang.AbstractMethodError
Constructs an AbstractMethodError with no detail message.
AbstractMethodError(String) - Constructor for error java.lang.AbstractMethodError
Constructs an AbstractMethodError with the specified detail message.
AbstractOwnableSynchronizer - Class in java.util.concurrent.locks
A synchronizer that may be exclusively owned by a thread.
AbstractOwnableSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractOwnableSynchronizer
Empty constructor for use by subclasses.
AbstractPreferences - Class in java.util.prefs
This class provides a skeletal implementation of the Preferences class, greatly easing the task of implementing it.
AbstractPreferences(AbstractPreferences, String) - Constructor for class java.util.prefs.AbstractPreferences
Creates a preference node with the specified parent and the specified name relative to its parent.
AbstractProcessor - Class in javax.annotation.processing
An abstract annotation processor designed to be a convenient superclass for most concrete annotation processors.
AbstractProcessor() - Constructor for class javax.annotation.processing.AbstractProcessor
Constructor for subclasses to call.
AbstractQueue<E> - Class in java.util
This class provides skeletal implementations of some Queue operations.
AbstractQueue() - Constructor for class java.util.AbstractQueue
Constructor for use by subclasses.
AbstractQueuedLongSynchronizer - Class in java.util.concurrent.locks
A version of AbstractQueuedSynchronizer in which synchronization state is maintained as a long.
AbstractQueuedLongSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Creates a new AbstractQueuedLongSynchronizer instance with initial synchronization state of zero.
AbstractQueuedLongSynchronizer.ConditionObject - Class in java.util.concurrent.locks
Condition implementation for a AbstractQueuedLongSynchronizer serving as the basis of a Lock implementation.
AbstractQueuedLongSynchronizer.ConditionObject() - Constructor for class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Creates a new ConditionObject instance.
AbstractQueuedSynchronizer - Class in java.util.concurrent.locks
Provides a framework for implementing blocking locks and related synchronizers (semaphores, events, etc) that rely on first-in-first-out (FIFO) wait queues.
AbstractQueuedSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractQueuedSynchronizer
Creates a new AbstractQueuedSynchronizer instance with initial synchronization state of zero.
AbstractQueuedSynchronizer.ConditionObject - Class in java.util.concurrent.locks
Condition implementation for a AbstractQueuedSynchronizer serving as the basis of a Lock implementation.
AbstractQueuedSynchronizer.ConditionObject() - Constructor for class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Creates a new ConditionObject instance.
AbstractRegionPainter - Class in javax.swing.plaf.nimbus
Convenient base class for defining Painter instances for rendering a region or component in Nimbus.
AbstractRegionPainter() - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter
Create a new AbstractRegionPainter
AbstractRegionPainter.PaintContext - Class in javax.swing.plaf.nimbus
A class encapsulating state useful when painting.
AbstractRegionPainter.PaintContext(Insets, Dimension, boolean) - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
Creates a new PaintContext which does not attempt to cache or scale any cached images.
AbstractRegionPainter.PaintContext(Insets, Dimension, boolean, AbstractRegionPainter.PaintContext.CacheMode, double, double) - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
Creates a new PaintContext.
AbstractRegionPainter.PaintContext.CacheMode - Enum in javax.swing.plaf.nimbus
AbstractScriptEngine - Class in javax.script
Provides a standard implementation for several of the variants of the eval method.
AbstractScriptEngine() - Constructor for class javax.script.AbstractScriptEngine
Creates a new instance of AbstractScriptEngine using a SimpleScriptContext as its default ScriptContext.
AbstractScriptEngine(Bindings) - Constructor for class javax.script.AbstractScriptEngine
Creates a new instance using the specified Bindings as the ENGINE_SCOPE Bindings in the protected context field.
AbstractSelectableChannel - Class in java.nio.channels.spi
Base implementation class for selectable channels.
AbstractSelectableChannel(SelectorProvider) - Constructor for class java.nio.channels.spi.AbstractSelectableChannel
Initializes a new instance of this class.
AbstractSelectionKey - Class in java.nio.channels.spi
Base implementation class for selection keys.
AbstractSelectionKey() - Constructor for class java.nio.channels.spi.AbstractSelectionKey
Initializes a new instance of this class.
AbstractSelector - Class in java.nio.channels.spi
Base implementation class for selectors.
AbstractSelector(SelectorProvider) - Constructor for class java.nio.channels.spi.AbstractSelector
Initializes a new instance of this class.
AbstractSequentialList<E> - Class in java.util
This class provides a skeletal implementation of the List interface to minimize the effort required to implement this interface backed by a "sequential access" data store (such as a linked list).
AbstractSequentialList() - Constructor for class java.util.AbstractSequentialList
Sole constructor.
AbstractSet<E> - Class in java.util
This class provides a skeletal implementation of the Set interface to minimize the effort required to implement this interface.
AbstractSet() - Constructor for class java.util.AbstractSet
Sole constructor.
AbstractSpinnerModel - Class in javax.swing
This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations.
AbstractSpinnerModel() - Constructor for class javax.swing.AbstractSpinnerModel
AbstractTableModel - Class in javax.swing.table
This abstract class provides default implementations for most of the methods in the TableModel interface.
AbstractTableModel() - Constructor for class javax.swing.table.AbstractTableModel
AbstractTypeVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor of types with default behavior appropriate for the RELEASE_6 source version.
AbstractTypeVisitor6() - Constructor for class javax.lang.model.util.AbstractTypeVisitor6
Constructor for concrete subclasses to call.
AbstractTypeVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor of types with default behavior appropriate for the RELEASE_7 source version.
AbstractTypeVisitor7() - Constructor for class javax.lang.model.util.AbstractTypeVisitor7
Constructor for concrete subclasses to call.
AbstractUndoableEdit - Class in javax.swing.undo
An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
AbstractUndoableEdit() - Constructor for class javax.swing.undo.AbstractUndoableEdit
Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.
AbstractUnmarshallerImpl - Class in javax.xml.bind.helpers
Partial default Unmarshaller implementation.
AbstractUnmarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractUnmarshallerImpl
AbstractWriter - Class in javax.swing.text
AbstractWriter is an abstract class that actually does the work of writing out the element tree including the attributes.
AbstractWriter(Writer, Document) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Document, int, int) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Element) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Element, int, int) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
accelerationPriority - Variable in class java.awt.Image
Priority for accelerating this image.
ACCELERATOR_KEY - Static variable in interface javax.swing.Action
The key used for storing a KeyStroke to be used as the accelerator for the action.
acceleratorDelimiter - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
Accelerator delimiter string, such as '+' in 'Ctrl+C'.
acceleratorFont - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
acceleratorForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
acceleratorSelectionForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
accept(Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(Component) - Method in class java.awt.DefaultFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(File) - Method in interface java.io.FileFilter
Tests whether or not the specified abstract pathname should be included in a pathname list.
accept(File, String) - Method in interface java.io.FilenameFilter
Tests if a specified file should be included in a file list.
accept() - Method in class java.net.ServerSocket
Listens for a connection to be made to this socket and accepts it.
accept(SocketImpl) - Method in class java.net.SocketImpl
Accepts a connection.
accept(A, CompletionHandler<AsynchronousSocketChannel, ? super A>) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Accepts a connection.
accept() - Method in class java.nio.channels.AsynchronousServerSocketChannel
Accepts a connection.
accept() - Method in class java.nio.channels.ServerSocketChannel
Accepts a connection made to this channel's socket.
accept(T) - Method in interface java.nio.file.DirectoryStream.Filter
Decides if the given directory entry should be accepted or filtered.
accept(AnnotationValueVisitor<R, P>, P) - Method in interface javax.lang.model.element.AnnotationValue
Applies a visitor to this value.
accept(ElementVisitor<R, P>, P) - Method in interface javax.lang.model.element.Element
Applies a visitor to this element.
accept(TypeVisitor<R, P>, P) - Method in interface javax.lang.model.type.TypeMirror
Applies a visitor to this type.
accept(File) - Method in class javax.swing.filechooser.FileFilter
Whether the given file is accepted by this filter.
accept(File) - Method in class javax.swing.filechooser.FileNameExtensionFilter
Tests the specified file, returning true if the file is accepted, false otherwise.
accept(File) - Method in class javax.swing.JFileChooser
Returns true if the file should be displayed.
accept(Component) - Method in class javax.swing.LayoutFocusTraversalPolicy
Determines whether the specified Component is an acceptable choice as the new focus owner.
accept(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
accept(Component) - Method in class javax.swing.SortingFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(XMLEvent) - Method in interface javax.xml.stream.EventFilter
Tests whether this event is part of this stream.
accept(XMLStreamReader) - Method in interface javax.xml.stream.StreamFilter
Tests whether the current state is part of this stream.
ACCEPT_ALL - Static variable in interface java.net.CookiePolicy
One pre-defined policy which accepts all cookies.
ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies whether a the AcceptAllFileFilter is used or not.
ACCEPT_NONE - Static variable in interface java.net.CookiePolicy
One pre-defined policy which accepts no cookies.
ACCEPT_ONLY - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for context acceptance only.
ACCEPT_ORIGINAL_SERVER - Static variable in interface java.net.CookiePolicy
One pre-defined policy which only accepts cookies from original server.
acceptChanges() - Method in interface javax.sql.rowset.CachedRowSet
Propagates row update, insert and delete changes made to this CachedRowSet object to the underlying data source.
acceptChanges(Connection) - Method in interface javax.sql.rowset.CachedRowSet
Propagates all row update, insert and delete changes to the data source backing this CachedRowSet object using the specified Connection object to establish a connection to the data source.
acceptDrag(int) - Method in class java.awt.dnd.DropTargetContext
accept the Drag.
acceptDrag(int) - Method in class java.awt.dnd.DropTargetDragEvent
Accepts the drag.
acceptDrop(int) - Method in class java.awt.dnd.DropTargetContext
called to signal that the drop is acceptable using the specified operation.
acceptDrop(int) - Method in class java.awt.dnd.DropTargetDropEvent
accept the drop, using the specified action.
ACCEPTING_JOBS - Static variable in class javax.print.attribute.standard.PrinterIsAcceptingJobs
The printer is currently acccepting jobs.
acceptNode(Node) - Method in interface org.w3c.dom.ls.LSParserFilter
This method will be called by the parser at the completion of the parsing of each node.
AcceptPendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to initiate an accept operation on a channel and a previous accept operation has not completed.
AcceptPendingException() - Constructor for exception java.nio.channels.AcceptPendingException
Constructs an instance of this class.
acceptSecContext(byte[], int, int) - Method in interface org.ietf.jgss.GSSContext
Called by the context acceptor upon receiving a token from the peer.
acceptSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss.GSSContext
Called by the context acceptor to process a token from the peer using streams.
acceptsURL(String) - Method in interface java.sql.Driver
Retrieves whether the driver thinks that it can open a connection to the given URL.
access - Variable in class org.omg.CORBA.ValueMember
The type of access (public, private) for the value member described by this ValueMember object.
AccessControlContext - Class in java.security
An AccessControlContext is used to make system resource access decisions based on the context it encapsulates.
AccessControlContext(ProtectionDomain[]) - Constructor for class java.security.AccessControlContext
Create an AccessControlContext with the given array of ProtectionDomains.
AccessControlContext(AccessControlContext, DomainCombiner) - Constructor for class java.security.AccessControlContext
Create a new AccessControlContext with the given AccessControlContext and DomainCombiner.
AccessControlException - Exception in java.security
This exception is thrown by the AccessController to indicate that a requested access (to a critical system resource such as the file system or the network) is denied.
AccessControlException(String) - Constructor for exception java.security.AccessControlException
Constructs an AccessControlException with the specified, detailed message.
AccessControlException(String, Permission) - Constructor for exception java.security.AccessControlException
Constructs an AccessControlException with the specified, detailed message, and the requested permission that caused the exception.
AccessController - Class in java.security
The AccessController class is used for access control operations and decisions.
AccessDeniedException - Exception in java.nio.file
Checked exception thrown when a file system operation is denied, typically due to a file permission or other access check.
AccessDeniedException(String) - Constructor for exception java.nio.file.AccessDeniedException
Constructs an instance of this class.
AccessDeniedException(String, String, String) - Constructor for exception java.nio.file.AccessDeniedException
Constructs an instance of this class.
AccessException - Exception in java.rmi
An AccessException is thrown by certain methods of the java.rmi.Naming class (specifically bind, rebind, and unbind) and methods of the java.rmi.activation.ActivationSystem interface to indicate that the caller does not have permission to perform the action requested by the method call.
AccessException(String) - Constructor for exception java.rmi.AccessException
Constructs an AccessException with the specified detail message.
AccessException(String, Exception) - Constructor for exception java.rmi.AccessException
Constructs an AccessException with the specified detail message and nested exception.
Accessible - Interface in javax.accessibility
Interface Accessible is the main interface for the accessibility package.
ACCESSIBLE_ACTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the supported set of actions has changed.
ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the active descendant of a component has changed.
ACCESSIBLE_CARET_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleText caret has changed.
ACCESSIBLE_CHILD_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when Accessible children are added/removed from the object.
ACCESSIBLE_COMPONENT_BOUNDS_CHANGED - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that a change has occurred in a component's bounds.
ACCESSIBLE_DESCRIPTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleDescription property has changed.
ACCESSIBLE_HYPERTEXT_OFFSET - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that a hypertext element has received focus.
ACCESSIBLE_INVALIDATE_CHILDREN - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that a significant change has occurred to the children of a component like a tree or text.
ACCESSIBLE_NAME_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleName property has changed.
ACCESSIBLE_SELECTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleSelection has changed.
ACCESSIBLE_STATE_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleStateSet property has changed.
ACCESSIBLE_TABLE_CAPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the table caption has changed The old value in the PropertyChangeEvent will be an Accessible representing the previous table caption and the new value will be an Accessible representing the new table caption.
ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the column description has changed The old value in the PropertyChangeEvent will be null and the new value will be an Integer representing the column index.
ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the column header has changed The old value in the PropertyChangeEvent will be null and the new value will be an AccessibleTableModelChange representing the header change.
ACCESSIBLE_TABLE_MODEL_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that table data has changed.
ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the row description has changed The old value in the PropertyChangeEvent will be null and the new value will be an Integer representing the row index.
ACCESSIBLE_TABLE_ROW_HEADER_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the row header has changed The old value in the PropertyChangeEvent will be null and the new value will be an AccessibleTableModelChange representing the header change.
ACCESSIBLE_TABLE_SUMMARY_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the table summary has changed The old value in the PropertyChangeEvent will be an Accessible representing the previous table summary and the new value will be an Accessible representing the new table summary.
ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that text attributes have changed.
ACCESSIBLE_TEXT_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that text has changed.
ACCESSIBLE_VALUE_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleValue property has changed.
ACCESSIBLE_VISIBLE_DATA_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the visual appearance of the object has changed.
AccessibleAction - Interface in javax.accessibility
The AccessibleAction interface should be supported by any object that can perform one or more actions.
AccessibleAttributeSequence - Class in javax.accessibility
This class collects together the span of text that share the same contiguous set of attributes, along with that set of attributes.
AccessibleAttributeSequence(int, int, AttributeSet) - Constructor for class javax.accessibility.AccessibleAttributeSequence
Constructs an AccessibleAttributeSequence with the given parameters.
accessibleAWTComponentHandler - Variable in class java.awt.Component.AccessibleAWTComponent
accessibleAWTFocusHandler - Variable in class java.awt.Component.AccessibleAWTComponent
AccessibleBundle - Class in javax.accessibility
Base class used to maintain a strongly typed enumeration.
AccessibleBundle() - Constructor for class javax.accessibility.AccessibleBundle
AccessibleComponent - Interface in javax.accessibility
The AccessibleComponent interface should be supported by any object that is rendered on the screen.
accessibleContainerHandler - Variable in class java.awt.Container.AccessibleAWTContainer
accessibleContainerHandler - Variable in class javax.swing.JComponent.AccessibleJComponent
AccessibleContext - Class in javax.accessibility
AccessibleContext represents the minimum information all accessible objects return.
AccessibleContext() - Constructor for class javax.accessibility.AccessibleContext
accessibleContext - Variable in class javax.swing.CellRendererPane
accessibleContext - Variable in class javax.swing.JApplet
accessibleContext - Variable in class javax.swing.JColorChooser
accessibleContext - Variable in class javax.swing.JComponent
The AccessibleContext associated with this JComponent.
accessibleContext - Variable in class javax.swing.JDialog
accessibleContext - Variable in class javax.swing.JFileChooser
accessibleContext - Variable in class javax.swing.JFrame
The accessible context property.
accessibleContext - Variable in class javax.swing.JWindow
The accessible context property.
accessibleContext - Variable in class javax.swing.ProgressMonitor
The AccessibleContext for the ProgressMonitor
accessibleDescription - Variable in class javax.accessibility.AccessibleContext
A localized String containing the description of the object.
AccessibleEditableText - Interface in javax.accessibility
The AccessibleEditableText interface should be implemented by all classes that present editable textual information on the display.
AccessibleExtendedComponent - Interface in javax.accessibility
The AccessibleExtendedComponent interface should be supported by any object that is rendered on the screen.
AccessibleExtendedTable - Interface in javax.accessibility
Class AccessibleExtendedTable provides extended information about a user-interface component that presents data in a two-dimensional table format.
AccessibleExtendedText - Interface in javax.accessibility
The AccessibleExtendedText interface contains additional methods not provided by the AccessibleText interface Applications can determine if an object supports the AccessibleExtendedText interface by first obtaining its AccessibleContext (see Accessible) and then calling the AccessibleContext.getAccessibleText() method of AccessibleContext.
accessibleFocusHandler - Variable in class javax.swing.JComponent.AccessibleJComponent
AccessibleHyperlink - Class in javax.accessibility
Encapsulation of a link, or set of links (e.g.
AccessibleHyperlink() - Constructor for class javax.accessibility.AccessibleHyperlink
AccessibleHypertext - Interface in javax.accessibility
The AccessibleHypertext class is the base class for all classes that present hypertext information on the display.
AccessibleIcon - Interface in javax.accessibility
The AccessibleIcon interface should be supported by any object that has an associated icon (e.g., buttons).
AccessibleKeyBinding - Interface in javax.accessibility
The AccessibleKeyBinding interface should be supported by any object that has a keyboard bindings such as a keyboard mnemonic and/or keyboard shortcut which can be used to select the object.
accessibleName - Variable in class javax.accessibility.AccessibleContext
A localized String containing the name of the object.
AccessibleObject - Class in java.lang.reflect
The AccessibleObject class is the base class for Field, Method and Constructor objects.
AccessibleObject() - Constructor for class java.lang.reflect.AccessibleObject
Constructor: only used by the Java Virtual Machine.
accessibleParent - Variable in class javax.accessibility.AccessibleContext
The accessible parent of this object.
AccessibleRelation - Class in javax.accessibility
Class AccessibleRelation describes a relation between the object that implements the AccessibleRelation and one or more other objects.
AccessibleRelation(String) - Constructor for class javax.accessibility.AccessibleRelation
Create a new AccessibleRelation using the given locale independent key.
AccessibleRelation(String, Object) - Constructor for class javax.accessibility.AccessibleRelation
Creates a new AccessibleRelation using the given locale independent key.
AccessibleRelation(String, Object[]) - Constructor for class javax.accessibility.AccessibleRelation
Creates a new AccessibleRelation using the given locale independent key.
AccessibleRelationSet - Class in javax.accessibility
Class AccessibleRelationSet determines a component's relation set.
AccessibleRelationSet() - Constructor for class javax.accessibility.AccessibleRelationSet
Creates a new empty relation set.
AccessibleRelationSet(AccessibleRelation[]) - Constructor for class javax.accessibility.AccessibleRelationSet
Creates a new relation with the initial set of relations contained in the array of relations passed in.
AccessibleResourceBundle - Class in javax.accessibility
Deprecated.
This class is deprecated as of version 1.3 of the Java Platform.
AccessibleResourceBundle() - Constructor for class javax.accessibility.AccessibleResourceBundle
Deprecated.
AccessibleRole - Class in javax.accessibility
Class AccessibleRole determines the role of a component.
AccessibleRole(String) - Constructor for class javax.accessibility.AccessibleRole
Creates a new AccessibleRole using the given locale independent key.
AccessibleSelection - Interface in javax.accessibility
This AccessibleSelection interface provides the standard mechanism for an assistive technology to determine what the current selected children are, as well as modify the selection set.
AccessibleState - Class in javax.accessibility
Class AccessibleState describes a component's particular state.
AccessibleState(String) - Constructor for class javax.accessibility.AccessibleState
Creates a new AccessibleState using the given locale independent key.
AccessibleStateSet - Class in javax.accessibility
Class AccessibleStateSet determines a component's state set.
AccessibleStateSet() - Constructor for class javax.accessibility.AccessibleStateSet
Creates a new empty state set.
AccessibleStateSet(AccessibleState[]) - Constructor for class javax.accessibility.AccessibleStateSet
Creates a new state with the initial set of states contained in the array of states passed in.
AccessibleStreamable - Interface in javax.accessibility
The AccessibleStreamable interface should be implemented by the AccessibleContext of any component that presents the raw stream behind a component on the display screen.
AccessibleTable - Interface in javax.accessibility
Class AccessibleTable describes a user-interface component that presents data in a two-dimensional table format.
AccessibleTableModelChange - Interface in javax.accessibility
The AccessibleTableModelChange interface describes a change to the table model.
AccessibleText - Interface in javax.accessibility
The AccessibleText interface should be implemented by all classes that present textual information on the display.
AccessibleTextSequence - Class in javax.accessibility
This class collects together key details of a span of text.
AccessibleTextSequence(int, int, String) - Constructor for class javax.accessibility.AccessibleTextSequence
Constructs an AccessibleTextSequence with the given parameters.
AccessibleValue - Interface in javax.accessibility
The AccessibleValue interface should be supported by any object that supports a numerical value (e.g., a scroll bar).
AccessMode - Enum in java.nio.file
Defines access modes used to test the accessibility of a file.
ACCESSORY_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different accessory component is in use (for example, to preview files).
AccountException - Exception in javax.security.auth.login
A generic account exception.
AccountException() - Constructor for exception javax.security.auth.login.AccountException
Constructs a AccountException with no detail message.
AccountException(String) - Constructor for exception javax.security.auth.login.AccountException
Constructs a AccountException with the specified detail message.
AccountExpiredException - Exception in javax.security.auth.login
Signals that a user account has expired.
AccountExpiredException() - Constructor for exception javax.security.auth.login.AccountExpiredException
Constructs a AccountExpiredException with no detail message.
AccountExpiredException(String) - Constructor for exception javax.security.auth.login.AccountExpiredException
Constructs a AccountExpiredException with the specified detail message.
AccountLockedException - Exception in javax.security.auth.login
Signals that an account was locked.
AccountLockedException() - Constructor for exception javax.security.auth.login.AccountLockedException
Constructs a AccountLockedException with no detail message.
AccountLockedException(String) - Constructor for exception javax.security.auth.login.AccountLockedException
Constructs a AccountLockedException with the specified detail message.
AccountNotFoundException - Exception in javax.security.auth.login
Signals that an account was not found.
AccountNotFoundException() - Constructor for exception javax.security.auth.login.AccountNotFoundException
Constructs a AccountNotFoundException with no detail message.
AccountNotFoundException(String) - Constructor for exception javax.security.auth.login.AccountNotFoundException
Constructs a AccountNotFoundException with the specified detail message.
Acl - Interface in java.security.acl
Interface representing an Access Control List (ACL).
AclEntry - Class in java.nio.file.attribute
An entry in an access control list (ACL).
AclEntry - Interface in java.security.acl
This is the interface used for representing one entry in an Access Control List (ACL).
AclEntry.Builder - Class in java.nio.file.attribute
A builder of AclEntry objects.
AclEntryFlag - Enum in java.nio.file.attribute
Defines the flags for used by the flags component of an ACL entry.
AclEntryPermission - Enum in java.nio.file.attribute
Defines the permissions for use with the permissions component of an ACL entry.
AclEntryType - Enum in java.nio.file.attribute
A typesafe enumeration of the access control entry types.
AclFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that supports reading or updating a file's Access Control Lists (ACL) or file owner attributes.
AclNotFoundException - Exception in java.security.acl
This is an exception that is thrown whenever a reference is made to a non-existent ACL (Access Control List).
AclNotFoundException() - Constructor for exception java.security.acl.AclNotFoundException
Constructs an AclNotFoundException.
acos(double) - Static method in class java.lang.Math
Returns the arc cosine of a value; the returned angle is in the range 0.0 through pi.
acos(double) - Static method in class java.lang.StrictMath
Returns the arc cosine of a value; the returned angle is in the range 0.0 through pi.
acquire(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in exclusive mode, ignoring interrupts.
acquire(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in exclusive mode, ignoring interrupts.
acquire() - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, blocking until one is available, or the thread is interrupted.
acquire(int) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, blocking until all are available, or the thread is interrupted.
acquiredBy() - Method in class java.nio.channels.FileLock
Returns the channel upon whose file this lock was acquired.
acquireInterruptibly(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in exclusive mode, aborting if interrupted.
acquireInterruptibly(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in exclusive mode, aborting if interrupted.
acquireShared(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in shared mode, ignoring interrupts.
acquireShared(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in shared mode, ignoring interrupts.
acquireSharedInterruptibly(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in shared mode, aborting if interrupted.
acquireSharedInterruptibly(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in shared mode, aborting if interrupted.
acquireUninterruptibly() - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, blocking until one is available.
acquireUninterruptibly(int) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, blocking until all are available.
action(Event, Object) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, should register this component as ActionListener on component which fires action events.
ACTION - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is write-like: it has an effect but does not return any information from the MBean.
Action - Interface in javax.swing
The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
ACTION - Static variable in class javax.swing.text.html.HTML.Attribute
Action - Annotation Type in javax.xml.ws
The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.
ACTION_APPEND_AS_CHILDREN - Static variable in interface org.w3c.dom.ls.LSParser
Append the result of the parse operation as children of the context node.
ACTION_COMMAND_KEY - Static variable in interface javax.swing.Action
The key used to determine the command String for the ActionEvent that will be created when an Action is going to be notified as the result of residing in a Keymap associated with a JComponent.
ACTION_COPY - Static variable in class java.awt.dnd.DnDConstants
An int representing a "copy" action.
ACTION_COPY_OR_MOVE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "copy" or "move" action.
ACTION_EVENT - Static variable in class java.awt.Event
This event indicates that the user wants some action to occur.
ACTION_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting action events.
ACTION_FIRST - Static variable in class java.awt.event.ActionEvent
The first number in the range of ids used for action events.
ACTION_INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is both read-like and write-like: it has an effect, and it also returns information from the MBean.
ACTION_INSERT_AFTER - Static variable in interface org.w3c.dom.ls.LSParser
Insert the result of the parse operation as the immediately following sibling of the context node.
ACTION_INSERT_BEFORE - Static variable in interface org.w3c.dom.ls.LSParser
Insert the result of the parse operation as the immediately preceding sibling of the context node.
ACTION_LAST - Static variable in class java.awt.event.ActionEvent
The last number in the range of ids used for action events.
ACTION_LINK - Static variable in class java.awt.dnd.DnDConstants
An int representing a "link" action.
ACTION_MOVE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "move" action.
ACTION_NONE - Static variable in class java.awt.dnd.DnDConstants
An int representing no action.
ACTION_PERFORMED - Static variable in class java.awt.event.ActionEvent
This event id indicates that a meaningful action occured.
ACTION_REFERENCE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "reference" action (synonym for ACTION_LINK).
ACTION_REPLACE - Static variable in interface org.w3c.dom.ls.LSParser
Replace the context node with the result of the parse operation.
ACTION_REPLACE_CHILDREN - Static variable in interface org.w3c.dom.ls.LSParser
Replace all the children of the context node with the result of the parse operation.
actionCommand - Variable in class javax.swing.DefaultButtonModel
The action command string fired by the button.
actionCommand - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
ActionEvent - Class in java.awt.event
A semantic event which indicates that a component-defined action occurred.
ActionEvent(Object, int, String) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object.
ActionEvent(Object, int, String, int) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object with modifier keys.
ActionEvent(Object, int, String, long, int) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object with the specified modifier keys and timestamp.
ActionListener - Interface in java.awt.event
The listener interface for receiving action events.
actionListener - Variable in class javax.swing.AbstractButton
The button model's ActionListener.
ActionMap - Class in javax.swing
ActionMap provides mappings from Objects (called keys or Action names) to Actions.
ActionMap() - Constructor for class javax.swing.ActionMap
Creates an ActionMap with no parent and no mappings.
ActionMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.ActionMap that implements UIResource.
ActionMapUIResource() - Constructor for class javax.swing.plaf.ActionMapUIResource
actionName - Variable in class javax.swing.text.JTextComponent.KeyBinding
The name of the action for the key.
actionPerformed(ActionEvent) - Method in class java.awt.AWTEventMulticaster
Handles the actionPerformed event by invoking the actionPerformed methods on listener-a and listener-b.
actionPerformed(ActionEvent) - Method in class java.awt.dnd.DropTarget.DropTargetAutoScroller
cause autoscroll to occur
actionPerformed(ActionEvent) - Method in interface java.awt.event.ActionListener
Invoked when an action occurs.
actionPerformed(ActionEvent) - Method in class java.awt.List.AccessibleAWTList
actionPerformed(ActionEvent) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
When an action is performed, editing is ended.
actionPerformed(ActionEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ScrollListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
Public as a result of Timer.
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.BeepAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.CopyAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.CutAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertBreakAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertContentAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertTabAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.PasteAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.html.FormView
Responsible for processeing the ActionEvent.
actionPerformed(ActionEvent) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Inserts the HTML into the document.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.AlignmentAction
Sets the alignment.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.BoldAction
Toggles the bold attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.FontFamilyAction
Sets the font family.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.FontSizeAction
Sets the font size.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.ForegroundAction
Sets the foreground color.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.ItalicAction
Toggles the italic attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.UnderlineAction
Toggles the Underline attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.insideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.outsideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.stillInsideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.tree.DefaultTreeCellEditor
Messaged when the timer fires, this will start the editing session.
actionPropertyChanged(Action, String) - Method in class javax.swing.AbstractButton
Updates the button's state in response to property changes in the associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JComboBox
Updates the combobox's state in response to property changes in associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JMenuItem
Updates the button's state in response to property changes in the associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JTextField
Updates the textfield's state in response to property changes in associated action.
Activatable - Class in java.rmi.activation
The Activatable class provides support for remote objects that require persistent access over time and that can be activated by the system.
Activatable(String, MarshalledObject<?>, boolean, int) - Constructor for class java.rmi.activation.Activatable
Constructs an activatable remote object by registering an activation descriptor (with the specified location, data, and restart mode) for this object, and exporting the object with the specified port.
Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation.Activatable
Constructs an activatable remote object by registering an activation descriptor (with the specified location, data, and restart mode) for this object, and exporting the object with the specified port, and specified client and server socket factories.
Activatable(ActivationID, int) - Constructor for class java.rmi.activation.Activatable
Constructor used to activate/export the object on a specified port.
Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation.Activatable
Constructor used to activate/export the object on a specified port.
activate() - Method in interface java.awt.im.spi.InputMethod
Activates the input method for immediate input processing.
activate(Applet) - Method in interface java.beans.AppletInitializer
Activate, and/or mark Applet active.
activate(boolean) - Method in class java.rmi.activation.ActivationID
Activate the object for this id.
activate(ActivationID, boolean) - Method in interface java.rmi.activation.Activator
Activate the object associated with the activation identifier, id.
activate(IIOParam) - Method in interface javax.imageio.IIOParamController
Activates the controller.
activate(IIOMetadata) - Method in interface javax.imageio.metadata.IIOMetadataController
Activates the controller.
activate() - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
activate_object(Servant) - Method in interface org.omg.PortableServer.POAOperations
This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
activate_object_with_id(byte[], Servant) - Method in interface org.omg.PortableServer.POAOperations
This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
activateController() - Method in class javax.imageio.IIOParam
Activates the installed IIOParamController for this IIOParam object and returns the resulting value.
activateController() - Method in class javax.imageio.metadata.IIOMetadata
Activates the installed IIOMetadataController for this IIOMetadata object and returns the resulting value.
ACTIVATED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Activated type.
ActivateFailedException - Exception in java.rmi.activation
This exception is thrown by the RMI runtime when activation fails during a remote call to an activatable object.
ActivateFailedException(String) - Constructor for exception java.rmi.activation.ActivateFailedException
Constructs an ActivateFailedException with the specified detail message.
ActivateFailedException(String, Exception) - Constructor for exception java.rmi.activation.ActivateFailedException
Constructs an ActivateFailedException with the specified detail message and nested exception.
activateFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
This will activate f moving it to the front.
activateFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, indicate that this frame has focus.
activateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the frame becomes selected.
activateLink(int, JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.LinkController
Calls linkActivated on the associated JEditorPane if the given position represents a link.
ActivationDataFlavor - Class in javax.activation
The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
ActivationDataFlavor(Class, String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(Class, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDesc - Class in java.rmi.activation
An activation descriptor contains the information necessary to activate an object: the object's group identifier, the object's fully-qualified class name, the object's code location (the location of the class), a codebase URL path, the object's restart "mode", and, a "marshalled" object that can contain object specific initialization data.
ActivationDesc(String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className, that can be loaded from the code location and whose initialization information is data.
ActivationDesc(String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className, that can be loaded from the code location and whose initialization information is data.
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className that can be loaded from the code location and whose initialization information is data.
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className that can be loaded from the code location and whose initialization information is data.
ActivationException - Exception in java.rmi.activation
General exception used by the activation interfaces.
ActivationException() - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException.
ActivationException(String) - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException with the specified detail message.
ActivationException(String, Throwable) - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException with the specified detail message and cause.
ActivationGroup - Class in java.rmi.activation
An ActivationGroup is responsible for creating new instances of "activatable" objects in its group, informing its ActivationMonitor when either: its object's become active or inactive, or the group as a whole becomes inactive.
ActivationGroup(ActivationGroupID) - Constructor for class java.rmi.activation.ActivationGroup
Constructs an activation group with the given activation group identifier.
ActivationGroup_Stub - Class in java.rmi.activation
ActivationGroup_Stub is a stub class for the subclasses of java.rmi.activation.ActivationGroup that are exported as a java.rmi.server.UnicastRemoteObject.
ActivationGroup_Stub(RemoteRef) - Constructor for class java.rmi.activation.ActivationGroup_Stub
Constructs a stub for the ActivationGroup class.
ActivationGroupDesc - Class in java.rmi.activation
An activation group descriptor contains the information necessary to create/recreate an activation group in which to activate objects.
ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation.ActivationGroupDesc
Constructs a group descriptor that uses the system defaults for group implementation and code location.
ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation.ActivationGroupDesc
Specifies an alternate group implementation and execution environment to be used for the group.
ActivationGroupDesc.CommandEnvironment - Class in java.rmi.activation
Startup options for ActivationGroup implementations.
ActivationGroupDesc.CommandEnvironment(String, String[]) - Constructor for class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Create a CommandEnvironment with all the necessary information.
ActivationGroupID - Class in java.rmi.activation
The identifier for a registered activation group serves several purposes: identifies the group uniquely within the activation system, and contains a reference to the group's activation system so that the group can contact its activation system when necessary.
ActivationGroupID(ActivationSystem) - Constructor for class java.rmi.activation.ActivationGroupID
Constructs a unique group id.
ActivationID - Class in java.rmi.activation
Activation makes use of special identifiers to denote remote objects that can be activated over time.
ActivationID(Activator) - Constructor for class java.rmi.activation.ActivationID
The constructor for ActivationID takes a single argument, activator, that specifies a remote reference to the activator responsible for activating the object associated with this identifier.
ActivationInstantiator - Interface in java.rmi.activation
An ActivationInstantiator is responsible for creating instances of "activatable" objects.
ActivationMonitor - Interface in java.rmi.activation
An ActivationMonitor is specific to an ActivationGroup and is obtained when a group is reported active via a call to ActivationSystem.activeGroup (this is done internally).
ActivationSystem - Interface in java.rmi.activation
The ActivationSystem provides a means for registering groups and "activatable" objects to be activated within those groups.
Activator - Interface in java.rmi.activation
The Activator facilitates remote object activation.
ACTIVATOR_ID - Static variable in class java.rmi.server.ObjID
Object number for well-known ObjID of the activator.
ACTIVE - Static variable in class javax.accessibility.AccessibleState
Indicates a window is currently the active window.
active - Variable in class javax.sound.midi.VoiceStatus
Indicates whether the voice is currently processing a MIDI note.
ACTIVE - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ACTIVE.java .
ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
ACTIVE_CAPTION - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaption system color.
ACTIVE_CAPTION_BORDER - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaptionBorder system color.
ACTIVE_CAPTION_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaptionText system color.
ACTIVE_SENSING - Static variable in class javax.sound.midi.ShortMessage
Status byte for Active Sensing message (0xFE, or 254).
activeCaption - Static variable in class java.awt.SystemColor
The color rendered for the window-title background of the currently active window.
activeCaptionBorder - Static variable in class java.awt.SystemColor
The color rendered for the border around the currently active window.
activeCaptionText - Static variable in class java.awt.SystemColor
The color rendered for the window-title text of the currently active window.
activeCount() - Static method in class java.lang.Thread
Returns an estimate of the number of active threads in the current thread's thread group and its subgroups.
activeCount() - Method in class java.lang.ThreadGroup
Returns an estimate of the number of active threads in this thread group and its subgroups.
ActiveEvent - Interface in java.awt
An interface for events that know how to dispatch themselves.
activeGroup(ActivationGroupID, ActivationInstantiator, long) - Method in interface java.rmi.activation.ActivationSystem
Callback to inform activation system that group is now active.
activeGroupCount() - Method in class java.lang.ThreadGroup
Returns an estimate of the number of active groups in this thread group and its subgroups.
activeObject(ActivationID, Remote) - Method in class java.rmi.activation.ActivationGroup
The group's activeObject method is called when an object is exported (either by Activatable object construction or an explicit call to Activatable.exportObject.
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in class java.rmi.activation.ActivationGroup
This protected method is necessary for subclasses to make the activeObject callback to the group's monitor.
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in interface java.rmi.activation.ActivationMonitor
Informs that an object is now active.
ACTIVITY_COMPLETED - Exception in org.omg.CORBA
The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
ACTIVITY_COMPLETED() - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
ACTIVITY_COMPLETED(String) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified message.
ACTIVITY_COMPLETED(int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
ACTIVITY_COMPLETED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
ACTIVITY_REQUIRED - Exception in org.omg.CORBA
The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
ACTIVITY_REQUIRED() - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
ACTIVITY_REQUIRED(String) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified message.
ACTIVITY_REQUIRED(int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
ACTIVITY_REQUIRED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
ActivityCompletedException - Exception in javax.activity
This exception may be thrown on any method for which Activity context is accessed and indicates that ongoing work within the Activity is not possible.
ActivityCompletedException() - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new instance with null as its detail message.
ActivityCompletedException(String) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new instance with the specified detail message.
ActivityCompletedException(Throwable) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new throwable with the specified cause.
ActivityCompletedException(String, Throwable) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new throwable with the specified detail message and cause.
ActivityRequiredException - Exception in javax.activity
This exception is thrown by a container if Activity context is not received on a method for which Activity context is mandatory.
ActivityRequiredException() - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new instance with null as its detail message.
ActivityRequiredException(String) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new instance with the specified detail message.
ActivityRequiredException(Throwable) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new throwable with the specified cause.
ActivityRequiredException(String, Throwable) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new throwable with the specified detail message and cause.
AD - Static variable in class java.util.GregorianCalendar
Value of the ERA field indicating the common era (Anno Domini), also known as CE.
adapt(Runnable) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the run method of the given Runnable as its action, and returns a null result upon ForkJoinTask.join().
adapt(Runnable, T) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the run method of the given Runnable as its action, and returns the given result upon ForkJoinTask.join().
adapt(Callable<? extends T>) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the call method of the given Callable as its action, and returns its result upon ForkJoinTask.join(), translating any checked exceptions encountered into RuntimeException.
adapter_id() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the opaque identifier for the object adapter.
adapter_manager_state_changed(int, short) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
Called whenever the state of an adapter manager changes.
adapter_name() - Method in interface org.omg.PortableInterceptor.ObjectReferenceTemplate
adapter_name() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the sequence of strings that identifies the object adapter instance that is handling this request.
adapter_state_changed(ObjectReferenceTemplate[], short) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
adapter_template() - Method in interface org.omg.PortableInterceptor.IORInfoOperations
Return the object reference template of the object adapter that was just created and is running IOR interceptors.
AdapterActivator - Interface in org.omg.PortableServer
An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
AdapterActivatorOperations - Interface in org.omg.PortableServer
An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
AdapterAlreadyExists - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
AdapterAlreadyExists() - Constructor for exception org.omg.PortableServer.POAPackage.AdapterAlreadyExists
AdapterAlreadyExists(String) - Constructor for exception org.omg.PortableServer.POAPackage.AdapterAlreadyExists
AdapterAlreadyExistsHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
AdapterAlreadyExistsHelper() - Constructor for class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
AdapterInactive - Exception in org.omg.PortableServer.POAManagerPackage
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
AdapterInactive() - Constructor for exception org.omg.PortableServer.POAManagerPackage.AdapterInactive
AdapterInactive(String) - Constructor for exception org.omg.PortableServer.POAManagerPackage.AdapterInactive
AdapterInactiveHelper - Class in org.omg.PortableServer.POAManagerPackage
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
AdapterInactiveHelper() - Constructor for class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
AdapterManagerIdHelper - Class in org.omg.PortableInterceptor
Adapter manager identifier.
AdapterManagerIdHelper() - Constructor for class org.omg.PortableInterceptor.AdapterManagerIdHelper
AdapterNameHelper - Class in org.omg.PortableInterceptor
The name of an object adapter.
AdapterNameHelper() - Constructor for class org.omg.PortableInterceptor.AdapterNameHelper
AdapterNonExistent - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
AdapterNonExistent() - Constructor for exception org.omg.PortableServer.POAPackage.AdapterNonExistent
AdapterNonExistent(String) - Constructor for exception org.omg.PortableServer.POAPackage.AdapterNonExistent
AdapterNonExistentHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
AdapterNonExistentHelper() - Constructor for class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
AdapterStateHelper - Class in org.omg.PortableInterceptor
Type of object adapter state.
AdapterStateHelper() - Constructor for class org.omg.PortableInterceptor.AdapterStateHelper
add(ComponentListener, ComponentListener) - Static method in class java.awt.AWTEventMulticaster
Adds component-listener-a with component-listener-b and returns the resulting multicast listener.
add(ContainerListener, ContainerListener) - Static method in class java.awt.AWTEventMulticaster
Adds container-listener-a with container-listener-b and returns the resulting multicast listener.
add(FocusListener, FocusListener) - Static method in class java.awt.AWTEventMulticaster
Adds focus-listener-a with focus-listener-b and returns the resulting multicast listener.
add(KeyListener, KeyListener) - Static method in class java.awt.AWTEventMulticaster
Adds key-listener-a with key-listener-b and returns the resulting multicast listener.
add(MouseListener, MouseListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-listener-a with mouse-listener-b and returns the resulting multicast listener.
add(MouseMotionListener, MouseMotionListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-motion-listener-a with mouse-motion-listener-b and returns the resulting multicast listener.
add(WindowListener, WindowListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-listener-a with window-listener-b and returns the resulting multicast listener.
add(WindowStateListener, WindowStateListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-state-listener-a with window-state-listener-b and returns the resulting multicast listener.
add(WindowFocusListener, WindowFocusListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-focus-listener-a with window-focus-listener-b and returns the resulting multicast listener.
add(ActionListener, ActionListener) - Static method in class java.awt.AWTEventMulticaster
Adds action-listener-a with action-listener-b and returns the resulting multicast listener.
add(ItemListener, ItemListener) - Static method in class java.awt.AWTEventMulticaster
Adds item-listener-a with item-listener-b and returns the resulting multicast listener.
add(AdjustmentListener, AdjustmentListener) - Static method in class java.awt.AWTEventMulticaster
Adds adjustment-listener-a with adjustment-listener-b and returns the resulting multicast listener.
add(TextListener, TextListener) - Static method in class java.awt.AWTEventMulticaster
add(InputMethodListener, InputMethodListener) - Static method in class java.awt.AWTEventMulticaster
Adds input-method-listener-a with input-method-listener-b and returns the resulting multicast listener.
add(HierarchyListener, HierarchyListener) - Static method in class java.awt.AWTEventMulticaster
Adds hierarchy-listener-a with hierarchy-listener-b and returns the resulting multicast listener.
add(HierarchyBoundsListener, HierarchyBoundsListener) - Static method in class java.awt.AWTEventMulticaster
Adds hierarchy-bounds-listener-a with hierarchy-bounds-listener-b and returns the resulting multicast listener.
add(MouseWheelListener, MouseWheelListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-wheel-listener-a with mouse-wheel-listener-b and returns the resulting multicast listener.
add(String) - Method in class java.awt.Choice
Adds an item to this Choice menu.
add(PopupMenu) - Method in class java.awt.Component
Adds the specified popup menu to the component.
add(Component) - Method in class java.awt.Container
Appends the specified component to the end of this container.
add(String, Component) - Method in class java.awt.Container
Adds the specified component to this container.
add(Component, int) - Method in class java.awt.Container
Adds the specified component to this container at the given position.
add(Component, Object) - Method in class java.awt.Container
Adds the specified component to the end of this container.
add(Component, Object, int) - Method in class java.awt.Container
Adds the specified component to this container with the specified constraints at the specified index.
add(Area) - Method in class java.awt.geom.Area
Adds the shape of the specified Area to the shape of this Area.
add(double, double) - Method in class java.awt.geom.Rectangle2D
Adds a point, specified by the double precision arguments newx and newy, to this Rectangle2D.
add(Point2D) - Method in class java.awt.geom.Rectangle2D
Adds the Point2D object pt to this Rectangle2D.
add(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Adds a Rectangle2D object to this Rectangle2D.
add(Object) - Method in class java.awt.image.renderable.ParameterBlock
Adds an object to the list of parameters.
add(byte) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Byte to the list of parameters.
add(char) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Character to the list of parameters.
add(short) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Short to the list of parameters.
add(int) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Integer to the list of parameters.
add(long) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Long to the list of parameters.
add(float) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Float to the list of parameters.
add(double) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Double to the list of parameters.
add(String) - Method in class java.awt.List
Adds the specified item to the end of scrolling list.
add(String, int) - Method in class java.awt.List
Adds the specified item to the the scrolling list at the position indicated by the index.
add(MenuItem) - Method in class java.awt.Menu
Adds the specified menu item to this menu.
add(String) - Method in class java.awt.Menu
Adds an item with the specified label to this menu.
add(Menu) - Method in class java.awt.MenuBar
Adds the specified menu to the menu bar.
add(int, int) - Method in class java.awt.Rectangle
Adds a point, specified by the integer arguments newx,newy to the bounds of this Rectangle.
add(Point) - Method in class java.awt.Rectangle
Adds the specified Point to the bounds of this Rectangle.
add(Rectangle) - Method in class java.awt.Rectangle
Adds a Rectangle to this Rectangle.
add(RenderingHints) - Method in class java.awt.RenderingHints
Adds all of the keys and corresponding values from the specified RenderingHints object to this RenderingHints object.
add(TrayIcon) - Method in class java.awt.SystemTray
Adds a TrayIcon to the SystemTray.
add(Object) - Method in class java.beans.beancontext.BeanContextSupport
Adds/nests a child within this BeanContext.
add(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this + augend), and whose scale is max(this.scale(), augend.scale()).
add(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this + augend), with rounding according to the context settings.
add(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this + val).
add(URI, HttpCookie) - Method in interface java.net.CookieStore
Adds one HTTP cookie to the store.
add(Permission) - Method in class java.security.PermissionCollection
Adds a permission object to the current collection of permission objects.
add(Permission) - Method in class java.security.Permissions
Adds a permission object to the PermissionCollection for the class the permission belongs to.
add(E) - Method in class java.util.AbstractCollection
Ensures that this collection contains the specified element (optional operation).
add(E) - Method in class java.util.AbstractList
Appends the specified element to the end of this list (optional operation).
add(int, E) - Method in class java.util.AbstractList
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in class java.util.AbstractQueue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(int, E) - Method in class java.util.AbstractSequentialList
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
add(E) - Method in class java.util.ArrayList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.ArrayList
Inserts the specified element at the specified position in this list.
add(int, int) - Method in class java.util.Calendar
Adds or subtracts the specified amount of time to the given calendar field, based on the calendar's rules.
add(E) - Method in interface java.util.Collection
Ensures that this collection contains the specified element (optional operation).
add(E) - Method in class java.util.concurrent.ArrayBlockingQueue
Inserts the specified element at the tail of this queue if it is possible to do so immediately without exceeding the queue's capacity, returning true upon success and throwing an IllegalStateException if this queue is full.
add(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(E) - Method in interface java.util.concurrent.BlockingQueue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the tail of this deque.
add(E) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Inserts the specified element at the tail of this queue.
add(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Inserts the specified element at the specified position in this list.
add(E) - Method in class java.util.concurrent.CopyOnWriteArraySet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.concurrent.DelayQueue
Inserts the specified element into this delay queue.
add(E) - Method in class java.util.concurrent.LinkedBlockingDeque
Inserts the specified element at the end of this deque unless it would violate capacity restrictions.
add(E) - Method in class java.util.concurrent.LinkedTransferQueue
Inserts the specified element at the tail of this queue.
add(E) - Method in class java.util.concurrent.PriorityBlockingQueue
Inserts the specified element into this priority queue.
add(E) - Method in interface java.util.Deque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(int, int) - Method in class java.util.GregorianCalendar
Adds the specified (signed) amount of time to the given calendar field, based on the calendar's rules.
add(E) - Method in class java.util.HashSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.LinkedList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.LinkedList
Inserts the specified element at the specified position in this list.
add(E) - Method in interface java.util.List
Appends the specified element to the end of this list (optional operation).
add(int, E) - Method in interface java.util.List
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in interface java.util.ListIterator
Inserts the specified element into the list (optional operation).
add(E) - Method in class java.util.PriorityQueue
Inserts the specified element into this priority queue.
add(E) - Method in interface java.util.Queue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(E) - Method in interface java.util.Set
Adds the specified element to this set if it is not already present (optional operation).
add(E) - Method in class java.util.TreeSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.Vector
Appends the specified element to the end of this Vector.
add(int, E) - Method in class java.util.Vector
Inserts the specified element at the specified position in this Vector.
add(AccessibleRelation) - Method in class javax.accessibility.AccessibleRelationSet
Adds a new relation to the current relation set.
add(AccessibleState) - Method in class javax.accessibility.AccessibleStateSet
Adds a new state to the current state set if it is not already present.
add(Attribute) - Method in class javax.management.AttributeList
Adds the Attribute specified as the last element of the list.
add(int, Attribute) - Method in class javax.management.AttributeList
Inserts the attribute specified as an element at the position specified.
add(Object) - Method in class javax.management.AttributeList
Appends the specified element to the end of this list.
add(int, Object) - Method in class javax.management.AttributeList
Inserts the specified element at the specified position in this list.
add(Role) - Method in class javax.management.relation.RoleList
Adds the Role specified as the last element of the list.
add(int, Role) - Method in class javax.management.relation.RoleList
Inserts the role specified as an element at the position specified.
add(Object) - Method in class javax.management.relation.RoleList
add(int, Object) - Method in class javax.management.relation.RoleList
add(RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Adds the RoleUnresolved specified as the last element of the list.
add(int, RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Inserts the unresolved role specified as an element at the position specified.
add(Object) - Method in class javax.management.relation.RoleUnresolvedList
add(int, Object) - Method in class javax.management.relation.RoleUnresolvedList
add(String) - Method in class javax.naming.CompositeName
Adds a single component to the end of this composite name.
add(int, String) - Method in class javax.naming.CompositeName
Adds a single component at a specified position within this composite name.
add(String) - Method in class javax.naming.CompoundName
Adds a single component to the end of this compound name.
add(int, String) - Method in class javax.naming.CompoundName
Adds a single component at a specified position within this compound name.
add(Object) - Method in interface javax.naming.directory.Attribute
Adds a new value to the attribute.
add(int, Object) - Method in interface javax.naming.directory.Attribute
Adds an attribute value to the ordered list of attribute values.
add(Object) - Method in class javax.naming.directory.BasicAttribute
Adds a new value to this attribute.
add(int, Object) - Method in class javax.naming.directory.BasicAttribute
add(String) - Method in class javax.naming.ldap.LdapName
Adds a single component to the end of this LDAP name.
add(Rdn) - Method in class javax.naming.ldap.LdapName
Adds a single RDN to the end of this LDAP name.
add(int, String) - Method in class javax.naming.ldap.LdapName
Adds a single component at a specified position within this LDAP name.
add(int, Rdn) - Method in class javax.naming.ldap.LdapName
Adds a single RDN at a specified position within this LDAP name.
add(String) - Method in interface javax.naming.Name
Adds a single component to the end of this name.
add(int, String) - Method in interface javax.naming.Name
Adds a single component at a specified position within this name.
add(RefAddr) - Method in class javax.naming.Reference
Adds an address to the end of the list of addresses.
add(int, RefAddr) - Method in class javax.naming.Reference
Adds an address to the list of addresses at index posn.
add(Attribute) - Method in interface javax.print.attribute.AttributeSet
Adds the specified attribute to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value.
add(Attribute) - Method in interface javax.print.attribute.DocAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in class javax.print.attribute.HashAttributeSet
Adds the specified attribute to this attribute set if it is not already present, first removing any existing in the same attribute category as the specified attribute value.
add(Attribute) - Method in interface javax.print.attribute.PrintJobAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in interface javax.print.attribute.PrintRequestAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in interface javax.print.attribute.PrintServiceAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(JobStateReason) - Method in class javax.print.attribute.standard.JobStateReasons
Adds the specified element to this job state reasons attribute if it is not already present.
add(MidiEvent) - Method in class javax.sound.midi.Track
Adds a new event to the track.
add(AbstractButton) - Method in class javax.swing.ButtonGroup
Adds the button to the group.
add(int, E) - Method in class javax.swing.DefaultListModel
Inserts the specified element at the specified position in this list.
add(Class<T>, T) - Method in class javax.swing.event.EventListenerList
Adds the listener as a listener of the specified type.
add(JMenuItem) - Method in class javax.swing.JMenu
Appends a menu item to the end of this menu.
add(Component) - Method in class javax.swing.JMenu
Appends a component to the end of this menu.
add(Component, int) - Method in class javax.swing.JMenu
Adds the specified component to this container at the given position.
add(String) - Method in class javax.swing.JMenu
Creates a new menu item with the specified text and appends it to the end of this menu.
add(Action) - Method in class javax.swing.JMenu
Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
add(JMenu) - Method in class javax.swing.JMenuBar
Appends the specified menu to the end of the menu bar.
add(JMenuItem) - Method in class javax.swing.JPopupMenu
Appends the specified menu item to the end of this menu.
add(String) - Method in class javax.swing.JPopupMenu
Creates a new menu item with the specified text and appends it to the end of this menu.
add(Action) - Method in class javax.swing.JPopupMenu
Appends a new menu item to the end of the menu which dispatches the specified Action object.
add(Component) - Method in class javax.swing.JTabbedPane
Adds a component with a tab title defaulting to the name of the component which is the result of calling component.getName.
add(String, Component) - Method in class javax.swing.JTabbedPane
Adds a component with the specified tab title.
add(Component, int) - Method in class javax.swing.JTabbedPane
Adds a component at the specified tab index with a tab title defaulting to the name of the component.
add(Component, Object) - Method in class javax.swing.JTabbedPane
Adds a component to the tabbed pane.
add(Component, Object, int) - Method in class javax.swing.JTabbedPane
Adds a component at the specified tab index.
add(Action) - Method in class javax.swing.JToolBar
Adds a new JButton which dispatches the action.
add(MutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
add(Duration) - Method in class javax.xml.datatype.Duration
Computes a new duration whose value is this+rhs.
add(Duration) - Method in class javax.xml.datatype.XMLGregorianCalendar
Add duration to this instance.
add(XMLEvent) - Method in interface javax.xml.stream.util.XMLEventConsumer
This method adds an event to the consumer.
add(XMLEvent) - Method in interface javax.xml.stream.XMLEventWriter
Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
add(XMLEventReader) - Method in interface javax.xml.stream.XMLEventWriter
Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
add(GSSName, int, int, Oid, int) - Method in interface org.ietf.jgss.GSSCredential
Adds a mechanism specific credential-element to an existing credential.
add(String) - Method in class org.omg.CORBA.ContextList
Adds a String object to this ContextList object.
add(TypeCode) - Method in class org.omg.CORBA.ExceptionList
Adds a TypeCode object describing an exception to this ExceptionList object.
add(int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
ADD_ATTRIBUTE - Static variable in interface javax.naming.directory.DirContext
This constant specifies to add an attribute with the specified values.
add_client_request_interceptor(ClientRequestInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add a client-side request Interceptor to the list of client-side request Interceptors.
ADD_FILE - Static variable in enum java.nio.file.attribute.AclEntryPermission
Permission to add a new file to a directory (equal to AclEntryPermission.WRITE_DATA)
add_in_arg() - Method in class org.omg.CORBA.Request
Creates an input argument and adds it to this Request object.
add_inout_arg() - Method in class org.omg.CORBA.Request
Adds an input/output argument to this Request object.
add_ior_component(TaggedComponent) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
add_ior_component_to_profile(TaggedComponent, int) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
add_ior_interceptor(IORInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add an IOR Interceptor to the list of IOR Interceptors.
add_item(String, int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
add_named_in_arg(String) - Method in class org.omg.CORBA.Request
Creates an input argument with the given name and adds it to this Request object.
add_named_inout_arg(String) - Method in class org.omg.CORBA.Request
Adds an input/output argument with the given name to this Request object.
add_named_out_arg(String) - Method in class org.omg.CORBA.Request
Adds an output argument with the given name to this Request object.
add_out_arg() - Method in class org.omg.CORBA.Request
Adds an output argument to this Request object.
ADD_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The SetOverrideType constant for the enum value ADD_OVERRIDE.
add_reply_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Allows Interceptors to add service contexts to the request.
add_request_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Allows Interceptors to add service contexts to the request.
add_server_request_interceptor(ServerRequestInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add a server-side request Interceptor to the list of server-side request Interceptors.
ADD_SUBDIRECTORY - Static variable in enum java.nio.file.attribute.AclEntryPermission
Permission to create a subdirectory to a directory (equal to AclEntryPermission.APPEND_DATA)
add_value(String, Any, int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
addAccessibleSelection(int) - Method in class java.awt.List.AccessibleAWTList
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in interface javax.accessibility.AccessibleSelection
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JList.AccessibleJList
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JMenu.AccessibleJMenu
Selects the ith menu in the menu.
addAccessibleSelection(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Selects the nth menu in the menu bar, forcing it to pop up.
addAccessibleSelection(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
addAccessibleSelection(int) - Method in class javax.swing.JTable.AccessibleJTable
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree
Adds the specified selected item in the object to the object's selection.
addActionForKeyStroke(KeyStroke, Action) - Method in interface javax.swing.text.Keymap
Adds a binding to the keymap.
addActionListener(ActionListener) - Method in class java.awt.Button
Adds the specified action listener to receive action events from this button.
addActionListener(ActionListener) - Method in class java.awt.List
Adds the specified action listener to receive action events from this list.
addActionListener(ActionListener) - Method in class java.awt.MenuItem
Adds the specified action listener to receive action events from this menu item.
addActionListener(ActionListener) - Method in class java.awt.TextField
Adds the specified action listener to receive action events from this text field.
addActionListener(ActionListener) - Method in class java.awt.TrayIcon
Adds the specified action listener to receive ActionEvents from this TrayIcon.
addActionListener(ActionListener) - Method in class javax.swing.AbstractButton
Adds an ActionListener to the button.
addActionListener(ActionListener) - Method in interface javax.swing.ButtonModel
Adds an ActionListener to the model.
addActionListener(ActionListener) - Method in interface javax.swing.ComboBoxEditor
Add an ActionListener.
addActionListener(ActionListener) - Method in class javax.swing.DefaultButtonModel
Adds an ActionListener to the model.
addActionListener(ActionListener) - Method in class javax.swing.JComboBox
Adds an ActionListener.
addActionListener(ActionListener) - Method in class javax.swing.JFileChooser
Adds an ActionListener to the file chooser.
addActionListener(ActionListener) - Method in class javax.swing.JTextField
Adds the specified action listener to receive action events from this textfield.
addActionListener(ActionListener) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
addActionListener(ActionListener) - Method in class javax.swing.Timer
Adds an action listener to the Timer.
addAdjustmentListener(AdjustmentListener) - Method in interface java.awt.Adjustable
Adds a listener to receive adjustment events when the value of the adjustable object changes.
addAdjustmentListener(AdjustmentListener) - Method in class java.awt.Scrollbar
Adds the specified adjustment listener to receive instances of AdjustmentEvent from this scroll bar.
addAdjustmentListener(AdjustmentListener) - Method in class java.awt.ScrollPaneAdjustable
Adds the specified adjustment listener to receive adjustment events from this ScrollPaneAdjustable.
addAdjustmentListener(AdjustmentListener) - Method in class javax.swing.JScrollBar
Adds an AdjustmentListener.
addAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
add Collection to set of Children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
addAll(Collection<? extends E>) - Method in class java.util.AbstractCollection
Adds all of the elements in the specified collection to this collection (optional operation).
addAll(int, Collection<? extends E>) - Method in class java.util.AbstractList
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.AbstractQueue
Adds all of the elements in the specified collection to this queue.
addAll(int, Collection<? extends E>) - Method in class java.util.AbstractSequentialList
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.ArrayList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.ArrayList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in interface java.util.Collection
Adds all of the elements in the specified collection to this collection (optional operation).
addAll(Collection<? super T>, T...) - Static method in class java.util.Collections
Adds all of the specified elements to the specified collection.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Appends all of the elements in the specified collection to the end of this deque, in the order that they are returned by the specified collection's iterator.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Appends all of the elements in the specified collection to the end of this queue, in the order that they are returned by the specified collection's iterator.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Adds all of the elements in the specified collection to this set if they're not already present.
addAll(Collection<? extends E>) - Method in class java.util.LinkedList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.LinkedList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in interface java.util.List
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation).
addAll(int, Collection<? extends E>) - Method in interface java.util.List
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in interface java.util.Set
Adds all of the elements in the specified collection to this set if they're not already present (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.TreeSet
Adds all of the elements in the specified collection to this set.
addAll(Collection<? extends E>) - Method in class java.util.Vector
Appends all of the elements in the specified Collection to the end of this Vector, in the order that they are returned by the specified Collection's Iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.Vector
Inserts all of the elements in the specified Collection into this Vector at the specified position.
addAll(AccessibleRelation[]) - Method in class javax.accessibility.AccessibleRelationSet
Adds all of the relations to the existing relation set.
addAll(AccessibleState[]) - Method in class javax.accessibility.AccessibleStateSet
Adds all of the states to the existing state set.
addAll(AttributeList) - Method in class javax.management.AttributeList
Appends all the elements in the AttributeList specified to the end of the list, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(int, AttributeList) - Method in class javax.management.AttributeList
Inserts all of the elements in the AttributeList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(Collection<?>) - Method in class javax.management.AttributeList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
addAll(int, Collection<?>) - Method in class javax.management.AttributeList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(RoleList) - Method in class javax.management.relation.RoleList
Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(int, RoleList) - Method in class javax.management.relation.RoleList
Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(Collection<?>) - Method in class javax.management.relation.RoleList
addAll(int, Collection<?>) - Method in class javax.management.relation.RoleList
addAll(RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAll(int, RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAll(Collection<?>) - Method in class javax.management.relation.RoleUnresolvedList
addAll(int, Collection<?>) - Method in class javax.management.relation.RoleUnresolvedList
addAll(Name) - Method in class javax.naming.CompositeName
Adds the components of a composite name -- in order -- to the end of this composite name.
addAll(int, Name) - Method in class javax.naming.CompositeName
Adds the components of a composite name -- in order -- at a specified position within this composite name.
addAll(Name) - Method in class javax.naming.CompoundName
Adds the components of a compound name -- in order -- to the end of this compound name.
addAll(int, Name) - Method in class javax.naming.CompoundName
Adds the components of a compound name -- in order -- at a specified position within this compound name.
addAll(Name) - Method in class javax.naming.ldap.LdapName
Adds the components of a name -- in order -- to the end of this name.
addAll(List<Rdn>) - Method in class javax.naming.ldap.LdapName
Adds the RDNs of a name -- in order -- to the end of this name.
addAll(int, Name) - Method in class javax.naming.ldap.LdapName
Adds the components of a name -- in order -- at a specified position within this name.
addAll(int, List<Rdn>) - Method in class javax.naming.ldap.LdapName
Adds the RDNs of a name -- in order -- at a specified position within this name.
addAll(Name) - Method in interface javax.naming.Name
Adds the components of a name -- in order -- to the end of this name.
addAll(int, Name) - Method in interface javax.naming.Name
Adds the components of a name -- in order -- at a specified position within this name.
addAll(AttributeSet) - Method in interface javax.print.attribute.AttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.DocAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in class javax.print.attribute.HashAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintJobAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintRequestAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintServiceAttributeSet
Adds all of the elements in the specified set to this attribute.
addAllAbsent(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends all of the elements in the specified collection that are not already contained in this list, to the end of this list, in the order that they are returned by the specified collection's iterator.
addAncestorListener(AncestorListener) - Method in class javax.swing.JComponent
Registers listener so that it will receive AncestorEvents when it or any of its ancestors move or are made visible or invisible.
addAndGet(int) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically adds the given value to the current value.
addAndGet(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically adds the given value to the element at index i.
addAndGet(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically adds the given value to the current value of the field of the given object managed by this updater.
addAndGet(long) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically adds the given value to the current value.
addAndGet(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically adds the given value to the element at index i.
addAndGet(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically adds the given value to the current value of the field of the given object managed by this updater.
addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap.SOAPMessage
Adds the given AttachmentPart object to this SOAPMessage object.
addAttribute(AttributedCharacterIterator.Attribute, Object) - Method in class java.text.AttributedString
Adds an attribute to the entire string.
addAttribute(AttributedCharacterIterator.Attribute, Object, int, int) - Method in class java.text.AttributedString
Adds an attribute to a subrange of the string.
addAttribute(String, String, int, boolean, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that may be set to an arbitrary value.
addAttribute(String, String, int, boolean, String, List<String>) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a set of enumerated values.
addAttribute(String, String, int, boolean, String, String, String, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a range of values.
addAttribute(String, String, int, boolean, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a list of values.
addAttribute(Object, Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Adds an attribute to the element.
addAttribute(AttributeSet, Object, Object) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Adds an attribute to the given set, and returns the new representative set.
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text.html.StyleSheet
Adds an attribute to the given set, and returns the new representative set.
addAttribute(Object, Object) - Method in interface javax.swing.text.MutableAttributeSet
Creates a new attribute set similar to this one except that it contains an attribute with the given name and value.
addAttribute(Object, Object) - Method in class javax.swing.text.SimpleAttributeSet
Adds an attribute to the list.
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text.StyleContext
Adds an attribute to the given set, and returns the new representative set.
addAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds an attribute.
addAttribute(Name, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttribute(QName, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Add an attribute to the end of the list, setting its "specified" flag to true.
addAttribute(String, String, String) - Method in class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Add an attribute to an attribute list.
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.helpers.AttributesImpl
Add an attribute to the end of the list.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
Registers an object which implements the NotificationListener interface as a listener.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int) - Method in class java.text.AttributedString
Adds a set of attributes to a subrange of the string.
addAttributes(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Adds a set of attributes to the element.
addAttributes(AttributeSet, AttributeSet) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Adds a set of attributes to the element.
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Adds a set of attributes to the element.
addAttributes(AttributeSet) - Method in interface javax.swing.text.MutableAttributeSet
Creates a new attribute set similar to this one except that it contains the given attributes and values.
addAttributes(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Adds a set of attributes to the list.
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.StyleContext
Adds a set of attributes to the element.
addAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds a set of attributes to the element.
addAuxiliaryLookAndFeel(LookAndFeel) - Static method in class javax.swing.UIManager
Adds a LookAndFeel to the list of auxiliary look and feels.
addAWTEventListener(AWTEventListener, long) - Method in class java.awt.Toolkit
Adds an AWTEventListener to receive all AWTEvents dispatched system-wide that conform to the given eventMask.
addBatch() - Method in interface java.sql.PreparedStatement
Adds a set of parameters to this PreparedStatement object's batch of commands.
addBatch(String) - Method in interface java.sql.Statement
Adds the given SQL command to the current list of commmands for this Statement object.
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in interface java.beans.beancontext.BeanContext
Adds the specified BeanContextMembershipListener to receive BeanContextMembershipEvents from this BeanContext whenever it adds or removes a child Component(s).
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in class java.beans.beancontext.BeanContextSupport
Adds a BeanContextMembershipListener
addBeanContextServicesListener(BeanContextServicesListener) - Method in interface java.beans.beancontext.BeanContextServices
Adds a BeanContextServicesListener to this BeanContext
addBeanContextServicesListener(BeanContextServicesListener) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a BeanContextServicesListener
addBody() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
addBodyElement(Name) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
addBodyElement(QName) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
addBooleanAttribute(String, String, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by the enumerated values TRUE and FALSE, with a datatype of DATATYPE_BOOLEAN.
addButtonComponents(Container, Object[], int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates the appropriate object to represent each of the objects in buttons and adds it to container.
addCaretListener(CaretListener) - Method in class javax.swing.text.JTextComponent
Adds a caret listener for notification of any changes to the caret.
addCellEditorListener(CellEditorListener) - Method in class javax.swing.AbstractCellEditor
Adds a CellEditorListener to the listener list.
addCellEditorListener(CellEditorListener) - Method in interface javax.swing.CellEditor
Adds a listener to the list that's notified when the editor stops, or cancels editing.
addCellEditorListener(CellEditorListener) - Method in class javax.swing.tree.DefaultTreeCellEditor
Adds the CellEditorListener.
addCertificate(Certificate) - Method in class java.security.Identity
Deprecated.
Adds a certificate for this identity.
addCertPathChecker(PKIXCertPathChecker) - Method in class java.security.cert.PKIXParameters
Adds a PKIXCertPathChecker to the list of certification path checkers.
addCertStore(CertStore) - Method in class java.security.cert.PKIXParameters
Adds a CertStore to the end of the list of CertStores used in finding certificates and CRLs.
addChangeListener(ChangeListener) - Method in class javax.swing.AbstractButton
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in class javax.swing.AbstractSpinnerModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.BoundedRangeModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.ButtonModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in interface javax.swing.colorchooser.ColorSelectionModel
Adds listener as a listener to changes in the model.
addChangeListener(ChangeListener) - Method in class javax.swing.colorchooser.DefaultColorSelectionModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultBoundedRangeModel
Adds a ChangeListener.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultButtonModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultSingleSelectionModel
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in class javax.swing.JProgressBar
Adds the specified ChangeListener to the progress bar.
addChangeListener(ChangeListener) - Method in class javax.swing.JSlider
Adds a ChangeListener to the slider.
addChangeListener(ChangeListener) - Method in class javax.swing.JSpinner
Adds a listener to the list that is notified each time a change to the model occurs.
addChangeListener(ChangeListener) - Method in class javax.swing.JTabbedPane
Adds a ChangeListener to this tabbedpane.
addChangeListener(ChangeListener) - Method in class javax.swing.JViewport
Adds a ChangeListener to the list that is notified each time the view's size, position, or the viewport's extent size has changed.
addChangeListener(ChangeListener) - Method in class javax.swing.MenuSelectionManager
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in interface javax.swing.SingleSelectionModel
Adds listener as a listener to changes in the model.
addChangeListener(ChangeListener) - Method in interface javax.swing.SpinnerModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.text.Caret
Adds a listener to track whenever the caret position has been changed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.DefaultCaret
Adds a listener to track whenever the caret position has been changed.
addChangeListener(ChangeListener) - Method in interface javax.swing.text.Style
Adds a listener to track whenever an attribute has been changed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext
Adds a listener to track when styles are added or removed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds a change listener.
addChildElement(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds an existing element to the list of legal children for a given parent node type.
addChildElement(Name) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
addChildElement(QName) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
addChildElement(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
addChildElement(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
addChildElement(String, String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
addChildElement(SOAPElement) - Method in interface javax.xml.soap.SOAPElement
Add a SOAPElement as a child of this SOAPElement instance.
addChoosableFileFilter(FileFilter) - Method in class javax.swing.JFileChooser
Adds a filter to the list of user choosable file filters.
addChooserPanel(AbstractColorChooserPanel) - Method in class javax.swing.JColorChooser
Adds a color chooser panel to the color chooser.
addColumn(TableColumn) - Method in class javax.swing.JTable
Appends aColumn to the end of the array of columns held by this JTable's column model.
addColumn(TableColumn) - Method in class javax.swing.table.DefaultTableColumnModel
Appends aColumn to the end of the tableColumns array.
addColumn(Object) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(Object, Vector) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(Object, Object[]) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(TableColumn) - Method in interface javax.swing.table.TableColumnModel
Appends aColumn to the end of the tableColumns array.
addColumnModelListener(TableColumnModelListener) - Method in class javax.swing.table.DefaultTableColumnModel
Adds a listener for table column model events.
addColumnModelListener(TableColumnModelListener) - Method in interface javax.swing.table.TableColumnModel
Adds a listener for table column model events.
addColumnSelectionInterval(int, int) - Method in class javax.swing.JTable
Adds the columns from index0 to index1, inclusive, to the current selection.
addComponent(Component) - Method in class javax.swing.GroupLayout.Group
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.Group
Adds a Component to this Group with the specified size.
addComponent(Component) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this Group with the specified size.
addComponent(Component, GroupLayout.Alignment) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this ParallelGroup with the specified alignment.
addComponent(Component, GroupLayout.Alignment, int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this ParallelGroup with the specified alignment and size.
addComponent(Component) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group.
addComponent(boolean, Component) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group with the specified size.
addComponent(boolean, Component, int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group with the specified size.
addComponentListener(ComponentListener) - Method in class java.awt.Component
Adds the specified component listener to receive component events from this component.
addConnectionEventListener(ConnectionEventListener) - Method in interface javax.sql.PooledConnection
Registers the given event listener so that it will be notified when an event occurs on this PooledConnection object.
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.remote.JMXConnector
Adds a listener to be informed of changes in connection status.
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.remote.rmi.RMIConnector
addConsumer(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Adds the specified ImageConsumer to the list of consumers interested in data for the filtered image.
addConsumer(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Registers an ImageConsumer with the ImageProducer for access to the image data during a later reconstruction of the Image.
addConsumer(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Adds an ImageConsumer to the list of consumers interested in data for this image.
addConsumer(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Adds an ImageConsumer to the list of consumers interested in data for this image.
addContainerGap() - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between an edge the container and components that touch the border of the container.
addContainerGap(int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between one edge of the container and the next or previous Component with the specified size.
addContainerListener(ContainerListener) - Method in class java.awt.Container
Adds the specified container listener to receive container events from this container.
addContent(char[], int, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds some text with the current character attributes.
addContent(char[], int, int, boolean) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds some text with the current character attributes.
addControlButtons() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
addControllerEventListener(ControllerEventListener, int[]) - Method in interface javax.sound.midi.Sequencer
Registers a controller event listener to receive notification whenever the sequencer processes a control-change event of the requested type or types.
addCSSAttribute(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html.StyleSheet
Adds a CSS attribute to the given set.
addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html.StyleSheet
Adds a CSS attribute to the given set.
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal.MetalTheme
Adds values specific to this theme to the defaults table.
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal.OceanTheme
Add this theme's custom entries to the defaults table.
addDetail() - Method in interface javax.xml.soap.SOAPFault
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
addDetailEntry(Name) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given name and adds it to this Detail object.
addDetailEntry(QName) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given QName and adds it to this Detail object.
addDirtyRegion(JComponent, int, int, int, int) - Method in class javax.swing.RepaintManager
Add a component in the list of components that should be refreshed.
addDirtyRegion(Window, int, int, int, int) - Method in class javax.swing.RepaintManager
Adds window to the list of Components that need to be repainted.
addDirtyRegion(Applet, int, int, int, int) - Method in class javax.swing.RepaintManager
Adds applet to the list of Components that need to be repainted.
addDocument(Document) - Method in interface javax.xml.soap.SOAPBody
Adds the root node of the DOM Document to this SOAPBody object.
addDocumentListener(DocumentListener) - Method in class javax.swing.text.AbstractDocument
Adds a document listener for notification of any changes.
addDocumentListener(DocumentListener) - Method in class javax.swing.text.DefaultStyledDocument
Adds a document listener for notification of any changes.
addDocumentListener(DocumentListener) - Method in interface javax.swing.text.Document
Registers the given observer to begin receiving notifications when changes are made to the document.
addDragGestureListener(DragGestureListener) - Method in class java.awt.dnd.DragGestureRecognizer
Register a new DragGestureListener.
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSource
Adds the specified DragSourceListener to this DragSource to receive drag source events during drag operations intiated with this DragSource.
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSourceContext
Add a DragSourceListener to this DragSourceContext if one has not already been added.
addDragSourceMotionListener(DragSourceMotionListener) - Method in class java.awt.dnd.DragSource
Adds the specified DragSourceMotionListener to this DragSource to receive drag motion events during drag operations intiated with this DragSource.
addDropTargetListener(DropTargetListener) - Method in class java.awt.dnd.DropTarget
Adds a new DropTargetListener (UNICAST SOURCE).
addEdit(UndoableEdit) - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Adds a document edit.
addEdit(UndoableEdit) - Method in class javax.swing.undo.AbstractUndoableEdit
This default implementation returns false.
addEdit(UndoableEdit) - Method in class javax.swing.undo.CompoundEdit
If this edit is inProgress, accepts anEdit and returns true.
addEdit(UndoableEdit) - Method in interface javax.swing.undo.UndoableEdit
Adds an UndoableEdit to this UndoableEdit.
addEdit(UndoableEdit) - Method in class javax.swing.undo.UndoManager
Adds an UndoableEdit to this UndoManager, if it's possible.
addEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
addElement(E) - Method in class java.util.Vector
Adds the specified component to the end of this vector, increasing its size by one.
addElement(String, String, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new element type to this metadata document format with a child policy other than CHILD_POLICY_REPEAT.
addElement(String, String, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new element type to this metadata document format with a child policy of CHILD_POLICY_REPEAT.
addElement(Object) - Method in class javax.swing.DefaultComboBoxModel
addElement(E) - Method in class javax.swing.DefaultListModel
Adds the specified component to the end of this list.
addElement(Object) - Method in interface javax.swing.MutableComboBoxModel
Adds an item at the end of the model.
addEntry(Principal, AclEntry) - Method in interface java.security.acl.Acl
Adds an ACL entry to this ACL.
addEventListener(String, EventListener, boolean) - Method in interface org.w3c.dom.events.EventTarget
This method allows the registration of event listeners on the event target.
addFault() - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFaultReasonText(String, Locale) - Method in interface javax.xml.soap.SOAPFault
Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
addFirst(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the front of this deque.
addFirst(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the front of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addFirst(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the front of this deque.
addFirst(E) - Method in class java.util.concurrent.LinkedBlockingDeque
addFirst(E) - Method in interface java.util.Deque
Inserts the specified element at the front of this deque if it is possible to do so immediately without violating capacity restrictions.
addFirst(E) - Method in class java.util.LinkedList
Inserts the specified element at the beginning of this list.
addFlavorForUnencodedNative(String, DataFlavor) - Method in class java.awt.datatransfer.SystemFlavorMap
Adds a mapping from a single String native to a single DataFlavor.
addFlavorListener(FlavorListener) - Method in class java.awt.datatransfer.Clipboard
Registers the specified FlavorListener to receive FlavorEvents from this clipboard.
addFocusListener(FocusListener) - Method in class java.awt.Component.AccessibleAWTComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class java.awt.Component
Adds the specified focus listener to receive focus events from this component when this component gains input focus.
addFocusListener(FocusListener) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in interface javax.accessibility.AccessibleComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
addFocusListener(FocusListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
addFocusListener(FocusListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
addFocusListener(FocusListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addGap(int) - Method in class javax.swing.GroupLayout.Group
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.Group
Adds a gap to this Group with the specified size.
addGap(int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a gap to this Group with the specified size.
addGap(int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a gap to this Group with the specified size.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.Group
Adds a Group to this Group.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Group to this Group.
addGroup(GroupLayout.Alignment, GroupLayout.Group) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Group to this ParallelGroup with the specified alignment.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Group to this Group.
addGroup(boolean, GroupLayout.Group) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Group to this Group.
addHandler(Handler) - Method in class java.util.logging.Logger
Add a log Handler to receive logging messages.
addHandshakeCompletedListener(HandshakeCompletedListener) - Method in class javax.net.ssl.SSLSocket
Registers an event listener to receive notifications that an SSL handshake has completed on this connection.
addHeader(String, String) - Method in class javax.xml.soap.MimeHeaders
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
addHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
addHeaderElement(Name) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
addHierarchyBoundsListener(HierarchyBoundsListener) - Method in class java.awt.Component
Adds the specified hierarchy bounds listener to receive hierarchy bounds events from this component when the hierarchy to which this container belongs changes.
addHierarchyListener(HierarchyListener) - Method in class java.awt.Component
Adds the specified hierarchy listener to receive hierarchy changed events from this component when the hierarchy to which this container belongs changes.
addHighlight(int, int, Highlighter.HighlightPainter) - Method in class javax.swing.text.DefaultHighlighter
Adds a highlight to the view.
addHighlight(int, int, Highlighter.HighlightPainter) - Method in interface javax.swing.text.Highlighter
Adds a highlight to the view.
addHyperlinkListener(HyperlinkListener) - Method in class javax.swing.JEditorPane
Adds a hyperlink listener for notification of any changes, for example when a link is selected and entered.
addIcon(Container) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates and adds a JLabel representing the icon returned from getIcon to top.
addIdentity(Identity) - Method in class java.security.IdentityScope
Deprecated.
Adds an identity to this identity scope.
addIfAbsent(E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Append the element if not present.
addIIOReadProgressListener(IIOReadProgressListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadProgressListener to the list of registered progress listeners.
addIIOReadUpdateListener(IIOReadUpdateListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadUpdateListener to the list of registered update listeners.
addIIOReadWarningListener(IIOReadWarningListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadWarningListener to the list of registered warning listeners.
addIIOWriteProgressListener(IIOWriteProgressListener) - Method in class javax.imageio.ImageWriter
Adds an IIOWriteProgressListener to the list of registered progress listeners.
addIIOWriteWarningListener(IIOWriteWarningListener) - Method in class javax.imageio.ImageWriter
Adds an IIOWriteWarningListener to the list of registered warning listeners.
addImage(Image, int) - Method in class java.awt.MediaTracker
Adds an image to the list of images being tracked by this media tracker.
addImage(Image, int, int, int) - Method in class java.awt.MediaTracker
Adds a scaled image to the list of images being tracked by this media tracker.
addImpl(Component, Object, int) - Method in class java.awt.Container
Adds the specified component to this container at the specified index.
addImpl(Component, Object, int) - Method in class java.awt.ScrollPane
Adds the specified component to this scroll pane container.
addImpl(Component, Object, int) - Method in class javax.swing.AbstractButton
Adds the specified component to this container at the specified index, refer to Container.addImpl(Component, Object, int) for a complete description of this method.
addImpl(Component, Object, int) - Method in class javax.swing.CellRendererPane
If the specified component is already a child of this then we don't bother doing anything - stacking order doesn't matter for cell renderer components (CellRendererPane doesn't paint anyway).<
addImpl(Component, Object, int) - Method in class javax.swing.JApplet
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JDesktopPane
Adds the specified component to this container at the specified index.
addImpl(Component, Object, int) - Method in class javax.swing.JDialog
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JFrame
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JInternalFrame
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JLayer
This method is not supported by JLayer and always throws UnsupportedOperationException
addImpl(Component, Object, int) - Method in class javax.swing.JLayeredPane
addImpl(Component, Object, int) - Method in class javax.swing.JRootPane
Overridden to enforce the position of the glass component as the zero child.
addImpl(Component, Object, int) - Method in class javax.swing.JSplitPane
Adds the specified component to this split pane.
addImpl(Component, Object, int) - Method in class javax.swing.JToolBar
If a JButton is being added, it is initially set to be disabled.
addImpl(Component, Object, int) - Method in class javax.swing.JViewport
Sets the JViewport's one lightweight child, which can be null.
addImpl(Component, Object, int) - Method in class javax.swing.JWindow
Adds the specified child Component.
addInputMethodListener(InputMethodListener) - Method in class java.awt.Component
Adds the specified input method listener to receive input method events from this component.
addInputMethodListener(InputMethodListener) - Method in class javax.swing.text.JTextComponent
addInternal(EventListener, EventListener) - Static method in class java.awt.AWTEventMulticaster
Returns the resulting multicast listener from adding listener-a and listener-b together.
addInternalFrameListener(InternalFrameListener) - Method in class javax.swing.JInternalFrame
Adds the specified listener to receive internal frame events from this internal frame.
addInvalidComponent(JComponent) - Method in class javax.swing.RepaintManager
Mark the component as in need of layout and queue a runnable for the event dispatching thread that will validate the components first isValidateRoot() ancestor.
addIssuer(X500Principal) - Method in class java.security.cert.X509CRLSelector
Adds a name to the issuerNames criterion.
addIssuerName(String) - Method in class java.security.cert.X509CRLSelector
Denigrated, use X509CRLSelector.addIssuer(X500Principal) or X509CRLSelector.addIssuerName(byte[]) instead.
addIssuerName(byte[]) - Method in class java.security.cert.X509CRLSelector
Adds a name to the issuerNames criterion.
addItem(String) - Method in class java.awt.Choice
Obsolete as of Java 2 platform v1.1.
addItem(String) - Method in class java.awt.List
Deprecated.
replaced by add(String).
addItem(String, int) - Method in class java.awt.List
Deprecated.
replaced by add(String, int).
addItem(Object) - Method in class javax.swing.JComboBox
Adds an item to the item list.
addItemListener(ItemListener) - Method in class java.awt.Checkbox
Adds the specified item listener to receive item events from this check box.
addItemListener(ItemListener) - Method in class java.awt.CheckboxMenuItem
Adds the specified item listener to receive item events from this check box menu item.
addItemListener(ItemListener) - Method in class java.awt.Choice
Adds the specified item listener to receive item events from this Choice menu.
addItemListener(ItemListener) - Method in interface java.awt.ItemSelectable
Adds a listener to receive item events when the state of an item is changed by the user.
addItemListener(ItemListener) - Method in class java.awt.List
Adds the specified item listener to receive item events from this list.
addItemListener(ItemListener) - Method in class javax.swing.AbstractButton
Adds an ItemListener to the checkbox.
addItemListener(ItemListener) - Method in interface javax.swing.ButtonModel
Adds an ItemListener to the model.
addItemListener(ItemListener) - Method in class javax.swing.DefaultButtonModel
Adds an ItemListener to the model.
addItemListener(ItemListener) - Method in class javax.swing.JComboBox
Adds an ItemListener.
ADDITION - Static variable in interface org.w3c.dom.events.MutationEvent
The Attr was just added.
AdditionalComments - Static variable in class javax.swing.text.html.HTMLDocument
Document property key value.
addKeyEventDispatcher(KeyEventDispatcher) - Method in class java.awt.KeyboardFocusManager
Adds a KeyEventDispatcher to this KeyboardFocusManager's dispatcher chain.
addKeyEventPostProcessor(KeyEventPostProcessor) - Method in class java.awt.KeyboardFocusManager
Adds a KeyEventPostProcessor to this KeyboardFocusManager's post- processor chain.
addKeyListener(KeyListener) - Method in class java.awt.Component
Adds the specified key listener to receive key events from this component.
addKeymap(String, Keymap) - Static method in class javax.swing.text.JTextComponent
Adds a new keymap into the keymap hierarchy.
addLast(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
addLast(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the end of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addLast(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the end of this deque.
addLast(E) - Method in class java.util.concurrent.LinkedBlockingDeque
addLast(E) - Method in interface java.util.Deque
Inserts the specified element at the end of this deque if it is possible to do so immediately without violating capacity restrictions.
addLast(E) - Method in class java.util.LinkedList
Appends the specified element to the end of this list.
addLayoutComponent(Component, Object) - Method in class java.awt.BorderLayout
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class java.awt.BorderLayout
Deprecated.
replaced by addLayoutComponent(Component, Object).
addLayoutComponent(Component, Object) - Method in class java.awt.CardLayout
Adds the specified component to this card layout's internal table of names.
addLayoutComponent(String, Component) - Method in class java.awt.CardLayout
Deprecated.
replaced by addLayoutComponent(Component, Object).
addLayoutComponent(String, Component) - Method in class java.awt.FlowLayout
Adds the specified component to the layout.
addLayoutComponent(String, Component) - Method in class java.awt.GridBagLayout
Has no effect, since this layout manager does not use a per-component string.
addLayoutComponent(Component, Object) - Method in class java.awt.GridBagLayout
Adds the specified component to the layout, using the specified constraints object.
addLayoutComponent(String, Component) - Method in class java.awt.GridLayout
Adds the specified component with the specified name to the layout.
addLayoutComponent(String, Component) - Method in interface java.awt.LayoutManager
If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
addLayoutComponent(Component, Object) - Method in interface java.awt.LayoutManager2
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.BoxLayout
Not used by this class.
addLayoutComponent(Component, Object) - Method in class javax.swing.BoxLayout
Not used by this class.
addLayoutComponent(String, Component) - Method in class javax.swing.GroupLayout
Notification that a Component has been added to the parent container.
addLayoutComponent(Component, Object) - Method in class javax.swing.GroupLayout
Notification that a Component has been added to the parent container.
addLayoutComponent(String, Component) - Method in class javax.swing.JRootPane.RootLayout
addLayoutComponent(Component, Object) - Method in class javax.swing.JRootPane.RootLayout
addLayoutComponent(String, Component) - Method in class javax.swing.JSpinner.DefaultEditor
This LayoutManager method does nothing.
addLayoutComponent(String, Component) - Method in class javax.swing.OverlayLayout
Adds the specified component to the layout.
addLayoutComponent(Component, Object) - Method in class javax.swing.OverlayLayout
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Adds the component at place.
addLayoutComponent(Component, Object) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing.ScrollPaneLayout
Adds the specified component to the layout.
addLayoutComponent(String, Component) - Method in class javax.swing.SpringLayout
Has no effect, since this layout manager does not use a per-component string.
addLayoutComponent(Component, Object) - Method in class javax.swing.SpringLayout
If constraints is an instance of SpringLayout.Constraints, associates the constraints with the specified component.
addLayoutComponent(String, Component) - Method in class javax.swing.ViewportLayout
Adds the specified component to the layout.
addLineListener(LineListener) - Method in interface javax.sound.sampled.Line
Adds a listener to this line.
addListDataListener(ListDataListener) - Method in class javax.swing.AbstractListModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addListDataListener(ListDataListener) - Method in interface javax.swing.ListModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addListSelectionListener(ListSelectionListener) - Method in class javax.swing.DefaultListSelectionModel
Add a listener to the list that's notified each time a change to the selection occurs.
addListSelectionListener(ListSelectionListener) - Method in class javax.swing.JList
Adds a listener to the list, to be notified each time a change to the selection occurs; the preferred way of listening for selection state changes.
addListSelectionListener(ListSelectionListener) - Method in interface javax.swing.ListSelectionModel
Add a listener to the list that's notified each time a change to the selection occurs.
addLogger(Logger) - Method in class java.util.logging.LogManager
Add a named logger.
addMailcap(String) - Method in class javax.activation.MailcapCommandMap
Add entries to the registry.
addMember(Principal) - Method in interface java.security.acl.Group
Adds the specified member to the group.
addMenuDragMouseListener(MenuDragMouseListener) - Method in class javax.swing.JMenuItem
Adds a MenuDragMouseListener to the menu item.
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JMenuItem
Adds a MenuKeyListener to the menu item.
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JPopupMenu
Adds a MenuKeyListener to the popup menu.
addMenuListener(MenuListener) - Method in class javax.swing.JMenu
Adds a listener for menu events.
addMessageComponents(Container, GridBagConstraints, Object, int, boolean) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates the appropriate object to represent msg and places it into container.
addMetaEventListener(MetaEventListener) - Method in interface javax.sound.midi.Sequencer
Registers a meta-event listener to receive notification whenever a meta-event is encountered in the sequence and processed by the sequencer.
addMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart
Adds a MIME header with the specified name and value to this AttachmentPart object.
addMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
addMimeTypes(String) - Method in class javax.activation.MimetypesFileTypeMap
Prepend the MIME type values to the registry.
addMouseListener(MouseListener) - Method in class java.awt.Component
Adds the specified mouse listener to receive mouse events from this component.
addMouseListener(MouseListener) - Method in class java.awt.TrayIcon
Adds the specified mouse listener to receive mouse events from this TrayIcon.
addMouseMotionListener(MouseMotionListener) - Method in class java.awt.Component
Adds the specified mouse motion listener to receive mouse motion events from this component.
addMouseMotionListener(MouseMotionListener) - Method in class java.awt.TrayIcon
Adds the specified mouse listener to receive mouse-motion events from this TrayIcon.
addMouseWheelListener(MouseWheelListener) - Method in class java.awt.Component
Adds the specified mouse wheel listener to receive mouse wheel events from this component.
addMtomAttachment(DataHandler, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider MIME content data for optimized binary storage as an attachment.
addMtomAttachment(byte[], int, int, String, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider binary data for optimized binary storage as an attachment.
addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap.SOAPElement
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
addNamingListener(Name, int, NamingListener) - Method in interface javax.naming.event.EventContext
Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
addNamingListener(String, int, NamingListener) - Method in interface javax.naming.event.EventContext
Adds a listener for receiving naming events fired when the object named by the string target name and scope changes.
addNamingListener(Name, String, SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
addNamingListener(String, String, SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.
addNamingListener(Name, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
addNamingListener(String, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.AbstractPreferences
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.Preferences
Registers the specified listener to receive node change events for this node.
addNotification(String, String, Object, Date, long, long, boolean) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
addNotification(String, String, Object, Date) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
addNotification(String, String, Object, Date, long, long, boolean) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
addNotification(String, String, Object, Date) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.MBeanServerDelegate
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
Registers an object which implements the NotificationListener interface as a listener.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.NotificationBroadcaster
Adds a listener to this MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.NotificationBroadcasterSupport
Adds a listener.
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.StandardEmitterMBean
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi.RMIConnectionImpl
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
addNotify() - Method in class java.awt.Button
Creates the peer of the button.
addNotify() - Method in class java.awt.Canvas
Creates the peer of the canvas.
addNotify() - Method in class java.awt.Checkbox
Creates the peer of the Checkbox.
addNotify() - Method in class java.awt.CheckboxMenuItem
Creates the peer of the checkbox item.
addNotify() - Method in class java.awt.Choice
Creates the Choice's peer.
addNotify() - Method in class java.awt.Component
Makes this Component displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Container
Makes this Container displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Dialog
Makes this Dialog displayable by connecting it to a native screen resource.
addNotify(ComponentPeer) - Method in class java.awt.dnd.DropTarget
Notify the DropTarget that it has been associated with a Component This method is usually called from java.awt.Component.addNotify() of the Component associated with this DropTarget to notify the DropTarget that a ComponentPeer has been associated with that Component.
addNotify(DropTargetContextPeer) - Method in class java.awt.dnd.DropTargetContext
Called when associated with the DropTargetContextPeer.
addNotify() - Method in class java.awt.FileDialog
Creates the file dialog's peer.
addNotify() - Method in class java.awt.Frame
Makes this Frame displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Label
Creates the peer for this label.
addNotify() - Method in class java.awt.List
Creates the peer for the list.
addNotify() - Method in class java.awt.Menu
Creates the menu's peer.
addNotify() - Method in class java.awt.MenuBar
Creates the menu bar's peer.
addNotify() - Method in class java.awt.MenuItem
Creates the menu item's peer.
addNotify() - Method in class java.awt.Panel
Creates the Panel's peer.
addNotify() - Method in class java.awt.PopupMenu
Creates the popup menu's peer.
addNotify() - Method in class java.awt.Scrollbar
Creates the Scrollbar's peer.
addNotify() - Method in class java.awt.ScrollPane
Creates the scroll pane's peer.
addNotify() - Method in class java.awt.TextArea
Creates the TextArea's peer.
addNotify() - Method in class java.awt.TextComponent
Makes this Component displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.TextField
Creates the TextField's peer.
addNotify() - Method in class java.awt.Window
Makes this Window displayable by creating the connection to its native screen resource.
addNotify() - Method in class javax.swing.JComponent
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JLayer
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JMenuBar
Overrides JComponent.addNotify to register this menu bar with the current keyboard manager.
addNotify() - Method in class javax.swing.JRootPane
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JTable
Calls the configureEnclosingScrollPane method.
addNotify() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
addNotUnderstoodHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addObjectValue(String, Class<T>, boolean, T) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<T>, boolean, T, List<? extends T>) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<?>, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Adds the specified object in the set of observed MBeans, if this object is not already present.
addObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Adds the specified object in the set of observed MBeans.
addObserver(Observer) - Method in class java.util.Observable
Adds an observer to the set of observers for this object, provided that it is not the same as some observer already in the set.
addOwner(Principal, Principal) - Method in interface java.security.acl.Owner
Adds an owner.
addPathToName(int, String) - Method in class java.security.cert.X509CertSelector
Adds a name to the pathToNames criterion.
addPathToName(int, byte[]) - Method in class java.security.cert.X509CertSelector
Adds a name to the pathToNames criterion.
addPermission(Permission) - Method in interface java.security.acl.AclEntry
Adds the specified permission to this ACL entry.
addPoint(int, int) - Method in class java.awt.Polygon
Appends the specified coordinates to this Polygon.
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing.JComboBox
Adds a PopupMenu listener which will listen to notification messages from the popup portion of the combo box.
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing.JPopupMenu
Adds a PopupMenu listener.
addPort(QName, String, String) - Method in class javax.xml.ws.Service
Creates a new port for the service.
addPort(QName, String, String) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a new port for the service.
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.AbstractPreferences
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.Preferences
Registers the specified listener to receive preference change events for this preference node.
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between two components.
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between two components.
addPreferredGap(LayoutStyle.ComponentPlacement) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between the nearest components.
addPreferredGap(LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between the nearest components.
addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet) - Method in interface javax.print.DocPrintJob
Registers a listener for changes in the specified attributes.
addPrintJobListener(PrintJobListener) - Method in interface javax.print.DocPrintJob
Registers a listener for event occurring during this print job.
addPrintServiceAttributeListener(PrintServiceAttributeListener) - Method in interface javax.print.PrintService
Registers a listener for events on this PrintService.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component.AccessibleAWTComponent
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Component
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Container.AccessibleAWTContainer
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Container
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Container
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.SystemTray
Adds a PropertyChangeListener to the list of listeners for the specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Toolkit
Adds the specified property change listener for the named desktop property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Window
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Window
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Adds a PropertyChangeListener to this BeanContextChild in order to receive a PropertyChangeEvent whenever the specified property has changed.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Add a PropertyChangeListener for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.Customizer
Register a listener for the PropertyChange event.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Add a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Add a PropertyChangeListener for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.PropertyEditor
Adds a listener for the value change.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyEditorSupport
Adds a listener for the value change.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Packer
Registers a listener for PropertyChange events on the properties map.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Unpacker
Registers a listener for PropertyChange events on the properties map.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.util.logging.LogManager
Adds an event listener to be invoked when the logging properties are re-read.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.accessibility.AccessibleContext
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.AbstractAction
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.Action
Adds a PropertyChange listener.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JComponent.AccessibleJComponent
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Add a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.SwingWorker
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.TableColumn
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.tree.TreeSelectionModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.UIDefaults
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Static method in class javax.swing.UIManager
Adds a PropertyChangeListener to the listener list.
addProvider(Provider) - Static method in class java.security.Security
Adds a provider to the next position available.
addProviderAtEnd(Provider, Oid) - Method in class org.ietf.jgss.GSSManager
This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
addProviderAtFront(Provider, Oid) - Method in class org.ietf.jgss.GSSManager
This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
addRelation(ObjectName) - Method in class javax.management.relation.RelationService
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelationType(RelationType) - Method in class javax.management.relation.RelationService
Adds given object as a relation type.
addRelationType(RelationType) - Method in interface javax.management.relation.RelationServiceMBean
Adds given object as a relation type.
addRenderingHints(Map<?, ?>) - Method in class java.awt.Graphics2D
Sets the values of an arbitrary number of preferences for the rendering algorithms.
addRequestProperty(String, String) - Method in class java.net.URLConnection
Adds a general request property specified by a key-value pair.
addResourceBundle(String) - Method in class javax.swing.UIDefaults
Adds a resource bundle to the list of resource bundles that are searched for localized values.
addResponseHeader(String, String) - Method in class javax.xml.ws.spi.http.HttpExchange
Adds a response header with the given name and value.
address() - Method in class java.net.Proxy
Returns the socket address of the proxy, or null if its a direct connection.
address - Variable in class java.net.SocketImpl
The IP address of the remote end of this socket.
ADDRESS - Static variable in class javax.swing.text.html.HTML.Tag
address(String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the address to the W3CEndpointReference instance's wsa:Address.
AddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage
Address is the Host and Port information represented as a String.
AddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
Addressing - Annotation Type in javax.xml.ws.soap
This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
AddressingFeature - Class in javax.xml.ws.soap
AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
AddressingFeature() - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean, boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean, boolean, AddressingFeature.Responses) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature.Responses - Enum in javax.xml.ws.soap
If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
addRoleInfo(RoleInfo) - Method in class javax.management.relation.RelationTypeSupport
Add a role info.
addRow(Vector) - Method in class javax.swing.table.DefaultTableModel
Adds a row to the end of the model.
addRow(Object[]) - Method in class javax.swing.table.DefaultTableModel
Adds a row to the end of the model.
addRowSelectionInterval(int, int) - Method in class javax.swing.JTable
Adds the rows from index0 to index1, inclusive, to the current selection.
addRowSet(Joinable) - Method in interface javax.sql.rowset.JoinRowSet
Adds the given RowSet object to this JoinRowSet object.
addRowSet(RowSet, int) - Method in interface javax.sql.rowset.JoinRowSet
Adds the given RowSet object to this JoinRowSet object and sets the designated column as the match column for the RowSet object.
addRowSet(RowSet, String) - Method in interface javax.sql.rowset.JoinRowSet
Adds rowset to this JoinRowSet object and sets the designated column as the match column.
addRowSet(RowSet[], int[]) - Method in interface javax.sql.rowset.JoinRowSet
Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column indexes.
addRowSet(RowSet[], String[]) - Method in interface javax.sql.rowset.JoinRowSet
Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column names.
addRowSetListener(RowSetListener) - Method in interface javax.sql.RowSet
Registers the given listener so that it will be notified of events that occur on this RowSet object.
addRowSetListener(RowSetListener) - Method in class javax.sql.rowset.BaseRowSet
The listener will be notified whenever an event occurs on this RowSet object.
addRowSorterListener(RowSorterListener) - Method in class javax.swing.RowSorter
Adds a RowSorterListener to receive notification about this RowSorter.
addrs - Variable in class javax.naming.Reference
Contains the addresses contained in this Reference.
addrType - Variable in class javax.naming.RefAddr
Contains the type of this address.
addRule(String) - Method in class javax.swing.text.html.StyleSheet
Adds a set of rules to the sheet.
addSelectionInterval(int, int) - Method in class javax.swing.DefaultListSelectionModel
Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
addSelectionInterval(int, int) - Method in class javax.swing.JList
Sets the selection to be the union of the specified interval with current selection.
addSelectionInterval(int, int) - Method in class javax.swing.JTree
Adds the specified rows (inclusive) to the selection.
addSelectionInterval(int, int) - Method in interface javax.swing.ListSelectionModel
Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
addSelectionPath(TreePath) - Method in class javax.swing.JTree
Adds the node identified by the specified TreePath to the current selection.
addSelectionPath(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds path to the current selection.
addSelectionPath(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel
Adds path to the current selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.JTree
Adds each path in the array of paths to the current selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds paths to the current selection.
addSelectionPaths(TreePath[]) - Method in interface javax.swing.tree.TreeSelectionModel
Adds paths to the current selection.
addSelectionRow(int) - Method in class javax.swing.JTree
Adds the path at the specified row to the current selection.
addSelectionRows(int[]) - Method in class javax.swing.JTree
Adds the paths at each of the specified rows to the current selection.
addSeparator() - Method in class java.awt.Menu
Adds a separator line, or a hypen, to the menu at the current position.
addSeparator() - Method in class javax.swing.JMenu
Appends a new separator to the end of the menu.
addSeparator() - Method in class javax.swing.JPopupMenu
Appends a new separator at the end of the menu.
addSeparator() - Method in class javax.swing.JToolBar
Appends a separator of default size to the end of the tool bar.
addSeparator(Dimension) - Method in class javax.swing.JToolBar
Appends a separator of a specified size to the end of the tool bar.
addService(Class, BeanContextServiceProvider) - Method in interface java.beans.beancontext.BeanContextServices
Adds a service to this BeanContext.
addService(Class, BeanContextServiceProvider) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a service
addService(Class, BeanContextServiceProvider, boolean) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a service
addShutdownHook(Thread) - Method in class java.lang.Runtime
Registers a new virtual-machine shutdown hook.
addSingletonComponent(Component, Component) - Method in class javax.swing.ScrollPaneLayout
Removes an existing component.
addSource(Object) - Method in class java.awt.image.renderable.ParameterBlock
Adds an image to end of the list of sources.
addSource(DOMImplementationSource) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry
Register an implementation.
addSpecialElement(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds content that is basically specified entirely in the attribute set.
addStatementEventListener(StatementEventListener) - Method in interface javax.sql.PooledConnection
Registers a StatementEventListener with this PooledConnection object.
addStyle(String, Style) - Method in class javax.swing.JTextPane
Adds a new style into the logical style hierarchy.
addStyle(String, Style) - Method in class javax.swing.text.DefaultStyledDocument
Adds a new style into the logical style hierarchy.
addStyle(String, Style) - Method in class javax.swing.text.StyleContext
Adds a new style into the style hierarchy.
addStyle(String, Style) - Method in interface javax.swing.text.StyledDocument
Adds a new style into the logical style hierarchy.
addStyleSheet(StyleSheet) - Method in class javax.swing.text.html.StyleSheet
Adds the rules from the StyleSheet ss to those of the receiver.
addSubComponents() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
addSubComponents() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method avoid creating a menu bar.
addSubjectAlternativeName(int, String) - Method in class java.security.cert.X509CertSelector
Adds a name to the subjectAlternativeNames criterion.
addSubjectAlternativeName(int, byte[]) - Method in class java.security.cert.X509CertSelector
Adds a name to the subjectAlternativeNames criterion.
addSuppressed(Throwable) - Method in class java.lang.Throwable
Appends the specified exception to the exceptions that were suppressed in order to deliver this exception.
addSwaRefAttachment(DataHandler) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Add MIME data as an attachment and return attachment's content-id, cid.
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method to do nothing.
addTab(String, Icon, Component, String) - Method in class javax.swing.JTabbedPane
Adds a component and tip represented by a title and/or icon, either of which can be null.
addTab(String, Icon, Component) - Method in class javax.swing.JTabbedPane
Adds a component represented by a title and/or icon, either of which can be null.
addTab(String, Component) - Method in class javax.swing.JTabbedPane
Adds a component represented by a title and no icon.
addTableModelListener(TableModelListener) - Method in class javax.swing.table.AbstractTableModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addTableModelListener(TableModelListener) - Method in interface javax.swing.table.TableModel
Adds a listener to the list that is notified each time a change to the data model occurs.
addTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Tag in HTML to start adding tags from.
addTask(Runnable) - Method in class javax.swing.text.LayoutQueue
Add a task that is not needed immediately because the results are not believed to be visible.
addTextListener(TextListener) - Method in class java.awt.TextComponent
Adds the specified text event listener to receive text events from this text component.
addTextNode(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
addTileObserver(TileObserver) - Method in class java.awt.image.BufferedImage
Adds a tile observer.
addTileObserver(TileObserver) - Method in interface java.awt.image.WritableRenderedImage
Adds an observer.
addTo(Calendar) - Method in class javax.xml.datatype.Duration
Adds this duration to a Calendar object.
addTo(Date) - Method in class javax.xml.datatype.Duration
Adds this duration to a Date object.
addToEnvironment(String, Object) - Method in interface javax.naming.Context
Adds a new environment property to the environment of this context.
addToEnvironment(String, Object) - Method in class javax.naming.InitialContext
addTransformer(ClassFileTransformer, boolean) - Method in interface java.lang.instrument.Instrumentation
Registers the supplied transformer.
addTransformer(ClassFileTransformer) - Method in interface java.lang.instrument.Instrumentation
Registers the supplied transformer.
addTreeExpansionListener(TreeExpansionListener) - Method in class javax.swing.JTree
Adds a listener for TreeExpansion events.
addTreeModelListener(TreeModelListener) - Method in class javax.swing.tree.DefaultTreeModel
Adds a listener for the TreeModelEvent posted after the tree changes.
addTreeModelListener(TreeModelListener) - Method in interface javax.swing.tree.TreeModel
Adds a listener for the TreeModelEvent posted after the tree changes.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree
Adds a listener for TreeSelection events.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
addTreeSelectionListener(TreeSelectionListener) - Method in interface javax.swing.tree.TreeSelectionModel
Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
addTreeWillExpandListener(TreeWillExpandListener) - Method in class javax.swing.JTree
Adds a listener for TreeWillExpand events.
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.text.AbstractDocument
Adds an undo listener for notification of any changes.
addUndoableEditListener(UndoableEditListener) - Method in interface javax.swing.text.Document
Registers the given observer to begin receiving notifications when undoable edits are made to the document.
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.undo.UndoableEditSupport
Registers an UndoableEditListener.
addUnencodedNativeForFlavor(DataFlavor, String) - Method in class java.awt.datatransfer.SystemFlavorMap
Adds a mapping from the specified DataFlavor (and all DataFlavors equal to the specified DataFlavor) to the specified String native.
addUnicodeLocaleAttribute(String) - Method in class java.util.Locale.Builder
Adds a unicode locale attribute, if not already present, otherwise has no effect.
addUpgradeHeaderElement(Iterator) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String[]) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
addURL(URL) - Method in class java.net.URLClassLoader
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(URL) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(URL) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addVetoableChangeListener(VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a VetoableChangeListener to the listener list.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a VetoableChangeListener to the listener list for a specific property.
addVetoableChangeListener(String, VetoableChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Adds a VetoableChangeListener to this BeanContextChild to receive events whenever the specified property changes.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Add a VetoableChangeListener for a specific property.
addVetoableChangeListener(VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Add a VetoableChangeListener to the listener list.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Add a VetoableChangeListener for a specific property.
addVetoableChangeListener(VetoableChangeListener) - Method in class javax.swing.JComponent
Adds a VetoableChangeListener to the listener list.
addWindowFocusListener(WindowFocusListener) - Method in class java.awt.Window
Adds the specified window focus listener to receive window events from this window.
addWindowListener(WindowListener) - Method in class java.awt.Window
Adds the specified window listener to receive window events from this window.
addWindowStateListener(WindowStateListener) - Method in class java.awt.Window
Adds the specified window state listener to receive window events from this window.
Adjustable - Interface in java.awt
The interface for objects which have an adjustable numeric value contained within a bounded range of values.
adjustAllocation(Shape) - Method in class javax.swing.text.FieldView
Adjusts the allocation given to the view to be a suitable allocation for a text field.
adjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt.GridBagLayout
Adjusts the x, y, width, and height fields to the correct values depending on the constraint geometry and pads.
AdjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt.GridBagLayout
This method is obsolete and supplied for backwards compatability only; new code should call adjustForGravity instead.
ADJUSTMENT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting adjustment events.
ADJUSTMENT_FIRST - Static variable in class java.awt.event.AdjustmentEvent
Marks the first integer id for the range of adjustment event ids.
ADJUSTMENT_LAST - Static variable in class java.awt.event.AdjustmentEvent
Marks the last integer id for the range of adjustment event ids.
ADJUSTMENT_VALUE_CHANGED - Static variable in class java.awt.event.AdjustmentEvent
The adjustment value changed event.
AdjustmentEvent - Class in java.awt.event
The adjustment event emitted by Adjustable objects like Scrollbar and ScrollPane.
AdjustmentEvent(Adjustable, int, int, int) - Constructor for class java.awt.event.AdjustmentEvent
Constructs an AdjustmentEvent object with the specified Adjustable source, event type, adjustment type, and value.
AdjustmentEvent(Adjustable, int, int, int, boolean) - Constructor for class java.awt.event.AdjustmentEvent
Constructs an AdjustmentEvent object with the specified Adjustable source, event type, adjustment type, and value.
AdjustmentListener - Interface in java.awt.event
The listener interface for receiving adjustment events.
adjustmentValueChanged(AdjustmentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the adjustmentValueChanged event by invoking the adjustmentValueChanged methods on listener-a and listener-b.
adjustmentValueChanged(AdjustmentEvent) - Method in interface java.awt.event.AdjustmentListener
Invoked when the value of the adjustable has changed.
adjustRow(FlowView, int, int, int) - Method in class javax.swing.text.FlowView.FlowStrategy
Adjusts the given row if possible to fit within the layout span.
adjustSizes(int, SizeRequirements[]) - Static method in class javax.swing.SizeRequirements
Adjust a specified array of sizes by a given amount.
adjustVisibility(Rectangle) - Method in class javax.swing.text.DefaultCaret
Scrolls the associated view (if necessary) to make the caret visible.
Adler32 - Class in java.util.zip
A class that can be used to compute the Adler-32 checksum of a data stream.
Adler32() - Constructor for class java.util.zip.Adler32
Creates a new Adler32 object.
ADMIN_UIROLE - Static variable in class javax.print.ServiceUIFactory
Denotes a UI which performs an administrative role.
adoptNode(Node) - Method in interface org.w3c.dom.Document
Attempts to adopt a node from another document to this document.
AEGEAN_NUMBERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Aegean Numbers" Unicode character block.
AffineTransform - Class in java.awt.geom
The AffineTransform class represents a 2D affine transform that performs a linear mapping from 2D coordinates to other 2D coordinates that preserves the "straightness" and "parallelness" of lines.
AffineTransform() - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform representing the Identity transformation.
AffineTransform(AffineTransform) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform that is a copy of the specified AffineTransform object.
AffineTransform(float, float, float, float, float, float) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from 6 floating point values representing the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(float[]) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from an array of floating point values representing either the 4 non-translation enries or the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(double, double, double, double, double, double) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from 6 double precision values representing the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(double[]) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from an array of double precision values representing either the 4 non-translation entries or the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransformOp - Class in java.awt.image
This class uses an affine transform to perform a linear mapping from 2D coordinates in the source image or Raster to 2D coordinates in the destination image or Raster.
AffineTransformOp(AffineTransform, RenderingHints) - Constructor for class java.awt.image.AffineTransformOp
Constructs an AffineTransformOp given an affine transform.
AffineTransformOp(AffineTransform, int) - Constructor for class java.awt.image.AffineTransformOp
Constructs an AffineTransformOp given an affine transform and the interpolation type.
after(Timestamp) - Method in class java.sql.Timestamp
Indicates whether this Timestamp object is later than the given Timestamp object.
after(Object) - Method in class java.util.Calendar
Returns whether this Calendar represents a time after the time represented by the specified Object.
after(Date) - Method in class java.util.Date
Tests if this date is after the specified date.
AFTER_LAST_LINE - Static variable in class java.awt.BorderLayout
Synonym for PAGE_END.
AFTER_LINE_ENDS - Static variable in class java.awt.BorderLayout
Synonym for LINE_END.
afterExecute(Runnable, Throwable) - Method in class java.util.concurrent.ThreadPoolExecutor
Method invoked upon completion of execution of the given Runnable.
afterLast() - Method in interface java.sql.ResultSet
Moves the cursor to the end of this ResultSet object, just after the last row.
afterMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked after marshalling source to XML.

afterOffset(int) - Static method in class java.awt.font.TextHitInfo
Creates a TextHitInfo at the specified offset, associated with the character after the offset.
afterUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked after unmarshalling XML data into target.

AIFC - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AIFF-C file.
AIFF - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AIFF file.
ALAW - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies a-law encoded data.
ALCHEMICAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Alchemical Symbols" Unicode character block.
ALERT - Static variable in class javax.accessibility.AccessibleRole
Object is used to alert the user about something.
AlgorithmConstraints - Interface in java.security
This interface specifies constraints for cryptographic algorithms, keys (key sizes), and other algorithm parameters.
AlgorithmMethod - Interface in javax.xml.crypto
An abstract representation of an algorithm defined in the XML Security specifications.
AlgorithmParameterGenerator - Class in java.security
The AlgorithmParameterGenerator class is used to generate a set of parameters to be used with a certain algorithm.
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String) - Constructor for class java.security.AlgorithmParameterGenerator
Creates an AlgorithmParameterGenerator object.
AlgorithmParameterGeneratorSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the AlgorithmParameterGenerator class, which is used to generate a set of parameters to be used with a certain algorithm.
AlgorithmParameterGeneratorSpi() - Constructor for class java.security.AlgorithmParameterGeneratorSpi
AlgorithmParameters - Class in java.security
This class is used as an opaque representation of cryptographic parameters.
AlgorithmParameters(AlgorithmParametersSpi, Provider, String) - Constructor for class java.security.AlgorithmParameters
Creates an AlgorithmParameters object.
AlgorithmParameterSpec - Interface in java.security.spec
A (transparent) specification of cryptographic parameters.
AlgorithmParametersSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the AlgorithmParameters class, which is used to manage algorithm parameters.
AlgorithmParametersSpi() - Constructor for class java.security.AlgorithmParametersSpi
aliases() - Method in class java.nio.charset.Charset
Returns a set containing this charset's aliases.
aliases() - Method in class java.security.KeyStore
Lists all the alias names of this keystore.
ALIGN - Static variable in class javax.swing.text.html.HTML.Attribute
ALIGN_BAR - Static variable in class javax.swing.text.TabStop
ALIGN_CENTER - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_CENTER - Static variable in class javax.swing.text.TabStop
Characters following tab are positioned such that all following characters up to next tab/newline are centered around the tabs location.
ALIGN_DECIMAL - Static variable in class javax.swing.text.TabStop
Characters following tab are aligned such that next decimal/tab/newline is at the tab location, very similar to RIGHT_TAB, just includes decimal as additional character to look for.
ALIGN_JUSTIFIED - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_LEFT - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_LEFT - Static variable in class javax.swing.text.TabStop
Character following tab is positioned at location.
ALIGN_RIGHT - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_RIGHT - Static variable in class javax.swing.text.TabStop
Characters following tab are positioned such that all following characters up to next tab/newline end at location.
alignment - Variable in class javax.swing.SizeRequirements
The alignment, specified as a value between 0.0 and 1.0, inclusive.
Alignment - Static variable in class javax.swing.text.StyleConstants
Alignment for the paragraph.
ALINK - Static variable in class javax.swing.text.html.HTML.Attribute
ALL - Static variable in class java.awt.JobAttributes.DefaultSelectionType
The DefaultSelectionType instance to use for specifying that all pages of the job should be printed.
ALL - Static variable in class java.util.logging.Level
ALL indicates that all messages should be logged.
ALL_COLUMNS - Static variable in class javax.swing.event.TableModelEvent
Specifies all columns in a row or rows.
ALL_RANGES - Static variable in class java.awt.font.NumericShaper
Identifies all ranges, for full contextual shaping.
ALL_STYLES - Static variable in class java.util.Calendar
A style specifier for getDisplayNames indicating names in all styles, such as "January" and "Jan".
ALLBITS - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that a static image which was previously drawn is now complete and can be drawn again in its final form.
allKeys() - Method in class javax.swing.ActionMap
Returns an array of the keys defined in this ActionMap and its parent.
allKeys() - Method in class javax.swing.InputMap
Returns an array of the KeyStrokes defined in this InputMap and its parent.
allNotesOff() - Method in interface javax.sound.midi.MidiChannel
Turns off all notes that are currently sounding on this channel.
allocate(int) - Static method in class java.nio.ByteBuffer
Allocates a new byte buffer.
allocate(int) - Static method in class java.nio.CharBuffer
Allocates a new char buffer.
allocate(int) - Static method in class java.nio.DoubleBuffer
Allocates a new double buffer.
allocate(int) - Static method in class java.nio.FloatBuffer
Allocates a new float buffer.
allocate(int) - Static method in class java.nio.IntBuffer
Allocates a new int buffer.
allocate(int) - Static method in class java.nio.LongBuffer
Allocates a new long buffer.
allocate(int) - Static method in class java.nio.ShortBuffer
Allocates a new short buffer.
allocate(XMLStreamReader) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event given the current state of the XMLStreamReader.
allocate(XMLStreamReader, XMLEventConsumer) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
allocate_slot_id() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Called to allocate a slot on PortableInterceptor.Current.
allocateArray(int) - Method in class javax.swing.text.GapContent
Allocate an array to store items of the type appropriate (which is determined by the subclass).
allocateDirect(int) - Static method in class java.nio.ByteBuffer
Allocates a new direct byte buffer.
ALLOCATOR - Static variable in class javax.xml.stream.XMLInputFactory
The property used to set/get the implementation of the allocator
allOf(Class<E>) - Static method in class java.util.EnumSet
Creates an enum set containing all of the elements in the specified element type.
ALLOW_UNASSIGNED - Static variable in class java.net.IDN
Flag to allow processing of unassigned code points
allowCoreThreadTimeOut(boolean) - Method in class java.util.concurrent.ThreadPoolExecutor
Sets the policy governing whether core threads may time out and terminate if no tasks arrive within the keep-alive time, being replaced if needed when new tasks arrive.
ALLOWED_CLASSNAMES - Static variable in class javax.management.openmbean.OpenType
Deprecated.
Use ALLOWED_CLASSNAMES_LIST instead.
ALLOWED_CLASSNAMES_LIST - Static variable in class javax.management.openmbean.OpenType
List of the fully qualified names of the Java classes allowed for open data values.
allowMultipleSelections() - Method in class javax.security.auth.callback.ChoiceCallback
Get the boolean determining whether multiple selections from the choices list are allowed.
allowsChildren - Variable in class javax.swing.tree.DefaultMutableTreeNode
true if the node is able to have children
allowsCoreThreadTimeOut() - Method in class java.util.concurrent.ThreadPoolExecutor
Returns true if this pool allows core threads to time out and terminate if no tasks arrive within the keepAlive time, being replaced if needed when new tasks arrive.
allowsMultipleSelections() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by isMultipleMode().
allowThreadSuspension(boolean) - Method in class java.lang.ThreadGroup
Deprecated.
The definition of this call depends on ThreadGroup.suspend(), which is deprecated. Further, the behavior of this call was never specified.
allowUserInteraction - Variable in class java.net.URLConnection
If true, this URL is being examined in a context in which it makes sense to allow user interactions such as popping up an authentication dialog.
AllPermission - Class in java.security
The AllPermission is a permission that implies all other permissions.
AllPermission() - Constructor for class java.security.AllPermission
Creates a new AllPermission object.
AllPermission(String, String) - Constructor for class java.security.AllPermission
Creates a new AllPermission object.
allProceduresAreCallable() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the current user can call all the procedures returned by the method getProcedures.
allRowsChanged() - Method in class javax.swing.DefaultRowSorter
Invoked when the contents of the underlying model have completely changed.
allRowsChanged() - Method in class javax.swing.RowSorter
Invoked when the contents of the underlying model have completely changed.
allSoundOff() - Method in interface javax.sound.midi.MidiChannel
Immediately turns off all sounding notes on this channel, ignoring the state of the Hold Pedal and the internal decay rate of the current Instrument.
allTablesAreSelectable() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the current user can use all the tables returned by the method getTables in a SELECT statement.
ALPHABETIC_PRESENTATION_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Alphabetic Presentation Forms" Unicode character block.
AlphaComposite - Class in java.awt
The AlphaComposite class implements basic alpha compositing rules for combining source and destination colors to achieve blending and transparency effects with graphics and images.
AlreadyBound - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
AlreadyBound() - Constructor for exception org.omg.CosNaming.NamingContextPackage.AlreadyBound
AlreadyBound(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage.AlreadyBound
AlreadyBoundException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to bind the socket a network oriented channel that is already bound.
AlreadyBoundException() - Constructor for exception java.nio.channels.AlreadyBoundException
Constructs an instance of this class.
AlreadyBoundException - Exception in java.rmi
An AlreadyBoundException is thrown if an attempt is made to bind an object in the registry to a name that already has an associated binding.
AlreadyBoundException() - Constructor for exception java.rmi.AlreadyBoundException
Constructs an AlreadyBoundException with no specified detail message.
AlreadyBoundException(String) - Constructor for exception java.rmi.AlreadyBoundException
Constructs an AlreadyBoundException with the specified detail message.
AlreadyBoundHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java .
AlreadyBoundHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
AlreadyBoundHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
AlreadyBoundHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
AlreadyBoundHolder(AlreadyBound) - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
AlreadyConnectedException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to connect a SocketChannel that is already connected.
AlreadyConnectedException() - Constructor for exception java.nio.channels.AlreadyConnectedException
Constructs an instance of this class.
alreadyNotified - Variable in class javax.management.monitor.Monitor
Deprecated.
equivalent to Monitor.alreadyNotifieds[0].
alreadyNotifieds - Variable in class javax.management.monitor.Monitor
Selected monitor errors that have already been notified.
ALT - Static variable in class javax.swing.text.html.HTML.Attribute
ALT_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Alt key extended modifier constant.
ALT_GRAPH_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The AltGraph key extended modifier constant.
ALT_GRAPH_MASK - Static variable in class java.awt.event.InputEvent
The AltGraph key modifier constant.
ALT_MASK - Static variable in class java.awt.event.ActionEvent
The alt modifier.
ALT_MASK - Static variable in class java.awt.Event
This flag indicates that the Alt key was down when the event occurred.
ALT_MASK - Static variable in class java.awt.event.InputEvent
The Alt key modifier constant.
ALTERNATE - Static variable in class java.util.FormattableFlags
Requires the output to use an alternate form.
alternateAddTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.
alternateParentTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Alternate Tag to check for in the document if parentTag is not found.
altName - Variable in exception javax.naming.CannotProceedException
Contains the name of the resolved object, relative to the context altNameCtx.
altNameCtx - Variable in exception javax.naming.CannotProceedException
Contains the context relative to which altName is specified.
ALWAYS_UPDATE - Static variable in class javax.swing.text.DefaultCaret
Indicates that the caret position is to be always updated accordingly to the document changes regardless whether the document updates are performed on the Event Dispatching Thread or not.
AM - Static variable in class java.util.Calendar
Value of the Calendar.AM_PM field indicating the period of the day from midnight to just before noon.
AM_PM - Static variable in class java.text.DateFormat.Field
Constant identifying the time of day indicator (e.g.
AM_PM - Static variable in class java.util.Calendar
Field number for get and set indicating whether the HOUR is before or after noon.
AM_PM_FIELD - Static variable in class java.text.DateFormat
Useful constant for AM_PM field alignment.
ANCESTOR_ADDED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component was added to the hierarchy of visible objects (made visible), and is currently being displayed.
ANCESTOR_MOVED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating an ancestor-Container was moved.
ANCESTOR_MOVED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component changed its position on the screen.
ANCESTOR_REMOVED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component was removed from the hierarchy of visible objects (hidden) and is no longer being displayed.
ANCESTOR_RESIZED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating an ancestor-Container was resized.
ancestorAdded(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when the source or one of its ancestors is made visible either by setVisible(true) being called or by its being added to the component hierarchy.
AncestorEvent - Class in javax.swing.event
An event reported to a child component that originated from an ancestor in the component hierarchy.
AncestorEvent(JComponent, int, Container, Container) - Constructor for class javax.swing.event.AncestorEvent
Constructs an AncestorEvent object to identify a change in an ancestor-component's display-status.
AncestorListener - Interface in javax.swing.event
AncestorListener Interface to support notification when changes occur to a JComponent or one of its ancestors.
ancestorMoved(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the ancestorMoved event by invoking the ancestorMoved methods on listener-a and listener-b.
ancestorMoved(HierarchyEvent) - Method in class java.awt.event.HierarchyBoundsAdapter
Called when an ancestor of the source is moved.
ancestorMoved(HierarchyEvent) - Method in interface java.awt.event.HierarchyBoundsListener
Called when an ancestor of the source is moved.
ancestorMoved(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when either the source or one of its ancestors is moved.
ancestorRemoved(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when the source or one of its ancestors is made invisible either by setVisible(false) being called or by its being remove from the component hierarchy.
ancestorResized(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the ancestorResized event by invoking the ancestorResized methods on listener-a and listener-b.
ancestorResized(HierarchyEvent) - Method in class java.awt.event.HierarchyBoundsAdapter
Called when an ancestor of the source is resized.
ancestorResized(HierarchyEvent) - Method in interface java.awt.event.HierarchyBoundsListener
Called when an ancestor of the source is resized.
anchor - Variable in class java.awt.GridBagConstraints
This field is used when the component is smaller than its display area.
ANCHOR_SELECTION_PATH_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for anchor selection path.
ANCIENT_GREEK_MUSICAL_NOTATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Greek Musical Notation" Unicode character block.
ANCIENT_GREEK_NUMBERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Greek Numbers" Unicode character block.
ANCIENT_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Symbols" Unicode character block.
and(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this & val).
and(BitSet) - Method in class java.util.BitSet
Performs a logical AND of this target bit set with the argument bit set.
and(QueryExp, QueryExp) - Static method in class javax.management.Query
Returns a query expression that is the conjunction of two other query expressions.
andFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries if all of the supplied filters include the entry.
andNot(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this & ~val).
andNot(BitSet) - Method in class java.util.BitSet
Clears all of the bits in this BitSet whose corresponding bit is set in the specified BitSet.
annotateClass(Class<?>) - Method in class java.io.ObjectOutputStream
Subclasses may implement this method to allow class data to be stored in the stream.
AnnotatedElement - Interface in java.lang.reflect
Represents an annotated element of the program currently running in this VM.
annotateProxyClass(Class<?>) - Method in class java.io.ObjectOutputStream
Subclasses may implement this method to store custom data in the stream along with descriptors for dynamic proxy classes.
Annotation - Interface in java.lang.annotation
The common interface extended by all annotation types.
Annotation - Class in java.text
An Annotation object is used as a wrapper for a text attribute value if the attribute has annotation characteristics.
Annotation(Object) - Constructor for class java.text.Annotation
Constructs an annotation record with the given value, which may be null.
AnnotationFormatError - Error in java.lang.annotation
Thrown when the annotation parser attempts to read an annotation from a class file and determines that the annotation is malformed.
AnnotationFormatError(String) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified detail message.
AnnotationFormatError(String, Throwable) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified detail message and cause.
AnnotationFormatError(Throwable) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified cause and a detail message of (cause == null ? null : cause.toString()) (which typically contains the class and detail message of cause).
AnnotationMirror - Interface in javax.lang.model.element
Represents an annotation.
annotationType() - Method in interface java.lang.annotation.Annotation
Returns the annotation type of this annotation.
annotationType() - Method in exception java.lang.annotation.IncompleteAnnotationException
Returns the Class object for the annotation type with the missing element.
AnnotationTypeMismatchException - Exception in java.lang.annotation
Thrown to indicate that a program has attempted to access an element of an annotation whose type has changed after the annotation was compiled (or serialized).
AnnotationTypeMismatchException(Method, String) - Constructor for exception java.lang.annotation.AnnotationTypeMismatchException
Constructs an AnnotationTypeMismatchException for the specified annotation type element and found data type.
AnnotationValue - Interface in javax.lang.model.element
Represents a value of an annotation type element.
AnnotationValueVisitor<R,P> - Interface in javax.lang.model.element
A visitor of the values of annotation type elements, using a variant of the visitor design pattern.
ANY - Static variable in interface javax.swing.text.html.parser.DTDConstants
Any - Class in org.omg.CORBA
Serves as a container for any data that can be described in IDL or for any IDL primitive type.
Any() - Constructor for class org.omg.CORBA.Any
AnyHolder - Class in org.omg.CORBA
The Holder for Any.
AnyHolder() - Constructor for class org.omg.CORBA.AnyHolder
Constructs a new AnyHolder object with its value field initialized to null.
AnyHolder(Any) - Constructor for class org.omg.CORBA.AnyHolder
Constructs a new AnyHolder object for the given Any object.
AnySeqHelper - Class in org.omg.CORBA
The Helper for AnySeq.
AnySeqHelper() - Constructor for class org.omg.CORBA.AnySeqHelper
AnySeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/AnySeqHelper.java .
AnySeqHelper() - Constructor for class org.omg.DynamicAny.AnySeqHelper
AnySeqHolder - Class in org.omg.CORBA
The Holder for AnySeq.
AnySeqHolder() - Constructor for class org.omg.CORBA.AnySeqHolder
AnySeqHolder(Any[]) - Constructor for class org.omg.CORBA.AnySeqHolder
anySubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
AppConfigurationEntry - Class in javax.security.auth.login
This class represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method in the Configuration class.
AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>) - Constructor for class javax.security.auth.login.AppConfigurationEntry
Default constructor for this class.
AppConfigurationEntry.LoginModuleControlFlag - Class in javax.security.auth.login
This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.
append(Shape, boolean) - Method in class java.awt.geom.Path2D
Appends the geometry of the specified Shape object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D.Double
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D.Float
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(Printable, PageFormat) - Method in class java.awt.print.Book
Appends a single page to the end of this Book.
append(Printable, PageFormat, int) - Method in class java.awt.print.Book
Appends numPages pages to the end of this Book.
append(String) - Method in class java.awt.TextArea
Appends the given text to the text area's current text.
append(CharSequence) - Method in class java.io.CharArrayWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.CharArrayWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.CharArrayWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.PrintStream
Appends the specified character sequence to this output stream.
append(CharSequence, int, int) - Method in class java.io.PrintStream
Appends a subsequence of the specified character sequence to this output stream.
append(char) - Method in class java.io.PrintStream
Appends the specified character to this output stream.
append(CharSequence) - Method in class java.io.PrintWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.PrintWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.PrintWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.StringWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.StringWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.StringWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.Writer
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.Writer
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.Writer
Appends the specified character to this writer.
append(CharSequence) - Method in interface java.lang.Appendable
Appends the specified character sequence to this Appendable.
append(CharSequence, int, int) - Method in interface java.lang.Appendable
Appends a subsequence of the specified character sequence to this Appendable.
append(char) - Method in interface java.lang.Appendable
Appends the specified character to this Appendable.
append(Object) - Method in class java.lang.StringBuffer
append(String) - Method in class java.lang.StringBuffer
append(StringBuffer) - Method in class java.lang.StringBuffer
Appends the specified StringBuffer to this sequence.
append(CharSequence) - Method in class java.lang.StringBuffer
Appends the specified CharSequence to this sequence.
append(CharSequence, int, int) - Method in class java.lang.StringBuffer
append(char[]) - Method in class java.lang.StringBuffer
append(char[], int, int) - Method in class java.lang.StringBuffer
append(boolean) - Method in class java.lang.StringBuffer
append(char) - Method in class java.lang.StringBuffer
append(int) - Method in class java.lang.StringBuffer
append(long) - Method in class java.lang.StringBuffer
append(float) - Method in class java.lang.StringBuffer
append(double) - Method in class java.lang.StringBuffer
append(Object) - Method in class java.lang.StringBuilder
append(String) - Method in class java.lang.StringBuilder
append(StringBuffer) - Method in class java.lang.StringBuilder
Appends the specified StringBuffer to this sequence.
append(CharSequence) - Method in class java.lang.StringBuilder
append(CharSequence, int, int) - Method in class java.lang.StringBuilder
append(char[]) - Method in class java.lang.StringBuilder
append(char[], int, int) - Method in class java.lang.StringBuilder
append(boolean) - Method in class java.lang.StringBuilder
append(char) - Method in class java.lang.StringBuilder
append(int) - Method in class java.lang.StringBuilder
append(long) - Method in class java.lang.StringBuilder
append(float) - Method in class java.lang.StringBuilder
append(double) - Method in class java.lang.StringBuilder
append(CharSequence) - Method in class java.nio.CharBuffer
Appends the specified character sequence to this buffer (optional operation).
append(CharSequence, int, int) - Method in class java.nio.CharBuffer
Appends a subsequence of the specified character sequence to this buffer (optional operation).
append(char) - Method in class java.nio.CharBuffer
Appends the specified char to this buffer (optional operation).
append(String) - Method in class javax.swing.JTextArea
Appends the given text to the end of the document.
append(View) - Method in class javax.swing.text.View
Appends a single child view.
Appendable - Interface in java.lang
An object to which char sequences and values can be appended.
appendChild(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Adds the node newChild to the end of the list of children of this node.
appendChild(Node) - Method in interface org.w3c.dom.Node
Adds the node newChild to the end of the list of children of this node.
appendCodePoint(int) - Method in class java.lang.StringBuffer
appendCodePoint(int) - Method in class java.lang.StringBuilder
appendData(String) - Method in interface org.w3c.dom.CharacterData
Append the string to the end of the character data of the node.
appendEvent(InputEvent) - Method in class java.awt.dnd.DragGestureRecognizer
Listeners registered on the Component by this Recognizer shall record all Events that are recognized as part of the series of Events that go to comprise a Drag and Drop initiating gesture via this API.
appendFaultSubcode(QName) - Method in interface javax.xml.soap.SOAPFault
Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
appendParameterTypes(Class<?>...) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
appendParameterTypes(List<Class<?>>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
appendRemainingComponent(String) - Method in exception javax.naming.NamingException
Add name as the last component in remaining name.
appendRemainingComponent(String) - Method in class javax.naming.spi.ResolveResult
Adds a single component to the end of remaining name.
appendRemainingName(Name) - Method in exception javax.naming.NamingException
Add components from 'name' as the last components in remaining name.
appendRemainingName(Name) - Method in class javax.naming.spi.ResolveResult
Adds components to the end of remaining name.
appendReplacement(StringBuffer, String) - Method in class java.util.regex.Matcher
Implements a non-terminal append-and-replace step.
appendTail(StringBuffer) - Method in class java.util.regex.Matcher
Implements a terminal append-and-replace step.
appendText(String) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by append(String).
appendTo(File) - Static method in class java.lang.ProcessBuilder.Redirect
Returns a redirect to append to the specified file.
appendToBootstrapClassLoaderSearch(JarFile) - Method in interface java.lang.instrument.Instrumentation
Specifies a JAR file with instrumentation classes to be defined by the bootstrap class loader.
appendToSystemClassLoaderSearch(JarFile) - Method in interface java.lang.instrument.Instrumentation
Specifies a JAR file with instrumentation classes to be defined by the system class loader.
Applet - Class in java.applet
An applet is a small program that is intended not to be run on its own, but rather to be embedded inside another application.
Applet() - Constructor for class java.applet.Applet
Constructs a new Applet.
APPLET - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying an applet for the initial context constructor to use when searching for other properties.
APPLET - Static variable in class javax.swing.text.html.HTML.Tag
applet - Variable in class javax.swing.text.html.parser.DTD
Applet.AccessibleApplet - Class in java.applet
This class implements accessibility support for the Applet class.
Applet.AccessibleApplet() - Constructor for class java.applet.Applet.AccessibleApplet
AppletContext - Interface in java.applet
This interface corresponds to an applet's environment: the document containing the applet and the other applets in the same document.
AppletInitializer - Interface in java.beans
This interface is designed to work in collusion with java.beans.Beans.instantiate.
appletResize(int, int) - Method in interface java.applet.AppletStub
Called when the applet wants to be resized.
AppletStub - Interface in java.applet
When an applet is first created, an applet stub is attached to it using the applet's setStub method.
ApplicationException - Exception in org.omg.CORBA.portable
This class is used for reporting application level exceptions between ORBs and stubs.
ApplicationException(String, InputStream) - Constructor for exception org.omg.CORBA.portable.ApplicationException
Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.
apply(ObjectName) - Method in class javax.management.AttributeValueExp
Applies the AttributeValueExp on an MBean.
apply(ObjectName) - Method in class javax.management.ObjectName
Test whether this ObjectName, which may be a pattern, matches another ObjectName.
apply(ObjectName) - Method in interface javax.management.QueryExp
Applies the QueryExp on an MBean.
apply(ObjectName) - Method in class javax.management.StringValueExp
Applies the ValueExp on a MBean.
apply(ObjectName) - Method in interface javax.management.ValueExp
Applies the ValueExp on a MBean.
APPLY_REVERB - Static variable in class javax.sound.sampled.BooleanControl.Type
Represents a control for whether reverberation is applied to a line.
applyComponentOrientation(ComponentOrientation) - Method in class java.awt.Component
Sets the ComponentOrientation property of this component and all components contained within it.
applyComponentOrientation(ComponentOrientation) - Method in class java.awt.Container
Sets the ComponentOrientation property of this container and all components contained within it.
applyComponentOrientation(ComponentOrientation) - Method in class javax.swing.JMenu
Sets the ComponentOrientation property of this menu and all components contained within it.
applyLocalizedPattern(String) - Method in class java.text.DecimalFormat
Apply the given pattern to this Format object.
applyLocalizedPattern(String) - Method in class java.text.SimpleDateFormat
Applies the given localized pattern string to this date format.
applyPattern(String) - Method in class java.text.ChoiceFormat
Sets the pattern.
applyPattern(String) - Method in class java.text.DecimalFormat
Apply the given pattern to this Format object.
applyPattern(String) - Method in class java.text.MessageFormat
Sets the pattern used by this message format.
applyPattern(String) - Method in class java.text.SimpleDateFormat
Applies the given pattern string to this date format.
applyPropertyChange(PropertyChangeEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Notifies the LayerUI when any of its property are changed and enables updating every JLayer this LayerUI instance is set to.
applyResourceBundle(ResourceBundle) - Method in class java.awt.Window
Deprecated.
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
applyResourceBundle(String) - Method in class java.awt.Window
Deprecated.
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
appRandom - Variable in class java.security.SignatureSpi
Application-specified source of randomness.
APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the mnemonic for the approve (yes, ok) button.
APPROVE_BUTTON_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the text on the approve (yes, ok) button.
APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the tooltip text for the approve (yes, ok) button.
APPROVE_OPTION - Static variable in class javax.swing.JFileChooser
Return value if approve (yes, ok) is chosen.
APPROVE_SELECTION - Static variable in class javax.swing.JFileChooser
Instruction to approve the current selection (same as pressing yes or ok).
approveSelection() - Method in class javax.swing.JFileChooser
Called by the UI when the user hits the Approve button (labeled "Open" or "Save", by default).
APRIL - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the fourth month of the year in the Gregorian and Julian calendars.
APRIL - Static variable in class javax.xml.datatype.DatatypeConstants
Value for fourth month of year.
ARABIC - Static variable in class java.awt.font.NumericShaper
Identifies the ARABIC range and decimal base.
ARABIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic" Unicode character block.
ARABIC_PRESENTATION_FORMS_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Presentation Forms-A" Unicode character block.
ARABIC_PRESENTATION_FORMS_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Presentation Forms-B" Unicode character block.
ARABIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Supplement" Unicode character block.
Arc2D - Class in java.awt.geom
Arc2D is the abstract superclass for all objects that store a 2D arc defined by a framing rectangle, start angle, angular extent (length of the arc), and a closure type (OPEN, CHORD, or PIE).
Arc2D(int) - Constructor for class java.awt.geom.Arc2D
This is an abstract class that cannot be instantiated directly.
Arc2D.Double - Class in java.awt.geom
This class defines an arc specified in double precision.
Arc2D.Double() - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new OPEN arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0).
Arc2D.Double(int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0), and the specified closure type.
Arc2D.Double(double, double, double, double, double, double, int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Arc2D.Double(Rectangle2D, double, double, int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Arc2D.Float - Class in java.awt.geom
This class defines an arc specified in float precision.
Arc2D.Float() - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new OPEN arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0).
Arc2D.Float(int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0), and the specified closure type.
Arc2D.Float(float, float, float, float, float, float, int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Arc2D.Float(Rectangle2D, float, float, int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
archeight - Variable in class java.awt.geom.RoundRectangle2D.Double
The height of the arc that rounds off the corners.
archeight - Variable in class java.awt.geom.RoundRectangle2D.Float
The height of the arc that rounds off the corners.
ARCHIVE - Static variable in class javax.swing.text.html.HTML.Attribute
arcwidth - Variable in class java.awt.geom.RoundRectangle2D.Double
The width of the arc that rounds off the corners.
arcwidth - Variable in class java.awt.geom.RoundRectangle2D.Float
The width of the arc that rounds off the corners.
Area - Class in java.awt.geom
An Area object stores and manipulates a resolution-independent description of an enclosed area of 2-dimensional space.
Area() - Constructor for class java.awt.geom.Area
Default constructor which creates an empty area.
Area(Shape) - Constructor for class java.awt.geom.Area
The Area class creates an area geometry from the specified Shape object.
AREA - Static variable in class javax.swing.text.html.HTML.Tag
AreaAveragingScaleFilter - Class in java.awt.image
An ImageFilter class for scaling images using a simple area averaging algorithm that produces smoother results than the nearest neighbor algorithm.
AreaAveragingScaleFilter(int, int) - Constructor for class java.awt.image.AreaAveragingScaleFilter
Constructs an AreaAveragingScaleFilter that scales the pixels from its source Image as specified by the width and height parameters.
areExtraMouseButtonsEnabled() - Method in class java.awt.Toolkit
Reports whether events from extra mouse buttons are allowed to be processed and posted into EventQueue.
areFieldsSet - Variable in class java.util.Calendar
True if fields[] are in sync with the currently set time.
areFocusTraversalKeysSet(int) - Method in class java.awt.Component
Returns whether the Set of focus traversal keys for the given focus traversal operation has been explicitly defined for this Component.
areFocusTraversalKeysSet(int) - Method in class java.awt.Container
Returns whether the Set of focus traversal keys for the given focus traversal operation has been explicitly defined for this Container.
areNew - Variable in class javax.swing.event.TreeSelectionEvent
For each path identifies if that path is in fact new.
arePathsContiguous(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the paths are contiguous, or this object has no RowMapper.
areTablesSet() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam
Returns true if tables are currently set.
areTablesSet() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Returns true if tables are currently set.
arg - Variable in class java.awt.Event
An arbitrary argument of the event.
ARG_IN - Interface in org.omg.CORBA
Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server.
ARG_INOUT - Interface in org.omg.CORBA
Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client.
ARG_OUT - Interface in org.omg.CORBA
A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client.
ARGUMENT - Static variable in class java.text.MessageFormat.Field
Constant identifying a portion of a message that was generated from an argument passed into formatToCharacterIterator.
argument - Variable in class org.omg.Dynamic.Parameter
arguments() - Method in class org.omg.CORBA.Request
Retrieves the NVList object containing the arguments to the method being invoked.
arguments(NVList) - Method in class org.omg.CORBA.ServerRequest
Specifies method parameter types and retrieves "in" and "inout" argument values.
arguments() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Returns the arguments passed to ORB.init.
arguments() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of Parameter objects, containing the arguments on the operation being invoked.
ARGV - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that passes an array of positional arguments to a script.
ArithmeticException - Exception in java.lang
Thrown when an exceptional arithmetic condition has occurred.
ArithmeticException() - Constructor for exception java.lang.ArithmeticException
Constructs an ArithmeticException with no detail message.
ArithmeticException(String) - Constructor for exception java.lang.ArithmeticException
Constructs an ArithmeticException with the specified detail message.
ARMED - Static variable in class javax.accessibility.AccessibleState
Indicates that the object is armed.
ARMED - Static variable in class javax.swing.DefaultButtonModel
Identifies the "armed" bit in the bitmask, which indicates partial commitment towards choosing/triggering the button.
ARMENIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Armenian" Unicode character block.
arrangeGrid(Container) - Method in class java.awt.GridBagLayout
Lays out the grid.
ArrangeGrid(Container) - Method in class java.awt.GridBagLayout
This method is obsolete and supplied for backwards compatability only; new code should call arrangeGrid instead.
Array - Class in java.lang.reflect
The Array class provides static methods to dynamically create and access Java arrays.
array() - Method in class java.nio.Buffer
Returns the array that backs this buffer (optional operation).
array() - Method in class java.nio.ByteBuffer
Returns the byte array that backs this buffer (optional operation).
array() - Method in class java.nio.CharBuffer
Returns the char array that backs this buffer (optional operation).
array() - Method in class java.nio.DoubleBuffer
Returns the double array that backs this buffer (optional operation).
array() - Method in class java.nio.FloatBuffer
Returns the float array that backs this buffer (optional operation).
array() - Method in class java.nio.IntBuffer
Returns the int array that backs this buffer (optional operation).
array() - Method in class java.nio.LongBuffer
Returns the long array that backs this buffer (optional operation).
array() - Method in class java.nio.ShortBuffer
Returns the short array that backs this buffer (optional operation).
Array - Interface in java.sql
The mapping in the Java programming language for the SQL type ARRAY.
ARRAY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type ARRAY.
array - Variable in class javax.swing.text.Segment
This is the array containing the text of interest.
ArrayBlockingQueue<E> - Class in java.util.concurrent
A bounded blocking queue backed by an array.
ArrayBlockingQueue(int) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity and default access policy.
ArrayBlockingQueue(int, boolean) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity and the specified access policy.
ArrayBlockingQueue(int, boolean, Collection<? extends E>) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity, the specified access policy and initially containing the elements of the given collection, added in traversal order of the collection's iterator.
arraycopy(Object, int, Object, int, int) - Static method in class java.lang.System
Copies an array from the specified source array, beginning at the specified position, to the specified position of the destination array.
ArrayDeque<E> - Class in java.util
Resizable-array implementation of the Deque interface.
ArrayDeque() - Constructor for class java.util.ArrayDeque
Constructs an empty array deque with an initial capacity sufficient to hold 16 elements.
ArrayDeque(int) - Constructor for class java.util.ArrayDeque
Constructs an empty array deque with an initial capacity sufficient to hold the specified number of elements.
ArrayDeque(Collection<? extends E>) - Constructor for class java.util.ArrayDeque
Constructs a deque containing the elements of the specified collection, in the order they are returned by the collection's iterator.
arrayElementGetter(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle giving read access to elements of an array.
arrayElementSetter(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle giving write access to elements of an array.
ArrayIndexOutOfBoundsException - Exception in java.lang
Thrown to indicate that an array has been accessed with an illegal index.
ArrayIndexOutOfBoundsException() - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs an ArrayIndexOutOfBoundsException with no detail message.
ArrayIndexOutOfBoundsException(int) - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs a new ArrayIndexOutOfBoundsException class with an argument indicating the illegal index.
ArrayIndexOutOfBoundsException(String) - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs an ArrayIndexOutOfBoundsException class with the specified detail message.
ArrayList<E> - Class in java.util
Resizable-array implementation of the List interface.
ArrayList(int) - Constructor for class java.util.ArrayList
Constructs an empty list with the specified initial capacity.
ArrayList() - Constructor for class java.util.ArrayList
Constructs an empty list with an initial capacity of ten.
ArrayList(Collection<? extends E>) - Constructor for class java.util.ArrayList
Constructs a list containing the elements of the specified collection, in the order they are returned by the collection's iterator.
arrayOffset() - Method in class java.nio.Buffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.ByteBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.CharBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.DoubleBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.FloatBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.IntBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.LongBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.ShortBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
Arrays - Class in java.util
This class contains various methods for manipulating arrays (such as sorting and searching).
ArrayStoreException - Exception in java.lang
Thrown to indicate that an attempt has been made to store the wrong type of object into an array of objects.
ArrayStoreException() - Constructor for exception java.lang.ArrayStoreException
Constructs an ArrayStoreException with no detail message.
ArrayStoreException(String) - Constructor for exception java.lang.ArrayStoreException
Constructs an ArrayStoreException with the specified detail message.
ArrayType - Interface in javax.lang.model.type
Represents an array type.
ArrayType<T> - Class in javax.management.openmbean
The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
ArrayType(int, OpenType<?>) - Constructor for class javax.management.openmbean.ArrayType
Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
ArrayType(SimpleType<?>, boolean) - Constructor for class javax.management.openmbean.ArrayType
Constructs a unidimensional ArrayType instance for the supplied SimpleType.
arrive() - Method in class java.util.concurrent.Phaser
Arrives at this phaser, without waiting for others to arrive.
arriveAndAwaitAdvance() - Method in class java.util.concurrent.Phaser
Arrives at this phaser and awaits others.
arriveAndDeregister() - Method in class java.util.concurrent.Phaser
Arrives at this phaser and deregisters from it without waiting for others to arrive.
ARROW_BUTTON - Static variable in class javax.swing.plaf.synth.Region
ArrowButton's are special types of buttons that also render a directional indicator, typically an arrow.
arrowButton - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
arrowIcon - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
ARROWS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arrows" Unicode character block.
asCharacters() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as Characters, may result in a class cast exception if this event is not Characters.
asCharBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a char buffer.
ASCII_STREAM_PARAM - Static variable in class javax.sql.rowset.BaseRowSet
A constant indicating to a RowSetReaderImpl object that a given parameter is an ASCII stream.
asciiStream - Variable in class javax.sql.rowset.BaseRowSet
The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.
asCollector(Class<?>, int) - Method in class java.lang.invoke.MethodHandle
Makes an adapter which accepts a given number of trailing positional arguments and collects them into an array argument.
asDoubleBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a double buffer.
asElement() - Method in interface javax.lang.model.type.DeclaredType
Returns the element corresponding to this type.
asElement() - Method in interface javax.lang.model.type.TypeVariable
Returns the element corresponding to this type variable.
asElement(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the element corresponding to a type.
asEndElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
asFileAttribute(Set<PosixFilePermission>) - Static method in class java.nio.file.attribute.PosixFilePermissions
Creates a FileAttribute, encapsulating a copy of the given file permissions, suitable for passing to the createFile or createDirectory methods.
asFloatBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a float buffer.
asin(double) - Static method in class java.lang.Math
Returns the arc sine of a value; the returned angle is in the range -pi/2 through pi/2.
asin(double) - Static method in class java.lang.StrictMath
Returns the arc sine of a value; the returned angle is in the range -pi/2 through pi/2.
asInstance(MethodHandle, Class<T>) - Static method in class java.lang.invoke.MethodHandles
Produces an instance of the given single-method interface which redirects its calls to the given method handle.
asIntBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as an int buffer.
asksAllowsChildren - Variable in class javax.swing.tree.DefaultTreeModel
Determines how the isLeaf method figures out if a node is a leaf node.
asksAllowsChildren() - Method in class javax.swing.tree.DefaultTreeModel
Tells how leaf nodes are determined.
asLifoQueue(Deque<T>) - Static method in class java.util.Collections
Returns a view of a Deque as a Last-in-first-out (Lifo) Queue.
asList(T...) - Static method in class java.util.Arrays
Returns a fixed-size list backed by the specified array.
asList() - Method in class javax.management.AttributeList
Return a view of this list as a List<Attribute>.
asList() - Method in class javax.management.relation.RoleList
Return a view of this list as a List<Role>.
asList() - Method in class javax.management.relation.RoleUnresolvedList
Return a view of this list as a List<RoleUnresolved>.
asLongBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a long buffer.
asMemberOf(DeclaredType, Element) - Method in interface javax.lang.model.util.Types
Returns the type of an element when that element is viewed as a member of, or otherwise directly contained by, a given type.
asReadOnlyBuffer() - Method in class java.nio.ByteBuffer
Creates a new, read-only byte buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.CharBuffer
Creates a new, read-only char buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.DoubleBuffer
Creates a new, read-only double buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.FloatBuffer
Creates a new, read-only float buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.IntBuffer
Creates a new, read-only int buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.LongBuffer
Creates a new, read-only long buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.ShortBuffer
Creates a new, read-only short buffer that shares this buffer's content.
assembleSystemMenu() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
assembleSystemMenu() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method to do nothing.
AssertionError - Error in java.lang
Thrown to indicate that an assertion has failed.
AssertionError() - Constructor for error java.lang.AssertionError
Constructs an AssertionError with no detail message.
AssertionError(Object) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified object, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(boolean) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified boolean, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(char) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified char, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(int) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified int, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(long) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified long, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(float) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified float, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(double) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified double, which is converted to a string as defined in The Java Language Specification, Second Edition, Section 15.18.1.1.
AssertionError(String, Throwable) - Constructor for error java.lang.AssertionError
Constructs a new AssertionError with the specified detail message and cause.
asShortBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a short buffer.
assign(DynAny) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Copy the contents from one Dynamic Any into another.
assign(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
asSpreader(Class<?>, int) - Method in class java.lang.invoke.MethodHandle
Makes an adapter which accepts a trailing array argument and spreads its elements as positional arguments.
asStartElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
asSubclass(Class<U>) - Method in class java.lang.类
Casts this 类 object to represent a subclass of the class represented by the specified class object.
assureRectsCreated(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
asType(MethodType) - Method in class java.lang.invoke.MethodHandle
Produces an adapter method handle which adapts the type of the current method handle to a new type.
asType() - Method in interface javax.lang.model.element.Element
Returns the type defined by this element.
asVarargsCollector(Class<?>) - Method in class java.lang.invoke.MethodHandle
Makes a variable arity adapter which is able to accept any number of trailing positional arguments and collect them into an array argument.
AsyncBoxView - Class in javax.swing.text
A box that does layout asynchronously.
AsyncBoxView(Element, int) - Constructor for class javax.swing.text.AsyncBoxView
Construct a box view that does asynchronous layout.
AsyncBoxView.ChildLocator - Class in javax.swing.text
A class to manage the effective position of the child views in a localized area while changes are being made around the localized area.
AsyncBoxView.ChildLocator() - Constructor for class javax.swing.text.AsyncBoxView.ChildLocator
construct a child locator.
AsyncBoxView.ChildState - Class in javax.swing.text
A record representing the layout state of a child view.
AsyncBoxView.ChildState(View) - Constructor for class javax.swing.text.AsyncBoxView.ChildState
Construct a child status.
AsyncHandler<T> - Interface in javax.xml.ws
The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
AsynchronousByteChannel - Interface in java.nio.channels
An asynchronous channel that can read and write bytes.
AsynchronousChannel - Interface in java.nio.channels
A channel that supports asynchronous I/O operations.
AsynchronousChannelGroup - Class in java.nio.channels
A grouping of asynchronous channels for the purpose of resource sharing.
AsynchronousChannelGroup(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousChannelGroup
Initialize a new instance of this class.
AsynchronousChannelProvider - Class in java.nio.channels.spi
Service-provider class for asynchronous channels.
AsynchronousChannelProvider() - Constructor for class java.nio.channels.spi.AsynchronousChannelProvider
Initializes a new instance of this class.
AsynchronousCloseException - Exception in java.nio.channels
Checked exception received by a thread when another thread closes the channel or the part of the channel upon which it is blocked in an I/O operation.
AsynchronousCloseException() - Constructor for exception java.nio.channels.AsynchronousCloseException
Constructs an instance of this class.
AsynchronousFileChannel - Class in java.nio.channels
An asynchronous channel for reading, writing, and manipulating a file.
AsynchronousFileChannel() - Constructor for class java.nio.channels.AsynchronousFileChannel
Initializes a new instance of this class.
AsynchronousServerSocketChannel - Class in java.nio.channels
An asynchronous channel for stream-oriented listening sockets.
AsynchronousServerSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousServerSocketChannel
Initializes a new instance of this class.
AsynchronousSocketChannel - Class in java.nio.channels
An asynchronous channel for stream-oriented connecting sockets.
AsynchronousSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousSocketChannel
Initializes a new instance of this class.
AT_TARGET - Static variable in interface org.w3c.dom.events.Event
The event is currently being evaluated at the target EventTarget.
atan(double) - Static method in class java.lang.Math
Returns the arc tangent of a value; the returned angle is in the range -pi/2 through pi/2.
atan(double) - Static method in class java.lang.StrictMath
Returns the arc tangent of a value; the returned angle is in the range -pi/2 through pi/2.
atan2(double, double) - Static method in class java.lang.Math
Returns the angle theta from the conversion of rectangular coordinates (x, y) to polar coordinates (r, theta).
atan2(double, double) - Static method in class java.lang.StrictMath
Returns the angle theta from the conversion of rectangular coordinates (x, y) to polar coordinates (r, theta).
AtomicBoolean - Class in java.util.concurrent.atomic
A boolean value that may be updated atomically.
AtomicBoolean(boolean) - Constructor for class java.util.concurrent.atomic.AtomicBoolean
Creates a new AtomicBoolean with the given initial value.
AtomicBoolean() - Constructor for class java.util.concurrent.atomic.AtomicBoolean
Creates a new AtomicBoolean with initial value false.
AtomicInteger - Class in java.util.concurrent.atomic
An int value that may be updated atomically.
AtomicInteger(int) - Constructor for class java.util.concurrent.atomic.AtomicInteger
Creates a new AtomicInteger with the given initial value.
AtomicInteger() - Constructor for class java.util.concurrent.atomic.AtomicInteger
Creates a new AtomicInteger with initial value 0.
AtomicIntegerArray - Class in java.util.concurrent.atomic
An int array in which elements may be updated atomically.
AtomicIntegerArray(int) - Constructor for class java.util.concurrent.atomic.AtomicIntegerArray
Creates a new AtomicIntegerArray of the given length, with all elements initially zero.
AtomicIntegerArray(int[]) - Constructor for class java.util.concurrent.atomic.AtomicIntegerArray
Creates a new AtomicIntegerArray with the same length as, and all elements copied from, the given array.
AtomicIntegerFieldUpdater<T> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile int fields of designated classes.
AtomicIntegerFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicLong - Class in java.util.concurrent.atomic
A long value that may be updated atomically.
AtomicLong(long) - Constructor for class java.util.concurrent.atomic.AtomicLong
Creates a new AtomicLong with the given initial value.
AtomicLong() - Constructor for class java.util.concurrent.atomic.AtomicLong
Creates a new AtomicLong with initial value 0.
AtomicLongArray - Class in java.util.concurrent.atomic
A long array in which elements may be updated atomically.
AtomicLongArray(int) - Constructor for class java.util.concurrent.atomic.AtomicLongArray
Creates a new AtomicLongArray of the given length, with all elements initially zero.
AtomicLongArray(long[]) - Constructor for class java.util.concurrent.atomic.AtomicLongArray
Creates a new AtomicLongArray with the same length as, and all elements copied from, the given array.
AtomicLongFieldUpdater<T> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile long fields of designated classes.
AtomicLongFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicLongFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicMarkableReference<V> - Class in java.util.concurrent.atomic
An AtomicMarkableReference maintains an object reference along with a mark bit, that can be updated atomically.
AtomicMarkableReference(V, boolean) - Constructor for class java.util.concurrent.atomic.AtomicMarkableReference
Creates a new AtomicMarkableReference with the given initial values.
AtomicMoveNotSupportedException - Exception in java.nio.file
Checked exception thrown when a file cannot be moved as an atomic file system operation.
AtomicMoveNotSupportedException(String, String, String) - Constructor for exception java.nio.file.AtomicMoveNotSupportedException
Constructs an instance of this class.
AtomicReference<V> - Class in java.util.concurrent.atomic
An object reference that may be updated atomically.
AtomicReference(V) - Constructor for class java.util.concurrent.atomic.AtomicReference
Creates a new AtomicReference with the given initial value.
AtomicReference() - Constructor for class java.util.concurrent.atomic.AtomicReference
Creates a new AtomicReference with null initial value.
AtomicReferenceArray<E> - Class in java.util.concurrent.atomic
An array of object references in which elements may be updated atomically.
AtomicReferenceArray(int) - Constructor for class java.util.concurrent.atomic.AtomicReferenceArray
Creates a new AtomicReferenceArray of the given length, with all elements initially null.
AtomicReferenceArray(E[]) - Constructor for class java.util.concurrent.atomic.AtomicReferenceArray
Creates a new AtomicReferenceArray with the same length as, and all elements copied from, the given array.
AtomicReferenceFieldUpdater<T,V> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile reference fields of designated classes.
AtomicReferenceFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicStampedReference<V> - Class in java.util.concurrent.atomic
An AtomicStampedReference maintains an object reference along with an integer "stamp", that can be updated atomically.
AtomicStampedReference(V, int) - Constructor for class java.util.concurrent.atomic.AtomicStampedReference
Creates a new AtomicStampedReference with the given initial values.
attach(Object) - Method in class java.nio.channels.SelectionKey
Attaches the given object to this key.
attachment() - Method in class java.nio.channels.SelectionKey
Retrieves the current attachment.
AttachmentMarshaller - Class in javax.xml.bind.attachment
Enable JAXB marshalling to optimize storage of binary data.
AttachmentMarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentMarshaller
AttachmentPart - Class in javax.xml.soap
A single attachment to a SOAPMessage object.
AttachmentPart() - Constructor for class javax.xml.soap.AttachmentPart
AttachmentUnmarshaller - Class in javax.xml.bind.attachment
Enables JAXB unmarshalling of a root document containing optimized binary data formats.
AttachmentUnmarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentUnmarshaller
ATTEMPTED - Static variable in class javax.print.attribute.standard.PDLOverrideSupported
The printer attempts to make the external job attribute values take precedence over embedded instructions in the documents' print data, however there is no guarantee.
attemptMark(V, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Atomically sets the value of the mark to the given update value if the current reference is == to the expected reference.
attemptStamp(V, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference
Atomically sets the value of the stamp to the given update value if the current reference is == to the expected reference.
attr(String) - Static method in class javax.management.Query
Returns a new attribute expression.
attr(String, String) - Static method in class javax.management.Query
Returns a new qualified attribute expression.
Attr - Interface in org.w3c.dom
The Attr interface represents an attribute in an Element object.
Attribute - Class in javax.management
Represents an MBean attribute by associating its name with its value.
Attribute(String, Object) - Constructor for class javax.management.Attribute
Constructs an Attribute object which associates the given attribute name with the given value.
Attribute - Interface in javax.naming.directory
This interface represents an attribute associated with a named object.
Attribute - Interface in javax.print.attribute
Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
Attribute - Interface in javax.xml.stream.events
An interface that contains information about an attribute.
ATTRIBUTE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an attribute
attribute(QName, String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
ATTRIBUTE_CHANGE - Static variable in class javax.management.AttributeChangeNotification
Notification type which indicates that the observed MBean attribute value has changed.
ATTRIBUTE_NODE - Static variable in interface org.w3c.dom.Node
The node is an Attr.
ATTRIBUTE_RUN - Static variable in interface javax.accessibility.AccessibleExtendedText
Constant used to indicate that the part of the text that should be retrieved is contiguous text with the same text attributes.
AttributeChangeNotification - Class in javax.management
Provides definitions of the attribute change notifications sent by MBeans.
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - Constructor for class javax.management.AttributeChangeNotification
Constructs an attribute change notification object.
AttributeChangeNotificationFilter - Class in javax.management
This class implements of the NotificationFilter interface for the attribute change notification.
AttributeChangeNotificationFilter() - Constructor for class javax.management.AttributeChangeNotificationFilter
AttributedCharacterIterator - Interface in java.text
An AttributedCharacterIterator allows iteration through both text and related attribute information.
AttributedCharacterIterator.Attribute - Class in java.text
Defines attribute keys that are used to identify text attributes.
AttributedCharacterIterator.Attribute(String) - Constructor for class java.text.AttributedCharacterIterator.Attribute
Constructs an Attribute with the given name.
attributeDecl(String, String, String, String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an attribute type declaration.
attributeDecl(String, String, String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2
AttributedString - Class in java.text
An AttributedString holds text and related attribute information.
AttributedString(String) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given text.
AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given text and attributes.
AttributedString(AttributedCharacterIterator) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given attributed text represented by AttributedCharacterIterator.
AttributedString(AttributedCharacterIterator, int, int) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the subrange of the given attributed text represented by AttributedCharacterIterator.
AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[]) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the subrange of the given attributed text represented by AttributedCharacterIterator.
AttributeException - Interface in javax.print
Interface AttributeException is a mixin interface which a subclass of PrintException can implement to report an error condition involving one or more printing attributes that a particular Print Service instance does not support.
AttributeInUseException - Exception in javax.naming.directory
This exception is thrown when an operation attempts to add an attribute that already exists.
AttributeInUseException(String) - Constructor for exception javax.naming.directory.AttributeInUseException
Constructs a new instance of AttributeInUseException with an explanation.
AttributeInUseException() - Constructor for exception javax.naming.directory.AttributeInUseException
Constructs a new instance of AttributeInUseException.
AttributeList - Class in javax.management
Represents a list of values for attributes of an MBean.
AttributeList() - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList.
AttributeList(int) - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList with the initial capacity specified.
AttributeList(AttributeList) - Constructor for class javax.management.AttributeList
Constructs an AttributeList containing the elements of the AttributeList specified, in the order in which they are returned by the AttributeList's iterator.
AttributeList(List<Attribute>) - Constructor for class javax.management.AttributeList
Constructs an AttributeList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
AttributeList - Class in javax.swing.text.html.parser
This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
AttributeList(String) - Constructor for class javax.swing.text.html.parser.AttributeList
Create an attribute list element.
AttributeList(String, int, int, String, Vector<?>, AttributeList) - Constructor for class javax.swing.text.html.parser.AttributeList
Create an attribute list element.
AttributeList - Interface in org.xml.sax
Deprecated.
This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
AttributeListImpl - Class in org.xml.sax.helpers
Deprecated.
This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
AttributeListImpl() - Constructor for class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Create an empty attribute list.
AttributeListImpl(AttributeList) - Constructor for class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Construct a persistent copy of an existing attribute list.
AttributeModificationException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add, or remove, or modify an attribute, its identifier, or its values that conflicts with the attribute's (schema) definition or the attribute's state.
AttributeModificationException(String) - Constructor for exception javax.naming.directory.AttributeModificationException
Constructs a new instance of AttributeModificationException using an explanation.
AttributeModificationException() - Constructor for exception javax.naming.directory.AttributeModificationException
Constructs a new instance of AttributeModificationException.
attributeNames() - Method in class java.beans.FeatureDescriptor
Gets an enumeration of the locale-independent names of this feature.
attributeNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values might not be allowed.
AttributeNotFoundException - Exception in javax.management
The specified attribute does not exist or cannot be retrieved.
AttributeNotFoundException() - Constructor for exception javax.management.AttributeNotFoundException
Default constructor.
AttributeNotFoundException(String) - Constructor for exception javax.management.AttributeNotFoundException
Constructor that allows a specific error message to be specified.
attributeNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are definitely allowed.
attributeNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that whether NULL values are allowed is not known.
Attributes - Class in java.util.jar
The Attributes class maps Manifest attribute names to associated string values.
Attributes() - Constructor for class java.util.jar.Attributes
Constructs a new, empty Attributes object with default size.
Attributes(int) - Constructor for class java.util.jar.Attributes
Constructs a new, empty Attributes object with the specified initial size.
Attributes(Attributes) - Constructor for class java.util.jar.Attributes
Constructs a new Attributes object with the same attribute name-value mappings as in the specified Attributes.
attributes - Variable in class javax.accessibility.AccessibleAttributeSequence
The text attributes
Attributes - Interface in javax.naming.directory
This interface represents a collection of attributes.
Attributes - Interface in org.xml.sax
Interface for a list of XML attributes.
Attributes.Name - Class in java.util.jar
The Attributes.Name class represents an attribute name stored in this Map.
Attributes.Name(String) - Constructor for class java.util.jar.Attributes.Name
Constructs a new attribute name using the given string name.
Attributes2 - Interface in org.xml.sax.ext
SAX2 extension to augment the per-attribute information provided though Attributes.
Attributes2Impl - Class in org.xml.sax.ext
SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Attributes2Impl() - Constructor for class org.xml.sax.ext.Attributes2Impl
Construct a new, empty Attributes2Impl object.
Attributes2Impl(Attributes) - Constructor for class org.xml.sax.ext.Attributes2Impl
Copy an existing Attributes or Attributes2 object.
AttributeSet - Interface in javax.print.attribute
Interface AttributeSet specifies the interface for a set of printing attributes.
AttributeSet - Interface in javax.swing.text
A collection of unique attributes.
AttributeSet.CharacterAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation.
AttributeSet.ColorAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
AttributeSet.FontAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text.
AttributeSet.ParagraphAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.
AttributeSetUtilities - Class in javax.print.attribute
Class AttributeSetUtilities provides static methods for manipulating AttributeSets.
AttributesImpl - Class in org.xml.sax.helpers
Default implementation of the Attributes interface.
AttributesImpl() - Constructor for class org.xml.sax.helpers.AttributesImpl
Construct a new, empty AttributesImpl object.
AttributesImpl(Attributes) - Constructor for class org.xml.sax.helpers.AttributesImpl
Copy an existing Attributes object.
attributeUpdate(PrintJobAttributeEvent) - Method in interface javax.print.event.PrintJobAttributeListener
Notifies the listener of a change in some print job attributes.
attributeUpdate(PrintServiceAttributeEvent) - Method in interface javax.print.event.PrintServiceAttributeListener
Called to notify a listener of an event in the print service.
AttributeValueExp - Class in javax.management
Represents attributes used as arguments to relational constraints.
AttributeValueExp() - Constructor for class javax.management.AttributeValueExp
Deprecated.
An instance created with this constructor cannot be used in a query.
AttributeValueExp(String) - Constructor for class javax.management.AttributeValueExp
Creates a new AttributeValueExp representing the specified object attribute, named attr.
AttributeView - Interface in java.nio.file.attribute
An object that provides a read-only or updatable view of non-opaque values associated with an object in a filesystem.
attrID - Variable in class javax.naming.directory.BasicAttribute
Holds the attribute's id.
atts - Variable in class javax.swing.text.html.parser.Element
AU - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AU file.
AudioClip - Interface in java.applet
The AudioClip interface is a simple abstraction for playing a sound clip.
AudioFileFormat - Class in javax.sound.sampled
An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.
AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int) - Constructor for class javax.sound.sampled.AudioFileFormat
Constructs an audio file format object.
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int) - Constructor for class javax.sound.sampled.AudioFileFormat
Constructs an audio file format object.
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>) - Constructor for class javax.sound.sampled.AudioFileFormat
Construct an audio file format object with a set of defined properties.
AudioFileFormat.Type - Class in javax.sound.sampled
An instance of the Type class represents one of the standard types of audio file.
AudioFileFormat.Type(String, String) - Constructor for class javax.sound.sampled.AudioFileFormat.Type
Constructs a file type.
AudioFileReader - Class in javax.sound.sampled.spi
Provider for audio file reading services.
AudioFileReader() - Constructor for class javax.sound.sampled.spi.AudioFileReader
AudioFileWriter - Class in javax.sound.sampled.spi
Provider for audio file writing services.
AudioFileWriter() - Constructor for class javax.sound.sampled.spi.AudioFileWriter
AudioFormat - Class in javax.sound.sampled
AudioFormat is the class that specifies a particular arrangement of data in a sound stream.
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with the given parameters.
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with the given parameters.
AudioFormat(float, int, int, boolean, boolean) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with a linear PCM encoding and the given parameters.
AudioFormat.Encoding - Class in javax.sound.sampled
The Encoding class names the specific type of data representation used for an audio stream.
AudioFormat.Encoding(String) - Constructor for class javax.sound.sampled.AudioFormat.Encoding
Constructs a new encoding.
AudioInputStream - Class in javax.sound.sampled
An audio input stream is an input stream with a specified audio format and length.
AudioInputStream(InputStream, AudioFormat, long) - Constructor for class javax.sound.sampled.AudioInputStream
Constructs an audio input stream that has the requested format and length in sample frames, using audio data from the specified input stream.
AudioInputStream(TargetDataLine) - Constructor for class javax.sound.sampled.AudioInputStream
Constructs an audio input stream that reads its data from the target data line indicated.
AudioPermission - Class in javax.sound.sampled
The AudioPermission class represents access rights to the audio system resources.
AudioPermission(String) - Constructor for class javax.sound.sampled.AudioPermission
Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".
AudioPermission(String, String) - Constructor for class javax.sound.sampled.AudioPermission
Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".
AudioSystem - Class in javax.sound.sampled
The AudioSystem class acts as the entry point to the sampled-audio system resources.
augmentList(Action[], Action[]) - Static method in class javax.swing.text.TextAction
Takes one list of commands and augments it with another list of commands.
AUGUST - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the eighth month of the year in the Gregorian and Julian calendars.
AUGUST - Static variable in class javax.xml.datatype.DatatypeConstants
Value for eighth month of year.
authenticate(Object) - Method in interface javax.management.remote.JMXAuthenticator
Authenticates the MBeanServerConnection client with the given client credentials.
AuthenticationException - Exception in javax.naming
This exception is thrown when an authentication error occurs while accessing the naming or directory service.
AuthenticationException(String) - Constructor for exception javax.naming.AuthenticationException
Constructs a new instance of AuthenticationException using the explanation supplied.
AuthenticationException() - Constructor for exception javax.naming.AuthenticationException
Constructs a new instance of AuthenticationException.
AuthenticationException - Exception in javax.security.sasl
This exception is thrown by a SASL mechanism implementation to indicate that the SASL exchange has failed due to reasons related to authentication, such as an invalid identity, passphrase, or key.
AuthenticationException() - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException.
AuthenticationException(String) - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException with a detailed message.
AuthenticationException(String, Throwable) - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException with a detailed message and a root exception.
AuthenticationNotSupportedException - Exception in javax.naming
This exception is thrown when the particular flavor of authentication requested is not supported.
AuthenticationNotSupportedException(String) - Constructor for exception javax.naming.AuthenticationNotSupportedException
Constructs a new instance of AuthenticationNotSupportedException using an explanation.
AuthenticationNotSupportedException() - Constructor for exception javax.naming.AuthenticationNotSupportedException
Constructs a new instance of AuthenticationNotSupportedException all name resolution fields and explanation initialized to null.
Authenticator - Class in java.net
The class Authenticator represents an object that knows how to obtain authentication for a network connection.
Authenticator() - Constructor for class java.net.Authenticator
AUTHENTICATOR - Static variable in class javax.management.remote.JMXConnectorServer
Name of the attribute that specifies the authenticator for a connector server.
Authenticator.RequestorType - Enum in java.net
The type of the entity requesting authentication.
AUTHORITATIVE - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the authoritativeness of the service requested.
AuthorizeCallback - Class in javax.security.sasl
This callback is used by SaslServer to determine whether one entity (identified by an authenticated authentication id) can act on behalf of another entity (identified by an authorization id).
AuthorizeCallback(String, String) - Constructor for class javax.security.sasl.AuthorizeCallback
Constructs an instance of AuthorizeCallback.
AuthPermission - Class in javax.security.auth
This class is for authentication permissions.
AuthPermission(String) - Constructor for class javax.security.auth.AuthPermission
Creates a new AuthPermission with the specified name.
AuthPermission(String, String) - Constructor for class javax.security.auth.AuthPermission
Creates a new AuthPermission object with the specified name.
AuthProvider - Class in java.security
This class defines login and logout methods for a provider.
AuthProvider(String, double, String) - Constructor for class java.security.AuthProvider
Constructs a provider with the specified name, version number, and information.
AUTO_RESIZE_ALL_COLUMNS - Static variable in class javax.swing.JTable
During all resize operations, proportionately resize all columns.
AUTO_RESIZE_LAST_COLUMN - Static variable in class javax.swing.JTable
During all resize operations, apply adjustments to the last column only.
AUTO_RESIZE_NEXT_COLUMN - Static variable in class javax.swing.JTable
When a column is adjusted in the UI, adjust the next column the opposite way.
AUTO_RESIZE_OFF - Static variable in class javax.swing.JTable
Do not adjust column widths automatically; use a horizontal scrollbar instead.
AUTO_RESIZE_SUBSEQUENT_COLUMNS - Static variable in class javax.swing.JTable
During UI adjustment, change subsequent columns to preserve the total width; this is the default behavior.
AutoCloseable - Interface in java.lang
A resource that must be closed when it is no longer needed.
autoCommitFailureClosesAllResultSets() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a SQLException while autoCommit is true inidcates that all open ResultSets are closed, even ones that are holdable.
autoCreateColumnsFromModel - Variable in class javax.swing.JTable
The table will query the TableModel to build the default set of columns if this is true.
autoResizeMode - Variable in class javax.swing.JTable
Determines if the table automatically resizes the width of the table's columns to take up the entire width of the table, and how it does the resizing.
Autoscroll - Interface in java.awt.dnd
During DnD operations it is possible that a user may wish to drop the subject of the operation on a region of a scrollable GUI control that is not currently visible to the user.
autoscroll(Point) - Method in interface java.awt.dnd.Autoscroll
notify the Component to autoscroll
autoScrollDown() - Method in class javax.swing.plaf.basic.BasicComboPopup
This protected method is implementation specific and should be private.
autoscrollTimer - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
autoScrollUp() - Method in class javax.swing.plaf.basic.BasicComboPopup
This protected method is implementation specific and should be private.
AUTOSENSE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "[B" (byte array).
AUTOSENSE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.io.InputStream" (byte stream).
AUTOSENSE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.net.URL".
AUX_RETURN - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the auxiliary return gain on a line.
AUX_SEND - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the auxiliary send gain on a line.
available() - Method in class java.io.BufferedInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.ByteArrayInputStream
Returns the number of remaining bytes that can be read (or skipped over) from this input stream.
available() - Method in class java.io.FileInputStream
Returns an estimate of the number of remaining bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.FilterInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next caller of a method for this input stream.
available() - Method in class java.io.InputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.LineNumberInputStream
Deprecated.
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in interface java.io.ObjectInput
Returns the number of bytes that can be read without blocking.
available() - Method in class java.io.ObjectInputStream
Returns the number of bytes that can be read without blocking.
available() - Method in class java.io.PipedInputStream
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in class java.io.PushbackInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.SequenceInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from the current underlying input stream without blocking by the next invocation of a method for the current underlying input stream.
available() - Method in class java.io.StringBufferInputStream
Deprecated.
Returns the number of bytes that can be read from the input stream without blocking.
available() - Method in class java.net.SocketImpl
Returns the number of bytes that can be read from this socket without blocking.
available() - Method in class java.util.zip.DeflaterInputStream
Returns 0 after EOF has been reached, otherwise always return 1.
available() - Method in class java.util.zip.InflaterInputStream
Returns 0 after EOF has been reached, otherwise always return 1.
available() - Method in class java.util.zip.ZipInputStream
Returns 0 after EOF has reached for the current entry data, otherwise always return 1.
available() - Method in class javax.crypto.CipherInputStream
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in class javax.sound.sampled.AudioInputStream
Returns the maximum number of bytes that can be read (or skipped over) from this audio input stream without blocking.
available() - Method in interface javax.sound.sampled.DataLine
Obtains the number of bytes of data currently available to the application for processing in the data line's internal buffer.
availableCharsets() - Static method in class java.nio.charset.Charset
Constructs a sorted map from canonical charset names to charset objects.
availableLocales - Variable in class javax.imageio.ImageReader
An array of Locales which may be used to localize warning messages, or null if localization is not supported.
availableLocales - Variable in class javax.imageio.ImageWriter
An array of Locales that may be used to localize warning messages and compression setting values, or null if localization is not supported.
availablePermits() - Method in class java.util.concurrent.Semaphore
Returns the current number of permits available in this semaphore.
availableProcessors() - Method in class java.lang.Runtime
Returns the number of processors available to the Java virtual machine.
averageBytesPerChar() - Method in class java.nio.charset.CharsetEncoder
Returns the average number of bytes that will be produced for each character of input.
averageCharsPerByte() - Method in class java.nio.charset.CharsetDecoder
Returns the average number of characters that will be produced for each byte of input.
AVESTAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Avestan" Unicode character block.
avoidingGui() - Method in class java.beans.beancontext.BeanContextSupport
Used to determine if the BeanContext child is avoiding using its GUI.
avoidingGui() - Method in interface java.beans.Visibility
Determines whether this bean is avoiding using a GUI.
await() - Method in class java.util.concurrent.CountDownLatch
Causes the current thread to wait until the latch has counted down to zero, unless the thread is interrupted.
await(long, TimeUnit) - Method in class java.util.concurrent.CountDownLatch
Causes the current thread to wait until the latch has counted down to zero, unless the thread is interrupted, or the specified waiting time elapses.
await() - Method in class java.util.concurrent.CyclicBarrier
Waits until all parties have invoked await on this barrier.
await(long, TimeUnit) - Method in class java.util.concurrent.CyclicBarrier
Waits until all parties have invoked await on this barrier, or the specified waiting time elapses.
await() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements interruptible condition wait.
await(long, TimeUnit) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements timed condition wait.
await() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements interruptible condition wait.
await(long, TimeUnit) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements timed condition wait.
await() - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted.
await(long, TimeUnit) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified waiting time elapses.
awaitAdvance(int) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value, returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitAdvanceInterruptibly(int) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value, throwing InterruptedException if interrupted while waiting, or returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitAdvanceInterruptibly(int, long, TimeUnit) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value or the given timeout to elapse, throwing InterruptedException if interrupted while waiting, or returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitNanos(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements timed condition wait.
awaitNanos(long) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements timed condition wait.
awaitNanos(long) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified waiting time elapses.
awaitTermination(long, TimeUnit) - Method in class java.nio.channels.AsynchronousChannelGroup
Awaits termination of the group.
awaitTermination(long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Blocks until all tasks have completed execution after a shutdown request, or the timeout occurs, or the current thread is interrupted, whichever happens first.
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent.ForkJoinPool
Blocks until all tasks have completed execution after a shutdown request, or the timeout occurs, or the current thread is interrupted, whichever happens first.
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent.ThreadPoolExecutor
awaitUninterruptibly() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements uninterruptible condition wait.
awaitUninterruptibly() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements uninterruptible condition wait.
awaitUninterruptibly() - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled.
awaitUntil(Date) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements absolute timed condition wait.
awaitUntil(Date) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements absolute timed condition wait.
awaitUntil(Date) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified deadline elapses.
AWT_COMPONENT - Static variable in class javax.accessibility.AccessibleRole
An AWT component, but nothing else is known about it.
AWTError - Error in java.awt
Thrown when a serious Abstract Window Toolkit error has occurred.
AWTError(String) - Constructor for error java.awt.AWTError
Constructs an instance of AWTError with the specified detail message.
AWTEvent - Class in java.awt
The root event class for all AWT events.
AWTEvent(Event) - Constructor for class java.awt.AWTEvent
Constructs an AWTEvent object from the parameters of a 1.0-style event.
AWTEvent(Object, int) - Constructor for class java.awt.AWTEvent
Constructs an AWTEvent object with the specified source object and type.
AWTEventListener - Interface in java.awt.event
The listener interface for receiving notification of events dispatched to objects that are instances of Component or MenuComponent or their subclasses.
AWTEventListenerProxy - Class in java.awt.event
A class which extends the EventListenerProxy specifically for adding an AWTEventListener for a specific event mask.
AWTEventListenerProxy(long, AWTEventListener) - Constructor for class java.awt.event.AWTEventListenerProxy
Constructor which binds the AWTEventListener to a specific event mask.
AWTEventMulticaster - Class in java.awt
AWTEventMulticaster implements efficient and thread-safe multi-cast event dispatching for the AWT events defined in the java.awt.event package.
AWTEventMulticaster(EventListener, EventListener) - Constructor for class java.awt.AWTEventMulticaster
Creates an event multicaster instance which chains listener-a with listener-b.
AWTException - Exception in java.awt
Signals that an Absract Window Toolkit exception has occurred.
AWTException(String) - Constructor for exception java.awt.AWTException
Constructs an instance of AWTException with the specified detail message.
AWTKeyStroke - Class in java.awt
An AWTKeyStroke represents a key action on the keyboard, or equivalent input device.
AWTKeyStroke() - Constructor for class java.awt.AWTKeyStroke
Constructs an AWTKeyStroke with default values.
AWTKeyStroke(char, int, int, boolean) - Constructor for class java.awt.AWTKeyStroke
Constructs an AWTKeyStroke with the specified values.
AWTPermission - Class in java.awt
This class is for AWT permissions.
AWTPermission(String) - Constructor for class java.awt.AWTPermission
Creates a new AWTPermission with the specified name.
AWTPermission(String, String) - Constructor for class java.awt.AWTPermission
Creates a new AWTPermission object with the specified name.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类


B-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

b - Variable in class java.awt.AWTEventMulticaster
B - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering B, 11 x 17 in.
B - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering B size, 11 inch by 17 inch.
B - Static variable in class javax.print.attribute.standard.MediaSizeName
B size .
B - Static variable in class javax.swing.text.html.HTML.Tag
B0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B0.
B0 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B0 size, 1000 mm by 1414 mm.
B0 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B0 size, 1030 mm by 1456 mm.
B1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B1.
B1 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B1 size, 707 mm by 1000 mm.
B1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B1 size, 728 mm by 1030 mm.
B10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B10.
B10 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B10 size, 31 mm by 44 mm.
B10 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B10 size, 32 mm by 45 mm.
B2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B2.
B2 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B2 size, 500 mm by 707 mm.
B2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B2 size, 515 mm by 728 mm.
B3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B3.
B3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B3 size, 353 mm by 500 mm.
B3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B3 size, 364 mm by 515 mm.
B4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B4.
B4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B4 size, 250 mm by 353 mm.
B4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B4 size, 257 mm by 364 mm.
B5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B5.
B5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B5 size, 176 mm by 250 mm.
B5 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B5 size, 182 mm by 257 mm.
B6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B6.
B6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B6 size, 125 mm by 176 mm.
B6 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B6 size, 128 mm by 182 mm.
B7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B7.
B7 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B7 size, 88 mm by 125 mm.
B7 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B7 size, 91 mm by 128 mm.
B8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B8.
B8 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B8 size, 62 mm by 88 mm.
B8 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B8 size, 64 mm by 91 mm.
B9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B9.
B9 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B9 size, 44 mm by 62 mm.
B9 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B9 size, 45 mm by 64 mm.
BACK_SPACE - Static variable in class java.awt.Event
The BackSpace key.
backBuffers - Variable in class java.awt.Component.BltBufferStrategy
The back buffers
BACKGROUND - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are BACKGROUND, the contents of the back buffer are cleared with the background color after flipping.
BACKGROUND - Static variable in class java.awt.font.TextAttribute
Attribute key for the paint used to render the background of the text.
BACKGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the background of a region.
BACKGROUND - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND - Static variable in class javax.swing.text.html.HTML.Attribute
Background - Static variable in class javax.swing.text.StyleConstants
Name of the background color attribute.
BACKGROUND_ATTACHMENT - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_IMAGE - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_POSITION - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_REPEAT - Static variable in class javax.swing.text.html.CSS.Attribute
backgroundNonSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the background when the node isn't selected.
backgroundSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the background when a node is selected.
backingStore - Variable in class javax.swing.JViewport
Deprecated.
As of Java 2 platform v1.3
BACKINGSTORE_SCROLL_MODE - Static variable in class javax.swing.JViewport
Draws viewport contents into an offscreen image.
BackingStoreException - Exception in java.util.prefs
Thrown to indicate that a preferences operation could not complete because of a failure in the backing store, or a failure to contact the backing store.
BackingStoreException(String) - Constructor for exception java.util.prefs.BackingStoreException
Constructs a BackingStoreException with the specified detail message.
BackingStoreException(Throwable) - Constructor for exception java.util.prefs.BackingStoreException
Constructs a BackingStoreException with the specified cause.
backingStoreImage - Variable in class javax.swing.JViewport
The view image used for a backing store.
Backward - Static variable in class javax.swing.text.Position.Bias
Indicates a bias toward the previous character in the model.
BACKWARD_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Backward focus traversal keys.
backwardAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically backward one position.
BAD_BINDINGS - Static variable in exception org.ietf.jgss.GSSException
Channel bindings mismatch.
BAD_CONTEXT - Exception in org.omg.CORBA
Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
BAD_CONTEXT() - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_CONTEXT(String) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
BAD_CONTEXT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
BAD_CONTEXT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.
BAD_INV_ORDER - Exception in org.omg.CORBA
This exception indicates that the caller has invoked operations in the wrong order.
BAD_INV_ORDER() - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_INV_ORDER(String) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_INV_ORDER(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
BAD_INV_ORDER(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.
BAD_LOCATION - Static variable in class javax.swing.text.AbstractDocument
Error message to indicate a bad location.
BAD_MECH - Static variable in exception org.ietf.jgss.GSSException
Unsupported mechanism requested.
BAD_MIC - Static variable in exception org.ietf.jgss.GSSException
Token had invalid integrity check.
BAD_NAME - Static variable in exception org.ietf.jgss.GSSException
Invalid name provided.
BAD_NAMETYPE - Static variable in exception org.ietf.jgss.GSSException
Name of unsupported type provided.
BAD_OPERATION - Exception in org.omg.CORBA
Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
BAD_OPERATION() - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_OPERATION(String) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_OPERATION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified minor code and completion status.
BAD_OPERATION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.
BAD_PARAM - Exception in org.omg.CORBA
Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
BAD_PARAM() - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_PARAM(String) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_PARAM(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified minor code and completion status.
BAD_PARAM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.
BAD_POLICY - Interface in org.omg.CORBA
A PolicyErrorCode which would be filled in the PolicyError exception.
BAD_POLICY_TYPE - Interface in org.omg.CORBA
A PolicyErrorCode which would be filled in the PolicyError exception.
BAD_POLICY_VALUE - Interface in org.omg.CORBA
Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.
BAD_QOP - Static variable in exception org.ietf.jgss.GSSException
Unsupported QOP value.
BAD_QOS - Exception in org.omg.CORBA
The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
BAD_QOS() - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
BAD_QOS(String) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified message.
BAD_QOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified minor code and completion status.
BAD_QOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
BAD_STATUS - Static variable in exception org.ietf.jgss.GSSException
Invalid status code.
BAD_TYPECODE - Exception in org.omg.CORBA
Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
BAD_TYPECODE() - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_TYPECODE(String) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_TYPECODE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
BAD_TYPECODE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.
BadAttributeValueExpException - Exception in javax.management
Thrown when an invalid MBean attribute is passed to a query constructing method.
BadAttributeValueExpException(Object) - Constructor for exception javax.management.BadAttributeValueExpException
Constructs an BadAttributeValueExpException with the specified Object.
BadBinaryOpValueExpException - Exception in javax.management
Thrown when an invalid expression is passed to a method for constructing a query.
BadBinaryOpValueExpException(ValueExp) - Constructor for exception javax.management.BadBinaryOpValueExpException
Constructs a BadBinaryOpValueExpException with the specified ValueExp.
BadBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view is a bad break opportunity for the purpose of formatting.
BadKind - Exception in org.omg.CORBA.TypeCodePackage
The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
BadKind() - Constructor for exception org.omg.CORBA.TypeCodePackage.BadKind
Constructs a BadKind exception with no reason message.
BadKind(String) - Constructor for exception org.omg.CORBA.TypeCodePackage.BadKind
Constructs a BadKind exception with the specified reason message.
BadLocationException - Exception in javax.swing.text
This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
BadLocationException(String, int) - Constructor for exception javax.swing.text.BadLocationException
Creates a new BadLocationException object.
BadPaddingException - Exception in javax.crypto
This exception is thrown when a particular padding mechanism is expected for the input data but the data is not padded properly.
BadPaddingException() - Constructor for exception javax.crypto.BadPaddingException
Constructs a BadPaddingException with no detail message.
BadPaddingException(String) - Constructor for exception javax.crypto.BadPaddingException
Constructs a BadPaddingException with the specified detail message.
BadStringOperationException - Exception in javax.management
Thrown when an invalid string operation is passed to a method for constructing a query.
BadStringOperationException(String) - Constructor for exception javax.management.BadStringOperationException
Constructs a BadStringOperationException with the specified detail message.
BALANCE - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the relative balance of a stereo signal between two stereo speakers.
BALINESE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Balinese" Unicode character block.
BAMUM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bamum" Unicode character block.
BAMUM_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bamum Supplement" Unicode character block.
BandCombineOp - Class in java.awt.image
This class performs an arbitrary linear combination of the bands in a Raster, using a specified matrix.
BandCombineOp(float[][], RenderingHints) - Constructor for class java.awt.image.BandCombineOp
Constructs a BandCombineOp with the specified matrix.
BandedSampleModel - Class in java.awt.image
This class represents image data which is stored in a band interleaved fashion and for which each sample of a pixel occupies one data element of the DataBuffer.
BandedSampleModel(int, int, int, int) - Constructor for class java.awt.image.BandedSampleModel
Constructs a BandedSampleModel with the specified parameters.
BandedSampleModel(int, int, int, int, int[], int[]) - Constructor for class java.awt.image.BandedSampleModel
Constructs a BandedSampleModel with the specified parameters.
bandOffsets - Variable in class java.awt.image.ComponentSampleModel
Offsets for all bands in data array elements.
bank - Variable in class javax.sound.midi.VoiceStatus
The bank number of the instrument that this voice is currently using.
bankIndices - Variable in class java.awt.image.ComponentSampleModel
Index for each bank storing a band of image data.
banks - Variable in class java.awt.image.DataBuffer
The number of banks in this DataBuffer.
BASE - Static variable in class javax.swing.text.html.HTML.Tag
base - Variable in class javax.swing.text.html.parser.DTD
BASE64 - Static variable in interface javax.xml.crypto.dsig.Transform
The Base64 transform algorithm URI.
BASEFONT - Static variable in class javax.swing.text.html.HTML.Tag
baseIsLeftToRight() - Method in class java.text.Bidi
Return true if the base direction is left-to-right.
BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BASELINE - Static variable in class javax.swing.SpringLayout
Specifies the baseline of a component.
BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
baselineLayout(int, int, int[], int[]) - Method in class javax.swing.text.BoxView
Computes the location and extent of each child view in this BoxView given the targetSpan, which is the width (or height) of the region we have to work with.
baselineRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for this BoxView by examining the size of each child view.
BaseRowSet - Class in javax.sql.rowset
An abstract class providing a RowSet object with its basic functionality.
BaseRowSet() - Constructor for class javax.sql.rowset.BaseRowSet
Constructs a new BaseRowSet object initialized with a default Vector object for its listeners field.
baseWireHandle - Static variable in interface java.io.ObjectStreamConstants
First wire handle to be assigned.
BASIC_LATIN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Basic Latin" Unicode character block.
BasicArrowButton - Class in javax.swing.plaf.basic
JButton object that draws a scaled Arrow in one of the cardinal directions.
BasicArrowButton(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicArrowButton
Creates a BasicArrowButton whose arrow is drawn in the specified direction and with the specified colors.
BasicArrowButton(int) - Constructor for class javax.swing.plaf.basic.BasicArrowButton
Creates a BasicArrowButton whose arrow is drawn in the specified direction.
BasicAttribute - Class in javax.naming.directory
This class provides a basic implementation of the Attribute interface.
BasicAttribute(String) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of an unordered attribute with no value.
BasicAttribute(String, Object) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of an unordered attribute with a single value.
BasicAttribute(String, boolean) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of a possibly ordered attribute with no value.
BasicAttribute(String, Object, boolean) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of a possibly ordered attribute with a single value.
BasicAttributes - Class in javax.naming.directory
This class provides a basic implementation of the Attributes interface.
BasicAttributes() - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes.
BasicAttributes(boolean) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes.
BasicAttributes(String, Object) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes with one attribute.
BasicAttributes(String, Object, boolean) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes with one attribute.
BasicBorders - Class in javax.swing.plaf.basic
Factory object that can vend Borders appropriate for the basic L & F.
BasicBorders() - Constructor for class javax.swing.plaf.basic.BasicBorders
BasicBorders.ButtonBorder - Class in javax.swing.plaf.basic
BasicBorders.ButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.ButtonBorder
BasicBorders.FieldBorder - Class in javax.swing.plaf.basic
BasicBorders.FieldBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.FieldBorder
BasicBorders.MarginBorder - Class in javax.swing.plaf.basic
BasicBorders.MarginBorder() - Constructor for class javax.swing.plaf.basic.BasicBorders.MarginBorder
BasicBorders.MenuBarBorder - Class in javax.swing.plaf.basic
BasicBorders.MenuBarBorder(Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.MenuBarBorder
BasicBorders.RadioButtonBorder - Class in javax.swing.plaf.basic
BasicBorders.RadioButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
BasicBorders.RolloverButtonBorder - Class in javax.swing.plaf.basic
Special thin border for rollover toolbar buttons.
BasicBorders.RolloverButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
BasicBorders.SplitPaneBorder - Class in javax.swing.plaf.basic
Draws the border around the splitpane.
BasicBorders.SplitPaneBorder(Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
BasicBorders.ToggleButtonBorder - Class in javax.swing.plaf.basic
BasicBorders.ToggleButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
BasicButtonListener - Class in javax.swing.plaf.basic
Button Listener
BasicButtonListener(AbstractButton) - Constructor for class javax.swing.plaf.basic.BasicButtonListener
BasicButtonUI - Class in javax.swing.plaf.basic
BasicButton implementation
BasicButtonUI() - Constructor for class javax.swing.plaf.basic.BasicButtonUI
BasicCheckBoxMenuItemUI - Class in javax.swing.plaf.basic
BasicCheckboxMenuItem implementation
BasicCheckBoxMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
BasicCheckBoxUI - Class in javax.swing.plaf.basic
CheckboxUI implementation for BasicCheckboxUI
BasicCheckBoxUI() - Constructor for class javax.swing.plaf.basic.BasicCheckBoxUI
BasicColorChooserUI - Class in javax.swing.plaf.basic
Provides the basic look and feel for a JColorChooser.
BasicColorChooserUI() - Constructor for class javax.swing.plaf.basic.BasicColorChooserUI
BasicColorChooserUI.PropertyHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicColorChooserUI.PropertyHandler() - Constructor for class javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
BasicComboBoxEditor - Class in javax.swing.plaf.basic
The default editor for editable combo boxes.
BasicComboBoxEditor() - Constructor for class javax.swing.plaf.basic.BasicComboBoxEditor
BasicComboBoxEditor.UIResource - Class in javax.swing.plaf.basic
A subclass of BasicComboBoxEditor that implements UIResource.
BasicComboBoxEditor.UIResource() - Constructor for class javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
BasicComboBoxRenderer - Class in javax.swing.plaf.basic
ComboBox renderer
BasicComboBoxRenderer() - Constructor for class javax.swing.plaf.basic.BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource - Class in javax.swing.plaf.basic
A subclass of BasicComboBoxRenderer that implements UIResource.
BasicComboBoxRenderer.UIResource() - Constructor for class javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
BasicComboBoxUI - Class in javax.swing.plaf.basic
Basic UI implementation for JComboBox.
BasicComboBoxUI() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI
BasicComboBoxUI.ComboBoxLayoutManager - Class in javax.swing.plaf.basic
This layout manager handles the 'standard' layout of combo boxes.
BasicComboBoxUI.ComboBoxLayoutManager() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
BasicComboBoxUI.FocusHandler - Class in javax.swing.plaf.basic
This listener hides the popup when the focus is lost.
BasicComboBoxUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
BasicComboBoxUI.ItemHandler - Class in javax.swing.plaf.basic
This listener watches for changes to the selection in the combo box.
BasicComboBoxUI.ItemHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
BasicComboBoxUI.KeyHandler - Class in javax.swing.plaf.basic
This listener checks to see if the key event isn't a navigation key.
BasicComboBoxUI.KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
BasicComboBoxUI.ListDataHandler - Class in javax.swing.plaf.basic
This listener watches for changes in the ComboBoxModel.
BasicComboBoxUI.ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
BasicComboBoxUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This listener watches for bound properties that have changed in the combo box.
BasicComboBoxUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
BasicComboPopup - Class in javax.swing.plaf.basic
This is a basic implementation of the ComboPopup interface.
BasicComboPopup(JComboBox) - Constructor for class javax.swing.plaf.basic.BasicComboPopup
BasicComboPopup.InvocationKeyHandler - Class in javax.swing.plaf.basic
As of Java 2 platform v 1.4, this class is now obsolete and is only included for backwards API compatibility.
BasicComboPopup.InvocationKeyHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
BasicComboPopup.InvocationMouseHandler - Class in javax.swing.plaf.basic
A listener to be registered upon the combo box (not its popup menu) to handle mouse events that affect the state of the popup menu.
BasicComboPopup.InvocationMouseHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
BasicComboPopup.InvocationMouseMotionHandler - Class in javax.swing.plaf.basic
This listener watches for dragging and updates the current selection in the list if it is dragging over the list.
BasicComboPopup.InvocationMouseMotionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
BasicComboPopup.ItemHandler - Class in javax.swing.plaf.basic
This listener watches for changes to the selection in the combo box.
BasicComboPopup.ItemHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ItemHandler
BasicComboPopup.ListDataHandler - Class in javax.swing.plaf.basic
As of 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
BasicComboPopup.ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
BasicComboPopup.ListMouseHandler - Class in javax.swing.plaf.basic
This listener hides the popup when the mouse is released in the list.
BasicComboPopup.ListMouseHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
BasicComboPopup.ListMouseMotionHandler - Class in javax.swing.plaf.basic
This listener changes the selected item as you move the mouse over the list.
BasicComboPopup.ListMouseMotionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
BasicComboPopup.ListSelectionHandler - Class in javax.swing.plaf.basic
As of Java 2 platform v 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
BasicComboPopup.ListSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
BasicComboPopup.PropertyChangeHandler - Class in javax.swing.plaf.basic
This listener watches for bound properties that have changed in the combo box.
BasicComboPopup.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
BasicControl - Class in javax.naming.ldap
This class provides a basic implementation of the Control interface.
BasicControl(String) - Constructor for class javax.naming.ldap.BasicControl
Constructs a non-critical control.
BasicControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap.BasicControl
Constructs a control using the supplied arguments.
BasicDesktopIconUI - Class in javax.swing.plaf.basic
Basic L&F for a minimized window on a desktop.
BasicDesktopIconUI() - Constructor for class javax.swing.plaf.basic.BasicDesktopIconUI
BasicDesktopIconUI.MouseInputHandler - Class in javax.swing.plaf.basic
Listens for mouse movements and acts on them.
BasicDesktopIconUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
BasicDesktopPaneUI - Class in javax.swing.plaf.basic
Basic L&F for a desktop.
BasicDesktopPaneUI() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI
BasicDesktopPaneUI.CloseAction - Class in javax.swing.plaf.basic
Handles closing an internal frame.
BasicDesktopPaneUI.CloseAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
BasicDesktopPaneUI.MaximizeAction - Class in javax.swing.plaf.basic
Handles maximizing an internal frame.
BasicDesktopPaneUI.MaximizeAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
BasicDesktopPaneUI.MinimizeAction - Class in javax.swing.plaf.basic
Handles minimizing an internal frame.
BasicDesktopPaneUI.MinimizeAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
BasicDesktopPaneUI.NavigateAction - Class in javax.swing.plaf.basic
Handles navigating to the next internal frame.
BasicDesktopPaneUI.NavigateAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
BasicDesktopPaneUI.OpenAction - Class in javax.swing.plaf.basic
Handles restoring a minimized or maximized internal frame.
BasicDesktopPaneUI.OpenAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
BasicDirectoryModel - Class in javax.swing.plaf.basic
Basic implementation of a file list.
BasicDirectoryModel(JFileChooser) - Constructor for class javax.swing.plaf.basic.BasicDirectoryModel
BasicEditorPaneUI - Class in javax.swing.plaf.basic
Provides the look and feel for a JEditorPane.
BasicEditorPaneUI() - Constructor for class javax.swing.plaf.basic.BasicEditorPaneUI
Creates a new BasicEditorPaneUI.
BasicFileAttributes - Interface in java.nio.file.attribute
Basic attributes associated with a file in a file system.
BasicFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of a basic set of file attributes common to many file systems.
BasicFileChooserUI - Class in javax.swing.plaf.basic
Basic L&F implementation of a FileChooser.
BasicFileChooserUI(JFileChooser) - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI
BasicFileChooserUI.AcceptAllFileFilter - Class in javax.swing.plaf.basic
BasicFileChooserUI.AcceptAllFileFilter() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
BasicFileChooserUI.ApproveSelectionAction - Class in javax.swing.plaf.basic
Responds to an Open or Save request
BasicFileChooserUI.ApproveSelectionAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
BasicFileChooserUI.BasicFileView - Class in javax.swing.plaf.basic
BasicFileChooserUI.BasicFileView() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
BasicFileChooserUI.CancelSelectionAction - Class in javax.swing.plaf.basic
Responds to a cancel request.
BasicFileChooserUI.CancelSelectionAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
BasicFileChooserUI.ChangeToParentDirectoryAction - Class in javax.swing.plaf.basic
BasicFileChooserUI.ChangeToParentDirectoryAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
BasicFileChooserUI.DoubleClickListener - Class in javax.swing.plaf.basic
BasicFileChooserUI.DoubleClickListener(JList) - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
BasicFileChooserUI.GoHomeAction - Class in javax.swing.plaf.basic
Acts on the "home" key event or equivalent event.
BasicFileChooserUI.GoHomeAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
BasicFileChooserUI.NewFolderAction - Class in javax.swing.plaf.basic
Creates a new folder.
BasicFileChooserUI.NewFolderAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
BasicFileChooserUI.SelectionListener - Class in javax.swing.plaf.basic
BasicFileChooserUI.SelectionListener() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
BasicFileChooserUI.UpdateAction - Class in javax.swing.plaf.basic
Rescans the files in the current directory
BasicFileChooserUI.UpdateAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
BasicFormattedTextFieldUI - Class in javax.swing.plaf.basic
Provides the look and feel implementation for JFormattedTextField.
BasicFormattedTextFieldUI() - Constructor for class javax.swing.plaf.basic.BasicFormattedTextFieldUI
BasicGraphicsUtils - Class in javax.swing.plaf.basic
BasicGraphicsUtils() - Constructor for class javax.swing.plaf.basic.BasicGraphicsUtils
BasicHTML - Class in javax.swing.plaf.basic
Support for providing html views for the swing components.
BasicHTML() - Constructor for class javax.swing.plaf.basic.BasicHTML
BasicIconFactory - Class in javax.swing.plaf.basic
Factory object that can vend Icons appropriate for the basic L & F.
BasicIconFactory() - Constructor for class javax.swing.plaf.basic.BasicIconFactory
BasicInternalFrameTitlePane - Class in javax.swing.plaf.basic
The class that manages a basic title bar
BasicInternalFrameTitlePane(JInternalFrame) - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane
BasicInternalFrameTitlePane.CloseAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.CloseAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
BasicInternalFrameTitlePane.IconifyAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.IconifyAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
BasicInternalFrameTitlePane.MaximizeAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.MaximizeAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
BasicInternalFrameTitlePane.MoveAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.MoveAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
BasicInternalFrameTitlePane.PropertyChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
BasicInternalFrameTitlePane.RestoreAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.RestoreAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
BasicInternalFrameTitlePane.SizeAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.SizeAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
BasicInternalFrameTitlePane.SystemMenuBar - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.SystemMenuBar() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
BasicInternalFrameTitlePane.TitlePaneLayout - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.TitlePaneLayout() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
BasicInternalFrameUI - Class in javax.swing.plaf.basic
A basic L&F implementation of JInternalFrame.
BasicInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI
BasicInternalFrameUI.BasicInternalFrameListener - Class in javax.swing.plaf.basic
BasicInternalFrameUI.BasicInternalFrameListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
BasicInternalFrameUI.BorderListener - Class in javax.swing.plaf.basic
Listens for border adjustments.
BasicInternalFrameUI.BorderListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
BasicInternalFrameUI.ComponentHandler - Class in javax.swing.plaf.basic
BasicInternalFrameUI.ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
BasicInternalFrameUI.GlassPaneDispatcher - Class in javax.swing.plaf.basic
BasicInternalFrameUI.GlassPaneDispatcher() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
BasicInternalFrameUI.InternalFrameLayout - Class in javax.swing.plaf.basic
BasicInternalFrameUI.InternalFrameLayout() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
BasicInternalFrameUI.InternalFramePropertyChangeListener - Class in javax.swing.plaf.basic
BasicInternalFrameUI.InternalFramePropertyChangeListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
BasicLabelUI - Class in javax.swing.plaf.basic
A Windows L&F implementation of LabelUI.
BasicLabelUI() - Constructor for class javax.swing.plaf.basic.BasicLabelUI
BasicListUI - Class in javax.swing.plaf.basic
An extensible implementation of ListUI.
BasicListUI() - Constructor for class javax.swing.plaf.basic.BasicListUI
BasicListUI.FocusHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicListUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.FocusHandler
BasicListUI.ListDataHandler - Class in javax.swing.plaf.basic
The ListDataListener that's added to the JLists model at installUI time, and whenever the JList.model property changes.
BasicListUI.ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.ListDataHandler
BasicListUI.ListSelectionHandler - Class in javax.swing.plaf.basic
The ListSelectionListener that's added to the JLists selection model at installUI time, and whenever the JList.selectionModel property changes.
BasicListUI.ListSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
BasicListUI.MouseInputHandler - Class in javax.swing.plaf.basic
Mouse input, and focus handling for JList.
BasicListUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
BasicListUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
The PropertyChangeListener that's added to the JList at installUI time.
BasicListUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
BasicLookAndFeel - Class in javax.swing.plaf.basic
A base class to use in creating a look and feel for Swing.
BasicLookAndFeel() - Constructor for class javax.swing.plaf.basic.BasicLookAndFeel
BasicMenuBarUI - Class in javax.swing.plaf.basic
A default L&F implementation of MenuBarUI.
BasicMenuBarUI() - Constructor for class javax.swing.plaf.basic.BasicMenuBarUI
BasicMenuItemUI - Class in javax.swing.plaf.basic
BasicMenuItem implementation
BasicMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicMenuItemUI
BasicMenuItemUI.MouseInputHandler - Class in javax.swing.plaf.basic
BasicMenuItemUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
BasicMenuUI - Class in javax.swing.plaf.basic
A default L&F implementation of MenuUI.
BasicMenuUI() - Constructor for class javax.swing.plaf.basic.BasicMenuUI
BasicMenuUI.ChangeHandler - Class in javax.swing.plaf.basic
As of Java 2 platform 1.4, this previously undocumented class is now obsolete.
BasicMenuUI.ChangeHandler(JMenu, BasicMenuUI) - Constructor for class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
BasicMenuUI.MouseInputHandler - Class in javax.swing.plaf.basic
Instantiated and used by a menu item to handle the current menu selection from mouse events.
BasicMenuUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
BasicOptionPaneUI - Class in javax.swing.plaf.basic
Provides the basic look and feel for a JOptionPane.
BasicOptionPaneUI() - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI
BasicOptionPaneUI.ButtonActionListener - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicOptionPaneUI.ButtonActionListener(int) - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
BasicOptionPaneUI.ButtonAreaLayout - Class in javax.swing.plaf.basic
ButtonAreaLayout behaves in a similar manner to FlowLayout.
BasicOptionPaneUI.ButtonAreaLayout(boolean, int) - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
BasicOptionPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicOptionPaneUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
BasicPanelUI - Class in javax.swing.plaf.basic
BasicPanel implementation
BasicPanelUI() - Constructor for class javax.swing.plaf.basic.BasicPanelUI
BasicPasswordFieldUI - Class in javax.swing.plaf.basic
Provides the Windows look and feel for a password field.
BasicPasswordFieldUI() - Constructor for class javax.swing.plaf.basic.BasicPasswordFieldUI
BasicPermission - Class in java.security
The BasicPermission class extends the Permission class, and can be used as the base class for permissions that want to follow the same naming convention as BasicPermission.
BasicPermission(String) - Constructor for class java.security.BasicPermission
Creates a new BasicPermission with the specified name.
BasicPermission(String, String) - Constructor for class java.security.BasicPermission
Creates a new BasicPermission object with the specified name.
BasicPopupMenuSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of PopupMenuSeparatorUI.
BasicPopupMenuSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
BasicPopupMenuUI - Class in javax.swing.plaf.basic
A Windows L&F implementation of PopupMenuUI.
BasicPopupMenuUI() - Constructor for class javax.swing.plaf.basic.BasicPopupMenuUI
BasicProgressBarUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ProgressBarUI.
BasicProgressBarUI() - Constructor for class javax.swing.plaf.basic.BasicProgressBarUI
BasicProgressBarUI.ChangeHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicProgressBarUI.ChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
BasicRadioButtonMenuItemUI - Class in javax.swing.plaf.basic
BasicRadioButtonMenuItem implementation
BasicRadioButtonMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
BasicRadioButtonUI - Class in javax.swing.plaf.basic
RadioButtonUI implementation for BasicRadioButtonUI
BasicRadioButtonUI() - Constructor for class javax.swing.plaf.basic.BasicRadioButtonUI
BasicRootPaneUI - Class in javax.swing.plaf.basic
Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
BasicRootPaneUI() - Constructor for class javax.swing.plaf.basic.BasicRootPaneUI
BasicScrollBarUI - Class in javax.swing.plaf.basic
Implementation of ScrollBarUI for the Basic Look and Feel
BasicScrollBarUI() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI
BasicScrollBarUI.ArrowButtonListener - Class in javax.swing.plaf.basic
Listener for cursor keys.
BasicScrollBarUI.ArrowButtonListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
BasicScrollBarUI.ModelListener - Class in javax.swing.plaf.basic
A listener to listen for model changes.
BasicScrollBarUI.ModelListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
BasicScrollBarUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicScrollBarUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
BasicScrollBarUI.ScrollListener - Class in javax.swing.plaf.basic
Listener for scrolling events initiated in the ScrollPane.
BasicScrollBarUI.ScrollListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
BasicScrollBarUI.ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
BasicScrollBarUI.TrackListener - Class in javax.swing.plaf.basic
Track mouse drags.
BasicScrollBarUI.TrackListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
BasicScrollPaneUI - Class in javax.swing.plaf.basic
A default L&F implementation of ScrollPaneUI.
BasicScrollPaneUI() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI
BasicScrollPaneUI.HSBChangeListener - Class in javax.swing.plaf.basic
Horizontal scrollbar listener.
BasicScrollPaneUI.HSBChangeListener() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
BasicScrollPaneUI.MouseWheelHandler - Class in javax.swing.plaf.basic
MouseWheelHandler is an inner class which implements the MouseWheelListener interface.
BasicScrollPaneUI.MouseWheelHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
BasicScrollPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicScrollPaneUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
BasicScrollPaneUI.ViewportChangeHandler - Class in javax.swing.plaf.basic
Listener for viewport events.
BasicScrollPaneUI.ViewportChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
BasicScrollPaneUI.VSBChangeListener - Class in javax.swing.plaf.basic
Vertical scrollbar listener.
BasicScrollPaneUI.VSBChangeListener() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
BasicSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of SeparatorUI.
BasicSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicSeparatorUI
BasicSliderUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of SliderUI.
BasicSliderUI(JSlider) - Constructor for class javax.swing.plaf.basic.BasicSliderUI
BasicSliderUI.ActionScroller - Class in javax.swing.plaf.basic
As of Java 2 platform v1.3 this undocumented class is no longer used.
BasicSliderUI.ActionScroller(JSlider, int, boolean) - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
BasicSliderUI.ChangeHandler - Class in javax.swing.plaf.basic
Data model listener.
BasicSliderUI.ChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
BasicSliderUI.ComponentHandler - Class in javax.swing.plaf.basic
Listener for resizing events.
BasicSliderUI.ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
BasicSliderUI.FocusHandler - Class in javax.swing.plaf.basic
Focus-change listener.
BasicSliderUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
BasicSliderUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicSliderUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
BasicSliderUI.ScrollListener - Class in javax.swing.plaf.basic
Scroll-event listener.
BasicSliderUI.ScrollListener() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ScrollListener
BasicSliderUI.ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ScrollListener
BasicSliderUI.TrackListener - Class in javax.swing.plaf.basic
Track mouse movements.
BasicSliderUI.TrackListener() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.TrackListener
BasicSpinnerUI - Class in javax.swing.plaf.basic
The default Spinner UI delegate.
BasicSpinnerUI() - Constructor for class javax.swing.plaf.basic.BasicSpinnerUI
BasicSplitPaneDivider - Class in javax.swing.plaf.basic
Divider used by BasicSplitPaneUI.
BasicSplitPaneDivider(BasicSplitPaneUI) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates an instance of BasicSplitPaneDivider.
BasicSplitPaneDivider.DividerLayout - Class in javax.swing.plaf.basic
Used to layout a BasicSplitPaneDivider.
BasicSplitPaneDivider.DividerLayout() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
BasicSplitPaneDivider.DragController - Class in javax.swing.plaf.basic
Handles the events during a dragging session for a HORIZONTAL_SPLIT oriented split pane.
BasicSplitPaneDivider.DragController(MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
BasicSplitPaneDivider.MouseHandler - Class in javax.swing.plaf.basic
MouseHandler is responsible for converting mouse events (released, dragged...) into the appropriate DragController methods.
BasicSplitPaneDivider.MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
BasicSplitPaneDivider.VerticalDragController - Class in javax.swing.plaf.basic
Handles the events during a dragging session for a VERTICAL_SPLIT oriented split pane.
BasicSplitPaneDivider.VerticalDragController(MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
BasicSplitPaneUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of the SplitPaneUI.
BasicSplitPaneUI() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI
BasicSplitPaneUI.BasicHorizontalLayoutManager - Class in javax.swing.plaf.basic
LayoutManager for JSplitPanes that have an orientation of HORIZONTAL_SPLIT.
BasicSplitPaneUI.BasicVerticalLayoutManager - Class in javax.swing.plaf.basic
LayoutManager used for JSplitPanes with an orientation of VERTICAL_SPLIT.
BasicSplitPaneUI.BasicVerticalLayoutManager() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
BasicSplitPaneUI.FocusHandler - Class in javax.swing.plaf.basic
Implementation of the FocusListener that the JSplitPane UI uses.
BasicSplitPaneUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
BasicSplitPaneUI.KeyboardDownRightHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardDownRightHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
BasicSplitPaneUI.KeyboardEndHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardEndHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
BasicSplitPaneUI.KeyboardHomeHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardHomeHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
BasicSplitPaneUI.KeyboardResizeToggleHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardResizeToggleHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
BasicSplitPaneUI.KeyboardUpLeftHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardUpLeftHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
BasicSplitPaneUI.PropertyHandler - Class in javax.swing.plaf.basic
Implementation of the PropertyChangeListener that the JSplitPane UI uses.
BasicSplitPaneUI.PropertyHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
BasicStroke - Class in java.awt
The BasicStroke class defines a basic set of rendering attributes for the outlines of graphics primitives, which are rendered with a Graphics2D object that has its Stroke attribute set to this BasicStroke.
BasicStroke(float, int, int, float, float[], float) - Constructor for class java.awt.BasicStroke
Constructs a new BasicStroke with the specified attributes.
BasicStroke(float, int, int, float) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified attributes.
BasicStroke(float, int, int) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified attributes.
BasicStroke(float) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified line width and with default values for the cap and join styles.
BasicStroke() - Constructor for class java.awt.BasicStroke
Constructs a new BasicStroke with defaults for all attributes.
BasicTabbedPaneUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of TabbedPaneUI.
BasicTabbedPaneUI() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI
BasicTabbedPaneUI.FocusHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
BasicTabbedPaneUI.MouseHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
BasicTabbedPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
BasicTabbedPaneUI.TabbedPaneLayout - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.TabbedPaneLayout() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
BasicTabbedPaneUI.TabSelectionHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.TabSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
BasicTableHeaderUI - Class in javax.swing.plaf.basic
BasicTableHeaderUI implementation
BasicTableHeaderUI() - Constructor for class javax.swing.plaf.basic.BasicTableHeaderUI
BasicTableHeaderUI.MouseInputHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicTableHeaderUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
BasicTableUI - Class in javax.swing.plaf.basic
BasicTableUI implementation
BasicTableUI() - Constructor for class javax.swing.plaf.basic.BasicTableUI
BasicTableUI.FocusHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicTableUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.FocusHandler
BasicTableUI.KeyHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicTableUI.KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.KeyHandler
BasicTableUI.MouseInputHandler - Class in javax.swing.plaf.basic
This inner class is marked "public" due to a compiler bug.
BasicTableUI.MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
BasicTextAreaUI - Class in javax.swing.plaf.basic
Provides the look and feel for a plain text editor.
BasicTextAreaUI() - Constructor for class javax.swing.plaf.basic.BasicTextAreaUI
Constructs a new BasicTextAreaUI object.
BasicTextFieldUI - Class in javax.swing.plaf.basic
Basis of a look and feel for a JTextField.
BasicTextFieldUI() - Constructor for class javax.swing.plaf.basic.BasicTextFieldUI
Creates a new BasicTextFieldUI.
BasicTextPaneUI - Class in javax.swing.plaf.basic
Provides the look and feel for a styled text editor.
BasicTextPaneUI() - Constructor for class javax.swing.plaf.basic.BasicTextPaneUI
Creates a new BasicTextPaneUI.
BasicTextUI - Class in javax.swing.plaf.basic
Basis of a text components look-and-feel.
BasicTextUI() - Constructor for class javax.swing.plaf.basic.BasicTextUI
Creates a new UI.
BasicTextUI.BasicCaret - Class in javax.swing.plaf.basic
BasicTextUI.BasicCaret() - Constructor for class javax.swing.plaf.basic.BasicTextUI.BasicCaret
BasicTextUI.BasicHighlighter - Class in javax.swing.plaf.basic
BasicTextUI.BasicHighlighter() - Constructor for class javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
BasicToggleButtonUI - Class in javax.swing.plaf.basic
BasicToggleButton implementation
BasicToggleButtonUI() - Constructor for class javax.swing.plaf.basic.BasicToggleButtonUI
BasicToolBarSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ToolBarSeparatorUI.
BasicToolBarSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicToolBarSeparatorUI
BasicToolBarUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ToolBarUI.
BasicToolBarUI() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI
BasicToolBarUI.DockingListener - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicToolBarUI.DockingListener(JToolBar) - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
BasicToolBarUI.DragWindow - Class in javax.swing.plaf.basic
BasicToolBarUI.FrameListener - Class in javax.swing.plaf.basic
BasicToolBarUI.FrameListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.FrameListener
BasicToolBarUI.PropertyListener - Class in javax.swing.plaf.basic
BasicToolBarUI.PropertyListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
BasicToolBarUI.ToolBarContListener - Class in javax.swing.plaf.basic
BasicToolBarUI.ToolBarContListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
BasicToolBarUI.ToolBarFocusListener - Class in javax.swing.plaf.basic
BasicToolBarUI.ToolBarFocusListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
BasicToolTipUI - Class in javax.swing.plaf.basic
Standard tool tip L&F.
BasicToolTipUI() - Constructor for class javax.swing.plaf.basic.BasicToolTipUI
BasicTreeUI - Class in javax.swing.plaf.basic
The basic L&F for a hierarchical data structure.
BasicTreeUI() - Constructor for class javax.swing.plaf.basic.BasicTreeUI
BasicTreeUI.CellEditorHandler - Class in javax.swing.plaf.basic
Listener responsible for getting cell editing events and updating the tree accordingly.
BasicTreeUI.CellEditorHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
BasicTreeUI.ComponentHandler - Class in javax.swing.plaf.basic
Updates the preferred size when scrolling (if necessary).
BasicTreeUI.ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
BasicTreeUI.FocusHandler - Class in javax.swing.plaf.basic
Repaints the lead selection row when focus is lost/gained.
BasicTreeUI.FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
BasicTreeUI.KeyHandler - Class in javax.swing.plaf.basic
This is used to get mutliple key down events to appropriately generate events.
BasicTreeUI.KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
BasicTreeUI.MouseHandler - Class in javax.swing.plaf.basic
TreeMouseListener is responsible for updating the selection based on mouse events.
BasicTreeUI.MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
BasicTreeUI.MouseInputHandler - Class in javax.swing.plaf.basic
MouseInputHandler handles passing all mouse events, including mouse motion events, until the mouse is released to the destination it is constructed with.
BasicTreeUI.MouseInputHandler(Component, Component, MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
BasicTreeUI.NodeDimensionsHandler - Class in javax.swing.plaf.basic
Class responsible for getting size of node, method is forwarded to BasicTreeUI method.
BasicTreeUI.NodeDimensionsHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
BasicTreeUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
PropertyChangeListener for the tree.
BasicTreeUI.PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
BasicTreeUI.SelectionModelPropertyChangeHandler - Class in javax.swing.plaf.basic
Listener on the TreeSelectionModel, resets the row selection if any of the properties of the model change.
BasicTreeUI.SelectionModelPropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
BasicTreeUI.TreeCancelEditingAction - Class in javax.swing.plaf.basic
ActionListener that invokes cancelEditing when action performed.
BasicTreeUI.TreeCancelEditingAction(String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
BasicTreeUI.TreeExpansionHandler - Class in javax.swing.plaf.basic
Updates the TreeState in response to nodes expanding/collapsing.
BasicTreeUI.TreeExpansionHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
BasicTreeUI.TreeHomeAction - Class in javax.swing.plaf.basic
TreeHomeAction is used to handle end/home actions.
BasicTreeUI.TreeHomeAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
BasicTreeUI.TreeIncrementAction - Class in javax.swing.plaf.basic
TreeIncrementAction is used to handle up/down actions.
BasicTreeUI.TreeIncrementAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
BasicTreeUI.TreeModelHandler - Class in javax.swing.plaf.basic
Forwards all TreeModel events to the TreeState.
BasicTreeUI.TreeModelHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
BasicTreeUI.TreePageAction - Class in javax.swing.plaf.basic
TreePageAction handles page up and page down events.
BasicTreeUI.TreePageAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
BasicTreeUI.TreeSelectionHandler - Class in javax.swing.plaf.basic
Listens for changes in the selection model and updates the display accordingly.
BasicTreeUI.TreeSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
BasicTreeUI.TreeToggleAction - Class in javax.swing.plaf.basic
For the first selected row expandedness will be toggled.
BasicTreeUI.TreeToggleAction(String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
BasicTreeUI.TreeTraverseAction - Class in javax.swing.plaf.basic
TreeTraverseAction is the action used for left/right keys.
BasicTreeUI.TreeTraverseAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
BasicViewportUI - Class in javax.swing.plaf.basic
BasicViewport implementation
BasicViewportUI() - Constructor for class javax.swing.plaf.basic.BasicViewportUI
BATAK - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Batak" Unicode character block.
BATCHSIZE - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the batch size to use when returning data via the service's protocol.
BatchUpdateException - Exception in java.sql
The subclass of SQLException thrown when an error occurs during a batch update operation.
BatchUpdateException(String, String, int, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState, vendorCode and updateCounts.
BatchUpdateException(String, String, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState and updateCounts.
BatchUpdateException(String, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason and updateCounts.
BatchUpdateException(int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given updateCounts.
BatchUpdateException() - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object.
BatchUpdateException(Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given cause.
BatchUpdateException(int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given cause and updateCounts.
BatchUpdateException(String, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, cause and updateCounts.
BatchUpdateException(String, String, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState,cause, and updateCounts.
BatchUpdateException(String, String, int, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState, vendorCode cause and updateCounts.
BC - Static variable in class java.util.GregorianCalendar
Value of the ERA field indicating the period before the common era (before Christ), also known as BCE.
bcmListeners - Variable in class java.beans.beancontext.BeanContextSupport
all accesses to the protected ArrayList bcmListeners field shall be synchronized on that object.
bcsChildren() - Method in class java.beans.beancontext.BeanContextSupport
Returns an iterator of all children of this BeanContext.
bcsListeners - Variable in class java.beans.beancontext.BeanContextServicesSupport
List of BeanContextServicesListener objects.
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from BeanContextSupport readObject before it deserializes the children ...
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext.BeanContextSupport
called by readObject after defaultReadObject() but prior to deserialization of any children.
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from BeanContextSupport writeObject before it serializes the children ...
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext.BeanContextSupport
called by writeObject after defaultWriteObject() but prior to serialization of currently serializable children.
BeanContext - Interface in java.beans.beancontext
The BeanContext acts a logical hierarchical container for JavaBeans.
beanContext - Variable in class java.beans.beancontext.BeanContextChildSupport
BeanContextChild - Interface in java.beans.beancontext
JavaBeans wishing to be nested within, and obtain a reference to their execution environment, or context, as defined by the BeanContext sub-interface shall implement this interface.
BeanContextChildComponentProxy - Interface in java.beans.beancontext
This interface is implemented by BeanContextChildren that have an AWT Component associated with them.
beanContextChildPeer - Variable in class java.beans.beancontext.BeanContextChildSupport
The BeanContext in which this BeanContextChild is nested.
BeanContextChildSupport - Class in java.beans.beancontext
This is a general support class to provide support for implementing the BeanContextChild protocol.
BeanContextChildSupport() - Constructor for class java.beans.beancontext.BeanContextChildSupport
construct a BeanContextChildSupport where this class has been subclassed in order to implement the JavaBean component itself.
BeanContextChildSupport(BeanContextChild) - Constructor for class java.beans.beancontext.BeanContextChildSupport
construct a BeanContextChildSupport where the JavaBean component itself implements BeanContextChild, and encapsulates this, delegating that interface to this implementation
BeanContextContainerProxy - Interface in java.beans.beancontext
This interface is implemented by BeanContexts' that have an AWT Container associated with them.
BeanContextEvent - Class in java.beans.beancontext
BeanContextEvent is the abstract root event class for all events emitted from, and pertaining to the semantics of, a BeanContext.
BeanContextEvent(BeanContext) - Constructor for class java.beans.beancontext.BeanContextEvent
Contruct a BeanContextEvent
BeanContextMembershipEvent - Class in java.beans.beancontext
A BeanContextMembershipEvent encapsulates the list of children added to, or removed from, the membership of a particular BeanContext.
BeanContextMembershipEvent(BeanContext, Collection) - Constructor for class java.beans.beancontext.BeanContextMembershipEvent
Contruct a BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext, Object[]) - Constructor for class java.beans.beancontext.BeanContextMembershipEvent
Contruct a BeanContextMembershipEvent
BeanContextMembershipListener - Interface in java.beans.beancontext
Compliant BeanContexts fire events on this interface when the state of the membership of the BeanContext changes.
BeanContextProxy - Interface in java.beans.beancontext
This interface is implemented by a JavaBean that does not directly have a BeanContext(Child) associated with it (via implementing that interface or a subinterface thereof), but has a public BeanContext(Child) delegated from it.
BeanContextServiceAvailableEvent - Class in java.beans.beancontext
This event type is used by the BeanContextServicesListener in order to identify the service being registered.
BeanContextServiceAvailableEvent(BeanContextServices, Class) - Constructor for class java.beans.beancontext.BeanContextServiceAvailableEvent
Construct a BeanContextAvailableServiceEvent.
BeanContextServiceProvider - Interface in java.beans.beancontext
One of the primary functions of a BeanContext is to act a as rendezvous between JavaBeans, and BeanContextServiceProviders.
BeanContextServiceProviderBeanInfo - Interface in java.beans.beancontext
A BeanContextServiceProvider implementor who wishes to provide explicit information about the services their bean may provide shall implement a BeanInfo class that implements this BeanInfo subinterface and provides explicit information about the methods, properties, events, etc, of their services.
BeanContextServiceRevokedEvent - Class in java.beans.beancontext
This event type is used by the BeanContextServiceRevokedListener in order to identify the service being revoked.
BeanContextServiceRevokedEvent(BeanContextServices, Class, boolean) - Constructor for class java.beans.beancontext.BeanContextServiceRevokedEvent
Construct a BeanContextServiceEvent.
BeanContextServiceRevokedListener - Interface in java.beans.beancontext
The listener interface for receiving BeanContextServiceRevokedEvent objects.
BeanContextServices - Interface in java.beans.beancontext
The BeanContextServices interface provides a mechanism for a BeanContext to expose generic "services" to the BeanContextChild objects within.
BeanContextServicesListener - Interface in java.beans.beancontext
The listener interface for receiving BeanContextServiceAvailableEvent objects.
BeanContextServicesSupport - Class in java.beans.beancontext
This helper class provides a utility implementation of the java.beans.beancontext.BeanContextServices interface.
BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Construct a BeanContextServicesSupport instance
BeanContextServicesSupport(BeanContextServices, Locale, boolean) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance using the specified Locale and design mode.
BeanContextServicesSupport(BeanContextServices, Locale) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance using the specified locale
BeanContextServicesSupport(BeanContextServices) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance with a peer
BeanContextServicesSupport() - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance that is not a delegate of another object
BeanContextServicesSupport.BCSSChild - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSProxyServiceProvider - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSServiceProvider - Class in java.beans.beancontext
subclasses may subclass this nested class to add behaviors for each BeanContextServicesProvider.
BeanContextSupport - Class in java.beans.beancontext
This helper class provides a utility implementation of the java.beans.beancontext.BeanContext interface.
BeanContextSupport(BeanContext, Locale, boolean, boolean) - Constructor for class java.beans.beancontext.BeanContextSupport
Construct a BeanContextSupport instance
BeanContextSupport(BeanContext, Locale, boolean) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using the specified Locale and design mode.
BeanContextSupport(BeanContext, Locale) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using the specified locale
BeanContextSupport(BeanContext) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using with a default locale
BeanContextSupport() - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance that is not a delegate of another object
BeanContextSupport.BCSChild - Class in java.beans.beancontext
BeanContextSupport.BCSIterator - Class in java.beans.beancontext
protected final subclass that encapsulates an iterator but implements a noop remove() method.
BeanDescriptor - Class in java.beans
A BeanDescriptor provides global information about a "bean", including its Java class, its displayName, etc.
BeanDescriptor(Class<?>) - Constructor for class java.beans.BeanDescriptor
Create a BeanDescriptor for a bean that doesn't have a customizer.
BeanDescriptor(Class<?>, Class<?>) - Constructor for class java.beans.BeanDescriptor
Create a BeanDescriptor for a bean that has a customizer.
BeanInfo - Interface in java.beans
A bean implementor who wishes to provide explicit information about their bean may provide a BeanInfo class that implements this BeanInfo interface and provides explicit information about the methods, properties, events, etc, of their bean.
Beans - Class in java.beans
This class provides some general purpose beans control methods.
Beans() - Constructor for class java.beans.Beans
beep() - Method in class java.awt.Toolkit
Emits an audio beep.
beepAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to create a beep.
before(Timestamp) - Method in class java.sql.Timestamp
Indicates whether this Timestamp object is earlier than the given Timestamp object.
before(Object) - Method in class java.util.Calendar
Returns whether this Calendar represents a time before the time represented by the specified Object.
before(Date) - Method in class java.util.Date
Tests if this date is before the specified date.
BEFORE_FIRST_LINE - Static variable in class java.awt.BorderLayout
Synonym for PAGE_START.
BEFORE_LINE_BEGINS - Static variable in class java.awt.BorderLayout
Synonym for LINE_START.
beforeExecute(Thread, Runnable) - Method in class java.util.concurrent.ThreadPoolExecutor
Method invoked prior to executing the given Runnable in the given thread.
beforeFirst() - Method in interface java.sql.ResultSet
Moves the cursor to the front of this ResultSet object, just before the first row.
beforeMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked before marshalling from source to XML.

beforeOffset(int) - Static method in class java.awt.font.TextHitInfo
Creates a TextHitInfo at the specified offset, associated with the character before the offset.
beforeUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked before unmarshalling into target.

begin() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Marks the beginning of an I/O operation that might block indefinitely.
begin() - Method in class java.nio.channels.spi.AbstractSelector
Marks the beginning of an I/O operation that might block indefinitely.
beginAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of the document.
beginDragDividerLocation - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Location of the divider when the dragging session began.
beginDraggingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
beginDraggingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method is normally called when the user has indicated that they will begin dragging a component around.
beginHandshake() - Method in class javax.net.ssl.SSLEngine
Initiates handshaking (initial or renegotiation) on this SSLEngine.
beginLineAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a line.
beginParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a paragraph.
beginResizingFrame(JComponent, int) - Method in class javax.swing.DefaultDesktopManager
beginResizingFrame(JComponent, int) - Method in interface javax.swing.DesktopManager
This methods is normally called when the user has indicated that they will begin resizing the frame.
beginUpdate() - Method in class javax.swing.undo.UndoableEditSupport
beginWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a word.
BELOW_BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title below the border's bottom line.
BELOW_TOP - Static variable in class javax.swing.border.TitledBorder
Position the title below the border's top line.
BENGALI - Static variable in class java.awt.font.NumericShaper
Identifies the BENGALI range and decimal base.
BENGALI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bengali" Unicode character block.
BEST_COMPRESSION - Static variable in class java.util.zip.Deflater
Compression level for best compression.
BEST_SPEED - Static variable in class java.util.zip.Deflater
Compression level for fastest compression.
bestRowNotPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier is NOT a pseudo column.
bestRowPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier is a pseudo column.
bestRowSession - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is the remainder of the current session.
bestRowTemporary - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is very temporary, lasting only while the row is being used.
bestRowTransaction - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is the remainder of the current transaction.
bestRowUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier may or may not be a pseudo column.
between(ValueExp, ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents the constraint that one value is between two other values.
BevelBorder - Class in javax.swing.border
A class which implements a simple two-line bevel border.
BevelBorder(int) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
BevelBorder(int, Color, Color) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type, highlight and shadow colors.
BevelBorder(int, Color, Color, Color, Color) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type, highlight and shadow colors.
bevelType - Variable in class javax.swing.border.BevelBorder
BGCOLOR - Static variable in class javax.swing.text.html.HTML.Attribute
Bidi - Class in java.text
This class implements the Unicode Bidirectional Algorithm.
Bidi(String, int) - Constructor for class java.text.Bidi
Create Bidi from the given paragraph of text and base direction.
Bidi(AttributedCharacterIterator) - Constructor for class java.text.Bidi
Create Bidi from the given paragraph of text.
Bidi(char[], int, byte[], int, int, int) - Constructor for class java.text.Bidi
Create Bidi from the given text, embedding, and direction information.
BIDI_EMBEDDING - Static variable in class java.awt.font.TextAttribute
Attribute key for the embedding level of the text.
BidiElementName - Static variable in class javax.swing.text.AbstractDocument
Name of elements used to hold a unidirectional run
BidiLevel - Static variable in class javax.swing.text.StyleConstants
Bidirectional level of a character as assigned by the Unicode bidi algorithm.
BIG - Static variable in class javax.swing.text.html.HTML.Tag
BIG_ENDIAN - Static variable in class java.nio.ByteOrder
Constant denoting big-endian byte order.
BigDecimal - Class in java.math
Immutable, arbitrary-precision signed decimal numbers.
BigDecimal(char[], int, int) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor, while allowing a sub-array to be specified.
BigDecimal(char[], int, int, MathContext) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor, while allowing a sub-array to be specified and with rounding according to the context settings.
BigDecimal(char[]) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor.
BigDecimal(char[], MathContext) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor and with rounding according to the context settings.
BigDecimal(String) - Constructor for class java.math.BigDecimal
Translates the string representation of a BigDecimal into a BigDecimal.
BigDecimal(String, MathContext) - Constructor for class java.math.BigDecimal
Translates the string representation of a BigDecimal into a BigDecimal, accepting the same strings as the BigDecimal.BigDecimal(String) constructor, with rounding according to the context settings.
BigDecimal(double) - Constructor for class java.math.BigDecimal
Translates a double into a BigDecimal which is the exact decimal representation of the double's binary floating-point value.
BigDecimal(double, MathContext) - Constructor for class java.math.BigDecimal
Translates a double into a BigDecimal, with rounding according to the context settings.
BigDecimal(BigInteger) - Constructor for class java.math.BigDecimal
Translates a BigInteger into a BigDecimal.
BigDecimal(BigInteger, MathContext) - Constructor for class java.math.BigDecimal
Translates a BigInteger into a BigDecimal rounding according to the context settings.
BigDecimal(BigInteger, int) - Constructor for class java.math.BigDecimal
Translates a BigInteger unscaled value and an int scale into a BigDecimal.
BigDecimal(BigInteger, int, MathContext) - Constructor for class java.math.BigDecimal
Translates a BigInteger unscaled value and an int scale into a BigDecimal, with rounding according to the context settings.
BigDecimal(int) - Constructor for class java.math.BigDecimal
Translates an int into a BigDecimal.
BigDecimal(int, MathContext) - Constructor for class java.math.BigDecimal
Translates an int into a BigDecimal, with rounding according to the context settings.
BigDecimal(long) - Constructor for class java.math.BigDecimal
Translates a long into a BigDecimal.
BigDecimal(long, MathContext) - Constructor for class java.math.BigDecimal
Translates a long into a BigDecimal, with rounding according to the context settings.
BIGDECIMAL - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
bigEndian - Variable in class javax.sound.sampled.AudioFormat
Indicates whether the audio data is stored in big-endian or little-endian order.
BIGINT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BIGINT.
BigInteger - Class in java.math
Immutable arbitrary-precision integers.
BigInteger(byte[]) - Constructor for class java.math.BigInteger
Translates a byte array containing the two's-complement binary representation of a BigInteger into a BigInteger.
BigInteger(int, byte[]) - Constructor for class java.math.BigInteger
Translates the sign-magnitude representation of a BigInteger into a BigInteger.
BigInteger(String, int) - Constructor for class java.math.BigInteger
Translates the String representation of a BigInteger in the specified radix into a BigInteger.
BigInteger(String) - Constructor for class java.math.BigInteger
Translates the decimal String representation of a BigInteger into a BigInteger.
BigInteger(int, Random) - Constructor for class java.math.BigInteger
Constructs a randomly generated BigInteger, uniformly distributed over the range 0 to (2numBits - 1), inclusive.
BigInteger(int, int, Random) - Constructor for class java.math.BigInteger
Constructs a randomly generated positive BigInteger that is probably prime, with the specified bitLength.
BIGINTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigInteger.
BINARY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BINARY.
BINARY_STREAM_PARAM - Static variable in class javax.sql.rowset.BaseRowSet
A constant indicating to a RowSetReaderImpl object that a given parameter is a binary stream.
BinaryRefAddr - Class in javax.naming
This class represents the binary form of the address of a communications end-point.
BinaryRefAddr(String, byte[]) - Constructor for class javax.naming.BinaryRefAddr
Constructs a new instance of BinaryRefAddr using its address type and a byte array for contents.
BinaryRefAddr(String, byte[], int, int) - Constructor for class javax.naming.BinaryRefAddr
Constructs a new instance of BinaryRefAddr using its address type and a region of a byte array for contents.
binarySearch(long[], long) - Static method in class java.util.Arrays
Searches the specified array of longs for the specified value using the binary search algorithm.
binarySearch(long[], int, int, long) - Static method in class java.util.Arrays
Searches a range of the specified array of longs for the specified value using the binary search algorithm.
binarySearch(int[], int) - Static method in class java.util.Arrays
Searches the specified array of ints for the specified value using the binary search algorithm.
binarySearch(int[], int, int, int) - Static method in class java.util.Arrays
Searches a range of the specified array of ints for the specified value using the binary search algorithm.
binarySearch(short[], short) - Static method in class java.util.Arrays
Searches the specified array of shorts for the specified value using the binary search algorithm.
binarySearch(short[], int, int, short) - Static method in class java.util.Arrays
Searches a range of the specified array of shorts for the specified value using the binary search algorithm.
binarySearch(char[], char) - Static method in class java.util.Arrays
Searches the specified array of chars for the specified value using the binary search algorithm.
binarySearch(char[], int, int, char) - Static method in class java.util.Arrays
Searches a range of the specified array of chars for the specified value using the binary search algorithm.
binarySearch(byte[], byte) - Static method in class java.util.Arrays
Searches the specified array of bytes for the specified value using the binary search algorithm.
binarySearch(byte[], int, int, byte) - Static method in class java.util.Arrays
Searches a range of the specified array of bytes for the specified value using the binary search algorithm.
binarySearch(double[], double) - Static method in class java.util.Arrays
Searches the specified array of doubles for the specified value using the binary search algorithm.
binarySearch(double[], int, int, double) - Static method in class java.util.Arrays
Searches a range of the specified array of doubles for the specified value using the binary search algorithm.
binarySearch(float[], float) - Static method in class java.util.Arrays
Searches the specified array of floats for the specified value using the binary search algorithm.
binarySearch(float[], int, int, float) - Static method in class java.util.Arrays
Searches a range of the specified array of floats for the specified value using the binary search algorithm.
binarySearch(Object[], Object) - Static method in class java.util.Arrays
Searches the specified array for the specified object using the binary search algorithm.
binarySearch(Object[], int, int, Object) - Static method in class java.util.Arrays
Searches a range of the specified array for the specified object using the binary search algorithm.
binarySearch(T[], T, Comparator<? super T>) - Static method in class java.util.Arrays
Searches the specified array for the specified object using the binary search algorithm.
binarySearch(T[], int, int, T, Comparator<? super T>) - Static method in class java.util.Arrays
Searches a range of the specified array for the specified object using the binary search algorithm.
binarySearch(List<? extends Comparable<? super T>>, T) - Static method in class java.util.Collections
Searches the specified list for the specified object using the binary search algorithm.
binarySearch(List<? extends T>, T, Comparator<? super T>) - Static method in class java.util.Collections
Searches the specified list for the specified object using the binary search algorithm.
binaryStream - Variable in class javax.sql.rowset.BaseRowSet
The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.
bind(Object, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces an early-bound method handle for a non-static method.
bind(SocketAddress) - Method in class java.net.DatagramSocket
Binds this DatagramSocket to a specific address & port.
bind(int, InetAddress) - Method in class java.net.DatagramSocketImpl
Binds a datagram socket to a local port and address.
bind(SocketAddress) - Method in class java.net.ServerSocket
Binds the ServerSocket to a specific address (IP address and port number).
bind(SocketAddress, int) - Method in class java.net.ServerSocket
Binds the ServerSocket to a specific address (IP address and port number).
bind(SocketAddress) - Method in class java.net.Socket
Binds the socket to a local address.
bind(InetAddress, int) - Method in class java.net.SocketImpl
Binds this socket to the specified local IP address and port number.
bind(SocketAddress) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress, int) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress) - Method in class java.nio.channels.AsynchronousSocketChannel
bind(SocketAddress) - Method in class java.nio.channels.DatagramChannel
bind(SocketAddress) - Method in interface java.nio.channels.NetworkChannel
Binds the channel's socket to a local address.
bind(SocketAddress) - Method in class java.nio.channels.ServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress, int) - Method in class java.nio.channels.ServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress) - Method in class java.nio.channels.SocketChannel
bind(String, Remote) - Static method in class java.rmi.Naming
Binds the specified name to a remote object.
bind(String, Remote) - Method in interface java.rmi.registry.Registry
Binds a remote reference to the specified name in this registry.
bind(Name, Object) - Method in interface javax.naming.Context
Binds a name to an object.
bind(String, Object) - Method in interface javax.naming.Context
Binds a name to an object.
bind(Name, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes.
bind(String, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes.
bind(String, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
bind(Name, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
bind(String, Object) - Method in class javax.naming.InitialContext
bind(Name, Object) - Method in class javax.naming.InitialContext
BIND - Static variable in class javax.print.attribute.standard.Finishings
This value indicates that a binding is to be applied to the document; the type and placement of the binding is site-defined.
bind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextExtStub
Creates a binding of a name and an object in the naming context.
bind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextStub
Creates a binding of a name and an object in the naming context.
bind(NameComponent[], Object) - Method in interface org.omg.CosNaming.NamingContextOperations
Creates a binding of a name and an object in the naming context.
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextExtStub
Names an object that is a naming context.
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextStub
Names an object that is a naming context.
bind_context(NameComponent[], NamingContext) - Method in interface org.omg.CosNaming.NamingContextOperations
Names an object that is a naming context.
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation creates a new context and binds it to the name supplied as an argument.
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextStub
This operation creates a new context and binds it to the name supplied as an argument.
bind_new_context(NameComponent[]) - Method in interface org.omg.CosNaming.NamingContextOperations
This operation creates a new context and binds it to the name supplied as an argument.
Binder<XmlNode> - Class in javax.xml.bind
Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
Binder() - Constructor for class javax.xml.bind.Binder
BindException - Exception in java.net
Signals that an error occurred while attempting to bind a socket to a local address and port.
BindException(String) - Constructor for exception java.net.BindException
Constructs a new BindException with the specified detail message as to why the bind error occurred.
BindException() - Constructor for exception java.net.BindException
Construct a new BindException with no detailed message.
Binding - Class in javax.naming
This class represents a name-to-object binding found in a context.
Binding(String, Object) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name and object.
Binding(String, Object, boolean) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, object, and whether the name is relative.
Binding(String, String, Object) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, class name, and object.
Binding(String, String, Object, boolean) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, class name, object, and whether the name is relative.
Binding - Interface in javax.xml.ws
The Binding interface is the base interface for JAX-WS protocol bindings.
Binding - Class in org.omg.CosNaming
org/omg/CosNaming/Binding.java .
Binding() - Constructor for class org.omg.CosNaming.Binding
Binding(NameComponent[], BindingType) - Constructor for class org.omg.CosNaming.Binding
binding_name - Variable in class org.omg.CosNaming.Binding
binding_type - Variable in class org.omg.CosNaming.Binding
BindingHelper - Class in org.omg.CosNaming
org/omg/CosNaming/BindingHelper.java .
BindingHelper() - Constructor for class org.omg.CosNaming.BindingHelper
BindingHolder - Class in org.omg.CosNaming
org/omg/CosNaming/BindingHolder.java .
BindingHolder() - Constructor for class org.omg.CosNaming.BindingHolder
BindingHolder(Binding) - Constructor for class org.omg.CosNaming.BindingHolder
BindingIterator - Interface in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHelper - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHelper() - Constructor for class org.omg.CosNaming.BindingIteratorHelper
BindingIteratorHolder - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHolder() - Constructor for class org.omg.CosNaming.BindingIteratorHolder
BindingIteratorHolder(BindingIterator) - Constructor for class org.omg.CosNaming.BindingIteratorHolder
BindingIteratorOperations - Interface in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorPOA - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorPOA() - Constructor for class org.omg.CosNaming.BindingIteratorPOA
BindingListHelper - Class in org.omg.CosNaming
List of Bindings.
BindingListHelper() - Constructor for class org.omg.CosNaming.BindingListHelper
BindingListHolder - Class in org.omg.CosNaming
List of Bindings.
BindingListHolder() - Constructor for class org.omg.CosNaming.BindingListHolder
BindingListHolder(Binding[]) - Constructor for class org.omg.CosNaming.BindingListHolder
BindingProvider - Interface in javax.xml.ws
The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
Bindings - Interface in javax.script
A mapping of key/value pairs, all of whose keys are Strings.
BindingType - Annotation Type in javax.xml.ws
The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
BindingType - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingType(int) - Constructor for class org.omg.CosNaming.BindingType
BindingTypeHelper - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHelper() - Constructor for class org.omg.CosNaming.BindingTypeHelper
BindingTypeHolder - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHolder() - Constructor for class org.omg.CosNaming.BindingTypeHolder
BindingTypeHolder(BindingType) - Constructor for class org.omg.CosNaming.BindingTypeHolder
bindTo(Object) - Method in class java.lang.invoke.MethodHandle
Binds a value x to the first argument of a method handle, without invoking it.
BIT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BIT.
BIT_DEPTH_MULTI - Static variable in class java.awt.DisplayMode
Value of the bit depth if multiple bit depths are supported in this display mode.
bitCount(int) - Static method in class java.lang.Integer
Returns the number of one-bits in the two's complement binary representation of the specified int value.
bitCount(long) - Static method in class java.lang.Long
Returns the number of one-bits in the two's complement binary representation of the specified long value.
bitCount() - Method in class java.math.BigInteger
Returns the number of bits in the two's complement representation of this BigInteger that differ from its sign bit.
bitLength() - Method in class java.math.BigInteger
Returns the number of bits in the minimal two's-complement representation of this BigInteger, excluding a sign bit.
BITMASK - Static variable in interface java.awt.Transparency
Represents image data that is guaranteed to be either completely opaque, with an alpha value of 1.0, or completely transparent, with an alpha value of 0.0.
bitOffset - Variable in class javax.imageio.stream.ImageInputStreamImpl
The current bit offset within the stream.
BitSet - Class in java.util
This class implements a vector of bits that grows as needed.
BitSet() - Constructor for class java.util.BitSet
Creates a new bit set.
BitSet(int) - Constructor for class java.util.BitSet
Creates a bit set whose initial size is large enough to explicitly represent bits with indices in the range 0 through nbits-1.
black - Static variable in class java.awt.Color
The color black.
BLACK - Static variable in class java.awt.Color
The color black.
BLIT_SCROLL_MODE - Static variable in class javax.swing.JViewport
Use graphics.copyArea to implement scrolling.
Blob - Interface in java.sql
The representation (mapping) in the JavaTM programming language of an SQL BLOB value.
BLOB - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BLOB.
block(InetAddress) - Method in class java.nio.channels.MembershipKey
Block multicast datagrams from the given source address.
block() - Method in interface java.util.concurrent.ForkJoinPool.ManagedBlocker
Possibly blocks the current thread, for example waiting for a lock or condition.
BLOCK_DECREMENT - Static variable in class java.awt.event.AdjustmentEvent
The block decrement adjustment type.
BLOCK_ELEMENTS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Block Elements" Unicode character block.
BLOCK_INCREMENT - Static variable in class java.awt.event.AdjustmentEvent
The block increment adjustment type.
blockClose(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds an instruction to the parse buffer to close out a block element of the given type.
blockIncrement - Variable in class javax.swing.JScrollBar
BlockingDeque<E> - Interface in java.util.concurrent
A Deque that additionally supports blocking operations that wait for the deque to become non-empty when retrieving an element, and wait for space to become available in the deque when storing an element.
blockingLock() - Method in class java.nio.channels.SelectableChannel
Retrieves the object upon which the configureBlocking and register methods synchronize.
blockingLock() - Method in class java.nio.channels.spi.AbstractSelectableChannel
BlockingQueue<E> - Interface in java.util.concurrent
A Queue that additionally supports operations that wait for the queue to become non-empty when retrieving an element, and wait for space to become available in the queue when storing an element.
blockOpen(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds an instruction to the parse buffer to create a block element with the given attributes.
BLOCKQUOTE - Static variable in class javax.swing.text.html.HTML.Tag
BlockView - Class in javax.swing.text.html
A view implementation to display a block (as a box) with CSS specifications.
BlockView(Element, int) - Constructor for class javax.swing.text.html.BlockView
Creates a new view that represents an html box.
blue - Static variable in class java.awt.Color
The color blue.
BLUE - Static variable in class java.awt.Color
The color blue.
BLUECOMPONENT - Static variable in class java.awt.color.ICC_ProfileRGB
Used to get a gamma value or TRC for the blue component.
BMPImageWriteParam - Class in javax.imageio.plugins.bmp
A subclass of ImageWriteParam for encoding images in the BMP format.
BMPImageWriteParam(Locale) - Constructor for class javax.imageio.plugins.bmp.BMPImageWriteParam
Constructs a BMPImageWriteParam set to use a given Locale and with default values for all parameters.
BMPImageWriteParam() - Constructor for class javax.imageio.plugins.bmp.BMPImageWriteParam
Constructs an BMPImageWriteParam object with default values for all parameters and a null Locale.
BODY - Static variable in class javax.swing.text.html.HTML.Tag
body - Variable in class javax.swing.text.html.parser.DTD
BOLD - Static variable in class java.awt.Font
The bold style constant.
Bold - Static variable in class javax.swing.text.StyleConstants
Name of the bold attribute.
BOLD_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The bold action identifier
Book - Class in java.awt.print
The Book class provides a representation of a document in which pages may have different page formats and page painters.
Book() - Constructor for class java.awt.print.Book
Creates a new, empty Book.
Boolean - Class in java.lang
The Boolean class wraps a value of the primitive type boolean in an object.
Boolean(boolean) - Constructor for class java.lang.Boolean
Allocates a Boolean object representing the value argument.
Boolean(String) - Constructor for class java.lang.Boolean
Allocates a Boolean object representing the value true if the string argument is not null and is equal, ignoring case, to the string "true".
BOOLEAN - Static variable in class java.sql.Types
The constant in the Java programming language, somtimes referred to as a type code, that identifies the generic SQL type BOOLEAN.
BOOLEAN - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Boolean.
BOOLEAN - Static variable in class javax.xml.xpath.XPathConstants
The XPath 1.0 boolean data type.
BooleanControl - Class in javax.sound.sampled
A BooleanControl provides the ability to switch between two possible settings that affect a line's audio.
BooleanControl(BooleanControl.Type, boolean, String, String) - Constructor for class javax.sound.sampled.BooleanControl
Constructs a new boolean control object with the given parameters.
BooleanControl(BooleanControl.Type, boolean) - Constructor for class javax.sound.sampled.BooleanControl
Constructs a new boolean control object with the given parameters.
BooleanControl.Type - Class in javax.sound.sampled
An instance of the BooleanControl.Type class identifies one kind of boolean control.
BooleanControl.Type(String) - Constructor for class javax.sound.sampled.BooleanControl.Type
Constructs a new boolean control type.
BooleanHolder - Class in org.omg.CORBA
The Holder for Boolean.
BooleanHolder() - Constructor for class org.omg.CORBA.BooleanHolder
Constructs a new BooleanHolder object with its value field initialized to false.
BooleanHolder(boolean) - Constructor for class org.omg.CORBA.BooleanHolder
Constructs a new BooleanHolder object with its value field initialized with the given boolean.
BooleanSeqHelper - Class in org.omg.CORBA
The Helper for BooleanSeq.
BooleanSeqHelper() - Constructor for class org.omg.CORBA.BooleanSeqHelper
BooleanSeqHolder - Class in org.omg.CORBA
The Holder for BooleanSeq.
BooleanSeqHolder() - Constructor for class org.omg.CORBA.BooleanSeqHolder
BooleanSeqHolder(boolean[]) - Constructor for class org.omg.CORBA.BooleanSeqHolder
booleanValue() - Method in class java.lang.Boolean
Returns the value of this Boolean object as a boolean primitive.
BootstrapMethodError - Error in java.lang
Thrown to indicate that an invokedynamic instruction has failed to find its bootstrap method, or the bootstrap method has failed to provide a call site with a target of the correct method type.
BootstrapMethodError() - Constructor for error java.lang.BootstrapMethodError
Constructs an BootstrapMethodError with no detail message.
BootstrapMethodError(String) - Constructor for error java.lang.BootstrapMethodError
Constructs an BootstrapMethodError with the specified detail message.
BootstrapMethodError(String, Throwable) - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with the specified detail message and cause.
BootstrapMethodError(Throwable) - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with the specified cause.
BOPOMOFO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bopomofo" Unicode character block.
BOPOMOFO_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bopomofo Extended" Unicode character block.
Border - Interface in javax.swing.border
Interface describing an object capable of rendering a border around the edges of a swing component.
border - Variable in class javax.swing.border.TitledBorder
BORDER - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER - Static variable in class javax.swing.text.html.HTML.Attribute
border - Variable in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
Border to use.
BORDER_BOTTOM - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the border drawn, or having it not drawn.
BORDER_PAINTED_FLAT_CHANGED_PROPERTY - Static variable in class javax.swing.JCheckBox
Identifies a change to the flat property.
BORDER_RIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BorderFactory - Class in javax.swing
Factory class for vending standard Border objects.
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.ButtonBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.MenuBarBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.MenuItemBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
BorderLayout - Class in java.awt
A border layout lays out a container, arranging and resizing its components to fit in five regions: north, south, east, west, and center.
BorderLayout() - Constructor for class java.awt.BorderLayout
Constructs a new border layout with no gaps between components.
BorderLayout(int, int) - Constructor for class java.awt.BorderLayout
Constructs a border layout with the specified gaps between components.
borderListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
borderSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellEditor
True if the border selection color should be drawn.
borderSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the focus indicator when the node has focus.
BorderUIResource - Class in javax.swing.plaf
BorderUIResource(Border) - Constructor for class javax.swing.plaf.BorderUIResource
Creates a UIResource border object which wraps an existing Border instance.
BorderUIResource.BevelBorderUIResource - Class in javax.swing.plaf
BorderUIResource.BevelBorderUIResource(int) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
BorderUIResource.BevelBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
BorderUIResource.BevelBorderUIResource(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
BorderUIResource.CompoundBorderUIResource - Class in javax.swing.plaf
BorderUIResource.CompoundBorderUIResource(Border, Border) - Constructor for class javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
BorderUIResource.EmptyBorderUIResource - Class in javax.swing.plaf
BorderUIResource.EmptyBorderUIResource(int, int, int, int) - Constructor for class javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
BorderUIResource.EmptyBorderUIResource(Insets) - Constructor for class javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
BorderUIResource.EtchedBorderUIResource - Class in javax.swing.plaf
BorderUIResource.EtchedBorderUIResource() - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
BorderUIResource.EtchedBorderUIResource(int) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
BorderUIResource.EtchedBorderUIResource(Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
BorderUIResource.EtchedBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
BorderUIResource.LineBorderUIResource - Class in javax.swing.plaf
BorderUIResource.LineBorderUIResource(Color) - Constructor for class javax.swing.plaf.BorderUIResource.LineBorderUIResource
BorderUIResource.LineBorderUIResource(Color, int) - Constructor for class javax.swing.plaf.BorderUIResource.LineBorderUIResource
BorderUIResource.MatteBorderUIResource - Class in javax.swing.plaf
BorderUIResource.MatteBorderUIResource(int, int, int, int, Color) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
BorderUIResource.MatteBorderUIResource(int, int, int, int, Icon) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
BorderUIResource.MatteBorderUIResource(Icon) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
BorderUIResource.TitledBorderUIResource - Class in javax.swing.plaf
BorderUIResource.TitledBorderUIResource(String) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BorderUIResource.TitledBorderUIResource(Border) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BorderUIResource.TitledBorderUIResource(Border, String) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BorderUIResource.TitledBorderUIResource(Border, String, int, int) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font, Color) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
BOTH - Static variable in class java.awt.GridBagConstraints
Resize the component both horizontally and vertically.
bottom - Variable in class java.awt.Insets
The inset from the bottom.
BOTTOM - Static variable in class javax.print.attribute.standard.MediaTray
The bottom input tray in the printer.
bottom - Variable in class javax.swing.border.EmptyBorder
BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title in the middle of the border's bottom line.
BOTTOM - Static variable in class javax.swing.JSplitPane
Used to add a Component below the other Component.
BOTTOM - Static variable in interface javax.swing.SwingConstants
Box-orientation constant used to specify the bottom of a box.
BOTTOM_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentY.
BOTTOM_ALIGNMENT - Static variable in class java.awt.font.GraphicAttribute
Aligns bottom of graphic to bottom of line.
BoundedRangeModel - Interface in javax.swing
Defines the data model used by components like Sliders and ProgressBars.
bounds() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getBounds().
bounds - Variable in class java.awt.Polygon
The bounds of this Polygon.
Bounds - Exception in org.omg.CORBA
A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
Bounds() - Constructor for exception org.omg.CORBA.Bounds
Constructs an Bounds with no specified detail message.
Bounds(String) - Constructor for exception org.omg.CORBA.Bounds
Constructs an Bounds with the specified detail message.
Bounds - Exception in org.omg.CORBA.TypeCodePackage
Provides the TypeCode operations member_name(), member_type(), and member_label.
Bounds() - Constructor for exception org.omg.CORBA.TypeCodePackage.Bounds
Constructs a Bounds exception with no reason message.
Bounds(String) - Constructor for exception org.omg.CORBA.TypeCodePackage.Bounds
Constructs a Bounds exception with the specified reason message.
Box - Class in javax.swing
A lightweight container that uses a BoxLayout object as its layout manager.
Box(int) - Constructor for class javax.swing.Box
Creates a Box that displays its components along the the specified axis.
Box.AccessibleBox - Class in javax.swing
This class implements accessibility support for the Box class.
Box.AccessibleBox() - Constructor for class javax.swing.Box.AccessibleBox
Box.Filler - Class in javax.swing
An implementation of a lightweight component that participates in layout but has no view.
Box.Filler(Dimension, Dimension, Dimension) - Constructor for class javax.swing.Box.Filler
Constructor to create shape with the given size ranges.
Box.Filler.AccessibleBoxFiller - Class in javax.swing
This class implements accessibility support for the Box.Filler class.
Box.Filler.AccessibleBoxFiller() - Constructor for class javax.swing.Box.Filler.AccessibleBoxFiller
BOX_DRAWING - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Box Drawing" Unicode character block.
boxedClass(PrimitiveType) - Method in interface javax.lang.model.util.Types
Returns the class of a boxed value of a given primitive type.
BoxedValueHelper - Interface in org.omg.CORBA.portable
BoxLayout - Class in javax.swing
A layout manager that allows multiple components to be laid out either vertically or horizontally.
BoxLayout(Container, int) - Constructor for class javax.swing.BoxLayout
Creates a layout manager that will lay out components along the given axis.
boxRect - Variable in class javax.swing.plaf.basic.BasicProgressBarUI
Used to hold the location and size of the bouncing box (returned by getBox) to be painted.
BoxView - Class in javax.swing.text
A view that arranges its children into a box shape by tiling its children along an axis.
BoxView(Element, int) - Constructor for class javax.swing.text.BoxView
Constructs a BoxView.
BR - Static variable in class javax.swing.text.html.HTML.Tag
BRAHMI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Brahmi" Unicode character block.
BRAILLE_PATTERNS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Braille Patterns" Unicode character block.
breadthFirstEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order.
BreakIterator - Class in java.text
The BreakIterator class implements methods for finding the location of boundaries in text.
BreakIterator() - Constructor for class java.text.BreakIterator
Constructor.
BreakIteratorProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the BreakIterator class.
BreakIteratorProvider() - Constructor for class java.text.spi.BreakIteratorProvider
Sole constructor.
breaksFlow() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag causes a line break to the flow of data, otherwise returns false.
breaksFlow() - Method in class javax.swing.text.html.parser.TagElement
breakView(int, int, float, float) - Method in class javax.swing.text.GlyphView
Breaks this view on the given axis at the given length.
breakView(int, int, float, float) - Method in class javax.swing.text.html.InlineView
Tries to break this view on the given axis.
breakView(int, float, Shape) - Method in class javax.swing.text.ParagraphView
Breaks this view on the given axis at the given length.
breakView(int, int, float, float) - Method in class javax.swing.text.View
Tries to break this view on the given axis.
BRIEF - Static variable in class java.rmi.server.LogStream
Deprecated.
log level constant (brief logging).
brighter() - Method in class java.awt.Color
Creates a new Color that is a brighter version of this Color.
BrokenBarrierException - Exception in java.util.concurrent
Exception thrown when a thread tries to wait upon a barrier that is in a broken state, or which enters the broken state while the thread is waiting.
BrokenBarrierException() - Constructor for exception java.util.concurrent.BrokenBarrierException
Constructs a BrokenBarrierException with no specified detail message.
BrokenBarrierException(String) - Constructor for exception java.util.concurrent.BrokenBarrierException
Constructs a BrokenBarrierException with the specified detail message.
browse(URI) - Method in class java.awt.Desktop
Launches the default browser to display a URI.
BUBBLING_PHASE - Static variable in interface org.w3c.dom.events.Event
The current event phase is the bubbling phase.
buf - Variable in class java.io.BufferedInputStream
The internal buffer array where the data is stored.
buf - Variable in class java.io.BufferedOutputStream
The internal buffer where data is stored.
buf - Variable in class java.io.ByteArrayInputStream
An array of bytes that was provided by the creator of the stream.
buf - Variable in class java.io.ByteArrayOutputStream
The buffer where data is stored.
buf - Variable in class java.io.CharArrayReader
The character buffer.
buf - Variable in class java.io.CharArrayWriter
The buffer where data is stored.
buf - Variable in class java.io.PushbackInputStream
The pushback buffer.
buf - Variable in class java.util.zip.DeflaterInputStream
Input buffer for reading compressed data.
buf - Variable in class java.util.zip.DeflaterOutputStream
Output buffer for writing compressed data.
buf - Variable in class java.util.zip.InflaterInputStream
Input buffer for decompression.
buf - Variable in class java.util.zip.InflaterOutputStream
Output buffer for writing uncompressed data.
buffer - Variable in class java.io.PipedInputStream
The circular buffer into which incoming data is placed.
buffer - Variable in class java.io.StringBufferInputStream
Deprecated.
The string from which bytes are read.
Buffer - Class in java.nio
A container for data of a specific primitive type.
buffer - Variable in class javax.swing.text.DefaultStyledDocument
BUFFER_SIZE_DEFAULT - Static variable in class javax.swing.text.DefaultStyledDocument
The default size of the initial content buffer.
BufferCapabilities - Class in java.awt
Capabilities and properties of buffers.
BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents) - Constructor for class java.awt.BufferCapabilities
Creates a new object for specifying buffering capabilities
BufferCapabilities.FlipContents - Class in java.awt
A type-safe enumeration of the possible back buffer contents after page-flipping
BUFFERED_OPTION - Static variable in class javax.swing.DebugGraphics
Show buffered operations in a separate Frame.
BufferedImage - Class in java.awt.image
The BufferedImage subclass describes an Image with an accessible buffer of image data.
BufferedImage(int, int, int) - Constructor for class java.awt.image.BufferedImage
Constructs a BufferedImage of one of the predefined image types.
BufferedImage(int, int, int, IndexColorModel) - Constructor for class java.awt.image.BufferedImage
Constructs a BufferedImage of one of the predefined image types: TYPE_BYTE_BINARY or TYPE_BYTE_INDEXED.
BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>) - Constructor for class java.awt.image.BufferedImage
Constructs a new BufferedImage with a specified ColorModel and Raster.
BufferedImageFilter - Class in java.awt.image
The BufferedImageFilter class subclasses an ImageFilter to provide a simple means of using a single-source/single-destination image operator (BufferedImageOp) to filter a BufferedImage in the Image Producer/Consumer/Observer paradigm.
BufferedImageFilter(BufferedImageOp) - Constructor for class java.awt.image.BufferedImageFilter
Constructs a BufferedImageFilter with the specified single-source/single-destination operator.
BufferedImageOp - Interface in java.awt.image
This interface describes single-input/single-output operations performed on BufferedImage objects.
BufferedInputStream - Class in java.io
A BufferedInputStream adds functionality to another input stream-namely, the ability to buffer the input and to support the mark and reset methods.
BufferedInputStream(InputStream) - Constructor for class java.io.BufferedInputStream
Creates a BufferedInputStream and saves its argument, the input stream in, for later use.
BufferedInputStream(InputStream, int) - Constructor for class java.io.BufferedInputStream
Creates a BufferedInputStream with the specified buffer size, and saves its argument, the input stream in, for later use.
BufferedOutputStream - Class in java.io
The class implements a buffered output stream.
BufferedOutputStream(OutputStream) - Constructor for class java.io.BufferedOutputStream
Creates a new buffered output stream to write data to the specified underlying output stream.
BufferedOutputStream(OutputStream, int) - Constructor for class java.io.BufferedOutputStream
Creates a new buffered output stream to write data to the specified underlying output stream with the specified buffer size.
BufferedReader - Class in java.io
Reads text from a character-input stream, buffering characters so as to provide for the efficient reading of characters, arrays, and lines.
BufferedReader(Reader, int) - Constructor for class java.io.BufferedReader
Creates a buffering character-input stream that uses an input buffer of the specified size.
BufferedReader(Reader) - Constructor for class java.io.BufferedReader
Creates a buffering character-input stream that uses a default-sized input buffer.
BufferedWriter - Class in java.io
Writes text to a character-output stream, buffering characters so as to provide for the efficient writing of single characters, arrays, and strings.
BufferedWriter(Writer) - Constructor for class java.io.BufferedWriter
Creates a buffered character-output stream that uses a default-sized output buffer.
BufferedWriter(Writer, int) - Constructor for class java.io.BufferedWriter
Creates a new buffered character-output stream that uses an output buffer of the given size.
BufferOverflowException - Exception in java.nio
Unchecked exception thrown when a relative put operation reaches the target buffer's limit.
BufferOverflowException() - Constructor for exception java.nio.BufferOverflowException
Constructs an instance of this class.
BufferPoolMXBean - Interface in java.lang.management
The management interface for a buffer pool, for example a pool of direct or mapped buffers.
BufferStrategy - Class in java.awt.image
The BufferStrategy class represents the mechanism with which to organize complex memory on a particular Canvas or Window.
BufferStrategy() - Constructor for class java.awt.image.BufferStrategy
BufferUnderflowException - Exception in java.nio
Unchecked exception thrown when a relative get operation reaches the source buffer's limit.
BufferUnderflowException() - Constructor for exception java.nio.BufferUnderflowException
Constructs an instance of this class.
BUGINESE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Buginese" Unicode character block.
BUHID - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Buhid" Unicode character block.
build() - Method in class java.nio.file.attribute.AclEntry.Builder
Constructs an AclEntry from the components of this builder.
build(CertPathParameters) - Method in class java.security.cert.CertPathBuilder
Attempts to build a certification path using the specified algorithm parameter set.
build() - Method in class java.util.Locale.Builder
Returns an instance of Locale created from the fields set on this builder.
build() - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
buildChooser() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Builds a new chooser panel.
bulkRegister(int) - Method in class java.util.concurrent.Phaser
Adds the given number of new unarrived parties to this phaser.
bumps - Variable in class javax.swing.plaf.metal.MetalBorders.ToolBarBorder
bumps - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
burstStringInto(Container, String, int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Recursively creates new JLabel instances to represent d.
BUSY - Static variable in class javax.accessibility.AccessibleState
Indicates the current object is busy.
Button - Class in java.awt
This class creates a labeled button.
Button() - Constructor for class java.awt.Button
Constructs a button with an empty string for its label.
Button(String) - Constructor for class java.awt.Button
Constructs a button with the specified label.
BUTTON - Static variable in class javax.swing.plaf.synth.Region
Button region.
Button.AccessibleAWTButton - Class in java.awt
This class implements accessibility support for the Button class.
Button.AccessibleAWTButton() - Constructor for class java.awt.Button.AccessibleAWTButton
BUTTON1 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #1; used by MouseEvent.getButton().
BUTTON1_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button1 extended modifier constant.
BUTTON1_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button1 modifier constant.
BUTTON2 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #2; used by MouseEvent.getButton().
BUTTON2_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button2 extended modifier constant.
BUTTON2_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button2 modifier constant.
BUTTON3 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #3; used by MouseEvent.getButton().
BUTTON3_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button3 extended modifier constant.
BUTTON3_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button3 modifier constant.
ButtonGroup - Class in javax.swing
This class is used to create a multiple-exclusion scope for a set of buttons.
ButtonGroup() - Constructor for class javax.swing.ButtonGroup
Creates a new ButtonGroup.
buttonIndex - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
buttonListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
ButtonModel - Interface in javax.swing
State model for buttons.
buttons - Variable in class javax.swing.ButtonGroup
ButtonUI - Class in javax.swing.plaf
Pluggable look and feel interface for JButton.
ButtonUI() - Constructor for class javax.swing.plaf.ButtonUI
Byte - Class in java.lang
The Byte class wraps a value of primitive type byte in an object.
Byte(byte) - Constructor for class java.lang.Byte
Constructs a newly allocated Byte object that represents the specified byte value.
Byte(String) - Constructor for class java.lang.Byte
Constructs a newly allocated Byte object that represents the byte value indicated by the String parameter.
BYTE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Byte.
ByteArrayInputStream - Class in java.io
A ByteArrayInputStream contains an internal buffer that contains bytes that may be read from the stream.
ByteArrayInputStream(byte[]) - Constructor for class java.io.ByteArrayInputStream
Creates a ByteArrayInputStream so that it uses buf as its buffer array.
ByteArrayInputStream(byte[], int, int) - Constructor for class java.io.ByteArrayInputStream
Creates ByteArrayInputStream that uses buf as its buffer array.
ByteArrayOutputStream - Class in java.io
This class implements an output stream in which the data is written into a byte array.
ByteArrayOutputStream() - Constructor for class java.io.ByteArrayOutputStream
Creates a new byte array output stream.
ByteArrayOutputStream(int) - Constructor for class java.io.ByteArrayOutputStream
Creates a new byte array output stream, with a buffer capacity of the specified size, in bytes.
ByteBuffer - Class in java.nio
A byte buffer.
ByteChannel - Interface in java.nio.channels
A channel that can read and write bytes.
ByteHolder - Class in org.omg.CORBA
The Holder for Byte.
ByteHolder() - Constructor for class org.omg.CORBA.ByteHolder
Constructs a new ByteHolder object with its value field initialized to 0.
ByteHolder(byte) - Constructor for class org.omg.CORBA.ByteHolder
Constructs a new ByteHolder object for the given byte.
byteLength - Variable in class javax.sound.midi.MidiFileFormat
The length of the MIDI file in bytes.
ByteLookupTable - Class in java.awt.image
This class defines a lookup table object.
ByteLookupTable(int, byte[][]) - Constructor for class java.awt.image.ByteLookupTable
Constructs a ByteLookupTable object from an array of byte arrays representing a lookup table for each band.
ByteLookupTable(int, byte[]) - Constructor for class java.awt.image.ByteLookupTable
Constructs a ByteLookupTable object from an array of bytes representing a lookup table to be applied to all bands.
ByteOrder - Class in java.nio
A typesafe enumeration for byte orders.
byteOrder - Variable in class javax.imageio.stream.ImageInputStreamImpl
The byte order of the stream as an instance of the enumeration class java.nio.ByteOrder, where ByteOrder.BIG_ENDIAN indicates network byte order and ByteOrder.LITTLE_ENDIAN indicates the reverse order.
bytesConsumed() - Method in class javax.net.ssl.SSLEngineResult
Returns the number of bytes consumed from the input buffer.
bytesProduced() - Method in class javax.net.ssl.SSLEngineResult
Returns the number of bytes written to the output buffer.
bytesTransferred - Variable in exception java.io.InterruptedIOException
Reports how many bytes had been transferred as part of the I/O operation before it was interrupted.
bytesWidth(byte[], int, int) - Method in class java.awt.FontMetrics
Returns the total advance width for showing the specified array of bytes in this Font.
byteValue() - Method in class java.lang.Byte
Returns the value of this Byte as a byte.
byteValue() - Method in class java.lang.Double
Returns the value of this Double as a byte (by casting to a byte).
byteValue() - Method in class java.lang.Float
Returns the value of this Float as a byte (by casting to a byte).
byteValue() - Method in class java.lang.Integer
Returns the value of this Integer as a byte.
byteValue() - Method in class java.lang.Long
Returns the value of this Long as a byte.
byteValue() - Method in class java.lang.Number
Returns the value of the specified number as a byte.
byteValue() - Method in class java.lang.Short
Returns the value of this Short as a byte.
byteValueExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to a byte, checking for lost information.
BYZANTINE_MUSICAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Byzantine Musical Symbols" Unicode character block.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ahmBl#e...oahhtvs n


C-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

C

C - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering C, 17 x 22 in.
C - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering C size, 17 inch by 22 inch.
C - Static variable in class javax.print.attribute.standard.MediaSizeName
C size .
C0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C0.
C1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C1.
C10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C10.
C14NMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec
A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
C2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C2.
C3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C3.
C3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C3 size, 324 mm by 458 mm.
C4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C4.
C4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C4 size, 229 mm by 324 mm.
C5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C5.
C5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C5 size, 162 mm by 229 mm.
C6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C6.
C6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C6 size, 114 mm by 162 mm.
C7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C7.
C8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C8.
C9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C9.
cachedChildren() - Method in class java.util.prefs.AbstractPreferences
Returns all known unremoved children of this node.
cachedMinimumSize - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
CachedRowSet - Interface in javax.sql.rowset
The interface that all standard implementations of CachedRowSet must implement.
cacheIcon(File, Icon) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
cacheMBeanInfo(MBeanInfo) - Method in class javax.management.StandardMBean
Customization hook: cache the MBeanInfo built for this object.
CacheRequest - Class in java.net
Represents channels for storing resources in the ResponseCache.
CacheRequest() - Constructor for class java.net.CacheRequest
CacheResponse - Class in java.net
Represent channels for retrieving resources from the ResponseCache.
CacheResponse() - Constructor for class java.net.CacheResponse
calcRect - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
A rectangle used for general layout calculations in order to avoid constructing many new Rectangles on the fly.
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing.SizeRequirements
Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments.
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments.
calculateBreakPosition(int, int) - Method in class javax.swing.text.WrappedPlainView
This is called by the nested wrapped line views to determine the break location.
calculateContentRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateFocusRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateGeometry() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateGeometry() - Method in class javax.swing.plaf.synth.SynthSliderUI
calculateIndex(CompositeData) - Method in interface javax.management.openmbean.TabularData
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
calculateIndex(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
calculateInnerArea(JComponent, Rectangle) - Static method in class javax.swing.SwingUtilities
Stores the position and size of the inner painting area of the specified component in r and returns r.
calculateLabelRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateLayoutInfo() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for the major axis axis.
calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.BlockView
Calculate the requirements of the block along the major axis (i.e.
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateMaxTabWidth(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateMaxTabWidth(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for the minor axis axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.FlowView
Calculate equirements along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.BlockView
Calculate the requirements of the block along the minor axis (i.e.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.ParagraphView
Calculate the needs for the paragraph along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.ParagraphView
Calculate the needs for the paragraph along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.TableView
Calculate the requirements for the minor axis.
calculateSize(boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateTabAreaHeight(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabAreaWidth(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabHeight(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabRects(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateThumbLocation() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateThumbLocation() - Method in class javax.swing.plaf.synth.SynthSliderUI
calculateThumbSize() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTickRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
calculateTrackBuffer() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTrackRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calendar - Variable in class java.text.DateFormat
The Calendar instance used for calculating the date-time fields and the instant of time.
Calendar - Class in java.util
The Calendar class is an abstract class that provides methods for converting between a specific instant in time and a set of calendar fields such as YEAR, MONTH, DAY_OF_MONTH, HOUR, and so on, and for manipulating the calendar fields, such as getting the date of the next week.
Calendar() - Constructor for class java.util.Calendar
Constructs a Calendar with the default time zone and locale.
Calendar(TimeZone, Locale) - Constructor for class java.util.Calendar
Constructs a calendar with the specified time zone and locale.
call() - Method in interface java.util.concurrent.Callable
Computes a result, or throws an exception if unable to do so.
call() - Method in interface javax.tools.JavaCompiler.CompilationTask
Performs this compilation task.
call(SOAPMessage, Object) - Method in class javax.xml.soap.SOAPConnection
Sends the given message to the specified endpoint and blocks until it has returned the response.
Callable<V> - Interface in java.util.concurrent
A task that returns a result and may throw an exception.
callable(Runnable, T) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given task and returns the given result.
callable(Runnable) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given task and returns null.
callable(PrivilegedAction<?>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given privileged action and returns its result.
callable(PrivilegedExceptionAction<?>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given privileged exception action and returns its result.
CallableStatement - Interface in java.sql
The interface used to execute SQL stored procedures.
Callback - Interface in javax.security.auth.callback
Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.
CallbackHandler - Interface in javax.security.auth.callback
An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
CallSite - Class in java.lang.invoke
A CallSite is a holder for a variable MethodHandle, which is called its target.
CANADA - Static variable in class java.util.Locale
Useful constant for country.
CANADA_FRENCH - Static variable in class java.util.Locale
Useful constant for country.
cancel() - Method in class java.awt.print.PrinterJob
Cancels a print job that is in progress.
cancel() - Method in class java.nio.channels.SelectionKey
Requests that the registration of this key's channel with its selector be cancelled.
cancel() - Method in class java.nio.channels.spi.AbstractSelectionKey
Cancels this key.
cancel() - Method in interface java.nio.file.WatchKey
Cancels the registration with the watch service.
cancel() - Method in interface java.sql.Statement
Cancels this Statement object if both the DBMS and driver support aborting an SQL statement.
cancel(boolean) - Method in class java.util.concurrent.ForkJoinTask
Attempts to cancel execution of this task.
cancel(boolean) - Method in interface java.util.concurrent.Future
Attempts to cancel execution of this task.
cancel(boolean) - Method in class java.util.concurrent.FutureTask
cancel() - Method in class java.util.Timer
Terminates this timer, discarding any currently scheduled tasks.
cancel() - Method in class java.util.TimerTask
Cancels this timer task.
cancel() - Method in interface javax.print.CancelablePrintJob
Stops further processing of a print job.
CANCEL - Static variable in class javax.security.auth.callback.ConfirmationCallback
CANCEL option.
cancel(boolean) - Method in class javax.swing.SwingWorker
Attempts to cancel execution of this task.
CANCEL_OPTION - Static variable in class javax.swing.JFileChooser
Return value if cancel is chosen.
CANCEL_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if CANCEL is chosen.
CANCEL_SELECTION - Static variable in class javax.swing.JFileChooser
Instruction to cancel the current selection.
CancelablePrintJob - Interface in javax.print
This interface is used by a printing application to cancel a print job.
cancelButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelCellEditing() - Method in class javax.swing.AbstractCellEditor
Calls fireEditingCanceled.
cancelCellEditing() - Method in interface javax.swing.CellEditor
Tells the editor to cancel editing and not accept any partially edited value.
cancelCellEditing() - Method in class javax.swing.DefaultCellEditor
Forwards the message from the CellEditor to the delegate.
cancelCellEditing() - Method in class javax.swing.DefaultCellEditor.EditorDelegate
Cancels editing.
cancelCellEditing() - Method in class javax.swing.tree.DefaultTreeCellEditor
Messages cancelCellEditing to the realEditor and removes it from this instance.
CANCELED - Static variable in class javax.print.attribute.standard.JobState
The job has been canceled by some human agency, the printer has completed canceling the job, and all job status attributes have reached their final values for the job.
cancelEditing() - Method in class javax.swing.JTree
Cancels the current editing session.
cancelEditing(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI
Cancels the current editing session.
cancelEditing(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the cancelEditing method on each UI handled by this object.
cancelEditing(JTree) - Method in class javax.swing.plaf.TreeUI
Cancels the current editing session.
cancelLatestCommittedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests
Gets the latest committed text from the text editing component and removes it from the component's text body.
CancellationException - Exception in java.util.concurrent
Exception indicating that the result of a value-producing task, such as a FutureTask, cannot be retrieved because the task was cancelled.
CancellationException() - Constructor for exception java.util.concurrent.CancellationException
Constructs a CancellationException with no detail message.
CancellationException(String) - Constructor for exception java.util.concurrent.CancellationException
Constructs a CancellationException with the specified detail message.
CancelledKeyException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to use a selection key that is no longer valid.
CancelledKeyException() - Constructor for exception java.nio.channels.CancelledKeyException
Constructs an instance of this class.
cancelledKeys() - Method in class java.nio.channels.spi.AbstractSelector
Retrieves this selector's cancelled-key set.
cancelRowUpdates() - Method in interface java.sql.ResultSet
Cancels the updates made to the current row in this ResultSet object.
cancelSelection() - Method in class javax.swing.JFileChooser
Called by the UI when the user chooses the Cancel button.
canDecodeInput(Object) - Method in class javax.imageio.spi.ImageReaderSpi
Returns true if the supplied source object appears to be of the format supported by this reader.
canDisplay(char) - Method in class java.awt.Font
Checks if this Font has a glyph for the specified character.
canDisplay(int) - Method in class java.awt.Font
Checks if this Font has a glyph for the specified character.
canDisplayUpTo(String) - Method in class java.awt.Font
Indicates whether or not this Font can display a specified String.
canDisplayUpTo(char[], int, int) - Method in class java.awt.Font
Indicates whether or not this Font can display the characters in the specified text starting at start and ending at limit.
canDisplayUpTo(CharacterIterator, int, int) - Method in class java.awt.Font
Indicates whether or not this Font can display the text specified by the iter starting at start and ending at limit.
canDock(Component, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
canEdit - Variable in class javax.swing.tree.DefaultTreeCellEditor
As of Java 2 platform v1.4 this field should no longer be used.
canEditImmediately(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor
Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
canEncode() - Method in class java.nio.charset.Charset
Tells whether or not this charset supports encoding.
canEncode(char) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not this encoder can encode the given character.
canEncode(CharSequence) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not this encoder can encode the given character sequence.
canEncodeImage(ImageTypeSpecifier) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter implementation associated with this service provider is able to encode an image with the given layout.
canEncodeImage(RenderedImage) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter implementation associated with this service provider is able to encode the given RenderedImage instance.
canExecute() - Method in class java.io.File
Tests whether the application can execute the file denoted by this abstract pathname.
canFilterIndexColorModel - Variable in class java.awt.image.RGBImageFilter
This boolean indicates whether or not it is acceptable to apply the color filtering of the filterRGB method to the color table entries of an IndexColorModel object in lieu of pixel by pixel filtering.
canImport(TransferHandler.TransferSupport) - Method in class javax.swing.TransferHandler
This method is called repeatedly during a drag and drop operation to allow the developer to configure properties of, and to return the acceptability of transfers; with a return value of true indicating that the transfer represented by the given TransferSupport (which contains all of the details of the transfer) is acceptable at the current time, and a value of false rejecting the transfer.
canImport(JComponent, DataFlavor[]) - Method in class javax.swing.TransferHandler
Indicates whether a component will accept an import of the given set of data flavors prior to actually attempting to import it.
canInsertEmpty(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the insertion of a new, empty image at the given index.
canInsertImage(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the insertion of a new image at the given index.
canNodeAppear(String, ImageTypeSpecifier) - Method in interface javax.imageio.metadata.IIOMetadataFormat
Returns true if the element (and the subtree below it) is allowed to appear in a metadata document for an image of the given type, defined by an ImageTypeSpecifier.
canNodeAppear(String, ImageTypeSpecifier) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
CannotProceed - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
CannotProceed() - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceed(NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceed(String, NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceedException - Exception in javax.naming
This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further.
CannotProceedException(String) - Constructor for exception javax.naming.CannotProceedException
Constructs a new instance of CannotProceedException using an explanation.
CannotProceedException() - Constructor for exception javax.naming.CannotProceedException
Constructs a new instance of CannotProceedException.
CannotProceedHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java .
CannotProceedHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
CannotProceedHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
CannotProceedHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
CannotProceedHolder(CannotProceed) - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
CannotRedoException - Exception in javax.swing.undo
Thrown when an UndoableEdit is told to redo() and can't.
CannotRedoException() - Constructor for exception javax.swing.undo.CannotRedoException
CannotUndoException - Exception in javax.swing.undo
Thrown when an UndoableEdit is told to undo() and can't.
CannotUndoException() - Constructor for exception javax.swing.undo.CannotUndoException
canOffsetTiles - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows tiling grid offset parameters to be set.
canOffsetTiles() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can perform tiling with non-zero grid offsets while writing.
CANON_EQ - Static variable in class java.util.regex.Pattern
Enables canonical equivalence.
CANONICAL - Static variable in class javax.security.auth.x500.X500Principal
Canonical String format of Distinguished Names.
CANONICAL_DECOMPOSITION - Static variable in class java.text.Collator
Decomposition mode value.
CanonicalizationMethod - Interface in javax.xml.crypto.dsig
A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
canonicalize(Oid) - Method in interface org.ietf.jgss.GSSName
Creates a name that is canonicalized for some mechanism.
canPathsBeAdded(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Used to test if a particular set of TreePaths can be added.
canPathsBeRemoved(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the paths can be removed without breaking the continuity of the model.
canRead() - Method in class java.io.File
Tests whether the application can read the file denoted by this abstract pathname.
canReadRaster() - Method in class javax.imageio.ImageReader
Returns true if this plug-in supports reading just a Raster of pixel data.
canRedo() - Method in class javax.swing.undo.AbstractUndoableEdit
Returns true if this edit is alive and hasBeenDone is false.
canRedo() - Method in class javax.swing.undo.CompoundEdit
Returns false if isInProgress or if super returns false.
canRedo() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit may be redone.
canRedo() - Method in class javax.swing.undo.UndoManager
Returns true if edits may be redone.
canRemoveImage(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the removal of an existing image at the given index.
canReplaceImageMetadata(int) - Method in class javax.imageio.ImageWriter
Returns true if it is possible to replace the image metadata associated with an existing image with index imageIndex.
canReplacePixels(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer allows pixels of the given image to be replaced using the replacePixels methods.
canReplaceStreamMetadata() - Method in class javax.imageio.ImageWriter
Returns true if it is possible to replace the stream metadata already present in the output.
canSetParameter(String, Object) - Method in interface org.w3c.dom.DOMConfiguration
Check if setting a parameter to a specific value is supported.
canSetSourceRenderSize - Variable in class javax.imageio.ImageReadParam
true if this ImageReadParam allows the source rendering dimensions to be set.
canSetSourceRenderSize() - Method in class javax.imageio.ImageReadParam
Returns true if this reader allows the source image to be rendered at an arbitrary size as part of the decoding process, by means of the setSourceRenderSize method.
canUndo() - Method in class javax.swing.undo.AbstractUndoableEdit
Returns true if this edit is alive and hasBeenDone is true.
canUndo() - Method in class javax.swing.undo.CompoundEdit
Returns false if isInProgress or if super returns false.
canUndo() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit may be undone.
canUndo() - Method in class javax.swing.undo.UndoManager
Returns true if edits may be undone.
canUndoOrRedo() - Method in class javax.swing.undo.UndoManager
Returns true if it is possible to invoke undo or redo.
canUseCacheFile() - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns true if the ImageInputStream implementation associated with this service provider can optionally make use of a cache file for improved performance and/or memory footrprint.
canUseCacheFile() - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns true if the ImageOutputStream implementation associated with this service provider can optionally make use of a cache File for improved performance and/or memory footrprint.
Canvas - Class in java.awt
A Canvas component represents a blank rectangular area of the screen onto which the application can draw or from which the application can trap input events from the user.
Canvas() - Constructor for class java.awt.Canvas
Constructs a new Canvas.
Canvas(GraphicsConfiguration) - Constructor for class java.awt.Canvas
Constructs a new Canvas given a GraphicsConfiguration object.
CANVAS - Static variable in class javax.accessibility.AccessibleRole
Object that can be drawn into and is used to trap events.
Canvas.AccessibleAWTCanvas - Class in java.awt
This class implements accessibility support for the Canvas class.
Canvas.AccessibleAWTCanvas() - Constructor for class java.awt.Canvas.AccessibleAWTCanvas
canWrite() - Method in class java.io.File
Tests whether the application can modify the file denoted by this abstract pathname.
canWriteCompressed - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this writer can write images using compression.
canWriteCompressed() - Method in class javax.imageio.ImageWriteParam
Returns true if this writer supports compression.
canWriteEmpty() - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the writing of a complete image stream consisting of a single image with undefined pixel values and associated metadata and thumbnails to the output.
canWriteProgressive - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows images to be written as a progressive sequence of increasing quality passes.
canWriteProgressive() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can write out images as a series of passes of progressively increasing quality.
canWriteRasters() - Method in class javax.imageio.ImageWriter
Returns true if the methods that take an IIOImage parameter are capable of dealing with a Raster (as opposed to RenderedImage) source image.
canWriteSequence() - Method in class javax.imageio.ImageWriter
Returns true if the writer is able to append an image to an image stream that already contains header information and possibly prior images.
canWriteTiles - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows tile width and tile height parameters to be set.
canWriteTiles() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can perform tiling while writing.
CAP_BUTT - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with no added decoration.
CAP_ROUND - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with a round decoration that has a radius equal to half of the width of the pen.
CAP_SQUARE - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with a square projection that extends beyond the end of the segment to a distance equal to half of the line width.
capacity() - Method in class java.lang.StringBuffer
capacity() - Method in class java.nio.Buffer
Returns this buffer's capacity.
capacity() - Method in class java.util.Vector
Returns the current capacity of this vector.
capacity() - Method in class javax.swing.DefaultListModel
Returns the current capacity of this list.
capacityIncrement - Variable in class java.util.Vector
The amount by which the capacity of the vector is automatically incremented when its size becomes greater than its capacity.
capacityIncrement - Static variable in class javax.management.monitor.Monitor
The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
caps - Variable in class java.awt.Component.BltBufferStrategy
The buffering capabilities
caps - Variable in class java.awt.Component.FlipBufferStrategy
The buffering capabilities
CAPS_LOCK - Static variable in class java.awt.Event
The Caps Lock key, a non-ASCII action key.
CAPTION - Static variable in class javax.swing.text.html.HTML.Tag
capture(TypeMirror) - Method in interface javax.lang.model.util.Types
Applies capture conversion to a type.
CAPTURING_PHASE - Static variable in interface org.w3c.dom.events.Event
The current event phase is the capturing phase.
cardinality() - Method in class java.util.BitSet
Returns the number of bits set to true in this BitSet.
CardLayout - Class in java.awt
A CardLayout object is a layout manager for a container.
CardLayout() - Constructor for class java.awt.CardLayout
Creates a new card layout with gaps of size zero.
CardLayout(int, int) - Constructor for class java.awt.CardLayout
Creates a new card layout with the specified horizontal and vertical gaps.
Caret - Interface in javax.swing.text
A place within a document view that represents where things can be inserted into the document model.
CARET_POSITION_CHANGED - Static variable in class java.awt.event.InputMethodEvent
The event type indicating a changed insertion point in input method text.
CaretEvent - Class in javax.swing.event
CaretEvent is used to notify interested parties that the text caret has changed in the event source.
CaretEvent(Object) - Constructor for class javax.swing.event.CaretEvent
Creates a new CaretEvent object.
CaretListener - Interface in javax.swing.event
Listener for changes in the caret position of a text component.
caretPositionChanged(InputMethodEvent) - Method in class java.awt.AWTEventMulticaster
Handles the caretPositionChanged event by invoking the caretPositionChanged methods on listener-a and listener-b.
caretPositionChanged(InputMethodEvent) - Method in interface java.awt.event.InputMethodListener
Invoked when the caret within composed text has changed.
caretUpdate(CaretEvent) - Method in interface javax.swing.event.CaretListener
Called when the caret position is updated.
caretUpdate(CaretEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles caret updates (fire appropriate property change event, which are AccessibleContext.ACCESSIBLE_CARET_PROPERTY and AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY).
CARIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Carian" Unicode character block.
CASE_INSENSITIVE - Static variable in class java.util.regex.Pattern
Enables case-insensitive matching.
CASE_INSENSITIVE_ORDER - Static variable in class java.lang.String
A Comparator that orders String objects as by compareToIgnoreCase.
cast(Object) - Method in class java.lang.类
Casts an object to the class or interface represented by this 类 object.
catchException(MethodHandle, Class<? extends Throwable>, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Makes a method handle which adapts a target method handle, by running it inside an exception handler.
catchExceptions - Variable in class java.awt.event.InvocationEvent
Set to true if dispatch() catches Throwable and stores it in the exception instance variable.
cbrt(double) - Static method in class java.lang.Math
Returns the cube root of a double value.
cbrt(double) - Static method in class java.lang.StrictMath
Returns the cube root of a double value.
CDATA - Static variable in interface javax.swing.text.html.parser.DTDConstants
CDATA - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a CDATA section
CDATA_SECTION_ELEMENTS - Static variable in class javax.xml.transform.OutputKeys
cdata-section-elements = expanded names.
CDATA_SECTION_NODE - Static variable in interface org.w3c.dom.Node
The node is a CDATASection.
CDATASection - Interface in org.w3c.dom
CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
ceil(double) - Static method in class java.lang.Math
Returns the smallest (closest to negative infinity) double value that is greater than or equal to the argument and is equal to a mathematical integer.
ceil(double) - Static method in class java.lang.StrictMath
Returns the smallest (closest to negative infinity) double value that is greater than or equal to the argument and is equal to a mathematical integer.
ceiling(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
ceiling(E) - Method in interface java.util.NavigableSet
Returns the least element in this set greater than or equal to the given element, or null if there is no such element.
ceiling(E) - Method in class java.util.TreeSet
ceilingEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key greater than or equal to the given key, or null if there is no such entry.
ceilingEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key greater than or equal to the given key, or null if there is no such key.
ceilingEntry(K) - Method in class java.util.TreeMap
ceilingKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
ceilingKey(K) - Method in interface java.util.NavigableMap
Returns the least key greater than or equal to the given key, or null if there is no such key.
ceilingKey(K) - Method in class java.util.TreeMap
CELL_EDITOR_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for cellEditor.
CELL_RENDERER_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for cellRenderer.
CELL_RENDERER_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
CellEditor - Interface in javax.swing
This interface defines the methods any general editor should be able to implement.
cellEditor - Variable in class javax.swing.JTable
The active cell editor object, that overwrites the screen real estate occupied by the current cell and allows the user to change its contents.
cellEditor - Variable in class javax.swing.JTree
Editor for the entries.
cellEditor - Variable in class javax.swing.plaf.basic.BasicTreeUI
Editor for the tree.
cellEditor - Variable in class javax.swing.table.TableColumn
The editor used to edit the data cells of the column.
CellEditorListener - Interface in javax.swing.event
CellEditorListener defines the interface for an object that listens to changes in a CellEditor
cellHeight - Variable in class javax.swing.plaf.basic.BasicListUI
cellHeights - Variable in class javax.swing.plaf.basic.BasicListUI
CELLPADDING - Static variable in class javax.swing.text.html.HTML.Attribute
cellRenderer - Variable in class javax.swing.JTree
The cell used to draw nodes.
cellRenderer - Variable in class javax.swing.table.TableColumn
The renderer used to draw the data cells of the column.
cellRendererChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
CellRendererPane - Class in javax.swing
This class is inserted in between cell renderers and the components that use them.
CellRendererPane() - Constructor for class javax.swing.CellRendererPane
Construct a CellRendererPane object.
CellRendererPane.AccessibleCellRendererPane - Class in javax.swing
This class implements accessibility support for the CellRendererPane class.
CellRendererPane.AccessibleCellRendererPane() - Constructor for class javax.swing.CellRendererPane.AccessibleCellRendererPane
cellSelectionEnabled - Variable in class javax.swing.JTable
Obsolete as of Java 2 platform v1.3.
CELLSPACING - Static variable in class javax.swing.text.html.HTML.Attribute
cellWidth - Variable in class javax.swing.plaf.basic.BasicListUI
CENTER - Static variable in class java.awt.BorderLayout
The center layout constraint (middle of container).
CENTER - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be centered.
CENTER - Static variable in class java.awt.GridBagConstraints
Put the component in the center of its display area.
CENTER - Static variable in class java.awt.Label
Indicates that the label should be centered.
CENTER - Static variable in class javax.swing.border.TitledBorder
Position title text in the center of the border line.
CENTER - Static variable in interface javax.swing.SwingConstants
The central position in an area.
CENTER - Static variable in class javax.swing.text.html.HTML.Tag
CENTER_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentY and getAlignmentX.
CENTER_BASELINE - Static variable in class java.awt.Font
The baseline used in ideographic scripts like Chinese, Japanese, and Korean when laying out text.
CENTER_BASELINE - Static variable in class java.awt.font.GraphicAttribute
Aligns origin of graphic to center baseline of line.
centersChildren - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
If true, children are lumped together in parent.
Certificate - Class in java.security.cert
Abstract class for managing a variety of identity certificates.
Certificate(String) - Constructor for class java.security.cert.Certificate
Creates a certificate of the specified type.
Certificate - Interface in java.security
Deprecated.
A new certificate handling package is created in the Java platform. This Certificate interface is entirely deprecated and is here to allow for a smooth transition to the new package.
Certificate - Class in javax.security.cert
Abstract class for managing a variety of identity certificates.
Certificate() - Constructor for class javax.security.cert.Certificate
Certificate.CertificateRep - Class in java.security.cert
Alternate Certificate class for serialization.
Certificate.CertificateRep(String, byte[]) - Constructor for class java.security.cert.Certificate.CertificateRep
Construct the alternate Certificate class with the Certificate type and Certificate encoding bytes.
CertificateEncodingException - Exception in java.security.cert
Certificate Encoding Exception.
CertificateEncodingException() - Constructor for exception java.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with no detail message.
CertificateEncodingException(String) - Constructor for exception java.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with the specified detail message.
CertificateEncodingException(String, Throwable) - Constructor for exception java.security.cert.CertificateEncodingException
Creates a CertificateEncodingException with the specified detail message and cause.
CertificateEncodingException(Throwable) - Constructor for exception java.security.cert.CertificateEncodingException
Creates a CertificateEncodingException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateEncodingException - Exception in javax.security.cert
Certificate Encoding Exception.
CertificateEncodingException() - Constructor for exception javax.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with no detail message.
CertificateEncodingException(String) - Constructor for exception javax.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with the specified detail message.
CertificateException - Exception in java.security.cert
This exception indicates one of a variety of certificate problems.
CertificateException() - Constructor for exception java.security.cert.CertificateException
Constructs a certificate exception with no detail message.
CertificateException(String) - Constructor for exception java.security.cert.CertificateException
Constructs a certificate exception with the given detail message.
CertificateException(String, Throwable) - Constructor for exception java.security.cert.CertificateException
Creates a CertificateException with the specified detail message and cause.
CertificateException(Throwable) - Constructor for exception java.security.cert.CertificateException
Creates a CertificateException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateException - Exception in javax.security.cert
This exception indicates one of a variety of certificate problems.
CertificateException() - Constructor for exception javax.security.cert.CertificateException
Constructs a certificate exception with no detail message.
CertificateException(String) - Constructor for exception javax.security.cert.CertificateException
Constructs a certificate exception with the given detail message.
CertificateExpiredException - Exception in java.security.cert
Certificate Expired Exception.
CertificateExpiredException() - Constructor for exception java.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with no detail message.
CertificateExpiredException(String) - Constructor for exception java.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with the specified detail message.
CertificateExpiredException - Exception in javax.security.cert
Certificate Expired Exception.
CertificateExpiredException() - Constructor for exception javax.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with no detail message.
CertificateExpiredException(String) - Constructor for exception javax.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with the specified detail message.
CertificateFactory - Class in java.security.cert
This class defines the functionality of a certificate factory, which is used to generate certificate, certification path (CertPath) and certificate revocation list (CRL) objects from their encodings.
CertificateFactory(CertificateFactorySpi, Provider, String) - Constructor for class java.security.cert.CertificateFactory
Creates a CertificateFactory object of the given type, and encapsulates the given provider implementation (SPI object) in it.
CertificateFactorySpi - Class in java.security.cert
This class defines the Service Provider Interface (SPI) for the CertificateFactory class.
CertificateFactorySpi() - Constructor for class java.security.cert.CertificateFactorySpi
CertificateNotYetValidException - Exception in java.security.cert
Certificate is not yet valid exception.
CertificateNotYetValidException() - Constructor for exception java.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with no detail message.
CertificateNotYetValidException(String) - Constructor for exception java.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with the specified detail message.
CertificateNotYetValidException - Exception in javax.security.cert
Certificate is not yet valid exception.
CertificateNotYetValidException() - Constructor for exception javax.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with no detail message.
CertificateNotYetValidException(String) - Constructor for exception javax.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with the specified detail message.
CertificateParsingException - Exception in java.security.cert
Certificate Parsing Exception.
CertificateParsingException() - Constructor for exception java.security.cert.CertificateParsingException
Constructs a CertificateParsingException with no detail message.
CertificateParsingException(String) - Constructor for exception java.security.cert.CertificateParsingException
Constructs a CertificateParsingException with the specified detail message.
CertificateParsingException(String, Throwable) - Constructor for exception java.security.cert.CertificateParsingException
Creates a CertificateParsingException with the specified detail message and cause.
CertificateParsingException(Throwable) - Constructor for exception java.security.cert.CertificateParsingException
Creates a CertificateParsingException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateParsingException - Exception in javax.security.cert
Certificate Parsing Exception.
CertificateParsingException() - Constructor for exception javax.security.cert.CertificateParsingException
Constructs a CertificateParsingException with no detail message.
CertificateParsingException(String) - Constructor for exception javax.security.cert.CertificateParsingException
Constructs a CertificateParsingException with the specified detail message.
CertificateRevokedException - Exception in java.security.cert
An exception that indicates an X.509 certificate is revoked.
CertificateRevokedException(Date, CRLReason, X500Principal, Map<String, Extension>) - Constructor for exception java.security.cert.CertificateRevokedException
Constructs a CertificateRevokedException with the specified revocation date, reason code, authority name, and map of extensions.
certificates() - Method in class java.security.Identity
Deprecated.
Returns a copy of all the certificates for this identity.
CertPath - Class in java.security.cert
An immutable sequence of certificates (a certification path).
CertPath(String) - Constructor for class java.security.cert.CertPath
Creates a CertPath of the specified type.
CertPath.CertPathRep - Class in java.security.cert
Alternate CertPath class for serialization.
CertPath.CertPathRep(String, byte[]) - Constructor for class java.security.cert.CertPath.CertPathRep
Creates a CertPathRep with the specified type and encoded form of a certification path.
CertPathBuilder - Class in java.security.cert
A class for building certification paths (also known as certificate chains).
CertPathBuilder(CertPathBuilderSpi, Provider, String) - Constructor for class java.security.cert.CertPathBuilder
Creates a CertPathBuilder object of the given algorithm, and encapsulates the given provider implementation (SPI object) in it.
CertPathBuilderException - Exception in java.security.cert
An exception indicating one of a variety of problems encountered when building a certification path with a CertPathBuilder.
CertPathBuilderException() - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with null as its detail message.
CertPathBuilderException(String) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with the given detail message.
CertPathBuilderException(Throwable) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException that wraps the specified throwable.
CertPathBuilderException(String, Throwable) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with the specified detail message and cause.
CertPathBuilderResult - Interface in java.security.cert
A specification of the result of a certification path builder algorithm.
CertPathBuilderSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertPathBuilder class.
CertPathBuilderSpi() - Constructor for class java.security.cert.CertPathBuilderSpi
The default constructor.
CertPathParameters - Interface in java.security.cert
A specification of certification path algorithm parameters.
CertPathTrustManagerParameters - Class in javax.net.ssl
A wrapper for CertPathParameters.
CertPathTrustManagerParameters(CertPathParameters) - Constructor for class javax.net.ssl.CertPathTrustManagerParameters
Construct new CertPathTrustManagerParameters from the specified parameters.
CertPathValidator - Class in java.security.cert
A class for validating certification paths (also known as certificate chains).
CertPathValidator(CertPathValidatorSpi, Provider, String) - Constructor for class java.security.cert.CertPathValidator
Creates a CertPathValidator object of the given algorithm, and encapsulates the given provider implementation (SPI object) in it.
CertPathValidatorException - Exception in java.security.cert
An exception indicating one of a variety of problems encountered when validating a certification path.
CertPathValidatorException() - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with no detail message.
CertPathValidatorException(String) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the given detail message.
CertPathValidatorException(Throwable) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException that wraps the specified throwable.
CertPathValidatorException(String, Throwable) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message and cause.
CertPathValidatorException(String, Throwable, CertPath, int) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message, cause, certification path, and index.
CertPathValidatorException(String, Throwable, CertPath, int, CertPathValidatorException.Reason) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message, cause, certification path, index, and reason.
CertPathValidatorException.BasicReason - Enum in java.security.cert
The BasicReason enumerates the potential reasons that a certification path of any type may be invalid.
CertPathValidatorException.Reason - Interface in java.security.cert
The reason the validation algorithm failed.
CertPathValidatorResult - Interface in java.security.cert
A specification of the result of a certification path validator algorithm.
CertPathValidatorSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertPathValidator class.
CertPathValidatorSpi() - Constructor for class java.security.cert.CertPathValidatorSpi
The default constructor.
CertSelector - Interface in java.security.cert
A selector that defines a set of criteria for selecting Certificates.
CertStore - Class in java.security.cert
A class for retrieving Certificates and CRLs from a repository.
CertStore(CertStoreSpi, Provider, String, CertStoreParameters) - Constructor for class java.security.cert.CertStore
Creates a CertStore object of the given type, and encapsulates the given provider implementation (SPI object) in it.
CertStoreException - Exception in java.security.cert
An exception indicating one of a variety of problems retrieving certificates and CRLs from a CertStore.
CertStoreException() - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with null as its detail message.
CertStoreException(String) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with the given detail message.
CertStoreException(Throwable) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException that wraps the specified throwable.
CertStoreException(String, Throwable) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with the specified detail message and cause.
CertStoreParameters - Interface in java.security.cert
A specification of CertStore parameters.
CertStoreSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertStore class.
CertStoreSpi(CertStoreParameters) - Constructor for class java.security.cert.CertStoreSpi
The sole constructor.
CHAM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cham" Unicode character block.
CHANGE - Static variable in class javax.swing.event.DocumentEvent.EventType
Change type.
change(int, int, AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Changes content.
CHANGED - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the user operation has changed.
ChangedCharSetException - Exception in javax.swing.text
ChangedCharSetException as the name indicates is an exception thrown when the charset is changed.
ChangedCharSetException(String, boolean) - Constructor for exception javax.swing.text.ChangedCharSetException
changedUpdate(DocumentEvent) - Method in interface javax.swing.event.DocumentListener
Gives notification that an attribute or set of attributes changed.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FlowView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text.FlowView.FlowStrategy
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.GlyphView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.BlockView
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.ImageView
Invoked when the Elements attributes have changed.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.InlineView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.LabelView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.ParagraphView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changeEvent - Variable in class javax.swing.AbstractButton
Only one ChangeEvent is needed per button instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.AbstractCellEditor
changeEvent - Variable in class javax.swing.colorchooser.DefaultColorSelectionModel
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.DefaultBoundedRangeModel
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.DefaultButtonModel
Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.DefaultSingleSelectionModel
ChangeEvent - Class in javax.swing.event
ChangeEvent is used to notify interested parties that state has changed in the event source.
ChangeEvent(Object) - Constructor for class javax.swing.event.ChangeEvent
Constructs a ChangeEvent object.
changeEvent - Variable in class javax.swing.JProgressBar
Only one ChangeEvent is needed per instance since the event's only interesting property is the immutable source, which is the progress bar.
changeEvent - Variable in class javax.swing.JSlider
Only one ChangeEvent is needed per slider instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.JTabbedPane
Only one ChangeEvent is needed per TabPane instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.MenuSelectionManager
Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.table.DefaultTableColumnModel
Change event (only one needed)
changeEvent - Variable in class javax.swing.text.DefaultCaret
The change event for the model.
changeEvent - Variable in class javax.swing.text.StyleContext.NamedStyle
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
changeHighlight(Object, int, int) - Method in class javax.swing.text.DefaultHighlighter
Changes a highlight.
changeHighlight(Object, int, int) - Method in interface javax.swing.text.Highlighter
Changes the given highlight to span a different portion of the document.
changeInfo - Variable in class javax.naming.event.NamingEvent
Contains information about the change that generated this event.
changeListener - Variable in class javax.swing.AbstractButton
The button model's changeListener.
ChangeListener - Interface in javax.swing.event
Defines an object which listens for ChangeEvents.
changeListener - Variable in class javax.swing.JProgressBar
Listens for change events sent by the progress bar's model, redispatching them to change-event listeners registered upon this progress bar.
changeListener - Variable in class javax.swing.JSlider
The changeListener (no suffix) is the listener we add to the slider's model.
changeListener - Variable in class javax.swing.JTabbedPane
The changeListener is the listener we add to the model.
changeListener - Variable in class javax.swing.plaf.basic.BasicMenuBarUI
changeListener - Variable in class javax.swing.plaf.basic.BasicMenuUI
changeListener - Variable in class javax.swing.plaf.basic.BasicProgressBarUI
changeListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
changeParameterType(int, Class<?>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with a single different parameter type.
changeReturnType(Class<?>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with a different return type.
changeSelection(int, int, boolean, boolean) - Method in class javax.swing.JTable
Updates the selection models of the table, depending on the state of the two flags: toggle and extend.
changeShape(Dimension, Dimension, Dimension) - Method in class javax.swing.Box.Filler
Change the size requests for this shape.
changeSupport - Variable in class javax.swing.AbstractAction
If any PropertyChangeListeners have been registered, the changeSupport field describes them.
changeSupport - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Used to messaged registered listeners.
changeToParentDirectory() - Method in class javax.swing.JFileChooser
Changes the directory to be set to the parent of the current directory.
changeUpdate() - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Updates the element structure in response to a change in the document.
Channel - Interface in java.nio.channels
A nexus for I/O operations.
channel() - Method in class java.nio.channels.FileLock
Returns the file channel upon whose file this lock was acquired.
channel() - Method in class java.nio.channels.MembershipKey
Returns the channel for which this membership key was created.
channel() - Method in class java.nio.channels.SelectionKey
Returns the channel for which this key was created.
channel - Variable in class javax.sound.midi.VoiceStatus
The MIDI channel on which this voice is playing.
CHANNEL_PRESSURE - Static variable in class javax.sound.midi.ShortMessage
Command value for Channel Pressure (Aftertouch) message (0xD0, or 208)
ChannelBinding - Class in org.ietf.jgss
This class encapsulates the concept of caller-provided channel binding information.
ChannelBinding(InetAddress, InetAddress, byte[]) - Constructor for class org.ietf.jgss.ChannelBinding
Create a ChannelBinding object with user supplied address information and data.
ChannelBinding(byte[]) - Constructor for class org.ietf.jgss.ChannelBinding
Creates a ChannelBinding object without any addressing information.
Channels - Class in java.nio.channels
Utility methods for channels and streams.
channels - Variable in class javax.sound.sampled.AudioFormat
The number of audio channels in this format (1 for mono, 2 for stereo).
CHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type CHAR.
CHAR_REPLACEMENT - Static variable in class java.awt.font.TextAttribute
Attribute key for a user-defined glyph to display in lieu of the font's standard glyph for a character.
CHAR_UNDEFINED - Static variable in class java.awt.event.KeyEvent
KEY_PRESSED and KEY_RELEASED events which do not map to a valid Unicode character use this for the keyChar value.
Character - Class in java.lang
The Character class wraps a value of the primitive type char in an object.
Character(char) - Constructor for class java.lang.Character
Constructs a newly allocated Character object that represents the specified char value.
CHARACTER - Static variable in interface javax.accessibility.AccessibleText
Constant used to indicate that the part of the text that should be retrieved is a character.
CHARACTER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Character.
Character.Subset - Class in java.lang
Instances of this class represent particular subsets of the Unicode character set.
Character.Subset(String) - Constructor for class java.lang.Character.Subset
Constructs a new Subset instance.
Character.UnicodeBlock - Class in java.lang
A family of character subsets representing the character blocks in the Unicode specification.
Character.UnicodeScript - Enum in java.lang
A family of character subsets representing the character scripts defined in the Unicode Standard Annex #24: Script Names.
CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap.SOAPMessage
Specifies the character type encoding for the SOAP Message.
CharacterCodingException - Exception in java.nio.charset
Checked exception thrown when a character encoding or decoding error occurs.
CharacterCodingException() - Constructor for exception java.nio.charset.CharacterCodingException
Constructs an instance of this class.
CharacterData - Interface in org.w3c.dom
The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
CharacterIterator - Interface in java.text
This interface defines a protocol for bidirectional iteration over text.
Characters - Interface in javax.xml.stream.events
This describes the interface to Characters events.
CHARACTERS - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is characters
characters(char[], int, int) - Method in interface org.xml.sax.ContentHandler
Receive notification of character data.
characters(char[], int, int) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of character data.
characters(char[], int, int) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of character data inside an element.
characters(char[], int, int) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of character data inside an element.
characters(char[], int, int) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
characters(char[], int, int) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a character data event.
characters(char[], int, int) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 characters event.
CharArrayReader - Class in java.io
This class implements a character buffer that can be used as a character-input stream.
CharArrayReader(char[]) - Constructor for class java.io.CharArrayReader
Creates a CharArrayReader from the specified array of chars.
CharArrayReader(char[], int, int) - Constructor for class java.io.CharArrayReader
Creates a CharArrayReader from the specified array of chars.
CharArrayWriter - Class in java.io
This class implements a character buffer that can be used as an Writer.
CharArrayWriter() - Constructor for class java.io.CharArrayWriter
Creates a new CharArrayWriter.
CharArrayWriter(int) - Constructor for class java.io.CharArrayWriter
Creates a new CharArrayWriter with the specified initial size.
charAt(int) - Method in interface java.lang.CharSequence
Returns the char value at the specified index.
charAt(int) - Method in class java.lang.String
Returns the char value at the specified index.
charAt(int) - Method in class java.lang.StringBuffer
charAt(int) - Method in class java.nio.CharBuffer
Reads the character at the given index relative to the current position.
charAt(int) - Method in class javax.swing.text.Segment
Returns the char value at the specified index.
charAttr - Variable in class javax.swing.text.html.HTMLDocument.HTMLReader
CharBuffer - Class in java.nio
A char buffer.
CharConversionException - Exception in java.io
Base class for character conversion exceptions.
CharConversionException() - Constructor for exception java.io.CharConversionException
This provides no detailed message.
CharConversionException(String) - Constructor for exception java.io.CharConversionException
This provides a detailed message.
charCount(int) - Static method in class java.lang.Character
Determines the number of char values needed to represent the specified character (Unicode code point).
CharHolder - Class in org.omg.CORBA
The Holder for Char.
CharHolder() - Constructor for class org.omg.CORBA.CharHolder
Constructs a new CharHolder object with its value field initialized to 0.
CharHolder(char) - Constructor for class org.omg.CORBA.CharHolder
Constructs a new CharHolder object for the given char.
CharSeqHelper - Class in org.omg.CORBA
The Helper for CharSeq.
CharSeqHelper() - Constructor for class org.omg.CORBA.CharSeqHelper
CharSeqHolder - Class in org.omg.CORBA
The Holder for CharSeq.
CharSeqHolder() - Constructor for class org.omg.CORBA.CharSeqHolder
CharSeqHolder(char[]) - Constructor for class org.omg.CORBA.CharSeqHolder
CharSequence - Interface in java.lang
A CharSequence is a readable sequence of char values.
Charset - Class in java.nio.charset
A named mapping between sequences of sixteen-bit Unicode code units and sequences of bytes.
Charset(String, String[]) - Constructor for class java.nio.charset.Charset
Initializes a new charset with the given canonical name and alias set.
charset() - Method in class java.nio.charset.CharsetDecoder
Returns the charset that created this decoder.
charset() - Method in class java.nio.charset.CharsetEncoder
Returns the charset that created this encoder.
CharsetDecoder - Class in java.nio.charset
An engine that can transform a sequence of bytes in a specific charset into a sequence of sixteen-bit Unicode characters.
CharsetDecoder(Charset, float, float) - Constructor for class java.nio.charset.CharsetDecoder
Initializes a new decoder.
CharsetEncoder - Class in java.nio.charset
An engine that can transform a sequence of sixteen-bit Unicode characters into a sequence of bytes in a specific charset.
CharsetEncoder(Charset, float, float, byte[]) - Constructor for class java.nio.charset.CharsetEncoder
Initializes a new encoder.
CharsetEncoder(Charset, float, float) - Constructor for class java.nio.charset.CharsetEncoder
Initializes a new encoder.
charsetForName(String) - Method in class java.nio.charset.spi.CharsetProvider
Retrieves a charset for the given charset name.
CharsetProvider - Class in java.nio.charset.spi
Charset service-provider class.
CharsetProvider() - Constructor for class java.nio.charset.spi.CharsetProvider
Initializes a new charset provider.
charsets() - Method in class java.nio.charset.spi.CharsetProvider
Creates an iterator that iterates over the charsets supported by this provider.
charStream - Variable in class javax.sql.rowset.BaseRowSet
The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.
charsWidth(char[], int, int) - Method in class java.awt.FontMetrics
Returns the total advance width for showing the specified array of characters in this Font.
charValue() - Method in class java.lang.Character
Returns the value of this Character object.
charWidth(int) - Method in class java.awt.FontMetrics
Returns the advance width of the specified character in this Font.
charWidth(char) - Method in class java.awt.FontMetrics
Returns the advance width of the specified character in this Font.
check(Certificate, Collection<String>) - Method in class java.security.cert.PKIXCertPathChecker
Performs the check(s) on the specified certificate using its internal state and removes any critical extensions that it processes from the specified collection of OID strings that represent the unresolved critical extensions.
check(String, URL, String, MLetContent) - Method in class javax.management.loading.MLet
This method is to be overridden when extending this service to support caching and versioning.
CHECK_BOX - Static variable in class javax.accessibility.AccessibleRole
A choice that can be checked or unchecked and provides a separate indicator for the current state.
CHECK_BOX - Static variable in class javax.swing.plaf.synth.Region
CheckBox region.
CHECK_BOX_MENU_ITEM - Static variable in class javax.swing.plaf.synth.Region
CheckBoxMenuItem region.
checkAccept(String, int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not permitted to accept a socket connection from the specified host and port number.
checkAccess(Thread) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to modify the thread argument.
checkAccess(ThreadGroup) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to modify the thread group argument.
checkAccess() - Method in class java.lang.Thread
Determines if the currently running thread has permission to modify this thread.
checkAccess() - Method in class java.lang.ThreadGroup
Determines if the currently running thread has permission to modify this thread group.
checkAccess(Path, AccessMode...) - Method in class java.nio.file.spi.FileSystemProvider
Checks the existence, and optionally the accessibility, of a file.
checkAccess() - Method in class java.util.logging.LogManager
Check that the current context is trusted to modify the logging configuration.
checkAll() - Method in class java.awt.MediaTracker
Checks to see if all images being tracked by this media tracker have finished loading.
checkAll(boolean) - Method in class java.awt.MediaTracker
Checks to see if all images being tracked by this media tracker have finished loading.
checkAwtEventQueueAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the AWT event queue.
Checkbox - Class in java.awt
A check box is a graphical component that can be in either an "on" (true) or "off" (false) state.
Checkbox() - Constructor for class java.awt.Checkbox
Creates a check box with an empty string for its label.
Checkbox(String) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label.
Checkbox(String, boolean) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label and sets the specified state.
Checkbox(String, boolean, CheckboxGroup) - Constructor for class java.awt.Checkbox
Constructs a Checkbox with the specified label, set to the specified state, and in the specified check box group.
Checkbox(String, CheckboxGroup, boolean) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label, in the specified check box group, and set to the specified state.
Checkbox.AccessibleAWTCheckbox - Class in java.awt
This class implements accessibility support for the Checkbox class.
Checkbox.AccessibleAWTCheckbox() - Constructor for class java.awt.Checkbox.AccessibleAWTCheckbox
CheckboxGroup - Class in java.awt
The CheckboxGroup class is used to group together a set of Checkbox buttons.
CheckboxGroup() - Constructor for class java.awt.CheckboxGroup
Creates a new instance of CheckboxGroup.
CheckboxMenuItem - Class in java.awt
This class represents a check box that can be included in a menu.
CheckboxMenuItem() - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with an empty label.
CheckboxMenuItem(String) - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with the specified label.
CheckboxMenuItem(String, boolean) - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with the specified label and state.
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem - Class in java.awt
Inner class of CheckboxMenuItem used to provide default support for accessibility.
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem() - Constructor for class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
checkClientTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkClientTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkClientTrusted(X509Certificate[], String) - Method in interface javax.net.ssl.X509TrustManager
Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for client SSL authentication based on the authentication type.
checkClosed() - Method in class javax.imageio.stream.ImageInputStreamImpl
Throws an IOException if the stream has been closed.
checkConnect(String, int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to open a socket connection to the specified host and port number.
checkConnect(String, int, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is not allowed to open a socket connection to the specified host and port number.
checkCreateClassLoader() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to create a new class loader.
checkDelete(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to delete the specified file.
CHECKED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is currently checked.
CHECKED - Static variable in class javax.swing.text.html.HTML.Attribute
checkedCollection(Collection<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified collection.
CheckedInputStream - Class in java.util.zip
An input stream that also maintains a checksum of the data being read.
CheckedInputStream(InputStream, Checksum) - Constructor for class java.util.zip.CheckedInputStream
Creates an input stream using the specified Checksum.
checkedList(List<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified list.
checkedMap(Map<K, V>, Class<K>, Class<V>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified map.
CheckedOutputStream - Class in java.util.zip
An output stream that also maintains a checksum of the data being written.
CheckedOutputStream(OutputStream, Checksum) - Constructor for class java.util.zip.CheckedOutputStream
Creates an output stream with the specified Checksum.
checkedSet(Set<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified set.
checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified sorted map.
checkedSortedSet(SortedSet<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified sorted set.
checkError() - Method in class java.io.PrintStream
Flushes the stream and checks its error state.
checkError() - Method in class java.io.PrintWriter
Flushes the stream if it's not closed and checks its error state.
checkExec(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to create a subprocess.
checkExit(int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to cause the Java Virtual Machine to halt with the specified status code.
checkForClickInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.
checkGuard(Object) - Method in interface java.security.Guard
Determines whether or not to allow access to the guarded object object.
checkGuard(Object) - Method in class java.security.Permission
Implements the guard interface for a permission.
checkHorizontalKey(int, String) - Method in class javax.swing.AbstractButton
Verify that the key argument is a legal value for the horizontalAlignment and horizontalTextPosition properties.
checkHorizontalKey(int, String) - Method in class javax.swing.JLabel
Verify that key is a legal value for the horizontalAlignment properties.
checkIcon - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
checkID(int) - Method in class java.awt.MediaTracker
Checks to see if all images tracked by this media tracker that are tagged with the specified identifier have finished loading.
checkID(int, boolean) - Method in class java.awt.MediaTracker
Checks to see if all images tracked by this media tracker that are tagged with the specified identifier have finished loading.
checkImage(Image, ImageObserver) - Method in class java.awt.Component
Returns the status of the construction of a screen representation of the specified image.
checkImage(Image, int, int, ImageObserver) - Method in class java.awt.Component
Returns the status of the construction of a screen representation of the specified image.
checkImage(Image, int, int, ImageObserver) - Method in class java.awt.Toolkit
Indicates the construction status of a specified image that is being prepared for display.
checkLink(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to dynamic link the library code specified by the string argument file.
checkListen(int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to wait for a connection request on the specified local port number.
checkMaxDegree(int) - Method in class javax.management.relation.RoleInfo
Returns true if the value parameter is lower than or equal to the expected maximum degree, false otherwise.
checkMemberAccess(Class<?>, int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access members.
checkMinDegree(int) - Method in class javax.management.relation.RoleInfo
Returns true if the value parameter is greater than or equal to the expected minimum degree, false otherwise.
checkMulticast(InetAddress) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to use (join/leave/send/receive) IP multicast.
checkMulticast(InetAddress, byte) - Method in class java.lang.SecurityManager
Deprecated.
Use #checkPermission(java.security.Permission) instead
checkOpacity(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonListener
checkPackageAccess(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the package specified by the argument.
checkPackageDefinition(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to define classes in the package specified by the argument.
checkPainter() - Method in class javax.swing.text.GlyphView
Check to see that a glyph painter exists.
checkPermission(Permission) - Method in class java.lang.SecurityManager
Throws a SecurityException if the requested access, specified by the given permission, is not permitted based on the security policy currently in effect.
checkPermission(Permission, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is denied access to the resource specified by the given permission.
checkPermission(Permission) - Method in class java.security.AccessControlContext
Determines whether the access request indicated by the specified permission should be allowed or denied, based on the security policy currently in effect, and the context in this object.
checkPermission(Permission) - Static method in class java.security.AccessController
Determines whether the access request indicated by the specified permission should be allowed or denied, based on the current AccessControlContext and security policy.
checkPermission(Principal, Permission) - Method in interface java.security.acl.Acl
Checks whether or not the specified principal has the specified permission.
checkPermission(Permission) - Method in interface java.security.acl.AclEntry
Checks if the specified permission is part of the permission set in this entry.
checkPrintJobAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to initiate a print job request.
checkPropertiesAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access or modify the system properties.
checkPropertyAccess(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the system property with the specified key name.
checkRead(FileDescriptor) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to read from the specified file descriptor.
checkRead(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to read the file specified by the string argument.
checkRead(String, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is not allowed to read the file specified by the string argument.
checkReadParamBandSettings(ImageReadParam, int, int) - Static method in class javax.imageio.ImageReader
A utility method that may be used by readers to test the validity of the source and destination band settings of an ImageReadParam.
checkRoleReading(String, String) - Method in class javax.management.relation.RelationService
Checks if given Role can be read in a relation of the given type.
checkRoleReading(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be read in a relation of the given type.
checkRoleWriting(Role, String, Boolean) - Method in class javax.management.relation.RelationService
Checks if given Role can be set in a relation of given type.
checkRoleWriting(Role, String, Boolean) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be set in a relation of given type.
checkSecurityAccess(String) - Method in class java.lang.SecurityManager
Determines whether the permission with the specified permission target name should be granted or denied.
checkServerTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkServerTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkServerTrusted(X509Certificate[], String) - Method in interface javax.net.ssl.X509TrustManager
Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for server SSL authentication based on the authentication type.
checkSetFactory() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to set the socket factory used by ServerSocket or Socket, or the stream handler factory used by URL.
Checksum - Interface in java.util.zip
An interface representing a data checksum.
checkSystemClipboardAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the system clipboard.
checkTopLevelWindow(Object) - Method in class java.lang.SecurityManager
Returns false if the calling thread is not trusted to bring up the top-level window indicated by the window argument.
checkValidity() - Method in class java.security.cert.X509Certificate
Checks that the certificate is currently valid.
checkValidity(Date) - Method in class java.security.cert.X509Certificate
Checks that the given date is within the certificate's validity period.
checkValidity() - Method in class javax.security.cert.X509Certificate
Checks that the certificate is currently valid.
checkValidity(Date) - Method in class javax.security.cert.X509Certificate
Checks that the specified date is within the certificate's validity period.
checkVerticalKey(int, String) - Method in class javax.swing.AbstractButton
Verify that the key argument is a legal value for the vertical properties.
checkVerticalKey(int, String) - Method in class javax.swing.JLabel
Verify that key is a legal value for the verticalAlignment or verticalTextPosition properties.
checkWrite(FileDescriptor) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to write to the specified file descriptor.
checkWrite(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to write to the file specified by the string argument.
CHEROKEE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cherokee" Unicode character block.
CHILD_NODE_OF - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object is a child node of one or more objects.
CHILD_NODE_OF_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the CHILD_NODE_OF relation between two or more objects has changed.
CHILD_POLICY_ALL - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have a single instance of each of its legal child elements, in order.
CHILD_POLICY_CHOICE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or one children, selected from among its legal child elements.
CHILD_POLICY_EMPTY - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element may not have any children.
CHILD_POLICY_MAX - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
The largest valid CHILD_POLICY_* constant, to be used for range checks.
CHILD_POLICY_REPEAT - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or more instances of its unique legal child element.
CHILD_POLICY_SEQUENCE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have a sequence of instances of any of its legal child elements.
CHILD_POLICY_SOME - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or one instance of each of its legal child elements, in order.
childAdded(NodeChangeEvent) - Method in interface java.util.prefs.NodeChangeListener
This method gets called when a child node is added.
childAlloc - Variable in class javax.swing.text.AsyncBoxView.ChildLocator
A shape to use for the child allocation to avoid creating a lot of garbage.
childAllocation(int, Rectangle) - Method in class javax.swing.text.BoxView
Allocates a region for a child view.
childAllocation(int, Rectangle) - Method in class javax.swing.text.CompositeView
Returns the allocation for a given child.
childChanged(AsyncBoxView.ChildState) - Method in class javax.swing.text.AsyncBoxView.ChildLocator
Notification that a child changed.
childDeserializedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
Called by readObject with the newly deserialized child and BCSChild.
childIndices - Variable in class javax.swing.event.TreeModelEvent
Indices identifying the position of where the children were.
childJustAddedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may override this method to simply extend add() semantics after the child has been added and before the event notification has occurred.
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from superclass child removal operations after a child has been successfully removed.
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may override this method to simply extend remove() semantics after the child has been removed and before the event notification has occurred.
childRemoved(NodeChangeEvent) - Method in interface java.util.prefs.NodeChangeListener
This method gets called when a child node is removed.
children - Variable in class java.beans.beancontext.BeanContextMembershipEvent
The list of children affected by this event notification.
children - Variable in class java.beans.beancontext.BeanContextSupport
all accesses to the protected HashMap children field shall be synchronized on that object.
children - Variable in class javax.swing.event.TreeModelEvent
Children that have been removed.
children() - Method in class javax.swing.JTree.DynamicUtilTreeNode
Subclassed to load the children, if necessary.
children() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Returns the children of the receiver as an Enumeration.
children() - Method in class javax.swing.text.AbstractDocument.BranchElement
Returns the children of the receiver as an Enumeration.
children() - Method in class javax.swing.text.AbstractDocument.LeafElement
Returns the children of the receiver as an Enumeration.
children - Variable in class javax.swing.tree.DefaultMutableTreeNode
array of children, may be null if this node has no children
children() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns a forward-order enumeration of this node's children.
children() - Method in interface javax.swing.tree.TreeNode
Returns the children of the receiver as an Enumeration.
childrenAdded(BeanContextMembershipEvent) - Method in interface java.beans.beancontext.BeanContextMembershipListener
Called when a child or list of children is added to a BeanContext that this listener is registered with.
childrenNames() - Method in class java.util.prefs.AbstractPreferences
Implements the children method as per the specification in Preferences.childrenNames().
childrenNames() - Method in class java.util.prefs.Preferences
Returns the names of the children of this preference node, relative to this node.
childrenNamesSpi() - Method in class java.util.prefs.AbstractPreferences
Returns the names of the children of this preference node.
childrenRemoved(BeanContextMembershipEvent) - Method in interface java.beans.beancontext.BeanContextMembershipListener
Called when a child or list of children is removed from a BeanContext that this listener is registered with.
childSpi(String) - Method in class java.util.prefs.AbstractPreferences
Returns the named child of this preference node, creating it if it does not already exist.
childValue(T) - Method in class java.lang.InheritableThreadLocal
Computes the child's initial value for this inheritable thread-local variable as a function of the parent's value at the time the child thread is created.
childValue - Variable in class javax.swing.JTree.DynamicUtilTreeNode
Value to create children with.
CHINA - Static variable in class java.util.Locale
Useful constant for country.
CHINESE - Static variable in class java.util.Locale
Useful constant for language.
Choice - Class in java.awt
The Choice class presents a pop-up menu of choices.
Choice() - Constructor for class java.awt.Choice
Creates a new choice menu.
Choice.AccessibleAWTChoice - Class in java.awt
This class implements accessibility support for the Choice class.
Choice.AccessibleAWTChoice() - Constructor for class java.awt.Choice.AccessibleAWTChoice
ChoiceCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).
ChoiceCallback(String, String[], int, boolean) - Constructor for class javax.security.auth.callback.ChoiceCallback
Construct a ChoiceCallback with a prompt, a list of choices, a default choice, and a boolean specifying whether or not multiple selections from the list of choices are allowed.
ChoiceFormat - Class in java.text
A ChoiceFormat allows you to attach a format to a range of numbers.
ChoiceFormat(String) - Constructor for class java.text.ChoiceFormat
Constructs with limits and corresponding formats based on the pattern.
ChoiceFormat(double[], String[]) - Constructor for class java.text.ChoiceFormat
Constructs with the limits and the corresponding formats.
choices - Variable in class java.sql.DriverPropertyInfo
An array of possible values if the value for the field DriverPropertyInfo.value may be selected from a particular set of values; otherwise null.
CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the list of predefined file filters the user can choose from.
chooseClientAlias(String[], Principal[], Socket) - Method in interface javax.net.ssl.X509KeyManager
Choose an alias to authenticate the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooseEngineClientAlias(String[], Principal[], SSLEngine) - Method in class javax.net.ssl.X509ExtendedKeyManager
Choose an alias to authenticate the client side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooseEngineServerAlias(String, Principal[], SSLEngine) - Method in class javax.net.ssl.X509ExtendedKeyManager
Choose an alias to authenticate the server side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooser - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
JColorChooser this BasicColorChooserUI is installed on.
CHOOSER_PANELS_PROPERTY - Static variable in class javax.swing.JColorChooser
The chooserPanel array property name.
chooseServerAlias(String, Principal[], Socket) - Method in interface javax.net.ssl.X509KeyManager
Choose an alias to authenticate the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
CHORD - Static variable in class java.awt.geom.Arc2D
The closure type for an arc closed by drawing a straight line segment from the start of the arc segment to the end of the arc segment.
CHOU_1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #1 envelope size, 142 mm by 332 mm.
CHOU_2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #2 envelope size, 119 mm by 277 mm.
CHOU_3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #3 envelope size, 120 mm by 235 mm.
CHOU_30 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #30 envelope size, 92 mm by 235 mm.
CHOU_4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #4 envelope size, 90 mm by 205 mm.
CHOU_40 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #40 envelope size, 90 mm by 225 mm.
Chromaticity - Class in javax.print.attribute.standard
Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
Chromaticity(int) - Constructor for class javax.print.attribute.standard.Chromaticity
Construct a new chromaticity enumeration value with the given integer value.
chunkLength - Variable in class java.net.HttpURLConnection
The chunk-length when using chunked encoding streaming mode for output.
Cipher - Class in javax.crypto
This class provides the functionality of a cryptographic cipher for encryption and decryption.
Cipher(CipherSpi, Provider, String) - Constructor for class javax.crypto.Cipher
Creates a Cipher object.
CipherInputStream - Class in javax.crypto
A CipherInputStream is composed of an InputStream and a Cipher so that read() methods return data that are read in from the underlying InputStream but have been additionally processed by the Cipher.
CipherInputStream(InputStream, Cipher) - Constructor for class javax.crypto.CipherInputStream
Constructs a CipherInputStream from an InputStream and a Cipher.
CipherInputStream(InputStream) - Constructor for class javax.crypto.CipherInputStream
Constructs a CipherInputStream from an InputStream without specifying a Cipher.
CipherOutputStream - Class in javax.crypto
A CipherOutputStream is composed of an OutputStream and a Cipher so that write() methods first process the data before writing them out to the underlying OutputStream.
CipherOutputStream(OutputStream, Cipher) - Constructor for class javax.crypto.CipherOutputStream
Constructs a CipherOutputStream from an OutputStream and a Cipher.
CipherOutputStream(OutputStream) - Constructor for class javax.crypto.CipherOutputStream
Constructs a CipherOutputStream from an OutputStream without specifying a Cipher.
CipherSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the Cipher class.
CipherSpi() - Constructor for class javax.crypto.CipherSpi
CITE - Static variable in class javax.swing.text.html.HTML.Tag
CJK_COMPATIBILITY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility" Unicode character block.
CJK_COMPATIBILITY_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Forms" Unicode character block.
CJK_COMPATIBILITY_IDEOGRAPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Ideographs" Unicode character block.
CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Ideographs Supplement" Unicode character block.
CJK_RADICALS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Radicals Supplement" Unicode character block.
CJK_STROKES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Strokes" Unicode character block.
CJK_SYMBOLS_AND_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Symbols and Punctuation" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension A" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension B" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension C" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension D" Unicode character block.
类<T> - Class in java.lang
Instances of the class 类 represent classes and interfaces in a running Java application.
类 - Static variable in class javax.swing.text.html.HTML.Attribute
CLASS_ABSTRACT - Static variable in class java.awt.color.ICC_Profile
Profile class is abstract.
CLASS_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a class attribute name, indicates the format of that attribute, using the layout language specified in the JSR 200 specification.
CLASS_COLORSPACECONVERSION - Static variable in class java.awt.color.ICC_Profile
Profile class is color space conversion.
CLASS_DEVICELINK - Static variable in class java.awt.color.ICC_Profile
Profile class is device link.
CLASS_DISPLAY - Static variable in class java.awt.color.ICC_Profile
Profile class is display.
CLASS_INPUT - Static variable in class java.awt.color.ICC_Profile
Profile class is input.
CLASS_LOADING_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the ClassLoadingMXBean.
CLASS_NAMEDCOLOR - Static variable in class java.awt.color.ICC_Profile
Profile class is named color.
CLASS_OUTPUT - Static variable in class java.awt.color.ICC_Profile
Profile class is output.
CLASS_PATH - Static variable in class java.util.jar.Attributes.Name
Name object for Class-Path manifest attribute.
classattr() - Static method in class javax.management.Query
Returns a new class attribute expression which can be used in any Query call that expects a ValueExp.
ClassCastException - Exception in java.lang
Thrown to indicate that the code has attempted to cast an object to a subclass of which it is not an instance.
ClassCastException() - Constructor for exception java.lang.ClassCastException
Constructs a ClassCastException with no detail message.
ClassCastException(String) - Constructor for exception java.lang.ClassCastException
Constructs a ClassCastException with the specified detail message.
ClassCircularityError - Error in java.lang
Thrown when the Java Virtual Machine detects a circularity in the superclass hierarchy of a class being loaded.
ClassCircularityError() - Constructor for error java.lang.ClassCircularityError
Constructs a ClassCircularityError with no detail message.
ClassCircularityError(String) - Constructor for error java.lang.ClassCircularityError
Constructs a ClassCircularityError with the specified detail message.
ClassDefinition - Class in java.lang.instrument
This class serves as a parameter block to the Instrumentation.redefineClasses method.
ClassDefinition(Class<?>, byte[]) - Constructor for class java.lang.instrument.ClassDefinition
Creates a new ClassDefinition binding using the supplied class and class file bytes.
classDepth(String) - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
ClassDesc - Class in javax.rmi.CORBA
This class is used to marshal java.lang.Class objects over IIOP.
ClassDesc() - Constructor for class javax.rmi.CORBA.ClassDesc
classEquals(Class, Class) - Static method in class java.beans.beancontext.BeanContextSupport
Tests to see if two class objects, or their names are equal.
classFactory - Variable in class javax.naming.Reference
Contains the name of the factory class for creating an instance of the object to which this Reference refers.
classFactoryLocation - Variable in class javax.naming.Reference
Contains the location of the factory class.
ClassFileTransformer - Interface in java.lang.instrument
An agent provides an implementation of this interface in order to transform class files.
ClassFormatError - Error in java.lang
Thrown when the Java Virtual Machine attempts to read a class file and determines that the file is malformed or otherwise cannot be interpreted as a class file.
ClassFormatError() - Constructor for error java.lang.ClassFormatError
Constructs a ClassFormatError with no detail message.
ClassFormatError(String) - Constructor for error java.lang.ClassFormatError
Constructs a ClassFormatError with the specified detail message.
CLASSID - Static variable in class javax.swing.text.html.HTML.Attribute
ClassLoader - Class in java.lang
A class loader is an object that is responsible for loading classes.
ClassLoader(ClassLoader) - Constructor for class java.lang.ClassLoader
Creates a new class loader using the specified parent class loader for delegation.
ClassLoader() - Constructor for class java.lang.ClassLoader
Creates a new class loader using the ClassLoader returned by the method getSystemClassLoader() as the parent class loader.
classLoaderDepth() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
ClassLoaderRepository - Interface in javax.management.loading
Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
ClassLoadingMXBean - Interface in java.lang.management
The management interface for the class loading system of the Java virtual machine.
classModifiers() - Static method in class java.lang.reflect.修饰符
Return an int value OR-ing together the source language modifiers that can be applied to a class.
classname - Variable in exception java.io.InvalidClassException
Name of the invalid class.
className - Variable in class javax.naming.Reference
Contains the fully-qualified name of the class of the object to which this Reference refers.
ClassNotFoundException - Exception in java.lang
Thrown when an application tries to load in a class through its string name using: The forName method in class 类.
ClassNotFoundException() - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with no detail message.
ClassNotFoundException(String) - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with the specified detail message.
ClassNotFoundException(String, Throwable) - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with the specified detail message and optional exception that was raised while loading the class.
ClassValue<T> - Class in java.lang
Lazily associate a computed value with (potentially) every type.
ClassValue() - Constructor for class java.lang.ClassValue
clean(ObjID[], long, VMID, boolean) - Method in interface java.rmi.dgc.DGC
The clean call removes the 'vmid' from the reference list of each remote object indicated in 'id's.
CLEAR - Static variable in class java.awt.AlphaComposite
Both the color and the alpha of the destination are cleared (Porter-Duff Clear rule).
Clear - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque CLEAR rule with an alpha of 1.0f.
clear() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by removeAll().
clear() - Method in class java.awt.RenderingHints
Clears this RenderingHints object of all key/value pairs.
clear() - Method in class java.beans.beancontext.BeanContextSupport
clear the children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
clear() - Method in class java.lang.ref.Reference
Clears this reference object.
clear() - Method in class java.nio.Buffer
Clears this buffer.
clear() - Method in class java.security.Provider
Clears this provider so that it no longer contains the properties used to look up facilities implemented by the provider.
clear() - Method in class java.util.AbstractCollection
Removes all of the elements from this collection (optional operation).
clear() - Method in class java.util.AbstractList
Removes all of the elements from this list (optional operation).
clear() - Method in class java.util.AbstractMap
Removes all of the mappings from this map (optional operation).
clear() - Method in class java.util.AbstractQueue
Removes all of the elements from this queue.
clear() - Method in class java.util.ArrayDeque
Removes all of the elements from this deque.
clear() - Method in class java.util.ArrayList
Removes all of the elements from this list.
clear(int) - Method in class java.util.BitSet
Sets the bit specified by the index to false.
clear(int, int) - Method in class java.util.BitSet
Sets the bits from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to false.
clear() - Method in class java.util.BitSet
Sets all of the bits in this BitSet to false.
clear() - Method in class java.util.Calendar
Sets all the calendar field values and the time value (millisecond offset from the Epoch) of this Calendar undefined.
clear(int) - Method in class java.util.Calendar
Sets the given calendar field value and the time value (millisecond offset from the Epoch) of this Calendar undefined.
clear() - Method in interface java.util.Collection
Removes all of the elements from this collection (optional operation).
clear() - Method in class java.util.concurrent.ArrayBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.ConcurrentHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Removes all of the elements from this deque.
clear() - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes all of the mappings from this map.
clear() - Method in class java.util.concurrent.ConcurrentSkipListSet
Removes all of the elements from this set.
clear() - Method in class java.util.concurrent.CopyOnWriteArrayList
Removes all of the elements from this list.
clear() - Method in class java.util.concurrent.CopyOnWriteArraySet
Removes all of the elements from this set.
clear() - Method in class java.util.concurrent.DelayQueue
Atomically removes all of the elements from this delay queue.
clear() - Method in class java.util.concurrent.LinkedBlockingDeque
Atomically removes all of the elements from this deque.
clear() - Method in class java.util.concurrent.LinkedBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.PriorityBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.SynchronousQueue
Does nothing.
clear() - Method in class java.util.EnumMap
Removes all mappings from this map.
clear() - Method in class java.util.HashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.HashSet
Removes all of the elements from this set.
clear() - Method in class java.util.Hashtable
Clears this hashtable so that it contains no keys.
clear() - Method in class java.util.IdentityHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.jar.Attributes
Removes all attributes from this Map.
clear() - Method in class java.util.jar.Manifest
Clears the main Attributes as well as the entries in this Manifest.
clear() - Method in class java.util.LinkedHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.LinkedList
Removes all of the elements from this list.
clear() - Method in interface java.util.List
Removes all of the elements from this list (optional operation).
clear() - Method in class java.util.Locale.Builder
Resets the builder to its initial, empty state.
clear() - Method in interface java.util.Map
Removes all of the mappings from this map (optional operation).
clear() - Method in class java.util.prefs.AbstractPreferences
Implements the clear method as per the specification in Preferences.clear().
clear() - Method in class java.util.prefs.Preferences
Removes all of the preferences (key-value associations) in this preference node.
clear() - Method in class java.util.PriorityQueue
Removes all of the elements from this priority queue.
clear() - Method in interface java.util.Set
Removes all of the elements from this set (optional operation).
clear() - Method in class java.util.TreeMap
Removes all of the mappings from this map.
clear() - Method in class java.util.TreeSet
Removes all of the elements from this set.
clear() - Method in class java.util.Vector
Removes all of the elements from this Vector.
clear() - Method in class java.util.WeakHashMap
Removes all of the mappings from this map.
clear() - Method in class javax.accessibility.AccessibleRelationSet
Removes all the relations from the current relation set.
clear() - Method in class javax.accessibility.AccessibleStateSet
Removes all the states from the current state set.
clear() - Method in interface javax.management.openmbean.TabularData
Removes all CompositeData values (ie rows) from this TabularData instance.
clear() - Method in class javax.management.openmbean.TabularDataSupport
Removes all rows from this TabularDataSupport instance.
clear() - Method in interface javax.naming.directory.Attribute
Removes all values from this attribute.
clear() - Method in class javax.naming.directory.BasicAttribute
clear() - Method in class javax.naming.Reference
Deletes all addresses from this reference.
clear() - Method in interface javax.print.attribute.AttributeSet
Removes all attributes from this attribute set.
clear() - Method in class javax.print.attribute.HashAttributeSet
Removes all attributes from this attribute set.
clear() - Method in class javax.script.SimpleBindings
Removes all of the mappings from this map (optional operation).
clear() - Method in class javax.swing.ActionMap
Removes all the mappings from this ActionMap.
clear() - Method in class javax.swing.ComponentInputMap
Removes all the mappings from this object.
clear() - Method in class javax.swing.DefaultListModel
Removes all of the elements from this list.
clear() - Method in class javax.swing.InputMap
Removes all the mappings from this InputMap.
CLEAR - Static variable in class javax.swing.text.html.CSS.Attribute
CLEAR - Static variable in class javax.swing.text.html.HTML.Attribute
clear() - Method in class javax.xml.datatype.XMLGregorianCalendar
Unset all fields to undefined.
clear() - Method in class org.omg.CORBA.Environment
Clears this Environment object of its exception.
clear() - Method in class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Clear the attribute list.
clear() - Method in class org.xml.sax.helpers.AttributesImpl
Clear the attribute list for reuse.
clearAbortRequest() - Method in class javax.imageio.ImageReader
Clears any previous abort request.
clearAbortRequest() - Method in class javax.imageio.ImageWriter
Clears any previous abort request.
clearAccessibleSelection() - Method in class java.awt.List.AccessibleAWTList
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in interface javax.accessibility.AccessibleSelection
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JComboBox.AccessibleJComboBox
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JMenu.AccessibleJMenu
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
clearAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree
Clears the selection in the object, so that nothing in the object is selected.
clearAssertionStatus() - Method in class java.lang.ClassLoader
Sets the default assertion status for this class loader to false and discards any package defaults or class assertion status settings associated with the class loader.
clearAutoscroll() - Method in class java.awt.dnd.DropTarget
clear autoscrolling
clearBatch() - Method in interface java.sql.Statement
Empties this Statement object's current list of SQL commands.
clearBit(int) - Method in class java.math.BigInteger
Returns a BigInteger whose value is equivalent to this BigInteger with the designated bit cleared.
clearCache() - Static method in class java.util.ResourceBundle
Removes all resource bundles from the cache that have been loaded using the caller's class loader.
clearCache(ClassLoader) - Static method in class java.util.ResourceBundle
Removes all resource bundles from the cache that have been loaded using the given class loader.
clearChanged() - Method in class java.util.Observable
Indicates that this object has no longer changed, or that it has already notified all of its observers of its most recent change, so that the hasChanged method will now return false.
clearContent() - Method in class javax.xml.soap.AttachmentPart
Clears out the content of this AttachmentPart object.
clearError() - Method in class java.io.PrintStream
Clears the internal error state of this stream.
clearError() - Method in class java.io.PrintWriter
Clears the error state of this stream.
clearExtensions() - Method in class java.util.Locale.Builder
Resets the extensions to their initial, empty state.
clearGlobalFocusOwner() - Method in class java.awt.KeyboardFocusManager
Clears the global focus owner at both the Java and native levels.
clearIconCache() - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
clearIconCache() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
clearParameters() - Method in interface java.sql.PreparedStatement
Clears the current parameter values immediately.
clearParameters() - Method in class javax.sql.rowset.BaseRowSet
Clears all of the current parameter values in this RowSet object's internal representation of the parameters to be set in this RowSet object's command when it is executed.
clearParameters() - Method in interface javax.sql.RowSet
Clears the parameters set for this RowSet object's command.
clearParameters() - Method in class javax.xml.transform.Transformer
Clear all parameters set with setParameter.
clearPassword() - Method in class javax.crypto.spec.PBEKeySpec
Clears the internal copy of the password.
clearPassword() - Method in class javax.security.auth.callback.PasswordCallback
Clear the retrieved password.
clearProperty(String) - Static method in class java.lang.System
Removes the system property indicated by the specified key.
clearRect(int, int, int, int) - Method in class java.awt.Graphics
Clears the specified rectangle by filling it with the background color of the current drawing surface.
clearRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.clearRect.
clearSelectedPath() - Method in class javax.swing.MenuSelectionManager
Tell the menu selection to close and unselect all the menu components.
clearSelection() - Method in class javax.swing.ButtonGroup
Clears the selection such that none of the buttons in the ButtonGroup are selected.
clearSelection() - Method in class javax.swing.DefaultListSelectionModel
Change the selection to the empty set.
clearSelection() - Method in class javax.swing.DefaultSingleSelectionModel
clearSelection() - Method in class javax.swing.JList
Clears the selection; after calling this method, isSelectionEmpty will return true.
clearSelection() - Method in class javax.swing.JTable
Deselects all selected columns and rows.
clearSelection() - Method in class javax.swing.JTree
Clears the selection.
clearSelection() - Method in interface javax.swing.ListSelectionModel
Change the selection to the empty set.
clearSelection() - Method in interface javax.swing.SingleSelectionModel
Clears the selection (to -1).
clearSelection() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Empties the current selection.
clearSelection() - Method in interface javax.swing.tree.TreeSelectionModel
Empties the current selection.
clearTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicButtonUI
clearToggledPaths() - Method in class javax.swing.JTree
Clears the cache of toggled tree paths.
clearWarnings() - Method in interface java.sql.Connection
Clears all warnings reported for this Connection object.
clearWarnings() - Method in interface java.sql.ResultSet
Clears all warnings reported on this ResultSet object.
clearWarnings() - Method in interface java.sql.Statement
Clears all the warnings reported on this Statement object.
CLICK - Static variable in interface javax.accessibility.AccessibleAction
An action which causes a component to execute its default action.
clickCount - Variable in class java.awt.Event
For MOUSE_DOWN events, this field indicates the number of consecutive clicks.
clickCountToStart - Variable in class javax.swing.DefaultCellEditor
An integer specifying the number of clicks needed to start editing.
clientClosed(RMIConnection) - Method in class javax.management.remote.rmi.RMIServerImpl
Method called when a client connection created by makeClient is closed.
ClientInfoStatus - Enum in java.sql
Enumeration for status of the reason that a property could not be set via a call to Connection.setClientInfo
ClientRequestInfo - Interface in org.omg.PortableInterceptor
Request Information, accessible to client-side request interceptors.
ClientRequestInfoOperations - Interface in org.omg.PortableInterceptor
Request Information, accessible to client-side request interceptors.
ClientRequestInterceptor - Interface in org.omg.PortableInterceptor
Client-side request interceptor.
ClientRequestInterceptorOperations - Interface in org.omg.PortableInterceptor
Client-side request interceptor.
clip(Shape) - Method in class java.awt.Graphics2D
Intersects the current Clip with the interior of the specified Shape and sets the Clip to the resulting intersection.
Clip - Interface in javax.sound.sampled
The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
Clipboard - Class in java.awt.datatransfer
A class that implements a mechanism to transfer data using cut/copy/paste operations.
Clipboard(String) - Constructor for class java.awt.datatransfer.Clipboard
Creates a clipboard object.
ClipboardOwner - Interface in java.awt.datatransfer
Defines the interface for classes that will provide data to a clipboard.
clipRect(int, int, int, int) - Method in class java.awt.Graphics
Intersects the current clip with the specified rectangle.
clipRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.clipRect.
Clob - Interface in java.sql
The mapping in the JavaTM programming language for the SQL CLOB type.
CLOB - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type CLOB.
clockSequence() - Method in class java.util.UUID
The clock sequence value associated with this UUID.
clone() - Method in class java.awt.BufferCapabilities
clone() - Method in class java.awt.datatransfer.DataFlavor
Returns a clone of this DataFlavor.
clone() - Method in class java.awt.font.TextLayout
Creates a copy of this TextLayout.
clone() - Method in class java.awt.font.TextMeasurer
clone() - Method in class java.awt.geom.AffineTransform
Returns a copy of this AffineTransform object.
clone() - Method in class java.awt.geom.Area
Returns an exact copy of this Area object.
clone() - Method in class java.awt.geom.CubicCurve2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Dimension2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Line2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D.Double
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D.Float
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Point2D
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.geom.QuadCurve2D
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.geom.RectangularShape
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.GridBagConstraints
Creates a copy of this grid bag constraint.
clone() - Method in class java.awt.image.ImageFilter
Clones this object.
clone() - Method in class java.awt.image.Kernel
Clones this object.
clone() - Method in class java.awt.image.renderable.ParameterBlock
Creates a copy of a ParameterBlock.
clone() - Method in class java.awt.image.renderable.RenderContext
Makes a copy of a RenderContext.
clone() - Method in class java.awt.ImageCapabilities
clone() - Method in class java.awt.Insets
Create a copy of this object.
clone() - Method in class java.awt.JobAttributes
Creates and returns a copy of this JobAttributes.
clone() - Method in class java.awt.PageAttributes
Creates and returns a copy of this PageAttributes.
clone() - Method in class java.awt.print.PageFormat
Makes a copy of this PageFormat with the same contents as this PageFormat.
clone() - Method in class java.awt.print.Paper
Creates a copy of this Paper with the same contents as this Paper.
clone() - Method in class java.awt.RenderingHints
Creates a clone of this RenderingHints object that has the same contents as this RenderingHints object.
clone() - Method in class java.lang.Enum
Throws CloneNotSupportedException.
clone() - Method in class java.lang.Object
Creates and returns a copy of this object.
clone() - Method in class java.lang.Thread
Throws CloneNotSupportedException as a Thread can not be meaningfully cloned.
clone() - Method in class java.net.HttpCookie
Create and return a copy of this object.
clone() - Method in class java.rmi.server.UnicastRemoteObject
Returns a clone of the remote object that is distinct from the original.
clone() - Method in interface java.security.acl.AclEntry
Clones this ACL entry.
clone() - Method in interface java.security.cert.CertPathBuilderResult
Makes a copy of this CertPathBuilderResult.
clone() - Method in interface java.security.cert.CertPathParameters
Makes a copy of this CertPathParameters.
clone() - Method in interface java.security.cert.CertPathValidatorResult
Makes a copy of this CertPathValidatorResult.
clone() - Method in interface java.security.cert.CertSelector
Makes a copy of this CertSelector.
clone() - Method in interface java.security.cert.CertStoreParameters
Makes a copy of this CertStoreParameters.
clone() - Method in class java.security.cert.CollectionCertStoreParameters
Returns a copy of this object.
clone() - Method in interface java.security.cert.CRLSelector
Makes a copy of this CRLSelector.
clone() - Method in class java.security.cert.LDAPCertStoreParameters
Returns a copy of this object.
clone() - Method in class java.security.cert.PKIXCertPathChecker
Returns a clone of this object.
clone() - Method in class java.security.cert.PKIXCertPathValidatorResult
Returns a copy of this object.
clone() - Method in class java.security.cert.PKIXParameters
Makes a copy of this PKIXParameters object.
clone() - Method in class java.security.cert.X509CertSelector
Returns a copy of this object.
clone() - Method in class java.security.cert.X509CRLSelector
Returns a copy of this object.
clone() - Method in class java.security.MessageDigest
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.MessageDigestSpi
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.Signature
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.SignatureSpi
Returns a clone if the implementation is cloneable.
clone() - Method in class java.text.BreakIterator
Create a copy of this iterator
clone() - Method in interface java.text.CharacterIterator
Create a copy of this iterator
clone() - Method in class java.text.ChoiceFormat
Overrides Cloneable
clone() - Method in class java.text.Collator
Overrides Cloneable
clone() - Method in class java.text.DateFormat
Overrides Cloneable
clone() - Method in class java.text.DateFormatSymbols
Overrides Cloneable
clone() - Method in class java.text.DecimalFormat
Standard override; no change in semantics.
clone() - Method in class java.text.DecimalFormatSymbols
Standard override.
clone() - Method in class java.text.Format
Creates and returns a copy of this object.
clone() - Method in class java.text.MessageFormat
Creates and returns a copy of this object.
clone() - Method in class java.text.NumberFormat
Overrides Cloneable
clone() - Method in class java.text.RuleBasedCollator
Standard override; no change in semantics.
clone() - Method in class java.text.SimpleDateFormat
Creates a copy of this SimpleDateFormat.
clone() - Method in class java.text.StringCharacterIterator
Creates a copy of this iterator.
clone() - Method in class java.util.AbstractMap
Returns a shallow copy of this AbstractMap instance: the keys and values themselves are not cloned.
clone() - Method in class java.util.ArrayDeque
Returns a copy of this deque.
clone() - Method in class java.util.ArrayList
Returns a shallow copy of this ArrayList instance.
clone() - Method in class java.util.BitSet
Cloning this BitSet produces a new BitSet that is equal to it.
clone() - Method in class java.util.Calendar
Creates and returns a copy of this object.
clone() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a shallow copy of this ConcurrentSkipListMap instance.
clone() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns a shallow copy of this ConcurrentSkipListSet instance.
clone() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns a shallow copy of this list.
clone() - Method in class java.util.Date
Return a copy of this object.
clone() - Method in class java.util.EnumMap
Returns a shallow copy of this enum map.
clone() - Method in class java.util.EnumSet
Returns a copy of this set.
clone() - Method in class java.util.GregorianCalendar
clone() - Method in class java.util.HashMap
Returns a shallow copy of this HashMap instance: the keys and values themselves are not cloned.
clone() - Method in class java.util.HashSet
Returns a shallow copy of this HashSet instance: the elements themselves are not cloned.
clone() - Method in class java.util.Hashtable
Creates a shallow copy of this hashtable.
clone() - Method in class java.util.IdentityHashMap
Returns a shallow copy of this identity hash map: the keys and values themselves are not cloned.
clone() - Method in class java.util.jar.Attributes
Returns a copy of the Attributes, implemented as follows:
clone() - Method in class java.util.jar.Manifest
Returns a shallow copy of this Manifest.
clone() - Method in class java.util.LinkedList
Returns a shallow copy of this LinkedList.
clone() - Method in class java.util.Locale
Overrides Cloneable.
clone() - Method in class java.util.SimpleTimeZone
Returns a clone of this SimpleTimeZone instance.
clone() - Method in class java.util.TimeZone
Creates a copy of this TimeZone.
clone() - Method in class java.util.TreeMap
Returns a shallow copy of this TreeMap instance.
clone() - Method in class java.util.TreeSet
Returns a shallow copy of this TreeSet instance.
clone() - Method in class java.util.Vector
Returns a clone of this vector.
clone() - Method in class java.util.zip.ZipEntry
Returns a copy of this entry.
clone() - Method in class javax.crypto.Mac
Returns a clone if the provider implementation is cloneable.
clone() - Method in class javax.crypto.MacSpi
Returns a clone if the implementation is cloneable.
clone() - Method in interface javax.management.Descriptor
Returns a descriptor which is equal to this descriptor.
clone() - Method in class javax.management.ImmutableDescriptor
Returns a descriptor which is equal to this descriptor.
clone() - Method in class javax.management.MBeanAttributeInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanConstructorInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanNotificationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanOperationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanParameterInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.modelmbean.DescriptorSupport
Returns a new Descriptor which is a duplicate of the Descriptor.
clone() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo
Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo
Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
clone() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Creates and returns a copy of this object.
clone() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
Returns a shallow clone of this instance.
clone() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo
Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo
Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
clone() - Method in class javax.management.openmbean.TabularDataSupport
Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map.
clone() - Method in class javax.management.relation.Role
Clone the role object.
clone() - Method in class javax.management.relation.RoleUnresolved
Clone this object.
clone() - Method in class javax.naming.CompositeName
Generates a copy of this composite name.
clone() - Method in class javax.naming.CompoundName
Creates a copy of this compound name.
clone() - Method in interface javax.naming.directory.Attribute
Makes a copy of the attribute.
clone() - Method in interface javax.naming.directory.Attributes
Makes a copy of the attribute set.
clone() - Method in class javax.naming.directory.BasicAttribute
clone() - Method in class javax.naming.directory.BasicAttributes
clone() - Method in class javax.naming.ldap.LdapName
Generates a new copy of this name.
clone() - Method in interface javax.naming.Name
Generates a new copy of this name.
clone() - Method in class javax.naming.Reference
Makes a copy of this reference using its class name list of addresses, class factory name and class factory location.
clone() - Method in class javax.print.attribute.EnumSyntax
Returns a clone of this enumeration value, which to preserve the semantics of enumeration values is the same object as this enumeration value.
clone() - Method in class javax.sound.midi.MetaMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.MidiMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.ShortMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.SysexMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.swing.AbstractAction
Clones the abstract action.
clone() - Method in class javax.swing.DefaultListSelectionModel
Returns a clone of this selection model with the same selection.
clone() - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Clones the AbstractFormatter.
clone() - Method in class javax.swing.text.DefaultFormatter
Creates a copy of the DefaultFormatter.
clone(Element, Element) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Creates a copy of this element, with a different parent.
clone() - Method in class javax.swing.text.EditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.text.ElementIterator
Clones the ElementIterator.
clone() - Method in class javax.swing.text.GlyphView
Creates a shallow copy.
clone() - Method in class javax.swing.text.html.HTMLEditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.text.InternationalFormatter
Creates a copy of the DefaultFormatter.
clone() - Method in class javax.swing.text.Segment
Creates a shallow copy.
clone() - Method in class javax.swing.text.SimpleAttributeSet
Clones a set of attributes.
clone() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Clones a set of attributes.
clone() - Method in class javax.swing.text.StyledEditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.tree.DefaultMutableTreeNode
Overridden to make clone public.
clone() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns a clone of this object with the same selection.
clone() - Method in class javax.xml.datatype.XMLGregorianCalendar
Creates and returns a copy of this object.
Cloneable - Interface in java.lang
A class implements the Cloneable interface to indicate to the Object.clone() method that it is legal for that method to make a field-for-field copy of instances of that class.
cloneNode(boolean) - Method in class javax.imageio.metadata.IIOMetadataNode
Returns a duplicate of this node.
cloneNode(boolean) - Method in interface org.w3c.dom.Node
Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
CloneNotSupportedException - Exception in java.lang
Thrown to indicate that the clone method in class Object has been called to clone an object, but that the object's class does not implement the Cloneable interface.
CloneNotSupportedException() - Constructor for exception java.lang.CloneNotSupportedException
Constructs a CloneNotSupportedException with no detail message.
CloneNotSupportedException(String) - Constructor for exception java.lang.CloneNotSupportedException
Constructs a CloneNotSupportedException with the specified detail message.
cloneWithSource(Object) - Method in class javax.swing.event.TreeSelectionEvent
Returns a copy of the receiver, but with the source being newSource.
closable - Variable in class javax.swing.JInternalFrame
The frame can be closed.
close() - Method in class java.awt.SplashScreen
Hides the splash screen, closes the window, and releases all associated resources.
close() - Method in class java.beans.XMLDecoder
This method closes the input stream associated with this stream.
close() - Method in class java.beans.XMLEncoder
This method calls flush, writes the closing postamble and then closes the output stream associated with this stream.
close() - Method in class java.io.BufferedInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.BufferedReader
close() - Method in class java.io.BufferedWriter
close() - Method in class java.io.ByteArrayInputStream
Closing a ByteArrayInputStream has no effect.
close() - Method in class java.io.ByteArrayOutputStream
Closing a ByteArrayOutputStream has no effect.
close() - Method in class java.io.CharArrayReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.CharArrayWriter
Close the stream.
close() - Method in interface java.io.Closeable
Closes this stream and releases any system resources associated with it.
close() - Method in class java.io.FileInputStream
Closes this file input stream and releases any system resources associated with the stream.
close() - Method in class java.io.FileOutputStream
Closes this file output stream and releases any system resources associated with this stream.
close() - Method in class java.io.FilterInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.FilterOutputStream
Closes this output stream and releases any system resources associated with the stream.
close() - Method in class java.io.FilterReader
close() - Method in class java.io.FilterWriter
close() - Method in class java.io.InputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.InputStreamReader
close() - Method in interface java.io.ObjectInput
Closes the input stream.
close() - Method in class java.io.ObjectInputStream
Closes the input stream.
close() - Method in interface java.io.ObjectOutput
Closes the stream.
close() - Method in class java.io.ObjectOutputStream
Closes the stream.
close() - Method in class java.io.OutputStream
Closes this output stream and releases any system resources associated with this stream.
close() - Method in class java.io.OutputStreamWriter
close() - Method in class java.io.PipedInputStream
Closes this piped input stream and releases any system resources associated with the stream.
close() - Method in class java.io.PipedOutputStream
Closes this piped output stream and releases any system resources associated with this stream.
close() - Method in class java.io.PipedReader
Closes this piped stream and releases any system resources associated with the stream.
close() - Method in class java.io.PipedWriter
Closes this piped output stream and releases any system resources associated with this stream.
close() - Method in class java.io.PrintStream
Closes the stream.
close() - Method in class java.io.PrintWriter
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.PushbackInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.PushbackReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.RandomAccessFile
Closes this random access file stream and releases any system resources associated with the stream.
close() - Method in class java.io.Reader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.SequenceInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.StringReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.StringWriter
Closing a StringWriter has no effect.
close() - Method in class java.io.Writer
Closes the stream, flushing it first.
close() - Method in interface java.lang.AutoCloseable
Closes this resource, relinquishing any underlying resources.
close() - Method in class java.net.DatagramSocket
Closes this datagram socket.
close() - Method in class java.net.DatagramSocketImpl
Close the socket.
close() - Method in class java.net.ServerSocket
Closes this socket.
close() - Method in class java.net.Socket
Closes this socket.
close() - Method in class java.net.SocketImpl
Closes this socket.
close() - Method in class java.net.URLClassLoader
Closes this URLClassLoader, so that it can no longer be used to load new classes or resources that are defined by this loader.
close() - Method in interface java.nio.channels.AsynchronousChannel
Closes this channel.
close() - Method in interface java.nio.channels.Channel
Closes this channel.
close() - Method in class java.nio.channels.FileLock
This method invokes the FileLock.release() method.
close() - Method in interface java.nio.channels.InterruptibleChannel
Closes this channel.
close() - Method in interface java.nio.channels.MulticastChannel
Closes this channel.
close() - Method in class java.nio.channels.Selector
Closes this selector.
close() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Closes this channel.
close() - Method in class java.nio.channels.spi.AbstractSelector
Closes this selector.
close() - Method in class java.nio.file.FileSystem
Closes this file system.
close() - Method in interface java.nio.file.WatchService
Closes this watch service.
close() - Method in interface java.sql.Connection
Releases this Connection object's database and JDBC resources immediately instead of waiting for them to be automatically released.
close() - Method in interface java.sql.ResultSet
Releases this ResultSet object's database and JDBC resources immediately instead of waiting for this to happen when it is automatically closed.
close() - Method in interface java.sql.Statement
Releases this Statement object's database and JDBC resources immediately instead of waiting for this to happen when it is automatically closed.
close() - Method in class java.util.Formatter
Closes this formatter.
close() - Method in class java.util.logging.ConsoleHandler
Override StreamHandler.close to do a flush but not to close the output stream.
close() - Method in class java.util.logging.FileHandler
Close all the files.
close() - Method in class java.util.logging.Handler
Close the Handler and free all associated resources.
close() - Method in class java.util.logging.MemoryHandler
Close the Handler and free all associated resources.
close() - Method in class java.util.logging.SocketHandler
Close this output stream.
close() - Method in class java.util.logging.StreamHandler
Close the current output stream.
close() - Method in class java.util.Scanner
Closes this scanner.
close() - Method in class java.util.zip.DeflaterInputStream
Closes this input stream and its underlying input stream, discarding any pending uncompressed data.
close() - Method in class java.util.zip.DeflaterOutputStream
Writes remaining compressed data to the output stream and closes the underlying stream.
close() - Method in class java.util.zip.GZIPInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.InflaterInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.InflaterOutputStream
Writes any remaining uncompressed data to the output stream and closes the underlying output stream.
close() - Method in class java.util.zip.ZipFile
Closes the ZIP file.
close() - Method in class java.util.zip.ZipInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.ZipOutputStream
Closes the ZIP output stream as well as the stream being filtered.
close() - Method in class javax.crypto.CipherInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class javax.crypto.CipherOutputStream
Closes this output stream and releases any system resources associated with this stream.
close() - Method in class javax.imageio.stream.FileCacheImageInputStream
Closes this FileCacheImageInputStream, closing and removing the cache file.
close() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Closes this FileCacheImageOututStream.
close() - Method in class javax.imageio.stream.FileImageInputStream
close() - Method in class javax.imageio.stream.FileImageOutputStream
close() - Method in interface javax.imageio.stream.ImageInputStream
Closes the stream.
close() - Method in class javax.imageio.stream.ImageInputStreamImpl
close() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Closes this MemoryCacheImageInputStream, freeing the cache.
close() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Closes this MemoryCacheImageOutputStream.
close() - Method in interface javax.management.remote.JMXConnector
Closes the client connection to its server.
close() - Method in interface javax.management.remote.rmi.RMIConnection
Closes this connection.
close() - Method in class javax.management.remote.rmi.RMIConnectionImpl
close() - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
close() - Method in class javax.management.remote.rmi.RMIConnector
close() - Method in class javax.management.remote.rmi.RMIServerImpl
Closes this connection server.
close() - Method in interface javax.naming.Context
Closes this context.
close() - Method in class javax.naming.InitialContext
close() - Method in class javax.naming.ldap.StartTlsResponse
Closes the TLS connection gracefully and reverts back to the underlying connection.
close() - Method in interface javax.naming.NamingEnumeration
Closes this enumeration.
close() - Method in interface javax.sound.midi.MidiDevice
Closes the device, indicating that the device should now release any system resources it is using.
close() - Method in interface javax.sound.midi.Receiver
Indicates that the application has finished using the receiver, and that limited resources it requires may be released or made available.
close() - Method in interface javax.sound.midi.Transmitter
Indicates that the application has finished using the transmitter, and that limited resources it requires may be released or made available.
close() - Method in class javax.sound.sampled.AudioInputStream
Closes this audio input stream and releases any system resources associated with the stream.
close() - Method in interface javax.sound.sampled.Line
Closes the line, indicating that any system resources in use by the line can be released.
CLOSE - Static variable in class javax.sound.sampled.LineEvent.Type
A type of event that is sent when a line closes, freeing the system resources it had obtained when it was opened.
close() - Method in interface javax.sql.PooledConnection
Closes the physical connection that this PooledConnection object represents.
close() - Method in class javax.swing.ProgressMonitor
Indicate that the operation is complete.
close() - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.close to close the progress monitor as well as the stream.
close() - Method in class javax.tools.ForwardingJavaFileManager
close() - Method in interface javax.tools.JavaFileManager
Releases any resources opened by this file manager directly or indirectly.
close() - Method in class javax.xml.soap.SOAPConnection
Closes this SOAPConnection object.
close() - Method in class javax.xml.stream.util.EventReaderDelegate
close() - Method in class javax.xml.stream.util.StreamReaderDelegate
close() - Method in interface javax.xml.stream.XMLEventReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLEventWriter
Frees any resources associated with this stream
close() - Method in interface javax.xml.stream.XMLStreamReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLStreamWriter
Close this writer and free any resources associated with the writer.
close(MessageContext) - Method in interface javax.xml.ws.handler.Handler
Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.
close() - Method in class javax.xml.ws.spi.http.HttpExchange
This must be called to end an exchange.
CLOSE_ALL_RESULTS - Static variable in interface java.sql.Statement
The constant indicating that all ResultSet objects that have previously been kept open should be closed when calling getMoreResults.
CLOSE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
CLOSE_CURRENT_RESULT - Static variable in interface java.sql.Statement
The constant indicating that the current ResultSet object should be closed when calling getMoreResults.
CLOSE_CURSORS_AT_COMMIT - Static variable in interface java.sql.ResultSet
The constant indicating that open ResultSet objects with this holdability will be closed when the current transaction is commited.
CLOSE_FAILURE - Static variable in class java.util.logging.ErrorManager
CLOSE_FAILURE is used when a close of an output stream fails.
Closeable - Interface in java.io
A Closeable is a source or destination of data that can be closed.
closeAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
closeButton - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIServerImpl
Closes a client connection made by makeClient.
CLOSED - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection-closed notification.
CLOSED_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if user closes window without selecting anything, more than likely this should be treated as either a CANCEL_OPTION or NO_OPTION.
ClosedByInterruptException - Exception in java.nio.channels
Checked exception received by a thread when another thread interrupts it while it is blocked in an I/O operation upon a channel.
ClosedByInterruptException() - Constructor for exception java.nio.channels.ClosedByInterruptException
Constructs an instance of this class.
ClosedChannelException - Exception in java.nio.channels
Checked exception thrown when an attempt is made to invoke or complete an I/O operation upon channel that is closed, or at least closed to that operation.
ClosedChannelException() - Constructor for exception java.nio.channels.ClosedChannelException
Constructs an instance of this class.
ClosedDirectoryStreamException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a directory stream that is closed.
ClosedDirectoryStreamException() - Constructor for exception java.nio.file.ClosedDirectoryStreamException
Constructs an instance of this class.
ClosedFileSystemException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a file and the file system is closed.
ClosedFileSystemException() - Constructor for exception java.nio.file.ClosedFileSystemException
Constructs an instance of this class.
closedIcon - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Icon used to show non-leaf nodes that aren't expanded.
ClosedSelectorException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to invoke an I/O operation upon a closed selector.
ClosedSelectorException() - Constructor for exception java.nio.channels.ClosedSelectorException
Constructs an instance of this class.
ClosedWatchServiceException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a watch service that is closed.
ClosedWatchServiceException() - Constructor for exception java.nio.file.ClosedWatchServiceException
Constructs an instance of this class.
closeEntry() - Method in class java.util.zip.ZipInputStream
Closes the current ZIP entry and positions the stream for reading the next entry.
closeEntry() - Method in class java.util.zip.ZipOutputStream
Closes the current ZIP entry and positions the stream for writing the next entry.
closeFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the frame, and, if necessary, the desktopIcon, from its parent.
closeFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, this call should remove the frame from it's parent.
closeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to close the frame.
closeIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
closeInbound() - Method in class javax.net.ssl.SSLEngine
Signals that no more inbound network data will be sent to this SSLEngine.
closeKey - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
closeOnCompletion() - Method in interface java.sql.Statement
Specifies that this Statement will be closed when all its dependent result sets are closed.
closeOutbound() - Method in class javax.net.ssl.SSLEngine
Signals that no more outbound application data will be sent on this SSLEngine.
closeOutUnwantedEmbeddedTags(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Searches the attribute set and for each tag that is stored in the tag vector.
closePath() - Method in class java.awt.geom.Path2D
Closes the current subpath by drawing a straight line back to the coordinates of the last moveTo.
closeServer() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
Called by RMIServerImpl.close() to close the connector server by unexporting this object.
closeServer() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
Called by RMIServerImpl.close() to close the connector server by unexporting this object.
closeServer() - Method in class javax.management.remote.rmi.RMIServerImpl
Called by RMIServerImpl.close() to close the connector server.
CMMException - Exception in java.awt.color
This exception is thrown if the native CMM returns an error.
CMMException(String) - Constructor for exception java.awt.color.CMMException
Constructs a CMMException with the specified detail message.
coalesceEvents(AWTEvent, AWTEvent) - Method in class java.awt.Component
Potentially coalesce an event being posted with an existing event.
CODE - Static variable in class javax.swing.text.html.HTML.Attribute
CODE - Static variable in class javax.swing.text.html.HTML.Tag
code - Variable in exception org.w3c.dom.DOMException
code - Variable in exception org.w3c.dom.events.EventException
code - Variable in exception org.w3c.dom.ls.LSException
CODE_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a code attribute name, indicates the format of that attribute.
CODEBASE - Static variable in class javax.swing.text.html.HTML.Attribute
Codec - Interface in org.omg.IOP
The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
codec_factory() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Returns the IOP.CodecFactory.
CodecFactory - Interface in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecFactoryHelper - Class in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecFactoryHelper() - Constructor for class org.omg.IOP.CodecFactoryHelper
CodecFactoryOperations - Interface in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecOperations - Interface in org.omg.IOP
The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
codePointAt(CharSequence, int) - Static method in class java.lang.Character
Returns the code point at the given index of the CharSequence.
codePointAt(char[], int) - Static method in class java.lang.Character
Returns the code point at the given index of the char array.
codePointAt(char[], int, int) - Static method in class java.lang.Character
Returns the code point at the given index of the char array, where only array elements with index less than limit can be used.
codePointAt(int) - Method in class java.lang.String
Returns the character (Unicode code point) at the specified index.
codePointAt(int) - Method in class java.lang.StringBuffer
codePointBefore(CharSequence, int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the CharSequence.
codePointBefore(char[], int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the char array.
codePointBefore(char[], int, int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the char array, where only array elements with index greater than or equal to start can be used.
codePointBefore(int) - Method in class java.lang.String
Returns the character (Unicode code point) before the specified index.
codePointBefore(int) - Method in class java.lang.StringBuffer
codePointCount(CharSequence, int, int) - Static method in class java.lang.Character
Returns the number of Unicode code points in the text range of the specified char sequence.
codePointCount(char[], int, int) - Static method in class java.lang.Character
Returns the number of Unicode code points in a subarray of the char array argument.
codePointCount(int, int) - Method in class java.lang.String
Returns the number of Unicode code points in the specified text range of this String.
codePointCount(int, int) - Method in class java.lang.StringBuffer
CoderMalfunctionError - Error in java.nio.charset
Error thrown when the decodeLoop method of a CharsetDecoder, or the encodeLoop method of a CharsetEncoder, throws an unexpected exception.
CoderMalfunctionError(Exception) - Constructor for error java.nio.charset.CoderMalfunctionError
Initializes an instance of this class.
CoderResult - Class in java.nio.charset
A description of the result state of a coder.
CODESET_INCOMPATIBLE - Exception in org.omg.CORBA
This exception is raised whenever meaningful communication is not possible between client and server native code sets.
CODESET_INCOMPATIBLE() - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
CODESET_INCOMPATIBLE(String) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified message.
CODESET_INCOMPATIBLE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
CODESET_INCOMPATIBLE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
CodeSets - Interface in org.omg.IOP
org/omg/IOP/CodeSets.java .
CodeSigner - Class in java.security
This class encapsulates information about a code signer.
CodeSigner(CertPath, Timestamp) - Constructor for class java.security.CodeSigner
Constructs a CodeSigner object.
CodeSource - Class in java.security
This class extends the concept of a codebase to encapsulate not only the location (URL) but also the certificate chains that were used to verify signed code originating from that location.
CodeSource(URL, Certificate[]) - Constructor for class java.security.CodeSource
Constructs a CodeSource and associates it with the specified location and set of certificates.
CodeSource(URL, CodeSigner[]) - Constructor for class java.security.CodeSource
Constructs a CodeSource and associates it with the specified location and set of code signers.
CODETYPE - Static variable in class javax.swing.text.html.HTML.Attribute
CodingErrorAction - Class in java.nio.charset
A typesafe enumeration for coding-error actions.
coerceData(boolean) - Method in class java.awt.image.BufferedImage
Forces the data to match the state specified in the isAlphaPremultiplied variable.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.ColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.ComponentColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.DirectColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
colHead - Variable in class javax.swing.ScrollPaneLayout
The column header child.
COLLAPSED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is collapsed.
collapsedIcon - Variable in class javax.swing.plaf.basic.BasicTreeUI
CollapsedStringAdapter - Class in javax.xml.bind.annotation.adapters
Built-in XmlAdapter to handle xs:token and its derived types.
CollapsedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
collapsePath(TreePath) - Method in class javax.swing.JTree
Ensures that the node identified by the specified path is collapsed and viewable.
collapseRow(int) - Method in class javax.swing.JTree
Ensures that the node in the specified row is collapsed.
COLLATED - Static variable in class javax.print.attribute.standard.SheetCollate
Sheets within a document appear in collated order when multiple copies are printed.
CollationElementIterator - Class in java.text
The CollationElementIterator class is used as an iterator to walk through each character of an international string.
CollationKey - Class in java.text
A CollationKey represents a String under the rules of a specific Collator object.
CollationKey(String) - Constructor for class java.text.CollationKey
CollationKey constructor.
Collator - Class in java.text
The Collator class performs locale-sensitive String comparison.
Collator() - Constructor for class java.text.Collator
Default constructor.
CollatorProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the Collator class.
CollatorProvider() - Constructor for class java.text.spi.CollatorProvider
Sole constructor.
Collection<E> - Interface in java.util
The root interface in the collection hierarchy.
CollectionCertStoreParameters - Class in java.security.cert
Parameters used as input for the Collection CertStore algorithm.
CollectionCertStoreParameters(Collection<?>) - Constructor for class java.security.cert.CollectionCertStoreParameters
Creates an instance of CollectionCertStoreParameters which will allow certificates and CRLs to be retrieved from the specified Collection.
CollectionCertStoreParameters() - Constructor for class java.security.cert.CollectionCertStoreParameters
Creates an instance of CollectionCertStoreParameters with the default parameter values (an empty and immutable Collection).
Collections - Class in java.util
This class consists exclusively of static methods that operate on or return collections.
Color - Class in java.awt
The Color class is used to encapsulate colors in the default sRGB color space or colors in arbitrary color spaces identified by a ColorSpace.
Color(int, int, int) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified red, green, and blue values in the range (0 - 255).
Color(int, int, int, int) - Constructor for class java.awt.Color
Creates an sRGB color with the specified red, green, blue, and alpha values in the range (0 - 255).
Color(int) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified combined RGB value consisting of the red component in bits 16-23, the green component in bits 8-15, and the blue component in bits 0-7.
Color(int, boolean) - Constructor for class java.awt.Color
Creates an sRGB color with the specified combined RGBA value consisting of the alpha component in bits 24-31, the red component in bits 16-23, the green component in bits 8-15, and the blue component in bits 0-7.
Color(float, float, float) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified red, green, and blue values in the range (0.0 - 1.0).
Color(float, float, float, float) - Constructor for class java.awt.Color
Creates an sRGB color with the specified red, green, blue, and alpha values in the range (0.0 - 1.0).
Color(ColorSpace, float[], float) - Constructor for class java.awt.Color
Creates a color in the specified ColorSpace with the color components specified in the float array and the specified alpha.
COLOR - Static variable in class java.awt.PageAttributes.ColorType
The ColorType instance to use for specifying color printing.
COLOR - Static variable in class javax.print.attribute.standard.Chromaticity
Color printing.
color - Variable in class javax.swing.border.MatteBorder
COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
COLOR - Static variable in class javax.swing.text.html.HTML.Attribute
COLOR_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The Color choice action identifier The color is passed as an argument
COLOR_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A specialized pane that lets the user choose a color.
COLOR_CHOOSER - Static variable in class javax.swing.plaf.synth.Region
ColorChooser region.
COLOR_CHOOSER_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
ColorChooserComponentFactory - Class in javax.swing.colorchooser
A class designed to produce preconfigured "accessory" objects to insert into color choosers.
ColorChooserUI - Class in javax.swing.plaf
Pluggable look and feel interface for JColorChooser.
ColorChooserUI() - Constructor for class javax.swing.plaf.ColorChooserUI
ColorConvertOp - Class in java.awt.image
This class performs a pixel-by-pixel color conversion of the data in the source image.
ColorConvertOp(RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp which will convert from a source color space to a destination color space.
ColorConvertOp(ColorSpace, RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from a ColorSpace object.
ColorConvertOp(ColorSpace, ColorSpace, RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from two ColorSpace objects.
ColorConvertOp(ICC_Profile[], RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from an array of ICC_Profiles.
ColorModel - Class in java.awt.image
The ColorModel abstract class encapsulates the methods for translating a pixel value to color components (for example, red, green, and blue) and an alpha component.
ColorModel(int) - Constructor for class java.awt.image.ColorModel
Constructs a ColorModel that translates pixels of the specified number of bits to color/alpha components.
ColorModel(int, int[], ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image.ColorModel
Constructs a ColorModel that translates pixel values to color/alpha components.
colorModel - Variable in class javax.imageio.ImageTypeSpecifier
The ColorModel to be used as a prototype.
ColorSelectionModel - Interface in javax.swing.colorchooser
A model that supports selecting a Color.
ColorSpace - Class in java.awt.color
This abstract class is used to serve as a color space tag to identify the specific color space of a Color object or, via a ColorModel object, of an Image, a BufferedImage, or a GraphicsDevice.
ColorSpace(int, int) - Constructor for class java.awt.color.ColorSpace
Constructs a ColorSpace object given a color space type and the number of components.
ColorSupported - Class in javax.print.attribute.standard
Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
ColorSupported(int) - Constructor for class javax.print.attribute.standard.ColorSupported
Construct a new color supported enumeration value with the given integer value.
ColorType - Class in javax.swing.plaf.synth
A typesafe enumeration of colors that can be fetched from a style.
ColorType(String) - Constructor for class javax.swing.plaf.synth.ColorType
Creates a new ColorType with the specified description.
ColorUIResource - Class in javax.swing.plaf
ColorUIResource(int, int, int) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(int) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(float, float, float) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(Color) - Constructor for class javax.swing.plaf.ColorUIResource
COLS - Static variable in class javax.swing.text.html.HTML.Attribute
COLSPAN - Static variable in class javax.swing.text.html.HTML.Attribute
column - Variable in class javax.swing.event.TableModelEvent
COLUMN_HEADER - Static variable in class javax.accessibility.AccessibleRole
The header for a column of data.
COLUMN_HEADER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the area at the top the viewport between the upper left corner and the upper right corner.
COLUMN_WIDTH_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
columnAdded(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was added to the model.
columnAdded(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (column insertions)
columnAdded(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is added to the table column model.
columnAdded(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is added to the table column model.
columnAtPoint(Point) - Method in class javax.swing.JTable
Returns the index of the column that point lies in, or -1 if the result is not in the range [0, getColumnCount()-1].
columnAtPoint(Point) - Method in class javax.swing.table.JTableHeader
Returns the index of the column that point lies in, or -1 if it lies out of bounds.
columnHeader - Variable in class javax.swing.JScrollPane
The column header child.
columnIdentifiers - Variable in class javax.swing.table.DefaultTableModel
The Vector of column identifiers.
columnMargin - Variable in class javax.swing.table.DefaultTableColumnModel
Width margin between each column
columnMarginChanged(ChangeEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was moved due to a margin change.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes of a column moving due to margin changes.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.JTable
Invoked when a column is moved due to a margin change.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is moved due to a margin change.
columnModel - Variable in class javax.swing.JTable
The TableColumnModel of the table.
columnModel - Variable in class javax.swing.table.JTableHeader
The TableColumnModel of the table header.
columnMoved(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was repositioned.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes of a column repositioning.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is repositioned.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is repositioned.
columnNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column might not allow NULL values.
columnNoNulls - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that a column does not allow NULL values.
columnNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column definitely allows NULL values.
columnNullable - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that a column allows NULL values.
columnNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that the nullability of columns is unknown.
columnNullableUnknown - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that the nullability of a column's values is unknown.
columnRemoved(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was removed from the model.
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (column deletions)
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is removed from the table column model.
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is removed from the table column model.
columnSelectionAllowed - Variable in class javax.swing.table.DefaultTableColumnModel
Column selection allowed in this column model
columnSelectionChanged(ListSelectionEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that the selection model of the TableColumnModel changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track that the selection model of the TableColumnModel changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.JTable
Invoked when the selection model of the TableColumnModel is changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table.JTableHeader
Invoked when the selection model of the TableColumnModel is changed.
columnUpdated(int) - Method in interface javax.sql.rowset.CachedRowSet
Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
columnUpdated(String) - Method in interface javax.sql.rowset.CachedRowSet
Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
columnWeights - Variable in class java.awt.GridBagLayout
This field holds the overrides to the column weights.
columnWidths - Variable in class java.awt.GridBagLayout
This field holds the overrides to the column minimum width.
combine(ProtectionDomain[], ProtectionDomain[]) - Method in interface java.security.DomainCombiner
Modify or update the provided ProtectionDomains.
combine(ProtectionDomain[], ProtectionDomain[]) - Method in class javax.security.auth.SubjectDomainCombiner
Update the relevant ProtectionDomains with the Principals from the Subject associated with this SubjectDomainCombiner.
COMBINING - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph that represents a combining character, such as an umlaut.
COMBINING_DIACRITICAL_MARKS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks" Unicode character block.
COMBINING_DIACRITICAL_MARKS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks Supplement" Unicode character block.
COMBINING_HALF_MARKS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Half Marks" Unicode character block.
COMBINING_MARKS_FOR_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks for Symbols" Unicode character block.
COMBINING_SPACING_MARK - Static variable in class java.lang.Character
General category "Mc" in the Unicode specification.
COMBO_BOX - Static variable in class javax.accessibility.AccessibleRole
A list of choices the user can select from.
COMBO_BOX - Static variable in class javax.swing.plaf.synth.Region
ComboBox region.
comboBox - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
comboBox - Variable in class javax.swing.plaf.basic.BasicComboPopup
comboBox - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
ComboBoxEditor - Interface in javax.swing
The editor component used for JComboBox components.
ComboBoxModel - Interface in javax.swing
A data model for a combo box.
ComboBoxUI - Class in javax.swing.plaf
Pluggable look and feel interface for JComboBox.
ComboBoxUI() - Constructor for class javax.swing.plaf.ComboBoxUI
comboIcon - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
ComboPopup - Interface in javax.swing.plaf.basic
The interface which defines the methods required for the implementation of the popup portion of a combo box.
COMM_FAILURE - Exception in org.omg.CORBA
This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
COMM_FAILURE() - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
COMM_FAILURE(String) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
COMM_FAILURE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified minor code and completion status.
COMM_FAILURE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.
command(Object) - Static method in class java.lang.Compiler
Examines the argument type and its fields and perform some documented operation.
command(List<String>) - Method in class java.lang.ProcessBuilder
Sets this process builder's operating system program and arguments.
command(String...) - Method in class java.lang.ProcessBuilder
Sets this process builder's operating system program and arguments.
command() - Method in class java.lang.ProcessBuilder
Returns this process builder's operating system program and arguments.
CommandInfo - Class in javax.activation
The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandInfo(String, String) - Constructor for class javax.activation.CommandInfo
The Constructor for CommandInfo.
CommandMap - Class in javax.activation
The CommandMap class provides an interface to a registry of command objects available in the system.
CommandMap() - Constructor for class javax.activation.CommandMap
CommandObject - Interface in javax.activation
JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
COMMENT - Static variable in class javax.swing.text.html.HTML.Attribute
COMMENT - Static variable in class javax.swing.text.html.HTML.Tag
All comments are labeled with this tag.
comment(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out comments.
Comment - Interface in javax.xml.stream.events
An interface for comment events
COMMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a comment
Comment - Interface in org.w3c.dom
This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
comment(char[], int, int) - Method in class org.xml.sax.ext.DefaultHandler2
comment(char[], int, int) - Method in interface org.xml.sax.ext.LexicalHandler
Report an XML comment anywhere in the document.
COMMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a Comment.
commentChar(int) - Method in class java.io.StreamTokenizer
Specified that the character argument starts a single-line comment.
COMMENTS - Static variable in class java.util.regex.Pattern
Permits whitespace and comments in pattern.
commit() - Method in interface java.sql.Connection
Makes all changes made since the previous commit/rollback permanent and releases any database locks currently held by this Connection object.
commit() - Method in interface javax.security.auth.spi.LoginModule
Method to commit the authentication process (phase 2).
commit() - Method in interface javax.sql.rowset.CachedRowSet
Each CachedRowSet object's SyncProvider contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
commit() - Method in interface javax.sql.rowset.JdbcRowSet
Each JdbcRowSet contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
commit() - Method in interface javax.sql.rowset.spi.TransactionalWriter
Makes permanent all changes that have been performed by the acceptChanges method since the last call to either the commit or rollback methods.
COMMIT - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, commitEdit should be invoked.
commit(Xid, boolean) - Method in interface javax.transaction.xa.XAResource
Commits the global transaction specified by xid.
COMMIT_ON_ACCEPT_CHANGES - Static variable in interface javax.sql.rowset.CachedRowSet
Deprecated.
Because this field is final (it is part of an interface), its value cannot be changed.
COMMIT_OR_REVERT - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, commitEdit should be invoked.
commitEdit() - Method in class javax.swing.JFormattedTextField
Forces the current value to be taken from the AbstractFormatter and set as the current value.
commitEdit() - Method in class javax.swing.JSpinner
Commits the currently edited value to the SpinnerModel.
commitEdit() - Method in class javax.swing.JSpinner.DefaultEditor
Pushes the currently edited value to the SpinnerModel.
COMMON - Static variable in class java.awt.JobAttributes.DialogType
The DialogType instance to use for specifying the cross-platform, pure Java print dialog.
COMMON - Static variable in class javax.print.attribute.standard.DialogTypeSelection
COMMON_INDIC_NUMBER_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Common Indic Number Forms" Unicode character block.
CommonDataSource - Interface in javax.sql
Interface that defines the methods which are common between DataSource, XADataSource and ConnectionPoolDataSource.
CommunicationException - Exception in javax.naming
This exception is thrown when the client is unable to communicate with the directory or naming service.
CommunicationException(String) - Constructor for exception javax.naming.CommunicationException
Constructs a new instance of CommunicationException using the arguments supplied.
CommunicationException() - Constructor for exception javax.naming.CommunicationException
Constructs a new instance of CommunicationException.
compact() - Method in class java.nio.ByteBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.CharBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.DoubleBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.FloatBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.IntBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.LongBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.ShortBuffer
Compacts this buffer (optional operation).
COMPACT - Static variable in class javax.swing.text.html.HTML.Attribute
COMPACT_DISC - Static variable in class javax.sound.sampled.Port.Info
A type of port that gets audio from a CD-ROM drive.
Comparable<T> - Interface in java.lang
This interface imposes a total ordering on the objects of each class that implements it.
Comparator<T> - Interface in java.util
A comparison function, which imposes a total ordering on some collection of objects.
comparator() - Method in class java.util.concurrent.ConcurrentSkipListMap
comparator() - Method in class java.util.concurrent.ConcurrentSkipListSet
comparator() - Method in class java.util.concurrent.PriorityBlockingQueue
Returns the comparator used to order the elements in this queue, or null if this queue uses the natural ordering of its elements.
comparator() - Method in class java.util.PriorityQueue
Returns the comparator used to order the elements in this queue, or null if this queue is sorted according to the natural ordering of its elements.
comparator() - Method in interface java.util.SortedMap
Returns the comparator used to order the keys in this map, or null if this map uses the natural ordering of its keys.
comparator() - Method in interface java.util.SortedSet
Returns the comparator used to order the elements in this set, or null if this set uses the natural ordering of its elements.
comparator() - Method in class java.util.TreeMap
comparator() - Method in class java.util.TreeSet
compare(boolean, boolean) - Static method in class java.lang.Boolean
Compares two boolean values.
compare(byte, byte) - Static method in class java.lang.Byte
Compares two byte values numerically.
compare(char, char) - Static method in class java.lang.Character
Compares two char values numerically.
compare(double, double) - Static method in class java.lang.Double
Compares the two specified double values.
compare(float, float) - Static method in class java.lang.Float
Compares the two specified float values.
compare(int, int) - Static method in class java.lang.Integer
Compares two int values numerically.
compare(long, long) - Static method in class java.lang.Long
Compares two long values numerically.
compare(short, short) - Static method in class java.lang.Short
Compares two short values numerically.
compare(String, String) - Method in class java.text.Collator
Compares the source string to the target string according to the collation rules for this Collator.
compare(Object, Object) - Method in class java.text.Collator
Compares its two arguments for order.
compare(String, String) - Method in class java.text.RuleBasedCollator
Compares the character data stored in two different strings based on the collation rules.
compare(T, T) - Method in interface java.util.Comparator
Compares its two arguments for order.
compare(T, T, Comparator<? super T>) - Static method in class java.util.Objects
Returns 0 if the arguments are identical and c.compare(a, b) otherwise.
compare(Duration) - Method in class javax.xml.datatype.Duration
Partial order relation comparison with this Duration instance.
compare(XMLGregorianCalendar) - Method in class javax.xml.datatype.XMLGregorianCalendar
Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
compareAndSet(boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, int) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(long, long) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, long, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, long, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(V, V, boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Atomically sets the value of both the reference and mark to the given update values if the current reference is == to the expected reference and the current mark is equal to the expected mark.
compareAndSet(V, V) - Method in class java.util.concurrent.atomic.AtomicReference
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, E, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, V, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(V, V, int, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference
Atomically sets the value of both the reference and stamp to the given update values if the current reference is == to the expected reference and the current stamp is equal to the expected stamp.
compareAndSetState(long, long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Atomically sets synchronization state to the given updated value if the current state value equals the expected value.
compareAndSetState(int, int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Atomically sets synchronization state to the given updated value if the current state value equals the expected value.
compareDocumentPosition(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
compareDocumentPosition(Node) - Method in interface org.w3c.dom.Node
Compares the reference node, i.e.
compareTabOrder(Component, Component) - Method in class javax.swing.DefaultFocusManager
compareTo(File) - Method in class java.io.File
Compares two abstract pathnames lexicographically.
compareTo(Object) - Method in class java.io.ObjectStreamField
Compare this field with another ObjectStreamField.
compareTo(Boolean) - Method in class java.lang.Boolean
Compares this Boolean instance with another.
compareTo(Byte) - Method in class java.lang.Byte
Compares two Byte objects numerically.
compareTo(Character) - Method in class java.lang.Character
Compares two Character objects numerically.
compareTo(T) - Method in interface java.lang.Comparable
Compares this object with the specified object for order.
compareTo(Double) - Method in class java.lang.Double
Compares two Double objects numerically.
compareTo(E) - Method in class java.lang.Enum
Compares this enum with the specified object for order.
compareTo(Float) - Method in class java.lang.Float
Compares two Float objects numerically.
compareTo(Integer) - Method in class java.lang.Integer
Compares two Integer objects numerically.
compareTo(Long) - Method in class java.lang.Long
Compares two Long objects numerically.
compareTo(Short) - Method in class java.lang.Short
Compares two Short objects numerically.
compareTo(String) - Method in class java.lang.String
Compares two strings lexicographically.
compareTo(BigDecimal) - Method in class java.math.BigDecimal
Compares this BigDecimal with the specified BigDecimal.
compareTo(BigInteger) - Method in class java.math.BigInteger
Compares this BigInteger with the specified BigInteger.
compareTo(URI) - Method in class java.net.URI
Compares this URI to another object, which must be a URI.
compareTo(ByteBuffer) - Method in class java.nio.ByteBuffer
Compares this buffer to another.
compareTo(CharBuffer) - Method in class java.nio.CharBuffer
Compares this buffer to another.
compareTo(Charset) - Method in class java.nio.charset.Charset
Compares this charset to another.
compareTo(DoubleBuffer) - Method in class java.nio.DoubleBuffer
Compares this buffer to another.
compareTo(FileTime) - Method in class java.nio.file.attribute.FileTime
Compares the value of two FileTime objects for order.
compareTo(Path) - Method in interface java.nio.file.Path
Compares two abstract paths lexicographically.
compareTo(FloatBuffer) - Method in class java.nio.FloatBuffer
Compares this buffer to another.
compareTo(IntBuffer) - Method in class java.nio.IntBuffer
Compares this buffer to another.
compareTo(LongBuffer) - Method in class java.nio.LongBuffer
Compares this buffer to another.
compareTo(ShortBuffer) - Method in class java.nio.ShortBuffer
Compares this buffer to another.
compareTo(Timestamp) - Method in class java.sql.Timestamp
Compares this Timestamp object to the given Timestamp object.
compareTo(Date) - Method in class java.sql.Timestamp
Compares this Timestamp object to the given Date object.
compareTo(CollationKey) - Method in class java.text.CollationKey
Compare this CollationKey to the target CollationKey.
compareTo(Calendar) - Method in class java.util.Calendar
Compares the time values (millisecond offsets from the Epoch) represented by two Calendar objects.
compareTo(Date) - Method in class java.util.Date
Compares two Dates for ordering.
compareTo(UUID) - Method in class java.util.UUID
Compares this UUID with the specified UUID.
compareTo(ObjectName) - Method in class javax.management.ObjectName
Compares two ObjectName instances.
compareTo(Object) - Method in class javax.naming.CompositeName
Compares this CompositeName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.CompoundName
Compares this CompoundName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.ldap.LdapName
Compares this LdapName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.ldap.Rdn
Compares this Rdn with the specified Object for order.
compareTo(Object) - Method in interface javax.naming.Name
Compares this name with another name for order.
compareToIgnoreCase(String) - Method in class java.lang.String
Compares two strings lexicographically, ignoring case differences.
Compilable - Interface in javax.script
The optional interface implemented by ScriptEngines whose methods compile scripts to a form that can be executed repeatedly without recompilation.
COMPILATION_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the CompilationMXBean.
CompilationMXBean - Interface in java.lang.management
The management interface for the compilation system of the Java virtual machine.
compile(String) - Static method in class java.util.regex.Pattern
Compiles the given regular expression into a pattern.
compile(String, int) - Static method in class java.util.regex.Pattern
Compiles the given regular expression into a pattern with the given flags.
compile(String) - Method in interface javax.script.Compilable
Compiles the script (source represented as a String) for later execution.
compile(Reader) - Method in interface javax.script.Compilable
Compiles the script (source read from Reader) for later execution.
compile(String) - Method in interface javax.xml.xpath.XPath
Compile an XPath expression for later evaluation.
compileClass(Class<?>) - Static method in class java.lang.Compiler
Compiles the specified class.
compileClasses(String) - Static method in class java.lang.Compiler
Compiles all classes whose name matches the specified string.
CompiledScript - Class in javax.script
Extended by classes that store results of compilations.
CompiledScript() - Constructor for class javax.script.CompiledScript
Compiler - Class in java.lang
The Compiler class is provided to support Java-to-native-code compilers and related services.
complementOf(EnumSet<E>) - Static method in class java.util.EnumSet
Creates an enum set with the same element type as the specified enum set, initially containing all the elements of this type that are not contained in the specified set.
COMPLETE - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media was completed successfully.
complete() - Method in class java.util.Calendar
Fills in any unset fields in the calendar fields.
complete(V) - Method in class java.util.concurrent.ForkJoinTask
Completes this task, and if not already aborted or cancelled, returning the given value as the result of subsequent invocations of join and related operations.
completed(V, A) - Method in interface java.nio.channels.CompletionHandler
Invoked when an operation has completed.
COMPLETED - Static variable in class javax.print.attribute.standard.JobState
The job has completed successfully or with warnings or errors after processing, all of the job media sheets have been successfully stacked in the appropriate output bin(s), and all job status attributes have reached their final values for the job.
completed - Variable in exception org.omg.CORBA.SystemException
The status of the operation that threw this exception.
COMPLETED_MAYBE - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
COMPLETED_NO - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
COMPLETED_YES - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_YES.
completeDrag(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
completeDrag(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Messages finishDraggingTo with the new location for the mouse event.
completeEditing() - Method in class javax.swing.plaf.basic.BasicTreeUI
Messages to stop the editing session.
completeEditing(boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI
Stops the editing session.
completeExceptionally(Throwable) - Method in class java.util.concurrent.ForkJoinTask
Completes this task abnormally, and if not already aborted or cancelled, causes it to throw the given exception upon join and related operations.
COMPLETESCANLINES - Static variable in interface java.awt.image.ImageConsumer
The pixels will be delivered in (multiples of) complete scanlines at a time.
completeUIInstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
Invoked from installUI after all the defaults/listeners have been installed.
completeUIUninstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
Completion - Interface in javax.annotation.processing
A suggested completion for an annotation.
CompletionHandler<V,A> - Interface in java.nio.channels
A handler for consuming the result of an asynchronous I/O operation.
Completions - Class in javax.annotation.processing
Utility class for assembling Completion objects.
CompletionService<V> - Interface in java.util.concurrent
A service that decouples the production of new asynchronous tasks from the consumption of the results of completed tasks.
CompletionStatus - Class in org.omg.CORBA
An object that indicates whether a method had completed running when a SystemException was thrown.
CompletionStatusHelper - Class in org.omg.CORBA
The Helper for CompletionStatus.
CompletionStatusHelper() - Constructor for class org.omg.CORBA.CompletionStatusHelper
Component - Class in java.awt
A component is an object having a graphical representation that can be displayed on the screen and that can interact with the user.
Component() - Constructor for class java.awt.Component
Constructs a new component.
component - Variable in class java.awt.dnd.DragGestureRecognizer
The Component associated with this DragGestureRecognizer.
COMPONENT - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph with no corresponding character in the backing store.
component - Static variable in class javax.swing.ImageIcon
Component.AccessibleAWTComponent - Class in java.awt
Inner class of Component used to provide default support for accessibility.
Component.AccessibleAWTComponent() - Constructor for class java.awt.Component.AccessibleAWTComponent
Though the class is abstract, this should be called by all sub-classes.
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when shown/hidden..
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler() - Constructor for class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when focus events happen
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler() - Constructor for class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
Component.BaselineResizeBehavior - Enum in java.awt
Enumeration of the common ways the baseline of a component can change as the size changes.
Component.BltBufferStrategy - Class in java.awt
Inner class for blitting offscreen surfaces to a component.
Component.BltBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt.Component.BltBufferStrategy
Creates a new blt buffer strategy around a component
Component.FlipBufferStrategy - Class in java.awt
Inner class for flipping buffers on a component.
Component.FlipBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt.Component.FlipBufferStrategy
Creates a new flipping buffer strategy for this component.
COMPONENT_ADDED - Static variable in class java.awt.event.ContainerEvent
This event indicates that a component was added to the container.
component_count() - Method in class org.omg.DynamicAny._DynAnyStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynArrayStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynEnumStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynFixedStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynSequenceStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynStructStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynValueStub
Returns the number of components of a DynAny.
component_count() - Method in interface org.omg.DynamicAny.DynAnyOperations
Returns the number of components of a DynAny.
component_data - Variable in class org.omg.IOP.TaggedComponent
The component data associated with the component id.
COMPONENT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting component events.
COMPONENT_FIRST - Static variable in class java.awt.event.ComponentEvent
The first number in the range of ids used for component events.
COMPONENT_HIDDEN - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component was rendered invisible.
COMPONENT_LAST - Static variable in class java.awt.event.ComponentEvent
The last number in the range of ids used for component events.
COMPONENT_MOVED - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component's position changed.
COMPONENT_REMOVED - Static variable in class java.awt.event.ContainerEvent
This event indicates that a component was removed from the container.
COMPONENT_RESIZED - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component's size changed.
COMPONENT_SHOWN - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component was made visible.
ComponentAdapter - Class in java.awt.event
An abstract adapter class for receiving component events.
ComponentAdapter() - Constructor for class java.awt.event.ComponentAdapter
componentAdded(ContainerEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentAdded container event by invoking the componentAdded methods on listener-a and listener-b.
componentAdded(ContainerEvent) - Method in class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
componentAdded(ContainerEvent) - Method in class java.awt.event.ContainerAdapter
Invoked when a component has been added to the container.
componentAdded(ContainerEvent) - Method in interface java.awt.event.ContainerListener
Invoked when a component has been added to the container.
componentAdded(ContainerEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
componentAdded(ContainerEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
ComponentAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the component attribute.
ComponentColorModel - Class in java.awt.image
A ColorModel class that works with pixel values that represent color and alpha information as separate samples and that store each sample in a separate data element.
ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) - Constructor for class java.awt.image.ComponentColorModel
Constructs a ComponentColorModel from the specified parameters.
ComponentColorModel(ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image.ComponentColorModel
Constructs a ComponentColorModel from the specified parameters.
ComponentElementName - Static variable in class javax.swing.text.StyleConstants
Name of elements used to represent components.
ComponentEvent - Class in java.awt.event
A low-level event which indicates that a component moved, changed size, or changed visibility (also, the root class for the other component-level events).
ComponentEvent(Component, int) - Constructor for class java.awt.event.ComponentEvent
Constructs a ComponentEvent object.
componentForPoint(Component, Point) - Method in class javax.swing.MenuSelectionManager
Returns the component in the currently selected path which contains sourcePoint.
componentHidden(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentHidden event by invoking the componentHidden methods on listener-a and listener-b.
componentHidden(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentHidden(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component has been made invisible.
componentHidden(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component has been made invisible.
componentHidden(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
ComponentIdHelper - Class in org.omg.IOP
Standard way of representing multicomponent profiles.
ComponentIdHelper() - Constructor for class org.omg.IOP.ComponentIdHelper
ComponentInputMap - Class in javax.swing
A ComponentInputMap is an InputMap associated with a particular JComponent.
ComponentInputMap(JComponent) - Constructor for class javax.swing.ComponentInputMap
Creates a ComponentInputMap associated with the specified component.
ComponentInputMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.ComponentInputMap that implements UIResource.
ComponentInputMapUIResource(JComponent) - Constructor for class javax.swing.plaf.ComponentInputMapUIResource
ComponentListener - Interface in java.awt.event
The listener interface for receiving component events.
componentListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
componentListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
componentMoved(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentMoved event by invoking the componentMoved methods on listener-a and listener-b.
componentMoved(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentMoved(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component's position changes.
componentMoved(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component's position changes.
componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
ComponentOrientation - Class in java.awt
The ComponentOrientation class encapsulates the language-sensitive orientation that is to be used to order the elements of a component or of text.
componentRemoved(ContainerEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentRemoved container event by invoking the componentRemoved methods on listener-a and listener-b.
componentRemoved(ContainerEvent) - Method in class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
componentRemoved(ContainerEvent) - Method in class java.awt.event.ContainerAdapter
Invoked when a component has been removed from the container.
componentRemoved(ContainerEvent) - Method in interface java.awt.event.ContainerListener
Invoked when a component has been removed from the container.
componentRemoved(ContainerEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
componentRemoved(ContainerEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
componentResized(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentResized event by invoking the componentResized methods on listener-a and listener-b.
componentResized(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentResized(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component's size changes.
componentResized(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component's size changes.
componentResized(ComponentEvent) - Method in class javax.swing.JViewport.ViewListener
componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
Invoked when a JInternalFrame's parent's size changes.
componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
components - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
components_established(IORInfo) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
ComponentSampleModel - Class in java.awt.image
This class represents image data which is stored such that each sample of a pixel occupies one data element of the DataBuffer.
ComponentSampleModel(int, int, int, int, int, int[]) - Constructor for class java.awt.image.ComponentSampleModel
Constructs a ComponentSampleModel with the specified parameters.
ComponentSampleModel(int, int, int, int, int, int[], int[]) - Constructor for class java.awt.image.ComponentSampleModel
Constructs a ComponentSampleModel with the specified parameters.
componentShown(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentShown event by invoking the componentShown methods on listener-a and listener-b.
componentShown(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentShown(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component has been made visible.
componentShown(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component has been made visible.
componentShown(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
ComponentUI - Class in javax.swing.plaf
The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
ComponentUI() - Constructor for class javax.swing.plaf.ComponentUI
Sole constructor.
ComponentView - Class in javax.swing.text
Component decorator that implements the view interface.
ComponentView(Element) - Constructor for class javax.swing.text.ComponentView
Creates a new ComponentView object.
compose(Raster, Raster, WritableRaster) - Method in interface java.awt.CompositeContext
Composes the two source Raster objects and places the result in the destination WritableRaster.
ComposedTextAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the input method composed text attribute.
composeName(Name, Name) - Method in interface javax.naming.Context
Composes the name of this context with a name relative to this context.
composeName(String, String) - Method in interface javax.naming.Context
Composes the name of this context with a name relative to this context.
composeName(String, String) - Method in class javax.naming.InitialContext
Composes the name of this context with a name relative to this context.
composeName(Name, Name) - Method in class javax.naming.InitialContext
Composes the name of this context with a name relative to this context.
Composite - Interface in java.awt
The Composite interface, along with CompositeContext, defines the methods to compose a draw primitive with the underlying graphics area.
CompositeContext - Interface in java.awt
The CompositeContext interface defines the encapsulated and optimized environment for a compositing operation.
CompositeData - Interface in javax.management.openmbean
The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
CompositeDataInvocationHandler - Class in javax.management.openmbean
An InvocationHandler that forwards getter methods to a CompositeData.
CompositeDataInvocationHandler(CompositeData) - Constructor for class javax.management.openmbean.CompositeDataInvocationHandler
Construct a handler backed by the given CompositeData.
CompositeDataSupport - Class in javax.management.openmbean
The CompositeDataSupport class is the open data class which implements the CompositeData interface.
CompositeDataSupport(CompositeType, String[], Object[]) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
CompositeDataSupport(CompositeType, Map<String, ?>) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
CompositeDataView - Interface in javax.management.openmbean
A Java class can implement this interface to indicate how it is to be converted into a CompositeData by the MXBean framework.
CompositeName - Class in javax.naming
This class represents a composite name -- a sequence of component names spanning multiple namespaces.
CompositeName(Enumeration<String>) - Constructor for class javax.naming.CompositeName
Constructs a new composite name instance using the components specified by 'comps'.
CompositeName(String) - Constructor for class javax.naming.CompositeName
Constructs a new composite name instance by parsing the string n using the composite name syntax (left-to-right, slash separated).
CompositeName() - Constructor for class javax.naming.CompositeName
Constructs a new empty composite name.
CompositeType - Class in javax.management.openmbean
The CompositeType class is the open type class whose instances describe the types of CompositeData values.
CompositeType(String, String, String[], String[], OpenType<?>[]) - Constructor for class javax.management.openmbean.CompositeType
Constructs a CompositeType instance, checking for the validity of the given parameters.
CompositeView - Class in javax.swing.text
CompositeView is an abstract View implementation which manages one or more child views.
CompositeView(Element) - Constructor for class javax.swing.text.CompositeView
Constructs a CompositeView for the given element.
CompoundBorder - Class in javax.swing.border
A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
CompoundBorder() - Constructor for class javax.swing.border.CompoundBorder
Creates a compound border with null outside and inside borders.
CompoundBorder(Border, Border) - Constructor for class javax.swing.border.CompoundBorder
Creates a compound border with the specified outside and inside borders.
CompoundControl - Class in javax.sound.sampled
A CompoundControl, such as a graphic equalizer, provides control over two or more related properties, each of which is itself represented as a Control.
CompoundControl(CompoundControl.Type, Control[]) - Constructor for class javax.sound.sampled.CompoundControl
Constructs a new compound control object with the given parameters.
CompoundControl.Type - Class in javax.sound.sampled
An instance of the CompoundControl.Type inner class identifies one kind of compound control.
CompoundControl.Type(String) - Constructor for class javax.sound.sampled.CompoundControl.Type
Constructs a new compound control type.
CompoundEdit - Class in javax.swing.undo
A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
CompoundEdit() - Constructor for class javax.swing.undo.CompoundEdit
compoundEdit - Variable in class javax.swing.undo.UndoableEditSupport
CompoundName - Class in javax.naming
This class represents a compound name -- a name from a hierarchical name space.
CompoundName(Enumeration<String>, Properties) - Constructor for class javax.naming.CompoundName
Constructs a new compound name instance using the components specified in comps and syntax.
CompoundName(String, Properties) - Constructor for class javax.naming.CompoundName
Constructs a new compound name instance by parsing the string n using the syntax specified by the syntax properties supplied.
COMPRESS - Static variable in class javax.print.attribute.standard.Compression
UNIX compression technology.
Compression - Class in javax.print.attribute.standard
Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
Compression(int) - Constructor for class javax.print.attribute.standard.Compression
Construct a new compression enumeration value with the given integer value.
COMPRESSION_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the printer encountered an error in the document data while decompressing it.
compressionMode - Variable in class javax.imageio.ImageWriteParam
The mode controlling compression settings, which must be set to one of the four MODE_* values.
compressionQuality - Variable in class javax.imageio.ImageWriteParam
A float containing the current compression quality setting.
compressionType - Variable in class javax.imageio.ImageWriteParam
A String containing the name of the current compression type, or null if none is set.
compressionTypes - Variable in class javax.imageio.ImageWriteParam
An array of Strings containing the names of the available compression types.
comptable - Variable in class java.awt.GridBagLayout
This hashtable maintains the association between a component and its gridbag constraints.
compute() - Method in class java.util.concurrent.RecursiveAction
The main computation performed by this task.
compute() - Method in class java.util.concurrent.RecursiveTask
The main computation performed by this task.
computeBlit(int, int, Point, Point, Dimension, Rectangle) - Method in class javax.swing.JViewport
Computes the parameters for a blit where the backing store image currently contains oldLoc in the upper left hand corner and we're scrolling to newLoc.
computeDifference(Rectangle, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience returning an array of rect representing the regions within rectA that do not overlap with rectB.
computeFields() - Method in class java.util.Calendar
Converts the current millisecond time value Calendar.time to calendar field values in fields[].
computeFields() - Method in class java.util.GregorianCalendar
Converts the time value (millisecond offset from the Epoch) to calendar field values.
computeIntersection(int, int, int, int, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience to calculate the intersection of two rectangles without allocating a new rectangle.
computePopupBounds(int, int, int, int) - Method in class javax.swing.plaf.basic.BasicComboPopup
Calculate the placement and size of the popup portion of the combo box based on the combo box location and the enclosing screen bounds.
computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle) - Static method in class javax.imageio.ImageReader
Computes the source region of interest and the destination region of interest, taking the width and height of the source image, an optional destination image, and an optional ImageReadParam into account.
computerIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
computeStringWidth(SynthContext, Font, FontMetrics, String) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Returns the size of the passed in string.
computeStringWidth(FontMetrics, String) - Static method in class javax.swing.SwingUtilities
Compute the width of the string using a font with the specified "metrics" (sizes).
computeTime() - Method in class java.util.Calendar
Converts the current calendar field values in fields[] to the millisecond time value Calendar.time.
computeTime() - Method in class java.util.GregorianCalendar
Converts calendar field values to the time value (millisecond offset from the Epoch).
computeUnion(int, int, int, int, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience method that calculates the union of two rectangles without allocating a new rectangle.
computeValue(Class<?>) - Method in class java.lang.ClassValue
Computes the given class's derived value for this ClassValue.
computeVisibleRect(Rectangle) - Method in class javax.swing.JComponent
Returns the Component's "visible rect rectangle" - the intersection of the visible rectangles for this component and all of its ancestors.
concat(String) - Method in class java.lang.String
Concatenates the specified string to the end of this string.
concatenate(AffineTransform) - Method in class java.awt.geom.AffineTransform
Concatenates an AffineTransform Tx to this AffineTransform Cx in the most commonly useful way to provide a new user space that is mapped to the former user space by Tx.
concatenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Modifies the current user-to-device transform by appending another transform.
concetenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Deprecated.
replaced by concatenateTransform(AffineTransform).
concrete_base_type() - Method in class org.omg.CORBA.TypeCode
Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
CONCUR_READ_ONLY - Static variable in interface java.sql.ResultSet
The constant indicating the concurrency mode for a ResultSet object that may NOT be updated.
CONCUR_UPDATABLE - Static variable in interface java.sql.ResultSet
The constant indicating the concurrency mode for a ResultSet object that may be updated.
ConcurrentHashMap<K,V> - Class in java.util.concurrent
A hash table supporting full concurrency of retrievals and adjustable expected concurrency for updates.
ConcurrentHashMap(int, float, int) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with the specified initial capacity, load factor and concurrency level.
ConcurrentHashMap(int, float) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with the specified initial capacity and load factor and with the default concurrencyLevel (16).
ConcurrentHashMap(int) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with the specified initial capacity, and with default load factor (0.75) and concurrencyLevel (16).
ConcurrentHashMap() - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with a default initial capacity (16), load factor (0.75) and concurrencyLevel (16).
ConcurrentHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new map with the same mappings as the given map.
ConcurrentLinkedDeque<E> - Class in java.util.concurrent
An unbounded concurrent deque based on linked nodes.
ConcurrentLinkedDeque() - Constructor for class java.util.concurrent.ConcurrentLinkedDeque
Constructs an empty deque.
ConcurrentLinkedDeque(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentLinkedDeque
Constructs a deque initially containing the elements of the given collection, added in traversal order of the collection's iterator.
ConcurrentLinkedQueue<E> - Class in java.util.concurrent
An unbounded thread-safe queue based on linked nodes.
ConcurrentLinkedQueue() - Constructor for class java.util.concurrent.ConcurrentLinkedQueue
Creates a ConcurrentLinkedQueue that is initially empty.
ConcurrentLinkedQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentLinkedQueue
Creates a ConcurrentLinkedQueue initially containing the elements of the given collection, added in traversal order of the collection's iterator.
ConcurrentMap<K,V> - Interface in java.util.concurrent
A Map providing additional atomic putIfAbsent, remove, and replace methods.
ConcurrentModificationException - Exception in java.util
This exception may be thrown by methods that have detected concurrent modification of an object when such modification is not permissible.
ConcurrentModificationException() - Constructor for exception java.util.ConcurrentModificationException
Constructs a ConcurrentModificationException with no detail message.
ConcurrentModificationException(String) - Constructor for exception java.util.ConcurrentModificationException
Constructs a ConcurrentModificationException with the specified detail message.
ConcurrentModificationException(Throwable) - Constructor for exception java.util.ConcurrentModificationException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause.
ConcurrentModificationException(String, Throwable) - Constructor for exception java.util.ConcurrentModificationException
Constructs a new exception with the specified detail message and cause.
ConcurrentNavigableMap<K,V> - Interface in java.util.concurrent
A ConcurrentMap supporting NavigableMap operations, and recursively so for its navigable sub-maps.
ConcurrentSkipListMap<K,V> - Class in java.util.concurrent
A scalable concurrent ConcurrentNavigableMap implementation.
ConcurrentSkipListMap() - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new, empty map, sorted according to the natural ordering of the keys.
ConcurrentSkipListMap(Comparator<? super K>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new, empty map, sorted according to the specified comparator.
ConcurrentSkipListMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new map containing the same mappings as the given map, sorted according to the natural ordering of the keys.
ConcurrentSkipListMap(SortedMap<K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new map containing the same mappings and using the same ordering as the specified sorted map.
ConcurrentSkipListSet<E> - Class in java.util.concurrent
A scalable concurrent NavigableSet implementation based on a ConcurrentSkipListMap.
ConcurrentSkipListSet() - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new, empty set that orders its elements according to their natural ordering.
ConcurrentSkipListSet(Comparator<? super E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new, empty set that orders its elements according to the specified comparator.
ConcurrentSkipListSet(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new set containing the elements in the specified collection, that orders its elements according to their natural ordering.
ConcurrentSkipListSet(SortedSet<E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new set containing the same elements and using the same ordering as the specified sorted set.
Condition - Interface in java.util.concurrent.locks
Condition factors out the Object monitor methods (wait, notify and notifyAll) into distinct objects to give the effect of having multiple wait-sets per object, by combining them with the use of arbitrary Lock implementations.
CONFIG - Static variable in class java.util.logging.Level
CONFIG is a message level for static configuration messages.
config(String) - Method in class java.util.logging.Logger
Log a CONFIG message.
Configuration - Class in javax.security.auth.login
A Configuration object is responsible for specifying which LoginModules should be used for a particular application, and in what order the LoginModules should be invoked.
Configuration() - Constructor for class javax.security.auth.login.Configuration
Sole constructor.
Configuration.Parameters - Interface in javax.security.auth.login
This represents a marker interface for Configuration parameters.
ConfigurationException - Exception in javax.naming
This exception is thrown when there is a configuration problem.
ConfigurationException(String) - Constructor for exception javax.naming.ConfigurationException
Constructs a new instance of ConfigurationException using an explanation.
ConfigurationException() - Constructor for exception javax.naming.ConfigurationException
Constructs a new instance of ConfigurationException with all name resolution fields and explanation initialized to null.
ConfigurationSpi - Class in javax.security.auth.login
This class defines the Service Provider Interface (SPI) for the Configuration class.
ConfigurationSpi() - Constructor for class javax.security.auth.login.ConfigurationSpi
configureArrowButton() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
configureBlocking(boolean) - Method in class java.nio.channels.SelectableChannel
Adjusts this channel's blocking mode.
configureBlocking(boolean) - Method in class java.nio.channels.spi.AbstractSelectableChannel
Adjusts this channel's blocking mode.
configureEditor(ComboBoxEditor, Object) - Method in class javax.swing.JComboBox
Initializes the editor with the specified item.
configureEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This protected method is implementation specific and should be private.
configureEditor() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
configureEnclosingScrollPane() - Method in class javax.swing.JTable
If this JTable is the viewportView of an enclosing JScrollPane (the usual situation), configure this ScrollPane by, amongst other things, installing the table's tableHeader as the columnHeaderView of the scroll pane.
configureGraphics(Graphics2D) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Configures the given Graphics2D.
configureLayoutCache() - Method in class javax.swing.plaf.basic.BasicTreeUI
Resets the TreeState instance based on the tree we're providing the look and feel for.
configureList() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the list which is used to hold the combo box items in the popup.
configurePopup() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the popup portion of the combo box.
configurePropertiesFromAction(Action) - Method in class javax.swing.AbstractButton
Sets the properties on this button to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JComboBox
Sets the properties on this combobox to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JMenuItem
Sets the properties on this button to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JTextField
Sets the properties on this textfield to match those in the specified Action.
configureScrollBarColors() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
configureScrollBarColors() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
configureScrollBarColors() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
configureScroller() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the scrollable portion which holds the list within the combo box popup.
ConfirmationCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a ConfirmationCallback to the handle method of a CallbackHandler to ask for YES/NO, OK/CANCEL, YES/NO/CANCEL or other similar confirmations.
ConfirmationCallback(int, int, int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a message type, an option type and a default option.
ConfirmationCallback(int, String[], int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a message type, a list of options and a default option.
ConfirmationCallback(String, int, int, int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a prompt, message type, an option type and a default option.
ConfirmationCallback(String, int, String[], int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a prompt, message type, a list of options and a default option.
connect(PipedOutputStream) - Method in class java.io.PipedInputStream
Causes this piped input stream to be connected to the piped output stream src.
connect(PipedInputStream) - Method in class java.io.PipedOutputStream
Connects this piped output stream to a receiver.
connect(PipedWriter) - Method in class java.io.PipedReader
Causes this piped reader to be connected to the piped writer src.
connect(PipedReader) - Method in class java.io.PipedWriter
Connects this piped writer to a receiver.
connect(InetAddress, int) - Method in class java.net.DatagramSocket
Connects the socket to a remote address for this socket.
connect(SocketAddress) - Method in class java.net.DatagramSocket
Connects this socket to a remote socket address (IP address + port number).
connect(InetAddress, int) - Method in class java.net.DatagramSocketImpl
Connects a datagram socket to a remote destination.
connect(SocketAddress) - Method in class java.net.Socket
Connects this socket to the server.
connect(SocketAddress, int) - Method in class java.net.Socket
Connects this socket to the server with a specified timeout value.
connect(String, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port on the named host.
connect(InetAddress, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port number on the specified host.
connect(SocketAddress, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port number on the specified host.
connect() - Method in class java.net.URLConnection
Opens a communications link to the resource referenced by this URL, if such a connection has not already been established.
connect(SocketAddress, A, CompletionHandler<Void, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Connects this channel.
connect(SocketAddress) - Method in class java.nio.channels.AsynchronousSocketChannel
Connects this channel.
connect(SocketAddress) - Method in class java.nio.channels.DatagramChannel
Connects this channel's socket.
connect(SocketAddress) - Method in class java.nio.channels.SocketChannel
Connects this channel's socket.
connect(String, Properties) - Method in interface java.sql.Driver
Attempts to make a database connection to the given URL.
connect() - Method in interface javax.management.remote.JMXConnector
Establishes the connection to the connector server.
connect(Map<String, ?>) - Method in interface javax.management.remote.JMXConnector
Establishes the connection to the connector server.
connect(JMXServiceURL) - Static method in class javax.management.remote.JMXConnectorFactory
Creates a connection to the connector server at the given address.
connect(JMXServiceURL, Map<String, ?>) - Static method in class javax.management.remote.JMXConnectorFactory
Creates a connection to the connector server at the given address.
connect() - Method in class javax.management.remote.rmi.RMIConnector
connect(Map<String, ?>) - Method in class javax.management.remote.rmi.RMIConnector
connect(Remote, Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote).
connect(ORB) - Method in class javax.rmi.CORBA.Stub
Connects this stub to an ORB.
connect(Stub, ORB) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.connect(org.omg.CORBA.ORB).
connect(Remote, Remote) - Static method in class javax.rmi.PortableRemoteObject
Makes a Remote object ready for remote communication.
connect(Object) - Method in class org.omg.CORBA.ORB
Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
connected - Variable in class java.net.URLConnection
If false, this connection object has not created a communications link to the specified URL.
ConnectException - Exception in java.net
Signals that an error occurred while attempting to connect a socket to a remote address and port.
ConnectException(String) - Constructor for exception java.net.ConnectException
Constructs a new ConnectException with the specified detail message as to why the connect error occurred.
ConnectException() - Constructor for exception java.net.ConnectException
Construct a new ConnectException with no detailed message.
ConnectException - Exception in java.rmi
A ConnectException is thrown if a connection is refused to the remote host for a remote method call.
ConnectException(String) - Constructor for exception java.rmi.ConnectException
Constructs a ConnectException with the specified detail message.
ConnectException(String, Exception) - Constructor for exception java.rmi.ConnectException
Constructs a ConnectException with the specified detail message and nested exception.
connectFailed(URI, SocketAddress, IOException) - Method in class java.net.ProxySelector
Called to indicate that a connection could not be established to a proxy/socks server.
CONNECTING_TO_DEVICE - Static variable in class javax.print.attribute.standard.PrinterStateReason
The printer has scheduled a job on the output device and is in the process of connecting to a shared network output device (and might not be able to actually start printing the job for an arbitrarily long time depending on the usage of the output device by other servers on the network).
ConnectIOException - Exception in java.rmi
A ConnectIOException is thrown if an IOException occurs while making a connection to the remote host for a remote method call.
ConnectIOException(String) - Constructor for exception java.rmi.ConnectIOException
Constructs a ConnectIOException with the specified detail message.
ConnectIOException(String, Exception) - Constructor for exception java.rmi.ConnectIOException
Constructs a ConnectIOException with the specified detail message and nested exception.
Connection - Interface in java.sql
A connection (session) with a specific database.
connectionClosed(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a client connection is closed normally.
connectionClosed(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
connectionClosed(ConnectionEvent) - Method in interface javax.sql.ConnectionEventListener
Notifies this ConnectionEventListener that the application has called the method close on its representation of a pooled connection.
connectionErrorOccurred(ConnectionEvent) - Method in interface javax.sql.ConnectionEventListener
Notifies this ConnectionEventListener that a fatal error has occurred and the pooled connection can no longer be used.
ConnectionEvent - Class in javax.sql
An Event object that provides information about the source of a connection-related event.
ConnectionEvent(PooledConnection) - Constructor for class javax.sql.ConnectionEvent
Constructs a ConnectionEvent object initialized with the given PooledConnection object.
ConnectionEvent(PooledConnection, SQLException) - Constructor for class javax.sql.ConnectionEvent
Constructs a ConnectionEvent object initialized with the given PooledConnection object and SQLException object.
ConnectionEventListener - Interface in javax.sql
An object that registers to be notified of events generated by a PooledConnection object.
connectionFailed(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a client connection fails.
connectionFailed(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
connectionOpened(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a new client connection is opened.
connectionOpened(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
ConnectionPendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to connect a SocketChannel for which a non-blocking connection operation is already in progress.
ConnectionPendingException() - Constructor for exception java.nio.channels.ConnectionPendingException
Constructs an instance of this class.
ConnectionPoolDataSource - Interface in javax.sql
A factory for PooledConnection objects.
CONNECTOR_PUNCTUATION - Static variable in class java.lang.Character
General category "Pc" in the Unicode specification.
CONREF - Static variable in interface javax.swing.text.html.parser.DTDConstants
Console - Class in java.io
Methods to access the character-based console device, if any, associated with the current Java virtual machine.
console() - Static method in class java.lang.System
Returns the unique Console object associated with the current Java virtual machine, if any.
ConsoleHandler - Class in java.util.logging
This Handler publishes log records to System.err.
ConsoleHandler() - Constructor for class java.util.logging.ConsoleHandler
Create a ConsoleHandler for System.err.
constant(Class<?>, Object) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle of the requested return type which returns the given constant value every time it is invoked.
constant(int) - Static method in class javax.swing.Spring
Returns a strut -- a spring whose minimum, preferred, and maximum values each have the value pref.
constant(int, int, int) - Static method in class javax.swing.Spring
Returns a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively.
ConstantCallSite - Class in java.lang.invoke
A ConstantCallSite is a CallSite whose target is permanent, and can never be changed.
ConstantCallSite(MethodHandle) - Constructor for class java.lang.invoke.ConstantCallSite
Creates a call site with a permanent target.
constantName() - Method in exception java.lang.EnumConstantNotPresentException
Returns the name of the missing enum constant.
constraintBeforeFloating - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Constructor<T> - Class in java.lang.reflect
Constructor provides information about, and access to, a single constructor for a class.
constructorModifiers() - Static method in class java.lang.reflect.修饰符
Return an int value OR-ing together the source language modifiers that can be applied to a constructor.
ConstructorProperties - Annotation Type in java.beans
An annotation on a constructor that shows how the parameters of that constructor correspond to the constructed object's getter methods.
constructorsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of constructors in elements.
constructorsIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of constructors in elements.
consume() - Method in class java.awt.AWTEvent
Consumes this event, if this event can be consumed.
consume() - Method in class java.awt.event.InputEvent
Consumes this event so that it will not be processed in the default manner by the source which originated it.
consume() - Method in class java.awt.event.InputMethodEvent
Consumes this event so that it will not be processed in the default manner by the source which originated it.
consumed - Variable in class java.awt.AWTEvent
Controls whether or not the event is sent back down to the peer once the source has processed it - false means it's sent to the peer; true means it's not.
consumer - Variable in class java.awt.image.ImageFilter
The consumer of the particular image data stream for which this instance of the ImageFilter is filtering data.
containedIn(Oid[]) - Method in class org.ietf.jgss.Oid
A utility method to test if this Oid value is contained within the supplied Oid array.
Container - Class in java.awt
A generic Abstract Window Toolkit(AWT) container object is a component that can contain other AWT components.
Container() - Constructor for class java.awt.Container
Constructs a new Container.
Container.AccessibleAWTContainer - Class in java.awt
Inner class of Container used to provide default support for accessibility.
Container.AccessibleAWTContainer() - Constructor for class java.awt.Container.AccessibleAWTContainer
Container.AccessibleAWTContainer.AccessibleContainerHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when children are added or removed.
Container.AccessibleAWTContainer.AccessibleContainerHandler() - Constructor for class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
CONTAINER_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting container events.
CONTAINER_FIRST - Static variable in class java.awt.event.ContainerEvent
The first number in the range of ids used for container events.
CONTAINER_LAST - Static variable in class java.awt.event.ContainerEvent
The last number in the range of ids used for container events.
ContainerAdapter - Class in java.awt.event
An abstract adapter class for receiving container events.
ContainerAdapter() - Constructor for class java.awt.event.ContainerAdapter
ContainerEvent - Class in java.awt.event
A low-level event which indicates that a container's contents changed because a component was added or removed.
ContainerEvent(Component, int, Component) - Constructor for class java.awt.event.ContainerEvent
Constructs a ContainerEvent object.
ContainerListener - Interface in java.awt.event
The listener interface for receiving container events.
containerListener - Variable in class javax.swing.plaf.basic.BasicMenuBarUI
ContainerOrderFocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy that determines traversal order based on the order of child Components in a Container.
ContainerOrderFocusTraversalPolicy() - Constructor for class java.awt.ContainerOrderFocusTraversalPolicy
contains(Point) - Method in class java.awt.Component.AccessibleAWTComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(int, int) - Method in class java.awt.Component
Checks whether this component "contains" the specified point, where x and y are defined to be relative to the coordinate system of this component.
contains(Point) - Method in class java.awt.Component
Checks whether this component "contains" the specified point, where the point's x and y coordinates are defined to be relative to the coordinate system of this component.
contains(double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified point is inside the boundary of the arc.
contains(double, double, double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc entirely contains the specified rectangle.
contains(Rectangle2D) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc entirely contains the specified rectangle.
contains(double, double) - Method in class java.awt.geom.Area
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.Area
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Area
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.Area
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.CubicCurve2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(double, double) - Method in class java.awt.geom.Line2D
Tests if a specified coordinate is inside the boundary of this Line2D.
contains(Point2D) - Method in class java.awt.geom.Line2D
Tests if a given Point2D is inside the boundary of this Line2D.
contains(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the interior of this Line2D entirely contains the specified set of rectangular coordinates.
contains(Rectangle2D) - Method in class java.awt.geom.Line2D
Tests if the interior of this Line2D entirely contains the specified Rectangle2D.
contains(PathIterator, double, double) - Static method in class java.awt.geom.Path2D
Tests if the specified coordinates are inside the closed boundary of the specified PathIterator.
contains(PathIterator, Point2D) - Static method in class java.awt.geom.Path2D
Tests if the specified Point2D is inside the closed boundary of the specified PathIterator.
contains(double, double) - Method in class java.awt.geom.Path2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.Path2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(PathIterator, double, double, double, double) - Static method in class java.awt.geom.Path2D
Tests if the specified rectangular area is entirely inside the closed boundary of the specified PathIterator.
contains(PathIterator, Rectangle2D) - Static method in class java.awt.geom.Path2D
Tests if the specified Rectangle2D is entirely inside the closed boundary of the specified PathIterator.
contains(double, double, double, double) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.QuadCurve2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Point2D) - Method in class java.awt.geom.RectangularShape
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(Rectangle2D) - Method in class java.awt.geom.RectangularShape
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Point) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class java.awt.Polygon
Determines whether the specified Point is inside this Polygon.
contains(int, int) - Method in class java.awt.Polygon
Determines whether the specified coordinates are inside this Polygon.
contains(double, double) - Method in class java.awt.Polygon
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.Polygon
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.Polygon
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.Polygon
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(Point) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle contains the specified Point.
contains(int, int) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle contains the point at the specified location (x,y).
contains(Rectangle) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle entirely contains the specified Rectangle.
contains(int, int, int, int) - Method in class java.awt.Rectangle
Checks whether this Rectangle entirely contains the Rectangle at the specified location (X,Y) with the specified dimensions (W,H).
contains(double, double) - Method in interface java.awt.Shape
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in interface java.awt.Shape
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in interface java.awt.Shape
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in interface java.awt.Shape
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(Object) - Method in class java.beans.beancontext.BeanContextMembershipEvent
Is the child specified affected by the event?
contains(Object) - Method in class java.beans.beancontext.BeanContextSupport
Determines whether or not the specified object is currently a child of this BeanContext.
contains(CharSequence) - Method in class java.lang.String
Returns true if and only if this string contains the specified sequence of char values.
contains(Charset) - Method in class java.nio.charset.Charset
Tells whether or not this charset contains the given charset.
contains(Object) - Method in class java.util.AbstractCollection
Returns true if this collection contains the specified element.
contains(Object) - Method in class java.util.ArrayDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.ArrayList
Returns true if this list contains the specified element.
contains(Object) - Method in interface java.util.Collection
Returns true if this collection contains the specified element.
contains(Object) - Method in class java.util.concurrent.ArrayBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in interface java.util.concurrent.BlockingDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in interface java.util.concurrent.BlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Legacy method testing if some key maps into the specified value in this table.
contains(Object) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns true if this deque contains at least one element e such that o.equals(e).
contains(Object) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains the specified element.
contains(Object) - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedBlockingDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedTransferQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.PriorityBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.SynchronousQueue
Always returns false.
contains(Object) - Method in interface java.util.Deque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.HashSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.Hashtable
Tests if some key maps into the specified value in this hashtable.
contains(Object) - Method in class java.util.LinkedList
Returns true if this list contains the specified element.
contains(Object) - Method in interface java.util.List
Returns true if this list contains the specified element.
contains(Object) - Method in class java.util.PriorityQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in interface java.util.Set
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.TreeSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.Vector
Returns true if this vector contains the specified element.
contains(Point) - Method in interface javax.accessibility.AccessibleComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(String) - Method in class javax.accessibility.AccessibleRelationSet
Returns whether the relation set contains a relation that matches the specified key.
contains(AccessibleState) - Method in class javax.accessibility.AccessibleStateSet
Checks if the current state is in the state set.
contains(Object) - Method in class javax.imageio.spi.ServiceRegistry
Returns true if provider is currently registered.
contains(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type argument contains another.
contains(Object) - Method in interface javax.naming.directory.Attribute
Determines whether a value is in the attribute.
contains(Object) - Method in class javax.naming.directory.BasicAttribute
Determines whether a value is in this attribute.
contains(int) - Method in class javax.print.attribute.SetOfIntegerSyntax
Determine if this set-of-integer attribute contains the given value.
contains(IntegerSyntax) - Method in class javax.print.attribute.SetOfIntegerSyntax
Determine if this set-of-integer attribute contains the given integer attribute's value.
contains(Object) - Method in class javax.swing.DefaultListModel
Tests whether the specified object is a component in this list.
contains(int, int) - Method in class javax.swing.JComponent
Gives the UI delegate an opportunity to define the precise shape of this component for the sake of mouse processing.
contains(Point) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
contains(Point) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
contains(Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
contains(JComponent, int, int) - Method in class javax.swing.plaf.ComponentUI
Returns true if the specified x,y location is contained within the look and feel's defined shape of the specified component.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the contains method on each UI handled by this object.
contains(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
contains(String) - Method in interface org.w3c.dom.DOMStringList
Test if a string is part of this DOMStringList.
contains(String) - Method in interface org.w3c.dom.NameList
Test if a name is part of this NameList.
containsAlias(String) - Method in class java.security.KeyStore
Checks if the given alias exists in this keystore.
containsAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
Tests to see if all objects in the specified Collection are children of this BeanContext.
containsAll(Collection<?>) - Method in class java.util.AbstractCollection
Returns true if this collection contains all of the elements in the specified collection.
containsAll(Collection<?>) - Method in interface java.util.Collection
Returns true if this collection contains all of the elements in the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.SynchronousQueue
Returns false unless the given collection is empty.
containsAll(Collection<?>) - Method in interface java.util.List
Returns true if this list contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in interface java.util.Set
Returns true if this set contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.Vector
Returns true if this Vector contains all of the elements in the specified Collection.
containsAngle(double) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified angle is within the angular extents of the arc.
containsAttribute(Object, Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether a given attribute name/value is defined.
containsAttribute(Object, Object) - Method in interface javax.swing.text.AttributeSet
Returns true if this set defines an attribute with the same name and an equal value.
containsAttribute(Object, Object) - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the attribute list contains a specified attribute name/value pair.
containsAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether a given attribute name/value is defined.
containsAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether a given attribute name/value is defined.
containsAttributes(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether the element contains all the attributes.
containsAttributes(AttributeSet) - Method in interface javax.swing.text.AttributeSet
Returns true if this set defines all the attributes from the given set with equal values.
containsAttributes(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the attribute list contains all the specified name/value pairs.
containsAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether the element contains all the attributes.
containsAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether the attribute set contains all of the given attributes.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Returns true if in the last call to validateComponent the message or buttons contained a subclass of Component.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the containsCustomComponents method on each UI handled by this object.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.OptionPaneUI
Returns true if the user has supplied instances of Component for either the options or message.
containsKey(Object) - Method in class java.awt.RenderingHints
Returns true if this RenderingHints contains a mapping for the specified key.
containsKey(Object) - Method in class java.beans.beancontext.BeanContextSupport
Determines whether or not the specified object is currently a child of this BeanContext.
containsKey(Object) - Method in class java.util.AbstractMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Tests if the specified object is a key in this table.
containsKey(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.EnumMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.HashMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.Hashtable
Tests if the specified object is a key in this hashtable.
containsKey(Object) - Method in class java.util.IdentityHashMap
Tests whether the specified object reference is a key in this identity hash map.
containsKey(Object) - Method in class java.util.jar.Attributes
Returns true if this Map contains the specified attribute name (key).
containsKey(Object) - Method in interface java.util.Map
Returns true if this map contains a mapping for the specified key.
containsKey(String) - Method in class java.util.ResourceBundle
Determines whether the given key is contained in this ResourceBundle or its parent bundles.
containsKey(Object) - Method in class java.util.TreeMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.WeakHashMap
Returns true if this map contains a mapping for the specified key.
containsKey(String) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeType
Returns true if this CompositeType instance defines an item whose name is itemName.
containsKey(Object[]) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object[]) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Class<?>) - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains an attribute for the specified category.
containsKey(Class<?>) - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains an attribute for the specified category.
containsKey(Object) - Method in interface javax.script.Bindings
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class javax.script.SimpleBindings
Returns true if this map contains a mapping for the specified key.
containsNS(String, String) - Method in interface org.w3c.dom.NameList
Test if the pair namespaceURI/name is part of this NameList.
containsObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Tests whether the specified object is in the set of observed MBeans.
containsObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Tests whether the specified object is in the set of observed MBeans.
containsValue(Object) - Method in class java.awt.RenderingHints
Returns true if this RenderingHints maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.AbstractMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.EnumMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.HashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.Hashtable
Returns true if this hashtable maps one or more keys to this value.
containsValue(Object) - Method in class java.util.IdentityHashMap
Tests whether the specified object reference is a value in this identity hash map.
containsValue(Object) - Method in class java.util.jar.Attributes
Returns true if this Map maps one or more attribute names (keys) to the specified value.
containsValue(Object) - Method in class java.util.LinkedHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in interface java.util.Map
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.TreeMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.WeakHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(CompositeData) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified value.
containsValue(Attribute) - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains the given attribute value.
containsValue(Attribute) - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains the given attribute.
containsValue(Object) - Method in class javax.script.SimpleBindings
Returns true if this map maps one or more keys to the specified value.
CONTENT - Static variable in class javax.swing.text.html.HTML.Attribute
CONTENT - Static variable in class javax.swing.text.html.HTML.Tag
All text content is labeled with this tag.
content - Variable in class javax.swing.text.html.parser.ContentModel
The content.
content - Variable in class javax.swing.text.html.parser.Element
CONTENT_AREA_FILLED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the button paint the content area.
CONTENT_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
CONTENT_TYPE - Static variable in class java.util.jar.Attributes.Name
Name object for Content-Type manifest attribute.
content_type() - Method in class org.omg.CORBA.TypeCode
Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
contentBorderInsets - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
ContentElementName - Static variable in class javax.swing.text.AbstractDocument
Name of elements used to represent content
contentEquals(StringBuffer) - Method in class java.lang.String
Compares this string to the specified StringBuffer.
contentEquals(CharSequence) - Method in class java.lang.String
Compares this string to the specified CharSequence.
contentEquals(CharSequence) - Method in interface javax.lang.model.element.Name
Compares this name to the specified CharSequence.
ContentHandler - Class in java.net
The abstract class ContentHandler is the superclass of all classes that read an Object from a URLConnection.
ContentHandler() - Constructor for class java.net.ContentHandler
ContentHandler - Interface in org.xml.sax
Receive notification of the logical content of a document.
ContentHandlerFactory - Interface in java.net
This interface defines a factory for content handlers.
ContentModel - Class in javax.swing.text.html.parser
A representation of a content model.
ContentModel() - Constructor for class javax.swing.text.html.parser.ContentModel
ContentModel(Element) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model for an element.
ContentModel(int, ContentModel) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model of a particular type.
ContentModel(int, Object, ContentModel) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model of a particular type.
contentPane - Variable in class javax.swing.JRootPane
The content pane.
contentRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
contents - Variable in class java.awt.datatransfer.Clipboard
CONTENTS_CHANGED - Static variable in class javax.swing.event.ListDataEvent
Identifies one or more changes in the lists contents.
contentsChanged(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
contentsChanged(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
contentsChanged(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener contents changed method.
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
contentsLost() - Method in class java.awt.Component.BltBufferStrategy
contentsLost() - Method in class java.awt.Component.FlipBufferStrategy
contentsLost() - Method in class java.awt.image.BufferStrategy
Returns whether the drawing buffer was lost since the last call to getDrawGraphics.
contentsLost() - Method in class java.awt.image.VolatileImage
Returns true if rendering data was lost since last validate call.
contentsRestored() - Method in class java.awt.Component.BltBufferStrategy
contentsRestored() - Method in class java.awt.Component.FlipBufferStrategy
contentsRestored() - Method in class java.awt.image.BufferStrategy
Returns whether the drawing buffer was recently restored from a lost state and reinitialized to the default background color (white).
ContentType - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getType.
context - Variable in class java.awt.dnd.DropTargetEvent
The DropTargetContext associated with this DropTargetEvent.
context() - Method in interface java.nio.file.WatchEvent
Returns the context for the event.
Context - Interface in javax.naming
This interface represents a naming context, which consists of a set of name-to-object bindings.
context - Variable in class javax.script.AbstractScriptEngine
The default ScriptContext of this AbstractScriptEngine.
Context - Class in org.omg.CORBA
An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
Context() - Constructor for class org.omg.CORBA.Context
context_data - Variable in class org.omg.IOP.ServiceContext
The data associated with this service context
CONTEXT_EXPIRED - Static variable in exception org.ietf.jgss.GSSException
Security context expired.
context_id - Variable in class org.omg.IOP.ServiceContext
The service context id
context_name() - Method in class org.omg.CORBA.Context
Retrieves the name of this Context object.
ContextList - Class in org.omg.CORBA
An object containing a modifiable list of String objects that represent property names.
ContextList() - Constructor for class org.omg.CORBA.ContextList
ContextNotEmptyException - Exception in javax.naming
This exception is thrown when attempting to destroy a context that is not empty.
ContextNotEmptyException(String) - Constructor for exception javax.naming.ContextNotEmptyException
Constructs a new instance of ContextNotEmptyException using an explanation.
ContextNotEmptyException() - Constructor for exception javax.naming.ContextNotEmptyException
Constructs a new instance of ContextNotEmptyException with all name resolution fields and explanation initialized to null.
contexts() - Method in class org.omg.CORBA.Request
Retrieves the ContextList object for this request.
contexts() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of String objects describing the contexts that may be passed on this operation invocation.
ContextualRenderedImageFactory - Interface in java.awt.image.renderable
ContextualRenderedImageFactory provides an interface for the functionality that may differ between instances of RenderableImageOp.
CONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree.TreeSelectionModel
Selection can only be contiguous.
CONTINUE - Static variable in class javax.sound.midi.ShortMessage
Status byte for Continue message (0xFB, or 251).
continueDrag(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
continueDrag(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Messages dragDividerTo with the new location for the mouse event.
CONTINUOUS_LAYOUT_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property name for continuousLayout.
continuousLayout - Variable in class javax.swing.JSplitPane
Whether or not the views are continuously redisplayed while resizing.
contListener - Variable in class javax.swing.plaf.metal.MetalToolBarUI
This protected field is implemenation specific.
CONTROL - Static variable in class java.awt.SystemColor
The array index for the SystemColor.control system color.
control - Static variable in class java.awt.SystemColor
The color rendered for the background of control panels and control objects, such as pushbuttons.
CONTROL - Static variable in class java.lang.Character
General category "Cc" in the Unicode specification.
Control - Interface in javax.naming.ldap
This interface represents an LDAPv3 control as defined in RFC 2251.
Control - Class in javax.sound.sampled
Lines often have a set of controls, such as gain and pan, that affect the audio signal passing through the line.
Control(Control.Type) - Constructor for class javax.sound.sampled.Control
Constructs a Control with the specified type.
Control.Type - Class in javax.sound.sampled
An instance of the Type class represents the type of the control.
Control.Type(String) - Constructor for class javax.sound.sampled.Control.Type
Constructs a new control type with the name specified.
CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Instruction to display the control buttons.
CONTROL_CHANGE - Static variable in class javax.sound.midi.ShortMessage
Command value for Control Change message (0xB0, or 176)
CONTROL_DK_SHADOW - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlDkShadow system color.
CONTROL_FACTORIES - Static variable in interface javax.naming.ldap.LdapContext
Constant that holds the name of the environment property for specifying the list of control factories to use.
CONTROL_HIGHLIGHT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlHighlight system color.
CONTROL_LT_HIGHLIGHT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlLtHighlight system color.
CONTROL_PICTURES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Control Pictures" Unicode character block.
CONTROL_SHADOW - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlShadow system color.
CONTROL_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlText system color.
controlChange(ShortMessage) - Method in interface javax.sound.midi.ControllerEventListener
Invoked when a Sequencer has encountered and processed a control-change event of interest to this listener.
controlChange(int, int) - Method in interface javax.sound.midi.MidiChannel
Reacts to a change in the specified controller's value.
controlDkShadow - Static variable in class java.awt.SystemColor
The color rendered for dark shadow areas on 3D control objects, such as pushbuttons.
controlDown() - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatilibility.
ControlFactory - Class in javax.naming.ldap
This abstract class represents a factory for creating LDAPv3 controls.
ControlFactory() - Constructor for class javax.naming.ldap.ControlFactory
controlHighlight - Static variable in class java.awt.SystemColor
The color rendered for light areas of 3D control objects, such as pushbuttons.
CONTROLLED_BY - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is controlled by one or more target objects.
CONTROLLED_BY_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the target object that is doing the controlling has changed
controller - Variable in class javax.imageio.IIOParam
The IIOParamController that will be used to provide settings for this IIOParam object when the activateController method is called.
controller - Variable in class javax.imageio.metadata.IIOMetadata
The IIOMetadataController that will be used to provide settings for this IIOMetadata object when the activateController method is called.
CONTROLLER_FOR - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is a controller for one or more target objects.
CONTROLLER_FOR_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the controller for the target object has changed
ControllerEventListener - Interface in javax.sound.midi
The ControllerEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a requested type of MIDI control-change event.
controlLtHighlight - Static variable in class java.awt.SystemColor
The color rendered for highlight areas of 3D control objects, such as pushbuttons.
controlShadow - Static variable in class java.awt.SystemColor
The color rendered for shadow areas of 3D control objects, such as pushbuttons.
controlText - Static variable in class java.awt.SystemColor
The color rendered for the text of control panels and control objects, such as pushbuttons.
convert(long, TimeUnit) - Method in enum java.util.concurrent.TimeUnit
Convert the given time duration in the given unit to this unit.
convertArguments(MethodHandle, MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which adapts the type of the given method handle to a new type by pairwise argument conversion.
convertColumnIndexToModel(int) - Method in class javax.swing.JTable
Maps the index of the column in the view at viewColumnIndex to the index of the column in the table model.
convertColumnIndexToView(int) - Method in class javax.swing.JTable
Maps the index of the column in the table model at modelColumnIndex to the index of the column in the view.
CONVERTED_TEXT - Static variable in class java.awt.im.InputMethodHighlight
Constant for the converted text state.
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in interface javax.imageio.ImageTranscoder
Returns an IIOMetadata object that may be used for encoding and optionally modified using its document interfaces or other interfaces specific to the writer plug-in that will be used for encoding.
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio.ImageWriter
convertMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup
convertMouseEvent(Component, MouseEvent, Component) - Static method in class javax.swing.SwingUtilities
Returns a MouseEvent similar to sourceEvent except that its x and y members have been converted to destination's coordinate system.
convertPoint(Component, Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a aPoint in source coordinate system to destination coordinate system.
convertPoint(Component, int, int, Component) - Static method in class javax.swing.SwingUtilities
Convert the point (x,y) in source coordinate system to destination coordinate system.
convertPointFromScreen(Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a point from a screen coordinates to a component's coordinate system
convertPointToScreen(Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a point from a component's coordinate system to screen coordinates.
convertPreviousRowIndexToModel(int) - Method in class javax.swing.event.RowSorterEvent
Returns the location of index in terms of the model prior to the sort.
convertRectangle(Component, Rectangle, Component) - Static method in class javax.swing.SwingUtilities
Convert the rectangle aRectangle in source coordinate system to destination coordinate system.
convertRowIndexToModel(int) - Method in class javax.swing.DefaultRowSorter
Returns the location of index in terms of the underlying model.
convertRowIndexToModel(int) - Method in class javax.swing.JTable
Maps the index of the row in terms of the view to the underlying TableModel.
convertRowIndexToModel(int) - Method in class javax.swing.RowSorter
Returns the location of index in terms of the underlying model.
convertRowIndexToView(int) - Method in class javax.swing.DefaultRowSorter
Returns the location of index in terms of the view.
convertRowIndexToView(int) - Method in class javax.swing.JTable
Maps the index of the row in terms of the TableModel to the view.
convertRowIndexToView(int) - Method in class javax.swing.RowSorter
Returns the location of index in terms of the view.
convertRowToY(int) - Method in class javax.swing.plaf.basic.BasicListUI
Return the JList relative Y coordinate of the origin of the specified row or -1 if row isn't valid.
convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in interface javax.imageio.ImageTranscoder
Returns an IIOMetadata object that may be used for encoding and optionally modified using its document interfaces or other interfaces specific to the writer plug-in that will be used for encoding.
convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in class javax.imageio.ImageWriter
convertToIntDiscrete(Raster, boolean) - Method in class java.awt.image.IndexColorModel
Returns a new BufferedImage of TYPE_INT_ARGB or TYPE_INT_RGB that has a Raster with pixel data computed by expanding the indices in the source Raster using the color/alpha component arrays of this ColorModel.
convertToVector(Object[]) - Static method in class javax.swing.table.DefaultTableModel
Returns a vector that contains the same objects as the array.
convertToVector(Object[][]) - Static method in class javax.swing.table.DefaultTableModel
Returns a vector of vectors that contains the same objects as the array.
convertValueToText(Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing.JTree
Called by the renderers to convert the specified value to text.
convertYToRow(int) - Method in class javax.swing.plaf.basic.BasicListUI
Convert the JList relative coordinate to the row that contains it, based on the current layout.
ConvolveOp - Class in java.awt.image
This class implements a convolution from the source to the destination.
ConvolveOp(Kernel, int, RenderingHints) - Constructor for class java.awt.image.ConvolveOp
Constructs a ConvolveOp given a Kernel, an edge condition, and a RenderingHints object (which may be null).
ConvolveOp(Kernel) - Constructor for class java.awt.image.ConvolveOp
Constructs a ConvolveOp given a Kernel.
CookieHandler - Class in java.net
A CookieHandler object provides a callback mechanism to hook up a HTTP state management policy implementation into the HTTP protocol handler.
CookieHandler() - Constructor for class java.net.CookieHandler
CookieHolder - Class in org.omg.PortableServer.ServantLocatorPackage
The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
CookieHolder() - Constructor for class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
CookieHolder(Object) - Constructor for class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
CookieManager - Class in java.net
CookieManager provides a concrete implementation of CookieHandler, which separates the storage of cookies from the policy surrounding accepting and rejecting cookies.
CookieManager() - Constructor for class java.net.CookieManager
Create a new cookie manager.
CookieManager(CookieStore, CookiePolicy) - Constructor for class java.net.CookieManager
Create a new cookie manager with specified cookie store and cookie policy.
CookiePolicy - Interface in java.net
CookiePolicy implementations decide which cookies should be accepted and which should be rejected.
CookieStore - Interface in java.net
A CookieStore object represents a storage for cookie.
COORDS - Static variable in class javax.swing.text.html.HTML.Attribute
COPIED - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are COPIED, the contents of the back buffer are copied to the front buffer when flipping.
Copies - Class in javax.print.attribute.standard
Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
Copies(int) - Constructor for class javax.print.attribute.standard.Copies
Construct a new copies attribute with the given integer value.
CopiesSupported - Class in javax.print.attribute.standard
Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute.
CopiesSupported(int) - Constructor for class javax.print.attribute.standard.CopiesSupported
Construct a new copies supported attribute containing a single integer.
CopiesSupported(int, int) - Constructor for class javax.print.attribute.standard.CopiesSupported
Construct a new copies supported attribute containing a single range of integers.
COPTIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Coptic" Unicode character block.
copy(Path, Path, CopyOption...) - Static method in class java.nio.file.Files
Copy a file to a target file.
copy(InputStream, Path, CopyOption...) - Static method in class java.nio.file.Files
Copies all bytes from an input stream to a file.
copy(Path, OutputStream) - Static method in class java.nio.file.Files
Copies all bytes from a file to an output stream.
copy(Path, Path, CopyOption...) - Method in class java.nio.file.spi.FileSystemProvider
Copy a file to a target file.
copy(List<? super T>, List<? extends T>) - Static method in class java.util.Collections
Copies all of the elements from one list into another.
copy() - Method in class javax.swing.JPasswordField
Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
copy - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
copy() - Method in class javax.swing.text.JTextComponent
Transfers the currently selected range in the associated text model to the system clipboard, leaving the contents in the text model.
COPY - Static variable in class javax.swing.TransferHandler
An int representing a "copy" transfer action.
copy() - Method in class org.omg.CORBA._PolicyStub
Copies the policy object.
copy() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Clones this DynAny object.
copy() - Method in interface org.omg.CORBA.PolicyOperations
Returns a copy of the Policy object.
copy() - Method in class org.omg.DynamicAny._DynAnyStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynArrayStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynEnumStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynFixedStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynSequenceStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynStructStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynUnionStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynValueStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in interface org.omg.DynamicAny.DynAnyOperations
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
COPY_OR_MOVE - Static variable in class javax.swing.TransferHandler
An int representing a source action capability of either "copy" or "move".
copyAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to copy the selected region and place the contents into the system clipboard.
copyArea(int, int, int, int, int, int) - Method in class java.awt.Graphics
Copies an area of the component by a distance specified by dx and dy.
copyArea(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.copyArea.
copyAttributes() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Copies a set of attributes.
copyAttributes() - Method in interface javax.swing.text.AttributeSet
Returns an attribute set that is guaranteed not to change over time.
copyAttributes() - Method in class javax.swing.text.SimpleAttributeSet
Makes a copy of the attributes.
copyAttributes() - Method in class javax.swing.text.StyleContext.NamedStyle
Copies a set of attributes.
copyAttributes() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Copies a set of attributes.
copyChildren() - Method in class java.beans.beancontext.BeanContextSupport
Gets a copy of the this BeanContext's children.
copyData(WritableRaster) - Method in class java.awt.image.BufferedImage
Computes an arbitrary rectangular region of the BufferedImage and copies it into a specified WritableRaster.
copyData(WritableRaster) - Method in interface java.awt.image.RenderedImage
Computes an arbitrary rectangular region of the RenderedImage and copies it into a caller-supplied WritableRaster.
copyInto(Object[]) - Method in class java.util.Vector
Copies the components of this vector into the specified array.
copyInto(Object[]) - Method in class javax.swing.DefaultListModel
Copies the components of this list into the specified array.
copyObject(Object, ORB) - Static method in class javax.rmi.CORBA.Util
Copies or connects an object.
copyObject(Object, ORB) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
copyObjects(Object[], ORB) - Static method in class javax.rmi.CORBA.Util
Copies or connects an array of objects.
copyObjects(Object[], ORB) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
copyOf(T[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with nulls (if necessary) so the copy has the specified length.
copyOf(U[], int, Class<? extends T[]>) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with nulls (if necessary) so the copy has the specified length.
copyOf(byte[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(short[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(int[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(long[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(char[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with null characters (if necessary) so the copy has the specified length.
copyOf(float[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(double[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(boolean[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with false (if necessary) so the copy has the specified length.
copyOf(EnumSet<E>) - Static method in class java.util.EnumSet
Creates an enum set with the same element type as the specified enum set, initially containing the same elements (if any).
copyOf(Collection<E>) - Static method in class java.util.EnumSet
Creates an enum set initialized from the specified collection.
copyOfRange(T[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(U[], int, int, Class<? extends T[]>) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(byte[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(short[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(int[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(long[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(char[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(float[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(double[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(boolean[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
CopyOnWriteArrayList<E> - Class in java.util.concurrent
A thread-safe variant of ArrayList in which all mutative operations (add, set, and so on) are implemented by making a fresh copy of the underlying array.
CopyOnWriteArrayList() - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates an empty list.
CopyOnWriteArrayList(Collection<? extends E>) - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates a list containing the elements of the specified collection, in the order they are returned by the collection's iterator.
CopyOnWriteArrayList(E[]) - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates a list holding a copy of the given array.
CopyOnWriteArraySet<E> - Class in java.util.concurrent
A Set that uses an internal CopyOnWriteArrayList for all of its operations.
CopyOnWriteArraySet() - Constructor for class java.util.concurrent.CopyOnWriteArraySet
Creates an empty set.
CopyOnWriteArraySet(Collection<? extends E>) - Constructor for class java.util.concurrent.CopyOnWriteArraySet
Creates a set containing all of the elements of the specified collection.
CopyOption - Interface in java.nio.file
An object that configures how to copy or move a file.
copySign(double, double) - Static method in class java.lang.Math
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(float, float) - Static method in class java.lang.Math
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(double, double) - Static method in class java.lang.StrictMath
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(float, float) - Static method in class java.lang.StrictMath
Returns the first floating-point argument with the sign of the second floating-point argument.
copyValueOf(char[], int, int) - Static method in class java.lang.String
Returns a String that represents the character sequence in the array specified.
copyValueOf(char[]) - Static method in class java.lang.String
Returns a String that represents the character sequence in the array specified.
cos(double) - Static method in class java.lang.Math
Returns the trigonometric cosine of an angle.
cos(double) - Static method in class java.lang.StrictMath
Returns the trigonometric cosine of an angle.
cosh(double) - Static method in class java.lang.Math
Returns the hyperbolic cosine of a double value.
cosh(double) - Static method in class java.lang.StrictMath
Returns the hyperbolic cosine of a double value.
count - Variable in class java.io.BufferedInputStream
The index one greater than the index of the last valid byte in the buffer.
count - Variable in class java.io.BufferedOutputStream
The number of valid bytes in the buffer.
count - Variable in class java.io.ByteArrayInputStream
The index one greater than the last valid character in the input stream buffer.
count - Variable in class java.io.ByteArrayOutputStream
The number of valid bytes in the buffer.
count - Variable in class java.io.CharArrayReader
The index of the end of this buffer.
count - Variable in class java.io.CharArrayWriter
The number of chars in the buffer.
count - Variable in class java.io.StringBufferInputStream
Deprecated.
The number of valid characters in the input stream buffer.
count() - Method in interface java.nio.file.WatchEvent
Returns the event count.
count - Variable in class javax.swing.text.Segment
This is the number of array elements that make up the text of interest.
count() - Method in class org.omg.CORBA.ContextList
Returns the number of String objects in this ContextList object.
count() - Method in class org.omg.CORBA.ExceptionList
Retrieves the number of TypeCode objects in this ExceptionList object.
count() - Method in class org.omg.CORBA.NVList
Returns the number of NamedValue objects that have been added to this NVList object.
countAttachments() - Method in class javax.xml.soap.SOAPMessage
Gets a count of the number of attachments in this message.
countComponents() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getComponentCount().
countDown() - Method in class java.util.concurrent.CountDownLatch
Decrements the count of the latch, releasing all waiting threads if the count reaches zero.
CountDownLatch - Class in java.util.concurrent
A synchronization aid that allows one or more threads to wait until a set of operations being performed in other threads completes.
CountDownLatch(int) - Constructor for class java.util.concurrent.CountDownLatch
Constructs a CountDownLatch initialized with the given count.
CounterMonitor - Class in javax.management.monitor
Defines a monitor MBean designed to observe the values of a counter attribute.
CounterMonitor() - Constructor for class javax.management.monitor.CounterMonitor
Default constructor.
CounterMonitorMBean - Interface in javax.management.monitor
Exposes the remote management interface of the counter monitor MBean.
COUNTING_ROD_NUMERALS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Counting Rod Numerals" Unicode character block.
countItems() - Method in class java.awt.Choice
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countItems() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countItems() - Method in class java.awt.Menu
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countMenus() - Method in class java.awt.MenuBar
Deprecated.
As of JDK version 1.1, replaced by getMenuCount().
countObservers() - Method in class java.util.Observable
Returns the number of observers of this Observable object.
countStackFrames() - Method in class java.lang.Thread
Deprecated.
The definition of this call depends on Thread.suspend(), which is deprecated. Further, the results of this call were never well-defined.
countTokens() - Method in class java.util.StringTokenizer
Calculates the number of times that this tokenizer's nextToken method can be called before it generates an exception.
COVER - Static variable in class javax.print.attribute.standard.Finishings
This value is specified when it is desired to select a non-printed (or pre-printed) cover for the document.
COVER_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more covers on the device are open.
CPE - Static variable in class javax.naming.spi.NamingManager
Constant that holds the name of the environment property into which getContinuationContext() stores the value of its CannotProceedException parameter.
crc - Variable in class java.util.zip.GZIPInputStream
CRC-32 for uncompressed data.
crc - Variable in class java.util.zip.GZIPOutputStream
CRC-32 of uncompressed data.
CRC32 - Class in java.util.zip
A class that can be used to compute the CRC-32 of a data stream.
CRC32() - Constructor for class java.util.zip.CRC32
Creates a new CRC32 object.
create() - Method in class java.awt.Graphics
Creates a new Graphics object that is a copy of this Graphics object.
create(int, int, int, int) - Method in class java.awt.Graphics
Creates a new Graphics object based on this Graphics object, but with a new translation and clip area.
create(RenderContext, ParameterBlock) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory
Creates a rendering, given a RenderContext and a ParameterBlock containing the operation's sources and parameters.
create(ParameterBlock, RenderingHints) - Method in interface java.awt.image.renderable.RenderedImageFactory
Creates a RenderedImage representing the results of an imaging operation (or chain of operations) for a given ParameterBlock and RenderingHints.
create(Class<T>, Object, String) - Static method in class java.beans.EventHandler
Creates an implementation of listenerInterface in which all of the methods in the listener interface apply the handler's action to the target.
create(Class<T>, Object, String, String) - Static method in class java.beans.EventHandler
/** Creates an implementation of listenerInterface in which all of the methods pass the value of the event expression, eventPropertyName, to the final method in the statement, action, which is applied to the target.
create(Class<T>, Object, String, String, String) - Static method in class java.beans.EventHandler
Creates an implementation of listenerInterface in which the method named listenerMethodName passes the value of the event expression, eventPropertyName, to the final method in the statement, action, which is applied to the target.
create() - Method in class java.net.DatagramSocketImpl
Creates a datagram socket.
create(boolean) - Method in class java.net.SocketImpl
Creates either a stream or a datagram socket.
create(String) - Static method in class java.net.URI
Creates a URI by parsing the given string.
create() - Method in class javax.swing.DebugGraphics
Overrides Graphics.create to return a DebugGraphics object.
create(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.create to return a DebugGraphics object.
create(Element) - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Creates a view (PasswordView) for an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextAreaUI
Creates the view for an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextFieldUI
Creates a view (FieldView) based on an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextUI
Creates a view for an element.
create(Element, int, int) - Method in class javax.swing.plaf.basic.BasicTextUI
Creates a view for an element.
create(Element) - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI
Creates a view (PasswordView) for an element.
create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument
Initialize the document to reflect the given element structure (i.e.
create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html.HTMLDocument
Replaces the contents of the document with the given element specifications.
create(Element) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLFactory
Creates a view from an element.
create(Element) - Method in interface javax.swing.text.ViewFactory
Creates a view from the given structural element of a document.
create(Name) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
create(String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
create(String, String, String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
create(Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified implementor object.
create(Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified implementor object and web service features.
create(String, Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified binding type and implementor object.
create(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified binding type, implementor object, and web service features.
create(URL, QName) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(URL, QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(QName) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create_abstract_interface_tc(String, String) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL abstract interface.
create_alias_tc(String, String, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL alias (typedef).
create_any() - Method in class org.omg.CORBA.ORB
Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
create_array_tc(int, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL array.
create_basic_dyn_any(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_child(String) - Method in class org.omg.CORBA.Context
Creates a Context object with the given string as its name and with this Context object set as its parent.
create_codec(Encoding) - Method in interface org.omg.IOP.CodecFactoryOperations
Create a Codec of the given encoding.
create_context_list() - Method in class org.omg.CORBA.ORB
Creates an empty ContextList object.
create_dyn_any(Any) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_any(Any) - Method in class org.omg.DynamicAny._DynAnyFactoryStub
Creates a new DynAny object from an any value.
create_dyn_any(Any) - Method in interface org.omg.DynamicAny.DynAnyFactoryOperations
Creates a new DynAny object from an any value.
create_dyn_any_from_type_code(TypeCode) - Method in class org.omg.DynamicAny._DynAnyFactoryStub
Creates a DynAny from a TypeCode.
create_dyn_any_from_type_code(TypeCode) - Method in interface org.omg.DynamicAny.DynAnyFactoryOperations
Creates a DynAny from a TypeCode.
create_dyn_array(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_enum(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_sequence(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_struct(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_union(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_enum_tc(String, String, String[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL enum.
create_environment() - Method in class org.omg.CORBA.ORB
Creates an Environment object.
create_exception_list() - Method in class org.omg.CORBA.ORB
Creates an empty ExceptionList object.
create_exception_tc(String, String, StructMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL exception.
create_fixed_tc(short, short) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL fixed type.
create_id_assignment_policy(IdAssignmentPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_id_uniqueness_policy(IdUniquenessPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_implicit_activation_policy(ImplicitActivationPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_input_stream() - Method in class org.omg.CORBA.Any
Creates an input stream from which this Any object's value can be unmarshalled.
create_input_stream() - Method in class org.omg.CORBA.portable.OutputStream
Returns an input stream with the same buffer.
create_interface_tc(String, String) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL 接口.
create_lifespan_policy(LifespanPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_list(int) - Method in class org.omg.CORBA.ORB
Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
create_named_value(String, Any, int) - Method in class org.omg.CORBA.ORB
Creates a NamedValue object using the given name, value, and argument mode flags.
create_native_tc(String, String) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL native type.
create_operation_list(Object) - Method in class org.omg.CORBA.ORB
Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
create_output_stream() - Method in class org.omg.CORBA.Any
Creates an output stream into which this Any object's value can be marshalled.
create_output_stream() - Method in class org.omg.CORBA.ORB
Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
create_POA(String, POAManager, Policy[]) - Method in interface org.omg.PortableServer.POAOperations
This operation creates a new POA as a child of the target POA.
create_policy(int, Any) - Method in class org.omg.CORBA.ORB
Can be invoked to create new instances of policy objects of a specific type with specified initial state.
create_policy(int, Any) - Method in interface org.omg.PortableInterceptor.PolicyFactoryOperations
Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
create_recursive_sequence_tc(int, int) - Method in class org.omg.CORBA.ORB
Deprecated.
Use a combination of create_recursive_tc and create_sequence_tc instead
create_recursive_tc(String) - Method in class org.omg.CORBA.ORB
Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
create_reference(String) - Method in interface org.omg.PortableServer.POAOperations
This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
create_reference_with_id(byte[], String) - Method in interface org.omg.PortableServer.POAOperations
This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
create_request(Object, Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable.Delegate
Creates a Request instance for use in the Dynamic Invocation Interface.
create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable.Delegate
Creates a Request instance for use in the Dynamic Invocation Interface.
create_request_processing_policy(RequestProcessingPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_sequence_tc(int, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL sequence.
create_servant_retention_policy(ServantRetentionPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_string_tc(int) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing a bounded IDL string.
create_struct_tc(String, String, StructMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL struct.
create_thread_policy(ThreadPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_union_tc(String, String, TypeCode, UnionMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL union.
create_value_box_tc(String, String, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object for an IDL value box.
create_value_tc(String, String, short, TypeCode, ValueMember[]) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL value type.
create_wstring_tc(int) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing a bounded IDL wstring (wide string).
createActionChangeListener(JMenuItem) - Method in class javax.swing.JMenu
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
createActionChangeListener(JMenuItem) - Method in class javax.swing.JPopupMenu
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
createActionChangeListener(JButton) - Method in class javax.swing.JToolBar
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur, or null if the default property change listener for the control is desired.
createActionComponent(Action) - Method in class javax.swing.JMenu
Factory method which creates the JMenuItem for Actions added to the JMenu.
createActionComponent(Action) - Method in class javax.swing.JPopupMenu
Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
createActionComponent(Action) - Method in class javax.swing.JToolBar
Factory method which creates the JButton for Actions added to the JToolBar.
createActionListener() - Method in class javax.swing.AbstractButton
createActionMap() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createActionPropertyChangeListener(Action) - Method in class javax.swing.AbstractButton
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActionPropertyChangeListener(Action) - Method in class javax.swing.JComboBox
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActionPropertyChangeListener(Action) - Method in class javax.swing.JTextField
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createAndPublishEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates and publishes an endpoint object with the specified address and implementation object.
createAndPublishEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates and publishes an endpoint object with the specified address, implementation object and web service features.
createArrayOf(String, Object[]) - Method in interface java.sql.Connection
Factory method for creating Array objects.
createArrowButton() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a button which will be used as the control to show or hide the popup portion of the combo box.
createArrowButton() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createArrowButton() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
createArrowButtonListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createAttachmentPart() - Method in class javax.xml.soap.SOAPMessage
Creates a new empty AttachmentPart object.
createAttachmentPart(DataHandler) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it using the given DataHandler object.
createAttachmentPart(Object, String) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it with the specified data of the specified content type.
createAttribute(String, String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(QName, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(String) - Method in interface org.w3c.dom.Document
Creates an Attr of the given name.
createAttributeNS(String, String) - Method in interface org.w3c.dom.Document
Creates an attribute of the given qualified name and namespace URI.
createAudioAction(Object) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Creates and returns an Action used to play a sound.
createBackBuffers(int) - Method in class java.awt.Component.BltBufferStrategy
Creates the back buffers
createBanded(ColorSpace, int[], int[], int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a banded image format that will use a ComponentColorModel and a BandedSampleModel to store each channel in a separate array.
createBandedRaster(int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified data type, width, height, and number of bands.
createBandedRaster(int, int, int, int, int[], int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified data type, width, height, scanline stride, bank indices and band offsets.
createBandedRaster(DataBuffer, int, int, int, int[], int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified DataBuffer, width, height, scanline stride, bank indices, and band offsets.
createBaselineGroup(boolean, boolean) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup that aligns it's elements along the baseline.
createBCSChild(Object, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport
Subclasses can override this method to insert their own subclass of Child without having to override add() or the other Collection methods that add children to the set.
createBCSChild(Object, Object) - Method in class java.beans.beancontext.BeanContextSupport
Subclasses can override this method to insert their own subclass of Child without having to override add() or the other Collection methods that add children to the set.
createBCSSServiceProvider(Class, BeanContextServiceProvider) - Method in class java.beans.beancontext.BeanContextServicesSupport
subclasses can override this method to create new subclasses of BCSSServiceProvider without having to overrride addService() in order to instantiate.
createBevelBorder(int) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createBevelBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using the specified highlighting and shadowing.
createBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using the specified colors for the inner and outer highlight and shadow areas.
createBinder(Class<T>) - Method in class javax.xml.bind.JAXBContext
Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
createBinder() - Method in class javax.xml.bind.JAXBContext
Creates a Binder for W3C DOM.
createBindings() - Method in interface javax.script.ScriptEngine
Returns an uninitialized Bindings.
createBlackLineBorder() - Static method in class javax.swing.border.LineBorder
Convenience method for getting the Color.black LineBorder of thickness 1.
createBlob() - Method in interface java.sql.Connection
Constructs an object that implements the Blob interface.
createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
Returns the MouseInputAdapter that will be installed on the TitlePane.
createBranchElement(Element, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Creates a document branch element, that can contain other elements.
createBranchElement(Element, AttributeSet) - Method in class javax.swing.text.html.HTMLDocument
Creates a document branch element, that can contain other elements.
createBufferedImage(int, int) - Method in class javax.imageio.ImageTypeSpecifier
Creates a BufferedImage with a given width and height according to the specification embodied in this object.
createBuffers(int, BufferCapabilities) - Method in class java.awt.Component.FlipBufferStrategy
Creates one or more complex, flipping buffers with the given capabilities.
createBufferStrategy(int) - Method in class java.awt.Canvas
Creates a new strategy for multi-buffering on this component.
createBufferStrategy(int, BufferCapabilities) - Method in class java.awt.Canvas
Creates a new strategy for multi-buffering on this component with the required buffer capabilities.
createBufferStrategy(int) - Method in class java.awt.Window
Creates a new strategy for multi-buffering on this component.
createBufferStrategy(int, BufferCapabilities) - Method in class java.awt.Window
Creates a new strategy for multi-buffering on this component with the required buffer capabilities.
createButton(Button) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Button using the specified peer interface.
createButtonActionListener(int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createButtonArea() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates and returns a Container containing the buttons.
createButtonListener(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
createButtonListener(AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
createButtons() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createButtons() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createCachedRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a CachedRowSet.
createCanvas(Canvas) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Canvas using the specified peer interface.
createCaret() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the object to use for a caret.
createCaret() - Method in class javax.swing.text.DefaultEditorKit
Fetches a caret that can navigate through views produced by the associated ViewFactory.
createCaret() - Method in class javax.swing.text.EditorKit
Fetches a caret that can navigate through views produced by the associated ViewFactory.
createCData(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the CData flag set to true
createCDATASection(String) - Method in interface org.w3c.dom.Document
Creates a CDATASection node whose value is the specified string.
createCellEditorListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener to handle events from the current editor.
createCellRendererPane() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns the renderer pane that renderer components are placed in.
createChangeListener() - Method in class javax.swing.AbstractButton
Subclasses that want to handle ChangeEvents differently can override this to return another ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JProgressBar
Subclasses that want to handle change events from the model differently can override this to return an instance of a custom ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JSlider
Subclasses that want to handle ChangeEvents from the model differently can override this to return an instance of a custom ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JTabbedPane
Subclasses that want to handle ChangeEvents differently can override this to return a subclass of ModelListener or another ChangeListener implementation.
createChangeListener() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
createChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createChangeListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createChangeListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createCharacters(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event, this method does not check if the content is all whitespace.
createCheckbox(Checkbox) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Checkbox using the specified peer interface.
createCheckboxMenuItem(CheckboxMenuItem) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of CheckboxMenuItem using the specified peer interface.
createChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image.Raster
Returns a new Raster which shares all or part of this Raster's DataBuffer.
createChildren(DefaultMutableTreeNode, Object) - Static method in class javax.swing.JTree.DynamicUtilTreeNode
Adds to parent all the children in children.
createChildState(View) - Method in class javax.swing.text.AsyncBoxView
New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more
createChoice(Choice) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Choice using the specified peer interface.
createClassFile(CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new class file, and returns an object to allow writing to it.
createClob() - Method in interface java.sql.Connection
Constructs an object that implements the Clob interface.
createComment(String) - Method in class javax.xml.stream.XMLEventFactory
Create a comment
createComment(String) - Method in interface org.w3c.dom.Document
Creates a Comment node given the specified string.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.AffineTransformOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in interface java.awt.image.BufferedImageOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.ColorConvertOp
Creates a zeroed destination image with the correct size and number of bands, given this source.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.ConvolveOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.LookupOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.RescaleOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.AffineTransformOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.BandCombineOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.ColorConvertOp
Creates a zeroed destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.ConvolveOp
Creates a zeroed destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.LookupOp
Creates a zeroed-destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in interface java.awt.image.RasterOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.RescaleOp
Creates a zeroed-destination Raster with the correct size and number of bands, given this source.
createCompatibleImage(int, int) - Method in class java.awt.GraphicsConfiguration
Returns a BufferedImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleImage(int, int, int) - Method in class java.awt.GraphicsConfiguration
Returns a BufferedImage that supports the specified transparency and has a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.BandedSampleModel
Creates a new BandedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ComponentColorModel
Creates a SampleModel with the specified width and height, that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ComponentSampleModel
Creates a new ComponentSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.IndexColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a new MultiPixelPackedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.PackedColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.PixelInterleavedSampleModel
Creates a new PixelInterleavedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.SampleModel
Creates a SampleModel which describes data in this SampleModel's format, but with a different width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.SinglePixelPackedSampleModel
Creates a new SinglePixelPackedSampleModel with the specified width and height.
createCompatibleVolatileImage(int, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleVolatileImage(int, int, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleVolatileImage(int, int, ImageCapabilities) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration, using the specified image capabilities.
createCompatibleVolatileImage(int, int, ImageCapabilities, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration, using the specified image capabilities and transparency value.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.ColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.ComponentColorModel
Creates a WritableRaster with the specified width and height, that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.DirectColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.IndexColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster() - Method in class java.awt.image.Raster
Create a compatible WritableRaster the same size as this Raster with the same SampleModel and a new initialized DataBuffer.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with the specified size, a new SampleModel, and a new initialized DataBuffer.
createCompatibleWritableRaster(Rectangle) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with location (minX, minY) and size (width, height) specified by rect, a new SampleModel, and a new initialized DataBuffer.
createCompatibleWritableRaster(int, int, int, int) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with the specified location (minX, minY) and size (width, height), a new SampleModel, and a new initialized DataBuffer.
createComponent(Component) - Method in class java.awt.Toolkit
Creates a peer for a component or container.
createComponent() - Method in class javax.swing.text.ComponentView
Create the component that is associated with this view.
createComponent() - Method in class javax.swing.text.html.FormView
Create the component.
createComponent() - Method in class javax.swing.text.html.ObjectView
Create the component.
createComponentListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createComponentListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createComponentListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates and returns a new ComponentHandler.
createComponentListener() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
createCompoundBorder() - Static method in class javax.swing.BorderFactory
Creates a compound border with a null inside edge and a null outside edge.
createCompoundBorder(Border, Border) - Static method in class javax.swing.BorderFactory
Creates a compound border specifying the border objects to use for the outside and inside edges.
createCompoundEdit() - Method in class javax.swing.undo.UndoableEditSupport
Called only from beginUpdate.
createConnection() - Method in class javax.xml.soap.SOAPConnectionFactory
Create a new SOAPConnection.
createContainer() - Method in class javax.swing.tree.DefaultTreeCellEditor
Creates the container to manage placement of editingComponent.
createContainerListener() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
createContainerListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
Creates a container listener that will be added to the JToolBar.
createContentHandler(String) - Method in interface java.net.ContentHandlerFactory
Creates a new ContentHandler to read an object from a URLStreamHandler.
createContentPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default contentPane.
createContext(ColorModel, ColorModel, RenderingHints) - Method in class java.awt.AlphaComposite
Creates a context for the compositing operation.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.Color
Creates and returns a PaintContext used to generate a solid color field pattern.
createContext(ColorModel, ColorModel, RenderingHints) - Method in interface java.awt.Composite
Creates a context containing state that is used to perform the compositing operation.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.GradientPaint
Creates and returns a PaintContext used to generate a linear color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.LinearGradientPaint
Creates and returns a PaintContext used to generate a linear color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in interface java.awt.Paint
Creates and returns a PaintContext used to generate the color pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.RadialGradientPaint
Creates and returns a PaintContext used to generate a circular radial color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.TexturePaint
Creates and returns a PaintContext used to generate a tiled image pattern.
createContext(GSSName, Oid, GSSCredential, int) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a context on the initiator's side.
createContext(GSSCredential) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a context on the acceptor' side.
createContext(byte[]) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a previously exported context.
createCopy() - Method in interface javax.sql.rowset.CachedRowSet
Creates a RowSet object that is a deep copy of the data in this CachedRowSet object.
createCopyNoConstraints() - Method in interface javax.sql.rowset.CachedRowSet
Creates a CachedRowSet object that is a deep copy of this CachedRowSet object's data but is independent of it.
createCopySchema() - Method in interface javax.sql.rowset.CachedRowSet
Creates a CachedRowSet object that is an empty copy of this CachedRowSet object.
createCredential(int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring default credentials.
createCredential(GSSName, int, Oid, int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring a single mechanism credential.
createCredential(GSSName, int, Oid[], int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring credentials over a set of mechanisms.
createCustomCursor(Image, Point, String) - Method in class java.awt.Toolkit
Creates a new custom cursor object.
createDashedBorder(Paint) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint.
createDashedBorder(Paint, float, float) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint, relative length, and relative spacing.
createDashedBorder(Paint, float, float, float, boolean) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint, thickness, line shape, relative length, and relative spacing.
createDataBuffer() - Method in class java.awt.image.BandedSampleModel
Creates a DataBuffer that corresponds to this BandedSampleModel, The DataBuffer's data type, number of banks, and size will be consistent with this BandedSampleModel.
createDataBuffer() - Method in class java.awt.image.ComponentSampleModel
Creates a DataBuffer that corresponds to this ComponentSampleModel.
createDataBuffer() - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a DataBuffer that corresponds to this MultiPixelPackedSampleModel.
createDataBuffer() - Method in class java.awt.image.SampleModel
Creates a DataBuffer that corresponds to this SampleModel.
createDataBuffer() - Method in class java.awt.image.SinglePixelPackedSampleModel
Creates a DataBuffer that corresponds to this SinglePixelPackedSampleModel.
createDataContentHandler(String) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String, DataSource) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String) - Method in interface javax.activation.DataContentHandlerFactory
Creates a new DataContentHandler object for the MIME type.
createDataContentHandler(String) - Method in class javax.activation.MailcapCommandMap
Return the DataContentHandler for the specified MIME type.
createDatagramSocketImpl() - Method in interface java.net.DatagramSocketImplFactory
Creates a new DatagramSocketImpl instance.
createdCellEditor - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if editor that is currently in the tree was created by this instance.
createDecreaseButton(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createDecreaseButton(int) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
Returns the view that represents the decrease view.
createDecreaseButton(int) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
createDefaultCellEditor() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a default cell editor.
createDefaultCellEditor() - Method in class javax.swing.plaf.synth.SynthTreeUI
createDefaultCellRenderer() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns the default cell renderer that is used to do the stamping of each node.
createDefaultCellRenderer() - Method in class javax.swing.plaf.synth.SynthTreeUI
createDefaultChoosers() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
createDefaultChoosers() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
createDefaultColumnModel() - Method in class javax.swing.JTable
Returns the default column model object, which is a DefaultTableColumnModel.
createDefaultColumnModel() - Method in class javax.swing.table.JTableHeader
Returns the default column model object which is a DefaultTableColumnModel.
createDefaultColumnsFromModel() - Method in class javax.swing.JTable
Creates default columns for the table from the data model using the getColumnCount method defined in the TableModel interface.
createDefaultDataModel() - Method in class javax.swing.JTable
Returns the default table model object, which is a DefaultTableModel.
createDefaultDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates the default divider.
createDefaultDivider() - Method in class javax.swing.plaf.metal.MetalSplitPaneUI
Creates the default divider.
createDefaultDivider() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Creates the default divider.
createDefaultDocument() - Method in class javax.swing.text.DefaultEditorKit
Creates an uninitialized text storage model (PlainDocument) that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.EditorKit
Creates an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.html.HTMLEditorKit
Create an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.StyledEditorKit
Creates an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDragGestureRecognizer(Component, int, DragGestureListener) - Method in class java.awt.dnd.DragSource
Creates a new DragGestureRecognizer that implements the default abstract subclass of DragGestureRecognizer for this DragSource, and sets the specified Component and DragGestureListener on the newly created object.
createDefaultEditorKit() - Method in class javax.swing.JEditorPane
Creates the default editor kit (PlainEditorKit) for when the component is first created.
createDefaultEditorKit() - Method in class javax.swing.JTextPane
Creates the EditorKit to use by default.
createDefaultEditors() - Method in class javax.swing.JTable
Creates default cell editors for objects, numbers, and boolean values.
createDefaultHeaderRenderer() - Method in class javax.swing.table.TableColumn
As of Java 2 platform v1.3, this method is not called by the TableColumn constructor.
createDefaultKeySelectionManager() - Method in class javax.swing.JComboBox
Returns an instance of the default key-selection manager.
createDefaultModel() - Method in class javax.swing.JTextArea
Creates the default implementation of the model to be used at construction if one isn't explicitly given.
createDefaultModel() - Method in class javax.swing.JTextField
Creates the default implementation of the model to be used at construction if one isn't explicitly given.
createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
createDefaultRenderer() - Method in class javax.swing.table.JTableHeader
Returns a default renderer to be used when no header renderer is defined by a TableColumn.
createDefaultRenderers() - Method in class javax.swing.JTable
Creates default cell renderers for objects, numbers, doubles, dates, booleans, and icons.
createDefaultRendering() - Method in interface java.awt.image.renderable.RenderableImage
Returnd a RenderedImage instance of this image with a default width and height in pixels.
createDefaultRendering() - Method in class java.awt.image.renderable.RenderableImageOp
Gets a RenderedImage instance of this image with a default width and height in pixels.
createDefaultRoot() - Method in class javax.swing.text.DefaultStyledDocument
Creates the root element to be used to represent the default document structure.
createDefaultRoot() - Method in class javax.swing.text.html.HTMLDocument
Creates the root element to be used to represent the default document structure.
createDefaultRoot() - Method in class javax.swing.text.PlainDocument
Creates the root element to be used to represent the default document structure.
createDefaultSelectionModel() - Method in class javax.swing.JTable
Returns the default selection model object, which is a DefaultListSelectionModel.
createDefaultTableHeader() - Method in class javax.swing.JTable
Returns the default table header object, which is a JTableHeader.
createDefaultTheme() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Ensures the current MetalTheme is non-null.
createDesktopManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createDesktopPeer(Desktop) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of the Desktop using the specified peer interface.
createDetail() - Method in class javax.xml.soap.SOAPFactory
Creates a new Detail object which serves as a container for DetailEntry objects.
createDetailsView(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDialog(Dialog) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Dialog using the specified peer interface.
createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener) - Static method in class javax.swing.JColorChooser
Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons.
createDialog(Component) - Method in class javax.swing.JFileChooser
Creates and returns a new JDialog wrapping this centered on the parent in the parent's frame.
createDialog(Component, String) - Method in class javax.swing.JOptionPane
Creates and returns a new JDialog wrapping this centered on the parentComponent in the parentComponent's frame.
createDialog(String) - Method in class javax.swing.JOptionPane
Creates and returns a new parentless JDialog with the specified title.
createDirectories(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a directory by creating all nonexistent parent directories first.
createDirectory(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory.
createDirectory(Path, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Creates a new directory.
createDirectoryComboBoxModel(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDirectoryComboBoxRenderer(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDisabledImage(Image) - Static method in class javax.swing.GrayFilter
Creates a disabled image
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDockingListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createDockingListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createDocument(String, String, DocumentType) - Method in interface org.w3c.dom.DOMImplementation
Creates a DOM Document object of the specified type with its document element.
createDocumentFragment() - Method in interface org.w3c.dom.Document
Creates an empty DocumentFragment object.
createDocumentType(String, String, String) - Method in interface org.w3c.dom.DOMImplementation
Creates an empty DocumentType node.
createDoubleClickListener(JFileChooser, JList) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener) - Method in class java.awt.dnd.DragSource
Creates a new DragGestureRecognizer that implements the specified abstract subclass of DragGestureRecognizer, and sets the specified Component and DragGestureListener on the newly created object.
createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener) - Method in class java.awt.Toolkit
Creates a concrete, platform dependent, subclass of the abstract DragGestureRecognizer class requested, and associates it with the DragSource, Component and DragGestureListener specified.
createDragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragSource
Creates the DragSourceContext to handle the current drag operation.
createDragSourceContextPeer(DragGestureEvent) - Method in class java.awt.Toolkit
Creates the peer for a DragSourceContext.
createDragWindow(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
createdRenderer - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if the renderer that is currently in the tree was created by this instance.
createDropTargetAutoScroller(Component, Point) - Method in class java.awt.dnd.DropTarget
create an embedded autoscroller
createDropTargetContext() - Method in class java.awt.dnd.DropTarget
Creates the DropTargetContext associated with this DropTarget.
createDTD(DTD, String) - Static method in class javax.swing.text.html.parser.ParserDelegator
createDTD(String) - Method in class javax.xml.stream.XMLEventFactory
Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
createEastPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createEditor(SpinnerModel) - Method in class javax.swing.JSpinner
This method is called by the constructors to create the JComponent that displays the current value of the sequence.
createEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the default editor that will be used in editable combo boxes.
createEditor() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
This method is called by installUI to get the editor component of the JSpinner.
createEditor() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createEditor() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
createEditor() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
This method is called by installUI to get the editor component of the JSpinner.
createEditorComponent() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
Creates the internal editor component.
createEditorKitForContentType(String) - Static method in class javax.swing.JEditorPane
Creates a handler for the given type from the default registry of editor kits.
createElement(Element) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object from an existing DOM Element.
createElement(Name) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given Name object.
createElement(QName) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given QName object.
createElement(String) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given local name.
createElement(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPElement object with the given local name, prefix and uri.
createElement(String) - Method in interface org.w3c.dom.Document
Creates an element of the type specified.
createElementNS(String, String) - Method in interface org.w3c.dom.Document
Creates an element of the given qualified name and namespace URI.
createEmptyBorder() - Static method in class javax.swing.BorderFactory
Creates an empty border that takes up no space.
createEmptyBorder(int, int, int, int) - Static method in class javax.swing.BorderFactory
Creates an empty border that takes up space but which does no drawing, specifying the width of the top, left, bottom, and right sides.
createEmptyFrameIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory
createEndDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of an EndDocument event
createEndElement(QName, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding and implementation object.
createEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding, implementation object and web service features.
createEndpoint(String, Class<?>, Invoker, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
createEntityReference(String, EntityDeclaration) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a EntityReference event
createEntityReference(String) - Method in interface org.w3c.dom.Document
Creates an EntityReference object.
createEtchedBorder() - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the component's current background color for highlighting and shading.
createEtchedBorder(Color, Color) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the specified highlighting and shading colors.
createEtchedBorder(int) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the component's current background color for highlighting and shading.
createEtchedBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the specified highlighting and shading colors.
createEvent(String) - Method in interface org.w3c.dom.events.DocumentEvent
createExceptionReply() - Method in interface org.omg.CORBA.portable.ResponseHandler
Called by the servant during a method invocation.
createExtendedResponse(String, byte[], int, int) - Method in interface javax.naming.ldap.ExtendedRequest
Creates the response object that corresponds to this request.
createExtendedResponse(String, byte[], int, int) - Method in class javax.naming.ldap.StartTlsRequest
Creates an extended response object that corresponds to the LDAP StartTLS extended request.
createFault(String, QName) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPFault object initialized with the given reasonText and faultCode
createFault() - Method in class javax.xml.soap.SOAPFactory
Creates a new default SOAPFault object
createFile(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new and empty file, failing if the file already exists.
createFileDialog(FileDialog) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of FileDialog using the specified peer interface.
createFileObject(File, String) - Method in class javax.swing.filechooser.FileSystemView
Returns a File object constructed in dir from the given filename.
createFileObject(String) - Method in class javax.swing.filechooser.FileSystemView
Returns a File object constructed from the given path string.
createFileSystemRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Creates a new File object for f with correct behavior for a file system root directory.
createFilterComboBoxModel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createFilterComboBoxRenderer() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createFilteredReader(XMLStreamReader, StreamFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered reader that wraps the filter around the reader
createFilteredReader(XMLEventReader, EventFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered event reader that wraps the filter around the event reader
createFilteredRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a FilteredRowSet.
createFloatingFrame(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
createFloatingWindow(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates a window which contains the toolbar after it has been dragged out from its container
createFocusListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a FocusListener which will be added to the combo box.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicListUI
createFocusListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createFocusListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a FocusListener for the JSplitPane UI.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the focus listener for handling keyboard navigation in the JTable.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener that is responsible for updating the display when focus is lost/gained.
createFont(int, InputStream) - Static method in class java.awt.Font
Returns a new Font using the specified font type and input data.
createFont(int, File) - Static method in class java.awt.Font
Returns a new Font using the specified font type and the specified font file.
createFragment(int, int) - Method in class javax.swing.text.GlyphView
Creates a view that represents a portion of the element.
createFragment(int, int) - Method in class javax.swing.text.View
Creates a view that represents a portion of the element.
createFrame(Frame) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Frame using the specified peer interface.
createFrameListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createFromBufferedImageType(int) - Static method in class javax.imageio.ImageTypeSpecifier
Returns an ImageTypeSpecifier that encodes one of the standard BufferedImage types (other than TYPE_CUSTOM).
createFromRenderedImage(RenderedImage) - Static method in class javax.imageio.ImageTypeSpecifier
Returns an ImageTypeSpecifier that encodes the layout of a RenderedImage (which may be a BufferedImage).
createGlassPane() - Method in class javax.swing.JLayer
Called by the constructor methods to create a default glassPane.
createGlassPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default glassPane.
createGlassPaneDispatcher() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createGlue() - Static method in class javax.swing.Box
Creates an invisible "glue" component that can be useful in a Box whose visible components have a maximum width (for a horizontal box) or height (for a vertical box).
createGlyphVector(FontRenderContext, String) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, char[]) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, CharacterIterator) - Method in class java.awt.Font
Creates a GlyphVector by mapping the specified characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, int[]) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGraphics(BufferedImage) - Method in class java.awt.GraphicsEnvironment
Returns a Graphics2D object for rendering into the specified BufferedImage.
createGraphics() - Method in class java.awt.image.BufferedImage
Creates a Graphics2D, which can be used to draw into this BufferedImage.
createGraphics() - Method in class java.awt.image.VolatileImage
Creates a Graphics2D, which can be used to draw into this VolatileImage.
createGraphics() - Method in class java.awt.SplashScreen
Creates a graphics context (as a Graphics2D object) for the splash screen overlay image, which allows you to draw over the splash screen.
createGrayLineBorder() - Static method in class javax.swing.border.LineBorder
Convenience method for getting the Color.gray LineBorder of thickness 1.
createGrayscale(int, int, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a grayscale image format that will pack pixels of the given bit depth into array elements of the specified data type.
createGrayscale(int, int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a grayscale plus alpha image format that will pack pixels of the given bit depth into array elements of the specified data type.
createGroup(ActivationGroupID, ActivationGroupDesc, long) - Static method in class java.rmi.activation.ActivationGroup
Create and set the activation group for the current VM.
createHandler(Object, ExceptionListener, ClassLoader) - Static method in class java.beans.XMLDecoder
Creates a new handler for SAX parser that can be used to parse embedded XML archives created by the XMLEncoder class.
createHighlighter() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the object to use for adding highlights.
createHorizontalBox() - Static method in class javax.swing.Box
Creates a Box that displays its components from left to right.
createHorizontalGlue() - Static method in class javax.swing.Box
Creates a horizontal glue component.
createHorizontalScrollBar() - Method in class javax.swing.JScrollPane
Returns a JScrollPane.ScrollBar by default.
createHorizontalStrut(int) - Static method in class javax.swing.Box
Creates an invisible, fixed-width component.
createHSBChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createHTMLView(JComponent, String) - Static method in class javax.swing.plaf.basic.BasicHTML
Create an html renderer for the given component and string of html.
createIgnorableSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create an ignorable space
createImage(ImageProducer) - Method in class java.awt.Component
Creates an image from the specified image producer.
createImage(int, int) - Method in class java.awt.Component
Creates an off-screen drawable image to be used for double buffering.
createImage(String) - Method in class java.awt.Toolkit
Returns an image which gets pixel data from the specified file.
createImage(URL) - Method in class java.awt.Toolkit
Returns an image which gets pixel data from the specified URL.
createImage(ImageProducer) - Method in class java.awt.Toolkit
Creates an image with the specified image producer.
createImage(byte[]) - Method in class java.awt.Toolkit
Creates an image which decodes the image stored in the specified byte array.
createImage(byte[], int, int) - Method in class java.awt.Toolkit
Creates an image which decodes the image stored in the specified byte array, and at the specified offset and length.
createImageInputStream(Object) - Static method in class javax.imageio.ImageIO
Returns an ImageInputStream that will take its input from the given Object.
createImageOutputStream(Object) - Static method in class javax.imageio.ImageIO
Returns an ImageOutputStream that will send its output to the given Object.
createIncreaseButton(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createIncreaseButton(int) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
Returns the view that represents the increase view.
createIncreaseButton(int) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
createIndexed(byte[], byte[], byte[], byte[], int, int) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for an indexed-color image format that will pack index values of the given bit depth into array elements of the specified data type.
createInitialContextFactory(Hashtable<?, ?>) - Method in interface javax.naming.spi.InitialContextFactoryBuilder
Creates an initial context factory using the specified environment.
createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLEditorKit
Copies the key/values in elements AttributeSet into set.
createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text.StyledEditorKit
Copies the key/values in elements AttributeSet into set.
createInputMethod() - Method in interface java.awt.im.spi.InputMethodDescriptor
Creates a new instance of the corresponding input method.
createInputMethodJFrame(String, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Creates a top-level Swing JFrame for use by the input method.
createInputMethodWindow(String, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Creates a top-level window for use by the input method.
createInputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns an instance of the ImageInputStream implementation associated with this service provider.
createInputStreamInstance(Object) - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns an instance of the ImageInputStream implementation associated with this service provider.
createInterleaved(ColorSpace, int[], int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for an interleaved image format that will use a ComponentColorModel and a PixelInterleavedSampleModel to store each pixel component in a separate byte, short, or int.
createInterleavedRaster(int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified data type, width, height, and number of bands.
createInterleavedRaster(int, int, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified data type, width, height, scanline stride, pixel stride, and band offsets.
createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified DataBuffer, width, height, scanline stride, pixel stride, and band offsets.
createInternalFrame(Component, String) - Method in class javax.swing.JOptionPane
Creates and returns an instance of JInternalFrame.
createInternalFrameListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Double
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Float
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.Rectangle
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createInverse() - Method in class java.awt.geom.AffineTransform
Returns an AffineTransform object representing the inverse transformation.
createItemListener() - Method in class javax.swing.AbstractButton
createItemListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates an ItemListener which will be added to the combo box.
createItemListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates an ItemListener which will be added to the combo box.
createJAXBIntrospector() - Method in class javax.xml.bind.JAXBContext
Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
createJdbcRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a JdbcRowSet.
createJoinRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a JoinRowSet.
createKeyboardDownRightListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardEndListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardHomeListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardResizeToggleListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardUpLeftListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a KeyListener which will be added to the combo box.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the key listener that will be added to the combo box.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the key listener for handling keyboard navigation in the JTable.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener reponsible for getting key events from the tree.
createKeymap() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the keymap to use for the text component, and installs any necessary bindings into it.
createLabel(Label) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Label using the specified peer interface.
createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Creates a large set of attributes that should trade off space for time.
createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text.StyleContext
Create a large set of attributes that should trade off space for time.
createLayeredPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default layeredPane.
createLayout() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createLayout() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner.
createLayout() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createLayout() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
createLayout() - Method in class javax.swing.plaf.synth.SynthToolBarUI
Creates a LayoutManager to use with the toolbar.
createLayoutCache() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the object responsible for managing what is expanded, as well as the size of nodes.
createLayoutManager() - Method in class javax.swing.JViewport
Subclassers can override this to install a different layout manager (or null) in the constructor.
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a layout manager for managing the components which make up the combo box.
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Invoked by installUI to create a layout manager object to manage the JTabbedPane.
createLayoutManager() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createLayoutManager() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
createLayoutManager() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text.AbstractDocument
Creates a document leaf element.
createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text.html.HTMLDocument
Creates a document leaf element that directly represents text (doesn't have any children).
createLeftOneTouchButton() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates and return an instance of JButton that can be used to collapse the left component in the split pane.
createLineBidi(int, int) - Method in class java.text.Bidi
Create a Bidi object representing the bidi information on a line of text within the paragraph represented by the current Bidi.
createLineBorder(Color) - Static method in class javax.swing.BorderFactory
Creates a line border withe the specified color.
createLineBorder(Color, int) - Static method in class javax.swing.BorderFactory
Creates a line border with the specified color and width.
createLineBorder(Color, int, boolean) - Static method in class javax.swing.BorderFactory
Creates a line border with the specified color, thickness, and corner shape.
createLink(Path, Path) - Static method in class java.nio.file.Files
Creates a new link (directory entry) for an existing file (optional operation).
createLink(Path, Path) - Method in class java.nio.file.spi.FileSystemProvider
Creates a new link (directory entry) for an existing file.
createList(List) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of List using the specified peer interface.
createList() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the JList used in the popup to display the items in the combo box model.
createList(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createListDataListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a list data listener which will be added to the ComboBoxModel.
createListDataListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a list data listener which will be added to the ComboBoxModel.
createListDataListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of ListDataListener that's added to the JLists by model as needed.
createListMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a mouse listener that watches for mouse events in the popup's list.
createListMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a mouse motion listener that watches for mouse motion events in the popup's list.
createListSelectionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a list selection listener that watches for selection changes in the popup's list.
createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createListSelectionListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of ListSelectionHandler that's added to the JLists by selectionModel as needed.
createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
Creates a selection listener for the list of files and directories.
createLoweredBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a border with a lowered beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createLoweredSoftBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a beveled border with a lowered edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createLSInput() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
createLSOutput() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
createLSParser(short, String) - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new LSParser.
createLSSerializer() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new LSSerializer object.
createMarshaller() - Method in class javax.xml.bind.JAXBContext
Create a Marshaller object that can be used to convert a java content tree into XML data.
createMatteBorder(int, int, int, int, Color) - Static method in class javax.swing.BorderFactory
Creates a matte-look border using a solid color.
createMatteBorder(int, int, int, int, Icon) - Static method in class javax.swing.BorderFactory
Creates a matte-look border that consists of multiple tiles of a specified icon.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName).
createMBean(String, ObjectName, ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBeanServer() - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with a standard default domain name.
createMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with the specified default domain name.
createMenu(Menu) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Menu using the specified peer interface.
createMenuBar(MenuBar) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of MenuBar using the specified peer interface.
createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMenuItem(MenuItem) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of MenuItem using the specified peer interface.
createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMenuListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMessage() - Method in class javax.xml.soap.MessageFactory
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap.MessageFactory
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
createMessageArea() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Messaged from installComponents to create a Container containing the body of the message.
createMessageArea() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Called from SynthOptionPaneUI.installComponents() to create a Container containing the body of the message.
createModel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createModelListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates a delegate that implements MouseInputListener.
createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Creates the mouse listener for the JTableHeader.
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the mouse listener for the JTable.
createMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a listener that will watch for mouse-press and release events on the combo box.
createMouseListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createMouseListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener responsible for updating the selection based on mouse events.
createMouseListener() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
createMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the mouse motion listener which will be added to the combo box.
createMouseWheelListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
Creates an instance of MouseWheelListener, which is added to the JScrollPane by installUI().
createMultiDocPrintJob() - Method in interface javax.print.MultiDocPrintService
Create a job which can print a multiDoc.
createName(String, String, String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name.
createName(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name.
createName(String, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a string name from the specified namespace to a GSSName object.
createName(byte[], Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
createName(String, Oid, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
createName(byte[], Oid, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
createNamespace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a new default Namespace
createNamespace(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Namespace
createNClob() - Method in interface java.sql.Connection
Constructs an object that implements the NClob interface.
createNewFile() - Method in class java.io.File
Atomically creates a new, empty file named by this abstract pathname if and only if a file with this name does not yet exist.
createNewFolder(File) - Method in class javax.swing.filechooser.FileSystemView
Creates a new folder with a default folder name.
createNextButton() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates an increment button, i.e.
createNextButton() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
createNodeDimensions() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.
createNonRolloverBorder() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates the non rollover border for toolbar components.
createNonRolloverBorder() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
createObjectFactory(Object, Hashtable<?, ?>) - Method in interface javax.naming.spi.ObjectFactoryBuilder
Creates a new object factory using the environment supplied.
createOutput(String, String) - Method in class javax.xml.bind.SchemaOutputResolver
Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
createOutputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns an instance of the ImageOutputStream implementation associated with this service provider.
createOutputStreamInstance(Object) - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns an instance of the ImageOutputStream implementation associated with this service provider.
createPacked(ColorSpace, int, int, int, int, int, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a packed image format that will use a DirectColorModel and a packed SampleModel to store each pixel packed into in a single byte, short, or int.
createPackedRaster(int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a SinglePixelPackedSampleModel with the specified data type, width, height, and band masks.
createPackedRaster(int, int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a packed SampleModel with the specified data type, width, height, number of bands, and bits per band.
createPackedRaster(DataBuffer, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a SinglePixelPackedSampleModel with the specified DataBuffer, width, height, scanline stride, and band masks.
createPackedRaster(DataBuffer, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a MultiPixelPackedSampleModel with the specified DataBuffer, width, height, and bits per pixel.
createPanel(Panel) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Panel using the specified peer interface.
createParallelGroup() - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with an alignment of Alignment.LEADING.
createParallelGroup(GroupLayout.Alignment) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with the specified alignment.
createParallelGroup(GroupLayout.Alignment, boolean) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with the specified alignment and resize behavior.
createPopup() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the popup portion of the combo box.
createPopup() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createPopup() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
createPopupMenu(PopupMenu) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of PopupMenu using the specified peer interface.
createPosition(int) - Method in interface javax.swing.text.AbstractDocument.Content
Creates a position within the content that will track change as the content is mutated.
createPosition(int) - Method in class javax.swing.text.AbstractDocument
Returns a position that will track change as the document is altered.
createPosition(int) - Method in interface javax.swing.text.Document
This method allows an application to mark a place in a sequence of character content.
createPosition(int) - Method in class javax.swing.text.GapContent
Creates a position within the content that will track change as the content is mutated.
createPosition(int) - Method in class javax.swing.text.StringContent
Creates a position within the content that will track change as the content is mutated.
createPreviousButton() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a decrement button, i.e.
createPreviousButton() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
createPrintJob() - Method in interface javax.print.PrintService
Creates and returns a PrintJob capable of handling data from any of the supported document flavors.
createProcessingInstruction(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a processing instruction
createProcessingInstruction(String, String) - Method in interface org.w3c.dom.Document
Creates a ProcessingInstruction node given the specified name and data strings.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a PropertyChangeListener which will be added to the combo box.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a PropertyChangeListener which will be added to the combo box.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
Returns the PropertyChangeListener to install on the JDesktopPane.
createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of PropertyChangeHandler that's added to the JList by installUI().
createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Creates a PropertyChangeListener which will be added to the menu item.
createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
Creates an instance of PropertyChangeListener that's added to the JScrollPane by installUI().
createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a PropertyChangeListener that can be added to the JSpinner itself.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a PropertyChangeListener for the JSplitPane UI.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener that is responsible that updates the UI based on how the tree changes.
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.metal.MetalSliderUI
createPropertyEditor(Object) - Method in class java.beans.PropertyDescriptor
Constructs an instance of a property editor using the current property editor class.
createPropertyListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createQName(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
createRaisedBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a border with a raised beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createRaisedSoftBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a beveled border with a raised edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image.Raster
Creates a Raster with the specified SampleModel and DataBuffer.
createReaderInstance() - Method in class javax.imageio.spi.ImageReaderSpi
Returns an instance of the ImageReader implementation associated with this service provider.
createReaderInstance(Object) - Method in class javax.imageio.spi.ImageReaderSpi
Returns an instance of the ImageReader implementation associated with this service provider.
createRegistry(int) - Static method in class java.rmi.registry.LocateRegistry
Creates and exports a Registry instance on the local host that accepts requests on the specified port.
createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.registry.LocateRegistry
Creates and exports a Registry instance on the local host that uses custom socket factories for communication with that instance.
createRelation(String, String, RoleList) - Method in class javax.management.relation.RelationService
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelation(String, String, RoleList) - Method in interface javax.management.relation.RelationServiceMBean
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in class javax.management.relation.RelationService
Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in interface javax.management.relation.RelationServiceMBean
Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createRenderer() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the default renderer that will be used in a non-editiable combo box.
createRenderer() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
createRendering(RenderContext) - Method in interface java.awt.image.renderable.RenderableImage
Creates a RenderedImage that represented a rendering of this image using a given RenderContext.
createRendering(RenderContext) - Method in class java.awt.image.renderable.RenderableImageOp
Creates a RenderedImage which represents this RenderableImageOp (including its Renderable sources) rendered according to the given RenderContext.
createReply() - Method in interface org.omg.CORBA.portable.ResponseHandler
Called by the servant during a method invocation.
createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new auxiliary resource file for writing and returns a file object for it.
createRightOneTouchButton() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates and return an instance of JButton that can be used to collapse the right component in the split pane.
createRigidArea(Dimension) - Static method in class javax.swing.Box
Creates an invisible component that's always the specified size.
createRolloverBorder() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates a rollover border for toolbar components.
createRolloverBorder() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createRolloverListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
Creates a property change listener that will be added to the JToolBar.
createRootLayout() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default layoutManager.
createRootPane() - Method in class javax.swing.JApplet
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JDialog
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JFrame
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JInternalFrame
Called by the constructor to set up the JRootPane.
createRootPane() - Method in class javax.swing.JWindow
Called by the constructor methods to create the default rootPane.
createRow() - Method in class javax.swing.text.FlowView
Create a View that should be used to hold a a rows worth of children in a flow.
createRow() - Method in class javax.swing.text.ParagraphView
Create a View that should be used to hold a a row's worth of children in a flow.
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl.Sasl
Creates a SaslClient using the parameters supplied.
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl.SaslClientFactory
Creates a SaslClient using the parameters supplied.
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl.Sasl
Creates a SaslServer for the specified mechanism.
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl.SaslServerFactory
Creates a SaslServer using the parameters supplied.
createScaledRendering(int, int, RenderingHints) - Method in interface java.awt.image.renderable.RenderableImage
Creates a RenderedImage instance of this image with width w, and height h in pixels.
createScaledRendering(int, int, RenderingHints) - Method in class java.awt.image.renderable.RenderableImageOp
Creates a RenderedImage instance of this image with width w, and height h in pixels.
createScreenCapture(Rectangle) - Method in class java.awt.Robot
Creates an image containing pixels read from the screen.
createScrollbar(Scrollbar) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Scrollbar using the specified peer interface.
createScrollBarSwapListener() - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
createScrollButton(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
createScrollButton(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
createScroller() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the scroll pane which houses the scrollable list.
createScrollListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createScrollListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createScrollPane(ScrollPane) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of ScrollPane using the specified peer interface.
createScrollPaneForTable(JTable) - Static method in class javax.swing.JTable
Deprecated.
As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
createSecondaryLoop() - Method in class java.awt.EventQueue
Creates a new secondary loop associated with this event queue.
createSelectionModel() - Method in class javax.swing.JList
Returns an instance of DefaultListSelectionModel; called during construction to initialize the list's selection model property.
createSelectionModel() - Method in class javax.swing.table.DefaultTableColumnModel
Creates a new default list selection model.
createSelectionModelPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener responsible for getting property change events from the selection model.
createSeparator() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createSeparator() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
createSequentialGroup() - Method in class javax.swing.GroupLayout
Creates and returns a SequentialGroup.
createServerSocket(int) - Method in interface java.rmi.server.RMIServerSocketFactory
Create a server socket on the specified port (port 0 indicates an anonymous port).
createServerSocket(int) - Method in class java.rmi.server.RMISocketFactory
Create a server socket on the specified port (port 0 indicates an anonymous port).
createServerSocket() - Method in class javax.net.ServerSocketFactory
Returns an unbound server socket.
createServerSocket(int) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port.
createServerSocket(int, int) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port, and uses the specified connection backlog.
createServerSocket(int, int, InetAddress) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port, with a specified listen backlog and local IP.
createServerSocket(int) - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Creates a server socket that accepts SSL connections configured according to this factory's SSL socket configuration parameters.
createServiceDelegate(URL, QName, Class<? extends Service>) - Method in class javax.xml.ws.spi.Provider
Creates a service delegate object.
createServiceDelegate(URL, QName, Class<? extends Service>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates a service delegate object.
createShared() - Method in interface javax.sql.rowset.CachedRowSet
Returns a new RowSet object backed by the same data as that of this CachedRowSet object.
createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Creates a compact set of attributes that might be shared.
createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text.StyleContext
Create a compact set of attributes that might be shared.
createSocket(String, int) - Method in interface java.rmi.server.RMIClientSocketFactory
Create a client socket connected to the specified host and port.
createSocket(String, int) - Method in class java.rmi.server.RMISocketFactory
Creates a client socket connected to the specified host and port.
createSocket() - Method in class javax.net.SocketFactory
Creates an unconnected socket.
createSocket(String, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified remote host at the specified remote port.
createSocket(String, int, InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified remote host on the specified remote port.
createSocket(InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified port number at the specified address.
createSocket(InetAddress, int, InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connect it to the specified remote address on the specified remote port.
createSocket(Socket, String, int, boolean) - Method in class javax.net.ssl.SSLSocketFactory
Returns a socket layered over an existing socket connected to the named host, at the given port.
createSocket(String, int) - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Creates an SSL socket.
createSocketImpl() - Method in interface java.net.SocketImplFactory
Creates a new SocketImpl instance.
createSoftBevelBorder(int) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createSoftBevelBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using the specified highlighting and shadowing.
createSoftBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using the specified colors for the inner and outer edges of the highlight and the shadow areas.
createSourceFile(CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new source file and returns an object to allow writing to it.
createSouthPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the isSpace flag set to true
createSQLXML() - Method in interface java.sql.Connection
Constructs an object that implements the SQLXML interface.
createSSLEngine() - Method in class javax.net.ssl.SSLContext
Creates a new SSLEngine using this context.
createSSLEngine(String, int) - Method in class javax.net.ssl.SSLContext
Creates a new SSLEngine using this context using advisory peer information.
createStandardLabels(int) - Method in class javax.swing.JSlider
Creates a Hashtable of numerical text labels, starting at the slider minimum, and using the increment specified.
createStandardLabels(int, int) - Method in class javax.swing.JSlider
Creates a Hashtable of numerical text labels, starting at the starting point specified, and using the increment specified.
createStartDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String, boolean) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartElement(QName, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator, NamespaceContext) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStatement() - Method in interface java.sql.Connection
Creates a Statement object for sending SQL statements to the database.
createStatement(int, int) - Method in interface java.sql.Connection
Creates a Statement object that will generate ResultSet objects with the given type and concurrency.
createStatement(int, int, int) - Method in interface java.sql.Connection
Creates a Statement object that will generate ResultSet objects with the given type, concurrency, and holdability.
createStrokeBorder(BasicStroke) - Static method in class javax.swing.BorderFactory
Creates a border of the specified stroke.
createStrokeBorder(BasicStroke, Paint) - Static method in class javax.swing.BorderFactory
Creates a border of the specified stroke and paint.
createStrokedShape(Shape) - Method in class java.awt.BasicStroke
Returns a Shape whose interior defines the stroked outline of a specified Shape.
createStrokedShape(Shape) - Method in interface java.awt.Stroke
Returns an outline Shape which encloses the area that should be painted when the Shape is stroked according to the rules defined by the object implementing the Stroke interface.
createStruct(String, Object[]) - Method in interface java.sql.Connection
Factory method for creating Struct objects.
createSubcontext(Name) - Method in interface javax.naming.Context
Creates and binds a new context.
createSubcontext(String) - Method in interface javax.naming.Context
Creates and binds a new context.
createSubcontext(Name, Attributes) - Method in interface javax.naming.directory.DirContext
Creates and binds a new context, along with associated attributes.
createSubcontext(String, Attributes) - Method in interface javax.naming.directory.DirContext
Creates and binds a new context, along with associated attributes.
createSubcontext(String, Attributes) - Method in class javax.naming.directory.InitialDirContext
createSubcontext(Name, Attributes) - Method in class javax.naming.directory.InitialDirContext
createSubcontext(String) - Method in class javax.naming.InitialContext
createSubcontext(Name) - Method in class javax.naming.InitialContext
createSubsetSampleModel(int[]) - Method in class java.awt.image.BandedSampleModel
Creates a new BandedSampleModel with a subset of the bands of this BandedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.ComponentSampleModel
Creates a new ComponentSampleModel with a subset of the bands of this ComponentSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a new MultiPixelPackedSampleModel with a subset of the bands of this MultiPixelPackedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.PixelInterleavedSampleModel
Creates a new PixelInterleavedSampleModel with a subset of the bands of this PixelInterleavedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.SampleModel
Creates a new SampleModel with a subset of the bands of this SampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.SinglePixelPackedSampleModel
This creates a new SinglePixelPackedSampleModel with a subset of the bands of this SinglePixelPackedSampleModel.
createSymbolicLink(Path, Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a symbolic link to a target (optional operation).
createSymbolicLink(Path, Path, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Creates a symbolic link to a target.
createSystemMenu() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createSystemMenuBar() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createTableCell(Element) - Method in class javax.swing.text.TableView
Deprecated.
Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
createTableRow(Element) - Method in class javax.swing.text.TableView
Creates a new table row.
createTempDirectory(Path, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory in the specified directory, using the given prefix to generate its name.
createTempDirectory(String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory in the default temporary-file directory, using the given prefix to generate its name.
createTempFile(String, String, File) - Static method in class java.io.File
Creates a new empty file in the specified directory, using the given prefix and suffix strings to generate its name.
createTempFile(String, String) - Static method in class java.io.File
Creates an empty file in the default temporary-file directory, using the given prefix and suffix to generate its name.
createTempFile(Path, String, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new empty file in the specified directory, using the given prefix and suffix strings to generate its name.
createTempFile(String, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates an empty file in the default temporary-file directory, using the given prefix and suffix to generate its name.
createTextArea(TextArea) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of TextArea using the specified peer interface.
createTextField(TextField) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of TextField using the specified peer interface.
createTextNode(String) - Method in interface org.w3c.dom.Document
Creates a Text node given the specified string.
createTitledBorder(String) - Static method in class javax.swing.BorderFactory
Creates a new titled border with the specified title, the default border type (determined by the current look and feel), the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
createTitledBorder(Border) - Static method in class javax.swing.BorderFactory
Creates a new titled border with an empty title, the specified border object, the default text position (sitting on the top line), the default justification (leading), and the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with default positioning (sitting on the top line), default justification (leading) and the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int, Font) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int, Font, Color) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning, font and color.
createToolBarContListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createToolBarFocusListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createToolTip() - Method in class javax.swing.JComponent
Returns the instance of JToolTip that should be used to display the tooltip.
createTrack() - Method in class javax.sound.midi.Sequence
Creates a new, initially empty track as part of this sequence.
createTrackListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createTrackListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createTrackListener(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
createTranscoderInstance() - Method in class javax.imageio.spi.ImageTranscoderSpi
Returns an instance of the ImageTranscoder implementation associated with this service provider.
createTransferable(JComponent) - Method in class javax.swing.TransferHandler
Creates a Transferable to use as the source for a data transfer.
createTransferableProxy(Transferable, boolean) - Method in class java.awt.dnd.DropTargetContext
Creates a TransferableProxy to proxy for the specified Transferable.
createTransformedArea(AffineTransform) - Method in class java.awt.geom.Area
Creates a new Area object that contains the same geometry as this Area transformed by the specified AffineTransform.
createTransformedShape(Shape) - Method in class java.awt.geom.AffineTransform
Returns a new Shape object defined by the geometry of the specified Shape after it has been transformed by this transform.
createTransformedShape(AffineTransform) - Method in class java.awt.geom.Path2D
Returns a new Shape representing a transformed version of this Path2D.
createTranslatedChild(int, int) - Method in class java.awt.image.Raster
Create a Raster with the same size, SampleModel and DataBuffer as this one, but with a different location.
createTreeCellEditor() - Method in class javax.swing.tree.DefaultTreeCellEditor
This is invoked if a TreeCellEditor is not supplied in the constructor.
createTreeExpansionListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates and returns the object responsible for updating the treestate when nodes expanded state changes.
createTreeModel(Object) - Static method in class javax.swing.JTree
Returns a TreeModel wrapping the specified object.
createTreeModelListener() - Method in class javax.swing.JTree
Creates and returns an instance of TreeModelHandler.
createTreeModelListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns a listener that can update the tree when the model changes.
createTreeSelectionListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener that updates the display based on selection change methods.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicCheckBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicColorChooserUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicComboBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicDesktopIconUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicDesktopPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicEditorPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicFileChooserUI
Creates a BasicFileChooserUI implementation for the specified component.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicFormattedTextFieldUI
Creates a UI for a JFormattedTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicInternalFrameUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicLabelUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicListUI
Returns a new instance of BasicListUI.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates a new BasicOptionPaneUI instance.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPanelUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Creates a UI for a JPasswordField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPopupMenuUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicProgressBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRadioButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRootPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicScrollPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSliderUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSpinnerUI
Returns a new instance of BasicSpinnerUI.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a new BasicSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTableHeaderUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTableUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextAreaUI
Creates a UI for a JTextArea.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextFieldUI
Creates a UI for a JTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToggleButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolTipUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTreeUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicViewportUI
createUI(JComponent) - Static method in class javax.swing.plaf.ComponentUI
Returns an instance of the UI delegate for the specified component.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalCheckBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalComboBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalDesktopIconUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalFileChooserUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalInternalFrameUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalLabelUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalMenuBarUI
Creates the ComponentUI implementation for the passed in component.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalProgressBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalRadioButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalRootPaneUI
Creates a UI for a JRootPane.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalScrollPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSliderUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSplitPaneUI
Creates a new MetalSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTabbedPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTextFieldUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToggleButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToolBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToolTipUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTreeUI
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiButtonUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiColorChooserUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiComboBoxUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiDesktopIconUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiFileChooserUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiInternalFrameUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiLabelUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiListUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiMenuBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiMenuItemUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiOptionPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiPanelUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiPopupMenuUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiProgressBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiRootPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiScrollBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiScrollPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSeparatorUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSliderUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSpinnerUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSplitPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTableHeaderUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTableUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTextUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiToolBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiToolTipUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTreeUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiViewportUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthCheckBoxUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthColorChooserUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthDesktopIconUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthEditorPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthFormattedTextFieldUI
Creates a UI for a JFormattedTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthInternalFrameUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthLabelUI
Returns the LabelUI implementation used for the skins look and feel.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthListUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel
Creates the Synth look and feel ComponentUI for the passed in JComponent.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthOptionPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPanelUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPasswordFieldUI
Creates a UI for a JPasswordField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPopupMenuUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthProgressBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRadioButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRootPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthScrollPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSeparatorUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSliderUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSpinnerUI
Returns a new instance of SynthSpinnerUI.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSplitPaneUI
Creates a new SynthSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTableHeaderUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTableUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextAreaUI
Creates a UI object for a JTextArea.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextFieldUI
Creates a UI for a JTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToggleButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToolBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToolTipUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTreeUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthViewportUI
Creates a new UI object for the given component.
createUIs(ComponentUI, Vector, JComponent) - Static method in class javax.swing.plaf.multi.MultiLookAndFeel
Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Double
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Float
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.Rectangle
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnmarshalException(SAXException) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Creates an UnmarshalException from a SAXException.
createUnmarshaller(ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler
When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
createUnmarshaller(ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler
createUnmarshaller() - Method in class javax.xml.bind.JAXBContext
Create an Unmarshaller object that can be used to convert XML data into a java content tree.
createUnresolved(String, int) - Static method in class java.net.InetSocketAddress
Creates an unresolved socket address from a hostname and a port number.
createURLStreamHandler(String) - Method in interface java.net.URLStreamHandlerFactory
Creates a new URLStreamHandler instance with the specified protocol.
createValidator() - Method in class javax.xml.bind.JAXBContext
Deprecated.
since JAXB2.0
createValue(UIDefaults) - Method in interface javax.swing.UIDefaults.ActiveValue
Creates the value retrieved from the UIDefaults table.
createValue(UIDefaults) - Method in class javax.swing.UIDefaults.LazyInputMap
Creates an InputMap with the bindings that are passed in.
createValue(UIDefaults) - Method in interface javax.swing.UIDefaults.LazyValue
Creates the actual value retrieved from the UIDefaults table.
createValue(UIDefaults) - Method in class javax.swing.UIDefaults.ProxyLazyValue
Creates the value retrieved from the UIDefaults table.
createValueHandler() - Static method in class javax.rmi.CORBA.Util
Returns a singleton instance of a class that implements the ValueHandler interface.
createValueHandler() - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.createValueHandler().
createVerticalBox() - Static method in class javax.swing.Box
Creates a Box that displays its components from top to bottom.
createVerticalGlue() - Static method in class javax.swing.Box
Creates a vertical glue component.
createVerticalScrollBar() - Method in class javax.swing.JScrollPane
Returns a JScrollPane.ScrollBar by default.
createVerticalStrut(int) - Static method in class javax.swing.Box
Creates an invisible, fixed-height component.
createView(FlowView, int, int, int) - Method in class javax.swing.text.FlowView.FlowStrategy
Creates a view that can be used to represent the current piece of the flow.
createViewListener() - Method in class javax.swing.JViewport
Creates a listener for the view.
createViewport() - Method in class javax.swing.JScrollPane
Returns a new JViewport by default.
createViewportChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createVolatileImage(int, int) - Method in class java.awt.Component
Creates a volatile off-screen drawable image to be used for double buffering.
createVolatileImage(int, int, ImageCapabilities) - Method in class java.awt.Component
Creates a volatile off-screen drawable image, with the given capabilities.
createVSBChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createW3CEndpointReference(String, QName, QName, List<Element>, String, List<Element>) - Method in class javax.xml.ws.spi.Provider
Factory method to create a W3CEndpointReference.
createW3CEndpointReference(String, QName, QName, QName, List<Element>, String, List<Element>, List<Element>, Map<QName, String>) - Method in class javax.xml.ws.spi.Provider
Factory method to create a W3CEndpointReference.
createWebRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a WebRowSet.
createWestPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createWindow(Window) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Window using the specified peer interface.
createWinListener(JPopupMenu) - Method in class javax.swing.JMenu
Creates a window-closing listener for the popup.
createWritableChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image.WritableRaster
Returns a new WritableRaster which shares all or part of this WritableRaster's DataBuffer.
createWritableRaster(SampleModel, Point) - Static method in class java.awt.image.Raster
Creates a WritableRaster with the specified SampleModel.
createWritableRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image.Raster
Creates a WritableRaster with the specified SampleModel and DataBuffer.
createWritableTranslatedChild(int, int) - Method in class java.awt.image.WritableRaster
Create a WritableRaster with the same size, SampleModel and DataBuffer as this one, but with a different location.
createWriterInstance() - Method in class javax.imageio.spi.ImageWriterSpi
Returns an instance of the ImageWriter implementation associated with this service provider.
createWriterInstance(Object) - Method in class javax.imageio.spi.ImageWriterSpi
Returns an instance of the ImageWriter implementation associated with this service provider.
createXMLEventReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(XMLStreamReader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from an XMLStreamReader.
createXMLEventReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a JAXP source.
createXMLEventReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a JAXP result.
createXMLEventWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a writer
createXMLReader() - Static method in class org.xml.sax.helpers.XMLReaderFactory
Attempt to create an XMLReader from system defaults.
createXMLReader(String) - Static method in class org.xml.sax.helpers.XMLReaderFactory
Attempt to create an XML reader from a class name.
createXMLStreamReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a reader
createXMLStreamReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a JAXP source.
createXMLStreamReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a writer
createXMLStreamWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a JAXP result.
createZipEntry(String) - Method in class java.util.jar.JarInputStream
Creates a new JarEntry (ZipEntry) for the specified JAR file entry name.
createZipEntry(String) - Method in class java.util.zip.ZipInputStream
Creates a new ZipEntry object for the specified entry name.
createZone(int, int) - Method in class javax.swing.text.ZoneView
Create a view to represent a zone for the given range within the model (which should be within the range of this objects responsibility).
creationTime() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns the creation time.
CredentialException - Exception in javax.security.auth.login
A generic credential exception.
CredentialException() - Constructor for exception javax.security.auth.login.CredentialException
Constructs a CredentialException with no detail message.
CredentialException(String) - Constructor for exception javax.security.auth.login.CredentialException
Constructs a CredentialException with the specified detail message.
CredentialExpiredException - Exception in javax.security.auth.login
Signals that a Credential has expired.
CredentialExpiredException() - Constructor for exception javax.security.auth.login.CredentialExpiredException
Constructs a CredentialExpiredException with no detail message.
CredentialExpiredException(String) - Constructor for exception javax.security.auth.login.CredentialExpiredException
Constructs a CredentialExpiredException with the specified detail message.
CredentialNotFoundException - Exception in javax.security.auth.login
Signals that a credential was not found.
CredentialNotFoundException() - Constructor for exception javax.security.auth.login.CredentialNotFoundException
Constructs a CredentialNotFoundException with no detail message.
CredentialNotFoundException(String) - Constructor for exception javax.security.auth.login.CredentialNotFoundException
Constructs a CredentialNotFoundException with the specified detail message.
CREDENTIALS - Static variable in interface javax.management.remote.JMXConnector
Name of the attribute that specifies the credentials to send to the connector server during connection.
CREDENTIALS - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the credentials to use.
CREDENTIALS_EXPIRED - Static variable in exception org.ietf.jgss.GSSException
Expired credentials.
CRITICAL - Static variable in interface javax.naming.ldap.Control
Indicates a critical control.
criticality - Variable in class javax.naming.ldap.BasicControl
The control's criticality.
CRL - Class in java.security.cert
This class is an abstraction of certificate revocation lists (CRLs) that have different formats but important common uses.
CRL(String) - Constructor for class java.security.cert.CRL
Creates a CRL of the specified type.
CRLException - Exception in java.security.cert
CRL (Certificate Revocation List) Exception.
CRLException() - Constructor for exception java.security.cert.CRLException
Constructs a CRLException with no detail message.
CRLException(String) - Constructor for exception java.security.cert.CRLException
Constructs a CRLException with the specified detail message.
CRLException(String, Throwable) - Constructor for exception java.security.cert.CRLException
Creates a CRLException with the specified detail message and cause.
CRLException(Throwable) - Constructor for exception java.security.cert.CRLException
Creates a CRLException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CRLReason - Enum in java.security.cert
The CRLReason enumeration specifies the reason that a certificate is revoked, as defined in RFC 3280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile.
CRLSelector - Interface in java.security.cert
A selector that defines a set of criteria for selecting CRLs.
CropImageFilter - Class in java.awt.image
An ImageFilter class for cropping images.
CropImageFilter(int, int, int, int) - Constructor for class java.awt.image.CropImageFilter
Constructs a CropImageFilter that extracts the absolute rectangular region of pixels from its source Image as specified by the x, y, w, and h parameters.
CROSS_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a cross product of two tables
CROSSHAIR_CURSOR - Static variable in class java.awt.Cursor
The crosshair cursor type.
CROSSHAIR_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.CROSSHAIR_CURSOR.
CryptoPrimitive - Enum in java.security
An enumeration of cryptographic primitives.
CS_CIEXYZ - Static variable in class java.awt.color.ColorSpace
The CIEXYZ conversion color space defined above.
CS_GRAY - Static variable in class java.awt.color.ColorSpace
The built-in linear gray scale color space.
CS_LINEAR_RGB - Static variable in class java.awt.color.ColorSpace
A built-in linear RGB color space.
CS_PYCC - Static variable in class java.awt.color.ColorSpace
The Photo YCC conversion color space.
CS_sRGB - Static variable in class java.awt.color.ColorSpace
The sRGB color space defined at http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html .
CSS - Class in javax.swing.text.html
Defines a set of CSS attributes as a typesafe enumeration.
CSS() - Constructor for class javax.swing.text.html.CSS
CSS.Attribute - Class in javax.swing.text.html
Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
CTRL_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Control key extended modifier constant.
CTRL_MASK - Static variable in class java.awt.event.ActionEvent
The control modifier.
CTRL_MASK - Static variable in class java.awt.Event
This flag indicates that the Control key was down when the event occurred.
CTRL_MASK - Static variable in class java.awt.event.InputEvent
The Control key modifier constant.
ctrlx - Variable in class java.awt.geom.QuadCurve2D.Double
The X coordinate of the control point of the quadratic curve segment.
ctrlx - Variable in class java.awt.geom.QuadCurve2D.Float
The X coordinate of the control point of the quadratic curve segment.
ctrlx1 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the first control point of the cubic curve segment.
ctrlx1 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the first control point of the cubic curve segment.
ctrlx2 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the second control point of the cubic curve segment.
ctrlx2 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the second control point of the cubic curve segment.
ctrly - Variable in class java.awt.geom.QuadCurve2D.Double
The Y coordinate of the control point of the quadratic curve segment.
ctrly - Variable in class java.awt.geom.QuadCurve2D.Float
The Y coordinate of the control point of the quadratic curve segment.
ctrly1 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the first control point of the cubic curve segment.
ctrly1 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the first control point of the cubic curve segment.
ctrly2 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the second control point of the cubic curve segment.
ctrly2 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the second control point of the cubic curve segment.
ctx() - Method in class org.omg.CORBA.Request
Retrieves the Context object for this request.
ctx(Context) - Method in class org.omg.CORBA.Request
Sets this request's Context object to the one given.
ctx() - Method in class org.omg.CORBA.ServerRequest
Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
CTX_RESTRICT_SCOPE - Interface in org.omg.CORBA
A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope.
CubicCurve2D - Class in java.awt.geom
The CubicCurve2D class defines a cubic parametric curve segment in (x,y) coordinate space.
CubicCurve2D() - Constructor for class java.awt.geom.CubicCurve2D
This is an abstract class that cannot be instantiated directly.
CubicCurve2D.Double - Class in java.awt.geom
A cubic parametric curve segment specified with double coordinates.
CubicCurve2D.Double() - Constructor for class java.awt.geom.CubicCurve2D.Double
Constructs and initializes a CubicCurve with coordinates (0, 0, 0, 0, 0, 0, 0, 0).
CubicCurve2D.Double(double, double, double, double, double, double, double, double) - Constructor for class java.awt.geom.CubicCurve2D.Double
Constructs and initializes a CubicCurve2D from the specified double coordinates.
CubicCurve2D.Float - Class in java.awt.geom
A cubic parametric curve segment specified with float coordinates.
CubicCurve2D.Float() - Constructor for class java.awt.geom.CubicCurve2D.Float
Constructs and initializes a CubicCurve with coordinates (0, 0, 0, 0, 0, 0, 0, 0).
CubicCurve2D.Float(float, float, float, float, float, float, float, float) - Constructor for class java.awt.geom.CubicCurve2D.Float
Constructs and initializes a CubicCurve2D from the specified float coordinates.
CUNEIFORM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cuneiform" Unicode character block.
CUNEIFORM_NUMBERS_AND_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cuneiform Numbers and Punctuation" Unicode character block.
CURRENCY - Static variable in class java.text.NumberFormat.Field
Constant identifying the currency field.
Currency - Class in java.util
Represents a currency.
CURRENCY_SYMBOL - Static variable in class java.lang.Character
General category "Sc" in the Unicode specification.
CURRENCY_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Currency Symbols" Unicode character block.
CurrencyNameProvider - Class in java.util.spi
An abstract class for service providers that provide localized currency symbols and display names for the Currency class.
CurrencyNameProvider() - Constructor for class java.util.spi.CurrencyNameProvider
Sole constructor.
current() - Method in class java.text.BreakIterator
Returns character index of the text boundary that was most recently returned by next(), next(int), previous(), first(), last(), following(int) or preceding(int).
current() - Method in interface java.text.CharacterIterator
Gets the character at the current position (as returned by getIndex()).
current() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.current() for String.
current() - Static method in class java.util.concurrent.ThreadLocalRandom
Returns the current thread's ThreadLocalRandom.
current() - Method in class javax.swing.text.ElementIterator
Fetches the current Element.
CURRENT - Static variable in interface javax.swing.text.html.parser.DTDConstants
current() - Method in class javax.swing.text.Segment
Gets the character at the current position (as returned by getIndex()).
Current - Interface in org.omg.CORBA
Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
Current - Interface in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
Current - Interface in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
current_component() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
current_component() - Method in class org.omg.DynamicAny._DynAnyStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynArrayStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynEnumStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynFixedStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynSequenceStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynStructStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynValueStub
Returns the DynAny for the component at the current position.
current_component() - Method in interface org.omg.DynamicAny.DynAnyOperations
Returns the DynAny for the component at the current position.
current_factory() - Method in interface org.omg.PortableInterceptor.IORInfoOperations
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
current_factory(ObjectReferenceFactory) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
current_member_kind() - Method in interface org.omg.CORBA.DynStruct
Deprecated.
Returns the TCKind object that describes the kind of the current member.
current_member_kind() - Method in interface org.omg.CORBA.DynValue
Deprecated.
Returns the TCKind object that describes the current member.
current_member_kind() - Method in class org.omg.DynamicAny._DynStructStub
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in class org.omg.DynamicAny._DynValueStub
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in interface org.omg.DynamicAny.DynStructOperations
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in interface org.omg.DynamicAny.DynValueOperations
Returns the TCKind associated with the member at the current position.
current_member_name() - Method in interface org.omg.CORBA.DynStruct
Deprecated.
During a traversal, returns the name of the current member.
current_member_name() - Method in interface org.omg.CORBA.DynValue
Deprecated.
Returns the name of the current member while traversing a DynAny object that represents a Value object.
current_member_name() - Method in class org.omg.DynamicAny._DynStructStub
Returns the name of the member at the current position.
current_member_name() - Method in class org.omg.DynamicAny._DynValueStub
Returns the name of the member at the current position.
current_member_name() - Method in interface org.omg.DynamicAny.DynStructOperations
Returns the name of the member at the current position.
current_member_name() - Method in interface org.omg.DynamicAny.DynValueOperations
Returns the name of the member at the current position.
currentCellRenderer - Variable in class javax.swing.plaf.basic.BasicTreeUI
Renderer that is being used to do the actual cell drawing.
currentClassLoader() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
currentGroupID() - Static method in class java.rmi.activation.ActivationGroup
Returns the current activation group's identifier.
CurrentHelper - Class in org.omg.CORBA
The Helper for Current.
CurrentHelper() - Constructor for class org.omg.CORBA.CurrentHelper
CurrentHelper - Class in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
CurrentHelper() - Constructor for class org.omg.PortableInterceptor.CurrentHelper
CurrentHelper - Class in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
CurrentHelper() - Constructor for class org.omg.PortableServer.CurrentHelper
CurrentHolder - Class in org.omg.CORBA
The Holder for Current.
CurrentHolder() - Constructor for class org.omg.CORBA.CurrentHolder
CurrentHolder(Current) - Constructor for class org.omg.CORBA.CurrentHolder
currentLoadedClass() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
currentManager(Component) - Static method in class javax.swing.RepaintManager
Return the RepaintManager for the calling thread given a Component.
currentManager(JComponent) - Static method in class javax.swing.RepaintManager
Return the RepaintManager for the calling thread given a JComponent.
currentMouseX - Variable in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
currentMouseX - Variable in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
currentMouseY - Variable in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
currentMouseY - Variable in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
CurrentOperations - Interface in org.omg.CORBA
The interface for Current.
CurrentOperations - Interface in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
CurrentOperations - Interface in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
currentSegment(float[]) - Method in class java.awt.geom.FlatteningPathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(double[]) - Method in class java.awt.geom.FlatteningPathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(float[]) - Method in interface java.awt.geom.PathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(double[]) - Method in interface java.awt.geom.PathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentThread() - Static method in class java.lang.Thread
Returns a reference to the currently executing thread object.
currentTimeMillis() - Static method in class java.lang.System
Returns the current time in milliseconds.
currentValuePane - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
Cursor - Class in java.awt
A class to encapsulate the bitmap representation of the mouse cursor.
Cursor(int) - Constructor for class java.awt.Cursor
Creates a new cursor object with the specified type.
Cursor(String) - Constructor for class java.awt.Cursor
Creates a new custom cursor object with the specified name.
cursorMoved(RowSetEvent) - Method in interface javax.sql.RowSetListener
Notifies registered listeners that a RowSet object's cursor has moved.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D.Double
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(float, float, float, float, float, float) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
CUSTOM_CURSOR - Static variable in class java.awt.Cursor
The type associated with all custom cursors.
CUSTOM_DIALOG - Static variable in class javax.swing.JFileChooser
Type value indicating that the JFileChooser supports a developer-specified file operation.
Customizer - Interface in java.beans
A customizer class provides a complete custom GUI for customizing a target Java Bean.
CustomMarshal - Interface in org.omg.CORBA
An abstract value type that is meant to be used by the ORB, not the user.
CustomValue - Interface in org.omg.CORBA.portable
An extension of ValueBase that is implemented by custom value types.
cut(int, int) - Method in interface javax.accessibility.AccessibleEditableText
Cuts the text between two indices into the system clipboard.
cut() - Method in class javax.swing.JPasswordField
Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
cut(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Cuts the text between two indices into the system clipboard.
cut(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Cuts the text between two indices into the system clipboard.
cut() - Method in class javax.swing.text.JTextComponent
Transfers the currently selected range in the associated text model to the system clipboard, removing the contents from the model.
cutAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to cut the selected region and place the contents into the system clipboard.
cxt - Variable in exception org.omg.CosNaming.NamingContextPackage.CannotProceed
cyan - Static variable in class java.awt.Color
The color cyan.
CYAN - Static variable in class java.awt.Color
The color cyan.
CyclicBarrier - Class in java.util.concurrent
A synchronization aid that allows a set of threads to all wait for each other to reach a common barrier point.
CyclicBarrier(int, Runnable) - Constructor for class java.util.concurrent.CyclicBarrier
Creates a new CyclicBarrier that will trip when the given number of parties (threads) are waiting upon it, and which will execute the given barrier action when the barrier is tripped, performed by the last thread entering the barrier.
CyclicBarrier(int) - Constructor for class java.util.concurrent.CyclicBarrier
Creates a new CyclicBarrier that will trip when the given number of parties (threads) are waiting upon it, and does not perform a predefined action when the barrier is tripped.
CYPRIOT_SYLLABARY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cypriot Syllabary" Unicode character block.
CYRILLIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic" Unicode character block.
CYRILLIC_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Extended-A" Unicode character block.
CYRILLIC_EXTENDED_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Extended-B" Unicode character block.
CYRILLIC_SUPPLEMENTARY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Supplementary" Unicode character block.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类


D-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

D - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering D, 22 x 34 in.
D - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering D size, 22 inch by 34 inch.
D - Static variable in class javax.print.attribute.standard.MediaSizeName
D size .
damage(Rectangle) - Method in class javax.swing.text.DefaultCaret
Damages the area surrounding the caret to cause it to be repainted in a new location.
damageLineRange(int, int, Shape, Component) - Method in class javax.swing.text.PlainView
Repaint the given line range.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.basic.BasicTextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the damageRange method on each UI handled by this object.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the damageRange method on each UI handled by this object.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.TextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.TextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
DARK - Static variable in class javax.swing.plaf.metal.MetalIconFactory
DARK_GRAY - Static variable in class java.awt.Color
The color dark gray.
darker() - Method in class java.awt.Color
Creates a new Color that is a darker version of this Color.
darkGray - Static variable in class java.awt.Color
The color dark gray.
darkShadow - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
darkShadow - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder
darkShadow - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
darkShadowColor - Static variable in class javax.swing.plaf.metal.MetalSliderUI
DASH_PUNCTUATION - Static variable in class java.lang.Character
General category "Pd" in the Unicode specification.
data - Variable in class javax.sound.midi.MidiMessage
The MIDI message data.
DATA - Static variable in class javax.swing.text.html.HTML.Attribute
data - Variable in class javax.swing.text.html.parser.Element
A field to store user data.
data - Variable in class javax.swing.text.html.parser.Entity
Data - Interface in javax.xml.crypto
An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
DATA_CONVERSION - Exception in org.omg.CORBA
This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
DATA_CONVERSION() - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
DATA_CONVERSION(String) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified detail.
DATA_CONVERSION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
DATA_CONVERSION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.
DATA_TRANSFER_COMPLETE - Static variable in class javax.print.event.PrintJobEvent
The job is not necessarily printed yet, but the data has been transferred successfully from the client to the print service.
DatabaseMetaData - Interface in java.sql
Comprehensive information about the database as a whole.
DataBindingException - Exception in javax.xml.bind
Exception that represents a failure in a JAXB operation.
DataBindingException(String, Throwable) - Constructor for exception javax.xml.bind.DataBindingException
DataBindingException(Throwable) - Constructor for exception javax.xml.bind.DataBindingException
DataBuffer - Class in java.awt.image
This class exists to wrap one or more data arrays.
DataBuffer(int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer containing one bank of the specified data type and size.
DataBuffer(int, int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer containing the specified number of banks.
DataBuffer(int, int, int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer that contains the specified number of banks.
DataBuffer(int, int, int, int[]) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer which contains the specified number of banks.
dataBuffer - Variable in class java.awt.image.Raster
The DataBuffer that stores the image data.
DataBufferByte - Class in java.awt.image
This class extends DataBuffer and stores data internally as bytes.
DataBufferByte(int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank and the specified size.
DataBufferByte(int, int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte based DataBuffer with the specified number of banks all of which are the specified size.
DataBufferByte(byte[], int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank using the specified array.
DataBufferByte(byte[], int, int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferByte(byte[][], int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with the specified arrays.
DataBufferByte(byte[][], int, int[]) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with the specified arrays, size, and offsets.
DataBufferDouble - Class in java.awt.image
This class extends DataBuffer and stores data internally in double form.
DataBufferDouble(int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with a specified size.
DataBufferDouble(int, int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with a specified number of banks, all of which are of a specified size.
DataBufferDouble(double[], int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data array.
DataBufferDouble(double[], int, int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data array.
DataBufferDouble(double[][], int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data arrays.
DataBufferDouble(double[][], int, int[]) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data arrays, size, and per-bank offsets.
DataBufferFloat - Class in java.awt.image
This class extends DataBuffer and stores data internally in float form.
DataBufferFloat(int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with a specified size.
DataBufferFloat(int, int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with a specified number of banks, all of which are of a specified size.
DataBufferFloat(float[], int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data array.
DataBufferFloat(float[], int, int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data array.
DataBufferFloat(float[][], int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data arrays.
DataBufferFloat(float[][], int, int[]) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data arrays, size, and per-bank offsets.
DataBufferInt - Class in java.awt.image
This class extends DataBuffer and stores data internally as integers.
DataBufferInt(int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank and the specified size.
DataBufferInt(int, int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified number of banks, all of which are the specified size.
DataBufferInt(int[], int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank using the specified array.
DataBufferInt(int[], int, int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferInt(int[][], int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified arrays.
DataBufferInt(int[][], int, int[]) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified arrays, size, and offsets.
DataBufferShort - Class in java.awt.image
This class extends DataBuffer and stores data internally as shorts.
DataBufferShort(int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank and the specified size.
DataBufferShort(int, int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified number of banks all of which are the specified size.
DataBufferShort(short[], int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank using the specified array.
DataBufferShort(short[], int, int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferShort(short[][], int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified arrays.
DataBufferShort(short[][], int, int[]) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified arrays, size, and offsets.
DataBufferUShort - Class in java.awt.image
This class extends DataBuffer and stores data internally as shorts.
DataBufferUShort(int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank and the specified size.
DataBufferUShort(int, int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with the specified number of banks, all of which are the specified size.
DataBufferUShort(short[], int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank using the specified array.
DataBufferUShort(short[], int, int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferUShort(short[][], int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with the specified arrays.
DataBufferUShort(short[][], int, int[]) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with specified arrays, size, and offsets.
DataContentHandler - Interface in javax.activation
The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory - Interface in javax.activation
This interface defines a factory for DataContentHandlers.
dataDefinitionCausesTransactionCommit() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a data definition statement within a transaction forces the transaction to commit.
dataDefinitionIgnoredInTransactions() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database ignores a data definition statement within a transaction.
DataFlavor - Class in java.awt.datatransfer
A DataFlavor provides meta information about data.
DataFlavor() - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a new DataFlavor.
DataFlavor(Class<?>, String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a Java class.
DataFlavor(String, String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a MimeType.
DataFlavor(String, String, ClassLoader) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a MimeType.
DataFlavor(String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor from a mimeType string.
DataFormatException - Exception in java.util.zip
Signals that a data format error has occurred.
DataFormatException() - Constructor for exception java.util.zip.DataFormatException
Constructs a DataFormatException with no detail message.
DataFormatException(String) - Constructor for exception java.util.zip.DataFormatException
Constructs a DataFormatException with the specified detail message.
DatagramChannel - Class in java.nio.channels
A selectable channel for datagram-oriented sockets.
DatagramChannel(SelectorProvider) - Constructor for class java.nio.channels.DatagramChannel
Initializes a new instance of this class.
DatagramPacket - Class in java.net
This class represents a datagram packet.
DatagramPacket(byte[], int, int) - Constructor for class java.net.DatagramPacket
Constructs a DatagramPacket for receiving packets of length length, specifying an offset into the buffer.
DatagramPacket(byte[], int) - Constructor for class java.net.DatagramPacket
Constructs a DatagramPacket for receiving packets of length length.
DatagramPacket(byte[], int, int, InetAddress, int) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length with offset ioffsetto the specified port number on the specified host.
DatagramPacket(byte[], int, int, SocketAddress) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length with offset ioffsetto the specified port number on the specified host.
DatagramPacket(byte[], int, InetAddress, int) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length to the specified port number on the specified host.
DatagramPacket(byte[], int, SocketAddress) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length to the specified port number on the specified host.
DatagramSocket - Class in java.net
This class represents a socket for sending and receiving datagram packets.
DatagramSocket() - Constructor for class java.net.DatagramSocket
Constructs a datagram socket and binds it to any available port on the local host machine.
DatagramSocket(DatagramSocketImpl) - Constructor for class java.net.DatagramSocket
Creates an unbound datagram socket with the specified DatagramSocketImpl.
DatagramSocket(SocketAddress) - Constructor for class java.net.DatagramSocket
Creates a datagram socket, bound to the specified local socket address.
DatagramSocket(int) - Constructor for class java.net.DatagramSocket
Constructs a datagram socket and binds it to the specified port on the local host machine.
DatagramSocket(int, InetAddress) - Constructor for class java.net.DatagramSocket
Creates a datagram socket, bound to the specified local address.
DatagramSocketImpl - Class in java.net
Abstract datagram and multicast socket implementation base class.
DatagramSocketImpl() - Constructor for class java.net.DatagramSocketImpl
DatagramSocketImplFactory - Interface in java.net
This interface defines a factory for datagram socket implementations.
DataHandler - Class in javax.activation
The DataHandler class provides a consistent interface to data available in many different sources and formats.
DataHandler(DataSource) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object, String) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing a URL.
DataInput - Interface in java.io
The DataInput interface provides for reading bytes from a binary stream and reconstructing from them data in any of the Java primitive types.
DataInputStream - Class in java.io
A data input stream lets an application read primitive Java data types from an underlying input stream in a machine-independent way.
DataInputStream(InputStream) - Constructor for class java.io.DataInputStream
Creates a DataInputStream that uses the specified underlying InputStream.
DataInputStream - Interface in org.omg.CORBA
Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
DataLine - Interface in javax.sound.sampled
DataLine adds media-related functionality to its superinterface, Line.
DataLine.Info - Class in javax.sound.sampled
Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines.
DataLine.Info(Class<?>, AudioFormat[], int, int) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a set of supported audio formats and a range for the buffer size.
DataLine.Info(Class<?>, AudioFormat, int) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a single audio format and a desired buffer size.
DataLine.Info(Class<?>, AudioFormat) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a single audio format.
DATALINK - Static variable in class java.sql.Types
The constant in the Java programming language, somtimes referred to as a type code, that identifies the generic SQL type DATALINK.
dataModel - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
dataModel - Variable in class javax.swing.JTable
The TableModel of the table.
DataOutput - Interface in java.io
The DataOutput interface provides for converting data from any of the Java primitive types to a series of bytes and writing these bytes to a binary stream.
DataOutputStream - Class in java.io
A data output stream lets an application write primitive Java data types to an output stream in a portable way.
DataOutputStream(OutputStream) - Constructor for class java.io.DataOutputStream
Creates a new data output stream to write data to the specified underlying output stream.
DataOutputStream - Interface in org.omg.CORBA
Defines the methods used to write primitive data types to output streams for marshalling custom value types.
DataSource - Interface in javax.activation
The DataSource interface provides the JavaBeans Activation Framework with an abstraction of an arbitrary collection of data.
DataSource - Interface in javax.sql
A factory for connections to the physical data source that this DataSource object represents.
DATASOURCE_DB_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on the entire data source that is the source of data for the RowSet object that is using this SyncProvider object.
DATASOURCE_NO_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that no locks remain on the originating data source.
DATASOURCE_ROW_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on the rows that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
DATASOURCE_TABLE_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on all tables that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
DataTruncation - Exception in java.sql
An exception thrown as a DataTruncation exception (on writes) or reported as a DataTruncation warning (on reads) when a data values is unexpectedly truncated for reasons other than its having execeeded MaxFieldSize.
DataTruncation(int, boolean, boolean, int, int) - Constructor for exception java.sql.DataTruncation
Creates a DataTruncation object with the SQLState initialized to 01004 when read is set to true and 22001 when read is set to false, the reason set to "Data truncation", the vendor code set to 0, and the other fields set to the given values.
DataTruncation(int, boolean, boolean, int, int, Throwable) - Constructor for exception java.sql.DataTruncation
Creates a DataTruncation object with the SQLState initialized to 01004 when read is set to true and 22001 when read is set to false, the reason set to "Data truncation", the vendor code set to 0, and the other fields set to the given values.
dataType - Variable in class java.awt.image.DataBuffer
The data type of this DataBuffer.
dataType - Variable in class java.awt.image.SampleModel
Data type of the DataBuffer storing the pixel data.
DATATYPE_BOOLEAN - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is one of the boolean values 'true' or 'false'.
DATATYPE_DOUBLE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of a double-precision decimal floating-point number.
DATATYPE_FLOAT - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of a decimal floating-point number.
DATATYPE_INTEGER - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of an integer.
DATATYPE_STRING - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a general Unicode string.
DatatypeConfigurationException - Exception in javax.xml.datatype
Indicates a serious configuration error.
DatatypeConfigurationException() - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with no specified detail mesage and cause.
DatatypeConfigurationException(String) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified detail message.
DatatypeConfigurationException(String, Throwable) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified detail message and cause.
DatatypeConfigurationException(Throwable) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified cause.
DatatypeConstants - Class in javax.xml.datatype
Utility class to contain basic Datatype values as constants.
DatatypeConstants.Field - Class in javax.xml.datatype
Type-safe enum class that represents six fields of the Duration class.
DatatypeConverter - Class in javax.xml.bind
The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
DatatypeConverterInterface - Interface in javax.xml.bind
The DatatypeConverterInterface is for JAXB provider use only.
DatatypeFactory - Class in javax.xml.datatype
Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
DatatypeFactory() - Constructor for class javax.xml.datatype.DatatypeFactory
Protected constructor to prevent instaniation outside of package.
DATATYPEFACTORY_IMPLEMENTATION_CLASS - Static variable in class javax.xml.datatype.DatatypeFactory
Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
DATATYPEFACTORY_PROPERTY - Static variable in class javax.xml.datatype.DatatypeFactory
Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
dataVector - Variable in class javax.swing.table.DefaultTableModel
The Vector of Vectors of Object values.
Date - Class in java.sql
A thin wrapper around a millisecond value that allows JDBC to identify this as an SQL DATE value.
Date(int, int, int) - Constructor for class java.sql.Date
Deprecated.
instead use the constructor Date(long date)
Date(long) - Constructor for class java.sql.Date
Constructs a Date object using the given milliseconds time value.
DATE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DATE.
DATE - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the month.
Date - Class in java.util
The class Date represents a specific instant in time, with millisecond precision.
Date() - Constructor for class java.util.Date
Allocates a Date object and initializes it so that it represents the time at which it was allocated, measured to the nearest millisecond.
Date(long) - Constructor for class java.util.Date
Allocates a Date object and initializes it to represent the specified number of milliseconds since the standard base time known as "the epoch", namely January 1, 1970, 00:00:00 GMT.
Date(int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date) or GregorianCalendar(year + 1900, month, date).
Date(int, int, int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min) or GregorianCalendar(year + 1900, month, date, hrs, min).
Date(int, int, int, int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min, sec) or GregorianCalendar(year + 1900, month, date, hrs, min, sec).
Date(String) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by DateFormat.parse(String s).
DATE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.util.Date.
DATE - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema 1.0 datatype date.
DATE_EDITOR - Static variable in class javax.accessibility.AccessibleRole
A DATE_EDITOR is a component that allows users to edit java.util.Date and java.util.Time objects
DATE_FIELD - Static variable in class java.text.DateFormat
Useful constant for DATE field alignment.
dateFilter(RowFilter.ComparisonType, Date, int...) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria.
DateFormat - Class in java.text
DateFormat is an abstract class for date/time formatting subclasses which formats and parses dates or time in a language-independent manner.
DateFormat() - Constructor for class java.text.DateFormat
Create a new date format.
DateFormat.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from DateFormat.formatToCharacterIterator and as field identifiers in FieldPosition.
DateFormat.Field(String, int) - Constructor for class java.text.DateFormat.Field
Creates a Field.
DateFormatProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the DateFormat class.
DateFormatProvider() - Constructor for class java.text.spi.DateFormatProvider
Sole constructor.
DateFormatSymbols - Class in java.text
DateFormatSymbols is a public class for encapsulating localizable date-time formatting data, such as the names of the months, the names of the days of the week, and the time zone data.
DateFormatSymbols() - Constructor for class java.text.DateFormatSymbols
Construct a DateFormatSymbols object by loading format data from resources for the default locale.
DateFormatSymbols(Locale) - Constructor for class java.text.DateFormatSymbols
Construct a DateFormatSymbols object by loading format data from resources for the given locale.
DateFormatSymbolsProvider - Class in java.text.spi
An abstract class for service providers that provide instances of the DateFormatSymbols class.
DateFormatSymbolsProvider() - Constructor for class java.text.spi.DateFormatSymbolsProvider
Sole constructor.
DateFormatter - Class in javax.swing.text
DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
DateFormatter() - Constructor for class javax.swing.text.DateFormatter
This is shorthand for new DateFormatter(DateFormat.getDateInstance()).
DateFormatter(DateFormat) - Constructor for class javax.swing.text.DateFormatter
Returns a DateFormatter configured with the specified Format instance.
DATETIME - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
DateTimeAtCompleted - Class in javax.print.attribute.standard
Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).
DateTimeAtCompleted(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtCompleted
Construct a new date-time at completed attribute with the given Date value.
DateTimeAtCreation - Class in javax.print.attribute.standard
Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.
DateTimeAtCreation(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtCreation
Construct a new date-time at creation attribute with the given Date value.
DateTimeAtProcessing - Class in javax.print.attribute.standard
Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.
DateTimeAtProcessing(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtProcessing
Construct a new date-time at processing attribute with the given Date value.
DateTimeSyntax - Class in javax.print.attribute
Class DateTimeSyntax is an abstract base class providing the common implementation of all attributes whose value is a date and time.
DateTimeSyntax(Date) - Constructor for class javax.print.attribute.DateTimeSyntax
Construct a new date-time attribute with the given java.util.Date value.
DAY_OF_MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the day of month field.
DAY_OF_MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the month.
DAY_OF_WEEK - Static variable in class java.text.DateFormat.Field
Constant identifying the day of week field.
DAY_OF_WEEK - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the week.
DAY_OF_WEEK_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_WEEK field alignment.
DAY_OF_WEEK_IN_MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the day of week field.
DAY_OF_WEEK_IN_MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the ordinal number of the day of the week within the current month.
DAY_OF_WEEK_IN_MONTH_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_WEEK_IN_MONTH field alignment.
DAY_OF_YEAR - Static variable in class java.text.DateFormat.Field
Constant identifying the day of year field.
DAY_OF_YEAR - Static variable in class java.util.Calendar
Field number for get and set indicating the day number within the current year.
DAY_OF_YEAR_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_YEAR field alignment.
DAYS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the days field.
dbgTag - Variable in class javax.management.monitor.Monitor
Deprecated.
No replacement.
DD - Static variable in class javax.swing.text.html.HTML.Tag
deactivate(boolean) - Method in interface java.awt.im.spi.InputMethod
Deactivates the input method.
deactivate() - Method in interface javax.rmi.CORBA.Tie
Deactivates the target object represented by this tie.
deactivate(boolean, boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
deactivate_object(byte[]) - Method in interface org.omg.PortableServer.POAOperations
This operation causes the ObjectId specified in the oid parameter to be deactivated.
deactivateFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
deactivateFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, indicate that this frame has lost focus.
deactivateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the frame is no longer selected.
DebugGraphics - Class in javax.swing
Graphics subclass supporting graphics debugging.
DebugGraphics() - Constructor for class javax.swing.DebugGraphics
Constructs a new debug graphics context that supports slowed down drawing.
DebugGraphics(Graphics, JComponent) - Constructor for class javax.swing.DebugGraphics
Constructs a debug graphics context from an existing graphics context that slows down drawing for the specified component.
DebugGraphics(Graphics) - Constructor for class javax.swing.DebugGraphics
Constructs a debug graphics context from an existing graphics context that supports slowed down drawing.
decapitalize(String) - Static method in class java.beans.Introspector
Utility method to take a string and convert it to normal Java variable name capitalization.
DECEMBER - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the twelfth month of the year in the Gregorian and Julian calendars.
DECEMBER - Static variable in class javax.xml.datatype.DatatypeConstants
Value for twelve month of year.
DECIMAL - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DECIMAL.
DECIMAL128 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal128 format, 34 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL32 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal32 format, 7 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL64 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal64 format, 16 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL_DIGIT_NUMBER - Static variable in class java.lang.Character
General category "Nd" in the Unicode specification.
DECIMAL_SEPARATOR - Static variable in class java.text.NumberFormat.Field
Constant identifying the decimal separator field.
DecimalFormat - Class in java.text
DecimalFormat is a concrete subclass of NumberFormat that formats decimal numbers.
DecimalFormat() - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the default pattern and symbols for the default locale.
DecimalFormat(String) - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the given pattern and the symbols for the default locale.
DecimalFormat(String, DecimalFormatSymbols) - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the given pattern and symbols.
DecimalFormatSymbols - Class in java.text
This class represents the set of symbols (such as the decimal separator, the grouping separator, and so on) needed by DecimalFormat to format numbers.
DecimalFormatSymbols() - Constructor for class java.text.DecimalFormatSymbols
Create a DecimalFormatSymbols object for the default locale.
DecimalFormatSymbols(Locale) - Constructor for class java.text.DecimalFormatSymbols
Create a DecimalFormatSymbols object for the given locale.
DecimalFormatSymbolsProvider - Class in java.text.spi
An abstract class for service providers that provide instances of the DecimalFormatSymbols class.
DecimalFormatSymbolsProvider() - Constructor for class java.text.spi.DecimalFormatSymbolsProvider
Sole constructor.
DECLARE - Static variable in class javax.swing.text.html.HTML.Attribute
DECLARED - Static variable in interface java.lang.reflect.Member
Identifies the set of declared members of a class or interface.
DeclaredType - Interface in javax.lang.model.type
Represents a declared type, either a class type or an interface type.
declaredType - Variable in class javax.xml.bind.JAXBElement
Java datatype binding for xml element declaration's type.
declarePrefix(String, String) - Method in class org.xml.sax.helpers.NamespaceSupport
Declare a Namespace prefix.
DeclHandler - Interface in org.xml.sax.ext
SAX2 extension handler for DTD declaration events.
decode(String) - Static method in class java.awt.Color
Converts a String to an integer and returns the specified opaque Color.
decode(String) - Static method in class java.awt.Font
Returns the Font that the str argument describes.
decode(String) - Static method in class java.lang.Byte
Decodes a String into a Byte.
decode(String) - Static method in class java.lang.Integer
Decodes a String into an Integer.
decode(String) - Static method in class java.lang.Long
Decodes a String into a Long.
decode(String) - Static method in class java.lang.Short
Decodes a String into a Short.
decode(String) - Static method in class java.net.URLDecoder
Deprecated.
The resulting string may vary depending on the platform's default encoding. Instead, use the decode(String,String) method to specify the encoding.
decode(String, String) - Static method in class java.net.URLDecoder
Decodes a application/x-www-form-urlencoded string using a specific encoding scheme.
decode(ByteBuffer) - Method in class java.nio.charset.Charset
Convenience method that decodes bytes in this charset into Unicode characters.
decode(ByteBuffer, CharBuffer, boolean) - Method in class java.nio.charset.CharsetDecoder
Decodes as many bytes as possible from the given input buffer, writing the results to the given output buffer.
decode(ByteBuffer) - Method in class java.nio.charset.CharsetDecoder
Convenience method that decodes the remaining content of a single input byte buffer into a newly-allocated character buffer.
decode(InputStream) - Method in interface java.security.Certificate
Deprecated.
Decodes a certificate from an input stream.
decode(byte[]) - Method in interface org.omg.IOP.CodecOperations
Decodes the given byte array into an Any based on the encoding format effective for this Codec.
decode_value(byte[], TypeCode) - Method in interface org.omg.IOP.CodecOperations
Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
decodeAnchorX(float, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded X value of the control point, and the offset distance to the anchor from that control point.
decodeAnchorY(float, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded Y value of the control point, and the offset distance to the anchor from that control point.
decodeColor(String, float, float, float, int) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a color, which is derived from a base color in UI defaults.
decodeColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a color, which is derived from a offset between two other colors.
decodeDataFlavor(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Decodes a String native for use as a DataFlavor.
decodeGradient(float, float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Given parameters for creating a LinearGradientPaint, this method will create and return a linear gradient paint.
decodeJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Decodes a String native for use as a Java MIME type.
decodeLineStyle(Object) - Method in class javax.swing.plaf.metal.MetalTreeUI
this function converts between the string passed into the client property and the internal representation (currently and int)
decodeLoop(ByteBuffer, CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Decodes one or more bytes into one or more characters.
decodeRadialGradient(float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Given parameters for creating a RadialGradientPaint, this method will create and return a radial gradient paint.
decodeX(float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the given encoded X value.
decodeY(float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the given encoded y value.
decorateTask(Runnable, RunnableScheduledFuture<V>) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Modifies or replaces the task used to execute a runnable.
decorateTask(Callable<V>, RunnableScheduledFuture<V>) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Modifies or replaces the task used to execute a callable.
decrButton - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
DECREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic.BasicScrollBarUI
decreaseButton - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
DECREMENT - Static variable in interface javax.accessibility.AccessibleAction
An action which decrements a value.
decrementAndGet() - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically decrements by one the current value.
decrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically decrements by one the element at index i.
decrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically decrements by one the current value of the field of the given object managed by this updater.
decrementAndGet() - Method in class java.util.concurrent.atomic.AtomicLong
Atomically decrements by one the current value.
decrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically decrements by one the element at index i.
decrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically decrements by one the current value of the field of the given object managed by this updater.
decrGap - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
Distance between the decrement button and the track.
decrIndent() - Method in class javax.swing.text.AbstractWriter
Decrements the indent level.
DECRYPT - Static variable in class javax.xml.crypto.KeySelector.Purpose
A key for decrypting.
DECRYPT_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to decryption mode.
deepEquals(Object[], Object[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays are deeply equal to one another.
deepEquals(Object, Object) - Static method in class java.util.Objects
Returns true if the arguments are deeply equal to each other and false otherwise.
deepHashCode(Object[]) - Static method in class java.util.Arrays
Returns a hash code based on the "deep contents" of the specified array.
deepToString(Object[]) - Static method in class java.util.Arrays
Returns a string representation of the "deep contents" of the specified array.
def - Variable in class java.util.zip.DeflaterInputStream
Compressor for this stream.
def - Variable in class java.util.zip.DeflaterOutputStream
Compressor for this stream.
def_kind() - Method in class org.omg.CORBA._IDLTypeStub
def_kind() - Method in interface org.omg.CORBA.IRObjectOperations
Returns the DefinitionKind corresponding to this Interface Repository object.
defAttributeList(String, int, int, String, String, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an AttributeList.
DEFAULT - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the Cursor should change to the default (no drop) Cursor.
DEFAULT - Static variable in class java.security.spec.PSSParameterSpec
The PSS parameter set with all default values.
DEFAULT - Static variable in class java.text.DateFormat
Constant for default style pattern.
DEFAULT - Static variable in class javax.crypto.spec.OAEPParameterSpec
The OAEP parameter set with all default values.
DEFAULT - Static variable in class javax.crypto.spec.PSource.PSpecified
The encoding input P whose value equals byte[0].
DEFAULT - Static variable in interface javax.swing.Action
Not currently used.
DEFAULT - Static variable in interface javax.swing.plaf.synth.SynthConstants
Indicates the region is the default.
DEFAULT - Static variable in interface javax.swing.text.html.parser.DTDConstants
DEFAULT - Static variable in class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Indicates the default namespace ("#default").
DEFAULT_CARET_POLICY - Static variable in class java.awt.font.TextLayout
This CaretPolicy is used when a policy is not specified by the client.
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorFactory
Name of the attribute that specifies the default class loader.
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the default class loader.
DEFAULT_CLASS_LOADER_NAME - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the default class loader MBean name.
DEFAULT_COMPRESSION - Static variable in class java.util.zip.Deflater
Default compression level.
DEFAULT_CSS - Static variable in class javax.swing.text.html.HTMLEditorKit
Default Cascading Style Sheet file that sets up the tag views.
DEFAULT_CURSOR - Static variable in class java.awt.Cursor
The default cursor type (gets set if no cursor is defined).
DEFAULT_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.DEFAULT_CURSOR.
default_index() - Method in class org.omg.CORBA.TypeCode
Returns the index of the default member, or -1 if there is no default member.
DEFAULT_JUSTIFICATION - Static variable in class javax.swing.border.TitledBorder
Use the default justification for the title text.
DEFAULT_KEYMAP - Static variable in class javax.swing.text.JTextComponent
The default keymap that will be shared by all JTextComponent instances unless they have had a different keymap set.
DEFAULT_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Default layer.
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss.GSSContext
A lifetime constant representing the default context lifetime.
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss.GSSCredential
A lifetime constant representing the default credential lifetime.
DEFAULT_MODALITY_TYPE - Static variable in class java.awt.Dialog
Default modality type for modal dialogs.
DEFAULT_NS_PREFIX - Static variable in class javax.xml.XMLConstants
Prefix to use to represent the default XML Namespace.
DEFAULT_OBJECT_MODEL_URI - Static variable in class javax.xml.xpath.XPathFactory
Default Object Model URI.
DEFAULT_OPTION - Static variable in class javax.swing.JOptionPane
Type meaning Look and Feel should not supply any options -- only use the options from the JOptionPane.
default_POA(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
DEFAULT_POSITION - Static variable in class javax.swing.border.TitledBorder
Use the default vertical orientation for the title text.
DEFAULT_PROPERTY_NAME - Static variable in class javax.xml.xpath.XPathFactory
The default property name according to the JAXP spec.
DEFAULT_SIZE - Static variable in class javax.swing.GroupLayout
Indicates the size from the component or gap should be used for a particular range value.
DEFAULT_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
The default protocol: SOAP 1.1 for backwards compatibility.
DEFAULT_STRATEGY - Static variable in class java.util.zip.Deflater
Default compression strategy.
DEFAULT_STYLE - Static variable in class javax.swing.text.StyleContext
The name given to the default logical style attached to paragraphs.
DEFAULT_VALUE - Variable in class javax.lang.model.util.ElementScanner6
The specified default value.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleElementVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleTypeVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE_FIELD - Static variable in class javax.management.JMX
The name of the defaultValue field.
defaultAction(Object, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
The default action for visit methods.
defaultAction(Element, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
The default action for visit methods.
defaultAction(TypeMirror, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
The default action for visit methods.
DefaultBoundedRangeModel - Class in javax.swing
A generic implementation of BoundedRangeModel.
DefaultBoundedRangeModel() - Constructor for class javax.swing.DefaultBoundedRangeModel
Initializes all of the properties with default values.
DefaultBoundedRangeModel(int, int, int, int) - Constructor for class javax.swing.DefaultBoundedRangeModel
Initializes value, extent, minimum and maximum.
defaultButton - Variable in class javax.swing.JRootPane
The button that gets activated when the pane has the focus and a UI-specific action like pressing the Enter key occurs.
DefaultButtonModel - Class in javax.swing
The default implementation of a Button component's data model.
DefaultButtonModel() - Constructor for class javax.swing.DefaultButtonModel
Constructs a DefaultButtonModel.
DefaultCaret - Class in javax.swing.text
A default implementation of Caret.
DefaultCaret() - Constructor for class javax.swing.text.DefaultCaret
Constructs a default caret.
DefaultCellEditor - Class in javax.swing
The default editor for table and tree cells.
DefaultCellEditor(JTextField) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor that uses a text field.
DefaultCellEditor(JCheckBox) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor object that uses a check box.
DefaultCellEditor(JComboBox) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor object that uses a combo box.
DefaultCellEditor.EditorDelegate - Class in javax.swing
The protected EditorDelegate class.
DefaultCellEditor.EditorDelegate() - Constructor for class javax.swing.DefaultCellEditor.EditorDelegate
defaultCharset() - Static method in class java.nio.charset.Charset
Returns the default charset of this Java virtual machine.
defaultChoosers - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
DefaultColorSelectionModel - Class in javax.swing.colorchooser
A generic implementation of ColorSelectionModel.
DefaultColorSelectionModel() - Constructor for class javax.swing.colorchooser.DefaultColorSelectionModel
Creates a DefaultColorSelectionModel with the current color set to Color.white.
DefaultColorSelectionModel(Color) - Constructor for class javax.swing.colorchooser.DefaultColorSelectionModel
Creates a DefaultColorSelectionModel with the current color set to color, which should be non-null.
DefaultComboBoxModel - Class in javax.swing
The default model for combo boxes.
DefaultComboBoxModel() - Constructor for class javax.swing.DefaultComboBoxModel
Constructs an empty DefaultComboBoxModel object.
DefaultComboBoxModel(Object[]) - Constructor for class javax.swing.DefaultComboBoxModel
Constructs a DefaultComboBoxModel object initialized with an array of objects.
DefaultComboBoxModel(Vector<?>) - Constructor for class javax.swing.DefaultComboBoxModel
Constructs a DefaultComboBoxModel object initialized with a vector.
defaultConstraints - Variable in class java.awt.GridBagLayout
This field holds a gridbag constraints instance containing the default values, so if a component does not have gridbag constraints associated with it, then the component will be assigned a copy of the defaultConstraints.
defaultController - Variable in class javax.imageio.IIOParam
The default IIOParamController that will be used to provide settings for this IIOParam object when the activateController method is called.
defaultController - Variable in class javax.imageio.metadata.IIOMetadata
An IIOMetadataController that is suggested for use as the controller for this IIOMetadata object.
DefaultCopyDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a copy operation indicating that a drop is currently allowed.
DefaultCopyNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a copy operation indicating that a drop is currently not allowed.
DefaultDesktopManager - Class in javax.swing
This is an implementation of the DesktopManager.
DefaultDesktopManager() - Constructor for class javax.swing.DefaultDesktopManager
defaulted(String) - Method in class java.io.ObjectInputStream.GetField
Return true if the named field is defaulted and has no value in this stream.
DefaultEditorKit - Class in javax.swing.text
This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
DefaultEditorKit() - Constructor for class javax.swing.text.DefaultEditorKit
default constructor for DefaultEditorKit
DefaultEditorKit.BeepAction - Class in javax.swing.text
Creates a beep.
DefaultEditorKit.BeepAction() - Constructor for class javax.swing.text.DefaultEditorKit.BeepAction
Create this object with the appropriate identifier.
DefaultEditorKit.CopyAction - Class in javax.swing.text
Copies the selected region and place its contents into the system clipboard.
DefaultEditorKit.CopyAction() - Constructor for class javax.swing.text.DefaultEditorKit.CopyAction
Create this object with the appropriate identifier.
DefaultEditorKit.CutAction - Class in javax.swing.text
Cuts the selected region and place its contents into the system clipboard.
DefaultEditorKit.CutAction() - Constructor for class javax.swing.text.DefaultEditorKit.CutAction
Create this object with the appropriate identifier.
DefaultEditorKit.DefaultKeyTypedAction - Class in javax.swing.text
The action that is executed by default if a key typed event is received and there is no keymap entry.
DefaultEditorKit.DefaultKeyTypedAction() - Constructor for class javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
Creates this object with the appropriate identifier.
DefaultEditorKit.InsertBreakAction - Class in javax.swing.text
Places a line/paragraph break into the document.
DefaultEditorKit.InsertBreakAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertBreakAction
Creates this object with the appropriate identifier.
DefaultEditorKit.InsertContentAction - Class in javax.swing.text
Places content into the associated document.
DefaultEditorKit.InsertContentAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertContentAction
Creates this object with the appropriate identifier.
DefaultEditorKit.InsertTabAction - Class in javax.swing.text
Places a tab character into the document.
DefaultEditorKit.InsertTabAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertTabAction
Creates this object with the appropriate identifier.
DefaultEditorKit.PasteAction - Class in javax.swing.text
Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
DefaultEditorKit.PasteAction() - Constructor for class javax.swing.text.DefaultEditorKit.PasteAction
Create this object with the appropriate identifier.
defaultEditorsByColumnClass - Variable in class javax.swing.JTable
A table of objects that display and edit the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
DefaultFocusManager - Class in javax.swing
This class has been obsoleted by the 1.4 focus APIs.
DefaultFocusManager() - Constructor for class javax.swing.DefaultFocusManager
DefaultFocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy that determines traversal order based on the order of child Components in a Container.
DefaultFocusTraversalPolicy() - Constructor for class java.awt.DefaultFocusTraversalPolicy
defaultForkJoinWorkerThreadFactory - Static variable in class java.util.concurrent.ForkJoinPool
Creates a new ForkJoinWorkerThread.
DefaultFormatter - Class in javax.swing.text
DefaultFormatter formats aribtrary objects.
DefaultFormatter() - Constructor for class javax.swing.text.DefaultFormatter
Creates a DefaultFormatter.
DefaultFormatterFactory - Class in javax.swing.text
An implementation of JFormattedTextField.AbstractFormatterFactory.
DefaultFormatterFactory() - Constructor for class javax.swing.text.DefaultFormatterFactory
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatter.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultHandler - Class in org.xml.sax.helpers
Default base class for SAX2 event handlers.
DefaultHandler() - Constructor for class org.xml.sax.helpers.DefaultHandler
DefaultHandler2 - Class in org.xml.sax.ext
This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
DefaultHandler2() - Constructor for class org.xml.sax.ext.DefaultHandler2
Constructs a handler which ignores all parsing events.
DefaultHighlighter - Class in javax.swing.text
Implements the Highlighter interfaces.
DefaultHighlighter() - Constructor for class javax.swing.text.DefaultHighlighter
Creates a new DefaultHighlighther object.
DefaultHighlighter.DefaultHighlightPainter - Class in javax.swing.text
Simple highlight painter that fills a highlighted area with a solid color.
DefaultHighlighter.DefaultHighlightPainter(Color) - Constructor for class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
Constructs a new highlight painter.
defaultInitCtx - Variable in class javax.naming.InitialContext
Field holding the result of calling NamingManager.getInitialContext().
DefaultKeyboardFocusManager - Class in java.awt
The default KeyboardFocusManager for AWT applications.
DefaultKeyboardFocusManager() - Constructor for class java.awt.DefaultKeyboardFocusManager
defaultKeyTypedAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action that is executed by default if a key typed event is received and there is no keymap entry.
DefaultLinkDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a link operation indicating that a drop is currently allowed.
DefaultLinkNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a link operation indicating that a drop is currently not allowed.
DefaultListCellRenderer - Class in javax.swing
Renders an item in a list.
DefaultListCellRenderer() - Constructor for class javax.swing.DefaultListCellRenderer
Constructs a default renderer object for an item in a list.
DefaultListCellRenderer.UIResource - Class in javax.swing
A subclass of DefaultListCellRenderer that implements UIResource.
DefaultListCellRenderer.UIResource() - Constructor for class javax.swing.DefaultListCellRenderer.UIResource
DefaultListModel<E> - Class in javax.swing
This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur.
DefaultListModel() - Constructor for class javax.swing.DefaultListModel
DefaultListSelectionModel - Class in javax.swing
Default data model for list selections.
DefaultListSelectionModel() - Constructor for class javax.swing.DefaultListSelectionModel
DefaultLoaderRepository - Class in javax.management
Deprecated.
Use MBeanServer.getClassLoaderRepository() instead.
DefaultLoaderRepository() - Constructor for class javax.management.DefaultLoaderRepository
Deprecated.
DefaultLoaderRepository - Class in javax.management.loading
Deprecated.
Use MBeanServer.getClassLoaderRepository()} instead.
DefaultLoaderRepository() - Constructor for class javax.management.loading.DefaultLoaderRepository
Deprecated.
defaultManager() - Static method in class javax.swing.MenuSelectionManager
Returns the default menu selection manager.
DefaultMenuLayout - Class in javax.swing.plaf.basic
The default layout manager for Popup menus and menubars.
DefaultMenuLayout(Container, int) - Constructor for class javax.swing.plaf.basic.DefaultMenuLayout
DefaultMetalTheme - Class in javax.swing.plaf.metal
A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel".
DefaultMetalTheme() - Constructor for class javax.swing.plaf.metal.DefaultMetalTheme
Creates and returns an instance of DefaultMetalTheme.
DefaultMoveDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a move operation indicating that a drop is currently allowed.
DefaultMoveNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a move operation indicating that a drop is currently not allowed.
DefaultMutableTreeNode - Class in javax.swing.tree
A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
DefaultMutableTreeNode() - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node that has no parent and no children, but which allows children.
DefaultMutableTreeNode(Object) - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
DefaultMutableTreeNode(Object, boolean) - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.
defaultPage(PageFormat) - Method in class java.awt.print.PrinterJob
Clones the PageFormat argument and alters the clone to describe a default page size and orientation.
defaultPage() - Method in class java.awt.print.PrinterJob
Creates a new PageFormat instance and sets it to a default size and orientation.
DefaultPainter - Static variable in class javax.swing.text.DefaultHighlighter
Default implementation of LayeredHighlighter.LayerPainter that can be used for painting highlights.
DefaultPersistenceDelegate - Class in java.beans
The DefaultPersistenceDelegate is a concrete implementation of the abstract PersistenceDelegate class and is the delegate used by default for classes about which no information is available.
DefaultPersistenceDelegate() - Constructor for class java.beans.DefaultPersistenceDelegate
Creates a persistence delegate for a class with a nullary constructor.
DefaultPersistenceDelegate(String[]) - Constructor for class java.beans.DefaultPersistenceDelegate
Creates a default persistence delegate for a class with a constructor whose arguments are the values of the property names as specified by constructorPropertyNames.
defaultPressAction - Variable in class javax.swing.JRootPane
Deprecated.
As of Java 2 platform v1.3.
defaultReadObject() - Method in class java.io.ObjectInputStream
Read the non-static and non-transient fields of the current class from this stream.
defaultReleaseAction - Variable in class javax.swing.JRootPane
Deprecated.
As of Java 2 platform v1.3.
defaultRenderersByColumnClass - Variable in class javax.swing.JTable
A table of objects that display the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
DefaultRowSorter<M,I> - Class in javax.swing
An implementation of RowSorter that provides sorting and filtering around a grid-based data model.
DefaultRowSorter() - Constructor for class javax.swing.DefaultRowSorter
Creates an empty DefaultRowSorter.
DefaultRowSorter.ModelWrapper<M,I> - Class in javax.swing
DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter.
DefaultRowSorter.ModelWrapper() - Constructor for class javax.swing.DefaultRowSorter.ModelWrapper
Creates a new ModelWrapper.
defaults - Variable in class java.util.Properties
A property list that contains default values for any keys not found in this property list.
DefaultSingleSelectionModel - Class in javax.swing
A generic implementation of SingleSelectionModel.
DefaultSingleSelectionModel() - Constructor for class javax.swing.DefaultSingleSelectionModel
DefaultStyledDocument - Class in javax.swing.text
A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
DefaultStyledDocument(AbstractDocument.Content, StyleContext) - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a styled document.
DefaultStyledDocument(StyleContext) - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a styled document with the default content storage implementation and a shared set of styles.
DefaultStyledDocument() - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a default styled document.
DefaultStyledDocument.AttributeUndoableEdit - Class in javax.swing.text
An UndoableEdit used to remember AttributeSet changes to an Element.
DefaultStyledDocument.AttributeUndoableEdit(Element, AttributeSet, boolean) - Constructor for class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
DefaultStyledDocument.ElementBuffer - Class in javax.swing.text
Class to manage changes to the element hierarchy.
DefaultStyledDocument.ElementBuffer(Element) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementBuffer
Creates a new ElementBuffer.
DefaultStyledDocument.ElementSpec - Class in javax.swing.text
Specification for building elements.
DefaultStyledDocument.ElementSpec(AttributeSet, short) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor useful for markup when the markup will not be stored in the document.
DefaultStyledDocument.ElementSpec(AttributeSet, short, int) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor for parsing inside the document when the data has already been added, but len information is needed.
DefaultStyledDocument.ElementSpec(AttributeSet, short, char[], int, int) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor for creating a spec externally for batch input of content and markup into the document.
DefaultStyledDocument.SectionElement - Class in javax.swing.text
Default root element for a document...
DefaultStyledDocument.SectionElement() - Constructor for class javax.swing.text.DefaultStyledDocument.SectionElement
Creates a new SectionElement.
DefaultTableCellRenderer - Class in javax.swing.table
The standard class for rendering (displaying) individual cells in a JTable.
DefaultTableCellRenderer() - Constructor for class javax.swing.table.DefaultTableCellRenderer
Creates a default table cell renderer.
DefaultTableCellRenderer.UIResource - Class in javax.swing.table
A subclass of DefaultTableCellRenderer that implements UIResource.
DefaultTableCellRenderer.UIResource() - Constructor for class javax.swing.table.DefaultTableCellRenderer.UIResource
DefaultTableColumnModel - Class in javax.swing.table
The standard column-handler for a JTable.
DefaultTableColumnModel() - Constructor for class javax.swing.table.DefaultTableColumnModel
Creates a default table column model.
DefaultTableModel - Class in javax.swing.table
This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.
DefaultTableModel() - Constructor for class javax.swing.table.DefaultTableModel
Constructs a default DefaultTableModel which is a table of zero columns and zero rows.
DefaultTableModel(int, int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with rowCount and columnCount of null object values.
DefaultTableModel(Vector, int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
DefaultTableModel(Object[], int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
DefaultTableModel(Vector, Vector) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
DefaultTableModel(Object[][], Object[]) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
defaultTextIconGap - Variable in class javax.swing.plaf.basic.BasicButtonUI
defaultTextIconGap - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
defaultTextShiftOffset - Variable in class javax.swing.plaf.basic.BasicButtonUI
DefaultTextUI - Class in javax.swing.text
Deprecated.
DefaultTextUI() - Constructor for class javax.swing.text.DefaultTextUI
Deprecated.
defaultThreadFactory() - Static method in class java.util.concurrent.Executors
Returns a default thread factory used to create new threads.
DefaultTreeCellEditor - Class in javax.swing.tree
A TreeCellEditor.
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer) - Constructor for class javax.swing.tree.DefaultTreeCellEditor
Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor) - Constructor for class javax.swing.tree.DefaultTreeCellEditor
Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
DefaultTreeCellEditor.DefaultTextField - Class in javax.swing.tree
TextField used when no editor is supplied.
DefaultTreeCellEditor.DefaultTextField(Border) - Constructor for class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
Constructs a DefaultTreeCellEditor.DefaultTextField object.
DefaultTreeCellEditor.EditorContainer - Class in javax.swing.tree
Container responsible for placing the editingComponent.
DefaultTreeCellEditor.EditorContainer() - Constructor for class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Constructs an EditorContainer object.
DefaultTreeCellRenderer - Class in javax.swing.tree
Displays an entry in a tree.
DefaultTreeCellRenderer() - Constructor for class javax.swing.tree.DefaultTreeCellRenderer
Creates a DefaultTreeCellRenderer.
DefaultTreeModel - Class in javax.swing.tree
A simple tree data model that uses TreeNodes.
DefaultTreeModel(TreeNode) - Constructor for class javax.swing.tree.DefaultTreeModel
Creates a tree in which any node can have children.
DefaultTreeModel(TreeNode, boolean) - Constructor for class javax.swing.tree.DefaultTreeModel
Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
DefaultTreeSelectionModel - Class in javax.swing.tree
Default implementation of TreeSelectionModel.
DefaultTreeSelectionModel() - Constructor for class javax.swing.tree.DefaultTreeSelectionModel
Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.
DefaultValidationEventHandler - Class in javax.xml.bind.helpers
JAXB 1.0 only default validation event handler.
DefaultValidationEventHandler() - Constructor for class javax.xml.bind.helpers.DefaultValidationEventHandler
defaultWriteObject() - Method in class java.io.ObjectOutputStream
Write the non-static and non-transient fields of the current class to this stream.
defContentModel(int, Object, ContentModel) - Method in class javax.swing.text.html.parser.DTD
Creates and returns a new content model.
DEFECTIVE_CREDENTIAL - Static variable in exception org.ietf.jgss.GSSException
Defective credentials.
DEFECTIVE_TOKEN - Static variable in exception org.ietf.jgss.GSSException
Defective token.
defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an Element.
defEntity(String, int, int) - Method in class javax.swing.text.html.parser.DTD
Creates and returns a character Entity.
defEntity(String, int, String) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an Entity.
defineAttributes(String, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Defines attributes for an Element.
defineClass(byte[], int, int) - Method in class java.lang.ClassLoader
Deprecated.
Replaced by defineClass(String, byte[], int, int)
defineClass(String, byte[], int, int) - Method in class java.lang.ClassLoader
Converts an array of bytes into an instance of class 类.
defineClass(String, byte[], int, int, ProtectionDomain) - Method in class java.lang.ClassLoader
Converts an array of bytes into an instance of class 类, with an optional ProtectionDomain.
defineClass(String, ByteBuffer, ProtectionDomain) - Method in class java.lang.ClassLoader
Converts a ByteBuffer into an instance of class 类, with an optional ProtectionDomain.
defineClass(String, byte[], int, int, CodeSource) - Method in class java.security.SecureClassLoader
Converts an array of bytes into an instance of class Class, with an optional CodeSource.
defineClass(String, ByteBuffer, CodeSource) - Method in class java.security.SecureClassLoader
Converts a ByteBuffer into an instance of class 类, with an optional CodeSource.
defined_in - Variable in class org.omg.CORBA.ValueMember
The repository ID of the value in which this member is defined.
defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Returns the Element which matches the specified parameters.
defineEntity(String, int, char[]) - Method in class javax.swing.text.html.parser.DTD
Defines an entity.
definePackage(String, String, String, String, String, String, String, URL) - Method in class java.lang.ClassLoader
Defines a package by name in this ClassLoader.
definePackage(String, Manifest, URL) - Method in class java.net.URLClassLoader
Defines a new package by name in this ClassLoader.
DefinitionKind - Class in org.omg.CORBA
The class that provides the constants used to identify the type of an Interface Repository object.
DefinitionKind(int) - Constructor for class org.omg.CORBA.DefinitionKind
Constructs a DefinitionKind object with its _value field initialized with the given value.
DefinitionKindHelper - Class in org.omg.CORBA
The Helper for DefinitionKind.
DefinitionKindHelper() - Constructor for class org.omg.CORBA.DefinitionKindHelper
deflate(byte[], int, int) - Method in class java.util.zip.Deflater
Compresses the input data and fills specified buffer with compressed data.
deflate(byte[]) - Method in class java.util.zip.Deflater
Compresses the input data and fills specified buffer with compressed data.
deflate(byte[], int, int, int) - Method in class java.util.zip.Deflater
Compresses the input data and fills the specified buffer with compressed data.
deflate() - Method in class java.util.zip.DeflaterOutputStream
Writes next block of compressed data to the output stream.
DEFLATE - Static variable in class javax.print.attribute.standard.Compression
ZIP public domain inflate/deflate compression technology.
DEFLATE_HINT - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to Pack200.Packer.TRUE or Pack200.Packer.FALSE, the packer will set the deflation hint accordingly in the output archive, and will not transmit the individual deflation hints of archive elements.
DEFLATE_HINT - Static variable in interface java.util.jar.Pack200.Unpacker
Property indicating that the unpacker should ignore all transmitted values for DEFLATE_HINT, replacing them by the given value, Pack200.Unpacker.TRUE or Pack200.Unpacker.FALSE.
DEFLATED - Static variable in class java.util.zip.Deflater
Compression method for the deflate algorithm (the only one currently supported).
DEFLATED - Static variable in class java.util.zip.ZipEntry
Compression method for compressed (deflated) entries.
DEFLATED - Static variable in class java.util.zip.ZipOutputStream
Compression method for compressed (DEFLATED) entries.
Deflater - Class in java.util.zip
This class provides support for general purpose compression using the popular ZLIB compression library.
Deflater(int, boolean) - Constructor for class java.util.zip.Deflater
Creates a new compressor using the specified compression level.
Deflater(int) - Constructor for class java.util.zip.Deflater
Creates a new compressor using the specified compression level.
Deflater() - Constructor for class java.util.zip.Deflater
Creates a new compressor with the default compression level.
DeflaterInputStream - Class in java.util.zip
Implements an input stream filter for compressing data in the "deflate" compression format.
DeflaterInputStream(InputStream) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with a default compressor and buffer size.
DeflaterInputStream(InputStream, Deflater) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with the specified compressor and a default buffer size.
DeflaterInputStream(InputStream, Deflater, int) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with the specified compressor and buffer size.
DeflaterOutputStream - Class in java.util.zip
This class implements an output stream filter for compressing data in the "deflate" compression format.
DeflaterOutputStream(OutputStream, Deflater, int, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor, buffer size and flush mode.
DeflaterOutputStream(OutputStream, Deflater, int) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor and buffer size.
DeflaterOutputStream(OutputStream, Deflater, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor, flush mode and a default buffer size.
DeflaterOutputStream(OutputStream, Deflater) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor and a default buffer size.
DeflaterOutputStream(OutputStream, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with a default compressor, a default buffer size and the specified flush mode.
DeflaterOutputStream(OutputStream) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with a default compressor and buffer size.
deiconifyFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the desktopIcon from its parent and adds its frame to the parent.
deiconifyFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, remove any iconic representation that is present and restore the frame to it's original size and location.
deiconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to deiconify the frame.
deiconize() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
deinstall(JTextComponent) - Method in interface javax.swing.text.Caret
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JTextComponent) - Method in class javax.swing.text.DefaultCaret
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JTextComponent) - Method in class javax.swing.text.DefaultHighlighter
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JEditorPane) - Method in class javax.swing.text.EditorKit
Called when the kit is being removed from the JEditorPane.
deinstall(JTextComponent) - Method in interface javax.swing.text.Highlighter
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit
Called when the kit is being removed from the JEditorPane.
deinstall(JEditorPane) - Method in class javax.swing.text.StyledEditorKit
Called when the kit is being removed from the JEditorPane.
deinstallMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
delay(int) - Method in class java.awt.Robot
Sleeps for the specified time.
Delayed - Interface in java.util.concurrent
A mix-in style interface for marking objects that should be acted upon after a given delay.
DelayQueue<E extends Delayed> - Class in java.util.concurrent
An unbounded blocking queue of Delayed elements, in which an element can only be taken when its delay has expired.
DelayQueue() - Constructor for class java.util.concurrent.DelayQueue
Creates a new DelayQueue that is initially empty.
DelayQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.DelayQueue
Creates a DelayQueue initially containing the elements of the given collection of Delayed instances.
delegate - Variable in class javax.swing.DefaultCellEditor
The delegate class which handles all methods sent from the CellEditor.
Delegate - Class in org.omg.CORBA.portable
Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
Delegate() - Constructor for class org.omg.CORBA.portable.Delegate
Delegate - Class in org.omg.CORBA_2_3.portable
Delegate class provides the ORB vendor specific implementation of CORBA object.
Delegate() - Constructor for class org.omg.CORBA_2_3.portable.Delegate
Delegate - Interface in org.omg.PortableServer.portable
The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.
DELEGATE_NAME - Static variable in class javax.management.MBeanServerDelegate
Defines the default ObjectName of the MBeanServerDelegate.
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup
This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up.
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
Deprecated.
DelegationPermission - Class in javax.security.auth.kerberos
This class is used to restrict the usage of the Kerberos delegation model, ie: forwardable and proxiable tickets.
DelegationPermission(String) - Constructor for class javax.security.auth.kerberos.DelegationPermission
Create a new DelegationPermission with the specified subordinate and target principals.
DelegationPermission(String, String) - Constructor for class javax.security.auth.kerberos.DelegationPermission
Create a new DelegationPermission with the specified subordinate and target principals.
DELETE - Static variable in class java.awt.Event
The Delete key.
delete() - Method in class java.io.File
Deletes the file or directory denoted by this abstract pathname.
delete(int, int) - Method in class java.lang.StringBuffer
delete(int, int) - Method in class java.lang.StringBuilder
delete(String) - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Deletes a user-defined attribute.
delete(Path) - Static method in class java.nio.file.Files
Deletes a file.
delete(Path) - Method in class java.nio.file.spi.FileSystemProvider
Deletes a file.
delete(int, int) - Method in interface javax.accessibility.AccessibleEditableText
Deletes the text between two indices
DELETE - Static variable in interface javax.accessibility.AccessibleTableModelChange
Identifies the deletion of rows and/or columns.
DELETE - Static variable in class javax.swing.event.TableModelEvent
Identifies the removal of rows or columns.
delete(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Deletes the text between two indices
delete(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Deletes the text between two indices
delete() - Method in interface javax.tools.FileObject
Deletes this file object.
delete() - Method in class javax.tools.ForwardingFileObject
delete() - Method in class javax.tools.SimpleJavaFileObject
This implementation does nothing.
DELETE_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that a conflict occurred while the RowSet object was attempting to delete a row in the data source.
delete_values(String) - Method in class org.omg.CORBA.Context
Deletes from this Context object the NamedValue object(s) whose name field matches the given property name.
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font.LineBreakMeasurer
Updates this LineBreakMeasurer after a single character is deleted from the text, and sets the current position to the beginning of the paragraph.
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font.TextMeasurer
Updates the TextMeasurer after a single character has been deleted from the paragraph currently represented by this TextMeasurer.
deleteCharAt(int) - Method in class java.lang.StringBuffer
deleteCharAt(int) - Method in class java.lang.StringBuilder
deleteData(int, int) - Method in interface org.w3c.dom.CharacterData
Remove a range of 16-bit units from the node.
deleteDirectory(T) - Method in interface java.nio.file.SecureDirectoryStream
Deletes a directory.
deleteEntry(String) - Method in class java.security.KeyStore
Deletes the entry identified by the given alias from this keystore.
deleteFile(T) - Method in interface java.nio.file.SecureDirectoryStream
Deletes a file.
deleteIfExists(Path) - Static method in class java.nio.file.Files
Deletes a file if it exists.
deleteIfExists(Path) - Method in class java.nio.file.spi.FileSystemProvider
Deletes a file if it exists.
deleteNextCharAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the character of content that follows the current caret position.
deleteNextWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the word that follows the beginning of the selection.
deleteObserver(Observer) - Method in class java.util.Observable
Deletes an observer from the set of observers of this object.
deleteObservers() - Method in class java.util.Observable
Clears the observer list so that this object no longer has any observers.
deleteOnExit() - Method in class java.io.File
Requests that the file or directory denoted by this abstract pathname be deleted when the virtual machine terminates.
deleteOwner(Principal, Principal) - Method in interface java.security.acl.Owner
Deletes an owner.
deletePrevCharAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the character of content that precedes the current caret position.
deletePrevWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the word that precedes the beginning of the selection.
deleteRow() - Method in interface java.sql.ResultSet
Deletes the current row from this ResultSet object and from the underlying database.
deletesAreDetected(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether or not a visible row delete can be detected by calling the method ResultSet.rowDeleted.
deleteShortcut(MenuShortcut) - Method in class java.awt.MenuBar
Deletes the specified menu shortcut.
deleteShortcut() - Method in class java.awt.MenuItem
Delete any MenuShortcut object associated with this menu item.
deleteTrack(Track) - Method in class javax.sound.midi.Sequence
Removes the specified track from the sequence.
delimiter() - Method in class java.util.Scanner
Returns the Pattern this Scanner is currently using to match delimiters.
delItem(int) - Method in class java.awt.List
Deprecated.
replaced by remove(String) and remove(int).
delItems(int, int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, Not for public use in the future. This method is expected to be retained only as a package private method.
deliverEvent(Event) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e).
deliverEvent(Event) - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e)
deltaTransform(Point2D, Point2D) - Method in class java.awt.geom.AffineTransform
Transforms the relative distance vector specified by ptSrc and stores the result in ptDst.
deltaTransform(double[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of relative distance vectors by this transform.
Deprecated - Annotation Type in java.lang
A program element annotated @Deprecated is one that programmers are discouraged from using, typically because it is dangerous, or because a better alternative exists.
depth() - Method in class javax.swing.text.ElementIterator
Fetches the current depth of element tree.
depthFirstEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order.
depthOffset - Variable in class javax.swing.plaf.basic.BasicTreeUI
How much the depth should be offset to properly calculate x locations.
Deque<E> - Interface in java.util
A linear collection that supports element insertion and removal at both ends.
dequeueKeyEvents(long, Component) - Method in class java.awt.DefaultKeyboardFocusManager
Releases for normal dispatching to the current focus owner all KeyEvents which were enqueued because of a call to enqueueKeyEvents with the same timestamp and Component.
dequeueKeyEvents(long, Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should cancel delayed dispatching of KeyEvents.
dereference(XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod
Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
dereference(URIReference, XMLCryptoContext) - Method in interface javax.xml.crypto.URIDereferencer
Dereferences the specified URIReference and returns the dereferenced data.
deregister(AbstractSelectionKey) - Method in class java.nio.channels.spi.AbstractSelector
Removes the given key from its channel's key set.
deregisterAll(Class<?>) - Method in class javax.imageio.spi.ServiceRegistry
Deregisters all service provider object currently registered under the given category.
deregisterAll() - Method in class javax.imageio.spi.ServiceRegistry
Deregisters all currently registered service providers from all categories.
deregisterDriver(Driver) - Static method in class java.sql.DriverManager
Drops a driver from the DriverManager's list.
deregisterServiceProvider(T, Class<T>) - Method in class javax.imageio.spi.ServiceRegistry
Removes a service provider object from the given category.
deregisterServiceProvider(Object) - Method in class javax.imageio.spi.ServiceRegistry
Removes a service provider object from all categories that contain it.
DERIVATION_EXTENSION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
DERIVATION_LIST - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
DERIVATION_RESTRICTION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
DERIVATION_UNION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
derive(int) - Method in class java.awt.AlphaComposite
Returns a similar AlphaComposite object that uses the specified compositing rule.
derive(float) - Method in class java.awt.AlphaComposite
Returns a similar AlphaComposite object that uses the specified alpha value.
deriveFont(int, float) - Method in class java.awt.Font
Creates a new Font object by replicating this Font object and applying a new style and size.
deriveFont(int, AffineTransform) - Method in class java.awt.Font
Creates a new Font object by replicating this Font object and applying a new style and transform.
deriveFont(float) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new size to it.
deriveFont(AffineTransform) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new transform to it.
deriveFont(int) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new style to it.
deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new set of font attributes to it.
deriveMMFont(float[]) - Method in interface java.awt.font.MultipleMaster
Creates a new instance of a multiple master font based on the design axis values contained in the specified array.
deriveMMFont(float[], float, float, float, float) - Method in interface java.awt.font.MultipleMaster
Creates a new instance of a multiple master font based on detailed metric information.
DES_EDE_KEY_LEN - Static variable in class javax.crypto.spec.DESedeKeySpec
The constant which defines the length of a DESede key in bytes.
DES_KEY_LEN - Static variable in class javax.crypto.spec.DESKeySpec
The constant which defines the length of a DES key in bytes.
descendingIterator() - Method in class java.util.ArrayDeque
descendingIterator() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns an iterator over the elements in this set in descending order.
descendingIterator() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in interface java.util.Deque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in class java.util.LinkedList
descendingIterator() - Method in interface java.util.NavigableSet
Returns an iterator over the elements in this set, in descending order.
descendingIterator() - Method in class java.util.TreeSet
Returns an iterator over the elements in this set in descending order.
descendingKeySet() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a reverse order NavigableSet view of the keys contained in this map.
descendingKeySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
descendingKeySet() - Method in interface java.util.NavigableMap
Returns a reverse order NavigableSet view of the keys contained in this map.
descendingKeySet() - Method in class java.util.TreeMap
descendingMap() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a reverse order view of the mappings contained in this map.
descendingMap() - Method in class java.util.concurrent.ConcurrentSkipListMap
descendingMap() - Method in interface java.util.NavigableMap
Returns a reverse order view of the mappings contained in this map.
descendingMap() - Method in class java.util.TreeMap
descendingSet() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns a reverse order view of the elements contained in this set.
descendingSet() - Method in interface java.util.NavigableSet
Returns a reverse order view of the elements contained in this set.
descendingSet() - Method in class java.util.TreeSet
描述 - Variable in class java.sql.DriverPropertyInfo
A brief description of the property, which may be null.
描述 - Variable in class javax.management.MBeanFeatureInfo
The human-readable description of the feature.
Descriptor - Interface in javax.management
Additional metadata for a JMX element.
DescriptorAccess - Interface in javax.management
This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e.
DescriptorKey - Annotation Type in javax.management
Meta-annotation that describes how an annotation element relates to a field in a Descriptor.
DescriptorRead - Interface in javax.management
Interface to read the Descriptor of a management interface element such as an MBeanInfo.
DescriptorSupport - Class in javax.management.modelmbean
This class represents the metadata set for a ModelMBean element.
DescriptorSupport() - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor default constructor.
DescriptorSupport(int) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor.
DescriptorSupport(DescriptorSupport) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking a Descriptor as parameter.
DescriptorSupport(String) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking an XML String.
DescriptorSupport(String[], Object[]) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking field names and field values.
DescriptorSupport(String...) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking fields in the fieldName=fieldValue format.
DESedeKeySpec - Class in javax.crypto.spec
This class specifies a DES-EDE ("triple-DES") key.
DESedeKeySpec(byte[]) - Constructor for class javax.crypto.spec.DESedeKeySpec
Creates a DESedeKeySpec object using the first 24 bytes in key as the key material for the DES-EDE key.
DESedeKeySpec(byte[], int) - Constructor for class javax.crypto.spec.DESedeKeySpec
Creates a DESedeKeySpec object using the first 24 bytes in key, beginning at offset inclusive, as the key material for the DES-EDE key.
deselect(int) - Method in class java.awt.List
Deselects the item at the specified index.
DESELECTED - Static variable in class java.awt.event.ItemEvent
This state-change-value indicates that a selected item was deselected.
DESERET - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Deseret" Unicode character block.
deserialize(ObjectInputStream, Collection) - Method in class java.beans.beancontext.BeanContextSupport
used by readObject to deserialize a collection.
deserialize(ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
deserialize(String, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
deserialize(String, ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use getClassLoader to obtain the class loader for deserialization.
DESIGNATED_LONG - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO Designated Long size, 110 mm by 220 mm.
DesignMode - Interface in java.beans
This interface is intended to be implemented by, or delegated from, instances of java.beans.beancontext.BeanContext, in order to propagate to its nested hierarchy of java.beans.beancontext.BeanContextChild instances, the current "designTime" property.
designTime - Variable in class java.beans.beancontext.BeanContextSupport
A boolean indicating whether or not this object is currently in design time mode.
desiredAssertionStatus() - Method in class java.lang.类
Returns the assertion status that would be assigned to this class if it were to be initialized at the time this method is invoked.
DESKeySpec - Class in javax.crypto.spec
This class specifies a DES key.
DESKeySpec(byte[]) - Constructor for class javax.crypto.spec.DESKeySpec
Creates a DESKeySpec object using the first 8 bytes in key as the key material for the DES key.
DESKeySpec(byte[], int) - Constructor for class javax.crypto.spec.DESKeySpec
Creates a DESKeySpec object using the first 8 bytes in key, beginning at offset inclusive, as the key material for the DES key.
Desktop - Class in java.awt
The Desktop class allows a Java application to launch associated applications registered on the native desktop to handle a URI or a file.
DESKTOP - Static variable in class java.awt.SystemColor
The array index for the SystemColor.desktop system color.
desktop - Static variable in class java.awt.SystemColor
The color rendered for the background of the desktop.
desktop - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Desktop.Action - Enum in java.awt
Represents an action type.
DESKTOP_ICON - Static variable in class javax.accessibility.AccessibleRole
An iconified internal frame in a DESKTOP_PANE.
DESKTOP_ICON - Static variable in class javax.swing.plaf.synth.Region
DesktopIcon region.
DESKTOP_PANE - Static variable in class javax.accessibility.AccessibleRole
A pane that supports internal frames and iconified versions of those internal frames.
DESKTOP_PANE - Static variable in class javax.swing.plaf.synth.Region
DesktopPane region.
desktopIcon - Variable in class javax.swing.JInternalFrame
The icon that is displayed when this internal frame is iconified.
desktopIcon - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
DesktopIconUI - Class in javax.swing.plaf
Pluggable look and feel interface for JDesktopIcon.
DesktopIconUI() - Constructor for class javax.swing.plaf.DesktopIconUI
DesktopManager - Interface in javax.swing
DesktopManager objects are owned by a JDesktopPane object.
desktopManager - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
DesktopPaneUI - Class in javax.swing.plaf
Pluggable look and feel interface for JDesktopPane.
DesktopPaneUI() - Constructor for class javax.swing.plaf.DesktopPaneUI
desktopProperties - Variable in class java.awt.Toolkit
desktopPropsSupport - Variable in class java.awt.Toolkit
destHeight - Variable in class java.awt.image.ReplicateScaleFilter
The target height to scale the image.
destination - Variable in class javax.imageio.ImageReadParam
The current destination BufferedImage, or null if none has been set.
Destination - Class in javax.print.attribute.standard
Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
Destination(URI) - Constructor for class javax.print.attribute.standard.Destination
Constructs a new destination attribute with the specified URI.
destination - Variable in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
Destination that receives all events.
destinationBands - Variable in class javax.imageio.ImageReadParam
The set of destination bands to be used, as an array of ints.
destinationOffset - Variable in class javax.imageio.IIOParam
The offset in the destination where the upper-left decoded pixel should be placed.
destinationType - Variable in class javax.imageio.IIOParam
An ImageTypeSpecifier to be used to generate a destination image when reading, or to set the output color type when writing.
destroy() - Method in class java.applet.Applet
Called by the browser or applet viewer to inform this applet that it is being reclaimed and that it should destroy any resources that it has allocated.
destroy() - Method in class java.lang.Process
Kills the subprocess.
destroy() - Method in class java.lang.Thread
Deprecated.
This method was originally designed to destroy this thread without any cleanup. Any monitors it held would have remained locked. However, the method was never implemented. If if were to be implemented, it would be deadlock-prone in much the manner of Thread.suspend(). If the target thread held a lock protecting a critical system resource when it was destroyed, no thread could ever access this resource again. If another thread ever attempted to lock this resource, deadlock would result. Such deadlocks typically manifest themselves as "frozen" processes. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
destroy() - Method in class java.lang.ThreadGroup
Destroys this thread group and all of its subgroups.
destroy() - Method in class java.security.KeyStore.PasswordProtection
Clears the password.
destroy() - Method in interface javax.security.auth.Destroyable
Destroy this Object.
destroy() - Method in class javax.security.auth.kerberos.KerberosKey
Destroys this key.
destroy() - Method in class javax.security.auth.kerberos.KerberosTicket
Destroys the ticket and destroys any sensitive information stored in it.
destroy() - Method in class javax.security.auth.x500.X500PrivateCredential
Clears the references to the X.509 certificate, private key and the KeyStore alias in this object.
destroy() - Method in class org.omg.CORBA._IDLTypeStub
destroy() - Method in class org.omg.CORBA._PolicyStub
Destroys the policy object.
destroy() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Destroys this DynAny object and frees any resources used to represent the data value associated with it.
destroy() - Method in interface org.omg.CORBA.IRObjectOperations
Destroys this object.
destroy() - Method in class org.omg.CORBA.ORB
Destroys the ORB so that its resources can be reclaimed.
destroy() - Method in interface org.omg.CORBA.PolicyOperations
Destroys the Policy object.
destroy() - Method in class org.omg.CosNaming._BindingIteratorStub
This operation destroys the iterator.
destroy() - Method in class org.omg.CosNaming._NamingContextExtStub
The destroy operation deletes a naming context.
destroy() - Method in class org.omg.CosNaming._NamingContextStub
The destroy operation deletes a naming context.
destroy() - Method in interface org.omg.CosNaming.BindingIteratorOperations
This operation destroys the iterator.
destroy() - Method in interface org.omg.CosNaming.NamingContextOperations
The destroy operation deletes a naming context.
destroy() - Method in class org.omg.DynamicAny._DynAnyStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynArrayStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynEnumStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynFixedStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynSequenceStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynStructStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynUnionStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynValueStub
Destroys a DynAny object.
destroy() - Method in interface org.omg.DynamicAny.DynAnyOperations
Destroys a DynAny object.
destroy() - Method in interface org.omg.PortableInterceptor.InterceptorOperations
Provides an opportunity to destroy this interceptor.
destroy(boolean, boolean) - Method in interface org.omg.PortableServer.POAOperations
This operation destroys the POA and all descendant POAs.
Destroyable - Interface in javax.security.auth
Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
destroyBuffers() - Method in class java.awt.Component.FlipBufferStrategy
Destroys the buffers created through this object
DestroyFailedException - Exception in javax.security.auth
Signals that a destroy operation failed.
DestroyFailedException() - Constructor for exception javax.security.auth.DestroyFailedException
Constructs a DestroyFailedException with no detail message.
DestroyFailedException(String) - Constructor for exception javax.security.auth.DestroyFailedException
Constructs a DestroyFailedException with the specified detail message.
destroySubcontext(Name) - Method in interface javax.naming.Context
Destroys the named context and removes it from the namespace.
destroySubcontext(String) - Method in interface javax.naming.Context
Destroys the named context and removes it from the namespace.
destroySubcontext(String) - Method in class javax.naming.InitialContext
destroySubcontext(Name) - Method in class javax.naming.InitialContext
destWidth - Variable in class java.awt.image.ReplicateScaleFilter
The target width to scale the image.
detachNode() - Method in interface javax.xml.soap.Node
Removes this Node object from the tree.
detail - Variable in exception java.io.WriteAbortedException
Exception that was caught while writing the ObjectStream.
detail - Variable in exception java.rmi.activation.ActivationException
The cause of the activation exception.
detail - Variable in exception java.rmi.RemoteException
The cause of the remote exception.
detail - Variable in exception java.rmi.server.ServerCloneException
The cause of the exception.
Detail - Interface in javax.xml.soap
A container for DetailEntry objects.
DetailEntry - Interface in javax.xml.soap
The content for a Detail object, giving details for a SOAPFault object.
detailsViewIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
detectedCharset() - Method in class java.nio.charset.CharsetDecoder
Retrieves the charset that was detected by this decoder (optional operation).
determineOffset(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree.DefaultTreeCellEditor
DEVANAGARI - Static variable in class java.awt.font.NumericShaper
Identifies the DEVANAGARI range and decimal base.
DEVANAGARI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Devanagari" Unicode character block.
DEVANAGARI_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Devanagari Extended" Unicode character block.
DEVELOPER_EMPTY - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is out of developer.
DEVELOPER_LOW - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is low on developer.
DFN - Static variable in class javax.swing.text.html.HTML.Tag
DGC - Interface in java.rmi.dgc
The DGC abstraction is used for the server side of the distributed garbage collection algorithm.
DGC_ID - Static variable in class java.rmi.server.ObjID
Object number for well-known ObjID of the distributed garbage collector.
DHGenParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman key agreement.
DHGenParameterSpec(int, int) - Constructor for class javax.crypto.spec.DHGenParameterSpec
Constructs a parameter set for the generation of Diffie-Hellman (system) parameters.
DHKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman key.
DHParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-Agreement Standard.
DHParameterSpec(BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHParameterSpec
Constructs a parameter set for Diffie-Hellman, using a prime modulus p and a base generator g.
DHParameterSpec(BigInteger, BigInteger, int) - Constructor for class javax.crypto.spec.DHParameterSpec
Constructs a parameter set for Diffie-Hellman, using a prime modulus p, a base generator g, and the size in bits, l, of the random exponent (private value).
DHPrivateKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman private key.
DHPrivateKeySpec - Class in javax.crypto.spec
This class specifies a Diffie-Hellman private key with its associated parameters.
DHPrivateKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHPrivateKeySpec
Constructor that takes a private value x, a prime modulus p, and a base generator g.
DHPublicKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman public key.
DHPublicKeySpec - Class in javax.crypto.spec
This class specifies a Diffie-Hellman public key with its associated parameters.
DHPublicKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHPublicKeySpec
Constructor that takes a public value y, a prime modulus p, and a base generator g.
Diagnostic<S> - Interface in javax.tools
Interface for diagnostics from tools.
Diagnostic.Kind - Enum in javax.tools
Kinds of diagnostics, for example, error or warning.
DiagnosticCollector<S> - Class in javax.tools
Provides an easy way to collect diagnostics in a list.
DiagnosticCollector() - Constructor for class javax.tools.DiagnosticCollector
DiagnosticListener<S> - Interface in javax.tools
Interface for receiving diagnostics from tools.
Dialog - Class in java.awt
A Dialog is a top-level window with a title and a border that is typically used to take some form of input from the user.
Dialog(Frame) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Frame and an empty title.
Dialog(Frame, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame and modality and an empty title.
Dialog(Frame, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Frame and title.
Dialog(Frame, String, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame, title and modality.
Dialog(Frame, String, boolean, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame, title, modality, and GraphicsConfiguration.
Dialog(Dialog) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Dialog and an empty title.
Dialog(Dialog, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Dialog and title.
Dialog(Dialog, String, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Dialog, title, and modality.
Dialog(Dialog, String, boolean, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Dialog, title, modality and GraphicsConfiguration.
Dialog(Window) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Window and an empty title.
Dialog(Window, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Window and title.
Dialog(Window, Dialog.ModalityType) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window and modality and an empty title.
Dialog(Window, String, Dialog.ModalityType) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window, title and modality.
Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window, title, modality and GraphicsConfiguration.
DIALOG - Static variable in class java.awt.Font
A String constant for the canonical family name of the logical font "Dialog".
DIALOG - Static variable in class javax.accessibility.AccessibleRole
A top level window with title bar and a border.
Dialog.AccessibleAWTDialog - Class in java.awt
This class implements accessibility support for the Dialog class.
Dialog.AccessibleAWTDialog() - Constructor for class java.awt.Dialog.AccessibleAWTDialog
Dialog.ModalExclusionType - Enum in java.awt
Any top-level window can be marked not to be blocked by modal dialogs.
Dialog.ModalityType - Enum in java.awt
Modal dialogs block all input to some top-level windows.
DIALOG_INPUT - Static variable in class java.awt.Font
A String constant for the canonical family name of the logical font "DialogInput".
DIALOG_TITLE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the dialog title.
DIALOG_TYPE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the type of files displayed (files only, directories only, or both files and directories).
DIALOG_UI - Static variable in class javax.print.ServiceUIFactory
Denotes a UI implemented as an AWT dialog.
dialogInit() - Method in class javax.swing.JDialog
Called by the constructors to init the JDialog properly.
DialogTypeSelection - Class in javax.print.attribute.standard
Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
DialogTypeSelection(int) - Constructor for class javax.print.attribute.standard.DialogTypeSelection
Construct a new dialog type selection enumeration value with the given integer value.
Dictionary<K,V> - Class in java.util
The Dictionary class is the abstract parent of any class, such as Hashtable, which maps keys to values.
Dictionary() - Constructor for class java.util.Dictionary
Sole constructor.
die() - Method in class javax.swing.undo.AbstractUndoableEdit
Sets alive to false.
die() - Method in class javax.swing.undo.CompoundEdit
Sends die to each subedit, in the reverse of the order that they were added.
die() - Method in interface javax.swing.undo.UndoableEdit
Informs the edit that it should no longer be used.
digest - Variable in class java.security.DigestInputStream
The message digest associated with this stream.
digest - Variable in class java.security.DigestOutputStream
The message digest associated with this stream.
digest() - Method in class java.security.MessageDigest
Completes the hash computation by performing final operations such as padding.
digest(byte[], int, int) - Method in class java.security.MessageDigest
Completes the hash computation by performing final operations such as padding.
digest(byte[]) - Method in class java.security.MessageDigest
Performs a final update on the digest using the specified array of bytes, then completes the digest computation.
DigestException - Exception in java.security
This is the generic Message Digest exception.
DigestException() - Constructor for exception java.security.DigestException
Constructs a DigestException with no detail message.
DigestException(String) - Constructor for exception java.security.DigestException
Constructs a DigestException with the specified detail message.
DigestException(String, Throwable) - Constructor for exception java.security.DigestException
Creates a DigestException with the specified detail message and cause.
DigestException(Throwable) - Constructor for exception java.security.DigestException
Creates a DigestException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
DigestInputStream - Class in java.security
A transparent stream that updates the associated message digest using the bits going through the stream.
DigestInputStream(InputStream, MessageDigest) - Constructor for class java.security.DigestInputStream
Creates a digest input stream, using the specified input stream and message digest.
DigestMethod - Interface in javax.xml.crypto.dsig
A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
DigestMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec
A specification of algorithm parameters for a DigestMethod algorithm.
DigestOutputStream - Class in java.security
A transparent stream that updates the associated message digest using the bits going through the stream.
DigestOutputStream(OutputStream, MessageDigest) - Constructor for class java.security.DigestOutputStream
Creates a digest output stream, using the specified output stream and message digest.
digit(char, int) - Static method in class java.lang.Character
Returns the numeric value of the character ch in the specified radix.
digit(int, int) - Static method in class java.lang.Character
Returns the numeric value of the specified character (Unicode code point) in the specified radix.
Dimension - Class in java.awt
The Dimension class encapsulates the width and height of a component (in integer precision) in a single object.
Dimension() - Constructor for class java.awt.Dimension
Creates an instance of Dimension with a width of zero and a height of zero.
Dimension(Dimension) - Constructor for class java.awt.Dimension
Creates an instance of Dimension whose width and height are the same as for the specified dimension.
Dimension(int, int) - Constructor for class java.awt.Dimension
Constructs a Dimension and initializes it to the specified width and specified height.
Dimension2D - Class in java.awt.geom
The Dimension2D class is to encapsulate a width and a height dimension.
Dimension2D() - Constructor for class java.awt.geom.Dimension2D
This is an abstract class that cannot be instantiated directly.
DimensionUIResource - Class in javax.swing.plaf
DimensionUIResource(int, int) - Constructor for class javax.swing.plaf.DimensionUIResource
DINGBATS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Dingbats" Unicode character block.
DIR - Static variable in class javax.swing.text.html.HTML.Attribute
DIR - Static variable in class javax.swing.text.html.HTML.Tag
DirContext - Interface in javax.naming.directory
The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
DirectColorModel - Class in java.awt.image
The DirectColorModel class is a ColorModel class that works with pixel values that represent RGB color and alpha information as separate samples and that pack all samples for a single pixel into a single int, short, or byte quantity.
DirectColorModel(int, int, int, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified masks that indicate which bits in an int pixel representation contain the red, green and blue color samples.
DirectColorModel(int, int, int, int, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified masks that indicate which bits in an int pixel representation contain the red, green and blue color samples and the alpha sample, if present.
DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified parameters.
direction - Variable in class javax.swing.plaf.basic.BasicArrowButton
The direction of the arrow.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
Specifies the direction to adjust the selection by.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
Specifies the direction to adjust the selection by.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
Determines direction to traverse, 1 means expand, -1 means collapse.
DIRECTION_DEFAULT_LEFT_TO_RIGHT - Static variable in class java.text.Bidi
Constant indicating that the base direction depends on the first strong directional character in the text according to the Unicode Bidirectional Algorithm.
DIRECTION_DEFAULT_RIGHT_TO_LEFT - Static variable in class java.text.Bidi
Constant indicating that the base direction depends on the first strong directional character in the text according to the Unicode Bidirectional Algorithm.
DIRECTION_LEFT_TO_RIGHT - Static variable in class java.text.Bidi
Constant indicating base direction is left-to-right.
DIRECTION_RIGHT_TO_LEFT - Static variable in class java.text.Bidi
Constant indicating base direction is right-to-left.
DIRECTIONALITY_ARABIC_NUMBER - Static variable in class java.lang.Character
Weak bidirectional character type "AN" in the Unicode specification.
DIRECTIONALITY_BOUNDARY_NEUTRAL - Static variable in class java.lang.Character
Weak bidirectional character type "BN" in the Unicode specification.
DIRECTIONALITY_COMMON_NUMBER_SEPARATOR - Static variable in class java.lang.Character
Weak bidirectional character type "CS" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER - Static variable in class java.lang.Character
Weak bidirectional character type "EN" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR - Static variable in class java.lang.Character
Weak bidirectional character type "ES" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR - Static variable in class java.lang.Character
Weak bidirectional character type "ET" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT - Static variable in class java.lang.Character
Strong bidirectional character type "L" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING - Static variable in class java.lang.Character
Strong bidirectional character type "LRE" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE - Static variable in class java.lang.Character
Strong bidirectional character type "LRO" in the Unicode specification.
DIRECTIONALITY_NONSPACING_MARK - Static variable in class java.lang.Character
Weak bidirectional character type "NSM" in the Unicode specification.
DIRECTIONALITY_OTHER_NEUTRALS - Static variable in class java.lang.Character
Neutral bidirectional character type "ON" in the Unicode specification.
DIRECTIONALITY_PARAGRAPH_SEPARATOR - Static variable in class java.lang.Character
Neutral bidirectional character type "B" in the Unicode specification.
DIRECTIONALITY_POP_DIRECTIONAL_FORMAT - Static variable in class java.lang.Character
Weak bidirectional character type "PDF" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT - Static variable in class java.lang.Character
Strong bidirectional character type "R" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC - Static variable in class java.lang.Character
Strong bidirectional character type "AL" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING - Static variable in class java.lang.Character
Strong bidirectional character type "RLE" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE - Static variable in class java.lang.Character
Strong bidirectional character type "RLO" in the Unicode specification.
DIRECTIONALITY_SEGMENT_SEPARATOR - Static variable in class java.lang.Character
Neutral bidirectional character type "S" in the Unicode specification.
DIRECTIONALITY_UNDEFINED - Static variable in class java.lang.Character
Undefined bidirectional character type.
DIRECTIONALITY_WHITESPACE - Static variable in class java.lang.Character
Neutral bidirectional character type "WS" in the Unicode specification.
DIRECTORIES_ONLY - Static variable in class javax.swing.JFileChooser
Instruction to display only directories.
directory() - Method in class java.lang.ProcessBuilder
Returns this process builder's working directory.
directory(File) - Method in class java.lang.ProcessBuilder
Sets this process builder's working directory.
DIRECTORY_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies user's directory change.
DIRECTORY_PANE - Static variable in class javax.accessibility.AccessibleRole
A pane that allows the user to navigate through and select the contents of a directory.
directoryIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
DirectoryIteratorException - Exception in java.nio.file
Runtime exception thrown if an I/O error is encountered when iterating over the entries in a directory.
DirectoryIteratorException(IOException) - Constructor for exception java.nio.file.DirectoryIteratorException
Constructs an instance of this class.
DirectoryManager - Class in javax.naming.spi
This class contains methods for supporting DirContext implementations.
DirectoryNotEmptyException - Exception in java.nio.file
Checked exception thrown when a file system operation fails because a directory is not empty.
DirectoryNotEmptyException(String) - Constructor for exception java.nio.file.DirectoryNotEmptyException
Constructs an instance of this class.
directoryOpenButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The mnemonic keycode used for the approve button when a directory is selected and the current selection mode is FILES_ONLY.
directoryOpenButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The label text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
directoryOpenButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The tooltip text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
DirectoryStream<T> - Interface in java.nio.file
An object to iterate over the entries in a directory.
DirectoryStream.Filter<T> - Interface in java.nio.file
An interface that is implemented by objects that decide if a directory entry should be accepted or filtered.
directSupertypes(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the direct supertypes of a type.
DirObjectFactory - Interface in javax.naming.spi
This interface represents a factory for creating an object given an object and attributes about the object.
DirStateFactory - Interface in javax.naming.spi
This interface represents a factory for obtaining the state of an object and corresponding attributes for binding.
DirStateFactory.Result - Class in javax.naming.spi
An object/attributes pair for returning the result of DirStateFactory.getStateToBind().
DirStateFactory.Result(Object, Attributes) - Constructor for class javax.naming.spi.DirStateFactory.Result
Constructs an instance of Result.
dirty(ObjID[], long, Lease) - Method in interface java.rmi.dgc.DGC
The dirty call requests leases for the remote object references associated with the object identifiers contained in the array 'ids'.
disable() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
disable() - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
disable() - Static method in class java.lang.Compiler
Cause the Compiler to cease operation.
disable() - Method in class javax.swing.JComponent
Deprecated.
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
disableAllAttributes() - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute names.
disableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables any MBeanServerNotification (all ObjectNames are deselected).
disableAllTypes() - Method in class javax.management.NotificationFilterSupport
Disables all notification types.
disableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute change notifications the attribute name of which equals the specified attribute name to be sent to the listener.
DISABLED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the region is not enabled.
DISABLED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the button has been disabled.
DISABLED_SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the button has been disabled and selected.
disabledForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalButtonUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalRadioButtonUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalToggleButtonUI
disableEvents(long) - Method in class java.awt.Component
Disables the events defined by the specified event mask parameter from being delivered to this component.
disableEvents(long) - Method in class java.awt.MenuItem
Disables event delivery to this menu item for events defined by the specified event mask parameter.
disableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables MBeanServerNotifications concerning given ObjectName.
disableResizedPosting() - Method in class javax.swing.table.TableColumn
Deprecated.
as of Java 2 platform v1.3
disableSwingFocusManager() - Static method in class javax.swing.FocusManager
Deprecated.
as of 1.4, replaced by KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)
disableType(String) - Method in class javax.management.NotificationFilterSupport
Removes the given prefix from the prefix list.
discard_requests(boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to discarding.
discardAllEdits() - Method in class javax.swing.undo.UndoManager
Empties the undo manager sending each edit a die message in the process.
DISCARDING - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/DISCARDING.java .
DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
discardKeyEvents(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Discards all KeyEvents which were enqueued because of one or more calls to enqueueKeyEvents with the specified Component, or one of its descendants.
discardKeyEvents(Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should cancel delayed dispatching of KeyEvents.
disconnect() - Method in class java.net.DatagramSocket
Disconnects the socket.
disconnect() - Method in class java.net.DatagramSocketImpl
Disconnects a datagram socket from its remote destination.
disconnect() - Method in class java.net.HttpURLConnection
Indicates that other requests to the server are unlikely in the near future.
disconnect() - Method in class java.nio.channels.DatagramChannel
Disconnects this channel's socket.
disconnect(Object) - Method in class org.omg.CORBA.ORB
Disconnects the given servant object from the ORB.
DISCONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree.TreeSelectionModel
Selection can contain any number of items that are not necessarily contiguous.
discriminator() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
discriminator_kind() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns the TCKind object associated with the discriminator of this union.
discriminator_kind() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the TCKind value of the discriminators TypeCode.
discriminator_kind() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns the TCKind value of the discriminators TypeCode.
discriminator_type() - Method in class org.omg.CORBA.TypeCode
Returns a TypeCode object describing all non-default member labels.
disjoint(Collection<?>, Collection<?>) - Static method in class java.util.Collections
Returns true if the two specified collections have no elements in common.
DisjunctiveType - Interface in javax.lang.model.type
Represents a disjunctive type.
dismiss(JSpinner) - Method in class javax.swing.JSpinner.DefaultEditor
Disconnect this editor from the specified JSpinner.
dispatch() - Method in interface java.awt.ActiveEvent
Dispatch the event to its target, listeners of the events source, or do whatever it is this event is supposed to do.
dispatch() - Method in class java.awt.event.InvocationEvent
Executes the Runnable's run() method and notifies the notifier (if any) when run() has returned or thrown an exception.
dispatch(Remote, RemoteCall, int, long) - Method in interface java.rmi.server.Skeleton
Deprecated.
no replacement
dispatch(NamingListener) - Method in class javax.naming.event.NamingEvent
Invokes the appropriate listener method on this event.
dispatch(NamingListener) - Method in class javax.naming.event.NamingExceptionEvent
Invokes the namingExceptionThrown() method on a listener using this event.
dispatch(UnsolicitedNotificationListener) - Method in class javax.naming.ldap.UnsolicitedNotificationEvent
Invokes the notificationReceived() method on a listener using this event.
Dispatch<T> - Interface in javax.xml.ws
The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
dispatchEvent(AWTEvent) - Method in class java.awt.Component
Dispatches an event to this component or one of its sub components.
dispatchEvent(AWTEvent) - Method in class java.awt.DefaultKeyboardFocusManager
This method is called by the AWT event dispatcher requesting that the current KeyboardFocusManager dispatch the specified event on its behalf.
dispatchEvent(AWTEvent) - Method in class java.awt.EventQueue
Dispatches an event.
dispatchEvent(AWTEvent) - Method in class java.awt.im.InputContext
Dispatches an event to the active input method.
dispatchEvent(AWTEvent) - Method in interface java.awt.im.spi.InputMethod
Dispatches the event to the input method.
dispatchEvent(AWTEvent) - Method in class java.awt.KeyboardFocusManager
This method is called by the AWT event dispatcher requesting that the current KeyboardFocusManager dispatch the specified event on its behalf.
dispatchEvent(AWTEvent) - Method in class java.awt.MenuComponent
Delivers an event to this component or one of its sub components.
dispatchEvent(Event) - Method in interface org.w3c.dom.events.EventTarget
This method allows the dispatch of events into the implementations event model.
dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Method in interface java.awt.im.spi.InputMethodContext
Creates an input method event from the arguments given and dispatches it to the client component.
dispatchKeyEvent(KeyEvent) - Method in class java.awt.DefaultKeyboardFocusManager
Called by dispatchEvent if no other KeyEventDispatcher in the dispatcher chain dispatched the KeyEvent, or if no other KeyEventDispatchers are registered.
dispatchKeyEvent(KeyEvent) - Method in class java.awt.KeyboardFocusManager
Typically this method will be called by dispatchEvent if no other KeyEventDispatcher in the dispatcher chain dispatched the KeyEvent, or if no other KeyEventDispatchers are registered.
dispatchKeyEvent(KeyEvent) - Method in interface java.awt.KeyEventDispatcher
This method is called by the current KeyboardFocusManager requesting that this KeyEventDispatcher dispatch the specified event on its behalf.
DISPLAY - Static variable in class javax.swing.text.html.CSS.Attribute
DISPLAYABILITY_CHANGED - Static variable in class java.awt.event.HierarchyEvent
A change flag indicates that the HIERARCHY_CHANGED event was generated due to the changing of the hierarchy displayability.
DISPLAYED_MNEMONIC_INDEX_KEY - Static variable in interface javax.swing.Action
The key used for storing an Integer that corresponds to the index in the text (identified by the NAME property) that the decoration for a mnemonic should be rendered at.
displayMessage(String, String, TrayIcon.MessageType) - Method in class java.awt.TrayIcon
Displays a popup message near the tray icon.
DisplayMode - Class in java.awt
The DisplayMode class encapsulates the bit depth, height, width, and refresh rate of a GraphicsDevice.
DisplayMode(int, int, int, int) - Constructor for class java.awt.DisplayMode
Create a new display mode object with the supplied parameters.
displayName() - Method in class java.nio.charset.Charset
Returns this charset's human-readable name for the default locale.
displayName(Locale) - Method in class java.nio.charset.Charset
Returns this charset's human-readable name for the given locale.
dispose() - Method in class java.awt.Component.BltBufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in class java.awt.Component.FlipBufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in interface java.awt.CompositeContext
Releases resources allocated for a context.
dispose() - Method in class java.awt.Graphics
Disposes of this graphics context and releases any system resources that it is using.
dispose() - Method in class java.awt.im.InputContext
Releases the resources used by this input context.
dispose() - Method in interface java.awt.im.spi.InputMethod
Releases the resources used by this input method.
dispose() - Method in class java.awt.image.BufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in interface java.awt.PaintContext
Releases the resources allocated for the operation.
dispose() - Method in class java.awt.Window
Releases all of the native screen resources used by this Window, its subcomponents, and all of its owned children.
dispose() - Method in class javax.imageio.ImageReader
Allows any resources held by this object to be released.
dispose() - Method in class javax.imageio.ImageWriter
Allows any resources held by this object to be released.
dispose() - Method in class javax.print.StreamPrintService
Disposes this StreamPrintService.
dispose() - Method in interface javax.security.sasl.SaslClient
Disposes of any system resources or security-sensitive information the SaslClient might be using.
dispose() - Method in interface javax.security.sasl.SaslServer
Disposes of any system resources or security-sensitive information the SaslServer might be using.
dispose() - Method in class javax.swing.DebugGraphics
Overrides Graphics.dispose.
dispose() - Method in class javax.swing.JInternalFrame
Makes this internal frame invisible, unselected, and closed.
dispose() - Method in interface org.ietf.jgss.GSSContext
Releases any system resources and cryptographic information stored in the context object and invalidates the context.
dispose() - Method in interface org.ietf.jgss.GSSCredential
Releases any sensitive information that the GSSCredential object may be containing.
DISPOSE_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The dispose-window default window close operation.
distance(double, double, double, double) - Static method in class java.awt.geom.Point2D
Returns the distance between two points.
distance(double, double) - Method in class java.awt.geom.Point2D
Returns the distance from this Point2D to a specified point.
distance(Point2D) - Method in class java.awt.geom.Point2D
Returns the distance from this Point2D to a specified Point2D.
distanceSq(double, double, double, double) - Static method in class java.awt.geom.Point2D
Returns the square of the distance between two points.
distanceSq(double, double) - Method in class java.awt.geom.Point2D
Returns the square of the distance from this Point2D to a specified point.
distanceSq(Point2D) - Method in class java.awt.geom.Point2D
Returns the square of the distance from this Point2D to a specified Point2D.
DISTINCT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DISTINCT.
DIV - Static variable in class javax.management.Query
A code representing the Query.div(javax.management.ValueExp, javax.management.ValueExp) expression.
div(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the quotient of two numeric values.
DIV - Static variable in class javax.swing.text.html.HTML.Tag
divide(BigDecimal, int, int) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is as specified.
divide(BigDecimal, int, RoundingMode) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is as specified.
divide(BigDecimal, int) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is this.scale().
divide(BigDecimal, RoundingMode) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is this.scale().
divide(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose preferred scale is (this.scale() - divisor.scale()); if the exact quotient cannot be represented (because it has a non-terminating decimal expansion) an ArithmeticException is thrown.
divide(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), with rounding according to the context settings.
divide(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this / val).
divideAndRemainder(BigDecimal) - Method in class java.math.BigDecimal
Returns a two-element BigDecimal array containing the result of divideToIntegralValue followed by the result of remainder on the two operands.
divideAndRemainder(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a two-element BigDecimal array containing the result of divideToIntegralValue followed by the result of remainder on the two operands calculated with rounding according to the context settings.
divideAndRemainder(BigInteger) - Method in class java.math.BigInteger
Returns an array of two BigIntegers containing (this / val) followed by (this % val).
DIVIDER - Static variable in class javax.swing.JSplitPane
Used to add a Component that will represent the divider.
divider - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance of the divider for this JSplitPane.
DIVIDER_LOCATION_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property for the dividerLocation.
DIVIDER_SIZE_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property name for border.
dividerResizeToggleKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
dividerSize - Variable in class javax.swing.JSplitPane
Size of the divider.
dividerSize - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Size of the divider.
dividerSize - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
The size of the divider while the dragging session is valid.
divideToIntegralValue(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the integer part of the quotient (this / divisor) rounded down.
divideToIntegralValue(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the integer part of (this / divisor).
divisionType - Variable in class javax.sound.midi.MidiFileFormat
The division type of the MIDI file.
divisionType - Variable in class javax.sound.midi.Sequence
The timing division type of the sequence.
dk_AbstractInterface - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
dk_Alias - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
dk_all - Static variable in class org.omg.CORBA.DefinitionKind
The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
dk_Array - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
dk_Attribute - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
dk_Constant - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
dk_Enum - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
dk_Exception - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
dk_Fixed - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
dk_Interface - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
dk_Module - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
dk_Native - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
dk_none - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
dk_Operation - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
dk_Primitive - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
dk_Repository - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
dk_Sequence - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
dk_String - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a String.
dk_Struct - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
dk_Typedef - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
dk_Union - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
dk_Value - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
dk_ValueBox - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
dk_ValueMember - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
dk_Wstring - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.
DL - Static variable in class javax.swing.text.html.HTML.Tag
DnDConstants - Class in java.awt.dnd
This class contains constant values representing the type of action(s) to be performed by a Drag and Drop operation.
DNS_URL - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the DNS host and domain names to use for the JNDI URL context (for example, "dns://somehost/wiz.com").
DO_NOTHING_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The do-nothing default window close operation.
doAccessibleAction(int) - Method in class java.awt.Button.AccessibleAWTButton
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.Choice.AccessibleAWTChoice
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.MenuItem.AccessibleAWTMenuItem
Perform the specified Action on the object
doAccessibleAction(int) - Method in interface javax.accessibility.AccessibleAction
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.accessibility.AccessibleHyperlink
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Perform the specified Action on the tree node.
doAccessibleAction(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Performs the specified Action on the object
doAs(Subject, PrivilegedAction<T>) - Static method in class javax.security.auth.Subject
Perform work as a particular Subject.
doAs(Subject, PrivilegedExceptionAction<T>) - Static method in class javax.security.auth.Subject
Perform work as a particular Subject.
doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext) - Static method in class javax.security.auth.Subject
Perform privileged work as a particular Subject.
doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class javax.security.auth.Subject
Perform privileged work as a particular Subject.
Doc - Interface in javax.print
Interface Doc specifies the interface for an object that supplies one piece of print data for a Print Job.
DocAttribute - Interface in javax.print.attribute
Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
DocAttributeSet - Interface in javax.print.attribute
Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
DocFlavor - Class in javax.print
Class DocFlavor encapsulates an object that specifies the format in which print data is supplied to a DocPrintJob.
DocFlavor(String, String) - Constructor for class javax.print.DocFlavor
Constructs a new doc flavor object from the given MIME type and representation class name.
DocFlavor.BYTE_ARRAY - Class in javax.print
Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
DocFlavor.BYTE_ARRAY(String) - Constructor for class javax.print.DocFlavor.BYTE_ARRAY
Constructs a new doc flavor with the given MIME type and a print data representation class name of "[B" (byte array).
DocFlavor.CHAR_ARRAY - Class in javax.print
Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
DocFlavor.CHAR_ARRAY(String) - Constructor for class javax.print.DocFlavor.CHAR_ARRAY
Constructs a new doc flavor with the given MIME type and a print data representation class name of "[C" (character array).
DocFlavor.INPUT_STREAM - Class in javax.print
Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
DocFlavor.INPUT_STREAM(String) - Constructor for class javax.print.DocFlavor.INPUT_STREAM
Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.io.InputStream" (byte stream).
DocFlavor.READER - Class in javax.print
Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
DocFlavor.READER(String) - Constructor for class javax.print.DocFlavor.READER
Constructs a new doc flavor with the given MIME type and a print data representation class name of\ "java.io.Reader" (character stream).
DocFlavor.SERVICE_FORMATTED - Class in javax.print
Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
DocFlavor.SERVICE_FORMATTED(String) - Constructor for class javax.print.DocFlavor.SERVICE_FORMATTED
Constructs a new doc flavor with a MIME type of "application/x-java-jvm-local-objectref" indicating service formatted print data and the given print data representation class name.
DocFlavor.STRING - Class in javax.print
Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
DocFlavor.STRING(String) - Constructor for class javax.print.DocFlavor.STRING
Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.lang.String".
DocFlavor.URL - Class in javax.print
Class DocFlavor.URL provides predefined static constant DocFlavor objects.
DocFlavor.URL(String) - Constructor for class javax.print.DocFlavor.URL
Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.net.URL".
dockingBorderColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
dockingColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
dockingListener - Variable in class javax.swing.plaf.basic.BasicToolBarUI
doClick() - Method in class javax.swing.AbstractButton
Programmatically perform a "click".
doClick(int) - Method in class javax.swing.AbstractButton
Programmatically perform a "click".
doClick(int) - Method in class javax.swing.JMenu
Programmatically performs a "click".
doClick(MenuSelectionManager) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Call this method when a menu item is to be activated.
DocPrintJob - Interface in javax.print
This interface represents a print job that can print a specified document with a set of job attributes.
DOCTYPE_PUBLIC - Static variable in class javax.xml.transform.OutputKeys
doctype-public = string.
DOCTYPE_SYSTEM - Static variable in class javax.xml.transform.OutputKeys
doctype-system = string.
Document - Interface in javax.swing.text
The Document is a container for text that serves as the model for swing text components.
Document - Interface in org.w3c.dom
The Document interface represents the entire HTML or XML document.
DOCUMENT_ACCESS_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The Printer could not access one or more documents passed by reference (i.e., the print data representation object is a URL).
DOCUMENT_FORMAT_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the printer encountered an error in the document data while processing it.
DOCUMENT_FRAGMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a DocumentFragment.
DOCUMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a Document.
DOCUMENT_POSITION_CONTAINED_BY - Static variable in interface org.w3c.dom.Node
The node is contained by the reference node.
DOCUMENT_POSITION_CONTAINS - Static variable in interface org.w3c.dom.Node
The node contains the reference node.
DOCUMENT_POSITION_DISCONNECTED - Static variable in interface org.w3c.dom.Node
The two nodes are disconnected.
DOCUMENT_POSITION_FOLLOWING - Static variable in interface org.w3c.dom.Node
The node follows the reference node.
DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC - Static variable in interface org.w3c.dom.Node
The determination of preceding versus following is implementation-specific.
DOCUMENT_POSITION_PRECEDING - Static variable in interface org.w3c.dom.Node
The second node precedes the reference node.
DOCUMENT_TYPE_NODE - Static variable in interface org.w3c.dom.Node
The node is a DocumentType.
documentBaseKey - Static variable in class javax.swing.plaf.basic.BasicHTML
Key stored as a client property to indicate the base that relative references are resolved against.
DocumentBuilder - Class in javax.xml.parsers
Defines the API to obtain DOM Document instances from an XML document.
DocumentBuilder() - Constructor for class javax.xml.parsers.DocumentBuilder
Protected constructor
DocumentBuilderFactory - Class in javax.xml.parsers
Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
DocumentBuilderFactory() - Constructor for class javax.xml.parsers.DocumentBuilderFactory
Protected constructor to prevent instantiation.
Documented - Annotation Type in java.lang.annotation
Indicates that annotations with a type are to be documented by javadoc and similar tools by default.
DocumentEvent - Interface in javax.swing.event
Interface for document change notifications.
DocumentEvent - Interface in org.w3c.dom.events
The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
DocumentEvent.ElementChange - Interface in javax.swing.event
Describes changes made to a specific element.
DocumentEvent.EventType - Class in javax.swing.event
Enumeration for document event types
DocumentFilter - Class in javax.swing.text
DocumentFilter, as the name implies, is a filter for the Document mutation methods.
DocumentFilter() - Constructor for class javax.swing.text.DocumentFilter
DocumentFilter.FilterBypass - Class in javax.swing.text
Used as a way to circumvent calling back into the Document to change it.
DocumentFilter.FilterBypass() - Constructor for class javax.swing.text.DocumentFilter.FilterBypass
DocumentFragment - Interface in org.w3c.dom
DocumentFragment is a "lightweight" or "minimal" Document object.
DocumentHandler - Interface in org.xml.sax
Deprecated.
This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
DocumentListener - Interface in javax.swing.event
Interface for an observer to register to receive notifications of changes to a text document.
DocumentName - Class in javax.print.attribute.standard
Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document.
DocumentName(String, Locale) - Constructor for class javax.print.attribute.standard.DocumentName
Constructs a new document name attribute with the given document name and locale.
DocumentParser - Class in javax.swing.text.html.parser
A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
DocumentParser(DTD) - Constructor for class javax.swing.text.html.parser.DocumentParser
DocumentType - Interface in org.w3c.dom
Each Document has a doctype attribute whose value is either null or a DocumentType object.
doDefaultCloseAction() - Method in class javax.swing.JInternalFrame
Fires an INTERNAL_FRAME_CLOSING event and then performs the action specified by the internal frame's default close operation.
doesMaxRowSizeIncludeBlobs() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the return value for the method getMaxRowSize includes the SQL data types LONGVARCHAR and LONGVARBINARY.
doFinal() - Method in class javax.crypto.Cipher
Finishes a multiple-part encryption or decryption operation, depending on how this cipher was initialized.
doFinal(byte[], int) - Method in class javax.crypto.Cipher
Finishes a multiple-part encryption or decryption operation, depending on how this cipher was initialized.
doFinal(byte[]) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int, byte[]) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int, byte[], int) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal() - Method in class javax.crypto.Mac
Finishes the MAC operation.
doFinal(byte[], int) - Method in class javax.crypto.Mac
Finishes the MAC operation.
doFinal(byte[]) - Method in class javax.crypto.Mac
Processes the given array of bytes and finishes the MAC operation.
doInBackground() - Method in class javax.swing.SwingWorker
Computes a result, or throws an exception if unable to do so.
doInput - Variable in class java.net.URLConnection
This variable is set by the setDoInput method.
doLayout() - Method in class java.awt.Component
Prompts the layout manager to lay out this component.
doLayout() - Method in class java.awt.Container
Causes this container to lay out its components.
doLayout() - Method in class java.awt.ScrollPane
Lays out this container by resizing its child to its preferred size.
doLayout() - Method in class javax.swing.JLayer
Delegates its functionality to the LayerUI.doLayout(JLayer) method, if LayerUI is set.
doLayout() - Method in class javax.swing.JTable
Causes this table to lay out its rows and columns.
doLayout(JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Causes the passed instance of JLayer to lay out its components.
doLayout() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Lays out this Container.
doLookup(Name) - Static method in class javax.naming.InitialContext
A static method to retrieve the named object.
doLookup(String) - Static method in class javax.naming.InitialContext
A static method to retrieve the named object.
DOM_OBJECT_MODEL - Static variable in class javax.xml.xpath.XPathConstants
The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".
DomainCombiner - Interface in java.security
A DomainCombiner provides a means to dynamically update the ProtectionDomains associated with the current AccessControlContext.
DomainManager - Interface in org.omg.CORBA
Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
DomainManagerOperations - Interface in org.omg.CORBA
Provides the DomainManager with the means to access policies.
domainMatches(String, String) - Static method in class java.net.HttpCookie
The utility method to check whether a host name is in a domain or not.
DOMConfiguration - Interface in org.w3c.dom
The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
DOMCryptoContext - Class in javax.xml.crypto.dom
This class provides a DOM-specific implementation of the XMLCryptoContext interface.
DOMCryptoContext() - Constructor for class javax.xml.crypto.dom.DOMCryptoContext
Default constructor.
DOMError - Interface in org.w3c.dom
DOMError is an interface that describes an error.
DOMErrorHandler - Interface in org.w3c.dom
DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
DOMException - Exception in org.w3c.dom
DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
DOMException(short, String) - Constructor for exception org.w3c.dom.DOMException
DomHandler<ElementT,ResultT extends Result> - Interface in javax.xml.bind.annotation
Converts an element (and its descendants) from/to DOM (or similar) representation.
DOMImplementation - Interface in org.w3c.dom
The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
DOMImplementationList - Interface in org.w3c.dom
The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
DOMImplementationLS - Interface in org.w3c.dom.ls
DOMImplementationLS contains the factory methods for creating Load and Save objects.
DOMImplementationRegistry - Class in org.w3c.dom.bootstrap
A factory that enables applications to obtain instances of DOMImplementation.
DOMImplementationSource - Interface in org.w3c.dom
This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
DOMINO_TILES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Domino Tiles" Unicode character block.
DOMLocator - Interface in javax.xml.transform.dom
Indicates the position of a node in a source DOM, intended primarily for error reporting.
DOMLocator - Interface in org.w3c.dom
DOMLocator is an interface that describes a location (e.g.
DOMResult - Class in javax.xml.transform.dom
Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
DOMResult() - Constructor for class javax.xml.transform.dom.DOMResult
Zero-argument default constructor.
DOMResult(Node) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target.
DOMResult(Node, String) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target with the specified System ID.
DOMResult(Node, Node) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
DOMResult(Node, Node, String) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
DOMSignContext - Class in javax.xml.crypto.dsig.dom
A DOM-specific XMLSignContext.
DOMSignContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified signing key and parent node.
DOMSignContext(Key, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
DOMSignContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified key selector and parent node.
DOMSignContext(KeySelector, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
DOMSource - Class in javax.xml.transform.dom
Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.
DOMSource() - Constructor for class javax.xml.transform.dom.DOMSource
Zero-argument default constructor.
DOMSource(Node) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node.
DOMSource(Node, String) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
DOMSTRING_SIZE_ERR - Static variable in exception org.w3c.dom.DOMException
If the specified range of text does not fit into a DOMString.
DOMStringList - Interface in org.w3c.dom
The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
DOMStructure - Class in javax.xml.crypto.dom
A DOM-specific XMLStructure.
DOMStructure(Node) - Constructor for class javax.xml.crypto.dom.DOMStructure
Creates a DOMStructure containing the specified node.
DOMURIReference - Interface in javax.xml.crypto.dom
A DOM-specific URIReference.
DOMValidateContext - Class in javax.xml.crypto.dsig.dom
A DOM-specific XMLValidateContext.
DOMValidateContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMValidateContext
Creates a DOMValidateContext containing the specified key selector and node.
DOMValidateContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMValidateContext
Creates a DOMValidateContext containing the specified key and node.
done() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
done(RemoteCall) - Method in interface java.rmi.server.RemoteRef
Deprecated.
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
DONE - Static variable in class java.text.BreakIterator
DONE is returned by previous(), next(), next(int), preceding(int) and following(int) when either the first or last text boundary has been reached.
DONE - Static variable in interface java.text.CharacterIterator
Constant that is returned when the iterator has reached either the end or the beginning of the text.
done() - Method in class java.util.concurrent.FutureTask
Protected method invoked when this task transitions to state isDone (whether normally or via cancellation).
done() - Method in class javax.swing.SwingWorker
Executed on the Event Dispatch Thread after the doInBackground method is finished.
dontUseGui() - Method in class java.beans.beancontext.BeanContextSupport
notify this instance that it may no longer render a GUI.
dontUseGui() - Method in interface java.beans.Visibility
This method instructs the bean that it should not use the Gui.
DOOR_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more doors on the device are open.
doOutput - Variable in class java.net.URLConnection
This variable is set by the setDoOutput method.
doPaint(Graphics2D, JComponent, int, int, Object[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Actually performs the painting operation.
doPhase(Key, boolean) - Method in class javax.crypto.KeyAgreement
Executes the next phase of this key agreement with the given key that was received from one of the other parties involved in this key agreement.
doPrivileged(PrivilegedAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled.
doPrivileged(PrivilegedAction<T>, AccessControlContext) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled and restricted by the specified AccessControlContext.
doPrivileged(PrivilegedExceptionAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled.
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled and restricted by the specified AccessControlContext.
doPrivilegedWithCombiner(PrivilegedAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled.
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled.
DosFileAttributes - Interface in java.nio.file.attribute
File attributes associated with a file in a file system that supports legacy "DOS" attributes.
DosFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of the legacy "DOS" file attributes.
DOTALL - Static variable in class java.util.regex.Pattern
Enables dotall mode.
Double - Class in java.lang
The Double class wraps a value of the primitive type double in an object.
Double(double) - Constructor for class java.lang.Double
Constructs a newly allocated Double object that represents the primitive double argument.
Double(String) - Constructor for class java.lang.Double
Constructs a newly allocated Double object that represents the floating-point value of type double represented by the string.
DOUBLE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DOUBLE.
DOUBLE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Double.
DoubleBuffer - Class in java.nio
A double buffer.
DoubleHolder - Class in org.omg.CORBA
The Holder for Double.
DoubleHolder() - Constructor for class org.omg.CORBA.DoubleHolder
Constructs a new DoubleHolder object with its value field initialized to 0.0.
DoubleHolder(double) - Constructor for class org.omg.CORBA.DoubleHolder
Constructs a new DoubleHolder object for the given double.
DoubleSeqHelper - Class in org.omg.CORBA
The Helper for DoubleSeq.
DoubleSeqHelper() - Constructor for class org.omg.CORBA.DoubleSeqHelper
DoubleSeqHolder - Class in org.omg.CORBA
The Holder for DoubleSeq.
DoubleSeqHolder() - Constructor for class org.omg.CORBA.DoubleSeqHolder
DoubleSeqHolder(double[]) - Constructor for class org.omg.CORBA.DoubleSeqHolder
doubleToLongBits(double) - Static method in class java.lang.Double
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "double format" bit layout.
doubleToRawLongBits(double) - Static method in class java.lang.Double
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "double format" bit layout, preserving Not-a-Number (NaN) values.
doubleValue() - Method in class java.lang.Byte
Returns the value of this Byte as a double.
doubleValue() - Method in class java.lang.Double
Returns the double value of this Double object.
doubleValue() - Method in class java.lang.Float
Returns the double value of this Float object.
doubleValue() - Method in class java.lang.Integer
Returns the value of this Integer as a double.
doubleValue() - Method in class java.lang.Long
Returns the value of this Long as a double.
doubleValue() - Method in class java.lang.Number
Returns the value of the specified number as a double.
doubleValue() - Method in class java.lang.Short
Returns the value of this Short as a double.
doubleValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to a double.
doubleValue() - Method in class java.math.BigInteger
Converts this BigInteger to a double.
doubleValue() - Method in class java.util.concurrent.atomic.AtomicInteger
doubleValue() - Method in class java.util.concurrent.atomic.AtomicLong
DOWN - Static variable in class java.awt.Event
The Down Arrow key, a non-ASCII action key.
DOWN_CYCLE_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Down Cycle focus traversal keys.
downAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically downward one position.
downFocusCycle(Container) - Method in class java.awt.DefaultKeyboardFocusManager
Moves the focus down one focus traversal cycle.
downFocusCycle(Container) - Method in class java.awt.KeyboardFocusManager
Moves the focus down one focus traversal cycle.
downFocusCycle() - Method in class java.awt.KeyboardFocusManager
Moves the focus down one focus traversal cycle from the current focus owner, if and only if the current focus owner is a Container that is a focus cycle root.
downKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
downKey - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
Deprecated.
As of Java 2 platform v1.3.
downKey - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Deprecated.
As of Java 2 platform v1.3.
DPCM - Static variable in class javax.print.attribute.ResolutionSyntax
Value to indicate units of dots per centimeter (dpcm).
DPI - Static variable in class javax.print.attribute.ResolutionSyntax
Value to indicate units of dots per inch (dpi).
DRAFT - Static variable in class java.awt.PageAttributes.PrintQualityType
The PrintQualityType instance to use for specifying a draft print quality.
DRAFT - Static variable in class javax.print.attribute.standard.PrintQuality
Lowest quality available on the printer.
DRAG_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Drag layer.
dragDividerTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Messages the BasicSplitPaneUI with dragDividerTo that this instance is contained in.
dragDividerTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Messaged during a dragging session to move the divider to the passed in location.
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd.DragSourceAdapter
This method is invoked to signify that the Drag and Drop operation is complete.
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragDropEnd on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDropEvent.
dragDropEnd(DragSourceDropEvent) - Method in interface java.awt.dnd.DragSourceListener
This method is invoked to signify that the Drag and Drop operation is complete.
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot enters a platform-dependent drop site.
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragEnter on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dragEnter(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot enters a platform-dependent drop site.
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dragEnter on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called while a drag operation is ongoing, when the mouse pointer enters the operable part of the drop site for the DropTarget registered with this listener.
dragEnter(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called while a drag operation is ongoing, when the mouse pointer enters the operable part of the drop site for the DropTarget registered with this listener.
dragExit(DragSourceEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot exits a platform-dependent drop site.
dragExit(DragSourceEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragExit on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceEvent.
dragExit(DragSourceEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot exits a platform-dependent drop site.
dragExit(DropTargetEvent) - Method in class java.awt.dnd.DropTarget
Calls dragExit on the registered DropTargetListener and passes it the specified DropTargetEvent.
dragExit(DropTargetEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called while a drag operation is ongoing, when the mouse pointer has exited the operable part of the drop site for the DropTarget registered with this listener.
dragExit(DropTargetEvent) - Method in interface java.awt.dnd.DropTargetListener
Called while a drag operation is ongoing, when the mouse pointer has exited the operable part of the drop site for the DropTarget registered with this listener.
dragFrame(JComponent, int, int) - Method in class javax.swing.DefaultDesktopManager
Moves the visible location of the frame being dragged to the location specified.
dragFrame(JComponent, int, int) - Method in interface javax.swing.DesktopManager
The user has moved the frame.
draggedColumn - Variable in class javax.swing.table.JTableHeader
The index of the column being dragged.
draggedDistance - Variable in class javax.swing.table.JTableHeader
The distance from its original position the column has been dragged.
dragger - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Handles mouse dragging message to do the actual dragging.
DragGestureEvent - Class in java.awt.dnd
A DragGestureEvent is passed to DragGestureListener's dragGestureRecognized() method when a particular DragGestureRecognizer detects that a platform dependent drag initiating gesture has occurred on the Component that it is tracking.
DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>) - Constructor for class java.awt.dnd.DragGestureEvent
Constructs a DragGestureEvent object given by the DragGestureRecognizer instance firing this event, an act parameter representing the user's preferred action, an ori parameter indicating the origin of the drag, and a List of events that comprise the gesture(evs parameter).
DragGestureListener - Interface in java.awt.dnd
The listener interface for receiving drag gesture events.
dragGestureListener - Variable in class java.awt.dnd.DragGestureRecognizer
The DragGestureListener associated with this DragGestureRecognizer.
dragGestureRecognized(DragGestureEvent) - Method in interface java.awt.dnd.DragGestureListener
This method is invoked by the DragGestureRecognizer when the DragGestureRecognizer detects a platform-dependent drag initiating gesture.
DragGestureRecognizer - Class in java.awt.dnd
The DragGestureRecognizer is an abstract base class for the specification of a platform-dependent listener that can be associated with a particular Component in order to identify platform-dependent drag initiating gestures.
DragGestureRecognizer(DragSource, Component, int, DragGestureListener) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, the Component this DragGestureRecognizer should "observe" for drag initiating gestures, the action(s) supported for this Drag and Drop operation, and the DragGestureListener to notify once a drag initiating gesture has been detected.
DragGestureRecognizer(DragSource, Component, int) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, the Component this DragGestureRecognizer should "observe" for drag initiating gestures, and the action(s) supported for this Drag and Drop operation.
DragGestureRecognizer(DragSource, Component) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, and the Component this DragGestureRecognizer should "observe" for drag initiating gestures.
DragGestureRecognizer(DragSource) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation.
draggingHW - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Set to true in startDragging if any of the children (not including the nonContinuousLayoutDivider) are heavy weights.
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called whenever the mouse is moved during a drag operation.
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragMouseMoved on the DragSourceMotionListeners registered with the DragSource associated with this DragSourceContext, and them passes the specified DragSourceDragEvent.
dragMouseMoved(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceMotionListener
Called whenever the mouse is moved during a drag operation.
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot moves over a platform-dependent drop site.
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragOver on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dragOver(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot moves over a platform-dependent drop site.
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dragOver on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called when a drag operation is ongoing, while the mouse pointer is still over the operable part of the drop site for the DropTarget registered with this listener.
dragOver(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called when a drag operation is ongoing, while the mouse pointer is still over the operable part of the drop site for the DropTarget registered with this listener.
dragSource - Variable in class java.awt.dnd.DragGestureRecognizer
The DragSource associated with this DragGestureRecognizer.
DragSource - Class in java.awt.dnd
The DragSource is the entity responsible for the initiation of the Drag and Drop operation, and may be used in a number of scenarios: 1 default instance per JVM for the lifetime of that JVM.
DragSource() - Constructor for class java.awt.dnd.DragSource
Creates a new DragSource.
DragSourceAdapter - Class in java.awt.dnd
An abstract adapter class for receiving drag source events.
DragSourceAdapter() - Constructor for class java.awt.dnd.DragSourceAdapter
DragSourceContext - Class in java.awt.dnd
The DragSourceContext class is responsible for managing the initiator side of the Drag and Drop protocol.
DragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Constructor for class java.awt.dnd.DragSourceContext
Called from DragSource, this constructor creates a new DragSourceContext given the DragSourceContextPeer for this Drag, the DragGestureEvent that triggered the Drag, the initial Cursor to use for the Drag, an (optional) Image to display while the Drag is taking place, the offset of the Image origin from the hotspot at the instant of the triggering event, the Transferable subject data, and the DragSourceListener to use during the Drag and Drop operation.
DragSourceDragEvent - Class in java.awt.dnd
The DragSourceDragEvent is delivered from the DragSourceContextPeer, via the DragSourceContext, to the DragSourceListener registered with that DragSourceContext and with its associated DragSource.
DragSourceDragEvent(DragSourceContext, int, int, int) - Constructor for class java.awt.dnd.DragSourceDragEvent
Constructs a DragSourceDragEvent.
DragSourceDragEvent(DragSourceContext, int, int, int, int, int) - Constructor for class java.awt.dnd.DragSourceDragEvent
Constructs a DragSourceDragEvent given the specified DragSourceContext, user drop action, target drop action, modifiers and coordinates.
DragSourceDropEvent - Class in java.awt.dnd
The DragSourceDropEvent is delivered from the DragSourceContextPeer, via the DragSourceContext, to the dragDropEnd method of DragSourceListeners registered with that DragSourceContext and with its associated DragSource.
DragSourceDropEvent(DragSourceContext, int, boolean) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drop, given the DragSourceContext, the drop action, and a boolean indicating if the drop was successful.
DragSourceDropEvent(DragSourceContext, int, boolean, int, int) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drop, given the DragSourceContext, the drop action, a boolean indicating if the drop was successful, and coordinates.
DragSourceDropEvent(DragSourceContext) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drag that does not result in a drop.
DragSourceEvent - Class in java.awt.dnd
This class is the base class for DragSourceDragEvent and DragSourceDropEvent.
DragSourceEvent(DragSourceContext) - Constructor for class java.awt.dnd.DragSourceEvent
Construct a DragSourceEvent given a specified DragSourceContext.
DragSourceEvent(DragSourceContext, int, int) - Constructor for class java.awt.dnd.DragSourceEvent
Construct a DragSourceEvent given a specified DragSourceContext, and coordinates of the cursor location.
DragSourceListener - Interface in java.awt.dnd
The DragSourceListener defines the event interface for originators of Drag and Drop operations to track the state of the user's gesture, and to provide appropriate "drag over" feedback to the user throughout the Drag and Drop operation.
DragSourceMotionListener - Interface in java.awt.dnd
A listener interface for receiving mouse motion events during a drag operation.
dragTo(Point, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
dragWindow - Variable in class javax.swing.plaf.basic.BasicToolBarUI
drain() - Method in class java.io.ObjectOutputStream
Drain any buffered data in ObjectOutputStream.
drain() - Method in interface javax.sound.sampled.DataLine
Drains queued data from the line by continuing data I/O until the data line's internal buffer has been emptied.
drainPermits() - Method in class java.util.concurrent.Semaphore
Acquires and returns all permits that are immediately available.
drainTasksTo(Collection<? super ForkJoinTask<?>>) - Method in class java.util.concurrent.ForkJoinPool
Removes all available unexecuted submitted and forked tasks from scheduling queues and adds them to the given collection, without altering their execution status.
drainTo(Collection<? super E>) - Method in class java.util.concurrent.ArrayBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.ArrayBlockingQueue
drainTo(Collection<? super E>) - Method in interface java.util.concurrent.BlockingQueue
Removes all available elements from this queue and adds them to the given collection.
drainTo(Collection<? super E>, int) - Method in interface java.util.concurrent.BlockingQueue
Removes at most the given number of available elements from this queue and adds them to the given collection.
drainTo(Collection<? super E>) - Method in class java.util.concurrent.DelayQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.DelayQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedBlockingDeque
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedBlockingDeque
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedTransferQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedTransferQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.PriorityBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.PriorityBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.SynchronousQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.SynchronousQueue
draw(Graphics2D, float, float) - Method in class java.awt.font.GraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.ImageGraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.ShapeGraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.TextLayout
Renders this TextLayout at the specified location in the specified Graphics2D context.
draw(Shape) - Method in class java.awt.Graphics2D
Strokes the outline of a Shape using the settings of the current Graphics2D context.
draw3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics
Draws a 3-D highlighted outline of the specified rectangle.
draw3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics2D
Draws a 3-D highlighted outline of the specified rectangle.
draw3DRect(int, int, int, int, boolean) - Method in class javax.swing.DebugGraphics
Overrides Graphics.draw3DRect.
drawArc(int, int, int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of a circular or elliptical arc covering the specified rectangle.
drawArc(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawArc.
drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawBuffer - Variable in class java.awt.Component.FlipBufferStrategy
The drawing buffer
drawBytes(byte[], int, int, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified byte array, using this graphics context's current font and color.
drawBytes(byte[], int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawBytes.
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI
drawChars(char[], int, int, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified character array, using this graphics context's current font and color.
drawChars(char[], int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawChars.
drawCheck(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon
drawDashedHorizontalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawDashedRect(Graphics, int, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawDashedVerticalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawEchoCharacter(Graphics, int, int, char) - Method in class javax.swing.text.PasswordView
Renders the echo character, or whatever graphic should be used to display the password characters.
drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawGlyphVector(GlyphVector, float, float) - Method in class java.awt.Graphics2D
Renders the text of the specified GlyphVector using the Graphics2D context's rendering attributes.
drawGroove(Graphics, int, int, int, int, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawImage(Image, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as is currently available.
drawImage(Image, int, int, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(Image, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as is currently available.
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, AffineTransform, ImageObserver) - Method in class java.awt.Graphics2D
Renders an image, applying a transform from image space into user space before drawing.
drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class java.awt.Graphics2D
Renders a BufferedImage that is filtered with a BufferedImageOp.
drawImage(Image, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawingCache - Variable in class javax.swing.plaf.basic.BasicTreeUI
Used for minimizing the drawing of vertical lines.
drawInverted() - Method in class javax.swing.plaf.basic.BasicSliderUI
drawLine(int, int, int, int) - Method in class java.awt.Graphics
Draws a line, using the current color, between the points (x1, y1) and (x2, y2) in this graphics context's coordinate system.
drawLine(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawLine.
drawLine(SynthContext, Object, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Draws a line between the two end points.
drawLine(SynthContext, Object, Graphics, int, int, int, int, Object) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Draws a line between the two end points.
drawLine(int, Graphics, int, int) - Method in class javax.swing.text.PlainView
Renders a line of text, suppressing whitespace at the end and expanding any tabs.
drawLine(int, int, Graphics, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders a line of text, suppressing whitespace at the end and expanding any tabs.
drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawOval(int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of an oval.
drawOval(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawOval.
drawPolygon(int[], int[], int) - Method in class java.awt.Graphics
Draws a closed polygon defined by arrays of x and y coordinates.
drawPolygon(Polygon) - Method in class java.awt.Graphics
Draws the outline of a polygon defined by the specified Polygon object.
drawPolygon(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawPolygon.
drawPolyline(int[], int[], int) - Method in class java.awt.Graphics
Draws a sequence of connected lines defined by arrays of x and y coordinates.
drawPolyline(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawPolyline.
drawRect(int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of the specified rectangle.
drawRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawRect.
drawRenderableImage(RenderableImage, AffineTransform) - Method in class java.awt.Graphics2D
Renders a RenderableImage, applying a transform from image space into user space before drawing.
drawRenderedImage(RenderedImage, AffineTransform) - Method in class java.awt.Graphics2D
Renders a RenderedImage, applying a transform from image space into user space before drawing.
drawRoundRect(int, int, int, int, int, int) - Method in class java.awt.Graphics
Draws an outlined round-cornered rectangle using this graphics context's current color.
drawRoundRect(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawRoundRect.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PasswordView
Renders the given range in the model as selected text.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PlainView
Renders the given range in the model as selected text.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders the given range in the model as selected text.
drawString(String, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified string, using this graphics context's current font and color.
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt.Graphics
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(String, int, int) - Method in class java.awt.Graphics2D
Renders the text of the specified String, using the current text attribute state in the Graphics2D context.
drawString(String, float, float) - Method in class java.awt.Graphics2D
Renders the text specified by the specified String, using the current text attribute state in the Graphics2D context.
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt.Graphics2D
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(AttributedCharacterIterator, float, float) - Method in class java.awt.Graphics2D
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(String, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawString.
drawString(AttributedCharacterIterator, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawString.
drawString(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
Draw a string with the graphics g at location (x,y) just like g.drawString would.
drawStringUnderlineCharAt(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
Draw a string with the graphics g at location (x, y) just like g.drawString would.
drawTabbedText(Segment, int, int, Graphics, TabExpander, int) - Static method in class javax.swing.text.Utilities
Draws the given text, expanding any tabs that are contained using the given tab expansion technique.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PasswordView
Renders the given range in the model as normal unselected text.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PlainView
Renders the given range in the model as normal unselected text.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders the given range in the model as normal unselected text.
drawVBuffer - Variable in class java.awt.Component.FlipBufferStrategy
The drawing buffer as a volatile image
Driver - Interface in java.sql
The interface that every driver class must implement.
DriverManager - Class in java.sql
The basic service for managing a set of JDBC drivers.
NOTE: The DataSource interface, new in the JDBC 2.0 API, provides another way to connect to a data source.
DriverPropertyInfo - Class in java.sql
Driver properties for making a connection.
DriverPropertyInfo(String, String) - Constructor for class java.sql.DriverPropertyInfo
Constructs a DriverPropertyInfo object with a given name and value.
drop(DropTargetDropEvent) - Method in class java.awt.dnd.DropTarget
Calls drop on the registered DropTargetListener and passes it the specified DropTargetDropEvent if this DropTarget is active.
drop(DropTargetDropEvent) - Method in interface java.awt.dnd.DropTargetListener
Called when the drag operation has terminated with a drop on the operable part of the drop site for the DropTarget registered with this listener.
drop() - Method in class java.nio.channels.MembershipKey
Drop membership.
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called when the user has modified the drop gesture.
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dropActionChanged on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dropActionChanged(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called when the user has modified the drop gesture.
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dropActionChanged on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called if the user has modified the current drop gesture.
dropActionChanged(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called if the user has modified the current drop gesture.
dropArguments(MethodHandle, int, List<Class<?>>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which calls the original method handle, after dropping the given argument(s) at the given position.
dropArguments(MethodHandle, int, Class<?>...) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which calls the original method handle, after dropping the given argument(s) at the given position.
dropComplete(boolean) - Method in class java.awt.dnd.DropTargetContext
This method signals that the drop is completed and if it was successful or not.
dropComplete(boolean) - Method in class java.awt.dnd.DropTargetDropEvent
This method notifies the DragSource that the drop transfer(s) are completed.
DropMode - Enum in javax.swing
Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
dropParameterTypes(int, int) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with some parameter types omitted.
DropTarget - Class in java.awt.dnd
The DropTarget is associated with a Component when that Component wishes to accept drops during Drag and Drop operations.
DropTarget(Component, int, DropTargetListener, boolean, FlavorMap) - Constructor for class java.awt.dnd.DropTarget
Creates a new DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, a DropTargetListener to handle event processing, a boolean indicating if the DropTarget is currently accepting drops, and a FlavorMap to use (or null for the default FlavorMap).
DropTarget(Component, int, DropTargetListener, boolean) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, a DropTargetListener to handle event processing, and a boolean indicating if the DropTarget is currently accepting drops.
DropTarget() - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget.
DropTarget(Component, DropTargetListener) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, and the DropTargetListener to handle event processing.
DropTarget(Component, int, DropTargetListener) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, and a DropTargetListener to handle event processing.
DropTarget.DropTargetAutoScroller - Class in java.awt.dnd
this protected nested class implements autoscrolling
DropTarget.DropTargetAutoScroller(Component, Point) - Constructor for class java.awt.dnd.DropTarget.DropTargetAutoScroller
construct a DropTargetAutoScroller
DropTargetAdapter - Class in java.awt.dnd
An abstract adapter class for receiving drop target events.
DropTargetAdapter() - Constructor for class java.awt.dnd.DropTargetAdapter
DropTargetContext - Class in java.awt.dnd
A DropTargetContext is created whenever the logical cursor associated with a Drag and Drop operation coincides with the visible geometry of a Component associated with a DropTarget.
DropTargetContext.TransferableProxy - Class in java.awt.dnd
TransferableProxy is a helper inner class that implements Transferable interface and serves as a proxy for another Transferable object which represents data transfer for a particular drag-n-drop operation.
DropTargetDragEvent - Class in java.awt.dnd
The DropTargetDragEvent is delivered to a DropTargetListener via its dragEnter() and dragOver() methods.
DropTargetDragEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd.DropTargetDragEvent
Construct a DropTargetDragEvent given the DropTargetContext for this operation, the location of the "Drag" Cursor's hotspot in the Component's coordinates, the user drop action, and the source drop actions.
DropTargetDropEvent - Class in java.awt.dnd
The DropTargetDropEvent is delivered via the DropTargetListener drop() method.
DropTargetDropEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd.DropTargetDropEvent
Construct a DropTargetDropEvent given the DropTargetContext for this operation, the location of the drag Cursor's hotspot in the Component's coordinates, the currently selected user drop action, and the current set of actions supported by the source.
DropTargetDropEvent(DropTargetContext, Point, int, int, boolean) - Constructor for class java.awt.dnd.DropTargetDropEvent
Construct a DropTargetEvent given the DropTargetContext for this operation, the location of the drag Cursor's hotspot in the Component's coordinates, the currently selected user drop action, the current set of actions supported by the source, and a boolean indicating if the source is in the same JVM as the target.
DropTargetEvent - Class in java.awt.dnd
The DropTargetEvent is the base class for both the DropTargetDragEvent and the DropTargetDropEvent.
DropTargetEvent(DropTargetContext) - Constructor for class java.awt.dnd.DropTargetEvent
Construct a DropTargetEvent object with the specified DropTargetContext.
DropTargetListener - Interface in java.awt.dnd
The DropTargetListener interface is the callback interface used by the DropTarget class to provide notification of DnD operations that involve the subject DropTarget.
DSA_SHA1 - Static variable in interface javax.xml.crypto.dsig.SignatureMethod
The DSAwithSHA1 (DSS) signature method algorithm URI.
DSA_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.KeyValue
URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue.
DSAKey - Interface in java.security.interfaces
The interface to a DSA public or private key.
DSAKeyPairGenerator - Interface in java.security.interfaces
An interface to an object capable of generating DSA key pairs.
DSAParameterSpec - Class in java.security.spec
This class specifies the set of parameters used with the DSA algorithm.
DSAParameterSpec(BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAParameterSpec
Creates a new DSAParameterSpec with the specified parameter values.
DSAParams - Interface in java.security.interfaces
Interface to a DSA-specific set of key parameters, which defines a DSA key family.
DSAPrivateKey - Interface in java.security.interfaces
The standard interface to a DSA private key.
DSAPrivateKeySpec - Class in java.security.spec
This class specifies a DSA private key with its associated parameters.
DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAPrivateKeySpec
Creates a new DSAPrivateKeySpec with the specified parameter values.
DSAPublicKey - Interface in java.security.interfaces
The interface to a DSA public key.
DSAPublicKeySpec - Class in java.security.spec
This class specifies a DSA public key with its associated parameters.
DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAPublicKeySpec
Creates a new DSAPublicKeySpec with the specified parameter values.
DST - Static variable in class java.awt.AlphaComposite
The destination is left untouched (Porter-Duff Destination rule).
Dst - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST rule with an alpha of 1.0f.
DST_ATOP - Static variable in class java.awt.AlphaComposite
The part of the destination lying inside of the source is composited over the source and replaces the destination (Porter-Duff Destination Atop Source rule).
DST_IN - Static variable in class java.awt.AlphaComposite
The part of the destination lying inside of the source replaces the destination (Porter-Duff Destination In Source rule).
DST_OFFSET - Static variable in class java.util.Calendar
Field number for get and set indicating the daylight saving offset in milliseconds.
DST_OUT - Static variable in class java.awt.AlphaComposite
The part of the destination lying outside of the source replaces the destination (Porter-Duff Destination Held Out By Source rule).
DST_OVER - Static variable in class java.awt.AlphaComposite
The destination is composited over the source and the result replaces the destination (Porter-Duff Destination Over Source rule).
DstAtop - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_ATOP rule with an alpha of 1.0f.
DstIn - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_IN rule with an alpha of 1.0f.
DstOut - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_OUT rule with an alpha of 1.0f.
DstOver - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_OVER rule with an alpha of 1.0f.
DT - Static variable in class javax.swing.text.html.HTML.Tag
DTD - Class in javax.swing.text.html.parser
The representation of an SGML DTD.
DTD(String) - Constructor for class javax.swing.text.html.parser.DTD
Creates a new DTD with the specified name.
dtd - Variable in class javax.swing.text.html.parser.Parser
DTD - Interface in javax.xml.stream.events
This is the top level interface for events dealing with DTDs
DTD - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a DTD
DTDConstants - Interface in javax.swing.text.html.parser
SGML constants used in a DTD.
DTDHandler - Interface in org.xml.sax
Receive notification of basic DTD-related events.
DUMMY - Static variable in class javax.swing.text.html.HTML.Attribute
dump(PrintStream, int) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Dumps a debugging representation of the element hierarchy.
dump(PrintStream) - Method in class javax.swing.text.AbstractDocument
Gives a diagnostic dump.
dumpAllThreads(boolean, boolean) - Method in interface java.lang.management.ThreadMXBean
Returns the thread info for all live threads with stack trace and synchronization information.
dumpStack() - Static method in class java.lang.Thread
Prints a stack trace of the current thread to the standard error stream.
DUPLEX - Static variable in class javax.print.attribute.standard.Sides
An alias for "two sided long edge" (see TWO_SIDED_LONG_EDGE).
duplicate() - Method in class java.nio.ByteBuffer
Creates a new byte buffer that shares this buffer's content.
duplicate() - Method in class java.nio.CharBuffer
Creates a new char buffer that shares this buffer's content.
duplicate() - Method in class java.nio.DoubleBuffer
Creates a new double buffer that shares this buffer's content.
duplicate() - Method in class java.nio.FloatBuffer
Creates a new float buffer that shares this buffer's content.
duplicate() - Method in class java.nio.IntBuffer
Creates a new int buffer that shares this buffer's content.
duplicate() - Method in class java.nio.LongBuffer
Creates a new long buffer that shares this buffer's content.
duplicate() - Method in class java.nio.ShortBuffer
Creates a new short buffer that shares this buffer's content.
duplicate(Object) - Method in class org.omg.CORBA.portable.Delegate
Returns a duplicate of the object reference provided.
DUPLICATE_ELEMENT - Static variable in exception org.ietf.jgss.GSSException
Duplicate credential element requested.
DUPLICATE_TOKEN - Static variable in exception org.ietf.jgss.GSSException
The token was a duplicate of an earlier token.
DuplicateFormatFlagsException - Exception in java.util
Unchecked exception thrown when duplicate flags are provided in the format specifier.
DuplicateFormatFlagsException(String) - Constructor for exception java.util.DuplicateFormatFlagsException
Constructs an instance of this class with the specified flags.
DuplicateName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
DuplicateName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateName(String, String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
DuplicateNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
DURATION - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema datatype duration.
Duration - Class in javax.xml.datatype
Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
Duration() - Constructor for class javax.xml.datatype.Duration
Default no-arg constructor.
DURATION_DAYTIME - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
DURATION_YEARMONTH - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
DYNAMIC_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
DynamicImplementation - Class in org.omg.CORBA
Deprecated.
org.omg.CORBA.DynamicImplementation
DynamicImplementation() - Constructor for class org.omg.CORBA.DynamicImplementation
Deprecated.
DynamicImplementation - Class in org.omg.PortableServer
Allows dynamic handling of object invocations.
DynamicImplementation() - Constructor for class org.omg.PortableServer.DynamicImplementation
dynamicInvoker() - Method in class java.lang.invoke.CallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
dynamicInvoker() - Method in class java.lang.invoke.ConstantCallSite
Returns this call site's permanent target.
dynamicInvoker() - Method in class java.lang.invoke.MutableCallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
dynamicInvoker() - Method in class java.lang.invoke.VolatileCallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
DynamicMBean - Interface in javax.management
Defines the methods that should be implemented by a Dynamic MBean (MBean that exposes a dynamic management interface).
DynAny - Interface in org.omg.CORBA
Deprecated.
Use the new DynAny instead
DynAny - Interface in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnyFactory - Interface in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyFactoryHelper - Class in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyFactoryHelper() - Constructor for class org.omg.DynamicAny.DynAnyFactoryHelper
DynAnyFactoryOperations - Interface in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyHelper - Class in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnyHelper() - Constructor for class org.omg.DynamicAny.DynAnyHelper
DynAnyOperations - Interface in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnySeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/DynAnySeqHelper.java .
DynAnySeqHelper() - Constructor for class org.omg.DynamicAny.DynAnySeqHelper
DynArray - Interface in org.omg.CORBA
Deprecated.
Use the new DynArray instead
DynArray - Interface in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynArrayHelper - Class in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynArrayHelper() - Constructor for class org.omg.DynamicAny.DynArrayHelper
DynArrayOperations - Interface in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynEnum - Interface in org.omg.CORBA
Deprecated.
Use the new DynEnum instead
DynEnum - Interface in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynEnumHelper - Class in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynEnumHelper() - Constructor for class org.omg.DynamicAny.DynEnumHelper
DynEnumOperations - Interface in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynFixed - Interface in org.omg.CORBA
Deprecated.
Use the new DynFixed instead
DynFixed - Interface in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynFixedHelper - Class in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynFixedHelper() - Constructor for class org.omg.DynamicAny.DynFixedHelper
DynFixedOperations - Interface in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynSequence - Interface in org.omg.CORBA
Deprecated.
Use the new DynSequence instead
DynSequence - Interface in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynSequenceHelper - Class in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynSequenceHelper() - Constructor for class org.omg.DynamicAny.DynSequenceHelper
DynSequenceOperations - Interface in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynStruct - Interface in org.omg.CORBA
Deprecated.
Use the new DynStruct instead
DynStruct - Interface in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynStructHelper - Class in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynStructHelper() - Constructor for class org.omg.DynamicAny.DynStructHelper
DynStructOperations - Interface in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynUnion - Interface in org.omg.CORBA
Deprecated.
Use the new DynUnion instead
DynUnion - Interface in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynUnionHelper - Class in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynUnionHelper() - Constructor for class org.omg.DynamicAny.DynUnionHelper
DynUnionOperations - Interface in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynValue - Interface in org.omg.CORBA
Deprecated.
Use the new DynValue instead
DynValue - Interface in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
DynValueBox - Interface in org.omg.DynamicAny
DynValueBox objects support the manipulation of IDL boxed value types.
DynValueBoxOperations - Interface in org.omg.DynamicAny
DynValueBox objects support the manipulation of IDL boxed value types.
DynValueCommon - Interface in org.omg.DynamicAny
DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueCommonOperations - Interface in org.omg.DynamicAny
DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueHelper - Class in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
DynValueHelper() - Constructor for class org.omg.DynamicAny.DynValueHelper
DynValueOperations - Interface in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

b


E-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

E - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering E, 34 x 44 in.
E - Static variable in class java.lang.Math
The double value that is closer than any other to e, the base of the natural logarithms.
E - Static variable in class java.lang.StrictMath
The double value that is closer than any other to e, the base of the natural logarithms.
E - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering E size, 34 inch by 44 inch.
E - Static variable in class javax.print.attribute.standard.MediaSizeName
E size .
E_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The east-resize cursor type.
E_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.E_RESIZE_CURSOR.
EAST - Static variable in class java.awt.BorderLayout
The east layout constraint (right side of container).
EAST - Static variable in class java.awt.GridBagConstraints
Put the component on the right side of its display area, centered vertically.
EAST - Static variable in class javax.swing.SpringLayout
Specifies the right edge of a component's bounding rectangle.
EAST - Static variable in interface javax.swing.SwingConstants
Compass-direction east (right).
EASTERN_ARABIC - Static variable in class java.awt.font.NumericShaper
Identifies the ARABIC range and ARABIC_EXTENDED decimal base.
eastPane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
ECField - Interface in java.security.spec
This interface represents an elliptic curve (EC) finite field.
ECFieldF2m - Class in java.security.spec
This immutable class defines an elliptic curve (EC) characteristic 2 finite field.
ECFieldF2m(int) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with normal basis.
ECFieldF2m(int, BigInteger) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
ECFieldF2m(int, int[]) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
ECFieldFp - Class in java.security.spec
This immutable class defines an elliptic curve (EC) prime finite field.
ECFieldFp(BigInteger) - Constructor for class java.security.spec.ECFieldFp
Creates an elliptic curve prime finite field with the specified prime p.
ECGenParameterSpec - Class in java.security.spec
This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters.
ECGenParameterSpec(String) - Constructor for class java.security.spec.ECGenParameterSpec
Creates a parameter specification for EC parameter generation using a standard (or predefined) name stdName in order to generate the corresponding (precomputed) elliptic curve domain parameters.
echoCharIsSet() - Method in class java.awt.TextField
Indicates whether or not this text field has a character set for echoing.
echoCharIsSet() - Method in class javax.swing.JPasswordField
Returns true if this JPasswordField has a character set for echoing.
ECKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) key.
ECParameterSpec - Class in java.security.spec
This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC).
ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int) - Constructor for class java.security.spec.ECParameterSpec
Creates elliptic curve domain parameters based on the specified values.
ECPoint - Class in java.security.spec
This immutable class represents a point on an elliptic curve (EC) in affine coordinates.
ECPoint(BigInteger, BigInteger) - Constructor for class java.security.spec.ECPoint
Creates an ECPoint from the specified affine x-coordinate x and affine y-coordinate y.
ECPrivateKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) private key.
ECPrivateKeySpec - Class in java.security.spec
This immutable class specifies an elliptic curve private key with its associated parameters.
ECPrivateKeySpec(BigInteger, ECParameterSpec) - Constructor for class java.security.spec.ECPrivateKeySpec
Creates a new ECPrivateKeySpec with the specified parameter values.
ECPublicKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) public key.
ECPublicKeySpec - Class in java.security.spec
This immutable class specifies an elliptic curve public key with its associated parameters.
ECPublicKeySpec(ECPoint, ECParameterSpec) - Constructor for class java.security.spec.ECPublicKeySpec
Creates a new ECPublicKeySpec with the specified parameter values.
EDGE_NO_OP - Static variable in class java.awt.image.ConvolveOp
Pixels at the edge of the source image are copied to the corresponding pixels in the destination without modification.
EDGE_SPACING - Static variable in class javax.swing.border.TitledBorder
EDGE_STITCH - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along one edge.
EDGE_STITCH_BOTTOM - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the bottom edge.
EDGE_STITCH_LEFT - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the left edge.
EDGE_STITCH_RIGHT - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the right edge.
EDGE_STITCH_TOP - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the top edge.
EDGE_ZERO_FILL - Static variable in class java.awt.image.ConvolveOp
Pixels at the edge of the destination image are set to zero.
edit(File) - Method in class java.awt.Desktop
Launches the associated editor application and opens a file for editing.
EDITABLE - Static variable in class javax.accessibility.AccessibleState
Indicates the user can change the contents of this object.
editable - Variable in class javax.swing.JTree
Is the tree editable? Default is false.
EDITABLE_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for editable.
editablePropertyChanged(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
Deprecated.
As of Java 2 platform v1.4.
EDITBAR - Static variable in class javax.accessibility.AccessibleRole
A role indicating the object acts as a formula for calculating a value.
editCellAt(int, int) - Method in class javax.swing.JTable
Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
editCellAt(int, int, EventObject) - Method in class javax.swing.JTable
Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
editingCanceled(ChangeEvent) - Method in interface javax.swing.event.CellEditorListener
This tells the listeners the editor has canceled editing
editingCanceled(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Invoked when editing is canceled.
editingCanceled(ChangeEvent) - Method in class javax.swing.JTable
Invoked when editing is canceled.
editingCanceled(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
Messaged when editing has been canceled in the tree.
editingColumn - Variable in class javax.swing.JTable
Identifies the column of the cell being edited.
editingComponent - Variable in class javax.swing.plaf.basic.BasicTreeUI
When editing, this will be the Component that is doing the actual editing.
editingComponent - Variable in class javax.swing.tree.DefaultTreeCellEditor
Component used in editing, obtained from the editingContainer.
editingContainer - Variable in class javax.swing.tree.DefaultTreeCellEditor
Editing container, will contain the editorComponent.
editingIcon - Variable in class javax.swing.tree.DefaultTreeCellEditor
Icon to use when editing.
editingPath - Variable in class javax.swing.plaf.basic.BasicTreeUI
Path that is being edited.
editingRow - Variable in class javax.swing.JTable
Identifies the row of the cell being edited.
editingRow - Variable in class javax.swing.plaf.basic.BasicTreeUI
Row that is being edited.
editingStopped(ChangeEvent) - Method in interface javax.swing.event.CellEditorListener
This tells the listeners the editor has ended editing
editingStopped(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to a cell's contents.
editingStopped(ChangeEvent) - Method in class javax.swing.JTable
Invoked when editing is finished.
editingStopped(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
Messaged when editing has stopped in the tree.
editor - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
editor - Variable in class javax.swing.plaf.basic.BasicComboBoxEditor
editor - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
EDITOR_PANE - Static variable in class javax.swing.plaf.synth.Region
EditorPane region.
editorBorderInsets - Variable in class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
editorBorderInsets - Static variable in class javax.swing.plaf.metal.MetalComboBoxEditor
The default editor border Insets.
editorComp - Variable in class javax.swing.JTable
If editing, the Component that is handling the editing.
editorComponent - Variable in class javax.swing.DefaultCellEditor
The Swing component being edited.
EditorContainer() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
editorHasDifferentSize - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if the editor has a different size than the renderer.
EditorKit - Class in javax.swing.text
Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
EditorKit() - Constructor for class javax.swing.text.EditorKit
Construct an EditorKit.
edits - Variable in class javax.swing.undo.CompoundEdit
The collection of UndoableEdits undone/redone en masse by this CompoundEdit.
editToBeRedone() - Method in class javax.swing.undo.UndoManager
Returns the the next significant edit to be redone if redo is invoked.
editToBeUndone() - Method in class javax.swing.undo.UndoManager
Returns the the next significant edit to be undone if undo is invoked.
effective_profile() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the profile that will be used to send the request.
effective_target() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the actual object on which the operation will be invoked.
EFFORT - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to a single decimal digit, the packer will use the indicated amount of effort in compressing the archive.
EGYPTIAN_HIEROGLYPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Egyptian Hieroglyphs" Unicode character block.
element() - Method in exception java.lang.annotation.AnnotationTypeMismatchException
Returns the Method object for the incorrectly typed element.
element() - Method in class java.util.AbstractQueue
Retrieves, but does not remove, the head of this queue.
element() - Method in class java.util.ArrayDeque
Retrieves, but does not remove, the head of the queue represented by this deque.
element() - Method in interface java.util.concurrent.BlockingDeque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque).
element() - Method in class java.util.concurrent.ConcurrentLinkedDeque
element() - Method in class java.util.concurrent.LinkedBlockingDeque
Retrieves, but does not remove, the head of the queue represented by this deque.
element() - Method in interface java.util.Deque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque).
element() - Method in class java.util.LinkedList
Retrieves, but does not remove, the head (first element) of this list.
element() - Method in interface java.util.Queue
Retrieves, but does not remove, the head of this queue.
Element - Interface in javax.lang.model.element
Represents a program element such as a package, class, or method.
element - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
Element - Interface in javax.swing.text
Interface to describe a structural piece of a document.
Element - Class in javax.swing.text.html.parser
An element as described in a DTD using the ELEMENT construct.
Element - Interface in javax.xml.bind
This is an element marker interface.
element(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
Element - Interface in org.w3c.dom
The Element interface represents an element in an HTML or XML document.
ELEMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is an Element.
elementAt(int) - Method in class java.util.Vector
Returns the component at the specified index.
elementAt(int) - Method in class javax.swing.DefaultListModel
Returns the component at the specified index.
elementCount - Variable in class java.util.Vector
The number of valid components in this Vector object.
elementCount - Variable in class javax.management.monitor.Monitor
The number of valid components in the vector of observed objects.
elementCountToTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
elementData - Variable in class java.util.Vector
The array buffer into which the components of the vector are stored.
elementDecl(String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an element type declaration.
elementDecl(String, String) - Method in class org.xml.sax.ext.DefaultHandler2
ElementFilter - Class in javax.lang.model.util
Filters for selecting just the elements of interest from a collection of elements.
elementHash - Variable in class javax.swing.text.html.parser.DTD
ElementIterator - Class in javax.swing.text
ElementIterator, as the name suggests, iteratates over the Element tree.
ElementIterator(Document) - Constructor for class javax.swing.text.ElementIterator
Creates a new ElementIterator.
ElementIterator(Element) - Constructor for class javax.swing.text.ElementIterator
Creates a new ElementIterator.
ElementKind - Enum in javax.lang.model.element
The kind of an element.
ElementKindVisitor6<R,P> - Class in javax.lang.model.util
A visitor of program elements based on their kind with default behavior appropriate for the RELEASE_6 source version.
ElementKindVisitor6() - Constructor for class javax.lang.model.util.ElementKindVisitor6
Constructor for concrete subclasses; uses null for the default value.
ElementKindVisitor6(R) - Constructor for class javax.lang.model.util.ElementKindVisitor6
Constructor for concrete subclasses; uses the argument for the default value.
ElementKindVisitor7<R,P> - Class in javax.lang.model.util
A visitor of program elements based on their kind with default behavior appropriate for the RELEASE_7 source version.
ElementKindVisitor7() - Constructor for class javax.lang.model.util.ElementKindVisitor7
Constructor for concrete subclasses; uses null for the default value.
ElementKindVisitor7(R) - Constructor for class javax.lang.model.util.ElementKindVisitor7
Constructor for concrete subclasses; uses the argument for the default value.
elementName() - Method in exception java.lang.annotation.IncompleteAnnotationException
Returns the name of the missing element.
ElementNameAttribute - Static variable in class javax.swing.text.AbstractDocument
Name of the attribute used to specify element names.
elements() - Method in class java.security.PermissionCollection
Returns an enumeration of all the Permission objects in the collection.
elements() - Method in class java.security.Permissions
Returns an enumeration of all the Permission objects in all the PermissionCollections in this Permissions object.
elements() - Method in class java.security.Provider
elements() - Method in class java.util.concurrent.ConcurrentHashMap
Returns an enumeration of the values in this table.
elements() - Method in class java.util.Dictionary
Returns an enumeration of the values in this dictionary.
elements() - Method in class java.util.Hashtable
Returns an enumeration of the values in this hashtable.
elements() - Method in class java.util.Vector
Returns an enumeration of the components of this vector.
Elements - Interface in javax.lang.model.util
Utility methods for operating on program elements.
elements() - Method in class javax.swing.DefaultListModel
Returns an enumeration of the components of this list.
elements - Variable in class javax.swing.text.html.parser.DTD
ElementScanner6<R,P> - Class in javax.lang.model.util
A scanning visitor of program elements with default behavior appropriate for the RELEASE_6 source version.
ElementScanner6() - Constructor for class javax.lang.model.util.ElementScanner6
Constructor for concrete subclasses; uses null for the default value.
ElementScanner6(R) - Constructor for class javax.lang.model.util.ElementScanner6
Constructor for concrete subclasses; uses the argument for the default value.
ElementScanner7<R,P> - Class in javax.lang.model.util
A scanning visitor of program elements with default behavior appropriate for the RELEASE_7 source version.
ElementScanner7() - Constructor for class javax.lang.model.util.ElementScanner7
Constructor for concrete subclasses; uses null for the default value.
ElementScanner7(R) - Constructor for class javax.lang.model.util.ElementScanner7
Constructor for concrete subclasses; uses the argument for the default value.
ElementType - Enum in java.lang.annotation
A program element type.
ElementVisitor<R,P> - Interface in javax.lang.model.element
A visitor of program elements, in the style of the visitor design pattern.
Ellipse2D - Class in java.awt.geom
The Ellipse2D class describes an ellipse that is defined by a framing rectangle.
Ellipse2D() - Constructor for class java.awt.geom.Ellipse2D
This is an abstract class that cannot be instantiated directly.
Ellipse2D.Double - Class in java.awt.geom
The Double class defines an ellipse specified in double precision.
Ellipse2D.Double() - Constructor for class java.awt.geom.Ellipse2D.Double
Constructs a new Ellipse2D, initialized to location (0, 0) and size (0, 0).
Ellipse2D.Double(double, double, double, double) - Constructor for class java.awt.geom.Ellipse2D.Double
Constructs and initializes an Ellipse2D from the specified coordinates.
Ellipse2D.Float - Class in java.awt.geom
The Float class defines an ellipse specified in float precision.
Ellipse2D.Float() - Constructor for class java.awt.geom.Ellipse2D.Float
Constructs a new Ellipse2D, initialized to location (0, 0) and size (0, 0).
Ellipse2D.Float(float, float, float, float) - Constructor for class java.awt.geom.Ellipse2D.Float
Constructs and initializes an Ellipse2D from the specified coordinates.
EllipticCurve - Class in java.security.spec
This immutable class holds the necessary values needed to represent an elliptic curve.
EllipticCurve(ECField, BigInteger, BigInteger) - Constructor for class java.security.spec.EllipticCurve
Creates an elliptic curve with the specified elliptic field field and the coefficients a and b.
EllipticCurve(ECField, BigInteger, BigInteger, byte[]) - Constructor for class java.security.spec.EllipticCurve
Creates an elliptic curve with the specified elliptic field field, the coefficients a and b, and the seed used for curve generation.
EM - Static variable in class javax.swing.text.html.HTML.Tag
EMBEDDED_BY - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object is embedded in one or more objects.
EMBEDDED_BY_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the EMBEDDED_BY relation between two or more objects has changed.
EMBEDS - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object has one or more objects embedded in it.
EMBEDS_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the EMBEDS relation between two or more objects has changed.
EMOTICONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Emoticons" Unicode character block.
empty() - Method in class java.util.Stack
Tests if this stack is empty.
empty() - Method in class javax.swing.text.html.parser.ContentModel
Return true if the content model could match an empty input stream.
EMPTY - Static variable in interface javax.swing.text.html.parser.DTDConstants
EMPTY - Static variable in class javax.swing.text.SimpleAttributeSet
An empty attribute set.
EMPTY_DESCRIPTOR - Static variable in class javax.management.ImmutableDescriptor
An empty descriptor.
EMPTY_ENUMERATION - Static variable in class javax.swing.tree.DefaultMutableTreeNode
An enumeration that is always empty.
EMPTY_LIST - Static variable in class java.util.Collections
The empty list (immutable).
EMPTY_MAP - Static variable in class java.util.Collections
The empty map (immutable).
EMPTY_SET - Static variable in class java.util.Collections
The empty set (immutable).
EmptyBorder - Class in javax.swing.border
A class which provides an empty, transparent border which takes up space but does no drawing.
EmptyBorder(int, int, int, int) - Constructor for class javax.swing.border.EmptyBorder
Creates an empty border with the specified insets.
EmptyBorder(Insets) - Constructor for class javax.swing.border.EmptyBorder
Creates an empty border with the specified insets.
emptyEnumeration() - Static method in class java.util.Collections
Returns an enumeration that has no elements.
emptyIterator() - Static method in class java.util.Collections
Returns an iterator that has no elements.
emptyList() - Static method in class java.util.Collections
Returns the empty list (immutable).
emptyListIterator() - Static method in class java.util.Collections
Returns a list iterator that has no elements.
emptyMap() - Static method in class java.util.Collections
Returns the empty map (immutable).
emptySet() - Static method in class java.util.Collections
Returns the empty set (immutable).
EmptyStackException - Exception in java.util
Thrown by methods in the Stack class to indicate that the stack is empty.
EmptyStackException() - Constructor for exception java.util.EmptyStackException
Constructs a new EmptyStackException with null as its error message string.
emptyTag(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out all empty elements (all tags that have no corresponding end tag).
enable() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable(boolean) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable() - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable(boolean) - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable() - Static method in class java.lang.Compiler
Cause the Compiler to resume operation.
enable() - Method in class javax.swing.JComponent
Deprecated.
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
enableActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
enableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables all MBeanServerNotifications (all ObjectNames are selected).
enableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Enables all the attribute change notifications the attribute name of which equals the specified name to be sent to the listener.
enableClientWindowNotification(InputMethod, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Enables or disables notification of the current client window's location and state for the specified input method.
ENABLED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is enabled.
enabled - Variable in class javax.swing.AbstractAction
Specifies whether action is enabled; the default is true.
ENABLED - Static variable in class javax.swing.DefaultButtonModel
Identifies the "enabled" bit in the bitmask, which indicates that the button can be selected by an input device (such as a mouse pointer).
ENABLED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the component is enabled.
enabled - Variable in class javax.xml.ws.WebServiceFeature
Specifies if the feature is enabled or disabled
enableEvents(long) - Method in class java.awt.Component
Enables the events defined by the specified event mask parameter to be delivered to this component.
enableEvents(long) - Method in class java.awt.MenuItem
Enables event delivery to this menu item for events to be defined by the specified event mask parameter
enableInputMethods(boolean) - Method in class java.awt.Component
Enables or disables input method support for this component.
enableInputMethods(boolean) - Method in class java.awt.TextComponent
Enables or disables input method support for this text component.
enableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables MBeanServerNotifications concerning given ObjectName.
enableReplaceObject(boolean) - Method in class java.io.ObjectOutputStream
Enable the stream to do replacement of objects in the stream.
enableResizedPosting() - Method in class javax.swing.table.TableColumn
Deprecated.
as of Java 2 platform v1.3
enableResolveObject(boolean) - Method in class java.io.ObjectInputStream
Enable the stream to allow objects read from the stream to be replaced.
enableType(String) - Method in class javax.management.NotificationFilterSupport
Enables all the notifications the type of which starts with the specified prefix to be sent to the listener.
ENCLOSED_ALPHANUMERIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Alphanumeric Supplement" Unicode character block.
ENCLOSED_ALPHANUMERICS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Alphanumerics" Unicode character block.
ENCLOSED_CJK_LETTERS_AND_MONTHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed CJK Letters and Months" Unicode character block.
ENCLOSED_IDEOGRAPHIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Ideographic Supplement" Unicode character block.
ENCLOSING_MARK - Static variable in class java.lang.Character
General category "Me" in the Unicode specification.
encode(String) - Static method in class java.net.URLEncoder
Deprecated.
The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
encode(String, String) - Static method in class java.net.URLEncoder
Translates a string into application/x-www-form-urlencoded format using a specific encoding scheme.
encode(CharBuffer) - Method in class java.nio.charset.Charset
Convenience method that encodes Unicode characters into bytes in this charset.
encode(String) - Method in class java.nio.charset.Charset
Convenience method that encodes a string into bytes in this charset.
encode(CharBuffer, ByteBuffer, boolean) - Method in class java.nio.charset.CharsetEncoder
Encodes as many characters as possible from the given input buffer, writing the results to the given output buffer.
encode(CharBuffer) - Method in class java.nio.charset.CharsetEncoder
Convenience method that encodes the remaining content of a single input character buffer into a newly-allocated byte buffer.
encode(OutputStream) - Method in interface java.security.cert.Extension
Generates the extension's DER encoding and writes it to the output stream.
encode(OutputStream) - Method in interface java.security.Certificate
Deprecated.
Encodes the certificate to an output stream in a format that can be decoded by the decode method.
encode(Any) - Method in interface org.omg.IOP.CodecOperations
Converts the given any into a byte array based on the encoding format effective for this Codec.
encode_value(Any) - Method in interface org.omg.IOP.CodecOperations
Converts the given any into a byte array based on the encoding format effective for this Codec.
encodeDataFlavor(DataFlavor) - Static method in class java.awt.datatransfer.SystemFlavorMap
Encodes a DataFlavor for use as a String native.
EncodedKeySpec - Class in java.security.spec
This class represents a public or private key in encoded format.
EncodedKeySpec(byte[]) - Constructor for class java.security.spec.EncodedKeySpec
Creates a new EncodedKeySpec with the given encoded key.
encodedParams - Variable in class javax.crypto.SealedObject
The cryptographic parameters used by the sealing Cipher, encoded in the default format.
encodeJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Encodes a MIME type for use as a String native.
encodeLoop(CharBuffer, ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Encodes one or more characters into one or more bytes.
Encoder - Class in java.beans
An Encoder is a class which can be used to create files or streams that encode the state of a collection of JavaBeans in terms of their public APIs.
Encoder() - Constructor for class java.beans.Encoder
encoding - Variable in class javax.sound.sampled.AudioFormat
The audio encoding technique used by this format.
ENCODING - Static variable in class javax.xml.transform.OutputKeys
encoding = string.
Encoding - Class in org.omg.IOP
org/omg/IOP/Encoding.java .
Encoding() - Constructor for class org.omg.IOP.Encoding
Encoding(short, byte, byte) - Constructor for class org.omg.IOP.Encoding
ENCODING_CDR_ENCAPS - Interface in org.omg.IOP
org/omg/IOP/ENCODING_CDR_ENCAPS.java .
encodingSet() - Method in interface javax.xml.stream.events.StartDocument
Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
ENCRYPT - Static variable in class javax.xml.crypto.KeySelector.Purpose
A key for encrypting.
ENCRYPT_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to encryption mode.
EncryptedPrivateKeyInfo - Class in javax.crypto
This class implements the EncryptedPrivateKeyInfo type as defined in PKCS #8.
EncryptedPrivateKeyInfo(byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs (i.e., parses) an EncryptedPrivateKeyInfo from its ASN.1 encoding.
EncryptedPrivateKeyInfo(String, byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs an EncryptedPrivateKeyInfo from the encryption algorithm name and the encrypted data.
EncryptedPrivateKeyInfo(AlgorithmParameters, byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs an EncryptedPrivateKeyInfo from the encryption algorithm parameters and the encrypted data.
ENCTYPE - Static variable in class javax.swing.text.html.HTML.Attribute
END - Static variable in class java.awt.Event
The End key, a non-ASCII action key.
end() - Method in class java.awt.PrintJob
Ends the print job and does any necessary cleanup.
end(boolean) - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Marks the end of an I/O operation that might block indefinitely.
end() - Method in class java.nio.channels.spi.AbstractSelector
Marks the end of an I/O operation that might block indefinitely.
end() - Method in class java.util.regex.Matcher
Returns the offset after the last character matched.
end(int) - Method in class java.util.regex.Matcher
Returns the offset after the last character of the subsequence captured by the given group during the previous match operation.
end() - Method in interface java.util.regex.MatchResult
Returns the offset after the last character matched.
end(int) - Method in interface java.util.regex.MatchResult
Returns the offset after the last character of the subsequence captured by the given group during this match.
end() - Method in class java.util.zip.Deflater
Closes the compressor and discards any unprocessed input.
end() - Method in class java.util.zip.Inflater
Closes the decompressor and discards any unprocessed input.
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
Called when an end tag is seen for the type of tag this action was registered to.
end() - Method in class javax.swing.undo.CompoundEdit
Sets inProgress to false.
end() - Method in class javax.swing.undo.StateEdit
Gets the post-edit state of the StateEditable object and ends the edit.
end() - Method in class javax.swing.undo.UndoManager
Turns this UndoManager into a normal CompoundEdit.
end(Xid, int) - Method in interface javax.transaction.xa.XAResource
Ends the work performed on behalf of a transaction branch.
END_DOCUMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end document
END_ELEMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end element
END_OF_EXCLUSIVE - Static variable in class javax.sound.midi.ShortMessage
Status byte for End of System Exclusive message (0xF7, or 247).
END_PUNCTUATION - Static variable in class java.lang.Character
General category "Pe" in the Unicode specification.
end_value() - Method in interface org.omg.CORBA.portable.ValueInputStream
The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
end_value() - Method in interface org.omg.CORBA.portable.ValueOutputStream
The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
endAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of the document.
endCDATA() - Method in class org.xml.sax.ext.DefaultHandler2
endCDATA() - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of a CDATA section.
endComposition() - Method in class java.awt.im.InputContext
Ends any input composition that may currently be going on in this context.
endComposition() - Method in interface java.awt.im.spi.InputMethod
Ends any input composition that may currently be going on in this context.
EndDocument - Interface in javax.xml.stream.events
A marker interface for the end of the document
endDocument() - Method in interface org.xml.sax.ContentHandler
Receive notification of the end of a document.
endDocument() - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of the end of a document.
endDocument() - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of the end of the document.
endDocument() - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of the document.
endDocument() - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
endDocument() - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end document event.
endDocument() - Method in class org.xml.sax.helpers.XMLReaderAdapter
End document event.
endDraggingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
endDraggingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method signals the end of the dragging session.
endDTD() - Method in class org.xml.sax.ext.DefaultHandler2
endDTD() - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of DTD declarations.
EndElement - Interface in javax.xml.stream.events
An interface for the end element event.
endElement(String, String, String) - Method in interface org.xml.sax.ContentHandler
Receive notification of the end of an element.
endElement(String) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of the end of an element.
endElement(String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of the end of an element.
endElement(String, String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of an element.
endElement(String) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
endElement(String, String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end element event.
endElement(String, String, String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 end element event.
endEntity(String) - Method in class org.xml.sax.ext.DefaultHandler2
endEntity(String) - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of an entity.
endFontTag() - Method in class javax.swing.text.html.MinimalHTMLWriter
This is no longer used, instead <span> will be written out.
endIndex - Variable in class javax.accessibility.AccessibleAttributeSequence
The end index of the text sequence
endIndex - Variable in class javax.accessibility.AccessibleTextSequence
The end index of the text sequence
endInsertEmpty() - Method in class javax.imageio.ImageWriter
Completes the insertion of a new image that was begun with a prior call to prepareInsertEmpty.
endKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
endLineAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a line.
EndOfLineStringProperty - Static variable in class javax.swing.text.DefaultEditorKit
When reading a document if a CRLF is encountered a property with this name is added and the value will be "\r\n".
endParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a paragraph.
Endpoint - Class in javax.xml.ws
A Web service endpoint.
Endpoint() - Constructor for class javax.xml.ws.Endpoint
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider
Standard property: Target service endpoint address.
EndpointContext - Class in javax.xml.ws
EndpointContext allows multiple endpoints in an application to share any information.
EndpointContext() - Constructor for class javax.xml.ws.EndpointContext
endpointName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
EndpointReference - Class in javax.xml.ws
This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
EndpointReference() - Constructor for class javax.xml.ws.EndpointReference
endPrefixMapping(String) - Method in interface org.xml.sax.ContentHandler
End the scope of a prefix-URI mapping.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of a Namespace mapping.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end Namespace prefix mapping event.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 end prefix mapping event.
endReplacePixels() - Method in class javax.imageio.ImageWriter
Terminates a sequence of calls to replacePixels.
endResizingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
endResizingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method signals the end of the resize session.
endsWith(String) - Method in class java.lang.String
Tests if this string ends with the specified suffix.
endsWith(Path) - Method in interface java.nio.file.Path
Tests if this path ends with the given path.
endsWith(String) - Method in interface java.nio.file.Path
Tests if this path ends with a Path, constructed by converting the given path string, in exactly the manner specified by the endsWith(Path) method.
endsWith(Name) - Method in class javax.naming.CompositeName
Determines whether a composite name is a suffix of this composite name.
endsWith(Name) - Method in class javax.naming.CompoundName
Determines whether a compound name is a suffix of this compound name.
endsWith(Name) - Method in class javax.naming.ldap.LdapName
Determines whether this LDAP name ends with a specified LDAP name suffix.
endsWith(List<Rdn>) - Method in class javax.naming.ldap.LdapName
Determines whether the specified RDN sequence forms a suffix of this LDAP name.
endsWith(Name) - Method in interface javax.naming.Name
Determines whether this name ends with a specified suffix.
ENDTAG - Static variable in class javax.swing.text.html.HTML.Attribute
endTag(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out an end tag for the element.
ENDTAG - Static variable in interface javax.swing.text.html.parser.DTDConstants
endTag(boolean) - Method in class javax.swing.text.html.parser.Parser
Handle an end tag.
EndTagType - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getType.
endUpdate() - Method in class javax.swing.undo.UndoableEditSupport
DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
endWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a word.
endWriteEmpty() - Method in class javax.imageio.ImageWriter
Completes the writing of a new image that was begun with a prior call to prepareWriteEmpty.
endWriteSequence() - Method in class javax.imageio.ImageWriter
Completes the writing of a sequence of images begun with prepareWriteSequence.
ENGINE - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that is the name of the ScriptEngine implementation.
ENGINE_SCOPE - Static variable in interface javax.script.ScriptContext
EngineScope attributes are visible during the lifetime of a single ScriptEngine and a set of attributes is maintained for each engine.
ENGINE_VERSION - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that identifies the version of the ScriptEngine implementation.
engineAliases() - Method in class java.security.KeyStoreSpi
Lists all the alias names of this keystore.
engineBuild(CertPathParameters) - Method in class java.security.cert.CertPathBuilderSpi
Attempts to build a certification path using the specified algorithm parameter set.
engineContainsAlias(String) - Method in class java.security.KeyStoreSpi
Checks if the given alias exists in this keystore.
engineCreateSSLEngine() - Method in class javax.net.ssl.SSLContextSpi
Creates a new SSLEngine using this context.
engineCreateSSLEngine(String, int) - Method in class javax.net.ssl.SSLContextSpi
Creates a SSLEngine using this context.
engineDeleteEntry(String) - Method in class java.security.KeyStoreSpi
Deletes the entry identified by the given alias from this keystore.
engineDigest() - Method in class java.security.MessageDigestSpi
Completes the hash computation by performing final operations such as padding.
engineDigest(byte[], int, int) - Method in class java.security.MessageDigestSpi
Completes the hash computation by performing final operations such as padding.
engineDoFinal(byte[], int, int) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal(byte[], int, int, byte[], int) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal() - Method in class javax.crypto.MacSpi
Completes the MAC computation and resets the MAC for further use, maintaining the secret key that the MAC was initialized with.
engineDoPhase(Key, boolean) - Method in class javax.crypto.KeyAgreementSpi
Executes the next phase of this key agreement with the given key that was received from one of the other parties involved in this key agreement.
engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security.KeyStoreSpi
Determines if the keystore Entry for the specified alias is an instance or subclass of the specified entryClass.
engineGenerateCertificate(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a certificate object and initializes it with the data read from the input stream inStream.
engineGenerateCertificates(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Returns a (possibly empty) collection view of the certificates read from the given input stream inStream.
engineGenerateCertPath(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with the data read from the InputStream inStream.
engineGenerateCertPath(InputStream, String) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with the data read from the InputStream inStream.
engineGenerateCertPath(List<? extends Certificate>) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with a List of Certificates.
engineGenerateCRL(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a certificate revocation list (CRL) object and initializes it with the data read from the input stream inStream.
engineGenerateCRLs(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Returns a (possibly empty) collection view of the CRLs read from the given input stream inStream.
engineGenerateKey() - Method in class javax.crypto.KeyGeneratorSpi
Generates a secret key.
engineGenerateParameters() - Method in class java.security.AlgorithmParameterGeneratorSpi
Generates the parameters.
engineGeneratePrivate(KeySpec) - Method in class java.security.KeyFactorySpi
Generates a private key object from the provided key specification (key material).
engineGeneratePublic(KeySpec) - Method in class java.security.KeyFactorySpi
Generates a public key object from the provided key specification (key material).
engineGenerateSecret() - Method in class javax.crypto.KeyAgreementSpi
Generates the shared secret and returns it in a new buffer.
engineGenerateSecret(byte[], int) - Method in class javax.crypto.KeyAgreementSpi
Generates the shared secret, and places it into the buffer sharedSecret, beginning at offset inclusive.
engineGenerateSecret(String) - Method in class javax.crypto.KeyAgreementSpi
Creates the shared secret and returns it as a secret key object of the requested algorithm type.
engineGenerateSecret(KeySpec) - Method in class javax.crypto.SecretKeyFactorySpi
Generates a SecretKey object from the provided key specification (key material).
engineGenerateSeed(int) - Method in class java.security.SecureRandomSpi
Returns the given number of seed bytes.
engineGenExemptionBlob() - Method in class javax.crypto.ExemptionMechanismSpi
Generates the exemption mechanism key blob.
engineGenExemptionBlob(byte[], int) - Method in class javax.crypto.ExemptionMechanismSpi
Generates the exemption mechanism key blob, and stores the result in the output buffer, starting at outputOffset inclusive.
engineGetAppConfigurationEntry(String) - Method in class javax.security.auth.login.ConfigurationSpi
Retrieve the AppConfigurationEntries for the specified name.
engineGetBlockSize() - Method in class javax.crypto.CipherSpi
Returns the block size (in bytes).
engineGetCertificate(String) - Method in class java.security.KeyStoreSpi
Returns the certificate associated with the given alias.
engineGetCertificateAlias(Certificate) - Method in class java.security.KeyStoreSpi
Returns the (alias) name of the first keystore entry whose certificate matches the given certificate.
engineGetCertificateChain(String) - Method in class java.security.KeyStoreSpi
Returns the certificate chain associated with the given alias.
engineGetCertificates(CertSelector) - Method in class java.security.cert.CertStoreSpi
Returns a Collection of Certificates that match the specified selector.
engineGetCertPathEncodings() - Method in class java.security.cert.CertificateFactorySpi
Returns an iteration of the CertPath encodings supported by this certificate factory, with the default encoding first.
engineGetClientSessionContext() - Method in class javax.net.ssl.SSLContextSpi
Returns a client SSLSessionContext object for this context.
engineGetCreationDate(String) - Method in class java.security.KeyStoreSpi
Returns the creation date of the entry identified by the given alias.
engineGetCRLs(CRLSelector) - Method in class java.security.cert.CertStoreSpi
Returns a Collection of CRLs that match the specified selector.
engineGetDefaultSSLParameters() - Method in class javax.net.ssl.SSLContextSpi
Returns a copy of the SSLParameters indicating the default settings for this SSL context.
engineGetDigestLength() - Method in class java.security.MessageDigestSpi
Returns the digest length in bytes.
engineGetEncoded() - Method in class java.security.AlgorithmParametersSpi
Returns the parameters in their primary encoding format.
engineGetEncoded(String) - Method in class java.security.AlgorithmParametersSpi
Returns the parameters encoded in the specified format.
engineGetEntry(String, KeyStore.ProtectionParameter) - Method in class java.security.KeyStoreSpi
Gets a KeyStore.Entry for the specified alias with the specified protection parameter.
engineGetIV() - Method in class javax.crypto.CipherSpi
Returns the initialization vector (IV) in a new buffer.
engineGetKey(String, char[]) - Method in class java.security.KeyStoreSpi
Returns the key associated with the given alias, using the given password to recover it.
engineGetKeyManagers() - Method in class javax.net.ssl.KeyManagerFactorySpi
Returns one key manager for each type of key material.
engineGetKeySize(Key) - Method in class javax.crypto.CipherSpi
Returns the key size of the given key object in bits.
engineGetKeySpec(Key, Class<T>) - Method in class java.security.KeyFactorySpi
Returns a specification (key material) of the given key object.
engineGetKeySpec(SecretKey, Class) - Method in class javax.crypto.SecretKeyFactorySpi
Returns a specification (key material) of the given key object in the requested format.
engineGetMacLength() - Method in class javax.crypto.MacSpi
Returns the length of the MAC in bytes.
engineGetOutputSize(int) - Method in class javax.crypto.CipherSpi
Returns the length in bytes that an output buffer would need to be in order to hold the result of the next update or doFinal operation, given the input length inputLen (in bytes).
engineGetOutputSize(int) - Method in class javax.crypto.ExemptionMechanismSpi
Returns the length in bytes that an output buffer would need to be in order to hold the result of the next engineGenExemptionBlob operation, given the input length inputLen (in bytes).
engineGetParameter(String) - Method in class java.security.SignatureSpi
Deprecated.
engineGetParameters() - Method in class java.security.SignatureSpi
This method is overridden by providers to return the parameters used with this signature engine, or null if this signature engine does not use any parameters.
engineGetParameters() - Method in class javax.crypto.CipherSpi
Returns the parameters used with this cipher.
engineGetParameterSpec(Class<T>) - Method in class java.security.AlgorithmParametersSpi
Returns a (transparent) specification of this parameters object.
engineGetPermissions(CodeSource) - Method in class java.security.PolicySpi
Return a PermissionCollection object containing the set of permissions granted to the specified CodeSource.
engineGetPermissions(ProtectionDomain) - Method in class java.security.PolicySpi
Return a PermissionCollection object containing the set of permissions granted to the specified ProtectionDomain.
engineGetServerSessionContext() - Method in class javax.net.ssl.SSLContextSpi
Returns a server SSLSessionContext object for this context.
engineGetServerSocketFactory() - Method in class javax.net.ssl.SSLContextSpi
Returns a ServerSocketFactory object for this context.
engineGetSocketFactory() - Method in class javax.net.ssl.SSLContextSpi
Returns a SocketFactory object for this context.
engineGetSupportedSSLParameters() - Method in class javax.net.ssl.SSLContextSpi
Returns a copy of the SSLParameters indicating the maximum supported settings for this SSL context.
engineGetTrustManagers() - Method in class javax.net.ssl.TrustManagerFactorySpi
Returns one trust manager for each type of trust material.
engineImplies(ProtectionDomain, Permission) - Method in class java.security.PolicySpi
Check whether the policy has granted a Permission to a ProtectionDomain.
engineInit(int, SecureRandom) - Method in class java.security.AlgorithmParameterGeneratorSpi
Initializes this parameter generator for a certain size and source of randomness.
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.AlgorithmParameterGeneratorSpi
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
engineInit(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParametersSpi
Initializes this parameters object using the parameters specified in paramSpec.
engineInit(byte[]) - Method in class java.security.AlgorithmParametersSpi
Imports the specified parameters and decodes them according to the primary decoding format for parameters.
engineInit(byte[], String) - Method in class java.security.AlgorithmParametersSpi
Imports the parameters from params and decodes them according to the specified decoding format.
engineInit(int, Key, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key and a source of randomness.
engineInit(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
engineInit(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
engineInit(Key) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key.
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key and a set of algorithm parameters.
engineInit(Key, AlgorithmParameters) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key and a set of algorithm parameters.
engineInit(Key, SecureRandom) - Method in class javax.crypto.KeyAgreementSpi
Initializes this key agreement with the given key and source of randomness.
engineInit(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyAgreementSpi
Initializes this key agreement with the given key, set of algorithm parameters, and source of randomness.
engineInit(SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes the key generator.
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes the key generator with the specified parameter set and a user-provided source of randomness.
engineInit(int, SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes this key generator for a certain keysize, using the given source of randomness.
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto.MacSpi
Initializes the MAC with the given (secret) key and algorithm parameters.
engineInit(KeyStore, char[]) - Method in class javax.net.ssl.KeyManagerFactorySpi
Initializes this factory with a source of key material.
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl.KeyManagerFactorySpi
Initializes this factory with a source of key material.
engineInit(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl.SSLContextSpi
Initializes this context.
engineInit(KeyStore) - Method in class javax.net.ssl.TrustManagerFactorySpi
Initializes this factory with a source of certificate authorities and related trust material.
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl.TrustManagerFactorySpi
Initializes this factory with a source of provider-specific key material.
engineInitSign(PrivateKey) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified private key for signing operations.
engineInitSign(PrivateKey, SecureRandom) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified private key and source of randomness for signing operations.
engineInitVerify(PublicKey) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified public key for verification operations.
engineIsCertificateEntry(String) - Method in class java.security.KeyStoreSpi
Returns true if the entry identified by the given alias was created by a call to setCertificateEntry, or created by a call to setEntry with a TrustedCertificateEntry.
engineIsKeyEntry(String) - Method in class java.security.KeyStoreSpi
Returns true if the entry identified by the given alias was created by a call to setKeyEntry, or created by a call to setEntry with a PrivateKeyEntry or a SecretKeyEntry.
engineLoad(InputStream, char[]) - Method in class java.security.KeyStoreSpi
Loads the keystore from the given input stream.
engineLoad(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStoreSpi
Loads the keystore using the given KeyStore.LoadStoreParameter.
engineNextBytes(byte[]) - Method in class java.security.SecureRandomSpi
Generates a user-specified number of random bytes.
engineRefresh() - Method in class java.security.PolicySpi
Refreshes/reloads the policy configuration.
engineRefresh() - Method in class javax.security.auth.login.ConfigurationSpi
Refresh and reload the Configuration.
engineReset() - Method in class java.security.MessageDigestSpi
Resets the digest for further use.
engineReset() - Method in class javax.crypto.MacSpi
Resets the MAC for further use, maintaining the secret key that the MAC was initialized with.
engineScope - Variable in class javax.script.SimpleScriptContext
This is the engine scope bindings.
engineSetCertificateEntry(String, Certificate) - Method in class java.security.KeyStoreSpi
Assigns the given certificate to the given alias.
engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - Method in class java.security.KeyStoreSpi
Saves a KeyStore.Entry under the specified alias.
engineSetKeyEntry(String, Key, char[], Certificate[]) - Method in class java.security.KeyStoreSpi
Assigns the given key to the given alias, protecting it with the given password.
engineSetKeyEntry(String, byte[], Certificate[]) - Method in class java.security.KeyStoreSpi
Assigns the given key (that has already been protected) to the given alias.
engineSetMode(String) - Method in class javax.crypto.CipherSpi
Sets the mode of this cipher.
engineSetPadding(String) - Method in class javax.crypto.CipherSpi
Sets the padding mechanism of this cipher.
engineSetParameter(String, Object) - Method in class java.security.SignatureSpi
Deprecated.
Replaced by engineSetParameter.
engineSetParameter(AlgorithmParameterSpec) - Method in class java.security.SignatureSpi
This method is overridden by providers to initialize this signature engine with the specified parameter set.
engineSetSeed(byte[]) - Method in class java.security.SecureRandomSpi
Reseeds this random object.
engineSign() - Method in class java.security.SignatureSpi
Returns the signature bytes of all the data updated so far.
engineSign(byte[], int, int) - Method in class java.security.SignatureSpi
Finishes this signature operation and stores the resulting signature bytes in the provided buffer outbuf, starting at offset.
engineSize() - Method in class java.security.KeyStoreSpi
Retrieves the number of entries in this keystore.
engineStore(OutputStream, char[]) - Method in class java.security.KeyStoreSpi
Stores this keystore to the given output stream, and protects its integrity with the given password.
engineStore(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStoreSpi
Stores this keystore using the given KeyStore.LoadStoreParmeter.
engineToString() - Method in class java.security.AlgorithmParametersSpi
Returns a formatted string describing the parameters.
engineTranslateKey(Key) - Method in class java.security.KeyFactorySpi
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this key factory.
engineTranslateKey(SecretKey) - Method in class javax.crypto.SecretKeyFactorySpi
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this secret-key factory.
engineUnwrap(byte[], String, int) - Method in class javax.crypto.CipherSpi
Unwrap a previously wrapped key.
engineUpdate(byte) - Method in class java.security.MessageDigestSpi
Updates the digest using the specified byte.
engineUpdate(byte[], int, int) - Method in class java.security.MessageDigestSpi
Updates the digest using the specified array of bytes, starting at the specified offset.
engineUpdate(ByteBuffer) - Method in class java.security.MessageDigestSpi
Update the digest using the specified ByteBuffer.
engineUpdate(byte) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified using the specified byte.
engineUpdate(byte[], int, int) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified, using the specified array of bytes, starting at the specified offset.
engineUpdate(ByteBuffer) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified using the specified ByteBuffer.
engineUpdate(byte[], int, int) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(byte[], int, int, byte[], int) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(ByteBuffer, ByteBuffer) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(byte) - Method in class javax.crypto.MacSpi
Processes the given byte.
engineUpdate(byte[], int, int) - Method in class javax.crypto.MacSpi
Processes the first len bytes in input, starting at offset inclusive.
engineUpdate(ByteBuffer) - Method in class javax.crypto.MacSpi
Processes input.remaining() bytes in the ByteBuffer input, starting at input.position().
engineValidate(CertPath, CertPathParameters) - Method in class java.security.cert.CertPathValidatorSpi
Validates the specified certification path using the specified algorithm parameter set.
engineVerify(byte[]) - Method in class java.security.SignatureSpi
Verifies the passed-in signature.
engineVerify(byte[], int, int) - Method in class java.security.SignatureSpi
Verifies the passed-in signature in the specified array of bytes, starting at the specified offset.
engineWrap(Key) - Method in class javax.crypto.CipherSpi
Wrap a key.
ENGLISH - Static variable in class java.util.Locale
Useful constant for language.
enqueue() - Method in class java.lang.ref.Reference
Adds this reference object to the queue with which it is registered, if any.
enqueueKeyEvents(long, Component) - Method in class java.awt.DefaultKeyboardFocusManager
Delays dispatching of KeyEvents until the specified Component becomes the focus owner.
enqueueKeyEvents(long, Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should delay dispatching of KeyEvents until the specified Component becomes the focus owner.
ensureCapacity(int) - Method in class java.lang.StringBuffer
ensureCapacity(int) - Method in class java.util.ArrayList
Increases the capacity of this ArrayList instance, if necessary, to ensure that it can hold at least the number of elements specified by the minimum capacity argument.
ensureCapacity(int) - Method in class java.util.Vector
Increases the capacity of this vector, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
ensureCapacity(int) - Method in class javax.swing.DefaultListModel
Increases the capacity of this list, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
ensureFileIsVisible(File) - Method in class javax.swing.JFileChooser
Makes sure that the specified file is viewable, and not hidden.
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.FileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the ensureFileIsVisible method on each UI handled by this object.
ensureIndexIsVisible(int) - Method in class javax.swing.JList
Scrolls the list within an enclosing viewport to make the specified cell completely visible.
ensureRowsAreVisible(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Ensures that the rows identified by beginRow through endRow are visible.
ENTER - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the Cursor has entered a DropTarget.
ENTER - Static variable in class java.awt.Event
The Enter key.
enter() - Method in interface java.awt.SecondaryLoop
Blocks the execution of the current thread and enters a new secondary event loop on the event dispatch thread.
ENTERED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Entered type.
entering(String, String) - Method in class java.util.logging.Logger
Log a method entry.
entering(String, String, Object) - Method in class java.util.logging.Logger
Log a method entry, with one parameter.
entering(String, String, Object[]) - Method in class java.util.logging.Logger
Log a method entry, with an array of parameters.
ENTITIES - Static variable in interface javax.swing.text.html.parser.DTDConstants
ENTITY - Static variable in interface javax.swing.text.html.parser.DTDConstants
Entity - Class in javax.swing.text.html.parser
An entity is described in a DTD using the ENTITY construct.
Entity(String, int, char[]) - Constructor for class javax.swing.text.html.parser.Entity
Creates an entity.
Entity - Interface in org.w3c.dom
This interface represents a known entity, either parsed or unparsed, in an XML document.
ENTITY_DECLARATION - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates a Entity Declaration
ENTITY_NODE - Static variable in interface org.w3c.dom.Node
The node is an Entity.
ENTITY_REFERENCE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an entity reference
ENTITY_REFERENCE_NODE - Static variable in interface org.w3c.dom.Node
The node is an EntityReference.
EntityDeclaration - Interface in javax.xml.stream.events
An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
entityHash - Variable in class javax.swing.text.html.parser.DTD
EntityReference - Interface in javax.xml.stream.events
An interface for handling Entity events.
EntityReference - Interface in org.w3c.dom
EntityReference nodes may be used to represent an entity reference in the tree.
EntityResolver - Interface in org.xml.sax
Basic interface for resolving entities.
EntityResolver2 - Interface in org.xml.sax.ext
Extended interface for mapping external entity references to input sources, or providing a missing external subset.
entries() - Method in interface java.security.acl.Acl
Returns an enumeration of the entries in this ACL.
entries() - Method in class java.util.jar.JarFile
Returns an enumeration of the zip file entries.
entries() - Method in class java.util.zip.ZipFile
Returns an enumeration of the ZIP file entries.
ENTRY_CREATE - Static variable in class java.nio.file.StandardWatchEventKind
Directory entry created.
ENTRY_DELETE - Static variable in class java.nio.file.StandardWatchEventKind
Directory entry deleted.
ENTRY_MODIFY - Static variable in class java.nio.file.StandardWatchEventKind
Directory entry modified.
entryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security.KeyStore
Determines if the keystore Entry for the specified alias is an instance or subclass of the specified entryClass.
entrySet() - Method in class java.awt.RenderingHints
Returns a Set view of the mappings contained in this RenderingHints.
entrySet() - Method in class java.security.Provider
Returns an unmodifiable Set view of the property entries contained in this Provider.
entrySet() - Method in class java.util.AbstractMap
entrySet() - Method in class java.util.concurrent.ConcurrentHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.EnumMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.HashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.Hashtable
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.IdentityHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.jar.Attributes
Returns a Collection view of the attribute name-value mappings contained in this Map.
entrySet() - Method in interface java.util.Map
Returns a Set view of the mappings contained in this map.
entrySet() - Method in interface java.util.SortedMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.TreeMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.WeakHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class javax.management.openmbean.TabularDataSupport
Returns a collection view of the index to row mappings contained in this TabularDataSupport instance.
entrySet() - Method in class javax.script.SimpleBindings
Returns a Set view of the mappings contained in this map.
Enum<E extends Enum<E>> - Class in java.lang
This is the common base class of all Java language enumeration types.
Enum(String, int) - Constructor for class java.lang.Enum
Sole constructor.
EnumConstantNotPresentException - Exception in java.lang
Thrown when an application tries to access an enum constant by name and the enum type contains no constant with the specified name.
EnumConstantNotPresentException(Class<? extends Enum>, String) - Constructor for exception java.lang.EnumConstantNotPresentException
Constructs an EnumConstantNotPresentException for the specified constant.
EnumControl - Class in javax.sound.sampled
A EnumControl provides control over a set of discrete possible values, each represented by an object.
EnumControl(EnumControl.Type, Object[], Object) - Constructor for class javax.sound.sampled.EnumControl
Constructs a new enumerated control object with the given parameters.
EnumControl.Type - Class in javax.sound.sampled
An instance of the EnumControl.Type inner class identifies one kind of enumerated control.
EnumControl.Type(String) - Constructor for class javax.sound.sampled.EnumControl.Type
Constructs a new enumerated control type.
enumerate(Thread[]) - Static method in class java.lang.Thread
Copies into the specified array every active thread in the current thread's thread group and its subgroups.
enumerate(Thread[]) - Method in class java.lang.ThreadGroup
Copies into the specified array every active thread in this thread group and its subgroups.
enumerate(Thread[], boolean) - Method in class java.lang.ThreadGroup
Copies into the specified array every active thread in this thread group.
enumerate(ThreadGroup[]) - Method in class java.lang.ThreadGroup
Copies into the specified array references to every active subgroup in this thread group and its subgroups.
enumerate(ThreadGroup[], boolean) - Method in class java.lang.ThreadGroup
Copies into the specified array references to every active subgroup in this thread group.
enumeration(Collection<T>) - Static method in class java.util.Collections
Returns an enumeration over the specified collection.
Enumeration<E> - Interface in java.util
An object that implements the Enumeration interface generates a series of elements, one at a time.
EnumMap<K extends Enum<K>,V> - Class in java.util
A specialized Map implementation for use with enum type keys.
EnumMap(Class<K>) - Constructor for class java.util.EnumMap
Creates an empty enum map with the specified key type.
EnumMap(EnumMap<K, ? extends V>) - Constructor for class java.util.EnumMap
Creates an enum map with the same key type as the specified enum map, initially containing the same mappings (if any).
EnumMap(Map<K, ? extends V>) - Constructor for class java.util.EnumMap
Creates an enum map initialized from the specified map.
EnumSet<E extends Enum<E>> - Class in java.util
A specialized Set implementation for use with enum types.
EnumSyntax - Class in javax.print.attribute
Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects.
EnumSyntax(int) - Constructor for class javax.print.attribute.EnumSyntax
Construct a new enumeration value with the given integer value.
enumType() - Method in exception java.lang.EnumConstantNotPresentException
Returns the type of the missing enum constant.
env() - Method in class org.omg.CORBA.Request
Retrieves the Environment object for this request.
ENV_10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_10_ENVELOPE.
ENV_10X13 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X13_ENVELOPE.
ENV_10X14 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X14_ENVELOPE.
ENV_10X15 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X15_ENVELOPE.
ENV_11 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_11_ENVELOPE.
ENV_12 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_12_ENVELOPE.
ENV_14 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_14_ENVELOPE.
ENV_6X9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_6X9_ENVELOPE.
ENV_7X9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_7X9_ENVELOPE.
ENV_9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_9_ENVELOPE.
ENV_9X11 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_9X11_ENVELOPE.
ENV_9X12 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_9X12_ENVELOPE.
ENV_INVITE - Static variable in class java.awt.PageAttributes.MediaType
An alias for INVITE_ENVELOPE.
ENV_ITALY - Static variable in class java.awt.PageAttributes.MediaType
An alias for ITALY_ENVELOPE.
ENV_MONARCH - Static variable in class java.awt.PageAttributes.MediaType
An alias for MONARCH_ENVELOPE.
ENV_PERSONAL - Static variable in class java.awt.PageAttributes.MediaType
An alias for PERSONAL_ENVELOPE.
ENVELOPE - Static variable in class javax.print.attribute.standard.MediaTray
The envelope input tray in the printer.
ENVELOPED - Static variable in interface javax.xml.crypto.dsig.Transform
The Enveloped Signature transform algorithm URI.
environment() - Method in class java.lang.ProcessBuilder
Returns a string map view of this process builder's environment.
environment - Variable in exception javax.naming.CannotProceedException
Contains the environment relevant for the Context or DirContext method that cannot proceed.
Environment - Class in org.omg.CORBA
A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
Environment() - Constructor for class org.omg.CORBA.Environment
eof - Variable in exception java.io.OptionalDataException
True if there is no more data in the buffered part of the stream.
EOFException - Exception in java.io
Signals that an end of file or end of stream has been reached unexpectedly during input.
EOFException() - Constructor for exception java.io.EOFException
Constructs an EOFException with null as its error detail message.
EOFException(String) - Constructor for exception java.io.EOFException
Constructs an EOFException with the specified detail message.
eolIsSignificant(boolean) - Method in class java.io.StreamTokenizer
Determines whether or not ends of line are treated as tokens.
eos - Variable in class java.util.zip.GZIPInputStream
Indicates end of input stream.
EQ - Static variable in class javax.management.Query
A code representing the Query.eq(javax.management.ValueExp, javax.management.ValueExp) query.
eq(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents an equality constraint on two values.
EQUAL - Static variable in class javax.xml.datatype.DatatypeConstants
Comparison result.
equal(Any) - Method in class org.omg.CORBA.Any
Checks for equality between this Any object and the given Any object.
equal(TypeCode) - Method in class org.omg.CORBA.TypeCode
Compares this TypeCode object with the given one, testing for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Compares two DynAny values for equality.
equal(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Compares two DynAny values for equality.
equals(Object) - Method in class java.awt.AlphaComposite
Determines whether the specified object is equal to this AlphaComposite.
equals(Object) - Method in class java.awt.AWTKeyStroke
Returns true if this object is identical to the specified object.
equals(Object) - Method in class java.awt.BasicStroke
Tests if a specified object is equal to this BasicStroke by first testing if it is a BasicStroke and then comparing its width, join, cap, miter limit, dash, and dash phase attributes with those of this BasicStroke.
equals(Object) - Method in class java.awt.Color
Determines whether another object is equal to this Color.
equals(Object) - Method in class java.awt.datatransfer.DataFlavor
Indicates whether some other object is "equal to" this one.
equals(DataFlavor) - Method in class java.awt.datatransfer.DataFlavor
This method has the same behavior as DataFlavor.equals(Object).
equals(String) - Method in class java.awt.datatransfer.DataFlavor
Deprecated.
As inconsistent with hashCode() contract, use isMimeTypeEqual(String) instead.
equals(Object) - Method in class java.awt.Dimension
Checks whether two dimension objects have equal values.
equals(DisplayMode) - Method in class java.awt.DisplayMode
Returns whether the two display modes are equal.
equals(Object) - Method in class java.awt.DisplayMode
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class java.awt.Font
Compares this Font object to the specified Object.
equals(Object) - Method in class java.awt.font.FontRenderContext
Return true if obj is an instance of FontRenderContext and has the same transform, antialiasing, and fractional metrics values as this.
equals(FontRenderContext) - Method in class java.awt.font.FontRenderContext
Return true if rhs has the same transform, antialiasing, and fractional metrics values as this.
equals(GlyphVector) - Method in class java.awt.font.GlyphVector
Tests if the specified GlyphVector exactly equals this GlyphVector.
equals(Object) - Method in class java.awt.font.ImageGraphicAttribute
Compares this ImageGraphicAttribute to the specified Object.
equals(ImageGraphicAttribute) - Method in class java.awt.font.ImageGraphicAttribute
Compares this ImageGraphicAttribute to the specified ImageGraphicAttribute.
equals(Object) - Method in class java.awt.font.NumericShaper
Returns true if the specified object is an instance of NumericShaper and shapes identically to this one, regardless of the range representations, the bit mask or the enum.
equals(Object) - Method in class java.awt.font.ShapeGraphicAttribute
Compares this ShapeGraphicAttribute to the specified Object.
equals(ShapeGraphicAttribute) - Method in class java.awt.font.ShapeGraphicAttribute
Compares this ShapeGraphicAttribute to the specified ShapeGraphicAttribute.
equals(Object) - Method in class java.awt.font.TextHitInfo
Returns true if the specified Object is a TextHitInfo and equals this TextHitInfo.
equals(TextHitInfo) - Method in class java.awt.font.TextHitInfo
Returns true if the specified TextHitInfo has the same charIndex and isLeadingEdge as this TextHitInfo.
equals(Object) - Method in class java.awt.font.TextLayout
Returns true if the specified Object is a TextLayout object and if the specified Object equals this TextLayout.
equals(TextLayout) - Method in class java.awt.font.TextLayout
Returns true if the two layouts are equal.
equals(Object) - Method in class java.awt.font.TransformAttribute
Returns true if rhs is a TransformAttribute whose transform is equal to this TransformAttribute's transform.
equals(Object) - Method in class java.awt.geom.AffineTransform
Returns true if this AffineTransform represents the same affine coordinate transform as the specified argument.
equals(Object) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified Object is equal to this Arc2D.
equals(Area) - Method in class java.awt.geom.Area
Tests whether the geometries of the two Area objects are equal.
equals(Object) - Method in class java.awt.geom.Ellipse2D
Determines whether or not the specified Object is equal to this Ellipse2D.
equals(Object) - Method in class java.awt.geom.Point2D
Determines whether or not two points are equal.
equals(Object) - Method in class java.awt.geom.Rectangle2D
Determines whether or not the specified Object is equal to this Rectangle2D.
equals(Object) - Method in class java.awt.geom.RoundRectangle2D
Determines whether or not the specified Object is equal to this RoundRectangle2D.
equals(Object) - Method in class java.awt.image.ColorModel
Tests if the specified Object is an instance of ColorModel and if it equals this ColorModel.
equals(Object) - Method in class java.awt.image.ComponentColorModel
Compares this color model with another for equality.
equals(Object) - Method in class java.awt.image.ComponentSampleModel
equals(Object) - Method in class java.awt.image.MultiPixelPackedSampleModel
equals(Object) - Method in class java.awt.image.PackedColorModel
Tests if the specified Object is an instance of PackedColorModel and equals this PackedColorModel.
equals(Object) - Method in class java.awt.image.SinglePixelPackedSampleModel
equals(Object) - Method in class java.awt.Insets
Checks whether two insets objects are equal.
equals(Object) - Method in class java.awt.JobAttributes
Determines whether two JobAttributes are equal to each other.
equals(MenuShortcut) - Method in class java.awt.MenuShortcut
Returns whether this MenuShortcut is the same as another: equality is defined to mean that both MenuShortcuts use the same key and both either use or don't use the SHIFT key.
equals(Object) - Method in class java.awt.MenuShortcut
Returns whether this MenuShortcut is the same as another: equality is defined to mean that both MenuShortcuts use the same key and both either use or don't use the SHIFT key.
equals(Object) - Method in class java.awt.PageAttributes
Determines whether two PageAttributes are equal to each other.
equals(Object) - Method in class java.awt.Point
Determines whether or not two points are equal.
equals(Object) - Method in class java.awt.Rectangle
Checks whether two rectangles are equal.
equals(Object) - Method in class java.awt.RenderingHints
Compares the specified Object with this RenderingHints for equality.
equals(Object) - Method in class java.awt.RenderingHints.Key
The equals method for all Key objects will return the same result as the equality operator '=='.
equals(Object) - Method in class java.beans.IndexedPropertyDescriptor
Compares this PropertyDescriptor against the specified object.
equals(Object) - Method in class java.beans.PropertyDescriptor
Compares this PropertyDescriptor against the specified object.
equals(Object) - Method in class java.io.File
Tests this abstract pathname for equality with the given object.
equals(Object) - Method in class java.io.FilePermission
Checks two FilePermission objects for equality.
equals(Object) - Method in interface java.lang.annotation.Annotation
Returns true if the specified object represents an annotation that is logically equivalent to this one.
equals(Object) - Method in class java.lang.Boolean
Returns true if and only if the argument is not null and is a Boolean object that represents the same boolean value as this object.
equals(Object) - Method in class java.lang.Byte
Compares this object to the specified object.
equals(Object) - Method in class java.lang.Character
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Character.Subset
Compares two Subset objects for equality.
equals(Object) - Method in class java.lang.Double
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Enum
Returns true if the specified object is equal to this enum constant.
equals(Object) - Method in class java.lang.Float
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Integer
Compares this object to the specified object.
equals(Object) - Method in class java.lang.invoke.MethodType
Compares the specified object with this type for equality.
equals(Object) - Method in class java.lang.Long
Compares this object to the specified object.
equals(Object) - Method in class java.lang.Object
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class java.lang.ProcessBuilder.Redirect
Compares the specified object with this Redirect for equality.
equals(Object) - Method in class java.lang.reflect.Constructor
Compares this Constructor against the specified object.
equals(Object) - Method in class java.lang.reflect.字段
Compares this Field against the specified object.
equals(Object) - Method in class java.lang.reflect.方法
Compares this Method against the specified object.
equals(Object) - Method in class java.lang.Short
Compares this object to the specified object.
equals(Object) - Method in class java.lang.StackTraceElement
Returns true if the specified object is another StackTraceElement instance representing the same execution point as this instance.
equals(Object) - Method in class java.lang.String
Compares this string to the specified object.
equals(Object) - Method in class java.math.BigDecimal
Compares this BigDecimal with the specified Object for equality.
equals(Object) - Method in class java.math.BigInteger
Compares this BigInteger with the specified Object for equality.
equals(Object) - Method in class java.math.MathContext
Compares this MathContext with the specified Object for equality.
equals(Object) - Method in class java.net.HttpCookie
Test the equality of two http cookies.
equals(Object) - Method in class java.net.Inet4Address
Compares this object against the specified object.
equals(Object) - Method in class java.net.Inet6Address
Compares this object against the specified object.
equals(Object) - Method in class java.net.InetAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.InetSocketAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.InterfaceAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.NetworkInterface
Compares this object against the specified object.
equals(Object) - Method in class java.net.Proxy
Compares this object against the specified object.
equals(Object) - Method in class java.net.SocketPermission
Checks two SocketPermission objects for equality.
equals(Object) - Method in class java.net.URI
Tests this URI for equality with another object.
equals(Object) - Method in class java.net.URL
Compares this URL for equality with another object.
equals(URL, URL) - Method in class java.net.URLStreamHandler
Provides the default equals calculation.
equals(Object) - Method in class java.nio.ByteBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.CharBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.charset.Charset
Tells whether or not this object is equal to another.
equals(Object) - Method in class java.nio.DoubleBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.file.attribute.AclEntry
Compares the specified object with this ACL entry for equality.
equals(Object) - Method in class java.nio.file.attribute.FileTime
Tests this FileTime for equality with the given object.
equals(Object) - Method in interface java.nio.file.Path
Tests this path for equality with the given object.
equals(Object) - Method in class java.nio.FloatBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.IntBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.LongBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.ShortBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.rmi.activation.ActivationDesc
Compares two activation descriptors for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Compares two command environments for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupDesc
Compares two activation group descriptors for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupID
Compares two group identifiers for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationID
Compares two activation ids for content equality.
equals(Object) - Method in class java.rmi.dgc.VMID
Compare this VMID to another, and return true if they are the same identifier.
equals(Object) - Method in class java.rmi.MarshalledObject
Compares this MarshalledObject to another object.
equals(Object) - Method in class java.rmi.server.ObjID
Compares the specified object with this ObjID for equality.
equals(Object) - Method in class java.rmi.server.RemoteObject
Compares two remote objects for equality.
equals(Object) - Method in class java.rmi.server.UID
Compares the specified object with this UID for equality.
equals(Object) - Method in class java.security.AccessControlContext
Checks two AccessControlContext objects for equality.
equals(Object) - Method in interface java.security.acl.Permission
Returns true if the object passed matches the permission represented in this interface.
equals(Object) - Method in class java.security.AllPermission
Checks two AllPermission objects for equality.
equals(Object) - Method in class java.security.BasicPermission
Checks two BasicPermission objects for equality.
equals(Object) - Method in class java.security.cert.Certificate
Compares this certificate for equality with the specified object.
equals(Object) - Method in class java.security.cert.CertPath
Compares this certification path for equality with the specified object.
equals(Object) - Method in class java.security.cert.X509CRL
Compares this CRL for equality with the given object.
equals(Object) - Method in class java.security.cert.X509CRLEntry
Compares this CRL entry for equality with the given object.
equals(Object) - Method in class java.security.CodeSigner
Tests for equality between the specified object and this code signer.
equals(Object) - Method in class java.security.CodeSource
Tests for equality between the specified object and this object.
equals(Object) - Method in class java.security.Identity
Deprecated.
Tests for equality between the specified object and this identity.
equals(Object) - Method in class java.security.Permission
Checks two Permission objects for equality.
equals(Object) - Method in interface java.security.Principal
Compares this principal to the specified object.
equals(Object) - Method in class java.security.spec.ECFieldF2m
Compares this finite field for equality with the specified object.
equals(Object) - Method in class java.security.spec.ECFieldFp
Compares this prime finite field for equality with the specified object.
equals(Object) - Method in class java.security.spec.ECPoint
Compares this elliptic curve point for equality with the specified object.
equals(Object) - Method in class java.security.spec.EllipticCurve
Compares this elliptic curve for equality with the specified object.
equals(Object) - Method in class java.security.Timestamp
Tests for equality between the specified object and this timestamp.
equals(Object) - Method in class java.security.UnresolvedPermission
Checks two UnresolvedPermission objects for equality.
equals(Object) - Method in interface java.sql.RowId
Compares this RowId to the specified object.
equals(Timestamp) - Method in class java.sql.Timestamp
Tests to see if this Timestamp object is equal to the given Timestamp object.
equals(Object) - Method in class java.sql.Timestamp
Tests to see if this Timestamp object is equal to the given object.
equals(Object) - Method in class java.text.AttributedCharacterIterator.Attribute
Compares two objects for equality.
equals(Object) - Method in class java.text.ChoiceFormat
Equality comparision between two
equals(String, String) - Method in class java.text.Collator
Convenience method for comparing the equality of two strings based on this Collator's collation rules.
equals(Object) - Method in class java.text.Collator
Compares the equality of two Collators.
equals(Object) - Method in class java.text.DateFormat
Overrides equals
equals(Object) - Method in class java.text.DateFormatSymbols
Override equals
equals(Object) - Method in class java.text.DecimalFormat
Overrides equals
equals(Object) - Method in class java.text.DecimalFormatSymbols
Override equals.
equals(Object) - Method in class java.text.FieldPosition
Overrides equals
equals(Object) - Method in class java.text.MessageFormat
Equality comparison between two message format objects
equals(Object) - Method in class java.text.NumberFormat
Overrides equals
equals(Object) - Method in class java.text.ParsePosition
Overrides equals
equals(Object) - Method in class java.text.RuleBasedCollator
Compares the equality of two collation objects.
equals(Object) - Method in class java.text.SimpleDateFormat
Compares the given object with this SimpleDateFormat for equality.
equals(Object) - Method in class java.text.StringCharacterIterator
Compares the equality of two StringCharacterIterator objects.
equals(Object) - Method in class java.util.AbstractList
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.AbstractMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.AbstractMap.SimpleEntry
Compares the specified object with this entry for equality.
equals(Object) - Method in class java.util.AbstractMap.SimpleImmutableEntry
Compares the specified object with this entry for equality.
equals(Object) - Method in class java.util.AbstractSet
Compares the specified object with this set for equality.
equals(long[], long[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of longs are equal to one another.
equals(int[], int[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of ints are equal to one another.
equals(short[], short[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of shorts are equal to one another.
equals(char[], char[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of chars are equal to one another.
equals(byte[], byte[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of bytes are equal to one another.
equals(boolean[], boolean[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of booleans are equal to one another.
equals(double[], double[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of doubles are equal to one another.
equals(float[], float[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of floats are equal to one another.
equals(Object[], Object[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of Objects are equal to one another.
equals(Object) - Method in class java.util.BitSet
Compares this object against the specified object.
equals(Object) - Method in class java.util.Calendar
Compares this Calendar to the specified Object.
equals(Object) - Method in interface java.util.Collection
Compares the specified object with this collection for equality.
equals(Object) - Method in interface java.util.Comparator
Indicates whether some other object is "equal to" this comparator.
equals(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.concurrent.ConcurrentSkipListSet
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.concurrent.CopyOnWriteArraySet
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.Date
Compares two dates for equality.
equals(Object) - Method in class java.util.EnumMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.GregorianCalendar
Compares this GregorianCalendar to the specified Object.
equals(Object) - Method in class java.util.Hashtable
Compares the specified Object with this Map for equality, as per the definition in the Map interface.
equals(Object) - Method in class java.util.IdentityHashMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.jar.Attributes
Compares the specified Attributes object with this Map for equality.
equals(Object) - Method in class java.util.jar.Attributes.Name
Compares this attribute name to another for equality.
equals(Object) - Method in class java.util.jar.Manifest
Returns true if the specified Object is also a Manifest and has the same main Attributes and entries.
equals(Object) - Method in interface java.util.List
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.Locale
Returns true if this Locale is equal to another object.
equals(Object) - Method in class java.util.logging.Level
Compare two objects for value equality.
equals(Object) - Method in interface java.util.Map.Entry
Compares the specified object with this entry for equality.
equals(Object) - Method in interface java.util.Map
Compares the specified object with this map for equality.
equals(Object, Object) - Static method in class java.util.Objects
Returns true if the arguments are equal to each other and false otherwise.
equals(Object) - Method in class java.util.PropertyPermission
Checks two PropertyPermission objects for equality.
equals(Object) - Method in interface java.util.Set
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.SimpleTimeZone
Compares the equality of two SimpleTimeZone objects.
equals(Object) - Method in class java.util.UUID
Compares this object to the specified object.
equals(Object) - Method in class java.util.Vector
Compares the specified Object with this Vector for equality.
equals(DataFlavor) - Method in class javax.activation.ActivationDataFlavor
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
equals(Object) - Method in class javax.crypto.spec.RC2ParameterSpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.crypto.spec.RC5ParameterSpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.crypto.spec.SecretKeySpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.imageio.ImageTypeSpecifier
Returns true if the given Object is an ImageTypeSpecifier and has a SampleModel and ColorModel that are equal to those of this object.
equals(Object) - Method in interface javax.lang.model.element.Element
Returns true if the argument represents the same element as this, or false otherwise.
equals(Object) - Method in interface javax.lang.model.element.Name
Returns true if the argument represents the same name as this, and false otherwise.
equals(Object) - Method in interface javax.lang.model.type.TypeMirror
Obeys the general contract of Object.equals.
equals(Object) - Method in class javax.management.Attribute
Compares the current Attribute Object with another Attribute Object.
equals(Object) - Method in interface javax.management.Descriptor
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.ImmutableDescriptor
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.MBeanAttributeInfo
Compare this MBeanAttributeInfo to another.
equals(Object) - Method in class javax.management.MBeanConstructorInfo
Compare this MBeanConstructorInfo to another.
equals(Object) - Method in class javax.management.MBeanFeatureInfo
Compare this MBeanFeatureInfo to another.
equals(Object) - Method in class javax.management.MBeanInfo
Compare this MBeanInfo to another.
equals(Object) - Method in class javax.management.MBeanNotificationInfo
Compare this MBeanNotificationInfo to another.
equals(Object) - Method in class javax.management.MBeanOperationInfo
Compare this MBeanOperationInfo to another.
equals(Object) - Method in class javax.management.MBeanParameterInfo
Compare this MBeanParameterInfo to another.
equals(Object) - Method in class javax.management.MBeanPermission
Checks two MBeanPermission objects for equality.
equals(Object) - Method in class javax.management.MBeanServerPermission
Checks two MBeanServerPermission objects for equality.
equals(Object) - Method in class javax.management.modelmbean.DescriptorSupport
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.ObjectInstance
Compares the current object instance with another object instance.
equals(Object) - Method in class javax.management.ObjectName
Compares the current object name with another object name.
equals(Object) - Method in class javax.management.openmbean.ArrayType
Compares the specified obj parameter with this ArrayType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.CompositeData
Compares the specified obj parameter with this CompositeData instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Compares the specified obj parameter with this CompositeDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeType
Compares the specified obj parameter with this CompositeType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanInfo
Compares the specified obj parameter with this OpenMBeanInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenType
Compares the specified obj parameter with this open type instance for equality.
equals(Object) - Method in class javax.management.openmbean.SimpleType
Compares the specified obj parameter with this SimpleType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.TabularData
Compares the specified obj parameter with this TabularData instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularDataSupport
Compares the specified obj parameter with this TabularDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularType
Compares the specified obj parameter with this TabularType instance for equality.
equals(Object) - Method in class javax.management.remote.JMXPrincipal
Compares the specified Object with this JMXPrincipal for equality.
equals(Object) - Method in class javax.management.remote.JMXServiceURL
Indicates whether some other object is equal to this one.
equals(Object) - Method in class javax.naming.BinaryRefAddr
Determines whether obj is equal to this address.
equals(Object) - Method in class javax.naming.CompositeName
Determines whether two composite names are equal.
equals(Object) - Method in class javax.naming.CompoundName
Determines whether obj is syntactically equal to this compound name.
equals(Object) - Method in class javax.naming.directory.BasicAttribute
Determines whether obj is equal to this attribute.
equals(Object) - Method in class javax.naming.directory.BasicAttributes
Determines whether this BasicAttributes is equal to another Attributes Two Attributes are equal if they are both instances of Attributes, treat the case of attribute IDs the same way, and contain the same attributes.
equals(Object) - Method in class javax.naming.ldap.LdapName
Determines whether two LDAP names are equal.
equals(Object) - Method in class javax.naming.ldap.Rdn
Compares the specified Object with this Rdn for equality.
equals(Object) - Method in class javax.naming.RefAddr
Determines whether obj is equal to this RefAddr.
equals(Object) - Method in class javax.naming.Reference
Determines whether obj is a reference with the same addresses (in same order) as this reference.
equals(Object) - Method in interface javax.print.attribute.AttributeSet
Compares the specified object with this attribute set for equality.
equals(Object) - Method in class javax.print.attribute.DateTimeSyntax
Returns whether this date-time attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.HashAttributeSet
Compares the specified object with this attribute set for equality.
equals(Object) - Method in class javax.print.attribute.IntegerSyntax
Returns whether this integer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.ResolutionSyntax
Returns whether this resolution attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.SetOfIntegerSyntax
Returns whether this set-of-integer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.Size2DSyntax
Returns whether this two-dimensional size attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Copies
Returns whether this copies attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.CopiesSupported
Returns whether this copies supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtCompleted
Returns whether this date-time at completed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtCreation
Returns whether this date-time at creation attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtProcessing
Returns whether this date-time at processing attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Destination
Returns whether this destination attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DocumentName
Returns whether this document name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobHoldUntil
Returns whether this job hold until attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressions
Returns whether this job impressions attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressionsCompleted
Returns whether this job impressions completed attribute is equivalent tp the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressionsSupported
Returns whether this job impressions supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctets
Returns whether this job K octets attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctetsProcessed
Returns whether this job K octets processed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctetsSupported
Returns whether this job K octets supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheets
Returns whether this job media sheets attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted
Returns whether this job media sheets completed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheetsSupported
Returns whether this job media sheets supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMessageFromOperator
Returns whether this job message from operator attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobName
Returns whether this job name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobOriginatingUserName
Returns whether this job originating user name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobPriority
Returns whether this job priority attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobPrioritySupported
Returns whether this job priority supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Media
Returns whether this media attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns whether this media margins attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.MediaSize
Returns whether this media size attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberOfDocuments
Returns whether this number of documents attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberOfInterveningJobs
Returns whether this number of intervening jobs attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberUp
Returns whether this number up attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberUpSupported
Returns whether this number up supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.OutputDeviceAssigned
Returns whether this output device assigned attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PageRanges
Returns whether this page ranges attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PagesPerMinute
Returns whether this pages per minute attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PagesPerMinuteColor
Returns whether this pages per minute color attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterInfo
Returns whether this printer info attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterLocation
Returns whether this printer location attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMakeAndModel
Returns whether this printer make and model attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMessageFromOperator
Returns whether this printer message from operator attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMoreInfo
Returns whether this printer more info attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer
Returns whether this printer more info manufacturer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterName
Returns whether this printer name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterResolution
Returns whether this printer resolution attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterURI
Returns whether this printer name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.QueuedJobCount
Returns whether this queued job count attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.RequestingUserName
Returns whether this requesting user name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.TextSyntax
Returns whether this text attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.URISyntax
Returns whether this URI attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.DocFlavor
Determines if this doc flavor object is equal to the given object.
equals(Object) - Method in interface javax.print.PrintService
Determines if two services are referring to the same underlying service.
equals(Object) - Method in class javax.rmi.CORBA.Stub
Compares two stubs for equality.
equals(Stub, Object) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.equals(java.lang.Object).
equals(Object) - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class javax.security.auth.kerberos.DelegationPermission
Checks two DelegationPermission objects for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosKey
Compares the specified Object with this KerberosKey for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosPrincipal
Compares the specified Object with this Principal for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosTicket
Compares the specified Object with this KerberosTicket for equality.
equals(Object) - Method in class javax.security.auth.kerberos.ServicePermission
Checks two ServicePermission objects for equality.
equals(Object) - Method in class javax.security.auth.PrivateCredentialPermission
Checks two PrivateCredentialPermission objects for equality.
equals(Object) - Method in class javax.security.auth.Subject
Compares the specified Object with this Subject for equality.
equals(Object) - Method in class javax.security.auth.x500.X500Principal
Compares the specified Object with this X500Principal for equality.
equals(Object) - Method in class javax.security.cert.Certificate
Compares this certificate for equality with the specified object.
equals(Object) - Method in class javax.sound.midi.MidiDevice.Info
Reports whether two objects are equal.
equals(Object) - Method in class javax.sound.midi.Sequencer.SyncMode
Determines whether two objects are equal.
equals(Object) - Method in class javax.sound.sampled.AudioFileFormat.Type
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.AudioFormat.Encoding
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.Control.Type
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.LineEvent.Type
Indicates whether the specified object is equal to this event type, returning true if the objects are identical.
equals(Object) - Method in class javax.sound.sampled.Mixer.Info
Indicates whether two info objects are equal, returning true if they are identical.
equals(Object) - Method in class javax.sound.sampled.Port.Info
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.ReverbType
Indicates whether the specified object is equal to this reverb type, returning true if the objects are identical.
equals(Object) - Method in class javax.swing.RowSorter.SortKey
Returns true if this object equals the specified object.
equals(Object) - Method in class javax.swing.text.DefaultCaret
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.html.HTML.UnknownTag
Compares this object to the specifed object.
equals(Object) - Method in class javax.swing.text.SimpleAttributeSet
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Compares this object to the specifed object.
equals(Object) - Method in class javax.swing.text.TabSet
Indicates whether this TabSet is equal to another one.
equals(Object) - Method in class javax.swing.text.TabStop
Returns true if the tabs are equal.
equals(Object) - Method in class javax.swing.tree.TreePath
Compares this TreePath to the specified object.
equals(Object) - Method in class javax.xml.datatype.Duration
Checks if this duration object has the same duration as another Duration object.
equals(Object) - Method in class javax.xml.datatype.XMLGregorianCalendar
Compares this calendar to the specified object.
equals(Object) - Method in class javax.xml.namespace.QName
Test this QName for equality with another Object.
equals(Object) - Method in class org.ietf.jgss.ChannelBinding
Compares two instances of ChannelBinding.
equals(Object) - Method in interface org.ietf.jgss.GSSCredential
Tests if this GSSCredential asserts the same entity as the supplied object.
equals(GSSName) - Method in interface org.ietf.jgss.GSSName
Compares two GSSName objects to determine if they refer to the same entity.
equals(Object) - Method in interface org.ietf.jgss.GSSName
Compares this GSSName object to another Object that might be a GSSName.
equals(Object) - Method in class org.ietf.jgss.Oid
Tests if two Oid objects represent the same Object identifier value.
equals(Object, Object) - Method in class org.omg.CORBA.portable.Delegate
Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
equals(Object) - Method in class org.omg.CORBA.portable.ObjectImpl
Compares this ObjectImpl object with the given one for equality.
equalsIgnoreCase(String) - Method in class java.lang.String
Compares this String to another String, ignoring case considerations.
equivalent(TypeCode) - Method in class org.omg.CORBA.TypeCode
Tests to see if the given TypeCode object is equivalent to this TypeCode object.
ERA - Static variable in class java.text.DateFormat.Field
Constant identifying the era field.
ERA - Static variable in class java.util.Calendar
Field number for get and set indicating the era, e.g., AD or BC in the Julian calendar.
ERA_FIELD - Static variable in class java.text.DateFormat
Useful constant for ERA field alignment.
erase() - Method in class java.lang.invoke.MethodType
Erases all reference types to Object.
erasure(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the erasure of a type.
err - Static variable in class java.io.FileDescriptor
A handle to the standard error stream.
err - Static variable in class java.lang.System
The "standard" error output stream.
ERROR - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that an image which was being tracked asynchronously has encountered an error.
Error - Error in java.lang
An Error is a subclass of Throwable that indicates serious problems that a reasonable application should not try to catch.
Error() - Constructor for error java.lang.Error
Constructs a new error with null as its detail message.
Error(String) - Constructor for error java.lang.Error
Constructs a new error with the specified detail message.
Error(String, Throwable) - Constructor for error java.lang.Error
Constructs a new error with the specified detail message and cause.
Error(Throwable) - Constructor for error java.lang.Error
Constructs a new error with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ERROR - Static variable in interface java.util.jar.Pack200.Packer
The string "error", a possible value for certain properties.
error(String, Exception, int) - Method in class java.util.logging.ErrorManager
The error method is called when a Handler failure occurs.
ERROR - Static variable in class javax.print.attribute.standard.Severity
Indicates that the PrinterStateReason is an "error" (most severe).
ERROR - Static variable in class javax.security.auth.callback.ConfirmationCallback
ERROR message type.
ERROR - Static variable in class javax.security.auth.callback.TextOutputCallback
Error message.
error(String, String, String, String) - Method in class javax.swing.text.html.parser.Parser
Invoke the error handler.
error(String, String, String) - Method in class javax.swing.text.html.parser.Parser
error(String, String) - Method in class javax.swing.text.html.parser.Parser
error(String) - Method in class javax.swing.text.html.parser.Parser
ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
error(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a recoverable error.
error(SAXParseException) - Method in interface org.xml.sax.ErrorHandler
Receive notification of a recoverable error.
error(SAXParseException) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of a recoverable parser error.
error(SAXParseException) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of a recoverable parser error.
error(SAXParseException) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an error event.
ERROR_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
ERROR_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for error messages.
ERROR_OPTION - Static variable in class javax.swing.JFileChooser
Return value if an error occured.
errorCode - Variable in exception javax.transaction.xa.XAException
The error code with which to create the SystemException.
ERRORED - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media encountered an error.
ErrorHandler - Interface in org.xml.sax
Basic interface for SAX error handlers.
ErrorListener - Interface in javax.xml.transform
To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
ErrorManager - Class in java.util.logging
ErrorManager objects can be attached to Handlers to process any error that occurs on a Handler during Logging.
ErrorManager() - Constructor for class java.util.logging.ErrorManager
errorRaised() - Method in interface javax.annotation.processing.RoundEnvironment
Returns true if an error was raised in the prior round of processing; returns false otherwise.
ErrorType - Interface in javax.lang.model.type
Represents a class or interface type that cannot be properly modeled.
errorWriter - Variable in class javax.script.SimpleScriptContext
This is the writer to be used to output errors from scripts.
ESCAPE - Static variable in class java.awt.Event
The Escape key.
escapeValue(Object) - Static method in class javax.naming.ldap.Rdn
Given the value of an attribute, returns a string escaped according to the rules specified in RFC 2253.
establish_components(IORInfo) - Method in interface org.omg.PortableInterceptor.IORInterceptorOperations
A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
EtchedBorder - Class in javax.swing.border
A class which implements a simple etched border which can either be etched-in or etched-out.
EtchedBorder() - Constructor for class javax.swing.border.EtchedBorder
Creates a lowered etched border whose colors will be derived from the background color of the component passed into the paintBorder method.
EtchedBorder(int) - Constructor for class javax.swing.border.EtchedBorder
Creates an etched border with the specified etch-type whose colors will be derived from the background color of the component passed into the paintBorder method.
EtchedBorder(Color, Color) - Constructor for class javax.swing.border.EtchedBorder
Creates a lowered etched border with the specified highlight and shadow colors.
EtchedBorder(int, Color, Color) - Constructor for class javax.swing.border.EtchedBorder
Creates an etched border with the specified etch-type, highlight and shadow colors.
etchType - Variable in class javax.swing.border.EtchedBorder
etherealize(byte[], POA, Servant, boolean, boolean) - Method in class org.omg.PortableServer._ServantActivatorStub
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
etherealize(byte[], POA, Servant, boolean, boolean) - Method in interface org.omg.PortableServer.ServantActivatorOperations
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
ETHIOPIC - Static variable in class java.awt.font.NumericShaper
Identifies the ETHIOPIC range and decimal base.
ETHIOPIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic" Unicode character block.
ETHIOPIC_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Extended" Unicode character block.
ETHIOPIC_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Extended-A" Unicode character block.
ETHIOPIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Supplement" Unicode character block.
EUROPEAN - Static variable in class java.awt.font.NumericShaper
Identifies the Latin-1 (European) and extended range, and Latin-1 (European) decimal base.
eval(Reader, Bindings) - Method in class javax.script.AbstractScriptEngine
eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field.
eval(String, Bindings) - Method in class javax.script.AbstractScriptEngine
Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
eval(Reader) - Method in class javax.script.AbstractScriptEngine
eval(Reader) calls the abstract eval(Reader, ScriptContext) passing the value of the context field.
eval(String) - Method in class javax.script.AbstractScriptEngine
Same as eval(Reader) except that the abstract eval(String, ScriptContext) is used.
eval(ScriptContext) - Method in class javax.script.CompiledScript
Executes the program stored in this CompiledScript object.
eval(Bindings) - Method in class javax.script.CompiledScript
Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution.
eval() - Method in class javax.script.CompiledScript
Executes the program stored in the CompiledScript object.
eval(String, ScriptContext) - Method in interface javax.script.ScriptEngine
Causes the immediate execution of the script whose source is the String passed as the first argument.
eval(Reader, ScriptContext) - Method in interface javax.script.ScriptEngine
Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
eval(String) - Method in interface javax.script.ScriptEngine
Executes the specified script.
eval(Reader) - Method in interface javax.script.ScriptEngine
Same as eval(String) except that the source of the script is provided as a Reader
eval(String, Bindings) - Method in interface javax.script.ScriptEngine
Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution.
eval(Reader, Bindings) - Method in interface javax.script.ScriptEngine
Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
evaluate(RowSet) - Method in interface javax.sql.rowset.Predicate
This method is typically called a FilteredRowSet object internal methods (not public) that control the RowSet object's cursor moving from row to the next.
evaluate(Object, int) - Method in interface javax.sql.rowset.Predicate
This method is called by a FilteredRowSet object to check whether the value lies between the filtering criterion (or criteria if multiple constraints exist) set using the setFilter() method.
evaluate(Object, String) - Method in interface javax.sql.rowset.Predicate
This method is called by the FilteredRowSet object to check whether the value lies between the filtering criteria set using the setFilter method.
evaluate(String, Object, QName) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the specified context and return the result as the specified type.
evaluate(String, Object) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the specified context and return the result as a String.
evaluate(String, InputSource, QName) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
evaluate(String, InputSource) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
evaluate(Object, QName) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
evaluate(Object) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the specified context and return the result as a String.
evaluate(InputSource, QName) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
evaluate(InputSource) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
evaluate(List) - Method in interface javax.xml.xpath.XPathFunction
Evaluate the function with the specified arguments.
evaluateChallenge(byte[]) - Method in interface javax.security.sasl.SaslClient
Evaluates the challenge data and generates a response.
evaluateResponse(byte[]) - Method in interface javax.security.sasl.SaslServer
Evaluates the response data and generates a challenge.
Event - Class in java.awt
NOTE: The Event class is obsolete and is available only for backwards compatilibility.
Event(Object, long, int, int, int, int, int, Object) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatilibility.
Event(Object, long, int, int, int, int, int) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatilibility.
Event(Object, int, Object) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatilibility.
event - Variable in exception javax.swing.tree.ExpandVetoException
The event that the exception was created for.
Event - Interface in org.w3c.dom.events
The Event interface is used to provide contextual information about an event to the handler processing the event.
EventContext - Interface in javax.naming.event
Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.
EventDirContext - Interface in javax.naming.event
Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.
eventDispatched(AWTEvent) - Method in interface java.awt.event.AWTEventListener
Invoked when an event is dispatched in the AWT.
eventDispatched(AWTEvent) - Method in class java.awt.event.AWTEventListenerProxy
Forwards the AWT event to the listener delegate.
eventDispatched(AWTEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes AWTEvents for JLayer and all its descendants to this LayerUI instance.
EventException - Exception in org.w3c.dom.events
Event operations may throw an EventException as specified in their method descriptions.
EventException(short, String) - Constructor for exception org.w3c.dom.events.EventException
EventFilter - Interface in javax.xml.stream
This interface declares a simple filter interface that one can create to filter XMLEventReaders
EventHandler - Class in java.beans
The EventHandler class provides support for dynamically generating event listeners whose methods execute a simple statement involving an incoming event object and a target object.
EventHandler(Object, String, String, String) - Constructor for class java.beans.EventHandler
Creates a new EventHandler object; you generally use one of the create methods instead of invoking this constructor directly.
EventListener - Interface in java.util
A tagging interface that all event listener interfaces must extend.
EventListener - Interface in org.w3c.dom.events
The EventListener interface is the primary method for handling events.
EventListenerList - Class in javax.swing.event
A class that holds a list of EventListeners.
EventListenerList() - Constructor for class javax.swing.event.EventListenerList
EventListenerProxy<T extends EventListener> - Class in java.util
An abstract wrapper class for an EventListener class which associates a set of additional parameters with the listener.
EventListenerProxy(T) - Constructor for class java.util.EventListenerProxy
Creates a proxy for the specified listener.
EventObject - Class in java.util
The root class from which all event state objects shall be derived.
EventObject(Object) - Constructor for class java.util.EventObject
Constructs a prototypical Event.
EventQueue - Class in java.awt
EventQueue is a platform-independent class that queues events, both from the underlying peer classes and from trusted application classes.
EventQueue() - Constructor for class java.awt.EventQueue
EventReaderDelegate - Class in javax.xml.stream.util
This is the base class for deriving an XMLEventReader filter.
EventReaderDelegate() - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an empty filter with no parent.
EventReaderDelegate(XMLEventReader) - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an filter with the specified parent.
events - Variable in class java.awt.dnd.DragGestureRecognizer
The list of events (in order) that the DragGestureRecognizer "recognized" as a "gesture" that triggers a drag.
EventSetDescriptor - Class in java.beans
An EventSetDescriptor describes a group of events that a given Java bean fires.
EventSetDescriptor(Class<?>, String, Class<?>, String) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor assuming that you are following the most simple standard design pattern where a named event "fred" is (1) delivered as a call on the single method of interface FredListener, (2) has a single argument of type FredEvent, and (3) where the FredListener may be registered with a call on an addFredListener method of the source component and removed with a call on a removeFredListener method.
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using string names.
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String) - Constructor for class java.beans.EventSetDescriptor
This constructor creates an EventSetDescriptor from scratch using string names.
EventSetDescriptor(String, Class<?>, Method[], Method, Method) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using java.lang.reflect.Method and java.lang.Class objects.
EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method) - Constructor for class java.beans.EventSetDescriptor
This constructor creates an EventSetDescriptor from scratch using java.lang.reflect.Method and java.lang.Class objects.
EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using java.lang.reflect.MethodDescriptor and java.lang.Class objects.
EventTarget - Interface in org.w3c.dom.events
The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
eventTypeEnabled(int) - Method in class java.awt.ScrollPane
If wheel scrolling is enabled, we return true for MouseWheelEvents
evt - Variable in class java.awt.Event
The next event.
exactInvoker(MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a special invoker method handle which can be used to invoke any method handle of the given type, as if by invokeExact.
examineAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
examineHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
ExcC14NParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
ExcC14NParameterSpec() - Constructor for class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Creates a ExcC14NParameterSpec with an empty prefix list.
ExcC14NParameterSpec(List) - Constructor for class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Creates a ExcC14NParameterSpec with the specified list of prefixes.
ExcellentBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view supports breaking, and this represents a very attractive place to break.
except(Any) - Method in class org.omg.CORBA.ServerRequest
Deprecated.
use set_exception()
except - Variable in exception org.omg.CORBA.UnknownUserException
The Any instance that contains the actual user exception thrown by the server.
Exception - Exception in java.lang
The class Exception and its subclasses are a form of Throwable that indicates conditions that a reasonable application might want to catch.
Exception() - Constructor for exception java.lang.Exception
Constructs a new exception with null as its detail message.
Exception(String) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified detail message.
Exception(String, Throwable) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified detail message and cause.
Exception(Throwable) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
exception() - Method in class org.omg.CORBA.Environment
Retrieves the exception in this Environment object.
exception(Exception) - Method in class org.omg.CORBA.Environment
Inserts the given exception into this Environment object.
ExceptionDetailMessage - Interface in org.omg.IOP
org/omg/IOP/ExceptionDetailMessage.java .
ExceptionInInitializerError - Error in java.lang
Signals that an unexpected exception has occurred in a static initializer.
ExceptionInInitializerError() - Constructor for error java.lang.ExceptionInInitializerError
Constructs an ExceptionInInitializerError with null as its detail message string and with no saved throwable object.
ExceptionInInitializerError(Throwable) - Constructor for error java.lang.ExceptionInInitializerError
Constructs a new ExceptionInInitializerError class by saving a reference to the Throwable object thrown for later retrieval by the ExceptionInInitializerError.getException() method.
ExceptionInInitializerError(String) - Constructor for error java.lang.ExceptionInInitializerError
Constructs an ExceptionInInitializerError with the specified detail message string.
ExceptionList - Class in org.omg.CORBA
An object used in Request operations to describe the exceptions that can be thrown by a method.
ExceptionList() - Constructor for class org.omg.CORBA.ExceptionList
ExceptionListener - Interface in java.beans
An ExceptionListener is notified of internal exceptions.
exceptions() - Method in class org.omg.CORBA.Request
Retrieves the ExceptionList object for this request.
exceptions() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
exceptionThrown(Exception) - Method in interface java.beans.ExceptionListener
This method is called when a recoverable exception has been caught.
exchange(V) - Method in class java.util.concurrent.Exchanger
Waits for another thread to arrive at this exchange point (unless the current thread is interrupted), and then transfers the given object to it, receiving its object in return.
exchange(V, long, TimeUnit) - Method in class java.util.concurrent.Exchanger
Waits for another thread to arrive at this exchange point (unless the current thread is interrupted or the specified waiting time elapses), and then transfers the given object to it, receiving its object in return.
Exchanger<V> - Class in java.util.concurrent
A synchronization point at which threads can pair and swap elements within pairs.
Exchanger() - Constructor for class java.util.concurrent.Exchanger
Creates a new Exchanger.
exclusions - Variable in class javax.swing.text.html.parser.Element
EXCLUSIVE - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
EXCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Exclusive Canonical XML with comments canonicalization method algorithm URI.
exclusiveOr(Area) - Method in class java.awt.geom.Area
Sets the shape of this Area to be the combined area of its current shape and the shape of the specified Area, minus their intersection.
exec(String) - Method in class java.lang.Runtime
Executes the specified string command in a separate process.
exec(String, String[]) - Method in class java.lang.Runtime
Executes the specified string command in a separate process with the specified environment.
exec(String, String[], File) - Method in class java.lang.Runtime
Executes the specified string command in a separate process with the specified environment and working directory.
exec(String[]) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process.
exec(String[], String[]) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process with the specified environment.
exec(String[], String[], File) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process with the specified environment and working directory.
exec() - Method in class java.util.concurrent.ForkJoinTask
Immediately performs the base action of this task.
exec() - Method in class java.util.concurrent.RecursiveAction
Implements execution conventions for RecursiveActions.
exec() - Method in class java.util.concurrent.RecursiveTask
Implements execution conventions for RecursiveTask.
ExecutableElement - Interface in javax.lang.model.element
Represents a method, constructor, or initializer (static or instance) of a class or interface, including annotation type elements.
ExecutableType - Interface in javax.lang.model.type
Represents the type of an executable.
execute() - Method in class java.beans.Expression
The execute method finds a method whose name is the same as the methodName property, and invokes the method on the target.
execute() - Method in class java.beans.Statement
The execute method finds a method whose name is the same as the methodName property, and invokes the method on the target.
execute() - Method in interface java.sql.PreparedStatement
Executes the SQL statement in this PreparedStatement object, which may be any kind of SQL statement.
execute(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results.
execute(String, int) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that any auto-generated keys should be made available for retrieval.
execute(String, int[]) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
execute(String, String[]) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
execute(Runnable) - Method in interface java.util.concurrent.Executor
Executes the given command at some time in the future.
execute(ForkJoinTask<?>) - Method in class java.util.concurrent.ForkJoinPool
Arranges for (asynchronous) execution of the given task.
execute(Runnable) - Method in class java.util.concurrent.ForkJoinPool
execute(Runnable) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Executes command with zero required delay.
execute(Runnable) - Method in class java.util.concurrent.ThreadPoolExecutor
Executes the given task sometime in the future.
execute(Connection) - Method in interface javax.sql.rowset.CachedRowSet
Populates this CachedRowSet object with data, using the given connection to produce the result set from which the data will be read.
execute() - Method in interface javax.sql.RowSet
Fills this RowSet object with data.
execute() - Method in class javax.swing.SwingWorker
Schedules this SwingWorker for execution on a worker thread.
EXECUTE_FAILED - Static variable in interface java.sql.Statement
The constant indicating that an error occured while executing a batch statement.
executeBatch() - Method in interface java.sql.Statement
Submits a batch of commands to the database for execution and if all commands execute successfully, returns an array of update counts.
executeCall() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
executeQuery() - Method in interface java.sql.PreparedStatement
Executes the SQL query in this PreparedStatement object and returns the ResultSet object generated by the query.
executeQuery(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which returns a single ResultSet object.
executeUpdate() - Method in interface java.sql.PreparedStatement
Executes the SQL statement in this PreparedStatement object, which must be an SQL Data Manipulation Language (DML) statement, such as INSERT, UPDATE or DELETE; or an SQL statement that returns nothing, such as a DDL statement.
executeUpdate(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which may be an INSERT, UPDATE, or DELETE statement or an SQL statement that returns nothing, such as an SQL DDL statement.
executeUpdate(String, int) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver with the given flag about whether the auto-generated keys produced by this Statement object should be made available for retrieval.
executeUpdate(String, int[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
executeUpdate(String, String[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
ExecutionException - Exception in java.util.concurrent
Exception thrown when attempting to retrieve the result of a task that aborted by throwing an exception.
ExecutionException() - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with no detail message.
ExecutionException(String) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified detail message.
ExecutionException(String, Throwable) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified detail message and cause.
ExecutionException(Throwable) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified cause.
EXECUTIVE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Executive, 7 1/4 x 10 1/2 in.
EXECUTIVE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the executive size, 7.25 inches by 10.5 inches.
EXECUTIVE - Static variable in class javax.print.attribute.standard.MediaSizeName
executive size .
Executor - Interface in java.util.concurrent
An object that executes submitted Runnable tasks.
ExecutorCompletionService<V> - Class in java.util.concurrent
A CompletionService that uses a supplied Executor to execute tasks.
ExecutorCompletionService(Executor) - Constructor for class java.util.concurrent.ExecutorCompletionService
Creates an ExecutorCompletionService using the supplied executor for base task execution and a LinkedBlockingQueue as a completion queue.
ExecutorCompletionService(Executor, BlockingQueue<Future<V>>) - Constructor for class java.util.concurrent.ExecutorCompletionService
Creates an ExecutorCompletionService using the supplied executor for base task execution and the supplied queue as its completion queue.
Executors - Class in java.util.concurrent
Factory and utility methods for Executor, ExecutorService, ScheduledExecutorService, ThreadFactory, and Callable classes defined in this package.
ExecutorService - Interface in java.util.concurrent
An Executor that provides methods to manage termination and methods that can produce a Future for tracking progress of one or more asynchronous tasks.
ExemptionMechanism - Class in javax.crypto
This class provides the functionality of an exemption mechanism, examples of which are key recovery, key weakening, and key escrow.
ExemptionMechanism(ExemptionMechanismSpi, Provider, String) - Constructor for class javax.crypto.ExemptionMechanism
Creates a ExemptionMechanism object.
ExemptionMechanismException - Exception in javax.crypto
This is the generic ExemptionMechanism exception.
ExemptionMechanismException() - Constructor for exception javax.crypto.ExemptionMechanismException
Constructs a ExemptionMechanismException with no detailed message.
ExemptionMechanismException(String) - Constructor for exception javax.crypto.ExemptionMechanismException
Constructs a ExemptionMechanismException with the specified detailed message.
ExemptionMechanismSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the ExemptionMechanism class.
ExemptionMechanismSpi() - Constructor for class javax.crypto.ExemptionMechanismSpi
exists() - Method in class java.io.File
Tests whether the file or directory denoted by this abstract pathname exists.
exists(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file exists.
exit() - Method in interface java.awt.SecondaryLoop
Unblocks the execution of the thread blocked by the SecondaryLoop.enter() method and exits the secondary loop.
exit(int) - Method in class java.lang.Runtime
Terminates the currently running Java virtual machine by initiating its shutdown sequence.
exit(int) - Static method in class java.lang.System
Terminates the currently running Java Virtual Machine.
EXIT_ON_CLOSE - Static variable in class javax.swing.JFrame
The exit application default window close operation.
EXIT_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The exit application default window close operation.
EXITED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Exited type.
exiting(String, String) - Method in class java.util.logging.Logger
Log a method return.
exiting(String, String, Object) - Method in class java.util.logging.Logger
Log a method return, with result object.
exitValue() - Method in class java.lang.Process
Returns the exit value for the subprocess.
exp(double) - Static method in class java.lang.Math
Returns Euler's number e raised to the power of a double value.
exp(double) - Static method in class java.lang.StrictMath
Returns Euler's number e raised to the power of a double value.
EXPANDABLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object allows progressive disclosure of its children.
EXPANDED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is expanded.
expandedIcon - Variable in class javax.swing.plaf.basic.BasicTreeUI
expandPath(TreePath) - Method in class javax.swing.JTree
Ensures that the node identified by the specified path is expanded and viewable.
expandRow(int) - Method in class javax.swing.JTree
Ensures that the node in the specified row is expanded and viewable.
EXPANDS_SELECTED_PATHS_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for expands selected paths property
expandTabRunsArray() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
ExpandVetoException - Exception in javax.swing.tree
Exception used to stop and expand/collapse from happening.
ExpandVetoException(TreeExpansionEvent) - Constructor for exception javax.swing.tree.ExpandVetoException
Constructs an ExpandVetoException object with no message.
ExpandVetoException(TreeExpansionEvent, String) - Constructor for exception javax.swing.tree.ExpandVetoException
Constructs an ExpandVetoException object with the specified message.
explicitCastArguments(MethodHandle, MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which adapts the type of the given method handle to a new type by pairwise argument conversion.
expm1(double) - Static method in class java.lang.Math
Returns ex -1.
expm1(double) - Static method in class java.lang.StrictMath
Returns ex -1.
EXPONENT - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent field.
EXPONENT_SIGN - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent sign field.
EXPONENT_SYMBOL - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent symbol field.
export() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
export() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
export() - Method in class javax.management.remote.rmi.RMIServerImpl
Exports this RMI object.
export() - Method in interface org.ietf.jgss.GSSContext
Exports this context so that another process may import it..
export() - Method in interface org.ietf.jgss.GSSName
Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
exportAsDrag(JComponent, InputEvent, int) - Method in class javax.swing.TransferHandler
Causes the Swing drag support to be initiated.
exportDone(JComponent, Transferable, int) - Method in class javax.swing.TransferHandler
Invoked after data has been exported.
ExportException - Exception in java.rmi.server
An ExportException is a RemoteException thrown if an attempt to export a remote object fails.
ExportException(String) - Constructor for exception java.rmi.server.ExportException
Constructs an ExportException with the specified detail message.
ExportException(String, Exception) - Constructor for exception java.rmi.server.ExportException
Constructs an ExportException with the specified detail message and nested exception.
exportNode(OutputStream) - Method in class java.util.prefs.AbstractPreferences
Implements the exportNode method as per the specification in Preferences.exportNode(OutputStream).
exportNode(OutputStream) - Method in class java.util.prefs.Preferences
Emits on the specified output stream an XML document representing all of the preferences contained in this node (but not its descendants).
exportObject(Remote, String, MarshalledObject<?>, boolean, int) - Static method in class java.rmi.activation.Activatable
Registers an activation descriptor (with the specified location, data, and restart mode) for the specified object, and exports that object with the specified port.
exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation.Activatable
Registers an activation descriptor (with the specified location, data, and restart mode) for the specified object, and exports that object with the specified port, and the specified client and server socket factories.
exportObject(Remote, ActivationID, int) - Static method in class java.rmi.activation.Activatable
Export the activatable remote object to the RMI runtime to make the object available to receive incoming calls.
exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation.Activatable
Export the activatable remote object to the RMI runtime to make the object available to receive incoming calls.
exportObject(Remote, Object) - Method in interface java.rmi.server.ServerRef
Creates a client stub object for the supplied Remote object.
exportObject(Remote) - Static method in class java.rmi.server.UnicastRemoteObject
Exports the remote object to make it available to receive incoming calls using an anonymous port.
exportObject(Remote, int) - Static method in class java.rmi.server.UnicastRemoteObject
Exports the remote object to make it available to receive incoming calls, using the particular supplied port.
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.server.UnicastRemoteObject
Exports the remote object to make it available to receive incoming calls, using a transport specified by the given socket factory.
exportObject(Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.exportObject(java.rmi.Remote).
exportObject(Remote) - Static method in class javax.rmi.PortableRemoteObject
Makes a server object ready to receive remote calls.
exportSubtree(OutputStream) - Method in class java.util.prefs.AbstractPreferences
Implements the exportSubtree method as per the specification in Preferences.exportSubtree(OutputStream).
exportSubtree(OutputStream) - Method in class java.util.prefs.Preferences
Emits an XML document representing all of the preferences contained in this node and all of its descendants.
exportToClipboard(JComponent, Clipboard, int) - Method in class javax.swing.TransferHandler
Causes a transfer from the given component to the given clipboard.
Expression - Class in java.beans
An Expression object represents a primitive expression in which a single method is applied to a target and a set of arguments to return a result - as in "a.getFoo()".
Expression(Object, String, Object[]) - Constructor for class java.beans.Expression
Creates a new Expression object for the specified target object to invoke the method specified by the name and by the array of arguments.
Expression(Object, Object, String, Object[]) - Constructor for class java.beans.Expression
Creates a new Expression object with the specified value for the specified target object to invoke the method specified by the name and by the array of arguments.
extendedOperation(ExtendedRequest) - Method in class javax.naming.ldap.InitialLdapContext
extendedOperation(ExtendedRequest) - Method in interface javax.naming.ldap.LdapContext
Performs an extended operation.
ExtendedRequest - Interface in javax.naming.ldap
This interface represents an LDAPv3 extended operation request as defined in RFC 2251.
ExtendedResponse - Interface in javax.naming.ldap
This interface represents an LDAP extended operation response as defined in RFC 2251.
ExtendedSSLSession - Class in javax.net.ssl
Extends the SSLSession interface to support additional session attributes.
ExtendedSSLSession() - Constructor for class javax.net.ssl.ExtendedSSLSession
Extension - Interface in java.security.cert
This interface represents an X.509 extension.
extension - Variable in enum javax.tools.JavaFileObject.Kind
The extension which (by convention) is normally used for this kind of file object.
EXTENSION_INSTALLATION - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-Name manifest attribute used for declaring dependencies on installed extensions.
EXTENSION_LIST - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-List manifest attribute used for declaring dependencies on installed extensions.
EXTENSION_NAME - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-Name manifest attribute used for declaring dependencies on installed extensions.
extent - Variable in class java.awt.geom.Arc2D.Double
The angular extent of the arc in degrees.
extent - Variable in class java.awt.geom.Arc2D.Float
The angular extent of the arc in degrees.
externalEntityDecl(String, String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report a parsed external entity declaration.
externalEntityDecl(String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2
Externalizable - Interface in java.io
Only the identity of the class of an Externalizable instance is written in the serialization stream and it is the responsibility of the class to save and restore the contents of its instances.
extract(Any) - Static method in class org.omg.CORBA.AnySeqHelper
extract(Any) - Static method in class org.omg.CORBA.BooleanSeqHelper
extract(Any) - Static method in class org.omg.CORBA.CharSeqHelper
extract(Any) - Static method in class org.omg.CORBA.CompletionStatusHelper
extract(Any) - Static method in class org.omg.CORBA.CurrentHelper
extract(Any) - Static method in class org.omg.CORBA.DefinitionKindHelper
extract(Any) - Static method in class org.omg.CORBA.DoubleSeqHelper
extract(Any) - Static method in class org.omg.CORBA.FieldNameHelper
extract(Any) - Static method in class org.omg.CORBA.FloatSeqHelper
extract(Any) - Static method in class org.omg.CORBA.IdentifierHelper
extract(Any) - Static method in class org.omg.CORBA.IDLTypeHelper
extract(Any) - Static method in class org.omg.CORBA.LongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.LongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.NameValuePairHelper
extract(Any) - Static method in class org.omg.CORBA.ObjectHelper
extract(Any) - Static method in class org.omg.CORBA.OctetSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ParameterModeHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyErrorHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyListHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyTypeHelper
extract(Any) - Static method in class org.omg.CORBA.RepositoryIdHelper
extract(Any) - Static method in class org.omg.CORBA.ServiceDetailHelper
extract(Any) - Static method in class org.omg.CORBA.ServiceInformationHelper
extract(Any) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
extract(Any) - Static method in class org.omg.CORBA.ShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA.StringSeqHelper
extract(Any) - Static method in class org.omg.CORBA.StringValueHelper
extract(Any) - Static method in class org.omg.CORBA.StructMemberHelper
extract(Any) - Static method in class org.omg.CORBA.ULongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ULongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.UnionMemberHelper
extract(Any) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
extract(Any) - Static method in class org.omg.CORBA.UShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ValueBaseHelper
extract(Any) - Static method in class org.omg.CORBA.ValueMemberHelper
extract(Any) - Static method in class org.omg.CORBA.VersionSpecHelper
extract(Any) - Static method in class org.omg.CORBA.VisibilityHelper
extract(Any) - Static method in class org.omg.CORBA.WCharSeqHelper
extract(Any) - Static method in class org.omg.CORBA.WrongTransactionHelper
extract(Any) - Static method in class org.omg.CORBA.WStringSeqHelper
extract(Any) - Static method in class org.omg.CORBA.WStringValueHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingIteratorHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingListHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingTypeHelper
extract(Any) - Static method in class org.omg.CosNaming.IstringHelper
extract(Any) - Static method in class org.omg.CosNaming.NameComponentHelper
extract(Any) - Static method in class org.omg.CosNaming.NameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
extract(Any) - Static method in class org.omg.DynamicAny.AnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynArrayHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynEnumHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynFixedHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynSequenceHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynStructHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynUnionHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynValueHelper
extract(Any) - Static method in class org.omg.DynamicAny.FieldNameHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameValuePairHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
extract(Any) - Static method in class org.omg.IOP.CodecFactoryHelper
extract(Any) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
extract(Any) - Static method in class org.omg.IOP.ComponentIdHelper
extract(Any) - Static method in class org.omg.IOP.IORHelper
extract(Any) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
extract(Any) - Static method in class org.omg.IOP.ProfileIdHelper
extract(Any) - Static method in class org.omg.IOP.ServiceContextHelper
extract(Any) - Static method in class org.omg.IOP.ServiceContextListHelper
extract(Any) - Static method in class org.omg.IOP.ServiceIdHelper
extract(Any) - Static method in class org.omg.IOP.TaggedComponentHelper
extract(Any) - Static method in class org.omg.IOP.TaggedProfileHelper
extract(Any) - Static method in class org.omg.Messaging.SyncScopeHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.CurrentHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
extract(Any) - Static method in class org.omg.PortableServer.CurrentHelper
extract(Any) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
extract(Any) - Static method in class org.omg.PortableServer.ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableServer.POAHelper
extract(Any) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer.ServantActivatorHelper
extract(Any) - Static method in class org.omg.PortableServer.ServantLocatorHelper
extract_any() - Method in class org.omg.CORBA.Any
Extracts the Any object in this Any object's value field.
extract_boolean() - Method in class org.omg.CORBA.Any
Extracts the boolean in this Any object's value field.
extract_char() - Method in class org.omg.CORBA.Any
Extracts the char in this Any object's value field.
extract_double() - Method in class org.omg.CORBA.Any
Extracts the double in this Any object's value field.
extract_fixed() - Method in class org.omg.CORBA.Any
Extracts the java.math.BigDecimal object in this Any object's value field.
extract_float() - Method in class org.omg.CORBA.Any
Extracts the float in this Any object's value field.
extract_long() - Method in class org.omg.CORBA.Any
Extracts the int in this Any object's value field.
extract_longlong() - Method in class org.omg.CORBA.Any
Extracts the long in this Any object's value field.
extract_Object() - Method in class org.omg.CORBA.Any
Extracts the org.omg.CORBA.Object in this Any object's value field.
extract_octet() - Method in class org.omg.CORBA.Any
Extracts the byte in this Any object's value field.
extract_Principal() - Method in class org.omg.CORBA.Any
Deprecated.
Deprecated by CORBA 2.2.
extract_short() - Method in class org.omg.CORBA.Any
Extracts the short in this Any object's value field.
extract_Streamable() - Method in class org.omg.CORBA.Any
Extracts a Streamable from this Any object's value field.
extract_string() - Method in class org.omg.CORBA.Any
Extracts the String object in this Any object's value field.
extract_TypeCode() - Method in class org.omg.CORBA.Any
Extracts the TypeCode object in this Any object's value field.
extract_ulong() - Method in class org.omg.CORBA.Any
Extracts the int in this Any object's value field.
extract_ulonglong() - Method in class org.omg.CORBA.Any
Extracts the long in this Any object's value field.
extract_ushort() - Method in class org.omg.CORBA.Any
Extracts the short in this Any object's value field.
extract_Value() - Method in class org.omg.CORBA.Any
Extracts the java.io.Serializable object in this Any object's value field.
extract_wchar() - Method in class org.omg.CORBA.Any
Extracts the char in this Any object's value field.
extract_wstring() - Method in class org.omg.CORBA.Any
Extracts the String object in this Any object's value field.
extractAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
extractContentAsDocument() - Method in interface javax.xml.soap.SOAPBody
Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
extractHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.
extraImageMetadataFormatClassNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the class names of any additional image metadata formats supported by this plug-in, initially null.
extraImageMetadataFormatNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the names of any additional image metadata formats supported by this plug-in, initially null.
extraMetadataFormatClassNames - Variable in class javax.imageio.metadata.IIOMetadata
An array of names of classes implementing IIOMetadataFormat and representing the metadata formats, other than the standard and native formats, that are supported by this plug-in, initialized to null and set via the constructor.
extraMetadataFormatNames - Variable in class javax.imageio.metadata.IIOMetadata
An array of names of formats, other than the standard and native formats, that are supported by this plug-in, initialized to null and set via the constructor.
extraStreamMetadataFormatClassNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the class names of any additional stream metadata formats supported by this plug-in, initially null.
extraStreamMetadataFormatNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the names of any additional stream metadata formats supported by this plug-in, initially null.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

rs)ragl,,,r mmeeescan


F-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

F0 - Static variable in class java.security.spec.RSAKeyGenParameterSpec
The public-exponent value F0 = 3.
F1 - Static variable in class java.awt.Event
The F1 function key, a non-ASCII action key.
F10 - Static variable in class java.awt.Event
The F10 function key, a non-ASCII action key.
F11 - Static variable in class java.awt.Event
The F11 function key, a non-ASCII action key.
F12 - Static variable in class java.awt.Event
The F12 function key, a non-ASCII action key.
F2 - Static variable in class java.awt.Event
The F2 function key, a non-ASCII action key.
F3 - Static variable in class java.awt.Event
The F3 function key, a non-ASCII action key.
F4 - Static variable in class java.awt.Event
The F4 function key, a non-ASCII action key.
F4 - Static variable in class java.security.spec.RSAKeyGenParameterSpec
The public exponent-value F4 = 65537.
F5 - Static variable in class java.awt.Event
The F5 function key, a non-ASCII action key.
F6 - Static variable in class java.awt.Event
The F6 function key, a non-ASCII action key.
F7 - Static variable in class java.awt.Event
The F7 function key, a non-ASCII action key.
F8 - Static variable in class java.awt.Event
The F8 function key, a non-ASCII action key.
F9 - Static variable in class java.awt.Event
The F9 function key, a non-ASCII action key.
FACE - Static variable in class javax.swing.text.html.HTML.Attribute
FactoryConfigurationError - Error in javax.xml.parsers
Thrown when a problem with configuration with the Parser Factories exists.
FactoryConfigurationError() - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with no detail mesage.
FactoryConfigurationError(String) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the String specified as an error message.
FactoryConfigurationError(Exception) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with a given Exception base cause of the error.
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the given Exception base cause and detail message.
FactoryConfigurationError - Error in javax.xml.stream
An error class for reporting factory configuration errors.
FactoryConfigurationError() - Constructor for error javax.xml.stream.FactoryConfigurationError
Default constructor
FactoryConfigurationError(Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String, Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with associated message
failed(Throwable, A) - Method in interface java.nio.channels.CompletionHandler
Invoked when an operation fails.
FAILED - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection-failed notification.
FailedLoginException - Exception in javax.security.auth.login
Signals that user authentication failed.
FailedLoginException() - Constructor for exception javax.security.auth.login.FailedLoginException
Constructs a FailedLoginException with no detail message.
FailedLoginException(String) - Constructor for exception javax.security.auth.login.FailedLoginException
Constructs a FailedLoginException with the specified detail message.
failure(Exception) - Method in interface java.rmi.server.RMIFailureHandler
The failure callback is invoked when the RMI runtime is unable to create a ServerSocket via the RMISocketFactory.
FAILURE - Static variable in exception org.ietf.jgss.GSSException
General failure, unspecified at GSS-API level.
FALSE - Static variable in class java.lang.Boolean
The Boolean object corresponding to the primitive value false.
FALSE - Static variable in interface java.util.jar.Pack200.Packer
The string "false", a possible value for certain properties.
FALSE - Static variable in interface java.util.jar.Pack200.Unpacker
The string "false", a possible value for certain properties.
FAMILY - Static variable in class java.awt.font.TextAttribute
Attribute key for the font name.
Family - Static variable in class javax.swing.text.StyleConstants
Name of the font family.
FATAL_ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
fatalError(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a non-recoverable error.
fatalError(SAXParseException) - Method in interface org.xml.sax.ErrorHandler
Receive notification of a non-recoverable error.
fatalError(SAXParseException) - Method in class org.xml.sax.HandlerBase
Deprecated.
Report a fatal XML parsing error.
fatalError(SAXParseException) - Method in class org.xml.sax.helpers.DefaultHandler
Report a fatal XML parsing error.
fatalError(SAXParseException) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a fatal error event.
FaultAction - Annotation Type in javax.xml.ws
The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.
fd - Variable in class java.net.DatagramSocketImpl
The file descriptor object.
fd - Variable in class java.net.SocketImpl
The file descriptor object for this socket.
FEATURE - Static variable in class javax.xml.transform.dom.DOMResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.dom.DOMSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
FEATURE - Static variable in class javax.xml.transform.stax.StAXResult
If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.stax.StAXSource
If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.stream.StreamResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.stream.StreamSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE_SECURE_PROCESSING - Static variable in class javax.xml.XMLConstants
Feature for secure processing.
FEATURE_XMLFILTER - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the SAXTransformerFactory.newXMLFilter(Source src) and SAXTransformerFactory.newXMLFilter(Templates templates) methods are supported.
FeatureDescriptor - Class in java.beans
The FeatureDescriptor class is the common baseclass for PropertyDescriptor, EventSetDescriptor, and MethodDescriptor, etc.
FeatureDescriptor() - Constructor for class java.beans.FeatureDescriptor
Constructs a FeatureDescriptor.
FEBRUARY - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the second month of the year in the Gregorian and Julian calendars.
FEBRUARY - Static variable in class javax.xml.datatype.DatatypeConstants
Value for second month of year.
FETCH_FORWARD - Static variable in interface java.sql.ResultSet
The constant indicating that the rows in a result set will be processed in a forward direction; first-to-last.
FETCH_REVERSE - Static variable in interface java.sql.ResultSet
The constant indicating that the rows in a result set will be processed in a reverse direction; last-to-first.
FETCH_UNKNOWN - Static variable in interface java.sql.ResultSet
The constant indicating that the order in which rows in a result set will be processed is unknown.
fetchNotifications(long, int, long) - Method in interface javax.management.remote.rmi.RMIConnection
Retrieves notifications from the connector server.
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi.RMIConnectionImpl
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
fictional() - Method in class javax.swing.text.html.parser.TagElement
Fidelity - Class in javax.print.attribute.standard
Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
Fidelity(int) - Constructor for class javax.print.attribute.standard.Fidelity
Construct a new fidelity enumeration value with the given integer value.
FIDELITY_FALSE - Static variable in class javax.print.attribute.standard.Fidelity
The printer should make reasonable attempts to print the job, even if it cannot print it exactly as specified.
FIDELITY_TRUE - Static variable in class javax.print.attribute.standard.Fidelity
The job must be printed exactly as specified.
Field - Class in java.lang.reflect
A Field provides information about, and dynamic access to, a single field of a class or an interface.
FIELD_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a field attribute name, indicates the format of that attribute.
FIELD_COUNT - Static variable in class java.util.Calendar
The number of distinct fields recognized by get and set.
FIELD_UNDEFINED - Static variable in class javax.xml.datatype.DatatypeConstants
Designation that an "int" field is not set.
fieldModifiers() - Static method in class java.lang.reflect.修饰符
Return an int value OR-ing together the source language modifiers that can be applied to a field.
FieldNameHelper - Class in org.omg.CORBA
The Helper for FieldName.
FieldNameHelper() - Constructor for class org.omg.CORBA.FieldNameHelper
FieldNameHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/FieldNameHelper.java .
FieldNameHelper() - Constructor for class org.omg.DynamicAny.FieldNameHelper
FieldPosition - Class in java.text
FieldPosition is a simple class used by Format and its subclasses to identify fields in formatted output.
FieldPosition(int) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field.
FieldPosition(Format.Field) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field constant.
FieldPosition(Format.Field, int) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field.
fields - Variable in class java.util.Calendar
The calendar field values for the currently set time for this calendar.
fieldsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of fields in elements.
fieldsIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of fields in elements.
FieldView - Class in javax.swing.text
Extends the multi-line plain text view to be suitable for a single-line editor view.
FieldView(Element) - Constructor for class javax.swing.text.FieldView
Constructs a new FieldView wrapped on an element.
FILE - Static variable in class java.awt.JobAttributes.DestinationType
The DestinationType instance to use for specifying print to file.
File - Class in java.io
An abstract representation of file and directory pathnames.
File(String) - Constructor for class java.io.File
Creates a new File instance by converting the given pathname string into an abstract pathname.
File(String, String) - Constructor for class java.io.File
Creates a new File instance from a parent pathname string and a child pathname string.
File(File, String) - Constructor for class java.io.File
Creates a new File instance from a parent abstract pathname and a child pathname string.
File(URI) - Constructor for class java.io.File
Creates a new File instance by converting the given file: URI into an abstract pathname.
file() - Method in class java.lang.ProcessBuilder.Redirect
Returns the File source or destination associated with this redirect, or null if there is no such file.
FILE - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
Host-specific file names.
FILE_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A specialized dialog that displays the files in the directory and lets the user select a file, browse a different directory, or specify a filename.
FILE_CHOOSER - Static variable in class javax.swing.plaf.synth.Region
FileChooser region.
FILE_CHOOSER_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
User changed the kind of files to display.
FILE_HIDING_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the display-hidden-files property.
FILE_SELECTION_MODE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the kind of selection (single, multiple, etc.).
FILE_SYSTEM_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different object is being used to find available drives on the system.
FILE_VERSION - Static variable in class javax.swing.text.html.parser.DTD
FILE_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different object is being used to retrieve file information.
FileAlreadyExistsException - Exception in java.nio.file
Checked exception thrown when an attempt is made to create a file or directory and a file of that name already exists.
FileAlreadyExistsException(String) - Constructor for exception java.nio.file.FileAlreadyExistsException
Constructs an instance of this class.
FileAlreadyExistsException(String, String, String) - Constructor for exception java.nio.file.FileAlreadyExistsException
Constructs an instance of this class.
FileAttribute<T> - Interface in java.nio.file.attribute
An object that encapsulates the value of a file attribute that can be set atomically when creating a new file or directory by invoking the createFile or createDirectory methods.
FileAttributeView - Interface in java.nio.file.attribute
An attribute view that is a read-only or updatable view of non-opaque values associated with a file in a filesystem.
FileCacheImageInputStream - Class in javax.imageio.stream
An implementation of ImageInputStream that gets its input from a regular InputStream.
FileCacheImageInputStream(InputStream, File) - Constructor for class javax.imageio.stream.FileCacheImageInputStream
Constructs a FileCacheImageInputStream that will read from a given InputStream.
FileCacheImageOutputStream - Class in javax.imageio.stream
An implementation of ImageOutputStream that writes its output to a regular OutputStream.
FileCacheImageOutputStream(OutputStream, File) - Constructor for class javax.imageio.stream.FileCacheImageOutputStream
Constructs a FileCacheImageOutputStream that will write to a given outputStream.
FileChannel - Class in java.nio.channels
A channel for reading, writing, mapping, and manipulating a file.
FileChannel() - Constructor for class java.nio.channels.FileChannel
Initializes a new instance of this class.
FileChannel.MapMode - Class in java.nio.channels
A typesafe enumeration for file-mapping modes.
FileChooserUI - Class in javax.swing.plaf
Pluggable look and feel interface for JFileChooser.
FileChooserUI() - Constructor for class javax.swing.plaf.FileChooserUI
FileDataSource - Class in javax.activation
The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileDataSource(File) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from a File object.
FileDataSource(String) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from the specified path name.
FileDescriptor - Class in java.io
Instances of the file descriptor class serve as an opaque handle to the underlying machine-specific structure representing an open file, an open socket, or another source or sink of bytes.
FileDescriptor() - Constructor for class java.io.FileDescriptor
Constructs an (invalid) FileDescriptor object.
FileDialog - Class in java.awt
The FileDialog class displays a dialog window from which the user can select a file.
FileDialog(Frame) - Constructor for class java.awt.FileDialog
Creates a file dialog for loading a file.
FileDialog(Frame, String) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading a file.
FileDialog(Frame, String, int) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading or saving a file.
FileDialog(Dialog) - Constructor for class java.awt.FileDialog
Creates a file dialog for loading a file.
FileDialog(Dialog, String) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading a file.
FileDialog(Dialog, String, int) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading or saving a file.
FileFilter - Interface in java.io
A filter for abstract pathnames.
FileFilter - Class in javax.swing.filechooser
FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
FileFilter() - Constructor for class javax.swing.filechooser.FileFilter
FileHandler - Class in java.util.logging
Simple file logging Handler.
FileHandler() - Constructor for class java.util.logging.FileHandler
Construct a default FileHandler.
FileHandler(String) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to the given filename.
FileHandler(String, boolean) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to the given filename, with optional append.
FileHandler(String, int, int) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to a set of files.
FileHandler(String, int, int, boolean) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to a set of files with optional append.
fileIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
FileImageInputStream - Class in javax.imageio.stream
An implementation of ImageInputStream that gets its input from a File or RandomAccessFile.
FileImageInputStream(File) - Constructor for class javax.imageio.stream.FileImageInputStream
Constructs a FileImageInputStream that will read from a given File.
FileImageInputStream(RandomAccessFile) - Constructor for class javax.imageio.stream.FileImageInputStream
Constructs a FileImageInputStream that will read from a given RandomAccessFile.
FileImageOutputStream - Class in javax.imageio.stream
An implementation of ImageOutputStream that writes its output directly to a File or RandomAccessFile.
FileImageOutputStream(File) - Constructor for class javax.imageio.stream.FileImageOutputStream
Constructs a FileImageOutputStream that will write to a given File.
FileImageOutputStream(RandomAccessFile) - Constructor for class javax.imageio.stream.FileImageOutputStream
Constructs a FileImageOutputStream that will write to a given RandomAccessFile.
FileInputStream - Class in java.io
A FileInputStream obtains input bytes from a file in a file system.
FileInputStream(String) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by opening a connection to an actual file, the file named by the path name name in the file system.
FileInputStream(File) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by opening a connection to an actual file, the file named by the File object file in the file system.
FileInputStream(FileDescriptor) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by using the file descriptor fdObj, which represents an existing connection to an actual file in the file system.
fileKey() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns an object that uniquely identifies the given file, or null if a file key is not available.
FileLock - Class in java.nio.channels
A token representing a lock on a region of a file.
FileLock(FileChannel, long, long, boolean) - Constructor for class java.nio.channels.FileLock
Initializes a new instance of this class.
FileLock(AsynchronousFileChannel, long, long, boolean) - Constructor for class java.nio.channels.FileLock
Initializes a new instance of this class.
FileLockInterruptionException - Exception in java.nio.channels
Checked exception received by a thread when another thread interrupts it while it is waiting to acquire a file lock.
FileLockInterruptionException() - Constructor for exception java.nio.channels.FileLockInterruptionException
Constructs an instance of this class.
fileManager - Variable in class javax.tools.ForwardingJavaFileManager
The file manager which all methods are delegated to.
FILENAME - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that is the name of the file being executed.
FileNameExtensionFilter - Class in javax.swing.filechooser
An implementation of FileFilter that filters using a specified set of extensions.
FileNameExtensionFilter(String, String...) - Constructor for class javax.swing.filechooser.FileNameExtensionFilter
Creates a FileNameExtensionFilter with the specified description and file name extensions.
FilenameFilter - Interface in java.io
Instances of classes that implement this interface are used to filter filenames.
FileNameMap - Interface in java.net
A simple interface which provides a mechanism to map between a file name and a MIME type string.
FileNotFoundException - Exception in java.io
Signals that an attempt to open the file denoted by a specified pathname has failed.
FileNotFoundException() - Constructor for exception java.io.FileNotFoundException
Constructs a FileNotFoundException with null as its error detail message.
FileNotFoundException(String) - Constructor for exception java.io.FileNotFoundException
Constructs a FileNotFoundException with the specified detail message.
FileObject - Interface in javax.tools
File abstraction for tools.
fileObject - Variable in class javax.tools.ForwardingFileObject
The file object which all methods are delegated to.
FileOutputStream - Class in java.io
A file output stream is an output stream for writing data to a File or to a FileDescriptor.
FileOutputStream(String) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file with the specified name.
FileOutputStream(String, boolean) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file with the specified name.
FileOutputStream(File) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file represented by the specified File object.
FileOutputStream(File, boolean) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file represented by the specified File object.
FileOutputStream(FileDescriptor) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the specified file descriptor, which represents an existing connection to an actual file in the file system.
FileOwnerAttributeView - Interface in java.nio.file.attribute
A file attribute view that supports reading or updating the owner of a file.
FilePermission - Class in java.io
This class represents access to a file or directory.
FilePermission(String, String) - Constructor for class java.io.FilePermission
Creates a new FilePermission object with the specified actions.
Filer - Interface in javax.annotation.processing
This interface supports the creation of new files by an annotation processor.
FileReader - Class in java.io
Convenience class for reading character files.
FileReader(String) - Constructor for class java.io.FileReader
Creates a new FileReader, given the name of the file to read from.
FileReader(File) - Constructor for class java.io.FileReader
Creates a new FileReader, given the File to read from.
FileReader(FileDescriptor) - Constructor for class java.io.FileReader
Creates a new FileReader, given the FileDescriptor to read from.
FilerException - Exception in javax.annotation.processing
Indicates a Filer detected an attempt to open a file that would violate the guarantees provided by the Filer.
FilerException(String) - Constructor for exception javax.annotation.processing.FilerException
Constructs an exception with the specified detail message.
Files - Class in java.nio.file
This class consists exclusively of static methods that operate on files, directories, or other types of files.
FILES_AND_DIRECTORIES - Static variable in class javax.swing.JFileChooser
Instruction to display both files and directories.
FILES_ONLY - Static variable in class javax.swing.JFileChooser
Instruction to display only files.
FileStore - Class in java.nio.file
Storage for files.
FileStore() - Constructor for class java.nio.file.FileStore
Initializes a new instance of this class.
FileStoreAttributeView - Interface in java.nio.file.attribute
An attribute view that is a read-only or updatable view of the attributes of a FileStore.
FileSystem - Class in java.nio.file
Provides an interface to a file system and is the factory for objects to access files and other objects in the file system.
FileSystem() - Constructor for class java.nio.file.FileSystem
Initializes a new instance of this class.
FileSystemAlreadyExistsException - Exception in java.nio.file
Runtime exception thrown when an attempt is made to create a file system that already exists.
FileSystemAlreadyExistsException() - Constructor for exception java.nio.file.FileSystemAlreadyExistsException
Constructs an instance of this class.
FileSystemAlreadyExistsException(String) - Constructor for exception java.nio.file.FileSystemAlreadyExistsException
Constructs an instance of this class.
FileSystemException - Exception in java.nio.file
Thrown when a file system operation fails on one or two files.
FileSystemException(String) - Constructor for exception java.nio.file.FileSystemException
Constructs an instance of this class.
FileSystemException(String, String, String) - Constructor for exception java.nio.file.FileSystemException
Constructs an instance of this class.
FileSystemLoopException - Exception in java.nio.file
Checked exception thrown when a file system loop, or cycle, is encountered.
FileSystemLoopException(String) - Constructor for exception java.nio.file.FileSystemLoopException
Constructs an instance of this class.
FileSystemNotFoundException - Exception in java.nio.file
Runtime exception thrown when a file system cannot be found.
FileSystemNotFoundException() - Constructor for exception java.nio.file.FileSystemNotFoundException
Constructs an instance of this class.
FileSystemNotFoundException(String) - Constructor for exception java.nio.file.FileSystemNotFoundException
Constructs an instance of this class.
FileSystemProvider - Class in java.nio.file.spi
Service-provider class for file systems.
FileSystemProvider() - Constructor for class java.nio.file.spi.FileSystemProvider
Initializes a new instance of this class.
FileSystems - Class in java.nio.file
Factory methods for file systems.
FileSystemView - Class in javax.swing.filechooser
FileSystemView is JFileChooser's gateway to the file system.
FileSystemView() - Constructor for class javax.swing.filechooser.FileSystemView
FileTime - Class in java.nio.file.attribute
Represents the value of a file's time stamp attribute.
FileTypeDetector - Class in java.nio.file.spi
A file type detector for probing a file to guess its file type.
FileTypeDetector() - Constructor for class java.nio.file.spi.FileTypeDetector
Initializes a new instance of this class.
FileTypeMap - Class in javax.activation
The FileTypeMap is an abstract class that provides a data typing interface for files.
FileTypeMap() - Constructor for class javax.activation.FileTypeMap
The default constructor.
FileView - Class in javax.swing.filechooser
FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
FileView() - Constructor for class javax.swing.filechooser.FileView
FileVisitOption - Enum in java.nio.file
Defines the file tree traversal options.
FileVisitor<T> - Interface in java.nio.file
A visitor of files.
FileVisitResult - Enum in java.nio.file
The result type of a FileVisitor.
FileWriter - Class in java.io
Convenience class for writing character files.
FileWriter(String) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a file name.
FileWriter(String, boolean) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a file name with a boolean indicating whether or not to append the data written.
FileWriter(File) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a File object.
FileWriter(File, boolean) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a File object.
FileWriter(FileDescriptor) - Constructor for class java.io.FileWriter
Constructs a FileWriter object associated with a file descriptor.
FILL - Static variable in class java.awt.font.ShapeGraphicAttribute
A key indicating the shape should be filled.
fill(Shape) - Method in class java.awt.Graphics2D
Fills the interior of a Shape using the settings of the Graphics2D context.
fill - Variable in class java.awt.GridBagConstraints
This field is used when the component's display area is larger than the component's requested size.
fill(long[], long) - Static method in class java.util.Arrays
Assigns the specified long value to each element of the specified array of longs.
fill(long[], int, int, long) - Static method in class java.util.Arrays
Assigns the specified long value to each element of the specified range of the specified array of longs.
fill(int[], int) - Static method in class java.util.Arrays
Assigns the specified int value to each element of the specified array of ints.
fill(int[], int, int, int) - Static method in class java.util.Arrays
Assigns the specified int value to each element of the specified range of the specified array of ints.
fill(short[], short) - Static method in class java.util.Arrays
Assigns the specified short value to each element of the specified array of shorts.
fill(short[], int, int, short) - Static method in class java.util.Arrays
Assigns the specified short value to each element of the specified range of the specified array of shorts.
fill(char[], char) - Static method in class java.util.Arrays
Assigns the specified char value to each element of the specified array of chars.
fill(char[], int, int, char) - Static method in class java.util.Arrays
Assigns the specified char value to each element of the specified range of the specified array of chars.
fill(byte[], byte) - Static method in class java.util.Arrays
Assigns the specified byte value to each element of the specified array of bytes.
fill(byte[], int, int, byte) - Static method in class java.util.Arrays
Assigns the specified byte value to each element of the specified range of the specified array of bytes.
fill(boolean[], boolean) - Static method in class java.util.Arrays
Assigns the specified boolean value to each element of the specified array of booleans.
fill(boolean[], int, int, boolean) - Static method in class java.util.Arrays
Assigns the specified boolean value to each element of the specified range of the specified array of booleans.
fill(double[], double) - Static method in class java.util.Arrays
Assigns the specified double value to each element of the specified array of doubles.
fill(double[], int, int, double) - Static method in class java.util.Arrays
Assigns the specified double value to each element of the specified range of the specified array of doubles.
fill(float[], float) - Static method in class java.util.Arrays
Assigns the specified float value to each element of the specified array of floats.
fill(float[], int, int, float) - Static method in class java.util.Arrays
Assigns the specified float value to each element of the specified range of the specified array of floats.
fill(Object[], Object) - Static method in class java.util.Arrays
Assigns the specified Object reference to each element of the specified array of Objects.
fill(Object[], int, int, Object) - Static method in class java.util.Arrays
Assigns the specified Object reference to each element of the specified range of the specified array of Objects.
fill(List<? super T>, T) - Static method in class java.util.Collections
Replaces all of the elements of the specified list with the specified element.
fill() - Method in class java.util.zip.InflaterInputStream
Fills input buffer with more data to decompress.
fill3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics
Paints a 3-D highlighted rectangle filled with the current color.
fill3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics2D
Paints a 3-D highlighted rectangle filled with the current color.
fill3DRect(int, int, int, int, boolean) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fill3DRect.
fillArc(int, int, int, int, int, int) - Method in class java.awt.Graphics
Fills a circular or elliptical arc covering the specified rectangle.
fillArc(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillArc.
filledSlider - Variable in class javax.swing.plaf.metal.MetalSliderUI
FILLER - Static variable in class javax.accessibility.AccessibleRole
An object that fills up space in a user interface.
fillInStackTrace() - Method in class java.lang.Throwable
Fills in the execution stack trace.
fillOval(int, int, int, int) - Method in class java.awt.Graphics
Fills an oval bounded by the specified rectangle with the current color.
fillOval(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillOval.
fillPolygon(int[], int[], int) - Method in class java.awt.Graphics
Fills a closed polygon defined by arrays of x and y coordinates.
fillPolygon(Polygon) - Method in class java.awt.Graphics
Fills the polygon defined by the specified Polygon object with the graphics context's current color.
fillPolygon(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillPolygon.
fillRect(int, int, int, int) - Method in class java.awt.Graphics
Fills the specified rectangle.
fillRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillRect.
fillRoundRect(int, int, int, int, int, int) - Method in class java.awt.Graphics
Fills the specified rounded corner rectangle with the current color.
fillRoundRect(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillRoundRect.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.AffineTransformOp
Transforms the source BufferedImage and stores the results in the destination BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.AffineTransformOp
Transforms the source Raster and stores the results in the destination Raster.
filter(Raster, WritableRaster) - Method in class java.awt.image.BandCombineOp
Transforms the Raster using the matrix specified in the constructor.
filter(BufferedImage, BufferedImage) - Method in interface java.awt.image.BufferedImageOp
Performs a single-input/single-output operation on a BufferedImage.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.ColorConvertOp
ColorConverts the source BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.ColorConvertOp
ColorConverts the image data in the source Raster.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.ConvolveOp
Performs a convolution on BufferedImages.
filter(Raster, WritableRaster) - Method in class java.awt.image.ConvolveOp
Performs a convolution on Rasters.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.LookupOp
Performs a lookup operation on a BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.LookupOp
Performs a lookup operation on a Raster.
filter(Raster, WritableRaster) - Method in interface java.awt.image.RasterOp
Performs a single-input/single-output operation from a source Raster to a destination Raster.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.RescaleOp
Rescales the source BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.RescaleOp
Rescales the pixel data in the source Raster.
Filter - Interface in java.util.logging
A Filter can be used to provide fine grain control over what is logged, beyond the control provided by log levels.
filter(Object) - Method in interface javax.imageio.spi.ServiceRegistry.Filter
Returns true if the given provider object matches the criterion defined by this Filter.
FILTER_ACCEPT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Accept the node.
FILTER_INTERRUPT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Interrupt the normal processing of the document.
FILTER_REJECT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Reject the node and its children.
FILTER_SKIP - Static variable in interface org.w3c.dom.ls.LSParserFilter
Skip this single node.
filterArguments(MethodHandle, int, MethodHandle...) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle target by pre-processing one or more of its arguments, each with its own unary filter function, and then calling the target with each pre-processed argument replaced by the result of its corresponding filter function.
FILTERED - Static variable in class java.util.zip.Deflater
Compression strategy best used for data consisting mostly of small values with a somewhat random distribution.
FilteredImageSource - Class in java.awt.image
This class is an implementation of the ImageProducer interface which takes an existing image and a filter object and uses them to produce image data for a new filtered version of the original image.
FilteredImageSource(ImageProducer, ImageFilter) - Constructor for class java.awt.image.FilteredImageSource
Constructs an ImageProducer object from an existing ImageProducer and a filter object.
FilteredRowSet - Interface in javax.sql.rowset
The standard interface that all standard implementations of FilteredRowSet must implement.
filterIndexColorModel(IndexColorModel) - Method in class java.awt.image.RGBImageFilter
Filters an IndexColorModel object by running each entry in its color tables through the filterRGB function that RGBImageFilter subclasses must provide.
FilterInputStream - Class in java.io
A FilterInputStream contains some other input stream, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality.
FilterInputStream(InputStream) - Constructor for class java.io.FilterInputStream
Creates a FilterInputStream by assigning the argument in to the field this.in so as to remember it for later use.
FilterOutputStream - Class in java.io
This class is the superclass of all classes that filter output streams.
FilterOutputStream(OutputStream) - Constructor for class java.io.FilterOutputStream
Creates an output stream filter built on top of the specified underlying output stream.
FilterReader - Class in java.io
Abstract class for reading filtered character streams.
FilterReader(Reader) - Constructor for class java.io.FilterReader
Creates a new filtered reader.
filterReturnValue(MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle target by post-processing its return value with a unary filter function.
filterRGB(int, int, int) - Method in class java.awt.image.RGBImageFilter
Subclasses must specify a method to convert a single input pixel in the default RGB ColorModel to a single output pixel.
filterRGB(int, int, int) - Method in class javax.swing.GrayFilter
Overrides RGBImageFilter.filterRGB.
filterRGBPixels(int, int, int, int, int[], int, int) - Method in class java.awt.image.RGBImageFilter
Filters a buffer of pixels in the default RGB ColorModel by passing them one by one through the filterRGB method.
filters - Variable in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
FilterWriter - Class in java.io
Abstract class for writing filtered character streams.
FilterWriter(Writer) - Constructor for class java.io.FilterWriter
Create a new filtered writer.
FINAL - Static variable in class java.lang.reflect.修饰符
The int value representing the final modifier.
FINAL_QUOTE_PUNCTUATION - Static variable in class java.lang.Character
General category "Pf" in the Unicode specification.
finalize() - Method in class java.awt.color.ICC_Profile
Frees the resources associated with an ICC_Profile object.
finalize() - Method in class java.awt.Graphics
Disposes of this graphics context once it is no longer referenced.
finalize() - Method in class java.awt.image.ColorModel
Disposes of system resources associated with this ColorModel once this ColorModel is no longer referenced.
finalize() - Method in class java.awt.image.IndexColorModel
Disposes of system resources associated with this ColorModel once this ColorModel is no longer referenced.
finalize() - Method in class java.awt.PrintJob
Ends this print job once it is no longer referenced.
finalize() - Method in class java.io.FileInputStream
Ensures that the close method of this file input stream is called when there are no more references to it.
finalize() - Method in class java.io.FileOutputStream
Cleans up the connection to the file, and ensures that the close method of this file output stream is called when there are no more references to this stream.
finalize() - Method in class java.lang.Enum
enum classes cannot have finalize methods.
finalize() - Method in class java.lang.Object
Called by the garbage collector on an object when garbage collection determines that there are no more references to the object.
finalize() - Method in class java.util.concurrent.ThreadPoolExecutor
Invokes shutdown when this executor is no longer referenced and it has no threads.
finalize() - Method in class java.util.zip.Deflater
Closes the compressor when garbage is collected.
finalize() - Method in class java.util.zip.Inflater
Closes the decompressor when garbage is collected.
finalize() - Method in class java.util.zip.ZipFile
Ensures that the close method of this ZIP file is called when there are no more references to it.
finalize() - Method in class javax.crypto.ExemptionMechanism
Ensures that the key stored away by this ExemptionMechanism object will be wiped out when there are no more references to it.
finalize() - Method in class javax.imageio.spi.ServiceRegistry
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileCacheImageInputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileImageInputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileImageOutputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.ImageInputStreamImpl
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Finalizes this object prior to garbage collection.
finalSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
find() - Method in class java.util.regex.Matcher
Attempts to find the next subsequence of the input sequence that matches the pattern.
find(int) - Method in class java.util.regex.Matcher
Resets this matcher and then attempts to find the next subsequence of the input sequence that matches the pattern, starting at the specified index.
find_POA(String, boolean) - Method in interface org.omg.PortableServer.POAOperations
If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
findAssociatedMBeans(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the MBeans associated to given one in a relation.
findAssociatedMBeans(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the MBeans associated to given one in a relation.
findClass(String) - Method in class java.lang.ClassLoader
Finds the class with the specified binary name.
findClass(String) - Method in class java.net.URLClassLoader
Finds and loads the class with the specified name from the URL search path.
findClass(String) - Method in class javax.management.loading.MLet
This is the main method for class loaders that is being redefined.
findColumn(String) - Method in interface java.sql.ResultSet
Maps the given ResultSet column label to its ResultSet column index.
findColumn(String) - Method in class javax.swing.table.AbstractTableModel
Returns a column given its name.
findComponentAt(int, int) - Method in class java.awt.Container
Locates the visible child component that contains the specified position.
findComponentAt(Point) - Method in class java.awt.Container
Locates the visible child component that contains the specified point.
findConstructor(Class<?>, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle which creates an object and initializes it, using the constructor of the specified type.
findDeadlockedThreads() - Method in interface java.lang.management.ThreadMXBean
Finds cycles of threads that are in deadlock waiting to acquire object monitors or ownable synchronizers.
findEditor(Class<?>) - Static method in class java.beans.PropertyEditorManager
Locate a value editor for a given target type.
findElementMatchingTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
Returns the deepest element at offset matching tag.
findFocusOwner(Component) - Static method in class javax.swing.SwingUtilities
Deprecated.
As of 1.4, replaced by KeyboardFocusManager.getFocusOwner().
findGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving read access to a non-static field.
findInLine(String) - Method in class java.util.Scanner
Attempts to find the next occurrence of a pattern constructed from the specified string, ignoring delimiters.
findInLine(Pattern) - Method in class java.util.Scanner
Attempts to find the next occurrence of the specified pattern ignoring delimiters.
findLibrary(String) - Method in class java.lang.ClassLoader
Returns the absolute path name of a native library.
findLibrary(String) - Method in class javax.management.loading.MLet
Returns the absolute path name of a native library.
findLoadedClass(String) - Method in class java.lang.ClassLoader
Returns the class with the given binary name if this loader has been recorded by the Java virtual machine as an initiating loader of a class with that binary name.
findMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a list of registered MBeanServer objects.
findMedia(float, float, int) - Static method in class javax.print.attribute.standard.MediaSize
The specified dimensions are used to locate a matching MediaSize instance from amongst all the standard MediaSize instances.
findMonitorDeadlockedThreads() - Method in interface java.lang.management.ThreadMXBean
Finds cycles of threads that are in deadlock waiting to acquire object monitors.
findOffsetToCharactersInString(char[], int) - Method in class javax.swing.text.ParagraphView
Finds the next character in the document with a character in string, starting at offset start.
findReferencingRelations(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the relations where a given MBean is referenced.
findReferencingRelations(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the relations where a given MBean is referenced.
findRelationsOfType(String) - Method in class javax.management.relation.RelationService
Returns the relation ids for relations of the given type.
findRelationsOfType(String) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation ids for relations of the given type.
findResource(String) - Method in class java.lang.ClassLoader
Finds the resource with the given name.
findResource(String) - Method in class java.net.URLClassLoader
Finds the resource with the specified name on the URL search path.
findResources(String) - Method in class java.lang.ClassLoader
Returns an enumeration of URL objects representing all the resources with the given name.
findResources(String) - Method in class java.net.URLClassLoader
Returns an Enumeration of URLs representing all of the resources on the URL search path having the specified name.
findSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving write access to a non-static field.
findSpecial(Class<?>, String, MethodType, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces an early-bound method handle for a virtual method, as if called from an invokespecial instruction from caller.
findStatic(Class<?>, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a static method.
findStaticGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving read access to a static field.
findStaticSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving write access to a static field.
findSystemClass(String) - Method in class java.lang.ClassLoader
Finds a class with the specified binary name, loading it if necessary.
findVirtual(Class<?>, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a virtual method.
findWithinHorizon(String, int) - Method in class java.util.Scanner
Attempts to find the next occurrence of a pattern constructed from the specified string, ignoring delimiters.
findWithinHorizon(Pattern, int) - Method in class java.util.Scanner
Attempts to find the next occurrence of the specified pattern.
FINE - Static variable in class java.util.logging.Level
FINE is a message level providing tracing information.
fine(String) - Method in class java.util.logging.Logger
Log a FINE message.
FINER - Static variable in class java.util.logging.Level
FINER indicates a fairly detailed tracing message.
finer(String) - Method in class java.util.logging.Logger
Log a FINER message.
FINEST - Static variable in class java.util.logging.Level
FINEST indicates a highly detailed tracing message.
finest(String) - Method in class java.util.logging.Logger
Log a FINEST message.
finish() - Method in class java.util.zip.Deflater
When called, indicates that compression should end with the current contents of the input buffer.
finish() - Method in class java.util.zip.DeflaterOutputStream
Finishes writing compressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.GZIPOutputStream
Finishes writing compressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.InflaterOutputStream
Finishes writing uncompressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.ZipOutputStream
Finishes writing the contents of the ZIP output stream without closing the underlying stream.
finishConnect() - Method in class java.nio.channels.SocketChannel
Finishes the process of connecting a socket channel.
finishDraggingTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Messages the BasicSplitPaneUI with finishDraggingTo that this instance is contained in.
finishDraggingTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Messaged to finish the dragging session.
finished() - Method in class java.util.zip.Deflater
Returns true if the end of the compressed data output stream has been reached.
finished() - Method in class java.util.zip.Inflater
Returns true if the end of the compressed data stream has been reached.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Called when the specified split pane has finished painting its children.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the finishedPaintingChildren method on each UI handled by this object.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.SplitPaneUI
Messaged after the JSplitPane the receiver is providing the look and feel for paints its children.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Finishings - Class in javax.print.attribute.standard
Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
Finishings(int) - Constructor for class javax.print.attribute.standard.Finishings
Construct a new finishings binding enumeration value with the given integer value.
fireActionEvent() - Method in class javax.swing.JComboBox
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(String) - Method in class javax.swing.JFileChooser
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed() - Method in class javax.swing.JTextField
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.Timer
Notifies all listeners that have registered interest for notification on this event type.
fireAdjustmentValueChanged(int, int, int) - Method in class javax.swing.JScrollBar
Notify listeners that the scrollbar's model has changed.
fireCaretUpdate(CaretEvent) - Method in class javax.swing.text.JTextComponent
Notifies all listeners that have registered interest for notification on this event type.
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text.html.HTMLDocument
Notifies all listeners that have registered interest for notification on this event type.
fireChildrenAdded(BeanContextMembershipEvent) - Method in class java.beans.beancontext.BeanContextSupport
Fire a BeanContextshipEvent on the BeanContextMembershipListener interface
fireChildrenRemoved(BeanContextMembershipEvent) - Method in class java.beans.beancontext.BeanContextSupport
Fire a BeanContextshipEvent on the BeanContextMembershipListener interface
fireColumnAdded(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnMarginChanged() - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnMoved(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnRemoved(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireContentsChanged(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements of the list change.
fireContentsChanged() - Method in class javax.swing.plaf.basic.BasicDirectoryModel
fireDragGestureRecognized(int, Point) - Method in class java.awt.dnd.DragGestureRecognizer
Notify the DragGestureListener that a Drag and Drop initiating gesture has occurred.
fireEditingCanceled() - Method in class javax.swing.AbstractCellEditor
Notifies all listeners that have registered interest for notification on this event type.
fireEditingStopped() - Method in class javax.swing.AbstractCellEditor
Notifies all listeners that have registered interest for notification on this event type.
fireHyperlinkUpdate(HyperlinkEvent) - Method in class javax.swing.JEditorPane
Notifies all listeners that have registered interest for notification on this event type.
fireIndexedPropertyChange(String, int, Object, Object) - Method in class java.beans.PropertyChangeSupport
Reports a bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireIndexedPropertyChange(String, int, int, int) - Method in class java.beans.PropertyChangeSupport
Reports an integer bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireIndexedPropertyChange(String, int, boolean, boolean) - Method in class java.beans.PropertyChangeSupport
Reports a boolean bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireInsertUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireInternalFrameEvent(int) - Method in class javax.swing.JInternalFrame
Fires an internal frame event.
fireIntervalAdded(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements are added to the model.
fireIntervalRemoved(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements are removed from the model.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.JComboBox
Notifies all listeners that have registered interest for notification on this event type.
fireMenuCanceled() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDeselected() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseDragged(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseEntered(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseExited(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseReleased(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyPressed(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyReleased(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyTyped(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuSelected() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
firePopupMenuCanceled() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box has been canceled.
firePopupMenuCanceled() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu is cancelled.
firePopupMenuCanceled() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box has become invisible.
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu will become invisible.
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePopupMenuWillBecomeVisible() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box will become visible.
firePopupMenuWillBecomeVisible() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu will become visible.
firePopupMenuWillBecomeVisible() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePropertyChange(String, Object, Object) - Method in class java.awt.Component
Support for reporting bound property changes for Object properties.
firePropertyChange(String, boolean, boolean) - Method in class java.awt.Component
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, int, int) - Method in class java.awt.Component
Support for reporting bound property changes for integer properties.
firePropertyChange(String, byte, byte) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, char, char) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, short, short) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, long, long) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, float, float) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, double, double) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, Object, Object) - Method in class java.awt.KeyboardFocusManager
Fires a PropertyChangeEvent in response to a change in a bound property.
firePropertyChange(String, Object, Object) - Method in class java.beans.beancontext.BeanContextChildSupport
Report a bound property update to any registered listeners.
firePropertyChange(String, Object, Object) - Method in class java.beans.PropertyChangeSupport
Reports a bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, int, int) - Method in class java.beans.PropertyChangeSupport
Reports an integer bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, boolean, boolean) - Method in class java.beans.PropertyChangeSupport
Reports a boolean bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(PropertyChangeEvent) - Method in class java.beans.PropertyChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange() - Method in class java.beans.PropertyEditorSupport
Report that we have been modified to any interested listeners.
firePropertyChange(String, Object, Object) - Method in class javax.accessibility.AccessibleContext
Support for reporting bound property changes.
firePropertyChange(String, Object, Object) - Method in class javax.swing.AbstractAction
Supports reporting bound property changes.
firePropertyChange(String, Object, Object) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, byte, byte) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, char, char) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, short, short) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, int, int) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, long, long) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, float, float) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, double, double) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(PropertyChangeEvent) - Method in class javax.swing.event.SwingPropertyChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.JComponent
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, int, int) - Method in class javax.swing.JComponent
Support for reporting bound property changes for integer properties.
firePropertyChange(String, char, char) - Method in class javax.swing.JComponent
firePropertyChange(String, Object, Object) - Method in class javax.swing.JViewport
Notifies listeners of a property change.
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf.LayerUI
Support for reporting bound property changes for Object properties.
firePropertyChange(String, Object, Object) - Method in class javax.swing.SwingWorker
Reports a bound property update to any registered listeners.
firePropertyChange(String, Object, Object) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
firePropertyChange(String, Object, Object) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, byte, byte) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, char, char) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, short, short) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, int, int) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, long, long) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, float, float) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, double, double) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, Object, Object) - Method in class javax.swing.UIDefaults
Support for reporting bound property changes.
fireRemoveUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireRowSorterChanged(int[]) - Method in class javax.swing.RowSorter
Notifies listener that the mapping has changed.
fireSelectionValueChanged(int, int, boolean) - Method in class javax.swing.JList
Notifies ListSelectionListeners added directly to the list of selection changes made to the selection model.
fireServiceAdded(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceEvent notifying of a new service.
fireServiceAdded(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceAvailableEvent indicating that a new service has become available.
fireServiceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceEvent notifying of a service being revoked.
fireServiceRevoked(Class, boolean) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceRevokedEvent indicating that a particular service is no longer available.
fireSortOrderChanged() - Method in class javax.swing.RowSorter
Notifies listener that the sort order has changed.
fireStateChanged() - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.AbstractSpinnerModel
Run each ChangeListeners stateChanged() method.
fireStateChanged() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel
Runs each ChangeListener's stateChanged method.
fireStateChanged() - Method in class javax.swing.DefaultBoundedRangeModel
Runs each ChangeListener's stateChanged method.
fireStateChanged() - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.DefaultSingleSelectionModel
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.JProgressBar
Send a ChangeEvent, whose source is this JProgressBar, to all ChangeListeners that have registered interest in ChangeEvents.
fireStateChanged() - Method in class javax.swing.JSlider
Send a ChangeEvent, whose source is this JSlider, to all ChangeListeners that have registered interest in ChangeEvents.
fireStateChanged() - Method in class javax.swing.JSpinner
Sends a ChangeEvent, whose source is this JSpinner, to each ChangeListener.
fireStateChanged() - Method in class javax.swing.JTabbedPane
Sends a ChangeEvent, with this JTabbedPane as the source, to each registered listener.
fireStateChanged() - Method in class javax.swing.JViewport
Notifies all ChangeListeners when the views size, position, or the viewports extent size has changed.
fireStateChanged() - Method in class javax.swing.MenuSelectionManager
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.text.DefaultCaret
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.text.StyleContext.NamedStyle
Notifies all listeners that have registered interest for notification on this event type.
fireTableCellUpdated(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that the value of the cell at [row, column] has been updated.
fireTableChanged(TableModelEvent) - Method in class javax.swing.table.AbstractTableModel
Forwards the given notification event to all TableModelListeners that registered themselves as listeners for this table model.
fireTableDataChanged() - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that all cell values in the table's rows may have changed.
fireTableRowsDeleted(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been deleted.
fireTableRowsInserted(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been inserted.
fireTableRowsUpdated(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been updated.
fireTableStructureChanged() - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that the table's structure has changed.
fireTreeCollapsed(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeExpanded(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesInserted(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesRemoved(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeStructureChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeWillCollapse(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeWillExpand(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text.html.HTMLDocument
Notifies all listeners that have registered interest for notification on this event type.
fireValueChanged(boolean) - Method in class javax.swing.DefaultListSelectionModel
Notifies listeners that we have ended a series of adjustments.
fireValueChanged(int, int) - Method in class javax.swing.DefaultListSelectionModel
Notifies ListSelectionListeners that the value of the selection, in the closed interval firstIndex, lastIndex, has changed.
fireValueChanged(int, int, boolean) - Method in class javax.swing.DefaultListSelectionModel
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Notifies all listeners that are registered for tree selection events on this object.
fireVetoableChange(String, Object, Object) - Method in class java.awt.KeyboardFocusManager
Fires a PropertyChangeEvent in response to a change in a vetoable property.
fireVetoableChange(String, Object, Object) - Method in class java.beans.beancontext.BeanContextChildSupport
Report a vetoable property update to any registered listeners.
fireVetoableChange(String, Object, Object) - Method in class java.beans.VetoableChangeSupport
Reports a constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, int, int) - Method in class java.beans.VetoableChangeSupport
Reports an integer constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, boolean, boolean) - Method in class java.beans.VetoableChangeSupport
Reports a boolean constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(PropertyChangeEvent) - Method in class java.beans.VetoableChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, Object, Object) - Method in class javax.swing.JComponent
Supports reporting constrained property changes.
fireVisibleDataPropertyChange() - Method in class javax.swing.JTree.AccessibleJTree
Fire a visible data property change notification.
first(Container) - Method in class java.awt.CardLayout
Flips to the first card of the container.
first() - Method in interface java.sql.ResultSet
Moves the cursor to the first row in this ResultSet object.
first() - Method in class java.text.BreakIterator
Returns the first boundary.
first() - Method in interface java.text.CharacterIterator
Sets the position to getBeginIndex() and returns the character at that position.
first() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.first() for String.
first() - Method in class java.util.concurrent.ConcurrentSkipListSet
first() - Method in interface java.util.SortedSet
Returns the first (lowest) element currently in this set.
first() - Method in class java.util.TreeSet
first() - Method in class javax.swing.text.ElementIterator
Fetches the first element.
first(Object) - Method in class javax.swing.text.html.parser.ContentModel
Return true if the token could potentially be the first token in the input stream.
first() - Method in class javax.swing.text.html.parser.ContentModel
Return the element that must be next.
first() - Method in class javax.swing.text.Segment
Sets the position to getBeginIndex() and returns the character at that position.
FIRST_LINE_END - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the first line of text on a page would normally end for the current ComponentOrientation.
FIRST_LINE_START - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the first line of text on a page would normally begin for the current ComponentOrientation.
firstColumn - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
firstElement() - Method in class java.util.Vector
Returns the first component (the item at index 0) of this vector.
firstElement() - Method in class javax.swing.DefaultListModel
Returns the first component of this list.
firstEntry() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key in this map, or null if the map is empty.
firstEntry() - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key in this map, or null if the map is empty.
firstEntry() - Method in class java.util.TreeMap
firstKey() - Method in class java.util.concurrent.ConcurrentSkipListMap
firstKey() - Method in interface java.util.SortedMap
Returns the first (lowest) key currently in this map.
firstKey() - Method in class java.util.TreeMap
firstLineIndent - Variable in class javax.swing.text.ParagraphView
Indentation for the first line, from the left inset.
FirstLineIndent - Static variable in class javax.swing.text.StyleConstants
The amount of space to indent the first line of the paragraph.
firstRow - Variable in class javax.swing.event.TableModelEvent
firstRow - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
FIXED - Static variable in interface javax.swing.text.html.parser.DTDConstants
fixed_digits() - Method in class org.omg.CORBA.TypeCode
Returns the number of digits in the fixed type described by this TypeCode object.
fixed_scale() - Method in class org.omg.CORBA.TypeCode
Returns the scale of the fixed type described by this TypeCode object.
fixedCellHeightChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
fixedCellWidthChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
fixedContentLength - Variable in class java.net.HttpURLConnection
The fixed content-length when using fixed-length streaming mode.
fixedContentLengthLong - Variable in class java.net.HttpURLConnection
The fixed content-length when using fixed-length streaming mode.
FixedHeightLayoutCache - Class in javax.swing.tree
NOTE: This will become more open in a future release.
FixedHeightLayoutCache() - Constructor for class javax.swing.tree.FixedHeightLayoutCache
FixedHolder - Class in org.omg.CORBA
The Holder for Fixed.
FixedHolder() - Constructor for class org.omg.CORBA.FixedHolder
Construct the FixedHolder without initializing the contained value.
FixedHolder(BigDecimal) - Constructor for class org.omg.CORBA.FixedHolder
Construct the FixedHolder and initialize it with the given value.
FLAG_COMPLEX_GLYPHS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has a complex glyph-to-char mapping (one that does not map glyphs to chars one-to-one in strictly ascending or descending order matching the run direction).
FLAG_HAS_POSITION_ADJUSTMENTS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has position adjustments.
FLAG_HAS_TRANSFORMS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has per-glyph transforms.
FLAG_MASK - Static variable in class java.awt.font.GlyphVector
A mask for supported flags from getLayoutFlags.
FLAG_RUN_RTL - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has a right-to-left run direction.
flags() - Method in class java.nio.file.attribute.AclEntry
Returns a copy of the flags component.
flags() - Method in class java.util.regex.Pattern
Returns this pattern's match flags.
flags() - Method in class org.omg.CORBA.NamedValue
Retrieves the argument mode flag for this NamedValue object.
FLASH_OPTION - Static variable in class javax.swing.DebugGraphics
Flash graphics operations.
flashColor() - Static method in class javax.swing.DebugGraphics
Returns the Color used to flash drawing operations.
flashCount() - Static method in class javax.swing.DebugGraphics
Returns the number of times that drawing operations will flash.
flashTime() - Static method in class javax.swing.DebugGraphics
Returns the time delay of drawing operation flashing.
FlatteningPathIterator - Class in java.awt.geom
The FlatteningPathIterator class returns a flattened view of another PathIterator object.
FlatteningPathIterator(PathIterator, double) - Constructor for class java.awt.geom.FlatteningPathIterator
Constructs a new FlatteningPathIterator object that flattens a path as it iterates over it.
FlatteningPathIterator(PathIterator, double, int) - Constructor for class java.awt.geom.FlatteningPathIterator
Constructs a new FlatteningPathIterator object that flattens a path as it iterates over it.
FlavorEvent - Class in java.awt.datatransfer
FlavorEvent is used to notify interested parties that available DataFlavors have changed in the Clipboard (the event source).
FlavorEvent(Clipboard) - Constructor for class java.awt.datatransfer.FlavorEvent
Constructs a FlavorEvent object.
FlavorException - Interface in javax.print
Interface FlavorException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a doc flavor or flavors (class DocFlavor).
FlavorListener - Interface in java.awt.datatransfer
Defines an object which listens for FlavorEvents.
FlavorMap - Interface in java.awt.datatransfer
A two-way Map between "natives" (Strings), which correspond to platform- specfic data formats, and "flavors" (DataFlavors), which corerspond to platform-independent MIME types.
flavorsChanged(FlavorEvent) - Method in interface java.awt.datatransfer.FlavorListener
Invoked when the target Clipboard of the listener has changed its available DataFlavors.
FlavorTable - Interface in java.awt.datatransfer
A FlavorMap which relaxes the traditional 1-to-1 restriction of a Map.
flip(BufferCapabilities.FlipContents) - Method in class java.awt.Component.FlipBufferStrategy
Flipping moves the contents of the back buffer to the front buffer, either by copying or by moving the video pointer.
flip() - Method in class java.nio.Buffer
Flips this buffer.
flip(int) - Method in class java.util.BitSet
Sets the bit at the specified index to the complement of its current value.
flip(int, int) - Method in class java.util.BitSet
Sets each bit from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to the complement of its current value.
flipBit(int) - Method in class java.math.BigInteger
Returns a BigInteger whose value is equivalent to this BigInteger with the designated bit flipped.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.BoxView
Determines in which direction the next view lays.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.CompositeView
Determines in which direction the next view lays.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.ParagraphView
Determines in which direction the next view lays.
Float - Class in java.lang
The Float class wraps a value of primitive type float in an object.
Float(float) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the primitive float argument.
Float(double) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the argument converted to type float.
Float(String) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the floating-point value of type float represented by the string.
FLOAT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type FLOAT.
FLOAT - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Float.
FLOAT - Static variable in class javax.swing.text.html.CSS.Attribute
floatAt(Point, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
FloatBuffer - Class in java.nio
A float buffer.
FloatControl - Class in javax.sound.sampled
A FloatControl object provides control over a range of floating-point values.
FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String) - Constructor for class javax.sound.sampled.FloatControl
Constructs a new float control object with the given parameters
FloatControl(FloatControl.Type, float, float, float, int, float, String) - Constructor for class javax.sound.sampled.FloatControl
Constructs a new float control object with the given parameters.
FloatControl.Type - Class in javax.sound.sampled
An instance of the FloatControl.Type inner class identifies one kind of float control.
FloatControl.Type(String) - Constructor for class javax.sound.sampled.FloatControl.Type
Constructs a new float control type.
FloatHolder - Class in org.omg.CORBA
The Holder for Float.
FloatHolder() - Constructor for class org.omg.CORBA.FloatHolder
Constructs a new FloatHolder object with its value field initialized to 0.0.
FloatHolder(float) - Constructor for class org.omg.CORBA.FloatHolder
Constructs a new FloatHolder object for the given float.
floatingBorderColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
floatingColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
FloatSeqHelper - Class in org.omg.CORBA
The Helper for FloatSeq.
FloatSeqHelper() - Constructor for class org.omg.CORBA.FloatSeqHelper
FloatSeqHolder - Class in org.omg.CORBA
The Holder for FloatSeq.
FloatSeqHolder() - Constructor for class org.omg.CORBA.FloatSeqHolder
FloatSeqHolder(float[]) - Constructor for class org.omg.CORBA.FloatSeqHolder
floatToIntBits(float) - Static method in class java.lang.Float
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "single format" bit layout.
floatToRawIntBits(float) - Static method in class java.lang.Float
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "single format" bit layout, preserving Not-a-Number (NaN) values.
floatValue() - Method in class java.lang.Byte
Returns the value of this Byte as a float.
floatValue() - Method in class java.lang.Double
Returns the float value of this Double object.
floatValue() - Method in class java.lang.Float
Returns the float value of this Float object.
floatValue() - Method in class java.lang.Integer
Returns the value of this Integer as a float.
floatValue() - Method in class java.lang.Long
Returns the value of this Long as a float.
floatValue() - Method in class java.lang.Number
Returns the value of the specified number as a float.
floatValue() - Method in class java.lang.Short
Returns the value of this Short as a float.
floatValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to a float.
floatValue() - Method in class java.math.BigInteger
Converts this BigInteger to a float.
floatValue() - Method in class java.util.concurrent.atomic.AtomicInteger
floatValue() - Method in class java.util.concurrent.atomic.AtomicLong
floor(double) - Static method in class java.lang.Math
Returns the largest (closest to positive infinity) double value that is less than or equal to the argument and is equal to a mathematical integer.
floor(double) - Static method in class java.lang.StrictMath
Returns the largest (closest to positive infinity) double value that is less than or equal to the argument and is equal to a mathematical integer.
floor(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
floor(E) - Method in interface java.util.NavigableSet
Returns the greatest element in this set less than or equal to the given element, or null if there is no such element.
floor(E) - Method in class java.util.TreeSet
floorEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the greatest key less than or equal to the given key, or null if there is no such key.
floorEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the greatest key less than or equal to the given key, or null if there is no such key.
floorEntry(K) - Method in class java.util.TreeMap
floorKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
floorKey(K) - Method in interface java.util.NavigableMap
Returns the greatest key less than or equal to the given key, or null if there is no such key.
floorKey(K) - Method in class java.util.TreeMap
floppyDriveIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
FlowLayout - Class in java.awt
A flow layout arranges components in a directional flow, much like lines of text in a paragraph.
FlowLayout() - Constructor for class java.awt.FlowLayout
Constructs a new FlowLayout with a centered alignment and a default 5-unit horizontal and vertical gap.
FlowLayout(int) - Constructor for class java.awt.FlowLayout
Constructs a new FlowLayout with the specified alignment and a default 5-unit horizontal and vertical gap.
FlowLayout(int, int, int) - Constructor for class java.awt.FlowLayout
Creates a new flow layout manager with the indicated alignment and the indicated horizontal and vertical gaps.
FLOWS_FROM - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is logically contiguous with a second object where the second object occurs before the object.
FLOWS_FROM_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the FLOWS_FROM relation between two objects has changed.
FLOWS_TO - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is logically contiguous with a second object where the second object occurs after the object.
FLOWS_TO_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the FLOWS_TO relation between two objects has changed.
FlowView - Class in javax.swing.text
A View that tries to flow it's children into some partially constrained space.
FlowView(Element, int) - Constructor for class javax.swing.text.FlowView
Constructs a FlowView for the given element.
FlowView.FlowStrategy - Class in javax.swing.text
Strategy for maintaining the physical form of the flow.
FlowView.FlowStrategy() - Constructor for class javax.swing.text.FlowView.FlowStrategy
flush() - Method in class java.awt.Image
Flushes all reconstructable resources being used by this Image object.
flush() - Method in class java.beans.XMLEncoder
This method writes out the preamble associated with the XML encoding if it has not been written already and then writes out all of the values that been written to the stream since the last time flush was called.
flush() - Method in class java.io.BufferedOutputStream
Flushes this buffered output stream.
flush() - Method in class java.io.BufferedWriter
Flushes the stream.
flush() - Method in class java.io.CharArrayWriter
Flush the stream.
flush() - Method in class java.io.Console
Flushes the console and forces any buffered output to be written immediately .
flush() - Method in class java.io.DataOutputStream
Flushes this data output stream.
flush() - Method in class java.io.FilterOutputStream
Flushes this output stream and forces any buffered output bytes to be written out to the stream.
flush() - Method in class java.io.FilterWriter
Flushes the stream.
flush() - Method in interface java.io.Flushable
Flushes this stream by writing any buffered output to the underlying stream.
flush() - Method in interface java.io.ObjectOutput
Flushes the stream.
flush() - Method in class java.io.ObjectOutputStream
Flushes the stream.
flush() - Method in class java.io.OutputStream
Flushes this output stream and forces any buffered output bytes to be written out.
flush() - Method in class java.io.OutputStreamWriter
Flushes the stream.
flush() - Method in class java.io.PipedOutputStream
Flushes this output stream and forces any buffered output bytes to be written out.
flush() - Method in class java.io.PipedWriter
Flushes this output stream and forces any buffered output characters to be written out.
flush() - Method in class java.io.PrintStream
Flushes the stream.
flush() - Method in class java.io.PrintWriter
Flushes the stream.
flush() - Method in class java.io.StringWriter
Flush the stream.
flush() - Method in class java.io.Writer
Flushes the stream.
flush(CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Flushes this decoder.
flush(ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Flushes this encoder.
flush() - Method in class java.util.Formatter
Flushes this formatter.
flush() - Method in class java.util.logging.Handler
Flush any buffered output.
flush() - Method in class java.util.logging.MemoryHandler
Causes a flush on the target Handler.
flush() - Method in class java.util.logging.StreamHandler
Flush any buffered messages.
flush() - Method in class java.util.prefs.AbstractPreferences
Implements the flush method as per the specification in Preferences.flush().
flush() - Method in class java.util.prefs.Preferences
Forces any changes in the contents of this preference node and its descendants to the persistent store.
flush() - Method in class java.util.zip.DeflaterOutputStream
Flushes the compressed output stream.
flush() - Method in class java.util.zip.InflaterOutputStream
Flushes this output stream, forcing any pending buffered output bytes to be written.
flush() - Method in class javax.crypto.CipherOutputStream
Flushes this output stream by forcing any buffered output bytes that have already been processed by the encapsulated cipher object to be written out.
flush() - Method in interface javax.imageio.stream.ImageInputStream
Discards the initial position of the stream prior to the current stream position.
flush() - Method in class javax.imageio.stream.ImageInputStreamImpl
flush() - Method in interface javax.sound.sampled.DataLine
Flushes queued data from the line.
flush() - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
The last method called on the reader.
flush() - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
flush() - Method in class javax.tools.ForwardingJavaFileManager
flush() - Method in interface javax.tools.JavaFileManager
Flushes any resources opened for output by this file manager directly or indirectly.
flush() - Method in interface javax.xml.stream.XMLEventWriter
Writes any cached events to the underlying output mechanism
flush() - Method in interface javax.xml.stream.XMLStreamWriter
Write any cached data to the underlying output mechanism.
FLUSH_FAILURE - Static variable in class java.util.logging.ErrorManager
FLUSH_FAILURE is used when a flush to an output stream fails.
Flushable - Interface in java.io
A Flushable is a destination of data that can be flushed.
flushAttributes() - Method in class javax.swing.text.html.parser.Parser
flushBefore(long) - Method in class javax.imageio.stream.FileCacheImageOutputStream
flushBefore(long) - Method in interface javax.imageio.stream.ImageInputStream
Discards the initial portion of the stream prior to the indicated postion.
flushBefore(long) - Method in class javax.imageio.stream.ImageInputStreamImpl
flushBefore(long) - Method in interface javax.imageio.stream.ImageOutputStream
Flushes all data prior to the given position to the underlying destination, such as an OutputStream or File.
flushBefore(long) - Method in class javax.imageio.stream.MemoryCacheImageInputStream
flushBefore(long) - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
flushBits() - Method in class javax.imageio.stream.ImageOutputStreamImpl
If the bit offset is non-zero, forces the remaining bits in the current byte to 0 and advances the stream position by one.
flushCaches() - Static method in class java.beans.Introspector
Flush all of the Introspector's internal caches.
flushedPos - Variable in class javax.imageio.stream.ImageInputStreamImpl
The position prior to which data may be discarded.
flushFromCaches(Class<?>) - Static method in class java.beans.Introspector
Flush the Introspector's internal cached information for a given class.
flushRequirementChanges() - Method in class javax.swing.text.AsyncBoxView
Publish the changes in preferences upward to the parent view.
flushSpi() - Method in class java.util.prefs.AbstractPreferences
This method is invoked with this node locked.
focus - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
FOCUS - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the focus.
FOCUS_ACCELERATOR_KEY - Static variable in class javax.swing.text.JTextComponent
The bound property name for the focus accelerator.
FOCUS_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting focus events.
FOCUS_FIRST - Static variable in class java.awt.event.FocusEvent
The first number in the range of ids used for focus events.
FOCUS_GAINED - Static variable in class java.awt.event.FocusEvent
This event indicates that the Component is now the focus owner.
FOCUS_LAST - Static variable in class java.awt.event.FocusEvent
The last number in the range of ids used for focus events.
FOCUS_LOST - Static variable in class java.awt.event.FocusEvent
This event indicates that the Component is no longer the focus owner.
FOCUS_MANAGER_CLASS_PROPERTY - Static variable in class javax.swing.FocusManager
This field is obsolete, and its use is discouraged since its specification is incompatible with the 1.4 focus APIs.
FOCUS_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the border highlighted when focused, or not.
FOCUSABLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object can accept keyboard focus, which means all events resulting from typing on the keyboard will normally be passed to it when it has focus.
FocusAdapter - Class in java.awt.event
An abstract adapter class for receiving keyboard focus events.
FocusAdapter() - Constructor for class java.awt.event.FocusAdapter
focusColor - Variable in class javax.swing.plaf.metal.MetalButtonUI
focusColor - Variable in class javax.swing.plaf.metal.MetalRadioButtonUI
focusColor - Variable in class javax.swing.plaf.metal.MetalToggleButtonUI
FOCUSED - Static variable in class javax.accessibility.AccessibleState
Indicates this object currently has the keyboard focus.
FOCUSED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Indicates the region has focus.
focusedCompIndex - Variable in class javax.swing.plaf.basic.BasicToolBarUI
FocusEvent - Class in java.awt.event
A low-level event which indicates that a Component has gained or lost the input focus.
FocusEvent(Component, int, boolean, Component) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object with the specified temporary state and opposite Component.
FocusEvent(Component, int, boolean) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object and identifies whether or not the change is temporary.
FocusEvent(Component, int) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object and identifies it as a permanent change in focus.
focusGained(FocusEvent) - Method in class java.awt.AWTEventMulticaster
Handles the focusGained event by invoking the focusGained methods on listener-a and listener-b.
focusGained(FocusEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusGained(FocusEvent) - Method in class java.awt.event.FocusAdapter
Invoked when a component gains the keyboard focus.
focusGained(FocusEvent) - Method in interface java.awt.event.FocusListener
Invoked when a component gains the keyboard focus.
focusGained(FocusEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicListUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
Invoked when focus is activated on the tree we're in, redraws the lead row.
focusGained(FocusEvent) - Method in class javax.swing.text.DefaultCaret
Called when the component containing the caret gains focus.
focusInsets - Variable in class javax.swing.plaf.basic.BasicSliderUI
FocusListener - Interface in java.awt.event
The listener interface for receiving keyboard focus events on a component.
focusListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
focusListener - Variable in class javax.swing.plaf.basic.BasicListUI
focusListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
focusListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance of the FocusListener for this JSplitPane.
focusListener - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
focusListener - Variable in class javax.swing.plaf.basic.BasicTableUI
focusLost(FocusEvent) - Method in class java.awt.AWTEventMulticaster
Handles the focusLost event by invoking the focusLost methods on listener-a and listener-b.
focusLost(FocusEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusLost(FocusEvent) - Method in class java.awt.event.FocusAdapter
Invoked when a component loses the keyboard focus.
focusLost(FocusEvent) - Method in interface java.awt.event.FocusListener
Invoked when a component loses the keyboard focus.
focusLost(FocusEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicListUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
Invoked when focus is activated on the tree we're in, redraws the lead row.
focusLost(FocusEvent) - Method in class javax.swing.text.DefaultCaret
Called when the component containing the caret loses focus.
FocusManager - Class in javax.swing
This class has been obsoleted by the 1.4 focus APIs.
FocusManager() - Constructor for class javax.swing.FocusManager
focusNextComponent(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Focuses the Component after aComponent, typically based on a FocusTraversalPolicy.
focusNextComponent(Component) - Method in class java.awt.KeyboardFocusManager
Focuses the Component after aComponent, typically based on a FocusTraversalPolicy.
focusNextComponent() - Method in class java.awt.KeyboardFocusManager
Focuses the Component after the current focus owner.
focusPreviousComponent(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Focuses the Component before aComponent, typically based on a FocusTraversalPolicy.
focusPreviousComponent(Component) - Method in class java.awt.KeyboardFocusManager
Focuses the Component before aComponent, typically based on a FocusTraversalPolicy.
focusPreviousComponent() - Method in class java.awt.KeyboardFocusManager
Focuses the Component before the current focus owner.
focusRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
FocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy defines the order in which Components with a particular focus cycle root are traversed.
FocusTraversalPolicy() - Constructor for class java.awt.FocusTraversalPolicy
foldArguments(MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle target by pre-processing some of its arguments, and then calling the target with the result of the pre-processing, plus all original arguments.
FOLIO - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Folio, 8 1/2 x 13 in.
FOLIO - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the folio size, 8.5 inches by 13 inches.
FOLIO - Static variable in class javax.print.attribute.standard.MediaSizeName
folio size .
following(int) - Method in class java.text.BreakIterator
Returns the first boundary following the specified character offset.
Font - Class in java.awt
The Font class represents fonts, which are used to render text in a visible way.
Font(String, int, int) - Constructor for class java.awt.Font
Creates a new Font from the specified name, style and point size.
Font(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.awt.Font
Creates a new Font with the specified attributes.
Font(Font) - Constructor for class java.awt.Font
Creates a new Font from the specified font.
FONT - Static variable in class java.awt.font.TextAttribute
Attribute key used to provide the font to use to render text.
font - Variable in class java.awt.FontMetrics
The actual Font from which the font metrics are created.
FONT - Static variable in class javax.swing.text.html.CSS.Attribute
FONT - Static variable in class javax.swing.text.html.HTML.Tag
font - Variable in class javax.swing.tree.DefaultTreeCellEditor
Font to paint with, null indicates font of renderer is to be used.
FONT_CHANGE_BIGGER - Static variable in class javax.swing.text.html.HTMLEditorKit
The font size increase to next value action identifier
FONT_CHANGE_SMALLER - Static variable in class javax.swing.text.html.HTMLEditorKit
The font size decrease to next value action identifier
FONT_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A FONT_CHOOSER is a component that lets the user pick various attributes for fonts.
FONT_FAMILY - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_SIZE - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_VARIANT - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_WEIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
fontChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
FontFamily - Static variable in class javax.swing.text.StyleConstants
Name of the font family.
FontFormatException - Exception in java.awt
Thrown by method createFont in the Font class to indicate that the specified font is bad.
FontFormatException(String) - Constructor for exception java.awt.FontFormatException
Report a FontFormatException for the reason specified.
FontMetrics - Class in java.awt
The FontMetrics class defines a font metrics object, which encapsulates information about the rendering of a particular font on a particular screen.
FontMetrics(Font) - Constructor for class java.awt.FontMetrics
Creates a new FontMetrics object for finding out height and width information about the specified Font and specific character glyphs in that Font.
FontRenderContext - Class in java.awt.font
The FontRenderContext class is a container for the information needed to correctly measure text.
FontRenderContext() - Constructor for class java.awt.font.FontRenderContext
Constructs a new FontRenderContext object.
FontRenderContext(AffineTransform, boolean, boolean) - Constructor for class java.awt.font.FontRenderContext
Constructs a FontRenderContext object from an optional AffineTransform and two boolean values that determine if the newly constructed object has anti-aliasing or fractional metrics.
FontRenderContext(AffineTransform, Object, Object) - Constructor for class java.awt.font.FontRenderContext
Constructs a FontRenderContext object from an optional AffineTransform and two Object values that determine if the newly constructed object has anti-aliasing or fractional metrics.
FontSize - Static variable in class javax.swing.text.StyleConstants
Name of the font size.
FontUIResource - Class in javax.swing.plaf
A subclass of java.awt.Font that implements UIResource.
FontUIResource(String, int, int) - Constructor for class javax.swing.plaf.FontUIResource
FontUIResource(Font) - Constructor for class javax.swing.plaf.FontUIResource
FOOTER - Static variable in class javax.accessibility.AccessibleRole
A text footer
force(boolean) - Method in class java.nio.channels.AsynchronousFileChannel
Forces any updates to this channel's file to be written to the storage device that contains it.
force(boolean) - Method in class java.nio.channels.FileChannel
Forces any updates to this channel's file to be written to the storage device that contains it.
force() - Method in class java.nio.MappedByteBuffer
Forces any changes made to this buffer's content to be written to the storage device containing the mapped file.
ForcedBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view supports breaking, and must be broken to be represented properly when placed in a view that formats its children by breaking them.
forceTermination() - Method in class java.util.concurrent.Phaser
Forces this phaser to enter termination state.
forClass() - Method in class java.io.ObjectStreamClass
Return the class in the local VM that this version is mapped to.
forDigit(int, int) - Static method in class java.lang.Character
Determines the character representation for a specific digit in the specified radix.
FOREGROUND - Static variable in class java.awt.font.TextAttribute
Attribute key for the paint used to render the text.
FOREGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the foreground of a region.
Foreground - Static variable in class javax.swing.text.StyleConstants
Name of the foreground color attribute.
forget(Xid) - Method in interface javax.transaction.xa.XAResource
Tells the resource manager to forget about a heuristically completed transaction branch.
fork() - Method in class java.util.concurrent.ForkJoinTask
Arranges to asynchronously execute this task.
ForkJoinPool - Class in java.util.concurrent
An ExecutorService for running ForkJoinTasks.
ForkJoinPool() - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with parallelism equal to Runtime.availableProcessors(), using the default thread factory, no UncaughtExceptionHandler, and non-async LIFO processing mode.
ForkJoinPool(int) - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with the indicated parallelism level, the default thread factory, no UncaughtExceptionHandler, and non-async LIFO processing mode.
ForkJoinPool(int, ForkJoinPool.ForkJoinWorkerThreadFactory, Thread.UncaughtExceptionHandler, boolean) - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with the given parameters.
ForkJoinPool.ForkJoinWorkerThreadFactory - Interface in java.util.concurrent
Factory for creating new ForkJoinWorkerThreads.
ForkJoinPool.ManagedBlocker - Interface in java.util.concurrent
Interface for extending managed parallelism for tasks running in ForkJoinPools.
ForkJoinTask<V> - Class in java.util.concurrent
Abstract base class for tasks that run within a ForkJoinPool.
ForkJoinTask() - Constructor for class java.util.concurrent.ForkJoinTask
ForkJoinWorkerThread - Class in java.util.concurrent
A thread managed by a ForkJoinPool, which executes ForkJoinTasks.
ForkJoinWorkerThread(ForkJoinPool) - Constructor for class java.util.concurrent.ForkJoinWorkerThread
Creates a ForkJoinWorkerThread operating in the given pool.
forLanguageTag(String) - Static method in class java.util.Locale
Returns a locale for the specified IETF BCP 47 language tag string.
FORM - Static variable in class javax.swing.text.html.HTML.Tag
format(String, Object...) - Method in class java.io.Console
Writes a formatted string to this console's output stream using the specified format string and arguments.
format(String, Object...) - Method in class java.io.PrintStream
Writes a formatted string to this output stream using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.io.PrintStream
Writes a formatted string to this output stream using the specified format string and arguments.
format(String, Object...) - Method in class java.io.PrintWriter
Writes a formatted string to this writer using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.io.PrintWriter
Writes a formatted string to this writer using the specified format string and arguments.
FORMAT - Static variable in class java.lang.Character
General category "Cf" in the Unicode specification.
format(String, Object...) - Static method in class java.lang.String
Returns a formatted string using the specified format string and arguments.
format(Locale, String, Object...) - Static method in class java.lang.String
Returns a formatted string using the specified locale, format string, and arguments.
format(long, StringBuffer, FieldPosition) - Method in class java.text.ChoiceFormat
Specialization of format.
format(double, StringBuffer, FieldPosition) - Method in class java.text.ChoiceFormat
Returns pattern with formatted double.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.DateFormat
Overrides Format.
format(Date, StringBuffer, FieldPosition) - Method in class java.text.DateFormat
Formats a Date into a date/time string.
format(Date) - Method in class java.text.DateFormat
Formats a Date into a date/time string.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Formats a number and appends the resulting text to the given string buffer.
format(double, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Formats a double to produce a string.
format(long, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Format a long to produce a string.
Format - Class in java.text
Format is an abstract base class for formatting locale-sensitive information such as dates, messages, and numbers.
Format() - Constructor for class java.text.Format
Sole constructor.
format(Object) - Method in class java.text.Format
Formats an object to produce a string.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.Format
Formats an object and appends the resulting text to a given string buffer.
format(Object[], StringBuffer, FieldPosition) - Method in class java.text.MessageFormat
Formats an array of objects and appends the MessageFormat's pattern, with format elements replaced by the formatted objects, to the provided StringBuffer.
format(String, Object...) - Static method in class java.text.MessageFormat
Creates a MessageFormat with the given pattern and uses it to format the given arguments.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.MessageFormat
Formats an array of objects and appends the MessageFormat's pattern, with format elements replaced by the formatted objects, to the provided StringBuffer.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Formats a number and appends the resulting text to the given string buffer.
format(double) - Method in class java.text.NumberFormat
Specialization of format.
format(long) - Method in class java.text.NumberFormat
Specialization of format.
format(double, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Specialization of format.
format(long, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Specialization of format.
format(Date, StringBuffer, FieldPosition) - Method in class java.text.SimpleDateFormat
Formats the given Date into a date/time string and appends the result to the given StringBuffer.
format(String, Object...) - Method in class java.util.Formatter
Writes a formatted string to this object's destination using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.util.Formatter
Writes a formatted string to this object's destination using the specified locale, format string, and arguments.
format(LogRecord) - Method in class java.util.logging.Formatter
Format the given log record and return the formatted string.
format(LogRecord) - Method in class java.util.logging.SimpleFormatter
Format the given LogRecord.
format(LogRecord) - Method in class java.util.logging.XMLFormatter
Format the given message to XML.
format - Variable in class javax.sound.sampled.AudioInputStream
The format of the audio data contained in the stream.
format - Variable in class org.omg.IOP.Encoding
The encoding format.
Format.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from Format.formatToCharacterIterator and as field identifiers in FieldPosition.
Format.Field(String) - Constructor for class java.text.Format.Field
Creates a Field with the specified name.
FORMAT_CLASS - Static variable in class java.util.ResourceBundle.Control
The class-only format List containing "java.class".
FORMAT_DEFAULT - Static variable in class java.util.ResourceBundle.Control
The default format List, which contains the strings "java.class" and "java.properties", in this order.
FORMAT_FAILURE - Static variable in class java.util.logging.ErrorManager
FORMAT_FAILURE is used when formatting fails for any reason.
FORMAT_PROPERTIES - Static variable in class java.util.ResourceBundle.Control
The properties-only format List containing "java.properties".
FormatConversionProvider - Class in javax.sound.sampled.spi
A format conversion provider provides format conversion services from one or more input formats to one or more output formats.
FormatConversionProvider() - Constructor for class javax.sound.sampled.spi.FormatConversionProvider
FormatFlagsConversionMismatchException - Exception in java.util
Unchecked exception thrown when a conversion and flag are incompatible.
FormatFlagsConversionMismatchException(String, char) - Constructor for exception java.util.FormatFlagsConversionMismatchException
Constructs an instance of this class with the specified flag and conversion.
formatMessage(LogRecord) - Method in class java.util.logging.Formatter
Localize and format the message string from a log record.
FormatMismatch - Exception in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/FormatMismatch.java .
FormatMismatch() - Constructor for exception org.omg.IOP.CodecPackage.FormatMismatch
FormatMismatch(String) - Constructor for exception org.omg.IOP.CodecPackage.FormatMismatch
FormatMismatchHelper - Class in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
FormatMismatchHelper() - Constructor for class org.omg.IOP.CodecPackage.FormatMismatchHelper
Formattable - Interface in java.util
The Formattable interface must be implemented by any class that needs to perform custom formatting using the 's' conversion specifier of Formatter.
FormattableFlags - Class in java.util
FomattableFlags are passed to the Formattable.formatTo() method and modify the output format for Formattables.
FORMATTED_TEXT_FIELD - Static variable in class javax.swing.plaf.synth.Region
FormattedTextField region.
Formatter - Class in java.util
An interpreter for printf-style format strings.
Formatter() - Constructor for class java.util.Formatter
Constructs a new formatter.
Formatter(Appendable) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified destination.
Formatter(Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified locale.
Formatter(Appendable, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified destination and locale.
Formatter(String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name.
Formatter(String, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name and charset.
Formatter(String, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name, charset, and locale.
Formatter(File) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file.
Formatter(File, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file and charset.
Formatter(File, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file, charset, and locale.
Formatter(PrintStream) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified print stream.
Formatter(OutputStream) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream.
Formatter(OutputStream, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream and charset.
Formatter(OutputStream, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream, charset, and locale.
Formatter - Class in java.util.logging
A Formatter provides support for formatting LogRecords.
Formatter() - Constructor for class java.util.logging.Formatter
Construct a new formatter.
Formatter.BigDecimalLayoutForm - Enum in java.util
FormatterClosedException - Exception in java.util
Unchecked exception thrown when the formatter has been closed.
FormatterClosedException() - Constructor for exception java.util.FormatterClosedException
Constructs an instance of this class.
formatTo(Formatter, int, int, int) - Method in interface java.util.Formattable
Formats the object using the provided formatter.
formatToCharacterIterator(Object) - Method in class java.text.DecimalFormat
Formats an Object producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.Format
Formats an Object producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.MessageFormat
Formats an array of objects and inserts them into the MessageFormat's pattern, producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.SimpleDateFormat
Formats an Object producing an AttributedCharacterIterator.
FormSubmitEvent - Class in javax.swing.text.html
FormSubmitEvent is used to notify interested parties that a form was submited.
FormSubmitEvent.MethodType - Enum in javax.swing.text.html
Represents an HTML form method type.
FormView - Class in javax.swing.text.html
Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
FormView(Element) - Constructor for class javax.swing.text.html.FormView
Creates a new FormView object.
FormView.MouseEventListener - Class in javax.swing.text.html
MouseEventListener class to handle form submissions when an input with type equal to image is clicked on.
FormView.MouseEventListener() - Constructor for class javax.swing.text.html.FormView.MouseEventListener
forName(String) - Static method in class java.lang.Character.UnicodeBlock
Returns the UnicodeBlock with the given name.
forName(String) - Static method in enum java.lang.Character.UnicodeScript
Returns the UnicodeScript constant with the given Unicode script name or the script name alias.
forName(String) - Static method in class java.lang.类
Returns the 类 object associated with the class or interface with the given string name.
forName(String, boolean, ClassLoader) - Static method in class java.lang.类
Returns the 类 object associated with the class or interface with the given string name, using the given class loader.
forName(String) - Static method in class java.nio.charset.Charset
Returns a charset object for the named charset.
Forward - Static variable in class javax.swing.text.Position.Bias
Indicates to bias toward the next character in the model.
forward - Variable in exception org.omg.PortableInterceptor.ForwardRequest
The new object to forward the request to.
forward_reference() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
forward_reference - Variable in exception org.omg.PortableServer.ForwardRequest
FORWARD_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Forward focus traversal keys.
forwardAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically forward one position.
ForwardingFileObject<F extends FileObject> - Class in javax.tools
Forwards calls to a given file object.
ForwardingFileObject(F) - Constructor for class javax.tools.ForwardingFileObject
Creates a new instance of ForwardingFileObject.
ForwardingJavaFileManager<M extends JavaFileManager> - Class in javax.tools
Forwards calls to a given file manager.
ForwardingJavaFileManager(M) - Constructor for class javax.tools.ForwardingJavaFileManager
Creates a new instance of ForwardingJavaFileManager.
ForwardingJavaFileObject<F extends JavaFileObject> - Class in javax.tools
Forwards calls to a given file object.
ForwardingJavaFileObject(F) - Constructor for class javax.tools.ForwardingJavaFileObject
Creates a new instance of ForwardingJavaFileObject.
ForwardRequest - Exception in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ForwardRequest.java .
ForwardRequest() - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest - Exception in org.omg.PortableServer
org/omg/PortableServer/ForwardRequest.java .
ForwardRequest() - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequestHelper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ForwardRequestHelper.java .
ForwardRequestHelper() - Constructor for class org.omg.PortableInterceptor.ForwardRequestHelper
ForwardRequestHelper - Class in org.omg.PortableServer
org/omg/PortableServer/ForwardRequestHelper.java .
ForwardRequestHelper() - Constructor for class org.omg.PortableServer.ForwardRequestHelper
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.BoxView
Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.TableView
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Forwards the DocumentEvent to the give child view.
foundType() - Method in exception java.lang.annotation.AnnotationTypeMismatchException
Returns the type of data found in the incorrectly typed element.
FRACTION - Static variable in class java.text.NumberFormat.Field
Constant identifying the fraction field.
FRACTION_FIELD - Static variable in class java.text.NumberFormat
Field constant used to construct a FieldPosition object.
Frame - Class in java.awt
A Frame is a top-level window with a title and a border.
Frame() - Constructor for class java.awt.Frame
Constructs a new instance of Frame that is initially invisible.
Frame(GraphicsConfiguration) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame with the specified GraphicsConfiguration.
Frame(String) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame object with the specified title.
Frame(String, GraphicsConfiguration) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame object with the specified title and a GraphicsConfiguration.
FRAME - Static variable in class javax.accessibility.AccessibleRole
A top level window with a title bar, border, menu bar, etc.
FRAME - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
frame - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
frame - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
frame - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
FRAME - Static variable in class javax.swing.text.html.HTML.Tag
Frame.AccessibleAWTFrame - Class in java.awt
This class implements accessibility support for the Frame class.
Frame.AccessibleAWTFrame() - Constructor for class java.awt.Frame.AccessibleAWTFrame
FRAME_CONTENT_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Frame Content layer.
FRAME_ICON_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
FRAMEBITS - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that another complete frame of a multi-frame image which was previously drawn is now available to be drawn again.
FRAMEBORDER - Static variable in class javax.swing.text.html.HTML.Attribute
frameIcon - Variable in class javax.swing.JInternalFrame
The icon shown in the top-left corner of this internal frame.
frameInit() - Method in class javax.swing.JFrame
Called by the constructors to init the JFrame properly.
frameLength - Variable in class javax.sound.sampled.AudioInputStream
This stream's length, in sample frames.
framePos - Variable in class javax.sound.sampled.AudioInputStream
The current position in this stream, in sample frames (zero-based).
frameRate - Variable in class javax.sound.sampled.AudioFormat
The number of frames played or recorded per second, for sounds that have this format.
FRAMESET - Static variable in class javax.swing.text.html.HTML.Tag
frameSize - Variable in class javax.sound.sampled.AudioFormat
The number of bytes in each frame of a sound that has this format.
frameSize - Variable in class javax.sound.sampled.AudioInputStream
The size of each frame, in bytes.
FRANCE - Static variable in class java.util.Locale
Useful constant for country.
free() - Method in interface java.sql.Array
This method frees the Array object and releases the resources that it holds.
free() - Method in interface java.sql.Blob
This method frees the Blob object and releases the resources that it holds.
free() - Method in interface java.sql.Clob
This method frees the Clob object and releases the resources the resources that it holds.
free() - Method in interface java.sql.SQLXML
This method closes this object and releases the resources that it held.
free() - Method in class javax.sql.rowset.serial.SerialArray
This method frees the Array object and releases the resources that it holds.
free() - Method in class javax.sql.rowset.serial.SerialBlob
This method frees the Blob object and releases the resources that it holds.
free() - Method in class javax.sql.rowset.serial.SerialClob
FREE_MEM - Exception in org.omg.CORBA
Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
FREE_MEM() - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
FREE_MEM(String) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
FREE_MEM(int, CompletionStatus) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified minor code and completion status.
FREE_MEM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.
FREE_STANDING_PROP - Static variable in class javax.swing.plaf.metal.MetalScrollBarUI
freeMemory() - Method in class java.lang.Runtime
Returns the amount of free memory in the Java Virtual Machine.
FRENCH - Static variable in class java.util.Locale
Useful constant for language.
frequency(Collection<?>, Object) - Static method in class java.util.Collections
Returns the number of elements in the specified collection equal to the specified object.
FRIDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Friday.
from(CompositeData) - Static method in class java.lang.management.MemoryNotificationInfo
Returns a MemoryNotificationInfo object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.MemoryUsage
Returns a MemoryUsage object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.MonitorInfo
Returns a MonitorInfo object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.ThreadInfo
Returns a ThreadInfo object represented by the given CompositeData.
from(File) - Static method in class java.lang.ProcessBuilder.Redirect
Returns a redirect to read from the specified file.
from(long, TimeUnit) - Static method in class java.nio.file.attribute.FileTime
Returns a FileTime representing a value at the given unit of granularity.
from_any(Any) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Make a DynAny object from an Any object.
from_any(Any) - Method in class org.omg.DynamicAny._DynAnyStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynArrayStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynEnumStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynFixedStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynSequenceStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynStructStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynUnionStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynValueStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in interface org.omg.DynamicAny.DynAnyOperations
Initializes the value associated with a DynAny object with the value contained in an any.
from_int(int) - Static method in class org.omg.CORBA.CompletionStatus
Creates a CompletionStatus object from the given int.
from_int(int) - Static method in class org.omg.CORBA.DefinitionKind
Creates a DefinitionKind instance corresponding to the given code .
from_int(int) - Static method in class org.omg.CORBA.ParameterMode
from_int(int) - Static method in class org.omg.CORBA.SetOverrideType
Converts the given int to the corresponding SetOverrideType instance.
from_int(int) - Static method in class org.omg.CORBA.TCKind
Converts the given int to the corresponding TCKind instance.
from_int(int) - Static method in class org.omg.CosNaming.BindingType
from_int(int) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
from_int(int) - Static method in class org.omg.PortableServer.IdAssignmentPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.IdUniquenessPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ImplicitActivationPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.LifespanPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.POAManagerPackage.State
from_int(int) - Static method in class org.omg.PortableServer.RequestProcessingPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ServantRetentionPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ThreadPolicyValue
fromCIEXYZ(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in the CS_CIEXYZ conversion color space into this ColorSpace.
fromCIEXYZ(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in the CS_CIEXYZ conversion color space into this ColorSpace.
fromIndex - Variable in class javax.swing.event.TableColumnModelEvent
The index of the column from where it was moved or removed
fromMethodDescriptorString(String, ClassLoader) - Static method in class java.lang.invoke.MethodType
Finds or creates an instance of a method type, given the spelling of its bytecode descriptor.
fromMillis(long) - Static method in class java.nio.file.attribute.FileTime
Returns a FileTime representing the given value in milliseconds.
fromRGB(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in the default CS_sRGB color space into this ColorSpace.
fromRGB(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in the default CS_sRGB color space into this ColorSpace.
fromString(String) - Static method in class java.nio.file.attribute.PosixFilePermissions
Returns the set of permissions corresponding to a given String representation.
fromString(String) - Static method in class java.util.UUID
Creates a UUID from the string standard representation as described in the UUID.toString() method.
FTP - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
File Transfer Protocol (FTP).
FULL - Static variable in class java.text.DateFormat
Constant for full style pattern.
FULL_DECOMPOSITION - Static variable in class java.text.Collator
Decomposition mode value.
FULL_FLUSH - Static variable in class java.util.zip.Deflater
Compression flush mode used to flush out all pending output and reset the deflater.
FULL_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a a full JOIN.
FULLWIDTH_DIGITS - Static variable in class java.awt.im.InputSubset
Constant for the fullwidth digits included in the Unicode halfwidth and fullwidth forms character block.
FULLWIDTH_LATIN - Static variable in class java.awt.im.InputSubset
Constant for the fullwidth ASCII variants subset of the Unicode halfwidth and fullwidth forms character block.
functionColumnIn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an IN parameter.
functionColumnInOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an INOUT parameter.
functionColumnOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an OUT parameter.
functionColumnResult - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is a column in a result set.
functionColumnUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that type of the parameter or column is unknown.
functionNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are not allowed.
functionNoTable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the function does not return a table.
functionNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are allowed.
functionNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that whether NULL values are allowed is unknown.
functionResultUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that it is not known whether the function returns a result or a table.
functionReturn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is a return value.
functionReturnsTable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the function returns a table.
FUSER_OVER_TEMP - Static variable in class javax.print.attribute.standard.PrinterStateReason
The fuser temperature is above normal.
FUSER_UNDER_TEMP - Static variable in class javax.print.attribute.standard.PrinterStateReason
The fuser temperature is below normal.
Future<V> - Interface in java.util.concurrent
A Future represents the result of an asynchronous computation.
FutureTask<V> - Class in java.util.concurrent
A cancellable asynchronous computation.
FutureTask(Callable<V>) - Constructor for class java.util.concurrent.FutureTask
Creates a FutureTask that will, upon running, execute the given Callable.
FutureTask(Runnable, V) - Constructor for class java.util.concurrent.FutureTask
Creates a FutureTask that will, upon running, execute the given Runnable, and arrange that get will return the given result on successful completion.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

ri("geEcccmaccphtt l


G-Index

概述

软件包

类

使用

树

已过时

Index

帮助

Java™ Platform
Standard Ed. 7
草案 ea-b138

Prev Letter

Next Letter

框架

无框架

所有的类

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
G

GAP_TOKEN - Static variable in exception org.ietf.jgss.GSSException

An expected per-message token was not received.

GapContent - Class in javax.swing.text

An implementation of the AbstractDocument.Content interface implemented using a gapped buffer similar to that used by emacs.

GapContent() - Constructor for class javax.swing.text.GapContent

Creates a new GapContent object.

GapContent(int) - Constructor for class javax.swing.text.GapContent

Creates a new GapContent object, with the initial size specified.

GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management.ManagementFactory

The domain name and the type key property in the ObjectName for a GarbageCollectorMXBean.

GarbageCollectorMXBean - Interface in java.lang.management

The management interface for the garbage collection of the Java virtual machine.

GatheringByteChannel - Interface in java.nio.channels

A channel that can write bytes from a sequence of buffers.

GaugeMonitor - Class in javax.management.monitor

Defines a monitor MBean designed to observe the values of a gauge attribute.

GaugeMonitor() - Constructor for class javax.management.monitor.GaugeMonitor

Default constructor.

GaugeMonitorMBean - Interface in javax.management.monitor

Exposes the remote management interface of the gauge monitor MBean.

gc() - Method in interface java.lang.management.MemoryMXBean

Runs the garbage collector.

gc() - Method in class java.lang.Runtime

Runs the garbage collector.

gc() - Static method in class java.lang.System

Runs the garbage collector.

gcd(BigInteger) - Method in class java.math.BigInteger

Returns a BigInteger whose value is the greatest common divisor of abs(this) and abs(val).

GDAY - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gDay.

GE - Static variable in class javax.management.Query

A code representing the Query.geq(javax.management.ValueExp, javax.management.ValueExp) query.

GENERAL - Static variable in interface javax.swing.text.html.parser.DTDConstants

GENERAL_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "General Punctuation" Unicode character block.

GeneralPath - Class in java.awt.geom

The GeneralPath class represents a geometric path constructed from straight lines, and quadratic and cubic (Bézier) curves.

GeneralPath() - Constructor for class java.awt.geom.GeneralPath

Constructs a new empty single precision GeneralPath object with a default winding rule of Path2D.WIND_NON_ZERO.

GeneralPath(int) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object with the specified winding rule to control operations that require the interior of the path to be defined.

GeneralPath(int, int) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object with the specified winding rule and the specified initial capacity to store path coordinates.

GeneralPath(Shape) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object from an arbitrary Shape object.

GeneralSecurityException - Exception in java.security

The GeneralSecurityException class is a generic security exception class that provides type safety for all the security-related exception classes that extend from it.

GeneralSecurityException() - Constructor for exception java.security.GeneralSecurityException

Constructs a GeneralSecurityException with no detail message.

GeneralSecurityException(String) - Constructor for exception java.security.GeneralSecurityException

Constructs a GeneralSecurityException with the specified detail message.

GeneralSecurityException(String, Throwable) - Constructor for exception java.security.GeneralSecurityException

Creates a GeneralSecurityException with the specified detail message and cause.

GeneralSecurityException(Throwable) - Constructor for exception java.security.GeneralSecurityException

Creates a GeneralSecurityException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

generateCertificate(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a certificate object and initializes it with the data read from the input stream inStream.

generateCertificates(InputStream) - Method in class java.security.cert.CertificateFactory

Returns a (possibly empty) collection view of the certificates read from the given input stream inStream.

generateCertPath(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with the data read from the InputStream inStream.

generateCertPath(InputStream, String) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with the data read from the InputStream inStream.

generateCertPath(List<? extends Certificate>) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with a List of Certificates.

generateCRL(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a certificate revocation list (CRL) object and initializes it with the data read from the input stream inStream.

generateCRLs(InputStream) - Method in class java.security.cert.CertificateFactory

Returns a (possibly empty) collection view of the CRLs read from the given input stream inStream.

Generated - Annotation Type in javax.annotation

The Generated annotation is used to mark source code that has been generated.

generatedKeyAlwaysReturned() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a generated key will always be returned if the column name(s) or index(es) specified for the auto generated key column(s) are valid and the statement succeeds.

generateKey() - Method in class javax.crypto.KeyGenerator

Generates a secret key.

generateKeyPair() - Method in class java.security.KeyPairGenerator

Generates a key pair.

generateKeyPair() - Method in class java.security.KeyPairGeneratorSpi

Generates a key pair.

generateParameters() - Method in class java.security.AlgorithmParameterGenerator

Generates the parameters.

generatePrivate(KeySpec) - Method in class java.security.KeyFactory

Generates a private key object from the provided key specification (key material).

generatePublic(KeySpec) - Method in class java.security.KeyFactory

Generates a public key object from the provided key specification (key material).

generateSchema(SchemaOutputResolver) - Method in class javax.xml.bind.JAXBContext

Generates the schema documents for this context.

generateSecret() - Method in class javax.crypto.KeyAgreement

Generates the shared secret and returns it in a new buffer.

generateSecret(byte[], int) - Method in class javax.crypto.KeyAgreement

Generates the shared secret, and places it into the buffer sharedSecret, beginning at offset inclusive.

generateSecret(String) - Method in class javax.crypto.KeyAgreement

Creates the shared secret and returns it as a SecretKey object of the specified algorithm.

generateSecret(KeySpec) - Method in class javax.crypto.SecretKeyFactory

Generates a SecretKey object from the provided key specification (key material).

generateSeed(int) - Method in class java.security.SecureRandom

Returns the given number of seed bytes, computed using the seed generation algorithm that this class uses to seed itself.

generic() - Method in class java.lang.invoke.MethodType

Converts all types, both reference and primitive, to Object.

GENERIC_FAILURE - Static variable in class java.util.logging.ErrorManager

GENERIC_FAILURE is used for failure that don't fit into one of the other categories.

GenericArrayType - Interface in java.lang.reflect

GenericArrayType represents an array type whose component type is either a parameterized type or a type variable.

GenericDeclaration - Interface in java.lang.reflect

A common interface for all entities that declare type variables.

genericInvoker(MethodType) - Static method in class java.lang.invoke.MethodHandles

Produces a special invoker method handle which can be used to invoke any method handle of the given type, as if by invokeGeneric.

genericMethodType(int, boolean) - Static method in class java.lang.invoke.MethodType

Finds or creates a method type whose components are Object with an optional trailing Object[] array.

genericMethodType(int) - Static method in class java.lang.invoke.MethodType

Finds or creates a method type whose components are all Object.

GenericSignatureFormatError - Error in java.lang.reflect

Thrown when a syntactically malformed signature attribute is encountered by a reflective method that needs to interpret the generic signature information for a type, method or constructor.

GenericSignatureFormatError() - Constructor for error java.lang.reflect.GenericSignatureFormatError

genExemptionBlob() - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob.

genExemptionBlob(byte[]) - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob, and stores the result in the output buffer.

genExemptionBlob(byte[], int) - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob, and stores the result in the output buffer, starting at outputOffset inclusive.

genKeyPair() - Method in class java.security.KeyPairGenerator

Generates a key pair.

GEOMETRIC_SHAPES - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Geometric Shapes" Unicode character block.

GEORGIAN - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Georgian" Unicode character block.

GEORGIAN_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Georgian Supplement" Unicode character block.

geq(ValueExp, ValueExp) - Static method in class javax.management.Query

Returns a query expression that represents a "greater than or equal to" constraint on two values.

GERMAN - Static variable in class java.util.Locale

Useful constant for language.

GERMANY - Static variable in class java.util.Locale

Useful constant for country.

get(Object) - Method in class java.awt.RenderingHints

Returns the value to which the specified key is mapped.

get(Object) - Method in class java.beans.Encoder

Returns a tentative value for oldInstance in the environment created by this stream.

get(String, boolean) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named boolean field from the persistent field.

get(String, byte) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named byte field from the persistent field.

get(String, char) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named char field from the persistent field.

get(String, short) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named short field from the persistent field.

get(String, int) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named int field from the persistent field.

get(String, long) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named long field from the persistent field.

get(String, float) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named float field from the persistent field.

get(String, double) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named double field from the persistent field.

get(String, Object) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named Object field from the persistent field.

get(Class<?>) - Method in class java.lang.ClassValue

Returns the value for the given class.

get() - Method in class java.lang.ref.PhantomReference

Returns this reference object's referent.

get() - Method in class java.lang.ref.Reference

Returns this reference object's referent.

get() - Method in class java.lang.ref.SoftReference

Returns this reference object's referent.

get(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object.

get(Object) - Method in class java.lang.reflect.字段

Returns the value of the field represented by this Field, on the specified object.

get() - Method in class java.lang.ThreadLocal

Returns the value in the current thread's copy of this thread-local variable.

get(URI, Map<String, List<String>>) - Method in class java.net.CookieHandler

Gets all the applicable cookies from a cookie cache for the specified uri in the request header.

get(URI, Map<String, List<String>>) - Method in class java.net.CookieManager

get(URI) - Method in interface java.net.CookieStore

Retrieve cookies associated with given URI, or whose domain matches the given URI.

get(URI, String, Map<String, List<String>>) - Method in class java.net.ResponseCache

Retrieve the cached response based on the requesting uri, request method and request headers.

get() - Method in class java.nio.ByteBuffer

Relative get method.

get(int) - Method in class java.nio.ByteBuffer

Absolute get method.

get(byte[], int, int) - Method in class java.nio.ByteBuffer

Relative bulk get method.

get(byte[]) - Method in class java.nio.ByteBuffer

Relative bulk get method.

get() - Method in class java.nio.CharBuffer

Relative get method.

get(int) - Method in class java.nio.CharBuffer

Absolute get method.

get(char[], int, int) - Method in class java.nio.CharBuffer

Relative bulk get method.

get(char[]) - Method in class java.nio.CharBuffer

Relative bulk get method.

get() - Method in class java.nio.DoubleBuffer

Relative get method.

get(int) - Method in class java.nio.DoubleBuffer

Absolute get method.

get(double[], int, int) - Method in class java.nio.DoubleBuffer

Relative bulk get method.

get(double[]) - Method in class java.nio.DoubleBuffer

Relative bulk get method.

get(String, String...) - Static method in class java.nio.file.Paths

Converts a path string, or a sequence of strings that when joined form a path string, to a Path.

get(URI) - Static method in class java.nio.file.Paths

Converts the given URI to a Path object.

get() - Method in class java.nio.FloatBuffer

Relative get method.

get(int) - Method in class java.nio.FloatBuffer

Absolute get method.

get(float[], int, int) - Method in class java.nio.FloatBuffer

Relative bulk get method.

get(float[]) - Method in class java.nio.FloatBuffer

Relative bulk get method.

get() - Method in class java.nio.IntBuffer

Relative get method.

get(int) - Method in class java.nio.IntBuffer

Absolute get method.

get(int[], int, int) - Method in class java.nio.IntBuffer

Relative bulk get method.

get(int[]) - Method in class java.nio.IntBuffer

Relative bulk get method.

get() - Method in class java.nio.LongBuffer

Relative get method.

get(int) - Method in class java.nio.LongBuffer

Absolute get method.

get(long[], int, int) - Method in class java.nio.LongBuffer

Relative bulk get method.

get(long[]) - Method in class java.nio.LongBuffer

Relative bulk get method.

get() - Method in class java.nio.ShortBuffer

Relative get method.

get(int) - Method in class java.nio.ShortBuffer

Absolute get method.

get(short[], int, int) - Method in class java.nio.ShortBuffer

Relative bulk get method.

get(short[]) - Method in class java.nio.ShortBuffer

Relative bulk get method.

get() - Method in class java.rmi.MarshalledObject

Returns a new copy of the contained marshalledobject.

get(Object) - Method in class java.security.Provider

get(int) - Method in class java.util.AbstractList

Returns the element at the specified position in this list.

get(Object) - Method in class java.util.AbstractMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.AbstractSequentialList

Returns the element at the specified position in this list.

get(int) - Method in class java.util.ArrayList

Returns the element at the specified position in this list.

get(int) - Method in class java.util.BitSet

Returns the value of the bit with the specified index.

get(int, int) - Method in class java.util.BitSet

Returns a new BitSet composed of bits from this BitSet from fromIndex (inclusive) to toIndex (exclusive).

get(int) - Method in class java.util.Calendar

Returns the value of the given calendar field.

get() - Method in class java.util.concurrent.atomic.AtomicBoolean

Returns the current value.

get() - Method in class java.util.concurrent.atomic.AtomicInteger

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get() - Method in class java.util.concurrent.atomic.AtomicLong

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get(boolean[]) - Method in class java.util.concurrent.atomic.AtomicMarkableReference

Returns the current values of both the reference and the mark.

get() - Method in class java.util.concurrent.atomic.AtomicReference

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get(int[]) - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current values of both the reference and the stamp.

get(Object) - Method in class java.util.concurrent.ConcurrentHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.concurrent.CopyOnWriteArrayList

Returns the element at the specified position in this list.

get() - Method in class java.util.concurrent.ForkJoinTask

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in class java.util.concurrent.ForkJoinTask

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get() - Method in interface java.util.concurrent.Future

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in interface java.util.concurrent.Future

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get() - Method in class java.util.concurrent.FutureTask

get(long, TimeUnit) - Method in class java.util.concurrent.FutureTask

get(Object) - Method in class java.util.Dictionary

Returns the value to which the key is mapped in this dictionary.

get(Object) - Method in class java.util.EnumMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.HashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.Hashtable

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.IdentityHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.jar.Attributes

Returns the value of the specified attribute name, or null if the attribute name was not found.

get(Object) - Method in class java.util.LinkedHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.LinkedList

Returns the element at the specified position in this list.

get(int) - Method in interface java.util.List

Returns the element at the specified position in this list.

get(Object) - Method in interface java.util.Map

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(String, String) - Method in class java.util.prefs.AbstractPreferences

Implements the get method as per the specification in Preferences.get(String,String).

get(String, String) - Method in class java.util.prefs.Preferences

Returns the value associated with the specified key in this preference node.

get(Object) - Method in class java.util.TreeMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.Vector

Returns the element at the specified position in this Vector.

get(Object) - Method in class java.util.WeakHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(String) - Method in class javax.accessibility.AccessibleRelationSet

Returns the relation that matches the specified key.

get(String) - Method in class javax.activation.MimeTypeParameterList

Retrieve the value associated with the given name, or null if there is no current association.

get(String) - Method in interface javax.management.openmbean.CompositeData

Returns the value of the item whose name is key.

get(String) - Method in class javax.management.openmbean.CompositeDataSupport

Returns the value of the item whose name is key.

get(Object[]) - Method in interface javax.management.openmbean.TabularData

Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

get(Object) - Method in class javax.management.openmbean.TabularDataSupport

This method simply calls get((Object[]) key).

get(Object[]) - Method in class javax.management.openmbean.TabularDataSupport

Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

get(int) - Method in class javax.naming.CompositeName

Retrieves a component of this composite name.

get(int) - Method in class javax.naming.CompoundName

Retrieves a component of this compound name.

get() - Method in interface javax.naming.directory.Attribute

Retrieves one of this attribute's values.

get(int) - Method in interface javax.naming.directory.Attribute

Retrieves the attribute value from the ordered list of attribute values.

get(String) - Method in interface javax.naming.directory.Attributes

Retrieves the attribute with the given attribute id from the attribute set.

get() - Method in class javax.naming.directory.BasicAttribute

Retrieves one of this attribute's values.

get(int) - Method in class javax.naming.directory.BasicAttribute

get(String) - Method in class javax.naming.directory.BasicAttributes

get(int) - Method in class javax.naming.ldap.LdapName

Retrieves a component of this LDAP name as a string.

get(int) - Method in interface javax.naming.Name

Retrieves a component of this name.

get(String) - Method in class javax.naming.Reference

Retrieves the first address that has the address type 'addrType'.

get(int) - Method in class javax.naming.Reference

Retrieves the address at index posn.

get(Class<?>) - Method in interface javax.print.attribute.AttributeSet

Returns the attribute value which this attribute set contains in the given attribute category.

get(Class<?>) - Method in class javax.print.attribute.HashAttributeSet

Returns the attribute value which this attribute set contains in the given attribute category.

get(String) - Method in class javax.script.AbstractScriptEngine

Gets the value for the specified key in the ENGINE_SCOPE of the protected context field.

get(Object) - Method in interface javax.script.Bindings

Returns the value to which this map maps the specified key.

get(String) - Method in interface javax.script.ScriptEngine

Retrieves a value set in the state of this engine.

get(String) - Method in class javax.script.ScriptEngineManager

Gets the value for the specified key in the Global Scope

get(Object) - Method in class javax.script.SimpleBindings

Returns the value to which this map maps the specified key.

get(int) - Method in class javax.sound.midi.Track

Obtains the event at the specified index.

get(Object) - Method in class javax.swing.ActionMap

Returns the binding for key, messaging the parent ActionMap if the binding is not locally defined.

get(int) - Method in class javax.swing.DefaultListModel

Returns the element at the specified position in this list.

get(KeyStroke) - Method in class javax.swing.InputMap

Returns the binding for keyStroke, messaging the parent InputMap if the binding is not locally defined.

get(SynthContext, Object) - Method in class javax.swing.plaf.nimbus.NimbusStyle

get(SynthContext, Object) - Method in class javax.swing.plaf.synth.SynthStyle

Getter for a region specific style property.

get() - Method in class javax.swing.SwingWorker

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in class javax.swing.SwingWorker

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get(Object) - Method in class javax.swing.UIDefaults

Returns the value for key.

get(Object, Locale) - Method in class javax.swing.UIDefaults

Returns the value for key associated with the given locale.

get(Object) - Static method in class javax.swing.UIManager

Returns an object from the defaults.

get(Object, Locale) - Static method in class javax.swing.UIManager

Returns an object from the defaults that is appropriate for the given locale.

get(Object) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the object that the specified key maps to.

get(Object) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the value to which this context maps the specified key.

get(Object) - Method in class javax.xml.soap.SOAPConnection

Gets a message from a specific endpoint and blocks until it receives,

get2DigitYearStart() - Method in class java.text.SimpleDateFormat

Returns the beginning date of the 100-year period 2-digit years are interpreted as being within.

get_any() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.Any contained in this DynAny object.

get_any() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynStructStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynValueStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts an Any value contained in the Any represented by this DynAny.

get_as_string() - Method in class org.omg.DynamicAny._DynEnumStub

Returns the value of the DynEnum as an IDL identifier.

get_as_string() - Method in interface org.omg.DynamicAny.DynEnumOperations

Returns the value of the DynEnum as an IDL identifier.

get_as_ulong() - Method in class org.omg.DynamicAny._DynEnumStub

Returns the value of the DynEnum as the enumerated value's ordinal value.

get_as_ulong() - Method in interface org.omg.DynamicAny.DynEnumOperations

Returns the value of the DynEnum as the enumerated value's ordinal value.

get_boolean() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the boolean contained in this DynAny object.

get_boolean() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the boolean value from this DynAny.

get_boxed_value() - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Returns the boxed value as an Any.

get_boxed_value_as_dyn_any() - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Returns the boxed value as a DynAny.

get_char() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the char contained in this DynAny object.

get_char() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the char value from this DynAny.

get_char() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the char value from this DynAny.

get_codebase(Object) - Method in class org.omg.CORBA_2_3.portable.Delegate

Returns the codebase for object reference provided.

get_compact_typecode() - Method in class org.omg.CORBA.TypeCode

Strips out all optional name and member name fields, but leaves all alias typecodes intact.

get_current() - Method in class org.omg.CORBA.ORB

Deprecated.
use resolve_initial_references.

get_default_context() - Method in class org.omg.CORBA.ORB

Gets the default Context object.

get_discriminator() - Method in class org.omg.DynamicAny._DynUnionStub

Returns the current discriminator value.

get_discriminator() - Method in interface org.omg.DynamicAny.DynUnionOperations

Returns the current discriminator value.

get_domain_managers(Object) - Method in class org.omg.CORBA.portable.Delegate

Retrieves the DomainManagers of this object.

get_domain_policy(int) - Method in interface org.omg.CORBA.DomainManagerOperations

This returns the policy of the specified type for objects in this domain.

get_double() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the double contained in this DynAny object.

get_double() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the double value from this DynAny.

get_double() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the double value from this DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_effective_component(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

get_effective_components(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns an array of all tagged components with the given ID from the profile selected for this request.

get_effective_policy(int) - Method in interface org.omg.PortableInterceptor.IORInfoOperations

Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.

get_elements() - Method in interface org.omg.CORBA.DynArray

Deprecated.

Returns the value of all the elements of this array.

get_elements() - Method in interface org.omg.CORBA.DynSequence

Deprecated.

Returns the value of every element in this sequence.

get_elements() - Method in class org.omg.DynamicAny._DynArrayStub

Returns the elements of the DynArray.

get_elements() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the elements of the sequence.

get_elements() - Method in interface org.omg.DynamicAny.DynArrayOperations

Returns the elements of the DynArray.

get_elements() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the elements of the sequence.

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny._DynArrayStub

Returns the elements of the DynArray as DynAnys.

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the DynAnys representing the elements of the sequence.

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny.DynArrayOperations

Returns the elements of the DynArray as DynAnys.

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the DynAnys representing the elements of the sequence.

get_float() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the float contained in this DynAny object.

get_float() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the float value from this DynAny.

get_float() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the float value from this DynAny.

get_id() - Method in interface org.omg.CORBA.portable.BoxedValueHelper

get_id() - Method in class org.omg.CORBA.StringValueHelper

get_id() - Method in class org.omg.CORBA.WStringValueHelper

get_interface_def(Object) - Method in class org.omg.CORBA.portable.Delegate

Return an InterfaceDef for the object reference provided.

get_interface_def(Servant) - Method in interface org.omg.PortableServer.portable.Delegate

This operation returns an object in the Interface Repository which provides type information that may be useful to a program.

get_length() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the current length of the sequence.

get_length() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the current length of the sequence.

get_long() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the int contained in this DynAny object.

get_long() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the integer value from this DynAny.

get_long() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the integer value from this DynAny.

get_longlong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the long contained in this DynAny object.

get_longlong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_longlong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_members() - Method in interface org.omg.CORBA.DynStruct

Deprecated.

Returns an array containing all the members of the stored struct.

get_members() - Method in interface org.omg.CORBA.DynValue

Deprecated.

Returns an array containing all the members of the value object stored in this DynValue.

get_members() - Method in class org.omg.DynamicAny._DynStructStub

Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members() - Method in class org.omg.DynamicAny._DynValueStub

Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.

get_members() - Method in interface org.omg.DynamicAny.DynStructOperations

Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members() - Method in interface org.omg.DynamicAny.DynValueOperations

Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.

get_members_as_dyn_any() - Method in class org.omg.DynamicAny._DynStructStub

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members_as_dyn_any() - Method in class org.omg.DynamicAny._DynValueStub

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny.DynStructOperations

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny.DynValueOperations

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.

get_next_response() - Method in class org.omg.CORBA.ORB

Gets the next Request instance for which a response has been received.

get_object_id() - Method in interface org.omg.PortableServer.CurrentOperations

Returns the ObjectId identifying the object in whose context it is called.

get_octet() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the byte contained in this DynAny object.

get_octet() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the byte value from this DynAny.

get_octet() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the byte value from this DynAny.

get_POA() - Method in interface org.omg.PortableServer.CurrentOperations

Returns reference to the POA implementing the object in whose context it is called.

get_policy(Object, int) - Method in class org.omg.CORBA.portable.Delegate

Returns the Policy object of the specified type which applies to this object.

get_primitive_tc(TCKind) - Method in class org.omg.CORBA.ORB

Retrieves the TypeCode object that represents the given primitive IDL type.

get_reference() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.Other contained in this DynAny object.

get_reference() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the reference to a CORBA Object from this DynAny.

get_reply_service_context(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns a copy of the service context with the given ID that is associated with the reply.

get_request_policy(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns the given policy in effect for this operation.

get_request_service_context(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns a copy of the service context with the given ID that is associated with the request.

get_response() - Method in class org.omg.CORBA.Request

Allows the user to access the response for the invocation triggered earlier with the send_deferred method.

get_servant() - Method in interface org.omg.PortableServer.POAOperations

This operation returns the default servant associated with the POA.

get_servant_manager() - Method in interface org.omg.PortableServer.POAOperations

If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.

get_server_policy(int) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Returns the policy in effect for this operation for the given policy type.

get_service_information(short, ServiceInformationHolder) - Method in class org.omg.CORBA.ORB

Used to obtain information about CORBA facilities and services that are supported by this ORB.

get_short() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the short contained in this DynAny object.

get_short() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the short value from this DynAny.

get_short() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the short value from this DynAny.

get_slot(int) - Method in interface org.omg.PortableInterceptor.CurrentOperations

Retrieves the slot data the application set in PICurrent via get_slot.

get_slot(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

get_state() - Method in interface org.omg.PortableServer.POAManagerOperations

This operation returns the state of the POA manager.

get_string() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the String contained in this DynAny object.

get_string() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the string value from this DynAny.

get_string() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the string value from this DynAny.

get_typecode() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.

get_typecode() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the TypeCode object from this DynAny.

get_ulong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the int contained in this DynAny object.

get_ulong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the integer value from this DynAny.

get_ulong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the integer value from this DynAny.

get_ulonglong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the long contained in this DynAny object.

get_ulonglong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_ushort() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the short contained in this DynAny object.

get_ushort() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the short value from this DynAny.

get_ushort() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the short value from this DynAny.

get_val() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the java.io.Serializable object contained in this DynAny object.

get_val() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynStructStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynValueStub

Extracts a Serializable object from this DynAny.

get_val() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts a Serializable object from this DynAny.

get_value() - Method in interface org.omg.CORBA.DynFixed

Deprecated.

Returns the value of the fixed type represented in this DynFixed object.

get_value() - Method in class org.omg.DynamicAny._DynFixedStub

Returns the value of a DynFixed.

get_value() - Method in interface org.omg.DynamicAny.DynFixedOperations

Returns the value of a DynFixed.

get_value_def(String) - Method in class org.omg.CORBA_2_3.ORB

get_values(String, int, String) - Method in class org.omg.CORBA.Context

Retrieves the NamedValue objects whose name field matches the given name or name pattern.

get_wchar() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the char contained in this DynAny object.

get_wchar() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_wchar() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_wstring() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the String contained in this DynAny object.

get_wstring() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the string value from this DynAny.

get_wstring() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the string value from this DynAny.

getA() - Method in class java.security.spec.EllipticCurve

Returns the first coefficient a of the elliptic curve.

getAbsoluteFile() - Method in class java.io.File

Returns the absolute form of this abstract pathname.

getAbsolutePath() - Method in class java.io.File

Returns the absolute pathname string of this abstract pathname.

getAccelerationPriority() - Method in class java.awt.Image

Returns the current value of the acceleration priority hint.

getAccelerator() - Method in class javax.swing.JMenuItem

Returns the KeyStroke which serves as an accelerator for the menu item.

getAcceleratorForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the accelerator foreground color of the current theme.

getAcceleratorForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the accelerator foreground color.

getAcceleratorSelectedForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the accelerator selected foreground color of the current theme.

getAcceleratorSelectedForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the accelerator selected foreground color.

getAcceleratorString() - Method in class javax.swing.plaf.metal.MetalToolTipUI

getAcceptAllFileFilter() - Method in class javax.swing.JFileChooser

Returns the AcceptAll file filter.

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Returns the default accept all file filter

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAcceptAllFileFilter method on each UI handled by this object.

getAcceptedIssuers() - Method in interface javax.net.ssl.X509TrustManager

Return an array of certificate authority certificates which are trusted for authenticating peers.

getAcceptorAddress() - Method in class org.ietf.jgss.ChannelBinding

Get the acceptor's address for this channel binding.

getAccessibleAction() - Method in class java.awt.Button.AccessibleAWTButton

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.Choice.AccessibleAWTChoice

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleAction associated with this object that supports one or more actions.

getAccessibleAction() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleAction() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleAction associated with this object that supports one or more actions.

getAccessibleAction() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleAction associated with this object if one exists.

getAccessibleAction() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAction() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

getAccessibleActionAnchor(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns an object that represents the link anchor, as appropriate for that link.

getAccessibleActionAnchor(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Return an object that represents the link anchor, as appropriate for that link.

getAccessibleActionCount() - Method in class java.awt.Button.AccessibleAWTButton

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.Choice.AccessibleAWTChoice

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in interface javax.accessibility.AccessibleAction

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class javax.accessibility.AccessibleHyperlink

Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g.

getAccessibleActionCount() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g.

getAccessibleActionCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of accessible actions available in this tree node.

getAccessibleActionCount() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Button.AccessibleAWTButton

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Choice.AccessibleAWTChoice

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in interface javax.accessibility.AccessibleAction

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns a String description of this particular link action.

getAccessibleActionDescription(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Return a String description of this particular link action.

getAccessibleActionDescription(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Return a description of the specified action of the tree node.

getAccessibleActionDescription(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns a description of the specified action of the object.

getAccessibleActionObject(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns an object that represents the link action, as appropriate for that link.

getAccessibleActionObject(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Returns a URL object that represents the link.

getAccessibleAt(Point) - Method in class java.awt.Component.AccessibleAWTComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.Container.AccessibleAWTContainer

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.List.AccessibleAWTList

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in interface javax.accessibility.AccessibleComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the Accessible at a specified row and column in the table.

getAccessibleAt(Point) - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleAt(Point) - Method in class javax.swing.JList.AccessibleJList

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getAccessibleAt(Point) - Method in class javax.swing.JTable.AccessibleJTable

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleAt(Point) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class javax.swing.JTree.AccessibleJTree

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Component, Point) - Static method in class javax.swing.SwingUtilities

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAt(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleCaption() - Method in interface javax.accessibility.AccessibleTable

Returns the caption for the table.

getAccessibleCaption() - Method in class javax.swing.JTable.AccessibleJTable

Returns the caption for the table.

getAccessibleChild(int) - Method in class java.awt.Component.AccessibleAWTComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.Container.AccessibleAWTContainer

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.List.AccessibleAWTList

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.accessibility.AccessibleContext

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleChild(int) - Method in class javax.swing.JList.AccessibleJList

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JRootPane.AccessibleJRootPane

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTree.AccessibleJTree

Return the nth Accessible child of the object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.ComponentUI

Returns the ith Accessible child of the object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the specified Accessible child of the object.

getAccessibleChild(Component, int) - Static method in class javax.swing.SwingUtilities

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChild(int) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Return the nth Accessible child of the object.

getAccessibleChildrenCount() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.Container.AccessibleAWTContainer

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class java.awt.List.AccessibleAWTList

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.accessibility.AccessibleContext

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleChildrenCount() - Method in class javax.swing.JList.AccessibleJList

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JRootPane.AccessibleJRootPane

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTree.AccessibleJTree

Returns the number of top-level children nodes of this JTree.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the number of accessible children in the object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the number of accessible children of the object.

getAccessibleChildrenCount(Component) - Static method in class javax.swing.SwingUtilities

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChildrenCount() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Returns the number of accessible children in the object.

getAccessibleColumn(int) - Method in interface javax.accessibility.AccessibleExtendedTable

Returns the column number of an index in the table.

getAccessibleColumn(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the column number of an index in the table.

getAccessibleColumnAtIndex(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the column at a given index into the table.

getAccessibleColumnCount() - Method in interface javax.accessibility.AccessibleTable

Returns the number of columns in the table.

getAccessibleColumnCount() - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleColumnDescription(int) - Method in interface javax.accessibility.AccessibleTable

Returns the description text of the specified column in the table.

getAccessibleColumnDescription(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the description of the specified column in the table.

getAccessibleColumnExtentAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the number of columns occupied by the Accessible at a specified row and column in the table.

getAccessibleColumnExtentAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of columns occupied by the Accessible at a given (row, column).

getAccessibleColumnHeader() - Method in interface javax.accessibility.AccessibleTable

Returns the column headers as an AccessibleTable.

getAccessibleColumnHeader() - Method in class javax.swing.JTable.AccessibleJTable

Returns the column headers as an AccessibleTable.

getAccessibleComponent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleComponent associated with this object that has a graphical representation.

getAccessibleComponent() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Get the AccessibleComponent associated with this object.

getAccessibleComponent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleComponent associated with this object.

getAccessibleComponent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleComponent associated with this object that has a graphical representation.

getAccessibleComponent() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Get the AccessibleComponent associated with this object.

getAccessibleContext() - Method in class java.applet.Applet

Gets the AccessibleContext associated with this Applet.

getAccessibleContext() - Method in class java.awt.Button

Gets the AccessibleContext associated with this Button.

getAccessibleContext() - Method in class java.awt.Canvas

Gets the AccessibleContext associated with this Canvas.

getAccessibleContext() - Method in class java.awt.Checkbox

Gets the AccessibleContext associated with this Checkbox.

getAccessibleContext() - Method in class java.awt.CheckboxMenuItem

Gets the AccessibleContext associated with this CheckboxMenuItem.

getAccessibleContext() - Method in class java.awt.Choice

Gets the AccessibleContext associated with this Choice.

getAccessibleContext() - Method in class java.awt.Component

Gets the AccessibleContext associated with this Component.

getAccessibleContext() - Method in class java.awt.Dialog

Gets the AccessibleContext associated with this Dialog.

getAccessibleContext() - Method in class java.awt.Frame

Gets the AccessibleContext associated with this Frame.

getAccessibleContext() - Method in class java.awt.Label

Gets the AccessibleContext associated with this Label.

getAccessibleContext() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the AccessibleContext for this object.

getAccessibleContext() - Method in class java.awt.List

Gets the AccessibleContext associated with this List.

getAccessibleContext() - Method in class java.awt.Menu

Gets the AccessibleContext associated with this Menu.

getAccessibleContext() - Method in class java.awt.MenuBar

Gets the AccessibleContext associated with this MenuBar.

getAccessibleContext() - Method in class java.awt.MenuComponent

Gets the AccessibleContext associated with this MenuComponent.

getAccessibleContext() - Method in class java.awt.MenuItem

Gets the AccessibleContext associated with this MenuItem.

getAccessibleContext() - Method in class java.awt.Panel

Gets the AccessibleContext associated with this Panel.

getAccessibleContext() - Method in class java.awt.PopupMenu

Gets the AccessibleContext associated with this PopupMenu.

getAccessibleContext() - Method in class java.awt.Scrollbar

Gets the AccessibleContext associated with this Scrollbar.

getAccessibleContext() - Method in class java.awt.ScrollPane

Gets the AccessibleContext associated with this ScrollPane.

getAccessibleContext() - Method in class java.awt.TextArea

Returns the AccessibleContext associated with this TextArea.

getAccessibleContext() - Method in class java.awt.TextComponent

Gets the AccessibleContext associated with this TextComponent.

getAccessibleContext() - Method in class java.awt.TextField

Gets the AccessibleContext associated with this TextField.

getAccessibleContext() - Method in class java.awt.Window

Gets the AccessibleContext associated with this Window.

getAccessibleContext() - Method in interface javax.accessibility.Accessible

Returns the AccessibleContext associated with this object.

getAccessibleContext() - Method in class javax.swing.Box.Filler

Gets the AccessibleContext associated with this Box.Filler.

getAccessibleContext() - Method in class javax.swing.Box

Gets the AccessibleContext associated with this Box.

getAccessibleContext() - Method in class javax.swing.CellRendererPane

Gets the AccessibleContext associated with this CellRendererPane.

getAccessibleContext() - Method in class javax.swing.ImageIcon

Gets the AccessibleContext associated with this ImageIcon.

getAccessibleContext() - Method in class javax.swing.JApplet

Gets the AccessibleContext associated with this JApplet.

getAccessibleContext() - Method in class javax.swing.JButton

Gets the AccessibleContext associated with this JButton.

getAccessibleContext() - Method in class javax.swing.JCheckBox

Gets the AccessibleContext associated with this JCheckBox.

getAccessibleContext() - Method in class javax.swing.JCheckBoxMenuItem

Gets the AccessibleContext associated with this JCheckBoxMenuItem.

getAccessibleContext() - Method in class javax.swing.JColorChooser

Gets the AccessibleContext associated with this JColorChooser.

getAccessibleContext() - Method in class javax.swing.JComboBox

Gets the AccessibleContext associated with this JComboBox.

getAccessibleContext() - Method in class javax.swing.JComponent

Returns the AccessibleContext associated with this JComponent.

getAccessibleContext() - Method in class javax.swing.JDesktopPane

Gets the AccessibleContext associated with this JDesktopPane.

getAccessibleContext() - Method in class javax.swing.JDialog

Gets the AccessibleContext associated with this JDialog.

getAccessibleContext() - Method in class javax.swing.JEditorPane

Gets the AccessibleContext associated with this JEditorPane.

getAccessibleContext() - Method in class javax.swing.JFileChooser

Gets the AccessibleContext associated with this JFileChooser.

getAccessibleContext() - Method in class javax.swing.JFrame

Gets the AccessibleContext associated with this JFrame.

getAccessibleContext() - Method in class javax.swing.JInternalFrame

Gets the AccessibleContext associated with this JInternalFrame.

getAccessibleContext() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Gets the AccessibleContext associated with this JDesktopIcon.

getAccessibleContext() - Method in class javax.swing.JLabel

Get the AccessibleContext of this object

getAccessibleContext() - Method in class javax.swing.JLayer

Gets the AccessibleContext associated with this JLayer.

getAccessibleContext() - Method in class javax.swing.JLayeredPane

Gets the AccessibleContext associated with this JLayeredPane.

getAccessibleContext() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Get the AccessibleContext for this object.

getAccessibleContext() - Method in class javax.swing.JList

Gets the AccessibleContext associated with this JList.

getAccessibleContext() - Method in class javax.swing.JMenu

Gets the AccessibleContext associated with this JMenu.

getAccessibleContext() - Method in class javax.swing.JMenuBar

Gets the AccessibleContext associated with this JMenuBar.

getAccessibleContext() - Method in class javax.swing.JMenuItem

Returns the AccessibleContext associated with this JMenuItem.

getAccessibleContext() - Method in class javax.swing.JOptionPane

Returns the AccessibleContext associated with this JOptionPane.

getAccessibleContext() - Method in class javax.swing.JPanel

Gets the AccessibleContext associated with this JPanel.

getAccessibleContext() - Method in class javax.swing.JPasswordField

Returns the AccessibleContext associated with this JPasswordField.

getAccessibleContext() - Method in class javax.swing.JPopupMenu

Gets the AccessibleContext associated with this JPopupMenu.

getAccessibleContext() - Method in class javax.swing.JProgressBar

Gets the AccessibleContext associated with this JProgressBar.

getAccessibleContext() - Method in class javax.swing.JRadioButton

Gets the AccessibleContext associated with this JRadioButton.

getAccessibleContext() - Method in class javax.swing.JRadioButtonMenuItem

Gets the AccessibleContext associated with this JRadioButtonMenuItem.

getAccessibleContext() - Method in class javax.swing.JRootPane

Gets the AccessibleContext associated with this JRootPane.

getAccessibleContext() - Method in class javax.swing.JScrollBar

Gets the AccessibleContext associated with this JScrollBar.

getAccessibleContext() - Method in class javax.swing.JScrollPane

Gets the AccessibleContext associated with this JScrollPane.

getAccessibleContext() - Method in class javax.swing.JSeparator

Gets the AccessibleContext associated with this JSeparator.

getAccessibleContext() - Method in class javax.swing.JSlider

Gets the AccessibleContext associated with this JSlider.

getAccessibleContext() - Method in class javax.swing.JSpinner

Gets the AccessibleContext for the JSpinner

getAccessibleContext() - Method in class javax.swing.JSplitPane

Gets the AccessibleContext associated with this JSplitPane.

getAccessibleContext() - Method in class javax.swing.JTabbedPane

Gets the AccessibleContext associated with this JTabbedPane.

getAccessibleContext() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleContext associated with this component.

getAccessibleContext() - Method in class javax.swing.JTable

Gets the AccessibleContext associated with this JTable.

getAccessibleContext() - Method in class javax.swing.JTextArea

Gets the AccessibleContext associated with this JTextArea.

getAccessibleContext() - Method in class javax.swing.JTextField

Gets the AccessibleContext associated with this JTextField.

getAccessibleContext() - Method in class javax.swing.JToggleButton

Gets the AccessibleContext associated with this JToggleButton.

getAccessibleContext() - Method in class javax.swing.JToolBar

Gets the AccessibleContext associated with this JToolBar.

getAccessibleContext() - Method in class javax.swing.JToolTip

Gets the AccessibleContext associated with this JToolTip.

getAccessibleContext() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleContext associated with this tree node.

getAccessibleContext() - Method in class javax.swing.JTree

Gets the AccessibleContext associated with this JTree.

getAccessibleContext() - Method in class javax.swing.JViewport

Gets the AccessibleContext associated with this JViewport.

getAccessibleContext() - Method in class javax.swing.JWindow

Gets the AccessibleContext associated with this JWindow.

getAccessibleContext() - Method in class javax.swing.plaf.basic.BasicComboPopup

Gets the AccessibleContext associated with this BasicComboPopup.

getAccessibleContext() - Method in class javax.swing.ProgressMonitor

Gets the AccessibleContext for the ProgressMonitor

getAccessibleContext() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Get the AccessibleContext associated with this object.

getAccessibleContext() - Method in class javax.swing.table.JTableHeader

Gets the AccessibleContext associated with this JTableHeader.

getAccessibleContext() - Method in class javax.swing.text.html.HTMLEditorKit

returns the AccessibleContext associated with this editor kit

getAccessibleContext() - Method in class javax.swing.text.JTextComponent

Gets the AccessibleContext associated with this JTextComponent.

getAccessibleDescription() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.accessibility.AccessibleContext

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JEditorPane.AccessibleJEditorPane

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleDescription() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JToolTip.AccessibleJToolTip

Get the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleEditableText() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleEditableText associated with this object presenting editable text on the display.

getAccessibleEditableText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleEditableText interface for this text component.

getAccessibleIcon() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleIcons associated with an object that has one or more associated icons

getAccessibleIcon() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleIcons associated with this object if one or more exist.

getAccessibleIcon() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the AccessibleIcons associated with this object if one or more exist.

getAccessibleIcon() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Returns the icon for the element renderer, as the only item of an array of AccessibleIcons or a null array if the renderer component contains no icons.

getAccessibleIconDescription() - Method in interface javax.accessibility.AccessibleIcon

Gets the description of the icon.

getAccessibleIconDescription() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the description of the icon.

getAccessibleIconHeight() - Method in interface javax.accessibility.AccessibleIcon

Gets the height of the icon

getAccessibleIconHeight() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the height of the icon.

getAccessibleIconWidth() - Method in interface javax.accessibility.AccessibleIcon

Gets the width of the icon

getAccessibleIconWidth() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the width of the icon.

getAccessibleIndex(int, int) - Method in interface javax.accessibility.AccessibleExtendedTable

getAccessibleIndex(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the index at a row and column in the table.

getAccessibleIndexAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the index at a given (row, column) in the table.

getAccessibleIndexInParent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.accessibility.AccessibleContext

Gets the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleIndexInParent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JTree.AccessibleJTree

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent(Component) - Static method in class javax.swing.SwingUtilities

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleKeyBinding() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns key bindings associated with this object

getAccessibleKeyBinding(int) - Method in interface javax.accessibility.AccessibleKeyBinding

Returns a key binding for this object.

getAccessibleKeyBinding() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns key bindings associated with this object

getAccessibleKeyBinding() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns key bindings associated with this object

getAccessibleKeyBinding() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns key bindings associated with this object

getAccessibleKeyBindingCount() - Method in interface javax.accessibility.AccessibleKeyBinding

Returns the number of key bindings for this object

getAccessibleName() - Method in class java.awt.Button.AccessibleAWTButton

Get the accessible name of this object.

getAccessibleName() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class java.awt.Label.AccessibleAWTLabel

Get the accessible name of this object.

getAccessibleName() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the accessible name of this object.

getAccessibleName() - Method in class javax.accessibility.AccessibleContext

Gets the accessibleName property of this object.

getAccessibleName() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JDialog.AccessibleJDialog

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JFrame.AccessibleJFrame

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleName() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the accessible name of this object, or null if there is no accessible name.

getAccessibleName() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the accessibleName property of this object.

getAccessibleName() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleParent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.accessibility.AccessibleContext

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the Accessible parent of this object.

getAccessibleRelationSet() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleRelationSet associated with an object

getAccessibleRelationSet() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleRelationSet associated with this object if one exists.

getAccessibleRelationSet() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the AccessibleRelationSet associated with this object if one exists.

getAccessibleRole() - Method in class java.applet.Applet.AccessibleApplet

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Button.AccessibleAWTButton

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Canvas.AccessibleAWTCanvas

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the role of this object.

getAccessibleRole() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Choice.AccessibleAWTChoice

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.Dialog.AccessibleAWTDialog

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Frame.AccessibleAWTFrame

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Label.AccessibleAWTLabel

Get the role of this object.

getAccessibleRole() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the role of this object.

getAccessibleRole() - Method in class java.awt.List.AccessibleAWTList

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Menu.AccessibleAWTMenu

Get the role of this object.

getAccessibleRole() - Method in class java.awt.MenuBar.AccessibleAWTMenuBar

Get the role of this object.

getAccessibleRole() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Panel.AccessibleAWTPanel

Get the role of this object.

getAccessibleRole() - Method in class java.awt.PopupMenu.AccessibleAWTPopupMenu

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the role of this object.

getAccessibleRole() - Method in class java.awt.ScrollPane.AccessibleAWTScrollPane

Get the role of this object.

getAccessibleRole() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.Window.AccessibleAWTWindow

Get the role of this object.

getAccessibleRole() - Method in class javax.accessibility.AccessibleContext

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.Box.AccessibleBox

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.Box.Filler.AccessibleBoxFiller

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.CellRendererPane.AccessibleCellRendererPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JButton.AccessibleJButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JCheckBox.AccessibleJCheckBox

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JColorChooser.AccessibleJColorChooser

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JDesktopPane.AccessibleJDesktopPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JFileChooser.AccessibleJFileChooser

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JLayeredPane.AccessibleJLayeredPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleRole() - Method in class javax.swing.JList.AccessibleJList

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenu.AccessibleJMenu

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenuItem.AccessibleJMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JOptionPane.AccessibleJOptionPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JPanel.AccessibleJPanel

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JPopupMenu.AccessibleJPopupMenu

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JRadioButton.AccessibleJRadioButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JRootPane.AccessibleJRootPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JScrollPane.AccessibleJScrollPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSeparator.AccessibleJSeparator

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JTable.AccessibleJTable

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JToggleButton.AccessibleJToggleButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JToolBar.AccessibleJToolBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JToolTip.AccessibleJToolTip

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTree.AccessibleJTree

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JViewport.AccessibleJViewport

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleRole() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Gets the role of this object.

getAccessibleRow(int) - Method in interface javax.accessibility.AccessibleExtendedTable

Returns the row number of an index in the table.

getAccessibleRow(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the row number of an index in the table.

getAccessibleRowAtIndex(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the row at a given index into the table.

getAccessibleRowCount() - Method in interface javax.accessibility.AccessibleTable

Returns the number of rows in the table.

getAccessibleRowCount() - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleRowDescription(int) - Method in interface javax.accessibility.AccessibleTable

Returns the description of the specified row in the table.

getAccessibleRowDescription(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the description of the specified row in the table.

getAccessibleRowExtentAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the number of rows occupied by the Accessible at a specified row and column in the table.

getAccessibleRowExtentAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of rows occupied by the Accessible at a specified row and column in the table.

getAccessibleRowHeader() - Method in interface javax.accessibility.AccessibleTable

Returns the row headers as an AccessibleTable.

getAccessibleRowHeader() - Method in class javax.swing.JTable.AccessibleJTable

Returns the row headers as an AccessibleTable.

getAccessibleSelection() - Method in class java.awt.List.AccessibleAWTList

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class java.awt.List.AccessibleAWTList

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.

getAccessibleSelection(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns an Accessible representing the specified selected child in the object.

getAccessibleSelection() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.

getAccessibleSelection(int) - Method in interface javax.accessibility.AccessibleSelection

Returns an Accessible representing the specified selected child of the object.

getAccessibleSelection() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns an Accessible representing the specified selected child in the popup.

getAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JList.AccessibleJList

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.JMenu.AccessibleJMenu

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the currently selected sub-menu if one is selected, otherwise null (there can only be one selection, and it can only be a sub-menu, as otherwise menu items don't remain selected).

getAccessibleSelection() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Returns the currently selected menu if one is selected, otherwise null.

getAccessibleSelection() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Gets the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

getAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleSelection associated with this object if one exists.

getAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns an Accessible representing the specified selected child in the object.

getAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleSelection associated with this object if one exists.

getAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleSelectionCount() - Method in class java.awt.List.AccessibleAWTList

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in interface javax.accessibility.AccessibleSelection

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JList.AccessibleJList

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JMenu.AccessibleJMenu

Returns 1 if a sub-menu is currently selected in this menu.

getAccessibleSelectionCount() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Returns 1 if a menu is currently selected in this menu bar.

getAccessibleSelectionCount() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

getAccessibleSelectionCount() - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JTree.AccessibleJTree

Returns the number of items currently selected.

getAccessibleStateSet() - Method in class java.applet.Applet.AccessibleApplet

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class java.awt.Dialog.AccessibleAWTDialog

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.Frame.AccessibleAWTFrame

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.List.AccessibleAWTList

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.TextArea.AccessibleAWTTextArea

Gets the state set of this object.

getAccessibleStateSet() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Gets the state set of the TextComponent.

getAccessibleStateSet() - Method in class java.awt.TextField.AccessibleAWTTextField

Gets the state set of this object.

getAccessibleStateSet() - Method in class java.awt.Window.AccessibleAWTWindow

Get the state of this object.

getAccessibleStateSet() - Method in class javax.accessibility.AccessibleContext

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JDialog.AccessibleJDialog

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JEditorPane.AccessibleJEditorPane

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JFrame.AccessibleJFrame

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleStateSet() - Method in class javax.swing.JList.AccessibleJList

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the accessible state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTextArea.AccessibleJTextArea

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTextField.AccessibleJTextField

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JToolBar.AccessibleJToolBar

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the state set of this object.

getAccessibleStateSet(Component) - Static method in class javax.swing.SwingUtilities

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleStateSet() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Gets the state set of the JTextComponent.

getAccessibleSummary() - Method in interface javax.accessibility.AccessibleTable

Returns the summary description of the table.

getAccessibleSummary() - Method in class javax.swing.JTable.AccessibleJTable

Returns the summary description of the table.

getAccessibleTable() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleTable associated with an object

getAccessibleTable() - Method in class javax.swing.JTable.AccessibleJTable

Gets the AccessibleTable associated with this object.

getAccessibleText() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Get the AccessibleText associated with this object.

getAccessibleText() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

getAccessibleText() - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

getAccessibleText() - Method in class javax.swing.JLabel.AccessibleJLabel

getAccessibleText() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleText() - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Gets the AccessibleText for the JPasswordField.

getAccessibleText() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleText associated with this object if one exists.

getAccessibleText() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleText associated with this object if one exists.

getAccessibleText() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Get the AccessibleText associated with this object.

getAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleValue associated with this object that supports a Numerical value.

getAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleValue associated with this object if one exists.

getAccessibleValue() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleValue associated with this object if one exists.

getAccessibleValue() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleValue associated with this object that supports a Numerical value.

getAccessibleValue() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessLevel() - Method in class javax.tools.ForwardingJavaFileObject

getAccessLevel() - Method in interface javax.tools.JavaFileObject

Provides a hint about the access level of the class represented by this file object.

getAccessLevel() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns null.

getAccessory() - Method in class javax.swing.JFileChooser

Returns the accessory component.

getAccessoryPanel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of AC Huffman tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of AC Huffman tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getAcl() - Method in interface java.nio.file.attribute.AclFileAttributeView

Reads the access control list.

getAction() - Method in class java.beans.EventHandler

Returns the name of the target's writable property that this event handler will set, or the name of the method that this event handler will invoke on the target.

getAction() - Method in class javax.swing.AbstractButton

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction() - Method in class javax.swing.JComboBox

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction() - Method in class javax.swing.JTextField

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction(KeyStroke) - Method in interface javax.swing.text.Keymap

Fetches the action appropriate for the given symbolic event sequence.

getActionCommand() - Method in class java.awt.Button

Returns the command name of the action event fired by this button.

getActionCommand() - Method in class java.awt.event.ActionEvent

Returns the command string associated with this action.

getActionCommand() - Method in class java.awt.MenuItem

Gets the command name of the action event that is fired by this menu item.

getActionCommand() - Method in class java.awt.TrayIcon

Returns the command name of the action event fired by this tray icon.

getActionCommand() - Method in class javax.swing.AbstractButton

Returns the action command for this button.

getActionCommand() - Method in interface javax.swing.ButtonModel

Returns the action command string for the button.

getActionCommand() - Method in class javax.swing.DefaultButtonModel

Returns the action command string for the button.

getActionCommand() - Method in class javax.swing.JComboBox

Returns the action command that is included in the event sent to action listeners.

getActionCommand() - Method in class javax.swing.Timer

Returns the string that will be delivered as the action command in ActionEvents fired by this timer.

getActionForKeyStroke(KeyStroke) - Method in class javax.swing.JComponent

Returns the object that will perform the action registered for a given keystroke.

getActionListeners() - Method in class java.awt.Button

Returns an array of all the action listeners registered on this button.

getActionListeners() - Method in class java.awt.List

Returns an array of all the action listeners registered on this list.

getActionListeners() - Method in class java.awt.MenuItem

Returns an array of all the action listeners registered on this menu item.

getActionListeners() - Method in class java.awt.TextField

Returns an array of all the action listeners registered on this textfield.

getActionListeners() - Method in class java.awt.TrayIcon

Returns an array of all the action listeners registered on this TrayIcon.

getActionListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ActionListeners added to this AbstractButton with addActionListener().

getActionListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the action listeners registered on this DefaultButtonModel.

getActionListeners() - Method in class javax.swing.JComboBox

Returns an array of all the ActionListeners added to this JComboBox with addActionListener().

getActionListeners() - Method in class javax.swing.JFileChooser

Returns an array of all the action listeners registered on this file chooser.

getActionListeners() - Method in class javax.swing.JTextField

Returns an array of all the ActionListeners added to this JTextField with addActionListener().

getActionListeners() - Method in class javax.swing.Timer

Returns an array of all the action listeners registered on this timer.

getActionMap() - Method in class javax.swing.JComponent

Returns the ActionMap used to determine what Action to fire for particular KeyStroke binding.

getActionMap() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getActions() - Method in class java.io.FilePermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class java.net.SocketPermission

Returns the canonical string representation of the actions.

getActions() - Method in class java.security.AllPermission

Returns the canonical string representation of the actions.

getActions() - Method in class java.security.BasicPermission

Returns the canonical string representation of the actions, which currently is the empty string "", since there are no actions for a BasicPermission.

getActions() - Method in class java.security.Permission

Returns the actions as a String.

getActions() - Method in class java.security.UnresolvedPermission

Returns the canonical string representation of the actions, which currently is the empty string "", since there are no actions for an UnresolvedPermission.

getActions() - Method in class java.util.PropertyPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.management.MBeanPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.security.auth.kerberos.ServicePermission

Returns the canonical string representation of the actions.

getActions() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a custom set of Actions.

getActions() - Method in class javax.swing.JFormattedTextField

Fetches the command list for the editor.

getActions() - Method in class javax.swing.JTextField

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.DefaultEditorKit

Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.

getActions() - Method in class javax.swing.text.EditorKit

Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.

getActions() - Method in class javax.swing.text.html.HTMLEditorKit

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.InternationalFormatter

If getSupportsIncrement returns true, this returns two Actions suitable for incrementing/decrementing the value.

getActions() - Method in class javax.swing.text.JTextComponent

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.StyledEditorKit

Fetches the command list for the editor.

getActivationDesc(ActivationID) - Method in interface java.rmi.activation.ActivationSystem

Returns the activation descriptor, for the object with the activation identifier, id.

getActivationGroupDesc(ActivationGroupID) - Method in interface java.rmi.activation.ActivationSystem

Returns the activation group descriptor, for the group with the activation group identifier, id.

getActiveCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate number of threads that are actively executing tasks.

getActiveThreadCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of threads that are currently stealing or executing tasks.

getActiveWindow() - Method in class java.awt.KeyboardFocusManager

Returns the active Window, if the active Window is in the same context as the calling thread.

getActor() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the uri of the actor attribute of this SOAPHeaderElement.

getActualMaximum(int) - Method in class java.util.Calendar

Returns the maximum value that the specified calendar field could have, given the time value of this Calendar.

getActualMaximum(int) - Method in class java.util.GregorianCalendar

Returns the maximum value that this calendar field could have, taking into consideration the given time value and the current values of the getFirstDayOfWeek, getMinimalDaysInFirstWeek, getGregorianChange and getTimeZone methods.

getActualMinimum(int) - Method in class java.util.Calendar

Returns the minimum value that the specified calendar field could have, given the time value of this Calendar.

getActualMinimum(int) - Method in class java.util.GregorianCalendar

Returns the minimum value that this calendar field could have, taking into consideration the given time value and the current values of the getFirstDayOfWeek, getMinimalDaysInFirstWeek, getGregorianChange and getTimeZone methods.

getActualTypeArguments() - Method in interface java.lang.reflect.ParameterizedType

Returns an array of Type objects representing the actual type arguments to this type.

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAdapter(Class<A>) - Method in interface javax.xml.bind.Marshaller

Gets the adapter associated with the specified type.

getAdapter(Class<A>) - Method in interface javax.xml.bind.Unmarshaller

Gets the adapter associated with the specified type.

getAdditionalBeanInfo() - Method in interface java.beans.BeanInfo

This method allows a BeanInfo object to return an arbitrary collection of other BeanInfo objects that provide additional information on the current bean.

getAdditionalBeanInfo() - Method in class java.beans.SimpleBeanInfo

Claim there are no other relevant BeanInfo objects.

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

getAddListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to add event listeners.

getAddress() - Method in class java.net.DatagramPacket

Returns the IP address of the machine to which this datagram is being sent or from which the datagram was received.

getAddress() - Method in class java.net.Inet4Address

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.Inet6Address

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.InetAddress

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.InetSocketAddress

Gets the InetAddress.

getAddress() - Method in class java.net.InterfaceAddress

Returns an InetAddress for this address.

getAddress() - Method in interface javax.management.remote.JMXAddressable

The address of this object.

getAddress() - Method in interface javax.management.remote.JMXConnectorServerMBean

The address of this connector server.

getAddress() - Method in class javax.management.remote.rmi.RMIConnector

The address of this connector.

getAddress() - Method in class javax.management.remote.rmi.RMIConnectorServer

getAdjustable() - Method in class java.awt.event.AdjustmentEvent

Returns the Adjustable object where this event originated.

getAdjustmentListeners() - Method in class java.awt.Scrollbar

Returns an array of all the adjustment listeners registered on this scrollbar.

getAdjustmentListeners() - Method in class java.awt.ScrollPaneAdjustable

Returns an array of all the adjustment listeners registered on this ScrollPaneAdjustable.

getAdjustmentListeners() - Method in class javax.swing.JScrollBar

Returns an array of all the AdjustmentListeners added to this JScrollBar with addAdjustmentListener().

getAdjustmentType() - Method in class java.awt.event.AdjustmentEvent

Returns the type of adjustment which caused the value changed event.

getAdler() - Method in class java.util.zip.Deflater

Returns the ADLER-32 value of the uncompressed data.

getAdler() - Method in class java.util.zip.Inflater

Returns the ADLER-32 value of the uncompressed data.

getAdvance() - Method in class java.awt.font.GlyphMetrics

Returns the advance of the glyph along the baseline (either horizontal or vertical).

getAdvance() - Method in class java.awt.font.GraphicAttribute

Returns the advance of this GraphicAttribute.

getAdvance() - Method in class java.awt.font.ImageGraphicAttribute

Returns the advance of this ImageGraphicAttribute.

getAdvance() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the advance of this ShapeGraphicAttribute.

getAdvance() - Method in class java.awt.font.TextLayout

Returns the advance of this TextLayout.

getAdvanceBetween(int, int) - Method in class java.awt.font.TextMeasurer

Returns the graphical width of a line beginning at start and including characters up to limit.

getAdvanceX() - Method in class java.awt.font.GlyphMetrics

Returns the x-component of the advance of the glyph.

getAdvanceY() - Method in class java.awt.font.GlyphMetrics

Returns the y-component of the advance of the glyph.

getAffineX() - Method in class java.security.spec.ECPoint

Returns the affine x-coordinate x.

getAffineY() - Method in class java.security.spec.ECPoint

Returns the affine y-coordinate y.

getAfterIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String after a given index.

getAfterIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String after a given index.

getAlgName() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the encryption algorithm.

getAlgorithm() - Method in class java.security.AlgorithmParameterGenerator

Returns the standard name of the algorithm this parameter generator is associated with.

getAlgorithm() - Method in class java.security.AlgorithmParameters

Returns the name of the algorithm associated with this parameter object.

getAlgorithm() - Method in class java.security.cert.CertPathBuilder

Returns the name of the algorithm of this CertPathBuilder.

getAlgorithm() - Method in class java.security.cert.CertPathValidator

Returns the algorithm name of this CertPathValidator.

getAlgorithm() - Method in interface java.security.Key

Returns the standard algorithm name for this key.

getAlgorithm() - Method in class java.security.KeyFactory

Gets the name of the algorithm associated with this KeyFactory.

getAlgorithm() - Method in class java.security.KeyPairGenerator

Returns the standard name of the algorithm for this key pair generator.

getAlgorithm() - Method in class java.security.MessageDigest

Returns a string that identifies the algorithm, independent of implementation details.

getAlgorithm() - Method in class java.security.Provider.Service

Return the name of the algorithm of this service.

getAlgorithm() - Method in class java.security.SecureRandom

Returns the name of the algorithm implemented by this SecureRandom object.

getAlgorithm() - Method in class java.security.Signature

Returns the name of the algorithm for this signature object.

getAlgorithm() - Method in class java.security.SignedObject

Retrieves the name of the signature algorithm.

getAlgorithm() - Method in class javax.crypto.Cipher

Returns the algorithm name of this Cipher object.

getAlgorithm() - Method in class javax.crypto.KeyAgreement

Returns the algorithm name of this KeyAgreement object.

getAlgorithm() - Method in class javax.crypto.KeyGenerator

Returns the algorithm name of this KeyGenerator object.

getAlgorithm() - Method in class javax.crypto.Mac

Returns the algorithm name of this Mac object.

getAlgorithm() - Method in class javax.crypto.SealedObject

Returns the algorithm that was used to seal this object.

getAlgorithm() - Method in class javax.crypto.SecretKeyFactory

Returns the algorithm name of this SecretKeyFactory object.

getAlgorithm() - Method in class javax.crypto.spec.PSource

Returns the PSource algorithm name.

getAlgorithm() - Method in class javax.crypto.spec.SecretKeySpec

Returns the name of the algorithm associated with this secret key.

getAlgorithm() - Method in class javax.net.ssl.KeyManagerFactory

Returns the algorithm name of this KeyManagerFactory object.

getAlgorithm() - Method in class javax.net.ssl.TrustManagerFactory

Returns the algorithm name of this TrustManagerFactory object.

getAlgorithm() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the standard algorithm name for this key.

getAlgorithm() - Method in interface javax.xml.crypto.AlgorithmMethod

Returns the algorithm URI of this AlgorithmMethod.

getAlgorithm() - Method in class javax.xml.crypto.dsig.TransformService

Returns the URI of the algorithm supported by this TransformService.

getAlgorithmConstraints() - Method in class javax.net.ssl.SSLParameters

Returns the cryptographic algorithm constraints.

getAlgorithmProperty(String, String) - Static method in class java.security.Security

Deprecated.
This method used to return the value of a proprietary property in the master file of the "SUN" Cryptographic Service Provider in order to determine how to parse algorithm-specific parameters. Use the new provider-based and algorithm-independent AlgorithmParameters and KeyFactory engine classes (introduced in the J2SE version 1.2 platform) instead.

getAlgorithms(String) - Static method in class java.security.Security

Returns a Set of Strings containing the names of all available algorithms or types for the specified Java cryptographic service (e.g., Signature, MessageDigest, Cipher, Mac, KeyStore).

getAlgParameters() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the algorithm parameters used by the encryption algorithm.

getAlias() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the KeyStore alias.

getAlignedSizeRequirements(SizeRequirements[]) - Static method in class javax.swing.SizeRequirements

Determines the total space necessary to align a set of components.

getAlignment() - Method in class java.awt.FlowLayout

Gets the alignment for this layout.

getAlignment() - Method in class java.awt.font.GraphicAttribute

Returns the alignment of this GraphicAttribute.

getAlignment() - Method in class java.awt.Label

Gets the current alignment of this label.

getAlignment(int) - Method in class javax.swing.text.BoxView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.ComponentView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.GlyphView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.html.BlockView

Gets the alignment.

getAlignment(int) - Method in class javax.swing.text.html.ImageView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.html.ListView

Calculates the desired shape of the list.

getAlignment(int) - Method in class javax.swing.text.IconView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.ParagraphView

Determines the desired alignment for this view along an axis.

getAlignment(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the alignment setting.

getAlignment() - Method in class javax.swing.text.TabStop

Returns the alignment, as an integer, of the tab.

getAlignment(int) - Method in class javax.swing.text.View

Determines the desired alignment for this view along an axis.

getAlignmentX() - Method in class java.awt.Component

Returns the alignment along the x axis.

getAlignmentX() - Method in class java.awt.Container

Returns the alignment along the x axis.

getAlignmentX() - Method in class javax.swing.JComponent

Overrides Container.getAlignmentX to return the vertical alignment.

getAlignmentY() - Method in class java.awt.Component

Returns the alignment along the y axis.

getAlignmentY() - Method in class java.awt.Container

Returns the alignment along the y axis.

getAlignmentY() - Method in class javax.swing.JComponent

Overrides Container.getAlignmentY to return the horizontal alignment.

getAlignOnBaseline() - Method in class java.awt.FlowLayout

Returns true if components are to be vertically aligned along their baseline.

getAll(String[]) - Method in interface javax.management.openmbean.CompositeData

Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

getAll(String[]) - Method in class javax.management.openmbean.CompositeDataSupport

Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

getAll() - Method in class javax.naming.CompositeName

Retrieves the components of this composite name as an enumeration of strings.

getAll() - Method in class javax.naming.CompoundName

Retrieves the components of this compound name as an enumeration of strings.

getAll() - Method in interface javax.naming.directory.Attribute

Retrieves an enumeration of the attribute's values.

getAll() - Method in interface javax.naming.directory.Attributes

Retrieves an enumeration of the attributes in the attribute set.

getAll() - Method in class javax.naming.directory.BasicAttribute

Retrieves an enumeration of this attribute's values.

getAll() - Method in class javax.naming.directory.BasicAttributes

getAll() - Method in class javax.naming.ldap.LdapName

Retrieves the components of this name as an enumeration of strings.

getAll() - Method in interface javax.naming.Name

Retrieves the components of this name as an enumeration of strings.

getAll() - Method in class javax.naming.Reference

Retrieves an enumeration of the addresses in this reference.

getAllAnnotationMirrors(Element) - Method in interface javax.lang.model.util.Elements

Returns all annotations of an element, whether inherited or directly present.

getAllAttributeKeys() - Method in interface java.text.AttributedCharacterIterator

Returns the keys of all attributes defined on the iterator's text range.

getAllAttributeKeys() - Static method in class javax.swing.text.html.CSS

Return the set of all possible CSS attribute keys.

getAllAttributeKeys() - Static method in class javax.swing.text.html.HTML

Returns the set of HTML attributes recognized.

getAllAttributes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attribute Name objects in this SOAPElement object.

getAllAttributesAsQNames() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attributes in this SOAPElement as QName objects.

getAllByName(String) - Static method in class java.net.InetAddress

Given the name of a host, returns an array of its IP addresses, based on the configured name service on the system.

getAllCommands(String) - Method in class javax.activation.CommandMap

Get all the available commands for this type.

getAllCommands(String, DataSource) - Method in class javax.activation.CommandMap

Get all the available commands for this type.

getAllCommands() - Method in class javax.activation.DataHandler

Return all the commands for this type of data.

getAllCommands(String) - Method in class javax.activation.MailcapCommandMap

Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.

getAllFonts() - Method in class java.awt.GraphicsEnvironment

Returns an array containing a one-point size instance of all fonts available in this GraphicsEnvironment.

getAllFrames() - Method in class javax.swing.JDesktopPane

Returns all JInternalFrames currently displayed in the desktop.

getAllFramesInLayer(int) - Method in class javax.swing.JDesktopPane

Returns all JInternalFrames currently displayed in the specified layer of the desktop.

getAllHeaders() - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeaders in this MimeHeaders object.

getAllLoadedClasses() - Method in interface java.lang.instrument.Instrumentation

Returns an array of all classes currently loaded by the JVM.

getAllMembers(TypeElement) - Method in interface javax.lang.model.util.Elements

Returns all members of a type element, whether inherited or declared directly.

getAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart

Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.

getAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart

Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.

getAllNotificationIDs() - Method in class javax.management.timer.Timer

Gets all timer notification identifiers registered into the list of notifications.

getAllNotificationIDs() - Method in interface javax.management.timer.TimerMBean

Gets all timer notification identifiers registered into the list of notifications.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.BranchElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.LeafElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns true if this node is allowed to have children.

getAllowsChildren() - Method in interface javax.swing.tree.TreeNode

Returns true if the receiver allows children.

getAllowsInvalid() - Method in class javax.swing.text.DefaultFormatter

Returns whether or not the value being edited is allowed to be invalid for a length of time.

getAllowUserInteraction() - Method in class java.net.URLConnection

Returns the value of the allowUserInteraction field for this object.

getAllRelationIds() - Method in class javax.management.relation.RelationService

Returns all the relation ids for all the relations handled by the Relation Service.

getAllRelationIds() - Method in interface javax.management.relation.RelationServiceMBean

Returns all the relation ids for all the relations handled by the Relation Service.

getAllRelationTypeNames() - Method in class javax.management.relation.RelationService

Retrieves names of all known relation types.

getAllRelationTypeNames() - Method in interface javax.management.relation.RelationServiceMBean

Retrieves names of all known relation types.

getAllRoles() - Method in interface javax.management.relation.Relation

Returns all roles present in the relation.

getAllRoles(String) - Method in class javax.management.relation.RelationService

Returns all roles present in the relation.

getAllRoles(String) - Method in interface javax.management.relation.RelationServiceMBean

Returns all roles present in the relation.

getAllRoles() - Method in class javax.management.relation.RelationSupport

Returns all roles present in the relation.

getAllStackTraces() - Static method in class java.lang.Thread

Returns a map of stack traces for all live threads.

getAllTags() - Static method in class javax.swing.text.html.HTML

Returns the set of actual HTML tags that are recognized by the default HTML reader.

getAllThreadIds() - Method in interface java.lang.management.ThreadMXBean

Returns all live thread IDs.

getAlpha() - Method in class java.awt.AlphaComposite

Returns the alpha value of this AlphaComposite.

getAlpha() - Method in class java.awt.Color

Returns the alpha component in the range 0-255.

getAlpha(int) - Method in class java.awt.image.ColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.ColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.ComponentColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.ComponentColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.DirectColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.DirectColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.IndexColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlphaMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the alpha component.

getAlphaRaster() - Method in class java.awt.image.BufferedImage

Returns a WritableRaster representing the alpha channel for BufferedImage objects with ColorModel objects that support a separate spatial alpha channel, such as ComponentColorModel and DirectColorModel.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.ColorModel

Returns a Raster representing the alpha channel of an image, extracted from the input Raster, provided that pixel values of this ColorModel represent color and alpha information as separate spatial bands (e.g.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.ComponentColorModel

Returns a Raster representing the alpha channel of an image, extracted from the input Raster.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.PackedColorModel

Returns a WritableRaster representing the alpha channel of an image, extracted from the input WritableRaster.

getAlphas(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of alpha transparency components into the specified array.

getAlternatives() - Method in interface javax.lang.model.type.DisjunctiveType

Return the alternatives comprising this disjunctive type.

getAltKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'alt' key was depressed during the firing of the event.

getAltName() - Method in exception javax.naming.CannotProceedException

Retrieves the altName field of this exception.

getAltNameCtx() - Method in exception javax.naming.CannotProceedException

Retrieves the altNameCtx field of this exception.

getAltText() - Method in class javax.swing.text.html.ImageView

Returns the text to display if the image can't be loaded.

getAmountFull(Insets, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

This determines the amount of the progress bar that should be filled based on the percent done gathered from the model.

getAmPmStrings() - Method in class java.text.DateFormatSymbols

Gets ampm strings.

getAncestor() - Method in class javax.swing.event.AncestorEvent

Returns the ancestor that the event actually occurred on.

getAncestorListeners() - Method in class javax.swing.JComponent

Returns an array of all the ancestor listeners registered on this component.

getAncestorNamed(String, Component) - Static method in class javax.swing.SwingUtilities

Convenience method for searching above comp in the component hierarchy and returns the first object of name it finds.

getAncestorOfClass(Class<?>, Component) - Static method in class javax.swing.SwingUtilities

Convenience method for searching above comp in the component hierarchy and returns the first object of class c it finds.

getAncestorParent() - Method in class javax.swing.event.AncestorEvent

Returns the parent of the ancestor the event actually occurred on.

getAnchorRect() - Method in class java.awt.TexturePaint

Returns a copy of the anchor rectangle which positions and sizes the textured image.

getAnchorSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getAnchorSelectionIndex() - Method in class javax.swing.JList

Returns the anchor selection index.

getAnchorSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getAnchorSelectionPath() - Method in class javax.swing.JTree

Returns the path identified as the anchor.

getAndAdd(int) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically adds the given value to the current value.

getAndAdd(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically adds the given value to the element at index i.

getAndAdd(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically adds the given value to the current value of the field of the given object managed by this updater.

getAndAdd(long) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically adds the given value to the current value.

getAndAdd(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically adds the given value to the element at index i.

getAndAdd(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically adds the given value to the current value of the field of the given object managed by this updater.

getAndDecrement() - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically decrements by one the current value.

getAndDecrement(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically decrements by one the element at index i.

getAndDecrement(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically decrements by one the current value of the field of the given object managed by this updater.

getAndDecrement() - Method in class java.util.concurrent.atomic.AtomicLong

Atomically decrements by one the current value.

getAndDecrement(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically decrements by one the element at index i.

getAndDecrement(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically decrements by one the current value of the field of the given object managed by this updater.

getAndIncrement() - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically increments by one the current value.

getAndIncrement(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically increments by one the element at index i.

getAndIncrement(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically increments by one the current value of the field of the given object managed by this updater.

getAndIncrement() - Method in class java.util.concurrent.atomic.AtomicLong

Atomically increments by one the current value.

getAndIncrement(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically increments by one the element at index i.

getAndIncrement(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically increments by one the current value of the field of the given object managed by this updater.

getAndSet(boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean

Atomically sets to the given value and returns the previous value.

getAndSet(int) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically sets to the given value and returns the old value.

getAndSet(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAndSet(long) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically sets to the given value and returns the old value.

getAndSet(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAndSet(V) - Method in class java.util.concurrent.atomic.AtomicReference

Atomically sets to the given value and returns the old value.

getAndSet(int, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAngleExtent() - Method in class java.awt.geom.Arc2D.Double

Returns the angular extent of the arc.

getAngleExtent() - Method in class java.awt.geom.Arc2D.Float

Returns the angular extent of the arc.

getAngleExtent() - Method in class java.awt.geom.Arc2D

Returns the angular extent of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D.Double

Returns the starting angle of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D.Float

Returns the starting angle of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D

Returns the starting angle of the arc.

getAnimationIndex() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Gets the index of the current animation frame.

getAnnotation(Class<A>) - Method in class java.lang.类

getAnnotation(Class<A>) - Method in class java.lang.软件包

getAnnotation(Class<T>) - Method in class java.lang.reflect.AccessibleObject

getAnnotation(Class<T>) - Method in interface java.lang.reflect.AnnotatedElement

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<T>) - Method in class java.lang.reflect.Constructor

getAnnotation(Class<T>) - Method in class java.lang.reflect.字段

getAnnotation(Class<T>) - Method in class java.lang.reflect.方法

getAnnotation(Class<A>) - Method in interface javax.lang.model.element.Element

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotationMirrors() - Method in interface javax.lang.model.element.Element

Returns the annotations that are directly present on this element.

getAnnotations() - Method in class java.lang.类

getAnnotations() - Method in class java.lang.软件包

getAnnotations() - Method in class java.lang.reflect.AccessibleObject

getAnnotations() - Method in interface java.lang.reflect.AnnotatedElement

Returns all annotations present on this element.

getAnnotationType() - Method in interface javax.lang.model.element.AnnotationMirror

Returns the type of this annotation.

getAnonymityState() - Method in interface org.ietf.jgss.GSSContext

Determines if the context initiator is anonymously authenticated to the context acceptor.

getAnonymousLogger() - Static method in class java.util.logging.Logger

Create an anonymous Logger.

getAnonymousLogger(String) - Static method in class java.util.logging.Logger

Create an anonymous Logger.

getAntiAliasingHint() - Method in class java.awt.font.FontRenderContext

Return the text anti-aliasing rendering mode hint used in this FontRenderContext.

getAppConfigurationEntry(String) - Method in class javax.security.auth.login.Configuration

Retrieve the AppConfigurationEntries for the specified name from this Configuration.

getApplet(String) - Method in interface java.applet.AppletContext

Finds and returns the applet in the document represented by this applet context with the given name.

getAppletContext() - Method in class java.applet.Applet

Determines this applet's context, which allows the applet to query and affect the environment in which it runs.

getAppletContext() - Method in interface java.applet.AppletStub

Returns the applet's context.

getAppletInfo() - Method in class java.applet.Applet

Returns information about this applet.

getApplets() - Method in interface java.applet.AppletContext

Finds all the applets in the document represented by this applet context.

getApplicationBufferSize() - Method in interface javax.net.ssl.SSLSession

Gets the current size of the largest application data that is expected when using this session.

getApplicationData() - Method in class org.ietf.jgss.ChannelBinding

Get the application specified data for this channel binding.

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getApproveButtonMnemonic() - Method in class javax.swing.JFileChooser

Returns the approve button's mnemonic.

getApproveButtonMnemonic(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButtonText() - Method in class javax.swing.JFileChooser

Returns the text used in the ApproveButton in the FileChooserUI.

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getApproveButtonText method on each UI handled by this object.

getApproveButtonToolTipText() - Method in class javax.swing.JFileChooser

Returns the tooltip text used in the ApproveButton.

getApproveButtonToolTipText(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveSelectionAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getArch() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system architecture.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D.Double

Gets the height of the arc that rounds off the corners.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D.Float

Gets the height of the arc that rounds off the corners.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D

Gets the height of the arc that rounds off the corners.

getArcType() - Method in class java.awt.geom.Arc2D

Returns the arc closure type of the arc: Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D.Double

Gets the width of the arc that rounds off the corners.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D.Float

Gets the width of the arc that rounds off the corners.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D

Gets the width of the arc that rounds off the corners.

getAreaOfInterest() - Method in class java.awt.image.renderable.RenderContext

Gets the ares of interest currently contained in the RenderContext.

getArgument() - Method in exception javax.lang.model.element.UnknownAnnotationValueException

Returns the additional argument.

getArgument() - Method in exception javax.lang.model.element.UnknownElementException

Returns the additional argument.

getArgument() - Method in exception javax.lang.model.type.UnknownTypeException

Returns the additional argument.

getArgumentClass() - Method in exception java.util.IllegalFormatConversionException

Returns the class of the mismatched argument.

getArguments() - Method in class java.beans.Statement

Returns the arguments for the method to invoke.

getArray() - Method in interface java.sql.Array

Retrieves the contents of the SQL ARRAY value designated by this Array object in the form of an array in the Java programming language.

getArray(Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves the contents of the SQL ARRAY value designated by this Array object.

getArray(long, int) - Method in interface java.sql.Array

Retrieves a slice of the SQL ARRAY value designated by this Array object, beginning with the specified index and containing up to count successive elements of the SQL array.

getArray(long, int, Map<String, Class<?>>) - Method in interface java.sql.Array

Retreives a slice of the SQL ARRAY value designated by this Array object, beginning with the specified index and containing up to count successive elements of the SQL array.

getArray(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ARRAY parameter as an Array object in the Java programming language.

getArray(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC ARRAY parameter as an Array object in the Java programming language.

getArray(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Array object in the Java programming language.

getArray(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Array object in the Java programming language.

getArray() - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of this SerialArray object.

getArray(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of this SerialArray object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

getArray(long, int) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.

getArray(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.

getArray() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the array of characters.

getArrayLength() - Method in class javax.swing.text.GapContent

Get the length of the allocated array.

getArrayType(TypeMirror) - Method in interface javax.lang.model.util.Types

Returns an array type with the specified component type.

getArrayType(OpenType<E>) - Static method in class javax.management.openmbean.ArrayType

Create an ArrayType instance in a type-safe manner.

getArrivedParties() - Method in class java.util.concurrent.Phaser

Returns the number of registered parties that have arrived at the current phase of this phaser.

getAscent() - Method in class java.awt.font.GraphicAttribute

Returns the ascent of this GraphicAttribute.

getAscent() - Method in class java.awt.font.ImageGraphicAttribute

Returns the ascent of this ImageGraphicAttribute.

getAscent() - Method in class java.awt.font.LineMetrics

Returns the ascent of the text.

getAscent() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the ascent of this ShapeGraphicAttribute.

getAscent() - Method in class java.awt.font.TextLayout

Returns the ascent of this TextLayout.

getAscent() - Method in class java.awt.FontMetrics

Determines the font ascent of the Font described by this FontMetrics object.

getAscent(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getAsciiStream() - Method in interface java.sql.Clob

Retrieves the CLOB value designated by this Clob object as an ascii stream.

getAsciiStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of ASCII characters.

getAsciiStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of ASCII characters.

getAsciiStream() - Method in class javax.sql.rowset.serial.SerialClob

Retrieves the CLOB value designated by this SerialClob object as an ascii stream.

getAspectRatio(int) - Method in class javax.imageio.ImageReader

Returns the aspect ratio of the given image (that is, its width divided by its height) as a float.

getAssociatedStylesheet(Source, String, String, String) - Method in class javax.xml.transform.TransformerFactory

Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.

getAsText() - Method in interface java.beans.PropertyEditor

Gets the property value as text.

getAsText() - Method in class java.beans.PropertyEditorSupport

Gets the property value as a string suitable for presentation to a human to edit.

getAsTree(String) - Method in class javax.imageio.metadata.IIOMetadata

Returns an XML DOM Node object that represents the root of a tree of metadata contained within this object according to the conventions defined by a given metadata format.

getAsync() - Method in interface org.w3c.dom.ls.LSParser

true if the LSParser is asynchronous, false if it is synchronous.

getAsynchronousLoadPriority() - Method in class javax.swing.text.AbstractDocument

Gets the asynchronous loading priority.

getAsyncMode() - Method in class java.util.concurrent.ForkJoinPool

Returns true if this pool uses local first-in-first-out scheduling mode for forked tasks that are never joined.

getAtIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String at a given index.

getAtIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String at a given index.

getAttachment(SOAPElement) - Method in class javax.xml.soap.SOAPMessage

Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.

getAttachmentAsByteArray(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Retrieve the attachment identified by content-id, cid, as a byte[]

getAttachmentAsDataHandler(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Lookup MIME content by content-id, cid, and return as a DataHandler.

getAttachmentMarshaller() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAttachmentMarshaller() - Method in interface javax.xml.bind.Marshaller

getAttachments() - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.

getAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that have header entries that match the specified headers.

getAttachmentUnmarshaller() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAttachmentUnmarshaller() - Method in interface javax.xml.bind.Unmarshaller

getAttrChange() - Method in interface org.w3c.dom.events.MutationEvent

attrChange indicates the type of change which triggered the DOMAttrModified event.

getAttribute(Path, String, LinkOption...) - Static method in class java.nio.file.Files

Reads the value of a file attribute.

getAttribute(String) - Method in class java.nio.file.FileStore

Reads the value of a file store attribute.

getAttribute(String) - Method in class java.security.Provider.Service

Return the value of the specified attribute or null if this attribute is not set for this Service.

getAttribute(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the value of the named attribute for the current character.

getAttribute(String) - Method in class javax.imageio.metadata.IIOMetadataNode

Retrieves an attribute value by name.

getAttribute(ObjectName) - Method in class javax.management.AttributeValueExp

Return the value of the given attribute in the named MBean.

getAttribute(String) - Method in interface javax.management.DynamicMBean

Obtain the value of a specific attribute of the Dynamic MBean.

getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServer

getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServerConnection

Gets the value of a specific attribute of a named MBean.

getAttribute(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanAttributeInfo requested by name.

getAttribute(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getAttribute(String) - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the value of a specific attribute defined for this ModelMBean.

getAttribute(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getAttribute(ObjectName, String).

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getAttribute(String) - Method in class javax.management.StandardMBean

getAttribute() - Method in class javax.naming.directory.ModificationItem

Retrieves the attribute associated with this modification item.

getAttribute(Class<T>) - Method in interface javax.print.PrintService

Gets the value of the single specified service attribute.

getAttribute(String, int) - Method in interface javax.script.ScriptContext

Gets the value of an attribute in a given scope.

getAttribute(String) - Method in interface javax.script.ScriptContext

Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.

getAttribute(String) - Method in class javax.script.SimpleScriptContext

Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.

getAttribute(String, int) - Method in class javax.script.SimpleScriptContext

Gets the value of an attribute in a given scope.

getAttribute(Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the value of an attribute.

getAttribute(Object) - Method in interface javax.swing.text.AttributeSet

Fetches the value of the given attribute.

getAttribute(String) - Static method in class javax.swing.text.html.CSS

Translates a string to a CSS.Attribute object.

getAttribute(String) - Method in class javax.swing.text.html.parser.Element

Get an attribute by name.

getAttribute(Object) - Method in class javax.swing.text.SimpleAttributeSet

Gets the value of an attribute.

getAttribute(Object) - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the value of an attribute.

getAttribute(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the value of an attribute.

getAttribute(String) - Method in class javax.xml.parsers.DocumentBuilderFactory

Allows the user to retrieve specific attributes on the underlying implementation.

getAttribute(String) - Method in class javax.xml.transform.TransformerFactory

Allows the user to retrieve specific attributes on the underlying implementation.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpContext

Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an attribute that is associated with this HttpExchange.

getAttribute(String) - Method in interface org.w3c.dom.Element

Retrieves an attribute value by name.

getAttributeByName(QName) - Method in interface javax.xml.stream.events.StartElement

Returns the attribute referred to by this name

getAttributeByValue(String) - Method in class javax.swing.text.html.parser.Element

Get an attribute by value.

getAttributeContext() - Method in class javax.swing.text.AbstractDocument

Fetches the context for managing attributes.

getAttributeCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the number of attributes that are defined.

getAttributeCount() - Method in interface javax.swing.text.AttributeSet

Returns the number of attributes that are defined locally in this set.

getAttributeCount() - Method in class javax.swing.text.SimpleAttributeSet

Gets a count of the number of attributes.

getAttributeCount() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the number of attributes that are defined.

getAttributeCount() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the number of attributes that are defined.

getAttributeCount() - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeCount() - Method in interface javax.xml.stream.XMLStreamReader

Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.

getAttributeDataType(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with DATATYPE_, indicating the format and interpretation of the value of the given attribute within th enamed element.

getAttributeDataType(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeDefaultValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the default value of the named attribute, if it is not explictly present within the named element, as a String, or null if no default value is available.

getAttributeDefaultValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeDefinition() - Method in interface javax.naming.directory.Attribute

Retrieves the attribute's schema definition.

getAttributeDefinition() - Method in class javax.naming.directory.BasicAttribute

Retrieves this attribute's schema definition.

getAttributeDescription(String, String, Locale) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns a String containing a description of the named attribute, or null.

getAttributeDescription(String, String, Locale) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns a String containing a description of the named attribute, or null.

getAttributeEnumerations(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings containing the legal enumerated values for the given attribute within the named element.

getAttributeEnumerations(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeID() - Method in class javax.naming.ldap.SortKey

Retrieves the attribute ID of the sort key.

getAttributeID() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the ID of the attribute that caused the sort to fail.

getAttributeKey(String) - Static method in class javax.swing.text.html.HTML

Fetches an attribute constant for a well-known attribute name (i.e.

getAttributeListMaxLength(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of list items that may be used to define this attribute.

getAttributeListMaxLength(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeListMinLength(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of list items that may be used to define this attribute.

getAttributeListMinLength(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeLocalName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeLocalName(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the localName of the attribute at the provided index

getAttributeMaxValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum legal value for the attribute.

getAttributeMaxValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeMinValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum legal value for the attribute.

getAttributeMinValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeName() - Method in class javax.management.AttributeChangeNotification

Gets the name of the attribute which has changed.

getAttributeName() - Method in class javax.management.AttributeValueExp

Returns a string representation of the name of the attribute.

getAttributeName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeName(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the qname of the attribute at the provided index

getAttributeNames(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings listing the names of the attributes that may be associated with the named element.

getAttributeNames(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeNames() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the names of all attributes.

getAttributeNames() - Method in interface javax.swing.text.AttributeSet

Returns an enumeration over the names of the attributes that are defined locally in the set.

getAttributeNames() - Method in class javax.swing.text.SimpleAttributeSet

Gets the names of the attributes in the set.

getAttributeNames() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the names of all attributes.

getAttributeNames() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the names of all attributes.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpContext

Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpExchange

Gives all the attribute names that are associated with this HttpExchange.

getAttributeNamespace(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeNamespace(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the namespace of the attribute at the provided index

getAttributeNode(String) - Method in class javax.imageio.metadata.IIOMetadataNode

getAttributeNode(String) - Method in interface org.w3c.dom.Element

Retrieves an attribute node by name.

getAttributeNodeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getAttributeNode(localName).

getAttributeNodeNS(String, String) - Method in interface org.w3c.dom.Element

Retrieves an Attr node by local name and namespace URI.

getAttributeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getAttribute(localName).

getAttributeNS(String, String) - Method in interface org.w3c.dom.Element

Retrieves an attribute value by local name and namespace URI.

getAttributePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix of this attribute at the provided index

getAttributes() - Method in class java.awt.Font

Returns a map of font attributes available in this Font.

getAttributes() - Method in class java.net.JarURLConnection

Return the Attributes object for this connection if the URL for it points to a JAR file entry, null otherwise.

getAttributes(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given attribute of the given type for a user-defined type (UDT) that is available in the given schema and catalog.

getAttributes() - Method in interface java.sql.Struct

Produces the ordered values of the attributes of the SQL structured type that this Struct object represents.

getAttributes(Map<String, Class<?>>) - Method in interface java.sql.Struct

Produces the ordered values of the attributes of the SQL structured type that this Struct object represents.

getAttributes() - Method in interface java.text.AttributedCharacterIterator

Returns a map with the attributes defined on the current character.

getAttributes() - Method in class java.util.jar.JarEntry

Returns the Manifest Attributes for this entry, or null if none.

getAttributes(String) - Method in class java.util.jar.Manifest

Returns the Attributes for the specified entry name.

getAttributes() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns a NamedNodeMap containing the attributes of this node.

getAttributes(String[]) - Method in interface javax.management.DynamicMBean

Get the values of several attributes of the Dynamic MBean.

getAttributes() - Method in class javax.management.loading.MLetContent

Gets the attributes of the MLET tag.

getAttributes() - Method in class javax.management.MBeanInfo

Returns the list of attributes exposed for management.

getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServer

getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServerConnection

Retrieves the values of several attributes of a named MBean.

getAttributes() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of attributes exposed for management.

getAttributes(String[]) - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the values of several attributes in the ModelMBean.

getAttributes() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance.

getAttributes() - Method in interface javax.management.remote.JMXConnectorServerMBean

The attributes for this connector server.

getAttributes(ObjectName, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getAttributes() - Method in class javax.management.remote.rmi.RMIConnectorServer

getAttributes(String[]) - Method in class javax.management.StandardMBean

getAttributes(Name) - Method in interface javax.naming.directory.DirContext

Retrieves all of the attributes associated with a named object.

getAttributes(String) - Method in interface javax.naming.directory.DirContext

Retrieves all of the attributes associated with a named object.

getAttributes(Name, String[]) - Method in interface javax.naming.directory.DirContext

Retrieves selected attributes associated with a named object.

getAttributes(String, String[]) - Method in interface javax.naming.directory.DirContext

Retrieves selected attributes associated with a named object.

getAttributes(String) - Method in class javax.naming.directory.InitialDirContext

getAttributes(String, String[]) - Method in class javax.naming.directory.InitialDirContext

getAttributes(Name) - Method in class javax.naming.directory.InitialDirContext

getAttributes(Name, String[]) - Method in class javax.naming.directory.InitialDirContext

getAttributes() - Method in class javax.naming.directory.SearchResult

Retrieves the attributes in this search result.

getAttributes() - Method in class javax.naming.spi.DirStateFactory.Result

Retrieves the attributes to be bound.

getAttributes() - Method in interface javax.print.Doc

Obtains the set of printing attributes for this doc object.

getAttributes() - Method in interface javax.print.DocPrintJob

Obtains this Print Job's set of printing attributes.

getAttributes() - Method in class javax.print.event.PrintJobAttributeEvent

Determine the printing attributes that changed and their new values.

getAttributes() - Method in class javax.print.event.PrintServiceAttributeEvent

Determine the printing service attributes that changed and their new values.

getAttributes() - Method in interface javax.print.PrintService

Obtains this print service's set of printer description attributes giving this Print Service's status.

getAttributes() - Method in class javax.print.SimpleDoc

Obtains the set of printing attributes for this doc object.

getAttributes() - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves an array of Object values containing the attributes of the SQL structured type that this SerialStruct object represents.

getAttributes(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves the attributes for the SQL structured type that this SerialStruct represents as an array of Object values, using the given type map for custom mapping if appropriate.

getAttributes() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the attributes for the element.

getAttributes() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the element attributes.

getAttributes() - Method in interface javax.swing.text.Element

Fetches the collection of attributes this element contains.

getAttributes() - Method in class javax.swing.text.html.BlockView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Return the attributes for this tag.

getAttributes() - Method in class javax.swing.text.html.ImageView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.InlineView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.Option

Fetch the attributes associated with this option.

getAttributes() - Method in class javax.swing.text.html.ParagraphView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.parser.Element

Get the attributes.

getAttributes() - Method in class javax.swing.text.html.parser.Parser

getAttributes() - Method in class javax.swing.text.View

Fetches the attributes to use when rendering.

getAttributes() - Method in interface javax.xml.stream.events.StartElement

Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.

getAttributes() - Method in interface org.w3c.dom.Node

A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

getAttributesScope(String) - Method in interface javax.script.ScriptContext

Get the lowest scope in which an attribute is defined.

getAttributesScope(String) - Method in class javax.script.SimpleScriptContext

Get the lowest scope in which an attribute is defined.

getAttributeSyntaxDefinition() - Method in interface javax.naming.directory.Attribute

Retrieves the syntax definition associated with the attribute.

getAttributeSyntaxDefinition() - Method in class javax.naming.directory.BasicAttribute

Retrieves the syntax definition associated with this attribute.

getAttributeType() - Method in class javax.management.AttributeChangeNotification

Gets the type of the attribute which has changed.

getAttributeType(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeType(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the XML type of the attribute at the provided index

getAttributeTypeInfo(int) - Method in class javax.xml.validation.TypeInfoProvider

Returns the immutable TypeInfo object for the specified attribute of the current element.

getAttributeValue(Name) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified name.

getAttributeValue(QName) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified qname.

getAttributeValue(String, String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeValue(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeValue(String, String) - Method in interface javax.xml.stream.XMLStreamReader

Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality

getAttributeValue(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the value of the attribute at the index

getAttributeValueType(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with VALUE_, indicating whether the values of the given attribute within the named element are arbitrary, constrained to lie within a specified range, constrained to be one of a set of enumerated values, or are a whitespace-separated list of arbitrary values.

getAttributeValueType(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttrName() - Method in interface org.w3c.dom.events.MutationEvent

attrName indicates the name of the changed Attr node in a DOMAttrModified event.

getAudioActionMap() - Method in class javax.swing.plaf.basic.BasicLookAndFeel

Returns an ActionMap containing the audio actions for this look and feel.

getAudioClip(URL) - Method in class java.applet.Applet

Returns the AudioClip object specified by the URL argument.

getAudioClip(URL, String) - Method in class java.applet.Applet

Returns the AudioClip object specified by the URL and name arguments.

getAudioClip(URL) - Method in interface java.applet.AppletContext

Creates an audio clip.

getAudioFileFormat(InputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the provided input stream.

getAudioFileFormat(URL) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the specified URL.

getAudioFileFormat(File) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the specified File.

getAudioFileFormat(InputStream) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the input stream provided.

getAudioFileFormat(URL) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the URL provided.

getAudioFileFormat(File) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the File provided.

getAudioFileTypes() - Static method in class javax.sound.sampled.AudioSystem

Obtains the file types for which file writing support is provided by the system.

getAudioFileTypes(AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains the file types that the system can write from the audio input stream specified.

getAudioFileTypes() - Method in class javax.sound.sampled.spi.AudioFileWriter

Obtains the file types for which file writing support is provided by this audio file writer.

getAudioFileTypes(AudioInputStream) - Method in class javax.sound.sampled.spi.AudioFileWriter

Obtains the file types that this audio file writer can write from the audio input stream specified.

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.

getAudioInputStream(AudioFormat, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream of the indicated format, by converting the provided audio input stream.

getAudioInputStream(InputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the provided input stream.

getAudioInputStream(URL) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the URL provided.

getAudioInputStream(File) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the provided File.

getAudioInputStream(InputStream) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the input stream provided.

getAudioInputStream(URL) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the URL provided.

getAudioInputStream(File) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the File provided.

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains an audio input stream with the specified encoding from the given audio input stream.

getAudioInputStream(AudioFormat, AudioInputStream) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains an audio input stream with the specified format from the given audio input stream.

getAuthenticationID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the authentication id to check.

getAuthority() - Method in class java.net.URI

Returns the decoded authority component of this URI.

getAuthority() - Method in class java.net.URL

Gets the authority part of this URL.

getAuthorityKeyIdentifier() - Method in class java.security.cert.X509CertSelector

Returns the authorityKeyIdentifier criterion.

getAuthorityName() - Method in exception java.security.cert.CertificateRevokedException

Returns the name of the authority that signed the certificate's revocation status information.

getAuthorizationID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the authorization id to check.

getAuthorizationID() - Method in interface javax.security.sasl.SaslServer

Reports the authorization ID in effect for the client of this session.

getAuthorizedID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the id of the authorized user.

getAuthTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the time that the client was authenticated.

getAutoCommit() - Method in interface java.sql.Connection

Retrieves the current auto-commit mode for this Connection object.

getAutoCommit() - Method in interface javax.sql.rowset.JdbcRowSet

Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.

getAutoCreateColumnsFromModel() - Method in class javax.swing.JTable

Determines whether the table will create default columns from the model.

getAutoCreateContainerGaps() - Method in class javax.swing.GroupLayout

Returns true if gaps between the container and components that border the container are automatically created.

getAutoCreateGaps() - Method in class javax.swing.GroupLayout

Returns true if gaps between components are automatically created.

getAutoCreateRowSorter() - Method in class javax.swing.JTable

Returns true if whenever the model changes, a new RowSorter should be created and installed as the table's sorter; otherwise, returns false.

getAutoDelay() - Method in class java.awt.Robot

Returns the number of milliseconds this Robot sleeps after generating an event.

getAutoResizeMode() - Method in class javax.swing.JTable

Returns the auto resize mode of the table.

getAutoscrollInsets() - Method in interface java.awt.dnd.Autoscroll

This method returns the Insets describing the autoscrolling region or border relative to the geometry of the implementing Component.

getAutoscrolls() - Method in class javax.swing.JComponent

Gets the autoscrolls property.

getAuxiliaryLookAndFeels() - Static method in class javax.swing.UIManager

Returns the list of auxiliary look and feels (can be null).

getAvailableAcceleratedMemory() - Method in class java.awt.GraphicsDevice

This method returns the number of bytes available in accelerated memory on this device.

getAvailableAttributes() - Method in class java.awt.Font

Returns the keys of all the attributes supported by this Font.

getAvailableCurrencies() - Static method in class java.util.Currency

Gets the set of available currencies.

getAvailableDataFlavors() - Method in class java.awt.datatransfer.Clipboard

Returns an array of DataFlavors in which the current contents of this clipboard can be provided.

getAvailableFontFamilyNames() - Method in class java.awt.GraphicsEnvironment

Returns an array containing the names of all font families in this GraphicsEnvironment localized for the default locale, as returned by Locale.getDefault().

getAvailableFontFamilyNames(Locale) - Method in class java.awt.GraphicsEnvironment

Returns an array containing the names of all font families in this GraphicsEnvironment localized for the specified locale.

getAvailableIDs(int) - Static method in class java.util.TimeZone

Gets the available IDs according to the given time zone offset in milliseconds.

getAvailableIDs() - Static method in class java.util.TimeZone

Gets all the available IDs supported.

getAvailableInstruments() - Method in interface javax.sound.midi.Synthesizer

Obtains a list of instruments that come with the synthesizer.

getAvailableLocales() - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns the locales supported by the corresponding input method.

getAvailableLocales() - Static method in class java.text.BreakIterator

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.Collator

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DateFormat

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DateFormatSymbols

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DecimalFormatSymbols

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.NumberFormat

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.util.Calendar

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.util.Locale

Returns an array of all installed locales.

getAvailableLocales() - Method in class java.util.spi.LocaleServiceProvider

Returns an array of all locales for which this locale service provider can provide localized objects or names.

getAvailableLocales() - Method in class javax.imageio.ImageReader

Returns an array of Locales that may be used to localize warning listeners and compression settings.

getAvailableLocales() - Method in class javax.imageio.ImageWriter

Returns an array of Locales that may be used to localize warning listeners and compression settings.

getAvailableProcessors() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the number of processors available to the Java virtual machine.

getAvailableSize(Dimension, Insets) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the available width based on the container size and Insets.

getAWTEventListeners() - Method in class java.awt.Toolkit

Returns an array of all the AWTEventListeners registered on this toolkit.

getAWTEventListeners(long) - Method in class java.awt.Toolkit

Returns an array of all the AWTEventListeners registered on this toolkit which listen to all of the event types specified in the eventMask argument.

getAWTKeyStroke(char) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke that represents a KEY_TYPED event for the specified character.

getAWTKeyStroke(Character, int) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.

getAWTKeyStroke(int, int, boolean) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.

getAWTKeyStroke(int, int) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke, given a numeric key code and a set of modifiers.

getAWTKeyStroke(String) - Static method in class java.awt.AWTKeyStroke

Parses a string and returns an AWTKeyStroke.

getAWTKeyStrokeForEvent(KeyEvent) - Static method in class java.awt.AWTKeyStroke

Returns an AWTKeyStroke which represents the stroke which generated a given KeyEvent.

getAxis() - Method in class javax.swing.BoxLayout

Returns the axis that was used to lay out components.

getAxis() - Method in class javax.swing.text.BoxView

Fetches the tile axis property.

getB() - Method in class java.security.spec.EllipticCurve

Returns the second coefficient b of the elliptic curve.

getBackBuffer() - Method in class java.awt.Component.FlipBufferStrategy

getBackBufferCapabilities() - Method in class java.awt.BufferCapabilities

getBackground() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the background color of this object.

getBackground() - Method in class java.awt.Component

Gets the background color of this component.

getBackground() - Method in class java.awt.Graphics2D

Returns the background color used for clearing a region.

getBackground() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the background color of this object.

getBackground() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the background color of this object.

getBackground() - Method in class java.awt.TextComponent

Gets the background color of this text component.

getBackground() - Method in class java.awt.Window

Gets the background color of this window.

getBackground() - Method in interface javax.accessibility.AccessibleComponent

Gets the background color of this object.

getBackground() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getBackground() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the background color of this object.

getBackground() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the background color of this object.

getBackground() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBackground(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the background color from an attribute set.

getBackground() - Method in class javax.swing.text.GlyphView

Fetch the background color to use to render the glyphs.

getBackground(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Takes a set of attributes and turn it into a background color specification.

getBackground() - Method in class javax.swing.text.LabelView

Fetches the background color to use to render the glyphs.

getBackground(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the background color setting from the attribute list.

getBackground(AttributeSet) - Method in class javax.swing.text.StyleContext

Takes a set of attributes and turn it into a background color specification.

getBackground(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a background color specification.

getBackgroundAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab background color at index.

getBackgroundNonSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the background color to be used for non selected nodes.

getBackgroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext.

getBackgroundSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color to use for the background if node is selected.

getBandOffsets() - Method in class java.awt.image.ComponentSampleModel

Returns the band offset for all bands.

getBank() - Method in class javax.sound.midi.Patch

Returns the number of the bank that contains the instrument whose location this Patch specifies.

getBankData() - Method in class java.awt.image.DataBufferByte

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferDouble

Returns the data array for all banks.

getBankData() - Method in class java.awt.image.DataBufferFloat

Returns the data array for all banks.

getBankData() - Method in class java.awt.image.DataBufferInt

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferShort

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferUShort

Returns the data arrays for all banks.

getBankIndices() - Method in class java.awt.image.ComponentSampleModel

Returns the bank indices for all bands.

getBase() - Method in class javax.swing.text.html.HTMLDocument

Returns the location to resolve relative URLs against.

getBase() - Method in class javax.swing.text.html.StyleSheet

Returns the base.

getBase64Content() - Method in class javax.xml.soap.AttachmentPart

Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.

getBaseLevel() - Method in class java.text.Bidi

Return the base level (0 if left-to-right, 1 if right-to-left).

getBaseline(int, int) - Method in class java.awt.Component

Returns the baseline.

getBaseline() - Method in class java.awt.font.TextLayout

Returns the baseline for this TextLayout.

getBaseline(Component, int, int) - Method in class javax.swing.border.AbstractBorder

Returns the baseline.

getBaseline(Component, int, int) - Method in class javax.swing.border.TitledBorder

Returns the baseline.

getBaseline(int, int) - Method in class javax.swing.JComponent

Returns the baseline.

getBaseline(int, int) - Method in class javax.swing.JSpinner.DefaultEditor

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicButtonUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicLabelUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicPanelUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicSpinnerUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the baseline.

getBaseline(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the baseline for the specified tab.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTableUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.ComponentUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this calls the view's getBaseline() method.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.metal.MetalComboBoxUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthButtonUI

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthLabelUI

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthSliderUI

getBaseline(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getBaselineFor(char) - Method in class java.awt.Font

Returns the baseline appropriate for displaying this character.

getBaselineIndex() - Method in class java.awt.font.LineMetrics

Returns the baseline index of the text.

getBaselineOffset() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the amount the baseline is offset by.

getBaselineOffset() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Returns the amount the baseline is offset by.

getBaselineOffsets() - Method in class java.awt.font.LineMetrics

Returns the baseline offsets of the text, relative to the baseline of the text.

getBaselineOffsets() - Method in class java.awt.font.TextLayout

Returns the offsets array for the baselines used for this TextLayout.

getBaselineResizeBehavior() - Method in class java.awt.Component

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(Component) - Method in class javax.swing.border.AbstractBorder

Returns an enum indicating how the baseline of a component changes as the size changes.

getBaselineResizeBehavior(Component) - Method in class javax.swing.border.TitledBorder

Returns an enum indicating how the baseline of the border changes as the size changes.

getBaselineResizeBehavior() - Method in class javax.swing.JComponent

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior() - Method in class javax.swing.JSpinner.DefaultEditor

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicPanelUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns an enum indicating how the baseline of he component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getBaselineResizeBehavior() method.

getBaseType() - Method in interface java.sql.Array

Retrieves the JDBC type of the elements in the array designated by this Array object.

getBaseType() - Method in class javax.activation.MimeType

Return a String representation of this object without the parameter list.

getBaseType() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves the SQL type of the elements in this SerialArray object.

getBaseTypeName() - Method in interface java.sql.Array

Retrieves the SQL type name of the elements in the array designated by this Array object.

getBaseTypeName() - Method in interface java.sql.Ref

Retrieves the fully-qualified SQL name of the SQL structured type that this Ref object references.

getBaseTypeName() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves the DBMS-specific type name for the elements in this SerialArray object.

getBaseTypeName() - Method in class javax.sql.rowset.serial.SerialRef

Returns a string describing the base type name of the Ref.

getBaseURI() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getBaseURI() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getBaseURI() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the base URI.

getBaseURI() - Method in interface javax.xml.stream.events.EntityDeclaration

Get the base URI for this reference or null if this information is not available

getBaseURI() - Method in interface org.w3c.dom.ls.LSInput

The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.

getBaseURI() - Method in interface org.w3c.dom.Node

The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.

getBasicConstraints() - Method in class java.security.cert.X509Certificate

Gets the certificate constraints path length from the critical BasicConstraints extension, (OID = 2.5.29.19).

getBasicConstraints() - Method in class java.security.cert.X509CertSelector

Returns the basic constraints constraint.

getBasicSplitPaneUI() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the SplitPaneUI the receiver is currently in.

getBean(CommandInfo) - Method in class javax.activation.DataHandler

A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.

getBeanClass() - Method in class java.beans.BeanDescriptor

Gets the bean's Class object.

getBeanContext() - Method in interface java.beans.beancontext.BeanContextChild

Gets the BeanContext associated with this BeanContextChild.

getBeanContext() - Method in class java.beans.beancontext.BeanContextChildSupport

Gets the nesting BeanContext for this BeanContextChildSupport.

getBeanContext() - Method in class java.beans.beancontext.BeanContextEvent

Gets the BeanContext associated with this event.

getBeanContextChildPeer() - Method in class java.beans.beancontext.BeanContextChildSupport

Gets the BeanContextChild associated with this BeanContextChildSupport.

getBeanContextPeer() - Method in class java.beans.beancontext.BeanContextSupport

Gets the instance of BeanContext that this object is providing the implementation for.

getBeanContextProxy() - Method in interface java.beans.beancontext.BeanContextProxy

Gets the BeanContextChild (or subinterface) associated with this object.

getBeanContextServicesPeer() - Method in class java.beans.beancontext.BeanContextServicesSupport

Gets the BeanContextServices associated with this BeanContextServicesSupport.

getBeanDescriptor() - Method in interface java.beans.BeanInfo

Gets the beans BeanDescriptor.

getBeanDescriptor() - Method in class java.beans.SimpleBeanInfo

Deny knowledge about the class and customizer of the bean.

getBeanInfo(Class<?>) - Static method in class java.beans.Introspector

Introspect on a Java Bean and learn about all its properties, exposed methods, and events.

getBeanInfo(Class<?>, int) - Static method in class java.beans.Introspector

Introspect on a Java bean and learn about all its properties, exposed methods, and events, subject to some control flags.

getBeanInfo(Class<?>, Class<?>) - Static method in class java.beans.Introspector

Introspect on a Java bean and learn all about its properties, exposed methods, below a given "stop" point.

getBeanInfo(Class<?>, Class<?>, int) - Static method in class java.beans.Introspector

Introspect on a Java Bean and learn about all its properties, exposed methods and events, below a given stopClass point subject to some control flags.

getBeanInfoSearchPath() - Static method in class java.beans.Introspector

Gets the list of package names that will be used for finding BeanInfo classes.

getBeforeIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String before a given index.

getBeforeIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String before a given index.

getBeginIndex() - Method in interface java.text.CharacterIterator

Returns the start index of the text.

getBeginIndex() - Method in class java.text.FieldPosition

Retrieves the index of the first character in the requested field.

getBeginIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getBeginIndex() for String.

getBeginIndex() - Method in class javax.swing.text.Segment

Returns the start index of the text.

getBestConfiguration(GraphicsConfiguration[]) - Method in class java.awt.GraphicsConfigTemplate

Returns the "best" configuration possible that passes the criteria defined in the GraphicsConfigTemplate.

getBestConfiguration(GraphicsConfigTemplate) - Method in class java.awt.GraphicsDevice

Returns the "best" configuration possible that passes the criteria defined in the GraphicsConfigTemplate.

getBestCursorSize(int, int) - Method in class java.awt.Toolkit

Returns the supported cursor dimension which is closest to the desired sizes.

getBestRowIdentifier(String, String, String, int, boolean) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of a table's optimal set of columns that uniquely identifies a row.

getBevelType() - Method in class javax.swing.border.BevelBorder

Returns the type of the bevel border.

getBias() - Method in class javax.swing.text.JTextComponent.DropLocation

Returns the bias for the drop index.

getBidiLevel(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the BidiLevel setting.

getBidiRootElement() - Method in class javax.swing.text.AbstractDocument

Returns the root element of the bidirectional structure for this document.

getBigDecimal(int, int) - Method in interface java.sql.CallableStatement

Deprecated.
use getBigDecimal(int parameterIndex) or getBigDecimal(String parameterName)

getBigDecimal(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC NUMERIC parameter as a java.math.BigDecimal object with as many digits to the right of the decimal point as the value contains.

getBigDecimal(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC NUMERIC parameter as a java.math.BigDecimal object with as many digits to the right of the decimal point as the value contains.

getBigDecimal(int, int) - Method in interface java.sql.ResultSet

Deprecated.

getBigDecimal(String, int) - Method in interface java.sql.ResultSet

Deprecated.

getBigDecimal(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.math.BigDecimal with full precision.

getBigDecimal(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.math.BigDecimal with full precision.

getBinaryName(TypeElement) - Method in interface javax.lang.model.util.Elements

Returns the binary name of a type element.

getBinaryStream() - Method in interface java.sql.Blob

Retrieves the BLOB value designated by this Blob instance as a stream.

getBinaryStream(long, long) - Method in interface java.sql.Blob

Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.

getBinaryStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of uninterpreted bytes.

getBinaryStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of uninterpreted bytes.

getBinaryStream() - Method in interface java.sql.SQLXML

Retrieves the XML value designated by this SQLXML instance as a stream.

getBinaryStream() - Method in class javax.sql.rowset.serial.SerialBlob

Returns this SerialBlob object as an input stream.

getBinaryStream(long, long) - Method in class javax.sql.rowset.serial.SerialBlob

Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.

getBinding() - Method in interface javax.xml.ws.BindingProvider

Get the Binding for this binding provider.

getBinding() - Method in class javax.xml.ws.Endpoint

Returns the binding for this endpoint.

getBindingID() - Method in interface javax.xml.ws.Binding

Get the URI for this binding instance.

getBindingID() - Method in interface javax.xml.ws.handler.PortInfo

Gets the URI identifying the binding used by the port being accessed.

getBindings(int) - Method in class javax.script.AbstractScriptEngine

Returns the Bindings with the specified scope value in the protected context field.

getBindings(int) - Method in interface javax.script.ScriptContext

Gets the Bindings associated with the given scope in this ScriptContext.

getBindings(int) - Method in interface javax.script.ScriptEngine

Returns a scope of named values.

getBindings() - Method in class javax.script.ScriptEngineManager

getBindings returns the value of the globalScope field.

getBindings(int) - Method in class javax.script.SimpleScriptContext

Returns the value of the engineScope field if specified scope is ENGINE_SCOPE.

getBitDepth() - Method in class java.awt.DisplayMode

Returns the bit depth of the display, in bits per pixel.

getBitMasks() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the bit masks for all bands.

getBitOffset(int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the offset, in bits, into the data element in which it is stored for the xth pixel of a scanline.

getBitOffset() - Method in interface javax.imageio.stream.ImageInputStream

Returns the current bit offset, as an integer between 0 and 7, inclusive.

getBitOffset() - Method in class javax.imageio.stream.ImageInputStreamImpl

getBitOffsets() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the bit offsets into the data array element representing a pixel for all bands.

getBitRate(float) - Method in class javax.imageio.ImageWriteParam

Returns a float indicating an estimate of the number of bits of output data for each bit of input image data at the given quality level.

getBitsPerBand(int) - Method in class javax.imageio.ImageTypeSpecifier

Return the number of bits used to represent samples of the given band.

getBlack() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the black color of the current theme.

getBlack() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the black color.

getBlack() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the black color.

getBlackBoxBounds(int, int) - Method in class java.awt.font.TextLayout

Returns the black box bounds of the characters in the specified range.

getBlackLineBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getBlinkRate() - Method in interface javax.swing.text.Caret

Gets the blink rate of the caret.

getBlinkRate() - Method in class javax.swing.text.DefaultCaret

Gets the caret blink rate.

getBlob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BLOB parameter as a Blob object in the Java programming language.

getBlob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BLOB parameter as a Blob object in the Java programming language.

getBlob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Blob object in the Java programming language.

getBlob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Blob object in the Java programming language.

getBlockedCount() - Method in class java.lang.management.ThreadInfo

Returns the total number of times that the thread associated with this ThreadInfo blocked to enter or reenter a monitor.

getBlockedTime() - Method in class java.lang.management.ThreadInfo

Returns the approximate accumulated elapsed time (in milliseconds) that the thread associated with this ThreadInfo has blocked to enter or reenter a monitor since thread contention monitoring is enabled.

getBlocker(Thread) - Static method in class java.util.concurrent.locks.LockSupport

Returns the blocker object supplied to the most recent invocation of a park method that has not yet unblocked, or null if not blocked.

getBlockIncrement() - Method in interface java.awt.Adjustable

Gets the block value increment for the adjustable object.

getBlockIncrement() - Method in class java.awt.Scrollbar

Gets the block increment of this scroll bar.

getBlockIncrement() - Method in class java.awt.ScrollPaneAdjustable

getBlockIncrement(int) - Method in class javax.swing.JScrollBar

Returns the amount to change the scrollbar's value by, given a block (usually "page") up/down request.

getBlockIncrement() - Method in class javax.swing.JScrollBar

For backwards compatibility with java.awt.Scrollbar.

getBlockIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Computes the block increment for scrolling if the viewport's view is a Scrollable object.

getBlockSize() - Method in class javax.crypto.Cipher

Returns the block size (in bytes).

getBlue() - Method in class java.awt.Color

Returns the blue component in the range 0-255 in the default sRGB space.

getBlue(int) - Method in class java.awt.image.ColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.ColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.ComponentColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.ComponentColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.DirectColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.DirectColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.IndexColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlueMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the blue color component.

getBlues(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of blue color components into the specified array.

getBody() - Method in class java.net.CacheRequest

Returns an OutputStream to which the response body can be written.

getBody() - Method in class java.net.CacheResponse

Returns the response body as an InputStream.

getBody() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPBody object associated with this SOAPEnvelope object.

getBoolean(String) - Static method in class java.lang.Boolean

Returns true if and only if the system property named by the argument exists and is equal to the string "true".

getBoolean(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a boolean.

getBoolean(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance boolean field.

getBoolean(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BIT or BOOLEAN parameter as a boolean in the Java programming language.

getBoolean(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BIT or BOOLEAN parameter as a boolean in the Java programming language.

getBoolean(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a boolean in the Java programming language.

getBoolean(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a boolean in the Java programming language.

getBoolean(String, boolean) - Method in class java.util.prefs.AbstractPreferences

Implements the getBoolean method as per the specification in Preferences.getBoolean(String,boolean).

getBoolean(String, boolean) - Method in class java.util.prefs.Preferences

Returns the boolean value represented by the string associated with the specified key in this preference node.

getBoolean(SynthContext, Object, boolean) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is an Boolean.

getBoolean(Object) - Method in class javax.swing.UIDefaults

If the value of key is boolean, return the boolean value, otherwise return false.

getBoolean(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is boolean, return the boolean value, otherwise return false.

getBoolean(Object) - Static method in class javax.swing.UIManager

Returns a boolean from the defaults which is associated with the key value.

getBoolean(Object, Locale) - Static method in class javax.swing.UIManager

Returns a boolean from the defaults which is associated with the key value and the given Locale.

getBootClassPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the boot class path that is used by the bootstrap class loader to search for class files.

getBorder() - Method in class javax.swing.border.TitledBorder

Returns the border of the titled border.

getBorder() - Method in class javax.swing.JComponent

Returns the border of this component or null if no border is currently set.

getBorder() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the border of this component or null if no border is currently set.

getBorder() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Overrides JComponent.getBorder to returns the current border.

getBorder(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Border return it, otherwise return null.

getBorder(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Border return it, otherwise return null.

getBorder(Object) - Static method in class javax.swing.UIManager

Returns a border from the defaults.

getBorder(Object, Locale) - Static method in class javax.swing.UIManager

Returns a border from the defaults that is appropriate for the given locale.

getBorderColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getBorderInsets(Component) - Method in class javax.swing.border.AbstractBorder

This default implementation returns a new Insets object that is initialized by the AbstractBorder.getBorderInsets(Component,Insets) method.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.AbstractBorder

Reinitializes the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.BevelBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component) - Method in interface javax.swing.border.Border

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.CompoundBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.EmptyBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets() - Method in class javax.swing.border.EmptyBorder

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.EtchedBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.LineBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.MatteBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets() - Method in class javax.swing.border.MatteBorder

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.SoftBevelBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.StrokeBorder

Reinitializes the insets parameter with this border's current insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.TitledBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.FieldBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.MarginBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder

getBorderInsets(Component) - Method in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder

getBorderInsets(Component) - Method in class javax.swing.plaf.BorderUIResource

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.Flush3DBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.InternalFrameBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.MenuItemBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.OptionDialogBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.PaletteBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ToolBarBorder

getBorderPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext.

getBorderSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns the color the border is drawn.

getBorderSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the border is drawn.

getBorderTitle(Border) - Method in class javax.swing.JComponent.AccessibleJComponent

Recursively search through the border hierarchy (if it exists) for a TitledBorder with a non-null title.

getBottomComponent() - Method in class javax.swing.JSplitPane

Returns the component below, or to the right of the divider.

getBottomInset() - Method in class javax.swing.text.AsyncBoxView

Get the bottom part of the margin around the view.

getBottomInset() - Method in class javax.swing.text.CompositeView

Gets the bottom inset.

getBottomPanel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getBoundActions() - Method in interface javax.swing.text.Keymap

Fetches all of the actions defined in this keymap.

getBoundedPosition(GlyphView, int, float, float) - Method in class javax.swing.text.GlyphView.GlyphPainter

Determines the model location that represents the maximum advance that fits within the given span.

getBoundingBox() - Method in class java.awt.Polygon

Deprecated.
As of JDK version 1.1, replaced by getBounds().

getBoundKeyStrokes() - Method in interface javax.swing.text.Keymap

Fetches all of the keystrokes in this map that are bound to some action.

getBounds() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.Component

Gets the bounds of this component in the form of a Rectangle object.

getBounds(Rectangle) - Method in class java.awt.Component

Stores the bounds of this component into "return value" rv and return rv.

getBounds() - Method in class java.awt.font.GraphicAttribute

Returns a Rectangle2D that encloses all of the bits drawn by this GraphicAttribute relative to the rendering position.

getBounds() - Method in class java.awt.font.ImageGraphicAttribute

Returns a Rectangle2D that encloses all of the bits rendered by this ImageGraphicAttribute, relative to the rendering position.

getBounds() - Method in class java.awt.font.ShapeGraphicAttribute

Returns a Rectangle2D that encloses all of the bits drawn by this ShapeGraphicAttribute relative to the rendering position.

getBounds() - Method in class java.awt.font.TextLayout

Returns the bounds of this TextLayout.

getBounds() - Method in class java.awt.geom.Area

Returns a bounding Rectangle that completely encloses this Area.

getBounds() - Method in class java.awt.geom.CubicCurve2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.Line2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.Path2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.QuadCurve2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.RectangularShape

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.GraphicsConfiguration

Returns the bounds of the GraphicsConfiguration in the device coordinates.

getBounds() - Method in class java.awt.image.Raster

Returns the bounding Rectangle of this Raster.

getBounds() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.Polygon

Gets the bounding box of this Polygon.

getBounds() - Method in class java.awt.Rectangle

Gets the bounding Rectangle of this Rectangle.

getBounds() - Method in interface java.awt.Shape

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.SplashScreen

Returns the bounds of the splash screen window as a Rectangle.

getBounds() - Method in interface java.lang.reflect.TypeVariable

Returns an array of Type objects representing the upper bound(s) of this type variable.

getBounds() - Method in interface javax.accessibility.AccessibleComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the bounds of this type parameter.

getBounds(Rectangle) - Method in class javax.swing.JComponent

Stores the bounds of this component into "return value" rv and returns rv.

getBounds() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getBounds() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getBounds() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getBounds() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns a rectangle giving the bounds needed to draw path.

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns a rectangle giving the bounds needed to draw path.

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.

getBounds2D() - Method in class java.awt.font.GlyphMetrics

Returns the bounds of the glyph.

getBounds2D() - Method in class java.awt.geom.Arc2D

Returns the high-precision framing rectangle of the arc.

getBounds2D() - Method in class java.awt.geom.Area

Returns a high precision bounding Rectangle2D that completely encloses this Area.

getBounds2D() - Method in class java.awt.geom.CubicCurve2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.CubicCurve2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Ellipse2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Ellipse2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Line2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Line2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Path2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Path2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.QuadCurve2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.QuadCurve2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D(BufferedImage) - Method in class java.awt.image.AffineTransformOp

Returns the bounding box of the transformed destination.

getBounds2D(Raster) - Method in class java.awt.image.AffineTransformOp

Returns the bounding box of the transformed destination.

getBounds2D(Raster) - Method in class java.awt.image.BandCombineOp

Returns the bounding box of the transformed destination.

getBounds2D(BufferedImage) - Method in interface java.awt.image.BufferedImageOp

Returns the bounding box of the filtered destination image.

getBounds2D(BufferedImage) - Method in class java.awt.image.ColorConvertOp

Returns the bounding box of the destination, given this source.

getBounds2D(Raster) - Method in class java.awt.image.ColorConvertOp

Returns the bounding box of the destination, given this source.

getBounds2D(BufferedImage) - Method in class java.awt.image.ConvolveOp

Returns the bounding box of the filtered destination image.

getBounds2D(Raster) - Method in class java.awt.image.ConvolveOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(BufferedImage) - Method in class java.awt.image.LookupOp

Returns the bounding box of the filtered destination image.

getBounds2D(Raster) - Method in class java.awt.image.LookupOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(Raster) - Method in interface java.awt.image.RasterOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(ParameterBlock) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Returns the bounding box for the output of the operation, performed on a given set of sources, in rendering-independent space.

getBounds2D(BufferedImage) - Method in class java.awt.image.RescaleOp

Returns the bounding box of the rescaled destination image.

getBounds2D(Raster) - Method in class java.awt.image.RescaleOp

Returns the bounding box of the rescaled destination Raster.

getBounds2D() - Method in class java.awt.Polygon

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.Rectangle

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in interface java.awt.Shape

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBoundsAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab bounds at index.

getBoundsForIconOf(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager

The iconifyFrame() code calls this to determine the proper bounds for the desktopIcon.

getBox(Rectangle) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r.

getBox(Rectangle) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

getBoxLength(int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the length of the "bouncing box" to be painted.

getBoxPainter(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the box formatter to use for the given set of CSS attributes.

getBranchQualifier() - Method in interface javax.transaction.xa.Xid

Obtain the transaction branch identifier part of XID as an array of bytes.

getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determine where to break the given text to fit within the given span.

getBreakWeight(int, float, float) - Method in class javax.swing.text.GlyphView

Determines how attractive a break opportunity in this view is.

getBreakWeight(int, float, float) - Method in class javax.swing.text.html.InlineView

Determines how attractive a break opportunity in this view is.

getBreakWeight(int, float) - Method in class javax.swing.text.ParagraphView

Gets the break weight for a given location.

getBreakWeight(int, float, float) - Method in class javax.swing.text.View

Determines how attractive a break opportunity in this view is.

getBroadcast() - Method in class java.net.DatagramSocket

Tests if SO_BROADCAST is enabled.

getBroadcast() - Method in class java.net.InterfaceAddress

Returns an InetAddress for the brodcast address for this InterfaceAddress.

getBubbles() - Method in interface org.w3c.dom.events.Event

Used to indicate whether or not an event is a bubbling event.

getBuffer() - Method in class java.io.StringWriter

Return the string buffer itself.

getBufferCapabilities() - Method in class java.awt.GraphicsConfiguration

Returns the buffering capabilities of this GraphicsConfiguration.

getBufferedImageOp() - Method in class java.awt.image.BufferedImageFilter

Returns the BufferedImageOp.

getBufferedImageType() - Method in class javax.imageio.ImageTypeSpecifier

Returns an int containing one of the enumerated constant values describing image formats from BufferedImage.

getBufferSize() - Method in interface javax.sound.sampled.DataLine

Obtains the maximum number of bytes of data that will fit in the data line's internal buffer.

getBufferStrategy() - Method in class java.awt.Canvas

Returns the BufferStrategy used by this component.

getBufferStrategy() - Method in class java.awt.Window

Returns the BufferStrategy used by this component.

getBuilder() - Method in class javax.xml.bind.annotation.W3CDomHandler

getBundle(String) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name, the default locale, and the caller's class loader.

getBundle(String, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, the default locale and the specified control.

getBundle(String, Locale) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name and locale, and the caller's class loader.

getBundle(String, Locale, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, target locale and control, and the caller's class loader.

getBundle(String, Locale, ClassLoader) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name, locale, and class loader.

getBundle(String, Locale, ClassLoader, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, target locale, class loader and control.

getBusy() - Method in interface org.w3c.dom.ls.LSParser

true if the LSParser is currently busy loading a document, otherwise false.

getButton() - Method in class java.awt.event.MouseEvent

Returns which, if any, of the mouse buttons has changed state.

getButton() - Method in interface org.w3c.dom.events.MouseEvent

During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.

getButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getButtonBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JButton

getButtonCount() - Method in class javax.swing.ButtonGroup

Returns the number of buttons in the group.

getButtonPanel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getButtons() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the buttons to display from the JOptionPane the receiver is providing the look and feel for.

getButtonWidth() - Method in class javax.swing.plaf.metal.MetalScrollButton

getByAddress(String, byte[], NetworkInterface) - Static method in class java.net.Inet6Address

Create an Inet6Address in the exact manner of InetAddress.getByAddress(String,byte[]) except that the IPv6 scope_id is set to the value corresponding to the given interface for the address type specified in addr.

getByAddress(String, byte[], int) - Static method in class java.net.Inet6Address

Create an Inet6Address in the exact manner of InetAddress.getByAddress(String,byte[]) except that the IPv6 scope_id is set to the given numeric value.

getByAddress(String, byte[]) - Static method in class java.net.InetAddress

Creates an InetAddress based on the provided host name and IP address.

getByAddress(byte[]) - Static method in class java.net.InetAddress

Returns an InetAddress object given the raw IP address .

getByIndex(int) - Static method in class java.net.NetworkInterface

Get a network interface given its index.

getByInetAddress(InetAddress) - Static method in class java.net.NetworkInterface

Convenience method to search for a network interface that has the specified Internet Protocol (IP) address bound to it.

getByName(String) - Static method in class java.net.InetAddress

Determines the IP address of a host, given the host's name.

getByName(String) - Static method in class java.net.NetworkInterface

Searches for the network interface with the specified name.

getByte(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a byte.

getByte(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance byte field.

getByte(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TINYINT parameter as a byte in the Java programming language.

getByte(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TINYINT parameter as a byte in the Java programming language.

getByte(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte in the Java programming language.

getByte(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte in the Java programming language.

getByteArray(String, byte[]) - Method in class java.util.prefs.AbstractPreferences

Implements the getByteArray method as per the specification in Preferences.getByteArray(String,byte[]).

getByteArray(String, byte[]) - Method in class java.util.prefs.Preferences

Returns the byte array value represented by the string associated with the specified key in this preference node.

getByteLength() - Method in class javax.sound.midi.MidiFileFormat

Obtains the length of the MIDI file, expressed in 8-bit bytes.

getByteLength() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the size in bytes of the entire audio file (not just its audio data).

getByteOffset() - Method in interface org.w3c.dom.DOMLocator

The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

getByteOrder() - Method in interface javax.imageio.stream.ImageInputStream

Returns the byte order with which data values will be read from this stream as an instance of the java.nio.ByteOrder enumeration.

getByteOrder() - Method in class javax.imageio.stream.ImageInputStreamImpl

getByteParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a byte.

getBytes(int, int, byte[], int) - Method in class java.lang.String

Deprecated.
This method does not properly convert characters into bytes. As of JDK 1.1, the preferred way to do this is via the String.getBytes() method, which uses the platform's default charset.

getBytes(String) - Method in class java.lang.String

Encodes this String into a sequence of bytes using the named charset, storing the result into a new byte array.

getBytes(Charset) - Method in class java.lang.String

Encodes this String into a sequence of bytes using the given charset, storing the result into a new byte array.

getBytes() - Method in class java.lang.String

Encodes this String into a sequence of bytes using the platform's default charset, storing the result into a new byte array.

getBytes(long, int) - Method in interface java.sql.Blob

Retrieves all or part of the BLOB value that this Blob object represents, as an array of bytes.

getBytes(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BINARY or VARBINARY parameter as an array of byte values in the Java programming language.

getBytes(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BINARY or VARBINARY parameter as an array of byte values in the Java programming language.

getBytes(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte array in the Java programming language.

getBytes(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte array in the Java programming language.

getBytes() - Method in interface java.sql.RowId

Returns an array of bytes representing the value of the SQL ROWID designated by this java.sql.RowId object.

getBytes(long, int) - Method in class javax.sql.rowset.serial.SerialBlob

Copies the specified number of bytes, starting at the given position, from this SerialBlob object to another array of bytes.

getBytesRead() - Method in class java.util.zip.Deflater

Returns the total number of uncompressed bytes input so far.

getBytesRead() - Method in class java.util.zip.Inflater

Returns the total number of compressed bytes input so far.

getByteStream() - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of bytes.

getByteStream() - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream of bytes.

getByteStream() - Method in class org.xml.sax.InputSource

Get the byte stream for this input source.

getBytesWritten() - Method in class java.util.zip.Deflater

Returns the total number of compressed bytes output so far.

getBytesWritten() - Method in class java.util.zip.Inflater

Returns the total number of uncompressed bytes output so far.

getCA() - Method in class java.security.cert.TrustAnchor

Returns the name of the most-trusted CA as an X500Principal.

getCachedIcon(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getCacheDirectory() - Static method in class javax.imageio.ImageIO

Returns the current value set by setCacheDirectory, or null if no explicit setting has been made.

getCachedMBeanInfo() - Method in class javax.management.StandardMBean

Customization hook: Return the MBeanInfo cached for this object.

getCalculatedDigestValue() - Method in interface javax.xml.crypto.dsig.Reference

Returns the calculated digest value of this Reference after a validation operation.

getCalendar() - Method in class java.text.DateFormat

Gets the calendar associated with this date/time formatter.

getCalendarField() - Method in class java.text.DateFormat.Field

Returns the Calendar field associated with this attribute.

getCalendarField() - Method in class javax.swing.SpinnerDateModel

Returns the Calendar field that is added to or subtracted from by the nextValue and previousValue methods.

getCallback() - Method in exception javax.security.auth.callback.UnsupportedCallbackException

Get the unrecognized Callback.

getCallbackHandler() - Method in class java.security.KeyStore.CallbackHandlerProtection

Returns the CallbackHandler.

getCAName() - Method in class java.security.cert.TrustAnchor

Returns the name of the most-trusted CA in RFC 2253 String format.

getCancelable() - Method in interface org.w3c.dom.events.Event

Used to indicate whether or not an event can have its default action prevented.

getCancelSelectionAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getCandidateLocales(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns a List of Locales as candidate locales for baseName and locale.

getCanonicalFile() - Method in class java.io.File

Returns the canonical form of this abstract pathname.

getCanonicalHostName() - Method in class java.net.InetAddress

Gets the fully qualified domain name for this IP address.

getCanonicalizationMethod() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the canonicalization method of this SignedInfo.

getCanonicalizedData() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the canonicalized signed info bytes after a signing or validation operation.

getCanonicalKeyPropertyListString() - Method in class javax.management.ObjectName

Returns a string representation of the list of key properties, in which the key properties are sorted in lexical order.

getCanonicalName() - Method in class java.lang.类

Returns the canonical name of the underlying class as defined by the Java Language Specification.

getCanonicalName() - Method in class javax.management.ObjectName

Returns the canonical form of the name; that is, a string representation where the properties are sorted in lexical order.

getCanonicalPath() - Method in class java.io.File

Returns the canonical pathname string of this abstract pathname.

getCanWrapLines() - Method in class javax.swing.text.AbstractWriter

Returns whether or not the lines can be wrapped.

getCapabilities() - Method in class java.awt.Component.BltBufferStrategy

getCapabilities() - Method in class java.awt.Component.FlipBufferStrategy

getCapabilities() - Method in class java.awt.image.BufferStrategy

Returns the BufferCapabilities for this BufferStrategy.

getCapabilities(GraphicsConfiguration) - Method in class java.awt.Image

Returns an ImageCapabilities object which can be inquired as to the capabilities of this Image on the specified GraphicsConfiguration.

getCapabilities() - Method in class java.awt.image.VolatileImage

Returns an ImageCapabilities object which can be inquired as to the specific capabilities of this VolatileImage.

getCAPublicKey() - Method in class java.security.cert.TrustAnchor

Returns the public key of the most-trusted CA.

getCaret() - Method in class java.awt.event.InputMethodEvent

Gets the caret.

getCaret() - Method in class javax.swing.text.JTextComponent

Fetches the caret that allows text-oriented navigation over the view.

getCaret() - Method in class javax.swing.text.NavigationFilter.FilterBypass

Returns the Caret that is changing.

getCaretColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the caret.

getCaretInfo(TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns information about the caret corresponding to hit.

getCaretInfo(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns information about the caret corresponding to hit.

getCaretListeners() - Method in class javax.swing.text.JTextComponent

Returns an array of all the caret listeners registered on this text component.

getCaretPosition() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class java.awt.TextComponent

Returns the position of the text insertion caret.

getCaretPosition() - Method in interface javax.accessibility.AccessibleText

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.JLabel.AccessibleJLabel

Return the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.text.JTextComponent

Returns the position of the text insertion caret for the text component.

getCaretShape(TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a Shape representing the caret at the specified hit inside the specified bounds.

getCaretShape(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns a Shape representing the caret at the specified hit inside the natural bounds of this TextLayout.

getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCaretShapes(int, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCaretShapes(int) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCatalog() - Method in interface java.sql.Connection

Retrieves this Connection object's current catalog name.

getCatalogName(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's table's catalog name.

getCatalogName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the catalog name of the table from which the value in the designated column was derived.

getCatalogs() - Method in interface java.sql.DatabaseMetaData

Retrieves the catalog names available in this database.

getCatalogSeparator() - Method in interface java.sql.DatabaseMetaData

Retrieves the String that this database uses as the separator between a catalog and table name.

getCatalogTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "catalog".

getCategories() - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator of 类 objects indicating the current set of categories.

getCategory() - Method in interface javax.print.attribute.Attribute

Get the printing attribute class which is to be used as the "category" for this printing attribute value when it is added to an attribute set.

getCategory() - Method in class javax.print.attribute.standard.Chromaticity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.ColorSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Compression

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Copies

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.CopiesSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtCreation

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtProcessing

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Destination

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DialogTypeSelection

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DocumentName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Fidelity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Finishings

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobHoldUntil

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressions

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressionsCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressionsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctetsProcessed

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctetsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheetsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMessageFromOperator

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobOriginatingUserName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobPriority

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobPrioritySupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobSheets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobState

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobStateReason

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobStateReasons

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Media

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MediaSize

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberOfDocuments

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberOfInterveningJobs

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberUp

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberUpSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.OrientationRequested

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.OutputDeviceAssigned

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PageRanges

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PagesPerMinute

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PagesPerMinuteColor

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PresentationDirection

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterInfo

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterLocation

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMakeAndModel

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMessageFromOperator

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMoreInfo

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterResolution

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterState

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterStateReason

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterStateReasons

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterURI

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrintQuality

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.QueuedJobCount

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.RequestingUserName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Severity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.SheetCollate

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Sides

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCause() - Method in exception java.awt.print.PrinterIOException

Returns the the cause of this exception (the IOException that terminated the print job).

getCause() - Method in exception java.io.WriteAbortedException

Returns the exception that terminated the operation (the cause).

getCause() - Method in exception java.lang.ClassNotFoundException

Returns the cause of this exception (the exception that was raised if an error occurred while attempting to load the class; otherwise null).

getCause() - Method in error java.lang.ExceptionInInitializerError

Returns the cause of this error (the exception that occurred during a static initialization that caused this error to be created).

getCause() - Method in exception java.lang.reflect.InvocationTargetException

Returns the cause of this exception (the thrown target exception, which may be null).

getCause() - Method in exception java.lang.reflect.UndeclaredThrowableException

Returns the cause of this exception (the Throwable instance wrapped in this UndeclaredThrowableException, which may be null).

getCause() - Method in class java.lang.Throwable

Returns the cause of this throwable or null if the cause is nonexistent or unknown.

getCause() - Method in exception java.nio.file.DirectoryIteratorException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.activation.ActivationException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.RemoteException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.server.ServerCloneException

Returns the cause of this exception.

getCause() - Method in exception java.security.PrivilegedActionException

Returns the cause of this exception (the exception thrown by the privileged computation that resulted in this PrivilegedActionException).

getCause() - Method in exception javax.management.MBeanException

Return the actual Exception thrown.

getCause() - Method in exception javax.management.ReflectionException

Returns the actual Exception thrown.

getCause() - Method in exception javax.management.remote.JMXProviderException

getCause() - Method in exception javax.management.remote.JMXServerErrorException

getCause() - Method in exception javax.management.RuntimeErrorException

Returns the actual Error thrown.

getCause() - Method in exception javax.management.RuntimeMBeanException

Returns the actual RuntimeException thrown.

getCause() - Method in exception javax.management.RuntimeOperationsException

Returns the actual RuntimeException thrown.

getCause() - Method in exception javax.naming.NamingException

Returns the cause of this exception.

getCause() - Method in exception javax.security.sasl.SaslException

getCause() - Method in exception javax.xml.bind.JAXBException

getCause() - Method in exception javax.xml.crypto.dsig.TransformException

Returns the cause of this TransformException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.dsig.XMLSignatureException

Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.KeySelectorException

Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.MarshalException

Returns the cause of this MarshalException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.NoSuchMechanismException

Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.URIReferenceException

Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown.

getCause() - Method in error javax.xml.parsers.FactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.soap.SOAPException

Returns the Throwable object embedded in this SOAPException if there is one.

getCause() - Method in error javax.xml.stream.FactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.transform.TransformerException

Returns the cause of this throwable or null if the cause is nonexistent or unknown.

getCause() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.xpath.XPathException

Get the cause of this XPathException.

getCause() - Method in exception org.xml.sax.SAXException

Return the cause of the exception

getCellBounds(int, int) - Method in class javax.swing.JList

Returns the bounding rectangle, in the list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.ListUI

Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getCellBounds method on each UI handled by this object.

getCellEditor() - Method in class javax.swing.JTable

Returns the active cell editor, which is null if the table is not currently editing.

getCellEditor(int, int) - Method in class javax.swing.JTable

Returns an appropriate editor for the cell specified by row and column.

getCellEditor() - Method in class javax.swing.JTree

Returns the editor used to edit entries in the tree.

getCellEditor() - Method in class javax.swing.plaf.basic.BasicTreeUI

getCellEditor() - Method in class javax.swing.table.TableColumn

Returns the TableCellEditor used by the JTable to edit values for this column.

getCellEditorListeners() - Method in class javax.swing.AbstractCellEditor

Returns an array of all the CellEditorListeners added to this AbstractCellEditor with addCellEditorListener().

getCellEditorListeners() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().

getCellEditorValue() - Method in interface javax.swing.CellEditor

Returns the value contained in the editor.

getCellEditorValue() - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Returns the value of this cell.

getCellEditorValue() - Method in class javax.swing.DefaultCellEditor

Forwards the message from the CellEditor to the delegate.

getCellEditorValue() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns the value currently being edited.

getCellLength() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the width (if HORIZONTAL) or height (if VERTICAL) of each of the indivdual cells/units to be rendered in the progress bar.

getCellRect(int, int, boolean) - Method in class javax.swing.JTable

Returns a rectangle for the cell that lies at the intersection of row and column.

getCellRenderer() - Method in class javax.swing.JList

Returns the object responsible for painting list items.

getCellRenderer(int, int) - Method in class javax.swing.JTable

Returns an appropriate renderer for the cell specified by this row and column.

getCellRenderer() - Method in class javax.swing.JTree

Returns the current TreeCellRenderer that is rendering each cell.

getCellRenderer() - Method in class javax.swing.plaf.basic.BasicTreeUI

Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.

getCellRenderer() - Method in class javax.swing.table.TableColumn

Returns the TableCellRenderer used by the JTable to draw values for this column.

getCellSelectionEnabled() - Method in class javax.swing.JTable

Returns true if both row and column selection models are enabled.

getCellSpacing() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the spacing between each of the cells/units in the progress bar.

getCenterPoint() - Method in class java.awt.GraphicsEnvironment

Returns the Point where Windows should be centered.

getCenterPoint() - Method in class java.awt.RadialGradientPaint

Returns a copy of the center point of the radial gradient.

getCentersChildren() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getCenterX() - Method in class java.awt.geom.RectangularShape

Returns the X coordinate of the center of the framing rectangle of the Shape in double precision.

getCenterY() - Method in class java.awt.geom.RectangularShape

Returns the Y coordinate of the center of the framing rectangle of the Shape in double precision.

getCertificate() - Method in class java.security.cert.X509CertSelector

Returns the certificateEquals criterion.

getCertificate(String) - Method in class java.security.KeyStore

Returns the certificate associated with the given alias.

getCertificate() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the end entity Certificate from the certificate chain in this entry.

getCertificate() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the X.509 certificate.

getCertificateAlias(Certificate) - Method in class java.security.KeyStore

Returns the (alias) name of the first keystore entry whose certificate matches the given certificate.

getCertificateChain(String) - Method in class java.security.KeyStore

Returns the certificate chain associated with the given alias.

getCertificateChain() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the Certificate chain from this entry.

getCertificateChain(String) - Method in interface javax.net.ssl.X509KeyManager

Returns the certificate chain associated with the given alias.

getCertificateChecking() - Method in class java.security.cert.X509CRLSelector

Returns the certificate being checked.

getCertificateIssuer() - Method in class java.security.cert.X509CRLEntry

Get the issuer of the X509Certificate described by this entry.

getCertificates() - Method in class java.net.JarURLConnection

Return the Certificate object for this connection if the URL for it points to a JAR file entry, null otherwise.

getCertificates() - Method in class java.security.cert.CertPath

Returns the list of certificates in this certification path.

getCertificates(CertSelector) - Method in class java.security.cert.CertStore

Returns a Collection of Certificates that match the specified selector.

getCertificates() - Method in class java.security.CodeSource

Returns the certificates associated with this CodeSource.

getCertificates() - Method in class java.util.jar.JarEntry

Returns the Certificate objects for this entry, or null if none.

getCertificateValid() - Method in class java.security.cert.X509CertSelector

Returns the certificateValid criterion.

getCertifiedText() - Method in interface org.w3c.dom.ls.LSInput

If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

getCertPath() - Method in interface java.security.cert.CertPathBuilderResult

Returns the built certification path.

getCertPath() - Method in exception java.security.cert.CertPathValidatorException

Returns the certification path that was being validated when the exception was thrown.

getCertPath() - Method in class java.security.cert.PKIXCertPathBuilderResult

Returns the built and validated certification path.

getCertPathCheckers() - Method in class java.security.cert.PKIXParameters

Returns the List of certification path checkers.

getCertPathEncodings() - Method in class java.security.cert.CertificateFactory

Returns an iteration of the CertPath encodings supported by this certificate factory, with the default encoding first.

getCertStoreParameters() - Method in class java.security.cert.CertStore

Returns the parameters used to initialize this CertStore.

getCertStores() - Method in class java.security.cert.PKIXParameters

Returns an immutable List of CertStores that are used to find certificates and CRLs.

getChange(Element) - Method in interface javax.swing.event.DocumentEvent

Gets the change information for the given element.

getChange(Element) - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Gets the changes for an element.

getChanged() - Method in class java.awt.event.HierarchyEvent

Returns the Component at the top of the hierarchy which was changed.

getChangedParent() - Method in class java.awt.event.HierarchyEvent

Returns the parent of the Component returned by getChanged().

getChangeFlags() - Method in class java.awt.event.HierarchyEvent

Returns a bitmask which indicates the type(s) of HIERARCHY_CHANGED events represented in this event object.

getChangeInfo() - Method in class javax.naming.event.NamingEvent

Retrieves the change information for this event.

getChangeListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ChangeListeners added to this AbstractButton with addChangeListener().

getChangeListeners() - Method in class javax.swing.AbstractSpinnerModel

Returns an array of all the ChangeListeners added to this AbstractSpinnerModel with addChangeListener().

getChangeListeners() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel

Returns an array of all the ChangeListeners added to this DefaultColorSelectionModel with addChangeListener.

getChangeListeners() - Method in class javax.swing.DefaultBoundedRangeModel

Returns an array of all the change listeners registered on this DefaultBoundedRangeModel.

getChangeListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the change listeners registered on this DefaultButtonModel.

getChangeListeners() - Method in class javax.swing.DefaultSingleSelectionModel

Returns an array of all the change listeners registered on this DefaultSingleSelectionModel.

getChangeListeners() - Method in class javax.swing.JProgressBar

Returns an array of all the ChangeListeners added to this progress bar with addChangeListener.

getChangeListeners() - Method in class javax.swing.JSlider

Returns an array of all the ChangeListeners added to this JSlider with addChangeListener().

getChangeListeners() - Method in class javax.swing.JSpinner

Returns an array of all the ChangeListeners added to this JSpinner with addChangeListener().

getChangeListeners() - Method in class javax.swing.JTabbedPane

Returns an array of all the ChangeListeners added to this JTabbedPane with addChangeListener.

getChangeListeners() - Method in class javax.swing.JViewport

Returns an array of all the ChangeListeners added to this JViewport with addChangeListener().

getChangeListeners() - Method in class javax.swing.MenuSelectionManager

Returns an array of all the ChangeListeners added to this MenuSelectionManager with addChangeListener().

getChangeListeners() - Method in class javax.swing.text.DefaultCaret

Returns an array of all the change listeners registered on this caret.

getChangeListeners() - Method in class javax.swing.text.StyleContext

Returns an array of all the ChangeListeners added to this StyleContext with addChangeListener().

getChangeListeners() - Method in class javax.swing.text.StyleContext.NamedStyle

Returns an array of all the ChangeListeners added to this NamedStyle with addChangeListener().

getChangeToParentDirectoryAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getChannel() - Method in class java.io.FileInputStream

Returns the unique FileChannel object associated with this file input stream.

getChannel() - Method in class java.io.FileOutputStream

Returns the unique FileChannel object associated with this file output stream.

getChannel() - Method in class java.io.RandomAccessFile

Returns the unique FileChannel object associated with this file.

getChannel() - Method in class java.net.DatagramSocket

Returns the unique DatagramChannel object associated with this datagram socket, if any.

getChannel() - Method in class java.net.ServerSocket

Returns the unique ServerSocketChannel object associated with this socket, if any.

getChannel() - Method in class java.net.Socket

Returns the unique SocketChannel object associated with this socket, if any.

getChannel() - Method in class javax.sound.midi.ShortMessage

Obtains the MIDI channel associated with this event.

getChannelPressure() - Method in interface javax.sound.midi.MidiChannel

Obtains the channel's keyboard pressure.

getChannels() - Method in interface javax.sound.midi.Synthesizer

Obtains the set of MIDI channels controlled by this synthesizer.

getChannels() - Method in class javax.sound.sampled.AudioFormat

Obtains the number of channels.

getChar(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a char.

getChar(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type char or of another primitive type convertible to type char via a widening conversion.

getChar() - Method in class java.nio.ByteBuffer

Relative get method for reading a char value.

getChar(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a char value.

getCharacterAttribute(int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the AttributeSet for a given character (at a given index).

getCharacterAttribute(int) - Method in interface javax.accessibility.AccessibleText

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.JLabel.AccessibleJLabel

Return the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AttributeSet for a given character (at a given index).

getCharacterAttributeRun() - Method in class javax.swing.text.StyledEditorKit

Fetches the element representing the current run of character attributes for the caret.

getCharacterAttributes() - Method in class javax.swing.JTextPane

Fetches the character attributes in effect at the current location of the caret, or null.

getCharacterBounds(int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in interface javax.accessibility.AccessibleText

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Determine the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.JLabel.AccessibleJLabel

Determine the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Determines the bounding box of the character at the given index into the string.

getCharacterCount() - Method in class java.awt.font.TextLayout

Returns the number of characters represented by this TextLayout.

getCharacterElement(int) - Method in class javax.swing.text.DefaultStyledDocument

Gets a character element based on a position.

getCharacterElement(int) - Method in interface javax.swing.text.StyledDocument

Gets the element that represents the character that is at the given offset within the document.

getCharacterEncodingScheme() - Method in interface javax.xml.stream.events.StartDocument

Returns the encoding style of the XML data

getCharacterEncodingScheme() - Method in class javax.xml.stream.util.StreamReaderDelegate

getCharacterEncodingScheme() - Method in interface javax.xml.stream.XMLStreamReader

Returns the character encoding declared on the xml declaration Returns null if none was declared

getCharacterInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for character breaks for the default locale.

getCharacterInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for character breaks for the given locale.

getCharacterInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for character breaks for the given locale.

getCharacterLevel(int) - Method in class java.awt.font.TextLayout

Returns the level of the character at index.

getCharacterOffset() - Method in interface javax.xml.stream.Location

Return the byte or character offset into the input source this location is pointing to.

getCharacterStream(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getCharacterStream(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getCharacterStream() - Method in interface java.sql.Clob

Retrieves the CLOB value designated by this Clob object as a java.io.Reader object (or as a stream of characters).

getCharacterStream(long, long) - Method in interface java.sql.Clob

Returns a Reader object that contains a partial Clob value, starting with the character specified by pos, which is length characters in length.

getCharacterStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getCharacterStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getCharacterStream() - Method in interface java.sql.SQLXML

Retrieves the XML value designated by this SQLXML instance as a java.io.Reader object.

getCharacterStream() - Method in class javax.sql.rowset.serial.SerialClob

Returns this SerialClob object's data as a stream of Unicode characters.

getCharacterStream(long, long) - Method in class javax.sql.rowset.serial.SerialClob

getCharacterStream() - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of 16-bit units.

getCharacterStream() - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

getCharacterStream() - Method in class org.xml.sax.InputSource

Get the character stream for this input source.

getCharContent(boolean) - Method in interface javax.tools.FileObject

Gets the character content of this file object, if available.

getCharContent(boolean) - Method in class javax.tools.ForwardingFileObject

getCharContent(boolean) - Method in class javax.tools.SimpleJavaFileObject

This implementation always throws UnsupportedOperationException.

getCharCount() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the number of characters (valid indicies)

getCharCount() - Method in interface javax.accessibility.AccessibleText

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.JLabel.AccessibleJLabel

Return the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the number of characters (valid indices)

getCharIndex() - Method in class java.awt.font.TextHitInfo

Returns the index of the character hit.

getCharParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a char.

getChars(int, int, char[], int) - Method in class java.lang.String

Copies characters from this string into the destination character array.

getChars(int, int, char[], int) - Method in class java.lang.StringBuffer

getChars(int, int, Segment) - Method in interface javax.swing.text.AbstractDocument.Content

Gets a sequence of characters and copies them into a Segment.

getChars(int, int, Segment) - Method in class javax.swing.text.GapContent

Retrieves a portion of the content.

getChars(int, int, Segment) - Method in class javax.swing.text.StringContent

Retrieves a portion of the content.

getCharsetName() - Method in exception java.nio.charset.IllegalCharsetNameException

Retrieves the illegal charset name.

getCharsetName() - Method in exception java.nio.charset.UnsupportedCharsetException

Retrieves the name of the unsupported charset.

getCharSetSpec() - Method in exception javax.swing.text.ChangedCharSetException

getCheckboxGroup() - Method in class java.awt.Checkbox

Determines this check box's group.

getCheckBoxIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getCheckBoxIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

Returns a checkbox icon.

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getChecksum() - Method in class java.util.zip.CheckedInputStream

Returns the Checksum for this input stream.

getChecksum() - Method in class java.util.zip.CheckedOutputStream

Returns the Checksum for this output stream.

getChild() - Method in class java.awt.event.ContainerEvent

Returns the component that was affected by the event.

getChild(String) - Method in class java.util.prefs.AbstractPreferences

Returns the named child if it exists, or null if it does not.

getChild() - Method in class java.util.prefs.NodeChangeEvent

Returns the node that was added or removed.

getChild(File, String) - Method in class javax.swing.filechooser.FileSystemView

getChild(Object, int) - Method in class javax.swing.tree.DefaultTreeModel

Returns the child of parent at index index in the parent's child array.

getChild(Object, int) - Method in interface javax.swing.tree.TreeModel

Returns the child of parent at index index in the parent's child array.

getChildAfter(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.

getChildAllocation(int, Shape) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetch the allocation to use for a child view.

getChildAllocation(int) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetch the allocation to use for a child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.AsyncBoxView

Fetches the allocation for the given child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.BoxView

Fetches the allocation for the given child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.CompositeView

Fetches the allocation for the given child view to render into.

getChildAllocation(int, Shape) - Method in class javax.swing.text.View

Fetches the allocation for the given child view.

getChildAt(int) - Method in class javax.swing.JTree.DynamicUtilTreeNode

Subclassed to load the children, if necessary.

getChildAt(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the child TreeNode at index childIndex.

getChildAt(int) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child at the specified index in this node's child array.

getChildAt(int) - Method in interface javax.swing.tree.TreeNode

Returns the child TreeNode at index childIndex.

getChildBeanContextChild(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the BeanContextChild (if any) of the specified child

getChildBeanContextMembershipListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the BeanContextMembershipListener (if any) of the specified child

getChildBeanContextServicesListener(Object) - Static method in class java.beans.beancontext.BeanContextServicesSupport

Gets the BeanContextServicesListener (if any) of the specified child.

getChildBefore(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.

getChildCount() - Method in class javax.swing.JTree.DynamicUtilTreeNode

Returns the number of child nodes.

getChildCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the number of children TreeNode's receiver contains.

getChildCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of children of this node.

getChildCount(Object) - Method in class javax.swing.tree.DefaultTreeModel

Returns the number of children of parent.

getChildCount(Object) - Method in interface javax.swing.tree.TreeModel

Returns the number of children of parent.

getChildCount() - Method in interface javax.swing.tree.TreeNode

Returns the number of children TreeNodes the receiver contains.

getChildElements() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element.

getChildElements(Name) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified name.

getChildElements(QName) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified qname.

getChildIndex() - Method in class javax.swing.JTree.DropLocation

Returns the index where the dropped data should be inserted with respect to the path returned by getPath().

getChildIndices() - Method in class javax.swing.event.TreeModelEvent

Returns the values of the child indexes.

getChildNames(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings indicating the names of the element which are allowed to be children of the named element, in the order in which they should appear.

getChildNames(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getChildNodes() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns a NodeList that contains all children of this node.

getChildNodes() - Method in interface org.w3c.dom.Node

A NodeList that contains all children of this node.

getChildPolicy(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with CHILD_POLICY_, indicating the legal pattern of children for the named element.

getChildPolicy(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getChildPropertyChangeListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the PropertyChangeListener (if any) of the specified child

getChildren() - Method in interface java.security.cert.PolicyNode

Returns an iterator over the children of this node.

getChildren() - Method in class javax.swing.event.TreeModelEvent

Returns the objects that are children of the node identified by getPath at the locations specified by getChildIndices.

getChildrenAdded() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Gets the child elements that were added to the given parent element.

getChildrenAdded() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Gets a list of children that were added.

getChildrenRemoved() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Gets the child elements that were removed from the given parent element.

getChildrenRemoved() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Gets a list of children that were removed.

getChildSerializable(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the Serializable (if any) associated with the specified Child

getChildState(int) - Method in class javax.swing.text.AsyncBoxView

Fetch the object representing the layout state of of the child at the given index.

getChildVetoableChangeListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the VetoableChangeListener (if any) of the specified child

getChildView() - Method in class javax.swing.text.AsyncBoxView.ChildState

Fetch the child view this record represents

getChildVisibility(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the Component (if any) associated with the specified child.

getChoices() - Method in class javax.security.auth.callback.ChoiceCallback

Get the list of choices.

getChoosableFileFilters() - Method in class javax.swing.JFileChooser

Gets the list of user choosable file filters.

getChooserPanels() - Method in class javax.swing.JColorChooser

Returns the specified color panels.

getCipherSuite() - Method in class java.net.SecureCacheResponse

Returns the cipher suite in use on the original connection that retrieved the network resource.

getCipherSuite() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the cipher suite in use by the session which was produced by the handshake.

getCipherSuite() - Method in class javax.net.ssl.HttpsURLConnection

Returns the cipher suite in use on this connection.

getCipherSuite() - Method in interface javax.net.ssl.SSLSession

Returns the name of the SSL cipher suite which is used for all connections in the session.

getCipherSuites() - Method in class javax.net.ssl.SSLParameters

Returns a copy of the array of ciphersuites or null if none have been set.

getClass() - Method in class java.lang.Object

Returns the runtime class of this Object.

getClassAnnotation(Class<?>) - Static method in class java.rmi.server.RMIClassLoader

Returns the annotation string (representing a location for the class definition) that RMI will use to annotate the class descriptor when marshalling objects of the given class.

getClassAnnotation(Class<?>) - Method in class java.rmi.server.RMIClassLoaderSpi

Provides the implementation for RMIClassLoader.getClassAnnotation(Class).

getClassContext() - Method in class java.lang.SecurityManager

Returns the current execution stack as an array of classes.

getClasses() - Method in class java.lang.类

Returns an array containing 类 objects representing all the public classes and interfaces that are members of the class represented by this 类 object.

getClassLoader() - Method in class java.lang.类

Returns the class loader for the class.

getClassLoader(String) - Static method in class java.rmi.server.RMIClassLoader

Returns a class loader that loads classes from the given codebase URL path.

getClassLoader(String) - Method in class java.rmi.server.RMIClassLoaderSpi

Provides the implementation for RMIClassLoader.getClassLoader(String).

getClassLoader() - Method in class java.security.ProtectionDomain

Returns the ClassLoader of this domain.

getClassLoader(ObjectName) - Method in interface javax.management.MBeanServer

Return the named ClassLoader.

getClassLoader(JavaFileManager.Location) - Method in class javax.tools.ForwardingJavaFileManager

getClassLoader(JavaFileManager.Location) - Method in interface javax.tools.JavaFileManager

Gets a class loader for loading plug-ins from the given location.

getClassLoaderFor(ObjectName) - Method in interface javax.management.MBeanServer

Return the ClassLoader that was used for loading the class of the named MBean.

getClassLoaderRepository() - Method in interface javax.management.MBeanServer

Return the ClassLoaderRepository for this MBeanServer.

getClassLoaderRepository(MBeanServer) - Static method in class javax.management.MBeanServerFactory

Return the ClassLoaderRepository used by the given MBeanServer.

getClassLoaderRepository() - Method in class javax.management.modelmbean.RequiredModelMBean

Return the Class Loader Repository used to perform class loading.

getClassLoadingLock(String) - Method in class java.lang.ClassLoader

Returns the lock object for class loading operations.

getClassLoadingMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the class loading system of the Java virtual machine.

getClassName() - Method in class java.lang.management.LockInfo

Returns the fully qualified name of the class of the lock object.

getClassName() - Method in class java.lang.StackTraceElement

Returns the fully qualified name of the class containing the execution point represented by this stack trace element.

getClassName() - Method in class java.rmi.activation.ActivationDesc

Returns the class name for the object specified by this descriptor.

getClassName() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's class name (possibly null).

getClassName() - Method in class java.security.Provider.Service

Return the name of the class implementing this service.

getClassName() - Method in exception java.util.MissingResourceException

Gets parameter passed by constructor.

getClassName() - Method in class javax.management.MBeanInfo

Returns the name of the Java class of the MBean described by this MBeanInfo.

getClassName() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the name of the Java class of the MBean described by this MBeanInfo.

getClassName() - Method in class javax.management.ObjectInstance

Returns the class part.

getClassName() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.

getClassName() - Method in class javax.management.openmbean.OpenType

Returns the fully qualified Java class name of the open data values this open type describes.

getClassName(MBeanInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the className that will be used in the MBeanInfo returned by this MBean.

getClassName() - Method in class javax.naming.Binding

Retrieves the class name of the object bound to the name of this binding.

getClassName() - Method in class javax.naming.NameClassPair

Retrieves the class name of the object bound to the name of this binding.

getClassName() - Method in class javax.naming.Reference

Retrieves the class name of the object to which this reference refers.

getClassName() - Method in class javax.swing.UIManager.LookAndFeelInfo

Returns the name of the class that implements this look and feel.

getClassPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java class path that is used by the system class loader to search for class files.

getClickCount() - Method in class java.awt.event.MouseEvent

Returns the number of mouse clicks associated with this event.

getClickCountToStart() - Method in class javax.swing.DefaultCellEditor

Returns the number of clicks needed to start editing.

getClient() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the client principal associated with this ticket.

getClientAddresses() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns a list of addresses from where the ticket can be used.

getClientAliases(String, Principal[]) - Method in interface javax.net.ssl.X509KeyManager

Get the matching aliases for authenticating the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

getClientHost() - Static method in class java.rmi.server.RemoteServer

Returns a string representation of the client host for the remote method invocation being processed in the current thread.

getClientHost() - Method in interface java.rmi.server.ServerRef

Returns the hostname of the current client.

getClientInfo(String) - Method in interface java.sql.Connection

Returns the value of the client info property specified by name.

getClientInfo() - Method in interface java.sql.Connection

Returns a list containing the name and current value of each client info property supported by the driver.

getClientInfoProperties() - Method in interface java.sql.DatabaseMetaData

Retrieves a list of the client info properties that the driver supports.

getClientProperty(Object) - Method in class javax.swing.JComponent

Returns the value of the property with the specified key.

getClientSessionContext() - Method in class javax.net.ssl.SSLContext

Returns the client session context, which represents the set of SSL sessions available for use during the handshake phase of client-side SSL sockets.

getClientX() - Method in interface org.w3c.dom.events.MouseEvent

The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

getClientY() - Method in interface org.w3c.dom.events.MouseEvent

The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

getClip() - Method in class java.awt.Graphics

Gets the current clipping area.

getClip() - Static method in class javax.sound.sampled.AudioSystem

Obtains a clip that can be used for playing back an audio file or an audio stream.

getClip(Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.

getClip() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getClip.

getClipBounds() - Method in class java.awt.Graphics

Returns the bounding rectangle of the current clipping area.

getClipBounds(Rectangle) - Method in class java.awt.Graphics

Returns the bounding rectangle of the current clipping area.

getClipBounds() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getClipBounds.

getClipRect() - Method in class java.awt.Graphics

Deprecated.
As of JDK version 1.1, replaced by getClipBounds().

getClob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC CLOB parameter as a java.sql.Clob object in the Java programming language.

getClob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC CLOB parameter as a java.sql.Clob object in the Java programming language.

getClob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Clob object in the Java programming language.

getClob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Clob object in the Java programming language.

getClosedIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent non-leaf nodes that are not expanded.

getClosestPathForLocation(int, int) - Method in class javax.swing.JTree

Returns the path to the node that is closest to x,y.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path to the node that is closest to x,y.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getClosestPathForLocation method on each UI handled by this object.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.TreeUI

Returns the path to the node that is closest to x,y.

getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int) - Method in class javax.swing.text.ParagraphView

Returns the closest model position to x.

getClosestRowForLocation(int, int) - Method in class javax.swing.JTree

Returns the row to the node that is closest to x,y.

getCode() - Method in class javax.management.loading.MLetContent

Gets the value of the CODE attribute of the MLET tag.

getCode() - Method in interface javax.tools.Diagnostic

Gets a diagnostic code indicating the type of diagnostic.

getCodeBase() - Method in class java.applet.Applet

Gets the base URL.

getCodeBase() - Method in interface java.applet.AppletStub

Gets the base URL.

getCodeBase() - Method in class javax.management.loading.MLetContent

Gets the code base URL.

getCodebase(Class) - Static method in class javax.rmi.CORBA.Util

Returns the codebase, if any, for the given class.

getCodebase(Class) - Method in interface javax.rmi.CORBA.UtilDelegate

Delegation call for Util.getCodebase(java.lang.Class).

getCodePoint() - Method in exception java.util.IllegalFormatCodePointException

Returns the illegal code point as defined by Character.isValidCodePoint(int).

getCodeSigners() - Method in class java.security.CodeSource

Returns the code signers associated with this CodeSource.

getCodeSigners() - Method in class java.util.jar.JarEntry

Returns the CodeSigner objects for this entry, or null if none.

getCodeSource() - Method in class java.security.ProtectionDomain

Returns the CodeSource of this domain.

getCofactor() - Method in class java.security.spec.ECParameterSpec

Returns the cofactor.

getCollapsedIcon() - Method in class javax.swing.plaf.basic.BasicTreeUI

getCollationElementIterator(String) - Method in class java.text.RuleBasedCollator

Return a CollationElementIterator for the given String.

getCollationElementIterator(CharacterIterator) - Method in class java.text.RuleBasedCollator

Return a CollationElementIterator for the given String.

getCollationKey(String) - Method in class java.text.Collator

Transforms the String into a series of bits that can be compared bitwise to other CollationKeys.

getCollationKey(String) - Method in class java.text.RuleBasedCollator

Transforms the string into a series of characters that can be compared with CollationKey.compareTo.

getCollection() - Method in class java.security.cert.CollectionCertStoreParameters

Returns the Collection from which Certificates and CRLs are retrieved.

getCollectionCount() - Method in interface java.lang.management.GarbageCollectorMXBean

Returns the total number of collections that have occurred.

getCollectionTime() - Method in interface java.lang.management.GarbageCollectorMXBean

Returns the approximate accumulated collection elapsed time in milliseconds.

getCollectionUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the memory usage after the Java virtual machine most recently expended effort in recycling unused objects in this memory pool.

getCollectionUsageThreshold() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the collection usage threshold value of this memory pool in bytes.

getCollectionUsageThresholdCount() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the number of times that the Java virtual machine has detected that the memory usage has reached or exceeded the collection usage threshold.

getColor(String) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor(String, Color) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor(String, int) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor() - Method in class java.awt.Graphics

Gets this graphics context's current color.

getColor() - Method in class java.awt.PageAttributes

Returns whether pages using these attributes will be rendered in color or monochrome.

getColor() - Method in class javax.swing.DebugGraphics

Returns the Color used for text drawing operations.

getColor() - Method in class javax.swing.JColorChooser

Gets the current color value from the color chooser.

getColor(SynthContext, ColorType) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the color for the specified state.

getColor() - Method in class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter

Returns the color of the highlight.

getColor(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Color return it, otherwise return null.

getColor(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Color return it, otherwise return null.

getColor(Object) - Static method in class javax.swing.UIManager

Returns a color from the defaults.

getColor(Object, Locale) - Static method in class javax.swing.UIManager

Returns a color from the defaults that is appropriate for the given locale.

getColor1() - Method in class java.awt.GradientPaint

Returns the color C1 anchored by the point P1.

getColor2() - Method in class java.awt.GradientPaint

Returns the color C2 anchored by the point P2.

getColorComponents(float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color, in the ColorSpace of the Color.

getColorComponents(ColorSpace, float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color in the ColorSpace specified by the cspace parameter.

getColorForGap(int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.nimbus.NimbusStyle

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the color for the specified state.

getColorFromModel() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the color that is currently selected.

getColorModel() - Method in class java.awt.Component

Gets the instance of ColorModel used to display the component on the output device.

getColorModel() - Method in class java.awt.GraphicsConfiguration

Returns the ColorModel associated with this GraphicsConfiguration.

getColorModel(int) - Method in class java.awt.GraphicsConfiguration

Returns the ColorModel associated with this GraphicsConfiguration that supports the specified transparency.

getColorModel() - Method in class java.awt.image.BufferedImage

Returns the ColorModel.

getColorModel() - Method in class java.awt.image.PixelGrabber

Get the ColorModel for the pixels stored in the array.

getColorModel() - Method in interface java.awt.image.RenderedImage

Returns the ColorModel associated with this image.

getColorModel() - Method in interface java.awt.PaintContext

Returns the ColorModel of the output.

getColorModel() - Method in class java.awt.Toolkit

Determines the color model of this toolkit's screen.

getColorModel() - Method in class javax.imageio.ImageTypeSpecifier

Returns the ColorModel specified by this object.

getColors() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the array of colors used by this gradient.

getColorSelectionModel() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the model that the chooser panel is editing.

getColorSpace() - Method in class java.awt.Color

Returns the ColorSpace of this Color.

getColorSpace() - Method in class java.awt.image.ColorModel

Returns the ColorSpace associated with this ColorModel.

getColorSpace() - Method in class java.awt.MultipleGradientPaint

Returns the enumerated type which specifies color space for interpolation.

getColorSpaceType() - Method in class java.awt.color.ICC_Profile

Returns the color space type.

getColumn() - Method in class javax.swing.event.TableModelEvent

Returns the column for the event.

getColumn() - Method in class javax.swing.JTable.DropLocation

Returns the column index where a dropped item should be placed in the table.

getColumn(Object) - Method in class javax.swing.JTable

Returns the TableColumn object for the column in the table whose identifier is equal to identifier, when compared using equals.

getColumn() - Method in class javax.swing.RowSorter.SortKey

Returns the index of the column.

getColumn(int) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the TableColumn object for the column at columnIndex.

getColumn(int) - Method in interface javax.swing.table.TableColumnModel

Returns the TableColumn object for the column at columnIndex.

getColumnClass(int) - Method in class javax.swing.JTable

Returns the type of the column appearing in the view at column position column.

getColumnClass(int) - Method in class javax.swing.table.AbstractTableModel

Returns Object.class regardless of columnIndex.

getColumnClass(int) - Method in interface javax.swing.table.TableModel

Returns the most specific superclass for all the cell values in the column.

getColumnClassName(int) - Method in interface java.sql.ResultSetMetaData

Returns the fully-qualified name of the Java class whose instances are manufactured if the method ResultSet.getObject is called to retrieve a value from the column.

getColumnClassName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the fully-qualified name of the class in the Java programming language to which a value in the designated column will be mapped.

getColumnCount() - Method in interface java.sql.ResultSetMetaData

Returns the number of columns in this ResultSet object.

getColumnCount() - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.

getColumnCount() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the number of columns in the model.

getColumnCount() - Method in class javax.swing.JTable

Returns the number of columns in the column model.

getColumnCount() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the number of columns in the tableColumns array.

getColumnCount() - Method in class javax.swing.table.DefaultTableModel

Returns the number of columns in this data table.

getColumnCount() - Method in interface javax.swing.table.TableColumnModel

Returns the number of columns in the model.

getColumnCount() - Method in interface javax.swing.table.TableModel

Returns the number of columns in the model.

getColumnCount() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the number of columns this cell spans (e.g.

getColumnDisplaySize(int) - Method in interface java.sql.ResultSetMetaData

Indicates the designated column's normal maximum width in characters.

getColumnDisplaySize(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the normal maximum width in chars of the designated column.

getColumnHeader() - Method in class javax.swing.JScrollPane

Returns the column header.

getColumnHeader() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that is the column header.

getColumnIndex(Object) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the index of the first column in the tableColumns array whose identifier is equal to identifier, when compared using equals.

getColumnIndex(Object) - Method in interface javax.swing.table.TableColumnModel

Returns the index of the first column in the table whose identifier is equal to identifier, when compared using equals.

getColumnIndexAtX(int) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the index of the column that lies at position x, or -1 if no column covers this point.

getColumnIndexAtX(int) - Method in interface javax.swing.table.TableColumnModel

Returns the index of the column that lies on the horizontal point, xPosition; or -1 if it lies outside the any of the column's bounds.

getColumnLabel(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's suggested title for use in printouts and displays.

getColumnLabel(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the the suggested column title for the designated column for use in printouts and displays.

getColumnMargin() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the width margin for TableColumn.

getColumnMargin() - Method in interface javax.swing.table.TableColumnModel

Returns the width between the cells in each column.

getColumnModel() - Method in class javax.swing.JTable

Returns the TableColumnModel that contains all column information of this table.

getColumnModel() - Method in class javax.swing.table.JTableHeader

Returns the TableColumnModel that contains all column information of this table header.

getColumnModelListeners() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of all the column model listeners registered on this model.

getColumnName(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's name.

getColumnName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the name of the designated column.

getColumnName(int) - Method in class javax.swing.JTable

Returns the name of the column appearing in the view at column position column.

getColumnName(int) - Method in class javax.swing.table.AbstractTableModel

Returns a default name for the column using spreadsheet conventions: A, B, C, ...

getColumnName(int) - Method in class javax.swing.table.DefaultTableModel

Returns the column name.

getColumnName(int) - Method in interface javax.swing.table.TableModel

Returns the name of the column at columnIndex.

getColumnNumber() - Method in exception javax.script.ScriptException

Get the column number on which an error occurred.

getColumnNumber() - Method in interface javax.tools.Diagnostic

Gets the column number of the character offset returned by Diagnostic.getPosition().

getColumnNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getColumnNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the column number if available

getColumnNumber() - Method in interface javax.xml.stream.Location

Return the column number where the current event ends, returns -1 if none is available.

getColumnNumber() - Method in interface javax.xml.transform.SourceLocator

Return the character position where the current document event ends.

getColumnNumber() - Method in interface org.w3c.dom.DOMLocator

The column number this locator is pointing to, or -1 if there is no column number available.

getColumnNumber() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved column number (1-based).

getColumnNumber() - Method in interface org.xml.sax.Locator

Return the column number where the current document event ends.

getColumnNumber() - Method in exception org.xml.sax.SAXParseException

The column number of the end of the text where the exception occurred.

getColumnPrivileges(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the access rights for a table's columns.

getColumns() - Method in class java.awt.GridLayout

Gets the number of columns in this layout.

getColumns() - Method in class java.awt.TextArea

Returns the number of columns in this text area.

getColumns() - Method in class java.awt.TextField

Gets the number of columns in this text field.

getColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of table columns available in the specified catalog.

getColumns() - Method in class javax.swing.JTextArea

Returns the number of columns in the TextArea.

getColumns() - Method in class javax.swing.JTextField

Returns the number of columns in this TextField.

getColumns() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an Enumeration of all the columns in the model.

getColumns() - Method in interface javax.swing.table.TableColumnModel

Returns an Enumeration of all the columns in the model.

getColumnSelectionAllowed() - Method in class javax.swing.JTable

Returns true if columns can be selected.

getColumnSelectionAllowed() - Method in class javax.swing.table.DefaultTableColumnModel

Returns true if column selection is allowed, otherwise false.

getColumnSelectionAllowed() - Method in interface javax.swing.table.TableColumnModel

Returns true if columns may be selected.

getColumnType(int) - Method in interface java.sql.ResultSetMetaData

Retrieves the designated column's SQL type.

getColumnType(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the type code (one of the java.sql.Types constants) for the SQL type of the value stored in the designated column.

getColumnTypeName(int) - Method in interface java.sql.ResultSetMetaData

Retrieves the designated column's database-specific type name.

getColumnTypeName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the DBMS-specific type name for values stored in the designated column.

getColumnWidth() - Method in class javax.swing.JTextArea

Gets column width.

getColumnWidth() - Method in class javax.swing.JTextField

Returns the column width.

getComboBox() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getComboIcon() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getCommand(String, String) - Method in class javax.activation.CommandMap

Get the default command corresponding to the MIME type.

getCommand(String, String, DataSource) - Method in class javax.activation.CommandMap

Get the default command corresponding to the MIME type.

getCommand(String) - Method in class javax.activation.DataHandler

Get the command cmdName.

getCommand(String, String) - Method in class javax.activation.MailcapCommandMap

Get the command corresponding to cmdName for the MIME type.

getCommand() - Method in class javax.sound.midi.ShortMessage

Obtains the MIDI command associated with this event.

getCommand() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the SQL query that is the command for this RowSet object.

getCommand() - Method in interface javax.sql.RowSet

Retrieves this RowSet object's command property.

getCommandClass() - Method in class javax.activation.CommandInfo

Return the command's class name.

getCommandEnvironment() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's command-environment control object.

getCommandName() - Method in class javax.activation.CommandInfo

Return the command verb.

getCommandObject(DataHandler, ClassLoader) - Method in class javax.activation.CommandInfo

Return the instantiated JavaBean component.

getCommandOptions() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment

Fetch the configured java command options.

getCommandPath() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment

Fetch the configured path-qualified java command name.

getComment() - Method in class java.net.HttpCookie

Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.

getComment() - Method in class java.util.zip.ZipEntry

Returns the comment string for the entry, or null if none.

getComment() - Method in class java.util.zip.ZipFile

Returns the zip file comment, or null if none.

getCommentURL() - Method in class java.net.HttpCookie

Returns the comment url describing the purpose of this cookie, or null if the cookie has no comment url.

getCommitsOnValidEdit() - Method in class javax.swing.text.DefaultFormatter

Returns when edits are published back to the JFormattedTextField.

getCommitted() - Method in class java.lang.management.MemoryUsage

Returns the amount of memory in bytes that is committed for the Java virtual machine to use.

getCommittedCharacterCount() - Method in class java.awt.event.InputMethodEvent

Gets the number of committed characters in the text.

getCommittedText(int, int, AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests

Gets an iterator providing access to the entire text and attributes contained in the text editing component except for uncommitted text.

getCommittedTextLength() - Method in interface java.awt.im.InputMethodRequests

Gets the length of the entire text contained in the text editing component except for uncommitted (composed) text.

getComparator(int) - Method in class javax.swing.DefaultRowSorter

Returns the Comparator for the specified column.

getComparator() - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Comparator which will be used to sort the Components in a focus traversal cycle.

getComparator(int) - Method in class javax.swing.table.TableRowSorter

Returns the Comparator for the specified column.

getCompilationMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the compilation system of the Java virtual machine.

getCompletedTaskCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate total number of tasks that have completed execution.

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in class javax.annotation.processing.AbstractProcessor

Returns an empty iterable of completions.

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in interface javax.annotation.processing.Processor

Returns to the tool infrastructure an iterable of suggested completions to an annotation.

getComponent(int) - Method in class java.awt.Container

Gets the nth component in this container.

getComponent() - Method in class java.awt.dnd.DragGestureEvent

Returns the Component associated with this DragGestureEvent.

getComponent() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the Component that is to be "observed" by the DragGestureRecognizer for drag initiating gestures.

getComponent() - Method in class java.awt.dnd.DragSourceContext

Returns the Component associated with this DragSourceContext.

getComponent() - Method in class java.awt.dnd.DropTarget

Gets the Component associated with this DropTarget.

getComponent() - Method in class java.awt.dnd.DropTargetContext

This method returns the Component associated with this DropTargetContext.

getComponent() - Method in class java.awt.event.ComponentEvent

Returns the originator of the event.

getComponent() - Method in class java.awt.event.HierarchyEvent

Returns the originator of the event.

getComponent() - Method in interface java.beans.beancontext.BeanContextChildComponentProxy

Gets the java.awt.Component associated with this BeanContextChild.

getComponent() - Method in class javax.swing.ComponentInputMap

Returns the component the InputMap was created for.

getComponent() - Method in class javax.swing.DefaultCellEditor

Returns a reference to the editor component.

getComponent() - Method in class javax.swing.event.AncestorEvent

Returns the component that the listener was added to.

getComponent() - Method in class javax.swing.JMenu

Returns the java.awt.Component used to paint this MenuElement.

getComponent() - Method in class javax.swing.JMenuBar

Implemented to be a MenuElement.

getComponent() - Method in class javax.swing.JMenuItem

Returns the java.awt.Component used to paint this object.

getComponent() - Method in class javax.swing.JPopupMenu

Returns this JPopupMenu component.

getComponent() - Method in class javax.swing.JToolTip

Returns the component the tooltip applies to.

getComponent() - Method in interface javax.swing.MenuElement

This method should return the java.awt.Component used to paint the receiving element.

getComponent() - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the text component associated with this UI implementation.

getComponent() - Method in class javax.swing.plaf.synth.SynthContext

Returns the hosting component containing the region.

getComponent() - Method in interface javax.swing.Renderer

Returns the component used to render the value.

getComponent() - Method in class javax.swing.text.ComponentView

Fetch the component associated with the view.

getComponent() - Method in class javax.swing.text.DefaultCaret

Gets the text editor component that this caret is is bound to.

getComponent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the component setting from the attribute list.

getComponent() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the target component of this transfer.

getComponentAfter(Container, Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class javax.swing.DefaultFocusManager

getComponentAfter(Container, Component) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAt(int, int) - Method in class java.awt.Component

Determines if this component or one of its immediate subcomponents contains the (x, y) location, and if so, returns the containing component.

getComponentAt(Point) - Method in class java.awt.Component

Returns the component or subcomponent that contains the specified point.

getComponentAt(int, int) - Method in class java.awt.Container

Locates the component that contains the x,y position.

getComponentAt(Point) - Method in class java.awt.Container

Gets the component that contains the specified point.

getComponentAt(int) - Method in class javax.swing.JTabbedPane

Returns the component at index.

getComponentAtIndex(int) - Method in class javax.swing.JMenuBar

Deprecated.
replaced by getComponent(int i)

getComponentAtIndex(int) - Method in class javax.swing.JPopupMenu

Deprecated.
replaced by Container.getComponent(int)

getComponentAtIndex(int) - Method in class javax.swing.JToolBar

Returns the component at the specified index.

getComponentBefore(Container, Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class javax.swing.DefaultFocusManager

getComponentBefore(Container, Component) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentColor(JComponent, String, Color, float, float, int) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Get a color property from the given JComponent.

getComponentCount() - Method in class java.awt.Container

Gets the number of components in this panel.

getComponentCountInLayer(int) - Method in class javax.swing.JLayeredPane

Returns the number of children currently in the specified layer.

getComponentGraphics(Graphics) - Method in class javax.swing.JComponent

Returns the graphics object used to paint this component.

getComponentIndex(Component) - Method in class javax.swing.JMenuBar

Returns the index of the specified component.

getComponentIndex(Component) - Method in class javax.swing.JPopupMenu

Returns the index of the specified component.

getComponentIndex(Component) - Method in class javax.swing.JToolBar

Returns the index of the specified component.

getComponentListeners() - Method in class java.awt.Component

Returns an array of all the component listeners registered on this component.

getComponentOrientation() - Method in class java.awt.Component

Retrieves the language-sensitive orientation that is to be used to order the elements or text within this component.

getComponentPopupMenu() - Method in class javax.swing.JComponent

Returns JPopupMenu that assigned for this component.

getComponents(float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, in the ColorSpace of the Color.

getComponents(ColorSpace, float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, in the ColorSpace specified by the cspace parameter.

getComponents() - Method in class java.awt.Container

Gets all the components in this container.

getComponents(int, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.DirectColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.DirectColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.IndexColorModel

Returns an array of unnormalized color/alpha components for a specified pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.IndexColorModel

Returns an array of unnormalized color/alpha components for a specified pixel in this ColorModel.

getComponentsInLayer(int) - Method in class javax.swing.JLayeredPane

Returns an array of the components in the specified layer.

getComponentSize(int) - Method in class java.awt.image.ColorModel

Returns the number of bits for the specified color/alpha component.

getComponentSize() - Method in class java.awt.image.ColorModel

Returns an array of the number of bits per color/alpha component.

getComponentSize() - Method in class java.awt.image.IndexColorModel

Returns an array of the number of bits for each color/alpha component.

getComponentState() - Method in class javax.swing.plaf.synth.SynthContext

Returns the state of the widget, which is a bitmask of the values defined in SynthConstants.

getComponentToLayer() - Method in class javax.swing.JLayeredPane

Returns the hashtable that maps components to layers.

getComponentType() - Method in class java.lang.类

Returns the 类 representing the component type of an array.

getComponentType() - Method in interface javax.lang.model.type.ArrayType

Returns the component type of this array type.

getComponentZOrder(Component) - Method in class java.awt.Container

Returns the z-order index of the component inside the container.

getComposite() - Method in class java.awt.Graphics2D

Returns the current Composite in the Graphics2D context.

getCompositeData() - Method in class javax.management.openmbean.CompositeDataInvocationHandler

Return the CompositeData that was supplied to the constructor.

getCompositeType() - Method in interface javax.management.openmbean.CompositeData

Returns the composite type of this composite data instance.

getCompositeType() - Method in class javax.management.openmbean.CompositeDataSupport

Returns the composite type of this composite data instance.

getCompressedSize() - Method in class java.util.zip.ZipEntry

Returns the size of the compressed entry data, or -1 if not known.

getCompressionMode() - Method in class javax.imageio.ImageWriteParam

Returns the current compression mode, if compression is supported.

getCompressionQuality() - Method in class javax.imageio.ImageWriteParam

Returns the current compression quality setting.

getCompressionQualityDescriptions() - Method in class javax.imageio.ImageWriteParam

Returns an array of Strings that may be used along with getCompressionQualityValues as part of a user interface for setting or displaying the compression quality level.

getCompressionQualityDescriptions() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

getCompressionQualityValues() - Method in class javax.imageio.ImageWriteParam

Returns an array of floats that may be used along with getCompressionQualityDescriptions as part of a user interface for setting or displaying the compression quality level.

getCompressionQualityValues() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

getCompressionThreshold() - Method in class javax.swing.text.StyleContext

Returns the maximum number of key/value pairs to try and compress into unique/immutable sets.

getCompressionType() - Method in class javax.imageio.ImageWriteParam

Returns the currently set compression type, or null if none has been set.

getCompressionTypes() - Method in class javax.imageio.ImageWriteParam

Returns a list of available compression types, as an array or Strings, or null if a compression type may not be chosen using these interfaces.

getConcurrency() - Method in interface java.sql.ResultSet

Retrieves the concurrency mode of this ResultSet object.

getConcurrency() - Method in class javax.sql.rowset.BaseRowSet

Returns the concurrency for this RowSet object.

getConditionForKeyStroke(KeyStroke) - Method in class javax.swing.JComponent

Returns the condition that determines whether a registered action occurs in response to the specified keystroke.

getConfiguration() - Static method in class javax.security.auth.login.Configuration

Get the installed login Configuration.

getConfigurations() - Method in class java.awt.GraphicsDevice

Returns all of the GraphicsConfiguration objects associated with this GraphicsDevice.

getConflictValue(int) - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.

getConflictValue(String) - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.

getConfState() - Method in interface org.ietf.jgss.GSSContext

Determines if data confidentiality is available over the context.

getConnectControls() - Method in class javax.naming.ldap.InitialLdapContext

getConnectControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the connection request controls in effect for this context.

getConnection() - Method in interface java.sql.DatabaseMetaData

Retrieves the connection that produced this metadata object.

getConnection(String, Properties) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection(String, String, String) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection(String) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection() - Method in interface java.sql.Statement

Retrieves the Connection object that produced this Statement object.

getConnection() - Method in interface javax.sql.DataSource

Attempts to establish a connection with the data source that this DataSource object represents.

getConnection(String, String) - Method in interface javax.sql.DataSource

Attempts to establish a connection with the data source that this DataSource object represents.

getConnection() - Method in interface javax.sql.PooledConnection

Creates and returns a Connection object that is a handle for the physical connection that this PooledConnection object represents.

getConnection() - Method in interface javax.sql.RowSetInternal

Retrieves the Connection object that was passed to this RowSet object.

getConnectionId() - Method in class javax.management.remote.JMXConnectionNotification

The connection ID to which this notification pertains.

getConnectionId() - Method in interface javax.management.remote.JMXConnector

Gets this connection's ID from the connector server.

getConnectionId() - Method in interface javax.management.remote.rmi.RMIConnection

Returns the connection ID.

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnectionImpl

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnector

getConnectionIds() - Method in class javax.management.remote.JMXConnectorServer

getConnectionIds() - Method in interface javax.management.remote.JMXConnectorServerMBean

The list of IDs for currently-open connections to this connector server.

getConnectTimeout() - Method in class java.net.URLConnection

Returns setting for connect timeout.

getConstantExpression(Object) - Method in interface javax.lang.model.util.Elements

Returns the text of a constant expression representing a primitive value or a string.

getConstantValue() - Method in interface javax.lang.model.element.VariableElement

Returns the value of this variable if this is a final field initialized to a compile-time constant.

getConstraint(String) - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the specified edge, which may be a derived value, or even null.

getConstraint(String, Component) - Method in class javax.swing.SpringLayout

Returns the spring controlling the distance between the specified edge of the component and the top or left edge of its parent.

getConstraints(Component) - Method in class java.awt.BorderLayout

Gets the constraints for the specified component

getConstraints(Component) - Method in class java.awt.GridBagLayout

Gets the constraints for the specified component.

getConstraints(Component) - Method in class javax.swing.SpringLayout

Returns the constraints for the specified component.

getConstructor(Class<?>...) - Method in class java.lang.类

Returns a Constructor object that reflects the specified public constructor of the class represented by this 类 object.

getConstructor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

Returns the ModelMBeanConstructorInfo requested by name.

getConstructors() - Method in class java.lang.类

Returns an array containing Constructor objects reflecting all the public constructors of the class represented by this 类 object.

getConstructors() - Method in class javax.management.MBeanInfo

Returns the list of the public constructors of the MBean.

getConstructors() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of the public constructors of the MBean.

getConstructors() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance.

getConstructors(MBeanConstructorInfo[], Object) - Method in class javax.management.StandardMBean

Customization hook: Get the MBeanConstructorInfo[] that will be used in the MBeanInfo returned by this MBean.

getContainer() - Method in class java.awt.event.ContainerEvent

Returns the originator of the event.

getContainer() - Method in interface java.beans.beancontext.BeanContextContainerProxy

Gets the java.awt.Container associated with this BeanContext.

getContainer() - Method in class javax.swing.text.View

Fetches the container hosting the view.

getContainerGap(JComponent, int, Container) - Method in class javax.swing.LayoutStyle

Returns the amount of space to place between the component and specified edge of its parent.

getContainerListeners() - Method in class java.awt.Container

Returns an array of all the container listeners registered on this container.

getContent(URLConnection) - Method in class java.net.ContentHandler

Given a URL connect stream positioned at the beginning of the representation of an object, this method reads that stream and creates an object from it.

getContent(URLConnection, Class[]) - Method in class java.net.ContentHandler

Given a URL connect stream positioned at the beginning of the representation of an object, this method reads that stream and creates an object that matches one of the types specified.

getContent() - Method in class java.net.URL

Gets the contents of this URL.

getContent(Class[]) - Method in class java.net.URL

Gets the contents of this URL.

getContent() - Method in class java.net.URLConnection

Retrieves the contents of this URL connection.

getContent(Class[]) - Method in class java.net.URLConnection

Retrieves the contents of this URL connection.

getContent(DataSource) - Method in interface javax.activation.DataContentHandler

Return an object representing the data in its most preferred form.

getContent() - Method in class javax.activation.DataHandler

Return the data in its preferred Object form.

getContent() - Method in class javax.naming.BinaryRefAddr

Retrieves the contents of this address as an Object.

getContent() - Method in class javax.naming.RefAddr

Retrieves the contents of this address.

getContent() - Method in class javax.naming.StringRefAddr

Retrieves the contents of this address.

getContent() - Method in class javax.swing.text.AbstractDocument

Gets the content for the document.

getContent() - Method in class javax.swing.text.html.parser.Element

Get content model

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyInfo

Returns an unmodifiable list containing the key information.

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo.X509Data

Returns an unmodifiable list of the content in this X509Data.

getContent() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty.

getContent() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.

getContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a Java object.

getContent() - Method in class javax.xml.soap.SOAPPart

Returns the content of the SOAPEnvelope as a JAXP Source object.

getContentBorderInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getContentDescription() - Method in class javax.xml.soap.SOAPMessage

Retrieves a description of this SOAPMessage object's content.

getContentEncoding() - Method in class java.net.URLConnection

Returns the value of the content-encoding header field.

getContentHandler() - Method in class javax.xml.validation.ValidatorHandler

Gets the ContentHandler which receives the augmented validation result.

getContentHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current content handler.

getContentHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the content event handler.

getContentHandler() - Method in interface org.xml.sax.XMLReader

Return the current content handler.

getContentId() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-ID".

getContentId() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Id".

getContentLength() - Method in class java.net.URLConnection

Returns the value of the content-length header field.

getContentLengthLong() - Method in class java.net.URLConnection

Returns the value of the content-length header field as a long.

getContentLocation() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Location".

getContentLocation() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Location".

getContentPane() - Method in class javax.swing.JApplet

Returns the contentPane object for this applet.

getContentPane() - Method in class javax.swing.JDialog

Returns the contentPane object for this dialog.

getContentPane() - Method in class javax.swing.JFrame

Returns the contentPane object for this frame.

getContentPane() - Method in class javax.swing.JInternalFrame

Returns the content pane for this internal frame.

getContentPane() - Method in class javax.swing.JRootPane

Returns the content pane -- the container that holds the components parented by the root pane.

getContentPane() - Method in class javax.swing.JWindow

Returns the Container which is the contentPane for this window.

getContentPane() - Method in interface javax.swing.RootPaneContainer

Returns the contentPane.

getContents(Object) - Method in class java.awt.datatransfer.Clipboard

Returns a transferable object representing the current contents of the clipboard.

getContents() - Method in class java.util.ListResourceBundle

Returns an array in which each item is a pair of objects in an Object array.

getContents() - Method in class javax.accessibility.AccessibleResourceBundle

Deprecated.

Returns the mapping between the programmatic keys and the localized display strings.

getContentType() - Method in class java.net.URLConnection

Returns the value of the content-type header field.

getContentType() - Method in class javax.activation.DataHandler

Return the MIME type of this object as retrieved from the source object.

getContentType() - Method in interface javax.activation.DataSource

This method returns the MIME type of the data in the form of a string.

getContentType() - Method in class javax.activation.FileDataSource

This method returns the MIME type of the data in the form of a string.

getContentType(File) - Method in class javax.activation.FileTypeMap

Return the type of the file object.

getContentType(String) - Method in class javax.activation.FileTypeMap

Return the type of the file passed in.

getContentType(File) - Method in class javax.activation.MimetypesFileTypeMap

Return the MIME type of the file object.

getContentType(String) - Method in class javax.activation.MimetypesFileTypeMap

Return the MIME type based on the specified file name.

getContentType() - Method in class javax.activation.URLDataSource

Returns the value of the URL content-type header field.

getContentType() - Method in class javax.swing.JEditorPane

Gets the type of content that this editor is currently set to deal with.

getContentType() - Method in class javax.swing.text.DefaultEditorKit

Gets the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.EditorKit

Gets the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.html.HTMLEditorKit

Get the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.rtf.RTFEditorKit

Get the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Type".

getContentTypeFor(String) - Method in interface java.net.FileNameMap

Gets the MIME type for the specified file name.

getContext() - Static method in class java.security.AccessController

This method takes a "snapshot" of the current calling context, which includes the current Thread's inherited AccessControlContext, and places it in an AccessControlContext object.

getContext() - Method in class javax.script.AbstractScriptEngine

Returns the value of the protected context field.

getContext() - Method in interface javax.script.ScriptEngine

Returns the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthColorChooserUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthListUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuBarUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthRootPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTableUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTextAreaUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTextFieldUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthToolBarUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTreeUI

getContext(JComponent) - Method in interface javax.swing.plaf.synth.SynthUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI

getContext() - Method in interface javax.xml.ws.Response

Gets the contained response context.

getContextClassLoader() - Method in class java.lang.Thread

Returns the context ClassLoader for this Thread.

getContextPath() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the context path of all the endpoints in an application.

getContextualShaper(int) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided unicode range(s).

getContextualShaper(Set<NumericShaper.Range>) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided Unicode range(s).

getContextualShaper(int, int) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided unicode range(s).

getContextualShaper(Set<NumericShaper.Range>, NumericShaper.Range) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided Unicode range(s).

getContinuationContext(CannotProceedException) - Static method in class javax.naming.spi.NamingManager

Creates a context in which to continue a context operation.

getContinuationDirContext(CannotProceedException) - Static method in class javax.naming.spi.DirectoryManager

Creates a context in which to continue a DirContext operation.

getContinueExistingPeriodicTasksAfterShutdownPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether to continue executing existing periodic tasks even when this executor has been shutdown.

getControl(List<String>) - Static method in class java.util.ResourceBundle.Control

Returns a ResourceBundle.Control in which the getFormats method returns the specified formats.

getControl(Control.Type) - Method in interface javax.sound.sampled.Line

Obtains a control of the specified type, if there is any.

getControl() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control color of the current theme.

getControl() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control color.

getControlButtonsAreShown() - Method in class javax.swing.JFileChooser

Returns the value of the controlButtonsAreShown property.

getControlDarkShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control dark shadow color of the current theme.

getControlDarkShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control dark shadow color.

getControlDisabled() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control disabled color of the current theme.

getControlDisabled() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control disabled color.

getControlFlag() - Method in class javax.security.auth.login.AppConfigurationEntry

Return the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.

getControlHighlight() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control highlight color of the current theme.

getControlHighlight() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control highlight color.

getControlInfo() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control info color of the current theme.

getControlInfo() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control info color.

getControlInstance(Control) - Method in class javax.naming.ldap.ControlFactory

Creates a control using this control factory.

getControlInstance(Control, Context, Hashtable<?, ?>) - Static method in class javax.naming.ldap.ControlFactory

Creates a control using known control factories.

getController() - Method in class javax.imageio.IIOParam

Returns whatever IIOParamController is currently installed.

getController() - Method in class javax.imageio.metadata.IIOMetadata

Returns whatever IIOMetadataController is currently installed.

getController(int) - Method in interface javax.sound.midi.MidiChannel

Obtains the current value of the specified controller.

getControlObject() - Method in interface java.awt.im.spi.InputMethod

Returns a control object from this input method, or null.

getControls() - Method in interface javax.naming.ldap.HasControls

Retrieves an array of Controls from the object that implements this interface.

getControls() - Method in interface javax.sound.sampled.Line

Obtains the set of controls associated with this line.

getControlShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control shadow color of the current theme.

getControlShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control shadow color.

getControlSize() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getControlTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control text color of the current theme.

getControlTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control text color.

getControlTextColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the control text color.

getControlTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the control text font.

getControlTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control text font of the current theme.

getControlTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control text font.

getConversion() - Method in exception java.util.FormatFlagsConversionMismatchException

Returns the incompatible conversion.

getConversion() - Method in exception java.util.IllegalFormatConversionException

Returns the inapplicable conversion.

getConversion() - Method in exception java.util.UnknownFormatConversionException

Returns the unknown conversion.

getCookie() - Method in class javax.naming.ldap.PagedResultsResponseControl

Retrieves the server-generated cookie.

getCookies() - Method in interface java.net.CookieStore

Get all not-expired cookies in cookie store.

getCookieStore() - Method in class java.net.CookieManager

To retrieve current cookie store.

getCopies() - Method in class java.awt.JobAttributes

Returns the number of copies the application should render for jobs using these attributes.

getCopies() - Method in class java.awt.print.PrinterJob

Gets the number of copies to be printed.

getCopyAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs copy operations to the clipboard.

getCorePoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the core number of threads.

getCorner(String) - Method in class javax.swing.JScrollPane

Returns the component at the specified corner.

getCorner(String) - Method in class javax.swing.ScrollPaneLayout

Returns the Component at the specified corner.

getCount() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the number of buffers in the pool.

getCount() - Method in class java.lang.management.MemoryNotificationInfo

Returns the number of times that the memory usage has crossed a threshold when the notification was constructed.

getCount() - Method in class java.util.concurrent.CountDownLatch

Returns the current count.

getCountLimit() - Method in class javax.naming.directory.SearchControls

Retrieves the maximum number of entries that will be returned as a result of the search.

getCountry() - Method in class java.util.Locale

Returns the country/region code for this locale, which should either be the empty string, an uppercase ISO 3166 2-letter code, or a UN M.49 3-digit code.

getCrc() - Method in class java.util.zip.ZipEntry

Returns the CRC-32 checksum of the uncompressed entry data, or -1 if not known.

getCreationDate(String) - Method in class java.security.KeyStore

Returns the creation date of the entry identified by the given alias.

getCreationTime() - Method in interface javax.net.ssl.SSLSession

Returns the time at which this Session representation was created, in milliseconds since midnight, January 1, 1970 UTC.

getCredDelegState() - Method in interface org.ietf.jgss.GSSContext

Determines if credential delegation is enabled on this context.

getCredentialClass() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the Class name of the Credential associated with this PrivateCredentialPermission.

getCriticalExtensionOIDs() - Method in interface java.security.cert.X509Extension

Gets a Set of the OID strings for the extension(s) marked CRITICAL in the certificate/CRL managed by the object implementing this interface.

getCRLs(CRLSelector) - Method in class java.security.cert.CertStore

Returns a Collection of CRLs that match the specified selector.

getCrossFeedResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's cross feed direction resolution in the given units.

getCrossFeedResolutionDphi() - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's cross feed direction resolution in units of dphi.

getCrossPlatformLookAndFeelClassName() - Static method in class javax.swing.UIManager

Returns the name of the LookAndFeel class that implements the default cross platform look and feel -- the Java Look and Feel (JLF).

getCrossReference(String, String, String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the foreign key columns in the given foreign key table that reference the primary key or the columns representing a unique constraint of the parent table (could be the same or a different table).

getCrtCoefficient() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the crtCoefficient.

getCrtCoefficient() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime's crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the crtCoefficient.

getCtrlKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the first control point.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the first control point.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D

Returns the first control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the second control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the second control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D

Returns the second control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D

Returns the control point.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the control point in double precision.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the control point in double precision.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the first control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the first control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the first control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the second control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the second control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the second control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the first control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the first control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the first control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the second control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the second control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the second control point in double precision.

getCurrency() - Method in class java.text.DecimalFormat

Gets the currency used by this decimal format when formatting currency values.

getCurrency() - Method in class java.text.DecimalFormatSymbols

Gets the currency of these DecimalFormatSymbols.

getCurrency() - Method in class java.text.NumberFormat

Gets the currency used by this number format when formatting currency values.

getCurrencyCode() - Method in class java.util.Currency

Gets the ISO 4217 currency code of this currency.

getCurrencyInstance() - Static method in class java.text.NumberFormat

Returns a currency format for the current default locale.

getCurrencyInstance(Locale) - Static method in class java.text.NumberFormat

Returns a currency format for the specified locale.

getCurrencyInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats monetary values for the specified locale.

getCurrencySymbol() - Method in class java.text.DecimalFormatSymbols

Returns the currency symbol for the currency of these DecimalFormatSymbols in their locale.

getCurrent() - Method in class java.awt.CheckboxGroup

Deprecated.
As of JDK version 1.1, replaced by getSelectedCheckbox().

getCurrentAccessibleContext() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleContext for the table cell renderer.

getCurrentAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the accessible value of this object.

getCurrentComponent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the table cell renderer component.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetContext

get the available DataFlavors of the Transferable operand of this operation.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the current DataFlavors from the DropTargetContext.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the current DataFlavors.

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetContext

This method returns a the currently available DataFlavors of the Transferable operand as a java.util.List.

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the current DataFlavors as a java.util.List

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the currently available DataFlavors as a java.util.List.

getCurrentDirectory() - Method in class javax.swing.JFileChooser

Returns the current directory.

getCurrentEvent() - Static method in class java.awt.EventQueue

Returns the the event currently being dispatched by the EventQueue associated with the calling thread.

getCurrentFocusCycleRoot() - Method in class java.awt.KeyboardFocusManager

Returns the current focus cycle root, if the current focus cycle root is in the same context as the calling thread.

getCurrentKeyboardFocusManager() - Static method in class java.awt.KeyboardFocusManager

Returns the current KeyboardFocusManager instance for the calling thread's context.

getCurrentLine() - Method in class javax.swing.text.html.parser.Parser

getCurrentLineLength() - Method in class javax.swing.text.AbstractWriter

Returns the current line length.

getCurrentManager() - Static method in class javax.swing.FocusManager

Returns the current KeyboardFocusManager instance for the calling thread's context.

getCurrentPoint() - Method in class java.awt.geom.Path2D

Returns the coordinates most recently added to the end of the path as a Point2D object.

getCurrentPos() - Method in class javax.swing.text.html.parser.Parser

getCurrentServiceClasses() - Method in interface java.beans.beancontext.BeanContextServices

Gets the currently available services for this context.

getCurrentServiceClasses() - Method in class java.beans.beancontext.BeanContextServicesSupport

getCurrentServiceSelectors() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the list of service dependent selectors.

getCurrentServiceSelectors(BeanContextServices, Class) - Method in interface java.beans.beancontext.BeanContextServiceProvider

Invoked by BeanContextServices, this method gets the current service selectors for the specified service.

getCurrentServiceSelectors(Class) - Method in interface java.beans.beancontext.BeanContextServices

Gets the list of service dependent service parameters (Service Selectors) for the specified service, by calling getCurrentServiceSelectors() on the underlying BeanContextServiceProvider.

getCurrentServiceSelectors(BeanContextServices, Class) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

getCurrentServiceSelectors(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport

getCurrentTarget() - Method in interface org.w3c.dom.events.Event

Used to indicate the EventTarget whose EventListeners are currently being processed.

getCurrentTheme() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Return the theme currently being used by MetalLookAndFeel.

getCurrentThreadCpuTime() - Method in interface java.lang.management.ThreadMXBean

Returns the total CPU time for the current thread in nanoseconds.

getCurrentThreadUserTime() - Method in interface java.lang.management.ThreadMXBean

Returns the CPU time that the current thread has executed in user mode in nanoseconds.

getCurrentWriter() - Method in class javax.swing.text.AbstractDocument

Fetches the current writing thread if there is one.

getCursor() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Cursor of this object.

getCursor() - Method in class java.awt.Component

Gets the cursor set in the component.

getCursor() - Method in class java.awt.dnd.DragSourceContext

Returns the current drag Cursor.

getCursor() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the Cursor of this object.

getCursor() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Cursor of this object.

getCursor() - Method in interface javax.accessibility.AccessibleComponent

Gets the Cursor of this object.

getCursor() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getCursor() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Cursor of this object.

getCursor() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getCursor() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getCursorName() - Method in interface java.sql.ResultSet

Retrieves the name of the SQL cursor used by this ResultSet object.

getCursorType() - Method in class java.awt.Frame

Deprecated.
As of JDK version 1.1, replaced by Component.getCursor().

getCurve() - Method in class java.security.spec.ECParameterSpec

Returns the elliptic curve that this parameter defines.

getCustomEditor() - Method in interface java.beans.PropertyEditor

A PropertyEditor may choose to make available a full custom Component that edits its property value.

getCustomEditor() - Method in class java.beans.PropertyEditorSupport

A PropertyEditor may chose to make available a full custom Component that edits its property value.

getCustomizerClass() - Method in class java.beans.BeanDescriptor

Gets the Class object for the bean's customizer.

getCutAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs cut operations to the clipboard.

getCycleMethod() - Method in class java.awt.MultipleGradientPaint

Returns the enumerated type which specifies cycling behavior.

getDaemonThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the current number of live daemon threads.

getDashArray() - Method in class java.awt.BasicStroke

Returns the array representing the lengths of the dash segments.

getDashPhase() - Method in class java.awt.BasicStroke

Returns the current dash phase.

getData() - Method in class java.awt.color.ICC_Profile

Returns a byte array corresponding to the data of this ICC_Profile.

getData(int) - Method in class java.awt.color.ICC_Profile

Returns a particular tagged data element from the profile as a byte array.

getData(DataFlavor) - Method in class java.awt.datatransfer.Clipboard

Returns an object representing the current contents of this clipboard in the specified DataFlavor.

getData() - Method in class java.awt.image.BufferedImage

Returns the image as one large tile.

getData(Rectangle) - Method in class java.awt.image.BufferedImage

Computes and returns an arbitrary region of the BufferedImage.

getData() - Method in class java.awt.image.DataBufferByte

Returns the default (first) byte data array.

getData(int) - Method in class java.awt.image.DataBufferByte

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferDouble

Returns the default (first) double data array.

getData(int) - Method in class java.awt.image.DataBufferDouble

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferFloat

Returns the default (first) float data array.

getData(int) - Method in class java.awt.image.DataBufferFloat

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferInt

Returns the default (first) int data array in DataBuffer.

getData(int) - Method in class java.awt.image.DataBufferInt

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferShort

Returns the default (first) byte data array.

getData(int) - Method in class java.awt.image.DataBufferShort

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferUShort

Returns the default (first) unsigned-short data array.

getData(int) - Method in class java.awt.image.DataBufferUShort

Returns the data array for the specified bank.

getData() - Method in interface java.awt.image.RenderedImage

Returns the image as one large tile (for tile based images this will require fetching the whole image and copying the image data over).

getData(Rectangle) - Method in interface java.awt.image.RenderedImage

Computes and returns an arbitrary region of the RenderedImage.

getData() - Method in class java.net.DatagramPacket

Returns the data buffer.

getData() - Method in class java.rmi.activation.ActivationDesc

Returns a "marshalled object" containing intialization/activation data for the object specified by this descriptor.

getData() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's initialization data.

getData() - Method in class javax.imageio.stream.IIOByteBuffer

Returns a reference to the byte array.

getData() - Method in class javax.sound.midi.MetaMessage

Obtains a copy of the data for the meta message.

getData() - Method in class javax.sound.midi.SoundbankResource

Obtains the sampled audio that is stored in this SoundbankResource.

getData() - Method in class javax.sound.midi.SysexMessage

Obtains a copy of the data for the system exclusive message.

getData() - Method in class javax.swing.text.html.FormSubmitEvent

Gets the form submission data.

getData() - Method in class javax.swing.text.html.parser.Entity

Returns the data.

getData() - Method in interface javax.xml.stream.events.Characters

Get the character data of this event

getData() - Method in interface javax.xml.stream.events.ProcessingInstruction

The data section of the processing instruction

getData() - Method in interface org.w3c.dom.CharacterData

The character data of the node that implements this interface.

getData() - Method in interface org.w3c.dom.ProcessingInstruction

The content of this processing instruction.

getData1() - Method in class javax.sound.midi.ShortMessage

Obtains the first data byte in the message.

getData2() - Method in class javax.sound.midi.ShortMessage

Obtains the second data byte in the message.

getDatabaseMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the major version number of the underlying database.

getDatabaseMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the minor version number of the underlying database.

getDatabaseProductName() - Method in interface java.sql.DatabaseMetaData

Retrieves the name of this database product.

getDatabaseProductVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the version number of this database product.

getDataBitOffset() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the data bit offset in bits.

getDataBuffer() - Method in class java.awt.image.Raster

Returns the DataBuffer associated with this Raster.

getDataClass() - Method in class javax.sound.midi.SoundbankResource

Obtains the class used by this sample to represent its data.

getDataElement(int[], int) - Method in class java.awt.image.ColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(float[], int) - Method in class java.awt.image.ColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of normalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.ComponentColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(float[], int) - Method in class java.awt.image.ComponentColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of normalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.DirectColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.IndexColorModel

Returns a pixel value represented as an int in this ColorModel given an array of unnormalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(float[], int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of normalized color/alpha components.

getDataElements(int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(float[], int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of normalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, Object) - Method in class java.awt.image.DirectColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.DirectColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(int, Object) - Method in class java.awt.image.IndexColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.IndexColorModel

Returns a data element array representation of a pixel in this ColorModel given an array of unnormalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, Object) - Method in class java.awt.image.Raster

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, int, int, Object) - Method in class java.awt.image.Raster

Returns the pixel data for the specified rectangle of pixels in a primitive array of type TransferType.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the pixel data for the specified rectangle of pixels in a primitive array of type TransferType.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataFlavors() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the data flavors for this transfer.

getDataHandler() - Method in class javax.xml.soap.AttachmentPart

Gets the DataHandler object for this AttachmentPart object.

getDataLength(int) - Method in class javax.sound.midi.ShortMessage

Retrieves the number of data bytes associated with a particular status byte value.

getDatalink() - Method in class javax.sql.rowset.serial.SerialDatalink

Returns a new URL that is a copy of this SerialDatalink object.

getDataSize() - Method in exception java.sql.DataTruncation

Gets the number of bytes of data that should have been transferred.

getDataSource() - Method in class javax.activation.DataHandler

Return the DataSource associated with this instance of DataHandler.

getDataSourceLock() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the current data source lock severity level active in this SyncProvider implementation.

getDataSourceName() - Method in class javax.sql.rowset.BaseRowSet

Returns the logical name that when supplied to a naming service that uses the Java Naming and Directory Interface (JNDI) API, will retrieve a javax.sql.DataSource object.

getDataSourceName() - Method in interface javax.sql.RowSet

Retrieves the logical name that identifies the data source for this RowSet object.

getDataType() - Method in class java.awt.image.DataBuffer

Returns the data type of this DataBuffer.

getDataType() - Method in class java.awt.image.SampleModel

Returns the data type of the DataBuffer storing the pixel data.

getDataTypeSize(int) - Static method in class java.awt.image.DataBuffer

Returns the size (in bits) of the data type, given a datatype tag.

getDataVector() - Method in class javax.swing.table.DefaultTableModel

Returns the Vector of Vectors that contains the table's data values.

getDate() - Method in class java.net.URLConnection

Returns the value of the date header field.

getDate() - Method in class java.security.cert.PKIXParameters

Returns the time for which the validity of the certification path should be determined.

getDate(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATE parameter as a java.sql.Date object.

getDate(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATE parameter as a java.sql.Date object, using the given Calendar object to construct the date.

getDate(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATE parameter as a java.sql.Date object.

getDate(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATE parameter as a java.sql.Date object, using the given Calendar object to construct the date.

getDate(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate() - Method in class java.sql.Time

Deprecated.

getDate() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_MONTH).

getDate(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the date associated to a timer notification.

getDate(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the date associated to a timer notification.

getDate() - Method in class javax.swing.SpinnerDateModel

Returns the current element in this sequence of Dates.

getDateAndTime() - Method in class java.security.cert.X509CRLSelector

Returns the dateAndTime criterion.

getDateFormatSymbols() - Method in class java.text.SimpleDateFormat

Gets a copy of the date and time format symbols of this date format.

getDateInstance() - Static method in class java.text.DateFormat

Gets the date formatter with the default formatting style for the default locale.

getDateInstance(int) - Static method in class java.text.DateFormat

Gets the date formatter with the given formatting style for the default locale.

getDateInstance(int, Locale) - Static method in class java.text.DateFormat

Gets the date formatter with the given formatting style for the given locale.

getDateInstance(int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats date with the given formatting style for the specified locale.

getDateTimeInstance() - Static method in class java.text.DateFormat

Gets the date/time formatter with the default formatting style for the default locale.

getDateTimeInstance(int, int) - Static method in class java.text.DateFormat

Gets the date/time formatter with the given date and time formatting styles for the default locale.

getDateTimeInstance(int, int, Locale) - Static method in class java.text.DateFormat

Gets the date/time formatter with the given formatting styles for the given locale.

getDateTimeInstance(int, int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats date and time with the given formatting style for the specified locale.

getDay() - Method in class java.sql.Time

Deprecated.

getDay() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_WEEK).

getDay() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return day in month or DatatypeConstants.FIELD_UNDEFINED.

getDays() - Method in class javax.xml.datatype.Duration

Obtains the value of the DAYS field as an integer value, or 0 if not present.

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of DC Huffman tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of DC Huffman tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getDebugGraphicsOptions() - Method in class javax.swing.JComponent

Returns the state of graphics debugging.

getDebugOptions() - Method in class javax.swing.DebugGraphics

Returns the current debugging options for this DebugGraphics.

getDecayTime() - Method in class javax.sound.sampled.ReverbType

Obtains the decay time, which is the amount of time over which the late reflections attenuate to effective zero.

getDecimalFormatSymbols() - Method in class java.text.DecimalFormat

Returns a copy of the decimal format symbols, which is generally not changed by the programmer or user.

getDecimalSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used for decimal sign.

getDeclaration(String) - Method in class javax.swing.text.html.StyleSheet

Translates a CSS declaration to an AttributeSet that represents the CSS declaration.

getDeclaration() - Method in interface javax.xml.stream.events.EntityReference

Return the declaration of this entity.

getDeclaredAnnotations() - Method in class java.lang.类

getDeclaredAnnotations() - Method in class java.lang.软件包

getDeclaredAnnotations() - Method in class java.lang.reflect.AccessibleObject

getDeclaredAnnotations() - Method in interface java.lang.reflect.AnnotatedElement

Returns all annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Constructor

getDeclaredAnnotations() - Method in class java.lang.reflect.字段

getDeclaredAnnotations() - Method in class java.lang.reflect.方法

getDeclaredClasses() - Method in class java.lang.类

Returns an array of 类 objects reflecting all the classes and interfaces declared as members of the class represented by this 类 object.

getDeclaredConstructor(Class<?>...) - Method in class java.lang.类

Returns a Constructor object that reflects the specified constructor of the class or interface represented by this 类 object.

getDeclaredConstructors() - Method in class java.lang.类

Returns an array of Constructor objects reflecting all the constructors declared by the class represented by this 类 object.

getDeclaredField(String) - Method in class java.lang.类

Returns a Field object that reflects the specified declared field of the class or interface represented by this 类 object.

getDeclaredFields() - Method in class java.lang.类

Returns an array of Field objects reflecting all the fields declared by the class or interface represented by this 类 object.

getDeclaredMethod(String, Class<?>...) - Method in class java.lang.类

Returns a Method object that reflects the specified declared method of the class or interface represented by this 类 object.

getDeclaredMethods() - Method in class java.lang.类

Returns an array of Method objects reflecting all the methods declared by the class or interface represented by this 类 object.

getDeclaredPrefixes() - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes declared in this context.

getDeclaredType(TypeElement, TypeMirror...) - Method in interface javax.lang.model.util.Types

Returns the type corresponding to a type element and actual type arguments.

getDeclaredType(DeclaredType, TypeElement, TypeMirror...) - Method in interface javax.lang.model.util.Types

Returns the type corresponding to a type element and actual type arguments, given a containing type of which it is a member.

getDeclaredType() - Method in class javax.xml.bind.JAXBElement

Returns the Java binding of the xml element declaration's type attribute.

getDeclaringClass() - Method in class java.lang.类

If the class or interface represented by this 类 object is a member of another class, returns the 类 object representing the class in which it was declared.

getDeclaringClass() - Method in class java.lang.Enum

Returns the Class object corresponding to this enum constant's enum type.

getDeclaringClass() - Method in class java.lang.reflect.Constructor

Returns the 类 object representing the class that declares the constructor represented by this Constructor object.

getDeclaringClass() - Method in class java.lang.reflect.字段

Returns the 类 object representing the class or interface that declares the field represented by this Field object.

getDeclaringClass() - Method in interface java.lang.reflect.Member

Returns the Class object representing the class or interface that declares the member or constructor represented by this Member.

getDeclaringClass() - Method in class java.lang.reflect.方法

Returns the 类 object representing the class or interface that declares the method represented by this Method object.

getDecomposition() - Method in class java.text.Collator

Get the decomposition mode of this Collator.

getDeepestComponentAt(Component, int, int) - Static method in class javax.swing.SwingUtilities

Returns the deepest visible descendent Component of parent that contains the location x, y.

getDefault() - Static method in class java.net.CookieHandler

Gets the system-wide cookie handler.

getDefault() - Static method in class java.net.ProxySelector

Gets the system-wide proxy selector.

getDefault() - Static method in class java.net.ResponseCache

Gets the system-wide response cache.

getDefault() - Static method in class java.nio.file.FileSystems

Returns the default FileSystem.

getDefault() - Static method in class java.util.Locale

Gets the current value of the default locale for this instance of the Java Virtual Machine.

getDefault(Locale.Category) - Static method in class java.util.Locale

Gets the current value of the default locale for the specified Category for this instance of the Java Virtual Machine.

getDefault() - Static method in class java.util.TimeZone

Gets the default TimeZone for this host.

getDefault() - Static method in class javax.net.ServerSocketFactory

Returns a copy of the environment's default socket factory.

getDefault() - Static method in class javax.net.SocketFactory

Returns a copy of the environment's default socket factory.

getDefault() - Static method in class javax.net.ssl.SSLContext

Returns the default SSL context.

getDefault() - Static method in class javax.net.ssl.SSLServerSocketFactory

Returns the default SSL server socket factory.

getDefault() - Static method in class javax.net.ssl.SSLSocketFactory

Returns the default SSL socket factory.

getDefaultAction() - Method in interface javax.swing.text.Keymap

Fetches the default action to fire if a key is typed (i.e.

getDefaultActions() - Method in class java.awt.dnd.DropTarget

Gets an int representing the current action(s) supported by this DropTarget.

getDefaultAlgorithm() - Static method in class javax.net.ssl.KeyManagerFactory

Obtains the default KeyManagerFactory algorithm name.

getDefaultAlgorithm() - Static method in class javax.net.ssl.TrustManagerFactory

Obtains the default TrustManagerFactory algorithm name.

getDefaultAllowUserInteraction() - Static method in class java.net.URLConnection

Returns the default value of the allowUserInteraction field.

getDefaultAttributeValue(Class<? extends Attribute>) - Method in interface javax.print.PrintService

Determines this print service's default printing attribute value in the given category.

getDefaultButton() - Method in class javax.swing.JRootPane

Returns the value of the defaultButton property.

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

Returns default button for current LookAndFeel.

getDefaultChoice() - Method in class javax.security.auth.callback.ChoiceCallback

Get the defaultChoice.

getDefaultChooserPanels() - Static method in class javax.swing.colorchooser.ColorChooserComponentFactory

getDefaultCipherSuites() - Method in class javax.net.ssl.SSLServerSocketFactory

Returns the list of cipher suites which are enabled by default.

getDefaultCipherSuites() - Method in class javax.net.ssl.SSLSocketFactory

Returns the list of cipher suites which are enabled by default.

getDefaultClassLoader() - Method in class javax.management.remote.rmi.RMIServerImpl

Gets the default ClassLoader used by this connector server.

getDefaultClosedIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.

getDefaultCloseOperation() - Method in class javax.swing.JDialog

Returns the operation which occurs when the user initiates a "close" on this dialog.

getDefaultCloseOperation() - Method in class javax.swing.JFrame

Returns the operation that occurs when the user initiates a "close" on this frame.

getDefaultCloseOperation() - Method in class javax.swing.JInternalFrame

Returns the default operation that occurs when the user initiates a "close" on this internal frame.

getDefaultCommandMap() - Static method in class javax.activation.CommandMap

Get the default CommandMap.

getDefaultComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the default Component to focus.

getDefaultComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the default Component to focus.

getDefaultComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the default Component to focus.

getDefaultConfiguration() - Method in class java.awt.GraphicsDevice

Returns the default GraphicsConfiguration associated with this GraphicsDevice.

getDefaultController() - Method in class javax.imageio.IIOParam

Returns the default IIOParamController, if there is one, regardless of the currently installed controller.

getDefaultController() - Method in class javax.imageio.metadata.IIOMetadata

Returns the default IIOMetadataController, if there is one, regardless of the currently installed controller.

getDefaultCursor() - Static method in class java.awt.Cursor

Return the system default cursor.

getDefaultCursor() - Method in class javax.swing.text.html.HTMLEditorKit

Returns the default cursor.

getDefaultDirectory() - Method in class javax.swing.filechooser.FileSystemView

Return the user's default starting directory for the file chooser.

getDefaultDomain() - Method in interface javax.management.MBeanServer

getDefaultDomain() - Method in interface javax.management.MBeanServerConnection

Returns the default domain used for naming the MBean.

getDefaultDomain(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getDefaultDomain().

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getDefaultDragSource() - Static method in class java.awt.dnd.DragSource

Gets the DragSource object associated with the underlying platform.

getDefaultEditor(Class<?>) - Method in class javax.swing.JTable

Returns the editor to be used when no editor has been set in a TableColumn.

getDefaultEventIndex() - Method in interface java.beans.BeanInfo

A bean may have a "default" event that is the event that will mostly commonly be used by humans when using the bean.

getDefaultEventIndex() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of a default event.

getDefaultFileTypeMap() - Static method in class javax.activation.FileTypeMap

Return the default FileTypeMap for the system.

getDefaultFlavorMap() - Static method in class java.awt.datatransfer.SystemFlavorMap

Returns the default FlavorMap for this thread's ClassLoader.

getDefaultFocusTraversalKeys(int) - Method in class java.awt.KeyboardFocusManager

Returns a Set of default focus traversal keys for a given traversal operation.

getDefaultFocusTraversalPolicy() - Method in class java.awt.KeyboardFocusManager

Returns the default FocusTraversalPolicy.

getDefaultFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.

getDefaultFractionDigits() - Method in class java.util.Currency

Gets the default number of fraction digits used with this currency.

getDefaultHostnameVerifier() - Static method in class javax.net.ssl.HttpsURLConnection

Gets the default HostnameVerifier that is inherited by new instances of this class.

getDefaultIcon() - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

getDefaultIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the default icon.

getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio.ImageWriter

Returns an IIOMetadata object containing default values for encoding an image of the given type.

getDefaultInitCtx() - Method in class javax.naming.InitialContext

Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx.

getDefaultInstance() - Static method in class javax.imageio.spi.IIORegistry

Returns the default IIORegistry instance used by the Image I/O API.

getDefaultLeafIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent leaf nodes.

getDefaultLightWeightPopupEnabled() - Static method in class javax.swing.JPopupMenu

Gets the defaultLightWeightPopupEnabled property, which by default is true.

getDefaultLocale() - Static method in class javax.swing.JComponent

Returns the default locale used to initialize each JComponent's locale property upon creation.

getDefaultLocale() - Method in class javax.swing.UIDefaults

Returns the default locale.

getDefaultName() - Method in class javax.security.auth.callback.NameCallback

Get the default name.

getDefaultNamespacePrefix() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getDefaultNamespacePrefix() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the default namespace prefix.

getDefaultOpenIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.

getDefaultOption() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the default option.

getDefaultPort() - Method in class java.net.URL

Gets the default port number of the protocol associated with this URL.

getDefaultPort() - Method in class java.net.URLStreamHandler

Returns the default port for a URL parsed by this handler.

getDefaultPrintService() - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getDefaultPropertyIndex() - Method in interface java.beans.BeanInfo

A bean may have a "default" property that is the property that will mostly commonly be initially chosen for update by human's who are customizing the bean.

getDefaultPropertyIndex() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of a default property.

getDefaultProviderInstance() - Static method in class java.rmi.server.RMIClassLoader

Returns the canonical instance of the default provider for the service provider interface RMIClassLoaderSpi.

getDefaultQueue() - Static method in class javax.swing.text.LayoutQueue

Fetch the default layout queue.

getDefaultReadParam() - Method in class javax.imageio.ImageReader

Returns a default ImageReadParam object appropriate for this format.

getDefaultRenderer(Class<?>) - Method in class javax.swing.JTable

Returns the cell renderer to be used when no renderer has been set in a TableColumn.

getDefaultRenderer() - Method in class javax.swing.table.JTableHeader

Returns the default renderer used when no headerRenderer is defined by a TableColumn.

getDefaultRepresentationClass() - Method in class java.awt.datatransfer.DataFlavor

getDefaultRepresentationClassAsString() - Method in class java.awt.datatransfer.DataFlavor

getDefaultRequestProperty(String) - Static method in class java.net.URLConnection

Deprecated.
The instance specific getRequestProperty method should be used after an appropriate instance of URLConnection is obtained.

getDefaultRootElement() - Method in class javax.swing.text.AbstractDocument

Returns the root element that views should be based upon unless some other mechanism for assigning views to element structures is provided.

getDefaultRootElement() - Method in class javax.swing.text.DefaultStyledDocument

Gets the default root element.

getDefaultRootElement() - Method in interface javax.swing.text.Document

Returns the root element that views should be based upon, unless some other mechanism for assigning views to element structures is provided.

getDefaultRootElement() - Method in class javax.swing.text.PlainDocument

Gets the default root element for the document model.

getDefaults() - Method in class javax.swing.LookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.basic.BasicLookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Creates, initializes, and returns the look and feel specific defaults.

getDefaults() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

getDefaults() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the defaults for this SynthLookAndFeel.

getDefaults() - Static method in class javax.swing.UIManager

Returns the defaults.

getDefaultScreenDevice() - Method in class java.awt.GraphicsEnvironment

Returns the default screen GraphicsDevice.

getDefaultSelection() - Method in class java.awt.JobAttributes

Specifies whether, for jobs using these attributes, the application should print all pages, the range specified by the return value of getPageRanges, or the current selection.

getDefaultSize() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Return the default size of an empty display area of the combo box using the current renderer and font.

getDefaultSize() - Method in class javax.swing.plaf.synth.SynthComboBoxUI

Returns the default size of an empty display area of the combo box using the current renderer and font.

getDefaultSocketFactory() - Static method in class java.rmi.server.RMISocketFactory

Returns a reference to the default socket factory used by this RMI implementation.

getDefaultSoundbank() - Method in interface javax.sound.midi.Synthesizer

Obtains the default soundbank for the synthesizer, if one exists.

getDefaultSSLParameters() - Method in class javax.net.ssl.SSLContext

Returns a copy of the SSLParameters indicating the default settings for this SSL context.

getDefaultSSLSocketFactory() - Static method in class javax.net.ssl.HttpsURLConnection

Gets the default static SSLSocketFactory that is inherited by new instances of this class.

getDefaultStream() - Static method in class java.rmi.server.LogStream

Deprecated.
no replacement

getDefaultStreamMetadata(ImageWriteParam) - Method in class javax.imageio.ImageWriter

Returns an IIOMetadata object containing default values for encoding a stream of images.

getDefaultStyleContext() - Static method in class javax.swing.text.StyleContext

Returns default AttributeContext shared by all documents that don't bother to define/supply their own context.

getDefaultText() - Method in class javax.security.auth.callback.TextInputCallback

Get the default text.

getDefaultTextIconGap(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI

getDefaultToolkit() - Static method in class java.awt.Toolkit

Gets the default toolkit.

getDefaultTransactionIsolation() - Method in interface java.sql.DatabaseMetaData

Retrieves this database's default transaction isolation level.

getDefaultTransform() - Method in class java.awt.GraphicsConfiguration

Returns the default AffineTransform for this GraphicsConfiguration.

getDefaultTreeModel() - Static method in class javax.swing.JTree

Creates and returns a sample TreeModel.

getDefaultType() - Static method in class java.security.cert.CertPathBuilder

Returns the default CertPathBuilder type as specified in the Java security properties file, or the string "PKIX" if no such property exists.

getDefaultType() - Static method in class java.security.cert.CertPathValidator

Returns the default CertPathValidator type as specified in the Java security properties file, or the string "PKIX" if no such property exists.

getDefaultType() - Static method in class java.security.cert.CertStore

Returns the default CertStore type as specified in the Java security properties file, or the string "LDAP" if no such property exists.

getDefaultType() - Static method in class java.security.KeyStore

Returns the default keystore type as specified in the Java security properties file, or the string "jks" (acronym for "Java keystore") if no such property exists.

getDefaultUncaughtExceptionHandler() - Static method in class java.lang.Thread

Returns the default handler invoked when a thread abruptly terminates due to an uncaught exception.

getDefaultUseCaches() - Method in class java.net.URLConnection

Returns the default value of a URLConnection's useCaches flag.

getDefaultValue() - Method in class java.lang.reflect.方法

Returns the default value for the annotation member represented by this Method instance.

getDefaultValue() - Method in interface javax.lang.model.element.ExecutableElement

Returns the default value if this executable is an annotation type element.

getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the default value for this parameter, if it has one, or null otherwise.

getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getDefaultValue() - Method in class javax.swing.text.html.CSS.Attribute

Fetch the default value for the attribute.

getDefaultWriteParam() - Method in class javax.imageio.ImageWriter

Returns a new ImageWriteParam object of the appropriate type for this file format containing default values, that is, those values that would be used if no ImageWriteParam object were specified.

getDefinitionClass() - Method in class java.lang.instrument.ClassDefinition

Returns the class.

getDefinitionClassFile() - Method in class java.lang.instrument.ClassDefinition

Returns the array of bytes that contains the new class file.

getDelay(TimeUnit) - Method in interface java.util.concurrent.Delayed

Returns the remaining delay associated with this object, in the given time unit.

getDelay() - Method in class javax.swing.JMenu

Returns the suggested delay, in milliseconds, before submenus are popped up or down.

getDelay() - Method in class javax.swing.Timer

Returns the delay, in milliseconds, between firings of action events.

getDelegatedTask() - Method in class javax.net.ssl.SSLEngine

Returns a delegated Runnable task for this SSLEngine.

getDelegCred() - Method in interface org.ietf.jgss.GSSContext

Obtains the credentials delegated by the context initiator to the context acceptor.

getDepth() - Method in interface java.security.cert.PolicyNode

Returns the depth of this node in the valid policy tree.

getDepth(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getDepth() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf.

getDER() - Method in class org.ietf.jgss.Oid

Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.

getDereferencedData() - Method in interface javax.xml.crypto.dsig.Reference

Returns the dereferenced data, if reference caching is enabled.

getDerefLinkFlag() - Method in class javax.naming.directory.SearchControls

Determines whether links will be dereferenced during the search.

getDerivedColor(String, float, float, float, int, boolean) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Get a derived color, derived colors are shared instances and is color value will change when its parent UIDefault color changes.

getDerivedColor(Color, Color, float, boolean) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Decodes and returns a color, which is derived from an offset between two other colors.

getDerivedColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Decodes and returns a color, which is derived from a offset between two other colors.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.GaugeMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.GaugeMonitor

Deprecated.
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.GaugeMonitorMBean

Deprecated.
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGauge() - Method in class javax.management.monitor.MonitorNotification

Gets the derived gauge of this monitor notification.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.StringMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.StringMonitor

Deprecated.
As of JMX 1.2, replaced by StringMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.StringMonitorMBean

Deprecated.
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.GaugeMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.GaugeMonitor

Deprecated.
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.GaugeMonitorMBean

Deprecated.
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.StringMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.StringMonitor

Deprecated.
As of JMX 1.2, replaced by StringMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.StringMonitorMBean

Deprecated.
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDescendantToggledPaths(TreePath) - Method in class javax.swing.JTree

Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.

getDescent() - Method in class java.awt.font.GraphicAttribute

Returns the descent of this GraphicAttribute.

getDescent() - Method in class java.awt.font.ImageGraphicAttribute

Returns the descent of this ImageGraphicAttribute.

getDescent() - Method in class java.awt.font.LineMetrics

Returns the descent of the text.

getDescent() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the descent of this ShapeGraphicAttribute.

getDescent() - Method in class java.awt.font.TextLayout

Returns the descent of this TextLayout.

getDescent() - Method in class java.awt.FontMetrics

Determines the font descent of the Font described by this FontMetrics object.

getDescent(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getDescription() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the description of the error.

getDescription(Locale) - Method in class javax.imageio.spi.IIOServiceProvider

Returns a brief, human-readable description of this service provider and its associated implementation.

getDescription() - Method in class javax.management.MBeanFeatureInfo

Returns the human-readable description of the feature.

getDescription() - Method in class javax.management.MBeanInfo

Returns a human readable description of the MBean.

getDescription() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a human readable description of the MBean.

getDescription(String) - Method in class javax.management.openmbean.CompositeType

Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.

getDescription() - Method in class javax.management.openmbean.OpenType

Returns the text description of this OpenType instance.

getDescription() - Method in class javax.management.relation.RoleInfo

Returns description text for the role.

getDescription(MBeanInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanInfo returned by this MBean.

getDescription(MBeanFeatureInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanFeatureInfo returned by this MBean.

getDescription(MBeanAttributeInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanAttributeInfo returned by this MBean.

getDescription(MBeanConstructorInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanConstructorInfo returned by this MBean.

getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.

getDescription(MBeanOperationInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanOperationInfo returned by this MBean.

getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.

getDescription() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the description of the device.

getDescription() - Method in interface javax.sound.midi.Soundbank

Obtains a textual description of the sound bank, suitable for display.

getDescription() - Method in class javax.sound.sampled.Mixer.Info

Obtains the description of the mixer.

getDescription() - Method in class javax.swing.event.HyperlinkEvent

Get the description of the link as a string.

getDescription() - Method in class javax.swing.filechooser.FileFilter

The description of this filter.

getDescription() - Method in class javax.swing.filechooser.FileNameExtensionFilter

The description of this filter.

getDescription(File) - Method in class javax.swing.filechooser.FileView

A human readable description of the file.

getDescription() - Method in class javax.swing.ImageIcon

Gets the description of the image.

getDescription(File) - Method in class javax.swing.JFileChooser

Returns the file description.

getDescription() - Method in class javax.swing.LookAndFeel

Return a one line description of this look and feel implementation, e.g.

getDescription() - Method in class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter

getDescription(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getDescription() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns a short description of this look and feel.

getDescription() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a one-line description of this look and feel.

getDescription() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Returns a textual description of this look and feel.

getDescription() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns a textual description of SynthLookAndFeel.

getDescriptor() - Method in interface javax.management.DescriptorRead

Returns a copy of Descriptor.

getDescriptor() - Method in class javax.management.MBeanFeatureInfo

Returns the descriptor for the feature.

getDescriptor() - Method in class javax.management.MBeanInfo

Get the descriptor of this MBeanInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo

Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo

Returns a copy of the associated Descriptor.

getDescriptor(String, String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a Descriptor requested by name and descriptorType.

getDescriptor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

Returns a Descriptor requested by name.

getDescriptor(String, String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo

Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo

Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.

getDescriptors(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.

getDescriptors(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDesignAxisDefaults() - Method in interface java.awt.font.MultipleMaster

Returns an array of default design values for each axis.

getDesignAxisNames() - Method in interface java.awt.font.MultipleMaster

Returns the name for each design axis.

getDesignAxisRanges() - Method in interface java.awt.font.MultipleMaster

Returns an array of design limits interleaved in the form [from->to] for each axis.

getDesktop() - Static method in class java.awt.Desktop

Returns the Desktop instance of the current browser context.

getDesktopColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the desktop color of the current theme.

getDesktopColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the desktop color.

getDesktopColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the desktop color.

getDesktopIcon() - Method in class javax.swing.JInternalFrame

Returns the JDesktopIcon used when this JInternalFrame is iconified.

getDesktopIconBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a Desktop Icon

getDesktopManager() - Method in class javax.swing.JDesktopPane

Returns the DesktopManger that handles desktop-specific UI actions.

getDesktopManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

Returns the proper DesktopManager.

getDesktopPane() - Method in class javax.swing.JInternalFrame

Convenience method that searches the ancestor hierarchy for a JDesktop instance.

getDesktopPane() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Convenience method to ask the icon for the Desktop object it belongs to.

getDesktopPaneForComponent(Component) - Static method in class javax.swing.JOptionPane

Returns the specified component's desktop pane.

getDesktopProperty(String) - Method in class java.awt.Toolkit

Obtains a value for the specified desktop property.

getDesktopPropertyValue(String, Object) - Static method in class javax.swing.LookAndFeel

Returns the value of the specified system desktop property by invoking Toolkit.getDefaultToolkit().getDesktopProperty().

getDestination() - Method in class java.awt.JobAttributes

Specifies whether output will be to a printer or a file for jobs using these attributes.

getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int) - Static method in class javax.imageio.ImageReader

Returns the BufferedImage to which decoded pixel data should be written.

getDestination() - Method in class javax.imageio.ImageReadParam

Returns the BufferedImage currently set by the setDestination method, or null if none is set.

getDestinationBands() - Method in class javax.imageio.ImageReadParam

Returns the set of band indices where data will be placed.

getDestinationOffset() - Method in class javax.imageio.IIOParam

Returns the offset in the destination image at which pixels are to be placed.

getDestinationType() - Method in class javax.imageio.IIOParam

Returns the type of image to be returned by the read, if one was set by a call to setDestination(ImageTypeSpecifier), as an ImageTypeSpecifier.

getDetail() - Method in interface javax.xml.soap.SOAPFault

Returns the optional detail element for this SOAPFault object.

getDetail() - Method in interface org.w3c.dom.events.UIEvent

Specifies some detail information about the Event, depending on the type of event.

getDetailEntries() - Method in interface javax.xml.soap.Detail

Gets an Iterator over all of the DetailEntrys in this Detail object.

getDeterminant() - Method in class java.awt.geom.AffineTransform

Returns the determinant of the matrix representation of the transform.

getDevice() - Method in class java.awt.GraphicsConfiguration

Returns the GraphicsDevice associated with this GraphicsConfiguration.

getDevice() - Method in class java.awt.PointerInfo

Returns the GraphicsDevice where the mouse pointer was at the moment this PointerInfo was created.

getDevice(MidiDevice.Info) - Method in class javax.sound.midi.spi.MidiDeviceProvider

Obtains an instance of the device represented by the info object.

getDeviceConfiguration() - Method in class java.awt.Graphics2D

Returns the device configuration associated with this Graphics2D.

getDeviceInfo() - Method in interface javax.sound.midi.MidiDevice

Obtains information about the device, including its Java class and Strings containing its name, vendor, and description.

getDeviceInfo() - Method in class javax.sound.midi.spi.MidiDeviceProvider

Obtains the set of info objects representing the device or devices provided by this MidiDeviceProvider.

getDiagnostics() - Method in class javax.tools.DiagnosticCollector

Gets a list view of diagnostics collected by this object.

getDialog() - Method in class java.awt.JobAttributes

Returns whether, for jobs using these attributes, the user should see a print dialog in which to modify the print settings, and which type of print dialog should be displayed.

getDialogTitle() - Method in class javax.swing.JFileChooser

Gets the string that goes in the JFileChooser's titlebar.

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Returns the title of this dialog

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getDialogTitle method on each UI handled by this object.

getDialogType() - Method in class javax.swing.JFileChooser

Returns the type of this dialog.

getDifferenceMode() - Method in class javax.management.monitor.CounterMonitor

Gets the difference mode flag value common to all observed MBeans.

getDifferenceMode() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the difference mode flag value.

getDifferenceMode() - Method in class javax.management.monitor.GaugeMonitor

Gets the difference mode flag value common to all observed MBeans.

getDifferenceMode() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the difference mode flag value.

getDigestAlgorithm() - Method in class java.security.spec.MGF1ParameterSpec

Returns the algorithm name of the message digest used by the mask generation function.

getDigestAlgorithm() - Method in class java.security.spec.PSSParameterSpec

Returns the message digest algorithm name.

getDigestAlgorithm() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the message digest algorithm name.

getDigestInputStream() - Method in interface javax.xml.crypto.dsig.Reference

Returns the pre-digested input stream, if reference caching is enabled.

getDigestLength() - Method in class java.security.MessageDigest

Returns the length of the digest in bytes, or 0 if this operation is not supported by the provider and the implementation is not cloneable.

getDigestMethod() - Method in interface javax.xml.crypto.dsig.Reference

Returns the digest method of this Reference.

getDigestValue() - Method in interface javax.xml.crypto.dsig.Reference

Returns the digest value of this Reference.

getDigit() - Method in class java.text.DecimalFormatSymbols

Gets the character used for a digit in a pattern.

getDimension() - Method in class javax.management.openmbean.ArrayType

Returns the dimension of arrays described by this ArrayType instance.

getDimension(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Dimension return it, otherwise return null.

getDimension(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Dimension return it, otherwise return null.

getDimension(Object) - Static method in class javax.swing.UIManager

Returns a dimension from the defaults.

getDimension(Object, Locale) - Static method in class javax.swing.UIManager

Returns a dimension from the defaults that is appropriate for the given locale.

getDirection() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the direction of the arrow.

getDirection() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the direction.

getDirectionality(char) - Static method in class java.lang.Character

Returns the Unicode directionality property for the given character.

getDirectionality(int) - Static method in class java.lang.Character

Returns the Unicode directionality property for the given character (Unicode code point).

getDirectories() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getDirectory() - Method in class java.awt.FileDialog

Gets the directory of this file dialog.

getDirectory() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Property to remember the directory that is currently selected in the UI.

getDirectoryName() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getDirectoryName() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getDirtyRegion(JComponent) - Method in class javax.swing.RepaintManager

Return the current dirty region for a component.

getDisabledIcon() - Method in class javax.swing.AbstractButton

Returns the icon used by the button when it's disabled.

getDisabledIcon() - Method in class javax.swing.JLabel

Returns the icon used by the label when it's disabled.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.LookAndFeel

Returns an Icon with a disabled appearance.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an Icon with a disabled appearance.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

getDisabledIconAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab disabled icon at index.

getDisabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter

Gets all the ObjectNames disabled.

getDisabledSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the icon used by the button when it's disabled and selected.

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing.LookAndFeel

Returns an Icon for use by disabled components that are also selected.

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an Icon for use by disabled components that are also selected.

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getDisabledTextColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the disabled text.

getDiscard() - Method in class java.net.HttpCookie

Return the discard attribute of the cookie

getDismissDelay() - Method in class javax.swing.ToolTipManager

Returns the dismissal delay value.

getDisplayCountry() - Method in class java.util.Locale

Returns a name for the locale's country that is appropriate for display to the user.

getDisplayCountry(Locale) - Method in class java.util.Locale

Returns a name for the locale's country that is appropriate for display to the user.

getDisplayCountry(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 region code (either ISO 3166 country code or UN M.49 area codes) and the given locale that is appropriate for display to the user.

getDisplayedMnemonic() - Method in class javax.swing.JLabel

Return the keycode that indicates a mnemonic key.

getDisplayedMnemonicIndex() - Method in class javax.swing.AbstractButton

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayedMnemonicIndex() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Provides a hint to the look and feel as to the index of the character in getDisplayName that should be visually identified as the mnemonic.

getDisplayedMnemonicIndex() - Method in class javax.swing.JLabel

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayedMnemonicIndexAt(int) - Method in class javax.swing.JTabbedPane

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

getDisplayLanguage() - Method in class java.util.Locale

Returns a name for the locale's language that is appropriate for display to the user.

getDisplayLanguage(Locale) - Method in class java.util.Locale

Returns a name for the locale's language that is appropriate for display to the user.

getDisplayLanguage(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 language code and the given locale that is appropriate for display to the user.

getDisplayMode() - Method in class java.awt.GraphicsDevice

Returns the current display mode of this GraphicsDevice.

getDisplayModes() - Method in class java.awt.GraphicsDevice

Returns all display modes available for this GraphicsDevice.

getDisplayName() - Method in class java.beans.FeatureDescriptor

Gets the localized display name of this feature.

getDisplayName() - Method in class java.net.NetworkInterface

Get the display name of this network interface.

getDisplayName(int, int, Locale) - Method in class java.util.Calendar

Returns the string representation of the calendar field value in the given style and locale.

getDisplayName() - Method in class java.util.Currency

Gets the name that is suitable for displaying this currency for the default locale.

getDisplayName(Locale) - Method in class java.util.Currency

Gets the name that is suitable for displaying this currency for the specified locale.

getDisplayName() - Method in class java.util.Locale

Returns a name for the locale that is appropriate for display to the user.

getDisplayName(Locale) - Method in class java.util.Locale

Returns a name for the locale that is appropriate for display to the user.

getDisplayName(String, Locale) - Method in class java.util.spi.CurrencyNameProvider

Returns a name for the currency that is appropriate for display to the user.

getDisplayName(String, boolean, int, Locale) - Method in class java.util.spi.TimeZoneNameProvider

Returns a name for the given time zone ID that's suitable for presentation to the user in the specified locale.

getDisplayName() - Method in class java.util.TimeZone

Returns a long standard time name of this TimeZone suitable for presentation to the user in the default locale.

getDisplayName(Locale) - Method in class java.util.TimeZone

Returns a long standard time name of this TimeZone suitable for presentation to the user in the specified locale.

getDisplayName(boolean, int) - Method in class java.util.TimeZone

Returns a name in the specified style of this TimeZone suitable for presentation to the user in the default locale.

getDisplayName(boolean, int, Locale) - Method in class java.util.TimeZone

Returns a name in the specified style of this TimeZone suitable for presentation to the user in the specified locale.

getDisplayName() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns a string containing the display name of the panel.

getDisplayNames(int, int, Locale) - Method in class java.util.Calendar

Returns a Map containing all names of the calendar field in the given style and locale and their corresponding field values.

getDisplayScript() - Method in class java.util.Locale

Returns a name for the the locale's script that is appropriate for display to the user.

getDisplayScript(Locale) - Method in class java.util.Locale

Returns a name for the locale's script that is appropriate for display to the user.

getDisplayScript(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 script code and the given locale that is appropriate for display to the user.

getDisplaySize() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the calculated size of the display area.

getDisplayVariant() - Method in class java.util.Locale

Returns a name for the locale's variant code that is appropriate for display to the user.

getDisplayVariant(Locale) - Method in class java.util.Locale

Returns a name for the locale's variant code that is appropriate for display to the user.

getDisplayVariant(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given variant code and the given locale that is appropriate for display to the user.

getDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the divider between the top Components.

getDividerBorderSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Deprecated.
As of Java 2 platform v1.3, instead set the border on the divider.

getDividerLocation() - Method in class javax.swing.JSplitPane

Returns the last value passed to setDividerLocation.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the location of the divider, which may differ from what the splitpane thinks the location of the divider is.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getDividerLocation method on each UI handled by this object.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the location of the divider.

getDividerSize() - Method in class javax.swing.JSplitPane

Returns the size of the divider.

getDividerSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the size of the divider, that is the width if the splitpane is HORIZONTAL_SPLIT, or the height of VERTICAL_SPLIT.

getDivisionType() - Method in class javax.sound.midi.MidiFileFormat

Obtains the timing division type for the MIDI file.

getDivisionType() - Method in class javax.sound.midi.Sequence

Obtains the timing division type for this sequence.

getDoc() - Method in interface javax.print.MultiDoc

Obtain the current doc object.

getDocComment(Element) - Method in interface javax.lang.model.util.Elements

Returns the text of the documentation ("Javadoc") comment of an element.

getDocFlavor() - Method in interface javax.print.Doc

Determines the doc flavor in which this doc object will supply its piece of print data.

getDocFlavor() - Method in class javax.print.SimpleDoc

Determines the doc flavor in which this doc object will supply its piece of print data.

getDockingColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI

Gets the color displayed when over a docking area

getDoctype() - Method in interface org.w3c.dom.Document

The Document Type Declaration (see DocumentType) associated with this document.

getDocument() - Method in interface javax.swing.event.DocumentEvent

Gets the document that sourced the change event.

getDocument() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Retrieves the underlying model.

getDocument() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Gets the document that sourced the change event.

getDocument() - Method in class javax.swing.text.AbstractWriter

Fetches the document.

getDocument() - Method in class javax.swing.text.DocumentFilter.FilterBypass

Returns the Document the mutation is occuring on.

getDocument() - Method in interface javax.swing.text.Element

Fetches the document associated with this element.

getDocument() - Method in class javax.swing.text.JTextComponent

Fetches the model associated with the editor.

getDocument() - Method in class javax.swing.text.View

Fetches the model associated with the view.

getDocumentBase() - Method in class java.applet.Applet

Gets the URL of the document in which this applet is embedded.

getDocumentBase() - Method in interface java.applet.AppletStub

Gets the URL of the document in which the applet is embedded.

getDocumentBase() - Method in class javax.management.loading.MLetContent

Gets the MLet text file's base URL.

getDocumentElement() - Method in interface org.w3c.dom.Document

This is a convenience attribute that allows direct access to the child node that is the document element of the document.

getDocumentFilter() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a DocumentFilter to restrict what can be input.

getDocumentFilter() - Method in class javax.swing.text.AbstractDocument

Returns the DocumentFilter that is responsible for filtering of insertion/removal.

getDocumentFilter() - Method in class javax.swing.text.DefaultFormatter

Returns the DocumentFilter used to restrict the characters that can be input into the JFormattedTextField.

getDocumentListeners() - Method in class javax.swing.text.AbstractDocument

Returns an array of all the document listeners registered on this document.

getDocumentProperties() - Method in class javax.swing.text.AbstractDocument

Supports managing a set of properties.

getDocumentTypeDeclaration() - Method in interface javax.xml.stream.events.DTD

Returns the entire Document Type Declaration as a string, including the internal DTD subset.

getDocumentURI() - Method in interface org.w3c.dom.Document

The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.

getDoInput() - Method in class java.net.URLConnection

Returns the value of this URLConnection's doInput flag.

getDomain() - Method in class java.net.HttpCookie

Returns the domain name set for this cookie.

getDomain() - Method in class javax.management.ObjectName

Returns the domain part.

getDomainCombiner() - Method in class java.security.AccessControlContext

Get the DomainCombiner associated with this AccessControlContext.

getDomains() - Method in interface javax.management.MBeanServer

getDomains() - Method in interface javax.management.MBeanServerConnection

Returns the list of domains in which any MBean is currently registered.

getDomains(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getDomains().

getDomains(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getDomains(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getDomConfig() - Method in interface org.w3c.dom.Document

The configuration used when Document.normalizeDocument() is invoked.

getDomConfig() - Method in interface org.w3c.dom.ls.LSParser

The DOMConfiguration object used when parsing an input source.

getDomConfig() - Method in interface org.w3c.dom.ls.LSSerializer

The DOMConfiguration object used by the LSSerializer when serializing a DOM node.

getDOMImplementation() - Method in class javax.xml.parsers.DocumentBuilder

Obtain an instance of a DOMImplementation object.

getDOMImplementation(String) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry

Return the first implementation that has the desired features, or null if none is found.

getDOMImplementation(String) - Method in interface org.w3c.dom.DOMImplementationSource

A method to request the first DOM implementation that supports the specified features.

getDOMImplementationList(String) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry

Return a list of implementations that support the desired features.

getDOMImplementationList(String) - Method in interface org.w3c.dom.DOMImplementationSource

A method to request a list of DOM implementations that support the specified features and versions, as specified in .

getDoOutput() - Method in class java.net.URLConnection

Returns the value of this URLConnection's doOutput flag.

getDot() - Method in class javax.swing.event.CaretEvent

Fetches the location of the caret.

getDot() - Method in interface javax.swing.text.Caret

Fetches the current position of the caret.

getDot() - Method in class javax.swing.text.DefaultCaret

Fetches the current position of the caret.

getDotBias() - Method in class javax.swing.text.DefaultCaret

Returns the bias of the caret position.

getDouble(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a double.

getDouble(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type double or of another primitive type convertible to type double via a widening conversion.

getDouble() - Method in class java.nio.ByteBuffer

Relative get method for reading a double value.

getDouble(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a double value.

getDouble(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DOUBLE parameter as a double in the Java programming language.

getDouble(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DOUBLE parameter as a double in the Java programming language.

getDouble(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a double in the Java programming language.

getDouble(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a double in the Java programming language.

getDouble(String, double) - Method in class java.util.prefs.AbstractPreferences

Implements the getDouble method as per the specification in Preferences.getDouble(String,double).

getDouble(String, double) - Method in class java.util.prefs.Preferences

Returns the double value represented by the string associated with the specified key in this preference node.

getDoubleBufferMaximumSize() - Method in class javax.swing.RepaintManager

Returns the maximum double buffer size.

getDoubleParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a double.

getDragAction() - Method in class java.awt.dnd.DragGestureEvent

Returns an int representing the action selected by the user.

getDragEnabled() - Method in class javax.swing.JColorChooser

Gets the value of the dragEnabled property.

getDragEnabled() - Method in class javax.swing.JFileChooser

Gets the value of the dragEnabled property.

getDragEnabled() - Method in class javax.swing.JList

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.JTable

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.JTree

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.text.JTextComponent

Returns whether or not automatic drag handling is enabled.

getDraggedColumn() - Method in class javax.swing.table.JTableHeader

Returns the the dragged column, if and only if, a drag is in process, otherwise returns null.

getDraggedDistance() - Method in class javax.swing.table.JTableHeader

Returns the column's horizontal distance from its original position, if and only if, a drag is in process.

getDragImage() - Method in class javax.swing.TransferHandler

Returns the drag image.

getDragImageOffset() - Method in class javax.swing.TransferHandler

Returns an anchor offset for the image to drag.

getDragMode() - Method in class javax.swing.JDesktopPane

Gets the current "dragging style" used by the desktop pane.

getDragOrigin() - Method in class java.awt.dnd.DragGestureEvent

Returns a Point in the coordinates of the Component over which the drag originated.

getDragSource() - Method in class java.awt.dnd.DragGestureEvent

Returns the DragSource.

getDragSource() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the DragSource this DragGestureRecognizer will use in order to process the Drag and Drop operation.

getDragSource() - Method in class java.awt.dnd.DragSourceContext

Returns the DragSource that instantiated this DragSourceContext.

getDragSourceContext() - Method in class java.awt.dnd.DragSourceEvent

This method returns the DragSourceContext that originated the event.

getDragSourceListeners() - Method in class java.awt.dnd.DragSource

Gets all the DragSourceListeners registered with this DragSource.

getDragSourceMotionListeners() - Method in class java.awt.dnd.DragSource

Gets all of the DragSourceMotionListeners registered with this DragSource.

getDragThreshold() - Static method in class java.awt.dnd.DragSource

Returns the drag gesture motion threshold.

getDrawGraphics() - Method in class java.awt.Component.BltBufferStrategy

getDrawGraphics() - Method in class java.awt.Component.FlipBufferStrategy

getDrawGraphics() - Method in class java.awt.image.BufferStrategy

Creates a graphics context for the drawing buffer.

getDrawsLayeredHighlights() - Method in class javax.swing.text.DefaultHighlighter

getDriver(String) - Static method in class java.sql.DriverManager

Attempts to locate a driver that understands the given URL.

getDriverMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves this JDBC driver's major version number.

getDriverMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves this JDBC driver's minor version number.

getDriverName() - Method in interface java.sql.DatabaseMetaData

Retrieves the name of this JDBC driver.

getDrivers() - Static method in class java.sql.DriverManager

Retrieves an Enumeration with all of the currently loaded JDBC drivers to which the current caller has access.

getDriverVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the version number of this JDBC driver as a String.

getDropAction() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the logical intersection of the target drop action and the set of drop actions supported by the drag source.

getDropAction() - Method in class java.awt.dnd.DragSourceDropEvent

This method returns an int representing the action performed by the target on the subject of the drop.

getDropAction() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the user drop action.

getDropAction() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the user drop action.

getDropAction() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the action chosen for the drop, when this TransferSupport represents a drop.

getDropLineRect(JTree.DropLocation) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns a ubounding box for the drop line.

getDropLocation() - Method in class javax.swing.JList

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.JTable

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.JTree

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.text.JTextComponent

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the current (non-null) drop location for the component, when this TransferSupport represents a drop.

getDropMode() - Method in class javax.swing.JList

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.JTable

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.JTree

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.text.JTextComponent

Returns the drop mode for this component.

getDropPoint() - Method in class javax.swing.TransferHandler.DropLocation

Returns the drop point, representing the mouse's current location within the component.

getDropSuccess() - Method in class java.awt.dnd.DragSourceDropEvent

This method returns a boolean indicating if the drop was successful.

getDropTarget() - Method in class java.awt.Component

Gets the DropTarget associated with this Component.

getDropTarget() - Method in class java.awt.dnd.DropTargetContext

This method returns the DropTarget associated with this DropTargetContext.

getDropTargetContext() - Method in class java.awt.dnd.DropTarget

Gets the DropTargetContext associated with this DropTarget.

getDropTargetContext() - Method in class java.awt.dnd.DropTargetEvent

This method returns the DropTargetContext associated with this DropTargetEvent.

getDSTSavings() - Method in class java.util.SimpleTimeZone

Returns the amount of time in milliseconds that the clock is advanced during daylight saving time.

getDSTSavings() - Method in class java.util.TimeZone

Returns the amount of time to be added to local standard time to get local wall clock time.

getDTD(String) - Static method in class javax.swing.text.html.parser.DTD

Returns a DTD with the specified name.

getDTDHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current DTD handler.

getDTDHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current DTD event handler.

getDTDHandler() - Method in interface org.xml.sax.XMLReader

Return the current DTD handler.

getDTDType() - Method in interface javax.xml.stream.events.Attribute

Gets the type of this attribute, default is the String "CDATA"

getEarliestSequenceNumber() - Method in class javax.management.remote.NotificationResult

Returns the sequence number of the earliest notification still in the buffer.

getEarlyReflectionDelay() - Method in class javax.sound.sampled.ReverbType

Returns the early reflection delay time in microseconds.

getEarlyReflectionIntensity() - Method in class javax.sound.sampled.ReverbType

Returns the early reflection intensity in decibels.

getEastPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getEchoChar() - Method in class java.awt.TextField

Gets the character that is to be used for echoing.

getEchoChar() - Method in class javax.swing.JPasswordField

Returns the character to be used for echoing.

getEdgeCondition() - Method in class java.awt.image.ConvolveOp

Returns the edge condition.

getEdit() - Method in class javax.swing.event.UndoableEditEvent

Returns the edit value.

getEditFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

getEditingColumn() - Method in class javax.swing.JTable

Returns the index of the column that contains the cell currently being edited.

getEditingPath() - Method in class javax.swing.JTree

Returns the path to the element that is currently being edited.

getEditingPath(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path to the element that is being edited.

getEditingPath(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getEditingPath method on each UI handled by this object.

getEditingPath(JTree) - Method in class javax.swing.plaf.TreeUI

Returns the path to the element that is being edited.

getEditingRow() - Method in class javax.swing.JTable

Returns the index of the row that contains the cell currently being edited.

getEditor() - Method in class javax.swing.JComboBox

Returns the editor used to paint and edit the selected item in the JComboBox field.

getEditor() - Method in class javax.swing.JSpinner

Returns the component that displays and potentially changes the model's value.

getEditor(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the target editor for an action.

getEditorComponent() - Method in interface javax.swing.ComboBoxEditor

Return the component that should be added to the tree hierarchy for this editor

getEditorComponent() - Method in class javax.swing.JTable

Returns the component that is handling the editing session.

getEditorComponent() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

getEditorKit() - Method in class javax.swing.JEditorPane

Fetches the currently installed kit for handling content.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI

Fetches the EditorKit for the UI.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the EditorKit for the UI.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getEditorKit method on each UI handled by this object.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.TextUI

Fetches the binding of services that set a policy for the type of document being edited.

getEditorKitClassNameForContentType(String) - Static method in class javax.swing.JEditorPane

Returns the currently registered EditorKit class name for the type type.

getEditorKitForContentType(String) - Method in class javax.swing.JEditorPane

Fetches the editor kit to use for the given type of content.

getEditorSearchPath() - Static method in class java.beans.PropertyEditorManager

Gets the package names that will be searched for property editors.

getEffectiveKeyBits() - Method in class javax.crypto.spec.RC2ParameterSpec

Returns the effective key size in bits.

getElem(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as an integer.

getElem(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as an integer.

getElem(int) - Method in class java.awt.image.DataBufferByte

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferByte

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as an int.

getElem(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as an int.

getElem(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as an int.

getElem(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as an int.

getElem(int) - Method in class java.awt.image.DataBufferInt

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferInt

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferShort

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferShort

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferUShort

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferUShort

Returns the requested data array element from the specified bank.

getElemDouble(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as a double.

getElemDouble(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as a double.

getElemDouble(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as a double.

getElement() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Returns the element represented.

getElement(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets a child element.

getElement(int) - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets a child element.

getElement() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Returns the underlying element.

getElement(int) - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets a child element.

getElement(int) - Method in interface javax.swing.text.Element

Fetches the child element at the given index.

getElement(String) - Method in class javax.swing.text.html.HTMLDocument

Returns the element that has the given id Attribute.

getElement(Element, Object, Object) - Method in class javax.swing.text.html.HTMLDocument

Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found.

getElement(String) - Method in class javax.swing.text.html.parser.DTD

Gets an element by name.

getElement(int) - Method in class javax.swing.text.html.parser.DTD

Gets an element by index.

getElement() - Method in class javax.swing.text.html.parser.TagElement

getElement() - Method in class javax.swing.text.View

Fetches the structural portion of the subject that this view is mapped to.

getElement(ResultT) - Method in interface javax.xml.bind.annotation.DomHandler

Once the portion is sent to the Result.

getElement(DOMResult) - Method in class javax.xml.bind.annotation.W3CDomHandler

getElementAt(int) - Method in class javax.swing.DefaultComboBoxModel

getElementAt(int) - Method in class javax.swing.DefaultListModel

Returns the component at the specified index.

getElementAt(int) - Method in interface javax.swing.ListModel

Returns the value at the specified index.

getElementAt(int) - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getElementAt(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getElementAt(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getElementById(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

Returns the Element with the specified ID attribute value.

getElementById(String) - Method in interface org.w3c.dom.Document

Returns the Element that has an ID attribute with the given value.

getElementCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the number of children for the element.

getElementCount() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the number of children for the element.

getElementCount() - Method in class javax.swing.text.AbstractDocument.LeafElement

Returns the number of child elements.

getElementCount() - Method in interface javax.swing.text.Element

Gets the number of child elements contained by this element.

getElementDescription(String, Locale) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns a String containing a description of the named element, or null.

getElementDescription(String, Locale) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns a String containing a description of the named element, or null.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in interface javax.swing.text.Element

Gets the child element index closest to the given offset.

getElementIterator() - Method in class javax.swing.text.AbstractWriter

Fetches the ElementIterator.

getElementMaxChildren(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of children of the named element with child policy CHILD_POLICY_REPEAT.

getElementMaxChildren(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getElementMinChildren(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of children of the named element with child policy CHILD_POLICY_REPEAT.

getElementMinChildren(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getElementName(Object) - Method in class javax.xml.bind.JAXBIntrospector

Get xml element qname for jaxbElement.

getElementName() - Method in interface javax.xml.soap.SOAPElement

Returns the name of this SOAPElement object.

getElementOpenType() - Method in class javax.management.openmbean.ArrayType

Returns the open type of element values contained in the arrays described by this ArrayType instance.

getElementQName() - Method in interface javax.xml.soap.SOAPElement

Returns the qname of this SOAPElement object.

getElements() - Method in class javax.swing.ButtonGroup

Returns all the buttons that are participating in this group.

getElements(Vector<Element>) - Method in class javax.swing.text.html.parser.ContentModel

Update elemVec with the list of elements that are part of the this contentModel.

getElementsAnnotatedWith(TypeElement) - Method in interface javax.annotation.processing.RoundEnvironment

Returns the elements annotated with the given annotation type.

getElementsAnnotatedWith(Class<? extends Annotation>) - Method in interface javax.annotation.processing.RoundEnvironment

Returns the elements annotated with the given annotation type.

getElementsAt(HTMLDocument, int) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

Returns an array of the Elements that contain offset.

getElementsByTagName(String) - Method in class javax.imageio.metadata.IIOMetadataNode

getElementsByTagName(String) - Method in interface org.w3c.dom.Document

Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.

getElementsByTagName(String) - Method in interface org.w3c.dom.Element

Returns a NodeList of all descendant Elements with a given tag name, in document order.

getElementsByTagNameNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getElementsByTagName(localName).

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom.Document

Returns a NodeList of all the Elements with a given local name and namespace URI in document order.

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom.Element

Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.

getElementText() - Method in class javax.xml.stream.util.EventReaderDelegate

getElementText() - Method in class javax.xml.stream.util.StreamReaderDelegate

getElementText() - Method in interface javax.xml.stream.XMLEventReader

Reads the content of a text-only element.

getElementText() - Method in interface javax.xml.stream.XMLStreamReader

Reads the content of a text-only element, an exception is thrown if this is not a text-only element.

getElementTypeInfo() - Method in class javax.xml.validation.TypeInfoProvider

Returns the immutable TypeInfo object for the current element.

getElementUtils() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns an implementation of some utility methods for operating on elements

getElementValues() - Method in interface javax.lang.model.element.AnnotationMirror

Returns the values of this annotation's elements.

getElementValuesWithDefaults(AnnotationMirror) - Method in interface javax.lang.model.util.Elements

Returns the values of an annotation's elements, including defaults.

getElemFloat(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as a float.

getElemFloat(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as a float.

getElemFloat(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as a float.

getEmptySet() - Method in interface javax.swing.text.AbstractDocument.AttributeContext

Fetches an empty AttributeSet.

getEmptySet() - Method in class javax.swing.text.StyleContext

Fetches an empty AttributeSet.

getEnabledAttributes() - Method in class javax.management.AttributeChangeNotificationFilter

Gets all the enabled attribute names for this filter.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLEngine

Returns the names of the SSL cipher suites which are currently enabled for use on this engine.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLServerSocket

Returns the list of cipher suites which are currently enabled for use by newly accepted connections.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLSocket

Returns the names of the SSL cipher suites which are currently enabled for use on this connection.

getEnabledCipherSuites() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns the names of the cipher suites enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the cipher suites that are enabled by default.

getEnabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter

Gets all the ObjectNames enabled.

getEnabledProtocols() - Method in class javax.net.ssl.SSLEngine

Returns the names of the protocol versions which are currently enabled for use with this SSLEngine.

getEnabledProtocols() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the protocols which are currently enabled for use by the newly accepted connections.

getEnabledProtocols() - Method in class javax.net.ssl.SSLSocket

Returns the names of the protocol versions which are currently enabled for use on this connection.

getEnabledProtocols() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns the names of the protocol versions enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the protocol versions that are enabled by default.

getEnabledTypes() - Method in class javax.management.NotificationFilterSupport

Gets all the enabled notification types for this filter.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLEngine

Returns true if new SSL sessions may be established by this engine.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLServerSocket

Returns true if new SSL sessions may be established by the sockets which are created from this server socket.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLSocket

Returns true if new SSL sessions may be established by this socket.

getEnclosedElements() - Method in interface javax.lang.model.element.Element

Returns the elements that are, loosely speaking, directly enclosed by this element.

getEnclosedElements() - Method in interface javax.lang.model.element.TypeElement

Returns the elements that are, loosely speaking, directly enclosed by this element.

getEnclosingClass() - Method in class java.lang.类

Returns the immediately enclosing class of the underlying class.

getEnclosingConstructor() - Method in class java.lang.类

If this 类 object represents a local or anonymous class within a constructor, returns a Constructor object representing the immediately enclosing constructor of the underlying class.

getEnclosingElement() - Method in interface javax.lang.model.element.Element

Returns the innermost element within which this element is, loosely speaking, enclosed.

getEnclosingElement() - Method in interface javax.lang.model.element.PackageElement

Returns null since a package is not enclosed by another element.

getEnclosingElement() - Method in interface javax.lang.model.element.TypeElement

Returns the package of a top-level type and returns the immediately lexically enclosing element for a 嵌套 type.

getEnclosingElement() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the generic element of this type parameter.

getEnclosingMethod() - Method in class java.lang.类

If this 类 object represents a local or anonymous class within a method, returns a Method object representing the immediately enclosing method of the underlying class.

getEnclosingType() - Method in interface javax.lang.model.type.DeclaredType

Returns the type of the innermost enclosing instance or a NoType of kind NONE if there is no enclosing instance.

getEncoded() - Method in class java.security.AlgorithmParameters

Returns the parameters in their primary encoding format.

getEncoded(String) - Method in class java.security.AlgorithmParameters

Returns the parameters encoded in the specified scheme.

getEncoded() - Method in class java.security.cert.Certificate

Returns the encoded form of this certificate.

getEncoded() - Method in class java.security.cert.CertPath

Returns the encoded form of this certification path, using the default encoding.

getEncoded(String) - Method in class java.security.cert.CertPath

Returns the encoded form of this certification path, using the specified encoding.

getEncoded() - Method in class java.security.cert.PolicyQualifierInfo

Returns the ASN.1 DER encoded form of this PolicyQualifierInfo.

getEncoded() - Method in class java.security.cert.X509CRL

Returns the ASN.1 DER-encoded form of this CRL.

getEncoded() - Method in class java.security.cert.X509CRLEntry

Returns the ASN.1 DER-encoded form of this CRL Entry, that is the inner SEQUENCE.

getEncoded() - Method in interface java.security.Key

Returns the key in its primary encoding format, or null if this key does not support encoding.

getEncoded() - Method in class java.security.spec.EncodedKeySpec

Returns the encoded key.

getEncoded() - Method in class java.security.spec.PKCS8EncodedKeySpec

Returns the key bytes, encoded according to the PKCS #8 standard.

getEncoded() - Method in class java.security.spec.X509EncodedKeySpec

Returns the key bytes, encoded according to the X.509 standard.

getEncoded() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the ASN.1 encoding of this object.

getEncoded() - Method in class javax.crypto.spec.SecretKeySpec

Returns the key material of this secret key.

getEncoded() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key material of this secret key.

getEncoded() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns an ASN.1 encoding of the entire ticket.

getEncoded() - Method in class javax.security.auth.x500.X500Principal

Returns the distinguished name in ASN.1 DER encoded form.

getEncoded() - Method in class javax.security.cert.Certificate

Returns the encoded form of this certificate.

getEncodedValue() - Method in class javax.naming.ldap.BasicControl

Retrieves the control's ASN.1 BER encoded value.

getEncodedValue() - Method in interface javax.naming.ldap.Control

Retrieves the ASN.1 BER encoded value of the LDAP control.

getEncodedValue() - Method in interface javax.naming.ldap.ExtendedRequest

Retrieves the ASN.1 BER encoded value of the LDAP extended operation request.

getEncodedValue() - Method in interface javax.naming.ldap.ExtendedResponse

Retrieves the ASN.1 BER encoded value of the LDAP extended operation response.

getEncodedValue() - Method in class javax.naming.ldap.StartTlsRequest

Retrieves the StartTLS request's ASN.1 BER encoded value.

getEncodedValue() - Method in class javax.naming.ldap.StartTlsResponse

Retrieves the StartTLS response's ASN.1 BER encoded value.

getEncoding() - Method in class java.io.InputStreamReader

Returns the name of the character encoding being used by this stream.

getEncoding() - Method in class java.io.OutputStreamWriter

Returns the name of the character encoding being used by this stream.

getEncoding() - Method in class java.util.logging.Handler

Return the character encoding for this Handler.

getEncoding() - Method in class javax.sound.sampled.AudioFormat

Obtains the type of encoding for sounds in this format.

getEncoding() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current output encoding.

getEncoding() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the encoding URI of this XMLObject.

getEncoding() - Method in class javax.xml.stream.util.StreamReaderDelegate

getEncoding() - Method in interface javax.xml.stream.XMLStreamReader

Return input encoding if known or null if unknown.

getEncoding() - Method in interface org.w3c.dom.ls.LSInput

The character encoding, if known.

getEncoding() - Method in interface org.w3c.dom.ls.LSOutput

The character encoding to use for the output.

getEncoding() - Method in interface org.xml.sax.ext.Locator2

Returns the name of the character encoding for the entity.

getEncoding() - Method in class org.xml.sax.ext.Locator2Impl

Returns the current value of the encoding property.

getEncoding() - Method in class org.xml.sax.InputSource

Get the character encoding for a byte stream or URI.

getEncodings() - Method in class java.security.cert.CertPath

Returns an iteration of the encodings supported by this certification path, with the default encoding first.

getEncodingStyle() - Method in interface javax.xml.soap.SOAPElement

Returns the encoding style for this SOAPElement object.

getEncryptedData() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the encrypted data.

getEnd() - Method in class javax.swing.SpinnerDateModel

Returns the last Date in the sequence.

getEndCap() - Method in class java.awt.BasicStroke

Returns the end cap style.

getEndIndex() - Method in interface java.text.CharacterIterator

Returns the end index of the text.

getEndIndex() - Method in class java.text.FieldPosition

Retrieves the index of the character following the last character in the requested field.

getEndIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getEndIndex() for String.

getEndIndex() - Method in class javax.accessibility.AccessibleHyperlink

Gets the index with the hypertext document at which this link ends

getEndIndex() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Get the index with the hypertext document at which this link ends

getEndIndex() - Method in class javax.swing.text.Segment

Returns the end index of the text.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractWriter

Returns the last offset to be output.

getEndOffset() - Method in interface javax.swing.text.Element

Fetches the offset from the beginning of the document that this element ends at.

getEndOffset() - Method in class javax.swing.text.GlyphView

Fetches the portion of the model that this view is responsible for.

getEndOffset() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the ending model offset for the highlight.

getEndOffset() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Returns the end of the range for which the current occurrence of the tag is defined and has the same attributes.

getEndOffset() - Method in class javax.swing.text.View

Fetches the portion of the model for which this view is responsible.

getEndPoint() - Method in class java.awt.geom.Arc2D

Returns the ending point of the arc.

getEndPoint() - Method in class java.awt.LinearGradientPaint

Returns a copy of the end point of the gradient axis.

getEndpointIdentificationAlgorithm() - Method in class javax.net.ssl.SSLParameters

Gets the endpoint identification algorithm.

getEndpointReference() - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Class<T>) - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Class<T>, Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference for this endpoint.

getEndpointReference(Class<T>, Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference associated with this endpoint.

getEndpoints() - Method in class javax.xml.ws.EndpointContext

This gives list of endpoints in an application.

getEndPosition() - Method in class javax.swing.text.AbstractDocument

Returns a position that represents the end of the document.

getEndPosition() - Method in interface javax.swing.text.Document

Returns a position that represents the end of the document.

getEndPosition() - Method in interface javax.tools.Diagnostic

Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.

getEndTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the expiration time for this ticket's validity period.

getEngine() - Method in class javax.script.CompiledScript

Returns the ScriptEngine whose compile method created this CompiledScript.

getEngineByExtension(String) - Method in class javax.script.ScriptEngineManager

Look up and create a ScriptEngine for a given extension.

getEngineByMimeType(String) - Method in class javax.script.ScriptEngineManager

Look up and create a ScriptEngine for a given mime type.

getEngineByName(String) - Method in class javax.script.ScriptEngineManager

Looks up and creates a ScriptEngine for a given name.

getEngineFactories() - Method in class javax.script.ScriptEngineManager

Returns an array whose elements are instances of all the ScriptEngineFactory classes found by the discovery mechanism.

getEngineName() - Method in interface javax.script.ScriptEngineFactory

Returns the full name of the ScriptEngine.

getEngineVersion() - Method in interface javax.script.ScriptEngineFactory

Returns the version of the ScriptEngine.

getEntities() - Method in interface javax.xml.stream.events.DTD

Return a List containing the general entities, both external and internal, declared in the DTD.

getEntities() - Method in interface org.w3c.dom.DocumentType

A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.

getEntity(String) - Method in class javax.swing.text.html.parser.DTD

Gets an entity by name.

getEntity(int) - Method in class javax.swing.text.html.parser.DTD

Gets a character entity.

getEntityResolver() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current entity resolver.

getEntityResolver() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current entity resolver.

getEntityResolver() - Method in interface org.xml.sax.XMLReader

Return the current entity resolver.

getEntries() - Method in class java.util.jar.Manifest

Returns a Map of the entries contained in this Manifest.

getEntry(String, KeyStore.ProtectionParameter) - Method in class java.security.KeyStore

Gets a keystore Entry for the specified alias with the specified protection parameter.

getEntry(String) - Method in class java.util.jar.JarFile

Returns the ZipEntry for the given entry name or null if not found.

getEntry(String) - Method in class java.util.zip.ZipFile

Returns the zip file entry for the specified name, or null if not found.

getEntryName() - Method in class java.net.JarURLConnection

Return the entry name for this connection.

getEnumConstants() - Method in class java.lang.类

Returns the elements of this enum class or null if this Class object does not represent an enum type.

getEnumValueTable() - Method in class javax.print.attribute.EnumSyntax

Returns the enumeration value table for this enumeration value's enumeration class.

getEnumValueTable() - Method in class javax.print.attribute.standard.Chromaticity

Returns the enumeration value table for class Chromaticity.

getEnumValueTable() - Method in class javax.print.attribute.standard.ColorSupported

Returns the enumeration value table for class ColorSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.Compression

Returns the enumeration value table for class Compression.

getEnumValueTable() - Method in class javax.print.attribute.standard.DialogTypeSelection

Returns the enumeration value table for class DialogTypeSelection.

getEnumValueTable() - Method in class javax.print.attribute.standard.Fidelity

Returns the enumeration value table for class Fidelity.

getEnumValueTable() - Method in class javax.print.attribute.standard.Finishings

Returns the enumeration value table for class Finishings.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobSheets

Returns the enumeration value table for class JobSheets.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobState

Returns the enumeration value table for class JobState.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobStateReason

Returns the enumeration value table for class JobStateReason.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaName

Returns the enumeration value table for class MediaTray.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaSizeName

Returns the enumeration value table for class MediaSizeName.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaTray

Returns the enumeration value table for class MediaTray.

getEnumValueTable() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Returns the enumeration value table for class MultipleDocumentHandling.

getEnumValueTable() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the enumeration value table for class OrientationRequested.

getEnumValueTable() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Returns the enumeration value table for class PDLOverrideSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.PresentationDirection

Returns the enumeration value table for class PresentationDirection.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Returns the enumeration value table for class PrinterIsAcceptingJobs.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterState

Returns the enumeration value table for class PrinterState.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterStateReason

Returns the enumeration value table for class PrinterStateReason.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrintQuality

Returns the enumeration value table for class PrintQuality.

getEnumValueTable() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Returns the enumeration value table for class ReferenceUriSchemesSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.Severity

Returns the enumeration value table for class Severity.

getEnumValueTable() - Method in class javax.print.attribute.standard.SheetCollate

Returns the enumeration value table for class SheetCollate.

getEnumValueTable() - Method in class javax.print.attribute.standard.Sides

Returns the enumeration value table for class Sides.

getenv(String) - Static method in class java.lang.System

Gets the value of the specified environment variable.

getenv() - Static method in class java.lang.System

Returns an unmodifiable string map view of the current system environment.

getEnvelope() - Method in class javax.xml.soap.SOAPPart

Gets the SOAPEnvelope object associated with this SOAPPart object.

getEnvironment() - Method in exception javax.naming.CannotProceedException

Retrieves the environment that was in effect when this exception was created.

getEnvironment() - Method in interface javax.naming.Context

Retrieves the environment in effect for this context.

getEnvironment() - Method in class javax.naming.InitialContext

getEon() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return high order component for XML Schema 1.0 dateTime datatype field for year.

getEonAndYear() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return XML Schema 1.0 dateTime datatype field for year.

getEras() - Method in class java.text.DateFormatSymbols

Gets era strings.

getErrorCode() - Method in exception java.sql.SQLException

Retrieves the vendor-specific exception code for this SQLException object.

getErrorCode() - Method in exception javax.xml.bind.JAXBException

Get the vendor specific error code

getErrorCode() - Method in exception javax.xml.bind.TypeConstraintException

Get the vendor specific error code

getErrorHandler() - Method in class javax.xml.validation.SchemaFactory

Gets the current ErrorHandler set to this SchemaFactory.

getErrorHandler() - Method in class javax.xml.validation.Validator

Gets the current ErrorHandler set to this Validator.

getErrorHandler() - Method in class javax.xml.validation.ValidatorHandler

Gets the current ErrorHandler set to this ValidatorHandler.

getErrorHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current error handler.

getErrorHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current error event handler.

getErrorHandler() - Method in interface org.xml.sax.XMLReader

Return the current error handler.

getErrorIndex() - Method in class java.text.ParsePosition

Retrieve the index at which an error occurred, or -1 if the error index has not been set.

getErrorIndex() - Method in exception java.util.IllformedLocaleException

Returns the index where the error was found.

getErrorListener() - Method in class javax.xml.transform.Transformer

Get the error event handler in effect for the transformation.

getErrorListener() - Method in class javax.xml.transform.TransformerFactory

Get the error event handler for the TransformerFactory.

getErrorManager() - Method in class java.util.logging.Handler

Retrieves the ErrorManager for this Handler.

getErrorOffset() - Method in exception java.text.ParseException

Returns the position where the error was found.

getErrorsAny() - Method in class java.awt.MediaTracker

Returns a list of all media that have encountered an error.

getErrorsID(int) - Method in class java.awt.MediaTracker

Returns a list of media with the specified ID that have encountered an error.

getErrorStream() - Method in class java.lang.Process

Returns the input stream connected to the error output of the subprocess.

getErrorStream() - Method in class java.net.HttpURLConnection

Returns the error stream if the connection failed but the server sent useful data nonetheless.

getErrorWriter() - Method in interface javax.script.ScriptContext

Returns the Writer used to display error output.

getErrorWriter() - Method in class javax.script.SimpleScriptContext

Returns the Writer used to display error output.

getEscapeProcessing() - Method in class javax.sql.rowset.BaseRowSet

Ascertains whether escape processing is enabled for this RowSet object.

getEscapeProcessing() - Method in interface javax.sql.RowSet

Retrieves whether escape processing is enabled for this RowSet object.

getEstimatedMajorSpan() - Method in class javax.swing.text.AsyncBoxView

Is the major span currently estimated?

getEtchedBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getEtchedInsets() - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

Returns the amount of space taken up by a border drawn by drawEtchedRect()

getEtchType() - Method in class javax.swing.border.EtchedBorder

Returns which etch-type is set on the etched border.

getEventAllocator() - Method in class javax.xml.stream.XMLInputFactory

Gets the allocator used by streams created with this factory

getEventContext() - Method in class javax.naming.event.NamingEvent

Retrieves the event source that fired this event.

getEventContext() - Method in class javax.naming.event.NamingExceptionEvent

Retrieves the EventContext that fired this event.

getEventHandler() - Method in class javax.xml.bind.Binder

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Marshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Unmarshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getEventMask() - Method in class java.awt.event.AWTEventListenerProxy

Returns the event mask associated with the listener.

getEventPhase() - Method in interface org.w3c.dom.events.Event

Used to indicate which phase of event flow is currently being evaluated.

getEventPropertyName() - Method in class java.beans.EventHandler

Returns the property of the event that should be used in the action applied to the target.

getEvents() - Method in class javax.xml.bind.util.ValidationEventCollector

Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.

getEventSetDescriptors() - Method in interface java.beans.BeanInfo

Gets the beans EventSetDescriptors.

getEventSetDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of event sets.

getEventType() - Method in class javax.swing.event.HyperlinkEvent

Gets the type of event.

getEventType() - Method in interface javax.xml.stream.events.XMLEvent

Returns an integer code for this event.

getEventType() - Method in class javax.xml.stream.util.StreamReaderDelegate

getEventType() - Method in interface javax.xml.stream.XMLStreamReader

Returns an integer code that indicates the type of the event the cursor is pointing to.

getException() - Method in class java.awt.event.InvocationEvent

Returns any Exception caught while executing the Runnable's run() method.

getException() - Method in exception java.lang.ClassNotFoundException

Returns the exception that was raised if an error occurred while attempting to load the class.

getException() - Method in error java.lang.ExceptionInInitializerError

Returns the exception that occurred during a static initialization that caused this error to be created.

getException() - Method in exception java.security.PrivilegedActionException

Returns the exception thrown by the privileged computation that resulted in this PrivilegedActionException.

getException() - Method in class java.util.concurrent.ForkJoinTask

Returns the exception thrown by the base computation, or a CancellationException if cancelled, or null if none or if the method has not yet completed.

getException() - Method in class javax.naming.event.NamingExceptionEvent

Retrieves the exception that was thrown.

getException() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the NamingException appropriate for the result code.

getException() - Method in interface javax.naming.ldap.UnsolicitedNotification

Retrieves the exception as constructed using information sent by the server.

getException() - Method in error javax.xml.parsers.FactoryConfigurationError

Return the actual exception (if any) that caused this exception to be raised.

getException() - Method in error javax.xml.stream.FactoryConfigurationError

Return the nested exception (if any)

getException() - Method in exception javax.xml.transform.TransformerException

This method retrieves an exception that this exception wraps.

getException() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

Return the actual exception (if any) that caused this exception to be raised.

getException() - Method in exception org.xml.sax.SAXException

Return the embedded exception, if any.

getExceptionListener() - Method in class java.beans.Encoder

Gets the exception handler for this stream.

getExceptionListener() - Method in class java.beans.XMLDecoder

Gets the exception handler for this stream.

getExceptionTypes() - Method in class java.lang.reflect.Constructor

Returns an array of 类 objects that represent the types of exceptions declared to be thrown by the underlying constructor represented by this Constructor object.

getExceptionTypes() - Method in class java.lang.reflect.方法

Returns an array of 类 objects that represent the types of the exceptions declared to be thrown by the underlying method represented by this Method object.

getExclusiveOwnerThread() - Method in class java.util.concurrent.locks.AbstractOwnableSynchronizer

Returns the thread last set by setExclusiveOwnerThread, or null if never set.

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire in exclusive mode.

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire in exclusive mode.

getExecuteExistingDelayedTasksAfterShutdownPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether to execute existing delayed tasks even when this executor has been shutdown.

getExecutor() - Method in class javax.xml.ws.Endpoint

Returns the executor for this Endpointinstance.

getExecutor() - Method in class javax.xml.ws.Service

Returns the executor for this Serviceinstance.

getExecutor() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the executor for this Serviceinstance.

getExemptionMechanism() - Method in class javax.crypto.Cipher

Returns the exemption mechanism object used with this cipher.

getExp() - Method in exception javax.management.BadBinaryOpValueExpException

Returns the ValueExp that originated the exception.

getExpandedDescendants(TreePath) - Method in class javax.swing.JTree

Returns an Enumeration of the descendants of the path parent that are currently expanded.

getExpandedIcon() - Method in class javax.swing.plaf.basic.BasicTreeUI

getExpandedIcon() - Method in class javax.swing.plaf.synth.SynthTreeUI

getExpandedState(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns true if the path is expanded, and visible.

getExpandedState(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns true if the path is expanded, and visible.

getExpandedState(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns true if the path is expanded, and visible.

getExpandsSelectedPaths() - Method in class javax.swing.JTree

Returns the expandsSelectedPaths property.

getExpectedPolicies() - Method in interface java.security.cert.PolicyNode

Returns the set of expected policies that would satisfy this node's valid policy in the next certificate to be processed.

getExpiration() - Method in class java.net.URLConnection

Returns the value of the expires header field.

getExplanation() - Method in exception javax.naming.NamingException

Retrieves the explanation associated with this exception.

getExponent(float) - Static method in class java.lang.Math

Returns the unbiased exponent used in the representation of a float.

getExponent(double) - Static method in class java.lang.Math

Returns the unbiased exponent used in the representation of a double.

getExponent(float) - Static method in class java.lang.StrictMath

Returns the unbiased exponent used in the representation of a float.

getExponent(double) - Static method in class java.lang.StrictMath

Returns the unbiased exponent used in the representation of a double.

getExponent() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime's exponent.

getExponentSeparator() - Method in class java.text.DecimalFormatSymbols

Returns the string used to separate the mantissa from the exponent.

getExponentSize() - Method in class javax.crypto.spec.DHGenParameterSpec

Returns the size in bits of the random exponent (private value).

getExportedKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the foreign key columns that reference the given table's primary key columns (the foreign keys exported by a table).

getExpression() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns the XPath expression to be evaluated.

getExtendedCacheKeys(JComponent) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Get any extra attributes which the painter implementation would like to include in the image cache lookups.

getExtendedKeyCode() - Method in class java.awt.event.KeyEvent

Returns an extended key code for the event.

getExtendedKeyCodeForChar(int) - Static method in class java.awt.event.KeyEvent

Returns an extended key code for a unicode character.

getExtendedKeyUsage() - Method in class java.security.cert.X509Certificate

Gets an unmodifiable list of Strings representing the OBJECT IDENTIFIERs of the ExtKeyUsageSyntax field of the extended key usage extension, (OID = 2.5.29.37).

getExtendedKeyUsage() - Method in class java.security.cert.X509CertSelector

Returns the extendedKeyUsage criterion.

getExtendedState() - Method in class java.awt.Frame

Gets the state of this frame.

getExtendsBound() - Method in interface javax.lang.model.type.WildcardType

Returns the upper bound of this wildcard.

getExtension(char) - Method in class java.util.Locale

Returns the extension (or private use) value associated with the specified key, or null if there is no extension associated with the key.

getExtension() - Method in class javax.sound.sampled.AudioFileFormat.Type

Obtains the common file name extension for this file type.

getExtensionKeys() - Method in class java.util.Locale

Returns the set of extension keys associated with this locale, or the empty set if it has no extensions.

getExtensions() - Method in exception java.security.cert.CertificateRevokedException

Returns a map of X.509 extensions containing additional information about the revoked certificate, such as the Invalidity Date Extension.

getExtensions() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of filename extensions, which generally identify scripts written in the language supported by this ScriptEngine.

getExtensions() - Method in class javax.swing.filechooser.FileNameExtensionFilter

Returns the set of file name extensions files are tested against.

getExtensionValue(String) - Method in interface java.security.cert.X509Extension

Gets the DER-encoded OCTET string for the extension value (extnValue) identified by the passed-in oid String.

getExtent() - Method in interface javax.swing.BoundedRangeModel

Returns the model's extent, the length of the inner range that begins at the model's value.

getExtent() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's extent.

getExtent() - Method in class javax.swing.JSlider

Returns the "extent" from the BoundedRangeModel.

getExtentSize() - Method in class javax.swing.JViewport

Returns the size of the visible part of the view in view coordinates.

getExternalElements() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns an unmodifiable list of XMLStructures representing elements from an external namespace.

getExternalSubset(String, String) - Method in class org.xml.sax.ext.DefaultHandler2

Tells the parser that if no external subset has been declared in the document text, none should be used.

getExternalSubset(String, String) - Method in interface org.xml.sax.ext.EntityResolver2

Allows applications to provide an external subset for documents that don't explicitly define one.

getExtra() - Method in class java.util.zip.ZipEntry

Returns the extra field data for the entry, or null if none.

getExtraImageMetadataFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing the names of additional document formats, other than the native and standard formats, recognized by the getAsTree and setFromTree methods on the image metadata objects produced or consumed by this plug-in.

getExtraMetadataFormatNames() - Method in class javax.imageio.metadata.IIOMetadata

Returns an array of Strings containing the names of additional metadata formats, other than the native and standard formats, recognized by this plug-in's getAsTree, setFromTree, and mergeTree methods.

getExtraNameCharacters() - Method in interface java.sql.DatabaseMetaData

Retrieves all the "extra" characters that can be used in unquoted identifier names (those beyond a-z, A-Z, 0-9 and _).

getExtraStreamMetadataFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing the names of additional document formats, other than the native and standard formats, recognized by the getAsTree and setFromTree methods on the stream metadata objects produced or consumed by this plug-in.

getFactory() - Method in class java.util.concurrent.ForkJoinPool

Returns the factory used for constructing new workers.

getFactory() - Method in interface javax.script.ScriptEngine

Returns a ScriptEngineFactory for the class to which this ScriptEngine belongs.

getFactoryClassLocation() - Method in class javax.naming.Reference

Retrieves the location of the factory of the object to which this reference refers.

getFactoryClassName() - Method in class javax.naming.Reference

Retrieves the class name of the factory of the object to which this reference refers.

getFailedProperties() - Method in exception java.sql.SQLClientInfoException

Returns the list of client info properties that could not be set.

getFailureHandler() - Static method in class java.rmi.server.RMISocketFactory

Returns the handler for socket creation failure set by the setFailureHandler method.

getFallbackLocale(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns a Locale to be used as a fallback locale for further resource bundle searches by the ResourceBundle.getBundle factory method.

getFamily() - Method in class java.awt.Font

Returns the family name of this Font.

getFamily(Locale) - Method in class java.awt.Font

Returns the family name of this Font, localized for the specified locale.

getFault() - Method in interface javax.xml.soap.SOAPBody

Returns the SOAPFault object in this SOAPBody object.

getFault() - Method in exception javax.xml.ws.soap.SOAPFaultException

Gets the embedded SOAPFault instance.

getFaultActor() - Method in interface javax.xml.soap.SOAPFault

Gets the fault actor for this SOAPFault object.

getFaultCode() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object.

getFaultCodeAsName() - Method in interface javax.xml.soap.SOAPFault

Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.

getFaultCodeAsQName() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object as a QName object.

getFaultNode() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Node element value for this SOAPFault object.

getFaultReasonLocales() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.

getFaultReasonText(Locale) - Method in interface javax.xml.soap.SOAPFault

Returns the Reason Text associated with the given Locale.

getFaultReasonTexts() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.

getFaultRole() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Role element value for this SOAPFault object.

getFaultString() - Method in interface javax.xml.soap.SOAPFault

Gets the fault string for this SOAPFault object.

getFaultStringLocale() - Method in interface javax.xml.soap.SOAPFault

Gets the locale of the fault string for this SOAPFault object.

getFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault

Gets the Subcodes for this SOAPFault as an iterator over QNames.

getFD() - Method in class java.io.FileInputStream

Returns the FileDescriptor object that represents the connection to the actual file in the file system being used by this FileInputStream.

getFD() - Method in class java.io.FileOutputStream

Returns the file descriptor associated with this stream.

getFD() - Method in class java.io.RandomAccessFile

Returns the opaque file descriptor object associated with this stream.

getFeature(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getFeature(String) - Method in class javax.xml.parsers.DocumentBuilderFactory

Get the state of the named feature.

getFeature(String) - Method in class javax.xml.parsers.SAXParserFactory

Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.

getFeature(String) - Method in class javax.xml.transform.TransformerFactory

Look up the value of a feature.

getFeature(String) - Method in class javax.xml.validation.SchemaFactory

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.validation.Validator

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.validation.ValidatorHandler

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.xpath.XPathFactory

Get the state of the named feature.

getFeature(String, String) - Method in interface org.w3c.dom.DOMImplementation

This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.

getFeature(String, String) - Method in interface org.w3c.dom.Node

This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .

getFeature(String) - Method in class org.xml.sax.helpers.ParserAdapter

Check a parser feature flag.

getFeature(String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Look up the value of a feature.

getFeature(String) - Method in interface org.xml.sax.XMLReader

Look up the value of a feature flag.

getFeedResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's feed direction resolution in the given units.

getFeedResolutionDphi() - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's feed direction resolution in units of dphi.

getFetchDirection() - Method in interface java.sql.ResultSet

Retrieves the fetch direction for this ResultSet object.

getFetchDirection() - Method in interface java.sql.Statement

Retrieves the direction for fetching rows from database tables that is the default for result sets generated from this Statement object.

getFetchDirection() - Method in class javax.sql.rowset.BaseRowSet

Retrieves this RowSet object's current setting for the fetch direction.

getFetchSize() - Method in interface java.sql.ResultSet

Retrieves the fetch size for this ResultSet object.

getFetchSize() - Method in interface java.sql.Statement

Retrieves the number of result set rows that is the default fetch size for ResultSet objects generated from this Statement object.

getFetchSize() - Method in class javax.sql.rowset.BaseRowSet

Returns the fetch size for this RowSet object.

getField(String) - Method in class java.io.ObjectStreamClass

Get the field of this class by name.

getField(String) - Method in class java.lang.类

Returns a Field object that reflects the specified public member field of the class or interface represented by this 类 object.

getField() - Method in class java.security.spec.EllipticCurve

Returns the finite field field that this elliptic curve is over.

getField() - Method in class java.text.FieldPosition

Retrieves the field identifier.

getField(DatatypeConstants.Field) - Method in class javax.xml.datatype.Duration

Gets the value of a field.

getFieldAttribute() - Method in class java.text.FieldPosition

Returns the field identifier as an attribute constant from one of the Field subclasses.

getFieldNames() - Method in interface javax.management.Descriptor

Returns all the field names in the descriptor.

getFieldNames() - Method in class javax.management.ImmutableDescriptor

getFieldNames() - Method in class javax.management.modelmbean.DescriptorSupport

getFields() - Method in class java.io.ObjectStreamClass

Return an array of the fields of this serializable class.

getFields() - Method in class java.lang.类

Returns an array containing Field objects reflecting all the accessible public fields of the class or interface represented by this 类 object.

getFields() - Method in interface javax.management.Descriptor

Returns all of the fields contained in this descriptor as a string array.

getFields() - Method in class javax.management.ImmutableDescriptor

getFields() - Method in class javax.management.modelmbean.DescriptorSupport

getFields() - Method in class javax.sql.rowset.serial.SerialJavaObject

Returns an array of Field objects that contains each field of the object that this helper class is serializing.

getFields(int) - Method in class javax.swing.text.InternationalFormatter

Returns the Format.Field constants associated with the text at offset.

getFieldSize() - Method in interface java.security.spec.ECField

Returns the field size in bits.

getFieldSize() - Method in class java.security.spec.ECFieldF2m

Returns the field size in bits which is m for this characteristic 2 finite field.

getFieldSize() - Method in class java.security.spec.ECFieldFp

Returns the field size in bits which is size of prime p for this prime finite field.

getFieldValue(String) - Method in interface javax.management.Descriptor

Returns the value for a specific field name, or null if no value is present for that name.

getFieldValue(String) - Method in class javax.management.ImmutableDescriptor

getFieldValue(String) - Method in class javax.management.modelmbean.DescriptorSupport

getFieldValues(String...) - Method in interface javax.management.Descriptor

Returns all the field values in the descriptor as an array of Objects.

getFieldValues(String...) - Method in class javax.management.ImmutableDescriptor

getFieldValues(String...) - Method in class javax.management.modelmbean.DescriptorSupport

getFile() - Method in class java.awt.FileDialog

Gets the selected file of this file dialog.

getFile() - Method in class java.net.URL

Gets the file name of this URL.

getFile() - Method in exception java.nio.file.FileSystemException

Returns the file used to create this exception.

getFile() - Method in class javax.activation.FileDataSource

Return the File object that corresponds to this FileDataSource.

getFileAttributeView(Path, Class<V>, LinkOption...) - Static method in class java.nio.file.Files

Returns a file attribute view of a given type.

getFileAttributeView(Class<V>) - Method in interface java.nio.file.SecureDirectoryStream

Returns a new file attribute view to access the file attributes of this directory.

getFileAttributeView(T, Class<V>, LinkOption...) - Method in interface java.nio.file.SecureDirectoryStream

Returns a new file attribute view to access the file attributes of a file in this directory.

getFileAttributeView(Path, Class<V>, LinkOption...) - Method in class java.nio.file.spi.FileSystemProvider

Returns a file attribute view of a given type.

getFileChooser() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileChooserDetailViewIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserHomeFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserListViewIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserNewFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserUpFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileDescriptor() - Method in class java.net.DatagramSocketImpl

Gets the datagram socket file descriptor.

getFileDescriptor() - Method in class java.net.SocketImpl

Returns the value of this socket's fd field.

getFileFilter() - Method in class javax.swing.JFileChooser

Returns the currently selected file filter.

getFileForInput(JavaFileManager.Location, String, String) - Method in class javax.tools.ForwardingJavaFileManager

getFileForInput(JavaFileManager.Location, String, String) - Method in interface javax.tools.JavaFileManager

Gets a file object for input representing the specified relative name in the specified package in the given location.

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in class javax.tools.ForwardingJavaFileManager

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in interface javax.tools.JavaFileManager

Gets a file object for output representing the specified relative name in the specified package in the given location.

getFileName() - Method in class java.awt.JobAttributes

Specifies the file name for the output file for jobs using these attributes.

getFileName() - Method in class java.lang.StackTraceElement

Returns the name of the source file containing the execution point represented by this stack trace element.

getFileName() - Method in interface java.nio.file.Path

Returns the name of the file or directory denoted by this path as a Path object.

getFileName() - Method in exception javax.script.ScriptException

Get the source of the script causing the error.

getFileName() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileName() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getFilenameFilter() - Method in class java.awt.FileDialog

Determines this file dialog's filename filter.

getFileNameMap() - Static method in class java.net.URLConnection

Loads filename map (a mimetable) from a data file.

getFilePointer() - Method in class java.io.RandomAccessFile

Returns the current offset in this file.

getFiler() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the filer used to create new source, class, or auxiliary files.

getFiles() - Method in class java.awt.FileDialog

Returns files that the user selects.

getFiles(File, boolean) - Method in class javax.swing.filechooser.FileSystemView

Gets the list of shown (i.e.

getFiles() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getFileSelectionMode() - Method in class javax.swing.JFileChooser

Returns the current file-selection mode.

getFileStore(Path) - Static method in class java.nio.file.Files

Returns the FileStore representing the file store where a file is located.

getFileStore(Path) - Method in class java.nio.file.spi.FileSystemProvider

Returns the FileStore representing the file store where a file is located.

getFileStoreAttributeView(Class<V>) - Method in class java.nio.file.FileStore

Returns a FileStoreAttributeView of the given type.

getFileStores() - Method in class java.nio.file.FileSystem

Returns an object to iterate over the underlying file stores.

getFileSuffixes() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing a list of file suffixes associated with the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getFileSystem(URI) - Static method in class java.nio.file.FileSystems

Returns a reference to an existing FileSystem.

getFileSystem() - Method in interface java.nio.file.Path

Returns the file system that created this object.

getFileSystem(URI) - Method in class java.nio.file.spi.FileSystemProvider

Returns an existing FileSystem created by this provider.

getFileSystemView() - Static method in class javax.swing.filechooser.FileSystemView

getFileSystemView() - Method in class javax.swing.JFileChooser

Returns the file system view.

getFileView() - Method in class javax.swing.JFileChooser

Returns the current file view.

getFileView(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileView(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getFileView(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getFileView method on each UI handled by this object.

getFillsViewportHeight() - Method in class javax.swing.JTable

Returns whether or not this table is always made large enough to fill the height of an enclosing viewport.

getFilter() - Method in class java.util.logging.Handler

Get the current Filter for this Handler.

getFilter() - Method in class java.util.logging.Logger

Get the current filter for this Logger.

getFilter() - Method in interface javax.sql.rowset.FilteredRowSet

Retrieves the active filter for this FilteredRowSet object.

getFilter() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns the filter operation.

getFilter() - Method in interface org.w3c.dom.ls.LSParser

When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

getFilter() - Method in interface org.w3c.dom.ls.LSSerializer

When the application provides a filter, the serializer will call out to the filter before serializing each Node.

getFilterInstance(ImageConsumer) - Method in class java.awt.image.ImageFilter

Returns a unique instance of an ImageFilter object which will actually perform the filtering for the specified ImageConsumer.

getFirst() - Method in class java.util.ArrayDeque

getFirst() - Method in class java.util.concurrent.ConcurrentLinkedDeque

getFirst() - Method in class java.util.concurrent.LinkedBlockingDeque

getFirst() - Method in interface java.util.Deque

Retrieves, but does not remove, the first element of this deque.

getFirst() - Method in class java.util.LinkedList

Returns the first element in this list.

getFirstChild() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the first child of this node, or null if the node has no children.

getFirstChild() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's first child.

getFirstChild() - Method in interface org.w3c.dom.Node

The first child of this node.

getFirstColumn() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the first column that changed.

getFirstColumn() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getFirstComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class javax.swing.DefaultFocusManager

getFirstComponent(Container) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstDayOfWeek() - Method in class java.util.Calendar

Gets what the first day of the week is; e.g., SUNDAY in the U.S., MONDAY in France.

getFirstIndex() - Method in class javax.swing.event.ListSelectionEvent

Returns the index of the first row whose selection may have changed.

getFirstLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.

getFirstLineIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the first line indent setting.

getFirstQueuedThread() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns the first (longest-waiting) thread in the queue, or null if no threads are currently queued.

getFirstQueuedThread() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns the first (longest-waiting) thread in the queue, or null if no threads are currently queued.

getFirstRow() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the first row that changed.

getFirstRow() - Method in class javax.swing.event.TableModelEvent

Returns the first row that changed.

getFirstRow() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getFirstVisibleIndex() - Method in class javax.swing.JList

Returns the smallest list index that is currently visible.

getFixedCellHeight() - Method in class javax.swing.JList

Returns the value of the fixedCellHeight property.

getFixedCellWidth() - Method in class javax.swing.JList

Returns the value of the fixedCellWidth property.

getFixedRate(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

getFixedRate(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

getFlags() - Method in exception java.util.DuplicateFormatFlagsException

Returns the set of flags which contains a duplicate flag.

getFlags() - Method in exception java.util.FormatFlagsConversionMismatchException

Returns the incompatible flag.

getFlags() - Method in exception java.util.IllegalFormatFlagsException

Returns the set of flags which contains an illegal combination.

getFlags() - Method in exception java.util.UnknownFormatFlagsException

Returns the set of flags which contains an unknown flag.

getFlags() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the flags associated with this ticket.

getFlatness(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom.CubicCurve2D

Returns the flatness of the cubic curve specified by the indicated control points.

getFlatness(double[], int) - Static method in class java.awt.geom.CubicCurve2D

Returns the flatness of the cubic curve specified by the control points stored in the indicated array at the indicated index.

getFlatness() - Method in class java.awt.geom.CubicCurve2D

Returns the flatness of this curve.

getFlatness() - Method in class java.awt.geom.FlatteningPathIterator

Returns the flatness of this iterator.

getFlatness(double, double, double, double, double, double) - Static method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the indicated control points.

getFlatness(double[], int) - Static method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the control points stored in the indicated array at the indicated index.

getFlatness() - Method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of this QuadCurve2D.

getFlatnessSq(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of the cubic curve specified by the indicated control points.

getFlatnessSq(double[], int) - Static method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of the cubic curve specified by the control points stored in the indicated array at the indicated index.

getFlatnessSq() - Method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of this curve.

getFlatnessSq(double, double, double, double, double, double) - Static method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the indicated control points.

getFlatnessSq(double[], int) - Static method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the control points stored in the indicated array at the indicated index.

getFlatnessSq() - Method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of this QuadCurve2D.

getFlavorListeners() - Method in class java.awt.datatransfer.Clipboard

Returns an array of all the FlavorListeners currently registered on this Clipboard.

getFlavorMap() - Method in class java.awt.dnd.DragSource

This method returns the FlavorMap for this DragSource.

getFlavorMap() - Method in class java.awt.dnd.DropTarget

Gets the FlavorMap associated with this DropTarget.

getFlavorsForNative(String) - Method in interface java.awt.datatransfer.FlavorTable

Returns a List of DataFlavors to which the specified String corresponds.

getFlavorsForNative(String) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a List of DataFlavors to which the specified String native can be translated by the data transfer subsystem.

getFlavorsForNatives(String[]) - Method in interface java.awt.datatransfer.FlavorMap

Returns a Map of the specified String natives to their corresponding DataFlavor.

getFlavorsForNatives(String[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a Map of the specified String natives to their most preferred DataFlavor.

getFlipContents() - Method in class java.awt.BufferCapabilities

getFloat(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a float.

getFloat(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type float or of another primitive type convertible to type float via a widening conversion.

getFloat() - Method in class java.nio.ByteBuffer

Relative get method for reading a float value.

getFloat(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a float value.

getFloat(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC FLOAT parameter as a float in the Java programming language.

getFloat(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC FLOAT parameter as a float in the Java programming language.

getFloat(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a float in the Java programming language.

getFloat(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a float in the Java programming language.

getFloat(String, float) - Method in class java.util.prefs.AbstractPreferences

Implements the getFloat method as per the specification in Preferences.getFloat(String,float).

getFloat(String, float) - Method in class java.util.prefs.Preferences

Returns the float value represented by the string associated with the specified key in this preference node.

getFloatingColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI

Gets the color displayed when over a floating area

getFloatParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a float.

getFlowAxis() - Method in class javax.swing.text.FlowView

Fetches the axis along which views should be flowed.

getFlowSpan(int) - Method in class javax.swing.text.FlowView

Fetch the constraining span to flow against for the given child index.

getFlowSpan(int) - Method in class javax.swing.text.ParagraphView

Fetches the constraining span to flow against for the given child index.

getFlowStart(int) - Method in class javax.swing.text.FlowView

Fetch the location along the flow axis that the flow span will start at.

getFlowStart(int) - Method in class javax.swing.text.ParagraphView

Fetches the location along the flow axis that the flow span will start at.

getFlushedPosition() - Method in interface javax.imageio.stream.ImageInputStream

Returns the earliest position in the stream to which seeking may be performed.

getFlushedPosition() - Method in class javax.imageio.stream.ImageInputStreamImpl

getFocusableWindowState() - Method in class java.awt.Window

Returns whether this Window can become the focused Window if it meets the other requirements outlined in isFocusableWindow.

getFocusAccelerator() - Method in class javax.swing.text.JTextComponent

Returns the key accelerator that will cause the receiving text component to get the focus.

getFocusColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getFocusColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getFocusColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the focus color of the current theme.

getFocusColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getFocusColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the focus color.

getFocusColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getFocusCycleRootAncestor() - Method in class java.awt.Component

Returns the Container which is the focus cycle root of this Component's focus traversal cycle.

getFocusCycleRootAncestor() - Method in class java.awt.Window

Always returns null because Windows have no ancestors; they represent the top of the Component hierarchy.

getFocusCycleRootAncestor() - Method in class javax.swing.JInternalFrame

Always returns null because JInternalFrames must always be roots of a focus traversal cycle.

getFocusedComponent() - Method in class javax.swing.text.TextAction

Fetches the text component that currently has focus.

getFocusedWindow() - Method in class java.awt.KeyboardFocusManager

Returns the focused Window, if the focused Window is in the same context as the calling thread.

getFocusIndex() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the index of the tab that has focus.

getFocusListeners() - Method in class java.awt.Component

Returns an array of all the focus listeners registered on this component.

getFocusLostBehavior() - Method in class javax.swing.JFormattedTextField

Returns the behavior when focus is lost.

getFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the focus owner, if the focus owner is in the same context as the calling thread.

getFocusOwner() - Method in class java.awt.Window

Returns the child Component of this Window that has focus if this Window is focused; returns null otherwise.

getFocusOwner() - Method in class javax.swing.JInternalFrame

If this JInternalFrame is active, returns the child that has focus.

getFocusPoint() - Method in class java.awt.RadialGradientPaint

Returns a copy of the focus point of the radial gradient.

getFocusTraversalKeys(int) - Method in class java.awt.Component

Returns the Set of focus traversal keys for a given traversal operation for this Component.

getFocusTraversalKeys(int) - Method in class java.awt.Container

Returns the Set of focus traversal keys for a given traversal operation for this Container.

getFocusTraversalKeys(int) - Method in class java.awt.Window

Gets a focus traversal key for this Window.

getFocusTraversalKeysEnabled() - Method in class java.awt.Component

Returns whether focus traversal keys are enabled for this Component.

getFocusTraversalPolicy() - Method in class java.awt.Container

Returns the focus traversal policy that will manage keyboard traversal of this Container's children, or null if this Container is not a focus cycle root.

getFollowRedirects() - Static method in class java.net.HttpURLConnection

Returns a boolean indicating whether or not HTTP redirects (3xx) should be automatically followed.

getFont() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Font of this object.

getFont() - Method in class java.awt.Component

Gets the font of this component.

getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Static method in class java.awt.Font

Returns a Font appropriate to the attributes.

getFont(String) - Static method in class java.awt.Font

Returns a Font object from the system properties list.

getFont(String, Font) - Static method in class java.awt.Font

Gets the specified Font from the system properties list.

getFont() - Method in class java.awt.font.GlyphVector

Returns the Font associated with this GlyphVector.

getFont() - Method in class java.awt.FontMetrics

Gets the Font described by this FontMetrics object.

getFont() - Method in class java.awt.Graphics

Gets the current font.

getFont() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the Font of this object.

getFont() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Font of this object.

getFont() - Method in class java.awt.MenuComponent

Gets the font used for this menu component.

getFont() - Method in interface java.awt.MenuContainer

getFont() - Method in interface javax.accessibility.AccessibleComponent

Gets the Font of this object.

getFont(Component) - Method in class javax.swing.border.TitledBorder

getFont() - Method in class javax.swing.DebugGraphics

Returns the Font used for text drawing operations.

getFont() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getFont() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Font of this object.

getFont() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getFont(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the Font for the specified state.

getFont() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFont(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the font from an attribute set.

getFont() - Method in class javax.swing.text.GlyphView

Fetch the font that the glyphs should be based upon.

getFont(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the font to use for the given set of attributes.

getFont() - Method in class javax.swing.text.LabelView

Fetches the font that the glyphs should be based upon.

getFont(AttributeSet) - Method in class javax.swing.text.StyleContext

Gets the font from an attribute set.

getFont(String, int, int) - Method in class javax.swing.text.StyleContext

Gets a new font.

getFont(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a font specification.

getFont() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

getFont() - Method in class javax.swing.tree.DefaultTreeCellEditor

Gets the font used for editing.

getFont() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Gets the font of this component.

getFont(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Font return it, otherwise return null.

getFont(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Font return it, otherwise return null.

getFont(Object) - Static method in class javax.swing.UIManager

Returns a font from the defaults.

getFont(Object, Locale) - Static method in class javax.swing.UIManager

Returns a font from the defaults that is appropriate for the given locale.

getFontFamily(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the font family setting from the attribute list.

getFontForState(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

getFontForState(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the font for the specified state.

getFontList() - Method in class java.awt.Toolkit

Deprecated.
see GraphicsEnvironment.getAvailableFontFamilyNames()

getFontMetrics(Font) - Method in class java.awt.Component.AccessibleAWTComponent

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.Component

Gets the font metrics for the specified font.

getFontMetrics() - Method in class java.awt.Graphics

Gets the font metrics of the current font.

getFontMetrics(Font) - Method in class java.awt.Graphics

Gets the font metrics for the specified font.

getFontMetrics(Font) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.Toolkit

Deprecated.
As of JDK version 1.2, replaced by the Font method getLineMetrics.

getFontMetrics(Font) - Method in interface javax.accessibility.AccessibleComponent

Gets the FontMetrics of this object.

getFontMetrics() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getFontMetrics.

getFontMetrics(Font) - Method in class javax.swing.DebugGraphics

Overrides Graphics.getFontMetrics.

getFontMetrics(Font) - Method in class javax.swing.JComponent

Gets the FontMetrics for the specified Font.

getFontMetrics(Font) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getFontMetrics(Font) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getFontMetrics() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getFontMetrics() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getFontMetrics(Font) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFontMetrics() - Method in class javax.swing.text.FieldView

Fetches the font metrics associated with the component hosting this view.

getFontMetrics() - Method in class javax.swing.text.LabelView

Deprecated.
FontMetrics are not used for glyph rendering when running in the JDK.

getFontMetrics(Font) - Method in class javax.swing.text.StyleContext

Returns font metrics for a font.

getFontName() - Method in class java.awt.Font

Returns the font face name of this Font.

getFontName(Locale) - Method in class java.awt.Font

Returns the font face name of the Font, localized for the specified locale.

getFontPeer(String, int) - Method in class java.awt.Toolkit

Deprecated.
see java.awt.GraphicsEnvironment#getAllFonts

getFontRenderContext() - Method in class java.awt.font.GlyphVector

Returns the FontRenderContext associated with this GlyphVector.

getFontRenderContext() - Method in class java.awt.FontMetrics

Gets the FontRenderContext used by this FontMetrics object to measure text.

getFontRenderContext() - Method in class java.awt.Graphics2D

Get the rendering context of the Font within this Graphics2D context.

getFontSize(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the font size setting from the attribute list.

getFontTable(int) - Method in interface java.awt.font.OpenType

Returns the table as an array of bytes for a specified tag.

getFontTable(String) - Method in interface java.awt.font.OpenType

Returns the table as an array of bytes for a specified tag.

getFontTable(int, int, int) - Method in interface java.awt.font.OpenType

Returns a subset of the table as an array of bytes for a specified tag.

getFontTable(String, int, int) - Method in interface java.awt.font.OpenType

Returns a subset of the table as an array of bytes for a specified tag.

getFontTableSize(int) - Method in interface java.awt.font.OpenType

Returns the size of the table for a specified tag.

getFontTableSize(String) - Method in interface java.awt.font.OpenType

Returns the size of the table for a specified tag.

getForeground() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the foreground color of this object.

getForeground() - Method in class java.awt.Component

Gets the foreground color of this component.

getForeground() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the foreground color of this object.

getForeground() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the foreground color of this object.

getForeground() - Method in interface javax.accessibility.AccessibleComponent

Gets the foreground color of this object.

getForeground() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getForeground() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the foreground color of this object.

getForeground() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the foreground color of this object.

getForeground() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getForeground(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the foreground color from an attribute set.

getForeground() - Method in class javax.swing.text.GlyphView

Fetch the foreground color to use to render the glyphs.

getForeground(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Takes a set of attributes and turn it into a foreground color specification.

getForeground() - Method in class javax.swing.text.LabelView

Fetches the foreground color to use to render the glyphs.

getForeground(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the foreground color setting from the attribute list.

getForeground(AttributeSet) - Method in class javax.swing.text.StyleContext

Takes a set of attributes and turn it into a foreground color specification.

getForeground(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a foreground color specification.

getForegroundAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab foreground color at index.

getForegroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext.

getFormat() - Method in interface java.security.Certificate

Deprecated.

Returns the name of the coding format.

getFormat() - Method in interface java.security.Key

Returns the name of the primary encoding format of this key, or null if this key does not support encoding.

getFormat() - Method in class java.security.spec.EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class java.security.spec.PKCS8EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class java.security.spec.X509EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class javax.crypto.spec.SecretKeySpec

Returns the name of the encoding format for this secret key.

getFormat() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the name of the encoding format for this secret key.

getFormat() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the format of the audio data contained in the audio file.

getFormat() - Method in class javax.sound.sampled.AudioInputStream

Obtains the audio format of the sound data in this audio input stream.

getFormat() - Method in interface javax.sound.sampled.DataLine

Obtains the current format (encoding, sample rate, number of channels, etc.) of the data line's audio data.

getFormat() - Method in class javax.swing.JSpinner.DateEditor

Returns the java.text.SimpleDateFormat object the JFormattedTextField uses to parse and format numbers.

getFormat() - Method in class javax.swing.JSpinner.NumberEditor

Returns the java.text.DecimalFormat object the JFormattedTextField uses to parse and format numbers.

getFormat() - Method in class javax.swing.text.InternationalFormatter

Returns the format that dictates the legal values that can be edited and displayed.

getFormatId() - Method in interface javax.transaction.xa.Xid

Obtain the format identifier part of the XID.

getFormatName() - Method in class javax.imageio.ImageReader

Returns a String identifying the format of the input source.

getFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing human-readable names for the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getFormats() - Method in class java.text.ChoiceFormat

Get the formats passed in the constructor.

getFormats() - Method in class java.text.MessageFormat

Gets the formats used for the format elements in the previously set pattern string.

getFormats(String) - Method in class java.util.ResourceBundle.Control

Returns a List of Strings containing formats to be used to load resource bundles for the given baseName.

getFormats() - Method in class javax.sound.sampled.DataLine.Info

Obtains a set of audio formats supported by the data line.

getFormatsByArgumentIndex() - Method in class java.text.MessageFormat

Gets the formats used for the values passed into format methods or returned from parse methods.

getFormatSpecifier() - Method in exception java.util.MissingFormatArgumentException

Returns the unmatched format specifier.

getFormatSpecifier() - Method in exception java.util.MissingFormatWidthException

Returns the format specifier which does not have a width.

getFormattedTextField() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Returns the current JFormattedTextField the AbstractFormatter is installed on.

getFormatter() - Method in class java.util.logging.Handler

Return the Formatter for this Handler.

getFormatter(JFormattedTextField) - Method in class javax.swing.JFormattedTextField.AbstractFormatterFactory

Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.

getFormatter() - Method in class javax.swing.JFormattedTextField

Returns the AbstractFormatter that is used to format and parse the current value.

getFormatter(JFormattedTextField) - Method in class javax.swing.text.DefaultFormatterFactory

Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.

getFormatterFactory() - Method in class javax.swing.JFormattedTextField

Returns the current AbstractFormatterFactory.

getFractionalMetricsHint() - Method in class java.awt.font.FontRenderContext

Return the text fractional metrics rendering mode hint used in this FontRenderContext.

getFractionalSecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return fractional seconds.

getFractions() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the array of floats used by this gradient to calculate color distribution.

getFragment() - Method in class java.net.URI

Returns the decoded fragment component of this URI.

getFrame() - Method in class java.awt.geom.RectangularShape

Returns the framing Rectangle2D that defines the overall shape of this object.

getFrameCount() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the number of frames for the complete animation loop used by an indeterminate JProgessBar.

getFrameForComponent(Component) - Static method in class javax.swing.JOptionPane

Returns the specified component's Frame.

getFrameIcon() - Method in class javax.swing.JInternalFrame

Returns the image displayed in the title bar of this internal frame (usually in the top-left corner).

getFrameLength() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the length of the audio data contained in the file, expressed in sample frames.

getFrameLength() - Method in class javax.sound.sampled.AudioInputStream

Obtains the length of the stream, expressed in sample frames rather than bytes.

getFrameLength() - Method in interface javax.sound.sampled.Clip

Obtains the media length in sample frames.

getFramePosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in sample frames.

getFramePosition() - Method in class javax.sound.sampled.LineEvent

Obtains the position in the line's audio data when the event occurred, expressed in sample frames.

getFrameRate() - Method in class javax.sound.sampled.AudioFormat

Obtains the frame rate in frames per second.

getFrames() - Static method in class java.awt.Frame

Returns an array of all Frames created by this application.

getFrameSize() - Method in class javax.sound.sampled.AudioFormat

Obtains the frame size in bytes.

getFreeSpace() - Method in class java.io.File

Returns the number of unallocated bytes in the partition named by this abstract path name.

getFromIndex() - Method in class javax.swing.event.TableColumnModelEvent

Returns the fromIndex.

getFromPage() - Method in class java.awt.JobAttributes

Returns, for jobs using these attributes, the first page to be printed, if a range of pages is to be printed.

getFrontBufferCapabilities() - Method in class java.awt.BufferCapabilities

getFullScreenWindow() - Method in class java.awt.GraphicsDevice

Returns the Window object representing the full-screen window if the device is in full-screen mode.

getFunctionColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given catalog's system or user function parameters and return type.

getFunctions(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the system and user functions available in the given catalog.

getG() - Method in interface java.security.interfaces.DSAParams

Returns the base, g.

getG() - Method in class java.security.spec.DSAParameterSpec

Returns the base g.

getG() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the base g.

getG() - Method in class java.security.spec.DSAPublicKeySpec

Returns the base g.

getG() - Method in class javax.crypto.spec.DHParameterSpec

Returns the base generator g.

getG() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the base generator g.

getG() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the base generator g.

getGamma() - Method in class java.awt.color.ICC_ProfileGray

Returns a gamma value representing the tone reproduction curve (TRC).

getGamma(int) - Method in class java.awt.color.ICC_ProfileRGB

Returns a gamma value representing the tone reproduction curve (TRC) for a particular component.

getGarbageCollectorMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of GarbageCollectorMXBean objects in the Java virtual machine.

getGeneratedKeys() - Method in interface java.sql.Statement

Retrieves any auto-generated keys created as a result of executing this Statement object.

getGenerator() - Method in class java.security.spec.ECParameterSpec

Returns the generator which is also known as the base point.

getGenericComponentType() - Method in interface java.lang.reflect.GenericArrayType

Returns a Type object representing the component type of this array.

getGenericDeclaration() - Method in interface java.lang.reflect.TypeVariable

Returns the GenericDeclaration object representing the generic declaration declared this type variable.

getGenericElement() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the generic class, interface, method, or constructor that is parameterized by this type parameter.

getGenericExceptionTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Type objects that represent the exceptions declared to be thrown by this Constructor object.

getGenericExceptionTypes() - Method in class java.lang.reflect.方法

Returns an array of Type objects that represent the exceptions declared to be thrown by this Method object.

getGenericInterfaces() - Method in class java.lang.类

Returns the Types representing the interfaces directly implemented by the class or interface represented by this object.

getGenericParameterTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Type objects that represent the formal parameter types, in declaration order, of the method represented by this Constructor object.

getGenericParameterTypes() - Method in class java.lang.reflect.方法

Returns an array of Type objects that represent the formal parameter types, in declaration order, of the method represented by this Method object.

getGenericReturnType() - Method in class java.lang.reflect.方法

Returns a Type object that represents the formal return type of the method represented by this Method object.

getGenericSuperclass() - Method in class java.lang.类

Returns the Type representing the direct superclass of the entity (class, interface, primitive type or void) represented by this 类.

getGenericType() - Method in class java.lang.reflect.字段

Returns a Type object that represents the declared type for the field represented by this Field object.

getGestureModifiers() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns an int representing the current state of the input device modifiers associated with the user's gesture.

getGestureModifiersEx() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns an int representing the current state of the input device extended modifiers associated with the user's gesture.

getGetListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to access the registered event listeners.

getGlassPane() - Method in class javax.swing.JApplet

Returns the glassPane object for this applet.

getGlassPane() - Method in class javax.swing.JDialog

Returns the glassPane object for this dialog.

getGlassPane() - Method in class javax.swing.JFrame

Returns the glassPane object for this frame.

getGlassPane() - Method in class javax.swing.JInternalFrame

Returns the glass pane for this internal frame.

getGlassPane() - Method in class javax.swing.JLayer

Returns the JLayer's glassPane component or null.

getGlassPane() - Method in class javax.swing.JRootPane

Returns the current glass pane for this JRootPane.

getGlassPane() - Method in class javax.swing.JWindow

Returns the glassPane Component for this window.

getGlassPane() - Method in interface javax.swing.RootPaneContainer

Returns the glassPane.

getGlobal() - Static method in class java.util.logging.Logger

Return global logger object with the name Logger.GLOBAL_LOGGER_NAME.

getGlobalActiveWindow() - Method in class java.awt.KeyboardFocusManager

Returns the active Window, even if the calling thread is in a different context than the active Window.

getGlobalCurrentFocusCycleRoot() - Method in class java.awt.KeyboardFocusManager

Returns the current focus cycle root, even if the calling thread is in a different context than the current focus cycle root.

getGlobalFocusedWindow() - Method in class java.awt.KeyboardFocusManager

Returns the focused Window, even if the calling thread is in a different context than the focused Window.

getGlobalFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the focus owner, even if the calling thread is in a different context than the focus owner.

getGlobalPermanentFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the permanent focus owner, even if the calling thread is in a different context than the permanent focus owner.

getGlobalTransactionId() - Method in interface javax.transaction.xa.Xid

Obtain the global transaction identifier part of XID as an array of bytes.

getGlyphCharIndex(int) - Method in class java.awt.font.GlyphVector

Returns the character index of the specified glyph.

getGlyphCharIndices(int, int, int[]) - Method in class java.awt.font.GlyphVector

Returns the character indices of the specified glyphs.

getGlyphCode(int) - Method in class java.awt.font.GlyphVector

Returns the glyphcode of the specified glyph.

getGlyphCodes(int, int, int[]) - Method in class java.awt.font.GlyphVector

Returns an array of glyphcodes for the specified glyphs.

getGlyphJustificationInfo(int) - Method in class java.awt.font.GlyphVector

Returns the justification information for the glyph at the specified index into this GlyphVector.

getGlyphLogicalBounds(int) - Method in class java.awt.font.GlyphVector

Returns the logical bounds of the specified glyph within this GlyphVector.

getGlyphMetrics(int) - Method in class java.awt.font.GlyphVector

Returns the metrics of the glyph at the specified index into this GlyphVector.

getGlyphOutline(int) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of the specified glyph within this GlyphVector.

getGlyphOutline(int, float, float) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of the specified glyph within this GlyphVector, offset to x, y.

getGlyphPainter() - Method in class javax.swing.text.GlyphView

Fetch the currently installed glyph painter.

getGlyphPixelBounds(int, FontRenderContext, float, float) - Method in class java.awt.font.GlyphVector

Returns the pixel bounds of the glyph at index when this GlyphVector is rendered in a Graphics with the given FontRenderContext at the given location.

getGlyphPosition(int) - Method in class java.awt.font.GlyphVector

Returns the position of the specified glyph relative to the origin of this GlyphVector.

getGlyphPositions(int, int, float[]) - Method in class java.awt.font.GlyphVector

Returns an array of glyph positions for the specified glyphs.

getGlyphTransform(int) - Method in class java.awt.font.GlyphVector

Returns the transform of the specified glyph within this GlyphVector.

getGlyphVisualBounds(int) - Method in class java.awt.font.GlyphVector

Returns the visual bounds of the specified glyph within the GlyphVector.

getGoHomeAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getGranularityPeriod() - Method in class javax.management.monitor.Monitor

Gets the granularity period (in milliseconds).

getGranularityPeriod() - Method in interface javax.management.monitor.MonitorMBean

Gets the granularity period (in milliseconds).

getGraphics() - Method in class java.awt.Component

Creates a graphics context for this component.

getGraphics() - Method in class java.awt.image.BufferedImage

This method returns a Graphics2D, but is here for backwards compatibility.

getGraphics() - Method in class java.awt.Image

Creates a graphics context for drawing to an off-screen image.

getGraphics() - Method in class java.awt.image.VolatileImage

This method returns a Graphics2D, but is here for backwards compatibility.

getGraphics() - Method in class java.awt.PrintJob

Gets a Graphics object that will draw to the next page.

getGraphics() - Method in class javax.swing.JApplet

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JComponent

Returns this component's graphics context, which lets you draw on a component.

getGraphics() - Method in class javax.swing.JDialog

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JFrame

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JWindow

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.text.View

Fetch a Graphics for rendering.

getGraphicsConfiguration() - Method in class java.awt.Component

Gets the GraphicsConfiguration associated with this Component.

getGraphicsUtils(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the SynthGraphicUtils for the specified context.

getGreatestMinimum(int) - Method in class java.util.Calendar

Returns the highest minimum value for the given calendar field of this Calendar instance.

getGreatestMinimum(int) - Method in class java.util.GregorianCalendar

Returns the highest minimum value for the given calendar field of this GregorianCalendar instance.

getGreen() - Method in class java.awt.Color

Returns the green component in the range 0-255 in the default sRGB space.

getGreen(int) - Method in class java.awt.image.ColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.ColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.ComponentColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.ComponentColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.DirectColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.DirectColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.IndexColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreenMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the green color component.

getGreens(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of green color components into the specified array.

getGregorianChange() - Method in class java.util.GregorianCalendar

Gets the Gregorian Calendar change date.

getGridColor() - Method in class javax.swing.JTable

Returns the color used to draw grid lines.

getGridColumn() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the column of the grid location

getGridRow() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the row of the grid location

getGrooveInsets() - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

Returns the amount of space taken up by a border drawn by drawGroove()

getGroup() - Method in class javax.swing.DefaultButtonModel

Returns the group that the button belongs to.

getGroupID() - Method in class java.rmi.activation.ActivationDesc

Returns the group identifier for the object specified by this descriptor.

getGroupingSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used for thousands separator.

getGroupingSize() - Method in class java.text.DecimalFormat

Return the grouping size.

getGuarantor() - Method in interface java.security.Certificate

Deprecated.

Returns the guarantor of the certificate, that is, the principal guaranteeing that the public key associated with this certificate is that of the principal associated with this certificate.

getHAdjustable() - Method in class java.awt.ScrollPane

Returns the ScrollPaneAdjustable object which represents the state of the horizontal scrollbar.

getHandler() - Method in class javax.xml.transform.sax.SAXResult

Get the ContentHandler that is the Result.

getHandlerChain() - Method in interface javax.xml.ws.Binding

Gets a copy of the handler chain for a protocol binding instance.

getHandlerChain(PortInfo) - Method in interface javax.xml.ws.handler.HandlerResolver

Gets the handler chain for the specified port.

getHandlerResolver() - Method in class javax.xml.ws.Service

Returns the configured handler resolver.

getHandlerResolver() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the configured handler resolver.

getHandlers() - Method in class java.util.logging.Logger

Get the Handlers associated with this logger.

getHandshakeSession() - Method in class javax.net.ssl.SSLEngine

Returns the SSLSession being constructed during a SSL/TLS handshake.

getHandshakeSession() - Method in class javax.net.ssl.SSLSocket

Returns the SSLSession being constructed during a SSL/TLS handshake.

getHandshakeStatus() - Method in class javax.net.ssl.SSLEngine

Returns the current handshake status for this SSLEngine.

getHandshakeStatus() - Method in class javax.net.ssl.SSLEngineResult

Gets the handshake status of this SSLEngine operation.

getHardwareAddress() - Method in class java.net.NetworkInterface

Returns the hardware address (usually MAC) of the interface if it has one and if it can be accessed given the current privileges.

getHashColor() - Method in class javax.swing.plaf.basic.BasicTreeUI

getHead(Handler) - Method in class java.util.logging.Formatter

Return the header string for a set of formatted records.

getHead(Handler) - Method in class java.util.logging.XMLFormatter

Return the header string for a set of XML formatted records.

getHeader(String) - Method in class javax.xml.soap.MimeHeaders

Returns all of the values for the specified header as an array of String objects.

getHeader() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPHeader object for this SOAPEnvelope object.

getHeaderField(int) - Method in class java.net.HttpURLConnection

Returns the value for the nth header field.

getHeaderField(String) - Method in class java.net.URLConnection

Returns the value of the named header field.

getHeaderField(int) - Method in class java.net.URLConnection

Returns the value for the nth header field.

getHeaderFieldDate(String, long) - Method in class java.net.HttpURLConnection

getHeaderFieldDate(String, long) - Method in class java.net.URLConnection

Returns the value of the named field parsed as date.

getHeaderFieldInt(String, int) - Method in class java.net.URLConnection

Returns the value of the named field parsed as a number.

getHeaderFieldKey(int) - Method in class java.net.HttpURLConnection

Returns the key for the nth header field.

getHeaderFieldKey(int) - Method in class java.net.URLConnection

Returns the key for the nth header field.

getHeaderFieldLong(String, long) - Method in class java.net.URLConnection

Returns the value of the named field parsed as a number.

getHeaderFields() - Method in class java.net.URLConnection

Returns an unmodifiable Map of the header fields.

getHeaderRect(int) - Method in class javax.swing.table.JTableHeader

Returns the rectangle containing the header tile at column.

getHeaderRenderer() - Method in class javax.swing.table.TableColumn

Returns the TableCellRenderer used to draw the header of the TableColumn.

getHeaders() - Method in class java.net.CacheResponse

Returns the response headers as a Map.

getHeaders() - Method in interface javax.xml.ws.handler.soap.SOAPHandler

Gets the header blocks that can be processed by this Handler instance.

getHeaders(QName, JAXBContext, boolean) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets headers that have a particular qualified name from the message in the message context.

getHeaderValue() - Method in class javax.swing.table.TableColumn

Returns the Object used as the value for the header renderer.

getHeapMemoryUsage() - Method in interface java.lang.management.MemoryMXBean

Returns the current memory usage of the heap that is used for object allocation.

getHeight() - Method in class java.awt.Component

Returns the current height of this component.

getHeight() - Method in class java.awt.Dimension

Returns the height of this Dimension in double precision.

getHeight() - Method in class java.awt.DisplayMode

Returns the height of the display, in pixels.

getHeight() - Method in class java.awt.font.LineMetrics

Returns the height of the text.

getHeight() - Method in class java.awt.FontMetrics

Gets the standard height of a line of text in this font.

getHeight() - Method in class java.awt.geom.Arc2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Arc2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Dimension2D

Returns the height of this Dimension in double precision.

getHeight() - Method in class java.awt.geom.Ellipse2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Ellipse2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Rectangle2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Rectangle2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RectangularShape

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.image.BufferedImage

Returns the height of the BufferedImage.

getHeight(ImageObserver) - Method in class java.awt.image.BufferedImage

Returns the height of the BufferedImage.

getHeight(ImageObserver) - Method in class java.awt.Image

Determines the height of the image.

getHeight() - Method in class java.awt.image.Kernel

Returns the height of this Kernel.

getHeight() - Method in class java.awt.image.PixelGrabber

Get the height of the pixel buffer (after adjusting for image height).

getHeight() - Method in class java.awt.image.Raster

Returns the height in pixels of the Raster.

getHeight() - Method in interface java.awt.image.renderable.RenderableImage

Gets the height in user coordinate space.

getHeight() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the height in user coordinate space.

getHeight() - Method in interface java.awt.image.RenderedImage

Returns the height of the RenderedImage.

getHeight() - Method in class java.awt.image.SampleModel

Returns the height in pixels.

getHeight() - Method in class java.awt.image.VolatileImage

Returns the height of the VolatileImage.

getHeight() - Method in class java.awt.print.PageFormat

Returns the height, in 1/72nds of an inch, of the page.

getHeight() - Method in class java.awt.print.Paper

Returns the height of the page in 1/72nds of an inch.

getHeight() - Method in class java.awt.Rectangle

Returns the height of the bounding Rectangle in double precision.

getHeight(int) - Method in class javax.imageio.ImageReader

Returns the height in pixels of the given image within the input source.

getHeight(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the height of the printable area in the specified units.

getHeight() - Method in class javax.swing.JComponent

Returns the current height of this component.

getHeight() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the height property.

getHeight() - Method in class javax.swing.text.BoxView

Returns the current height of the box.

getHeight(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getHeightOfHighValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHeightOfLowValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHeightOfTallestLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHelpMenu() - Method in class java.awt.MenuBar

Gets the help menu on the menu bar.

getHelpMenu() - Method in class javax.swing.JMenuBar

Gets the help menu for the menu bar.

getHere() - Method in interface javax.xml.crypto.dom.DOMURIReference

Returns the here node.

getHgap() - Method in class java.awt.BorderLayout

Returns the horizontal gap between components.

getHgap() - Method in class java.awt.CardLayout

Gets the horizontal gap between components.

getHgap() - Method in class java.awt.FlowLayout

Gets the horizontal gap between components and between the components and the borders of the Container

getHgap() - Method in class java.awt.GridLayout

Gets the horizontal gap between components.

getHideActionText() - Method in class javax.swing.AbstractButton

Returns the value of the hideActionText property, which determines whether the button displays text from the Action.

getHierarchyBoundsListeners() - Method in class java.awt.Component

Returns an array of all the hierarchy bounds listeners registered on this component.

getHierarchyListeners() - Method in class java.awt.Component

Returns an array of all the hierarchy listeners registered on this component.

getHighestValue() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the biggest value that has an entry in the label table.

getHighestValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the label that corresponds to the lowest slider value in the label table.

getHighlightColor(Component) - Method in class javax.swing.border.EtchedBorder

Returns the highlight color of the etched border when rendered on the specified component.

getHighlightColor() - Method in class javax.swing.border.EtchedBorder

Returns the highlight color of the etched border.

getHighlightColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHighlightedTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the highlighted text color of the current theme.

getHighlightedTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the highlighted text color.

getHighlighter() - Method in class javax.swing.text.JTextComponent

Fetches the object responsible for making highlights.

getHighlightInnerColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the inner highlight color of the bevel border when rendered on the specified component.

getHighlightInnerColor() - Method in class javax.swing.border.BevelBorder

Returns the inner highlight color of the bevel border.

getHighlightOuterColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the outer highlight color of the bevel border when rendered on the specified component.

getHighlightOuterColor() - Method in class javax.swing.border.BevelBorder

Returns the outer highlight color of the bevel border.

getHighlights() - Method in class javax.swing.text.DefaultHighlighter

Makes a copy of the highlights.

getHighlights() - Method in interface javax.swing.text.Highlighter

Fetches the current list of highlights.

getHighThreshold() - Method in class javax.management.monitor.GaugeMonitor

Gets the high threshold value common to all observed MBeans.

getHighThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the high threshold value.

getHoldability() - Method in interface java.sql.Connection

Retrieves the current holdability of ResultSet objects created using this Connection object.

getHoldability() - Method in interface java.sql.ResultSet

Retrieves the holdability of this ResultSet object

getHoldCount() - Method in class java.util.concurrent.locks.ReentrantLock

Queries the number of holds on this lock by the current thread.

getHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock

Queries the number of holds on this write lock by the current thread.

getHomeDirectory() - Method in class javax.swing.filechooser.FileSystemView

getHonorsVisibility() - Method in class javax.swing.GroupLayout

Returns whether component visiblity is considered when sizing and positioning components.

getHorizontalAlignment() - Method in class javax.swing.AbstractButton

Returns the horizontal alignment of the icon and text.

getHorizontalAlignment() - Method in class javax.swing.JLabel

Returns the alignment of the label's contents along the X axis.

getHorizontalAlignment() - Method in class javax.swing.JTextField

Returns the horizontal alignment of the text.

getHorizontalLegBuffer() - Method in class javax.swing.plaf.basic.BasicTreeUI

The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default.

getHorizontalLegBuffer() - Method in class javax.swing.plaf.metal.MetalTreeUI

getHorizontalScrollBar() - Method in class javax.swing.JScrollPane

Returns the horizontal scroll bar that controls the viewport's horizontal view position.

getHorizontalScrollBar() - Method in class javax.swing.ScrollPaneLayout

Returns the JScrollBar object that handles horizontal scrolling.

getHorizontalScrollBarPolicy() - Method in class javax.swing.JScrollPane

Returns the horizontal scroll bar policy value.

getHorizontalScrollBarPolicy() - Method in class javax.swing.ScrollPaneLayout

Returns the horizontal scrollbar-display policy.

getHorizontalSliderThumbIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getHorizontalTextPosition() - Method in class javax.swing.AbstractButton

Returns the horizontal position of the text relative to the icon.

getHorizontalTextPosition() - Method in class javax.swing.JLabel

Returns the horizontal position of the label's text, relative to its image.

getHorizontalVisibility() - Method in class javax.swing.JTextField

Gets the visibility of the text field.

getHost() - Method in class java.net.URI

Returns the host component of this URI.

getHost() - Method in class java.net.URL

Gets the host name of this URL, if applicable.

getHost() - Method in class javax.management.remote.JMXServiceURL

The host part of the Service URL.

getHostAddress() - Method in class java.net.Inet4Address

Returns the IP address string in textual presentation form.

getHostAddress() - Method in class java.net.Inet6Address

Returns the IP address string in textual presentation.

getHostAddress() - Method in class java.net.InetAddress

Returns the IP address string in textual presentation.

getHostAddress(URL) - Method in class java.net.URLStreamHandler

Get the IP address of our host.

getHostName() - Method in class java.net.InetAddress

Gets the host name for this IP address.

getHostName() - Method in class java.net.InetSocketAddress

Gets the hostname.

getHostnameVerifier() - Method in class javax.net.ssl.HttpsURLConnection

Gets the HostnameVerifier in place on this instance.

getHostString() - Method in class java.net.InetSocketAddress

Returns the hostname, or the String form of the address if it doesn't have a hostname (it was created using a literal).

getHour() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return hours or DatatypeConstants.FIELD_UNDEFINED.

getHours() - Method in class java.sql.Date

Deprecated.

getHours() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.HOUR_OF_DAY).

getHours() - Method in class javax.xml.datatype.Duration

Obtains the value of the HOURS field as an integer value, or 0 if not present.

getHSBColor(float, float, float) - Static method in class java.awt.Color

Creates a Color object based on the specified values for the HSB color model.

getHScrollbarHeight() - Method in class java.awt.ScrollPane

Returns the height that would be occupied by a horizontal scrollbar, which is independent of whether it is currently displayed by the scroll pane or not.

getHTMLBaseline(View, int, int) - Static method in class javax.swing.plaf.basic.BasicHTML

Returns the baseline for the html renderer.

getHTMLDocument(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

getHTMLEditorKit(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

getHTMLTag() - Method in class javax.swing.text.html.parser.TagElement

getHttpContext() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a HttpContext for this exchange.

getHumanPresentableName() - Method in class java.awt.datatransfer.DataFlavor

Returns the human presentable name for the data format that this DataFlavor represents.

getHumanPresentableName() - Method in class javax.activation.ActivationDataFlavor

Return the Human Presentable name.

getHyperlinkListeners() - Method in class javax.swing.JEditorPane

Returns an array of all the HyperLinkListeners added to this JEditorPane with addHyperlinkListener().

getICC_Profiles() - Method in class java.awt.image.ColorConvertOp

Returns the array of ICC_Profiles used to construct this ColorConvertOp.

getIcon(int) - Method in interface java.beans.BeanInfo

This method returns an image object that can be used to represent the bean in toolboxes, toolbars, etc.

getIcon(int) - Method in class java.beans.SimpleBeanInfo

Claim there are no icons available.

getIcon() - Method in class javax.swing.AbstractButton

Returns the default icon.

getIcon(File) - Method in class javax.swing.filechooser.FileView

The icon that represents this file in the JFileChooser.

getIcon(File) - Method in class javax.swing.JFileChooser

Returns the icon for this file or type of file, depending on the system.

getIcon() - Method in class javax.swing.JLabel

Returns the graphic image (glyph, icon) that the label displays.

getIcon() - Method in class javax.swing.JOptionPane

Returns the icon this pane displays.

getIcon(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getIcon() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the icon from the JOptionPane the receiver is providing the look and feel for, or the default icon as returned from getDefaultIcon.

getIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the Icon to use for painting the button.

getIcon(SynthContext, Object) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is an Icon.

getIcon(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the icon setting from the attribute list.

getIcon(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Icon return it, otherwise return null.

getIcon(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Icon return it, otherwise return null.

getIcon(Object) - Static method in class javax.swing.UIManager

Returns an Icon from the defaults.

getIcon(Object, Locale) - Static method in class javax.swing.UIManager

Returns an Icon from the defaults that is appropriate for the given locale.

getIconAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab icon at index.

getIconForTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getIconForType(int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the icon to use for the passed in type.

getIconHeight() - Method in interface javax.swing.Icon

Returns the icon's height.

getIconHeight() - Method in class javax.swing.ImageIcon

Gets the height of the icon.

getIconHeight() - Method in class javax.swing.plaf.IconUIResource

getIconHeight() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getIconHeight() - Method in class javax.swing.plaf.metal.MetalComboBoxIcon

Created a stub to satisfy the interface.

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

getIconImage() - Method in class java.awt.Frame

Returns the image to be displayed as the icon for this frame.

getIconImages() - Method in class java.awt.Window

Returns the sequence of images to be displayed as the icon for this window.

getIconTextGap() - Method in class javax.swing.AbstractButton

Returns the amount of space between the text and the icon displayed in this button.

getIconTextGap() - Method in class javax.swing.JLabel

Returns the amount of space between the text and the icon displayed in this label.

getIconWidth() - Method in interface javax.swing.Icon

Returns the icon's width.

getIconWidth() - Method in class javax.swing.ImageIcon

Gets the width of the icon.

getIconWidth() - Method in class javax.swing.plaf.IconUIResource

getIconWidth() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getIconWidth() - Method in class javax.swing.plaf.metal.MetalComboBoxIcon

Created a stub to satisfy the interface.

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

getID() - Method in class java.awt.AWTEvent

Returns the event type.

getId() - Method in class java.lang.Thread

Returns the identifier of this Thread.

getID() - Method in class java.rmi.activation.Activatable

Returns the object's activation identifier.

getId() - Method in interface java.security.cert.Extension

Gets the extensions's object identifier.

getID() - Method in class java.util.TimeZone

Gets the ID of this time zone.

getID() - Method in interface javax.naming.directory.Attribute

Retrieves the id of this attribute.

getID() - Method in class javax.naming.directory.BasicAttribute

getID() - Method in class javax.naming.ldap.BasicControl

Retrieves the control's object identifier string.

getID() - Method in interface javax.naming.ldap.Control

Retrieves the object identifier assigned for the LDAP control.

getID() - Method in interface javax.naming.ldap.ExtendedRequest

Retrieves the object identifier of the request.

getID() - Method in interface javax.naming.ldap.ExtendedResponse

Retrieves the object identifier of the response.

getID() - Method in class javax.naming.ldap.StartTlsRequest

Retrieves the StartTLS request's object identifier string.

getID() - Method in class javax.naming.ldap.StartTlsResponse

Retrieves the StartTLS response's object identifier string.

getId() - Method in interface javax.net.ssl.SSLSession

Returns the identifier assigned to this Session.

getID() - Method in class javax.swing.LookAndFeel

Return a string that identifies this look and feel.

getID() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an identifier for this look and feel.

getID() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a string, suitable for use by applications/services, that identifies this look and feel.

getID() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Return a string that identifies this look and feel.

getID() - Method in class javax.swing.plaf.synth.ColorType

Returns a unique id, as an integer, for this ColorType.

getID() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Return a string that identifies this look and feel.

getId() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyInfo

Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.

getId() - Method in interface javax.xml.crypto.dsig.Manifest

Returns the Id of this Manifest.

getId() - Method in interface javax.xml.crypto.dsig.Reference

Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.

getId() - Method in interface javax.xml.crypto.dsig.SignatureProperties

Returns the Id of this SignatureProperties.

getId() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns the Id of this SignatureProperty.

getId() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the optional Id attribute of this SignedInfo.

getId() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the Id of this XMLObject.

getId() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the optional Id of this XMLSignature.

getId() - Method in interface javax.xml.crypto.dsig.XMLSignature.SignatureValue

Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.

getId() - Method in class javax.xml.datatype.DatatypeConstants.Field

Get id of this Field.

getID() - Method in class javax.xml.ws.RespectBindingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.AddressingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.MTOMFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.WebServiceFeature

Get the unique identifier for this WebServiceFeature.

getId() - Method in exception org.omg.CORBA.portable.ApplicationException

Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.

getIdentifier(int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the identifier for the specified row.

getIdentifier() - Method in class javax.swing.RowFilter.Entry

Returns the identifer (in the model) of the entry.

getIdentifier() - Method in class javax.swing.table.TableColumn

Returns the identifier object for this column.

getIdentifierQuoteString() - Method in interface java.sql.DatabaseMetaData

Retrieves the string used to quote SQL identifiers.

getIdentity(String) - Method in class java.security.IdentityScope

Deprecated.

Returns the identity in this scope with the specified name (if any).

getIdentity(Principal) - Method in class java.security.IdentityScope

Deprecated.

Retrieves the identity whose name is the same as that of the specified principal.

getIdentity(PublicKey) - Method in class java.security.IdentityScope

Deprecated.

Retrieves the identity with the specified public key.

getIdentityHashCode() - Method in class java.lang.management.LockInfo

Returns the identity hash code of the lock object returned from the System.identityHashCode(java.lang.Object) method.

getIDs() - Method in interface javax.naming.directory.Attributes

Retrieves an enumeration of the ids of the attributes in the attribute set.

getIDs() - Method in class javax.naming.directory.BasicAttributes

getIds() - Method in interface javax.net.ssl.SSLSessionContext

Returns an Enumeration of all session id's grouped under this SSLSessionContext.

getIDstring() - Method in class java.awt.GraphicsDevice

Returns the identification string associated with this GraphicsDevice.

getIfModifiedSince() - Method in class java.net.URLConnection

Returns the value of this object's ifModifiedSince field.

getIgnoreRepaint() - Method in class java.awt.Component

getImage(URL) - Method in class java.applet.Applet

Returns an Image object that can then be painted on the screen.

getImage(URL, String) - Method in class java.applet.Applet

Returns an Image object that can then be painted on the screen.

getImage(URL) - Method in interface java.applet.AppletContext

Returns an Image object that can then be painted on the screen.

getImage() - Method in class java.awt.TexturePaint

Returns the BufferedImage texture used to fill the shapes.

getImage(String) - Method in class java.awt.Toolkit

Returns an image which gets pixel data from the specified file, whose format can be either GIF, JPEG or PNG.

getImage(URL) - Method in class java.awt.Toolkit

Returns an image which gets pixel data from the specified URL.

getImage() - Method in class java.awt.TrayIcon

Returns the current image used for this TrayIcon.

getImage() - Method in class javax.swing.ImageIcon

Returns this icon's Image.

getImage() - Method in class javax.swing.text.html.ImageView

Returns the image to render.

getImageableHeight() - Method in class java.awt.print.PageFormat

Return the height, in 1/72nds of an inch, of the imageable area of the page.

getImageableHeight() - Method in class java.awt.print.Paper

Returns the height of this Paper object's imageable area.

getImageableWidth() - Method in class java.awt.print.PageFormat

Returns the width, in 1/72nds of an inch, of the imageable area of the page.

getImageableWidth() - Method in class java.awt.print.Paper

Returns the width of this Paper object's imageable area.

getImageableX() - Method in class java.awt.print.PageFormat

Returns the x coordinate of the upper left point of the imageable area of the Paper object associated with this PageFormat.

getImageableX() - Method in class java.awt.print.Paper

Returns the x coordinate of the upper-left corner of this Paper object's imageable area.

getImageableY() - Method in class java.awt.print.PageFormat

Returns the y coordinate of the upper left point of the imageable area of the Paper object associated with this PageFormat.

getImageableY() - Method in class java.awt.print.Paper

Returns the y coordinate of the upper-left corner of this Paper object's imageable area.

getImageCapabilities() - Method in class java.awt.GraphicsConfiguration

Returns the image capabilities of this GraphicsConfiguration.

getImageLoadStatus() - Method in class javax.swing.ImageIcon

Returns the status of the image loading operation.

getImageMetadata(int) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object containing metadata associated with the given image, or null if the reader does not support reading metadata, is set to ignore metadata, or if no metadata is available.

getImageMetadata(int, String, Set<String>) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the given image, or null if the reader does not support reading metadata or none is available.

getImageMetadataFormat(String) - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an IIOMetadataFormat object describing the given image metadata format, or null if no description is available.

getImageObserver() - Method in class javax.swing.ImageIcon

Returns the image observer for the image.

getImageReader(ImageWriter) - Static method in class javax.imageio.ImageIO

Returns an ImageReadercorresponding to the given ImageWriter, if there is one, or null if the plug-in for this ImageWriter does not specify a corresponding ImageReader, or if the given ImageWriter is not registered.

getImageReaders(Object) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode the supplied Object, typically an ImageInputStream.

getImageReadersByFormatName(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode the named format.

getImageReadersByMIMEType(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode files with the given MIME type.

getImageReadersBySuffix(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode files with the given suffix.

getImageReaderSpiNames() - Method in class javax.imageio.spi.ImageWriterSpi

Returns an array of Strings containing all the fully qualified names of all the ImageReaderSpi classes that can understand the internal metadata representation used by the ImageWriter associated with this service provider, or null if there are no such ImageReaders specified.

getImageTranscoders(ImageReader, ImageWriter) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageTranscoders that claim to be able to transcode between the metadata of the given ImageReader and ImageWriter.

getImageTypes(int) - Method in class javax.imageio.ImageReader

Returns an Iterator containing possible image types to which the given image may be decoded, in the form of ImageTypeSpecifierss.

getImageURL() - Method in class java.awt.SplashScreen

Returns the current splash screen image.

getImageURL() - Method in class javax.swing.text.html.ImageView

Return a URL for the image source, or null if it could not be determined.

getImageWriter(ImageReader) - Static method in class javax.imageio.ImageIO

Returns an ImageWritercorresponding to the given ImageReader, if there is one, or null if the plug-in for this ImageReader does not specify a corresponding ImageWriter, or if the given ImageReader is not registered.

getImageWriters(ImageTypeSpecifier, String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode images of the given layout (specified using an ImageTypeSpecifier) in the given format.

getImageWritersByFormatName(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode the named format.

getImageWritersByMIMEType(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode files with the given MIME type.

getImageWritersBySuffix(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode files with the given suffix.

getImageWriterSpiNames() - Method in class javax.imageio.spi.ImageReaderSpi

Returns an array of Strings containing the fully qualified names of all the ImageWriterSpi classes that can understand the internal metadata representation used by the ImageReader associated with this service provider, or null if there are no such ImageWriters specified.

getImpact() - Method in class javax.management.MBeanOperationInfo

Returns the impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.

getImpact() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance.

getImpact(MBeanOperationInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the impact flag of the operation that will be used in the MBeanOperationInfo returned by this MBean.

getImplementation() - Method in class javax.management.StandardMBean

Get the implementation of this Standard MBean (or MXBean).

getImplementation() - Method in interface org.w3c.dom.Document

The DOMImplementation object that handles this document.

getImplementationClass() - Method in class javax.management.StandardMBean

Get the class of the implementation of this Standard MBean (or MXBean).

getImplementationName() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation name (the name of this product).

getImplementationName() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation name (the name of this product).

getImplementationTitle() - Method in class java.lang.软件包

Return the title of this package.

getImplementationVendor() - Method in class java.lang.软件包

Returns the name of the organization, vendor or company that provided this implementation.

getImplementationVendor() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation vendor (the vendor of this product).

getImplementationVendor() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation vendor (the vendor of this product).

getImplementationVersion() - Method in class java.lang.软件包

Return the version of this implementation.

getImplementationVersion() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation version (the version of this product).

getImplementationVersion() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation version (the version of this product).

getImplementor() - Method in class javax.xml.ws.Endpoint

Returns the implementation object for this endpoint.

getImplicitDownCycleTraversal() - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns whether this ContainerOrderFocusTraversalPolicy transfers focus down-cycle implicitly.

getImplicitDownCycleTraversal() - Method in class javax.swing.SortingFocusTraversalPolicy

Returns whether this SortingFocusTraversalPolicy transfers focus down- cycle implicitly.

getImportedKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the primary key columns that are referenced by the given table's foreign key columns (the primary keys imported by a table).

getInactiveControlTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the inactive control text color of the current theme.

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the inactive control text color.

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the inactive control text color.

getInactiveSystemTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the inactive system text color of the current theme.

getInactiveSystemTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the inactive system text color.

getInCheck() - Method in class java.lang.SecurityManager

Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.

getIndentLevel() - Method in class javax.swing.text.AbstractWriter

Returns the current indentation level.

getIndentSpace() - Method in class javax.swing.text.AbstractWriter

Returns the amount of space to indent.

getIndex() - Method in class java.beans.IndexedPropertyChangeEvent

Gets the index of the property that was changed.

getIndex() - Method in class java.net.NetworkInterface

Returns the index of this network interface.

getIndex() - Method in exception java.net.URISyntaxException

Returns an index into the input string of the position at which the parse error occurred, or -1 if this position is not known.

getIndex() - Method in exception java.nio.file.InvalidPathException

Returns an index into the input string of the position at which the error occurred, or -1 if this position is not known.

getIndex() - Method in exception java.security.cert.CertPathValidatorException

Returns the index of the certificate in the certification path that caused the exception to be thrown.

getIndex() - Method in exception java.sql.DataTruncation

Retrieves the index of the column or parameter that was truncated.

getIndex() - Method in interface java.text.CharacterIterator

Returns the current index.

getIndex() - Method in class java.text.ParsePosition

Retrieve the current parse position.

getIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getIndex() for String.

getIndex() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the error index.

getIndex() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Fetches the index within the element represented.

getIndex() - Method in class javax.swing.JList.DropLocation

Returns the index where dropped data should be placed in the list.

getIndex(int) - Method in class javax.swing.SizeSequence

Returns the index of the entry that corresponds to the specified position.

getIndex(TreeNode) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the index of node in the receivers children.

getIndex() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Returns the index into the list of elements.

getIndex() - Method in class javax.swing.text.html.parser.Element

Get index.

getIndex() - Method in class javax.swing.text.JTextComponent.DropLocation

Returns the index where dropped data should be inserted into the associated component.

getIndex() - Method in class javax.swing.text.Segment

Returns the current index.

getIndex(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the index of the specified child in this node's child array.

getIndex(TreeNode) - Method in interface javax.swing.tree.TreeNode

Returns the index of node in the receivers children.

getIndex(String, String) - Method in interface org.xml.sax.Attributes

Look up the index of an attribute by Namespace name.

getIndex(String) - Method in interface org.xml.sax.Attributes

Look up the index of an attribute by XML qualified (prefixed) name.

getIndex(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's index by Namespace name.

getIndex(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's index by qualified (prefixed) name.

getIndex0() - Method in class javax.swing.event.ListDataEvent

Returns the lower index of the range.

getIndex1() - Method in class javax.swing.event.ListDataEvent

Returns the upper index of the range.

getIndexAtPoint(Point) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in interface javax.accessibility.AccessibleText

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.JLabel.AccessibleJLabel

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexedPropertyType() - Method in class java.beans.IndexedPropertyDescriptor

Returns the Java type info for the indexed property.

getIndexedReadMethod() - Method in class java.beans.IndexedPropertyDescriptor

Gets the method that should be used to read an indexed property value.

getIndexedWriteMethod() - Method in class java.beans.IndexedPropertyDescriptor

Gets the method that should be used to write an indexed property value.

getIndexInfo(String, String, String, boolean, boolean) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given table's indices and statistics.

getIndexNames() - Method in class javax.management.openmbean.TabularType

Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.

getIndexOf(Object) - Method in class javax.swing.DefaultComboBoxModel

Returns the index-position of the specified object in the list.

getIndexOf(Component) - Method in class javax.swing.JLayeredPane

Returns the index of the specified Component.

getIndexOfChild(Object, Object) - Method in class javax.swing.tree.DefaultTreeModel

Returns the index of child in parent.

getIndexOfChild(Object, Object) - Method in interface javax.swing.tree.TreeModel

Returns the index of child in parent.

getIndexOfSize(float) - Static method in class javax.swing.text.html.StyleSheet

getInetAddress() - Method in class java.net.DatagramSocket

Returns the address to which this socket is connected.

getInetAddress() - Method in class java.net.ServerSocket

Returns the local address of this server socket.

getInetAddress() - Method in class java.net.Socket

Returns the address to which the socket is connected.

getInetAddress() - Method in class java.net.SocketImpl

Returns the value of this socket's address field.

getInetAddresses() - Method in class java.net.NetworkInterface

Convenience method to return an Enumeration with all or a subset of the InetAddresses bound to this network interface.

getInfinity() - Method in class java.text.DecimalFormatSymbols

Gets the string used to represent infinity.

getInfo() - Method in class java.security.Identity

Deprecated.

Returns general information previously specified for this identity.

getInfo() - Method in class java.security.Provider

Returns a human-readable description of the provider and its services.

getInheritsPopupMenu() - Method in class javax.swing.JComponent

Returns true if the JPopupMenu should be inherited from the parent.

getInit() - Method in class java.lang.management.MemoryUsage

Returns the amount of memory in bytes that the Java virtual machine initially requests from the operating system for memory management.

getInitialComponent(Window) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus when a Window is made visible for the first time.

getInitialComponent(JInternalFrame) - Method in class javax.swing.InternalFrameFocusTraversalPolicy

Returns the Component that should receive the focus when a JInternalFrame is selected for the first time.

getInitialContext(Hashtable<?, ?>) - Method in interface javax.naming.spi.InitialContextFactory

Creates an Initial Context for beginning name resolution.

getInitialContext(Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates an initial context using the specified environment properties.

getInitialDelay() - Method in class javax.swing.Timer

Returns the Timer's initial delay.

getInitialDelay() - Method in class javax.swing.ToolTipManager

Returns the initial delay value.

getInitialLocation(Insets) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the left inset, unless the Insets are null in which case 0 is returned.

getInitialPolicies() - Method in class java.security.cert.PKIXParameters

Returns an immutable Set of initial policy identifiers (OID strings), indicating that any one of these policies would be acceptable to the certificate user for the purposes of certification path processing.

getInitialSelectionValue() - Method in class javax.swing.JOptionPane

Returns the input value that is displayed as initially selected to the user.

getInitialValue() - Method in class javax.swing.JOptionPane

Returns the initial value.

getInitialValueIndex() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the initial index into the buttons to select.

getInitiatedClasses(ClassLoader) - Method in interface java.lang.instrument.Instrumentation

Returns an array of all classes for which loader is an initiating loader.

getInitiatorAddress() - Method in class org.ietf.jgss.ChannelBinding

Get the initiator's address for this channel binding.

getInitThreshold() - Method in class javax.management.monitor.CounterMonitor

Gets the initial threshold value common to all observed objects.

getInitThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the initial threshold value common to all observed objects.

getInput() - Method in exception java.net.URISyntaxException

Returns the input string.

getInput() - Method in exception java.nio.file.InvalidPathException

Returns the input string.

getInput() - Method in class javax.imageio.ImageReader

Returns the ImageInputStream or other Object previously set as the input source.

getInput() - Method in interface org.w3c.dom.ls.LSLoadEvent

The input source that was parsed.

getInput() - Method in interface org.w3c.dom.ls.LSProgressEvent

The input source that is being parsed.

getInputArguments() - Method in interface java.lang.management.RuntimeMXBean

Returns the input arguments passed to the Java virtual machine which does not include the arguments to the main method.

getInputAttributes() - Method in class javax.swing.JTextPane

Gets the input attributes for the pane.

getInputAttributes() - Method in class javax.swing.text.html.HTMLEditorKit

Gets the input attributes used for the styled editing actions.

getInputAttributes() - Method in class javax.swing.text.StyledEditorKit

Gets the input attributes for the pane.

getInputClass() - Method in class javax.imageio.spi.ImageInputStreamSpi

Returns a 类 object representing the class or interface type that must be implemented by an input source in order to be "wrapped" in an ImageInputStream via the createInputStreamInstance method.

getInputContext() - Method in class java.awt.Component

Gets the input context used by this component for handling the communication with input methods when text is entered in this component.

getInputContext() - Method in class java.awt.Window

Gets the input context for this window.

getInputEncoding() - Method in interface org.w3c.dom.Document

An attribute specifying the encoding used for this document at the time of the parsing.

getInputEncoding() - Method in interface org.w3c.dom.Entity

An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.

getInputEvent() - Method in class javax.swing.event.HyperlinkEvent

Returns the InputEvent that triggered the hyperlink event.

getInputLength() - Method in exception java.nio.charset.MalformedInputException

getInputLength() - Method in exception java.nio.charset.UnmappableCharacterException

getInputMap(int) - Method in class javax.swing.JComponent

Returns the InputMap that is used during condition.

getInputMap() - Method in class javax.swing.JComponent

Returns the InputMap that is used when the component has focus.

getInputMethodControlObject() - Method in class java.awt.im.InputContext

Returns a control object from the current input method, or null.

getInputMethodDisplayName(Locale, Locale) - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns the user-visible name of the corresponding input method for the given input locale in the language in which the name will be displayed.

getInputMethodIcon(Locale) - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns an icon for the corresponding input method.

getInputMethodListeners() - Method in class java.awt.Component

Returns an array of all the input method listeners registered on this component.

getInputMethodRequests() - Method in class java.awt.Component

Gets the input method request handler which supports requests from input methods for this component.

getInputMethodRequests() - Method in class java.awt.TextComponent

getInputMethodRequests() - Method in class javax.swing.text.JTextComponent

getInputSource() - Method in class javax.xml.transform.sax.SAXSource

Get the SAX InputSource to be used for the Source.

getInputStream() - Method in class java.lang.Process

Returns the input stream connected to the normal output of the subprocess.

getInputStream() - Method in class java.net.Socket

Returns an input stream for this socket.

getInputStream() - Method in class java.net.SocketImpl

Returns an input stream for this socket.

getInputStream() - Method in class java.net.URLConnection

Returns an input stream that reads from this open connection.

getInputStream() - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getInputStream(ZipEntry) - Method in class java.util.jar.JarFile

Returns an input stream for reading the contents of the specified zip file entry.

getInputStream(ZipEntry) - Method in class java.util.zip.ZipFile

Returns an input stream for reading the contents of the specified zip file entry.

getInputStream() - Method in class javax.activation.DataHandler

Get the InputStream for this object.

getInputStream() - Method in interface javax.activation.DataSource

This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.

getInputStream() - Method in class javax.activation.FileDataSource

This method will return an InputStream representing the the data and will throw an IOException if it can not do so.

getInputStream() - Method in class javax.activation.URLDataSource

The getInputStream method from the URL.

getInputStream() - Method in class javax.xml.transform.stream.StreamSource

Get the byte stream that was set with setByteStream.

getInputStream() - Method in exception org.omg.CORBA.portable.ApplicationException

Returns the input stream from which the exception data can be read as its parameters.

getInputTypes() - Method in class javax.imageio.spi.ImageReaderSpi

Returns an array of 类 objects indicating what types of objects may be used as arguments to the reader's setInput method.

getInputValue() - Method in class javax.swing.JOptionPane

Returns the value the user has input, if wantsInput is true.

getInputVerifier() - Method in class javax.swing.JComponent

Returns the input verifier for this component.

getInsertionIndex() - Method in class java.awt.font.TextHitInfo

Returns the insertion index.

getInsertPositionOffset() - Method in interface java.awt.im.InputMethodRequests

Gets the offset of the insert position in the committed text contained in the text editing component.

getInset(int, View) - Method in class javax.swing.text.html.StyleSheet.BoxPainter

Fetches the inset needed on a given side to account for the margin, border, and padding.

getInsets() - Method in class java.awt.Container

Determines the insets of this container, which indicate the size of the container's border.

getInsets() - Method in class javax.swing.JComponent

If a border has been set on this component, returns the border's insets; otherwise calls super.getInsets.

getInsets(Insets) - Method in class javax.swing.JComponent

Returns an Insets object containing this component's inset values.

getInsets() - Method in class javax.swing.JViewport

Returns the insets (border) dimensions as (0,0,0,0), since borders are not supported on a JViewport.

getInsets(Insets) - Method in class javax.swing.JViewport

Returns an Insets object containing this JViewports inset values.

getInsets() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Gets the insets from the JComboBox.

getInsets(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getInsets() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

If a border has been set on this component, returns the border's insets, else calls super.getInsets.

getInsets(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the insets.

getInsets() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.nimbus.NimbusStyle

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the Insets that are used to calculate sizing information.

getInsets(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Insets return it, otherwise return null.

getInsets(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Insets return it, otherwise return null.

getInsets(Object) - Static method in class javax.swing.UIManager

Returns an Insets object from the defaults.

getInsets(Object, Locale) - Static method in class javax.swing.UIManager

Returns an Insets object from the defaults that is appropriate for the given locale.

getInsetSpan(int) - Method in class javax.swing.text.AsyncBoxView

Fetch the span along an axis that is taken up by the insets.

getInsideAllocation(Shape) - Method in class javax.swing.text.CompositeView

Translates the immutable allocation given to the view to a mutable allocation that represents the interior allocation (i.e.

getInsideBorder() - Method in class javax.swing.border.CompoundBorder

Returns the inside border object.

getInstalledLookAndFeels() - Static method in class javax.swing.UIManager

Returns an array of LookAndFeelInfos representing the LookAndFeel implementations currently available.

getInstance(int) - Static method in class java.awt.AlphaComposite

Creates an AlphaComposite object with the specified rule.

getInstance(int, float) - Static method in class java.awt.AlphaComposite

Creates an AlphaComposite object with the specified rule and the constant alpha to multiply with the alpha of the source.

getInstance(int) - Static method in class java.awt.color.ColorSpace

Returns a ColorSpace representing one of the specific predefined color spaces.

getInstance(byte[]) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile object corresponding to the data in a byte array.

getInstance(int) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to one of the specific color spaces defined by the ColorSpace class (for example CS_sRGB).

getInstance(String) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to the data in a file.

getInstance(InputStream) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to the data in an InputStream.

getInstance() - Static method in class java.awt.im.InputContext

Returns a new InputContext instance.

getInstance(String) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String, String) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String, String) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object that implements the specified certificate type.

getInstance(String, String) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object for the specified certificate type.

getInstance(String, Provider) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object for the specified certificate type.

getInstance(String) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String, String) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, String) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, CertStoreParameters) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type and is initialized with the specified parameters.

getInstance(String, CertStoreParameters, String) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type.

getInstance(String, CertStoreParameters, Provider) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type.

getInstance(String) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String, String) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String, String) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String, String) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String, Provider) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, String) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, Provider) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, Policy.Parameters) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String, Policy.Parameters, String) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String, Policy.Parameters, Provider) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String, String) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String, Provider) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance(String, String) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance(String, Provider) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance() - Static method in class java.text.Collator

Gets the Collator for the current default locale.

getInstance(Locale) - Static method in class java.text.Collator

Gets the Collator for the desired locale.

getInstance() - Static method in class java.text.DateFormat

Get a default date/time formatter that uses the SHORT style for both the date and the time.

getInstance() - Static method in class java.text.DateFormatSymbols

Gets the DateFormatSymbols instance for the default locale.

getInstance(Locale) - Static method in class java.text.DateFormatSymbols

Gets the DateFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.text.DecimalFormatSymbols

Gets the DecimalFormatSymbols instance for the default locale.

getInstance(Locale) - Static method in class java.text.DecimalFormatSymbols

Gets the DecimalFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the current default locale.

getInstance(Locale) - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the specified locale.

getInstance(Locale) - Method in class java.text.spi.CollatorProvider

Returns a new Collator instance for the specified locale.

getInstance(Locale) - Method in class java.text.spi.DateFormatSymbolsProvider

Returns a new DateFormatSymbols instance for the specified locale.

getInstance(Locale) - Method in class java.text.spi.DecimalFormatSymbolsProvider

Returns a new DecimalFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.util.Calendar

Gets a calendar using the default time zone and locale.

getInstance(TimeZone) - Static method in class java.util.Calendar

Gets a calendar using the specified time zone and default locale.

getInstance(Locale) - Static method in class java.util.Calendar

Gets a calendar using the default time zone and specified locale.

getInstance(TimeZone, Locale) - Static method in class java.util.Calendar

Gets a calendar with the specified time zone and locale.

getInstance(String) - Static method in class java.util.Currency

Returns the Currency instance for the given currency code.

getInstance(Locale) - Static method in class java.util.Currency

Returns the Currency instance for the country of the given locale.

getInstance(String) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String, String) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String, Provider) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String, String) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String, String) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String, String) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String, String) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String, String) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used.

getInstance(String, String, String) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used.

getInstance(String, Hashtable<String, String>) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used.

getInstance(ObjectName) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere the given object can be used.

getInstance(String) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String, String) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String, Provider) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String, String) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String, Provider) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(String, String) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(String, Provider) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(String, Configuration.Parameters) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(String, Configuration.Parameters, String) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(String, Configuration.Parameters, Provider) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(InputStream) - Static method in class javax.security.cert.X509Certificate

Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream.

getInstance(byte[]) - Static method in class javax.security.cert.X509Certificate

Instantiates an X509Certificate object, and initializes it with the specified byte array.

getInstance(String) - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the SyncProvider instance identified by providerID.

getInstance() - Static method in class javax.swing.LayoutStyle

Returns the shared instance of LayoutStyle.

getInstance(String) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance() - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).

getInstance(String, String, Provider) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.

getInstance(String, String, String) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.

getInstance(String) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance() - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").

getInstance() - Static method in class org.ietf.jgss.GSSManager

Returns the default GSSManager implementation.

getInstanceFollowRedirects() - Method in class java.net.HttpURLConnection

Returns the value of this HttpURLConnection's instanceFollowRedirects field.

getInstanceOf(Object, Class<?>) - Static method in class java.beans.Beans

From a given bean, obtain an object representing a specified type view of that source object.

getInstrument(Patch) - Method in interface javax.sound.midi.Soundbank

Obtains an Instrument from the given Patch.

getInstruments() - Method in interface javax.sound.midi.Soundbank

Obtains a list of instruments contained in this sound bank.

getInt(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as an int.

getInt(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type int or of another primitive type convertible to type int via a widening conversion.

getInt() - Method in class java.nio.ByteBuffer

Relative get method for reading an int value.

getInt(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading an int value.

getInt(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC INTEGER parameter as an int in the Java programming language.

getInt(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC INTEGER parameter as an int in the Java programming language.

getInt(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an int in the Java programming language.

getInt(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an int in the Java programming language.

getInt(String, int) - Method in class java.util.prefs.AbstractPreferences

Implements the getInt method as per the specification in Preferences.getInt(String,int).

getInt(String, int) - Method in class java.util.prefs.Preferences

Returns the int value represented by the string associated with the specified key in this preference node.

getInt(SynthContext, Object, int) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is a Number.

getInt(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Integer return its integer value, otherwise return 0.

getInt(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Integer return its integer value, otherwise return 0.

getInt(Object) - Static method in class javax.swing.UIManager

Returns an integer from the defaults.

getInt(Object, Locale) - Static method in class javax.swing.UIManager

Returns an integer from the defaults that is appropriate for the given locale.

getInteger(String) - Static method in class java.lang.Integer

Determines the integer value of the system property with the specified name.

getInteger(String, int) - Static method in class java.lang.Integer

Determines the integer value of the system property with the specified name.

getInteger(String, Integer) - Static method in class java.lang.Integer

Returns the integer value of the system property with the specified name.

getIntegerAttributeValue(AttributeSet, HTML.Attribute, int) - Static method in class javax.swing.text.html.HTML

Fetches an integer attribute value.

getIntegerInstance() - Static method in class java.text.NumberFormat

Returns an integer number format for the current default locale.

getIntegerInstance(Locale) - Static method in class java.text.NumberFormat

Returns an integer number format for the specified locale.

getIntegerInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats integer values for the specified locale.

getIntegState() - Method in interface org.ietf.jgss.GSSContext

Determines if data integrity is available over the context.

getIntercellSpacing() - Method in class javax.swing.JTable

Returns the horizontal and vertical space between cells.

getInterface() - Method in class java.net.MulticastSocket

Retrieve the address of the network interface used for multicast packets.

getInterface(Class<T>) - Method in interface javax.script.Invocable

Returns an implementation of an interface using functions compiled in the interpreter.

getInterface(Object, Class<T>) - Method in interface javax.script.Invocable

Returns an implementation of an interface using member functions of a scripting object compiled in the interpreter.

getInterfaceAddresses() - Method in class java.net.NetworkInterface

Get a List of all or a subset of the InterfaceAddresses of this network interface.

getInterfaces() - Method in class java.lang.类

Determines the interfaces implemented by the class or interface represented by this object.

getInterfaces() - Method in interface javax.lang.model.element.TypeElement

Returns the interface types directly implemented by this class or extended by this interface.

getInteriorRectangle(Component, int, int, int, int) - Method in class javax.swing.border.AbstractBorder

This convenience method calls the static method.

getInteriorRectangle(Component, Border, int, int, int, int) - Static method in class javax.swing.border.AbstractBorder

Returns a rectangle using the arguments minus the insets of the border.

getInternalFrame() - Method in class javax.swing.event.InternalFrameEvent

Returns the originator of the event.

getInternalFrame() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the JInternalFrame that this DesktopIcon is associated with.

getInternalFrameAltMaximizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getInternalFrameCloseIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameDefaultMenuIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameListeners() - Method in class javax.swing.JInternalFrame

Returns an array of all the InternalFrameListeners added to this JInternalFrame with addInternalFrameListener.

getInternalFrameMaximizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameMinimizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalSubset() - Method in interface org.w3c.dom.DocumentType

The internal subset as a string, or null if there is none.

getInternationalCurrencySymbol() - Method in class java.text.DecimalFormatSymbols

Returns the ISO 4217 currency code of the currency of these DecimalFormatSymbols.

getInterpolationType() - Method in class java.awt.image.AffineTransformOp

Returns the interpolation type used by this op.

getIntParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as an int.

getInvalidCharacters() - Method in class javax.swing.text.MaskFormatter

Returns the characters that are not valid for input.

getInvalidityDate() - Method in exception java.security.cert.CertificateRevokedException

Returns the invalidity date, as specifed in the Invalidity Date extension of this CertificateRevokedException.

getInverted() - Method in class javax.swing.JSlider

Returns true if the value-range shown for the slider is reversed,

getInvocationHandler(Object) - Static method in class java.lang.reflect.Proxy

Returns the invocation handler for the specified proxy instance.

getInvoker() - Method in class javax.swing.JPopupMenu

Returns the component which is the 'invoker' of this popup menu.

getInvokesStopCellEditing() - Method in class javax.swing.JTree

Returns the indicator that tells what happens when editing is interrupted.

getIOException() - Method in exception java.awt.print.PrinterIOException

Returns the IOException that terminated the print job.

getISO3Country() - Method in class java.util.Locale

Returns a three-letter abbreviation for this locale's country.

getISO3Language() - Method in class java.util.Locale

Returns a three-letter abbreviation of this locale's language.

getISOCountries() - Static method in class java.util.Locale

Returns a list of all 2-letter country codes defined in ISO 3166.

getISOLanguages() - Static method in class java.util.Locale

Returns a list of all 2-letter language codes defined in ISO 639.

getIssuer() - Method in class java.security.cert.X509CertSelector

Returns the issuer criterion as an X500Principal.

getIssuerAlternativeNames() - Method in class java.security.cert.X509Certificate

Gets an immutable collection of issuer alternative names from the IssuerAltName extension, (OID = 2.5.29.18).

getIssuerAsBytes() - Method in class java.security.cert.X509CertSelector

Returns the issuer criterion as a byte array.

getIssuerAsString() - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.getIssuer() or X509CertSelector.getIssuerAsBytes() instead.

getIssuerDN() - Method in class java.security.cert.X509Certificate

Denigrated, replaced by X509Certificate.getIssuerX500Principal().

getIssuerDN() - Method in class java.security.cert.X509CRL

Denigrated, replaced by X509CRL.getIssuerX500Principal().

getIssuerDN() - Method in class javax.security.cert.X509Certificate

Gets the issuer (issuer distinguished name) value from the certificate.

getIssuerName() - Method in interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.

getIssuerNames() - Method in class java.security.cert.X509CRLSelector

Returns a copy of the issuerNames criterion.

getIssuers() - Method in class java.security.cert.X509CRLSelector

Returns the issuerNames criterion.

getIssuerUniqueID() - Method in class java.security.cert.X509Certificate

Gets the issuerUniqueID value from the certificate.

getIssuerX500Principal() - Method in class java.security.cert.X509Certificate

Returns the issuer (issuer distinguished name) value from the certificate as an X500Principal.

getIssuerX500Principal() - Method in class java.security.cert.X509CRL

Returns the issuer (issuer distinguished name) value from the CRL as an X500Principal.

getItalicAngle() - Method in class java.awt.Font

Returns the italic angle of this Font.

getItem(int) - Method in class java.awt.Choice

Gets the string at the specified index in this Choice menu.

getItem() - Method in class java.awt.event.ItemEvent

Returns the item affected by the event.

getItem(int) - Method in class java.awt.List

Gets the item associated with the specified index.

getItem(int) - Method in class java.awt.Menu

Gets the item located at the specified index of this menu.

getItem() - Method in interface javax.swing.ComboBoxEditor

Return the edited item

getItem(int) - Method in class javax.swing.JMenu

Returns the JMenuItem at the specified position.

getItem() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

getItemAt(int) - Method in class javax.swing.JComboBox

Returns the list item at the specified index.

getItemCount() - Method in class java.awt.Choice

Returns the number of items in this Choice menu.

getItemCount() - Method in class java.awt.List

Gets the number of items in the list.

getItemCount() - Method in class java.awt.Menu

Get the number of items in this menu.

getItemCount() - Method in class javax.swing.JComboBox

Returns the number of items in the list.

getItemCount() - Method in class javax.swing.JMenu

Returns the number of items on the menu, including separators.

getItemListeners() - Method in class java.awt.Checkbox

Returns an array of all the item listeners registered on this checkbox.

getItemListeners() - Method in class java.awt.CheckboxMenuItem

Returns an array of all the item listeners registered on this checkbox menuitem.

getItemListeners() - Method in class java.awt.Choice

Returns an array of all the item listeners registered on this choice.

getItemListeners() - Method in class java.awt.List

Returns an array of all the item listeners registered on this list.

getItemListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ItemListeners added to this AbstractButton with addItemListener().

getItemListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the item listeners registered on this DefaultButtonModel.

getItemListeners() - Method in class javax.swing.JComboBox

Returns an array of all the ItemListeners added to this JComboBox with addItemListener().

getItems() - Method in class java.awt.List

Gets the items in the list.

getItemSelectable() - Method in class java.awt.event.ItemEvent

Returns the originator of the event.

getIterationCount() - Method in interface javax.crypto.interfaces.PBEKey

Returns the iteration count or 0 if not specified.

getIterationCount() - Method in class javax.crypto.spec.PBEKeySpec

Returns the iteration count or 0 if not specified.

getIterationCount() - Method in class javax.crypto.spec.PBEParameterSpec

Returns the iteration count.

getIterator() - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to the entire contents of this string.

getIterator(AttributedCharacterIterator.Attribute[]) - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to selected contents of this string.

getIterator(AttributedCharacterIterator.Attribute[], int, int) - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to selected contents of this string.

getIterator(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument

Fetches an iterator for the specified HTML tag.

getIV() - Method in class javax.crypto.Cipher

Returns the initialization vector (IV) in a new buffer.

getIV() - Method in class javax.crypto.spec.IvParameterSpec

Returns the initialization vector (IV).

getIV() - Method in class javax.crypto.spec.RC2ParameterSpec

Returns the IV or null if this parameter set does not contain an IV.

getIV() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the IV or null if this parameter set does not contain an IV.

getJarEntry() - Method in class java.net.JarURLConnection

Return the JAR entry object for this connection, if any.

getJarEntry(String) - Method in class java.util.jar.JarFile

Returns the JarEntry for the given entry name or null if not found.

getJarFile() - Method in class java.net.JarURLConnection

Return the JAR file for this connection.

getJarFiles() - Method in class javax.management.loading.MLetContent

Gets the list of .jar files specified by the ARCHIVE attribute of the MLET tag.

getJarFileURL() - Method in class java.net.JarURLConnection

Returns the URL for the Jar file for this connection.

getJavaEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Gets the corresponding Java encoding name from an IANA name.

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in class javax.tools.ForwardingJavaFileManager

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in interface javax.tools.JavaFileManager

Gets a file object for input representing the specified class of the specified kind in the given location.

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in class javax.tools.ForwardingJavaFileManager

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in interface javax.tools.JavaFileManager

Gets a file object for output representing the specified class of the specified kind in the given location.

getJavaFileObjects(File...) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given files.

getJavaFileObjects(String...) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given file names.

getJavaFileObjectsFromFiles(Iterable<? extends File>) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given files.

getJavaFileObjectsFromStrings(Iterable<String>) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given file names.

getJavaInitializationString() - Method in interface java.beans.PropertyEditor

Returns a fragment of Java code that can be used to set a property to match the editors current state.

getJavaInitializationString() - Method in class java.beans.PropertyEditorSupport

This method is intended for use when generating Java code to set the value of the property.

getJAXBNode(XmlNode) - Method in class javax.xml.bind.Binder

Gets the JAXB object associated with the given XML element.

getJDBCMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the major JDBC version number for this driver.

getJDBCMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the minor JDBC version number for this driver.

getJMenuBar() - Method in class javax.swing.JApplet

Returns the menubar set on this applet.

getJMenuBar() - Method in class javax.swing.JDialog

Returns the menubar set on this dialog.

getJMenuBar() - Method in class javax.swing.JFrame

Returns the menubar set on this frame.

getJMenuBar() - Method in class javax.swing.JInternalFrame

Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.

getJMenuBar() - Method in class javax.swing.JRootPane

Returns the menu bar from the layered pane.

getJobName() - Method in class java.awt.print.PrinterJob

Gets the name of the document to be printed.

getJoinType() - Method in interface javax.sql.rowset.JoinRowSet

Returns a int describing the set SQL JOIN type governing this JoinRowSet instance.

getJustificationInfo() - Method in class java.awt.font.GraphicAttribute

Returns the justification information for this GraphicAttribute.

getJustifiedLayout(float) - Method in class java.awt.font.TextLayout

Creates a copy of this TextLayout justified to the specified width.

getKeepAlive() - Method in class java.net.Socket

Tests if SO_KEEPALIVE is enabled.

getKeepAliveTime(TimeUnit) - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the thread keep-alive time, which is the amount of time that threads in excess of the core pool size may remain idle before being terminated.

getKernel() - Method in class java.awt.image.ConvolveOp

Returns the Kernel.

getKernelData(float[]) - Method in class java.awt.image.Kernel

Returns the kernel data in row major order.

getKey() - Method in class java.awt.MenuShortcut

Returns the raw keycode of this MenuShortcut.

getKey(String, char[]) - Method in class java.security.KeyStore

Returns the key associated with the given alias, using the given password to recover it.

getKey() - Method in class java.util.AbstractMap.SimpleEntry

Returns the key corresponding to this entry.

getKey() - Method in class java.util.AbstractMap.SimpleImmutableEntry

Returns the key corresponding to this entry.

getKey() - Method in interface java.util.Map.Entry

Returns the key corresponding to this entry.

getKey() - Method in exception java.util.MissingResourceException

Gets parameter passed by constructor.

getKey() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the key of the preference that was changed.

getKey() - Method in class javax.accessibility.AccessibleRelation

Returns the key for this relation

getKey() - Method in class javax.crypto.spec.DESedeKeySpec

Returns the DES-EDE key.

getKey() - Method in class javax.crypto.spec.DESKeySpec

Returns the DES key material.

getKey() - Method in interface javax.xml.crypto.KeySelectorResult

Returns the selected key.

getKeyChar() - Method in class java.awt.AWTKeyStroke

Returns the character for this AWTKeyStroke.

getKeyChar() - Method in class java.awt.event.KeyEvent

Returns the character associated with the key in this event.

getKeyCode() - Method in class java.awt.AWTKeyStroke

Returns the numeric key code for this AWTKeyStroke.

getKeyCode() - Method in class java.awt.event.KeyEvent

Returns the integer keyCode associated with the key in this event.

getKeyColumns() - Method in interface javax.sql.rowset.CachedRowSet

Returns an array containing one or more column numbers indicating the columns that form a key that uniquely identifies a row in this CachedRowSet object.

getKeyEventDispatchers() - Method in class java.awt.KeyboardFocusManager

Returns this KeyboardFocusManager's KeyEventDispatcher chain as a List.

getKeyEventPostProcessors() - Method in class java.awt.KeyboardFocusManager

Returns this KeyboardFocusManager's KeyEventPostProcessor chain as a List.

getKeyEventType() - Method in class java.awt.AWTKeyStroke

Returns the type of KeyEvent which corresponds to this AWTKeyStroke.

getKeyId() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.

getKeyInfo() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the key info of this XMLSignature.

getKeyInfoFactory() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns a KeyInfoFactory that creates KeyInfo objects.

getKeyLength() - Method in class javax.crypto.spec.PBEKeySpec

Returns the to-be-derived key length or 0 if not specified.

getKeyListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getKeyListener().

getKeyListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a key listener that will be added to the combo box or null.

getKeyListeners() - Method in class java.awt.Component

Returns an array of all the key listeners registered on this component.

getKeyLocation() - Method in class java.awt.event.KeyEvent

Returns the location of the key that originated this key event.

getKeyManagers() - Method in class javax.net.ssl.KeyManagerFactory

Returns one key manager for each type of key material.

getKeymap() - Method in class javax.swing.text.JTextComponent

Fetches the keymap currently active in this text component.

getKeymap(String) - Static method in class javax.swing.text.JTextComponent

Fetches a named keymap previously added to the document.

getKeymapName() - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the name of the keymap that will be installed/used by default for this UI.

getKeyModifiersText(int) - Static method in class java.awt.event.KeyEvent

Returns a String describing the modifier key(s), such as "Shift", or "Ctrl+Shift".

getKeyPacket() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.

getKeyProperty(String) - Method in class javax.management.ObjectName

Obtains the value associated with a key in a key property.

getKeyPropertyList() - Method in class javax.management.ObjectName

Returns the key properties as a Hashtable.

getKeyPropertyListString() - Method in class javax.management.ObjectName

Returns a string representation of the list of key properties specified at creation time.

getKeys() - Method in class java.util.ListResourceBundle

Returns an Enumeration of the keys contained in this ResourceBundle and its parent bundles.

getKeys() - Method in class java.util.PropertyResourceBundle

Returns an Enumeration of the keys contained in this ResourceBundle and its parent bundles.

getKeys() - Method in class java.util.ResourceBundle

Returns an enumeration of the keys.

getKeys() - Method in class javax.swing.AbstractAction

Returns an array of Objects which are keys for which values have been set for this AbstractAction, or null if no keys have values set.

getKeySelectionManager() - Method in class javax.swing.JComboBox

Returns the list's key-selection manager.

getKeySelector() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getKeySelector() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the key selector for finding a key.

getKeySelectorResult() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.

getKeysize() - Method in class java.security.spec.RSAKeyGenParameterSpec

Returns the keysize.

getKeySpec(Key, Class<T>) - Method in class java.security.KeyFactory

Returns a specification (key material) of the given key object.

getKeySpec(Cipher) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key, String) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key, Provider) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(SecretKey, Class) - Method in class javax.crypto.SecretKeyFactory

Returns a specification (key material) of the given key object in the requested format.

getKeyStore() - Method in class java.security.KeyStore.Builder

Returns the KeyStore described by this object.

getKeyStroke(char) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified character.

getKeyStroke(char, boolean) - Static method in class javax.swing.KeyStroke

Deprecated.
use getKeyStroke(char)

getKeyStroke(Character, int) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.

getKeyStroke(int, int, boolean) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.

getKeyStroke(int, int) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers.

getKeyStroke(String) - Static method in class javax.swing.KeyStroke

Parses a string and returns a KeyStroke.

getKeyStrokeForEvent(KeyEvent) - Static method in class javax.swing.KeyStroke

Returns a KeyStroke which represents the stroke which generated a given KeyEvent.

getKeyStrokesForAction(Action) - Method in interface javax.swing.text.Keymap

Fetches the keystrokes that will result in the given action.

getKeyText(int) - Static method in class java.awt.event.KeyEvent

Returns a String describing the keyCode, such as "HOME", "F1" or "A".

getKeyType() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key type for this long-term key.

getKeyUsage() - Method in class java.security.cert.X509Certificate

Gets a boolean array representing bits of the KeyUsage extension, (OID = 2.5.29.15).

getKeyUsage() - Method in class java.security.cert.X509CertSelector

Returns the keyUsage criterion.

getKind() - Method in interface javax.lang.model.element.Element

Returns the kind of this element.

getKind() - Method in interface javax.lang.model.type.TypeMirror

Returns the kind of this type.

getKind() - Method in interface javax.tools.Diagnostic

Gets the kind of this diagnostic, for example, error or warning.

getKind() - Method in class javax.tools.ForwardingJavaFileObject

getKind() - Method in interface javax.tools.JavaFileObject

Gets the kind of this file object.

getKind() - Method in class javax.tools.SimpleJavaFileObject

getL() - Method in class javax.crypto.spec.DHParameterSpec

Returns the size in bits, l, of the random exponent (private value).

getLabel() - Method in class java.awt.Button

Gets the label of this button.

getLabel() - Method in class java.awt.Checkbox

Gets the label of this check box.

getLabel() - Method in class java.awt.MenuItem

Gets the label for this menu item.

getLabel() - Method in class javax.swing.AbstractButton

Deprecated.
- Replaced by getText

getLabel() - Method in class javax.swing.JPopupMenu

Returns the popup menu's label

getLabel() - Method in class javax.swing.text.html.Option

Fetch the label associated with the option.

getLabelFor() - Method in class javax.swing.JLabel

Get the component this is labelling.

getLabelTable() - Method in class javax.swing.JSlider

Returns the dictionary of what labels to draw at which values.

getLanguage() - Method in class java.util.Locale

Returns the language code of this Locale.

getLanguageName() - Method in interface javax.script.ScriptEngineFactory

Returns the name of the scripting langauge supported by this ScriptEngine.

getLanguageVersion() - Method in interface javax.script.ScriptEngineFactory

Returns the version of the scripting language supported by this ScriptEngine.

getLargeDisplayIcon() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the large display icon for the panel.

getLargestPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the largest number of threads that have ever simultaneously been in the pool.

getLast() - Method in class java.util.ArrayDeque

getLast() - Method in class java.util.concurrent.ConcurrentLinkedDeque

getLast() - Method in class java.util.concurrent.LinkedBlockingDeque

getLast() - Method in interface java.util.Deque

Retrieves, but does not remove, the last element of this deque.

getLast() - Method in class java.util.LinkedList

Returns the last element in this list.

getLastAccessedTime() - Method in interface javax.net.ssl.SSLSession

Returns the last time this Session representation was accessed by the session level infrastructure, in milliseconds since midnight, January 1, 1970 UTC.

getLastChild() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the last child of this node, or null if the node has no children.

getLastChild() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's last child.

getLastChild() - Method in interface org.w3c.dom.Node

The last child of this node.

getLastChildPath(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns a path to the last child of parent.

getLastColumn() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the last column that changed.

getLastColumn() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getLastComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class javax.swing.DefaultFocusManager

getLastComponent(Container) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastCursor() - Method in class javax.swing.JInternalFrame

Returns the last Cursor that was set by the setCursor method that is not a resizable Cursor.

getLastDividerLocation() - Method in class javax.swing.JSplitPane

Returns the last location the divider was at.

getLastDragLocation() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the last drag location of the JSplitPane.

getLastIndex() - Method in class javax.swing.event.ListSelectionEvent

Returns the index of the last row whose selection may have changed.

getLastLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.

getLastModified() - Method in class java.net.URLConnection

Returns the value of the last-modified header field.

getLastModified() - Method in interface javax.tools.FileObject

Gets the time this file object was last modified.

getLastModified() - Method in class javax.tools.ForwardingFileObject

getLastModified() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns 0L.

getLastModifiedTime(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns a file's last modified time.

getLastPathComponent() - Method in class javax.swing.tree.TreePath

Returns the last element of this path.

getLastRow() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the last row that changed.

getLastRow() - Method in class javax.swing.event.TableModelEvent

Returns the last row that changed.

getLastRow() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getLastSelectedPathComponent() - Method in class javax.swing.JTree

Returns the last path component of the selected path.

getLastVisibleIndex() - Method in class javax.swing.JList

Returns the largest list index that is currently visible.

getLatency() - Method in interface javax.sound.midi.Synthesizer

Obtains the processing latency incurred by this synthesizer, expressed in microseconds.

getLateReflectionDelay() - Method in class javax.sound.sampled.ReverbType

Returns the late reflection delay time in microseconds.

getLateReflectionIntensity() - Method in class javax.sound.sampled.ReverbType

Returns the late reflection intensity in decibels.

getLayer() - Method in class javax.swing.JInternalFrame

Convenience method for getting the layer attribute of this component.

getLayer(JComponent) - Static method in class javax.swing.JLayeredPane

Gets the layer property for a JComponent, it does not cause any side effects like setLayer().

getLayer(Component) - Method in class javax.swing.JLayeredPane

Returns the layer attribute for the specified Component.

getLayeredPane() - Method in class javax.swing.JApplet

Returns the layeredPane object for this applet.

getLayeredPane() - Method in class javax.swing.JDialog

Returns the layeredPane object for this dialog.

getLayeredPane() - Method in class javax.swing.JFrame

Returns the layeredPane object for this frame.

getLayeredPane() - Method in class javax.swing.JInternalFrame

Returns the layered pane for this internal frame.

getLayeredPane() - Method in class javax.swing.JRootPane

Gets the layered pane used by the root pane.

getLayeredPane() - Method in class javax.swing.JWindow

Returns the layeredPane object for this window.

getLayeredPane() - Method in interface javax.swing.RootPaneContainer

Returns the layeredPane.

getLayeredPaneAbove(Component) - Static method in class javax.swing.JLayeredPane

Convenience method that returns the first JLayeredPane which contains the specified component.

getLayerEventMask() - Method in class javax.swing.JLayer

Returns the bitmap of event mask to receive by this JLayer and its LayerUI.

getLayout() - Method in class java.awt.Container

Gets the layout manager for this container.

getLayout(int, int) - Method in class java.awt.font.TextMeasurer

Returns a TextLayout on the given character range.

getLayoutAlignmentX(Container) - Method in class java.awt.BorderLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class java.awt.CardLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class java.awt.GridBagLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in interface java.awt.LayoutManager2

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.BoxLayout

Returns the alignment along the X axis for the container.

getLayoutAlignmentX(Container) - Method in class javax.swing.GroupLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.JRootPane.RootLayout

getLayoutAlignmentX(Container) - Method in class javax.swing.OverlayLayout

Returns the alignment along the x axis for the container.

getLayoutAlignmentX(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.SpringLayout

Returns 0.5f (centered).

getLayoutAlignmentY(Container) - Method in class java.awt.BorderLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class java.awt.CardLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class java.awt.GridBagLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in interface java.awt.LayoutManager2

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.BoxLayout

Returns the alignment along the Y axis for the container.

getLayoutAlignmentY(Container) - Method in class javax.swing.GroupLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.JRootPane.RootLayout

getLayoutAlignmentY(Container) - Method in class javax.swing.OverlayLayout

Returns the alignment along the y axis for the container.

getLayoutAlignmentY(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.SpringLayout

Returns 0.5f (centered).

getLayoutComponent(Object) - Method in class java.awt.BorderLayout

Gets the component that was added using the given constraint

getLayoutComponent(Container, Object) - Method in class java.awt.BorderLayout

Returns the component that corresponds to the given constraint location based on the target Container's component orientation.

getLayoutDimensions() - Method in class java.awt.GridBagLayout

Determines column widths and row heights for the layout grid.

getLayoutFlags() - Method in class java.awt.font.GlyphVector

Returns flags describing the global state of the GlyphVector.

getLayoutInfo(Container, int) - Method in class java.awt.GridBagLayout

Fills in an instance of GridBagLayoutInfo for the current set of managed children.

GetLayoutInfo(Container, int) - Method in class java.awt.GridBagLayout

This method is obsolete and supplied for backwards compatability only; new code should call getLayoutInfo instead.

getLayoutOrientation() - Method in class javax.swing.JList

Returns the layout orientation property for the list: VERTICAL if the layout is a single column of cells, VERTICAL_WRAP if the layout is "newspaper style" with the content flowing vertically then horizontally, or HORIZONTAL_WRAP if the layout is "newspaper style" with the content flowing horizontally then vertically.

getLayoutOrigin() - Method in class java.awt.GridBagLayout

Determines the origin of the layout area, in the graphics coordinate space of the target container.

getLayoutPath() - Method in class java.awt.font.TextLayout

Return the LayoutPath, or null if the layout path is the default path (x maps to advance, y maps to offset).

getLayoutQueue() - Method in class javax.swing.text.AsyncBoxView

Fetch the queue to use for layout.

getLayoutStyle() - Method in class javax.swing.GroupLayout

Returns the LayoutStyle used for calculating the preferred gap between components.

getLayoutStyle() - Method in class javax.swing.LookAndFeel

Returns the LayoutStyle for this look and feel.

getLayoutStyle() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns a LayoutStyle implementing the Java look and feel design guidelines as specified at http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html.

getLayoutView(int) - Method in class javax.swing.text.ParagraphView

Returns the view at a given index.

getLayoutViewCount() - Method in class javax.swing.text.ParagraphView

Returns the number of views that this view is responsible for.

getLayoutWeights() - Method in class java.awt.GridBagLayout

Determines the weights of the layout grid's columns and rows.

getLeader() - Method in class javax.swing.text.TabStop

Returns the leader of the tab.

getLeading() - Method in class java.awt.font.LineMetrics

Returns the leading of the text.

getLeading() - Method in class java.awt.font.TextLayout

Returns the leading of the TextLayout.

getLeading() - Method in class java.awt.FontMetrics

Determines the standard leading of the Font described by this FontMetrics object.

getLeadSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getLeadSelectionIndex() - Method in class javax.swing.JList

Returns the lead selection index.

getLeadSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getLeadSelectionPath() - Method in class javax.swing.JTree

Returns the path identified as the lead.

getLeadSelectionPath() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the last path that was added.

getLeadSelectionPath() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the last path that was added.

getLeadSelectionRow() - Method in class javax.swing.JTree

Returns the row index corresponding to the lead path.

getLeadSelectionRow() - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the lead row of the selection.

getLeadSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the lead selection index.

getLeadSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the lead selection index.

getLeafCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the total number of leaves that are descendants of this node.

getLeafIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent leaf nodes.

getLeastMaximum(int) - Method in class java.util.Calendar

Returns the lowest maximum value for the given calendar field of this Calendar instance.

getLeastMaximum(int) - Method in class java.util.GregorianCalendar

Returns the lowest maximum value for the given calendar field of this GregorianCalendar instance.

getLeastSignificantBits() - Method in class java.util.UUID

Returns the least significant 64 bits of this UUID's 128 bit value.

getLeftChildIndent() - Method in class javax.swing.plaf.basic.BasicTreeUI

getLeftComponent() - Method in class javax.swing.JSplitPane

Returns the component to the left (or above) the divider.

getLeftIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the left indent setting.

getLeftInset() - Method in class javax.swing.text.AsyncBoxView

Get the left part of the margin around the view.

getLeftInset() - Method in class javax.swing.text.CompositeView

Gets the left inset.

getLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the set of legal values for this parameter, if it has one, or null otherwise.

getLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getLength(Object) - Static method in class java.lang.reflect.Array

Returns the length of the specified array object, as an int.

getLength() - Method in class java.net.DatagramPacket

Returns the length of the data to be sent or the length of the data received.

getLength() - Method in class java.text.Bidi

Return the length of text in the line.

getLength() - Method in class javax.imageio.metadata.IIOMetadataNode

getLength() - Method in class javax.imageio.stream.IIOByteBuffer

Returns the length of the data of interest within the byte array returned by getData.

getLength() - Method in class javax.sound.midi.MidiMessage

Obtains the total length of the MIDI message in bytes.

getLength() - Method in interface javax.swing.event.DocumentEvent

Returns the length of the change.

getLength() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the length of the change.

getLength() - Method in class javax.swing.text.AbstractDocument

Returns the length of the data.

getLength() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the length.

getLength() - Method in interface javax.swing.text.Document

Returns number of characters of content currently in the document.

getLength() - Method in interface org.w3c.dom.CharacterData

The number of 16-bit units that are available through data and the substringData method below.

getLength() - Method in interface org.w3c.dom.DOMImplementationList

The number of DOMImplementations in the list.

getLength() - Method in interface org.w3c.dom.DOMStringList

The number of DOMStrings in the list.

getLength() - Method in interface org.w3c.dom.NamedNodeMap

The number of nodes in this map.

getLength() - Method in interface org.w3c.dom.NameList

The number of pairs (name and namespaceURI) in the list.

getLength() - Method in interface org.w3c.dom.NodeList

The number of nodes in the list.

getLength() - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the number of attributes in this list.

getLength() - Method in interface org.xml.sax.Attributes

Return the number of attributes in the list.

getLength() - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Return the number of attributes in the list.

getLength() - Method in class org.xml.sax.helpers.AttributesImpl

Return the number of attributes in the list.

getLengths() - Method in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

Returns an array of shorts containing the number of values for each length in the Huffman table.

getLevel() - Method in class java.util.logging.Handler

Get the log level specifying which messages will be logged by this Handler.

getLevel() - Method in class java.util.logging.Logger

Get the log Level that has been specified for this Logger.

getLevel() - Method in class java.util.logging.LogRecord

Get the logging message level, for example Level.SEVERE.

getLevel() - Method in interface javax.sound.sampled.DataLine

Obtains the current volume level for the line.

getLevel() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of levels above this node -- the distance from the root to this node.

getLevelAt(int) - Method in class java.text.Bidi

Return the resolved level of the character at offset.

getLexicalHandler() - Method in class javax.xml.transform.sax.SAXResult

Get a SAX2 LexicalHandler for the output.

getLibraryDirectory() - Method in class javax.management.loading.MLet

Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

getLibraryDirectory() - Method in interface javax.management.loading.MLetMBean

Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

getLibraryPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java library path.

getLifetime() - Method in interface org.ietf.jgss.GSSContext

Determines what the remaining lifetime for this context is.

getLimit() - Method in class javax.swing.undo.UndoManager

Returns the maximum number of edits this UndoManager holds.

getLimits() - Method in class java.text.ChoiceFormat

Get the limits passed in the constructor.

getLine(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a line that matches the description in the specified Line.Info object.

getLine() - Method in class javax.sound.sampled.LineEvent

Obtains the audio line that is the source of this event.

getLine(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains a line that is available for use and that matches the description in the specified Line.Info object.

getLineBreakIndex(int, float) - Method in class java.awt.font.TextMeasurer

Returns the index of the first character which will not fit on on a line beginning at start and possible measuring up to maxAdvance in graphical width.

getLineBuffer() - Method in class javax.swing.text.PlainView

Gives access to a buffer that can be used to fetch text from the associated document.

getLineBuffer() - Method in class javax.swing.text.WrappedPlainView

Gives access to a buffer that can be used to fetch text from the associated document.

getLineClass() - Method in class javax.sound.sampled.Line.Info

Obtains the class of the line that this Line.Info object describes.

getLineColor() - Method in class javax.swing.border.LineBorder

Returns the color of the border.

getLineCount() - Method in class javax.swing.JTextArea

Determines the number of lines contained in the area.

getLineEndOffset(int) - Method in class javax.swing.JTextArea

Determines the offset of the end of the given line.

getLineIncrement() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getUnitIncrement().

getLineInfo() - Method in interface javax.sound.sampled.Line

Obtains the Line.Info object describing this line.

getLineInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for line breaks for the default locale.

getLineInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for line breaks for the given locale.

getLineInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for line breaks for the given locale.

getLineJoin() - Method in class java.awt.BasicStroke

Returns the line join style.

getLineLength() - Method in class javax.swing.text.AbstractWriter

Returns the maximum line length.

getLineMetrics(String, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified String and FontRenderContext.

getLineMetrics(String, int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(char[], int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(String, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified String in the specified Graphics context.

getLineMetrics(String, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified String in the specified Graphics context.

getLineMetrics(char[], int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified character array in the specified Graphics context.

getLineMetrics(CharacterIterator, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified CharacterIterator in the specified Graphics context.

getLineNumber() - Method in class java.io.LineNumberInputStream

Deprecated.

Returns the current line number.

getLineNumber() - Method in class java.io.LineNumberReader

Get the current line number.

getLineNumber() - Method in class java.lang.StackTraceElement

Returns the line number of the source line containing the execution point represented by this stack trace element.

getLineNumber() - Method in exception javax.script.ScriptException

Get the line number on which an error occurred.

getLineNumber() - Method in interface javax.tools.Diagnostic

Gets the line number of the character offset returned by Diagnostic.getPosition().

getLineNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getLineNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the line number if available

getLineNumber() - Method in interface javax.xml.stream.Location

Return the line number where the current event ends, returns -1 if none is available.

getLineNumber() - Method in interface javax.xml.transform.SourceLocator

Return the line number where the current document event ends.

getLineNumber() - Method in interface org.w3c.dom.DOMLocator

The line number this locator is pointing to, or -1 if there is no column number available.

getLineNumber() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved line number (1-based).

getLineNumber() - Method in interface org.xml.sax.Locator

Return the line number where the current document event ends.

getLineNumber() - Method in exception org.xml.sax.SAXParseException

The line number of the end of the text where the exception occurred.

getLineOfOffset(int) - Method in class javax.swing.JTextArea

Translates an offset into the components text to a line number.

getLineSeparator() - Method in class javax.swing.text.AbstractWriter

Returns the string used to represent newlines.

getLineSpacing(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the line spacing setting.

getLineStartOffset(int) - Method in class javax.swing.JTextArea

Determines the offset of the start of the given line.

getLineWidth() - Method in class java.awt.BasicStroke

Returns the line width.

getLineWrap() - Method in class javax.swing.JTextArea

Gets the line-wrapping policy of the text area.

getLink(int) - Method in interface javax.accessibility.AccessibleHypertext

Returns the nth Link of this Hypertext document.

getLink(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the index into an array of hyperlinks that index.

getLinkCount() - Method in interface javax.accessibility.AccessibleHypertext

Returns the number of links within this hypertext document.

getLinkCount() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the number of links within this hypertext doc.

getLinkCursor() - Method in class javax.swing.text.html.HTMLEditorKit

Returns the cursor to use over hyper links.

getLinkedException() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLinkedException() - Method in exception javax.xml.bind.JAXBException

Get the linked exception

getLinkedException() - Method in exception javax.xml.bind.TypeConstraintException

Get the linked exception

getLinkedException() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the linked exception for this warning/error.

getLinkExplanation() - Method in exception javax.naming.LinkException

Retrieves the explanation associated with the problem encounter when resolving a link.

getLinkIndex(int) - Method in interface javax.accessibility.AccessibleHypertext

Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.

getLinkIndex(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.

getLinkName() - Method in class javax.naming.LinkRef

Retrieves the name of this link.

getLinkRemainingName() - Method in exception javax.naming.LinkException

Retrieves the remaining unresolved portion of the link name.

getLinkResolvedName() - Method in exception javax.naming.LinkException

Retrieves the leading portion of the link name that was resolved successfully.

getLinkResolvedObj() - Method in exception javax.naming.LinkException

Retrieves the object to which resolution was successful.

getLinkText(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the contiguous text within the document that is associated with this hyperlink.

getList() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getList().

getList() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns the list that is being used to draw the items in the combo box.

getList() - Method in class javax.swing.SpinnerListModel

Returns the List that defines the sequence for this model.

getListCellRendererComponent(JList<?>, Object, int, boolean, boolean) - Method in class javax.swing.DefaultListCellRenderer

getListCellRendererComponent(JList<? extends E>, E, int, boolean, boolean) - Method in interface javax.swing.ListCellRenderer

Return a component that has been configured to display the specified value.

getListCellRendererComponent(JList, Object, int, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicComboBoxRenderer

getListCellRendererComponent(JList, Object, int, boolean, boolean) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer

getListDataListeners() - Method in class javax.swing.AbstractListModel

Returns an array of all the list data listeners registered on this AbstractListModel.

getListener() - Method in class java.util.EventListenerProxy

Returns the listener associated with the proxy.

getListener() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getListener() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getListener() - Method in interface javax.xml.bind.Marshaller

Return Marshaller.Listener registered with this Marshaller.

getListener() - Method in interface javax.xml.bind.Unmarshaller

Return Unmarshaller.Listener registered with this Unmarshaller.

getListenerCount() - Method in class javax.swing.event.EventListenerList

Returns the total number of listeners for this listener list.

getListenerCount(Class<?>) - Method in class javax.swing.event.EventListenerList

Returns the total number of listeners of the supplied type for this listener list.

getListenerID() - Method in class javax.management.remote.TargetedNotification

The ID of the listener to which the notification is targeted.

getListenerList() - Method in class javax.swing.event.EventListenerList

Passes back the event listener list as an array of ListenerType-listener pairs.

getListenerMethodDescriptors() - Method in class java.beans.EventSetDescriptor

Gets the MethodDescriptors of the target listener interface.

getListenerMethodName() - Method in class java.beans.EventHandler

Returns the name of the method that will trigger the action.

getListenerMethods() - Method in class java.beans.EventSetDescriptor

Gets the methods of the target listener interface.

getListeners(EventListener, Class<T>) - Static method in class java.awt.AWTEventMulticaster

Returns an array of all the objects chained as FooListeners by the specified java.util.EventListener.

getListeners(Class<T>) - Method in class java.awt.Button

Returns an array of all the objects currently registered as FooListeners upon this Button.

getListeners(Class<T>) - Method in class java.awt.Checkbox

Returns an array of all the objects currently registered as FooListeners upon this Checkbox.

getListeners(Class<T>) - Method in class java.awt.CheckboxMenuItem

Returns an array of all the objects currently registered as FooListeners upon this CheckboxMenuItem.

getListeners(Class<T>) - Method in class java.awt.Choice

Returns an array of all the objects currently registered as FooListeners upon this Choice.

getListeners(Class<T>) - Method in class java.awt.Component

Returns an array of all the objects currently registered as FooListeners upon this Component.

getListeners(Class<T>) - Method in class java.awt.Container

Returns an array of all the objects currently registered as FooListeners upon this Container.

getListeners(Class<T>) - Method in class java.awt.dnd.DragSource

Gets all the objects currently registered as FooListeners upon this DragSource.

getListeners(Class<T>) - Method in class java.awt.List

Returns an array of all the objects currently registered as FooListeners upon this List.

getListeners(Class<T>) - Method in class java.awt.MenuItem

Returns an array of all the objects currently registered as FooListeners upon this MenuItem.

getListeners(Class<T>) - Method in class java.awt.Scrollbar

Returns an array of all the objects currently registered as FooListeners upon this Scrollbar.

getListeners(Class<T>) - Method in class java.awt.TextComponent

Returns an array of all the objects currently registered as FooListeners upon this TextComponent.

getListeners(Class<T>) - Method in class java.awt.TextField

Returns an array of all the objects currently registered as FooListeners upon this TextField.

getListeners(Class<T>) - Method in class java.awt.Window

Returns an array of all the objects currently registered as FooListeners upon this Window.

getListeners(Class<T>) - Method in class javax.swing.AbstractListModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.AbstractSpinnerModel

Return an array of all the listeners of the given type that were added to this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultBoundedRangeModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultButtonModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultListSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultSingleSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.event.EventListenerList

Return an array of all the listeners of the given type.

getListeners(Class<T>) - Method in class javax.swing.JComponent

Returns an array of all the objects currently registered as FooListeners upon this JComponent.

getListeners(Class<T>) - Method in class javax.swing.table.AbstractTableModel

Returns an array of all the objects currently registered as FooListeners upon this AbstractTableModel.

getListeners(Class<T>) - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.text.AbstractDocument

Returns an array of all the objects currently registered as FooListeners upon this document.

getListeners(Class<T>) - Method in class javax.swing.text.DefaultCaret

Returns an array of all the objects currently registered as FooListeners upon this caret.

getListeners(Class<T>) - Method in class javax.swing.text.StyleContext.NamedStyle

Return an array of all the listeners of the given type that were added to this model.

getListeners(Class<T>) - Method in class javax.swing.Timer

Returns an array of all the objects currently registered as FooListeners upon this Timer.

getListeners(Class<T>) - Method in class javax.swing.tree.DefaultTreeModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListenerType() - Method in class java.beans.EventSetDescriptor

Gets the 类 object for the target interface.

getListPainter(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the list formatter to use for the given set of CSS attributes.

getListSelectionListeners() - Method in class javax.swing.DefaultListSelectionModel

Returns an array of all the list selection listeners registered on this DefaultListSelectionModel.

getListSelectionListeners() - Method in class javax.swing.JList

Returns an array of all the ListSelectionListeners added to this JList by way of addListSelectionListener.

getLoadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the number of classes that are currently loaded in the Java virtual machine.

getLoadedInstruments() - Method in interface javax.sound.midi.Synthesizer

Obtains a list of the instruments that are currently loaded onto this Synthesizer.

getLoadingImageIcon() - Method in class javax.swing.text.html.ImageView

Returns the icon to use while in the process of loading the image.

getLoadsSynchronously() - Method in class javax.swing.text.html.ImageView

Returns true if the image should be loaded when first asked for.

getLocalAddress() - Method in class java.net.DatagramSocket

Gets the local address to which the socket is bound.

getLocalAddress() - Method in class java.net.Socket

Gets the local address to which the socket is bound.

getLocalAddress() - Method in interface java.nio.channels.NetworkChannel

Returns the socket address that this channel's socket is bound to, or null if the socket is not bound.

getLocalAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved local address on which the request was received.

getLocalBounds(Component) - Static method in class javax.swing.SwingUtilities

Return the rectangle (0,0,bounds.width,bounds.height) for the component aComponent

getLocalCertificateChain() - Method in class java.net.SecureCacheResponse

Returns the certificate chain that were sent to the server during handshaking of the original connection that retrieved the network resource.

getLocalCertificates() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the certificate(s) that were sent to the peer during handshaking.

getLocalCertificates() - Method in class javax.net.ssl.HttpsURLConnection

Returns the certificate(s) that were sent to the server during handshaking.

getLocalCertificates() - Method in interface javax.net.ssl.SSLSession

Returns the certificate(s) that were sent to the peer during handshaking.

getLocale() - Method in class java.applet.Applet

Gets the locale of the applet.

getLocale() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the locale of this object.

getLocale() - Method in class java.awt.Component

Gets the locale of this component.

getLocale() - Method in class java.awt.im.InputContext

Returns the current locale of the current input method or keyboard layout.

getLocale() - Method in interface java.awt.im.spi.InputMethod

Returns the current input locale.

getLocale() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the locale of the component.

getLocale() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the locale of this object.

getLocale() - Method in class java.awt.Window

Gets the Locale object that is associated with this window, if the locale has been set.

getLocale() - Method in class java.beans.beancontext.BeanContextSupport

Gets the locale for this BeanContext.

getLocale() - Method in class java.text.MessageFormat

Gets the locale that's used when creating or comparing subformats.

getLocale() - Method in class java.util.ResourceBundle

Returns the locale of this resource bundle.

getLocale() - Method in class javax.accessibility.AccessibleContext

Gets the locale of the component.

getLocale() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the current locale or null if no locale is in effect.

getLocale() - Method in class javax.imageio.ImageReader

Returns the currently set Locale, or null if none has been set.

getLocale() - Method in class javax.imageio.ImageWriteParam

Returns the currently set Locale, or null if only a default Locale is supported.

getLocale() - Method in class javax.imageio.ImageWriter

Returns the currently set Locale, or null if none has been set.

getLocale() - Method in class javax.print.attribute.TextSyntax

Returns this text attribute's text string's natural language (locale).

getLocale() - Method in class javax.security.auth.callback.LanguageCallback

Get the retrieved Locale.

getLocale() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the locale of this object.

getLocale() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocale() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the locale of the component.

getLocale() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Gets the locale of the component.

getLocale() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the locale of the component.

getLocale() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocalGraphicsEnvironment() - Static method in class java.awt.GraphicsEnvironment

Returns the local GraphicsEnvironment.

getLocalHost() - Static method in class java.net.InetAddress

Returns the address of the local host.

getLocalizedCompressionTypeName() - Method in class javax.imageio.ImageWriteParam

Returns a localized version of the name of the current compression type, using the Locale returned by getLocale.

getLocalizedInputStream(InputStream) - Method in class java.lang.Runtime

Deprecated.
As of JDK 1.1, the preferred way to translate a byte stream in the local encoding into a character stream in Unicode is via the InputStreamReader and BufferedReader classes.

getLocalizedMessage() - Method in class java.lang.Throwable

Creates a localized description of this throwable.

getLocalizedName() - Method in class java.util.logging.Level

Return the localized string name of the Level, for the current default locale.

getLocalizedOutputStream(OutputStream) - Method in class java.lang.Runtime

Deprecated.
As of JDK 1.1, the preferred way to translate a Unicode character stream into a byte stream in the local encoding is via the OutputStreamWriter, BufferedWriter, and PrintWriter classes.

getLocalName() - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getNodeName.

getLocalName() - Method in interface javax.xml.soap.Name

Gets the local name part of the XML name that this Name object represents.

getLocalName() - Method in class javax.xml.stream.util.StreamReaderDelegate

getLocalName() - Method in interface javax.xml.stream.XMLStreamReader

Returns the (local) name of the current event.

getLocalName() - Method in interface org.w3c.dom.Node

Returns the local part of the qualified name of this node.

getLocalName(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's local name by index.

getLocalName(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's local name.

getLocalPart() - Method in class javax.xml.namespace.QName

Get the local part of this QName.

getLocalPatternChars() - Method in class java.text.DateFormatSymbols

Gets localized date-time pattern characters.

getLocalPort() - Method in class java.net.DatagramSocket

Returns the port number on the local host to which this socket is bound.

getLocalPort() - Method in class java.net.DatagramSocketImpl

Gets the local port.

getLocalPort() - Method in class java.net.ServerSocket

Returns the port number on which this socket is listening.

getLocalPort() - Method in class java.net.Socket

Returns the local port number to which this socket is bound.

getLocalPort() - Method in class java.net.SocketImpl

Returns the value of this socket's localport field.

getLocalPrincipal() - Method in class java.net.SecureCacheResponse

Returns the principal that was sent to the server during handshaking in the original connection that retrieved the network resource.

getLocalPrincipal() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the principal that was sent to the peer during handshaking.

getLocalPrincipal() - Method in class javax.net.ssl.HttpsURLConnection

Returns the principal that was sent to the server during handshaking.

getLocalPrincipal() - Method in interface javax.net.ssl.SSLSession

Returns the principal that was sent to the peer during handshaking.

getLocalSocketAddress() - Method in class java.net.DatagramSocket

Returns the address of the endpoint this socket is bound to.

getLocalSocketAddress() - Method in class java.net.ServerSocket

Returns the address of the endpoint this socket is bound to, or null if it is not bound yet.

getLocalSocketAddress() - Method in class java.net.Socket

Returns the address of the endpoint this socket is bound to, or null if it is not bound yet.

getLocalSupportedSignatureAlgorithms() - Method in class javax.net.ssl.ExtendedSSLSession

Obtains an array of supported signature algorithms that the local side is willing to use.

getLocation() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.Component

Gets the location of this component in the form of a point specifying the component's top-left corner.

getLocation(Point) - Method in class java.awt.Component

Stores the x,y origin of this component into "return value" rv and return rv.

getLocation() - Method in class java.awt.dnd.DragSourceEvent

This method returns a Point indicating the cursor location in screen coordinates at the moment this event occured, or null if the cursor location is not specified for this event.

getLocation() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns a Point indicating the Cursor's current location within the Component's coordinates.

getLocation() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns a Point indicating the Cursor's current location in the Component's coordinates.

getLocation() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.Point

Returns the location of this point.

getLocation() - Method in class java.awt.PointerInfo

Returns the Point that represents the coordinates of the pointer on the screen.

getLocation() - Method in class java.awt.Rectangle

Returns the location of this Rectangle.

getLocation() - Method in exception java.net.HttpRetryException

Returns the value of the Location header field if the error resulted from redirection.

getLocation() - Method in class java.rmi.activation.ActivationDesc

Returns the code location for the object specified by this descriptor.

getLocation() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's code location.

getLocation() - Method in class java.security.CodeSource

Returns the location associated with this CodeSource.

getLocation() - Method in interface javax.accessibility.AccessibleComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation(Point) - Method in class javax.swing.JComponent

Stores the x,y origin of this component into "return value" rv and returns rv.

getLocation() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocation() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocation() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocation(JavaFileManager.Location) - Method in interface javax.tools.StandardJavaFileManager

Gets the path associated with the given location.

getLocation() - Method in interface javax.xml.stream.events.XMLEvent

Return the location of this event.

getLocation() - Method in class javax.xml.stream.util.StreamReaderDelegate

getLocation() - Method in exception javax.xml.stream.XMLStreamException

Gets the location of the exception

getLocation() - Method in interface javax.xml.stream.XMLStreamReader

Return the current location of the processor.

getLocation() - Method in interface org.w3c.dom.DOMError

The location of the error.

getLocationAsString() - Method in exception javax.xml.transform.TransformerException

Get the location information as a string.

getLocationInJTree() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocationOffset(int, int) - Method in interface java.awt.im.InputMethodRequests

Gets the offset within the composed text for the specified absolute x and y coordinates on the screen.

getLocationOnScreen() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class java.awt.Component

Gets the location of this component in the form of a point specifying the component's top-left corner in the screen's coordinate space.

getLocationOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute x, y position of the event.

getLocationOnScreen() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in interface javax.accessibility.AccessibleComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocationOnScreen() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocationOnScreen() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocator() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLocator() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the locator for this warning/error.

getLocator() - Method in exception javax.xml.transform.TransformerException

Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.

getLockedMonitors() - Method in class java.lang.management.ThreadInfo

Returns an array of MonitorInfo objects, each of which represents an object monitor currently locked by the thread associated with this ThreadInfo.

getLockedStackDepth() - Method in class java.lang.management.MonitorInfo

Returns the depth in the stack trace where the object monitor was locked.

getLockedStackFrame() - Method in class java.lang.management.MonitorInfo

Returns the stack frame that locked the object monitor.

getLockedSynchronizers() - Method in class java.lang.management.ThreadInfo

Returns an array of LockInfo objects, each of which represents an ownable synchronizer currently locked by the thread associated with this ThreadInfo.

getLockInfo() - Method in class java.lang.management.ThreadInfo

Returns the LockInfo of an object for which the thread associated with this ThreadInfo is blocked waiting.

getLockingKeyState(int) - Method in class java.awt.Toolkit

Returns whether the given locking key on the keyboard is currently in its "on" state.

getLockName() - Method in class java.lang.management.ThreadInfo

Returns the string representation of an object for which the thread associated with this ThreadInfo is blocked waiting.

getLockOwnerId() - Method in class java.lang.management.ThreadInfo

Returns the ID of the thread which owns the object for which the thread associated with this ThreadInfo is blocked waiting.

getLockOwnerName() - Method in class java.lang.management.ThreadInfo

Returns the name of the thread which owns the object for which the thread associated with this ThreadInfo is blocked waiting.

getLog() - Static method in class java.rmi.server.RemoteServer

Returns stream for the RMI call log.

getLogger(String) - Static method in class java.util.logging.Logger

Find or create a logger for a named subsystem.

getLogger(String, String) - Static method in class java.util.logging.Logger

Find or create a logger for a named subsystem.

getLogger(String) - Method in class java.util.logging.LogManager

Method to find a named logger.

getLogger() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the logging object for applications to retrieve synchronization events posted by SyncProvider implementations.

getLoggerLevel(String) - Method in interface java.lang.management.PlatformLoggingMXBean

Gets the name of the log level associated with the specified logger.

getLoggerLevel(String) - Method in interface java.util.logging.LoggingMXBean

Gets the name of the log level associated with the specified logger.

getLoggerName() - Method in class java.util.logging.LogRecord

Get the source Logger's name.

getLoggerNames() - Method in interface java.lang.management.PlatformLoggingMXBean

Returns the list of the currently registered logger names.

getLoggerNames() - Method in interface java.util.logging.LoggingMXBean

Returns the list of currently registered logger names.

getLoggerNames() - Method in class java.util.logging.LogManager

Get an enumeration of known logger names.

getLoggingMXBean() - Static method in class java.util.logging.LogManager

Returns LoggingMXBean for managing loggers.

getLogicalBounds() - Method in class java.awt.font.GlyphVector

Returns the logical bounds of this GlyphVector.

getLogicalHighlightShape(int, int, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the logical selection in the specified range, extended to the specified bounds.

getLogicalHighlightShape(int, int) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the logical selection in the specified range, extended to the natural bounds of this TextLayout.

getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the logical ranges of text corresponding to a visual selection.

getLogicalStyle() - Method in class javax.swing.JTextPane

Fetches the logical style assigned to the paragraph represented by the current position of the caret, or null.

getLogicalStyle(int) - Method in class javax.swing.text.DefaultStyledDocument

Fetches the logical style assigned to the paragraph represented by the given position.

getLogicalStyle(int) - Method in interface javax.swing.text.StyledDocument

Gets a logical style for a given position in a paragraph.

getLogicalView(FlowView) - Method in class javax.swing.text.FlowView.FlowStrategy

This method gives flow strategies access to the logical view of the FlowView.

getLoginModuleName() - Method in class javax.security.auth.login.AppConfigurationEntry

Get the class name of the configured LoginModule.

getLoginTimeout() - Static method in class java.sql.DriverManager

Gets the maximum time in seconds that a driver can wait when attempting to log in to a database.

getLoginTimeout() - Method in interface javax.sql.CommonDataSource

Gets the maximum time in seconds that this data source can wait while attempting to connect to a database.

getLogManager() - Static method in class java.util.logging.LogManager

Return the global LogManager object.

getLogStream() - Static method in class java.sql.DriverManager

Deprecated.

getLogTimers() - Static method in class javax.swing.Timer

Returns true if logging is enabled.

getLogWriter() - Static method in class java.sql.DriverManager

Retrieves the log writer.

getLogWriter() - Method in interface javax.sql.CommonDataSource

Retrieves the log writer for this DataSource object.

getLong(String) - Static method in class java.lang.Long

Determines the long value of the system property with the specified name.

getLong(String, long) - Static method in class java.lang.Long

Determines the long value of the system property with the specified name.

getLong(String, Long) - Static method in class java.lang.Long

Returns the long value of the system property with the specified name.

getLong(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a long.

getLong(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type long or of another primitive type convertible to type long via a widening conversion.

getLong() - Method in class java.nio.ByteBuffer

Relative get method for reading a long value.

getLong(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a long value.

getLong(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BIGINT parameter as a long in the Java programming language.

getLong(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BIGINT parameter as a long in the Java programming language.

getLong(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a long in the Java programming language.

getLong(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a long in the Java programming language.

getLong(String, long) - Method in class java.util.prefs.AbstractPreferences

Implements the getLong method as per the specification in Preferences.getLong(String,long).

getLong(String, long) - Method in class java.util.prefs.Preferences

Returns the long value represented by the string associated with the specified key in this preference node.

getLongFramePosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in sample frames.

getLongParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a long.

getLookAndFeel() - Static method in class javax.swing.UIManager

Returns the current look and feel or null.

getLookAndFeelDefaults() - Static method in class javax.swing.UIManager

Returns the UIDefaults from the current look and feel, that were obtained at the time the look and feel was installed.

getLoopbackAddress() - Static method in class java.net.InetAddress

Returns the loopback address.

getLoopbackMode() - Method in class java.net.MulticastSocket

Get the setting for local loopback of multicast datagrams.

getLoopCount() - Method in interface javax.sound.midi.Sequencer

Obtains the number of repetitions for playback.

getLoopEndPoint() - Method in interface javax.sound.midi.Sequencer

Obtains the end position of the loop, in MIDI ticks.

getLoopStartPoint() - Method in interface javax.sound.midi.Sequencer

Obtains the start position of the loop, in MIDI ticks.

getLowerBound() - Method in interface javax.lang.model.type.TypeVariable

Returns the lower bound of this type variable.

getLowerBounds() - Method in interface java.lang.reflect.WildcardType

Returns an array of Type objects representing the lower bound(s) of this type variable.

getLoweredBevelBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getLowestSetBit() - Method in class java.math.BigInteger

Returns the index of the rightmost (lowest-order) one bit in this BigInteger (the number of zero bits to the right of the rightmost one bit).

getLowestValue() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the smallest value that has an entry in the label table.

getLowestValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the label that corresponds to the highest slider value in the label table.

getLowThreshold() - Method in class javax.management.monitor.GaugeMonitor

Gets the low threshold value common to all observed MBeans.

getLowThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the low threshold value.

getLSB() - Method in class java.awt.font.GlyphMetrics

Returns the left (top) side bearing of the glyph.

getM() - Method in class java.security.spec.ECFieldF2m

Returns the value m of this characteristic 2 finite field.

getMacLength() - Method in class javax.crypto.Mac

Returns the length of the MAC in bytes.

getMagicCaretPosition() - Method in interface javax.swing.text.Caret

Gets the current caret visual location.

getMagicCaretPosition() - Method in class javax.swing.text.DefaultCaret

Gets the saved caret position.

getMainAttributes() - Method in class java.net.JarURLConnection

Returns the main Attributes for the JAR file for this connection.

getMainAttributes() - Method in class java.util.jar.Manifest

Returns the main Attributes for the Manifest.

getMajor() - Method in exception org.ietf.jgss.GSSException

Returns the GSS-API level major error code for the problem causing this exception to be thrown.

getMajorAxis() - Method in class javax.swing.text.AsyncBoxView

Fetch the major axis (the axis the children are tiled along).

getMajorOffset() - Method in class javax.swing.text.AsyncBoxView.ChildState

Get the offset along the major axis

getMajorSpan() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the span along the major axis.

getMajorString() - Method in exception org.ietf.jgss.GSSException

Returns a string explaining the GSS-API level major error code in this exception.

getMajorTickSpacing() - Method in class javax.swing.JSlider

This method returns the major tick spacing.

getMajorVersion() - Method in class java.awt.color.ICC_Profile

Returns profile major version.

getMajorVersion() - Method in interface java.sql.Driver

Retrieves the driver's major version number.

getManagementSpecVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the version of the specification for the management interface implemented by the running Java virtual machine.

getManifest() - Method in class java.net.JarURLConnection

Returns the Manifest for this connection, or null if none.

getManifest() - Method in class java.util.jar.JarFile

Returns the jar file manifest, or null if none.

getManifest() - Method in class java.util.jar.JarInputStream

Returns the Manifest for this JAR file, or null if none.

getMapSize() - Method in class java.awt.image.IndexColorModel

Returns the size of the color/alpha component arrays in this IndexColorModel.

getMargin() - Method in class javax.swing.AbstractButton

Returns the margin between the button's border and the label.

getMargin() - Method in class javax.swing.JMenuBar

Returns the margin between the menubar's border and its menus.

getMargin() - Method in class javax.swing.JPopupMenu

Returns the margin, in pixels, between the popup menu's border and its containees.

getMargin() - Method in class javax.swing.JToolBar

Returns the margin between the tool bar's border and its buttons.

getMargin() - Method in class javax.swing.text.JTextComponent

Returns the margin between the text component's border and its text.

getMark() - Method in class javax.swing.event.CaretEvent

Fetches the location of other end of a logical selection.

getMark() - Method in interface javax.swing.text.Caret

Fetches the current position of the mark.

getMark() - Method in class javax.swing.text.DefaultCaret

Fetches the current position of the mark.

getMarkBias() - Method in class javax.swing.text.DefaultCaret

Returns the bias of the mark.

getMask(int) - Method in class java.awt.image.PackedColorModel

Returns the mask indicating which bits in a pixel contain the specified color/alpha sample.

getMask() - Method in class javax.swing.text.MaskFormatter

Returns the formatting mask.

getMaskForButton(int) - Static method in class java.awt.event.InputEvent

A method to obtain a mask for any existing mouse button.

getMasks() - Method in class java.awt.image.PackedColorModel

Returns a mask array indicating which bits in a pixel contain the color and alpha samples.

getMasterSyncMode() - Method in interface javax.sound.midi.Sequencer

Obtains the current master synchronization mode for this sequencer.

getMasterSyncModes() - Method in interface javax.sound.midi.Sequencer

Obtains the set of master synchronization modes supported by this sequencer.

getMatchAllSubjectAltNames() - Method in class java.security.cert.X509CertSelector

Indicates if the X509Certificate must contain all or at least one of the subjectAlternativeNames specified in the setSubjectAlternativeNames or addSubjectAlternativeName methods.

getMatchColumnIndexes() - Method in interface javax.sql.rowset.Joinable

Retrieves the indexes of the match columns that were set for this RowSet object with the method setMatchColumn(int[] columnIdxes).

getMatchColumnNames() - Method in interface javax.sql.rowset.Joinable

Retrieves the names of the match columns that were set for this RowSet object with the method setMatchColumn(String [] columnNames).

getMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeader objects whose name matches a name in the given array of names.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatchingRuleID() - Method in class javax.naming.ldap.SortKey

Retrieves the matching rule ID used to order the attribute values.

getMatrix() - Method in class java.awt.color.ICC_ProfileRGB

Returns a 3x3 float matrix constructed from the X, Y, and Z components of the profile's redColorantTag, greenColorantTag, and blueColorantTag.

getMatrix(double[]) - Method in class java.awt.geom.AffineTransform

Retrieves the 6 specifiable values in the 3x3 affine transformation matrix and places them into an array of double precisions values.

getMatrix() - Method in class java.awt.image.BandCombineOp

Returns a copy of the linear combination matrix.

getMatrix() - Method in class java.awt.print.PageFormat

Returns a transformation matrix that translates user space rendering to the requested orientation of the page.

getMatteColor() - Method in class javax.swing.border.MatteBorder

Returns the color used for tiling the border or null if a tile icon is being used.

getMax() - Method in class java.lang.management.MemoryUsage

Returns the maximum amount of memory in bytes that can be used for memory management.

getMaxAdvance() - Method in class java.awt.FontMetrics

Gets the maximum advance width of any character in this Font.

getMaxAge() - Method in class java.net.HttpCookie

Returns the maximum age of the cookie, specified in seconds.

getMaxAllowedKeyLength(String) - Static method in class javax.crypto.Cipher

Returns the maximum key length for the specified transformation according to the installed JCE jurisdiction policy files.

getMaxAllowedParameterSpec(String) - Static method in class javax.crypto.Cipher

Returns an AlgorithmParameterSpec object which contains the maximum cipher parameter value according to the jurisdiction policy file.

getMaxAscent() - Method in class java.awt.FontMetrics

Determines the maximum ascent of the Font described by this FontMetrics object.

getMaxBinaryLiteralLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of hex characters this database allows in an inline binary literal.

getMaxBufferSize() - Method in class javax.sound.sampled.DataLine.Info

Obtains the maximum buffer size supported by the data line.

getMaxCatalogNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a catalog name.

getMaxCharactersPerLineCount() - Method in class javax.swing.JOptionPane

Returns the maximum number of characters to place on a line in a message.

getMaxCharactersPerLineCount() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the maximum number of characters to place on a line.

getMaxCharBounds(FontRenderContext) - Method in class java.awt.Font

Returns the bounds for the character with the maximum bounds as defined in the specified FontRenderContext.

getMaxCharBounds(Graphics) - Method in class java.awt.FontMetrics

Returns the bounds for the character with the maximum bounds in the specified Graphics context.

getMaxCharLiteralLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows for a character literal.

getMaxColumnNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows for a column name.

getMaxColumnsInGroupBy() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a GROUP BY clause.

getMaxColumnsInIndex() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in an index.

getMaxColumnsInOrderBy() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in an ORDER BY clause.

getMaxColumnsInSelect() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a SELECT list.

getMaxColumnsInTable() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a table.

getMaxConnections() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of concurrent connections to this database that are possible.

getMaxCRL() - Method in class java.security.cert.X509CRLSelector

Returns the maxCRLNumber criterion.

getMaxCursorNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a cursor name.

getMaxDecent() - Method in class java.awt.FontMetrics

Deprecated.
As of JDK version 1.1.1, replaced by getMaxDescent().

getMaxDegree() - Method in class javax.management.relation.RoleInfo

Returns maximum degree for corresponding role reference.

getMaxDescent() - Method in class java.awt.FontMetrics

Determines the maximum descent of the Font described by this FontMetrics object.

getMaxExpansion(int) - Method in class java.text.CollationElementIterator

Return the maximum length of any expansion sequences that end with the specified comparison order.

getMaxFieldSize() - Method in interface java.sql.Statement

Retrieves the maximum number of bytes that can be returned for character and binary column values in a ResultSet object produced by this Statement object.

getMaxFieldSize() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of bytes that can be used for a column value in this RowSet object.

getMaxFieldSize() - Method in interface javax.sql.RowSet

Retrieves the maximum number of bytes that may be returned for certain column values.

getMaximizedBounds() - Method in class java.awt.Frame

Gets maximized bounds for this frame.

getMaximum() - Method in interface java.awt.Adjustable

Gets the maximum value of the adjustable object.

getMaximum() - Method in class java.awt.Scrollbar

Gets the maximum value of this scroll bar.

getMaximum() - Method in class java.awt.ScrollPaneAdjustable

getMaximum(int) - Method in class java.util.Calendar

Returns the maximum value for the given calendar field of this Calendar instance.

getMaximum(int) - Method in class java.util.GregorianCalendar

Returns the maximum value for the given calendar field of this GregorianCalendar instance.

getMaximum() - Method in class javax.sound.sampled.FloatControl

Obtains the maximum value permitted.

getMaximum() - Method in interface javax.swing.BoundedRangeModel

Returns the model's maximum.

getMaximum() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's maximum.

getMaximum() - Method in class javax.swing.JProgressBar

Returns the progress bar's maximum value from the BoundedRangeModel.

getMaximum() - Method in class javax.swing.JScrollBar

The maximum value of the scrollbar is maximum - extent.

getMaximum() - Method in class javax.swing.JSlider

Returns the maximum value supported by the slider from the BoundedRangeModel.

getMaximum() - Method in class javax.swing.ProgressMonitor

Returns the maximum value -- the higher end of the progress value.

getMaximum() - Method in class javax.swing.SpinnerNumberModel

Returns the last number in the sequence.

getMaximum() - Method in class javax.swing.text.InternationalFormatter

Returns the maximum permissible value.

getMaximumAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the maximum accessible value of this object.

getMaximumCharHeight(SynthContext) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the maximum height of the the Font from the passed in SynthContext.

getMaximumCursorColors() - Method in class java.awt.Toolkit

Returns the maximum number of colors the Toolkit supports in a custom cursor palette.

getMaximumDividerLocation() - Method in class javax.swing.JSplitPane

Returns the maximum location of the divider from the look and feel implementation.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Gets the maximum location of the divider.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMaximumDividerLocation method on each UI handled by this object.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the maximum possible location of the divider.

getMaximumFractionDigits() - Method in class java.text.DecimalFormat

Gets the maximum number of digits allowed in the fraction portion of a number.

getMaximumFractionDigits() - Method in class java.text.NumberFormat

Returns the maximum number of digits allowed in the fraction portion of a number.

getMaximumIntegerDigits() - Method in class java.text.DecimalFormat

Gets the maximum number of digits allowed in the integer portion of a number.

getMaximumIntegerDigits() - Method in class java.text.NumberFormat

Returns the maximum number of digits allowed in the integer portion of a number.

getMaximumPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the maximum allowed number of threads.

getMaximumRowCount() - Method in class javax.swing.JComboBox

Returns the maximum number of items the combo box can display without a scrollbar

getMaximumSize() - Method in class java.awt.Component

Gets the maximum size of this component.

getMaximumSize() - Method in class java.awt.Container

Returns the maximum size of this container.

getMaximumSize() - Method in class javax.swing.JComponent

If the maximum size has been set to a non-null value just returns it.

getMaximumSize() - Method in class javax.swing.JScrollBar

The scrollbar is flexible along it's scrolling axis and rigid along the other axis.

getMaximumSize() - Method in class javax.swing.JToolBar.Separator

Returns the maximum size for the separator.

getMaximumSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the maximum size of the BasicArrowButton.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

Desktop icons can not be resized.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the maximum size for the passed in component, This is passed off to the current layoutmanager.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the maximum size of the header.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the maximum size of the table.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the maximum size for the editor component.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the maximum size for this component, which will be the preferred size if the instance is currently in a JTree, or 0, 0.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's maximum size appropriate for the look and feel.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getMaximumSize() method.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the maximum size of the JFileChooser.

getMaximumSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the maximum size needed to properly render an icon and text.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

getMaximumSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.BoxView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.ComponentView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.FormView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.View

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the maximum span for this view along an axis.

getMaximumStreamFormatVersion() - Method in interface javax.rmi.CORBA.ValueHandlerMultiFormat

Returns the maximum stream format version for RMI/IDL custom value types that is supported by this ValueHandler object.

getMaximumThumbSize() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the largest acceptable size for the thumb.

getMaximumValue() - Method in class javax.swing.Spring

Returns the maximum value of this Spring.

getMaximumWindowBounds() - Method in class java.awt.GraphicsEnvironment

Returns the maximum bounds for centered Windows.

getMaximumZoneSize() - Method in class javax.swing.text.ZoneView

Get the current maximum zone size.

getMaxIndexLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of bytes this database allows for an index, including all of the parts of the index.

getMaxLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the maximum value, such as "Right" or "Full."

getMaxLines(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains the approximate maximum number of lines of the requested type that can be open simultaneously on the mixer.

getMaxPage() - Method in class java.awt.JobAttributes

Specifies the maximum value the user can specify as the last page to be printed for jobs using these attributes.

getMaxPathLength() - Method in class java.security.cert.PKIXBuilderParameters

Returns the value of the maximum number of intermediate non-self-issued certificates that may exist in a certification path.

getMaxPolyphony() - Method in interface javax.sound.midi.Synthesizer

Obtains the maximum number of notes that this synthesizer can sound simultaneously.

getMaxPriority() - Method in class java.lang.ThreadGroup

Returns the maximum priority of this thread group.

getMaxProcedureNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a procedure name.

getMaxReceivers() - Method in interface javax.sound.midi.MidiDevice

Obtains the maximum number of MIDI IN connections available on this MIDI device for receiving MIDI data.

getMaxRows() - Method in interface java.sql.Statement

Retrieves the maximum number of rows that a ResultSet object produced by this Statement object can contain.

getMaxRows() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of rows that this RowSet object may contain.

getMaxRows() - Method in interface javax.sql.RowSet

Retrieves the maximum number of rows that this RowSet object can contain.

getMaxRowSize() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of bytes this database allows in a single row.

getMaxSchemaNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a schema name.

getMaxSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Returns the last selected index or -1 if the selection is empty.

getMaxSelectionIndex() - Method in class javax.swing.JList

Returns the largest selected cell index, or -1 if the selection is empty.

getMaxSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Returns the last selected index or -1 if the selection is empty.

getMaxSelectionRow() - Method in class javax.swing.JTree

Returns the largest selected row.

getMaxSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.

getMaxSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.

getMaxSortKeys() - Method in class javax.swing.DefaultRowSorter

Returns the maximum number of sort keys.

getMaxStatementLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in an SQL statement.

getMaxStatements() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of active statements to this database that can be open at the same time.

getMaxTableNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in a table name.

getMaxTablesInSelect() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of tables this database allows in a SELECT statement.

getMaxTransmitters() - Method in interface javax.sound.midi.MidiDevice

Obtains the maximum number of MIDI OUT connections available on this MIDI device for transmitting MIDI data.

getMaxUserNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in a user name.

getMaxValue(int) - Method in class java.awt.color.ColorSpace

Returns the maximum normalized color component value for the specified component.

getMaxValue(int) - Method in class java.awt.color.ICC_ColorSpace

Returns the maximum normalized color component value for the specified component.

getMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the maximal value for this parameter, if it has one, or null otherwise.

getMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getMaxWidth() - Method in class javax.swing.table.TableColumn

Returns the maximum width for the TableColumn.

getMaxX() - Method in class java.awt.geom.RectangularShape

Returns the largest X coordinate of the framing rectangle of the Shape in double precision.

getMaxY() - Method in class java.awt.geom.RectangularShape

Returns the largest Y coordinate of the framing rectangle of the Shape in double precision.

getMaxZonesLoaded() - Method in class javax.swing.text.ZoneView

Get the current setting of the number of zones allowed to be loaded at the same time.

getMBeanCount() - Method in interface javax.management.MBeanServer

Returns the number of MBeans registered in the MBean server.

getMBeanCount() - Method in interface javax.management.MBeanServerConnection

Returns the number of MBeans registered in the MBean server.

getMBeanCount(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getMBeanCount().

getMBeanCount(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getMBeanCount(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getMBeanDescriptor() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the ModelMBean's descriptor which contains MBean wide policies.

getMBeanDescriptor() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getMBeanInfo() - Method in interface javax.management.DynamicMBean

Provides the exposed attributes and actions of the Dynamic MBean using an MBeanInfo object.

getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServer

getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServerConnection

This method discovers the attributes and operations that an MBean exposes for management.

getMBeanInfo() - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.

getMBeanInfo(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getMBeanInfo() - Method in class javax.management.StandardMBean

Get the MBeanInfo for this MBean.

getMBeanInterface() - Method in class javax.management.StandardMBean

Get the Management Interface of this Standard MBean (or MXBean).

getMBeanName() - Method in class javax.management.MBeanServerNotification

Returns the object name of the MBean that caused the notification.

getMBeanServer() - Static method in class javax.management.QueryEval

Return the MBean server that was most recently given to the setMBeanServer method by this thread.

getMBeanServer() - Method in class javax.management.remote.JMXConnectorServer

Returns the MBean server that this connector server is attached to.

getMBeanServer() - Method in interface javax.management.remote.MBeanServerForwarder

Returns the MBeanServer object to which requests will be forwarded.

getMBeanServer() - Method in class javax.management.remote.rmi.RMIServerImpl

The MBeanServer to which this connector server is attached.

getMBeanServerConnection() - Method in class javax.management.MBeanServerInvocationHandler

The MBean server connection through which the methods of a proxy using this handler are forwarded.

getMBeanServerConnection() - Method in interface javax.management.remote.JMXConnector

Returns an MBeanServerConnection object representing a remote MBean server.

getMBeanServerConnection(Subject) - Method in interface javax.management.remote.JMXConnector

Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.

getMBeanServerConnection() - Method in class javax.management.remote.rmi.RMIConnector

getMBeanServerConnection(Subject) - Method in class javax.management.remote.rmi.RMIConnector

getMBeanServerId() - Method in class javax.management.MBeanServerDelegate

Returns the MBean server agent identity.

getMBeanServerId() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the MBean server agent identity.

getMBeansFromURL(URL) - Method in class javax.management.loading.MLet

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(String) - Method in class javax.management.loading.MLet

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(String) - Method in interface javax.management.loading.MLetMBean

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(URL) - Method in interface javax.management.loading.MLetMBean

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansToUnregister() - Method in class javax.management.relation.RelationNotification

Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).

getMech() - Method in interface org.ietf.jgss.GSSContext

Determines what mechanism is being used for this context.

getMechanismName() - Method in interface javax.security.sasl.SaslClient

Returns the IANA-registered mechanism name of this SASL client.

getMechanismName() - Method in interface javax.security.sasl.SaslServer

Returns the IANA-registered mechanism name of this SASL server.

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl.SaslClientFactory

Returns an array of names of mechanisms that match the specified mechanism selection policies.

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl.SaslServerFactory

Returns an array of names of mechanisms that match the specified mechanism selection policies.

getMechanismType() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")

getMechanismType() - Method in class javax.xml.crypto.dsig.TransformService

Returns the mechanism type supported by this TransformService.

getMechanismType() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").

getMechs() - Method in interface org.ietf.jgss.GSSCredential

Returns a list of mechanisms supported by this credential.

getMechs() - Method in class org.ietf.jgss.GSSManager

Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.

getMechsForName(Oid) - Method in class org.ietf.jgss.GSSManager

Returns a list of mechanisms that support the indicated name type.

getMedia() - Method in class java.awt.PageAttributes

Returns the paper size for pages using these attributes.

getMediaSizeForName(MediaSizeName) - Static method in class javax.print.attribute.standard.MediaSize

Get the MediaSize for the specified named media.

getMediaSizeName() - Method in class javax.print.attribute.standard.MediaSize

Get the media name, if any, for this size.

getMediaSubtype() - Method in class javax.print.DocFlavor

Returns this doc flavor object's media subtype (from the MIME type).

getMediaType() - Method in class javax.print.DocFlavor

Returns this doc flavor object's media type (from the MIME type).

getMediaWhitePoint() - Method in class java.awt.color.ICC_ProfileGray

Returns a float array of length 3 containing the X, Y, and Z components of the mediaWhitePointTag in the ICC profile.

getMediaWhitePoint() - Method in class java.awt.color.ICC_ProfileRGB

Returns an array that contains the components of the profile's mediaWhitePointTag.

getMemberControls() - Method in class javax.sound.sampled.CompoundControl

Returns the set of member controls that comprise the compound control.

getMembers() - Method in class javax.print.attribute.SetOfIntegerSyntax

Obtain this set-of-integer attribute's members in canonical array form.

getMemoryManagerMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of MemoryManagerMXBean objects in the Java virtual machine.

getMemoryManagerNames() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the name of memory managers that manages this memory pool.

getMemoryMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the memory system of the Java virtual machine.

getMemoryPoolMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of MemoryPoolMXBean objects in the Java virtual machine.

getMemoryPoolNames() - Method in interface java.lang.management.MemoryManagerMXBean

Returns the name of memory pools that this memory manager manages.

getMemoryUsed() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the memory that the Java virtual machine is using for this buffer pool.

getMenu(int) - Method in class java.awt.MenuBar

Gets the specified menu.

getMenu(int) - Method in class javax.swing.JMenuBar

Returns the menu at the specified position in the menu bar.

getMenuArrowIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuArrowIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getMenuBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu background color of the current theme.

getMenuBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu background color.

getMenuBar() - Method in class java.awt.Frame

Gets the menu bar for this frame.

getMenuBar() - Method in class javax.swing.JInternalFrame

Deprecated.
As of Swing version 1.0.3, replaced by getJMenuBar().

getMenuBar() - Method in class javax.swing.JRootPane

Deprecated.
As of Swing version 1.0.3 replaced by getJMenuBar().

getMenuBarBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getMenuComponent(int) - Method in class javax.swing.JMenu

Returns the component at position n.

getMenuComponentCount() - Method in class javax.swing.JMenu

Returns the number of components on the menu.

getMenuComponents() - Method in class javax.swing.JMenu

Returns an array of Components of the menu's subcomponents.

getMenuCount() - Method in class java.awt.MenuBar

Gets the number of menus on the menu bar.

getMenuCount() - Method in class javax.swing.JMenuBar

Returns the number of items in the menu bar.

getMenuDisabledForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu disabled foreground color of the current theme.

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu disabled foreground color.

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the menu disabled foreground color.

getMenuDragMouseListeners() - Method in class javax.swing.JMenuItem

Returns an array of all the MenuDragMouseListeners added to this JMenuItem with addMenuDragMouseListener().

getMenuForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu foreground color of the current theme.

getMenuForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu foreground color.

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

Returns an icon to be used by JCheckBoxMenuItem.

getMenuKeyListeners() - Method in class javax.swing.JMenuItem

Returns an array of all the MenuKeyListeners added to this JMenuItem with addMenuKeyListener().

getMenuKeyListeners() - Method in class javax.swing.JPopupMenu

Returns an array of all the MenuKeyListeners added to this JPopupMenu with addMenuKeyListener().

getMenuListeners() - Method in class javax.swing.JMenu

Returns an array of all the MenuListeners added to this JMenu with addMenuListener().

getMenuSelectedBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu selected background color of the current theme.

getMenuSelectedBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu selected background color.

getMenuSelectedForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu selected foreground color of the current theme.

getMenuSelectedForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu selected foreground color.

getMenuSelectionManager() - Method in class javax.swing.event.MenuDragMouseEvent

Returns the current menu selection manager.

getMenuSelectionManager() - Method in class javax.swing.event.MenuKeyEvent

Returns the current menu selection manager.

getMenuShortcutKeyMask() - Method in class java.awt.Toolkit

Determines which modifier key is the appropriate accelerator key for menu shortcuts.

getMenuTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the menu text font.

getMenuTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu text font of the current theme.

getMenuTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu text font.

getMessage() - Method in exception java.awt.HeadlessException

getMessage() - Method in exception java.io.InvalidClassException

Produce the message and include the classname, if present.

getMessage() - Method in exception java.io.WriteAbortedException

Produce the message and include the message from the nested exception, if there is one.

getMessage() - Method in class java.lang.Throwable

Returns the detail message string of this throwable.

getMessage() - Method in exception java.net.URISyntaxException

Returns a string describing the parse error.

getMessage() - Method in exception java.nio.charset.MalformedInputException

getMessage() - Method in exception java.nio.charset.UnmappableCharacterException

getMessage() - Method in exception java.nio.file.FileSystemException

Returns the detail message string.

getMessage() - Method in exception java.nio.file.InvalidPathException

Returns a string describing the error.

getMessage() - Method in exception java.rmi.activation.ActivationException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.rmi.RemoteException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.rmi.server.ServerCloneException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.security.cert.CertificateRevokedException

getMessage() - Method in exception java.util.DuplicateFormatFlagsException

getMessage() - Method in exception java.util.FormatFlagsConversionMismatchException

getMessage() - Method in exception java.util.IllegalFormatCodePointException

getMessage() - Method in exception java.util.IllegalFormatConversionException

getMessage() - Method in exception java.util.IllegalFormatFlagsException

getMessage() - Method in exception java.util.IllegalFormatPrecisionException

getMessage() - Method in exception java.util.IllegalFormatWidthException

getMessage() - Method in class java.util.logging.LogRecord

Get the "raw" log message, before localization or formatting.

getMessage() - Method in exception java.util.MissingFormatArgumentException

getMessage() - Method in exception java.util.MissingFormatWidthException

getMessage() - Method in exception java.util.regex.PatternSyntaxException

Returns a multi-line string containing the description of the syntax error and its index, the erroneous regular-expression pattern, and a visual indication of the error index within the pattern.

getMessage() - Method in exception java.util.UnknownFormatConversionException

getMessage() - Method in exception java.util.UnknownFormatFlagsException

getMessage() - Method in interface javax.annotation.processing.Completion

Returns an informative message about the completion.

getMessage() - Method in class javax.management.Notification

Get the notification message.

getMessage() - Method in exception javax.script.ScriptException

Returns a message containing the String passed to a constructor as well as line and column numbers and filename if any of these are known.

getMessage() - Method in class javax.security.auth.callback.TextOutputCallback

Get the message to be displayed.

getMessage() - Method in class javax.sound.midi.MidiEvent

Obtains the MIDI message contained in the event.

getMessage() - Method in class javax.sound.midi.MidiMessage

Obtains the MIDI message data.

getMessage() - Method in class javax.swing.JOptionPane

Returns the message-object this pane displays.

getMessage() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the message to display from the JOptionPane the receiver is providing the look and feel for.

getMessage(Locale) - Method in interface javax.tools.Diagnostic

Gets a localized message for the given locale.

getMessage() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getMessage() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the text message for this warning/error.

getMessage() - Method in error javax.xml.parsers.FactoryConfigurationError

Return the message (if any) for this error .

getMessage() - Method in exception javax.xml.soap.SOAPException

Returns the detail message for this SOAPException object.

getMessage() - Method in error javax.xml.stream.FactoryConfigurationError

Report the message associated with this error

getMessage() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

Return the message (if any) for this error .

getMessage() - Method in interface javax.xml.ws.handler.LogicalMessageContext

Gets the message from this message context

getMessage() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAPMessage from this message context.

getMessage() - Method in exception org.ietf.jgss.GSSException

Returns a textual representation of both the major and the minor status codes.

getMessage() - Method in interface org.w3c.dom.DOMError

An implementation specific string describing the error that occurred.

getMessage() - Method in exception org.xml.sax.SAXException

Return a detail message for this exception.

getMessageAndLocation() - Method in exception javax.xml.transform.TransformerException

Get the error message with location information appended.

getMessageContext() - Method in interface javax.xml.ws.WebServiceContext

Returns the MessageContext for the request being served at the time this method is called.

getMessageDigest() - Method in class java.security.DigestInputStream

Returns the message digest associated with this stream.

getMessageDigest() - Method in class java.security.DigestOutputStream

Returns the message digest associated with this stream.

getMessageFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ MessageFactory instance used by this SOAP binding.

getMessager() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the messager used to report errors, warnings, and other notices.

getMessageType() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the message type.

getMessageType() - Method in class javax.security.auth.callback.TextOutputCallback

Get the message type.

getMessageType() - Method in class javax.swing.JOptionPane

Returns the message type.

getMetaData() - Method in interface java.sql.Connection

Retrieves a DatabaseMetaData object that contains metadata about the database to which this Connection object represents a connection.

getMetaData() - Method in interface java.sql.PreparedStatement

Retrieves a ResultSetMetaData object that contains information about the columns of the ResultSet object that will be returned when this PreparedStatement object is executed.

getMetaData() - Method in interface java.sql.ResultSet

Retrieves the number, types and properties of this ResultSet object's columns.

getMetadata() - Method in class javax.imageio.IIOImage

Returns a reference to the current IIOMetadata object, or null is none is set.

getMetadata() - Method in class javax.xml.ws.Endpoint

Returns a list of metadata documents for the service.

getMetadataFormat(String) - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataFormat object describing the given metadata format, or null if no description is available.

getMetadataFormatNames() - Method in class javax.imageio.metadata.IIOMetadata

Returns an array of Strings containing the names of all metadata formats, including the native and standard formats, recognized by this plug-in's getAsTree, setFromTree, and mergeTree methods.

getMetaKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'meta' key was depressed during the firing of the event.

getMethod() - Method in class java.beans.MethodDescriptor

Gets the method that this MethodDescriptor encapsualtes.

getMethod(String, Class<?>...) - Method in class java.lang.类

Returns a Method object that reflects the specified public member method of the class or interface represented by this 类 object.

getMethod() - Method in class java.util.zip.ZipEntry

Returns the compression method of the entry, or -1 if not specified.

getMethod() - Method in class javax.swing.text.html.FormSubmitEvent

Gets the form method type.

getMethodCallSyntax(String, String, String...) - Method in interface javax.script.ScriptEngineFactory

Returns a String which can be used to invoke a method of a Java object using the syntax of the supported scripting language.

getMethodDescriptors() - Method in interface java.beans.BeanInfo

Gets the beans MethodDescriptors.

getMethodDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of methods.

getMethodName() - Method in class java.beans.Statement

Returns the name of the method to invoke.

getMethodName() - Method in class java.lang.StackTraceElement

Returns the name of the method containing the execution point represented by this stack trace element.

getMethods() - Method in class java.lang.类

Returns an array containing Method objects reflecting all the public member methods of the class or interface represented by this 类 object, including those declared by the class or interface and those inherited from superclasses and superinterfaces.

getMGFAlgorithm() - Method in class java.security.spec.PSSParameterSpec

Returns the mask generation function algorithm name.

getMGFAlgorithm() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the mask generation function algorithm name.

getMGFParameters() - Method in class java.security.spec.PSSParameterSpec

Returns the parameters for the mask generation function.

getMGFParameters() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the parameters for the mask generation function.

getMIC(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss.GSSContext

Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.

getMIC(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss.GSSContext

Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.

getMicrosecondLength() - Method in class javax.sound.midi.MidiFileFormat

Obtains the length of the MIDI file, expressed in microseconds.

getMicrosecondLength() - Method in class javax.sound.midi.Sequence

Obtains the duration of this sequence, expressed in microseconds.

getMicrosecondLength() - Method in interface javax.sound.midi.Sequencer

Obtains the length of the current sequence, expressed in microseconds, or 0 if no sequence is set.

getMicrosecondLength() - Method in interface javax.sound.sampled.Clip

Obtains the media duration in microseconds

getMicrosecondPosition() - Method in interface javax.sound.midi.MidiDevice

Obtains the current time-stamp of the device, in microseconds.

getMicrosecondPosition() - Method in interface javax.sound.midi.Sequencer

Obtains the current position in the sequence, expressed in microseconds.

getMicrosecondPosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in microseconds.

getMidiDevice() - Method in interface javax.sound.midi.MidiDeviceReceiver

Obtains a MidiDevice object which is an owner of this Receiver.

getMidiDevice() - Method in interface javax.sound.midi.MidiDeviceTransmitter

Obtains a MidiDevice object which is an owner of this Transmitter.

getMidiDevice(MidiDevice.Info) - Static method in class javax.sound.midi.MidiSystem

Obtains the requested MIDI device.

getMidiDeviceInfo() - Static method in class javax.sound.midi.MidiSystem

Obtains an array of information objects representing the set of all MIDI devices available on the system.

getMidiFileFormat(InputStream) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the data in the specified input stream.

getMidiFileFormat(URL) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the data in the specified URL.

getMidiFileFormat(File) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the specified File.

getMidiFileFormat(InputStream) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the input stream provided.

getMidiFileFormat(URL) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the URL provided.

getMidiFileFormat(File) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the File provided.

getMidiFileTypes() - Static method in class javax.sound.midi.MidiSystem

Obtains the set of MIDI file types for which file writing support is provided by the system.

getMidiFileTypes(Sequence) - Static method in class javax.sound.midi.MidiSystem

Obtains the set of MIDI file types that the system can write from the sequence specified.

getMidiFileTypes() - Method in class javax.sound.midi.spi.MidiFileWriter

Obtains the set of MIDI file types for which file writing support is provided by this file writer.

getMidiFileTypes(Sequence) - Method in class javax.sound.midi.spi.MidiFileWriter

Obtains the file types that this file writer can write from the sequence specified.

getMidLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the mid-point value, such as "Center" or "Default."

getMidTermsOfReductionPolynomial() - Method in class java.security.spec.ECFieldF2m

Returns an integer array which contains the order of the middle term(s) of the reduction polynomial for polynomial basis or null for normal basis.

getMillis() - Method in class java.util.logging.LogRecord

Get event time in milliseconds since 1970.

getMillisecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return millisecond precision of XMLGregorianCalendar.getFractionalSecond().

getMillisToDecideToPopup() - Method in class javax.swing.ProgressMonitor

Returns the amount of time this object waits before deciding whether or not to popup a progress monitor.

getMillisToPopup() - Method in class javax.swing.ProgressMonitor

Returns the amount of time it will take for the popup to appear.

getMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart

Gets all the values of the header identified by the given String.

getMimeHeader(String) - Method in class javax.xml.soap.SOAPPart

Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.

getMimeHeaders() - Method in class javax.xml.soap.SOAPMessage

Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.

getMimeType() - Method in class java.awt.datatransfer.DataFlavor

Returns the MIME type string for this DataFlavor.

getMimeType() - Method in class javax.activation.ActivationDataFlavor

Return the MIME type for this DataFlavor.

getMimeType() - Method in class javax.print.DocFlavor

Returns this doc flavor object's MIME type string based on the canonical form.

getMimeType() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the mime type of this XMLObject.

getMimeType() - Method in class javax.xml.crypto.OctetStreamData

Returns the MIME type associated with the data object represented by this OctetStreamData.

getMimeTypes() - Method in interface javax.accessibility.AccessibleStreamable

Returns an array of DataFlavor objects for the MIME types this object supports.

getMimeTypes() - Method in class javax.activation.CommandMap

Get all the MIME types known to this command map.

getMimeTypes() - Method in class javax.activation.MailcapCommandMap

Get all the MIME types known to this command map.

getMIMETypes() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing a list of MIME types associated with the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getMimeTypes() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of mimetypes, associated with scripts that can be executed by the engine.

getMinBufferSize() - Method in class javax.sound.sampled.DataLine.Info

Obtains the minimum buffer size supported by the data line.

getMinCRL() - Method in class java.security.cert.X509CRLSelector

Returns the minCRLNumber criterion.

getMinDegree() - Method in class javax.management.relation.RoleInfo

Returns minimum degree for corresponding role reference.

getMinimalDaysInFirstWeek() - Method in class java.util.Calendar

Gets what the minimal days required in the first week of the year are; e.g., if the first week is defined as one that contains the first day of the first month of a year, this method returns 1.

getMinimum() - Method in interface java.awt.Adjustable

Gets the minimum value of the adjustable object.

getMinimum() - Method in class java.awt.Scrollbar

Gets the minimum value of this scroll bar.

getMinimum() - Method in class java.awt.ScrollPaneAdjustable

getMinimum(int) - Method in class java.util.Calendar

Returns the minimum value for the given calendar field of this Calendar instance.

getMinimum(int) - Method in class java.util.GregorianCalendar

Returns the minimum value for the given calendar field of this GregorianCalendar instance.

getMinimum() - Method in class javax.sound.sampled.FloatControl

Obtains the minimum value permitted.

getMinimum() - Method in interface javax.swing.BoundedRangeModel

Returns the minimum acceptable value.

getMinimum() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's minimum.

getMinimum() - Method in class javax.swing.JProgressBar

Returns the progress bar's minimum value from the BoundedRangeModel.

getMinimum() - Method in class javax.swing.JScrollBar

Returns the minimum value supported by the scrollbar (usually zero).

getMinimum() - Method in class javax.swing.JSlider

Returns the minimum value supported by the slider from the BoundedRangeModel.

getMinimum() - Method in class javax.swing.ProgressMonitor

Returns the minimum value -- the lower end of the progress value.

getMinimum() - Method in class javax.swing.SpinnerNumberModel

Returns the first number in this sequence.

getMinimum() - Method in class javax.swing.text.InternationalFormatter

Returns the minimum permissible value.

getMinimumAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the minimum accessible value of this object.

getMinimumDividerLocation() - Method in class javax.swing.JSplitPane

Returns the minimum location of the divider from the look and feel implementation.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Gets the minimum location of the divider.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMinimumDividerLocation method on each UI handled by this object.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the minimum possible location of the divider.

getMinimumFractionDigits() - Method in class java.text.DecimalFormat

Gets the minimum number of digits allowed in the fraction portion of a number.

getMinimumFractionDigits() - Method in class java.text.NumberFormat

Returns the minimum number of digits allowed in the fraction portion of a number.

getMinimumHorizontalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinimumIntegerDigits() - Method in class java.text.DecimalFormat

Gets the minimum number of digits allowed in the integer portion of a number.

getMinimumIntegerDigits() - Method in class java.text.NumberFormat

Returns the minimum number of digits allowed in the integer portion of a number.

getMinimumOptionPaneSize() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the minimum size the option pane should be.

getMinimumSize() - Method in class java.awt.Component

Gets the mininimum size of this component.

getMinimumSize() - Method in class java.awt.Container

Returns the minimum size of this container.

getMinimumSize(int) - Method in class java.awt.List

Gets the minumum dimensions for a list with the specified number of rows.

getMinimumSize() - Method in class java.awt.List

Determines the minimum size of this scrolling list.

getMinimumSize(int, int) - Method in class java.awt.TextArea

Determines the minimum size of a text area with the specified number of rows and columns.

getMinimumSize() - Method in class java.awt.TextArea

Determines the minimum size of this text area.

getMinimumSize(int) - Method in class java.awt.TextField

Gets the minumum dimensions for a text field with the specified number of columns.

getMinimumSize() - Method in class java.awt.TextField

Gets the minumum dimensions for this text field.

getMinimumSize(Component) - Method in class javax.swing.border.TitledBorder

Returns the minimum dimensions this border requires in order to fully display the border and title.

getMinimumSize() - Method in class javax.swing.JComponent

If the minimum size has been set to a non-null value just returns it.

getMinimumSize() - Method in class javax.swing.JScrollBar

The scrollbar is flexible along it's scrolling axis and rigid along the other axis.

getMinimumSize() - Method in class javax.swing.JToolBar.Separator

Returns the minimum size for the separator.

getMinimumSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the minimum size of the BasicArrowButton.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

The minumum size is the size of the display area plus insets plus the button.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The Minimum size for this component is 10.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinimumSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns dividerSize x dividerSize

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the minimum size for the passed in component, This is passed off to the current layoutmanager.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the minimum size of the header.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the minimum size of the table.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

The method is overridden to take into account caret width.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the minimum size for the editor component.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the minimum size for this component.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getMinimalSize() method.

getMinimumSize() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the minimum size of the JFileChooser.

getMinimumSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the minimum size needed to properly render an icon and text.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

getMinimumSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.BoxView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.ComponentView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.GlyphView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.View

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the minimum span for this view along an axis.

getMinimumThumbSize() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the smallest acceptable size for the thumb.

getMinimumThumbSize() - Method in class javax.swing.plaf.metal.MetalScrollBarUI

getMinimumThumbSize() - Method in class javax.swing.plaf.synth.SynthScrollBarUI

getMinimumValue() - Method in class javax.swing.Spring

Returns the minimum value of this Spring.

getMinimumVerticalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinIndex() - Method in class javax.imageio.ImageReader

Returns the lowest valid index for reading an image, thumbnail, or image metadata.

getMinLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the minimum value, such as "Left" or "Off."

getMinor() - Method in exception org.ietf.jgss.GSSException

Returns the mechanism level error code for the problem causing this exception to be thrown.

getMinorAxis() - Method in class javax.swing.text.AsyncBoxView

Fetch the minor axis (the axis orthoginal to the tiled axis).

getMinorOffset() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the offset along the minor axis

getMinorSpan() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the span along the minor axis.

getMinorStatus() - Method in class org.ietf.jgss.MessageProp

Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.

getMinorString() - Method in exception org.ietf.jgss.GSSException

Returns a string explaining the mechanism specific error code.

getMinorString() - Method in class org.ietf.jgss.MessageProp

Retrieves a string explaining the minor status code.

getMinorTickSpacing() - Method in class javax.swing.JSlider

This method returns the minor tick spacing.

getMinorVersion() - Method in class java.awt.color.ICC_Profile

Returns profile minor version.

getMinorVersion() - Method in interface java.sql.Driver

Gets the driver's minor version number.

getMinPage() - Method in class java.awt.JobAttributes

Specifies the minimum value the user can specify as the first page to be printed for jobs using these attributes.

getMinSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Returns the first selected index or -1 if the selection is empty.

getMinSelectionIndex() - Method in class javax.swing.JList

Returns the smallest selected cell index, or -1 if the selection is empty.

getMinSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Returns the first selected index or -1 if the selection is empty.

getMinSelectionRow() - Method in class javax.swing.JTree

Returns the smallest selected row.

getMinSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.

getMinSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.

getMinSize(Container, GridBagLayoutInfo) - Method in class java.awt.GridBagLayout

Figures out the minimum size of the master based on the information from getLayoutInfo.

GetMinSize(Container, GridBagLayoutInfo) - Method in class java.awt.GridBagLayout

This method is obsolete and supplied for backwards compatability only; new code should call getMinSize instead.

getMinTileX() - Method in class java.awt.image.BufferedImage

Returns the minimum tile index in the x direction.

getMinTileX() - Method in interface java.awt.image.RenderedImage

Returns the minimum tile index in the X direction.

getMinTileY() - Method in class java.awt.image.BufferedImage

Returns the minimum tile index in the y direction.

getMinTileY() - Method in interface java.awt.image.RenderedImage

Returns the minimum tile index in the Y direction.

getMinusSign() - Method in class java.text.DecimalFormatSymbols

Gets the character used to represent minus sign.

getMinute() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return minutes or DatatypeConstants.FIELD_UNDEFINED.

getMinutes() - Method in class java.sql.Date

Deprecated.

getMinutes() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.MINUTE).

getMinutes() - Method in class javax.xml.datatype.Duration

Obtains the value of the MINUTES field as an integer value, or 0 if not present.

getMinValue(int) - Method in class java.awt.color.ColorSpace

Returns the minimum normalized color component value for the specified component.

getMinValue(int) - Method in class java.awt.color.ICC_ColorSpace

Returns the minimum normalized color component value for the specified component.

getMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the minimal value for this parameter, if it has one, or null otherwise.

getMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getMinWidth() - Method in class javax.swing.table.TableColumn

Returns the minimum width for the TableColumn.

getMinX() - Method in class java.awt.geom.RectangularShape

Returns the smallest X coordinate of the framing rectangle of the Shape in double precision.

getMinX() - Method in class java.awt.image.BufferedImage

Returns the minimum x coordinate of this BufferedImage.

getMinX() - Method in class java.awt.image.Raster

Returns the minimum valid X coordinate of the Raster.

getMinX() - Method in interface java.awt.image.renderable.RenderableImage

Gets the minimum X coordinate of the rendering-independent image data.

getMinX() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the minimum X coordinate of the rendering-independent image data.

getMinX() - Method in interface java.awt.image.RenderedImage

Returns the minimum X coordinate (inclusive) of the RenderedImage.

getMinY() - Method in class java.awt.geom.RectangularShape

Returns the smallest Y coordinate of the framing rectangle of the Shape in double precision.

getMinY() - Method in class java.awt.image.BufferedImage

Returns the minimum y coordinate of this BufferedImage.

getMinY() - Method in class java.awt.image.Raster

Returns the minimum valid Y coordinate of the Raster.

getMinY() - Method in interface java.awt.image.renderable.RenderableImage

Gets the minimum Y coordinate of the rendering-independent image data.

getMinY() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the minimum Y coordinate of the rendering-independent image data.

getMinY() - Method in interface java.awt.image.RenderedImage

Returns the minimum Y coordinate (inclusive) of the RenderedImage.

getMissingGlyphCode() - Method in class java.awt.Font

Returns the glyphCode which is used when this Font does not have a glyph for a specified unicode code point.

getMiterLimit() - Method in class java.awt.BasicStroke

Returns the limit of miter joins.

getMixer(Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains the requested audio mixer.

getMixer(Mixer.Info) - Method in class javax.sound.sampled.spi.MixerProvider

Obtains an instance of the mixer represented by the info object.

getMixerInfo() - Static method in class javax.sound.sampled.AudioSystem

Obtains an array of mixer info objects that represents the set of audio mixers that are currently installed on the system.

getMixerInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about this mixer, including the product's name, version, vendor, etc.

getMixerInfo() - Method in class javax.sound.sampled.spi.MixerProvider

Obtains the set of info objects representing the mixer or mixers provided by this MixerProvider.

getMnemonic() - Method in class javax.swing.AbstractButton

Returns the keyboard mnemonic from the the current model.

getMnemonic() - Method in interface javax.swing.ButtonModel

Gets the keyboard mnemonic for the button.

getMnemonic() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Provides a hint to the look and feel as to the KeyEvent.VK constant that can be used as a mnemonic to access the panel.

getMnemonic() - Method in class javax.swing.DefaultButtonModel

Gets the keyboard mnemonic for the button.

getMnemonicAt(int) - Method in class javax.swing.JTabbedPane

Returns the keyboard mnemonic for accessing the specified tab.

getModalExclusionType() - Method in class java.awt.Window

Returns the modal exclusion type of this window.

getModalityType() - Method in class java.awt.Dialog

Returns the modality type of this dialog.

getMode() - Method in class java.awt.FileDialog

Indicates whether this file dialog box is for loading from a file or for saving to a file.

getModel() - Method in class javax.swing.AbstractButton

Returns the model that this button represents.

getModel() - Method in class javax.swing.DefaultRowSorter

Returns the underlying model.

getModel() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the underlying model that this Model is wrapping.

getModel() - Method in class javax.swing.JComboBox

Returns the data model currently used by the JComboBox.

getModel() - Method in class javax.swing.JList

Returns the data model that holds the list of items displayed by the JList component.

getModel() - Method in class javax.swing.JProgressBar

Returns the data model used by this progress bar.

getModel() - Method in class javax.swing.JScrollBar

Returns data model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.

getModel() - Method in class javax.swing.JSlider

Returns the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.

getModel() - Method in class javax.swing.JSpinner.DateEditor

Return our spinner ancestor's SpinnerDateModel.

getModel() - Method in class javax.swing.JSpinner

Returns the SpinnerModel that defines this spinners sequence of values.

getModel() - Method in class javax.swing.JSpinner.ListEditor

Return our spinner ancestor's SpinnerNumberModel.

getModel() - Method in class javax.swing.JSpinner.NumberEditor

Return our spinner ancestor's SpinnerNumberModel.

getModel() - Method in class javax.swing.JTabbedPane

Returns the model associated with this tabbedpane.

getModel() - Method in class javax.swing.JTable

Returns the TableModel that provides the data displayed by this JTable.

getModel() - Method in class javax.swing.JTree

Returns the TreeModel that is providing the data.

getModel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getModel() - Method in class javax.swing.plaf.basic.BasicTreeUI

getModel() - Method in class javax.swing.RowFilter.Entry

Returns the underlying model.

getModel() - Method in class javax.swing.RowSorter

Returns the underlying model.

getModel() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the TreeModel that is providing the data.

getModelIndex() - Method in class javax.swing.table.TableColumn

Returns the model index for this column.

getModelRowCount() - Method in class javax.swing.DefaultRowSorter

Returns the number of rows in the underlying model.

getModelRowCount() - Method in class javax.swing.RowSorter

Returns the number of rows in the underlying model.

getModelWrapper() - Method in class javax.swing.DefaultRowSorter

Returns the model wrapper providing the data that is being sorted and filtered.

getModificationOp() - Method in class javax.naming.directory.ModificationItem

Retrieves the modification code of this modification item.

getModifier() - Method in class javax.swing.text.html.parser.AttributeList

getModifiers() - Method in class java.awt.AWTKeyStroke

Returns the modifier keys for this AWTKeyStroke.

getModifiers() - Method in class java.awt.event.ActionEvent

Returns the modifier keys held down during this action event.

getModifiers() - Method in class java.awt.event.InputEvent

Returns the modifier mask for this event.

getModifiers() - Method in class java.lang.类

Returns the Java language modifiers for this class or interface, encoded in an integer.

getModifiers() - Method in class java.lang.reflect.Constructor

Returns the Java language modifiers for the constructor represented by this Constructor object, as an integer.

getModifiers() - Method in class java.lang.reflect.字段

Returns the Java language modifiers for the field represented by this Field object, as an integer.

getModifiers() - Method in interface java.lang.reflect.Member

Returns the Java language modifiers for the member or constructor represented by this Member, as an integer.

getModifiers() - Method in class java.lang.reflect.方法

Returns the Java language modifiers for the method represented by this Method object, as an integer.

getModifiers() - Method in interface javax.lang.model.element.Element

Returns the modifiers of this element, excluding annotations.

getModifiersEx() - Method in class java.awt.event.InputEvent

Returns the extended modifier mask for this event.

getModifiersEx() - Method in class java.awt.event.MouseEvent

Returns the extended modifier mask for this event.

getModifiersExText(int) - Static method in class java.awt.event.InputEvent

Returns a String describing the extended modifier keys and mouse buttons, such as "Shift", "Button1", or "Ctrl+Shift".

getModulus() - Method in interface java.security.interfaces.RSAKey

Returns the modulus.

getModulus() - Method in class java.security.spec.RSAPrivateKeySpec

Returns the modulus.

getModulus() - Method in class java.security.spec.RSAPublicKeySpec

Returns the modulus.

getModulus() - Method in class javax.management.monitor.CounterMonitor

Gets the modulus value common to all observed MBeans.

getModulus() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the modulus value.

getMonetaryDecimalSeparator() - Method in class java.text.DecimalFormatSymbols

Returns the monetary decimal separator.

getMono() - Method in interface javax.sound.midi.MidiChannel

Obtains the current mono/poly mode.

getMonth() - Method in class java.sql.Time

Deprecated.

getMonth() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.MONTH).

getMonth() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return number of month or DatatypeConstants.FIELD_UNDEFINED.

getMonths() - Method in class java.text.DateFormatSymbols

Gets month strings.

getMonths() - Method in class javax.xml.datatype.Duration

Obtains the value of the MONTHS field as an integer value, or 0 if not present.

getMoreResults() - Method in interface java.sql.Statement

Moves to this Statement object's next result, returns true if it is a ResultSet object, and implicitly closes any current ResultSet object(s) obtained with the method getResultSet.

getMoreResults(int) - Method in interface java.sql.Statement

Moves to this Statement object's next result, deals with any current ResultSet object(s) according to the instructions specified by the given flag, and returns true if the next result is a ResultSet object.

getMostRecentEventTime() - Static method in class java.awt.EventQueue

Returns the timestamp of the most recent event that had a timestamp, and that was dispatched from the EventQueue associated with the calling thread.

getMostRecentFocusOwner() - Method in class java.awt.Window

Returns the child Component of this Window that will receive the focus when this Window is focused.

getMostRecentFocusOwner() - Method in class javax.swing.JInternalFrame

Returns the child component of this JInternalFrame that will receive the focus when this JInternalFrame is selected.

getMostSignificantBits() - Method in class java.util.UUID

Returns the most significant 64 bits of this UUID's 128 bit value.

getMouseInfoPeer() - Method in class java.awt.Toolkit

Obtains this toolkit's implementation of helper class for MouseInfo operations.

getMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getMouseListener().

getMouseListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a mouse listener that will be added to the combo box or null.

getMouseListeners() - Method in class java.awt.Component

Returns an array of all the mouse listeners registered on this component.

getMouseListeners() - Method in class java.awt.TrayIcon

Returns an array of all the mouse listeners registered on this TrayIcon.

getMouseModifiersText(int) - Static method in class java.awt.event.MouseEvent

Returns a String instance describing the modifier keys and mouse buttons that were down during the event, such as "Shift", or "Ctrl+Shift".

getMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getMouseMotionListener().

getMouseMotionListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a mouse motion listener that will be added to the combo box or null.

getMouseMotionListeners() - Method in class java.awt.Component

Returns an array of all the mouse motion listeners registered on this component.

getMouseMotionListeners() - Method in class java.awt.TrayIcon

Returns an array of all the mouse-motion listeners registered on this TrayIcon.

getMousePosition() - Method in class java.awt.Component

Returns the position of the mouse pointer in this Component's coordinate space if the Component is directly under the mouse pointer, otherwise returns null.

getMousePosition(boolean) - Method in class java.awt.Container

Returns the position of the mouse pointer in this Container's coordinate space if the Container is under the mouse pointer, otherwise returns null.

getMouseWheelListeners() - Method in class java.awt.Component

Returns an array of all the mouse wheel listeners registered on this component.

getMTU() - Method in class java.net.NetworkInterface

Returns the Maximum Transmission Unit (MTU) of this interface.

getMultiClickThreshhold() - Method in class javax.swing.AbstractButton

Gets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.

getMultiDocPrintServices(DocFlavor[], AttributeSet) - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getMultipleDocumentHandling() - Method in class java.awt.JobAttributes

Specifies the handling of multiple copies, including collation, for jobs using these attributes.

getMultiplier() - Method in class java.text.DecimalFormat

Gets the multiplier for use in percent, per mille, and similar formats.

getMustUnderstand() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.

getMute() - Method in interface javax.sound.midi.MidiChannel

Obtains the current mute state for this channel.

getMutualAuthState() - Method in interface org.ietf.jgss.GSSContext

Determines if mutual authentication is enabled on this context.

getName(int) - Method in class java.awt.color.ColorSpace

Returns the name of the component given the component index.

getName() - Method in class java.awt.Component

Gets the name of the component.

getName() - Method in class java.awt.Cursor

Returns the name of this cursor.

getName() - Method in class java.awt.datatransfer.Clipboard

Returns the name of this clipboard object.

getName() - Method in class java.awt.Font

Returns the logical name of this Font.

getName() - Method in class java.awt.MenuComponent

Gets the name of the menu component.

getName() - Method in class java.beans.FeatureDescriptor

Gets the programmatic name of this feature.

getName() - Method in class java.io.File

Returns the name of the file or directory denoted by this abstract pathname.

getName() - Method in class java.io.ObjectStreamClass

Returns the name of the class described by this descriptor.

getName() - Method in class java.io.ObjectStreamField

Get the name of this field.

getName(int) - Static method in class java.lang.Character

Returns the Unicode name of the specified character codePoint, or null if the code point is unassigned.

getName() - Method in class java.lang.类

Returns the name of the entity (class, interface, array class, primitive type, or void) represented by this 类 object, as a String.

getName() - Method in interface java.lang.management.BufferPoolMXBean

Returns the name representing this buffer pool.

getName() - Method in interface java.lang.management.CompilationMXBean

Returns the name of the Just-in-time (JIT) compiler.

getName() - Method in interface java.lang.management.MemoryManagerMXBean

Returns the name representing this memory manager.

getName() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the name representing this memory pool.

getName() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system name.

getName() - Method in interface java.lang.management.RuntimeMXBean

Returns the name representing the running Java virtual machine.

getName() - Method in class java.lang.软件包

Return the name of this package.

getName() - Method in class java.lang.reflect.Constructor

Returns the name of this constructor, as a string.

getName() - Method in class java.lang.reflect.字段

Returns the name of the field represented by this Field object.

getName() - Method in interface java.lang.reflect.Member

Returns the simple name of the underlying member or constructor represented by this Member.

getName() - Method in class java.lang.reflect.方法

Returns the name of the method represented by this Method object, as a String.

getName() - Method in interface java.lang.reflect.TypeVariable

Returns the name of this type variable, as it occurs in the source code.

getName() - Method in class java.lang.Thread

Returns this thread's name.

getName() - Method in class java.lang.ThreadGroup

Returns the name of this thread group.

getName() - Method in class java.net.HttpCookie

Returns the name of the cookie.

getName() - Method in class java.net.NetworkInterface

Get the name of this network interface.

getName() - Method in exception java.nio.file.attribute.UserPrincipalNotFoundException

Returns the user principal name if this exception was created with the user principal name that was not found, otherwise null.

getName(int) - Method in interface java.nio.file.Path

Returns a name element of this path as a Path object.

getName() - Method in interface java.security.acl.Acl

Returns the name of this ACL.

getName() - Method in class java.security.Identity

Deprecated.

Returns this identity's name.

getName() - Method in class java.security.Permission

Returns the name of this Permission.

getName() - Method in interface java.security.Principal

Returns the name of this principal.

getName() - Method in class java.security.Provider

Returns the name of this provider.

getName() - Method in class java.security.spec.ECGenParameterSpec

Returns the standard or predefined name of the to-be-generated EC domain parameters.

getName() - Method in class java.text.AttributedCharacterIterator.Attribute

Returns the name of the attribute.

getName() - Method in class java.util.logging.Level

Return the non-localized string name of the Level.

getName() - Method in class java.util.logging.Logger

Get the name for this logger.

getName() - Method in class java.util.zip.ZipEntry

Returns the name of the entry.

getName() - Method in class java.util.zip.ZipFile

Returns the path name of the ZIP file.

getName() - Method in class javax.activation.DataHandler

Return the name of the data object.

getName() - Method in interface javax.activation.DataSource

Return the name of this object where the name of the object is dependant on the nature of the underlying objects.

getName() - Method in class javax.activation.FileDataSource

Return the name of this object.

getName() - Method in class javax.activation.URLDataSource

Calls the getFile method on the URL used to instantiate the object.

getName() - Method in class javax.crypto.ExemptionMechanism

Returns the exemption mechanism name of this ExemptionMechanism object.

getName(CharSequence) - Method in interface javax.lang.model.util.Elements

Return a name with the same sequence of characters as the argument.

getName() - Method in class javax.management.Attribute

Returns a String containing the name of the attribute.

getName() - Method in class javax.management.loading.MLetContent

Gets the value of the NAME attribute of the MLET tag.

getName() - Method in class javax.management.MBeanFeatureInfo

Returns the name of the feature.

getName() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.

getName() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the name of the operation described by this OpenMBeanOperationInfo instance.

getName() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the name of the parameter described by this OpenMBeanParameterInfo instance.

getName() - Method in class javax.management.relation.RoleInfo

Returns the name of the role.

getName() - Method in class javax.management.remote.JMXPrincipal

Returns the name of this principal.

getName() - Method in class javax.naming.NameClassPair

Retrieves the name of this binding.

getName() - Method in class javax.net.ssl.SSLSessionBindingEvent

Returns the name to which the object is being bound, or the name from which the object is being unbound.

getName() - Method in interface javax.print.attribute.Attribute

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Chromaticity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.ColorSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Compression

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Copies

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.CopiesSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtCreation

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtProcessing

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Destination

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DialogTypeSelection

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DocumentName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Fidelity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Finishings

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobHoldUntil

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressions

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressionsCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressionsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctetsProcessed

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctetsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheetsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMessageFromOperator

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobOriginatingUserName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobPriority

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobPrioritySupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobSheets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobState

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobStateReason

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobStateReasons

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Media

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MediaSize

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberOfDocuments

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberOfInterveningJobs

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberUp

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberUpSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.OrientationRequested

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.OutputDeviceAssigned

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PageRanges

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PagesPerMinute

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PagesPerMinuteColor

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PresentationDirection

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterInfo

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterLocation

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMakeAndModel

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMessageFromOperator

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMoreInfo

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterResolution

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterState

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterStateReason

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterStateReasons

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterURI

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrintQuality

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.QueuedJobCount

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.RequestingUserName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Severity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.SheetCollate

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Sides

Get the name of the category of which this attribute value is an instance.

getName() - Method in interface javax.print.PrintService

Returns a String name for this print service which may be used by applications to request a particular print service.

getName() - Method in class javax.security.auth.callback.NameCallback

Get the retrieved name.

getName() - Method in class javax.security.auth.kerberos.KerberosPrincipal

The returned string corresponds to the single-string representation of a Kerberos Principal name as specified in Section 2.1 of RFC 1964.

getName() - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the format defined in RFC 2253.

getName(String) - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the specified format.

getName(String, Map<String, String>) - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the specified format.

getName() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the name of the device.

getName() - Method in interface javax.sound.midi.Soundbank

Obtains the name of the sound bank.

getName() - Method in class javax.sound.midi.SoundbankResource

Obtains the name of the resource.

getName() - Method in class javax.sound.sampled.Mixer.Info

Obtains the name of the mixer.

getName() - Method in class javax.sound.sampled.Port.Info

Obtains the name of the port.

getName() - Method in class javax.sound.sampled.ReverbType

Obtains the name of this reverb type.

getName(File) - Method in class javax.swing.filechooser.FileView

The name of the file.

getName(File) - Method in class javax.swing.JFileChooser

Returns the filename.

getName() - Method in class javax.swing.LookAndFeel

Return a short string that identifies this look and feel, e.g.

getName(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getName() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the name of this theme.

getName() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the name of this look and feel.

getName() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the name of this theme.

getName() - Method in class javax.swing.plaf.metal.OceanTheme

Return the name of this theme, "Ocean".

getName() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a string, suitable for use in menus, that identifies this look and feel.

getName() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Return a short string that identifies this look and feel.

getName() - Method in class javax.swing.plaf.synth.Region

Returns the name of the region.

getName() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Return a short string that identifies this look and feel.

getName() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the name of the element.

getName() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the element name.

getName() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the element name.

getName() - Method in class javax.swing.text.DefaultStyledDocument.SectionElement

Gets the name of the element.

getName() - Method in interface javax.swing.text.Element

Fetches the name of the element.

getName() - Method in class javax.swing.text.html.HTMLDocument.BlockElement

Gets the name of the element.

getName() - Method in class javax.swing.text.html.HTMLDocument.RunElement

Gets the name of the element.

getName() - Method in class javax.swing.text.html.parser.AttributeList

getName() - Method in class javax.swing.text.html.parser.DTD

Gets the name of the DTD.

getName() - Method in class javax.swing.text.html.parser.Element

Get the name of the element.

getName() - Method in class javax.swing.text.html.parser.Entity

Gets the name of the entity.

getName() - Method in interface javax.swing.text.Keymap

Fetches the name of the set of key-bindings.

getName() - Method in interface javax.swing.text.Style

Fetches the name of the style.

getName() - Method in class javax.swing.text.StyleContext.NamedStyle

Fetches the name of the style.

getName() - Method in class javax.swing.UIManager.LookAndFeelInfo

Returns the name of the look and feel in a form suitable for a menu or other presentation

getName() - Method in interface javax.tools.FileObject

Gets a user-friendly name for this file object.

getName() - Method in class javax.tools.ForwardingFileObject

getName() - Method in interface javax.tools.JavaFileManager.Location

Gets the name of this location.

getName() - Method in class javax.tools.SimpleJavaFileObject

getName() - Method in enum javax.tools.StandardLocation

getName() - Method in class javax.xml.bind.JAXBElement

Returns the xml element tag name.

getName() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyName

Returns the name of this KeyName.

getName() - Method in class javax.xml.soap.MimeHeader

Returns the name of this MimeHeader object.

getName() - Method in interface javax.xml.stream.events.Attribute

Returns the QName for this attribute

getName() - Method in interface javax.xml.stream.events.EndElement

Get the name of this event

getName() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's name

getName() - Method in interface javax.xml.stream.events.EntityReference

The name of the entity

getName() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation name.

getName() - Method in interface javax.xml.stream.events.StartElement

Get the name of this event

getName() - Method in class javax.xml.stream.util.StreamReaderDelegate

getName() - Method in interface javax.xml.stream.XMLStreamReader

Returns a QName for the current START_ELEMENT or END_ELEMENT event

getName() - Method in interface org.ietf.jgss.GSSCredential

Retrieves the name of the entity that the credential asserts.

getName(Oid) - Method in interface org.ietf.jgss.GSSCredential

Retrieves a Mechanism Name of the entity that the credential asserts.

getName() - Method in interface org.w3c.dom.Attr

Returns the name of this attribute.

getName() - Method in interface org.w3c.dom.DocumentType

The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

getName(int) - Method in interface org.w3c.dom.NameList

Returns the indexth name item in the collection.

getName(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the name of an attribute in this list (by position).

getName(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the name of an attribute (by position).

getNameConstraints() - Method in class java.security.cert.TrustAnchor

Returns the name constraints parameter.

getNameConstraints() - Method in class java.security.cert.X509CertSelector

Returns the name constraints criterion.

getNameCount() - Method in interface java.nio.file.Path

Returns the number of name elements in the path.

getNamedItem(String) - Method in interface org.w3c.dom.NamedNodeMap

Retrieves a node specified by name.

getNamedItemNS(String, String) - Method in interface org.w3c.dom.NamedNodeMap

Retrieves a node specified by local name and namespace URI.

getNameInNamespace() - Method in interface javax.naming.Context

Retrieves the full name of this context within its own namespace.

getNameInNamespace() - Method in class javax.naming.InitialContext

getNameInNamespace() - Method in class javax.naming.NameClassPair

Retrieves the full name of this binding.

getNameParser(Name) - Method in interface javax.naming.Context

Retrieves the parser associated with the named context.

getNameParser(String) - Method in interface javax.naming.Context

Retrieves the parser associated with the named context.

getNameParser(String) - Method in class javax.naming.InitialContext

getNameParser(Name) - Method in class javax.naming.InitialContext

getNames() - Method in class javax.activation.MimeTypeParameterList

Retrieve an enumeration of all the names in this list.

getNames() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of short names for the ScriptEngine, which may be used to identify the ScriptEngine by the ScriptEngineManager.

getNamesForMech(Oid) - Method in class org.ietf.jgss.GSSManager

Returns then name types supported by the indicated mechanism.

getNamespaceContext() - Method in interface javax.xml.stream.events.StartElement

Gets a read-only namespace context.

getNamespaceContext() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceContext() - Method in interface javax.xml.stream.XMLEventWriter

Returns the current namespace context.

getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamReader

Returns a read only namespace context for the current position.

getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamWriter

Returns the current namespace context.

getNamespaceContext() - Method in interface javax.xml.xpath.XPath

Return the current namespace context.

getNamespaceCount() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceCount() - Method in interface javax.xml.stream.XMLStreamReader

Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

Returns a map of namespace prefixes.

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns a map of namespace prefixes.

getNamespacePrefix(String, String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the prefix that the specified URI maps to.

getNamespacePrefix(String, String) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the namespace prefix that the specified namespace URI is associated with.

getNamespacePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespacePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix for the namespace declared at the index.

getNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings declared by this element.

getNamespaces() - Method in interface javax.xml.stream.events.EndElement

Returns an Iterator of namespaces that have gone out of scope.

getNamespaces() - Method in interface javax.xml.stream.events.StartElement

Returns an Iterator of namespaces declared on this element.

getNamespaceURI() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since namespaces are not supported.

getNamespaceURI(String) - Method in interface javax.xml.namespace.NamespaceContext

Get Namespace URI bound to a prefix in the current scope.

getNamespaceURI() - Method in class javax.xml.namespace.QName

Get the Namespace URI of this QName.

getNamespaceURI(String) - Method in interface javax.xml.soap.SOAPElement

Returns the URI of the namespace that has the given prefix.

getNamespaceURI() - Method in interface javax.xml.stream.events.Namespace

Gets the uri bound to the prefix of this namespace

getNamespaceURI(String) - Method in interface javax.xml.stream.events.StartElement

Gets the value that the prefix is bound to in the context of this element.

getNamespaceURI(String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI(String) - Method in interface javax.xml.stream.XMLStreamReader

Return the uri for the given prefix.

getNamespaceURI(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the uri for the namespace declared at the index.

getNamespaceURI() - Method in interface javax.xml.stream.XMLStreamReader

If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.

getNamespaceURI(int) - Method in interface org.w3c.dom.NameList

Returns the indexth namespaceURI item in the collection.

getNamespaceURI() - Method in interface org.w3c.dom.Node

The namespace URI of this node, or null if it is unspecified (see ).

getNameType() - Method in class javax.security.auth.kerberos.KerberosPrincipal

Returns the name type of the KerberosPrincipal.

getNaN() - Method in class java.text.DecimalFormatSymbols

Gets the string used to represent "not a number".

getNanos() - Method in class java.sql.Timestamp

Gets this Timestamp object's nanos value.

getNativeCommands(String) - Method in class javax.activation.MailcapCommandMap

Get the native commands for the given MIME type.

getNativeContainer(Component) - Static method in class java.awt.Toolkit

Give native peers the ability to query the native container given a native component (eg the direct parent may be lightweight).

getNativeImageMetadataFormatName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the name of the "native" image metadata format for this plug-in, which typically allows for lossless encoding and transmission of the image metadata stored in the format handled by this plug-in.

getNativeMetadataFormatName() - Method in class javax.imageio.metadata.IIOMetadata

Returns the name of the "native" metadata format for this plug-in, which typically allows for lossless encoding and transmission of the metadata stored in the format handled by this plug-in.

getNativesForFlavor(DataFlavor) - Method in interface java.awt.datatransfer.FlavorTable

Returns a List of String natives to which the specified DataFlavor corresponds.

getNativesForFlavor(DataFlavor) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a List of String natives to which the specified DataFlavor can be translated by the data transfer subsystem.

getNativesForFlavors(DataFlavor[]) - Method in interface java.awt.datatransfer.FlavorMap

Returns a Map of the specified DataFlavors to their corresponding String native.

getNativesForFlavors(DataFlavor[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a Map of the specified DataFlavors to their most preferred String native.

getNativeStreamMetadataFormatName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the name of the "native" stream metadata format for this plug-in, which typically allows for lossless encoding and transmission of the stream metadata stored in the format handled by this plug-in.

getNavigationFilter() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a filter to restrict where the user can navigate to.

getNavigationFilter() - Method in class javax.swing.text.DefaultFormatter

Returns the NavigationFilter used to restrict where the cursor can be placed.

getNavigationFilter() - Method in class javax.swing.text.JTextComponent

Returns the NavigationFilter.

getNbNotifications() - Method in class javax.management.timer.Timer

Gets the number of timer notifications registered into the list of notifications.

getNbNotifications() - Method in interface javax.management.timer.TimerMBean

Gets the number of timer notifications registered into the list of notifications.

getNbOccurences(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the remaining number of occurrences associated to a timer notification.

getNbOccurences(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the remaining number of occurrences associated to a timer notification.

getNCharacterStream(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getNCharacterStream(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getNCharacterStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getNCharacterStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getNClob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC NCLOB parameter as a java.sql.NClob object in the Java programming language.

getNClob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC NCLOB parameter as a java.sql.NClob object in the Java programming language.

getNClob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a NClob object in the Java programming language.

getNClob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a NClob object in the Java programming language.

getNeedClientAuth() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine will require client authentication.

getNeedClientAuth() - Method in class javax.net.ssl.SSLParameters

Returns whether client authentication should be required.

getNeedClientAuth() - Method in class javax.net.ssl.SSLServerSocket

Returns true if client authentication will be required on newly accepted server-mode SSLSockets.

getNeedClientAuth() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket will require client authentication.

getNeedClientAuth() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns true if client authentication is required on SSL connections accepted by server sockets created by this factory.

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController

Returns the x argument, since this is used for horizontal splits.

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController

Returns the y argument, since this is used for vertical splits.

getNegativePrefix() - Method in class java.text.DecimalFormat

Get the negative prefix.

getNegativeSuffix() - Method in class java.text.DecimalFormat

Get the negative suffix.

getNegotiatedProperty(String) - Method in interface javax.security.sasl.SaslClient

Retrieves the negotiated property.

getNegotiatedProperty(String) - Method in interface javax.security.sasl.SaslServer

Retrieves the negotiated property.

getNestedException() - Method in exception javax.xml.stream.XMLStreamException

Gets the nested exception.

getNestingKind() - Method in interface javax.lang.model.element.TypeElement

Returns the nesting kind of this type element.

getNestingKind() - Method in class javax.tools.ForwardingJavaFileObject

getNestingKind() - Method in interface javax.tools.JavaFileObject

Provides a hint about the nesting level of the class represented by this file object.

getNestingKind() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns null.

getNetworkInterface() - Method in class java.net.MulticastSocket

Get the multicast network interface set.

getNetworkInterfaces() - Static method in class java.net.NetworkInterface

Returns all the interfaces on this machine.

getNetworkPrefixLength() - Method in class java.net.InterfaceAddress

Returns the network prefix length for this address.

getNetworkTimeout() - Method in interface java.sql.Connection

Retrieves the number of milliseconds the driver will wait for a database request to complete.

getNewBinding() - Method in class javax.naming.event.NamingEvent

Retrieves the binding of the object after the change.

getNewDocument() - Method in interface org.w3c.dom.ls.LSLoadEvent

The document that finished loading.

getNewFolderAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getNewLeadSelectionPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the current lead path.

getNewLine() - Method in interface org.w3c.dom.ls.LSSerializer

The end-of-line sequence of characters to be used in the XML being written out.

getNewRoleValue() - Method in class javax.management.relation.RelationNotification

Returns new value of updated role (only for role update).

getNewState() - Method in class java.awt.event.WindowEvent

For WINDOW_STATE_CHANGED events returns the new state of the window.

getNewValue() - Method in class java.beans.PropertyChangeEvent

Gets the new value for the property, expressed as an Object.

getNewValue() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the new value for the preference.

getNewValue() - Method in class javax.management.AttributeChangeNotification

Gets the new value of the attribute which has changed.

getNewValue() - Method in interface org.w3c.dom.events.MutationEvent

newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getNext() - Method in class javax.swing.text.html.parser.AttributeList

getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Returns the next visual position for the cursor, in either the east or west direction.

getNextEntry() - Method in class java.util.jar.JarInputStream

Reads the next ZIP file entry and positions the stream at the beginning of the entry data.

getNextEntry() - Method in class java.util.zip.ZipInputStream

Reads the next ZIP file entry and positions the stream at the beginning of the entry data.

getNextEvent() - Method in class java.awt.EventQueue

Removes an event from the EventQueue and returns it.

getNextException() - Method in exception java.sql.SQLException

Retrieves the exception chained to this SQLException object by setNextException(SQLException ex).

getNextFocusableComponent() - Method in class javax.swing.JComponent

Deprecated.
As of 1.4, replaced by FocusTraversalPolicy.

getNextJarEntry() - Method in class java.util.jar.JarInputStream

Reads the next JAR file entry and positions the stream at the beginning of the entry data.

getNextLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the leaf after this node or null if this node is the last leaf in the tree.

getNextLeftHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextLeftHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextLeftHit(int) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextMatch(String, int, Position.Bias) - Method in class javax.swing.JList

Returns the next list element whose toString value starts with the given prefix.

getNextMatch(String, int, Position.Bias) - Method in class javax.swing.JTree

Returns the TreePath to the next tree element that begins with a prefix.

getNextNode() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the node that follows this node in a preorder traversal of this node's tree.

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Returns the next visual position for the cursor, in either the north or south direction.

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.ParagraphView

Returns the next visual position for the cursor, in either the east or west direction.

getNextRightHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if there is no such hit, returns null.

getNextRightHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if no such hit, returns null.

getNextRightHit(int) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if no such hit, returns null.

getNextSequenceNumber() - Method in class javax.management.remote.NotificationResult

Returns the sequence number of the next notification available for querying.

getNextSibling() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the next sibling of this node, or null if the node has no next sibling.

getNextSibling() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the next sibling of this node in the parent's children array.

getNextSibling() - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Returns the nextSibling node.

getNextSibling() - Method in class javax.xml.transform.dom.DOMResult

Get the child node before which the result nodes will be inserted.

getNextSibling() - Method in interface org.w3c.dom.Node

The node immediately following this node.

getNextTabIndex(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextTabRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextUpdate() - Method in class java.security.cert.X509CRL

Gets the nextUpdate date from the CRL.

getNextValue() - Method in class javax.swing.JSpinner

Returns the object in the sequence that comes after the object returned by getValue().

getNextValue() - Method in class javax.swing.SpinnerDateModel

Returns the next Date in the sequence, or null if the next date is after end.

getNextValue() - Method in class javax.swing.SpinnerListModel

Returns the next legal value of the underlying sequence or null if value is already the last element.

getNextValue() - Method in interface javax.swing.SpinnerModel

Return the object in the sequence that comes after the object returned by getValue().

getNextValue() - Method in class javax.swing.SpinnerNumberModel

Returns the next number in the sequence.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.basic.BasicTextUI

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getNextVisualPositionFrom method on each UI handled by this object.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.TextUI

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.AsyncBoxView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.GlyphView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.GlyphView.GlyphPainter

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.text.NavigationFilter

Returns the next visual position to place the caret at from an existing position.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.View

Provides a way to determine the next visually represented model location at which one might place a caret.

getNextWarning() - Method in exception java.sql.SQLWarning

Retrieves the warning chained to this SQLWarning object by setNextWarning.

getNextWarning() - Method in exception javax.sql.rowset.RowSetWarning

Retrieves the warning chained to this RowSetWarning object.

getNextWord(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the start of the next word for the given location.

getNode() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the preference node that emitted the event.

getNode(Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

By default, the getNode method is unsupported and throw an UnsupportedOperationException.

getNode() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getNode(Object) - Method in interface javax.xml.bind.Marshaller

Get a DOM tree view of the content tree(Optional).

getNode() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the DOM Node if available

getNode() - Method in class javax.xml.crypto.dom.DOMStructure

Returns the node contained in this DOMStructure.

getNode() - Method in class javax.xml.crypto.dsig.dom.DOMValidateContext

Returns the node.

getNode() - Method in class javax.xml.transform.dom.DOMResult

Get the node that will contain the result DOM tree.

getNode() - Method in class javax.xml.transform.dom.DOMSource

Get the node that represents a Source DOM tree.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

Responsible for getting the size of a particular node.

getNodeDimensions() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns, by reference in placeIn, the size needed to represent value.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache.NodeDimensions

Returns, by reference in bounds, the size and x origin to place value at.

getNodeName() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the node name associated with this node.

getNodeName() - Method in interface org.w3c.dom.Node

The name of this node, depending on its type; see the table above.

getNodeType() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the node type, which is always ELEMENT_NODE.

getNodeType() - Method in interface org.w3c.dom.Node

A code representing the type of the underlying object, as defined above.

getNodeValue() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the value associated with this node.

getNodeValue() - Method in interface org.w3c.dom.Node

The value of this node, depending on its type; see the table above.

getNoFallbackControl(List<String>) - Static method in class java.util.ResourceBundle.Control

Returns a ResourceBundle.Control in which the getFormats method returns the specified formats and the getFallbackLocale method returns null.

getNoImageIcon() - Method in class javax.swing.text.html.ImageView

Returns the icon to use if the image couldn't be found.

getNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the divider to use when the splitPane is configured to not continuously layout.

getNonCriticalExtensionOIDs() - Method in interface java.security.cert.X509Extension

Gets a Set of the OID strings for the extension(s) marked NON-CRITICAL in the certificate/CRL managed by the object implementing this interface.

getNonHeapMemoryUsage() - Method in interface java.lang.management.MemoryMXBean

Returns the current memory usage of non-heap memory that is used by the Java virtual machine.

getNonMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all of the MimeHeader objects whose name does not match a name in the given array of names.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Returns a non-rollover border for the button.

getNoNSSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current noNamespaceSchemaLocation.

getNormalBounds() - Method in class javax.swing.JInternalFrame

If the JInternalFrame is not in maximized state, returns getBounds(); otherwise, returns the bounds that the JInternalFrame would be restored to.

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in normalized form, given an unnormalized component array.

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in normalized form, given a pixel in this ColorModel.

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in normalized form, given an unnormalized component array.

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in normalized form, given a pixel in this ColorModel.

getNormalizingTransform() - Method in class java.awt.GraphicsConfiguration

Returns a AffineTransform that can be concatenated with the default AffineTransform of a GraphicsConfiguration so that 72 units in user space equals 1 inch in device space.

getNorthPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getNotAfter() - Method in class java.security.cert.X509Certificate

Gets the notAfter date from the validity period of the certificate.

getNotAfter() - Method in class javax.security.cert.X509Certificate

Gets the notAfter date from the validity period of the certificate.

getNotationName() - Method in interface javax.xml.stream.events.EntityDeclaration

The name of the associated notation.

getNotationName() - Method in interface org.w3c.dom.Entity

For unparsed entities, the name of the notation for the entity.

getNotations() - Method in interface javax.xml.stream.events.DTD

Return a List containing the notations declared in the DTD.

getNotations() - Method in interface org.w3c.dom.DocumentType

A NamedNodeMap containing the notations declared in the DTD.

getNotBefore() - Method in class java.security.cert.X509Certificate

Gets the notBefore date from the validity period of the certificate.

getNotBefore() - Method in class javax.security.cert.X509Certificate

Gets the notBefore date from the validity period of the certificate.

getNote() - Method in class javax.swing.ProgressMonitor

Specifies the additional note that is displayed along with the progress message.

getNotification(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanNotificationInfo requested by name.

getNotification(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getNotification() - Method in class javax.management.remote.TargetedNotification

The emitted notification.

getNotification() - Method in class javax.naming.ldap.UnsolicitedNotificationEvent

Returns the unsolicited notification.

getNotificationID() - Method in class javax.management.timer.TimerNotification

Gets the identifier of this timer notification.

getNotificationIDs(String) - Method in class javax.management.timer.Timer

Gets all the identifiers of timer notifications corresponding to the specified type.

getNotificationIDs(String) - Method in interface javax.management.timer.TimerMBean

Gets all the identifiers of timer notifications corresponding to the specified type.

getNotificationInfo() - Method in class javax.management.MBeanServerDelegate

getNotificationInfo() - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the array of Notifications always generated by the RequiredModelMBean.

getNotificationInfo() - Method in class javax.management.monitor.CounterMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.

getNotificationInfo() - Method in class javax.management.monitor.GaugeMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.

getNotificationInfo() - Method in class javax.management.monitor.StringMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.

getNotificationInfo() - Method in interface javax.management.NotificationBroadcaster

Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

getNotificationInfo() - Method in class javax.management.NotificationBroadcasterSupport

getNotificationInfo() - Method in class javax.management.relation.RelationService

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.

getNotificationInfo() - Method in class javax.management.remote.JMXConnectorServer

Returns an array indicating the notifications that this MBean sends.

getNotificationInfo() - Method in class javax.management.StandardEmitterMBean

getNotificationInfo() - Method in class javax.management.timer.Timer

getNotificationMessage(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification detailed message corresponding to the specified identifier.

getNotificationMessage(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification detailed message corresponding to the specified identifier.

getNotifications() - Method in class javax.management.MBeanInfo

Returns the list of the notifications emitted by the MBean.

getNotifications() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of the notifications emitted by the MBean.

getNotifications() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.

getNotificationType(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification type corresponding to the specified identifier.

getNotificationType(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification type corresponding to the specified identifier.

getNotificationUserData(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification user data object corresponding to the specified identifier.

getNotificationUserData(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification user data object corresponding to the specified identifier.

getNotifTypes() - Method in class javax.management.MBeanNotificationInfo

Returns the array of strings (in dot notation) containing the notification types that the MBean may emit.

getNotify() - Method in class javax.management.monitor.CounterMonitor

Gets the notification's on/off switch value common to all observed MBeans.

getNotify() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the notification's on/off switch value.

getNotifyDiffer() - Method in class javax.management.monitor.StringMonitor

Gets the differing notification's on/off switch value common to all observed MBeans.

getNotifyDiffer() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the differing notification's on/off switch value.

getNotifyHigh() - Method in class javax.management.monitor.GaugeMonitor

Gets the high notification's on/off switch value common to all observed MBeans.

getNotifyHigh() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the high notification's on/off switch value.

getNotifyLow() - Method in class javax.management.monitor.GaugeMonitor

Gets the low notification's on/off switch value common to all observed MBeans.

getNotifyLow() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the low notification's on/off switch value.

getNotifyMatch() - Method in class javax.management.monitor.StringMonitor

Gets the matching notification's on/off switch value common to all observed MBeans.

getNotifyMatch() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the matching notification's on/off switch value.

getNoType(TypeKind) - Method in interface javax.lang.model.util.Types

Returns a pseudo-type used where no actual type is appropriate.

getNString(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated NCHAR, NVARCHAR or LONGNVARCHAR parameter as a String in the Java programming language.

getNString(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated NCHAR, NVARCHAR or LONGNVARCHAR parameter as a String in the Java programming language.

getNString(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getNString(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getNullFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the formatter to use if the value is null.

getNullType() - Method in interface javax.lang.model.util.Types

Returns the null type.

getNumBands() - Method in class java.awt.image.Raster

Returns the number of bands (samples per pixel) in this Raster.

getNumBands() - Method in class java.awt.image.SampleModel

Returns the total number of bands of image data.

getNumBands() - Method in class javax.imageio.ImageTypeSpecifier

Return the number of bands specified by this object.

getNumBanks() - Method in class java.awt.image.DataBuffer

Returns the number of banks in this DataBuffer.

getNumber() - Method in class javax.swing.SpinnerNumberModel

Returns the value of the current element of the sequence.

getNumberFormat() - Method in class java.text.DateFormat

Gets the number formatter which this date/time formatter uses to format and parse a time.

getNumberInstance() - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the current default locale.

getNumberInstance(Locale) - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the specified locale.

getNumberInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new general-purpose NumberFormat instance for the specified locale.

getNumberOfButtons() - Static method in class java.awt.MouseInfo

Returns the number of buttons on the mouse.

getNumberOfPages() - Method in class java.awt.print.Book

Returns the number of pages in this Book.

getNumberOfPages() - Method in interface java.awt.print.Pageable

Returns the number of pages in the set.

getNumberWaiting() - Method in class java.util.concurrent.CyclicBarrier

Returns the number of parties currently waiting at the barrier.

getNumChars() - Method in class java.awt.font.LineMetrics

Returns the number of characters (char values) in the text whose metrics are encapsulated by this LineMetrics object.

getNumColorComponents() - Method in class java.awt.image.ColorModel

Returns the number of color components in this ColorModel.

getNumComponents() - Method in class java.awt.color.ColorSpace

Returns the number of components of this ColorSpace.

getNumComponents() - Method in class java.awt.color.ICC_Profile

Returns the number of color components in the "input" color space of this profile.

getNumComponents() - Method in class java.awt.image.ColorModel

Returns the number of components, including alpha, in this ColorModel.

getNumComponents() - Method in class java.awt.image.LookupTable

Returns the number of components in the lookup table.

getNumComponents() - Method in class javax.imageio.ImageTypeSpecifier

Return the number of color components specified by this object.

getNumDataElements() - Method in class java.awt.image.ComponentSampleModel

Returns the number of data elements needed to transfer a pixel with the ComponentSampleModel.getDataElements(int, int, Object, DataBuffer) and ComponentSampleModel.setDataElements(int, int, Object, DataBuffer) methods.

getNumDataElements() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of data elements needed to transfer one pixel via the MultiPixelPackedSampleModel.getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) and MultiPixelPackedSampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) methods.

getNumDataElements() - Method in class java.awt.image.Raster

Returns the number of data elements needed to transfer one pixel via the getDataElements and setDataElements methods.

getNumDataElements() - Method in class java.awt.image.SampleModel

Returns the number of data elements needed to transfer a pixel via the getDataElements and setDataElements methods.

getNumDataElements() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of data elements needed to transfer one pixel via the getDataElements and setDataElements methods.

getNumDesignAxes() - Method in interface java.awt.font.MultipleMaster

Returns the number of multiple master design controls.

getNumericCode() - Method in class java.util.Currency

Returns the ISO 4217 numeric code of this currency.

getNumericFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of math functions available with this database.

getNumericValue(char) - Static method in class java.lang.Character

Returns the int value that the specified Unicode character represents.

getNumericValue(int) - Static method in class java.lang.Character

Returns the int value that the specified character (Unicode code point) represents.

getNumFactors() - Method in class java.awt.image.RescaleOp

Returns the number of scaling factors and offsets used in this RescaleOp.

getNumGlyphs() - Method in class java.awt.Font

Returns the number of glyphs in this Font.

getNumGlyphs() - Method in class java.awt.font.GlyphVector

Returns the number of glyphs in this GlyphVector.

getNumImages(boolean) - Method in class javax.imageio.ImageReader

Returns the number of images, not including thumbnails, available from the current input source.

getNumParameters() - Method in class java.awt.image.renderable.ParameterBlock

Returns the number of parameters (not including source images).

getNumSources() - Method in class java.awt.image.renderable.ParameterBlock

Returns the number of source images.

getNumThumbnails() - Method in class javax.imageio.IIOImage

Returns the number of thumbnails stored in this IIOImage.

getNumThumbnails(int) - Method in class javax.imageio.ImageReader

Returns the number of thumbnail preview images associated with the given image.

getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio.ImageWriter

Returns the number of thumbnails suported by the format being written, given the image type and any additional write parameters and metadata objects that will be used during encoding.

getNumXTiles() - Method in class java.awt.image.BufferedImage

Returns the number of tiles in the x direction.

getNumXTiles() - Method in interface java.awt.image.RenderedImage

Returns the number of tiles in the X direction.

getNumYTiles() - Method in class java.awt.image.BufferedImage

Returns the number of tiles in the y direction.

getNumYTiles() - Method in interface java.awt.image.RenderedImage

Returns the number of tiles in the Y direction.

getObject() - Method in class java.security.GuardedObject

Retrieves the guarded object, or throws an exception if access to the guarded object is denied by the guard.

getObject() - Method in class java.security.SignedObject

Retrieves the encapsulated object.

getObject(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as an Object in the Java programming language.

getObject(int, Map<String, Class<?>>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterIndex and uses map for the custom mapping of the parameter value.

getObject(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a parameter as an Object in the Java programming language.

getObject(String, Map<String, Class<?>>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterName and uses map for the custom mapping of the parameter value.

getObject(int, Class<T>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterIndex and will convert from the SQL type of the parameter to the requested Java data type, if the conversion is supported.

getObject(String, Class<T>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterName and will convert from the SQL type of the parameter to the requested Java data type, if the conversion is supported.

getObject(Map<String, Class<?>>) - Method in interface java.sql.Ref

Retrieves the referenced object and maps it to a Java type using the given type map.

getObject() - Method in interface java.sql.Ref

Retrieves the SQL structured type instance referenced by this Ref object.

getObject(int) - Method in interface java.sql.ResultSet

Gets the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(String) - Method in interface java.sql.ResultSet

Gets the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(int, Map<String, Class<?>>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(String, Map<String, Class<?>>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(int, Class<T>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object and will convert from the SQL type of the column to the requested Java data type, if the conversion is supported.

getObject(String, Class<T>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object and will convert from the SQL type of the column to the requested Java data type, if the conversion is supported.

getObject(String) - Method in class java.util.ResourceBundle

Gets an object for the given key from this resource bundle or one of its parents.

getObject(Key) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject(Cipher) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject(Key, String) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject() - Method in class javax.naming.Binding

Retrieves the object bound to the name of this binding.

getObject() - Method in class javax.naming.spi.DirStateFactory.Result

Retrieves the object to be bound.

getObject() - Method in class javax.sql.rowset.serial.SerialJavaObject

Returns an Object that is a copy of this SerialJavaObject object.

getObject(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialRef

Returns an Object representing the SQL structured type to which this SerialRef object refers.

getObject() - Method in class javax.sql.rowset.serial.SerialRef

Returns an Object representing the SQL structured type to which this SerialRef object refers.

getObject() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getObject() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the object in the Java content tree if available

getObjectArrayMaxLength(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of array elements that may be used to define the Object reference within the named element.

getObjectArrayMaxLength(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectArrayMinLength(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of array elements that may be used to define the Object reference within the named element.

getObjectArrayMinLength(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectClass(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the 类 type of the Object reference stored within the element.

getObjectClass(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectDefaultValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an Objects containing the default value for the Object reference within the named element.

getObjectDefaultValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectEnumerations(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Objects containing the legal enumerated values for the Object reference within the named element.

getObjectEnumerations(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectForLayer(int) - Method in class javax.swing.JLayeredPane

Returns the Integer object associated with a specified layer.

getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServer

getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServerConnection

Gets the ObjectInstance for a given MBean registered with the MBean server.

getObjectInstance(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getObjectInstance(ObjectName).

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi.DirectoryManager

Creates an instance of an object for the specified object, attributes, and environment.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi.DirObjectFactory

Creates an object using the location or reference information, and attributes specified.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates an instance of an object for the specified object and environment.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi.ObjectFactory

Creates an object using the location or reference information specified.

getObjectMaxValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum legal value for the Object reference within the named element.

getObjectMaxValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectMinValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum legal value for the Object reference within the named element.

getObjectMinValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectName() - Method in interface java.lang.management.PlatformManagedObject

Returns an ObjectName instance representing the object name of this platform managed object.

getObjectName() - Method in class javax.management.MBeanServerInvocationHandler

The name of the MBean within the MBean server to which methods are forwarded.

getObjectName() - Method in class javax.management.ObjectInstance

Returns the object name part.

getObjectName() - Method in class javax.management.relation.RelationNotification

Returns the ObjectName of the created/removed/updated relation.

getObjectParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

Gets a parameter as an object.

getObjectPendingFinalizationCount() - Method in interface java.lang.management.MemoryMXBean

Returns the approximate number of objects for which finalization is pending.

getObjects() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns an unmodifiable list of XMLObjects contained in this XMLSignature.

getObjectSize(Object) - Method in interface java.lang.instrument.Instrumentation

Returns an implementation-specific approximation of the amount of storage consumed by the specified object.

getObjectStreamClass() - Method in class java.io.ObjectInputStream.GetField

Get the ObjectStreamClass that describes the fields in the stream.

getObjectValueType(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the enumerated values starting with VALUE_, indicating the type of values (enumeration, range, or array) that are allowed for the Object reference.

getObjectValueType(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObservedAttribute() - Method in class javax.management.monitor.Monitor

Gets the attribute being observed.

getObservedAttribute() - Method in interface javax.management.monitor.MonitorMBean

Gets the attribute being observed.

getObservedAttribute() - Method in class javax.management.monitor.MonitorNotification

Gets the observed attribute of this monitor notification.

getObservedObject() - Method in class javax.management.monitor.Monitor

Deprecated.
As of JMX 1.2, replaced by Monitor.getObservedObjects()

getObservedObject() - Method in interface javax.management.monitor.MonitorMBean

Deprecated.
As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()

getObservedObject() - Method in class javax.management.monitor.MonitorNotification

Gets the observed object of this monitor notification.

getObservedObjects() - Method in class javax.management.monitor.Monitor

Returns an array containing the objects being observed.

getObservedObjects() - Method in interface javax.management.monitor.MonitorMBean

Returns an array containing the objects being observed.

getOctetStream() - Method in class javax.xml.crypto.OctetStreamData

Returns the input stream of this OctetStreamData.

getOffendingNode() - Method in exception javax.imageio.metadata.IIOInvalidTreeException

Returns the Node that caused the error in parsing.

getOffscreenBuffer(Component, int, int) - Method in class javax.swing.RepaintManager

Return the offscreen buffer that should be used as a double buffer with the component c.

getOffset(int, int) - Method in class java.awt.image.ComponentSampleModel

Gets the offset for the first band of pixel (x,y).

getOffset(int, int, int) - Method in class java.awt.image.ComponentSampleModel

Gets the offset for band b of pixel (x,y).

getOffset() - Method in class java.awt.image.DataBuffer

Returns the offset of the default bank in array elements.

getOffset() - Method in class java.awt.image.LookupTable

Returns the offset.

getOffset(int, int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the offset of pixel (x, y) in data array elements.

getOffset(int, int) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the offset (in data array elements) of pixel (x,y).

getOffset() - Method in class java.io.ObjectStreamField

Offset of field within instance data.

getOffset() - Method in class java.net.DatagramPacket

Returns the offset of the data to be sent or the offset of the data received.

getOffset() - Method in class java.text.CollationElementIterator

Returns the character offset in the original text corresponding to the next collation element.

getOffset(long) - Method in class java.util.SimpleTimeZone

Returns the offset of this time zone from UTC at the given time.

getOffset(int, int, int, int, int, int) - Method in class java.util.SimpleTimeZone

Returns the difference in milliseconds between local time and UTC, taking into account both the raw offset and the effect of daylight saving, for the specified date and time.

getOffset(int, int, int, int, int, int) - Method in class java.util.TimeZone

Gets the time zone offset, for current date, modified in case of daylight savings.

getOffset(long) - Method in class java.util.TimeZone

Returns the offset of this time zone from UTC at the specified date.

getOffset() - Method in class javax.imageio.stream.IIOByteBuffer

Returns the offset within the byte array returned by getData at which the data of interest start.

getOffset() - Method in class javax.management.monitor.CounterMonitor

Gets the offset value common to all observed MBeans.

getOffset() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the offset value.

getOffset() - Method in class javax.print.attribute.EnumSyntax

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.print.attribute.standard.Finishings

Returns the lowest integer value used by class Finishings.

getOffset() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the lowest integer value used by class OrientationRequested.

getOffset() - Method in class javax.print.attribute.standard.PrintQuality

Returns the lowest integer value used by class PrintQuality.

getOffset() - Method in interface javax.swing.event.DocumentEvent

Returns the offset within the document of the start of the change.

getOffset() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getOffset() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the offset within the document of the start of the change.

getOffset(int, int) - Method in class javax.swing.text.BoxView

Fetches the offset of a particular child's current layout.

getOffset() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the starting offset.

getOffset() - Method in interface javax.swing.text.Position

Fetches the current offset within the document.

getOffset() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getOffset() - Method in interface javax.xml.bind.ValidationEventLocator

Return the byte offset if available

getOffsetHit(int) - Method in class java.awt.font.TextHitInfo

Creates a TextHitInfo whose character index is offset by delta from the charIndex of this TextHitInfo.

getOffsets() - Method in class java.awt.image.DataBuffer

Returns the offsets (in array elements) of all the banks.

getOffsets(float[]) - Method in class java.awt.image.RescaleOp

Returns the offsets in the given array.

getOldBinding() - Method in class javax.naming.event.NamingEvent

Retrieves the binding of the object before the change.

getOldLeadSelectionPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the path that was previously the lead path.

getOldRoleValue() - Method in class javax.management.relation.RelationNotification

Returns old value of updated role (only for role update).

getOldState() - Method in class java.awt.event.WindowEvent

For WINDOW_STATE_CHANGED events returns the previous state of the window.

getOldValue() - Method in class java.beans.PropertyChangeEvent

Gets the old value for the property, expressed as an Object.

getOldValue() - Method in class javax.management.AttributeChangeNotification

Gets the old value of the attribute which has changed.

getOmni() - Method in interface javax.sound.midi.MidiChannel

Obtains the current omni mode.

getOOBInline() - Method in class java.net.Socket

Tests if OOBINLINE is enabled.

getOpacity() - Method in class java.awt.Window

Returns the opacity of the window.

getOpenIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent non-leaf nodes that are expanded.

getOpenType() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.

getOpenType() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.

getOpenType() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.

getOperatingSystemMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the operating system on which the Java virtual machine is running.

getOperation() - Method in class java.rmi.server.Operation

Deprecated.
no replacement

getOperation(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanOperationInfo requested by name.

getOperation(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getOperations() - Method in interface java.rmi.server.Skeleton

Deprecated.
no replacement

getOperations() - Method in class javax.management.MBeanInfo

Returns the list of operations of the MBean.

getOperations() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of operations of the MBean.

getOperations() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance.

getOppositeComponent() - Method in class java.awt.event.FocusEvent

Returns the other Component involved in this focus change.

getOppositeWindow() - Method in class java.awt.event.WindowEvent

Returns the other Window involved in this focus or activation change.

getOptimizeHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns the value passed into the most recent call to setOptimizeHuffmanTables, or false if setOptimizeHuffmanTables has never been called.

getOption(int) - Method in interface java.net.SocketOptions

Fetch the value of an option.

getOption(SocketOption<T>) - Method in interface java.nio.channels.NetworkChannel

Returns the value of a socket option.

getOptions() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the processor-specific options passed to the annotation processing tool.

getOptions() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the confirmation options.

getOptions() - Method in class javax.security.auth.login.AppConfigurationEntry

Get the options configured for this LoginModule.

getOptions() - Method in class javax.swing.JOptionPane

Returns the choices the user can make.

getOptionType() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the option type.

getOptionType() - Method in class javax.swing.JOptionPane

Returns the type of options that are displayed.

getOrder() - Method in class java.security.spec.ECParameterSpec

Returns the order of the generator.

getOrientation() - Method in interface java.awt.Adjustable

Gets the orientation of the adjustable object.

getOrientation(Locale) - Static method in class java.awt.ComponentOrientation

Returns the orientation that is appropriate for the given locale.

getOrientation(ResourceBundle) - Static method in class java.awt.ComponentOrientation

Deprecated.
As of J2SE 1.4, use ComponentOrientation.getOrientation(java.util.Locale).

getOrientation() - Method in class java.awt.print.PageFormat

Returns the orientation of this PageFormat.

getOrientation() - Method in class java.awt.Scrollbar

Returns the orientation of this scroll bar.

getOrientation() - Method in class java.awt.ScrollPaneAdjustable

Returns the orientation of this scrollbar.

getOrientation() - Method in class javax.swing.JProgressBar

Returns SwingConstants.VERTICAL or SwingConstants.HORIZONTAL, depending on the orientation of the progress bar.

getOrientation() - Method in class javax.swing.JScrollBar

Returns the component's orientation (horizontal or vertical).

getOrientation() - Method in class javax.swing.JSeparator

Returns the orientation of this separator.

getOrientation() - Method in class javax.swing.JSlider

Return this slider's vertical or horizontal orientation.

getOrientation() - Method in class javax.swing.JSplitPane

Returns the orientation.

getOrientation() - Method in class javax.swing.JToolBar

Returns the current orientation of the tool bar.

getOrientation() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the orientation for the JSplitPane.

getOrientation() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

Returns the orientation of the toolbar window when the toolbar is floating.

getOrientationRequested() - Method in class java.awt.PageAttributes

Returns the print orientation for pages using these attributes.

getOrigin() - Method in class java.awt.PageAttributes

Returns whether drawing at (0, 0) to pages using these attributes draws at the upper-left corner of the physical page, or at the upper-left corner of the printable area.

getOriginal() - Method in interface javax.sql.rowset.CachedRowSet

Returns a ResultSet object containing the original value of this CachedRowSet object.

getOriginal() - Method in interface javax.sql.RowSetInternal

Retrieves a ResultSet object containing the original value of this RowSet object.

getOriginalRow() - Method in interface javax.sql.rowset.CachedRowSet

Returns a ResultSet object containing the original value for the current row only of this CachedRowSet object.

getOriginalRow() - Method in interface javax.sql.RowSetInternal

Retrieves a ResultSet object containing the original value of the current row only.

getOriginatingNode() - Method in interface javax.xml.transform.dom.DOMLocator

Return the node where the event occurred.

getOriginatingProvider() - Method in class javax.imageio.ImageReader

Returns the ImageReaderSpi that was passed in on the constructor.

getOriginatingProvider() - Method in class javax.imageio.ImageWriter

Returns the ImageWriterSpi object that created this ImageWriter, or null if this object was not created through the IIORegistry.

getOtherFile() - Method in exception java.nio.file.FileSystemException

Returns the other file used to create this exception.

getOtherHit() - Method in class java.awt.font.TextHitInfo

Creates a TextHitInfo on the other side of the insertion point.

getOtherPrimeInfo() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the otherPrimeInfo or null if there are only two prime factors (p and q).

getOtherPrimeInfo() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns a copy of the otherPrimeInfo or null if there are only two prime factors (p and q).

getOutline() - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of this GlyphVector.

getOutline(float, float) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of this GlyphVector when rendered at x, y.

getOutline(AffineTransform) - Method in class java.awt.font.GraphicAttribute

Return a Shape that represents the region that this GraphicAttribute renders.

getOutline(AffineTransform) - Method in class java.awt.font.ShapeGraphicAttribute

Return a Shape that represents the region that this ShapeGraphicAttribute renders.

getOutline(AffineTransform) - Method in class java.awt.font.TextLayout

Returns a Shape representing the outline of this TextLayout.

getOutput() - Method in class javax.imageio.ImageWriter

Returns the ImageOutputStream or other Object set by the most recent call to the setOutput method.

getOutputClass() - Method in class javax.imageio.spi.ImageOutputStreamSpi

Returns a 类 object representing the class or interface type that must be implemented by an output destination in order to be "wrapped" in an ImageOutputStream via the createOutputStreamInstance method.

getOutputFormat() - Method in class javax.print.StreamPrintService

Returns the document format emitted by this print service.

getOutputFormat() - Method in class javax.print.StreamPrintServiceFactory

Queries the factory for the document format that is emitted by printers obtained from this factory.

getOutputLength() - Method in class javax.xml.crypto.dsig.spec.HMACParameterSpec

Returns the truncation length.

getOutputProperties() - Method in interface javax.xml.transform.Templates

Get the properties corresponding to the effective xsl:output element.

getOutputProperties() - Method in class javax.xml.transform.Transformer

Get a copy of the output properties for the transformation.

getOutputProperty(String) - Method in class javax.xml.transform.Transformer

Get an output property that is in effect for the transformer.

getOutputSize(int) - Method in class javax.crypto.Cipher

Returns the length in bytes that an output buffer would need to be in order to hold the result of the next update or doFinal operation, given the input length inputLen (in bytes).

getOutputSize(int) - Method in class javax.crypto.ExemptionMechanism

Returns the length in bytes that an output buffer would need to be in order to hold the result of the next genExemptionBlob operation, given the input length inputLen (in bytes).

getOutputStatement(String) - Method in interface javax.script.ScriptEngineFactory

Returns a String that can be used as a statement to display the specified String using the syntax of the supported scripting language.

getOutputStream() - Method in class java.lang.Process

Returns the output stream connected to the normal input of the subprocess.

getOutputStream() - Method in class java.net.Socket

Returns an output stream for this socket.

getOutputStream() - Method in class java.net.SocketImpl

Returns an output stream for this socket.

getOutputStream() - Method in class java.net.URLConnection

Returns an output stream that writes to this connection.

getOutputStream() - Method in class java.rmi.server.LogStream

Deprecated.
no replacement

getOutputStream() - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getOutputStream() - Method in class javax.activation.DataHandler

Get an OutputStream for this DataHandler to allow overwriting the underlying data.

getOutputStream() - Method in interface javax.activation.DataSource

This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.

getOutputStream() - Method in class javax.activation.FileDataSource

This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.

getOutputStream() - Method in class javax.activation.URLDataSource

The getOutputStream method from the URL.

getOutputStream() - Method in class javax.print.StreamPrintService

Gets the output stream.

getOutputStream() - Method in class javax.xml.transform.stream.StreamResult

Get the byte stream that was set with setOutputStream.

getOutputTypes() - Method in class javax.imageio.spi.ImageWriterSpi

Returns an array of 类 objects indicating what types of objects may be used as arguments to the writer's setOutput method.

getOutsideBorder() - Method in class javax.swing.border.CompoundBorder

Returns the outside border object.

getOverwriteMode() - Method in class javax.swing.text.DefaultFormatter

Returns the behavior when inserting characters.

getOwnedWindows() - Method in class java.awt.Window

Return an array containing all the windows this window currently owns.

getOwner() - Method in class java.awt.Window

Returns the owner of this window.

getOwner() - Method in class java.beans.XMLDecoder

Gets the owner of this decoder.

getOwner() - Method in class java.beans.XMLEncoder

Gets the owner of this encoder.

getOwner() - Method in interface java.nio.file.attribute.FileOwnerAttributeView

Read the file owner.

getOwner(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns the owner of a file.

getOwner() - Method in class java.util.concurrent.locks.ReentrantLock

Returns the thread that currently owns this lock, or null if not owned.

getOwner() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns the thread that currently owns the write lock, or null if not owned.

getOwnerDocument() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since IIOMetadataNodes do not belong to any Document.

getOwnerDocument() - Method in interface org.w3c.dom.Node

The Document object associated with this node.

getOwnerElement() - Method in interface org.w3c.dom.Attr

The Element node this attribute is attached to or null if this attribute is not in use.

getOwnerlessWindows() - Static method in class java.awt.Window

Returns an array of all Windows created by this application that have no owner.

getOwnerType() - Method in interface java.lang.reflect.ParameterizedType

Returns a Type object representing the type that this type is a member of.

getP() - Method in interface java.security.interfaces.DSAParams

Returns the prime, p.

getP() - Method in class java.security.spec.DSAParameterSpec

Returns the prime p.

getP() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the prime p.

getP() - Method in class java.security.spec.DSAPublicKeySpec

Returns the prime p.

getP() - Method in class java.security.spec.ECFieldFp

Returns the prime p of this prime finite field.

getP() - Method in class javax.crypto.spec.DHParameterSpec

Returns the prime modulus p.

getP() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the prime modulus p.

getP() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the prime modulus p.

getP1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the start point.

getP1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the start point.

getP1() - Method in class java.awt.geom.CubicCurve2D

Returns the start point.

getP1() - Method in class java.awt.geom.Line2D.Double

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.Line2D.Float

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.Line2D

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the start point.

getP1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the start point.

getP1() - Method in class java.awt.geom.QuadCurve2D

Returns the start point.

getP2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the end point.

getP2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the end point.

getP2() - Method in class java.awt.geom.CubicCurve2D

Returns the end point.

getP2() - Method in class java.awt.geom.Line2D.Double

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.Line2D.Float

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.Line2D

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the end point.

getP2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the end point.

getP2() - Method in class java.awt.geom.QuadCurve2D

Returns the end point.

getPackage() - Method in class java.lang.类

Gets the package for this class.

getPackage(String) - Method in class java.lang.ClassLoader

Returns a 软件包 that has been defined by this class loader or any of its ancestors.

getPackage(String) - Static method in class java.lang.软件包

Find a package by name in the callers ClassLoader instance.

getPackageElement(CharSequence) - Method in interface javax.lang.model.util.Elements

Returns a package given its fully qualified name.

getPackageOf(Element) - Method in interface javax.lang.model.util.Elements

Returns the package of an element.

getPackages() - Method in class java.lang.ClassLoader

Returns all of the 软件包 defined by this class loader and its ancestors.

getPackages() - Static method in class java.lang.软件包

Get all the packages currently known for the caller's ClassLoader instance.

getPacketBufferSize() - Method in interface javax.net.ssl.SSLSession

Gets the current size of the largest SSL/TLS packet that is expected when using this session.

getPadding() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getPage() - Method in class javax.swing.JEditorPane

Gets the current URL being displayed.

getPageDimension() - Method in class java.awt.PrintJob

Returns the dimensions of the page in pixels.

getPageFormat(int) - Method in class java.awt.print.Book

Returns the PageFormat of the page specified by pageIndex.

getPageFormat(int) - Method in interface java.awt.print.Pageable

Returns the PageFormat of the page specified by pageIndex.

getPageFormat(PrintRequestAttributeSet) - Method in class java.awt.print.PrinterJob

Calculates a PageFormat with values consistent with those supported by the current PrintService for this job (ie the value returned by getPrintService()) and media, printable area and orientation contained in attributes.

getPageIncrement() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getBlockIncrement().

getPageRanges() - Method in class java.awt.JobAttributes

Specifies, for jobs using these attributes, the ranges of pages to be printed, if a range of pages is to be printed.

getPageResolution() - Method in class java.awt.PrintJob

Returns the resolution of the page in pixels per inch.

getPageSize() - Method in interface javax.sql.rowset.CachedRowSet

Returns the page-size for the CachedRowSet object

getPaint() - Method in class java.awt.Graphics2D

Returns the current Paint of the Graphics2D context.

getPaint() - Method in class javax.swing.border.StrokeBorder

Returns the Paint object used to generate a color during the border rendering.

getPaintContext() - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Gets the PaintContext for this painting operation.

getPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

getPainter(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the SynthPainter that will be used for painting.

getPainter(GlyphView, int, int) - Method in class javax.swing.text.GlyphView.GlyphPainter

Create a painter to use for the given GlyphView.

getPainter() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the painter for the highlighter.

getPaintLabels() - Method in class javax.swing.JSlider

Tells if labels are to be painted.

getPaintTicks() - Method in class javax.swing.JSlider

Tells if tick marks are to be painted.

getPaintTrack() - Method in class javax.swing.JSlider

Tells if the track (area the slider slides in) is to be painted.

getPaper() - Method in class java.awt.print.PageFormat

Returns a copy of the Paper object associated with this PageFormat.

getParagraphAttributes() - Method in class javax.swing.JTextPane

Fetches the current paragraph attributes in effect at the location of the caret, or null if none.

getParagraphElement(int) - Method in class javax.swing.text.AbstractDocument

Get the paragraph element containing the given position.

getParagraphElement(int) - Method in class javax.swing.text.DefaultStyledDocument

Gets the paragraph element at the offset pos.

getParagraphElement(int) - Method in class javax.swing.text.PlainDocument

Get the paragraph element containing the given position.

getParagraphElement(int) - Method in interface javax.swing.text.StyledDocument

Gets the element that represents the paragraph that encloses the given offset within the document.

getParagraphElement(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the element to use for a paragraph/line.

getParallelism() - Method in class java.util.concurrent.ForkJoinPool

Returns the targeted parallelism level of this pool.

getParamClasses() - Method in class java.awt.image.renderable.ParameterBlock

Returns an array of Class objects describing the types of the parameters.

getParameter(String) - Method in class java.applet.Applet

Returns the value of the named parameter in the HTML tag.

getParameter(String) - Method in interface java.applet.AppletStub

Returns the value of the named parameter in the HTML tag.

getParameter(String) - Method in class java.awt.datatransfer.DataFlavor

Returns the human presentable name for this DataFlavor if paramName equals "humanPresentableName".

getParameter(String) - Method in class java.security.Signature

Deprecated.

getParameter() - Method in exception java.sql.DataTruncation

Indicates whether the value truncated was a parameter value or a column value.

getParameter(String) - Method in class javax.activation.MimeType

Retrieve the value associated with the given name, or null if there is no current association.

getParameter(String) - Method in class javax.print.DocFlavor

Returns a String representing a MIME parameter.

getParameter(String) - Method in interface javax.script.ScriptEngineFactory

Returns the value of an attribute whose meaning may be implementation-specific.

getParameter(String) - Method in class javax.xml.transform.Transformer

Get a parameter that was explicitly set with setParameter.

getParameter(String) - Method in interface org.w3c.dom.DOMConfiguration

Return the value of a parameter if known.

getParameterAnnotations() - Method in class java.lang.reflect.Constructor

Returns an array of arrays that represent the annotations on the formal parameters, in declaration order, of the method represented by this Constructor object.

getParameterAnnotations() - Method in class java.lang.reflect.方法

Returns an array of arrays that represent the annotations on the formal parameters, in declaration order, of the method represented by this Method object.

getParameterBlock() - Method in class java.awt.image.renderable.RenderableImageOp

Returns a reference to the current parameter block.

getParameterClassName(int) - Method in interface java.sql.ParameterMetaData

Retrieves the fully-qualified name of the Java class whose instances should be passed to the method PreparedStatement.setObject.

getParameterCount() - Method in interface java.sql.ParameterMetaData

Retrieves the number of parameters in the PreparedStatement object for which this ParameterMetaData object contains information.

getParameterDescriptors() - Method in class java.beans.MethodDescriptor

Gets the ParameterDescriptor for each of this MethodDescriptor's method's parameters.

getParameterInfo() - Method in class java.applet.Applet

Returns information about the parameters that are understood by this applet.

getParameterMetaData() - Method in interface java.sql.PreparedStatement

Retrieves the number, types and properties of this PreparedStatement object's parameters.

getParameterMode(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's mode.

getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.

getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.

getParameterNames() - Method in interface org.w3c.dom.DOMConfiguration

The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.

getParameters() - Method in class java.awt.image.renderable.ParameterBlock

Returns the entire Vector of parameters.

getParameters() - Method in class java.security.Policy

Return Policy parameters.

getParameters() - Method in class java.security.Signature

Returns the parameters used with this signature object.

getParameters() - Method in class java.util.logging.LogRecord

Get the parameters to the log message.

getParameters() - Method in class javax.activation.MimeType

Retrieve this object's parameter list.

getParameters() - Method in class javax.crypto.Cipher

Returns the parameters used with this cipher.

getParameters() - Method in interface javax.lang.model.element.ExecutableElement

Returns the formal parameters of this executable.

getParameters() - Method in class javax.net.ssl.CertPathTrustManagerParameters

Return a clone of the CertPathParameters encapsulated by this class.

getParameters() - Method in class javax.net.ssl.KeyStoreBuilderParameters

Return the unmodifiable List of the KeyStore.Builders encapsulated by this object.

getParameters() - Method in class javax.security.auth.login.Configuration

Return Configuration parameters.

getParameterSpec(Class<T>) - Method in class java.security.AlgorithmParameters

Returns a (transparent) specification of this parameter object.

getParameterSpec() - Method in interface javax.xml.crypto.AlgorithmMethod

Returns the algorithm parameters of this AlgorithmMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.CanonicalizationMethod

Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.DigestMethod

Returns the algorithm-specific input parameters associated with this DigestMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.SignatureMethod

Returns the algorithm-specific input parameters of this SignatureMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.Transform

Returns the algorithm-specific input parameters associated with this Transform.

getParameterType(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's SQL type.

getParameterTypeName(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's database-specific type name.

getParameterTypes() - Method in class java.lang.reflect.Constructor

Returns an array of 类 objects that represent the formal parameter types, in declaration order, of the constructor represented by this Constructor object.

getParameterTypes() - Method in class java.lang.reflect.方法

Returns an array of 类 objects that represent the formal parameter types, in declaration order, of the method represented by this Method object.

getParameterTypes() - Method in interface javax.lang.model.type.ExecutableType

Returns the types of this executable's formal parameters.

getParameterTypes() - Method in class javax.management.loading.MLetContent

Gets the list of values of the TYPE attribute in each nested <PARAM> tag within the MLET tag.

getParameterValues() - Method in class javax.management.loading.MLetContent

Gets the list of values of the VALUE attribute in each nested <PARAM> tag within the MLET tag.

getParams() - Method in interface java.security.interfaces.DSAKey

Returns the DSA-specific key parameters.

getParams() - Method in interface java.security.interfaces.ECKey

Returns the domain parameters associated with this key.

getParams() - Method in class java.security.spec.ECPrivateKeySpec

Returns the associated elliptic curve domain parameters.

getParams() - Method in class java.security.spec.ECPublicKeySpec

Returns the associated elliptic curve domain parameters.

getParams() - Method in interface javax.crypto.interfaces.DHKey

Returns the key parameters.

getParams() - Method in class javax.sql.rowset.BaseRowSet

Retrieves an array containing the parameter values (both Objects and primitives) that have been set for this RowSet object's command and throws an SQLException object if all parameters have not been set.

getParams() - Method in interface javax.sql.RowSetInternal

Retrieves the parameters that have been set for this RowSet object's command.

getParent() - Method in class java.awt.Component

Gets the parent of this component.

getParent() - Method in class java.awt.image.Raster

Returns the parent Raster (if any) of this Raster or null.

getParent() - Method in class java.awt.MenuComponent

Returns the parent container for this menu component.

getParent() - Method in class java.awt.PopupMenu

Returns the parent container for this menu component.

getParent() - Method in class java.io.File

Returns the pathname string of this abstract pathname's parent, or null if this pathname does not name a parent directory.

getParent() - Method in class java.lang.ClassLoader

Returns the parent class loader for delegation.

getParent() - Method in class java.lang.ThreadGroup

Returns the parent of this thread group.

getParent() - Method in class java.net.NetworkInterface

Returns the parent NetworkInterface of this interface if this is a subinterface, or null if it is a physical (non virtual) interface or has no parent.

getParent() - Method in interface java.nio.file.Path

Returns the parent path, or null if this path does not have a parent.

getParent() - Method in interface java.security.cert.PolicyNode

Returns the parent of this node, or null if this is the root node.

getParent() - Method in class java.util.concurrent.Phaser

Returns the parent of this phaser, or null if none.

getParent() - Method in class java.util.logging.Logger

Return the parent for this Logger.

getParent() - Method in class java.util.prefs.NodeChangeEvent

Returns the parent of the node that was added or removed.

getParent() - Method in class javax.swing.ActionMap

Returns this ActionMap's parent.

getParent() - Method in class javax.swing.InputMap

Gets this InputMap's parent.

getParent() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the parent TreeNode of the receiver.

getParent() - Method in class javax.swing.text.View

Returns the parent of the view.

getParent() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's parent or null if this node has no parent.

getParent() - Method in interface javax.swing.tree.TreeNode

Returns the parent TreeNode of the receiver.

getParent() - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Returns the parent node.

getParent() - Method in class javax.xml.stream.util.EventReaderDelegate

Get the parent of this instance.

getParent() - Method in class javax.xml.stream.util.StreamReaderDelegate

Get the parent of this instance.

getParent() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the parent reader.

getParent() - Method in interface org.xml.sax.XMLFilter

Get the parent reader.

getParentDirectory(File) - Method in class javax.swing.filechooser.FileSystemView

Returns the parent directory of dir.

getParentElement() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the parent of the element.

getParentElement() - Method in interface javax.swing.text.Element

Fetches the parent element.

getParentElement() - Method in interface javax.xml.soap.Node

Returns the parent element of this Node object.

getParentFile() - Method in class java.io.File

Returns the abstract pathname of this abstract pathname's parent, or null if this pathname does not name a parent directory.

getParentLogger() - Method in interface java.sql.Driver

Return the parent Logger of all the Loggers used by this driver.

getParentLogger() - Method in interface javax.sql.CommonDataSource

Return the parent Logger of all the Loggers used by this data source.

getParentLoggerName(String) - Method in interface java.lang.management.PlatformLoggingMXBean

Returns the name of the parent for the specified logger.

getParentLoggerName(String) - Method in interface java.util.logging.LoggingMXBean

Returns the name of the parent for the specified logger.

getParentNode() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the parent of this node.

getParentNode() - Method in interface org.w3c.dom.Node

The parent of this node.

getParentPath() - Method in class javax.swing.tree.TreePath

Returns the TreePath of the parent.

getParser() - Method in class javax.swing.text.html.HTMLDocument

Returns the parser that is used when inserting HTML into the existing document.

getParser() - Method in class javax.swing.text.html.HTMLEditorKit

Fetch the parser to use for reading HTML streams.

getParser() - Method in class javax.xml.parsers.SAXParser

Returns the SAX parser that is encapsultated by the implementation of this class.

getPartialSize(int, int) - Method in class javax.swing.text.ParagraphView

Returns the size used by the views between startOffset and endOffset.

getPartialSpan(int, int) - Method in class javax.swing.text.GlyphView

Determines the span along the same axis as tab expansion for a portion of the view.

getPartialSpan(int, int) - Method in interface javax.swing.text.TabableView

Determines the span along the same axis as tab expansion for a portion of the view.

getParties() - Method in class java.util.concurrent.CyclicBarrier

Returns the number of parties required to trip this barrier.

getPassword() - Method in class java.net.PasswordAuthentication

Returns the user password.

getPassword() - Method in class java.security.KeyStore.PasswordProtection

Gets the password.

getPassword() - Method in interface javax.crypto.interfaces.PBEKey

Returns the password.

getPassword() - Method in class javax.crypto.spec.PBEKeySpec

Returns a copy of the password.

getPassword() - Method in class javax.security.auth.callback.PasswordCallback

Get the retrieved password.

getPassword() - Method in class javax.sql.rowset.BaseRowSet

Returns the password used to create a database connection for this RowSet object.

getPassword() - Method in interface javax.sql.RowSet

Retrieves the password used to create a database connection.

getPassword() - Method in class javax.swing.JPasswordField

Returns the text contained in this TextComponent.

getPasswordAuthentication() - Method in class java.net.Authenticator

Called when password authorization is needed.

getPasteAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs paste operations from the clipboard.

getPatch() - Method in class javax.sound.midi.Instrument

Obtains the Patch object that indicates the bank and program numbers where this instrument is to be stored in the synthesizer.

getPatchList() - Method in class javax.sound.midi.Sequence

Obtains a list of patches referenced in this sequence.

getPath() - Method in class java.io.File

Converts this abstract pathname into a pathname string.

getPath() - Method in class java.net.HttpCookie

Returns the path on the server to which the browser returns this cookie.

getPath() - Method in class java.net.URI

Returns the decoded path component of this URI.

getPath() - Method in class java.net.URL

Gets the path part of this URL.

getPath(String, String...) - Method in class java.nio.file.FileSystem

Converts a path string, or a sequence of strings that when joined form a path string, to a Path.

getPath(URI) - Method in class java.nio.file.spi.FileSystemProvider

Return a Path object by converting the given URI.

getPath() - Method in class javax.swing.event.MenuDragMouseEvent

Returns the path to the selected menu item.

getPath() - Method in class javax.swing.event.MenuKeyEvent

Returns the path to the menu item referenced by this event.

getPath() - Method in class javax.swing.event.TreeExpansionEvent

Returns the path to the value that has been expanded/collapsed.

getPath() - Method in class javax.swing.event.TreeModelEvent

Convenience method to get the array of objects from the TreePath instance that this event wraps.

getPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the first path element.

getPath() - Method in class javax.swing.JTree.DropLocation

Returns the path where dropped data should be placed in the tree.

getPath() - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPath() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the path from the root, to get to this node.

getPath() - Method in class javax.swing.tree.TreePath

Returns an ordered array of the elements of this TreePath.

getPath() - Method in class javax.xml.ws.spi.http.HttpContext

Returns the path for this context.

getPathBetweenRows(int, int) - Method in class javax.swing.JTree

Returns the paths (inclusive) between the specified rows.

getPathBounds(TreePath) - Method in class javax.swing.JTree

Returns the Rectangle that the specified node will be drawn into.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPathBounds method on each UI handled by this object.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.TreeUI

Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.

getPathClosestTo(int, int) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the path to the node that is closest to x,y.

getPathClosestTo(int, int) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the path to the node that is closest to x,y.

getPathClosestTo(int, int) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the path to the node that is closest to x,y.

getPathComponent(int) - Method in class javax.swing.tree.TreePath

Returns the path element at the specified index.

getPathCount() - Method in class javax.swing.tree.TreePath

Returns the number of elements in the path.

getPathForLocation(int, int) - Method in class javax.swing.JTree

Returns the path for the node at the specified location.

getPathForRow(int) - Method in class javax.swing.JTree

Returns the path for the specified row.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path for passed in row.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPathForRow method on each UI handled by this object.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.TreeUI

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the path for row.

getPathInfo() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Arc2D

Returns an iteration object that defines the boundary of the arc.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Area

Creates a PathIterator for the outline of this Area object.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Area

Creates a PathIterator for the flattened outline of this Area object.

getPathIterator(AffineTransform) - Method in class java.awt.geom.CubicCurve2D

Returns an iteration object that defines the boundary of the shape.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.CubicCurve2D

Return an iteration object that defines the boundary of the flattened shape.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Ellipse2D

Returns an iteration object that defines the boundary of this Ellipse2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Line2D

Returns an iteration object that defines the boundary of this Line2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Line2D

Returns an iteration object that defines the boundary of this flattened Line2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Path2D.Double

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Path2D.Float

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Path2D

Returns an iterator object that iterates along the Shape boundary and provides access to a flattened view of the Shape outline geometry.

getPathIterator(AffineTransform) - Method in class java.awt.geom.QuadCurve2D

Returns an iteration object that defines the boundary of the shape of this QuadCurve2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.QuadCurve2D

Returns an iteration object that defines the boundary of the flattened shape of this QuadCurve2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Rectangle2D

Returns an iteration object that defines the boundary of this Rectangle2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Rectangle2D

Returns an iteration object that defines the boundary of the flattened Rectangle2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.RectangularShape

Returns an iterator object that iterates along the Shape object's boundary and provides access to a flattened view of the outline of the Shape object's geometry.

getPathIterator(AffineTransform) - Method in class java.awt.geom.RoundRectangle2D

Returns an iteration object that defines the boundary of this RoundRectangle2D.

getPathIterator(AffineTransform) - Method in class java.awt.Polygon

Returns an iterator object that iterates along the boundary of this Polygon and provides access to the geometry of the outline of this Polygon.

getPathIterator(AffineTransform, double) - Method in class java.awt.Polygon

Returns an iterator object that iterates along the boundary of the Shape and provides access to the geometry of the outline of the Shape.

getPathIterator(AffineTransform) - Method in interface java.awt.Shape

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform, double) - Method in interface java.awt.Shape

Returns an iterator object that iterates along the Shape boundary and provides access to a flattened view of the Shape outline geometry.

getPathMatcher(String) - Method in class java.nio.file.FileSystem

Returns a PathMatcher that performs match operations on the String representation of Path objects by interpreting a given pattern.

getPaths() - Method in class javax.swing.event.TreeSelectionEvent

Returns the paths that have been added or removed from the selection.

getPathToNames() - Method in class java.security.cert.X509CertSelector

Returns a copy of the pathToNames criterion.

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree.DefaultMutableTreeNode

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPathToRoot(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree.DefaultTreeModel

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPattern() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the erroneous regular-expression pattern.

getPatternSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used to separate positive and negative subpatterns in a pattern.

getPayload() - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

getPayload(JAXBContext) - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as a JAXB object.

getPCSType() - Method in class java.awt.color.ICC_Profile

Returns the color space type of the Profile Connection Space (PCS).

getPeakThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the peak live thread count since the Java virtual machine started or peak was reset.

getPeakUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the peak memory usage of this memory pool since the Java virtual machine was started or since the peak was reset.

getPeer() - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, programs should not directly manipulate peers; replaced by boolean isDisplayable().

getPeer() - Method in class java.awt.Font

Deprecated.
Font rendering is now platform independent.

getPeer() - Method in class java.awt.MenuComponent

Deprecated.
As of JDK version 1.1, programs should not directly manipulate peers.

getPeerCertificateChain() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was identified as part of defining the session.

getPeerCertificateChain() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was identified as part of defining the session.

getPeerCertificates() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was established as part of defining the session.

getPeerCertificates() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was established as part of defining the session.

getPeerHost() - Method in class javax.net.ssl.SSLEngine

Returns the host name of the peer.

getPeerHost() - Method in interface javax.net.ssl.SSLSession

Returns the host name of the peer in this session.

getPeerPort() - Method in class javax.net.ssl.SSLEngine

Returns the port number of the peer.

getPeerPort() - Method in interface javax.net.ssl.SSLSession

Returns the port number of the peer in this session.

getPeerPrincipal() - Method in class java.net.SecureCacheResponse

Returns the server's principal which was established as part of defining the session during the original connection that retrieved the network resource.

getPeerPrincipal() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was established as part of defining the session.

getPeerPrincipal() - Method in class javax.net.ssl.HttpsURLConnection

Returns the server's principal which was established as part of defining the session.

getPeerPrincipal() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was established as part of defining the session.

getPeerSupportedSignatureAlgorithms() - Method in class javax.net.ssl.ExtendedSSLSession

Obtains an array of supported signature algorithms that the peer is able to use.

getPercent() - Method in class java.text.DecimalFormatSymbols

Gets the character used for percent sign.

getPercentComplete() - Method in class javax.swing.JProgressBar

Returns the percent complete for the progress bar.

getPercentInstance() - Static method in class java.text.NumberFormat

Returns a percentage format for the current default locale.

getPercentInstance(Locale) - Static method in class java.text.NumberFormat

Returns a percentage format for the specified locale.

getPercentInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats percentage values for the specified locale.

getPeriod(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the period (in milliseconds) associated to a timer notification.

getPeriod(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the period (in milliseconds) associated to a timer notification.

getPermanentFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the permanent focus owner, if the permanent focus owner is in the same context as the calling thread.

getPerMill() - Method in class java.text.DecimalFormatSymbols

Gets the character used for per mille sign.

getPermission() - Method in class java.net.HttpURLConnection

Returns a SocketPermission object representing the permission necessary to connect to the destination host and port.

getPermission() - Method in class java.net.URLConnection

Returns a permission object representing the permission necessary to make the connection represented by this object.

getPermission() - Method in exception java.security.AccessControlException

Gets the Permission object associated with this exeception, or null if there was no corresponding Permission object.

getPermissions(CodeSource) - Method in class java.net.URLClassLoader

Returns the permissions for the given codesource object.

getPermissions(Principal) - Method in interface java.security.acl.Acl

Returns an enumeration for the set of allowed permissions for the specified principal (representing an entity such as an individual or a group).

getPermissions(CodeSource) - Method in class java.security.Policy

Return a PermissionCollection object containing the set of permissions granted to the specified CodeSource.

getPermissions(ProtectionDomain) - Method in class java.security.Policy

Return a PermissionCollection object containing the set of permissions granted to the specified ProtectionDomain.

getPermissions() - Method in class java.security.ProtectionDomain

Returns the static permissions granted to this domain.

getPermissions(CodeSource) - Method in class java.security.SecureClassLoader

Returns the permissions for the given CodeSource object.

getPermissions(Subject, CodeSource) - Method in class javax.security.auth.Policy

Deprecated.

Retrieve the Permissions granted to the Principals associated with the specified CodeSource.

getPersistenceDelegate(Class<?>) - Method in class java.beans.Encoder

Returns the persistence delegate for the given type.

getPhase() - Method in class java.util.concurrent.Phaser

Returns the current phase number.

getPIData() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPIData() - Method in interface javax.xml.stream.XMLStreamReader

Get the data section of a processing instruction

getPITarget() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPITarget() - Method in interface javax.xml.stream.XMLStreamReader

Get the target of a processing instruction

getPitchBend() - Method in interface javax.sound.midi.MidiChannel

Obtains the upward or downward pitch offset for this channel.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns all samples for the specified pixel in an int array.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns all samples for the specified pixel in an int array, one sample per array element.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the specified single band pixel in the first element of an int array.

getPixel(int, int, int[]) - Method in class java.awt.image.Raster

Returns the samples in an array of int for the specified pixel.

getPixel(int, int, float[]) - Method in class java.awt.image.Raster

Returns the samples in an array of float for the specified pixel.

getPixel(int, int, double[]) - Method in class java.awt.image.Raster

Returns the samples in an array of double for the specified pixel.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified pixel in an int array, one sample per array element.

getPixel(int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for the specified pixel in an array of float.

getPixel(int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for the specified pixel in an array of double.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns all samples in for the specified pixel in an int array.

getPixelBitStride() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the pixel bit stride in bits.

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font.GlyphVector

Returns the pixel bounds of this GlyphVector when rendered in a graphics with the given FontRenderContext at the given location.

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font.TextLayout

Returns the pixel bounds of this TextLayout when rendered in a graphics with the given FontRenderContext at the given location.

getPixelColor(int, int) - Method in class java.awt.Robot

Returns the color of a pixel at the given screen coordinates.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per data array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per array element.

getPixels() - Method in class java.awt.image.PixelGrabber

Get the pixel buffer.

getPixels(int, int, int, int, int[]) - Method in class java.awt.image.Raster

Returns an int array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, float[]) - Method in class java.awt.image.Raster

Returns a float array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, double[]) - Method in class java.awt.image.Raster

Returns a double array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in an int array, one sample per array element.

getPixels(int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in a float array, one sample per array element.

getPixels(int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in a double array, one sample per array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per array element.

getPixelSize() - Method in class java.awt.image.ColorModel

Returns the number of bits per pixel described by this ColorModel.

getPixelStride() - Method in class java.awt.image.ComponentSampleModel

Returns the pixel stride of this ComponentSampleModel.

getPlaceholder() - Method in class javax.swing.text.MaskFormatter

Returns the String to use if the value does not completely fill in the mask.

getPlaceholderCharacter() - Method in class javax.swing.text.MaskFormatter

Returns the character to use in place of characters that are not present in the value, ie the user must fill them in.

getPlatformManagementInterfaces() - Static method in class java.lang.management.ManagementFactory

Returns the set of 类 objects, subinterface of PlatformManagedObject, representing all management interfaces for monitoring and managing the Java platform.

getPlatformMBeanServer() - Static method in class java.lang.management.ManagementFactory

Returns the platform MBeanServer.

getPlatformMXBean(Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the platform MXBean implementing the given mxbeanInterface which is specified to have one single instance in the Java virtual machine.

getPlatformMXBean(MBeanServerConnection, Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the platform MXBean proxy for mxbeanInterface which is specified to have one single instance in a Java virtual machine and the proxy will forward the method calls through the given MBeanServerConnection.

getPlatformMXBeans(Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the list of platform MXBeans implementing the given mxbeanInterface in the Java virtual machine.

getPlatformMXBeans(MBeanServerConnection, Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the list of the platform MXBean proxies for forwarding the method calls of the mxbeanInterface through the given MBeanServerConnection.

getPluginClassName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the fully-qualified class name of the ImageReader or ImageWriter plug-in associated with this service provider.

getPoint() - Method in class java.awt.event.MouseEvent

Returns the x,y position of the event relative to the source component.

getPoint1() - Method in class java.awt.GradientPaint

Returns a copy of the point P1 that anchors the first color.

getPoint2() - Method in class java.awt.GradientPaint

Returns a copy of the point P2 which anchors the second color.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.AffineTransformOp

Returns the location of the corresponding destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.BandCombineOp

Returns the location of the corresponding destination point given a point in the source Raster.

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image.BufferedImageOp

Returns the location of the corresponding destination point given a point in the source image.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.ColorConvertOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.ConvolveOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.LookupOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image.RasterOp

Returns the location of the destination point given a point in the source Raster.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.RescaleOp

Returns the location of the destination point given a point in the source.

getPointerInfo() - Static method in class java.awt.MouseInfo

Returns a PointerInfo instance that represents the current location of the mouse pointer.

getPointSize(int) - Method in class javax.swing.text.html.StyleSheet

Returns the point size, given a size index.

getPointSize(String) - Method in class javax.swing.text.html.StyleSheet

Given a string such as "+2", "-2", or "2", returns a point size value.

getPolicy() - Method in class java.security.cert.X509CertSelector

Returns the policy criterion.

getPolicy() - Static method in class java.security.Policy

Returns the installed Policy object.

getPolicy() - Static method in class javax.security.auth.Policy

Deprecated.

Returns the installed Policy object.

getPolicyQualifier() - Method in class java.security.cert.PolicyQualifierInfo

Returns the ASN.1 DER encoded form of the qualifier field of this PolicyQualifierInfo.

getPolicyQualifierId() - Method in class java.security.cert.PolicyQualifierInfo

Returns the policyQualifierId field of this PolicyQualifierInfo.

getPolicyQualifiers() - Method in interface java.security.cert.PolicyNode

Returns the set of policy qualifiers associated with the valid policy represented by this node.

getPolicyQualifiersRejected() - Method in class java.security.cert.PKIXParameters

Gets the PolicyQualifiersRejected flag.

getPolicyTree() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the root node of the valid policy tree resulting from the PKIX certification path validation algorithm.

getPolyPressure(int) - Method in interface javax.sound.midi.MidiChannel

Obtains the pressure with which the specified key is being depressed.

getPool() - Static method in class java.util.concurrent.ForkJoinTask

Returns the pool hosting the current task execution, or null if this task is executing outside of any ForkJoinPool.

getPool() - Method in class java.util.concurrent.ForkJoinWorkerThread

Returns the pool hosting this thread.

getPooledConnection() - Method in interface javax.sql.ConnectionPoolDataSource

Attempts to establish a physical database connection that can be used as a pooled connection.

getPooledConnection(String, String) - Method in interface javax.sql.ConnectionPoolDataSource

Attempts to establish a physical database connection that can be used as a pooled connection.

getPoolIndex() - Method in class java.util.concurrent.ForkJoinWorkerThread

Returns the index number of this thread in its pool.

getPoolName() - Method in class java.lang.management.MemoryNotificationInfo

Returns the name of the memory pool that triggers this notification.

getPoolSize() - Method in class java.util.concurrent.ForkJoinPool

Returns the number of worker threads that have started but not yet terminated.

getPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the current number of threads in the pool.

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getPopup method on each UI handled by this object.

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf.PopupMenuUI

Returns the Popup that will be responsible for displaying the JPopupMenu.

getPopup(Component, Component, int, int) - Method in class javax.swing.PopupFactory

Creates a Popup for the Component owner containing the Component contents.

getPopupHeightForRowCount(int) - Method in class javax.swing.plaf.basic.BasicComboPopup

Retrieves the height of the popup based on the current ListCellRenderer and the maximum row count.

getPopupLocation(MouseEvent) - Method in class javax.swing.JComponent

Returns the preferred location to display the popup menu in this component's coordinate system.

getPopupMenu() - Method in class java.awt.TrayIcon

Returns the popup menu associated with this TrayIcon.

getPopupMenu() - Method in class javax.swing.JMenu

Returns the popupmenu associated with this menu.

getPopupMenuListeners() - Method in class javax.swing.JComboBox

Returns an array of all the PopupMenuListeners added to this JComboBox with addPopupMenuListener().

getPopupMenuListeners() - Method in class javax.swing.JPopupMenu

Returns an array of all the PopupMenuListeners added to this JMenuItem with addPopupMenuListener().

getPopupMenuOrigin() - Method in class javax.swing.JMenu

Computes the origin for the JMenu's popup menu.

getPort() - Method in class java.net.DatagramPacket

Returns the port number on the remote host to which this datagram is being sent or from which the datagram was received.

getPort() - Method in class java.net.DatagramSocket

Returns the port number to which this socket is connected.

getPort() - Method in class java.net.InetSocketAddress

Gets the port number.

getPort() - Method in class java.net.Socket

Returns the remote port number to which this socket is connected.

getPort() - Method in class java.net.SocketImpl

Returns the value of this socket's port field.

getPort() - Method in class java.net.URI

Returns the port number of this URI.

getPort() - Method in class java.net.URL

Gets the port number of this URL.

getPort() - Method in class java.security.cert.LDAPCertStoreParameters

Returns the port number of the LDAP server.

getPort() - Method in class javax.management.remote.JMXServiceURL

The port of the Service URL.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.EndpointReference

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPortlist() - Method in class java.net.HttpCookie

Return the port list attribute of the cookie

getPortName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL port being accessed.

getPorts() - Method in class javax.xml.ws.Service

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPorts() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPosition() - Method in class java.awt.font.LineBreakMeasurer

Returns the current position of this LineBreakMeasurer.

getPosition(Component) - Method in class javax.swing.JLayeredPane

Get the relative position of the component within its layer.

getPosition(int) - Method in class javax.swing.SizeSequence

Returns the start position for the specified entry.

getPosition() - Method in class javax.swing.text.TabStop

Returns the position, as a float, of the tab.

getPosition() - Method in interface javax.tools.Diagnostic

Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem.

getPosition() - Method in interface org.w3c.dom.ls.LSProgressEvent

The current position in the input source, including all external entities and other resources that have been read.

getPositionAbove(JTextComponent, int, int) - Static method in class javax.swing.text.Utilities

Determines the position in the model that is closest to the given view location in the row above.

getPositionBelow(JTextComponent, int, int) - Static method in class javax.swing.text.Utilities

Determines the position in the model that is closest to the given view location in the row below.

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text.GapContent

Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text.StringContent

Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.

getPositivePrefix() - Method in class java.text.DecimalFormat

Get the positive prefix.

getPositiveSuffix() - Method in class java.text.DecimalFormat

Get the positive suffix.

getPosixFilePermissions(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns a file's POSIX file permissions.

getPreciseWheelRotation() - Method in class java.awt.event.MouseWheelEvent

Returns the number of "clicks" the mouse wheel was rotated, as a double.

getPrecision() - Method in class java.math.MathContext

Returns the precision setting.

getPrecision(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's specified column size.

getPrecision(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's specified column size.

getPrecision() - Method in exception java.util.IllegalFormatPrecisionException

Returns the precision

getPrecision() - Method in class javax.sound.sampled.FloatControl

Obtains the resolution or granularity of the control, in the units that the control measures.

getPrecision(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the total number of digits for values stored in the designated column.

getPredefinedCursor(int) - Static method in class java.awt.Cursor

Returns a cursor object with the specified predefined type.

getPreferredButtonSize(AbstractButton, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

getPreferredCommands(String) - Method in class javax.activation.CommandMap

Get the preferred command list from a MIME Type.

getPreferredCommands(String, DataSource) - Method in class javax.activation.CommandMap

Get the preferred command list from a MIME Type.

getPreferredCommands() - Method in class javax.activation.DataHandler

Return the preferred commands for this type of data.

getPreferredCommands(String) - Method in class javax.activation.MailcapCommandMap

Get the preferred command list for a MIME Type.

getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container) - Method in class javax.swing.LayoutStyle

Returns the amount of space to use between two components.

getPreferredHeight() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the preferred height.

getPreferredHeight() - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the preferred height.

getPreferredHorizontalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredInnerHorizontal() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredInnerVertical() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth.SynthMenuItemUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth.SynthMenuUI

getPreferredMinSize() - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the minimum preferred size.

getPreferredScrollableViewportSize() - Method in class javax.swing.JLayer

Returns the preferred size of the viewport for a view component.

getPreferredScrollableViewportSize() - Method in class javax.swing.JList

Computes the size of viewport needed to display visibleRowCount rows.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTable

Returns the preferred size of the viewport for this table.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTextArea

Returns the preferred size of the viewport if this component is embedded in a JScrollPane.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTree

Returns the preferred display size of a JTree.

getPreferredScrollableViewportSize() - Method in interface javax.swing.Scrollable

Returns the preferred size of the viewport for a view component.

getPreferredScrollableViewportSize() - Method in class javax.swing.text.JTextComponent

Returns the preferred size of the viewport for a view component.

getPreferredSize() - Method in class java.awt.Component

Gets the preferred size of this component.

getPreferredSize() - Method in class java.awt.Container

Returns the preferred size of this container.

getPreferredSize(int) - Method in class java.awt.List

Gets the preferred dimensions for a list with the specified number of rows.

getPreferredSize() - Method in class java.awt.List

Gets the preferred size of this scrolling list.

getPreferredSize(int, int) - Method in class java.awt.TextArea

Determines the preferred size of a text area with the specified number of rows and columns.

getPreferredSize() - Method in class java.awt.TextArea

Determines the preferred size of this text area.

getPreferredSize(int) - Method in class java.awt.TextField

Gets the preferred size of this text field with the specified number of columns.

getPreferredSize() - Method in class java.awt.TextField

Gets the preferred size of this text field.

getPreferredSize() - Method in class javax.swing.JComponent

If the preferredSize has been set to a non-null value just returns it.

getPreferredSize() - Method in class javax.swing.JEditorPane

Returns the preferred size for the JEditorPane.

getPreferredSize() - Method in class javax.swing.JTextArea

Returns the preferred size of the TextArea.

getPreferredSize() - Method in class javax.swing.JTextField

Returns the preferred size Dimensions needed for this TextField.

getPreferredSize() - Method in class javax.swing.JToolBar.Separator

Returns the preferred size for the separator.

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the preferred size of the BasicArrowButton.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicComboBoxRenderer

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI

The preferredSize of the list depends upon the layout orientation.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

If c is the JOptionPane the receiver is contained in, the preferred size that is returned is the maximum of the preferred size of the LayoutManager for the JOptionPane, and getMinimumOptionPaneSize.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

The preferred size of the radio button

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns dividerSize x dividerSize

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the preferred size for the passed in component, This is passed off to the current layoutmanager.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the preferred size of the header.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the preferred size of the table.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

The method is overridden to take into account caret width.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the preferred size for the editor component.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the preferred size to properly display the tree, this is a cover method for getPreferredSize(c, true).

getPreferredSize(JComponent, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the preferred size to represent the tree in c.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getPreferredSize() method.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the preferred size of the specified JFileChooser.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollBarUI

getPreferredSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the preferred size needed to properly render an icon and text.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI

A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer

Returns the preferred size for the Container.

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Overrides JComponent.getPreferredSize to return slightly wider preferred size value.

getPreferredSizeOfComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the width of the passed in Components preferred size.

getPreferredSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.BoxView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.ComponentView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.FieldView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.GlyphView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.ImageView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the preferred span for this view.

getPreferredSpan(int) - Method in class javax.swing.text.IconView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.PasswordView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.PlainView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.View

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the preferred span for this view along an axis.

getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio.ImageWriter

Returns an array of Dimensions indicating the legal size ranges for thumbnail images as they will be encoded in the output file or stream.

getPreferredTileSizes() - Method in class javax.imageio.ImageWriteParam

Returns an array of Dimensions indicating the legal size ranges for tiles as they will be encoded in the output file or stream.

getPreferredValue() - Method in class javax.swing.Spring

Returns the preferred value of this Spring.

getPreferredVerticalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredWidth() - Method in class javax.swing.table.TableColumn

Returns the preferred width of the TableColumn.

getPreferredWidth(Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the preferred width for the passed in region.

getPreferredWidth(Rectangle) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the preferred width and height for the region in visibleRegion.

getPrefix() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since namespaces are not supported.

getPrefix(int) - Method in class javax.naming.CompositeName

Creates a composite name whose components consist of a prefix of the components in this composite name.

getPrefix(int) - Method in class javax.naming.CompoundName

Creates a compound name whose components consist of a prefix of the components in this compound name.

getPrefix(int) - Method in class javax.naming.ldap.LdapName

Creates a name whose components consist of a prefix of the components of this LDAP name.

getPrefix(int) - Method in interface javax.naming.Name

Creates a name whose components consist of a prefix of the components of this name.

getPrefix(String) - Method in interface javax.xml.namespace.NamespaceContext

Get prefix bound to Namespace URI in the current scope.

getPrefix() - Method in class javax.xml.namespace.QName

Get the prefix of this QName.

getPrefix() - Method in interface javax.xml.soap.Name

Returns the prefix that was specified when this Name object was initialized.

getPrefix() - Method in interface javax.xml.stream.events.Namespace

Gets the prefix, returns "" if this is a default namespace declaration.

getPrefix() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPrefix(String) - Method in interface javax.xml.stream.XMLEventWriter

Gets the prefix the uri is bound to

getPrefix() - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix of the current event or null if the event does not have a prefix

getPrefix(String) - Method in interface javax.xml.stream.XMLStreamWriter

Gets the prefix the uri is bound to

getPrefix() - Method in interface org.w3c.dom.Node

The namespace prefix of this node, or null if it is unspecified.

getPrefix(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Return one of the prefixes mapped to a Namespace URI.

getPrefixes(String) - Method in interface javax.xml.namespace.NamespaceContext

Get all prefixes bound to a Namespace URI in the current scope.

getPrefixes() - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes whose declarations are active in the current context.

getPrefixes(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.

getPrefixList() - Method in class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec

Returns the inclusive namespace prefix list.

getPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of this edit suitable for use in, say, a change log.

getPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

This default implementation returns "".

getPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getPresentationName from the last UndoableEdit added to edits.

getPresentationName() - Method in class javax.swing.undo.StateEdit

Gets the presentation name for this edit

getPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.

getPreservesUnknownTags() - Method in class javax.swing.text.html.HTMLDocument

Returns the behavior the parser observes when encountering unknown tags.

getPressedIcon() - Method in class javax.swing.AbstractButton

Returns the pressed icon for the button.

getPreviewPanel() - Static method in class javax.swing.colorchooser.ColorChooserComponentFactory

getPreviewPanel() - Method in class javax.swing.JColorChooser

Returns the preview panel that shows a chosen color.

getPreviousBounds(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager

Gets the normal bounds of the component prior to the component being maximized.

getPreviousLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the leaf before this node or null if this node is the first leaf in the tree.

getPreviousNode() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the node that precedes this node in a preorder traversal of this node's tree.

getPreviousRowCount() - Method in class javax.swing.event.RowSorterEvent

Returns the number of rows before the sort.

getPreviousSibling() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the previous sibling of this node, or null if this node has no previous sibling.

getPreviousSibling() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the previous sibling of this node in the parent's children array.

getPreviousSibling() - Method in interface org.w3c.dom.Node

The node immediately preceding this node.

getPreviousTabIndex(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousTabRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousValue() - Method in class javax.swing.JSpinner

Returns the object in the sequence that comes before the object returned by getValue().

getPreviousValue() - Method in class javax.swing.SpinnerDateModel

Returns the previous Date in the sequence, or null if the previous date is before start.

getPreviousValue() - Method in class javax.swing.SpinnerListModel

Returns the previous element of the underlying sequence or null if value is already the first element.

getPreviousValue() - Method in interface javax.swing.SpinnerModel

Return the object in the sequence that comes before the object returned by getValue().

getPreviousValue() - Method in class javax.swing.SpinnerNumberModel

Returns the previous number in the sequence.

getPreviousWord(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determine the start of the prev word for the given location.

getPrevValue() - Method in interface org.w3c.dom.events.MutationEvent

prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getPrimary1() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 1 color.

getPrimary1() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 1 color.

getPrimary1() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 1 color.

getPrimary2() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 2 color.

getPrimary2() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 2 color.

getPrimary2() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 2 color.

getPrimary3() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 3 color.

getPrimary3() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 3 color.

getPrimary3() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 3 color.

getPrimaryControl() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control color of the current theme.

getPrimaryControl() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control color.

getPrimaryControlDarkShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control dark shadow color of the current theme.

getPrimaryControlDarkShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control dark shadow color.

getPrimaryControlHighlight() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control highlight color of the current theme.

getPrimaryControlHighlight() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control highlight color.

getPrimaryControlInfo() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control info color of the current theme.

getPrimaryControlInfo() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control info color.

getPrimaryControlShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control shadow color of the current theme.

getPrimaryControlShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control shadow color.

getPrimaryKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given table's primary key columns.

getPrimaryType() - Method in class java.awt.datatransfer.DataFlavor

Returns the primary MIME type for this DataFlavor.

getPrimaryType() - Method in class javax.activation.MimeType

Retrieve the primary type of this object.

getPrime() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime.

getPrimeExponentP() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeExponentP.

getPrimeExponentP() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeExponentP.

getPrimeExponentP() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeExponentP.

getPrimeExponentP() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeExponentP.

getPrimeExponentQ() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeExponentQ.

getPrimeExponentQ() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeExponentQ.

getPrimeExponentQ() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeExponentQ.

getPrimeExponentQ() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeExponentQ.

getPrimeP() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeP.

getPrimeP() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeP.

getPrimeP() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeP.

getPrimeP() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeP.

getPrimeQ() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeQ.

getPrimeQ() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeQ.

getPrimeQ() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeQ.

getPrimeQ() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeQ.

getPrimeSize() - Method in class javax.crypto.spec.DHGenParameterSpec

Returns the size in bits of the prime modulus.

getPrimitiveArrayType(Class<T>) - Static method in class javax.management.openmbean.ArrayType

Create an ArrayType instance in a type-safe manner.

getPrimitiveType(TypeKind) - Method in interface javax.lang.model.util.Types

Returns a primitive type.

getPrincipal() - Method in interface java.security.acl.AclEntry

Returns the principal for which permissions are granted or denied by this ACL entry.

getPrincipal() - Method in interface java.security.Certificate

Deprecated.

Returns the principal of the principal-key pair being guaranteed by the guarantor.

getPrincipal() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the principal that this key belongs to.

getPrincipals() - Method in class java.security.ProtectionDomain

Returns an array of principals for this domain.

getPrincipals() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the Principal classes and names associated with this PrivateCredentialPermission.

getPrincipals() - Method in class javax.security.auth.Subject

Return the Set of Principals associated with this Subject.

getPrincipals(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of Principals associated with this Subject that are instances or subclasses of the specified 类.

getPrintable(int) - Method in class java.awt.print.Book

Returns the Printable instance responsible for rendering the page specified by pageIndex.

getPrintable(int) - Method in interface java.awt.print.Pageable

Returns the Printable instance responsible for rendering the page specified by pageIndex.

getPrintable(JTable.PrintMode, MessageFormat, MessageFormat) - Method in class javax.swing.JTable

Return a Printable for use in printing this JTable.

getPrintable(MessageFormat, MessageFormat) - Method in class javax.swing.text.JTextComponent

Returns a Printable to use for printing the content of this JTextComponent.

getPrintableArea(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the printable area as an array of 4 values in the order x, y, w, h.

getPrintData() - Method in interface javax.print.Doc

Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor.

getPrintData() - Method in class javax.print.SimpleDoc

getPrinter() - Method in class java.awt.JobAttributes

Returns the destination printer for jobs using these attributes.

getPrinterJob() - Method in interface java.awt.print.PrinterGraphics

Returns the PrinterJob that is controlling the current rendering request.

getPrinterJob() - Static method in class java.awt.print.PrinterJob

Creates and returns a PrinterJob which is initially associated with the default printer.

getPrinterResolution() - Method in class java.awt.PageAttributes

Returns the print resolution for pages using these attributes.

getPrintEventType() - Method in class javax.print.event.PrintJobEvent

Gets the reason for this event.

getPrintJob() - Method in interface java.awt.PrintGraphics

Returns the PrintJob object from which this PrintGraphics object originated.

getPrintJob(Frame, String, Properties) - Method in class java.awt.Toolkit

Gets a PrintJob object which is the result of initiating a print operation on the toolkit's platform.

getPrintJob(Frame, String, JobAttributes, PageAttributes) - Method in class java.awt.Toolkit

Gets a PrintJob object which is the result of initiating a print operation on the toolkit's platform.

getPrintJob() - Method in class javax.print.event.PrintJobAttributeEvent

Determine the Print Job to which this print job event pertains.

getPrintJob() - Method in class javax.print.event.PrintJobEvent

Determines the DocPrintJob to which this print job event pertains.

getPrintQuality() - Method in class java.awt.PageAttributes

Returns the print quality for pages using these attributes.

getPrintService() - Method in class java.awt.print.PrinterJob

Returns the service (printer) for this printer job.

getPrintService() - Method in interface javax.print.DocPrintJob

Determines the PrintService object to which this print job object is bound.

getPrintService() - Method in class javax.print.event.PrintServiceAttributeEvent

Returns the print service.

getPrintService(OutputStream) - Method in class javax.print.StreamPrintServiceFactory

Returns a StreamPrintService that can print to the specified output stream.

getPrintServices(DocFlavor, AttributeSet) - Method in class javax.print.PrintServiceLookup

Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.

getPrintServices() - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getPriority() - Method in class java.lang.Thread

Returns this thread's priority.

getPrivacy() - Method in class org.ietf.jgss.MessageProp

Retrieves the privacy state.

getPrivate() - Method in class java.security.KeyPair

Returns a reference to the private key component of this key pair.

getPrivateCredentials() - Method in class javax.security.auth.Subject

Return the Set of private credentials held by this Subject.

getPrivateCredentials(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of private credentials associated with this Subject that are instances or subclasses of the specified 类.

getPrivateExponent() - Method in interface java.security.interfaces.RSAPrivateKey

Returns the private exponent.

getPrivateExponent() - Method in class java.security.spec.RSAPrivateKeySpec

Returns the private exponent.

getPrivateKey() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the PrivateKey from this entry.

getPrivateKey() - Method in class java.security.Signer

Deprecated.

Returns this signer's private key.

getPrivateKey(String) - Method in interface javax.net.ssl.X509KeyManager

Returns the key associated with the given alias.

getPrivateKey() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the PrivateKey.

getPrivateKeyValid() - Method in class java.security.cert.X509CertSelector

Returns the privateKeyValid criterion.

getProblemType() - Method in class javax.management.relation.RoleUnresolved

Retrieves problem type.

getProcedureColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given catalog's stored procedure parameter and result columns.

getProcedures(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the stored procedures available in the given catalog.

getProcedureTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "procedure".

getProcessedDTD() - Method in interface javax.xml.stream.events.DTD

Returns an implementation defined representation of the DTD.

getProfile() - Method in class java.awt.color.ICC_ColorSpace

Returns the ICC_Profile for this ICC_ColorSpace.

getProfileClass() - Method in class java.awt.color.ICC_Profile

Returns the profile class.

getProgram(String...) - Method in interface javax.script.ScriptEngineFactory

Returns A valid scripting language executable progam with given statements.

getProgram() - Method in interface javax.sound.midi.MidiChannel

Obtains the current program number for this channel.

getProgram() - Method in class javax.sound.midi.Patch

Returns the index, within a bank, of the instrument whose location this Patch specifies.

getProgress() - Method in class javax.swing.SwingWorker

Returns the progress bound property.

getProgressBarBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getProgressiveMode() - Method in class javax.imageio.ImageWriteParam

Returns the current mode for writing the stream in a progressive manner.

getProgressMonitor() - Method in class javax.swing.ProgressMonitorInputStream

Get the ProgressMonitor object being used by this stream.

getPrompt() - Method in class javax.security.auth.callback.ChoiceCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.NameCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.PasswordCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.TextInputCallback

Get the prompt.

getPropagatedFrom() - Method in class java.beans.beancontext.BeanContextEvent

Gets the BeanContext from which this event was propagated.

getPropagationId() - Method in class java.beans.PropertyChangeEvent

The "propagationId" field is reserved for future use.

getProperties() - Static method in class java.lang.System

Determines the current system properties.

getProperties() - Method in interface javax.xml.crypto.dsig.SignatureProperties

Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.

getProperties() - Method in class javax.xml.ws.Endpoint

Returns the property bag for this Endpoint instance.

getProperty(String, ImageObserver) - Method in class java.awt.image.BufferedImage

Returns a property of the image by name.

getProperty(String) - Method in class java.awt.image.BufferedImage

Returns a property of the image by name.

getProperty(String, ImageObserver) - Method in class java.awt.Image

Gets a property of this image by name.

getProperty(ParameterBlock, String) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Gets the appropriate instance of the property specified by the name parameter.

getProperty(String) - Method in interface java.awt.image.renderable.RenderableImage

Gets a property from the property set of this image.

getProperty(String) - Method in class java.awt.image.renderable.RenderableImageOp

Gets a property from the property set of this image.

getProperty(String) - Method in interface java.awt.image.RenderedImage

Gets a property from the property set of this image.

getProperty(String, String) - Static method in class java.awt.Toolkit

Gets a property with the specified key and default.

getProperty(String) - Static method in class java.lang.System

Gets the system property indicated by the specified key.

getProperty(String, String) - Static method in class java.lang.System

Gets the system property indicated by the specified key.

getProperty(String) - Method in class java.security.Provider

getProperty(String) - Static method in class java.security.Security

Gets a security property value.

getProperty(String) - Method in class java.util.logging.LogManager

Get the value of a logging property.

getProperty(String) - Method in class java.util.Properties

Searches for the property with the specified key in this property list.

getProperty(String, String) - Method in class java.util.Properties

Searches for the property with the specified key in this property list.

getProperty(String) - Method in class javax.sound.midi.MidiFileFormat

Obtain the property value specified by the key.

getProperty(String) - Method in class javax.sound.sampled.AudioFileFormat

Obtain the property value specified by the key.

getProperty(String) - Method in class javax.sound.sampled.AudioFormat

Obtain the property value specified by the key.

getProperty(Object) - Method in class javax.swing.text.AbstractDocument

A convenience method for looking up a property value.

getProperty(Object) - Method in interface javax.swing.text.Document

Gets the properties associated with the document.

getProperty(String) - Method in class javax.xml.bind.Binder

Get the particular property in the underlying implementation of Binder.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Default implementation of the getProperty method handles the four defined properties in Marshaller.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Default implementation of the getProperty method always throws PropertyException since there are no required properties.

getProperty(String) - Method in interface javax.xml.bind.Marshaller

Get the particular property in the underlying implementation of Marshaller.

getProperty(String) - Method in interface javax.xml.bind.Unmarshaller

Get the particular property in the underlying implementation of Unmarshaller.

getProperty(String) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getProperty(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the object that the specified name maps to.

getProperty(String) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the value of the specified property.

getProperty(String) - Method in class javax.xml.parsers.SAXParser

Returns the particular property requested for in the underlying implementation of XMLReader.

getProperty(String) - Method in class javax.xml.soap.SOAPMessage

Retrieves value of the specified property.

getProperty(String) - Method in class javax.xml.stream.util.EventReaderDelegate

getProperty(String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getProperty(String) - Method in interface javax.xml.stream.XMLEventReader

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.stream.XMLInputFactory

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.stream.XMLOutputFactory

Get a feature/property on the underlying implementation

getProperty(String) - Method in interface javax.xml.stream.XMLStreamReader

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in interface javax.xml.stream.XMLStreamWriter

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.validation.SchemaFactory

Look up the value of a property.

getProperty(String) - Method in class javax.xml.validation.Validator

Look up the value of a property.

getProperty(String) - Method in class javax.xml.validation.ValidatorHandler

Look up the value of a property.

getProperty(String) - Method in class org.xml.sax.helpers.ParserAdapter

Get a parser property.

getProperty(String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Look up the value of a property.

getProperty(String) - Method in interface org.xml.sax.XMLReader

Look up the value of a property.

getPropertyChangeEvent() - Method in exception java.beans.PropertyVetoException

Gets the vetoed PropertyChangeEvent.

getPropertyChangeListeners() - Method in class java.awt.Component

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners(String) - Method in class java.awt.Component

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class java.awt.KeyboardFocusManager

Returns an array of all the property change listeners registered on this keyboard focus manager.

getPropertyChangeListeners(String) - Method in class java.awt.KeyboardFocusManager

Returns an array of all the PropertyChangeListeners associated with the named property.

getPropertyChangeListeners(String) - Method in class java.awt.SystemTray

Returns an array of all the listeners that have been associated with the named property.

getPropertyChangeListeners() - Method in class java.awt.Toolkit

Returns an array of all the property change listeners registered on this toolkit.

getPropertyChangeListeners(String) - Method in class java.awt.Toolkit

Returns an array of all the PropertyChangeListeners associated with the named property.

getPropertyChangeListeners() - Method in class java.beans.PropertyChangeSupport

Returns an array of all the listeners that were added to the PropertyChangeSupport object with addPropertyChangeListener().

getPropertyChangeListeners(String) - Method in class java.beans.PropertyChangeSupport

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class javax.swing.AbstractAction

Returns an array of all the PropertyChangeListeners added to this AbstractAction with addPropertyChangeListener().

getPropertyChangeListeners() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners() - Method in class javax.swing.plaf.LayerUI

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners(String) - Method in class javax.swing.plaf.LayerUI

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class javax.swing.table.TableColumn

Returns an array of all the PropertyChangeListeners added to this TableColumn with addPropertyChangeListener().

getPropertyChangeListeners() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.

getPropertyChangeListeners() - Method in class javax.swing.UIDefaults

Returns an array of all the PropertyChangeListeners added to this UIDefaults with addPropertyChangeListener().

getPropertyChangeListeners() - Static method in class javax.swing.UIManager

Returns an array of all the PropertyChangeListeners added to this UIManager with addPropertyChangeListener().

getPropertyChangeSupport() - Method in class javax.swing.SwingWorker

Returns the PropertyChangeSupport for this SwingWorker.

getPropertyDescriptors() - Method in interface java.beans.BeanInfo

Returns descriptors for all properties of the bean.

getPropertyDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of properties.

getPropertyEditorClass() - Method in class java.beans.PropertyDescriptor

Gets any explicit PropertyEditor Class that has been registered for this property.

getPropertyInfo(String, Properties) - Method in interface java.sql.Driver

Gets information about the possible properties for this driver.

getPropertyName() - Method in class java.beans.PropertyChangeEvent

Gets the programmatic name of the property that was changed.

getPropertyName() - Method in class java.beans.PropertyChangeListenerProxy

Returns the name of the named property associated with the listener.

getPropertyName() - Method in class java.beans.VetoableChangeListenerProxy

Returns the name of the named property associated with the listener.

getPropertyNames() - Method in class java.awt.image.BufferedImage

Returns an array of names recognized by getProperty(String) or null, if no property names are recognized.

getPropertyNames() - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Returns a list of names recognized by getProperty.

getPropertyNames() - Method in interface java.awt.image.renderable.RenderableImage

Returns a list of names recognized by getProperty.

getPropertyNames() - Method in class java.awt.image.renderable.RenderableImageOp

Return a list of names recognized by getProperty.

getPropertyNames() - Method in interface java.awt.image.RenderedImage

Returns an array of names recognized by getProperty(String) or null, if no property names are recognized.

getPropertyOverrides() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's property-override list.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicEditorPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicFormattedTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicMenuUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicToggleButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.metal.MetalCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthFormattedTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthRadioButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthTextPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthToggleButtonUI

getPropertyType() - Method in class java.beans.PropertyDescriptor

Returns the Java type info for the property.

getProtectionDomain() - Method in class java.lang.类

Returns the ProtectionDomain of this class.

getProtectionParameter(String) - Method in class java.security.KeyStore.Builder

Returns the ProtectionParameters that should be used to obtain the Entry with the given alias.

getProtectionParameter() - Method in interface java.security.KeyStore.LoadStoreParameter

Gets the parameter used to protect keystore data.

getProtocol() - Method in class java.net.URL

Gets the protocol name of this URL.

getProtocol() - Method in class javax.management.remote.JMXServiceURL

The protocol part of the Service URL.

getProtocol() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl

getProtocol() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl

getProtocol() - Method in class javax.management.remote.rmi.RMIServerImpl

Returns the protocol string for this object.

getProtocol() - Method in class javax.net.ssl.SSLContext

Returns the protocol name of this SSLContext object.

getProtocol() - Method in interface javax.net.ssl.SSLSession

Returns the standard name of the protocol used for all connections in the session.

getProtocol() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.

getProtocols() - Method in class javax.net.ssl.SSLParameters

Returns a copy of the array of protocols or null if none have been set.

getPrototypeCellValue() - Method in class javax.swing.JList

Returns the "prototypical" cell value -- a value used to calculate a fixed width and height for cells.

getPrototypeDisplayValue() - Method in class javax.swing.JComboBox

Returns the "prototypical display" value - an Object used for the calculation of the display height and width.

getProvider() - Method in class java.security.AlgorithmParameterGenerator

Returns the provider of this algorithm parameter generator object.

getProvider() - Method in class java.security.AlgorithmParameters

Returns the provider of this parameter object.

getProvider() - Method in class java.security.cert.CertificateFactory

Returns the provider of this certificate factory.

getProvider() - Method in class java.security.cert.CertPathBuilder

Returns the provider of this CertPathBuilder.

getProvider() - Method in class java.security.cert.CertPathValidator

Returns the Provider of this CertPathValidator.

getProvider() - Method in class java.security.cert.CertStore

Returns the provider of this CertStore.

getProvider() - Method in class java.security.KeyFactory

Returns the provider of this key factory object.

getProvider() - Method in class java.security.KeyPairGenerator

Returns the provider of this key pair generator object.

getProvider() - Method in class java.security.KeyStore

Returns the provider of this keystore.

getProvider() - Method in class java.security.MessageDigest

Returns the provider of this message digest object.

getProvider() - Method in class java.security.Policy

Return the Provider of this Policy.

getProvider() - Method in class java.security.Provider.Service

Return the Provider of this service.

getProvider() - Method in class java.security.SecureRandom

Returns the provider of this SecureRandom object.

getProvider(String) - Static method in class java.security.Security

Returns the provider installed with the specified name, if any.

getProvider() - Method in class java.security.Signature

Returns the provider of this signature object.

getProvider() - Method in class javax.crypto.Cipher

Returns the provider of this Cipher object.

getProvider() - Method in class javax.crypto.ExemptionMechanism

Returns the provider of this ExemptionMechanism object.

getProvider() - Method in class javax.crypto.KeyAgreement

Returns the provider of this KeyAgreement object.

getProvider() - Method in class javax.crypto.KeyGenerator

Returns the provider of this KeyGenerator object.

getProvider() - Method in class javax.crypto.Mac

Returns the provider of this Mac object.

getProvider() - Method in class javax.crypto.SecretKeyFactory

Returns the provider of this SecretKeyFactory object.

getProvider() - Method in class javax.net.ssl.KeyManagerFactory

Returns the provider of this KeyManagerFactory object.

getProvider() - Method in class javax.net.ssl.SSLContext

Returns the provider of this SSLContext object.

getProvider() - Method in class javax.net.ssl.TrustManagerFactory

Returns the provider of this TrustManagerFactory object.

getProvider() - Method in class javax.security.auth.login.Configuration

Return the Provider of this Configuration.

getProvider() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns the provider of this KeyInfoFactory.

getProvider() - Method in class javax.xml.crypto.dsig.TransformService

Returns the provider of this TransformService.

getProvider() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns the provider of this XMLSignatureFactory.

getProviderGrade() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a constant indicating the grade of synchronization a RowSet object can expect from this SyncProvider object.

getProviderID() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the unique identifier for this SyncProvider object.

getProviders() - Static method in class java.security.Security

Returns an array containing all the installed providers.

getProviders(String) - Static method in class java.security.Security

Returns an array containing all installed providers that satisfy the specified selection criterion, or null if no such providers have been installed.

getProviders(Map<String, String>) - Static method in class java.security.Security

Returns an array containing all installed providers that satisfy the specified* selection criteria, or null if no such providers have been installed.

getProxyClass(ClassLoader, Class<?>...) - Static method in class java.lang.reflect.Proxy

Returns the java.lang.Class object for a proxy class given a class loader and an array of interfaces.

getPseudoColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the pseudo or hidden columns available in a given table within the specified catalog and schema.

getPSName() - Method in class java.awt.Font

Returns the postscript name of this Font.

getPSource() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the source of encoding input P.

getPublic() - Method in class java.security.KeyPair

Returns a reference to the public key component of this key pair.

getPublicCredentials() - Method in class javax.security.auth.Subject

Return the Set of public credentials held by this Subject.

getPublicCredentials(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of public credentials associated with this Subject that are instances or subclasses of the specified 类.

getPublicExponent() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the public exponent.

getPublicExponent() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the public exponent.

getPublicExponent() - Method in interface java.security.interfaces.RSAPublicKey

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAKeyGenParameterSpec

Returns the public-exponent value.

getPublicExponent() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAPublicKeySpec

Returns the public exponent.

getPublicId() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's public identifier, or null if none was given

getPublicId() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation's public identifier, or null if none was given.

getPublicId() - Method in interface javax.xml.stream.Location

Returns the public ID of the XML

getPublicId() - Method in interface javax.xml.transform.SourceLocator

Return the public identifier for the current document event.

getPublicId() - Method in class javax.xml.transform.stream.StreamSource

Get the public identifier that was set with setPublicId.

getPublicId() - Method in interface org.w3c.dom.DocumentType

The public identifier of the external subset.

getPublicId() - Method in interface org.w3c.dom.Entity

The public identifier associated with the entity if specified, and null otherwise.

getPublicId() - Method in interface org.w3c.dom.ls.LSInput

The public identifier for this input source.

getPublicId() - Method in interface org.w3c.dom.Notation

The public identifier of this notation.

getPublicId() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved public identifier.

getPublicId() - Method in class org.xml.sax.InputSource

Get the public identifier for this input source.

getPublicId() - Method in interface org.xml.sax.Locator

Return the public identifier for the current document event.

getPublicId() - Method in exception org.xml.sax.SAXParseException

Get the public identifier of the entity where the exception occurred.

getPublicKey() - Method in class java.security.cert.Certificate

Gets the public key from this certificate.

getPublicKey() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the public key of the subject (target) of the certification path, including any inherited public key parameters if applicable.

getPublicKey() - Method in interface java.security.Certificate

Deprecated.

Returns the key of the principal-key pair being guaranteed by the guarantor.

getPublicKey() - Method in class java.security.Identity

Deprecated.

Returns this identity's public key.

getPublicKey() - Method in class javax.security.cert.Certificate

Gets the public key from this certificate.

getPublicKey() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyValue

Returns the public key of this KeyValue.

getPurgeFlag() - Method in class javax.management.relation.RelationService

Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

getPurgeFlag() - Method in interface javax.management.relation.RelationServiceMBean

Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

getPushLevel() - Method in class java.util.logging.MemoryHandler

Get the pushLevel.

getQ() - Method in interface java.security.interfaces.DSAParams

Returns the subprime, q.

getQ() - Method in class java.security.spec.DSAParameterSpec

Returns the sub-prime q.

getQ() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the sub-prime q.

getQ() - Method in class java.security.spec.DSAPublicKeySpec

Returns the sub-prime q.

getQName(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's XML qualified (prefixed) name by index.

getQName(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's qualified (prefixed) name.

getQOP() - Method in class org.ietf.jgss.MessageProp

Retrieves the QOP value.

getQTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of quantization tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getQTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of quantization tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getQuadrantRotateInstance(int) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates by the specified number of quadrants.

getQuadrantRotateInstance(int, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates by the specified number of quadrants around the specified anchor point.

getQualifiedName() - Method in interface javax.lang.model.element.PackageElement

Returns the fully qualified name of this package.

getQualifiedName() - Method in interface javax.lang.model.element.QualifiedNameable

Returns the fully qualified name of an element.

getQualifiedName() - Method in interface javax.lang.model.element.TypeElement

Returns the fully qualified name of this type element.

getQualifiedName() - Method in interface javax.xml.soap.Name

Gets the namespace-qualified name of the XML name that this Name object represents.

getQuery() - Method in class java.net.URI

Returns the decoded query component of this URI.

getQuery() - Method in class java.net.URL

Gets the query part of this URL.

getQueryString() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the query string that is contained in the request URI after the path.

getQueryTimeout() - Method in interface java.sql.Statement

Retrieves the number of seconds the driver will wait for a Statement object to execute.

getQueryTimeout() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of seconds the driver will wait for a query to execute.

getQueryTimeout() - Method in interface javax.sql.RowSet

Retrieves the maximum number of seconds the driver will wait for a statement to execute.

getQueue() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Returns the task queue used by this executor.

getQueue() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the task queue used by this executor.

getQueuedReaderThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire the read lock.

getQueuedSubmissionCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of tasks submitted to this pool that have not yet begun executing.

getQueuedTaskCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the total number of tasks currently held in queues by worker threads (but not including tasks submitted to the pool that have not begun executing).

getQueuedTaskCount() - Static method in class java.util.concurrent.ForkJoinTask

Returns an estimate of the number of tasks that have been forked by the current worker thread but not yet executed.

getQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire.

getQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire.

getQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantLock

Returns a collection containing threads that may be waiting to acquire this lock.

getQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire either the read or write lock.

getQueuedThreads() - Method in class java.util.concurrent.Semaphore

Returns a collection containing threads that may be waiting to acquire.

getQueuedWriterThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire the write lock.

getQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns an estimate of the number of threads waiting to acquire.

getQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns an estimate of the number of threads waiting to acquire.

getQueueLength() - Method in class java.util.concurrent.locks.ReentrantLock

Returns an estimate of the number of threads waiting to acquire this lock.

getQueueLength() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns an estimate of the number of threads waiting to acquire either the read or write lock.

getQueueLength() - Method in class java.util.concurrent.Semaphore

Returns an estimate of the number of threads waiting to acquire.

getRadioButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getRadioButtonIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getRadioButtonIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getRadius() - Method in class java.awt.RadialGradientPaint

Returns the radius of the circle defining the radial gradient.

getRaisedBevelBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getRanges() - Method in class java.awt.font.NumericShaper

Returns an int that ORs together the values for all the ranges that will be shaped.

getRangeSet() - Method in class java.awt.font.NumericShaper

Returns a Set representing all the Unicode ranges in this NumericShaper that will be shaped.

getRaster() - Method in class java.awt.image.BufferedImage

Returns the WritableRaster.

getRaster(int, int, int, int) - Method in interface java.awt.PaintContext

Returns a Raster containing the colors generated for the graphics operation.

getRaster() - Method in class javax.imageio.IIOImage

Returns the currently set Raster, or null if only a RenderedImage is available.

getRawAuthority() - Method in class java.net.URI

Returns the raw authority component of this URI.

getRawContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawContentBytes() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawFragment() - Method in class java.net.URI

Returns the raw fragment component of this URI.

getRawImageType(int) - Method in class javax.imageio.ImageReader

Returns an ImageTypeSpecifier indicating the SampleModel and ColorModel which most closely represents the "raw" internal format of the image.

getRawOffset() - Method in class java.util.SimpleTimeZone

Gets the GMT offset for this time zone.

getRawOffset() - Method in class java.util.TimeZone

Returns the amount of time in milliseconds to add to UTC to get standard time in this time zone.

getRawPath() - Method in class java.net.URI

Returns the raw path component of this URI.

getRawQuery() - Method in class java.net.URI

Returns the raw query component of this URI.

getRawResult() - Method in class java.util.concurrent.ForkJoinTask

Returns the result that would be returned by ForkJoinTask.join(), even if this task completed abnormally, or null if this task is not known to have been completed.

getRawResult() - Method in class java.util.concurrent.RecursiveAction

Always returns null.

getRawResult() - Method in class java.util.concurrent.RecursiveTask

getRawSchemeSpecificPart() - Method in class java.net.URI

Returns the raw scheme-specific part of this URI.

getRawType() - Method in interface java.lang.reflect.ParameterizedType

Returns the Type object representing the class or interface that declared this type.

getRawUserInfo() - Method in class java.net.URI

Returns the raw user-information component of this URI.

getRdn(int) - Method in class javax.naming.ldap.LdapName

Retrieves an RDN of this LDAP name as an Rdn.

getRdns() - Method in class javax.naming.ldap.LdapName

Retrieves the list of relative distinguished names.

getRead() - Method in exception java.sql.DataTruncation

Indicates whether or not the value was truncated on a read.

getReader() - Method in interface javax.script.ScriptContext

Returns a Reader to be used by the script to read input.

getReader() - Method in class javax.script.SimpleScriptContext

Returns a Reader to be used by the script to read input.

getReader(int) - Method in class javax.swing.text.html.HTMLDocument

Fetches the reader for the parser to use when loading the document with HTML.

getReader(int, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument

Returns the reader for the parser to use to load the document with HTML.

getReader() - Method in class javax.xml.transform.stream.StreamSource

Get the character stream that was set with setReader.

getReaderFileSuffixes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the file suffixes associated with the formats understood by the current set of registered readers.

getReaderFormatNames() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the informal format names understood by the current set of registered readers.

getReaderForText(Transferable) - Method in class java.awt.datatransfer.DataFlavor

Gets a Reader for a text flavor, decoded, if necessary, for the expected charset (encoding).

getReaderForText() - Method in interface javax.print.Doc

Obtains a reader for extracting character print data from this doc.

getReaderForText() - Method in class javax.print.SimpleDoc

Obtains a reader for extracting character print data from this doc.

getReaderMIMETypes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the MIME types understood by the current set of registered readers.

getReaderServiceProviderName() - Method in class javax.imageio.spi.ImageTranscoderSpi

Returns the fully qualified class name of an ImageReaderSpi class that generates IIOMetadata objects that may be used as input to this transcoder.

getReadHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of reentrant read holds on this lock by the current thread.

getReadLockCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of read locks held for this lock.

getReadMethod() - Method in class java.beans.PropertyDescriptor

Gets the method that should be used to read the property value.

getReadTimeout() - Method in class java.net.URLConnection

Returns setting for read timeout.

getRealm() - Method in class javax.security.auth.kerberos.KerberosPrincipal

Returns the realm component of this Kerberos principal.

getReason() - Method in exception java.net.HttpRetryException

Returns a string explaining why the http request could not be retried.

getReason() - Method in exception java.net.URISyntaxException

Returns a string explaining why the input string could not be parsed.

getReason() - Method in exception java.nio.file.FileSystemException

Returns the string explaining why the file system operation failed.

getReason() - Method in exception java.nio.file.InvalidPathException

Returns a string explaining why the input string was rejected.

getReason() - Method in exception java.security.cert.CertPathValidatorException

Returns the reason that the validation failed.

getReason() - Method in interface javax.print.URIException

Return the reason for the event.

getReceiveBufferSize() - Method in class java.net.DatagramSocket

Get value of the SO_RCVBUF option for this DatagramSocket, that is the buffer size used by the platform for input on this DatagramSocket.

getReceiveBufferSize() - Method in class java.net.ServerSocket

Gets the value of the SO_RCVBUF option for this ServerSocket, that is the proposed buffer size that will be used for Sockets accepted from this ServerSocket.

getReceiveBufferSize() - Method in class java.net.Socket

Gets the value of the SO_RCVBUF option for this Socket, that is the buffer size used by the platform for input on this Socket.

getReceiver() - Method in interface javax.sound.midi.MidiDevice

Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data.

getReceiver() - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI receiver from an external MIDI port or other default device.

getReceiver() - Method in interface javax.sound.midi.Transmitter

Obtains the current receiver to which this transmitter will deliver MIDI messages.

getReceivers() - Method in interface javax.sound.midi.MidiDevice

Returns all currently active, non-closed receivers connected with this MidiDevice.

getRecursionLimit() - Method in class java.awt.geom.FlatteningPathIterator

Returns the recursion limit of this iterator.

getRed() - Method in class java.awt.Color

Returns the red component in the range 0-255 in the default sRGB space.

getRed(int) - Method in class java.awt.image.ColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.ColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.ComponentColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.ComponentColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.DirectColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.DirectColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.IndexColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRedMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the red color component.

getRedoPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of the redoable form of this edit, e.g.

getRedoPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName.

getRedoPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getRedoPresentationName from the last UndoableEdit added to edits.

getRedoPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example.

getRedoPresentationName() - Method in class javax.swing.undo.UndoManager

Returns a description of the redoable form of this edit.

getReds(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of red color components into the specified array.

getReductionPolynomial() - Method in class java.security.spec.ECFieldF2m

Returns a BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial for polynomial basis or null for normal basis.

getRef() - Method in class java.net.URL

Gets the anchor (also known as the "reference") of this URL.

getRef() - Method in class java.rmi.server.RemoteObject

Returns the remote reference for the remote object.

getRef(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC REF(<structured-type>) parameter as a Ref object in the Java programming language.

getRef(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC REF(<structured-type>) parameter as a Ref object in the Java programming language.

getRef(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Ref object in the Java programming language.

getRef(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Ref object in the Java programming language.

getRefClass(ObjectOutput) - Method in interface java.rmi.server.RemoteRef

Returns the class name of the ref type to be serialized onto the stream 'out'.

getReference() - Method in class java.util.concurrent.atomic.AtomicMarkableReference

Returns the current value of the reference.

getReference() - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current value of the reference.

getReference() - Method in interface javax.naming.Referenceable

Retrieves the Reference of this object.

getReferencedMBeans() - Method in interface javax.management.relation.Relation

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans(String) - Method in class javax.management.relation.RelationService

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans(String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans() - Method in class javax.management.relation.RelationSupport

Retrieves MBeans referenced in the various roles of the relation.

getReferences() - Method in interface javax.xml.crypto.dsig.Manifest

Returns an unmodifiable list of one or more References that are contained in this Manifest.

getReferences() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns an unmodifiable list of one or more References.

getReferralContext() - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using the context's environment and no controls.

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using environment properties and no controls.

getReferralContext(Hashtable<?, ?>, Control[]) - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using request controls and environment properties.

getReferralContext() - Method in exception javax.naming.ReferralException

Retrieves the context at which to continue the method.

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming.ReferralException

Retrieves the context at which to continue the method using environment properties.

getReferralInfo() - Method in exception javax.naming.ReferralException

Retrieves information (such as URLs) related to this referral.

getReferrals() - Method in interface javax.naming.ldap.UnsolicitedNotification

Retrieves the referral(s) sent by the server.

getRefMBeanClassName() - Method in class javax.management.relation.RoleInfo

Returns name of type of MBean expected to be referenced in corresponding role.

getRefreshRate() - Method in class java.awt.DisplayMode

Returns the refresh rate of the display, in hertz.

getRegion() - Method in class javax.swing.plaf.synth.SynthContext

Returns the Region identifying this state.

getRegion(JComponent) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the Region for the JComponent c.

getRegisteredKeyStrokes() - Method in class javax.swing.JComponent

Returns the KeyStrokes that will initiate registered actions.

getRegisteredParties() - Method in class java.util.concurrent.Phaser

Returns the number of parties registered at this phaser.

getRegisteredProviders() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns an Enumeration of currently registered synchronization providers.

getRegistry() - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the the remote object Registry for the local host on the default registry port of 1099.

getRegistry(int) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the the remote object Registry for the local host on the specified port.

getRegistry(String) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the remote object Registry on the specified host on the default registry port of 1099.

getRegistry(String, int) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the remote object Registry on the specified host and port.

getRegistry(String, int, RMIClientSocketFactory) - Static method in class java.rmi.registry.LocateRegistry

Returns a locally created remote reference to the remote object Registry on the specified host and port.

getRejectedExecutionHandler() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the current handler for unexecutable tasks.

getRelatedData() - Method in interface org.w3c.dom.DOMError

The related DOMError.type dependent data if any.

getRelatedException() - Method in interface org.w3c.dom.DOMError

The related platform dependent exception if any.

getRelatedNode() - Method in interface org.w3c.dom.DOMLocator

The node this locator is pointing to, or null if no node is available.

getRelatedNode() - Method in interface org.w3c.dom.events.MutationEvent

relatedNode is used to identify a secondary node related to a mutation event.

getRelatedTarget() - Method in interface org.w3c.dom.events.MouseEvent

Used to identify a secondary EventTarget related to a UI event.

getRelationId() - Method in interface javax.management.relation.Relation

Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

getRelationId() - Method in class javax.management.relation.RelationNotification

Returns the relation identifier of created/removed/updated relation.

getRelationId() - Method in class javax.management.relation.RelationSupport

Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

getRelationServiceName() - Method in interface javax.management.relation.Relation

Returns ObjectName of the Relation Service handling the relation.

getRelationServiceName() - Method in class javax.management.relation.RelationSupport

Returns ObjectName of the Relation Service handling the relation.

getRelationTypeName() - Method in interface javax.management.relation.Relation

Returns name of associated relation type.

getRelationTypeName() - Method in class javax.management.relation.RelationNotification

Returns the relation type name of created/removed/updated relation.

getRelationTypeName(String) - Method in class javax.management.relation.RelationService

Returns name of associated relation type for given relation.

getRelationTypeName(String) - Method in interface javax.management.relation.RelationServiceMBean

Returns name of associated relation type for given relation.

getRelationTypeName() - Method in class javax.management.relation.RelationSupport

Returns name of associated relation type.

getRelationTypeName() - Method in interface javax.management.relation.RelationType

Returns the relation type name.

getRelationTypeName() - Method in class javax.management.relation.RelationTypeSupport

Returns the relation type name.

getRelay() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the relay attribute for this SOAPHeaderElement

getRemaining() - Method in class java.util.zip.Inflater

Returns the total number of bytes remaining in the input buffer.

getRemainingAcceptLifetime(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.

getRemainingInitLifetime(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.

getRemainingLifetime() - Method in interface org.ietf.jgss.GSSCredential

Returns the remaining lifetime in seconds for a credential.

getRemainingName() - Method in exception javax.naming.NamingException

Retrieves the remaining unresolved portion of the name.

getRemainingName() - Method in class javax.naming.spi.ResolveResult

Retrieves the remaining unresolved portion of the name.

getRemainingNewName() - Method in exception javax.naming.CannotProceedException

Retrieves the "remaining new name" field of this exception, which is used when this exception is thrown during a rename() operation.

getRemoteAddress() - Method in class java.nio.channels.AsynchronousSocketChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class java.nio.channels.DatagramChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class java.nio.channels.SocketChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved address of the remote entity invoking this request.

getRemoteSocketAddress() - Method in class java.net.DatagramSocket

Returns the address of the endpoint this socket is connected to, or null if it is unconnected.

getRemoteSocketAddress() - Method in class java.net.Socket

Returns the address of the endpoint this socket is connected to, or null if it is unconnected.

getRemoveListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to remove event listeners.

getRemoveOnCancelPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether cancelled tasks should be immediately removed from the work queue at time of cancellation.

getRenderableSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a RenderableImage.

getRenderedImage() - Method in class javax.imageio.IIOImage

Returns the currently set RenderedImage, or null if only a Raster is available.

getRenderedSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a RenderedImage.

getRenderer() - Method in class javax.swing.JComboBox

Returns the renderer used to display the selected item in the JComboBox field.

getRenderingHint(RenderingHints.Key) - Method in class java.awt.Graphics2D

Returns the value of a single preference for the rendering algorithms.

getRenderingHints() - Method in class java.awt.Graphics2D

Gets the preferences for the rendering algorithms.

getRenderingHints() - Method in class java.awt.image.AffineTransformOp

Returns the rendering hints used by this transform operation.

getRenderingHints() - Method in class java.awt.image.BandCombineOp

Returns the rendering hints for this operation.

getRenderingHints() - Method in interface java.awt.image.BufferedImageOp

Returns the rendering hints for this operation.

getRenderingHints() - Method in class java.awt.image.ColorConvertOp

Returns the rendering hints used by this op.

getRenderingHints() - Method in class java.awt.image.ConvolveOp

Returns the rendering hints for this op.

getRenderingHints() - Method in class java.awt.image.LookupOp

Returns the rendering hints for this op.

getRenderingHints() - Method in interface java.awt.image.RasterOp

Returns the rendering hints for this RasterOp.

getRenderingHints() - Method in class java.awt.image.renderable.RenderContext

Gets the rendering hints of this RenderContext.

getRenderingHints() - Method in class java.awt.image.RescaleOp

Returns the rendering hints for this op.

getRenewTill() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the latest expiration time for this ticket, including all renewals.

getReorderingAllowed() - Method in class javax.swing.table.JTableHeader

Returns true if the user is allowed to rearrange columns by dragging their headers, false otherwise.

getReplacementText() - Method in interface javax.xml.stream.events.EntityDeclaration

The replacement text of the entity.

getReplayDetState() - Method in interface org.ietf.jgss.GSSContext

Determines if replay detection is enabled for the per-message security services from this context.

getRepresentationClass() - Method in class java.awt.datatransfer.DataFlavor

Returns the 类 which objects supporting this DataFlavor will return when this DataFlavor is requested.

getRepresentationClass() - Method in class javax.activation.ActivationDataFlavor

Return the representation class.

getRepresentationClassName() - Method in class javax.print.DocFlavor

Returns the name of this doc flavor object's representation class.

getRequestBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream from which the request body can be read.

getRequestContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that is used to initialize the message context for request messages.

getRequestControls() - Method in class javax.naming.ldap.InitialLdapContext

getRequestControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the request controls in effect for this context.

getRequestHeader(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the value of the specified request header.

getRequestHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an immutable Map containing the HTTP headers that were included with this request.

getRequestingHost() - Method in class java.net.Authenticator

Gets the hostname of the site or proxy requesting authentication, or null if not available.

getRequestingPort() - Method in class java.net.Authenticator

Gets the port number for the requested connection.

getRequestingPrompt() - Method in class java.net.Authenticator

Gets the prompt string given by the requestor.

getRequestingProtocol() - Method in class java.net.Authenticator

Give the protocol that's requesting the connection.

getRequestingScheme() - Method in class java.net.Authenticator

Gets the scheme of the requestor (the HTTP scheme for an HTTP firewall, for example).

getRequestingSite() - Method in class java.net.Authenticator

Gets the InetAddress of the site requesting authorization, or null if not available.

getRequestingURL() - Method in class java.net.Authenticator

Returns the URL that resulted in this request for authentication.

getRequestMethod() - Method in class java.net.HttpURLConnection

Get the request method.

getRequestMethod() - Method in class javax.xml.ws.spi.http.HttpExchange

Get the HTTP request method

getRequestorType() - Method in class java.net.Authenticator

Returns whether the requestor is a Proxy or a Server.

getRequestProperties() - Method in class java.net.URLConnection

Returns an unmodifiable Map of general request properties for this connection.

getRequestProperty(String) - Method in class java.net.URLConnection

Returns the value of the named general request property for this connection.

getRequestURI() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.

getReshowDelay() - Method in class javax.swing.ToolTipManager

Returns the reshow delay property.

getResizable() - Method in class javax.swing.table.TableColumn

Returns true if the user is allowed to resize the TableColumn's width, false otherwise.

getResizeWeight() - Method in class javax.swing.JSplitPane

Returns the number that determines how extra space is distributed.

getResizeWeight(int) - Method in class javax.swing.text.BoxView

Gets the resize weight.

getResizeWeight(int) - Method in class javax.swing.text.FieldView

Determines the resizability of the view along the given axis.

getResizeWeight(int) - Method in class javax.swing.text.html.BlockView

Gets the resize weight.

getResizeWeight(int) - Method in class javax.swing.text.TableView.TableRow

Determines the resizability of the view along the given axis.

getResizeWeight(int) - Method in class javax.swing.text.View

Determines the resizability of the view along the given axis.

getResizingAllowed() - Method in class javax.swing.table.JTableHeader

Returns true if the user is allowed to resize columns by dragging between their headers, false otherwise.

getResizingColumn() - Method in class javax.swing.table.JTableHeader

Returns the resizing column.

getResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Get this resolution attribute's resolution values in the given units.

getResolution() - Method in class javax.sound.midi.MidiFileFormat

Obtains the timing resolution for the MIDI file.

getResolution() - Method in class javax.sound.midi.Sequence

Obtains the timing resolution for this sequence.

getResolvedName() - Method in exception javax.naming.NamingException

Retrieves the leading portion of the name that was resolved successfully.

getResolvedObj() - Method in exception javax.naming.NamingException

Retrieves the object to which resolution was successful.

getResolvedObj() - Method in class javax.naming.spi.ResolveResult

Retrieves the Object to which resolution was successful.

getResolveParent() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the resolving parent.

getResolveParent() - Method in interface javax.swing.text.AttributeSet

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.html.HTMLDocument.BlockElement

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.html.HTMLDocument.RunElement

Gets the resolving parent.

getResolveParent() - Method in interface javax.swing.text.Keymap

Fetches the parent keymap used to resolve key-bindings.

getResolveParent() - Method in class javax.swing.text.SimpleAttributeSet

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets attributes from the parent.

getResolveParent() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

If not overriden, the resolving parent defaults to the parent element.

getResource(String, BeanContextChild) - Method in interface java.beans.beancontext.BeanContext

Analagous to java.lang.ClassLoader.getResource(), this method allows a BeanContext implementation to interpose behavior between the child Component and underlying ClassLoader.

getResource(String, BeanContextChild) - Method in class java.beans.beancontext.BeanContextSupport

getResource(String) - Method in class java.lang.类

Finds a resource with a given name.

getResource(String) - Method in class java.lang.ClassLoader

Finds the resource with the given name.

getResource(JavaFileManager.Location, CharSequence, CharSequence) - Method in interface javax.annotation.processing.Filer

Returns an object for reading an existing resource.

getResource(String) - Method in interface javax.management.loading.MLetMBean

Finds the resource with the given name.

getResourceAsStream(String, BeanContextChild) - Method in interface java.beans.beancontext.BeanContext

Analagous to java.lang.ClassLoader.getResourceAsStream(), this method allows a BeanContext implementation to interpose behavior between the child Component and underlying ClassLoader.

getResourceAsStream(String, BeanContextChild) - Method in class java.beans.beancontext.BeanContextSupport

getResourceAsStream(String) - Method in class java.lang.类

Finds a resource with a given name.

getResourceAsStream(String) - Method in class java.lang.ClassLoader

Returns an input stream for reading the specified resource.

getResourceAsStream(String) - Method in class java.net.URLClassLoader

Returns an input stream for reading the specified resource.

getResourceAsStream(String) - Method in interface javax.management.loading.MLetMBean

Returns an input stream for reading the specified resource.

getResourceBaseName() - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns the currently set base name for locating ResourceBundles.

getResourceBundle() - Method in class java.util.logging.Logger

Retrieve the localization resource bundle for this logger for the current default locale.

getResourceBundle() - Method in class java.util.logging.LogRecord

Get the localization resource bundle

getResourceBundleName() - Method in class java.util.logging.Level

Return the level's localization resource bundle name, or null if no localization bundle is defined.

getResourceBundleName() - Method in class java.util.logging.Logger

Retrieve the localization resource bundle name for this logger.

getResourceBundleName() - Method in class java.util.logging.LogRecord

Get the localization resource bundle name

getResourceResolver() - Method in class javax.xml.validation.SchemaFactory

Gets the current LSResourceResolver set to this SchemaFactory.

getResourceResolver() - Method in class javax.xml.validation.Validator

Gets the current LSResourceResolver set to this Validator.

getResourceResolver() - Method in class javax.xml.validation.ValidatorHandler

Gets the current LSResourceResolver set to this ValidatorHandler.

getResources(String) - Method in class java.lang.ClassLoader

Finds all the resources with the given name.

getResources(String) - Method in interface javax.management.loading.MLetMBean

Finds all the resources with the given name.

getResources() - Method in interface javax.sound.midi.Soundbank

Extracts a list of non-Instrument resources contained in the sound bank.

getResponseBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream to which the response body must be written.

getResponseCode() - Method in class java.net.HttpURLConnection

Gets the status code from an HTTP response message.

getResponseContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that resulted from processing a response message.

getResponseControls() - Method in class javax.naming.ldap.InitialLdapContext

getResponseControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the response controls produced as a result of the last method invoked on this context.

getResponseHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.

getResponseMessage() - Method in class java.net.HttpURLConnection

Gets the HTTP response message, if any, returned along with the response code from a server.

getResponses() - Method in class javax.xml.ws.soap.AddressingFeature

If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

getRestartMode() - Method in class java.rmi.activation.ActivationDesc

Returns the "restart" mode of the object associated with this activation descriptor.

getResult() - Method in interface javax.xml.bind.UnmarshallerHandler

Obtains the unmarshalled result.

getResult() - Method in class javax.xml.bind.util.JAXBResult

Gets the unmarshalled object created by the transformation.

getResult() - Method in class javax.xml.soap.SAAJResult

getResultCode() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the LDAP result code of the sort operation.

getResultSet() - Method in interface java.sql.Array

Retrieves a result set that contains the elements of the SQL ARRAY value designated by this Array object.

getResultSet(Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves a result set that contains the elements of the SQL ARRAY value designated by this Array object.

getResultSet(long, int) - Method in interface java.sql.Array

Retrieves a result set holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet(long, int, Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves a result set holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet() - Method in interface java.sql.Statement

Retrieves the current result as a ResultSet object.

getResultSet(long, int) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object that contains all of the elements of the SQL ARRAY value represented by this SerialArray object.

getResultSet() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object that contains all of the elements in the ARRAY value that this SerialArray object represents.

getResultSet(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a result set holding the elements of the subarray that starts at Retrieves a ResultSet object that contains a subarray of the elements in this SerialArray object, starting at index index and containing up to count successive elements.

getResultSetConcurrency() - Method in interface java.sql.Statement

Retrieves the result set concurrency for ResultSet objects generated by this Statement object.

getResultSetHoldability() - Method in interface java.sql.DatabaseMetaData

Retrieves this database's default holdability for ResultSet objects.

getResultSetHoldability() - Method in interface java.sql.Statement

Retrieves the result set holdability for ResultSet objects generated by this Statement object.

getResultSetType() - Method in interface java.sql.Statement

Retrieves the result set type for ResultSet objects generated by this Statement object.

getResultSize() - Method in class javax.naming.ldap.PagedResultsResponseControl

Retrieves (an estimate of) the number of entries in the search result.

getResultStream(boolean) - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getReturningAttributes() - Method in class javax.naming.directory.SearchControls

Retrieves the attributes that will be returned as part of the search.

getReturningObjFlag() - Method in class javax.naming.directory.SearchControls

Determines whether objects will be returned as part of the result.

getReturnOpenType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReturnOpenType() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport

Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReturnType() - Method in class java.lang.reflect.方法

Returns a 类 object that represents the formal return type of the method represented by this Method object.

getReturnType() - Method in interface javax.lang.model.element.ExecutableElement

Returns the return type of this executable.

getReturnType() - Method in interface javax.lang.model.type.ExecutableType

Returns the return type of this executable.

getReturnType() - Method in class javax.management.MBeanOperationInfo

Returns the type of the method's return value.

getReturnType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReuseAddress() - Method in class java.net.DatagramSocket

Tests if SO_REUSEADDR is enabled.

getReuseAddress() - Method in class java.net.ServerSocket

Tests if SO_REUSEADDR is enabled.

getReuseAddress() - Method in class java.net.Socket

Tests if SO_REUSEADDR is enabled.

getRevocationDate() - Method in exception java.security.cert.CertificateRevokedException

Returns the date on which the certificate was revoked.

getRevocationDate() - Method in class java.security.cert.X509CRLEntry

Gets the revocation date from this X509CRLEntry, the revocationDate.

getRevocationReason() - Method in exception java.security.cert.CertificateRevokedException

Returns the reason the certificate was revoked.

getRevocationReason() - Method in class java.security.cert.X509CRLEntry

Returns the reason the certificate has been revoked, as specified in the Reason Code extension of this CRL entry.

getRevokedCertificate(BigInteger) - Method in class java.security.cert.X509CRL

Gets the CRL entry, if any, with the given certificate serialNumber.

getRevokedCertificate(X509Certificate) - Method in class java.security.cert.X509CRL

Get the CRL entry, if any, for the given certificate.

getRevokedCertificates() - Method in class java.security.cert.X509CRL

Gets all the entries from this CRL.

getRGB() - Method in class java.awt.Color

Returns the RGB value representing the color in the default sRGB ColorModel.

getRGB(int, int) - Method in class java.awt.image.BufferedImage

Returns an integer pixel in the default RGB color model (TYPE_INT_ARGB) and default sRGB colorspace.

getRGB(int, int, int, int, int[], int, int) - Method in class java.awt.image.BufferedImage

Returns an array of integer pixels in the default RGB color model (TYPE_INT_ARGB) and default sRGB color space, from a portion of the image data.

getRGB(int) - Method in class java.awt.image.ColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.ColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.ComponentColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.ComponentColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.DirectColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.DirectColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.IndexColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGBColorComponents(float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color, in the default sRGB color space.

getRGBComponents(float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, as represented in the default sRGB color space.

getRGBdefault() - Static method in class java.awt.image.ColorModel

Returns a DirectColorModel that describes the default format for integer RGB values used in many of the methods in the AWT image interfaces for the convenience of the programmer.

getRGBs(int[]) - Method in class java.awt.image.IndexColorModel

Converts data for each index from the color and alpha component arrays to an int in the default RGB ColorModel format and copies the resulting 32-bit ARGB values into the specified array.

getRightChildIndent() - Method in class javax.swing.plaf.basic.BasicTreeUI

getRightComponent() - Method in class javax.swing.JSplitPane

Returns the component to the right (or below) the divider.

getRightIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the right indent setting.

getRightInset() - Method in class javax.swing.text.AsyncBoxView

Get the right part of the margin around the view.

getRightInset() - Method in class javax.swing.text.CompositeView

Gets the right inset.

getRMIRepositoryID(Class) - Method in interface javax.rmi.CORBA.ValueHandler

Returns the CORBA RepositoryId for the given Java class.

getRole(String) - Method in interface javax.management.relation.Relation

Retrieves role value for given role name.

getRole(String, String) - Method in class javax.management.relation.RelationService

Retrieves role value for given role name in given relation.

getRole(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves role value for given role name in given relation.

getRole(String) - Method in class javax.management.relation.RelationSupport

Retrieves role value for given role name.

getRole() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the value of the Role attribute of this SOAPHeaderElement.

getRoleCardinality(String) - Method in interface javax.management.relation.Relation

Returns the number of MBeans currently referenced in the given role.

getRoleCardinality(String, String) - Method in class javax.management.relation.RelationService

Retrieves the number of MBeans currently referenced in the given role.

getRoleCardinality(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves the number of MBeans currently referenced in the given role.

getRoleCardinality(String) - Method in class javax.management.relation.RelationSupport

Returns the number of MBeans currently referenced in the given role.

getRoleInfo(String, String) - Method in class javax.management.relation.RelationService

Retrieves role info for given role name of a given relation type.

getRoleInfo(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves role info for given role of a given relation type.

getRoleInfo(String) - Method in interface javax.management.relation.RelationType

Returns the role info (RoleInfo object) for the given role info name (null if not found).

getRoleInfo(String) - Method in class javax.management.relation.RelationTypeSupport

Returns the role info (RoleInfo object) for the given role info name (null if not found).

getRoleInfos(String) - Method in class javax.management.relation.RelationService

Retrieves list of role infos (RoleInfo objects) of a given relation type.

getRoleInfos(String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves list of role infos (RoleInfo objects) of a given relation type.

getRoleInfos() - Method in interface javax.management.relation.RelationType

Returns the list of role definitions (ArrayList of RoleInfo objects).

getRoleInfos() - Method in class javax.management.relation.RelationTypeSupport

Returns the list of role definitions (ArrayList of RoleInfo objects).

getRoleName() - Method in class javax.management.relation.RelationNotification

Returns name of updated role of updated relation (only for role update).

getRoleName() - Method in class javax.management.relation.Role

Retrieves role name.

getRoleName() - Method in class javax.management.relation.RoleUnresolved

Retrieves role name.

getRoles(String[]) - Method in interface javax.management.relation.Relation

Retrieves values of roles with given names.

getRoles(String, String[]) - Method in class javax.management.relation.RelationService

Retrieves values of roles with given names in given relation.

getRoles(String, String[]) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves values of roles with given names in given relation.

getRoles(String[]) - Method in class javax.management.relation.RelationSupport

Retrieves values of roles with given names.

getRoles() - Method in class javax.management.relation.RoleResult

Retrieves list of roles successfully accessed.

getRoles() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAP actor roles associated with an execution of the handler chain.

getRoles() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the roles played by the SOAP binding instance.

getRolesUnresolved() - Method in class javax.management.relation.RoleResult

Retrieves list of roles unsuccessfully accessed.

getRoleValue() - Method in class javax.management.relation.Role

Retrieves role value.

getRoleValue() - Method in class javax.management.relation.RoleUnresolved

Retrieves role value.

getRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Returns a rollover border for the button.

getRolloverColumn() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Returns the index of the column header over which the mouse currently is.

getRolloverIcon() - Method in class javax.swing.AbstractButton

Returns the rollover icon for the button.

getRolloverSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the rollover selection icon for the button.

getRolloverTab() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the tab the mouse is currently over, or -1 if the mouse is no longer over any tab.

getRoot() - Method in interface java.nio.file.Path

Returns the root component of this path as a Path object, or null if this path does not have a root component.

getRoot() - Method in class java.util.concurrent.Phaser

Returns the root ancestor of this phaser, which is the same as this phaser if it has no parent.

getRoot(Component) - Static method in class javax.swing.SwingUtilities

Returns the root component for the current component tree.

getRoot() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the root of the tree that contains this node.

getRoot() - Method in class javax.swing.tree.DefaultTreeModel

Returns the root of the tree.

getRoot() - Method in interface javax.swing.tree.TreeModel

Returns the root of the tree.

getRootCause() - Method in exception javax.naming.NamingException

Retrieves the root cause of this NamingException, if any.

getRootDirectories() - Method in class java.nio.file.FileSystem

Returns an object to iterate over the paths of the root directories.

getRootElement() - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer

Gets the root element.

getRootElements() - Method in interface javax.annotation.processing.RoundEnvironment

Returns the root elements for annotation processing generated by the prior round.

getRootElements() - Method in class javax.swing.text.AbstractDocument

Gets all root elements defined.

getRootElements() - Method in interface javax.swing.text.Document

Returns all of the root elements that are defined.

getRootFrame() - Static method in class javax.swing.JOptionPane

Returns the Frame to use for the class methods in which a frame is not provided.

getRootName() - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the name of the root element of the format.

getRootName() - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getRootPane() - Method in class javax.swing.JApplet

Returns the rootPane object for this applet.

getRootPane() - Method in class javax.swing.JComponent

Returns the JRootPane ancestor for this component.

getRootPane() - Method in class javax.swing.JDialog

Returns the rootPane object for this dialog.

getRootPane() - Method in class javax.swing.JFrame

Returns the rootPane object for this frame.

getRootPane() - Method in class javax.swing.JInternalFrame

Returns the rootPane object for this internal frame.

getRootPane() - Method in class javax.swing.JWindow

Returns the rootPane object for this window.

getRootPane() - Method in interface javax.swing.RootPaneContainer

Return this component's single JRootPane child.

getRootPane(Component) - Static method in class javax.swing.SwingUtilities

If c is a JRootPane descendant return its JRootPane ancestor.

getRoots() - Method in class javax.swing.filechooser.FileSystemView

Returns all root partitions on this system.

getRootView(JTextComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches a View with the allocation of the associated text component (i.e.

getRootView(JTextComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getRootView method on each UI handled by this object.

getRootView(JTextComponent) - Method in class javax.swing.plaf.TextUI

Fetches a View with the allocation of the associated text component (i.e.

getRotateInstance(double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a rotation transformation.

getRotateInstance(double, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates around an anchor point.

getRotateInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates according to a rotation vector.

getRotateInstance(double, double, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates around an anchor point accordinate to a rotation vector.

getRoundedCorners() - Method in class javax.swing.border.LineBorder

Returns whether this border will be drawn with rounded corners.

getRoundingMode() - Method in class java.math.MathContext

Returns the roundingMode setting.

getRoundingMode() - Method in class java.text.DecimalFormat

Gets the RoundingMode used in this DecimalFormat.

getRoundingMode() - Method in class java.text.NumberFormat

Gets the RoundingMode used in this NumberFormat.

getRounds() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the number of rounds.

getRow() - Method in interface java.sql.ResultSet

Retrieves the current row number.

getRow() - Method in class javax.swing.JTable.DropLocation

Returns the row index where a dropped item should be placed in the table.

getRowBounds(int) - Method in class javax.swing.JTree

Returns the Rectangle that the node at the specified row is drawn in.

getRowCount() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the number of rows in the model.

getRowCount() - Method in class javax.swing.JTable

Returns the number of rows that can be shown in the JTable, given unlimited space.

getRowCount() - Method in class javax.swing.JTree

Returns the number of viewable nodes.

getRowCount(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the number of rows that are being displayed.

getRowCount(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getRowCount method on each UI handled by this object.

getRowCount(JTree) - Method in class javax.swing.plaf.TreeUI

Returns the number of rows that are being displayed.

getRowCount() - Method in class javax.swing.table.DefaultTableModel

Returns the number of rows in this data table.

getRowCount() - Method in interface javax.swing.table.TableModel

Returns the number of rows in the model.

getRowCount() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the number of rows this cell spans (that is, the grid height).

getRowCount() - Method in class javax.swing.tree.AbstractLayoutCache

Number of rows being displayed.

getRowCount() - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the number of visible rows.

getRowCount() - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the number of visible rows.

getRowEnd(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the ending row model position of the row that contains the specified model position.

getRowFilter() - Method in class javax.swing.DefaultRowSorter

Returns the filter that determines which rows, if any, should be hidden from view.

getRowForLocation(int, int) - Method in class javax.swing.JTree

Returns the row for the specified location.

getRowForPath(TreePath) - Method in class javax.swing.JTree

Returns the row that displays the node identified by the specified path.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the row that the last item identified in path is visible at.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getRowForPath method on each UI handled by this object.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.TreeUI

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the row where the last item identified in path is visible.

getRowHeader() - Method in class javax.swing.JScrollPane

Returns the row header.

getRowHeader() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that is the row header.

getRowHeight() - Method in class javax.swing.JTable

Returns the height of a table row, in pixels.

getRowHeight(int) - Method in class javax.swing.JTable

Returns the height, in pixels, of the cells in row.

getRowHeight() - Method in class javax.swing.JTextArea

Defines the meaning of the height of a row.

getRowHeight() - Method in class javax.swing.JTree

Returns the height of each row.

getRowHeight(int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the height of the specified row based on the current layout.

getRowHeight() - Method in class javax.swing.plaf.basic.BasicTreeUI

getRowHeight() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the height of each row.

getRowId(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ROWID parameter as a java.sql.RowId object.

getRowId(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ROWID parameter as a java.sql.RowId object.

getRowId(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.RowId object in the Java programming language.

getRowId(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.RowId object in the Java programming language.

getRowIdLifetime() - Method in interface java.sql.DatabaseMetaData

Indicates whether or not this data source supports the SQL ROWID type, and if so the lifetime for which a RowId object remains valid.

getRowMapper() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the RowMapper instance that is able to map a TreePath to a row.

getRowMapper() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the RowMapper instance that is able to map a TreePath to a row.

getRowMargin() - Method in class javax.swing.JTable

Gets the amount of empty space, in pixels, between cells.

getRows() - Method in class java.awt.GridLayout

Gets the number of rows in this layout.

getRows() - Method in class java.awt.List

Gets the number of visible lines in this list.

getRows() - Method in class java.awt.TextArea

Returns the number of rows in the text area.

getRows() - Method in class javax.swing.JTextArea

Returns the number of rows in the TextArea.

getRowSelectionAllowed() - Method in class javax.swing.JTable

Returns true if rows can be selected.

getRowSetNames() - Method in interface javax.sql.rowset.JoinRowSet

Returns a String array containing the names of the RowSet objects added to this JoinRowSet object.

getRowSetReader() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a javax.sql.RowSetReader object, which can be used to populate a RowSet object with data.

getRowSets() - Method in interface javax.sql.rowset.JoinRowSet

Returns a Collection object containing the RowSet objects that have been added to this JoinRowSet object.

getRowSetWarnings() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves the first warning reported by calls on this RowSet object.

getRowSetWarnings() - Method in interface javax.sql.rowset.JdbcRowSet

Retrieves the first warning reported by calls on this JdbcRowSet object.

getRowSetWriter() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a javax.sql.RowSetWriter object, which can be used to write a RowSet object's data back to the underlying data source.

getRowsForPaths(TreePath[]) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the rows that the TreePath instances in path are being displayed at.

getRowsForPaths(TreePath[]) - Method in interface javax.swing.tree.RowMapper

Returns the rows that the TreePath instances in path are being displayed at.

getRowSorter() - Method in class javax.swing.JTable

Returns the object responsible for sorting.

getRowStart(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the starting row model position of the row that contains the specified model position.

getRowType() - Method in class javax.management.openmbean.TabularType

Returns the type of the row elements of tabular data values described by this TabularType instance.

getRowX(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the location, along the x-axis, to render a particular row at.

getRowX(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

getRowX(int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI

getRSB() - Method in class java.awt.font.GlyphMetrics

Returns the right (bottom) side bearing of the glyph.

getRule() - Method in class java.awt.AlphaComposite

Returns the compositing rule of this AlphaComposite.

getRule(HTML.Tag, Element) - Method in class javax.swing.text.html.StyleSheet

Fetches the style to use to render the given type of HTML tag.

getRule(String) - Method in class javax.swing.text.html.StyleSheet

Fetches the rule that best matches the selector given in string form.

getRules() - Method in class java.text.RuleBasedCollator

Gets the table-based rules for the collation object.

getRunCount() - Method in class java.text.Bidi

Return the number of level runs.

getRunForTab(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getRunLevel(int) - Method in class java.text.Bidi

Return the level of the nth logical run in this line.

getRunLimit() - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to all attributes containing the current character.

getRunLimit(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to the given attribute containing the current character.

getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to the given attributes containing the current character.

getRunLimit(int) - Method in class java.text.Bidi

Return the index of the character past the end of the nth logical run in this line, as an offset from the start of the line.

getRunningThreadCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of worker threads that are not blocked waiting to join tasks or for other managed synchronization.

getRunStart() - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to all attributes containing the current character.

getRunStart(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to the given attribute containing the current character.

getRunStart(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to the given attributes containing the current character.

getRunStart(int) - Method in class java.text.Bidi

Return the index of the character at the start of the nth logical run in this line, as an offset from the start of the line.

getRuntime() - Static method in class java.lang.Runtime

Returns the runtime object associated with the current Java application.

getRunTimeCodeBase() - Method in interface javax.rmi.CORBA.ValueHandler

Returns the CodeBase for this ValueHandler.

getRuntimeMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the runtime system of the Java virtual machine.

getS() - Method in interface java.security.interfaces.ECPrivateKey

Returns the private value S.

getS() - Method in class java.security.spec.ECPrivateKeySpec

Returns the private value S.

getSalt() - Method in interface javax.crypto.interfaces.PBEKey

Returns the salt or null if not specified.

getSalt() - Method in class javax.crypto.spec.PBEKeySpec

Returns a copy of the salt or null if not specified.

getSalt() - Method in class javax.crypto.spec.PBEParameterSpec

Returns the salt.

getSaltLength() - Method in class java.security.spec.PSSParameterSpec

Returns the salt length in bits.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns as int the sample in a specified band for the pixel located at (x, y).

getSample(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for the pixel located at (x,y) as an int.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for the pixel located at (x,y) as an int.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleModel() - Method in class java.awt.image.BufferedImage

Returns the SampleModel associated with this BufferedImage.

getSampleModel() - Method in class java.awt.image.Raster

Returns the SampleModel that describes the layout of the image data.

getSampleModel() - Method in interface java.awt.image.RenderedImage

Returns the SampleModel associated with this image.

getSampleModel() - Method in class javax.imageio.ImageTypeSpecifier

Returns a SampleModel based on the settings encapsulated within this object.

getSampleModel(int, int) - Method in class javax.imageio.ImageTypeSpecifier

Returns a SampleModel based on the settings encapsulated within this object.

getSampleModelTranslateX() - Method in class java.awt.image.Raster

Returns the X translation from the coordinate system of the SampleModel to that of the Raster.

getSampleModelTranslateY() - Method in class java.awt.image.Raster

Returns the Y translation from the coordinate system of the SampleModel to that of the Raster.

getSampleRate() - Method in class javax.sound.sampled.AudioFormat

Obtains the sample rate.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the samples in a specified band for the specified rectangle of pixels in an int array, one sample per data array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the samples in a specified band for the specified rectangle of pixels in an int array, one sample per data array element.

getSamples(int, int, int, int, int, int[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSamples(int, int, int, int, int, float[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for the specified rectangle of pixels in a float array, one sample per array element.

getSamples(int, int, int, int, int, double[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for a specified rectangle of pixels in a double array, one sample per array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSamples(int, int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for the specified rectangle of pixels in a float array, one sample per array element.

getSamples(int, int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for a specified rectangle of pixels in a double array, one sample per array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSampleSize() - Method in class java.awt.image.ComponentSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.ComponentSampleModel

Returns the number of bits per sample for the specified band.

getSampleSize() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of bits per sample for the specified band.

getSampleSize() - Method in class java.awt.image.SampleModel

Returns the size in bits of samples for all bands.

getSampleSize(int) - Method in class java.awt.image.SampleModel

Returns the size in bits of samples for the specified band.

getSampleSize() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of bits per sample for the specified band.

getSampleSizeInBits() - Method in class javax.sound.sampled.AudioFormat

Obtains the size of a sample.

getSaslClientFactories() - Static method in class javax.security.sasl.Sasl

Gets an enumeration of known factories for producing SaslClient.

getSaslServerFactories() - Static method in class javax.security.sasl.Sasl

Gets an enumeration of known factories for producing SaslServer.

getSavepointId() - Method in interface java.sql.Savepoint

Retrieves the generated ID for the savepoint that this Savepoint object represents.

getSavepointName() - Method in interface java.sql.Savepoint

Retrieves the name of the savepoint that this Savepoint object represents.

getScale(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's number of digits to right of the decimal point.

getScale(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's number of digits to right of the decimal point.

getScale(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the number of digits to the right of the decimal point for values stored in the designated column.

getScaledInstance(int, int, int) - Method in class java.awt.Image

Creates a scaled version of this image.

getScaledInstance(float, boolean) - Method in class javax.imageio.plugins.jpeg.JPEGQTable

Returns a new quantization table where the values are multiplied by scaleFactor and then clamped to the range 1..32767 (or to 1..255 if forceBaseline is true).

getScaleFactors(float[]) - Method in class java.awt.image.RescaleOp

Returns the scale factors in the given array.

getScaleInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a scaling transformation.

getScaleX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate scaling element (m00) of the 3x3 affine transformation matrix.

getScaleY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate scaling element (m11) of the 3x3 affine transformation matrix.

getScanlineStride() - Method in class java.awt.image.ComponentSampleModel

Returns the scanline stride of this ComponentSampleModel.

getScanlineStride() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the scanline stride.

getScanlineStride() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the scanline stride of this SinglePixelPackedSampleModel.

getSchema() - Method in interface java.sql.Connection

Retrieves this Connection object's current schema name.

getSchema(Name) - Method in interface javax.naming.directory.DirContext

Retrieves the schema associated with the named object.

getSchema(String) - Method in interface javax.naming.directory.DirContext

Retrieves the schema associated with the named object.

getSchema(String) - Method in class javax.naming.directory.InitialDirContext

getSchema(Name) - Method in class javax.naming.directory.InitialDirContext

getSchema() - Method in class javax.xml.bind.Binder

Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.

getSchema() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getSchema() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getSchema() - Method in interface javax.xml.bind.Marshaller

Get the JAXP 1.3 Schema object being used to perform marshal-time validation.

getSchema() - Method in interface javax.xml.bind.Unmarshaller

Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.

getSchema() - Method in class javax.xml.parsers.DocumentBuilder

Get a reference to the the Schema being used by the XML processor.

getSchema() - Method in class javax.xml.parsers.DocumentBuilderFactory

Gets the Schema object specified through the DocumentBuilderFactory.setSchema(Schema schema) method.

getSchema() - Method in class javax.xml.parsers.SAXParser

Get a reference to the the Schema being used by the XML processor.

getSchema() - Method in class javax.xml.parsers.SAXParserFactory

Gets the Schema object specified through the SAXParserFactory.setSchema(Schema schema) method.

getSchemaClassDefinition(Name) - Method in interface javax.naming.directory.DirContext

Retrieves a context containing the schema objects of the named object's class definitions.

getSchemaClassDefinition(String) - Method in interface javax.naming.directory.DirContext

Retrieves a context containing the schema objects of the named object's class definitions.

getSchemaClassDefinition(String) - Method in class javax.naming.directory.InitialDirContext

getSchemaClassDefinition(Name) - Method in class javax.naming.directory.InitialDirContext

getSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current schemaLocation.

getSchemaName(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's table's schema.

getSchemaName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the schema name of the table from which the value in the designated column was derived.

getSchemas() - Method in interface java.sql.DatabaseMetaData

Retrieves the schema names available in this database.

getSchemas(String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves the schema names available in this database.

getSchemaTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "schema".

getSchemaType() - Method in interface javax.xml.stream.events.XMLEvent

This method is provided for implementations to provide optional type information about the associated event.

getSchemaTypeInfo() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getSchemaTypeInfo() - Method in interface org.w3c.dom.Attr

The type information associated with this attribute.

getSchemaTypeInfo() - Method in interface org.w3c.dom.Element

The type information associated with this element.

getScheme() - Method in class java.net.URI

Returns the scheme component of this URI.

getScheme() - Method in class java.nio.file.spi.FileSystemProvider

Returns the URI scheme that identifies this provider.

getScheme() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the name of the scheme used to make this request, for example: http, or https.

getSchemeSpecificPart() - Method in class java.net.URI

Returns the decoded scheme-specific part of this URI.

getScope() - Method in class java.security.Identity

Deprecated.

Returns this identity's scope.

getScope() - Method in class javax.xml.bind.JAXBElement

Returns scope of xml element declaration.

getScope(String) - Method in interface javax.xml.ws.handler.MessageContext

Gets the scope of a property.

getScopedInterface() - Method in class java.net.Inet6Address

Returns the scoped interface, if this instance was created with with a scoped interface.

getScopeId() - Method in class java.net.Inet6Address

Returns the numeric scopeId, if this instance is associated with an interface.

getScopes() - Method in interface javax.script.ScriptContext

Returns immutable List of all the valid values for scope in the ScriptContext.

getScopes() - Method in class javax.script.SimpleScriptContext

Returns immutable List of all the valid values for scope in the ScriptContext.

getScreenDevices() - Method in class java.awt.GraphicsEnvironment

Returns an array of all of the screen GraphicsDevice objects.

getScreenInsets(GraphicsConfiguration) - Method in class java.awt.Toolkit

Gets the insets of the screen.

getScreenResolution() - Method in class java.awt.Toolkit

Returns the screen resolution in dots-per-inch.

getScreenSize() - Method in class java.awt.Toolkit

Gets the size of the screen.

getScreenX() - Method in interface org.w3c.dom.events.MouseEvent

The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

getScreenY() - Method in interface org.w3c.dom.events.MouseEvent

The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

getScript() - Method in class java.util.Locale

Returns the script for this locale, which should either be the empty string or an ISO 15924 4-letter script code.

getScriptContext(Bindings) - Method in class javax.script.AbstractScriptEngine

Returns a SimpleScriptContext.

getScriptEngine() - Method in interface javax.script.ScriptEngineFactory

Returns an instance of the ScriptEngine associated with this ScriptEngineFactory.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JLayer

Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one block of rows or columns, depending on the value of orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JList

Returns the distance to scroll to expose the next or previous block.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JTable

Returns visibleRect.height or visibleRect.width, depending on this table's orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JTree

Returns the amount for a block increment, which is the height or width of visibleRect, based on orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in interface javax.swing.Scrollable

Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.text.JTextComponent

Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

getScrollableTracksViewportHeight() - Method in class javax.swing.JEditorPane

Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.JLayer

Returns false to indicate that the height of the viewport does not determine the height of the layer, unless the preferred height of the layer is smaller than the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.JList

Returns true if this JList is displayed in a JViewport and the viewport is taller than the list's preferred height, or if the layout orientation is VERTICAL_WRAP and visibleRowCount <= 0; otherwise returns false.

getScrollableTracksViewportHeight() - Method in class javax.swing.JTable

Returns false to indicate that the height of the viewport does not determine the height of the table, unless getFillsViewportHeight is true and the preferred height of the table is smaller than the viewport's height.

getScrollableTracksViewportHeight() - Method in class javax.swing.JTree

Returns false to indicate that the height of the viewport does not determine the height of the table, unless the preferred height of the tree is smaller than the viewports height.

getScrollableTracksViewportHeight() - Method in interface javax.swing.Scrollable

Return true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.text.JTextComponent

Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JEditorPane

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JLayer

Returns false to indicate that the width of the viewport does not determine the width of the layer, unless the preferred width of the layer is smaller than the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JList

Returns true if this JList is displayed in a JViewport and the viewport is wider than the list's preferred width, or if the layout orientation is HORIZONTAL_WRAP and visibleRowCount <= 0; otherwise returns false.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTable

Returns false if autoResizeMode is set to AUTO_RESIZE_OFF, which indicates that the width of the viewport does not determine the width of the table.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTextArea

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTree

Returns false to indicate that the width of the viewport does not determine the width of the table, unless the preferred width of the tree is smaller than the viewports width.

getScrollableTracksViewportWidth() - Method in interface javax.swing.Scrollable

Return true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.text.JTextComponent

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JLayer

Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JList

Returns the distance to scroll to expose the next or previous row (for vertical scrolling) or column (for horizontal scrolling).

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTable

Returns the scroll increment (in pixels) that completely exposes one new row or column (depending on the orientation).

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTextArea

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTree

Returns the amount to increment when scrolling.

getScrollableUnitIncrement(Rectangle, int, int) - Method in interface javax.swing.Scrollable

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.text.JTextComponent

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollAmount() - Method in class java.awt.event.MouseWheelEvent

Returns the number of units that should be scrolled per click of mouse wheel rotation.

getScrollbarDisplayPolicy() - Method in class java.awt.ScrollPane

Returns the display policy for the scrollbars.

getScrollbarVisibility() - Method in class java.awt.TextArea

Returns an enumerated value that indicates which scroll bars the text area uses.

getScrollMode() - Method in class javax.swing.JViewport

Returns the current scrolling mode.

getScrollOffset() - Method in class javax.swing.JTextField

Gets the scroll offset, in pixels.

getScrollPane() - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

Returns the JScrollPane housing the JTree, or null if one isn't found.

getScrollPosition() - Method in class java.awt.ScrollPane

Returns the current x,y position within the child which is displayed at the 0,0 location of the scrolled panel's view port.

getScrollsOnExpand() - Method in class javax.swing.JTree

Returns the value of the scrollsOnExpand property.

getScrollType() - Method in class java.awt.event.MouseWheelEvent

Returns the type of scrolling that should take place in response to this event.

getSearchScope() - Method in class javax.naming.directory.SearchControls

Retrieves the search scope of these SearchControls.

getSearchStringEscape() - Method in interface java.sql.DatabaseMetaData

Retrieves the string that can be used to escape wildcard characters.

getSecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return seconds or DatatypeConstants.FIELD_UNDEFINED.

getSecondary1() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 1 color.

getSecondary1() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 1 color.

getSecondary1() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 1 color.

getSecondary2() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 2 color.

getSecondary2() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 2 color.

getSecondary2() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 2 color.

getSecondary3() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 3 color.

getSecondary3() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 3 color.

getSecondary3() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 3 color.

getSeconds() - Method in class java.sql.Date

Deprecated.

getSeconds() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.SECOND).

getSeconds() - Method in class javax.xml.datatype.Duration

Obtains the value of the SECONDS field as an integer value, or 0 if not present.

getSecretKey() - Method in class java.security.KeyStore.SecretKeyEntry

Gets the SecretKey from this entry.

getSecure() - Method in class java.net.HttpCookie

Returns true if sending this cookie should be restricted to a secure protocol, or false if the it can be sent using any protocol.

getSecurityContext() - Method in class java.lang.SecurityManager

Creates an object that encapsulates the current execution environment.

getSecurityContext(ClassLoader) - Method in interface java.rmi.server.LoaderHandler

Deprecated.
no replacement

getSecurityContext(ClassLoader) - Static method in class java.rmi.server.RMIClassLoader

Deprecated.
no replacement. As of the Java 2 platform v1.2, RMI no longer uses this method to obtain a class loader's security context.

getSecurityManager() - Static method in class java.lang.System

Gets the system security interface.

getSeed(int) - Static method in class java.security.SecureRandom

Returns the given number of seed bytes, computed using the seed generation algorithm that this class uses to seed itself.

getSeed() - Method in class java.security.spec.EllipticCurve

Returns the seeding bytes seed used during curve generation.

getSelectColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getSelectColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getSelectColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getSelectedAccessibleColumns() - Method in interface javax.accessibility.AccessibleTable

Returns the selected columns in a table.

getSelectedAccessibleColumns() - Method in class javax.swing.JTable.AccessibleJTable

Returns the selected columns in a table.

getSelectedAccessibleRows() - Method in interface javax.accessibility.AccessibleTable

Returns the selected rows in a table.

getSelectedAccessibleRows() - Method in class javax.swing.JTable.AccessibleJTable

Returns the selected rows in a table.

getSelectedCheckbox() - Method in class java.awt.CheckboxGroup

Gets the current choice from this check box group.

getSelectedColor() - Method in interface javax.swing.colorchooser.ColorSelectionModel

Returns the selected Color which should be non-null.

getSelectedColor() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel

Returns the selected Color which should be non-null.

getSelectedColumn() - Method in class javax.swing.JTable

Returns the index of the first selected column, -1 if no column is selected.

getSelectedColumnCount() - Method in class javax.swing.JTable

Returns the number of selected columns.

getSelectedColumnCount() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the number of columns selected.

getSelectedColumnCount() - Method in interface javax.swing.table.TableColumnModel

Returns the number of selected columns.

getSelectedColumns() - Method in class javax.swing.JTable

Returns the indices of all selected columns.

getSelectedColumns() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of selected columns.

getSelectedColumns() - Method in interface javax.swing.table.TableColumnModel

Returns an array of indicies of all selected columns.

getSelectedComponent() - Method in class javax.swing.JTabbedPane

Returns the currently selected component for this tabbedpane.

getSelectedFile() - Method in class javax.swing.JFileChooser

Returns the selected file.

getSelectedFiles() - Method in class javax.swing.JFileChooser

Returns a list of selected files if the file chooser is set to allow multiple selection.

getSelectedFrame() - Method in class javax.swing.JDesktopPane

Returns the currently active JInternalFrame in this JDesktopPane, or null if no JInternalFrame is currently active.

getSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the selected icon for the button.

getSelectedIndex() - Method in class java.awt.Choice

Returns the index of the currently selected item.

getSelectedIndex() - Method in class java.awt.List

Gets the index of the selected item on the list,

getSelectedIndex() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the selected confirmation option.

getSelectedIndex() - Method in class javax.swing.DefaultSingleSelectionModel

getSelectedIndex() - Method in class javax.swing.JComboBox

Returns the first item in the list that matches the given item.

getSelectedIndex() - Method in class javax.swing.JList

Returns the smallest selected cell index; the selection when only a single item is selected in the list.

getSelectedIndex() - Method in class javax.swing.JTabbedPane

Returns the currently selected index for this tabbedpane.

getSelectedIndex() - Method in interface javax.swing.SingleSelectionModel

Returns the model's selection.

getSelectedIndexes() - Method in class java.awt.List

Gets the selected indexes on the list.

getSelectedIndexes() - Method in class javax.security.auth.callback.ChoiceCallback

Get the selected choices.

getSelectedIndices() - Method in class javax.swing.JList

Returns an array of all of the selected indices, in increasing order.

getSelectedItem() - Method in class java.awt.Choice

Gets a representation of the current choice as a string.

getSelectedItem() - Method in class java.awt.List

Gets the selected item on this scrolling list.

getSelectedItem() - Method in interface javax.swing.ComboBoxModel

Returns the selected item

getSelectedItem() - Method in class javax.swing.DefaultComboBoxModel

getSelectedItem() - Method in class javax.swing.JComboBox

Returns the current selected item.

getSelectedItem() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getSelectedItem() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getSelectedItems() - Method in class java.awt.List

Gets the selected items on this scrolling list.

getSelectedObjects() - Method in class java.awt.Checkbox

Returns an array (length 1) containing the checkbox label or null if the checkbox is not selected.

getSelectedObjects() - Method in class java.awt.CheckboxMenuItem

Returns the an array (length 1) containing the checkbox menu item label or null if the checkbox is not selected.

getSelectedObjects() - Method in class java.awt.Choice

Returns an array (length 1) containing the currently selected item.

getSelectedObjects() - Method in interface java.awt.ItemSelectable

Returns the selected items or null if no items are selected.

getSelectedObjects() - Method in class java.awt.List

Gets the selected items on this scrolling list in an array of Objects.

getSelectedObjects() - Method in class javax.swing.AbstractButton

Returns an array (length 1) containing the label or null if the button is not selected.

getSelectedObjects() - Method in class javax.swing.DefaultButtonModel

Overridden to return null.

getSelectedObjects() - Method in class javax.swing.JCheckBoxMenuItem

Returns an array (length 1) containing the check box menu item label or null if the check box is not selected.

getSelectedObjects() - Method in class javax.swing.JComboBox

Returns an array containing the selected item.

getSelectedPath() - Method in class javax.swing.MenuSelectionManager

Returns the path to the currently selected menu item

getSelectedRow() - Method in class javax.swing.JTable

Returns the index of the first selected row, -1 if no row is selected.

getSelectedRowCount() - Method in class javax.swing.JTable

Returns the number of selected rows.

getSelectedRows() - Method in class javax.swing.JTable

Returns the indices of all selected rows.

getSelectedTabPadInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getSelectedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests

Gets the currently selected text from the text editing component.

getSelectedText() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the portion of the text that is selected.

getSelectedText() - Method in class java.awt.TextComponent

Returns the selected text from the text that is presented by this text component.

getSelectedText() - Method in interface javax.accessibility.AccessibleText

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.text.JTextComponent

Returns the selected text contained in this TextComponent.

getSelectedTextColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the selected text.

getSelectedValue() - Method in class javax.swing.JList

Returns the value for the smallest selected cell index; the selected value when only a single item is selected in the list.

getSelectedValues() - Method in class javax.swing.JList

Deprecated.
As of JDK 1.7, replaced by JList.getSelectedValuesList()

getSelectedValuesList() - Method in class javax.swing.JList

Returns a list of all the selected items, in increasing order based on their indices in the list.

getSelection() - Method in class javax.swing.ButtonGroup

Returns the model of the selected button.

getSelectionBackground() - Method in class javax.swing.JList

Returns the color used to draw the background of selected items.

getSelectionBackground() - Method in class javax.swing.JTable

Returns the background color for selected cells.

getSelectionBackground() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The "selectionBackground" is the color of the text when it is painted over an unfilled area of the progress bar.

getSelectionColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the selection.

getSelectionCount() - Method in class javax.swing.JTree

Returns the number of nodes selected.

getSelectionCount() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the number of paths that are selected.

getSelectionCount() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the number of paths that are selected.

getSelectionEnd() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the end offset within the selected text.

getSelectionEnd() - Method in class java.awt.TextComponent

Gets the end position of the selected text in this text component.

getSelectionEnd() - Method in interface javax.accessibility.AccessibleText

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.text.JTextComponent

Returns the selected text's end position.

getSelectionForeground() - Method in class javax.swing.JList

Returns the color used to draw the foreground of selected items.

getSelectionForeground() - Method in class javax.swing.JTable

Returns the foreground color for selected cells.

getSelectionForeground() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The "selectionForeground" is the color of the text when it is painted over a filled area of the progress bar.

getSelectionMode() - Method in class javax.swing.DefaultListSelectionModel

Returns the current selection mode.

getSelectionMode() - Method in class javax.swing.JList

Returns the current selection mode for the list.

getSelectionMode() - Method in interface javax.swing.ListSelectionModel

Returns the current selection mode.

getSelectionMode() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.

getSelectionMode() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

getSelectionModel() - Method in class javax.swing.JColorChooser

Returns the data model that handles color selections.

getSelectionModel() - Method in class javax.swing.JList

Returns the current selection model.

getSelectionModel() - Method in class javax.swing.JMenuBar

Returns the model object that handles single selections.

getSelectionModel() - Method in class javax.swing.JPopupMenu

Returns the model object that handles single selections.

getSelectionModel() - Method in class javax.swing.JTable

Returns the ListSelectionModel that is used to maintain row selection state.

getSelectionModel() - Method in class javax.swing.JTree

Returns the model for selections.

getSelectionModel() - Method in class javax.swing.plaf.basic.BasicTreeUI

getSelectionModel() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the ListSelectionModel that is used to maintain column selection state.

getSelectionModel() - Method in interface javax.swing.table.TableColumnModel

Returns the current selection model.

getSelectionModel() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the model used to maintain the selection.

getSelectionPainter() - Method in class javax.swing.text.DefaultCaret

Gets the painter for the Highlighter.

getSelectionPath() - Method in class javax.swing.JTree

Returns the path to the first selected node.

getSelectionPath() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the first path in the selection.

getSelectionPath() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the first path in the selection.

getSelectionPaths() - Method in class javax.swing.JTree

Returns the paths of all selected values.

getSelectionPaths() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection.

getSelectionPaths() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the paths in the selection.

getSelectionRows() - Method in class javax.swing.JTree

Returns all of the currently selected rows.

getSelectionRows() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection in terms of rows.

getSelectionRows() - Method in interface javax.swing.tree.TreeSelectionModel

Returns all of the currently selected rows.

getSelectionStart() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the start offset within the selected text.

getSelectionStart() - Method in class java.awt.TextComponent

Gets the start position of the selected text in this text component.

getSelectionStart() - Method in interface javax.accessibility.AccessibleText

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.text.JTextComponent

Returns the selected text's start position.

getSelectionValues() - Method in class javax.swing.JOptionPane

Returns the input selection values.

getSendBufferSize() - Method in class java.net.DatagramSocket

Get value of the SO_SNDBUF option for this DatagramSocket, that is the buffer size used by the platform for output on this DatagramSocket.

getSendBufferSize() - Method in class java.net.Socket

Get value of the SO_SNDBUF option for this Socket, that is the buffer size used by the platform for output on this Socket.

getSendPastNotifications() - Method in class javax.management.timer.Timer

Gets the flag indicating whether or not the timer sends past notifications.

getSendPastNotifications() - Method in interface javax.management.timer.TimerMBean

Gets the flag indicating whether or not the timer sends past notifications.

getSentenceInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for sentence breaks for the default locale.

getSentenceInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for sentence breaks for the given locale.

getSentenceInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for sentence breaks for the given locale.

getSeparator() - Method in class java.nio.file.FileSystem

Returns the name separator, represented as a string.

getSeparatorBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the separator background color of the current theme.

getSeparatorBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the separator background color.

getSeparatorForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the separator foreground color of the current theme.

getSeparatorForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the separator foreground color.

getSeparatorSize() - Method in class javax.swing.JToolBar.Separator

Returns the size of the separator

getSequence(InputStream) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified input stream.

getSequence(URL) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified URL.

getSequence(File) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified File.

getSequence() - Method in interface javax.sound.midi.Sequencer

Obtains the sequence on which the Sequencer is currently operating.

getSequence(InputStream) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the input stream provided.

getSequence(URL) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the URL provided.

getSequence(File) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the File provided.

getSequenceDetState() - Method in interface org.ietf.jgss.GSSContext

Determines if sequence checking is enabled for the per-message security services from this context.

getSequenceNumber() - Method in class java.util.logging.LogRecord

Get the sequence number.

getSequenceNumber() - Method in class javax.management.Notification

Get the notification sequence number.

getSequencer() - Static method in class javax.sound.midi.MidiSystem

Obtains the default Sequencer, connected to a default device.

getSequencer(boolean) - Static method in class javax.sound.midi.MidiSystem

Obtains the default Sequencer, optionally connected to a default device.

getSerializedObject() - Method in class javax.management.loading.MLetContent

Gets the value of the OBJECT attribute of the MLET tag.

getSerialNumber() - Method in class java.security.cert.X509Certificate

Gets the serialNumber value from the certificate.

getSerialNumber() - Method in class java.security.cert.X509CertSelector

Returns the serialNumber criterion.

getSerialNumber() - Method in class java.security.cert.X509CRLEntry

Gets the serial number from this X509CRLEntry, the userCertificate.

getSerialNumber() - Method in class javax.security.cert.X509Certificate

Gets the serialNumber value from the certificate.

getSerialNumber() - Method in interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

Returns the serial number of this X509IssuerSerial.

getSerialVersionUID() - Method in class java.io.ObjectStreamClass

Return the serialVersionUID for this class.

getServer() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the service principal associated with this ticket.

getServerAliases(String, Principal[]) - Method in interface javax.net.ssl.X509KeyManager

Get the matching aliases for authenticating the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

getServerCertificateChain() - Method in class java.net.SecureCacheResponse

Returns the server's certificate chain, which was established as part of defining the session in the original connection that retrieved the network resource, from cache.

getServerCertificates() - Method in class javax.net.ssl.HttpsURLConnection

Returns the server's certificate chain which was established as part of defining the session.

getServerName() - Method in class java.security.cert.LDAPCertStoreParameters

Returns the DNS name of the LDAP server.

getServerSessionContext() - Method in class javax.net.ssl.SSLContext

Returns the server session context, which represents the set of SSL sessions available for use during the handshake phase of server-side SSL sockets.

getServerSocketFactory() - Method in class javax.net.ssl.SSLContext

Returns a ServerSocketFactory object for this context.

getService(BeanContextServices, Object, Class, Object) - Method in interface java.beans.beancontext.BeanContextServiceProvider

Invoked by BeanContextServices, this method requests an instance of a service from this BeanContextServiceProvider.

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - Method in interface java.beans.beancontext.BeanContextServices

A BeanContextChild, or any arbitrary object associated with a BeanContextChild, may obtain a reference to a currently registered service from its nesting BeanContextServices via invocation of this method.

getService(BeanContextServices, Object, Class, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - Method in class java.beans.beancontext.BeanContextServicesSupport

obtain a service which may be delegated

getService(String, String) - Method in class java.security.Provider

Get the service describing this Provider's implementation of the specified type of this algorithm or alias.

getServiceClass() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the service class that is the subject of this notification.

getServiceClass() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent

Gets the service class that is the subject of this notification

getServiceName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL service name containing the port being accessed.

getServiceName() - Method in class javax.xml.ws.Service

Gets the name of this service.

getServiceName() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the name of this service.

getServiceProvider() - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider

getServiceProviderByClass(Class<T>) - Method in class javax.imageio.spi.ServiceRegistry

Returns the currently registered service provider object that is of the given class type.

getServiceProviders(Class<T>, boolean) - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator containing all registered service providers in the given category.

getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean) - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator containing service provider objects within a given category that satisfy a criterion imposed by the supplied ServiceRegistry.Filter object's filter method.

getServices() - Method in class java.security.Provider

Get an unmodifiable Set of all services supported by this Provider.

getServicesBeanInfo() - Method in interface java.beans.beancontext.BeanContextServiceProviderBeanInfo

Gets a BeanInfo array, one for each service class or interface statically available from this ServiceProvider.

getServiceUIFactory() - Method in interface javax.print.PrintService

Returns a factory for UI components which allow users to interact with the service in various roles.

getSession() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the session that triggered this event.

getSession() - Method in class javax.net.ssl.SSLEngine

Returns the SSLSession in use in this SSLEngine.

getSession() - Method in class javax.net.ssl.SSLSessionBindingEvent

Returns the SSLSession into which the listener is being bound or from which the listener is being unbound.

getSession(byte[]) - Method in interface javax.net.ssl.SSLSessionContext

Returns the SSLSession bound to the specified session id.

getSession() - Method in class javax.net.ssl.SSLSocket

Returns the SSL Session in use by this connection.

getSessionCacheSize() - Method in interface javax.net.ssl.SSLSessionContext

Returns the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.

getSessionContext() - Method in interface javax.net.ssl.SSLSession

Returns the context in which this session is bound.

getSessionKey() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the session key associated with this ticket.

getSessionKeyType() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the key type of the session key associated with this ticket as defined by the Kerberos Protocol Specification.

getSessionTimeout() - Method in interface javax.net.ssl.SSLSessionContext

Returns the timeout limit of SSLSession objects grouped under this SSLSessionContext.

getSeverity() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getSeverity() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the severity code for this warning/error.

getSeverity() - Method in interface org.w3c.dom.DOMError

The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

getShadowColor(Component) - Method in class javax.swing.border.EtchedBorder

Returns the shadow color of the etched border when rendered on the specified component.

getShadowColor() - Method in class javax.swing.border.EtchedBorder

Returns the shadow color of the etched border.

getShadowColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getShadowInnerColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the inner shadow color of the bevel border when rendered on the specified component.

getShadowInnerColor() - Method in class javax.swing.border.BevelBorder

Returns the inner shadow color of the bevel border.

getShadowOuterColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the outer shadow color of the bevel border when rendered on the specified component.

getShadowOuterColor() - Method in class javax.swing.border.BevelBorder

Returns the outer shadow color of the bevel border.

getShape() - Method in class java.awt.Window

Returns the shape of the window.

getShaper(int) - Static method in class java.awt.font.NumericShaper

Returns a shaper for the provided unicode range.

getShaper(NumericShaper.Range) - Static method in class java.awt.font.NumericShaper

Returns a shaper for the provided Unicode range.

getSharedAncestor(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the nearest common ancestor to this node and aNode.

getSharedInstance() - Static method in class javax.swing.PopupFactory

Returns the shared PopupFactory which can be used to obtain Popups.

getSharedQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire in shared mode.

getSharedQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire in shared mode.

getShearInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a shearing transformation.

getShearX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate shearing element (m01) of the 3x3 affine transformation matrix.

getShearY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate shearing element (m10) of the 3x3 affine transformation matrix.

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

getShiftKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'shift' key was depressed during the firing of the event.

getShort(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a short.

getShort(Object) - Method in class java.lang.reflect.字段

Gets the value of a static or instance field of type short or of another primitive type convertible to type short via a widening conversion.

getShort() - Method in class java.nio.ByteBuffer

Relative get method for reading a short value.

getShort(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a short value.

getShort(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC SMALLINT parameter as a short in the Java programming language.

getShort(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC SMALLINT parameter as a short in the Java programming language.

getShort(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a short in the Java programming language.

getShort(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a short in the Java programming language.

getShortcut() - Method in class java.awt.MenuItem

Get the MenuShortcut object associated with this menu item,

getShortcutMenuItem(MenuShortcut) - Method in class java.awt.MenuBar

Gets the instance of MenuItem associated with the specified MenuShortcut object, or null if none of the menu items being managed by this menu bar is associated with the specified menu shortcut.

getShortDescription() - Method in class java.beans.FeatureDescriptor

Gets the short description of this feature.

getShortMonths() - Method in class java.text.DateFormatSymbols

Gets short month strings.

getShortParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a short.

getShortWeekdays() - Method in class java.text.DateFormatSymbols

Gets short weekday strings.

getShowDeleted() - Method in class javax.sql.rowset.BaseRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowDeleted() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowDeleted() - Method in interface javax.sql.rowset.JdbcRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowHorizontalLines() - Method in class javax.swing.JTable

Returns true if the table draws horizontal lines between cells, false if it doesn't.

getShowsRootHandles() - Method in class javax.swing.JTree

Returns the value of the showsRootHandles property.

getShowsRootHandles() - Method in class javax.swing.plaf.basic.BasicTreeUI

getShowVerticalLines() - Method in class javax.swing.JTable

Returns true if the table draws vertical lines between cells, false if it doesn't.

getSiblingCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of siblings of this node.

getSides() - Method in class java.awt.JobAttributes

Returns how consecutive pages should be imposed upon the sides of the print medium for jobs using these attributes.

getSigAlgName() - Method in class java.security.cert.X509Certificate

Gets the signature algorithm name for the certificate signature algorithm.

getSigAlgName() - Method in class java.security.cert.X509CRL

Gets the signature algorithm name for the CRL signature algorithm.

getSigAlgName() - Method in class javax.security.cert.X509Certificate

Gets the signature algorithm name for the certificate signature algorithm.

getSigAlgOID() - Method in class java.security.cert.X509Certificate

Gets the signature algorithm OID string from the certificate.

getSigAlgOID() - Method in class java.security.cert.X509CRL

Gets the signature algorithm OID string from the CRL.

getSigAlgOID() - Method in class javax.security.cert.X509Certificate

Gets the signature algorithm OID string from the certificate.

getSigAlgParams() - Method in class java.security.cert.X509Certificate

Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm.

getSigAlgParams() - Method in class java.security.cert.X509CRL

Gets the DER-encoded signature algorithm parameters from this CRL's signature algorithm.

getSigAlgParams() - Method in class javax.security.cert.X509Certificate

Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm.

getSign() - Method in class javax.xml.datatype.Duration

Returns the sign of this duration in -1,0, or 1.

getSignature() - Method in class java.security.cert.X509Certificate

Gets the signature value (the raw signature bits) from the certificate.

getSignature() - Method in class java.security.cert.X509CRL

Gets the signature value (the raw signature bits) from the CRL.

getSignature() - Method in class java.security.SignedObject

Retrieves the signature on the signed object, in the form of a byte array.

getSignature() - Method in class javax.management.MBeanConstructorInfo

Returns the list of parameters for this constructor.

getSignature() - Method in class javax.management.MBeanOperationInfo

Returns the list of parameters for this operation.

getSignature() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.

getSignature() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance.

getSignatureMethod() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the signature method of this SignedInfo.

getSignatureValue() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the signature value of this XMLSignature.

getSignedInfo() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the signed info of this XMLSignature.

getSignerCertPath() - Method in class java.security.CodeSigner

Returns the signer's certificate path.

getSignerCertPath() - Method in class java.security.Timestamp

Returns the certificate path for the Timestamping Authority.

getSigners() - Method in class java.lang.类

Gets the signers of this class.

getSigProvider() - Method in class java.security.cert.PKIXParameters

Returns the signature provider's name, or null if not set.

getSimpleName() - Method in class java.lang.类

Returns the simple name of the underlying class as given in the source code.

getSimpleName() - Method in interface javax.lang.model.element.Element

Returns the simple (unqualified) name of this element.

getSimpleName() - Method in interface javax.lang.model.element.ExecutableElement

Returns the simple name of a constructor, method, or initializer.

getSimpleName() - Method in interface javax.lang.model.element.PackageElement

Returns the simple name of this package.

getSimpleName() - Method in interface javax.lang.model.element.TypeElement

Returns the simple name of this type element.

getSize() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.Component

Returns the size of this component in the form of a Dimension object.

getSize(Dimension) - Method in class java.awt.Component

Stores the width/height of this component into "return value" rv and return rv.

getSize() - Method in class java.awt.Dimension

Gets the size of this Dimension object.

getSize() - Method in class java.awt.Font

Returns the point size of this Font, rounded to an integer.

getSize() - Method in class java.awt.image.DataBuffer

Returns the size (in array elements) of all banks.

getSize() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.Rectangle

Gets the size of this Rectangle, represented by the returned Dimension.

getSize() - Method in class java.awt.SplashScreen

Returns the size of the splash screen window as a Dimension.

getSize() - Method in class java.awt.TrayIcon

Returns the size, in pixels, of the space that the tray icon occupies in the system tray.

getSize() - Method in class java.util.zip.ZipEntry

Returns the uncompressed size of the entry data, or -1 if not known.

getSize() - Method in interface javax.accessibility.AccessibleComponent

Returns the size of this object in the form of a Dimension object.

getSize(int) - Method in class javax.print.attribute.Size2DSyntax

Get this two-dimensional size attribute's dimensions in the given units as floating-point values.

getSize() - Method in class javax.swing.DefaultComboBoxModel

getSize() - Method in class javax.swing.DefaultListModel

Returns the number of components in this list.

getSize(Dimension) - Method in class javax.swing.JComponent

Stores the width/height of this component into "return value" rv and returns rv.

getSize() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getSize() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getSize() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getSize() - Method in interface javax.swing.ListModel

Returns the length of the list.

getSize() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getSize() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getSize() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getSize(int) - Method in class javax.swing.SizeSequence

Returns the size of the specified entry.

getSize() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getSize() - Method in class javax.xml.soap.AttachmentPart

Returns the number of bytes in this AttachmentPart object.

getSize2D() - Method in class java.awt.Font

Returns the point size of this Font in float value.

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns true, basic L&F wants all the buttons to have the same width.

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI

getSizeForComponent(Component) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the size a component would have if used as a cell renderer.

getSizeOfComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the width of the passed in component.

getSizes() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the sizes of the components.

getSizes() - Method in class javax.swing.SizeSequence

Returns the size of all entries.

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the Icon used in calculating the preferred/minimum/maximum size.

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthRadioButtonUI

Returns the Icon used in calculating the preferred/minimum/maximum size.

getSlaveSyncMode() - Method in interface javax.sound.midi.Sequencer

Obtains the current slave synchronization mode for this sequencer.

getSlaveSyncModes() - Method in interface javax.sound.midi.Sequencer

Obtains the set of slave synchronization modes supported by the sequencer.

getSmallDisplayIcon() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the small display icon for the panel.

getSnapshot() - Method in class java.awt.image.VolatileImage

Returns a static snapshot image of this object.

getSnapToTicks() - Method in class javax.swing.JSlider

Returns true if the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.

getSOAPBody() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Body contained in this SOAPMessage object.

getSOAPFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ SOAPFactory instance used by this SOAP binding.

getSOAPHeader() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Header contained in this SOAPMessage object.

getSOAPPart() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP part of this SOAPMessage object.

getSocket() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the socket which is the source of this event.

getSocketAddress() - Method in class java.net.DatagramPacket

Gets the SocketAddress (usually IP address + port number) of the remote host that this packet is being sent to or is coming from.

getSocketFactory() - Static method in class java.rmi.server.RMISocketFactory

Returns the socket factory set by the setSocketFactory method.

getSocketFactory() - Method in class javax.net.ssl.SSLContext

Returns a SocketFactory object for this context.

getSoLinger() - Method in class java.net.Socket

Returns setting for SO_LINGER.

getSolo() - Method in interface javax.sound.midi.MidiChannel

Obtains the current solo state for this channel.

getSortKeys() - Method in class javax.swing.DefaultRowSorter

Returns the current sort keys.

getSortKeys() - Method in class javax.swing.RowSorter

Returns the current sort keys.

getSortOrder() - Method in class javax.swing.RowSorter.SortKey

Returns the sort order of the column.

getSortsOnUpdates() - Method in class javax.swing.DefaultRowSorter

Returns true if a sort should happen when the underlying model is updated; otherwise, returns false.

getSoTimeout() - Method in class java.net.DatagramSocket

Retrieve setting for SO_TIMEOUT.

getSoTimeout() - Method in class java.net.ServerSocket

Retrieve setting for SO_TIMEOUT.

getSoTimeout() - Method in class java.net.Socket

Returns setting for SO_TIMEOUT.

getSoundbank(InputStream) - Static method in class javax.sound.midi.MidiSystem

Constructs a MIDI sound bank by reading it from the specified stream.

getSoundbank(URL) - Static method in class javax.sound.midi.MidiSystem

Constructs a Soundbank by reading it from the specified URL.

getSoundbank(File) - Static method in class javax.sound.midi.MidiSystem

Constructs a Soundbank by reading it from the specified File.

getSoundbank() - Method in class javax.sound.midi.SoundbankResource

Obtains the sound bank that contains this SoundbankResource.

getSoundbank(URL) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the URL provided.

getSoundbank(InputStream) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the InputStream provided.

getSoundbank(File) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the File provided.

getSource() - Method in class java.awt.image.BufferedImage

Returns the object that produces the pixels for the image.

getSource() - Method in class java.awt.Image

Gets the object that produces the pixels for the image.

getSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a general Object.

getSource() - Method in class java.awt.image.VolatileImage

This returns an ImageProducer for this VolatileImage.

getSource() - Method in class java.beans.PropertyEditorSupport

Returns the bean that is used as the source of events.

getSource(Class<T>) - Method in interface java.sql.SQLXML

Returns a Source for reading the XML value designated by this SQLXML instance.

getSource() - Method in class java.util.EventObject

The object on which the Event initially occurred.

getSource() - Method in class javax.swing.event.RowSorterEvent

Returns the source of the event as a RowSorter.

getSource() - Method in interface javax.tools.Diagnostic

Gets the source object associated with this diagnostic.

getSourceActions() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns an int representing the type of action(s) this Drag and Drop operation will support.

getSourceActions() - Method in class java.awt.dnd.DragSourceContext

Returns a bitwise mask of DnDConstants that represent the set of drop actions supported by the drag source for the drag operation associated with this DragSourceContext.

getSourceActions() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the source drop actions.

getSourceActions() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the source drop actions.

getSourceActions(JComponent) - Method in class javax.swing.TransferHandler

Returns the type of transfer actions supported by the source; any bitwise-OR combination of COPY, MOVE and LINK.

getSourceAsBeanContextServices() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the source as a reference of type BeanContextServices.

getSourceAsBeanContextServices() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent

Gets the source as a reference of type BeanContextServices

getSourceAsDragGestureRecognizer() - Method in class java.awt.dnd.DragGestureEvent

Returns the source as a DragGestureRecognizer.

getSourceBands() - Method in class javax.imageio.IIOParam

Returns the set of of source bands to be used.

getSourceClassName() - Method in class java.util.logging.LogRecord

Get the name of the class that (allegedly) issued the logging request.

getSourceDataLine(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.

getSourceDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

getSourceDropActions() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the drag source's supported drop actions, when this TransferSupport represents a drop.

getSourceElement() - Method in class javax.swing.event.HyperlinkEvent

Returns the Element that corresponds to the source of the event.

getSourceEncodings() - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of source format encodings from which format conversion services are provided by this provider.

getSourceLineInfo(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains information about all source lines of a particular type that are supported by the installed mixers.

getSourceLineInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about the set of source lines supported by this mixer.

getSourceLineInfo(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains information about source lines of a particular type supported by the mixer.

getSourceLines() - Method in interface javax.sound.sampled.Mixer

Obtains the set of all source lines currently open to this mixer.

getSourceMaxProgressivePass() - Method in class javax.imageio.ImageReadParam

If getSourceNumProgressivePasses is equal to Integer.MAX_VALUE, returns Integer.MAX_VALUE.

getSourceMethodName() - Method in class java.util.logging.LogRecord

Get the name of the method that (allegedly) issued the logging request.

getSourceMinProgressivePass() - Method in class javax.imageio.ImageReadParam

Returns the index of the first progressive pass that will be decoded.

getSourceNumProgressivePasses() - Method in class javax.imageio.ImageReadParam

Returns the number of the progressive passes that will be decoded.

getSourceRegion() - Method in class javax.imageio.IIOParam

Returns the source region to be used.

getSourceRegion(ImageReadParam, int, int) - Static method in class javax.imageio.ImageReader

A utility method that may be used by readers to compute the region of the source image that should be read, taking into account any source region and subsampling offset settings in the supplied ImageReadParam.

getSourceRenderSize() - Method in class javax.imageio.ImageReadParam

Returns the width and height of the source image as it will be rendered during decoding, if they have been set via the setSourceRenderSize method.

getSources() - Method in class java.awt.image.BufferedImage

Returns a Vector of RenderedImage objects that are the immediate sources, not the sources of these immediate sources, of image data for this BufferedImage.

getSources() - Method in class java.awt.image.renderable.ParameterBlock

Returns the entire Vector of sources.

getSources() - Method in interface java.awt.image.renderable.RenderableImage

Returns a vector of RenderableImages that are the sources of image data for this RenderableImage.

getSources() - Method in class java.awt.image.renderable.RenderableImageOp

Returns a vector of RenderableImages that are the sources of image data for this RenderableImage.

getSources() - Method in interface java.awt.image.RenderedImage

Returns a vector of RenderedImages that are the immediate sources of image data for this RenderedImage.

getSourceString() - Method in class java.text.CollationKey

Returns the String that this CollationKey represents.

getSourceVersion() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the source version that any generated source and 类 files should conform to.

getSourceVersions() - Method in interface javax.tools.Tool

Gets the source versions of the Java™ programming language supported by this tool.

getSourceXSubsampling() - Method in class javax.imageio.IIOParam

Returns the number of source columns to advance for each pixel.

getSourceYSubsampling() - Method in class javax.imageio.IIOParam

Returns the number of rows to advance for each pixel.

getSouthPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getSpaceAbove(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the space above setting.

getSpaceBelow(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the space below setting.

getSpan(int, int) - Method in class javax.swing.text.BoxView

Fetches the span of a particular childs current layout.

getSpan(GlyphView, int, int, TabExpander, float) - Method in class javax.swing.text.GlyphView.GlyphPainter

Determine the span the glyphs given a start location (for tab expansion).

getSpecificationName() - Method in class javax.management.MBeanServerDelegate

Returns the full name of the JMX specification implemented by this product.

getSpecificationName() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the full name of the JMX specification implemented by this product.

getSpecificationTitle() - Method in class java.lang.软件包

Return the title of the specification that this package implements.

getSpecificationVendor() - Method in class java.lang.软件包

Return the name of the organization, vendor, or company that owns and maintains the specification of the classes that implement this package.

getSpecificationVendor() - Method in class javax.management.MBeanServerDelegate

Returns the vendor of the JMX specification implemented by this product.

getSpecificationVendor() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the vendor of the JMX specification implemented by this product.

getSpecificationVersion() - Method in class java.lang.软件包

Returns the version number of the specification that this package implements.

getSpecificationVersion() - Method in class javax.management.MBeanServerDelegate

Returns the version of the JMX specification implemented by this product.

getSpecificationVersion() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the version of the JMX specification implemented by this product.

getSpecified() - Method in interface org.w3c.dom.Attr

True if this attribute was explicitly given a value in the instance document, false otherwise.

getSpecName() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification name.

getSpecVendor() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification vendor.

getSpecVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification version.

getSpi(String) - Method in class java.util.prefs.AbstractPreferences

Return the value associated with the specified key at this preference node, or null if there is no association for this key, or the association cannot be determined at this time.

getSpinner() - Method in class javax.swing.JSpinner.DefaultEditor

Returns the JSpinner ancestor of this editor or null if none of the ancestors are a JSpinner.

getSplashScreen() - Static method in class java.awt.SplashScreen

Returns the SplashScreen object used for Java startup splash screen control on systems that support display.

getSplitPane() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the splitpane this instance is currently contained in.

getSplitPaneBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getSplitPaneDividerBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

Returns a border instance for a JSplitPane divider

getSQLException() - Method in class javax.sql.ConnectionEvent

Retrieves the SQLException for this ConnectionEvent object.

getSQLException() - Method in class javax.sql.StatementEvent

Returns the SQLException the driver is about to throw

getSQLKeywords() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of all of this database's SQL keywords that are NOT also SQL:2003 keywords.

getSQLState() - Method in exception java.sql.SQLException

Retrieves the SQLState for this SQLException object.

getSQLStateType() - Method in interface java.sql.DatabaseMetaData

Indicates whether the SQLSTATE returned by SQLException.getSQLState is X/Open (now known as Open Group) SQL CLI or SQL:2003.

getSQLTypeName() - Method in interface java.sql.SQLData

Returns the fully-qualified name of the SQL user-defined type that this object represents.

getSQLTypeName() - Method in interface java.sql.Struct

Retrieves the SQL type name of the SQL structured type that this Struct object represents.

getSQLTypeName() - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves the SQL type name for this SerialStruct object.

getSQLXML(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated SQL XML parameter as a java.sql.SQLXML object in the Java programming language.

getSQLXML(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated SQL XML parameter as a java.sql.SQLXML object in the Java programming language.

getSQLXML(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet as a java.sql.SQLXML object in the Java programming language.

getSQLXML(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet as a java.sql.SQLXML object in the Java programming language.

getSrcName() - Method in interface org.ietf.jgss.GSSContext

Returns the name of the context initiator.

getSSLParameters() - Method in class javax.net.ssl.SSLEngine

Returns the SSLParameters in effect for this SSLEngine.

getSSLParameters() - Method in class javax.net.ssl.SSLServerSocket

Returns the SSLParameters in effect for newly accepted connections.

getSSLParameters() - Method in class javax.net.ssl.SSLSocket

Returns the SSLParameters in effect for this SSLSocket.

getSSLSocketFactory() - Method in class javax.net.ssl.HttpsURLConnection

Gets the SSL socket factory to be used when creating sockets for secure https URL connections.

getStackTrace() - Method in class java.lang.management.ThreadInfo

Returns the stack trace of the thread associated with this ThreadInfo.

getStackTrace() - Method in class java.lang.Thread

Returns an array of stack trace elements representing the stack dump of this thread.

getStackTrace() - Method in class java.lang.Throwable

Provides programmatic access to the stack trace information printed by Throwable.printStackTrace().

getStamp() - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current value of the stamp.

getStandardChromaNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the chroma information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardCompressionNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the compression information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDataNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the data format information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDimensionNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the dimension information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDocumentNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the document information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - Method in interface javax.tools.JavaCompiler

Gets a new instance of the standard file manager implementation for this tool.

getStandardFormatInstance() - Static method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns an IIOMetadataFormat object describing the standard, plug-in neutral javax.imageio_1.0 metadata document format described in the comment of the javax.imageio.metadata package.

getStandardTextNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the textual information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTileNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the tiling information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTransparencyNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the transparency information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTree() - Method in class javax.imageio.metadata.IIOMetadata

A utility method to return a tree of IIOMetadataNodes representing the metadata contained within this object according to the conventions of the standard javax_imageio_1.0 metadata format.

getStart() - Method in class javax.swing.SpinnerDateModel

Returns the first Date in the sequence.

getStartIndex() - Method in class javax.accessibility.AccessibleHyperlink

Gets the index with the hypertext document at which this link begins

getStartIndex() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Get the index with the hypertext document at which this link begins

getStartOffset() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractWriter

Returns the first offset to be output.

getStartOffset() - Method in interface javax.swing.text.Element

Fetches the offset from the beginning of the document that this element begins at.

getStartOffset() - Method in class javax.swing.text.GlyphView

Fetches the portion of the model that this view is responsible for.

getStartOffset() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the starting model offset for the highlight.

getStartOffset() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Returns the start of the range for which the current occurrence of the tag is defined and has the same attributes.

getStartOffset() - Method in class javax.swing.text.View

Fetches the portion of the model for which this view is responsible.

getStartPoint() - Method in class java.awt.geom.Arc2D

Returns the starting point of the arc.

getStartPoint() - Method in class java.awt.LinearGradientPaint

Returns a copy of the start point of the gradient axis.

getStartPosition() - Method in class javax.swing.text.AbstractDocument

Returns a position that represents the start of the document.

getStartPosition() - Method in interface javax.swing.text.Document

Returns a position that represents the start of the document.

getStartPosition() - Method in interface javax.tools.Diagnostic

Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.

getStartTime() - Method in interface java.lang.management.RuntimeMXBean

Returns the start time of the Java virtual machine in milliseconds.

getStartTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the start time for this ticket's validity period.

getState() - Method in class java.awt.Checkbox

Determines whether this check box is in the "on" or "off" state.

getState() - Method in class java.awt.CheckboxMenuItem

Determines whether the state of this check box menu item is "on" or "off."

getState() - Method in class java.awt.Frame

Gets the state of this frame (obsolete).

getState() - Method in class java.awt.im.InputMethodHighlight

Returns the conversion state of the text range.

getState() - Method in class java.lang.Thread

Returns the state of this thread.

getState() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns the current value of synchronization state.

getState() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns the current value of synchronization state.

getState() - Method in class javax.swing.JCheckBoxMenuItem

Returns the selected-state of the item.

getState() - Method in class javax.swing.SwingWorker

Returns the SwingWorker state bound property.

getStateChange() - Method in class java.awt.event.ItemEvent

Returns the type of state change (selected or deselected).

getStateLabel(boolean) - Method in class javax.sound.sampled.BooleanControl

Obtains the label for the specified state.

getStatement() - Method in interface java.sql.ResultSet

Retrieves the Statement object that produced this ResultSet object.

getStatement() - Method in class javax.sql.StatementEvent

Returns the PreparedStatement that is being closed or is invalid

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi.DirectoryManager

Retrieves the state of an object for binding when given the original object and its attributes.

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi.DirStateFactory

Retrieves the state of an object for binding given the object and attributes to be transformed.

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Retrieves the state of an object for binding.

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi.StateFactory

Retrieves the state of an object for binding.

getStaticAttribute(Object) - Static method in class javax.swing.text.StyleContext

Returns the object previously registered with registerStaticAttributeKey.

getStaticAttributeKey(Object) - Static method in class javax.swing.text.StyleContext

Returns the String that key will be registered with

getStatus() - Method in class java.awt.image.PixelGrabber

Return the status of the pixels.

getStatus() - Method in class javax.net.ssl.SSLEngineResult

Gets the return value of this SSLEngine operation.

getStatus() - Method in class javax.sound.midi.MidiMessage

Obtains the status byte for the MIDI message.

getStatus() - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the conflict status of the current row of this SyncResolver, which indicates the operation the RowSet object was attempting when the conflict occurred.

getStatusCode() - Method in exception javax.xml.ws.http.HTTPException

Gets the HTTP status code.

getStealCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the total number of tasks stolen from one thread's work queue by another.

getStepSize() - Method in class javax.swing.SpinnerNumberModel

Returns the size of the value change computed by the getNextValue and getPreviousValue methods.

getStream(String) - Method in interface java.applet.AppletContext

Returns the stream to which specified key is associated within this applet context.

getStream(DataFlavor) - Method in interface javax.accessibility.AccessibleStreamable

Returns an InputStream for a DataFlavor

getStream(URL) - Method in class javax.swing.JEditorPane

Fetches a stream for the given URL, which is about to be loaded by the setPage method.

getStreamForBytes() - Method in interface javax.print.Doc

Obtains an input stream for extracting byte print data from this doc.

getStreamForBytes() - Method in class javax.print.SimpleDoc

Obtains an input stream for extracting byte print data from this doc.

getStreamKeys() - Method in interface java.applet.AppletContext

Finds all the keys of the streams in this applet context.

getStreamMetadata() - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the input source as a whole (i.e., not associated with any particular image), or null if the reader does not support reading metadata, is set to ignore metadata, or if no metadata is available.

getStreamMetadata(String, Set<String>) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the input source as a whole (i.e., not associated with any particular image).

getStreamMetadataFormat(String) - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an IIOMetadataFormat object describing the given stream metadata format, or null if no description is available.

getStreamPosition() - Method in interface javax.imageio.stream.ImageInputStream

Returns the current byte position of the stream.

getStreamPosition() - Method in class javax.imageio.stream.ImageInputStreamImpl

getStrength() - Method in class java.text.Collator

Returns this Collator's strength property.

getStrictErrorChecking() - Method in interface org.w3c.dom.Document

An attribute specifying whether error checking is enforced or not.

getStrikethroughOffset() - Method in class java.awt.font.LineMetrics

Returns the position of the strike-through line relative to the baseline.

getStrikethroughThickness() - Method in class java.awt.font.LineMetrics

Returns the thickness of the strike-through line.

getString(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC CHAR, VARCHAR, or LONGVARCHAR parameter as a String in the Java programming language.

getString(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC CHAR, VARCHAR, or LONGVARCHAR parameter as a String in the Java programming language.

getString(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getString(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getString() - Method in interface java.sql.SQLXML

Returns a string representation of the XML value designated by this SQLXML instance.

getString(String) - Method in class java.util.ResourceBundle

Gets a string for the given key from this resource bundle or one of its parents.

getString() - Method in class javax.swing.JProgressBar

Returns a String representation of the current progress.

getString(SynthContext, Object, String) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is a String.

getString(int, int) - Method in interface javax.swing.text.AbstractDocument.Content

Fetches a string of characters contained in the sequence.

getString(int, int) - Method in class javax.swing.text.GapContent

Retrieves a portion of the content.

getString() - Method in class javax.swing.text.html.parser.Entity

Returns the data as a String.

getString(int, int) - Method in class javax.swing.text.StringContent

Retrieves a portion of the content.

getString(Object) - Method in class javax.swing.UIDefaults

If the value of key is a String return it, otherwise return null.

getString(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a String return it, otherwise return null.

getString(Object) - Static method in class javax.swing.UIManager

Returns a string from the defaults.

getString(Object, Locale) - Static method in class javax.swing.UIManager

Returns a string from the defaults that is appropriate for the given locale.

getStringArray(String) - Method in class java.util.ResourceBundle

Gets a string array for the given key from this resource bundle or one of its parents.

getStringBounds(String, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified String in the specified FontRenderContext.

getStringBounds(String, int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified String in the specified FontRenderContext.

getStringBounds(char[], int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified array of characters in the specified FontRenderContext.

getStringBounds(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the characters indexed in the specified CharacterIterator in the specified FontRenderContext.

getStringBounds(String, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified String in the specified Graphics context.

getStringBounds(String, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified String in the specified Graphics context.

getStringBounds(char[], int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified array of characters in the specified Graphics context.

getStringBounds(CharacterIterator, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the characters indexed in the specified CharacterIterator in the specified Graphics context.

getStringConverter() - Method in class javax.swing.table.TableRowSorter

Returns the object responsible for converting values from the model to strings.

getStringData() - Method in interface org.w3c.dom.ls.LSInput

String data to parse.

getStringFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of string functions available with this database.

getStringNameType() - Method in interface org.ietf.jgss.GSSName

Returns the name type of the printable representation of this name that can be obtained from the toString method.

getStringPlacement(Graphics, String, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Designate the place where the progress string will be painted.

getStringTable() - Method in class javax.print.attribute.EnumSyntax

Returns the string table for this enumeration value's enumeration class.

getStringTable() - Method in class javax.print.attribute.standard.Chromaticity

Returns the string table for class Chromaticity.

getStringTable() - Method in class javax.print.attribute.standard.ColorSupported

Returns the string table for class ColorSupported.

getStringTable() - Method in class javax.print.attribute.standard.Compression

Returns the string table for class Compression.

getStringTable() - Method in class javax.print.attribute.standard.DialogTypeSelection

Returns the string table for class DialogTypeSelection.

getStringTable() - Method in class javax.print.attribute.standard.Fidelity

Returns the string table for class Fidelity.

getStringTable() - Method in class javax.print.attribute.standard.Finishings

Returns the string table for class Finishings.

getStringTable() - Method in class javax.print.attribute.standard.JobSheets

Returns the string table for class JobSheets.

getStringTable() - Method in class javax.print.attribute.standard.JobState

Returns the string table for class JobState.

getStringTable() - Method in class javax.print.attribute.standard.JobStateReason

Returns the string table for class JobStateReason.

getStringTable() - Method in class javax.print.attribute.standard.MediaName

Returns the string table for class MediaTray.

getStringTable() - Method in class javax.print.attribute.standard.MediaSizeName

Returns the string table for class MediaSizeName.

getStringTable() - Method in class javax.print.attribute.standard.MediaTray

Returns the string table for class MediaTray.

getStringTable() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Returns the string table for class MultipleDocumentHandling.

getStringTable() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the string table for class OrientationRequested.

getStringTable() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Returns the string table for class PDLOverrideSupported.

getStringTable() - Method in class javax.print.attribute.standard.PresentationDirection

Returns the string table for class PresentationDirection.

getStringTable() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Returns the string table for class PrinterIsAcceptingJobs.

getStringTable() - Method in class javax.print.attribute.standard.PrinterState

Returns the string table for class PrinterState.

getStringTable() - Method in class javax.print.attribute.standard.PrinterStateReason

Returns the string table for class PrinterStateReason.

getStringTable() - Method in class javax.print.attribute.standard.PrintQuality

Returns the string table for class PrintQuality.

getStringTable() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Returns the string table for class ReferenceUriSchemesSupported.

getStringTable() - Method in class javax.print.attribute.standard.Severity

Returns the string table for class Severity.

getStringTable() - Method in class javax.print.attribute.standard.SheetCollate

Returns the string table for class SheetCollate.

getStringTable() - Method in class javax.print.attribute.standard.Sides

Returns the string table for class Sides.

getStringToCompare() - Method in class javax.management.monitor.StringMonitor

Gets the string to compare with the observed attribute common to all observed MBeans.

getStringToCompare() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the string to compare with the observed attribute.

getStringValue(int) - Method in class javax.swing.RowFilter.Entry

Returns the string value at the specified index.

getStringValueAt(int, int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the value as a String at the specified index.

getStroke() - Method in class java.awt.Graphics2D

Returns the current Stroke in the Graphics2D context.

getStroke() - Method in class javax.swing.border.StrokeBorder

Returns the BasicStroke object used to stroke a shape during the border rendering.

getStrongCaret(TextHitInfo, TextHitInfo, TextLayout) - Method in class java.awt.font.TextLayout.CaretPolicy

Chooses one of the specified TextHitInfo instances as a strong caret in the specified TextLayout.

getStyle() - Method in class java.awt.Font

Returns the style of this Font.

getStyle() - Method in class java.awt.im.InputMethodHighlight

Returns the rendering style attributes for the text range, or null.

getStyle(String) - Method in class javax.swing.JTextPane

Fetches a named non-null style previously added.

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Gets the style associated with the given component and region.

getStyle() - Method in class javax.swing.plaf.synth.SynthContext

Returns the style associated with this Region.

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Gets a SynthStyle for the specified region of the specified component.

getStyle(JComponent, Region) - Method in class javax.swing.plaf.synth.SynthStyleFactory

Returns the style for the specified Component.

getStyle(String) - Method in class javax.swing.text.DefaultStyledDocument

Fetches a named style previously added.

getStyle(String) - Method in class javax.swing.text.StyleContext

Fetches a named style previously added to the document

getStyle(String) - Method in interface javax.swing.text.StyledDocument

Fetches a named style previously added.

getStyledDocument() - Method in class javax.swing.JTextPane

Fetches the model associated with the editor.

getStyledDocument(JEditorPane) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the document associated with an editor pane.

getStyledEditorKit() - Method in class javax.swing.JTextPane

Gets the editor kit.

getStyledEditorKit(JEditorPane) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the editor kit associated with an editor pane.

getStyleFactory() - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the current SynthStyleFactory.

getStyleNames() - Method in class javax.swing.text.DefaultStyledDocument

Fetches the list of of style names.

getStyleNames() - Method in class javax.swing.text.StyleContext

Fetches the names of the styles defined.

getStyleSheet() - Method in class javax.swing.text.html.BlockView

getStyleSheet() - Method in class javax.swing.text.html.HTMLDocument

Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.

getStyleSheet() - Method in class javax.swing.text.html.HTMLEditorKit

Get the set of styles currently being used to render the HTML elements.

getStyleSheet() - Method in class javax.swing.text.html.ImageView

Convenience method to get the StyleSheet.

getStyleSheet() - Method in class javax.swing.text.html.InlineView

getStyleSheet() - Method in class javax.swing.text.html.ParagraphView

getStylesheet() - Method in class javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec

Returns the stylesheet.

getStyleSheets() - Method in class javax.swing.text.html.StyleSheet

Returns an array of the linked StyleSheets.

getSubElements() - Method in class javax.swing.JMenu

Returns an array of MenuElements containing the submenu for this menu component.

getSubElements() - Method in class javax.swing.JMenuBar

Implemented to be a MenuElement -- returns the menus in this menu bar.

getSubElements() - Method in class javax.swing.JMenuItem

This method returns an array containing the sub-menu components for this menu component.

getSubElements() - Method in class javax.swing.JPopupMenu

Returns an array of MenuElements containing the submenu for this menu component.

getSubElements() - Method in interface javax.swing.MenuElement

This method should return an array containing the sub-elements for the receiving menu element

getSubimage(int, int, int, int) - Method in class java.awt.image.BufferedImage

Returns a subimage defined by a specified rectangular region.

getSubInterfaces() - Method in class java.net.NetworkInterface

Get an Enumeration with all the subinterfaces (also known as virtual interfaces) attached to this network interface.

getSubject() - Method in class java.security.cert.X509CertSelector

Returns the subject criterion as an X500Principal.

getSubject() - Method in class javax.security.auth.login.LoginContext

Return the authenticated Subject.

getSubject(AccessControlContext) - Static method in class javax.security.auth.Subject

Get the Subject associated with the provided AccessControlContext.

getSubject() - Method in class javax.security.auth.SubjectDomainCombiner

Get the Subject associated with this SubjectDomainCombiner.

getSubjectAlternativeNames() - Method in class java.security.cert.X509Certificate

Gets an immutable collection of subject alternative names from the SubjectAltName extension, (OID = 2.5.29.17).

getSubjectAlternativeNames() - Method in class java.security.cert.X509CertSelector

Returns a copy of the subjectAlternativeNames criterion.

getSubjectAsBytes() - Method in class java.security.cert.X509CertSelector

Returns the subject criterion as a byte array.

getSubjectAsString() - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.getSubject() or X509CertSelector.getSubjectAsBytes() instead.

getSubjectDN() - Method in class java.security.cert.X509Certificate

Denigrated, replaced by X509Certificate.getSubjectX500Principal().

getSubjectDN() - Method in class javax.security.cert.X509Certificate

Gets the subject (subject distinguished name) value from the certificate.

getSubjectKeyIdentifier() - Method in class java.security.cert.X509CertSelector

Returns the subjectKeyIdentifier criterion.

getSubjectPublicKey() - Method in class java.security.cert.X509CertSelector

Returns the subjectPublicKey criterion.

getSubjectPublicKeyAlgID() - Method in class java.security.cert.X509CertSelector

Returns the subjectPublicKeyAlgID criterion.

getSubjectUniqueID() - Method in class java.security.cert.X509Certificate

Gets the subjectUniqueID value from the certificate.

getSubjectX500Principal() - Method in class java.security.cert.X509Certificate

Returns the subject (subject distinguished name) value from the certificate as an X500Principal.

getSubsamplingXOffset() - Method in class javax.imageio.IIOParam

Returns the horizontal offset of the subsampling grid.

getSubsamplingYOffset() - Method in class javax.imageio.IIOParam

Returns the vertical offset of the subsampling grid.

getSubString(long, int) - Method in interface java.sql.Clob

Retrieves a copy of the specified substring in the CLOB value designated by this Clob object.

getSubString(long, int) - Method in class javax.sql.rowset.serial.SerialClob

Returns a copy of the substring contained in this SerialClob object, starting at the given position and continuing for the specified number or characters.

getSubTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the sub-text font.

getSubTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the sub-text font of the current theme.

getSubTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the sub-text font.

getSubType() - Method in class java.awt.datatransfer.DataFlavor

Returns the sub MIME type of this DataFlavor.

getSubType() - Method in class javax.activation.MimeType

Retrieve the subtype of this object.

getSuffix(int) - Method in class javax.naming.CompositeName

Creates a composite name whose components consist of a suffix of the components in this composite name.

getSuffix(int) - Method in class javax.naming.CompoundName

Creates a compound name whose components consist of a suffix of the components in this compound name.

getSuffix(int) - Method in class javax.naming.ldap.LdapName

Creates a name whose components consist of a suffix of the components in this LDAP name.

getSuffix(int) - Method in interface javax.naming.Name

Creates a name whose components consist of a suffix of the components in this name.

getSuperBound() - Method in interface javax.lang.model.type.WildcardType

Returns the lower bound of this wildcard.

getSuperclass() - Method in class java.lang.类

Returns the 类 representing the superclass of the entity (class, interface, primitive type or void) represented by this 类.

getSuperclass() - Method in interface javax.lang.model.element.TypeElement

Returns the direct superclass of this type element.

getSuperTables(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the table hierarchies defined in a particular schema in this database.

getSuperTypes(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the user-defined type (UDT) hierarchies defined in a particular schema in this database.

getSupportedAnnotationTypes() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedAnnotationTypes, return an unmodifiable set with the same set of strings as the annotation.

getSupportedAnnotationTypes() - Method in interface javax.annotation.processing.Processor

Returns the names of the annotation types supported by this processor.

getSupportedAttributeCategories() - Method in interface javax.print.PrintService

Determines the printing attribute categories a client can specify when setting up a job for this print service.

getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet) - Method in interface javax.print.PrintService

Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLEngine

Returns the names of the cipher suites which could be enabled for use on this engine.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the cipher suites which could be enabled for use on an SSL connection.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLServerSocketFactory

Returns the names of the cipher suites which could be enabled for use on an SSL connection created by this factory.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLSocket

Returns the names of the cipher suites which could be enabled for use on this connection.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLSocketFactory

Returns the names of the cipher suites which could be enabled for use on an SSL connection.

getSupportedDocFlavors() - Method in interface javax.print.PrintService

Determines the print data formats a client can specify when setting up a job for this PrintService.

getSupportedDocFlavors() - Method in class javax.print.StreamPrintServiceFactory

Queries the factory for the document flavors that can be accepted by printers obtained from this factory.

getSupportedExtensions() - Method in class java.security.cert.PKIXCertPathChecker

Returns an immutable Set of X.509 certificate extensions that this PKIXCertPathChecker supports (i.e.

getSupportedOptions() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedOptions, return an unmodifiable set with the same set of strings as the annotation.

getSupportedOptions() - Method in interface javax.annotation.processing.Processor

Returns the options recognized by this processor.

getSupportedProtocols() - Method in class javax.net.ssl.SSLEngine

Returns the names of the protocols which could be enabled for use with this SSLEngine.

getSupportedProtocols() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the protocols which could be enabled for use.

getSupportedProtocols() - Method in class javax.net.ssl.SSLSocket

Returns the names of the protocols which could be enabled for use on an SSL connection.

getSupportedSourceVersion() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedSourceVersion, return the source version in the annotation.

getSupportedSourceVersion() - Method in interface javax.annotation.processing.Processor

Returns the latest source version supported by this annotation processor.

getSupportedSSLParameters() - Method in class javax.net.ssl.SSLContext

Returns a copy of the SSLParameters indicating the supported settings for this SSL context.

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.synth.SynthScrollBarUI

getSupportsWindowDecorations() - Method in class javax.swing.LookAndFeel

Returns true if the LookAndFeel returned RootPaneUI instances support providing Window decorations in a JRootPane.

getSupportsWindowDecorations() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns true; metal can provide Window decorations.

getSuppressed() - Method in class java.lang.Throwable

Returns an array containing all of the exceptions that were suppressed, typically by the try-with-resources statement, in order to deliver this exception.

getSurplusQueuedTaskCount() - Static method in class java.util.concurrent.ForkJoinTask

Returns an estimate of how many more locally queued tasks are held by the current worker thread than there are other worker threads that might steal them.

getSurrendersFocusOnKeystroke() - Method in class javax.swing.JTable

Returns true if the editor should get the focus when keystrokes cause the editor to be activated

getSymbol() - Method in class java.util.Currency

Gets the symbol of this currency for the default locale.

getSymbol(Locale) - Method in class java.util.Currency

Gets the symbol of this currency for the specified locale.

getSymbol(String, Locale) - Method in class java.util.spi.CurrencyNameProvider

Gets the symbol of the given currency code for the specified locale.

getSyncAllWidths() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getSyncFactory() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the SyncFactory singleton.

getSyncProvider() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves the SyncProvider implementation for this CachedRowSet object.

getSyncResolver() - Method in exception javax.sql.rowset.spi.SyncProviderException

Retrieves the SyncResolver object that has been set for this SyncProviderException object, or if none has been set, an instance of the default SyncResolver implementation included in the reference implementation.

getSynthesizer() - Static method in class javax.sound.midi.MidiSystem

Obtains the default synthesizer.

getSystem() - Static method in class java.rmi.activation.ActivationGroup

Returns the activation system for the VM.

getSystem() - Method in class java.rmi.activation.ActivationGroupID

Returns the group's activation system.

getSystemClassLoader() - Static method in class java.lang.ClassLoader

Returns the system class loader for delegation.

getSystemClipboard() - Method in class java.awt.Toolkit

Gets the singleton instance of the system Clipboard which interfaces with clipboard facilities provided by the native platform.

getSystemCustomCursor(String) - Static method in class java.awt.Cursor

Returns a system-specific custom cursor object matching the specified name.

getSystemDisplayName(File) - Method in class javax.swing.filechooser.FileSystemView

Name of a file, directory, or folder as it would be displayed in a system file browser.

getSystemEventQueue() - Method in class java.awt.Toolkit

Get the application's or applet's EventQueue instance.

getSystemEventQueueImpl() - Method in class java.awt.Toolkit

Gets the application's or applet's EventQueue instance, without checking access.

getSystemFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of system functions available with this database.

getSystemIcon(File) - Method in class javax.swing.filechooser.FileSystemView

Icon for a file, directory, or folder as it would be displayed in a system file browser.

getSystemId() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's system identifier.

getSystemId() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation's system identifier, or null if none was given.

getSystemId() - Method in interface javax.xml.stream.events.StartDocument

Returns the system ID of the XML data

getSystemId() - Method in interface javax.xml.stream.Location

Returns the system ID of the XML

getSystemId() - Method in class javax.xml.transform.dom.DOMResult

Get the System Identifier.

getSystemId() - Method in class javax.xml.transform.dom.DOMSource

Get the base ID (URL or system ID) from where URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.Result

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.sax.SAXResult

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.sax.SAXSource

Get the base ID (URI or system ID) from where URIs will be resolved.

getSystemId() - Method in interface javax.xml.transform.sax.TemplatesHandler

Get the base ID (URI or system ID) from where relative URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.sax.TransformerHandler

Get the base ID (URI or system ID) from where relative URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.Source

Get the system identifier that was set with setSystemId.

getSystemId() - Method in interface javax.xml.transform.SourceLocator

Return the system identifier for the current document event.

getSystemId() - Method in class javax.xml.transform.stax.StAXResult

The returned system identifier is always null.

getSystemId() - Method in class javax.xml.transform.stax.StAXSource

Get the system identifier used by this StAXSource.

getSystemId() - Method in class javax.xml.transform.stream.StreamResult

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.stream.StreamSource

Get the system identifier that was set with setSystemId.

getSystemId() - Method in interface org.w3c.dom.DocumentType

The system identifier of the external subset.

getSystemId() - Method in interface org.w3c.dom.Entity

The system identifier associated with the entity if specified, and null otherwise.

getSystemId() - Method in interface org.w3c.dom.ls.LSInput

The system identifier, a URI reference [IETF RFC 2396], for this input source.

getSystemId() - Method in interface org.w3c.dom.ls.LSOutput

The system identifier, a URI reference [IETF RFC 2396], for this output destination.

getSystemId() - Method in interface org.w3c.dom.Notation

The system identifier of this notation.

getSystemId() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved system identifier.

getSystemId() - Method in class org.xml.sax.InputSource

Get the system identifier for this input source.

getSystemId() - Method in interface org.xml.sax.Locator

Return the system identifier for the current document event.

getSystemId() - Method in exception org.xml.sax.SAXParseException

Get the system identifier of the entity where the exception occurred.

getSystemJavaCompiler() - Static method in class javax.tools.ToolProvider

Gets the Java™ programming language compiler provided with this platform.

getSystemLoadAverage() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the system load average for the last minute.

getSystemLookAndFeelClassName() - Static method in class javax.swing.UIManager

Returns the name of the LookAndFeel class that implements the native system look and feel if there is one, otherwise the name of the default cross platform LookAndFeel class.

getSystemProperties() - Method in interface java.lang.management.RuntimeMXBean

Returns a map of names and values of all system properties.

getSystemResource(String) - Static method in class java.lang.ClassLoader

Find a resource of the specified name from the search path used to load classes.

getSystemResourceAsStream(String) - Static method in class java.lang.ClassLoader

Open for reading, a resource of the specified name from the search path used to load classes.

getSystemResources(String) - Static method in class java.lang.ClassLoader

Finds all resources of the specified name from the search path used to load classes.

getSystemScope() - Static method in class java.security.IdentityScope

Deprecated.

Returns the system's identity scope.

getSystemSelection() - Method in class java.awt.Toolkit

Gets the singleton instance of the system selection as a Clipboard object.

getSystemTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the system text color of the current theme.

getSystemTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the system text color.

getSystemTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the system text font.

getSystemTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the sytem text font of the current theme.

getSystemTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the system text font.

getSystemToolClassLoader() - Static method in class javax.tools.ToolProvider

Returns the class loader for tools provided with this platform.

getSystemTray() - Static method in class java.awt.SystemTray

Gets the SystemTray instance that represents the desktop's tray area.

getSystemTypeDescription(File) - Method in class javax.swing.filechooser.FileSystemView

Type description for a file, directory, or folder as it would be displayed in a system file browser.

getTab(int) - Method in class javax.swing.text.TabSet

Returns the TabStop at index index.

getTabAfter(float) - Method in class javax.swing.text.TabSet

Returns the Tab instance after location.

getTabAreaInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabBase() - Method in class javax.swing.text.ParagraphView

Returns where the tabs are calculated from.

getTabbedSpan(float, TabExpander) - Method in class javax.swing.text.GlyphView

Determines the desired span when using the given tab expansion implementation.

getTabbedSpan(float, TabExpander) - Method in interface javax.swing.text.TabableView

Determines the desired span when using the given tab expansion implementation.

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determines the relative offset into the given text that best represents the given span in the view coordinate system.

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean) - Static method in class javax.swing.text.Utilities

getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determines the width of the given segment of text taking tabs into consideration.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the bounds of the specified tab index.

getTabBounds(int, Rectangle) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the bounds of the specified tab in the coordinate space of the JTabbedPane component.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getTabBounds method on each UI handled by this object.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.TabbedPaneUI

getTabComponentAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab component at index.

getTabCount() - Method in class javax.swing.JTabbedPane

Returns the number of tabs in this tabbedpane.

getTabCount() - Method in class javax.swing.text.TabSet

Returns the number of Tab instances the receiver contains.

getTabExpander() - Method in class javax.swing.text.GlyphView

Fetch the TabExpander to use if tabs are present in this view.

getTabIndex(TabStop) - Method in class javax.swing.text.TabSet

getTabIndexAfter(float) - Method in class javax.swing.text.TabSet

Returns the index of the Tab to be used after location.

getTabInsets(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabInsets(int, int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Overridden to do nothing for the Java L&F.

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Overridden to do nothing for the Java L&F.

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLayoutPolicy() - Method in class javax.swing.JTabbedPane

Returns the policy used by the tabbedpane to layout the tabs when all the tabs will not fit within a single run.

getTable() - Method in class java.awt.image.ByteLookupTable

Returns the lookup table data by reference.

getTable() - Method in class java.awt.image.LookupOp

Returns the LookupTable.

getTable() - Method in class java.awt.image.ShortLookupTable

Returns the lookup table data by reference.

getTable() - Method in class javax.imageio.plugins.jpeg.JPEGQTable

Returns a copy of the current quantization table as an array of ints in natural (not zig-zag) order.

getTable() - Method in class javax.swing.table.JTableHeader

Returns the table associated with this header.

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in class javax.swing.DefaultCellEditor

Implements the TableCellEditor interface.

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in interface javax.swing.table.TableCellEditor

Sets an initial value for the editor.

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in class javax.swing.table.DefaultTableCellRenderer

Returns the default table cell renderer.

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in interface javax.swing.table.TableCellRenderer

Returns the component used for drawing the cell.

getTableHeader() - Method in class javax.swing.JTable

Returns the tableHeader used by this JTable.

getTableModelListeners() - Method in class javax.swing.table.AbstractTableModel

Returns an array of all the table model listeners registered on this model.

getTableName(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's table name.

getTableName() - Method in interface javax.sql.rowset.CachedRowSet

Returns an identifier for the object (table) that was used to create this CachedRowSet object.

getTableName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the name of the table from which the value in the designated column was derived.

getTablePrivileges(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the access rights for each table available in a catalog.

getTables(String, String, String, String[]) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the tables available in the given catalog.

getTableTypes() - Method in interface java.sql.DatabaseMetaData

Retrieves the table types available in this database.

getTabPlacement() - Method in class javax.swing.JTabbedPane

Returns the placement of the tabs for this tabbedpane.

getTabRunCount() - Method in class javax.swing.JTabbedPane

Returns the number of tab runs currently used to display the tabs.

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getTabRunCount method on each UI handled by this object.

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.TabbedPaneUI

getTabRunIndent(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOffset(int, int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOverlay(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOverlay(int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

getTabSet() - Method in class javax.swing.text.ParagraphView

Gets the Tabset to be used in calculating tabs.

getTabSet(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the TabSet.

getTabSize() - Method in class javax.swing.JTextArea

Gets the number of characters used to expand tabs.

getTabSize() - Method in class javax.swing.text.PlainView

Returns the tab size set for the document, defaulting to 8.

getTabSize() - Method in class javax.swing.text.WrappedPlainView

Returns the tab size set for the document, defaulting to 8.

getTabularType() - Method in interface javax.management.openmbean.TabularData

Returns the tabular type describing this TabularData instance.

getTabularType() - Method in class javax.management.openmbean.TabularDataSupport

Returns the tabular type describing this TabularData instance.

getTag(String) - Static method in class javax.swing.text.html.HTML

Fetches a tag constant for a well-known tag name (i.e.

getTag() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Type of tag this iterator represents.

getTagName() - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getNodeName.

getTagName() - Method in interface org.w3c.dom.Element

The name of the element.

getTags() - Method in interface java.beans.PropertyEditor

If the property value must be one of a set of known tagged values, then this method should return an array of the tags.

getTags() - Method in class java.beans.PropertyEditorSupport

If the property value must be one of a set of known tagged values, then this method should return an array of the tag values.

getTail(Handler) - Method in class java.util.logging.Formatter

Return the tail string for a set of formatted records.

getTail(Handler) - Method in class java.util.logging.XMLFormatter

Return the tail string for a set of XML formatted records.

getTarget() - Method in class java.beans.EventHandler

Returns the object to which this event handler will send a message.

getTarget() - Method in class java.beans.Statement

Returns the target object of this statement.

getTarget() - Method in class java.lang.invoke.CallSite

Returns the target method of the call site, according to the behavior defined by this call site's specific class.

getTarget() - Method in class java.lang.invoke.ConstantCallSite

Returns the target method of the call site, which behaves like a final field of the ConstantCallSite.

getTarget() - Method in class java.lang.invoke.MutableCallSite

Returns the target method of the call site, which behaves like a normal field of the MutableCallSite.

getTarget() - Method in class java.lang.invoke.VolatileCallSite

Returns the target method of the call site, which behaves like a volatile field of the VolatileCallSite.

getTarget() - Method in class javax.accessibility.AccessibleRelation

Returns the target objects for this relation

getTarget() - Method in interface javax.rmi.CORBA.Tie

Returns the target for this tie.

getTarget() - Method in class javax.swing.BoxLayout

Returns the container that uses this layout manager.

getTarget() - Method in class javax.swing.OverlayLayout

Returns the container that uses this layout manager.

getTarget() - Method in class javax.swing.text.html.HTMLFrameHyperlinkEvent

returns the target for the link.

getTarget() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns the target URI of this SignatureProperty.

getTarget() - Method in interface javax.xml.stream.events.ProcessingInstruction

The target section of the processing instruction

getTarget() - Method in interface org.w3c.dom.events.Event

Used to indicate the EventTarget to which the event was originally dispatched.

getTarget() - Method in interface org.w3c.dom.ProcessingInstruction

The target of this processing instruction.

getTargetActions() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the target drop action.

getTargetActions() - Method in class java.awt.dnd.DropTargetContext

This method returns an int representing the current actions this DropTarget will accept.

getTargetCertConstraints() - Method in class java.security.cert.PKIXParameters

Returns the required constraints on the target certificate.

getTargetDataLine(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.

getTargetDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

getTargetedNotifications() - Method in class javax.management.remote.NotificationResult

Returns the notifications resulting from the query, and the listeners they correspond to.

getTargetEncodings(AudioFormat.Encoding) - Static method in class javax.sound.sampled.AudioSystem

Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.

getTargetEncodings(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.

getTargetEncodings() - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target format encodings to which format conversion services are provided by this provider.

getTargetEncodings(AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target format encodings supported by the format converter given a particular source format.

getTargetError() - Method in exception javax.management.RuntimeErrorException

Returns the actual Error thrown.

getTargetException() - Method in exception java.lang.reflect.InvocationTargetException

Get the thrown target exception.

getTargetException() - Method in exception javax.management.MBeanException

Return the actual Exception thrown.

getTargetException() - Method in exception javax.management.ReflectionException

Returns the actual Exception thrown.

getTargetException() - Method in exception javax.management.RuntimeMBeanException

Returns the actual RuntimeException thrown.

getTargetException() - Method in exception javax.management.RuntimeOperationsException

Returns the actual RuntimeException thrown.

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.

getTargetLineInfo(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains information about all target lines of a particular type that are supported by the installed mixers.

getTargetLineInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about the set of target lines supported by this mixer.

getTargetLineInfo(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains information about target lines of a particular type supported by the mixer.

getTargetLines() - Method in interface javax.sound.sampled.Mixer

Obtains the set of all target lines currently open from this mixer.

getTargName() - Method in interface org.ietf.jgss.GSSContext

Returns the name of the context acceptor.

getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>) - Method in interface javax.tools.JavaCompiler

Creates a future for a compilation task with the given components and arguments.

getTaskCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate total number of tasks that have ever been scheduled for execution.

getTBSCertificate() - Method in class java.security.cert.X509Certificate

Gets the DER-encoded certificate information, the tbsCertificate from this certificate.

getTBSCertList() - Method in class java.security.cert.X509CRL

Gets the DER-encoded CRL information, the tbsCertList from this CRL.

getTcpNoDelay() - Method in class java.net.Socket

Tests if TCP_NODELAY is enabled.

getTemplates() - Method in interface javax.xml.transform.sax.TemplatesHandler

When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.

getTempoFactor() - Method in interface javax.sound.midi.Sequencer

Returns the current tempo factor for the sequencer.

getTempoInBPM() - Method in interface javax.sound.midi.Sequencer

Obtains the current tempo, expressed in beats per minute.

getTempoInMPQ() - Method in interface javax.sound.midi.Sequencer

Obtains the current tempo, expressed in microseconds per quarter note.

getText() - Method in class java.awt.event.InputMethodEvent

Gets the combined committed and composed text.

getText() - Method in class java.awt.Label

Gets the text of this label.

getText() - Method in class java.awt.TextComponent

Returns the text that is presented by this text component.

getText() - Method in class java.text.BreakIterator

Get the text being scanned

getText() - Method in class javax.security.auth.callback.TextInputCallback

Get the retrieved text.

getText() - Method in class javax.swing.AbstractButton

Returns the button's text.

getText() - Method in class javax.swing.JEditorPane

Returns the text contained in this TextComponent in terms of the content type of this editor.

getText() - Method in class javax.swing.JLabel

Returns the text string that the label displays.

getText() - Method in class javax.swing.JPasswordField

Deprecated.
As of Java 2 platform v1.2, replaced by getPassword.

getText(int, int) - Method in class javax.swing.JPasswordField

Deprecated.
As of Java 2 platform v1.2, replaced by getPassword.

getText(int, int) - Method in class javax.swing.text.AbstractDocument

Gets a sequence of text from the document.

getText(int, int, Segment) - Method in class javax.swing.text.AbstractDocument

Fetches the text contained within the given portion of the document.

getText(Element) - Method in class javax.swing.text.AbstractWriter

Returns the text associated with the element.

getText(int, int) - Method in interface javax.swing.text.Document

Fetches the text contained within the given portion of the document.

getText(int, int, Segment) - Method in interface javax.swing.text.Document

Fetches the text contained within the given portion of the document.

getText(int, int) - Method in class javax.swing.text.GlyphView

Fetch a reference to the text that occupies the given range.

getText(int, int) - Method in class javax.swing.text.JTextComponent

Fetches a portion of the text represented by the component.

getText() - Method in class javax.swing.text.JTextComponent

Returns the text contained in this TextComponent.

getText() - Method in interface javax.xml.stream.events.Comment

Return the string data of the comment, returns empty string if it does not exist

getText() - Method in class javax.xml.stream.util.StreamReaderDelegate

getText() - Method in interface javax.xml.stream.XMLStreamReader

Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.

getTextBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a text component

getTextBounds(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the bounding rectangle of the text between two indices.

getTextBounds(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the Rectangle enclosing the text between two indicies.

getTextCharacters(int, char[], int, int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextCharacters() - Method in interface javax.xml.stream.XMLStreamReader

Returns an array which contains the characters from this event.

getTextCharacters(int, char[], int, int) - Method in interface javax.xml.stream.XMLStreamReader

Gets the the text associated with a CHARACTERS, SPACE or CDATA event.

getTextComponent(ActionEvent) - Method in class javax.swing.text.TextAction

Determines the component to use for the action.

getTextContent() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getTextContent() - Method in interface org.w3c.dom.Node

This attribute returns the text content of this node and its descendants.

getTextField() - Method in class javax.swing.JSpinner.DefaultEditor

Returns the JFormattedTextField child of this editor.

getTextFieldBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getTextFieldBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JTextField

getTextHighlightColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the text highlight color of the current theme.

getTextHighlightColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the text highlight color.

getTextLength() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextLength() - Method in interface javax.xml.stream.XMLStreamReader

Returns the length of the sequence of characters for this Text event within the text character array.

getTextListeners() - Method in class java.awt.TextComponent

Returns an array of all the text listeners registered on this text component.

getTextLocation(TextHitInfo) - Method in interface java.awt.im.InputMethodRequests

Gets the location of a specified offset in the current composed text, or of the selection in committed text.

getTextNonSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the text is drawn with when the node isn't selected.

getTextPlainUnicodeFlavor() - Static method in class java.awt.datatransfer.DataFlavor

Returns a DataFlavor representing plain text with Unicode encoding, where:

getTextRange(int, int) - Method in interface javax.accessibility.AccessibleEditableText

Returns the text string between two indices.

getTextRange(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the text between two indices

getTextRange(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the text between two indices.

getTextRange(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the text string between two indices.

getTextRange(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the text string between two indices.

getTextSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the text is drawn with when the node is selected.

getTextSequenceAfter(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence after a given index.

getTextSequenceAfter(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence after a given index.

getTextSequenceAfter(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence after a given index.

getTextSequenceAt(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence at a given index.

getTextSequenceAt(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence at a given index.

getTextSequenceAt(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence at a given index.

getTextSequenceBefore(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence before a given index.

getTextSequenceBefore(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence before a given index.

getTextSequenceBefore(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence before a given index.

getTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicButtonUI

getTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicToggleButtonUI

Overriden so that the text will not be rendered as shifted for Toggle buttons and subclasses.

getTextStart() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextStart() - Method in interface javax.xml.stream.XMLStreamReader

Returns the offset into the text character array where the first character (of this text event) is stored.

getTextViewForTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the text View object required to render stylized text (HTML) for the specified tab or null if no specialized text rendering is needed for this tab.

getThickness() - Method in class javax.swing.border.LineBorder

Returns the thickness of the border.

getThisUpdate() - Method in class java.security.cert.X509CRL

Gets the thisUpdate date from the CRL.

getThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the current number of live threads including both daemon and non-daemon threads.

getThreadCpuTime(long) - Method in interface java.lang.management.ThreadMXBean

Returns the total CPU time for a thread of the specified ID in nanoseconds.

getThreadFactory() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the thread factory used to create new threads.

getThreadGroup() - Method in class java.lang.SecurityManager

Returns the thread group into which to instantiate any new thread being created at the time this is being called.

getThreadGroup() - Method in class java.lang.Thread

Returns the thread group to which this thread belongs.

getThreadId() - Method in class java.lang.management.ThreadInfo

Returns the ID of the thread associated with this ThreadInfo.

getThreadID() - Method in class java.util.logging.LogRecord

Get an identifier for the thread where the message originated.

getThreadInfo(long) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for a thread of the specified id with no stack trace.

getThreadInfo(long[]) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids with no stack trace.

getThreadInfo(long, int) - Method in interface java.lang.management.ThreadMXBean

Returns a thread info for a thread of the specified id, with stack trace of a specified number of stack trace elements.

getThreadInfo(long[], int) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids, with stack trace of a specified number of stack trace elements.

getThreadInfo(long[], boolean, boolean) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids, with stack trace and synchronization information.

getThreadMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the thread system of the Java virtual machine.

getThreadName() - Method in class java.lang.management.ThreadInfo

Returns the name of the thread associated with this ThreadInfo.

getThreadState() - Method in class java.lang.management.ThreadInfo

Returns the state of the thread associated with this ThreadInfo.

getThreadUserTime(long) - Method in interface java.lang.management.ThreadMXBean

Returns the CPU time that a thread of the specified ID has executed in user mode in nanoseconds.

getThreshold(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getThreshold() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getThreshold(ObjectName)

getThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getThreshold(ObjectName)

getThreshold(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the threshold value for the specified MBean.

getThreshold() - Method in class javax.xml.ws.soap.MTOMFeature

Gets the threshold value used to determine when binary data should be sent as an attachment.

getThrowable() - Method in class java.awt.event.InvocationEvent

Returns any Throwable caught while executing the Runnable's run() method.

getThrown() - Method in class java.util.logging.LogRecord

Get any throwable associated with the log record.

getThrownTypes() - Method in interface javax.lang.model.element.ExecutableElement

Returns the exceptions and other throwables listed in this method or constructor's throws clause in declaration order.

getThrownTypes() - Method in interface javax.lang.model.type.ExecutableType

Returns the exceptions and other throwables listed in this executable's throws clause.

getThumbBounds() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Return the current size/location of the thumb.

getThumbnail(int) - Method in class javax.imageio.IIOImage

Returns a thumbnail associated with the main image.

getThumbnailHeight(int, int) - Method in class javax.imageio.ImageReader

Returns the height of the thumbnail preview image indexed by thumbnailIndex, associated with the image indexed by ImageIndex.

getThumbnails() - Method in class javax.imageio.IIOImage

Returns the current List of thumbnail BufferedImages, or null if none is set.

getThumbnailWidth(int, int) - Method in class javax.imageio.ImageReader

Returns the width of the thumbnail preview image indexed by thumbnailIndex, associated with the image indexed by ImageIndex.

getThumbOverhang() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the amount that the thumb goes past the slide bar.

getThumbSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getThumbSize() - Method in class javax.swing.plaf.metal.MetalSliderUI

getThumbSize() - Method in class javax.swing.plaf.synth.SynthSliderUI

getTick() - Method in class javax.sound.midi.MidiEvent

Obtains the time-stamp for the event, in MIDI ticks

getTickLength() - Method in class javax.sound.midi.Sequence

Obtains the duration of this sequence, expressed in MIDI ticks.

getTickLength() - Method in interface javax.sound.midi.Sequencer

Obtains the length of the current sequence, expressed in MIDI ticks, or 0 if no sequence is set.

getTickLength() - Method in class javax.swing.plaf.basic.BasicSliderUI

Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.

getTickLength() - Method in class javax.swing.plaf.metal.MetalSliderUI

Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.

getTickPosition() - Method in interface javax.sound.midi.Sequencer

Obtains the current position in the sequence, expressed in MIDI ticks.

getTie(Remote) - Static method in class javax.rmi.CORBA.Util

Returns the tie (if any) for a given target object.

getTie(Remote) - Method in interface javax.rmi.CORBA.UtilDelegate

Delegation call for Util.getTie(java.rmi.Remote).

getTile(int, int) - Method in class java.awt.image.BufferedImage

Returns tile (tileX, tileY).

getTile(int, int) - Method in interface java.awt.image.RenderedImage

Returns tile (tileX, tileY).

getTiledSizeRequirements(SizeRequirements[]) - Static method in class javax.swing.SizeRequirements

Determines the total space necessary to place a set of components end-to-end.

getTileGridXOffset() - Method in class java.awt.image.BufferedImage

Returns the x offset of the tile grid relative to the origin, For example, the x coordinate of the location of tile (0, 0).

getTileGridXOffset() - Method in interface java.awt.image.RenderedImage

Returns the X offset of the tile grid relative to the origin, i.e., the X coordinate of the upper-left pixel of tile (0, 0).

getTileGridXOffset(int) - Method in class javax.imageio.ImageReader

Returns the X coordinate of the upper-left corner of tile (0, 0) in the given image.

getTileGridXOffset() - Method in class javax.imageio.ImageWriteParam

Returns the horizontal tile grid offset of an image as it will be written to the output stream.

getTileGridYOffset() - Method in class java.awt.image.BufferedImage

Returns the y offset of the tile grid relative to the origin, For example, the y coordinate of the location of tile (0, 0).

getTileGridYOffset() - Method in interface java.awt.image.RenderedImage

Returns the Y offset of the tile grid relative to the origin, i.e., the Y coordinate of the upper-left pixel of tile (0, 0).

getTileGridYOffset(int) - Method in class javax.imageio.ImageReader

Returns the Y coordinate of the upper-left corner of tile (0, 0) in the given image.

getTileGridYOffset() - Method in class javax.imageio.ImageWriteParam

Returns the vertical tile grid offset of an image as it will be written to the output stream.

getTileHeight() - Method in class java.awt.image.BufferedImage

Returns the tile height in pixels.

getTileHeight() - Method in interface java.awt.image.RenderedImage

Returns the tile height in pixels.

getTileHeight(int) - Method in class javax.imageio.ImageReader

Returns the height of a tile in the given image.

getTileHeight() - Method in class javax.imageio.ImageWriteParam

Returns the height of each tile in an image as it will be written to the output stream.

getTileIcon() - Method in class javax.swing.border.MatteBorder

Returns the icon used for tiling the border or null if a solid color is being used.

getTileWidth() - Method in class java.awt.image.BufferedImage

Returns the tile width in pixels.

getTileWidth() - Method in interface java.awt.image.RenderedImage

Returns the tile width in pixels.

getTileWidth(int) - Method in class javax.imageio.ImageReader

Returns the width of a tile in the given image.

getTileWidth() - Method in class javax.imageio.ImageWriteParam

Returns the width of each tile in an image as it will be written to the output stream.

getTilingMode() - Method in class javax.imageio.ImageWriteParam

Returns the current tiling mode, if tiling is supported.

getTime(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIME parameter as a java.sql.Time object.

getTime(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIME parameter as a java.sql.Time object, using the given Calendar object to construct the time.

getTime(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIME parameter as a java.sql.Time object.

getTime(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIME parameter as a java.sql.Time object, using the given Calendar object to construct the time.

getTime(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime() - Method in class java.sql.Timestamp

Returns the number of milliseconds since January 1, 1970, 00:00:00 GMT represented by this Timestamp object.

getTime() - Method in class java.util.Calendar

Returns a Date object representing this Calendar's time value (millisecond offset from the Epoch").

getTime() - Method in class java.util.Date

Returns the number of milliseconds since January 1, 1970, 00:00:00 GMT represented by this Date object.

getTime() - Method in class java.util.zip.ZipEntry

Returns the modification time of the entry, or -1 if not specified.

getTimeDateFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of the time and date functions available with this database.

getTimeInMillis() - Method in class java.util.Calendar

Returns this Calendar's time value in milliseconds.

getTimeInMillis(Calendar) - Method in class javax.xml.datatype.Duration

Returns the length of the duration in milli-seconds.

getTimeInMillis(Date) - Method in class javax.xml.datatype.Duration

Returns the length of the duration in milli-seconds.

getTimeInstance() - Static method in class java.text.DateFormat

Gets the time formatter with the default formatting style for the default locale.

getTimeInstance(int) - Static method in class java.text.DateFormat

Gets the time formatter with the given formatting style for the default locale.

getTimeInstance(int, Locale) - Static method in class java.text.DateFormat

Gets the time formatter with the given formatting style for the given locale.

getTimeInstance(int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats time with the given formatting style for the specified locale.

getTimeLimit() - Method in class javax.naming.directory.SearchControls

Retrieves the time limit of these SearchControls in milliseconds.

getTimestamp() - Method in class java.security.CodeSigner

Returns the signature timestamp.

getTimestamp() - Method in class java.security.Timestamp

Returns the date and time when the timestamp was generated.

getTimestamp(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIMESTAMP parameter as a java.sql.Timestamp object.

getTimestamp(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIMESTAMP parameter as a java.sql.Timestamp object, using the given Calendar object to construct the Timestamp object.

getTimestamp(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIMESTAMP parameter as a java.sql.Timestamp object.

getTimestamp(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIMESTAMP parameter as a java.sql.Timestamp object, using the given Calendar object to construct the Timestamp object.

getTimestamp(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimeStamp() - Method in class javax.management.Notification

Get the notification timestamp.

getTimeStamp() - Method in interface org.w3c.dom.events.Event

Used to specify the time (in milliseconds relative to the epoch) at which the event was created.

getTimeToLive() - Method in class java.net.DatagramSocketImpl

Retrieve the TTL (time-to-live) option.

getTimeToLive() - Method in class java.net.MulticastSocket

Get the default time-to-live for multicast packets sent out on the socket.

getTimeToLive(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns the time-to-live (TTL) value for resource bundles that are loaded under this ResourceBundle.Control.

getTimeZone() - Method in class java.text.DateFormat

Gets the time zone.

getTimeZone() - Method in class java.util.Calendar

Gets the time zone.

getTimeZone() - Method in class java.util.GregorianCalendar

getTimeZone(String) - Static method in class java.util.TimeZone

Gets the TimeZone for the given ID.

getTimezone() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.

getTimeZone(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Returns a java.util.TimeZone for this class.

getTimezoneOffset() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000).

getTipText() - Method in class javax.swing.JToolTip

Returns the text that is shown when the tool tip is displayed.

getTitle() - Method in class java.awt.Dialog

Gets the title of the dialog.

getTitle() - Method in class java.awt.Frame

Gets the title of the frame.

getTitle() - Method in class javax.swing.border.TitledBorder

Returns the title of the titled border.

getTitle() - Method in class javax.swing.JInternalFrame

Returns the title of the JInternalFrame.

getTitle(String, FontMetrics, int) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

getTitleAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab title at index.

getTitleColor() - Method in class javax.swing.border.TitledBorder

Returns the title-color of the titled border.

getTitledBorderText() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the titled border text

getTitleFont() - Method in class javax.swing.border.TitledBorder

Returns the title-font of the titled border.

getTitleJustification() - Method in class javax.swing.border.TitledBorder

Returns the title-justification of the titled border.

getTitlePosition() - Method in class javax.swing.border.TitledBorder

Returns the title-position of the titled border.

getToggleButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getToggleButtonBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JToggleButton

getToggleClickCount() - Method in class javax.swing.JTree

Returns the number of mouse clicks needed to expand or close a node.

getToIndex() - Method in class javax.swing.event.TableColumnModelEvent

Returns the toIndex.

getTokenThreshold() - Method in class javax.swing.text.html.HTMLDocument

Gets the number of tokens to buffer before trying to update the documents element structure.

getToolkit() - Method in class java.awt.Component

Gets the toolkit of this component.

getToolkit() - Method in class java.awt.Window

Returns the toolkit of this frame.

getToolTip() - Method in class java.awt.TrayIcon

Returns the tooltip string associated with this TrayIcon.

getToolTipLocation(MouseEvent) - Method in class javax.swing.JComponent

Returns the tooltip location in this component's coordinate system.

getToolTipText() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns the tool tip text

getToolTipText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the tool tip text

getToolTipText() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the tool tip text

getToolTipText() - Method in class javax.swing.JComponent

Returns the tooltip string that has been set with setToolTipText.

getToolTipText(MouseEvent) - Method in class javax.swing.JComponent

Returns the string to be used as the tooltip for event.

getToolTipText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the tool tip text

getToolTipText(MouseEvent) - Method in class javax.swing.JList

Returns the tooltip text to be used for the given event.

getToolTipText(MouseEvent) - Method in class javax.swing.JTabbedPane

Returns the tooltip text for the component determined by the mouse event location.

getToolTipText(MouseEvent) - Method in class javax.swing.JTable

Overrides JComponent's getToolTipText method in order to allow the renderer's tips to be used if it has text set.

getToolTipText(MouseEvent) - Method in class javax.swing.JTree

Overrides JComponent's getToolTipText method in order to allow renderer's tips to be used if it has text set.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.basic.BasicTextUI

Returns the string to be used as the tooltip at the passed in location.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getToolTipText method on each UI handled by this object.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.TextUI

Returns the string to be used as the tooltip at the passed in location.

getToolTipText(MouseEvent) - Method in class javax.swing.table.JTableHeader

Allows the renderer's tips to be used if there is text set.

getToolTipText(float, float, Shape) - Method in class javax.swing.text.html.ImageView

For images the tooltip text comes from text specified with the ALT attribute.

getToolTipText(MouseEvent) - Method in class javax.swing.text.JTextComponent

Returns the string to be used as the tooltip for event.

getToolTipText(float, float, Shape) - Method in class javax.swing.text.View

Returns the tooltip text at the specified location.

getToolTipTextAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab tooltip text at index.

getToPage() - Method in class java.awt.JobAttributes

Returns, for jobs using these attributes, the last page (inclusive) to be printed, if a range of pages is to be printed.

getTopComponent() - Method in class javax.swing.JSplitPane

Returns the component above, or to the left of the divider.

getTopInset() - Method in class javax.swing.text.AsyncBoxView

Get the top part of the margin around the view.

getTopInset() - Method in class javax.swing.text.CompositeView

Gets the top inset.

getTopLevelAncestor() - Method in class javax.swing.JComponent

Returns the top-level ancestor of this component (either the containing Window or Applet), or null if this component has not been added to any container.

getTotalCapacity() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the total capacity of the buffers in this pool.

getTotalColumnWidth() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the total combined width of all columns.

getTotalColumnWidth() - Method in interface javax.swing.table.TableColumnModel

Returns the total width of all the columns.

getTotalCompilationTime() - Method in interface java.lang.management.CompilationMXBean

Returns the approximate accumlated elapsed time (in milliseconds) spent in compilation.

getTotalIn() - Method in class java.util.zip.Deflater

Returns the total number of uncompressed bytes input so far.

getTotalIn() - Method in class java.util.zip.Inflater

Returns the total number of compressed bytes input so far.

getTotalLoadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the total number of classes that have been loaded since the Java virtual machine has started execution.

getTotalOut() - Method in class java.util.zip.Deflater

Returns the total number of compressed bytes output so far.

getTotalOut() - Method in class java.util.zip.Inflater

Returns the total number of uncompressed bytes output so far.

getTotalSize() - Method in interface org.w3c.dom.ls.LSProgressEvent

The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.

getTotalSpace() - Method in class java.io.File

Returns the size of the partition named by this abstract pathname.

getTotalSpace() - Method in class java.nio.file.FileStore

Returns the size, in bytes, of the file store.

getTotalStartedThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the total number of threads created and also started since the Java virtual machine started.

getTrackBounds() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the current bounds of the track, i.e.

getTrackLength() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the longer dimension of the slide bar.

getTrackMute(int) - Method in interface javax.sound.midi.Sequencer

Obtains the current mute state for a track.

getTracks() - Method in class javax.sound.midi.Sequence

Obtains an array containing all the tracks in this sequence.

getTrackSolo(int) - Method in interface javax.sound.midi.Sequencer

Obtains the current solo state for a track.

getTrackWidth() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the shorter dimension of the track.

getTrafficClass() - Method in class java.net.DatagramSocket

Gets traffic class or type-of-service in the IP datagram header for packets sent from this DatagramSocket.

getTrafficClass() - Method in class java.net.Socket

Gets traffic class or type-of-service in the IP header for packets sent from this Socket

getTrailerField() - Method in class java.security.spec.PSSParameterSpec

Returns the value for the trailer field, i.e.

getTransactionIsolation() - Method in interface java.sql.Connection

Retrieves this Connection object's current transaction isolation level.

getTransactionIsolation() - Method in class javax.sql.rowset.BaseRowSet

Returns the transaction isolation property for this RowSet object's connection.

getTransactionIsolation() - Method in interface javax.sql.RowSet

Retrieves the transaction isolation level set for this RowSet object.

getTransactionTimeout() - Method in interface javax.transaction.xa.XAResource

Obtains the current transaction timeout value set for this XAResource instance.

getTransferable() - Method in class java.awt.dnd.DragSourceContext

Returns the Transferable associated with this DragSourceContext.

getTransferable() - Method in class java.awt.dnd.DropTargetContext

get the Transferable (proxy) operand of this operation

getTransferable() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the Transferable object that represents the data associated with the current drag operation.

getTransferable() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the Transferable object associated with the drop.

getTransferable() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the Transferable associated with this transfer.

getTransferData(DataFlavor) - Method in class java.awt.datatransfer.StringSelection

Returns the Transferable's data in the requested DataFlavor if possible.

getTransferData(DataFlavor) - Method in interface java.awt.datatransfer.Transferable

Returns an object which represents the data to be transferred.

getTransferData(DataFlavor) - Method in class java.awt.dnd.DropTargetContext.TransferableProxy

Returns an object which represents the data provided by the encapsulated transferable for the requested data flavor.

getTransferData(DataFlavor, DataSource) - Method in interface javax.activation.DataContentHandler

Returns an object which represents the data to be transferred.

getTransferData(DataFlavor) - Method in class javax.activation.DataHandler

Returns an object that represents the data to be transferred.

getTransferDataFlavors() - Method in class java.awt.datatransfer.StringSelection

Returns an array of flavors in which this Transferable can provide the data.

getTransferDataFlavors() - Method in interface java.awt.datatransfer.Transferable

Returns an array of DataFlavor objects indicating the flavors the data can be provided in.

getTransferDataFlavors() - Method in class java.awt.dnd.DropTargetContext.TransferableProxy

Returns an array of DataFlavor objects indicating the flavors the data can be provided in by the encapsulated transferable.

getTransferDataFlavors() - Method in interface javax.activation.DataContentHandler

Returns an array of DataFlavor objects indicating the flavors the data can be provided in.

getTransferDataFlavors() - Method in class javax.activation.DataHandler

Return the DataFlavors in which this data is available.

getTransferHandler() - Method in class javax.swing.JApplet

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JComponent

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JDialog

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JFrame

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JWindow

Gets the transferHandler property.

getTransferSize() - Method in exception java.sql.DataTruncation

Gets the number of bytes of data actually transferred.

getTransferType() - Method in class java.awt.image.ColorModel

Returns the transfer type of this ColorModel.

getTransferType() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the TransferType used to transfer pixels by way of the getDataElements and setDataElements methods.

getTransferType() - Method in class java.awt.image.Raster

Returns the TransferType used to transfer pixels via the getDataElements and setDataElements methods.

getTransferType() - Method in class java.awt.image.SampleModel

Returns the TransferType used to transfer pixels via the getDataElements and setDataElements methods.

getTransform() - Method in class java.awt.font.FontRenderContext

Gets the transform that is used to scale typographical points to pixels in this FontRenderContext.

getTransform() - Method in class java.awt.Font

Returns a copy of the transform associated with this Font.

getTransform() - Method in class java.awt.font.TransformAttribute

Returns a copy of the wrapped transform.

getTransform() - Method in class java.awt.Graphics2D

Returns a copy of the current Transform in the Graphics2D context.

getTransform() - Method in class java.awt.image.AffineTransformOp

Returns the affine transform used by this transform operation.

getTransform() - Method in class java.awt.image.renderable.RenderContext

Gets the current user-to-device AffineTransform.

getTransform() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the transform applied to the gradient.

getTransformer() - Method in interface javax.xml.transform.sax.TransformerHandler

Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.

getTransforms() - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod

Returns an unmodifiable list of Transforms of this RetrievalMethod.

getTransforms() - Method in interface javax.xml.crypto.dsig.Reference

Returns an unmodifiable list of Transforms that are contained in this Reference.

getTransformType() - Method in class java.awt.font.FontRenderContext

Returns the integer type of the affine transform for this FontRenderContext as specified by AffineTransform.getType()

getTranslateInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a translation transformation.

getTranslateX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate of the translation element (m02) of the 3x3 affine transformation matrix.

getTranslateY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate of the translation element (m12) of the 3x3 affine transformation matrix.

getTransmitter() - Method in interface javax.sound.midi.MidiDevice

Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.

getTransmitter() - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI transmitter from an external MIDI port or other default source.

getTransmitters() - Method in interface javax.sound.midi.MidiDevice

Returns all currently active, non-closed transmitters connected with this MidiDevice.

getTransparency() - Method in class java.awt.Color

Returns the transparency mode for this Color.

getTransparency() - Method in class java.awt.GradientPaint

Returns the transparency mode for this GradientPaint.

getTransparency() - Method in class java.awt.image.BufferedImage

Returns the transparency.

getTransparency() - Method in class java.awt.image.ColorModel

Returns the transparency.

getTransparency() - Method in class java.awt.image.IndexColorModel

Returns the transparency.

getTransparency() - Method in class java.awt.image.VolatileImage

Returns the transparency.

getTransparency() - Method in class java.awt.MultipleGradientPaint

Returns the transparency mode for this Paint object.

getTransparency() - Method in class java.awt.TexturePaint

Returns the transparency mode for this TexturePaint.

getTransparency() - Method in interface java.awt.Transparency

Returns the type of this Transparency.

getTransparentPixel() - Method in class java.awt.image.IndexColorModel

Returns the index of a transparent pixel in this IndexColorModel or -1 if there is no pixel with an alpha value of 0.

getTrayIcons() - Method in class java.awt.SystemTray

Returns an array of all icons added to the tray by this application.

getTrayIconSize() - Method in class java.awt.SystemTray

Returns the size, in pixels, of the space that a tray icon will occupy in the system tray.

getTRC() - Method in class java.awt.color.ICC_ProfileGray

Returns the TRC as an array of shorts.

getTRC(int) - Method in class java.awt.color.ICC_ProfileRGB

Returns the TRC for a particular component as an array.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.DefaultCellEditor

Implements the TreeCellEditor interface.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree.DefaultTreeCellEditor

Configures the editor.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in interface javax.swing.tree.TreeCellEditor

Sets an initial value for the editor.

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Configures the renderer based on the passed in components.

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in interface javax.swing.tree.TreeCellRenderer

Sets the value of the current tree cell to value.

getTreeComputerIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeControlIcon(boolean) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeExpansionListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeExpansionListeners added to this JTree with addTreeExpansionListener().

getTreeFloppyDriveIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeHardDriveIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeLeafIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeLock() - Method in class java.awt.Component

Gets this component's locking object (the object that owns the thread synchronization monitor) for AWT component-tree and layout operations.

getTreeLock() - Method in class java.awt.MenuComponent

Gets this component's locking object (the object that owns the thread sychronization monitor) for AWT component-tree and layout operations.

getTreeModelListeners() - Method in class javax.swing.tree.DefaultTreeModel

Returns an array of all the tree model listeners registered on this model.

getTreePath() - Method in class javax.swing.event.TreeModelEvent

For all events, except treeStructureChanged, returns the parent of the changed nodes.

getTreeSelectionListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeSelectionListeners added to this JTree with addTreeSelectionListener().

getTreeSelectionListeners() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the tree selection listeners registered on this model.

getTreeWillExpandListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeWillExpandListeners added to this JTree with addTreeWillExpandListener().

getTrigger() - Method in class java.awt.dnd.DragSourceContext

Returns the DragGestureEvent that initially triggered the drag.

getTrigger() - Method in class javax.management.monitor.MonitorNotification

Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.

getTriggerEvent() - Method in class java.awt.dnd.DragGestureEvent

Returns the initial event that triggered the gesture.

getTriggerEvent() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the first event in the series of events that initiated the Drag and Drop operation.

getTrustAnchor() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the TrustAnchor describing the CA that served as a trust anchor for the certification path.

getTrustAnchors() - Method in class java.security.cert.PKIXParameters

Returns an immutable Set of the most-trusted CAs.

getTrustedCert() - Method in class java.security.cert.TrustAnchor

Returns the most-trusted CA certificate.

getTrustedCertificate() - Method in class java.security.KeyStore.TrustedCertificateEntry

Gets the trusted Certficate from this entry.

getTrustManagers() - Method in class javax.net.ssl.TrustManagerFactory

Returns one trust manager for each type of trust material.

getTTL() - Method in class java.net.DatagramSocketImpl

Deprecated.
use getTimeToLive instead.

getTTL() - Method in class java.net.MulticastSocket

Deprecated.
use the getTimeToLive method instead, which returns an int instead of a byte.

getType() - Method in class java.awt.color.ColorSpace

Returns the color space type of this ColorSpace (for example TYPE_RGB, TYPE_XYZ, ...).

getType() - Method in class java.awt.Cursor

Returns the type for this cursor.

getType() - Method in class java.awt.font.GlyphMetrics

Returns the raw glyph type code.

getType() - Method in class java.awt.geom.AffineTransform

Retrieves the flag bits describing the conversion properties of this transform.

getType() - Method in class java.awt.GraphicsDevice

Returns the type of this GraphicsDevice.

getType() - Method in class java.awt.image.BufferedImage

Returns the image type.

getType() - Method in class java.awt.Window

Returns the type of the window.

getType() - Method in class java.io.ObjectStreamField

Get the type of the field.

getType(char) - Static method in class java.lang.Character

Returns a value indicating a character's general category.

getType(int) - Static method in class java.lang.Character

Returns a value indicating a character's general category.

getType() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the type of this memory pool.

getType() - Method in class java.lang.reflect.字段

Returns a 类 object that identifies the declared type for the field represented by this Field object.

getType() - Method in class java.security.cert.Certificate

Returns the type of this certificate.

getType() - Method in class java.security.cert.CertificateFactory

Returns the name of the certificate type associated with this certificate factory.

getType() - Method in class java.security.cert.CertPath

Returns the type of Certificates in this certification path.

getType() - Method in class java.security.cert.CertStore

Returns the type of this CertStore.

getType() - Method in class java.security.cert.CRL

Returns the type of this CRL.

getType() - Method in class java.security.KeyStore

Returns the type of this keystore.

getType() - Method in class java.security.Policy

Return the type of this Policy.

getType() - Method in class java.security.Provider.Service

Get the type of this service.

getType() - Method in interface java.sql.ResultSet

Retrieves the type of this ResultSet object.

getType() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the type of event

getType() - Method in class javax.management.MBeanAttributeInfo

Returns the class name of the attribute.

getType() - Method in class javax.management.MBeanParameterInfo

Returns the type or class name of the data.

getType() - Method in class javax.management.Notification

Get the notification type.

getType(String) - Method in class javax.management.openmbean.CompositeType

Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

getType() - Method in class javax.naming.event.NamingEvent

Returns the type of this event.

getType() - Method in class javax.naming.ldap.Rdn

Retrieves one of this Rdn's type.

getType() - Method in class javax.naming.RefAddr

Retrieves the address type of this address.

getType() - Method in class javax.security.auth.login.Configuration

Return the type of this Configuration.

getType() - Method in class javax.sound.midi.MetaMessage

Obtains the type of the MetaMessage.

getType() - Method in class javax.sound.midi.MidiFileFormat

Obtains the MIDI file type.

getType() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the audio file type, such as WAVE or AU.

getType() - Method in class javax.sound.sampled.Control

Obtains the control's type.

getType() - Method in class javax.sound.sampled.LineEvent

Obtains the event's type.

getType() - Method in class javax.sql.rowset.BaseRowSet

Returns the type of this RowSet object.

getType() - Method in interface javax.swing.event.DocumentEvent

Gets the type of event.

getType() - Method in class javax.swing.event.ListDataEvent

Returns the event type.

getType() - Method in class javax.swing.event.RowSorterEvent

Returns the type of event.

getType() - Method in class javax.swing.event.TableModelEvent

Returns the type of event - one of: INSERT, UPDATE and DELETE.

getType() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getType() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the type of event.

getType() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the element type.

getType() - Method in class javax.swing.text.html.parser.AttributeList

getType() - Method in class javax.swing.text.html.parser.Element

Get type.

getType() - Method in class javax.swing.text.html.parser.Entity

Gets the type of the entity.

getType() - Method in interface javax.xml.crypto.URIReference

Returns the type of data referenced by this URI.

getType() - Method in interface org.w3c.dom.DOMError

A DOMString indicating which related data is expected in relatedData.

getType() - Method in interface org.w3c.dom.events.Event

The name of the event (case-insensitive).

getType(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the type of an attribute in the list (by position).

getType(String) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the type of an attribute in the list (by name).

getType(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by index.

getType(String, String) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by Namespace name.

getType(String) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by XML qualified (prefixed) name.

getType(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the type of an attribute (by position).

getType(String) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the type of an attribute (by name).

getType(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's type by index.

getType(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's type by Namespace-qualified name.

getType(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's type by qualified (prefixed) name.

getTypeArguments() - Method in interface javax.lang.model.type.DeclaredType

Returns the actual type arguments of this type.

getTypeCode() - Method in class java.io.ObjectStreamField

Returns character encoding of field type.

getTypeDescription(File) - Method in class javax.swing.filechooser.FileView

A human readable description of the type of the file.

getTypeDescription(File) - Method in class javax.swing.JFileChooser

Returns the file type.

getTypeDescription(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getTypeElement(CharSequence) - Method in interface javax.lang.model.util.Elements

Returns a type element given its canonical name.

getTypeInfo() - Method in interface java.sql.DatabaseMetaData

Retrieves a description of all the data types supported by this database.

getTypeInfoProvider() - Method in class javax.xml.validation.ValidatorHandler

Obtains the TypeInfoProvider implementation of this ValidatorHandler.

getTypeMap() - Method in interface java.sql.Connection

Retrieves the Map object associated with this Connection object.

getTypeMap() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the type map associated with the Connection object for this RowSet object.

getTypeMap() - Method in interface javax.sql.RowSet

Retrieves the Map object associated with this RowSet object, which specifies the custom mapping of SQL user-defined types, if any.

getTypeMirror() - Method in exception javax.lang.model.type.MirroredTypeException

Returns the type mirror corresponding to the type being accessed.

getTypeMirrors() - Method in exception javax.lang.model.type.MirroredTypesException

Returns the type mirrors corresponding to the types being accessed.

getTypeName() - Method in class javax.management.openmbean.OpenType

Returns the name of this OpenType instance.

getTypeName() - Method in interface org.w3c.dom.TypeInfo

The name of a type declared for the associated element or attribute, or null if unknown.

getTypeNamespace() - Method in interface org.w3c.dom.TypeInfo

The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

getTypeParameters() - Method in class java.lang.类

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in class java.lang.reflect.Constructor

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in interface java.lang.reflect.GenericDeclaration

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in class java.lang.reflect.方法

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.ExecutableElement

Returns the formal type parameters of this executable in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.Parameterizable

Returns the formal type parameters of the type element in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.TypeElement

Returns the formal type parameters of this type element in declaration order.

getTypeString() - Method in class java.io.ObjectStreamField

Return the JVM type signature.

getTypeUtils() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns an implementation of some utility methods for operating on types.

getTypeVariables() - Method in interface javax.lang.model.type.ExecutableType

Returns the type variables declared by the formal type parameters of this executable.

getUDTs(String, String, String, int[]) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the user-defined types (UDTs) defined in a particular schema.

getUI(int, String) - Method in class javax.print.ServiceUIFactory

Get a UI object which may be cast to the requested UI type by the application and used in its user interface.

getUI() - Method in class javax.swing.AbstractButton

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JColorChooser

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JComboBox

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JDesktopPane

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JFileChooser

Gets the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JInternalFrame

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JLabel

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JLayer

Returns the LayerUI for this JLayer.

getUI() - Method in class javax.swing.JList

Returns the ListUI, the look and feel object that renders this component.

getUI() - Method in class javax.swing.JMenuBar

Returns the menubar's current UI.

getUI() - Method in class javax.swing.JOptionPane

Returns the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JPanel

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JPopupMenu

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JProgressBar

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JRootPane

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JScrollBar

Returns the delegate that implements the look and feel for this component.

getUI() - Method in class javax.swing.JScrollPane

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JSeparator

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JSlider

Gets the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JSpinner

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JSplitPane

Returns the SplitPaneUI that is providing the current look and feel.

getUI() - Method in class javax.swing.JTabbedPane

Returns the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JTable

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JToolBar

Returns the tool bar's current UI.

getUI() - Method in class javax.swing.JToolTip

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JTree

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JViewport

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.table.JTableHeader

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.text.JTextComponent

Fetches the user-interface factory for this text-oriented editor.

getUI(JComponent) - Method in class javax.swing.UIDefaults

Creates an ComponentUI implementation for the specified component.

getUI(JComponent) - Static method in class javax.swing.UIManager

Returns the appropriate ComponentUI implementation for target.

getUIActionMap(JComponent) - Static method in class javax.swing.SwingUtilities

Returns the ActionMap provided by the UI in component component.

getUIClass(String, ClassLoader) - Method in class javax.swing.UIDefaults

The value of get(uidClassID) must be the String name of a class that implements the corresponding ComponentUI class.

getUIClass(String) - Method in class javax.swing.UIDefaults

Returns the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JButton

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JCheckBox

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JCheckBoxMenuItem

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JColorChooser

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JComboBox

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JComponent

Returns the UIDefaults key used to look up the name of the swing.plaf.ComponentUI class that defines the look and feel for this component.

getUIClassID() - Method in class javax.swing.JDesktopPane

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JEditorPane

Gets the class ID for the UI.

getUIClassID() - Method in class javax.swing.JFileChooser

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JFormattedTextField

Gets the class ID for a UI.

getUIClassID() - Method in class javax.swing.JInternalFrame

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JLabel

Returns a string that specifies the name of the l&f class that renders this component.

getUIClassID() - Method in class javax.swing.JList

Returns "ListUI", the UIDefaults key used to look up the name of the javax.swing.plaf.ListUI class that defines the look and feel for this component.

getUIClassID() - Method in class javax.swing.JMenu

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JMenuBar

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JMenuItem

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JOptionPane

Returns the name of the UI class that implements the L&F for this component.

getUIClassID() - Method in class javax.swing.JPanel

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPasswordField

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPopupMenu

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPopupMenu.Separator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JProgressBar

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JRadioButton

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JRadioButtonMenuItem

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JRootPane

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JScrollBar

Returns the name of the LookAndFeel class for this component.

getUIClassID() - Method in class javax.swing.JScrollPane

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JSeparator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JSlider

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JSpinner

Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.

getUIClassID() - Method in class javax.swing.JSplitPane

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JTabbedPane

Returns the name of the UI class that implements the L&F for this component.

getUIClassID() - Method in class javax.swing.JTable

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JTextArea

Returns the class ID for the UI.

getUIClassID() - Method in class javax.swing.JTextField

Gets the class ID for a UI.

getUIClassID() - Method in class javax.swing.JTextPane

Returns the class ID for the UI.

getUIClassID() - Method in class javax.swing.JToggleButton

Returns a string that specifies the name of the l&f class that renders this component.

getUIClassID() - Method in class javax.swing.JToolBar

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JToolBar.Separator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JToolTip

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JTree

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JViewport

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.table.JTableHeader

Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.

getUIClassNamesForRole(int) - Method in class javax.print.ServiceUIFactory

Given a UI role obtained from this factory obtain the UI types available from this factory which implement this role.

getUIError(String) - Method in class javax.swing.UIDefaults

If getUI() fails for any reason, it calls this method before returning null.

getUIInputMap(JComponent, int) - Static method in class javax.swing.SwingUtilities

Returns the InputMap provided by the UI for condition condition in component component.

getUIs() - Method in class javax.swing.plaf.multi.MultiButtonUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiLabelUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiListUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiPanelUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSliderUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTableUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTextUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiToolBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiToolTipUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTreeUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiViewportUI

Returns the list of UIs associated with this multiplexing UI.

getUnallocatedSpace() - Method in class java.nio.file.FileStore

Returns the number of unallocated bytes in the file store.

getUnarrivedParties() - Method in class java.util.concurrent.Phaser

Returns the number of registered parties that have not yet arrived at the current phase of this phaser.

getUncaughtExceptionHandler() - Method in class java.lang.Thread

Returns the handler invoked when this thread abruptly terminates due to an uncaught exception.

getUncaughtExceptionHandler() - Method in class java.util.concurrent.ForkJoinPool

Returns the handler for internal worker threads that terminate due to unrecoverable errors encountered while executing tasks.

getUndeclaredThrowable() - Method in exception java.lang.reflect.UndeclaredThrowableException

Returns the Throwable instance wrapped in this UndeclaredThrowableException, which may be null.

getUnderlineOffset() - Method in class java.awt.font.LineMetrics

Returns the position of the underline relative to the baseline.

getUnderlineThickness() - Method in class java.awt.font.LineMetrics

Returns the thickness of the underline.

getUndoableEditListeners() - Method in class javax.swing.text.AbstractDocument

Returns an array of all the undoable edit listeners registered on this document.

getUndoableEditListeners() - Method in class javax.swing.undo.UndoableEditSupport

Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().

getUndoOrRedoPresentationName() - Method in class javax.swing.undo.UndoManager

Convenience method that returns either getUndoPresentationName or getRedoPresentationName.

getUndoPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of the undoable form of this edit, e.g.

getUndoPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName.

getUndoPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getUndoPresentationName from the last UndoableEdit added to edits.

getUndoPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example.

getUndoPresentationName() - Method in class javax.swing.undo.UndoManager

Returns a description of the undoable form of this edit.

getUnexecutedModifications() - Method in exception javax.naming.directory.AttributeModificationException

Retrieves the unexecuted modification list.

getUnicodeLocaleAttributes() - Method in class java.util.Locale

Returns the set of unicode locale attributes associated with this locale, or the empty set if it has no attributes.

getUnicodeLocaleKeys() - Method in class java.util.Locale

Returns the set of Unicode locale keys defined by this locale, or the empty set if this locale has none.

getUnicodeLocaleType(String) - Method in class java.util.Locale

Returns the Unicode locale type associated with the specified Unicode locale key for this locale.

getUnicodeStream(int) - Method in interface java.sql.ResultSet

Deprecated.
use getCharacterStream in place of getUnicodeStream

getUnicodeStream(String) - Method in interface java.sql.ResultSet

Deprecated.
use getCharacterStream instead

getUnitIncrement() - Method in interface java.awt.Adjustable

Gets the unit value increment for the adjustable object.

getUnitIncrement() - Method in class java.awt.Scrollbar

Gets the unit increment for this scrollbar.

getUnitIncrement() - Method in class java.awt.ScrollPaneAdjustable

getUnitIncrement(int) - Method in class javax.swing.JScrollBar

Returns the amount to change the scrollbar's value by, given a unit up/down request.

getUnitIncrement() - Method in class javax.swing.JScrollBar

For backwards compatibility with java.awt.Scrollbar.

getUnitIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Computes the unit increment for scrolling if the viewport's view is a Scrollable object.

getUnits() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the units in which the control's values are expressed, such as "dB" or "frames per second."

getUnitsToScroll() - Method in class java.awt.event.MouseWheelEvent

This is a convenience method to aid in the implementation of the common-case MouseWheelListener - to scroll a ScrollPane or JScrollPane by an amount which conforms to the platform settings.

getUnknownAnnotationValue() - Method in exception javax.lang.model.element.UnknownAnnotationValueException

Returns the unknown annotation value.

getUnknownElement() - Method in exception javax.lang.model.element.UnknownElementException

Returns the unknown element.

getUnknownType() - Method in exception javax.lang.model.type.UnknownTypeException

Returns the unknown type.

getUnloadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the total number of classes unloaded since the Java virtual machine has started execution.

getUnmarshallerHandler() - Method in interface javax.xml.bind.Unmarshaller

Get an unmarshaller handler object that can be used as a component in an XML pipeline.

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in unnormalized form, given a normalized component array.

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in unnormalized form, given a normalized component array.

getUnresolvedActions() - Method in class java.security.UnresolvedPermission

Get the actions for the underlying permission that has not been resolved.

getUnresolvedCerts() - Method in class java.security.UnresolvedPermission

Get the signer certificates (without any supporting chain) for the underlying permission that has not been resolved.

getUnresolvedName() - Method in class java.security.UnresolvedPermission

Get the target name of the underlying permission that has not been resolved.

getUnresolvedType() - Method in class java.security.UnresolvedPermission

Get the type (class name) of the underlying permission that has not been resolved.

getUnsupportedAttributes() - Method in interface javax.print.AttributeException

Returns the array of printing attribute classes for which the Print Service instance does not support the attribute at all, or null if there are no such attributes.

getUnsupportedAttributes(DocFlavor, AttributeSet) - Method in interface javax.print.PrintService

Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.

getUnsupportedFlavors() - Method in interface javax.print.FlavorException

Returns the unsupported flavors.

getUnsupportedURI() - Method in interface javax.print.URIException

Return the URI.

getUnsupportedValues() - Method in interface javax.print.AttributeException

Returns the array of printing attributes for which the Print Service instance supports the attribute but does not support that particular value of the attribute, or null if there are no such attribute values.

getUnwrappedParent(Component) - Static method in class javax.swing.SwingUtilities

Returns the first ancestor of the component which is not an instance of JLayer.

getUnwrappedView(JViewport) - Static method in class javax.swing.SwingUtilities

Returns the first JViewport's descendant which is not an instance of JLayer.

getUpdateAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getUpdateCount() - Method in interface java.sql.Statement

Retrieves the current result as an update count; if the result is a ResultSet object or there are no more results, -1 is returned.

getUpdateCounts() - Method in exception java.sql.BatchUpdateException

Retrieves the update count for each update statement in the batch update that executed successfully before this exception occurred.

getUpdateLevel() - Method in class javax.swing.undo.UndoableEditSupport

Returns the update level value.

getUpdatePeriod() - Method in class javax.sound.sampled.FloatControl

Obtains the smallest time interval, in microseconds, over which the control's value can change during a shift.

getUpdatePolicy() - Method in class javax.swing.text.DefaultCaret

Gets the caret movement policy on document updates.

getUpdateRect() - Method in class java.awt.event.PaintEvent

Returns the rectangle representing the area which needs to be repainted in response to this event.

getUpdateSelectionOnSort() - Method in class javax.swing.JTable

Returns true if the selection should be updated after sorting.

getUpdateTableInRealTime() - Method in class javax.swing.table.JTableHeader

Obsolete as of Java 2 platform v1.3.

getUpperBound() - Method in interface javax.lang.model.type.TypeVariable

Returns the upper bound of this type variable.

getUpperBounds() - Method in interface java.lang.reflect.WildcardType

Returns an array of Type objects representing the upper bound(s) of this type variable.

getUptime() - Method in interface java.lang.management.RuntimeMXBean

Returns the uptime of the Java virtual machine in milliseconds.

getURI() - Method in class java.security.URIParameter

Returns the URI.

getURI() - Method in class javax.print.attribute.URISyntax

Returns this URI attribute's URI value.

getURI() - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod

Returns the URI of the referenced KeyInfo information.

getURI() - Method in class javax.xml.crypto.OctetStreamData

Returns the URI String identifying the data object represented by this OctetStreamData.

getURI() - Method in interface javax.xml.crypto.URIReference

Returns the URI of the referenced data object.

getURI() - Method in interface javax.xml.soap.Name

Returns the URI of the namespace for the XML name that this Name object represents.

getUri() - Method in interface org.w3c.dom.DOMLocator

The URI this locator is pointing to, or null if no URI is available.

getURI(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's Namespace URI by index.

getURI(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's Namespace URI.

getURI(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Look up a prefix and get the currently-mapped Namespace URI.

getURIDereferencer() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getURIDereferencer() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.

getURIDereferencer() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.

getURIDereferencer() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns a URIDereferencer that is used to dereference URIReferences.

getURIReference() - Method in exception javax.xml.crypto.URIReferenceException

Returns the URIReference that was being dereferenced when the exception was thrown.

getURIResolver() - Method in class javax.xml.transform.Transformer

Get an object that will be used to resolve URIs used in document().

getURIResolver() - Method in class javax.xml.transform.TransformerFactory

Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

getURIs() - Method in interface java.net.CookieStore

Get all URIs which identify the cookies in this cookie store.

getURL() - Method in class java.net.URLConnection

Returns the value of this URLConnection's URL field.

getURL(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATALINK parameter as a java.net.URL object.

getURL(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATALINK parameter as a java.net.URL object.

getURL() - Method in interface java.sql.DatabaseMetaData

Retrieves the URL for this DBMS.

getURL(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.net.URL object in the Java programming language.

getURL(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.net.URL object in the Java programming language.

getURL() - Method in class javax.activation.URLDataSource

Return the URL used to create this DataSource.

getUrl() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the JDBC URL that this RowSet object's javax.sql.Reader object uses to make a connection with a relational database using a JDBC technology-enabled driver.

getUrl() - Method in interface javax.sql.RowSet

Retrieves the url property this RowSet object will use to create a connection if it uses the DriverManager instead of a DataSource object to establish the connection.

getURL() - Method in class javax.swing.event.HyperlinkEvent

Gets the URL that the link refers to.

getURL() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getURL() - Method in interface javax.xml.bind.ValidationEventLocator

Return the name of the XML source as a URL if available

getURLContext(String, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates a context for the given URL scheme id.

getURLOrDefaultInitCtx(String) - Method in class javax.naming.InitialContext

Retrieves a context for resolving the string name name.

getURLOrDefaultInitCtx(Name) - Method in class javax.naming.InitialContext

Retrieves a context for resolving name.

getURLPath() - Method in class javax.management.remote.JMXServiceURL

The URL Path part of the Service URL.

getURLs() - Method in class java.net.URLClassLoader

Returns the search path of URLs for loading classes and resources.

getURLs() - Method in class javax.management.loading.MLet

Returns the search path of URLs for loading classes and resources.

getURLs() - Method in interface javax.management.loading.MLetMBean

Returns the search path of URLs for loading classes and resources.

getUsableSpace() - Method in class java.io.File

Returns the number of bytes available to this virtual machine on the partition named by this abstract pathname.

getUsableSpace() - Method in class java.nio.file.FileStore

Returns the number of bytes available to this Java virtual machine on the file store.

getUsage() - Method in class java.lang.management.MemoryNotificationInfo

Returns the memory usage of the memory pool when this notification was constructed.

getUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns an estimate of the memory usage of this memory pool.

getUsage() - Method in interface org.ietf.jgss.GSSCredential

Returns the credential usage mode.

getUsage(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the credential usage mode for a specific mechanism.

getUsageThreshold() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the usage threshold value of this memory pool in bytes.

getUsageThresholdCount() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the number of times that the memory usage has crossed the usage threshold.

getUseCache() - Static method in class javax.imageio.ImageIO

Returns the current value set by setUseCache, or true if no explicit setting has been made.

getUseCaches() - Method in class java.net.URLConnection

Returns the value of this URLConnection's useCaches field.

getUseClientMode() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine is set to use client mode when handshaking.

getUseClientMode() - Method in class javax.net.ssl.SSLServerSocket

Returns true if accepted connections will be in SSL client mode.

getUseClientMode() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket is set to use client mode when handshaking.

getUsed() - Method in class java.lang.management.MemoryUsage

Returns the amount of used memory in bytes.

getUseParentHandlers() - Method in class java.util.logging.Logger

Discover whether or not this logger is sending its output to its parent logger.

getUserAction() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the user drop action.

getUserData(String) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getUserData() - Method in class javax.management.Notification

Get the user data.

getUserData(String) - Method in interface org.w3c.dom.Node

Retrieves the object associated to a key on a this node.

getUserDropAction() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the user drop action for the drop, when this TransferSupport represents a drop.

getUserInfo() - Method in class java.net.URI

Returns the decoded user-information component of this URI.

getUserInfo() - Method in class java.net.URL

Gets the userInfo part of this URL.

getUserName() - Method in class java.awt.print.PrinterJob

Gets the name of the printing user.

getUserName() - Method in class java.net.PasswordAuthentication

Returns the user name.

getUserName() - Method in interface java.sql.DatabaseMetaData

Retrieves the user name as known to this database.

getUsername() - Method in class javax.sql.rowset.BaseRowSet

Returns the user name used to create a database connection.

getUsername() - Method in interface javax.sql.RowSet

Retrieves the username used to create a database connection for this RowSet object.

getUserObject() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the Object value associated with this node.

getUserObject() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's user object.

getUserObjectPath() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the user object path, from the root, to get to this node.

getUserPrincipal() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the Principal that represents the authenticated user for this HttpExchange.

getUserPrincipal() - Method in interface javax.xml.ws.WebServiceContext

Returns the Principal that identifies the sender of the request currently being serviced.

getUserPrincipalLookupService() - Method in class java.nio.file.FileSystem

Returns the UserPrincipalLookupService for this file system (optional operation).

getUserTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the user text color of the current theme.

getUserTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the user text color.

getUserTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the user text font.

getUserTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the user text font of the current theme.

getUserTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the user text font.

getUtf16Offset() - Method in interface org.w3c.dom.DOMLocator

The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

getVAdjustable() - Method in class java.awt.ScrollPane

Returns the ScrollPaneAdjustable object which represents the state of the vertical scrollbar.

getValidCharacters() - Method in class javax.swing.text.MaskFormatter

Returns the valid characters that can be input.

getValidPixels() - Method in class java.awt.image.IndexColorModel

Returns a BigInteger that indicates the valid/invalid pixels in the colormap.

getValidPolicy() - Method in interface java.security.cert.PolicyNode

Returns the valid policy represented by this node.

getValue() - Method in interface java.awt.Adjustable

Gets the current value of the adjustable object.

getValue() - Method in class java.awt.event.AdjustmentEvent

Returns the current value in the adjustment event.

getValue() - Method in class java.awt.Scrollbar

Gets the current value of this scroll bar.

getValue() - Method in class java.awt.ScrollPaneAdjustable

getValue() - Method in class java.beans.Expression

If the value property of this instance is not already set, this method dynamically finds the method with the specified methodName on this target with these arguments and calls it.

getValue(String) - Method in class java.beans.FeatureDescriptor

Retrieve a named attribute with this feature.

getValue() - Method in interface java.beans.PropertyEditor

Gets the property value.

getValue() - Method in class java.beans.PropertyEditorSupport

Gets the value of the property.

getValue() - Method in class java.net.HttpCookie

Returns the value of the cookie.

getValue() - Method in class java.rmi.dgc.Lease

Returns the lease duration.

getValue() - Method in interface java.security.cert.Extension

Gets the extensions's DER-encoded value.

getValue() - Method in class java.text.Annotation

Returns the value of the attribute, which may be null.

getValue() - Method in class java.util.AbstractMap.SimpleEntry

Returns the value corresponding to this entry.

getValue() - Method in class java.util.AbstractMap.SimpleImmutableEntry

Returns the value corresponding to this entry.

getValue(String) - Method in class java.util.jar.Attributes

Returns the value of the specified attribute name, specified as a string, or null if the attribute was not found.

getValue(Attributes.Name) - Method in class java.util.jar.Attributes

Returns the value of the specified Attributes.Name, or null if the attribute was not found.

getValue() - Method in interface java.util.Map.Entry

Returns the value corresponding to this entry.

getValue() - Method in class java.util.zip.Adler32

Returns the checksum value.

getValue() - Method in interface java.util.zip.Checksum

Returns the current checksum value.

getValue() - Method in class java.util.zip.CRC32

Returns CRC-32 value.

getValue() - Method in interface javax.annotation.processing.Completion

Returns the text of the suggested completion.

getValue() - Method in class javax.crypto.spec.PSource.PSpecified

Returns the value of encoding input P.

getValue() - Method in interface javax.lang.model.element.AnnotationValue

Returns the value.

getValue() - Method in class javax.management.Attribute

Returns an Object that is the value of this attribute.

getValue() - Method in class javax.management.StringValueExp

Returns the string represented by the StringValueExp instance.

getValue() - Method in class javax.naming.ldap.Rdn

Retrieves one of this Rdn's value.

getValue(String) - Method in interface javax.net.ssl.SSLSession

Returns the object bound to the given name in the session's application layer data.

getValue() - Method in class javax.print.attribute.DateTimeSyntax

Returns this date-time attribute's java.util.Date value.

getValue() - Method in class javax.print.attribute.EnumSyntax

Returns this enumeration value's integer value.

getValue() - Method in class javax.print.attribute.IntegerSyntax

Returns this integer attribute's integer value.

getValue() - Method in class javax.print.attribute.TextSyntax

Returns this text attribute's text string.

getValue() - Method in class javax.sound.sampled.BooleanControl

Obtains this control's current value.

getValue() - Method in class javax.sound.sampled.EnumControl

Obtains this control's current value.

getValue() - Method in class javax.sound.sampled.FloatControl

Obtains this control's current value.

getValue(String) - Method in class javax.swing.AbstractAction

Gets the Object associated with the specified key.

getValue(String) - Method in interface javax.swing.Action

Gets one of this object's properties using the associated key.

getValue() - Method in interface javax.swing.BoundedRangeModel

Returns the model's current value.

getValue() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's current value.

getValue() - Method in class javax.swing.JFormattedTextField

Returns the last valid value.

getValue() - Method in class javax.swing.JOptionPane

Returns the value the user has selected.

getValue() - Method in class javax.swing.JProgressBar

Returns the progress bar's current value from the BoundedRangeModel.

getValue() - Method in class javax.swing.JScrollBar

Returns the scrollbar's value.

getValue() - Method in class javax.swing.JSlider

Returns the slider's current value from the BoundedRangeModel.

getValue() - Method in class javax.swing.JSpinner

Returns the current value of the model, typically this value is displayed by the editor.

getValue(int) - Method in class javax.swing.RowFilter.Entry

Returns the value at the specified index.

getValue() - Method in class javax.swing.SpinnerDateModel

Returns the current element in this sequence of Dates.

getValue() - Method in class javax.swing.SpinnerListModel

Returns the current element of the sequence.

getValue() - Method in interface javax.swing.SpinnerModel

The current element of the sequence.

getValue() - Method in class javax.swing.SpinnerNumberModel

Returns the value of the current element of the sequence.

getValue() - Method in class javax.swing.Spring

Returns the current value of this Spring.

getValue() - Method in class javax.swing.text.html.Option

Convenience method to return the string associated with the value attribute.

getValue() - Method in class javax.swing.text.html.parser.AttributeList

getValue() - Method in class javax.xml.bind.JAXBElement

Return the content model and attribute values for this element.

getValue(Object) - Static method in class javax.xml.bind.JAXBIntrospector

Get the element value of a JAXB element.

getValue() - Method in interface javax.xml.crypto.dsig.XMLSignature.SignatureValue

Returns the signature value of this SignatureValue.

getValue() - Method in class javax.xml.soap.MimeHeader

Returns the value of this MimeHeader object.

getValue() - Method in interface javax.xml.soap.Node

Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.

getValue() - Method in interface javax.xml.stream.events.Attribute

Gets the normalized value of this attribute

getValue() - Method in interface org.w3c.dom.Attr

On retrieval, the value of the attribute is returned as a string.

getValue(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the value of an attribute in the list (by position).

getValue(String) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the value of an attribute in the list (by name).

getValue(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by index.

getValue(String, String) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by Namespace name.

getValue(String) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by XML qualified (prefixed) name.

getValue(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the value of an attribute (by position).

getValue(String) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the value of an attribute (by name).

getValue(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's value by index.

getValue(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's value by Namespace-qualified name.

getValue(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's value by qualified (prefixed) name.

getValueAt(int, int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the value at the specified index.

getValueAt(int, int) - Method in class javax.swing.JTable

Returns the cell value at row and column.

getValueAt(int, int) - Method in class javax.swing.table.DefaultTableModel

Returns an attribute value for the cell at row and column.

getValueAt(int, int) - Method in interface javax.swing.table.TableModel

Returns the value for the cell at columnIndex and rowIndex.

getValueClass() - Method in class javax.swing.text.DefaultFormatter

Returns that class that is used to create new Objects.

getValueContainsLiteralCharacters() - Method in class javax.swing.text.MaskFormatter

Returns true if stringToValue should return literal characters in the mask.

getValueCount() - Method in class javax.swing.RowFilter.Entry

Returns the number of values in the entry.

getValueIsAdjusting() - Method in class java.awt.event.AdjustmentEvent

Returns true if this is one of multiple adjustment events.

getValueIsAdjusting() - Method in class java.awt.Scrollbar

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in class java.awt.ScrollPaneAdjustable

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in interface javax.swing.BoundedRangeModel

Returns true if the current changes to the value property are part of a series of changes.

getValueIsAdjusting() - Method in class javax.swing.DefaultBoundedRangeModel

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in class javax.swing.DefaultListSelectionModel

Returns true if the selection is undergoing a series of changes.

getValueIsAdjusting() - Method in class javax.swing.event.ListSelectionEvent

Returns whether or not this is one in a series of multiple events, where changes are still being made.

getValueIsAdjusting() - Method in class javax.swing.JList

Returns the value of the selection model's isAdjusting property.

getValueIsAdjusting() - Method in class javax.swing.JScrollBar

True if the scrollbar knob is being dragged.

getValueIsAdjusting() - Method in class javax.swing.JSlider

Returns the valueIsAdjusting property from the model.

getValueIsAdjusting() - Method in interface javax.swing.ListSelectionModel

Returns true if the selection is undergoing a series of changes.

getValueNames() - Method in interface javax.net.ssl.SSLSession

Returns an array of the names of all the application layer data objects bound into the Session.

getValues() - Method in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

Returns an array of shorts containing the values arranged by increasing length of their corresponding codes.

getValues() - Method in class javax.sound.sampled.EnumControl

Returns the set of possible values for this control.

getValues() - Method in class javax.swing.text.html.parser.AttributeList

getVariant() - Method in class java.util.Locale

Returns the variant code for this locale.

getVariation() - Method in class java.awt.im.InputMethodHighlight

Returns the variation of the text range.

getVendor() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the name of the company who supplies the device.

getVendor() - Method in interface javax.sound.midi.Soundbank

Obtains a string naming the company that provides the sound bank

getVendor() - Method in class javax.sound.sampled.Mixer.Info

Obtains the vendor of the mixer.

getVendor() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the vendor name of this SyncProvider instance

getVendorName() - Method in class javax.imageio.spi.IIOServiceProvider

Returns the name of the vendor responsible for creating this service provider and its associated implementation.

getVerifyInputWhenFocusTarget() - Method in class javax.swing.JComponent

Returns the value that indicates whether the input verifier for the current focus owner will be called before this component requests focus.

getVersion() - Method in interface java.awt.font.OpenType

Returns the version of the OpenType font.

getVersion() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system version.

getVersion() - Method in class java.net.HttpCookie

Returns the version of the protocol this cookie complies with.

getVersion() - Method in class java.security.cert.X509Certificate

Gets the version (version number) value from the certificate.

getVersion() - Method in class java.security.cert.X509CRL

Gets the version (version number) value from the CRL.

getVersion() - Method in class java.security.Provider

Returns the version number for this provider.

getVersion() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the version.

getVersion() - Method in class javax.imageio.spi.IIOServiceProvider

Returns a string describing the version number of this service provider and its associated implementation.

getVersion() - Method in class javax.management.loading.MLetContent

Gets the value of the VERSION attribute of the MLET tag.

getVersion() - Method in interface javax.management.remote.rmi.RMIServer

The version of the RMI Connector Protocol understood by this connector server.

getVersion() - Method in class javax.management.remote.rmi.RMIServerImpl

getVersion() - Method in class javax.management.remote.rmi.RMIServerImpl_Stub

getVersion() - Method in class javax.security.cert.X509Certificate

Gets the version (version number) value from the certificate.

getVersion() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the version of the device.

getVersion() - Method in interface javax.sound.midi.Soundbank

Obtains the version string for the sound bank.

getVersion() - Method in class javax.sound.sampled.Mixer.Info

Obtains the version of the mixer.

getVersion() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the release version of this SyncProvider instance.

getVersion() - Method in interface javax.xml.stream.events.StartDocument

Returns the version of XML of this XML stream

getVersion() - Method in class javax.xml.stream.util.StreamReaderDelegate

getVersion() - Method in interface javax.xml.stream.XMLStreamReader

Get the xml version declared on the xml declaration Returns null if none was declared

getVersionColumns(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of a table's columns that are automatically updated when any value in a row is updated.

getVersionNumber() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key version number.

getVerticalAlignment() - Method in class javax.swing.AbstractButton

Returns the vertical alignment of the text and icon.

getVerticalAlignment() - Method in class javax.swing.JLabel

Returns the alignment of the label's contents along the Y axis.

getVerticalLegBuffer() - Method in class javax.swing.plaf.basic.BasicTreeUI

The vertical element of legs between nodes starts at the bottom of the parent node by default.

getVerticalScrollBar() - Method in class javax.swing.JScrollPane

Returns the vertical scroll bar that controls the viewports vertical view position.

getVerticalScrollBar() - Method in class javax.swing.ScrollPaneLayout

Returns the JScrollBar object that handles vertical scrolling.

getVerticalScrollBarPolicy() - Method in class javax.swing.JScrollPane

Returns the vertical scroll bar policy value.

getVerticalScrollBarPolicy() - Method in class javax.swing.ScrollPaneLayout

Returns the vertical scrollbar-display policy.

getVerticalSliderThumbIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getVerticalTextPosition() - Method in class javax.swing.AbstractButton

Returns the vertical position of the text relative to the icon.

getVerticalTextPosition() - Method in class javax.swing.JLabel

Returns the vertical position of the label's text, relative to its image.

getVetoableChangeListeners() - Method in class java.awt.KeyboardFocusManager

Returns an array of all the vetoable change listeners registered on this keyboard focus manager.

getVetoableChangeListeners(String) - Method in class java.awt.KeyboardFocusManager

Returns an array of all the VetoableChangeListeners associated with the named property.

getVetoableChangeListeners() - Method in class java.beans.VetoableChangeSupport

Returns an array of all the listeners that were added to the VetoableChangeSupport object with addVetoableChangeListener().

getVetoableChangeListeners(String) - Method in class java.beans.VetoableChangeSupport

Returns an array of all the listeners which have been associated with the named property.

getVetoableChangeListeners() - Method in class javax.swing.JComponent

Returns an array of all the vetoable change listeners registered on this component.

getVgap() - Method in class java.awt.BorderLayout

Returns the vertical gap between components.

getVgap() - Method in class java.awt.CardLayout

Gets the vertical gap between components.

getVgap() - Method in class java.awt.FlowLayout

Gets the vertical gap between components and between the components and the borders of the Container.

getVgap() - Method in class java.awt.GridLayout

Gets the vertical gap between components.

getView() - Method in class javax.swing.JLayer

Returns the JLayer's view component or null.

getView() - Method in class javax.swing.JViewport

Returns the JViewport's one child or null.

getView(int) - Method in class javax.swing.text.AsyncBoxView

Gets the nth child view.

getView(int) - Method in class javax.swing.text.CompositeView

Returns the n-th view in this container.

getView(int) - Method in class javax.swing.text.View

Gets the nth child view.

getView() - Method in interface org.w3c.dom.events.UIEvent

The view attribute identifies the AbstractView from which the event was generated.

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text.BoxView

Fetches the child view at the given coordinates.

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text.CompositeView

Fetches the child view at the given coordinates.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.CompositeView

Fetches the child view that represents the given position in the model.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.TableView

Fetches the child view that represents the given position in the model.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.TableView.TableRow

Fetches the child view that represents the given position in the model.

getViewAttributes(View) - Method in class javax.swing.text.html.StyleSheet

Fetches a set of attributes to use in the view for displaying.

getViewCount() - Method in class javax.swing.text.AsyncBoxView

Returns the number of views in this view.

getViewCount() - Method in class javax.swing.text.CompositeView

Returns the number of child views of this view.

getViewCount() - Method in class javax.swing.text.View

Returns the number of views in this view.

getViewFactory() - Method in class javax.swing.text.DefaultEditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.EditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.html.HTMLEditorKit

Fetch a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.StyledEditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.View

Fetches the ViewFactory implementation that is feeding the view hierarchy.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.AsyncBoxView

Returns the child view index representing the given position in the model.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.CompositeView

Returns the child view index representing the given position in the model.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.View

Returns the child view index representing the given position in the model.

getViewIndex(float, float, Shape) - Method in class javax.swing.text.View

Returns the child view index representing the given position in the view.

getViewIndexAtPoint(float, float, Shape) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetches the child view index at the given point.

getViewIndexAtPosition(int, Position.Bias) - Method in class javax.swing.text.AsyncBoxView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.CompositeView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.FlowView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.ZoneView

Returns the child view index representing the given position in the model.

getViewIndexAtVisualOffset(float) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Locate the view responsible for an offset into the box along the major axis.

getViewport() - Method in class javax.swing.JScrollPane

Returns the current JViewport.

getViewport() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that displays the scrollable contents.

getViewportBorder() - Method in class javax.swing.JScrollPane

Returns the Border object that surrounds the viewport.

getViewportBorderBounds() - Method in class javax.swing.JScrollPane

Returns the bounds of the viewport's border.

getViewportBorderBounds(JScrollPane) - Method in class javax.swing.ScrollPaneLayout

Deprecated.
As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().

getViewportSize() - Method in class java.awt.ScrollPane

Returns the current size of the scroll pane's view port.

getViewPosition() - Method in class javax.swing.JViewport

Returns the view coordinates that appear in the upper left hand corner of the viewport, or 0,0 if there's no view.

getViewRect() - Method in class javax.swing.JViewport

Returns a rectangle whose origin is getViewPosition and size is getExtentSize.

getViewRowCount() - Method in class javax.swing.DefaultRowSorter

Returns the number of rows in the view.

getViewRowCount() - Method in class javax.swing.RowSorter

Returns the number of rows in the view.

getViewSize() - Method in class javax.swing.JViewport

If the view's size hasn't been explicitly set, return the preferred size, otherwise return the view's current size.

getVisible() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getVisibleAmount().

getVisibleAdvance() - Method in class java.awt.font.TextLayout

Returns the advance of this TextLayout, minus trailing whitespace.

getVisibleAmount() - Method in interface java.awt.Adjustable

Gets the length of the proportional indicator.

getVisibleAmount() - Method in class java.awt.Scrollbar

Gets the visible amount of this scroll bar.

getVisibleAmount() - Method in class java.awt.ScrollPaneAdjustable

getVisibleAmount() - Method in class javax.swing.JScrollBar

Returns the scrollbar's extent, aka its "visibleAmount".

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the number of visible children for row.

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the number of visible children for row.

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the number of visible children for path.

getVisibleComponent() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getVisibleEditorRect() - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the allocation to give the root View.

getVisibleIndex() - Method in class java.awt.List

Gets the index of the item that was last made visible by the method makeVisible.

getVisibleNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings visible to this element.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePosition() - Method in class java.awt.event.InputMethodEvent

Gets the position that's most important to be visible.

getVisibleRect() - Method in class javax.swing.JComponent

Returns the Component's "visible rectangle" - the intersection of this component's visible rectangle, new Rectangle(0, 0, getWidth(), getHeight()), and all of its ancestors' visible rectangles.

getVisibleRowCount() - Method in class javax.swing.JList

Returns the value of the visibleRowCount property.

getVisibleRowCount() - Method in class javax.swing.JTree

Returns the number of rows that are displayed in the display area.

getVisualBounds() - Method in class java.awt.font.GlyphVector

Returns the visual bounds of this GlyphVector The visual bounds is the bounding box of the outline of this GlyphVector.

getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a path enclosing the visual selection in the specified range, extended to bounds.

getVisualHighlightShape(TextHitInfo, TextHitInfo) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the visual selection in the specified range, extended to the bounds.

getVisualOtherHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit on the opposite side of the specified hit's caret.

getVisualRepresentation(Transferable) - Method in class javax.swing.TransferHandler

Returns an object that establishes the look of a transfer.

getVMID() - Method in class java.rmi.dgc.Lease

Returns the client VMID associated with the lease.

getVmName() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation name.

getVmVendor() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation vendor.

getVmVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation version.

getVoiceStatus() - Method in interface javax.sound.midi.Synthesizer

Obtains the current status of the voices produced by this synthesizer.

getVolatileOffscreenBuffer(Component, int, int) - Method in class javax.swing.RepaintManager

Return a volatile offscreen buffer that should be used as a double buffer with the specified component c.

getVScrollbarWidth() - Method in class java.awt.ScrollPane

Returns the width that would be occupied by a vertical scrollbar, which is independent of whether it is currently displayed by the scroll pane or not.

getW() - Method in interface java.security.interfaces.ECPublicKey

Returns the public point W.

getW() - Method in class java.security.spec.ECPublicKeySpec

Returns the public point W.

getWaitedCount() - Method in class java.lang.management.ThreadInfo

Returns the total number of times that the thread associated with this ThreadInfo waited for notification.

getWaitedTime() - Method in class java.lang.management.ThreadInfo

Returns the approximate accumulated elapsed time (in milliseconds) that the thread associated with this ThreadInfo has waited for notification since thread contention monitoring is enabled.

getWaitingConsumerCount() - Method in class java.util.concurrent.LinkedTransferQueue

getWaitingConsumerCount() - Method in interface java.util.concurrent.TransferQueue

Returns an estimate of the number of consumers waiting to receive elements via BlockingQueue.take() or timed poll.

getWaitingThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Returns a collection containing those threads that may be waiting on this Condition.

getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing those threads that may be waiting on the given condition associated with this synchronizer.

getWaitingThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Returns a collection containing those threads that may be waiting on this Condition.

getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing those threads that may be waiting on the given condition associated with this synchronizer.

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks.ReentrantLock

Returns a collection containing those threads that may be waiting on the given condition associated with this lock.

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing those threads that may be waiting on the given condition associated with the write lock.

getWaitQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Returns an estimate of the number of threads waiting on this condition.

getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns an estimate of the number of threads waiting on the given condition associated with this synchronizer.

getWaitQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Returns an estimate of the number of threads waiting on this condition.

getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns an estimate of the number of threads waiting on the given condition associated with this synchronizer.

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks.ReentrantLock

Returns an estimate of the number of threads waiting on the given condition associated with this lock.

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns an estimate of the number of threads waiting on the given condition associated with the write lock.

getWantClientAuth() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine will request client authentication.

getWantClientAuth() - Method in class javax.net.ssl.SSLParameters

Returns whether client authentication should be requested.

getWantClientAuth() - Method in class javax.net.ssl.SSLServerSocket

Returns true if client authentication will be requested on newly accepted server-mode connections.

getWantClientAuth() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket will request client authentication.

getWantsInput() - Method in class javax.swing.JOptionPane

Returns the value of the wantsInput property.

getWarnings() - Method in interface java.sql.Connection

Retrieves the first warning reported by calls on this Connection object.

getWarnings() - Method in interface java.sql.ResultSet

Retrieves the first warning reported by calls on this ResultSet object.

getWarnings() - Method in interface java.sql.Statement

Retrieves the first warning reported by calls on this Statement object.

getWarningString() - Method in class java.awt.Window

Gets the warning string that is displayed with this window.

getWarningString() - Method in class javax.swing.JInternalFrame

Gets the warning string that is displayed with this internal frame.

getWeekdays() - Method in class java.text.DateFormatSymbols

Gets weekday strings.

getWeeksInWeekYear() - Method in class java.util.Calendar

Returns the number of weeks in the week year represented by this Calendar.

getWeeksInWeekYear() - Method in class java.util.GregorianCalendar

Returns the number of weeks in the week year represented by this GregorianCalendar.

getWeekYear() - Method in class java.util.Calendar

Returns the week year represented by this Calendar.

getWeekYear() - Method in class java.util.GregorianCalendar

Returns the week year represented by this GregorianCalendar.

getWestPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getWhatToShow() - Method in interface org.w3c.dom.ls.LSParserFilter

Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.

getWhatToShow() - Method in interface org.w3c.dom.ls.LSSerializerFilter

Tells the LSSerializer what types of nodes to show to the filter.

getWheelRotation() - Method in class java.awt.event.MouseWheelEvent

Returns the number of "clicks" the mouse wheel was rotated, as an integer.

getWhen() - Method in class java.awt.event.ActionEvent

Returns the timestamp of when this event occurred.

getWhen() - Method in class java.awt.event.InputEvent

Returns the difference in milliseconds between the timestamp of when this event occurred and midnight, January 1, 1970 UTC.

getWhen() - Method in class java.awt.event.InputMethodEvent

Returns the time stamp of when this event occurred.

getWhen() - Method in class java.awt.event.InvocationEvent

Returns the timestamp of when this event occurred.

getWhereClause() - Method in interface javax.sql.rowset.JoinRowSet

Return a SQL-like description of the WHERE clause being used in a JoinRowSet object.

getWhite() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the white color of the current theme.

getWhite() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the white color.

getWholeText() - Method in interface org.w3c.dom.Text

Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.

getWidth() - Method in class java.awt.Component

Returns the current width of this component.

getWidth() - Method in class java.awt.Dimension

Returns the width of this Dimension in double precision.

getWidth() - Method in class java.awt.DisplayMode

Returns the width of the display, in pixels.

getWidth() - Method in class java.awt.geom.Arc2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Arc2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Dimension2D

Returns the width of this Dimension in double precision.

getWidth() - Method in class java.awt.geom.Ellipse2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Ellipse2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Rectangle2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Rectangle2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RectangularShape

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.image.BufferedImage

Returns the width of the BufferedImage.

getWidth(ImageObserver) - Method in class java.awt.image.BufferedImage

Returns the width of the BufferedImage.

getWidth(ImageObserver) - Method in class java.awt.Image

Determines the width of the image.

getWidth() - Method in class java.awt.image.Kernel

Returns the width of this Kernel.

getWidth() - Method in class java.awt.image.PixelGrabber

Get the width of the pixel buffer (after adjusting for image width).

getWidth() - Method in class java.awt.image.Raster

Returns the width in pixels of the Raster.

getWidth() - Method in interface java.awt.image.renderable.RenderableImage

Gets the width in user coordinate space.

getWidth() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the width in user coordinate space.

getWidth() - Method in interface java.awt.image.RenderedImage

Returns the width of the RenderedImage.

getWidth() - Method in class java.awt.image.SampleModel

Returns the width in pixels.

getWidth() - Method in class java.awt.image.VolatileImage

Returns the width of the VolatileImage.

getWidth() - Method in class java.awt.print.PageFormat

Returns the width, in 1/72nds of an inch, of the page.

getWidth() - Method in class java.awt.print.Paper

Returns the width of the page in 1/72nds of an inch.

getWidth() - Method in class java.awt.Rectangle

Returns the width of the bounding Rectangle in double precision.

getWidth() - Method in exception java.util.IllegalFormatWidthException

Returns the width

getWidth(int) - Method in class javax.imageio.ImageReader

Returns the width in pixels of the given image within the input source.

getWidth(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the width of the printable area in the specified units.

getWidth() - Method in class javax.swing.JComponent

Returns the current width of this component.

getWidth() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the width property.

getWidth() - Method in class javax.swing.table.TableColumn

Returns the width of the TableColumn.

getWidth() - Method in class javax.swing.text.BoxView

Returns the current width of the box.

getWidthOfHighValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidthOfLowValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidthOfWidestLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidths() - Method in class java.awt.FontMetrics

Gets the advance widths of the first 256 characters in the Font.

getWildcardType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types

Returns a new wildcard type argument.

getWindingRule() - Method in class java.awt.geom.FlatteningPathIterator

Returns the winding rule for determining the interior of the path.

getWindingRule() - Method in class java.awt.geom.Path2D

Returns the fill style winding rule.

getWindingRule() - Method in interface java.awt.geom.PathIterator

Returns the winding rule for determining the interior of the path.

getWindow() - Method in class java.awt.event.WindowEvent

Returns the originator of the event.

getWindowAncestor(Component) - Static method in class javax.swing.SwingUtilities

Returns the first Window ancestor of c, or null if c is not contained inside a Window.

getWindowBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window background color of the current theme.

getWindowBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window background color.

getWindowDecorationStyle() - Method in class javax.swing.JRootPane

Returns a constant identifying the type of Window decorations the JRootPane is providing.

getWindowFocusListeners() - Method in class java.awt.Window

Returns an array of all the window focus listeners registered on this window.

getWindowListeners() - Method in class java.awt.Window

Returns an array of all the window listeners registered on this window.

getWindows() - Static method in class java.awt.Window

Returns an array of all Windows, both owned and ownerless, created by this application.

getWindowStateListeners() - Method in class java.awt.Window

Returns an array of all the window state listeners registered on this window.

getWindowTitleBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title background color of the current theme.

getWindowTitleBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title background color.

getWindowTitleFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the window title font.

getWindowTitleFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title font of the current theme.

getWindowTitleFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title font.

getWindowTitleForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title foreground color of the current theme.

getWindowTitleForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title foreground color.

getWindowTitleInactiveBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title inactive background color of the current theme.

getWindowTitleInactiveBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title inactive background color.

getWindowTitleInactiveForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title inactive foreground color of the current theme.

getWindowTitleInactiveForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title inactive foreground color.

getWordEnd(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the end of a word for the given location.

getWordInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for word breaks for the default locale.

getWordInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for word breaks for the given locale.

getWordInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for word breaks for the given locale.

getWordSize() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the word size in bits.

getWordStart(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the start of a word for the given model location.

getWrapSizeLimit(int, boolean, int) - Method in interface org.ietf.jgss.GSSContext

Used to determine limits on the size of the message that can be passed to wrap.

getWrapStyleWord() - Method in class javax.swing.JTextArea

Gets the style of wrapping used if the text area is wrapping lines.

getWritableParent() - Method in class java.awt.image.WritableRaster

Returns the parent WritableRaster (if any) of this WritableRaster, or else null.

getWritableTile(int, int) - Method in class java.awt.image.BufferedImage

Checks out a tile for writing.

getWritableTile(int, int) - Method in interface java.awt.image.WritableRenderedImage

Checks out a tile for writing.

getWritableTileIndices() - Method in class java.awt.image.BufferedImage

Returns an array of Point objects indicating which tiles are checked out for writing.

getWritableTileIndices() - Method in interface java.awt.image.WritableRenderedImage

Returns an array of Point objects indicating which tiles are checked out for writing.

getWriteHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of reentrant write holds on this lock by the current thread.

getWriteMethod() - Method in class java.beans.PropertyDescriptor

Gets the method that should be used to write the property value.

getWriter() - Method in interface javax.script.ScriptContext

Returns the Writer for scripts to use when displaying output.

getWriter() - Method in class javax.script.SimpleScriptContext

Returns the Writer for scripts to use when displaying output.

getWriter() - Method in class javax.swing.text.AbstractWriter

Returns the Writer that is used to output the content.

getWriter() - Method in class javax.xml.transform.stream.StreamResult

Get the character stream that was set with setWriter.

getWriterFileSuffixes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the file suffixes associated with the formats understood by the current set of registered writers.

getWriterFormatNames() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the informal format names understood by the current set of registered writers.

getWriterMIMETypes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the MIME types understood by the current set of registered writers.

getWriterServiceProviderName() - Method in class javax.imageio.spi.ImageTranscoderSpi

Returns the fully qualified class name of an ImageWriterSpi class that generates IIOMetadata objects that may be used as input to this transcoder.

getWSDLDocumentLocation() - Method in class javax.xml.ws.Service

Gets the location of the WSDL document for this Service.

getWSDLDocumentLocation() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the location of the WSDL document for this Service.

getX() - Method in class java.awt.Component

Returns the current x coordinate of the components origin.

getX() - Method in class java.awt.dnd.DragSourceEvent

This method returns the horizontal coordinate of the cursor location in screen coordinates at the moment this event occured, or zero if the cursor location is not specified for this event.

getX() - Method in class java.awt.event.MouseEvent

Returns the horizontal x position of the event relative to the source component.

getX() - Method in class java.awt.geom.Arc2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Arc2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Ellipse2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Ellipse2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Point2D.Double

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Point2D.Float

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Point2D

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Rectangle2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Rectangle2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RectangularShape

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.Point

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.Rectangle

Returns the X coordinate of the bounding Rectangle in double precision.

getX() - Method in interface java.security.interfaces.DSAPrivateKey

Returns the value of the private key, x.

getX() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the private key x.

getX() - Method in interface javax.crypto.interfaces.DHPrivateKey

Returns the private value, x.

getX() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the private value x.

getX(int) - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's X dimension in the given units as a floating-point value.

getX(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the x location of the origin of the printable area in the specified units.

getX() - Method in class javax.swing.JComponent

Returns the current x coordinate of the component's origin.

getX() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the x property.

getX1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D.Double

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D.Float

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the start point in double in precision.

getX1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the start point in double in precision.

getX1() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the start point in double in precision.

getX2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the end point in double precision.

getXAConnection() - Method in interface javax.sql.XADataSource

Attempts to establish a physical database connection that can be used in a distributed transaction.

getXAConnection(String, String) - Method in interface javax.sql.XADataSource

Attempts to establish a physical database connection, using the given user name and password.

getXAResource() - Method in interface javax.sql.XAConnection

Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.

getXMicrometers() - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's X dimension in units of micrometers (µm).

getXmlEncoding() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, the encoding of this document.

getXmlEncoding() - Method in interface org.w3c.dom.Entity

An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.

getXMLEventReader() - Method in class javax.xml.transform.stax.StAXSource

Get the XMLEventReader used by this StAXSource.

getXMLEventWriter() - Method in class javax.xml.transform.stax.StAXResult

Get the XMLEventWriter used by this StAXResult.

getXMLNode(Object) - Method in class javax.xml.bind.Binder

Gets the XML element associated with the given JAXB object.

getXMLReader() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Obtains a configured XMLReader.

getXMLReader() - Method in class javax.xml.parsers.SAXParser

Returns the XMLReader that is encapsulated by the implementation of this class.

getXMLReader() - Method in class javax.xml.transform.sax.SAXSource

Get the XMLReader to be used for the Source.

getXMLReporter() - Method in class javax.xml.stream.XMLInputFactory

The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

getXMLResolver() - Method in class javax.xml.stream.XMLInputFactory

The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

getXMLSchemaType() - Method in class javax.xml.datatype.Duration

Return the name of the XML Schema date/time type that this instance maps to.

getXMLSchemaType() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return the name of the XML Schema date/time type that this instance maps to.

getXmlStandalone() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, whether this document is standalone.

getXMLStreamReader() - Method in class javax.xml.transform.stax.StAXSource

Get the XMLStreamReader used by this StAXSource.

getXMLStreamWriter() - Method in class javax.xml.transform.stax.StAXResult

Get the XMLStreamWriter used by this StAXResult.

getXmlVersion() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, the version number of this document.

getXmlVersion() - Method in interface org.w3c.dom.Entity

An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.

getXMLVersion() - Method in interface org.xml.sax.ext.Locator2

Returns the version of XML used for the entity.

getXMLVersion() - Method in class org.xml.sax.ext.Locator2Impl

Returns the current value of the version property.

getXOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute horizontal x position of the event.

getXOrigin() - Method in class java.awt.image.Kernel

Returns the X origin of this Kernel.

getXPath() - Method in class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

Returns the XPath expression to be evaluated.

getXPathFunctionResolver() - Method in interface javax.xml.xpath.XPath

Return the current function resolver.

getXPathList() - Method in class javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec

Returns a list of one or more XPathType objects.

getXPathVariableResolver() - Method in interface javax.xml.xpath.XPath

Return the current variable resolver.

getY() - Method in class java.awt.Component

Returns the current y coordinate of the components origin.

getY() - Method in class java.awt.dnd.DragSourceEvent

This method returns the vertical coordinate of the cursor location in screen coordinates at the moment this event occured, or zero if the cursor location is not specified for this event.

getY() - Method in class java.awt.event.MouseEvent

Returns the vertical y position of the event relative to the source component.

getY() - Method in class java.awt.geom.Arc2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Arc2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Ellipse2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Ellipse2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Point2D.Double

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Point2D.Float

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Point2D

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Rectangle2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Rectangle2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RectangularShape

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.Point

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.Rectangle

Returns the Y coordinate of the bounding Rectangle in double precision.

getY() - Method in interface java.security.interfaces.DSAPublicKey

Returns the value of the public key, y.

getY() - Method in class java.security.spec.DSAPublicKeySpec

Returns the public key y.

getY() - Method in interface javax.crypto.interfaces.DHPublicKey

Returns the public value, y.

getY() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the public value y.

getY(int) - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's Y dimension in the given units as a floating-point value.

getY(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the y location of the origin of the printable area in the specified units.

getY() - Method in class javax.swing.JComponent

Returns the current y coordinate of the component's origin.

getY() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the y property.

getY1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the start point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the end point in double precision.

getYear() - Method in class java.sql.Time

Deprecated.

getYear() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.YEAR) - 1900.

getYear() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.

getYears() - Method in class javax.xml.datatype.Duration

Get the years value of this Duration as an int or 0 if not present.

getYMicrometers() - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's Y dimension in units of micrometers (µm).

getYOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute vertical y position of the event.

getYOrigin() - Method in class java.awt.image.Kernel

Returns the Y origin of this Kernel.

getZeroDigit() - Method in class java.text.DecimalFormatSymbols

Gets the character used for zero.

getZoneStrings() - Method in class java.text.DateFormatSymbols

Gets time zone strings.

GIF - Static variable in class javax.print.DocFlavor.BYTE_ARRAY

Doc flavor with MIME type = "image/gif", print data representation class name = "[B" (byte array).

GIF - Static variable in class javax.print.DocFlavor.INPUT_STREAM

Doc flavor with MIME type = "image/gif", print data representation class name = "java.io.InputStream" (byte stream).

GIF - Static variable in class javax.print.DocFlavor.URL

Doc flavor with MIME type = "image/gif", print data representation class name = "java.net.URL".

GLAGOLITIC - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Glagolitic" Unicode character block.

GLASS_PANE - Static variable in class javax.accessibility.AccessibleRole

A pane that is guaranteed to be painted on top of all panes beneath it.

GLASS_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame

Bound property name.

glassPane - Variable in class javax.swing.JRootPane

The glass pane that overlays the menu bar and content pane, so it can intercept mouse movements and such.

glassPaneDispatcher - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI

global - Static variable in class java.util.logging.Logger

Deprecated.
Initialization of this field is prone to deadlocks. The field must be initialized by the Logger class initialization which may cause deadlocks with the LogManager class initialization. In such cases two class initialization wait for each other to complete. The preferred way to get the global logger object is via the call Logger.getGlobal(). For compatibility with old JDK versions where the Logger.getGlobal() is not available use the call Logger.getLogger(Logger.GLOBAL_LOGGER_NAME) or Logger.getLogger("global").

GLOBAL_LOGGER_NAME - Static variable in class java.util.logging.Logger

GLOBAL_LOGGER_NAME is a name for the global logger.

GLOBAL_SCOPE - Static variable in interface javax.script.ScriptContext

GlobalScope attributes are visible to all engines created by same ScriptEngineFactory.

globalHierarchyLock - Static variable in interface java.beans.beancontext.BeanContext

This global lock is used by both BeanContext and BeanContextServices implementors to serialize changes in a BeanContext hierarchy and any service requests etc.

globalScope - Variable in class javax.script.SimpleScriptContext

This is the global scope bindings.

GlyphJustificationInfo - Class in java.awt.font

The GlyphJustificationInfo class represents information about the justification properties of a glyph.

GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float) - Constructor for class java.awt.font.GlyphJustificationInfo

Constructs information about the justification properties of a glyph.

GlyphMetrics - Class in java.awt.font

The GlyphMetrics class represents infomation for a single glyph.

GlyphMetrics(float, Rectangle2D, byte) - Constructor for class java.awt.font.GlyphMetrics

Constructs a GlyphMetrics object.

GlyphMetrics(boolean, float, float, Rectangle2D, byte) - Constructor for class java.awt.font.GlyphMetrics

Constructs a GlyphMetrics object.

GlyphVector - Class in java.awt.font

A GlyphVector object is a collection of glyphs containing geometric information for the placement of each glyph in a transformed coordinate space which corresponds to the device on which the GlyphVector is ultimately displayed.

GlyphVector() - Constructor for class java.awt.font.GlyphVector

GlyphView - Class in javax.swing.text

A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.

GlyphView(Element) - Constructor for class javax.swing.text.GlyphView

Constructs a new view wrapped on an element.

GlyphView.GlyphPainter - Class in javax.swing.text

A class to perform rendering of the glyphs.

GlyphView.GlyphPainter() - Constructor for class javax.swing.text.GlyphView.GlyphPainter

GMONTH - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gMonth.

GMONTHDAY - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.

GoodBreakWeight - Static variable in class javax.swing.text.View

The weight to indicate a view supports breaking, but better opportunities probably exist.

GOPHER - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Gopher Protocol.

GOT_FOCUS - Static variable in class java.awt.Event

A component gained the focus.

gotDefault - Variable in class javax.naming.InitialContext

Field indicating whether the initial context has been obtained by calling NamingManager.getInitialContext().

gotFocus(Event, Object) - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, replaced by processFocusEvent(FocusEvent).

GOTHIC - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gothic" Unicode character block.

grabFocus() - Method in class javax.swing.JComponent

Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window.

grabPixels() - Method in class java.awt.image.PixelGrabber

Request the Image or ImageProducer to start delivering pixels and wait for all of the pixels in the rectangle of interest to be delivered.

grabPixels(long) - Method in class java.awt.image.PixelGrabber

Request the Image or ImageProducer to start delivering pixels and wait for all of the pixels in the rectangle of interest to be delivered or until the specified timeout has elapsed.

GRADE_CHECK_ALL_AT_COMMIT - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a high level optimistic synchronization grade with respect to the originating data source.

GRADE_CHECK_MODIFIED_AT_COMMIT - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a low level optimistic synchronization grade with respect to the originating data source.

GRADE_LOCK_WHEN_LOADED - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates the most pessimistic synchronization grade with respect to the originating data source.

GRADE_LOCK_WHEN_MODIFIED - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a pessimistic synchronization grade with respect to the originating data source.

GRADE_NONE - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates that no synchronization with the originating data source is provided.

GradientPaint - Class in java.awt

The GradientPaint class provides a way to fill a Shape with a linear color gradient pattern.

GradientPaint(float, float, Color, float, float, Color) - Constructor for class java.awt.GradientPaint

Constructs a simple acyclic GradientPaint object.

GradientPaint(Point2D, Color, Point2D, Color) - Constructor for class java.awt.GradientPaint

Constructs a simple acyclic GradientPaint object.

GradientPaint(float, float, Color, float, float, Color, boolean) - Constructor for class java.awt.GradientPaint

Constructs either a cyclic or acyclic GradientPaint object depending on the boolean parameter.

GradientPaint(Point2D, Color, Point2D, Color, boolean) - Constructor for class java.awt.GradientPaint

Constructs either a cyclic or acyclic GradientPaint object depending on the boolean parameter.

GraphicAttribute - Class in java.awt.font

This class is used with the CHAR_REPLACEMENT attribute.

GraphicAttribute(int) - Constructor for class java.awt.font.GraphicAttribute

Constructs a GraphicAttribute.

Graphics - Class in java.awt

The Graphics class is the abstract base class for all graphics contexts that allow an application to draw onto components that are realized on various devices, as well as onto off-screen images.

Graphics() - Constructor for class java.awt.Graphics

Constructs a new Graphics object.

Graphics2D - Class in java.awt

This Graphics2D class extends the Graphics class to provide more sophisticated control over geometry, coordinate transformations, color management, and text layout.

Graphics2D() - Constructor for class java.awt.Graphics2D

Constructs a new Graphics2D object.

GraphicsConfigTemplate - Class in java.awt

The GraphicsConfigTemplate class is used to obtain a valid GraphicsConfiguration.

GraphicsConfigTemplate() - Constructor for class java.awt.GraphicsConfigTemplate

This class is an abstract class so only subclasses can be instantiated.

GraphicsConfiguration - Class in java.awt

The GraphicsConfiguration class describes the characteristics of a graphics destination such as a printer or monitor.

GraphicsConfiguration() - Constructor for class java.awt.GraphicsConfiguration

This is an abstract class that cannot be instantiated directly.

GraphicsDevice - Class in java.awt

The GraphicsDevice class describes the graphics devices that might be available in a particular graphics environment.

GraphicsDevice() - Constructor for class java.awt.GraphicsDevice

This is an abstract class that cannot be instantiated directly.

GraphicsDevice.WindowTranslucency - Enum in java.awt

Kinds of translucency supported by the underlying system.

GraphicsEnvironment - Class in java.awt

The GraphicsEnvironment class describes the collection of GraphicsDevice objects and Font objects available to a Java(tm) application on a particular platform.

GraphicsEnvironment() - Constructor for class java.awt.GraphicsEnvironment

This is an abstract class and cannot be instantiated directly.

gray - Static variable in class java.awt.Color

The color gray.

GRAY - Static variable in class java.awt.Color

The color gray.

GrayFilter - Class in javax.swing

An image filter that "disables" an image by turning it into a grayscale image, and brightening the pixels in the image.

GrayFilter(boolean, int) - Constructor for class javax.swing.GrayFilter

Constructs a GrayFilter object that filters a color image to a grayscale image.

GREATER - Static variable in class javax.xml.datatype.DatatypeConstants

Comparison result.

GREEK - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Greek and Coptic" Unicode character block.

GREEK_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Greek Extended" Unicode character block.

green - Static variable in class java.awt.Color

The color green.

GREEN - Static variable in class java.awt.Color

The color green.

GREENCOMPONENT - Static variable in class java.awt.color.ICC_ProfileRGB

Used to get a gamma value or TRC for the green component.

GregorianCalendar - Class in java.util

GregorianCalendar is a concrete subclass of Calendar and provides the standard calendar system used by most of the world.

GregorianCalendar() - Constructor for class java.util.GregorianCalendar

Constructs a default GregorianCalendar using the current time in the default time zone with the default locale.

GregorianCalendar(TimeZone) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the given time zone with the default locale.

GregorianCalendar(Locale) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the default time zone with the given locale.

GregorianCalendar(TimeZone, Locale) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the given time zone with the given locale.

GregorianCalendar(int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date set in the default time zone with the default locale.

GregorianCalendar(int, int, int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date and time set for the default time zone with the default locale.

GregorianCalendar(int, int, int, int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date and time set for the default time zone with the default locale.

GridBagConstraints - Class in java.awt

The GridBagConstraints class specifies constraints for components that are laid out using the GridBagLayout class.

GridBagConstraints() - Constructor for class java.awt.GridBagConstraints

Creates a GridBagConstraint object with all of its fields set to their default value.

GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int) - Constructor for class java.awt.GridBagConstraints

Creates a GridBagConstraints object with all of its fields set to the passed-in arguments.

GridBagLayout - Class in java.awt

The GridBagLayout class is a flexible layout manager that aligns components vertically, horizontally or along their baseline without requiring that the components be of the same size.

GridBagLayout() - Constructor for class java.awt.GridBagLayout

Creates a grid bag layout manager.

GridBagLayoutInfo - Class in java.awt

The GridBagLayoutInfo is an utility class for GridBagLayout layout manager.

gridColor - Variable in class javax.swing.JTable

The color of the grid.

gridheight - Variable in class java.awt.GridBagConstraints

Specifies the number of cells in a column for the component's display area.

GridLayout - Class in java.awt

The GridLayout class is a layout manager that lays out a container's components in a rectangular grid.

GridLayout() - Constructor for class java.awt.GridLayout

Creates a grid layout with a default of one column per component, in a single row.

GridLayout(int, int) - Constructor for class java.awt.GridLayout

Creates a grid layout with the specified number of rows and columns.

GridLayout(int, int, int, int) - Constructor for class java.awt.GridLayout

Creates a grid layout with the specified number of rows and columns.

gridwidth - Variable in class java.awt.GridBagConstraints

Specifies the number of cells in a row for the component's display area.

gridx - Variable in class java.awt.GridBagConstraints

Specifies the cell containing the leading edge of the component's display area, where the first cell in a row has gridx=0.

gridy - Variable in class java.awt.GridBagConstraints

Specifies the cell at the top of the component's display area, where the topmost cell has gridy=0.

group() - Method in class java.nio.channels.MembershipKey

Returns the multicast group for which this membership key was created.

group() - Method in interface java.nio.file.attribute.PosixFileAttributes

Returns the group owner of the file.

Group - Interface in java.security.acl

This interface is used to represent a group of principals.

group() - Method in class java.util.regex.Matcher

Returns the input subsequence matched by the previous match.

group(int) - Method in class java.util.regex.Matcher

Returns the input subsequence captured by the given group during the previous match operation.

group(String) - Method in class java.util.regex.Matcher

Returns the input subsequence captured by the given named-capturing group during the previous match operation.

group() - Method in interface java.util.regex.MatchResult

Returns the input subsequence matched by the previous match.

group(int) - Method in interface java.util.regex.MatchResult

Returns the input subsequence captured by the given group during the previous match operation.

group - Variable in class javax.swing.DefaultButtonModel

The button group that the button belongs to.

GROUP_BOX - Static variable in class javax.accessibility.AccessibleRole

A GROUP_BOX is a simple container that contains a border around it and contains components inside it.

groupCount() - Method in class java.util.regex.Matcher

Returns the number of capturing groups in this matcher's pattern.

groupCount() - Method in interface java.util.regex.MatchResult

Returns the number of capturing groups in this match result's pattern.

GROUPING_SEPARATOR - Static variable in class java.text.NumberFormat.Field

Constant identifying the grouping separator field.

GroupLayout - Class in javax.swing

GroupLayout is a LayoutManager that hierarchically groups components in order to position them in a Container.

GroupLayout(Container) - Constructor for class javax.swing.GroupLayout

Creates a GroupLayout for the specified Container.

GroupLayout.Alignment - Enum in javax.swing

Enumeration of the possible ways ParallelGroup can align its children.

GroupLayout.Group - Class in javax.swing

Group provides the basis for the two types of operations supported by GroupLayout: laying out components one after another (SequentialGroup) or aligned (ParallelGroup).

GroupLayout.ParallelGroup - Class in javax.swing

A Group that aligns and sizes it's children.

GroupLayout.SequentialGroup - Class in javax.swing

A Group that positions and sizes its elements sequentially, one after another.

GroupPrincipal - Interface in java.nio.file.attribute

A UserPrincipal representing a group identity, used to determine access rights to objects in a file system.

grow(int, int) - Method in class java.awt.Rectangle

Resizes the Rectangle both horizontally and vertically.

growAbsorb - Variable in class java.awt.font.GlyphJustificationInfo

If true, this glyph absorbs all extra space at this and lower priority levels when it grows.

growLeftLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the left side of this glyph can grow.

growPriority - Variable in class java.awt.font.GlyphJustificationInfo

The priority level of this glyph as it is growing.

growRightLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the right side of this glyph can grow.

GSSContext - Interface in org.ietf.jgss

This interface encapsulates the GSS-API security context and provides the security services that are available over the context.

GSSCredential - Interface in org.ietf.jgss

This interface encapsulates the GSS-API credentials for an entity.

GSSException - Exception in org.ietf.jgss

This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.

GSSException(int) - Constructor for exception org.ietf.jgss.GSSException

Creates a GSSException object with a specified major code.

GSSException(int, int, String) - Constructor for exception org.ietf.jgss.GSSException

Creates a GSSException object with the specified major code, minor code, and minor code textual explanation.

GSSManager - Class in org.ietf.jgss

This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.

GSSManager() - Constructor for class org.ietf.jgss.GSSManager

GSSName - Interface in org.ietf.jgss

This interface encapsulates a single GSS-API principal entity.

GT - Static variable in class javax.management.Query

A code representing the Query.gt(javax.management.ValueExp, javax.management.ValueExp) query.

gt(ValueExp, ValueExp) - Static method in class javax.management.Query

Returns a query expression that represents a "greater than" constraint on two values.

Guard - Interface in java.security

This interface represents a guard, which is an object that is used to protect access to another object.

GuardedObject - Class in java.security

A GuardedObject is an object that is used to protect access to another object.

GuardedObject(Object, Guard) - Constructor for class java.security.GuardedObject

Constructs a GuardedObject using the specified object and guard.

guardWithTest(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles

Makes a method handle which adapts a target method handle, by guarding it with a test, a boolean-valued method handle.

guardWithTest(MethodHandle, MethodHandle) - Method in class java.lang.invoke.SwitchPoint

Returns a method handle which always delegates either to the target or the fallback.

guessContentTypeFromName(String) - Static method in class java.net.URLConnection

Tries to determine the content type of an object, based on the specified "file" component of a URL.

guessContentTypeFromStream(InputStream) - Static method in class java.net.URLConnection

Tries to determine the type of an input stream based on the characters at the beginning of the input stream.

GUJARATI - Static variable in class java.awt.font.NumericShaper

Identifies the GUJARATI range and decimal base.

GUJARATI - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gujarati" Unicode character block.

GURMUKHI - Static variable in class java.awt.font.NumericShaper

Identifies the GURMUKHI range and decimal base.

GURMUKHI - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gurmukhi" Unicode character block.

GYEAR - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gYear.

GYEARMONTH - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.

GZIP - Static variable in class javax.print.attribute.standard.Compression

GNU zip compression technology described in RFC 1952.

GZIP_MAGIC - Static variable in class java.util.zip.GZIPInputStream

GZIP header magic number.

GZIPInputStream - Class in java.util.zip

This class implements a stream filter for reading compressed data in the GZIP file format.

GZIPInputStream(InputStream, int) - Constructor for class java.util.zip.GZIPInputStream

Creates a new input stream with the specified buffer size.

GZIPInputStream(InputStream) - Constructor for class java.util.zip.GZIPInputStream

Creates a new input stream with a default buffer size.

GZIPOutputStream - Class in java.util.zip

This class implements a stream filter for writing compressed data in the GZIP file format.

GZIPOutputStream(OutputStream, int) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with the specified buffer size.

GZIPOutputStream(OutputStream, int, boolean) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with the specified buffer size and flush mode.

GZIPOutputStream(OutputStream) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with a default buffer size.

GZIPOutputStream(OutputStream, boolean) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with a default buffer size and the specified flush mode.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

概述

软件包

类

使用

树

已过时

Index

帮助

Java™ Platform
Standard Ed. 7
草案 ea-b138

Prev Letter

Next Letter

框架

无框架

所有的类


H-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

h - Variable in class java.lang.reflect.Proxy
the invocation handler for this proxy instance.
H1 - Static variable in class javax.swing.text.html.HTML.Tag
H2 - Static variable in class javax.swing.text.html.HTML.Tag
H3 - Static variable in class javax.swing.text.html.HTML.Tag
H4 - Static variable in class javax.swing.text.html.HTML.Tag
H5 - Static variable in class javax.swing.text.html.HTML.Tag
H6 - Static variable in class javax.swing.text.html.HTML.Tag
HALFWIDTH_AND_FULLWIDTH_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Halfwidth and Fullwidth Forms" Unicode character block.
HALFWIDTH_KATAKANA - Static variable in class java.awt.im.InputSubset
Constant for the halfwidth katakana subset of the Unicode halfwidth and fullwidth forms character block.
HALIGN - Static variable in class javax.swing.text.html.HTML.Attribute
halt(int) - Method in class java.lang.Runtime
Forcibly terminates the currently running Java virtual machine.
HAND_CURSOR - Static variable in class java.awt.Cursor
The hand cursor type.
HAND_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.HAND_CURSOR.
handle(Callback[]) - Method in interface javax.security.auth.callback.CallbackHandler
Retrieve or display the information requested in the provided Callbacks.
handle(HttpExchange) - Method in class javax.xml.ws.spi.http.HttpHandler
Handles a given request and generates an appropriate response.
handle(short, String, Object, Node, Node) - Method in interface org.w3c.dom.UserDataHandler
This method is called whenever the node for which this handler is registered is imported or cloned.
handleComment(char[], int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
handleComment(char[], int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleComment(char[]) - Method in class javax.swing.text.html.parser.DocumentParser
handleComment(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when an HTML comment is encountered.
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Empty Tag.
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when an empty tag is encountered.
handleEndOfLineString(String) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
This is invoked after the stream has been parsed, but before flush.
handleEndOfLineString(String) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
This is invoked after the stream has been parsed, but before flush.
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle End Tag.
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when an end tag is encountered.
handleEOFInComment() - Method in class javax.swing.text.html.parser.Parser
handleError(String, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleError(int, String) - Method in class javax.swing.text.html.parser.DocumentParser
handleError(int, String) - Method in class javax.swing.text.html.parser.Parser
An error has occurred.
handleError(DOMError) - Method in interface org.w3c.dom.DOMErrorHandler
This method is called on the error handler when an error occurs.
handleEvent(Event) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1 replaced by processEvent(AWTEvent).
handleEvent(ValidationEvent) - Method in class javax.xml.bind.helpers.DefaultValidationEventHandler
handleEvent(ValidationEvent) - Method in class javax.xml.bind.util.ValidationEventCollector
handleEvent(ValidationEvent) - Method in interface javax.xml.bind.ValidationEventHandler
Receive notification of a validation warning or error.
handleEvent(Event) - Method in interface org.w3c.dom.events.EventListener
This method is called whenever an event occurs of the type for which the EventListener interface was registered.
handleExpandControlClick(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Messaged when the user clicks the particular row, this invokes toggleExpandState.
handleFault(C) - Method in interface javax.xml.ws.handler.Handler
The handleFault method is invoked for fault message processing.
handleGetObject(String) - Method in class java.util.ListResourceBundle
handleGetObject(String) - Method in class java.util.PropertyResourceBundle
handleGetObject(String) - Method in class java.util.ResourceBundle
Gets an object for the given key from this resource bundle.
handleJustify(float) - Method in class java.awt.font.TextLayout
Justify this layout.
handleKeySet() - Method in class java.util.ListResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleKeySet() - Method in class java.util.PropertyResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleKeySet() - Method in class java.util.ResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleMBeanUnregistration(ObjectName, String) - Method in interface javax.management.relation.Relation
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleMBeanUnregistration(ObjectName, String) - Method in class javax.management.relation.RelationSupport
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleMessage(C) - Method in interface javax.xml.ws.handler.Handler
The handleMessage method is invoked for normal processing of inbound and outbound messages.
handleNotification(NotificationListener, Notification, Object) - Method in class javax.management.NotificationBroadcasterSupport
This method is called by sendNotification for each listener in order to send the notification to that listener.
handleNotification(Notification, Object) - Method in interface javax.management.NotificationListener
Invoked when a JMX notification occurs.
handleNotification(Notification, Object) - Method in class javax.management.relation.RelationService
Invoked when a JMX notification occurs.
handleOption(String, Iterator<String>) - Method in class javax.tools.ForwardingJavaFileManager
handleOption(String, Iterator<String>) - Method in interface javax.tools.JavaFileManager
Handles one option.
Handler - Class in java.util.logging
A Handler object takes log messages from a Logger and exports them.
Handler() - Constructor for class java.util.logging.Handler
Default constructor.
Handler<C extends MessageContext> - Interface in javax.xml.ws.handler
The Handler interface is the base interface for JAX-WS handlers.
handler - Variable in class javax.xml.ws.spi.http.HttpContext
HandlerBase - Class in org.xml.sax
Deprecated.
This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
HandlerBase() - Constructor for class org.xml.sax.HandlerBase
Deprecated.
HandlerChain - Annotation Type in javax.jws
Associates the Web Service with an externally defined handler chain.
handleResponse(Response<T>) - Method in interface javax.xml.ws.AsyncHandler
Called when the response to an asynchronous operation is available.
HandlerResolver - Interface in javax.xml.ws.handler
HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Start Tag.
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when a start tag is encountered.
handleText(char[], int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Called by the parser to indicate a block of text was encountered.
handleText(char[], int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleText(char[]) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Text.
handleText(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when PCDATA is encountered.
handleTitle(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when an HTML title tag is encountered.
handshakeCompleted(HandshakeCompletedEvent) - Method in interface javax.net.ssl.HandshakeCompletedListener
This method is invoked on registered objects when a SSL handshake is completed.
HandshakeCompletedEvent - Class in javax.net.ssl
This event indicates that an SSL handshake completed on a given SSL connection.
HandshakeCompletedEvent(SSLSocket, SSLSession) - Constructor for class javax.net.ssl.HandshakeCompletedEvent
Constructs a new HandshakeCompletedEvent.
HandshakeCompletedListener - Interface in javax.net.ssl
This interface is implemented by any class which wants to receive notifications about the completion of an SSL protocol handshake on a given SSL connection.
HANGING_BASELINE - Static variable in class java.awt.font.GraphicAttribute
Aligns origin of graphic to hanging baseline of line.
HANGING_BASELINE - Static variable in class java.awt.Font
The baseline used in Devanigiri and similar scripts when laying out text.
HANGUL_COMPATIBILITY_JAMO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Compatibility Jamo" Unicode character block.
HANGUL_JAMO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo" Unicode character block.
HANGUL_JAMO_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo Extended-A" Unicode character block.
HANGUL_JAMO_EXTENDED_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo Extended-B" Unicode character block.
HANGUL_SYLLABLES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Syllables" Unicode character block.
HANJA - Static variable in class java.awt.im.InputSubset
Constant for all Han characters used in writing Korean, including a subset of the CJK unified ideographs as well as Korean Han characters that may be defined as surrogate characters.
HANUNOO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hanunoo" Unicode character block.
hardDriveIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
has_no_active_member() - Method in class org.omg.DynamicAny._DynUnionStub
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
has_no_active_member() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
hasAlpha() - Method in class java.awt.image.ColorModel
Returns whether or not alpha is supported in this ColorModel.
hasAnchoringBounds() - Method in class java.util.regex.Matcher
Queries the anchoring of region bounds for this matcher.
hasArray() - Method in class java.nio.Buffer
Tells whether or not this buffer is backed by an accessible array.
hasArray() - Method in class java.nio.ByteBuffer
Tells whether or not this buffer is backed by an accessible byte array.
hasArray() - Method in class java.nio.CharBuffer
Tells whether or not this buffer is backed by an accessible char array.
hasArray() - Method in class java.nio.DoubleBuffer
Tells whether or not this buffer is backed by an accessible double array.
hasArray() - Method in class java.nio.FloatBuffer
Tells whether or not this buffer is backed by an accessible float array.
hasArray() - Method in class java.nio.IntBuffer
Tells whether or not this buffer is backed by an accessible int array.
hasArray() - Method in class java.nio.LongBuffer
Tells whether or not this buffer is backed by an accessible long array.
hasArray() - Method in class java.nio.ShortBuffer
Tells whether or not this buffer is backed by an accessible short array.
hasAttribute(String) - Method in class javax.imageio.metadata.IIOMetadataNode
hasAttribute(String) - Method in interface org.w3c.dom.Element
Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
hasAttributeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode
Equivalent to hasAttribute(localName).
hasAttributeNS(String, String) - Method in interface org.w3c.dom.Element
Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
hasAttributes() - Method in class javax.imageio.metadata.IIOMetadataNode
hasAttributes() - Method in interface org.w3c.dom.Node
Returns whether this node (if it is an element) has any attributes.
hasBeenExpanded(TreePath) - Method in class javax.swing.JTree
Returns true if the node identified by the path has ever been expanded.
hasChanged() - Method in class java.util.Observable
Tests if this object has changed.
hasChildNodes() - Method in class javax.imageio.metadata.IIOMetadataNode
Returns true if this node has child nodes.
hasChildNodes() - Method in interface org.w3c.dom.Node
Returns whether this node has any children.
hasChildren - Variable in class javax.swing.JTree.DynamicUtilTreeNode
Does the this JTree have children? This property is currently not implemented.
hasContended() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads have ever contended to acquire this synchronizer; that is if an acquire method has ever blocked.
hasContended() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads have ever contended to acquire this synchronizer; that is if an acquire method has ever blocked.
hasController() - Method in class javax.imageio.IIOParam
Returns true if there is a controller installed for this IIOParam object.
hasController() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if there is a controller installed for this IIOMetadata object.
HasControls - Interface in javax.naming.ldap
This interface is for returning controls with objects returned in NamingEnumerations.
hasCustomComponents - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
This is set to true in validateComponent if a Component is contained in either the message or the buttons.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
hasDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified default value, or false otherwise.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
hasDetail() - Method in interface javax.xml.soap.SOAPFault
Returns true if this SOAPFault has a Detail subelement and false otherwise.
hasDynamicLocaleList() - Method in interface java.awt.im.spi.InputMethodDescriptor
Returns whether the list of available locales can change at runtime.
hasEntered - Variable in class javax.swing.plaf.basic.BasicComboPopup
hasEvents() - Method in class javax.xml.bind.util.ValidationEventCollector
Returns true if this event collector contains at least one ValidationEvent.
hasExpired() - Method in class java.net.HttpCookie
Reports whether this http cookie has expired or not.
hasExtensions() - Method in class java.security.cert.X509CRLEntry
Returns true if this CRL entry has extensions.
hasFault() - Method in interface javax.xml.soap.SOAPBody
Indicates whether a SOAPFault object exists in this SOAPBody object.
hasFeature(String, String) - Method in interface org.w3c.dom.DOMImplementation
Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.
hasFocus() - Method in class java.awt.Component
Returns true if this Component is the focus owner.
hasFocus - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
hasFocus - Variable in class javax.swing.tree.DefaultTreeCellRenderer
True if has focus.
hash(Object...) - Static method in class java.util.Objects
Generates a hash code for a sequence of input values.
hash(Object, int) - Method in class org.omg.CORBA.portable.Delegate
Returns an ORB-internal identifier (hashcode) for this object reference.
HashAttributeSet - Class in javax.print.attribute
Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.
HashAttributeSet() - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new, empty attribute set.
HashAttributeSet(Attribute) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the given attribute.
HashAttributeSet(Attribute[]) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given array.
HashAttributeSet(AttributeSet) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given set.
HashAttributeSet(Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new, empty attribute set, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(Attribute, Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the given attribute, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(Attribute[], Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(AttributeSet, Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the given interface.
hashCode() - Method in class java.awt.AlphaComposite
Returns the hashcode for this composite.
hashCode() - Method in class java.awt.AWTKeyStroke
Returns a numeric value for this object that is likely to be unique, making it a good choice as the index value in a hash table.
hashCode() - Method in class java.awt.BasicStroke
Returns the hashcode for this stroke.
hashCode() - Method in class java.awt.Color
Computes the hash code for this Color.
hashCode() - Method in class java.awt.datatransfer.DataFlavor
Returns hash code for this DataFlavor.
hashCode() - Method in class java.awt.Dimension
Returns the hash code for this Dimension.
hashCode() - Method in class java.awt.DisplayMode
Returns a hash code value for the object.
hashCode() - Method in class java.awt.font.FontRenderContext
Return a hashcode for this FontRenderContext.
hashCode() - Method in class java.awt.Font
Returns a hashcode for this Font.
hashCode() - Method in class java.awt.font.ImageGraphicAttribute
Returns a hashcode for this ImageGraphicAttribute.
hashCode() - Method in class java.awt.font.NumericShaper
Returns a hash code for this shaper.
hashCode() - Method in class java.awt.font.ShapeGraphicAttribute
Returns a hashcode for this ShapeGraphicAttribute.
hashCode() - Method in class java.awt.font.TextHitInfo
Returns the hash code.
hashCode() - Method in class java.awt.font.TextLayout
Returns the hash code of this TextLayout.
hashCode() - Method in class java.awt.font.TransformAttribute
hashCode() - Method in class java.awt.geom.AffineTransform
Returns the hashcode for this transform.
hashCode() - Method in class java.awt.geom.Arc2D
Returns the hashcode for this Arc2D.
hashCode() - Method in class java.awt.geom.Ellipse2D
Returns the hashcode for this Ellipse2D.
hashCode() - Method in class java.awt.geom.Point2D
Returns the hashcode for this Point2D.
hashCode() - Method in class java.awt.geom.Rectangle2D
Returns the hashcode for this Rectangle2D.
hashCode() - Method in class java.awt.geom.RoundRectangle2D
Returns the hashcode for this RoundRectangle2D.
hashCode() - Method in class java.awt.image.BandedSampleModel
hashCode() - Method in class java.awt.image.ColorModel
Returns the hash code for this ColorModel.
hashCode() - Method in class java.awt.image.ComponentSampleModel
hashCode() - Method in class java.awt.image.MultiPixelPackedSampleModel
hashCode() - Method in class java.awt.image.PixelInterleavedSampleModel
hashCode() - Method in class java.awt.image.SinglePixelPackedSampleModel
hashCode() - Method in class java.awt.Insets
Returns the hash code for this Insets.
hashCode() - Method in class java.awt.JobAttributes
Returns a hash code value for this JobAttributes.
hashCode() - Method in class java.awt.MenuShortcut
Returns the hashcode for this MenuShortcut.
hashCode() - Method in class java.awt.PageAttributes
Returns a hash code value for this PageAttributes.
hashCode() - Method in class java.awt.RenderingHints
Returns the hash code value for this RenderingHints.
hashCode() - Method in class java.awt.RenderingHints.Key
The hash code for all Key objects will be the same as the system identity code of the object as defined by the System.identityHashCode() method.
hashCode() - Method in class java.beans.IndexedPropertyDescriptor
Returns a hash code value for the object.
hashCode() - Method in class java.beans.PropertyDescriptor
Returns a hash code value for the object.
hashCode() - Method in class java.io.File
Computes a hash code for this abstract pathname.
hashCode() - Method in class java.io.FilePermission
Returns the hash code value for this object.
hashCode() - Method in interface java.lang.annotation.Annotation
Returns the hash code of this annotation, as defined below:
hashCode() - Method in class java.lang.Boolean
Returns a hash code for this Boolean object.
hashCode() - Method in class java.lang.Byte
Returns a hash code for this Byte; equal to the result of invoking intValue().
hashCode() - Method in class java.lang.Character
Returns a hash code for this Character; equal to the result of invoking charValue().
hashCode() - Method in class java.lang.Character.Subset
Returns the standard hash code as defined by the Object.hashCode() method.
hashCode() - Method in class java.lang.Double
Returns a hash code for this Double object.
hashCode() - Method in class java.lang.Enum
Returns a hash code for this enum constant.
hashCode() - Method in class java.lang.Float
Returns a hash code for this Float object.
hashCode() - Method in class java.lang.Integer
Returns a hash code for this Integer.
hashCode() - Method in class java.lang.invoke.MethodType
Returns the hash code value for this method type.
hashCode() - Method in class java.lang.Long
Returns a hash code for this Long.
hashCode() - Method in class java.lang.Object
Returns a hash code value for the object.
hashCode() - Method in class java.lang.软件包
Return the hash code computed from the package name.
hashCode() - Method in class java.lang.ProcessBuilder.Redirect
Returns a hash code value for this Redirect.
hashCode() - Method in class java.lang.reflect.Constructor
Returns a hashcode for this Constructor.
hashCode() - Method in class java.lang.reflect.字段
Returns a hashcode for this Field.
hashCode() - Method in class java.lang.reflect.方法
Returns a hashcode for this Method.
hashCode() - Method in class java.lang.Short
Returns a hash code for this Short; equal to the result of invoking intValue().
hashCode() - Method in class java.lang.StackTraceElement
Returns a hash code value for this stack trace element.
hashCode() - Method in class java.lang.String
Returns a hash code for this string.
hashCode() - Method in class java.math.BigDecimal
Returns the hash code for this BigDecimal.
hashCode() - Method in class java.math.BigInteger
Returns the hash code for this BigInteger.
hashCode() - Method in class java.math.MathContext
Returns the hash code for this MathContext.
hashCode() - Method in class java.net.HttpCookie
Return hash code of this http cookie.
hashCode() - Method in class java.net.Inet4Address
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.Inet6Address
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.InetAddress
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.InetSocketAddress
Returns a hashcode for this socket address.
hashCode() - Method in class java.net.InterfaceAddress
Returns a hashcode for this Interface address.
hashCode() - Method in class java.net.NetworkInterface
hashCode() - Method in class java.net.Proxy
Returns a hashcode for this Proxy.
hashCode() - Method in class java.net.SocketPermission
Returns the hash code value for this object.
hashCode() - Method in class java.net.URI
Returns a hash-code value for this URI.
hashCode() - Method in class java.net.URL
Creates an integer suitable for hash table indexing.
hashCode(URL) - Method in class java.net.URLStreamHandler
Provides the default hash calculation.
hashCode() - Method in class java.nio.ByteBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.CharBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.charset.Charset
Computes a hashcode for this charset.
hashCode() - Method in class java.nio.DoubleBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.file.attribute.AclEntry
Returns the hash-code value for this ACL entry.
hashCode() - Method in class java.nio.file.attribute.FileTime
Computes a hash code for this file time.
hashCode() - Method in interface java.nio.file.Path
Computes a hash code for this path.
hashCode() - Method in class java.nio.FloatBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.IntBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.LongBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.ShortBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.rmi.activation.ActivationDesc
Return the same hashCode for similar ActivationDescs.
hashCode() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Return identical values for similar CommandEnvironments.
hashCode() - Method in class java.rmi.activation.ActivationGroupDesc
Produce identical numbers for similar ActivationGroupDescs.
hashCode() - Method in class java.rmi.activation.ActivationGroupID
Returns a hashcode for the group's identifier.
hashCode() - Method in class java.rmi.activation.ActivationID
Returns a hashcode for the activation id.
hashCode() - Method in class java.rmi.dgc.VMID
Compute hash code for this VMID.
hashCode() - Method in class java.rmi.MarshalledObject
Return a hash code for this MarshalledObject.
hashCode() - Method in class java.rmi.server.ObjID
Returns the hash code value for this object identifier, the object number.
hashCode() - Method in class java.rmi.server.RemoteObject
Returns a hashcode for a remote object.
hashCode() - Method in class java.rmi.server.UID
Returns the hash code value for this UID.
hashCode() - Method in class java.security.AccessControlContext
Returns the hash code value for this context.
hashCode() - Method in class java.security.AllPermission
Returns the hash code value for this object.
hashCode() - Method in class java.security.BasicPermission
Returns the hash code value for this object.
hashCode() - Method in class java.security.cert.Certificate
Returns a hashcode value for this certificate from its encoded form.
hashCode() - Method in class java.security.cert.CertPath
Returns the hashcode for this certification path.
hashCode() - Method in class java.security.cert.X509CRL
Returns a hashcode value for this CRL from its encoded form.
hashCode() - Method in class java.security.cert.X509CRLEntry
Returns a hashcode value for this CRL entry from its encoded form.
hashCode() - Method in class java.security.CodeSigner
Returns the hash code value for this code signer.
hashCode() - Method in class java.security.CodeSource
Returns the hash code value for this object.
hashCode() - Method in class java.security.Identity
Deprecated.
Returns a hashcode for this identity.
hashCode() - Method in class java.security.Permission
Returns the hash code value for this Permission object.
hashCode() - Method in interface java.security.Principal
Returns a hashcode for this principal.
hashCode() - Method in class java.security.spec.ECFieldF2m
Returns a hash code value for this characteristic 2 finite field.
hashCode() - Method in class java.security.spec.ECFieldFp
Returns a hash code value for this prime finite field.
hashCode() - Method in class java.security.spec.ECPoint
Returns a hash code value for this elliptic curve point.
hashCode() - Method in class java.security.spec.EllipticCurve
Returns a hash code value for this elliptic curve.
hashCode() - Method in class java.security.Timestamp
Returns the hash code value for this timestamp.
hashCode() - Method in class java.security.UnresolvedPermission
Returns the hash code value for this object.
hashCode() - Method in interface java.sql.RowId
Returns a hash code value of this RowId object.
hashCode() - Method in class java.text.AttributedCharacterIterator.Attribute
Returns a hash code value for the object.
hashCode() - Method in class java.text.ChoiceFormat
Generates a hash code for the message format object.
hashCode() - Method in class java.text.Collator
Generates the hash code for this Collator.
hashCode() - Method in class java.text.DateFormat
Overrides hashCode
hashCode() - Method in class java.text.DateFormatSymbols
Override hashCode.
hashCode() - Method in class java.text.DecimalFormat
Overrides hashCode
hashCode() - Method in class java.text.DecimalFormatSymbols
Override hashCode.
hashCode() - Method in class java.text.FieldPosition
Returns a hash code for this FieldPosition.
hashCode() - Method in class java.text.MessageFormat
Generates a hash code for the message format object.
hashCode() - Method in class java.text.NumberFormat
Overrides hashCode
hashCode() - Method in class java.text.ParsePosition
Returns a hash code for this ParsePosition.
hashCode() - Method in class java.text.RuleBasedCollator
Generates the hash code for the table-based collation object
hashCode() - Method in class java.text.SimpleDateFormat
Returns the hash code value for this SimpleDateFormat object.
hashCode() - Method in class java.text.StringCharacterIterator
Computes a hashcode for this iterator.
hashCode() - Method in class java.util.AbstractList
Returns the hash code value for this list.
hashCode() - Method in class java.util.AbstractMap
Returns the hash code value for this map.
hashCode() - Method in class java.util.AbstractMap.SimpleEntry
Returns the hash code value for this map entry.
hashCode() - Method in class java.util.AbstractMap.SimpleImmutableEntry
Returns the hash code value for this map entry.
hashCode() - Method in class java.util.AbstractSet
Returns the hash code value for this set.
hashCode(long[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(int[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(short[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(char[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(byte[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(boolean[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(float[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(double[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(Object[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode() - Method in class java.util.BitSet
Returns the hash code value for this bit set.
hashCode() - Method in class java.util.Calendar
Returns a hash code for this calendar.
hashCode() - Method in interface java.util.Collection
Returns the hash code value for this collection.
hashCode() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the hash code value for this list.
hashCode() - Method in class java.util.Date
Returns a hash code value for this object.
hashCode() - Method in class java.util.GregorianCalendar
Generates the hash code for this GregorianCalendar object.
hashCode() - Method in class java.util.Hashtable
Returns the hash code value for this Map as per the definition in the Map interface.
hashCode() - Method in class java.util.IdentityHashMap
Returns the hash code value for this map.
hashCode() - Method in class java.util.jar.Attributes
Returns the hash code value for this Map.
hashCode() - Method in class java.util.jar.Attributes.Name
Computes the hash value for this attribute name.
hashCode() - Method in class java.util.jar.Manifest
Returns the hash code for this Manifest.
hashCode() - Method in interface java.util.List
Returns the hash code value for this list.
hashCode() - Method in class java.util.Locale
Override hashCode.
hashCode() - Method in class java.util.logging.Level
Generate a hashcode.
hashCode() - Method in interface java.util.Map.Entry
Returns the hash code value for this map entry.
hashCode() - Method in interface java.util.Map
Returns the hash code value for this map.
hashCode(Object) - Static method in class java.util.Objects
Returns the hash code of a non-null argument and 0 for a null argument.
hashCode() - Method in class java.util.PropertyPermission
Returns the hash code value for this object.
hashCode() - Method in interface java.util.Set
Returns the hash code value for this set.
hashCode() - Method in class java.util.SimpleTimeZone
Generates the hash code for the SimpleDateFormat object.
hashCode() - Method in class java.util.UUID
Returns a hash code for this UUID.
hashCode() - Method in class java.util.Vector
Returns the hash code value for this Vector.
hashCode() - Method in class java.util.zip.ZipEntry
Returns the hash code value for this entry.
hashCode() - Method in class javax.crypto.spec.RC2ParameterSpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.crypto.spec.RC5ParameterSpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.crypto.spec.SecretKeySpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.imageio.ImageTypeSpecifier
Returns the hash code for this ImageTypeSpecifier.
hashCode() - Method in interface javax.lang.model.element.Element
Obeys the general contract of Object.hashCode.
hashCode() - Method in interface javax.lang.model.element.Name
Obeys the general contract of Object.hashCode.
hashCode() - Method in interface javax.lang.model.type.TypeMirror
Obeys the general contract of Object.hashCode.
hashCode() - Method in class javax.management.Attribute
Returns a hash code value for this attribute.
hashCode() - Method in interface javax.management.Descriptor
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.ImmutableDescriptor
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.MBeanAttributeInfo
hashCode() - Method in class javax.management.MBeanConstructorInfo
hashCode() - Method in class javax.management.MBeanFeatureInfo
hashCode() - Method in class javax.management.MBeanInfo
hashCode() - Method in class javax.management.MBeanNotificationInfo
hashCode() - Method in class javax.management.MBeanOperationInfo
hashCode() - Method in class javax.management.MBeanParameterInfo
hashCode() - Method in class javax.management.MBeanPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.management.MBeanServerPermission
hashCode() - Method in class javax.management.modelmbean.DescriptorSupport
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.ObjectInstance
hashCode() - Method in class javax.management.ObjectName
Returns a hash code for this object name.
hashCode() - Method in class javax.management.openmbean.ArrayType
Returns the hash code value for this ArrayType instance.
hashCode() - Method in interface javax.management.openmbean.CompositeData
Returns the hash code value for this CompositeData instance.
hashCode() - Method in class javax.management.openmbean.CompositeDataSupport
Returns the hash code value for this CompositeDataSupport instance.
hashCode() - Method in class javax.management.openmbean.CompositeType
Returns the hash code value for this CompositeType instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns the hash code value for this OpenMBeanAttributeInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns the hash code value for this OpenMBeanConstructorInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns the hash code value for this OpenMBeanInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Returns the hash code value for this OpenMBeanInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the hash code value for this OpenMBeanOperationInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Returns the hash code value for this OpenMBeanOperationInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the hash code value for this OpenMBeanParameterInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the hash code value for this OpenMBeanParameterInfoSupport instance.
hashCode() - Method in class javax.management.openmbean.OpenType
hashCode() - Method in class javax.management.openmbean.SimpleType
Returns the hash code value for this SimpleType instance.
hashCode() - Method in interface javax.management.openmbean.TabularData
Returns the hash code value for this TabularData instance.
hashCode() - Method in class javax.management.openmbean.TabularDataSupport
Returns the hash code value for this TabularDataSupport instance.
hashCode() - Method in class javax.management.openmbean.TabularType
Returns the hash code value for this TabularType instance.
hashCode() - Method in class javax.management.remote.JMXPrincipal
Returns a hash code for this JMXPrincipal.
hashCode() - Method in class javax.management.remote.JMXServiceURL
hashCode() - Method in class javax.naming.BinaryRefAddr
Computes the hash code of this address using its address type and contents.
hashCode() - Method in class javax.naming.CompositeName
Computes the hash code of this composite name.
hashCode() - Method in class javax.naming.CompoundName
Computes the hash code of this compound name.
hashCode() - Method in class javax.naming.directory.BasicAttribute
Calculates the hash code of this attribute.
hashCode() - Method in class javax.naming.directory.BasicAttributes
Calculates the hash code of this BasicAttributes.
hashCode() - Method in class javax.naming.ldap.LdapName
Computes the hash code of this LDAP name.
hashCode() - Method in class javax.naming.ldap.Rdn
Returns the hash code of this RDN.
hashCode() - Method in class javax.naming.RefAddr
Computes the hash code of this address using its address type and contents.
hashCode() - Method in class javax.naming.Reference
Computes the hash code of this reference.
hashCode() - Method in interface javax.print.attribute.AttributeSet
Returns the hash code value for this attribute set.
hashCode() - Method in class javax.print.attribute.DateTimeSyntax
Returns a hash code value for this date-time attribute.
hashCode() - Method in class javax.print.attribute.EnumSyntax
Returns a hash code value for this enumeration value.
hashCode() - Method in class javax.print.attribute.HashAttributeSet
Returns the hash code value for this attribute set.
hashCode() - Method in class javax.print.attribute.IntegerSyntax
Returns a hash code value for this integer attribute.
hashCode() - Method in class javax.print.attribute.ResolutionSyntax
Returns a hash code value for this resolution attribute.
hashCode() - Method in class javax.print.attribute.SetOfIntegerSyntax
Returns a hash code value for this set-of-integer attribute.
hashCode() - Method in class javax.print.attribute.Size2DSyntax
Returns a hash code value for this two-dimensional size attribute.
hashCode() - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns a hash code value for this attribute.
hashCode() - Method in class javax.print.attribute.TextSyntax
Returns a hashcode for this text attribute.
hashCode() - Method in class javax.print.attribute.URISyntax
Returns a hashcode for this URI attribute.
hashCode() - Method in class javax.print.DocFlavor
Returns a hash code for this doc flavor object.
hashCode() - Method in interface javax.print.PrintService
This method should be implemented consistently with equals(Object).
hashCode() - Method in class javax.rmi.CORBA.Stub
Returns a hash code value for the object which is the same for all stubs that represent the same remote object.
hashCode(Stub) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.hashCode().
hashCode() - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Returns a hash code value for this SslRMIClientSocketFactory.
hashCode() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Returns a hash code value for this SslRMIServerSocketFactory.
hashCode() - Method in class javax.security.auth.kerberos.DelegationPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.kerberos.KerberosKey
Returns a hashcode for this KerberosKey.
hashCode() - Method in class javax.security.auth.kerberos.KerberosPrincipal
Returns a hashcode for this principal.
hashCode() - Method in class javax.security.auth.kerberos.KerberosTicket
Returns a hashcode for this KerberosTicket.
hashCode() - Method in class javax.security.auth.kerberos.ServicePermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.PrivateCredentialPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.Subject
Returns a hashcode for this Subject.
hashCode() - Method in class javax.security.auth.x500.X500Principal
Return a hash code for this X500Principal.
hashCode() - Method in class javax.security.cert.Certificate
Returns a hashcode value for this certificate from its encoded form.
hashCode() - Method in class javax.sound.midi.MidiDevice.Info
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.midi.Sequencer.SyncMode
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.AudioFileFormat.Type
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.AudioFormat.Encoding
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.Control.Type
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.LineEvent.Type
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.Mixer.Info
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.Port.Info
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.ReverbType
Finalizes the hashcode method.
hashCode() - Method in class javax.swing.RowSorter.SortKey
Returns the hash code for this SortKey.
hashCode() - Method in class javax.swing.text.html.HTML.UnknownTag
Returns the hash code which corresponds to the string for this tag.
hashCode() - Method in class javax.swing.text.SimpleAttributeSet
Returns a hashcode for this set of attributes.
hashCode() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Returns a hashcode for this set of attributes.
hashCode() - Method in class javax.swing.text.TabSet
Returns a hashcode for this set of TabStops.
hashCode() - Method in class javax.swing.text.TabStop
Returns the hashCode for the object.
hashCode() - Method in class javax.swing.tree.TreePath
Returns the hash code of this TreePath.
hashCode() - Method in class javax.xml.datatype.Duration
Returns a hash code consistent with the definition of the equals method.
hashCode() - Method in class javax.xml.datatype.XMLGregorianCalendar
Returns a hash code consistent with the definition of the equals method.
hashCode() - Method in class javax.xml.namespace.QName
Generate the hash code for this QName.
hashCode() - Method in class org.ietf.jgss.ChannelBinding
Returns a hashcode value for this ChannelBinding object.
hashCode() - Method in interface org.ietf.jgss.GSSCredential
Returns a hashcode value for this GSSCredential.
hashCode() - Method in interface org.ietf.jgss.GSSName
Returns a hashcode value for this GSSName.
hashCode() - Method in class org.ietf.jgss.Oid
Returns a hashcode value for this Oid.
hashCode(Object) - Method in class org.omg.CORBA.portable.Delegate
Provides the implementation to override the hashCode() method of the delegating CORBA object.
hashCode() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns the hash code for this ObjectImpl object.
HashDocAttributeSet - Class in javax.print.attribute
Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
HashDocAttributeSet() - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new, empty hash doc attribute set.
HashDocAttributeSet(DocAttribute) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new hash doc attribute set, initially populated with the given value.
HashDocAttributeSet(DocAttribute[]) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new hash doc attribute set, initially populated with the values from the given array.
HashDocAttributeSet(DocAttributeSet) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the DocAttribute interface.
HashMap<K,V> - Class in java.util
Hash table based implementation of the Map interface.
HashMap(int, float) - Constructor for class java.util.HashMap
Constructs an empty HashMap with the specified initial capacity and load factor.
HashMap(int) - Constructor for class java.util.HashMap
Constructs an empty HashMap with the specified initial capacity and the default load factor (0.75).
HashMap() - Constructor for class java.util.HashMap
Constructs an empty HashMap with the default initial capacity (16) and the default load factor (0.75).
HashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.HashMap
Constructs a new HashMap with the same mappings as the specified Map.
HashPrintJobAttributeSet - Class in javax.print.attribute
Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
HashPrintJobAttributeSet() - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new, empty hash print job attribute set.
HashPrintJobAttributeSet(PrintJobAttribute) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new hash print job attribute set, initially populated with the given value.
HashPrintJobAttributeSet(PrintJobAttribute[]) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new hash print job attribute set, initially populated with the values from the given array.
HashPrintJobAttributeSet(PrintJobAttributeSet) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintJobAttribute interface.
HashPrintRequestAttributeSet - Class in javax.print.attribute
Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
HashPrintRequestAttributeSet() - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new, empty print request attribute set.
HashPrintRequestAttributeSet(PrintRequestAttribute) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new print request attribute set, initially populated with the given value.
HashPrintRequestAttributeSet(PrintRequestAttribute[]) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new print request attribute set, initially populated with the values from the given array.
HashPrintRequestAttributeSet(PrintRequestAttributeSet) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the (PrintRequestAttributeSe interface.
HashPrintServiceAttributeSet - Class in javax.print.attribute
Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
HashPrintServiceAttributeSet() - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new, empty hash print service attribute set.
HashPrintServiceAttributeSet(PrintServiceAttribute) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new hash print service attribute set, initially populated with the given value.
HashPrintServiceAttributeSet(PrintServiceAttribute[]) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new print service attribute set, initially populated with the values from the given array.
HashPrintServiceAttributeSet(PrintServiceAttributeSet) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintServiceAttribute interface.
HashSet<E> - Class in java.util
This class implements the Set interface, backed by a hash table (actually a HashMap instance).
HashSet() - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has default initial capacity (16) and load factor (0.75).
HashSet(Collection<? extends E>) - Constructor for class java.util.HashSet
Constructs a new set containing the elements in the specified collection.
HashSet(int, float) - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has the specified initial capacity and the specified load factor.
HashSet(int) - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has the specified initial capacity and default load factor (0.75).
Hashtable<K,V> - Class in java.util
This class implements a hash table, which maps keys to values.
Hashtable(int, float) - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with the specified initial capacity and the specified load factor.
Hashtable(int) - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with the specified initial capacity and default load factor (0.75).
Hashtable() - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with a default initial capacity (11) and load factor (0.75).
Hashtable(Map<? extends K, ? extends V>) - Constructor for class java.util.Hashtable
Constructs a new hashtable with the same mappings as the given Map.
hasInitialContextFactoryBuilder() - Static method in class javax.naming.spi.NamingManager
Determines whether an initial context factory builder has been set.
hasInitialResponse() - Method in interface javax.security.sasl.SaslClient
Determines whether this mechanism has an optional initial response.
hasLayoutAttributes() - Method in class java.awt.Font
Return true if this Font contains attributes that require extra layout processing.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
hasLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified set of legal values, or false otherwise.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
hasListeners(String) - Method in class java.beans.PropertyChangeSupport
Check if there are any listeners for a specific property, including those registered on all properties.
hasListeners(String) - Method in class java.beans.VetoableChangeSupport
Check if there are any listeners for a specific property, including those registered on all properties.
hasLocation(JavaFileManager.Location) - Method in class javax.tools.ForwardingJavaFileManager
hasLocation(JavaFileManager.Location) - Method in interface javax.tools.JavaFileManager
Determines if a location is known to this file manager.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
hasMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified maximal value, or false otherwise.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
hasMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified minimal value, or false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
hasMore() - Method in interface javax.naming.NamingEnumeration
Determines whether there are any more elements in the enumeration.
hasMoreElements() - Method in interface java.util.Enumeration
Tests if this enumeration contains more elements.
hasMoreElements() - Method in class java.util.StringTokenizer
Returns the same value as the hasMoreTokens method.
hasMoreTokens() - Method in class java.util.StringTokenizer
Tests if there are more tokens available from this tokenizer's string.
hasName() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasName() - Method in interface javax.xml.stream.XMLStreamReader
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
hasNext() - Method in class java.beans.beancontext.BeanContextSupport.BCSIterator
hasNext() - Method in interface java.util.Iterator
Returns true if the iteration has more elements.
hasNext() - Method in interface java.util.ListIterator
Returns true if this list iterator has more elements when traversing the list in the forward direction.
hasNext() - Method in class java.util.Scanner
Returns true if this scanner has another token in its input.
hasNext(String) - Method in class java.util.Scanner
Returns true if the next token matches the pattern constructed from the specified string.
hasNext(Pattern) - Method in class java.util.Scanner
Returns true if the next complete token matches the specified pattern.
hasNext() - Method in class javax.xml.stream.util.EventReaderDelegate
hasNext() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasNext() - Method in interface javax.xml.stream.XMLEventReader
Check if there are more events.
hasNext() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if there are more parsing events and false if there are no more events.
hasNextBigDecimal() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigDecimal using the Scanner.nextBigDecimal() method.
hasNextBigInteger() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigInteger in the default radix using the Scanner.nextBigInteger() method.
hasNextBigInteger(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigInteger in the specified radix using the Scanner.nextBigInteger() method.
hasNextBoolean() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a boolean value using a case insensitive pattern created from the string "true|false".
hasNextByte() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a byte value in the default radix using the Scanner.nextByte() method.
hasNextByte(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a byte value in the specified radix using the Scanner.nextByte() method.
hasNextDouble() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a double value using the Scanner.nextDouble() method.
hasNextFloat() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a float value using the Scanner.nextFloat() method.
hasNextInt() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as an int value in the default radix using the Scanner.nextInt() method.
hasNextInt(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as an int value in the specified radix using the Scanner.nextInt() method.
hasNextLine() - Method in class java.util.Scanner
Returns true if there is another line in the input of this scanner.
hasNextLong() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a long value in the default radix using the Scanner.nextLong() method.
hasNextLong(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a long value in the specified radix using the Scanner.nextLong() method.
hasNextShort() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a short value in the default radix using the Scanner.nextShort() method.
hasNextShort(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a short value in the specified radix using the Scanner.nextShort() method.
hasPrevious() - Method in interface java.util.ListIterator
Returns true if this list iterator has more elements when traversing the list in the reverse direction.
hasPrimitives() - Method in class java.lang.invoke.MethodType
Reports if this type contains a primitive argument or return value.
hasQueuedPredecessors() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads have been waiting to acquire longer than the current thread.
hasQueuedPredecessors() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads have been waiting to acquire longer than the current thread.
hasQueuedSubmissions() - Method in class java.util.concurrent.ForkJoinPool
Returns true if there are any tasks submitted to this pool that have not yet begun executing.
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether the given thread is waiting to acquire this lock.
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether the given thread is waiting to acquire either the read or write lock.
hasQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads are waiting to acquire.
hasQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads are waiting to acquire.
hasQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether any threads are waiting to acquire this lock.
hasQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether any threads are waiting to acquire the read or write lock.
hasQueuedThreads() - Method in class java.util.concurrent.Semaphore
Queries whether any threads are waiting to acquire.
hasRaster() - Method in class javax.imageio.IIOImage
Returns true if this IIOImage stores a Raster rather than a RenderedImage.
hasRelation(String) - Method in class javax.management.relation.RelationService
Checks if there is a relation identified in Relation Service with given relation id.
hasRelation(String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if there is a relation identified in Relation Service with given relation id.
hasRemaining() - Method in class java.nio.Buffer
Tells whether there are any elements between the current position and the limit.
hasSameRules(TimeZone) - Method in class java.util.SimpleTimeZone
Returns true if this zone has the same rules and offset as another zone.
hasSameRules(TimeZone) - Method in class java.util.TimeZone
Returns true if this zone has the same rule and offset as another zone.
hasService(Class) - Method in interface java.beans.beancontext.BeanContextServices
Reports whether or not a given service is currently available from this context.
hasService(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport
has a service, which may be delegated
hasText() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasText() - Method in interface javax.xml.stream.XMLStreamReader
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
hasThumbnails(int) - Method in class javax.imageio.ImageReader
Returns true if the given image has thumbnail preview images associated with it.
hasTileWriters() - Method in class java.awt.image.BufferedImage
Returns whether or not any tile is checked out for writing.
hasTileWriters() - Method in interface java.awt.image.WritableRenderedImage
Returns whether any tile is checked out for writing.
hasTransparentBounds() - Method in class java.util.regex.Matcher
Queries the transparency of region bounds for this matcher.
hasUniformLineMetrics() - Method in class java.awt.Font
Checks whether or not this Font has uniform line metrics.
hasUniformLineMetrics() - Method in class java.awt.FontMetrics
Checks to see if the Font has uniform line metrics.
hasUnsupportedCriticalExtension() - Method in interface java.security.cert.X509Extension
Check if there is a critical extension that is not supported.
hasWaiters() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Queries whether any threads are waiting on this condition.
hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads are waiting on the given condition associated with this synchronizer.
hasWaiters() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Queries whether any threads are waiting on this condition.
hasWaiters(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads are waiting on the given condition associated with this synchronizer.
hasWaiters(Condition) - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether any threads are waiting on the given condition associated with this lock.
hasWaiters(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether any threads are waiting on the given condition associated with the write lock.
hasWaitingConsumer() - Method in class java.util.concurrent.LinkedTransferQueue
hasWaitingConsumer() - Method in interface java.util.concurrent.TransferQueue
Returns true if there is at least one consumer waiting to receive an element via BlockingQueue.take() or timed poll.
hasWrappers() - Method in class java.lang.invoke.MethodType
Reports if this type contains a wrapper argument or return value.
HEAD - Static variable in class javax.swing.text.html.HTML.Tag
head - Variable in class javax.swing.text.html.parser.DTD
HEADER - Static variable in class javax.accessibility.AccessibleRole
A text header
header - Variable in class javax.swing.plaf.basic.BasicTableHeaderUI
The JTableHeader that is delegating the painting to this UI.
HEADER_RENDERER_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
HEADER_ROW - Static variable in class javax.swing.event.TableModelEvent
Identifies the header row.
HEADER_VALUE_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
headerRenderer - Variable in class javax.swing.table.TableColumn
The renderer used to draw the header of the column.
headerValue - Variable in class javax.swing.table.TableColumn
The header value of the column.
HeadlessException - Exception in java.awt
Thrown when code that is dependent on a keyboard, display, or mouse is called in an environment that does not support a keyboard, display, or mouse.
HeadlessException() - Constructor for exception java.awt.HeadlessException
HeadlessException(String) - Constructor for exception java.awt.HeadlessException
headMap(K, boolean) - Method in interface java.util.concurrent.ConcurrentNavigableMap
headMap(K) - Method in interface java.util.concurrent.ConcurrentNavigableMap
headMap(K, boolean) - Method in class java.util.concurrent.ConcurrentSkipListMap
headMap(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
headMap(K, boolean) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are less than (or equal to, if inclusive is true) toKey.
headMap(K) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are strictly less than toKey.
headMap(K) - Method in interface java.util.SortedMap
Returns a view of the portion of this map whose keys are strictly less than toKey.
headMap(K, boolean) - Method in class java.util.TreeMap
headMap(K) - Method in class java.util.TreeMap
HEADPHONE - Static variable in class javax.sound.sampled.Port.Info
A type of port that sends audio to a headphone jack.
headSet(E, boolean) - Method in class java.util.concurrent.ConcurrentSkipListSet
headSet(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
headSet(E, boolean) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are less than (or equal to, if inclusive is true) toElement.
headSet(E) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are strictly less than toElement.
headSet(E) - Method in interface java.util.SortedSet
Returns a view of the portion of this set whose elements are strictly less than toElement.
headSet(E, boolean) - Method in class java.util.TreeSet
headSet(E) - Method in class java.util.TreeSet
heavyWeightPopupEnabled - Variable in class javax.swing.ToolTipManager
HEBREW - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hebrew" Unicode character block.
height - Variable in class java.awt.Component.BltBufferStrategy
height - Variable in class java.awt.Dimension
The height dimension; negative values can be used.
height - Variable in class java.awt.geom.Arc2D.Double
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
height - Variable in class java.awt.geom.Arc2D.Float
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
height - Variable in class java.awt.geom.Ellipse2D.Double
The overall height of the Ellipse2D.
height - Variable in class java.awt.geom.Ellipse2D.Float
The overall height of this Ellipse2D.
height - Variable in class java.awt.geom.Rectangle2D.Double
The height of this Rectangle2D.
height - Variable in class java.awt.geom.Rectangle2D.Float
The height of this Rectangle2D.
height - Variable in class java.awt.geom.RoundRectangle2D.Double
The height of this RoundRectangle2D.
height - Variable in class java.awt.geom.RoundRectangle2D.Float
The height of this RoundRectangle2D.
HEIGHT - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that the height of the base image is now available and can be taken from the height argument to the imageUpdate callback method.
height - Variable in class java.awt.image.Raster
The height of this Raster.
height - Variable in class java.awt.image.SampleModel
Height in pixels of the region of image data that this SampleModel describes.
height - Variable in class java.awt.Rectangle
The height of the Rectangle.
height(Component) - Static method in class javax.swing.Spring
Returns a spring whose minimum, preferred, maximum and value properties are defined by the heights of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
HEIGHT - Static variable in class javax.swing.SpringLayout
Specifies the height of a component's bounding rectangle.
HEIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
HEIGHT - Static variable in class javax.swing.text.html.HTML.Attribute
helpButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpQuiesce() - Static method in class java.util.concurrent.ForkJoinTask
Possibly executes tasks until the pool hosting the current task is quiescent.
HexBinaryAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter for xs:hexBinary.
HexBinaryAdapter() - Constructor for class javax.xml.bind.annotation.adapters.HexBinaryAdapter
hiddenDivider - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Divider that is used for noncontinuous layout mode.
hide() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setVisible(boolean).
hide() - Method in class java.awt.Dialog
Deprecated.
As of JDK version 1.5, replaced by setVisible(boolean).
hide() - Method in class java.awt.Window
Deprecated.
As of JDK version 1.5, replaced by Window.setVisible(boolean).
hide() - Method in class javax.swing.JInternalFrame
hide() - Method in class javax.swing.plaf.basic.BasicComboPopup
Implementation of ComboPopup.hide().
hide() - Method in interface javax.swing.plaf.basic.ComboPopup
Hides the popup
hide() - Method in class javax.swing.Popup
Hides and disposes of the Popup.
HIDE_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The hide-window default window close operation
hidePopup() - Method in class javax.swing.JComboBox
Causes the combo box to close its popup window.
hides(Element, Element) - Method in interface javax.lang.model.util.Elements
Tests whether one type, method, or field hides another.
hideWindows() - Method in interface java.awt.im.spi.InputMethod
Closes or hides all windows opened by this input method instance or its class.
HIERARCHY_BOUNDS_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting hierarchy bounds events.
HIERARCHY_CHANGED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating that modification was made to the entire hierarchy tree.
HIERARCHY_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting hierarchy events.
HIERARCHY_FIRST - Static variable in class java.awt.event.HierarchyEvent
Marks the first integer id for the range of hierarchy event ids.
HIERARCHY_LAST - Static variable in class java.awt.event.HierarchyEvent
Marks the last integer id for the range of ancestor event ids.
HIERARCHY_REQUEST_ERR - Static variable in exception org.w3c.dom.DOMException
If any Node is inserted somewhere it doesn't belong.
HierarchyBoundsAdapter - Class in java.awt.event
An abstract adapter class for receiving ancestor moved and resized events.
HierarchyBoundsAdapter() - Constructor for class java.awt.event.HierarchyBoundsAdapter
HierarchyBoundsListener - Interface in java.awt.event
The listener interface for receiving ancestor moved and resized events.
hierarchyChanged(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the hierarchyChanged event by invoking the hierarchyChanged methods on listener-a and listener-b.
hierarchyChanged(HierarchyEvent) - Method in interface java.awt.event.HierarchyListener
Called when the hierarchy has been changed.
HierarchyEvent - Class in java.awt.event
An event which indicates a change to the Component hierarchy to which Component belongs.
HierarchyEvent(Component, int, Component, Container) - Constructor for class java.awt.event.HierarchyEvent
Constructs an HierarchyEvent object to identify a change in the Component hierarchy.
HierarchyEvent(Component, int, Component, Container, long) - Constructor for class java.awt.event.HierarchyEvent
Constructs an HierarchyEvent object to identify a change in the Component hierarchy.
HierarchyListener - Interface in java.awt.event
The listener interface for receiving hierarchy changed events.
HIGH - Static variable in class java.awt.PageAttributes.PrintQualityType
The PrintQualityType instance to use for specifying a high print quality.
HIGH - Static variable in class javax.print.attribute.standard.PrintQuality
Highest quality available on the printer.
HIGH_PRIVATE_USE_SURROGATES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "High Private Use Surrogates" Unicode character block.
HIGH_SURROGATES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "High Surrogates" Unicode character block.
higher(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
higher(E) - Method in interface java.util.NavigableSet
Returns the least element in this set strictly greater than the given element, or null if there is no such element.
higher(E) - Method in class java.util.TreeSet
higherEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key strictly greater than the given key, or null if there is no such key.
higherEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key strictly greater than the given key, or null if there is no such key.
higherEntry(K) - Method in class java.util.TreeMap
higherKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
higherKey(K) - Method in interface java.util.NavigableMap
Returns the least key strictly greater than the given key, or null if there is no such key.
higherKey(K) - Method in class java.util.TreeMap
highestLayer() - Method in class javax.swing.JLayeredPane
Returns the highest layer value from all current children.
highestOneBit(int) - Static method in class java.lang.Integer
Returns an int value with at most a single one-bit, in the position of the highest-order ("leftmost") one-bit in the specified int value.
highestOneBit(long) - Static method in class java.lang.Long
Returns a long value with at most a single one-bit, in the position of the highest-order ("leftmost") one-bit in the specified long value.
highlight - Variable in class javax.swing.border.EtchedBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
highlight - Variable in class javax.swing.plaf.basic.BasicSeparatorUI
highlight - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
highlightColor - Static variable in class javax.swing.plaf.metal.MetalSliderUI
Highlighter - Interface in javax.swing.text
An interface for an object that allows one to mark up the background with colored areas.
Highlighter.Highlight - Interface in javax.swing.text
Highlighter.HighlightPainter - Interface in javax.swing.text
Highlight renderer.
highlightInner - Variable in class javax.swing.border.BevelBorder
highlightOuter - Variable in class javax.swing.border.BevelBorder
highSurrogate(int) - Static method in class java.lang.Character
Returns the leading surrogate (a high surrogate code unit) of the surrogate pair representing the specified supplementary character (Unicode code point) in the UTF-16 encoding.
HINTS_OBSERVED - Static variable in interface java.awt.image.renderable.RenderableImage
String constant that can be used to identify a property on a RenderedImage obtained via the createRendering or createScaledRendering methods.
HIRAGANA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hiragana" Unicode character block.
hit(Rectangle, Shape, boolean) - Method in class java.awt.Graphics2D
Checks whether or not the specified Shape intersects the specified Rectangle, which is in device space.
hitClip(int, int, int, int) - Method in class java.awt.Graphics
Returns true if the specified rectangular area might intersect the current clipping area.
hitEnd() - Method in class java.util.regex.Matcher
Returns true if the end of input was hit by the search engine in the last match operation performed by this matcher.
hitTestChar(float, float, Rectangle2D) - Method in class java.awt.font.TextLayout
Returns a TextHitInfo corresponding to the specified point.
hitTestChar(float, float) - Method in class java.awt.font.TextLayout
Returns a TextHitInfo corresponding to the specified point.
hitToPoint(TextHitInfo, Point2D) - Method in class java.awt.font.TextLayout
Convert a hit to a point in standard coordinates.
HMAC_SHA1 - Static variable in interface javax.xml.crypto.dsig.SignatureMethod
The HMAC-SHA1 MAC signature method algorithm URI
HMACParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the XML Signature HMAC Algorithm.
HMACParameterSpec(int) - Constructor for class javax.xml.crypto.dsig.spec.HMACParameterSpec
Creates an HMACParameterSpec with the specified truncation length.
HOLD_CURSORS_OVER_COMMIT - Static variable in interface java.sql.ResultSet
The constant indicating that open ResultSet objects with this holdability will remain open when the current transaction is commited.
hold_requests(boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.
Holder<T> - Class in javax.xml.ws
Holds a value of type T.
Holder() - Constructor for class javax.xml.ws.Holder
Creates a new holder with a null value.
Holder(T) - Constructor for class javax.xml.ws.Holder
Create a new holder with the specified value.
HOLDING - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/HOLDING.java .
HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
holdsLock(Object) - Static method in class java.lang.Thread
Returns true if and only if the current thread holds the monitor lock on the specified object.
HOME - Static variable in class java.awt.Event
The Home key, a non-ASCII action key.
homeFolderIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
homeKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
HONOR_DISPLAY_PROPERTIES - Static variable in class javax.swing.JEditorPane
Key for a client property used to indicate whether the default font and foreground color from the component are used if a font or foreground color is not specified in the styled text.
HORIZONTAL - Static variable in interface java.awt.Adjustable
Indicates that the Adjustable has horizontal orientation.
HORIZONTAL - Static variable in class java.awt.GridBagConstraints
Resize the component horizontally but not vertically.
HORIZONTAL - Static variable in class java.awt.Scrollbar
A constant that indicates a horizontal scroll bar.
HORIZONTAL - Static variable in class javax.accessibility.AccessibleState
Indicates the orientation of this object is horizontal.
HORIZONTAL - Static variable in interface javax.swing.SwingConstants
Horizontal orientation.
HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's horizontal alignment.
HORIZONTAL_CENTER - Static variable in class javax.swing.SpringLayout
Specifies the horizontal center of a component's bounding rectangle.
HORIZONTAL_SCROLLBAR - Static variable in interface javax.swing.ScrollPaneConstants
Identifies a horizonal scrollbar.
HORIZONTAL_SCROLLBAR_ALWAYS - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are always displayed.
HORIZONTAL_SCROLLBAR_AS_NEEDED - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are displayed only when needed.
HORIZONTAL_SCROLLBAR_NEVER - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are never displayed.
HORIZONTAL_SCROLLBAR_POLICY - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the horizontal scroll bar policy property.
HORIZONTAL_SPLIT - Static variable in class javax.swing.JSplitPane
Horizontal split indicates the Components are split along the x axis.
HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's horizontal text position.
HORIZONTAL_WRAP - Static variable in class javax.swing.JList
Indicates a "newspaper style" layout with cells flowing horizontally then vertically.
horizontalScrollBar - Variable in class javax.swing.JScrollPane
The scrollpane's horizontal scrollbar child.
horizontalScrollBarPolicy - Variable in class javax.swing.JScrollPane
The display policy for the horizontal scrollbar.
horizThumbIcon - Static variable in class javax.swing.plaf.metal.MetalSliderUI
A default horizontal thumb Icon.
hostEncoding - Static variable in class javax.print.DocFlavor
A String representing the host operating system encoding.
HostnameVerifier - Interface in javax.net.ssl
This class is the base interface for hostname verification.
hostnameVerifier - Variable in class javax.net.ssl.HttpsURLConnection
The hostnameVerifier for this object.
hostsEqual(URL, URL) - Method in class java.net.URLStreamHandler
Compares the host components of two URLs.
HOUR - Static variable in class java.util.Calendar
Field number for get and set indicating the hour of the morning or afternoon.
HOUR0 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour field, where the legal values are 0 to 11.
HOUR0_FIELD - Static variable in class java.text.DateFormat
Useful constant for zero-based HOUR field alignment.
HOUR1 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour field, where the legal values are 1 to 12.
HOUR1_FIELD - Static variable in class java.text.DateFormat
Useful constant for one-based HOUR field alignment.
HOUR_OF_DAY - Static variable in class java.util.Calendar
Field number for get and set indicating the hour of the day.
HOUR_OF_DAY0 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour of day field, where the legal values are 0 to 23.
HOUR_OF_DAY0_FIELD - Static variable in class java.text.DateFormat
Useful constant for zero-based HOUR_OF_DAY field alignment.
HOUR_OF_DAY1 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour of day field, where the legal values are 1 to 24.
HOUR_OF_DAY1_FIELD - Static variable in class java.text.DateFormat
Useful constant for one-based HOUR_OF_DAY field alignment.
HOURS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the hours field.
HR - Static variable in class javax.swing.text.html.HTML.Tag
HREF - Static variable in class javax.swing.text.html.HTML.Attribute
hsb - Variable in class javax.swing.ScrollPaneLayout
The scrollpane's horizontal scrollbar child.
hsbChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI
hsbPolicy - Variable in class javax.swing.ScrollPaneLayout
The display policy for the horizontal scrollbar.
HSBtoRGB(float, float, float) - Static method in class java.awt.Color
Converts the components of a color, as specified by the HSB model, to an equivalent set of values for the default RGB model.
HSPACE - Static variable in class javax.swing.text.html.HTML.Attribute
HTML - Class in javax.swing.text.html
Constants used in the HTMLDocument.
HTML() - Constructor for class javax.swing.text.html.HTML
HTML - Static variable in class javax.swing.text.html.HTML.Tag
html - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
HTML to insert.
html - Variable in class javax.swing.text.html.parser.DTD
HTML.Attribute - Class in javax.swing.text.html
Typesafe enumeration representing an HTML attribute.
HTML.Tag - Class in javax.swing.text.html
Typesafe enumeration for an HTML tag.
HTML.Tag() - Constructor for class javax.swing.text.html.HTML.Tag
HTML.Tag(String) - Constructor for class javax.swing.text.html.HTML.Tag
Creates a new Tag with the specified id, and with causesBreak and isBlock set to false.
HTML.Tag(String, boolean, boolean) - Constructor for class javax.swing.text.html.HTML.Tag
Creates a new Tag with the specified id; causesBreak and isBlock are defined by the user.
HTML.UnknownTag - Class in javax.swing.text.html
HTML.UnknownTag(String) - Constructor for class javax.swing.text.html.HTML.UnknownTag
Creates a new UnknownTag with the specified id.
HTML_CONTAINER - Static variable in class javax.accessibility.AccessibleRole
An object containing a collection of Accessibles that together represents HTML content.
HTMLDocument - Class in javax.swing.text.html
A document that models HTML.
HTMLDocument() - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document using the default buffer size and a default StyleSheet.
HTMLDocument(StyleSheet) - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism.
HTMLDocument(AbstractDocument.Content, StyleSheet) - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
HTMLDocument.BlockElement - Class in javax.swing.text.html
An element that represents a structural block of HTML.
HTMLDocument.BlockElement(Element, AttributeSet) - Constructor for class javax.swing.text.html.HTMLDocument.BlockElement
Constructs a composite element that initially contains no children.
HTMLDocument.HTMLReader - Class in javax.swing.text.html
An HTML reader to load an HTML document with an HTML element structure.
HTMLDocument.HTMLReader(int) - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader
HTMLDocument.HTMLReader(int, int, int, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader
HTMLDocument.HTMLReader.BlockAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.BlockAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
HTMLDocument.HTMLReader.CharacterAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.CharacterAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
HTMLDocument.HTMLReader.FormAction - Class in javax.swing.text.html
Action to support forms by building all of the elements used to represent form controls.
HTMLDocument.HTMLReader.FormAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
HTMLDocument.HTMLReader.HiddenAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.HiddenAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
HTMLDocument.HTMLReader.IsindexAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.IsindexAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
HTMLDocument.HTMLReader.ParagraphAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.ParagraphAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
HTMLDocument.HTMLReader.PreAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.PreAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
HTMLDocument.HTMLReader.SpecialAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.SpecialAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
HTMLDocument.HTMLReader.TagAction - Class in javax.swing.text.html
An action to be performed in response to parsing a tag.
HTMLDocument.HTMLReader.TagAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
HTMLDocument.Iterator - Class in javax.swing.text.html
An iterator to iterate over a particular type of tag.
HTMLDocument.Iterator() - Constructor for class javax.swing.text.html.HTMLDocument.Iterator
HTMLDocument.RunElement - Class in javax.swing.text.html
An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
HTMLDocument.RunElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text.html.HTMLDocument.RunElement
Constructs an element that represents content within the document (has no children).
HTMLEditorKit - Class in javax.swing.text.html
The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
HTMLEditorKit() - Constructor for class javax.swing.text.html.HTMLEditorKit
Constructs an HTMLEditorKit, creates a StyleContext, and loads the style sheet.
HTMLEditorKit.HTMLFactory - Class in javax.swing.text.html
A factory to build views for HTML.
HTMLEditorKit.HTMLFactory() - Constructor for class javax.swing.text.html.HTMLEditorKit.HTMLFactory
HTMLEditorKit.HTMLTextAction - Class in javax.swing.text.html
An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
HTMLEditorKit.HTMLTextAction(String) - Constructor for class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
HTMLEditorKit.InsertHTMLTextAction - Class in javax.swing.text.html
InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.LinkController - Class in javax.swing.text.html
Class to watch the associated component and fire hyperlink events on it when appropriate.
HTMLEditorKit.LinkController() - Constructor for class javax.swing.text.html.HTMLEditorKit.LinkController
HTMLEditorKit.Parser - Class in javax.swing.text.html
Interface to be supported by the parser.
HTMLEditorKit.Parser() - Constructor for class javax.swing.text.html.HTMLEditorKit.Parser
HTMLEditorKit.ParserCallback - Class in javax.swing.text.html
The result of parsing drives these callback methods.
HTMLEditorKit.ParserCallback() - Constructor for class javax.swing.text.html.HTMLEditorKit.ParserCallback
HTMLFrameHyperlinkEvent - Class in javax.swing.text.html
HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a html frame hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, Element, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLWriter - Class in javax.swing.text.html
This is a writer for HTMLDocuments.
HTMLWriter(Writer, HTMLDocument) - Constructor for class javax.swing.text.html.HTMLWriter
Creates a new HTMLWriter.
HTMLWriter(Writer, HTMLDocument, int, int) - Constructor for class javax.swing.text.html.HTMLWriter
Creates a new HTMLWriter.
HTTP - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
HyperText Transfer Protocol (HTTP).
HTTP_ACCEPTED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 202: Accepted.
HTTP_BAD_GATEWAY - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 502: Bad Gateway.
HTTP_BAD_METHOD - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 405: Method Not Allowed.
HTTP_BAD_REQUEST - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 400: Bad Request.
HTTP_BINDING - Static variable in interface javax.xml.ws.http.HTTPBinding
A constant representing the identity of the XML/HTTP binding.
HTTP_CLIENT_TIMEOUT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 408: Request Time-Out.
HTTP_CONFLICT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 409: Conflict.
HTTP_CREATED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 201: Created.
HTTP_ENTITY_TOO_LARGE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 413: Request Entity Too Large.
HTTP_FORBIDDEN - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 403: Forbidden.
HTTP_GATEWAY_TIMEOUT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 504: Gateway Timeout.
HTTP_GONE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 410: Gone.
HTTP_INTERNAL_ERROR - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 500: Internal Server Error.
HTTP_LENGTH_REQUIRED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 411: Length Required.
HTTP_MOVED_PERM - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 301: Moved Permanently.
HTTP_MOVED_TEMP - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 302: Temporary Redirect.
HTTP_MULT_CHOICE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 300: Multiple Choices.
HTTP_NO_CONTENT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 204: No Content.
HTTP_NOT_ACCEPTABLE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 406: Not Acceptable.
HTTP_NOT_AUTHORITATIVE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 203: Non-Authoritative Information.
HTTP_NOT_FOUND - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 404: Not Found.
HTTP_NOT_IMPLEMENTED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 501: Not Implemented.
HTTP_NOT_MODIFIED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 304: Not Modified.
HTTP_OK - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 200: OK.
HTTP_PARTIAL - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 206: Partial Content.
HTTP_PAYMENT_REQUIRED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 402: Payment Required.
HTTP_PRECON_FAILED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 412: Precondition Failed.
HTTP_PROXY_AUTH - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 407: Proxy Authentication Required.
HTTP_REQ_TOO_LONG - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 414: Request-URI Too Large.
HTTP_REQUEST_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request headers.
HTTP_REQUEST_METHOD - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request method.
HTTP_RESET - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 205: Reset Content.
HTTP_RESPONSE_CODE - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response status code.
HTTP_RESPONSE_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response headers.
HTTP_SEE_OTHER - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 303: See Other.
HTTP_SERVER_ERROR - Static variable in class java.net.HttpURLConnection
Deprecated.
it is misplaced and shouldn't have existed.
HTTP_UNAUTHORIZED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 401: Unauthorized.
HTTP_UNAVAILABLE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 503: Service Unavailable.
HTTP_UNSUPPORTED_TYPE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 415: Unsupported Media Type.
HTTP_USE_PROXY - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 305: Use Proxy.
HTTP_VERSION - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 505: HTTP Version Not Supported.
HTTPBinding - Interface in javax.xml.ws.http
The HTTPBinding interface is an abstraction for the XML/HTTP binding.
HttpContext - Class in javax.xml.ws.spi.http
HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
HttpContext() - Constructor for class javax.xml.ws.spi.http.HttpContext
HttpCookie - Class in java.net
An HttpCookie object represents an http cookie, which carries state information between server and user agent.
HttpCookie(String, String) - Constructor for class java.net.HttpCookie
Constructs a cookie with a specified name and value.
HTTPEQUIV - Static variable in class javax.swing.text.html.HTML.Attribute
HTTPException - Exception in javax.xml.ws.http
The HTTPException exception represents a XML/HTTP fault.
HTTPException(int) - Constructor for exception javax.xml.ws.http.HTTPException
Constructor for the HTTPException
HttpExchange - Class in javax.xml.ws.spi.http
This class encapsulates a HTTP request received and a response to be generated in one exchange.
HttpExchange() - Constructor for class javax.xml.ws.spi.http.HttpExchange
HttpHandler - Class in javax.xml.ws.spi.http
A handler which is invoked to process HTTP requests.
HttpHandler() - Constructor for class javax.xml.ws.spi.http.HttpHandler
HttpRetryException - Exception in java.net
Thrown to indicate that a HTTP request needs to be retried but cannot be retried automatically, due to streaming mode being enabled.
HttpRetryException(String, int) - Constructor for exception java.net.HttpRetryException
Constructs a new HttpRetryException from the specified response code and exception detail message
HttpRetryException(String, int, String) - Constructor for exception java.net.HttpRetryException
Constructs a new HttpRetryException with detail message responseCode and the contents of the Location response header field.
HTTPS - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
Secure HyperText Transfer Protocol (HTTPS).
HttpsURLConnection - Class in javax.net.ssl
HttpsURLConnection extends HttpURLConnection with support for https-specific features.
HttpsURLConnection(URL) - Constructor for class javax.net.ssl.HttpsURLConnection
Creates an HttpsURLConnection using the URL specified.
HttpURLConnection - Class in java.net
A URLConnection with support for HTTP-specific features.
HttpURLConnection(URL) - Constructor for class java.net.HttpURLConnection
Constructor for the HttpURLConnection.
HUFFMAN_ONLY - Static variable in class java.util.zip.Deflater
Compression strategy for Huffman coding only.
HYPERLINK - Static variable in class javax.accessibility.AccessibleRole
A hypertext anchor
HyperlinkEvent - Class in javax.swing.event
HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent.EventType - Class in javax.swing.event
Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().
HyperlinkListener - Interface in javax.swing.event
HyperlinkListener
hyperlinkUpdate(HyperlinkEvent) - Method in interface javax.swing.event.HyperlinkListener
Called when a hypertext link is updated.
hypot(double, double) - Static method in class java.lang.Math
Returns sqrt(x2 +y2) without intermediate overflow or underflow.
hypot(double, double) - Static method in class java.lang.StrictMath
Returns sqrt(x2 +y2) without intermediate overflow or underflow.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类

提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java SE 开发人员文档. 该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。
版权所有 © 1993, 2011, Oracle 及其联盟会员。保留所有权利。
草案 ea-b138

.sAalen///s.eeeeablco


I-Index

  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

I

I - Static variable in class javax.swing.text.html.HTML.Tag
icAbsoluteColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: AbsoluteColorimetric.
ICC_ColorSpace - Class in java.awt.color
The ICC_ColorSpace class is an implementation of the abstract ColorSpace class.
ICC_ColorSpace(ICC_Profile) - Constructor for class java.awt.color.ICC_ColorSpace
Constructs a new ICC_ColorSpace from an ICC_Profile object.
ICC_Profile - Class in java.awt.color
A representation of color profile data for device independent and device dependent color spaces based on the International Color Consortium Specification ICC.1:2001-12, File Format for Color Profiles, (see http://www.color.org).
ICC_ProfileGray - Class in java.awt.color
A subclass of the ICC_Profile class which represents profiles which meet the following criteria: the color space type of the profile is TYPE_GRAY and the profile includes the grayTRCTag and mediaWhitePointTag tags.
ICC_ProfileRGB - Class in java.awt.color
The ICC_ProfileRGB class is a subclass of the ICC_Profile class that represents profiles which meet the following criteria: The profile's color space type is RGB. The profile includes the redColorantTag, greenColorantTag, blueColorantTag, redTRCTag, greenTRCTag, blueTRCTag, and mediaWhitePointTag tags. The ICC_Profile getInstance method will return an ICC_ProfileRGB object when these conditions are met.
icCurveCount - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: curveType count.
icCurveData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: curveType data.
icHdrAttributes - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device attributes.
icHdrCmmId - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: CMM for this profile.
icHdrColorSpace - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: color space of data.
icHdrCreator - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile creator.
icHdrDate - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: date profile was created.
icHdrDeviceClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: type of profile.
icHdrFlags - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: various bit settings.
icHdrIlluminant - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile illuminant.
icHdrMagic - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: icMagicNumber.
icHdrManufacturer - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device manufacturer.
icHdrModel - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device model number.
icHdrPcs - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: PCS - XYZ or Lab only.
icHdrPlatform - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: primary platform.
icHdrProfileID - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile's ID.
icHdrRenderingIntent - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: rendering intent.
icHdrSize - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile size in bytes.
icHdrVersion - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: format version number.
icICCAbsoluteColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: ICC-AbsoluteColorimetric.
icMediaRelativeColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Media-RelativeColorimetric.
ICON - Static variable in class javax.accessibility.AccessibleRole
A small fixed size picture, typically used to decorate components.
Icon - Interface in javax.swing
A small fixed size picture, typically used to decorate components.
icon - Variable in class javax.swing.JOptionPane
Icon used in pane.
icon - Variable in class javax.swing.plaf.basic.BasicRadioButtonUI
ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon that represents the button.
ICON_COLOR_16x16 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 16 x 16 color icon.
ICON_COLOR_32x32 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 32 x 32 color icon.
ICON_MONO_16x16 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 16 x 16 monochrome icon.
ICON_MONO_32x32 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 32 x 32 monochrome icon.
ICON_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for icon.
iconable - Variable in class javax.swing.JInternalFrame
The frame can "iconified" (shrunk down and displayed as an icon-image).
IconAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the icon attribute.
iconButton - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
iconCache - Variable in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
IconElementName - Static variable in class javax.swing.text.StyleConstants
Name of elements used to represent icons.
iconIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
ICONIFIED - Static variable in class java.awt.Frame
This state bit indicates that frame is iconified.
ICONIFIED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is minimized and is represented only by an icon.
ICONIFY_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
iconifyAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
iconifyFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the frame from its parent and adds its desktopIcon to the parent.
iconifyFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, remove this frame from it's parent and add an iconic representation.
iconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to iconify the frame.
iconOnly - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
iconPane - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
The title pane component used in the desktop icon.
IconUIResource - Class in javax.swing.plaf
An Icon wrapper class which implements UIResource.
IconUIResource(Icon) - Constructor for class javax.swing.plaf.IconUIResource
Creates a UIResource icon object which wraps an existing Icon instance.
IconView - Class in javax.swing.text
Icon decorator that implements the view interface.
IconView(Element) - Constructor for class javax.swing.text.IconView
Creates a new icon view that represents an element.
icPerceptual - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Perceptual.
icRelativeColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: RelativeColorimetric.
icSaturation - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Saturation.
icSigAbstractClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'abst'.
icSigAToB0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B0'.
icSigAToB1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B1'.
icSigAToB2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B2'.
icSigBlueColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bXYZ'.
icSigBlueMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bXYZ'.
icSigBlueTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bTRC'.
icSigBToA0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A0'.
icSigBToA1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A1'.
icSigBToA2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A2'.
icSigCalibrationDateTimeTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'calt'.
icSigCharTargetTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'targ'.
icSigChromaticAdaptationTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'chad'.
icSigChromaticityTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'chrm'.
icSigCmyData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CMY '.
icSigCmykData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CMYK'.
icSigColorantOrderTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'clro'.
icSigColorantTableTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'clrt'.
icSigColorSpaceClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'spac'.
icSigCopyrightTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'cprt'.
icSigCrdInfoTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'crdi'.
icSigDeviceMfgDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'dmnd'.
icSigDeviceModelDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'dmdd'.
icSigDeviceSettingsTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'devs'.
icSigDisplayClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'mntr'.
icSigGamutTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gamt'.
icSigGrayData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'GRAY'.
icSigGrayTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'kTRC'.
icSigGreenColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gXYZ'.
icSigGreenMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gXYZ'.
icSigGreenTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gTRC'.
icSigHead - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'head' - special.
icSigHlsData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'HLS'.
icSigHsvData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'HSV'.
icSigInputClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'scnr'.
icSigLabData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Lab '.
icSigLinkClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'link'.
icSigLuminanceTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'lumi'.
icSigLuvData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Luv '.
icSigMeasurementTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'meas'.
icSigMediaBlackPointTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bkpt'.
icSigMediaWhitePointTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'wtpt'.
icSigNamedColor2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ncl2'.
icSigNamedColorClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'nmcl'.
icSigOutputClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'prtr'.
icSigOutputResponseTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'resp'.
icSigPreview0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre0'.
icSigPreview1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre1'.
icSigPreview2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre2'.
icSigProfileDescriptionTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'desc'.
icSigProfileSequenceDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pseq'.
icSigPs2CRD0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd0'.
icSigPs2CRD1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd1'.
icSigPs2CRD2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd2'.
icSigPs2CRD3Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd3'.
icSigPs2CSATag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ps2s'.
icSigPs2RenderingIntentTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ps2i'.
icSigRedColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rXYZ'.
icSigRedMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rXYZ'.
icSigRedTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rTRC'.
icSigRgbData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'RGB '.
icSigScreeningDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'scrd'.
icSigScreeningTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'scrn'.
icSigSpace2CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '2CLR'.
icSigSpace3CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '3CLR'.
icSigSpace4CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '4CLR'.
icSigSpace5CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '5CLR'.
icSigSpace6CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '6CLR'.
icSigSpace7CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '7CLR'.
icSigSpace8CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '8CLR'.
icSigSpace9CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '9CLR'.
icSigSpaceACLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'ACLR'.
icSigSpaceBCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'BCLR'.
icSigSpaceCCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CCLR'.
icSigSpaceDCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'DCLR'.
icSigSpaceECLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'ECLR'.
icSigSpaceFCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'FCLR'.
icSigTechnologyTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'tech'.
icSigUcrBgTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bfd '.
icSigViewingCondDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'vued'.
icSigViewingConditionsTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'view'.
icSigXYZData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'XYZ '.
icSigYCbCrData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'YCbr'.
icSigYxyData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Yxy '.
icTagReserved - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: reserved.
icTagType - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: tag type signaturE.
icXYZNumberX - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: XYZNumber X.
id - Variable in class java.awt.AWTEvent
The event's id.
id - Variable in class java.awt.Event
Indicates which type of event the event is, and which other Event variables are relevant for the event.
id - Variable in class javax.naming.ldap.BasicControl
The control's object identifier string.
ID - Static variable in class javax.swing.text.html.HTML.Attribute
ID - Static variable in interface javax.swing.text.html.parser.DTDConstants
ID - Static variable in class javax.xml.ws.RespectBindingFeature
Constant value identifying the RespectBindingFeature
ID - Static variable in class javax.xml.ws.soap.AddressingFeature
Constant value identifying the AddressingFeature
ID - Static variable in class javax.xml.ws.soap.MTOMFeature
Constant value identifying the MTOMFeature
id() - Static method in class org.omg.CORBA.AnySeqHelper
id() - Static method in class org.omg.CORBA.BooleanSeqHelper
id() - Static method in class org.omg.CORBA.CharSeqHelper
id() - Static method in class org.omg.CORBA.CompletionStatusHelper
id() - Static method in class org.omg.CORBA.CurrentHelper
id() - Static method in class org.omg.CORBA.DefinitionKindHelper
id() - Static method in class org.omg.CORBA.DoubleSeqHelper
id() - Static method in class org.omg.CORBA.FieldNameHelper
id() - Static method in class org.omg.CORBA.FloatSeqHelper
id() - Static method in class org.omg.CORBA.IdentifierHelper
id() - Static method in class org.omg.CORBA.IDLTypeHelper
id() - Static method in class org.omg.CORBA.LongLongSeqHelper
id() - Static method in class org.omg.CORBA.LongSeqHelper
id - Variable in class org.omg.CORBA.NameValuePair
The name to be associated with a value by this NameValuePair object.
id() - Static method in class org.omg.CORBA.NameValuePairHelper
id() - Static method in class org.omg.CORBA.ObjectHelper
id() - Static method in class org.omg.CORBA.OctetSeqHelper
id() - Static method in class org.omg.CORBA.ParameterModeHelper
id() - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
id() - Static method in class org.omg.CORBA.PolicyErrorHelper
id() - Static method in class org.omg.CORBA.PolicyHelper
id() - Static method in class org.omg.CORBA.PolicyListHelper
id() - Static method in class org.omg.CORBA.PolicyTypeHelper
id() - Static method in class org.omg.CORBA.RepositoryIdHelper
id() - Static method in class org.omg.CORBA.ServiceDetailHelper
id() - Static method in class org.omg.CORBA.ServiceInformationHelper
id() - Static method in class org.omg.CORBA.SetOverrideTypeHelper
id() - Static method in class org.omg.CORBA.ShortSeqHelper
id() - Static method in class org.omg.CORBA.StringSeqHelper
id() - Static method in class org.omg.CORBA.StringValueHelper
id() - Static method in class org.omg.CORBA.StructMemberHelper
id() - Method in class org.omg.CORBA.TypeCode
Retrieves the RepositoryId globally identifying the type of this TypeCode object.
id() - Static method in class org.omg.CORBA.ULongLongSeqHelper
id() - Static method in class org.omg.CORBA.ULongSeqHelper
id() - Static method in class org.omg.CORBA.UnionMemberHelper
id() - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
id() - Static method in class org.omg.CORBA.UShortSeqHelper
id() - Static method in class org.omg.CORBA.ValueBaseHelper
id - Variable in class org.omg.CORBA.ValueMember
The repository ID of the value member described by this ValueMember object;
id() - Static method in class org.omg.CORBA.ValueMemberHelper
id() - Static method in class org.omg.CORBA.VersionSpecHelper
id() - Static method in class org.omg.CORBA.VisibilityHelper
id() - Static method in class org.omg.CORBA.WCharSeqHelper
id() - Static method in class org.omg.CORBA.WrongTransactionHelper
id() - Static method in class org.omg.CORBA.WStringSeqHelper
id() - Static method in class org.omg.CORBA.WStringValueHelper
id() - Static method in class org.omg.CosNaming.BindingHelper
id() - Static method in class org.omg.CosNaming.BindingIteratorHelper
id() - Static method in class org.omg.CosNaming.BindingListHelper
id() - Static method in class org.omg.CosNaming.BindingTypeHelper
id() - Static method in class org.omg.CosNaming.IstringHelper
id - Variable in class org.omg.CosNaming.NameComponent
id() - Static method in class org.omg.CosNaming.NameComponentHelper
id() - Static method in class org.omg.CosNaming.NameHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
id() - Static method in class org.omg.CosNaming.NamingContextHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
id() - Static method in class org.omg.DynamicAny.AnySeqHelper
id() - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
id() - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
id() - Static method in class org.omg.DynamicAny.DynAnyHelper
id() - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
id() - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
id() - Static method in class org.omg.DynamicAny.DynAnySeqHelper
id() - Static method in class org.omg.DynamicAny.DynArrayHelper
id() - Static method in class org.omg.DynamicAny.DynEnumHelper
id() - Static method in class org.omg.DynamicAny.DynFixedHelper
id() - Static method in class org.omg.DynamicAny.DynSequenceHelper
id() - Static method in class org.omg.DynamicAny.DynStructHelper
id() - Static method in class org.omg.DynamicAny.DynUnionHelper
id() - Static method in class org.omg.DynamicAny.DynValueHelper
id() - Static method in class org.omg.DynamicAny.FieldNameHelper
id - Variable in class org.omg.DynamicAny.NameDynAnyPair
The name associated with the DynAny.
id() - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
id() - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
id - Variable in class org.omg.DynamicAny.NameValuePair
The name associated with the Any.
id() - Static method in class org.omg.DynamicAny.NameValuePairHelper
id() - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
id() - Static method in class org.omg.IOP.CodecFactoryHelper
id() - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
id() - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
id() - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
id() - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
id() - Static method in class org.omg.IOP.ComponentIdHelper
id() - Static method in class org.omg.IOP.IORHelper
id() - Static method in class org.omg.IOP.MultipleComponentProfileHelper
id() - Static method in class org.omg.IOP.ProfileIdHelper
id() - Static method in class org.omg.IOP.ServiceContextHelper
id() - Static method in class org.omg.IOP.ServiceContextListHelper
id() - Static method in class org.omg.IOP.ServiceIdHelper
id() - Static method in class org.omg.IOP.TaggedComponentHelper
id() - Static method in class org.omg.IOP.TaggedProfileHelper
id() - Static method in class org.omg.Messaging.SyncScopeHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
id() - Static method in class org.omg.PortableInterceptor.CurrentHelper
id() - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
id() - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
id() - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
id() - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
id() - Static method in class org.omg.PortableInterceptor.ORBIdHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
id() - Static method in class org.omg.PortableInterceptor.ServerIdHelper
id() - Static method in class org.omg.PortableServer.CurrentHelper
id() - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
id() - Static method in class org.omg.PortableServer.ForwardRequestHelper
id() - Static method in class org.omg.PortableServer.POAHelper
id() - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
id() - Method in interface org.omg.PortableServer.POAOperations
This returns the unique id of the POA in the process in which it is created.
id() - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
id() - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
id() - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
id() - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
id() - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
id() - Static method in class org.omg.PortableServer.ServantActivatorHelper
id() - Static method in class org.omg.PortableServer.ServantLocatorHelper
ID_ASSIGNMENT_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
id_to_reference(byte[]) - Method in interface org.omg.PortableServer.POAOperations
If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
id_to_servant(byte[]) - Method in interface org.omg.PortableServer.POAOperations
If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
ID_UNIQUENESS_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
IdAssignmentPolicy - Interface in org.omg.PortableServer
IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdAssignmentPolicyOperations - Interface in org.omg.PortableServer
IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdAssignmentPolicyValue - Class in org.omg.PortableServer
The IdAssignmentPolicyValue can have the following values.
IdAssignmentPolicyValue(int) - Constructor for class org.omg.PortableServer.IdAssignmentPolicyValue
IDENTICAL - Static variable in class java.text.Collator
Collator strength value.
identifier - Variable in class javax.swing.table.TableColumn
This object is not used internally by the drawing machinery of the JTable; identifiers may be set in the TableColumn as as an optional way to tag and locate table columns.
IdentifierHelper - Class in org.omg.CORBA
The Helper for Identifier.
IdentifierHelper() - Constructor for class org.omg.CORBA.IdentifierHelper
identities() - Method in class java.security.IdentityScope
Deprecated.
Returns an enumeration of all identities in this identity scope.
IDENTITY - Static variable in class java.awt.font.TransformAttribute
A TransformAttribute representing the identity transform.
identity(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which returns its sole argument when invoked.
Identity - Class in java.security
Deprecated.
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
Identity() - Constructor for class java.security.Identity
Deprecated.
Constructor for serialization only.
Identity(String, IdentityScope) - Constructor for class java.security.Identity
Deprecated.
Constructs an identity with the specified name and scope.
Identity(String) - Constructor for class java.security.Identity
Deprecated.
Constructs an identity with the specified name and no scope.
identityEquals(Identity) - Method in class java.security.Identity
Deprecated.
Tests for equality between the specified identity and this identity.
identityHashCode(Object) - Static method in class java.lang.System
Returns the same hash code for the given object as would be returned by the default method hashCode(), whether or not the given object's class overrides hashCode().
IdentityHashMap<K,V> - Class in java.util
This class implements the Map interface with a hash table, using reference-equality in place of object-equality when comparing keys (and values).
IdentityHashMap() - Constructor for class java.util.IdentityHashMap
Constructs a new, empty identity hash map with a default expected maximum size (21).
IdentityHashMap(int) - Constructor for class java.util.IdentityHashMap
Constructs a new, empty map with the specified expected maximum size.
IdentityHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.IdentityHashMap
Constructs a new identity hash map containing the keys-value mappings in the specified map.
IdentityScope - Class in java.security
Deprecated.
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
IdentityScope() - Constructor for class java.security.IdentityScope
Deprecated.
This constructor is used for serialization only and should not be used by subclasses.
IdentityScope(String) - Constructor for class java.security.IdentityScope
Deprecated.
Constructs a new identity scope with the specified name.
IdentityScope(String, IdentityScope) - Constructor for class java.security.IdentityScope
Deprecated.
Constructs a new identity scope with the specified name and scope.
IDEOGRAPHIC_DESCRIPTION_CHARACTERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ideographic Description Characters" Unicode character block.
IDLE - Static variable in class javax.print.attribute.standard.PrinterState
Indicates that new jobs can start processing without waiting.
IDLEntity - Interface in org.omg.CORBA.portable
An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
IDLType - Interface in org.omg.CORBA
An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
IDLTypeHelper - Class in org.omg.CORBA
The Helper for IDLType.
IDLTypeHelper() - Constructor for class org.omg.CORBA.IDLTypeHelper
IDLTypeOperations - Interface in org.omg.CORBA
This interface must be implemented by all IDLType objects.
IDN - Class in java.net
Provides methods to convert internationalized domain names (IDNs) between a normal Unicode representation and an ASCII Compatible Encoding (ACE) representation.
IDREF - Static variable in interface javax.swing.text.html.parser.DTDConstants
IDREFS - Static variable in interface javax.swing.text.html.parser.DTDConstants
IdUniquenessPolicy - Interface in org.omg.PortableServer
The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IdUniquenessPolicyOperations - Interface in org.omg.PortableServer
The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IdUniquenessPolicyValue - Class in org.omg.PortableServer
IdUniquenessPolicyValue can have the following values.
IdUniquenessPolicyValue(int) - Constructor for class org.omg.PortableServer.IdUniquenessPolicyValue
IEEEremainder(double, double) - Static method in class java.lang.Math
Computes the remainder operation on two arguments as prescribed by the IEEE 754 standard.
IEEEremainder(double, double) - Static method in class java.lang.StrictMath
Computes the remainder operation on two arguments as prescribed by the IEEE 754 standard.
ifModifiedSince - Variable in class java.net.URLConnection
Some protocols support skipping the fetching of the object unless the object has been modified more recently than a certain time.
ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax.ContentHandler
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an ignorable whitespace event.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 ignorable whitespace event.
IGNORE - Static variable in class java.nio.charset.CodingErrorAction
Action indicating that a coding error is to be handled by dropping the erroneous input and resuming the coding operation.
IGNORE_ALL_BEANINFO - Static variable in class java.beans.Introspector
IGNORE_IMMEDIATE_BEANINFO - Static variable in class java.beans.Introspector
ignoreMetadata - Variable in class javax.imageio.ImageReader
true if the current input source has been marked as allowing metadata to be ignored by setInput.
IIOByteBuffer - Class in javax.imageio.stream
A class representing a mutable reference to an array of bytes and an offset and length within that array.
IIOByteBuffer(byte[], int, int) - Constructor for class javax.imageio.stream.IIOByteBuffer
Constructs an IIOByteBuffer that references a given byte array, offset, and length.
IIOException - Exception in javax.imageio
An exception class used for signaling run-time failure of reading and writing operations.
IIOException(String) - Constructor for exception javax.imageio.IIOException
Constructs an IIOException with a given message String.
IIOException(String, Throwable) - Constructor for exception javax.imageio.IIOException
Constructs an IIOException with a given message String and a Throwable that was its underlying cause.
IIOImage - Class in javax.imageio
A simple container class to aggregate an image, a set of thumbnail (preview) images, and an object representing metadata associated with the image.
IIOImage(RenderedImage, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio.IIOImage
Constructs an IIOImage containing a RenderedImage, and thumbnails and metadata associated with it.
IIOImage(Raster, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio.IIOImage
Constructs an IIOImage containing a Raster, and thumbnails and metadata associated with it.
IIOInvalidTreeException - Exception in javax.imageio.metadata
An IIOInvalidTreeException is thrown when an attempt by an IIOMetadata object to parse a tree of IIOMetadataNodes fails.
IIOInvalidTreeException(String, Node) - Constructor for exception javax.imageio.metadata.IIOInvalidTreeException
Constructs an IIOInvalidTreeException with a message string and a reference to the Node that caused the parsing error.
IIOInvalidTreeException(String, Throwable, Node) - Constructor for exception javax.imageio.metadata.IIOInvalidTreeException
Constructs an IIOInvalidTreeException with a message string, a reference to an exception that caused this exception, and a reference to the Node that caused the parsing error.
IIOMetadata - Class in javax.imageio.metadata
An abstract class to be extended by objects that represent metadata (non-image data) associated with images and streams.
IIOMetadata() - Constructor for class javax.imageio.metadata.IIOMetadata
Constructs an empty IIOMetadata object.
IIOMetadata(boolean, String, String, String[], String[]) - Constructor for class javax.imageio.metadata.IIOMetadata
Constructs an IIOMetadata object with the given format names and format class names, as well as a boolean indicating whether the standard format is supported.
IIOMetadataController - Interface in javax.imageio.metadata
An interface to be implemented by objects that can determine the settings of an IIOMetadata object, either by putting up a GUI to obtain values from a user, or by other means.
IIOMetadataFormat - Interface in javax.imageio.metadata
An object describing the structure of metadata documents returned from IIOMetadata.getAsTree and passed to IIOMetadata.setFromTree and mergeTree.
IIOMetadataFormatImpl - Class in javax.imageio.metadata
A concrete class providing a reusable implementation of the IIOMetadataFormat interface.
IIOMetadataFormatImpl(String, int) - Constructor for class javax.imageio.metadata.IIOMetadataFormatImpl
Constructs a blank IIOMetadataFormatImpl instance, with a given root element name and child policy (other than CHILD_POLICY_REPEAT).
IIOMetadataFormatImpl(String, int, int) - Constructor for class javax.imageio.metadata.IIOMetadataFormatImpl
Constructs a blank IIOMetadataFormatImpl instance, with a given root element name and a child policy of CHILD_POLICY_REPEAT.
IIOMetadataNode - Class in javax.imageio.metadata
A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
IIOMetadataNode() - Constructor for class javax.imageio.metadata.IIOMetadataNode
Constructs an empty IIOMetadataNode.
IIOMetadataNode(String) - Constructor for class javax.imageio.metadata.IIOMetadataNode
Constructs an IIOMetadataNode with a given node name.
IIOParam - Class in javax.imageio
A superclass of all classes describing how streams should be decoded or encoded.
IIOParam() - Constructor for class javax.imageio.IIOParam
Protected constructor may be called only by subclasses.
IIOParamController - Interface in javax.imageio
An interface to be implemented by objects that can determine the settings of an IIOParam object, either by putting up a GUI to obtain values from a user, or by other means.
IIOReadProgressListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of progress.
IIOReadUpdateListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of pixel updates.
IIOReadWarningListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of warnings (non-fatal errors).
IIORegistry - Class in javax.imageio.spi
A registry for service provider instances.
IIOServiceProvider - Class in javax.imageio.spi
A superinterface for functionality common to all Image I/O service provider interfaces (SPIs).
IIOServiceProvider(String, String) - Constructor for class javax.imageio.spi.IIOServiceProvider
Constructs an IIOServiceProvider with a given vendor name and version identifier.
IIOServiceProvider() - Constructor for class javax.imageio.spi.IIOServiceProvider
Constructs a blank IIOServiceProvider.
IIOWriteProgressListener - Interface in javax.imageio.event
An interface used by ImageWriter implementations to notify callers of their image writing methods of progress.
IIOWriteWarningListener - Interface in javax.imageio.event
An interface used by ImageWriter implementations to notify callers of their image and thumbnail reading methods of warnings (non-fatal errors).
IllegalAccessError - Error in java.lang
Thrown if an application attempts to access or modify a field, or to call a method that it does not have access to.
IllegalAccessError() - Constructor for error java.lang.IllegalAccessError
Constructs an IllegalAccessError with no detail message.
IllegalAccessError(String) - Constructor for error java.lang.IllegalAccessError
Constructs an IllegalAccessError with the specified detail message.
IllegalAccessException - Exception in java.lang
An IllegalAccessException is thrown when an application tries to reflectively create an instance (other than an array), set or get a field, or invoke a method, but the currently executing method does not have access to the definition of the specified class, field, method or constructor.
IllegalAccessException() - Constructor for exception java.lang.IllegalAccessException
Constructs an IllegalAccessException without a detail message.
IllegalAccessException(String) - Constructor for exception java.lang.IllegalAccessException
Constructs an IllegalAccessException with a detail message.
IllegalArgumentException - Exception in java.lang
Thrown to indicate that a method has been passed an illegal or inappropriate argument.
IllegalArgumentException() - Constructor for exception java.lang.IllegalArgumentException
Constructs an IllegalArgumentException with no detail message.
IllegalArgumentException(String) - Constructor for exception java.lang.IllegalArgumentException
Constructs an IllegalArgumentException with the specified detail message.
IllegalArgumentException(String, Throwable) - Constructor for exception java.lang.IllegalArgumentException
Constructs a new exception with the specified detail message and cause.
IllegalArgumentException(Throwable) - Constructor for exception java.lang.IllegalArgumentException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
IllegalBlockingModeException - Exception in java.nio.channels
Unchecked exception thrown when a blocking-mode-specific operation is invoked upon a channel in the incorrect blocking mode.
IllegalBlockingModeException() - Constructor for exception java.nio.channels.IllegalBlockingModeException
Constructs an instance of this class.
IllegalBlockSizeException - Exception in javax.crypto
This exception is thrown when the length of data provided to a block cipher is incorrect, i.e., does not match the block size of the cipher.
IllegalBlockSizeException() - Constructor for exception javax.crypto.IllegalBlockSizeException
Constructs an IllegalBlockSizeException with no detail message.
IllegalBlockSizeException(String) - Constructor for exception javax.crypto.IllegalBlockSizeException
Constructs an IllegalBlockSizeException with the specified detail message.
IllegalChannelGroupException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to open a channel in a group that was not created by the same provider.
IllegalChannelGroupException() - Constructor for exception java.nio.channels.IllegalChannelGroupException
Constructs an instance of this class.
IllegalCharsetNameException - Exception in java.nio.charset
Unchecked exception thrown when a string that is not a legal charset name is used as such.
IllegalCharsetNameException(String) - Constructor for exception java.nio.charset.IllegalCharsetNameException
Constructs an instance of this class.
IllegalClassFormatException - Exception in java.lang.instrument
Thrown by an implementation of ClassFileTransformer.transform when its input parameters are invalid.
IllegalClassFormatException() - Constructor for exception java.lang.instrument.IllegalClassFormatException
Constructs an IllegalClassFormatException with no detail message.
IllegalClassFormatException(String) - Constructor for exception java.lang.instrument.IllegalClassFormatException
Constructs an IllegalClassFormatException with the specified detail message.
IllegalComponentStateException - Exception in java.awt
Signals that an AWT component is not in an appropriate state for the requested operation.
IllegalComponentStateException() - Constructor for exception java.awt.IllegalComponentStateException
Constructs an IllegalComponentStateException with no detail message.
IllegalComponentStateException(String) - Constructor for exception java.awt.IllegalComponentStateException
Constructs an IllegalComponentStateException with the specified detail message.
IllegalFormatCodePointException - Exception in java.util
Unchecked exception thrown when a character with an invalid Unicode code point as defined by Character.isValidCodePoint(int) is passed to the Formatter.
IllegalFormatCodePointException(int) - Constructor for exception java.util.IllegalFormatCodePointException
Constructs an instance of this class with the specified illegal code point as defined by Character.isValidCodePoint(int).
IllegalFormatConversionException - Exception in java.util
Unchecked exception thrown when the argument corresponding to the format specifier is of an incompatible type.
IllegalFormatConversionException(char, Class<?>) - Constructor for exception java.util.IllegalFormatConversionException
Constructs an instance of this class with the mismatched conversion and the corresponding argument class.
IllegalFormatException - Exception in java.util
Unchecked exception thrown when a format string contains an illegal syntax or a format specifier that is incompatible with the given arguments.
IllegalFormatFlagsException - Exception in java.util
Unchecked exception thrown when an illegal combination flags is given.
IllegalFormatFlagsException(String) - Constructor for exception java.util.IllegalFormatFlagsException
Constructs an instance of this class with the specified flags.
IllegalFormatPrecisionException - Exception in java.util
Unchecked exception thrown when the precision is a negative value other than -1, the conversion does not support a precision, or the value is otherwise unsupported.
IllegalFormatPrecisionException(int) - Constructor for exception java.util.IllegalFormatPrecisionException
Constructs an instance of this class with the specified precision.
IllegalFormatWidthException - Exception in java.util
Unchecked exception thrown when the format width is a negative value other than -1 or is otherwise unsupported.
IllegalFormatWidthException(int) - Constructor for exception java.util.IllegalFormatWidthException
Constructs an instance of this class with the specified width.
IllegalMonitorStateException - Exception in java.lang
Thrown to indicate that a thread has attempted to wait on an object's monitor or to notify other threads waiting on an object's monitor without owning the specified monitor.
IllegalMonitorStateException() - Constructor for exception java.lang.IllegalMonitorStateException
Constructs an IllegalMonitorStateException with no detail message.
IllegalMonitorStateException(String) - Constructor for exception java.lang.IllegalMonitorStateException
Constructs an IllegalMonitorStateException with the specified detail message.
IllegalPathStateException - Exception in java.awt.geom
The IllegalPathStateException represents an exception that is thrown if an operation is performed on a path that is in an illegal state with respect to the particular operation being performed, such as appending a path segment to a GeneralPath without an initial moveto.
IllegalPathStateException() - Constructor for exception java.awt.geom.IllegalPathStateException
Constructs an IllegalPathStateException with no detail message.
IllegalPathStateException(String) - Constructor for exception java.awt.geom.IllegalPathStateException
Constructs an IllegalPathStateException with the specified detail message.
IllegalSelectorException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to register a channel with a selector that was not created by the provider that created the channel.
IllegalSelectorException() - Constructor for exception java.nio.channels.IllegalSelectorException
Constructs an instance of this class.
IllegalStateException - Exception in java.lang
Signals that a method has been invoked at an illegal or inappropriate time.
IllegalStateException() - Constructor for exception java.lang.IllegalStateException
Constructs an IllegalStateException with no detail message.
IllegalStateException(String) - Constructor for exception java.lang.IllegalStateException
Constructs an IllegalStateException with the specified detail message.
IllegalStateException(String, Throwable) - Constructor for exception java.lang.IllegalStateException
Constructs a new exception with the specified detail message and cause.
IllegalStateException(Throwable) - Constructor for exception java.lang.IllegalStateException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
IllegalThreadStateException - Exception in java.lang
Thrown to indicate that a thread is not in an appropriate state for the requested operation.
IllegalThreadStateException() - Constructor for exception java.lang.IllegalThreadStateException
Constructs an IllegalThreadStateException with no detail message.
IllegalThreadStateException(String) - Constructor for exception java.lang.IllegalThreadStateException
Constructs an IllegalThreadStateException with the specified detail message.
IllformedLocaleException - Exception in java.util
Thrown by methods in Locale and Locale.Builder to indicate that an argument is not a well-formed BCP 47 tag.
IllformedLocaleException() - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with no detail message and -1 as the error index.
IllformedLocaleException(String) - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with the given message and -1 as the error index.
IllformedLocaleException(String, int) - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with the given message and the error index.
Image - Class in java.awt
The abstract class Image is the superclass of all classes that represent graphical images.
Image() - Constructor for class java.awt.Image
image - Variable in class javax.imageio.IIOImage
The RenderedImage being referenced.
IMAGE_INCOMPATIBLE - Static variable in class java.awt.image.VolatileImage
Validated image is incompatible with supplied GraphicsConfiguration object and should be re-created as appropriate.
IMAGE_OK - Static variable in class java.awt.image.VolatileImage
Validated image is ready to use as-is.
IMAGE_RESTORED - Static variable in class java.awt.image.VolatileImage
Validated image has been restored and is now ready to use.
IMAGEABORTED - Static variable in interface java.awt.image.ImageConsumer
The image creation process was deliberately aborted.
ImageCapabilities - Class in java.awt
Capabilities and properties of images.
ImageCapabilities(boolean) - Constructor for class java.awt.ImageCapabilities
Creates a new object for specifying image capabilities.
imageComplete(int) - Method in class java.awt.image.BufferedImageFilter
Filters the information provided in the imageComplete method of the ImageConsumer interface.
imageComplete(int) - Method in interface java.awt.image.ImageConsumer
The imageComplete method is called when the ImageProducer is finished delivering all of the pixels that the source image contains, or when a single frame of a multi-frame animation has been completed, or when an error in loading or producing the image has occured.
imageComplete(int) - Method in class java.awt.image.ImageFilter
Filters the information provided in the imageComplete method of the ImageConsumer interface.
imageComplete(int) - Method in class java.awt.image.PixelGrabber
The imageComplete method is part of the ImageConsumer API which this class must implement to retrieve the pixels.
imageComplete(ImageReader) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that the current image read operation has completed.
imageComplete(ImageWriter) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that the image write operation has completed.
ImageConsumer - Interface in java.awt.image
The interface for objects expressing interest in image data through the ImageProducer interfaces.
IMAGEERROR - Static variable in interface java.awt.image.ImageConsumer
An error was encountered while producing the image.
ImageFilter - Class in java.awt.image
This class implements a filter for the set of interface methods that are used to deliver data from an ImageProducer to an ImageConsumer.
ImageFilter() - Constructor for class java.awt.image.ImageFilter
imageFlavor - Static variable in class java.awt.datatransfer.DataFlavor
The DataFlavor representing a Java Image class, where:
ImageGraphicAttribute - Class in java.awt.font
The ImageGraphicAttribute class is an implementation of GraphicAttribute which draws images in a TextLayout.
ImageGraphicAttribute(Image, int) - Constructor for class java.awt.font.ImageGraphicAttribute
Constucts an ImageGraphicAttribute from the specified Image.
ImageGraphicAttribute(Image, int, float, float) - Constructor for class java.awt.font.ImageGraphicAttribute
Constructs an ImageGraphicAttribute from the specified Image.
ImageIcon - Class in javax.swing
An implementation of the Icon interface that paints Icons from Images.
ImageIcon(String, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified file.
ImageIcon(String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified file.
ImageIcon(URL, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified URL.
ImageIcon(URL) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified URL.
ImageIcon(Image, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the image.
ImageIcon(Image) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an image object.
ImageIcon(byte[], String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
ImageIcon(byte[]) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
ImageIcon() - Constructor for class javax.swing.ImageIcon
Creates an uninitialized image icon.
ImageIcon.AccessibleImageIcon - Class in javax.swing
This class implements accessibility support for the ImageIcon class.
ImageIcon.AccessibleImageIcon() - Constructor for class javax.swing.ImageIcon.AccessibleImageIcon
ImageInputStream - Interface in javax.imageio.stream
A seekable input stream interface for use by ImageReaders.
ImageInputStreamImpl - Class in javax.imageio.stream
An abstract class implementing the ImageInputStream interface.
ImageInputStreamImpl() - Constructor for class javax.imageio.stream.ImageInputStreamImpl
Constructs an ImageInputStreamImpl.
ImageInputStreamSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageInputStreams.
ImageInputStreamSpi() - Constructor for class javax.imageio.spi.ImageInputStreamSpi
Constructs a blank ImageInputStreamSpi.
ImageInputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi.ImageInputStreamSpi
Constructs an ImageInputStreamSpi with a given set of values.
ImageIO - Class in javax.imageio
A class containing static convenience methods for locating ImageReaders and ImageWriters, and performing simple encoding and decoding.
ImageObserver - Interface in java.awt.image
An asynchronous update interface for receiving notifications about Image information as the Image is constructed.
ImageOutputStream - Interface in javax.imageio.stream
A seekable output stream interface for use by ImageWriters.
ImageOutputStreamImpl - Class in javax.imageio.stream
An abstract class implementing the ImageOutputStream interface.
ImageOutputStreamImpl() - Constructor for class javax.imageio.stream.ImageOutputStreamImpl
Constructs an ImageOutputStreamImpl.
ImageOutputStreamSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageOutputStreams.
ImageOutputStreamSpi() - Constructor for class javax.imageio.spi.ImageOutputStreamSpi
Constructs a blank ImageOutputStreamSpi.
ImageOutputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi.ImageOutputStreamSpi
Constructs an ImageOutputStreamSpi with a given set of values.
ImageProducer - Interface in java.awt.image
The interface for objects which can produce the image data for Images.
imageProgress(ImageReader, float) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports the approximate degree of completion of the current read call of the associated ImageReader.
imageProgress(ImageWriter, float) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports the approximate degree of completion of the current write call within the associated ImageWriter.
ImageReader - Class in javax.imageio
An abstract superclass for parsing and decoding of images.
ImageReader(ImageReaderSpi) - Constructor for class javax.imageio.ImageReader
Constructs an ImageReader and sets its originatingProvider field to the supplied value.
ImageReaderSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageReaders.
ImageReaderSpi() - Constructor for class javax.imageio.spi.ImageReaderSpi
Constructs a blank ImageReaderSpi.
ImageReaderSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageReaderSpi
Constructs an ImageReaderSpi with a given set of values.
ImageReaderWriterSpi - Class in javax.imageio.spi
A superclass containing instance variables and methods common to ImageReaderSpi and ImageWriterSpi.
ImageReaderWriterSpi(String, String, String[], String[], String[], String, boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageReaderWriterSpi
Constructs an ImageReaderWriterSpi with a given set of values.
ImageReaderWriterSpi() - Constructor for class javax.imageio.spi.ImageReaderWriterSpi
Constructs a blank ImageReaderWriterSpi.
ImageReadParam - Class in javax.imageio
A class describing how a stream is to be decoded.
ImageReadParam() - Constructor for class javax.imageio.ImageReadParam
Constructs an ImageReadParam.
imageStarted(ImageReader, int) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that an image read operation is beginning.
imageStarted(ImageWriter, int) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that an image write operation is beginning.
imageSubmit(String) - Method in class javax.swing.text.html.FormView
This method is called to submit a form in response to a click on an image -- an <INPUT> form element of type "image".
ImageTranscoder - Interface in javax.imageio
An interface providing metadata transcoding capability.
ImageTranscoderSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageTranscoders.
ImageTranscoderSpi() - Constructor for class javax.imageio.spi.ImageTranscoderSpi
Constructs a blank ImageTranscoderSpi.
ImageTranscoderSpi(String, String) - Constructor for class javax.imageio.spi.ImageTranscoderSpi
Constructs an ImageTranscoderSpi with a given set of values.
ImageTypeSpecifier - Class in javax.imageio
A class that allows the format of an image (in particular, its SampleModel and ColorModel) to be specified in a convenient manner.
ImageTypeSpecifier(ColorModel, SampleModel) - Constructor for class javax.imageio.ImageTypeSpecifier
Constructs an ImageTypeSpecifier directly from a ColorModel and a SampleModel.
ImageTypeSpecifier(RenderedImage) - Constructor for class javax.imageio.ImageTypeSpecifier
Constructs an ImageTypeSpecifier from a RenderedImage.
imageUpdate(Image, int, int, int, int, int) - Method in class java.awt.Component
Repaints the component when the image has changed.
imageUpdate(Image, int, int, int, int, int) - Method in interface java.awt.image.ImageObserver
This method is called when information about an image which was previously requested using an asynchronous interface becomes available.
imageUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that a given region of the image has been updated.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.AbstractButton
This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.JLabel
This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.JSlider
Repaints the component when the image has changed.
ImageView - Class in javax.swing.text.html
View of an Image, intended to support the HTML <IMG> tag.
ImageView(Element) - Constructor for class javax.swing.text.html.ImageView
Creates a new view that represents an IMG element.
ImageWriteParam - Class in javax.imageio
A class describing how a stream is to be encoded.
ImageWriteParam() - Constructor for class javax.imageio.ImageWriteParam
Constructs an empty ImageWriteParam.
ImageWriteParam(Locale) - Constructor for class javax.imageio.ImageWriteParam
Constructs an ImageWriteParam set to use a given Locale.
ImageWriter - Class in javax.imageio
An abstract superclass for encoding and writing images.
ImageWriter(ImageWriterSpi) - Constructor for class javax.imageio.ImageWriter
Constructs an ImageWriter and sets its originatingProvider instance variable to the supplied value.
ImageWriterSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageWriters.
ImageWriterSpi() - Constructor for class javax.imageio.spi.ImageWriterSpi
Constructs a blank ImageWriterSpi.
ImageWriterSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageWriterSpi
Constructs an ImageWriterSpi with a given set of values.
ImagingOpException - Exception in java.awt.image
The ImagingOpException is thrown if one of the BufferedImageOp or RasterOp filter methods cannot process the image.
ImagingOpException(String) - Constructor for exception java.awt.image.ImagingOpException
Constructs an ImagingOpException object with the specified message.
IMG - Static variable in class javax.swing.text.html.HTML.Tag
IMG_ALIGN_BOTTOM - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the bottom.
IMG_ALIGN_MIDDLE - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images in the middle.
IMG_ALIGN_TOP - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the top.
IMG_BORDER - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the border.
IMMUTABLE_INFO_FIELD - Static variable in class javax.management.JMX
The name of the immutableInfo field.
ImmutableDescriptor - Class in javax.management
An immutable descriptor.
ImmutableDescriptor(String[], Object[]) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor containing the given fields and values.
ImmutableDescriptor(String...) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor containing the given fields.
ImmutableDescriptor(Map<String, ?>) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor where the names and values of the fields are the keys and values of the given Map.
IMP_LIMIT - Exception in org.omg.CORBA
This exception indicates that an implementation limit was exceeded in the ORB run time.
IMP_LIMIT() - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
IMP_LIMIT(String) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
IMP_LIMIT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified minor code and completion status.
IMP_LIMIT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.
IMPERIAL_ARAMAIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Imperial Aramaic" Unicode character block.
impl - Variable in class javax.naming.CompoundName
Implementation of this compound name.
implAccept(Socket) - Method in class java.net.ServerSocket
Subclasses of ServerSocket use this method to override accept() to return their own subclass of socket.
implCloseChannel() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Closes this channel.
implCloseChannel() - Method in class java.nio.channels.spi.AbstractSelectableChannel
Closes this channel.
implCloseSelectableChannel() - Method in class java.nio.channels.spi.AbstractSelectableChannel
Closes this selectable channel.
implCloseSelector() - Method in class java.nio.channels.spi.AbstractSelector
Closes this selector.
implConfigureBlocking(boolean) - Method in class java.nio.channels.spi.AbstractSelectableChannel
Adjusts this channel's blocking mode.
IMPLEMENTATION_TITLE - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Title manifest attribute used for package versioning.
IMPLEMENTATION_URL - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Vendor-URL manifest attribute used for package versioning.
IMPLEMENTATION_VENDOR - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Vendor manifest attribute used for package versioning.
IMPLEMENTATION_VENDOR_ID - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Vendor-Id manifest attribute used for package versioning.
IMPLEMENTATION_VERSION - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Version manifest attribute used for package versioning.
implFlush(CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Flushes this decoder.
implFlush(ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Flushes this encoder.
IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
IMPLICIT_ACTIVATION_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
ImplicitActivationPolicy - Interface in org.omg.PortableServer
This policy specifies whether implicit activation of servants is supported in the created POA.
ImplicitActivationPolicyOperations - Interface in org.omg.PortableServer
This policy specifies whether implicit activation of servants is supported in the created POA.
ImplicitActivationPolicyValue - Class in org.omg.PortableServer
ImplicitActivationPolicyValue has the following semantics.
ImplicitActivationPolicyValue(int) - Constructor for class org.omg.PortableServer.ImplicitActivationPolicyValue
IMPLIED - Static variable in class javax.swing.text.html.HTML.Tag
All text content must be in a paragraph element.
IMPLIED - Static variable in class javax.swing.text.html.HTMLEditorKit.ParserCallback
This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.
IMPLIED - Static variable in interface javax.swing.text.html.parser.DTDConstants
implies(Permission) - Method in class java.io.FilePermission
Checks if this FilePermission object "implies" the specified permission.
implies(Permission) - Method in class java.net.SocketPermission
Checks if this socket permission object "implies" the specified permission.
implies(Permission) - Method in class java.security.AllPermission
Checks if the specified permission is "implied" by this object.
implies(Permission) - Method in class java.security.BasicPermission
Checks if the specified permission is "implied" by this object.
implies(CodeSource) - Method in class java.security.CodeSource
Returns true if this CodeSource object "implies" the specified CodeSource.
implies(Permission) - Method in class java.security.Permission
Checks if the specified permission's actions are "implied by" this object's actions.
implies(Permission) - Method in class java.security.PermissionCollection
Checks to see if the specified permission is implied by the collection of Permission objects held in this PermissionCollection.
implies(Permission) - Method in class java.security.Permissions
Checks to see if this object's PermissionCollection for permissions of the specified permission's class implies the permissions expressed in the permission object.
implies(ProtectionDomain, Permission) - Method in class java.security.Policy
Evaluates the global policy for the permissions granted to the ProtectionDomain and tests whether the permission is granted.
implies(Permission) - Method in class java.security.ProtectionDomain
Check and see if this ProtectionDomain implies the permissions expressed in the Permission object.
implies(Permission) - Method in class java.security.UnresolvedPermission
This method always returns false for unresolved permissions.
implies(Permission) - Method in class java.util.PropertyPermission
Checks if this PropertyPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.management.MBeanPermission
Checks if this MBeanPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.management.MBeanServerPermission
Checks if this MBeanServerPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.kerberos.DelegationPermission
Checks if this Kerberos delegation permission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.kerberos.ServicePermission
Checks if this Kerberos service permission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.PrivateCredentialPermission
Checks if this PrivateCredentialPermission implies the specified Permission.
implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's malformed-input action.
implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's malformed-input action.
implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's unmappable-character action.
implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's unmappable-character action.
implReplaceWith(String) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's replacement value.
implReplaceWith(byte[]) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's replacement value.
implReset() - Method in class java.nio.charset.CharsetDecoder
Resets this decoder, clearing any charset-specific internal state.
implReset() - Method in class java.nio.charset.CharsetEncoder
Resets this encoder, clearing any charset-specific internal state.
importData(TransferHandler.TransferSupport) - Method in class javax.swing.TransferHandler
Causes a transfer to occur from a clipboard or a drag and drop operation.
importData(JComponent, Transferable) - Method in class javax.swing.TransferHandler
Causes a transfer to a component from a clipboard or a DND drop operation.
importedKeyCascade - Static variable in interface java.sql.DatabaseMetaData
For the column UPDATE_RULE, indicates that when the primary key is updated, the foreign key (imported key) is changed to agree with it.
importedKeyInitiallyDeferred - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyInitiallyImmediate - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyNoAction - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that if the primary key has been imported, it cannot be updated or deleted.
importedKeyNotDeferrable - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyRestrict - Static variable in interface java.sql.DatabaseMetaData
For the column UPDATE_RULE, indicates that a primary key may not be updated if it has been imported by another table as a foreign key.
importedKeySetDefault - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that if the primary key is updated or deleted, the foreign key (imported key) is set to the default value.
importedKeySetNull - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that when the primary key is updated or deleted, the foreign key (imported key) is changed to NULL.
importNode(Node, boolean) - Method in interface org.w3c.dom.Document
Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
importPreferences(InputStream) - Static method in class java.util.prefs.Preferences
Imports all of the preferences represented by the XML document on the specified input stream.
importStyleSheet(URL) - Method in class javax.swing.text.html.StyleSheet
Imports a style sheet from url.
in - Static variable in class java.io.FileDescriptor
A handle to the standard input stream.
in - Variable in class java.io.FilterInputStream
The input stream to be filtered.
in - Variable in class java.io.FilterReader
The underlying character-input stream.
in - Variable in class java.io.PipedInputStream
The index of the position in the circular buffer at which the next byte of data will be stored when received from the connected piped output stream.
in(Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Creates a lookup on the specified new lookup class.
in - Static variable in class java.lang.System
The "standard" input stream.
in(ValueExp, ValueExp[]) - Static method in class javax.management.Query
Returns an expression constraining a value to be one of an explicit list.
inactive(ActivationID) - Static method in class java.rmi.activation.Activatable
Informs the system that the object with the corresponding activation id is currently inactive.
INACTIVE - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/INACTIVE.java .
INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
INACTIVE_CAPTION - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaption system color.
INACTIVE_CAPTION_BORDER - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaptionBorder system color.
INACTIVE_CAPTION_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaptionText system color.
inactiveCaption - Static variable in class java.awt.SystemColor
The color rendered for the window-title background of inactive windows.
inactiveCaptionBorder - Static variable in class java.awt.SystemColor
The color rendered for the border around inactive windows.
inactiveCaptionText - Static variable in class java.awt.SystemColor
The color rendered for the window-title text of inactive windows.
inactiveGroup() - Method in class java.rmi.activation.ActivationGroup
This protected method is necessary for subclasses to make the inactiveGroup callback to the group's monitor.
inactiveGroup(ActivationGroupID, long) - Method in interface java.rmi.activation.ActivationMonitor
Informs that the group is now inactive.
inactiveObject(ActivationID) - Method in class java.rmi.activation.ActivationGroup
The group's inactiveObject method is called indirectly via a call to the Activatable.inactive method.
inactiveObject(ActivationID) - Method in interface java.rmi.activation.ActivationMonitor
An activation group calls its monitor's inactiveObject method when an object in its group becomes inactive (deactivates).
INBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
incarnate(byte[], POA) - Method in class org.omg.PortableServer._ServantActivatorStub
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
incarnate(byte[], POA) - Method in interface org.omg.PortableServer.ServantActivatorOperations
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
INCH - Static variable in class javax.print.attribute.Size2DSyntax
Value to indicate units of inches (in).
INCH - Static variable in class javax.print.attribute.standard.MediaPrintableArea
Value to indicate units of inches (in).
inCheck - Variable in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
inClass(String) - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
inClassLoader() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
include(RowFilter.Entry<? extends M, ? extends I>) - Method in class javax.swing.RowFilter
Returns true if the specified entry should be shown; returns false if the entry should be hidden.
inclusions - Variable in class javax.swing.text.html.parser.Element
INCLUSIVE - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Canonical XML (without comments) canonicalization method algorithm URI.
INCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Canonical XML with comments canonicalization method algorithm URI.
IncompatibleClassChangeError - Error in java.lang
Thrown when an incompatible class change has occurred to some class definition.
IncompatibleClassChangeError() - Constructor for error java.lang.IncompatibleClassChangeError
Constructs an IncompatibleClassChangeError with no detail message.
IncompatibleClassChangeError(String) - Constructor for error java.lang.IncompatibleClassChangeError
Constructs an IncompatibleClassChangeError with the specified detail message.
IncompleteAnnotationException - Exception in java.lang.annotation
Thrown to indicate that a program has attempted to access an element of an annotation type that was added to the annotation type definition after the annotation was compiled (or serialized).
IncompleteAnnotationException(Class<? extends Annotation>, String) - Constructor for exception java.lang.annotation.IncompleteAnnotationException
Constructs an IncompleteAnnotationException to indicate that the named element was missing from the specified annotation type.
InconsistentTypeCode - Exception in org.omg.CORBA.ORBPackage
InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
InconsistentTypeCode() - Constructor for exception org.omg.CORBA.ORBPackage.InconsistentTypeCode
Constructs an InconsistentTypeCode user exception with no reason message.
InconsistentTypeCode(String) - Constructor for exception org.omg.CORBA.ORBPackage.InconsistentTypeCode
Constructs an InconsistentTypeCode user exception with the specified reason message.
InconsistentTypeCode - Exception in org.omg.DynamicAny.DynAnyFactoryPackage
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
InconsistentTypeCode() - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
InconsistentTypeCode(String) - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
InconsistentTypeCodeHelper - Class in org.omg.DynamicAny.DynAnyFactoryPackage
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java .
InconsistentTypeCodeHelper() - Constructor for class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
incrButton - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
INCREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic.BasicScrollBarUI
increaseButton - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
INCREMENT - Static variable in interface javax.accessibility.AccessibleAction
An action which increments a value.
incrementAndGet() - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically increments by one the current value.
incrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically increments by one the element at index i.
incrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically increments by one the current value of the field of the given object managed by this updater.
incrementAndGet() - Method in class java.util.concurrent.atomic.AtomicLong
Atomically increments by one the current value.
incrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically increments by one the element at index i.
incrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically increments by one the current value of the field of the given object managed by this updater.
incrementAnimationIndex() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
Sets the index of the current animation frame, to the next valid value, which results in the progress bar being repainted.
incrGap - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
Distance between the increment button and the track.
incrIndent() - Method in class javax.swing.text.AbstractWriter
Increments the indent level.
inDaylightTime(Date) - Method in class java.util.SimpleTimeZone
Queries if the given date is in daylight saving time.
inDaylightTime(Date) - Method in class java.util.TimeZone
Queries if the given date is in Daylight Saving Time in this time zone.
INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss.GSSContext
A lifetime constant representing indefinite context lifetime.
INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss.GSSCredential
A lifetime constant representing indefinite credential lifetime.
indent() - Method in class javax.swing.text.AbstractWriter
Does indentation.
INDENT - Static variable in class javax.xml.transform.OutputKeys
indent = "yes" | "no".
INDETERMINATE - Static variable in class javax.accessibility.AccessibleState
Indicates that the object state is indeterminate.
INDETERMINATE - Static variable in class javax.xml.datatype.DatatypeConstants
Comparison result.
index - Variable in class javax.swing.text.html.parser.Element
index - Variable in exception org.omg.PortableServer.POAPackage.InvalidPolicy
INDEX_SIZE_ERR - Static variable in exception org.w3c.dom.DOMException
If index or size is negative, or greater than the allowed value.
indexAtLocation(int, int) - Method in class javax.swing.JTabbedPane
Returns the tab index corresponding to the tab whose bounds intersect the specified location.
IndexColorModel - Class in java.awt.image
The IndexColorModel class is a ColorModel class that works with pixel values consisting of a single sample that is an index into a fixed colormap in the default sRGB color space.
IndexColorModel(int, int, byte[], byte[], byte[]) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the specified arrays of red, green, and blue components.
IndexColorModel(int, int, byte[], byte[], byte[], int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the given arrays of red, green, and blue components.
IndexColorModel(int, int, byte[], byte[], byte[], byte[]) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the given arrays of red, green, blue and alpha components.
IndexColorModel(int, int, byte[], int, boolean) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from a single array of interleaved red, green, blue and optional alpha components.
IndexColorModel(int, int, byte[], int, boolean, int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from a single array of interleaved red, green, blue and optional alpha components.
IndexColorModel(int, int, int[], int, boolean, int, int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from an array of ints where each int is comprised of red, green, blue, and optional alpha components in the default RGB color model format.
IndexColorModel(int, int, int[], int, int, BigInteger) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from an int array where each int is comprised of red, green, blue, and alpha components in the default RGB color model format.
IndexedPropertyChangeEvent - Class in java.beans
An "IndexedPropertyChange" event gets delivered whenever a component that conforms to the JavaBeans™ specification (a "bean") changes a bound indexed property.
IndexedPropertyChangeEvent(Object, String, Object, Object, int) - Constructor for class java.beans.IndexedPropertyChangeEvent
Constructs a new IndexedPropertyChangeEvent object.
IndexedPropertyDescriptor - Class in java.beans
An IndexedPropertyDescriptor describes a property that acts like an array and has an indexed read and/or indexed write method to access specific elements of the array.
IndexedPropertyDescriptor(String, Class<?>) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor constructs an IndexedPropertyDescriptor for a property that follows the standard Java conventions by having getFoo and setFoo accessor methods, for both indexed access and array access.
IndexedPropertyDescriptor(String, Class<?>, String, String, String, String) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor takes the name of a simple property, and method names for reading and writing the property, both indexed and non-indexed.
IndexedPropertyDescriptor(String, Method, Method, Method, Method) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor takes the name of a simple property, and Method objects for reading and writing the property.
indexOf(int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified character.
indexOf(int, int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified character, starting the search at the specified index.
indexOf(String) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified substring.
indexOf(String, int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified substring, starting at the specified index.
indexOf(String) - Method in class java.lang.StringBuffer
indexOf(String, int) - Method in class java.lang.StringBuffer
indexOf(String) - Method in class java.lang.StringBuilder
indexOf(String, int) - Method in class java.lang.StringBuilder
indexOf(Object) - Method in class java.util.AbstractList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.ArrayList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(E, int) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the first occurrence of the specified element in this list, searching forwards from index, or returns -1 if the element is not found.
indexOf(Object) - Method in class java.util.LinkedList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in interface java.util.List
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.Vector
Returns the index of the first occurrence of the specified element in this vector, or -1 if this vector does not contain the element.
indexOf(Object, int) - Method in class java.util.Vector
Returns the index of the first occurrence of the specified element in this vector, searching forwards from index, or returns -1 if the element is not found.
indexOf(Object) - Method in class javax.swing.DefaultListModel
Searches for the first occurrence of elem.
indexOf(Object, int) - Method in class javax.swing.DefaultListModel
Searches for the first occurrence of elem, beginning the search at index.
indexOf(Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
indexOfComponent(Component) - Method in class javax.swing.JTabbedPane
Returns the index of the tab for the specified component.
indexOfSubList(List<?>, List<?>) - Static method in class java.util.Collections
Returns the starting position of the first occurrence of the specified target list within the specified source list, or -1 if there is no such occurrence.
indexOfTab(String) - Method in class javax.swing.JTabbedPane
Returns the first tab index with a given title, or -1 if no tab has this title.
indexOfTab(Icon) - Method in class javax.swing.JTabbedPane
Returns the first tab index with a given icon, or -1 if no tab has this icon.
indexOfTabComponent(Component) - Method in class javax.swing.JTabbedPane
Returns the index of the tab for the specified tab component.
IndexOutOfBoundsException - Exception in java.lang
Thrown to indicate that an index of some sort (such as to an array, to a string, or to a vector) is out of range.
IndexOutOfBoundsException() - Constructor for exception java.lang.IndexOutOfBoundsException
Constructs an IndexOutOfBoundsException with no detail message.
IndexOutOfBoundsException(String) - Constructor for exception java.lang.IndexOutOfBoundsException
Constructs an IndexOutOfBoundsException with the specified detail message.
indexToLocation(int) - Method in class javax.swing.JList
Returns the origin of the specified item in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.basic.BasicListUI
Returns the origin in the given JList, of the specified item, in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.ListUI
Returns the origin in the given JList, of the specified item, in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the indexToLocation method on each UI handled by this object.
IndirectionException - Exception in org.omg.CORBA.portable
The Indirection exception is a Java specific system exception.
IndirectionException(int) - Constructor for exception org.omg.CORBA.portable.IndirectionException
Creates an IndirectionException with the right offset value.
Inet4Address - Class in java.net
This class represents an Internet Protocol version 4 (IPv4) address.
Inet6Address - Class in java.net
This class represents an Internet Protocol version 6 (IPv6) address.
InetAddress - Class in java.net
This class represents an Internet Protocol (IP) address.
InetSocketAddress - Class in java.net
This class implements an IP Socket Address (IP address + port number) It can also be a pair (hostname + port number), in which case an attempt will be made to resolve the hostname.
InetSocketAddress(int) - Constructor for class java.net.InetSocketAddress
Creates a socket address where the IP address is the wildcard address and the port number a specified value.
InetSocketAddress(InetAddress, int) - Constructor for class java.net.InetSocketAddress
Creates a socket address from an IP address and a port number.
InetSocketAddress(String, int) - Constructor for class java.net.InetSocketAddress
Creates a socket address from a hostname and a port number.
inf - Variable in class java.util.zip.InflaterInputStream
Decompressor for this stream.
inf - Variable in class java.util.zip.InflaterOutputStream
Decompressor for this stream.
inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in class javax.tools.ForwardingJavaFileManager
inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in interface javax.tools.JavaFileManager
Infers a binary name of a file object based on a location.
inflate(byte[], int, int) - Method in class java.util.zip.Inflater
Uncompresses bytes into specified buffer.
inflate(byte[]) - Method in class java.util.zip.Inflater
Uncompresses bytes into specified buffer.
Inflater - Class in java.util.zip
This class provides support for general purpose decompression using the popular ZLIB compression library.
Inflater(boolean) - Constructor for class java.util.zip.Inflater
Creates a new decompressor.
Inflater() - Constructor for class java.util.zip.Inflater
Creates a new decompressor.
InflaterInputStream - Class in java.util.zip
This class implements a stream filter for uncompressing data in the "deflate" compression format.
InflaterInputStream(InputStream, Inflater, int) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with the specified decompressor and buffer size.
InflaterInputStream(InputStream, Inflater) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with the specified decompressor and a default buffer size.
InflaterInputStream(InputStream) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with a default decompressor and buffer size.
InflaterOutputStream - Class in java.util.zip
Implements an output stream filter for uncompressing data stored in the "deflate" compression format.
InflaterOutputStream(OutputStream) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with a default decompressor and buffer size.
InflaterOutputStream(OutputStream, Inflater) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with the specified decompressor and a default buffer size.
InflaterOutputStream(OutputStream, Inflater, int) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with the specified decompressor and buffer size.
INFO - Static variable in class java.awt.SystemColor
The array index for the SystemColor.info system color.
info - Static variable in class java.awt.SystemColor
The color rendered for the background of tooltips or spot help.
INFO - Static variable in class java.util.logging.Level
INFO is a message level for informational messages.
info(String) - Method in class java.util.logging.Logger
Log an INFO message.
INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is read-like: it returns information but does not change any state.
INFO_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.infoText system color.
inFontTag() - Method in class javax.swing.text.html.MinimalHTMLWriter
Returns true if we are currently in a <font> tag.
inForkJoinPool() - Static method in class java.util.concurrent.ForkJoinTask
Returns true if the current thread is a ForkJoinWorkerThread executing as a ForkJoinPool computation.
INFORMATION - Static variable in class javax.security.auth.callback.ConfirmationCallback
INFORMATION message type.
INFORMATION - Static variable in class javax.security.auth.callback.TextOutputCallback
Information message.
INFORMATION_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
INFORMATION_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for information messages.
infoText - Static variable in class java.awt.SystemColor
The color rendered for the text of tooltips or spot help.
INHERIT - Static variable in class java.lang.ProcessBuilder.Redirect
Indicates that subprocess I/O source or destination will be the same as those of the current process.
InheritableThreadLocal<T> - Class in java.lang
This class extends ThreadLocal to provide inheritance of values from parent thread to child thread: when a child thread is created, the child receives initial values for all inheritable thread-local variables for which the parent has values.
InheritableThreadLocal() - Constructor for class java.lang.InheritableThreadLocal
Inherited - Annotation Type in java.lang.annotation
Indicates that an annotation type is automatically inherited.
inheritedChannel() - Static method in class java.lang.System
Returns the channel inherited from the entity that created this Java virtual machine.
inheritedChannel() - Method in class java.nio.channels.spi.SelectorProvider
Returns the channel inherited from the entity that created this Java virtual machine.
inheritIO() - Method in class java.lang.ProcessBuilder
Sets the source and destination for subprocess standard I/O to be the same as those of the current Java process.
inHitRegion(int, int) - Method in class javax.swing.tree.DefaultTreeCellEditor
Returns true if the passed in location is a valid mouse location to start editing from.
init() - Method in class java.applet.Applet
Called by the browser or applet viewer to inform this applet that it has been loaded into the system.
init(int) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator for a certain size.
init(int, SecureRandom) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator for a certain size and source of randomness.
init(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
init(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
init(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParameters
Initializes this parameter object using the parameters specified in paramSpec.
init(byte[]) - Method in class java.security.AlgorithmParameters
Imports the specified parameters and decodes them according to the primary decoding format for parameters.
init(byte[], String) - Method in class java.security.AlgorithmParameters
Imports the parameters from params and decodes them according to the specified decoding scheme.
init(boolean) - Method in class java.security.cert.PKIXCertPathChecker
Initializes the internal state of this PKIXCertPathChecker.
init(ProcessingEnvironment) - Method in class javax.annotation.processing.AbstractProcessor
Initializes the processor with the processing environment by setting the processingEnv field to the value of the processingEnv argument.
init(ProcessingEnvironment) - Method in interface javax.annotation.processing.Processor
Initializes the processor with the processing environment.
init(int, Key) - Method in class javax.crypto.Cipher
Initializes this cipher with a key.
init(int, Key, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a source of randomness.
init(int, Key, AlgorithmParameterSpec) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a set of algorithm parameters.
init(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
init(int, Key, AlgorithmParameters) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a set of algorithm parameters.
init(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
init(int, Certificate) - Method in class javax.crypto.Cipher
Initializes this cipher with the public key from the given certificate.
init(int, Certificate, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with the public key from the given certificate and a source of randomness.
init(Key) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key and a set of algorithm parameters.
init(Key, AlgorithmParameters) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key and a set of algorithm parameters.
init(Key) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key, which is required to contain all the algorithm parameters required for this key agreement.
init(Key, SecureRandom) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key and source of randomness.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key and set of algorithm parameters.
init(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key, set of algorithm parameters, and source of randomness.
init(SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator.
init(AlgorithmParameterSpec) - Method in class javax.crypto.KeyGenerator
Initializes this key generator with the specified parameter set.
init(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator with the specified parameter set and a user-provided source of randomness.
init(int) - Method in class javax.crypto.KeyGenerator
Initializes this key generator for a certain keysize.
init(int, SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator for a certain keysize, using a user-provided source of randomness.
init(Key) - Method in class javax.crypto.Mac
Initializes this Mac object with the given key.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.Mac
Initializes this Mac object with the given key and algorithm parameters.
init(Hashtable<?, ?>) - Method in class javax.naming.InitialContext
Initializes the initial context using the supplied environment.
init(KeyStore, char[]) - Method in class javax.net.ssl.KeyManagerFactory
Initializes this factory with a source of key material.
init(ManagerFactoryParameters) - Method in class javax.net.ssl.KeyManagerFactory
Initializes this factory with a source of provider-specific key material.
init(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl.SSLContext
Initializes this context.
init(KeyStore) - Method in class javax.net.ssl.TrustManagerFactory
Initializes this factory with a source of certificate authorities and related trust material.
init(ManagerFactoryParameters) - Method in class javax.net.ssl.TrustManagerFactory
Initializes this factory with a source of provider-specific trust material.
init(String, Icon) - Method in class javax.swing.AbstractButton
init(String, Icon) - Method in class javax.swing.JMenuItem
Initializes the menu item with the specified text and icon.
init(StateEditable, String) - Method in class javax.swing.undo.StateEdit
init(TransformParameterSpec) - Method in class javax.xml.crypto.dsig.TransformService
Initializes this TransformService with the specified parameters.
init(XMLStructure, XMLCryptoContext) - Method in class javax.xml.crypto.dsig.TransformService
Initializes this TransformService with the specified parameters and document context.
init() - Static method in class org.omg.CORBA.ORB
Returns the ORB singleton object.
init(String[], Properties) - Static method in class org.omg.CORBA.ORB
Creates a new ORB instance for a standalone application.
init(Applet, Properties) - Static method in class org.omg.CORBA.ORB
Creates a new ORB instance for an applet.
initCause(Throwable) - Method in class java.lang.Throwable
Initializes the cause of this throwable to the specified value.
initCause(Throwable) - Method in exception javax.naming.NamingException
Initializes the cause of this exception to the specified value.
initCause(Throwable) - Method in exception javax.security.sasl.SaslException
initCause(Throwable) - Method in exception javax.xml.soap.SOAPException
Initializes the cause field of this SOAPException object with the given Throwable object.
initCause(Throwable) - Method in exception javax.xml.transform.TransformerException
Initializes the cause of this throwable to the specified value.
initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with mappings from uiClassID to the fully qualified name of the ui class.
initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with mappings from uiClassID to the fully qualified name of the ui class.
initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with the defaults for the basic look and feel.
initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with the defaults for metal.
initEvent(String, boolean, boolean) - Method in interface org.w3c.dom.events.Event
The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
INITIAL_CONTEXT_FACTORY - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the initial context factory to use.
INITIAL_QUOTE_PUNCTUATION - Static variable in class java.lang.Character
General category "Pi" in the Unicode specification.
INITIAL_SELECTION_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for initialSelectionValue.
INITIAL_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for initialValue.
InitialContext - Class in javax.naming
This class is the starting context for performing naming operations.
InitialContext(boolean) - Constructor for class javax.naming.InitialContext
Constructs an initial context with the option of not initializing it.
InitialContext() - Constructor for class javax.naming.InitialContext
Constructs an initial context.
InitialContext(Hashtable<?, ?>) - Constructor for class javax.naming.InitialContext
Constructs an initial context using the supplied environment.
InitialContextFactory - Interface in javax.naming.spi
This interface represents a factory that creates an initial context.
InitialContextFactoryBuilder - Interface in javax.naming.spi
This interface represents a builder that creates initial context factories.
InitialDirContext - Class in javax.naming.directory
This class is the starting context for performing directory operations.
InitialDirContext(boolean) - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext with the option of not initializing it.
InitialDirContext() - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext.
InitialDirContext(Hashtable<?, ?>) - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext using the supplied environment.
initialFocusComponent - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
Component to receive focus when messaged with selectInitialValue.
initialize(Applet, BeanContext) - Method in interface java.beans.AppletInitializer
If passed to the appropriate variant of java.beans.Beans.instantiate this method will be called in order to associate the newly instantiated Applet (JavaBean) with its AppletContext, AppletStub, and Container.
initialize() - Method in class java.beans.beancontext.BeanContextServicesSupport
called by BeanContextSupport superclass during construction and deserialization to initialize subclass transient state.
initialize() - Method in class java.beans.beancontext.BeanContextSupport
protected method called from constructor and readObject to initialize transient state of BeanContextSupport instance.
initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans.DefaultPersistenceDelegate
This default implementation of the initialize method assumes all state held in objects of this type is exposed via the matching pairs of "setter" and "getter" methods in the order they are returned by the Introspector.
initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans.PersistenceDelegate
Produce a series of statements with side effects on newInstance so that the new instance becomes equivalent to oldInstance.
initialize(DSAParams, SecureRandom) - Method in interface java.security.interfaces.DSAKeyPairGenerator
Initializes the key pair generator using the DSA family parameters (p,q and g) and an optional SecureRandom bit source.
initialize(int, boolean, SecureRandom) - Method in interface java.security.interfaces.DSAKeyPairGenerator
Initializes the key pair generator for a given modulus length (instead of parameters), and an optional SecureRandom bit source.
initialize(int) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator for a certain keysize using a default parameter set and the SecureRandom implementation of the highest-priority installed provider as the source of randomness.
initialize(int, SecureRandom) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator for a certain keysize with the given source of randomness (and a default parameter set).
initialize(AlgorithmParameterSpec) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator using the specified parameter set and the SecureRandom implementation of the highest-priority installed provider as the source of randomness.
initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator with the given parameter set and source of randomness.
initialize(int, SecureRandom) - Method in class java.security.KeyPairGeneratorSpi
Initializes the key pair generator for a certain keysize, using the default parameter set.
initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.KeyPairGeneratorSpi
Initializes the key pair generator using the specified parameter set and user-provided source of randomness.
initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in interface javax.security.auth.spi.LoginModule
Initialize this LoginModule.
initialize() - Method in class javax.swing.LookAndFeel
Initializes the look and feel.
initialize() - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Initializes the look and feel.
initialize() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel
Called by UIManager when this look and feel is installed.
initialize() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Called by UIManager when this look and feel is installed.
INITIALIZE - Exception in org.omg.CORBA
Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
INITIALIZE() - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.
INITIALIZE(String) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
INITIALIZE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified minor code and completion status.
INITIALIZE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.
initializeAutoscrolling(Point) - Method in class java.awt.dnd.DropTarget
initialize autoscrolling
initializeBeanContextResources() - Method in class java.beans.beancontext.BeanContextChildSupport
This method may be overridden by subclasses to provide their own initialization behaviors.
initializeBeanContextResources() - Method in class java.beans.beancontext.BeanContextServicesSupport
called from setBeanContext to notify a BeanContextChild to allocate resources obtained from the nesting BeanContext.
initializeDesktopProperties() - Method in class java.awt.Toolkit
initializeDesktopProperties
initializeLocalVars() - Method in class javax.swing.JTable
Initializes table properties to their default values.
initializeLocalVars() - Method in class javax.swing.table.JTableHeader
Initializes the local variables and properties with default values.
InitialLdapContext - Class in javax.naming.ldap
This class is the starting context for performing LDAPv3-style extended operations and controls.
InitialLdapContext() - Constructor for class javax.naming.ldap.InitialLdapContext
Constructs an initial context using no environment properties or connection request controls.
InitialLdapContext(Hashtable<?, ?>, Control[]) - Constructor for class javax.naming.ldap.InitialLdapContext
Constructs an initial context using environment properties and connection request controls.
initialSelectionValue - Variable in class javax.swing.JOptionPane
Initial value to select in selectionValues.
initialSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
initialValue() - Method in class java.lang.ThreadLocal
Returns the current thread's "initial value" for this thread-local variable.
initialValue - Variable in class javax.swing.JOptionPane
Value that should be initially selected in options.
INITIATE_AND_ACCEPT - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for both context initiation and acceptance.
INITIATE_ONLY - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for context initiation only.
initMouseEvent(String, boolean, boolean, AbstractView, int, int, int, int, int, boolean, boolean, boolean, boolean, short, EventTarget) - Method in interface org.w3c.dom.events.MouseEvent
The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
initMutationEvent(String, boolean, boolean, Node, String, String, String, short) - Method in interface org.w3c.dom.events.MutationEvent
The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.
InitParam - Annotation Type in javax.jws.soap
Deprecated.
As of JSR-181 2.0 with no replacement.
initParams() - Method in class javax.sql.rowset.BaseRowSet
Performs the necessary internal configurations and initializations to allow any JDBC RowSet implementation to start using the standard facilities provided by a BaseRowSet instance.
initSecContext(byte[], int, int) - Method in interface org.ietf.jgss.GSSContext
Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
initSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss.GSSContext
Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
initSign(PrivateKey) - Method in class java.security.Signature
Initialize this object for signing.
initSign(PrivateKey, SecureRandom) - Method in class java.security.Signature
Initialize this object for signing.
initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with system colors.
initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with system colors.
initUIEvent(String, boolean, boolean, AbstractView, int) - Method in interface org.w3c.dom.events.UIEvent
The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.
initVerify(PublicKey) - Method in class java.security.Signature
Initializes this object for verification.
initVerify(Certificate) - Method in class java.security.Signature
Initializes this object for verification, using the public key from the given certificate.
inject(WebServiceContext) - Method in class javax.xml.ws.spi.Invoker
JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
InlineView - Class in javax.swing.text.html
Displays the inline element styles based upon css attributes.
InlineView(Element) - Constructor for class javax.swing.text.html.InlineView
Constructs a new view wrapped on an element.
INNER_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a inner join between two tables.
input - Variable in class javax.imageio.ImageReader
The ImageInputStream or other Object by setInput and retrieved by getInput.
INPUT - Static variable in class javax.swing.text.html.HTML.Tag
INPUT_METHOD_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting input method events.
INPUT_METHOD_FIRST - Static variable in class java.awt.event.InputMethodEvent
Marks the first integer id for the range of input method event ids.
INPUT_METHOD_HIGHLIGHT - Static variable in class java.awt.font.TextAttribute
Attribute key for input method highlight styles.
INPUT_METHOD_LAST - Static variable in class java.awt.event.InputMethodEvent
Marks the last integer id for the range of input method event ids.
INPUT_METHOD_SEGMENT - Static variable in class java.text.AttributedCharacterIterator.Attribute
Attribute key for input method segments.
INPUT_METHOD_TEXT_CHANGED - Static variable in class java.awt.event.InputMethodEvent
The event type indicating changed input method text.
INPUT_METHOD_UNDERLINE - Static variable in class java.awt.font.TextAttribute
Attribute key for input method underlines.
INPUT_TRAY_MISSING - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more input trays are not in the device.
INPUT_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for inputValue.
inputClass - Variable in class javax.imageio.spi.ImageInputStreamSpi
A 类 object indicating the legal object type for use by the createInputStreamInstance method.
inputComponent - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
JComponent provide for input if optionPane.getWantsInput() returns true.
InputContext - Class in java.awt.im
Provides methods to control text input facilities such as input methods and keyboard layouts.
InputContext() - Constructor for class java.awt.im.InputContext
Constructs an InputContext.
InputEvent - Class in java.awt.event
The root event class for all component-level input events.
InputMap - Class in javax.swing
InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object.
InputMap() - Constructor for class javax.swing.InputMap
Creates an InputMap with no parent and no mappings.
InputMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.InputMap that implements UIResource.
InputMapUIResource() - Constructor for class javax.swing.plaf.InputMapUIResource
InputMethod - Interface in java.awt.im.spi
Defines the interface for an input method that supports complex text input.
InputMethodContext - Interface in java.awt.im.spi
Provides methods that input methods can use to communicate with their client components or to request other services.
InputMethodDescriptor - Interface in java.awt.im.spi
Defines methods that provide sufficient information about an input method to enable selection and loading of that input method.
InputMethodEvent - Class in java.awt.event
Input method events contain information about text that is being composed using an input method.
InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, time, text, caret, and visiblePosition.
InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, text, caret, and visiblePosition.
InputMethodEvent(Component, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, caret, and visiblePosition.
InputMethodHighlight - Class in java.awt.im
An InputMethodHighlight is used to describe the highlight attributes of text being composed.
InputMethodHighlight(boolean, int) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodHighlight(boolean, int, int) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodHighlight(boolean, int, int, Map<TextAttribute, ?>) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodListener - Interface in java.awt.event
The listener interface for receiving input method events.
InputMethodRequests - Interface in java.awt.im
InputMethodRequests defines the requests that a text editing component has to handle in order to work with input methods.
inputMethodTextChanged(InputMethodEvent) - Method in class java.awt.AWTEventMulticaster
Handles the inputMethodTextChanged event by invoking the inputMethodTextChanged methods on listener-a and listener-b.
inputMethodTextChanged(InputMethodEvent) - Method in interface java.awt.event.InputMethodListener
Invoked when the text entered through an input method has changed.
InputMismatchException - Exception in java.util
Thrown by a Scanner to indicate that the token retrieved does not match the pattern for the expected type, or that the token is out of range for the expected type.
InputMismatchException() - Constructor for exception java.util.InputMismatchException
Constructs an InputMismatchException with null as its error message string.
InputMismatchException(String) - Constructor for exception java.util.InputMismatchException
Constructs an InputMismatchException, saving a reference to the error message string s for later retrieval by the getMessage method.
InputSource - Class in org.xml.sax
A single input source for an XML entity.
InputSource() - Constructor for class org.xml.sax.InputSource
Zero-argument default constructor.
InputSource(String) - Constructor for class org.xml.sax.InputSource
Create a new input source with a system identifier.
InputSource(InputStream) - Constructor for class org.xml.sax.InputSource
Create a new input source with a byte stream.
InputSource(Reader) - Constructor for class org.xml.sax.InputSource
Create a new input source with a character stream.
InputStream - Class in java.io
This abstract class is the superclass of all classes representing an input stream of bytes.
InputStream() - Constructor for class java.io.InputStream
InputStream - Class in org.omg.CORBA.portable
InputStream is the Java API for reading IDL types from CDR marshal streams.
InputStream() - Constructor for class org.omg.CORBA.portable.InputStream
InputStream - Class in org.omg.CORBA_2_3.portable
InputStream provides for the reading of all of the mapped IDL types from the stream.
InputStream() - Constructor for class org.omg.CORBA_2_3.portable.InputStream
InputStreamReader - Class in java.io
An InputStreamReader is a bridge from byte streams to character streams: It reads bytes and decodes them into characters using a specified charset.
InputStreamReader(InputStream) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the default charset.
InputStreamReader(InputStream, String) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the named charset.
InputStreamReader(InputStream, Charset) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the given charset.
InputStreamReader(InputStream, CharsetDecoder) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the given charset decoder.
InputSubset - Class in java.awt.im
Defines additional Unicode subsets for use by input methods.
inputTypes - Variable in class javax.imageio.spi.ImageReaderSpi
An array of 类 objects to be returned from getInputTypes, initially null.
inputValue - Variable in class javax.swing.JOptionPane
Value the user has input.
InputVerifier - Class in javax.swing
The purpose of this class is to help clients support smooth focus navigation through GUIs with text fields.
InputVerifier() - Constructor for class javax.swing.InputVerifier
inRange(Element) - Method in class javax.swing.text.AbstractWriter
This method determines whether the current element is in the range specified.
INSCRIPTIONAL_PAHLAVI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Inscriptional Pahlavi" Unicode character block.
INSCRIPTIONAL_PARTHIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Inscriptional Parthian" Unicode character block.
insert(String, int) - Method in class java.awt.Choice
Inserts the item into this choice at the specified position.
INSERT - Static variable in class java.awt.Event
The Insert key, a non-ASCII action key.
insert(MenuItem, int) - Method in class java.awt.Menu
Inserts a menu item into this menu at the specified position.
insert(String, int) - Method in class java.awt.Menu
Inserts a menu item with the specified label into this menu at the specified position.
insert(String, int) - Method in class java.awt.TextArea
Inserts the specified text at the specified position in this text area.
insert(int, char[], int, int) - Method in class java.lang.StringBuffer
insert(int, Object) - Method in class java.lang.StringBuffer
insert(int, String) - Method in class java.lang.StringBuffer
insert(int, char[]) - Method in class java.lang.StringBuffer
insert(int, CharSequence) - Method in class java.lang.StringBuffer
insert(int, CharSequence, int, int) - Method in class java.lang.StringBuffer
insert(int, boolean) - Method in class java.lang.StringBuffer
insert(int, char) - Method in class java.lang.StringBuffer
insert(int, int) - Method in class java.lang.StringBuffer
insert(int, long) - Method in class java.lang.StringBuffer
insert(int, float) - Method in class java.lang.StringBuffer
insert(int, double) - Method in class java.lang.StringBuffer
insert(int, char[], int, int) - Method in class java.lang.StringBuilder
insert(int, Object) - Method in class java.lang.StringBuilder
insert(int, String) - Method in class java.lang.StringBuilder
insert(int, char[]) - Method in class java.lang.StringBuilder
insert(int, CharSequence) - Method in class java.lang.StringBuilder
insert(int, CharSequence, int, int) - Method in class java.lang.StringBuilder
insert(int, boolean) - Method in class java.lang.StringBuilder
insert(int, char) - Method in class java.lang.StringBuilder
insert(int, int) - Method in class java.lang.StringBuilder
insert(int, long) - Method in class java.lang.StringBuilder
insert(int, float) - Method in class java.lang.StringBuilder
insert(int, double) - Method in class java.lang.StringBuilder
INSERT - Static variable in interface javax.accessibility.AccessibleTableModelChange
Identifies the insertion of new rows and/or columns.
INSERT - Static variable in class javax.swing.event.DocumentEvent.EventType
Insert type.
INSERT - Static variable in class javax.swing.event.TableModelEvent
Identifies the addtion of new rows or columns.
insert(String, int) - Method in class javax.swing.JMenu
Inserts a new menu item with the specified text at a given position.
insert(JMenuItem, int) - Method in class javax.swing.JMenu
Inserts the specified JMenuitem at a given position.
insert(Action, int) - Method in class javax.swing.JMenu
Inserts a new menu item attached to the specified Action object at a given position.
insert(Action, int) - Method in class javax.swing.JPopupMenu
Inserts a menu item for the specified Action object at a given position.
insert(Component, int) - Method in class javax.swing.JPopupMenu
Inserts the specified component into the menu at a given position.
insert(String, int) - Method in class javax.swing.JTextArea
Inserts the specified text at the specified position.
insert(int, int, DefaultStyledDocument.ElementSpec[], AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Inserts new content.
insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument
Inserts new elements in bulk.
insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html.HTMLDocument
Inserts new elements in bulk.
insert(int, View) - Method in class javax.swing.text.View
Inserts a single child view.
insert(MutableTreeNode, int) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
insert(MutableTreeNode, int) - Method in interface javax.swing.tree.MutableTreeNode
Adds child to the receiver at index.
insert(Any, Any[]) - Static method in class org.omg.CORBA.AnySeqHelper
insert(Any, boolean[]) - Static method in class org.omg.CORBA.BooleanSeqHelper
insert(Any, char[]) - Static method in class org.omg.CORBA.CharSeqHelper
insert(Any, CompletionStatus) - Static method in class org.omg.CORBA.CompletionStatusHelper
insert(Any, Current) - Static method in class org.omg.CORBA.CurrentHelper
insert(Any, DefinitionKind) - Static method in class org.omg.CORBA.DefinitionKindHelper
insert(Any, double[]) - Static method in class org.omg.CORBA.DoubleSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.FieldNameHelper
insert(Any, float[]) - Static method in class org.omg.CORBA.FloatSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.IdentifierHelper
insert(Any, IDLType) - Static method in class org.omg.CORBA.IDLTypeHelper
insert(Any, long[]) - Static method in class org.omg.CORBA.LongLongSeqHelper
insert(Any, int[]) - Static method in class org.omg.CORBA.LongSeqHelper
insert(Any, NameValuePair) - Static method in class org.omg.CORBA.NameValuePairHelper
insert(Any, Object) - Static method in class org.omg.CORBA.ObjectHelper
insert(Any, byte[]) - Static method in class org.omg.CORBA.OctetSeqHelper
insert(Any, ParameterMode) - Static method in class org.omg.CORBA.ParameterModeHelper
insert(Any, short) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
insert(Any, PolicyError) - Static method in class org.omg.CORBA.PolicyErrorHelper
insert(Any, Policy) - Static method in class org.omg.CORBA.PolicyHelper
insert(Any, Policy[]) - Static method in class org.omg.CORBA.PolicyListHelper
insert(Any, int) - Static method in class org.omg.CORBA.PolicyTypeHelper
insert(Any, String) - Static method in class org.omg.CORBA.RepositoryIdHelper
insert(Any, ServiceDetail) - Static method in class org.omg.CORBA.ServiceDetailHelper
insert(Any, ServiceInformation) - Static method in class org.omg.CORBA.ServiceInformationHelper
insert(Any, SetOverrideType) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
insert(Any, short[]) - Static method in class org.omg.CORBA.ShortSeqHelper
insert(Any, String[]) - Static method in class org.omg.CORBA.StringSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.StringValueHelper
insert(Any, StructMember) - Static method in class org.omg.CORBA.StructMemberHelper
insert(Any, long[]) - Static method in class org.omg.CORBA.ULongLongSeqHelper
insert(Any, int[]) - Static method in class org.omg.CORBA.ULongSeqHelper
insert(Any, UnionMember) - Static method in class org.omg.CORBA.UnionMemberHelper
insert(Any, UnknownUserException) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
insert(Any, short[]) - Static method in class org.omg.CORBA.UShortSeqHelper
insert(Any, Serializable) - Static method in class org.omg.CORBA.ValueBaseHelper
insert(Any, ValueMember) - Static method in class org.omg.CORBA.ValueMemberHelper
insert(Any, String) - Static method in class org.omg.CORBA.VersionSpecHelper
insert(Any, short) - Static method in class org.omg.CORBA.VisibilityHelper
insert(Any, char[]) - Static method in class org.omg.CORBA.WCharSeqHelper
insert(Any, WrongTransaction) - Static method in class org.omg.CORBA.WrongTransactionHelper
insert(Any, String[]) - Static method in class org.omg.CORBA.WStringSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.WStringValueHelper
insert(Any, Binding) - Static method in class org.omg.CosNaming.BindingHelper
insert(Any, BindingIterator) - Static method in class org.omg.CosNaming.BindingIteratorHelper
insert(Any, Binding[]) - Static method in class org.omg.CosNaming.BindingListHelper
insert(Any, BindingType) - Static method in class org.omg.CosNaming.BindingTypeHelper
insert(Any, String) - Static method in class org.omg.CosNaming.IstringHelper
insert(Any, NameComponent) - Static method in class org.omg.CosNaming.NameComponentHelper
insert(Any, NameComponent[]) - Static method in class org.omg.CosNaming.NameHelper
insert(Any, NamingContextExt) - Static method in class org.omg.CosNaming.NamingContextExtHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
insert(Any, InvalidAddress) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
insert(Any, NamingContext) - Static method in class org.omg.CosNaming.NamingContextHelper
insert(Any, AlreadyBound) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
insert(Any, CannotProceed) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
insert(Any, InvalidName) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
insert(Any, NotEmpty) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
insert(Any, NotFound) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
insert(Any, NotFoundReason) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
insert(Any, Any[]) - Static method in class org.omg.DynamicAny.AnySeqHelper
insert(Any, DynAnyFactory) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
insert(Any, InconsistentTypeCode) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
insert(Any, DynAny) - Static method in class org.omg.DynamicAny.DynAnyHelper
insert(Any, InvalidValue) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
insert(Any, TypeMismatch) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
insert(Any, DynAny[]) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
insert(Any, DynArray) - Static method in class org.omg.DynamicAny.DynArrayHelper
insert(Any, DynEnum) - Static method in class org.omg.DynamicAny.DynEnumHelper
insert(Any, DynFixed) - Static method in class org.omg.DynamicAny.DynFixedHelper
insert(Any, DynSequence) - Static method in class org.omg.DynamicAny.DynSequenceHelper
insert(Any, DynStruct) - Static method in class org.omg.DynamicAny.DynStructHelper
insert(Any, DynUnion) - Static method in class org.omg.DynamicAny.DynUnionHelper
insert(Any, DynValue) - Static method in class org.omg.DynamicAny.DynValueHelper
insert(Any, String) - Static method in class org.omg.DynamicAny.FieldNameHelper
insert(Any, NameDynAnyPair) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
insert(Any, NameDynAnyPair[]) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
insert(Any, NameValuePair) - Static method in class org.omg.DynamicAny.NameValuePairHelper
insert(Any, NameValuePair[]) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
insert(Any, CodecFactory) - Static method in class org.omg.IOP.CodecFactoryHelper
insert(Any, UnknownEncoding) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
insert(Any, FormatMismatch) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
insert(Any, InvalidTypeForEncoding) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
insert(Any, TypeMismatch) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
insert(Any, int) - Static method in class org.omg.IOP.ComponentIdHelper
insert(Any, IOR) - Static method in class org.omg.IOP.IORHelper
insert(Any, TaggedComponent[]) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
insert(Any, int) - Static method in class org.omg.IOP.ProfileIdHelper
insert(Any, ServiceContext) - Static method in class org.omg.IOP.ServiceContextHelper
insert(Any, ServiceContext[]) - Static method in class org.omg.IOP.ServiceContextListHelper
insert(Any, int) - Static method in class org.omg.IOP.ServiceIdHelper
insert(Any, TaggedComponent) - Static method in class org.omg.IOP.TaggedComponentHelper
insert(Any, TaggedProfile) - Static method in class org.omg.IOP.TaggedProfileHelper
insert(Any, short) - Static method in class org.omg.Messaging.SyncScopeHelper
insert(Any, int) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
insert(Any, String[]) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
insert(Any, short) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
insert(Any, Current) - Static method in class org.omg.PortableInterceptor.CurrentHelper
insert(Any, ForwardRequest) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
insert(Any, InvalidSlot) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
insert(Any, IORInterceptor_3_0) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
insert(Any, byte[]) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
insert(Any, ObjectReferenceFactory) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
insert(Any, ObjectReferenceTemplate) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
insert(Any, ObjectReferenceTemplate[]) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
insert(Any, DuplicateName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
insert(Any, InvalidName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
insert(Any, Current) - Static method in class org.omg.PortableServer.CurrentHelper
insert(Any, NoContext) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
insert(Any, ForwardRequest) - Static method in class org.omg.PortableServer.ForwardRequestHelper
insert(Any, POA) - Static method in class org.omg.PortableServer.POAHelper
insert(Any, AdapterInactive) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
insert(Any, AdapterAlreadyExists) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
insert(Any, AdapterNonExistent) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
insert(Any, InvalidPolicy) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
insert(Any, NoServant) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
insert(Any, ObjectAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
insert(Any, ObjectNotActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
insert(Any, ServantAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
insert(Any, ServantNotActive) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
insert(Any, WrongAdapter) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
insert(Any, WrongPolicy) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
insert(Any, ServantActivator) - Static method in class org.omg.PortableServer.ServantActivatorHelper
insert(Any, ServantLocator) - Static method in class org.omg.PortableServer.ServantLocatorHelper
insert_any(Any) - Method in class org.omg.CORBA.Any
Inserts the given Any object into this Any object's value field.
insert_any(Any) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
insert_any(Any) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an Any value into the Any represented by this DynAny.
insert_boolean(boolean) - Method in class org.omg.CORBA.Any
Inserts the given boolean into this Any object's value field.
insert_boolean(boolean) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given boolean as the value for this DynAny object.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a boolean value into the DynAny.
insert_char(char) - Method in class org.omg.CORBA.Any
Inserts the given char into this Any object's value field.
insert_char(char) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given char as the value for this DynAny object.
insert_char(char) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a char value into the DynAny.
insert_char(char) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a char value into the DynAny.
insert_double(double) - Method in class org.omg.CORBA.Any
Inserts the given double into this Any object's value field.
insert_double(double) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given double as the value for this DynAny object.
insert_double(double) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a double value into the DynAny.
insert_double(double) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a double value into the DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_fixed(BigDecimal) - Method in class org.omg.CORBA.Any
Throws an org.omg.CORBA.NO_IMPLEMENT exception.
insert_fixed(BigDecimal, TypeCode) - Method in class org.omg.CORBA.Any
Throws an org.omg.CORBA.NO_IMPLEMENT exception.
insert_float(float) - Method in class org.omg.CORBA.Any
Inserts the given float into this Any object's value field.
insert_float(float) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given float as the value for this DynAny object.
insert_float(float) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a float value into the DynAny.
insert_float(float) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a float value into the DynAny.
insert_long(int) - Method in class org.omg.CORBA.Any
Inserts the given int into this Any object's value field.
insert_long(int) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given int as the value for this DynAny object.
insert_long(int) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an integer value into the DynAny.
insert_longlong(long) - Method in class org.omg.CORBA.Any
Inserts the given long into this Any object's value field.
insert_longlong(long) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given long as the value for this DynAny object.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a long value into the DynAny.
insert_Object(Object) - Method in class org.omg.CORBA.Any
Inserts the given org.omg.CORBA.Object object into this Any object's value field.
insert_Object(Object, TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given org.omg.CORBA.Object object into this Any object's value field.
insert_octet(byte) - Method in class org.omg.CORBA.Any
Inserts the given byte into this Any object's value field.
insert_octet(byte) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given byte as the value for this DynAny object.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a byte value into the DynAny.
insert_Principal(Principal) - Method in class org.omg.CORBA.Any
Deprecated.
Deprecated by CORBA 2.2.
insert_reference(Object) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a reference to a CORBA object into the DynAny.
INSERT_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that a conflict occurred while the RowSet object was attempting to insert a row into the data source.
insert_short(short) - Method in class org.omg.CORBA.Any
Inserts the given short into this Any object's value field.
insert_short(short) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given short as the value for this DynAny object.
insert_short(short) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a short value into the DynAny.
insert_short(short) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a short value into the DynAny.
insert_Streamable(Streamable) - Method in class org.omg.CORBA.Any
Inserts the given Streamable object into this Any object's value field.
insert_string(String) - Method in class org.omg.CORBA.Any
Inserts the given String object into this Any object's value field.
insert_string(String) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given String object as the value for this DynAny object.
insert_string(String) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a string value into the DynAny.
insert_string(String) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a string value into the DynAny.
insert_TypeCode(TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given TypeCode object into this Any object's value field.
insert_typecode(TypeCode) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a TypeCode object into the DynAny.
insert_ulong(int) - Method in class org.omg.CORBA.Any
Inserts the given int into this Any object's value field.
insert_ulong(int) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given int as the value for this DynAny object.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an integer value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.CORBA.Any
Inserts the given long into this Any object's value field.
insert_ulonglong(long) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given long as the value for this DynAny object.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a long value into the DynAny.
insert_ushort(short) - Method in class org.omg.CORBA.Any
Inserts the given short into this Any object's value field.
insert_ushort(short) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given short as the value for this DynAny object.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a short value into the DynAny.
insert_val(Serializable) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given java.io.Serializable object as the value for this DynAny object.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a reference to a Serializable object into this DynAny.
insert_Value(Serializable) - Method in class org.omg.CORBA.Any
Inserts the given java.io.Serializable object into this Any object's value field.
insert_Value(Serializable, TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given java.io.Serializable object into this Any object's value field.
insert_wchar(char) - Method in class org.omg.CORBA.Any
Inserts the given char into this Any object's value field.
insert_wchar(char) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given char as the value for this DynAny object.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a char value into the DynAny.
insert_wstring(String) - Method in class org.omg.CORBA.Any
Inserts the given String object into this Any object's value field.
insert_wstring(String) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given String as the value for this DynAny object.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a string value into the DynAny.
insertAfterEnd(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string after the the end of the given element.
insertAfterStart(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string at the start of the element.
insertArguments(MethodHandle, int, Object...) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which calls the original method handle target, after inserting the given argument(s) at the given position.
insertAtBoundary(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
This is invoked when inserting at a boundary.
insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Deprecated.
As of Java 2 platform v1.3, use insertAtBoundary
insertBefore(Node, Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Inserts the node newChild before the existing child node refChild.
insertBefore(Node, Node) - Method in interface org.w3c.dom.Node
Inserts the node newChild before the existing child node refChild.
insertBeforeEnd(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string at the end of the element.
insertBeforeStart(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string before the start of the given element.
insertBreakAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place a line/paragraph break into the document.
insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font.LineBreakMeasurer
Updates this LineBreakMeasurer after a single character is inserted into the text, and sets the current position to the beginning of the paragraph.
insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font.TextMeasurer
Updates the TextMeasurer after a single character has been inserted into the paragraph currently represented by this TextMeasurer.
insertComponent(Component) - Method in class javax.swing.JTextPane
Inserts a component into the document as a replacement for the currently selected content.
insertContentAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place content into the associated document.
insertData(int, String) - Method in interface org.w3c.dom.CharacterData
Insert a string at the specified 16-bit unit offset.
insertElementAt(E, int) - Method in class java.util.Vector
Inserts the specified object as a component in this vector at the specified index.
insertElementAt(Object, int) - Method in class javax.swing.DefaultComboBoxModel
insertElementAt(E, int) - Method in class javax.swing.DefaultListModel
Inserts the specified element as a component in this list at the specified index.
insertElementAt(Object, int) - Method in interface javax.swing.MutableComboBoxModel
Adds an item at a specific index.
insertEntries(int, int, int) - Method in class javax.swing.SizeSequence
Adds a contiguous group of entries to this SizeSequence.
insertHTML(HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit
Inserts HTML into an existing document.
insertHTML(JEditorPane, HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
A cover for HTMLEditorKit.insertHTML.
insertIcon(Icon) - Method in class javax.swing.JTextPane
Inserts an icon into the document as a replacement for the currently selected content.
insertIndexForLayer(int, int) - Method in class javax.swing.JLayeredPane
Primitive method that determines the proper location to insert a new child based on layer and position requests.
insertIndexInterval(int, int, boolean) - Method in class javax.swing.DefaultListSelectionModel
Insert length indices beginning before/after index.
insertIndexInterval(int, int, boolean) - Method in interface javax.swing.ListSelectionModel
Insert length indices beginning before/after index.
insertItemAt(Object, int) - Method in class javax.swing.JComboBox
Inserts an item into the item list at a given index.
insertNodeInto(MutableTreeNode, MutableTreeNode, int) - Method in class javax.swing.tree.DefaultTreeModel
Invoked this to insert newChild at location index in parents children.
insertParameterTypes(int, Class<?>...) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
insertParameterTypes(int, List<Class<?>>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
insertProviderAt(Provider, int) - Static method in class java.security.Security
Adds a new provider, at a specified position.
insertRow() - Method in interface java.sql.ResultSet
Inserts the contents of the insert row into this ResultSet object and into the database.
insertRow(int, Vector) - Method in class javax.swing.table.DefaultTableModel
Inserts a row at row in the model.
insertRow(int, Object[]) - Method in class javax.swing.table.DefaultTableModel
Inserts a row at row in the model.
insertsAreDetected(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether or not a visible row insert can be detected by calling the method ResultSet.rowInserted.
insertSeparator(int) - Method in class java.awt.Menu
Inserts a separator at the specified position.
insertSeparator(int) - Method in class javax.swing.JMenu
Inserts a separator at the specified position.
insertString(int, String) - Method in interface javax.swing.text.AbstractDocument.Content
Inserts a string of characters into the sequence.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Inserts some content into the document.
insertString(int, String, AttributeSet) - Method in interface javax.swing.text.Document
Inserts a string of content.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter.FilterBypass
Inserts the specified text, bypassing the DocumentFilter.
insertString(DocumentFilter.FilterBypass, int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter
Invoked prior to insertion of text into the specified Document.
insertString(int, String) - Method in class javax.swing.text.GapContent
Inserts a string into the content.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.PlainDocument
Inserts some content into the document.
insertString(int, String) - Method in class javax.swing.text.StringContent
Inserts a string into the content.
insertTab(String, Icon, Component, String, int) - Method in class javax.swing.JTabbedPane
Inserts a new tab for the given component, at the given index, represented by the given title and/or icon, either of which may be null.
insertTabAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place a tab character into the document.
insertText(String, int) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by insert(String, int).
insertTextAtIndex(int, String) - Method in interface javax.accessibility.AccessibleEditableText
Inserts the specified string at the given index/
insertTextAtIndex(int, String) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Inserts the specified string at the given index/
insertTextAtIndex(int, String) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Inserts the specified string at the given index
insertUpdate(DocumentEvent) - Method in interface javax.swing.event.DocumentListener
Gives notification that there was an insert into the document.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Updates document structure as a result of text insertion.
insertUpdate(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Inserts an update into the document.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FieldView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text.FlowView.FlowStrategy
Gives notification that something was inserted into the document in a location that the given flow view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FlowView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.GlyphView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.html.HTMLDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.InlineView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles document insert (fire appropriate property change event which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.PlainDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.ZoneView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insetCache - Variable in class javax.swing.plaf.basic.BasicSliderUI
insets() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getInsets().
insets - Variable in class java.awt.GridBagConstraints
This field specifies the external padding of the component, the minimum amount of space between the component and the edges of its display area.
Insets - Class in java.awt
An Insets object is a representation of the borders of a container.
Insets(int, int, int, int) - Constructor for class java.awt.Insets
Creates and initializes a new Insets object with the specified top, left, bottom, and right insets.
InsetsUIResource - Class in javax.swing.plaf
InsetsUIResource(int, int, int, int) - Constructor for class javax.swing.plaf.InsetsUIResource
inside(int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
inside(int, int) - Method in class java.awt.Polygon
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
inside(int, int) - Method in class java.awt.Rectangle
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
insideBorder - Variable in class javax.swing.border.CompoundBorder
install(JFormattedTextField) - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Installs the AbstractFormatter onto a particular JFormattedTextField.
install(JTextComponent) - Method in interface javax.swing.text.Caret
Called when the UI is being installed into the interface of a JTextComponent.
install(JTextComponent) - Method in class javax.swing.text.DefaultCaret
Called when the UI is being installed into the interface of a JTextComponent.
install(JFormattedTextField) - Method in class javax.swing.text.DefaultFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JTextComponent) - Method in class javax.swing.text.DefaultHighlighter
Called when the UI is being installed into the interface of a JTextComponent.
install(JEditorPane) - Method in class javax.swing.text.EditorKit
Called when the kit is being installed into the a JEditorPane.
install(JTextComponent) - Method in interface javax.swing.text.Highlighter
Called when the UI is being installed into the interface of a JTextComponent.
install(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit
Called when the kit is being installed into the a JEditorPane.
install(JFormattedTextField) - Method in class javax.swing.text.InternationalFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JFormattedTextField) - Method in class javax.swing.text.MaskFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JEditorPane) - Method in class javax.swing.text.StyledEditorKit
Called when the kit is being installed into a JEditorPane.
installAncestorListener() - Method in class javax.swing.JComboBox
installBorder(JComponent, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's border property with a value from the defaults.
installChooserPanel(JColorChooser) - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Invoked when the panel is added to the chooser.
installColors(JComponent, String, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's foreground and background color properties with values from the defaults.
installColorsAndFont(JComponent, String, String, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's foreground, background and font properties with values from the defaults.
installComboBoxListeners() - Method in class javax.swing.plaf.basic.BasicComboPopup
This method adds the necessary listeners to the JComboBox.
installComboBoxModelListeners(ComboBoxModel) - Method in class javax.swing.plaf.basic.BasicComboPopup
Installs the listeners on the combo box model.
installComponents() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates and initializes the components which make up the aggregate combo box.
installComponents() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installComponents(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installComponents() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installComponents(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installComponents(JMenuItem) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installComponents() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installComponents(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installComponents() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installComponents() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Creates and installs any required subcomponents for the JTabbedPane.
installComponents() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installComponents() - Method in class javax.swing.plaf.basic.BasicTreeUI
Intalls the subcomponents of the tree, which is the renderer pane.
installComponents() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installComponents(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installComponents() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installComponents() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installComponents() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Installs the default colors, default font, default renderer, and default editor into the JComboBox.
installDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installDefaults(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installDefaults(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicListUI
Initializes list properties such as font, foreground, and background, and adds the CellRendererPane.
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installDefaults(JPanel) - Method in class javax.swing.plaf.basic.BasicPanelUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Installs the necessary properties on the JPasswordField.
installDefaults() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI
installDefaults(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installDefaults(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installDefaults(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Initialize the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
installDefaults() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the UI defaults.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Initializes JTableHeader properties such as font, foreground, and background.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTableUI
Initialize JTable properties, e.g.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTextAreaUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTextUI
Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
installDefaults(JSeparator) - Method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTreeUI
installDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalCheckBoxUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalRadioButtonUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.metal.MetalSeparatorUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
installDefaults(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle
installDefaults(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
installDefaults(JLabel) - Method in class javax.swing.plaf.synth.SynthLabelUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthListUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installDefaults(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
installDefaults(JRootPane) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
installDefaults(JScrollPane) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Installs default setting.
installDefaults(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Initializes the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
installDefaults() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Installs the UI defaults.
installDefaults(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle
Installs the necessary state from this Style on the JComponent from context.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTableUI
Initializes JTable properties, such as font, foreground, and background.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTextAreaUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTextFieldUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTreeUI
installDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Installs defaults for a viewport.
installDesktopManager() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installDesktopManager() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
installedProviders() - Static method in class java.nio.file.spi.FileSystemProvider
Returns a list of the installed file system providers.
installIcons(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installKeyboardActions(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonListener
Register default key actions: pressing space to "click" a button and registring the keyboard mnemonic (if any).
installKeyboardActions(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Adds keyboard actions to the JComboBox.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboPopup
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installKeyboardActions(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicListUI
Registers the keyboard bindings on the JList that the BasicListUI is associated with.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installKeyboardActions(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installKeyboardActions(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installKeyboardActions(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the keyboard Actions onto the JSpinner.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the keyboard actions for the UI.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Register all keyboard actions on the JTableHeader.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableUI
Register all keyboard actions on the JTable.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTextUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTreeUI
installKeyboardActions() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installKeyboardActions() - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI
installListeners(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installListeners() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installListeners() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates and installs listeners for the combo box and its model.
installListeners() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installListeners() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
installListeners(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installListeners(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installListeners() - Method in class javax.swing.plaf.basic.BasicListUI
Creates and installs the listeners for the JList, its model, and its selectionModel.
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuUI
installListeners() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installListeners() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installListeners(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installListeners(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installListeners(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installListeners() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.
installListeners() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the event listeners for the UI.
installListeners() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Attaches listeners to the JTableHeader.
installListeners() - Method in class javax.swing.plaf.basic.BasicTableUI
Attaches listeners to the JTable.
installListeners() - Method in class javax.swing.plaf.basic.BasicTextUI
Installs listeners for the UI.
installListeners() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installListeners(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installListeners() - Method in class javax.swing.plaf.basic.BasicTreeUI
installListeners() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installListeners(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installListeners() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installListeners() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
installListeners() - Method in class javax.swing.plaf.metal.MetalToolBarUI
installListeners(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
installListeners() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
installListeners() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
installListeners() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installListeners() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
installListeners() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
installListeners() - Method in class javax.swing.plaf.synth.SynthListUI
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuUI
installListeners() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installListeners(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
Installs listeners into the panel.
installListeners() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
installListeners() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
installListeners() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
installListeners(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Installs listeners.
installListeners(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
installListeners() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
installListeners() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Installs the event listeners for the UI.
installListeners() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
installListeners() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
installListeners() - Method in class javax.swing.plaf.synth.SynthTableUI
Attaches listeners to the JTable.
installListeners() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
installListeners() - Method in class javax.swing.plaf.synth.SynthTreeUI
installListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Installs listeners into the viewport.
installListListeners() - Method in class javax.swing.plaf.basic.BasicComboPopup
Adds the listeners to the list control.
installLookAndFeel(UIManager.LookAndFeelInfo) - Static method in class javax.swing.UIManager
Adds the specified look and feel to the set of available look and feels.
installLookAndFeel(String, String) - Static method in class javax.swing.UIManager
Adds the specified look and feel to the set of available look and feels.
installMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installNextButtonListeners(Component) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the necessary listeners on the next button, c, to update the JSpinner in response to a user gesture.
installNonRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs non-rollover borders on all the child components of the JComponent.
installNormalBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs normal borders on all the child components of the JComponent.
installPreviewPanel() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installPreviousButtonListeners(Component) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the necessary listeners on the previous button, c, to update the JSpinner in response to a user gesture.
installProperty(JComponent, String, Object) - Static method in class javax.swing.LookAndFeel
Convenience method for installing a property with the specified name and value on a component if that property has not already been set by the developer.
installRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs rollover borders on all the child components of the JComponent.
installStrings(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installStrings(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installTitlePane() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI
Initializes this.list by calling installDefaults(), installListeners(), and installKeyboardActions() in order.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Installs the receiver as the L&F for the passed in JOptionPane.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPanelUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Calls installDefaults, installListeners, and then adds the components returned by createNextButton, createPreviousButton, and createEditor.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the UI.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTextPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
installUI(JComponent) - Method in class javax.swing.plaf.ComponentUI
Configures the specified component appropriately for the look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.LayerUI
Configures the JLayer this LayerUI is set to.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalMenuBarUI
Configures the specified component appropriate for the metal look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalRootPaneUI
Invokes supers implementation of installUI to install the necessary state onto the passed in JRootPane to render the metal look and feel implementation of RootPaneUI.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalSliderUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolBarUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalTreeUI
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthTextPaneUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
InstanceAlreadyExistsException - Exception in javax.management
The MBean is already registered in the repository.
InstanceAlreadyExistsException() - Constructor for exception javax.management.InstanceAlreadyExistsException
Default constructor.
InstanceAlreadyExistsException(String) - Constructor for exception javax.management.InstanceAlreadyExistsException
Constructor that allows a specific error message to be specified.
instanceFollowRedirects - Variable in class java.net.HttpURLConnection
If true, the protocol will automatically follow redirects.
InstanceNotFoundException - Exception in javax.management
The specified MBean does not exist in the repository.
InstanceNotFoundException() - Constructor for exception javax.management.InstanceNotFoundException
Default constructor.
InstanceNotFoundException(String) - Constructor for exception javax.management.InstanceNotFoundException
Constructor that allows a specific error message to be specified.
instantiate(ClassLoader, String) - Static method in class java.beans.Beans
Instantiate a JavaBean.
instantiate(ClassLoader, String, BeanContext) - Static method in class java.beans.Beans
Instantiate a JavaBean.
instantiate(ClassLoader, String, BeanContext, AppletInitializer) - Static method in class java.beans.Beans
Instantiate a bean.
instantiate(Object, Encoder) - Method in class java.beans.DefaultPersistenceDelegate
This default implementation of the instantiate method returns an expression containing the predefined method name "new" which denotes a call to a constructor with the arguments as specified in the DefaultPersistenceDelegate's constructor.
instantiate(Object, Encoder) - Method in class java.beans.PersistenceDelegate
Returns an expression whose value is oldInstance.
instantiate(String) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository.
instantiate(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates an object using the class Loader specified by its ObjectName.
instantiate(String, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository.
instantiate(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object.
instantiateChild(String) - Method in interface java.beans.beancontext.BeanContext
Instantiate the javaBean named as a child of this BeanContext.
instantiateChild(String) - Method in class java.beans.beancontext.BeanContextSupport
The instantiateChild method is a convenience hook in BeanContext to simplify the task of instantiating a Bean, nested, into a BeanContext.
InstantiationError - Error in java.lang
Thrown when an application tries to use the Java new construct to instantiate an abstract class or an interface.
InstantiationError() - Constructor for error java.lang.InstantiationError
Constructs an InstantiationError with no detail message.
InstantiationError(String) - Constructor for error java.lang.InstantiationError
Constructs an InstantiationError with the specified detail message.
InstantiationException - Exception in java.lang
Thrown when an application tries to create an instance of a class using the newInstance method in class 类, but the specified class object cannot be instantiated.
InstantiationException() - Constructor for exception java.lang.InstantiationException
Constructs an InstantiationException with no detail message.
InstantiationException(String) - Constructor for exception java.lang.InstantiationException
Constructs an InstantiationException with the specified detail message.
Instrument - Class in javax.sound.midi
An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect.
Instrument(Soundbank, Patch, String, Class<?>) - Constructor for class javax.sound.midi.Instrument
Constructs a new MIDI instrument from the specified Patch.
Instrumentation - Interface in java.lang.instrument
This class provides services needed to instrument Java programming language code.
InsufficientResourcesException - Exception in javax.naming
This exception is thrown when resources are not available to complete the requested operation.
InsufficientResourcesException(String) - Constructor for exception javax.naming.InsufficientResourcesException
Constructs a new instance of InsufficientResourcesException using an explanation.
InsufficientResourcesException() - Constructor for exception javax.naming.InsufficientResourcesException
Constructs a new instance of InsufficientResourcesException with all name resolution fields and explanation initialized to null.
insureRowContinuity() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Makes sure the currently selected TreePaths are valid for the current selection mode.
insureUniqueness() - Method in class javax.swing.tree.DefaultTreeSelectionModel
This method is obsolete and its implementation is now a noop.
intBitsToFloat(int) - Static method in class java.lang.Float
Returns the float value corresponding to a given bit representation.
IntBuffer - Class in java.nio
An int buffer.
Integer - Class in java.lang
The Integer class wraps a value of the primitive type int in an object.
Integer(int) - Constructor for class java.lang.Integer
Constructs a newly allocated Integer object that represents the specified int value.
Integer(String) - Constructor for class java.lang.Integer
Constructs a newly allocated Integer object that represents the int value indicated by the String parameter.
INTEGER - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type INTEGER.
INTEGER - Static variable in class java.text.NumberFormat.Field
Constant identifying the integer field.
INTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Integer.
INTEGER_FIELD - Static variable in class java.text.NumberFormat
Field constant used to construct a FieldPosition object.
IntegerSyntax - Class in javax.print.attribute
Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.
IntegerSyntax(int) - Constructor for class javax.print.attribute.IntegerSyntax
Construct a new integer attribute with the given integer value.
IntegerSyntax(int, int, int) - Constructor for class javax.print.attribute.IntegerSyntax
Construct a new integer attribute with the given integer value, which must lie within the given range.
Interceptor - Interface in org.omg.PortableInterceptor
All Portable Interceptors implement Interceptor.
InterceptorOperations - Interface in org.omg.PortableInterceptor
All Portable Interceptors implement Interceptor.
interestOps() - Method in class java.nio.channels.SelectionKey
Retrieves this key's interest set.
interestOps(int) - Method in class java.nio.channels.SelectionKey
Sets this key's interest set to the given value.
接口 - Static variable in class java.lang.reflect.修饰符
The int value representing the 接口 modifier.
INTERFACE_CLASS_NAME_FIELD - Static variable in class javax.management.JMX
The name of the interfaceClassName field.
InterfaceAddress - Class in java.net
This class represents a Network Interface address.
interfaceModifiers() - Static method in class java.lang.reflect.修饰符
Return an int value OR-ing together the source language modifiers that can be applied to an interface.
interfaceName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
INTERLOCK_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more interlock devices on the printer are unlocked.
intern() - Method in class java.lang.String
Returns a canonical representation for the string object.
INTERNAL - Exception in org.omg.CORBA
This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
INTERNAL() - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INTERNAL(String) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INTERNAL(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified minor code and completion status.
INTERNAL(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.
INTERNAL_CLOCK - Static variable in class javax.sound.midi.Sequencer.SyncMode
A master synchronization mode that makes the sequencer get its timing information from its internal clock.
INTERNAL_FRAME - Static variable in class javax.accessibility.AccessibleRole
A frame-like object that is clipped by a desktop pane.
INTERNAL_FRAME - Static variable in class javax.swing.plaf.synth.Region
InternalFrame region.
INTERNAL_FRAME_ACTIVATED - Static variable in class javax.swing.event.InternalFrameEvent
The "window activated" event type.
INTERNAL_FRAME_CLOSED - Static variable in class javax.swing.event.InternalFrameEvent
The "window closed" event.
INTERNAL_FRAME_CLOSING - Static variable in class javax.swing.event.InternalFrameEvent
The "window is closing" event.
INTERNAL_FRAME_DEACTIVATED - Static variable in class javax.swing.event.InternalFrameEvent
The "window deactivated" event type.
INTERNAL_FRAME_DEICONIFIED - Static variable in class javax.swing.event.InternalFrameEvent
The "window deiconified" event type.
INTERNAL_FRAME_FIRST - Static variable in class javax.swing.event.InternalFrameEvent
The first number in the range of IDs used for internal frame events.
INTERNAL_FRAME_ICONIFIED - Static variable in class javax.swing.event.InternalFrameEvent
The "window iconified" event.
INTERNAL_FRAME_LAST - Static variable in class javax.swing.event.InternalFrameEvent
The last number in the range of IDs used for internal frame events.
INTERNAL_FRAME_OPENED - Static variable in class javax.swing.event.InternalFrameEvent
The "window opened" event.
INTERNAL_FRAME_TITLE_PANE - Static variable in class javax.swing.plaf.synth.Region
TitlePane of an InternalFrame.
internalEntityDecl(String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an internal entity declaration.
internalEntityDecl(String, String) - Method in class org.xml.sax.ext.DefaultHandler2
InternalError - Error in java.lang
Thrown to indicate some unexpected internal error has occurred in the Java Virtual Machine.
InternalError() - Constructor for error java.lang.InternalError
Constructs an InternalError with no detail message.
InternalError(String) - Constructor for error java.lang.InternalError
Constructs an InternalError with the specified detail message.
internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is activated.
internalFrameActivated(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is activated.
internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFrameAdapter - Class in javax.swing.event
An abstract adapter class for receiving internal frame events.
InternalFrameAdapter() - Constructor for class javax.swing.event.InternalFrameAdapter
internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame has been closed.
internalFrameClosed(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame has been closed.
internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is in the process of being closed.
internalFrameClosing(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is in the process of being closed.
internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is de-activated.
internalFrameDeactivated(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is de-activated.
internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is de-iconified.
internalFrameDeiconified(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is de-iconified.
internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFrameEvent - Class in javax.swing.event
An AWTEvent that adds support for JInternalFrame objects as the event source.
InternalFrameEvent(JInternalFrame, int) - Constructor for class javax.swing.event.InternalFrameEvent
Constructs an InternalFrameEvent object.
InternalFrameFocusTraversalPolicy - Class in javax.swing
A FocusTraversalPolicy which can optionally provide an algorithm for determining a JInternalFrame's initial Component.
InternalFrameFocusTraversalPolicy() - Constructor for class javax.swing.InternalFrameFocusTraversalPolicy
internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is iconified.
internalFrameIconified(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is iconified.
internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameLayout - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
InternalFrameListener - Interface in javax.swing.event
The listener interface for receiving internal frame events.
internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame has been opened.
internalFrameOpened(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when a internal frame has been opened.
internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFrameUI - Class in javax.swing.plaf
Pluggable look and feel interface for JInternalFrame.
InternalFrameUI() - Constructor for class javax.swing.plaf.InternalFrameUI
internalGet(int) - Method in class java.util.Calendar
Returns the value of the given calendar field.
InternationalFormatter - Class in javax.swing.text
InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
InternationalFormatter() - Constructor for class javax.swing.text.InternationalFormatter
Creates an InternationalFormatter with no Format specified.
InternationalFormatter(Format) - Constructor for class javax.swing.text.InternationalFormatter
Creates an InternationalFormatter with the specified Format instance.
INTERPRETER_RESOURCE_UNAVAILABLE - Static variable in class javax.print.attribute.standard.PrinterStateReason
An interpreter resource is unavailable (e.g., font, form).
interrupt() - Method in class java.lang.Thread
Interrupts this thread.
interrupt() - Method in class java.lang.ThreadGroup
Interrupts all threads in this thread group.
interrupted() - Static method in class java.lang.Thread
Tests whether the current thread has been interrupted.
InterruptedByTimeoutException - Exception in java.nio.channels
Checked exception received by a thread when a timeout elapses before an asynchronous operation completes.
InterruptedByTimeoutException() - Constructor for exception java.nio.channels.InterruptedByTimeoutException
Constructs an instance of this class.
InterruptedException - Exception in java.lang
Thrown when a thread is waiting, sleeping, or otherwise occupied, and the thread is interrupted, either before or during the activity.
InterruptedException() - Constructor for exception java.lang.InterruptedException
Constructs an InterruptedException with no detail message.
InterruptedException(String) - Constructor for exception java.lang.InterruptedException
Constructs an InterruptedException with the specified detail message.
InterruptedIOException - Exception in java.io
Signals that an I/O operation has been interrupted.
InterruptedIOException() - Constructor for exception java.io.InterruptedIOException
Constructs an InterruptedIOException with null as its error detail message.
InterruptedIOException(String) - Constructor for exception java.io.InterruptedIOException
Constructs an InterruptedIOException with the specified detail message.
InterruptedNamingException - Exception in javax.naming
This exception is thrown when the naming operation being invoked has been interrupted.
InterruptedNamingException(String) - Constructor for exception javax.naming.InterruptedNamingException
Constructs an instance of InterruptedNamingException using an explanation of the problem.
InterruptedNamingException() - Constructor for exception javax.naming.InterruptedNamingException
Constructs an instance of InterruptedNamingException with all name resolution fields and explanation initialized to null.
InterruptibleChannel - Interface in java.nio.channels
A channel that can be asynchronously closed and interrupted.
intersect(Area) - Method in class java.awt.geom.Area
Sets the shape of this Area to the intersection of its current shape and the shape of the specified Area.
intersect(Rectangle2D, Rectangle2D, Rectangle2D) - Static method in class java.awt.geom.Rectangle2D
Intersects the pair of specified source Rectangle2D objects and puts the result into the specified destination Rectangle2D object.
INTERSECT - Static variable in class javax.xml.crypto.dsig.spec.XPathType.Filter
The intersect filter operation.
intersection(Rectangle) - Method in class java.awt.Rectangle
Computes the intersection of this Rectangle with the specified Rectangle.
intersects(double, double, double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc intersects the interior of the specified rectangle.
intersects(double, double, double, double) - Method in class java.awt.geom.Area
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Area
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Line2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(PathIterator, double, double, double, double) - Static method in class java.awt.geom.Path2D
Tests if the interior of the specified PathIterator intersects the interior of a specified set of rectangular coordinates.
intersects(PathIterator, Rectangle2D) - Static method in class java.awt.geom.Path2D
Tests if the interior of the specified PathIterator intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.RectangularShape
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(double, double, double, double) - Method in class java.awt.Polygon
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.Polygon
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(Rectangle) - Method in class java.awt.Rectangle
Determines whether or not this Rectangle and the specified Rectangle intersect.
intersects(double, double, double, double) - Method in interface java.awt.Shape
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in interface java.awt.Shape
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(BitSet) - Method in class java.util.BitSet
Returns true if the specified BitSet has any bits set to true that are also set to true in this BitSet.
intersectsLine(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the line segment from (x1,y1) to (x2,y2) intersects this line segment.
intersectsLine(Line2D) - Method in class java.awt.geom.Line2D
Tests if the specified line segment intersects this line segment.
intersectsLine(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the specified line segment intersects the interior of this Rectangle2D.
intersectsLine(Line2D) - Method in class java.awt.geom.Rectangle2D
Tests if the specified line segment intersects the interior of this Rectangle2D.
INTERVAL_ADDED - Static variable in class javax.swing.event.ListDataEvent
Identifies the addition of one or more contiguous items to the list
INTERVAL_REMOVED - Static variable in class javax.swing.event.ListDataEvent
Identifies the removal of one or more contiguous items from the list
intervalAdded(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent after the indices in the index0,index1 interval have been inserted in the data model.
intervalAdded(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
intervalAdded(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener interval added method.
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Obsolete - not used.
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
intervalRemoved(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent after the indices in the index0,index1 interval have been removed from the data model.
intervalRemoved(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
intervalRemoved(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener interval removed method.
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Obsolete - not used.
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
INTF_REPOS - Exception in org.omg.CORBA
Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
INTF_REPOS() - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INTF_REPOS(String) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified detail.
INTF_REPOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified minor code and completion status.
INTF_REPOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.
IntHolder - Class in org.omg.CORBA
The Holder for Int.
IntHolder() - Constructor for class org.omg.CORBA.IntHolder
Constructs a new IntHolder object with its value field initialized to 0.
IntHolder(int) - Constructor for class org.omg.CORBA.IntHolder
Constructs a new IntHolder object with its value field initialized to the given int.
intKey() - Method in class java.awt.RenderingHints.Key
Returns the private integer key that the subclass instantiated this Key with.
IntrospectionException - Exception in java.beans
Thrown when an exception happens during Introspection.
IntrospectionException(String) - Constructor for exception java.beans.IntrospectionException
Constructs an IntrospectionException with a detailed message.
IntrospectionException - Exception in javax.management
An exception occurred during the introspection of an MBean.
IntrospectionException() - Constructor for exception javax.management.IntrospectionException
Default constructor.
IntrospectionException(String) - Constructor for exception javax.management.IntrospectionException
Constructor that allows a specific error message to be specified.
Introspector - Class in java.beans
The Introspector class provides a standard way for tools to learn about the properties, events, and methods supported by a target Java Bean.
intValue() - Method in class java.lang.Byte
Returns the value of this Byte as an int.
intValue() - Method in class java.lang.Double
Returns the value of this Double as an int (by casting to type int).
intValue() - Method in class java.lang.Float
Returns the value of this Float as an int (by casting to type int).
intValue() - Method in class java.lang.Integer
Returns the value of this Integer as an int.
intValue() - Method in class java.lang.Long
Returns the value of this Long as an int.
intValue() - Method in class java.lang.Number
Returns the value of the specified number as an int.
intValue() - Method in class java.lang.Short
Returns the value of this Short as an int.
intValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to an int.
intValue() - Method in class java.math.BigInteger
Converts this BigInteger to an int.
intValue() - Method in class java.util.concurrent.atomic.AtomicInteger
intValue() - Method in class java.util.concurrent.atomic.AtomicLong
intValue() - Method in class java.util.logging.Level
Get the integer value for this level.
intValueExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to an int, checking for lost information.
INUSE_ATTRIBUTE_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to add an attribute that is already in use elsewhere.
INV_FLAG - Exception in org.omg.CORBA
Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
INV_FLAG() - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_FLAG(String) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_FLAG(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified minor code and completion status.
INV_FLAG(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.
INV_IDENT - Exception in org.omg.CORBA
This exception indicates that an IDL identifier is syntactically invalid.
INV_IDENT() - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_IDENT(String) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_IDENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified minor code and completion status.
INV_IDENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.
INV_OBJREF - Exception in org.omg.CORBA
This exception indicates that an object reference is internally malformed.
INV_OBJREF() - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_OBJREF(String) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_OBJREF(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified minor code and completion status.
INV_OBJREF(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.
INV_POLICY - Exception in org.omg.CORBA
Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
INV_POLICY() - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
INV_POLICY(String) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_POLICY(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified minor code and completion status.
INV_POLICY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
Invalid - Exception in org.omg.CORBA.DynAnyPackage
Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
Invalid() - Constructor for exception org.omg.CORBA.DynAnyPackage.Invalid
Constructs an Invalid object.
Invalid(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.Invalid
Constructs an Invalid object.
INVALID_ACCESS_ERR - Static variable in exception org.w3c.dom.DOMException
If a parameter or an operation is not supported by the underlying object.
INVALID_ACTIVITY - Exception in org.omg.CORBA
The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
INVALID_ACTIVITY() - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
INVALID_ACTIVITY(String) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified message.
INVALID_ACTIVITY(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
INVALID_ACTIVITY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
INVALID_CHARACTER_ERR - Static variable in exception org.w3c.dom.DOMException
If an invalid or illegal character is specified, such as in an XML name.
INVALID_MODIFICATION_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to modify the type of the underlying object.
INVALID_STATE_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to use an object that is not, or is no longer, usable.
INVALID_TRANSACTION - Exception in org.omg.CORBA
Exception thrown when the request carried an invalid transaction context.
INVALID_TRANSACTION() - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INVALID_TRANSACTION(String) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified detail message.
INVALID_TRANSACTION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
INVALID_TRANSACTION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.
InvalidActivityException - Exception in javax.activity
This exception may be thrown on any method for which Activity context is accessed and indicates that the attempted invocation or the Activity context associated with the attempted invocation is incompatible with the Activity's current state.
InvalidActivityException() - Constructor for exception javax.activity.InvalidActivityException
Constructs a new instance with null as its detail message.
InvalidActivityException(String) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new instance with the specified detail message.
InvalidActivityException(Throwable) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new throwable with the specified cause.
InvalidActivityException(String, Throwable) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new throwable with the specified detail message and cause.
InvalidAddress - Exception in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
InvalidAddress() - Constructor for exception org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
InvalidAddress(String) - Constructor for exception org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
InvalidAddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java .
InvalidAddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
InvalidAddressHolder - Class in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .
InvalidAddressHolder() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
InvalidAddressHolder(InvalidAddress) - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
InvalidAlgorithmParameterException - Exception in java.security
This is the exception for invalid or inappropriate algorithm parameters.
InvalidAlgorithmParameterException() - Constructor for exception java.security.InvalidAlgorithmParameterException
Constructs an InvalidAlgorithmParameterException with no detail message.
InvalidAlgorithmParameterException(String) - Constructor for exception java.security.InvalidAlgorithmParameterException
Constructs an InvalidAlgorithmParameterException with the specified detail message.
InvalidAlgorithmParameterException(String, Throwable) - Constructor for exception java.security.InvalidAlgorithmParameterException
Creates a InvalidAlgorithmParameterException with the specified detail message and cause.
InvalidAlgorithmParameterException(Throwable) - Constructor for exception java.security.InvalidAlgorithmParameterException
Creates a InvalidAlgorithmParameterException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidApplicationException - Exception in javax.management
Thrown when an attempt is made to apply either of the following: A subquery expression to an MBean or a qualified attribute expression to an MBean of the wrong class.
InvalidApplicationException(Object) - Constructor for exception javax.management.InvalidApplicationException
Constructs an InvalidApplicationException with the specified Object.
invalidate() - Method in class java.awt.Component
Invalidates this component and its ancestors.
invalidate() - Method in class java.awt.Container
Invalidates the container.
invalidate() - Method in class java.awt.Polygon
Invalidates or flushes any internally-cached data that depends on the vertex coordinates of this Polygon.
invalidate() - Method in interface javax.net.ssl.SSLSession
Invalidates the session.
invalidate() - Method in class javax.swing.CellRendererPane
Overridden to avoid propagating a invalidate up the tree when the cell renderer child is configured.
invalidate() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
invalidate() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
invalidate() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
invalidateAll(SwitchPoint[]) - Static method in class java.lang.invoke.SwitchPoint
Sets all of the given switch points into the invalid state.
invalidateFileCache() - Method in class javax.swing.plaf.basic.BasicDirectoryModel
This method is used to interrupt file loading thread.
invalidateLayout(Container) - Method in class java.awt.BorderLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class java.awt.CardLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class java.awt.GridBagLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in interface java.awt.LayoutManager2
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class javax.swing.BoxLayout
Indicates that a child has changed its layout related information, and thus any cached calculations should be flushed.
invalidateLayout(Container) - Method in class javax.swing.GroupLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class javax.swing.JRootPane.RootLayout
invalidateLayout(Container) - Method in class javax.swing.OverlayLayout
Indicates a child has changed its layout related information, which causes any cached calculations to be flushed.
invalidateLayout(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Does nothing.
invalidateLayout(Container) - Method in class javax.swing.SpringLayout
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache
Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache
Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache
Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
invalidateSizes() - Method in class javax.swing.tree.AbstractLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
invalidateSizes() - Method in class javax.swing.tree.FixedHeightLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
invalidateSizes() - Method in class javax.swing.tree.VariableHeightLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
InvalidAttributeIdentifierException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add to create an attribute with an invalid attribute identifier.
InvalidAttributeIdentifierException(String) - Constructor for exception javax.naming.directory.InvalidAttributeIdentifierException
Constructs a new instance of InvalidAttributeIdentifierException using the explanation supplied.
InvalidAttributeIdentifierException() - Constructor for exception javax.naming.directory.InvalidAttributeIdentifierException
Constructs a new instance of InvalidAttributeIdentifierException.
InvalidAttributesException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add or modify an attribute set that has been specified incompletely or incorrectly.
InvalidAttributesException(String) - Constructor for exception javax.naming.directory.InvalidAttributesException
Constructs a new instance of InvalidAttributesException using an explanation.
InvalidAttributesException() - Constructor for exception javax.naming.directory.InvalidAttributesException
Constructs a new instance of InvalidAttributesException.
InvalidAttributeValueException - Exception in javax.management
The value specified is not valid for the attribute.
InvalidAttributeValueException() - Constructor for exception javax.management.InvalidAttributeValueException
Default constructor.
InvalidAttributeValueException(String) - Constructor for exception javax.management.InvalidAttributeValueException
Constructor that allows a specific error message to be specified.
InvalidAttributeValueException - Exception in javax.naming.directory
This class is thrown when an attempt is made to add to an attribute a value that conflicts with the attribute's schema definition.
InvalidAttributeValueException(String) - Constructor for exception javax.naming.directory.InvalidAttributeValueException
Constructs a new instance of InvalidAttributeValueException using an explanation.
InvalidAttributeValueException() - Constructor for exception javax.naming.directory.InvalidAttributeValueException
Constructs a new instance of InvalidAttributeValueException.
InvalidClassException - Exception in java.io
Thrown when the Serialization runtime detects one of the following problems with a Class.
InvalidClassException(String) - Constructor for exception java.io.InvalidClassException
Report an InvalidClassException for the reason specified.
InvalidClassException(String, String) - Constructor for exception java.io.InvalidClassException
Constructs an InvalidClassException object.
InvalidDnDOperationException - Exception in java.awt.dnd
This exception is thrown by various methods in the java.awt.dnd package.
InvalidDnDOperationException() - Constructor for exception java.awt.dnd.InvalidDnDOperationException
Create a default Exception
InvalidDnDOperationException(String) - Constructor for exception java.awt.dnd.InvalidDnDOperationException
Create an Exception with its own descriptive message
invalidEdit() - Method in class javax.swing.JFormattedTextField.AbstractFormatter
This should be invoked when the user types an invalid character.
invalidEdit() - Method in class javax.swing.JFormattedTextField
Invoked when the user inputs an invalid value.
InvalidKeyException - Exception in java.security
This is the exception for invalid Keys (invalid encoding, wrong length, uninitialized, etc).
InvalidKeyException() - Constructor for exception java.security.InvalidKeyException
Constructs an InvalidKeyException with no detail message.
InvalidKeyException(String) - Constructor for exception java.security.InvalidKeyException
Constructs an InvalidKeyException with the specified detail message.
InvalidKeyException(String, Throwable) - Constructor for exception java.security.InvalidKeyException
Creates a InvalidKeyException with the specified detail message and cause.
InvalidKeyException(Throwable) - Constructor for exception java.security.InvalidKeyException
Creates a InvalidKeyException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidKeyException - Exception in javax.management.openmbean
This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
InvalidKeyException() - Constructor for exception javax.management.openmbean.InvalidKeyException
An InvalidKeyException with no detail message.
InvalidKeyException(String) - Constructor for exception javax.management.openmbean.InvalidKeyException
An InvalidKeyException with a detail message.
InvalidKeySpecException - Exception in java.security.spec
This is the exception for invalid key specifications.
InvalidKeySpecException() - Constructor for exception java.security.spec.InvalidKeySpecException
Constructs an InvalidKeySpecException with no detail message.
InvalidKeySpecException(String) - Constructor for exception java.security.spec.InvalidKeySpecException
Constructs an InvalidKeySpecException with the specified detail message.
InvalidKeySpecException(String, Throwable) - Constructor for exception java.security.spec.InvalidKeySpecException
Creates a InvalidKeySpecException with the specified detail message and cause.
InvalidKeySpecException(Throwable) - Constructor for exception java.security.spec.InvalidKeySpecException
Creates a InvalidKeySpecException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidMarkException - Exception in java.nio
Unchecked exception thrown when an attempt is made to reset a buffer when its mark is not defined.
InvalidMarkException() - Constructor for exception java.nio.InvalidMarkException
Constructs an instance of this class.
InvalidMidiDataException - Exception in javax.sound.midi
An InvalidMidiDataException indicates that inappropriate MIDI data was encountered.
InvalidMidiDataException() - Constructor for exception javax.sound.midi.InvalidMidiDataException
Constructs an InvalidMidiDataException with null for its error detail message.
InvalidMidiDataException(String) - Constructor for exception javax.sound.midi.InvalidMidiDataException
Constructs an InvalidMidiDataException with the specified detail message.
InvalidName - Exception in org.omg.CORBA.ORBPackage
The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
InvalidName() - Constructor for exception org.omg.CORBA.ORBPackage.InvalidName
Constructs an InvalidName exception with no reason message.
InvalidName(String) - Constructor for exception org.omg.CORBA.ORBPackage.InvalidName
Constructs an InvalidName exception with the specified reason message.
InvalidName - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidName.java .
InvalidName() - Constructor for exception org.omg.CosNaming.NamingContextPackage.InvalidName
InvalidName(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage.InvalidName
InvalidName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
InvalidName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
InvalidName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
InvalidNameException - Exception in javax.naming
This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
InvalidNameException(String) - Constructor for exception javax.naming.InvalidNameException
Constructs an instance of InvalidNameException using an explanation of the problem.
InvalidNameException() - Constructor for exception javax.naming.InvalidNameException
Constructs an instance of InvalidNameException with all fields set to null.
InvalidNameHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java .
InvalidNameHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
InvalidNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
InvalidNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
InvalidNameHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
InvalidNameHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
InvalidNameHolder(InvalidName) - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
InvalidObjectException - Exception in java.io
Indicates that one or more deserialized objects failed validation tests.
InvalidObjectException(String) - Constructor for exception java.io.InvalidObjectException
Constructs an InvalidObjectException.
InvalidOpenTypeException - Exception in javax.management.openmbean
This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
InvalidOpenTypeException() - Constructor for exception javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with no detail message.
InvalidOpenTypeException(String) - Constructor for exception javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with a detail message.
InvalidParameterException - Exception in java.security
This exception, designed for use by the JCA/JCE engine classes, is thrown when an invalid parameter is passed to a method.
InvalidParameterException() - Constructor for exception java.security.InvalidParameterException
Constructs an InvalidParameterException with no detail message.
InvalidParameterException(String) - Constructor for exception java.security.InvalidParameterException
Constructs an InvalidParameterException with the specified detail message.
InvalidParameterSpecException - Exception in java.security.spec
This is the exception for invalid parameter specifications.
InvalidParameterSpecException() - Constructor for exception java.security.spec.InvalidParameterSpecException
Constructs an InvalidParameterSpecException with no detail message.
InvalidParameterSpecException(String) - Constructor for exception java.security.spec.InvalidParameterSpecException
Constructs an InvalidParameterSpecException with the specified detail message.
InvalidPathException - Exception in java.nio.file
Unchecked exception thrown when path string cannot be converted into a Path because the path string contains invalid characters, or the path string is invalid for other file system specific reasons.
InvalidPathException(String, String, int) - Constructor for exception java.nio.file.InvalidPathException
Constructs an instance from the given input string, reason, and error index.
InvalidPathException(String, String) - Constructor for exception java.nio.file.InvalidPathException
Constructs an instance from the given input string and reason.
InvalidPolicy - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/InvalidPolicy.java .
InvalidPolicy() - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicy(short) - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicy(String, short) - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicyHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
InvalidPolicyHelper() - Constructor for class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
InvalidPreferencesFormatException - Exception in java.util.prefs
Thrown to indicate that an operation could not complete because the input did not conform to the appropriate XML document type for a collection of preferences, as per the Preferences specification.
InvalidPreferencesFormatException(Throwable) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified cause.
InvalidPreferencesFormatException(String) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified detail message.
InvalidPreferencesFormatException(String, Throwable) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified detail message and cause.
InvalidPropertiesFormatException - Exception in java.util
Thrown to indicate that an operation could not complete because the input did not conform to the appropriate XML document type for a collection of properties, as per the Properties specification.
InvalidPropertiesFormatException(Throwable) - Constructor for exception java.util.InvalidPropertiesFormatException
Constructs an InvalidPropertiesFormatException with the specified cause.
InvalidPropertiesFormatException(String) - Constructor for exception java.util.InvalidPropertiesFormatException
Constructs an InvalidPropertiesFormatException with the specified detail message.
InvalidRelationIdException - Exception in javax.management.relation
This exception is raised when relation id provided for a relation is already used.
InvalidRelationIdException() - Constructor for exception javax.management.relation.InvalidRelationIdException
Default constructor, no message put in exception.
InvalidRelationIdException(String) - Constructor for exception javax.management.relation.InvalidRelationIdException
Constructor with given message put in exception.
InvalidRelationServiceException - Exception in javax.management.relation
This exception is raised when an invalid Relation Service is provided.
InvalidRelationServiceException() - Constructor for exception javax.management.relation.InvalidRelationServiceException
Default constructor, no message put in exception.
InvalidRelationServiceException(String) - Constructor for exception javax.management.relation.InvalidRelationServiceException
Constructor with given message put in exception.
InvalidRelationTypeException - Exception in javax.management.relation
Invalid relation type.
InvalidRelationTypeException() - Constructor for exception javax.management.relation.InvalidRelationTypeException
Default constructor, no message put in exception.
InvalidRelationTypeException(String) - Constructor for exception javax.management.relation.InvalidRelationTypeException
Constructor with given message put in exception.
InvalidRoleInfoException - Exception in javax.management.relation
This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
InvalidRoleInfoException() - Constructor for exception javax.management.relation.InvalidRoleInfoException
Default constructor, no message put in exception.
InvalidRoleInfoException(String) - Constructor for exception javax.management.relation.InvalidRoleInfoException
Constructor with given message put in exception.
InvalidRoleValueException - Exception in javax.management.relation
Role value is invalid.
InvalidRoleValueException() - Constructor for exception javax.management.relation.InvalidRoleValueException
Default constructor, no message put in exception.
InvalidRoleValueException(String) - Constructor for exception javax.management.relation.InvalidRoleValueException
Constructor with given message put in exception.
InvalidSearchControlsException - Exception in javax.naming.directory
This exception is thrown when the specification of the SearchControls for a search operation is invalid.
InvalidSearchControlsException() - Constructor for exception javax.naming.directory.InvalidSearchControlsException
Constructs a new instance of InvalidSearchControlsException.
InvalidSearchControlsException(String) - Constructor for exception javax.naming.directory.InvalidSearchControlsException
Constructs a new instance of InvalidSearchControlsException with an explanation.
InvalidSearchFilterException - Exception in javax.naming.directory
This exception is thrown when the specification of a search filter is invalid.
InvalidSearchFilterException() - Constructor for exception javax.naming.directory.InvalidSearchFilterException
Constructs a new instance of InvalidSearchFilterException.
InvalidSearchFilterException(String) - Constructor for exception javax.naming.directory.InvalidSearchFilterException
Constructs a new instance of InvalidSearchFilterException with an explanation.
InvalidSeq - Exception in org.omg.CORBA.DynAnyPackage
The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
InvalidSeq() - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidSeq
Constructs an InvalidSeq object.
InvalidSeq(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidSeq
Constructs an InvalidSeq object.
InvalidSlot - Exception in org.omg.PortableInterceptor
org/omg/PortableInterceptor/InvalidSlot.java .
InvalidSlot() - Constructor for exception org.omg.PortableInterceptor.InvalidSlot
InvalidSlot(String) - Constructor for exception org.omg.PortableInterceptor.InvalidSlot
InvalidSlotHelper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/InvalidSlotHelper.java .
InvalidSlotHelper() - Constructor for class org.omg.PortableInterceptor.InvalidSlotHelper
InvalidTargetObjectTypeException - Exception in javax.management.modelmbean
Exception thrown when an invalid target object type is specified.
InvalidTargetObjectTypeException() - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Default constructor.
InvalidTargetObjectTypeException(String) - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor from a string.
InvalidTargetObjectTypeException(Exception, String) - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor taking an exception and a string.
InvalidTransactionException - Exception in javax.transaction
This exception indicates that the request carried an invalid transaction context.
InvalidTransactionException() - Constructor for exception javax.transaction.InvalidTransactionException
InvalidTransactionException(String) - Constructor for exception javax.transaction.InvalidTransactionException
InvalidTypeForEncoding - Exception in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
InvalidTypeForEncoding() - Constructor for exception org.omg.IOP.CodecPackage.InvalidTypeForEncoding
InvalidTypeForEncoding(String) - Constructor for exception org.omg.IOP.CodecPackage.InvalidTypeForEncoding
InvalidTypeForEncodingHelper - Class in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
InvalidTypeForEncodingHelper() - Constructor for class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
InvalidValue - Exception in org.omg.CORBA.DynAnyPackage
InvalidValue() - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidValue
Constructs an InvalidValue object.
InvalidValue(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidValue
Constructs an InvalidValue object.
InvalidValue - Exception in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
InvalidValue() - Constructor for exception org.omg.DynamicAny.DynAnyPackage.InvalidValue
InvalidValue(String) - Constructor for exception org.omg.DynamicAny.DynAnyPackage.InvalidValue
InvalidValueHelper - Class in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java .
InvalidValueHelper() - Constructor for class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
inverseTransform(Point2D, Point2D) - Method in class java.awt.geom.AffineTransform
Inverse transforms the specified ptSrc and stores the result in ptDst.
inverseTransform(double[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Inverse transforms an array of double precision coordinates by this transform.
invert() - Method in class java.awt.geom.AffineTransform
Sets this transform to the inverse of itself.
INVITE - Static variable in class java.awt.PageAttributes.MediaType
An alias for INVITE_ENVELOPE.
INVITE_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Invitation Envelope, 220 x 220 mm.
Invocable - Interface in javax.script
The optional interface implemented by ScriptEngines whose methods allow the invocation of procedures in scripts that have previously been executed.
INVOCATION_DEFAULT - Static variable in class java.awt.event.InvocationEvent
The default id for all InvocationEvents.
INVOCATION_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting invocation events.
INVOCATION_FIRST - Static variable in class java.awt.event.InvocationEvent
Marks the first integer id for the range of invocation event ids.
INVOCATION_LAST - Static variable in class java.awt.event.InvocationEvent
Marks the last integer id for the range of invocation event ids.
InvocationEvent - Class in java.awt.event
An event which executes the run() method on a Runnable when dispatched by the AWT event dispatcher thread.
InvocationEvent(Object, Runnable) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source which will execute the runnable's run method when dispatched.
InvocationEvent(Object, Runnable, Object, boolean) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source which will execute the runnable's run method when dispatched.
InvocationEvent(Object, int, Runnable, Object, boolean) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source and ID which will execute the runnable's run method when dispatched.
InvocationHandler - Interface in java.lang.reflect
InvocationHandler is the interface implemented by the invocation handler of a proxy instance.
InvocationTargetException - Exception in java.lang.reflect
InvocationTargetException is a checked exception that wraps an exception thrown by an invoked method or constructor.
InvocationTargetException() - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs an InvocationTargetException with null as the target exception.
InvocationTargetException(Throwable) - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs a InvocationTargetException with a target exception.
InvocationTargetException(Throwable, String) - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs a InvocationTargetException with a target exception and a detail message.
INVOICE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Invoice, 5 1/2 x 8 1/2 in.
INVOICE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the invoice size, 5.5 inches by 8.5 inches.
INVOICE - Static variable in class javax.print.attribute.standard.MediaSizeName
invoice size .
invoke(Object, Method, Object[]) - Method in class java.beans.EventHandler
Extract the appropriate property value from the event and pass it to the action associated with this EventHandler.
invoke(Object, Method, Object[]) - Method in interface java.lang.reflect.InvocationHandler
Processes a method invocation on a proxy instance and returns the result.
invoke(Object, Object...) - Method in class java.lang.reflect.方法
Invokes the underlying method represented by this Method object, on the specified object with the specified parameters.
invoke(Object, Method, Object[]) - Method in class java.rmi.server.RemoteObjectInvocationHandler
Processes a method invocation made on the encapsulating proxy instance, proxy, and returns the result.
invoke(Remote, Method, Object[], long) - Method in interface java.rmi.server.RemoteRef
Invoke a method.
invoke(RemoteCall) - Method in interface java.rmi.server.RemoteRef
Deprecated.
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
invoke(ForkJoinTask<T>) - Method in class java.util.concurrent.ForkJoinPool
Performs the given task, returning its result upon completion.
invoke() - Method in class java.util.concurrent.ForkJoinTask
Commences performing this task, awaits its completion if necessary, and returns its result, or throws an (unchecked) RuntimeException or Error if the underlying computation did so.
invoke(String, Object[], String[]) - Method in interface javax.management.DynamicMBean
Allows an action to be invoked on the Dynamic MBean.
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServer
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Invokes an operation on an MBean.
invoke(Object, Method, Object[]) - Method in class javax.management.MBeanServerInvocationHandler
invoke(String, Object[], String[]) - Method in class javax.management.modelmbean.RequiredModelMBean
Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
invoke(Object, Method, Object[]) - Method in class javax.management.openmbean.CompositeDataInvocationHandler
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
invoke(String, Object[], String[]) - Method in class javax.management.StandardMBean
invoke(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation synchronously.
invoke(T) - Method in interface javax.xml.ws.Provider
Invokes an operation occording to the contents of the request message.
invoke(Method, Object...) - Method in class javax.xml.ws.spi.Invoker
JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.
invoke(ServerRequest) - Method in class org.omg.CORBA.DynamicImplementation
Deprecated.
Deprecated by Portable Object Adapter
invoke(Object, OutputStream) - Method in class org.omg.CORBA.portable.Delegate
invoke is called by a stub to invoke an operation.
invoke() - Method in class org.omg.CORBA.Request
Makes a synchronous invocation using the information in the Request object.
invoke(ServerRequest) - Method in class org.omg.CosNaming._BindingIteratorImplBase
invoke(ServerRequest) - Method in class org.omg.CosNaming._NamingContextImplBase
invoke(ServerRequest) - Method in class org.omg.PortableServer.DynamicImplementation
Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.AbstractExecutorService
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent.AbstractExecutorService
invokeAll(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning a list of Futures holding their status and results when all complete.
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning a list of Futures holding their status and results when all complete or the timeout expires, whichever happens first.
invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.ForkJoinPool
invokeAll(ForkJoinTask<?>, ForkJoinTask<?>) - Static method in class java.util.concurrent.ForkJoinTask
Forks the given tasks, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAll(ForkJoinTask<?>...) - Static method in class java.util.concurrent.ForkJoinTask
Forks the given tasks, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAll(Collection<T>) - Static method in class java.util.concurrent.ForkJoinTask
Forks all tasks in the specified collection, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAndWait(Runnable) - Static method in class java.awt.EventQueue
Causes runnable to have its run method called in the dispatch thread of the system EventQueue.
invokeAndWait(Runnable) - Static method in class javax.swing.SwingUtilities
Causes doRun.run() to be executed synchronously on the AWT event dispatching thread.
invokeAny(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.AbstractExecutorService
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent.AbstractExecutorService
invokeAny(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning the result of one that has completed successfully (i.e., without throwing an exception), if any do.
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning the result of one that has completed successfully (i.e., without throwing an exception), if any do before the given timeout elapses.
invokeAsync(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeAsync(T, AsyncHandler<T>) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeExact(Object...) - Method in class java.lang.invoke.MethodHandle
Invokes the method handle, allowing any caller type descriptor, but requiring an exact type match.
invokeFunction(String, Object...) - Method in interface javax.script.Invocable
Used to call top-level procedures and functions defined in scripts.
invokeGeneric(Object...) - Method in class java.lang.invoke.MethodHandle
Invokes the method handle, allowing any caller type descriptor, and optionally performing conversions on arguments and return values.
InvokeHandler - Interface in org.omg.CORBA.portable
This interface provides a dispatching mechanism for an incoming call.
invokeLater(Runnable) - Static method in class java.awt.EventQueue
Causes runnable to have its run method called in the dispatch thread of the system EventQueue.
invokeLater(Runnable) - Static method in class javax.swing.SwingUtilities
Causes doRun.run() to be executed asynchronously on the AWT event dispatching thread.
invokeMethod(Object, String, Object...) - Method in interface javax.script.Invocable
Calls a method on a script object compiled during a previous script execution, which is retained in the state of the ScriptEngine.
invokeOneWay(T) - Method in interface javax.xml.ws.Dispatch
Invokes a service operation using the one-way interaction mode.
Invoker - Class in javax.xml.ws.spi
Invoker hides the detail of calling into application endpoint implementation.
Invoker() - Constructor for class javax.xml.ws.spi.Invoker
INVOKES_STOP_CELL_EDITING_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for messagesStopCellEditing.
invokesStopCellEditing - Variable in class javax.swing.JTree
If true, when editing is to be stopped by way of selection changing, data in tree changing or other means stopCellEditing is invoked, and changes are saved.
invokeWithArguments(Object...) - Method in class java.lang.invoke.MethodHandle
Performs a varargs invocation, passing the arguments in the given array to the method handle, as if via invokeGeneric from a call site which mentions only the type Object, and whose arity is the length of the argument array.
invokeWithArguments(List<?>) - Method in class java.lang.invoke.MethodHandle
Performs a varargs invocation, passing the arguments in the given array to the method handle, as if via invokeGeneric from a call site which mentions only the type Object, and whose arity is the length of the argument array.
IOError - Error in java.io
Thrown when a serious I/O error has occurred.
IOError(Throwable) - Constructor for error java.io.IOError
Constructs a new instance of IOError with the specified cause.
IOException - Exception in java.io
Signals that an I/O exception of some sort has occurred.
IOException() - Constructor for exception java.io.IOException
Constructs an IOException with null as its error detail message.
IOException(String) - Constructor for exception java.io.IOException
Constructs an IOException with the specified detail message.
IOException(String, Throwable) - Constructor for exception java.io.IOException
Constructs an IOException with the specified detail message and cause.
IOException(Throwable) - Constructor for exception java.io.IOException
Constructs an IOException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ioException() - Method in class java.util.Formatter
Returns the IOException last thrown by this formatter's Appendable.
ioException() - Method in class java.util.Scanner
Returns the IOException last thrown by this Scanner's underlying Readable.
IOR - Class in org.omg.IOP
org/omg/IOP/IOR.java .
IOR() - Constructor for class org.omg.IOP.IOR
IOR(String, TaggedProfile[]) - Constructor for class org.omg.IOP.IOR
IORHelper - Class in org.omg.IOP
org/omg/IOP/IORHelper.java .
IORHelper() - Constructor for class org.omg.IOP.IORHelper
IORHolder - Class in org.omg.IOP
org/omg/IOP/IORHolder.java .
IORHolder() - Constructor for class org.omg.IOP.IORHolder
IORHolder(IOR) - Constructor for class org.omg.IOP.IORHolder
IORInfo - Interface in org.omg.PortableInterceptor
Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInfoOperations - Interface in org.omg.PortableInterceptor
Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInterceptor - Interface in org.omg.PortableInterceptor
Interceptor used to establish tagged components in the profiles within an IOR.
IORInterceptor_3_0 - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0.java .
IORInterceptor_3_0Helper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
IORInterceptor_3_0Helper() - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
IORInterceptor_3_0Holder - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
IORInterceptor_3_0Holder() - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
IORInterceptor_3_0Holder(IORInterceptor_3_0) - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
IORInterceptor_3_0Operations - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
IORInterceptorOperations - Interface in org.omg.PortableInterceptor
Interceptor used to establish tagged components in the profiles within an IOR.
IP_MULTICAST_IF - Static variable in interface java.net.SocketOptions
Set which outgoing interface on which to send multicast packets.
IP_MULTICAST_IF - Static variable in class java.net.StandardSocketOption
The network interface for Internet Protocol (IP) multicast datagrams.
IP_MULTICAST_IF2 - Static variable in interface java.net.SocketOptions
Same as above.
IP_MULTICAST_LOOP - Static variable in interface java.net.SocketOptions
This option enables or disables local loopback of multicast datagrams.
IP_MULTICAST_LOOP - Static variable in class java.net.StandardSocketOption
Loopback for Internet Protocol (IP) multicast datagrams.
IP_MULTICAST_TTL - Static variable in class java.net.StandardSocketOption
The time-to-live for Internet Protocol (IP) multicast datagrams.
IP_TOS - Static variable in interface java.net.SocketOptions
This option sets the type-of-service or traffic class field in the IP header for a TCP or UDP socket.
IP_TOS - Static variable in class java.net.StandardSocketOption
The Type of Service (ToS) octet in the Internet Protocol (IP) header.
IPA_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "IPA Extensions" Unicode character block.
ipadx - Variable in class java.awt.GridBagConstraints
This field specifies the internal padding of the component, how much space to add to the minimum width of the component.
ipady - Variable in class java.awt.GridBagConstraints
This field specifies the internal padding, that is, how much space to add to the minimum height of the component.
IRObject - Interface in org.omg.CORBA
An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
IRObjectOperations - Interface in org.omg.CORBA
This is the Operations interface for the mapping from IRObject.
is_a(Object, String) - Method in class org.omg.CORBA.portable.Delegate
Checks if the object reference is an instance of the given interface.
is_a(Servant, String) - Method in interface org.omg.PortableServer.portable.Delegate
This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
IS_CLOSED_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is closed.
IS_COALESCING - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to coalesce adjacent character data sections
is_equivalent(Object, Object) - Method in class org.omg.CORBA.portable.Delegate
Determines if the two object references are equivalent.
IS_ICON_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is iconified.
is_local(Object) - Method in class org.omg.CORBA.portable.Delegate
Returns true if this object is implemented by a local servant.
IS_MAXIMUM_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is maximized.
IS_NAMESPACE_AWARE - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
is_null() - Method in class org.omg.DynamicAny._DynValueStub
Returns true if the DynValueCommon represents a null value type.
is_null() - Method in interface org.omg.DynamicAny.DynValueCommonOperations
Returns true if the DynValueCommon represents a null value type.
IS_PALETTE - Static variable in class javax.swing.plaf.metal.MetalInternalFrameUI
IS_REPAIRING_NAMESPACES - Static variable in class javax.xml.stream.XMLOutputFactory
Property used to set prefix defaulting on the output side
IS_REPLACING_ENTITY_REFERENCES - Static variable in class javax.xml.stream.XMLInputFactory
Requires the parser to replace internal entity references with their replacement text and report them as characters
IS_SELECTED_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicated that this frame has selected status.
IS_SUPPORTING_EXTERNAL_ENTITIES - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to resolve external parsed entities
IS_VALIDATING - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off implementation specific validation
isAbsolute() - Method in class java.io.File
Tests whether this abstract pathname is absolute.
isAbsolute() - Method in class java.net.URI
Tells whether or not this URI is absolute.
isAbsolute() - Method in interface java.nio.file.Path
Tells whether or not this path is absolute.
isAbstract(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the abstract modifier, false otherwise.
isAccelerated() - Method in class java.awt.ImageCapabilities
Returns true if the object whose capabilities are encapsulated in this ImageCapabilities can be or is accelerated.
isAcceleratorHidden() - Method in class javax.swing.plaf.metal.MetalToolTipUI
isAcceptable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready to accept a new socket connection.
isAcceptAllFileFilterUsed() - Method in class javax.swing.JFileChooser
Returns whether the AcceptAll FileFilter is used.
isAccessible() - Method in class java.lang.reflect.AccessibleObject
Get the value of the accessible flag for this object.
isAccessibleChildSelected(int) - Method in class java.awt.List.AccessibleAWTList
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in interface javax.accessibility.AccessibleSelection
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JList.AccessibleJList
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JMenu.AccessibleJMenu
Returns true if the current child of this object is selected (that is, if this child is a popped-up submenu).
isAccessibleChildSelected(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
isAccessibleChildSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTree.AccessibleJTree
Returns true if the current child of this object is selected.
isAccessibleColumnSelected(int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the specified column is selected.
isAccessibleColumnSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the specified column is selected.
isAccessibleRowSelected(int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the specified row is selected.
isAccessibleRowSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the specified row is selected.
isAccessibleSelected(int, int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the accessible at a specified row and column is selected.
isAccessibleSelected(int, int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the accessible at a given (row, column) is selected.
isActionKey() - Method in class java.awt.event.KeyEvent
Returns whether the key in this event is an "action" key.
isActive() - Method in class java.applet.Applet
Determines if this applet is active.
isActive() - Method in interface java.applet.AppletStub
Determines if the applet is active.
isActive() - Method in class java.awt.dnd.DropTarget
Reports whether or not this DropTarget is currently active (ready to accept drops).
isActive() - Method in class java.awt.Window
Returns whether this Window is active.
isActive() - Method in class javax.management.monitor.Monitor
Tests whether the monitor MBean is active.
isActive() - Method in interface javax.management.monitor.MonitorMBean
Tests if the monitor MBean is active.
isActive() - Method in class javax.management.relation.RelationService
Checks if the Relation Service is active.
isActive() - Method in interface javax.management.relation.RelationServiceMBean
Checks if the Relation Service is active.
isActive() - Method in interface javax.management.remote.JMXConnectorServerMBean
Determines whether the connector server is active.
isActive() - Method in class javax.management.remote.rmi.RMIConnectorServer
isActive() - Method in class javax.management.timer.Timer
Tests whether the timer MBean is active.
isActive() - Method in interface javax.management.timer.TimerMBean
Tests whether the timer MBean is active.
isActive() - Method in interface javax.sound.sampled.DataLine
Indicates whether the line is engaging in active I/O (such as playback or capture).
isActive() - Method in class javax.swing.text.DefaultCaret
Determines if the caret is currently active.
isAddedPath() - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the path identified by getPath was added to the selection.
isAddedPath(TreePath) - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the specified path was added to the selection.
isAddedPath(int) - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the path at getPaths()[index] was added to the selection.
isAfter(int, int, Rectangle) - Method in class javax.swing.text.BoxView
Determines if a point falls after an allocated region.
isAfter(int, int, Rectangle) - Method in class javax.swing.text.CompositeView
Tests whether a point lies after the rectangle range.
isAfterLast() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is after the last row in this ResultSet object.
isAlive() - Method in class java.lang.Thread
Tests if this thread is alive.
isAllocationValid() - Method in class javax.swing.text.BoxView
Are the allocations for the children still valid?
isAlphaPremultiplied() - Method in class java.awt.image.BufferedImage
Returns whether or not the alpha has been premultiplied.
isAlphaPremultiplied() - Method in class java.awt.image.ColorModel
Returns whether or not the alpha has been premultiplied in the pixel values to be translated by this ColorModel.
isAltDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Alt modifier is down on this event.
isAltGraphDown() - Method in class java.awt.event.InputEvent
Returns whether or not the AltGraph modifier is down on this event.
isAlwaysOnTop() - Method in class java.awt.Window
Returns whether this window is an always-on-top window.
isAlwaysOnTopSupported() - Method in class java.awt.Toolkit
Returns whether the always-on-top mode is supported by this toolkit.
isAlwaysOnTopSupported() - Method in class java.awt.Window
Returns whether the always-on-top mode is supported for this window.
isAncestorOf(Component) - Method in class java.awt.Container
Checks if the component is contained in the component hierarchy of this container.
isAnnotation() - Method in class java.lang.类
Returns true if this 类 object represents an annotation type.
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.类
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.软件包
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.reflect.AccessibleObject
isAnnotationPresent(Class<? extends Annotation>) - Method in interface java.lang.reflect.AnnotatedElement
Returns true if an annotation for the specified type is present on this element, else false.
isAnonymous() - Method in interface org.ietf.jgss.GSSName
Tests if this name object represents an anonymous entity.
isAnonymousClass() - Method in class java.lang.类
Returns true if and only if the underlying class is an anonymous class.
isAntiAliased() - Method in class java.awt.font.FontRenderContext
Returns a boolean which indicates whether or not some form of antialiasing is specified by this FontRenderContext.
isAnyLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress in a wildcard address.
isAnyLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress in a wildcard address.
isAnyLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress in a wildcard address.
isAnyPolicyInhibited() - Method in class java.security.cert.PKIXParameters
Checks whether the any policy OID should be processed if it is included in a certificate.
isArchive() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the archive attribute.
isArmed() - Method in interface javax.swing.ButtonModel
Indicates partial commitment towards triggering the button.
isArmed() - Method in class javax.swing.DefaultButtonModel
Indicates partial commitment towards triggering the button.
isArmed() - Method in class javax.swing.JMenuItem
Returns whether the menu item is "armed".
isArray() - Method in class java.lang.类
Determines if this 类 object represents an array class.
isArray() - Method in class javax.management.openmbean.OpenType
Returns true if the open data values this open type describes are arrays, false otherwise.
isAscending() - Method in class javax.naming.ldap.SortKey
Determines the sort order.
isAssignable(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type is assignable to another.
isAssignableFrom(Class<?>) - Method in class java.lang.类
Determines if the class or interface represented by this 类 object is either the same as, or is a superclass or superinterface of, the class or interface represented by the specified 类 parameter.
isAttribute() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an Attribute.
isAttributeCategorySupported(Class<? extends Attribute>) - Method in interface javax.print.PrintService
Determines whether a client can specify the given printing attribute category when setting up a job for this print service.
isAttributeRequired(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat
Returns true if the named attribute must be present within the named element.
isAttributeRequired(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
isAttributeSpecified(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
isAttributeSpecified(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns a boolean which indicates if this attribute was created by default
isAttributeValueSupported(Attribute, DocFlavor, AttributeSet) - Method in interface javax.print.PrintService
Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
isAuthorized() - Method in class javax.security.sasl.AuthorizeCallback
Determines whether the authentication id is allowed to act on behalf of the authorization id.
isAutoDetecting() - Method in class java.nio.charset.CharsetDecoder
Tells whether or not this decoder implements an auto-detecting charset.
isAutoFormSubmission() - Method in class javax.swing.text.html.HTMLEditorKit
Indicates whether an html form submission is processed automatically or only FormSubmitEvent is fired.
isAutoIncrement(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is automatically numbered.
isAutoIncrement(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Retrieves whether a value stored in the designated column is automatically numbered, and thus readonly.
isAutoRequestFocus() - Method in class java.awt.Window
Returns whether this window should receive focus on subsequently being shown (with a call to setVisible(true)), or being moved to the front (with a call to Window.toFront()).
isAutoScrolling - Variable in class javax.swing.plaf.basic.BasicComboPopup
isAutoWaitForIdle() - Method in class java.awt.Robot
Returns whether this Robot automatically invokes waitForIdle after generating an event.
isBackgroundSet() - Method in class java.awt.Component
Returns whether the background color has been explicitly set for this Component.
isBackingStoreEnabled() - Method in class javax.swing.JViewport
Deprecated.
As of Java 2 platform v1.3, replaced by getScrollMode().
isBefore(int, int, Rectangle) - Method in class javax.swing.text.BoxView
Determines if a point falls before an allocated region.
isBefore(int, int, Rectangle) - Method in class javax.swing.text.CompositeView
Tests whether a point lies before the rectangle range.
isBeforeFirst() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is before the first row in this ResultSet object.
isBigEndian() - Method in class javax.sound.sampled.AudioFormat
Indicates whether the audio data is stored in big-endian or little-endian byte order.
isBlock() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag is a block tag, which is a tag used to add structure to a document.
isBlocking() - Method in class java.nio.channels.SelectableChannel
Tells whether or not every I/O operation on this channel will block until it completes.
isBlocking() - Method in class java.nio.channels.spi.AbstractSelectableChannel
isBlockTag(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Determines if the HTML.Tag associated with the element is a block tag.
isBmpCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is in the Basic Multilingual Plane (BMP).
isBold() - Method in class java.awt.Font
Indicates whether or not this Font object's style is BOLD.
isBold(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the bold attribute is set.
isBootClassPathSupported() - Method in interface java.lang.management.RuntimeMXBean
Tests if the Java virtual machine supports the boot class path mechanism used by the bootstrap class loader to search for class files.
isBorderOpaque() - Method in class javax.swing.border.AbstractBorder
This default implementation returns false.
isBorderOpaque() - Method in class javax.swing.border.BevelBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in interface javax.swing.border.Border
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.CompoundBorder
Returns whether or not the compound border is opaque.
isBorderOpaque() - Method in class javax.swing.border.EmptyBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.EtchedBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.LineBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.MatteBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.SoftBevelBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.TitledBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
isBorderOpaque() - Method in class javax.swing.plaf.BorderUIResource
isBorderPainted() - Method in class javax.swing.AbstractButton
Gets the borderPainted property.
isBorderPainted() - Method in class javax.swing.JMenuBar
Returns true if the menu bars border should be painted.
isBorderPainted() - Method in class javax.swing.JPopupMenu
Checks whether the border should be painted.
isBorderPainted() - Method in class javax.swing.JProgressBar
Returns the borderPainted property.
isBorderPainted() - Method in class javax.swing.JToolBar
Gets the borderPainted property.
isBorderPaintedFlat() - Method in class javax.swing.JCheckBox
Gets the value of the borderPaintedFlat property.
isBound() - Method in class java.beans.PropertyDescriptor
Updates to "bound" properties will cause a "PropertyChange" event to get fired when the property is changed.
isBound() - Method in class java.net.DatagramSocket
Returns the binding state of the socket.
isBound() - Method in class java.net.ServerSocket
Returns the binding state of the ServerSocket.
isBound() - Method in class java.net.Socket
Returns the binding state of the socket.
isBoundary(int) - Method in class java.text.BreakIterator
Returns true if the specified character offset is a text boundary.
isBridge() - Method in class java.lang.reflect.方法
Returns true if this method is a bridge method; returns false otherwise.
isBroken() - Method in class java.util.concurrent.CyclicBarrier
Queries if this barrier is in a broken state.
isCached() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns true since this ImageInputStream caches data in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns true since this ImageOutputStream caches data in order to allow seeking backwards.
isCached() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCached() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns true since this ImageInputStream caches data in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns true since this ImageOutputStream caches data in order to allow seeking backwards.
isCachedFile() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns true since this ImageInputStream maintains a file cache.
isCachedFile() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns true since this ImageOutputStream maintains a file cache.
isCachedFile() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards, and the cache is kept in a temporary file.
isCachedFile() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCachedFile() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns false since this ImageInputStream does not maintain a file cache.
isCachedFile() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns false since this ImageOutputStream does not maintain a file cache.
isCachedMemory() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns false since this ImageInputStream does not maintain a main memory cache.
isCachedMemory() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns false since this ImageOutputStream does not maintain a main memory cache.
isCachedMemory() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards, and the cache is kept in main memory.
isCachedMemory() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCachedMemory() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns true since this ImageInputStream maintains a main memory cache.
isCachedMemory() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns true since this ImageOutputStream maintains a main memory cache.
isCanceled() - Method in class javax.swing.ProgressMonitor
Returns true if the user hits the Cancel button in the progress dialog.
isCancelled() - Method in class java.awt.print.PrinterJob
Returns true if a print job is in progress, but is going to be cancelled at the next opportunity; otherwise returns false.
isCancelled() - Method in class java.util.concurrent.ForkJoinTask
isCancelled() - Method in interface java.util.concurrent.Future
Returns true if this task was cancelled before it completed normally.
isCancelled() - Method in class java.util.concurrent.FutureTask
isCancelled() - Method in class javax.swing.SwingWorker
Returns true if this task was cancelled before it completed normally.
isCaseIgnored() - Method in interface javax.naming.directory.Attributes
Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
isCaseIgnored() - Method in class javax.naming.directory.BasicAttributes
isCaseSensitive(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether a column's case matters.
isCaseSensitive(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether the case of the designated column's name matters.
isCatalogAtStart() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a catalog appears at the start of a fully qualified table name.
isCData() - Method in interface javax.xml.stream.events.Characters
Returns true if this is a CData section.
isCellEditable(EventObject) - Method in class javax.swing.AbstractCellEditor
Returns true.
isCellEditable(EventObject) - Method in interface javax.swing.CellEditor
Asks the editor if it can start editing using anEvent.
isCellEditable(EventObject) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
Returns true if anEvent is not a MouseEvent.
isCellEditable(EventObject) - Method in class javax.swing.DefaultCellEditor
Forwards the message from the CellEditor to the delegate.
isCellEditable(int, int) - Method in class javax.swing.JTable
Returns true if the cell at row and column is editable.
isCellEditable(int, int) - Method in class javax.swing.table.AbstractTableModel
Returns false.
isCellEditable(int, int) - Method in class javax.swing.table.DefaultTableModel
Returns true regardless of parameter values.
isCellEditable(int, int) - Method in interface javax.swing.table.TableModel
Returns true if the cell at rowIndex and columnIndex is editable.
isCellEditable(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor
If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
isCellSelected(int, int) - Method in class javax.swing.JTable
Returns true if the specified indices are in the valid range of rows and columns and the cell at the specified position is selected.
isCertificateEntry(String) - Method in class java.security.KeyStore
Returns true if the entry identified by the given alias was created by a call to setCertificateEntry, or created by a call to setEntry with a TrustedCertificateEntry.
isCharacters() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is Characters.
isCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate
isCharacters() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event
isCharsetDetected() - Method in class java.nio.charset.CharsetDecoder
Tells whether or not this decoder has yet detected a charset (optional operation).
isClass() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of class: either 类 or ENUM.
isClosable() - Method in class javax.swing.JInternalFrame
Returns whether this JInternalFrame can be closed by some user action.
isClosed() - Method in class java.net.DatagramSocket
Returns whether the socket is closed or not.
isClosed() - Method in class java.net.ServerSocket
Returns the closed state of the ServerSocket.
isClosed() - Method in class java.net.Socket
Returns the closed state of the socket.
isClosed() - Method in interface java.sql.Connection
Retrieves whether this Connection object has been closed.
isClosed() - Method in interface java.sql.ResultSet
Retrieves whether this ResultSet object has been closed.
isClosed() - Method in interface java.sql.Statement
Retrieves whether this Statement object has been closed.
isClosed - Variable in class javax.swing.JInternalFrame
The frame has been closed.
isClosed() - Method in class javax.swing.JInternalFrame
Returns whether this JInternalFrame is currently closed.
isCloseOnCompletion() - Method in interface java.sql.Statement
Returns a value indicating whether this Statement will be closed when all its dependent result sets are closed.
isCoalesce() - Method in class javax.swing.Timer
Returns true if the Timer coalesces multiple pending action events.
isCoalescing() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
isCollapsed(TreePath) - Method in class javax.swing.JTree
Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
isCollapsed(int) - Method in class javax.swing.JTree
Returns true if the node at the specified display row is collapsed.
isCollectionUsageThresholdExceeded() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if the memory usage of this memory pool after the most recent collection on which the Java virtual machine has expended effort has reached or exceeded its collection usage threshold.
isCollectionUsageThresholdSupported() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool supports a collection usage threshold.
isColumnSelected(int) - Method in class javax.swing.JTable
Returns true if the specified index is in the valid range of columns, and the column at that index is selected.
isCombining() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a combining glyph.
isComment() - Method in interface javax.xml.soap.Text
Retrieves whether this Text object represents a comment.
isCompatibleRaster(Raster) - Method in class java.awt.image.ColorModel
Returns true if raster is compatible with this ColorModel and false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.ComponentColorModel
Returns true if raster is compatible with this ColorModel; false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.DirectColorModel
Returns true if raster is compatible with this ColorModel and false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.IndexColorModel
Returns true if raster is compatible with this ColorModel or false if it is not compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.ColorModel
Checks if the SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.ComponentColorModel
Checks whether or not the specified SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.IndexColorModel
Checks if the specified SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.PackedColorModel
Checks if the specified SampleModel is compatible with this ColorModel.
isCompatibleValue(Object) - Method in class java.awt.RenderingHints.Key
Returns true if the specified object is a valid value for this Key.
isCompatibleWith(String) - Method in class java.lang.软件包
Compare this package's specification version with a desired version.
isCompilationTimeMonitoringSupported() - Method in interface java.lang.management.CompilationMXBean
Tests if the Java virtual machine supports the monitoring of compilation time.
isComplete() - Method in interface javax.security.sasl.SaslClient
Determines whether the authentication exchange has completed.
isComplete() - Method in interface javax.security.sasl.SaslServer
Determines whether the authentication exchange has completed.
isCompletedAbnormally() - Method in class java.util.concurrent.ForkJoinTask
Returns true if this task threw an exception or was cancelled.
isCompletedNormally() - Method in class java.util.concurrent.ForkJoinTask
Returns true if this task completed without throwing an exception and was not cancelled.
isCompletelyDirty(JComponent) - Method in class javax.swing.RepaintManager
Convenience method that returns true if aComponent will be completely painted during the next paintDirtyRegions().
isComponent() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a component glyph.
isComponentPartOfCurrentMenu(Component) - Method in class javax.swing.MenuSelectionManager
Return true if c is part of the currently used menu
isCompositionEnabled() - Method in class java.awt.im.InputContext
Determines whether the current input method is enabled for composition.
isCompositionEnabled() - Method in interface java.awt.im.spi.InputMethod
Determines whether this input method is enabled.
isCompressionLossless() - Method in class javax.imageio.ImageWriteParam
Returns true if the current compression type provides lossless compression.
isCompressionLossless() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Returns false since the JPEG plug-in only supports lossy compression.
isComputerNode(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for a computer node, e.g.
isConnectable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel has either finished, or failed to finish, its socket-connection operation.
isConnected() - Method in class java.net.DatagramSocket
Returns the connection state of the socket.
isConnected() - Method in class java.net.Socket
Returns the connection state of the socket.
isConnected() - Method in class java.nio.channels.DatagramChannel
Tells whether or not this channel's socket is connected.
isConnected() - Method in class java.nio.channels.SocketChannel
Tells whether or not this channel's network socket is connected.
isConnectionPending() - Method in class java.nio.channels.SocketChannel
Tells whether or not a connection operation is in progress on this channel.
isConstrained() - Method in class java.beans.PropertyDescriptor
Attempted updates to "Constrained" properties will cause a "VetoableChange" event to get fired when the property is changed.
isConsumed() - Method in class java.awt.AWTEvent
Returns whether this event has been consumed.
isConsumed() - Method in class java.awt.event.InputEvent
Returns whether or not this event has been consumed.
isConsumed() - Method in class java.awt.event.InputMethodEvent
Returns whether or not this event has been consumed.
isConsumer(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Determines whether an ImageConsumer is on the list of consumers currently interested in data for this image.
isConsumer(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Determines if a specified ImageConsumer object is currently registered with this ImageProducer as one of its consumers.
isConsumer(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Determines if an ImageConsumer is on the list of consumers currently interested in data for this image.
isConsumer(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Determine if an ImageConsumer is on the list of consumers currently interested in data for this image.
isContentAreaFilled() - Method in class javax.swing.AbstractButton
Gets the contentAreaFilled property.
isContextual() - Method in class java.awt.font.NumericShaper
Returns a boolean indicating whether or not this shaper shapes contextually.
isContinuousLayout() - Method in class javax.swing.JSplitPane
Gets the continuousLayout property.
isContinuousLayout() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Determines wether the JSplitPane is set to use a continuous layout.
isControlDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Control modifier is down on this event.
isControlSupported(Control.Type) - Method in interface javax.sound.sampled.Line
Indicates whether the line supports a control of the specified type.
isConversionSupported(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
isConversionSupported(AudioFormat, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio input stream of a specified format can be obtained from an audio input stream of another specified format.
isConversionSupported(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to a particular encoding from a particular format.
isConversionSupported(AudioFormat, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to one particular format from another.
isCritical() - Method in interface java.security.cert.Extension
Gets the extension's criticality setting.
isCritical() - Method in interface java.security.cert.PolicyNode
Returns the criticality indicator of the certificate policy extension in the most recently processed certificate.
isCritical() - Method in class javax.naming.ldap.BasicControl
Determines the control's criticality.
isCritical() - Method in interface javax.naming.ldap.Control
Determines the criticality of the LDAP control.
isCryptoAllowed(Key) - Method in class javax.crypto.ExemptionMechanism
Returns whether the result blob has been generated successfully by this exemption mechanism.
isCS_sRGB() - Method in class java.awt.color.ColorSpace
Returns true if the ColorSpace is CS_sRGB.
isCurrency(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is a cash value.
isCurrency(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column is a cash value.
isCurrent() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is still current.
isCurrent() - Method in interface javax.security.auth.Refreshable
Determine if this Object is current.
isCurrentServiceInvalidNow() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent
Reports if the current service is being forcibly revoked, in which case the references are now invalidated and unusable.
isCurrentThreadCpuTimeSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports CPU time measurement for the current thread.
isCursorSet() - Method in class java.awt.Component
Returns whether the cursor has been explicitly set for this Component.
isCustomMarshaled(Class) - Method in interface javax.rmi.CORBA.ValueHandler
Indicates whether the given class performs custom or default marshaling.
isCyclic() - Method in class java.awt.GradientPaint
Returns true if the gradient cycles repeatedly between the two colors C1 and C2.
isDaemon() - Method in class java.lang.Thread
Tests if this thread is a daemon thread.
isDaemon() - Method in class java.lang.ThreadGroup
Tests if this thread group is a daemon thread group.
isDataFlavorAvailable(DataFlavor) - Method in class java.awt.datatransfer.Clipboard
Returns whether or not the current contents of this clipboard can be provided in the specified DataFlavor.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.datatransfer.StringSelection
Returns whether the requested flavor is supported by this Transferable.
isDataFlavorSupported(DataFlavor) - Method in interface java.awt.datatransfer.Transferable
Returns whether or not the specified data flavor is supported for this object.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetContext
This method returns a boolean indicating if the given DataFlavor is supported by this DropTargetContext.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetContext.TransferableProxy
Returns whether or not the specified data flavor is supported by the encapsulated transferable.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetDragEvent
This method returns a boolean indicating if the specified DataFlavor is supported.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetDropEvent
This method returns a boolean indicating if the specified DataFlavor is available from the source.
isDataFlavorSupported(DataFlavor) - Method in class javax.activation.DataHandler
Returns whether the specified data flavor is supported for this object.
isDataFlavorSupported(DataFlavor) - Method in class javax.swing.TransferHandler.TransferSupport
Returns whether or not the given data flavor is supported.
isDecimalSeparatorAlwaysShown() - Method in class java.text.DecimalFormat
Allows you to get the behavior of the decimal separator with integers.
isDeclared(int) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(String) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(String, String) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(int) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDeclared(String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDeclared(String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDefaultButton() - Method in class javax.swing.JButton
Gets the value of the defaultButton property, which if true means that this button is the current default button for its JRootPane.
isDefaultCapable() - Method in class javax.swing.JButton
Gets the value of the defaultCapable property.
isDefaultLookAndFeelDecorated() - Static method in class javax.swing.JDialog
Returns true if newly created JDialogs should have their Window decorations provided by the current look and feel.
isDefaultLookAndFeelDecorated() - Static method in class javax.swing.JFrame
Returns true if newly created JFrames should have their Window decorations provided by the current look and feel.
isDefaultNamespace(String) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isDefaultNamespace(String) - Method in interface org.w3c.dom.Node
This method checks if the specified namespaceURI is the default namespace or not.
isDefaultNamespaceDeclaration() - Method in interface javax.xml.stream.events.Namespace
returns true if this attribute declares the default namespace
isDefined(char) - Static method in class java.lang.Character
Determines if a character is defined in Unicode.
isDefined(int) - Static method in class java.lang.Character
Determines if a character (Unicode code point) is defined in Unicode.
isDefined(Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether a given attribute is defined.
isDefined(Object) - Method in interface javax.swing.text.AttributeSet
Checks whether the named attribute has a value specified in the set without resolving through another attribute set.
isDefined(Object) - Method in class javax.swing.text.SimpleAttributeSet
Tells whether a given attribute is defined.
isDefined(Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether a given attribute is defined.
isDefined(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether a given attribute is defined.
isDefinitelyWritable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether a write on the designated column will definitely succeed.
isDefinitelyWritable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a write operation on the designated column will definitely succeed.
isDelegated() - Method in class java.beans.beancontext.BeanContextChildSupport
Reports whether or not this class is a delegate of another.
isDeprecated(Element) - Method in interface javax.lang.model.util.Elements
Returns true if the element is deprecated, false otherwise.
isDerivedFrom(String, String, int) - Method in interface org.w3c.dom.TypeInfo
This method returns if there is a derivation between the reference type definition, i.e.
isDescendant(TreePath) - Method in class javax.swing.tree.TreePath
Returns true if aTreePath is a descendant of this TreePath.
isDescendingFrom(Component, Component) - Static method in class javax.swing.SwingUtilities
Return true if a component a descends from a component b
isDesignTime() - Method in class java.beans.beancontext.BeanContextSupport
Reports whether or not this object is in currently in design time mode.
isDesignTime() - Static method in class java.beans.Beans
Test if we are in design-mode.
isDesignTime() - Method in interface java.beans.DesignMode
A value of true denotes that JavaBeans should behave in design time mode, a value of false denotes runtime behavior.
isDesktopSupported() - Static method in class java.awt.Desktop
Tests whether this class is supported on the current platform.
isDestroyed() - Method in class java.lang.ThreadGroup
Tests if this thread group has been destroyed.
isDestroyed() - Method in class java.security.KeyStore.PasswordProtection
Determines if password has been cleared.
isDestroyed() - Method in interface javax.security.auth.Destroyable
Determine if this Object has been destroyed.
isDestroyed() - Method in class javax.security.auth.kerberos.KerberosKey
Determines if this key has been destroyed.
isDestroyed() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket has been destroyed.
isDestroyed() - Method in class javax.security.auth.x500.X500PrivateCredential
Determines if the references to the X.509 certificate and private key in this object have been cleared.
isDeviceSupported(MidiDevice.Info) - Method in class javax.sound.midi.spi.MidiDeviceProvider
Indicates whether the device provider supports the device represented by the specified device info object.
isDigit(char) - Static method in class java.lang.Character
Determines if the specified character is a digit.
isDigit(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a digit.
isDirect() - Method in class java.nio.Buffer
Tells whether or not this buffer is direct.
isDirect() - Method in class java.nio.ByteBuffer
Tells whether or not this byte buffer is direct.
isDirect() - Method in class java.nio.CharBuffer
Tells whether or not this char buffer is direct.
isDirect() - Method in class java.nio.DoubleBuffer
Tells whether or not this double buffer is direct.
isDirect() - Method in class java.nio.FloatBuffer
Tells whether or not this float buffer is direct.
isDirect() - Method in class java.nio.IntBuffer
Tells whether or not this int buffer is direct.
isDirect() - Method in class java.nio.LongBuffer
Tells whether or not this long buffer is direct.
isDirect() - Method in class java.nio.ShortBuffer
Tells whether or not this short buffer is direct.
isDirectory() - Method in class java.io.File
Tests whether the file denoted by this abstract pathname is a directory.
isDirectory() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a directory.
isDirectory(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file is a directory.
isDirectory() - Method in class java.util.zip.ZipEntry
Returns true if this is a directory entry.
isDirectorySelected() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
Property to remember whether a directory is currently selected in the UI.
isDirectorySelectionEnabled() - Method in class javax.swing.JFileChooser
Convenience call that determines if directories are selectable based on the current file selection mode.
isDispatched() - Method in class java.awt.event.InvocationEvent
Returns true if the event is dispatched or any exception is thrown while dispatching, false otherwise.
isDispatchThread() - Static method in class java.awt.EventQueue
Returns true if the calling thread is the current AWT EventQueue's dispatch thread.
isDisplayable() - Method in class java.awt.Component
Determines whether this component is displayable.
isDisplayChangeSupported() - Method in class java.awt.GraphicsDevice
Returns true if this GraphicsDevice supports low-level display changes.
isDisposed() - Method in class javax.print.StreamPrintService
Returns a boolean indicating whether or not this StreamPrintService has been disposed.
isDocFlavorSupported(DocFlavor) - Method in interface javax.print.PrintService
Determines if this print service supports a specific DocFlavor.
isDomainPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the domain part.
isDone() - Method in class java.awt.geom.FlatteningPathIterator
Tests if the iteration is complete.
isDone() - Method in interface java.awt.geom.PathIterator
Tests if the iteration is complete.
isDone() - Method in class java.util.concurrent.ForkJoinTask
isDone() - Method in interface java.util.concurrent.Future
Returns true if this task completed.
isDone() - Method in class java.util.concurrent.FutureTask
isDone() - Method in class javax.swing.SwingWorker
Returns true if this task completed.
isDoubleBuffered() - Method in class java.awt.Component
Returns true if this component is painted to an offscreen image ("buffer") that's copied to the screen later.
isDoubleBuffered() - Method in class javax.swing.JComponent
Returns whether this component should use a buffer to paint.
isDoubleBufferingEnabled() - Method in class javax.swing.RepaintManager
Returns true if this RepaintManager is double buffered.
isDragging - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
isDragging() - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns true if the user is dragging the slider.
isDragging - Variable in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
isDragImageSupported() - Static method in class java.awt.dnd.DragSource
Reports whether or not drag Image support is available on the underlying platform.
isDrawingBuffer() - Method in class javax.swing.DebugGraphics
Returns the drawingBuffer value.
isDrive(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for drives or partitions, e.g.
isDrop() - Method in class javax.swing.TransferHandler.TransferSupport
Returns whether or not this TransferSupport represents a drop operation.
isDropLine(JTree.DropLocation) - Method in class javax.swing.plaf.basic.BasicTreeUI
Tells if a DropLocation should be indicated by a line between nodes.
isDuplicateToken() - Method in class org.ietf.jgss.MessageProp
Tests if this is a duplicate of an earlier token.
isDynamic() - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory
Returns true if successive renderings (that is, calls to create(RenderContext, ParameterBlock)) with the same arguments may produce different results.
isDynamic() - Method in interface java.awt.image.renderable.RenderableImage
Returns true if successive renderings (that is, calls to createRendering() or createScaledRendering()) with the same arguments may produce different results.
isDynamic() - Method in class java.awt.image.renderable.RenderableImageOp
Returns true if successive renderings (that is, calls to createRendering() or createScaledRendering()) with the same arguments may produce different results.
isDynamicLayoutActive() - Method in class java.awt.Toolkit
Returns whether dynamic layout of Containers on resize is currently active (both set in program ( isDynamicLayoutSet() ) , and supported by the underlying operating system and/or window manager).
isDynamicLayoutSet() - Method in class java.awt.Toolkit
Returns whether the layout of Containers is validated dynamically during resizing, or statically, after resizing is complete.
isEchoOn() - Method in class javax.security.auth.callback.PasswordCallback
Return whether the password should be displayed as it is being typed.
isEditable() - Method in class java.awt.TextComponent
Indicates whether or not this text component is editable.
isEditable - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
isEditable() - Method in class javax.swing.JComboBox
Returns true if the JComboBox is editable.
isEditable() - Method in class javax.swing.JTree
Returns true if the tree is editable.
isEditable() - Method in class javax.swing.plaf.basic.BasicTreeUI
isEditable() - Method in class javax.swing.text.JTextComponent
Returns the boolean indicating whether this TextComponent is editable or not.
isEditing() - Method in class javax.swing.JTable
Returns true if a cell is being edited.
isEditing() - Method in class javax.swing.JTree
Returns true if the tree is being edited.
isEditing(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns true if the tree is being edited.
isEditing(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the isEditing method on each UI handled by this object.
isEditing(JTree) - Method in class javax.swing.plaf.TreeUI
Returns true if the tree is being edited.
isEditValid() - Method in class javax.swing.JFormattedTextField
Returns true if the current value being edited is valid.
isElement(Object) - Method in class javax.xml.bind.JAXBIntrospector
Return true iff object represents a JAXB element.
isElementContentWhitespace() - Method in interface org.w3c.dom.Text
Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
isEmpty() - Method in class java.awt.geom.Arc2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Arc2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Area
Tests whether this Area object encloses any area.
isEmpty() - Method in class java.awt.geom.Ellipse2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Ellipse2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Rectangle2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Rectangle2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RectangularShape
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RoundRectangle2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RoundRectangle2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.Rectangle
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.RenderingHints
Returns true if this RenderingHints contains no key-value mappings.
isEmpty() - Method in class java.beans.beancontext.BeanContextSupport
Reports whether or not this BeanContext is empty.
isEmpty() - Method in class java.lang.String
Returns true if, and only if, String.length() is 0.
isEmpty() - Method in class java.util.AbstractCollection
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.AbstractMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.ArrayDeque
Returns true if this deque contains no elements.
isEmpty() - Method in class java.util.ArrayList
Returns true if this list contains no elements.
isEmpty() - Method in class java.util.BitSet
Returns true if this BitSet contains no bits that are set to true.
isEmpty() - Method in interface java.util.Collection
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentHashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns true if this queue contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains no elements.
isEmpty() - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.concurrent.LinkedTransferQueue
Returns true if this queue contains no elements.
isEmpty() - Method in class java.util.concurrent.SynchronousQueue
Always returns true.
isEmpty() - Method in class java.util.Dictionary
Tests if this dictionary maps no keys to value.
isEmpty() - Method in class java.util.HashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.HashSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.Hashtable
Tests if this hashtable maps no keys to values.
isEmpty() - Method in class java.util.IdentityHashMap
Returns true if this identity hash map contains no key-value mappings.
isEmpty() - Method in class java.util.jar.Attributes
Returns true if this Map contains no attributes.
isEmpty() - Method in interface java.util.List
Returns true if this list contains no elements.
isEmpty() - Method in interface java.util.Map
Returns true if this map contains no key-value mappings.
isEmpty() - Method in interface java.util.Set
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.TreeSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.Vector
Tests if this vector has no components.
isEmpty() - Method in class java.util.WeakHashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class javax.activation.MimeTypeParameterList
Determine whether or not this list is empty.
isEmpty() - Method in interface javax.management.openmbean.TabularData
Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
isEmpty() - Method in class javax.management.openmbean.TabularDataSupport
Returns true if this TabularDataSupport instance contains no rows.
isEmpty() - Method in class javax.management.timer.Timer
Tests whether the list of timer notifications is empty.
isEmpty() - Method in interface javax.management.timer.TimerMBean
Tests whether the list of timer notifications is empty.
isEmpty() - Method in class javax.naming.CompositeName
Determines whether this composite name is empty.
isEmpty() - Method in class javax.naming.CompoundName
Determines whether this compound name is empty.
isEmpty() - Method in class javax.naming.ldap.LdapName
Determines whether this LDAP name is empty.
isEmpty() - Method in interface javax.naming.Name
Determines whether this name is empty.
isEmpty() - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains no attributes.
isEmpty() - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains no attributes.
isEmpty() - Method in class javax.script.SimpleBindings
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class javax.swing.DefaultListModel
Tests whether this list has any components.
isEmpty() - Method in class javax.swing.text.html.parser.Element
Check if empty
isEmpty() - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the set of attributes is empty.
isEnabled() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is enabled.
isEnabled() - Method in class java.awt.Component
Determines whether this component is enabled.
isEnabled() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is enabled.
isEnabled() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is enabled.
isEnabled() - Method in class java.awt.MenuItem
Checks whether this menu item is enabled.
isEnabled() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is enabled.
isEnabled() - Method in class javax.swing.AbstractAction
Returns true if the action is enabled.
isEnabled() - Method in interface javax.swing.Action
Returns the enabled state of the Action.
isEnabled() - Method in interface javax.swing.ButtonModel
Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
isEnabled() - Method in class javax.swing.DefaultButtonModel
Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
isEnabled() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isEnabled() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if the object is enabled.
isEnabled() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
isEnabled() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isEnabled() - Method in class javax.swing.ToolTipManager
Returns true if this object is enabled.
isEnabled() - Method in class javax.xml.ws.WebServiceFeature
Returns true if this feature is enabled.
isEnabledAt(int) - Method in class javax.swing.JTabbedPane
Returns whether or not the tab at index is currently enabled.
isEndDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EndDocument.
isEndElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a EndElement.
isEndElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isEndElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to an end tag (otherwise false)
isEnqueued() - Method in class java.lang.ref.Reference
Tells whether or not this reference object has been enqueued, either by the program or by the garbage collector.
isEntityReference() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EntityReference.
isEnum() - Method in class java.lang.类
Returns true if and only if this class was declared as an enum in the source code.
isEnumConstant() - Method in class java.lang.reflect.字段
Returns true if this field represents an element of an enumerated type; returns false otherwise.
isEqual(byte[], byte[]) - Static method in class java.security.MessageDigest
Compares two digests for equality.
isEqual(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether two attribute sets are equal.
isEqual(AttributeSet) - Method in interface javax.swing.text.AttributeSet
Determines if the two attribute sets are equivalent.
isEqual(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Compares two attribute sets.
isEqual(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether two attribute sets are equal.
isEqual(AttributeSet) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether two attribute sets are equal.
isEqualNode(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isEqualNode(Node) - Method in interface org.w3c.dom.Node
Tests whether two nodes are equal.
isError() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an error condition.
isErrorAny() - Method in class java.awt.MediaTracker
Checks the error status of all of the images.
isErrorID(int) - Method in class java.awt.MediaTracker
Checks the error status of all of the images tracked by this media tracker with the specified identifier.
isEstablished() - Method in interface org.ietf.jgss.GSSContext
Used during context establishment to determine the state of the context.
isEventDispatchThread() - Static method in class javax.swing.SwingUtilities
Returns true if the current thread is an AWT event dispatching thread.
isExecutable(Path) - Static method in class java.nio.file.Files
Tests whether a file is executable.
isExpanded(TreePath) - Method in class javax.swing.JTree
Returns true if the node identified by the path is currently expanded,
isExpanded(int) - Method in class javax.swing.JTree
Returns true if the node at the specified display row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the value identified by row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache
Returns true if the value identified by row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache
Returns true if the value identified by path is currently expanded.
isExpandEntityReferences() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
isExpert() - Method in class java.beans.FeatureDescriptor
The "expert" flag is used to distinguish between those features that are intended for expert users from those that are intended for normal users.
isExplicitPolicyRequired() - Method in class java.security.cert.PKIXParameters
Checks if explicit policy is required.
isFair() - Method in class java.util.concurrent.locks.ReentrantLock
Returns true if this lock has fairness set true.
isFair() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Returns true if this lock has fairness set true.
isFair() - Method in class java.util.concurrent.Semaphore
Returns true if this semaphore has fairness set true.
isFeatureSupported(String) - Method in class javax.xml.crypto.dom.DOMStructure
isFeatureSupported(String) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Indicates whether a specified feature is supported.
isFeatureSupported(String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Indicates whether a specified feature is supported.
isFeatureSupported(String) - Method in interface javax.xml.crypto.XMLStructure
Indicates whether a specified feature is supported.
isField() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of field: either FIELD or ENUM_CONSTANT.
isFile() - Method in class java.io.File
Tests whether the file denoted by this abstract pathname is a normal file.
isFileHidingEnabled() - Method in class javax.swing.JFileChooser
Returns true if hidden files are not shown in the file chooser; otherwise, returns false.
isFileSelectionEnabled() - Method in class javax.swing.JFileChooser
Convenience call that determines if files are selectable based on the current file selection mode.
isFileSystem(File) - Method in class javax.swing.filechooser.FileSystemView
Checks if f represents a real directory or file as opposed to a special folder such as "Desktop".
isFileSystemRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Is dir the root of a tree in the file system, such as a drive or partition.
isFileTypeSupported(int) - Static method in class javax.sound.midi.MidiSystem
Indicates whether file writing support for the specified MIDI file type is provided by the system.
isFileTypeSupported(int, Sequence) - Static method in class javax.sound.midi.MidiSystem
Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
isFileTypeSupported(int) - Method in class javax.sound.midi.spi.MidiFileWriter
Indicates whether file writing support for the specified MIDI file type is provided by this file writer.
isFileTypeSupported(int, Sequence) - Method in class javax.sound.midi.spi.MidiFileWriter
Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
isFileTypeSupported(AudioFileFormat.Type) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether file writing support for the specified file type is provided by the system.
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
isFileTypeSupported(AudioFileFormat.Type) - Method in class javax.sound.sampled.spi.AudioFileWriter
Indicates whether file writing support for the specified file type is provided by this audio file writer.
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Method in class javax.sound.sampled.spi.AudioFileWriter
Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
isFinal(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the final modifier, false otherwise.
isFirst() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is on the first row of this ResultSet object.
isFixedRowHeight() - Method in class javax.swing.JTree
Returns true if the height of each display row is a fixed size.
isFixedRowHeight() - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the height of each row is a fixed size.
isFlavorJavaFileListType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a list of file objects.
isFlavorRemoteObjectType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a remote object.
isFlavorSerializedObjectType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a serialized object.
isFlavorTextType() - Method in class java.awt.datatransfer.DataFlavor
Returns whether this DataFlavor is a valid text flavor for this implementation of the Java platform.
isFloatable() - Method in class javax.swing.JToolBar
Gets the floatable property.
isFloating() - Method in class javax.swing.plaf.basic.BasicToolBarUI
isFloppyDrive(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for a floppy disk.
isFocusable() - Method in class java.awt.Component
Returns whether this Component can be focused.
isFocusableWindow() - Method in class java.awt.Window
Returns whether this Window can become the focused Window, that is, whether this Window or any of its subcomponents can become the focus owner.
isFocusCycleRoot(Container) - Method in class java.awt.Component
Returns whether the specified Container is the focus cycle root of this Component's focus traversal cycle.
isFocusCycleRoot(Container) - Method in class java.awt.Container
Returns whether the specified Container is the focus cycle root of this Container's focus traversal cycle.
isFocusCycleRoot() - Method in class java.awt.Container
Returns whether this Container is the root of a focus traversal cycle.
isFocusCycleRoot() - Method in class java.awt.Window
Always returns true because all Windows must be roots of a focus traversal cycle.
isFocusCycleRoot() - Method in class javax.swing.JInternalFrame
Always returns true because all JInternalFrames must be roots of a focus traversal cycle.
isFocused() - Method in class java.awt.Window
Returns whether this Window is focused.
isFocusManagerEnabled() - Static method in class javax.swing.FocusManager
Deprecated.
As of 1.4, replaced by KeyboardFocusManager.getDefaultFocusTraversalPolicy()
isFocusOwner() - Method in class java.awt.Component
Returns true if this Component is the focus owner.
isFocusPainted() - Method in class javax.swing.AbstractButton
Gets the paintFocus property.
isFocusTraversable() - Method in class java.awt.Component.AccessibleAWTComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class java.awt.Component
Deprecated.
As of 1.4, replaced by isFocusable().
isFocusTraversable() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in interface javax.accessibility.AccessibleComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isFocusTraversable() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
isFocusTraversable() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicArrowButton
Returns whether the arrow button should get the focus.
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Determines if the JComboBox is focus traversable.
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicComboPopup
Overridden to unconditionally return false.
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.ComboBoxUI
Determine whether or not the combo box itself is traversable
isFocusTraversable() - Method in class javax.swing.plaf.metal.MetalComboBoxButton
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the isFocusTraversable method on each UI handled by this object.
isFocusTraversable() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isFocusTraversalPolicyProvider() - Method in class java.awt.Container
Returns whether this container provides focus traversal policy.
isFocusTraversalPolicySet() - Method in class java.awt.Container
Returns whether the focus traversal policy has been explicitly set for this Container.
isFontSet() - Method in class java.awt.Component
Returns whether the font has been explicitly set for this Component.
isForegroundSet() - Method in class java.awt.Component
Returns whether the foreground color has been explicitly set for this Component.
isFormatLossless() - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the format that this writer outputs preserves pixel data bit-accurately.
isFormatSupported(AudioFormat) - Method in class javax.sound.sampled.DataLine.Info
Indicates whether this data line supports a particular audio format.
isFormattedOutput() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the formatted output flag.
isForwardable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is forwardable.
isForwardCheckingSupported() - Method in class java.security.cert.PKIXCertPathChecker
Indicates if forward checking is supported.
isForwarded() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket had been forwarded or was issued based on authentication involving a forwarded ticket-granting ticket.
isFragment() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the fragment flag.
isFrameStateSupported(int) - Method in class java.awt.Toolkit
Returns whether Toolkit supports this state for Frames.
isFreeStanding - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
isFullScreenRequired() - Method in class java.awt.BufferCapabilities
isFullScreenSupported() - Method in class java.awt.GraphicsDevice
Returns true if this GraphicsDevice supports full-screen exclusive mode.
isGapToken() - Method in class org.ietf.jgss.MessageProp
Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
isGeneral() - Method in class javax.swing.text.html.parser.Entity
Returns true if it is a general entity.
isGlobalScope() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element declaration is global.
isGraphicsConfigSupported(GraphicsConfiguration) - Method in class java.awt.GraphicsConfigTemplate
Returns a boolean indicating whether or not the specified GraphicsConfiguration can be used to create a drawing surface that supports the indicated features.
isGroupingUsed() - Method in class java.text.NumberFormat
Returns true if grouping is used in this format.
isGuiAvailable() - Static method in class java.beans.Beans
Determines whether beans can assume a GUI is available.
isHeadless() - Static method in class java.awt.GraphicsEnvironment
Tests whether or not a display, keyboard, and mouse can be supported in this environment.
isHeadlessInstance() - Method in class java.awt.GraphicsEnvironment
Returns whether or not a display, keyboard, and mouse can be supported in this graphics environment.
isHeldByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantLock
Queries if this lock is held by the current thread.
isHeldByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Queries if this write lock is held by the current thread.
isHeldExclusively() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Returns true if synchronization is held exclusively with respect to the current (calling) thread.
isHeldExclusively() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Returns true if synchronization is held exclusively with respect to the current (calling) thread.
isHidden() - Method in class java.beans.FeatureDescriptor
The "hidden" flag is used to identify features that are intended only for tool use, and which should not be exposed to humans.
isHidden() - Method in class java.io.File
Tests whether the file named by this abstract pathname is a hidden file.
isHidden() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the hidden attribute.
isHidden(Path) - Static method in class java.nio.file.Files
Tells whether or not a file is considered hidden.
isHidden(Path) - Method in class java.nio.file.spi.FileSystemProvider
Tells whether or not a file is considered hidden.
isHidden(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
isHiddenFile(File) - Method in class javax.swing.filechooser.FileSystemView
Returns whether a file is hidden or not.
isHighSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode high-surrogate code unit (also known as leading-surrogate code unit).
isHorizontal() - Method in class java.awt.ComponentOrientation
Are lines horizontal? This will return true for horizontal, left-to-right writing systems such as Roman.
isHTMLString(String) - Static method in class javax.swing.plaf.basic.BasicHTML
Check the given string to see if it should trigger the html rendering logic in a non-text component that supports html rendering.
isHttpOnly() - Method in class java.net.HttpCookie
Returns true if this cookie contains the HttpOnly attribute.
isIcon - Variable in class javax.swing.JInternalFrame
The frame has been iconified.
isIcon() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is currently iconified.
isIconifiable() - Method in class javax.swing.JInternalFrame
Gets the iconable property, which by default is false.
isIconOnly() - Method in class javax.swing.plaf.metal.MetalComboBoxButton
isId() - Method in interface org.w3c.dom.Attr
Returns whether this attribute is known to be of type ID (i.e.
isIdAttribute(int) - Method in class javax.xml.validation.TypeInfoProvider
Returns true if the specified attribute is determined to be ID.
isIdentifier(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not name is a syntactically valid identifier (simple name) or keyword in the latest source version.
isIdentifierIgnorable(char) - Static method in class java.lang.Character
Determines if the specified character should be regarded as an ignorable character in a Java identifier or a Unicode identifier.
isIdentifierIgnorable(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) should be regarded as an ignorable character in a Java identifier or a Unicode identifier.
isIdentity() - Method in class java.awt.font.TransformAttribute
Returns true if the wrapped transform is an identity transform.
isIdentity() - Method in class java.awt.geom.AffineTransform
Returns true if this AffineTransform is an identity transform.
isIgnorableWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Return true if this is ignorableWhiteSpace.
isIgnoringComments() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignores comments.
isIgnoringElementContentWhitespace() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
isIgnoringMetadata() - Method in class javax.imageio.ImageReader
Returns true if the current input source has been marked as allowing metadata to be ignored by passing true as the ignoreMetadata argument to the setInput method.
isImageAutoSize() - Method in class java.awt.TrayIcon
Returns the value of the auto-size property.
isImageTiled(int) - Method in class javax.imageio.ImageReader
Returns true if the image is organized into tiles, that is, equal-sized non-overlapping rectangles.
isInboundDone() - Method in class javax.net.ssl.SSLEngine
Returns whether SSLEngine.unwrap(ByteBuffer, ByteBuffer) will accept any more inbound data messages.
isInDefaultEventSet() - Method in class java.beans.EventSetDescriptor
Reports if an event set is in the "default" set.
isIndeterminate() - Method in class javax.swing.JProgressBar
Returns the value of the indeterminate property.
ISINDEX - Static variable in class javax.swing.text.html.HTML.Tag
isindex - Variable in class javax.swing.text.html.parser.DTD
isIndexSelected(int) - Method in class java.awt.List
Determines if the specified item in this scrolling list is selected.
isInfinite(double) - Static method in class java.lang.Double
Returns true if the specified number is infinitely large in magnitude, false otherwise.
isInfinite() - Method in class java.lang.Double
Returns true if this Double value is infinitely large in magnitude, false otherwise.
isInfinite(float) - Static method in class java.lang.Float
Returns true if the specified number is infinitely large in magnitude, false otherwise.
isInfinite() - Method in class java.lang.Float
Returns true if this Float value is infinitely large in magnitude, false otherwise.
isInherited() - Method in class javax.swing.text.html.CSS.Attribute
Indicates if the attribute should be inherited from the parent or not.
isInitial() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket was issued using the Kerberos AS-Exchange protocol, and not issued based on some ticket-granting ticket.
isInitialized() - Method in class javax.annotation.processing.AbstractProcessor
Returns true if this object has been initialized, false otherwise.
isInitiator() - Method in interface org.ietf.jgss.GSSContext
Determines if this is the context initiator.
isInNative() - Method in class java.lang.management.ThreadInfo
Tests if the thread associated with this ThreadInfo is executing native code via the Java Native Interface (JNI).
isInProgress() - Method in class javax.swing.undo.CompoundEdit
Returns true if this edit is in progress--that is, it has not received end.
isInputShutdown() - Method in class java.net.Socket
Returns whether the read-half of the socket connection is closed.
isInRelationService() - Method in class javax.management.relation.RelationSupport
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInRelationService() - Method in interface javax.management.relation.RelationSupportMBean
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInsert() - Method in class javax.swing.JList.DropLocation
Returns whether or not this location represents an insert location.
isInsertColumn() - Method in class javax.swing.JTable.DropLocation
Returns whether or not this location represents an insert of a column.
isInsertRow() - Method in class javax.swing.JTable.DropLocation
Returns whether or not this location represents an insert of a row.
isInstance(Object) - Method in class java.lang.类
Determines if the specified Object is assignment-compatible with the object represented by this 类.
isInstanceOf(Object, Class<?>) - Static method in class java.beans.Beans
Check if a bean can be viewed as a given target type.
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServer
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServerConnection
Returns true if the MBean specified is an instance of the specified class, false otherwise.
isInstanceOf(StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents an inheritance constraint on an MBean class.
isInstanceOf(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
isInState(T) - Method in class javax.swing.plaf.nimbus.State
Gets whether the specified JComponent is in the custom state represented by this class.
isInterface() - Method in class java.lang.类
Determines if the specified 类 object represents an interface type.
isInterface(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the 接口 modifier, false otherwise.
isInterface() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of interface: either 接口 or ANNOTATION_TYPE.
isInterrupted() - Method in class java.lang.Thread
Tests whether this thread has been interrupted.
isIPv4CompatibleAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an IPv4 compatible IPv6 address.
isIs() - Method in class javax.management.MBeanAttributeInfo
Indicates if this attribute has an "is" getter.
isIs() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
isISOControl(char) - Static method in class java.lang.Character
Determines if the specified character is an ISO control character.
isISOControl(int) - Static method in class java.lang.Character
Determines if the referenced character (Unicode code point) is an ISO control character.
isItalic() - Method in class java.awt.Font
Indicates whether or not this Font object's style is ITALIC.
isItalic(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the italic attribute is set.
isJavaIdentifierPart(char) - Static method in class java.lang.Character
Determines if the specified character may be part of a Java identifier as other than the first character.
isJavaIdentifierPart(int) - Static method in class java.lang.Character
Determines if the character (Unicode code point) may be part of a Java identifier as other than the first character.
isJavaIdentifierStart(char) - Static method in class java.lang.Character
Determines if the specified character is permissible as the first character in a Java identifier.
isJavaIdentifierStart(int) - Static method in class java.lang.Character
Determines if the character (Unicode code point) is permissible as the first character in a Java identifier.
isJavaLetter(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isJavaIdentifierStart(char).
isJavaLetterOrDigit(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isJavaIdentifierPart(char).
isJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Returns whether the specified String is an encoded Java MIME type.
isKeyBindingActive() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
isKeyBindingRegistered() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
isKeyDown - Variable in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
Set to true while keyPressed is active.
isKeyEntry(String) - Method in class java.security.KeyStore
Returns true if the entry identified by the given alias was created by a call to setKeyEntry, or created by a call to setEntry with a PrivateKeyEntry or a SecretKeyEntry.
isKeyword(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not s is a keyword or literal in the latest source version.
isLargeModel() - Method in class javax.swing.JTree
Returns true if the tree is configured for a large model.
isLargeModel() - Method in class javax.swing.plaf.basic.BasicTreeUI
isLast() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is on the last row of this ResultSet object.
isLayoutValid() - Method in class javax.swing.text.AsyncBoxView.ChildState
Has the child view been laid out.
isLayoutValid(int) - Method in class javax.swing.text.BoxView
Determines if the layout is valid along the given axis.
isLeadAnchorNotificationEnabled() - Method in class javax.swing.DefaultListSelectionModel
Returns the value of the leadAnchorNotificationEnabled flag.
isLeadingEdge() - Method in class java.awt.font.TextHitInfo
Returns true if the leading edge of the character was hit.
isLeaf() - Method in class javax.swing.JTree.DynamicUtilTreeNode
Returns true if this node allows children.
isLeaf(int) - Method in class javax.swing.plaf.basic.BasicTreeUI
isLeaf() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether the element is a leaf.
isLeaf() - Method in class javax.swing.text.AbstractDocument.BranchElement
Checks whether the element is a leaf.
isLeaf() - Method in class javax.swing.text.AbstractDocument.LeafElement
Checks whether the element is a leaf.
isLeaf() - Method in interface javax.swing.text.Element
Is this element a leaf element? An element that may have children, even if it currently has no children, would return false.
isLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if this node has no children.
isLeaf(Object) - Method in class javax.swing.tree.DefaultTreeModel
Returns whether the specified node is a leaf node.
isLeaf(Object) - Method in interface javax.swing.tree.TreeModel
Returns true if node is a leaf.
isLeaf() - Method in interface javax.swing.tree.TreeNode
Returns true if the receiver is a leaf.
isLeapYear(int) - Method in class java.util.GregorianCalendar
Determines if the given year is a leap year.
isLeftMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the left mouse button.
isLeftToRight() - Method in class java.awt.ComponentOrientation
HorizontalLines: Do items run left-to-right?
Vertical Lines: Do lines run left-to-right?
This will return true for horizontal, left-to-right writing systems such as Roman.
isLeftToRight() - Method in class java.awt.font.TextLayout
Returns true if this TextLayout has a left-to-right base direction or false if it has a right-to-left base direction.
isLeftToRight() - Method in class java.text.Bidi
Return true if the line is all left-to-right text and the base direction is left-to-right.
isLegalReplacement(byte[]) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not the given byte array is a legal replacement value for this encoder.
isLenient() - Method in class java.text.DateFormat
Tell whether date/time parsing is to be lenient.
isLenient() - Method in class java.util.Calendar
Tells whether date/time interpretation is to be lenient.
isLetter(char) - Static method in class java.lang.Character
Determines if the specified character is a letter.
isLetter(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a letter.
isLetterOrDigit(char) - Static method in class java.lang.Character
Determines if the specified character is a letter or digit.
isLetterOrDigit(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a letter or digit.
isLigature() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a ligature glyph.
isLight - Variable in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
isLightweight() - Method in class java.awt.Component
A lightweight component doesn't have a native toolkit peer.
isLightweightComponent(Component) - Static method in class javax.swing.JComponent
Returns true if this component is lightweight, that is, if it doesn't have a native window system peer.
isLightWeightPopupEnabled() - Method in class javax.swing.JComboBox
Gets the value of the lightWeightPopupEnabled property.
isLightWeightPopupEnabled() - Method in class javax.swing.JPopupMenu
Gets the lightWeightPopupEnabled property.
isLightWeightPopupEnabled() - Method in class javax.swing.ToolTipManager
Returns true if lightweight (all-Java) Tooltips are in use, or false if heavyweight (native peer) Tooltips are being used.
isLineEmpty() - Method in class javax.swing.text.AbstractWriter
Returns true if the current line should be considered empty.
isLineSupported(Line.Info) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether the system supports any lines that match the specified Line.Info object.
isLineSupported(Line.Info) - Method in interface javax.sound.sampled.Mixer
Indicates whether the mixer supports a line (or lines) that match the specified Line.Info object.
isLinkLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is an link local address.
isLinkLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an link local address.
isLinkLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is an link local address.
isLoaded() - Method in class java.nio.MappedByteBuffer
Tells whether or not this buffer's content is resident in physical memory.
isLocal - Variable in class java.awt.dnd.DropTargetContext.TransferableProxy
A boolean indicating if the encapsulated Transferable object represents the result of local drag-n-drop operation (within the same JVM).
isLocal(Stub) - Static method in class javax.rmi.CORBA.Util
The isLocal method has the same semantics as the ObjectImpl._is_local method, except that it can throw a RemoteException.
isLocal(Stub) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.isLocal(javax.rmi.CORBA.Stub).
isLocalClass() - Method in class java.lang.类
Returns true if and only if the underlying class is a local class.
isLocallyDefined(KeyStroke) - Method in interface javax.swing.text.Keymap
Determines if the given key sequence is locally defined.
isLocalTransfer() - Method in class java.awt.dnd.DropTargetDropEvent
This method returns an int indicating if the source is in the same JVM as the target.
isLocationByPlatform() - Method in class java.awt.Window
Returns true if this Window will appear at the default location for the native windowing system the next time this Window is made visible.
isLocationInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.
isLocationInExpandControl(int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTreeUI
isLocked() - Method in class java.util.concurrent.locks.ReentrantLock
Queries if this lock is held by any thread.
isLoggable(LogRecord) - Method in interface java.util.logging.Filter
Check if a given log record should be published.
isLoggable(LogRecord) - Method in class java.util.logging.Handler
Check if this Handler would actually log a given LogRecord.
isLoggable(Level) - Method in class java.util.logging.Logger
Check if a message of the given level would actually be logged by this logger.
isLoggable(LogRecord) - Method in class java.util.logging.MemoryHandler
Check if this Handler would actually log a given LogRecord into its internal buffer.
isLoggable(LogRecord) - Method in class java.util.logging.StreamHandler
Check if this Handler would actually log a given LogRecord.
isLongerThan(Duration) - Method in class javax.xml.datatype.Duration
Checks if this duration object is strictly longer than another Duration object.
isLoopback() - Method in class java.net.NetworkInterface
Returns whether a network interface is a loopback interface.
isLoopbackAddress() - Method in class java.net.Inet4Address
isLoopbackAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is a loopback address.
isLoopbackAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is a loopback address.
isLowerCase(char) - Static method in class java.lang.Character
Determines if the specified character is a lowercase character.
isLowerCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a lowercase character.
isLowSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode low-surrogate code unit (also known as trailing-surrogate code unit).
isMalformed() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes a malformed-input error.
isManagingFocus() - Method in class javax.swing.JComponent
Deprecated.
As of 1.4, replaced by Component.setFocusTraversalKeys(int, Set) and Container.setFocusCycleRoot(boolean).
ISMAP - Static variable in class javax.swing.text.html.HTML.Attribute
isMarked() - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Returns the current value of the mark.
isMaximizable() - Method in class javax.swing.JInternalFrame
Gets the value of the maximizable property.
isMaximum - Variable in class javax.swing.JInternalFrame
The frame has been expanded to its maximum size.
isMaximum() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is currently maximized.
isMaximumSizeSet() - Method in class java.awt.Component
Returns true if the maximum size has been set to a non-null value otherwise returns false.
isMCGlobal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has global scope.
isMCGlobal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has global scope.
isMCGlobal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has global scope.
isMCLinkLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has link scope.
isMCLinkLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has link scope.
isMCLinkLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has link scope.
isMCNodeLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has node scope.
isMCNodeLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has node scope.
isMCNodeLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has node scope.
isMCOrgLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has organization scope.
isMCOrgLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has organization scope.
isMCOrgLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has organization scope.
isMCSiteLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has site scope.
isMCSiteLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has site scope.
isMCSiteLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has site scope.
isMember(Principal) - Method in interface java.security.acl.Group
Returns true if the passed principal is a member of the group.
isMemberClass() - Method in class java.lang.类
Returns true if and only if the underlying class is a member class.
isMenuComponent(Component) - Method in class javax.swing.JMenu
Returns true if the specified component exists in the submenu hierarchy.
isMetaDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Meta modifier is down on this event.
isMiddleMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the middle mouse button.
isMimeTypeEqual(String) - Method in class java.awt.datatransfer.DataFlavor
Returns whether the string representation of the MIME type passed in is equivalent to the MIME type of this DataFlavor.
isMimeTypeEqual(DataFlavor) - Method in class java.awt.datatransfer.DataFlavor
Compares the mimeType of two DataFlavor objects.
isMimeTypeEqual(String) - Method in class javax.activation.ActivationDataFlavor
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
isMimeTypeSerializedObject() - Method in class java.awt.datatransfer.DataFlavor
Does the DataFlavor represent a serialized object?
isMinimumSizeDirty - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
isMinimumSizeSet() - Method in class java.awt.Component
Returns whether or not setMinimumSize has been invoked with a non-null value.
isMirrored(char) - Static method in class java.lang.Character
Determines whether the character is mirrored according to the Unicode specification.
isMirrored(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is mirrored according to the Unicode specification.
isMixed() - Method in class java.text.Bidi
Return true if the line is not left-to-right or right-to-left.
isMixerSupported(Mixer.Info) - Method in class javax.sound.sampled.spi.MixerProvider
Indicates whether the mixer provider supports the mixer represented by the specified mixer info object.
isMN() - Method in interface org.ietf.jgss.GSSName
Tests if this name object represents a Mechanism Name (MN).
isModal() - Method in class java.awt.Dialog
Indicates whether the dialog is modal.
isModalExclusionTypeSupported(Dialog.ModalExclusionType) - Method in class java.awt.Toolkit
Returns whether the given modal exclusion type is supported by this toolkit.
isModalityTypeSupported(Dialog.ModalityType) - Method in class java.awt.Toolkit
Returns whether the given modality type is supported by this toolkit.
isModifiableClass(Class<?>) - Method in interface java.lang.instrument.Instrumentation
Determines whether a class is modifiable by retransformation or redefinition.
isMouseOver() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Returns whether or not the mouse is currently over the divider
isMTOMEnabled() - Method in interface javax.xml.ws.soap.SOAPBinding
Returns true if the use of MTOM is enabled.
isMultiBufferAvailable() - Method in class java.awt.BufferCapabilities
isMulticastAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is an IP multicast address.
isMulticastAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an IP multicast address.
isMulticastAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is an IP multicast address.
isMultipleMode() - Method in class java.awt.FileDialog
Returns whether the file dialog allows the multiple file selection.
isMultipleMode() - Method in class java.awt.List
Determines whether this list allows multiple selections.
isMultiSelectEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true signifies a mouse event on the node should select from the anchor point.
isMultiSelectionEnabled() - Method in class javax.swing.JFileChooser
Returns true if multiple files can be selected.
isMXBean() - Method in class javax.management.MBeanServerInvocationHandler
If true, the proxy is for an MXBean, and appropriate mappings are applied to method parameters and return values.
isMXBeanInterface(Class<?>) - Static method in class javax.management.JMX
Test whether an interface is an MXBean interface.
isName(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not name is a syntactically valid qualified name in the latest source version.
isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools.ForwardingJavaFileObject
isNameCompatible(String, JavaFileObject.Kind) - Method in interface javax.tools.JavaFileObject
Checks if this file object is compatible with the specified simple name and kind.
isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools.SimpleJavaFileObject
This implementation compares the path of its URI to the given simple name.
isNamespace() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a Namespace.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNamespaceDeclUris() - Method in class org.xml.sax.helpers.NamespaceSupport
Returns true if namespace declaration attributes are placed into a namespace.
isNaN(double) - Static method in class java.lang.Double
Returns true if the specified number is a Not-a-Number (NaN) value, false otherwise.
isNaN() - Method in class java.lang.Double
Returns true if this Double value is a Not-a-Number (NaN), false otherwise.
isNaN(float) - Static method in class java.lang.Float
Returns true if the specified number is a Not-a-Number (NaN) value, false otherwise.
isNaN() - Method in class java.lang.Float
Returns true if this Float value is a Not-a-Number (NaN), false otherwise.
isNative(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the native modifier, false otherwise.
isNativeLookAndFeel() - Method in class javax.swing.LookAndFeel
If the underlying platform has a "native" look and feel, and this is an implementation of it, return true.
isNativeLookAndFeel() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Returns false; MetalLookAndFeel is not a native look and feel.
isNativeLookAndFeel() - Method in class javax.swing.plaf.multi.MultiLookAndFeel
Returns false; this look and feel is not native to any platform.
isNativeLookAndFeel() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Returns false, SynthLookAndFeel is not a native look and feel.
isNativeMethod() - Method in class java.lang.StackTraceElement
Returns true if the method containing the execution point represented by this stack trace element is a native method.
isNativeMethodPrefixSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether the current JVM configuration supports setting a native method prefix.
isNavigationKey(int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Returns whether or not the supplied keyCode maps to a key that is used for navigation.
isNegative() - Method in interface java.security.acl.AclEntry
Returns true if this is a negative ACL entry (one denying the associated principal the set of permissions in the entry), false otherwise.
isNested() - Method in enum javax.lang.model.element.NestingKind
Does this constant correspond to a nested type element? A nested type element is any that is not top-level.
isNil() - Method in class javax.xml.bind.JAXBElement
Returns true iff this element instance content model is nil.
isNodeAncestor(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
isNodeChild(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if aNode is a child of this node.
isNodeDescendant(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
isNodeRelated(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if and only if aNode is in the same tree as this node.
isNodeSibling(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is a sibling of (has the same parent as) this node.
isNormalized(CharSequence, Normalizer.Form) - Static method in class java.text.Normalizer
Determines if the given sequence of char values is normalized.
isNotificationEnabled(Notification) - Method in class javax.management.AttributeChangeNotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in interface javax.management.NotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.NotificationFilterSupport
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.relation.MBeanServerNotificationFilter
Invoked before sending the specified notification to the listener.
isNotifyOnEDT() - Method in class javax.swing.event.SwingPropertyChangeSupport
Returns notifyOnEDT property.
isNullable(int) - Method in interface java.sql.ParameterMetaData
Retrieves whether null values are allowed in the designated parameter.
isNullable(int) - Method in interface java.sql.ResultSetMetaData
Indicates the nullability of values in the designated column.
isNullable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Retrieves a constant indicating whether it is possible to store a NULL value in the designated column.
ISO_2A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS 2A0, 1189 x 1682 mm.
ISO_4A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS 4A0, 1682 x 2378 mm.
ISO_A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A0, 841 x 1189 mm.
ISO_A0 - Static variable in class javax.print.attribute.standard.MediaSizeName
A0 size.
ISO_A1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A1, 594 x 841 mm.
ISO_A1 - Static variable in class javax.print.attribute.standard.MediaSizeName
A1 size.
ISO_A10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A10, 26 x 37 mm.
ISO_A10 - Static variable in class javax.print.attribute.standard.MediaSizeName
A10 size.
ISO_A2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A2, 420 x 594 mm.
ISO_A2 - Static variable in class javax.print.attribute.standard.MediaSizeName
A2 size.
ISO_A3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A3, 297 x 420 mm.
ISO_A3 - Static variable in class javax.print.attribute.standard.MediaSizeName
A3 size.
ISO_A4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A4, 210 x 297 mm.
ISO_A4 - Static variable in class javax.print.attribute.standard.MediaSizeName
A4 size.
ISO_A4_TRANSPARENT - Static variable in class javax.print.attribute.standard.MediaName
A4 transparency.
ISO_A4_WHITE - Static variable in class javax.print.attribute.standard.MediaName
white A4 paper.
ISO_A5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A5, 148 x 210 mm.
ISO_A5 - Static variable in class javax.print.attribute.standard.MediaSizeName
A5 size.
ISO_A6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A6, 105 x 148 mm.
ISO_A6 - Static variable in class javax.print.attribute.standard.MediaSizeName
A6 size.
ISO_A7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A7, 74 x 105 mm.
ISO_A7 - Static variable in class javax.print.attribute.standard.MediaSizeName
A7 size.
ISO_A8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A8, 52 x 74 mm.
ISO_A8 - Static variable in class javax.print.attribute.standard.MediaSizeName
A8 size.
ISO_A9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN & JIS A9, 37 x 52 mm.
ISO_A9 - Static variable in class javax.print.attribute.standard.MediaSizeName
A9 size.
ISO_B0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B0, 1000 x 1414 mm.
ISO_B0 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B0 size.
ISO_B1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B1, 707 x 1000 mm.
ISO_B1 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B1 size.
ISO_B10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B10, 31 x 44 mm.
ISO_B10 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B10 size.
ISO_B2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B2, 500 x 707 mm.
ISO_B2 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B2 size.
ISO_B3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B3, 353 x 500 mm.
ISO_B3 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B3 size.
ISO_B4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B4, 250 x 353 mm.
ISO_B4 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B4 size.
ISO_B4_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B4.
ISO_B5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B5, 176 x 250 mm.
ISO_B5 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B5 size.
ISO_B5_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B5.
ISO_B6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B6, 125 x 176 mm.
ISO_B6 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B6 size.
ISO_B7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B7, 88 x 125 mm.
ISO_B7 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B7 size.
ISO_B8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B8, 62 x 88 mm.
ISO_B8 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B8 size.
ISO_B9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B9, 44 x 62 mm.
ISO_B9 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B9 size.
ISO_C0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C0, 917 x 1297 mm.
ISO_C0 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C0 size.
ISO_C0_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C0.
ISO_C1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C1, 648 x 917 mm.
ISO_C1 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C1 size.
ISO_C10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C10, 28 x 40 mm.
ISO_C10_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C10.
ISO_C1_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C1.
ISO_C2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C2, 458 x 648 mm.
ISO_C2 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C2 size.
ISO_C2_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C2.
ISO_C3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C3, 324 x 458 mm.
ISO_C3 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C3 size.
ISO_C3_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C3.
ISO_C4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C4, 229 x 324 mm.
ISO_C4 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C4 size.
ISO_C4_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C4.
ISO_C5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C5, 162 x 229 mm.
ISO_C5 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C5 size.
ISO_C5_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C5.
ISO_C6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C6, 114 x 162 mm.
ISO_C6 - Static variable in class javax.print.attribute.standard.MediaSizeName
letter size.
ISO_C6_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C6.
ISO_C7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C7, 81 x 114 mm.
ISO_C7_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C7.
ISO_C8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C8, 57 x 81 mm.
ISO_C8_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C8.
ISO_C9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C9, 40 x 57 mm.
ISO_C9_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C9.
ISO_DESIGNATED_LONG - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO Designated Long, 110 x 220 mm.
ISO_DESIGNATED_LONG - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO designated long size .
ISO_DESIGNATED_LONG_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_DESIGNATED_LONG.
isObjectModelSupported(String) - Method in class javax.xml.xpath.XPathFactory
Is specified object model supported by this XPathFactory?
isObjectMonitorUsageSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports monitoring of object monitor usage.
isOldToken() - Method in class org.ietf.jgss.MessageProp
Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
isOneTouchExpandable() - Method in class javax.swing.JSplitPane
Gets the oneTouchExpandable property.
isOnKeyRelease() - Method in class java.awt.AWTKeyStroke
Returns whether this AWTKeyStroke represents a key release.
isOpaque() - Method in class java.awt.Component
Returns true if this component is completely opaque, returns false by default.
isOpaque() - Method in class java.awt.Window
Indicates if the window is currently opaque.
isOpaque() - Method in class java.net.URI
Tells whether or not this URI is opaque.
isOpaque() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
isOpaque() - Method in class javax.swing.JComponent
Returns true if this component is completely opaque.
isOpaque() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
isOpaque(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle
isOpaque(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle
Returns true if the region is opaque.
isOpaque() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
isOpen() - Method in interface java.nio.channels.Channel
Tells whether or not this channel is open.
isOpen() - Method in class java.nio.channels.Selector
Tells whether or not this selector is open.
isOpen() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
isOpen() - Method in class java.nio.channels.spi.AbstractSelector
isOpen() - Method in class java.nio.file.FileSystem
Tells whether or not this file system is open.
isOpen() - Method in interface javax.sound.midi.MidiDevice
Reports whether the device is open.
isOpen() - Method in interface javax.sound.sampled.Line
Indicates whether the line is open, meaning that it has reserved system resources and is operational, although it might not currently be playing or capturing sound.
isOptimizedDrawingEnabled() - Method in class javax.swing.JComponent
Returns true if this component tiles its children -- that is, if it can guarantee that the children will not overlap.
isOptimizedDrawingEnabled() - Method in class javax.swing.JLayer
The JLayer overrides the default implementation of this method (in JComponent) to return false.
isOptimizedDrawingEnabled() - Method in class javax.swing.JLayeredPane
Returns false if components in the pane can overlap, which makes optimized drawing impossible.
isOptimizedDrawingEnabled() - Method in class javax.swing.JRootPane
The glassPane and contentPane have the same bounds, which means JRootPane does not tiles its children and this should return false.
isOptimizedDrawingEnabled() - Method in class javax.swing.JViewport
The JViewport overrides the default implementation of this method (in JComponent) to return false.
isOrdered() - Method in interface javax.naming.directory.Attribute
Determines whether this attribute's values are ordered.
isOrdered() - Method in class javax.naming.directory.BasicAttribute
isOther() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is something other than a regular file, directory, or symbolic link.
isOutboundDone() - Method in class javax.net.ssl.SSLEngine
Returns whether SSLEngine.wrap(ByteBuffer, ByteBuffer) will produce any more outbound data messages.
isOutputLocation() - Method in interface javax.tools.JavaFileManager.Location
Determines if this is an output location.
isOutputLocation() - Method in enum javax.tools.StandardLocation
isOutputShutdown() - Method in class java.net.Socket
Returns whether the write-half of the socket connection is closed.
isOverflow() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an overflow condition.
isOwner(Principal) - Method in interface java.security.acl.Owner
Returns true if the given principal is an owner of the ACL.
isOwnReader(ImageReader) - Method in class javax.imageio.spi.ImageReaderSpi
Returns true if the ImageReader object passed in is an instance of the ImageReader associated with this service provider.
isOwnWriter(ImageWriter) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter object passed in is an instance of the ImageWriter associated with this service provider.
isPageFlipping() - Method in class java.awt.BufferCapabilities
isPaintable() - Method in interface java.beans.PropertyEditor
Determines whether this property editor is paintable.
isPaintable() - Method in class java.beans.PropertyEditorSupport
Determines whether the class will honor the paintValue method.
isPaintingForPrint() - Method in class javax.swing.JComponent
Returns true if the current painting operation on this component is part of a print operation.
isPaintingOrigin() - Method in class javax.swing.JComponent
Returns true if a paint triggered on a child component should cause painting to originate from this Component, or one of its ancestors.
isPaintingOrigin() - Method in class javax.swing.JLayer
Always returns true to cause painting to originate from JLayer, or one of its ancestors.
isPaintingOrigin() - Method in class javax.swing.JViewport
Returns true if scroll mode is a BACKINGSTORE_SCROLL_MODE to cause painting to originate from JViewport, or one of its ancestors.
isPaintingTile() - Method in class javax.swing.JComponent
Returns true if the component is currently painting a tile.
isPalette - Variable in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
isParameter() - Method in class javax.swing.text.html.parser.Entity
Returns true if it is a parameter entity.
isParent(File, File) - Method in class javax.swing.filechooser.FileSystemView
On Windows, a file can appear in multiple folders, other than its parent directory in the filesystem.
isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec.DESedeKeySpec
Checks if the given DES-EDE key, starting at offset inclusive, is parity-adjusted.
isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec.DESKeySpec
Checks if the given DES key material, starting at offset inclusive, is parity-adjusted.
isParseBigDecimal() - Method in class java.text.DecimalFormat
Returns whether the DecimalFormat.parse(java.lang.String, java.text.ParsePosition) method returns BigDecimal.
isParseIntegerOnly() - Method in class java.text.NumberFormat
Returns true if this format will parse numbers as integers only.
isPartialReturn() - Method in class javax.swing.text.Segment
Flag to indicate that partial returns are valid.
isPathEditable(TreePath) - Method in class javax.swing.JTree
Returns isEditable.
isPathSelected(TreePath) - Method in class javax.swing.JTree
Returns true if the item identified by the path is currently selected.
isPathSelected(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the path, path, is in the current selection.
isPathSelected(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the path, path, is in the current selection.
isPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern.
isPeriodic() - Method in interface java.util.concurrent.RunnableScheduledFuture
Returns true if this is a periodic task.
isPlain() - Method in class java.awt.Font
Indicates whether or not this Font object's style is PLAIN.
isPointToPoint() - Method in class java.net.NetworkInterface
Returns whether a network interface is a point to point interface.
isPolicyMappingInhibited() - Method in class java.security.cert.PKIXParameters
Checks if policy mapping is inhibited.
isPolygonal() - Method in class java.awt.geom.Area
Tests whether this Area consists entirely of straight edged polygonal geometry.
isPoolable() - Method in interface java.sql.Statement
Returns a value indicating whether the Statement is poolable or not.
isPopupMenuVisible() - Method in class javax.swing.JMenu
Returns true if the menu's popup window is visible.
isPopupTrigger() - Method in class java.awt.event.MouseEvent
Returns whether or not this mouse event is the popup menu trigger event for the platform.
isPopupTrigger(MouseEvent) - Method in class javax.swing.JPopupMenu
Returns true if the MouseEvent is considered a popup trigger by the JPopupMenu's currently installed UI.
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the isPopupTrigger method on each UI handled by this object.
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.PopupMenuUI
isPopupVisible() - Method in class javax.swing.JComboBox
Determines the visibility of the popup.
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Tells if the popup is visible or not.
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.ComboBoxUI
Determine the visibility of the popup
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the isPopupVisible method on each UI handled by this object.
isPostdated() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is post-dated.
isPreferred() - Method in class java.beans.FeatureDescriptor
The "preferred" flag is used to identify features that are particularly important for presenting to humans.
isPreferredSizeSet() - Method in class java.awt.Component
Returns true if the preferred size has been set to a non-null value otherwise returns false.
isPreformatted() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag is pre-formatted, which is true if the tag is either PRE or TEXTAREA.
isPreformatted() - Method in class javax.swing.text.html.parser.TagElement
isPressed() - Method in interface javax.swing.ButtonModel
Indicates if the button is pressed.
isPressed() - Method in class javax.swing.DefaultButtonModel
Indicates if the button is pressed.
isPrimitive() - Method in class java.io.ObjectStreamField
Return true if this field has a primitive type.
isPrimitive() - Method in class java.lang.类
Determines if the specified 类 object represents a primitive type.
isPrimitive() - Method in enum javax.lang.model.type.TypeKind
Returns true if this kind corresponds to a primitive type and false otherwise.
isPrimitiveArray() - Method in class javax.management.openmbean.ArrayType
Returns true if the open data values this open type describes are primitive arrays, false otherwise.
isPrivate(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the private modifier, false otherwise.
isProbablePrime(int) - Method in class java.math.BigInteger
Returns true if this BigInteger is probably prime, false if it's definitely composite.
isProcessingInstruction() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a ProcessingInstruction.
isPropagated() - Method in class java.beans.beancontext.BeanContextEvent
Reports whether or not this event is propagated from some other BeanContext.
isPropertyListPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the key property list.
isPropertyPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the key properties.
isPropertySupported(String) - Method in class javax.xml.stream.XMLInputFactory
Query the set of properties that this factory supports.
isPropertySupported(String) - Method in class javax.xml.stream.XMLOutputFactory
Query the set of properties that this factory supports.
isPropertyValuePattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the value part of at least one of the key properties.
isPropertyValuePattern(String) - Method in class javax.management.ObjectName
Checks whether the value associated with a key in a key property is a pattern.
isProtected(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the protected modifier, false otherwise.
isProtReady() - Method in interface org.ietf.jgss.GSSContext
Determines if the context is ready for per message operations to be used over it.
isProxiable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is proxiable.
isProxy() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is a proxy-ticket.
isProxyClass(Class<?>) - Static method in class java.lang.reflect.Proxy
Returns true if and only if the specified class was dynamically generated to be a proxy class using the getProxyClass method or the newProxyInstance method.
isPublic(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the public modifier, false otherwise.
isPublished() - Method in class javax.xml.ws.Endpoint
Returns true if the endpoint is in the published state.
isQueued(Thread) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Returns true if the given thread is currently queued.
isQueued(Thread) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Returns true if the given thread is currently queued.
isQuiescent() - Method in class java.util.concurrent.ForkJoinPool
Returns true if all worker threads are currently idle.
isRandomAccessEasy(int) - Method in class javax.imageio.ImageReader
Returns true if the storage format of the given image places no inherent impediment on random access to pixels.
isReachable(int) - Method in class java.net.InetAddress
Test whether that address is reachable.
isReachable(NetworkInterface, int, int) - Method in class java.net.InetAddress
Test whether that address is reachable.
isReadable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready for reading.
isReadable(Path) - Static method in class java.nio.file.Files
Tests whether a file is readable.
isReadable() - Method in class javax.management.MBeanAttributeInfo
Whether the value of the attribute can be read.
isReadable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
isReadable() - Method in class javax.management.relation.RoleInfo
Returns read access mode for the role (true if it is readable).
isReadOnly() - Method in class java.nio.Buffer
Tells whether or not this buffer is read-only.
isReadOnly() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the read-only attribute.
isReadOnly() - Method in class java.nio.file.FileStore
Tells whether this file store is read-only.
isReadOnly() - Method in class java.nio.file.FileSystem
Tells whether or not this file system allows only read-only access to its file stores.
isReadOnly() - Method in class java.security.PermissionCollection
Returns true if this PermissionCollection object is marked as readonly.
isReadOnly() - Method in interface java.sql.Connection
Retrieves whether this Connection object is in read-only mode.
isReadOnly() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database is in read-only mode.
isReadOnly(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is definitely not writable.
isReadOnly() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if this object does not support the mergeTree, setFromTree, and reset methods.
isReadOnly() - Method in class javax.security.auth.Subject
Query whether this Subject is read-only.
isReadOnly() - Method in class javax.sql.rowset.BaseRowSet
Returns a boolean indicating whether this RowSet object is read-only.
isReadOnly() - Method in interface javax.sql.RowSet
Retrieves whether this RowSet object is read-only.
isReadOnly(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether the designated column is definitely not writable, thus readonly.
isRecording() - Method in interface javax.sound.midi.Sequencer
Indicates whether the Sequencer is currently recording.
isRectangleContainingRectangle(Rectangle, Rectangle) - Static method in class javax.swing.SwingUtilities
Return true if a contains b
isRectangular() - Method in class java.awt.geom.Area
Tests whether this Area is rectangular in shape.
isRedefineClassesSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether or not the current JVM configuration supports redefinition of classes.
isRegistered() - Method in class java.nio.channels.SelectableChannel
Tells whether or not this channel is currently registered with any selectors.
isRegistered() - Method in class java.nio.channels.spi.AbstractSelectableChannel
isRegistered() - Method in class java.nio.charset.Charset
Tells whether or not this charset is registered in the IANA Charset Registry.
isRegistered(ObjectName) - Method in interface javax.management.MBeanServer
isRegistered(ObjectName) - Method in interface javax.management.MBeanServerConnection
Checks whether an MBean, identified by its object name, is already registered with the MBean server.
isRegistered(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.isRegistered(ObjectName).
isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
isRegularFile() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a regular file with opaque content.
isRegularFile(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file is a regular file with opaque content.
isRelation(ObjectName) - Method in class javax.management.relation.RelationService
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelationMBean(String) - Method in class javax.management.relation.RelationService
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRelationMBean(String) - Method in interface javax.management.relation.RelationServiceMBean
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRelative() - Method in class javax.naming.NameClassPair
Determines whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
isReleasable() - Method in interface java.util.concurrent.ForkJoinPool.ManagedBlocker
Returns true if blocking is unnecessary.
isRemoved() - Method in class java.util.prefs.AbstractPreferences
Returns true iff this node (or an ancestor) has been removed with the AbstractPreferences.removeNode() method.
isRenewable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is renewable.
isRepeats() - Method in class javax.swing.Timer
Returns true (the default) if the Timer will send an action event to its listeners multiple times.
isReplacing - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
isRepresentationClassByteBuffer() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.nio.ByteBuffer or a subclass thereof.
isRepresentationClassCharBuffer() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.nio.CharBuffer or a subclass thereof.
isRepresentationClassInputStream() - Method in class java.awt.datatransfer.DataFlavor
Does the DataFlavor represent a java.io.InputStream?
isRepresentationClassReader() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.io.Reader or a subclass thereof.
isRepresentationClassRemote() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the representation class is Remote.
isRepresentationClassSerializable() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the representation class can be serialized.
isRequestFocusEnabled() - Method in class javax.swing.JComponent
Returns true if this JComponent should get focus; otherwise returns false.
isRequired() - Method in class javax.xml.ws.soap.AddressingFeature
If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
isResizable() - Method in class java.awt.Dialog
Indicates whether this dialog is resizable by the user.
isResizable() - Method in class java.awt.Frame
Indicates whether this frame is resizable by the user.
isResizable() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame can be resized by some user action.
isResizable - Variable in class javax.swing.table.TableColumn
If true, the user is allowed to resize the column; the default is true.
isRetransformClassesSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether or not the current JVM configuration supports retransformation of classes.
isRevocationEnabled() - Method in class java.security.cert.PKIXParameters
Checks the RevocationEnabled flag.
isRevoked(Certificate) - Method in class java.security.cert.CRL
Checks whether the given certificate is on this CRL.
isRightMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the right mouse button.
isRightToLeft() - Method in class java.text.Bidi
Return true if the line is all right-to-left text, and the base direction is right-to-left.
isRoleStatus(int) - Static method in class javax.management.relation.RoleStatus
Returns true if given value corresponds to a known role status, false otherwise.
isRollover() - Method in interface javax.swing.ButtonModel
Indicates that the mouse is over the button.
isRollover() - Method in class javax.swing.DefaultButtonModel
Indicates that the mouse is over the button.
isRollover() - Method in class javax.swing.JToolBar
Returns the rollover state.
isRolloverBorders() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Returns a flag to determine whether rollover button borders are enabled.
isRolloverEnabled() - Method in class javax.swing.AbstractButton
Gets the rolloverEnabled property.
isRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Determines if the given file is a root in the navigatable tree(s).
isRoot() - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if this node is the root of the tree.
isRootPaneCheckingEnabled() - Method in class javax.swing.JApplet
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JDialog
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JFrame
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JInternalFrame
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JWindow
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootVisible() - Method in class javax.swing.JTree
Returns true if the root node of the tree is displayed.
isRootVisible() - Method in class javax.swing.plaf.basic.BasicTreeUI
isRootVisible() - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the root node of the tree is displayed.
isRowSelected(int) - Method in class javax.swing.JTable
Returns true if the specified index is in the valid range of rows, and the row at that index is selected.
isRowSelected(int) - Method in class javax.swing.JTree
Returns true if the node identified by row is selected.
isRowSelected(int) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the row identified by row is selected.
isRowSelected(int) - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the row identified by row is selected.
isRunning() - Method in interface javax.sound.midi.Sequencer
Indicates whether the Sequencer is currently running.
isRunning() - Method in interface javax.sound.sampled.DataLine
Indicates whether the line is running.
isRunning() - Method in class javax.swing.Timer
Returns true if the Timer is running.
isSameFile(Path, Path) - Static method in class java.nio.file.Files
Tests if two paths locate the same file.
isSameFile(Path, Path) - Method in class java.nio.file.spi.FileSystemProvider
Tests if two paths locate the same file.
isSameFile(FileObject, FileObject) - Method in class javax.tools.ForwardingJavaFileManager
isSameFile(FileObject, FileObject) - Method in interface javax.tools.JavaFileManager
Compares two file objects and return true if they represent the same underlying object.
isSameFile(FileObject, FileObject) - Method in interface javax.tools.StandardJavaFileManager
Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
isSameNode(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isSameNode(Node) - Method in interface org.w3c.dom.Node
Returns whether this node is the same node as the given one.
isSameRM(XAResource) - Method in interface javax.transaction.xa.XAResource
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
isSameType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether two TypeMirror objects represent the same type.
isSchemaLanguageSupported(String) - Method in class javax.xml.validation.SchemaFactory
Is specified schema supported by this SchemaFactory?
isSealed() - Method in class java.lang.软件包
Returns true if this package is sealed.
isSealed(URL) - Method in class java.lang.软件包
Returns true if this package is sealed with respect to the specified code source url.
isSearchable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column can be used in a where clause.
isSearchable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column can be used in a WHERE clause.
isSeekForwardOnly() - Method in class javax.imageio.ImageReader
Returns true if the current input source has been marked as seek forward only by passing true as the seekForwardOnly argument to the setInput method.
isSelected() - Method in class java.awt.im.InputMethodHighlight
Returns whether the text range is selected.
isSelected(int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by isIndexSelected(int).
isSelected() - Method in class javax.swing.AbstractButton
Returns the state of the button.
isSelected(ButtonModel) - Method in class javax.swing.ButtonGroup
Returns whether a ButtonModel is selected.
isSelected() - Method in interface javax.swing.ButtonModel
Indicates if the button has been selected.
isSelected() - Method in class javax.swing.DefaultButtonModel
Indicates if the button has been selected.
isSelected() - Method in class javax.swing.DefaultSingleSelectionModel
isSelected - Variable in class javax.swing.JInternalFrame
The frame is currently selected.
isSelected() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is the currently "selected" or active frame.
isSelected() - Method in class javax.swing.JMenu
Returns true if the menu is currently selected (highlighted).
isSelected() - Method in class javax.swing.JMenuBar
Returns true if the menu bar currently has a component selected.
isSelected() - Method in class javax.swing.JToggleButton.ToggleButtonModel
Checks if the button is selected.
isSelected - Variable in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
isSelected() - Method in interface javax.swing.SingleSelectionModel
Returns true if the selection model currently has a selected value.
isSelected() - Method in class javax.swing.text.html.Option
Fetches the selection state associated with this option.
isSelectedIndex(int) - Method in class javax.swing.DefaultListSelectionModel
Returns true if the specified index is selected.
isSelectedIndex(int) - Method in class javax.swing.JList
Returns true if the specified index is selected, else false.
isSelectedIndex(int) - Method in interface javax.swing.ListSelectionModel
Returns true if the specified index is selected.
isSelectionEmpty() - Method in class javax.swing.DefaultListSelectionModel
Returns true if no indices are selected.
isSelectionEmpty() - Method in class javax.swing.JList
Returns true if nothing is selected, else false.
isSelectionEmpty() - Method in class javax.swing.JTree
Returns true if the selection is currently empty.
isSelectionEmpty() - Method in interface javax.swing.ListSelectionModel
Returns true if no indices are selected.
isSelectionEmpty() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the selection is currently empty.
isSelectionEmpty() - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the selection is currently empty.
isSelectionVisible() - Method in interface javax.swing.text.Caret
Determines if the selection is currently visible.
isSelectionVisible() - Method in class javax.swing.text.DefaultCaret
Checks whether the current selection is visible.
isSerializing() - Method in class java.beans.beancontext.BeanContextSupport
Is this BeanContext in the process of being serialized?
isServiceClass(Class) - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent
Checks this event to determine whether or not the service being revoked is of a particular class.
isSet - Variable in class java.util.Calendar
The flags which tell if a specified calendar field for the calendar is set.
isSet(int) - Method in class java.util.Calendar
Determines if the given calendar field has a value set, including cases that the value has been set by internal fields calculations triggered by a get method call.
isSet(DatatypeConstants.Field) - Method in class javax.xml.datatype.Duration
Checks if a field is set.
isShared() - Method in class java.nio.channels.FileLock
Tells whether this lock is shared.
isShiftDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Shift modifier is down on this event.
isShorterThan(Duration) - Method in class javax.xml.datatype.Duration
Checks if this duration object is strictly shorter than another Duration object.
isShowing() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is showing.
isShowing() - Method in class java.awt.Component
Determines whether this component is showing on screen.
isShowing() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is showing.
isShowing() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is showing.
isShowing() - Method in class java.awt.Window
Checks if this Window is showing on screen.
isShowing() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is showing.
isShowing() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isShowing() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if the object is showing.
isShowing() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isShowing() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isShutdown() - Method in class java.nio.channels.AsynchronousChannelGroup
Tells whether or not this asynchronous channel group is shutdown.
isShutdown() - Method in interface java.util.concurrent.ExecutorService
Returns true if this executor has been shut down.
isShutdown() - Method in class java.util.concurrent.ForkJoinPool
Returns true if this pool has been shut down.
isShutdown() - Method in class java.util.concurrent.ThreadPoolExecutor
isSigned(int) - Method in interface java.sql.ParameterMetaData
Retrieves whether values for the designated parameter can be signed numbers.
isSigned(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether values in the designated column are signed numbers.
isSigned(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column is a signed number.
isSignificant() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
DefaultDocument events are significant.
isSignificant() - Method in class javax.swing.undo.AbstractUndoableEdit
This default implementation returns true.
isSignificant() - Method in class javax.swing.undo.CompoundEdit
Returns true if any of the UndoableEdits in edits do.
isSignificant() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit is considered significant.
isSingular() - Method in class java.awt.geom.Area
Tests whether this Area is comprised of a single closed subpath.
isSiteLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is a site local address.
isSiteLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is a site local address.
isSiteLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is a site local address.
isSortable(int) - Method in class javax.swing.DefaultRowSorter
Returns true if the specified column is sortable; otherwise, false.
isSorted() - Method in class javax.naming.ldap.SortResponseControl
Determines if the search results have been successfully sorted.
isSoundbankSupported(Soundbank) - Method in interface javax.sound.midi.Synthesizer
Informs the caller whether this synthesizer is capable of loading instruments from the specified soundbank.
isSource() - Method in class javax.sound.sampled.Port.Info
Indicates whether the port is a source or a target for its mixer.
isSourceEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion from the specified source format encoding.
isSpace(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isWhitespace(char).
isSpaceChar(char) - Static method in class java.lang.Character
Determines if the specified character is a Unicode space character.
isSpaceChar(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a Unicode space character.
isSpecified() - Method in interface javax.xml.stream.events.Attribute
A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
isSpecified(int) - Method in class javax.xml.validation.TypeInfoProvider
Returns false if the attribute was added by the validator.
isSpecified(int) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(String, String) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(String) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(int) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isSpecified(String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isSpecified(String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isStandalone() - Method in interface javax.xml.stream.events.StartDocument
Returns if this XML is standalone
isStandalone() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStandalone() - Method in interface javax.xml.stream.XMLStreamReader
Get the standalone declaration from the xml declaration
isStandard() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a standard glyph.
isStandardImageMetadataFormatSupported() - Method in class javax.imageio.spi.ImageReaderWriterSpi
Returns true if the standard metadata format is among the document formats recognized by the getAsTree and setFromTree methods on the image metadata objects produced or consumed by this plug-in.
isStandardMetadataFormatSupported() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if the standard metadata format is supported by getMetadataFormat, getAsTree, setFromTree, and mergeTree.
isStandardStreamMetadataFormatSupported() - Method in class javax.imageio.spi.ImageReaderWriterSpi
Returns true if the standard metadata format is among the document formats recognized by the getAsTree and setFromTree methods on the stream metadata objects produced or consumed by this plug-in.
isStartDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartDocument.
isStartElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartElement.
isStartElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStartElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a start tag (otherwise false)
isStatic(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the static modifier, false otherwise.
isStrict(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the strictfp modifier, false otherwise.
isStrikeThrough() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should have a strikethrough line.
isStrikeThrough() - Method in class javax.swing.text.LabelView
Determines if the glyphs should have a strikethrough line.
isStrikeThrough(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the strikethrough attribute is set.
isStringPainted() - Method in class javax.swing.JProgressBar
Returns the value of the stringPainted property.
isSubregion() - Method in class javax.swing.plaf.synth.Region
Returns true if the Region is a subregion of a Component, otherwise false.
isSubscript() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be rendered as superscript.
isSubscript() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be rendered as superscript.
isSubscript(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the subscript attribute is set.
isSubsignature(ExecutableType, ExecutableType) - Method in interface javax.lang.model.util.Types
Tests whether the signature of one method is a subsignature of another.
isSubtype(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type is a subtype of another.
isSuperscript() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be rendered as subscript.
isSuperscript() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be rendered as subscript.
isSuperscript(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the superscript attribute is set.
isSupplementaryCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is in the supplementary character range.
isSupported(Desktop.Action) - Method in class java.awt.Desktop
Tests whether an action is supported on the current platform.
isSupported() - Static method in class java.awt.SystemTray
Returns whether the system tray is supported on the current platform.
isSupported(String) - Static method in class java.nio.charset.Charset
Tells whether the named charset is supported.
isSupported(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode
Returns false since DOM features are not supported.
isSupported(String, String) - Method in interface org.w3c.dom.Node
Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
isSupportedLookAndFeel() - Method in class javax.swing.LookAndFeel
Return true if the underlying platform supports and or permits this look and feel.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Returns true; MetalLookAndFeel can be run on any platform.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.multi.MultiLookAndFeel
Returns true; every platform permits this look and feel.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Returns true, SynthLookAndFeel is always supported.
isSupportedOption(String) - Method in class javax.tools.ForwardingJavaFileManager
isSupportedOption(String) - Method in interface javax.tools.OptionChecker
Determines if the given option is supported and if so, the number of arguments the option takes.
isSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode surrogate code unit.
isSurrogatePair(char, char) - Static method in class java.lang.Character
Determines whether the specified pair of char values is a valid Unicode surrogate pair.
isSuspended() - Method in class java.lang.management.ThreadInfo
Tests if the thread associated with this ThreadInfo is suspended.
isSymbolicLink() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a symbolic link.
isSymbolicLink(Path) - Static method in class java.nio.file.Files
Tests whether a file is a symbolic link.
isSynchronizationSupported(Line[], boolean) - Method in interface javax.sound.sampled.Mixer
Reports whether this mixer supports synchronization of the specified set of lines.
isSynchronized(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the synchronized modifier, false otherwise.
isSynchronizerUsageSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports monitoring of ownable synchronizer usage.
isSynthetic() - Method in class java.lang.类
Returns true if this class is a synthetic class; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Constructor
Returns true if this constructor is a synthetic constructor; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.字段
Returns true if this field is a synthetic field; returns false otherwise.
isSynthetic() - Method in interface java.lang.reflect.Member
Returns true if this member was introduced by the compiler; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.方法
Returns true if this method is a synthetic method; returns false otherwise.
isSystem() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the system attribute.
isTargetEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to the specified target format encoding.
isTearOff() - Method in class java.awt.Menu
Indicates whether this menu is a tear-off menu.
isTearOff() - Method in class javax.swing.JMenu
Returns true if the menu can be torn off.
isTemporary() - Method in class java.awt.event.FocusEvent
Identifies the focus change event as temporary or permanent.
isTerminated() - Method in class java.nio.channels.AsynchronousChannelGroup
Tells whether or not this group has terminated.
isTerminated() - Method in interface java.util.concurrent.ExecutorService
Returns true if all tasks have completed following shut down.
isTerminated() - Method in class java.util.concurrent.ForkJoinPool
Returns true if all tasks have completed following shut down.
isTerminated() - Method in class java.util.concurrent.Phaser
Returns true if this phaser has been terminated.
isTerminated() - Method in class java.util.concurrent.ThreadPoolExecutor
isTerminating() - Method in class java.util.concurrent.ForkJoinPool
Returns true if the process of termination has commenced but not yet completed.
isTerminating() - Method in class java.util.concurrent.ThreadPoolExecutor
Returns true if this executor is in the process of terminating after ThreadPoolExecutor.shutdown() or ThreadPoolExecutor.shutdownNow() but has not completely terminated.
isText(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Returns true if the element is a text element.
isThreadContentionMonitoringEnabled() - Method in interface java.lang.management.ThreadMXBean
Tests if thread contention monitoring is enabled.
isThreadContentionMonitoringSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports thread contention monitoring.
isThreadCpuTimeEnabled() - Method in interface java.lang.management.ThreadMXBean
Tests if thread CPU time measurement is enabled.
isThreadCpuTimeSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine implementation supports CPU time measurement for any thread.
isThumbRollover() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
Returns true if the mouse is currently over the thumb.
isTileWritable(int, int) - Method in class java.awt.image.BufferedImage
Returns whether or not a tile is currently checked out for writing.
isTileWritable(int, int) - Method in interface java.awt.image.WritableRenderedImage
Returns whether a tile is currently checked out for writing.
isTimeSet - Variable in class java.util.Calendar
True if then the value of time is valid.
isTitleCase(char) - Static method in class java.lang.Character
Determines if the specified character is a titlecase character.
isTitleCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a titlecase character.
isToggleEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true indicates the row under the mouse should be toggled based on the event.
isToggleSelectionEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true signifies a mouse event on the node should toggle the selection of only the row under mouse.
isTopDown() - Method in class javax.imageio.plugins.bmp.BMPImageWriteParam
Returns the value of the topDown parameter.
isTopLevelMenu() - Method in class javax.swing.JMenu
Returns true if the menu is a 'top-level menu', that is, if it is the direct child of a menubar.
isTransferable() - Method in interface org.ietf.jgss.GSSContext
Determines if the context is transferable to other processes through the use of the export method.
isTransformed() - Method in class java.awt.font.FontRenderContext
Indicates whether or not this FontRenderContext object measures text in a transformed render context.
isTransformed() - Method in class java.awt.Font
Indicates whether or not this Font object has a transform that affects its size in addition to the Size attribute.
isTransient(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the transient modifier, false otherwise.
isTranslucencyCapable() - Method in class java.awt.GraphicsConfiguration
Returns whether this GraphicsConfiguration supports the PERPIXEL_TRANSLUCENT kind of translucency.
isTraversable(File) - Method in class javax.swing.filechooser.FileSystemView
Returns true if the file (directory) can be visited.
isTraversable(File) - Method in class javax.swing.filechooser.FileView
Whether the directory is traversable or not.
isTraversable(File) - Method in class javax.swing.JFileChooser
Returns true if the file (directory) can be visited.
IstringHelper - Class in org.omg.CosNaming
org/omg/CosNaming/IstringHelper.java .
IstringHelper() - Constructor for class org.omg.CosNaming.IstringHelper
isTrueVolatile() - Method in class java.awt.ImageCapabilities
Returns true if the VolatileImage described by this ImageCapabilities can lose its surfaces.
isTypeSubstituted() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
isUndecorated() - Method in class java.awt.Dialog
Indicates whether this dialog is undecorated.
isUndecorated() - Method in class java.awt.Frame
Indicates whether this frame is undecorated.
isUnderflow() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an underflow condition.
isUnderline() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be underlined.
isUnderline() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be underlined.
isUnderline(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the underline attribute is set.
isUnicast() - Method in class java.beans.EventSetDescriptor
Normally event sources are multicast.
isUnicodeIdentifierPart(char) - Static method in class java.lang.Character
Determines if the specified character may be part of a Unicode identifier as other than the first character.
isUnicodeIdentifierPart(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) may be part of a Unicode identifier as other than the first character.
isUnicodeIdentifierStart(char) - Static method in class java.lang.Character
Determines if the specified character is permissible as the first character in a Unicode identifier.
isUnicodeIdentifierStart(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is permissible as the first character in a Unicode identifier.
isUnique() - Static method in class java.rmi.dgc.VMID
Deprecated.
isUnmappable() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an unmappable-character error.
isUnnamed() - Method in interface javax.lang.model.element.PackageElement
Returns true is this is an unnamed package and false otherwise.
isUnresolved() - Method in class java.net.InetSocketAddress
Checks whether the address has been resolved or not.
isUnseqToken() - Method in class org.ietf.jgss.MessageProp
Tests if a later token had already been processed.
isUnshared() - Method in class java.io.ObjectStreamField
Returns boolean value indicating whether or not the serializable field represented by this ObjectStreamField instance is unshared.
isUp() - Method in class java.net.NetworkInterface
Returns whether a network interface is up and running.
isUpperCase(char) - Static method in class java.lang.Character
Determines if the specified character is an uppercase character.
isUpperCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is an uppercase character.
isUsageThresholdExceeded() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if the memory usage of this memory pool reaches or exceeds its usage threshold value.
isUsageThresholdSupported() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool supports usage threshold.
isUserInRole(String) - Method in class javax.xml.ws.spi.http.HttpExchange
Indicates whether an authenticated user is included in the specified logical "role".
isUserInRole(String) - Method in interface javax.xml.ws.WebServiceContext
Returns a boolean indicating whether the authenticated user is included in the specified logical role.
isUserNode() - Method in class java.util.prefs.AbstractPreferences
Implements the isUserNode method as per the specification in Preferences.isUserNode().
isUserNode() - Method in class java.util.prefs.Preferences
Returns true if this preference node is in the user preference tree, false if it's in the system preference tree.
isValid() - Method in class java.awt.Component
Determines whether this component is valid.
isValid(int) - Method in class java.awt.image.IndexColorModel
Returns whether or not the pixel is valid.
isValid() - Method in class java.awt.image.IndexColorModel
Returns whether or not all of the pixels are valid.
isValid() - Method in interface java.lang.management.MemoryManagerMXBean
Tests if this memory manager is valid in the Java virtual machine.
isValid() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool is valid in the Java virtual machine.
isValid() - Method in class java.nio.channels.FileLock
Tells whether or not this lock is valid.
isValid() - Method in class java.nio.channels.MembershipKey
Tells whether or not this membership is valid.
isValid() - Method in class java.nio.channels.SelectionKey
Tells whether or not this key is valid.
isValid() - Method in class java.nio.channels.spi.AbstractSelectionKey
isValid() - Method in interface java.nio.file.WatchKey
Tells whether or not this watch key is valid.
isValid(int) - Method in interface java.sql.Connection
Returns true if the connection has not been closed and is still valid.
isValid() - Method in class javax.accessibility.AccessibleHyperlink
Since the document a link is associated with may have changed, this method returns whether or not this Link is still valid (with respect to the document it references).
isValid() - Method in interface javax.management.Descriptor
Returns true if all of the fields have legal values given their names.
isValid() - Method in class javax.management.ImmutableDescriptor
Returns true if all of the fields have legal values given their names.
isValid() - Method in class javax.management.modelmbean.DescriptorSupport
Returns true if all of the fields have legal values given their names.
isValid() - Method in interface javax.net.ssl.SSLSession
Returns whether this session is valid and available for resuming or joining.
isValid() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
Since the document a link is associated with may have changed, this method returns whether this Link is valid anymore (with respect to the document it references).
isValid() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Returns true if the dragging session is valid.
isValid() - Method in class javax.swing.text.html.HTMLDocument.Iterator
Indicates if the iterator is currently representing an occurrence of a tag.
isValid() - Method in class javax.xml.datatype.XMLGregorianCalendar
Validate instance by getXMLSchemaType() constraints.
isValidateRoot() - Method in class java.applet.Applet
Indicates if this container is a validate root.
isValidateRoot() - Method in class java.awt.Container
Indicates if this container is a validate root.
isValidateRoot() - Method in class java.awt.Window
Indicates if this container is a validate root.
isValidateRoot() - Method in class javax.swing.JComponent
If this method returns true, revalidate calls by descendants of this component will cause the entire tree beginning with this root to be validated.
isValidateRoot() - Method in class javax.swing.JRootPane
If a descendant of this JRootPane calls revalidate, validate from here on down.
isValidateRoot() - Method in class javax.swing.JScrollPane
Overridden to return true so that any calls to revalidate on any descendants of this JScrollPane will cause the entire tree beginning with this JScrollPane to be validated.
isValidateRoot() - Method in class javax.swing.JSplitPane
Returns true, so that calls to revalidate on any descendant of this JSplitPane will cause a request to be queued that will validate the JSplitPane and all its descendants.
isValidateRoot() - Method in class javax.swing.JTextField
Calls to revalidate that come from within the textfield itself will be handled by validating the textfield, unless the textfield is contained within a JViewport, in which case this returns false.
isValidating() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
isValidating() - Method in interface javax.xml.bind.Unmarshaller
Deprecated.
since JAXB2.0, please see Unmarshaller.getSchema()
isValidating() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValidating() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValidCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified code point is a valid Unicode code point value.
isValue(Object) - Method in class javax.management.openmbean.ArrayType
Tests whether obj is a value for this ArrayType instance.
isValue(Object) - Method in class javax.management.openmbean.CompositeType
Tests whether obj is a value which could be described by this CompositeType instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
isValue(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenType
Tests whether obj is a value for this open type.
isValue(Object) - Method in class javax.management.openmbean.SimpleType
Tests whether obj is a value for this SimpleType instance.
isValue(Object) - Method in class javax.management.openmbean.TabularType
Tests whether obj is a value which could be described by this TabularType instance.
isVarArgs() - Method in class java.lang.reflect.Constructor
Returns true if this constructor was declared to take a variable number of arguments; returns false otherwise.
isVarArgs() - Method in class java.lang.reflect.方法
Returns true if this method was declared to take a variable number of arguments; returns false otherwise.
isVarArgs() - Method in interface javax.lang.model.element.ExecutableElement
Returns true if this method or constructor accepts a variable number of arguments and returns false otherwise.
isVarargsCollector() - Method in class java.lang.invoke.MethodHandle
Determines if this method handle supports variable arity calls.
isVerbose() - Method in interface java.lang.management.ClassLoadingMXBean
Tests if the verbose output for the class loading system is enabled.
isVerbose() - Method in interface java.lang.management.MemoryMXBean
Tests if verbose output for the memory system is enabled.
isVertical() - Method in class java.awt.font.TextLayout
Returns true if this TextLayout is vertical.
isViewSizeSet - Variable in class javax.swing.JViewport
True when the viewport dimensions have been determined.
isVirtual() - Method in class java.net.NetworkInterface
Returns whether this interface is a virtual interface (also called subinterface).
isVisible() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is visible.
isVisible() - Method in class java.awt.Component
Determines whether this component should be visible when its parent is visible.
isVisible() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is visible.
isVisible() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is visible.
isVisible() - Method in class java.awt.SplashScreen
Determines whether the splash screen is visible.
isVisible() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is visible.
isVisible() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isVisible() - Method in class javax.swing.JPopupMenu
Returns true if the popup menu is visible (currently being displayed).
isVisible() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if this object is visible.
isVisible() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isVisible(TreePath) - Method in class javax.swing.JTree
Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded.
isVisible() - Method in interface javax.swing.plaf.basic.ComboPopup
Returns true if the popup is visible (currently being displayed).
isVisible() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isVisible() - Method in interface javax.swing.text.Caret
Determines if the caret is currently visible.
isVisible() - Method in class javax.swing.text.DefaultCaret
Indicates whether or not the caret is currently visible.
isVisible() - Method in class javax.swing.text.html.ParagraphView
Indicates whether or not this view should be displayed.
isVisible() - Method in class javax.swing.text.View
Returns a boolean that indicates whether the view is visible or not.
isVolatile(int) - Static method in class java.lang.reflect.修饰符
Return true if the integer argument includes the volatile modifier, false otherwise.
isWeak(byte[], int) - Static method in class javax.crypto.spec.DESKeySpec
Checks if the given DES key material is weak or semi-weak.
isWeekDateSupported() - Method in class java.util.Calendar
Returns whether this Calendar supports week dates.
isWeekDateSupported() - Method in class java.util.GregorianCalendar
Returns true indicating this GregorianCalendar supports week dates.
isWheelScrollingEnabled() - Method in class java.awt.ScrollPane
Indicates whether or not scrolling will take place in response to the mouse wheel.
isWheelScrollingEnabled() - Method in class javax.swing.JScrollPane
Indicates whether or not scrolling will take place in response to the mouse wheel.
isWhitespace() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a whitespace glyph.
isWhitespace(char) - Static method in class java.lang.Character
Determines if the specified character is white space according to Java.
isWhitespace(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is white space according to Java.
isWhiteSpace(char) - Static method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
returns true if the specified char is a white space character.
isWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Returns true if this set of Characters is all whitespace.
isWhiteSpace() - Method in class javax.xml.stream.util.StreamReaderDelegate
isWhiteSpace() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event that consists of all whitespace
isWhiteSpaceExceptSpace(char) - Static method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
Returns true if the specified char is a white space character but not 0x20.
isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) - Method in class java.awt.GraphicsDevice
Returns whether the given level of translucency is supported by this graphics device.
isWrapperFor(Class<?>) - Method in interface java.sql.Wrapper
Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does.
isWrapperFor(Class<?>) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does.
isWrapperInstance(Object) - Static method in class java.lang.invoke.MethodHandles
Determines if the given object was produced by a call to asInstance.
isWritable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready for writing.
isWritable(Path) - Static method in class java.nio.file.Files
Tests whether a file is writable.
isWritable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether it is possible for a write on the designated column to succeed.
isWritable() - Method in class javax.management.MBeanAttributeInfo
Whether new values can be written to the attribute.
isWritable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
isWritable() - Method in class javax.management.relation.RoleInfo
Returns write access mode for the role (true if it is writable).
isWritable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether it is possible for a write operation on the designated column to succeed.
isWriteLocked() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries if the write lock is held by any thread.
isWriteLockedByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries if the write lock is held by the current thread.
isXIncludeAware() - Method in class javax.xml.parsers.DocumentBuilder
Get the XInclude processing mode for this parser.
isXIncludeAware() - Method in class javax.xml.parsers.DocumentBuilderFactory
Get state of XInclude processing.
isXIncludeAware() - Method in class javax.xml.parsers.SAXParser
Get the XInclude processing mode for this parser.
isXIncludeAware() - Method in class javax.xml.parsers.SAXParserFactory
Get state of XInclude processing.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Read-only property that returns true if JAXB marshaller should enable XOP creation.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller
Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.
isZoneLoaded(View) - Method in class javax.swing.text.ZoneView
Determine if a zone is in the loaded state.
ITALIAN - Static variable in class java.util.Locale
Useful constant for language.
ITALIC - Static variable in class java.awt.Font
The italicized style constant.
Italic - Static variable in class javax.swing.text.StyleConstants
Name of the italic attribute.
ITALIC_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The italic action identifier
ITALY - Static variable in class java.awt.PageAttributes.MediaType
An alias for ITALY_ENVELOPE.
ITALY - Static variable in class java.util.Locale
Useful constant for country.
ITALY_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Italy Envelope, 110 x 230 mm.
ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Italy envelope size, 110 mm by 230 mm.
ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
Italy envelope size .
item(int) - Method in class javax.imageio.metadata.IIOMetadataNode
item(int) - Method in class org.omg.CORBA.ContextList
Returns the String object at the given index.
item(int) - Method in class org.omg.CORBA.ExceptionList
Returns the TypeCode object at the given index.
item(int) - Method in class org.omg.CORBA.NVList
Retrieves the NamedValue object at the given index.
item(int) - Method in interface org.w3c.dom.DOMImplementationList
Returns the indexth item in the collection.
item(int) - Method in interface org.w3c.dom.DOMStringList
Returns the indexth item in the collection.
item(int) - Method in interface org.w3c.dom.NamedNodeMap
Returns the indexth item in the map.
item(int) - Method in interface org.w3c.dom.NodeList
Returns the indexth item in the collection.
ITEM_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting item events.
ITEM_FIRST - Static variable in class java.awt.event.ItemEvent
The first number in the range of ids used for item events.
ITEM_LAST - Static variable in class java.awt.event.ItemEvent
The last number in the range of ids used for item events.
ITEM_STATE_CHANGED - Static variable in class java.awt.event.ItemEvent
This event id indicates that an item's state changed.
ItemEvent - Class in java.awt.event
A semantic event which indicates that an item was selected or deselected.
ItemEvent(ItemSelectable, int, Object, int) - Constructor for class java.awt.event.ItemEvent
Constructs an ItemEvent object.
ItemListener - Interface in java.awt.event
The listener interface for receiving item events.
itemListener - Variable in class javax.swing.AbstractButton
The button model's ItemListener.
itemListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
itemListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
ItemSelectable - Interface in java.awt
The interface for objects which contain a set of items for which zero or more can be selected.
itemStateChanged(ItemEvent) - Method in class java.awt.AWTEventMulticaster
Handles the itemStateChanged event by invoking the itemStateChanged methods on listener-a and listener-b.
itemStateChanged(ItemEvent) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox
Fire accessible property change events when the state of the toggle button changes.
itemStateChanged(ItemEvent) - Method in interface java.awt.event.ItemListener
Invoked when an item has been selected or deselected by the user.
itemStateChanged(ItemEvent) - Method in class java.awt.List.AccessibleAWTList
itemStateChanged(ItemEvent) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
When an item's state changes, editing is ended.
itemStateChanged(ItemEvent) - Method in class javax.swing.JToggleButton.AccessibleJToggleButton
Fire accessible property change events when the state of the toggle button changes.
itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ItemHandler
Iterable<T> - Interface in java.lang
Implementing this interface allows an object to be the target of the "foreach" statement.
iterator() - Method in class java.awt.dnd.DragGestureEvent
Returns an Iterator for the events comprising the gesture.
iterator() - Method in class java.beans.beancontext.BeanContextMembershipEvent
Gets the array of children affected by this event.
iterator() - Method in class java.beans.beancontext.BeanContextSupport
Gets all JavaBean or BeanContext instances currently nested in this BeanContext.
iterator() - Method in interface java.lang.Iterable
Returns an iterator over a set of elements of type T.
iterator() - Method in interface java.nio.file.DirectoryStream
Returns the iterator associated with this DirectoryStream.
iterator() - Method in interface java.nio.file.Path
Returns an iterator over the name elements of this path.
iterator() - Method in exception java.sql.SQLException
Returns an iterator over the chained SQLExceptions.
iterator() - Method in class java.util.AbstractCollection
Returns an iterator over the elements contained in this collection.
iterator() - Method in class java.util.AbstractList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in class java.util.AbstractSequentialList
Returns an iterator over the elements in this list (in proper sequence).
iterator() - Method in class java.util.ArrayDeque
Returns an iterator over the elements in this deque.
iterator() - Method in class java.util.ArrayList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in interface java.util.Collection
Returns an iterator over the elements in this collection.
iterator() - Method in class java.util.concurrent.ArrayBlockingQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in interface java.util.concurrent.BlockingDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns an iterator over the elements in this set in ascending order.
iterator() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns an iterator over the elements contained in this set in the order in which these elements were added.
iterator() - Method in class java.util.concurrent.DelayQueue
Returns an iterator over all the elements (both expired and unexpired) in this queue.
iterator() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.LinkedBlockingQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.LinkedTransferQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.PriorityBlockingQueue
Returns an iterator over the elements in this queue.
iterator() - Method in class java.util.concurrent.SynchronousQueue
Returns an empty iterator in which hasNext always returns false.
iterator() - Method in interface java.util.Deque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.HashSet
Returns an iterator over the elements in this set.
Iterator<E> - Interface in java.util
An iterator over a collection.
iterator() - Method in interface java.util.List
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in interface java.util.NavigableSet
Returns an iterator over the elements in this set, in ascending order.
iterator() - Method in class java.util.PriorityQueue
Returns an iterator over the elements in this queue.
iterator() - Method in class java.util.ServiceLoader
Lazily loads the available providers of this loader's service.
iterator() - Method in interface java.util.Set
Returns an iterator over the elements in this set.
iterator() - Method in class java.util.TreeSet
Returns an iterator over the elements in this set in ascending order.
iterator() - Method in class java.util.Vector
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in class javax.xml.crypto.dom.DOMCryptoContext
Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext.
iterator() - Method in interface javax.xml.crypto.NodeSetData
Returns a read-only iterator over the nodes contained in this NodeSetData in document order.
IvParameterSpec - Class in javax.crypto.spec
This class specifies an initialization vector (IV).
IvParameterSpec(byte[]) - Constructor for class javax.crypto.spec.IvParameterSpec
Creates an IvParameterSpec object using the bytes in iv as the IV.
IvParameterSpec(byte[], int, int) - Constructor for class javax.crypto.spec.IvParameterSpec
Creates an IvParameterSpec object using the first len bytes in iv, beginning at offset inclusive, as the IV.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
  • 概述
  • 软件包
  • 类
  • 使用
  • 树
  • 已过时
  • Index
  • 帮助
Java™ Platform
Standard Ed. 7
草案 ea-b138
  • Prev Letter
  • Next Letter
  • 框架
  • 无框架
  • 所有的类